Startseite

Startseite

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Handbuch

Treiber

Tutorials

Glossar

© 2012 Ing. Punzenberger COPA-DATA GmbH


Handbuch

Handbuch

In diesem Bereich finden Sie die zenon Produktdokumentation.

Noch in diesem Kapitel

Roter Faden durch die Hilfe - Ein Überblick

zenon Produktfamilie

Effizient projektieren mit zenon

Alarmverwaltung

Änderungshistorie

Anlagenmodellierung

Archivserver

Automatic Line Coloring (ALC) - Topologie

Batch Control

Benutzerverwaltung

Bilder

Chronologische Ereignisliste (CEL)

Controls

Dateiaufbau

Diagnose Viewer

Editor

Energy Edition

Energy Management System (EMS)

Erweiterter Trend

Funktionen

Import - Export

Industrial Maintenance Manager (IMM)

Industrial Performance Analyzer

Installation und Updates

Keyblock Runtime Start

Keyboard

Lizenzierung

Maßeinheitenumschaltung

Menüs

Message Control

Monitorverwaltung

Multitouch

Netzwerk

OPC-Server

PLC Diagnosis

Process Gateway

Production and Facility Scheduler (PFS)

Programmierschnittstellen

Projektsicherung

Projektkonvertierung

Projektsimulation

Projektverwaltung und Arbeitsbereich

Querverweise

Remote Desktop

Remote-Transport

Reporting

Standard-Rezepte

Rezeptgruppen-Manager

Runtime

Runtime-Hilfe

SAP Interface

Scheduler

Skripte

Sprachumschaltung

Startup Tool

Statusverarbeitung

Treibersimulation

Variablen

Verriegelungen

Verteiltes Engineering

Weltbild

Wizards

Zeitsteuerung

zenon Logic

zenon Demo-Projekt

zenon Operator

zenon Science Package for Lego MINDSTORMS 2.0

zenon Webserver und zenon Webserver Pro

Zuweisungen


Roter Faden durch die Hilfe - Ein Überblick

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick

Je mächtiger das Leitsystem, desto umfangreicher ist auch die dazugehörige Hilfe.

Im Unterschied zu allen anderen Kapiteln, in denen Features und Funktionalitäten erklärt werden, dient dieses Kapitel dazu, Ihnen den Umgang mit unserer Hilfe zu erleichtern.

Noch in diesem Kapitel

Welche Hilfekapitel für den Anfang

Wegweiser durch die Hilfe

Funktionalitäten Onlinehilfe - So findet man, was man sucht


Welche Hilfekapitel für den Anfang

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

info Info

Dieses Kapitel ist für all jene gedacht, die zenon das erste Mal benutzen und vor dem Problem stehen, welche Hilfe-Thematik für den Anfang hilfreich sein könnte. Hier wird auf die Schritte eingegangen, die für ein einfaches Basis Projekt erforderlich sind. Die passenden Informationen aus Tutorial und Handbuch sind mit den jeweiligen Schritten verknüpft.

Noch in diesem Kapitel

Der Editor

Anlegen eines Projektes

Bilder und Schablonen

Treiber und Variablen

Funktionen

Starten der Runtime

Weitere Möglichkeiten


Der Editor

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang -> Der Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon:

zenon besteht aus zwei Teilen:

1. Editor
(Bediensystem): Hier werden die Projekte erstellt.

2. Runtime
(Laufzeit): Dort kann die projektierte Anlage beobachtet und bedient werden.

Aufbau des Editors:

Die Benutzeroberfläche des Editors gliedert sich in verschiedene Bereiche:

Element

Inhalt

01 - Symbolleisten:

Sammlung der Symbolleisten für den Editor und seine Module. Sie stehen zur Verfügung für:

  • Andockbare Fenster
  • Ausrichtung
  • Bilder / Symbole
  • Editorprofile
  • Elemente
  • Menüleiste
  • Production & Facility Scheduler
  • Remote Transport
  • Report Generator
  • Runtime Dateien
  • Sichtbarkeitsebenen
  • VBA-Makros

02 - Projektmanager:

Baumansicht des Projektmanagers.

03 - Detailansicht des Projektmanagers:

Details zum im Projektmanager ausgewählten Modul.

04 - Hauptfenster:

Hauptarbeitsbereich, hier werden Dokumente wie Bilder oder Reporte dargestellt.

05 - Symbolleiste Elemente:

Symbolleiste für die Elemente der Bilder - Vektorelemente und Dynamische Elemente.

06 - Eigenschaften

Zeigt Eigenschaften des ausgewählten Objekts an. Dafür stehen drei Modi zur Verfügung, die in der Symbolleiste der Eigenschaften ausgewählt werden.

07 - Eigenschaftenhilfe:

Zeigt kurze Hilfeeinträge zu Eigenschaften von Bildern, Variablen, Funktionen und anderen Elementen, die parametriert werden, an.

08 - Ausgabefenster

Anzeige von Meldungen, wenn Projekte kompiliert und zur Runtime abgesetzt werden.

09 - Statusleiste:

Zeigt Statusinformationen zur Editorbereitschaft und für Bilder an.

10 - Symbolleiste Eigenschaften:

Definiert Anzeige und Sortierung der Eigenschaften, blendet Eigenschaftenhilfe ein.

11 - Querverweisliste:

Welche Fenster angezeigt werden, wählen Sie aus:

  • in der Dropdownliste unter Optionen

Die Anordnung der Fenster lässt sich individuell anpassen. Nur das Hauptfenster kann nicht ausgeblendet werden.

Der nächste Schritt:

Um mehr über das Anlegen eines Projektes zu erfahren, klicken Sie auf den Link in der Box.

seealso Siehe auch

Anlegen eines Projektes


Anlegen eines Projektes

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang -> Anlegen eines Projektes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Anlegen des Arbeitsbereiches:

Der Arbeitsbereich bildet die Basis für ein oder mehrere Projekte.
Wie ein neuer Arbeitsbereich angelegt wird erfahren Sie im Tutorial Basis.

Anlegen eines Projektes:

Dann wird im Arbeitsbereich ein neues Projekt angelegt. Ein Projekt ist eine in sich abgeschlossene und für sich lauffähige Einheit aus Projektierungselementen (z.B. Bildern, Variablen, Funktionen etc.).
Informationen zur Vorgehensweise beim Anlegen eines Projektes finden Sie im Tutorial Basis.

info Info

Sie sind nun in der Lage ein Projekt anzulegen.

Der nächste Schritt:

Ihr Projekt soll nun durch Bilder erweitert werden? Klicken Sie auf den Link in der Box.

seealso Siehe auch

Bilder und Schablonen


Bilder und Schablonen

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang -> Bilder und Schablonen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Anlegen einer Schablone:

Schablonen legen den Bildschirmbereich fest, in dem die Bilder später aufgeschalten werden. Jedes Bild basiert auf einer Schablone.
Nähere Informationen zum Anlegen der Schablonen finden Sie auch im Tutorial Basis und im Kapitel Schablonen.

Anlegen eines Bildes:

zenon bietet verschiedenste vordefinierte Bildtypen, so auch den einfachsten 'Standard' in dem der Bildschirmbereich frei definiert werden kann. Bei den optischen Anpassungen des Bildes, sind Ihnen kaum Grenzen gesetzt.
Um nun die Anlage im Bild schematisch darstellen zu können, wählen Sie einfach aus den vordefinierten Bildelementen.

Erweitern des Bildes durch Bildelemente:

zenon bietet vordefinierte Vektor- und Dynamische Bildelemente an, die mit Funktionen bzw. Variablen verknüpft werden können.
Nähere Informationen zu den Bildelementen finden Sie im Tutorial Basis, die verschiedenen Formen der vordefinierten Bildelemente sind im Kapitel Bildelemente ausführlich beschrieben.
Eine weitere Möglichkeit der Zeitersparnis beim Projektieren bieten unsere vordefinierten Symbole, die Sie in der Symbolbibliothek sehen. Nähere Informationen hierzu finden Sie im Kapitel Symbole.

info Info

Sie können nun ein neues Projekt mit Bildern und Bildelementen erstellen.

Der nächste Schritt:

Ihre Bildelemente sollen "echte" Werte anzeigen und Ihre Anlage soll via zenon beobachtbar sein? Klicken Sie auf den Link in der Box.

seealso Siehe auch

Treiber und Variablen


Treiber und Variablen

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang -> Treiber und Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auswahl eines Treibers

Variablen basieren auf dem zugeordneten Treiber, weshalb zuvor ein Treiber ausgewählt wird. Beim Projektieren wird meist auf einen der im Lieferumfang standardmäßig enthaltenen Simulationstreiber zurückgegriffen. Dieser kann anschließen durch den zur jeweiligen SPS passenden Treiber ausgetauscht werden. Als offenes und unabhängiges System unterstützt zenon mehr als 250 Treiber, die Informationen zu den unterschiedlichen Treibern entnehmen Sie bitte der entsprechenden Treiberdokumentaion. Diese finden Sie online unter dem Register Treiber oder aber als pdf-Datei zum Ausdrucken auf unserer CD/DVD.

Anlegen einer Variable

Variablen sind die Schnittstelle zu den Prozessdaten und repräsentieren bestimmte Messwerte oder Zustände. Um auf kritische Prozessereignisse in Ihrer Anlage aufmerksam zu machen, können den Variablen Grenzwerte zugeordnet werden.
Die konkrete Vorgehensweise beim Anlegen einer Variable finden Sie im Tutorial Basis. Eine umfangreiche Beschreibung von Variablen, Datentypen und Reaktionsmatrizen bietet das Kapitel Variablendefinition und Prozessdatenmodell.

Darstellen der Werte im Bildelement

Um die 'eingehenden' Werte darzustellen, können die angelegten Bildelemente mit den Variablen verknüpft werden.
Nähere Informationen zu dem Verknüpfen einer Variable mit einem dynamischen Bildelement finden Sie auch im Tutorial Basis. Das Kapitel Bildelemente enthält eine Verlinkung zu den Dynamischen - und Vektor Bildelementen von zenon.

info Info

Sie haben nun einen Einblick bekommen, wie Variablen und Treiber benutzt werden können.

Der nächste Schritt

Sie wollen nicht nur Beobachten sondern auch Bedienen? Um in zenon eingreifen zu können, müssen Funktionen angelegt und verknüpft werden.

seealso Siehe auch

Funktionen


Funktionen

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Anlegen einer Funktion:

Funktionen sind die Grundlage dafür, dass während der Runtime eine Bedienung der Anlage möglich ist. z.B. kann zwischen einzelnen Anlagenbildern hin- und her geschaltet werden oder es können Wertänderungen vorgenommen werden.
Mehrere Funktionen können in Skripten zusammengefasst und verwaltet werden. Nähere Informationen dazu finden Sie auch im Kapitel Skript Verwaltung.

Verknüpfen der Funktion mit einem dynamischen Bildelement:

Nähere Informationen finden Sie im Tutorial Basis. Da zenon eine Fülle der unterschiedlichsten Funktionen anbietet, sind diese im Kapitel Übersicht Funktionen aufgelistet und kurz beschrieben. Des weiteren finden Sie im Dialog Funktion neu eine kurze Erklärung zu den einzelnen Funktionen.

info Info

Sie sind nun in der Lage ein einfaches Projekt anzulegen. Sie können ein Bild erstellen, Bildelemente mit Variablen und Funktionen verknüpfen, und bereits Grenzwertverletzung darstellen.

Der nächste Schritt:

Zeit zu sehen, was projektiert wurde? Klicken Sie auf den Link in der Box.

seealso Siehe auch

Starten der Runtime


Starten der Runtime

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang -> Starten der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vom Editor in die Runtime

Was im Editor projektiert wurde, können Sie jetzt in der Runtime beobachten und bedienen. Wir verlassen also das Bediensystem (Editor) und wechseln in die Laufzeit (Runtime).
Näher Informationen zum Starten der Runtime erhalten Sie im Tutorial Basis und im Kapitel Runtime.

info Info

Dem Projektieren sowie anschließendem Bedienen und Beobachten Ihrer Anlage steht nichts mehr im Wege.

Mehr?

Das war natürlich nur ein winziger Einblick in die Möglichkeiten, die Ihnen zenon bietet. Sie wollen mehr wissen und mehr lernen? Klicken Sie auf den Link in der Box.

seealso Siehe auch

Weitere Möglichkeiten


Weitere Möglichkeiten

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Welche Hilfekapitel für den Anfang -> Weitere Möglichkeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier finden Sie eine Vielzahl an Möglichkeiten, die sie mit zenon umsetzen können:

Sie wollen ... | Kein Problem!
Auf kritische Prozessereignisse (Grenzwertverletzungen) aufmerksam zu machen? | Alarm Verwaltung
Alarme auswerten | Industrial Performance Analyzer
Prozess- und Systemereignisse mitprotokollieren? | Chronologische Ereignisliste
Änderungen am Projekt mitprotokollieren? | Änderungshistorie
Prozessdaten erfassen und verdichten? | Archiv Server
Leitungen einfärben und dynamisieren | Automatic Line Coloring
Eine FDA-konforme Benutzerverwaltung (Passwortsystem) erstellen? | Benutzer Verwaltung
Log Files auswerten? | Diagnose Viewer
Werte aus dem Prozess als Kurve darstellen? | Erweiterter Trend
Wartungsdaten von Maschinen verwalten? | Industrial Maintenance Manager
Nachrichten versenden? | Message Control
Ein Client/Server Netzwerk erstellen? | Netzwerk
Entwicklungsumgebung | Editor
Projektteile im- bzw. exportieren? | Import/Export
Aktionen zu einer definierten Zeit ausführen? | Production und Facility Scheduler
Reports erstellen? | Report Generator
Vorgabelisten für Sollwerte und Befehle erstellen? | Rezepte
Eine Funktionsabfolge definieren? | Skript Verwaltung
Funktionen zu einem definierten Zeitpunkt aufrufen? | Zeitsteuerung
In der Runtime dargestellte Textinformationen in verschiedene Sprachen umzuschalten | Sprachumschaltung
Den Zugriff auf bestimmte zenon Objekte während der Runtime mit Hilfe von Variablen steuern? | Verriegelungen
Zyklische Abfolgen selbst programmieren? | Process Control Engine
Die Integration mit zenon Logic kennenlernen? | zenon LogicWorkbench
Mit der ERP-Ebene Daten austauschen? | SAP Interface


Wegweiser durch die Hilfe

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Wegweiser durch die Hilfe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

info Info

Hier finden Sie eine Gesamt-Übersicht über die Kapitel des Online-Handbuches und gleichzeitig eine kurze Einführung in die Terminologie von zenon.

Parameter | Beschreibung
Alarm Verwaltung | Kritische Prozessereignisse Die Alarmierung hat im Gesamtsystem die Aufgabe, auf kritische Prozessereignisse aufmerksam zu machen und den Benutzer bei deren Lokalisierung und Behebung zu unterstützen.
Änderungs-Historie | Dokumentation der Projektierung, Audit Trail Die Änderungshistorie dient der lückenlosen Dokumentation der Projektierung. Es können die Änderungen (z.B. ändern, löschen, erzeugen) die in einem Projekt gemacht werden, mitprotokolliert werden.
Archiv Server | Erfassung von Prozessdaten Das Modul Archivserver dient der Erfassung und freien mehrstufigen Verdichtung (Mittelwert, Summe, Maximum und/oder Minimum) der Prozessdaten, verbunden mit einer systemkonformen, flexiblen und bedienerfreundlichen Editierebene.
Automatic Line Coloring | Topologische Einfärbung von Leitungen Die automatische Linienfärbung dient zur einfachen automatischen Dynamisierung von Leitungen in der Verfahrenstechnik (für Medien) sowie in der elektrischen Energieverteilung (für Strom).
Benutzer Verwaltung | Passwortsystem zenonsieht sowohl für den Editor (Kapitel Projekt) als auch für den Onlinebetrieb (Runtime) eine Benutzerverwaltung vor. Es hält mit seinem Passwortsystem die laut FDA (Food and Drug Administration, 21 CFR Part 11) vorgegebenen Richtlinien ein.
Bilderstellung | Hauptbestandteil eines Projektes sind Bilder, die dem Bediener einen möglichst umfassenden Informationsstand über die zu bedienende Anlage geben sollen.
Chronologische Ereignisliste | Betriebstagebuch, Audit Trail Alle Prozess- und Systemereignisse sowie Benutzervorgaben können in der chronologischen Ereignisliste CEL protokolliert werden.
Dateiaufbau | Informationen für Systemadministratoren, die direkt in die ini-Dateien eingreifen wollen. Systemdateien, zenon6.ini, project.ini, nbflist.ini, Variablendatei, dBase-Importdatei
Dynamische Bildelemente / Vektor Bildelemente | Vektor und Dynamische Elemente zenon bietet zwei Arten von Bildelementen an: Vektor- und Dynamische Bildelemente. Sämtliche Elemente können dynamisisert werden.
Editor | Projektierungsumgebung Das Leistsystem unterteilt sich in Editor und Runtime. Die Projektierungsumgebung, der Editor und die Onlinedarstellung, die Runtime. Projekte werden im Editor erstellt, das Bedienen und Beobachten erfolgt in der Runtime. Detaillierte Beschreibung der zenon Projektierungsumgebung, dem Editor.
Erweiterter Trend | Kurvendarstellung von Werten Der Erweiterte Trend dient zur Darstellung der Online (HD-Verwaltung) und historischer Werte (Archivwerte) von Prozess- und abgeleiteten Prozessvariablen.
Funktionen | Vordefinierte Makros die vom Projektanten einfach benutzt und parametriert werden können und den Eingriffen in zenon dienen Die Eingriffe der Benutzer in zenon werden über benutzerdefinierte Projektfunktionen realisiert. Alle in einem Projekt verwendeten Funktionen basieren auf den vorhandenen Systemfunktionen.
HTML | Darstellung als HTML Seiten Die Verwendung eines Bildes für die Darstellung von HTML-Seiten bietet alle Möglichkeiten des Microsoft Internet-Explorers.
Import/Export | Teile eines Projekts lassen sich in zenon importieren bzw. aus zenon exportieren. Das Format der Export-Dateien ist *.XML.
Industrial Maintenance Manager | Verwaltung der Wartungsdaten Der Industrial Maintenance Manager dient zur Pflege von Maschinen- und Wartungsdaten. Serviceintervalle können bequem geplant und verwaltet werden. Auf einen Blick ist feststellbar, welche Geräte, Anlagen, Maschinen usw. heute/in dieser Woche/nächstes Monat usw. gewartet werden müssen. Ebenso wird mitprotokolliert, welche Wartungsarbeiten in der Vergangenheit durchgeführt worden sind.
Industrial Performance Analyzer | Alarmauswertung Der Industrial Performance Analyzer dient dazu, Schwachstellen (Stillstandszeiten) einer Anlage zu lokalisieren und minimieren.
Keyboard | Virtuelle Tastatur Mit der Verwendung eines Bildes Keyboard lässt sich eine frei definierbare virtuelle Tastatur erzeugen.
Liste | Protokolle und Textdateien Das Listenfenster dient zur Ausgabe von Protokollen und Textdateien, die aus Datenbankabfragen erstellt werden bzw. als Textdateien vorhanden sind.
Menü Verwaltung | Der Menü-Editor erlaubt das Erstellen Windows-konformer Menüs.
Message Control |  | Versand von Nachrichten per SMS, Voice Message oder als E-mail Die Aufgabe dieses Moduls ist der Versand von Nachrichten an unterschiedliche Empfänger.
Monitor Verwaltung | Mehrmonitorsystem Durch die zenon Monitorverwaltung ist arbeitsplatzspezifisch definierbar, ob das Zielsystem des Projektes mit einem oder mehreren Monitoren ausgestattet ist.
Netzwerk | Client/Server Modell Das Prozessleitsystem realisiert in einer Netzwerkumgebung das so genannte Client/Server Modell oder ein multihierarchisches System mit Unterstationen, Bereichszentralen und Zentralen.
OPC-Server | Der OPC Server stellt die im Projekt verwendeten Variablen allen handelsüblichen OPC Client Tools zur Verfügung.
PLC Diagnosis | Mit der PLC-Diagnosis können Programmdetails einer Steuerung direkt in der Visualisierung in einem Bild angezeigt werden. Je nach Steuerung stehen unterschiedliche Funktionalitäten zur Verfügung. Derzeit existieren die Simatic S7-Graph Schrittkettenanlayse zur Darstellung von Schrittketteninformationen von S7 Steuerungen und der zenon Logic Monitoring Viewer zur Darstellung von allen Programmen die in der zenon Logic Runtime abgearbeitet werden.
Process Control Engine | Programmierung zyklischer Abfolgen Die Process Control Engine (PCE) bietet die Möglichkeit zyklische Abläufe in VB Script oder Java Script zu programmieren (übergesetzte Leitfunktionen). Die PCE eignet sich besonders für lange andauernde Funktionen, die im Hintergrund ablaufen (z.B. aufwändige Export-Funktionen). Im Gegensatz zu VBA unterstützt die PCE Multithreading.
Process Gateway | Das Process Gateway dient zur Kopplung mit übergeordnete Systeme. Teile des zenon Prozessabbildes anderen Anwendungen können zur Verfügung gestellt und aktualisiert werden.
Production und Facility Scheduler | Fahrplan, Zeitschaltuhr Der Production and Facility Scheduler PFS ermöglicht das Ausführen von Aktionen (z.B. Ändern des Sollwertes einer Variablen, Ausführung einer Funktion) an einen Zeitraum gekoppelt oder nach einem zeitlichen Muster.
Projekt Verwaltung | Information über Projekterstellung, Projektverwaltung Projekte sichern, rücklesen, Globalprojekte, Konfiguration, Remote Transport
Prozessdatenmodell und Variablendefinition | Variablen sind die Schnittstelle zwischen der Datenquelle (SPS, Feldbus etc.) und zenon. Variablen, Datentypen, Treiber, Reaktionsmatrizen
Querverweisliste | Projektübersicht Mittels Querverweisliste kann eine Projektübersicht in Tabellenform generiert werden. Die Querverweisliste gibt z.B. Aufschluss darüber, welche Variablen in welchen Bildern verwendet werden.
Report Generator | Der Report Generator dient der Erstellung von Reports auf Basis von Online- und Archivdaten.
Rezepte | Vorgabelisten für Sollwerte und Befehle Rezepte dienen der Zusammenstellung von Vorgabelisten für Sollwerte und Befehle, die im Onlinebetrieb mit einem Funktionsaufruf ausgeführt werden.
Rezeptgruppen Manager | Zusätzlich zu den Standard Rezepturen bietet der Rezeptgruppen Manager weitere Möglichkeiten, wie z.B. freie Layouterstellung, freie Gruppeneinteilung.
Runtime | Onlinebedienung, Laufzeit Das Leistsystem unterteilt sich in Editor und Runtime. Die Projektierungsumgebung, der Editor und die Onlinedarstellung, die Runtime. Projekte werden im Editor erstellt, das Bedienen und Beobachten erfolgt in der Runtime. Bedienungsmöglichkeiten in der Laufzeit Runtime
Runtime-Hilfe | zenon bietet die Möglichkeit für laufende Projekte in der Runtime eine kontextsensitive Hilfe zu erstellen.
Scheduler | Aktionsausführung nach Zeit Der Scheduler wird geladen, wenn das PFS Modul nicht lizenziert wird. Seine Funktion ist dem des PFS ähnlich, jedoch weniger umfangreich. Der Scheduler dient zur Ausführung von Aktionen zu einer festgelegten Zeit.
Schriften | Schriften, die im Betriebssystem vorhanden sind, können in zenon genutzt werden.
Skript Verwaltung | Funktionsabfolge Sollen mehrere benutzerdefinierte Funktionen zu einer Abfolge verbunden werden, müssen sie zu einem Skript zusammengefasst werden.
Sprachumschaltung | Die Sprachumschaltungs-Funktion ermöglicht, im Onlinebetrieb dargestellte Textinformationen in verschiedene Sprachen umzuschalten. Bei der Umsetzung internationaler Projekte ist die Umschaltbarkeit der Sprache unerlässlich.
Statusverarbeitung | Attribute für Variablen Mit der Statusverwaltung ist es möglich jeder Variable eigene Attribute zu geben. Insgesamt sind 32 Stati / Attribute definiert. Die gebräuchlichsten sind spontan, gestört, Handwert und Ersatzwert.
zenon Logic Runtime | Die zenon Logic Runtime interpretiert den kompilierten Code (SPS-Code) der zenon Logic Workbench. Die Runtime läuft auf Windows XP und Vista und XP embedded PCs und auf Windows CE Plattformen.
zenon Logic Workbench | zenon Logic ist eine IEC 61131-3 Programmierumgebung. Mit der zenon Logic Entwicklungsumgebung - der so genannten Workbench - können Steuerungen in den fünf definierten Sprachen der IEC 61131-3 projektiert und programmiert werden.
VBA | Erweiterung von zenon Mit VBA kann die Funktionalität von zenon selbstständig erweitert werden. Die Möglichkeiten VBA in zenon einzusetzen am Beispiel spezieller Lösungsmöglichkeiten für die Projektrealisierung werden beschrieben.
Verriegelungen | Zugriffsberechtigungen Verriegelungen dienen dazu, den Zugriff auf bestimmte zenon Objekte zur Laufzeit mit Hilfe von Variablen steuern zu können.
Verteiltes Engineering | Mehrbenutzer Verwaltung , Mehrplatzfähigkeit Die zenon Mehrbenutzer-Funktion macht es möglich, dass mehrere User zur gleichen Zeit an demselben Projekt arbeiten.
Video | .avi Dateien in zenon Mit der Verwendung eines Bildes für die Videodarstellung sind Online- und gespeicherte Videoaufnahmen (*.avi) darstellbar.
Was bietet Ihnen das zenon unter CE? | Die CE Runtime von zenon ist auf verschiedenen CE Hardware Plattformen lauffähig. Grundsätzlich bietet die CE Version von zenon dieselbe Funktionalität wie die PC Version von zenon mit einigen Einschränkungen, die sich durch die geringeren Hardwareressourcen ergeben.
Web Server und Web Server Pro | Der Web Server bringt Projekte 1:1 ins Internet und Intranet. Für den Transfer sind keinerlei Projektanpassungen erforderlich. Im Gegensatz zum Web Server Pro, bietet der Web Server eine reine Beobachtungsfunktionalität. Der Web Server Pro bietet eine komplette Bedien- und Beobachtungsfunktionalität. Über das Web kann direkt auf Prozesse eingegriffen werden.
Wizards | Assistenten, Projektierungsunterstützung Um immer wiederkehrende Aufgaben beim Projektieren möglichst einfach und zeitsparend erledigen zu können, bietet zenon Wizards zu unterschiedlichen Themen an. Benutzer können eigene Wizards für individuelle Aufgaben erstellen.
Weltbild | Scrollen bei großen Bildern Mit der Verwendung eines Weltbildes ist es möglich in Standardbildern, die größer sind als die Bildschirmauflösung, mit der Maus zu scrollen. Hier ist es ebenfalls möglich, zu zoomen und abhängig von den Zoomstufen Detailinformationen im Bild ein- und auszublenden. (Zooming, panning, decluttering).
Zuweisungen | Wertübertragung Die Rangierung des aktuellen Wertes einer Prozessvariablen auf eine zweite Prozessvariable innerhalb eines Treibers oder treiberübergreifend wird mit der Verwendung von Zuweisungen realisiert.


Funktionalitäten Onlinehilfe - So findet man, was man sucht

Handbuch -> Roter Faden durch die Hilfe - Ein Überblick -> Funktionalitäten Onlinehilfe - So findet man, was man sucht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Manchmal kommt es vor, dass Informationen zwar in der Hilfe dokumentiert wurden, aber mit der Suche-Funktionalität trotzdem nicht gefunden werden.
Deshalb finden Sie hier einige Tipps, wie Sie in unserer Hilfe erfolgreich suchen und vor allem auch finden.

Suchstrategien

  • Per Default startet die Hilfe mit der Registerkarte Inhalt. Hier finden Sie sämtliche Dokumentation (Online-Handbuch, Tutorials und Treiber-Dokumentationen) in einer Baumstruktur.
  • In der Registerkarte Suchen kann nach Begriffen gesucht werden, indem sie in das Suchfeld eingegeben werden.
  • in der Registerkarte Favoriten können Sie bevorzugte Hilfekapitel ablegen. Dazu einfach das gewünschte Kapitel im Reiter Inhalt auswählen, oder über Suchen finden (jeweils Doppelklick erforderlich), anschließend zu Favoriten wechseln. Dieses Hilfekapitel wird hier unter Aktuelles Thema vorgeschlagen und kann zu den Favoriten hinzugefügt werden.

Suche nach Worten oder Phrasen:

Parameter | Beschreibung
Einzelnes Wort | z.B. Alarm Kapitel werden angezeigt, die das Wort 'Alarm' enthalten. Die grammatikalischen Variationen dieses Wortes werden ebenfalls berücksichtigt.
Phrase | z.B. 'Alarm Verwaltung' Kapitel werden nach der kompletten Phrase 'Alarm Verwaltung' durchsucht. Ohne Anführungszeichen, würden Suchergebnisse zu Alarm UND Verwaltung angezeigt werden, also Kapitel, die beide Begriffe enthalten.
Erweiterungen | z.B. Alarm* Kapitel werden nach allen Begriffen durchsucht, die 'Alarm' als Teil des Wortes enthalten. Der Asterisk (*) kann auch am Anfang des zu suchenden Begriffes eingegeben werden (z.B. *Alarm)
Verknüpfungen | AND Beide Wörter sollen im selben Kapitel vorkommen. z.B. Alarm AND CEL Kapitel die beide Wörter enthalten werden angezeigt.
 | OR Mindestens eines der Wörter soll im Kapitel vorkommen. z.B. Alarm OR CEL Kapitel, die entweder das Wort 'Alarm' oder das Wort 'CEL' oder beide Wörter enthalten, werden angezeigt.
 | NOT Nur eines der Wörter im Kapitel. z.B. Alarm NOT CEL Kapitel, die das Wort 'Alarm' aber nicht das Wort 'CEL' enthalten, werden angezeigt.
 | NEAR Beide Wörter im selben Kapitel, nahe beieinander z.B. Alarm NEAR CEL Kapitel, die beide Begriffe 'Alarm' und 'CEL' in einem maximalen Abstand von acht Wörtern enthalten.


zenon Produktfamilie

Handbuch -> zenon Produktfamilie

zenon stellt als Automatisierungssoftware für HMI, SCADA und Reporting vielfältige, integrierte Funktionalitäten für Engineering und Runtime plattformunabhängig zur Verfügung.

Mit zenon können Sie:

  • Automatisierungsprojekte erstellen, verteilen, bearbeiten und ausführen
  • integrierte Soft-SPS zenon Logicnutzen
  • Daten anlagenübergreifend und aus vielfältigen Quellen erheben und auswerten

attention Achtung

Verweise im Handbuch auf zenon allgemein meinen in der Regel immer zenon Supervisor und zenon Operator.

zenon ist auch in zwei speziellen Editionen erhältlich:

  • Energy Edition: für Energie- und Infrastruktur-Unternehmen
  • Pharma Edition: für Pharmazeutische Industrie

Diese Editionen sind auf die jeweiligen Einsatzgebiete optimiert und enthalten spezielle Elemente wie eigene Symbole, Wizards usw.

Noch in diesem Kapitel

zenon Supervisor

zenon Operator

Integrierte zenon Logic

zenon Analyzer


zenon Supervisor

Handbuch -> zenon Produktfamilie -> zenon Supervisor

Der zenon Supervisor ist ein umfassendes Werkzeug zur Erstellung und Ausführung von Automatisierungsprojekten. Er besteht aus Editor und Runtime, erlaubt den schnellen Aufbau von Automatisierungsnetzwerken - auch über Webanbindung - und kann unter allen aktuellen Windows Betriebssystemen eingesetzt werden werden.

Für den Einsatz auf Maschinenbediensystemen steht auch eine funktional eingeschränkte Variante, der zenon Operator, zur Verfügung.


zenon Operator

Handbuch -> zenon Produktfamilie -> zenon Operator

Der zenon Operator ist ein an Maschinenbedienung angepasstes, kostengünstiges Produkt. Die prinzipielle Funktionsweise entspricht dem zenon Supervisor. Der Operator ist gegenüber dem zenon Supervisor aber funktionell eingeschränkt.

Der zenon Operator besteht aus Editor und Runtime und kann auf PC-Betriebssystemen und CE-Betriebssystemen eingesetzt werden.


Integrierte zenon Logic

Handbuch -> zenon Produktfamilie -> Integrierte zenon Logic

zenon Logic ist die in zenon integrierte Programmierumgebung nach IEC 61131. Sie steht als Editor und Runtime (Soft-SPS) für zenon Supervisor und zenon Operator zur Verfügung.


zenon Analyzer

Handbuch -> zenon Produktfamilie -> zenon Analyzer

Der zenon Analyzer bietet durch systemübergreifende Analyse managementnahe und controllingnahe Sicht auf alle online und offline verfügbare Daten. Er fasst bisher getrennte Aufgaben zusammen und eliminiert Reibungsverluste, die durch parallele Abstimmung, Wartung und Koordination unterschiedlicher IT-Systeme entstehen. Der zenon Analyzer:

  • verdichtet und verrechnet Daten aus verschiedenen Quellen in verschiedenen Formaten
  • setzt sie zueinander in Relation
  • stellt die Ergebnisse daraus in grafischer Form als Report dar

Beim Einsatz des zenon Analyzer wird der Produktionsprozess nicht unterbrochen. Der zenon Analyzer kann in ein bestehendes Produktivsystem implementiert werden, ohne dass dieses umkonfiguriert werden muss. Bei Datenerhebung und Reporterstellung läuft das Produktivsystem ungestört weiter. Die bestehende Infrastruktur wird unabhängig von Herstellern in das Reporting durch zenon Analyzer eingebunden.

Für den Zugriff auf Auswertungen ist nur ein Microsoft Standard-Browser nötig. Es muss keine Software installiert, angepasst oder gewartet werden. Auswertungen können ohne zusätzliche Komponenten oder Plug-Ins ins Intranet eines Unternehmens eingebettet werden. Standard-Reports werden bereits mit zenon Analyzer ausgeliefert. Es können jederzeit eigene Auswertungen erstellt, gespeichert und verteilt werden.

Nähere Informationen zum zenon Analyzer finden Sie in der gesonderten Dokumentation des zenon Analyzer oder erhalten Sie bei Ihrem COPA-DATA Sales-Partner: sales@copadata.com.


Effizient projektieren mit zenon

Handbuch -> Effizient projektieren mit zenon

Sie arbeiten zum ersten Mal mit zenon?
Hier lesen Sie, wie Sie zenon effizient einsetzen. Auch wenn Sie bereits Erfahrung mit anderen Prozessleitsystemen haben, empfehlen wir Ihnen einen Blick in dieses Kapitel. Sie erfahren, welche Grundidee hinter zenon steht und wie es funktioniert, warum und wie zenon Ihre Arbeit einfacher und schneller macht.

zenon im Überblick

zenon besteht aus Editor und Runtime.
Projekte werden im Editor erstellt. Das Bedienen und Beobachten erfolgt in der Runtime. Editor und Runtime sind ab Version 6.20 versionsübergreifend kompatibel. Ein Projekt, das mit Version 6.50 erstellt wurde, läuft zum Beispiel auch auf einer Runtime mit Version 6.22 und umgekehrt.

zenon unterscheidet sich von anderen Systemen vor allem durch:

  • Einfache Bedienung: Viele Aktionen benötigen nur wenige Mausklicks, Assistenten und Wizards machen die Arbeit leicht und schnell, Sie arbeiten mit Drag&Drop per Maus oder mit der Tastatur, wie Sie es wünschen.
  • Praktische Objektorientierung: Sie arbeiten durchgängig mit Objekten, die Sie schnell parametrieren statt aufwändig programmieren. Sie nutzen einmal definierte Objekte auch projektübergreifend, profitieren von Vererbung und blitzschnellen Änderungen von Eigenschaften.
  • Exzellente Wiederverwendbarkeit einmal projektierter Objekte und Elemente: Von einzelnen Variablen bis zu kompletten Projekten sind in zenon viele Elemente sehr einfach und effektiv wiederverwendbar.
  • Integriertes Netzwerk: Verteiltes Engineering im Netzwerk und 100% Redundanz sind kein besonderer Aufwand mehr. Netzwerke erstellen Sie durch Aktivieren der entsprechenden Checkbox. Und genau so einfach vernetzten Sie vereinzelte stand alone Projekte zu effizienten, redundanten Systemen.

Tipps und Tricks

Viele nützliche Tipps finden Sie jederzeit im Forum von www.copadata.com. Wie Sie zenon optimal einsetzen, lernen Sie am besten in den COPA-DATA Trainings und Workshops, abgestimmt auf Ihre Schwerpunkte und Projekte. Ihr Vertriebspartner informiert Sie gerne - oder schreiben Sie eine kurze Mail an sales@copadata.com.

Noch in diesem Kapitel

Einfache Bedienung

Objektorientierung

Elemente wiederverwenden

Integriertes Netzwerk


Einfache Bedienung

Handbuch -> Effizient projektieren mit zenon -> Einfache Bedienung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon macht Ihnen das Projektieren durch viele kleine Annehmlichkeiten leichter und erhöht so Ihre Produktivität. Bei der Arbeit mit zenon werden Sie entdecken, dass Sie viele Aufgaben ganz nach Ihren Präferenzen lösen können. Zum Beispiel:

Favoriten

In den Eigenschaften der Objekte und im Funktionsauswahldialog können Sie eigene Favoriten definieren. Diese werden Ihnen immer am Beginn der Eigenschaftenlisten angeboten und geben Ihnen so schnellen Zugriff auf jene Eigenschaften, die sie besonders häufig benötigen.

Allgemeine Tastaturbedienung im Editor

Der Editor lässt sich bequem über Symbole und Menüs mit der Maus bedienen, aber auch durchgängig per Tastatur. Die von Windows gewohnten Tastenkürzel funktionieren auch in zenon. Zum Beispiel:

  • Strg+C und Strg+V für kopieren und einfügen
  • Einfg erstellt neue Objekte
  • Entf löscht markierte Objekte
  • Cursor Tasten dienen zum Navigieren in Ansichten
  • Esc bricht Aktion ab
  • Rückwärts löschen (Backspace) springt im Verzeichnisbaum auch auf die darüber liegende Ebene
  • Strg+Z macht letzte Aktionen rückgängig, ausgenommen Datenbankoperationen

Mehr zur Tastaturbedienung lesen Sie im Kapitel Tastenkombinationen.

Drag&Drop

Im Editor haben Sie die Möglichkeit, Arbeitsschritte per Drag&Drop zu vereinfachen. Zum Beispiel:

  • Reihenfolge der Menüeinträge ändern
  • Schriften auf Dynamische Elemente wie Universalregler, Uhr, Combi-Element etc. verknüpfen
  • Reihenfolge von Strukturelemente für Strukturdatentypen ändern
  • Reihenfolge innerhalb eines Scripts ändern
  • Kopieren oder verschieben von Funktionen über verschiedene Scripts
  • Skripte kopieren, indem sie auf den Stammknoten gezogen werden

Intelligente Assistenten und Wizards für komplexe Aufgaben

Die in zenon integrierten Assistenten und Wizards helfen Ihnen, schnell ein Basisprojekt zu erstellen oder komplexe Einstellungen zielgerichtet vorzunehmen. Wir empfehlen vor allem Einsteigern die Assistenten für den Universalregler, das Combi-Element und die Archivierung.

Tooltips für Elemente und Eigenschaften

Wenn Sie den Mauszeiger über ein Anzeigeelement (z. B. eine Text-Schaltfläche) oder eine Eigenschaft mit Verknüpfung (z. B. die mit einer Text-Schaltfläche verknüpfte Funktion) bewegen, erscheint ein Tooltip. Dieser zeigt Informationen der verknüpften Elemente an, wie die verknüpfte Funktion und deren Parameter.

Erweiterte Zeichenmöglichkeiten

Der grafische Editor bietet Ihnen eine breite Auswahl an Funktionen, die Ihnen das Abbilden von Anlagen leicht macht und Ihnen gleichzeitig sehr vielfältige Gestaltungsmöglichkeiten gibt. Vom stufenloser Zoom über skalieren per Klick bis zu einrastenden Elementeckpunkten und automatischem Verteilen von Elementen nach Regeln. Details dazu finden Sie im Kapitel Bilder.

Springen zu verknüpften Elementen

Bei allen grafischen Elementen, bei Funktionen, bei Variablen und auch bei anderen Elementen haben Sie die möglichkeiten direkt zu den Verknüpften Elementen zu springen. Beispielsweise kommen Sie von einem Anzeigeelement mit einem Mausklick direkt zur verknüpften Variable, von der Variable direkt zum verwendeten Datentyp und von dort sogar weiter zur verwendeten Einheit. Bei Bedarf können Sie alle diese Schritte auch bequem per Mausklick wieder zurück zum Ausgangselement springen.


Objektorientierung

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

COPA-DATA betrachtet das Thema Automatisierung erstens objektorientiert und zweitens ganz pragmatisch. So funktioniert auch zenon, das sich darüber hinaus auch selbst weitgehend automatisieren lässt. Sie benötigen für zenon keine Programmiersprache. Sie müssen keine Zeile Code programmieren. Stattdessen weisen Sie Objekten per Mausklick Eigenschaften zu. Das funktioniert nicht nur mit einzelnen Objekten, sondern auch zentral für ein ganzes Projekt und sogar projektübergreifend.

Wenn Sie jetzt befürchten, dass Sie zenon nicht individualisieren können und ganz auf die Objekteigenschaften angewiesen sind, heißt die gute Nachricht: Natürlich können Sie zenon auch sehr individuell gestalten. Dazu nutzen Sie vor allem VBA oder die VSTA (.NET) Entwicklungsumgebung. Außerdem bietet zenon viele Schnittstellen, um mit Hardware und Software zu kommunizieren und verfügt mit zenon Logic über eine integrierte SCADA Logic .

Drei wichtige Grundgedanken für die Arbeit mit zenon

Drei zentrale Prinzipien machen die die Projektierung mit zenon einfach, zuverlässig und wartungsfreundlich:

  1. Parametrieren statt programmieren:

    Einfach die nötigen Parameter setzen statt zu programmieren oder Skripte anzupassen.

  2. Global/zentral statt lokal:

    Objekte einmal definieren und immer wieder verwenden, auch projektübergreifend, statt Skripte immer wieder zu schreiben oder zu kopieren.

  3. Objektorientiert parametrieren:

    Alle Vorteile objektorientierten Denkens nutzen.

Noch in diesem Kapitel

Parametrieren statt programmieren

Global und zentral statt lokal

Objektorientiert parametrieren


Parametrieren statt programmieren

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Parametrieren statt programmieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Welchen Vorteil bringt es, Projekte zu parametrieren statt zu programmieren?

Sie verzichten vor allem auf fehleranfälligen Code und gewinnen hohe Flexibilität, Übersicht, Tempo und einen sehr hohen Grad an Wiederverwendbarkeit. Vier Punkte sprechen besonders dafür:

  1. Vorgefertigte Module bringen Zeitgewinn
    zenon enthält viele vorgefertigte Module. Statt selbst Skripte zu programmieren, wählt der Projektant das passende Modul und konfiguriert es, indem er die gewünschten Eigenschaften und Parameter selektiert. So erstellen Sie in kurzer Zeit lauffähige Projekte.
  2. Produkt kommt ausgereift vom Hersteller
    Der Projektant konzentriert sich auf seine Projekte. Die Software wird beim Hersteller entwickelt und getestet, Projektanten müssen keinen eigenen Code schreiben. Damit lässt sich der Umgang mit zenon schnell erlernen, auch für Mitarbeiter ohne Erfahrung im Software-Engineering.
  3. Einfache Wartung und Anpassung des Projektes
    zenon arbeitet streng objektorientiert. In Kombination mit dem Grundsatz "parametrieren statt programmieren" heißt das: leichte Wartung und Anpassung. Für Änderungen und Kontrollen muss man nur die Eigenschaften der einzelnen Objekte überprüfen oder ändern statt lange Codezeilen zu lesen und umzuschreiben. Auf die Lebenszeit eines Projektes gesehen bringt das
    • Übersicht: Projekte lassen sich auch nach Jahren und auch von neuen Mitarbeitern noch nachvollziehen.
    • Sicherheit: Fehleranfällige Skripte und Programmierung werden vermieden.
    • Zeitgewinn: Projektierung, Anpassung und Wartung lassen sich sehr viel schneller realisieren.
  4. Einfache Anpassung an Maschinen
    zenon lässt sich schnell und einfach an neue oder veränderte Maschinen anpassen. Projektanpassungen verlangen nur wenigen Mausklicks.

zenon anpassen

Parametrieren verhindert auch, dass Fehler in Skripten wieder und wieder kopiert werden. Es vermeidet umständliche Änderungen in vielen Einzelskripten, wenn lediglich eine Kleinigkeit angepasst werden soll. Das heißt aber nicht, unbeweglich sein. Auch zenon gibt Ihnen Möglichkeiten, das System individuell zu erweitern und anzupassen.

  • VBA/VSTA:
    Mit Hilfe der integrierten Skriptsprachen Visual Basics for Applications bzw. C# und VB.NET können Sie auch in der Runtime beliebigen Code ausführen. So lösen Sie Automatisierungsaufgaben, Logikaufgaben und Schnittstellenaufgaben wie Datenbankzugriffe.
  • zenon Logic:
    Die vollständig integrierte Steuerungsumgebung erlaubt Ihnen als SCADA Logic alle 5 IEC 61131-3 Sprachen zu nutzen. Damit erledigen Sie alle Berechnungen und Logikaufgaben.
  • PCE:
    Die integrierte Process Control Engine ermöglicht Ihnen, Automatsierungsaufgaben in den Sprachen VB-Skript und Java Skript umzusetzen.
  • ActiveX Controls:
    Beliebige Standard-Controls wie Flash Player oder Acrobat Reader lassen sich in zenon integrieren. Die Schnittstelle ist offen gelegt und steht damit auch selbst programmierten ActiveX Controls offen.
  • WPF-Elemente
    Durch die direkte Integration des Microsoft Formats Windows Presentation Foundation können Sie grafische Elemente wie z.B,. einen Button, ein Zeigerinstrument und vieles anderes in diesem neuen Grafikformat direkt in zenon Bildern einbinden. Diese Elemente können Sie frei mit Variablen und Funktionen verknüpfen und damit beliebige grafische Effekte umsetzen.
  • COM-Schnittstelle:
    Über die vollständig offen gelegte COM-Schnittstelle greifen Sie von außen auf zenon zu. Für die Kommunikation stehen beliebige Programmiersprachen wie C++, .NET, Delphi und so weiter zur Verfügung.


Global und zentral statt lokal

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Global und zentral statt lokal

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eigenschaften lassen sich bei zenon auf unterschiedlichen Wegen definieren, je nachdem, was Ihre Aufgabe verlangt:

  • direkt am Objekt
  • zentral
  • global

Natürlich lassen sich auch in zenon alle Einstellungen direkt beim Objekt vornehmen. Aber das ist nicht immer der beste Weg.

Eigenschaften zentral definieren

Oft ist es sinnvoll, Einstellungen einmal zentral vorzunehmen. Damit haben neue Objekte von Anfang an die gewünschten Eigenschaften. Änderungen sind besonders einfach: Die gewünschte Eigenschaft wird nur an einer einzigen Stelle zentral geändert - und alle betroffenen Objekte übernehmen sie automatisch. Also nur ein Klick statt vieler Zeilen Code oder vieler Mausklicks.

Diese zentralen Einstellungen lassen sich aus jeder Stelle im Editor leicht finden. Jedes Objekt, das Einstellungen von einer zentralen Quelle bezieht, bietet die Möglichkeit, diese direkt anzuspringen. Sie folgen einfach einem Link und sehen sofort, wie Elemente verbunden sind.

Eigenschaften können Sie aber nicht nur zentral für ein Projekt definieren, sondern auch projektübergreifend global.

Global projektieren

zenon lässt Sie mehr als ein Projekt zur gleichen Zeit bearbeiten - und spart dabei die wertvollste Ressource: Arbeitszeit. In allen Projekten gleiche Schriften verwenden, ist zum Beispiel sehr einfach. Einmal definiert, stehen Eigenschaften wie Schriftart oder Schriftgröße sofort allen Projekten eines Arbeitsbereiches zur Verfügung. Benötigen Sie eine andere Schriftart für alle Projekte, kostet Sie das nur einige Sekunden, um sie im Globalprojekt zu ändern. Und wenn Sie nur ein Projekt mit einer anderen Schrift versehen möchten? Dann ändern Sie diese Schrift eben nur zentral in diesem Projekt.

info Info

Verwenden Sie im Globalprojekt am besten andere Nummernkreise als in den lokalen Projekten. Denn zenon gibt bei identen Nummern immer den lokalen Einstellungen den Vorzug.

Und: Verwenden Sie eigene Namen für Schriftlisten, die Sie im Globalprojekt und in den Einzelprojekten konsistent halten. So stellen Sie sicher, dass auch bei einem Sprachwechsel alle Schriften gefunden werden.

Beziehungen von Objekten überblicken

Übersicht über Ihre Projekte und Beziehungen von Objekten gewinnen Sie zusätzlich mit:

  • Querverweisliste (QVL):
    Sie zeigt Querbeziehungen in einem Projekt an und ermöglicht die einfache Suche nach der Verwendung von Variablen und Funktionen.
  • Wizard für Dokumentation
    Er erstellt automatisch eine komplette Projektdokumentation. Was dokumentiert wird, lässt sich für jede Eigenschaft exakt einstellen.


Objektorientiert parametrieren

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Objektorientiert parametrieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

'Objektorientiert parametrieren' ist die grundlegende Philosophie bei zenon. Sie bringt Übersicht und spart viel Zeit beim Anlegen und Verwalten von Variablen.

Jede Variable in zenon basiert auf zwei Elementen:

  • Treiber
  • Datentyp

Noch in diesem Kapitel

Treiber

Datentypen

Tipps zu Adressierung und Import-Export


Treiber

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Objektorientiert parametrieren -> Treiber

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Treiber werden in zenon nicht direkt angebunden, sondern über einen Treiber-Objekttyp. Dieser bestimmt, welcher Bereich auf der Steuerung angesprochen werden soll.

Treiber-Objekttyp

Es existieren viele unterschiedliche Treiber-Objekttypen, zum Beispiel Standard SPS-Merker, Datenbausteine, Eingänge, Ausgänge, Zähler, aber auch Spezialtypen wie Alarm- oder Treibervariablen.

Der Treiber-Objekttyp bestimmt:

  • den Bereich auf der Steuerung
  • welche Granularität der Treiber in diesem Bereich hat
  • welche Datentypen auf dem Bereich angelegt werden können

Tipp: Nicht jeder Datentyp kann in jedem Bereich angelegt werden. Wählen Sie daher beim Anlegen einer Variable immer:

  • zuerst den Treiber,
  • dann den Treiber-Objekttyp und
  • zuletzt den Datentypen

Exkurs: Granularität

Granularität ist vor allem bei numerisch adressierenden Steuerungen wie z. B. der Siemens S7 wichtig. Nicht jede Steuerung hat dieselbe Rasterung und auch nicht alle Bereiche in einer Steuerung haben dieselbe Rasterung.

So ist z. B. der Datenbausteinbereich der Siemens S5 wortorientiert, der Merkerbereich aber Byte-orientiert. Das bedeutet, dass die kleinste Einheit, die adressiert werden kann, ein Byte oder eben ein Wort ist. Will man z. B. in einen solchen Bereich ein Bit schreiben, muss man mindestens ein ganzes Byte/Wort lesen, das entsprechende Bit ausmaskieren, ändern und dann das ganze Byte/Wort wieder auf die Steuerung schreiben.

Dieselbe Information benötigt man auch bei der Adressierung der Bereiche, Offset genannt. Man beginnt dabei bei Null und zählt in Byte- oder Wort-Schritten weiter. Nutzt man in zenon die automatische Adressierung, wird diese Granularität automatisch berücksichtigt. Die Granularität ist also nicht vom Treiber abhängig, sondern vom Treiber-Objekttyp.

Treibervariablen

Die Treibervariablen werden von jedem Treiber angeboten und bringen viele Vorteile für die Projektierung. Sie kommunizieren nicht mit der Steuerung, sondern lesen einen internen Speicherbereich des Treibers mit vor allem statistischen Informationen aus. Aber auch spezielle Funktionen lassen sich mit Variablen steuern, z. B. Telefonnummern für Modemverbindungen oder Befehle zum Wählen oder Auflegen.

Genauere Informationen dazu lesen Sie im Hilfekapitel Treibervariablen.

Auf der Installations-CD von zenonfinden Sie eine dBase-Datei mit den wichtigsten Treibervariablen. Damit können Sie diese Variablen zu jedem Treiber importieren statt sie manuell anzulegen.


Datentypen

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Objektorientiert parametrieren -> Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Datentypen sind das Herzstück des objektorientierten Parametrierens. Da bei den Treiber‑Objektypen keine Einstellungen vorgenommen werden können, sind diese für die Objektorientierung nicht nutzbar. Die Datentypen dagegen bieten hier sehr viele Möglichkeiten.

Wir unterscheiden drei Arten:

  • einfache Datentypen
  • Struktur-Datentypen
  • Strukturelemente

Noch in diesem Kapitel

Einfache Datentypen

Struktur-Datentypen - Strukturelemente - Strukturarray


Einfache Datentypen

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Objektorientiert parametrieren -> Datentypen -> Einfache Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einfache Datentypen sind immer IEC Datentypen, also die im IEC Standard 61131-3 definierten Datentypen wie BOOL, INT, USINT, UDINT, USINT, STRING, WSTRING usw. Sie bringen die Länge eines Bereichs mit - zum Beispiel:
BOOL: 1 Bit
INT: 16 Bit mit Vorzeichen
UINT: 16 Bit ohne Vorzeichen

Die Datentypen in zenon erlauben neben dem IEC Datentyp aber die Einstellung von weit mehr Eigenschaften. Diese haben dieselben Bezeichnungen wie die Eigenschaften der Variablen:

  • Kennung
  • Einheit
  • Wertbereich
  • Grenzwerte

Wozu diese "doppelte Buchführung"?

Der Hintergrund ist so einfach wie praktisch:
Die Variable übernimmt Wertberechnung, Einheit und eben auch Grenzwerte vom zugrundeliegenden Datentyp - so wie ein Anzeigelement z. B. die Schriftart und Schriftgröße von der verknüpften Schrift übernimmt.

Objektorientierung

Anders als bei der Verknüpfung von Dynamischen Elementen und Schriften haben wir es hier mit einem objektorientierter Ansatz zu tun: Das Datentypobjekt vererbt seine Eigenschaften auf die Variable. Der Unterschied?

Verknüpfte/abgeleitete Eigenschaften lassen sich bei der Variablen trennen oder überschreiben. Das funktioniert für jede Eigenschaft einzeln, aber auch für alle Eigenschaften gleichzeitig. Sie können also z. B. die Einheit vom Datentyp zentral übernehmen, die Kennung, oder die Adresse jedoch direkt bei der Variablen überschreiben. Das funktioniert so:

  • Ändern Sie bei der Variablen den entsprechenden Wert, dann wird die Verknüpfung getrennt.
    Sie erkennen das auch daran, dass in den Eigenschaften das Häkchen verschwunden ist.

Über das Kontextmenü können Sie folgende Funktionen nutzen:

  • Eigenschaft vom Datentyp ableiten:

    Wenn Sie die Verknüpfung getrennt haben, können Sie diese wieder herstellen.

  • Eigenschaft trennen:

    Sie können eine einzelne Eigenschaft trennen, ohne dass Sie den Wert ändern müssen. Wenn Sie später den Wert beim Datentyp ändern, können Sie sicher sein, dass die Variable davon nicht beeinflusst wird. So können Sie ganz bewusst einstellen, ob das Vererbungskonzept greift oder nicht.

Als besondere Hilfestellung können Sie auch alle Eigenschaften mit einem Mausklick vom Datentyp übernehmen oder trennen. Damit können Sie besonders schnell den Ursprungszustand (alles abgeleitet) wiederherstellen oder eben aufheben. Was bringt Ihnen das Ganze in der Praxis?

Besonders hohe Flexibilität: Wenn Sie viele Variablen mit gleichem Grenzwert haben, z. B. einen Alarm bei Wert 1, dann stellen Sie diesen beim Datentyp ein. Den Grenzwertext und andere optionale Parameter stellen Sie dann bei jeder Variable gesondert ein. Sie sparen sich damit das Anlegen und Warten des Grenzwerts bei jeder einzelnen Variablen und Ihre Engineeringleistung steigt deutlich.Der standardmäßig angelegte Datentyp BOOL hat übrigens bereits einen Grenzwert bei 0 und bei 1!

Wenn Sie nun gar nicht bei jeder Bool-Variablen einen Grenzwert haben, müssen Sie aber nicht bei jeder Variablen extra aufpassen und den Grenzwert wieder ausschalten. Sie nutzen einfach eine bequeme Möglichkeit unter zenon und legen einen eigenen Bool-Datentyp an. Gehen Sie so vor:

  • Standard-Datentyp einfach lassen wie er ist
  • auf Datentyp neu klicken
  • eine Liste mit den existierenden Datentypen wird angeboten
  • Standard-Bool auswählen
  • Namen vergeben, z. B. MyBool
  • alle Eigenschaften des neuen Datentyps werden vom alten automatisch übernommen
  • bei MyBool Grenzwerte löschen

Alle Bool-Variablen, die keine Grenzwerte haben sollen, legen Sie dann auf diesem neuen Datentyp MyBool an – und schon sind die nicht gewünschten Grenzwerte verschwunden. Jene, die erwünscht sind, bleiben aber weiter erhalten.

Sie können natürlich nicht nur einen eigenen Bool-Datentyp erstellen, sondern beliebig viele anlegen. Alle Variablen, die über weite Bereiche idente Eigenschaften benötigen, bekommen einen eigenen Datentyp. Ändert sich eine Eigenschaft, ändern Sie diese zentral und alle abgeleiteten Variablen werden automatisch mitgeändert – ausgenommen jene, bei denen die Verknüpfung getrennt wurde.


Struktur-Datentypen - Strukturelemente - Strukturarray

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Objektorientiert parametrieren -> Datentypen -> Struktur-Datentypen - Strukturelemente - Strukturarray

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Struktur-Datentyp

Struktur-Datentyp meint eine Gruppe von Datentypen, die in ihrer Reihenfolge und ihrer Anordnung genau definiert sind. Zum Beispiel kann sich die Struktur Motor aus den Elementen Ist-Drehzahl und Leistungsaufnahme zusammensetzen.

Eine Struktur kann auch verschachtelt sein, wobei beliebige Hierarchieebenen möglich sind.

Mit Struktur-Datentypen lässt sich der Variablenhaushalt genau so aufbauen, wie er in der Steuerung bzw. logisch in der Realität existiert.

Strukturelement

Ein Struktur-Datentyp ist eigentlich nur eine Hülle, die den Namen für die Struktur vergibt, selbst jedoch keine eigenen Eigenschaften mitbringt.

Diese kommen erst mit den Strukturelementen, die dem Struktur-Datentyp hinzugefügt werden. Dabei unterscheiden wir:

  • verknüpfter Struktur-Datentyp:

    Bezug zu einem bereits bestehenden Datentyp. Alle Eigenschaften werden übernommen, ausgenommen der Name.

    Vorteil: Hat das Strukturelement sehr viele Eigenschaften eines bereits existierenden Datentyps, können diese einfach wiederverwendet werde. Bei der Variablen können natürlich nach wie vor einzelne Eigenschaften geändert oder vom Datentyp getrennt werden.

  • eigener eingebetteter Struktur-Datentyp:

    Erlaubt individuelle Adressierungseinstellungen. Dieser neue Datentyp ist ausschließlich innerhalb dieser Struktur gültig.

info Info

Vorteil Objektorientierung: Ändert sich die Struktur irgendwann, dann genügt es, den Struktur-Datentyp zu ändern, um alle Variablen, die auf dieser Struktur liegen, automatisch anzupassen.

Änderungen sind in allen Ausprägungen möglich:

  • einfachen Eigenschaften wie die Einheit beim Datentyp
  • komplexe Eigenschaften wie das Hinzufügen oder Löschen eines Grenzwertes
  • Änderung der gesamten Struktur durch z. B. Änderung der Reihenfolge der Elemente oder Hinzufügen oder Löschen einzelner Strukturelemente im Struktur-Datentyp

Strukturarray

Wenn es nicht nur um eine Maschine geht, sondern um viele, kommt das Strukturarray zum Einsatz.

Zum Beispiel: 100 Pumpen statt 1 Pumpe.
Dann verwandeln Sie die Strukturvariablen einfach ein Strukturarray. So werden mit einem einzigen Mausklick 100 Variablen zu 100 Strukturvariablen.

Wenn wir pro Pumpe zum Beispiel je 12 Einzelvariablen anlegen müssen, benötigen wir 1200 Variablen insgesamt. Die Methode „objektorientiert parametrieren" ermöglicht das mit wenigen Mausklicks. Dazu kommt der Vorteil, dass alle Variablen schon voreingestellt sind. Jede einzelne Variable bringt bereits alle Eigenschaften mit, die sie braucht , wie Einheit, Wertberechnung, Alarme, CEL Einträge usw.

info Info

Struktur-Datentypen eigenen sich auch für die Wiederverwendung von Variablen.

Noch in diesem Kapitel

Beispiel Pumpe


Beispiel Pumpe

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Objektorientiert parametrieren -> Datentypen -> Struktur-Datentypen - Strukturelemente - Strukturarray -> Beispiel Pumpe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Beispiel Pumpe

Ausgangslage

Eine Pumpe besteht aus zwei Motoren. Jeder davon hat einige Variablen wie:

  • Ist-Drehzahl
  • Stromaufnahme
  • Leistung
  • usw.

Jeder Motor wiederum hat einen Motorregler mit folgenden Variablen:

  • Soll-Drehzahl
  • P-Anteil
  • I-Anteil

Diese Konstellation bauen Sie so auf:

  1. Erzeugen Sie eine Struktur Regler aus je einem Datentyp für
    • Soll-Drehzahl
    • P-Anteil
    • I-Anteil
  2. Erstellen Sie eine Struktur Motor mit den jeweils eigenen Datentypen:
    • Ist-Drehzahl
    • Stromaufnahme
    • Leistung
    • usw.
  3. In die Struktur Motor übernehmen Sie den Regler.
  4. Erstellen Sie die Pumpenstruktur und integrieren Sie dort den Motor.

    Da wir zwei Motoren haben, übernehmen Sie den Motordatentyp einfach zweimal in Ihre Struktur Pumpe.

  5. Erstellen Sie eine Variable, die auf diesem Strukturdatentyp beruht:
    • Neue Variable anlegen
    • Struktur-Datentyp Pumpe auswählen

    Die einzelnen Elemente dieser Strukturvariablen heißen Strukturelemente und können in zenon überall als einzeln Elemente genutzt werden, zum Beispiel in Bildern, Alarmen, Archiven, Rezepten usw.


Tipps zu Adressierung und Import-Export

Handbuch -> Effizient projektieren mit zenon -> Objektorientierung -> Objektorientiert parametrieren -> Tipps zu Adressierung und Import-Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Tipps aus der Praxis zu:

  • Adressierung
  • Export/Import

Adressierung:

Bei numerischen Steuerungen haben Sie die Wahl, ob die Adressierung automatisch oder halbautomatisch erfolgen soll. Alle hier beschriebenen Eigenschaften sind auch über VBA/VSTA erreichbar und können damit für die automatische Projektierung genutzt werden.

Automatische Adressierung:

Offset und - falls erforderlich - Byte- und Bitadresse werden auf Basis der Position der Strukturelemente automatisch errechnet, bei Arrays auch über das gesamte Array hinweg. Wenn Sie in der Steuerung dieselbe Struktur wie in zenon angelegt haben, passt das Ganze zu 100% zusammen und Sie brauchen sich um die richtige Adressierung keinerlei Gedanken machen.

Halbautomatische Adressierung:

Sie vergeben einzelne Startadressen bereits beim Datentyp. Anhand dieser Adressen werden dann die weiteren Adressen berechnet. Diese können Sie bei Bedarf natürlich auch anpassen. Details dazu finden bei Automatische Adressierung.

Bei symbolisch adressierten Steuerungen müssen in zenon und in der Steuerung die gleichen Namen vergeben werden.

XML Export/Import:

Beim Export und Import werden auch Informationen wie Datentypen, Strukturen, Ableitungen usw. mitgenommen. Sie können also Ihre einmal erstellten Struktur-Datentypen und Strukturvariablen bequem exportieren und über Import in anderen Projekten eins zu eins weiter nutzen oder nach Bedarf modifizieren.


Elemente wiederverwenden

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim ersten Anlegen eines Projektes benötigen Sie Zeit für das Erstellen von Variablen, Funktionen, Bildern und deren Verknüpfungen. Diese Zeit können Sie bei folgenden Projekten deutlich reduzieren. Denn mit zenon haben Sie die Möglichkeit, einmal erstellte Elemente einfach in andere Projekte zu übernehmen.

Zum Beispiel benötigen Sie in vielen Projekte Standardelemente wie Bilder für den Systemstatus oder Detailbilder für immer wieder verwendete Hardwarekomponenten (Pumpen, Ventile, Motoren usw.).

Um Elemente wiederzuverwenden, stehen Ihnen verschiedene Wege zur Verfügung:

Thema | Wiederverwendung von
Variablen und Funktionen ersetzen | Elementen
Symbole | Bildern
Struktur-Datentyp | Variablen
Reaktionsmatrizen | Variablen
Globalprojekt | zentralen Elementen eines Projekts
XML | Projektteilen mittels Import und Export
Wizards | Bildern und Elementen mittel Import oder Individualisierung
Projekte wiederverwenden | Projekten

info Info

Um Element effizient wiederverwenden zu können, achten Sie schon bei der Erstellung von Variablen, Funktionen und Bildern auf eindeutige Benennung.

Noch in diesem Kapitel

Variablen und Funktionen ersetzen

Symbole

Struktur-Datentyp

Reaktionsmatrizen

Globalprojekt

XML

Wizards

Projekte wiederverwenden


Variablen und Funktionen ersetzen

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Variablen und Funktionen ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen und Funktionen, die bei Dynamischen Elementen hinterlegt werden, können automatisiert ersetzt werden. Dies kann an unterschiedlichen Stellen geschehen:

  • Verknüpfung im Bild ersetzen
  • Verknüpfung bei Bildumschaltung ersetzen
  • Indizes ersetzen
  • Mehr über Ersetzung von Variablen und Funktionen lesen Sie auch im Handbuch Bilder im Abschnitt Verknüpfungen von Variablen und Funktionen ersetzen.

Noch in diesem Kapitel

Namenskonventionen

Möglichkeiten der Ersetzung


Namenskonventionen

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Variablen und Funktionen ersetzen -> Namenskonventionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Variablen und andere Elemente sicher ersetzen zu können, sollte die Benennung systematisch und möglichst normiert erfolgen. Damit unterstützen Sie nicht nur die Wiederverwendbarkeit, sondern auch Wartung und Reverese Engineering.

Verschiedene Systeme unterstützen Sie bei der systematischen Benennung.

Zum Beispiel: Energiewirtschaft

Deutschland

  • KKS (Kraftwerk-Kennzeichen-System), Details siehe http://de.wikipedia.org/wiki/Kraftwerk-Kennzeichensystem
  • DIN 6779 (Kennzeichnungssystematik für technische Produkte und technische Produktdokumentation), Details siehe http://de.wikipedia.org/wiki/DIN_6779
  • AKZ (Anlagenkennzeichnungssystem), Details siehe http://de.wikipedia.org/wiki/Anlagenkennzeichnungssystem

International

  • KKS (Power Plant Classification System), Details siehe http://en.wikipedia.org/wiki/KKS_Power_Plant_Classification_System

Solche Normen existieren für alle Branchen. Es empfiehlt sich, deren Namenskonventionen zu benutzen.

Beispiel KKS:

In einem Energieprojekt sollten Variablen gemäß dem KKS benannt werden. Eine entsprechend benannte Variable mit der Bezeichnung C01_MDY10-QA001_QA07 sagt aus:

  • Windenergieanlage C01 (Reihe C, Nr. 1)
  • Windturbinensteuerung MDY10, Leistungsteil QA001,
  • Leistungsschutz QA07


Möglichkeiten der Ersetzung

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Variablen und Funktionen ersetzen -> Möglichkeiten der Ersetzung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ersetzungen können an unterschiedlichen Stellen eines Projekts verwendet werden:

  • Verknüpfung im Bild ersetzen: Bilder werden kopiert und im kopierten Bild werden die Verknüpfungen ersetzt.
  • Verknüpfung bei Bildumschaltung ersetzen: Es wird für unterschiedliche Steuerungen nur ein einziges Bild verwendet und beim Aufschalten werden die Verknüpfungen angepasst.
  • Indizes ersetzen: Ersetzen von Variablen in einem Prozessbild über den Wert von Indexvariablen.

Noch in diesem Kapitel

Verknüpfung im Bild ersetzen

Verknüpfung bei Bildumschaltung ersetzen

Indizes ersetzen


Verknüpfung im Bild ersetzen

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Variablen und Funktionen ersetzen -> Möglichkeiten der Ersetzung -> Verknüpfung im Bild ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn in einem Bild Variablen verknüpft sind, können diese über einen Ersetzungsdialog bequem ausgetauscht werden. Voraussetzung:

  • klare Benennung der Variablen

Damit können einmal erstellte Bilder über Copy & Paste weiter verwendet werden. Die Ersetzung wird über das Kontextmenü gestartet:

  • Rechtsklick auf das Bildelement
  • Klick auf Verknüpfungen ersetzen

Damit wird der Dialog für die Ersetzung geöffnet.

Beispiel

In unserem Beispiel verfügt das Projekt über eine Menge an Variablen aus unterschiedlichen Anlagenteilen. Auf dem Prozessbild sind:

  • 10 Variablen, die aus der Windturbinensteuerung MDY10 kommen, mit dynamischen Elementen verknüpft
  • Buttons mit Bildumschaltung auf unterschiedliche Bereiche von MDY10 vorhanden

Über Copy & Paste will der Projektant das Bild 1:1 für die Windturbinensteuerung MDY11 wiederverwenden und die Variablen bzw. Funktionen durch die entsprechenden der neuen Steuerung ersetzen. Dazu:

  1. werden die dynamischen Elemente, auf denen die Variablen und Funktionen verknüpft sind, markiert
  2. wird der Ersetzungsdialog geöffnet

  3. im Feld Quelle wir die Anlagenkennzeichnung *MDY10* eingegeben
    (d führenden und schließenden * sind Wildcards)
  4. im Feld Ziel wird MDY11 eingegeben
  5. mit Übernehmen wird die Ersetzung durchgeführt und mit OK der Dialog geschlossen

Das Bild kann jetzt für die neue Steuerung verwendet werden.


Verknüpfung bei Bildumschaltung ersetzen

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Variablen und Funktionen ersetzen -> Möglichkeiten der Ersetzung -> Verknüpfung bei Bildumschaltung ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei dieser Methode wird immer das Originalbild verwendet und zur Runtime mit unterschiedlichen Variablen und Funktionen aufgeschaltet. Das Bild enthält so wie im Beispiel "Verknüpfung im Bild ersetzen" verschiedene Variablen und Funktionen. Die Ersetzung erfolgt beim Umschalten. Dazu:

  1. werden mehrere Funktionen Bildumschaltung auf dieses Bild projektiert
  2. wird beim Erstellen der Funktion der Dialog zur Ersetzung angeboten
  3. beinhaltet jede Funktion einen eigenen Ersetzungsvorgang

Eine Variante dazu, die mit nur einer Bildumschaltung auskommt: Indizes ersetzen für Arrays.


Indizes ersetzen

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Variablen und Funktionen ersetzen -> Möglichkeiten der Ersetzung -> Indizes ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In Arrays kann die Ersetzung für Variablen über Indexvariablen erfolgen.

Wie in Verknüpfung bei Bildumschaltung ersetzen wird das Bild nur einmal verwendet. Die verknüpften Variablen werden bei der Umschaltung ersetzt. Die Bildumschaltung wird nur einmal projektiert (Unterschied zu Verknüpfung im Bild ersetzen) und kann über eine Index-Variable mehrmals wiederverwendet werden kann.

Beispiel

Die Bildumschaltung wird auf ein Prozessbild durchgeführt, das 10 Variablen der Windturbinensteuerung MDY10 beinhaltet. Ziel des Projektanten ist es, dieses Bild 1:1 wiederzuverwenden, da die Windturbinensteuerungen MDY11, MDY12 und MDY13 über die selbe Anzahl an Variablen verfügen.

Die Indizierungsregel:

  • Quelle: C01 MDY10 QA001*
  • Ziel: C01 MDY{X01} QA001

bewirkt:

  • bei der Bildumschaltung wird der Funktion mitgeteilt, dass sie bei der Bildumschaltung zur Runtime den Variablenwert von X01 Index Windturbinensteuerung in die Variablennamen einsetzen muss.

    Beispiel: Besitzt diese Variable den Wert 12 so wird beim Ausführen der Bildumschaltung das Prozessbild mit allen Variablen der Windturbinensteuerung MDY12 angezeigt


Symbole

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Symbole

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbole bieten ein großes Potenzial zur Wiederverwendung. Symbole lassen sich sehr komplex aufbauen und unterstützern Vererbung. Symbole können eingebettet oder verknüpft werden. Bei Verlinkung genügt die Modifikation an einer Stelle, um alle Bilder, die dieses Symbol verwenden, zu aktualisieren. Symbole können auch in andere Symbole verknüpft werden.

Beispiel Buttonleiste

Ein Symbol (leeres Rechteck) wird als Basis in alle Buttons verknüpft.

Frei gegebene Eigenschaften ermöglichen es, jeden Button mit unterschiedlichen Grafiken zu versehen. Sollen Form oder Farbe der Buttons verändert werden, muss nur das Symbol "leerer Button" modifiziert werden. Alle Buttons übernehmen automatisch die neue Form und/oder Farbe.

Noch in diesem Kapitel

Frei gegebene Eigenschaften

Ersetzung bei Symbolen

Globale Symbolbibliothek


Frei gegebene Eigenschaften

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Symbole -> Frei gegebene Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verknüpfte Symbole vererben ihre Eigenschaften auf die Objekte, in die sie verknüpft wurden. Allerdings können einzelne Eigenschaften aus der Vererbung gelöst werden. Zum Beispiel die angezeigte Grafik in unserem Button. Wird die Vererbung gelöst, kann diese Eigenschaft für jedes Objekt individuell gesetzt werden. Änderungen dieses details im Ausgangselement beeinflussen die anderen Objekte nicht mehr.

Bilder wiederverwenden

Die Kombination aus Symbolen und freigegebenen Eigenschaften kann eine effektive Lösung für die Wiederverwendung von Prozessbildern sein.

Beispiel

In einem Projekt gibt es einen zentralen Parametrierungsdialog, der für unterschiedlichste Parametrierungen verwendet werden soll. Da dieser in unterschiedlichsten Bereichen eingesetzt wird, besteht auch die Forderung, dass gewisse Anpassungen (z.B. Hintergrundfarben, Bilder, …) möglich sein sollen.

Copy and Paste:

  1. ein Prozessbild erstellen, das diesen Parametrierungsdialog enthält
  2. Bild über Copy & Paste vervielfältigen
  3. die mehrfach vorhandenen Prozessbilder können grafisch an die Anforderungen angepasst werden

Aber: Vererbung ist hier nicht möglich. Möchte der Projektant im Nachhinein zentrale Anpassungen (betreffend der Grundstruktur des Parametrierungsdialogs) durchführen, so muss er diese in jedem einzelnen Prozessbild nachziehen.

Ansatz über Symbol mit freigegebenen Eigenschaften:

  1. der Parametrierungsdialog wird über ein Symbol erstellt
  2. Elemente, die für die unterschiedlichen Parametrierungsstellen angepasst werden müssen, werden über freigegebene Eigenschaften aus dem Vererbungskonzept entkoppelt
  3. das Symbol wird in die entsprechenden Bildern verknüpft, positioniert und angepasst.

  4. Sollte sich der Projektant dafür entscheiden das generelle Aussehen des Dialogs zu verändern, so führt er diese Änderung zentral im Symbol durch. Diese Änderung wirkt sich dann auf alle Positionen, in denen das Symbol verknüpft ist, aus.

  5. Über die freigegebenen Eigenschaften und eine entsprechende Ersetzung kann das globale Symbole individuell angepasst werden.

  6. In diesem Fall hat sich der Projektant dafür entschieden, dass sich die generelle grafische Oberfläche von Parametrierungsdialogen ändern muss. Diese Änderung führt er zentral am Symbol „Parametrierung" durch. Die individuellen Eigenschaften der einzelnen Parametrierungsdialoge bleiben unverändert, es ändern sich nur jene Eigenschaften, die in der Vererbung enthalten sind.


Ersetzung bei Symbolen

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Symbole -> Ersetzung bei Symbolen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der im Abschnitt Variablen und Funktionen ersetzen beschriebene Vorgang kann auch bei Symbolen durchgeführt werden. Auch hier ist eine durchdachte Benennung der Objekte Voraussetzung.

Bei der Ersetzung für Symbole müssen zwei unterschiedliche Herangehensweisen unterschieden werden: Ein Symbol kann aus einer Bibliothek (Projekt/Global)

  • in ein Prozessbild eingebettet werden.
  • in ein Prozessbild verknüpft werden

Je nach Herangehensweise werden unterschiedliche Dialoge zur Ersetzung der Variablen/Funktionen aufgeschaltet.

Eingebettete Symbole

Hier werden die Variablen direkt über den Ersetzungsdialog ersetzt. Der Dialog bietet mitunter die Möglichkeit, Variablen über einen Variablenauswahldialog auszuwählen. Symbole auf diese Art und Weise zu verwenden ist für die Wiederverwendung nicht ideal geeignet.

Verknüpfte Symbole

Bei diesem Verfahren wird über Ersetzungsstrings gearbeitet. Diese Strings werden bei der Kompilierung durch die entsprechenden Variablen ersetzt. Über den hier aufgeschalteten Dialog ist es nicht möglich Variablen über einen Variablen-Auswahldialog zu ersetzen. Der Projektant arbeitet hier über einzelne Ersetzungsstrings, die durch ein Semikolon (;) voneinander getrennt werden.

Das hinter diesem Ersetzungsdialog liegende Symbol kann nun in den unterschiedlichsten Anlagenbereichen wiederverwendet werden. Dieses Beispiel geht davon aus, dass in jedem Anlagenbereich ähnliche Variablen und Funktionen (Unterscheidung nur durch Anlagenkürzel im Namen) verwendet werden und diese so schnell und übersichtlich ersetzt werden können.

Mehr über Ersetzung bei Symbolen lesen Sie auch im Handbuch Bilder im Abschnitt Verknüpfte Symbole.


Globale Symbolbibliothek

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Symbole -> Globale Symbolbibliothek

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbole werden entweder in der Projekt-Symbolbibliothek oder in der Globalen Symbolbibliothek verwaltet. Der wesentliche Unterschied:

Symbolbibliothek

Eigenschaft

Globale Symbolbibliothek

Symbole sind in allen Projekten verfügbar.Der Knoten Globale Symbolbibliothek befindet sich im Projektmanager unterhalb der aktuell geladenen Projekte

Globale Symbole werden im zenon Programmordner gespeichert und nur beim Editorstart aktualisiert. Diese Symbole werden bei der Projektsicherung nicht gesichert.

Projekt-Symbolbibliothek

Symbole sind nur im aktuellen Projekt verfügbar.

Die Symbole werden im Projektordner gespeichert. Die Projekt-Symbolbibliothek befindet sich im aktuellen Projekt im Knoten Bilder und wird bei einer Projektsicherung mitgesichert.

Beispiel

Eine zentrale Projektierungsstelle stellt eine Sammlung von Symbolen zusammen, die von den weltweit verteilten Projektierungsstellen in ihren individualisierten Projekten verwendet werden soll. Zum Beispiel werden komplexe Symbole zur Verfügung gestellt, die wichtige Teile von Prozessbildern darstellen. Diese Sammlung an Symbolen befindet sich in einem Ordner oder einer Datei, z.B. „Global_Used_Symbols.SYM". Werden zentral grafische Veränderungen an dieser globalen Symbolsammlung durchgeführt, so wird einfach die „Global_Used_Symbols.SYM" Datei an alle Projektierungsstellen versendet und dort ersetzt. Die individuelle Anpassung kann erfolgt über frei gegebene Eigenschaften und Ersetzung.

Es ist nicht immer nötig, die gesamte Symbolsammlung zu verteilen. Um einzelne ausgewählte Symbole zu verteilen, kann auch der XML-Export/Import genutzt werden.

attention Achtung

Bei Verwendung der Globalen Symbolbibliothek muss eine klare Regel bestehen: Lokale Projektierungsstellen dürfen die Symbole aus der Symbolsammlung nicht verändern. Jede Änderung würde beim nächsten Update überschrieben werden.


Struktur-Datentyp

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Struktur-Datentyp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen können über Struktur Datentypen wiederverwendet werden. Damit lassen sich komplexe Strukturen aufbauen und die Vorteile einer Vererbung nutzen.

Beispiel

Der Struktur-Datentyp „Motor" besteht aus drei Elementen:

  • Status
  • Drehzahl
  • Temperatur

Die Elementen unterscheiden sich in ihrer Vererbungsart:

  • „Status" und „Drehzahl" sind vom Datentyp INT abgeleitet, aber ihre Vererbung wurde durch das Einbetten aufgebrochen.
    D. h.: Spätere Aktualisierungen am INT Datentyp wirken sich nicht auf diese beiden Elemente aus.
  • „Temperatur" stammt auch vom Datentyp INT ab, die Vererbung ist intakt.
    D. h.: Spätere Änderungen am INT Datentyp wirken sich auch auf die Einstellungen dieses Struktur-Elements aus.

Werden nun zum Beispiel 20 Motoren projektiert, deren Aufbau immer ident ist, können Variablen basierend auf dem selbst erzeugten Datentyp „Motor" erzeugt werden. Dies kann z.B. über das Anlegen eines Arrays von diesem Datentyp passieren. Die grafische Darstellung wird in diesem Beispiel über ein Symbol gelöst.

Beim Verknüpfen des Symbols in ein Prozessbild werden die Platzhalter-Variablen des Symbols durch jene des selbst erzeugten Struktur-Datentyps ersetzt. Achten Sie auch hier von Anfang an auf die durchdachte Benennung.

Gestaltet man ein Prozessbild als Übersicht über alle Motoren, kann man einfach über Copy&Paste das eingefügte Symbol vervielfachen. Es muss nur noch bei jedem Symbol die Zielvariable durch die entsprechende Laufnummer ersetzt werden:

Sollen zu einem späteren Zeitpunkt Grenzwerte für die „Drehzahl" Variablen hinzugefügt werden, profitiert man von der vorhandenen Vererbungsbeziehung zwischen dem selbst angelegten Datentyp und den daraus erzeugten Variablen. Für die geplante Änderung wird am Strukturelement „Drehzahl" des eigenen Datentyps „Motor" ein neuer Grenzwert angelegt. Diese an einer Position durchgeführte Änderung, wirkt sich auf alle 20 angelegte Motoren aus.

Dem Projektanten steht es aber auch durchaus frei diese Vererbungsbeziehung aufzulösen. Es kann also bei einer der 20 angelegten Motorvariablen der Grenzwert für „Drehzahl"geändert werden.

Hinweis: Es können einzelne oder alle Eigenschaften einer Variablen vom Datentyp entkoppelt werden.

info Info

Tipps zur Verwendung von Struktur-Datentypen lesen Sie auch im Abschnitt Struktur-Datentypen - Strukturelemente - Strukturarray und im Handbuch Variablen im Abschnitt Struktur Datentypen.


Reaktionsmatrizen

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Reaktionsmatrizen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Reaktionsmatrizen bewirken, dass die Ausprägung einer Variable überall im Projekt gleich ist. Im Gegensatz zu Grenzwerten verfolgen sie einen zentralen Ansatz: Eine Reaktionsmatrix wird einmal projektiert und dann beliebigen Variablen zugeordnet. Alle Variablen, die mit der Reaktionsmatrix verknüpft sind, reagieren damit gleich. Der Vorteil: zentrale und einfache Wartung.


Globalprojekt

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Globalprojekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit einem Globalprojekt lassen sich Standards projektübergreifend festlegen. Damit ist es möglich, bestimmte Module oder Elemente für alle Standorte zu definieren, während lokale Projekte individuelle Parameter festlegen.

Im Globalprojekt können projektiert werden:

  • Alarmierung:

    Deklaration der global zu verwendeten Alarmgruppen, Alarmklassen und Alarmbereiche.

  • Anlagenmodellierung:

    Diese kann die zentrale Projektierung unterstützen, da man eine Aufteilung in zwei „Anlagen" vornehmen könnte. Dabei mus klar definiert werden, welche Projektierungselemente von der zentralen Projektierungsstelle kommen und welche von der lokalen Projektierungsstelle stammen.

  • Benutzer:

    Sieht ein Standard die Existenz von bestimmten global gültigen Benutzern vor, so können diese über das Globalprojekt festgelegt werden.

  • Dateien:

    Durch einen Standard können beispielsweise Grafiken vorgegeben sein, die in den individuell erstellten Projekten verwendet werden müssen. Diese können global zur Verfügung gestellt werden.

  • Schablonen:

    Festlegen der Prozessbild-Anordnung und Größe der zu entwickelnden Projekte. In einer Richtlinie könnte beispielsweise klar festgelegt werden, dass in einem Projekt, neu angelegte Bilder nur über Schablonen eines Globalprojekts angelegt werden. Somit wird eine globale, grafische Einheitlichkeit gewährleistet.

  • Schriften und Farbpaletten:

    Um eine Einheitlichkeit bei dargestellten Texten und Farben zu erreichen, kann ein vordefinierter Satz von Schriftlisten bzw. Farbpaletten zur globalen Verwendung festgelegt werden.

  • Sprachtabellen:

    Wird durch einen Standard ein festgelegter Satz an zu verwendeten Begriffen und Aussagen in der Projektierung festgelegt, so ist es möglich diese über die definierten Sprachtabellen festzulegen und gleichzeitig die entsprechenden Übersetzungen durchzuführen.

Beispiel

Eine zentrale Projektierungsstelle definiert Standards in den Bereichen Farben, Schriften, Schablonen usw. über ein Globalprojekt für alle Projektanten. Das Globalprojekt wird als Projekt-Backup an alle Teams verteilt. Diese importieren es in ihren Arebitsbereich. Über eine Richtlinie muss klar festgelegt werden, dass lokale Projektierungsstellen keine Änderungen an einem Globalprojekt vornehmen dürfen, da diese immer wieder durch das Einspielen von Aktualisierungen der zentralen Projektierungsstelle überschrieben werden.

Beispiel Anlagenmodell

Ein einfaches Anlagenmodell, das nur eine Unterscheidung zwischen einer zentralen und einer lokalen Projektierungsgruppe trifft. In einem individualisierten Projekt könnte man sich diese Unterscheidung nun bei der Visualisierung im Editor zur Hilfe nehmen. Im Detail würde das so aussehen, dass jedes projektierte Elemente im Editor mit einer entsprechenden Anlagengruppen Zuordnung versehen wird.

Die vorhandenen Prozessbilder werden nach Anlagenzuordnung angezeigt.

Damit kann eine lokale Projektierungsstelle klar erkennen, welcher Bilder wieder von einer zentralen Projektierungsstelle über den XML Import aktualisiert werden. Für den lokalen Projektanten ist damit auch klar, welche Bilder er nicht verändern darf. Denn jede Änderung an global gewarteten Bildern wird beim nächsten Update wieder überschrieben.

Tipp: Für die Aktualisierung eines Globalprojekts muss nicht immer ein komplettes Projekt-Backup erstellt und importiert werden. Einzelne Änderungen können auch über den Export und Import per XML lokal aktualisiert werden.


XML

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> XML

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Import und Export über die XML-Schnittstelle bietet vielfältige Möglichkeiten zur Wiederverwendung von Projektteilen.

attention Achtung

Beim Import werden vorhandene Elemente mit gleichem Namen überschrieben.

Abhängigkeiten beim Import

Wenn mehrere Projektteile importiert werden sollen, gibt es dementsprechend auch mehrere XML Dateien mit unterschiedlichen Inhalten. Um alle Inhalte mehrerer XML-Dateien korrekt zu übernehmen, müssen vorhandene Abhängigkeiten berücksichtigt werden:

Wird zum Beispiel ein Bild importiert und die darin verknüpften Variablen existieren im Projekt nicht, dann kann die Verknüpfung nicht wiederhergestellt werden. Um alle Verknüpfungen korrekt anzulegen, kann es nötig sein, den Import eines Bildes oder von Variablen zweimal durchzuführen.

Beispiel für Bild XML:

Die umfangreichste Variante ist, ein Bild zu exportieren, da die erzeugte XML-Datei nicht nur das Bild und die enthaltenen Elemente sondern auch die Schablone, verknüpfte Variablen und Funktionen beinhaltet, also alles, was im Bild zu sehen und direkt verknüpft ist.

Im Bild „A" wird mittels Button eine Funktion „B" ausgeführt, um wiederum das Bild „A" zu öffnen:

  • Die Funktion „B" benötigt das Bild „A", damit dieses in der Funktion „B" verknüpft wird.
  • Das Bild „A" wiederum benötigt die Funktion „B", damit diese am Button verknüpft wird.

Man muss also:

  1. erst die Funktion importieren,
  2. danach das Bild und dann
  3. ein weiters mal dieselbe Funktion, da andernfalls der Bezug zum Bild in der Funktion nicht hergestellt werden kann.

Projekte werksübergreifende vereinheitlichen

Der XML-Export/Import eignet sich auch dazu, um die werksübergreifende Einheitlichkeit von Projekten zu gewährleisten. Legt ein Unternehmen fest, dass bestimmte Projektteile weltweit einheitlich ausgelegt sein müssen, dann werden die einheitlichen Elemente:

  1. zentral projektiert
  2. in eine XML Datei exportiert
  3. als XML-Datei verteilt
  4. von jedem lokalen Team per XML-Import übernommen

Alternativ kann der Export und Import auch über einen eigenen Wizard erfolgen.

Da beim XML-Import bestehende Elemente überschrieben werden, müssen diese einheitlichen Elemente klar und verbindlich benannt werden. Lokale Änderungen dieser Elemente werden beim nächsten Import wieder überschrieben.

Wizards

Um den Benutzer beim Importieren zu unterstützten, bietet sich ein auf der zenon API basierende Wizard an. Im Wizard kann der Benutzer dann an Hand von Entscheidungshilfen auswählen, was importiert werden soll. Ein möglicher Ansatz für diesen Wizard ist, sich eine XML-Bibliothek anzulegen, die verschiedene Varianten von Bildern und Funktionalitäten als einzelne Dateien beinhaltet.

Individualisierung per Wizard

Über einen Wizard können auch Standardfunktionen, die im XML-Format vorliegen, individualisiert werden. Es wird eine Funktion per XML importiert und im Anschluss über die Änderung von bestimmten Eigenschaften, die nicht für jedes Objekt gleich sind, an die individuellen Anforderungen angepasst. Zum Beispiel kann eine Bildumschaltfunktion im XML-Format vorliegen und über eine Individualisierung der Eigenschaften mehrfach verwendet werden.


Wizards

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Wizards

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Wiederverwendung von Elementen und Teilen von Projekten kann mit Wizards vereinfacht und unterstützt werden. Wizards eigen sich zum Beispiel vor allem für:

  • Erstellung von Vorlage-Projekten:

    Ein Wizard ermöglicht es, bestimmte Standardteile eines neu zu erstellenden Projekts mittels weniger Mausklicks zu erzeugt. Im Gegensatz zum simplen Einspielen einer fertigen Projektsicherung des Vorlage-Projekts, gibt man hier dem Projektanten mehr Spielraum zur Individualisierung.

    Zum Beispiel könnte ein Wizard maschinenabhängig unterschiedliche Projekttypen erzeugen.

  • Erstellung von vordefinierten Projektteilen:

    Wizards können auch helfen, bestimmte Bereiche in einem Projekt zu erstellen.

    Zum Beispiel: Anlegen eines Projektbereichs „Motor".
    Der Wizard legt die für diesen Bereich vordefinierten Elemente an. Damit können mit wenigen Mausklicks können entsprechende Bilder, Funktionen, Variablen usw. projektiert werden. Neben den kürzeren Projektierungszeiten erreicht man gleichzeitig ein einheitliches Aussehen, da die Wizards von einer zentralen Projektierungsstelle programmiert und von den lokalen Projektierungsstellen verwendet werden.

  • Projektierung über vordefinierte Datenbanken bzw. Dateien:

    Auch Projektdatenbanken oder vordefinierte Dateien können die Projekterstellung oder Projekterweiterung unterstützen. Dabei werden in einer Datenbank oder in einer Excel-Datei die zu projektierenden Elemente beschrieben (Funktionsname, Funktionstyp, Funktionsparameter, Variablenname, Offset …). Mit Hilfe eines Wizards werden diese ausgelesen und entsprechende Projektierungen in zenon vorgenommen.

Mehr über Wizards und deren Erstellung lesen Sie im Handbuch Wizards.


Projekte wiederverwenden

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Projekte wiederverwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekte könne auch unterschiedliche weise wiederverwendet werden. Dabei spielen Mechanismen aus den anderen Kapitel der Wiederverwendbarkeit teilweise eine wesentliche Rolle.

Projektsicherung

Speichern unter

Mehrprojektverwaltung

Noch in diesem Kapitel

Projektsicherung

Speichern unter

Mehrprojektverwaltung


Projektsicherung

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Projekte wiederverwenden -> Projektsicherung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projektsicherungen ermöglichen es, komplette Projekte zu übernehmen.

Zum Beispiel kann ein Projekt als Vorlage an alle Teams verteilt werden. Diese spielen die Projektsicherung ein und individualisieren das Projekt.

attention Achtung

Diese Methode eignet sich nicht zum Übertragen von Projektänderungen, da bei der Übernahme sämtliche lokale Projektierungen überschrieben werden.

Um Projekte, die auf diese Weise erstellt wurden teamübergreifend zu warten, empfiehlt sich die Verwendung des XML-Exports/Imports.

Beachten Sie dabei, dass bereits vorhandene Elemente mit gleichem Namen beim Import überschrieben werden! Bei der Projektierung muss also klar gekennzeichnet werden, welche projektierten Elemente beim Import überschrieben werden dürfen. Für die dazu nötige Identifikationeigent sich zum Beispiel ein entsprechender Zusatz im Elementnamen oder die Vorgehensweise über Anlagengruppen siehe Abschnitt Globalprojekt.


Speichern unter

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Projekte wiederverwenden -> Speichern unter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Speichern unter erstellt im aktiven Arbeitsbereich eine Kopie eines Projekts unter neuem Namen und mit neuer GUID.

Beispiel

Auf Basis eines Vorlage-Projekts sollen individuelle Projekte für unterschiedliche Maschinentypen erstellt werden. Dazu:

  1. wird die Projektsicherung des Vorlage-Projekts eingespielt
  2. werden über Speichern unter im aktiven Arbeitsbereich mehrere unterschiedliche benannte Projekte erstellt (z.B. Maschine 1, Maschine 2, … )

Damit hat jedes Maschinenprojekt dieselbe Projekt-Ausgangssituation. Die Projekte haben allerdings keinerlei Verbindung mehr zum Vorlage-Projekt. Änderungen, die im Vorlage-Projekt durchgeführt werden, werden nicht automatisch in die kopierten Projekte übernommen. Änderungen in der Vorlage können aber per XML Export-/Import in die individualisierten Projekte eingespielt werden.

Beachten Sie dabei, dass bereits vorhandene Elemente mit gleichem Namen beim Import überschrieben werden! Bei der Projektierung muss also klar gekennzeichnet werden, welche projektierten Elemente beim Import überschrieben werden dürfen. Für die dazu nötige Identifikationeigent sich zum Beispiel ein entsprechender Zusatz im Elementnamen oder die Vorgehensweise über Anlagengruppen siehe Abschnitt Globalprojekt.


Mehrprojektverwaltung

Handbuch -> Effizient projektieren mit zenon -> Elemente wiederverwenden -> Projekte wiederverwenden -> Mehrprojektverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekte können in der zenon Mehrprojektverwaltung auch in einem Arbeitsbereich unter dem Dach eines Integrationsprojekts zusammengefasst werden. So kann ein Projekt zentral verändert werden, während lokale Projektierungen in einem anderen Projekt vorgenommen werden.

Beispiel

Über eine zentrale Projektierungsstelle solle die grafische Wiederverwendung in lokalen Projekten realisiert werden, um weltweit eine einheitliche Oberfläche sicherzustellen. Dazu erstellt die zentrale Projektierung ein Vorlage-Projekt, das die grafische Grundlage für alle anderen Projektierungsteams darstellt.Wird aber an der zentralen Stelle eine Änderung der Oberflächengestaltung durchgeführt, so muss diese an allen Projektierungsstellen nachgezogen werden. Das kann über die Mehrprojektverwaltung erfolgen: ein Projekt enthält die zentral zu verwaltenden Elemente, ein anderes Projekt die lokale Projektierung.

Vorgangsweise:

  1. initial wird eine Vorlage-Projekt an alle Projektierungsteams geschickt
  2. dieses wird in den aktiven Arbeitsbereich eingespielt wird
  3. es wird lokal ein zweites, leeres Projekt angelegt, das die spezifischen Anpassungen enthält
  4. im Arbeitsbereich existieren jetzt zwei Projekte: das Vorlage-Projekt und das individualisierte Projekt
  5. im nächsten Schritt erfolgt die multi-hierarchische Anordnung der Projekte
  6. das Vorlage-Projekt wird zum Integrationsprojekt, das individualisierte Projekt zum Unterprojekt

info Info

Diese Methode ist für Projekte, die unter Windows CE laufen sollen, nicht geeignet, da unter CE immer nur ein Projekt gestartet werden kann.


Integriertes Netzwerk

Handbuch -> Effizient projektieren mit zenon -> Integriertes Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verteiltes Engineering im Netzwerk und 100% Redundanz sind mit zenon kein besonderer Aufwand mehr für Sie. Netzwerke erstellen Sie durch Aktivieren der entsprechenden Checkbox bei den Projekteigenschaften. Und genau so einfach machen Sie aus vereinzelten stand alone Projekten effizient vernetzte, redundante Systeme.

Wenn Sie über ein TCP/IP-Windows-Netzwerk verfügen, stehen Ihnen in zenon automatisch Netzwerkfunktionen auf Mausklick zur Verfügung, als Client/Server Modell oder als multihierarchisches System mit Unterstationen, Bereichszentralen und Zentralen. Sie

  • erstellen Projekte auch mit mehreren Anwendern gleichzeitig im Netzwerk
  • sichern Anlagen durch die 100% zenon Kreisredundanz perfekt ab
  • bauen problemlos verteilte Systeme auf
  • greifen remote auf Stationen zu
  • überwachen und steuern Anlagen per Web-Server
  • sehen Prozessdaten auf allen Stationen in Echtzeit
  • machen Aktionen eines Arbeitsplatzes auf allen anderen sichtbar, z. B. das Quittieren von Alarmen
  • lassen Aktionen zentral protokollieren und archivieren
  • nutzen Prozessdaten sofort für ERP-Systeme wie SAP

Um die unbedingt nötige Zeitsynchronität aller beteiligten Rechner kümmert sich zenon automatisch.


Alarmverwaltung

Handbuch -> Alarmverwaltung

Die Alarmverwaltung informiert über auftretende Fehler wie das Überschreiten von Grenzwerten. Sie setzt sich zusammen aus:

  1. Alarmstatuszeile:
    Informationszeile, die zur Runtime immer im Vordergrund dargestellt wird und je nach Projektierung den jüngsten oder ältesten unquittierten Alarm enthält.
  2. Alarmmeldeliste (AML):
    Verwaltet zur Runtime die Alarme in einer Liste. Die AML:
    • zeigt Alarme und deren Ursachen in einer Liste ungefiltert oder gefiltert an
    • ermöglicht Lokalisierung der Alarmursache
    • ermöglicht Quittierung von Alarmen
    • ermöglicht das Löschen von Alarmen
    • ermöglicht Ausdruck und Speicherung von Alarmen

Alarme konfigurieren Sie über:

  • Einstellung von Grenzwerten für Variablen
  • mit Reaktionsmatrizen
  • Eigenschaften der Alarme

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Alarme projektieren

Bedienen zur Runtime


Alarme projektieren

Handbuch -> Alarmverwaltung -> Alarme projektieren

Die Bedienung der Alarmverwaltung erfolgt zur Runtime über Bilder vom Typ Alarmmeldeliste und Alarmmeldeliste Filter sowie die Alarmstatuszeile. Die Alarmstatuszeile wird automatisch als Schablone angelegt.

Editor

Um Alarme zur Runtime bedienen zu können, müssen im Editor:

  • ein Bild vom Typ Alarmmeldeliste projektiert werden
  • Grenzwertverletzungen von Variablen oder Reaktionsmatrizen definiert werden

Zusätzlich können Sie:

  • Alarme über Filter projektieren
  • Alarme gruppieren
  • mit einem Bild vom Typ Alarmmeldeliste Filter die zur Runtime verfügbaren Filter anpassen

Runtime

Für die Bedienung zur Runtime werden genutzt:

  • Bildumschaltung AML
  • Bildumschaltung AML Filter
  • die zenon Alarm-Funktionen
  • Bild vom Typ Alarmmeldeliste Filter benutzen
  • Alarmstatuszeile

Noch in diesem Kapitel

Bild vom Typ Alarmmeldeliste anlegen

Bild vom Typ Alarmmeldeliste Filter anlegen

Alarme definieren

Alarmbehandlung

Gruppierung von Alarmen

Alarmprojektierung über Filter

Funktionen


Bild vom Typ Alarmmeldeliste anlegen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Bild vom Typ Alarmmeldeliste anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Bild vom Typ Alarmmeldeliste ermöglicht, zur Runtime anstehende und gegangene Alarme anzuzeigen und zu protokollieren. Die Anzeige kann über Filter verändert werden. Funktionen ermöglichen den Export und den Druck der angezeigten Alarme.

Bild vom Typ Alarmmeldeliste Filter anlegen

Um ein Bild vom Typ Alarmmeldeliste anzulegen:

  1. wählen Sie in der Symbolleiste oder im Kontextmenü des Knotens Bilder den Befehl Bild neu
  2. ein leeres Bild vom Typ Standard wird aufgeschaltet
  3. ändern Sie in der Detailansicht den Bildtyp, dazu
    1. klicken Sie in der Spalte Bildtyp auf Standard
    2. wählen Sie in der Dropdownliste den Eintrag Alarmmeldeliste aus
  4. klicken Sie in das Bild
  5. wählen Sie in der Menüleiste den Menüpunkt Kontrollelemente
  6. klicken Sie in der Dropdownliste auf Vorlage einfügen
  7. die Standard-Elemente werden eingefügt
  8. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diesen am gewünschten Platz im Bild ein
  9. legen Sie eine Bildumschaltfunktion an, um die AML zur Runtime aufrufen zu können

Folgende Elemente stehen zur Verfügung:

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Alarmmeldeliste

Anzeige der Alarme. Das Aussehen ist konfigurierbar. Spalten werden über den Filter Spalteneinstellungen bei der Bildumschaltung festgelegt oder über die Eigenschaft Spalteneinstellung AML in den Projekteigenschaften in der Gruppe Alarmmeldeliste.

Interne ID: Bild vom Typ Alarmmeldeliste anlegen

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bild vom Typ Alarmmeldeliste anlegen

Spalteneinstellung AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

Interne ID: Bild vom Typ Alarmmeldeliste anlegen

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Anzeige: Eingestellter Filter

Anzeige der aktuell gewählten Filterbedingungen.

Filter...

Öffnet Dialogs zur Filterauswahl.

Quittieren/Löschen

Gruppe der Buttons für quittieren und löschen von Alarmen
  • Quittieren

Alarmmeldungen zur Runtime quittieren.
  • Seite quittieren

Alle auf der aktuellen Seite angezeigten Alarme werden quittiert.
  • Alle quittieren

Alle dem aktuellen Filterkriterium entsprechenden Alarme werden quittiert.

Hinweis Mehrbenutzer-Projekt: Es werden nur die Alarme jenes Projektes quittiert, für die der Benutzer die Berechtigung dazu besitzt. (Details Mehrbenutzer-Projekt siehe Kapitel Verteiltes Engineering)

  • Löschen

Löscht Alarm zur Runtime aus der Alarmmeldeliste. Alarm muss bereits quittiert sein.
  • Seite löschen

Löscht alle quittierten Alarme, die auf der aktuellen Seite angezeigt werden.
  • Alle löschen

Löscht alle quittierten Alarme, die dem aktuellen Filterkriterium entsprechen.

Stopp/Weiter

Schalter für Befüllung der Liste:

Stopp: Neue Elemente werden nicht mehr automatisch hinzugefügt.

Weiter: Neue Elemente werden automatisch hinzugefügt.

Achtung: Beschriftung des Buttons kann im Editor zwar geändert werden, wird zur Runtime aber nicht übernommen. Änderungen der Beschriftung projektieren Sie über die Sprachumschaltung.

Schließen

Schließt Alarmmeldeliste

Drucken

Druckt gefilterte Liste.

Drucken mit Dialog...

Öffnet vor dem Drucken die Druckereinstellungen.

Anzeige: Verknüpfte Funktion

Zeigt die der Alarmmeldung zugeordnete Funktion an.

Funktion ausführen

Führt zur Runtime die am Alarm projektierte Funktion aus.

Hinweis: Bei der Funktion Starte Programm kann der Variablenname des selektierten Alarms als Parameter für das zu startende Programm über das Schlüsselwort @alarm.name übergeben werden.

Hilfe aufrufen

Ruft projektierte Hilfe auf.

Anzeigen

Status und Elemente der Alarmverwaltung.
  • Anzahl gesamt

Zeit Anzahl aller Alarme.
  • Anzahl unquittiert

Zeigt Zahl unquittierter Alarme.
  • Info: Status Alarmmeldeliste

Anzeige, ob Alarmmeldeliste aktiv ist oder nicht (Projekt-Eigenschaft Alarmmeldeliste aktiv).
  • Kommentarfeld

Eingabe eines freien Textes (Kommentar) durch den Benutzer für den selektierten Alarm. Dieser Text kann in der Liste mit angezeigt werden (Option Kommentar in den Spalteneinstellungen der Alarmverwaltung.)

Navigation

Steuert Elemente der Liste.
  • Zeile nach oben

Blättert eine Zeile nach oben.
  • Zeile nach unten

Blättert eine Zeile nach unten.
  • Spalte nach rechts

Blättert eine Spalte nach rechts.
  • Spalte nach links

Blättert eine Spalte nach links.
  • Seite nach oben

Blättert eine Seite nach oben.
  • Seite nach unten

Blättert eine Seite nach unten.
  • Seite nach rechts

Blättert eine Seite nach rechts.
  • Seite nach links

Blättert eine Seite nach links.

Filterprofile

Filtereinstellungen, die der Anwender in der Runtime speichern kann.

  • Profilauswahl

Profil aus Liste auswählen.
  • Speichern

Speichert aktuelle Einstellung als Profil.
  • Löschen

Löscht ausgewähltes Profil.

info Info

Im Kontrollelement Filter anzeigen wird der aktuelle Filter angezeigt.

Bei einem:

  • Textfilter wird der Ausdruck [Txt] angezeigt
  • Relativzeitfilter wird ein Ausdruck nach folgendem Schema angezeigt:
    [T,Rel:%dd,%dh,%dm;%ds]
    Beispiel: [T,Rel:1d,0h,0m,0s] entspricht einem Tag.

Noch in diesem Kapitel

Aussehen der AML anpassen


Aussehen der AML anpassen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Bild vom Typ Alarmmeldeliste anlegen -> Aussehen der AML anpassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die tabellarischen Darstellung der Alarmmeldeliste kann an individuelle Vorgaben angepasst werden:

Bildlaufleisten, Kopfzeile und Raster

Um Größe und Aussehen von Bildlaufleisten, der Kopfzeile und eines Rasters für die Tabelle zu definieren:

  1. aktivieren Sie in den Projekteigenschaft in der Gruppe Darstellung die Eigenschaft Erweiterte grafische Einstellungen

    Interne ID: Aussehen der AML anpassen

    Erweiterte grafische Einstellungen

    Nur für PC verfügbar.

    Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

    Default: inaktiv.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der AML anpassen

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie die gewünschten Eigenschaften in den Gruppen Bildlaufleisten und Kopfzeile und Raster für das Element Alarmmeldeliste im Bild

    Interne ID: Aussehen der AML anpassen

    Kopfzeile und Raster

    Eigenschaften für die Kopfzeile und das Raster.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der AML anpassen

    Bildlaufleisten

    Eigenschaften für die horizontalen und vertikalen Bildlaufleisten.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wird für die Eigenschaft Anzeigestil Grafikdateien gewählt, dann werden alle Elemente, für die keine Grafikdatei ausgewählt wird, mit einem Farbverlauf dargestellt. Bei Steuerelementen für Listen können keine transparenten Grafiken verwendet werden.

Interne ID: Aussehen der AML anpassen

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: Aussehen der AML anpassen

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: Aussehen der AML anpassen

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der AML anpassen

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: Aussehen der AML anpassen

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der AML anpassen

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Aussehen der AML anpassen

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: Aussehen der AML anpassen

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: Aussehen der AML anpassen

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der AML anpassen

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zur Runtime sortieren

Um zur Runtime die für die Sortierung relevante Spalte zu kennzeichnen und die Sortierreihenfolge zu bestimmen, projektieren Sie grafische Elemente für die Titelzeile:

  1. wählen Sie für die Eigenschaft Anzeigestil den Wert Grafikdateien
  2. verknüpfen Sie die Eigenschaften Aufsteigend sortiert und Absteigend sortiert jeweils mit einer Grafikdatei

    Interne ID: Aussehen der AML anpassen

    Absteigend sortiert

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für absteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

    Interne ID: Aussehen der AML anpassen

    Anzeigestil

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

    Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

    Interne ID: Aussehen der AML anpassen

    Winkel [°]

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

    Minimum: 0

    Maximum: 360

    Default: 0

    Mehr im Online-Handbuch AML.

    Mehr im Online-Handbuch CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der AML anpassen

    Versatz [%]

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

    Minimum: -100

    Maximum: 100

    Default: 0

    Mehr im Online-Handbuch AML.

    Mehr im Online-Handbuch CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der AML anpassen

    Farbverlauf

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

    Linear: gleichmäßiger Verlauf

    Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

    Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

    Default: Linear

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der AML anpassen

    Verlaufsfarbe

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

    Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der AML anpassen

    Füllfarbe

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

    Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

    Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

    Default: Standard.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Default: keine Datei

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der AML anpassen

    Aufsteigend sortiert

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für aufsteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

    Default: keine Datei

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. zur Runtime wird in der für die Sortierung relevanten Spalte die gewählte Grafik für die jeweilige Sortierrichtung angezeigt
  4. Klick auf Grafik ändert Sortierreihenfolge
  5. Klicke in Spaltentitel aktiviert Spalte für Sortierung

Kopfzeile zur Runtime bedienen

Sie können Benutzern ermöglichen, die Kopfzeile zur Runtime zu bedienen. Dadurch ist eine individuelle Anpassung der Darstellung in der Runtime möglich:

  • Spalten verschieben
  • Größe ändern
  • Sortierung ändern.

Navigieren Sie dazu in den Projekteinstellungen zur Gruppe Alarmmeldeliste und wählen Sie bei der Eigenschaft Kopfzeile AML den Wert bedienbare Kopfzeile. Alternativ können Sie hier die Kopfzeile auch unbedienbar oder unsichtbar schalten.

Diese Einstellungen gelten für alle Kopfzeilen im Projekt.

info Info

Sie können die Bedienbarkeit bzw. die Sichtbarkeit der Kopfzeile für jedes Bild vom Typ Alarmmeldeliste individuell wieder unterbinden, indem Sie die Eigenschaft Kopfzeile anzeigen bzw. Kopfzeile bedienbar für die tabellarische Darstellung deaktivieren.

Interne ID: Aussehen der AML anpassen

Kopfzeile bedienbar

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile selektiert haben.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Ermöglicht es die Kopfzeile für das entsprechende Listenfeld zu bedienen. Zur Runtime können Sie die einzelnen Spalten verschieben und ihre Breite verändern. Sie könne die Darstellung nach einer beliebigen Spalte sortieren.

aktiv: Die Kopfzeile ist bedienbar.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Vorschau

Mit Aktivierung der Eigenschaft Erweiterte grafische Einstellungen werden im Editor die Kopfzeile und die Bildlaufleisten als Vorschau angezeigt.So lassen sich Details wie Farben Fülleffekte, Lichteffekte oder Raster einfacher projektieren.

Achtung: Da die Größe der Bildlaufleisten in der Vorschau der Größe zur Runtime entspricht, kann die gesamte Größe des Liste im Editor von der Größe zur Runtime abweichen. Das gilt auch für die Größe der Kopfzeile und die Schrift der Kopfzeile.


Bild vom Typ Alarmmeldeliste Filter anlegen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Bild vom Typ Alarmmeldeliste Filter anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ Alarmmeldeliste Filter ermöglicht es, zur Runtime individualisierte Filtereinstellungen für die Alarmmeldeliste vorzunehmen. Es werden nur die benötigen Filter projektiert und dem Benutzer zur Verfügung gestellt. Das Aussehen lässt sich frei definieren und damit an unterschiedliche Endgeräte anpassen. Es können alle Filtereinstellungen, die auch im Filter für die Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste vorhanden sind, projektiert werden.

Damit:

  • werden nur die wirklich benötigten Filterelemente projektiert und dem Benutzer zur Verfügung gestellt
  • bekommt der Benutzer nur diese Filter angezeigt und gewinnt Übersicht
  • kann das Aussehen völlig frei definiert werden und so zum Beispiel auch eine leichte Bedienung über einen Touchscreen realisiert werden

Details zur Handhabung zur Runtime, siehe Abschnitt Alarmmeldeliste Filter benutzen.

Definition der Filterkriterien, siehe Abschnitt Filter Alarmmeldeliste Filter.

attention Achtung

Bilder vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter und Zeitfilter müssen mit einer eigenen Schablone projektiert werden. Besitzen sie die gleiche Schablone wie andere Bilder werden zur Runtime beim Schließen des Bildes alle auf dieser Schablone basierenden Bilder ebenfalls geschlossen.

Bild vom Typ Alarmmeldeliste Filter anlegen

Um ein Bild vom Typ Alarmmeldeliste Filter anzulegen:

  1. wählen Sie in der Symbolleiste oder im Kontextmenü des Knotens Bilder den Befehl Bild neu
  2. ein leeres Bild vom Typ Standard wird aufgeschaltet
  3. ändern Sie in der Detailansicht den Bildtyp, dazu
    1. klicken Sie in der Spalte Bildtyp auf Standard
    2. wählen Sie in der Dropdownliste den Eintrag Alarmmeldeliste Filter aus
  4. wählen Sie eine eigene Schablone
    (AML Filter darf nicht auf derselben Schablone wie andere Bilder basieren)
  5. klicken Sie in das Bild
  6. wählen Sie in der Menüleiste den Menüpunkt Kontrollelemente
  7. klicken Sie in der Dropdownliste auf Vorlage einfügen
  8. der Dialog zur Auswahl einer Vorlage wird geöffnet
  9. wählen Sie die gewünschte Vorlage aus
  10. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diesen am gewünschten Platz im Bild ein
  11. legen Sie eine Bildumschaltfunktion an, um das Bild zur Runtime aufrufen zu können

Elemente

Das Bild vom Typ Alarmmeldeliste Filter kann folgende Steuer- und Anzeigeelemente enthalten.

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Allgemeine Filter

Dropdownliste verschiedener allgemeiner Filter.

Alle Elemente einfügen: Allgemeine Filter

Fügt alle Elemente aus dem Bereich Allgemeine Filter an vordefinierten Plätzen ein. Elemente können individuell angeordnet werden.

Variablenfilter

Alarme welcher Variablen werden angezeigt:
  • Variablenname

Filtern nach Namen der Variablen.
  • Kennung

Filtern nach Kennung der Variablen.
  • Groß-/Kleinschreibung beachten

Groß- und Kleinschreibung bei der Filterung der Variablen beachten.

Alarmart

Welche Alarme werden angezeigt:
  • Nur nicht quittierte Alarme

nur nicht quittierte
  • Nur gegangene Alarme

nur gegangene
  • Nur anstehende Alarme

nur anstehende
  • Kommentar erforderlich

Alarme, deren Quittierung einen Kommentar erfordert
  • Mindestzeit anstehende Alarme - Tage

Nur Alarme, die mindestens seit der angegeben Zahl von Tagen anstehen.
  • Mindestzeit anstehende Alarme - Stunden

Nur Alarme, die mindestens seit der angegeben Zahl von Stunden anstehen.
  • Mindestzeit anstehende Alarme - Minuten

Nur Alarme, die mindestens seit der angegeben Zahl von Minuten anstehen.
  • Mindestzeit anstehende Alarme - Sekunden

Nur Alarme, die mindestens seit der angegeben Zahl von Sekunden anstehen.
  • Mindestzeit anstehende Alarme - Millisekunden

Nur Alarme, die mindestens seit der angegeben Zahl von Millisekunden anstehen.

Datenherkunft

Woher stammen die Daten:
  • Ringpuffer

Aus dem Ringpuffer.
  • Historische Daten

Aus einem Archiv.
  • Beschriftung: Maximale Anzahl

Text für Eingabefeld Maximale Anzahl

  • Eingabefeld: Maximale Anzahl

Eingabe der maximal anzuzeigenden Alarme bei Anzeige historischer Alarme.

0: zeigt alle an

Runtime Einstellungen

  • Liste angehalten aufschalten

Schaltet die AML in angehaltenem Zustand auf. Neue Alarme werden nicht hinzugefügt.

Alarm/Ereignis-Gruppen/Alarm/Ereignis-Klassen/Alarmbereiche

Listenfelder für gruppierte Anzeige:
  • Alarm/Ereignis-Gruppen

Alarm/Ereignis-Gruppen
  • Alarm/Ereignis-Klassen

Alarm/Ereignis-Klassen
  • Alarmbereiche

Alarmbereiche

Zeitfilter

Dropdownliste verschiedener Zeitfilter.

Alle Elemente einfügen: Absoluter Zeitraum - klassische Darstellung

Fügt alle Elemente für die Definition absoluter Zeiträume ein: Jedes Element erhält ein eigenes Feld.

Alle Elemente einfügen: Absoluter Zeitraum - kleine Darstellung

Fügt Elemente für die Definition absoluter Zeiträume in kompakter Darstellung ein.

Alle Elemente einfügen: Relativer Zeitraum

Fügt alle Elemente für die Definition relativer Zeiträume ein.

Alle Elemente einfügen: Ab HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag, Monat - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Monat-Stunden-Minuten-Sekunden ein.

Beschriftung: Zeitfiltertyp

Beschriftung für Typ des Zeitfilters.

Combobox: Zeitfiltertyp

Combobox Zeitfilterty.

Anzeige: Zeitfiltertyp

Feld für Anzeige Zeitfiltertyp.

Zeit von

Felder und Beschriftungen für Angaben "Von"-Zeit.
  • Beschriftung: Von Jahr

  • Combobox: Von Jahr

  • Beschriftung: Von Monat

  • Combobox: Von Monat

  • Beschriftung: Von Tag

  • Combobox: Von Tag

  • Beschriftung: Von Stunde

  • Combobox: Von Stunde

  • Beschriftung: Von Minute

  • Combobox: Von Minute

  • Beschriftung: Von Sekunde

  • Combobox: Von Sekunde

  • Spincontrol: Von

Zeit bis

Felder und Beschriftungen für Angaben "Bis"-Zeit.
  • Beschriftung: Bis Jahr

  • Combobox: Bis Jahr

  • Beschriftung: Bis Monat

  • Combobox: Bis Monat

  • Beschriftung: Bis Tag

  • Combobox: Bis Tag

  • Beschriftung: Bis Stunde

  • Combobox: Bis Stunde

  • Beschriftung: Bis Minute

  • Combobox: Bis Minute

  • Beschriftung: Bis Sekunde

  • Combobox: Bis Sekunde

  • Spincontrol: Bis

Absolutzeitfilter

Felder und Beschriftungen für Angaben absoluter Zeitfilter.
  • Beschriftung: Von

  • Kalenderanzeige: Von Datum

  • Datumsanzeige: Von Datum

  • Zeitanzeige: Von Zeit

  • Beschriftung: Bis

  • Kalenderanzeige: Bis Datum

  • Datumsanzeige: Bis Datum

  • Zeitanzeige: Bis Zeit

Textfilter

Dropdownliste verschiedener Textfilter.

Alle Elemente einfügen: Textfilter

Fügt alle Elemente für Textfilter ein.

Kein Textfilter

Radiobutton für Abwahl Textfilter.

Suchen nach (Wörter getrennt durch Leerzeichen)

Radiobutton für Aktvierung der Suche

Beschriftung: Suchtext

Beschriftung für Suchfeld.

Eingabefeld: Suchtext

Feld für Eingabe der Suchbegriffe.

Optionen

Optionen für Suche
  • Groß-/Kleinschreibung beachten

Groß-/Kleinschreibung muss beachtet werden.
  • Wörter müssen nicht vollständig im Text vorkommen

Es wird auch nach Fragmenten gesucht.
  • Mindestens ein Wort muss im Text vorkommen

Mindestens ein Suchbegriff von mehreren muss im Ergebnis enthalten sein.
  • Alle Wörter müssen im Text vorkommen

Alle Suichbegriffe müssen im Ergebnis enthalten sein.
  • Filtertext muss exakt im Text vorkommen

Text aus dem Eingabefeld muss exakt im ergebnis enthalten sein.

OK

Eingaben übernehmen und Bild schließen.

Abbrechen

Eingaben verwerfen und Bild schließen.

Übernehmen

Eingaben übernehmen und bild für weitere Eingaben geöffnet lassen.

Aktualisieren

Bild aktualisieren.

Filterbilder

Filterbilder ermöglichen es, einen voreingestellten Filter von einem Bild auf ein anderes zu übertragen. Der Filter des Quellbildes wird über das Zielbild gelegt. Die Bilder können auch von unterschiedlichen Bildtypen sein.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.

Aufrufdefinition

Folgende Voraussetzungen müssen erfüllt sein, damit die eingestellten Filter zur Anwendung kommen:

  1. Als Zeitbereich beim Zeitfilter wird Filter beim Zeitfiltertyp einstellen gewählt.
  2. Das Bild (Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter oder Zeitfilter) wird mithilfe eines Buttons oder eines Combi-Elements aktiviert. Nur so wird der Bezug zwischen Filterbild und Quellbild gewährleistet.
  3. Das Quellbild und das Filterbild müssen auf unterschiedlichen Schablonen oder Monitoren projektiert sein. Nur wenn das Quellbild offen ist, kann der Filter für das Filterbild aktualisiert werden. Das ist nur möglich, wenn beide Bilder nicht dieselbe Schablone oder den selben Monitor verwenden.
  4. Das aufrufende Bild muss mit dem aufzurufenden Filterbild kompatibel sein (siehe Tabelle).
Quellbild | AML Filter | CEL Filter | Zeitfilter
Archiv-Nachbearbeitung | T | T | T
Erweiterter Trend | T | T | T
Zeitfilter | T | T | X
Alarmmeldeliste Filter | X | C | T
Chronologische Ereignisliste Filter | C | X | T
Alarmmeldeliste | X | C | T
Chronologische Ereignisliste | C | X | T

Legende:

  • C: Gemeinsame Einstellungen werden aktualisiert.
  • T: Zeiteinstellungen werden aktualisiert.
  • X: Alle Einstellungen werden aktualisiert.

info Info

Keine Filterung

Das Filterbild wird nicht gefiltert, sondern mit den projektierten Werten aufgeschaltet, wenn:

  • eine der Bedingungen 1 bis 3 nicht erfüllt wird oder
  • die Einstellung Aufrufendes Bild bei der Funktion Bildumschaltung nicht aktiviert ist oder
  • das Bild nicht über ein Bildelement aufgerufen wird

In diesem Fall werden zur Runtime die Buttons Übernehmen, Schließen und Aktualisieren ausgegraut dargestellt und haben keine Funktion.


Alarme definieren

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarme definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarme definieren Sie über:

  • Grenzwerte und Zustände bei Variablen
  • Reaktionsmatritzen

Alarmierung über Variablen

Definieren Sie Grenzwerte für Variablen (siehe Handbuch Variablen, Abschnitt Grenzwerte). Werden diese zur Runtime verletzt, wird ein Alarm generiert und in der Alarmstatuszeile angezeigt. Weitere Eigenschaften für die Alarmprojektierung konfigurieren Sie bei den:

  • Variablen-Eigenschaften der Gruppe Grenzwerte und den darin enthaltenen Untergruppen für jeden Grenzwert:

    Interne ID: Alarme definieren

    Grenzwerte

    Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

    Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

    Interne ID: Alarme definieren

    Reaktionsmatrix aktiv

    Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
    Inaktiv: Grenzwerte können für die Variable definiert werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • In Alarmmeldeliste: Der Alarm wird in die AML aufgenommen. Wann er dort wie angezeigt wird, steuern Sie zur Runtime über die Alarmmeldeliste oder eine Alarmmeldeliste Filter.

      Interne ID: Alarme definieren

      In Alarmmeldeliste

      Aktiv: Bei einer Grenzwertverletzung wird ein Eintrag in der Alarmmeldeliste erstellt.
      Inaktiv: In der Alarmmeldeliste wird kein Eintrag erstellt.
      Default: inaktiv

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Quittierpflichtig: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.

      Interne ID: Alarme definieren

      Quittierpflichtig

      Nur verfügbar für Alarme.
      Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
      Inaktiv: Keine Quittierung erforderlich.
      Default bei Alarmen: aktiv, sonst inaktiv

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Löschpflichtig: Der Alarm muss manuell gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.

      Interne ID: Alarme definieren

      Löschpflichtig

      Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
      Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
      Inaktiv: Kein Löschen erforderlich.
      Default: inaktiv

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Drucken: Druckt Alarm auf definiertem Drucker aus. Es wird entweder die CEL oder die AML gedruckt. Welche der beiden Listen gedruckt wird, legen Sie in den Projekteigenschaften unter Ausdruck für fest.

      Interne ID: Alarme definieren

      Ausdruck für

      Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
      Ermöglicht die Wahl, ob AMl oder CEL online gedruckt werden. Es kann immer nur eine der beiden Listen gedruckt werden.

      Interne ID: Alarme definieren

      Drucken aktiv

      Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
      Inaktiv: Kein Online-Ausdruck findet statt.
      Default: aktiv

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Alarmmeldeliste: Die Alarmmeldeliste (AML) wird online gedruckt.
      Chronologische Ereignisliste: Die Chronologische Ereignisliste (CEL) wird online gedruckt.
      Default: Alarmmeldeliste

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Alarme definieren

      Drucken

      Aktiv: Alarm oder Grenzwertverletzung wird für diese Variable je nach Einstellung in Eigenschaft Ausdruck für in der Gruppe AML und CEL der Prjekteigenschaften online gedruckt.
      Inaktiv: Kein Online-Ausdruck.
      Default: inaktiv

      Interne ID: Alarme definieren

      AML und CEL

      Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Alarm/Ereignis-Gruppe: Zuweisung einer Alarm/Ereignis-Gruppe.

      Interne ID: Alarme definieren

      Alarm/Ereignis-Gruppe

      Zuweisung einer Alarm/Ereignis-Gruppe (max. 65535) für den Grenzwert bei Verwendung als Alarm.
      Die Zuordnung zu einer Alarm/Ereignis-Gruppen erfolgt durch Selektion in der Liste.
      Default: 0 - (nicht verwendet).

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Alarm/Ereignis-Klasse: Zuweisung einer Alarm/Ereignis-Klasse.

      Interne ID: Alarme definieren

      Alarm/Ereignis-Klasse

      Zuweisung einer Alarm/Ereignis-Klasse (max. 65535) für den Grenzwert bei Verwendung als Alarm.
      Die Alarm/Ereignis-Klassenzuordnung erfolgt durch Selektion in der Liste.
      Default: 0 - (nicht verwendet).

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Variablen-Eigenschaften der Gruppe Alarmbehandlung:

    Interne ID: Alarme definieren

    Alarmbehandlung

    Eigenschaften für die Quittiervariable.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Alarmbereich: Zuweisung eines Alarmbereichs.

      Interne ID: Alarme definieren

      Alarmbereich

      Hier kann die Variable mit einem Alarmbereich verknüpft werden.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Quittiervariable: Setzt beim Quittieren des Alarms den Wert 0 oder 1 auf die hier definierte variable ab.

      Interne ID: Alarme definieren

      Quittiervariable

      Binärvariable: Wird ein Alarm der steuernden Variablen quittiert wird, wird der Wert der Quittiervariablen auf den unter Quittierwert definierten Wert gesetzt.

      Interne ID: Alarme definieren

      Quittierwert

      Wenn ein Alarm dieser Variable quittiert wird, wird die unter Quittiervariable ausgewählte Variable auf diesen Wert gesetzt.

      Auswahl 0 oder 1.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Quittierwert: Wert, der auf die in Quittiervariable definierte Variable ab.
    • In IPA-Datenbank speichern: Alarm steht im Industrial Performance Analyzer zur Auswertung zur Verfügung.

      Interne ID: Alarme definieren

      In IPA-Datenbank speichern

      Aktiv: Die Alarme dieser Variable sind für die Auswertung im Industrial Performance Analyzer (IPA) verfügbar.
      Inaktiv: Die Alarme dieser Variable werden bei der Auswertung im Industrial Performance Analyzer nicht berücksichtigt.
      Default: inaktiv

      Achtung: Der Industrial Performance Analyzer ist ein optionales Modul und muss lizenziert sein, um verwendet werden zu können.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Projekt-Eigenschaften der Gruppe AML und CEL:
    • Selektion mit Rahmen: Zur Runtime werden ausgewählte Zeilen werden durch einen Rahmen hervorgehoben.

      Interne ID: Alarme definieren

      Selektion mit Rahmen

      Aktiv: In der Alarmmeldeliste (AML) und der Chronologischen Ereignisliste (CEL) werden selektierte Zeilen durch mit einem Rahmen hervorgehoben. Empfohlen für bessere Lesbarkeit bei hohen Bildschirmauflösungen.
      Inaktiv: Die Hintergrundfarbe der selektierten Zeilen wird invertiert. Empfohlen für bessere Lesbarkeit bei niedrigen Bildschirmauflösungen.
      Default: inaktiv.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Selbe Kommentare: Kommentare, die zur Runtime zu einem Alarm eingegeben werden, werden auch in die CEL übernommen.

      Interne ID: Alarme definieren

      Selbe Kommentare

      Aktiv: Kommentare, die zur Runtime, zu einem Alarm hinzugefügt werden, werden auch beim dazugehörenden Eintrag der Chronologischen Ereignisliste (CEL) abgelegt.
      Inaktiv: Kommentare zu einem Alarm werden nur in der Alarmmeldeliste abgelegt.
      Default: inaktiv

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Drucken aktiv: Aktiviert den Online-Ausdruck.
    • Ausdruck für: Legt fest, ob AML oder CEL online gedruckt wird.
  • Projekt-Eigenschaften der Gruppe Alarmmeldeliste

    Interne ID: Alarme definieren

    Alarmmeldeliste

    Eigenschaften für die Alarmkonfiguration.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Hier stehen Ihnen vielfältige Eigenschaften zur Konfiguration von Alarmen zur Verfügung. Vor allem:

    • Aktivierung AML
    • Datenspeicherung AML
    • Signalisierung der Alarmzustände
    • Aktivierung der Alarmstatuszeile

    Details zu den einzelnen Einstellungen finden Sie in der Embedded Help direkt bei den Eigenschaften.

Alarmierung über Reaktionsmatritzen

Mit einer Reaktionsmatrix werten Sie definierte Grenzwertzustände und Statusbits aus (siehe Handbuch Variablen, Abschnitt Reaktionsmatritzen). Verletzungen der festgelegten Regeln führen zu einem Alarm. Wie bei Variablen direkt können Sie auch bei Reaktionsmatritzen das Verhalten bei Alarmierung definieren. Dazu aktivieren Sie die entsprechenden Eigenschaften im Konfigurationsdialog der Reaktionsmatritzen.


Alarmbehandlung

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarme werden, sobald sie auftreten, in einem Ringpuffer (alarm.bin) und einer Alarmdatei (*.aml) im Runtimeordner gespeichert.

Ringpuffer

Der Ringpuffer enthält alle anstehenden Alarme. Dabei werden verwaltet:

  • Zeit kommt in Millisekunden als eindeutige Signatur
  • weitere Informationen wie Ursache, Werte etc.
  • Zeit geht
  • Zeit quittiert

Beim Quittieren von Alarmen werden im Ringpuffer immer alle Alarme einer Variablen mit der gleichen Grenzwertverletzung gleichzeitig gelöscht.

Sobald der Alarm quittiert wird, wird er aus dem Ringpuffer gelöscht. Ausnahme: Die Eigenschaft löschpflichtig ist gesetzt, dann muss er vom Benutzer dezidiert gelöscht werden.

Größe des Ringpuffers

Die Größe des Ringpuffers muss in den Projekteigenschaften mit der Eigenschaft Größe des Ringpuffers ausreichend dimensioniert werden.
Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Interne ID: Alarmbehandlung

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: Alarmbehandlung

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Ringpuffer wird beim Beenden der Runtime automatisch als alarm.bin gespeichert. Wird die Runtime durch unerwartete Ereignisse beendet, wie Spannungsausfall, kommt es zu Datenverlust. Um das zu verhindern, kann der Ringpuffer über die Eigenschaft Ringpuffer bei Wertänderung speichern bei jedem neuen Eintrag oder über die Funktion AML- und CEL-Ringpuffer speichern manuell gespeichert werden.

Interne ID: Alarmbehandlung

Ringpuffer bei Wertänderung speichern

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Jede Änderung der Daten der Alarmmeldeliste bewirkt auch das Speichern der Daten (alarm.bin).
Hinweis: Damit wird bei jeder Speicherung der gesamte Ringpuffer gespeichert. Das kann - vor allem bei Flash Disks - zu erheblicher Systembelastung führen.
Inaktiv: Daten der Alarmmeldeliste (alarm.bin) werden nur beim Beenden der Runtime oder beim Ausführen der Funktion AML- und CEL-Ringbuffer speichern gespeichert. Empfiehlt sich vor allem bei niedriger Performance. Historische Daten (*.aml) können unabhängig von dieser Einstellung bei jeder Wertänderung gespeichert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Achtung: Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Über die definierten Anzahl können auch Alarme angezeigt werden, die noch keinen Geht-Zeitstempel besitzen. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen.

Example Beispiel
  • Größe des Ringpuffers: 100 Einträge
  • Anstehende Alarme zur Runtime ohne Geht-Zeitstempel: 120
  • Anzeige zur Runtime in der AML: 120

Alarmdatei

Alle Alarme werden zeitgleich mit dem Ringpuffer in eine eigene Alarmdatei (*.aml)geschrieben. Diese wird für jeden Kalendertag automatisch erstellt und über die Eigenschaft AML-Daten speichern verwaltet. Der Name der Alarmdatei setzt sich zusammen aus dem Buchstaben A, gefolgt vom Datum in der Form JJMMTT und der Endung .aml, z.B. A100623.aml. Diese Dateien werden für jeden Tag automatisch erstellt und müssen bei begrenztem Speicherplatz vom Anwender ausgelagert oder gelöscht werden. *.aml Dateien werden im Ordner ...\Projektordner\Computername\Projektname gespeichert.

Interne ID: Alarmbehandlung

AML-Daten speichern

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Nur Ringpuffer: Nur anstehende Alarme (alarm.bin) werden auf der Festplatte gespeichert.
Ringpuffer und historische Daten: Auch historische Alarme (*.aml) werden gespeichert.
Default: Auf CE-Geräten wird nur der Ringpuffer (alarm.bin) auf die Festplatte gespeichert; auf PCs werden auch die historischen Einträge (*.aml) gespeichert.
Default: Default.
Die Dateien (alarm.bin und *.aml) werden im Ordner \Projektordner\Computername\Projektname gespeichert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Synchronisierung von Ringpuffer und Alarmdatei

Ringpuffer und Alarmdatei werden synchronisiert. Diese Synchronisierung erfolgt immer vom Ringpuffer zur Alarmdatei. Alle Änderungen, wie Quittierung, werden nur im Ringpuffer vorgenommen und dann mit der Alarmdatei synchronisiert. So können in der Alarmdatei zwar z. B. alle unquittierten Alarme angezeigt und deren Quittierung veranlasst werden, die Aktion selbst findet aber im Ringpuffer statt.

Speicherzeiträume

Die Alarmdatei *.aml wird bei jedem neuen Eintrag gespeichert.

Der Ringpuffer (*.bin) wird gespeichert:

  • beim Beenden der Runtime
  • bei aktiver Eigenschaft Ringpuffer bei Wertänderung speichern nach jedem neuen Eintrag
  • beim Ausführen der Funktion AML- und CEL-Ringpuffer speichern

    Interne ID: Alarmbehandlung

    AML- und CEL-Ringpuffer speichern

    Diese Funktion speichert aktuelle Alarme und Ereignisse in die Dateien ALARM.BIN und CEL.BIN.

    Mehr im Online-Handbuch

Hinweis: Ist die Option Ringpuffer bei Wertänderung speichern deaktiviert, werden nach einem Stromausfall die Einträge in der AML und im Ringpuffer eventuell nicht mehr übereinstimmen.

attention Achtung

Läuft der Ringpuffer aufgrund zu geringer Dimensionierung über, bleiben unquittierte Einträge in der Alarmdatei erhalten. Diese werden beim Filtern angezeigt, können aber nicht mehr quittiert werden. Der Versuch diese zu quittieren kann aber das Quittieren von Alarmen in Ringpuffer auslösen, wenn diese die gleiche Variable und die gleiche Grenzwertverletzung betreffen.


Gruppierung von Alarmen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarme können gruppiert und priorisiert werden über:

  • Alarm/Ereignis-Gruppen: fassen zusammengehörige Alarme (oder Ereignisse) logisch zusammen
  • Alarm/Ereignis-Klassen: dienen der Priorisierung von Alarmen (oder Ereignissen) und werden zur farblichen Kennzeichnung von Alarmen in der AML und von Ereignissen in der CEL verwendet
  • Alarmbereiche: ermöglichen die detaillierte Auswertung von Alarm/Ereignis-Klassen über ein Combi-Element

Jeder Gruppe oder Klasse kann ein Name, eine Nummer, eine Farbe, eine Funktion und eine Zustandsvariable, Eine Grafik und eine Anlagengruppe zugeordnet werden.

Alarme können über das Kontextmenü per XML exportiert und importiert werden.

info Info

Es können maximal 65536 Alarm/Ereignis-Klassen und 65536 Alarm/Ereignis-Gruppen erstellt werden.

Kontextmenü Alarm Projektmanager

Menüpunkt | Aktion
XML exportieren alle... | Exportiert alle Einträge in XML-Datei.
XML importieren... | Importiert Einträge aus XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

info Info

Verwenden Sie in Globalprojekt, Integrationsprojekt und Unterprojekten eindeutige unterschiedliche IDs für Alarm/Ereignis-Gruppen, -Klassen und Alarmbereiche. So vermeiden Sie überschneidungen. Diese könnten zu verfälschten Anzeigen führen.

Noch in diesem Kapitel

Alarm/Ereignis-Gruppen

Alarm/Ereignis-Klassen

Alarmbereiche

Alarme in Globalprojekt und Intgerationsprojekten


Alarm/Ereignis-Gruppen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarm/Ereignis-Gruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarm/Ereignis-Gruppen fassen zusammengehörige Meldungen logisch zusammen.

Alarm/Ereignis-Gruppen anlegen

Um eine neue Alarm/Ereignis-Gruppe anzulegen:

  1. führen Sie im Projektmanager einen Rechtsklick auf den Unterknoten Alarm/Ereignis-Gruppen aus
  2. wählen Sie den Befehl: Alarm/Ereignis-Gruppe neu

    (alternativ wählen Sie das entsprechende Symbol in der Symbolleiste oder drücken auf die Taste Einfg)

Jeder Gruppe können über ihre Eigenschaften zusätzliche Informationen zugeordnet werden:

Parameter

Beschreibung

Name

Interne ID: Alarm_Ereignis-Gruppen

Name

Name der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Name der Alarm/Ereignis-Gruppe.

Wird in Filterbedingung der AML und CEL angezeigt.

Nr.

Interne ID: Alarm_Ereignis-Gruppen

Nr.

Nummer der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nummer der Alarm/Ereignis-Gruppe, wird von zenon automatisch vergeben.

Farbe

Interne ID: Alarm_Ereignis-Gruppen

Farbe

Farbe der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.
Die Farbe der Alarm/Ereignis-Klasse kann für die Darstellung in den Listen verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Farbe der Alarm/Ereignis-Gruppe.

Klick auf Schaltfläche ... öffnet Palette für Farbauswahl.

Beschreibung

Interne ID: Alarm_Ereignis-Gruppen

Beschreibung

Beschreibung der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beschreibung der Alarm/Ereignis-Gruppe.

Statusvariable

Interne ID: Alarm_Ereignis-Gruppen

Statusvariable

Name der Variablen, deren Wert anzeigt, ob die Gruppe/Klasse im Moment aktiv geschalten ist oder ob die Alarme dieser Gruppe/Klasse derzeit ignoriert werden.

Es können nur Binärvariablen verwendet werden. Ein Klick auf die Schaltfläche öffnet den Dialog zur Variablenauswahl. Alternativ tragen Sie den Namen der Variablen manuell in das Textfeld ein.

Variablen-Wert = 1: Gruppe/Klasse ist aktiv.

Alarm/Ereignis-Gruppen bzw. Alarm/Ereignis-Klassen können mit Hilfe der Funktion Alarm/Ereignis-Gruppe abmelden/anmelden aktiviert werden.

Interne ID: Alarm_Ereignis-Gruppen

Alarm/Ereignis-Gruppe abmelden/anmelden

Diese Funktion schaltet die Verbindung zur SPS für eine ausgewählte Alarm/Ereignis-Gruppe aus oder ein.

Mehr im Online-Handbuch

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bitvariable, mit der die zenon Runtime signalisiert, ob die Gruppe im Moment aktiv geschalten ist oder ob die Alarme dieser Gruppe derzeit ignoriert werden.

Aktivierung/Deaktivierung erfolgt über die Funktion Alarm/Ereignis-Gruppenverbindung aktiv/inaktiv. Der Zustand der Gruppe wird in der Chronologische Ereignisliste (CEL) mitprotokolliert.

Klick auf Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

Funktion

Interne ID: Alarm_Ereignis-Gruppen

Funktion

Name der Funktion, die ausgeführt wird, wenn ein Alarm dieser Gruppe/Klasse auftritt. Eine Klick auf die Schaltfläche öffnet den Dialog zur Funktionsauswahl. Alternativ tragen Sie den Namen der Funktion manuell in das Textfeld ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Funktion, die ausgeführt werden, wenn ein Alarm dieser Gruppe aktiv wird. Klick auf Schaltfläche ... öffnet den Dialog für die Funktionsauswahl.

Grafikdatei

Interne ID: Alarm_Ereignis-Gruppen

Grafikdatei

Selektieren Sie eine Grafik für die Alarm/Ereignis-Gruppe oder Alarm/Ereignis-Klasse. Ein Linksklick auf die Schaltfläche öffnet die Dateiauswahl. Selektieren Sie die gewünschte Grafikdatei.

Default: keine Datei

Mehr im Online-Handbuch zu Alarm/Ereignis-Gruppen

Mehr im Online-Handbuch zu Alarm/Ereignis-Klassen

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Auswahl einer Grafik, die die Alarm/Ereignis-Gruppe in der AML repräsentiert.

Um die Grafik in der AML anzuzeigen, wählen Sie im Filter der AML in der Registerkarte Spalteneinstellungen für die Spalte Alarm/Ereignis-Gruppe Symbol die Anzeigeart Grafikdatei.

Hinweis: In der AML richtet sich die Spaltenhöhe nach der selektierten Schriftart. Die gewählt Grafik wird gegebenenfalls skaliert und an die Spaltenhöhe angepasst.

Anlagengruppen

Interne ID: Alarm_Ereignis-Gruppen

Anlagengruppen

Verknüpft Element mit einem Anlagenmodell. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Anlagengruppe.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verknüpft Anlagenmodell mit der Alarm/Ereignis-Gruppe.

Definieren Sie die Zugehörigkeit zu einer Anlagengruppe. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl der Anlagengruppe.

Alarm/Ereignis-Gruppen löschen

Um eine Alarm/Ereignis-Gruppe zu löschen:

  1. wählen Sie die Alarm/Ereignis-Gruppe aus
  2. wählen Sie im Kontextmenü oder in der Symbolleiste Löschen
  3. bestätigen Sie die Sicherheitsabfrage

Hinweis: Beim Löschen verlieren alle verknüpften Variablen ihre Gruppenzugehörigkeit.

Noch in diesem Kapitel

Kontextmenüs und Symbolleiste Alarm/Ereignis-Gruppen


Kontextmenüs und Symbolleiste Alarm/Ereignis-Gruppen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarm/Ereignis-Gruppen -> Kontextmenüs und Symbolleiste Alarm/Ereignis-Gruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Projektmanager

Menüpunkt | Aktion
Alarm/Ereignis-Gruppe neu | Legt eine neue Alarm/Ereignis-Gruppe an.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü und Symbolleiste Detailansicht

Menüpunkt | Aktion
Alarm/Ereignis-Gruppe neu | Fügt eine neue Alarm/Ereignis-Gruppe in die Liste ein.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Alarm/Ereignis-Klassen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarm/Ereignis-Klassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarm/Ereignis-Klassen dienen:

  • zur Alarmpriorisierung für die Bildalarmierung
  • zur Festlegung der Alarmfarbe in der Alarmmeldeliste
  • als Filterkriteriumin der Alarmliste und chronologischen Ereignisliste
  • zur Auslösung von z.B. akustischer Alarmierung

Alarm/Ereignis-Klassen anlegen

Um eine neue Alarm/Ereignis-Klasse a nzulegen:

  1. führen Sie im Projektmanager einen Rechtsklick auf den Unterknoten Alarm/Ereignis-Klassen aus
  2. wählen Sie den Befehl: Alarm/Ereignis-Klasse neu

    (alternativ wählen Sie das entsprechende Symbol in der Symbolleiste oder drücken auf die Taste Einfg)

Jeder Klasse können über die Eigenschaften zusätzliche Informationen zugeordnet werden:

Parameter

Beschreibung

Name

Interne ID: Alarm_Ereignis-Klassen

Name

Name der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Name der Alarm/Ereignis-Klasse.

Wird in Filterbedingung der AML und CEL angezeigt.

Nr.

Interne ID: Alarm_Ereignis-Klassen

Nr.

Nummer der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nummer der Alarm/Ereignis-Klasse, wird von zenon automatisch vergeben.

Farbe

Interne ID: Alarm_Ereignis-Klassen

Farbe

Farbe der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.
Die Farbe der Alarm/Ereignis-Klasse kann für die Darstellung in den Listen verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Farbe der Alarm/Ereignis-Klasse, kann in der AML zur Kennzeichnung verwendet werden. Klick auf Schaltfläche ... öffnet Farbpalette.

Hinweis: Farbe wird für Langtext und Zustandstext in der AML und Bildalarmierung verwendet.

Beschreibung

Interne ID: Alarm_Ereignis-Klassen

Beschreibung

Beschreibung der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beschreibung der Alarm/Ereignis-Klasse.

Statusvariable

Interne ID: Alarm_Ereignis-Klassen

Statusvariable

Name der Variablen, deren Wert anzeigt, ob die Gruppe/Klasse im Moment aktiv geschalten ist oder ob die Alarme dieser Gruppe/Klasse derzeit ignoriert werden.

Es können nur Binärvariablen verwendet werden. Ein Klick auf die Schaltfläche öffnet den Dialog zur Variablenauswahl. Alternativ tragen Sie den Namen der Variablen manuell in das Textfeld ein.

Variablen-Wert = 1: Gruppe/Klasse ist aktiv.

Alarm/Ereignis-Gruppen bzw. Alarm/Ereignis-Klassen können mit Hilfe der Funktion Alarm/Ereignis-Gruppe abmelden/anmelden aktiviert werden.

Interne ID: Alarm_Ereignis-Klassen

Alarm/Ereignis-Gruppe abmelden/anmelden

Diese Funktion schaltet die Verbindung zur SPS für eine ausgewählte Alarm/Ereignis-Gruppe aus oder ein.

Mehr im Online-Handbuch

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bitvariable, mit der die zenon Runtime signalisiert, ob die Klasse im Moment aktiv geschalten ist oder ob die Alarme dieser Klasse derzeit ignoriert werden.

Aktivierung/Deaktivierung erfolgt über die Funktion Alarm/Ereignis-Gruppenverbindung aktiv/inaktiv. Der Zustand der Gruppe wird in der Chronologische Ereignisliste (CEL) mitprotokolliert.

Klick auf Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

Funktion

Interne ID: Alarm_Ereignis-Klassen

Funktion

Name der Funktion, die ausgeführt wird, wenn ein Alarm dieser Gruppe/Klasse auftritt. Eine Klick auf die Schaltfläche öffnet den Dialog zur Funktionsauswahl. Alternativ tragen Sie den Namen der Funktion manuell in das Textfeld ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Funktion, die ausgeführt werden, wenn ein Alarm dieser Klasse aktiv wird.

Klick auf Schaltfläche ... öffnet den Dialog für die Funktionsauswahl.

Grafikdatei

Interne ID: Alarm_Ereignis-Klassen

Grafikdatei

Selektieren Sie eine Grafik für die Alarm/Ereignis-Gruppe oder Alarm/Ereignis-Klasse. Ein Linksklick auf die Schaltfläche öffnet die Dateiauswahl. Selektieren Sie die gewünschte Grafikdatei.

Default: keine Datei

Mehr im Online-Handbuch zu Alarm/Ereignis-Gruppen

Mehr im Online-Handbuch zu Alarm/Ereignis-Klassen

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Auswahl einer Grafik, die die Alarm/Ereignis-Klasse in der AML repräsentiert.

Um die Grafik in der AML anzuzeigen, wählen Sie im Filter der AML in der Registerkarte Spalteneinstellungen für die Spalte Alarm/Ereignis-Klasse Symbol die Anzeigeart Grafikdatei.

Hinweis: In der AML richtet sich die Spaltenhöhe nach der selektierten Schriftart, deshalb wird die gewählt Grafik gegebenenfalls skaliert und an die Spaltenhöhe angepasst.

Anlagengruppen

Interne ID: Alarm_Ereignis-Klassen

Anlagengruppen

Verknüpft Element mit einem Anlagenmodell. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Anlagengruppe.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verknüpft Anlagenmodell mit der Alarm/Ereignis-Klasse.

Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl der Anlagengruppe.

Alarm/Ereignis-Klassen löschen

Um eine Alarm/Ereignis-Klasse zu löschen:

  1. wählen Sie die Alarm/Ereignis-Klasse aus
  2. wählen Sie im Kontextmenü oder in der Symbolleiste Löschen
  3. bestätigen Sie die Sicherheitsabfrage

Hinweis: Beim Löschen verlieren alle verknüpften Variablen ihre Klassenzugehörigkeit.

Noch in diesem Kapitel

Kontextmenüs und Symbolleiste Alarm/Ereignis-Klassen


Kontextmenüs und Symbolleiste Alarm/Ereignis-Klassen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarm/Ereignis-Klassen -> Kontextmenüs und Symbolleiste Alarm/Ereignis-Klassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Projektmanager

Menüpunkt | Aktion
Alarm/Ereignis-Klasse neu | Legt eine neue Alarm/Ereignis-Klasse an.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü und Symbolleiste Detailansicht

Menüpunkt | Aktion
Alarm/Ereignis-Klasse neu | Fügt eine neue Alarm/Ereignis-Klasse in die Liste ein.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Alarmbereiche

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarmbereiche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarmbereiche ermöglichen eine flexible Alarmierung über Statusvariablen. Diese können zum Beispiel über ein Combi-Element ausgewertet werden.

Alarmbereiche werden in Bereichseinträge gegliedert. Die Zahl der möglichen Bereichseinträge entspricht der Zahl der vorhandenen Alarm/Ereignis-Klassen.

Alarmbereiche anlegen

Um einen neuen Alarmbereich anzulegen:

  1. führen Sie im Projektmanager einen Rechtsklick auf den Unterknoten Alarmbereiche aus
  2. wählen Sie den Befehl: Alarmbereich neu

    (alternativ wählen Sie das entsprechende Symbol in der Symbolleiste oder drücken auf die Taste Einfg)

  3. wählen Sie im Knoten Allgemein die entsprechenden Variablen

    Interne ID: Alarmbereiche

    Allgemein

    Eigenschaften für die Alarm/Ereignis-Gruppen bzw. Alarm/Ereignis-Klassen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. erstellen Sie im Knoten Klassenverknüpfung mit Klick auf {Klassenverknüpfung neu} einen neuen Bereicheintrag

    Interne ID: Alarmbereiche

    {Klassenverknüpfung neu}

    Legt einen neuen Bereichseintrag für den Alarmbereich an.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Alarmbereiche

    Klassenverknüpfung

    Fasst Statusvariable, Anzahl der aktiven Alarme und der unquittierten Alarme zusammen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    (die Zahl der möglichen Bereicheinträge ist begrenzt auf die Zahl der vorhandenen Alarm/Ereignis-Klassen)

Eigenschaften für Alarmbereiche

Parameter

Beschreibung

Allgemein

Name

Interne ID: Alarmbereiche

Name

Name des Alarmbereichs.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Name des Alarmbereichs.

Wird in Filterbedingung der AML und CEL angezeigt.

Statusvariable

Interne ID: Alarmbereiche

Statusvariable

Das erste Bit dieser Bytevariable zeigt an, ob es aktive Alarme in diesem Alarmbereich gibt.
Das zweite Bit dieser Bytevariable zeigt an, ob es unquittierte Alarme in diesem Alarmbereich gibt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bytevariable:

Erstes Bit: Anzeige, ob der Alarmbereich aktive Alarme enthält.
Zweites Bit: Anzeige, ob dieser Alarmbereich unquittierte Alarme enthält. Details siehe "Bits Statusvariable".

Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

Anzahl aktive Alarme

Interne ID: Alarmbereiche

Anzahl aktive Alarme

Variable, die die Anzahl der aktiven Alarme in diesem Alarmbereich als Wert beinhaltet.
Öffnet den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Variable, deren Wert die die Anzahl der aktiven Alarme in diesem Alarmbereich anzeigt.
Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

Anzahl unquittierte Alarme

Interne ID: Alarmbereiche

Anzahl unquittierte Alarme

Variable, die die Anzahl der unquittierten Alarme in diesem Alarmbereich als Wert beinhaltet.
Öffnet den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Variable, die die Anzahl der unquittierten Alarme in diesem Alarmbereich als Wert beinhaltet.

Nr.

Interne ID: Alarmbereiche

Nr.

Nummer des Alarmbereichs.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Anzahl der konfigurierten Bereicheinträge. Nur Anzeige.

Anlagengruppen

Interne ID: Alarmbereiche

Anlagengruppen

Verknüpft Element mit einem Anlagenmodell. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Anlagengruppe.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verknüpft Anlagenmodell mit dem Alarmbereich.

Definieren Sie die Zugehörigkeit zu einer Anlagengruppe. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl der Anlagengruppe.

Klassenverknüpfung

Sammelt Bereicheinträge. Ein Klassenverknüpfung fasst Statusvariable und Anzahl der aktiven sowie unquittierten Alarme für eine Alarm/Ereignis-Klasse zusammen. Bereicheinträge werden über die Eigenschaft {Klassenverknüpfung neu} erstellt.

{Klassenverknüpfung neu}

Erstellt einen neuen Bereicheintrag.

Alarm/Ereignis-Klasse

Interne ID: Alarmbereiche

Alarm/Ereignis-Klasse

Alarm/Ereignis-Klasse für den Bereichseintrag.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alarmklasse für den Bereichseintrag.

{Klassenverknüpfung löschen}

Interne ID: Alarmbereiche

{Klassenverknüpfung löschen}

Der Bereichseintrag wird gelöscht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Löscht den Bereicheintrag ohne Rückfrage.

Alarm/Ereignis-Klasse

Auswahl der Alarm/Ereignis-Klasse für Bereicheintrag aus Dropdownliste. Alarm/Ereignis-Klasse muss bereits angelegt worden sein.

Weitere Einträge analog allgemeiner Einstellungen je Bereicheintrag mit:

  • Statusvariable

    Interne ID: Alarmbereiche

    Statusvariable

    Das erste Bit dieser Bytevariable zeigt an, ob es aktive Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich gibt.
    Das zweite Bit dieser Bytevariable zeigt an, ob es unquittierte Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich gibt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Anzahl aktive Alarme

    Interne ID: Alarmbereiche

    Anzahl aktive Alarme

    Variable, die die Anzahl der aktiven Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich als Wert beinhaltet.
    Öffnet den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Anzahl unquittierte Alarme

    Interne ID: Alarmbereiche

    Anzahl unquittierte Alarme

    Variable, die die Anzahl der unquittierten Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich als Wert beinhaltet.
    Öffnet den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bits Statusvariable

Bit | Bedeutung
0 | 1 = Alarme stehen an 0 = keine Alarme stehen an
1 | 1 = unquittierte Alarme vorhanden 0 = keine unquittierten Alarme

Noch in diesem Kapitel

Kontextmenüs und Symbolleiste Alarmbereiche

Alarmbereiche konfigurieren


Kontextmenüs und Symbolleiste Alarmbereiche

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarmbereiche -> Kontextmenüs und Symbolleiste Alarmbereiche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Projektmanager

Menüpunkt | Aktion
Alarmbereich neu | Legt einen neuen Alarmbereich an.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü und Symbolleiste Detailansicht

Menüpunkt | Aktion
Alarmbereich neu | Fügt einen neuen Alarmbereich in die Liste ein.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Alarmbereiche konfigurieren

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarmbereiche -> Alarmbereiche konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Alarmbereich zu erstellen:

  1. klicken Sie auf {Klassenverknüpfung neu}

    Interne ID: Alarmbereiche konfigurieren

    {Klassenverknüpfung neu}

    Legt einen neuen Bereichseintrag für den Alarmbereich an.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. wählen Sie die gewünschte Alarm/Ereignis-Klasse

    Interne ID: Alarmbereiche konfigurieren

    Alarm/Ereignis-Klasse

    Alarm/Ereignis-Klasse für den Bereichseintrag.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. definieren Sie für den Bereich
    • Statusvariable

      Interne ID: Alarmbereiche konfigurieren

      Statusvariable

      Das erste Bit dieser Bytevariable zeigt an, ob es aktive Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich gibt.
      Das zweite Bit dieser Bytevariable zeigt an, ob es unquittierte Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich gibt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Variable für Anzahl aktive Alarme und

      Interne ID: Alarmbereiche konfigurieren

      Anzahl aktive Alarme

      Variable, die die Anzahl der aktiven Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich als Wert beinhaltet.
      Öffnet den Dialog zur Variablenauswahl.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Variable für Anzahl unquittierte Alarme

      Interne ID: Alarmbereiche konfigurieren

      Anzahl unquittierte Alarme

      Variable, die die Anzahl der unquittierten Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich als Wert beinhaltet.
      Öffnet den Dialog zur Variablenauswahl.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Die Zuordnung eines Alarms zu einem Alarmbereich erfolgt in der Eigenschaften Alarmbereich der Variablen in der Gruppe Alarmbehandlung.

Interne ID: Alarmbereiche konfigurieren

Alarmbehandlung

Eigenschaften für die Quittiervariable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarmbereiche konfigurieren

Alarmbereich

Hier kann die Variable mit einem Alarmbereich verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beispiel Alarmbereich

Klassenverknüpfung Interne ID: Alarmbereiche konfigurieren Klassenverknüpfung Fasst Statusvariable, Anzahl der aktiven Alarme und der unquittierten Alarme zusammen. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Alarm/Ereignis-Klasse | Statusvariable | Anzahl aktive Alarme | Anzahl unquittierte Alarme
1 | Warnung | Status_warn_1 | Anstehend_warn_1 | Unquit_warn_1
 | Störung | Status_error_1 | Anstehend_error_1 | Unquit_error_1
2 | Warnung | Status_warn_2 | Anstehend_warn_2 | Unquit_warn_2
 | Störung | Status_error_2 | Anstehend_error_2 | Unquit_error_2

Beispiel-Anwendung Energy

Ein Alarmbereich ist eine Gruppe von Objekten. Diese werden zu einem Bild zusammengefasst. Bei einem Energieversorger wird jedes Umspannwerk durch ein Bild repräsentiert. Die Umspannwerke A bis T werden in 4 Unterseiten angezeigt. Alle Alarmbereiche werden in einem gemeinsamen Überblicksbild angezeigt.

  • Wird im Umspannwerk A ein Grenzwert verletzt, blinkt der Button für Umspannwerke im Übersichtsbild.
  • Im Gruppenbild blinkt der Button, der zur Seite mit den Umspannwerken A, B, C, D und E führt.
  • Im Detailbild blinkt der Button für Umspannwerk A.


Alarme in Globalprojekt und Intgerationsprojekten

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Gruppierung von Alarmen -> Alarme in Globalprojekt und Intgerationsprojekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jedes Projekt speichert eigene IDs für Alarmklassen, Alarmgruppen und Alarmbereiche. Bei Globalprojekten sowie Integrations- und Unterprojekten kann es damit zu Überlappungen kommen. Wenn in unterschiedlichen Projekten gleiche IDs verwendet werden, kann das zum Überschreiben von Einträgen in den Auswahldialogen der Filter führen.

Um das zu vermeiden, achten Sie darauf, in allen Projekten unterschiedliche IDs zu verwenden. Dazu legen Sie "Dummy"-Gruppen/Klassen/Bereiche an, die sie dann wieder löschen.


Alarmprojektierung über Filter

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Anzeige der Alarme zur Runtime projektieren Sie über Filter. Sie haben dazu mehrere Möglichkeiten:

  1. Informationen, die zur Runtime in der Alarmmeldeliste angezeigt werden, definieren:
    Damit legen Sie fest, welche Informationen zu einem Alarm angezeigt werden.
    Details siehe: Spalteneinstellung für Alarmmeldeliste.
  2. Alarme für die Alarmmeldeliste beim Aufschalten filtern und zur Runtime modifizieren:
    Damit definieren Sie Filter vor, geben am dem Bediener an der Maschine die Möglichkeit, eigene Filter zu definieren.
    Details siehe: Filter für Bildumschaltung Alarmmeldeliste.
  3. Filter für die Runtime fest vorgeben:
    Damit erstellen Sie Filter, die auf den tatsächlichen Einsatz zugeschnitten sind und blenden nicht benötigte Filterkriterien aus.
    Details siehe: Filter Alarmmeldeliste Filter.

Noch in diesem Kapitel

Spalteneinstellung für Alarmmeldeliste

Filter für Bildumschaltung Alarmmeldeliste

Filter für Bildumschaltung Alarmmeldeliste Filter


Spalteneinstellung für Alarmmeldeliste

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Spalteneinstellung für Alarmmeldeliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Welche Informationen zur Runtime in der Alarmmeldeliste angezeigt werden, legen Sie in den Spalteneinstellungen fest. Diese konfigurieren Sie bei einer Funktion Bildumschaltung in den Filterkriterien oder direkt in den Eigenschaften der Alarmmeldeliste im Projekt:

  1. öffnen Sie in den Projekteigenschaften den Knoten Alarmmeldeliste

    Interne ID: Spalteneinstellung für Alarmmeldeliste

    Alarmmeldeliste

    Eigenschaften für die Alarmkonfiguration.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie auf die Eigenschaft Spalteneinstellung AML

    Interne ID: Spalteneinstellung für Alarmmeldeliste

    Spalteneinstellung AML

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
    Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

    Interne ID: Spalteneinstellung für Alarmmeldeliste

    Alarmmeldeliste aktiv

    Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
    Inaktiv: Alarme werden nicht aufgezeichnet.
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog für die Spalteneinstellungen wird geöffnet

Hinweis: Für die Berechnung der Spaltenbreite wird die durchschnittliche Zeichenbreite der gewählten Schriftart verwendet.

info Info

In den Projekteinstellungen können Sie mithilfe der Eigenschaft Spalteneinstellung AML bzw.Spalteneinstellung CEL eine Default-Einstellung für die Reihenfolge und die Größe der Spalten vornehmen. Wenn Sie eine neue Funktion vom Typ Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste oder Chronologische Ereignisliste anlegen, wird diese Einstellung als default verwendet. Die Einstellung wird in der Datei project.ini gespeichert.

Interne ID: Spalteneinstellung für Alarmmeldeliste

Spalteneinstellung CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

Interne ID: Spalteneinstellung für Alarmmeldeliste

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter

Beschreibung

Spalten

Im Listenfeld dieser Registerkarte werden Ihnen alle zur Verfügung stehenden Spaltentypen angezeigt.

Die Reihenfolge der Spaltentypen ändern Sie mithilfe von Drag&Drop im Listenfeld:

  • klicken Sie in die Spalte Spaltentyp
  • verschieben Sie die einzelnen Einträge wie gewünscht

Alternative können Sie die Reihenfolge über die Schaltflächen Selektierten Eintrag nach oben verschieben und Selektierten Eintrag nach unten verschieben anpassen.
  • Checkbox:

Auswahl, welche Spaltentypen angezeigt werden.
  • Beschreibung:

Freier Texteintrag für Beschreibung der Spalte.

Beschreibung ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.

Hinweis: Für die Spaltenbeschreibung ist die zenon Sprachumschaltung verfügbar.
  • Spaltenbreite:

Definiert die Breite der Spalte in Zeichen.

Spaltenbreite ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.
-1: Breite wird zur Runtime über durchschnittliche Zeichenbreite berechnet

Hinweis: Aus Kompatibilitätsgründen erhalten jene Spalten, deren Breite in früheren zenon Versionen nicht geändert werden konnten (Zeitangaben), automatisch den Wert -1.

  • Anzeige:

Für die Spaltentypen

  • Alarm/Ereignis-Klasse Symbol
  • Alarm/Ereignis-Gruppe Symbol
  • Alarmzustand

ist Form der Anzeige zur Runtime auswählbar. Wählen Sie aus der Dropdownliste die gewünschte Form aus.

Selektierten Eintrag nach oben verschieben

Verschiebt ausgewählten Eintrag um eine Position nach oben.

Selektierten Eintrag nach unten verschieben

Verschiebt ausgewählten Eintrag um eine Position nach unten.

Vorschaufeld

Zeigt die im Listenfeld gewählten Spalten in der dort definierten Breite.

Sie können die Spaltenbreiten auch hier anpassen, indem Sie einen Linksklick auf das rechte Ende einer Spalte ausführen, die Maustaste gedrückt halten und die Maus entsprechend nach links oder rechts bewegen.

Tabelleneinstellungen

Absteigend sortieren

Sortiert die Einträge in der Liste nach der Spalte Zeit kommt in absteigender Reihenfolge. Diese Einstellungen gilt für das Aufschalten des Bilds.
In der Runtime können Sie die Sortierreihenfolge durch eine Klick auf den Spaltenkopf ändern. Die momentan verwendete Sortierreihenfolge wird durch einen Pfeil am Spaltenkopf angezeigt.

Raster anzeigen

Blendet eine Raster bei der Darstellung der Liste zur Runtime ein.

Abwechselnde Hintergrundfarbe verwenden

Verwendet abwechselnd die Zeilenfarbe 1 und Zeilenfarbe 2 als Hintergrundfarbe für die Liste in der Runtime.
  • Zeilenfarbe 1

Farbe, die als Hintergrundfarbe für alle ungeraden Zeilen (1, 3, 5 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.
  • Zeilenfarbe 2

Farbe, die als Hintergrundfarbe für alle geraden Zeilen (2, 4, 6 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.

Anzeige in den Zeitspalten

Uhreit

Zeigt die Zeit für einen Listeneintrag in folgender Form an: HH:MM:SS

Datum

Zeigt das Datum für einen Listeneintrag in folgender Form an: TT:MM:JJJJ

Millisekunden

Erweitert den Zeiteintrag um Millisekunden.

Hinweis: Muss aktiviert werden, wenn Millisekunden in Exporten oder Druckausgaben ausgegeben werden sollen.

Tipp: Wenn Sie das automatische Keyboard in der Runtime aktivieren, wird es beim Erscheinen eines Editierfelds aufgeschalten. Damit können Sie die Spalten auch dann konfigurieren, wenn Sie einen Rechner ohne Tastatur verwenden.

attention Achtung

Die Spaltenbreite wird in Zeichen angegeben und ist von der verwendeten Schriftart abhängig. Wenn die Spaltenbreite nicht einem Vielfachen der Zeichenbreite der verwendeten Schriftart entspricht, kann es zu Abweichungen bei der tatsächlichen Spaltenbreite kommen. Das kann zur Folge haben, dass Text abgeschnitten wird bzw. ein Leeraum ensteht.

Lösung: Verwenden Sie Proportionalschriften, wie z.B. Courier New.


Filter für Bildumschaltung Alarmmeldeliste

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Filter legen Sie fest, welche Alarme zur Runtime angezeigt werden sollen und welche ausgeblendet werden. Filter können im Editor und - je nach nach dem Vorgaben im Editor - zur Runtime definiert werden.

Um die Filterauswahl zur Runtime auf die Bedürfnisse des Operators zuzuschneiden, benutzen Sie statt dem Bild Alarmmeldeliste ein Bild vom Typ Alarmmeldeliste Filter.

Um eine Bildumschaltung auf ein BIld vom Typ Alarmmeldeliste zu projektieren:

  1. erstellen Sie eine Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste
  2. der Filterdialog wird geöffnet und bietet mehrere Registerkarten mit Filterkriterien an:
    • Allgemein
    • Zeit
    • Spalteneinstellungen
    • Text
    • Status
    • Projekt (Steht nur im Integrationsprojekt der Mehrprojektverwaltung zur Verfügung.)
    • Anlagenmodellierung

    Optional können, wenn verknüpfte Variablen oder Indizes vorhanden sind, noch folgende Registerkarten angezeigt werden:

    • Verknüpfungen ersetzen
    • Indizes ersetzen

    Details dazu lesen Sie im Handbuch Bilder in den Abschnitten Verknüpfungen von Variablen und Funktionen ersetzen und Verknüpfte Symbol e.

Noch in diesem Kapitel

Allgemein

Zeit

Spalteneinstellungen

Text

Status

Projekt

Anlagenmodellierung


Allgemein

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem allgemeinen Filter legen Sie fest, welcher Alarme angezeigt werden und welchen Zugriff Sie zur Runtime auf die Einstellung haben. Dazu unterscheiden Sie Alarme nach:

  • Art
  • Datenherkunft
  • Variablen
  • anstehender Zeit
  • Alarm/Ereignis-Gruppen, Klassen und Alarmbereichen

Die folgenden Eigenschaften stehen Ihnen zur Verfügung:

Parameter

Beschreibung

Variablenfilter

Einschränkung auf Alarme bestimmter Variablen

Variablenname

Geben Sie den Namen oder den Teil des Namens von Variablen an, nach dem Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Kennung

Geben Sie die Kennung oder die Teilkennung von Variablen an, nach der Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Groß-/Kleinschreibung beachten

Aktiv: Groß- und Kleinschreibung wird bei der Filterung nach Variablenname und/oder Kennung beachtet.

Alarmart

Art der Alarme, die angezeigt werden.

Nur nicht quittierte Alarme

Aktiv: Es werden nur Alarme angezeigt, die vom Benutzer noch nicht quittiert wurden.

Nur gegangene Alarme

Aktiv: Es werden nur Alarme angezeigt, die schon gegangen sind; d.h. deren Werte nicht mehr im kritischen Bereich sind.

Nur anstehende Alarme

Aktiv: Es werden nur Alarme angezeigt, die noch anstehen; d.h. deren Werte sich noch im kritischen Bereich befinden.

Kommentar erforderlich
  • Aktiv: Es werden nur Alarme angezeigt, für die bei der Quittierung Kommentarpflicht besteht.

Alarme müssen mindestens anstehen

Definieren Sie mithilfe der Spincontrols, wie lange ein Alarm mindestens anstehen muss, damit er angezeigt wird. Mögliche Einstellungen:

  • Tage
  • Stunden (Std.)
  • Minuten (Min.)
  • Sekunden (Sek.)
  • Millisekunden (ms)

Datenherkunft

Anzeige aktueller oder aktueller und historischer Alarme.

Ringpuffer

Aktiv: Es werden nur Daten aus dem Ringpuffer angezeigt.

Historische Daten
Maximale Anzahl

Aktiv: Es werden Daten aus dem Ringpuffer und historische Daten aus der AML angezeigt.

Die maximale Anzahl der anzuzeigenden Daten inkludiert die Daten aus dem Ringpuffer.

Runtime-Einstellungen

Verhalten der AML zur Runtime

Liste angehalten aufschalten

Aktiv: Solange die Liste angezeigt wird, werden keine neuen Einträge hinzugefügt.

(Nicht verfügbar für Funktion AML exportieren.)

Diesen Dialog zur Runtime anbieten

Aktiv: Vor jedem Aufschalten des Bildes wird der Filterdialog geöffnet. Die Filter-Einstellungen können modifiziert werden.

Alarm/Ereignis-Gruppen/Klassen, Alarmbereiche

Auswahl von Gruppen, Klassen und Alarmbereichen.

Alarm/Ereignis-Gruppen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Gruppen jene aus, aus denen Alarme angezeigt werden sollen.

Alarm/Ereignis-Klassen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Klassen jene aus, aus denen Alarme angezeigt werden sollen.

Alarmbereiche

Wählen Sie aus den vorhandenen Alarmbereichen jene aus, aus denen Alarme angezeigt werden sollen.

attention Achtung

Betrifft zenon unter Windows CE: CE Systeme, auf denen der Filterdialog angezeigt werden soll, müssen über eine höhere Auflösung als 800*600 Pixel verfügen, damit der Dialog vollständig dargestellt werden kann.


Zeit

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zeitfilter bieten eine komfortable Möglichkeit, um Daten die angezeigt oder exportiert werden sollen, zu begrenzen. Die Zeitfilter sind sehr flexibel einsetzbar und können sowohl im Editor voreingestellt, als auch zur Runtime angepasst werden.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Die hier beschriebenen Mechanismen gelten bei der Bildumschaltung sowie beim Export für:

  • Alarmmeldeliste
  • Chronologische Ereignisliste
  • Archiv-Nachbearbeitung
  • Erweiterter Trend
  • Report Generator
  • Report Viewer

Die Zeitfilterung kann prinzipiell auf zwei Arten erfolgen:

  1. Zeitbereich im Editor vorgeben
    Es werden fixe Zeitbereiche verwendet. Im Editor wird ein Zeitbereich vorgegeben. In der Runtime kann nur mehr nach diesem Zeitbereich gefiltert werden. Auch andere Filter - z.B. Filtern nach Variablenname, Alarm/Ereignis-Gruppen und -Klassen usw. - sind zur Runtime nicht mehr anpassbar.
  2. Zeitfilter zur Runtime anpassbar
    Es werden vorprojektierte Zeiten verwendet. Der Zeitfilter wird im Editor vorgegeben und kann zur Runtime beliebig verändert werden.

info Info

Wird auf ein Bild referenziert, das keine Zeitfilter hat, dann werden die Zeitfilter deaktiviert.

Für die Einstellung Filter bei Zeitfiltertyp einstellen kann die Option Filterdialog in der Runtime anzeigen zwar ausgewählt werden, steht zur Runtime aber nicht zur Verfügung.

Noch in diesem Kapitel

Zeitbereich im Editor vorgeben

Zeitfilter zur Runtime anpassbar


Zeitbereich im Editor vorgeben

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Zeit -> Zeitbereich im Editor vorgeben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitbereich im Editor vorgeben

Bei dieser Methode geben Sie im Editor bereits einen fixen Zeitbereich vor, der beim Ausführen der Funktion zur Runtime angewandt wird. Zur Runtime können Sie nur noch den Startzeitpunkt festlegen, aber keine weiteren Filtereinstellungen mehr verändern.

Zum Beispiel: Sie stellen einen 30 Minuten Zeitfilter ein. In der Runtime können Sie nur mehr einstellen, wann dieser 30 Minuten Zeitraum starten soll. Sie können den Filter aber nicht auf einen Tagesfilter umstellen.

attention Achtung

Bei Verwendung dieser Filterart können Sie zur Runtime auch alle anderen Filter, die auf der Karteikarte Allgemein zur Verfügung stehen, nicht mehr anpassen! Filtern auf Text, Status und Anlagen ist weiter möglich.

Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über den Button Filter verfügen, um den Filter zur Runtime zu starten

    Tipp: Aktivieren Sie im Filterdialog in der Registerkarte Allgemein die Option Filterdialog in der Runtime anzeigen. Damit können Sie den Startzeitpunkt bereits vor Ausführung der Funktion anpassen. Lassen Sie den Filter beim Aufschalten der Funktion in der Runtime nicht anzeigen, so wird immer der aktuelle Zeitbereich verwendet. Haben Sie die Option Letzen abgeschlossenen Zeitbereich verwenden aktiviert, wird der vorangegangene Zeitbereich angezeigt.
    Zum Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option Letzten abgeschlossenen Zeitbereich verwenden wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 bis 10:29:59 gesetzt.

  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl den gewünschten Filter;
    Ausnahme: Filter bei Zeitfiltertyp einstellen - dieser ist für die Option Zeitfilter zur Runtime anpassbar vorgesehen
  4. konfigurieren Sie den ausgewählten Zeitraum

Parameter

Beschreibung

Filter bei Zeitfiltertyp einstellen

Aktiviert die Möglichkeit, den Filter zur Runtime anzupassen.

Ein Tag

Es wird auf einen ganzer Tag gefiltert:
00:00:00 Uhr bis 23:59:59 Uhr.

Eine Woche

Es wird auf eine ganze Woche gefiltert:
Montag 00:00:00 Uhr bis Sonntag 23:59:59 Uhr.

Zwei Wochen

Es wird auf zwei ganze Wochen gefiltert:
Montag 00:00:00 Uhr der ersten Woche bis Sonntag 23:59:59 Uhr der zweiten Woche.

Ein Monat

Es wird auf einen ganzer Monat gefiltert:
Erster Tag des Monats 00:00:00 Uhr bis letzer Tag des Monats 23:59:59 Uhr.

Ein Jahr

Es wird auf ein ganzes Jahr gefiltert:
1.Januar des Jahres 00:00:00 Uhr bis 31. Dezember des Jahres 23:59:59 Uhr.

15 Minuten

Es wird auf einen Zeitbereich von 15 Minuten gefiltert.

30 Minuten

Es wird auf einen Zeitbereich von 30 Minuten gefiltert.

60 Minuten

Es wird auf einen Zeitbereich von 60 Minuten gefiltert.

Relativer Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein relativer Zeitraum in Tagen, Stunden (HH), Minuten (MM) und Sekunden (SS) angegeben werden kann.

Achtung! Der gewählte Zeitraum bezieht sich auf den Aufschaltzeitpunkt. Der gefilterte Zeitbereich wird daraufhin fest eingestellt.
Beispiel: Beim Aufrufen der Funktion ist es 10:23:00. Sie stellen einen relativen Zeitraum von einer Stunde ein. Der Filter wird auf 9:23:00 - 10:23:00 eingestellt.

Absoluter Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein absoluten Zeitraum eingeben könen . Sie legen dabei den Start- und Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS) fest.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Chargen

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt in dem Sie eine Charge auswählen können. Der Zeitfilter wird dann auf den Zeitraum der Charge eingestellt. Sie können damit z.B. nach allen Alarmen oder allen CEL Einträgen die während einer Charge aufgetreten sind filtern.

Hinweis: Der Filter zeigt nur abgeschlossene Chargen an.

Chargen relativ

Nur für Erweiterter Trend.

Darstellung geht immer von Nullpunkt aus. Ermöglicht direkten Vergleich mehrerer Chargen.

Optionen

Zu allen Zeitbereichen (ausgenommen absoluter und relativer Zeitbereich sowie Chargen) sind folgende Einstellungen möglich, um den Zeitbereich anzupassen:

Parameter

Option

Beschreibung

Letzten abgeschlossenen Zeitbereich verwenden

Aktiv: Es wird immer der aktuelle Zeitbereich verwendet. Ist die Option gesetzt wird der vorangegangene Zeitbereich angezeigt.

Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 Uhr bis 10:29:59 Uhr gesetzt.

Zeitbereich nach hinten verschieben um

Aktiv: Der gesamte Zeitbereich wird um die angegeben Zeit nach hinten verschoben. Der Zeitraum bleibt von dieser Einstellung unberührt.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. In der Runtime wird der Filter nun nicht zu jeder vollen Stunde beginnen, sondern immer 5 Minuten später, also z.B. um 10:05:00 Uhr um 11:05:00 Uhr usw. Gefiltert werden nach wie vor 60 Minuten also bis 11:04:59 Uhr bzw. 12:04:59 Uhr usw.

Zeit

Definiert die Zeitverschiebung in Stunden (HH), Minuten (MM), Sekunden (SS)

Zeitraum ändern um

Aktiv: Der gefilterte Zeitraum wird verkürzt oder verlängert.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. Die Option angegeben Zeit dazuzählen ist gesetzt. In der Runtime

werden nun nicht mehr 60 Minuten gefiltert sondern 65 Minuten, also z.B. von 10:00:00 Uhr bis 11:04:59 Uhr.

Zeit

Definiert die Zeit, um die der Zeitraum verkürzt oder verlängert wird. In Stunden (HH), Minuten (MM), Sekunden (SS)

angegebene Zeit dazuzählen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verlängert

angegebene Zeit abziehen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verkürzt

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Zeitfilter zur Runtime anpassbar

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Zeit -> Zeitfilter zur Runtime anpassbar

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitfilter zur Runtime anpassbar

Bei dieser Methode geben Sie im Editor einen Zeitfilter vor. Dieser kann zur Runtime vor der Ausführung angepasst werden. Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über die Buttons Filter und Filter anzeigen verfügen
  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl die Einstellung Filter bei Zeitfiltertyp einstellen aus

    Hinweis: Die Option Filterdialog in der Runtime anzeigen kann zwar ausgewählt werden, steht zur Runtime für die Einstellung die Option Filter bei Zeitfiltertyp einstellen aber nicht zur Verfügung.

  4. wählen Sie den Zeitraum aus der Dropdownliste Zeitfiltertyp

Parameter

Option

Beschreibung

Absoluter Zeitraum

Es wird ein fixer Zeitbereich im Editor vorgegeben. Beim Ausführen der Funktion wird genau der eingestellte absolute Zeitbereich verwendet.
Beispiel: Sie möchten alle Alarme vom 1.1.2011 - 31.12.2011 sehen, dann geben Sie die entsprechenden Daten bei Von und Bis an.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Von

Definiert den Startzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Bis

Definiert den Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Relativer Zeitraum

Es wird ein relativer Zeitbereich angegeben.

Achtung! Dieser Filter wird ständig aktualisiert. Er wandert also mit.

Zum Beispiel: Sie stellen eine relative Zeit von 10 Minuten ein und schalten um 12:00 Uhr ein Bild vom Typ Alarmmeldeliste mit diesem Zeitfilter auf. Dann werden Ihnen beim Aufschalten die Alarme von 11:50 bis 12:00 angezeigt. Wenn das Bild vom Typ Alarmmeldeliste geöffnet bleibt, wird der Filter automatisch aktualisiert. Um 12:01 sehen Sie die Alarme von 11:51-12:01 usw.

Zeit

Definiert den relativen Zeitraum in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab HH:MM:SS Uhr

Es wird eine Uhrzeit angegeben, ab dem der Filter wirkt. Ist die Uhrzeit am heutigen Tag noch nicht erreicht, wird ab der entsprechenden Uhrzeit des Vortages gefiltert.

Beispiel: Sie geben 23:00:00 ein. Ist es bei der Ausführung der Funktion 23:30 Uhr, dann wird von 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist es jedoch 22:30 Uhr, dann wird vom Vortag 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag - HH:MM:SS Uhr

Es werden ein Tag und eine Uhrzeit für den Filterbeginn angegeben. Ist die angegebene Zeit im laufendem Monat noch nicht erreicht, wird die entsprechende Zeit des Vormonats verwendet.

Beispiel: Sie geben Tag 5 - 23:00:00 ein. Ist es bei der Ausführung der Funktion der 10. des Monats um 23:30 Uhr , dann wird vom 5. des Monats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. des Monats, dann wird vom 5. des Vormonats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filter wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag, Monat - HH:MM:SS Uhr

Es werden ein Monat, ein Tag und eine Uhrzeit für den Filterbeginn eingegeben. Ist die angegebene Zeit im laufenden Jahr noch nicht erreicht, wird die entsprechende Zeit des Vorjahres verwendet.

Beispiel: Sie geben Monat Oktober, Tag 5 - 23:00:00 ein. Ist bei der Ausführung der Funktion der 10. Oktober um 23:30 Uhr, dann wird vom 5. Oktober ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. Oktober, dann wird vom 5. Oktober des Vorjahres ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und der 5. Oktober 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Monaten, Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Kein Zeitfilter

Es wird kein Zeitfilter verwendet.

Bei Report Viewer und in der Archiv-Nachbearbeitung werden mit dieser Einstellung alle Einträge seit 1. 1. 2000 angezeigt.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Spalteneinstellungen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Spalteneinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Dialog definieren Sie, welche Spalten Sie sich in welcher Form, Reihenfolge und Sortierung anzeigen lassen möchten.

Hinweis: Alle Einstellungen, die Sie in dieser Registerkarte vornehmen, gelten als Default für:

  • Bild vom Typ Alarmmeldeliste
  • Bild vom Typ Alarmmeldeliste Filter
  • Alarmstatuszeile
  • Bild vom Typ Chronologische Ereignisliste
  • Bild vom Typ Chronologische Ereignisliste Filter

Diese Default-Einstellungen können bei der Definition der einzelnen Alarmfunktionen/CEL-Funktionen geändert werden.

info Info

In den Projekteinstellungen können Sie mithilfe der Eigenschaft Spalteneinstellung AML bzw.Spalteneinstellung CEL eine Default-Einstellung für die Reihenfolge und die Größe der Spalten vornehmen. Wenn Sie eine neue Funktion vom Typ Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste oder Chronologische Ereignisliste anlegen, wird diese Einstellung als default verwendet. Die Einstellung wird in der Datei project.ini gespeichert.

Interne ID: Spalteneinstellungen

Spalteneinstellung CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

Interne ID: Spalteneinstellungen

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Spalteneinstellungen

Spalteneinstellung AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

Interne ID: Spalteneinstellungen

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter

Beschreibung

Spalten

Im Listenfeld dieser Registerkarte werden Ihnen alle zur Verfügung stehenden Spaltentypen angezeigt.

Die Reihenfolge der Spaltentypen ändern Sie mithilfe von Drag&Drop im Listenfeld:

  • klicken Sie in die Spalte Spaltentyp
  • verschieben Sie die einzelnen Einträge wie gewünscht

Alternative können Sie die Reihenfolge über die Schaltflächen Selektierten Eintrag nach oben verschieben und Selektierten Eintrag nach unten verschieben anpassen.
  • Checkbox:

Auswahl, welche Spaltentypen angezeigt werden.
  • Beschreibung:

Freier Texteintrag für Beschreibung der Spalte.

Beschreibung ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.

Hinweis: Für die Spaltenbeschreibung ist die zenon Sprachumschaltung verfügbar.
  • Spaltenbreite:

Definiert die Breite der Spalte in Zeichen.

Spaltenbreite ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.
-1: Breite wird zur Runtime über durchschnittliche Zeichenbreite berechnet

Hinweis: Aus Kompatibilitätsgründen erhalten jene Spalten, deren Breite in früheren zenon Versionen nicht geändert werden konnten (Zeitangaben), automatisch den Wert -1.

  • Anzeige:

Für die Spaltentypen

  • Alarm/Ereignis-Klasse Symbol
  • Alarm/Ereignis-Gruppe Symbol
  • Alarmzustand

ist Form der Anzeige zur Runtime auswählbar. Wählen Sie aus der Dropdownliste die gewünschte Form aus.

Selektierten Eintrag nach oben verschieben

Verschiebt ausgewählten Eintrag um eine Position nach oben.

Selektierten Eintrag nach unten verschieben

Verschiebt ausgewählten Eintrag um eine Position nach unten.

Vorschaufeld

Zeigt die im Listenfeld gewählten Spalten in der dort definierten Breite.

Sie können die Spaltenbreiten auch hier anpassen, indem Sie einen Linksklick auf das rechte Ende einer Spalte ausführen, die Maustaste gedrückt halten und die Maus entsprechend nach links oder rechts bewegen.

Tabelleneinstellungen

Absteigend sortieren

Sortiert die Einträge in der Liste nach der Spalte Zeit kommt in absteigender Reihenfolge. Diese Einstellungen gilt für das Aufschalten des Bilds.
In der Runtime können Sie die Sortierreihenfolge durch eine Klick auf den Spaltenkopf ändern. Die momentan verwendete Sortierreihenfolge wird durch einen Pfeil am Spaltenkopf angezeigt.

Raster anzeigen

Blendet eine Raster bei der Darstellung der Liste zur Runtime ein.

Abwechselnde Hintergrundfarbe verwenden

Verwendet abwechselnd die Zeilenfarbe 1 und Zeilenfarbe 2 als Hintergrundfarbe für die Liste in der Runtime.
  • Zeilenfarbe 1

Farbe, die als Hintergrundfarbe für alle ungeraden Zeilen (1, 3, 5 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.
  • Zeilenfarbe 2

Farbe, die als Hintergrundfarbe für alle geraden Zeilen (2, 4, 6 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.

Anzeige in den Zeitspalten

Uhreit

Zeigt die Zeit für einen Listeneintrag in folgender Form an: HH:MM:SS

Datum

Zeigt das Datum für einen Listeneintrag in folgender Form an: TT:MM:JJJJ

Millisekunden

Erweitert den Zeiteintrag um Millisekunden.

Hinweis: Muss aktiviert werden, wenn Millisekunden in Exporten oder Druckausgaben ausgegeben werden sollen.

Tipp: Wenn Sie das automatische Keyboard in der Runtime aktivieren, wird es beim Erscheinen eines Editierfelds aufgeschalten. Damit können Sie die Spalten auch dann konfigurieren, wenn Sie einen Rechner ohne Tastatur verwenden.

attention Achtung

Die Spaltenbreite wird in Zeichen angegeben und ist von der verwendeten Schriftart abhängig. Wenn die Spaltenbreite nicht einem Vielfachen der Zeichenbreite der verwendeten Schriftart entspricht, kann es zu Abweichungen bei der tatsächlichen Spaltenbreite kommen. Das kann zur Folge haben, dass Text abgeschnitten wird bzw. ein Leeraum ensteht.

Lösung: Verwenden Sie Proportionalschriften, wie z.B. Courier New.


Text

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Textfilter ermöglicht die Eingrenzung der Anzeige auf Meldungen, die bestimmte Suchbegriffe enthalten.

Parameter | Beschreibung
Filtern nach |
Kein Textfilter | Der Textfilter wird nicht verwendet.
Suche nach (Wörter getrennt durch Leerzeichen) | Der Textfilter wird verwendet. Die weiteren Optionen sind freigeschalten.
Eingabefeld | Geben Sie die entsprechenden Wörter bzw. Zeichenketten ein.
Optionen |
Groß-/Kleinschreibung beachten | Aktiv: Beim Filtern wird zwischen Groß- und Kleinschreibung unterschieden.
Wörter müssen nicht vollständig im Text vorkommen | Aktiv: Auch Wortteile werden beim Filtern berücksichtigt.
Mindestens ein Wort muss im Text vorkommen | Aktiv: Mindestens ein Wort des Suchstrings muss im Text vorkommen.
Alle Wörter müssen im Text vorkommen | Aktiv: Alle Wörter des Suchstrings müssen im Text vorkommen. Die Reihenfolge spielt dabei keine Rolle.
Filtertext muss exakt im Text vorkommen | Aktiv: Der Text muss exakt wie im Suchstring definiert im vorkommen.


Status

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Status

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Zustand der Checkbox gibt an, ob das Statusbit ausgewertet werden soll.

Status der Checkbox | Beschreibung
schwarzer Punkt | Das Statusbit wird nicht ausgewertet.
0 | Es werden nur die Einträge angezeigt, bei denen das Statusbit auf false steht.
1 | Es werden nur die Einträge angezeigt, bei denen das Statusbit auf true steht.

Example Beispiel

Ist die Checkbox SPONT auf 1 gesetzt, werden nur die Alarme angezeigt, die durch Spontanwerte hervorgerufen wurden.

Hinweis: Details zu Statusbits finden Sie im Kapitel Statusverarbeitung.


Projekt

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Projekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auswahl der Projekte, die für die AML berücksichtigt werden sollen. Der Filter zur Auswahl von Unterprojekten steht nur im Integrationsprojekt der Mehrprojektverwaltung zur Verfügung.

Die Auswahl aus dem Integrationsprojekt und allen Unterprojekten erfolgt per Multiselect durch Halten der Taste Strg und Mausklick auf die gewünschten Projekte.


Anlagenmodellierung

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste -> Anlagenmodellierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Filter werden alle bereits erstellten Anlagenmodelle angezeigt. Über das Kontextmenü oder die Menüleiste, können neue Modelle und Gruppen angelegt werden.

Um Gruppen zum Filter hinzuzufügen:

  1. wählen Sie das gewünschte Element
  2. klicken Sie auf die Schaltfläche Hinzufügen
  3. wiederholen Sie den Vorgang, bis alle benötigten Gruppen in der Liste enthalten sind
    (Multiselect ist nicht möglich)

Um Gruppen aus dem Filter zu entfernen:

  1. wählen Sie die gewünschten Elemente
    (Multiselect: Taset Strg oder Taste Umschalt gedrückt halten und gewünschte Elemente anklicken)
  2. klicken Sie auf die Schaltfläche Entfernen

Element | Beschreibung
Anlagenmodell | bietet Modelle und Gruppen zur Auswahl an
Hinzufügen | fügt ausgewählte Gruppe zur Filterliste hinzu
Entfernen | entfernt ausgewählte Gruppe aus Filterliste


Filter für Bildumschaltung Alarmmeldeliste Filter

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Alarmmeldeliste Filter zu projektieren:

  1. erstellen Sie eine Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste Filter
  2. der Filter wird mit allen Registerkarten angezeigt:
    • Bilder
    • Allgemein
    • Text
    • Zeit

Noch in diesem Kapitel

Bilder

Allgemein

Text

Zeit


Bilder

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste Filter -> Bilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Registerkarte definieren Sie die Bilder, die durch den Bildfilter aktualisiert werden sollen.

Folgende Einstellungen stehen Ihnen zur Verfügung:

Parameter

Beschreibung

Filter wird aus folgendem Bild übernommen

Aufrufendes Bild

Aktiv: Die Filtereinstellungen werden aus dem Bild übernommen, möchten, aus dem das Filterbild aufgerufen wird. Die Schaltfläche Bild ist ausgegraut. Sie können kein Bild explizit angeben, da bei dieser Einstellung die Filteraktualisierung immer vom aufrufenden Bild aus erfolgt.

Hinweis: Einstellungen in den Registerkarten Allgemein, Text und Zeit sind gesperrt.

Bildauswahl

Klick auf Schaltfläche öffnet den Bildauswahldialog.

Selektieren Sie das Bild, von dem der Filter - beim Betätigen des Buttons Aktualisieren in der Runtime - gelesen werden soll.

Hinweis: Es ist nur sinnvoll ein Bild zu selektieren, das den Bildfilter übernehmen bzw. füllen kann.

Das selektierte Bild wird in die Liste der zu aktualisierenden Bilder eingetragen. Wenn Sie es aus der Liste löschen, wird automatisch das nächste Bild aus der Liste hier eingetragen.

Hinweis: Nicht verfügbar, wenn Sie die Checkbox Aufrufendes Bild aktiviert haben.

Zu aktualisierende Bilder

Bildauswahl

Klick auf Schaltfläche öffnet Dialog zur Bildauswahl der Filterbilder. Wählen Sie die gewünschten Bilder.

Aktualisierung

Auf allen Monitoren aktualisieren

Aktiv: Die Bilder aus der Liste der zu aktualisierenden Bilder werden auf allen verfügbaren Monitoren aktualisiert.


Allgemein

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste Filter -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Variablenfilter

Einschränkung auf Alarme bestimmter Variablen

Variablenname

Geben Sie den Namen oder den Teil des Namens von Variablen an, nach dem Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Kennung

Geben Sie die Kennung oder die Teilkennung von Variablen an, nach der Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Groß-/Kleinschreibung beachten

Aktiv: Groß- und Kleinschreibung wird bei der Filterung nach Variablenname und/oder Kennung beachtet.

Alarmart

Art der Alarme, die angezeigt werden.

Nur nicht quittierte Alarme

Aktiv: Es werden nur Alarme angezeigt, die vom Benutzer noch nicht quittiert wurden.

Nur gegangene Alarme

Aktiv: Es werden nur Alarme angezeigt, die schon gegangen sind; d.h. deren Werte nicht mehr im kritischen Bereich sind.

Nur anstehende Alarme

Aktiv: Es werden nur Alarme angezeigt, die noch anstehen; d.h. deren Werte sich noch im kritischen Bereich befinden.

Alarme müssen mindestens anstehen

Definieren Sie mithilfe der Spincontrols wie lange ein Alarm mindestens anstehen muss, damit er angezeigt wird. Mögliche Einstellungen:

  • Tage
  • Stunden (Std.)
  • Minuten (Min.)
  • Sekunden (Sek.)
  • Millisekunden (ms)

Datenherkunft

Anzeige aktueller oder aktueller und historischer Alarme.

Ringpuffer

Aktiv: Es werden nur Daten aus dem Ringpuffer angezeigt.

Historische Daten
Maximale Anzahl

Aktiv: Es werden Daten aus dem Ringpuffer und historische Daten aus der AML angezeigt.

Die maximale Anzahl der anzuzeigenden Daten inkludiert die Daten aus dem Ringpuffer.

Runtime-Einstellungen

Verhalten der AML zur Runtime

Liste angehalten aufschalten

Aktiv: Solange die Liste angezeigt wird, werden keine neuen Einträge hinzugefügt.

Alarm/Ereignis-Gruppen/Klassen, Alarmbereiche

Auswahl von Gruppen, Klassen und Alarmbereichen.

Alarm/Ereignis-Gruppen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Gruppen jene aus, aus denen Alarme angezeigt werden sollen.

Alarm/Ereignis-Klassen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Klassen jene aus, aus denen Alarme angezeigt werden sollen.

Alarmbereiche

Wählen Sie aus den vorhandenen Alarmbereichen jene aus, aus denen Alarme angezeigt werden sollen.


Text

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste Filter -> Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Filtern nach |
Kein Textfilter | Der Textfilter wird nicht verwendet.
Suche nach (Wörter getrennt durch Leerzeichen) | Der Textfilter wird verwendet. Die weiteren Optionen sind freigeschalten.
Eingabefeld | Geben Sie die entsprechenden Wörter bzw. Zeichenketten ein.
Optionen |
Groß-/Kleinschreibung beachten | Aktiv: Beim Filtern wird zwischen Groß- und Kleinschreibung unterschieden.
Wörter müssen nicht vollständig im Text vorkommen | Aktiv: Auch Wortteile werden beim Filtern berücksichtigt.
Mindestens ein Wort muss im Text vorkommen | Aktiv: Mindestens ein Wort des Suchstrings muss im Text vorkommen.
Alle Wörter müssen im Text vorkommen | Aktiv: Alle Wörter des Suchstrings müssen im Text vorkommen. Die Reihenfolge spielt dabei keine Rolle.
Filtertext muss exakt im Text vorkommen | Aktiv: Der Text muss exakt wie im Suchstring definiert im vorkommen.


Zeit

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Alarmprojektierung über Filter -> Filter für Bildumschaltung Alarmmeldeliste Filter -> Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Definieren Sie auf dieser Registerkarte den Zeitbereich, der beim Öffnen des Filterbilds verwendet werden soll.

Folgende Einstellungen stehen Ihnen zur Verfügung:

Parameter

Option

Beschreibung

Absoluter Zeitraum

Es wird ein fixer Zeitbereich im Editor vorgegeben. Beim Ausführen der Funktion wird genau der eingestellte absolute Zeitbereich verwendet.
Beispiel: Sie möchten alle Alarme vom 1.1.2011 - 31.12.2011 sehen, dann geben Sie die entsprechenden Daten bei Von und Bis an.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Von

Definiert den Startzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Bis

Definiert den Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Relativer Zeitraum

Es wird ein relativer Zeitbereich angegeben.

Achtung! Dieser Filter wird ständig aktualisiert. Er wandert also mit.

Zum Beispiel: Sie stellen eine relative Zeit von 10 Minuten ein und schalten um 12:00 Uhr ein Bild vom Typ Alarmmeldeliste mit diesem Zeitfilter auf. Dann werden Ihnen beim Aufschalten die Alarme von 11:50 bis 12:00 angezeigt. Wenn das Bild vom Typ Alarmmeldeliste geöffnet bleibt, wird der Filter automatisch aktualisiert. Um 12:01 sehen Sie die Alarme von 11:51-12:01 usw.

Zeit

Definiert den relativen Zeitraum in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab HH:MM:SS Uhr

Es wird eine Uhrzeit angegeben, ab dem der Filter wirkt. Ist die Uhrzeit am heutigen Tag noch nicht erreicht, wird ab der entsprechenden Uhrzeit des Vortages gefiltert.

Beispiel: Sie geben 23:00:00 ein. Ist es bei der Ausführung der Funktion 23:30 Uhr, dann wird von 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist es jedoch 22:30 Uhr, dann wird vom Vortag 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag - HH:MM:SS Uhr

Es werden ein Tag und eine Uhrzeit für den Filterbeginn angegeben. Ist die angegebene Zeit im laufendem Monat noch nicht erreicht, wird die entsprechende Zeit des Vormonats verwendet.

Beispiel: Sie geben Tag 5 - 23:00:00 ein. Ist es bei der Ausführung der Funktion der 10. des Monats um 23:30 Uhr , dann wird vom 5. des Monats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. des Monats, dann wird vom 5. des Vormonats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filter wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag, Monat - HH:MM:SS Uhr

Es werden ein Monat, ein Tag und eine Uhrzeit für den Filterbeginn eingegeben. Ist die angegebene Zeit im laufenden Jahr noch nicht erreicht, wird die entsprechende Zeit des Vorjahres verwendet.

Beispiel: Sie geben Monat Oktober, Tag 5 - 23:00:00 ein. Ist bei der Ausführung der Funktion der 10. Oktober um 23:30 Uhr, dann wird vom 5. Oktober ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. Oktober, dann wird vom 5. Oktober des Vorjahres ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und der 5. Oktober 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Monaten, Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Kein Zeitfilter

Es wird kein Zeitfilter verwendet.


Funktionen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über Funktionen werden zur Runtime die Anzeige und Handhabung der Alarmmeldeliste gesteuert.

attention Achtung

Werden Funktionen im Netzwerk eingesetzt, beachten Sie deren Ausführungsort.

Noch in diesem Kapitel

Funktionen im Netzwerk

Bildumschaltung AML

Bildumschaltung AML Filter

Funktionen für Alarmverwaltung


Funktionen im Netzwerk

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen im Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Funktionen im Netzwerk eingesetzt werden, muss deren Ausführungsort beachtet werden:

Bei Funktionen, die im Netzwerk eingesetzt werden:

  • kann der Ausführungsort in manchen Fällen frei konfiguriert werden
  • ist der Ausführungsort in manchen Fällen fest vorgegeben

info Info

Skripte bündeln mehrere Funktionen. Der Ausführungsort hängt dann ab von den Einstellungen der Funktion Skript ausführen. Diese Einstellung überschreibt die Einstellungen der einzelnen Funktionen.

Ausführungsort konfigurieren

Bei Funktionen, deren Ausführungsort frei konfiguriert werden kann, stehen bei den Eigenschaften der Funktion entsprechende Parameter zur Verfügung. Um den Ausführungsort zu definieren:

  1. Navigieren Sie in den Eigenschaften der Funktion zur Gruppe Ausführung.

    Interne ID: Funktionen im Netzwerk

    Ausführung

    Nur verfügbar in Netzwerk-Projekten:
    Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Wählen Sie den gewünschten Ausführungsort durch Aktivierung der Checkbox aus. Mehrfachauswahl ist möglich:
    • Aktueller Rechner: Funktion wird auf dem aktuellen Rechner ausgeführt.

      Interne ID: Funktionen im Netzwerk

      Aktueller Rechner

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf dem Rechner ausgeführt, auf dem sie angestossen wurde.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Server: Funktion wird auf dem Server ausgeführt.

      Interne ID: Funktionen im Netzwerk

      Server

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf dem Server des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Standby: Funktion wird auf dem Server ausgeführt

      Interne ID: Funktionen im Netzwerk

      Standby

      Nur verfügbar in redundanten Netzwerk-Projekten:
      Die Funktion wird auf dem Standby-Server des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Client: Funktion wird auf allen Clients ausgeführt.

      Interne ID: Funktionen im Netzwerk

      Client

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf allen Clients des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Übersicht Funktionen im Netzwerk

Die folgende Tabelle zeigt, welche Funktionen wo ausgeführt werden.

Legende:

  • Einstellbar: Verhalten kann konfiguriert werden

    +: Ja

    -: Nein

    O: Default

  • Wenn nicht einstellbar, kennzeichnet O den Ausführungsort:
    • Aktiver Rechner
    • Server
    • Standby
    • Client

Funktion | Einstellbar | Aktueller Rechner | Server | Standby | Client
AML und CEL |  |  |  |  |
Alarme blinkquittieren | - | O |  |  |
Alarme löschen | - |  | O | O |
Alarme quittieren | - |  | O | O |
Alarm/Ereignis-Gruppe abmelden/anmelden | - | O |  |  |
Alarmmeldeliste/Alarm/Ereignis-Gruppen/Alarm/Ereignis-Klassen aktivieren/deaktivieren | - |  | O | O |
Alarmmeldeliste aktiv | - |  | O |  |
Alarmmeldeliste aktiv/inaktiv | - |  | O |  |
Alarmmeldeliste inaktiv | - |  | O |  |
AML exportieren | + | O |  |  |
AML- und CEL-Ringpuffer speichern | - |  | O | O |
CEL exportieren | + | O |  |  |
Drucken AML oder CEL | + | O |  |  |
IPA-Dokument erzeugen/drucken | - |  | O |  |
Online-Drucken ein/ausschalten | - |  | O | O |
Online-Drucken neue Seite beginnen | + | O |  |  |
Online-Drucker umschalten | - |  | O |  |
Anwendung |  |  |  |  |
Drucker wählen | + | O |  |  |
EMS starten | - |  | O |  |
EMS stoppen | - |  | O |  |
Erweiterter Trend Diagramm drucken | + | O |  |  |
Farbpalette umschalten | + | O |  |  |
Funktionen bei Grenzwerten aktiv | - |  | O | O |
Funktionen bei Grenzwerten aktiv/inaktiv | - |  | O | O |
Funktionen bei Grenzwerten inaktiv | - |  | O | O |
Hilfe aufrufen | + | O |  |  |
Nachladen | + | O |  |  |
Offene Wartungen ermitteln | - |  | O |  |
PFS - benutzerdefiniertes Ereignis anstoßen | + | O |  |  |
Projektsimulation aktivieren/deaktivieren | - | O |  |  |
Rechtsklick simulieren | + | O |  |  |
Remanentdaten speichern | + | O |  |  |
Runtime beenden | + | O |  |  |
S7-Graph Heuristik auswerten | + | O |  |  |
SAP-Funktion ausführen | + | O |  |  |
Sprachumschaltung | + | O |  |  |
Topologie - Erdschlusssuche | - |  | O |  |
Topologie - LoadShedding | - |  | O |  |
Archivserver |  |  |  |  |
Archiv beenden | - |  | O | O |
Archiv indizieren | - |  | O |  |
Archiv starten | - |  | O | O |
Archive exportieren | - | O |  |  |
Offene Archive anzeigen | - |  | O | O |
Benutzerverwaltung |  |  |  |  |
Benutzer ändern | + | O |  |  |
Login mit Dialog | + | O |  |  |
Login ohne Passwort | + | O |  |  |
Logout | + | O |  |  |
Passwort ändern | - | O |  |  |
Bilder |  |  |  |  |
ALC-Quellfarbe ändern | + | O |  |  |
Bild indiziert | - | O |  |  |
Bild schließen | + | O |  |  |
Bild zurück | - | O |  |  |
Bildmittelpunkt verschieben | + | O |  |  |
Bildumschaltung | + | O |  |  |
Eingabe auf Element mit Fokus aktivieren | +- | O |  |  |
Fokus auf Schablone setzen | + | O |  |  |
Fokus verschieben | - | O |  |  |
Fokus von Schablone nehmen | + | O |  |  |
Menü anzeigen | + | O |  |  |
Monitor zuordnen | + | O |  |  |
Runtimeprofile | + | O |  |  |
Schablone schließen | + | O |  |  |
Sollwertvorgabe für Keyboard-Bild | - | O |  |  |
Übersichtsfenster anzeigen | + | O |  |  |
Fehlerortung in elektrischen Netzen |  |  |  |  |
Erdschlussmeldung quittieren | + | O |  |  |
Erdschlusssuche beenden | + | O |  |  |
Erdschlusssuche starten | + | O |  |  |
Kurzschlussmeldung quittieren | + | O |  |  |
Message Control Hinweis: Ausführungsorte sind theoretisch frei einstellbar. Änderungen haben aber keine Auswirkung. Message Control wird immer am Server ausgeführt. |  |  |  |  |
Empfängerdatenbank anzeigen | + | O |  |  |
Sende Nachricht | + | O |  |  |
Sende Nachricht aktivieren | + | O |  |  |
Sende Nachricht deaktivieren | + | O |  |  |
Netzwerk |  |  |  |  |
Bedienberechtigung im Netz | + | O |  |  |
Redundanz Umschaltung | - |  |  | O |
Report Generator |  |  |  |  |
Drucken Report | + |  |  |  |
Report ausführen | + |  |  |  |
Report exportieren | + |  |  |  |
Rezepte |  |  |  |  |
Rezeptgruppen-Manager | - | O |  |  |
Standard-Rezept | - | O |  |  |
Standard-Rezept einzeln direkt | + | O | O | O | O
Standard-Rezept einzeln mit Auswahl | - | O |  |  |
Standard-Rezept einzeln mit Online-Auswahl | - | O |  |  |
Skript |  |  |  |  |
Skript ausführen | + | O |  |  |
Skript mit Online-Auswahl | + | O |  |  |
Variable |  |  |  |  |
Daten exportieren | - |  | O |  |
dBase Datei lesen | + | O |  |  |
Drucken Momentanwerte | + | O |  |  |
Einheitenumschaltung | + | O |  |  |
HD-Verwaltung aktiv | - |  | O | O |
HD-Verwaltung inaktiv | - |  | O | O |
HD-Verwaltung inaktiv/active | - |  | O | O |
Sollwert absetzen | - |  | O |  |
Treiberkommandos | - | O |  |  |
Treiber Simulationsabbild an Standby übertragen | - |  |  |  | O
Uhrzeit auf Variable schreiben | + | O |  |  |
Uhrzeit von Variable lesen | + | O |  |  |
VBA |  |  |  |  |
PCE-Editor öffnen | - |  | O |  |
VBA-Editor öffnen | + | O |  |  |
VBA-Makro ausführen | + | O |  |  |
VBA-Makro Dialog Anzeigen | + | O |  |  |
VSTA |  |  |  |  |
VSTA-Editor öffnen | + | O |  |  |
VSTA-Marko ausführen | + | O |  |  |
VSTA-Makro Dialog anzeigen | + | O |  |  |
Windows |  |  |  |  |
Audiodatei ausführen | + | O |  |  |
Dateioperation | + | O |  |  |
Dauerton Start | + | O |  |  |
Dauerton Stopp | + | O |  |  |
In den Hintergrund | - | O |  |  |
In den Vordergrund | - | O |  |  |
Screenshot drucken | + | O |  |  |
Starte Programm | + | O |  |  |


Bildumschaltung AML

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Bildumschaltung AML

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Alarmmeldeliste zur Runtime aufzuschalten:

  1. legen Sie ein Bild vom Typ Alarmmeldeliste an
  2. erstellen Sie eine Funktion Bildumschaltung auf das Bild
  3. definieren Sie die gewünschten Filtereigenschaften

Zur Runtime können die Filtereigenschaften modifziert werden. Ausnahme: Im Editor wurden feste Zeitfilter definiert.

Bildumschaltung projektieren

Um eine Bildumschaltung auf ein Bild vom Typ AML anzulegen:

  1. wählen Sie im Kontextmenü des Knotens Funktion den Befehl Funktion neu
  2. klicken Sie auf Bildumschaltung
  3. der Dialog zur Bildauswahl wird angezeigt
  4. wählen Sie das Bild vom Typ Alarm
    oder legen Sie es in diesem Dialog mit Klick auf das Symbol Bild neu an
  5. der Filter wird mit allen Registerkarten angezeigt:
    • Allgemein
    • Zeit
    • Spalteneinstellungen
    • Text
    • Status
    • Projekt (Steht nur im Integrationsprojekt der Mehrprojektverwaltung zur Verfügung.)
    • Anlagenmodellierung

    Optional können, wenn verknüpfte Variablen oder Indizes vorhanden sind, noch folgende Registerkarten angezeigt werden:

    • Verknüpfungen ersetzen
    • Indizes ersetzen

  6. definieren Sie die Filter, die zur Runtime vordefiniert sein sollen
  7. bestätigen Sie die Einstellungen und schließen Sie den Dialog mit Klick auf OK
  8. verknüpfen Sie die Funktion mit einem Button, um zur Runtime auf das Bild umzuschalten und die Filtereigenschaften anzubieten

info Info

Wird auf ein Bild referenziert, das keine Zeitfilter hat, dann werden die Zeitfilter deaktiviert.

Noch in diesem Kapitel

Filter Bildumschaltung AML


Filter Bildumschaltung AML

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Bildumschaltung AML -> Filter Bildumschaltung AML

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen einer Bildumschaltung auf ein Bild vom Typ AML werden mehrere Filter angeboten. Details siehe Abschnitt Alarmprojektierung über Filter, Kapitel Filter für Bildumschaltung Alarmmeldeliste.


Bildumschaltung AML Filter

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Bildumschaltung AML Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Alarmmeldeliste Filter zur Runtime aufzuschalten:

  1. legen Sie ein Bild vom Typ Alarmmeldeliste Filter an
  2. erstellen Sie eine Funktion Bildumschaltung auf das Bild
  3. definieren Sie die gewünschten Filtereigenschaften

Die Filtereigenschaften lassen sich zur Runtime nur über die im Bild definierten Buttons steuern.

Bildumschaltung projektieren

Um eine Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste Filter anzulegen:

  1. wählen Sie im Kontextmenü des Knotens Funktion den Befehl Funktion neu
  2. klicken Sie auf Bildumschaltung
  3. der Dialog zur Bildauswahl wird angezeigt
  4. wählen Sie das Bild vom Typ Alarmmeldeliste Filter
    oder legen Sie es in diesem Dialog mit Klick auf das Symbol Bild neu an
  5. der Filter wird mit allen Registerkarten angezeigt:
    • Bilder
    • Allgemein
    • Text
    • Zeit

  6. definieren Sie die Filter, die zur Runtime vordefiniert sein sollen
  7. bestätigen Sie die Einstellungen und schließen Sie den Dialog mit Klick auf OK
  8. verknüpfen Sie die Funktion mit einem Button, um zur Runtime auf das Bild umzuschalten und die Filtereigenschaften anzubieten

Noch in diesem Kapitel

Filter Bildumschaltung AML Filter


Filter Bildumschaltung AML Filter

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Bildumschaltung AML Filter -> Filter Bildumschaltung AML Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen einer Bildumschaltung auf ein Bild vom Typ AML werden mehrere Filter angeboten. Details siehe Abschnitt Alarmprojektierung über Filter, Kapitel Filter Alarmmeldeliste Filter.


Funktionen für Alarmverwaltung

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verschiedene Funktionen ermöglichen die Handhabung von Alarmen zur Runtime.

Um eine Funktion für die Alarmverwaltung zu erstellen:

  1. navigieren Sie zum Knoten Funktionen
  2. wählen Sie im Kontextmenü oder auf der Symbolleiste den Befehl Funktion neu
  3. der Dialog zur Auswahl von Funktionen wird geöffnet
  4. navigieren Sie zum Knoten AML/CEL

  5. wählen Sie die gewünschte Funktion
  6. konfigurieren Sie die Funktion, wenn nötig
  7. verknüpfen Sie die Funktion mit einem Button

Noch in diesem Kapitel

Alarm/Ereignis-Gruppe abmelden/anmelden

Alarme blinkquittieren

Alarme löschen

Alarme quittieren

Alarmmeldeliste aktiv

Alarmmeldeliste aktiv/inaktiv

Alarmmeldeliste inaktiv

Alarmmeldeliste, Alarm/Ereignis-Gruppen/Klassen aktivieren/deaktivieren

AML exportieren

AML- und CEL-Ringpuffer speichern

Drucken AML oder CEL

Online-Drucken ein/ausschalten

Online-Drucken neue Seite beginnen

Online Drucker umschalten


Alarm/Ereignis-Gruppe abmelden/anmelden

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarm/Ereignis-Gruppe abmelden/anmelden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Performance der Verbindung zu optimieren, können nicht benötigte Alarm/Ereignis-Gruppen abgemeldet werden. Damit werden deren Variablen vom Treiber nicht mehr angefordert.

Für diese Funktion müssen Sie:

  1. die Aktion definieren: abmelden oder anmelden
  2. die Alarm/Ereignis-Gruppe definieren
    (es kann nur eine Gruppe pro Funktion definiert werden)

Parameter

Beschreibung

Aktion

Legt Aktion fest. Mögliche Aktionen:

  • Abmelden: meldet Alarm/Ereignis-Gruppe ab
  • Anmelden: meldet Alarm/Ereignis-Gruppe an

Alarm/Ereignis-Gruppe

Auswahl der Alarm/Ereignis-Gruppe. Klick auf Schaltfläche öffnet Dialog zur Auswahl der Gruppe.

OK

Bestätigt Eingaben und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.

Beispiel

In der Steuerung wird ein Sammel-Alarm-Bit angelegt. Wird dieses Bit gesetzt, erfolgt über die Grenzwertverwaltung der Funktionsaufruf Alarm/Ereignis-Gruppe anmelden. Damit werden die Variablen angefordert, und die entsprechenden Grenzwerte in zenon überprüft. Das Bit kann dann in der Steuerung zurückgesetzt werden. Über einen Grenzwert kann die Alarm/Ereignis-Gruppe wieder abgemeldet werden. Bei Programmstart werden alle Grenzwertvariablen angefragt.


Alarme blinkquittieren

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarme blinkquittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Blinkquittieren zur Runtime wird nur das Blinkattribut der Prozessvariablen und das Blinken aller grafischen Elemente im Bild zurückgesetzt. Der Eintrag in der Alarmmeldeliste wird nicht quittiert - ausgenommen, die Eigenschaft Blink-Quittierung ist aktiv.

Interne ID: Alarme blinkquittieren

Blink-Quittierung

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Mit dem Quittieren des Blinkens eines Elements wird auch der entsprechende Alarm in der Alarmmeldeliste quittiert
Inaktiv: Das Quittieren des Blinkens eines Elements beendet nur das Blinken. Der entsprechende Alarm wird nicht quittiert.
Default: inaktiv.
Das Blinken von Elementen kann durch einen Doppelklick mit der rechten Maustaste auf das entsprechende Element oder durch die Funktion "Blinkquittieren" quittiert werden.

Interne ID: Alarme blinkquittieren

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um das Blinken von Alarmen zur Runtime zu quittieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Alarme blinkquittieren
  3. der Dialog zur Auswahl der Schablone öffnet sich
  4. wählen Sie die gewünschte Schablone
  5. wählen Sie bei Mehr-Monitor-Systemen den gewünschten Monitor
  6. verknüpfen Sie die Funktion mit einem Button

Parameter

Beschreibung

Schablone auswählen

Schablone, für die blinkquittiert werden soll.

Monitor

wählen Sie bei Mehr-Monitor-Projekten den virtuellen Monitor für die Ausführung:

  • aktueller Monitor
  • bestimmter virtueller Monitor

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.


Alarme löschen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarme löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Alarme gesammelt über Filterkriterien zu löschen, verwenden Sie die Funktion Alarme löschen:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Alarme löschen
  3. der Dialog zur Auswahl der Filterkriterien öffnet sich
    (analog zu Filterkriteren in der Bildumschaltung)

  4. definieren Sie die Kriterien für:
    • Allgemein
    • Zeit
    • Text
    • Status
  5. verknüpfen Sie die Funktion mit einem Button

Benutzerrechte

Die Funktionen Alarme quittieren und Alarme löschen können über Funktionsberechtigungen einer Benutzergruppe zugeordnet werden. Nur berechtigte Nutzer können dann Alarme quittieren oder löschen.

Zusätzlich kann bei den Grenzwerten der Variablen über die Eigenschaft Löschpflichtig in der jeweiligen Subgruppe der Gruppe Grenzwerte ein zusätzliches Bedienrecht gesetzt werden. Ausgewählte Alarme können damit nur von speziell berechtigten Personen aus der Alarmmeldeliste entfernt werden.

Interne ID: Alarme löschen

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: Alarme löschen

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarme löschen

Löschpflichtig

Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Kein Löschen erforderlich.
Default: inaktiv

Interne ID: Alarme löschen

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wurde die Eigenschaft Löschpflichtig gesetzt, werden Alarme erst dann aus der Liste der aktiven Alarme entfernt, wenn sie gelöscht wurden. Quittieren alleine reicht dann nicht aus.

info Info

Alarme können nur dann gelöscht werden, wenn sie quittiert wurden.


Alarme quittieren

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarme quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion quittieren Sie zur Runtime Alarme aus der Alarmmeldeliste. Vor allem ist damit auch globales Quittieren möglich.

Bei der Aktivierung der Funktion während der Runtime wird auch das Blinkattribut der Variablen und damit die Bildalarmierung (nur SICAM 230) zurückgesetzt. Die selektierten Alarme werden quittiert.

Für die Übergabeparameter siehe Kapitel Alarmprojektierung über Filter.

Um Alarme mit dieser Funktion zu quittieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Alarme quittieren
  3. der Dialog zur Auswahl der Filterkriterien öffnet sich
    (analog zu Filterkriterien in der Bildumschaltung)

  4. definieren Sie die Kriterien für:
    • Allgemein
    • Zeit
    • Text
    • Status
  5. verknüpfen Sie die Funktion mit einem Button

Benutzerrechte

Die Funktionen Alarme quittieren und Alarme löschen können über Funktionsberechtigungen einer Benutzergruppe zugeordnet werden. Nur berechtigte Nutzer können dann Alarme quittieren oder löschen.

Zusätzlich kann bei den Grenzwerten der Variablen über die Eigenschaft Löschpflichtig in der jeweiligen Subgruppe der Gruppe Grenzwerte ein zusätzliches Bedienrecht gesetzt werden. Ausgewählte Alarme können damit nur von speziell berechtigten Personen aus der Alarmmeldeliste entfernt werden.

Interne ID: Alarme quittieren

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: Alarme quittieren

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarme quittieren

Löschpflichtig

Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Kein Löschen erforderlich.
Default: inaktiv

Interne ID: Alarme quittieren

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wurde die Eigenschaft Löschpflichtig gesetzt, werden Alarme erst dann aus der Liste der aktiven Alarme entfernt, wenn sie gelöscht wurden. Quittieren alleine reicht dann nicht aus.

info Info

Alarme können nur dann gelöscht werden, wenn sie quittiert wurden.


Alarmmeldeliste aktiv

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarmmeldeliste aktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion schaltet zur Runtime den Status der Alarmmeldeliste beim Aufruf auf aktiv um.


Alarmmeldeliste aktiv/inaktiv

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarmmeldeliste aktiv/inaktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion schaltet zur Runtime den Status der Alarmmeldeliste bei jedem Aufruf zwischen aktiv und inaktiv um.


Alarmmeldeliste inaktiv

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarmmeldeliste inaktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion schaltet zur Runtime den Status der Alarmmeldeliste beim Aufruf auf inaktiv um.


Alarmmeldeliste, Alarm/Ereignis-Gruppen/Klassen aktivieren/deaktivieren

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Alarmmeldeliste, Alarm/Ereignis-Gruppen/Klassen aktivieren/deaktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion ermöglicht es, Alarme einer bestimmten Gruppe oder Klasse oder alle Alarme der AML zu aktivieren und deaktivieren oder zwischen diesen beiden Zuständen umzuschalten.

Um Alarme an- oder abzumelden:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Alarmmeldeliste, Alarm/Ereignis-Gruppen/Klassen aktivieren/deaktivieren
  3. der Dialog zur Auswahl der Alarme öffnet sich
  4. definieren Sie die Kriterien für die Funktion
  5. verknüpfen Sie die Funktion mit einem Button

Parameter | Beschreibung
Auswahl | Auswahl der Alarme.
gesamte Alarmmeldeliste | Funktion gilt für gesamte Alarmmeldeliste.
Alarme der Alarm/Ereignis-Gruppe | Funktion gilt für eine bestimmte Gruppe. Auswahl: Klick auf Schaltfläche öffnet Dropdownliste.
Alarme der Alarm/Ereignis-Klasse | Funktion gilt für eine bestimmte Klasse. Auswahl: Klick auf Schaltfläche öffnet Dropdownliste.
aktivieren/deaktivieren | Aktion der Funktion.
aktivieren | Aktiviert ausgewähltes Element.
deaktivieren | Deaktiviert ausgewähltes Element.
toggeln | Schaltet Zustand (aktiv/inaktiv) um.


AML exportieren

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> AML exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion können zur Runtime die gespeicherten Alarme mit Filterbedingungen in eine Datei oder Datenbank exportiert werden.

Um Alarme zu exportieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie AML exportieren
  3. der Dialog zur Auswahl der Filterkriterien öffnet sich
  4. definieren Sie die Kriterien für:
    • Exportformat
    • Allgemein
    • Zeit
    • Projekt
  5. verknüpfen Sie die Funktion mit einem Button

Noch in diesem Kapitel

Exportformat


Exportformat

Exportformat

Exporte sind unterschiedliche Formate möglich:

  • dBase
  • CSV
  • XML
  • SQL

info Info

Der Export nach SQL erfolgt inkrementell. Liegen bereits exportierte Daten vor, werden nur neue und geänderte Daten exportiert.

Parameter

Beschreibung

Exportformat

Auswahl des Dateityps. Mögliche Formate:

  • dBase: DBaseIV-Format (*.dbf):
  • CSV
  • XML
  • SQL

Hinweis zu dBase:

  • Dateinamen dürfen nicht länger als acht Zeichen sein.
  • Projektierte Spaltenbreite wird für Export verwendet. Ist z. B. unter Spalteneinstellungen ein Wert von 40 Zeichen eingestellt, werden auch nur maximal 40 Zeichen exportiert.
  • Es werden maximal 255 Zeichen exportiert.

Optionen

Als Unicode exportieren

Export in ASCII-Format erfolgt in Unicode.

Inkrementell exportieren

Es werden nur Unterschiede seit dem letzten Export exportiert.

Export in Datei

Festlegung der Datei, in der der Export gespeichert wird.

Dateiname

Dateiname individuell festlegen.

Maximal 32 alphanumerische Zeichen inklusive Dateiendung.

Hinweis: Bestehende Dateien gleichen Namens werden überschrieben.

Dateinamen automatisch generieren

Aktiv : Der Dateinamen wird aus einer Kurzkennung, einem Datumsschlüssel und einem individuellen Postfixautomatisch generiert.
Inaktiv : Der Dateiname wird vom Benutzer unter Dateiname eingegeben.

(Bestehende Dateien werden nicht überschrieben.)

Details siehe nächste Tabelle: Kodierung Name für automatische Namensvergabe

Postfix

Freie, individuelle Kennung. Steht nur für Dateinamen automatisch generieren zur Verfügung.

Mögliche Eingaben:

  • dBase: 1 alphanumerisches Zeichen
  • ASCII und XML: 32 alphanumerische Zeichen

Beispiel

Anzeige des vollständigen Dateinamens bei automatischer Generierung.

Eingestellter Exportordner

Anzeige des aktuell in den Projekteigenschaften eingestellten Exportpfades . (Eigenschaft Runtime-Ordner im Knoten Allgemein/Name/Ordner.)

Interne ID: Exportformat

Name/Ordner

Eigenschaften für den Namen und den Speicherplatz des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Exportformat

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Exportformat

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Export in SQL-Datenbank

Parameter für den Export in eine SQL-Datenbank

Datenbankverbindung

Konfiguration der Datenbankverbindung. Klick auf Schaltfläche ... öffnet Konfigurationsdialog.

Tabelle

Auswahl der Tabelle, in die geschrieben werden soll.

Registerkarte Allgemein

Allgemeiner Filter. Siehe Kapitel Alarmprojektierung über Filter, Abschnitt Allgemein.

Registerkarte Zeit

Zeitfilter. Siehe Kapitel Alarmprojektierung über Filter, Abschnitt Zeit.

Projekt

Projektfilter. Nur vorhanden im Integrationsprojekt der Mehrprojektverwaltung.

Konfiguration siehe Kapitel Alarmprojektierung über Filter, Abschnitt Projekt.

Kodierung Name für automatische Namensvergabe

Name

AJJMMTTP.XXX

A

Kurzkennung der Alarmmeldeliste

JJMMTT

Datumsangabe:

  • JJ: Jahr, zweistellig
  • MM: Monat, zweistellig
  • TT: Tag, zweistellig

P

Freie, individuelle Kennung:

  • dBase: 1 alphanumerisches Zeichen
  • ASCII und XML: 32 alphanumerische Zeichen

XXX

Dateiendung:

  • DBF: dBase
  • TXT: CSV
  • XML: XML

Formales

  • Format der Zeileneinträge: wird aus den Einstellungen der Eigenschaft Spalteneinstellung AML bzw.Spalteneinstellung CEL übernommen.

    Interne ID: Exportformat

    Spalteneinstellung CEL

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
    Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

    Interne ID: Exportformat

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Exportformat

    Spalteneinstellung AML

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
    Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

    Interne ID: Exportformat

    Alarmmeldeliste aktiv

    Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
    Inaktiv: Alarme werden nicht aufgezeichnet.
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Spaltentrennzeichen: Semikolon (Strichpunkt ;)

attention Achtung

Millisekunden für Druck und Export

Soll beim Drucken oder Exportieren von AML oder CEL die Zeit in Millisekunden angegeben werden, muss diese Eigenschaft im Dialog für die Spalteneinstellungen aktiviert werden. Dazu:

  • navigieren Sie in den Projekteigenschaften zum Knoten Alarmmeldeliste bzw. Chronologische Ereignisliste

    Interne ID: Exportformat

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Exportformat

    Alarmmeldeliste

    Eigenschaften für die Alarmkonfiguration.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • klicken Sie auf die Schaltfläche ... der Eigenschaft Spalteneinstellung AML bzw. Spalteneinstellung CEL
  • der Dialog für die Spalteneinstellung wird geöffnet
  • aktivieren Sie die Checkbox vor der Eigenschaft Millisekunden

Die Einstellung muss für AML und CEL jeweils extra vorgenommen werden.


AML- und CEL-Ringpuffer speichern

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> AML- und CEL-Ringpuffer speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion können zur Runtime der Inhalt der Ringpuffers für Alarme und Ereignisse sowie die Werte von Mathematik-Variablen (Zähler) gespeichert werden. Die Einträge werden in folgenden Dateien gespeichert:

Datei

Inhalt

Größe einstellbar über Eigenschaft

ALARM.BIN

Alarme

Größe des Ringpuffers

Interne ID: AML- und CEL-Ringpuffer speichern

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: AML- und CEL-Ringpuffer speichern

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

CEL.BIN

Einträge der Chronologischen Ereignisliste

Größe des Ringpuffers

Interne ID: AML- und CEL-Ringpuffer speichern

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Größe des CEL-Ringpuffers. Bei Überlauf des Ringpuffers (cel.bin) werden die Einträge in das CEL-Archiv (*.cel) übertragen.
Minimum: 1
Maximum: 32767
Default: 100

Interne ID: AML- und CEL-Ringpuffer speichern

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Zur Runtime werden eventuell mehr Einträge als projektiert angezeigt, da alte Einträge erst beim Aktualisieren der Liste aus der CEL entfernt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SY_MA32.BIN

Werte mathematischer Variablen (z.B. Zähler)

Um den AML-Ringpuffer zu speichern:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie AML- und CEL-Ringpuffer speichern
  3. verknüpfen Sie die Funktion mit einem Button


Drucken AML oder CEL

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Drucken AML oder CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion können zur Runtime die gespeicherten Alarme mit Filterbedingungen auf einem Drucker ausgegeben werden

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Drucken AML oder CEL
  3. der Dialog zur Auswahl der Liste öffnet sich

  4. wählen Sie Alarmmeldeliste
  5. der Dialog zur Auswahl der Filterkriterien öffnet sich
  6. definieren Sie die Kriterien für:
    • Allgemein
    • Zeit
    • Schrift: Auswahl aus den in zenon definierten Schriften
  7. verknüpfen Sie die Funktion mit einem Button

info Info

Zur Runtime kann nicht zwischen CEL und AML umgeschaltet werden. Um beide Listen drucken zu können, müssen zwei Funktionen projektiert werden.

Zeilenaufbau

Datum/Zeit gekommen | Datum/Zeit gegangen | Datum/Zeit quittiert | Langtext | Zustandstext

Die zur Verfügung stehenden Schlüsselworte für die Formatierungsdatei (ALAR.FRM für Online-Druck und ALAR_G.FRM für Offline-Druck) und Beispiel für deren Verwendung finden Sie im Kapitel FRM-Konfigurationsdatei im Abschnitt Bedienen zur Runtime.

Eine FRM-Datei gliedert sich in drei Teile:

  • Kopfteil: am Seitebeginn
  • Listenteil: zyklisch pro Zeile
  • Fußteil: am Seitenende

Grundsätze

Beachten Sie beim Bearbeiten von FRM-Dateien:

  • Trennung der Listenteile:
    • Kopfteil und Listenteil sowie Listenteil und Fußteil werden durch %% getrennt.

      Diese Gliederungsmarkierung darf nur je einmal für den Listenteil und den Fußteil verwendet werden.

    • Achtung: Nach der letzten Zeile müssen mindestens zwei leere Absätze folgen. Andernfalls wird die Fußzeile nicht gedruckt!
  • Positionierung der einzelnen Einträge:
    Es dürfen nur Leerzeichen verwendet werden, keine Tabulatoren.
  • Bearbeiten der FRM-Datei in einem Texteditor:
    Automatischer Zeilenumbruch muss deaktiviert werden, da sonst unerwünschte Effekte in der Formatierung auftreten können.

Schlüsselwörter

Die Einstellung der Seitenlänge wird in den Projekteigenschaften unter AML and CEL vorgenommen oder über die Dateien ALARM.frm oder ALAR_G.frm bzw. BTB.frm.

Interne ID: Drucken AML oder CEL

AML und CEL

Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bitte beachten Sie:

  • Die Anzahl der Alarmeinträge pro Seite ergibt sich aus der vorgegebenen Anzahl an Zeilen (z.B. Lines per page 72) abzüglich der für Kopf- und Fußtexte verwendeten Zeilen.

    Interne ID: Drucken AML oder CEL

    Zeilen pro Seite

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Anzahl der Zeilen, die beim Online-Ausdruck pro Seite gedruckt werden.
    Minimum: 0

    Interne ID: Drucken AML oder CEL

    Drucken aktiv

    Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
    Inaktiv: Kein Online-Ausdruck findet statt.
    Default: aktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Maximum: 65535
    Default: 72

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Für die Verwendung der Schlüsselworte, die die Reaktivierung auswerten (Zeit, Anzahl), muss in der Alarmverwaltung die Option Use reactivated time aktiviert sein.

    Interne ID: Drucken AML oder CEL

    Reaktiviertzeit verwenden

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Aktiv: Wenn derselbe Alarm mehrmals hintereinander auftritt, wird nur eine Zeile in der Alarmmeldeliste erstellt. Zusätzliche Informationen (z.B. Alarmzähler) können in der Liste dargestellt werden.
    Inaktiv: Jeder Alarm erhält eine eigene Zeile in der Alarmmeldeliste.
    Default: inaktiv.

    Interne ID: Drucken AML oder CEL

    Alarmmeldeliste aktiv

    Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
    Inaktiv: Alarme werden nicht aufgezeichnet.
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • In der Formatierungsdatei sind Schlüsselworte und freie Texte verwendbar. Schlüsselworte können alternativ in Deutsch oder Englisch verwendet werden. Die Verwendung englischer Schlüsselwörter wird empfohlen.
  • Nicht jedes Schlüsselwort ist für jede Art von Druck (AML, CEL, online, offline) geeignet.

Die folgende Tabelle enthält Schlüsselwörter in Deutsch und Englisch und deren Einsatzmöglichkeiten:

Deutsch

Englisch

AML Offline

CEL Offline

AML Online

CEL Online

Beschreibung

Schlüsselwörter für den Listenteil

@DATZEITKOMMT

@DTRECEIVED

X

X

X

X

Datum und Zeitpunkt des Alarmauftretens

@DATZEITGEHT

@DTCLEARED

X

-

X

-

Datum und Zeitpunkt des Alarmendes

@DATZEITOK

@DTACK

X

-

X

-

Datum und Zeitpunkt der Alarmquittierung

@DATZEITREAKT

@DTREACTIVATE

X

-

X

-

Datum und Zeitpunkt der Reaktivierung:

Eigenschaft Use reactivated time in Projekteigenschaften muss aktiviert sein.

@DATZEIT

@DTLASTEVENT

-

-

X

-

Datum und Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEIT

@TLASTEVENT

-

-

X

X

Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEITOK

@TACK

X

-

X

-

gibt nur Zeitpunkt der Quittierung an

@ZTKOMMT

@TRECEIVED

X

X

X

X

gibt nur Zeitpunkt des Alarmauftretens an

@ZTGEHT

@TCLEARED

X

-

X

-

gibt nur Zeitpunkt der Alarmendes an

@ZTREAKT

@TREACTIVATE

X

-

X

-

gibt nur Zeitpunkt der Reaktivierung an

@TIMELASTING

@TACTIVE

X

-

X

-

Zeit anstehend (Differenz Zeit Kommt - Zeit geht)

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@KANALNAME

@VARNAME

X

X

X

X

Variablenanme
CEL: Nur Einträge mit Variablen

@AK

@ACLASSNR

X

X

X

X

Alarm/Ereignis-Klassenname

@AG

@AGROUPNR

X

X

X

X

Alarm/Ereignis-Gruppennummer

@AGNAME

@AGROUPNAME

X

X

X

X

Name der Alarm/Ereignis-Gruppe

@AKNAME

ACLASSNAME

X

X

X

X

Name der Alarm/Ereignis-Klasse

@TAGNR

@IDENTIFICATION

X

X

X

X

Kennung (firmenspezifische Bezeichnung)

@AMELDUNG

@TEXT

X

X

X

X

Alarmmeldetext

@REAKTANZ

@NRREACTIVATE

X

-

X

-

Anzahl der Reaktivierungen

@STATUS

@STATUS

X

X

X

X

Statusinformation wie in der Alarmliste

@WERT

@VALUE

X

X

X

X

Variablenwert des Alarms

@REAKTIONSTEXT

@COMMENT

X

X

X

X

Kommentar aus der Alarmliste.

Bei Verwendung von dynamischen Grenzwerttexten nur veerfügbar, wenn Long dynamic limit texts AML bzw. Long dynamic limit texts CEL aktiviert ist.

Interne ID: Drucken AML oder CEL

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Drucken AML oder CEL

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

@USER

@USERID

X

X

X

X

AML: Anwender, der Alarm bestätigt hat.

@RECHNER

@COMPUTER

X

X

X

X

AML: Rechner, auf dem Alarm bestätigt wurde.

Schlüsselwörter für den Kopf- und Fußteil

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@SEITE

@PAGE

X

X

X

X

Seitenzahl

@HEADDATZEIT

@DTSYSTEM

X

X

X

X

Systemdatum und Systemuhrzeit

@HEADDATUM

@DSYSTEM

X

X

X

X

Systemdatum

@HEADZEIT

@TSYSTEM

X

X

X

X

Systemuhrzeit

@USER

@USERID

X

X

X

X

Benutzer, der druckt

@USERNAME

@USERNAME

X

X

X

X

Vollständiger Benutzername, der Aktivität auslöste

@RECHNER

@COMPUTER

X

X

X

X

Rechner, von deam aus gedruckt wird

[Text]

[Text]

beliebiger Text in der Ausgabezeile am Drucker

attention Achtung

Zwischen den Schlüsselwörtern muss ausreichend Platz vorgesehen werden, damit Einträge nicht überschrieben werden. Damit stellen Sie sicher, dass auch lange Grenzwert-Texte korrekt angezeigt werden.

Beispiel:

@TEXT (Leerzeichen bis hierher)

Einstellung Millisekunden

attention Achtung

Millisekunden für Druck und Export

Soll beim Drucken oder Exportieren von AML oder CEL die Zeit in Millisekunden angegeben werden, muss diese Eigenschaft im Dialog für die Spalteneinstellungen aktiviert werden. Dazu:

  • navigieren Sie in den Projekteigenschaften zum Knoten Alarmmeldeliste bzw. Chronologische Ereignisliste

    Interne ID: Drucken AML oder CEL

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Drucken AML oder CEL

    Alarmmeldeliste

    Eigenschaften für die Alarmkonfiguration.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • klicken Sie auf die Schaltfläche ... der Eigenschaft Spalteneinstellung AML bzw. Spalteneinstellung CEL

    Interne ID: Drucken AML oder CEL

    Spalteneinstellung CEL

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
    Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

    Interne ID: Drucken AML oder CEL

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Drucken AML oder CEL

    Spalteneinstellung AML

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
    Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Dialog für die Spalteneinstellung wird geöffnet
  • aktivieren Sie die Checkbox vor der Eigenschaft Millisekunden

Die Einstellung muss für AML und CEL jeweils extra vorgenommen werden.


Online-Drucken ein/ausschalten

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Online-Drucken ein/ausschalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird der Onlinedruck auf einen Status gesetzt:

  • einschalten: schaltet den Online-Druck ein
  • ausschalten: schaltet den Online-Druck aus
  • aktiv/inaktiv: schaltet den Online-Druck um

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Online-Drucken ein/ausschalten
  3. der Dialog zur Auswahl der Liste öffnet sich

  4. wählen Sie die gewünschte Funktion
  5. verknüpfen Sie die Funktion mit einem Button


Online-Drucken neue Seite beginnen

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Online-Drucken neue Seite beginnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion steuern Sie zur Runtime den Seitenvorschub beim Online-Drucken:

Die aktuelle Seite des Ausdruckes wird mit der projektierten Fußzeile versehen und ein Seitenvorschub auf den neuen Seitenanfang vorgenommen. Der Seitenzähler wird auf 1 zurückgesetzt und die Kopfzeile ausgedruckt.

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Online-Drucken neue Seite beginnen
  3. verknüpfen Sie die Funktion mit einem Button


Online Drucker umschalten

Handbuch -> Alarmverwaltung -> Alarme projektieren -> Funktionen -> Funktionen für Alarmverwaltung -> Online Drucker umschalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion kann zur Laufzeit der Drucker für den Online-Ausdruck gewechselt werden.

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Online-Drucker umschalten
  3. der Dialog zur Auswahl des Druckers öffnet sich
  4. wählen Sie den gewünschten Drucker aus der Dropdownliste
  5. verknüpfen Sie die Funktion mit einem Button

Parameter | Beschreibung
Druckerwahl | Auswahl des gewünschten Druckers aus der Dropdownliste.
Diesen Dialog zur Runtime anbieten | Aktiv: Bei Ausführung der Funktion wird der Dialog aufgeschaltet und der Drucker kann zur Runtime definiert werden.


Bedienen zur Runtime

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime

Zur Runtime wird die Alarmmeldeliste über eine Bildumschaltungsfunktion aufgerufen.

Die zur Verfügung stehenden Kontrollelemente und das Aussehen werden im Editor projektiert.

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Alarmmeldeliste

Anzeige der Alarme. Das Aussehen ist konfigurierbar. Spalten werden über den Filter Spalteneinstellungen bei der Bildumschaltung festgelegt oder über die Eigenschaft Spalteneinstellung AML in den Projekteigenschaften in der Gruppe Alarmmeldeliste.

Interne ID: Bedienen zur Runtime

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bedienen zur Runtime

Spalteneinstellung AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

Interne ID: Bedienen zur Runtime

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Anzeige: Eingestellter Filter

Anzeige der aktuell gewählten Filterbedingungen.

Filter...

Öffnet Dialogs zur Filterauswahl.

Quittieren/Löschen

Gruppe der Buttons für quittieren und löschen von Alarmen
  • Quittieren

Alarmmeldungen zur Runtime quittieren.
  • Seite quittieren

Alle auf der aktuellen Seite angezeigten Alarme werden quittiert.
  • Alle quittieren

Alle dem aktuellen Filterkriterium entsprechenden Alarme werden quittiert.

Hinweis Mehrbenutzer-Projekt: Es werden nur die Alarme jenes Projektes quittiert, für die der Benutzer die Berechtigung dazu besitzt. (Details Mehrbenutzer-Projekt siehe Kapitel Verteiltes Engineering)

  • Löschen

Löscht Alarm zur Runtime aus der Alarmmeldeliste. Alarm muss bereits quittiert sein.
  • Seite löschen

Löscht alle quittierten Alarme, die auf der aktuellen Seite angezeigt werden.
  • Alle löschen

Löscht alle quittierten Alarme, die dem aktuellen Filterkriterium entsprechen.

Stopp/Weiter

Schalter für Befüllung der Liste:

Stopp: Neue Elemente werden nicht mehr automatisch hinzugefügt.

Weiter: Neue Elemente werden automatisch hinzugefügt.

Achtung: Beschriftung des Buttons kann im Editor zwar geändert werden, wird zur Runtime aber nicht übernommen. Änderungen der Beschriftung projektieren Sie über die Sprachumschaltung.

Schließen

Schließt Alarmmeldeliste

Drucken

Druckt gefilterte Liste.

Drucken mit Dialog...

Öffnet vor dem Drucken die Druckereinstellungen.

Anzeige: Verknüpfte Funktion

Zeigt die der Alarmmeldung zugeordnete Funktion an.

Funktion ausführen

Führt zur Runtime die am Alarm projektierte Funktion aus.

Hinweis: Bei der Funktion Starte Programm kann der Variablenname des selektierten Alarms als Parameter für das zu startende Programm über das Schlüsselwort @alarm.name übergeben werden.

Hilfe aufrufen

Ruft projektierte Hilfe auf.

Anzeigen

Status und Elemente der Alarmverwaltung.
  • Anzahl gesamt

Zeit Anzahl aller Alarme.
  • Anzahl unquittiert

Zeigt Zahl unquittierter Alarme.
  • Info: Status Alarmmeldeliste

Anzeige, ob Alarmmeldeliste aktiv ist oder nicht (Projekt-Eigenschaft Alarmmeldeliste aktiv).
  • Kommentarfeld

Eingabe eines freien Textes (Kommentar) durch den Benutzer für den selektierten Alarm. Dieser Text kann in der Liste mit angezeigt werden (Option Kommentar in den Spalteneinstellungen der Alarmverwaltung.)

Navigation

Steuert Elemente der Liste.
  • Zeile nach oben

Blättert eine Zeile nach oben.
  • Zeile nach unten

Blättert eine Zeile nach unten.
  • Spalte nach rechts

Blättert eine Spalte nach rechts.
  • Spalte nach links

Blättert eine Spalte nach links.
  • Seite nach oben

Blättert eine Seite nach oben.
  • Seite nach unten

Blättert eine Seite nach unten.
  • Seite nach rechts

Blättert eine Seite nach rechts.
  • Seite nach links

Blättert eine Seite nach links.

Filterprofile

Filtereinstellungen, die der Anwender in der Runtime speichern kann.

  • Profilauswahl

Profil aus Liste auswählen.
  • Speichern

Speichert aktuelle Einstellung als Profil.
  • Löschen

Löscht ausgewähltes Profil.

Konfiguration der Anzeige

Welche Informationen in der Alarmstatuszeile und Alarmmeldeliste angezeigt werden, konfigurieren Sie über die Spalteneinstellung der Alarmprojektierung . Die Spalteneinstellungen erreichen Sie über:

  • Projekteigenschaften -> Alarmmeldeliste -> Spalteneinstellung AML (nur Registerkarte Spalteneinstellungen )

    oder

  • Funktion Bildumschaltung auf ein Bild vom Typ AML ( alle Registerkarten)

Funktionen für Grenzwerte als Alarm

Beim Runtime Start wird überprüft, ob der Alarm für den Grenzwert bereits vor dem Beenden der Runtime angestanden ist . Ist dies der Fall, dann wird die verknüpfte Funktion nicht erneut ausgeführt.
Hinweis: Handelt es sich bei dem Grenzwert nicht um einen Alarm, kann das Ausführen der Grenzwertfunktion beim Runtime Start durch dieProjekteinstellung Grenzwertfunkt. beim RT-Start ausführen in der Gruppe Funktionen beeinflusst werden. Diese Einstellung beeinflusst nur Grenzwerte, die kein Alarm sind.

Interne ID: Bedienen zur Runtime

Funktionen

Eigenschaften für die Funktionsverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bedienen zur Runtime

Grenzwertfunkt. beim RT-Start ausführen

Aktiv: Beim Start der Runtime wird eine mit einem anstehenden Grenzwert verknüpfte Funktion erneut ausgeführt.
Inaktiv: Beim Start der Runtime wird eine mit einem anstehenden Grenzwert verknüpfte Funktion nicht erneut ausgeführt.
Default: aktiv.

ACHTUNG: Diese Eigenschaft betrifft nur Grenzwerte, die keine Alarme sind!

Beispiel 1: Die Runtime wird geschlossen und kein Grenzwert ist verletzt. Dann wird ein Grenzwert verletzt und danach die Runtime gestartet. Ist der verletzte Grenzwert ein Alarm, so wird die verknüpfte Funktion beim Starten der Runtime ausgeführt. Ist der Grenzwert kein Alarm, wird die Einstellung dieser Eigenschaft benutzt.
Beispiel 2: Die Runtime wird geschlossen und ein Grenzwert, der kein Alarm ist, ist verletzt. Die verknüpfte Funktion wurde in dem Moment ausgeführt, als der Grenzwert verletzt wurde. Wenn die Runtime neu gestartet wird, ist dieser Grenzwert immer noch verletzt. Abhängig von dieser Eigenschaft wird die verknüpfte Funktion erneut ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Alarmstatuszeile

Alarmmeldeliste

Alarme quittieren

Alarme blinkquittieren

Alarme löschen

Alarme filtern

Alarme drucken und exportieren


Alarmstatuszeile

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarmstatuszeile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Alarmstatuszeile werden zur Laufzeit nicht quittierte Alarme als rote Zeile mit schwarzer Schrift angezeigt. Sie enthält Informationen über die auslösende Variable und die Zeit. Die Alarmstatuszeile ist als oberstes Windows Fenster definiert und überdeckt damit alle zenon Bilder und auch alle anderen Applikationen.

Alarme werden mit einem Doppelklick der rechten Maustaste quittiert.

Alarmstatuszeile konfigurieren

Um die Alarmstatuszeile zur Runtime anzuzeigen, aktivieren Sie in den Projekteigenschaften in der Gruppe Alarmmeldeliste die Eigenschaft Statuszeile aktiv.

Interne ID: Alarmstatuszeile

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Interne ID: Alarmstatuszeile

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarmstatuszeile

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Das Verhalten der Alarmstatuszeile zur Runtime und die zu verwendende Schriftart definieren Sie in den Projekteigenschaften der Alarmstatuszeile in der Gruppe Alarmmeldeliste:

Interne ID: Alarmstatuszeile

Alarmstatuszeile

Eigenschaften für die Statuszeile der Alarmverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • nächsten nachschieben: Definiert die Alarmstatuszeile als Ring. Als Ringgröße wird der Wert der Eigenschaft Größe des Ringpuffers verwendet. Ist diese Eigenschaft deaktiviert, beinhaltet die Alarmstatuszeile immer nur einen einzigen Alarm.

    Interne ID: Alarmstatuszeile

    Größe des Ringpuffers

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Maximale Anzahl der Einträge für den Ringpuffer.

    Minimum: 1
    Maximum: 32767
    Default: 100

    Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

    Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Alarmstatuszeile

    nächsten nachschieben

    Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
    Aktiv: Alle unquittierten Alarme werden zur Runtime in der Statuszeile hintereinander angezeigt. Sobald ein Alarm durch einen Doppelklick mit der rechten Maustaste quittiert wurde, wird der nächste Alarm angezeigt. Abhängig von der Einstellung in der Eigenschaft Anzeige wird der älteste oder der neueste Alarm zuerst angezeigt.
    Inaktiv: In der Statuszeile wird immer nur ein Alarm angezeigt. Die Statuszeile ist leer, nachdem der Alarm quittiert wurde.
    Default: aktiv

    Interne ID: Alarmstatuszeile

    Anzeige

    Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
    ältester Alarm: Abhängig von der Einstellung der Eigenschaft nächsten nachschieben wird nur der älteste unquittierte Alarm in der Statuszeile in der Runtime angezeigt (inaktiv) oder der älteste Alarm wird zuerst angezeigt (aktiv).
    jüngster Alarm: Abhängig von der Einstellung der Eigenschaft nächsten nachschieben wird nur der jüngste unquittierte Alarm in der Statuszeile in der Runtime angezeigt (inaktiv) oder der jüngste Alarm wird zuerst angezeigt (aktiv).
    Default: ältester Alarm

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Anzeige: Legt fest, ob der älteste oder der jüngste Alarm angezeigt wird. Die Auswahl erfolgt aus der Dropdownliste.
    • ältesten Alarm: FIFO-Puffer
    • jüngsten Alarm: LIFO-Puffer

attention Achtung

Verhalten bei Mehrprojektverwaltung:

Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte.

  • Wird die Alarmstatuszeile in einem Unterprojekt deaktiviert, aber nicht im Integrationsprojekt als Startprojekt, dann wird die Alarmstatuszeile dennoch weiter angezeigt.
  • Wird die Alarmstatuszeile im übergeordneten Startprojekt aktiviert, dann wird sie auch im Unterprojekt angezeigt, selbst wenn sie hier deaktiviert wurde.
  • Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Positionierung

Standardmäßig befindet sich die Alarmstatuszeile am oberen Monitorrand (Höhe=18 Pixel bei Standardschriftart). Sie könen die Größe und Position auch frei bei den Schablonen einstellen. Selektieren Sie dazu die Alarmstatuszeile und deaktivieren Sie die Option Standardposition verwenden. Danach können Sie die Alarmstatuszeile frei am Bildschirm wie, jede andere Schablone positionieren.
Bei der Mehrprojektverwaltung in der Runtime ist die Position der Alarmstatuszeile im Integrationsprojekt ausschlaggebend. Die Einstellungen der Unterprojekte werden ignoriert.

Statusmeldungen in blauer Statuszeile

Um den Benutzer darauf aufmerksam zu machen, dass die Anzahl der Alarme eine gewisse Anzahl überschritten hat, bzw. um darauf hinzuweisen, dass der Ringpuffer der Alarmmeldeliste bald überläuft, können Sie drei Statusmeldungen definieren.
Die Statusmeldungen überdecken die rote Alarmstatuszeile solange sie nicht quittiert werden. Die Quittierung erfolgt über einen Doppelklick mit der rechten Maustaste. Der Benutzer muss über die entsprechende Berechtigungsgruppe verfügen. Diese kann in der Benutzerverwaltung über die Funktionsberechtigungen eingestellt werden.

Für das Aufschalten der blauen Statusleiste gilt:

  • Die blaue Zeile hat höhere Priorität für die Anzeige als die rote Alarmstatuszeile.
  • Die blaue Zeile reagiert ausschließlich auf die Gesamtzahl der Einträge in der Liste
  • Über die Eigenschaften der Gruppe Alarmstatuszeile können drei Maxima für die Gesamtzahl der Einträge in der Liste definiert werden. Jedem Maximum kann eine Meldung zugewiesen werden, die beim Übersteigen von unten angezeigt wird.
  • Zu jeder Zeit ist das höchste mögliche Maximum aktiv.
  • Die blaue Zeile kann per rechten Doppelklick deaktiviert werden. Dabei werden die Nachbarmaxima erst dann ausgelöst, wenn sie explizit erreicht werden.
  • Ein deaktiviertes Maximum wird erst bei dessen erneuten Übersteigen von unten wieder reaktiviert.


Alarmmeldeliste

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarmmeldeliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Alarmmeldeliste stellt zur Laufzeit die Alarmmeldungen zeilenweise dar.

Um die AML zu erstellen und anzuzeigen, aktivieren Sie in den Projekteigenschaften in der Gruppe Alarmmeldeliste die Eigenschaft Alarmmeldeliste aktiv.

Interne ID: Alarmmeldeliste

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarmmeldeliste

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Darstellungsform der Liste wird im Filter der Bildumschaltungsfunktion auf ein Alarmmeldebild in der Registerkarte Spalteneinstellungen eingestellt.

Alarme werden, sobald sie auftreten, in einem Ringpuffer (alarm.bin) und einer Alarmdatei (*.aml) im Runtimeordner gespeichert.

Ringpuffer

Der Ringpuffer enthält alle anstehenden Alarme. Dabei werden verwaltet:

  • Zeit kommt in Millisekunden als eindeutige Signatur
  • weitere Informationen wie Ursache, Werte etc.
  • Zeit geht
  • Zeit quittiert

Beim Quittieren von Alarmen werden im Ringpuffer immer alle Alarme einer Variablen mit der gleichen Grenzwertverletzung gleichzeitig gelöscht.

Sobald der Alarm quittiert wird, wird er aus dem Ringpuffer gelöscht. Ausnahme: Die Eigenschaft löschpflichtig ist gesetzt, dann muss er vom Benutzer dezidiert gelöscht werden.

Größe des Ringpuffers

Die Größe des Ringpuffers muss in den Projekteigenschaften mit der Eigenschaft Größe des Ringpuffers ausreichend dimensioniert werden.
Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Interne ID: Alarmmeldeliste

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Ringpuffer wird beim Beenden der Runtime automatisch als alarm.bin gespeichert. Wird die Runtime durch unerwartete Ereignisse beendet, wie Spannungsausfall, kommt es zu Datenverlust. Um das zu verhindern, kann der Ringpuffer über die Eigenschaft Ringpuffer bei Wertänderung speichern bei jedem neuen Eintrag oder über die Funktion AML- und CEL-Ringpuffer speichern manuell gespeichert werden.

Interne ID: Alarmmeldeliste

Ringpuffer bei Wertänderung speichern

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Jede Änderung der Daten der Alarmmeldeliste bewirkt auch das Speichern der Daten (alarm.bin).
Hinweis: Damit wird bei jeder Speicherung der gesamte Ringpuffer gespeichert. Das kann - vor allem bei Flash Disks - zu erheblicher Systembelastung führen.
Inaktiv: Daten der Alarmmeldeliste (alarm.bin) werden nur beim Beenden der Runtime oder beim Ausführen der Funktion AML- und CEL-Ringbuffer speichern gespeichert. Empfiehlt sich vor allem bei niedriger Performance. Historische Daten (*.aml) können unabhängig von dieser Einstellung bei jeder Wertänderung gespeichert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Achtung: Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Über die definierten Anzahl können auch Alarme angezeigt werden, die noch keinen Geht-Zeitstempel besitzen. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen.

Example Beispiel
  • Größe des Ringpuffers: 100 Einträge
  • Anstehende Alarme zur Runtime ohne Geht-Zeitstempel: 120
  • Anzeige zur Runtime in der AML: 120

Alarmdatei

Alle Alarme werden zeitgleich mit dem Ringpuffer in eine eigene Alarmdatei (*.aml)geschrieben. Diese wird für jeden Kalendertag automatisch erstellt und über die Eigenschaft AML-Daten speichern verwaltet. Der Name der Alarmdatei setzt sich zusammen aus dem Buchstaben A, gefolgt vom Datum in der Form JJMMTT und der Endung .aml, z.B. A100623.aml. Diese Dateien werden für jeden Tag automatisch erstellt und müssen bei begrenztem Speicherplatz vom Anwender ausgelagert oder gelöscht werden. *.aml Dateien werden im Ordner ...\Projektordner\Computername\Projektname gespeichert.

Interne ID: Alarmmeldeliste

AML-Daten speichern

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Nur Ringpuffer: Nur anstehende Alarme (alarm.bin) werden auf der Festplatte gespeichert.
Ringpuffer und historische Daten: Auch historische Alarme (*.aml) werden gespeichert.
Default: Auf CE-Geräten wird nur der Ringpuffer (alarm.bin) auf die Festplatte gespeichert; auf PCs werden auch die historischen Einträge (*.aml) gespeichert.
Default: Default.
Die Dateien (alarm.bin und *.aml) werden im Ordner \Projektordner\Computername\Projektname gespeichert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Synchronisierung von Ringpuffer und Alarmdatei

Ringpuffer und Alarmdatei werden synchronisiert. Diese Synchronisierung erfolgt immer vom Ringpuffer zur Alarmdatei. Alle Änderungen, wie Quittierung, werden nur im Ringpuffer vorgenommen und dann mit der Alarmdatei synchronisiert. So können in der Alarmdatei zwar z. B. alle unquittierten Alarme angezeigt und deren Quittierung veranlasst werden, die Aktion selbst findet aber im Ringpuffer statt.

Speicherzeiträume

Die Alarmdatei *.aml wird bei jedem neuen Eintrag gespeichert.

Der Ringpuffer (*.bin) wird gespeichert:

  • beim Beenden der Runtime
  • bei aktiver Eigenschaft Ringpuffer bei Wertänderung speichern nach jedem neuen Eintrag
  • beim Ausführen der Funktion AML- und CEL-Ringpuffer speichern

    Interne ID: Alarmmeldeliste

    AML- und CEL-Ringpuffer speichern

    Diese Funktion speichert aktuelle Alarme und Ereignisse in die Dateien ALARM.BIN und CEL.BIN.

    Mehr im Online-Handbuch

Hinweis: Ist die Option Ringpuffer bei Wertänderung speichern deaktiviert, werden nach einem Stromausfall die Einträge in der AML und im Ringpuffer eventuell nicht mehr übereinstimmen.

attention Achtung

Läuft der Ringpuffer aufgrund zu geringer Dimensionierung über, bleiben unquittierte Einträge in der Alarmdatei erhalten. Diese werden beim Filtern angezeigt, können aber nicht mehr quittiert werden. Der Versuch diese zu quittieren kann aber das Quittieren von Alarmen in Ringpuffer auslösen, wenn diese die gleiche Variable und die gleiche Grenzwertverletzung betreffen.

AML zur Runtime

Alarme in der Alarmmeldeliste können drei Status besitzen:

  1. Nicht gegangen
  2. Nicht quittiert
  3. Nicht gelöscht

Alarme können quittierpflichtig und/oder löschpflichtig sein.

Quittieren setzt das Blinkattribut der Variablen zurück. Das Löschen eines Eintrages kann nur bei vorher erfolgter Quittierung eines gegangenen Alarmereignisses durchgeführt werden. Die Projektierung der Quittierungs- und/oder Löschpflicht erfolgt über die Eigenschaften Quittierpflichtig und Löschpflichtig im Knoten Grenzwerte/AML/CEL der Variablenprojektierung

Interne ID: Alarmmeldeliste

AML/CEL

Eigenschaften für die Alarm- und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarmmeldeliste

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: Alarmmeldeliste

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarmmeldeliste

Löschpflichtig

Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Kein Löschen erforderlich.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarmmeldeliste

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beispiel für den Zeilenaufbau der Alarmmeldeliste in der Runtime:

Variable | Datum/Zeit kommt | Datum/Zeit geht | Datum/Zeit quittiert | Meldetext
Motor1_Störung | 20.06.2010 13:00:04 | 20.06.2010 13:05:35 | 20.06.2010 13:05:40 | Motorschutzrelais hat angesprochen

Jede Zeile kann durch einen Doppelklick mit der rechten Maustaste quittiert werden. Der Benutzer muss über die entsprechende Berechtigungsgruppe verfügen.

Bei aufgeschalteter Alarmmeldeliste wird in der linken oberen Ecke der Status der Alarmverwaltung (aktiv oder inaktiv) angezeigt.

info Info

Die Variablen für nicht quittierte Alarme, quittierte Alarme und Anzahl der Alarme befinden sich in einer lokalen Liste im Speicher.

Siehe Variable 'nicht quittierte Alarme' im Kapitel Projektierung der Alarm- und CEL-Filter.


Alarme quittieren

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit die Information "quittiert" in der AML angezeigt wird, muss:

  1. bei der Variablen die Eigenschaft Quittierpflichtig aktiviert sein

    Interne ID: Alarme quittieren

    Quittierpflichtig

    Nur verfügbar für Alarme.
    Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
    Inaktiv: Keine Quittierung erforderlich.
    Default bei Alarmen: aktiv, sonst inaktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. der Alarm quittiert worden sein

Alarme können quittiert werden über:

  • doppelten Rechtsklick auf Alarmstatuszeile
  • doppelten Rechtsklick auf Eintrag in Alarmmeldeliste
  • Funktion Alarm quittieren
  • Button in Alarmmeldeliste

Beim Quittieren eines Alarms:

  • werden immer alle Alarme einer Variablen mit dem gleichen Grenzwert gemeinsam quittiert
  • werden Name und ID des löschenden Benutzers in der Alarmmeldeliste eingetragen
  • wird der Name des Rechners, von dem aus der Alarm quittiert wurde, in die Alarmmeldeliste eingetragen
  • kann das Quittieren zusätzlich in die Chronologische Ereignisliste eingetragen werden

Alarme werden bis zur Quittierung im Ringpuffer gespeichert. Gleichzeitig werden sie in einer filterbaren Alarmdatei (*.aml) abgelegt und synchron gehalten.

Achtung: Die Eigenschaft Größe des Ringpuffers muss ausreichend dimensioniert werden. Werden Alarme bedingt durch einen Überlauf nicht mehr im Ringpuffer gespeichert, können unquittierte Alarme in der Alarmdatei verbleiben. Details siehe Kapitel Alarmmeldeliste (AML).

Interne ID: Alarme quittieren

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: Alarme quittieren

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wenn Alarme kommentarpflichtig sind, können diese erst quittiert werden, wenn ein Kommentar eingetragen wurde. Der Benutzer muss über die dazu nötige Funktionsberechtigung verfügen.

Funktion Alarm quittieren

Die Funktion Alarm quittieren ermöglicht:

  • das Quittieren von Alarmen aus der AML über einen Funktionsaufruf
  • globales Quittieren

Bei der Nutzung der Funktion zur Runtime wird auch das Blinkattribut der Variablen und damit die Bildalarmierung (nur SICAM 230) zurückgesetzt. Die ausgewählten Alarme werden quittiert. Details siehe Kapitel Alarme quittieren.

Benutzerrechte

Die Funktionen Alarme quittieren und Alarme löschen können über Funktionsberechtigungen einer Benutzergruppe zugeordnet werden. Nur berechtigte Nutzer können dann Alarme quittieren oder löschen.

Zusätzlich kann bei den Grenzwerten der Variablen über die Eigenschaft Löschpflichtig in der jeweiligen Subgruppe der Gruppe Grenzwerte ein zusätzliches Bedienrecht gesetzt werden. Ausgewählte Alarme können damit nur von speziell berechtigten Personen aus der Alarmmeldeliste entfernt werden.

Interne ID: Alarme quittieren

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: Alarme quittieren

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Alarme quittieren

Löschpflichtig

Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Kein Löschen erforderlich.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wurde die Eigenschaft Löschpflichtig gesetzt, werden Alarme erst dann aus der Liste der aktiven Alarme entfernt, wenn sie gelöscht wurden. Quittieren alleine reicht dann nicht aus.

info Info

Alarme können nur dann gelöscht werden, wenn sie quittiert wurden.

Noch in diesem Kapitel

Kommentarpflicht für Quittierung


Kommentarpflicht für Quittierung

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme quittieren -> Kommentarpflicht für Quittierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für quittierpflichtige Alarme kann die Eingabe eines Kommentars zum Alarm erzwungen werden, bevor der Alarm quittiert werden kann. Um einen Kommentar eingeben zu können, benötigt der Benutzer die entsprechende Funktionsberechtigung Alarm Kommentar eingeben.

Um einen Alarm kommentarpflichtig zu machen, kann die entsprechende Option gesetzt werden bei:

  • der Konfiguration von Reaktionsmatrizen
  • der Eigenschaft Kommentar erforderlich in der Gruppe Grenzwerte der Variablen

    Interne ID: Kommentarpflicht für Quittierung

    Grenzwerte

    Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

    Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

    Interne ID: Kommentarpflicht für Quittierung

    Reaktionsmatrix aktiv

    Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
    Inaktiv: Grenzwerte können für die Variable definiert werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Kommentarpflicht für Quittierung

    Kommentar erforderlich

    Nur verfügbar, wenn Eigenschaft Quittierpflichtig aktiv ist.

    Interne ID: Kommentarpflicht für Quittierung

    Quittierpflichtig

    Nur verfügbar für Alarme.
    Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
    Inaktiv: Keine Quittierung erforderlich.
    Default bei Alarmen: aktiv, sonst inaktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Aktiv: Bevor ein Alarm quittiert werden kann, muss ein Kommentar eingegeben werden. Der Benutzer muss dazu über die Funktionsberechtigung Alarm Kommentar eingeben verfügen.

    Default: inaktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Kommentare von kommentarpflichtigen Alarmen können nachträglich nur von Benutzern mit der Funktionsberechtigung Alarm Kommentar ändern geändert werden. Werden Kommentare geändert, erfolgt ein Eintrag in der CEL mit Angabe des Variablennamens sowie des ursprünglichen und des geänderten Kommentars.

Kommentarpflichtige Alarme werden bei allen Quittiermöglichkeiten (inklusive VBA) auf Kommentare überprüft. Ebenso wird bei Änderungen von Kommentaren die nötige Berechtigung überprüft. Die Alarmmeldeliste kann auf kommentarpflichtige Alarme gefiltert werden über:

  • Filter der Alarmmeldelisteliste
  • Bild vom Typ Alarmmeldeliste Filter


Alarme blinkquittieren

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme blinkquittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Neben dem Quittieren von Alarmen aus der Alarmmeldeliste können Bilder bei Alarmen auch schablonenweise quittiert werden. Blinkquittieren wird über die Funktion Alarme blinkquittieren aufgerufen oder durch einen Doppelklick mit der rechten Maustaste auf das entsprechende Element. Dabei werden nur das Blinkattribut der Variablen und das Blinken aller grafischen Elemente im Bild zurückgesetzt. Es erfolgt aber keine Quittierung der Einträge in der AML.

Blinkquittierung mit Quittierung in AML

Eine Blinkquittierung quittiert auch die Alarme in der AML, wenn in der Alarmverwaltung die Option Blink-Quittierung gesetzt ist.

Interne ID: Alarme blinkquittieren

Blink-Quittierung

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Mit dem Quittieren des Blinkens eines Elements wird auch der entsprechende Alarm in der Alarmmeldeliste quittiert
Inaktiv: Das Quittieren des Blinkens eines Elements beendet nur das Blinken. Der entsprechende Alarm wird nicht quittiert.
Default: inaktiv.
Das Blinken von Elementen kann durch einen Doppelklick mit der rechten Maustaste auf das entsprechende Element oder durch die Funktion "Blinkquittieren" quittiert werden.

Interne ID: Alarme blinkquittieren

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur für SICAM 230: Die Quittierung in der Alarmmeldeliste bzw. auf Ebene der Alarmzeile am oberen Bildrand quittiert den Alarm auch im Bild und in der Bildalarmführung.

Blinkquittieren in Integrationsprojekten

Wenn Alarme in Integrationsprojekten über die Funktion Blinkquittieren quittiert werden sollen, müssen alle betroffenen Bilder geöffnet sein.

Haben Bilder im übergeordneten und im untergeordneten Projekt Schablonen mit gleichem Namen, werden die Bilder im untergeordneten Projekt nicht geöffnet. Unterscheiden sich die Vorlagen-Namen, bleiben die Bilder des Unterprojekts im Hintergrund geöffnet und können blinkquittiert werden.

info Info

Wenn Blinkquittieren im Netzwerk eingesetzt wird, wird es nur lokal am jeweiligen Client ausgeführt.


Alarme löschen

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Alarm zu löschen, muss:

  • eine Funktion Alarme löschen ausgeführt werden
    oder
  • der Button Löschen im Bild des Typs Alarmmeldeliste betätigt werden

Alarme können nur dann gelöscht werden, wenn sie quittiert wurden.

Wurde bei den Grenzwerten die Eigenschaft Löschpflichtig gesetzt, werden Alarme erst dann aus der Liste der aktiven Alarme entfernt, wenn sie gelöscht wurden. Quittieren alleine reicht dann nicht aus.

Interne ID: Alarme löschen

Löschpflichtig

Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Kein Löschen erforderlich.
Default: inaktiv

Interne ID: Alarme löschen

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Benutzerrechte

Die Funktionen Alarme quittieren und Alarme löschen können über Funktionsberechtigungen einer Benutzergruppe zugeordnet werden. Nur berechtigte Nutzer können dann Alarme quittieren oder löschen.

Zusätzlich kann bei den Grenzwerten der Variablen über die Eigenschaft Löschpflichtig in der jeweiligen Subgruppe der Gruppe Grenzwerte ein zusätzliches Bedienrecht gesetzt werden. Ausgewählte Alarme können damit nur von speziell berechtigten Personen aus der Alarmmeldeliste entfernt werden.

Interne ID: Alarme löschen

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: Alarme löschen

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wurde die Eigenschaft Löschpflichtig gesetzt, werden Alarme erst dann aus der Liste der aktiven Alarme entfernt, wenn sie gelöscht wurden. Quittieren alleine reicht dann nicht aus.

info Info

Alarme können nur dann gelöscht werden, wenn sie quittiert wurden.


Alarme filtern

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme filtern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarme können zur Runtime gefiltert angezeigt werden über:

  • Filteranwendung zur Runtime
  • Bildumschaltung mit vordefiniertem Filter auf ein Bild vom Typ Alarmmeldeliste
  • Bildumschaltung mit Filter beim Bildaufruf eines Bild vom Typ Alarmmeldeliste
  • Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste-Filter

Filtern zur Runtime

Im Bild vom Typ Alarmmeldeliste könne zur Runtime Filter angewandt werden. Um die in der AML angezeigten Alarme zu filtern:

  1. muss der Button Filter projektiert worden sein
  2. klicken Sie auf den Button
  3. der Filterdialog der Alarmmeldeliste wird geöffnet

Eingestellte Filter lassen sich in Profilen speichern.

Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste

Alarme können vorgefiltert angezeigt werden. Dazu:

  1. projektieren Sie einen Filter für die Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste
  2. die Alarmmeldeliste wird beim Aufruf gefiltert angezeigt
  3. wird für die Funktion die Option Diesen Dialog zur Runtime anbieten aktiviert, kann der Filter vor der Anzeige neu definiert werden
  4. weitere Filtereinstellungen zur Runtime sind über den Button Filter möglich

Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste-Filter

Um dem Benutzer zur Runtime nur die Filter anzubieten, die er benötigt, verwenden Sie das Bild vom Typ Alarmmeldeliste-Filter. Dazu:

  1. projektieren Sie eine Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste-Filter
  2. rufen Sie zur Runtime die AML über diese Funktion auf
  3. der Benutzer hat eine auf seine Bedürfnisse zugeschnittene Alarmmeldliste

Noch in diesem Kapitel

Filterprofile

Alarmmeldeliste Filter benutzen


Filterprofile

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme filtern -> Filterprofile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Filterprofile sind Filtereinstellungen, die der Anwender in der Runtime speichern und aufrufen kann.

Um Filterprofile verwenden zu können, müssen folgende Kontrollelemente projektiert werden:

Parameter | Beschreibung
Filterprofile | Profilverwaltung
Profilauswahl | Gespeichertes Profil auswählen (Dropdownliste)
Speichern | Einstellungen als Profil speichern (Schaltfläche)
Löschen | Profil löschen (Schaltfläche X)

Damit können Sie zur Runtime:

  • Filter speichern
  • gespeicherte Filter anwenden
  • Filterprofile löschen

Filterprofil speichern

Um ein Filterprofil zu erstellen:

  1. definieren Sie zur Runtime Filterbedingungen
  2. vergeben Sie in der Eigenschaft Filterprofile einen Namen
  3. klicken Sie auf Speichern

Filterprofil anwenden

Um ein Filterprofil anzuwenden:

  1. wählen Sie aus der Dropdownliste Eigenschaft Filterprofile einen Filter
  2. der Filter wird sofort angewandt

Filterprofil löschen

Um ein Filterprofil zu löschen:

  1. wählen Sie aus der Dropdownliste Eigenschaft Filterprofile einen Filter
  2. klicken Sie auf die Schaltfläche X
  3. das Profil wird gelöscht
  4. der gelöschte Filter wird weiter angewandt, bis ein neuer Filter definiert oder gewählt wurde


Alarmmeldeliste Filter benutzen

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme filtern -> Alarmmeldeliste Filter benutzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ Alarmmeldeliste Filter ermöglicht es, zur Runtime individualisierte Filtereinstellungen für die Alarmmeldeliste vorzunehmen. Es können alle Filtereinstellungen, die auch im Filter für die Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste vorhanden sind, projektiert werden.

Damit:

  • werden nur die wirklich benötigten Filterelemente projektiert und dem Benutzer zur Verfügung gestellt
  • bekommt der Benutzer nur diese Filter angezeigt und gewinnt Übersicht
  • kann das Aussehen völlig frei definiert werden und so zum Beispiel auch eine leichte Bedienung über einen Touchscreen realisiert werden

Filterbilder

Filterbilder ermöglichen es, einen voreingestellten Filter von einem Bild auf ein anderes zu übertragen. Der Filter des Quellbildes wird über das Zielbild gelegt. Die Bilder können auch von unterschiedlichen Bildtypen sein.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.

Aufrufdefinition

Folgende Voraussetzungen müssen erfüllt sein, damit die eingestellten Filter zur Anwendung kommen:

  1. Als Zeitbereich beim Zeitfilter wird Filter beim Zeitfiltertyp einstellen gewählt.
  2. Das Bild (Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter oder Zeitfilter) wird mithilfe eines Buttons oder eines Combi-Elements aktiviert. Nur so wird der Bezug zwischen Filterbild und Quellbild gewährleistet.
  3. Das Quellbild und das Filterbild müssen auf unterschiedlichen Schablonen oder Monitoren projektiert sein. Nur wenn das Quellbild offen ist, kann der Filter für das Filterbild aktualisiert werden. Das ist nur möglich, wenn beide Bilder nicht dieselbe Schablone oder den selben Monitor verwenden.
  4. Das aufrufende Bild muss mit dem aufzurufenden Filterbild kompatibel sein (siehe Tabelle).
Quellbild | AML Filter | CEL Filter | Zeitfilter
Archiv-Nachbearbeitung | T | T | T
Erweiterter Trend | T | T | T
Zeitfilter | T | T | X
Alarmmeldeliste Filter | X | C | T
Chronologische Ereignisliste Filter | C | X | T
Alarmmeldeliste | X | C | T
Chronologische Ereignisliste | C | X | T

Legende:

  • C: Gemeinsame Einstellungen werden aktualisiert.
  • T: Zeiteinstellungen werden aktualisiert.
  • X: Alle Einstellungen werden aktualisiert.

info Info

Keine Filterung

Das Filterbild wird nicht gefiltert, sondern mit den projektierten Werten aufgeschaltet, wenn:

  • eine der Bedingungen 1 bis 3 nicht erfüllt wird oder
  • die Einstellung Aufrufendes Bild bei der Funktion Bildumschaltung nicht aktiviert ist oder
  • das Bild nicht über ein Bildelement aufgerufen wird

In diesem Fall werden zur Runtime die Buttons Übernehmen, Schließen und Aktualisieren ausgegraut dargestellt und haben keine Funktion.

Aktualisierung

Beim Aufruf eines Filterbilds (Alarmmeldeliste Filter, Chronologische Ereignisliste Filter, Zeitfilter), werden die in der Funktion Bildumschaltung projektierten Bilder auf zwei Arten aktualisiert:

  • Wird das Filterbild über ein Bildelement aufgerufen, werden die Zielbilder, die sich auf demselben Monitor wie das Quellbild befinden aktualisiert.
  • Wird das Filterbild auf einem anderen Weg aufgerufen oder ist die Einstellung Auf allen Monitoren aktualisieren aktiviert, werden alle projektierten Zielbilder aktualisiert.

Die Aktualisierung erfolgt, sobald Sie den Button Übernehmen anklicken oder das Filterbild mit dem Button Schließen schließen. Der Button Abbrechen verwirft die Änderungen und schließt das Filterbild.

Filtereinstellungen aktualisieren

Mithilfe des Buttons Aktualisieren, übernehmen Sie die aktuellen Filtereinstellungen des Quellbilds. Wenn das Filterbild nicht durch ein Bildelement aufgerufen wurde oder wenn die Einstellung Aufrufendes Bild nicht aktiviert wurde, wird auf allen Monitoren nach einem Bild gesucht, das zur Aktualisierung verwendet werden kann. Das erste Bild, das gefunden wird, wird dann zur Aktualisierung verwendet.


Alarme drucken und exportieren

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme drucken und exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarme der AML können dokumentiert und archiviert werden über:

  • AML online drucken: jeder Alarm wird beim Anzeigen in der Liste auf einem Zeilendrucker ausgegeben
  • AML offline drucken: Die AML wird im aktuellen Zustand als abgeschlossene Liste ausgedruckt
  • Inhalte der AML (gefiltert) exportieren

Der für Ausdrucke zu verwendende Drucker wird über das Menü Datei -> Allgemeine Konfiguration -> Standard definiert.

attention Achtung

Für den Ausdruck wird eine Konfigurationsdatei *.frm verwendet:

  • online: ALARM.frm
  • offline: ALAR_G.frm.

Diese FRM-Datei muss sich im Projektbaum im Abschnitt Dateien im Ordner Texte und Formate befinden.

Vorlagen für FRM_Dateien finden Sie im zenon Installationsordner im Unterordner FRM_QRF. Diese können über Datei hinzufügen in den Abschnitt Texte und Formate eingefügt und dort bearbeitet werden.

Schlüsselwörter für FRM-Dateien finden Sie im Kapitel FRM-Konfigurationsdatei.

Noch in diesem Kapitel

Online drucken

Offline drucken

FRM-Konfigurationsdatei

Alarme exportieren


Online drucken

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme drucken und exportieren -> Online drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Online-Druck wird jeder auftretende Alarm sofort an den Drucker geschickt.

Achtung: Der Online-Druck erfolgt zeilenweise konform zum ESC/P (Epson Standard Code for Printers) und benötigt einen Epson-kompatiblen Drucker.

Um Alarme online auszudrucken:

  1. definieren Sie einen Drucker
  2. navigieren Sie in den Projekteigenschaften zum Knoten AML und CEL

    Interne ID: Online drucken

    AML und CEL

    Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren Sie die Eigenschaft Drucken aktiv

    Interne ID: Online drucken

    Drucken aktiv

    Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
    Inaktiv: Kein Online-Ausdruck findet statt.
    Default: aktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie bei der Eigenschaft Ausdruck für in der Dropdownliste Alarmmeldeliste aus

    Interne ID: Online drucken

    Ausdruck für

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Ermöglicht die Wahl, ob AMl oder CEL online gedruckt werden. Es kann immer nur eine der beiden Listen gedruckt werden.

    Alarmmeldeliste: Die Alarmmeldeliste (AML) wird online gedruckt.
    Chronologische Ereignisliste: Die Chronologische Ereignisliste (CEL) wird online gedruckt.
    Default: Alarmmeldeliste

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. legen Sie mit der Eigenschaft Zeilen pro Seite die Zeilenzahl fest (Default: 72)

    Interne ID: Online drucken

    Zeilen pro Seite

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Anzahl der Zeilen, die beim Online-Ausdruck pro Seite gedruckt werden.
    Minimum: 0

    Maximum: 65535
    Default: 72

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  6. konfigurieren Sie die ALARM.frm
  7. fügen Sie die ALARM.frm zum Knoten Dateien/Texte und Formate hinzu

Druck und Drucker zur Runtime steuern

Seitenwechsel

Seitenvorschub wird durchgeführt, wenn:

  • eine Seite vollständig beschrieben wurde
  • bei aktivem Online-Druck die Runtime beendet wird
  • die Funktion Online-Drucken neue Seite beginnen ausgeführt wird

Druck unterbrechen

Um den Online-Druck zu unterbrechen oder wieder aufzunehmen:

  • führen Sie die Funktion Online Ausdrucke ein/ausschalten aus.

Drucker wechseln und einrichten

Um zur Runtime den Drucker zu wechseln:

  • führen Sie die Funktion Online Drucker umschalten aus

Um zur Runtime den gewählten Drucker einzurichten:

  1. projektieren Sie für das Bild ein Kontrollelement Drucken mit Dialog
  2. klicken Sie zur Runtime auf den Button Drucken mit Dialog
  3. der Konfigurationsdialog wird geöffnet

Parameter

Beschreibung

Drucker

Einstellungen für den Drucker.

Name:

Auswahl des Druckers aus Dropdownliste. Liste enthält alle im Betriebssystem konfigurierten Drucker.

Eigenschaften...

Öffnet Dialog zur Konfiguration des gewählten Druckers.

Status:

Anzeige Druckerstatus. Nur Information.

Typ:

Anzeige Druckertyp. Nur Information

Standort:

Anzeige Standort des Druckers, falls konfiguriert. Nur Information.

Kommentar:

Anzeige Kommentar zum Drucker, falls konfiguriert. Nur Information.

Papier

Konfiguration des Ausdrucks.

Größe

Auswahl Papierformat aus Dropdownliste.

Quelle

Wahl der Papierzufuhr aus Dropdownliste.

Ausrichtung

Wahl der Papierausrichtung. Mögliche Parmeter:

  • Hochformat
  • Querformat

Netzwerk

Öffnet Dialog zur AUswahl eines Druckers im Netzwerk.

OK

Übernimmt Konfiguration und schließt Dialog. Zur Runtime wird damit der Druck gestartet.

Abbrechen

Verwirft Konfiguration und schließt Dialog. Zur Runtime wird damit auch der Ausdruck abgebrochen.

Formatierungsbeispiel

Projektierung in ALARM.FRM:

Datum: @DSYSTEM | Alarmmeldeliste Demoprojekt | Zeit @TSYSTEM Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
%% |  |  |
@DTRECEIVED | @TCLEARED | @IDENTIFICATION | @TEXT
%% |  |  |
 | Seite | @PAGE |

Ausgabe auf dem Drucker:

Datum: 20.03.2011 | Alarmmeldeliste Demoprojekt | Zeit: 12:00 Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
20.03.2011 13:00:00 | 20.03.2011 13:03:59 | Meldung 1 | Limit überschritten
20.03.2011 13:00:00 | 13:05:35 | Demomeldung | Limit 750 erreicht
20.03.2011 13:03:59 |  | Meldung 2 | Grenzwert
20.03.2011 13:11:23 |  | Meldung 3 | aus
20.03.2011 13:03:59 | 13:12:45 | Demomeldung | aus
 | Seite | 1 |


Offline drucken

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme drucken und exportieren -> Offline drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Offline drucken bedeutet, dass die Alarmmeldeliste so, wie sie im Moment zur Runtime angezeigt wird, ausgedruckt wird. Dieser Ausdruck ist eine Momentaufnahme inklusive aller gesetzter Filter und deren Einschränkungen. Der Druck erfolgt unabhängig davon, ob die Variablen die Option Drucken besitzen.

Drucken

Um die Alarmmeldeliste offline zu drucken:

  1. definieren Sie einen Drucker
  2. konfigurieren Sie die ALAR_G.frm
  3. fügen Sie die ALAR_G.frm zum Knoten Dateien/Texte und Formate hinzu
  4. klicken Sie zur Runtime auf den Button Drucken oder Drucken mit Dialog.

Drucker einrichten und wechseln

Drucker wechseln und einrichten

Um zur Runtime den Drucker zu wechseln:

  • führen Sie die Funktion Online Drucker umschalten aus

Um zur Runtime den gewählten Drucker einzurichten:

  1. projektieren Sie für das Bild ein Kontrollelement Drucken mit Dialog
  2. klicken Sie zur Runtime auf den Button Drucken mit Dialog
  3. der Konfigurationsdialog wird geöffnet

Parameter

Beschreibung

Drucker

Einstellungen für den Drucker.

Name:

Auswahl des Druckers aus Dropdownliste. Liste enthält alle im Betriebssystem konfigurierten Drucker.

Eigenschaften...

Öffnet Dialog zur Konfiguration des gewählten Druckers.

Status:

Anzeige Druckerstatus. Nur Information.

Typ:

Anzeige Druckertyp. Nur Information

Standort:

Anzeige Standort des Druckers, falls konfiguriert. Nur Information.

Kommentar:

Anzeige Kommentar zum Drucker, falls konfiguriert. Nur Information.

Papier

Konfiguration des Ausdrucks.

Größe

Auswahl Papierformat aus Dropdownliste.

Quelle

Wahl der Papierzufuhr aus Dropdownliste.

Ausrichtung

Wahl der Papierausrichtung. Mögliche Parmeter:

  • Hochformat
  • Querformat

Netzwerk

Öffnet Dialog zur AUswahl eines Druckers im Netzwerk.

OK

Übernimmt Konfiguration und schließt Dialog. Zur Runtime wird damit der Druck gestartet.

Abbrechen

Verwirft Konfiguration und schließt Dialog. Zur Runtime wird damit auch der Ausdruck abgebrochen.

Formatierungsbeispiel

Projektierung in ALAR_G.frm:

Datum: @DSYSTEM | Geschlossene AML Demoprojekt | Zeit @TSYSTEM Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
%% |  |  |
@DTRECEIVED | @TCLEARED | @IDENTIFICATION | @TEXT
%% |  |  |
 | Seite | @PAGE |

Ausgabe auf dem Drucker:

Datum: 20.03.2011 | Geschlossene AML Demoprojekt | Zeit: 12:00 Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
20.03.2011 13:00:00 | 20.03.2011 13:03:59 | Meldung 1 | Limit überschritten
20.03.2011 13:00:00 | 13:05:35 | Demomeldung | Limit 750 erreicht
20.03.2011 13:03:59 |  | Meldung 2 | Grenzwert
20.03.2011 13:11:23 |  | Meldung 3 | aus
20.03.2011 13:03:59 | 13:12:45 | Demomeldung | aus
 | Seite | 1 |


FRM-Konfigurationsdatei

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme drucken und exportieren -> FRM-Konfigurationsdatei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

FRM-Dateien (Formatdateien) sind Konfigurationsdateien für den Ausdruck von Listen.

Eine FRM-Datei gliedert sich in drei Teile:

  • Kopfteil: am Seitebeginn
  • Listenteil: zyklisch pro Zeile
  • Fußteil: am Seitenende

Grundsätze

Beachten Sie beim Bearbeiten von FRM-Dateien:

  • Trennung der Listenteile:
    • Kopfteil und Listenteil sowie Listenteil und Fußteil werden durch %% getrennt.

      Diese Gliederungsmarkierung darf nur je einmal für den Listenteil und den Fußteil verwendet werden.

    • Achtung: Nach der letzten Zeile müssen mindestens zwei leere Absätze folgen. Andernfalls wird die Fußzeile nicht gedruckt!
  • Positionierung der einzelnen Einträge:
    Es dürfen nur Leerzeichen verwendet werden, keine Tabulatoren.
  • Bearbeiten der FRM-Datei in einem Texteditor:
    Automatischer Zeilenumbruch muss deaktiviert werden, da sonst unerwünschte Effekte in der Formatierung auftreten können.

Schlüsselwörter

Die Einstellung der Seitenlänge wird in den Projekteigenschaften unter AML und CEL vorgenommen oder über die Dateien ALARM.frm oder ALAR_G.frm für AML bzw. BTB.frm und BTB_G.frm vür CEL.

Interne ID: FRM-Konfigurationsdatei

AML und CEL

Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bitte beachten Sie:

  • Die Anzahl der Alarmeinträge pro Seite ergibt sich aus der vorgegebenen Anzahl an Zeilen (z.B. Zeilen pro Seite 72) abzüglich der für Kopf- und Fußtexte verwendeten Zeilen.

    Interne ID: FRM-Konfigurationsdatei

    Zeilen pro Seite

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Anzahl der Zeilen, die beim Online-Ausdruck pro Seite gedruckt werden.
    Minimum: 0

    Interne ID: FRM-Konfigurationsdatei

    Drucken aktiv

    Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
    Inaktiv: Kein Online-Ausdruck findet statt.
    Default: aktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Maximum: 65535
    Default: 72

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Für die Verwendung der Schlüsselworte, die die Reaktivierung auswerten (Zeit, Anzahl), muss in der Alarmverwaltung die Option Reaktiviertzeit verwenden aktiviert sein.

    Interne ID: FRM-Konfigurationsdatei

    Reaktiviertzeit verwenden

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Aktiv: Wenn derselbe Alarm mehrmals hintereinander auftritt, wird nur eine Zeile in der Alarmmeldeliste erstellt. Zusätzliche Informationen (z.B. Alarmzähler) können in der Liste dargestellt werden.
    Inaktiv: Jeder Alarm erhält eine eigene Zeile in der Alarmmeldeliste.
    Default: inaktiv.

    Interne ID: FRM-Konfigurationsdatei

    Alarmmeldeliste aktiv

    Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
    Inaktiv: Alarme werden nicht aufgezeichnet.
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • In der Formatierungsdatei sind Schlüsselworte und freie Texte verwendbar. Schlüsselworte können alternativ in Deutsch oder Englisch verwendet werden. Die Verwendung englischer Schlüsselwörter wird empfohlen.
  • Nicht jedes Schlüsselwort ist für jede Art von Druck (AML, CEL, online, offline) geeignet.

Die folgende Tabelle enthält Schlüsselwörter in Deutsch und Englisch und deren Einsatzmöglichkeiten:

Deutsch

Englisch

AML Offline

CEL Offline

AML Online

CEL Online

Beschreibung

Schlüsselwörter für den Listenteil

@DATZEITKOMMT

@DTRECEIVED

X

X

X

X

Datum und Zeitpunkt des Alarmauftretens

@DATZEITGEHT

@DTCLEARED

X

-

X

-

Datum und Zeitpunkt des Alarmendes

@DATZEITOK

@DTACK

X

-

X

-

Datum und Zeitpunkt der Alarmquittierung

@DATZEITREAKT

@DTREACTIVATE

X

-

X

-

Datum und Zeitpunkt der Reaktivierung:

Eigenschaft Reaktiviertzeit verwenden in Projekteigenschaften muss aktiviert sein.

@DATZEIT

@DTLASTEVENT

-

-

X

-

Datum und Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEIT

@TLASTEVENT

-

-

X

X

Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEITOK

@TACK

X

-

X

-

gibt nur Zeitpunkt der Quittierung an

@ZTKOMMT

@TRECEIVED

X

X

X

X

gibt nur Zeitpunkt des Alarmauftretens an

@ZTGEHT

@TCLEARED

X

-

X

-

gibt nur Zeitpunkt der Alarmendes an

@ZTREAKT

@TREACTIVATE

X

-

X

-

gibt nur Zeitpunkt der Reaktivierung an

@TIMELASTING

@TACTIVE

X

-

X

-

Zeit anstehend (Differenz Zeit Kommt - Zeit geht)

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@KANALNAME

@VARNAME

X

X

X

X

Variablenanme
CEL: Nur Einträge mit Variablen

@AK

@ACLASSNR

X

X

X

X

Alarm/Ereignis-Klassenname

@AG

@AGROUPNR

X

X

X

X

Alarm/Ereignis-Gruppennummer

@AGNAME

@AGROUPNAME

X

X

X

X

Name der Alarm/Ereignis-Gruppe

@AKNAME

ACLASSNAME

X

X

X

X

Name der Alarm/Ereignis-Klasse

@TAGNR

@IDENTIFICATION

X

X

X

X

Kennung (firmenspezifische Bezeichnung)

@AMELDUNG

@TEXT

X

X

X

X

Alarmmeldetext

@REAKTANZ

@NRREACTIVATE

X

-

X

-

Anzahl der Reaktivierungen

@STATUS

@STATUS

X

X

X

X

Statusinformation wie in der Alarmliste

@WERT

@VALUE

X

X

X

X

Variablenwert des Alarms

@REAKTIONSTEXT

@COMMENT

X

X

X

X

Kommentar aus der Alarmliste.

Bei Verwendung von dynamischen Grenzwerttexten nur veerfügbar, wenn Lange dynamische Grenzwerttexte AML bzw. Lange dynamische Grenzwerttexte CEL aktiviert ist.

Interne ID: FRM-Konfigurationsdatei

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: FRM-Konfigurationsdatei

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

@USER

@USERID

X

X

X

X

AML: Anwender, der Alarm bestätigt hat.

@RECHNER

@COMPUTER

X

X

X

X

AML: Rechner, auf dem Alarm bestätigt wurde.

Schlüsselwörter für den Kopf- und Fußteil

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@SEITE

@PAGE

X

X

X

X

Seitenzahl

@HEADDATZEIT

@DTSYSTEM

X

X

X

X

Systemdatum und Systemuhrzeit

@HEADDATUM

@DSYSTEM

X

X

X

X

Systemdatum

@HEADZEIT

@TSYSTEM

X

X

X

X

Systemuhrzeit

@USER

@USERID

X

X

X

X

Benutzer, der druckt

@USERNAME

@USERNAME

X

X

X

X

Vollständiger Benutzername, der Aktivität auslöste

@RECHNER

@COMPUTER

X

X

X

X

Rechner, von deam aus gedruckt wird

[Text]

[Text]

beliebiger Text in der Ausgabezeile am Drucker

attention Achtung

Zwischen den Schlüsselwörtern muss ausreichend Platz vorgesehen werden, damit Einträge nicht überschrieben werden. Damit stellen Sie sicher, dass auch lange Grenzwert-Texte korrekt angezeigt werden.

Beispiel:

@TEXT (Leerzeichen bis hierher)


Alarme exportieren

Handbuch -> Alarmverwaltung -> Bedienen zur Runtime -> Alarme drucken und exportieren -> Alarme exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarme können in unterschiedliche Formate exportiert werden:

  • dBase
  • CSV
  • XML
  • SQL

Export

Um Alarme zu exportieren

  1. legen Sie eine Funktion AML exportieren an
  2. verknüpfen Sie die Funktion mit einem Button
  3. führen Sie die Funktion zur Runtime aus

info Info

Der Export nach SQL erfolgt inkrementell. Liegen bereits exportierte Daten vor, werden nur neue und geänderte Daten exportiert.


Änderungshistorie

Handbuch -> Änderungshistorie

Die Änderungshistorie dient der lückenlosen Dokumentation der Projektierung. Alle Eingriffe in ein Projekt, wie ändern, löschen, erzeugen usw., können protokolliert werden. Die Änderungshistorie ist per Default abgeschaltet und muss im Editor aktiviert werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
CSV exportieren alle... | Exportiert alle Einträge in eine CSV-Datei.
Erweiterten Filter aktivieren | Öffnet Dialog zur Projektierung erweiterter Filtereinstellungen.
Erweiterten Filter deaktivieren | Löscht die Einstellungen des erweiterten Filters und deaktiviert die Eigenschaften zur Projektierung erweiterter Filtereinstellungen.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Projektieren im Editor

Aufgezeichnete Daten

Aufgezeichnete Aktionen

Daten exportieren


Projektieren im Editor

Handbuch -> Änderungshistorie -> Projektieren im Editor

Die Änderungshistorie muss im Editor aktiviert werden. Dazu:

  1. navigieren Sie in den Projekteigenschaften zur Gruppe Änderungshistorie

    Interne ID: Projektieren im Editor

    Änderungshistorie

    Eigenschaften für die Änderungs-Historie.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. aktivieren Sie die Eigenschaft Änderungshistorie aktiv

    Interne ID: Projektieren im Editor

    Änderungshistorie aktiv

    Aktiv: Änderungen im Projekt werden mitprotokolliert.
    Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie über die Eigenschaft Detaillierungsstufe, welche Details aufgezeichnet werden:

    Interne ID: Projektieren im Editor

    Detaillierungsstufe

    Nur verfügbar, wenn die Eigenschaft Änderungshistorie aktiv aktiviert wurde.

    Auswahl der Detailstufen aus Dropdownliste.

    • Objekt: Es werden lediglich die Objektnamen der geänderten Objekte aufgezeichnet. Details zu den geänderten Eigenschaften und deren Werte scheinen nicht in der Änderungshistorie auf.
    • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
    • Wertänderungen: Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsgrad. Dabei wird neben dem neuen Wert einer Eigenschaft auch deren alter Wert gespeichert. Somit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich.

    Default: Eigenschaften

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Objekt: Es werden nur die Objektnamen der geänderten Objekte aufgezeichnet.
    • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
    • Wertänderungen: Neben dem neuen Wert einer Eigenschaft wird auch deren alter Wert gespeichert. Damit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich. Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsumfang.
  4. bei Mehrplatzfähigen Projekten kann über die Eigenschaft Änderungen automatisch ermöglichen zusätzlich der Eintrag eines Kommentars automatisch für den Schreibzugriff frei gegeben werden;
    diese Einstellung ist standardmäßig deaktiviert, da sie zu hohen Performanceansprüchen führen kann

    Interne ID: Projektieren im Editor

    Änderungen automatisch ermöglichen

    Nur verfügbar in mehrplatzfähigen Projekten und wenn die Änderungshistorie aktiv ist:
    Aktiv: Änderungen für Einträge der Liste werden automatisch ermöglicht, wenn Kommentare hinzugefügt werden. Sie müssen dann von Hand übernommen werden.
    Inaktiv: Kommentare können nur hinzugefügt werden, nachdem Änderungen für die Einträge vorher von Hand ermöglicht wurden.
    Default: inaktiv.

    ACHTUNG: Diese Funktionalität benötigt viel Performance, wenn sie aktiviert ist.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schutz der Änderungshistorie

Die Aktivierung/Deaktivierung der Änderungshistorie kann vor Änderungen durch unberechtigte Benutzer geschützt werden. Dazu:

  1. navigieren Sie in den Projekteigenschaften zur Gruppe Benutzerverwaltung

    Interne ID: Projektieren im Editor

    Benutzerverwaltung

    Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie in das Feld der Eigenschaft Funktionsbererechtigungen

    Interne ID: Projektieren im Editor

    Funktionsbererechtigungen

    Bestimmte Systemfunktionen (z.B: Projekt laden) können über die Berechtigungsebenen für unbefugte Benutzer gesperrt werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog zum Ändern der Funktionsberechtigungen wird geöffnet
  4. wählen Sie für Änderungshistorie ein/ausschalten die gewünschte Berechtigungsebene

Noch in diesem Kapitel

Änderungshistorie Detailansicht Symbolleiste und Kontextmenü


Änderungshistorie Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Änderungshistorie -> Projektieren im Editor -> Änderungshistorie Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Modul filtern | Setzt den Filter auf das Modul des ausgewählten Eintrags.
Objekt filtern | Setzt den Filter auf das Objekt des ausgewählten Eintrags.
Erweiterte Filter aktivieren | Aktiviert die Eigenschaften zur Projektierung erweiterter Filtereinstellungen.
Erweiterte Filter deaktivieren | Löscht die Einstellungen des erweiterten Filters und deaktiviert die Eigenschaften zur Projektierung erweiterter Filtereinstellungen.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Kopieren | Kopiert ausgewählten Eintrag in Zwischenablage.
Löschen | Löscht ausgewählte Einträge.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
Selektierte CSV exportieren | Exportiert ausgewählte Einträge in CSV-Datei.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Hilfe | Öffnet die Online-Hilfe.


Aufgezeichnete Daten

Handbuch -> Änderungshistorie -> Aufgezeichnete Daten

Bei aktivierter Änderungshistorie werden die Änderungen entsprechend den gewählten Einstellungen in der Detailansicht des Projektmanagers angezeigt. Der erste Eintrag dokumentiert das Aktivieren der Änderungshistorie. Beim Deaktivieren wird als letzter Eintrag die Deaktivierung eingetragen.

Eintrag

Beschreibung

Status

Status des Objekts bei Mehrplatzfähigen Projekten.

Grün: Objekt hat den Status Änderungen ermöglichen

Leer: Objekt hat den Status Änderungen übernehmen

Zeitstempel

Datum und Uhrzeit.

Aktion

Art des Eingriffs. Mögliche Werte:

  • Neu
  • Geändert
  • Gelöscht
  • Neu - VBA
  • Geändert - VBA
  • Gelöscht - VBA

Modul

Das Modul (z.B. PFS, Archiv, Report), in dem die Änderung durchgeführt wurde.

Objekt

Objekt, das geändert wurde.

Element

Element, das geändert wurde. Aufgezeichnet wird der Name wie in der Eigenschaft Elementname festgelegt.

Interne ID: Aufgezeichnete Daten

Elementname

Der Elementname muss für den Zugriff über VBA vergeben werden.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaft

Eigenschaft des Objektes/Elements, die geändert wurde.

Alter Wert

Der Wert der Eigenschaft bevor die Änderungen durchgeführt wurde.

Nur verfügbar, wenn in den Projekteigenschaften unter Detaillierungsstufe Wertänderungen ausgewählt wurde.

Interne ID: Aufgezeichnete Daten

Detaillierungsstufe

Nur verfügbar, wenn die Eigenschaft Änderungshistorie aktiv aktiviert wurde.

Interne ID: Aufgezeichnete Daten

Änderungshistorie aktiv

Aktiv: Änderungen im Projekt werden mitprotokolliert.
Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Auswahl der Detailstufen aus Dropdownliste.

  • Objekt: Es werden lediglich die Objektnamen der geänderten Objekte aufgezeichnet. Details zu den geänderten Eigenschaften und deren Werte scheinen nicht in der Änderungshistorie auf.
  • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
  • Wertänderungen: Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsgrad. Dabei wird neben dem neuen Wert einer Eigenschaft auch deren alter Wert gespeichert. Somit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich.

Default: Eigenschaften

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Neuer Wert

Wert der Eigenschaft nach der Änderung.

Nur verfügbar, wenn in den Projekteigenschaften unter Detaillierungsstufe

Eigenschaften oder Wertänderungen ausgewählt wurde.

Benutzer

Der Benutzer, der die Änderung durchgeführt hat. Ist die Benutzerverwaltung nicht aktiviert oder ist kein Benutzer eingeloggt, wird der Windows-Benutzer ausgelesen und eingetragen.

Rechner

Name des Computers, an dem die Änderung durchgeführt wurde.

Kommentar

Text zur freien Verfügung.

Die Spalten können per Drag&Drop mit der Maus beliebig angeordnet werden. Jede Spalte kann auf bestimmte Inhalte gefiltert werden.

Noch in diesem Kapitel

Daten filtern


Daten filtern

Handbuch -> Änderungshistorie -> Aufgezeichnete Daten -> Daten filtern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es bestehen zwei Möglichkeiten, um die angezeigte Liste der Änderungshistorie zu filtern:

  1. Erweiterter Filter der Änderungshistorie
  2. Filtern der Listenansicht

Erweiterter Filter der Änderungshistorie

Den erweiterten Filter erreichen Sie über das Kontextmenü im Projektmanager sowie in der Detailansicht.

Parameter | Beschreibung
Maximale Anzahl der Einträge | Definiert die maximale Anzahl von Datensätzen, die in der Listenansicht angezeigt werden 0: Unbeschränkte Anzahl. Default: 1000
Zeitperiode | Ermöglicht das Filtern auf einen bestimmten Zeitbereich bzw. ab oder bis zu einem bestimmten Zeitpunkt. Aktiv: Es werden nur Einträge aus dem angegeben Zeitbereich angezeigt. Default: deaktiviert
Von | Datum und Uhrzeit, ab dem Änderungen angezeigt werden sollen.
Bis | Datum und Uhrzeit, bis zu dem Änderungen angezeigt werden sollen.


Aufgezeichnete Aktionen

Handbuch -> Änderungshistorie -> Aufgezeichnete Aktionen

In der Änderungshistorie wird protokolliert:

Objekt

Änderungen

zenon Logic
  • zenon Logic Projekt neu
  • zenon Logic Projekt löschen
  • zenon Logic Projekt ändern

Archive
  • Archiv neu
  • Archiv löschen
  • Archiv ändern
  • Variable hinzufügen
  • Variable löschen

Benutzer
  • Benutzer neu
  • Benutzer löschen
  • Benutzer ändern

Bilder
  • Bild neu
  • Bild löschen
  • Bild ändern

Dateien
  • Datei hinzufügen
  • Datei löschen
  • Datei ändern

Datentypen
  • Datentyp neu
  • Datentyp löschen
  • Datentyp ändern

Dynamische Elemente/Vektor-Elemente
  • Element neu
  • Element löschen
  • Element ändern

Funktionen
  • Funktion neu
  • Funktion löschen
  • Funktion ändern

Menüs
  • Hauptmenü neu
  • Hauptmenü löschen
  • Hauptmenü ändern
  • Kontextmenü neu
  • Kontextmenü löschen
  • Kontextmenü ändern

Message Control
  • Beim Speichern von Änderungen

Process Control Engine
  • Beim Speichern von Änderungen

Projekt
  • Projekt im Projektbaum verschieben

Projektsicherung
  • Erstellung einer Projektsicherung mit Versionsnummer.

Reaktionsmatrizen
  • Rema neu
  • Rema löschen
  • Rema ändern

Report
  • Report neu
  • Report löschen
  • Report ändern - Beim Speichern

Rezept
  • Rezept neu
  • Rezept löschen
  • Rezept ändern
  • Variable hinzufügen
  • Variable löschen
  • Wert ändern

Rezeptgruppen
  • Rezeptgruppe neu
  • Rezeptgruppe löschen
  • Rezeptgruppe ändern
  • Rezept neu
  • Rezept ändern
  • Rezept löschen
  • Variable hinzufügen
  • Variable löschen
  • Wert ändern
  • Quelle ändern
  • Quellentyp ändern

Schablonen
  • Schablone neu
  • Schablone löschen
  • Schablone ändern

Scheduler
  • Beim Speichern von Änderungen

Schriften
  • Schrift neu
  • Schrift löschen
  • Schrift ändern

Skripte
  • Skript neu
  • Skript löschen
  • Skript ändern

Sprachtabelle
  • Eintrag neu
  • Eintrag löschen
  • Eintrag ändern

Treiber
  • Treiber neu
  • Treiber löschen
  • Treiber ändern

VBA
  • Beim Speichern von Änderungen im VBA-Editor wird ein Eintrag generiert.

Variablen
  • Variable neu
  • Variable löschen
  • Variable ändern

Verriegelungen
  • Verriegelung neu
  • Verriegelung ändern
  • Verriegelung löschen
  • Variable neu
  • Variable löschen

Zeitsteuerung
  • Zeitfunktion neu
  • Zeitfunktion löschen
  • Zeitfunktion ändern


Daten exportieren

Handbuch -> Änderungshistorie -> Daten exportieren

Die Daten der Änderungshistorie können in die Formate XML und CSV exportiert werden.

Um Daten zu exportieren:

  1. markieren Sie die gewünschten Einträge
    (Multiselekt per Tastenkombinationen Strg+linke Maustaste, Umschalt+linke Maustaste, Strg+a ist möglich)
  2. wählen Sie im Kontextmenü die gewünschte Exportform (XML, CSV)
  3. der Dialog zur Wahl des Speicherorts wird geöffnet
  4. vergeben Sie einen Namen und bestätigen Sie die Eingabe mit Klick auf Speichern

Hinweis: Die Überschriften der Einträge in den exportierten Daten sind in Englisch.


Anlagenmodellierung

Handbuch -> Anlagenmodellierung

Anlagenmodellierung bildet die Struktur einer Anlage im Editor nach. Entsprechend der Normen ISA S88 und S95 können mit zenon alle alle Ebenen eines Unternehmens abgebildet werden:

Die oberen drei Ebenen (Enterprise, Site, Area) ermöglichen es, die Details der unteren Ebenen korrekt zuzuordnen und in Beziehung zu setzen. Die unteren Ebenen referenzieren spezifische Ausstattungen, die für Prozesssteuerung und Prozesskontrolle zusammengestellt werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Anlagenmodellierung in zenon

Mit zenon können Sie das gesamte Modell abbilden und beliebige Maschinen, Gebäude und Abläufe erstellen. Zur Runtime und im Editor können damit Daten gruppiert und gefiltert werden. Das Modul Anlagenmodellierung finden Sie im Projektbaum ausschließlich im Globalprojekt. Das Bedeutet, dass Sie ein Globalprojekt anlegen müssen und in den Arbeitsbereich einbinden müssen, damit Sie die Anlagenmodellierung nutzen können.

Fenster Anlagenmodellierung

Die Anlagenmodelle können in einem eigenen Fenster geöffnet werden:

  • wählen Sie dazu im Kontextmenü der Anlagenmodellierung im Projektmanager den Befehl In neuem Fenster öffnen...
  • standardmäßig wird im unteren Bereich des Editors ein neues Fenster mit den Anlagenmodellen geöffnet
  • Sie können dieses Fenster wie alle Fenster im Editor beliebig platzieren
  • Falls Sie auch die Detailansicht der Anlagenmodellierung geöffnet halten, werden die Inhalte der beiden Fenster synchronisiert, so dass Sie in beiden Änderungen vornehmen können.

Noch in diesem Kapitel

Anlagenmodell erstellen

Modelle mit Elementen und Objekten verknüpfen

Filtern in Detailansicht

Filtern zur Runtime


Anlagenmodell erstellen

Handbuch -> Anlagenmodellierung -> Anlagenmodell erstellen

Sie können beliebig viele Anlagenmodelle erstellen und diese nach bestimmten Kriterien gruppieren. Erstellen Sie zuerst das Modell und erzeugen Sie diesem dann Gruppen.

Um ein neues Modell zu erstellen:

  • wählen Sie im Kontextmenü des Knotens Anlagenmodellierung im Globalprojekt den Befehl Anlagenmodell neu

    oder wählen Sie in der Symbolleiste das Symbol für Anlagenmodell neu

  • in der Detailansicht wird ein neuer Knoten mit dem Standardnamen ModellX erzeugt (X steht für die fortlaufende Nummerierung)
  • passen Sie den Namen an Ihre Bedürfnisse an, dazu drücken Sie bei markiertem Namen die Taste F2 oder führen einen Dreifachklick ins Namensfeld aus

Um eine neue Gruppe zu erstellen:

  • wählen Sie im Kontextmenü des Modells oder eine Übergruppe den Befehl Anlagengruppe neu

    oder drücken Sie die Taste Einfg

    oder wählen Sie in der Symbolleiste das Symbol Anlagengruppe neu

  • in der Modellstruktur wird eine neue Gruppe mit dem Standardnamen GruppeX erzeugt (X steht für die fortlaufende Nummerierung)
  • passen Sie den Namen an Ihre Bedürfnisse an: direkt nach dem Erstellen befindet sich das Namensfeld bereits im Editiermodus, später drücken Sie bei markiertem Namen die Taste F2 oder führen einen Dreifachklick ins Namensfeld aus
  • es sind beliebig viele Gruppen und Untergruppen erlaubt

Noch in diesem Kapitel

Anlagenmodell bearbeiten

Kontextmenü Projektmanager

Symbolleiste und Kontextmenü Detailansicht


Anlagenmodell bearbeiten

Handbuch -> Anlagenmodellierung -> Anlagenmodell erstellen -> Anlagenmodell bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Gruppen können innerhalb eines Modells und modellübergreifend neu sortiert, kopiert, verschoben und gelöscht werden:

Auswahl

Anlagenmodelle und Anlagengruppen können auch per Multiselect ausgewählt werden, wenn sich die Elemente:

  • auf der gleichen Ebene
  • innerhalb des gleichen Modells
  • und der gleichen übergeordneten Gruppe

    befinden.

Die Auswahl erfolgt mit der gedrückter Taste Strg+linker Mausklick:
Hinweis: Mit Umschalt+Mausklick ist zwar die Auswahl mehrerer Elemente auf unterschiedlichen Ebenen möglich, die Bearbeitungsmöglichkeiten im Kontextmenü und auf der Symbolleiste sind aber deaktiviert.

Löschen

  • markieren Sie den gewünschten Knoten
  • wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl Löschen oder drücken Sie die Taste Entf
  • der Knoten wird mit sämtlichen Untergruppen gelöscht

Verschieben per Drag&Drop

  • markieren Sie den gewünschten Knoten
  • halten Sie die linke Maustaste gedrückt
  • verschieben Sie den Knoten an die gewünschte Stelle und lassen Sie die Maustaste los

Umsortieren per Drag&Drop

  • markieren Sie den gewünschten Knoten
  • halten Sie Taste Strg gedrückt und ziehen Sie den Knoten mit gedrückter linker Maustaste an die gewünschte Position
  • eine horizontale Linie zeigt jene Stellen an, an denen Sie den Knoten einfügen können

Kopieren und einfügen

  • markieren Sie den gewünschten Knoten
  • wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl Kopieren oder die Tastenkombination Strg+C
  • markieren Sie den Ziel-Knoten
  • wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl Einfügen oder die Tastenkombination Strg+V
  • der kopierte Knoten wird eingefügt
    • Unterknoten werden nicht mitkopiert
    • der Gruppenname darf auf gleicher Ebene in der Zielgruppe noch nicht vorhanden sein

Umbenennen

Um Modelle oder Gruppen umzubenennen:

  1. markieren Sie das Modell/die Gruppe
  2. drücken Sie die Taste F2 oder führen Sie einen Dreifachklick auf das Modell/die Gruppe aus

Nach eine Umbenennung:

  • werden Modelle neu alphabetisch sortiert
  • bleiben Gruppen in der angelegten Struktur erhalten

attention Achtung

Die Aktionen löschen, umsortieren, verschieben, umbenennen und einfügen können nicht rückgängig gemacht werden.


Kontextmenü Projektmanager

Handbuch -> Anlagenmodellierung -> Anlagenmodell erstellen -> Kontextmenü Projektmanager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Befehl | Funktion
Anlagenmodell neu | erstellt ein neues Anlagenmodell mit der Standardbezeichnung ModellX (X steht für eine fortlaufende Nummer)
In neuem Fenster öffnen | öffnet ein neues Fenster im Editor, das die Anlagenmodelle enthält
Hilfe | öffnet diese Hilfeseite


Symbolleiste und Kontextmenü Detailansicht

Handbuch -> Anlagenmodellierung -> Anlagenmodell erstellen -> Symbolleiste und Kontextmenü Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste und Kontextmenü

Symbol

Funktion

Anlagengruppe neu

erstellt eine neue Anlagengruppe mit der Standardbezeichnung GruppeX (X steht für fortlaufende Nummer)

Anlagenmodell neu

erstellt ein neues Anlagenmodell mit der Standardbezeichnung ModellX (X steht für fortlaufende Nummer)

Verknüpfte Elemente

öffnet den Dialog zur Anzeige verknüpfter Elemente.

Kopieren

kopiert die gewählte Gruppe mit Untergruppen

Einfügen

fügt die kopierte Gruppe in andere Gruppe oder anderes Modell ein. Ist bereits eine Gruppe gleichen Namens vorhanden, wird der eingefügten Gruppe ein Kopie von vorangestellt.

Löschen

löscht die gewählte Gruppe mit allen Untergruppen

Knoten erweitern/ reduzieren

Öffnet die Dropdownliste zum Erweitern oder Reduzieren der Knoten.
  • Alle erweitern

Erweitert alle Knoten.
  • Alle reduzieren

Reduziert alle Knoten.
  • Selektierte erweitern

Erweitert den markierten Knoten.
  • Selektierte reduzieren

Reduziert den markierten Knoten.

XML exportieren alle

Exportiert alle Einträge in XML-Datei.

XML importieren

Importiert aus XML-Datei.

Hilfe

öffnet diese Hilfeseite


Modelle mit Elementen und Objekten verknüpfen

Handbuch -> Anlagenmodellierung -> Modelle mit Elementen und Objekten verknüpfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jede Anlagengruppe kann mit beliebigen zenon Elementen und Objekten verknüpft und danach gefiltert werden. Um eine Gruppe mit einem Element zu verknüpfen, haben Sie mehrere Möglichkeiten:

  • Über die Eigenschaft Anlagengruppen des Elements:

    Interne ID: Modelle mit Elementen und Objekten verknüpfen

    Anlagengruppen

    Verknüpft Element mit einem Anlagenmodell. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Anlagengruppe.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • kopieren und einfügen des Elementes in die gewünscht Gruppe des Modells
  • Über Drag&Drop der Anlagengruppe auf die Eigenschaft Anlagengruppen des Elements
  • Über Drag&Drop des Elementes auf die Anlagengruppe

Eigenschaft Anlagengruppen

Für die Verknüpfung über die Eigenschaften eines Elements:

  1. wählen Sie das Element aus
  2. klicken Sie auf die Eigenschaft Anlagengruppen im Knoten Allgemein

    Interne ID: Modelle mit Elementen und Objekten verknüpfen

    Allgemein

    Allgemeine Eigenschaften der Variable oder des Datentyps.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog zum Zuweisen von Elementen zu Anlagengruppen öffnet sich
  4. weisen Sie die gewünschten Anlagengruppen zu (Details siehe Unterkapitel Dialog Anlagenmodellierung)

info Info

Keine Vererbung

Werden bei der Konfiguration von zum Beispiel Datentypen, Treibern, Funktionen, Variablen Anlagenmodelle über die Eigenschaft Anlagengruppen zum Verknüpfen ausgewählt oder neu erzeugt, dienen diese nur zum Filtern und werden nicht vererbt.

Zum Beispiel: Ein in einem Datentyp gewähltes Anlagenmodell wird nicht auf eine Variable, die auf diesem Datentyp basiert, vererbt.

Kopieren und einfügen

Für die Verknüpfung mittels kopieren und einfügen:

  1. wählen Sie das Element aus
  2. kopieren Sie das Element (Befehl Kopieren oder Tastenkombination Strg+C)
  3. markieren Sie die gewünschte Anlagengruppe
  4. fügen Sie das Element ein (Befehl Einfügen oder Tastenkombination Strg+V)

Drag&Drop der Anlagengruppe

Für die Verknüpfung per Drag&Drop der Anlagengruppe auf das Element:

  1. wählen Sie die Anlagengruppe aus
  2. ziehen Sie diese mit gedrückter linker Maustaste auf die Eigenschaft Anlagengruppen im Knoten Allgemein des Elements

Drag&Drop des Elementes

Für die Verknüpfung per Drag&Drop des Elements auf die Anlagengruppe:

  1. wählen Sie das Element in der Detailansicht des Projektmanagers
  2. ziehen Sie es mit gedrückter linker Maustaste auf die gewünschte Anlagengruppe

info Info

Beim Drag&Drop von Strukturvariablen: Es werden nur aktivierte Variablen berücksichtigt. Nicht aktivierte Elemente werden nicht verknüpft. Überprüfen Sie bei geschlossen Strukturbäumen, ob alle gewünschten Variablen aktiviert sind.

Noch in diesem Kapitel

Dialog Anlagenmodellierung

Liste Verknüpfte Elemente


Dialog Anlagenmodellierung

Handbuch -> Anlagenmodellierung -> Modelle mit Elementen und Objekten verknüpfen -> Dialog Anlagenmodellierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Dialog Anlagenmodellierung weisen Sie einem Element beliebige Anlagengruppen zu. Der Dialog öffnet sich, wenn Sie in den Eigenschaften des Elements im Knoten Allgemein die Eigenschaft Anlagengruppen wählen:

Interne ID: Dialog Anlagenmodellierung

Anlagengruppen

Verknüpft Element mit einem Anlagenmodell. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Anlagengruppe.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Dialog Anlagenmodellierung

Allgemein

Allgemeine Eigenschaften der Variable oder des Datentyps.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaft | Beschreibung
Symbolleiste | Siehe Kapitel Symbolleiste und Kontextmenü Detailansicht.
Hinzufügen | Fügt ausgewählte Gruppen und Ebenen zur Auswahl hinzu.
Entfernen | Löscht ausgewählte Elemente aus der Auswahl.
OK | Übernimmt Einstellungen aus allen Registerkarten und schließt Dialog.
Abbrechen | Es wird kein Element ausgewählt.
Hilfe | Öffnet Online-Hilfe.

Gruppen hinzufügen

  • wählen Sie das gewünschte Anlagenmodell
  • wählen Sie eine Anlagengruppe oder Ebene, Elemente auf der gleichen hierarchischen Stufe können per Multiselect gleichzeitig ausgewählt werden (Taste Strg gedrückt halten)
  • fügen Sie diese über die Schaltfläche Hinzufügen zur Liste im untern Bereich des Dialogs hinzu
  • Untergruppen werden nicht automatisch hinzugefügt
  • es können beliebig viele Gruppen verknüpft werden

Gruppen löschen

  • wählen Sie in der Liste im unteren Bereich des Dialogs die gewünschten Elemente
  • klicken Sie auf die Schaltfläche Entfernen

Hinweis: Änderungen in einem Baum-Element bleiben erhalten, unabhängig davon, ob die Schaltfläche Abbrechen betätigt wird. Abbrechen bedeutet nur, dass kein Element ausgewählt wird.

In Bildumschaltung auf Anlagengruppe Filtern

Bei der Bildumschaltung auf ein Bild vom Typ AML, CEL oder RGM sowie bei der Funktion Gruppen/Klassen/Bereiche/Anlagen unterdrücken (Message Control) kann im Filterdialog auf Anlagengruppen gefiltert werden. Anleitungen dazu finden Sie bei der Beschreibung der entsprechenden Dialoge:

  • AML Anlagenmodellierung
  • CEL Anlagenmodellierung
  • RGM Anlagenmodellierung
  • Message Control Gruppen/Klassen/Bereiche/Anlagen unterdrücken


Liste Verknüpfte Elemente

Handbuch -> Anlagenmodellierung -> Modelle mit Elementen und Objekten verknüpfen -> Liste Verknüpfte Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für jede Anlagengruppe können alle Elemente, die die Anlagengruppe verknüpft haben als Liste angezeigt werden. Über das Kontextmenü können Sie dann direkt zum verknüpften Element springen.

  1. wählen Sie in die gewünschte Anlagengruppe
  2. wählen Sie im Kontextmenü den Befehl Verknüpfte Elemente...

    (Details siehe Unterkapitel Kontextmenü verknüpfte Elemente)

  3. die Liste der verknüpften Elemente wird geöffnet

Im Kontextmenü der Elemente können Sie

  • direkt zum Element springen
  • das Element aus der Liste löschen; das Element verliert dann seine Verknüpfung zu dieser Anlagengruppe

Noch in diesem Kapitel

Kontextmenü verknüpfte Elemente


Kontextmenü verknüpfte Elemente

Handbuch -> Anlagenmodellierung -> Modelle mit Elementen und Objekten verknüpfen -> Liste Verknüpfte Elemente -> Kontextmenü verknüpfte Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Dialog für verknüpfte Elemente können einzelne Elemente per Kontextmenü im Editor geöffnet oder aus der Liste gelöscht werden:

Befehl | Beschreibung
Zu verknüpftem Element springen | springt zum Element im Editor, die Liste bleibt geöffnet
Selektierte Elemente entfernen | löscht das gewählte Element aus der Liste, die Verbindung zu dieser Anlagengruppe wird gelöst
Hilfe | öffnet diese Hilfeseite


Filtern in Detailansicht

Handbuch -> Anlagenmodellierung -> Filtern in Detailansicht

In der Detailansicht des Projektmanagers kann nach Anlagengruppen gefiltert werden. Falls diese noch nicht angezeigt werden, wählen Sie im Kontextmenü den Befehl Spaltenauswahl und fügen Anlagengruppen hinzu. Um zu filtern:

  • klicken Sie auf das Filtersymbol in der Kopfspalte Anlagengruppen
  • der Auswahldialog für die Anlagengruppen wird geöffnet
  • fügen Sie die gewünschten Filterkriterien zur Liste hinzu
  • es werden nur noch jene Elemente in der Detailansicht angezeigt, die mit den ausgewählten Anlagengruppen verknüpft sind

Um den Filter zurückzusetzen:

  • klicken Sie auf das Filtersymbol in der Kopfspalte Anlagengruppen
  • der Auswahldialog für die Anlagengruppen wird geöffnet
  • entfernen Sie die gewünschten Filterkriterien aus der Liste


Filtern zur Runtime

Handbuch -> Anlagenmodellierung -> Filtern zur Runtime

Um zur Runtime zu filtern, erstellen Sie eine Funktion Bildumschaltung auf das gewünschte Bild und definieren in der Registerkarte Anlagenmodellierung den Filter. Zur Runtime werden Daten entsprechend dem voreingestellten Filter angezeigt. Um den Filter zur Runtime zu verändern, muss die Schaltfläche Filter in der Dialogmaske vorhanden sein:

  • klicken Sie auf die Schaltfläche Filter
  • wählen Sie im Filterdialog die Registerkarte Anlagenmodellierung
  • wählen Sie Modelle und Anlagengruppen aus
  • bestätigen Sie mit OK

Filterung auf Anlagengruppen zur Runtime ist möglich bei:

  • Rezeptgruppen-Manager:

    Es werden nur die Rezeptgruppen in der Dropdownliste angeboten, die auch im Filter enthalten sind. Werden neue Rezeptgruppen angelegt, können diese mit bestehenden Anlagengruppen verknüpft werden. Diese neu angelegten Daten können im Editor wieder aus den Runtime-Dateien zurückgelesen werden. Dabei werden auch die verknüpften Anlagengruppen zurückgelesen.

  • AML:

    Es werden nur die Alarme angezeigt, deren Variablen mit den Anlagengruppen verknüpft sind.

  • CEL:

    Es werden nur die Einträge angezeigt, deren Variablen mit den Anlagengruppen verknüpft sind.

Noch in diesem Kapitel

Funktion Bildumschaltung erstellen


Funktion Bildumschaltung erstellen

Handbuch -> Anlagenmodellierung -> Filtern zur Runtime -> Funktion Bildumschaltung erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Funktion Bildumschaltung zu erstellen und auf Anlagengruppen zu filtern:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. wählen Sie das gewünschte Bild
  3. klicken Sie im Dialog Filter auf die Registerkarte Anlagenmodellierung
  4. wählen Sie Modelle und Anlagengruppen aus
  5. bestätigen Sie mit OK

Element | Beschreibung
Anlagenmodell | bietet Modelle und Gruppen zur Auswahl an
Hinzufügen | fügt ausgewählte Gruppe zur Filterliste hinzu
Entfernen | entfernt ausgewählte Gruppe aus Filterliste


Archivserver

Handbuch -> Archivserver

Die Archivierung, das Aufzeichnen von Prozessdaten und daraus abgeleiteten Variablen, geschieht in zenon mithilfe des Moduls Archivserver. Der Archivserver verwaltet die Aufzeichnung der gewünschten Daten und stellt auch verschiedene Speicher- und Exportformate zur Verfügung. Dadurch sind die Daten für eine spätere Nachbearbeitung und Auswertung - auch außerhalb von zenon - verfügbar.

In zenon können Sie die Archivdaten mithilfe des Erweiterten Trends, des Report Generators oder des Bilds von Typ Archiv-Nachbearbeitung auswerten oder weiterverarbeiten.

tutorial Lizenzinformation

In Editor und Runtime (Einzelplatz, Server, Standby) lizenzpflichtig.

Hinweis: Funktionsreduzierte Archivserver Starter Edition ist bereits in Standardlizenz enthalten.

Noch in diesem Kapitel

Allgemein

Format der Archivdateien

Kaskadierung und Verdichtung

Projektieren im Editor

Folgearchive definieren

Chargenarchivierung

Strings archivieren

Ausgabemöglichkeiten

Ablauf der Archivierung

Filterprofile

Funktionen

Bedienung während der Runtime


Allgemein

Handbuch -> Archivserver -> Allgemein

Das Modul Archivserver steht Ihnen in zenon in zwei Versionen zur Verfügung: Archivserver Starter Edition und Archivserver lizenzierte Version.

Im Allgemeinen wird in zenon unter 3 Standardarchivierungen unterschieden.

  • Zyklische Archivierung
  • Start-/Stopp-Archivierung
  • RDA (Real Time Data Acquisition)

Noch in diesem Kapitel

Archivserver Starter Edition

Archivserver lizenzierte Version

Zyklische Archivierung

Start-/Stopp-Archivierung

RDA - Real time Data Acquisition


Archivserver Starter Edition

Handbuch -> Archivserver -> Allgemein -> Archivserver Starter Edition

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Standardumfang der TAG-basierten zenon Version am PC ist eine reduzierte Version des Archivservers enthalten. Die Starter Edition basiert auf dem Standard-Archivserver hat jedoch folgende Einschränkungen:

  • keine Chargenarchivierung
  • kein RDA
  • keine Aufzeichnung bei Wertänderung oder ereignisgesteuerte Archivierung, sondern nur zyklische Abtastung
  • kein Auslagerung der Daten, sondern nur Ringpuffer
  • keine Folgearchive
  • kein Manipulieren von Daten über Archiv-Nachbearbeitung oder Report Generator
  • Export unter CE nur im Format ASCII möglich (am PC zusätzlich auch XML und DBF)
  • Archivdaten können nur im ARX-Dateiformat gespeichert werden

Achtung:

  • Ist im Editor nur die Archivserver Starter Edition lizenziert, können Funktionalitäten, die die oben genannten Einschränkungen übersteigen, nicht projektiert werden.
  • Ist in der Runtime nur die Archivserver Starter Edition lizenziert, werden Archive, die die oben genannten Einschränkungen übersteigen, nicht gestartet. Es wird ein Eintrag im Diagnose Server erzeugt.
    Ebenso können vom Report oder von der Archiv-Nachbearbeitung keine Speicheroperationen durchgeführt werden.
    Beispiel: Ein Archiv ist mit Aufzeichnung bei Wertänderung projektiert. In der Runtime wird es nicht gestartet. Dadurch werden auch keine Daten für das Archiv aufgezeichnet.


Archivserver lizenzierte Version

Handbuch -> Archivserver -> Allgemein -> Archivserver lizenzierte Version

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Am PC kann die Archivserver Starter Edition jederzeit datenkompatibel zum vollwertigen Archivserver erweitert werden (Lizenzerweiterung).

  • Sind sowohl die Archivserver Starter Edition als auch der Archivserver lizenziert, stehen alle Funktionalitäten des Archivservers zur Verfügung.
  • Für I/O lizenzierte Versionen steht die Starter Edition nicht zur Verfügung.
  • Für die Windows CE 6.0 Runtime ist die Archivserver Starter Edition gemeinsam mit der Erweiterter Trend Starter Editon optional erhältlich (Datenexport unter CE nur im Format CSV).
    Für ältere Windows CE Versionen stehen beide Module nicht zur Verfügung.

SQL-Auslagerung

Die lizenzierte Version des Archivservers kann um SQL-Auslagerung erweitert werden. Dazu müssen Sie die Lizenz für den zenon SQL Server erwerben.


Zyklische Archivierung

Handbuch -> Archivserver -> Allgemein -> Zyklische Archivierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der zyklischen Archivierung wird ein Archiv regelmäßig gestartet und nach einem definierten Zeitraum wieder beendet.

In diesem Zeitraum können Werte in das Archiv geschrieben werden. Die Werte können entweder mithilfe der zyklischen Aufzeichnung, der ereignisgesteuerten Aufzeichnung oder der Aufzeichnung bei Wertänderung in das Archiv geschrieben werden.

info Info

Beachten Sie den Unterschied zwischen zyklischer Archivierung und zyklischer Abtastung.

Zyklische Archivierung bedeutet, dass in einem definierten Zyklus ein Archiv gestartet und beendet wird.

Beispiel:

Ein Archive wird jeden Tag um 0:00:00 Uhr gestartet und um 23:59:59 beendet.

Zyklische Abtastung bedeutet, dass immer zu einer bestimmten Zeit ein Wert in ein Archiv geschrieben wird.

Beispiel: Der Wert der Variable X wird alle 10 Minuten in ein Archiv geschrieben.


Start-/Stopp-Archivierung

Handbuch -> Archivserver -> Allgemein -> Start-/Stopp-Archivierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können die Archivierung in der zenon Runtime auch manuell mithilfe der Funktionen Archiv starten und Archiv beenden steuern.

Solange ein Archiv aktiv ist können Werte in das Archiv geschrieben werden. Die Werte können entweder mithilfe der zyklischen Aufzeichnung, der ereignisgesteuerten Aufzeichnung oder der Aufzeichnung bei Wertänderung in das Archiv geschrieben werden.


RDA - Real time Data Acquisition

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die RDA Funktionalität wird verwendet, um in der Steuerung archivierte Werte auszulesen und in einem zenon Archiv zu speichern. Eine typische Anwendung dafür sind Archivierungsaufgaben von Steuerungen, die nicht permanent an zenon angeschlossen sind.

RDA kann auch für Post-Mortem-Analysen bei Fehler auf der Steuerung verwendet werden. Dazu muss die Steuerung entsprechend konfiguriert werden.

1. Definieren der Variablen in der Steuerung

Für jede RDA Variable ist ein eigener, durchgehender, linearer Bereich in der SPS vorzusehen.

Um Probleme zu vermeiden sollte ein Datentyp für die Variablen gewählt werden, der nicht kleiner ist als der, in dem die Steuerung organisiert ist!

Die erste Variable des für das RDA vorgesehenen Bereichs in der Steuerung dient als Schalter für das Anstoßen des Transfer-Prozesses. D.h. wird diese Variable von der Steuerung auf den Wert 1 gesetzt, so werden die nachfolgenden Werte - wie im Header (siehe weiter unten) definiert - in zenon geladen und archiviert. Sodann setzt der Treiber die Variable automatisch wieder auf den Wert 0.

2. Definieren der Variablen in zenon

In zenon definieren Sie Ihre Variablen wie bisher. Diese Variablen müssen in der Steuerung in einem durchgehenden, linearen Bereich liegen.

Achten Sie dabei darauf, dass bei den Variablen-Eigenschaften unter Erweitert/Harddisk die Eigenschaft HD-Werte auf nachsortierte Werte (RDA) eingestellt ist.

3. Anlegen des Archives in zenon

Legen Sie ein Archiv an und wählen Sie die RDA Variablen aus. Das entsprechende Archiv muss ein spontanes Archiv sein.

Noch in diesem Kapitel

SPS Datenformatierungen

Header Beschreibung

Typen Beschreibung


SPS Datenformatierungen

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition -> SPS Datenformatierungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mögliche RDA Datentypen sind (BYTE, WORD, DWORD, FLOAT) abhängig von dem verwendeten Treiber in zenon z.B.: S5PG32, PSUNI32, ...

attention Achtung

Es können keine zukünftigen Werte eingelesen werden. Dies kann geschehen, wenn in der SPS und dem PC unterschiedliche Systemzeiten auftreten. Daher sollten die Zeiten synchronisiert werden.


Header Beschreibung

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition -> Header Beschreibung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter | Beschreibung
Index [0] | Größe ist abhängig vom Datentyp in zenon z.B.: (BYTE, WORD, DWORD, FLOAT) Trigger Flag: wird von der SPS auf 1 gesetzt wenn Nutzdaten geholt werden sollen. Nachdem zenon die Daten geholt hat wird das Flag automatisch auf 0 zurück gesetzt.
Index [1] | 32Bit Intel Format Anzahl der Nutzdaten. Wird von der SPS gesetzt
Index [2] | 32Bit Intel Format Zykluszeit in ms, wird nur für TYP1 verwendet. Wird von der SPS gesetzt
Index [3] | 32Bit Intel Format Typ 1.....Ohne Zeit (nur mehr aus Kompatibilitätsgründen vorhanden, und sollte nicht mehr verwendet werden) Typ 2.....Mit Zeitformat 1 Typ 3.....Mit Zeitformat 2 Typ 4 Wird von der SPS gesetzt
Index [4] | 32Bit Intel Format Index des ältesten Wertes (nur relevant bei TYP 1). Wird von der SPS gesetzt und hat folgende Auswirkung im Archiv:
Index [5] | Nutzdaten Anfang Größe je nach zenon Datentyp z.B.: (BYTE, WORD, DWORD, FLOAT)


Typen Beschreibung

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition -> Typen Beschreibung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

TYP 1

TYP 2

TYP 3

TYP 4


TYP 1

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition -> Typen Beschreibung -> TYP 1

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter | Beschreibung
Index [5] | Nutzdaten Anfang Größe je nach zenon Datentyp z.B.: (BYTE ,WORD, DWORD, FLOAT)
Index [6] |
Index [usw..] |

Anzahl | 5 | Ergebnis in Archiv |  |  |  |  |
Ältester Wert |  | 0 | 1 | 2 | 3 | 4 | Archiv
Wert SPS | Index SPS | Wert | Wert | Wert | Wert | Wert | Zeit
1 | 0 | 1 | 2 | 3 | 4 | 5 | 00:00
2 | 1 | 5 | 1 | 2 | 3 | 4 | 00:01
3 | 2 | 4 | 5 | 1 | 2 | 3 | 00:02
4 | 3 | 3 | 4 | 5 | 1 | 2 | 00:03
5 | 4 | 2 | 3 | 4 | 5 | 1 | 00:04

attention Achtung

Dieser Typ wurde durch Typ 4 ersetzt und sollte nicht mehr verwendet werden. Er ist nur noch aus Kompatibilitätsgründen vorhanden.


TYP 2

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition -> Typen Beschreibung -> TYP 2

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Index [5]

Nutzdaten Anfang Größe je nach zenon Datentyp
z.B.: (BYTE, WORD, DWORD, FLOAT)

Index [6]

4 Byte langes Zeit Format -->
Byte1=Stunden 0 - 23
Byte2=Minute 0 - 59
Byte3=Sekunde 0 - 59
Byte4=Hundertstel sek. 0 - 100

Index [7]

Nutzdaten Größe je nach zenon Datentyp
z.B.: (BYTE, WORD, DWORD, FLOAT)

Index [8]

4 Byte langes Zeit Format -->
Byte1=Stunden 0 - 23
Byte2=Minute 0 - 59
Byte3=Sekunde 0 - 59
Byte4=Hundertstel sek. 0 - 100

Index [usw..]


TYP 3

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition -> Typen Beschreibung -> TYP 3

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Index [5]

Nutzdaten Anfang Größe je nach zenon Datentyp
z.B.: (BYTE, WORD, DWORD, FLOAT)

Index [6]

8 Byte langes Zeit Format -->
Byte1=Jahr 97,98,usw..
(HINWEIS: Das Zeitformat wird ab 1900 zweistelling verwendet, d.h. ab 2000 ergeben sich hier drei Stellen)
Byte2=Monat 1 - 12
Byte3=Tag 1 - 31
Byte4=Stunden 0 - 23
Byte5=Minute 0 - 59
Byte6=Sekunde 0 - 59
Byte7=Hundertstel sek. 0 - 100
Byte8=res.

Index [7]

Nutzdaten Größe je nach zenon Datentyp
z.B.: (BYTE, WORD, DWORD, FLOAT)

Index [8]

8 Byte langes Zeit Format -->
Byte1=Jahr 97,98,usw..
(HINWEIS: Das Zeitformat wird ab 1900 zweistelling verwendet, d.h. ab 2000 ergeben sich hier drei Stellen)
Byte2=Monat 1 - 12
Byte3=Tag 1 - 31
Byte4=Stunden 0 - 23
Byte5=Minute 0 - 59
Byte6=Sekunde 0 - 59
Byte7=Hundertstel sek. 0 - 100
Byte8=res.

Index [usw..]


TYP 4

Handbuch -> Archivserver -> Allgemein -> RDA - Real time Data Acquisition -> Typen Beschreibung -> TYP 4

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Index [5]

8 Byte langes Zeit Format -->
Byte1=Jahr 97,98,usw..
(HINWEIS: Das Zeitformat wird ab 1900 zweistelling verwendet, d.h. ab 2000 ergeben sich hier drei Stellen)
Byte2=Monat 1 - 12
Byte3=Tag 1 - 31
Byte4=Stunden 0 - 23
Byte5=Minute 0 - 59
Byte6=Sekunde 0 - 59
Byte7=Hundertstel sek. 0 - 100
Byte8=res.

Index [6]

Nutzdaten Anfang Größe je nach zenon Datentyp
z.B.: (BYTE ,WORD, DWORD, FLOAT)

Index [usw..]


Format der Archivdateien

Handbuch -> Archivserver -> Format der Archivdateien

Archive haben folgende Datenstruktur: Der Name eines Archives wird aus der Kurzbezeichnung, der Speicherzeit in UTC im Format JJMMTThhmmss sowie der Dateierweiterung ARX gebildet.

Die Archivdatei mit der Kennung ARX beinhaltet die Kanaldefinitionen und die numerischen Daten. Die ARS Datei beinhaltet die Stringdaten. Der Archivheader beinhaltet die Archivdefinitionen und eventuell den Wert der Chargenvariable. Der für den Wert der Chargenvariable reservierte Speicherplatz hängt, wenn die Chargenvariable eine Stringvariable ist von der Stringlänge ab, bei numerischen Variablen sind dies fix 32 Zeichen. Chargenstrings werden in Unicode abgelegt. Wenn keine Chargenvariable definiert ist, wird der Speicherplatz nicht reserviert.

Der Datenrecord in der ARX Datei hat nun eine Länge von 24 Byte und bietet auch die Möglichkeit double Werte abzulegen. Die Statusinformationen sind 64Bit.

Aufgrund der Dateibenennung können nun Archive im Abstand von 1sek abgelegt werden. Für zyklische Archive wird empfohlen Speicherzeiten > 30sek einzuhalten.

Wenn sich das Format der Archivdateien geändert hat, wird beim Start der Runtime geprüft, ob sich Archivdateien (wird erkannt durch die Dateierweiterung ARV) im Runtime-Verzeichnis befinden. Nach Bestätigung der Konvertierung werden die Dateien in das neue Format umgewandelt. Diese Konvertierung wird für sämtliche Projekte ausgeführt bevor die Projekte starten.

Folgende Datenstruktur: Der Name eines Archives wird aus der Kurzbezeichnung, der Speicherzeit in UTC im Format JJMMTThhmmss sowie der Dateierweiterung ARX gebildet. Die Zeitangabe der ARX Datei hängt von der Zeitzone ab, die in den Windows Einstellungen getätigt wurde.

Example Beispiel

A1070405071200.ARX

A1 | Name des Archivs
07 | Jahr
04 | Monat
05 | Tag
07 | Stunde (UTC)
12 | Minuten
00 | Sekunde

UTC Zeit und lokale Zeit

Archive benutzen beim Speichern UTC-Zeit.

Die lokale Zeit, die am Computer angesetzt wird, setzt sich zusammen aus: UTC + Zeitzone + Sommerzeit/Winterzeit.

Die zenon Runtime berücksichtigt bei Archivabfragen automatisch die lokale Zeit.

Zum Beispiel: Berlin im Sommer

Lokale Zeit: 14:00

UTC: 14:00 Uhr minus 1h Sommerzeit minus 1h Zeitzone = 12:00 Uhr

Der Wert, der lokal um 14:00 Uhr auftritt wird mit der Zeit 12:00 gespeichert.

Sie fragen in Berlin Werte zwischen 13:00 und 15:00 Uhr lokaler Zeit ab. Die Runtime fordert dann vom Archiv die Werte mit einem Zeitstempel zwischen 11:00 und 13:00 Uhr an und zeigt diese mit der lokalen Zeit (13:00 bis 15:00 Uhr) an.


Kaskadierung und Verdichtung

Handbuch -> Archivserver -> Kaskadierung und Verdichtung

Die Archivierung basiert auf dem Prinzip der Kaskadierung von Archiven, d. h., in einem Eingangsarchiv werden die gewünschten Variablen erfasst und über Verdichtungsfunktionen in ein Folgearchiv übernommen.

Dieser Vorgang lässt sich beliebig oft fortsetzen. Die Verdichtungsfunktion wird beim Beenden des Archivzykluses angestoßen. Als Verdichtungsfunktionen über den Archivierungszyklus pro Archivvariable stehen zur Verfügung:

  1. Summenbildung
  2. Mittelwert
  3. Minimum
  4. Maximum

In einem Projekt können auch mehrere Kaskaden parallel arbeiten.

attention Achtung

Strings können nicht verdichtet werden.

Es wird zwischen unterschiedlichen Arten der Archivierung unterschieden. Als Trigger für die Einträge in die Archive sind verfügbar:

Parameter | Beschreibung
zyklisch | Das Schreiben von Werten in das Archiv wird durch einen definierten fixen Zyklus ausgelöst.
ereignisgesteuert | Das Schreiben von Werten in das Archiv wird durch eine definierte Bit-Variable ausgelöst.
bei Wertänderung | Das Schreiben von Werten in das Archiv wird durch eine Wertänderung einer der verknüpften Variablen ausgelöst, d.h. die Anzahl der archivierten Werte ist von der Änderungshäufigkeit abhängig. Die Definition einer Hysterese an den Variablen kann die Häufigkeit herabsetzen.

attention Achtung

In einem Archiv vom Typ Bei Wertänderung werden Variablen auch bei jeder Statusänderung gespeichert.

Zum Beispiel: Wenn ein Treiber gestoppt wird, bekommen alle seine Variablen den Status OFF. Somit verursacht das Stoppen und Starten des Treibers 2 Einträge:

  • OFF
  • SPONT oder GI (bei erfolgreicher Wiederverbindung)

Das passiert auch, wenn sich der Variablenwert nicht ändert.

Zum Exportieren eines Archivzykluses bestehen mehrere Möglichkeiten.

Parameter | Beschreibung
Datenbank | Ringspeicher für jedes Archiv, in dem die definierte Anzahl von Archivzyklen gehalten wird; Nachbearbeitung der Archivdaten innerhalb des Rings; bei Überlauf des Ringspeichers Archiv wahlweise verwerfen oder auf Datei exportieren
Dateiexport | nach dem Schließen eines Archivzykluses wird dieser sofort in eine Datei exportiert
Exportfunktion | Der Archivexport, d.h. das Sichern von Archiven auf Dateien mit Zeitfilter erfolgt in Standarddateiformaten (ASCII, dBase, XML, SQL). Die Dateinamen werden vom System eigenständig vergeben. Der Aufbau (JJMMTThhmmss/XML) verschlüsselt den Exportzeitpunkt mit einer Kennung für Jahr, Monat, Tag, Stunde, Minute und Sekunde. Die Dateiablage kann sowohl lokal als auch bei Integration in ein Netzwerk auf einem Fileserver erfolgen.

Wenn sich das Format der Archivdateien geändert hat, wird beim Start der Runtime geprüft ob sich Archivdateien (wird erkannt durch die Dateierweiterung ARV) im RT-Verzeichnis befinden. Nach Bestätigung der Konvertierung werden die Dateien in das neue Format umgewandelt. Diese Konvertierung wird für sämtliche Projekte ausgeführt bevor die Projekte starten.

Die alten Archivdateien werden gelöscht. Es wird empfohlen zuvor eine Sicherung der Dateien zu erstellen.

SB und Server führen die Konvertierung parallel vor dem Dateiabgleich aus.


Projektieren im Editor

Handbuch -> Archivserver -> Projektieren im Editor

Sie finden das Modul Archivserver im Projektmanager. Legen Sie Archive an und verwalten Sie diese.

Noch in diesem Kapitel

Archive Detailansicht Kontextmenü

Neues Archiv anlegen

Archivspalten in der Detailansicht


Archive Detailansicht Kontextmenü

Handbuch -> Archivserver -> Projektieren im Editor -> Archive Detailansicht Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste Archivserver und Archive

Parameter | Beschreibung
Archiv neu | Öffnet den Assistenten zum Anlegen eines Archivs.
Folgearchiv neu | Öffnet den Assistenten zum Anlegen eines Folgearchivs.
Archiv bearbeiten | Öffnet den Dialog zur Bearbeitung des ausgewählten Archivs.
Variable hinzufügen | Öffnet den Dialog zur Auswahl der Variablen.
Variable entfernen | Löscht Variable ohne Sicherheitsabfrage aus der Liste.
Löschen | Löscht das ausgewählte Archiv.
Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
Selektierte XML exportieren | Exportiert ausgewählte Archive in XML-Datei.
XML importieren | Importiert XML-Dateien.
Archiv umbenennen | Ermöglicht es, den Archiv-Namen zu ändern.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Archivserver

Menüpunkt | Aktion
Archiv neu | Öffnet den Assistenten zur Erstellung eines neuen Archivs.
Speichern | Speichert geänderte neue und Archive.
XML exportieren alle | Exportiert alle Archive in XML-Datei.
Selektierte XML exportieren | Exportiert ausgewählte Archive in XML-Datei.
XML importieren | Importiert XML-Dateien.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Archiv

Menüpunkt | Aktion
Archiv bearbeiten | Öffnet den Dialog zur Bearbeitung des ausgewählten Archivs.
Variable hinzufügen | Öffnet den Dialog zur Auswahl der Variablen.
Folgearchiv neu | Öffnet den Assistenten zum Anlegen eines Folgearchivs.
Löschen | Löscht ausgewähltes Archiv
Selektierte XML exportieren | Exportiert ausgewählte Archive in XML-Datei.
XML importieren | Importiert XML-Dateien.
Umbenennen | Ermöglicht es, den Archiv-Namen zu ändern.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Variablenliste

Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl der Variablen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Variable

Menüpunkt | Aktion
Variable entfernen | Löscht Variable aus Liste. Achtung: es erfolgt keine Sicherheitsabfrage.


Neues Archiv anlegen

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Legen Sie ein neues Archiv an, in dem Sie zuerst im Projektmanager den Knoten Archivserver selektieren. Dann können Sie entweder mithilfe des entsprechenden Symbols in der Symbolleiste oder dem Kontextmenü Archive neu... ein neues Archiv anlegen.

Der Assistent zum Anlegen eines Archivs wird geöffnet (siehe Assistent). Wenn Sie das Archiv ohne Hilfe des Assistenten anlegen möchten, klicken Sie auf Abbrechen.

Im Dialog Neues Archiv nehmen Sie die Einstellungen für das neue Archiv vor. Der Dialog wird auch angezeigt, wenn Sie die Eigenschaften eines bestehenden Archivs bearbeiten möchten.

Noch in diesem Kapitel

Assistent

Eigenschaften

Runtime

Aufzeichnungsart

Speichern

Optionen


Assistent

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen -> Assistent

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Assistent unterstützt Sie bei der grundlegenden Projektierung eines Archivs. Er wird per Default geöffnet. Wenn Sie das Archiv ohne Hilfe des Assistenten projektieren wollen, klicken Sie auf Abbruch.

Wenn Sie ein neues Archiv anlegen oder ein Folgearchiv definieren bietet der Assistent seine Hilfe an und führt Sie Schritt für Schritt durch die Projektierung: Er fragt Name und Kurzbezeichnung des Archivs ab, ermöglicht die Auswahl von Variablen und die Einstellungen zur Abtastung der Variablenwerte.

1. Kurzbezeichnung und Name

Zunächst haben Sie die Möglichkeit, dem neuen Archiv einen Namen und eine Kurzbezeichnung zuzuweisen. Die Kurzbezeichnung ist im Nachhinein nicht mehr veränderbar. Der Name kann später geändert werden. Beide Eingaben müssen erfolgt sein, um fortzusetzen.

Hinweis: Die Kurzbezeichnung darf nur alphanumerische Zeichen enthalten: also alle Buchstaben von A bis Z, aber keine Umlaute oder Sonderzeichen sowie alle Ziffern von 0 bis 9.

2. Variablenauswahl

Klicken Sie auf den Button Variablenauswahl um in den Dialog zur Auswahl der Variablen, die archiviert werden sollen, zu gelangen.

3 . Aufzeichnungsart

Entscheiden Sie, welche Art der Aufzeichnung Sie wünschen. Siehe Abschnitt Aufzeichnungsart.

Parameter | Beschreibung
Zyklische Aufzeichnung | Stellen Sie anschließend die Zykluszeit ein.
Ereignisgesteuerte Aufzeichnung | Geben Sie eine Ereignisvariable an, indem Sie auf die Schaltfläche ... klicken.
Aufzeichnung bei Wertänderung | Hier sind keine weiteren Eingaben nötig.

info Info

Bei einem neuen Archiv, wird der Dialog zur Abtastung angezeigt, bei einem Folgearchiv nicht, da ein Folgearchiv immer eine spontane Abtastung hat.

Parameter | Beschreibung
Weiter | Blättert zur folgenden Seite des Assistenten.
Zurück | Blättert zur vorhergehenden Seite des Assistenten.
Fertigstellen | Beendet den Assistenten. Das neue Archiv wird in den Archivbaum (Detailansicht des Projektmanagers) eingetragen.
Abbrechen | Alle getroffenen Einstellungen werden verworfen. Kein Neues Archiv wird erstellt.

Speicherzyklus- das passiert im Hintergrund

Der Zyklus, in dem Archivdateien gespeichert und ausgelagert werden (Siehe Abschnitt Speichern), wird automatisch aus den eingegebenen Daten ermittelt. Es wird versucht, möglichst viele 'vernünftige' Werte für den Speicherzyklus zu finden, sodass die entstehenden Daten eine brauchbare Größe nicht überschreiten, aber gleichzeitig genügend Werte für die Verdichtung in Folgearchiven zur Verfügung stehen.

Der Speicherzyklus wird folgendermaßen berechnet: Bei Archiven mit spontaner und ereignisgesteuerter Abtastung wird der Speicherzyklus auf 2 Stunden gesetzt. Bei Archiven mit zyklischer Abtastung oder Folgearchiven (die zwar spontane Abtastung haben, aber trotzdem zyklische Werte aus dem jeweiligen Quellarchiv erhalten) wird der Speicherzyklus so gewählt, dass bei Archiven mit sehr vielen Variablen nach Möglichkeit je Archivdatei nicht (wesentlich) mehr als 65000 Variablen eingetragen werde, aber dennoch pro Variable mindestens 6 Werte erfasst werden. Somit stehen für das Folgearchiv ausreichend viele Werte zur Verfügung.

Werden im Archiv weniger Variablen erfasst, wird der Zyklus so gewählt, dass die Größe der Dateien 65000 Werte nicht überschreitet und der Zyklus einen möglichst 'runden' Wert hat (Ganzzahlige Vielfache von 1,5,10,30 oder 60 Minuten).

Der Aufbewahrungszeitpunkt wird auf 1 Jahr (ohne Auslagerung) gesetzt).

Der Zeitpunkt für den Beginn des Abtast- und des Speicherzyklus wird auf 00:00:00 Uhr am 1. Januar des laufenden Kalenderjahres festgesetzt.


Eigenschaften

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen -> Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der Registerkarte Eigenschaften stehen Ihnen die folgenden Einstellungen zur Verfügung.

Parameter

Beschreibung

Archivbezeichnung

Kennung

Zweistellige eindeutige Kennung des Archives.Wird für die automatische Namensvergabe bei Exportfunktionen benutzt.

Achtung: Sie können die Kennung nachträglich nicht mehr ändern.
Hinweis: Benutzen Sie für die Kennung nur alphanumerische Zeichen (A-Z und 0-9). Damit vermeiden Sie mögliche Probleme beim Export und der Auslagerung der Archive.

Archivname

Name für das zu erstellende Archiv.

Variablenauswahl

Fügen Sie über des Kontextmenü Variablen hinzu, die in diesem Archiv berücksichtigt werden sollen. Sie können Variablen aus allen Projekten, die sich im selben Arbeitsbereich befinden, zu Ihrem Archiv hinzufügen.

Hinweis: Redundanz wird nicht unterstützt. Dies kann zu Datenverlust führen. Beachten Sie dies bei der Erstellung Ihrer Archive.

Chargen

Chargenvariable

Variable vom Typ String. Der Wert der Variablen wird als Chargenname verwendet. Ein Linksklick auf die Schaltfläche öffnet eine Dialog, in dem Sie die gewünschte Variable selektieren.

Hinweis: Der Wert der Variable wird als Chargenname verwendet. Während das Archiv aktiv ist kann sich der Wert der Variablen und somit auch der Chargenname ändern. Beachten Sie dies bei der Filterung.
Als endgültiger Chargenname wird der Wert der Variablen beim Beenden des Archivs verwendet.

Chargen indizieren

Wenn Sie diese Checkbox aktivieren, wird eine automatische Indizierung der Chargenwerte für dieses Archiv ausgeführt. Damit ist ein schneller Zugriff auf die Chargenwerte möglich.

Anlagenmodelierung

Anlagengruppen

Definieren Sie die Zugehörigkeit zu einer Anlagengruppe. Ein Linksklick auf die Schaltfläche öffnet eine Dialog, in dem Sie die gewünschte Anlagengruppe selektieren.

info Info

Archive können Variablen aus unterlagerten Projekten archivieren. Variablen aus unterlagerten Projekten sind am Variablennamen erkennbar, der den Projektnamen beinhaltet.

Bei der Chargenvariable (Chargenarchivierung) und bei der Ereignisvariable können auch Variablen aus unterlagerten Projekten verwendet werden.


Runtime

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen -> Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der Registerkarte Runtime stehen Ihnen die folgenden Einstellungen zur Verfügung.

Parameter | Beschreibung
Starten und Beenden |
Beim Start und Ende der Runtime | Das Archiv wird automatisch mit der Runtime gestartet und beendet. Hinweis: Wenn Sie diese Einstellung selektieren, vermeiden Sie das Archiv über Funktionen zu stoppen oder zu starten. Dies kann zu unerwünschten Verhalten der Runtime führen.
Benutzerdefiniert (z.B. über Funktionen) | Das Archiv wird mithilfe der Funktionen Archiv starten und Archiv beenden gestartet bzw. gestoppt.
RDA Blockarchiv | Die Verwaltung des Archivs geschieht über RDA.
Funktion ausführen bei |
Archivstart | Definieren Sie eine Funktion, die beim Start des Archives ausgeführt werden soll.
Archivende | Definieren Sie eine Funktion, die beim Beenden des Archives ausgeführt werden soll.
Start der Archivierung |
Datum/Zeit | Definition des Startzeitpunkts für den Abtast- und Speicherzyklus. Der eingestellten Zeitpunkt betrifft nicht die erste Abtastung, sondern definiert den ersten Speicherzeitpunkt der Dateien, die archiviert werden sollen.

Example Beispiel

Es gibt den Abtast - und Speicherzyklus (ASZ) und den Abtastzyklus (AZ). Diese beiden Zyklen sind nicht zu verwechseln.

Die Ermittlung des Zeitpunktes vom ersten Wert (EZW) durch ein Rundung des Abtast - und Speicherzyklus auf den Abtastzyklus. Durch die Implementierung dieser Funktionalität ergeben sich einige besondere, nicht immer leicht durchschaubare, Fälle:

Die Rundung des Abtast - und Speicherzyklus auf den ersten Abtastzyklus erfolgt Stunden mit Stunden, Minuten mit Minuten und Sekunden mit Sekunden. Das heißt: Ist die zu rundende Stelle (H:M:S) des Abtast - und Speicherzyklus kleiner als der des Abtastzyklus, ist dieser immer 0!

Wenn der Abtastzyklus ein Tag ist, wird der Abtast - und Speicherzyklus immer mit 0:0:0 Uhr angenommen -> Aufzeichnung beginnt mit 0 Uhr.

Bei monatlicher Abtastzyklus wird immer am 1. des Monats aufgezeichnet um 00:00:00.

Einige Beispiele:

ASZ: Abtast - und Speicherzyklus
EZW: Zeitpunkt erster Wert
ASZr: Abtast - und Speicherzyklus gerundet
AZ: Abtastzyklus

ASZ: XX:XX:XX AZ: 1T 00:00:00 -> EZW 00:00:00; ASZr 00:00:00 + AZ 00:00:00 = EZW 00:00.00

ASZ: 00:01:00 AZ: 0T 23:59:00 ->EZW 23:59:00; ASZr 00:00:00 + AZ 23:59:00 = EZW 23:59:00

ASZ: 00:30:00 AZ: 0T 00:30:00 ->EZW 01:00:00; ASZr 00:30:00 + AZ 00:30:00 = EZW 01:00:00

ASZ: 00:30:00 AZ: 0T 00:29:00 ->EZW 00:58:00; ASZr 00:29:00 + AZ 00:29:00 = EZW 00:58:00

ASZ: 00:30:00 AZ: 0T 00:05:00 ->EZW 00:35:00; ASZr 00:30:00 + AZ 00:05:00 = EZW 00:35:00

ASZ: 00:29:00 AZ: 0T 00:05:00 ->EZW 00:30:00; ASZr 00:25:00 + AZ 00:05:00 = EZW 00:30:00

ASZ: 00:00:00 AZ: 2T 00:00:00 ->EZW 00:30:00; ASZr 00:00:00 + AZ 2T 00:00:00 = EZW 3. 00:00:00

Jedes neue Archiv beginnt wieder mit dem EZW, entsprechend der oben beschriebenen Berechnung. Der Aufzeichnungszyklus läuft nicht über Archive hinweg, d.h. wenn der Abtastzyklus nicht ganzzahlig im Abtast- und Speicherzyklus enthalten ist, wird beim Archivwechsel ein Loch in der Aufzeichnung erzeugt.


Aufzeichnungsart

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen -> Aufzeichnungsart

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der Registerkarte Aufzeichnungsart stehen Ihnen die folgenden Einstellungen zur Verfügung.

Parameter | Beschreibung
Zyklisch |
Zyklische Aufzeichnung | Aktivieren Sie dieses Optionsfeld, wenn Sie eine zyklische Erfassung der Archivdaten möchten. Definieren Sie anschließend den Zyklus.
Zykluszeit | Definieren Sie in welchem Zyklus (Tage, Stunden, Minuten und Sekunden) Werte vom System eingelesen werden sollen.
Monatlich | Einlesen der Werte erfolgt bei jedem Monatswechsel.
Offset | Definieren Sie, wie lange das Archiv auf die angeforderten Werte warten soll. Der Offset hat keinen Einfluss auf den Zeitstempel der Werte. Er wird hauptsächlich bei langsamen Treibern benötigt. Hinweis: Beachten Sie, dass der Offset immer kleiner als die Zykluszeit sein muss.
Ereignisgesteuert |
Ereignisgesteuerte Aufzeichnung | Aktivieren Sie dieses Optionsfeld, wenn Sie eine ereignisgesteuerte Erfassung der Archivdaten möchten.
Triggervariable | Definieren Sie die Variable, die das Einlesen der Werte auslösen soll. Das Einlesen wird durch die Flankenänderung (0->1) der Triggervariablen ausgelöst.
Zeitstempel wird übernommen von | Mithilfe der beiden Optionsfelder definieren Sie, ob die Triggervariable oder die Archivvariable für den Zeitstempel verwendet wird.
Bei Wertänderung |
Aufzeichnung bei Wertänderung | Wenn Sie dieses Optionsfeld aktivieren, werden Variablen nur bei eigener spontaner Wertänderung ins Archiv geschrieben. Für den Messbereich kann eine Hysterese festgelegt werden (siehe Kapitel Hysterese im Handbuch Variablen).
Prozessabbild beim Start speichern | Beim Anlegen einer neuen Archiv-Datei werden die aktuellen Werte der Variablen eingetragen.
Prozessabbild beim Beenden speichern | Beim Schließen einer Archiv-Datei werden die aktuellen Werte der Variablen eingetragen. Wird eine Variable das erste mal gelesen (etwa beim Start der Runtime oder wenn sich ein Standby-Server zum Server hochstuft) kann ein Initialisierungswert eingetragen werden.
Ereignisgesteuert/Bei Wertänderung |
Initialisierungswert ignorieren | Aktivieren Sie diese Checkbox, wenn Sie möchten, dass der Initialisierungswert beim Archiv nicht berücksichtigt wird.


Speichern

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen -> Speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können die Archivinhalte mithilfe des Erweiterter Trend, des Report Generator oder des Bildtyps Archivnachbearbeitung weiterverarbeiten. Definieren Sie das Speicherverhalten jedes Archives, um das Archiv später bearbeiten zu können.

Hier werden die Speicherbedingungen für das Archiv festgelegt.

attention Achtung

Beim Ändern der Speicherart oder des Zykluses wird das aktuelle Alpha-Archiv, d.h. die Archivdatei, die gerade von zenon beschrieben wird, gelöscht.

Auf der Registerkarte Speichern stehen Ihnen die folgenden Einstellungen zur Verfügung.

Parameter

Beschreibung

Speicherformat

Interne Datenbank (*.arx)

Daten stehen für die Nachbearbeitung und Auswertung in einem Ring (FIFO) zur Verfügung; Daten werden hinter dem Projektpfad abgelegt (.../Projektpfad /Rechner /Projektname) und erst beim Ausreihen in den Exportpfad verschoben.

dBase (*.dbf)

Beim Beenden des Archivs werden die Daten sofort in eine *.dbf-Datei ausgelagern.

(Achtung: keine Nachbearbeitung, Protokollerstellung und Liniengrafik für ausgelagerte Archive mehr möglich!)

CSV (*.txt)

Beim Beenden des Archivs werden die Daten sofort in eine *.txt-Datei ausgelagert.

(Achtung: keine Nachbearbeitung, Protokollerstellung und Liniengrafik für ausgelagerte Archive möglich!)

Als Unicode speichern

Wenn Sie diese Checkbox aktivieren, wird die txt-Datei als Unicode gespeichert.

XML (*.xml)

Beim Beenden des Archivs werden die Daten sofort in eine *.xml-Datei ausgelagert.

(Achtung: keine Nachbearbeitung, Protokollerstellung und Liniengrafik für ausgelagerte Archive möglich!)

Speicherzyklus

Zyklus

Aktivieren Sie dieses Optionsfeld, um anschließend die Länge der einzelnen Archive in Tag, Stunden, Minuten, Sekunden festzulegen. Die Länge der Archive hat Auswirkung auf die Dateigröße und Anzahl der Archivdateien und bestimmt den Zyklus für Folgearchive.

Tage

Definieren Sie den Speicherzyklus des Archivs.

Stunden

Definieren Sie den Speicherzyklus des Archivs.

Minuten

Definieren Sie den Speicherzyklus des Archivs.

Sekunden

Definieren Sie den Speicherzyklus des Archivs.

Monatswechsel

Aktivieren Sie dieses Optionsfeld, um das Archiv bei jedem Monatswechsel zu speichern. (Monatsarchive.)

Jahreswechsel

Aktivieren Sie dieses Optionsfeld, um das Archiv bei jedem Jahreswechsel zu speichern. (Jahresarchive)

Auslagerung

Aufbewahrungsdauer

Definieren Sie die Aufbewahrungsdauer des Archivs in entweder Stunden, Tage, Monate oder Jahren.
Beachten Sie das die Aufbewahrungsdauer direkt mit dem Speicherzyklus zusammenhängt. Maximal können 65535 Archive aufbewahrt werden.

Beispiel: Zyklus 1 Sekunde -> maximal Aufbewahrungsdauer 18 Stunden. Zyklus 1 Minute -> maximale Aufbewahrungsdauer 1092 Stunden bzw. 45 Tage bzw. 1 Monat.

Auslagerung nach Ausbewahrungsdauer

Nicht auslagern (Archive werden gelöscht)

Aktivieren Sie dieses Optionsfeld, wenn die Archive nach der Aufbewahrungsdauer gelöscht werden sollen.

Interne Datenbank (*.arx)

Wenn Sie dieses Optionsfeld aktivieren, werden die Archive im internen Datenbankformat *.arx ausgelagert. ARX-Dateien können in zenon wieder gelesen und geschrieben werden.

SQL-Datenbank

Wenn Sie dieses Optionsfeld aktivieren, werden die Archive in eine SQL-Datenbank ausgelagert. Definieren Sie die gewünschte SQL-Datenbank, indem Sie auf ... klicken.
Achtung: In SQL ausgelagerte Archive können in zenon nur gelesen werden.

Tabellen anlegen

Klicken Sie auf diese Schaltfläche, um die benötigten Tabellen in SQL anzulegen oder gegebenenfalls zu aktualisieren.

XML (*.xml)

Wenn Sie dieses Optionsfeld aktivieren, werden die Archive im XML-Format ausgelagert.

CSV (*.txt)

Wenn Sie dieses Optionsfeld aktivieren, werden die Archive im TXT-Format ausgelagert.

Als Unicode exportieren

Aktivieren Sie diese Checkbox, um die ausgelagerte TXT-Datei als Unicode zu speichern.

dBase (*.dbf)

Wenn Sie dieses Optionsfeld aktivieren, werden die Archive im DBF-Format gespeichert.

Exportierte Spalten für CSV/dBase Auslagerung: V-Variablenname, I-Kennung, W-Wert, S-Status, D-Datum, Z-Zeit

Bei den beiden Auslagerungsoptionen dBase und CSV haben Sie die Möglichkeit, einige Parameter der archivierten Variablen mit auszulagern.
Tragen Sie in das Textfeld die Buchstaben der Parameter ein, die Sie auslagern möchten.
V = Variablenname
I = Variablenkennung
W = Wert
S = Status
D = Datum
Z = Zeit
Als default-Wert sind alle Parameter selektiert.

Die Projektierung des Spaltentrennzeichens (bei ASCII-Export) und der Nachkommastellen erfolgt in der Datei project.ini.

Parameter | Beschreibung
[ARCHIV] |
TRENNZEICHEN=, | Angabe der möglichen Trennzeichen

Die Dateinamen der zu exportierenden Archive werden wie folgt vergeben:

Parameter | Beschreibung
nnJJMMTThhmmss.xxx | Dateiname
- nn | Archivkurzbezeichnung laut Definition
- jj | Jahreskennung (z.B. 05 für 2005)
- mm | Monatskennung (z.B. 03 für März)
- tt | Tageskennung
- hh | Stunden in UTC/GMT Zeit
- mm | Minutenkennung 00..59
- ss | Sekundenkennung 00..59
- xxx | Dateiformat (DBF, TXT)

attention Achtung

Bei benutzerdefinierten Starten und Beenden der Archive:

Eine Einstellung in der Sektion Zyklus ist nicht nötig, da das Starten und Beenden der Archivdateien von Hand (d.h. über Funktionen) gesteuert wird. Daher wird dieser Wert auch ignoriert, so fern die Länge der Dateien betroffen ist.

Allerdings hat dieser Wert Einfluss darauf, wie viele Archiv-Dateien aufbewahrt werden sollen. Die unterschiedliche tatsächliche Länge der Archiv-Dateien wird nämlich hier nicht berücksichtigt. Tatsächlich rechnet sich zenon die Anzahl der aufzubewahrenden Archiv-Dateien folgendermaßen aus:

Beispiel: 5 Stunden ( Archive aufbewahren ) / 15 Minuten ( Zyklus ) = 20 aufzubewahrende Archiv-Dateien

Noch in diesem Kapitel

Archive auslagern


Archive auslagern

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen -> Speichern -> Archive auslagern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der Registerkarte Speichern legen Sie fest, wie Sie abgeschlossene Archive auslagern. Dafür haben Sie mehrere Möglichkeiten.

  • Nicht auslagern (Archive werden gelöscht)
  • Interne Datenbank (*.arx)
  • SQL Datenbank

Nicht auslagern (Archive werden gelöscht)

Die ältesten Archive werden gelöscht.

attention Achtung

Wird in der Eigenschaft Archive aufbewahren der Wert 0 eingetragen, so wird kein Archiv gespeichert. Es existiert jeweils nur das aktuell laufende Archiv.

Interne Datenbank (*.arx)

Wenn die Anzahl der aufzubewahrenden Archiv-Dateien erreicht wurde, werden die ältesten Archive im ARX-Format gespeichert. Diese Datei kann später in zenon wieder importiert werden und dort dann sowohl gelesen als auch beschrieben werden.

SQL Datenbank

Wenn die Anzahl der aufzubewahrenden Archiv-Dateien erreicht wurde, werden die ältesten Archive im SQL-Server gespeichert.
Die Auslagerung in eine SQL-Datenbank bietet den Vorteil, dass die Archivdaten auch nach der Auslagerung noch in zenon für Trends und Reports zur Verfügung stehen.
Um die Daten eines Archivs in einer SQL-Datenbank abzulegen:

  1. wählen Sie in der Registerkarte Speichern die Eigenschaft SQL-Datenbank
  2. klicken Sie auf die Schaltfläche ..., um den Dialog zur Datenbankwahl zu öffnen
  3. klicken Sie auf die Schaltfläche Tabellen anlegen, um Tabellen zu erzeugen

    Über die Schaltfläche Tabellen anlegen können die Tabellen jederzeit neu erzeugt oder automatisch angepasst werden, wenn z.B. Variablen dem Archiv hinzugefügt oder entfernt werden oder der Providerstring händisch angepasst wird.

    Wenn Sie ein Archive für die Auslagerung nach SQL konfigurieren und das Archive zu einem späteren Zeitpunkt neu konfigurieren, müssen Sie auch die Tabellen in SQL entsprechende anpassen.
    Beispiel:
    Wenn Sie ein Archiv für die Auslagerung nach SQL konfiguriert haben, die Tabellen in SQL bereits erstellt wurden und Sie dann eine Variable zur Chargenarchivierung verknüpfen, müssen die Tabellen in SQL neu erstellt werden, da sonst die Auslagerung nach SQL nicht durchgeführt werden kann. Die Tabelle für die Chargeninformation ist nicht vorhanden. In diesem Fall wird eine Meldung in die CEL und den Dignose Verver geschrieben, dass das Archiv nicht ausgelagert werden konnte.

    Jedesmal wenn Sie bei Archiven, die für SQL Auslagerung konfiguriert sind, Variablen hinzufügen oder entfernen, müssen die Tabellen in SQL aktualisiert werden.

info Info

Genauere Informationen entnehmen Sie bitte der Microsoft-Dokumentation.

In einer SQL-Datenbank ausgelagerte Archive werden im Gegensatz zu dBase, ASCII oder XML bei Bedarf (etwa ETM) automatisch wieder eingelesen.
Die Schaltfläche ... öffnet den Microsoft Dialog zur Auswahl des OLEDB Providers und der Definition der Verbindung.

Format der Datenbanktabelle: Projektname_Kurzbezeichnung

Spalte

Typ

Bedeutung

VARIABLE

int[4]

numerische Variablen-ID

CALCULATION

int[4]

Verdichtungsart bei Folgearchiven.

Bis zu 4 Werte sind möglich: Summe, Mittelwert, Minimum, Maximum.
Beim Export des Folgearchivs in eine Datei (zum Beispiel .csv) werden die Werte 1 bis 4 als Strings geschrieben:

  • 1=Summe
  • 2=Mittelwert
  • 3=Minimum
  • 4=Maximum

Bei Auslagerung oder Export nach SQL werden die Werte im ASCII-Code als Integer geschrieben:

  • 49=Summe
  • 50=Mittelwert
  • 51=Minimum
  • 52=Maximum

TIMESTAMP_S

int[4]

Zeitstempel in UNIX-Zeitformat

TIMESTAMP_MS

int[4]

Millisekundenanteil des Zeitstempels

VALUE

float[8]

Wert

STATUS

int[4]

Statusflags zum Wert (zenon Status)

GUID

char[36]

Nimmt die Projekt-Guid der Variable aus einem fremden Projekt auf oder ist NULL wenn die Variable aus dem eigenen Projekt.

STRVALUE

varchar

Die Länge hängt von der längsten zu archivierenden Stringvariable ab. Bei einer numerischen Variable hat das Feld den Wert NULL.

Der Name der Datenbanktabelle Projektname_VARIABLES setzt sich aus dem Projektnamen und der Archiv-Kurzbezeichnung zusammen. Beide Teile werden mit dem Unterstreichungszeichen verbunden. Ist der Projektname also ARV_IN_DB und die Archivkurzbezeichnung A1, so lautet der Tabellenname ARV_IN_DB_A1.

Tabelle Chargenname

Die Tabelle mit den Chargennamen für SQL ausgelagerte Archive:

  • hat den Namen [Projektname]_[Archivkürzel]_BATCH
  • besteht aus 3 Spalten:
SPalte | Typ | Bedeutung
BATCH | varchar (128) | Chargenname
START_S | int | Unix-Zeitstempel des Chargenanfangs
END_S | int | Unix-Zeitstempel des Chargenendes

Format der Querverweistabelle

Spalte | Typ | Bedeutung
VARIABLE | int[4] | numerische Variablen-ID
NAME | varchar[128] | Name der Variable
GUID | Char[36] | Nimmt die Projekt-Guid der Variable aus einem fremden Projekt auf oder ist NULL wenn im eigenen Projekt.

Der Name der Querverweistabelle setzt sich aus dem Projektnamen und der Endung VARIABLES zusammen. Beide Teile werden mit dem Unterstreichungszeichen verbunden. Ist der Projektname also ARV_IN_DB, so lautet der Tabellenname ARV_IN_DB_VARIABLES.

Die Spalten GUID und STRVALUE müssen entweder in der SQL Datenbank manuell hinzugefügt werden, oder Sie werden vom Editor aus hinzugefügt. Im Editor müssen Sie bei allen betroffenen Archiven auf die Registerkarte Speichern wechseln. Dort öffnen Sie in den Verbindungsstring zur Datenbank, und bestätigen den Dialog. Beim Schließen des Dialoges werden die Änderungen in der Datenbank durchgeführt.

attention Achtung

Wenn Sie diese Änderungen nicht durchführen, werden keine Archivdaten in die SQL Datenbank ausgelagert!
  • XML (*.XML): Wenn die Anzahl der aufzubewahrenden Archiv-Dateien erreicht wurde, werden die ältesten Archive im XML-Format gespeichert.
  • CSV (*.txt): Wenn die Anzahl der aufzubewahrenden Archiv-Dateien erreicht wurde, werden die ältesten Archive im CSV-Format in einer TXT-Datei gespeichert.
    Wenn Sie die Checkbox Als Unicode exportieren aktivieren, wird die ausgelagerte TXT-Datei im Unicode gespeichert.
  • dBase (*.dbf): Wenn die Anzahl der aufzubewahrenden Archiv-Dateien erreicht wurde, werden die ältesten Archive im DBF-Format gespeichert.


Optionen

Handbuch -> Archivserver -> Projektieren im Editor -> Neues Archiv anlegen -> Optionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der Registerkarte Optionen stehen Ihnen die folgenden Einstellungen zur Verfügung.

Parameter

Beschreibung

Berechnung im Folgearchiv

Werte in Folgearchivberechnung nur übernehmen, wenn folgender Statusfilter zutrifft

Selektieren Sie diese Checkbox, wenn Sie für die Berechnung der Werte von Folgearchiven Statusbits berücksichtigen möchten.

Die zusätzlichen Status werden

  • im Archiveditor angezeigt
  • beim Report angezeigt und können auch gesetzt werden

Definition der Status siehe im Kapitel Statusverarbeitung
Hinweis: Wenn Sie die Checkbox aktivieren, müssen Sie mindestens ein Statusbit selektieren.

Zeitstempel in Folgearchiven setzten

Zeitstempel des Minimal-/Maximalwertes

Aktivieren Sie dieses Optionsfeld, wenn Sie als Zeitstempel den des gefundenen Minimal-/Maximalwertes verwenden möchten.

Zeitstempel der Berechnung

Aktivieren Sie dieses Optionsfeld, wenn Sie als Zeitstempel den der Berechnung verwenden möchten.

Ersatzarchiv

Ersatzarchive erstellen

Aktiv: Fehlende Archivdateien bei nicht aktiver Runtime werden beim nächsten Start der Runtime erstellt.
Hinweis: Dazu muss die zyklische Aufzeichnung ausgewählt sein.

Inaktiv: Nur der aktuelle Zyklus wird aufgefüllt.

Erstellen eines Statusfilters

Durch Klick auf die Checkbox neben jedem angezeigten Status, können Sie für jeden Wert des Archivs entscheiden, ob er für das Folgearchiv herangezogen wird.

Example Beispiel

Im Folgearchiv sollen nur die Werte berücksichtigt werden, bei denen das Bit NORM gesetzt ist und bei denen INVALID nicht gesetzt ist.

Dazu setzten Sie bei NORM eine grüne 1 und bei INVALID eine rote 1. Die Checkboxen aller anderen Bits bleiben grau.

Sie können gesetzte oder ungesetzte Bits also explizit einschließen oder ausschließen.

info Info

Nicht alle bei der Aufzeichnung gesetzten Statusbits werden auch visualisiert. Nicht visualisierte Bits sind:

  • T_EXTERN (Statusbit 21)
  • T_INTERN (Statusbit 22)
  • INFO (Statusbit 26)
  • RES28 (Statusbits 28)
  • RES31 (Statusbits 31)
  • WR_ACK (Statusbit 40)
  • WR_SUC (Statusbit 41)
  • COT0 (Statusbit 32) bis COT5 (Statusbit 37)
  • T_STD (Statusbit 30)

Nicht visualisierte Statusbits werden:

  • beim Speichern als TXT-Datei oder als XML nicht geschrieben
  • beim Ausdrucken nicht gedruckt
  • beim Rezeptgruppen-Manager nicht angezeigt

Eine Übersicht über alle Statusbits finden Sie im Kapitel Statusbits


Archivspalten in der Detailansicht

Handbuch -> Archivserver -> Projektieren im Editor -> Archivspalten in der Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das neu angelegte Archiv wird in der Detailansicht angezeigt. Folgende Spalten werden per Default angezeigt:

Archive

Starten, beenden

Beginn

Abtastung

Auslagern

Chargen

Anzahl

geschätzte Größe

Diese Spalten sind statisch und können nicht gelöscht werden.

Noch in diesem Kapitel

Inkrementelles Suchen


Inkrementelles Suchen

Handbuch -> Archivserver -> Projektieren im Editor -> Archivspalten in der Detailansicht -> Inkrementelles Suchen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Inkrementelle Suche zu starten, klicken Sie in der Detailansicht auf eine Spaltenüberschrift. Die selektierte Spalte wird durch das 'Fernglas'-Icon markiert. Sie können den Suchbegriff eingeben und der Editor springt auf den passenden Eintrag.


Folgearchive definieren

Handbuch -> Archivserver -> Folgearchive definieren

Selektieren Sie das Archiv, von dem Sie ein Folgearchiv anlegen möchten und klicken Sie anschließend auf das Symbol für Folgearchiv neu in der Menüleiste. Sie können auch im Kontextmenü den Eintrag Folgearchiv neu selektieren und so mit der Definition für das Folgearchiv beginnen.
Wie auch beim Anlegen eines Archivs, begleitet Sie ein Assistent bei der Erstellung des Folgearchivs.

Noch in diesem Kapitel

Archiv- und Variablenauswahl für Folgearchiv


Archiv- und Variablenauswahl für Folgearchiv

Handbuch -> Archivserver -> Folgearchive definieren -> Archiv- und Variablenauswahl für Folgearchiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die folgenden Eigenschaften stehen Ihnen zur Verfügung.

Parameter | Beschreibung
Verfügbare Archive | Wählen Sie aus den verfügbaren Archive die Variablen aus, die im Folgearchiv berücksichtigt werden sollen. Mehrfachauswahl mit Strg oder Umschalt.
Summe | Aktivieren Sie diese Checkbox, wenn Sie die Addierung der Werte der ausgewählten Variablen in Abhängigkeit vom Speicherzyklus wünschen.
Mittelwert | Aktivieren Sie diese Checkbox, wenn Sie den Mittelwert der Werte der ausgewählten Variablen bilden möchten.
Minimum | Aktivieren Sie diese Checkbox für die Minimumermittlung pro ausgewählter Variable.
Maximum | Aktivieren Sie diese Checkbox für die Maximumermittlung pro ausgewählter Variable.

Die ausgewählten Variablen und die entsprechenden Datenverdichtungsarten werden in der Detailansicht der Archive angezeigt. Hier können Spalten hinzugefügt oder entfernt werden.

Zusätzliche Variablen können auch direkt hier mittels Drag and Drop in ein Folgearchiv eingefügt werden. Entweder einzelne Variablen werden aus der Variablenliste des Basisarchivs selektiert und dann mit gedrückter linker Maustaste auf die gewünschte Datenverdichtungsart eines zugehörigen Folgearchivs gezogen, oder man zieht das gesamte Basisarchiv auf eine Datenverdichtungsart, wobei alle seine Variablen zugeordnet werden.

Folgearchive werden von zenon automatisch auf die Archivierungsart bei Wertänderung gesetzt. Die Archivierungsart kann nicht geändert werden. Die Abtastrate ergibt sich aus der Länge des zugehörigen Basisarchivs. Die Werte der Variablen werden immer dann ins Folgearchiv eingetragen, wenn das Basisarchiv beendet wird. Alle Einträge des Basisarchivs werden standardmäßig zur Berechnung herangezogen (d.h. auch INVALID-Einträge und Handwerte), wenn nicht in der Definition des Basisarchivs unter Optionen anders eingestellt.


Chargenarchivierung

Handbuch -> Archivserver -> Chargenarchivierung

Die Chargenarchivierung ermöglicht Ihnen, die Zuordnung von Chargenbezeichnungen zu einem Archiv leicht durchzuführen. Mithilfe der Chargenbezeichnungen können Sie bei der Weiterverarbeitung der Archivdaten z.B. im Erweiterten Trend oder im Report Generator beliebig filtern.

Zum schnelleren Zugriff auf die Chargenwerte im Chargenfilter wird nun ein Index dieser Daten pro Archiv aufgebaut. Um die automatische Indizierung zu veranlassen ist die Checkbox Chargen indizieren zu aktivieren. Der Index wird in der Datei <Kurzbezeichnung>.ARI abgelegt. Wenn ein Chargenarchiv gespeichert wird, erfolgt auch ein Eintrag in die Indexdatei. Bei Auslagerung wird dieser Index ebenfalls aktualisiert.

Für die Auslagerung im ARX-Format wurde die zusätzliche Option internes Format geschaffen.

Werden Archive mit Dateioperationen gelöscht, so ist eine Reindizierung mit der neuen Funktion Archiv indizieren anzustoßen.

Der Index wird nur von Archivdateien im RT-Verzeichnis erstellt. Wenn vom Backupverzeichnis gelesen wird, wird nach wie vor Archivdatei für Archivdatei eingelesen.

Mittels der Funktion Archiv indizieren kann die Neuerstellung des Chargenindex für ein Archiv veranlasst werden. Der Aufbau der Indexdatei kann je nach Umfang der Archivdateien ein zeitaufwendiger Vorgang sein. Damit die Runtime nicht blockiert wird, erfolgt dieser Aufbau im Hintergrund. Wenn die Reindizierung noch nicht abgeschlossen ist, jedoch bereits Chargenwerte benötigt werden, muss diese Anfrage warten bis der Vorgang fertig ist. Mit der Einstellung synchron Ausführen wird bei der Funktionsausführung gewartet bis die Reindizierung fertig ist.

Noch in diesem Kapitel

Projektierung des Chargenfilters


Projektierung des Chargenfilters

Handbuch -> Archivserver -> Chargenarchivierung -> Projektierung des Chargenfilters

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Verwendung eines Chargenfilters wird in vielen Funktionen genutzt (Bildumschaltung, Export, Drucken, etc.) und soll hier zentral dargestellt werden.

Projektierbare Eigenschaften sind:

Parameter

Beschreibung

Filter auf Chargen aktiv

Aktivieren des Chargenfilters
Dieser Eintrag muss aktiviert sein, um die Archiv und Protokoll Funktionen batch und batchnr verwenden zu können.

Charge

Chargenname auf den gefiltert werden soll.
*: alle Chargen im Zeitbereich
Charge1|Charge2: Liste von Chargen

Letzte abgeschlossene Chargen

Die letzten X abgeschlossenen Archive werden angezeigt.

Diese Einstellung funktioniert nur für Archive, aber nicht für AML und CEL.

Voraussetzung für diese Einstellung: Filtern auf Chargen aktiv wurde aktiviert.

Zeitgrenzen

Definiert Zeitgrenzen für die Übernahme von Chargen.
  • Außerhalb

Chargen die teilweise im Zeitbereich liegen werden voll in die Auswertung übernommen
  • Innerhalb

Chargen die teilweise im Zeitbereich liegen werden nicht in die Auswertung übernommen
  • Von Außerhalb

Charge die teilweise am Beginn der Zeitgrenze liegt, wird voll in die Auswertung übernommen; Charge die teilweise am Ende der Zeitgrenze liegt, wird nicht in die Auswertung übernommen.
  • Bis Außerhalb

Charge die teilweise am Beginn der Zeitgrenze liegt, wird nicht in die Auswertung übernommen; Charge die teilweise am Ende der Zeitgrenze liegt, wird voll in die Auswertung übernommen.
  • Abschneiden

Variablen von Chargen die teilweise im Zeitbereich liegen werden in die Auswertung übernommen, wenn die Variablen im eingestellten Zeitbereich liegen.

Siehe auch Kapitel Erweiterter Trend, Report Generator und Kapitel Bildtyp Archivnachbearbeitung.


Strings archivieren

Handbuch -> Archivserver -> Strings archivieren

Stringvariablen können archiviert werden. Diese werden in eine Datei mit dem Namen <Kurzbezeichnung><Zeit>.AVS abgelegt.

Diese Datei beinhaltet nur die Daten der Strings und bildet eine logische Einheit mit der ARX-Datei. In der ARX-Datei ist vermerkt ob ein Stringarchiv vorhanden sein muss.

info Info

Wenn keine Strings im Archiv archiviert werden, wird kein ARS-Archiv erstellt.

Dateioperationen müssen somit beide Dateien berücksichtigen. Fehlt die ARS-Datei so werden auch die Daten aus der ARX-Datei nicht geladen.

Die Stringdaten werden in Unicode, mit dynamischer Datenlänge abgelegt. Dies geschieht um Speicherplatz zu sparen und ist unabhängig von der definierten Stringlänge. Im Datenrecord der ARX-Datei wird die Position des String-Record in der ARS-Datei vermerkt. Annahmen, wo sich Strings im ARS-Archiv befinden, sind nicht zulässig, da sie sich durch editieren in ihrer Position verändern.

Bei den Variablenproperties wurde ein Ersatzwert für Strings eingeführt, um das Archiv immer mit Werten versorgen zu können. Der String-Ersatzwert wird verwendet, wenn das Leitsystem (z.B zum Auffüllen von zyklischen Archiven) einen Wert für die String-Variable benötigt, aber kein Wert vorhanden ist. Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der der zuletzt gültige Wert.

Im Editor wird bei der Größenermittlung für Archive immer davon ausgegangen, dass der String mit der maximalen Stringlänge archiviert wird.

attention Achtung

Ändert sich die Länge einer zu archivierenden Stringvariable, so muss dieses Datenfeld angepasst werden!

Die Anpassung kann entweder manuell mit einen Datenbankadministrationswerkzeug erfolgen (z.B. Enterprise Manager für MS-SQL Server), oder mittels der Archivprojektierung. Im Editor muß bei allen betroffenen Archiven auf die Registerkarte Speichern gewechselt, derVerbindungsstring zur Datenbank geöffnet und der Dialog bestätigt werden. Beim Schließen des Dialoges werden die Änderungen in der Datenbank durchgeführt.

Diese Änderungen durchführen bevor Änderungen in die Runtime übernommen werden (durch online nachladen oder durch Runtime Neustart). Ansonsten werden längere Stringwerte abgeschnitten archiviert!


Ausgabemöglichkeiten

Handbuch -> Archivserver -> Ausgabemöglichkeiten

Parameter | Beschreibung
Report Generator | Es können nun auch String-Archivdaten im Report ausgegeben werden
Erweiterter Trend | Die Auswahl von Stringvariablen als Quelldaten ist unterdrückt.
DBF Aufzeichnung | Wurde als Aufzeichnungsformat DBF gewählt, so erhält die Tabelle nun eine zusätzliche Spalte mit dem Namen Strwer. Als Spaltenlänge die längste zu archivierende Stringvariable verwendet, maximal jedoch 255 Zeichen.
SQL | Die Tabelle <Projektname>_<Kurzbezeichnung> hat zwei zusätzliche Spalten bekommen: GUID: char 36; Nimmt die Projekt-Guid der Variable aus einem fremden Projekt auf oder ist NULL wenn im eigenen Projekt. STRVALUE: varchar; Die Länge hängt von der längsten zu archivierenden Stringvariable ab. Bei einem numerischen Kanal hat das Feld den Wert NULL. Die Tabelle <Projektname>_VARIABLES hat eine neue Spalte bekommen. GUID: char 36; Nimmt die Projekt-Guid der Variable aus einem fremden Projekt auf oder ist NULL wenn im eigenen Projekt. Eine zusätzliche Tabelle beinhaltet die dem Archiv zugehörigen Chargeninformationen. In dieser Tabelle befinden sich Informationen zu Chargenname, Start- und Stopzeiten.

attention Achtung

Wenn große Archivdaten angefordert werden, kann es zu Leistungseinbußen in der Runtime kommen.


Ablauf der Archivierung

Handbuch -> Archivserver -> Ablauf der Archivierung

Zu beachten ist, dass die Übertragung von Daten einige Zeit in Anspruch nimmt, so dass bei einem Triggerereignis eine Wartezeit von mehreren Sekunden entsteht, abhängig von der Anzahl der Werte.

Ferner ist zu beachten, dass der PC asynchron zur SPS arbeitet, so dass nicht alle Triggerflags gleichzeitig erkannt werden. Das kann zur Folge haben, dass Zeitverschiebungen bei den Daten auftreten. (Kann nur bei Typ 1 auftreten).

Eine Lösung des Problems ist die Zeitstempelung in der SPS (Typ 2, Typ 3 und Typ 4).

Bei Typ 4 wird im Gegensatz zu den Typen 2 und 3 nur die Startzeit übergeben. Es ist darauf zu achten, dass die Reihenfolge der Einträge in Typ 4 genau umgekehrt zu Typ 1 erfolgt.

attention Achtung

Beim Redundanzbetrieb erfolgt das Hochstufen des Servers erst dann, wenn alle Projekte geladen und abgeglichen wurden. Da für die Datenpunkte von einem unterlagerten Projekt keine Umschaltpuffer mitgeführt werden können, sind diese Daten in der Umschaltzeit des SB zum Servers und beim Nachladen nicht aktuell!

info Info

Allgemeines

SPS Datenformatierungen

Header Beschreibung

Typen Beschreibung


Filterprofile

Handbuch -> Archivserver -> Filterprofile

Filterprofile sind Filtereinstellungen, die der Anwender in der Runtime speichern kann. Zur Verwendung der Filterprofile gibt es im Menü Kontrollelemente ein Untermenü Filterprofile mit folgenden Elementen:

Parameter | Beschreibung
Filterprofile | Profilverwaltung
Profilauswahl | Gespeichertes Profil auswählen (Dropdownliste)
Speichern | Einstellungen als Profil speichern (Schaltfläche)
Löschen | Profil löschen (Schaltfläche)

In der Runtime können nun die Filterbedingungen geändert werden. Dann ist ein beliebiger, eindeutiger Name für die getroffenen Einstellungen in das Element Profilauswahl einzutragen. Mit der Schaltfläche Speichern wird das Profil dann gespeichert und steht bei zukünftigen Sitzungen zur Verfügung.

Nicht mehr benötigte Profile können nach Auswahl im Element Profilauswahl mit der Schaltfläche Löschen wieder gelöscht werden.


Funktionen

Handbuch -> Archivserver -> Funktionen

In zenon stehen Ihnen mehrere Funktionen zur Verfügung, um die Archivierung zu steuern.

Noch in diesem Kapitel

Bildumschaltung - Archiv-Nachbearbeitung

Archiv beenden

Archiv indizieren

Archiv starten

Aktive Archive anzeigen

Archive exportieren


Bildumschaltung - Archiv-Nachbearbeitung

Handbuch -> Archivserver -> Funktionen -> Bildumschaltung - Archiv-Nachbearbeitung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für das Aufschalten eines Bildes des Bildtyps Archivnachbearbeitung können die Filter im Editor vorprojektiert werden (definiertes Archiv; Archiv mit vorselektierten Statusbits).

info Info

Die Filtereigenschaften sind während der Runtime änderbar.

Projektierbare Eigenschaften sind:

Parameter | Beschreibung
Filter | Filterkriterien festlegen (Variablen, Wert, Status etc.)
Format | Anzeigeformat und Sortierung der angezeigten Archiveinträge
- Zeit | Sortierung aller Einträge nach Datum und Zeit
- Variable | Sortierung nach Variablenname
- unsortiert | keine Sortierung
Lesen vom Backupordner | Aktivieren Sie diese Checkbox, wenn Sie Archive aus dem Backupordern verwenden möchten.

Nach der Markierung des Archivs können die Filter ausgewählt werden.

info Info

Beachten Sie, dass Sie die gewünschten ausgelagerten Archive erst in den Backuporder kopieren müssen, bevor Sie über Lesen vom Backuporder darauf zugreifen können.
Beim Auslagern werden Archive im Order Ausgelagerte Archive gespeichert. Dieser Ordner entspricht nicht dem Backupordner.
Die Ordner für die Dateiablage definieren Sie im Dialog Standard Einstellungen auf der Registerkarte Ordner. Sie finden den Dialog unter Datei -> Allgemeine Konfiguration -> Standard.

Noch in diesem Kapitel

Filter


Filter

Handbuch -> Archivserver -> Funktionen -> Bildumschaltung - Archiv-Nachbearbeitung -> Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Option Filter öffnet einen Dialog mit drei Registerkarten:

  • Archivfilter
  • Zeit
  • Chargen

Archivfilter

Projektierbare Filter und Kombinationen sind:

Parameter | Beschreibung
Status | Filterung auf bestimmte Statusbits
Variable | Variablen, die aus dem selektierten Archiv aufgeschaltet werden sollen; die Markierung erfolgt mittels Mausklick auf den Variablen
Wert (Minimum, Maximum) | Filterung aller Archivwerte, deren technische Werte zwischen einem Minimum und Maximum liegen

Für die Archiveditierung sind die im Kapitel Bildtyp Archivnachbearbeitung definierten Speicherbegrenzungen (maximale Darstellungsgröße) zu berücksichtigen.

Die Auswahl von 'Status', 'Variablen' und 'min/max' kann nur erfolgen wenn die Option 'alle Eigenschaften' im Dialog 'Filter' nicht gesetzt ist.

Hinweis Registerkarte Zeit: Wird als Zeitfiltertyp die Option Kein Zeitfilter, dann werden werden zur Runtime alle Einträge seit 1. 1. 2000 angezeigt.


Archiv beenden

Handbuch -> Archivserver -> Funktionen -> Archiv beenden

Mit der Verwendung dieser Funktion wird ein im Onlinebetrieb aktuell laufendes Archiv beendet. Nach dem Beenden des Archivs wird das im Archiv projektierte Archiv-Endescript ausgeführt.

Geben Sie als Übergabeparameter das zu beendende Archiv an. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Vor der Verwendung der Funktion muss das Archiv im Editor mindestens angelegt worden sein. Die Auswahl des Archivs erfolgt durch selektieren des Archivs in der Archiv-Auswahl und klick auf die Schaltfläche OK.

In der Funktionsverwaltung wird hinter der Systemfunktion die Kurzkennung des Archivs als Übergabeparameter angegeben (z.B.: Archiv beenden [01]).

attention Achtung

Achtung: Wird das Starten und Stoppen des Archivs über Start/Ende der Runtime definiert, kann das manuelle Stoppen oder Starten des Archivs über Funktionen zu unerwünschtem Verhalten der Runtime führen.


Archiv indizieren

Handbuch -> Archivserver -> Funktionen -> Archiv indizieren

Diese Funktion dient dem nachträglichen Indizieren von Chargen-Archiven. Dies kann nach dem Löschen oder Ändern von einzelnen Archiven sinnvoll sein.

Geben Sie als Übergabeparameter das zu indizierende Chargen-Archiv an. Die Projektierung der Funktion erfolgt über eine Dialogmaske. Hier werden nur die projektierten Chargen-Archive angezeigt.

Parameter | Beschreibung
Synchron ausführen | Gilt nur für die Ausführung in einem Skript. Aktivieren Sie diese Checkbox, wenn Sie möchten, dass die nächste Funktion erst startet, wenn diese abgeschlossen ist.

info Info

Die Funktion Archive indizieren wird immer am prozessführenden Server ausgeführt.


Archiv starten

Handbuch -> Archivserver -> Funktionen -> Archiv starten

Mit der Verwendung dieser Funktion wird im Onlinebetrieb ein projektiertes Archiv gestartet. Nach dem Starten des Archivs wird das im Archiv projektierte Archiv-Startscript ausgeführt.

Geben Sie als Übergabeparameter das zu startende Archiv an. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Vor der Verwendung der Funktion muss das Archiv im Editor mindestens angelegt worden sein. Die Auswahl des Archivs erfolgt durch selektieren Archivs in der Archiv-Auswahl und klick auf die Schaltfläche OK.

In der Funktionsverwaltung wird hinter der Systemfunktion die Kurzkennung des Archivs als Übergabeparameter angegeben (z.B.: Archiv starten [01]).

attention Achtung

Achtung: Wird das Starten und Stoppen des Archivs über Start/Ende der Runtime definiert, kann das manuelle Stoppen oder Starten des Archivs über Funktionen zu unerwünschtem Verhalten der Runtime führen.


Aktive Archive anzeigen

Handbuch -> Archivserver -> Funktionen -> Aktive Archive anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion zeigt in der Runtime ein vordefiniertes Systemfenster der aktuell aktiven Archive an. Das Systemfenster wird permanent im Vordergrund angezeigt.


Archive exportieren

Handbuch -> Archivserver -> Funktionen -> Archive exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion werden die aufgezeichneten Einträge eines Archivs auf eine Datei exportiert.

Als Übergabeparameter sind die Dateiprojektierung (Name, Pfad, Formatierung etc.), das Archiv und der Zeitfilter anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Projektierbare Eigenschaften sind:

Parameter | Beschreibung
Allgemein | Festlegen des entsprechenden Dateinamens für den Archivexport
Archiv | Auswahl des Archivs
Zeit | Festlegung des entsprechenden Zeitbereiches mit Zeitformat und Zeittyp
Chargen | Auswahl der gewünschten Chargen

info Info

Wenn Sie ein aktives Chargenarchiv exportieren, wird als Endzeit der Zeitpunkt des Exports eingetragen. Als Chargenname wird der aktuelle Wert der Chargenvariablen verwendet.

Bitte beachten Sie, dass diese Werte nicht den Werten des beendeten Chargenarchivs entsprechen müssen.

Speicherüberprüfung beim Rücklesen

Beim Rücklesen von gespeicherten Archiven wird der vorhandene Speicher überprüft.

SQL

Sind weniger als 10% des im System vorhandenen Speichers frei, wird das Einlesen der Daten aus dem SQL-Server abgebrochen.

ARX-Dateien

Vor dem Einlesen von Archivdateien (*.arx) wird der zur Verfügung stehende Platz überprüft. Das Einlesen wird abgebrochen, wenn:

  • weniger als 10% des im System vorhandenen Speichers frei sind
  • die in der project.ini definierte Größe für den reservierten Speicherbereich (SPEICHER=) überschritten wird

Das Abbrechen wird über eine Fehlermeldung im Diagnose Viewer dokumentiert.

attention Achtung

Werden in der Archivierung Dateien erzeugt, die entweder den in der project.ini reservierte Speicherplatz oder die 10%-Regel überschreiten, können diese Dateien nicht mehr eingelesen werden.

XML-Export

Die Spalten Variablenname (V) und Kennung (I) enthalten nur den entsprechenden Namen der Variablen bzw. die Kennung der Variablen. In älteren zenon Versionen wurde in der Spalte Variablenname auch Informationen z.B. über die Verdichtungsart bei Folgearchiven gespeichert. Beachten Sie, dass es deshalb zu Inkompatibiltität beim XML-Export von älteren Versionen im Vergleich zur aktuellen Version kommen kann.

Noch in diesem Kapitel

Allgemein

Archiv


Allgemein

Handbuch -> Archivserver -> Funktionen -> Archive exportieren -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für das Exportieren der Daten auf eine Datei sind die Dateioptionen und -eigenschaften anzugeben.

Projektierbare Eigenschaften der Dateiprojektierung sind:

Parameter

Beschreibung

Exportformat

dBase

dBase IV - Datei (*.dbf)
Achtung: DBF-Dateien müssen:

  • in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • nahe am Stammverzeichnis (Root) abgelegt werden

CSV

CSV-Textdatei (*.txt)

Aufbau (-> steht für Tabulator):
Name -> Kennung -> Wert -> Einheit -> (Status_HI_DWORD)(Status_LO_DWORD) -> Sekunden

XML

XML - Datei (*.xml)

SQL

Auslagerung in eine SQL Datenbank

Hinweis: Der Export in eine SQL-Datenbank ist nur möglich, wenn Sie die entsprechende Lizenz für den Editor und die Runtime haben.

Exportierte Spalten

Variablenname (V)

Variablenname

Kennung (I)

Variablenkennung

Wert (W)

aufgezeichneter technischer Wert

Einheit (U)

zugehöriger Einheit

Status (S)

zugehöriger Variablenstatus

Datum (D)

zugehöriger Datumsstempel

Zeit (Z)

zugehöriger Zeitstempel

Optionen

Diesen Dialog zur Runtime anbieten

Wenn Sie diese Option aktivieren, wird der Dialog beim Aufschalten des Bildes in der Runtime angezeigt.

Archive vom Backupordner einlesen

Archive für den Export werden aus dem Backupordner gelesen.

Als Unicode exportieren

Nur verfügbar, wenn Sie bei Exportformat CSV selektiert haben.

Wenn Sie diese Option aktivieren, wird die exportierte Datei in Unicode (UTF-16) gespeichert.

Export in Datei

Dateiname

benutzerdefinierter frei vergebbarer Dateiname (Datei wird immer auf gleichen Namen exportiert)
Hinweis: Der Name darf keine Sonderzeichen enthalten. Das Eingabefeld wird unsichtbar, sobald Sie die Option Dateiname automatisch generieren aktiviert haben.

Dateinamen automatisch generieren

Wenn Sie diese Option aktivieren, wird der Dateiname aus einer Kurzkennung, einer Benutzerkurzkennung und einem Tagesschlüssel automatisch generiert.

Name

JMTHMM.yyy mit

J

Jahr (einstellig: 1..9, A, B, C, ...)

M

Monat (einstellig: 1..9, A, B, C, ...)

T

Tag (einstellig: 1..9, A, B, C, ...)

H

Stunde (einstellig: 1..9, A, B, C, ...)

MM

Minuten (zweistellig)

yyy

Dateityp (DBF, TXT, XML)

Dateinamen aus Chargennamen generieren

Nur sichtbar, wenn Sie die Option Dateiname automatisch generieren aktiviert haben.

Dateiname wird aus Chargennamen generiert

Hinweis: Wenn Sie diese Option wählen, müssen Sie darauf achten, dass der Chargenname keine Sonderzeichen enthält.

Postfix

freie Kennung (ASCII - 29 Zeichen); wird automatisch an den Dateinamen angehängt.
Hinweis: Nur bei gesetzter Option Dateinamen automatisch generieren

Eingestellter Exportordner

Anzeige des eingestellten Exportordners.

Änderung unter dem Menüpunkt Datei-> Allgemeine Konfiguration -> Standard Registerkarte Ordner Exportierte Archive.

Export in SQL-Datenbank

Datenbankverbindung

Bei Auslagerung in eine SQL-Datenbank kann hier die zu verwendende Datenbank angegeben werden.

Hinweis: Der Export in eine SQL-Datenbank ist nur möglich, wenn Sie die entsprechende Lizenz für den Editor und die Runtime haben.

Tabelle

Bei Auslagerung in eine SQL-Datenbank kann hier die zu verwendende Tabelle angegeben werden.

Hinweis: Der Export in eine SQL-Datenbank ist nur möglich, wenn Sie die entsprechende Lizenz für den Editor und die Runtime haben.


Archiv

Handbuch -> Archivserver -> Funktionen -> Archive exportieren -> Archiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach der Dateiprojektierung ist das zu exportierende Archiv anzugeben.

info Info

Das zu exportierende Archiv wird durch die Anwahl mit der Maus markiert. Vor der Verwendung der Funktion muss das Archiv im Editor mindestens angelegt worden sein.

In der Funktionsverwaltung wird als Übergabeparameter die Kurzbezeichnung angezeigt (z.B.: Archiv exportieren ([auto] 01 [T]ascii).


Bedienung während der Runtime

Handbuch -> Archivserver -> Bedienung während der Runtime

Während der Runtime wird der Bildtyp Archivnachbearbeitung über einen Funktionsaufruf (z.B. Button) geöffnet. Es wird die Onlinemaske des im Editor vordefinierten Bildes aufgeschaltet.

Die möglichen Onlinebedienungen sind:

Parameter | Beschreibung
Öffnen | anderes Archiv öffnen und Filterbedingungen setzen
Schließen | aktuell geöffnetes Archiv schließen
Speichern | geändertes Archiv speichern und Folgearchive auf Anfrage aktualisieren
Bearbeiten | selektierten Archiveintrag bearbeiten Wert ändern, Statusänderung nach Handwert
Einfügen | Archiveinträge in die entsprechenden Archivdateien einfügen! Sind für diesen Zeitbereich keine Archivdateien vorhanden, kann kein Einfügen erfolgen. Es wird eine Fehlermeldung in der Filterlistbox ausgegeben!
Löschen | Archiveintrag löschen
Auswahl | Auswählen mehrerer Archiveinträge und Markieren dieser Einträge für Bearbeitungsmodus
Fenster | Eine Dialogbox zur Ansicht der Archiveditierungsliste wird geöffnet. Hier können die Spaltenbreiten für die Ansicht und die Schriftart definiert werden.
Drucken | Ausdruck der aufgeschalteten Archivinformation

Beim Ausdruck des Archivs wird die Datei ARV_G.FRM mit den entsprechenden Schlüsselworten verwendet. Der zyklische Teil wird mit %% eingeschlossen. Die Datei muß im Installationspfad abgelegt sein.

Schlüsselworte |
- @HEADZEIT | Datums-Zeitstempel des Archivs
- @ARCHIVNAME | Name des Archivs
- @DATZEIT | Datums-Zeitsstempel des Archiveintrages
- @KANALNAME | Variablenname des Archiveintrages
- @WERT | Wert des Archiveintrages
- @EINHEIT | Einheit des Archiveintrages
- @AMELDUNG | Zustandstext des Archiveintrages
- @STATUS | Statustext des Archiveintrages

Example Beispiel

ARV_G.FRM

@HEADZEIT @ARCHIVNAME
Seite: @SEITE -----------------

Datum/Zeit TTA Wert Einheit Zustandstext Status
-------------------------------------------------------------------------------------------------
%%
@DATZEIT @KANALNAME @WERT @EINHEIT @AMELDUNG @STATUS
%%

Die Buttons werden entsprechend ihrer Funktion freigegeben und gesperrt. Über den Buttons sind Felder mit der Anzeige für

Parameter | Beschreibung
Archivname | Kurzkennung des aktuell geöffneten Archivs
Anzahl der Einträge | Gesamtanzahl der dargestellten Einträge der Prozessvariablen (nach Filterbedingung!)
Anzahl gestörte | Anzahl von Archiveinträgen mit Status INVALID

Als Summenübersicht für die eingestellten Filter und des Bearbeitungszustandes kann die Filterlistbox genutzt werden.

Soll ein anderes als das in der Funktion hinterlegten Archivs geöffnet werden, kann mit der Betätigung des Button Öffnen die Archivauswahlmaske mit den Einstellungen für Sortierung und Filterbedingungen aufgeschaltet werden.

Ist ein Archiv geöffnet und dargestellt, können die Archivwerte geändert werden.

Noch in diesem Kapitel

Bildtyp Archivnachbearbeitung

Arbeiten mit der Archivierung


Bildtyp Archivnachbearbeitung

Handbuch -> Archivserver -> Bedienung während der Runtime -> Bildtyp Archivnachbearbeitung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Bildtyp Archiv-Nachbearbeitung dient zur tabellarischen Onlinedarstellung und -editierung von gespeicherten Archivwerten. (Nähere Informationen zu den vordefinierten Bildtypen finden Sie im 'Bilder / Vordefinierte Bildtypen'.)

attention Achtung

Für die Verwendung der Funktion muss das Archivmodul lizenziert sein.

Das Anlegen des Archiv-Editorfensters erfolgt im Editor durch das Anlegen eines neuen Bildes der Bildtyp Archiv-Nachbearbeitung.

Nach dem Öffnen des Bildes wird ein leeres Bild aufgeschaltet und in der Menüzeile wird die Dropdownliste Kontrollelemente gefüllt.

Mit Hilfe der Kontrollelemente können die Bedienelemente für das Fenster im Bild angeordnet werden (im Editor nur zweidimensionale Darstellung). Die Funktionselemente werden in Buttons (für Onlinebedienung), Listen (Darstellung der/s Archive/s und Filterbedingung) und Anzeigeelemente (Darstellung von Informationen zur Archivwertausgabe) unterschieden.

Kontrollelemente sind:

Parameter | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Buttons | vordefinierte Bedienelemente
Öffnen | neues Archiv zur Anzeige bringen
Schließen | aktuelles Archiv abwählen
Speichern | Änderungen im Archiv speichern
Bearbeiten | selektierte/n Wert/e bearbeiten
Einfügen | neue Werte ins Archiv einfügen
Löschen | Werte aus dem Archiv löschen
Auswahl | Filterkriterium für Markierung setzen
Spalten | Spalteneinstellung
Drucken | Darstellung drucken
Listen |
Archivlistbox | Darstellung der Archive
Filterlistbox | Darstellung des Filterkriteriums
Anzeige |
Anzahl Werte | gelesene Werte
Anzahl INVALID | gelesene Werte, die mit INVALID-Bit (Statusbit) markiert sind
Anzeige Kurzbez. | Archivkurzbezeichnung anzeigen
Archiv aktiv | aktueller Verarbeitungszustand des Archiv (aktiv, inaktiv)
Profile | Profilverwaltung
Profilauswahl | Gespeichertes Profil auswählen
Speichern | Einstellungen als Profil speichern
Löschen | Profil löschen

info Info

Ein Dezimalwert kann sowohl mit 'Komma' als auch mit 'Punkt' angegeben werden, das Dezimalzeichen wird automatisch in einen 'Punkt' umgewandelt.

Mit der Betätigung des Menüpunktes Default im Pulldownmenü Kontrollelemente werden alle Kontrollelemente mit Standardwerten auf vordefinierte Positionen geladen.

Die Änderung der Kontrollelemente in Größe, Ausrichtung und Anordnung sowie der verwendeten Benutzerschriftart ist möglich. Die eingestellte Schriftart wird erst im Onlinebetrieb dargestellt. Es können Elemente, die in der Onlinedarstellung nicht benötigt werden (oder nicht vorhandensein dürfen), aus dem Bild gelöscht werden (z.B. Öffnen, Löschen, Speichern etc). Das Hinzufügen anderer Dynamische Bildelemente und Vektor Bildelemente ist ebenfalls möglich.

Das Aufschalten des Bildes mit der Archiveditierungsfunktion im Onlinebetrieb erfolgt über die Verwendung der Funktion Bildumschaltung - Archiv-Nachbearbeitung.

Noch in diesem Kapitel

Filter bei Bildumschaltung


Filter bei Bildumschaltung

Handbuch -> Archivserver -> Bedienung während der Runtime -> Bildtyp Archivnachbearbeitung -> Filter bei Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie ein Bild vom Typ Archiv-Nachbearbeitung aufschalten, wird Ihnen folgender Filter angezeigt. Wurde bei der Projektierung als Zeitfiltertyp die Option Kein Zeitfilter gesetzt, dann werden werden zur Runtime alle Einträge seit 1. 1. 2000 angezeigt.

Parameter

Beschreibung

Chargenfilter

Auf der linken Seite können Sie aus den verfügbaren Archiven das gewünschte auswählen. Auf der rechten Seite werden Ihnen die verfügbaren Chargen angezeigt. Sie haben die Möglichkeit dort die Chargen zu filtern.

Chargenname

In dieser Spalte werden Ihnen die Namen aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen alphabetisch aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie eine Zeichenfolge eingeben. Nur Chargen mit der jeweiligen Zeichenfolge werden angezeigt.

Startdatum

In dieser Spalte wird Ihnen das Startdatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Startzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Startdatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Startzeit

Nur verfügbar, wenn Sie ein Startdatum eingeben.

In dieser Spalte wird Ihnen die Startzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Startzeit manuell festlegen.

Hinweis: '*' bedeutet 0:00:00 Uhr.

Enddatum

In dieser Spalte wird Ihnen das Enddatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Endzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Enddatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Endzeit

Nur verfügbar, wenn Sie ein Enddatum eingeben.

In dieser Spalte wird Ihnen die Endzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Endzeit manuell festlegen.

Hinweis: '*' bedeutet 23:59:59 Uhr.

Dauer

Diese Spalte zeigt Ihnen die Dauer aller verfügbaren Chargen an. Sie dient nur der Anzeige.

info Info

Es werden auch noch nicht abgeschlossene Chargen angezeigt, falls sie den Filterkriterien entsprechen.

info Info

Der Wert der Chargenvariable wird beim Beginn der Charge sowohl in die Index-Datei also auch in den Header der ARX-Datei geschrieben. Bei jeder Änderung dieser Variable werden diese Einträge angepasst. Beim Abschließen der Charge wird der aktuelle Wert der Chargenvariable endgültig in die Index-Datei und in den Header geschrieben.

Erst wenn eine Charge abgeschlossen ist, ist der Chargenname festgeschrieben.


Arbeiten mit der Archivierung

Handbuch -> Archivserver -> Bedienung während der Runtime -> Arbeiten mit der Archivierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Während der Runtime stehen folgende Funktion für die Archivsteuerung und -überwachung zur Verfügung.

Parameter | Beschreibung
Archiv starten | Starten des im Editor hinterlegten Archivs
Archiv beenden | Beenden des im Editor hinterlegten Archivs
Archive aktive | Kontrollfenster für die Darstellung der aktuell laufenden Archive
Archiv indizieren | Nachträgliches Indizieren von Chargen-Archiven.

info Info

Das laufende Archiv schreibt die aufgezeichneten Daten in ein Alpha-Archiv (kk.ARX; kk - Kurzkennung des Archivs). Wird das Archiv über das System beendet (Funktion Archiv beenden) wird die Datei auf einen anderen Namen umkopiert. Wird die Runtime undefiniert beendet (Stromausfall), bleibt das Alpha-Archiv erhalten. Ist das Archiv als zyklisches projektiert, wird es beim Neustarten der Runtime mit Ersatzwerten für den fehlenden Bereich im aktuellen Intervall aufgefüllt. Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der der zuletzt gültige Wert. Vorhandene Einträge werden nicht überschrieben.

Noch in diesem Kapitel

Werte editieren

Auffüllen von Werten

Werte löschen

Werte ins Archiv speichern

Tabellendarstellung festlegen

Mehrfachauswahl von Werten


Werte editieren

Handbuch -> Archivserver -> Bedienung während der Runtime -> Arbeiten mit der Archivierung -> Werte editieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Einträge der Archivwerte können durch Doppelklick auf einem Wertfeld oder durch die Betätigung des Button Bearbeiten bei markierten Werten geändert werden. Es wird die Eingabe des neuen Wertes verlangt.

Wurden ein oder mehrere Werte geändert, wird der Status des Eintrages um Handwert erweitert. Gleichzeitig schlägt die Farbe im Spaltenkopf von Blau nach Rot um und der Button Speichern wird freigegeben. Die Markierung wird zurückgenommen.


Auffüllen von Werten

Handbuch -> Archivserver -> Bedienung während der Runtime -> Arbeiten mit der Archivierung -> Auffüllen von Werten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für das Auffüllen von geschlossenen, nicht aktiven Archiven mit fehlenden Werten ist der Button Einfügen zu betätigen. Es wird die Eingabemaske aufgeschaltet.

  • Ist ein Archiveintrag markiert, kann die Anzahl der Werte und der Wert für eine auszuwählende Prozessvariable des Archivs angegeben werden. Alle Einträge bekommen beim Einfügen den gleichen Zeitstempel.
  • Ist kein Eintrag markiert, kann neben Wert und Anzahl der Startzeitpunkt für das Auffüllen und der Zyklus (in Sekunden) festgelegt werden.

Wurden ein oder mehrere Werte geändert, wird der Status des Eintrages um Handwert erweitert. Gleichzeitig schlägt die Farbe im Spaltenkopf von blau nach rot um und die Schaltfläche Speichern wird freigegeben. Die Markierung wird zurückgenommen.


Werte löschen

Handbuch -> Archivserver -> Bedienung während der Runtime -> Arbeiten mit der Archivierung -> Werte löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollen ein oder mehrere Archiveinträge aus dem Archiv gelöscht werden, sind die Zeilen mit der Maus oder dem Button Auswahl zu markieren und der Button Löschen ist zu betätigen. Es wird eine Abfragemaske aufgeschaltet.

Soll der Wert endgültig gelöscht werden, ist der Button Ja zu betätigen, andernfalls der Button Nein.


Werte ins Archiv speichern

Handbuch -> Archivserver -> Bedienung während der Runtime -> Arbeiten mit der Archivierung -> Werte ins Archiv speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aktuelle und nicht gespeicherte Änderungen im Archiv werden durch eine rote Kopfzeile symbolisiert. Die Werte werden nach der Anwahl des Button Speichern in das Archiv gespeichert. Sind Folgearchive dem aktuell bearbeiteten Archiven zugeordnet, so werden die Folgearchive automatisch aktualisiert.


Tabellendarstellung festlegen

Handbuch -> Archivserver -> Bedienung während der Runtime -> Arbeiten mit der Archivierung -> Tabellendarstellung festlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Formatierung der Listenausgabe kann im Onlinebetrieb der Button Fenster betätigt werden.


Mehrfachauswahl von Werten

Handbuch -> Archivserver -> Bedienung während der Runtime -> Arbeiten mit der Archivierung -> Mehrfachauswahl von Werten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Mehrfachauswahl von Werteinträgen wird der Button Auswahl betätigt.

Die Checkbox alle Einträge suggeriert alle Variablen. Ein Aktivieren dieser Checkbox deaktiviert die Variablenselektion und wirkt auf den Zeitfilter.

Während der Runtime werden nach der Definition der Filterbedingungen die Archiveinträge dunkel hinterlegt.

Sollen die Markierungen zurückgesetzt werden, ist in der Maske Auswahl die Option kein Eintrag zu setzen.


Automatic Line Coloring (ALC) - Topologie

Handbuch -> Automatic Line Coloring (ALC) - Topologie

Die topologische Einfärbung von Leitungen dient zur einfachen automatischen Dynamisierung von Leitungen in der Verfahrenstechnik (für Medien) sowie in der elektrischen Energieverteilung (für Strom). Damit lassen sich die prozessgesteuerten Einfärbungen von topologischen Netzen einfach realisieren.

Aufgrund der Projektierung im Bild wird die Leitungsstruktur einschließlich ihrer angeschlossenen verfahrenstechnischen Elemente (z.B. Tanks und Ventile, bzw. Generatoren, Schalter und Verbraucher) intern als Modell nachgebildet und der Medienfluss während der Runtime dargestellt.

Um bildübergreifende Modelle zu ermöglichen, ist die gesamte Projektierung sowie Konfiguration immer projektweit. Es ergibt sich somit pro Projekt ein gesamtes Topologisches Modell, das zur Berechnung der Leitungszustände und schließlich zur Färbung der einzelnen Leitungen herangezogen wird.

Die gesamte Topologie wird dabei aus dem grafischen Design unter Anordnung der Elemente automatisch erstellt. Es sind keine weiteren projektiertechnischen Maßnahmen notwendig.

info Info

Der ALC Algorithmus durchläuft von einer Quelle ausgehend jeden Schalter pro Richtung nur einmal.

Detailbilder

Für die Darstellung von Einzelbildern kann mit der Hilfe von Alias ein Teilbereich aus dem Topologischen Netz herausgenommen und einzeln dargestellt werden. Ein Detailbild kann mit den Daten unterschiedlicher Anlagenteile, z.B. Abgängen oder Teilnetzen, dargestellt werden.

Lizenzierung

Für Editor und Runtime (Einzelplatz, Server, Standby) lizenzpflichtig. Nicht lizenzpflichtig für Runtime-Client. Lizenzierung erfolgt über zenon Energy Edition.

  • ALC: In der Lizenz für die Energy Edition enthalten, stellt grundlegende Eigenschaften der Linieneinfärbung zur Verfügung.
  • Topologie-Paket: Benötigt zusätzliche Lizenzierung am Server (nicht am Client) und erweitert ALC um:
    • Mehrfachversorgung
    • gesicherte Versorgung
    • Topologische Verriegelungen
    • Topologische Elemente Trafo und Trenner
    • Fehlerortung (ab Version 6.50)

Noch in diesem Kapitel

ALC Elemente

Konfiguration

ALC-Quellenfarbe ändern

Detailbilder

Fehlerortung in elektrischen Netzen


ALC Elemente

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Automatic Line Coloring (ALC) ermöglicht es, Leitungen abhängig vom Prozesszustand einzufärben. Als verfahrenstechnisches Element wird das Combi-Element verwendet. ALC dient zur einfachen automatischen Dynamisierung von Leitungen in der Verfahrenstechnik (für Medien) sowie topologischen Netzen in der elektrischen Energieverteilung (für Strom).

Projektierung

Für die Projektierung werden zwei Typen von Bildelementen mit verschiedener Funktion unterschieden. Zum einen sind dies Verfahrenstechnische Elemente (Quelle, Schalter, Trenner, Senke, Trafo bzw. Link) und zum anderen Leitungen.

Dabei ist es so, dass die verfahrenstechnischen Elemente eine Funktion und eine Farbe (Quelle und Trafo) besitzen. Wenn die verfahrenstechnischen Elemente aktiv sind, übernehmen die abgehenden Leitungen bei Quelle und bei Trafo die Farbe dieser Elemente bzw. nehmen bei Schalter und bei Link die Farbe der Eingangsleitung des Elements an. Bei Inaktivität der verfahrenstechnischen Elemente wird die Farbe der Leitungen aus der Projektierung im Element übernommen.

Die verschiedenen Funktionen dieser Elemente werden in den Eigenschaften des Combi Elementes zugewiesen.

Beispiel

Eine Quelle verfügt über eine angeschlossene Leitung. An diese Leitung ist ein Schalter angeschlossen. Daran ist wiederum eine zweite Leitung angeschlossen. Wenn die Quelle aktiv ist, wird die erste Leitung bis zum Schalter mit der in den Projekteigenschaften des Automatic Line Coloring definierten Farbe der Quelle eingefärbt. Die weitere Leitung wird erst dann eingefärbt, wenn der Schalter geschlossen ist.

Quelle inaktiv

Quelle aktiv

Schalter geschlossen

Undefiniert oder gestört

info Info

Befindet sich das verfahrenstechnische Element im Zustand undefiniert oder gestört, wird dies automatisch erkannt. Die abgehenden Leitungen und alle weiteren Elemente werden für beide Status in der Farbe der vordefinierten Quelle undefiniert angezeigt.

Noch in diesem Kapitel

Verfahrenstechnische Elemente

Leitungen

Überprüfung der Projektierung


Verfahrenstechnische Elemente

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verfahrenstechnische Elemente werden in zenon mit einem Combi Element erstellt und bestimmen je nach Zustand die Einfärbung der angeschlossenen Leitung.

Folgende Einstellungen stehen zur Verfügung:

Eigenschaft

Beschreibung

Funktionstyp

Gibt den verfahrenstechnischen Typ des Combi-Elements an.
  • Abschluss

Für Sammelschienenende. Unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
  • Quelle

Dient als Lieferant für eine Farbe. Ist die Quelle aktiv (Wert: 1), bekommen alle angeschlossenen Leitungen, die in den Elementeigenschaften die Option Farbe aus ALC gesetzt haben, die Farbe der Quelle zugewiesen. Die Farbe ist durch die in den Projekteigenschaften für die Quelle definierte Quellfarbe bestimmt. (z.B. Tanks oder Generatoren). Eine Quelle ist ein Einpol, dem eine statische Quellenummer zugeordnet ist. Die Quelle ist über den Zustand ihrer Hauptvariable schaltbar. Quellen gelten grundsätzlich als netzsynchron und kuppelbar.

Interne ID: Verfahrenstechnische Elemente

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""
  • Generator

Ein Generator verhält sich prinzipiell wie eine Quelle, nur dass er grundsätzlich als eigenständig und nicht-netzsynchron angenommen wird.
  • Schalter

Damit können Leitungen unterbrochen werden. Ist der Schalter geschlossen/aktiv (Wert: 1), dann ist die Verbindung zwischen zwei Leitungen geschlossen und die Leitung verfärbt sich bis zum nächsten Schalter mit der definierten Farbe der Quelle. Ein Schalter leitet in diesem Fall die Quellen-Farbe der Eingangsleitung an die Ausgangsleitung weiter.

Ist der Zustand des Schalters gestört oder undefiniert oder Status INVALID, verfärbt sich die Leitung in die Farbe undefiniert aus der ALC Konfiguration in den Projekteigenschaften. Ein Schalter liefert somit an seinem Ausgang (Anschluss 2) anstatt der eingehenden Quellennummer die Quellennummer 0 (undefiniert).

Beispiel: siehe Abschnitt Beispiel Schalter - Farben aus ALC.
  • Trenner

Ein Trenner verhält sich prinzipiell wie ein Schalter. Allerdings darf ein Trenner im Topologischen Modell nicht unter Spannung geschalten werden. Ein Zustand (Ein, Aus, Zwischenstellung, gestört) wird über seine Hauptvariable bestimmt.
  • Schieber

Ein Schieber (ein Ventil) verhält sich ähnlich wie ein Schalter, wird aber für Wasser- und Gasleitungen verwendet.

Werte der Hauptvariable:

Schieber AUS: Wert 0 -> Schieber geschlossen -> kein Wasserfluss

Schieber EIN: Wert 1 -> Schieber komplett geöffnet -> Wasserfluss

Schieber DIF: Wert 2 -> Schieber teilweise geöffnet -> Wasserfluss

Schieber STO: Wert 3 -> Schieber gestört
  • Senke

Damit wird das Ende der Leitung festgelegt. Die Senke hat keinen Einfluss auf die Farbberechnung, sondern wird ausschließlich dazu verwendet, dass das Modell vollständig abgebildet werden kann. Soll mit externen Programmen (z.B. VBA) auf das Modell zugegriffen werden, dann ist die Senke unter Umständen für weitere Berechnungen erforderlich, und damit auch zu projektieren.
In Energieprojekten wird die Senke zur Darstellung von Verbrauchern verwendet. Diese werden zur Berechnung der ALC - Verriegelungen (Befehlsgruppen) 'Verbraucher würde unterversorgt' herangezogen.
  • Trafo

Ein Trafo ist gleichzeitig eine Senke und eine Quelle. Er dient dazu die Eingangsfarbe (Eingangsquelle) gegen eine Ausgangsfarbe (Trafo eigene Quelle) auszutauschen.
Erst wenn der Trafo eine aktive Eingangsleitung hat, wird die Ausgangsleitung ebenfalls aktiv geschaltet. Die Ausgangsleitung bekommt jedoch nicht die Farbe der Eingangsleitung wie beim Schalter, sondern die Farbe der Trafo eigenen Quelle. Bei jedem Trafo muss daher eine Quelle eingestellt werden. Ein Trafo kann nicht aktiv oder inaktiv geschaltet werden, er ist immer aktiv.

Rückspeisefähiger Trafo:

Um einen rückspeisefähigen Trafo zu erhalten, müssen Sie bei Quelle für Rückspeisung eine Andere Quelle als UNDEFINED [0] selektieren. Das bedeutet, dass sich der Trafo in beiden Richtungen - vom Eingang zum Ausgang (Vorwärtsrichtung) und auch vom Ausgang zum Eingang (Rückwärtsrichtung) - gleich verhält. Der einzige Unterschied besteht darin, dass zur Weiterverbreitung die Quellnummer der Eigenschaft Quelle für Rückspeisung und nicht die der Eigenschaft Quelle verwendet wird.

Interne ID: Verfahrenstechnische Elemente

Quelle

Nur verfügbar, wenn ein Funktionstyp Quelle oder Trafo ausgewählt ist:
Auswahl der verknüpften Quelle/Trafos.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verfahrenstechnische Elemente

Quelle für Rückspeisung

Nur verfügbar, wenn Sie bei der Eigenschaft Funktionstyp Trafo selektiert haben.

Interne ID: Verfahrenstechnische Elemente

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Auswahl der verknüpften Trafos.

Wenn Sie eine andere Quelle als UNDEFINED [0] selektieren, ist der Trafo rückwärtsspeisefähig. Das bedeutet, dass sich der Trafo in beiden Richtungen - vom Eingang zum Ausgang (Vorwärtsrichtung) und auch vom Ausgang zum Eingang (Rückwärtsrichtung) - gleich verhält. Der einzige Unterschied besteht darin, dass zur Weiterverbreitung die Quellnummer der Eigenschaft Quelle für Rückspeisung und nicht die der Eigenschaft Quelle verwendet wird.

Hinweis: Fehlerhafte Netzzustände oder fehlerhafte Projektierungen, wie z.B. gleichzeitige Speisung von Eingang und Ausgang oder Kurzschluss von Eingang und Ausgang werden nicht speziell eingefärbt. Das bedeutet, dass sich der rückwärtsspeisefähiger Trafo verhält wie zwei antiparallel geschaltete Trafos, die nicht rückwärtsspeisefähig sind.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Fehlerhafte Netzzustände oder fehlerhafte Projektierungen, wie z.B. gleichzeitige Speisung von Eingang und Ausgang oder Kurzschluss von Eingang und Ausgang werden nicht speziell eingefärbt. Das bedeutet, dass sich der rückwärtsspeisefähiger Trafo verhält wie zwei antiparallel geschaltete Trafos, die nicht rückwärtsspeisefähig sind.
  • Link

Ein Link ist dazu da, um eine Leitung an einer anderen Stelle fortzuführen. Wird ein Link durch eine Leitung 'versorgt', so sind alle anderen Links mit derselben identischen Link-Nummer ebenfalls genau mit dieser Quelle(n) versorgt. Dabei spielt es keine Rolle, ob sich die Links auf demselben Bild oder auf völlig unterschiedlichen Bildern im Projekt befinden. Damit lassen sich Bildübergreifende Leitungen realisieren. Es ist zulässig, dass es mehr als zwei Links mit derselben Link-Nummer im Projekt gibt.

Links können durch mehrere Leitungen gleichzeitig versorgt werden bzw. mehrere Abgänge versorgen. Prinzipiell gibt es keine Unterscheidung wischen Zu- und Abgängen. Die Quelleninformationen werden an alle angeschlossene Leitung weitergegeben.
Achtung: Zwei Link Elemente dürfen nicht direkt mit einer Leitung verbunden werden. Es muss sich dazwischen immer ein anderes verfahrenstechnisches Element (Schalter/Trenner oder Trafo) befinden.
Ein Link kann nicht aktiv oder inaktiv geschaltet werden, er ist immer aktiv

Link-Nummer

Für den Funktionstyp Link wird hier die Link-Nummer frei eingestellt. Alle identischen Link-Nummern im Projekt korrelieren miteinander. Genaue Beschreibung beim Funktionstyp 'Link'.
Diese Eigenschaft ist nur aktiv, wenn als Funktionstyp 'Link' gewählt wurde.

Quelle

Hier erfolgt die Zuweisung der Quelle zum Element. Zur Auswahl in der Auswahlbox stehen alle Quellen, die in der ALC Konfiguration (bei den Projekteigenschaften) vergeben wurden. Angezeigt werden die Quellennamen.
Diese Eigenschaft ist nur aktiv, wenn als Funktionstyp 'Quelle', 'Trafo' oder 'Generator' gewählt wurde.

Damit dem Schalter der Zustand (geöffnet, geschlossen, gestört) mitgeteilt werden kann, muss im jeweiligen Element eine Variable des IEC Datentyps BOOL oder Integer als Hauptvariable verknüpft sein. Analog wird bei der Quelle der Zustand (aktiv/inaktiv) über die verknüpfte Hauptvariable ausgewertet.

Bei den Funktionstypen Quelle und Trafo wird die angegebene Quellennummer über geöffnete bzw. geschlossene Schalter bis zu den Verbrauchern (Senken) weitergeleitet. Aus der überlagerten Summe der speisenden Quellennummern werden die Zustände und somit die Farben aller angeschlossenen Leitungen und verfahrentechnischen Elemente berechnet.

info Info

Für die Schaltung werden nur die ersten beiden Bits berücksichtigt. Das erste Bit stellt die eigentlich Schaltung dar. 0 entspricht dabei aus und 1 entspricht an.

Das zweite Bit ist das Fehlerbit. Nur wenn es 0 ist, liegt kein Fehler vor.

Zustände

  • Ein Schalter und eine Quelle sind eingeschaltet, wenn der Wert der verknüpften Variable 1 ist.
  • Ein Schalter ist gestört, wenn der Wert der verknüpften Variable >1 ist oder den INVALID Status hat.
    Ein gestörter Schalter liefert an seinem Ausgang (Anschluss 2) anstatt der eingehenden Quellennummer die Quellennummer 0 (undefiniert). In Richtung vom Ausgang zum Eingang verhält sich der Schalter wie offen.

    Hinweis: Hat die (Rückmelde-)Variable eines Schalters den Status INVALID, so wird das gesamte nachfolgende Netz INVALID, weil der Zustand des Netzes nicht bekannt ist. Der Zustand INVALID wird über nachfolgende geschlossene Schalter weitergeleitet (geroutet).

attention Achtung

Wird in den einzelnen Zuständen die Farbe und Füllfarbe aus ALC aktiviert, werden auch die verfahrenstechnischen Elemente durch den Zustand der angeschlossenen Leitungen zur Laufzeit eingefärbt.

Noch in diesem Kapitel

Beispiel Schalter - Farben aus ALC

Anschlusspunkte bei verfahrenstechnischen Elementen

Eingang/Ausgang tauschen


Beispiel Schalter - Farben aus ALC

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente -> Beispiel Schalter - Farben aus ALC

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beispiel 1

Combi-Element mit Wertzustand 00 und Linienfarbe aus ALC:

  1. Projektierung im Editor:
    • Combielement mit Wertzustand 00
    • Linienfarbe aus ALC aktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe: grün
    • Farbe unbespannt: weiß
    • Schalterzustand: aus/offen (Wert 0)

Beispiel 2

Combi-Element mit Wertzustand 01 und Farben aus ALC:

  1. Projektierung im Editor
    • Combielement mit Wertzustand 01
    • Linienfarbe aus ALC aktiv
    • Füllfarbe aus ALC aktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe: grün
    • Farbe unbespannt: weiß
    • Schalterzustand: ein/geschlossen (Wert 1)

Beispiel 3

Combi-Element Wertzustand 00 ohne Farben aus ALC:

  1. Projektierung im Editor:
    • Combielement mit Wertzustand 00
    • Linienfarbe aus ALC nicht aktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe: grün
    • Farbe unbespannt und Konstruktionsfarbe der Linie: weiß
    • definierte Linien- und Füllfarben des Combielements: schwarz
    • Schalterzustand: aus/offen (Wert 0)

Beispiel 4

Combi-Element Wertzustand 01 ohne Farben aus ALC:

  1. Projektierung im Editor
    • Combielement mit Wertzustand 01
    • Linienfarbe aus ALC inaktiv
    • Füllfarbe aus ALC inaktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe = grün
    • Farbe unbespannt und Konstruktionsfarbe der Linie: weiß
    • definierte Linien- und Füllfarben des Combielements: schwarz
    • Schalterzustand: ein/geschlossen (Wert 1)


Anschlusspunkte bei verfahrenstechnischen Elementen

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente -> Anschlusspunkte bei verfahrenstechnischen Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Projektieren erfolgt der Anschluss einer Leitung (z.B. Linie) an ein verfahrenstechnisches Element (Combi-Element) durch überlappende Projektierung im Bild an so genannnten 'Fangpunkten' am Combi-Element. Bei jedem Anschlusspunkt kann nur eine Leitungen gleichzeitig 'angeschlossen' werden. Alle Leitungen, deren Leitungsanfänge sich im unten definierten Bereich befinden, gelten als angeschlossen (Topologie aus Grafik).

attention Achtung

Verwenden Sie ALC Elemente nur im ungedrehten Zustand, denn:

Die Berechnung des Topologischen Modells für ALC erfolgt im Editor auf Basis der Positionen der Elemente im ungedrehten Zustand und ohne Berücksichtigung etwaiger Dynamiken.

In der folgenden Grafik werden die möglichen Anschlusspunkte genauer dargestellt:

X = 1/3 Breite

Y = 1/3 Breite (max. 10 Pixel)

Z = 1/3 Höhe

W = 1/3 Höhe (max. 10 Pixel)

info Info

Befindet sich eine Leitung außerhalb des oben dargestellten Bereichs, wird keine Verbindung erkannt und es erfolgt daher keine Einfärbung der Leitung. Auch für alle nachfolgenden Leitungen wird damit die Einfärbung nicht stimmen.

Bei Quellen, Senken und bei Links können prinzipiell alle beschriebenen Anschlusspunkte verwendet werden.

attention Achtung

Bei Quellen und Senken darf immer nur ein einziger Anschlusspunkt gleichzeitig verwendet werden (welcher ist egal). Werden mehrere Anschlusspunkte gleichzeitig benutzt, kann es zu undefinierten Zuständen kommen.

Bei Elementen des Typs 'Link' können auch mehrere Anschlusspunkte gleichzeitig verwendet werden. Die eingehenden Farbinformationen werden gleichmäßig auf alle Leitungen verteilt.

Bei Schaltern/Trennern/Schiebern und Trafos erfolgt der Anschluss 1 (Versorgung) links oder oben und Anschluss 2 (Abgang) rechts oder unten. Diese Reihenfolge kann mit der Eigenschaft Eingang/Ausgang tauschen geändert werden.

Interne ID: Anschlusspunkte bei verfahrenstechnischen Elementen

Eingang/Ausgang tauschen

Nur verfügbar, wenn als Funktionstyp Trafo, Schalter, Schieber oder Trenner eingestellt wurde.

Interne ID: Anschlusspunkte bei verfahrenstechnischen Elementen

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Verschiebt den Eingang des ALC-Elements nach rechts oder unten und den Ausgang nach links oder oben.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Bei Schaltern und Trafos muss darauf geachtet werden, dass jeweils nur ein Versorgungsanschlusspunkt und ein Abgangsanschlusspunkt verwendet wird. Die gleichzeitige Verwendung mehrerer Versorgungs- oder Abgangversorgungspunkten führt zur Inkonsistenz und ist daher nicht zulässig.

info Info

Für alle verfahrenstechnische Elemente gilt: Pro Anschlusspunkt darf nur eine einzige Leitung angeschlossen werden. Abzweigungen können nicht direkt am Element realisiert werden, sondern müssen mit Hilfe von Leitungen projektiert werden.


Eingang/Ausgang tauschen

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente -> Eingang/Ausgang tauschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein Trafo, ein Trenner oder ein Schalter projektiert wird, können Eingang und Ausgang vertauscht werden. Dazu:

  1. wählen Sie als Funktionstyp entweder Trafo, Trenner oder Schalter

    Interne ID: Eingang/Ausgang tauschen

    Funktionstyp

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
    Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
    Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
    Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
    keine Funktion: Das Element hat im ALC keine Funktion.
    Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
    Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
    Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
    Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
    Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
    Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
    Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. aktivieren Sie cie Checkbox Eingang/Ausgang tauschen

    Interne ID: Eingang/Ausgang tauschen

    Eingang/Ausgang tauschen

    Nur verfügbar, wenn als Funktionstyp Trafo, Schalter, Schieber oder Trenner eingestellt wurde.

    Aktiv: Verschiebt den Eingang des ALC-Elements nach rechts oder unten und den Ausgang nach links oder oben.

    Default: inaktiv

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Eingang wird dann rechts oder unten und der Ausgang links oder oben gesetzt.

Überblick

Konfiguration Gerät | Eingang | Ausgang
normal | links | rechts
normal | oben | unten
getauscht | rechts | links
getauscht | unten | oben


Leitungen

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Leitungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Leitungen werden durch die Vektorelemente Linie, Polylinie und Rohrleitung repräsentiert.

Ist für eine Leitung die Eigenschaft Farben aus ALC aktiviert, so wird die Farbgebung aus der ALC-Konfiguration bestimmt. Leitungen werden je nach Zustand der verfahrenstechnischen Elemente und der ALC-Einstellungen automatisch vom System eingefärbt.

Dabei wird die Farbe im Normalfall von der höchst-prioren Quellennummer, des durch die Leitung fließenden Mediums, bestimmt, bzw. bleibt bei 'leer/unbespannt' so wie im Bild bei 'Farben statisch' oder bei 'Farben dynamisch' projektiert.

Die Darstellungsart definieren Sie über die Dropdownlisten:

  • Vorrang bei Darstellung
  • Mehrfachversorgung darstellen
  • Gesicherte Versorgung darstellen

In den Eigenschaften der Leitungen stehen Ihnen folgende Optionen zur Verfügung:

Parameter

Beschreibung

Farbe aus ALC

Interne ID: Leitungen

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiviert die automatische Linienfärbung für dieses Vektorelement. Das bedeutet: Ist die Quelle, die die Leitung versorgt aktiv, und sind alle Schalter/Ventile, die von der Quelle zur Leitung führen, geschlossen, so wird die Leitung eingefärbt. Bei Versorgung der Leitung durch nur eine einzige Quelle wird die projektierte Quellenfarbe zur Einfärbung verwendet. Die Linienbreite wird nicht beeinflusst.

Vorrang bei Darstellung

Interne ID: Leitungen

Vorrang bei Darstellung

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.

Definiert den Vorrang der Darstellung, wenn das Element mit mehreren aktiven Quellen verbunden ist.
Mehrfachversorgung: Das Element wird entsprechend den Regeln der Mehrfachversorgung dargestellt.
gesicherte Versorgung: Das Element wird entsprechend den Regeln der gesicherten Versorgung dargestellt.
Kein Vorrang: Die Einfärberegeln für Mehrfachversorgung und für Gesicherte Versorgung werden gleichzeitig angewandt, falls beide Kriterien erfüllt werden

Default: Mehrfachversorgung
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Definiert, ob Mehrfachversorgung, gesicherte Versorgung oder beide dargestellt werden.
Default: Mehrfachversorgung

Gesicherte Versorgung

Das Element wird entsprechend den Regeln der gesicherten Versorgung dargestellt.

Eine Leitung gilt dann als gesichert versorgt, wenn sie von mindestens zwei verschiedenen Schaltern oder Trafos mit einer Nicht-Systemquelle versorgt wird. Systemquellen tragen nicht zur gesicherten Versorgung bei, schließen sie aber auch nicht aus.

Mehrfachversorgung

Das Element wird entsprechend den Regeln der Mehrfachversorgung dargestellt.

Eine Leitung gilt dann als mehrfach versorgt, wenn sie von mindestens zwei verschiedenen Quellen versorgt wird. Dabei ist ohne Belang, ob es sich um System- oder um Benutzerquellen handelt und von welcher Seite die Leitung von den Quellen versorgt wird.

kein Vorrang

Die Einfärberegeln für Mehrfachversorgung und für Gesicherte Versorgung werden gleichzeitig angewandt, falls beide Kriterien erfüllt werden. Das bedeutet:

Ist eine Leitung

  • mehrfach und gesichert versorgt,
  • der Vorrang auf kein Vorrang eingestellt,
  • die Darstellung für Mehrfachversorgung auf zwei höchstpriore Quellen gesetzt,
  • die Darstellung für gesicherte Versorgung auf doppelte Breite gesetzt,

dann wird die Linie doppelt breit und zweifärbig gestrichelt dargestellt.

Mehrfachversorgung darstellen

Interne ID: Leitungen

Mehrfachversorgung darstellen

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.
Definiert die Darstellungsart, wenn das Element mit mehreren aktiven Quellen verbunden ist:
höchst-priore Quelle: Es wird nur die Farbe der Quelle mit der höchsten Priorität verwendet.
zwei höchst-priore Quellen: Die unterschiedlichen Farben der beiden Quellen mit der höchsten Priorität werden strichliert dargestellt.
alternative Farbe: Alternative Farbe für die Einfärbung bei Mehrfachversorgung.

Default: höchst-priore Quelle

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wird eine Leitung durch mehrere unterschiedliche Quellen gleichzeitig versorgt, spricht man von einer Mehrfachversorgung. Hier definieren Sie, wie mehrfach versorgte Leitungen dargestellt werden.

Default: höchst-priore Quelle

höchst-priore Quelle

Die Leitung übernimmt immer die Linienfarbe jener Quelle, die die höchste Priorität hat.
Hinweis: Prioritäten entsprechen der in der ALC Konfiguration gewählten Reihenfolge.

zwei höchst-priore Quellen

Relevant für Leitungen, die durch zwei oder mehrere unterschiedliche Quellen gespeist werden. Die zwei Quellen mit der höchsten Priorität bestimmen die Farbgebung. Die Leitung wird mit diesen beiden Farben gestreift dargestellt. Die Strichelungslänge kann über die Eigenschaft Strichelungslänge mehrfachversorgt festgelegt werden.

Interne ID: Leitungen

Strichelungslänge mehrfachversorgt

Nur verfügbar, wenn die Eigenschaft Mehrfachversorgung darstellen den Wert zwei höchstpriore Quellen hat.

Definiert die Strichelungslänge in Pixel für die gestrichelte ALC-Einfärbung bei Mehrfachversorgung.

Minmal: 0 (automatische Strichelungslänge)

Maximal: 32767

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Systemquellen gelten bei Mehrfachversorgung wie echte Quellen und färben Linien zweifärbig, falls sie entsprechend konfiguriert wurden.

alternative Farbe

Die in der Eigenschaft Alternative Farbe definierte Farbe wird verwendet.

Interne ID: Leitungen

Alternative Farbe

Nur verfügbar, wenn die Eigenschaft Mehrfachversorgung darstellen den Wert alternative Farbe hat.

Alternative Farbe für die ALC Einfärbung bei Mehrfachversorgung.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Strichelungslänge mehrfachversorgt

Definiert die Strichelungslänge in Pixel von Linien, Polylinien oder Rohrleitungen für die gestrichelte ALC-Einfärbung bei zwei höchstpriore Quellen für Mehrfachversorgung darstellen.

  • Minmal: 0 (automatische Strichelungslänge)
  • Maximal: 32767
  • Default: 0

Alternative Farbe

Alternative Farbe für die ALC Einfärbung von Linien, Polylinien oder Rohrleitungen bei Mehrfachversorgung.

gesicherte Versorgung darstellen

Interne ID: Leitungen

gesicherte Versorgung darstellen

Steht nur zur Verfügung, wenn Farbe aus ALC aktiviert wurde.

Auswahl, wie die gesicherte Versorgung dargestellt werden soll:

  • doppelte Breite
  • doppelte Helligkeit
  • normal

Default: normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wird eine Leitung durch eine einzige Quelle mehrfach (parallel) versorgt, spricht man von einer 'Gesicherten Versorgung'. Hier definieren Sie wie 'Gesicherte Versorgung' dargestellt wird.

Eine Leitung wird immer dann gesichert versorgt dargestellt, wenn sie von mindestens zwei Schaltern mit einer echten Quelle (nicht Systemquelle) versorgt wird.

Default: normal

doppelte Breite

Relevant für Leitungen, die von ein und derselben Quelle mehrfach (gesichert) versorgt werden. Ist das der Fall, wird die Leitung mit der doppelten projektierten Breite gezeichnet. (Beispiel: Eine Leitung mit Linienbreite 5 wird bei gesicherter Versorgung mit Linienbreite 10 dargestellt).
Wird diese Leitung durch zwei oder mehrere unterschiedliche Quellen (Mehrfachversorgung) versorgt, ändert sich die Linienbreite nicht!

Die Farbe wird immer durch die höchst-priore Quelle vorgegeben!

doppelte Helligkeit

Relevant für Leitungen, die von ein und derselben Quelle mehrfach (gesichert) versorgt werden. Ist das der Fall wird die Leitung mit der doppelten projektierten Helligkeit gezeichnet.
Wird diese Leitung durch zwei oder mehrere unterschiedliche Quellen (Mehrfachversorgung) versorgt, ändert sich die Linienfarbe nicht!
Wird diese Leitung von einer einzigen Quelle (gesicherte Versorgung) mehrfach versorgt, so wird die Leitung mit doppelter Helligkeit gezeichnet.
Formel für die Berechnung der doppelten Helligkeit:

  1. Die eingestellte RGB-Farbe wird in den HLS Farbraum umgerechnet.
  2. L (also Luminanz = Helligkeit) wird neu berechnen mit NeueLuminanz = 240*3/4 + L/4
  3. Der Farbwert wird mit der neuen Helligkeit wieder in den RGB Farbraum zurückgerechnet.

Die Farbe wird immer durch die höchst-priore Quelle vorgegeben!

normal

Das Element wird in der Farbe der Quelle und der projektierten Breite dargestellt.

Alias verwenden

Interne ID: Leitungen

Alias verwenden

Nur verfügbar, wenn Farbe aus ALC aktiv ist.
Aktiv: Alias wird verwendet. Das Element bezieht zur Runtime seine ALC-Farbe von einem anderen Element im topologischen Modell, ohne selbst Teil des Modells zu sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: ALias wird benutzt.

Alias

Interne ID: Leitungen

Alias

Nur verfügbar, wenn Farbe aus ALC aktiv ist.

Definiert Quellelement für Alias verwenden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines vorhandenen Elements.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Öffnet Dialog zur Auswahl eines Alias

info Info

Die Quellenfarben und die Prioritäten der Quellen werden bei den Projekteigenschaften eingestellt.

Benutzerdefinierte Quellen müssen eine ID höher als 9 haben. IDs bis 9 sind für Systemquellen reserviert.

info Info

Die Berechnung der Farbe einer Leitung zur Runtime wird nach folgender Prioritätenliste durchgeführt:

  1. Automatic Line Coloring (höchste Priorität, überlagert alle anderen Einstellungen)
  2. Farben dynamisch
  3. Farben statisch

Noch in diesem Kapitel

Beispiel

Anschlusspunkte bei Leitungen


Beispiel

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Leitungen -> Beispiel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es wird im Folgenden angenommen, dass der 'Quelle 0' die Farbe blau zugewiesen ist, während 'Quelle 1' die Farbe rot hat. Außerdem ist 'Quelle 0' die höchstpriore Quelle.

Quelle 0

Quelle 1

Daraus ergeben sich für die verschiedenen Optionen folgende beispielhafte Darstellungen:

 | Linie / Polylinie | Rohrleitung
höchst-priore Quelle |  |
zwei höchst-priore Quellen |  |
doppelte Breite |  |
doppelte Helligkeit |  |


Anschlusspunkte bei Leitungen

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Leitungen -> Anschlusspunkte bei Leitungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Projektieren erfolgt der Anschluss einer Leitung (Linie, Polylinie oder Rohrleitung) an eine weitere Leitung durch überlappende Projektierung im Bild an so genannten 'Fangpunkte' der Leitungen. Die Fangpunkte - eigentlich sind es Fangbereiche - befinden sich jeweils am Anfang und am Ende einer jeden Leitung und sind am Anfangs- bzw. Endpunkt jeweils ± 3 Pixel groß.

Example Beispiel

Der Anfangspunkt einer Leitung hat die Koordinaten (Startpunkt x/ Startpunkt y): 150/100 Pixel.
Daraus ergibt sich ein Fangbereich von (x / y): 147 - 153 / 97 - 103 Pixel.

Befindet sich der Leitungsanfang oder das Ende dieser Leitung, einer oder mehrerer weiteren Leitungen innerhalb dieses Bereichs, wird automatisch eine Verknüpfung hergestellt, ohne dass es dafür weiterer Einstellungen bedarf. Eine reine Überlappung der Fangbereiche der einzelnen Linien ist nicht ausreichend!

In der folgenden Grafik wird der Fangbereich grafisch dargestellt (Die grünen Leitungen haben mit der schwarzen Leitung eine Verbindung, die rote Leitung nicht.):

info Info

An jedem Fangpunkt können beliebig viele Leitungen miteinander verbunden werden.

attention Achtung

Befindet sich eine Leitung außerhalb des oben dargestellten Fangbereichs (z.B. die roten Leitungen in der Grafik), wird keine Verbindung erkannt und es erfolgt daher keine Einfärbung der Leitung. Auch für alle nachfolgenden Leitungen wird damit die Einfärbung nicht stimmen.

Leitungskreuzungen lassen sich sehr einfach realisieren, indem die Enden der Leitungen sich nicht im Fangbereich befinden:

attention Achtung

Verwenden Sie ALC Elemente nur im ungedrehten Zustand, denn:

Die Berechnung des Topologischen Modells für ALC erfolgt im Editor auf Basis der Positionen der Elemente im ungedrehten Zustand und ohne Berücksichtigung etwaiger Dynamiken.


Überprüfung der Projektierung

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Überprüfung der Projektierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projektieren Sie die gewünschten verfahrenstechnischen Elemente und Leitungen in einem oder mehreren Bildern und speichern Sie diese Bilder. Jetzt können Sie mithilfe von Alle Runtime-Dateien erzeugen oder Geänderte Runtime-Daten erzeugen überprüfen, ob in Ihren Bildern Fehler oder Konflikte vorhanden sind. Sollten Fehler und/oder Konflikte vorhanden sein, werden entsprechenden Fehlermeldungen oder Warnungen im Ausgabefenster angezeigt.

info Info

Klicken Sie die entsprechende Zeile im Ausgabefenster doppelt an. Das Bild mit dem fehlerhaften Bildelement wird automatisch geöffnet. Wenn sich das fehlerhafte Bildelement in einem Symbol befindet, wird automatisch das entsprechenden Symbol selektiert.

Folgende Fehlermeldungen können angezeigt werden.

  • ALC: Bild '%s' - An der Leitung '%s' sind zwei Link-Elemente mit unterschiedlicher Link-Nummer angeschlossen. (Doppelklick öffnet das Bild und selektiert die Leitung)
  • ALC: Bild '%s' - Am Element '%s' sind mehr als zwei Anschlusspunkte belegt. Pro Element darf jeweils nur ein Eingang und ein Ausgang verwendet werden. (Doppelklick öffnet das Bild und selektiert das Element

Folgende Warnungen können angezeigt werden.

  • ALC: Bild '%s' - Die Alias-Leitung '%s' ist an eine nicht Alias-Leitung angeschlossen. (Doppelklick öffnet das Bild und selektiert die Leitung)
  • ALC: Bild '%s' - Das Alias-Element '%s' ist an eine Nicht-Alias-Leitung angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)
  • ALC: Bild '%s' - Das Nicht-Alias-Element '%s' ist an eine Alias-Leitung angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)
  • ALC: Bild '%s' - Die Leitung '%s' ist nur einseitig angeschlossen. (Doppelklick öffnet das Bild und selektiert die Leitung)
  • ALC: Bild '%s' - Das Element '%s' ist nicht angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)
  • ALC: Bild '%s' - Das Element '%s' ist nur einseitig angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)

In den Fehlermeldungen bzw. Warnungen werden die entsprechenden Elemente mithilfe der Element-Referenz identifiziert. Diese Referenz dient auch als Verknüpfungsschlüssel bei ALC-Aliasen.


Konfiguration

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Modus der Einfärbung für UNDEFINED

Konfiguration der Quellen

Konfiguration der Topologischen Verriegelung


Modus der Einfärbung für UNDEFINED

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Modus der Einfärbung für UNDEFINED

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Zustand UNDEFINED kann die Einfärbung des Netzes in zwei Modi erfolgen:

  • Standard
  • Versorgung vorrangig

Die Einstellung erfolgt über die Projekteigenschaft Automatic Line Coloring/Modus der Einfärbung.

Interne ID: Modus der Einfärbung für UNDEFINED

Modus der Einfärbung

Legt den Modus der Einfärbung für den Zustand UNDEFINED fest. Klick auf Dropdownliste öffnet Auswahl:

- Standard: Die Quellenfarbe wird ausgehend von jeder eingeschalteten Quelle im Netz verteilt, solange der nächste Schalter geschlossen ist.

- Versorgung vorrangig: Färbt nur Leitungen ein, die von zumindest einer Quelle potenziell versorgt sind, aber von keiner Quelle eindeutig.

Default: Standard

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Modus der Einfärbung für UNDEFINED

Automatic Line Coloring

Eigenschaften nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Eigenschaften für ALC.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Standard

Die Graphensuche beginnt bei einer Quelle und durchschreitet das gesamte Netz so, dass jeder geschlossene Schalter (Schaltervariable hat Wert 1) pro Richtung nur einmal durchwandert wird und somit keine Zyklen entstehen. Dabei wir jeder besuchte Knoten (=Leitungssegment) mit der Quellenfarbe eingefärbt. Als Knoten werden direkt zusammenhängende Leitungen/Linien bezeichnet.

Trifft die Suche auf einen Schalter, dessen Schaltervariable einen der folgenden Status hat, wird ab diesem Punkt die UNDEFINED Farbe zum Einfärben verwendet:

  • INVALID [Wert: beliebig],
  • ist gestört [Wert: 3]
  • ist in Zwischenstellung [Wert: 2])

Die Graphensuche wird ab nun in gleicher Form weitergeführt. Jeder Schalter wird pro Richtung nur einmal mit der UNDEFINED Farbe durchwandert. Damit kann jeder Schalter pro Quelle maximal vier Mal durchwandert werden:

  1. mit Quellennummer in Vorwärtsrichtung,
  2. mit Quellennummer in Rückwärtsrichtung,
  3. mit UNDEFINED in Vorwärtsrichtung,
  4. mit UNDEFINED in Rückwärtsrichtung

Versorgung vorrangig

Mit der Einstellung Versorgung vorrangig werden nur Leitungen als UNDEFINED eingefärbt, die von zumindest einer Quelle potenziell versorgt sind, aber von keiner Quelle eindeutig. Ist eine Leitung von zumindest einer Quelle eindeutig versorgt, so kann sie von einer anderen Quelle keinen UNDEFINED Einfärbung mehr erhalten.

Diese Suche erfolgt zweistufig:

  • Im ersten Schritt wird wie bei Standard von jeder eingeschalteten Quelle ausgehend die Quellenfarbe im Netz verteilt, solange der nächste Schalter geschlossen ist. Ist der Schalter geöffnet oder gestört/undefiniert, wird die Suche beendet.
  • Im zweiten Schritte wird die Suche bei jedem gestört/undefiniert Schalter begonnen, der einseitig versorgt ist, und die UNDEFINED Farbe auf der unversorgten Seite im Netz verteilt. Diese Suche betrachtet auch Schalter als geschlossen, die gestört/undefined sind und verbreitet somit die UNDEFINED Farbe so lange im Netz, bis sie auf einen eindeutig geöffneten Schalter stößt. Zusätzlich wird die Suche beendet, wenn ein Leitungssegment erreicht wird, welches bereits versorgt ist.


Konfiguration der Quellen

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Konfiguration der Quellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration der Quellen, z.B. deren Bezeichnung und Farben (Reihenfolge und Priorität), erfolgt projektbezogen in den Projekteigenschaften unter ALC Konfiguration.

Für jede einzelne Quelle können folgende Parameter konfiguriert werden:

Parameter

Beschreibung

Nummer

Interne eindeutige fortlaufende Nummer, damit die Quellen eindeutig zugeordnet werden können. Diese Nummer wird vom System automatisch vergeben, und kann nicht geändert werden.

Achtung: Die IDs 0 bis 9 sind für Systemquellen reserviert und dürfen nicht benutzerspezifisch verwendet werden.

Name

Logische Bezeichnung für die Quelle (z.B.: 'Wasser' oder 'geerdet'). Diese Bezeichnung wird auch bei der Auswahl der Quelle beim Combi-Elementen verwendet. Die Bezeichnung können Sie ändern, indem Sie mit der linken Maustaste die Quellenbezeichnung anklicken. Dadurch wird in einen Editiermodus umgeschaltet. Mit der 'Enter' Taste oder durch Selektion einer anderen Quelle wird die Änderung übernommen.

Hinweis: Die Bezeichnungen sind nicht sprachumschaltbar.

Vordergrund

Vordergrundfarbe der jeweiligen Quelle. Diese wird für das Zeichnen von Linien, Polylinien sowie als äußere Farbe für Rohrleitungen verwendet.

Hintergrund

Hintergrundfarbe der jeweiligen Quelle. Diese wird als Hintergrundfarbe bei Rohrleitungen und verfahrenstechnischen Elementen (Combi-Element) verwendet.

Die Konfiguration der Farben kann direkt über die Eingabe des entsprechenden Hexadezimal-Codes erfolgen. Dazu klicken Sie mit der linken Maustaste die Farbbezeichnung an, dann wird in einen Editiermodus umgeschaltet. Mit der 'Enter' Taste oder durch Selektion einer anderen Quelle wird die Änderung auch hier übernommen.

Alternativ kann die Farbauswahl auch mittels eines Dialoges getroffen werden. Bei aktivieren des Hexadezimal-Codes erscheint in dieser Spalte die Schaltfläche ... Beim Anklicken dieser gelangen Sie jetzt in die Farbauswahl.

Der hexadezimale Farbcode beschreibt einen RGB Farbwert und setzt sich wie folgt zusammen: #RRGGBB.

Element | Bedeutung
# | Kennzeichnung dafür, dass ein Hexadezimaler Farbcode verwendet wird.
RR | 2 Stellen für den Rotwert der Farbe in Hexadezimaler Nomenklatur. 0-255 entspricht 0-FF
GG | 2 Stellen für den Grünwert der Farbe in Hexadezimaler Nomenklatur. 0-255 entspricht 0-FF
BB | 2 Stellen für den Blauwert der Farbe in Hexadezimaler Nomenklatur. 0-255 entspricht 0-FF

Mit den Schaltflächen Neu und Löschen werden neue Quellen angelegt bzw. bestehende Quellen gelöscht.

attention Achtung

Einschränkungen beim Löschen der Quellen:

Die Quellen mit der ID 0 bis 9 sind für Systemquellen reserviert und können nicht gelöscht werden.

Nur die Quelle mit der höchsten ID kann gelöscht werden.

info Info

Die Reihenfolge in dieser Liste entspricht der Priorität der Quellen, wobei das erste Element die höchste Priorität erhält.

Um die Prioritäten der einzelnen Quellen untereinander zu verändern, können Sie diese mit den Pfeil-Schaltflächen durchführen.


Konfiguration der Topologischen Verriegelung

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Konfiguration der Topologischen Verriegelung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit können topologische Verriegelungen aus der ALC für die Befehlsgabe konfiguriert werden.

info Info

Dieser Dialog ist nur verfügbar, wenn sowohl die Energy Edition als auch das Modul Automatic Line Coloring lizenziert sind (Topologiepaket).

Folgende Bedingungen stehen dabei zur Verfügung. Die hier getroffenen Einstellungen gelten global für das gesamte Topologische Modell:

Parameter | Beschreibung
Spannung gegen Erde | Verriegelung ist aktiv, wenn ein Schalter/Trenner geschlossen werden soll, an dessen einem Anschluss geerdetes Potential anliegt und dessen anderer Anschluss bespannt oder undefiniert ist.
Schalthandlung in Gebiet mit undefiniertem Zustand | Verriegelung ist aktiv, wenn ein Schalter/Trenner geschlossen werden soll, bei dem beide Anschlüsse auf 'undefiniert' oder 'gestört' liegen.
Trenner unter Last | Verriegelung ist aktiv, wenn für das Einschalten bzw. Ausschalten bestimmte Bedingungen erfüllt werden. Bedingungen: siehe Abschnitt "Trenner unter Last - Verriegelungsbedingungen".
Verbraucher würde nicht mehr versorgt werden | Verriegelung ist aktiv, falls nach der Schalthandlung (mittels Schalter oder Trenner) eingeschalteter Verbraucher spannungslos wäre der vorher versorgt war.
Bereich mit undefiniertem Zustand würde größer werden | Verriegelung ist aktiv, wenn ein Schalter/Trenner geschlossen werden soll, bei dem ein Anschluss auf 'undefiniert' oder 'gestört' liegt und der andere nicht.

Wenn Sie bei einer dieser Verriegelungen in die Spalte Status klicken, öffnet sich eine Dropdownliste mit drei Auswahlmöglichkeiten:

Parameter | Beschreibung
nicht prüfen | Die ausgewählte Bedingung wird in diesem Projekt (topologischen Modell) nicht berücksichtigt.
entriegelbar | Die ausgewählte Bedingung wird in diesem Projekt überprüft. Trifft die Bedingung zu, so kann sie der Benutzer mithilfe der Befehlsgabe entriegeln (Bild vom Typ Befehlsgabe). Die Entriegelung wird in der Chronologischen Ereignisliste mitprotokolliert.
nicht entriegelbar | Die ausgewählte Bedingung wird in diesem Projekt überprüft. Der Benutzer kann sie nicht entriegeln.

Ausnahme Topologische Verriegelung

Die Topologische Verriegelung wird nicht ausgeführt, wenn:

  • die Variable eines Schalters den Status Revision hat
    oder
  • die Variable handnachgeführt oder auf Ersatzwert eingestellt wird und dabei auf den selben Variablenwert geschaltet wird wie der Ausgangswert, also wenn der Schalter:
    • auf AUS ist und danach auf AUS nachgeführt oder ersetzt wird
    • auf EIN ist und danach auf EIN nachgeführt bzw. ersetzt wird

Noch in diesem Kapitel

Trenner unter Last - Verriegelungsbedingungen


Trenner unter Last - Verriegelungsbedingungen

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Konfiguration der Topologischen Verriegelung -> Trenner unter Last - Verriegelungsbedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Topologische Verriegelung Trenner unter Last darf ein Trenner geschaltet werden, wenn eine der folgenden Bedingungen zutrifft:

Beim Einschalten:

Vor dem Schalten:

  • sind das linke und das rechte Leitungssegment von der gleichen Quelle bespannt
  • ist das linke Leitungssegment spannungsfrei, das rechte Leitungssegment geerdet
  • ist das linke Leitungssegment geerdet, das rechte Leitungssegment spannungsfrei
  • ist das linke Leitungssegment unbelastet
  • ist das rechte Leitungssegment unbelastet

Beim Ausschalten:

Nach dem Schalten:

  • wären das linke und das rechte Leitungssegment von der gleichen Quelle bespannt
  • wäre das linke Leitungssegment spannungsfrei, das rechte Leitungssegment geerdet
  • wäre das linke Leitungssegment geerdet, das rechte Leitungssegment spannungsfrei
  • wäre das linke Leitungssegment unbelastet
  • wäre das rechte Leitungssegment unbelastet

info Info

Bedeutung von "unbelastet"

Für den Zustand unbelastet müssen alle diese Bedingungen erfüllt werden:

  • Alle am Leitungssegment angeschlossenen Schalter und Trenner sind geöffnet.
  • Alle am Leitungssegment angeschlossenen Quellen und Verbraucher sind ausgeschaltet.
  • Es darf kein Trafo am Leitungssegment angeschlossen sein.
  • Es darf sich nicht um einen Leitung handeln, an der ausschließlich dieser Trenner angeschlossen ist (offene Leitung).


ALC-Quellenfarbe ändern

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> ALC-Quellenfarbe ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion ALC-Quellenfarbe ändern kann die Vordergrund- und Hintergrundfarbe einer ALC-Quelle für die Einfärbung zur Runtime vorübergehend geändert werden. Die Änderung bleibt bis zum Beenden der Runtime, Nachladen oder erneuten Ausführung der Funktion geändert. Um die Funktion zu erstellen:

Interne ID: ALC-Quellenfarbe ändern

ALC-Quellenfarbe ändern

Funktion zur Konfiguration der ALC-Quellenfarben bei Fehlerortung in elektrischen Netzen.

Mehr im Online-Handbuch.

  • wählen Sie Funktion neu
  • navigieren Sie zum Knoten Bilder
  • wählen Sie ALC-Quellenfarbe ändern

  • der Dialog zur Definition der Linienfarbe und der Füllfarbe öffnet sich
  • definieren Sie die gewünschten Farben

Eigenschaft | Funktion
Quelle | Dropdownliste zur Auswahl der Quelle und Anzeige der aktuell zugewiesenen Farben. Diese Farben sind hier nicht änderbar.
Neue Farbe für Quelle | Klick auf Farbe öffnet Dialog zur Auswahl einer Farbe.


Detailbilder

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Detailbilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Darstellung von Einzelbildern kann mit der Hilfe von Alias ein Teilbereich aus dem Topologischen Netz herausgenommen und einzeln dargestellt werden. Die Bildelemente im Detailbild werden zwar nicht in das topologische Model mit aufgenommen, beziehen aber trotzdem ihre ALC-Farben aus dem Modell. Sie beziehen sich dazu auf einen Alias der Bildelemente aus dem Gesamtbild.

Alias anlegen

Alias können angelegt werden für die Elemente:

  • Linie
  • Polylinie
  • Rohrleitung
  • Combi-Element

Um ein Quellelement als Alias anzulegen:

  • aktivieren Sie in den Eigenschaften des Elements Alias verwenden

    Interne ID: Detailbilder

    Alias verwenden

    Nur verfügbar, wenn Farbe aus ALC aktiv ist.
    Aktiv: Alias wird verwendet. Das Element bezieht zur Runtime seine ALC-Farbe von einem anderen Element im topologischen Modell, ohne selbst Teil des Modells zu sein.

    Interne ID: Detailbilder

    Farbe aus ALC

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
    Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
    Inaktiv: Die Standard-Farbe wird verwendet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    (dazu muss ALC lizenziert sein und die Eigenschaft Farbe aus ALC aktiv)

  • klicken Sie bei der Eigenschaft Alias auf die Schaltfläche ...

    Interne ID: Detailbilder

    Alias

    Nur verfügbar, wenn Farbe aus ALC aktiv ist.

    Definiert Quellelement für Alias verwenden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines vorhandenen Elements.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Dialog zur Auswahl des Elements öffnet sich

Parameter

Beschreibung

Bild

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Bildes.

Verfügbare ALC-Elemente

Zeigt die zum Bild gehörigen Elemente mit Elementname, Art des Elements und Funktionstyp an. Klick auf ein Element wählt Alias aus.

Filter

Die Elemente können nach allen Spalten gefiltert werden. Beim Setzen eines Filters werden die angebotenen Möglichkeiten aller anderen Filter auf sinnvoll kombinierbare Werte reduziert.

  • Name: Eingabe eines freien Suchbegriffs mit Wildcards (*). Die letzten 12 Suchbegriffe werden bis zum Beenden des Editors in einer Liste angeboten.
  • Element: Auswahl aus Dropdownliste.
  • Funktionstyp: Auswahl aus Dropdownliste.

Klick auf ... öffnet gespeicherte Suche bzw. Dropdownliste.

Bei aktiviertem Filter löscht Klick auf Schaltfläche X den Filter.

Ausgewählter Alias

Zeigt das im Feld Verfügbare ALC-Elemente ausgewählte Element an.

Keine Auswahl

Entfernt ausgewähltes Element.

OK

Speichert Auswahl und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.

info Info

Bei der Auswahl eines Elements für einen Alias können nur Elemente und Bilder aus dem selben Projekt gewählt werden, in dem der Alias definiert wird. Elemente aus Unterprojekten oder parallelen Projekten stehen nicht zur Verfügung.

Ersetzung von Aliasnamen

Alias können bei der Bildumschaltung über Verknüpfung ersetzen ausgetauscht werden. Ein Detailbild kann daher mit den Daten unterschiedlicher Anlagenteile, z.B. Abgängen oder Teilnetzen, dargestellt werden. Die Ersetzung von Aliasnamen erfolgt analog zu jener von Variablen und Funktionen. Auch die Ersetzung in Elementen, die in Symbolen verwendet werden, ist möglich. Als Auswahldialog für das Ziel wird der gleiche Dialog wie bei der Eigenschaft Alias geöffnet.

Hinweis: Die Substituierung über Indexvariablen ist nicht möglich.


Fehlerortung in elektrischen Netzen

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Fehlerortung kennzeichnet Netzteile, die mit Erdschlusss oder Kurzschluss behaftet sind, durch spezielle Einfärbungen im ALC. Quellen für die Fehlersuche sind so genannte Erdschluss- bzw. Kurzschlussmelder, die einem Leistungsschalter zugeordnet sind. Erdschluss- und Kurzschlussmelder befinden sich immer am Ausgang des Leistungsschalter-Elements. Fehleranzeigen sind im Bild fixiert und müssen manuell zurückgesetzt werden.

info Info

Diese Funktionalität ist nur verfügbar, wenn sowohl die Energy Edition als auch das Modul Automatic Line Coloring lizenziert sind (Topologiepaket).

Fehlerortung

Die Fehlerortung läuft lokal. Jeder Client im Netzwerkbetrieb hat sein unabhängiges Modell und kann somit unabhängig Erd- und Kurzschlüsse in verschiedenen Netzteilen suchen.

Die Fehlerortung in elektrischen Netzen teilt sich in:

  • Erdschlusssuche
  • Kurzschlusssuche

Um die Fehlerortung zur projektieren

  • benötigen Sie eine Lizenz für ALC und zenon Energy Edition
  • legen Sie die entsprechenden Bilder an
  • konfigurieren Sie ALC auf den entsprechenden Combi-Elementen (Schalter, Trafos, Trenner, Schieber)
  • konfigurieren Sie Leitungen so, dass sie ihre Einfärbung über ALC erhalten

Für die Fehlerortung stehen Ihnen zur Runtime spezielle Funktionen zur Verfügung:

  • Erdschlusssuche starten
  • Erdschlussmeldung quittieren
  • Erdschlusssuche beenden
  • Kurzschlussmeldung quittieren

Einfärbungen

Fehler lassen sich durch eine spezielle Einfärbung der Leitungen im ALC anzeigen. Zur Runtime wechselt die per ALC zugewiesene Farbe automatisch sobald sich der Zustand der Leitung ändert. Die projektierten Einfärbungen können zur Runtime vorübergehend über die Funktion ALC-Quellenfarbe ändern geändert werden.

Meldungen werden in der Reihenfolge ihres Eintreffens bearbeitet. Bei Konflikten

  • haben die Farben für Fehleranzeige den Vorrang
  • haben Kurzschlussmeldungen Vorrang vor Erdschlussmeldungen

Noch in diesem Kapitel

Erdschlusssuche

Kurzschlusssuche


Erdschlusssuche

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Erdschlusssuche dient dazu, potenziell erdschlussbehaftete Netzteile durch Einfärbung zu markieren. Die Farbe wird aus der Projektierung der ALC-Quellenfarben für die Quelle GROUND FAULT bezogen.

Welche Netzteile potenziell erdschlussbehaftet sind, wird aus den Erdschlussmeldungen von Erdschlusserkennungsgeräten (Erdschlusssanzeiger, Schutzgerät mit Erdschlussserfassung) abgeleitet. Für Erdschlussmeldungen gilt:

  • Jedes Gerät kann ein bis drei Erdschlussmeldungen besitzen.
  • Erdschlussmeldungen werden entweder per Dauermeldungsverarbeitung oder per Wischermeldungsverarbeitung behandelt.
  • Bei Erdschlusserkennungsgeräten mit Richtung kann die Richtung vor- oder nacheilend zur Auslösung sein.
    • Voreilend: Zuerst kommt die Meldung, dann das Wischerbit.
    • Nacheilend: Zuerst kommt das Wischerbit, dann die Meldung.

info Info

Ein potenziell erdschlussbehafteter Netzteil wird erst dann als nicht mehr erdschlussbehaftet betrachtet, wenn dieser erfolgreich bespannt wurde.

Projektierung

Um die Erdschlusssuche zu projektieren:

  1. weisen Sie dem Combi-Element, das den Schalter repräsentiert, den Funktionstyp Schalter zu

    Interne ID: Erdschlusssuche

    Funktionstyp

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
    Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
    Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
    Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
    keine Funktion: Das Element hat im ALC keine Funktion.
    Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
    Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
    Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
    Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
    Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
    Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
    Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie Modus der Erdschlusssuche, Erschlusssanzeige und Erdschlusserkennung Auslösung
  3. legen Sie die Funktionen für Erdschlusssuche starten, Erschlusssmeldung quittieren und Erdschlusssuche beenden an

info Info

Um auch in vermaschten Netzen Erdschlüsse eingrenzen zu können, wird pro Pfad beginnend bei einer Quelle nur ein erdschlussbehafteter Bereich gesucht.

Noch in diesem Kapitel

Modus der Erdschlusssuche

Erdschlussserkennungstyp

Erschlussanzeige

Erdschlusserkennung Auslösung

Erdschlusssuche starten

Erschlusssmeldung quittieren

Erdschlusssuche beenden


Modus der Erdschlusssuche

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Modus der Erdschlusssuche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Erdschlusssuche kann wahlweise:

  • den potenziell erdschlussbehafteten Netzteil einfärben
    oder
  • das gesamte Netz, in dem sich ein Erdschluss befindet

Der Modus der Einfärbung wird definiert über die Eigenschaft Modus der Erdschlusssuche.

Interne ID: Modus der Erdschlusssuche

Modus der Erdschlusssuche

Legt fest, ob bei der Erdschlusssuche der potenziell erdschlussbehaftete Netzteil eingefärbt wird oder das gesamte Netz, in dem sich ein Erdschluss befindet.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um die Eigenschaft zu projektieren:

  • navigieren Sie in den Projekteigenschaften zum Knoten Automatic Line Coloring

    Interne ID: Modus der Erdschlusssuche

    Automatic Line Coloring

    Eigenschaften nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
    Eigenschaften für ALC.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • wählen Sie in der Dropdownliste der Eigenschaft Modus der Erdschlusssuche den gewünschten Modus
    • Netzteil einfärben: färbt nur den potenziell erdschlussbehaftete Netzteil ein
    • Ganzes netz einfärben: färbt das gesamte zusammenhängende Netz, in welchem sich ein Erdschluss befindet, ein

Diese Einstellung kann zur Laufzeit über das Objektmodell der zenon API geändert werden. Dabei wird die Erdschlusssuche komplett neu durchgerechnet.


Erdschlussserkennungstyp

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlussserkennungstyp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Einstellung Typ werden Richtung und Art der Meldungsverarbeitung für das Combi-Element vom Typ Schalter festgelegt. Zur Projektierung:

Interne ID: Erdschlussserkennungstyp

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Erdschlussserkennungstyp

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Erdschlussserkennungstyp

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Erdschlusserkennung

    Interne ID: Erdschlussserkennungstyp

    Erdschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Erdschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie bei der Eigenschaft Typ den gewünschten Typ mit Richtung und Art der Meldungsverarbeitung
    • Richtung:
      gibt an, ob die steigende Flanke der Auslösungsmeldung oder die steigende Flanke einer Richtung vorher kommt
    • voreilend: bei steigender Flanke der Auslösungsmeldung wird der aktuelle Zustand der Richtung verwendet
    • nacheilend: nach steigender Flanke der Auslösungsmeldung wird auf die erste steigende Flanke einer Richtung gewartet, trifft diese nicht innerhalb von 2 Sekunden ein, wird das Erdschlusserkennungsgerät als ungerichtet betrachtet
    • Meldungsverarbeitung:
      gibt an, wie Meldungen verarbeitet werden
    • keine: normaler Schalter, Meldungen werden nicht verarbeitet
    • Dauermeldungsverarbeitung: neu eintreffende Meldungen werden als neue Erdschlussauslösung berücksichtig
    • Wischermeldungsverarbeitung: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

Hinweis: Die Unterscheidung zwischen Dauermeldungsverarbeitung und Wischermeldungsverarbeitung bezieht sich nur auf die Verarbeitung der Meldung, nicht auf deren Art. Eine Wischermeldungsverarbeitung muss sich also nicht auf ein Wischer-Bit beziehen.

attention Achtung

Um intermittierende Erdschlüsse zu unterdrücken, werden Erdschlussmeldungen, die in kürzeren Abständen als 2s eintreffen, ignoriert.


Erschlussanzeige

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erschlussanzeige

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die bei Anzeige verknüpfte Variable ist eine Ausgangsvariable der Fehlerortung und zeigt den erfassten Zustand des Erdschlusserkennungsgeräts an. Das ist nötig, da alle Meldungen intern bis zum Quittieren gespeichert bleiben, also nicht zwingend dem aktuellen Zustand der Meldevariablen entsprechen.

Interne ID: Erschlussanzeige

Anzeige

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Ausgangsvariable der Fehlerortung fest, um den Zustand des Erdschlusserkennungsgeräts anzuzeigen. Die hier verknüpfte Variable sollte eine lokale Variable sein, um Probleme im Netzwerkbetrieb zu verhindern. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: Erschlussanzeige

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Erschlussanzeige

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei jeder Erfassung einer Änderung wird ein Sollwert auf diese Variable abgesetzt. Dabei sind die Werte wie folgt:

Wert | Bedeutung
0 | kein Erdschluss
1 | Erdschluss vorwärts
2 | Erdschluss rückwärts
3 | Erdschluss ungerichtet
4 | Fehlerzustand -> beide Richtungen haben angesprochen

info Info

Um Probleme im Netzwerkbetrieb zu verhindern, sollte die hier verknüpfte Variable eine lokale Variable sein.


Erdschlusserkennung Auslösung

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlusserkennung Auslösung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Auslösung wird die Variable für die Meldung des Erdschlusserkennungsgeräts definiert. Sie kann Informationen enthalten über das Vorhandensein eines Erdschlusses und die Richtung der Erdschlusses aus Sicht des Erdschlusserkennungsgeräts. Dabei wird unterschieden zwischen:

Interne ID: Erdschlusserkennung Auslösung

Auslösung

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable fest, die die Erkennung eines Erdschlusses anzeigt. Bei gerichteten Erdschlussmeldern muss zusätzlich die Richtung (Rückwärts oder Vorwärts) definiert werden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: Erdschlusserkennung Auslösung

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Erdschlusserkennung Auslösung

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Erdschlusserkennung Auslösung

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Erdschlusserkennung Auslösung

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ungerichteten Erdschlussmeldern
  • gerichteten Erdschlussmeldern mit Auslösemeldung
  • gerichteten Erdschlussmeldern ohne Auslösemeldung

Um die Variable für die Auslösung zu projektieren:

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Erdschlusserkennung Auslösung

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Erdschlusserkennung

    Interne ID: Erdschlusserkennung Auslösung

    Erdschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Erdschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. für ungerichtete Erdschlussmelder

      klicken Sie bei der Eigenschaft Auslösung auf die Schaltfläche ...

      wählen Sie im sich öffnenden Dialog die gewünschte Variable

      die Eigenschaften für die Richtung bleiben leer

    2. für gerichtete Erdschlussmelder mit Auslösemeldung

      verknüpfen Sie die Variable mit der Auslösung und ergänzen Sie die entsprechend Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

    3. für gerichtete Erdschlussmelder ohne Auslösemeldung

      verknüpfen Sie die Variable mit der entsprechenden Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

      die Eigenschaft Auslösung bleibt leer

Hinweis: Sprechen bei einem gerichteten Erdschlusserkennungsgerät mit Vorwärts beide Richtungen an, so wird dieses als fehlerhaft betrachtet und ignoriert.


Erdschlusssuche starten

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlusssuche starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Erdschlusssuche starten dient zur Lokalisierung eines Erdschlusses und hat zur Runtime zwei Auswirkungen:

Interne ID: Erdschlusssuche starten

Erdschlusssuche starten

Funktion zum Starten der Erdschlusssuche.

Mehr im Online-Handbuch.

  1. Meldungen aller Erdschlusserkennungsgeräte, die mit Wischermeldungsverarbeitung projektiert wurden, werden ignoriert.
  2. Der Suchalgorithmus wird geändert: Schalthandlungen können den erdschlussbehafteten Bereich nur noch verkleinern. Neu eintreffende Erdschlussmeldungen vergrößern den potenziell erdschlussbehafteten Bereich also nicht.

Um die Funktion Erdschlusssuche starten zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Erdschlusssuche starten

  • verknüpfen Sie die Funktion mit einem Button


Erschlusssmeldung quittieren

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erschlusssmeldung quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion Erdschlussmeldung quittieren kann zur Runtime ein intern erfasster Erdschluss eines Erdschlusserkennungsgeräts quittiert werden. Dabei wird der intern gelatchte Erdschlusszustand zurückgesetzt, wenn der Zustand noch ansteht, oder als quittiert markiert. Eine erfasste Erdschlussmeldung wird intern nur gelöscht, wenn diese quittiert ist und nicht mehr ansteht.

Interne ID: Erschlusssmeldung quittieren

Erdschlussmeldung quittieren

Funktion zum Quittieren einer Erdschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Regeln beim Quittieren:

  • Wurde eine Variable verknüpft, die einer Auslösungs- oder Richtungsvariable eines Erdschlusserkennungsgeräts entspricht, so wird nur diese spezielle Erdschlussmeldung quittiert.
  • Wurde keine Variable verknüpft, werden alle Erdschlussmeldungen quittiert.
  • Das Quittieren kann auch über das Objektmodell der zenon API erfolgen.

Um die Funktion Erdschlussmeldung quittieren zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Erdschlussmeldung quittieren

  • der Dialog zur Auswahl einer Variablen öffnet sich
  • verknüpfen Sie die gewünschte Variable mit der Funktion
  • verknüpfen Sie die Funktion mit einem Button


Erdschlusssuche beenden

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlusssuche beenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion Erdschlusssuche beenden Sie zur Runtime die Erdschlusssuche.

Interne ID: Erdschlusssuche beenden

Erdschlusssuche beenden

Funktion zum Beenden der Erdschlusssuche.

Mehr im Online-Handbuch.

Um die Funktion zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Erdschlusssuche beenden

  • verknüpfen Sie die Funktion mit einem Button


Kurzschlusssuche

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Kurzschlusssuche dient dazu, potenziell kurzschlussbehaftete Netzteile durch Einfärbung entsprechend zu markieren. Die Farbe wird aus der Projektierung der ALC-Quellenfarben für die Quelle SHORT FAULT bezogen.

Welche Netzteile potenziell kurzschlussbehaftet sind, wird aus Kurzschlussmeldungen abgeleitet. Ein Kurzschlusserkennungsgerät (Kurzschlussanzeiger, Schutzgerät) kann ein bis drei Kurzschlussmeldungen besitzen. Bei Kurzschlusserkennungsgeräten mit Richtung kann die Richtung vor- oder nacheilend zur Auslösung sein. Ein potenziell kurzschlussbehafteter Netzteil wird erst dann als nicht mehr kurzschlussbehaftet betrachtet, wenn dieser erfolgreich bespannt wurde.

Projektierung

Um die Kurzschlusssuche zu projektieren:

  1. weisen Sie dem Combi-Element, das den Schalter repräsentiert, den Funktionstyp Schalter zu

    Interne ID: Kurzschlusssuche

    Funktionstyp

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
    Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
    Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
    Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
    keine Funktion: Das Element hat im ALC keine Funktion.
    Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
    Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
    Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
    Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
    Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
    Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
    Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie Kurzschlusssanzeige undKurzschlussserkennung Auslösung
  3. legen Sie die Funktion für Kurzschlusssmeldung quittieren an

Noch in diesem Kapitel

Kurzschlussserkennungstyp

Kurzschlusssanzeige

Kurzschlussserkennung Auslösung

Kurzschlusssmeldung quittieren


Kurzschlussserkennungstyp

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlussserkennungstyp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Einstellung Typ werden Richtung und Art der Meldungsverarbeitung für das Combi-Element vom Typ Schalter festgelegt. Zur Projektierung:

Interne ID: Kurzschlussserkennungstyp

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Kurzschlussserkennungstyp

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Kurzschlussserkennungstyp

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Kurzschlusserkennung

    Interne ID: Kurzschlussserkennungstyp

    Kurzschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Kurzschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie bei der Eigenschaft Typ den gewünschten Typ
    • Richtung:
      gibt an, ob die steigende Flanke der Auslösungsmeldung oder die steigende Flanke einer Richtung vorher kommt
    • voreilend:
      bei steigender Flanke der Auslösungsmeldung wird der aktuelle Zustand der Richtung verwendet
    • nacheilend:
      nach steigender Flanke der Auslösungsmeldung wird auf die erste steigende Flanke einer Richtung gewartet, trifft diese nicht innerhalb von 2 Sekunden ein, wird das Kurzschlusserkennungsgerät als ungerichtet betrachtet
    • Meldungsverarbeitung:
      gibt an, wie Meldungen verarbeitet werden
    • keine:
      normaler Schalter, Meldungen werden nicht verarbeitet
    • Dauermeldungsverarbeitung:
      neu eintreffende Meldungen werden als neue Erdschlussauslösung berücksichtig


Kurzschlusssanzeige

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlusssanzeige

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die bei Anzeige verknüpfte Variable ist eine Ausgangsvariable der Fehlerortung und zeigt den erfassten Zustand des Kurzschlusserkennungsgeräts an. Das ist nötig, da alle Meldungen intern bis zum Quittieren gespeichert bleiben, also nicht unbedingt dem aktuellen Zustand der Meldevariablen entsprechen.

Interne ID: Kurzschlusssanzeige

Anzeige

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.

Interne ID: Kurzschlusssanzeige

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Kurzschlusssanzeige

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Ausgangsvariable der Fehlerortung fest, um den Zustand des Kurzschlusserkennungsgeräts anzuzeigen. Die hier verknüpfte Variable sollte eine lokale Variable sein, um Probleme im Netzwerkbetrieb zu verhindern. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei jeder Erfassung einer Änderung wird ein Sollwert auf diese Variable abgesetzt. Dabei sind die Werte wie folgt:

Wert | Bedeutung
0 | kein Kurzschluss
1 | Kurzschluss vorwärts
2 | Kurzschluss rückwärts
3 | Kurzschluss ungerichtet


Kurzschlussserkennung Auslösung

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlussserkennung Auslösung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Auslösung wird die Variable für die Meldung des Kurzschlusserkennungsgeräts definiert. Sie kann Informationen enthalten über das Vorhandensein eines Kurzschlusses und die Richtung der Kurzschlusses aus Sicht des Kurzschlusserkennungsgeräts.Dabei wird unterschieden zwischen:

Interne ID: Kurzschlussserkennung Auslösung

Auslösung

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.

Interne ID: Kurzschlussserkennung Auslösung

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Kurzschlussserkennung Auslösung

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Variable für die Meldung des Kurzschlusserkennungsgeräts fest. Bei gerichteten Kurzschlussmeldern muss zusätzlich die Richtung (Vorwärts oder Rückwärts) definiert werden. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Variablen.

Interne ID: Kurzschlussserkennung Auslösung

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Kurzschlussserkennung Auslösung

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ungerichteten Kurzschlussmeldern
  • gerichteten Kurzschlussmeldern mit Auslösemeldung
  • gerichteten Kurzschlussmeldern ohne Auslösemeldung

Um die Variable für zu projektieren:

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Kurzschlussserkennung Auslösung

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Kurzschlusserkennung

    Interne ID: Kurzschlussserkennung Auslösung

    Kurzschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Kurzschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. für ungerichtete Kurzschlussmelder

      klicken Sie bei der Eigenschaft Auslösung auf die Schaltfläche ...

      wählen Sie im sich öffnenden Dialog die gewünschte Variable

      die Eigenschaften für die Richtung bleiben leer

    2. für gerichtete Kurzschlussmelder mit Auslösemeldung

      verknüpfen Sie die Variable mit der Auslösung und ergänzen Sie die entsprechend Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

    3. für gerichtete Kurzschlussmelder ohne Auslösemeldung

      verknüpfen Sie die Variable mit der entsprechenden Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

      die Eigenschaft Auslösung bleibt leer


Kurzschlusssmeldung quittieren

Handbuch -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlusssmeldung quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion Kurzschlussmeldung quittieren kann zur Runtime ein intern erfasster Kurzschluss eines Kurzschlusserkennungsgeräts quittiert werden. Dabei wird der intern gelatchte Erdschlusszustand zurückgesetzt, wenn der Zustand noch ansteht, oder als quittiert markiert. Eine erfasste Kurzschlussmeldung wird intern nur gelöscht, wenn diese quittiert ist und nicht mehr ansteht.

Interne ID: Kurzschlusssmeldung quittieren

Kurzschlussmeldung quittieren

Funktion zum Quittieren einer Kurzschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Regeln beim Quittieren:

  • Wurde eine Variable verknüpft, die einer Auslösungs- oder Richtungsvariable eines Kurzschlusserkennungsgeräts entspricht, so wird nur diese spezielle Kurzschlussmeldung quittiert.
  • Wurde keine Variable verknüpft, werden alle Kurzschlussmeldungen quittiert.
  • Das Quittieren kann auch über das Objektmodell der zenon API erfolgen.

Um die Funktion Kurzschlussmeldung quittieren zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Kurzschlussmeldung quittieren

  • wählen Sie im sich öffnenden Dialog die gewünschte Variable
  • verknüpfen Sie die Funktion mit einem Button


Batch Control

Handbuch -> Batch Control

Das Modul Batch Control bietet Ihnen die Möglichkeit, batchorientierte Herstellungsverfahren für Los- und Chargenprodukte zu automatisieren. Das Modul entspricht dem Standard ANSI/ISA–88.01–1995, auch bekannt als ANSI/ISA–S88

Für Batch Control stehen zur Runtime zwei unterschiedliche Editoren zur Verfügung:

  • PFC-Editor: Für komplexe Rezepte mit Verzweigungen.
  • Matrix Editor: Für einfache sequentielle oder parallel ablaufende Rezepte.

Je nach Lizenz stehen Ihnen beide Editoren zur Verfügung oder nur einer.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig. Lizenzierung unterscheidet nach Nutzung von:

  • PFC-Editor
  • Matrix Editor
  • beiden Editoren

Editor:

Für die Projektierung im zenon Editor muss einer der beiden Batch-Editoren lizenziert sein.

Runtime:

Für die Ausführung zur Runtime muss einer der beiden Batch-Editoren lizenziert sein, um die Liste der Rezepte zu füllen. Das Anlegen und Bearbeiten von Rezepten ist immer nur für den lizenzierten Editor möglich.

Netzwerk:

Im Netzwerk zählt immer die Lizenz des Servers. Eigenständige Lizenzen der Clients werden im Netzwerkbetrieb ignoriert.

attention Achtung

Hinweise in der eingebetteten Hilfe auf VBA Keywords und auf XML-Export sind in der aktuellen Version noch ohne Funktion.

Noch in diesem Kapitel

Einführung

Terminologie

Ablauf

Projektieren im Editor

Konfigurieren und steuern in der Runtime

Verhalten im Netzwerk

Formeleditor

Fehlerbehandlung


Einführung

Handbuch -> Batch Control -> Einführung

Das Modul Batch Control besteht aus drei Teilen:

  1. Die Projektierumgebung im zenon Editor:
    Hier werden alle Aggregate (ISA Nomenklatur, Chapter 4.2.5: Units) mit ihren Grundfunktionen (ISA - 5.1.2.4: Phases) und Reaktionen erstellt. Die Grundfunktionen müssen eine Entsprechung in der Steuerung (ISA: Equipment Control) haben, die Technologische Funktion (ISA: Process Action) genannt wird.
    Batch Control spiegelt das physikalische Modell nach ISA 4.2 als flache Hierarchieebene, basierend auf Aggregaten (Units), wider.
    Auf die weiteren Ebenen des Modells wie Prozesszelle, Gebiet, Fabrik usw. wurde bewusst verzichtet. Auch bei der Erstellung der Batchrezepte wurde nur die unterste Ebene (Grundfunktionen) des ISA Struktur Modells 5.1 implementiert. Die weiteren Ebene wie Operationen, Aggregats-Prozeduren und Prozeduren stehen nicht zur Verfügung.
  2. PFC-Editor und Matrix-Editor:
    Mit diesen Editoren werden in der zenon Runtime die Vorlagenrezepte (ISA: Master recipes) erstellt. Von diesen werden die Steuerrezepte (ISA: Control recipes) abgeleitet, die ausgeführt werden können (Siehe auch ISA 5.3.1.). Während des Ablaufs wird im jeweiligen Editor der genaue Zustand des Batchrezepts dargestellt und Sie können in den Rezeptablauf eingreifen.
  3. Recipe Execution Engine (REE):
    Die REE ist direkt in die zenon Runtime integriert und führt ein Batchrezept vollautomatisch im Hintergrund aus. Die REE kann durch Kommandos wie Start, Pause, Stopp usw. vom Benutzer gesteuert werden. Ebenso sind drei Modi möglich: Au tomatisch, S emiautomatisch und M anuell.

Besonderheit des Moduls Batch Control

Im Gegensatz zu den meisten anderen zenon Modulen erfolgt ein großer Teil der Projektierung, nämlich die Rezepterstellung, in der Runtime und nicht im Editor. Das bringt einige Besonderheiten mit sich, die in den Jeweiligen Kapiteln behandelt werden. So werden z.B. geänderte Grundfunktionen nicht mehr in ein bereits freigegebenes Vorlagenrezept übertragen, um unerwünschte Datenänderungen zu verhindern.

Das Modul ist so konzipiert, dass es komplett unabhängig von der Steuerung ist. Das heißt, die Datenkommunikation erfolgt über alle verfügbaren zenon Treiber mit beliebigen SPSen oder auch RTUs. Diese führen nur die technologischen Funktionen aus. Die gesamte Rezeptabarbeitung erfolgt am Rechner in der REE. Bei einer Änderung am Batchrezept oder bei neuen Vorlagenrezepten sind damit keine Modifikation des SPS-Codes notwendig.

Das Modul befolgt die strikte Trennung zwischen Ablauf des Batchrezepts (ISA: Procedural Control Model) und Ausführung der Technologischen Funktion (ISA: Process Model) wie in ISA–S88, Kapitel 5.2.1 beschrieben.

Prinzipieller Aufbau der Kommunikation

Zur Kommunikation mit dem Prozess werden Standard zenon Variablen verwendet. Da Variablennamen aber sehr oft kryptische Bezeichner haben, wurde eine weiterer Abstrahierungsschicht eingeführt. Diese enthält Parameter, die in zwei Ausprägungen zur Verfügung stehen:

  • Befehslparameter: Mit ihnen werden beim Ausführen einer Grundfunktion Sollwerte an die SPS übertragen.
  • Rückgabeparameter: Mit ihnen werden Werte von der SPS für AUswertungen zurückgelesen.

Mit beiden Parameterarten können Werte sowohl geschrieben (z.B. in Reaktionen) als auch gelesen (z.B. in Bedingungen) werden.

Die SPS kommuniziert mit dem zenon Treiber, dieser wiederum mit der zenon Runtime. Die Runtime schickt die Werte weiter an die REE, wo sie verarbeitet werden. Die REE arbeitet intern asynchron zur zenon Runtime in einem 100 ms Zyklus.

Netzwerk

Das Modul Batch Control ist voll netzwerkfähig im Sinne der Client/Server-Technologie. Das heißt, es können Batch-Rezepte auf einem Client erstellt, dupliziert, bearbeitet, gelöscht usw. werden. Dabei erfolgt die gesamte Rezeptverwaltung immer am Server. Ebenso kann von einem Client aus die gesamte Ablaufbedienung wie Rezept starten, pausieren, stoppen usw. erfolgen. Auch Moduswechsel und manuelle Operationen wie springen sind möglich.

attention Achtung

Das Modul Batch Control ist nicht redundanzfähig. Es erfolgt kein Abgleich am Standby-Server. Bei einem Ausfall des Servers werden die ausgeführten Batch-Rezepte am Standby nicht nahtlos fortgesetzt!


Terminologie

Handbuch -> Batch Control -> Terminologie

Im zenon Modul Batch Control werden folgende Begriffe verwendet:

Begriff | Definition
Aggregat | Physikalisch verfügbarer Maschinen- oder Anlagenteil, mit dem Grundfunktionen ausgeführt werden können. (ISA 88: Unit)
Aggregatfreigabe | Element des Moduls Batch Control, das die Belegung eines Aggregats im Aggregatmanager aufhebt. Dadurch ist das Aggregat wieder durch andere Rezepte belegbar.
Aggregatsbelegung | Element des Moduls Batch Control, das die Belegung eines Aggregats im Aggregatmanager bewirkt. Ein belegtes Aggregat kann nur von Grundfunktionen innerhalb des Rezepts verwendet werden. Damit ist das Aggregat für Grundfunktionen anderer, parallel ablaufender Rezepte gesperrt.
Anfang Parallelzweig | Element, das eine Aufteilung des Rezeptablaufs in zwei oder mehrere Zweige ermöglicht.
Anfang Verzweigung | Element, das eine Aufteilung des Rezeptablaufs in zwei oder mehrere Zweige ermöglicht, von denen immer nur ein Zweig aktiv werden kann. Jeder nachfolgende Zweig muss mit einer Transition beginnen. Die Transition bestimmt im Rezeptablauf, welcher Zweig ausgeführt wird.
Anfangselement | Element des Moduls Batch Control, mit dem jedes Rezept beginnt.
Batch Control | Werkzeug zur Erstellung und Ausführung von ISA S88 konformen Master-Rezepten und Kontroll-Rezepten.
Batchbetrieb | Automatisches, sequentielles Abarbeiten eines Stapels von Einzeloperationen.
Ende Parallelzweig | Element, das die Aufteilung des Rezeptablaufs in zwei oder mehrere Zweige wieder zu einem Zweig zusammenführt.
Ende Verzweigung | Element, das eine durch ein Element Anfang Verzweigung begonnene Verzweigung wieder zusammenführt.
Endelement | Element des Moduls Batch Control, mit dem jedes Rezept endet.
Grundfunktion | Vordefinierter Handlungsablauf bestehend aus einer Eingangsverriegelung, Befehls- und Rückgabeparametern, einer Weiterschaltbedingung, Ereignisreaktion usw. (ISA 88: Phase)
Parallelzweig | Bereich des Modul Batch Control. Ein Parallelzweig beginnt mit einem Anfang Parallelzweig Element und wird durch ein Ende Parallelzweig Element wieder auf einen Ausführungszweig zusammengeführt. Dazwischen befinden sich mindestens zwei Zweige, die gleichzeitig ausgeführt werden.
REE - Recipe Execution Engine | Teil des Moduls Batch Control zur Ablaufsteuerung von Rezepten. Die Engine führt ein Kontrollrezept aus und verwaltet den gesamten Ablauf des Rezepts.
Steuerrezept | Teil des Moduls zenon Batch Control. Beinhaltet den Ablauf eines Produktionsprozesses auf Basis des Batch Verfahrens nach dem Standard ISA S88. Ein Kontrollrezept ist immer von einem Masterrezept abgeleitet und kann einmalig ausgeführt werden.
Transition | Element des Moduls Batch Control, das eine Bedingung beinhaltet. Das Element wird nach Grundfunktionen eingesetzt um einen definierten Übergang von einer Grundfunktion in die nächste zu gewährleisten.
Verknüpfungsstück | Besteht aus Verknüpfungslinie und Verknüpfungspunkt. Ermöglicht das Andocken an Anfangs/ende Zweigen/Parallelzweigen.
Verknüpfungspunkt | Punkt, an dem Linien andocken können, um Objekte miteinander zu verbinden.
Verzweigung | Bereich des Moduls Batch Control, der eine Aufteilung in zwei oder mehrere Zweige ermöglicht, von denen beim Rezeptablauf immer nur ein Zweig aktiv werden kann. Es handelt sich um eine Entweder-Oder-Verzweigung.Eine Verzweigung beginnt immer mit dem Element Anfang Verzweigung und endet mit dem Element Ende Verzweigung.
Vorlagenrezept | Teil des Moduls zenon Batch Control. Beinhaltet den Ablauf eines Produktionsprozesses auf Basis des Batch Verfahrens nach dem Standard ISA S88. Ein Rezept besteht aus den Komponenten: Grundfunktionen, Transitionen, Parallelzweig usw..Masterrezepte dienen als Vorlage für Kontrollrezepte.


Ablauf

Handbuch -> Batch Control -> Ablauf

Projektierung und Nutzung des Moduls Batch Control erfolgen in drei Hauptschritten:

  1. Projektierung im zenon Editor
  2. Rezepterstellung im Batch-Editor (PFC oder Matrix) zur Runtime
  3. Rezeptausführung zur Runtime

Projektierung

Der Projektant bildet im Editor die vorhandene physikalische Welt ab. Er definiert und erstellt Aggregate und weist diesen Grundfunktionen mit Parametern zu.

Rezepterstellung

Zur Runtime definiert der Rezeptersteller auf Basis der Vorgaben aus dem Editor das Vorlagenrezept. Dieses bestimmt den Ablauf. Dabei können nur die in der Projektierumgebung vorgegeben Aggregate, Grundfunktionen und Parameter verwendet werden.
Ausnahme: Wurde im Editor in der Gruppe Sollwert absetzen die Eigenschaft Im Rezept änderbar aktiviert, kann der entsprechende Parameter modifiziert werden. Dies ist nur für Befehlsparameter möglich.

Interne ID: Ablauf

Im Rezept änderbar

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl gesetzt wurde.

Interne ID: Ablauf

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Ablauf

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Rezeptersteller kann zur Runtime Parameter modifizieren.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Ablauf

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Rezeptausführung

Der Operator führt zur Runtime das Rezept aus. Dazu startet er ein Steuerrezept, das auf dem Vorlagenrezept basiert. Jedes Steuerrezept kann nur einmal gestartet und verwendet werden. Damit ist es eindeutig einer Charge zuordenbar. Rezepte laufen entweder automatisch, semiautomatisch oder manuell ab.

Der Operator kann Rezepte nicht mehr beeinflussen.
Ausnahme: Setzt der Rezeptersteller die Option Im Steuerrezept änderbar auf aktiv, kann der Operator zur Runtime noch Parameter editieren.


Projektieren im Editor

Handbuch -> Batch Control -> Projektieren im Editor

Um das Modul Batch Control in der Runtime nutzen zu können, müssen Sie zuerst im Editor:

  • Aggregate, Grundfunktionen und Reaktionen anlegen
  • ein Bild vom Typ Batch Control anlegen
  • eine Bildumschaltfunktion auf das Bild vom Typ Batch Control anlegen

Detailansicht

Im Modul Batch Control ist die Detailansicht zweigeteilt:

  • Der linke Teil umfasst den Aggregatsbaum. Der Eintrag Aggregate bildet den Ausgangspunkt für den Baum.
    Auf der nächsten Ebene werden die vorhandenen Aggregate angezeigt. Es folgen die zu jedem Aggregat gehörenden Grundfunktionen. Jede Grundfunktion besitzt als Unterpunkt Reaktionen.
  • Im rechten Teil wird, je nachdem welche Ebene des Baums ausgewählt wurde, eine flache Liste der Aggregate, Grundfunktionen, Parameter oder Reaktionen dargestellt.

Noch in diesem Kapitel

Aggregate

Grundfunktionen

Transitionen

Bedingungen

Reaktionen

Parameter

Eingangsverriegelung

Bild vom Typ Batch Control anlegen

Bildumschaltung Batch Control


Aggregate

Handbuch -> Batch Control -> Projektieren im Editor -> Aggregate

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein neues Aggregat anzulegen:

  1. navigieren Sie im Projektmanager zum Knoten Batch Control
  2. wählen Sie in der Detailansicht Aggregate
  3. wählen Sie im Kontextmenü den Befehl Aggregat neu
  4. ein neues Aggregat wird in der Detailansicht angelegt

Noch in diesem Kapitel

Symbolleiste Aggregatsbaum

Projektbaum - Kontextmenü Aggregate

Kontextmenü Aggregate

Kontextmenü Aggregat x

Detailansicht Aggregat

Detailansicht Aggregat X


Symbolleiste Aggregatsbaum

Handbuch -> Batch Control -> Projektieren im Editor -> Aggregate -> Symbolleiste Aggregatsbaum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Symbolleiste bezieht sich auf den kompletten Aggregatsbaum. Je nach ausgewähltem Element stehen ihre Symbole zur Verfügung oder sind deaktiviert.

Parameter

Beschreibung

Umbenennen

Öffnet Namensfeld des ausgewählten Elements zum Umbenennen.

Steht für Hauptknoten Aggregate nicht zur Verfügung.

Löschen

Löscht ausgewähltes Element nach Sicherheitsabfrage.

Steht für Hauptknoten Aggregate nicht zur Verfügung.

Alle erweitern

Zeigt die gesamte Baumstruktur an.

Durch Klick auf den Pfeil erhalten Sie eine Dropdownliste, in der Sie einen der folgenden Befehle auswählen können:

  • Alle erweitern: erweitert alle Knoten
  • Alle reduzieren: reduziert alle Knoten
  • Selektierte erweitern: erweitert ausgewählten Knoten
  • Selektierte reduzieren: reduziert ausgewählten Knoten

Klick auf Schaltfläche erweitert immer alle Elemente.

Elemente können auch über Doppelklick auf den übergeordneten Eintrag erweitert und reduziert werden.

Hilfe

Öffnet die Online-Hilfe.


Projektbaum - Kontextmenü Aggregate

Handbuch -> Batch Control -> Projektieren im Editor -> Aggregate -> Projektbaum - Kontextmenü Aggregate

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter | Beschreibung
Aggregat neu | Erstellt ein neues Aggregat.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Aggregate

Handbuch -> Batch Control -> Projektieren im Editor -> Aggregate -> Kontextmenü Aggregate

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rechtsklick auf den Haupteintrag Aggregate im Aggregatsbaum öffnet ein Kontextmenü:

Menüpunkt | Aktion
Aggregat neu | Erstellt ein neues Aggregat.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Aggregat x

Handbuch -> Batch Control -> Projektieren im Editor -> Aggregate -> Kontextmenü Aggregat x

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rechtsklick auf ein erstelltes Aggregat öffnet ein Kontextmenü:

Menüpunkt | Aktion
Grundfunktion neu | Erstellt eine neue Grundfunktion.
Umbenennen | Ermöglicht Umbenennen des ausgewählten Aggregats.
Löschen | Löscht ausgewähltes Aggregat nach einer Sicherheitsabfrage aus dem Baum.
Hilfe | Öffnet die Online-Hilfe.


Detailansicht Aggregat

Handbuch -> Batch Control -> Projektieren im Editor -> Aggregate -> Detailansicht Aggregat

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Menüpunkt | Aktion
Grundfunktion neu | Legt eine neue Grundfunktion in der Detailansicht an.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.


Detailansicht Aggregat X

Handbuch -> Batch Control -> Projektieren im Editor -> Aggregate -> Detailansicht Aggregat X

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Grundfunktion neu | Legt eine neue Grundfunktion in der Detailansicht an.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Zelle ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.


Grundfunktionen

Handbuch -> Batch Control -> Projektieren im Editor -> Grundfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Grundfunktion ist das Ausführungsobjekt eines Rezepts und damit der Hauptbestandteil. Jeder Grundfunktion im Modul Batch Control muss eine Technologisch Funktion in der Steuerung gegenüber stehen.

Beispiel: Sie möchten einen Tank aufheizen. Dazu brauchen sie:

  • Zuerst das entsprechende Equipment: eine Heizung im Tank.
  • Dann einen Temperatursensor, der die Ist-Temperatur im Tank misst. Diesen Sensor verbinden Sie mit einer Steuerung.
  • In der Steuerung ein Programm, das die Heizung steuert, bis die Solltemperatur erreicht ist.
    Dieses Steuerungsprogramm ist die Technologische Funktion in der SPS. Sie:
    • hat einen Eingangsparameter, eine Soll-Temperatur, die im Batch Control mit einem Befehlsparameter realisiert wird
    • benötigt einen Ausgangsparameter, auch eine Soll-Temperatur,die erreicht werden muss und im Batch Control als Rückgabeparameter realisiert wird

Um der Steuerung den Ablauf des Rezepts mitteilen zu können, benötigen Sie entsprechende Statusinformationen, die an die Steuerung übertragen werden. Dazu verwenden Sie Reaktionen und für die Rückmeldung Bedingungen.

Eine Grundfunktion besteht daher aus:

Typ | Beschreibung
Befehlsparameter | Die Sollwerte, die an die Steuerung übertragen werden
Rückgabeparameter | Die Rückgabewerte, die der REE den Zustand der Technologischen Funktion in der Steuerung mitteilen. Diese können in Bedingungen und Transitionen ausgewertet werden.
Reaktionen | REE Ereignisse können dazu genutzt werden, einerseits der Technologischen Funktion in der Steuerung den Zustand der REE mitzuteilen, als auch den Benutzer über Fehler (z.B.: Timeouts, ungültige Parameterwerte) zu informieren.
Bedingungen | Dienen zur Auswertung der Rückgabeparameter : Der Zustand der Technologischen Funktion in der Steuerung wird ausgewertet.
Zeiten | Zeitkritische Vorgänge können damit überwacht werden. Bei Überschreitung der projektierten Zeit wird ein Ereignis ausgelöst, auf das wiederum mit einer Reaktion reagiert werden kann.

Projektierung

Um eine neue Grundfunktion anzulegen:

  1. wählen Sie das Aggregat für die Grundfunktion aus oder legen Sie das gewünschte Aggregat zuerst an
  2. wählen Sie im Kontextmenü den Befehl Grundfunktion neu
  3. eine neue Grundfunktion wird in der Detailansicht eingeblendet
  4. der Unterpunkt Reaktionen wird automatisch zur Grundfunktion hinzugefügt

info Info

Werden im Editor mehrere Grundfunktionen gleichzeitig ausgewählt, deren Formeln ident sind, aber deren Parameter sich unterscheiden, dann wird das nicht durch farbliche Unterlegung der unterschiedlichen Werte angezeigt.

Noch in diesem Kapitel

Kontextmenü Grundfunktion

Detailansicht Grundfunktion


Kontextmenü Grundfunktion

Handbuch -> Batch Control -> Projektieren im Editor -> Grundfunktionen -> Kontextmenü Grundfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rechtsklick auf ein erstelltes Aggregat öffnet ein Kontextmenü:

Menüpunkt | Aktion
Grundfunktion neu | Erstellt eine neue Grundfunktion.
Umbenennen | Ermöglicht Umbenennen des ausgewählten Aggregats.
Löschen | Löscht ausgewähltes Aggregat nach einer Sicherheitsabfrage aus dem Baum.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Grundfunktion x

Rechtsklick auf eine erstellte Grundfunktion öffnet ein Kontextmenü zur Erstellung der Parameter:

Parameter | Beschreibung
Befehlsparameter neu | Erstellt einen neuen Befehlsparamter.
Rückgabeparameter neu | Erstellt einen neuen Rückgabeparamter.
Umbenennen | Ermöglicht, den Namen der aktuell ausgewählten Grundfunktion zu ändern.
Löschen | Löscht die aktuell ausgewählte Grundfunktion nach einer Sicherheitsabfrage.
Hilfe | Öffnet die Online-Hilfe.


Detailansicht Grundfunktion

Handbuch -> Batch Control -> Projektieren im Editor -> Grundfunktionen -> Detailansicht Grundfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Befehlsparameter neu | Legt einen neuen Befehlsparameter in der Detailansicht an.
Rückgabeparameter neu | Legt einen neuen Rückgabeparameter in der Detailansicht an.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Zelle bearbeiten | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.


Transitionen

Handbuch -> Batch Control -> Projektieren im Editor -> Transitionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Transition (Übergangsbedingung) wird eingesetzt, um einen definierten Übergang von einer Grundfunktion zur nächsten zu gewährleisten. Das Element beinhaltet als Element eine Bedingung und wird nach Grundfunktionen eingesetzt.

Als Transitionen stehen folgende Eigenschaften zur Verfügung:

  • Pausiert :
    Der Ablauf bleibt innerhalb der Grundfunktion stehen bei:

    Interne ID: Transitionen

    Pausiert

    Bedingung für den Wechsel von pausierend auf pausiert.
    Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
    Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Warten auf Beendet
    • Warten auf Zuweisung
    • Warten auf Verriegelung
    • Warten auf Ende Grundfunktion
    • Prüfen auf parallele Ausführung
  • Angehalten
    Der Ablauf bleibt innerhalb der Grundfunktion stehen bei:

    Interne ID: Transitionen

    Angehalten

    Bedingung für den Wechsel von anhaltend auf angehalten.

    Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
    Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Warten auf Beendet
    • Warten auf Zuweisung
    • Warten auf Verriegelung
    • Warten auf Ende Grundfunktion
    • Prüfen auf parallele Ausführung
  • Gestoppt

    Interne ID: Transitionen

    Gestoppt

    Bedingung für den Wechsel von stoppend auf gestoppt.

    Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
    Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Abbgebrochen

    Interne ID: Transitionen

    Abbgebrochen

    Bedingung für den Wechsel von abbrechend auf abgebrochen.

    Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
    Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Neu gestartet
    Grundfunktion wird von Anfang an neu ausgeführt.

    Interne ID: Transitionen

    Neu gestartet

    Bedingung für den Wechsel von neu startend auf laufend.

    Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
    Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Variablen

Übergangsbedingungen können mit einer binären Variablen verknüpft werden, die bestimmt, wann die Grundfunktion den Status wechselt. Der Statuswechsel wird verzögert bis:

  • der Wert der Variable definiert ist
  • der Wert der Variable 1 ist
  • der Status der Variable nicht gestört ist

Wird keine Variable definiert, ist der Statuswechsel immer erlaubt.

Alle Variablen für den Statuswechsel werden beim Advisen der Variablen mit angefordert, um möglichst schnell einen Wert zu bekommen. Die Werte für eine Variable, die den Statuswechsel bestimmt, werden beim Wechseln in den transienten Status ausgelesen. Ein eventueller Puls muss innerhalb der Wartezeit den Wert TRUE haben, um erkannt zu werden.

Hinweis: Beim Beenden der Runtime wird nicht auf die Variable zum Statuswechsel von stoppend auf gestoppt gewartet, da zu diesem Zeitpunkt bereits alle Variablen abgemeldet sind.


Bedingungen

Handbuch -> Batch Control -> Projektieren im Editor -> Bedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bedingungen dienen dazu, der REE den Status der Technologischen Funktion in der Steuerung mitzuteilen. Zur Auswertung der Bedingungen werden immer Formeln benutzt, die mit dem Formeleditor erstellt werden.

Tipp: Benutzen Sie einen einzigen Statusparameter (Rückgabeparameter), der verschiedene Werte annimmt, um den Zustand der Technologischen Funktion in der Steuerung an die Grundfunktion zu übermitteln. Ein Beispiel finden Sie im Kapitel Beispiel für Statusparameter.

Projektierung

Um eine neue Reaktion anzulegen:

  1. klicken Sie auf die entsprechende Grundfunktion
  2. wählen Sie in den Eigenschaften die gewünschten Bedingungen aus dem Knoten Allgemein oder Bedingungen transiente Status

    Interne ID: Bedingungen

    Bedingungen transiente Status

    Gruppe mit Eigenschaften für Übergangsbedingungen.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Bedingungen

    Allgemein

    Allgemeine Eigenschaften der Grundfunktion.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. klicken Sie in das Feld für den Wert oder auf die Schaltfläche ...
  4. der Formeleditor wird gestartet
  5. definieren Sie die Formel für die Bedingung

Hinweis: Das Gegenstück zu den Bedingungen sind die Reaktionen. Mit ihnen wird der Status der REE an die Technologischen Funktionen in der Steuerung übertragen.

Noch in diesem Kapitel

Wartezeiten


Wartezeiten

Handbuch -> Batch Control -> Projektieren im Editor -> Bedingungen -> Wartezeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Rezeptersteller kann Wartezeiten definieren. Die Konfiguration von Wartezeiten (Timeouts) verhindert, dass zeitkritische Prozesse durch unvorhergesehene Ereignisse zu lange dauern. Wird die Bedingung nicht innerhalb der definierten Wartezeit erreicht, wird ein entsprechendes Ereignis ausgelöst. Mit den Reaktionen kann man auf das Ereignis reagieren und den Rezeptablauf beeinflussen.

Für alle Wartezeiten gilt:

  • Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.
  • Die Wartezeiten laufen unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.
  • Wird eine Grundfunktion angehalten und neu gestartet, werden die Wartezeiten neu gestartet.
  • Wird eine Grundfunktion mehrfach durchlaufen werden bei jedem erneuten Durchlauf die Wartezeiten neu gestartet.
  • Wartezeiten selbst beeinflussen den Ablauf in keiner Weise. Sie dienen nur dazu, ein Ereignis zu generieren. Die Reaktion muss im Ereignis definiert werden. Nach dem Auslösen des Ereignisses wird weiter auf die Erfüllung der Bedingung gewartet.


Reaktionen

Handbuch -> Batch Control -> Projektieren im Editor -> Reaktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Reaktionen sind das Herzstück, um den Rezeptablauf zu beeinflussen und mit der Steuerung zu kommunizieren. Reaktion basieren immer auf Ereignissen. Das können Ereignissen der REE (z.B.: Grundfunktion gestartet) sein sowie auch allgemeine Ereignisse (z.B. "Runtime beenden" angestoßen). Mit Hilfe der Reaktionen können Sie z.B. der Steuerung mitteilen, wann eine Grundfunktion in der REE gestartet oder beendet wurde und wann alle Befehlsparameter abgesetzt wurden.

Ebenso müssen Sie mit Reaktionen den Status der Grundfunktion an die Steuerung übermitteln. Ansonsten hat die Steuerung keinerlei Information über den Ablauf des Rezepts.

Beispiel: Stoppen Sie die REE oder die Grundfunktion, wird das Ereignis Statuswechsel: Stoppen ausgelöst. Als Reaktion können Sie diesen Statuswechsel als Sollwertvorgabe an die Steuerung übermitteln. Erst dann kann die Steuerung darauf regieren und die Technologische Funktion stoppen. Ein Beispiel finden Sie im Kapitel Beispiel für Statusparameter.

Hinweis: Das Gegenstück zu den Reaktionen sind die Bedingungen. Mit ihnen wird der Status der Technologischen Funktion in der Steuerung an die REE übertragen.

Projektierung

Mit jeder Grundfunktion wird automatisch der Knoten Reaktionen erstellt. In diesem Knoten können beliebige Reaktionen angelegt werden. Um eine neue Reaktion anzulegen:

  1. klicken Sie auf Reaktionen
  2. wählen Sie im Kontextmenü den Befehl Reaktion neu
  3. eine neue Reaktion wird in der Detailansicht angelegt
  4. klicken Sie in der Detailansicht auf den Eintrag in der Spalte Ereignis
  5. wählen Sie aus der Dropdownliste das gewünschte Ereignis aus und definieren sie im Eigenschaftenfenster die gewünschte Reaktionsart.

Pro Reaktionart sind mehrere Reaktionen möglich. Diese werden bei ihrer Auslösung sortiert und entsprechend ihrer Priorität ausgeführt. Dabei hat 1 die höchste Priorität. Einige der Reaktionen werden nur einmal im Ablauf ausgelöst, zum Beispiel Timeouts. Wird die Grundfunktion neu gestartet, werden auch diese Reaktion bei Bedarf erneut ausgelöst.

Reaktionen können immer nur Parameter ihrer eigenen Grundfunktion verwenden. Werden Reaktionen von anderen Grundfunktionen kopiuert, versuchen diese, Paramter gleichen Namens der neuen Grundfunktion zu verwenden.

Werte der Reaktionen werden in der CEL geloggt.

Noch in diesem Kapitel

Kontextmenü Reaktionen Aggregatsbaum

Detailansicht Reaktionen

Ereignisse

Reaktionsarten


Kontextmenü Reaktionen Aggregatsbaum

Handbuch -> Batch Control -> Projektieren im Editor -> Reaktionen -> Kontextmenü Reaktionen Aggregatsbaum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter | Beschreibung
Reaktion neu | Erstellt eine neue Reaktion in der Detailansicht.
Hilfe | Öffnet die Online-Hilfe.


Detailansicht Reaktionen

Handbuch -> Batch Control -> Projektieren im Editor -> Reaktionen -> Detailansicht Reaktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Reaktion neu | Legt eine neue Reaktion in der Detailansicht an.
Ausführungsreihung: Früher | Reiht die Reaktion in der Ausführungsreihenfolge vor.
Ausführungsreihung: Später | Reiht die Reaktion in der Ausführungsreihenfolge zurück.
Ausführungsreihung: Tauschen | Nur aktiv, wenn exakt zwei Reaktionen ausgewählt wurden. Tauscht Platz in der Ausführungsreihenfolge für diese beiden Rektionen.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Zelle bearbeiten | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.


Ereignisse

Handbuch -> Batch Control -> Projektieren im Editor -> Reaktionen -> Ereignisse

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jede Reaktion ist eine Reaktion auf ein Ereignis. Das Ereignis wird in der Eigenschaft Ereignis festgelegt. Für jedes Ereignis können mehrere Reaktionen definiert werden. Die Ausführungsreihenfolge kann in der Detailansicht festgelegt werden.

Interne ID: Ereignisse

Ereignis

Auswahl des Ereignistyps, bei dem die Reaktion ausgeführt werden soll, aus Dropdownliste.
Für jedes Ereignis können mehrere Reaktionen definiert werden. Die Ausführungsreihenfolge kann in der Detailansicht festgelegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei der Validierung des Rezepts zur Runtime wird im Fehlerfall der Name des Ereignis angezeigt.
Syntax: (Ereignisname.x) Wobei Ereignisname dem Ereignis entspricht. x ist eine Ziffer, welche die Position in der Ausführungsreihenfolge anzeigt.

Aus der Dropdownliste können Sie folgende Ereignisse auswählen:

Ereignis

Beschreibung

Aggregatsbelegung nicht möglich

Wird ausgelöst, wenn das Aggregat beim ersten Versuch nicht erfolgreich belegt werden kann.

Befehlsparameter fertig abgesetzt

Wird ausgelöst, wenn alle Befehlsparameter geschrieben wurden. Es kann jedoch nicht garantiert werden, dass wirklich alle Parameter in der Steuerung angekommen sind. Das hängt von der Kommunikation und vom jeweiligen Treiber ab. Es kann jedoch davon ausgegangen werden.

Empfehlung: Nutzen Sie dieses Ereignis dazu, um der SPS mitzuteilen, dass die Grundfunktion alle Befehlsparameter geschrieben hat und die SPS mit der Abarbeitung der Technologischen Funktion beginnen kann.

Befehlsparameter ohne Wert

Wird ausgelöst, wenn ein Befehlsparameter getoggelt werden soll und die dem Parameter zugeordnete Variable keinen gültigen Ausgangswert hat.

Eingangsverriegelung blockiert

Wird ausgelöst, wenn die Eingangsverriegelung bei der ersten Prüfung blockiert ist.

Nur sinnvoll, wenn die Eigenschaft Eingangsverriegelung konfiguriert wurde.

Interne ID: Ereignisse

Eingangsverriegelung

Definiert Bedingung für Eingangsverriegelung. Klick auf Schaltfläche ... oder Eintrag öffnet den Formeleditor zur Definition einer Bedingung.
Wird eine Eingangsverriegelung konfiguriert, dann wird die Grundfunktion zur Runtime erst ausgeführt, wenn die Bedingung für die Eingangsverriegelung erfüllt wurde. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Die Formel gibt TRUE oder FALSE als Ergebnis aus. Die Bedingung kann zur Runtime angezeigt, aber nicht verändert werden.
Die Wartezeit für die Eingangsverriegelung wird mit der Eigenschaft Wartezeit Eingangsverrieglung konfiguriert.

Interne ID: Ereignisse

Wartezeit Eingangsverrieglung

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Eingangsverriegelung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Beginn der Prüfung der Eingangsverriegelung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Eingangsverriegelung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Grundfunktion abgeschlossen

Wird ausgelöst, wenn die Grundfunktion gestartet war und jetzt beendet wird.

Grundfunktion beendet

Wird ausgelöst, wenn die Grundfunktion beendet ist. Dieses Ereignis ist die letzte Reaktion der Grundfunktion und unabhängig vom Grund des Beendens. Damit ist die Weiterschaltbedingung erfüllt.

Dieses Ereignis wird auch bei einem Neustart ausgelöst.

Grundfunktion gestartet

Ist das erste ausgelöste Ereignis. Wird auch bei einem Neustart ausgelöst.

Mit diesem Ereignis teilen Sie der SPS mit, dass die Grundfunktion in der REE gestartet wurde und dass voraussichtlich bald die Befehlsparameter geschrieben werden.

Grundfunktion mehrfach gestartet

Eine Grundfunktion kann nur einmal aktiv sein. Wird sie parallel mehrfach aktiv, dann wird dieses Ereignis ausgelöst.

REE Moduswechsel: Automatisch

Die REE wurde in den Modus Automatisch geschaltet.

REE Moduswechsel: Manuell

Die REE wurde in den Modus Manuell geschaltet.

REE Moduswechsel: Semiautomatisch

Die REE wurde in den Modus Semiautomatisch geschaltet.

Runtime beenden angestoßen

Wird ausgelöst, wenn die Runtime beendet wird. Dies ist ein besonders kritischer Zustand für das Modul Batch Control, da der Rezeptabaluf in der Steuerung nicht sofort aufhört. Daher wird das Beenden der Runtime solange verhindert, bis das Modul Batch Control alle Daten gesichert hat. Es wird ein Prozessabbild erstellt, auf das dann wieder aufgesetzt werden kann.

Ebenso wird dafür gesorgt, dass Parameter der Sollwert Setzen Aktionen bei diesem Ereignis sicher auf der Steuerung ankommen. Die Grundfunktion wird intern erst pausiert, wenn die Schreibbestätigung vom Treiber erfolgt ist.

Weitere Details zum Beenden der Runtime findend Sie im Kapitel: Runtime Beenden und Wiederanlauf.

Bei diesem Ereignis sind keine Reaktionsarten der Gruppe Rezeptbeeinflussung möglich.

Runtime Wiederanlauf

Die Runtime ist wieder angelaufen.

Statuswechsel

Wenn die Grundfunktion ihren Status ändert, wird die entsprechende Reaktion aktiviert.

Statuswechsel: Abbrechend

Die Grundfunktion wird gerade abgebrochen.

Statuswechsel: Abgebrochen

Die Grundfunktion wurde abgebrochen.

Statuswechsel: Abgeschlossen

Die Grundfunktion ist abgeschlossen.

Statuswechsel: Angehalten

Die Grundfunktion wurde angehalten.

Statuswechsel: Anhaltend

Die Grundfunktion wird gerade angehalten.

Statuswechsel: Fortsetzend

Die Grundfunktion wird nach einer Unterbrechung fortgesetzt.

Ein Statuswechsel im Objekt von Pausiert auf In Ausführung löst die Ereignisse Fortsetzend und In Ausführung aus.

Statuswechsel: Gestoppt

Die Grundfunktion wurde gestoppt.

Statuswechsel: In Ausführung

Die Grundfunktion wird ausgeführt.

Statuswechsel: Neu startend

Die Grundfunktion startet gerade neu.

Statuswechsel: Pausierend

Die Grundfunktion wird gerade auf Pausiert geschaltet.

Statuswechsel: Pausiert

Die Grundfunktion pausiert.

Statuswechsel: Stoppend

Die Grundfunktion wird gerade gestoppt.

Verknüpfte Variable gestört
  • Wenn der Wert einer Variable mit Status INVALID (Ungültig) verwendet werden soll, wird dieses Ereignis einmalig pro gestörter Variable und Grundfunktionerzeugt.
  • Wenn der Variablenstatus von INVALID ) auf Nicht-INVALID und wieder auf INVALID wechselt, wird bei Verwendung der Variablen die Reaktion erneut ausgelöst.
  • Wenn die Grundfunktion neu gestartet wird, wird bei Verwendung einer gestörten Variablen dieses Ereignis erneut ausgelöst.

Bei folgenden Aktivitäten wird auf gestörte Variable geprüft:

  • Quellvariable in Reaktion
  • Variable für Weiterschaltbedingung
  • Variable für die Eingangsverriegelung
  • Befehlsparameter invertiert schreiben
  • Variablen für Statuswechsel bei transienten Status erlauben

Wartezeit Aggregatsbelegung überschritten

Wird ausgelöst, wenn die Wartezeit für die Aggregatsbelegung abläuft. Kann auch während Pausierend und Angehalten auftreten.

Wartezeit Eingangsverriegelung überschritten

Wird ausgelöst, wenn die Wartezeit (Timeout) für die Eingangsverriegelung abgelaufen ist.

Nur sinnvoll, wenn eine Eingangsverriegelung definiert wurde.

Wartezeit nachfolgende Bedingung überschritten

Wird ausgelöst, wenn die Grundfunktion, obwohl die Weiterschaltbedingung erfüllt war, nicht innerhalb der hierfür vorgesehenen Wartezeit (Timeout) abgeschlossen wird.

Wartezeit Weiterschaltbedingung überschritten

Wird ausgelöst, wenn die Wartezeit (Timeout) zum Warten auf die Weiterschaltbedingung (Beendet) überschritten wird.


Reaktionsarten

Handbuch -> Batch Control -> Projektieren im Editor -> Reaktionen -> Reaktionsarten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In den Eigenschaften der Reaktionen werden die Reaktionsarten genauer definiert und parametrisiert. In der Gruppe Reaktionen stehen Ihnen folgende Reaktionsarten zur Verfügung:

Interne ID: Reaktionsarten

Reaktionen

Enthält Eigenschaften für Reaktionen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Reaktionsart

Beschreibung

Parameter Sollwert setzen

Interne ID: Reaktionsarten

Parameter Sollwert setzen

Enthält Eigenschaften für Parameter Sollwert setzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beeinflusst sowohl Befehlsparameter als auch Rückgabeparameter direkt. Es können alle Parameterdatentypen verwendet werden.
Achtung: Der Wert muss innerhalb der Sollwertgrenzen der Variablen, die beim Parameter verknüpft ist, liegen. Ist dies nicht der Fall, wird bei der Validierung eine Fehlermeldung ausgegeben.

CEL-Eintrag

Interne ID: Reaktionsarten

CEL-Eintrag

Enthält Eigenschaften für Einträge in die CEL und in LOG-Dateien.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Erzeugt Einträge in die CEL und die LOG-Dateien. Damit kann die Reaktion dokumentiert und der Rezeptablauf auch später noch nachvollzogen werden. Dazu muss die Eigenschaft CEL Eintrag erzeugen aktiviert worden sein. Der Text für die CEL wird in der Eigenschaft CEL Meldungstext festgelegt.

Interne ID: Reaktionsarten

CEL Meldungstext

Nur verfügbar, wenn Eigenschaft CEL Eintrag erzeugen aktiv ist.

Text, der in die CEL eingetragen wird. Kann Schlüsselwörter aus der Sprachumschaltung enthalten.

Maximum: 512 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Reaktionsarten

CEL Eintrag erzeugen

Aktiv: Der in der Eigenschaft CEL Meldungstext definierte Text wird in die CEL eingetragen.

Der Eintrag erfolgt in der CEL am Server mit dem zu diesem Zeitpunkt angemeldeten Benutzer.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Funktion

Interne ID: Reaktionsarten

Funktion

Enthält Eigenschaft zur Funktionsauswahl.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Ermöglicht das Verknüpfen einer beliebigen zenon Funktion.

Damit können Sie z.B. ein Pop-up aufschalten, um den Benutzer über einen bestimmten Zustand zu informieren, oder eine Sicherungsaktion von Daten anstoßen.

Hinweis: Im Netzwerk wird die Funktion immer am Server ausgeführt.

Parameter zuweisen

Interne ID: Reaktionsarten

Parameter zuweisen

Enthält Eigenschaften für die Zuweisung von Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Ermöglicht es, eine Wertzuweisung von einem Quellparameter auf einen Zielparameter vorzunehmen. Es können sowohl Befehlsparameter als auch Rückgabeparameter verwendet werden. Der Datentyp von Quell-und Zielparameter muss ident sein, sonst wird bei der Validierung des Rezepts ein Fehler ausgegeben.

Interne ID: Reaktionsarten

Zielparameter

Nur verfügbar, wenn ein Quellparameter gewählt wurde.

Parameter, auf den der Wert des in der Eigenschaft Quellparameter gewählten Parameters übertragen wird. Klick auf Schaltfläche ... öffnet Dialog zur Parameterauswahl. Es werden nur Parameter vom passenden Typ angeboten. Wird der Parameter umbenannt, wird die Änderung automatisch übernommen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Reaktionsarten

Quellparameter

Parameter, dessen Wert auf den in der Eigenschaft Zielparameter gewählten Parameters übertragen wird. Klick auf Schaltfläche ... öffnet Dialog zur Parameterauswahl.

Beim Start der Grundfunktion zur Runtime wird der beim Quellparameter verknüpfte Wert der Variable abgefragt. Wird kein gültiger Wert empfangen, kann mittels der Reaktion „Verknüpfte Variable gestört" reagiert werden. Wird der Parameter umbenannt, wird die Änderung automatisch übernommen.

Zur Runtime wird während der Validierung überprüft, ob der Zielparameter vorhanden ist und die bei den Parametern verknüpften Variablen gültig und vom richtigen Typ sind.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Rezeptbeeinflussung

Interne ID: Reaktionsarten

Rezeptbeeinflussung

Enthält Eigenschaften für REE Modus und Kommando.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Erlaubt es:

  • den REE Modus zu ändern
  • REE Kommandos auszuführen
  • Grundfunktionskommandos auszuführen

Damit kann auf schwerwiegende Ereignisse, wie Wartezeiten überschritten oder Verknüpfte Variable gestört, reagiert werden-

Hinweis: Verwenden Sie diese Reaktionsart sorgsam, da diese Reaktionsart den gesamten Rezeptaublauf beeinflussen

Pro Ereignis können Sie jeweils nur ein einziges Mal:

  • den REE Modus setzen und

    Interne ID: Reaktionsarten

    REE Modus

    Über diese Reaktion kann in der Runtime den REE-Modus als Reaktion auf das Ereignisgesteuert werden.

    Auswahl des REE-Modus aus Dropdownliste:

    • Automatisch
    • Halbautomatisch
    • Ignorieren
    • Manuell

    Default: Ignorieren

    Hinweis: Pro Ereignis kann der REE Modus nur einmal gesetzt werden. Für alle weiteren Ereignisse des gleichen Typs wird der Modus automatisch auf Ignorieren gesetzt. Auch für "Runtime beenden" angestoßen wird der Modus automatisch auf Ignorieren gesetzt. Wird der Ereignis geändert auf ein Ereignis, für das bereits eine bestehende Reaktion für den REE-Modus konfiguriert wurde, wird die REE-Modus Reaktion vom geänderten Ereignis auf Ignorieren gesetzt. Ist noch keine Reaktion für den REE-Modus für das neue Ereignis vorhanden, wird die REE Modus Reaktion beibehalten. Ausnahme: "Runtime beenden" angestoßen.

    Interne ID: Reaktionsarten

    Ereignis

    Auswahl des Ereignistyps, bei dem die Reaktion ausgeführt werden soll, aus Dropdownliste.
    Für jedes Ereignis können mehrere Reaktionen definiert werden. Die Ausführungsreihenfolge kann in der Detailansicht festgelegt werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ein einziges Kommando absetzen.

    Interne ID: Reaktionsarten

    Kommando

    Rezept- oder Grundfunktionskommando, das zur Runtime beim Eintreten des Ereignisses ausgeführt wird. Rezeptkommandos beeinflussen die Ausführung des gesamten Rezepts. Grundfunktionskommandos beeinflussen nur jene Grundfunktion, für die die Reaktion konfiguriert wurde bzw. für die das Ereignis aufgetreten ist. Das Rezeptkommando bzw. Grundfunktionskommando wird zur Runtime nur ausgeführt, wenn das Kommando auch erlaubt ist. Zum Beispiel: Ein Rezept kann nicht fortgesetzt werden, wenn das Rezept gerade angehalten wird. Eine Grundfunktion kann nicht neu gestartet werden wenn die Grundfunktion in der Runtime pausiert ist, oder in Ausführung ist.

    Hinweis: Die Validierung des Rezepts in der Runtime prüft die Grundfunktionskommandos bzw. Rezeptkommandos nicht auf Plausibilität

    Auswahl des REE Kommandos aus Dropdownliste:

    • Grundfunktion anhalten
    • Grundfunktion fortsetzen
    • Grundfunktion neu starten
    • Grundfunktion pausieren
    • Ignorieren
    • Rezept abbrechen
    • Rezept anhalten
    • Rezept fortsetzen
    • Rezept neu starten
    • Rezept pausieren
    • Rezept stoppen

    Default: Ignorieren

    Hinweis: Pro Ereignis kann nur ein einziges Kommando gesetzt werden. Für alle weiteren Ereignisse des gleichen Typs wird die Eigenschaft automatisch auf Ignorieren gesetzt. Auch für "Runtime beenden" angestoßen wird die Eigenschaft automatisch auf Ignorieren gesetzt. Wenn der Ereignis geändert wird, wird diese Einstellung eventuell auch auf Ignorieren gesetzt.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Denn es ist zum Beispiel nicht sinnvoll, mit dem selben Ereignis das Rezept zu pausieren und es gleichzeitig anzuhalten.

Mehr über Kommandos lesen Sie im Kapitel Kommandos und Aktionen.


Parameter

Handbuch -> Batch Control -> Projektieren im Editor -> Parameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter sind die Kommunikationsschnittstelle zur Steuerung. Mit Ihnen werden Werte an die Steuerung übertragen und auch wieder zurückgelesen. Um im Modul Batch Control nicht mit komplexen und für den Anwender unverständlichen Variablennamen arbeiten zu müssen, gibt es die Abstrahierungsschicht. Jeder Parameter besteht - pro Grundfunktion - aus einem eindeutigen Namen und einer Beschreibung. Darin kann der Projektant dem Rezeptersteller bzw. dem Operator beschreiben, wofür der Parameter dient bzw. welche Auswirkungen er hat.

Zu einer Grundfunktion können Sie eine beliebige Anzahl an Parametern hinzufügen. Wir unterscheiden zwischen Befehlsparametern und Rückgabeparametern. Jeder Parameter kann jederzeit zwischen Befehls-und Rückgabeparameter umgeschaltet werden.

Noch in diesem Kapitel

Kontextmenü Parameter Aggregatsbaum

Detailansicht Parameter

Befehlsparameter

Rückgabeparameter

Beispiel für Statusparameter

Ausführungsdauer


Kontextmenü Parameter Aggregatsbaum

Handbuch -> Batch Control -> Projektieren im Editor -> Parameter -> Kontextmenü Parameter Aggregatsbaum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rechtsklick auf eine erstellte Grundfunktion öffnet ein Kontextmenü zur Erstellung der Parameter:

Parameter | Beschreibung
Befehlsparameter neu | Erstellt einen neuen Befehlsparamter.
Rückgabeparameter neu | Erstellt einen neuen Rückgabeparamter.
Umbenennen | Ermöglicht, den Namen der aktuell ausgewählten Grundfunktion zu ändern.
Löschen | Löscht die aktuell ausgewählte Grundfunktion nach einer Sicherheitsabfrage.
Hilfe | Öffnet die Online-Hilfe.


Detailansicht Parameter

Handbuch -> Batch Control -> Projektieren im Editor -> Parameter -> Detailansicht Parameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Befehlsparameter neu | Legt einen neuen Befehlsparameter in der Detailansicht an.
Rückgabeparameter neu | Legt einen neuen Rückgabeparameter in der Detailansicht an.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Zelle bearbeiten | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.


Befehlsparameter

Handbuch -> Batch Control -> Projektieren im Editor -> Parameter -> Befehlsparameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Befehlsparameter beinhalten die Sollwerte, die an die Steuerung übertragen werden. Beim Ausführen der Grundfunktion werden alle Befehlsparameter in die Steuerung geschrieben. Die genaue Beschreibung finden Sie im Kapitel: Ablauf einer Grundfunktion im Detail.

Befehlsparameter können auch in Transitionen, Bedingungen und Reaktionen verwendet werden.

Befehlsparameter verfügen über eine Vielzahl von EIgenschaften, die über das Eigenschaftenfenster eingestellt werden können. Jeder Parameter muss mit einer Variable verknüpft sein. Der Datentyp der Variable muss mit dem Datentyp des Parameters übereinstimmen und auch die Sollwertgrenzen des Parameters müssen innerhalb der Sollwertgrenzen der Variable liegen. Ist dies nicht der Fall werden bei der Validierung Fehlermeldungen ausgegeben.

Hinweis zur Eigenschaft Im Rezept änderbar: Damit wird festgelegt ob der Wert des Befehslparameters vom Ersteller des Vorlagenrezepts modifiziert werden darf. Sollen z.B. Maschinenparameter im Rezept nicht änderbar sein, sondern fix vorgegeben werden, muss diese Eigenschaft deaktiviert werden.

Interne ID: Befehlsparameter

Im Rezept änderbar

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl gesetzt wurde.

Interne ID: Befehlsparameter

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Befehlsparameter

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Rezeptersteller kann zur Runtime Parameter modifizieren.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Projektierung

Um einen neuen Befehlsparameter zu erstellen:

  1. selektieren Sie die gewünschte Grundfunktion
  2. wählen Sie im Kontextmenü den Befehl Befehlsparameter neu
  3. ein neuer Befehlsparameter wird in der Detailansicht angelegt


Rückgabeparameter

Handbuch -> Batch Control -> Projektieren im Editor -> Parameter -> Rückgabeparameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Rückgabeparameter beinhalten die Rückgabewerte, mit denen die Technologische Funktion der REE ihren Status mitteilt. Der Wert wird im Normalfall von der Steuerung gesetzt und von der REE ausgewertet. Rückgabeparameter können in Transitionen und Bedingungen ausgewertet werden.

Ebenso können sie in Reaktionen eingesetzt werden und sind dort auch beschreibbar. Dazu werden sie bei Parameter zuweisen und bei Parameter Sollwert setzen als Zielparameter angegeben.

Interne ID: Rückgabeparameter

Parameter Sollwert setzen

Enthält Eigenschaften für Parameter Sollwert setzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Rückgabeparameter

Parameter zuweisen

Enthält Eigenschaften für die Zuweisung von Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Projektierung

Um einen neuen Rückgabeparameter zu erstellen:

  1. selektieren Sie die gewünschte Grundfunktion, für die Sie einen neuen Rückgabeparameter erstellen wollen
  2. wählen Sie im Kontextmenü den Befehl Rückgabeparameter neu
  3. ein neuer Befehlsparameter wird in der Detailansicht angelegt


Beispiel für Statusparameter

Handbuch -> Batch Control -> Projektieren im Editor -> Parameter -> Beispiel für Statusparameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um mit der Steuerung kommunizieren zu können, benötigen Sie im Normalfall zwei Statusparameter:

  • einen in Schreibrichtung und
  • einen in Leserichtung

Die Variable hinter diesen Parametern sollten einen numerischen Datentypen haben wie USINT oder UINT.
Wir empfehlen, dass Sie beide Parameter als Rückgabeparameter ausführen. Das mag für die Kommandos in Schreibrichtung im ersten Moment unlogisch scheinen, hat aber folgenden Hintergrund: Die Befehlsparameter werden beim Ausführen der Grundfunktion immer alle abgesetzt. Damit sind Sie auch in der Liste der Befehlsparameter sichtbar und können so auch versehentlich geändert werden. Bei einem Kommando für die Steuerung ist das nicht sinnvoll. Es geht nicht nur darum, einen einzelnen Wert zur Steuerung als Befehl zu kommunizieren, sondern den Status der Grundfunktion im Rezept zu übermitteln.

Gerade beim Schreiben der Befehlsparameter ist es sinnvoll, der SPS nicht einfach das Schreiben an sich mitzuteilen, sondern den Zustand wenn alle Werte geschrieben worden sind und die SPS daher mit der Abarbeitung der Technologischen Funktion beginnen kann.

Dazu verwenden Sie am besten die Reaktion auf das Ereignis Befehlsparameter fertig abgesetzt. Bei Reaktionen auf ein Ereignis kann man auch Werte auf einen Rückgabeparameter schreiben. Daher ist es vernünftiger hier für beide Statusparameter Rückgabeparameter zu verwenden.

Hier ein Beispiel, welche Werte die Parameter annehmen können:

Statusparameter in Schreibrichtung (zur SPS): Kommandos

Wert

Name des Ereignisses

0

nicht definiert

1

Grundfunktion gestartet

2

Befehlsparameter fertig abgesetzt

3

Grundfunktion beendet: Weiterschaltbedingung erfüllt und Minimale Ausführungsdauer erreicht (falls projektiert)

Interne ID: Beispiel für Statusparameter

Minimale Ausführungsdauer

Minimale Ausführungsdauer der Grundfunktion.

  • >0: Zeitraum, der nach dem Schreiben der Befehlsparameter mindestens gewartet wird, unabhängig davon, ob die Weiterschaltbedingung erfüllt ist.
  • 0: Ausführungsdauer wird nicht überprüft

Minimale Ausführungsdauer kann Maximale Ausführungsdauer überschreiten.

Interne ID: Beispiel für Statusparameter

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: Beispiel für Statusparameter

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

4

Grundfunktion abgeschlossen

5-9

Reserve

10

Statuswechsel: Pausierend

11

Statuswechsel: Fortsetzend

12

Statuswechsel: Anhaltend

13

Statuswechsel: Neustartend

14

Statuswechsel: Stoppend

15

Statuswechsel: Abbrechend

16-19

Reserve

20

REE Moduswechsel: Automatisch

21

REE Moduswechsel: Semiautomatisch

22

REE Moduswechsel: Manuell

23-29

Reserve

30

Runtime beenden angestoßen

31

Runtime Wiederanlauf

32

Aggregatsbelegung nicht möglich

33

Wartezeit Aggregatsbelegung überschritten

34

Eingangsverriegelung blockiert

35

Wartezeit Eingangsverriegelung überschritten

36

Wartezeit Weiterschaltbedingung überschritten

37

Wartezeit nachfolgende Bedingung überschritten

38

Grundfunktion mehrfach gestartet

Die genaue Bedeutung der Ereignisse finden Sie im Kapitel Ereignisstyp.

Für jeden Eintrag in der Tabelle legen Sie eine entsprechende Reaktion zum Schreiben des Statuswerts bei der Grundfunktion an.
Tipp: Verwenden Sie bei allen Grundfunktionen die selben Parameterbezeichnungen, z.B.: StatusGrundfunktion. Sie müssen dann die Reaktionen nur bei einer einzigen Grundfunktion projektieren und können diese mit Copy & Paste an alle Grundfunktionen übertragen. Sie können natürlich auch die Parameter kopieren. Vergessen Sie dabei jedoch nicht, die Variablen richtig zu stellen. Diese müssen zur jeweiligen Grundfunktion passen.

Parameter in Leserichtung (von der SPS): Rückgabewerte

Wert | Beschreibung | Verknüpft in der Eigenschaft
0 - 1 | Nicht definiert |
2 | Technologische Funktion abgeschlossen | Weiterschaltbedingung
3 - 9 | Reserve |
10 | Technologische Funktion pausiert | Pausiert Interne ID: Beispiel für Statusparameter Pausiert Bedingung für den Wechsel von pausierend auf pausiert. Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden. Mehr in der Online-Hilfe. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""
11 | Reserve |
12 | Technologische Funktion angehalten | Angehalten Interne ID: Beispiel für Statusparameter Angehalten Bedingung für den Wechsel von anhaltend auf angehalten. Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden. Mehr in der Online-Hilfe. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""
13 | Technologische Funktion neu gestartet | Neu gestartet Interne ID: Beispiel für Statusparameter Neu gestartet Bedingung für den Wechsel von neu startend auf laufend. Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden. Mehr in der Online-Hilfe. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""
14 | Technologische Funktion gestoppt | Gestoppt Interne ID: Beispiel für Statusparameter Gestoppt Bedingung für den Wechsel von stoppend auf gestoppt. Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden. Mehr in der Online-Hilfe. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""
15 | Technologische Funktion abgebrochen | Abbgebrochen Interne ID: Beispiel für Statusparameter Abbgebrochen Bedingung für den Wechsel von abbrechend auf abgebrochen. Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden. Mehr in der Online-Hilfe. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verknüpfen Sie die Werte mit einer Formel in der jeweiligen Eigenschaft.

Tipp: Sie können die Formel kopieren und nur den jeweiligen Wert ändern. Wenn Sie diese Einstellung ganz zu Beginn der Parametrierung der ersten Grundfunktion durchführen, können Sie die gesamte Grundfunktion kopieren und verfügen damit bei allen Grundfunktionen über diese Einstellungen .


Ausführungsdauer

Handbuch -> Batch Control -> Projektieren im Editor -> Parameter -> Ausführungsdauer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Ausführungsdauer wird über zwei Eigenschaften, die nicht zusammenhängen, geregelt. Ihre Werte müssen sich also nicht sinnvoll ergänzen.

Maximale Ausführungsdauer

Die Maximale Ausführungsdauer bezieht sich auf Grundfunktion abgeschlossen und damit auf den Prozess. Sie hängt nicht mit der Minimalen Ausführungsdauer zusammen.

Interne ID: Ausführungsdauer

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: Ausführungsdauer

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Minimale Ausführungsdauer

Die Eigenschaft Minimale Ausführungsdauer legt fest, wie lange in zenon nach dem Schreiben der Befehlsparameter gewartet wird, unabhängig vom Prüfen der Weiterschaltbedingung. Während der Ausführung wird die minimale Ausführungsdauer geprüft. Ist der Wert größer 0, wird nach ihrem Ablauf ein Ereignis ausgelöst. Das geschieht unabhängig davon, ob die Grundfunktion immer noch ihre Weiterschaltbedingung prüft oder nur noch auf die Minimale Ausführungsdauer wartet.

Interne ID: Ausführungsdauer

Minimale Ausführungsdauer

Minimale Ausführungsdauer der Grundfunktion.

  • >0: Zeitraum, der nach dem Schreiben der Befehlsparameter mindestens gewartet wird, unabhängig davon, ob die Weiterschaltbedingung erfüllt ist.
  • 0: Ausführungsdauer wird nicht überprüft

Minimale Ausführungsdauer kann Maximale Ausführungsdauer überschreiten.

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Länge der Minimalen Ausführungsdauer kann auch die der Maximalen Ausführungsdauer überschreiten.

Beispiel

  • Es gibt eine Grundfunktion: Rühren einschalten. Die Bestätigung, dass der Rührer läuft, darf maximal 5 Sekunden dauern, bevor vor einem Fehler gewarnt wird.
    Projektierung: Eigenschaft Maximale Ausführungsdauer erhält Wert 5 Sekunden mit entsprechender Reaktion.
  • Der Mixer soll aber 15 Minuten lang laufen, bevor die nächste Grundfunktion ausgeführt wird.
    Projektierung: Eigenschaft Minimale Ausführungsdauer erhält Wert 15 Minuten.

Damit beträgt die Minimale Ausführungsdauer 15 Minuten und die Maximale Ausführungsdauer 5 Sekunden.


Eingangsverriegelung

Handbuch -> Batch Control -> Projektieren im Editor -> Eingangsverriegelung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit einer Eingangsverriegelung wird eine Grundfunktion zur Runtime erst ausgeführt, wenn die Bedingung für die Eingangsverriegelung erfüllt wurde.

Die Eingangsverriegelung wird über die Eigenschaft Eingangsverriegelung konfiguriert. Über den Formeleditor wird die Bedingung, die die Eingangsverriegelung erfüllen muss, definiert. Die Formel kann aus einem oder mehreren Befehlsparameter und/oder Rückgabeparameter der Grundfunktion bestehen. Auch Wert und Status der Variablen können verwendet werden. Die Formel gibt TRUE oder FALSE als Ergebnis aus. Die Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Wartezeit für die Eingangsverriegelung wird mit der Eigenschaft Wartezeit Eingangsverrieglung konfiguriert.

Interne ID: Eingangsverriegelung

Wartezeit Eingangsverrieglung

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Eingangsverriegelung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Beginn der Prüfung der Eingangsverriegelung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Eingangsverriegelung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Eingangsverriegelung

Eingangsverriegelung

Definiert Bedingung für Eingangsverriegelung. Klick auf Schaltfläche ... oder Eintrag öffnet den Formeleditor zur Definition einer Bedingung.
Wird eine Eingangsverriegelung konfiguriert, dann wird die Grundfunktion zur Runtime erst ausgeführt, wenn die Bedingung für die Eingangsverriegelung erfüllt wurde. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Die Formel gibt TRUE oder FALSE als Ergebnis aus. Die Bedingung kann zur Runtime angezeigt, aber nicht verändert werden.
Die Wartezeit für die Eingangsverriegelung wird mit der Eigenschaft Wartezeit Eingangsverrieglung konfiguriert.

Mehr in der Online-Hilfe .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wenn eine Eingangsverriegelung definiert wurde, erfolgt die Ausführung einer Grundfunktion, sobald folgende Bedingungen erfüllt sind:

  • die Grundfunktion ist aktiv
  • das Aggregat ist belegt
  • die Grundfunktion ist nicht doppelt aktiv
  • die Grundfunktion wird nicht bereits ausgeführt
  • die Eingangsverriegelung ist erfüllt

Wenn keine Eingangsverriegelung verknüpft ist, wird die Grundfunktion ausgeführt, sobald:

  • die Grundfunktion aktiv wird
  • das Aggregat belegt ist
  • die Grundfunktion nicht zwei mal ausgeführt wird
  • die benötigten Variablen alle einen Wert bekommen haben

info Info

Informationen zum Verhalten einer Eingangsverriegelung finden Sie auch im Kapitel Ablauf einer Grundfunktion im Detail.


Bild vom Typ Batch Control anlegen

Handbuch -> Batch Control -> Projektieren im Editor -> Bild vom Typ Batch Control anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Bild vom Typ Batch Control werden Vorlagenrezepte und/oder Steuerrezepte:

  • erstellt
  • verwaltet
  • in der Runtime ausgeführt

Die Darstellungsgröße des Bildes hängt von der gewählten Schablonengröße ab.

Um ein Bild vom Typ Batch Control anzulegen:

  1. wählen Sie im Knoten Bilder im Kontextmenü den Befehl Bild neu
  2. wählen Sie in der Spalte Bildtyp in der Dropdownliste Batch Control aus
  3. wählen Sie in der Menüleiste Kontrollelemente eine der drei Default Einstellungen:
    • Vorlage einfügen: bietet Vorlagen für unterschiedliche Auflösungen und Auswahl von nur Vorlagenrezept oder Standard (Vorlagen- und Steuerrezept)
    • Default Vorlagenrezept: fügt ausgewählte Elemente für ein Vorlagenrezept ein
    • Default Steuerrezept: fügt ausgewählte Elemente für ein Steuerrezept ein
  4. die Standardelemente für die gewünschte Einstellungen werden erstellt
  5. bei Bedarf fügen Sie weitere Kontrollelemente aus dem Menü Kontrollelemente hinzu
  6. erstellen Sie eine Bildumschaltung, um das Bild in der Runtime anzuzeigen

Element

Beschreibung

Vorlage einfügen

Fügt Kontrollelemente für Vorlagenrezepte und/oder Steuerrezepte an vordefinierten Stellen in das Bild ein. Diese Kontrollelemente können ergänzt, reduziert und neu positioniert werden.

Default (Vorlagenrezepte)

Fügt Kontrollelemente für Vorlagenrezepte an vordefinierten Stellen in das Bild ein. Diese Kontrollelemente können ergänzt, reduziert und neu positioniert werden.

Default (Steuerrezepte)

Fügt Kontrollelemente für Steuerrezepte an vordefinierten Stellen in das Bild ein. Diese Kontrollelemente können ergänzt, reduziert und neu positioniert werden.

Rezepteditor

Fügt den lizenzierten Editor zur Erstellung von Master- und Steuerrezepten ein.

Vorlagenrezepte

Kontrollelemente für Vorlagenrezepte.

Liste Vorlagenrezepte

In dieser Liste können alle Vorlagenrezepte angezeigt werden. Die Anzeige kann durch Filter auf eine individuelle Auswahl eingeschränkt werden.

Die Filterung kann bereits im zenon Editor in der Bildumschaltungsfunktion voreingestellt werden. Eine Online Filterung ist auch möglich. Diese Filter werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Alle Kommandos sind auch in den Kontextmenüs der Liste möglich. Die Kommandos zur Listenverwaltung sind in der Kopfzeile der Liste aufrufbar, die Kommandos zur Rezeptverwaltung beim Editieren eines oder mehrerer Rezepte.

Die Rezept in der Liste können nicht direkt in der Liste editiert werden. Umbenennen, ändern der Beschreibung oder ändern des Rezeptstatus sind nur mittels der jeweiligen Kommandos möglich.

Spaltenauswahl Vorlagenrezepte...

Öffnet einen Dialog, um festzulegen, welche Spalten dargestellt werden sollen.
Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Spalten formatieren Vorlagenrezepte...

Öffnet einen Dialog, um die Spalteneinstellungen zu ändern.
Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Vorlagenrezept neu...

Öffnet den Dialog zum Erstellen eines neuen Vorlagenrezepts.

Vorlagenrezept umbenennen

Nur aktiv, wenn genau ein Vorlagenrezept selektiert wurde.
Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.
Rezepte können nur im Status Edierbar umbenannt werden.
Verwenden Sie diese Funktion auch, um die Beschreibung des Vorlagenrezepts zu ändern.

Beim Umbenennen eines Rezepts wird ein CEL Eintrag erzeugt.

Vorlagenrezept duplizieren

Nur aktiv, wenn genau ein Rezept selektiert wurde.
Erstellt eine Kopie des selektierten Rezepts. Beim Erzeugen der Kopie wird die auf der Festplatte gespeicherte Version verwendet. Wird das Rezept gerade auf einem anderen Rechner editiert, und die Änderungen sind noch nicht gespeichert, werden diese Änderungen nicht übernommen. Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.

Die Kopie des Rezepts erhält automatisch den Status Editierbar und kann daher weiter bearbeitet werden.

Beim Duplizieren eines Rezepts wird ein CEL Eintrag erzeugt.

Vorlagenrezept löschen

Löscht die selektierten Rezepte unwiderruflich. Ist das Rezept auf einem anderen Rechner im Editor geöffnet, wird es dort automatisch geschlossen.

Löschen ist nur möglich, wenn es keine Steuerrezepte gibt, die auf dem Vorlagenrezept basieren. Es müssen zuerst alle Steuerrezepte gelöscht werden.
Rezepte die gerade im Testmodus ausgeführt werden (Vorlagenrezept Status: Test in Ausführung), können nicht gelöscht werden. Sie müssen zuerst Abgeschlossen, Gestoppt oder Abgebrochen werden.

Dürfen Rezepte nicht gelöscht werden, z.B. im FDA reglementiertem Umfeld, empfiehlt es sich, diesen Button nicht zu projektieren bzw. mit einer entsprechenden Berechtigungsebene zu versehen.
Beim Löschen eines Rezepts wird ein CEL Eintrag erzeugt.

Interne ID: Bild vom Typ Batch Control anlegen

Berechtigungsebene

Passwortlevel für das Setzen von Sollwerten oder das Ausführen von Funktionen mit dem ausgewählten dynamischen Element.
Minimum: 0.
Maximum: 127.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Vorlagenrezept öffnen

Öffnet die selektierten Vorlagenrezepte im Rezepteditor, sofern das Bildelement Rezepteditor im Bild vorhanden ist. Jedes selektierte Vorlagenrezept wird in einer eigenen Registerkarte des Rezepteditors geöffnet.

Vorlagenrezept in Editiermodus umschalten

Ändert den Vorlagenrezept Status der selektierten Rezepte auf Editierbar. In diesem Status können Rezepte wieder komplett bearbeitet werden.
Nur Rezepte im Testmodus können wieder auf Editierbar geschaltet werden.

Vorlagenrezept in Testmodus Editiermodus umschalten

Ändert den Vorlagenrezept Status der selektierten Rezepte auf Testmodus. Nur fehlerfreie Rezepte können in den Testmodus umgeschaltet werden. Treten bei der Validierung Fehler auf, müssen diese zuerst behoben werden.

Rezepte im Testmodus können ausgeführt, aber nicht mehr umprojektiert werden. Details zu den Status finden Sie im Kapitel Rezeptarten und Rezeptstatus

Vorlagenrezept freigeben

Ändert den Vorlagenrezept Status der selektierten Rezepte auf Freigegeben. Nur fehlerfreie Rezepte können frei gegeben werden. Treten bei der Validierung Fehler auf, müssen diese zuerst behoben werden.
Nur Rezepte im Status Testmodus und Editierbar können frei gegeben werden.

Frei gegeben Rezepte könne nicht mehr verändert werden. Nur von frei gegeben Rezepten können Steuerrezepte erstellt werden.
Details zu den Status finden Sie im Kapitel Rezeptarten und Rezeptstatus

Beim Freigeben eines Rezepts wird ein CEL Eintrag erzeugt.

Zugehörige Steuerrezepte in Liste anzeigen

Öffnet alle Steuerrezepte, die auf den selektierten Vorlagenrezepten basieren und den eingestellten Filterkriterien entsprechen.

Filter zum Anzeigen der Steuerrezepte

Ermöglicht Filterung der Steuerrezepte nach Kriterien:

  • Aktuell ausgeführte Steuerrezepte:
    Zeigt nur die Steuerrezepte an, die gerade ausgeführt werden. Wirkt sich erst aus, sobald Sie auf Zugehörige Steuerrezepte in der Liste anzeigen klicken.
  • Vorbereitete Steuerrezepte:
    Zeigt die Steuerrezepte, die zur Ausführung vorbereitet sind. Wirkt sich erst aus, sobald Sie auf Zugehörige Steuerrezepte in der Liste anzeigen klicken.
  • Abgeschlossene Steuerrezepte:
    Zeigt nur die Steuerrezepte, die bereits ausgeführt wurden. Wirkt sich erst aus, sobald Sie auf Zugehörige Steuerrezepte in der Liste anzeigen klicken.

Steuerrezepte

Kontrollelemente für Steuerrezepte.

Liste Steuerrezepte...

In dieser Liste können alle Steuerrezepte angezeigt werden. Die Anzeige kann durch Filter auf eine individuelle Auswahl eingeschränkt werden.

Standardmäßig ist die Liste immer leer. Zum Befüllend er Liste müssen:

  • Vorlagenrezepte selektiert werden
  • die Filter
    aktuell ausgeführte Steuerrezepte,
    vorbereitetet Steuerrezepte und
    abgeschlossene Steuerrezepte
    gesetzt sein
  • der Button Zugehörige Steuerrezepte in Liste anzeigen gedrückt werden

Zusätzlich zu den oben erwähnten Filtern kann die Liste selbst noch gefiltert werden. Die Filterung kann bereits im zenon Editor in der Bildumschaltungsfunktion voreingestellt werden. Eine Online Filterung ist auch möglich. Diese Filter werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Alle Kommandos sind auch in den Kontextmenüs der Liste möglich. Die Kommandos zur Listenverwaltung sind in der Kopfzeile der Liste aufrufbar, die Kommandos zur Rezeptverwaltung beim Editieren eines oder mehrerer Rezepte.
Die Rezept in der Liste können nicht direkt in der Liste editiert werden. Umbenennen, ändern der Beschreibung oder das Starten des Rezepts ist nur mittels der jeweiligen Kommandos möglich.

Spaltenauswahl Steuerrezepte...

Öffnet einen Dialog, um festzulegen, welche Spalten dargestellt werden sollen.
Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Spalten formatieren Steuerrezepte...

Öffnet einen Dialog, um die Spalteneinstellungen zu ändern.
Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Steuerrezept neu ...

Öffnet den Dialog zur Eingabe eines eindeutigen Namens und einer Beschreibung für das Steuerrezept. Die Eindeutigkeit des Namens wird auch im zenon Netzwerk geprüft. Der Name muss nur innerhalb des Vorlagenrezepts eindeutig sein. Steuerrezepte, die auf anderen Vorlagenrezepten basieren, dürfen über den selben Namen verfügen. Die Eindeutigkeit innerhalb des Moduls Batch Control wird erreicht, indem immer der Vorlagenrezeptname und der Steuerrezeptname referenziert werden.

Beim Anlegen eines Steuerrezepts wird ein CEL Eintrag erzeugt.

Steuerrezept umbenennen

Nur aktiv, wenn genau ein Steuerrezept selektiert wurde.
Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.
Rezepte können nur im Status Vorbereitet umbenannt werden.
Verwenden Sie diese Funktion auch, um die Beschreibung des Steuerrezepts zu ändern.

Steuerrezept duplizieren

Nur aktiv, wenn genau ein Rezept selektiert wurde.
Erstellt eine Kopie des selektierten Rezepts. Beim Erzeugen der Kopie wird die auf der Festplatte gespeicherte Version verwendet. Wird das Rezept gerade auf einem anderen Rechner editiert, und die Änderungen sind noch nicht gespeichert, werden diese Änderungen nicht übernommen. Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.

Die Kopie des Rezepts erhält automatisch den Status Vorbereitet und kann daher weiter bearbeitet oder gestartet werden. Der REE Status des Duplikats wird auf Automatisch gesetzt.

Beim Duplizieren eines Rezepts wird ein CEL Eintrag erzeugt.

Steuerrezept löschen

Löscht die selektierten Rezepte unwiderruflich. Ist das Rezept auf einem anderen Rechner im Editor geöffnet, wird es dort automatisch geschlossen.

Löschen ist nur möglich, wenn alle selektierten Rezepte nicht ausgeführt werden (Steuerrezept Status: In Ausführung). Sie müssen zuerst Abgeschlossen, Gestoppt oder Abgebrochen werden.

Dürfen Rezepte nicht gelöscht werden, z.B. im FDA reglementiertem Umfeld, empfiehlt es sich, diesen Button nicht zu projektieren bzw. mit einer entsprechenden Berechtigungsebene zu versehen.
Beim Löschen eines Rezepts wird ein CEL Eintrag erzeugt.

Steuerrezept öffnen

Öffnet die selektierten Steuerrezepte im Rezepteditor, sofern das Bildelement Rezepteditor im Bild vorhanden ist. Jedes selektierte Steuerrezept wird in einer eigenen Registerkarte des Rezepteditors geöffnet.

Steuerrezept starten

Startet die selektierten Steuerrezepte im eingestellten REE Modus. Die Rezepte werden unsichtbar am Server ausgeführt. Es ist nicht erforderlich, dass das Rezept im Rezepteditor geöffnet ist.


Bildumschaltung Batch Control

Handbuch -> Batch Control -> Projektieren im Editor -> Bildumschaltung Batch Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Batch Control in der Runtime zu nutzen, projektieren Sie eine Bildumschaltung auf ein Bild vom Typ Batch Control:

  1. wählen Sie im Knoten Funktionen im Kontextmenü den Eintrag Funktion neu
  2. wählen Sie die Funktion Bildumschaltung
  3. wählen Sie das Bild vom Typ Batch Control
  4. der Filterdialog wird angezeigt
  5. konfigurieren Sie die Spalteneinstellungen für die Liste der Vorlagenrezepte/Steuerrezepte nach Ihren Wünschen
  6. konfigurieren Sie die gewünschte Vorfilterung der Vorlagenrezepte/Steuerrezepte
  7. verknüpfen Sie die Funktion mit einem Button im Bild, um in der Runtime umzuschalten

Noch in diesem Kapitel

Spalteneinstellungen

Vorfilterung


Spalteneinstellungen

Handbuch -> Batch Control -> Projektieren im Editor -> Bildumschaltung Batch Control -> Spalteneinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Spalteneinstellungen werden konfiguriert für:

  • Liste der Vorlagenrezepte
  • Liste der Steuerrezepte

Parameter | Beschreibung
Listenfeld | Darstellung der konfigurierten Spalten.
Spaltenauswahl | Öffnet Dialog zur Auswahl der Spalten.
Spaltenformat | Öffnet Dialog zur Formatierung der Spalten.
OK | Übernimmt alle Änderungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Spaltenauswahl

Spaltenformat


Spaltenauswahl

Handbuch -> Batch Control -> Projektieren im Editor -> Bildumschaltung Batch Control -> Spalteneinstellungen -> Spaltenauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Spaltenauswahl für Liste der Vorlagenrezepte:

Spaltenauswahl für Liste der Steuerrezepte:

Schaltfläche | Funktion
Hinzufügen | Verschiebt die markierten Spalten aus den verfügbaren zu den ausgewählten. Nach der Bestätigung des Dialogs mit OK werden sie in der Detailansicht angezeigt.
Alle hinzufügen | Verschiebt alle verfügbaren Spalten zu den ausgewählten Spalten.
Entfernen | Entfernt die markierten Spalten aus den ausgewählten und zeigt sie in der Liste der verfügbaren Spalten an. Nach der Bestätigung des Dialogs mit OK werden sie aus der Detailansicht entfernt.
Alle entfernen | Entfernt alle Spalten aus der Liste der ausgewählten Spalten.
Nach oben | Verschiebt den ausgewählten Eintrag nach oben. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
Nach unten | Verschiebt den ausgewählten Eintrag nach unten. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Spaltenformat

Handbuch -> Batch Control -> Projektieren im Editor -> Bildumschaltung Batch Control -> Spalteneinstellungen -> Spaltenformat

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Dialog definieren Sie das Spaltenformat:

Parameter

Beschreibung

Verfügbare Spalten

Liste der über Spaltenauswahl bereit gestellten Spalten. Die hier selektierte Spalte wird über die Einstellungen der Sektion Parameter konfiguriert.

Parameter

Einstellungen für ausgewählte Spalte.

Beschriftung

Name für Spaltentitel. Der Spaltentitel ist online sprachumschaltbar. Dazu müsen Sie ein @ Zeichen vor den Namen eingeben.

Breite

Breite der Spalte in Zeichen.
Berechnung: Zahl mal durchschnittlicher Zeichenbreite der gewählten Schriftart.

Ausrichtung

Ausrichtung.

Mögliche Einstellungen:

  • Linksbündig: Text wird in der Spalte am linken Rand ausgerichtet.
  • Zentriert: Text wird in der Spalte zentriert dargestellt.
  • Rechtsbündig: Text wird in der Spalte am rechten Rand ausgerichtet.

Spaltenfilter im Prozessbild sperren

Aktiv: Der Filter für diese Spalte kann zur Runtime nicht verändert werden.

Hinweis: Nur verfügbar für:

  • Batch Control
  • Erweiterter Trend
  • Message Control
  • Rezeptgruppen-Manager

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Vorfilterung

Handbuch -> Batch Control -> Projektieren im Editor -> Bildumschaltung Batch Control -> Vorfilterung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit in der Runtime nicht ständig alle Rezepte in den Rezeptlisten geladen werden müssen, können Sie bereits in der Bildumschaltungsfunktion Filter festlegen. Dazu:

  1. klicken Sie in der Bildumschaltungsfunktion bei der Liste der Vorlagenrezepte oder bei der Liste der Steuerrezepte in einen Spaltenfilter
  2. geben dort den gewünschten Filtertext ein, wobei Wildcards in Form von Asterisks (*) zulässig sind:
    z.B. bei der Liste der Vorlagenrezepte in der Spalte Vorlagenrezept Status den Text In Ausf*
  3. bestätigen Sie den Filtertext mit der Taste Eingabe, damit er übernommen wird.

In der Runtime werden dann in der Liste der Vorlagenrezepte nur Rezepte erscheinen, die gerade im Testmodus sind und gerade ausgeführt werden. Sie können beliebig viele Spaltenfilter gleichzeitig anwenden.

Wenn Sie möchten, dass der Anwender den Filter zur Laufzeit nicht entfernen kann, dann öffnen Sie den Dialog Spaltenformat... und aktivieren Sie die Option Spaltenfilter im Prozessbild sperren. Dadurch kann der Anwender in der Runtime den Filter nicht modifzieren und bekommt daher Rezepte, die er z.B. nicht modifizieren darf, gar nicht angezeigt.


Konfigurieren und steuern in der Runtime

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die komplette Verwaltung, Erstellung und Abarbeitung der Rezepte erfolgt in der Runtime. Eine Bearbeitung im zenon Editor ist nicht möglich.

Überprüfung auf Änderungen im Editor

Beim Laden eines Rezepts wird überprüft, ob die Projektierung von Aggregaten, Grundfunktionen usw. im Editor verändert wurde. Wird eine Änderung festgestellt, dann wird diese in das Objekt, dem die geänderte Funktion zugeordnet ist, übernommen. Einstellungen, die in der Runtime überschrieben werden, bleiben erhalten. Wenn das Rezept verändert wurde, wird dies durch einen Asterisk (*) angezeigt. Laden umfasst öffnen, duplizieren und freigeben eines Rezepts.

Beim Nachladen wird das Rezept ebenfalls geprüft.

info Info

Aktualisiert werden nur Rezepte, die sich im Editiermodus oder im Testmodus befinden. Rezepte im Testmodus, die sich gerade in Ausführung befinden, werden erst nach dem Beenden der Ausführung aktualisiert.

Soll ein verändertes Rezept freigeben werden, das noch nicht gespeichert wurde, erfolgt eine Abfrage mit der Möglichkeit:

  • das aktuelle Rezept frei zu geben
  • das gespeicherte Rezept frei zu geben
  • den Freigabevorgang abzubrechen

attention Achtung

Änderungen an Grundfunktionen im Editor werden beim Freigeben eines Rezepts zur Runtime ohne Warnmeldung übernommen. Für alle Daten, die in der Runtime nicht überschrieben werden, ist der Editor das führende System.

Auswahlverfahren in Listen:

  • Taste Strg+A: wählt alle Elemente aus
  • Taste Strg+Mausklick: fügt Vorlagenrezept zur bestehenden Auswahl hinzu
  • Taste Strg+Umschalt+Mausklick: Erweitert Auswahl vom aktuell ausgewählten Vorlagenrezept bis zum angeklickten Vorlagenrezept

Noch in diesem Kapitel

Kommandos und Aktionen

Projektierungsregeln für Rezepte

Statuszeile

Rezeptarten und Rezeptstatus

Vorlagenrezepte

Rezepte validieren

Steuerrezepte

Rezepte verwalten

Recipe Execution Engine (REE)


Kommandos und Aktionen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Kommandos und Aktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime stehen Kommandos und Aktionen zur Verfügung:

  • Kommandos wirken sich auf den Rezeptablauf aus.
  • Aktionen ermöglichen die Bearbeitung von Rezepten.

Kommandos

Damit ein Kommando für die Grundfunktion akzeptiert wird, sind folgende Voraussetzungen nötig:

  • Die REE muss laufen.
  • Die Grundfunktionen muss aktiv sein.
  • Die Grundfunktion muss sich in einem Status befinden, in dem das Kommando erlaubt ist.

Durch Mehrfachselektion kann das Kommando im gleichen Ausführungszyklus an mehrere Grundfunktionen gesendet werden.

Kommando | Beschreibung
Rezept starten | Startet den Rezeptablauf.
Rezept pausieren | Pausiert den Ablauf des Rezepts.
Rezept fortsetzen | Setzt ein angehaltenes oder pausiertes Rezept fort.
Rezept anhalten | Hält den Rezeptablauf an.
Rezept neu starten | Startet das Rezept neu.
Rezept stoppen | Stoppt das Rezept.
Rezept abbrechen | Bricht das Rezept ab.
Grundfunktion pausieren | Pausiert die Grundfunktion.
Grundfunktion fortsetzen | Setzt die Grundfunktion fort.
Grundfunktion anhalten | Hält die Grundfunktion an.
Grundfunktion neu starten | Startet die Grundfunktion neu.
Umschalten in Automatischen Modus | Schaltet die REE in Automatischen Modus um.
Umschalten in Semiautomatischen Modus | Schaltet die REE in Semiautomatischen Modus um.
Umschalten in Manuellen Modus | Schaltet die REE in Manuellen Modus um.
Rezept nur an selektierten Ausführungspositionen fortsetzen | Setzt ein Rezept nur an den ausgewählten Positionen fort.
Rezept an allen Ausführungspositionen fortsetzen | Setzt ein Rezept an allen zur Verfügung stehenden Positionen fort.
Anstehende Bedingung überspringen | Überspringt eine anstehende Bedingung. Nur im Manuellen Modus möglich.

Erlaubte Kommandos

Für Rezeptkommandos und Grundfunktionskommandos gelten Ausführungsbedingungen. Zum Beispiel kann das Steuerrezept nicht mehr gestoppt werden, wenn es den Status Abbrechen hat.

Hinweis: Das Kommando Reset ist im zenon Batch Control nicht implementiert.

Überblick über Kommandos in Batch Control

Hinweis: Dieser Überblick ist dem ANSI/ISA-S88 Standard entnommen (Grafik 18).

Aktionen

Aktion | Beschreibung
Rezept auf Fehler prüfen | Überprüft den Rezeptablauf auf Fehler und gibt Fehlermeldungen aus.
Element bearbeiten | Öffnet den jeweiligen Dialog zur Bearbeitung des ausgewählten Elements.
Raster anzeigen/ausblenden | Schaltet beim PFC-Editor zwischen ANzeige und AUsblendung der Gitternetzlinien um.
Hintergrundfarbe und Rasterfarbe ändern | Öffnet den Dialog zum Ändern der Hintergrundfarbe und der Rasterfarbe.
Rezept duplizieren | Kopiert das ausgewählte Rezept und fügt es als Kopie in die Liste ein.
Steuerrezept erzeugen | Erzeugt ein Steuerrezept.
Vorlagenrezept neu | Öffnet den Dialog zur Erstellung eines neuen Rezepts.
Vorlagenrezept speichern | Speichert alle Änderungen, die in einem Vorlagenrezept seit der letzten Speicherung vorgenommen wurden.
Löschen | Löscht das ausgewählte Element.
Grundfunktion austauschen | Öffnet den Dialog zur Auswahl einer Grundfunktion. Die bisherige Grundfunktion wird durch die neu gewählte ersetzt.
Bearbeitungsmodus | Schaltet den Mauszeiger vom Einfügen eines Elements um auf Bearbeitungsmodus. Das Zurückschalten in den Bearbeitungsmodus kann auch mit Druck auf die Taste Esc erfolgen.
Grundfunktion einfügen | Besetzt den Mauszeiger mit einer Grundfunktion. Diese kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Transition einfügen | Besetzt den Mauszeiger mit einer Transition. Diese kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Anfang Parallelzweig einfügen | Besetzt den Mauszeiger mit einem Anfang Parallelzweig. Dieser kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Ende Parallelzweig einfügen | Besetzt den Mauszeiger mit einem Ende Parallelzweig. Dieses kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Anfang Verzweigung einfügen | Besetzt den Mauszeiger mit einem Anfang Verzweigung. Dieser kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Ende Verzweigung einfügen | Besetzt den Mauszeiger mit einem Ende Verzweigung. Dieses kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Aggregatsbelegung einfügen | Besetzt den Mauszeiger mit einer Aggregatsbelegung. Diese kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Sprungziel einfügen | Besetzt den Mauszeiger mit einem Sprungziel. Dieses kann per Klick an jeder erlaubten, freien Stelle eingefügt werden.
Rezept in den Testmodus umschalten | Schaltet das Rezept in den Testmodus um.
Rezept freigeben | Gibt das Rezept frei. Damit kann ein Steuerrezept erzeugt werden.


Projektierungsregeln für Rezepte

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Projektierungsregeln für Rezepte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Projektieren gelten im Allgemeinen die im Standard ANSI/ISA–S88 definierten Regeln.

Wichtige Grundsätze:

Allgemein

  • Bei allen Elementen müssen immer alle Verbindungspunkte verbunden sein.
    Ausnahme: Sprungziel-Element. Hier müssen mindestens der Ausgangs-Verbindungspunkt und ein Eingangs-Verbindungspunkt verbunden sein.
  • Das Anfangselement ist immer genau einmal vorhanden und markiert den Beginn des Ablaufs.
  • Das Endeelement ist immer genau einmal vorhanden und markiert das Ende des Ablaufs.
  • Grundfunktionen dürfen überall eingefügt werden. Es dürfen sich auch mehrere Grundfunktionen hintereinander befinden.
  • Es muss mindestens eine aktive Grundfunktion im Rezept vorhanden sein.

Transitionen

  • Zwei Transitionen dürfen nicht direkt hintereinander liegen.

Zweige

  • Als erstes Element nach einem Anfang Verzweigung muss an jeder Stelle eine Transition stehen.
  • Die einzelnen Zweige die bei einem Anfang Verzweigung starten, müssen alle wieder in ein Ende Verzweigung münden, niemals in ein Ende Parallelzweig. Außerhalb eines Parallelzweigs kann ein Zweig auch in ein Sprungziel-Element münden. Es dürfen sich alle Elemente zwischen Anfang und Ende eines Zweigs befinden, auch Parallelzweige, solange diese vor dem Ende Verzweigung wieder abgeschlossen werden.
  • Es muss nicht zwingend pro Anfang Verzweigung auch jeweils ein Ende Verzweigung geben. Es können auch zwei Anfang Verzweigung Elemente verzweigt auf ein einzelnes Ende Verzweigung gehen bzw. umgekehrt.
  • Es ist nicht notwendig, dass es für ein Anfang Verzweigung ein Ende Verzweigung gibt. Es kann auch einfach in einer Linie enden. Wenn man zum Beispiel ein Element Anfang Verzweigung mit zwei Pfaden hat, von denen einer in einem Sprungziel endet, ist ein Ende Verzweigung nicht sinnvoll.
  • Ende Verzweigung Elemente können wie Sprungziel-Elemente verwendet werden.
    Einschränkung: Das Element darf sich nicht vor einer Transition befinden.

Parallelzweige

  • Jeder Parallelzweig muss mindestens eine Grundfunktion enthalten.
  • Das erstes Element nach einem Anfang Parallelzweig darf keine Transition sein.
  • Die einzelnen Zweige, die bei einem Parallelzweig beginnen, müssen alle wieder in ein Ende Parallelzweig münden, dürfen aber niemals in ein Ende-Verzweigung enden. Zwischen Anfang Parallelzweig und Ende Parallelzweig dürfen beliebige Elemente verwendet werden, auch Zweige, solange diese vor dem Ende Parallelzweig wieder abgeschlossen werden.
  • Es müssen nicht alle Zweige, die in einem Anfang Parallelzweig gestartet wurden wieder in ein Ende Parallelzweig münden. Es reicht, wenn alle Zweige wieder über Parallel Ende Objekte zusammenlaufen. Genauso dürfen auch Zweige aus unterschiedlichen Anfang Parallelzweig Objekten in ein Ende Parallelzweig zusammenlaufen.
  • Parallelzweige erlauben das Einbetten weiterer Parallelzweige. Dabei gilt:
    • jeder eingebettete Parallelzweig muss sich wieder zum übergeordneten Parallelzweig vereinen
    • verschränkte Verschachtelung wird nicht unterstützt

Linien im PFC Editor

  • Linien dürfen als Verbindungen zwischen allen Objekten eingefügt werden. Es ist auch erlaubt, eine beliebige Anzahl von Linien hintereinander einzufügen.
  • Linien dürfen nicht dazu verwendet werden, zwei gleiche Verbindungspunkte zu verbinden.
    Zum Beispielt: Die beiden Eingänge von zwei Grundfunktionen dürfen nicht mit einer Linie direkt verbunden werden. In der Projektierung wird diese Verbindung zugelassen, sie wird allerdings rot als Fehler dargestellt und in der Validierung wird eine Fehlermeldung ausgegeben.

Sprungziele

  • Sprungziele sind dafür gedacht, um
    • zwischen Zweigen zu springen
    • aus Zweigen heraus zu springen,
    • Schleifen zu projektieren.

    Dabei gilt: Ein Pfad, der in einem Sprungziel endet, muss mit einem Anfang Verzweigung begonnen haben. Sonst wird das Ende nicht erreicht.

  • Sprungziele bestehen aus drei Eingängen und einem Ausgang. Es müssen immer mindestens ein Eingang und der Ausgang verbunden sein. Dabei macht es keinen Unterschied welcher der Eingangs-Verbindungspunkte verbunden ist.
  • Sprungziele dürfen hintereinander geschaltet werden.
  • Sprünge sind verboten:
    • zwischen Parallelzweigen
    • um aus einem Parallelzweig heraus zu springen
    • um in einem Parallelzweig hinein zu springen.

Reaktionen

  • Reaktionen können in jedem Objektstatus auftreten.
  • Pro Reaktionstyp sind mehrere Reaktionen möglich. Diese werden bei ihrer Auslösung sortiert und entsprechend ihrer Priorität ausgeführt. Dabei hat 1 die höchste Priorität.
  • Variablen, die in den Parametern der Reaktion als Quelle verwendet werden, werden beim Treiber mit zum Lesen angemeldet. Sollte ein Wert bei einer Reaktion benötigt werden, aber noch nicht zur Verfügung stehen oder gestört sein, wird der Ersatzwert geschrieben. Das Schreiben der Werte erfolgt ohne Schreibbestätigung.
  • Einige der Reaktionen werden nur einmal im Ablauf ausgelöst, zum Beispiel Timeouts. Wird die Grundfunktion neu gestartet, werden auch diese Reaktion bei Bedarf erneut ausgelöst.
  • Wenn als Reaktion auf eine Statusänderung ein Kommando ausgelöst wurde, das wiederum sofort eine Statusänderung auslöst (Kommando an die REE), wird das Kommando der zweiten Reaktion direkt nach Abarbeitung des 1. Kommandos behandelt.

Ausführungsdauer

  • Die Eigenschaft Minimale Ausführungsdauer legt fest, wie lange nach dem Schreiben der Befehlsparameter gewartet wird, unabhängig vom Prüfen der Abschlussbedingung.

    Interne ID: Projektierungsregeln für Rezepte

    Minimale Ausführungsdauer

    Minimale Ausführungsdauer der Grundfunktion.

    • >0: Zeitraum, der nach dem Schreiben der Befehlsparameter mindestens gewartet wird, unabhängig davon, ob die Weiterschaltbedingung erfüllt ist.
    • 0: Ausführungsdauer wird nicht überprüft

    Minimale Ausführungsdauer kann Maximale Ausführungsdauer überschreiten.

    Interne ID: Projektierungsregeln für Rezepte

    Maximale Ausführungsdauer

    Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

    Interne ID: Projektierungsregeln für Rezepte

    Weiterschaltbedingung

    Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
    Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

    Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

    • Minimalwert: 0T 00:00:00
    • Maximalwert: 9999T 23:59:59
    • Default: 0T 00:00:00

    Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Während der Ausführung wird die minimale Ausführungsdauer geprüft. Ist der Wert nicht nur 0, wird nach ihrem Ablauf ein Ereignis ausgelöst, unabhängig davon, ob die Grundfunktion immer noch ihre Abschlussbedingung prüft, oder nur noch auf die minimale Ausführungsdauer wartet.

Mehr zur Ausführungsdauer lesen Sie im Kapitel Ausführungsdauer.


Statuszeile

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Statuszeile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Statuszeile wird automatisch an jedes kommende Rezept angepasst und mit dessen Daten initialisiert. In der Statuszeile wird angezeigt:

  • Fehlerzustand des Rezepts:
    • Fehler: Im Rezept liegt aktuell ein Fehler vor. Anzahl der Fehler wird ebenfalls angezeigt.
    • Historischer Fehler: Während der Ausführung trat mindestens ein Fehler auf. Es liegt aber aktuell kein Fehler mehr vor.
    • Kein Fehler: Ausführung läuft bislang fehlerfrei ab.
  • der aktuelle Zustand der REE während der Ausführung
  • Mausposition und Veränderungen wie Schieben der Verbindungslinien
  • das Löschen, Hinzufügen oder Selektieren von Elementen

Im PFC-Editor bietet die Statuszeile im rechten Bereich zusätzlich die Anzeige und die Steuerung der Zoom-Stufe der aktuellen Ansicht an.


Rezeptarten und Rezeptstatus

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Rezeptarten und Rezeptstatus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prinzipiell unterscheiden wir zwischen folgenden beiden Rezeptarten:

  • PFC-Rezepte für freie, komplexe Abläufe. Sie werden mit dem PFC-Editor erstellt.
  • Matrix Rezepte für einfache sequentielle/parallele Abläufe. Sie werden mit dem Matrix Editor erstellt.

Für beide Rezeptarten gilt, dass sie in folgenden beiden Ausprägungen vorhanden sind:

  • Vorlagenrezepte:
    Bilden die Basis für die Steuerrezepte. Im Status Editierbar werden sie erstellt. Sind sie im Status Freigegeben können Sie nicht mehr modifiziert werden.
  • Steuerrezepte:
    Sind Rezepte, die einmalig ausgeführt werden können. Jedes Steuerrezept basiert auf einem Vorlagenrezept. Steuerrezepte können vom Ablauf her nicht modifiziert werden. Der Ablauf ist vom Vorlagenrezept vorgegeben. Änderbar sind nur Befehlsparameter, für die die Option Im Steuerrezept änderbar aktiviert wurde.

Status für Vorlagenrezepte

Vorlagenrezepte können folgende Status annehmen:

  • Editierbar: In diesem Status kann alles verändert werden. Jedes neue Vorlagenrezept wird in diesem Status erzeugt.
  • Testmodus: In diesem Status verhält sich das Rezept ähnlich wie ein Steuerrezept. Wie diese kann es nicht vom Ablauf her modifiziert werden. Es kann jedoch ausgeführt werden, und es stehen alle Kommandos, Aktionen, Modi usw. zur Verfügung. Es können auch alle Befehlsparameter verändert werden, für die die Option Im Rezept änderbar aktiviert wurde.
    Ausnahme: Ist eine Grundfunktion gerade aktiv, sind Änderungen nicht möglich. Maßgeblich dafür ist der Zustand beim Drücken des OK Buttons. Ist dabei die Grundfunktion aktiv, werden die Wertänderungen nicht übernommen und eine Fehlermeldung wird angezeigt.
    Im Testmodus können Rezept auch mehrfach hintereinander ausgeführt werden. Das ist bei Steuerrezepten nicht möglich. Änderungen aus dem Editor werden beim Nachladen bzw. nach einem Runtime-Neustart übernommen.
  • Freigegeben: In diesem Status sind keine Änderungen am Rezept mehr möglich.
    Hinweis: Auch Änderungen an den Grundfunktionen bzw. an den Reaktionen im Editor werden an ein Vorlagenrezept nicht übertragen. Der Zustand beim Freigeben wird eingefroren.
    Ausnahme: Änderungen an Variablen und an Funktionen werden durch diesen Schutzmechanismus nicht berücksichtigt. Das kann dazu führen, dass ein Vorlagenrezept und damit alle auf ihm basierenden Steuerrezepte ungültig werden. Wird z.B. der Datentyp einer Variable von Bool auf String geändert, wird die Valdierungsfunktion nicht mehr durchlaufen und das Rezept kann nicht mehr verwendet werden, bis der Fehler im Editor behoben ist. Ebenso werden die Aggregate selbst nicht geschützt, da sie rezeptübergreifend verwendet werden. Wird ein Aggregat-Name im Editor geändert, wirkt sich das unmittelbar nach dem Nachladen oder dem Neustart der Runtime auf alle darauf basierenden Grundfunktionen aus.

    Um ein Vorlagenrezept freigeben zu können muss das Rezept vorher fehlerfrei validiert worden sein. Die Validierung erfolgt beim Freigeben automatisch und kann nicht umgangen werden. Nur von freigegeben Rezepten können Steuerrezepte erstellt werden.

    Soll ein Vorlagenrezept mit dem Status Freigegeben modifiziert werden, müssen Die durch Duplizieren eine Kopie des Vorlagenrezepts erstellen. Diese erhält wieder den Status Editierbar.

Status für Steuerrezepte

Steuerrezepte können folgende Status annehmen:

  • Vorbereitet: Ein neu erzeugtes Steuerrezept besitzt diesen Status. In diesem Staus kann es gestartet werden, und es können auch Befehlsparameter, für die die Option Im Steuerrezept änderbar aktiviert wurde, verändert werden.
  • In Ausführung: Das Steuerrezept wurde gestartet und wird abgearbeitet. In diesem Status bleibt es nun, bis es Abgeschlossen, Gestoppt oder Abgebrochen wurde. Den genauen Zustand des Rezepts erfährt man durch den REE Status.
    In diesem Status können auch Befehlsparameter, für die die Option Im Steuerrezept änderbar aktiviert wurde, geändert werden.
    Ausnahme: Ist eine Grundfunktion gerade aktiv, sind Änderungen nicht möglich. Maßgeblich dafür ist der Zustand beim Drücken des OK Buttons. Ist dabei die Grundfunktion aktiv, werden die Wertänderungen nicht übernommen und eine Fehlermeldung wird angezeigt.
  • Abgeschlossen: Das Rezept hat seinen Endzustand erreicht. Es kann nicht mehr neu gestartet werden und es kann auch nicht mehr verändert werden. Änderungen an Befehlsparametern sind nicht mehr möglich. Abgeschlossene Steuerrezepte können dupliziert und gelöscht werden.


Vorlagenrezepte

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vorlagenrezepte bilden die Grundlage für Steuerrezepte. Mir Vorlagenrezepten wird der Rezeptablauf festgelegt und getestet. Nach der Freigabe eines Vorlagenrezepts kann dessen Inhalt und Struktur nicht mehr verändert werden.

Zum Erstellen von Vorlagenrezepten stehen zwei Editoren zur Verfügung. Je nach Lizenz kann nur einer von beiden oder beide verwendet werden.

Noch in diesem Kapitel

Vorlagenrezept erstellen

PFC-Rezept

Matrix-Rezept

Vorlagenrezept Testmodus

Vorlagenrezept freigeben


Vorlagenrezept erstellen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Vorlagenrezept erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Klick auf den Button Vorlagenrezept erzeugen öffnet den Dialog Vorlagenrezept Konfiguration.

Parameter

Beschreibung

Matrix-Rezept

Aktivieren Sie dieses Optionsfeld, wenn Sie ein Matrix-Rezept erstellen möchten.

Hinweis: Nur möglich bei entsprechender Lizenz.

PFC-Rezept

Aktivieren Sie dieses Optionsfeld, wenn Sie ein PFC-Rezept erstellen möchten.

Hinweis: Nur möglich bei entsprechender Lizenz.

Name

Eindeutiger Name für das Rezept. Der Name darf keinen Punkt (.), kein @ und keinen Asterisk (*) enthalten.

Maximale Länge: 256 Zeichen.

Hinweis: Beim Kopieren von Rezepten wird der bestehende Name mit dem Präfix "Kopie von" ergänzt. Wir dabei die maximal mögliche Länge überschritten, wird der Name von hinten auf die erlaubte Länge gekürzt.

Die Eindeutigkeit wird netzwerkweit geprüft. Es kann daher vorkommen, dass Sie den Namen nicht übernehmen können, da gleichzeitig ein anderer Benutzer auf einem anderen Rechner im zenon Netzwerk den selben Namen bereits vergeben hat und Sie das Rezept noch nicht in der Liste der Vorlagenrezepte sehen.

Den Rezeptnamen können Sie nachträglich ändern, aber nur so lange wie das Rezept im Status Editierbar ist.

Beschreibung

Optionale Beschreibung für das zu erstellenden Rezept.

Die Beschreibung können Sie nachträglich ändern, aber nur so lange wie das Rezept im Status Editierbar ist. Zum Ändern der Beschreibung wählen Sie den Button Vorlagenrezept umbenennen.

OK

Übernimmt alle Einstellungen und erzeugt ein neues Rezept.

Abbruch

Schließt den Dialog ohne ein Rezept zu erzeugen.


PFC-Rezept

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie im Dialog Vorlagenrezpt Konfiguration PFC-Rezept gewählt und den Dialog mit OK beendet haben, öffnet sich das von Ihnen neu erstellte Rezept in einer neuen Registerkarte im PFC-Editor.

Da jedes Rezept ein Anfangselement und ein Endeelement benötigt, sind diese beiden Elemente schon in Ihrem Rezent vorhanden und können auch nicht gelöscht werden.

Fügen Sie hier Ihrem Rezept die gewünschten Grundfunktionen, Transitionen, Verzweigungen, Parallelverzweigungen und Aggregatsbelegungen hinzu. Felder, die für das Einfügen eines Elements nicht geeignet sind, werden rot eingefärbt, wenn das Element darüber bewegt wird.

Noch in diesem Kapitel

PFC-Editor

Symbolleisten und Kontextmenü PFC-Rezept

Einstellungen Diagramm

Anfangselement

Aggregat belegen und konfigurieren

Grundfunktion einfügen und konfigurieren

Linien

Transition

Verzweigungen

Sprungziel

Endeelement


PFC-Editor

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> PFC-Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im PFC-Editor können Sie Ihre Rezepte grafisch erstellen.

Technische Details

  • Blattgröße:
    • Default: 10 x 10 Zellen
    • Minimal: 5 x 5 Zellen
    • Maximal: 500 x 1000 Zellen
  • Zellengröße:
    • Default: 155 x 111 Pixel
  • Außenränder: 100 Pixel
  • Gitter: wird per Default angezeigt, kann auch ausgeblendet werden
  • Bildlaufleiste: Wird angezeigt, wenn das Dokument größer als die Schablone ist
  • Scrollen per Mausrad: nach oben und unten, bzw. bei gehaltener Taste Umschalt nach links und rechts
  • Zoomen: Taste Strg + Scrollrad
  • Auswahl von Elementen: linker Mausklick
  • Mehrfachauswahl: Taste Strg + Mausklick
  • Element bewegen: Element anklicken und mit gedrückter linker Maustaste über das Diagramm bewegen. Inhalt kann auf Zellen mit grünem Hintergrund abgelegt werden. Färbt sich eine Zelle beim Darüberbewegen rot erlaubt sie kein Ablegen.


Symbolleisten und Kontextmenü PFC-Rezept

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Symbolleisten und Kontextmenü PFC-Rezept

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste PFC-Editor: Editiermodus

Parameter

Beschreibung

Vorlagenrezept neu...

Öffnet Dialog zur Erstellung eines neuen Vorlagenrezepts.

Vorlagenrezept speichern

Speichert das zur Bearbeitung geöffnete Rezept.

Wird ein anderes Rezept geöffnet, dann wird das aktuelle Rezept automatisch gespeichert.

Raster anzeigen/ausblenden

Blendet den Raster ein oder aus.

Hintergrundfarbe und Rasterfarbe ändern.

Öffnet Dialog zur Änderung der Farben für Hintergrund und Raster.

Löschen

Löscht ausgewählte Elemente aus Diagramm.

Mehrfachauswahl über Taste Strg+Mausklick.

Rezept auf Fehler prüfen

Überprüft Rezept auf Fehler und gibt gefundene Fehler in einem Informationsfenster aus. Es werden bei mehreren Fehlen die ersten Fehler angezeigt.

Die Fehlermeldung enthält die Fehlernummer, die ID des Elements, desses Position und eine Meldung in Klartext.

Element bearbeiten

Öffnet den jeweiligen Dialog zur Bearbeitung des ausgewählten Elements.

Grundfunktion austauschen

Öffnet Dialog zur Auswahl einer Grundfunktion und ersetzt die bestehende durch die neu gewählte Grundfunktion. Es können mehrere Grundfunktionen gemeinsam gewählt und zu einer gemeinsamen neuen Grundfunktion gewechselt werden.

Tastenkombination: Taste Umschalt+Doppelklick

Bearbeitungsmodus

Wechselt vom Einfügemodus in den Bearbeitungsmodus.

Grundfunktion einfügen

Fügt eine Grundfunktion ein.

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Transition einfügen

Fügt eine Transition ein.

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Anfang Parallelzweig einfügen

Fügt den Anfang eines Parallelzweigs ein.

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Ende Parallelzweig einfügen

Fügt das Ende eines Parallelzweigs ein

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Anfang Verzweigung einfügen

Fügt den Anfang einer Verzweigung ein.

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Ende Verzweigung einfügen

Fügt das Ende einer Verzweigung ein.

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Aggregatsbelegung einfügen

Fügt eine Aggregatsbelegung ein.

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Sprungziel einfügen

Fügt ein Sprungziel ein.

Bleibt so lange aktiv bis über das Symbol Bearbeitungsmodus oder die Taste Esc in den Bearbeitungsmodus oder über ein Symbol zum Einfügen eines Elements zu einer anderen Einfügeoption gewechselt wird.

Rezept in den Testmodus umschalten.

Schaltet das Rezept in den Testmodus. Dazu muss das Rezept fehlerfrei sein.

Rezept freigeben

Gibt das Rezept frei. Damit kann ein Steuerrezept erstellt werden.

Symbolleiste PFC-Rezept: frei gegeben

Parameter

Beschreibung

Rezept auf Fehler prüfen

Überprüft Rezept auf Fehler und gibt gefundene Fehler in einem Informationsfenster aus. Es werden bei mehreren Fehlen die ersten Fehler angezeigt.

Die Fehlermeldung enthält die Fehlernummer, die ID des Elements, desses Position und eine Meldung in Klartext.

Element bearbeiten

Öffnet den jeweiligen Dialog zur Bearbeitung des ausgewählten Elements.

Raster anzeigen/ausblenden

Blendet den Raster ein oder aus.

Hintergrundfarbe und Rasterfarbe ändern

Öffnet Dialog zur Änderung der Farben für Hintergrund und Raster.

Rezept duplizieren

Nur aktiv, wenn genau ein Rezept selektiert wurde.
Erstellt eine Kopie des selektierten Rezepts. Beim Erzeugen der Kopie wird die auf der Festplatte gespeicherte Version verwendet. Wird das Rezept gerade auf einem anderen Rechner editiert, und die Änderungen sind noch nicht gespeichert, werden diese Änderungen nicht übernommen. Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.

Steuerrezept erzeugen

Erzeugt ein Steuerrezept.

Kontextmenü Registerkarten

Jedes Diagramm wird im Editor mit einer Registerkarte markiert. Über das Kontextmenü stehen für jede Registerkarte folgende Befehle zur Verfügung:

Parameter | Beschreibung
Speichern | Speichert alle Änderungen im Diagramm.
Schließen | Schließt das Diagramm.
Alle anderen schließen | Schließt alle Diagramme, ausgenommen das Diagramm, dessen Kontextmenü aufgerufen wurde.


Einstellungen Diagramm

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Einstellungen Diagramm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klick auf das Symbol für die Farbkonfiguration in der Symbolleiste öffnet den Dialog zur Konfiguration Farben für Hintergrund und Raster.

Parameter | Beschreibung
Hintergrundfarbe | Definiert die Hintergrundfarbe des Diagramms. Klick auf die Farbe öffnet Farbpalette zur Auswahl einer Farbe.
Rasterfarbe | Definiert die Linienfarbe des Rastergitters. Klick auf die Farbe öffnet Farbpalette zur Auswahl einer Farbe.
OK | Übernimmt alle Einstellungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.


Anfangselement

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Anfangselement

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Erstes Element im Ablauf. Es wird im Editor beim Erstellen des Rezepts automatisch angelegt und kann nicht gelöscht werden.


Aggregat belegen und konfigurieren

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Aggregat belegen und konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Aggregat zu belegen:

  1. wählen Sie in der Symbolleiste das Symbol für Aggregatsbelegung einfügen
  2. bewegen Sie die Maus an die gewünschte Stelle
  3. platzieren Sie das Aggregat
  4. das Aggregat wird eingefügt

Um die Aggregatsbelegung zu konfigurieren:

  1. führen Sie einen Doppelklick auf das Aggregat aus
  2. der Dialog zur Konfiguration wird geöffnet

Konfiguration

In einem Konfigurationsdialog können die im Batchrezept vorhandenen Aggregate für die Runtime ausgewählt werden. Es wird zwischen Belegung und Freigabe unterschieden. Freigaben können selektiv oder global gesetzt werden. Bereits zuvor ausgewählte Aggregate, die im Rezept nicht mehr vorhanden sind, werden mit einem entsprechenden Hinweis angezeigt.

Parameter

Beschreibung

Liste Aggregate

Zeigt vorhandene Aggregate und deren zugeordnete Aktionen an.

Aktion

Weist dem in der Liste ausgewählten Aggregat eine Aktion zu.

Belegung des Aggregats

Belegt das Aggregat.

Freigabe des Aggregats

Gibt das Aggregat frei:

  • Freigabe der letzten Belegung: Die letzte Belegung wird frei gegeben.
  • Rezeptweite Freigabe: Alle Belegungen im Rezept werden frei gegeben.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbruch

Verwirft Änderungen und schließt Dialog.

Aggregate belegen und freigeben

Die Belegung eines Aggregats durch das Element Aggregatbelegung oder durch eine Grundfunktion ist nur möglich, wenn das Aggregat noch nicht oder ausschließlich im gleichen Rezept belegt ist. Belegung und Freigabe von Aggregaten erfolgt immer in einem Zyklus. Es wird immer so lange gewartet, bis alle zur Belegung bestimmten Aggregate gleichzeitig frei sind. Dann werden alle Belegungen und Freigaben gleichzeitig ausgeführt. Grundfunktionen, die vor einem Element Aggregatbelegung stehen, bleiben aktiv, bis die Belegung erfolgreich ausgeführt wurde. Wenn das Rezept beendet wird und noch Belegungen von Elementen Aggregatbelegung aktiv sind, werden diese implizit freigegeben.

Hinweis: Aggregate können auch im Status Pausiert oder Angehalten nicht von anderen Rezepten belegt werden. Aber: Im manuellen Modus kann das Belegen eines Aggregats durch ein weiteres Rezept erzwungen werden. Das Rezept mit der ersten Belegung behält die Kontrolle und hat Vorrang bei der Ausführung. Gibt dieses Rezept seine Hauptbelegung ab, übernimmt das Rezept mit der am längsten bestehenden erzwungenen Belegung die Hauptbelegung.

Aktionen

Für jedes Aggregat, das in dem Rezept verwendet wird, kann eine Aktion definiert werden:

  • keine Aktion
  • belegen
  • freigeben

Tooltip

Im Tooltip des Elements Aggregatbelegung werden alle Aggregate angezeigt, die für eine Belegung oder Freigabe markiert sind. Während der Ausführung wird die Ausführungsdauer angegeben und alle Aggregate, auf die gewartet werden muss, werden farblich gekennzeichnet. Auf Aggregate muss gewartet werden, wenn diese in einem anderen Rezept belegt sind.


Grundfunktion einfügen und konfigurieren

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Grundfunktion einfügen und konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Grundfunktion einzufügen:

  1. wählen Sie in der Symbolleiste das Symbol für Grundfunktion einfügen
  2. bewegen Sie die Maus an die gewünschte Stelle
  3. platzieren Sie die Grundfunktion
  4. der Dialog zur Auswahl einer Grundfunktion wird geöffnet
  5. wählen Sie die gewünschte Grundfunktion

Um eine Grundfunktion zu konfigurieren:

  1. führen Sie einen Doppelklick auf die Grundfunktion aus
  2. der Dialog zur Konfiguration wird geöffnet
    (wurde dem Element noch keine Grundfunktion zugewiesen, öffnet der Doppelklick den Dialog zur Auswahl einer Grundfunktion)

Konfiguration

Parameter | Beschreibung
Grundfunktion in diesem Schritt aktiv | Aktiv: Grundfunktion ist in diesem Schritt aktiv
Name | Name der Grundfunktion. Nur Anzeige.
Beschreibung | Kommentar zur Grundfunktion. Nur Anzeige.
Aggregat | Aggregat auf dem die Grundfunktion ausgeführt wird. Nur Anzeige.
OK | Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.
Abbruch | Verwirft alle Änderungen aller Registerkarten und schließt Dialog.

Konfiguration der Registerkarten siehe Kapitel:

  • Allgemein: Anzeige und Konfiguration der Einstellungen für die Grundfunktion
  • Parameter: Konfiguration der Parameter

Regeln für Bearbeitung einer Grundfunktion

Eine Grundfunktion kann bearbeitet werden:

  • In einem Vorlagenrezept im Editiermodus: Wenn der Benutzer über ausreichende Rechte verfügt.
  • In einem Vorlagenrezept im Testmodus: Wenn der Benutzer über ausreichende Rechte verfügt und die Grundfunktion nicht aktiv ist.
  • In einem Kontrollrezept mit Status Vorbereitet: Wenn der Benutzer über ausreichende Rechte verfügt.
  • In einem Kontrollrezept mit Status In Ausführung: Wenn der Benutzer über ausreichende Rechte verfügt und die Grundfunktion nicht aktiv ist.

In bereits ausgeführten Kontrollrezepten und in freigegebenen Vorlagenrezepten kann die Grundfunktion nicht mehr editiert werden.

Noch in diesem Kapitel

Auswahl Grundfunktion

Allgemein

Parameter

Parameter bearbeiten

Spaltenauswahl

Spaltenformat


Auswahl Grundfunktion

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Grundfunktion einfügen und konfigurieren -> Auswahl Grundfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Auswahl Grundfunktion

Wenn eine Grundfunktion hinzugefügt wird, öffnet sich der Dialog zur Auswahl einer Grundfunktion.

Parameter | Beschreibung
Projektbaum | Zeigt aktuelles Projekt an, aus dem die Grundfunktionen gewählt werden können.
Listenfeld Grundfunktionen | In der Liste werden alle im Editor projektierten Grundfunktionen angezeigt. Diese Liste kann gefiltert werden. Beim Filtern wird zwischen Groß- und Kleinschreibung unterschieden. Die Platzhalter * und ? können verwendet werden.
Pfeiltasten | Verschieben ausgewählte Grundfunktion nach oben bzw. unten.
Keine Auswahl | Löscht bereits ausgewählte Grundfunktion aus dem Element.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.

Alle Einstellungen des Dialogs werden beim Beenden benutzerspezifisch gespeichert.


Allgemein

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Grundfunktion einfügen und konfigurieren -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Allgemein

Die Eigenschaften der Registerkarte Allgemein werden mit Ausnahme der Option Im Steuerrezept änderbar im Editor vorgegeben. Die Werte können im Vorlagenrezept geändert werden. Ein Symbol zeigt an, ob der Wert im Dialog mit dem Wert im Editor übereinstimmt. Bei unterschiedlichen Werten, kann der im Editor definierte Wert wieder übernommen werden.

Bedeutung der Symbole neben den Werten:

Parameter | Beschreibung
: | Wert im Dialog und der im Editor vorgegebene Wert stimmen überein.
: | Wert im Dialog und der im Editor vorgegebene Wert unterscheiden sich.
: | Nur aktiv, wenn sich die Werte in Rezept und Editor unterscheiden. Klick auf Schaltfläche übernimmt Wert vom Editor. Dieser überschreibt den Wert im Vorlagenrezept.

Erklärung der über den beiden Registerkarten angezeigten Basisdaten siehe Kapitel Grundfunktion einfügen und konfigurieren.

Parameter

Beschreibung

Wartezeit Aggregatsbelegung

Zeit in Tagen, Stunden, Minuten und Sekunden, die auf die Belegung des Aggregats gewartet wird. Die Wartezeit kann zur Runtime verändert werden, solange sich das Rezept im Status editierbar befindet.

Nach Ablauf der definierten Zeit wird das Ereignis Wartezeit Aggregatsbelegung überschritten ausgelöst und das Element hervorgehoben dargestellt. Weitere Aktionen müssen vom Projektanten definiert werden. Erfolgen keine weiteren Aktionen, wird weiter gewartet.

Maximum: 9999T 23:59:59
Default: 0T 00:00:00

Hinweis: Ein Aggregat kann immer nur von einem einzigen Rezept mit Status In Ausführung belegt werden.

Wert wird im Editor vorgegeben und kann hier geändert werden, solange das Rezept nicht freigegeben wurde.

Eingangsverriegelung

Definiert Bedingung für Eingangsverriegelung. Klick auf Schaltfläche ... oder Eintrag öffnet den Formeleditor zur Definition einer Bedingung.
Wird eine Eingangsverriegelung konfiguriert, dann wird die Grundfunktion zur Runtime erst ausgeführt, wenn die Bedingung für die Eingangsverriegelung erfüllt wurde. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Die Formel gibt TRUE oder FALSE als Ergebnis aus. Die Bedingung kann zur Runtime angezeigt, aber nicht verändert werden.
Die Wartezeit für die Eingangsverriegelung wird mit der Eigenschaft Wartezeit Eingangsverrieglung konfiguriert.

Interne ID: Allgemein

Wartezeit Eingangsverrieglung

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Eingangsverriegelung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Beginn der Prüfung der Eingangsverriegelung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Eingangsverriegelung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: Allgemein

Eingangsverriegelung

Definiert Bedingung für Eingangsverriegelung. Klick auf Schaltfläche ... oder Eintrag öffnet den Formeleditor zur Definition einer Bedingung.
Wird eine Eingangsverriegelung konfiguriert, dann wird die Grundfunktion zur Runtime erst ausgeführt, wenn die Bedingung für die Eingangsverriegelung erfüllt wurde. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Die Formel gibt TRUE oder FALSE als Ergebnis aus. Die Bedingung kann zur Runtime angezeigt, aber nicht verändert werden.
Die Wartezeit für die Eingangsverriegelung wird mit der Eigenschaft Wartezeit Eingangsverrieglung konfiguriert.

Mehr in der Online-Hilfe .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wartezeit Eingangsverriegelung

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Eingangsverriegelung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Beginn der Prüfung der Eingangsverriegelung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Eingangsverriegelung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Wert wird im Editor vorgegeben und kann hier geändert werden, solange das Rezept nicht freigegeben wurde.

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Interne ID: Allgemein

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: Allgemein

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Wert wird im Editor vorgegeben und kann hier geändert werden, solange das Rezept nicht freigegeben wurde.

Nur sinnvoll, wenn die Eigenschaft Weiterschaltbedingung konfiguriert wurde.

Mehr zur Ausführungsdauer lesen Sie im Kapitel Ausführungsdauer.

Minimale Ausführungsdauer

Minimale Ausführungsdauer der Grundfunktion.

  • >0: Zeitraum, der nach dem Schreiben der Befehlsparameter mindestens gewartet wird, unabhängig davon, ob die Weiterschaltbedingung erfüllt ist.
  • 0: Ausführungsdauer wird nicht überprüft

Minimale Ausführungsdauer kann Maximale Ausführungsdauer überschreiten. Wert wird im Editor vorgegeben und kann hier geändert werden, solange das Rezept nicht freigegeben wurde.

Im Steuerrezept änderbar, wenn im Vorlagenrezept Option Im Steuerrezept änderbar aktiviert wurde.

Mehr zur Ausführungsdauer lesen Sie im Kapitel Ausführungsdauer.

Im Steuerrezept änderbar

Aktiv: Eigenschaft kann im Steuerrezept geändert werden.

Wartezeit nachfolgende Bedingungen

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die Grundfunktion abgeschlossen werden werden muss. Die Wartezeit beginnt mit dem Erreichen der Weiterschaltbedingung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit nachfolgende Bedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Hinweis: Ob nachfolgende Bedingungen existieren, hängt von der Rezeptstruktur ab. Die Konfiguration einer Wartezeit sollte daher besser nicht im Editor erfolgen, sondern zur Runtime. Wert wird im Editor vorgegeben und kann hier geändert werden, solange das Rezept nicht freigegeben wurde.

Weitere Informationen finden Sie in den Kapiteln Zeiten und Nachfolgende Bedingung.

OK

Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.

Abbruch

Verwirft alle Änderungen aller Registerkarten und schließt Dialog.


Parameter

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Grundfunktion einfügen und konfigurieren -> Parameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter

Erklärung der über den beiden Registerkarten angezeigten Basisdaten siehe Kapitel Grundfunktion einfügen und konfigurieren.

Parameter

Beschreibung

Liste Parameter

Zeigt die im Editor konfigurierten Parameter an. Parameter können nach Spalten gefiltert und sortiert werden.

Klick auf Symbol Parameter bearbeiten, Doppelklick auf den Parameter, Befehl im Kontextmenü, oder Druck auf die Taste Eingabe öffnet den Dialog zur Bearbeitung eines Parameters.

OK

Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.

Abbruch

Verwirft alle Änderungen aller Registerkarten und schließt Dialog.

Symbolleiste

Symbol | Bedeutung
Parameter bearbeiten | Öffnet Dialog zur Bearbeitung des Parameters.
Alle Befehlsparameter anzeigen | Schaltet um zwischen Anzeige der änderbaren Befehlsparameter und aller Befehlsparameter.
Rückgabeparameter anzeigen | Zeigt zusätzlich zu den Befehlsparametern auch die Rückgabeparameter an oder blendet diese aus.
Spaltenwahl | Öffnet Dialog zur Auswahl der anzuzeigenden Spalten.
Spaltenformat | Öffnet Dialog zur Formatierung der Spalten.


Parameter bearbeiten

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Grundfunktion einfügen und konfigurieren -> Parameter bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter bearbeiten

Um einen Parameter zur Runtime zu bearbeiten:

  1. wählen Sie im Dialog Grundfunktion editieren die Registerkarte Parameter
  2. markieren Sie den gewünschten Parameter
  3. öffnen Sie den Dialog zur Bearbeitung des Parameters über einen Klick auf Symbol Parameter bearbeiten, das Kontextmenü, einen Doppelklick auf den Parameter oder Druck auf die Taste Eingabe
  4. der Dialog zur Bearbeitung wird geöffnet

Für jeden Datentyp wird ein eigener Dialog geöffnet:

  • numerisch
  • binär
  • String
  • Zeitdauer

Die Eigenschaften werden in der Regel im Editor konfiguriert und zur Runtime nur angezeigt. Ausgenommen sind Werte des Datentyps. Diese können angepasst werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.

Interne ID: Parameter bearbeiten

Im Rezept änderbar

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl gesetzt wurde.

Interne ID: Parameter bearbeiten

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Parameter bearbeiten

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Rezeptersteller kann zur Runtime Parameter modifizieren.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Numerische Parameter

Parameter

Bedeutung

Parameter

Name des Parameters. Nur Anzeige.

Beschreibung

Freie Beschreibung des Parameters. Nur Anzeige.

Typ

Typ des Parameters: Befehl oder Rückgabe. Nur Anzeige.

Datentyp

Datentyp des Parameters. Nur Anzeige.

Im Steuerrezept änderbar

Aktiv: Wert des Parameters kann im Steuerrezept geändert werden.

Nur verfügbar, wenn:

  • der Parameter vom Typ Befehl ist
  • im Editor konfiguriert wurde, dass der Parameter im Batch-Rezept geändert werden darf (Eigenschaft: Im Rezept änderbar).

Minimum

Minimalwert für den Parameter.

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Minimum Variable

Zulässiger Minimalwert der Variablen.

Wert

Wert des Parameters.

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Einheit

Einheit des Werts.

Maximum

Maximalwert für den Parameter. Nur Anzeige.

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Maximum Variable

Zulässiger Minimalwert von Variable. Nur Anzeige.

Variable

Variable, die mit dem Parameter verknüpft ist. Nur Anzeige.

Datentyp Variable

Datentyp der Variable. Nur Anzeige.

Treiber

Treiber der Variablen. Nur Anzeige.

Treiberbezeichnung

Bezeichnung des Treibers der Variablen. Nur Anzeige.

Pfeiltasten

Navigation durch die Parameter.

Diese werden in der Reihenfolge der Liste angezeigt. Dabei werden nur Parameter angezeigt, die in der aktuellen Filterung und Gruppierung der Liste sichtbar sind.

Wurden Änderungen durchgeführt, erfolgt vor dem Wechsel zu einem anderen Parameter eine Abfrage, ob die Änderungen übernommen oder verworfen werden sollen. Sollen Änderungen übernommen werden, werden die Eingaben vor dem Weiterschalten überprüft.

Übernehmen

Übernimmt alle Änderungen, sofern die Überprüfung der Änderungen erfolgreich ist, und lässt Dialog zur weiteren Bearbeitung offen.

OK

Übernimmt alle Änderungen und schließt Dialog, sofern die Überprüfung der Änderungen erfolgreich ist.

Cancel

Verwirft alle nicht bereits übernommenen Änderungen und schließt Dialog.

Binäre Parameter

Parameter

Bedeutung

Parameter

Name des Parameters. Nur Anzeige.

Beschreibung

Freie Beschreibung des Parameters. Nur Anzeige.

Typ

Typ des Parameters: Befehl oder Rückgabe. Nur Anzeige.

Datentyp

Datentyp des Parameters. Nur Anzeige.

Im Steuerrezept änderbar

Aktiv: Wert des Parameters kann im Steuerrezept geändert werden.

Nur verfügbar, wenn:

  • der Parameter vom Typ Befehl ist
  • im Editor konfiguriert wurde, dass der Parameter im Batch-Rezept geändert werden darf (Eigenschaft: Im Rezept änderbar).

Aus

Zustand: Aus.

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Ein

Zustand: Ein.

Toggeln

Wechselt Zustand.

Variable

Variable, die mit dem Parameter verknüpft ist. Nur Anzeige.

Datentyp Variable

Datentyp der Variable. Nur Anzeige.

Treiber

Treiber der Variablen. Nur Anzeige.

Treiberbezeichnung

Bezeichnung des Treibers der Variablen. Nur Anzeige.

Pfeiltasten

Navigation durch die Parameter.

Diese werden in der Reihenfolge der Liste angezeigt. Dabei werden nur Parameter angezeigt, die in der aktuellen Filterung und Gruppierung der Liste sichtbar sind.

Wurden Änderungen durchgeführt, erfolgt vor dem Wechsel zu einem anderen Parameter eine Abfrage, ob die Änderungen übernommen oder verworfen werden sollen. Sollen Änderungen übernommen werden, werden die Eingaben vor dem Weiterschalten überprüft.

Übernehmen

Übernimmt alle Änderungen, sofern die Überprüfung der Änderungen erfolgreich ist, und lässt Dialog zur weiteren Bearbeitung offen.

OK

Übernimmt alle Änderungen und schließt Dialog, sofern die Überprüfung der Änderungen erfolgreich ist.

Cancel

Verwirft alle nicht bereits übernommenen Änderungen und schließt Dialog.

String-Parameter

Parameter

Bedeutung

Parameter

Name des Parameters. Nur Anzeige.

Beschreibung

Freie Beschreibung des Parameters. Nur Anzeige.

Typ

Typ des Parameters: Befehl oder Rückgabe. Nur Anzeige.

Datentyp

Datentyp des Parameters. Nur Anzeige.

Im Steuerrezept änderbar

Aktiv: Wert des Parameters kann im Steuerrezept geändert werden.

Nur verfügbar, wenn:

  • der Parameter vom Typ Befehl ist
  • im Editor konfiguriert wurde, dass der Parameter im Batch-Rezept geändert werden darf (Eigenschaft: Im Rezept änderbar).

String

Alphanumerische Zeichenfolge.

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Mögliche Länge ist begrenzt durch die in der Variable projektierte Stringlänge.

Interne ID: Parameter bearbeiten

Stringlänge

Nur verfügbar bei String-Variablen:
Maximale Anzahl von Zeichen, die die Variable aufnehmen kann.
Minimum: 0 Zeichen.
Maximum: 65535 Zeichen.
Default: 5 Zeichen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Stringlänge

Definiert mögliche Stringlänge. Nur Anzeige.

Variable

Variable, die mit dem Parameter verknüpft ist. Nur Anzeige.

Datentyp Variable

Datentyp der Variable. Nur Anzeige.

Treiber

Treiber der Variable. Nur Anzeige.

Treiberbezeichnung

Bezeichnung des Treibers der Variablen. Nur Anzeige.

Pfeiltasten

Navigation durch die Parameter.

Diese werden in der Reihenfolge der Liste angezeigt. Dabei werden nur Parameter angezeigt, die in der aktuellen Filterung und Gruppierung der Liste sichtbar sind.

Wurden Änderungen durchgeführt, erfolgt vor dem Wechsel zu einem anderen Parameter eine Abfrage, ob die Änderungen übernommen oder verworfen werden sollen. Sollen Änderungen übernommen werden, werden die Eingaben vor dem Weiterschalten überprüft.

Übernehmen

Übernimmt alle Änderungen, sofern die Überprüfung der Änderungen erfolgreich ist, und lässt Dialog zur weiteren Bearbeitung offen.

OK

Übernimmt alle Änderungen und schließt Dialog, sofern die Überprüfung der Änderungen erfolgreich ist.

Cancel

Verwirft alle nicht bereits übernommenen Änderungen und schließt Dialog.

Zeitdauer

Parameter

Bedeutung

Parameter

Name des Parameters. Nur Anzeige.

Beschreibung

Freie Beschreibung des Parameters. Nur Anzeige.

Typ

Typ des Parameters: Befehl oder Rückgabe. Nur Anzeige.

Datentyp

Datentyp des Parameters. Nur Anzeige.

Im Steuerrezept änderbar

Aktiv: Wert des Parameters kann im Steuerrezept geändert werden.

Nur verfügbar, wenn:

  • der Parameter vom Typ Befehl ist
  • im Editor konfiguriert wurde, dass der Parameter im Batch-Rezept geändert werden darf (Eigenschaft: Im Rezept änderbar).

Minimum

Minimalwert für den Parameter im Format:
T hh:mm:ss

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Minimum Variable

Zulässiger Minimalwert von Variable.

Dauer

Wert des Parameters im Format:
T hh:mm:ss.

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Einheit

Einheit des Werts.

Maximum

Maximalwert für den Parameter im Format:
T hh:mm:ss.

Vorgabe aus Editor kann geändert werden, wenn im Editor die Eigenschaft Im Rezept änderbar aktiviert wurde.
Wird der Wert geändert, wird dies durch das Symbol rechts vom Wert angezeigt. Geänderte Werte können über die daneben liegende Schaltfläche wieder durch die Vorgabe aus dem Editor überschrieben werden.

Maximum Variable

Zulässiger Minimalwert von Variable. Nur Anzeige.

Variable

Variable, die mit dem Parameter verknüpft ist. Nur Anzeige.

Datentyp Variable

Datentyp der Variable. Nur Anzeige.

Treiber

Treiber der Variable. Nur Anzeige.

Treiberbezeichnung

Bezeichnung des Treibers der Variablen. Nur Anzeige.

Pfeiltasten

Navigation durch die Parameter.

Diese werden in der Reihenfolge der Liste angezeigt. Dabei werden nur Parameter angezeigt, die in der aktuellen Filterung und Gruppierung der Liste sichtbar sind.

Wurden Änderungen durchgeführt, erfolgt vor dem Wechsel zu einem anderen Parameter eine Abfrage, ob die Änderungen übernommen oder verworfen werden sollen. Sollen Änderungen übernommen werden, werden die Eingaben vor dem Weiterschalten überprüft.

Übernehmen

Übernimmt alle Änderungen, sofern die Überprüfung der Änderungen erfolgreich ist, und lässt Dialog zur weiteren Bearbeitung offen.

OK

Übernimmt alle Änderungen und schließt Dialog, sofern die Überprüfung der Änderungen erfolgreich ist.

Cancel

Verwirft alle nicht bereits übernommenen Änderungen und schließt Dialog.


Spaltenauswahl

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Grundfunktion einfügen und konfigurieren -> Spaltenauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Spaltenauswahl

Schaltfläche | Funktion
Hinzufügen | Verschiebt die markierten Spalten aus den verfügbaren zu den ausgewählten. Nach der Bestätigung des Dialogs mit OK werden sie in der Detailansicht angezeigt.
Alle hinzufügen | Verschiebt alle verfügbaren Spalten zu den ausgewählten Spalten.
Entfernen | Entfernt die markierten Spalten aus den ausgewählten und zeigt sie in der Liste der verfügbaren Spalten an. Nach der Bestätigung des Dialogs mit OK werden sie aus der Detailansicht entfernt.
Alle entfernen | Entfernt alle Spalten aus der Liste der ausgewählten Spalten.
Nach oben | Verschiebt den ausgewählten Eintrag nach oben. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
Nach unten | Verschiebt den ausgewählten Eintrag nach unten. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Spaltenformat

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Grundfunktion einfügen und konfigurieren -> Spaltenformat

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Spaltenformat

Parameter

Beschreibung

Verfügbare Spalten

Liste der über Spaltenauswahl bereit gestellten Spalten. Die hier selektierte Spalte wird über die Einstellungen der Sektion Parameter konfiguriert.

Parameter

Einstellungen für ausgewählte Spalte.

Beschriftung

Name für Spaltentitel. Der Spaltentitel ist online sprachumschaltbar. Dazu müsen Sie ein @ Zeichen vor den Namen eingeben.

Breite

Breite der Spalte in Zeichen.
Berechnung: Zahl mal durchschnittlicher Zeichenbreite der gewählten Schriftart.

Ausrichtung

Ausrichtung.

Mögliche Einstellungen:

  • Linksbündig: Text wird in der Spalte am linken Rand ausgerichtet.
  • Zentriert: Text wird in der Spalte zentriert dargestellt.
  • Rechtsbündig: Text wird in der Spalte am rechten Rand ausgerichtet.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog.


Linien

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Linien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Linien verbinden Elemente über freie Verbindungspunkte. Um Verbindungspunkte miteinander zu verbinden:

  1. Aktivieren Sie einen Punkt mit der Maus-
    Der Verbindungspunkt wird grün eingefärbt. Rot dagegen symbolisiert einen bereits vergebenen Verbindungspunkt.

  2. Ziehen Sie eine Linie zu einem anderen Verbindungspunkt:
    Ein gelber Pfeil zeigt die Richtung der Linie an. Grüne Felder können überquert werden. Rot markierte Felder dürfen von der Linie nicht gekreuzt werden.

  3. Sobald die gelbe Spitze der Linie den nächsten Verbindungspunkt berührt, wird sie erstellt.

Operationen mit Linien

Linien:

  • werden mit der Maus gezogen
  • können verschoben werden (Taste Ctrl halten)
    Dabei trennen sich alle bisherigen Verbindungen und es wird versucht, die Linie neu zu verbinden, wenn sich am Ziel Objekte mit Verbindungspunkten in die richtige Richtung befinden.
    Sind mehrere Linien markiert, wird die Linie, in deren Zelle sich der Mauszeiger befindet, verschoben.
  • können gelöscht werden durch markieren und drücken der Taste Del
  • werden beim erneuten Ziehen von Anfang zu Ende gelöscht
  • verfügen über einen Tooltip, der ihre ID anzeigt.

Erreicht eine Line einen Verbindungspunkt eines Objekts, wird dieser aktiviert. Ist die Verbindung möglich, wird er grün dargestellt, sonst rot. Nicht erlaubt, sind Verbindungen, die zwei gleiche Verbindungspunkte verbinden, also zwei Eingänge oder zwei Ausgänge. Die Linie kann in jedem Fall eingefügt werden. Nicht erlaubte Verbindungen werden rot markiert und ergeben beim Testen eine entsprechende Fehlermeldung.

Die Verbindungspunkt der Elemente werden im Editiermodus immer angezeigt, auch wenn der fragliche Verbindungspunkt verbunden ist. Im Status "Freigegeben" werden keine Verbindungspunkt angezeigt.

Eigenschaften Verbindungspunkt:

  • verbunden: rote Markierung; Verbindung wird beim Ziehen der Linie getrennt und ein neuer Verbindungspunkt kann gesucht werden
  • offen: grüne Markierung; beim Ziehen wird eine neue Linie erstellt


Transition

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Transition

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Transitionen werden nach Grundfunktionen eingesetzt, um einen definierten Übergang von einer Grundfunktion zur nächsten zu gewährleisten. Transitionen zeigen im Ablauf ihren internen Status an und informieren mit einem Tooltip über Status und Ablaufdauer.

Details zu Transitionen lesen Sie auch im Abschnitt Projektieren im Editor im Kapitel Transitionen.


Verzweigungen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Verzweigungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rezepte können verzweigen und in Parallelzweigen ablaufen.

Zweige und Parallelzweige bestehen aus:

  • einfachen bzw. doppelten horizontalen Linien
  • Verknüpfungsstücken (bestehend aus Verknüpfungslinie und Verknüpfungspunkt)

Zweige einfügen

Um eine Verzweigung zu erstellen:

  1. wählen Sie das Symbol Anfang Verzweigung einfügen
  2. ziehen Sie die Verzweigung an´der gewünschten Stelle auf
  3. verbinden Sie den Eingangs-Verknüpfungspunkt mit einem Ausgangs-Verknüpfungspunkt des vorangehenden Objekts
  4. verbinden Sie die beiden Ausgangs-Verknüpfungspunkte mit den gewünschten folgenden Objekten
  5. schließen Sie eine Verzweigung mit dem Objekt Ende Verzweigung einfügen

Parallelzweige einfügen

Um eine Parallelverzweigung zu erstellen:

  1. wählen Sie das Symbol Anfang Parallelzweig einfügen
  2. ziehen Sie die Verzweigung an´der gewünschten Stelle auf
  3. verbinden Sie den Eingangs-Verknüpfungspunkt mit einem Ausgangs-Verknüpfungspunkt des vorangehenden Objekts
  4. verbinden Sie die beiden Ausgangs-Verknüpfungspunkte mit den gewünschten folgenden Objekten
  5. schließen Sie eine Parallelverzweigung mit dem Objekt Ende Parallelzweig einfügen

Modifizieren und bewegen

Zweige und Parallelzweige können verschoben und in der Größe verändert werden.

Verschieben

Um ein Objekt zu verschieben:

  1. klicken Sie das Objekt mit der mit Maus an
  2. halten Sie die Maustaste gedrückt
  3. zeihen Sie deas Objekt an die gewünschte Stelle

Größe ändern

Objekte Anfang/Ende Zweig/Parallelzweig können so verlängert und gekürzt werden. Um deren Größe zu ändern:

  1. bewegen Sie die Maus über das Objekt bis der Mauszeiger zum Doppelpfeil wird
  2. halten Sie die linke Maustaste gedrückt und bewegen Sie diese in die gewünschte Richtung:
    • vom Objekt weg, um es zu verlängern
    • in das Objekt hinein, um es zu verkürzen
  3. beim Verlängern wird ein neues Verknüpfungstück eingefügt;
    • alle Felder, in die verlängert werden kann, werden grün eingefärbt
    • um mehrere neue Verknüpfungsstücke einzufügen, muss der Vorgang wiederholt werden
  4. beim Verkürzen werden alle entsprechenden Verknüpfungsstücke gelöscht

Noch in diesem Kapitel

Zweige

Parallelzweige

Zweige aufteilen und wieder vereinen


Zweige

Zweige

Ein Zweig bietet die Möglichkeit, einen von mehreren möglichen Pfaden auszuführen. Dazu ist es notwendig, dass das erste Element am Anfang eines Zweiges eine Transition ist. Das bedeutet, ein Anfang Verzweigung kann als Nachfolgeobjekt nur eine Transitionen haben.

Ablauf:

  • Es wird der Pfad gewählt, bei dem als erstes die Transition TRUE wird.
  • Dann wird gewartet, bis alle Transitionen einen Wert haben.
  • Sollten mehrere Transitionen gleichzeitig TRUE sein, so wird immer der äußerst linke Pfad, bei dem die Transition TRUE ist gewählt.

Für Anfang und Ende gilt: Befindet sich vor dem Element eine Grundfunktion und dahinter eine Transition, bleibt die Grundfunktion aktiv bis auch die Transition beendet wurde.

In einem Zweig werden die Objekte sequenziell abgearbeitet. Jeder Zweig arbeiten seine Objekte unabhängig von anderen Zweigen ab.


Parallelzweige

Parallelzweige

Bei Parallelzweigen teilt sich ein Ausführungspfad in mehrere Ausführungspfade auf, die dann im Ablauf gleichzeitig ausgeführt werden. Für die Aktivierung der unterschiedlichen Elemente innerhalb eines Parallelzweigs kann keine bestimmte Reihenfolge festgelegt werden.

Im Ablauf wird auch jeweils der Zwischenbereich des Ende Parallelzweig eingefärbt. Die Farbe entspricht der Einfärbung der Grundfunktion.

Ende Grundfunktion wird als aktiv dargestellt, sobald das erste Vorgängerelement abgeschlossen wurde. Das heißt, eine Grundfunktion ist Beendet oder eine Transition ist durchquert. Transitionen werden dabei sofort nach dem Durchqueren als abgeschlossen gekennzeichnet, Grundfunktionen warten bei Ende Grundfunktion bis das Ende Parallelzweig abgeschlossen ist. Abgeschlossen bedeutet, dass entweder die darauffolgende Grundfunktion aktiv oder die darauffolgende Transition inaktiv wird.

Während der Ausführung wird der Status farbig angezeigt.


Zweige aufteilen und wieder vereinen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Verzweigungen -> Zweige aufteilen und wieder vereinen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zweige aufteilen und wieder vereinen

Bei Parallelzweigen teilt sich der Zweig bei Anfang Parallelzweig auf und vereint die einzelnen Zweige wieder bei Ende Parallelzweig. Die Pfade des Parallelobjekts sind voneinander unabhängige Zweige. Erst bei Ende Parallelzweig werden alle Zweige synchronisiert.

Die möglichen Zweige werden durch die Projektierung festgelegt. Ob die einzelnen Zweige belegt bzw. freigegeben werden, ergibt sich zur Runtime. Ein Zweig ist immer so lange aktiv wie ein Objekt in ihm aktiv ist.

Die Objekttypen Anfang Verzweigung, Ende Verzweigung und Spungziel belegen keine Zweige und geben keine frei, da diese Objekte im gleichen Zweig abgearbeitet werden. Vereinigung zwischen Zweigen sind nicht erlaubt.

Ende Parallelzweig

Ein Ende Parallelzweig vereint die Zweige der angeschlossenen Pfade wieder. Das Objekt nach Ende Parallelzweig wird aktiviert, wenn alle Pfade mit der Ausführung bei Ende Parallelzweig angekommen sind.

Der linke Pfad ist fertig, darum ist Ende Parallelzweig bereits aktiv. Die Transition nach Ende Parallelzweig ist noch nicht aktiv, da der rechte Zweig noch nicht beendet ist.

Wenn der rechte Zweig auch beendet wird:

Die Transition nach Ende Parallelzweig wird aktiviert. Alle zuvor aktiven Objekte sind nach wie vor aktiv. Anstelle der Transition könnte sich auch ein weiteres Ende Parallelzweig befinden.

Eine etwas komplexere Variante:

Die grün markierten Bereiche sind ein Zweig.

Kaskadierte Ende Parallelzweig:

Die grün markierten Bereiche sind ein Zweig.


Sprungziel

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Sprungziel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fügt ein Sprungziel ein.

Sprungziele ermöglichen es

  • zwischen Zweigen zu springen
  • aus Zweigen heraus zu springen
  • Schleifen zu projektieren

Sprungziele bestehen aus drei Eingängen und einem Ausgang. Dabei ist der Ausgang immer unten, und die Eingänge befinden sich immer oben und an den Seiten. Es können beliebige Eingangs-Verbindungspunkte verbunden sein. Ein Pfad, der in einem Sprungziel endet, muss mit einem Anfang Verzweigung begonnen haben. Sonst wird das Ende nicht erreicht. Sprungziele sind für Parallelzweige nicht zugelassen.

Während des Editierens sind alle Verbindungspunkte sichtbar, im Prüfmodus nur Verbindungspunkte, die auch verbunden sind.


Endeelement

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> PFC-Rezept -> Endeelement

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Letztes Element im Ablauf. Es wird im Editor beim Erstellen des Rezepts automatisch angelegt und kann nicht gelöscht werden.


Matrix-Rezept

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Matrix-Rezept

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie im Dialog Vorlagenrezpt Konfiguration Matrix-Rezept gewählt und den Dialog mit OK beendet haben, öffnet sich das von Ihnen neu erstellte Rezept in einer neuen Registerkarte im Matrix Editor.

Noch in diesem Kapitel

Matrix Editor

Symbolleisten Matrix-Rezept

Schritt benennen

Grundfunktion einfügen und konfigurieren


Matrix Editor

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Matrix-Rezept -> Matrix Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im PFC-Editor können Sie Ihre Rezepte in einer Matrix erstellen.

Technische Details

  • Matrix:
    • Spalten enthalten Grundfunktionen.
    • Zeilen enthalten Schritte mit aktiven/inaktiven Grundfunktionen.
  • Zeile/Spalte einfügen: Klick auf Pluszeichen fügt neue Zeile bzw. Spalte in die Matrix ein. Bei neuen Spalten wird automatisch der Dialog für die Konfiguration einer Grundfunktion geöffnet.
  • Zeile/Spalte löschen: Druck auf Taste Entf löscht markierte Zeilen bzw. Spalten.
  • Zeilen/Spalten verschieben: Zeilen und Spalten können per Drag & Drop mit der Maus verschoben werden. Individuelle bennungen von Schritten bleiben erhalten, die Schrittnummer wird automatisch angepasst.
  • Randzellen:
    • Doppelklick auf Grundfunkion: öffnet Dialog zur Konfiguration der Grundfunktion.
    • Doppelklick auf Schritt: öffnet Dialog zur Benennung des Schritts.
  • Auswahl von Zeilen/Spalten:
    • linker Mausklick in Randzelle: wählt eine Zeile/Spalte aus.
    • Taste Strg+Mausklick in Randzelle: wählt zusätzliche Zeile/Spalte aus.
  • Zellen:
    • linker Mausklick: wählt Zelle aus.
    • Taste Umschalt + Klick: aktiviert/deaktiviert Grundfunktion.
    • Taste Strg + Klick: wählt mehrere Zellen aus.
    • Doppelklick auf Zelle: öffnet Dialog zur Konfiguration der Grundfunktion.
  • Bildlaufleiste: Wird angezeigt, wenn das Dokument größer als die Schablone ist.
  • Scrollen per Mausrad: nach oben und unten, bzw. bei gehaltener Taste Umschalt nach links und rechts.


Symbolleisten Matrix-Rezept

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Matrix-Rezept -> Symbolleisten Matrix-Rezept

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Matrix-Rezept Editiermodus

Vorlagenrezept neu...

Öffnet Dialog zur Erstellung eines neuen Vorlagenrezepts.

Vorlagenrezept speichern

Speichert das zur Bearbeitung geöffnete Rezept.

Wird ein anderes Rezept geöffnet, dann wird das aktuelle Rezept automatisch gespeichert.

Hintergrundfarbe und Rasterfarbe ändern

Öffnet Dialog zur Änderung der Farben für Hintergrund und Raster.

Löschen

Löscht ausgewählte Elemente aus Diagramm.

Mehrfachauswahl über Taste Strg+Mausklick.

Rezept auf Fehler prüfen

Überprüft Rezept auf Fehler und gibt gefundene Fehler in einem Informationsfenster aus. Es werden bei mehreren Fehlen die ersten Fehler angezeigt.

Die Fehlermeldung enthält die Fehlernummer, die ID des Elements, desses Position und eine Meldung in Klartext.

Element bearbeiten

Öffnet den jeweiligen Dialog zur Bearbeitung des ausgewählten Elements.

Selektierte Grundfunktion aktivieren

Aktiviert ausgewählte Grundfunktion.

Selektierte Grundfunktion deaktivieren

Deaktiviert ausgewählte Grundfunktion.

Selektierte Spalte nach links bzw. selektierte Schritte nach oben schieben

Verschiebt ausgewählte Spalten um eine Position nach links oder ausgewählte Schritte um eine Position nach oben.

Selektierte Spalte nach rechts bzw. selektierte Schritte nach untren schieben

Verschiebt ausgewählte Spalten um eine Position nach rechts oder ausgewählte Schritte um eine Position nach unten.

Rezept in den Testmodus umschalten

Schaltet das Rezept in den Testmodus. Dazu muss das Rezept fehlerfrei sein.

Rezept freigeben

Gibt das Rezept frei. Damit kann ein Steuerrezept erstellt werden.

Matrix-Rezept freigegeben

Parameter

Beschreibung

Rezept auf Fehler prüfen

Überprüft Rezept auf Fehler und gibt gefundene Fehler in einem Informationsfenster aus. Es werden bei mehreren Fehlen die ersten Fehler angezeigt.

Die Fehlermeldung enthält die Fehlernummer, die ID des Elements, desses Position und eine Meldung in Klartext.

Element bearbeiten

Öffnet den jeweiligen Dialog zur Bearbeitung des ausgewählten Elements.

Raster anzeigen/ausblenden

Blendet den Raster ein oder aus.

Hintergrundfarbe und Rasterfarbe ändern

Öffnet Dialog zur Änderung der Farben für Hintergrund und Raster.

Rezept duplizieren

Nur aktiv, wenn genau ein Rezept selektiert wurde.
Erstellt eine Kopie des selektierten Rezepts. Beim Erzeugen der Kopie wird die auf der Festplatte gespeicherte Version verwendet. Wird das Rezept gerade auf einem anderen Rechner editiert, und die Änderungen sind noch nicht gespeichert, werden diese Änderungen nicht übernommen. Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.

Steuerrezept erzeugen

Erzeugt ein Steuerrezept.


Schritt benennen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Matrix-Rezept -> Schritt benennen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schritte im Matrix-Editor können individuell benannt werden. Doppelklick auf die Zelle Schritt öffnet Dialog zu Vergabe eines individuellen Namens.

Der Name kann bis zu 100 Zeichen umfassen und ist mit vorangestelltem @ sprachumschaltbar.


Grundfunktion einfügen und konfigurieren

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Matrix-Rezept -> Grundfunktion einfügen und konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Grundfunktion einzufügen:

  1. klicken Sie auf das Pluszeichen der letzten Spalte der Matrix
  2. der Dialog zur Auswahl einer Grundfunktion wird geöffnet
  3. wählen Sie die gewünschte Grundfunktion

Um eine Grundfunktion zu konfigurieren:

  1. führen Sie einen Doppelklick auf das Matrixfeld bzw.die Spalte mit der gewünschten Grundfunktion aus
  2. der Dialog zur Konfiguration wird geöffnet

Konfiguration

Parameter | Beschreibung
Grundfunktion in diesem Schritt aktiv | Aktiv: Grundfunktion ist in diesem Schritt aktiv
Name | Name der Grundfunktion. Nur Anzeige.
Beschreibung | Kommentar zur Grundfunktion. Nur Anzeige.
Aggregat | Aggregat auf dem die Grundfunktion ausgeführt wird. Nur Anzeige.
OK | Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.
Abbruch | Verwirft alle Änderungen aller Registerkarten und schließt Dialog.

Konfiguration der Registerkarten siehe Abschnitt PFC-Editor/Kapitel:

  • Allgemein: Anzeige und Konfiguration der Einstellungen für die Grundfunktion
  • Parameter: Konfiguration der Parameter

Regeln für Bearbeitung einer Grundfunktion

Eine Grundfunktion kann bearbeitet werden:

  • In einem Vorlagenrezept im Editiermodus: Wenn der Benutzer über ausreichende Rechte verfügt.
  • In einem Vorlagenrezept im Testmodus: Wenn der Benutzer über ausreichende Rechte verfügt und die Grundfunktion nicht aktiv ist.
  • In einem Kontrollrezept mit Status Vorbereitet: Wenn der Benutzer über ausreichende Rechte verfügt.
  • In einem Kontrollrezept mit Status In Ausführung: Wenn der Benutzer über ausreichende Rechte verfügt und die Grundfunktion nicht aktiv ist.

In bereits ausgeführten Kontrollrezepten und in freigegebenen Vorlagenrezepten kann die Grundfunktion nicht mehr editiert werden.


Vorlagenrezept Testmodus

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Vorlagenrezept Testmodus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Testmodus dient dazu ein Vorlagenrezept zu testen, ohne dass es vorher freigegeben wurde und Steuerrezepte erstellt wurden. Ebenso können im Testmodus auch Änderungen aus dem Editor direkt mittels Nachladen der Runtime übernommen werden.
Ausnahme: Während ein Rezept gerade ausgeführt wird, wird das Nachladen für dieses Rezept verzögert. Erst wenn das Rezept beendet, gestoppt oder abgebrochen wurde, wird der Nachladevorgang durchgeführt.

Im Testmodus kann der prinzipielle Rezeptablauf nicht geändert werden. Es können nur Werte der Befehlsparameter geändert werden. Änderungen werden direkt im Vorlagenrezept gespeichert. Eine explizites Speichern ist nicht erforderlich.

Parameter

Beschreibung

Rezept starten

Startet den Rezeptablauf.

Rezept pausieren

Pausiert das Rezept.

Rezept fortsetzen

Setzt pausiertes Rezept fort.

Rezept anhalten

Hält Rezept an,

Rezept neu starten

Startet angehaltenes Rezept neu.

Rezept stoppen

Stoppt das Rezept.

Rezept abbrechen

Bricht Rezeptablauf ab.

Grundfunktion pausieren

Pausiert Grundfunktion.

Grundfunktion fortsetzen

Setzt Ablauf einer pausierten Grundfunktion fort.

Grundfunktion anhalten

Hält Grundfunktion an.

Grundfunktion neu starten

Startet angehaltene Grundfunktion neu.

Rezept auf Fehler prüfen

Überprüft Rezept auf Fehler und gibt gefundene Fehler in einem Informationsfenster aus. Es werden bei mehreren Fehlen die ersten Fehler angezeigt.

Die Fehlermeldung enthält die Fehlernummer, die ID des Elements, desses Position und eine Meldung in Klartext.

Element bearbeiten

Öffnet den jeweiligen Dialog zur Bearbeitung des ausgewählten Elements.

Raster anzeigen/ausblenden

Blendet den Raster ein oder aus.

Hintergrundfarbe und Rasterfarbe ändern

Öffnet Dialog zur Änderung der Farben für Hintergrund und Raster.

Umschalten in Automatischen Modus

Schaltet Ausführung in den Automatischen Modus um.

Umschalten in Semiautomatischen Modus

Schaltet Ausführung in den Semiautomatischen Modus um.

Umschalten in Manuellen Modus

Schaltet Ausführung in den Manuellen Modus um.

Rezept nur an selektierten Ausführungspositionen fortsetzen

Setzt ein Rezept nur an den ausgewählten Positionen fort.

Rezept an allen Ausführungspositionen fortsetzen

Setzt ein Rezept an allen zur Verfügung stehenden Positionen fort.

Anstehende Bedingung überspringen

Überspringt eine anstehende Bedingung.

Nur im Manuellen Modus möglich.

Rezept in den Editiermodus umschalten

Schaltet vom Testmodus in den Editiermodus zurück.

Rezept freigeben

Gibt das Rezept frei. Damit kann ein Steuerrezept erstellt werden.


Vorlagenrezept freigeben

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Vorlagenrezepte -> Vorlagenrezept freigeben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können ein Vorlagenrezept freigeben, indem Sie es auswählen und auf den Button Vorlagenrezept freigeben klicken. Es können auch mehrere Rezepte gemeinsam ausgewählt und freigegeben werden. Die Freigabe muss über einen Dialog bestätigt werden.

info Info

Nur fehlerfreie Vorlagenrezepte können freigeben werden. Ein freigegebenes Vorlagenrezept kann nicht weiter bearbeitet werden.

Für jedes Rezept kann aber über Klick auf den Button Vorlagenrezept duplizieren eine Kopie des freigegebenen Vorlagenrezept erstellt werden. Diese Kopie kann wieder bearbeitet werden.


Rezepte validieren

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Rezepte validieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rezepte können während der Projektierung auf Fehler getestet werden. Um ein Rezept zu validieren, klicken Sie auf das entsprechende Symbol in Symbolleiste des Rezepteditorsder Runtime (grüner Haken - Rezept auf Fehler prüfen). Damit wird das Rezept nach internen Regeln auf Funktionsfähigkeit überprüft, vor allem werden geprüft:

  • Syntax (alle Linien verbunden, von Anfang bis Ende durchlaufbar usw.)
  • Variablen
  • Datentypen

Das Ergebnis der Prüfung wird als Pop-up im Klartext ausgegeben. Gefundene Fehler werden auch in der LOG-Datei, die mit dem Diagnose Viewer ausgewertet werden kann, gespeichert.

Regeln, die beim Projektieren zu beachten sind, finden Sie im Kapitel Projektierungsregeln für Rezepte.


Steuerrezepte

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Steuerrezepte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Steuerrezepte steuern den Ablauf eines Rezepts zur Runtime.

Noch in diesem Kapitel

Symbolleiste Steuerrezept

Steuerrezept erstellen

Steuerrezept ausführen


Symbolleiste Steuerrezept

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Steuerrezepte -> Symbolleiste Steuerrezept

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Art

Beschreibung

Rezept starten

Kommando

Startet den Rezeptablauf.

Rezept pausieren

Kommando

Pausiert das Rezept.

Rezept fortsetzen

Kommando

Setzt pausiertes Rezept fort.

Rezept anhalten

Kommando

Hält Rezept an,

Rezept neu starten

Kommando

Startet angehaltenes Rezept neu.

Rezept stoppen

Kommando

Stoppt das Rezept.

Rezept abbrechen

Kommando

Bricht Rezeptablauf ab.

Grundfunktion pausieren

Kommando

Pausiert Grundfunktion.

Grundfunktion fortsetzen

Kommando

Setzt Ablauf einer pausierten Grundfunktion fort.

Grundfunktion anhalten

Kommando

Hält Grundfunktion an.

Grundfunktion neu starten

Kommando

Startet angehaltene Grundfunktion neu.

Element bearbeiten

Aktion

Öffnet den jeweiligen Dialog zur Bearbeitung des ausgewählten Elements.

Raster anzeigen/ausblenden

Aktion

Blendet den Raster ein oder aus.

Hintergrundfarbe und Rasterfarbe ändern

Aktion

Öffnet Dialog zur Änderung der Farben für Hintergrund und Raster.

Umschalten in Automatischen Modus

Kommando

Schaltet Ausführung in den Automatischen Modus um.

Umschalten in Semiautomatischen Modus

Kommando

Schaltet Ausführung in den Semiautomatischen Modus um.

Umschalten in Manuellen Modus

Kommando

Schaltet Ausführung in den Manuellen Modus um.

Rezept nur an selektierten Ausführungspositionen fortsetzen

Kommando

Setzt ein Rezept nur an den ausgewählten Positionen fort.

Rezept an allen Ausführungspositionen fortsetzen

Kommando

Setzt ein Rezept an allen zur Verfügung stehenden Positionen fort.

Anstehende Bedingung überspringen

Kommando

Überspringt eine anstehende Bedingung.

Nur im Manuellen Modus möglich.

Rezept duplizieren

Aktion

Nur aktiv, wenn genau ein Rezept selektiert wurde.
Erstellt eine Kopie des selektierten Rezepts. Beim Erzeugen der Kopie wird die auf der Festplatte gespeicherte Version verwendet. Wird das Rezept gerade auf einem anderen Rechner editiert, und die Änderungen sind noch nicht gespeichert, werden diese Änderungen nicht übernommen. Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.

Die Kopie des Rezepts erhält automatisch den Status Vorbereitet und kann daher weiter bearbeitet oder gestartet werden. Der REE Status des Duplikats wird auf Automatisch gesetzt.

Beim Duplizieren eines Rezepts wird ein CEL Eintrag erzeugt.


Steuerrezept erstellen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Steuerrezepte -> Steuerrezept erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können Steuerrezepte nur auf Basis eines freigegebenen Vorlagenrezepts erstellen. Wählen Sie das freigegebene Vorlagenrezept in der Liste der Vorlagenrezepte aus, das als Basis für Ihr Steuerrezept dienen soll und klicken Sie auf denButton Steuerrezept neu....

Parameter | Beschreibung
Name | Eindeutigen Namen für das Steuerrezept an. Die Eindeutigkeit wird netzwerkweit geprüft. Es kann daher vorkommen, dass ein Name nicht übernommen wird, da gleichzeitig ein anderer Benutzer auf einem anderen Rechner im zenon Netzwerk den selben Namen bereits vergeben hat. Der Name kann nachträglich geändert werden, solange das Rezept im Status Vorbereitet ist.
Beschreibung | Optionale Beschreibung des Rezepts.
OK | Übernimmt Konfiguration und schließt Dialog.
Abbruch | Verwirft Eingaben und schließt Dialog.

Das neu erstellte Steuerrezept wird in einer neuen Registerkarte im Rezepteditor geöffnet sofern dieser im Bild projektiert ist. Das neu erstellte Rezept wird auch in der Liste der Steuerrezepte angezeigt, selbst wenn es nicht den eingestellten Filterkriterien entspricht. Im Netzwerk wird es nur auf dem Rechner angezeigt, auf dem es erzeugt wurde. Auf anderen Rechnern muss die Liste manuell aktualisiert werden.

Hinweis: Während ein Steuerrezept erstellt wird (Dialog noch offen), kann es auf anderen Rechnern bereits editiert, dupliziert und gelöscht werden. Es kann aber nicht gestartet werden. Die erlaubten Aktionen werden aber nicht ausgeführt, wenn die Erstellung des Steuerrezepts am erstellenden Client abgebrochen wird.


Steuerrezept ausführen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Steuerrezepte -> Steuerrezept ausführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Steuerrezepte können gestartet werden:

  • nach Auswahl eines Steuerrezepts in der Liste der Steuerrezepte:
    • per Klick auf die Schaltfläche Steuerrezept starten
    • per Klick auf den Befehl Starten im Kontextmenü
  • bei geöffnetem Kontrollrezept durch Klick auf das Symbol Steuerrezept starten in der Symbolleiste

PFC-Steuerrezept:

Matrix-Steuerrezept:

Werte ändern

Wurde im Vorlagenrezept die Eigenschaft Im Steuerrezept änderbar aktiviert, können bestimmte Werte im Steuerrezept angepasst werden, solange die Grundfunktion noch nicht aktiv ist. In diesem Fall wird neben dem Wert eine Schaltfläche zur Synchronisierung angezeigt. Klick auf diese Schaltfläche übernimmt wieder den im Vorlagenrezept definierten Wert.

In Steuerrezepten, die bereits ausgeführt wurden, können keine Werte mehr geändert werden.

Bedeutung der Symbole neben änderbaren Werten:

Symbol | Beschreibung
: | Wert im Steuerrezept und im Vorlagenrezept stimmen überein.
: | Wert im Steuerrezept und im Vorlagenrezept unterscheiden sich.
: | Klick auf Schaltfläche übernimmt Wert vom Vorlagenrezept. Dieser überschreibt den Wert im Steuerrezept. Nur aktiv, wenn sich die Werte im Steuerrezept und im Vorlagenrezept unterscheiden.

Tooltip

Ein Tooltip informiert über aktuelle und historische Ereignisse eines Elements.

Es werden angezeigt:

  • Elementname
  • Allgemeine Informationen zu Status und Anzahl der Ausführungen.
    Hinweis: Der Zähler wird aktiv, wenn die Grundfunktion neu aktiviert wird, also auch, wenn der Status Neustartend ist, aber die Neustartbedingung noch nicht durchlaufen wurde.
  • Fehler
  • Gesamtdauer inklusive Zeiten im Status Pausiert
  • Zeitlicher Ablauf


Rezepte verwalten

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Rezepte verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Runtime findet die gesamte Rezeptverwaltung mithilfe eines oder mehrere Bilder vom Bildtyp Batch Control statt. Durch geeignete Filtereinstellungen können Sie bereits gefilterte Ansichten auf Vorlagenrezepte und/oder Steuerrezepte erreichen.

Im Bild stehen verschiedene Kontrollelemente (Buttons, Listen, Editoren) für unterschiedliche Aufgaben zur Verfügung. Das Bild ist in drei Hauptbereiche eingeteilt, die teilweise auch völlig unabhängig projektiert und genutzt werden können:

  • Bereich Vorlagenrezepte: Besteht aus einer Liste und Buttons zur Verwaltung Der Bereich kann völlig eigenständig benutzt werden.
  • Bereich Steuerrezepte: Besteht aus einer Liste und Buttons zur Verwaltung Der Bereich kann nur in Verbindung mit der Liste Vorlagenrezepte verwendet werden, da zuerst ein Vorlagenrezept selektiert werden muss, bevor die dazugehörenden Steuerrezepte in der Liste angezeigt werden können.
  • Rezepteditoren: Je nach eingestellter Rezeptart wird der PFC-Editor oder der Matrix Editor verwendet. Der Rezepteditor benötigt entweder die Liste Vorlagenrezepte oder beide Listen, damit ein Rezept darin geöffnet werden kann.

Noch in diesem Kapitel

Vorlagenrezepte verwalten

Steuerrezepte verwalten

Speicherung auf der Festplatte und Sicherungsszenarien


Vorlagenrezepte verwalten

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Rezepte verwalten -> Vorlagenrezepte verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Liste und Listenformatierung

Liste/Aktion

Beschreibung

Liste Vorlagenrezepte

In dieser Liste können alle Vorlagenrezepte angezeigt werden. Die Anzeige kann durch Filter auf eine individuelle Auswahl eingeschränkt werden.

Die Filterung kann bereits im zenon Editor in der Bildumschaltungsfunktion voreingestellt werden. Eine Online Filterung ist auch möglich. Diese Filter werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Alle Kommandos sind auch in den Kontextmenüs der Liste möglich. Die Kommandos zur Listenverwaltung sind in der Kopfzeile der Liste aufrufbar, die Kommandos zur Rezeptverwaltung beim Editieren eines oder mehrerer Rezepte.

Die Rezept in der Liste können nicht direkt in der Liste editiert werden. Umbenennen, ändern der Beschreibung oder ändern des Rezeptstatus sind nur mittels der jeweiligen Kommandos möglich.

Hinweise zur optimalen Gestaltung der Liste:

Die Liste kann sowohl Inhaltlich als auch grafisch vielfältig gestaltet werden:

  • Inhaltlich: Die anzuzeigenden Spalten können ausgewählt werden, das Spaltenformat (Spaltenbreite, Ausrichtung, Spaltenbeschriftung) kann verändert und es kann eine Filterung eingestellt werden. Diese Einstellungen können in Editor und Runtime verändert werden.
  • Grafisch: Bei den Einstellungen der Liste im Editor finden Sie vielfältige Einstellmöglichkeiten in den Bereichen Darstellung, Bildlaufleisten und Farben. Mit diesen Eigenschaften können Sie die Listen auch Touchbedienbar gestalten.

    Interne ID: Vorlagenrezepte verwalten

    Farben

    Farbeigenschaften des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Vorlagenrezepte verwalten

    Bildlaufleisten

    Eigenschaften für die horizontalen und vertikalen Bildlaufleisten.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Vorlagenrezepte verwalten

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktionen zur Listenverwaltung

Aktion | Beschreibung
Spaltenauswahl Vorlagenrezepte... | Öffnet einen Dialog, um festzulegen, welche Spalten dargestellt werden sollen. Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.
Spalten formatieren Vorlagenrezepte... | Öffnet einen Dialog, um die Spalteneinstellungen zu ändern. Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Aktionen zur Rezeptverwaltung

Aktion

Beschreibung

Vorlagenrezept neu...

Erzeugt ein neues, komplett leeres Vorlagenrezept im Status Editierbar. Es erscheint der Dialog zur Eingabe eines eindeutigen Namens und einer freien Beschreibung. Die Eindeutigkeit des Namens wird auch im zenon Netzwerk geprüft.
Je nach Lizenzierung besteht auch die Möglichkeit zur Auswahl der Rezeptart: Matrix Rezept oder PFC-Rezept. Ist nur eine der beiden Rezeptarten lizenziert, wird die lizenzierte Rezeptart fix eingestellt. Die gewählte Rezeptart kann nachträglich nicht mehr verändert werden.

Beim Anlegen eines Vorlagenrezepts wird ein CEL Eintrag erzeugt.

Vorlagenrezept duplizieren

Nur aktiv, wenn genau ein Rezept selektiert wurde.
Erstellt eine Kopie des selektierten Rezepts. Beim Erzeugen der Kopie wird die auf der Festplatte gespeicherte Version verwendet. Wird das Rezept gerade auf einem anderen Rechner editiert, und die Änderungen sind noch nicht gespeichert, werden diese Änderungen nicht übernommen. Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.
Die Kopie des Rezepts erhält automatisch den Status Editierbar und kann daher weiter bearbeitet werden.

Beim Duplizieren eines Rezepts wird ein CEL Eintrag erzeugt.

Vorlagenrezept löschen

Löscht die selektierten Rezepte unwiderruflich. Ist das Rezept auf einem anderen Rechner im Editor geöffnet, wird es dort automatisch geschlossen.
Löschen ist nur möglich, wenn es keine Steuerrezepte gibt, die auf dem Vorlagenrezept basieren. Es müssen zuerst alle Steuerrezepte gelöscht werden.
Rezepte die gerade im Testmodus ausgeführt werden (Vorlagenrezept Status: Test in Ausführung), können nicht gelöscht werden. Sie müssen zuerst Abgeschlossen, Gestoppt oder Abgebrochen werden.

Dürfen Rezepte nicht gelöscht werden, z.B. im FDA reglementiertem Umfeld, empfiehlt es sich, diesen Button nicht zu projektieren bzw. mit einer entsprechenden Berechtigungsebene zu versehen.
Beim Löschen eines Rezepts wird ein CEL Eintrag erzeugt.

Interne ID: Vorlagenrezepte verwalten

Berechtigungsebene

Passwortlevel für das Setzen von Sollwerten oder das Ausführen von Funktionen mit dem ausgewählten dynamischen Element.
Minimum: 0.
Maximum: 127.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Vorlagenrezept umbenennen

Nur aktiv, wenn genau ein Vorlagenrezept selektiert wurde.
Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.
Rezepte können nur im Status Edierbar umbenannt werden.
Verwenden Sie diese Funktion auch, um die Beschreibung des Vorlagenrezepts zu ändern.

Beim Umbenennen eines Rezepts wird ein CEL Eintrag erzeugt.

Vorlagenrezept öffnen

Öffnet die selektierten Vorlagenrezepte im Rezepteditor, sofern das Bildelement Rezepteditor im Bild vorhanden ist. Jedes selektierte Vorlagenrezept wird in einer eigenen Registerkarte des Rezepteditors geöffnet.

Vorlagenrezept freigeben

Ändert den Vorlagenrezept Status der selektierten Rezepte auf Freigegeben. Nur fehlerfreie Rezepte können frei gegeben werden. Treten bei der Validierung Fehler auf, müssen diese zuerst behoben werden.
Nur Rezepte im Status Testmodus und Editierbar können frei gegeben werden.

Frei gegeben Rezepte könne nicht mehr verändert werden. Nur von frei gegeben Rezepten können Steuerrezepte erstellt werden.
Details zu den Status finden Sie im Kapitel Rezeptarten und Rezeptstatus

Beim Freigeben eines Rezepts wird ein CEL Eintrag erzeugt.

Vorlagenrezept testen

Ändert den Vorlagenrezept Status der selektierten Rezepte auf Testmodus. Nur fehlerfreie Rezepte können in den Testmodus umgeschaltet werden. Treten bei der Validierung Fehler auf, müssen diese zuerst behoben werden.

Rezepte im Testmodus können ausgeführt, aber nicht mehr umprojektiert werden. Details zu den Status finden Sie im Kapitel Rezeptarten und Rezeptstatus

Vorlagenrezept editieren

Ändert den Vorlagenrezept Status der selektierten Rezepte auf Editierbar. In diesem Status können Rezepte wieder komplett bearbeitet werden.
Nur Rezepte im Testmodus können wieder auf Editierbar geschaltet werden.

Steuerrezept neu...

Öffnet den Dialog zur Eingabe eines eindeutigen Namens und einer Beschreibung für das Steuerrezept. Die Eindeutigkeit des Namens wird auch im zenon Netzwerk geprüft. Der Name muss nur innerhalb des Vorlagenrezepts eindeutig sein. Steuerrezepte, die auf anderen Vorlagenrezepten basieren, dürfen über den selben Namen verfügen. Die Eindeutigkeit innerhalb des Moduls Batch Control wird erreicht, indem immer der Vorlagenrezeptname und der Steuerrezeptname referenziert werden.

Beim Anlegen eines Steuerrezepts wird ein CEL Eintrag erzeugt.

Aktionen zum Füllen der Steuerrezeptliste

Da jedes Steuerrezept nur ein einziges Mal ausgeführt werden kann, muss davon ausgegangen werden, dass es sehr viele Kontrollerezepte gibt. Da beim Laden in der Liste der Kontrollerezepte jedes Kontrollerezept auf der Festplatte geöffnet werden muss, ist es sinnvoll, nicht alle Kontrollerezepte anzuzeigen. Daher können Kontrollenrezepte nicht automatisch geöffnet werden. Sie müssen manuell und mittels Filter aufgeschaltet werden:

  1. Stellen Sie die passenden Filteroptionen ein.
  2. Selektieren sie die gewünschten Vorlagenrezepte.
  3. Klicken Sie auf den Button Zugehörige Steuerrezepte in Liste anzeigen.
  4. Es werden alle in den Filter und zur Selektion passenden Steuerrezepte in der Liste der Steuerrezepte angezeigt.
Aktion/Filter | Beschreibung
aktuell ausgeführte Steuerrezepte | Öffnet nur Steuerrezepte, die gerade ausgeführt werden. Steuerrezept Status: In Ausführung
vorbereitetet Steuerrezepte | Öffnet nur Steuerrezepte, die zur Ausführung vorbereitet sind. Steuerrezept Status: Vorbereitet
abgeschlossene Steuerrezepte | Öffnet nur Steuerrezepte, die bereits ausgeführt wurden. Steuerrezept Status: Vorbereitet
Zugehörige Steuerrezepte in Liste anzeigen | Öffnet alle Steuerrezepte, die auf den selektierten Vorlagenrezepten basieren und den eingestellten Filterkriterien entsprechen.


Steuerrezepte verwalten

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Rezepte verwalten -> Steuerrezepte verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Liste und Listenformatierung

Liste/Aktion

Beschreibung

Liste Steuerrezepte

In dieser Liste können alle Steuerrezepte angezeigt werden. Die Anzeige kann durch Filter auf eine individuelle Auswahl eingeschränkt werden.

Standardmäßig ist die Liste immer leer. Zum Befüllend er Liste müssen:

  • Vorlagenrezepte selektiert werden
  • die Filter
    aktuell ausgeführte Steuerrezepte,
    vorbereitetet Steuerrezepte und
    abgeschlossene Steuerrezepte
    gesetzt sein
  • der Button Zugehörige Steuerrezepte in Liste anzeigen gedrückt werden

Zusätzlich zu den oben erwähnten Filtern kann die Liste selbst noch gefiltert werden. Die Filterung kann bereits im zenon Editor in der Bildumschaltungsfunktion voreingestellt werden. Eine Online Filterung ist auch möglich. Diese Filter werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Alle Kommandos sind auch in den Kontextmenüs der Liste möglich. Die Kommandos zur Listenverwaltung sind in der Kopfzeile der Liste aufrufbar, die Kommandos zur Rezeptverwaltung beim Editieren eines oder mehrerer Rezepte.
Die Rezept in der Liste können nicht direkt in der Liste editiert werden. Umbenennen, ändern der Beschreibung oder das Starten des Rezepts ist nur mittels der jeweiligen Kommandos möglich.

Hinweise zur optimalen Gestaltung der Liste

Die Liste kann sowohl Inhaltlich als auch grafisch vielfältig gestaltet werden:

  • Inhaltlich: Die anzuzeigenden Spalten können ausgewählt werden, das Spaltenformat (Spaltenbreite, Ausrichtung, Spaltenbeschriftung) kann verändert und es kann eine Filterung eingestellt werden. Diese Einstellungen können in Editor und Runtime verändert werden.
  • Grafisch: Bei den Einstellungen der Liste im Editor finden Sie vielfältige Einstellmöglichkeiten in den Bereichen Darstellung, Bildlaufleisten und Farben. Mit diesen Eigenschaften können Sie die Listen auch Touchbedienbar gestalten.

    Interne ID: Steuerrezepte verwalten

    Farben

    Farbeigenschaften des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Steuerrezepte verwalten

    Bildlaufleisten

    Eigenschaften für die horizontalen und vertikalen Bildlaufleisten.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Steuerrezepte verwalten

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktionen zur Listenverwaltung

Aktion | Beschreibung
Spaltenauswahl Vorlagenrezepte... | Öffnet einen Dialog, um festzulegen, welche Spalten dargestellt werden sollen. Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.
Spalten formatieren Vorlagenrezepte... | Öffnet einen Dialog, um die Spalteneinstellungen zu ändern. Achtung: Diese Änderungen werden bei einer erneuten Aufschaltung des Bildes wieder verworfen. Eine dauerhafte Festlegung ist nur im zenon Editor möglich.

Aktionen zur Rezeptverwaltung

Aktion

Beschreibung

Steuerrezept duplizieren

Nur aktiv, wenn genau ein Rezept selektiert wurde.
Erstellt eine Kopie des selektierten Rezepts. Beim Erzeugen der Kopie wird die auf der Festplatte gespeicherte Version verwendet. Wird das Rezept gerade auf einem anderen Rechner editiert, und die Änderungen sind noch nicht gespeichert, werden diese Änderungen nicht übernommen. Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.

Die Kopie des Rezepts erhält automatisch den Status Vorbereitet und kann daher weiter bearbeitet oder gestartet werden. Der REE Status des Duplikats wird auf Automatisch gesetzt.

Beim Duplizieren eines Rezepts wird ein CEL Eintrag erzeugt.

Steuerrezept löschen

Löscht die selektierten Rezepte unwiderruflich. Ist das Rezept auf einem anderen Rechner im Editor geöffnet, wird es dort automatisch geschlossen.
Löschen ist nur möglich, wenn alle selektierten Rezepte nicht ausgeführt werden (Steuerrezept Status: In Ausführung). Sie müssen zuerst Abgeschlossen, Gestoppt oder Abgebrochen werden.

Dürfen Rezepte nicht gelöscht werden, z.B. im FDA reglementiertem Umfeld, empfiehlt es sich, diesen Button nicht zu projektieren bzw. mit einer entsprechenden Berechtigungsebene zu versehen.
Beim Löschen eines Rezepts wird ein CEL Eintrag erzeugt.

Interne ID: Steuerrezepte verwalten

Berechtigungsebene

Passwortlevel für das Setzen von Sollwerten oder das Ausführen von Funktionen mit dem ausgewählten dynamischen Element.
Minimum: 0.
Maximum: 127.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Steuerrezept umbenennen

Nur aktiv, wenn genau ein Steuerrezept selektiert wurde.
Der Dialog zur Eingabe eines eindeutigen Namens und der Beschreibung wird geöffnet.
Rezepte können nur im Status Vorbereitet umbenannt werden.
Verwenden Sie diese Funktion auch, um die Beschreibung des Steuerrezepts zu ändern.

Steuerrezept öffnen

Öffnet die selektierten Steuerrezepte im Rezepteditor, sofern das Bildelement Rezepteditor im Bild vorhanden ist. Jedes selektierte Steuerrezept wird in einer eigenen Registerkarte des Rezepteditors geöffnet.

Steuerrezept starten

Startet die selektierten Steuerrezepte im eingestellten REE Modus. Die Rezepte werden unsichtbar am Server ausgeführt. Es ist nicht erforderlich, dass das Rezept im Rezepteditor geöffnet ist.


Speicherung auf der Festplatte und Sicherungsszenarien

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Rezepte verwalten -> Speicherung auf der Festplatte und Sicherungsszenarien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vorlagenrezepte

Jedes Vorlagenrezept verfügt über eine eindeutige ID, unter der es auf der Festplatte mit der Dateiendung .MR gespeichert wird, z.B.: 9.MR.
Jedes Rezept entspricht somit einer Datei. Die ID des Rezepts kann in der Liste der Vorlagenrzepte abgelesen werden. Dazu muss die Spalte Vorlagenrezpt ID eingeblendet werden.
Der Ordner für die Vorlagenrezepte ist ein Unterordner des Runtime-Ordner: \RT\FILES\zenon\system\BatchRecipes

Interne ID: Speicherung auf der Festplatte und Sicherungsszenarien

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Für die Rezeptverwaltung ist im selben Ordner die Datei Recipe.unique zuständig. Sie sorgt dafür, dass die Rezeptnamen eindeutig sind.

Hinweis: Wird ein Rezept manuell über den Dateiexplorer und damit außerhalb der Runtime des Moduls Batch Control gelöscht, dann muss die Datei Recipe.unique gelöscht werden, damit deren Inhalte wieder korrekt sind. Wird zum Beispiel ein Kontrollrezept manuell gelöscht, kann das dazugehörige Vorlagenrezept im Modul Batch Control nicht mehr gelöscht werden, da das Kontrollrezept dort noch als vorhanden angezeigt wird. Erst nach der Neuintialisierung der Datei Recipe.unique kann auch das Vorlagenrezept gelsöcht werden.

Sicherung von Vorlagenrezepten

Die .MR Dateien - und damit alle Vorlagenrezepte - können jederzeit gesichert werden. Sie können dazu z.B. die Funktion Dateioperationen verwenden.

Rücksichern von Vorlagenrezepten

Das Rücksichern sollte nur in zwingen notwendigen Fällen erfolgen, da dabei zwangsläufig aktuellere Daten vernichtet werden. So gehen Sie vor:

  1. Beenden Sie die Runtime.
  2. Sichern Sie alle vorhanden Vorlagenrezepte.
  3. Benennen Sie die Datei Recipe.unique um, oder löschen Sie diese. Sie wird nach dem Starten der Runtime automatisch aus den .MR Dateien erneut generiert.
  4. Spielen Sie die .MR Dateien aus einer früheren Sicherung zurück.
  5. Starten Sie die Runtime neu.

Steuerrezepte

Jedes Steuerrezept verfügt über eine eindeutige ID unter der es auf der Festplatte mit der Dateiendung .CR gespeichert wird, z.B.: 9.CR.
Jedes Rezept entspricht somit einer Datei. Die ID des Rezepts kann in der Liste der Steuerrezepte abgelesen werden. Dazu muss die Spalte Kontrollrezpt ID eingeblendet werden. Steuerrezepte basieren immer auf einem Vorlagenrezept, und sind daher immer diesem zugeordnet. Die ID-Nummernkreise sind daher nur eindeutig im Bezug auf das zugrunde liegende Vorlagenrezept.
Beispiel: Das Vorlagenrezept mit der ID 9 hat die Kontrollzerepte mit der ID 1 und 2. Das Vorlagenrezpt mit der ID 10 hat ebenfalls die Steuerrezepte mit der ID 1 und 2.

Daher hat jedes Vorlagenrezept einen Unterordner, in dem die Steuerrezepte abgelegt sind. Der Name des Ordners lautet immer: <Vorlagenrezept ID>.crd. In unserem Beispiel gibt es daher den Ordner 9.crd mit den Dateien 1.CR und 2.CR sowie den Ordner 10.crd mit den Dateien 1.CR und 2.CR.

Die Ordner für die Steuerrezepte sind Unterordner des Runtime-Ordner: \RT\FILES\zenon\system\BatchRecipes\. In diesem Ordner sind die einzelnen Steuerrezept-Ordner angelegt. In jedem Steuerrezept-Ordner befindet sich die Datei Recipe.unique. Sie sorgt dafür, dass die Rezeptnamen eindeutig sind.

Sichern und rücksichern von Steuerrezepten

Gehen Sie wie bei den Vorlagenrezepten vor, nur dass Sie nun alle .CR Dateien und die dazugehörende Ordnerstruktur sichern müssen. Beim Rücksichern müssen Sie alle Recipe.unique Dateien löschen. Auch diese werden automatisch wiederhergestellt.


Recipe Execution Engine (REE)

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die REE (Recipe Execution Engine) führt Rezepte zur Runtime aus. Es kann eine beliebige Anzahl an Rezepten gestartet werden.

Noch in diesem Kapitel

Symbole und Farben

Verhalten von Elementen zur Runtime

Modus und Moduswechsel

Die REE Status

Rezept schrittweise ausführen und im Rezept springen

Ablauf einer Grundfunktion im Detail

Runtime Beenden und Wiederanlauf

Neustart Grundfunktion


Symbole und Farben

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Symbole und Farben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zustände im Ablauf einer Grundfunktion werden über verschiedene Symbole angezeigt:

Symbol

Bedeutung

Grundfunktion startet.

Ab dem Start der Grundfunktion, bereits vor Zuweisung.

Während des Wartens auf eine Verriegelungsbedingung.

Während der Ausführung einer Grundfunktion und dem Warten auf Reaktion Beendet.

In Vorbereitung für Start. Nach Neustart beim Warten auf die Neustartbedingungen.

Reaktion Beendet erkannt, es wird auf Reaktion Abgeschlossen gewartet.

Warten auf Ablauf Minimale Ausführungsdauer.

Interne ID: Symbole und Farben

Minimale Ausführungsdauer

Minimale Ausführungsdauer der Grundfunktion.

  • >0: Zeitraum, der nach dem Schreiben der Befehlsparameter mindestens gewartet wird, unabhängig davon, ob die Weiterschaltbedingung erfüllt ist.
  • 0: Ausführungsdauer wird nicht überprüft

Minimale Ausführungsdauer kann Maximale Ausführungsdauer überschreiten.

Interne ID: Symbole und Farben

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: Symbole und Farben

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehrfachausführung läuft.

Warten auf Benutzereingabe.

Timeout für Aggregatsbelegung ist abgelaufen.

Timeout für Verriegelung ist abgelaufen.

Auf Wert zum Schreiben wird zu lange gewartet.

Timeout für Reaktion Abgeschlossen abgelaufen.

Timeout für Reaktion Beendet abgelaufen.

Grundfunktion im Status Halten.

Wartezeit für Benutzereingabe abgelaufen.

Tritt während einer Grundfunktion ein Fehler auf, dann wird die Grundfunktion bis zum erneuten Start als fehlerhaft gekennzeichnet.

Der Ausführungsstatus einer Grundfunktion wird farblich signalisiert:

Status | Farbe
In Ausführung: | grün
Timeout: | roter Rand
Angehalten: | grau
Gestoppt: | gelb
Pausiert: | orange
Leerlauf,Stoppend, Abbruch, Fortsetzend, Neustart: | weiß
Abbruch: | rot
Fertig: | blau


Verhalten von Elementen zur Runtime

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Verhalten von Elementen zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Grundfunktionen

Alle Grundfunktionen Pausiert

Im Modus Manuell kann man alle Grundfunktionen in den Status Pausiert versetzen.
Zum Beispiel: Der Zweig wird vor dem Ende Parallelzweig über dieses Ende hinaus weiter durchschritten. Damit befindet sich die Ausführungsposition nach dem Ende Parallelzweig und vor der nächsten Grundfunktion. Alle Grundfunktionen vor dem Ende Parallelzweig sind im Status Pausiert. Nun wird eine dieser Grundfunktionen erst in Halten und dann in Neustart versetzt. Die anderen Grundfunktionen bleiben pausiert. Ist die neu gestartete Grundfunktion beendet, existiert nur noch eine Ausführungsposition. Wird diese mit Nächster Schritt aktiviert. Damit befinden sich alle Grundfunktionen in Pause und keine Ausführungsposition ist mehr vorhanden.

Lösung: Wiederaufnahme der pausierten Grundfunktionen.

Pausieren und Wiederaufnahme

Beim Pausieren und für Wiederaufnahme gilt:

  • Pausieren und fortsetzen mit aktiver Ausführungsposition: Eine pausierte Grundfunktion, für die eine Ausführungsposition aktiv ist, wird nicht fortgesetzt.
  • Umschalten vom manuellen REE Modus zum automatischen: Alle Grundfunktion, für die eine Ausführungsposition aktiv ist, werden fortgesetzt.
  • Ist eine Grundfunktion im manuellen Modus Pausiert und die REE wird auf Automatisch umgeschaltet, bleibt die Grundfunktion pausiert, wenn die Bedingung für das Pausieren TRUE ist. Auch eine globale Wiederaufnahme wird diese Grundfunktion nicht in den Status Fortsetzen versetzen, da die Grundfunktion im Modus Manuell pausiert wurde.
    • Ein Kommando Grundfunktion pausieren, gefolgt von einem globalen Pausieren und einem globalen Fortsetzen versetzen Grundfunktionen, die über das Grundfunktion pausieren Kommando pausiert wurden, in den Status Fortsetzen.
    • Grundfunktionen, die im Modus Manuell pausiert wurden, können mit einem Kommando Grundfunktion fortsetzen in den Status Fortsetzen versetzt werden.

Parallelzweige

In Parallelzweigen werden die Zweige von links nach rechts abgearbeitet.

Stoppen von Elementen

Wird ein Ende Parallelzweig gestoppt, wird es sofort inaktiv und reagiert auf keine weiteren REE Kommandos wie z. B. abbrechen. Daher wechselt es auch nicht den Status zu abgebrochen nach einem Kommando abbrechen. Das gilt auch für Transitionen. Grundfunktionen dagegen warten nach einem Stoppen eventuell noch darauf, das weitere Bedingungen erfüllt werden.

Transitionen

  • Eine Transition vor einem Ende Parallelzweig bleibt einschließlich der Grundfunktion vor der Transition aktiv nachdem sie durchlaufen wurde, wenn die Transition nach dem Ende Parallelzweig aktiv ist, aber noch nicht durchlaufen wurde.
  • In Parallelzweigen werden Impulse für eine Transition ignoriert, solange die Transition links der betreffenden Transition noch keinen gültigen Wert hat.


Modus und Moduswechsel

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Modus und Moduswechsel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die REE kann in drei Modi betrieben werden:

  • Automatisch: Das Rezept läuft vollautomatisch ab.
  • Semiautomatisch: Das Rezept wird manuell ausgeführt, es können keine Bedingungen übersprungen werden.
  • Manuell: Jeder Schritt im Rezept wird manuell ausgeführt, Bedingungen, auf die gewartet wird, können übersprungen werden (forcen).

Um ein Rezept manuell oder semiautomatisch auszuführen, können die Bewegungsarten Rezept schrittweise ausführen (steppen) und springen (jumpen) benutzt werden.

Beim Umschalten auf den Modus Automatisch werden alle Ausführungspositionen entfernt. Globale Kommandos werden nur in Zweigen ausgeführt, die keine Ausführungspositionen enthalten.

info Info

Um auf schwerwiegende Ereignisse reagieren zu können, kann der Modus auch im laufenden Betrieb über die Reaktionsart Rezeptbeeinflussung geändert werden.


Die REE Status

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Die REE Status

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Status sind möglich:

Status

Beschreibung

Leerlauf

Die REE befindet sich im Leerlauf.

In Ausführung

Beim Starten eines Kontrollrezept wechselt dieses in den Status In Ausführung.

Abgeschlossen

Sobald die Ausführung beendet wurde, wechselt ein Rezept in den Status Abgeschlossen. Das Ausführen ist in diesen Status nicht mehr möglich.

Soll ein Steuerrezept nach der Ausführung oder nach dem Beenden der Runtime erneut ausgeführt werden, wird sein Status von Abgeschlossen automatisch auf Vorbereitet gesetzt.

Pausierend:

Das Rezept wechselt in den Status Pausiert.

Pausiert

Der Ablauf bleibt innerhalb der Grundfunktion stehen bei:

  • Warten auf Beendet
  • Warten auf Belegung
  • Warten auf Veriegelungsbedingung
  • Warten auf Ende Grundfunktion
  • Prüfen auf parallele Ausführung

Anhaltend

Das Objekt wechselt in Angehalten und führt keine Belegung mehr aus. Bei einem Neustart wird das Objekt neu gestartet und wechselt auf In Ausführung.

Angehalten

Der Ablauf bleibt innerhalb der Grundfunktion stehen bei:

  • Warten auf Beendet
  • Warten auf Belegung
  • Warten auf Veriegelungsbedingung
  • Warten auf Ende Grundfunktion
  • Prüfen auf parallele Ausführung

Neu startend

Grundfunktion wird gerade neu gestartet.

Neu gestartet

Grundfunktion wird von Anfang an neu ausgeführt.

Stoppend

Bricht den Ablauf ab und wechselt zu Gestoppt.

Gestoppt

Das Objekt wurde gestoppt.

Abbrechend

Bricht den Ablauf ab und wechselt zu Abgebrochen.

Abgebrochen

Rezeptablauf wurde abgebrochen.

Kann ein Rezept im Abbild beim Wiederanlauf nicht gestartet werden, wechselt sein Status automatisch auf Abgebrochen.

Vorbereitet

Vorbereitet zum Ablaufen. Soll ein Steuerrezept nach der Ausführung oder nach dem Beenden der Runtime erneut ausgeführt werden, wird sein Status von Abgeschlossen automatisch auf Vorbereitet gesetzt.

Ausführungsposition und Sprungziele

Status | Beschreibung
Wiederaufnahme | Wenn ein Objekt in Pause ist und sich nach diesem eine Ausführungsposition befindet, bewirkt ein Fortsetzen das Gleiche wie ein Nächster Schritt. Dies inkludiert auch die Sprünge. Bei einem Grundfunktionskommando wirkt sich das Kommando nur auf den Sprung im gleichen Zweig aus.
Pause | Hat keine Auswirkung bei Sprungzielen. Bereits definierte Ziele bleiben erhalten.
Sonstige | Bewirken immer das Löschen der Sprünge. Bei einem Grundfunktionskommando wird nur der Sprung im Bereich der Grundfunktion gelöscht.


Rezept schrittweise ausführen und im Rezept springen

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Rezept schrittweise ausführen und im Rezept springen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rezept schrittweise ablaufen lassen (steppen)

Ein Rezept kann schrittweise ausgeführt werden, wenn :

  • sich das Rezept entweder im semiautomatischen oder im manuellen Modus befindet
    und
  • der Status des Rezepts In Ausführung ist.

Beim schrittweisen Ausführen wird die Ausführung angehalten, sobald ein Element fertig ausgeführt wurde. Das Anhalten erfolgt durch ein Kommando Pause an den betroffenen Ausführungspfad. Sobald in diesem Pfad alle aktiven Elemente den Status Pausiert erreicht haben, wird die Ausführungsposition durch einen orangen Pfeil angezeigt.

Die Ausführung wird fortgesetzt mit:

  • einem selektiven Schritt: Auswahl des entsprechenden Pfeils (grün)
  • einem globalen Schritt: alle Positionen mit Pfeilen für mögliche Fortsetzung werden gestartet

Kommandos

Globale Kommandos

Bei globalen Kommandos werden alle Ausführungspositionen gelöscht, da die Ausführung dort nicht fortgesetzt werden kann.

Ausnahmen: Pausieren und Fortsetzen . Hier bleiben die Ausführungspositionen so erhalten wie sie sind.

Grundfunktionskommandos

  • Anhalten für eine Grundfunktion: Die Ausführungsposition wird im Ausführungspfad der Grundfunktion gelöscht.
  • Fortsetzen: Falls eine Ausführungsposition vorhanden ist, wird in diesem Ausführungspfad ein selektiver nächster Schritt ausgeführt.

Sonderfälle:

Grundfunktionskommando Anhalten und Neustart in einem Parallelzweig bei aktivem Ende Parallelzweig

Hält man in diesem Beispiel ( (Bilder von links nach rechts) einen Parallelzweig an und startet neu, dann erreicht man nach weiterem schrittweisen Ausführen das bereits pausierte Ende Parallelzweig. Um die Ausführung hier fortzusetzen, muss die linke Grundfunktion ein Kommando Fortsetzen erhalten.

Nur einen Pfad in einem Parallelzweig mit einer aktiven Grundfunktion davor schrittweise ausführen

Wird in einem Parallelzweig mit einer Grundfunktion davor nur ein Pfad fertig ausgeführt und in einem der Parallelzweige gewartet (Grundfunktion davor ist In Ausführung, dann werden im Parallelzweig keine Ausführungspositionen mehr angezeigt. Um diese in den anderen Pfaden wieder zu erhalten, muss die Grundfunktion mit einem Grundfunktionskommando pausiert werden. Danach ist es möglich den Pfad fertig auszuführen.

Wird dann allerdings der Parallelzweig mit der Ausführungsposition weiter ausgeführt, dann wird die Grundfunktion vor dem Parallelzweig dadurch deaktiviert. Damit bleibt der linke Pfad Pausiert und ohne Ausführungsposition. Da hier nun keine aktive Grundfunktion vorhanden ist, kann die Ausführung nur mit einem globalen Pausieren und Fortsetzen wieder aufgenommen werden.

Springen (jump)

Springen bedeutet im Ablauf von einer Position auf eine andere - entfernte - zu wechseln, um dort die Ausführung fortzusetzen.

Um zu springen:

  1. wählen Sie eine Ausführungsposition mit der Maus aus
  2. ziehen Sie diesen auf eines der angebotenen Ziele
  3. führen Sie den nächsten Schritt aus

Es werden alle aktiven Elemente vor dem Quellzeiger deaktiviert und das Objekt nach dem Ziel aktiviert.

Wird ein Sprung registriert, bei dem Quelle und Ziel sinngemäß die gleiche Stelle sind (Sprung über Linien, Sprungziele oder Ende Zweig Objekte), dann wird dieser Sprung ignoriert und es wird ein einfacher Schritt ausgeführt.

Springen in Parallelzweigen

Wird in Parallelzweigen über die Grundfunktion im ersten Parallelzweig gesprungen, dann wird die erste Grundfunktion vor dem Parallelzweig deaktiviert. Damit ist keine Grundfunktion mehr aktiv. Grundfunktionen dürfen nicht übersprungen werden, wenn damit keine Grundfunktion im Rezept mehr aktiv ist. Folgendes Verhalten beim Springen führt zu einem Fehler:

  • Rezept mit Parallelzweig

  • Ein globaler Schritt aktiviert die Grundfunktion vor Anfang Parallelzweig.

  • Nach dem nächsten Schritt befindet sich die Ausführungsposition vor der Grundfunktion im Parallelzweig.

  • Die Ausführungsposition wird hinter diese Grundfunktion verschoben.

    Regel beim Springen: Objekte vor einem Anfang Parallelzweig werden inaktiv, sobald Objekte danach aktiv werden.
    Damit wird jetzt beim Sprung die erste Grundfunktion inaktiv. Die übersprungene Grundfunktion im Parallelzweig wurde nie aktiv, ebenso wenig die folgenden Grundfunktionen.
    Damit ist jetzt im Rezept keine Grundfunktion mehr aktiv:


Ablauf einer Grundfunktion im Detail

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Ablauf einer Grundfunktion im Detail

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Grundfunktion wird immer nach dem selben Schema sequentiell abgearbeitet. Um den genauen Ablauf aufschlüsseln zu können, bedarf es auch einer nachfolgenden Bedingung. Für diese Darstellung verwenden wir als nachfolgende Bedingung eine Transition. Die Grundfunktion selber benennen wir Grundfunktion 1. Weitere spezielle Ablaufverhalten mit nachfolgenden Bedingungen finden Sie im Kapitel Nachfolgende Bedingung.

Grundfunktion | Transition | Ereignis
Grundfunktion wird aktiviert |  |
Alle Variablen der Grundfunktion werden bei den Treibern angemeldet. |  |
Alle Ereignisse der Grundfunktion werden aktiviert. |  | Grundfunktion gestartet
Aggreagtsbelegung wird gestartet und Wartezeit Aggreagtbelegung wird gestartet |  | Wenn die Aggregatsbelegung nicht im ersten Versuch erfolgreich war: Aggregatsbelegung nicht möglich
Optional: Aggregatsbelegung innerhalb der Wartezeit nicht möglich. |  | Wartezeit Aggregatsbelegung überschritten
Prüfung, ob Grundfunktion nicht bereits ausgeführt wird, wird gestartet. Dies kann vorkommen, wenn die Grundfunktion schon in einem Parallelzweig aktiv ist oder wenn die Aggregatsbelegung manuell übersprungen wurde und die Grundfunktion in einem anderen Rezept bereits ausgeführt wird. |  | Grundfunktion mehrfach gestartet
Prüfung der Eingangsverriegelung wird gestartet und Wartezeit Eingangsverriegelung wird gestartet. |  | Wenn die Prüfung der Eingangsverriegelung nicht im ersten Versuch erfolgreich war: Eingangsverriegelung blockiert
Optional: Bedingung der Eingangsverriegelung innerhalb der Wartezeit nicht TRUE. |  | Wartezeit Eingangsverriegelung überschritten
Schreiben der Befehlsparameter |  | Wenn alle Befehlsparameter geschrieben wurden: Befehlsparameter fertig abgesetzt
Prüfung der Weiterschaltbedingung wird gestartet und Zeit für Minimale Ausführungsdauer und Maximale Ausführungsdauer wird gestartet. |  |
Optional: Weiterschaltbedingung erfüllt, aber Minimale Ausführungsdauer nicht erreicht. |  |
Optional: Bedingung der Weiterschaltbedingung innerhalb der Maximalen Ausführungsdauer nicht TRUE |  | Wartezeit Weiterschaltbedingung überschritten
Optional: Warten auf das Neustarten der gesamten Ausführung. Wenn die Ausführung noch beim Neustarten ist (für andere Grundfunktionen im Rezept ist die Neustartbedingung noch nicht erfüllt), dann wird hier gewartet. Das stellt sicher, dass das nachfolgende Element erst nach dem Wechsel auf In Ausführung des Rezepts aktiviert wird. |  |
Weiterschaltbedingung ist TRUE und Minimale Ausführungsdauer ist erreicht oder überschritten. Wartezeit nachfolgende Bedingung wird gestartet. | Transition wird aktiviert | Grundfunktion beendet
 | Alle Variablen der Transition werden bei den Treibern angemeldet | Wartezeit nachfolgende Bedingung überschritten
Optional: Nachfolgende Bedingung nicht innerhalb der Wartezeit TRUE | Die Transitionsbedingung wird geprüft. |
Die nächste Grundfunktion wird aktiviert. Die nachfolgende Bedingung kann sich aus mehreren Objekten zusammensetzen (z.B. Transition + Aggregatsbelegung). Erst wenn die nächste Grundfunktion erreicht wird (oder das Ende des Rezepts), gilt die nachfolgende Bedingung als erfüllt. |  |
Grundfunktion wird informiert dass nachfolgende Bedingung erfüllt ist | Transitionsbedingung ist TRUE | Grundfunktion abgeschlossen
Alle Ereignisse der Grundfunktion werden deaktiviert. |  |
Alle Variablen der Grundfunktion werden von den Treibern abgemeldet. | Alle Variablen der Transition werden von den Treibern abgemeldet. |
Die Grundfunktion wird deaktiviert. | Die Transition wird deaktiviert. |

Regel für Werte von Transitionen

Hat eine Transition während der Wartezeit für die Weiterschaltbedingung den Wert TRUE, wird sie als beendnet markiert. Sollte ihr Wert später wieder auf FALSE wechseln, hat das keinen Einfluss auf den weiteren Ablauf des Rezepts.

Noch in diesem Kapitel

Nachfolgende Bedingung


Nachfolgende Bedingung

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Ablauf einer Grundfunktion im Detail -> Nachfolgende Bedingung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Grundfunktion ist so lange aktiv, bis die nachfolgende Bedingung erfüllt ist. Erst wenn die nachfolgende Bedingung erfüllt ist, wird die Grundfunktion abgeschlossen. Das Ereignis Grundfunktion abgeschlossen wird angestoßen und die Grundfunktion wird deaktiviert. Vor dem Deaktivieren werden noch die Ereignis Reaktionen ausgeführt. Siehe auch Ablauf einer Grundfunktion im Detail

Die nachfolgende Bedingung kann sehr unterschiedlich sein. Hier einige Beispiele:

  • Grundfunktion 1 gefolgt von einer Grundfunktion 2:
    Sobald bei der Grundfunktion 1 die Weiterschaltbedingung (und optional die Minimale Ausführungsdauer) erfüllt ist, wird die Grundfunktion 1 abgeschlossen und die Grundfunktion 2 aktiviert.

  • Grundfunktion 1 gefolgt von einer Transition:
    Erst wenn die Transitionsbedingung erfüllt ist, wird die Grundfunktion 1 abgeschlossen
  • Grundfunktion 1 und Grundfunktion 2 parallel gefolgt von einem Ende Parallelzweig:
    Erst wenn bei beiden Grundfunktionen die Weiterschaltbedingung (und optional die Minimale Ausführungsdauer) erfüllt ist , werden beide Grundfunktionen abgeschlossen.
  • Grundfunktion 1 und Grundfunktion 2 parallel gefolgt von einem Ende Parallelzweig wiederum gefolgt von einer Transition:
    Erst wenn die Transitionsbedingung erfüllt ist, werden beide Grundfunktionen abgeschlossen


Runtime Beenden und Wiederanlauf

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Runtime Beenden und Wiederanlauf

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Beenden der Runtime wird eine Abbildatei (Image) der laufenden Rezepte erstellt. Diese beinhaltet die Abbilder der REEs, die Reihenfolge der Belegungen und alle Reaktionen, die beim Wiederanlauf benötigt werden.

Belegungen

Nach dem Wiederanlaufen entsprechen Belegungen dem Zustand vor dem Beenden. Es wird gespeichert, wer ein Aggregat belegt hat und wer in welcher Reihenfolge Belegungen erzwungen hat. Kann ein Rezept nicht wieder anlaufen (z. B. wegen fehl geschlagener Validierung), dann werden die Belegungen für dieses Rezept entfernt.

Reaktionen

Reaktionen, die vom Prozess angestoßen wurden, werden auch in das Image aufgenommen, wenn diese anstehen. Sie werden dann nach dem Wiederanlauf der REE ausgeführt. Dabei ist garantiert, dass die Reaktion immer als Ganzes ausgeführt wird, entweder vor dem Erstellen der Abbilddatei oder nach dem Wiederanlaufen.

Die Runtime Beenden Reaktion wird immer ausgeführt und kann nie ins Image aufgenommen werden.

Synchrones Schreiben

Die REE verwaltet die Bestätigungen für alle Variablen, deren Sollwertsetzen synchron ausgeführt werden soll. Der Timeout dafür wird durch die Zeit definiert, innerhalb der sich die Runtime beenden muss. Bei jeder Schreibbestätigung wird der Timeout neu gestartet. Ein Timeout wird in der LOG-Datei.

Variablen, die auf keinen Treiber zugreifen, werden immer ohne Bestätigung geschrieben, auch wenn eine Schreibbestätigung angefordert wird. Interne Treiber unterstützen keine Schreibbestätigung.

Parameter zuweisen

Da beim Starten der Runtime auch alle Treiber starten, können diese eventuell noch keinen gültigen Wert liefern, wenn dieser beim Wiederanlauf benötigt wird. Auf die Wertaktualisierung wird beim Wiederanlauf nicht gewartet. Damit ist nicht sichergestellt, dass der Wert wie erwartet geschrieben wird. Ist kein Wert verfügbar, wird der Ersatzwert verwendet.

Auf die Werte von internen Treibern wird gewartet, sofern diese innerhalb von 2 Zyklen verfügbar sind .


Neustart Grundfunktion

Handbuch -> Batch Control -> Konfigurieren und steuern in der Runtime -> Recipe Execution Engine (REE) -> Neustart Grundfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Grundfunktionen können neu gestartet werden. Dabei werden alle verbundenen aktiven Objekte deaktiviert, auch verbundenen Parallelzweige.

Deaktivierung

Bei einem Neustart einer Grundfunktion werden prinzipiell alle aktiven Objekte deaktiviert, allerdings nur, wenn sie verbunden sind. Isolierte aktive Objekte werden nicht deaktiviert.

Reihenfolge der Deaktivierung

Die Deaktivierung geht von dem Objekt aus, das am längsten aktiv ist. Dieses Objekt wird auch nach dem Neustart wieder aktiviert. Wenn dieses Objekt deaktiviert wird, deaktiviert es auch alle Zweige, zu denen es eine Verbindung über ein aktives Objekt herstellen kann.

Isolierter Zweig

Ein Zweig ist dann isoliert, wenn er über kein aktives Objekt mit einem anderen Zweig verbunden ist. Die Deaktivierung erfolgt immer nur zwischen verbundenen Zweigen. Solange ein Objekt nicht den Status Abgeschlossen hat, besteht auch keine aktive Verbindung zu seinem Nachfolgeobjekt. Ist in einem isolierten Zweig keine Grundfunktion vorhanden, wird beim Neustart das älteste Objekt aktiviert, zum Beispiel eine Transition.

Beispiel

Wenn in diesem Ablauf NormalTO neu gestartet wird, werden auch die Ende Parallelzweig und die Transition deaktiviert. Diese sind in äußeren Zweige gesehen von NormalTO.

Das bedeutet für Ende Parallelzweig: Solange nicht alle Pfade bei Ende Parallelzweig anstehen, besteht keine aktive Verbindung zum Nachfolgeobjekt. Für Anfang Parallelzweig gilt das Gleiche.

Solange die Transition vor Anfang Parallelzweig aktiv ist, sind auch Anfang Parallelzweig und die beiden Anfang Verzweigung aktiv. Ein Neustart wird auch die inneren Zweige neu starten. Ein Neustart der inneren Zweige deaktiviert diese. Die äußerste Transition wird neu gestartet.

Neustart ausgewählter Grundfunktionen

Eine oder mehrere Grundfunktionen können ausgewählt und neu gestartet werden. Bei der Auswahl mehrerer Grundfunktionen müssen sich diese in getrennten Zweigen befinden.

Im gewählten Zweig wird für das älteste Objekt ein Neustart ausgeführt. Damit werden alle aktiven Objekte in verbundenen Zweigen deaktiviert.

Globaler Neustart

Der globale Neustart führt einen Neustart für alle Grundfunktionen aus. Der Neustart wird für das älteste aktive Objekt ausgeführt und damit werden alle verbundenen aktiven Objekte deaktiviert. Alle noch verbleibenden aktiven Objekte befinden sich in einem isolierten Zweig. Auch hier wird wieder das älteste Objekt neu gestartet bis alle aktiven Objekte behandelt wurden. Manuelle Sprünge werden dabei nicht ausgeführt.


Verhalten im Netzwerk

Handbuch -> Batch Control -> Verhalten im Netzwerk

Das Modul Batch Control ist voll netzwerkfähig im Sinne der Client/Server-Technologie. Das heißt, es können Batch-Rezepte auf einem Client erstellt, dupliziert, bearbeitet, gelöscht usw. werden. Dabei erfolgt die gesamte Rezeptverwaltung immer am Server. Ebenso kann von einem Client aus die gesamte Ablaufbedienung wie Rezept starten, pausieren, stoppen usw. erfolgen. Auch Moduswechsel und manuelle Operationen wie springen sind möglich.

attention Achtung

Das Modul Batch Control ist nicht redundanzfähig. Es erfolgt kein Abgleich am Standby-Server. Bei einem Ausfall des Servers werden die ausgeführten Batch-Rezepte am Standby nicht nahtlos fortgesetzt!

Beim Einsatz von Batch Control in einem Netzwerk gilt:

Belegung

  • Das Erzwingen (forcen) von Belegungen kann von Server und Client aus erfolgen.

Funktionen

Funktionen werden immer am Server ausgeführt.

Grundfunktionen

  • Bearbeitung von Grundfunktionen in Vorlagenrezepten:
    • Editiermodus: Änderungen werden lokal am Client durchgeführt.
      Wird während der Bearbeitung das Rezept auf einem anderen Rechner im Netzwerk gespeichert, geht die aktuelle Konfiguration verloren. Es wird eine entsprechende Nachricht angezeigt und der Dialog zur Bearbeitung wird geschlossen, die neuen Daten vom Server werden angezeigt.
    • Testmodus: Änderungen werden am Server durchgeführt.
  • Steuerrezept: Änderungen werden am Server durchgeführt.
  • Wird ein Rezept im Netzwerk gespeichert, werden alle Clients, die dieses Rezept verwenden, aktualisiert.
  • Wird auf einem Rechner ein Rezept gelöscht, wird auf allen Rechnern, die dieses Rezept zur Ansicht geöffnet haben, eine Meldung ausgegeben, dass das Rezept gelöscht wurde.

Modus

  • Modus (automatisch, semiautomatisch, manuell) kann von Server und Client aus umgeschaltet werden.
  • Springen im Rezept und schrittweises ablaufen lassen von Rezepten kann von Server und Client aus erfolgen.

Rezepte

  • Rezepte können vom Server und von Clients gestartet und gesteuert werden.

Webclient

Mit einem Standard-Webclient ist es nicht möglich, die Größe eines Blattes zu ändern. Änderungen für Gitternetz und Farbe sind möglich. Es können auch keine neuen Rezepte erstellt werden. In der Symbolleiste werde alle Symbole, die nicht zugelassen sind, deaktiviert; die Auswahl entsprechender Objekte ist nicht möglich.

Der Webclient PRO ist von diesen Einschränkungen nicht betroffen.


Formeleditor

Handbuch -> Batch Control -> Formeleditor

Der Formeleditor wird immer automatisch aufgeschaltet, wenn die Eingabe oder Bearbeitung einer Formel verlangt wird. Vor allem bei:

Editor:

  • Grundfunktionen
  • Verriegelungsbedingungen
  • allen Bedingungen für Transitionen
  • Weiterschaltbedingung

Runtime:

  • Weiterschaltbedingung und Verriegelungen bei der Bearbeitung einer Grundfunktion
  • Bearbeitung von Transitionen

Hinweis: Wird die in der Formel referenzierte Grundfunktion entfernt und eine neue Grundfunktion eingefügt, werden die Operanden neu zugewiesen.

Formel eingeben

Als Eingabe werden akzeptiert:

  • Konstante in Dezimalzahlen
  • Hexadezimalzahlen, wenn diese durch ein x eingeleitet werden
  • Punkt als Dezimaltrennzeichen, dabei gilt:
    • Komma wird automatisch durch Punkt ersetzt: aus 23,000 wird 23.000
    • Nachkommastellen, die nur aus Nullen bestehen werden abgetrennt: aus 23.000 wird 23

Parameter

Beschreibung

Parameterliste

Liste der Parameter, die für die Formel verwendet werden können.

Jeder Eintrag besteht aus:

  • einem Basisknoten für die Bezeichnung
  • einem Wert
  • einem Status
  • den Bits von Wert und Status

Ein Symbol am ersten Knoten zeigt an, ob es sich um einen Befehls- oder Rückgabeparameter handelt.

Die Kurzbezeichnung am Beginn des Namens wird in der Formel verwendet.

Hinzufügen

Öffnet Dialog zum Hinzufügen eines Parameters. Dabei gilt:

  • Hinzugefügt werden können: numerische und binäre Parameter sowie Parameter für Zeitdauer.
  • Für Bedingungen der Grundfunktion können nur die für sie angelegten Parameter verwendet werden.
  • Parameter können auch mehrfach hinzugefügt werden.

Ersetzen

Ermöglicht das Ersetzen eines Parameters. Die Kurzbezeichnung bleibt beim Ersetzen bestehen.

Entfernen

Löscht den markierten Parameter. Damit ein Parameter gelöscht werden kann:

  • muss die Formel korrekt sein
  • darf der ausgewählte Parameter in der Formel nicht verwendet werden

Logische Operatoren

Über die Schaltflächen für Operatoren werden Operatoren in die Formel eingefügt.

AND

logisch 'UND'

OR

logisch 'ODER'

XOR

logisch 'EXKLUSIV ODER'

NOT

Negation

Syntax

Die Operatortasten fügen den auf ihnen dargestellten String in die Formel ein.

(

Klammer öffnen

)

Klammer schließen

Bitweise und Vergleichsoperatoren

&

Und

|

Oder

>

größer als

>=

größer gleich

<

kleiner als

<=

kleiner gleich

=

gleich

<>

kleiner oder größer

Bedingung

Konfiguration und Darstellung der Formel.

Kopieren

Kopiert die gesamte Formel:

  • alle konfigurierten Parameter aus dem Parameterbaum
  • Formel aus dem Feld

Einfügen

Fügt eine Formel aus der Zwischenablage ein. Dabei werden alle bisher konfigurierten Elemente gelöscht und durch die kopierte Formel ersetzt.

Beim Kopieren von Formeln zwischen Grundfunktionen wird versucht, die Operanden über ihre Namen wieder aufzulösen. Für Parameter die nicht gefunden werden, werden ungültige Einträge in der Operandenliste erstellt. Ihre Verwendungsstellen in der Formel bleiben bestehen.

OK

Übernimmt Formel und schließt den Dialog.

Dazu muss die Formel korrekt sein.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

info Info

Es können bis zu 99 Parameter in einer Formel verknüpft werden. X01 bis X99. Die Länge der Formel darf dabei 4096 Zeichen nicht überschreiten.

Die Bedeutung der Bits:

Parameter | Beschreibung
Wert-Bits | Es stehen 32 Wert-Bits (von 0 -31) zur Verfügung. Sie beschreiben den Parameterwert bitweise. Für binäre Parameter hat nur das Bit 0 Bedeutung, für SINT und USINT die Bits 0-7 usw...
Status-Bits | Stellt die gängigsten Status-Bits zur Verfügung. Die genaue Definition und Verwendung der Status-Bits finden Sie in der Liste Status-Bits.
Wert und Status | Alle Werte (Wert-Bits und Status-Bits) in den Formeln werden als Binärwerte betrachtet und können dann logisch mit UND bzw. ODER sowie anderen logischen Ausdrücken verbunden werden. Eine Ausnahme bilden der Gesamtwert und der Gesamtstatus. Damit man damit auf einen Boole'schen Ausdruck kommt, muss man diesen Gesamtwert zuerst mit einer Konstante bitweise verodern. Dazu wird der Operator & verwendet. Bei Ergebnis 0 (False) der bitweisen Veroderung ergibt sich der Binärwert 0 (False), ansonsten 1 (True). Beispiel: siehe Kapitel Beispiel bitweise Veroderung

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.

info Info

Formeln mit binären X-Werten und bitweiser Verknüpfung können mit maximal 2 binären Werten benutzt werden. Werden mehr Werte benötigt, muss die Verknüpfung ohne binäre X-Werte erfolgen.

Beispiel:

X01.Value & X02.Value -> funktioniert

X01.Value & X02.Value & X03.Value -> funktioniert nicht

Aber:

X01.00 AND X02.00 AND X03.00 AND X04.00 AND X05.00 -> funktioniert

Noch in diesem Kapitel

Liste Status-Bits

Logische Operatoren

Bitformeln

Vergleichsoperatoren

Beispiele für Formeln


Liste Status-Bits

Handbuch -> Batch Control -> Formeleditor -> Liste Status-Bits

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Details zur Statusverarbeitung lesen Sie im Kapitel Statusverarbeitung.


Logische Operatoren

Handbuch -> Batch Control -> Formeleditor -> Logische Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Logische Verknüpfungen: Variablen werden nur auf den logischen Wert '0' überprüft, ist der Wert ungleich '0', wird er mit '1' definiert.

Im Unterschied zur Bitformel kann der technische Bereich durch einen Streckungsfaktor verändert werden -> ungleich '0' oder '1'.

Operator | Bedeutung
AND | logisch 'UND'
NOT | Negation
OR | logisch 'ODER'
XOR | logisch 'EXKLUSIV ODER'

Die Operator haben in der Formelberechnung folgende Priorität:

Priorität | Operator
1 | & (Operator für Bitformeln)
2 | NOT
3 | AND
4 | XOR/OR

info Info

Es können bis zu 99 Variablen in einer Formel verknüpft werden. X01 bis X99.

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.


Bitformeln

Handbuch -> Batch Control -> Formeleditor -> Bitformeln

Bitformeln besitzen nur einen logischen Low- oder Highzustand. Im Unterschied zu logischen Formeln ist der Rohwert bereits fix vordefiniert (0,1).

Operator | Beschreibung
& | AND
| | OR

Noch in diesem Kapitel

Beispiel bitweise Veroderung


Beispiel bitweise Veroderung

Handbuch -> Batch Control -> Formeleditor -> Bitformeln -> Beispiel bitweise Veroderung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie wollen abfragen, ob eines der Anwenderstatus Bits 1-8 (M1 ... M8) von der Variable X01 gesetzt ist.

Normale Formel:

X01.M1 OR X01.M2 OR X01.M3 OR X01.M4 OR X01.M5 OR X01.M6 OR X01.M7 OR X01.M8
Diese Abfrage kann durch die bitweise Veroderung des Gesamtstatus wesentlich erleichtert werden.

Bitweise Veroderung:

X01.Status & 0xFF

Die Konstante kann, wie oben beschrieben, Hexadezimal eingegeben werden:

0xFF entspricht dezimal 256, das sind die ersten acht Statusbits (Binär 11111111). Steht eines dieser Bits auf 1, dann ist das Ergebnis dieser bitweisen Veroderung 1 (True), ansonsten 0 (False).

Sollen z. B. alle Anwender Status-Bits außer dem Anwender Status-Bit M7 abgefragt werden, wäre der Binäre Ausdruck dafür: 10111111. Bit 7 ist nicht interessant, steht daher auf 0. Das entspricht Hexadezimal 0xBF. Der Ausdruck für die Formel ist dann: X01.Status & 0xBF.

Statt mit einer Konstante bitweis zu verodern, kann man den Wert auch direkt mit einer dezimalen Zahl vergleichen. Ist ein Vergleich falsch, ergibt sich der Binärwert 0 (False), ansonsten 1 (True).

Beispiel:

Sie wollen abfragen, ob ein Wert der Konstanten 202 entspricht. Die Formel lautet:

X01.Wert = 202

Entspricht der Wert der Konstanten 202, so ist das Ergebnis dieses Vergleiches 1 (True), ansonsten 0 (False).

Hinweis: Die bitweise Veroderung funktioniert mit dem Oder-Zeichen (|) analog zu diesem Beispiel.


Vergleichsoperatoren

Handbuch -> Batch Control -> Formeleditor -> Vergleichsoperatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vergleichoperatoren dienen zum direkten Vergleich von zwei numerischen Werten. Das Ergebnis dieses Vergleichs wird in Form eines Binärzustandes dargestellt. „0“ wenn die Bedingung nicht erfüllt ist und „1“ wenn die Bedingung erfüllt ist.

Operator | Beschreibung
< | kleiner
> | größer
<= | kleiner gleich
>= | größer gleich
= | ist gleich
<> | ungleich

Links und rechts vom Vergleichs Operator muss ein (Gesamt-)Wert oder (Gesamt-)Status stehen, Einzelbits können mit diesen Vergleichsoperatoren nicht verwendet werden.

Rechts vom Vergleichs Operator kann auch eine Konstante stehen. Die Konstanten können nur Ganzzahlen sein, ein Vergleich mit Gleitkommazahlen ist nicht möglich.
Im Combi-Element werden diese Konstanten als hexadezimale Werte oder Dezimalwerte eingegeben. Hexadezimale Zahlen werden beim Klick auf OK automatisch in Dezimalzahlen umgewandelt (z.B. entspricht 0x64 dem numerischen Wert 100).

Example Beispiel

X01.Wert >= X02.Wert
Das Ergebnis ist „1“ wenn der Wert von X01 größer oder gleich dem Wert X02 ist

X01.Wert = 0x64
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 entspricht (= Hex 0x64)

(X01.Wert = 0x64) OR (X01.Wert = 0x65)
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 oder 101 entspricht (= Hex 0x64 und Hex 0x65)


Beispiele für Formeln

Handbuch -> Batch Control -> Formeleditor -> Beispiele für Formeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einfache logische UND Verknüpfung zwischen zwei Werte Bits

Example Beispiel

Formel: X01.03 AND X02.03

Diese Formel ergibt den Zustand WAHR, wenn sowohl Bit 3 der Variablen 1 als auch Bit 3 der Variablen 2 den Wert 1 hat.

Der Wert oder Status einer Variable analog vergleichen

Example Beispiel

(X01.Wert> X02.Wert)

Analoge Vergleiche auf logischer Basis miteinander vergleichen

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert)

Vergleiche mit Werte- und Status-Bits

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert) OR (X01.03 = X02.03)

Einen Wert mit einem dezimalen oder hexadezimalen Wert vergleichen

Example Beispiel

Formel: (X01.Wert = 111)

Formel: (X01.Wert = 0x6F)

Wird ein hexadezimaler Wert verwendet, so wird dieser mit dem Klick auf OK später in dezimale Schreibweise umgewandelt. Wurde ein dezimaler Wert angegeben und bestätigt, wird dieser beim erneuten Öffnen weiter als dezimaler Wert angezeigt.

info Info

Bei der Eingabe von Zahlen ist es nicht möglich, ein Komma oder einen Punkt zu verwenden.


Fehlerbehandlung

Handbuch -> Batch Control -> Fehlerbehandlung

Warnungen und Fehlermeldungen werden in Log-Dateien geschrieben und können mit dem Diagnose Viewer ausgewertet werden. Dazu muss in den Filtereinstellungen das Modul Batch Control aktiviert werden.

Systemtreibervariable

Batch Control stellt dem Systemtreiber SYSDRV Informationen in Systemtreibervariablen zur Verfügung. Informationen zu deren Meldungen finden Sie im Handbuch SYSDRV, im Kapitel Thema - Batch Control.

Pop-Up Meldungen

Meldung | Erklärung
Die Name "Name" ist ungültig oder wurde bereits vergeben. | Der Name enthält entweder ungültige Zeichen oder wird bereits verwendet. Der Name darf keinen Punkt enthalten, nicht nur aus Leerzeichen bestehen und darf nicht leer sein.
Duplizierung von'<MR>' @vom Server abgelehnt. | Das zur Duplizierung gewählte Rezept konnte am Server nicht dupliziert werden. Eventuell Ist dieses nicht mehr vorhanden.
Sollen selektierte Vorlagenrezepte wirklich gelöscht werden? | Sicherheitsabfrage vor dem unwiderruflichen Löschen eines Vorlagenrezepts.
Das Diagramm wurde geändert. Wollen Sie es speichern? | Sicherheitsabfrage zum Speichern vor dem Verlassen eines nicht gespeicherten Diagramms.


Benutzerverwaltung

Handbuch -> Benutzerverwaltung

zenon sieht sowohl für den Editor als auch für den Onlinebetrieb (Runtime) eine Benutzerverwaltung vor. Das Passwortsystem erfüllt die Richtlinien der FDA (Food and Drug Administration, 21 CFR Part 11).

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Das Konzept

Das Passwortkonzept geht davon aus, dass unterschiedliche Anwender unterschiedliche Bedienrechte (Passwortebenen) besitzen. Auch Administratoren verfügen über unterschiedliche Berechtigungsebenen, haben aber zusätzliche verwaltungsbezogene Funktionen wie das Administrieren von Benutzern.

Im vorhandenen Passwortkonzept ist es möglich, jedem Benutzer mehrere selektive (einzeln definierte) Passwortebenen (Bedienrechte) zuzuweisen. Es sind maximal 128 (0-127, ab Version 6.20) Passwortebenen projektierbar. Die Zuordnung der Benutzer zu den einzelnen Passwortebenen und der damit verbundene Aufbau des projekt-spezifischen Passwortkonzeptes kann vollständig frei erfolgen. Jedem Benutzer können beliebige Ebenen zugewiesen werden. So kann z. B. der Benutzer 1 über die Ebenen 0, 1, 5, 6 verfügen und der Benutzer 2 über die Ebenen 0, 1, 6, 8, 10. Aber es können nur Berechtigungen vergeben werden, über die der Administrator selbst verfügt.

Das Anmelden des Benutzers im Onlinebetrieb erfolgt über die Aktivierung der Funktion Login (Text Button, Bitmap Button etc.). Soll der Benutzer aufgrund eines Ereignisses automatisch angemeldet werden (z.B. Schlüsselschalterstellung als Meldung im System vorhanden), wird die Funktion Login ohne Passwort verwendet. Die Funktion wird in einem Grenzwert bzw. in einer Rema der Variable in der Variablenverwaltung projektiert.

Das durch den Benutzer angeregte Abmelden im Onlinebetrieb erfolgt mit der Funktion Logout. Der neu am System angemeldete Benutzer ist SYSTEM.

Wird über einen projektierten Zeitraum lang keine neuerliche Bedienaktion vorgenommen, kann ein automatisches, zeitgesteuertes Abmelden erfolgen.

Kontextmenü Projektmanager

Kontextmenü Benutzerverwaltung

Menüpunkt | Aktion
Editorprofile | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe

Kontextmenü Benutzer

Menüpunkt | Aktion
Benutzer neu | Öffnet den Dialog zur Anlage eines neuen Benutzers und trägt diesen in die Liste der Detailansicht ein.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Help | Öffnet die Online-Hilfe.

Kontextmenü Benutzergruppe

Menüpunkt | Aktion
Benutzergruppe neu | Öffnet den Dialog zur Anlage einer neuen Benutzergruppe und trägt diese in die Liste der Detailansicht ein.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Editorprofile | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Help | Öffnet die Online-Hilfe.

Kontextmenü Detailansicht: siehe Benutzerverwaltung Detailansicht Symbolleiste und Kontextmenü

Noch in diesem Kapitel

Projektieren im Editor

Active Directory (AD)

Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista)

Active Directory Application Mode - ADAM (für Windows XP)

Bedienen zur Runtime


Projektieren im Editor

Handbuch -> Benutzerverwaltung -> Projektieren im Editor

info Info

Wenn Sie den default-Wert für die maximale Passwortfehleingabe unter 'Projekteigenschaften -> Benutzerverwaltung -> Max. Passwortfehleing.' ändern, ist zu beachten, dass diese Änderung nur bei einem Neustart der Runtime aktiv wird. Die Funktion 'Nachladen' der Runtime übernimmt diese Änderung nicht, da sonst beliebig viele Versuche zur Passworteingabe möglich wären.

Noch in diesem Kapitel

Benutzerverwaltung Detailansicht Symbolleiste und Kontextmenü

Anlegen eines Benutzers

Anlegen einer Benutzergruppe

Ändern eines Benutzers

Änderung einer Benutzergruppe

Namensänderung der Berechtigungsebenen

Funktionsberechtigungen

Bild vom Typ Login anlegen


Benutzerverwaltung Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Benutzerverwaltung Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Menüpunkt/Symbol | Aktion
Benutzer neu | Öffnet den Dialog zur Anlage eines neuen Benutzers und trägt diesen in die Liste der Detailansicht ein.
Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte XML exportieren.. | Exportiert alle ausgewählten Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
XML importieren | Importiert aus XML-Datei.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Benutzergruppe

Menüpunkt | Aktion
Benutzergruppe neu | Öffnet den Dialog zur Anlage einer neuen Benutzergruppe und trägt diese in die Liste der Detailansicht ein.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Help | Öffnet die Online-Hilfe.


Anlegen eines Benutzers

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen eines Benutzers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen neuen Benutzer anzulegen:

  1. navigieren Sie zum Knoten Benutzerverwaltung/Benutzer
  2. wählen Sie im Kontextmenü des Projektmanagers oder der Datailansicht oder ind er Symbolleiste Benutzer neu...
  3. der Dialog zur Konfiguration wird geöffnet
  4. legen Sie in den einzelnen Registerkarten die Einstellungen fest für:
    • Benutzer
    • Passwort
    • Message Control
    • Berechtigungsebenen
    • Benutzergruppen

info Info

Empfehlung: Legen Sie als ersten Benutzer einen Administrator ein. Nur dieser hat Zugriff auf alle Funktionen und kann damit auch Benutzer, die durch dreimalige Falscheingabe eines Passwortes gesperrt wurden, wieder frei schalten.

Noch in diesem Kapitel

Benutzer

Passwort ändern

Message Control

Berechtigungsebenen

Benutzergruppen


Benutzer

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen eines Benutzers -> Benutzer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration des Benutzers:

Parameter

Beschreibung

Benutzername

Geben Sie hier den Benutzernamen ein. Der Benutzer meldet sich mit seinem Benutzernamen am System an.

Maximale Länge: 20 Zeichen.

Hinweis: Dieser Name muss eindeutig sein.

Vollständiger Name

Geben Sie den vollständigen Namen des Benutzers ein. Damit ordnen Sie Benutzernamen realen Personen zu.

Administrator

Aktiv: Der Benutzer erhält den Status eines Administrators.

Nur ein Administrator kann zur Laufzeit neue Benutzer anlegen, Benutzer editieren, Passwörter löschen usw.

Aktiv

Aktiv: Der Benutzer ist aktiv und kann sich zur Runtime anmelden.

Hinweis: Nach den Regeln der FDA 21 CFR PART 11 darf ein Benutzer nie gelöscht werden, damit auch zu jedem späteren Zeitpunkt nachvollzogen werden kann, wer welche Aktion durchgeführt hat. Daher darf bei Projekten, die diesen Regeln unterliegen, ein Benutzer nur deaktiviert aber nicht gelöscht werden.

Um das Löschen von Benutzern zu verhindern, deaktivieren Sie in den Projekteigenschaften die Eigenschaft Löschen von Benutzern in der Gruppe Benutzerverwaltung.

Interne ID: Benutzer

Benutzerverwaltung

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Benutzer

Löschen von Benutzern

Aktiv: Löschen eines Benutzers in der Runtime ist erlaubt.
Inaktiv: Benutzer können nur gelöscht markiert werden. Die Benutzer bleiben dabei in der Liste der Benutzer, sind allerdings für die Bedienung in der Runtime nicht mehr gültig (nach FDA Richtlinie).
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Gesperrt

Aktiv: Der Benutzer ist zur Runtime gesperrt und kann sich nicht anmelden.

Diese Option wird automatisch gesetzt, wenn ein Benutzer sein Passwort drei Mal falsch eingegeben hat.

Sperrcode

4-stelliger PIN-Code ein.

Dieser Code wird vom Benutzer in der Befehlsgabe verwendet, um Bereiche zu sperren bzw. wieder frei zu geben.

Runtimeprofil, das beim Login aufgerufen wird

Auswahl des Runtimeprofils aus Dropdownliste:

  • Keines
  • Default
  • Last

OK

Übernimmt Änderungen aller Registerkarten und schließt Dialog.

Abbrechen

Verwirft Änderungen aller Registerkarten und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.

info Info

Ein Administrator kann anderen Benutzern nur solche Gruppen frei geben, für die er selbst die Rechte besitzt.


Passwort ändern

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen eines Benutzers -> Passwort ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Festlegung oder Änderung des Passworts.

Passwörter dürfen maximal 20 Zeichen lang sein. Die minimale Länge wird in den Projekteigenschaften in der Gruppe Benutzerverwaltung mit der Eigenschaft Min. Passwortlänge definiert. Der Standwardwert beträgt 6 Zeichen.

Interne ID: Passwort ändern

Min. Passwortlänge

Zeichenanzahl, die ein Passwort mindestens haben muss.
Minimum: 0.
Maximum: 20.
Default: 6.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Passwort ändern

Benutzerverwaltung

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter | Beschreibung
Altes Passwort | Aktuelles Passwort.
Neues Passwort | Eingabe Neues Passwort. Beachten Sie bei sprachübergreifenden Projekten, dass es möglich sein muss,die Zeichen auf der entsprechenden Tastatur zur Runtime einzugeben.
Passwort bestätigen | Wiederholung des neuen Passworts.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

Die Funktionalität Kopieren und Einfügen steht für die Eingabe in Passwortfeldern nicht zur Verfügung.


Message Control

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen eines Benutzers -> Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Optionen für die Verwendung der Benutzer im Modul Message Control.

Parameter | Beschreibung
Message Control Benutzer | Aktiv: Der Benutzer wird vom Modul Message Control verwendet.
Telefon | Nummer des Festnetztelefons des Benutzers. Wird für Text-to-Speech verwendet. Eingabe in Ziffern. Ein führendes + als Abkürzung für 00 der internationalen Ländervorwahl ist erlaubt.
Mobiltelefon | Nummer des Mobiltelefons des Benutzers. Wird für Nachrichten über GSM und SMS verwendet. Eingabe in Ziffern, ein führendes + als Abkürzung für 00 der internationalen Ländervorwahl ist erlaubt.
E-Mail | E-Mail Adresse des Benutzers.
Ersatzperson | Auswahl einer Ersatzperson, falls der Benutzer nicht erreicht wird oder die Annahme der Nachricht verweigert. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl.
PIN-Code | PIN-Code, mit dem der Benutzer die Nachricht bestätigt.
NA-Code | PIN-Code, mit dem der Benutzer die Annahme der Nachricht verweigert (not available). Nachricht wird dann an nächsten Benutzer in der Liste gesendet.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

attention Achtung

Die Quittier-Codes für PIN (Bestätigung) und NA (Ablehnung) müssen sich unterscheiden und sollten nicht zu ähnlich gewählt werden.

Sind beide Codes ident, wird der Code als PIN und damit als Bestätigung der Nachricht interpretiert.

Wird ein unbekannter Code empfangen, wird bei SMS und E‑Mail die Nachricht an die Ersatzperson geschickt, bei Sprachnachrichten die Fehlernachricht abgespielt.


Berechtigungsebenen

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen eines Benutzers -> Berechtigungsebenen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Festlegung der Berechtigungsebenen für den Benutzer.

Parameter | Beschreibung
Verfügbare Berechtigungsebenen | Liste aller verfügbarer Berechtigungen
Ausgewählte Berechtigungsebenen | Liste der zugewiesenen Berechtigungen
Schaltfläche Doppelpfeil nach rechts | In der Liste Verfügbare Berechtigungsebenen ausgewählte Einträge werden zur Liste Ausgewählte Berechtigungsebenen hinzugefügt.
Schaltfläche Doppelpfeil nach links | In der Liste Ausgewählte Berechtigungsebenen ausgewählte Einträge werden aus dieser Liste entfernt.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

info Info

Mithilfe von Strg bzw. Umschalt können Sie mehrere Einträge gleichzeitig selektieren.

  • Bei gedrückter Strg-Taste können mehrere einzelne Einträge ausgewählt werden.
  • Wenn Sie Umschalt gedrückt halten und zwei Einträge anklicken, werden alle Einträge ausgewählt, die sich zwischen den beiden Einträgen befinden.
  • Bei gleichzeitigem Drücken und Halten von Strg und Umschalt und Auswählen von zwei Einträgen,werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Benutzergruppen

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen eines Benutzers -> Benutzergruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zuweisung des Benutzers zu Benutzergruppen.

Parameter | Beschreibung
Verfügbare Benutzergruppen | Liste aller verfügbarer Benutzergruppen.
Ausgewählte Benutzergruppe | Liste der zugewiesenen Benutzergruppen.
Schaltfläche Doppelpfeil nach rechts | In der Liste Verfügbare Benutzergruppen ausgewählte Einträge werden zur Liste Ausgewählte Benutzergruppe hinzugefügt.
Schaltfläche Doppelpfeil nach links | In der Liste Ausgewählte Benutzergruppe ausgewählte Einträge werden aus dieser Liste entfernt.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

info Info

Mithilfe von Strg bzw. Umschalt können Sie mehrere Einträge gleichzeitig selektieren.

  • Bei gedrückter Strg-Taste können mehrere einzelne Einträge ausgewählt werden.
  • Wenn Sie Umschalt gedrückt halten und zwei Einträge anklicken, werden alle Einträge ausgewählt, die sich zwischen den beiden Einträgen befinden.
  • Bei gleichzeitigem Drücken und Halten von Strg und Umschalt und Auswählen von zwei Einträgen,werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Anlegen einer Benutzergruppe

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen einer Benutzergruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Benutzergruppe anzulegen:

  1. markieren Sie in der Baumansicht des Projektmanagers unter dem Eintrag Benutzerverwaltung den Eintrag Benutzergruppen
  2. klicken Sie mit der rechten Maustaste in den Bereich Detailansicht (Detailansicht des Projektmanagers) oder direkt auf den Eintrag Benutzergruppen
  3. wählen Sie im Kontextmenü den Befehl Benutzergruppe neu oder klicken Sie alternativ dazu auf das entsprechende Symbol in der Symbolleiste
  4. die Dialogbox Neue Benutzergruppe anlegen wird geöffnet
  5. definieren Sie Namen und Berechtigungsebenen

info Info

In einem Projekt muss jede Benutzergruppe einen eindeutigen Namen haben.

Es ist möglich im Globalprojekt und im lokalen Projekt Benutzergruppen mit gleichen Namen zu erstellen. Ist dies der Fall, werden bei einem Konflikt die Berechtigungen der Benutzergruppe aus dem Standardprojekt herangezogen. Wird die lokale Gruppe gelöscht, erhält der Benutzer nach kompilieren der Runtime-Dateien im Editor wiederum die Rechte aus der Gruppe des Globalprojektes.

Beispiel:

Im lokalen Projekt und im Globalprojekt ist jeweils eine Benutzergruppe A vorhanden. Im Globalprojekt sind ihr die Berechtigungsebenen 1, 2, 3, 100 und 101 zugewiesen, im lokalen Projekt die Berechtigungsebenen 1 und 2. Zur Runtime gelten die Regeln aus dem lokalen Projekt, es werden also nur die Berechtigungsebenen 1 und 2 zugewiesen. Ist im lokalen Projekt keine Benutzergruppe A vorhanden, haben Mitglieder der Gruppe A die Berechtigungsebenen 1, 2, 3, 100 und 101 aus dem Globalprojekt.

Noch in diesem Kapitel

Benutzergruppe benennen

Berechtigungsebenen

Reihenfolge in Message Control


Benutzergruppe benennen

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen einer Benutzergruppe -> Benutzergruppe benennen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Geben Sie den Namen für die Benutzergruppe ein, die Sie neu anlegen möchten.

info Info

Der Gruppenname kann nicht sprachumschaltbar angelegt werden, da er im Active Directory überprüfbar sein muss.

@ ist kein gültiges Zeichen für den Namen einer Benutzergruppe.


Berechtigungsebenen

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen einer Benutzergruppe -> Berechtigungsebenen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zuweisung der Berechtigungsebenen zur einer Benutzergruppe.

Parameter | Beschreibung
Verfügbare Berechtigungsebenen | Liste aller verfügbarer Berechtigungen
Ausgewählte Berechtigungsebenen | Liste der zugewiesenen Berechtigungen
Schaltfläche Doppelpfeil nach rechts | In der Liste Verfügbare Berechtigungsebenen ausgewählte Einträge werden zur Liste Ausgewählte Berechtigungsebenen hinzugefügt.
Schaltfläche Doppelpfeil nach links | In der Liste Ausgewählte Berechtigungsebenen ausgewählte Einträge werden aus dieser Liste entfernt.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

info Info

Mithilfe von Strg bzw. Umschalt können Sie mehrere Einträge gleichzeitig selektieren.

  • Bei gedrückter Strg-Taste können mehrere einzelne Einträge ausgewählt werden.
  • Wenn Sie Umschalt gedrückt halten und zwei Einträge anklicken, werden alle Einträge ausgewählt, die sich zwischen den beiden Einträgen befinden.
  • Bei gleichzeitigem Drücken und Halten von Strg und Umschalt und Auswählen von zwei Einträgen,werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Reihenfolge in Message Control

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Anlegen einer Benutzergruppe -> Reihenfolge in Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Legt die Reihenfolge der Benutzer innerhalb einer Gruppe für die Verwendung im Modul Message Control fest.

Parameter | Beschreibung
Benutzer | Liste aller verfügbarer Benutzer
Nach oben | Reiht ausgewählten Benutzer um eine Position nach oben.
Nach unten | Reiht ausgewählten Benutzer um eine Position nach unten.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.


Ändern eines Benutzers

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Ändern eines Benutzers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Ändern eines Benutzers erfolgt durch Selektion des Benutzers aus der Liste der Detailansicht. Dadurch wird im Eigenschaften-Fenster die betreffenden Parameter angezeigt. Sie können die Parameter Benutzername, Vollständiger Name, Passwort, Berechtigungsebenen und Benutzergruppen ändern.


Änderung einer Benutzergruppe

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Änderung einer Benutzergruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Ändern einer Benutzergruppe erfolgt durch Selektion der Benutzergruppe aus der Liste der Detailansicht. Dadurch wird im Eigenschaften-Fenster die betreffenden Parameter angezeigt. Sie können die Parameter Name, und Berechtigungsebenen ändern.

info Info

Wenn Sie eine Benutzergruppe umbenennen, verlieren alle Benutzer, die mit dieser Benutzergruppe verknüpft waren, diese Verknüpfung. Die Benutzergruppe wird mit (del) angezeigt.

Ist jedoch im Globalprojekt eine Benutzergruppe mit gleichem Namen vorhanden, übernehmen alle Benutzer, die zuvor mit der umbenannten Benutzergruppe verknüpft waren, die Berechtigungsebenen dieser Benutzergruppe.


Namensänderung der Berechtigungsebenen

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Namensänderung der Berechtigungsebenen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Namen der Berechtigungsebenen können Sie global für Ihr Projekt ändern. Dazu gehen Sie bei den Projekteigenschaften zur Gruppe Benutzerverwaltung und klicken dort auf die Eigenschaft Berechtigungsebenen umbenennen.

Interne ID: Namensänderung der Berechtigungsebenen

Berechtigungsebenen umbenennen

Den 128 Berechtigungsebenen kann neben der Nummer ein Name zugewiesen werden. Hier wird der Dialog für die Definition der Namen geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Namensänderung der Berechtigungsebenen

Benutzerverwaltung

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mit einem Doppelklick in die gewünschte Zeile der Spalte Name öffnen Sie das Editierfeld. Nehmen Sie die Änderungen vor. Die Eingabe wird beendet, sobald der Fokus nicht länger im Feld steht bzw. wenn Sie mit Enter bestätigen. Die Namensänderung wird nicht durchgeführt, wenn Sie Esc drücken oder Sie das Editierfeld leer lassen.


Funktionsberechtigungen

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Funktionsberechtigungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Funktionsberechtigungen stellen sicher, dass bestimmte Aktionen zur Runtime nur von dazu berechtigten Benutzern ausgeführt werden können.

Um eine Funktionsberechtigung zu vergeben:

  1. navigieren Sie in den Projekteigenschaften zum Knoten Benutzerverwaltung

    Interne ID: Funktionsberechtigungen

    Benutzerverwaltung

    Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie auf die Eigenschaft Funktionsbererechtigungen

    Interne ID: Funktionsberechtigungen

    Funktionsbererechtigungen

    Bestimmte Systemfunktionen (z.B: Projekt laden) können über die Berechtigungsebenen für unbefugte Benutzer gesperrt werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog zur Konfiguration wird geöffnet
  4. weisen Sie der gewünschten Berechtigung eine Berechtigungseben zu
  5. weisen Sie den berechtigten Benutzern diese Berechtigungseben zu und entziehen Sie allen anderen Benutzern diese Berechtigungsebene

Parameter

Beschreibung

Alarm Kommentar ändern

Ein für die Quittierung nötiger Kommentar darf geändert werden.

Alarm Kommentar eingeben

Ein für die Quittierung nötiger Kommentar darf eingegeben werden.

Alarm löschen

Alarme dürfen zur Runtime gelöscht werden.

Alarm quit.über Alarmstatuszeile/Kontextmenü

Quittieren des Alarms über die Alarmstatuszeile oder das Kontextmenü ist nur möglich, wenn die Berechtigung in dem Projekt zum aktuell angezeigten Alarm vorhanden ist.

Bei Mehrprojektverwaltung: Quittieren der Systemmeldung in der Alarmstatuszeile oder über das Kontextmenü ist nur möglich, wenn die Berechtigung im I-Projekt vorhanden ist.

Anmerkung: Systemmeldungen sind jene Meldungen, die beim Erreichen einer einstellbaren Alarmanzahl in der Alarmstatuszeile ausgegeben werden.

Alarm quit. über Bilder vom Typ Alarmmeldeliste

Quittieren über ein Bild vom Typ ALarmmeldeliste ist nur mit der Berechtigung in dem mit der Variablen verknüpften Projekt möglich (Mehrprojektverwaltung).
Hinweis: Wenn die Berechtigung fehlt, wird zwar das Blinken abgestellt, aber der Alarm nicht quittiert.

Alarm quittieren über Funktion

Das Quittieren über eine Funktion ist nur möglich, wenn die Berechtigung zu den ausgewählten Alarmen in den jeweiligen Projekten vorhanden ist.

Änderungshistorie ein/ausschalten

Die Änderungshistorie kann im Editor nur ein/ausgeschalten werden, wenn der eingeloggte Benutzer über die entsprechende Berechtigungsgruppe verfügt.

Archiv editieren

Archivdaten (Archiv Server) können zur Runtime gändert werden.

Bearbeiten Erweiterter Trend

Kurven im Erweiterten Trend können zur Runtime bearbeitet werden. Bei fehlender Berechtigung sind folgende Kotrollelemente nicht aktiviert:

  • Diagramm
  • Kurven
  • Rahmen
  • activate
  • axis

Bild zurück (PGUP)

Bild zurück- Funktion können in der Runtime ausgeführt werden.

Bildkatalog

Die Funktion Bildumschaltung (Bild - Funktionen) mit gesetzter Option diesen Dialog zur Runtime anbieten kann nur ausgeführt werden, wenn der eingeloggte Benutzer über die entsprechende Berechtigungsgruppe verfügt.

Notizbuch: Datei öffnen

Die Funktion Datei öffnen im Bild Typ Notizbuch kann nur ausgeführt werden, wenn der eingeloggte Benutzer über die entsprechende Berechtigungsgruppe verfügt.

Notizbuch: Datei speichern

Die Funktion speichern im Bild Typ Notizbuch kann nur ausgeführt werden, wenn der eingeloggte Benutzer über die entsprechende Berechtigungsgruppe verfügt.

Projekt laden

Die Projektdatenbank kann im Editor nur geladen werden, wenn der eingeloggte Benutzer über die entsprechende Berechtigungsgruppe verfügt.

Für alle Aktionen muss der Benutzer angemeldet sein und über die entsprechende Berechtigungseben verfügen.

info Info

Das Quittieren eines Alarms ist nur möglich, wenn die Berechtigung zu den ausgewählten Alarmen in den jeweiligen Projekten vorhanden ist.

Sie können für jede dieser Quittiermethoden unterschiedliche Berechtigungsgruppen einstellen. Damit können Sie z.B. festlegen, dass eine Benutzergruppe nur über die Alarmstatuszeile quittieren kann und nicht anders.


Bild vom Typ Login anlegen

Handbuch -> Benutzerverwaltung -> Projektieren im Editor -> Bild vom Typ Login anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bedienung durch unterschiedliche Benutzer wird während der Runtime über ein Bild vom Typ Login ermöglicht. Dieses Bild muss zunächst im Editor angelegt werden.

Nähere Informationen zu den vordefinierten Bildtypen finden Sie im 'Bilder / Vordefinierte Bildtypen'.)

Nach dem Öffnen des Bildes wird ein leeres Bild aufgeschaltet. Die Standard-Kontrollelemente können Sie über das Menü Kontrollelemente -> Vorlage einfügen erstellen.


Active Directory (AD)

Handbuch -> Benutzerverwaltung -> Active Directory (AD)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Active Directory kann in zenon zur Benutzerverwaltung in der zenon Runtime verwendet werden. Für den zenon Editor steht AD nicht zur Verfügung.

Das Active Directory kann auf drei Arten von zenon genutzt werden:

  1. Der Name der Berechtigungsgruppe in der zenon Benutzerverwaltung stimmt mit dem Gruppennamen einer Benutzergruppe im Active Directory überein: Automatische Zuordnung der Active Directory Benutzer zu der zenon Berechtigungsgruppe. Alle Benutzer der AD Gruppe erhalten die Benutzerrechte, die in der zenon Berechtigungsgruppe definiert sind. Siehe Benutzergruppen in zenon und Gruppen im Active Directory haben den selben Namen
  2. In der Beschreibung der Active Directory Gruppe werden die zenon Berechtigungsebenen und das Projekt in einer eine bestimmte Syntax hinterlegt. Alle Benutzer der Gruppe enthalten in zenon die in der AD Gruppe hinterlegten Benutzerrechte. Siehe Zuordnung eines Active Directory Benutzers zu zenon Berechtigungsebenen
  3. Das Active Directory Schema wird um Felder erweitert, in denen die zenon Berechtigungsebenen abgespeichert werden. Das erfordert eine Schema Erweiterung des Active Directorys . Diese eignet sich allerdings nicht für den Einsatz im FDA 21 CFR Part11 reglementierten Umfeld. Siehe: Schema-Erweiterung des Active Directory.

info Info

Bei der Passwortprüfung in zenon wird auch Max. password age aus dem Active Directory geprüft.

info Info

Active Directory und ADAM/AD LDS stehen unter Windows CE nicht zur Verfügung.

Noch in diesem Kapitel

Allgemeines

Gleiche Benutzergruppen in zenon und im Active Directory

Setzen der zenon Berechtigungsebenen im Beschreibungsfeld einer Active Directory Gruppe

Schema-Erweiterung des Active Directory


Allgemeines

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Allgemeines

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um in zenon die Benutzer aus dem ActiveDirectory (in Folge: AD genannt) verwenden zu können ist eine Domäne auf Basis eines Windows Server Betriebssystems die Grundvoraussetzung. Um Benutzer im ActiveDirectory verwalten zu können, muss der Server ein DNS Server sein.

Es muss also ein Domaincontroller mit DNS und ActiveDirectory zur Verfügung stehen um diese Benutzerkonten dann auch auf einem PC in der Domäne als Benutzer in zenon verwenden zu können.

Der Zugriff auf die Benutzer des ActiveDirectory muss in den Eigenschaften des Projekts aktiviert werden.

Grundlegendes Wissen über das ActiveDirectory und Windows Server - Technologie wird vorausgesetzt.

attention Achtung

Wenn die Anmeldung über Active Directory erfolgt, müssen ausnahmslos alle Rechner auf Active Directory Zugriff haben. Das gilt auch für Clients und Webclients!

Hintergrund: Die Anmeldung eines Clients erfolgt direkt vom Client zum Active Directory. Der zenon Runtime-Server ist daran nicht beteiligt.
Ein Active Directory Benutzer kann also nur angemeldet werden, wenn ein Client:

  • Mitglied der Domäne ist
    und
  • Zugriff hat auf die Domäne hat


Gleiche Benutzergruppen in zenon und im Active Directory

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Gleiche Benutzergruppen in zenon und im Active Directory

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für Benutzer in zenon und im Active Directory gilt:

  • Existiert ein benutzer im AD, aber nicht in zenon, dann:
    • werden die Benutzergruppen in zenon überprüft
    • die Berechtigungsebenen der Gruppen, denen der Benutzer angehört, werden dem AD Benutzer zugewiesen
  • Existiert ein Benutzer sowohl im AD und in zenon und der Benutzer loggt sich in die Runtime ein, dann:
    • hat der lokale zenon Benutzer Vorrang vor dem AD Benutzer
    • werden in AD keine Berechtigungsebenen überprüft, da der lokale Benutzer eingeloggt ist


Setzen der zenon Berechtigungsebenen im Beschreibungsfeld einer Active Directory Gruppe

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Setzen der zenon Berechtigungsebenen im Beschreibungsfeld einer Active Directory Gruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Windows Benutzer aus dem Active Directory können in zenon verwendet werden.

Einzelne Benutzer können im Active Directory Gruppen zugewiesen werden. Die Namen der Gruppen müssen wie in folgender Syntax beschrieben lauten:

zenon Projektname##freier Text

In ihrer Beschreibung wird die Berechtigung des Benutzers mit folgender Syntax hinterlegt:

freier Text ##GRP=HEX-Zahl## freier Text

info Info

Die Groß-/Kleinschreibung spielt beim Gruppennamen und der Gruppenbeschreibung keine Rolle.

Um eine bessere Lesbarkeit zu gewährleisten, wird die HEX-Zahl in vier Teile (je ein Teil für jede Berechtigungsgruppe) geteilt, die jeweils mit einem Bindestrich unterteilt werden.

Aufbau der Hex-Zahl
FFFFFFFF | FFFFFFFF | FFFFFFFF | FFFFFFFF
Berechtigungseben 1 | Berechtigungseben 2 | Berechtigungsene 3 | Berechtigungseben 4

Example Beispiel

Gruppenname: MASCHINE01##Servicepersonal

Gruppenbeschreibung: freier Text##GRP=FFFFFFFF-FFFFFFFF-FFFFFFFF-FFFFFFFF##freier Text

Die Benutzer, die der Gruppe MASCHINE01##Servicepersonal zugeordnet sind, erhalten in zenon die Berechtigungsebenen 0 - 127.

Es ist nicht nötig alle 32 Stellen anzugeben. Nicht vorhandene Stellen werden als 0 interpretiert.

Example Beispiel

Gruppenbeschreibung: freier Text##GRP=7##freier Text

Benutzer, die der Gruppe mit dieser Beschreibung zugeordnet sind, erhalten in zenon die Berechtigungsebenen 0, 1 und 2.

7 hexadezimal entspricht in binärer Darstellung 111. Für jede 1 in der Binärzahl, wird die entsprechende Berechtigungsebene gesetzt. Das rechteste Bit steht für die Berechtigungsebene 0. Das Bit links daneben steht für die Berechtigungsebene 1 usw.

Eine Benutzer kann auch mehrere Gruppen zugehörig sein. Er erhält dann die Summe der Berechtigungsebenen der einzelnen Gruppen.

Wird ein Benutzer in zenon eingeloggt, wird erst überprüft, ob der Benutzer lokal in zenon vorhanden ist. Wenn nicht, wird nach dem Benutzer im Active Directory gesucht. Existiert der Benutzer dort auch nicht, wird der Benutzer nicht eingeloggt und ein entsprechender Eintrag in der CEL angelegt. Falls der Benutzer im AD vorhanden ist, jedoch keine Berechtigungsebenen in zenon für diesen Benutzer definiert sind, wird folgender Eintrag in der CEL angelegt: 'Keine Benutzerrechte für den Benutzer im AD definiert'. Der Benutzer wird mit Level 0 eingeloggt.


Schema-Erweiterung des Active Directory

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hinweis: Diese Erweiterung sollte nicht im FDA 21 CFR Part11 reglementierten Umfeld eingesetzt werden. Nutzen Sie für FDA 21 CFR Part11 kompatible Benutzerverwaltung entweder die Methode Benutzergruppen in zenon und Gruppen im Active Directory oder Zuordnung eines Active Directory Benutzers zu zenon Berechtigungsebenen.

info Info

Active Directory und ADAM/AD LDS stehen unter Windows CE nicht zur Verfügung.

Noch in diesem Kapitel

Installieren der Schema Erweiterung

Zuweisen von Benutzerrechten

Schema Erweiterung - Details


Installieren der Schema Erweiterung

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory -> Installieren der Schema Erweiterung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit den Benutzern im AD auch die 128 Berechtigungsebenen von zenon zugewiesen werden können, muss das AD-Schema um diese Einträge (4 Integerwerte) ergänzt werden.

Dazu werden 2 Dateien (zenonUserLevel.exe, zAD_UserDlg.exe) auf den Server kopiert (am besten in ein eigenes Verzeichnis). Sobald das Setup (zenonUserLevel.exe) gestartet wurde, darf dieser Ordner und die enthaltenen Dateien nicht mehr umbenannt oder gelöscht werden.

attention Achtung

Die beiden Dateien zenonUserLevel.exe und zAD_UserDlg.exe finden Sie auf der zenon DVD im Ordner /Software/zenonUserLevel/

Es wird vom Setup ein Verweis auf die Datei zAD_UserDlg.exe im AD-Schema hinterlegt.

Weiters werden 4 Integerwerte (zenonUserLevel1, zenonUserLevel2, zenonUserLevel3, zenonUserLevel4) dem AD-Schema hinzugefügt.

info Info

Nur ein Benutzer der Gruppe Schema Administratoren darf diese Änderungen durchführen! Der Domain-Administrator hat im Normalfall diese Rechte.


Zuweisen von Benutzerrechten

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory -> Zuweisen von Benutzerrechten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach der erfolgreichen Schema Erweiterung können nun den einzelnen Benutzern die Berechtigungsebenen zugewiesen werden.

Dazu wird die Microsoft Management Konsole (MMC) mit dem Plug-in Active Directory Users and Computers geöffnet.

Durch anklicken des gewünschten Benutzers mit der rechten Maustaste öffnet sich ein Kontextmenü. Im Kontextmenü wird ein neuer Menüpunkt sichtbar: zenonUserLevel.

In diesem Kontextmenü muss der Menüpunkt zenonUserLevel ausgewählt werden, damit sich das AdministrationsTool (zAD_UserDlg.exe) für den gewählten Benutzer öffnet.

info Info

Es können die Berechtigungsgruppen für zenonnur direkt beim Benutzer hinterlegt werden, Gruppen und Organisationseinheiten werden nicht unterstützt.

Mit Hilfe dieses Administrationstools können für jeden Benutzer bis zu 128 Berechtigungsebenen definiert werden.

info Info

Die Berechtigungsebene 0 ist per Default jedem Benutzer zugewiesen, diese kann mit dem Administrationstool auch nicht deaktiviert werden.

Diese Ebene entspricht dem Benutzer SYSTEM von zenon.

Noch in diesem Kapitel

Beschreibung des AdministrationsTools


Beschreibung des AdministrationsTools

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory -> Zuweisen von Benutzerrechten -> Beschreibung des AdministrationsTools

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
[erste Zeile] | LDAP-Parameter, der als Connectionstring dient.
Last Name | Nachname des selektieren Benutzers.
First Name | Vorname des selektieren Benutzers.
User Level | 4 Integerwerte repräsentieren je 32 Berechtigungsebenen. Eingabe durch aktivieren bzw. deaktivieren der Checkboxen oder direkte Eingabe in Feld.
# | Aktualisiert Darstellung der Berechtigungsebenen.
Select | Aktiviert alle Checkboxen in einer Spalte.
Clear | Deaktiviert alle Checkboxen in einer Spalte.
Save | Speicher aktuelle Einstellungen.
Cancel | Verwirft alle Einstellungen seit letztem Speichern und schließt Dialog.
OK | Speichert alle Einstellungen und schließt Dialog.
Logging | Zeigt Logginginformationen an.


Schema Erweiterung - Details

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory -> Schema Erweiterung - Details

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Hintergründe etwas zu verdeutlichen, werden hier die Schema Erweiterungen im Detail erklärt, damit diese bei Problemen auch kontrolliert bzw. überprüft werden können.

Damit die Details des AD-Schema betrachtet werden können, muss ADSI Edit auf dem Server installiert sein. Dieses Tool steht zur Verfügung, sobald die Support Tools von der Microsoft Server CD installiert worden sind.

Zu finden auf der CD unter: CD_ROOT/SUPPORT/TOOLS/SUPTOOLS.msi

Das ADSI Edit Plug-in kann dann in der Microsoft Management Konsole (MMC) geöffnet werden. Danach können verschiedene Verbindungen hergestellt werden.

Noch in diesem Kapitel

Schema

Configuration

Domain


Schema

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory -> Schema Erweiterung - Details -> Schema

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Schema können die zusätzlichen Attribute kontrolliert werden. Diese sind im Normalfall ganz unten aufgelistet.

zenonUserLevel1 - zenonUserLevel4


Configuration

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory -> Schema Erweiterung - Details -> Configuration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn die Verbindung auf Configuration eingerichtet wurde, können Details der einzelnen AD Objekte begutachtet und geändert werden. In diesem Fall ist jedoch nur das Objekt user-Display in den einzelnen DisplaySpecifiers von Interesse, da hier die Verknüpfung zwischen Benutzerobjekt und Administrationstool hergestellt wird.

Die Eigenschaften des Objektes user-Display enthalten ein Attribut mit dem Namen adminContextMenu.

Dieses Attribut beinhaltet die Verknüpfung zum Administrationstool (zAD_UserDlg.exe).

Man kann diesen Eintrag auch per Hand ändern, wenn dies notwendig sein sollte.

Dazu:

  1. Eintrag auswählen
  2. Schaltfläche Remove drücken
  3. den Parameter anpassen
  4. mit Add wieder hinzufügen

Der Parameter setzt sich wie folgt zusammen:

,Bezeichnung des Menüeintrages,Pfad zur zAD_UserDlg.exe Datei

Example Beispiel

Beispiel, wenn die EXE Datei im Verzeichnis D:/AD_Users hinterlegt ist.

,&zenonUserLevel,D:/AD_Users/zAD_UserDlg.exe


Domain

Handbuch -> Benutzerverwaltung -> Active Directory (AD) -> Schema-Erweiterung des Active Directory -> Schema Erweiterung - Details -> Domain

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn die Verbindung Domain geöffnet wird, sieht man auf den ersten Blick parallelen zur MMC mit dem Plug-in Active Directory Users and Computers. Genau diese Information kann man auch hier wieder finden, jedoch etwas detaillierter.

Untersucht man beispielsweise die Eigenschaften eines Benutzer Objekts und scrollt dabei in der Liste ganz nach unten, findet man auch hier wieder die 4 Integerwerte für die Berechtigungsebenen.


Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista)

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Active Directory Lightweight Directory Services (kurz: AD LDS) ist eine vereinfachte Version des Active Directory und eignet sich für den Einsatz auf normalen Desktop-Betriebssystemen, es muss also kein Server-Betriebssystem eingesetzt werden. Wie AD unterstützt auch AD LDS:

  1. Der Name der Berechtigungsgruppe in der zenon Benutzerverwaltung stimmt mit dem Gruppennamen einer Benutzergruppe im Active Directory überein: Automatische Zuordnung der Active Directory Benutzer zu der zenon Berechtigungsgruppe. Alle Benutzer der AD Gruppe erhalten die Benutzerrechte, die in der zenon Berechtigungsgruppe definiert sind. Siehe Benutzergruppen in zenon und Gruppen im Active Directory haben den selben Namen
  2. In der Beschreibung der Active Directory Gruppe werden die zenon Berechtigungsebenen und das Projekt in einer eine bestimmte Syntax hinterlegt. Alle Benutzer der Gruppe enthalten in zenon die in der AD Gruppe hinterlegten Benutzerrechte. Siehe Zuordnung eines Active Directory Benutzers zu zenon Berechtigungsebenen

AD LDS können Sie verwenden unter:

  • Windows Vista
  • Windows 7
  • Windows Server 2008

Für Windows XP benutzen Sie ADAM.

In dieser Anleitung wird die Installation und Konfiguration unter Windows Server 2008 erklärt. Die Nutzung unter Windows Vista und Windows erfolgt analog. Details dazu siehe Kapitel AD LDS unter Windows 7 und Windows Vista.

Noch in diesem Kapitel

AD LDS unter Windows 2008

Neue AD LDS Instanz erstellen

AD LDS Schema importieren

AD Schema Snap-in konfigurieren

Organisationseinheiten, Gruppen und Benutzer konfigurieren

Verwendung in zenon

AD LDS unter Windows 7 und Windows Vista


AD LDS unter Windows 2008

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> AD LDS unter Windows 2008

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die AD LDS Server Role zu installieren:

  1. wählen Sie in den Administrative Tools Server Manager

  2. klicken Sie auf Add Roles

  3. fügen Sie die AD LDS Role hinzu


Neue AD LDS Instanz erstellen

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Neue AD LDS Instanz erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine neue AD LDS Instanz zu erstellen:

  1. Rufen Sie im Active Directory Lightweight Directory Services Control Panel den AD LDS Setup Wizard auf.

  2. Starten Sie den Wizard:

  3. Wählen Sie die Option A unique instance.

  4. Vergeben Sie einen Namen für die Instanz.

  5. Konfigurieren Sie die Ports. Default:
    • LDAP: 389
    • SSL: 636

    Hinweis: Wenn Sie hier den voreingestellten Port ändern, müssen Sie auch in einigen der folgenden Einstellungen den Port anpassen.

  6. Spezifizieren Sie den Partition Name.

    In unserem Beispiel: o=zenon,c=com

    Der Partition Name wird zusammen mit dem Port und dem Servernamen später in zenon benutzt.

    Diese Konfiguration in zenon kann später erfolgen. Fahren Sie mit der Konfiguration im Wizard fort.

  7. Definieren Sie den Speicherort.
    Die Einstellung kann auf der Default-Einstellung belassen werden.

  8. Definieren Sie den Service Account für AD LDS.

    In unserem Beispiel: Network service account

    Falls der Computer, auf dem AD LDS installiert wird, kein Mitglied einer Domäne ist, erhalten Sie eine Warnmeldung:

    Das beeinträchtigt die Funktionalität von AD LDS nicht. Ausnahme: Sie verwenden die Funktion Replication.

    Bestätigen Sie die Warnung mit einem Klick auf die Schaltfläche Yes.

  9. Definieren Sie den Benutzer, der Administratorechte erhält.

    In unserem Beispiel verwenden wir Currently logged on user. In unserem Fall ein lokaler Benutzer mit Administratorrechten.

    Der Benutzer und sein Passwort werden später in zenon verwendet.

    Diese Konfiguration kann später erfolgen. Fahren Sie mit der Konfiguration im Wizard fort.

  10. Importieren Sie die benötigten LDIF-Dateien:
    • MS-InetOrgPerson.LDF
    • MS-User.LDF
    • MS-UserProxy.LDF

  11. Beenden Sie die Installation


AD LDS Schema importieren

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> AD LDS Schema importieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zum Import der AD LDS Schemata:

  1. Navigieren Sie im Windows Explorer zum Ordner %WINDIR%\ADAM.
  2. Wählen Sie im Kontextmenü [Taste Umschalt+rechter Mausklick]: Eingabeaufforderung hier öffnen.

  3. Geben Sie folgende Zeichenfolge ein:

    ldifde -i -s localhost -c CN=Configuration,DC=X #ConfigurationNamingContext -f MS-AdamSchemaW2k8.ldf

  4. Drücken Sie die Eingabetaste:

  5. Geben Sie folgende Zeichenfolge ein:

    ldifde -i -s localhost:389 -c CN=Configuration,DC=X #ConfigurationNamingContext -f MS-AdamSyncMetadata.ldf

    Hinweis: Falls Sie einen Port geändert haben, muss dieser hier angepasst werden.

  6. Drücken Sie die Eingabetaste:


AD Schema Snap-in konfigurieren

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> AD Schema Snap-in konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um das Schema Snap-in zu konfigurieren, registrieren Sie es zuerst über die Eingabeaufforderung (Administratorrechte nötig):

  1. klicken Sie auf die Schaltfläche Start
  2. navigieren Sie zur Eingabeaufforderung
  3. wählen Sie im Kontextmenü Als Administrator ausführen
  4. geben Sie in der Eingabeaufforderung ein: regsvr32 schmmgmt.dll
  5. bestätigen Sie mit Druck auf die Taste Eingabe

Konfiguration

  1. klicken Sie auf die Schaltfläche Start
  2. öffnen Sie Ausführen
  3. geben Sie ein: mmc /a

  4. klicken Sie auf File -> Add/Remove Snap-in...

  5. wählen Sie Active Directory Schema
  6. klicken Sie auf Add
  7. klicken Sie auf OK

  8. navigieren Sie zu Active Directory Schema
  9. wählen Sie im Kontextmenü Change Active Directory Domain Controller...

  10. Geben Sie Server und Port ein (in diesem Beispiel: localhost:389)

  11. Sie sollten jetzt dieses Fenster sehen:

  12. navigieren Sie zu Classes -> organization
  13. öffnen Sie Properties

  14. klicken Sie auf Add
    1. suchen Sie nach maxPwdAge
    2. klicken Sie auf OK

    1. wiederholen Sie diesen Schritt für lockoutDuration

    1. und für lockoutThreshold

  15. klicken Sie auf OK

Diese Schritte sind unbedingt nötig, um das maxPwdAge in der Organisationseinheit zur Verfügung zu haben, die im Anschluss konfiguriert wird.

  • maxPwdAge definiert die maximale Zeitspanne, nach der ein benutzer ein Passwort ändern muss.
  • lockoutDuration definiert den Zeitraum, für den ein Benutzer gesperrt wird, nachdem er sein Passwort mehrmals falsch eingegeben hat.
  • lockoutThreshold definiert die Anzahl der möglichen Fehlversuche, bevor ein Benutzer für einen bestimmten Zeitraum gesperrt wird.

In den lokalen Sicherheitsrichtlinien des Computers legen Sie die Regeln fest für:

  • password complexity
  • minimum password length
  • age


Organisationseinheiten, Gruppen und Benutzer konfigurieren

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Organisationseinheiten, Gruppen und Benutzer konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Konfiguration von Organisationseinheiten, Gruppen und Benutzern:

  1. öffnen Sie Start -> Administrative Tools -> ADSI Edit

  2. wählen Sie im Kontextmenü Connect to...
  3. benutzen Sie folgende Einstellungen (ändern, falls andere Einstellungen zuvor konfiguriert wurden):
    1. Connection Point: o=zenon,c=com
    2. Computer: localhost:389

    Sie sollten jetzt folgende Konfiguration sehen:

maxPwdAge konfigurieren

  1. markieren Sie O=zenon,c=com
  2. klicken Sie auf Refresh
  3. schließen Sie ADSI Edit
  4. öffnen Sie ADSI Edit erneut
  5. markieren Sie O=zenon,c=com
  6. wählen Sie im Kontextmenü Properties

  7. navigieren Sie zu maxPwdAge
    1. geben Sie einen gültigen Wert ein
    2. Format: DD:HH:MM:SS (in unserem Beispiel 10:00:00:00)

    Hinweis: Falls die Eigenschaft maxPwdAge nicht sichtbar ist, überprüfen Sie, ob sie korrekt hinzugefügt worden ist. Eventuell beseitigt auch ein Refresh oder das Schließen und Öffnen von ADSI Edit oder ein Neuladen des Schemas das Problem.

  8. navigieren Sie zu lockoutDuration
    1. geben Sie einen gültigen Wert ein
    2. Format: DD:HH:MM:SS (in unserem Beispiel 00:00:10:00, -> 10 Minuten)

  9. navigieren Sie zu lockoutThreshold

  10. geben Sie den gleichen Wert ein, wie in den lokalen Sicherheitsrichtlinien (z. B. 3)

Hinweis: Die Einstellungen für die Dauer der Accountsperre werden in AD LDS ignoriert. Es wird die Eigenschaft lockoutDuration (O=zenon,c=com) verwendet .

Noch in diesem Kapitel

Organisationseinheiten

Gruppen

Benutzer


Organisationseinheiten

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Organisationseinheiten, Gruppen und Benutzer konfigurieren -> Organisationseinheiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Organisationseinheit zu erstellen:

  1. markieren Sie O=zenon,c=com
  2. wählen Sie im Kontextmenü New -> Object

  3. wählen Sie organizationalUnit

  4. geben Sie einen Namen ein (in unserem Beispiel: zenon users OU)

  5. klicken Sie auf Next und dann auf Finish


Gruppen

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Organisationseinheiten, Gruppen und Benutzer konfigurieren -> Gruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Gruppe zu erstellen:

  1. markieren Sie die Organisationseinheit
  2. wählen Sie im Kontextmenü New -> Object

  3. wählen Sie group

  4. geben Sie einen Namen ein (in unserem Beispiel: zenon user group)

  5. klicken Sie auf Next
  6. wechseln Sie zur Registerkarte Attributes
  7. klicken Sie auf More Attributes
    1. navigieren Sie zur Eigenschaft Select a property to view
    2. wählen Sie in der Dropdownliste groupAttributes
    3. navigieren Sie zu Edit Attribute
    4. geben Sie den Wert 2147483650 ein (repräsentiert eine account group)

  8. klicken Sie auf Set
  9. wählen Sie bei der Eigenschaft Select a property to view jetzt sAMAccountName
  10. geben Sie den gleichen Wert wie für die Gruppe ein (zenon user group)

    Hinweis: Diese Einstellung ist nötig, damit die Benutzergruppen in zenon konfiguriert werden können

  11. Klicken Sie auf OK und dann auf Finish


Benutzer

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Organisationseinheiten, Gruppen und Benutzer konfigurieren -> Benutzer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Benutzer zu erstellen:

  1. markieren Sie die Organisationseinheit
  2. wählen Sie im Kontextmenü New -> Object

  3. wählen Sie die Klasse user

  4. geben Sie einen Namen ein (in unserem Beispiel: zenon1)

  5. klicken Sie auf Next
  6. wechseln Sie zur Registerkarte Attributes
  7. klicken Sie auf More Attributes
    1. navigieren Sie zur Eigenschaft Select a property to view
    2. wählen Sie in der Dropdownliste sAMAccountName
    3. navigieren Sie zu Edit Attribute
    4. geben Sie den gleichen Wert ein wie für den Benutzer (zenon1)ein
      (Diese Konfoguration ist nötig, damit der benutzer in zenon genutzt werden kann.)

  8. klicken Sie auf Set
  9. wählen Sie bei der Eigenschaft Select a property to view jetzt displayName
  10. geben Sie einen Wert für die Anzeige des namens ein, z. B. 1st zenon user

  11. klicken Sie auf Set, dann auf OK und auf Finish

Benutzer zur Gruppe hinzufügen

Um Benutzer zu einer Gruppe hinzuzufügen:

  1. wählen Sie zenon user group
  2. wählen Sie im Kontextmenü Properties

  3. markieren Sie member
  4. klicken Sie auf Edit

  5. um den zuvor erstellten AD LDS Account (user) hinzuzufügen:
    1. klicken Sie auf Add DN...
    2. geben Sie in die Eingabemaske ein: CN=zenon1,OU=zenon users OU,O=zenon,C=com

    1. Sie erhalten als Ergebnis:

  6. definieren Sie ein Passwort für den Benutzer zenon1

    Hinweis: Das Passwort muss die Anforderungen der lokalen Sicherheitsrichtlinien erfüllen

  7. setzen Sie für den Benutzer zenon1 die Eigenschaften set msDS-UserAccountDisabled auf False

Der Benutzer ist jetzt angelegt und kann in zenon verwendet werden.


Verwendung in zenon

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Verwendung in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Verwendung in zenon konfigurieren Sie erst die Einstellungen im Editor und setzen dann die Benutzerkennung auf AD LDS Ebene zur Runtime ein.

info Info

Active Directory und ADAM/AD LDS stehen unter Windows CE nicht zur Verfügung.

Noch in diesem Kapitel

Editor

Runtime - Systemtreibervariablen


Editor

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Verwendung in zenon -> Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration erfolgt in den Projekteigenschaften im Abschnitt Benutzerverwaltung:

Interne ID: Editor

Benutzerverwaltung

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Eine Benutzergruppe mit dem Namen zenon user group wurde erstellt

  • und Berechtigungsebenen wurden hinzugefügt


Runtime - Systemtreibervariablen

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> Verwendung in zenon -> Runtime - Systemtreibervariablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Der Benutzer zenon1 kann sich in zenon einloggen:

  • Der Benutzer erhält seine Berechtigungsebenen von der zenon Gruppe:

  • Die restlichen Tage, bis das Passwort geändert werden muss, werden angezeigt (mit einem Tag Unterschied):

Fehlerbehandlung

Treten zur Runtime Fehler auf, überprüfen Sie ob:

  • die Einstellungen korrekt gesetzt wurden:
    • Benutzername
    • sAMAccountName
  • die Firewall-Einstellungen korrekt gesetzt wurden
  • die Editor-Konfiguration korrekt ist für:
    • Verbindung
    • Passwort

Falls der Benutzer keine Berechtigungsebenen von der zenon group bekommt, überprüfen Sie ob:

  • die Namen übereinstimmen
  • sAMAccountName der Gruppe in AD LDS gesetzt wurde
  • der Benutzer in AD LDS zur Gruppe hinzugefügt wurde

AD/ADAM

Wenn Bedienberechtigungen aus der Benutzergruppe in AD/ADAM kommen sollen, muss in AD LDS:

  • bei der Gruppe die Eigenschaft description angepasst werden
  • die Gruppe genau so wie das Projekt benannt werden

Weitere Informationen zur Konfiguration finden Sie im Abschnitt Setzen der zenon Berechtigungsebenen im Beschreibungsfeld einer Active Directory Gruppe.


AD LDS unter Windows 7 und Windows Vista

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> AD LDS unter Windows 7 und Windows Vista

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

AD LDS kann auch unter Windows Vista und Windows 7 verwendet werden. Die Setups dafür erhalten Sie auf der Microsoft Website.

Nach der Installation erfolgt die Konfiguration über Systemsteuerung -> Verwaltung analog zur Beschreibung für Windows Server 2008.

Noch in diesem Kapitel

Problembehandlung unter Windows 7 und Windows Vista


Problembehandlung unter Windows 7 und Windows Vista

Handbuch -> Benutzerverwaltung -> Active Directory Lightweight Directory Services - AD LDS (ab Windows Vista) -> AD LDS unter Windows 7 und Windows Vista -> Problembehandlung unter Windows 7 und Windows Vista

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Werden nach dem Öffnen des Active Directory Schema Snap-ins keine Inhalte angezeigt, müssen die Zugriffsrechte angepasst werden. Dazu:

  1. wählen Sie im Kontextmenü Permissions...

  2. ordnen Sie den nötigen Benutzern die entsprechenden Rechte zu
    (neue Benutzer fügen Sie über Klick auf Add hinzu)

  3. klicken Sie auf die Schaltfläche Advanced

  4. klicken Sie auf die Schaltfläche Advanced
  5. öffnen Sie die Registerkarte Permissions
  6. aktivieren Sie die Option Apply to This object and all descedant objects für den jeweiligen Benutzer aus

  7. schließen Sie die Konsole und öffnen Sie diese erneut (mmc /a) für die weitere Konfiguration


Active Directory Application Mode - ADAM (für Windows XP)

Handbuch -> Benutzerverwaltung -> Active Directory Application Mode - ADAM (für Windows XP)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Active Directory Application Mode (ADAM) ist für den Einsatz unter Windows XP gedacht.

Für

  • Windows Vista
  • Windows 7
  • Windows Server 2008

verwenden Sie Active Directory Lightweight Directory Services

Voraussetzungen

Um Active Directory Application Mode für zenon verwenden zu können, müssen Sie bei der Konfiguration von ADAM folgende Punkte berücksichtigen.

  1. Erstellen Sie eine neue ADAM Instanz
  2. Spielen Sie ein AD Schema ein
  3. Um dem ADAM Benutzer den Zugriff zu ermöglichen, klicken Sie Programme -> Verwaltung -> Lokale Sicherheitsrichtlinien. Im sich öffnenden Dialog klicken Sie Sicherheitseinstellungen-> Kontorichtlinien. Hier legen Sie die gewünschten Einstellungen für Kennwortrichtlinien und Kontosperrungsrichtlinien fest.
  4. Konfigurieren Sie das ADAM Schema Snap-In.
  5. Im Snap-In führen Sie unter Klassen -> Organisation einen Rechtsklick aus und selektieren Eigenschaften. Dann geben Sie in der Registerkarte Attribute als optionales Attribut maxPwdAge ein. Dadurch stellen Sie sicher, dass die Kennwortüberprüfung und Kennwortänderung anlaog zum Active Directory funktioniert.

    Hinweis: Sie müssen die Gültigkeitsdauer des Passworts in Nanosekunden angeben.

  6. Legen Sie in ADAM Benutzer und Benutzergruppe an. Beachten Sie dabei folgende Punkt:
    • Beim Benutzer und bei der Benutzergruppe müssen Sie unter Eigenschaft -> Attribut-Editor beim Attribut sAMAccountName nochmals den Namen manuell eintagen.
    • Bei der Benutzergruppe müssen Sie den Namen wie unter Nutzung des Active Directory beschrieben eingeben.
    • Die zenon Berechtigungsebenen legen Sie wie unter Nutzung des Active Directory beschrieben unter dem Attribut description an.

info Info

Um den Benutzernamen mithilfe der Systemtreibervariable anzuzeigen, müssen Sie in ADAM beim Benutzer unter Eigenschaften -> Attribut-Editor beim Attribut displayName den Benutzernamen manuell setzen.

Noch in diesem Kapitel

Neue ADAM-Instanz erstellen

AD-Schema einspielen

ADAM-Schema Snap-in konfigurieren


Neue ADAM-Instanz erstellen

Handbuch -> Benutzerverwaltung -> Active Directory Application Mode - ADAM (für Windows XP) -> Neue ADAM-Instanz erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

So installieren Sie eine ADAM-Instanz mithilfe des Active Directory-Anwendungsmodus-Setup-Assistenten

  • Klicken Sie zum Starten des Active Directory-Anwendungsmodus-Setup-Assistenten auf Start, zeigen Sie auf Alle Programme und dann auf ADAM, und klicken Sie dann auf ADAM-Instanz erstellen.
  • Klicken Sie auf der Seite Willkommen auf Weiter.
  • Auf der Seite Setup-Optionen können Sie wählen, ob Sie eine eindeutige ADAM-Instanz installieren oder einem vorhandenen Konfigurationssatz eine neue Instanz zuordnen möchten. Da Sie die erste ADAM-Instanz installieren, klicken Sie auf Eine eindeutige Instanz installieren. Klicken Sie anschließend auf Weiter.
  • Geben Sie auf der Seite

    Instanzname

    einen Namen für die zu installierende ADAM-Instanz an. Der Name wird auf dem lokalen Computer zur eindeutigen Identifikation der ADAM-Instanz verwendet. Klicken Sie dann auf

    Weiter

    .
  • Geben Sie auf der Seite

    Ports

    die Kommunikationsports an, die von der ADAM-Instanz zur Kommunikation verwendet werden. ADAM kann mithilfe von LDAP (Lightweight Directory Access-Protokoll) oder SSL (Secure Sockets Layer) kommunizieren. Daher müssen Sie für beide Ports einen Wert angeben. Klicken Sie dann auf

    Weiter

    .

info Info

Wird auf dem Computer, auf dem Sie ADAM installieren, einer der Standardports bereits verwendet, wird vom Active Directory-Anwendungsmodus-Setup-Assistenten automatisch nach dem ersten verfügbaren Port gesucht, beginnend mit 50000. Beispielsweise werden von Active Directory die Ports 389 und 636 sowie die Ports 3268 und 3269 auf globalen Katalogservern verwendet. Daher werden beim Installieren von ADAM auf einem Domänencontroller die Standardwerte

50000

für den LDAP-Port und

50001

für den SSL-Port bereitgestellt.
  • Auf der Seite

    Anwendungsverzeichnispartition

    können Sie eine Anwendungsverzeichnispartition (oder einen Namenskontext) erstellen, indem Sie auf

    Ja, eine Anwendungsverzeichnispartition erstellen

    klicken. Wenn Sie stattdessen auf

    Nein, keine Anwendungsverzeichnispartition erstellen

    klicken, müssen Sie nach der Installation manuell eine Anwendungsverzeichnispartition erstellen. Wenn Sie eine Anwendungsverzeichnispartition erstellen, müssen Sie einen definierten Namen für die neue Partition angeben. Klicken Sie dann auf

    Weiter

    .

info Info

ADAM unterstützt definierte Namen im X.500- und im DNS-Stil (Domain Name System) für Verzeichnispartitionen der obersten Ebene.
  • Auf der Seite

    Dateipfade

    können Sie die Installationsverzeichnisse für ADAM-Daten- und Wiederherstellungsdateien (Protokolldateien) anzeigen und ändern. Standardmäßig werden ADAM-Daten- und Wiederherstellungsdateien unter

    %ProgramFiles%\Microsoft ADAM\Instanzname\data

    gespeichert. Dabei stellt

    Instanzname

    den ADAM-Instanznamen dar, den Sie auf der Seite

    Instanzname

    angeben. Klicken auf

    Weiter

    , um die Standardpfade zu übernehmen.

info Info

Beim Installieren von ADAM auf einem Computer unter Windows XP müssen Sie diese Dateien auf demselben logischen Volume installieren. Beim Installieren von ADAM unter Windows Server 2003 und Windows Server 2003 R2 in einer Produktionsumgebung wird empfohlen, die Dateien auf separaten physikalischen Datenträgern zu installieren.

Programmdateien und Verwaltungsprogramme werden von ADAM in

%windir%\ADAM

installiert.
  • Auf der Seite

    Dienstkontoauswahl

    wählen Sie ein Konto aus, das als Dienstkonto für ADAM verwendet wird. Das ausgewählte Konto bestimmt den Sicherheitskontext, in dem die ADAM-Instanz ausgeführt wird. Wenn Sie ADAM nicht auf einem Domänencontroller installieren, wird standardmäßig das Netzwerkdienstkonto vom Active Directory-Anwendungsmodus-Setup-Assistenten verwendet. Klicken Sie auf

    Weiter

    , um die Standardeinstellung

    Netzwerkdienstkonto

    zu übernehmen. Beim Installieren von ADAM auf einem Domänencontroller klicken Sie stattdessen auf

    Dieses Konto

    und wählen dann ein Domänenbenutzerkonto als ADAM-Dienstkonto aus.

info Info

Sie können das ADAM-Dienstkonto nach der Installation von ADAM mit dem Befehlszeilenprogramm

dsmgmt

ändern. Beim Installieren von ADAM auf einem Domänencontroller müssen Sie ein Domänenbenutzerkonto als ADAM-Dienstkonto auswählen.
  • Auf der Seite

    ADAM-Administratoren

    wählen Sie einen Benutzer oder eine Gruppe als Standardadministrator für die ADAM-Instanz aus. Der ausgewählte Benutzer oder die ausgewählte Gruppe verfügt über vollständige Verwaltungsfunktionalität für die ADAM-Instanz. Standardmäßig wird vom Active Directory-Anwendungsmodus-Setup-Assistenten der aktuell angemeldete Benutzer angegeben. Sie können diese Auswahl in jedes lokale Konto oder Domänenkonto bzw. in jede Gruppe im Netzwerk ändern. Klicken Sie auf den Standardwert

    Zurzeit angemeldeter Benutzer

    , und klicken Sie dann auf

    Weiter

    .
  • Auf der Seite

    Importieren von LDIF-Dateien

    können Sie zwei LDF-Dateien mit Benutzerklassen-Objektdefinitionen in das ADAM-Schema importieren. Das Importieren dieser Benutzerklassen-Objektdefinitionen ist optional.
    • Klicken Sie auf

      Die ausgewählten LDIF-Dateien für diese ADAM-Instanz importieren

      .
    • Klicken Sie auf

      MS-InetOrgPerson.LDF

      und dann auf

      Hinzufügen

      .
    • Klicken Sie auf

      MS-User.LDF

      und dann auf

      Hinzufügen

      .
    • Klicken Sie auf

      MS-UserProxy.LDF

      , auf

      Hinzufügen

      und dann auf

      Weiter

      .
  • Auf der Seite

    Installationsbereit

    können Sie die ausgewählten Installationsoptionen überprüfen. Wenn Sie auf

    Weiter

    klicken, beginnt der Active Directory-Anwendungsmodus-Setup-Assistent mit dem Kopieren von Dateien und mit der Installation von ADAM auf dem Computer.
  • Wenn der Active Directory-Anwendungsmodus-Setup-Assistent die Installation von ADAM erfolgreich abgeschlossen hat, wird die folgende Meldung angezeigt: "Der Active Directory-Anwendungsmodus-Setup-Assistent wurde erfolgreich abgeschlossen." Wenn die Seite

    Fertigstellen des Assistenten

    angezeigt wird, klicken Sie auf

    Fertig stellen

    , um den Assistenten zu schließen.

info Info

Wird der Active Directory-Anwendungsmodus-Setup-Assistent nicht erfolgreich abgeschlossen, wird auf der Seite

Zusammenfassung

eine Fehlermeldung mit dem Grund für den Fehler angezeigt.
  • Wenn im Active Directory-Anwendungsmodus-Setup-Assistenten ein Fehler auftritt, bevor die Seite

    Zusammenfassung

    geöffnet wird, können Sie die angezeigte Fehlermeldung überprüfen. Darüber hinaus können Sie auf

    Start

    und dann auf

    Ausführen

    klicken und einen der folgenden Dateinamen eingeben:

    %windir%\Debug\Adamsetup.log

    %windir%\Debug\Adamsetup_loader.log

    Die Dateien

    %windir%\Debug\Adamsetup.log

    und

    %windir%\Debug\Adamsetup_loader.log

    enthalten nützliche Informationen zur Problembehandlung bei ADAM-Setup-Fehlern.


AD-Schema einspielen

Handbuch -> Benutzerverwaltung -> Active Directory Application Mode - ADAM (für Windows XP) -> AD-Schema einspielen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

So verwenden Sie erstmalig das Active Directory/ADAM-Synchronisierungsprogramm

  • Klicken Sie auf Start,
  • öffnen Sie Alle Programme,
  • klicken Sie auf ADAM und
  • dann auf ADAM-Verwaltungsprogramme:

    ein Befehlsfenster im ADAM-Verzeichnis öffnet sich.

Zum Erweitern des ADAM-Schemas auf die Standardschemaobjekte von Windows Server in Active Directory:

  • geben Sie in der Eingabeaufforderung den folgenden Befehl in einer Zeile ein:

    ldifde -i -s localhost -c CN=Configuration,DC=X #ConfigurationNamingContext -f MS-AdamSchemaW2k3.ldf

  • Drücken Sie die Eingabetaste.


ADAM-Schema Snap-in konfigurieren

Handbuch -> Benutzerverwaltung -> Active Directory Application Mode - ADAM (für Windows XP) -> ADAM-Schema Snap-in konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfigurieren des Verwaltungsprogramms ADAM-Schema Snap-In

Mit einem weiteren ADAM-Verwaltungsprogramm, dem ADAM-Schema Snap-In, können Sie das ADAM-Schema verwalten. Wenn Sie das Active Directory-Schema-Snap-In bereits verwendet haben, sollte Ihnen das ADAM-Schema Snap-In bekannt vorkommen. Bevor Sie das ADAM-Schema Snap-In verwenden können, müssen Sie eine MMC-Datei dafür erstellen, wie in diesem Verfahren beschrieben.

  • Klicken Sie auf Start, auf Ausführen, geben Sie mmc /a ein, und klicken Sie anschließend auf OK.
  • Klicken Sie im Menü Datei auf Snap-In hinzufügen/entfernen, und klicken Sie dann auf Hinzufügen.
  • Klicken Sie in Verfügbare eigenständige Snap-Ins auf ADAM-Schema, auf Hinzufügen, auf Schließen, und klicken Sie dann auf OK.
  • Klicken Sie zum Speichern dieser Konsole im Menü Datei auf Speichern.
  • Geben Sie in Dateiname Folgendes ein, und klicken Sie dann auf Speichern:
    %windir%\system32\adamschmmgmt.msc
  • Stellen Sie über das ADAM-Schema Snap-In eine Verbindung mit der ADAM-Instanz her. Dazu klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf ADAM-Schema, klicken Sie auf ADAM-Server ändern. Geben Sie localhost bei ADAM-Server und 389 bei Port ein.
  • Klicken Sie auf OK. Das ADAM-Schema Snap-In sieht jetzt wie folgt aus. Sie können die Klassen und Attribute des ADAM-Schemas durchsuchen und anzeigen.
  • Führen Sie zum Erstellen einer Verknüpfung für das ADAM-Schema-Snap-In im Menü Start folgende Aktionen aus:
    • Klicken Sie mit der rechten Maustaste auf Start, klicken Sie auf Öffnen – Alle Benutzer, doppelklicken Sie auf den Ordner Programme, und doppelklicken Sie dann auf den Ordner ADAM.
    • Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Verknüpfung.
    • Geben Sie im Assistenten zum Erstellen von Verknüpfungen in Geben Sie den Speicherort des Elements ein die Zeichenfolge adamschmmgmt.msc ein, und klicken Sie dann auf Weiter.
    • Geben Sie auf der Seite Programmbezeichnung auswählen in Geben Sie den Namen für die Verknüpfung ein den Namen ADAM-Schema ein, und klicken Sie dann auf Fertig stellen.


Bedienen zur Runtime

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime

Jeder Benutzer hat zur Runtime die Möglichkeit, sein eigenes Passwort zu editieren. Er kann jedoch keinen anderen Benutzer editieren. Dies kann nur der Administrator. Änderungen zur Runtime müssen in den Editor zurückgelesen werden, um dort zur Verfügung zu stehen. Beachten Sie beim Übertragen von Runtime-Dateien die Eigenschaft RT änderbare Daten. Hier wird festgelegt, ob die Projektierung der Benutzerverwaltung zur Runtime übertragen wird und die Konfiguration in der Runtime überschreibt.

Interne ID: Bedienen zur Runtime

RT änderbare Daten

Der Konfigurationsdialog für die Runtime änderbaren Daten wird geöffnet.
Standard-Rezepte, Rezeptgruppen-Manager, Scheduler oder Production and Facility Scheduler und Benutzerverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Administrator kann über die Funktion Benutzer ändern:

  • neue Benutzer anlegen
  • vorhandene Benutzer ändern (ausgenommen Benutzername für Anmeldung)
  • Benutzergruppen anlegen, ändern und löschen

    Legt ein Administrator zur Runtime eine neue Benutzergruppe an, wird er automatisch Mitglied dieser Gruppe.

  • Berechtigungsebenen vergeben

    Der Administrator kann nur Berechtigungsebenen vergeben, die er selbst besitzt. Damit wird verhindert, dass sich ein Administrator das System komplett freischaltet.

Hinweis: Benutzer und Benutzergruppen aus dem Editor-Globalprojekt werden zur Runtime mit den Benutzern und Benutzergruppen des Projekts zusammengeführt. Sie können daher zur Runtime weder editiert, noch in den Editor zurückgelesen werden.

attention Achtung

Konformität mit FDA 21 CFR Part 11:

  • Weder Benutzer noch Administrator können zur Runtime den Benutzernamen ändern.
  • Das Löschen von Benutzern kann in den Projekteigenschaften mit der Eigenschaft Löschen von Benutzern in der Gruppe Benutzerverwaltung unterbunden werden.

    Interne ID: Bedienen zur Runtime

    Benutzerverwaltung

    Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Bedienen zur Runtime

    Löschen von Benutzern

    Aktiv: Löschen eines Benutzers in der Runtime ist erlaubt.
    Inaktiv: Benutzer können nur gelöscht markiert werden. Die Benutzer bleiben dabei in der Liste der Benutzer, sind allerdings für die Bedienung in der Runtime nicht mehr gültig (nach FDA Richtlinie).
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Login

Nach dem Starten der Runtime ist der aktuelle Benutzer SYSTEM mit der freigegebenen Bedienebenen LEVEL 0 angemeldet.

Beim Einloggen in der Runtime gibt es folgende Sicherheitsvorkehrungen:

  • Passwort

    Bei einer dreimaligen Falscheingabe des Passwortes erfolgt eine Sperre des Benutzers und er wird automatisch ausgeloggt. Das System ist somit für diesen Benutzer für alle Elemente die einen höhere Berechtigungsebene als 0 verlangen, unbedienbar. Er kann also keine mit einem Benutzerlevel verbundenen Bedienaktionen mehr durchführen.
    Folgende Meldung wird angezeigt:

    Der Administrator muss dann den entsprechenden Benutzer wieder freischalten (Eigenschaft Gesperrt deaktivieren).

    Der Benutzername des Benutzers, der sich fälschlicherweise versucht einzuloggen, wird in der Chronologischen Ereignisliste protokolliert.

  • Benutzername

    Bei Eingabe eines nicht existierenden Benutzernamens oder bei leerem Passwortfeld wird die Fehlermeldung "Ungültiger Benutzername" ausgegeben. Nach drei Fehleingaben wird das System für alle Elemente die eine höhere Berechtigungsebene als 0 verlangen, gesperrt. Kein Benutzer ist damit in der Lage, mit einer Benutzerebene geschützte Bedienaktionen durchführen. Eine Aufhebung dieser Sperre kann nur durch den Administrator erfolgen.

    Der Benutzername des Benutzers, der sich fälschlicherweise versucht einzuloggen, wird in der Chronologischen Ereignisliste als Ereignis für den aktuell eingeloggten Benutzer protokolliert.

  • Einloggen nach Deaktivierung

    Ist ein Benutzer deaktiviert und versucht sich dennoch einzuloggen, ist ein Einloggen nicht möglich. Dieser Versuch wird in der Chronologischen Ereignisliste protokolliert.

Passwort

Der jeweilige Benutzer ist der einzige, der Kenntnis über sein Passwort besitzt. Er ist auch der einzige, der sein Passwort ändern kann. Nachdem dem Benutzer ein Passwort durch den Administrator zugeteilt worden ist, muss der Benutzer beim erstmaligen Login sein Passwort neu festlegen. Damit wird sichergestellt, dass kein Administrator ein Benutzerpasswort kennt und dadurch falsche Signaturen auslöst. (Wichtig für FDA 21 CFR Part 11).

Wenn ein Benutzer sein Passwort vergisst, kann der Administrator das Passwort löschen und ein neues Initialpasswort vergeben. Der Administrator benötigt für diese Interventionen keine Kenntnis des Passwortes. Beim nächsten Einloggen muss der entsprechende Benutzer das Passwort wieder ändern.

Nähere Informationen zu geänderten Runtime-Dateien finden Sie im Kapitel: Projekt und Arbeitsbereich/RT änderbare Dateien

attention Achtung

Login über Bild vom Typ Login: Wird bei einer Anmeldung über ein Bild vom Typ Login für einen gültigen Benutzer kein Passwort eingegeben, erhalten Sie keine Fehlermeldung. Der Benutzer wird nicht eingeloggt. Das System wird auch nach dreimaligem Anmeldeversuch mit leerem Passwort nicht gesperrt.

Bei Eingabe eines falschen Passwortes und/oder eines nicht existierenden Benutzernamens wird das System wie gewohnt nach drei Versuchen gesperrt.

Noch in diesem Kapitel

Permanentes und temporäres Login

Passwortschutz im dynamischen Element

Passwort - Funktionen

Löschen eines Benutzers

Bild vom Typ Login


Permanentes und temporäres Login

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Permanentes und temporäres Login

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Benutzer können permanent oder temporär eingeloggt werden.

Permanentes Login

Das permanente Login erfolgt über die Funktion Login mit Dialog oder über die Funktion Login ohne Passwort. Der Benutzer ist damit permanent angemeldet und kann alle Bedienhandlungen durchführen, für die er berechtigt ist. Bei Handlungen, für die er keine Bedienberechtigung besitzt, wird eine entsprechende Meldung angezeigt.

Interne ID: Permanentes und temporäres Login

Login ohne Passwort

Diese Funktion loggt einen ausgewählten Benutzer ein, ohne nach seinem Passwort zu fragen.

Mehr im Online-Handbuch

Interne ID: Permanentes und temporäres Login

Login mit Dialog

Diese Funktion öffnet den Standard-Login-Dialog.

Mehr im Online-Handbuch

Tipp: Für eingeloggte Benutzer können mit Passwort geschützte Text-Buttons auf unsichtbar gesetzt werden. Dazu muss die Eigenschaft Gesperrte Buttons (Projekteigenschaften -> Benutzerverwaltung -> Temporäres Login) aktiviert werden.

Interne ID: Permanentes und temporäres Login

Temporäres Login

Eigenschaften für das temporäre Einloggen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Permanentes und temporäres Login

Benutzerverwaltung

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Permanentes und temporäres Login

Gesperrte Buttons

Nur verfügbar, wenn die Eigenschaft Temp. Login aktiv inaktiv ist.
Definiert das Aussehen von Buttons, die aufgrund der Einstellungen der Bedienberechtigung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Verriegelte Buttons (Grafische Ausprägung) kombiniert.

Interne ID: Permanentes und temporäres Login

Verriegelte Buttons

Definiert das Aussehen von Buttons zur Runtime, die aufgrund einer Verriegelung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Gesperrte Buttons (Benutzerverwaltung) kombiniert.

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Diese Eigenschaft wirkt unabhängig von der Eigenschaft Grafische Kennzeichnung aktiv. Ein grauer Button kann z.B. auch ein Schlosssymbol anzeigen.

Interne ID: Permanentes und temporäres Login

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Permanentes und temporäres Login

Temp. Login aktiv

Aktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, wird er zur Eingabe seiner Kennung und seines Passworts aufgefordert.
Inaktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, erhält er die Information, dass er dazu nicht berechtigt ist.
Default: aktiv.

Hinweis: Position und Größe der Login-Maske können in der zenon6.ini unter [Befehlsgabe] Position = definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Temporäres Einloggen ist für eingeloggte Benutzer nicht möglich. Damit erhalten eingeloggte Benutzer bei Funktionen, für die sie keine ausreichende Berechtigung besitzen, keinen Dialog zur Anmeldung eines temporären Logins.

Temporäres Login

Ist für einen nicht eingeloggten Benutzer eine Bedienhandlung nötig, die eine Authentifizierung erfordert, kann er temporär eingeloggt werden. Dazu muss in den Projekteigenschaften die Eigenschaft Temp. Login aktiv (-> Benutzerverwaltung -> Temporäres Login) aktiv geschaltet sein.

Login zur Runtime:

  • beim Ausführen einer passwortgeschützen Funktion wird der Dialog zum Login geöffnet
  • der Benutzer kann sich einloggen und entsprechend seinen Rechten die Bedienhandlung ausführen oder er erhält eine Meldung über fehlende Rechte
  • der Benutzer wird sofort nach der Bedienhandlung automatisch ausgeloggt

info Info

Temporäres Login:

  • ist nur bei einer Funktionsausführung wirksam
  • unterstützt Schalter, aber keine Taster
  • ist für permanent eingeloggte Benutzer deaktiviert


Passwortschutz im dynamischen Element

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Passwortschutz im dynamischen Element

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Laufzeit können alle Dynamische Bildelemente, die eine Funktionsausführung bzw. eine Sollwert absetzen - Funktion erlauben, mit einer Berechtigungsgruppe verknüpft werden.

Legen Sie dazu ein dynamisches Element an. Beispielsweise einen Textbutton. Nun erscheinen im Eigenschaften-Fenster alle projektierbaren Eigenschaften für dieses dynamische Element.

Selektieren Sie bei den Eigenschaften in der Gruppe 'Benuzter' die Eigenschaft 'Berechtigungsgruppe'. Hier können Sie die zur Funktionsausführung nötige Berechtigungsgruppe einstellen.

Bei dynamischen Elementen, bei denen eine Sollwertaktion geschützt werden soll, muss zuerst über das Eigenschaften-Fenster eine Variable verknüpft und das Sollwert Setzen aktiviert werden, bevor die Berechtigungsgruppe eingestellt werden kann.


Passwort - Funktionen

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Passwort - Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Login mit Dialog

Login ohne Passwort

Logout

Passwort ändern


Login mit Dialog

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Passwort - Funktionen -> Login mit Dialog

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Funktion öffnet zur Runtime die Login-Maske für ein erneutes Anmelden an zenon.

Die Anmeldung wird in der Chronologische Ereignisliste protokolliert.

Für den Login kann auch ein Bild vom Typ Login verwendet werden.

Größe und Position

Größe und Position des Anmeldefensters zur Runtime können in der zenon6.ini festgelegt werden:

  1. öffnen Sie die zenon 6.ini
  2. erstellen oder modifizieren Sie den Bereich:

    [Befehlsgabe]

  3. tragen Sie die Werte ein für

    POSITION= links, rechts, oben, unten

Default: POSITION= 0.001, 0.999, 0.835, 0.964

Achtung: Die Größe bezieht sich auf die Bildgröße und nicht auf die Größe der Hauptfensters.

info Info

Die zenon6.ini finden Sie im Pfad:

Windows Vista/7: C:\ProgramData\COPA-DATA\System\

Windows XP: C:\Dokumente und Einstellungen\All users\Anwendungsdaten\COPA-DATA\System


Login ohne Passwort

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Passwort - Funktionen -> Login ohne Passwort

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion ermöglicht es, zur Runtime einen Benutzer an zenon ohne Passworteingabe anzumelden. Dafür wird der Benutzer direkt benannt oder per Chip Ident System angemeldet. Der Funktionsaufruf kann über ein Ereignis (Meldungszustand von Schlüsselschalter) oder die Zeitsteuerung ausgelöst werden. In der Chronologische Ereignisliste wird das Anmelden protokolliert.

Um die Funktion Login ohne Passwort anzulegen:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Benutzerverwaltung
  • wählen Sie Login ohne Passwort
  • der Dialog zur Auswahl des Benutzers öffnet sich
  • wählen Sie die Art des Logins

Parameter

Beschreibung

Benutzer direkt

Meldet den ausgewählten Benutzer an.

Benutzer aus Variable

Meldet den Benutzer mit dem Benutzernamen aus der übergebenen Variablen an. Ermöglicht die Anmeldung über ein Chip Ident System.

Klick auf die Schaltfläche ... öffnet den Dialog zur Auswahl einer String-Variablen. Details siehe Absatz "Anmeldung über Chip Ident System".

Anmeldung über Chip Ident System

Die Anmeldung Benutzer aus Variable ermöglicht die Nutzung von Chip Ident Systemen wie z. B. Euchner oder Keba Identsystem. Um Die Anmeldung über eine Variable zu nutzen, beachten Sie:

  • Der Benutzer muss in der zenon Benutzerverwaltung oder im Active Directory mit dem gleichen Benutzernamen wie im Chip angelegt sein.

    zum Beispiel: Benutzername im Chip ist J. Smith, dann muss in der Benutzerverwaltung oder im Active Directory ein J. Smith mit entsprechenden Rechten existieren.

  • Hält der Benutzer seinen Chip vor den Chipleser wird die String-Variable (z.B. username) mit den Daten des Chips befüllt (z. B. J. Smith) und der Benutzer angemeldet.
  • Damit die Funktion ausgeführt wird, muss eine Reaktionsmatrix vom Typ String existieren, die auf jede Wertänderung reagiert und die Funktion ausführt.
    • Diese Rema muss mit der Variablen (z.B. username) verknüpft sein.


Logout

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Passwort - Funktionen -> Logout

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird im Onlinebetrieb (Runtime) der aktuelle Benutzer abgemeldet und der Benutzer SYSTEM mit dem Bedienlevel 0 angemeldet. In der Chronologische Ereignisliste wird das Anmelden des Systembenutzers protokolliert.

Es sind keine Übergabeparameter notwendig.

attention Achtung

Automatischer Logout vs. Automatische Funktion:

  • Automatischer Logout: Passiert permanent ab dem Ablauf der Zeit der letzten Bedienungsaktion.
  • Automatische Funktion: Passiert nur ein Mal ab dem Ablauf der Zeit der letzten Bedienungsaktion.


Passwort ändern

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Passwort - Funktionen -> Passwort ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann der angemeldete Benutzer sein aktuelles Passwort im Onlinebetrieb (Runtime) ändern. Für die systeminternen Benutzer ist keine Änderung möglich. Die Funktion wird nicht ausgeführt.

Im Onlinebetrieb wird eine Eingabemaske aufgeschaltet.

Die notwendigen Eingaben sind

Parameter | Beschreibung
altes Passwort | aktuelles Passwort eingeben
neues Passwort | neues Passwort eingeben
Sicherheitsabfrage | Sicherheitsabfrage für das neue Passwort

Wurde dem Benutzer kein Passwort zugewiesen, kann er es sich im Onlinebetrieb beim ersten Aufruf der Funktion selbst definieren. In der Maske wird kein altes Passwort abgefragt.


Löschen eines Benutzers

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Löschen eines Benutzers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Selektieren Sie den zu löschenden Benutzer in der Listenansicht und öffnen Sie mit einem rechten Mausklick das Kontextmenü. Gehen Sie auf Löschen und bestätigen Sie auch die zusätzliche Sicherheitsabfrage.


Bild vom Typ Login

Handbuch -> Benutzerverwaltung -> Bedienen zur Runtime -> Bild vom Typ Login

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung eines Bildes für das Einloggen ist die individuelle Gestaltung eines Login-Fensters möglich. (Nähere Informationen zu den vordefinierten Bildtypen finden Sie im 'Bilder / Vordefinierte Bildtypen'.)

Das Anlegen des Login-Bildes im Editor erfolgt durch Definition eines neuen Bildes der Bildtyp Login.

Nach dem Öffnen des Bildes wird ein leeres Bild aufgeschaltet und in der Menüzeile wird die Dropdownliste Kontrollelemente gefüllt.

Kontrollelemente:

Kontrollelement | Beschreibung
Aktueller Benutzer | Beschriftung Aktueller Benutzer
Anzeige - Aktueller Benutzer | Anzeige des aktuell angemeldeten Benutzers
Kennung | Beschriftung Benutzername
Eingabe Kennung | Eingabebereich für Benutzername
Passwort | Beschriftung Passwort
Eingabe Passwort | Eingabebereich für das Passwort
OK | Schaltfläche zum Einloggen und Schließen des Fensters
Abbruch | Schaltfläche für Abbruch
Login | Schaltfläche zum Einloggen ohne Schließen des Fensters

Login

Beim Einloggen in der Runtime gilt:

  • Nach dreimaliger Falscheingabe des Passwortes, wird der Benutzer für das System gesperrt. Diese Sperre kann nur ein Administrator aufheben.
  • Nach dreimaliger Falscheingabe eines Benutzernamens wird das System gesperrt. Das System ist für keinen Benutzer mehr bedienbar und muss von einem Administrator wieder frei geschaltet werden.
  • Wird bei der Anmeldung ein korrekter Benutzername angegeben, aber das Passwortfeld leer gelassen, erfolgt keine Reaktion. Das System wird nicht gesperrt.

Details siehe Kapitel Bedienen zur Runtime.


Bilder

Handbuch -> Bilder

Bilder sind zentrale Elemente eines Projektes. Sie repräsentieren die projektierte Anlage, informieren und bieten Bedienelemente an.
Bilder bestehen aus Vektor-Elementen und/oder Dynamischen Elementen. Diese werden mit Variablen oder Funktionen verknüpft. Bilder werden im Hauptfenster des Editors projektiert.

zenon bietet eine große Anzahl an vordefinierten Bildtypen, wie Alarmmeldelisten, Trendbilder usw. Der Vorteil dieser Bildtypen liegt darin, dass mit dem Bildtyp die gewünschte Funktionalität gleich verbunden ist. Sie müssen nur den Bildtyp anlegen und es steht ihnen sofort eine Fülle an vordefinierten Funktionalitäten zur Verfügung. Eine Übersicht der Bildtypen finden Sie im Abschnitt Bildtypen.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Hauptfenster

Im Hauptfenster werden Dokumente wie Bilder, Reporte usw. angezeigt und bearbeitet. Das Hauptfenster lässt sich als einziges Fenster nicht ausblenden.

Mehrere Dokumente parallel öffnen

Sie können im Hauptfenster mehrere Bilder gleichzeitig anzeigen. Diese Funktion aktivieren Sie über: Optionen -> Hauptfenster mit Registerkarten . Die Bilder sind über Registerkarten am oberen Rand des Hauptfensters erreichbar und können über Optionen im Menüpunkt Fenster angeordnet werden.

Um offene Bilder zu schließen, benutzen Sie die Tastenkombination Strg+F4, das Kontextmenü oder den Befehl Fenster -> Schließen.

Kontextmenü Dokumente

Ein Rechtsklick auf die Registerkarte eines Dokuments öffnet ein Kontextmenü:

Parameter | Beschreibung
Speichern | Speichert das Dokument.
Schließen | Schließt dieses Dokument.
Alle anderen schließen | Schließt alle anderen Dokumente.

Elemente im Bild positionieren

Elemente mit einem Klick auf das Symbol in der Symbolleiste Elemente aktivieren und mit der Maus im Hauptfenster aufziehen.

Zum Bewegen des Elements stehen mehrere Möglichkeiten zur Verfügung:

  • Schnell bewegen: Element anklicken und mit der Maus positionieren
  • Exakt positionieren: Element anklicken und mit den Pfeiltasten positionieren
  • Drehen: Element mit dem "Griff" über der linken oberen Ecke beliebig drehen

Positionierung von Elementen im Editor und zur Runtime

Elemente können im Editor und zur Runtime auf verschiedenen Ebenen positioniert werden. Im Editor können einzelne Ebenen auch ausgeblendet werden

Achtung: Kontrollelemente werden zur Runtime immer an oberster Stelle angezeigt. Das gilt auch, wenn sie im Editor von anderen Elementen überdeckt werden. Damit wird sicher gestellt, dass sie immer erreichbar sind.

Anpassung an Auflösung

Bilder und ihre Elemente werden zur Runtime automatisch an die Bildschirmauflösung angepasst. Dies kann unterbunden werden. Um Bild-Elemente in original im Editor projektierter Größe und Position anzuzeigen, aktivieren Sie für das entsprechende Bild die Eigenschaft Elemente nicht an Bildschirmauflösung anpassen in der GruppeGröße .

Interne ID: Bilder

Größe

Eigenschaften für die Größe und die Position des Bildes, die aus der verknüpften Schablone übernommen werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bilder

Elemente nicht an Bildschirmauflösung anpassen

Aktiv: Die im Bild enthaltenen Elemente werden zur Runtime nicht automatisch an die Bildschirmauflösung angepasst, sondern behalten die im Editor projektierte Position und Größe bei.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Kontextmenü Projektmanager

Grafikqualität

Bilder Detailansicht Symbolleiste und Kontextmenü

Symbolleiste Bilder bearbeiten

Symbolleiste Elemente

Kontextmenü Elemente

XML-Export und XML-Import

Bildelemente

Bildelemente bearbeiten

Schablonen

Farbpaletten

Schriften

Symbole

Sichtbarkeitsebenen

Bildtypen

Bild-Funktionen


Kontextmenü Projektmanager

Handbuch -> Bilder -> Kontextmenü Projektmanager

Menüpunkt | Aktion
Bild neu | Legt ein neues Bild mit dem Standardnamen Picture als Bildtyp Standard an.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei. Hinweis: Vorhandene Schablonen werden beim XML-Import über den Knoten Bilder nicht ersetzt. Beim XML-Import über den Knoten Schablonen werden vorhandene Schablonen überschrieben. In diesem Fall werden alle Bilder und deren Elemente an die neue Schablone angepasst.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.


Grafikqualität

Handbuch -> Bilder -> Grafikqualität

In zenon kann die Qualität der dargestellten Grafik auf die Ressourcen des Systems abgestimmt werden. Die Einstellung erfolgt über die Projekteigenschaft Grafikqualität in der Gruppe Grafische Ausprägung. Folgende Einstellungen sind möglich:

Interne ID: Grafikqualität

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grafikqualität

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Grafikqualität

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.
  • Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.
  • DirectX Software: Grafikberechnungen werden von der CPU erledigt. Es können, abhängig von den darzustellenden Grafiken, mehrere CPUs verwendet werden. Die Verwendung von DirectX Software kann eine hohe Auslastung der CPU erzeugen.
  • DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert, wodurch die Performance gesteigert werden kann. Wird diese Einstellung vom verwendeten System nicht unterstützt, schaltet zenon automatisch auf DirectX Software um. Prinzipiell ist DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

attention Achtung
  • Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.
  • DirectX Darstellung wird nur in der Runtime unterstützt.

DirectX

DirectX ermöglicht eine höhere Grafikqualität als Windows Basis oder Windows Erweitert. So kann DirectX im Gegensatz zu Windows Basis/Erweitert die Eigenschaften Antialiasing verwenden und ClearType Schriften unabhängig von den Einstellungen des Betriebssystems ein- und ausschalten. Die Antialiasing-Qualität von DirectX ist höher als bei Windows Erweitert.

Interne ID: Grafikqualität

ClearType Schriften

Aktiv: ClearType Schriften werden verwendet. Kann die Lesbarkeit von Schriften auf LCD-Bildschirmen in nativer Auflösung verbessern.

Inaktiv: Windows Standardschriften werden verwendet. Eignet sich oft für Röhrenmonitore und LCDs mit interpolierter Auflösung.
Hinweis: Wurde für die Eigenschaft Grafikqualität Windows Basis oder Windows Erweitert gewählt, muss unter Windows Vista und Windows 7 im Betriebssystem die Verwendung von ClearType-Schriften deaktiviert werden. Wurde DirectX gewählt, kann Cleartype unabhängig vom Betriebssystem ein- und ausgeschaltet werden.

Default: aktiv.

Hinweis: Änderungen der Einstellung werden für den Editor erst nach dem Neustart des Editors wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grafikqualität

Antialiasing verwenden

Nur verfügbar, wenn Grafikqualität aktiviert ist.

Schaltet die Kantenglättung von Linien ein. Dadurch werden vor allem schräge Linien grafisch wesentlich ansprechender dargestellt. Der Treppeneffekt entfällt. Wurde in der Eigenschaft Grafikqualität DirectX Software oder DirectX Hardware gewählt, kann Antialiasing unabhängig von den Betriebssystemeinstellungen ein- und ausgeschaltet werden. Die Antialiasing Qualität von DirectX ist höher als bei Windows Erweitert.

Antialising kann die Bildumschaltzeiten besonders bei älteren Betriebssystemen (bis Windows XP) verlängern.

Mögliche Optionen sind:

Ein: Kantenglättung immer aktiv

Aus: Kantenglättung deaktiviert

Default: Bei Windows Vista, Windows 7 und neueren Betriebssystemen ist die Kantenglättung aktiviert, bei älteren Betriebssystemen (Windows XP, Server 2003) deaktiviert.

Default: Default

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um DirectX verwenden zu können, müssen einige Voraussetzungen erfüllt werden:

Voraussetzung

Erklärung

DirectX Hardware oder DirectX Software muss aktiviert sein.

In den Projekteigenschaften muss für die Eigenschaft Grafische Ausprägung DirectX Hardware oder DirectX Software gewählt werden.

Das Betriebssystem muss DirectX 11 unterstützen.

DirectX Hardware und DirectX Software funktionieren nur auf Betriebssystemen mit DirectX11 Unterstützung:

  • Microsoft Windows Vista SP2 inkl. Plattform Update und Windows 7
  • Windows XP und Windows CE werden nicht unterstützt

Wenn das System DirectX 11 nicht unterstützt, wird automatisch auf Windows Erweitert umgeschaltet.

Die aktuelle DirectX Runtime muss installiert sein.

Diese wird für zenon mit dem Setup mit installiert. Für den Webclient muss sie manuell installiert werden.

Das Bild oder Element müssen DirectX unterstützen.

Nur unterstützte Elemente bzw. Bilder können mit DirectX dargestellt werden.

Bei DirectX Hardware müssen die Mindestvoraussetzungen erfüllt werden.

Details siehe Mindestvoraussetzungen Grafikkarte. Werden diesen nicht erfüllt, wird automatisch auf DirectX Software umgeschaltet.

Steht vom Betriebssystem keine Hardwarebeschleunigung zur Verfügung (zum Beispiel bei Remote Desktop), kann DirectX Hardware eventuell nicht verwendet werden.

Mindestvorraussetzungen Grafikkarte für DirectX Hardware

Für den Einsatz von DirectX Hardware müssen folgende Mindesvoraussetzungen erfüllt werden:

Parameter | Mindestvoraussetzung | Empfohlen
Grafikkarte: | Dezidierte DirectX 11 AMD oder nVidia Grafikkarte | Dezidierte DirectX 11 AMD oder nVidia Grafikkarte
Grafikspeicher: (Tatsächlich benötigte Größe ist abhängig von Anzahl der aufgeschalteten Bilder und dargestellten Elemente.) | 512 MB VRAM | 1 GB VRAM
Treiber Grafikkarte: | Aktuellster Treiber des Grafikkartenherstellers

Um die Grafikkartenunterstützung für DirectX Hardware zu überprüfen, kann das Windows Betriebssystem-Tool dxdiag.exe verwendet werden. Damit kann die DirectX Hardwarefähigkeit der Grafikkarte und des Treibers unter Anzeige mit dem Wert DDI-Version überprüft werden. Der Wert 11 zum Beispiel steht für DirectX 11.

Unterschiede DirectX zu Windows Erweitert

DirectX unterscheidet sich von Windows Erweitert hinsichtlich Qualität, Performance und Ressourcenbedarf. Einige der wichtigsten Unterschiede:

  • Skalierungen, Verzerrungen und Rotationen von Objekten werden mit Antialiasing dargestellt. Antialiasing funktioniert auch mit Transformationen.
  • Schatten werden als korrektes Ebenbild des eigentlichen Elementes dargestellt. Auch Texte und teiltransparente Bitmaps haben einen komplett korrekten Schatten. Dynamische Änderungen werden berücksichtigt: Bei gedrücktem Button ändert sich zum Beispiel auch der Schatten.
  • Glow-Effekt ermöglicht das Glühen eines Elementes über das Ebenbild des eigentlichen Elements. Auch Texte und teiltransparente Bitmaps haben einen korrekten Glow-Effekt. Dynamische Änderungen werden berücksichtigt: Bei gedrücktem Button ändert sich zum Beispiel auch der Glow-Effekt.

info Info

Die Verwendung von WMF- oder EMF-Grafiken mit DirectX kann zu Einbußen bei der Performance führen.

Beispiele

Gedrehte dynamische Elemente

Mit Windows Erweitert:

Mit DirectX:

Treppenbildung an den Rändern ist reduziert, Texte werden korrekt positioniert.

Halbtransparenter Button mit Schatten

Mit Windows Erweitert:

Mit DirectX:

Korrekter Schatten mit sichtbarem Text.

Schatten eines Buttons mit Bitmap

Links wird ein Bitmap-Button mit Schatten dargestellt, rechts das gleiche Bild mit der Eigenschaft Transparent aktiv.

Interne ID: Grafikqualität

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mit Windows Erweitert:

Mit DirectX:

Noch in diesem Kapitel

Fehlerbehandlung DirectX


Fehlerbehandlung DirectX

Handbuch -> Bilder -> Grafikqualität -> Fehlerbehandlung DirectX

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler werden im Diagnose Viewer ausgegeben.

DirectX wird nicht initialisiert

Kann DirectX beim Aufschalten eines Bildes oder im laufenden Betrieb nicht initialisiert werden, dann:

  • wird eine Fortschrittsanzeige angezeigt
  • wird versucht, DirectX neu zu initialisieren
  • läuft die Runtime normal weiter solange die Fortschrittsanzeige angezeigt wird
  • kann versucht werden, das Problem zu beheben (Treiberinstallation, ...)

Die Fortschrittsanzeige kann vom Benutzer durch Klick auf die Schaltfläche Abbrechen beendet werden. Nach dem Abbrechen wird die Runtime beendet und eine Fehlernachricht angezeigt, die nur mit Klick auf OK beendet werden kann.

Hinweis: Bei Fehlern, die ein Reinitialisieren von DirectX unmöglich machen, wird sofort eine Fehlernachricht angezeigt.

Diagnose Viewer

DirectX stellt im Diagnose Viewer individuelle Nachrichten bereit, mit jeweils:

  • einer Fehlermeldung
  • möglichen Gründen für den Fehler
  • Fehlercodes

Die Ausgabe erfolgt in einem eigenen Modul DirectX. Bei Fehlern wird der Fehlertext im Textfeld Error ausgegeben, bei Warnungen und Debug Hinweisen wird die entsprechende Meldung im Textfeld General ausgegeben:

  • Für das erfolgreiche Aufschalten eines Bildes wird mindestens eine DEBUG-Erfolgsmeldung ausgegeben.
  • Warnungen weisen auf Ereignisse hin, die den Betrieb beeinflussen können.
  • Tritt ein nicht behebbarer Fehler auf, wird eine Fehlermeldung (Error) ausgegeben.

info Info

Wird eine Meldung in der Tabelle im Diagnose Viewer nicht komplett angezeigt, öffnen Sie den Eintrag durch einen Doppelklick, um die gesamte Meldung anzuzeigen.

Checkliste für Fehlerüberprüfung

  • Eine entsprechende Überprüfung, ob DirectX funktioniert, kann durch das Aktivieren der Debug Meldungen im Diagnose Viewer durchgeführt werden. Bei erfolgreicher Unterstützung kommt eine entsprechende Meldung.
  • Kommen DirectX-spezifische Warnungen oder Fehlermeldungen im Diagnose Viewer?
  • Ist in der Projekteigenschaft Grafikqualität DirectX Hardware oder DirectX Software eingestellt?

    Interne ID: Fehlerbehandlung DirectX

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Fehlerbehandlung DirectX

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Interne ID: Fehlerbehandlung DirectX

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Werden die Mindestanforderungen an DirectX erfüllt? Details zur Mindestanforderung siehe Kapitel Grafikqualität.
    • Wird DirectX 11 vom Betriebssystem unterstützt?
    • Ist die aktuelle DirectX Runtime installiert?
    • Wird DirectX Hardware von der Grafikkarte unterstützt?

      Um die Grafikkartenunterstützung für DirectX Hardware zu überprüfen, kann das Windows Betriebssystem-Tool dxdiag.exe verwendet werden. Damit kann die DirectX Hardwarefähigkeit der Grafikkarte und des Treibers unter Anzeige mit dem Wert DDI-Version überprüft werden. Der Wert 11 zum Beispiel steht für DirectX 11.

  • Wird DirectX vom Bild bzw. Element unterstützt?
  • Funktioniert die Darstellung mit Windows Basis bzw. Windows Erweitert korrekt?
  • Funktioniert die Darstellung mit einem anderen Treiber korrekt?
  • Funktioniert die Darstellung mit einer Grafikkarte eines anderen Herstellers korrekt?


Bilder Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Bilder -> Bilder Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Bild neu | Fügt ein neues Bild zur Liste hinzu und setzt den Fokus auf diesen Eintrag.
Bild öffnen | Öffnet das Hauptfenster für das markierte Bild.
Standard-Funktion erzeugen | Öffnet den Assistenten zur Auswahl eines Bildes und zur Konfiguration der Details, um eine passende Funktion automatisch anzulegen. Die Aktion wird im Ausgabefenster dokumentiert.
Verknüpfte Elemente | Öffnet Dropdownliste mit Option Zurück zu Ausgangselement springen. Klick führt zu jenem Element zurück, von dem aus das Bild .ngesprungen wurde´
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien. Hinweis: Vorhandene Schablonen werden beim XML-Import über den Knoten Bilder nicht ersetzt. Beim XML-Import über den Knoten Schablonen werden vorhandene Schablonen überschrieben. In diesem Fall werden alle Bilder und deren Elemente an die neue Schablone angepasst.
Vorlage für Bildtyp erzeugen | Öffnet Dialog zum Anlegen eigener Vorlagen für das Einfügen von Kontrollelementen in den Bildtyp.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet den Dialog zum Suchen und Ersetzen von text in der ausgewählten Spalte.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag
Hilfe | Öffnet die Online-Hilfe.


Symbolleiste Bilder bearbeiten

Handbuch -> Bilder -> Symbolleiste Bilder bearbeiten

Für die Bearbeitung von Bildern steht eine Symbolleiste zur Verfügung. Diese wird standardmäßig unterhalb der Menüleiste angezeigt.

Symbol

(von links nach rechts)

Funktion

Bild speichern

Speichert das aktive Bild.

Alles speichern

Speichert alle geänderten Bilder.

Ausschneiden

Schneidet das aktive Bild aus und speichert es in der Zwischenablage, auch projektübergreifend. Nur verfügbar, wenn ein Element ausgewählt wurde.

Kopieren

Speichert eine Kopie des aktiven Bildes in der Zwischenablage. Nur verfügbar, wenn ein Element ausgewählt wurde.

Einfügen

Fügt ein Bild aus der Zwischenablage ein. Nur verfügbar, wenn die Zwischenablage Daten enthält.

Bild neu zeichnen

Aktualisiert die Bildschirmanzeige.

Bearbeitungsmodus

Schaltet von Zoom auf Bearbeitungsmodus um.

Rückgängig

Erlaubt es, bis zu 100 Aktionen rückgängig zu machen. Standardmäßig lassen sich 10 Aktionen rückgängig machen.

Die Anzahl der Aktionen definieren: Optionen -> Einstellungen ->Einstellungen -> Anzahl der rückgängig Aktionen. Tragen Sie hier eine Zahl zwischen 1 und 100 ein.

Zoom

Stellt zwei Zoom-Modi zur Verfügung:

  • Stufenloser Zoom:
    In der Combobox kann ein beliebiger Wert zwischen 15% und 400% eingegeben oder ein voreingestellter Wert ausgewählt werden.
  • Zoomtool:
    Über die beiden Lupensymbole (+ und -) wird im Bild per Mausklick direkt im Bild gezoomt. Drücken der Strg Taste schaltet zwischen den Modi um. Der eingestellte Zoom wird pro Bild gespeichert.

Zoom-Modus beenden: Klicken Sie auf das Symbol Bearbeitungsmodus. in der Symbolleiste Elemente.

Drucken

Der gesamte Bildschirminhalt wird auf dem als Standard gewählten Drucker ausgegeben. Druckereinstellung unter Datei -> Allgemeine Konfiguration -> Standard.

Hilfe

Ruft die Online Hilfe auf.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Elemente

Handbuch -> Bilder -> Symbolleiste Elemente

Nr. | Symbol | Funktion
01 | Rechteck | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
02 | Linie | mit definierbarer Linienstärke, -farbe und -art
03 | abgerundetes Rechteck | Rechteck mit frei definierbar abgerundeten Ecken
04 | Ellipse/Kreis | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster (Kreis)
05 | Polygon | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
06 | Polylinie | mit Linienart und -farbe (bei Flächenbeschreibung auch Füllmuster und -farbe)
07 | Kreisbogen | mit definierbarer Linienstärke, -farbe und -art
08 | Kreissegment | zeichnet Kreissegment mit Öffnungswinkel 180º (veränderbar), definierbarer Linienstärke, -farbe und -art
10 | Statischer Text | mit Schriftfarbe und Auswahl der Schriftart
09 | Rohrleitung | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
11 | Bargraf | Werte als Balkengrafik darstellen
12 | Zahlenwert | Werte numerisch darstellen
13 | Dynamischer Text | Grenzwerttexte anzeigen
14 | Trend-Element | einfache Liniengrafik
15 | Zeigerinstrument | Wert in Instrumentendarstellung
16 | Zustandselement | Farben aus der Zustandsprojektierung übernehmen
17 | Button | Aktionsfeld in Buttondarstellung
18 | Schalter | einfaches Befehls- bzw. Sollwertvorgabeelement
19 | Multibin | Darstellung mehrerer Prozessvariablen auf einem Bildpunkt in Farbe und Symbol (Zeichenkette)
20 | Bildalarmierung Button | Nur verfügbar mit einer SICAM 230 Lizenz
21 | Meldungselement | Darstellung von Texten aus einer Texttabelle
22 | Uhr | Datum und Uhrzeit
23 | Befehlsgabe-Element | Nur verfügbar mit einer SICAM 230 Lizenz
24 | Combi-Element | Darstellung einer oder mehrerer Variablen auf einem Bildpunkt in Farbe und Symbol (Zeichenkette)
25 | Bildalarmierung | Nur verfügbar mit einer SICAM 230 Lizenz
26 | ActiveX Element | AktivX-Elemente einfügen
27 | Universalregler | Schiebe- oder Drehregler
28 | Combo/Listbox | Werte von Variablen mit Textmeldungen verknüpfen
29 | WPF-Element | Stellt gültige WPF-XAML-Dateien dar.
30 | Bearbeitungsmodus | Schaltet aus Zoom in den Bearbeitungsmodus um
 | Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Kontextmenü Elemente

Handbuch -> Bilder -> Kontextmenü Elemente

Für die Elemente stehen Ihnen im Kontextmenü an die Situation angepasste Befehle zur Verfügung. Sie erreichen diese Befehle auch über Menüs und Symbolleisten.

Befehl

Beschreibung

Symbol

Öffnet Dropdownliste mit Befehlen. Je nach Symbolzustand sind verfügbar:

  • Eingebettetes Symbol erzeugen
  • Auflösen
  • In Einzelbearbeitungsmodus wechseln/Einzelbearbeitungsmodus verlassen
  • Einfügen in existierendes eingebettetes Symbol
  • Verknüpftes in eingebettetes Symbol konvertieren
  • Im Symboleditor bearbeiten
  • Einfügen in Symbolbibliothek
  • Eingebettetes Symbol erzeugen

Erzeugt ein eingebettetes Symbol.

  • Auflösen

Löst ein eingebettetes Symbol in seine Bildelemente auf.

  • In Einzelbearbeitungsmodus wechseln/Einzelbearbeitungsmodus verlassen

Wechselt in den Einzelbearbeitungsmodus oder zurück in den Symbolbearbeitungsmodus. Der Einzelbearbeitungsmodus erlaubt es, einzelne Elemente des Symbols zu bearbeiten.

  • Einfügen in existierendes eingebettetes Symbol...

Fügt Symbol in ein bereits existierendes eingebettetes Symbol ein.

  • Verknüpftes in eingebettetes Symbol konvertieren

Wandelt ein verknüpftes Symbol in ein eingebettetes um.

  • Bearbeiten im Symboleditor

Öffnet ein verknüpftes Symbol im Symboleditor, um es dort zu bearbeiten.

  • Einfügen in Symbolbibliothek

Öffnet Dialog, um Symbole aus einem Bild einer Symbolbibliothek hinzuzufügen.

Element Position

Öffnet Dropdownliste zum Ändern der Position des Elements:

  • Vordergrund: Verschiebt markierte Elemente in den Vordergrund
  • Hintergrund: Verschiebt markierte Elemente in den Hintergrund
  • Vorwärts: Verschiebt markierte Elemente um eine Ebene nach vorne
  • Rückwärts: Verschiebt markierte Elemente um eine Ebene nach hinten

Anordnen

Öffnet Dropdownliste zum neu Anordnen von Elementen.

Verknüpfte Elemente

Öffnet Dropdownliste mit dynamisch verknüpften Elementen, z.B.: Variablen, Funktionen, Schriften, Symbole usw.

Verknüpfungen ersetzen

Suchen/Ersetzen Funktion
z.B. Tank 1 Temperatur wird durch Tank 2 Temperatur ersetzt

Ausschneiden

Schneidet markierte Objekte aus und behält sie im Zwischenspeicher.

Kopieren

Kopiert markierte Objekte

Einfügen

Fügt kopierte oder ausgeschnittene Objekte aus dem Zwischenspeicher ein

An gleicher Position einfügen

Fügt kopierte oder ausgeschnittene Objekte aus dem Zwischenspeicher an der gleichen Position ein

Löschen

Löscht markierte Objekte

Format übertragen

Überträgt die Eigenschaften eines ausgewählten Elements auf ein anderes oder mehrere.

  • Übertragen auf ein Element:

    Klick auf Element mit Ursprungseigenschaften
    -> Klick auf Symbol Eigenschaften übertragen oder Befehl im Kontextmenü
    -> Klick auf Zielelement: Eigenschaften werden übertragen

  • Übertragen auf mehrere Elemente:

    Quellelement auswählen
    -> Zielelemente mit gedrückter Strg-Taste auswählen (Quell und Zielelemente sind markiert)
    > Klick auf Symbol Eigenschaften übertragen oder Befehl im Kontextmenü
    -> Eigenschaften des Quellelements werden auf die Zielelemente übertragen.

Welche Eigenschaften übertragen werden, ist abhängig von Quell- und Zielobjekt.

Wurden mehrere Elemente als Quelle gewählt, werden die Eigenschaften des ersten gewählten Elements übertragen.

Vollbildmodus

Der Vollbildmodus blendet alle übrigen Fenster aus und zeigt nur das Hauptfenster mit allen geöffneten Dokumenten (Bilder, Reporte, ...) als Vollbild über den ganzen Bildschirm an.

Der Vollbildmodus kann beendet werden über:

  • die eingeblendete Schaltfläche zum Beenden des Vollbildmodus
  • die Tastenkombination Umschalt+F9
  • die Taste Esc

Bild/Symbol neu zeichnen

Aktualisiert die Bildschirmanzeige.

Raster anzeigen

Schaltet die Anzeige des Rasters ein oder aus.

Raster verwenden

Schaltet Verwendung des Rasters ein oder aus.

Ein: Alle Objekte werden automatisch am Raster ausgerichtet.

Fangpunkte verwenden

Schaltet Fangpunkte ein oder aus.

Verwenden: Nähert man ein Objekt dem Anfasspunkt eines anderen Objektes, dann rastet das Objekt an diesem Anfasspunkt ein.

Zoomen

Ändert die Darstellungsgröße in festen Schritten zwischen 15 % und 400 %.

Screenshot aktuelles Bild/Symbol drucken

Das aktuelle Bild wird auf dem als Standard gewählten Drucker ausgegeben. Druckereinstellung unter Datei -> Allgemeine Konfiguration -> Standard.

Vektorgrafik einfügen

Öffnet den Dialog zum Einfügen einer externen Vektorgrafik.

Eigenschaften

Öffnet das Eigenschaftenfenster für das ausgewählte Element.

Hilfe

Öffnet die Online-Hilfe.


XML-Export und XML-Import

Handbuch -> Bilder -> XML-Export und XML-Import

Bilder exportieren

Mit den Bildern werden auch die darin enthaltenen Variablen und Funktionen exportiert. Die Export-Datei für die Bilder enthält:

  • Bilder
  • Schablonen
  • Symbole
  • Variablen
  • Funktionen

Um Bilder zu exportieren:

  1. markieren Sie die gewünschten Bilder
  2. wählen Sie im Kontextmenü der Detailansicht den Befehl Selektierte XML exportieren...
    Alternative: wählen Sie im Kontextmenü des Knotens Bilder den Befehl XML exportieren alle...
  3. der Auswahldialog für den Speicherort wird geöffnet
  4. wählen Sie den gewünschten Speicherort
  5. vergeben Sie einen Namen
  6. achten Sie auf den Dateityp XML
  7. bestätigen Sie mit Klick auf die Schaltfläche Speichern

Die ausgewählten Bilder werden in eine XML-Datei exportiert und können jederzeit in dieses oder andere Projekte wieder importiert werden.

Bilder importieren

Um Bilder zu importieren:

  1. wählen Sie im Kontextmenü des Knotens Bilder oder der Detailansicht Bilder den Befehl XML importieren
  2. der Auswahldialog für den Speicherort wird geöffnet
  3. navigieren Sie zum Speicherort der gewünschten XML-Datei
  4. wählen Sie die gewünschte Datei aus
  5. bestätigen Sie den Import mit Klick auf die Schaltfläche Öffnen

Die Bilder werden importiert.

Namenskonflikt beim Import

Beim Importieren eines Bildes wird der in der XML-Datei hinterlegte Name (Attribut ShortName) für die Benennung des neu anzulegenden Bildes verwendet. Existiert bereits ein Bild mit dem selben Namen, wird der Import unterbrochen und eine Fehlermeldung angezeigt:

Parameter | Beschreibung
Ja | Das in der Fehlermeldung genannte Bild wird beim Import durch das Bild aus der XML-Datei ersetzt. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Nein | Das in der Fehlermeldung genannte Bild wird nicht importiert, das bereits vorhandene Bild wird beibehalten. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Ja alle | Das in der Fehlermeldung genannte Bild wird beim Import durch das Bild aus der XML-Datei ersetzt. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Bilder werden ersetzt.
Nein alle | Das in der Fehlermeldung genannte Bild wird nicht importiert, das bereits vorhandene Bild wird beibehalten. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Bilder werden beibehalten.

Hinweis: Es wird nur der ShortName verwendet. Der Dateiname spielt für die Benennung des zu importierenden Bildes keine Rolle, kann also zur Konfliktlösung nicht verwendet werden.

Variablen und Funktionen in Bildern

Dynamische Elemente und Schablonen werden automatisch mit Bildern automatisch importiert. Variablen und Funktionen müssen vorher separat aus dieser Datei importiert werden.

Es werden dabei nur Variablen und Funktionen der ersten Ebene berücksichtigt, d.h. Variablen und Funktionen die direkt im Bild verknüpft sind. Da sich einerseits Funktionen auf Variablen beziehen können (z.B. Sollwert setzen) andererseits aber auch Variablen auf Funktionen (z.B. Grenzwert-Funktionen), kann es nötig sein, zuerst die Variablen, dann die Funktionen und dann noch einmal die Variablen zu importieren. Erst dann werden sämtliche Verknüpfungen korrekt übernommen.

Beispiel: Ein Bild enthält einen Button mit einer Funktion Sollwert absetzen auf eine Variable. Mit dem Bild wird die Funktion importiert, nicht aber die Variable.

info Info

Hier empfiehlt sich der Einsatz des XML Import Wizards.


Bildelemente

Handbuch -> Bilder -> Bildelemente

In zenon nutzen Sie zwei Arten von Bildelementen:

  1. statische Vektor-Elemente
  2. Dynamische Elemente

Beim Bearbeiten von Bildelementen stehen Ihnen viele Tastenkombinationen zur Verfügung. Details finden Sie in der Hilfe im Abschnitt Tastenkombinationen Grafik.

In diesem Abschnitt finden Sie Informationen zu:

  • Einfügen in das Hauptfenster
  • Eigenschaften definieren
  • Element Größe ändern
  • Element drehen
  • Reihenfolge zur Runtime
  • Vektor-Elemente in zenon
  • Dynamische Elemente in zenon

Einfügen in das Hauptfenster

Das ausgewählte Element kann mehrmals im Hauptfenster eingefügt und dort angeordnet werden. Welches Element ausgewählt und damit aktiv ist, zeigt ein Symbol unter der Spitze des Mauszeigers. Um das Element aufzuziehen:

  1. linke Maustaste drücken
  2. Maus ziehen
  3. Maustaste loslassen

Ausnahme: Polylinie, Polygon und Rohrleitung

  • ein Mausklick fügt eine neue Stützstelle ein
  • ein Doppelklick oder die Esc Taste beendet das Aufziehen

Elemente können mit der Maus frei gedreht werden, dazu:

  1. mit der Maus auf das Element klicken
  2. mit dem gelben Anfasspunkt drehen

Der Anfasspunkt und damit auch der Drehpunkt kann bei den Eigenschaften Bezugspunkt eingestellt werden.

Interne ID: Bildelemente

Bezugspunkt

Bestimmt den Startpunkt für die Berechnung des Drehwinkels bzw. der dynamischen Größenänderung des Elements.

ACHTUNG: Bei nicht rechteckigen Elementen beziehen sich die Angaben immer auf das umschließende Rechteck.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaften definieren

Für Elemente im Hauptfenster werden die Eigenschaften im Eigenschaften-Fenster eingestellt. Dazu muss das entsprechende Element im Hauptfenster aktiviert sein.

Sie können auch mehrere Elemente gleichzeitig auswählen und diesen gemeinsam Eigenschaften zuweisen. Dabei gilt:

  • Unterschiedliche Werte bei verschiedenen Eigenschaften werden rot hervorgehoben.
  • Eigenschaften, die nicht gemeinsam geändert werden können, sind deaktiviert.

Beim Erstellen der Elemente erhalten Sie zu den Eigenschaften auch kurze Hilfeanweisungen. Aktivieren Sie dazu in zenon das Hilfe-Fenster.

Element Größe ändern

Um die Größe eines Elements zu ändern, können Maus, Tastatur, Eigenschaften oder ein Dialog benutzt werden:

  • Mit der Maus:
    1. klicken Sie auf einen der Griffe des Elementrahmens
    2. ziehen Sie das Element auf die gewünschte Größe
  • Mit der Tastatur:
    • aktivieren Sie den gewünschten Anfasspunkt (Mauszeiger muss sich über Anfasspunkt befinden)
    • ziehen Sie mit den Pfeiltasten:
    • Ein Druck an einer Pfeiltaste ändert die Position um 1 Pixel.
    • Mit Taste Umschalt: + Pfeiltaste: Ein Druck an einer Pfeiltaste ändert die Position um 10 Pixel.
  • Mit dem Eigenschaftenfenster: In der Eigenschaftengruppe Position können Sie die Position und Größe der Elemente pixelgenau festlegen.

    Interne ID: Bildelemente

    Position

    Eigenschaften zu Position und Größe des Dynamischen Elements.

    Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Mit einem Dialog: Doppelklick auf einen Anfasspunkt öffnet einen Dialog, in dem Sie die Position pixelgenau festlegen können.

Element drehen

Elemente können können frei gedreht werden. Der Drehpunkt wird mit den Eigenschaften in der Gruppe Bezugspunkt eingestellt.

Den Drehwinkel stellen Sie wie folgt ein:

  • Mit der Maus: Auf das Element klicken und mit dem grünen Anfasspunkt drehen.
  • Mit dem Eigenschaftenfenster: Mit der Eigenschaft Drehwinkel [°] in der Gruppe Position.

    Interne ID: Bildelemente

    Drehwinkel [°]

    Frei definierbarer Winkel, um den das Element gedreht wird. Positive Werte drehen gegen den Uhrzeigersinn, negative Werte im Uhrzeigersinn. Werte über 360° werden als Differenz zu 360° dargestellt (400° entspricht 40°). Es können nur ganze Zahlen eingetragen werden.

    Bei gedrehten Elementen sind folgende Aktionen nicht mehr möglich:
    - spiegeln
    - rotieren um +/- 90°
    - skalieren per Pfeiltasten

    Default: 0

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Mit einem Dialog: Durch einen doppelklick auf den grünen Anfasspunkt öffnet sich ein Dialog, in dem Sie den Drehwinkel eingegeben können.

info Info

Fensterbasierte Bildelemente wie ActiveX, Listen oder Combo-/Listbox können zur Runtime nicht gedreht werden. Die Konfiguration im Editor ist für ActiceX möglich, hat aber keine Auswirkung auf die Darstellung zur Runtime.

Reihenfolge zur Runtime

Zur Runtime gilt in der Regel folgende Reihenfolge bei der Darstellung von Elementen, von oben nach unten:

  • WPF Element, immer im Vordergrund
  • ActiveX Element, immer im Vordergrund, ausgenommen es wird von einem WPF Element überlagert
  • Dynamische Elemente und Vektorelemente

Verdeckte Elemente

Bei sich überlagernden Elementen gilt:

  • Überlagert ein Vektorelement ein Dynamisches Element, so:
    • wird das Dynamische Element oder der überlagerte Teil nicht angezeigt
    • bleibt das Dynamische Elemente, auch wenn es vollständig verdeckt ist, bedienbar.
  • Liegen mehrere Dynamische Elemente übereinander, sind immer nur die sichtbaren (klickbaren) Teile bedienbar.

info Info

Elemente, die zur Runtime verdeckt werden, können mit der der Tastatur angesteuert werden. Details zur Projektierung siehe Handbuch Runtime, Kapitel Reihenfolge innerhalb Schablone festlegen.

Vektor-Elemente in zenon:

Vektorelemente erzeugen Sie in zenon mit dem Zeicheneditor. In der Symbolleiste Elemente oder in der Dropdownliste Elemente wählen Sie das gewünschte Element und platzieren es mit der Maus im Hauptfenster. Über das Fenster Eigenschaften konfigurieren Sie die Eigenschaften. Dazu muss das Element im Hauptfenster ausgewählt sein.

Element | Eigenschaften
Ellipse | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
Kreis | Symbol Ellipse wählen, beim Zeichnen Umschalt gedrückt halten; mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
Kreisbogen | mit definierbarer Linienstärke, -farbe und -art
Kreissegment | mit definierbarer Linienstärke, -farbe und -art
Linie | mit definierbarer Linienstärke, -farbe und -art
Polygon | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
Polylinie | mit Linienart und -farbe (bei Flächenbeschreibung auch Füllmuster und -farbe)
Quadrat | Symbol Rechteck wählen, beim Zeichnen Umschalt gedrückt halten; Rahmen- und Füllfarbe; Rahmenart und Füllmuster
Rechteck | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster.
abgerundetes Rechteck | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster; Rundungsgrad
Rohrleitung | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
Statischer Text | mit Schriftfarbe und Auswahl der Schriftart

Import eigener Vektorgrafiken

Vektor-Elemente, die in externen Programmen erzeugt wurden, können als Bild importiert und eingebunden werden. Benutzen Sie dazu im Projektmanager den Abschnitt Dateien -> Grafiken -> Datei hinzufügen.

Dynamische Elemente in zenon

Dynamische Bildelemente erzeugen Sie in zenon mit dem Zeicheneditor. In der Symbolleiste Elemente oder in der Dropdownliste Elemente wählen Sie das gewünschte Element und platzieren es mit der Maus im Hauptfenster. Über das Fenster Eigenschaften konfigurieren Sie die Eigenschaften. Dazu muss das Element im Hauptfenster aktiviert sein. Graphische Elemente lassen sich hier direkt über Variablen dynamisieren. Für viele Elemente wird beim Erstellen ein Konfigurationsdialog eingeblendet.

Dynamische Elemente in zenon:

Element

Funktion

ActiveX

Fügt ein beliebiges AktivX Elemente ein. Dieses muss bereits am Rechner installiert sein.

Bargraf

Stellt die Größe eines Signales in Balkenform dar. Dabei verändert sich die Länge eines Balkens mit der Signalgröße.

Befehlsgabe-Element

Ermöglicht das Absetzen von Befehlen für das Modul Befehlsgabe. Benötigt Lizenz für SICAM 230.

Bildalarmierung Button

Ermöglicht Alarmierung über Bild mit Farbe und Blinken. Benötigt Lizenz für SICAM 230.

Bitmap Button

Verknüpft eine Grafikdatei (Pixelgrafik: *.bmp, *.jpg, *.gif, oder *.png bzw. Vektorgrafik: *.wmf) mit einem Button.

Achtung! Dieses Element steht nur zur Verfügung, wenn die Projekteigenschaft RT Dateien erzeugen für auf kleiner als 6.50 eingestellt wurde. Ab Version 6.50 ist diese Funktionalität in das Element Button integriert.

Interne ID: Bildelemente

RT Dateien erzeugen für

Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt

6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.

6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.

6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.

6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.

6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.

6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.

6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Button

Ermöglicht es, Aktionen wie z. B. Funktion ausführen oder Sollwert setzen auszulösen. Er kann Text und Grafiken darstellen und als transparentes Objekt über andere Elemente gelegt werden.

Achtung! Wenn die Projekteigenschaft RT Dateien erzeugen für auf kleiner 6.50 eingestellt wurde, werden nur Textausgaben in der Runtime angezeigt. Grafiken und die Funktion unsichtbar müssen dann mit den Elementen Bitmap Button und Unsichtbarer Button projektiert werden. Diese beiden Elemente finden Sie dann in der Dropdownliste Elemente ganz unten.

Combi-Element

Stellt Zustände von Variablen über Symbole, Bilder und Texte bildlich dar und kann auch als Schalter bzw. als Button eingesetzt werden.

Combo-/Listbox

Zeigt abhängig vom Variablenwert einen Text in einer Combobox oder einer Listbox an. Mit Auswahl eines Eintrags wird der dazugehörige Wert abgesetzt oder die dazugehörige Funktion ausgeführt.

Dynamischer Text

Stellt den Wert einer Stringvariablen in alphanumerischer Form dar oder den aktuellen Grenzwerttext von numerischen Variablen.

Meldungselement

Liest abhängig von den Werten zweier Variablen Text aus einer Textdatei aus und zeigt diesen an.

Multibin

Ermöglicht es, abhängig von Variablenwerten eine Grafik anzuzeigen oder Symbole einzufärben und einen Zustandstext auszugeben.

Schalter

Zeigt Werte einer Binärvariablen an und modifiziert diese.

Symbol bewegen

Ermöglicht es, ein Symbol abhängig von Variablenwerten zu verschieben, drehen und in der Größe zu ändern.

Trend-Element

Stellt Werte in Form von Trendkurven dar.

Uhr

Zeigt die aktuelle Uhrzeit und das Datum an.

Universalregler

Stellt Regler in verschiedensten grafischen Ausprägungen zur Verfügung.

Unsichtbarer Button

Transparentes Objekt, mit dem eine Aktion wie z. B. Funktion ausführen oder Sollwert setzen ausgelöst werden kann.

Achtung! Dieses Element steht nur zur Verfügung, wenn die Projekteigenschaft RT Dateien erzeugen für auf kleiner als 6.50 eingestellt wurde. Ab Version 6.50 ist diese Funktionalität in das Element Button integriert.

WPF-Element

Stellt WPF-XAML-Dateien in zenon dar.

Zahlenwert

Stellt den Wert einer Variablen in numerischer Form dar.

Zeigerinstrument

Stellt den Wert einer Variablen in Form eines analogen Messgeräts dar mit einem Zeiger als Anzeigeelement dar.

Zustandselement

Überträgt Eigenschaften von verknüpften Variablen auf ein Symbol und zeigt statische Grenzwertexte an.

Eigenschaften definieren

Bei vielen Dynamischen Elementen öffnet sich ein Konfigurationsdialog zur Auswahl von Variablen und/oder Funktionen, die das Verhalten des Elements zur Runtime definieren. Die Eigenschaften können auch unabhängig vom Konfigurationsdialog im Eigenschaften-Fenster eingestellt werden. Dort lassen sie sich auch jederzeit ändern. Dazu muss das entsprechende Element im Hauptfenster aktiviert sein.

Sie können auch mehrere Elemente gleichzeitig auswählen und diesen gemeinsam Eigenschaften zuweisen. Dabei gilt:

  • Unterschiedliche Werte bei verschiedenen Eigenschaften werden rot hervorgehoben.
  • Eigenschaften, die nicht gemeinsam geändert werden können, sind deaktiviert.

Beim Erstellen der Elemente erhalten Sie zu den Eigenschaften auch kurze Hilfeanweisungen. Aktivieren Sie dazu in zenon die Eigenschaftenhilfe.

Anzeige im Hauptfenster

Informationen zu einem Dynamischen Element erhalten Sie im Hauptfenster durch:

Tooltip bei Mouseover:

  • Elementtyp
  • Elementname
  • Funktionsname/Funktionsart
  • verknüpfte Variablen

In der Statusleiste bei Aktivierung:

  • Position Mauszeiger
  • Elementtyp
  • Elementname
  • Startpunkt
  • Breite/Höhe

Noch in diesem Kapitel

.NET Controls

ActiveX

Bargraf

Befehlsgabe-Element

Bildalarmierung Button

Button

Combi-Element

Combo-/Listbox

Dynamischer Text

Ellipse

Kreis

Kreisbogen

Kreissegment

Linie

Meldungungselement

Multibin

Polygon

Polylinie

Rechteck

Quadrat

Rohrleitung

Schalter

Statischer Text

Symbol bewegen (nur bis Version 6.22)

Trend-Element

Uhr

Universalregler

WPF-Element

Zahlenwert

Zeigerinstrument

Zustandselement


.NET Controls

Handbuch -> Bilder -> Bildelemente -> .NET Controls

Das ActiveX Control CD_DotNetControlContainer.Container ermöglicht es, beliebige .NET Windows Forms Controls als Dynamisches Element in zenon zu verwenden. Dabei werden alle im .NET Control implementierten Funktionen unterstützt. Es kann mit allen zenon Versionen ab 5.50 verwendet werden, die ActiveX unterstützen.

Hinweis: .NET Framework 3.5 muss vorhanden sein.

info Info

Mehr über die Nutzung von .NET mit zenon lesen im Handbuch Programmierschnittstellen im Kapitel .NET.

Um das ActiveX Control CD_DotNetControlContainer.Container zu verwenden:

  1. legen Sie en Dynamisches Element vom Typ ActiveX an
  2. wählen Sie in der Liste der vorhandenen Control CD_DotNetControlContainer.Container
  3. klicken Sie auf die Schaltfläche Eigenschaften
  4. der Dialog zur Konfiguration des Controls öffnet sich

Parameter | Beschreibung
Load | Öffnet Dateimanager zur Auswahl einer .NET Control Assembly. Hinweis: Die .NET Control Assembly muss sich im selben Ordner wie die Runtime befinden. Es wird immer der absoluter Pfad zur .NET Control Assembly gespeichert, z.B: C:\Controls\Assembly.dll.
SelectUserControl | Auswahl des .NET Controls aus den im selektierten .NET Control Assembly verfügbaren Controls.
Preview | Zeigt absoluten Pfad zur .NET Control Assembly an. Feld links darunter: Vorschau auf das Control. Feld rechts darunter: Eigenschaftenliste für das ausgewählte .NET Control.
Symbol: Nach Kategorien | Zeigt Eigenschaften nach Kategorien sortiert an.
Symbol: Alphabetisch | Zeigt Eigenschaften alphabetisch sortiert an.
Symbol: Eigenschaftenseiten | Zeigt Eigenschaftenseiten an.
OK | Bestätigt Konfiguration. Diese wird dann im zenon ActiveX Element als XML Stream gespeichert.
Abbrechen | Konfiguration verwerfen.


ActiveX

Handbuch -> Bilder -> Bildelemente -> ActiveX

Mit dem Dynamischen Element ActiveX binden Sie ActiveX Elemente in Projekte ein.

info Info

Mehr über die Nutzung von ActiveX mit zenon lesen im Handbuch Programmierschnittstellen im Kapitel ActiveX.

Um ein ActiveX in einem Bild anzulegen:

  1. wählen Sie das Symbol ActiveX in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Steuerelement auf
  4. ein Konfigurationsdialog öffnet sich, in dem Sie das Element wählen und konfigurieren
  5. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  6. halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt

Einzelne Eigenschaften des Elements definieren Sie im Eigenschaftenfenster. Dazu muss das Element im Hauptfenster aktiv sein (Mausklick). Um Controls nachträglich auszuwählen oder zu ändern, öffnen Sie den Konfigurationsdialog mit Doppelklick oder dem Menüpunkt Eigenschaften im Kontextmenü.

attention Achtung

Es werden nur ActiveX Elemente angezeigt, die auf dem Rechner installiert bzw. registriert sind. Beachten Sie, dass alle verwendeten ActiveX Elemente auch auf allen Runtime-Systemen, auf denen Sie das Projekt einsetzen, installiert ist.
Zum Registrieren von ActiveX Elementen auf Remote Systemen können Sie auch den Remote Transport verwenden. Siehe: Dateien festlegen (Kopieren&Registrieren)

Konfiguration ActiveX

Element | Funktion
ActiveX Elemente | Liste aller verfügbaren ActiveX Elemente.
Eigenschaften | Öffnet, wenn vorhanden, einen Konfigurationsdialog für das markierte ActiveX. Informationen und Hilfe zur Konfiguration erhalten Sie vom Hersteller des jeweiligen ActiveX Controls.
Variablenzuordnung | Liste der dem ActiveX Element zugeordneten Variablen.
Variable | Öffnet, wenn Variablenzuordnung möglich ist, den zenon Dialog zur Variablenauswahl.
Nach unten | Sortiert markierte Variable nach unten.
Nach oben | Sortiert markierte Variable nach oben.

Positionsänderung zur Runtime

ActiveX-Controls arbeiten zur Runtime mit untransformierten Mauskoordinaten. Wird ein Element gedreht, gestreckt oder anderweitig in seiner Größe oder Position verändert, passt sich das Control nicht an und wir weiter an der ursprünglichen Position ausgeführt. Das transformierte Element kann damit an seiner transformierten Position nicht mehr über das Control bedient werden.

info Info

Beachten Sie den Unterschied zwischen windowed und windowless ActiveX Elementen.

Windowed ActiveX Elemente (z.B. alle Microsoft ActiveX Controls) liegen immer im Vordergrund.

Über windowless ActiveX Elemente kann dagegen z.B. ein Dynamisches Element drüber gelegt werden.


Bargraf

Handbuch -> Bilder -> Bildelemente -> Bargraf

Mit dem Dynamischen Element Bargraf zeigen Sie die Größe eines Signals numerisch an. Die Länge des Balkens verändert sich zur Runtime mit der Signalgröße.

Um einen Bargraf in einem Bild anzulegen:

  1. wählen Sie das Symbol Bargraf in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl einer Variablen öffnet sich
  5. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  6. halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt

Einzelne Eigenschaften des Elements definieren Sie im Eigenschaftenfenster. Dazu muss das Element im Hauptfenster aktiv sein (Mausklick).

Um die verknüpfte Variable zu ändern:

  1. öffnen Sie in der Detailansicht des Projektmanagers die Variablen
  2. ziehen Sie die gewünschte Variable mit gedrückter linker Maustaste auf das Element
  3. die bisherige Variable wird durch die neue ersetzt

Farbliche Darstellung der Grenzwertverletzung

Bei Grenzwertverletzungen kann die Farbe aus der Variablen den gesamten Bereich einfärben oder nur den Bereich ab der Grenzwertverletzung. Gesteuert wird diese Funktionalität über die Eigenschaft Explizit in der Gruppe Darstellung.

Interne ID: Bargraf

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bargraf

Explizit

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv

Hinweis: Beim Element Zeigerinstrument nur verfügbar, wenn die Darstellung als Band oder Teilkreis aktiv ist.

Interne ID: Bargraf

Teilkreis

Nur verfügbar, wenn die Anzeige als Band nicht aktiv ist:
Aktiv: Der Wert wird mit einem Teilkreis vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Teilkreis wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bargraf

Band

Nur verfügbar, wenn die Anzeige als Teilkreis nicht aktiv ist.

Unter Windows CE nicht verfügbar.
Aktiv: Der Wert wird mit einem Band vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Band wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv


Befehlsgabe-Element

Handbuch -> Bilder -> Bildelemente -> Befehlsgabe-Element

Ermöglicht das Absetzen von Befehlen für das Modul Befehlsgabe. Benötigt Lizenz für SICAM 230.

Anleitungen zur Nutzung des Elements finden Sie in der Hilfe zu SICAM 230.


Bildalarmierung Button

Handbuch -> Bilder -> Bildelemente -> Bildalarmierung Button

Achtung: Der Bildalarmierung Button benötigt eine Lizenz für SICAM 230. Weitere Anleitungen zur Nutzung des Elements finden Sie in der Hilfe zu SICAM 230.


Button

Handbuch -> Bilder -> Bildelemente -> Button

Mit dem Dynamischen Element Button erstellen Sie einen frei einstellbaren Button, den Sie im Bild interaktiv nutzen, um entweder eine Funktion auszuführen oder als Schalter für eine binäre Variable.

Der Button kann

  • eine Grafikdatei darstellen
  • eine Grafikdatei anmieren
  • unsichtbar dargestellt werden

info Info

Bis inklusive Version 6.22 werden Buttons unterteilt in Text Button, Bitmap Button und Unsichtbarer Button. Ab Version 6.50 sind alle mit Buttons projektierbaren Eigenschaften im Element Button zusammengefasst.

Um das Dynamische Element Button in einem Bild anzulegen:

  1. wählen Sie das Symbol Button in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Funktionen Auswahldialog öffnet sich
  5. wählen Sie die gewünschte Funktion
  6. definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften

    Tipp: Sie können die Ecken beliebig runden

  7. Variablen fügen Sie per Drag&Drop hinzu

Beschriftung

Um den Button zu beschriften:

  • klicken Sie in das Element
  • geben Sie Text ein
  • definieren Sie im Knoten Darstellung die Texteigenschaften

    Interne ID: Button

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Unterstreichen

Um Text zu unterstreichen, stellen sie dem zu unterstreichenden Zeichen ein & vor.

T&ext wird zu:

Möchten Sie das Zeichen '&' im Text benutzen, geben Sie es doppelt ein:
1 && 2 wird zu 1 & 2.

Zeilenumbruch

Um einen Zeilenumbruch festzulegen, benutzen Sie die Zeichenfolge \n.

Beispiel:

Zeile 1 \n

Zeile 2

Button als Schalter

Um den Button als Schalter zu verwenden:

  1. aktivieren Sie im Knoten Sollwert absetzen die Eigenschaft Schalter

    Interne ID: Button

    Schalter

    Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

    Interne ID: Button

    SW setzen aktiv

    Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
    Inaktiv: In diesem Element ist die Variable schreibgeschützt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Aktiv: Das Element schaltet den Wert einer Bit-Variable.
    Inaktiv: Das Element führt eine Funktion aus.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Button

    Sollwert absetzen

    Eigenschaften zum Setzen von Sollwerten.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. mit der Eigenschaft Taster aktivieren Sie die Einstellungen, um den Button als Taster zu verwenden

    Interne ID: Button

    Taster

    Nur verfügbar, wenn Schalter aktiv ist. (Ausnahme: Im Dynamischen Element Schalter immer verfügbar.)
    Aktiv: Der Sollzustand - definiert in der Eigenschaft Taster EIN - wird nur solange hergestellt, wie die linke Maustaste gedrückt bleibt, aber mindestens die Haltezeit [ms] lang.
    Inaktiv: Der Sollzustand bleibt, auch wenn die Maustaste losgelassen wird.
    Default: inaktiv.

    Interne ID: Button

    Haltezeit [ms]

    Nur verfügbar, wenn Schalter aktiv ist:
    Wenn Taster aktiv ist: Zeit (in ms), die ein Zustand gehalten wird, ausgehend vom Linksklick auf das entsprechende Element.

    Wenn Taster inaktiv ist: Reaktionsverzögerung auf Linksklick.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Button

    Taster EIN

    Nur verfügbar, wenn Taster aktiv ist:
    Aktiv: Taster schaltet auf EIN.
    Inaktiv: Taster schaltet auf AUS.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. verknüpfen Sie den Button mit einer binären Variablen (Knoten Variable / Funktion, Eigenschaft Variable)

    Interne ID: Button

    Variable

    Für Buttons nur verfügbar, wenn sie als Schalter verwendet werden:
    Name der verknüpften Variable.
    Öffnet den Variablenauswahldialog.
    Der Wert dieser Variable wird in diesem Element angezeigt und kann hier auch gesetzt werden.

    Nur SICAM 230 und Element Bild-Alarmierung:
    Die obige Beschreibung betrifft nur die Elemente Textbutton, Bitmapbutton und Unsichtbarer Button.

    Bedeutung in SICAM 230:
    Auf die ausgewählte Variable (32 Bit) werden die Zustände der Alarm/Ereignis-Klassen abgebildet. Je Klasse werden 2 Bits beschrieben (nach Klassennummer aufsteigend).

    Niederwertiges Bit: Alarm aktiv/inaktiv

    Höherwertiges Bit: Alarm quittiert/unquittiert

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Button

    Variable / Funktion

    Eigenschaften für die mit dem Element verknüpfte Variable oder Funktion.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Button zur Ausführung einer Funktion

Um den Button mit einer Funktion zu verknüpfen:

  1. deaktivieren Sie im Knoten Sollwert absetzen die Eigenschaft Schalter
  2. verknüpfen Sie den Button mit einer Funktion (Knoten Variable / Funktion, Eigenschaft Funktion)

    Interne ID: Button

    Funktion

    Name der verknüpften Funktion.
    Öffnet den Funktionsauswahldialog.
    Diese Funktion wird ausgeführt, wenn der Button in der Runtime mit der Maus angeklickt oder die verknüpfte Tastenkombination gedrückt wird.
    Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

    Nur SICAM 230 und Element Bild-Alarmierung:

    Zusätzlich zur Standardeigenschaft Bildumschaltung wird durch die verknüpfte Funktion das Bild ermittelt, dessen Alarmzustände angezeigt werden sollen.
    Obligat (außer bei Einstellung Global aktiv)!

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Button mit Grafik

Um den Button mit einer Grafik auszustatten:

  1. aktivieren Sie das Element
  2. definieren Sie im Knoten Darstellung über die Eigenschaften Grafikdatei und "Grafik Button gedrückt" die gewünschten Grafiken für die unterschiedlichen Schalterzustände. Sie können folgende Grafikdateien einsetzen: Pixelgrafik: *.bmp, *.jpg, *.gif, oder *.png bzw. Vektorgrafik: *.wmf.

    Interne ID: Button

    Grafikdatei

    Grafik, die auf dem Button im ungedrückten Zustand dargestellt werden soll (*.bmp, *.wmf, *.jpg, *.gif, *.png). Klick auf die Schaltfläche ... öffnet den Dateiauswahldialog.
    Achtung: Bilder müssen im Projektmanager im Knoten Dateien/Grafiken bereits vorhanden sein.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Standardmäßig hat ein Button mit Grafik eine dünne 3D-Rahmenlinie, die auf jeder Seite der Grafik einen Pixel verdeckt. Soll die Grafik ganz sichtbar sein, dann:

  • aktivieren Sie in den Eigenschaften des Buttons in der Gruppe Farben die Eigenschaft Transparenz Rahmenfarbe [%]

    Interne ID: Button

    Transparenz Rahmenfarbe [%]

    Nur verfügbar, wenn die EigenschaftÜber Helligkeitswerte nicht aktiviert wurde.

    Interne ID: Button

    Über Helligkeitswerte

    Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
    Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

    Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

    Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

    Interne ID: Button

    Füllmuster

    Auswahl des Füllmusters für das Element aus der Liste.

    Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Nur verfügbar, wenn die Projekteigenschaft Grafikqualität aktiviert ist.

    Interne ID: Button

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Button

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Interne ID: Button

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert über einen Wert zwischen 0 und 100 Prozent die Deckkraft der Farbe.

    0: unsichtbar

    100: deckend.

    Alle Werte dazwischen erscheinen je nach Einstellung transparent.

    Default: 0

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Button

    Farben

    Farbeigenschaften des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • mit dem Wert 100

    oder

  • aktivieren Sie die Eigenschaft Transparent, um Hintergrundfarbe und Rahmenfarbe zu deaktivieren

    Interne ID: Button

    Transparent

    Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

    Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Damit wird die 3D-Rahmenlinie nicht angezeigt und die ganze Grafik ist sichtbar.

Unsichtbarer Button

Um eine interaktive, transparente Bedienfläche zu definieren:

  1. aktivieren Sie das Element
  2. definieren Sie im Knoten Farben die Eigenschaft Transparent
  3. entfernen Sie alle Beschriftungen aus dem Button
  4. Zugriff zur Runtime:
    • der Mauszeiger ändert sich beim Bewegen der Maus über das Element
    • über eine definierte Tastenkombination (Knoten Runtime, Eigenschaft Tastenkombination)

      Interne ID: Button

      Tastenkombination

      Tastenkombinationen unterstützen das Ausführen bedienbarer Bildelemente. Zum Beispiel:

      - Ausführen von Kontrollelementen und Funktionen, die einem Element zugewiesenen wurden
      - Sollwert Absetzen (z. B. bei Schalter)
      - Fokus setzen bei bestimmten Fenstern (z.B. Kurvenliste im Erweiteren Trend oder Comboboxen im RGM)

      Klick auf Eingabefeld öffnet Dialog zur Definition der Tastenkombination. Im Dialog wird die gewünschte Kombination direkt eingegeben.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Button

      Runtime

      Eigenschaften für das Runtime-Verhalten des Elements.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Beim unsichtbaren Button kann der Status der Variablen nicht angezeigt werden.

Noch in diesem Kapitel

Grafiken animieren

Bitmap Button (nur bis Version 6.22)

Unsichtbarer Button (nur bis Version 6.22)


Grafiken animieren

Handbuch -> Bilder -> Bildelemente -> Button -> Grafiken animieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Dynamischen Element Button können Grafikdateien vom Typ GIF animiert werden:

  1. weisen Sie dem Button im Knoten Darstellung über die Eigenschaft Grafikdatei eine GIF-Datei zu

    Interne ID: Grafiken animieren

    Grafikdatei

    Grafik, die auf dem Button im ungedrückten Zustand dargestellt werden soll (*.bmp, *.wmf, *.jpg, *.gif, *.png). Klick auf die Schaltfläche ... öffnet den Dateiauswahldialog.
    Achtung: Bilder müssen im Projektmanager im Knoten Dateien/Grafiken bereits vorhanden sein.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Grafiken animieren

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. wählen Sie im gleichen Knoten die Eigenschaft GIF-Animation

    Interne ID: Grafiken animieren

    GIF-Animation

    Eigenschaften für die Animation, wenn eine animierte GIF Datei verwendet wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie zwischen Immer oder Animation nur wenn eine Bool Variable den Wert 1 besitzt: Verknüpfen Sie dazu Variable beid er Eigenschaft Variable

    Interne ID: Grafiken animieren

    Variable

    Bit-Variable, die die Animation ein und aus schaltet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Grafiken animieren

    Immer

    Aktiv: Die Animation läuft immer.
    Inaktiv: Die Animation wird nicht ausgeführt. Optional kann mit einer verknüpften Variable die Animation ein- und ausgeschalten werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Bitmap Button (nur bis Version 6.22)

Handbuch -> Bilder -> Bildelemente -> Button -> Bitmap Button (nur bis Version 6.22)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verknüpft eine Grafikdatei (Pixelgrafik: *.bmp, *.jpg, *.gif, oder *.png bzw. Vektorgrafik: *.wmf) mit einem Button.

Wenn die Projekteigenschaft RT Dateien erzeugen für auf kleiner 6.50 eingestellt wurde, kann das Element Button nur Texte in der Runtime anzeigen. Grafiken müssen in diesem Fall über den Bitmap Button projektiert werden.

Interne ID: Bitmap Button (nur bis Version 6.22)

RT Dateien erzeugen für

Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt

6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.

6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.

6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.

6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.

6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.

6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.

6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Buttons projektieren für unterschiedliche Runtimeversionen:

Button für | RT Dateien erzeugen für < 6.50 | ab 6.50
Text | Button | Button
Grafik | Bitmap Button | Button
unsichtbar | Unsichtbarer Button | Button

Um einen Bitmap Button zu aktivieren:

  • wählen Sie das Symbol Bitmap Button in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  • wählen Sie im Hauptfenster den Startpunkt
  • ziehen Sie mit gedrückter linker Maustaste das Element auf
  • ein Dialog öffnet sich, in dem Sie die gewünschte Funktion mit dem Element verknüpfen
  • Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  • halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt
  • Einzelne Eigenschaften des Elements definieren Sie im Eigenschaftenfenster. Dazu muss das Element im Hauptfenster aktiv sein (Mausklick).

Zur Auswahl von Funktionen wird ein gefilterter Dialog geöffnet:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Funktion gewählt werden soll.

Auswahlfenster

Auswahl der Funktion.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bereits verknüpfte Funktionen werden gelöscht

Tipp: Dieser Dialog ist in der Größe anpassbar. Die Dialoggröße und -position wird gespeichert.

Verknüpfte Funktion ändern

  1. manuell
    • öffnen Sie in der Detailansicht des Projektmanagers die Funktionen
    • ziehen Sie die gewünschte Funktion mit gedrückter linker Maustaste auf das Element
    • die bisherige Funktion wird durch die neue ersetzt
  2. automatisch
    • wählen Sie im Kontextmenü des Elements Verknüpfungen ersetzen. Details zur Vorgangsweise finden Sie im Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen.

Im Dynamischen Element Button können Grafikdateien vom Typ GIF animiert werden:

  1. weisen Sie dem Button im Knoten Darstellung über die Eigenschaft Grafikdatei eine GIF-Datei zu

    Interne ID: Bitmap Button (nur bis Version 6.22)

    Grafikdatei

    Grafik, die auf dem Button im ungedrückten Zustand dargestellt werden soll (*.bmp, *.wmf, *.jpg, *.gif, *.png). Klick auf die Schaltfläche ... öffnet den Dateiauswahldialog.
    Achtung: Bilder müssen im Projektmanager im Knoten Dateien/Grafiken bereits vorhanden sein.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Bitmap Button (nur bis Version 6.22)

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. wählen Sie im gleichen Knoten die Eigenschaft GIF-Animation

    Interne ID: Bitmap Button (nur bis Version 6.22)

    GIF-Animation

    Eigenschaften für die Animation, wenn eine animierte GIF Datei verwendet wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie zwischen Immer oder Animation nur wenn eine Bool Variable den Wert 1 besitzt: Verknüpfen Sie dazu Variable beid er Eigenschaft Variable

    Interne ID: Bitmap Button (nur bis Version 6.22)

    Variable

    Bit-Variable, die die Animation ein und aus schaltet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Bitmap Button (nur bis Version 6.22)

    Immer

    Aktiv: Die Animation läuft immer.
    Inaktiv: Die Animation wird nicht ausgeführt. Optional kann mit einer verknüpften Variable die Animation ein- und ausgeschalten werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Unsichtbarer Button (nur bis Version 6.22)

Handbuch -> Bilder -> Bildelemente -> Button -> Unsichtbarer Button (nur bis Version 6.22)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn die Projekteigenschaft RT Dateien erzeugen für auf kleiner 6.50 eingestellt wurde, kann das Element Button nur Texte in der Runtime anzeigen. Unsichtbare Buttons müssen in diesem Fall über das Element Unsichtbarer Button projektiert werden.

Interne ID: Unsichtbarer Button (nur bis Version 6.22)

RT Dateien erzeugen für

Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt

6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.

6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.

6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.

6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.

6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.

6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.

6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Buttons projektieren für unterschiedliche Runtimeversionen:

Button für | RT Dateien erzeugen für < 6.50 | ab 6.50
Text | Button | Button
Grafik | Bitmap Button | Button
unsichtbar | Unsichtbarer Button | Button

Das dynamische Element Unsichtbarer Button bietet die Möglichkeit, eine interaktive, transparente Bedienfläche zu definieren, mit der ein Funktionsaufruf verknüpft ist.

Um einen Unsichtbaren Button zu aktivieren:

  • wählen Sie das Symbol Unsichtbarer Button in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  • wählen Sie im Hauptfenster den Startpunkt
  • ziehen Sie mit gedrückter linker Maustaste das Element auf
  • ein Dialog öffnet sich, in dem Sie die gewünschte Funktion mit dem Element verknüpfen
  • Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  • halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt
  • Einzelne Eigenschaften des Elements definieren Sie im Eigenschaftenfenster. Dazu muss das Element im Hauptfenster aktiv sein (Mausklick).

Zur Auswahl von Funktionen wird ein gefilterter Dialog geöffnet:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Funktion gewählt werden soll.

Auswahlfenster

Auswahl der Funktion.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bereits verknüpfte Funktionen werden gelöscht

Tipp: Dieser Dialog ist in der Größe anpassbar. Die Dialoggröße und -position wird gespeichert.

Verknüpfte Funktion ändern

  1. manuell
    • öffnen Sie in der Detailansicht des Projektmanagers die Funktionen
    • ziehen Sie die gewünschte Funktion mit gedrückter linker Maustaste auf das Element
    • die bisherige Funktion wird durch die neue ersetzt
  2. automatisch

wählen Sie im Kontextmenü des Elements Verknüpfungen ersetzen. Details zur Vorgangsweise finden Sie im Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen.

info Info

Beim Unsichtbaren Button kann der Status der Variable nicht angezeigt werden.


Combi-Element

Handbuch -> Bilder -> Bildelemente -> Combi-Element

Das Combi-Element ist ein universal einsetzbares Dynamisches Element, das verschiedenste grafische Ausprägungen annehmen kann:

  • Grafik
  • Symbol aus der Bibliothek
  • in Bildern eingebettetes Symbol
  • Text

Die Form der Darstellung wird über Zustände definiert. Als Zustände können sowohl Variablenwerte der Hauptvariable dienen als auch Werte weiterer Variablen sowie Statusinformationen aller verknüpfter Variaben. Über Formeln können beliebige Verknüpfungen erstellt werden.
Zustände der Hauptvariablen (Grenzwertattribute) können direkt in das Combilement übertragen werden. Das Combilement untertstützt auch das Setzen von Sollwerten in Form eines Schalters/Tasters sowie das Absetzen von Funktionen und dient zur Umsetzung von verfahrenstechnischen Elementen für das Automatic Line Coloring.

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Interne ID: Combi-Element

SW setzen aktiv

Aktiv: Diese Variable für "Sollwert setzen" Aktionen freigeben.
Inaktiv: Diese Variable ist schreibgeschützt.
Default: aktiv

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Erstellen eines Combi-Elements

Um ein Combi-Element in einem Bild anzulegen:

  1. Klicken Sie in der Symbolleiste Elemente auf das Symbol Combi-Element und ziehen Sie das Element mit der Maus im Hauptfenster auf.
  2. Der Variablenauswahldialog öffnet sich, gefiltert auf numerische Variablen.
  3. Wählen Sie die gewünschte Variable aus.
  4. Der Assistent für die Einstellungen zum Combi-Element öffnet sich und führt Sie durch die Grundeinstellungen. Falls Sie alle Einstellungen lieber manuell vornehmen möchten, klicken Sie jetzt auf Abbrechen. Details zum Assistenten finden Sie im Kapitel Assistent.

Bei manueller Einstellung definieren Sie im Knoten Darstellung die Darstellungsart. Als Default wird Symbol aus Bibliothek vorgegeben. Je nach Einstellung legen Sie noch Bilddateien und Texte fest.

Interne ID: Combi-Element

Darstellungsart

Bitmap: Für jeden Zustand kann ein Bitmap ausgewählt werden.
Zusätzlich kann auch die Farbe eines Bildsymbols geändert werden.
Nur Bildsymbol: Für jeden Zustand kann einem bereits im Bild bestehenden Symbol eine Farbe zugeordnet werden.
Symbol aus Bibliothek: Für jeden Zustand kann ein Symbol aus der Bibliothek sowie seine Linien- und Hintergrungfarbe ausgewählt werden.
Zeichen: Für jeden Zustand kann ein Zeichen definiert werden (nur SICAM 230).
Zustandstext & Bildsymbol: Für jeden Zustand kann ein Text definiert werden.
Zusätzlich kann auch die Farbe eines Bildsymbols geändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Combi-Element

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zusätzliche Zustände definieren Sie entweder im Assistenten über die Schaltfläche Neuer Zustand oder in den Eigenschaften des Combi-Elements im Knoten Darstellung mit der Eigenschaft Konfiguration und Test.

Interne ID: Combi-Element

Konfiguration und Test

Öffnet den Dialog zur Definition der Zustände.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Funktionen und Variablen können dem Combi-Element auch per Drag&Drop zugewiesen werden. Dabei wird die jeweils bereits vorhandene Variable/Funktion durch die neue ersetzt.

attention Achtung

Symbole, die sich in einem Combi Element befinden, sind nicht bedienbar.

Ausnahme: Symbol aus Bibliothek können als klickbare Buttons erstellt werden.

Verknüpfungsregeln

Wenn Sie als Darstellungsart Symbol aus Bibliothek gewählt haben, können Sie Verknüpfungsregeln angeben. Über die Eigenschaft Konfiguration und Test öffnen Sie den Dialog für die Element-Eingabe. Nach der Auswahl des Symbols über den Symbolauswahl-Button können Sie Verknüpfungsregeln erstellen und bearbeiten. Diese Regeln werden pro Zustand gespeichert.

Example Beispiel

Im Symbol enthaltene Variablen/Funktionen:
Var_SWITCH_0010
Var_TEMPERATURE_0010
Fct_ShowTrend_0010
Fct_Help_0000

Mit folgender Regel werden nun die Variablen und die Funktion des Symbols ersetzt:
Quelle: *_0010
ersetzen durch: _0020

Ergebnis der Verknüpfungsregel:
Var_SWITCH_0020
Var_TEMPERATURE_0020
Fct_ShowTrend_0020
Fct_Help_0000

Es können also mit Hilfe der Verknüpfungsregel alle Variablen und Funktionen ausgetauscht werden. Wenn ein Variablen- oder Funktionsname nicht in das Schema passt, kann diese Verknüpfung nicht ersetzt werden.

Beim Erzeugen der Runtime-Dateien wird dann pro Zustand die jeweilige Verknüpfung entsprechend der Regel ersetzt.

Example Beispiel

Sie möchten grafisch darstellen, ob ein Motor eingeschalten ist und in welche Richtung er dreht.

Die Information zu Laufrichtung und zum Ein/Aus-Status kommt dabei von der Variablen auf Steuerungsseite. Über den Zustandstext wird im Motor angezeigt, ob und wie er sich dreht.

  • Wählen Sie in den Eigenschaften -> Darstellungsart -> Zustandstext.
  • Öffnen Sie den Dialog Element-Eingabe per Klick auf Konfiguration und Test.
  • Geben Sie den Zustandstext ein, den Sie dem jeweiligen Wert zuweisen wollen.

Während der Runtime steht in Ihrem Motor anschließend zum Beispiel: 'links', 'rechts' oder gar kein Text, wenn sich der Motor nicht dreht.

Nähere Informationen zur Auswertung der Status-Bits finden Sie im Kapitel Zustände

Noch in diesem Kapitel

Assistent

Klickbare Buttons in beliebiger Form

Zustände

Testmodus

Formeleditor

Darstellung von Variablenname und Variablenkennung


Assistent

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Assistent

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Grundkonfiguration des Combi-Elements steht ein Assistent zur Verfügung. Dieser öffnet sich, sobald Sie eine Variable für das Combi-Element ausgewählt haben.

Im ersten Schritt wählen Sie die Darstellungsart. Folgende Darstellungsarten stehen Ihnen zur Verfügung:

  • Symbol aus Bibliothek
  • Zustandstext und Bildsymbol
  • Bitmap und Bildsymbol
  • Nur Bildsymbol

info Info

In allen Fenstern für die Auswahl eines Zustands können Sie zusätzliche Zustände definieren. Dafür steht Ihnen die Schaltfläche Neuer Zustand zur Verfügung.

Default: Symbol aus Bibliothek.
Diese Einstellung wird auch als Standard in den Eigenschaften vorgegeben, wenn Sie das Combi-Element ohne Assistent erstellen.

Sobald Sie eine Darstellungsart gewählt haben, können Sie Zustände definieren. Der erste Zustand ist immer der Defaultzustand.
Hinweis: Für den Defaultzustand kann kein Wert angegeben werden, für alle anderen Zustände muss ein Wert angegeben werden. Sie können immer nur einen Zustand zur gleichen Zeit bearbeiten.

Symbol aus Bibliothek

Klicken Sie auf das leere Fenster links unten, um ein Symbol aus der Globalen Symbolbibliothek oder aus der Projektbibliothek auszuwählen. Mit einem Klick auf das X neben dem Fenster löschen Sie das ausgewählte Symbol wieder.

Einstellung | Beschreibung
Wert | Numerischer Wert, bei dem der Zustand aktiv wird. Default: kein Wert Ab 2. Zustand: Eintrag verpflichtend.
Neuer Zustand | Legt einen neuen Zustand für das Combi-Element an.

info Info

Für Symbol aus Bibliothek können klickbare Buttons in beliebiger Form erstellt werden.

Zustandstext und Bildsymbol

Jeden Zustand kann mit einem Text sowie mit Vordergrundfarbe und Hintergrundfarbe gekennzeichnet werden.

Einstellung | Beschreibung
Wert | Numerischer Wert, bei dem der Zustand aktiv wird. Default: kein Wert Ab 2. Zustand: Eintrag verpflichtend.
Zustandstext | Text, wie er zur Runtime angezeigt wird.
Farbe | Schriftfarbe des Zustandstextes.
Füllfarbe | Hintergrundfarbe des Zustandstextes.
Neuer Zustand | Legt einen neuen Zustand für das Combi-Element an.

Bitmap und Bildsymbol

Klicken Sie auf die Schaltfläche <Keine Grafik ausgewählt> links unten, um eine Bilddatei (*.bmp, *.gif, *jpg, *.png) auszuwählen. Sie haben zwei Möglichkeiten zur Bildauswahl::

  1. Bilder aus dem Projekt:

    Bilder, die Sie bereits im Grafikverzeichnis des Projektes hinterlegt haben (siehe Kapitel Editor -> Projektmanager -> Dateien), werden Ihnen vom Assistenten automatisch angeboten.

  2. Absoluter Pfad zu anderen Verzeichnissen:
    • Aktivieren Sie dazu Direkte Dateiauswahl
    • Das Fenster schaltet um auf Direktauswahl
    • Klicken Sie auf die Schaltfläche ...
    • Wählen Sie mit dem Explorer die entsprechende Datei
Einstellung | Beschreibung
Wert | Numerischer Wert, bei dem der Zustand aktiv wird. Default: kein Wert Ab 2. Zustand: Eintrag verpflichtend.
Neuer Zustand | Legt einen neuen Zustand für das Combi-Element an.

Nur Bildsymbol

Sie können ein gemeinsames Symbol für alle Zustände des Combi-Elements angeben.
Dieses Symbol:

  • muss bereits im Bild vorhanden sein
  • gilt für alle Zustände
  • kann für jeden Zustand mit einer eigenen Füllfarbe gekennzeichnet werden
Einstellung | Beschreibung
Wert | Numerischer Wert, bei dem der Zustand aktiv wird. Default: kein Wert Ab 2. Zustand: Eintrag verpflichtend.
Bildsymbol | Dropdownliste zur Auswahl eines Symbols. Werden keine Symbole angezeigt, dann sind im aktuellen Bild noch keine Symbole vorhanden.
Füllfarbe | Kennzeichnet den zugewiesenen Zustand.
Neuer Zustand | Legt einen neuen Zustand für das Combi-Element an.


Klickbare Buttons in beliebiger Form

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Klickbare Buttons in beliebiger Form

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Combi-Element können auch klickbare Buttons in beliebiger Form erstellt werden.

info Info

Diese Möglichkeit steht ab Version 6.51 zur Verfügung. Bei Projekten für frühere Versionen wird die Eigenschaft als inaktiv behandelt.

Um klickbare Buttons in beliebiger Form zu erstellen:

  1. erstellen Sie ein Combi-Element in der Ausprägung Symbol aus Bibliothek
  2. aktivieren Sie in den Eigenschaften des Combi-Elements im Knoten Darstellung die Eigenschaft Symbolform bestimmt Klickbereich

    Interne ID: Klickbare Buttons in beliebiger Form

    Symbolform bestimmt Klickbereich

    Ermöglicht es, einen klickbaren Button mit beliebiger Form zu erstellen. Steht nur für Option Symbol aus Bibliothek des Combi-Elements zur Verfügung.

    Aktiv: Die Symbolform wird als Klickbereich verwendet, jedes Element im Symbol wird einzeln für den Klickbereich berücksichtigt.

    Inaktiv: Die Form des Combi-Elements (gesamtes Rechteck) wird als Klickbereich verwendet.

    Default: inaktiv

    Achtung: Unter Windows CE nicht verfügbar.

    Eigenschaft steht ab Version 6.51 zur Verfügung. Bei Projekten für frühere Versionen wird die Eigenschaft als inaktiv behandelt.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Klickbare Buttons in beliebiger Form

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Diese Eigenschaft funktioniert unter Windows CE nicht, da die benötigte Funktionalität unter Windows CE nicht zur Verfügung steht.

Elemente

Im Symbol können sich weitere Symbole oder Combi-Elemente befinden. Diese werden entsprechend korrekt für den Klickbereich aufgelöst. Bei Symbolen werden ganz normal die Elementgrenzen verwendet, beim Combi-Element abhängig von der Eigenschaft Symbolform bestimmt Klickbereich entweder die einzelnen Klickbereiche der Elemente oder das Umgebungsrechteck des Combi-Elements.

Folgende Elemente haben ihren eigenen speziellen Klickbereich:

  • Abgerundetes Rechteck (bis Version 6.50 als eigenes Vektorelement vorhanden)
  • Button
  • Combi-Element mit Eigenschaft „Symbolform für Klickbereich"
  • Kreis
  • Kreissegment
  • Kreisbogen
  • Linie
  • Pipeline
  • Polygon
  • Polylinie
  • Rechteck
  • Statischer Text
  • Symbol (Korrekte Klickbereiche der Symbolelemente werden verwendet)

Alle anderen Elemente haben ihre rechteckige Umrandung als Klickbereich.

Spezielle Ausprägungen

Spezielle Ausprägung

Auswirkung

Nie speziell behandelt werden:

  • Linientyp
  • Füllmuster
  • Transparenzen jeglicher Art
    (ausgenommen Textelement)

Bereiche sind immer klickbar.

Transparenz bei Statischem Text:

Element erhält sich so, als ob das Element nicht existieren würde. Dadurch ist es möglich, Elemente zu benennen ohne unabsichtlich den Klickbereich zu vergrößern.

Beeinflusst Klickbereich nicht.

Tipp: Soll ein transparentes Textelement den Klickbereich beeinflussen:

  • deaktivieren Sie die Eigenschaft Transparent

    Interne ID: Klickbare Buttons in beliebiger Form

    Transparent

    Aktiv: Der Symbolhintergrund ist transparent.
    Inaktiv: Der Symbolhintergrund kann für jeden Zustand separat definiert werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • legen Sie manuell ein transparentes Element darüber oder darunter

Button

Wird für Klickbereich verwendet, eine GIF-Animation für "gedrückt" steht hier nicht zur Verfügung. Das entspricht dem Verhalten bei inaktiver Eigenschaft Symbolform bestimmt Klickbereich.

Interne ID: Klickbare Buttons in beliebiger Form

GIF-Animation

Eigenschaften für die Animation, wenn eine animierte GIF Datei verwendet wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Symbol ragt aus Combi-Element heraus.

Symbol wird dargestellt, Klicks werden aber nur innerhalb des Combi-Elements ausgewertet.

Anmerkung: Wenn Elemente über Symbolgrenzen hinausragen oder Symbole über die Grenzen eines Combi-Elements, kann es zu Darstellungsproblemen und Schmiereffekten kommen.

Klickbereiche

Im Editor werden teilweise größere Bereiche als Klickbereich definiert, um diese leichter anklickbar zu machen. Zum Beispiel kann eine Linie mit 1 Pixel Dicke im Editor auf einer Breite von 8 Pixel ausgewählt werden.

Zur Runtime erfolgt die Darstellung des Klickbereichs exakt. Zum Beispiel ist eine Linie von 1 Pixel Dicke auch nur auf einer Breite von 1 Pixel auswählbar.

Die Berechnung des Klickbereiches für das Combi-Element funktioniert unabhängig von der Einstellung der Eigenschaft Grafikqualität. Allerdings wird abhängig von dieser Einstellung ein unterschiedlicher Klickbereich für die Elemente berechnet.

Interne ID: Klickbare Buttons in beliebiger Form

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Klickbare Buttons in beliebiger Form

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: Klickbare Buttons in beliebiger Form

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wenn sich der Mauszeiger über dem Combi-Element befindet, wird analysiert ob sich der Cursor im Klickbereich des Elements befindet. Bei einer großen Anzahl von Elementen im Symbol des Combi-Elements kann die CPU-Last dann hoch ausfallen.

Noch in diesem Kapitel

Beispiel klickbare Buttons


Beispiel klickbare Buttons

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Klickbare Buttons in beliebiger Form -> Beispiel klickbare Buttons

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beispiel 1

Zustand Symbolform bestimmt Klickbereich Interne ID: Beispiel klickbare Buttons Symbolform bestimmt Klickbereich Ermöglicht es, einen klickbaren Button mit beliebiger Form zu erstellen. Steht nur für Option Symbol aus Bibliothek des Combi-Elements zur Verfügung. Aktiv: Die Symbolform wird als Klickbereich verwendet, jedes Element im Symbol wird einzeln für den Klickbereich berücksichtigt. Inaktiv: Die Form des Combi-Elements (gesamtes Rechteck) wird als Klickbereich verwendet. Default: inaktiv Achtung: Unter Windows CE nicht verfügbar. Eigenschaft steht ab Version 6.51 zur Verfügung. Bei Projekten für frühere Versionen wird die Eigenschaft als inaktiv behandelt. Mehr im Online-Handbuch. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Aktion
aktiv | Kein Klick
inaktiv | Klick

Beispiel 2

Zustand Symbolform bestimmt Klickbereich | Aktion
aktiv | Klick
inaktiv | Klick

Beispiel 3

Zustand Symbolform bestimmt Klickbereich | Aktion
aktiv | Kein Klick
inaktiv | Klick


Zustände

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Zustände

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Fenster Zustände erreichen Sie über die Eigenschaft Konfiguration und Test im Knoten Darstellung.

Interne ID: Zustände

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zustände

Konfiguration und Test

Öffnet den Dialog zur Definition der Zustände.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Ein Klick auf die Schaltfläche oder den Text "hier klicken" öffnet das Fenster Zustände:

Hier

  • bearbeiten Sie existierende Zustände
  • fügen Sie neue Zustände hinzu
  • legen Sie fest, in welcher Reihenfolge Zustände abgearbeitet werden.

Die Einstellungen im oberen Teil des Fensters sind für alle Darstellungsarten gleich. Im unteren Drittel werden individuelle Einstellungen für die vier verschiedenen Darstellungsarten vorgenommen.

Gemeinsame Einstellungen

Zustandsdefinition

Listet alle definierten Zustände auf. Ein Zustand kann aus Werten und Status bestehen. Das Element wird vom ersten Zustand bis zum letzten Eintrag abgearbeitet. Die erste vollständige Übereinstimmung wird angezeigt. Ausnahme: Die Eigenschaft übereinander (bei Symbolen aus der Bibliothek) oder gekettet (bei Texten) ist aktiv.

Parameter | Beschreibung
Defaultzustand | Der bei der Erstellung des Elements definierte Zustand. Er steht immer an erster Stelle und kann nicht mehr geändert oder gelöscht werden.
Wert | Zeigt den definierten Wert (32 Bit) an.
Status | Zeigt den definierten Status an. Ein "F" am Ende der Statusanzeige weist auf eine Formel hin.
Neu | Definiert neue Zustände. Dabei werden Werte, Status und Formel des aktuell markierten Zustands als Ausgangswerte übernommen.
Löschen | Löscht den markierten Zustand. Der Defaultzustand kann nicht gelöscht werden.
nach oben/nach unten | Ändert die Reihenfolge der Abarbeitung der Zustände. Der Defaultzustand steht immer an erster Stelle.

Formelvariablen

Zeigt alle Variablen an, die für die Eingabe in Formeln definiert wurden. Existierende Variablen werden mit einem grünen Haken markiert, nicht existierende mit einem roten X. Nicht existierende Variablen können über Ändern durch existierende erstezt werden. Die Schaltflächen Hinzufügen und Ändern öffnen den Dialog zur Variablenauswahl.

Wert

Ermöglicht

  • die Eingabe des Wertes für einen Zustand über eine Matrix oder numerisch
  • die Definition einer Formel
Parameter | Beschreibung
Wert | Festlegen des Wertes durch eine vorgegebene Bitstruktur.
Wert | Eingabe des numerischen Wertes.
Formel | Öffnet das Fenster zur Eingabe von Formeln. Es stehen die im Bereich Formelvariablen definierten Variablen zur Verfügung. Die Verknüpfung erfolgt über logische, bitweise und vergleichende Operatoren.

attention Achtung

Bei nicht-binären Variablen wird der Wert in der Signalauflösung angegeben! Einstellungen des Messbereichs oder der non-linearen Wertanpassung werden in diesem Element nicht berücksichtigt.

Status

Ermöglicht die Abfrage der Statusinformationen.

Achtung: Die meisten Status lassen sich nur abfragen, wenn der Treiber die Statusverarbeitung unterstützt.

Nr. | Kurzbezeichner | Langbezeichnung | Anmerkung
0 | M1 | Benutzerstatus 1 |
1 | M2 | Benutzerstatus 2 |
2 | M3 | Benutzerstatus 3 |
3 | M4 | Benutzerstatus 4 |
4 | M5 | Benutzerstatus 5 |
5 | M6 | Benutzerstatus 6 |
6 | M7 | Benutzerstatus 7 |
7 | M8 | Benutzerstatus 8 |
8 | NET_SEL | Select im Netzwerk |
9 | REVISION | Revision |
10 | PROGRESS | In Bearbeitung |
11 | TIMEOUT | Laufzeit Überschreitung |
12 | MAN_VAL | Handwert | Nur für Formeln verfügbar
13 | M14 | Benutzerstatus 14 | Nur für Formeln verfügbar
14 | M15 | Benutzerstatus 15 | Nur für Formeln verfügbar
15 | M16 | Benutzerstatus 16 | Nur für Formeln verfügbar
16 | GI | Generalabfrage |
17 | SPONT | Spontan |
18 | INVALID | Ungültig |
19 | T_CHG_A | Sommer/Winterzeit Ankündigung |
20 | OFF | Abgeschaltet |
21 | T_EXTERN | Echtzeit extern | Nur für Formeln verfügbar
22 | T_INTERN | Echtzeit intern | Nur für Formeln verfügbar
23 | N_SORTAB | Nicht sortierfähig | Nur für Formeln verfügbar
24 | FM_TR | Störmeldung Trafowert |
25 | RM_TR | Laufmeldung Trafowert |
26 | INFO | Info der Variable |
27 | ALT_VAL | Ersatzwert |
28 | RES28 | Reserviert |
29 | N_UPDATE | Nicht aktualisiert |
30 | T_STD | Winterzeit | Nur für Formeln verfügbar
31 | RES31 | Reserviert |
32 | COT0 | Übertragungsursache Bit 1 | Nur für Formeln verfügbar
33 | COT1 | Übertragungsursache Bit 2 | Nur für Formeln verfügbar
34 | COT2 | Übertragungsursache Bit 3 | Nur für Formeln verfügbar
35 | COT3 | Übertragungsursache Bit 4 | Nur für Formeln verfügbar
36 | COT4 | Übertragungsursache Bit 5 | Nur für Formeln verfügbar
37 | COT5 | Übertragungsursache Bit 6 | Nur für Formeln verfügbar
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | Nur für Formeln verfügbar
39 | TEST | Test-Bit (IEC 60870 [T]) |
40 | WR_ACK | Schreiben bestätigt | Nur für Formeln verfügbar
41 | WR_SUC | Schreiben erfolgreich | Nur für Formeln verfügbar
42 | NORM | Normalzustand | Nur für Formeln verfügbar
43 | N_NORM | Abweichung Normalzustand | Nur für Formeln verfügbar
44 | BL_870 | IEC 60870 Status: blocked |
45 | SB_870 | IEC 60870 Status: substituted |
46 | NT_870 | IEC 60870 Status: not topical |
47 | OV_870 | IEC 60870 Status: overflow |
48 | SE_870 | IEC 60870 Status: select |
49 | T_INVAL | Zeit ungültig | Nur für Formeln verfügbar
50 | RES50 | reserviert |
51 | RES51 | reserviert |
52 | RES52 | reserviert |
53 | RES53 | reserviert |
54 | RES54 | reserviert |
55 | RES55 | reserviert |
56 | RES56 | reserviert |
57 | RES57 | reserviert |
58 | RES58 | reserviert |
59 | RES59 | reserviert |
60 | RES60 | reserviert |
61 | RES61 | reserviert |
62 | RES62 | reserviert |
63 | RES63 | reserviert |

info Info

Die Kurzbezeichner für Statusbits wurden ab Version 6.50 für alle Sprachen vereinheitlicht. Details dazu und wie Sie alte Kurzbezeichner weiter verwenden können, lesen Sie im Kapitel Statusbits - Neue Kurzbezeichner.

Unquittiert: Ist die Option Blinken beim Grenzwert der Variablen aktiviert, wird das Bit unquittiert gesetzt. Mit der Option Blinkquittieren auch den Alarm in der Alarmkonfiguration wird der Alarm blinkquittiert und das Bit unquittiert auf Null gesetzt (siehe auch Kapitel Blinkquittieren von Alarmen).

Individuelle Einstellungen

Individuelle Einstellungen zu den 4 Darstellungsarten von Zuständen finden Sie in den Unterkapiteln:

Symbol aus Bibliothek

Zustandstext und Bildsymbol

Bitmap und Bildsymbol

Nur Bildsymbol

Zustand projektieren bei noch nicht verknüpften Variablen

Manchmal müssen Sie ein Combi-Element projektieren, verfügen aber noch nicht über eine real existierende Variable zu verfügen. Zum Beispiel, wenn das Combi-Element in einem Symbol der Symbolbibliothek verwendet werden soll und die Variablenverknüpfung erst beim Reinziehen in das Bild erstellt wird. In diesem Fall arbeiten Sie erst mit einer sogenannten Dummy-Variablen, die sie später durch eine existierende ersetzen. So können Sie alle Zustände im Combi-Element auch dann projektieren, wenn noch keine existierenden Variablen verknüpft wurden. Nur auf den Testmodus haben Sie mit Dummy-Variablen keinen Zugriff.

So legen Sie eine 'Dummy'-Variable an:

  • Geben Siein den Eigenschaften des Combi-Elements im Eingabefeld Variable einen symbolischen Namen an.

    Interne ID: Zustände

    Variable

    Für Buttons nur verfügbar, wenn sie als Schalter verwendet werden:
    Name der verknüpften Variable.
    Öffnet den Variablenauswahldialog.
    Der Wert dieser Variable wird in diesem Element angezeigt und kann hier auch gesetzt werden.

    Nur SICAM 230 und Element Bild-Alarmierung:
    Die obige Beschreibung betrifft nur die Elemente Textbutton, Bitmapbutton und Unsichtbarer Button.

    Bedeutung in SICAM 230:
    Auf die ausgewählte Variable (32 Bit) werden die Zustände der Alarm/Ereignis-Klassen abgebildet. Je Klasse werden 2 Bits beschrieben (nach Klassennummer aufsteigend).

    Niederwertiges Bit: Alarm aktiv/inaktiv

    Höherwertiges Bit: Alarm quittiert/unquittiert

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Klicken Sie im Bereich Darstellung in das Feld Konfiguration und Test:Die Seite Zustände in der Element-Eingabe wird geöffnet.
  • In der Liste der Formelvariablen werden existierende Variablen mit einem grünen Haken markiert, nicht existierende mit einem roten X. Sie können weitere Variablen hinzufügen:
  • Für existierende Variablen wählen Sie den Button Hinzufügen.
    Mit Ändern ersetzen Sie existierende Variablen durch andere, oder ersetzen nicht existierende Variable durch existierende.
  • Um eine nicht existierende Variable hinzuzufügen , klicken Sie erst auf Hinzufügen, dann auf Keine Auswahl. Sie erhalten eine Formelvariable mit folgendem Namensmuster: X00: <leer>. (00 steht für eine zweiziffrige Zahl.)
    Markieren Sie die Variable und klicken Sie in den Bereich <leer>; vergeben Sie eine Bezeichnung.
    Wenn Sie den Namen einer existierenden Variablen eingeben, wird die Verknüpfung zu dieser hergestellt, das Zeichen wechselt von rotem X auf grünen Haken.

Formeln

Wie eine Formel erstellt wird, lesen Sie im Kapitel Formeleditor.

Noch in diesem Kapitel

Symbol aus Bibliothek

Zustandstext und Bildsymbol

Grafik und Bildsymbol

Nur Bildsymbol


Symbol aus Bibliothek

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Zustände -> Symbol aus Bibliothek

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die generellen Einstellungen für alle Darstellungsarten von Zuständen finden Sie im Kapitel Zustände.

Parameter

Beschreibung

Darstellungselement

Symbol aus Bibliothek

Klick auf das Symbol öffnet den Dialog zur Symbolauswahl.

Klick auf das X neben dem Symbol löscht das gewählte Symbol.

Verknüpfungsregel bearbeiten

Variablen und Funktionen, die im Symbol enthalten sind, können mit Hilfe von Verknüpfungsregeln ausgetauscht werden.

Achtung: Wenn ein Variablen- oder Funktionsname nicht in das Schema passt, kann diese Verknüpfung nicht ersetzt werden.

Farben

Nur aktiv, wenn im Bereich Spezifische Einstellungen die Eigenschaft Original Symbolfarben abgeschaltet ist.

Farbe

Wahl der Farbe.

Füllfarbe

Wahl der Füllfarbe.

Aus ALC

Die Farbe der verknüpften Quellen wird verwendet.

Spezifische Einstellungen

Original Symbolfarben

Aktiv: Übernimmt Originalfarbe vom Symbol. Deaktiviert Eigenschaft Farbe der Haupt-Variable übernehmen.

Interne ID: Symbol aus Bibliothek

Farbe der Haupt-Variable übernehmen

Aktiv: Die Füllfarbe bei eingebetteten Symbolen und Symbolen aus Bibliothek wird beim Zustand Default von der Hauptvariablen übernommen, wenn bei dieser eine Grenzwertverletzung vorliegt.
Das bedeutet: Solange eine Grenzwertverletzung der Hauptvariablen besteht, wird die Füllfarbe aus der Grenzwertfarbe übernommen. Die Farbdefinition bei den Zuständen wird also überschrieben. Weitere Zustandsattribute wie z.B. Blinken, Transparenz oder Original Symbolfarbe werden jedoch aus der Zustandsdefinition übernommen. Auf Bitmapdarstellung hat diese Eigenschaft keine Auswirkung.

Ausnahme: Ist beim Zustand Default die Eigenschaft Original Symbolfarbe aktiviert, wird immer die originale Symbolfarbe verwendet.
Inaktiv: Die Farbe der Hauptvariablen hat keinen Einfluss auf die dargestellten Farben des Combi-Elements.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Blinken

Aktiv: Symbol blinkt zur Runtime, wenn Zustand erreicht wird.


Zustandstext und Bildsymbol

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Zustände -> Zustandstext und Bildsymbol

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die generellen Einstellungen für alle Darstellungsarten von Zuständen finden Sie im Überkapitel Zustände.

Parameter | Beschreibung
Darstellungselement |
Zustandtext | Text für den Zustand.
Text bei gedrückt | Text bei gedrücktem Symbol.
Farben |
Farbe | Wahl der Farbe.
Füllfarbe | Wahl der Füllfarbe.
Aus ALC | Die Farbe der verknüpften Quellen wird verwendet.
Spezifische Einstellungen |
Blinken | Aktiv: Symbol blinkt zur Runtime, wenn Zustand erreicht wird.
Transparent | Aktiv: Füllfarbe wird auf transparent gesetzt.


Grafik und Bildsymbol

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Zustände -> Grafik und Bildsymbol

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die generellen Einstellungen für alle Darstellungsarten von Zuständen finden Sie im Überkapitel Zustände.

Parameter | Beschreibung
Darstellungselement |
Grafik | Klick auf Grafik öffnet Dialog zur Grafikauswahl. Löschen: Name aus Textzeile entfernen.
Spezifische Einstellungen |
Blinken | Aktiv: Symbol blinkt zur Runtime, wenn Zustand erreicht wird.


Nur Bildsymbol

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Zustände -> Nur Bildsymbol

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die generellen Einstellungen für alle Darstellungsarten von Zuständen finden Sie im Überkapitel Zustände.

Parameter | Beschreibung
Farben |
Farbe | Wahl der Farbe.
Aus ALC | Die Farbe der verknüpften Quellen wird verwendet.
Spezifische Einstellungen |
Original Symbolfarben | Aktiv: Übernimmt Originalfarbe vom Symbol.
Symbol transparent | Aktiv: Symbolfarbe wird auf transparent gesetzt.
Blinken | Aktiv: Symbol blinkt zur Runtime, wenn Zustand erreicht wird.


Testmodus

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Testmodus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Testmodus simuliert die Runtime: Sie können eine Wertänderung testen und sehen, wie sich Ihr Combi Element während der Runtime verhält. Diese Registerkarte können Sie nur aktivieren, wenn alle Verknüpfungen auf existierende Variablen verweisen.

Hinweis: Im Testmodus erscheint das Symbol in einer schlechteren Auflösung als im Bild zur Runtime..


Formeleditor

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Formeleditor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Formeleditor unterstützt bei der Erstellung von Formeln mit logischen oder vergleichenden Operatoren beim Combi-Element, bei Verriegelungen und Befehlsgabe. Werden für eine Formel zusätzliche Variablen benötigt, erstellen Sie diese im Bereich Formelvariablen des Zustandsfensters mit Klick auf die Schaltfläche Hinzufügen. Vorhandene Formeln werden in der Zustandsliste durch den Buchstaben F angezeigt.

Formel erstellen

Klicken Sie im Zustandsfenster auf die Schaltfläche Formel. Der Formeleditor öffnet sich

Im linken Fenster wählen Sie die Bits für Ihre Formel aus.

Rechts finden Sie die Operatoren für logische und vergleichende Operationen.

Im Bereich Formel wird die erstellte Formel angezeigt.

info Info

Es können bis zu 99 Variablen in einer Formel verknüpft werden. X01 bis X99. Die Länge der Formel darf dabei 4096 Zeichen nicht überschreiten.

Die Bedeutung der Bits:

Parameter

Beschreibung

Wert-Bits

Es stehen 32 Wert-Bits (von 0 -31) zur Verfügung. Sie beschreiben den Variablenwert bitweise. Für BOOL'sche Variablen hat nur das Bit 0 Bedeutung, für SINT und USINT die Bits 0-7 usw...

Hinweis: Die Auswertung bezieht sich immer auf den Rohwert (Signalbereich) der Variablen und nicht auf den umgerechneten Messwert.

Status-Bits

Stellt die gängigsten Status-Bits zur Verfügung. Die genaue Definition und Verwendung der Status-Bits finden Sie in der Liste Status-Bits.

unquittiert

Unquittiert wird wie ein ganz normales Status-Bit behandelt, wird hier aber separat angeführt, da es nicht zu den klassischen Variablen Status gehört.

Wert und Status

Alle Werte (Wert-Bits und Status-Bits) in den Formeln werden als Binärwerte betrachtet und können dann logisch mit UND bzw. ODER sowie anderen logischen Ausdrücken verbunden werden.
Eine Ausnahme bilden der Gesamtwert und der Gesamtstatus. Damit man damit auf einen boole'schen Ausdruck kommt, muss man diesen Gesamtwert zuerst mit einer Konstante bitweise verodern. Dazu wird der Operator & verwendet.
Bei Ergebnis 0 (False) der bitweisen Veroderung ergibt sich der Binärwert 0 (False), ansonsten 1 (True).

Beispiel: siehe Kapitel Beispiel bitweise Veroderung

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.

Werden außerhalb des Formeleditors andere Einstellungen für den aktuellen Zustand gemacht, so werden diese mit der Formel mit einem logischen UND verknüpft.

Für Beispiele siehe Abschnitt Beispiele für Formeln.

info Info

Formeln mit binären X-Werten und bitweiser Verknüpfung können mit maximal 2 binären Werten benutzt werden. Werden mehr Werte benötigt, muss die Verknüpfung ohne binäre X-Werte erfolgen.

Beispiel:

X01.Value & X02.Value -> funktioniert

X01.Value & X02.Value & X03.Value -> funktioniert nicht

Aber:

X01.00 AND X02.00 AND X03.00 AND X04.00 AND X05.00 -> funktioniert

Noch in diesem Kapitel

Liste Status-Bits

Logische Operatoren

Bitformeln

Vergleichsoperatoren

Beispiele für Formeln


Liste Status-Bits

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Formeleditor -> Liste Status-Bits

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Details zur Statusverarbeitung lesen Sie im Kapitel Statusverarbeitung.


Logische Operatoren

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Formeleditor -> Logische Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Logische Verknüpfungen: Variablen werden nur auf den logischen Wert '0' überprüft, ist der Wert ungleich '0', wird er mit '1' definiert.

Im Unterschied zur Bitformel kann der technische Bereich durch einen Streckungsfaktor verändert werden -> ungleich '0' oder '1'.

Operator | Bedeutung
AND | logisch 'UND'
NOT | Negation
OR | logisch 'ODER'
XOR | logisch 'EXKLUSIV ODER'

Die Operator haben in der Formelberechnung folgende Priorität:

Priorität | Operator
1 | & (Operator für Bitformeln)
2 | NOT
3 | AND
4 | XOR/OR

info Info

Es können bis zu 99 Variablen in einer Formel verknüpft werden. X01 bis X99.

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.


Bitformeln

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Formeleditor -> Bitformeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bitformeln besitzen nur einen logischen Low- oder Highzustand. Im Unterschied zu logischen Formeln ist der Rohwert bereits fix vordefiniert (0,1).

Operator | Beschreibung
& | AND
| | OR

Noch in diesem Kapitel

Beispiel bitweise Veroderung


Beispiel bitweise Veroderung

Beispiel bitweise Veroderung

Sie wollen abfragen, ob eines der Anwenderstatus Bits 1-8 (M1 ... M8) von der Variable X01 gesetzt ist.

Normale Formel:

X01.M1 OR X01.M2 OR X01.M3 OR X01.M4 OR X01.M5 OR X01.M6 OR X01.M7 OR X01.M8
Diese Abfrage kann durch die bitweise Veroderung des Gesamtstatus wesentlich erleichtert werden.

Bitweise Veroderung:

X01.Status & 0xFF

Die Konstante kann, wie oben beschrieben, Hexadezimal eingegeben werden:

0xFF entspricht dezimal 256, das sind die ersten acht Statusbits (Binär 11111111). Steht eines dieser Bits auf 1, dann ist das Ergebnis dieser bitweisen Veroderung 1 (True), ansonsten 0 (False).

Sollen z. B. alle Anwender Status-Bits außer dem Anwender Status-Bit M7 abgefragt werden, wäre der Binäre Ausdruck dafür: 10111111. Bit 7 ist nicht interessant, steht daher auf 0. Das entspricht Hexadezimal 0xBF. Der Ausdruck für die Formel ist dann: X01.Status & 0xBF.

Statt mit einer Konstante bitweis zu verodern, kann man den Wert auch direkt mit einer dezimalen Zahl vergleichen. Ist ein Vergleich falsch, ergibt sich der Binärwert 0 (False), ansonsten 1 (True).

Beispiel:

Sie wollen abfragen, ob ein Wert der Konstanten 202 entspricht. Die Formel lautet:

X01.Wert = 202

Entspricht der Wert der Konstanten 202, so ist das Ergebnis dieses Vergleiches 1 (True), ansonsten 0 (False).

Hinweis: Die bitweise Veroderung funktioniert mit dem Oder-Zeichen (|) analog zu diesem Beispiel.


Vergleichsoperatoren

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Formeleditor -> Vergleichsoperatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vergleichoperatoren dienen zum direkten Vergleich von zwei numerischen Werten. Das Ergebnis dieses Vergleichs wird in Form eines Binärzustandes dargestellt. „0“ wenn die Bedingung nicht erfüllt ist und „1“ wenn die Bedingung erfüllt ist.

Operator | Beschreibung
< | kleiner
> | größer
<= | kleiner gleich
>= | größer gleich
= | ist gleich
<> | ungleich

Links und rechts vom Vergleichs Operator muss ein (Gesamt-)Wert oder (Gesamt-)Status stehen, Einzelbits können mit diesen Vergleichsoperatoren nicht verwendet werden.

Rechts vom Vergleichs Operator kann auch eine Konstante stehen. Die Konstanten können nur Ganzzahlen sein, ein Vergleich mit Gleitkommazahlen ist nicht möglich.
Im Combi-Element werden diese Konstanten als hexadezimale Werte oder Dezimalwerte eingegeben. Hexadezimale Zahlen werden beim Klick auf OK automatisch in Dezimalzahlen umgewandelt (z.B. entspricht 0x64 dem numerischen Wert 100).

Example Beispiel

X01.Wert >= X02.Wert
Das Ergebnis ist „1“ wenn der Wert von X01 größer oder gleich dem Wert X02 ist

X01.Wert = 0x64
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 entspricht (= Hex 0x64)

(X01.Wert = 0x64) OR (X01.Wert = 0x65)
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 oder 101 entspricht (= Hex 0x64 und Hex 0x65)


Beispiele für Formeln

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Formeleditor -> Beispiele für Formeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einfache logische UND Verknüpfung zwischen zwei Werte Bits

Example Beispiel

Formel: X01.03 AND X02.03

Diese Formel ergibt den Zustand WAHR, wenn sowohl Bit 3 der Variablen 1 als auch Bit 3 der Variablen 2 den Wert 1 hat.

Der Wert oder Status einer Variable analog vergleichen

Example Beispiel

(X01.Wert> X02.Wert)

Analoge Vergleiche auf logischer Basis miteinander vergleichen

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert)

Vergleiche mit Werte- und Status-Bits

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert) OR (X01.03 = X02.03)

Einen Wert mit einem dezimalen oder hexadezimalen Wert vergleichen

Example Beispiel

Formel: (X01.Wert = 111)

Formel: (X01.Wert = 0x6F)

Wird ein hexadezimaler Wert verwendet, so wird dieser mit dem Klick auf OK später in dezimale Schreibweise umgewandelt. Wurde ein dezimaler Wert angegeben und bestätigt, wird dieser beim erneuten Öffnen weiter als dezimaler Wert angezeigt.

info Info

Bei der Eingabe von Zahlen ist es nicht möglich, ein Komma oder einen Punkt zu verwenden.


Darstellung von Variablenname und Variablenkennung

Handbuch -> Bilder -> Bildelemente -> Combi-Element -> Darstellung von Variablenname und Variablenkennung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können mithilfe des Combi-Elements Variablenname und Variablenkennung darstellen. Gehen Sie dazu wie folgt vor:

  1. Legen Sie eine Combi-Element an.
  2. Selektieren Sie den Darstellungstyp Zustandstext & Bildsymbol.
  3. Legen Sie einen default Zustand an.
  4. Geben Sie bei Zustandstext folgende Platzhalter ein
Platzhalter | Beschreibung
%n | zeigt den Variablennamen
%n,1,2 | zeigt den Varibalennamen ab Position 1 für 2 Zeichen
%N | zeigt den Variablennamen
%N,3,2 | Zeigt den Variablennamen minus der ersten 3 Zeichen und minus der letzten 2 Zeichen
%l | zeigt die Variablenkennung
%l,1,2 | zeigt die Variablenkennung ab Position 1 für 2 Zeichen
%L | zeigt die Variablenkennung
%L.3.2 | zeigt die Variablenkennung minus der ersten 3 Zeichen und minus der letzten 2 Zeichen


Combo-/Listbox

Handbuch -> Bilder -> Bildelemente -> Combo-/Listbox

Mit dem DynamischenElement Combo-/Listbox verknüpfen Sie Werte von Variablen mit Texten. Diese nutzen Sie auf zwei Arten:

  1. Wird ein Text zur Runtime ausgewählt, ändert sich der Wert der Variablen auf jenen Wert, der mit diesem Text verknüpft ist.
  2. Erreicht die Variable einen der definierten Werte, wird der verknüpfte Text solange in der Combobox/Listbox angezeigt, wie der Wert ansteht.

Erstellen einer Combo-/Listbox

Um das Dynamische Element Combo-/Listbox in einem Bild anzulegen:

  1. wählen Sie das Symbol Combo-/Listbox in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. ein Dialog öffnet sich, in dem Sie die gewünschte Variable mit dem Element verknüpfen.
    Folgende Variablentypen werden unterstützt:
    • binär
    • numerisch
    • string

info Info

Variablen können auch per Drag&Drop mit dem Element verknüpft werden. Ziehen Sie eine Variable auf eine Combo-/Listbox, dann ersetzt sie die dort bereits vorhandene Variable.

Das Combo-/Listbox-Element unterstützt die gleichen zusätzlichen Funktionalitäten wie das Element Zahlenwert:

  • Schlossanzeige, Statusanzeige, Sichtbarkeit, dynamische Farben.
  • Dynamische Farben: Die Hintergrundfarbe wird nur für die vorhandenen Einträge übernommen; der nicht durch Einträge abgedeckte Bereich des Kontrollelements wird in der Standard-Farbe dargestellt.

Das Verknüpfen vom Makros auf Element-Events (z.B. LeftClickUp ...) wird nicht unterstützt.

attention Achtung

Unter Windows CE ist das Modifizieren von Farben und Schriftarten in der Combo-/ListBox nicht möglich.

Combo-/Listboxen können dynamisch oder statisch erstellt werden. Die Eigenschaft ID_PROP_COMBOLIST_DYNCONTENT_USE schaltet zwischen statischem und dynamischen Betrieb um. Beim statischen Betrieb werden im Editor fixe Einträge definiert. Im dynamischen Betrieb wird eine Inhaltsvariable verknüpft und deren Wert zur Runtime interpretiert.

Unterschied Combobox und Listbox

In der Combobox werden die Texte einzeln in einem Fenster aufgeklappt.

In der Listbox werden die Werte in einer Liste angezeigt, der aktuelle Wert wird markiert dargestellt. Gibt es mehr Zustände als in der Liste darstellbar sind, wird eine Bildlaufleiste angezeigt.

info Info

Hat die Variable einen Wert, der in den Einträgen der Combo-/Listbox nicht definiert wurde, so wird kein Text angezeigt oder markiert.

Statische Combobox oder Listbox

Für eine statische Box werden im Editor fixe Einträge konfiguriert. Diese werden zur Runtime dargestellt und angewendet.

Um Werte einzutragen:

  1. öffnen Sie die Gruppe Darstellung

    Interne ID: Combo-/Listbox

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. wählen Sie mit der Eigenschaft Typ die Darstellungsart aus: Combobox oder Listbox.

    Interne ID: Combo-/Listbox

    Typ

    ComboBox: Dieses Element wird als ComboBox verwendet.
    ListBox: Dieses Element wird als ListBox verwendet.
    Default: ListBox.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Defaultwert: Listbox

  3. deaktivieren Sie die Eigenschaft Einträge aus Stringvariable

    Interne ID: Combo-/Listbox

    Einträge aus Stringvariable

    Aktiv: Einträge für Combo-/Listbox werden über die in der Eigenschaft Variable ausgewählte Stringvariable definiert.

    Interne ID: Combo-/Listbox

    Variable

    Nur verfügbar, wenn Eigenschaft Einträge aus Stringvariable aktiv ist.

    Auswahl der Stringvariable, die die Einträge für Combo-/Listbox enthält. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Inaktiv: Einträge werden im Editor über den Dialog der Eigenschaft Einträge definiert.

    Interne ID: Combo-/Listbox

    Einträge

    Nur verfügbar, wenn die Eigenschaft Einträge aus Stringvariable inaktiv ist.

    Klick auf Schaltfläche ... öffnet den Dialog zur Definition der Einträge für eine statische List-/Combobox.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Default: inaktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. klicken Sie bei der Eigenschaft Einträge auf die Schaltfläche ...
  5. der Dialog zur Konfiguration der Einträge wird geöffnet

  6. tragen Sie Werte für Zustände ein
  7. verknüpfen Sie die Werte mit Texten für Zustände

Dialog Einträge

Parameter

Beschreibung

Einträge

Liste der bereits definierten Einträge.

Nr.

Fortlaufende Nummer, wird automatisch vergeben.

Wert

Wert, der unter Einträge/Wert vergeben wurde.

Wert absetzen

Ja: Wert absetzen ist aktiv.

Nein: Wert absetzen ist inaktiv.

Text

Zeichenfolge, die in Einträge/Text eingegeben wurde.

Funktion

Funktion, die im Feld Einträge/Funktion verknüpft wurde.

Variable

Verknüpfte Sichtbarkeitsvariable.

Neu

Erstellt einen neuen Eintrag mit:

  • fortlaufender Nummer
  • aktivem Wert absetzen

Löschen

Entfernt den ausgewählten Eintrag. Es kann jeweils nur ein Eintrag entfernt werden, Mehrfachauswahl ist nicht möglich.

Kopieren

Kopiert ausgewähltes Element und fügt es am Ende der Liste als neues Element ein. Die Einstellungen des kopierten Elements werden übernommen.

Nach oben/Nach unten

Verschiebt den gewählten Eintrag nach oben oder unten und passt die laufende Nummerierung an.

Eintragseinstellung

Konfiguration der Einträge in der Liste.

Text

Eingabe der Zeichenfolge, die mit dem Wert verknüpft wird.

Wert

Zahlenwert.

Welche Werte eingegeben werden können, hängt ab vom Datentyp der Variablen.

Wert absetzen

Aktiviert oder deaktiviert Sollwert setzen:

Aktiv: Der Wert wird als Sollwert abgesetzt.
Inaktiv: Der eingetragene Wert dient nur zur Indexierung der Selektion.
Achtung: Wert absetzen wirkt sich nur auf den Wert aus, nicht auf die Funktion. Diese wird immer abgesetzt. Bei einem Funktionsaufruf ohne verknüpfter Varible muss Wert Absetzen inaktiv sein!

Funktion

Funktion, die beim Selektieren des Eintrages zur Runtime ausgeführt wird. Klick auf die Schaltfläche ... öffnet den Dialog zur Auswahl einer Funktion.
Achtung: Die Funktion wird nur ausgeführt, wenn Sie den Eintrag über die Combobox/Listbox zur Laufzeit auswählen. Wird der auslösende Wert über eine Wertänderung der Variablen erreicht, wird die Funktion nicht ausgeführt. Bei einem Funktionsaufruf ohne verknüpfter Variable muss Wert Absetzen inaktiv sein!

Sichtbarkeitsvariable

Variable, deren Wertänderungen und damit Grenzwertverletzungen zur Runtime ausgewertet werden. Steht bei der Sichtbarkeitsvariablen eine Grenzwertverletzung an, wird die Eigenschaft Sichtbar von dieser Grenzwertverletzung ausgewertet. Sie bestimmt, ob der Eintrag in der Liste sichtbar ist oder nicht. Standardmäßig (es steht keine Grenzwertverletzung an) wird der Eintrag in der Liste dargestellt. Klick auf die Schaltfläche ... öffnet den Dialog zur Auswahl einer Variablen.

Achtung: Eine Wertänderung im laufenden Betrieb kann dazu führen, dass bei der Ausprägung Combobox eine aufgeklappte Combobox zugeklappt wird.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.

Einträge sortieren

Die Einträge können sortiert werden über:

  • Schaltflächen Nach oben und Nach unten: Gewünschtes Element markieren und mit den Schaltflächen bewegen.
  • Drag&Drop: Element mit der Maus an gewünschte Stelle ziehen. Eine rote Linie zeigt die Stelle, an der das Element eingefügt wird, an.

Dynamische Combobox oder Listbox

Für den dynamischen Betrieb muss über die Eigenschaft Variable eine Stringvariable , die die Inhalte definiert, verknüpft werden. Zur Runtime werden eventuell parallel konfigurierte statische Einträgen ignoriert. Der Wert Inhaltsvariable wird ausgewertet und interpretiert. Dafür muss der Wert der Variablen zur Runtime einem gültigen Layout entsprechen.

Layout

Der Stringwert stellt eine Liste von Einträgen dar. Jeder Eintrag besteht aus einen Wert und einen Text, die mit einen Komma „," getrennt werden. Einträge werden mit einem Semikolon „;" abgeschlossen. Enthält der Text-Teil eines Eintrags das Zeichen „@", wird der Textteil mit Hilfe der vorhandene Sprachtabelle übersetzt.

Beispiel eines gültigen Stringwerts:

1,eins;2,zwei;3,drei;

Beispiel eines gültigen Stringwerts mit Übersetzung:

1,@eins;2,@zwei;3,@drei;

Konfiguration

Um eine Variable zu verknüpfen:

  1. öffnen Sie die Gruppe Darstellung
  2. wählen Sie mit der Eigenschaft Typ die Darstellungsart aus: Combobox oder Listbox.

    Defaultwert: Listbox

  3. aktivieren Sie die Eigenschaft Einträge aus Stringvariable
  4. wählen Sie mit der Eigenschaft Variable die gewünschte Variable aus
    (Klick auf Schaltfläche ... öffnet Dialog für die Variablenauswahl)
  5. wählen Sie die Stringvariable mit den konfigurierten Einträgen

Element in Liste bei Auswahl hervorheben

Die in der Liste der Combobox oder Listbox angezeigten Elemente können zur Runtime farblich hervorgehoben werden. Dazu:

  • navigieren Sie in den Eigenschaften zur Gruppe Farben

    Interne ID: Combo-/Listbox

    Farben

    Farbeigenschaften des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • wählen Sie inder Gruppe Farben statisch die Eigenschaften

    Interne ID: Combo-/Listbox

    Farben statisch

    Eigenschaften für die farbliche Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Textfarbe bei Selektion für die Textfarbe

      Interne ID: Combo-/Listbox

      Textfarbe bei Selektion

      Definiert die Farbe des Textes, wenn ein Element ausgewählt wird. Die Farbe kann als Hexadezimalwert direkt in das Feld eingegeben oder nach Klick auf ... ausgewählt werden. Die Farbe ist statisch und verwendet nicht die verknüpfte Variable.

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Hintergrundfarbe bei Selektion für die Hintergrundfarbe des Textes

      Interne ID: Combo-/Listbox

      Hintergrundfarbe bei Selektion

      Definiert die Hintergrundfarbe, wenn ein Element ausgewählt wird. Die Farbe kann als Hexadezimalwert direkt in das Feld eingegeben oder nach Klick auf ... ausgewählt werden. Die Farbe ist statisch und verwendet nicht die verknüpfte Variable.

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Damit werden zur Runtime diese Farben verwendet. Einstellungen des Betriebssystems werden ignoriert, wie auch die Farben der verknüpften Variablen.

info Info

Bis zur Version 6.50 wurden die Farben des Betriebssystems verwendet. Beim Konvertieren von Projekten wird:

  • die Hintergrundfarbe auf die im Betriebssystem konfigurierte Farbe gesetzt
  • wird die Textfarbe als statisch definierte Farbe festgelegt

Auf Rechnern, bei denen die Farben im Betriebssystem geändert wurde, kann es zu unterschiedlichem Verhalten zur Runtime kommen.

Fehlerbehandlung

Fehler werden als Log-Eintrag im Diagnosis Server angezeigt:

Meldung | Ebene | Bedeutung
The value '%s' of the content variable '%s' is not valid, entries might be incorrect or missing! | Fehler | Die in der Eigenschaft Variable verknüpfte Stringvariable hat einen Wert mit ungültigem Layout. Der Text wird so weit wie möglich ausgewertet. Der aktuelle Wert wird mitgeloggt, um die Fehleranalyse zur Runtime zu erleichtern.


Dynamischer Text

Handbuch -> Bilder -> Bildelemente -> Dynamischer Text

Mit dem Dynamischen Element Dynamischer Text stellen Sie bei einer Grenzwertverletzung den aktuellen Grenzwerttext einer numerischen Variablen oder den Wert einer Stringvariablen in alphanumerischer Form dar. Liegt keine Grenzwertverletzung vor, wird der im Editor definierte Text angezeigt.

Um Dynamischen Text in einem Bild anzulegen:

  1. wählen Sie das Symbol Dynamischer Text in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl einer Variablen öffnet sich
  5. wählen Sie die gewünschte Variable
  6. definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften


Ellipse

Handbuch -> Bilder -> Bildelemente -> Ellipse

Um eine Ellipse zu zeichnen:

  1. wählen Sie das Symbol Ellipse/Kreis in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste die Ellipse auf
  4. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  5. halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt
  6. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster


Kreis

Handbuch -> Bilder -> Bildelemente -> Kreis

Um einen Kreis zu zeichnen:

  1. wählen Sie das Symbol Ellipse/Kreis in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. halten Sie Umschalt gedrückt
  4. ziehen Sie mit gedrückter linker Maustaste den Kreis auf
  5. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  6. halten Sie beim Ziehen an den äußeren Eckpunkten Alt gedrückt, so wird die Änderung symmetrisch ausgeführt
  7. soll die Kreisform beim Ziehen erhalten bleiben, halten Sie Umschalt gedrückt
  8. definieren Sie die gewünschten Eigenschaften im Eigeschaftenfenster


Kreisbogen

Handbuch -> Bilder -> Bildelemente -> Kreisbogen

Um einen Kreisbogen zu zeichnen:

  • wählen Sie das Symbol Kreisbogen in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  • wählen Sie im Hauptfenster den Startpunkt
  • ziehen Sie mit gedrückter linker Maustaste den Kreisbogen
  • aufziehen nach rechts oben öffnet den Kreisbogen nach links oben, analog funktionieren alle Richtungen
  • um die Öffnungsrichtung zu ändern, bewegen Sie einen mittleren Anfasspunkt über die gegenüberliegende Linie
  • Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  • halten Sie beim Ziehen an den äußeren Eckpunkten Alt gedrückt, so wird die Änderung symmetrisch ausgeführt
  • halten Sie beim Ziehen Umschalt gedrückt, so werden die Seitenverhältnisse beibehalten
  • definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

info Info

Der Kreisbogen wird immer als Viertelkreis dargestellt und kann durch Kopieren und Einfügen erweitert werden.
Füllmuster und Füllfarbe stehen für Kreisbögen nicht zur Verfügung.


Kreissegment

Handbuch -> Bilder -> Bildelemente -> Kreissegment

attention Achtung

Mit dem Kreissegment zeichnen Sie einen beliebigen Teil eines Kreises oder einer Ellipse.

Um ein Kreissegment zu zeichnen:

  1. wählen Sie das Symbol Kreissegment in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Kreissegment auf
  4. aufziehen nach rechts oben öffnet das Kreissegment nach links und umgekehrt
  5. um die Öffnungsrichtung zu ändern, bewegen Sie einen mittleren Anfasspunkt über die gegenüberliegende Linie
  6. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  7. halten Sie beim Ziehen an den äußeren Eckpunkten Alt gedrückt, so wird die Änderung symmetrisch ausgeführt
  8. halten Sie beim Ziehen Umschalt gedrückt, so werden die Seitenverhältnisse beibehalten
  9. um den Öffnungswinkel zu ändern oder das Kreissegment nach oben oder unten zu öffnen, haben Sie zwei Möglichkeiten:
    • bewegen Sie die Maus über einen der beiden geteilten Anfasspunkte bis sich der Mauszeiger über dem äußeren der beiden Punkte in ein Schwarzes Kreuz mit Pfeilen verwandelt und bewegen Sie den Punkt in die gewünschte Richtung
      oder
    • ändern Sie in den Eigenschaften unter Öffnungswinkel die Winkelangaben. Z.B.:
      - für Öffnung nach unten: Endwinkel [°] 180° und Startwinkel [°] auf 0°
      - für Öffnung nach: oben umgekehrt
      Winkelangaben können maximal 2 Kommastellen haben.
      Hinweis: Da die aus Winkelangaben berechneten Eckpunkte Pixel sind, und diese ganzzahlig sein müssen, kann es vorkommen, dass die Winkeldarstellung von der Angabe etwas abweicht. Zum beispiel ergibt die Angabe 45° keinen ganzzahligen Pixel. zenon intern wird abgerundet und der Winkel wird als 44,75° angezeigt.

      Interne ID: Kreissegment

      Startwinkel [°]

      Anfang des Öffnungswinkels. Der Öffnungswinkel des Kreissegmentes wird zwischen Startwinkel und Endwinkel angezeigt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Kreissegment

      Endwinkel [°]

      Ende des Öffnungswinkels. Der Öffnungswinkel des Kreissegmentes wird zwischen Startwinkel und Endwinkel angezeigt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Kreissegment

      Öffnungswinkel

      Definition der Winkel für das Kreissegment

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  10. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

Legende:

1) Anfasspunkt für Öffnungswinkel

2) Anfasspunkt für Höhe

info Info

Möchten Sie das Kreissegment als Kreisbogen mit freiem Öffnungswinkel verwenden, ändern Sie dazu die Eigenschaft Füllmuster auf den Wert transparent. Mit der Darstellungsart transparent wird nur die äußere Linie dargestellt.
Der Öffnungswinkel muss immer > 0° und < 360° sein.

Interne ID: Kreissegment

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: Kreissegment

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Achtung

Das Element Kreissegment steht unter Windows CE nicht zur Verfügung.


Linie

Handbuch -> Bilder -> Bildelemente -> Linie

Um eine Linie zu zeichnen:

  1. wählen Sie das Symbol Linie in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste die Linie auf
  4. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements möglich
  5. halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt
  6. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

info Info

Füllmuster und Füllfarbe stehen für Linien nicht zur Verfügung.


Meldungungselement

Handbuch -> Bilder -> Bildelemente -> Meldungungselement

Mit dem Dynamischen Element Meldungselement zeigen Sie zur Runtime Texte in Abhängigkeit von Zuständen der Prozessvariablen an. Quelle für die Texte sind ASCII-Textdateien, die als Tabelle aufgebaut sind. Diese können Sie frei projektieren.

Um das Meldungselement in einem Bild anzulegen:

  1. wählen Sie das Symbol Meldungselement in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl mehrerer Variablen öffnet sich
  5. wählen Sie die gewünschten Variablen
  6. definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften

Aufbau der Tabelle

  • Erstellen Sie ein ASCII Text-Dokument
  • speichern Sie es unbedingt im Format Unicode
  • als Spaltentrennzeichen benutzen Sie das Zeichen |(ASCII-Code 124)
  • Beispiel:

    1 | Aus | Ein | Diff | Stör

    2 |Off | On | True | False

    4 | Text1 | Text2 | Text3 | Text4

  • die verknüpften Variablen definieren Zeile und Spalte des anzuzeigenden Textes

Erste Variable

Die erste Variable in der Liste muss eine Wortvariable sein und definiert die Spalte, aus der der Text genommen wird. Gleichzeitig steuert sie die Art der Verarbeitung.

Bit gesetzt | Wirkung
Bit 15 (Bit mit höchstem Wert | Meldeelement gesperrt; es wird nichts mehr angezeigt.
Bit 14 | Aktualisierung der Bildschirmausgabe abgeschaltet; letzter aktiver Text wird angezeigt.

Hinweis: Für eine 16-Bit Variable sind maximal 14 Spalten möglich. Die Adressierung der Spalte erfolgt über die Bit-Nummer und nicht über den Analogwert.

Zweite und weitere Variablen

Die weiteren Prozessvariablen definieren die Zeilenposition, aus der der Text genommen wird. Die Wertigkeit ergibt sich aus

Wert | Zeile
1 | Zeile 1
2 | Zeile 2
4 | Zeile 3

Jede Zeilenvariable ist für maximal 16 Zeilen zuständig. Wenn mehr als 16 Zeilen benötigt werden, können weitere Zeilenvariablen definiert werden.

Soll Zeile 1 und Zeile 2 wechselnd angezeigt werden, muss die Wertigkeit der Zeilenvariablen 3 betragen. Sind alle 16 Bit gesetzt, so werden Zeile 1 bis Zeile 16 abwechselnd angezeigt.


Multibin

Handbuch -> Bilder -> Bildelemente -> Multibin

Mit dem Dynamische Element Multibin können Sie mehrere Zustände definieren:

  • eine Grafik abhängig von Variablenwerten anzeigen
  • Symbole einfärben
  • Zustandstext ausgeben
  • numerische Variablen und Binärvariablen verknüpfen
  • einen Schalter oder Taster für die erste Variable darstellen, sofern die erste Variable eine Binärvariable ist

Erstellen des Elements Multibin

Um Multibin in einem Bild anzulegen:

  1. wählen Sie das Symbol Multibin in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl mehrerer Variablen öffnet sich
  5. wählen Sie die gewünschten Variablen
  6. definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften

Zustände definieren

Die Einstellungen für anzuzeigende Zustände von Variablen definieren Sie im Dialog zur Eingabe der Elemente:

  1. klicken Sie im Knoten Darstellung

    Interne ID: Multibin

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. auf die Eigenschaft Konfiguration

    Interne ID: Multibin

    Konfiguration

    Öffnet den Dialog zur Definition der Zustände.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog zur Zustandsdefinition öffnet sich
  4. definierte Zustände werden von oben nach unten abgearbeitet
  5. die Einstellungen des ersten zutreffenden Zustands werden angezeigt

Noch in diesem Kapitel

Zustandsdefinition Multibin


Zustandsdefinition Multibin

Handbuch -> Bilder -> Bildelemente -> Multibin -> Zustandsdefinition Multibin

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Grafik

Bildsymbol/Zustandstext

Schalter Einstellungen

Um dem Element Multibin bestimmte Zustände zuzuweisen:

  1. klicken Sie im Knoten Darstellung

    Interne ID: Zustandsdefinition Multibin

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. auf die Eigenschaft Konfiguration

    Interne ID: Zustandsdefinition Multibin

    Konfiguration

    Öffnet den Dialog zur Definition der Zustände.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog zur Eingabe der Elemente öffnet sich
  4. wählen Sie gewünschte Darstellungsart:
    • Grafik: Darstellung der Information in Pixelgrafikdateien; damit sind auch bewegte Bilder möglich
    • Bildsymbol/Zustandstext: Darstellung über Symbole und Textinformationen
  5. Definierte Zustände werden von oben nach unten abgearbeitet und die Einstellungen des ersten zutreffenden Zustands werden angezeigt.


Grafik

Handbuch -> Bilder -> Bildelemente -> Multibin -> Zustandsdefinition Multibin -> Grafik

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Darstellung der Information in Pixelgrafikdateien, erlaubt auch bewegte Bilder.

Eigenschaft

Beschreibung

In Originalgröße

Aktiv: Grafiken werden in Originalgröße dargestellt.

Inaktiv: Grafiken werden zur Runtime auf die darzustellende Größe gestreckt bzw. gestaucht.

Optionen

Status anzeigen

Markiert das Element zur Runtime mit einem roten Punkt bei Ausnahmestatus.

Blinken aller Variablen berücksichtigen

Aktiv:Summenalarmierung aller verknüpften Prozessvariablen. Die Grafik bzw. Farbe wird durch den aktuellen Zustand festgelegt. Aktive Blinkzustände bleiben bis zur Quittierung erhalten.

Zustand 0 (LOW)

Einstellungen für den aktuellen Zustand passend zur Darstellungsart.

Grafik

Auswahl der Grafik. Klick auf Fläche öffnet Dialog zur Auswahl der Datei.

  • Um eine Datei aus einem Projekt auszuwählen, muss diese im Knoten Dateien/Grafiken im Projektmanager bereits vorhanden sein.
  • Um eine Datei direkt aus einem beliebigen Ordner des Rechners auszuwählen, muss die Eigenschaft Direkte Dateiauswahl aktiviert werden.

Weitere Zustände

Auswahl weiterer Variablen über die Schaltfläche ... und Sortierung der Zustände über die Schaltflächen Nach-oben und Nach-unten.

Für jede der verknüpften Variablen muss ein diskreter Zustand angegeben werden; bei Mehrbitmeldungen und bei numerischen Wertendurch die Eingabe des Wertes. Mehrbitmeldungen müssen mehrmals zugeordnet werden: Anzahl der Zustände minus 1; Bsp. Doppelmeldung=3.

Ist ein diskreter Zustand eingetreten, wird dieser dargestellt. Ist keiner der angegebenen Werte anstehend, wird der global für das Element gültige Zustand 0 [LOW] angezeigt.

Hinweis: Bei nicht-binären Variablen wird der Wert in der Signalauflösung angegeben.


Bildsymbol/Zustandstext

Handbuch -> Bilder -> Bildelemente -> Multibin -> Zustandsdefinition Multibin -> Bildsymbol/Zustandstext

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Darstellung über Symbole und Textinformationen. Gleichzeitig wird die Farbe des aktuellen Zustandes dem Symbol übergeben.

Eigenschaft

Beschreibung

Bildsymbol/
Zustandstext

Auswahl eines Symbols. Das Symbol muss im Bild bereits vorhanden sein. Das in der Dropdwon Liste ausgewählte Symbol blinkt im Bild bis der Dialog Element-Eingabe beendet wird.

Zustandstext anzeigen

Aktiv: Zustandtexte werden zur Runtime angezeigt.

Hintergrundfarbe einstellbar

Aktiv: Hintergrundfarbe für den Text ist frei wählbar.

Optionen

Status anzeigen

Markiert das Element zur Runtime mit einem roten Punkt bei Ausnahmestatus.

Nur Füllfläche einfärben

es werden nur die Füllflächen der statischen Elemente eingefärbt, Rahmenfarben bleiben erhalten

Blinken aller Variablen berücksichtigen

Aktiv: Summenalarmierung aller verknüpften Prozessvariablen. Die Grafik bzw. Farbe wird durch den aktuellen Zustand festgelegt. Aktive Blinkzustände bleiben bis zur Quittierung erhalten.

Hintergrundfarbe beim Blinken

Hintergrundfarbe beim Blinken

Zustand 0 (Low)

Zustandstext

Text der zur Runtime angezeigt wird. Eingabe nur möglich wenn die Eigenschaft Zustandstext anzeigen aktiv ist.

Symbol-/Textfarbe

Auswahl der Farbe für das Symbol und den Zustandstext.

Text Hintergrundfarbe

Wahl der Hintergrundfarbe für den Zustandsttext. Nur vorhanden, wenn die Eigenschaft Hintergrundfarbe einstellbar aktiv ist.

Weitere Zustände

Auswahl weiterer Variablen über die Schaltfläche ... und Sortierung der Zustände über die Schaltflächen Nach-oben und Nach-unten.

Für jede der verknüpften Variablen muss ein diskreter Zustand angegeben werden; bei Mehrbitmeldungen und bei numerischen Wertendurch die Eingabe des Wertes. Mehrbitmeldungen müssen mehrmals zugeordnet werden: Anzahl der Zustände minus 1; Bsp. Doppelmeldung=3.

Ist ein diskreter Zustand eingetreten, wird dieser dargestellt. Ist keiner der angegebenen Werte anstehend, wird der global für das Element gültige Zustand 0 [LOW] angezeigt.

Hinweis: Bei nicht-binären Variablen wird der Wert in der Signalauflösung angegeben.


Schalter Einstellungen

Handbuch -> Bilder -> Bildelemente -> Multibin -> Zustandsdefinition Multibin -> Schalter Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ist als erste Variable eine Binärvariable verknüpft, kann diese als Schalter oder Taster benutzt werden.

Eigenschaft | Beschreibung
Nur lesen | Zur Runtime ist keine Sollwertvorgabe möglich.
Schalter | Element fungiert als Schalter für Sollwertvorgabe.
Taster EIN | Setzt Sollwert HIGH ab. Die Taster-Vorzugslage geht auf Aus.
Taster AUS | Setzt Sollwert LOW ab. Die Taster-Vorzugslage geht auf Ein.
Haltezeit in ms | Haltezeit des Sollzustandes.
Berechtigungsgruppe | Legt die für die Sollwerteingabe nötige Berechtigungsebene fest.
Tastenkombination | Tastenkombination für Sollwertvorgabe


Polygon

Handbuch -> Bilder -> Bildelemente -> Polygon

Um ein Polygon zu zeichnen:

  1. wählen Sie das Symbol Polygon in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt mit einem Klick der linken Maustaste
  3. ziehen Sie die erste Teilstrecke
  4. setzen Sie mit einem einfachen Mausklick (links) einen ersten Eckpunkt
  5. ziehen sie weitere Linien und setzen Sie Eckpunkte
  6. ein Doppelklick oder das Drücken von Esc setzen den Endpunkt
  7. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  8. halten Sie beim Ziehen Umschalt gedrückt, so sind ausgehend von der ursprünglichen Position nur horizontale oder vertikale Bewegungen möglich
  9. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

    Tipp: Mit der Eigenschaft Rundung definieren Sie Rundung der Linien. Wählen Sie dazu einen Wert zwischen 0 (keine Rundung) und 1 (maximale Rundung).

    Interne ID: Polygon

    Rundung

    Nur verfügbar, wenn in den Projekteigenschaften die Option Grafikqualität im Knoten Grafische Ausprägung/Bilder aktiviert wurde.

    Interne ID: Polygon

    Bilder

    Eigenschaften für die Anzeige der Bilder in der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Polygon

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Polygon

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Polygon

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert für Polylinien, Polygone und Rohrleitungen die Rundung.

    Werte: 0,0 (keine Rundung) bis 1,0. (maximale Rundung)

    Default: 0

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinzufügen von Punkten:

Um Eckpunkte (Stützpunkte) hinzuzufügen:

  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Hinzufügen eines Knotens im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick fügt einen Eckpunkt hinzu

Löschen von Punkten:

  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Löschen des Knoten im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick entfernt den Punkt

info Info

Die Eigenschaft Über Helligkeitswerte steht für Polygone nicht zur Verfügung.

Interne ID: Polygon

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: Polygon

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Polylinie

Handbuch -> Bilder -> Bildelemente -> Polylinie

Um eine Polylinie zu zeichnen:

  1. wählen Sie das Symbol Polylinie in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt mit einem Klick der linken Maustaste
  3. ziehen Sie die erste Teilstrecke
  4. setzen Sie mit einem einfachen Mausklick (links) einen ersten Eckpunkt
  5. ziehen sie weitere Linien und setzen Sie Eckpunkte
  6. ein Doppelklick oder das Drücken von Esc setzen den Endpunkt
  7. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  8. halten Sie beim Ziehen Umschalt gedrückt, so sind ausgehend von der ursprünglichen Position nur horizontale oder vertikale Bewegungen möglich
  9. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

    Tipp: Mit der Eigenschaft Rundung definieren Sie Rundung der Linien. Wählen Sie dazu einen Wert zwischen 0 (keine Rundung) und 1.

    Interne ID: Polylinie

    Rundung

    Nur verfügbar, wenn in den Projekteigenschaften die Option Grafikqualität im Knoten Grafische Ausprägung/Bilder aktiviert wurde.

    Interne ID: Polylinie

    Bilder

    Eigenschaften für die Anzeige der Bilder in der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Polylinie

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Polylinie

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Polylinie

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert für Polylinien, Polygone und Rohrleitungen die Rundung.

    Werte: 0,0 (keine Rundung) bis 1,0. (maximale Rundung)

    Default: 0

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinzufügen von Punkten:

Um Eckpunkte (Stützpunkte) hinzuzufügen:

  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Hinzufügen eines Knotens im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick fügt einen Eckpunkt hinzu

Löschen von Punkten:

  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Löschen des Knoten im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick entfernt den Punkt

attention Achtung

Wenn Sie eine Polylinie zu einem Polygon formen, werden die Anfasspunkte für Start und Ende der Linie beim Überlappen unsichtbar, wen die Option Hintergrund invertieren aktiviert ist. Diese Option deaktivieren Sie unter Menü Optionen -> Einstellungen -> Eckpunkte -> Hintergrund invertieren.


Rechteck

Handbuch -> Bilder -> Bildelemente -> Rechteck

Um ein Rechteck zu zeichnen:

  1. wählen Sie das Symbol Rechteck in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Rechteck auf
  4. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  5. halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt
  6. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

    Tipp: Sie können die Ecken beliebig runden um ein abgerundetes Rechteck zu erzeugen


Quadrat

Handbuch -> Bilder -> Bildelemente -> Quadrat

Um ein Quadrat zu zeichnen:

  1. wählen Sie das Symbol Rechteck in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. halten Sie Umschalt gedrückt
  3. wählen Sie im Hauptfenster den Startpunkt
  4. ziehen Sie mit gedrückter linker Maustaste das Quadrat auf
  5. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements;
    soll bei Größenänderungen die Form 'Quadrat' erhalten bleiben, drücken Sie Umschalt während des Ziehens an den Eckpunkten
  6. halten Sie beim Ziehen an den äußeren Eckpunkten Alt gedrückt, so wird die Änderung symmetrisch ausgeführt
  7. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster


Rohrleitung

Handbuch -> Bilder -> Bildelemente -> Rohrleitung

Um eine Rohrleitung zu zeichnen:

  1. wählen Sie das Symbol Rohrleitung in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt mit einem Klick der linken Maustaste
  3. ziehen Sie die erste Teilstrecke
  4. setzen Sie mit einem einfachen Mausklick (links) einen ersten Eckpunkt
  5. ziehen sie weitere Linien und setzen Sie Eckpunkte
  6. ein Doppelklick oder Drücken von Esc setzen den Endpunkt
  7. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  8. halten Sie beim Ziehen Umschalt gedrückt, so sind ausgehend von der ursprünglichen Position nur horizontale oder vertikale Bewegungen möglich
  9. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

    Tipp: Mit der Eigenschaft Rundung definieren Sie Rundung der Linien. Wählen Sie dazu einen Wert zwischen 0 (keine Rundung) und 1 (maximale Rundung).

    Interne ID: Rohrleitung

    Rundung

    Nur verfügbar, wenn in den Projekteigenschaften die Option Grafikqualität im Knoten Grafische Ausprägung/Bilder aktiviert wurde.

    Interne ID: Rohrleitung

    Bilder

    Eigenschaften für die Anzeige der Bilder in der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Rohrleitung

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Rohrleitung

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Rohrleitung

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert für Polylinien, Polygone und Rohrleitungen die Rundung.

    Werte: 0,0 (keine Rundung) bis 1,0. (maximale Rundung)

    Default: 0

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinzufügen von Punkten:

Um Eckpunkte (Stützpunkte) hinzuzufügen:

  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Hinzufügen eines Knotens im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick fügt einen Eckpunkt hinzu

Löschen von Punkten:

  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Löschen des Knoten im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick entfernt den Punkt


Schalter

Handbuch -> Bilder -> Bildelemente -> Schalter

Mit dem Dynamische Element Schalter zeigen Sie die Werte einer Binärvariablen über Grafiken an und modifizieren sie. Das Element kann auch als Taster zur einstufigen ungesicherten Befehlsgabe verwendet werden.

Um einen Schalter in einem Bild anzulegen:

  • wählen Sie das Symbol Schalter in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  • wählen Sie im Hauptfenster den Startpunkt
  • ziehen Sie mit gedrückter linker Maustaste das Element auf
  • der Dialog zur Auswahl einer binären Variablen öffnet sich
  • wählen Sie die gewünschte Variable
  • definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften.

    Um das Element als Taster zu verwenden, aktivieren Sie im Knoten Sollwert absetzen die Eigenschaft Taster.

    Interne ID: Schalter

    Taster

    Nur verfügbar, wenn Schalter aktiv ist. (Ausnahme: Im Dynamischen Element Schalter immer verfügbar.)
    Aktiv: Der Sollzustand - definiert in der Eigenschaft Taster EIN - wird nur solange hergestellt, wie die linke Maustaste gedrückt bleibt, aber mindestens die Haltezeit [ms] lang.
    Inaktiv: Der Sollzustand bleibt, auch wenn die Maustaste losgelassen wird.
    Default: inaktiv.

    Interne ID: Schalter

    Haltezeit [ms]

    Nur verfügbar, wenn Schalter aktiv ist:
    Wenn Taster aktiv ist: Zeit (in ms), die ein Zustand gehalten wird, ausgehend vom Linksklick auf das entsprechende Element.

    Wenn Taster inaktiv ist: Reaktionsverzögerung auf Linksklick.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Schalter

    Taster EIN

    Nur verfügbar, wenn Taster aktiv ist:
    Aktiv: Taster schaltet auf EIN.
    Inaktiv: Taster schaltet auf AUS.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Schalter

    Schalter

    Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

    Interne ID: Schalter

    SW setzen aktiv

    Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
    Inaktiv: In diesem Element ist die Variable schreibgeschützt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Aktiv: Das Element schaltet den Wert einer Bit-Variable.
    Inaktiv: Das Element führt eine Funktion aus.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Schalter

    Sollwert absetzen

    Eigenschaften zum Setzen von Sollwerten.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Statischer Text

Handbuch -> Bilder -> Bildelemente -> Statischer Text

Um Statischen Text einzutragen:

  1. wählen Sie das Symbol Statischer Text in der Symbolleiste Elemente oder in der Dropdownliste Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Textfeld auf
  4. Form, Größe und Position sind jederzeit änderbar durch Ziehen an den Eckpunkten oder Bewegen des Elements
  5. halten Sie beim Ziehen an den äußeren Eckpunkten die Alt-Taste gedrückt, so wird die Änderung symmetrisch ausgeführt
  6. definieren Sie die gewünschten Eigenschaften im Eigenschaftenfenster

Um Text einzugeben:

  1. klicken Sie mit einem verzögerten Doppelklick auf das Textfeld

    oder: wählen Sie im Kontextmenü Text bearbeiten

  2. schreiben Sie den gewünschten Text

info Info

Der Umbruch des Textes erfolgt standardmäßig automatisch, abhängig von der Größe des Textfeldes. Um den Umbruch abzuschalten, deaktivieren Sie im Knoten Darstellung die Eigenschaft Textumbruch.

Interne ID: Statischer Text

Textumbruch

Aktiv: Automatischer Zeilenumbruch wird für den Text im Element verwendet.
Die Länge der Zeilen hängt von der Breite des Elements ab.
Inaktiv: Der Text wird in einer Zeile dargestellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Statischer Text

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Tipp: Wird in den Eigenschaften ein Textwinkel [°] (Darstellung) definiert, ist kein Umbruch des Textes möglich. Eine Winkeldarstellung mit Umbruch des Textes kann aber durch Drehen des gesamten Elements (inklusive der Rahmenlinien, falls aktiviert) erreicht werden.

Interne ID: Statischer Text

Textwinkel [°]

Winkel für die Darstellung des Textes.

ACHTUNG: Diese Option funktioniert nur bei eingebetteten Schriften.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Unterstreichen

Um Text zu unterstreichen, stellen sie dem zu unterstreichenden Zeichen ein & vor.

T&ext wird zu:

Möchten Sie das Zeichen '&' im Text benutzen, geben Sie es doppelt ein:
1 && 2 wird zu 1 & 2.

Zeilenumbruch

Um einen Zeilenumbruch festzulegen, benutzen Sie die Zeichenfolge \n.

Beispiel:

Zeile 1 \n

Zeile 2

info Info

Ab Version 6.51 ist die Eingabe nicht mehr auf 80 Zeichen begrenzt.


Symbol bewegen (nur bis Version 6.22)

Handbuch -> Bilder -> Bildelemente -> Symbol bewegen (nur bis Version 6.22)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem Dynamischen Element Symbol bewegen bewegen Sie beliebige Elemente abhängig vom Zustand anderer Variablen horizontal und vertikal oder verändern ihre Größe (Zoom). Dazu verbinden Sie die Elemente mit einem Symbol.

Um Symbol bewegen in einem Bild anzulegen:

  • wählen Sie das Symbol Symbol bewegen in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  • wählen Sie im Hauptfenster den Startpunkt
  • ziehen Sie mit gedrückter linker Maustaste das Element auf
  • wählen Sie die gewünschte Variable definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften
  • Sie können ur Symbole benutzen, die sich bereits im Bild befinden

Das Dynamische Element Symbol bewegen steht bis zur Version 6.22 zur Verfügung. Ab Version 6.50 nutzen Sie für alle dynamischen Aktionen die dynamischen Eigenschaften eines Elements wie Position, Größe und Drehen dynamisch oder Farben.

Interne ID: Symbol bewegen (nur bis Version 6.22)

Farben

Farbeigenschaften des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Symbol bewegen (nur bis Version 6.22)

Größe und Drehen dynamisch

Eigenschaften zur Dynamik des Elements.
Die Darstellung des Elements wird über Zustände von Variablen zur Laufzeit dynamisch angepasst.

Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Symbol bewegen (nur bis Version 6.22)

Position

Eigenschaften zu Position und Größe des Dynamischen Elements.

Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Trend-Element

Handbuch -> Bilder -> Bildelemente -> Trend-Element

Mit dem Dynamische Element Trend-Element stellen Sie Werte zur Runtime in Form von Trendkurven dar, wobei mehrere Prozessvariablen gleichzeitig dargestellt werden können.

Damit das Trend-Element Werte darstellen kann, muss die Eigenschaft Harddisk Datenspeicherung aktiv im Knoten Harddisk Datenspeicherung der Eigenschaften der Variablen aktiv sein sein. Zykluszeit [s] und Anzahl Werte müssen mit der Aktualisierungszeit und dem Darstellungszeitraum im Trend-Element übereinstimmen, sonst wird bei jedem Aufschalten des Bildes das Zeichnen der Kurven neu begonnen. Jede Änderung kann Auswirkung auf andere Trend-Elemente haben, die die gleiche Prozessvariable verwenden.

Interne ID: Trend-Element

Darstellungszeitraum

Zeitraum, der in den Kurven dargestellt werden soll.
(Stunden, Minuten Sekunden)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Trend-Element

Aktualisierungszeit

Zeitintervall, in dem die Darstellung aktualisiert wird (d.h. ein neuer Wert hinzugefügt wird).
(Stunden, Minuten, Sekunden, Millisekunden)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Trend-Element

Anzahl Werte

Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
Werteanzahl für die Ablage von Onlinewerten auf der Festplatte (Ringspeicher) für die Auswertung im Dynamischen Element Trend, für Onlinedaten im Erweiterten Trend oder den Export/Import der Werte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Trend-Element

Zykluszeit [s]

Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
Intervallzeit [in Sekunden] für die Ablage von Onlinewerten auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element Trend, für Onlinedaten im Erweiterten Trend oder den Export/Import der Werte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Trend-Element

Harddisk Datenspeicherung

Eigenschaften für das Speichern von Variablenwerten auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Trend-Element

Harddisk Datenspeicherung aktiv

Aktiv: Variablenwerte werden auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element "Trendelement" oder den Export/Import der Werte gespeichert.

Inaktiv: Keine Variablenwerte werden gespeichert.

Default: inaktiv.

Die HD-Daten brauchen je gespeicherten HD-Wert 24 Bytes Platz, unabhängig vom zu speichernden Variablentyp. Neben dem Wert werden noch folgende Informationen gespeichert:
- Zeit, zu der der Wert gemessen wurde.
- Millisekunden beim Einlesen des Wertes.
- Status des Wertes um Elemente entsprechend anzupassen.
- Zähler für eindeutige Kennung des Wertes (Spontantreiber).

Hinweis: Die Datenspeicherung wird auch bei der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend aktiviert, wenn Onlinedaten ausgewertet werden.
Variablen vom Typ String werden von der Harddisk-Datenspeicherung nicht unterstützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Erstellen eines Trend-Elements

Um ein Trend-Element in einem Bild anzulegen:

  1. wählen Sie das Symbol Trend-Element in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl mehrerer numerischer Variablen öffnet sich
  5. wählen Sie die gewünschten Variablen
  6. sämtliche Kurven werden im Trend-Element automatisch angelegt

    Um später neue Kurven hinzuzufügen:

    • wählen Sie in den Eigenschaften im Knoten Kurven die Eigenschaft {Kurve neu}

      Interne ID: Trend-Element

      {Kurve neu}

      Eine neue Kurve für das Trendelement wird erstellt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Trend-Element

      Kurven

      Eigenschaften für die Kurven des Trendelements.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      oder:

    • ziehen Sie die gewünschte Variable mit gedrückter linker Maustaste auf das Trend-Element
  7. definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften
    • Grafische Eigenschaften der Kurven zur Runtime definieren Sie im Knoten Kurven der Eigenschaften
    • Zykluszeit und Anzahl der Werte bestimmen Sie bei den Eigenschaften der jeweiligen Variablen im Knoten Harddisk Datenspeicherung

info Info

Funktionen und Variablen können auch per Drag&Drop mit dem Element verknüpft werden.


Uhr

Handbuch -> Bilder -> Bildelemente -> Uhr

Mit dem Dynamische Element Uhr zeigen Sie zur Runtime die aktuelle Uhrzeit an oder rechnen Sie numerische Werte in eine Uhrzeit um. Das Datum und/oder die Zeit kann als Absolutzeit oder ein Zeitunterschied dargestellt werden.

Anzeige

Die Anzeige zur Runtime hängt davon ab, ob eine Variable verknüpft wurde.

  • Ist keine Variable mit dem Element verknüpft, wird zur Runtime die aktuelle Systemzeit in Absolutzeit angezeigt.
    Dazu setzen Sie in der Gruppe Darstellung die Eigenschaft Anzeigetyp auf den Wert Systemzeit/Absolutzeit.

    Interne ID: Uhr

    Anzeigetyp

    Absolutzeit: Es wird die Zeit der Systemuhr mit den entsprechenden Formatierungen angezeigt.
    Zeitdifferenz: Der Wert einer verknüpften Variablen wird im eingestellten Zeitformat dargestellt.
    Default: Absolutzeit.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Uhr

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ist eine Variable verknüpft, kann deren Wert angezeigt werden als:
    • Zeitdifferenz: die Variable muss die Anzahl von Sekunden enthalten.
      Es können die Integer-Werte im Sekundenraum -2147483648 (min(DINT)) bis + 4294967295 (max(UDINT)) angezeigt werden.
      Es ist also auch möglich, negative Werte darzustellen: Ein Variablenwert von -60 wird im Format mm:ss als -01:00 angezeigt. Umgekehrt wird aus der Anzeige -01:40 der Variablenwert -100.
    • Absolutzeit: die Unixzeit, also die seit dem 1. Januar 1970 00:00 h UTC vergangenen Sekunden in positiven Bereich.

      Es können nur positive Werte bis 2147483647 dargestellt werden. Ein Variablenwert außerhalb dieses Bereichs führt zu einer falschen Anzeige: Der Teil hh:mm bleibt 00:00 oder 01:00 in Winterzeit.

Projektierung

Um eine Uhr in einem Bild anzulegen:

  1. wählen Sie das Symbol Uhr in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. soll eine Variable verknüpft werden, dann:
    verknüpfen Sie gewünschte Variable im Abschnitt Variable / Funktion oder per Drag&Drop mit dem Element

    Interne ID: Uhr

    Variable / Funktion

    Eigenschaften für die mit dem Element verknüpfte Variable oder Funktion.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Alle Variablen sind verknüpfbar, ausgenommen String und Bool.
    • Der Bruchteil von Float Variablen (z.B. von Datentypen REAL und DATA_AND_TIME) wird nicht berücksichtigt.
  5. definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften, vor allem:
  6. wählen Sie in der Gruppe Darstellung als Wert der Eigenschaft Anzeigetyp
    • Systemzeit/Absolutzeit: Die Zeit wird als absolute Uhrzeit dargestellt.
      Hinweis: Kontextmenü und Tooltip werden nicht unterstützt.
    • Zeitdifferenz: Die Zeitdifferenz wird in Minuten und Sekunden ausgegeben. Die verknüpfte Variable muss die Anzahl von Sekunden enthalten.
      Es können die Integer-Werte im Sekundenraum -2147483648 (min(DINT)) bis + 4294967295 (max(UDINT)) angezeigt werden. Es ist also auch möglich, negative Werte darzustellen.
      Beispiele im Format mm:ss: Der Variablenwert 50 wird als 00:50 dargestellt, der Variablenwert 100 als 01:40.
      Der Variablenwert -60 wird als -01:00 angezeigt. Umgekehrt wird aus der Anzeige -01:40 der Variablenwert -100.
  7. wählen Sie über die Eigenschaft Formatierung die gewünschte Darstellung

    Interne ID: Uhr

    Formatierung

    Format der Zeit-/Datumsanzeige.
    Ein Formatierungsstring wird aus der Liste ausgewählt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Beim Anzeigetyp Absolutzeit mit Sollwert absetzen über Element hat die Eingabemaske die Formatierung vom Typ Zeitdifferenz.

Interne ID: Uhr

Sollwert absetzen über

Sollwert setzen mit:
Befehlsgabe: Der neue Wert wird über die Aktion Sollwertvorgabe in der Befehlsgabe gesetzt.

Eingabemaske: Der neue Wert wird über die Standard-Eingabemaske eingegeben. Wenn ein Bild des Bildtyps "Keyboard" mit dem Namen "SETVALUEKBD" (für numerische Variablen) oder "SETSTRINGKBD" (für String-Variablen) existiert, wird dieses Bild anstelle der Standard-Eingabemaske verwendet.

Element: Der neue Wert wird direkt im Element eingegeben (nur bei den Elementen Zahlenwert und Textelement).

Programm: Der neue Wert wird in einem externen Programm eingegeben.

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Interne ID: Uhr

SW setzen aktiv

Aktiv: Diese Variable für "Sollwert setzen" Aktionen freigeben.
Inaktiv: Diese Variable ist schreibgeschützt.
Default: aktiv

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zum Beispiel:

  • Absolutzeit Formatierung: hh:mm:ss dd.mm.yy
    wird im Element dargestellt als: dd:hh:mm:ss
  • dd.mm.yyyy (z.B. 17.12.2008)
    als ddddd (14230 Tagen seit 1. 1. 1970).


Universalregler

Handbuch -> Bilder -> Bildelemente -> Universalregler

Mit dem Dynamische Element Universalregler zeigen Sie Variablenwerte in Form von Schiebereglern, Bargrafen, LED Balkenanzeigen und beliebigen anderen Reglern an. Der Regler erlaubt zur Runtime eine direkte Sollwerteingabe.

Um den Universalregler in einem Bild anzulegen:

  1. wählen Sie das Symbol Universalregler in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl einer Variablen öffnet sich
  5. wählen Sie die gewünschte Variable
  6. der Assistent zur Konfiguration des Universalreglers öffnet sich

  7. Wählen Sie die Ausrichtung:
    horitontal, vertikal oder rund

  8. Wählen Sie die Form:
    Schieb/Drehregler, Balken, LED Balken oder Bewegte Skala

  9. Sie erhalten eine Voransicht:
    Definieren Sie hier noch Titelanzeige und Position der Wertanzeige.

  10. Weitere Eigenschaften definieren Sie im Eigenschaften-Fenster

    Tipp: Die Darstellung und Form des Universalreglers verändern Sie in den Eigenschaften im Knoten Universalregler

    Interne ID: Universalregler

    Universalregler

    Konfiguration des Reglers.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Ein Schleppzeiger kann den den Minimal- bzw. Maximalwert der Variablen in einer bestimmten Zeitdauer darstellen. Ein Doppelklick auf das Element zur Runtime setzt den Schleppzeiger zurück.

Farbliche Darstellung der Grenzwertverletzung

Bei Grenzwertverletzungen kann die Farbe aus der Variablen den gesamten Bereich einfärben oder nur den Bereich ab der Grenzwertverletzung. Gesteuert wird diese Funktionalität über die Eigenschaft Balken explizit in der Gruppe Universalregler.

Interne ID: Universalregler

Balken explizit

Nur verfügbar, wenn für die Eigenschaft Stil Balken, Bewegte Skala oder LED Balken gewählt wurde.

Interne ID: Universalregler

Stil

Folgende Stile der Darstellung stehen zur Verfügung:
– Schiebe-/Drehregler
– Balken
– LED Balken
– Bewegte Skala

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv


WPF-Element

Handbuch -> Bilder -> Bildelemente -> WPF-Element

Mit dem Dynamischen Element WPF können gültige WPF/XAML-Dateien in zenon eingebunden und dargestellt werden.

info Info

Alle Marken- und Produktnamen in dieser Dokumentation sind Warenzeichen oder eingetragene Warenzeichen der jeweiligen Titelhalter.

Noch in diesem Kapitel

Grundlagen

Leitfaden für Designer

Engineering in zenon


Grundlagen

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Grundlagen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

XAML

XAML steht für Extensible Application Markup Language und wird ['zæ:m?l] ausgesprochen. Die von Microsoft entwickelte XML basierte Beschreibungssprache definiert die Syntax in Silverlight-Anwendungen und WPF-Oberflächen. XAML erlaubt es, Design und Programmierung zu trennen. Der Designer bereitet die grafische Oberfläche vor und erstellt Basis-Animationen, die dann vom Entwickler/Projekteur aufgegriffen werden. Der Projekteur kann diese .xaml Dateien gezielt ansteuern und entsprechend animieren.

WPF

WPF steht für Windows Presentation Foundation und bezeichnet ein Grafik-Framework, das Teil von Windows .NET Framework ist:

  • WPF stellt die Programmierumgebung dar.
  • XAML beschreibt, basierend auf XML, als Auszeichnungssprache die Oberflächenhierarchie.
    Je nach Aufbau der XAML-Datei besteht die Möglichkeit, Eigenschaften, Ereignisse und Transformationen von WPF-Elementen mit Variablen und Funktionen von zenon zu verknüpfen.
  • Das Framework vereint die verschiedenen Bereiche einer Präsentation wie Benutzerschnittstelle, Zeichnen, Grafiken, Audio, Video, Dokumente und Typographie.

WPF wird laut Microsoft mit Windows 7, Windows Vista und Windows Server 2008 ausgeliefert und ist erhältlich für Windows XP SP2 oder höher und Windows Server 2003. Zur Ausführung wird Microsoft .Net 3.5 benötigt.

Noch in diesem Kapitel

WPF in der Prozessvisualisierung

Wertübertragung von zenon an WPF

Referenzierte Objekte

Zuordnung zenon Objekt zu WPF Content

Workflows


WPF in der Prozessvisualisierung

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Grundlagen -> WPF in der Prozessvisualisierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für zenon eröffnet XAML individuelle grafische Gestaltungsmöglichkeiten. Anzeigenelemente und Dynamische Elemente können unabhängig von der Projektierung grafisch angepasst werden. Zum Beispiel werden aufwändige Illustrationen erst von Designern erstellt und dann als XAML-Datei in zenon importiert und mit den gewünschten Logiken verknüpft. Dafür bieten sich viele Anwendungsmöglichkeiten an, zum Beispiel:

Dynamische Elemente im Analog-Look

Grafiken müssen nicht mehr in zenon gezeichnet werden, sondern können direkt als XAML-Datei importiert werden. Das erlaubt den Einsatz von komplexen, aufwändig illustrierte Elementen in der Prozessvisualisierung. Spiegelungen, Schatten, 3D-Effekte etc. werden zum Beispiel als Grafik unterstützt. Die an die jeweilige Industrie-Umgebung angepassten Elemente ermöglichen intuitives Bedienen, analog den Bedienelementen an der Maschine.

Aufwändige Illustrationen für intuitives Bedienen

Die Einbindung von XAML basierenden Anzeigeelementen wertet Projekte grafisch auf und ermöglicht sehr einfach die übersichtlichere Prozessdarstellung. Auf Usability optimierte Elemente vereinfachen die Bedienung. Die übersichtliche Darstellung von Daten erleichtert die Rezeption von komplexen Inhalten. Die flexible Anpassungsmöglichkeit der einzelnen Elemente erhöht den Bedienkomfort. So ist es dem Projektanten möglich, eigenständig Anzeigenwerte, Skalen und Einheiten zu bestimmen.

Übersichtliche Datenpräsentation und Zusammenfassungen

Gruppierte Anzeigenelemente ermöglichen die übersichtliche Darstellung der wichtigsten Prozessdaten, so dass der Anlagenbediener stets über aktuelle Prozessabläufe informiert ist. Grafische Auswertungen, Anzeigenwerte und Regler können in einem Element gruppiert werden und ermöglichen eine schnelle und unkomplizierte Steuerung.

Industriespezifische Darstellungen

Elemente wie Thermometer, Skalen oder Bargrafen zählen zu den Basis-Elementen der Prozessvisualisierung. Durch XAML ist es möglich, diese grafisch an die jeweilige Industrie anzupassen. So finden Anlagenbediener die etablierten und gewohnten Elemente, die sie bereits von den Maschinen kennen, in der Prozessvisualisierung am Terminal wieder.

Anpassung an das Corporate Design

Illustrationen können an die jeweiligen Stilvorgaben des Unternehmens angepasst werden, um ein durchgängiges Erscheinungsbild bis hin zum einzelnen Prozessbild zu erreichen. Als Vorlage können dazu zum Beispiel die Standard-Bedienelemente von zenon verwendet werden, die dann an Farbwelten, Hausschriften und Illustrationsstile des Corporate Designs angepasst werden.


Wertübertragung von zenon an WPF

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Grundlagen -> Wertübertragung von zenon an WPF

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon arbeitet intern immer mit dem Datentyp Double oder String. Diese werden an das WPF-Element geschickt. Das WPF Element ist in einen .NET Container eingebettet. Damit der Datentyp verwendet werden kann, muss er meistens konvertiert werden. Diese Konvertierung wird von .NET automatisch durchgeführt.

Die Wertabsetzung erfolgt nach folgenden Regeln:

  • Ist der .NET-Typ (System.Object) für zenon nicht ersichtlich, wird der Wert so wie er ist an .NET geschickt. .NET muss sich selbst um die Darstellung bzw. Konvertierung kümmern.
  • Ist der .NET-Typ vom Typ Boolean (System.Boolean), dann schreibt zenon entsprechend der .NET-Konvention 0 bzw. -1.
  • Ist der .NET-Typ bekannt, wird geprüft, ob .NET den Wert konvertieren kann. Dazu wird der Konverter von .NET verwendet.
    • Ja: Der Wert wird geschickt.
    • Nein: Der Wert wird trotzdem geschickt. Reagiert .NET mit einer Fehlermeldung, wird der Wert von zenon in einen String umgewandelt und erneut geschickt.


Referenzierte Objekte

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Grundlagen -> Referenzierte Objekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In WPF können nicht nur Standardobjekte wie Rechtecke, Buttons, Textfelder, etc. verwendet werden, sondern auch WPF User Controls, die als Assemblys referenziert werden.

WPF User Controls sind individuell erstellte Objekte. Zum Beispiel kann dieses Element wie ein Tacho aussehen und spezielle Eigenschaften und optische Effekte anbieten, etwa eine Eigenschaft „Value", die beim Setzen dazu führt, dass der Zeiger des Tachos sich bewegt und den Wert anzeigt.

Der Workflow dazu:

  • Das Aussehen eines User Controls wird mit Standard-Objekten gezeichnet, die von WPF angeboten werden.
  • Die Eigenschaften und Interaktionen werden programmiert.
  • Das Gesamtpaket wird kompiliert und liegt als .Net Assembly vor.

Diese Assembly kann für WPF-Projekte verwendete werden. Dafür muss es im WPF-Editor (z.B: Microsoft Expression Blend) referenziert (verknüpft) werden. Wählen Sie dazu im zenon Datei-Auswahldialog die Assembly aus:

Ab diesem Zeitpunkt können die WPF User Controls der Assembly in der Toolbox unter Custom UserControls ausgewählt und im WPF-Projekt verwendet werden.

Referenzierte Assemblys in zenon verwenden

Um eine Assembly in zenon zu verwenden, muss dieses als Datei zur Verfügung gestellt werden.
Sammeldateien vom Format .cdwpf verwalten diese eigenständig, es sind keine weiteren Konfigurationen nötig. Für Dateien vom Format .xaml müssen Assemblies zum Ordner Dateien hinzugefügt werden:

  • klicken Sie im Projektbaum auf Dateien
  • wählen Sie Sonstige
  • wählen Sie im Kontextmenü Datei hinzufügen...
  • der Dateiauswahldialog öffnet sich
  • fügen Sie die gewünschte Assembly ein

Beim Anzeigen einer WPF-Datei im WPF-Element (Editor und Runtime) werden die Assemblys aus diesem Ordner geladen. Damit ist auch sicher gestellt, dass beim Übertragen der Runtime-Dateien mittels Remote Transport alle referenzierten Assemblys auf dem Zielrechner vorhanden sind.

Eine Sammeldatei (.cdwpf) und eine gleichnamige XAML-Datei können parallel existieren. Alle Assemblies (*.dll) aus allen Sammeldateien und dem Ordner Sonstige werden in einen Arbeitsordner kopiert. Bei mehreren gleichnamigen Assemblies wird nur das mit der höchsten Dateiversion verwendet.

attention Achtung

Assemblies werden nach dem Laden erst beim Beenden der Applikation wieder entladen. Das bedeutet:

Wenn eine WPF-Datei mit einer referenzierten Assembly in zenon dargestellt wird, dann wird diese Assembly geladen und befindet sich bis zum beenden von zenon im Speicher, selbst wenn das Bild wieder geschlossen wurde. Möchten Sie eine Assembly aus dem Ordner Dateien/Sonstige entfernen, muss zuvor der Editor neu gestartet werden, damit die Assembly entladen wird.


Zuordnung zenon Objekt zu WPF Content

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Grundlagen -> Zuordnung zenon Objekt zu WPF Content

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zuordung von zenon Objekten zu WPF Content erfolgt über den Namen des WPF-Objekts. Dabei ist zu beachten:

Visuelle Objekte besitzen keine Eigenschaft RuntimeNamePropertyAttribute. Daher steht in dem Moment, in dem der WPF Content geladen und erzeugt wird die Zusatzinformation Name nicht zur Verfügung.

Damit ist eine eindeutige Zuordnung von zenon Objekten auf WPF Objekte nicht mehr möglich. Daher werden im Konfigurationsdialog von zenon nur logische Objekte auflistet. Welche WPF Objekte über die Eigenschaft RuntimeNamePropertyAttribute verfügen, ist in der MSDN oder auf der Microsoft Website ersichtlich.

Workaround

Um visuelle Objekte dennoch zu dynamisieren, ist folgender Workaround möglich:

Beim visuellen Element wird dynamisierbare Eigenschaft über Databindung mit dem Text-Property einer unsichtbaren Textbox verknüpft.

Da die Textbox als logisches Objekt die Eigenschaft Name unterstützt, wird diese in zenon angezeigt.

Das Textbox-Property kann also mit zenon dynamisiert werden.

Dadurch wird indirekt auch das visuelle Objekt dynamisiert.


Workflows

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Grundlagen -> Workflows

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die WPF/XAML-Technologie ermöglicht neue Workflows in der Prozessvisualisierung. Die Trennung von Design und Funktionalität sorgt für klare Aufgabenteilung zwischen Projekteur und Designer; Designvorgaben lassen sich durch die Verwendung bereits existierender Designs, die vom Projekteur nicht mehr modifiziert werden müssen, leicht erfüllen.

Am Workflow zur Erstellung von WPF-Elementen in zenon sind folgende Personen beteiligt:

  • Designer
    • illustriert Elemente
    • sorgt für grafische Aufbereitung für MS Expression Design
  • MS Expression Blend Operator
    • animiert Elemente
    • legt Variablen für die Animation der WPF-Elemente in zenon an, auf die der Projekteur zugreifen kann
  • Projekteur
    • bindet Elemente in zenon ein
    • hinterlegt Logik und Funktionalität

Wir unterscheiden:

  • Workflow mit Microsoft Expression Blend
  • Workflow mit Adobe Illustrator

Noch in diesem Kapitel

Workflow mit Microsoft Expression Blend

Workflow mit Adobe Illustrator


Workflow mit Microsoft Expression Blend

Workflow mit Microsoft Expression Blend

Bei Verwendung von Microsoft Expression Blend erfolgt die Erstellung eines WPF-Elements in vier Schritten:

  1. Illustration des Elements in MS Expression Blend
  2. Element in MS Expression Design öffnen und als WPF exportieren
  3. Animation in MS Expression Blend
  4. Integration in zenon

Ein Beispiel für die Erstellung eines WPF-Elements mit Microsoft Expression Blend finden Sie im Kapitel Button als XAML-Datei mit Microsoft Expression Blend erstellen.


Workflow mit Adobe Illustrator

Workflow mit Adobe Illustrator

Aufbauend auf traditionelle Gestaltungsabläufe mit Adobe Illustrator bietet sich folgender Workflow an:

  1. Illustration der Elemente in Adobe Illustrator
  2. Import der .ai Dateien und Aufbereitung in MS Expression Design
  3. WPF-Export aus MS Expression Design
  4. Animation in MS Expression Blend
  5. Integration in zenon

Ein Beispiel zur Erstellung finden Sie im Kapitel Workflow mit Adobe Illustrator.


Leitfaden für Designer

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Leitfaden für Designer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Abschnitt informiert über die korrekte Erstellung von WPF Dateien im Microsoft Expression Blend und Adobe Illustrator. Die Tutorials zur Erstellung eines Button-Elements und eines Bargraf-Elements zeigen, wie in wenigen Schritten aus bereits existierenden Grafiken voll funktionsfähige WPF-Dateien für zenon erzeugt werden.

Folgende Werkzeuge werden dafür benützt:

  • Adobe Illustrator CS3 (AI)
  • Microsoft Expression Design 4 (ED)
  • Microsoft Expression Blend 4 (EB)
  • zenon 6.51

info Info

Sollen referenzierte Objekte (Assemblys) in WPF verwendet werden, beachten Sie die Hinweise im Kapitel Referenzierte Objekte.

Noch in diesem Kapitel

Workflow mit Microsoft Expression Blend

Workflow mit Adobe Illustrator


Workflow mit Microsoft Expression Blend

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Leitfaden für Designer -> Workflow mit Microsoft Expression Blend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Microsoft Expression Blend wird ein WPF-Element:

  • illustriert
  • über MS Expression Design in das WPF-Format umgewandelt
  • animiert

Das folgende Beispiel zeigt die Illustration und Umwandlung eines Button-Elements in eine XAML-Datei.

Hinweis: Eine Test-Version von „Microsoft Expression Blend" steht auf der Microsoft Web-Seite zum Download zur Verfügung.

Noch in diesem Kapitel

Button als XAML-Datei mit Microsoft Expression Blend erstellen


Button als XAML-Datei mit Microsoft Expression Blend erstellen

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Leitfaden für Designer -> Workflow mit Microsoft Expression Blend -> Button als XAML-Datei mit Microsoft Expression Blend erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Button als XAML-Datei mit Microsoft Expression Blend erstellen

Button erstellen

  1. Starten Sie Expression Blend
  2. wählen Sie die Option New Projekt

  3. wählen Sie als Projekttyp WPF
  4. vergeben Sie einen beliebigen Pfad und Namen (z.B. MyBlendProject)

    Die Einstellungen Language und Version können ignoriert werden, da keine Funktionalität programmiert werden soll.

  5. Nachdem der Dialog mit OK bestätigt wurde, erzeugt Microsoft Blend ein neues Projekt mit den gewählte Einstellungen. Expression Blend fügt eine leere XAML-Datei ein, die bereits eine Klassen-Referenz beinhaltet.
  6. Löschen Sie, die an die XAML-Datei dazugehörende, CS-Datei über das Kontextmenü.
  7. Benennen Sie die XAML-Datei MainControl.xaml auf MyButton.xaml um.
  8. Die Development-Größe der Datei wird standardmäßig auf 640 mal 480 Pixel gestellt und muss noch geändert werden:
    1. wechseln Sie in die Ansicht XAML
    2. korrigieren Sie die Größe auf 100 mal 100 Pixel
    3. löschen Sie die Klassenreferenz x:Class="MyBlendProject.MyButton"

  9. wechseln Sie in die Ansicht Design

  10. fügen Sie über die Symbolleiste einen Button ein
  11. definieren Sie die Eigenschaften
    • Width: 50
    • Height: 50
    • Margins: 25

    Damit befindet sich der Button jetzt in der Mitte des Controls.

  12. Speichern Sie die Änderungen und öffnen Sie die Datei zur Kontrolle im Internet Explorer. Sie sehen, dass der Button in der Größe von 50 x 50 Pixel dargestellt wird.

Button skalierbar machen

Wenn Sie diese Datei in diesem Zustand in zenon einbinden, wird der Button dort immer exakt die Größe von 50 x 50 Pixel haben. Da der Button skalierbar eingesetzt werden soll, wechseln Sie wieder zu Expression Blend:

  1. selektieren Sie den Button in der Baumansicht
  2. wählen Sie im Kontextmenü des Buttons Group Into->Viewbox
  3. der Button wird in einer Viewbox eingefügt
  4. definieren Sie die Eigenschaften der Viewbox
    • Width: Auto
    • Height: Auto
  5. speichern Sie die Datei

  6. Wenn Sie die Datei jetzt im Internet Explorer öffnen, wird der Button bei Größenänderungen des IE-Fensters automatisch skaliert. Diese Datei würde sich jetzt auch in zenon automatisch an Größenänderungen des WPF-Elements anpassen.

Namen ändern

Bevor Sie die Datei in zenon einbinden können, müssen Sie dem WPF-Element einen Name geben. Standardmäßig sind WPF-Elemente in Expression Blend nicht benannt, und werden mit eckige Klammer und dessen Typ gekennzeichnet. Die Zuordnung von zenon-Content auf WPF-Content geschieht über den Namen der WPF-Elemente:

  • ändern Sie in der Baumansicht den Namen
    • des Buttons auf MyButton
    • der ViewBox auf MyViewBox

Dieser Button kann jetzt als XAML-Datei in zenon eingebunden werden.


Workflow mit Adobe Illustrator

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Leitfaden für Designer -> Workflow mit Adobe Illustrator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Einsatz von Adobe Illustrator wird ein WPF-Element:

  • in Adobe Illustrator illustriert
  • in MS Expression Design in ein WPF umgewandelt
  • in MS Expression Blend animiert

Das folgende Beispiel zeigt die Illustration und Umwandlung eines Bargraf-Elements in eine XAML-Datei.

Noch in diesem Kapitel

Illustration Bargraf

WPF-Export

Animation in Blend


Illustration Bargraf

Illustration Bargraf

Ein Bargraf wird in Adobe Illustrator erstellt.

  1. AI: Ausgangselement Bargraf

    Illustriert in Adobe Illustrator CS3.

  2. AI: Pfadansicht Bargraf in Adobe Illustrator

    • alle Effekte müssen umgewandelt sein (Objekt -> Aussehen umwandeln)
    • alle Linien werden in Pfade umgewandelt (Objekt -> Pfad -> Konturlinie)
    • keine Filter wie Schlagschatten, Weichzeichner etc. verwenden

Hinweise zur Kompatibiltät

Illustrationen , die mit Adobe Illustrator erstellt werden, eignen sich grundsätzlich für den WPF-Export. Allerdings können nicht alle Illustrator-Effekte in Expression Design/Blend entsprechend werden. Beachten Sie:

Effekt

Beschreibung

Schnittmasken

In Adobe Illustrator erzeugte Schnittmasken werden von Expression Design nicht korrekt interpretiert. Meist werden sie in Blend als schwarze Farbflächen dargestellt.

Wir empfehlen, die Illustrationen ohne Schnittmasken anzulegen.

Filter und Effekte

Nicht jeder Adobe Illustrator Filter wird in Expression Design entsprechend übernommen: So funktionieren z.B. Weichzeichnungsfilter, Schlagschatten sowie Eckeneffekte aus Illustrator in Expression Design nicht.

Lösung:

  • Über den Befehl Objekt -> Aussehen Umwandeln in Adobe Illustrator lassen sich die meisten Effekte so umwandeln, dass sie von Expression Design korrekt gelesen werden können.
  • Eckeneffekte aus Adobe Illustrator werden von MS Design korrekt interpretiert, wenn sie in AI in Pfade umgewandelt werden.

Textfelder

Um Textfelder mit Code verknüpfen zu können, müssen diese in Expression Blend gesondert angelegt werden. „Labels" werden für dynamische Texte benötigt, für statische Informationen genügen einfache „Textfelder".

Die Möglichkeit, Textlabels zu erstellen, wird in MS Design nicht angeboten. Diese müssen direkt in MS Blend erstellt werden.

Transparenzen und Gruppentransparenzen

Zu Schwierigkeiten kann es bei der korrekten Interpretation von Transparenz-Einstellungen, insbesondere von Gruppentransparenz-Einstellungen, in Adobe Illustrator kommen.

MS Expression Blend sowie MS Expression Design bieten aber die Möglichkeit, Transparenz-Einstellungen neu anzulegen.

Ebenen multiplizieren

Diese Ebenen-Einstellungen in Adobe Illustrator werden von MS Expression Blend nicht immer richtig dargestellt.

Es gibt aber die Möglichkeit, „Ebene multiplizieren" direkt in Expression Design einzustellen.

Zeigerinstrumente und Standardpositionen

Um die Grafiken optimal für die Animation vorzubereiten, müssen Zeiger und Regler immer auf der Ausgangsposition, meist 0 oder 12:00 Uhr stehen.

So werden die Positions-Parameter für Rotationen etc. gleich richtig in Blend angegeben und eine Animation kann ohne Umrechnung von Positionsangaben erfolgen.


WPF-Export

WPF-Export

Für die Animation in Microsoft Expression Blend werden WPF-Dateien benötigt. Wir empfehlen Microsoft Expression Design für diesen Export, da es gute Ergebnisse liefert und die meisten Illustrator Effekte korrekt interpretiert werden.

Hinweis: Im Internet wird ein gratis Plug-in für den direkten Export von WPF-Dateien aus Adobe Illustrator angeboten. Dieses Plug-in bietet einen schnellen, unkomplizierten Export aus Illustrator, ist für die aktuelle Anwendung jedoch weniger gut geeignet, da es zu grafischen Verlusten kommt. Auch Farbabweichungen vom ursprünglichen Dokument sind möglich.

Dateien im Format .ai können regulär in Expression Design importiert werden, die Pfade bleiben dabei erhalten.
Achtung: Einige geläufige Illustrator Effekte können jedoch von Expression Design nicht richtig dargestellt werden (siehe Kapitel Illustration).

In 5 Schritten exportieren wir das bereits erstellte Bargraf-Element:

  1. ED: Import
    • importieren Sie die aufbereitete Illustrator-Datei in Microsoft Expression Design über Datei -> Importieren
  2. ED: Optimierung

    • wird die Ausgangsdatei in MS Expression Design nicht richtig angezeigt, kann sie hier noch nachbearbeitet und optimiert werden
  3. ED: Auswahl

    • markieren Sie mit dem Direktauswahl-Pfeil in MS Expression Design das Element für den WPF-Export, in diesem Fall die gesamte Uhr
  4. ED: Export starten

    • starten Sie den Export über Datei -> Exportieren
    • der Dialog zur Konfiguration der Exporteinstellungen öffnet sich
  5. ED: Exporteinstellungen

    • Nehmen Sie folgende Exporteinstellungen vor:
    1. Format: XAML Silverlight 4 / WPF Canvas

      Objekte immer benennen: Mit Häkchen aktivieren

      Platzieren Sie gruppierte Objekte in einem XAML Layoutcontainer: Mit Häkchen aktivieren

    2. Text: Bearbeitbarer Textblock
    3. Linieneffekte: Alle rastern

Die exportierte Datei hat die Dateiendung .xaml. Sie wird im nächsten Schritt in MS Expression Blend aufbereitet und animiert.


Animation in Blend

Animation in Blend

Mit MS Expression Blend werden:

  • die statischen XAML-Dateien aus MS Expression Design animiert
  • Variablen für die Steuerung der Effekte, die von zenon angesprochen werden können, angelegt

In 13 Schritten gelangen wir vom statischen XAML zum animierten Element, das in zenon eingebunden werden kann:

  1. EB:Projekt erstellen

    1. öffnen Sie Microsoft Expression Blend
    2. erstellen Sie ein neues Projekt
    3. wählen Sie als Projekttyp WPF -> WPF Control Library aus
    4. vergeben Sie einen Namen (in unserem Tutorial: Mein_Projekt)
    5. wählen Sie einen Speicherort
    6. wählen Sie eine Sprache (in unserem Tutorial: C#)
    7. wählen Sie die Framework Version 3.5
  2. EB: MainControl.xaml.cs löschen

    1. navigieren Sie zu MainControl.xaml.cs
    2. löschen Sie diese Datei über den Befehl Löschen im Kontextmenü
  3. EB: exportierte XAML-Datei öffnen

    1. öffnen Sie das Kontextmenü für Mein_Projekt (rechte Maustaste)
    2. wählen Sie Vorhandenes Element hinzufügen… aus
    3. wählen Sie die aus Microsoft Expression Design exportierte XAML-Datei, um diese in Microsoft Expression Blend zu öffnen
  4. EB: MainControl.xaml öffnen

    1. öffnen Sie die automatisch erstellte MainControl.xaml
    2. navigieren Sie im Bereich Objekte und Zeitachsen zum Eintrag UserControl
  5. EB: XAML-Code anpassen

    1. klicken Sie mit der rechten Maustaste auf UserControl
    2. wählen Sie im Kontextmenü XAML anzeigen
    3. löschen Sie m XAML-Code die Zeilen 7 und 9:

      x:Class="Mein_Projekt.MainControl"

      d:DesignWidth="640" d:DesignHeight="480"

  6. EB: XAML-Code überprüfen

    • Nun sollte der XAML Code so aussehen:

    <UserControl

    xmlns=http://schemas.microsoft.com/winfx/2006/xaml/presentation
    xmlns:x=http://schemas.microsoft.com/winfx/2006/xaml
    xmlns:d=http://schemas.microsoft.com/expression/blend/2008
    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"

    mc:Ignorable="d"
    x:Name="UserControl">

    <Grid x:Name="LayoutRoot"/>

    </UserControl>

  7. EB: Elemente kopieren

    1. öffnen Sie die von Expression Design importiertes XAML-Datei
    2. markieren Sie alle Elemente
    3. wählen Sie im Kontextmenü Kopieren
    4. wechseln Sie zurück zur automatisch erstellten XAML-Datei
  8. EB: Elemente einfügen

    1. klicken Sie mit der rechten Maustaste auf Layout Root
    2. wählen Sie Einfügen
  9. EB: Layouttyp anpassen

    1. klicken Sie mit der rechten Maustaste auf LayoutRoot -> Layouttyp ändern -> Viewbox
    2. nun sollte die Struktur so aussehen: UserControl -> LayoutRoot -> Grid -> Elemente
    3. vergeben sie einen Namen für LayoutRoot und Grid durch Doppelklick auf den Namen
  10. EB: Texte und Werte

    • dynamische und statische Texte werden mit Textfeldern gezeichnet
    • Werte (Zahlen) werden mit Labels ausgegeben
  11. EB: Labels einfügen

    • Labels ersetzen Zahlen, die später mittels Int-Variablen verknüpft werden sollen (muss für alle Zahlen-Elementen durchgeführt werden)
  12. EB: Eigenschaft setzen

    • um 100% anzuzeigen, setzen Sie die Eigenschaft MaxHeight des Bargrafanzeige-Elements auf 341 (die maximale Höhe des Indikator-Elements entspricht 340)
  13. EB: für Verwendung in zenon vorbereiten

    1. löschen Sie alle Namensbezeichnungen (Namen dürfen nur für Elemente vergeben werden, die über zenon angesprochen werden sollen)
    2. speichern Sie die XAML-Datei mit einem beliebigen Namen ab
    3. binden Sie die XAML-Datei in zenon ein

Tipp zur Kontrolle: Wenn die XAML-Datei im Microsoft Internet Explorer einwandfrei dargestellt wird und sich auch der Fenstergröße des Internet Explorers anpasst, wird sie auch in zenon korrekt verwendet.


Engineering in zenon

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um WPF mit zenon nutzen zu können, muss sowohl auf dem Editor-Rechner als auch auf der Runtime Microsoft Framework 3.5 installiert sein.

Bedingungen für WPF-Darstellung in zenon

Die Dynamisierung steht zur Zeit für einfache Variablen zur Verfügung, Arrays und Strukturen können nicht dynamisiert werden. Daher sind folgende WPF-Funktionen in zenon einsetzbar:

  • Element-Eigenschaften, die einfachen Datentypen entsprechen wie String, Int, Bool usw.
  • Element-Eigenschaften vom Typ „Object", die mit einfachen Datentypen gesetzt werden können
  • Element-Ereignisse können mit Funktionen verwendet werden; die Parameter der Ereignisse sind aber in zenon nicht verfügbar und nicht auswertbar
  • Elementtransformation, für die ein RenderTransform beim Element in der XAML-Datei vorhanden ist

    Achtung: Befindet sich bei Transformationen der Content außerhalb des Bereichs des WPF-Elements, geht dieser Teil des Contents verloren, bzw. wird nicht gezeichnet

attention Achtung

Wenn Runtime Dateien für ein Projekt für eine Version vor 6.50 erzeugt werden, dann werden vorhandene WPF-Elemente nicht in die Runtime-Bilder eingebunden.

WPF-Element anlegen

Um ein WPF-Element anzulegen:

  1. wählen Sie in der Symbolleiste der Elemente das Symbol für WPF-Element oder den entsprechenden Eintrag im Menü Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie das Element mit der Maus auf
  4. wählen Sie in den Eigenschaften in der Gruppe Darstellung die Eigenschaft XAML-Datei

    Interne ID: Engineering in zenon

    XAML-Datei

    Auswahl der XAML-Datei für das WPF-Element. Klick auf ... öffnet Dialog zur Auswahl. Die Datei muss bereits im Projektmanager unter Dateien/Grafiken angelegt worden sein oder im Dialog über das Symbol Datei hinzufügen ausgewählt werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Engineering in zenon

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. der Datei-Auswahldialog öffnet sich
  6. wählen Sie die gewünschte Datei aus
    gültige sind Dateien vom Format
    • *.xaml: Extensible Application Markup Language
    • *.cdwpf: WPF Sammeldatei, zeigt auch Vorschaubild

    (Die Datei muss bereits im Projektmanager unter Dateien/Grafiken vorhanden sein oder im Dialog neu angelegt werden.)

  7. konfigurieren Sie die Verknüpfung

info Info

Sollen referenzierte Objekte (Assemblys) in WPF verwendet werden, beachten Sie die Hinweise im Kapitel Referenzierte Objekte.

CDWPF-Dateien (Sammeldateien)

Regeln für die Verwendung von Sammeldateien:

  • Die Dateien können direkt in der ZIP-Datei liegen oder in einem gemeinsamen Ordner.
  • Der Name der XAML-Datei sollte dem Namen der Sammeldatei entsprechen.
  • Es darf nur eine XAML-Datei enthalten sein.
  • Die Vorschaugrafik sollte klein und nicht über 64 Pixel hoch sein.
    Name der Vorschaudatei: preview.png oder der Name der XAML Datei mit der Endung png.
  • Es können beliebig viele Assemblies verwendet wqerden. Die Unterscheidung erfolgt auf Basis der Dateiversion in numerischer Form.
  • Sammeldateien müssen keine Assembly enthalten.
  • Es werden alle Ordner durchsucht und nur Dateien berücksichtigt vom Typ *.dll, *.xaml oder *.png.

Darstellung unter Windows Vista und Windows 7

Enthält ein Bild vom Typ WPF einen Schieberegler und werden gleichzeitig die Aero-Effekte von Windows Vista oder Windows 7 verwendet, kann es im zenon Editor zu Refresh-Problemen kommen.

Noch in diesem Kapitel

Konfiguration der Verknüpfung

Gültigkeit von XAML-Dateien

Vorgefertigte Elemente

Beispiele: Integration von WPF in zenon

Fehlerbehandlung


Konfiguration der Verknüpfung

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Konfiguration der Verknüpfung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein WPF-Element zu konfigurieren

  1. wählen Sie in den Eigenschaften in der Gruppe Darstellung die Eigenschaft Konfiguration

    Interne ID: Konfiguration der Verknüpfung

    Konfiguration

    Öffnet den Dialog zur Konfiguration der XAML-Datei. Eigenschaften, Ereignisse, Transformationen und Bedienberechtigungen können zugewiesen werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. der Dialog mit drei Registerkarten öffnet sich mit einer Vorschau der XAML-Datei sowie der in der Datei vorhandenen Elemente

Parameter

Beschreibung

Vorhandene Elemente

Zeigt in einer Baumstruktur die benannten Elemente der Datei an. Das gewählte Element kann mit Prozessdaten verknüpft werden.

Die Zuordnung von WPF zur Prozessdaten basiert auf den Elementname. Daher werden Elemente nur angezeigt, wenn sie und die dazugehörigen übergeordneten Elemente einen Namen besitzen. Zuordnungen werden in den Registerkarten Eigenschaften, Ereignisse und Transformationen konfiguriert und angezeigt.

Vorschau

Das ausgewählte Element wird in der Vorschau blinkend dargestellt.

Eigenschaften

Konfiguration und Darstellung der Eigenschaften (Variablen, Bedienberechtigungen, Verriegelungen, verknüpfte Werte).

Ereignisse

Konfiguration und Darstellung der Ereignisse (Funktionen).

Transformationen

Konfiguration und Darstellung der Transformationen.

Name

Name der Eigenschaft.

Verknüpfung

Auswahl der Verknüpfung.

Verknüpfungsart

Art der Verknüpfung (Variable, Berechtigung, Funktion)

WPF-Info

Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).

Verknüpft

Zeigt an, ob eine Eigenschaft aktuell verwendet wird.

Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

info Info

Im Konfigurationsdialog können nur logische Objekt angezeigt werden. Visuelle Objekte werden nicht angezeigt. Hintergründe und wie visuelle Objekte dennoch dynamisiert werden können lesen Sie im Abschnitt Zuordnung zenon Objekt zu WPF Content.

Noch in diesem Kapitel

Eigenschaften

Ereignisse

Transformation


Eigenschaften

Eigenschaften

Die Eigenschaften ermöglichen das Verknüpfen von:

  • Variablen
  • Werten
  • Bedienberechtigungen und Verriegelungen

Parameter |  | Beschreibung
Name | Name der Eigenschaft.
Verknüpfung | Verknüpfte Variable, Bedienberechtigung oder verknüpfter Wert. Klick in die Spalte öffnet den jeweiligen Auswahldialog, abhängig vom Eintrag in der Spalte Verknüpfungsart.
Verknüpfungsart | Auswahl einer Verknüpfung.
WPF-Info | Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).
Verknüpft | Zeigt an, ob eine Eigenschaft aktuell verwendet wird. Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

Verknüpfung erstellen

Um eine Verknüpfung zu erstellen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste die gewünschte Verknüpfung.

    Zur Verfügung stehen:

    • <nicht verknüpft> (löst eine bestehende Verknüpfung)
    • Bedienberechtigung/Verriegelung
    • Variable
    • Wertverknüpfung
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der gewünschten Verknüpfung öffnet sich

info Info

Eigenschaften von WPF und zenon können sich unterscheiden. Wird zum Beispiel die Eigenschaft Sichtbarkeit verknüpft, stehen in .NET drei Werte zur Verfügung:

0 - sichtbar

1 - unsichtbar

2- eingeklappt

Diese Werte müssen über die verknüpfte zenon Variable abgebildet werden.

Noch in diesem Kapitel

Variable verknüpfen

Werte verknüpfen

Bedienberechtigung oder Verriegelung verknüpfen


Variable verknüpfen

Variable verknüpfen

Um eine Variable mit einer WPF-Eigenschaften zu verknüpfen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Variable
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Variablen öffnet sich

Dieser Dialog gilt auch für Auswahl der Variablen bei Transformationen. Die Konfiguration ermöglicht auch Umrechnung von zenon in WPF-Einheiten.

Parameter

Beschreibung

Verknüpfte Variable

Auswahl der zu verknüpfenden Variablen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl.

Wertbereich des WPF-Elements

Angaben zur Umrechnung der Variablenwerte in WPF-Werte.

Wertbereich umrechnen

Aktiv: WPF-Einheitenumrechnung ist eingeschaltet.

Auswirkung zur Runtime: Der aktuelle zenon Wert (inkl. zenon Einheit) wird mittels normierter Minimum- und Maximum-Wert auf den WPF-Bereich umgerechnet.

Zum Beispiel: Der Wert einer Variablen variiert von 100 bis 200. Bei der Variablen ist der normierte Bereich auf 100 - 200 eingestellt. Ziel ist, diese Wertänderung mittels eines WPF-Drehknopfs darzustellen. Dafür wird:

  • bei Transformation die Eigenschaft RotateTransform.Angle mit der Variablen verknüpft
  • Wert anpassen aktiviert
  • ein WPF-Wertbereich von 0 bis 360 konfiguriert

Jetzt wird der Drehknopf bei einen Wert von z.B. 150 um 180 Grad gedreht sein.

Minimum

Definiert den niedrigsten WPF-Wert.

Maximum

Definiert den höchsten WPF-Wert.

OK

Übernimmt Einstellungen und beendet Dialog.

Abbrechen

Verwirft Einstellungen und beendet Dialog.

Hilfe

Öffnet die Online-Hilfe.


Werte verknüpfen

Werte verknüpfen

Verknüpfte Werte können entweder ein String oder ein numerischer Wert vom Typ Double sein. Beim Aufschalten des Bildes wird nach dem Laden des WPF-Contents der gewählter Wert im WPF-Content abgesetzt.

attention Achtung

Der Datentyp der WPF-Eigenschaft muss nicht unbedingt Double oder String sein. Es werden aber von zenon nur Werte mit Typ String oder Double abgesetzt. Diese müssen auf WPF Seite von .NET konvertiert werden. Details siehe Kapitel Wertübertragung von zenon an WPF.

Um einen Wert mit einer WPF-Eigenschaften zu verknüpfen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Werteverknüpfungen
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Werteverknüpfung öffnet sich

Parameter

Beschreibung

Verknüpfter Wert:

Eingabe eines numerischen Werts oder Stringwerts.

String verwenden

Aktiv: Ein String-Wert wird statt eines numerischen Werts verwendet.

Stringwerte sind sprachumschaltbar. Zur Runtime wird der Text beim Aufschalten des Bildes übersetzt und im WPF-Content abgesetzt. Wird während das Bild geöffnet ist eine Sprachumschaltung durchgeführt, wird der Stringwert neu übersetzt und abgesetzt.

Stringwert/Numerischer Wert

Abhängig von der Auswahl der Eigenschaft String verwenden wird in dieses Feld ein numerischer Wert oder ein Stringwert eingegeben. Bei numerischen Werten kann zusätzlich eine Einheit ausgewählt werden.

Einheit:

Auswahl einer Einheit aus der Dropdownliste. Diese muss zuvor in der Einheitenumschaltung definiert worden sein.

Die Einheit wird dem numerischen Wert zugeordnet. Wird zur Runtime eine Einheitenumschaltung durchgeführt, wird der Wert umgerechnet auf die neue Einheit und zum WPF-Content abgesetzt.

OK

Übernimmt Einstellungen und beendet Dialog.

Abbrechen

Verwirft Einstellungen und beendet Dialog.

Hilfe

Öffnet die Online-Hilfe.


Bedienberechtigung oder Verriegelung verknüpfen

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Konfiguration der Verknüpfung -> Eigenschaften -> Bedienberechtigung oder Verriegelung verknüpfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bedienberechtigung oder Verriegelung verknüpfen

Bedienberechtigungen können nicht für das gesamte WPF-Element vergeben werden. Dem Element wird eine Benutzerebene zugewiesen. Berechtigungen werden innerhalb der Benutzerebene für einzelne Controls erteilt. Ist eine Berechtigung aktiv, wird der Wert 1 auf die Eigenschaft im Element geschrieben.

Um eine Bedienberechtigung oder Verriegelung mit einer WPF-Eigenschaften zu verknüpfen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Bedienberechtigung/Verriegelung
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Berechtigungen öffnet sich

Parameter | Beschreibung
Berechtigung/Verriegelung verknüpfen | Festlegung der Berechtigungen.
Verknüpfter Zustand | Auswahl der Berechtigung, die mit einem WPF-Control verknüpft wird, aus der Dropdownliste. Zum Beispiel kann Sichtbarkeit und Bedienbarkeit eines WPF-Buttons vom Status des Benutzers abhängen.

Berechtigung | Beschreibung
Bedienberechtigung vorhanden | Besitzt der Benutzer genügend Rechte, um das WPF-Element zu bedienen, wird der Wert 1 auf die Eigenschaft geschrieben.
Bedienberechtigung nicht vorhanden | Besitzt der Benutzer nicht genügend Rechte, um das WPF-Element zu bedienen, wird der Wert 1 auf die Eigenschaft geschrieben.
Nicht verriegelt | Ist das Element nicht durch die Verriegelung gesperrt, wird der Wert 1 auf die Eigenschaft geschrieben.
Verriegelt | Ist das Element durch die Verriegelung gesperrt, wird der Wert 1 auf die Eigenschaft geschrieben.
Bedienbar | Wenn die Bedienberechtigung vorhanden ist und das Element nicht verriegelt ist, dann wird der Wert 1 auf die Eigenschaft geschrieben.
Nicht bedienbar | Fehlt die Bedienberechtigung oder ist das Element verriegelt, dann wird der Wert 1 auf die Eigenschaft geschrieben.


Ereignisse

Ereignisse

Ereignisse ermöglichen das Verknüpfen von zenon Funktionen mit einem WPF-Element.

Parameter |  | Beschreibung
Name | Name der Eigenschaft.
Verknüpfung | Verknüpfte Funktion. Klick in die Zelle öffnet den Konfigurationsdialog.
Verknüpfungsart | Auswahl einer Verknüpfung. Klick in die Zelle öffnet den Auswahldialog.
WPF-Info | Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).
Verknüpft | Zeigt an, ob eine Eigenschaft aktuell verwendet wird. Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

Funktionen verknüpfen

Um eine Verknüpfung zu erstellen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Funktion
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Funktion öffnet sich

Parameter |  | Beschreibung
Verknüpfte Funktion | Auswahl der zu verknüpfenden Funktion. Klick auf Schaltfläche ... öffnet den Dialog zur Funktionsauswahl.
OK | Übernimmt Auswahl und schließt Dialog.
Abbrechen | Verwirft Änderungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Transformation

Transformation

Das WPF-Element unterstützt keine Dreh-Funktionalität. Befindet sich zum Beispiel das WPF-Element in einem Symbol und das Symbol wird gedreht, so dreht das WPF-Element nicht mit. Daher gibt es für WPF mit Transformation einen eigenen Mechanismus, um Elementen zu drehen oder anderweitig zu transformieren. Diese Transformationen werden in der Registerkarte Transformation konfiguriert.

Achtung: Falls sich Content außerhalb des Bereichs des WPF-Elementes befindet, geht dieser Teil des Contents verloren, bzw. wird nicht gezeichnet.

Parameter

Beschreibung

Name

Name der Eigenschaft.

Verknüpfung

Auswahl der verknüpften Variablen.

Transformationen werden in XAML als Transformationsobjekte mit eigenen Eigenschaften dargestellt. Unterstützt ein Element eine Transformation, dann werden die möglichen Eigenschaften der Transformationsobjekte in der Listenansicht dargestellt. (Mehr dazu in: Button als WPF-XAML in zenon einbinden.

Wird zum Beispiel die verknüpfte Variable auf den Wert 10 gesetzt, dann wird dieser Wert auf das WPF-Ziel geschrieben und das Element von WPF um 10° gedreht.

Verknüpfungsart

Auswahl der Verknüpfungsart Transformation.

WPF-Info

Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).

Verknüpft

Zeigt an, ob eine Eigenschaft aktuell verwendet wird.

Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

Transformation verknüpfen

Um eine Transformation mit einer WPF-Eigenschaften zu verknüpfen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Transformation
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Variablen öffnet sich

Die Konfiguration ermöglicht auch Umrechnung von zenon in WPF-Einheiten.

Parameter

Beschreibung

Verknüpfte Variable

Auswahl der zu verknüpfenden Variablen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl.

Wertbereich des WPF-Elements

Angaben zur Umrechnung der Variablenwerte in WPF-Werte.

Wertbereich umrechnen

Aktiv: WPF-Einheitenumrechnung ist eingeschaltet.

Auswirkung zur Runtime: Der aktuelle zenon Wert (inkl. zenon Einheit) wird mittels normierter Minimum- und Maximum-Wert auf den WPF-Bereich umgerechnet.

Zum Beispiel: Der Wert einer Variablen variiert von 100 bis 200. Bei der Variablen ist der normierte Bereich auf 100 - 200 eingestellt. Ziel ist, diese Wertänderung mittels eines WPF-Drehknopfs darzustellen. Dafür wird:

  • bei Transformation die Eigenschaft RotateTransform.Angle mit der Variablen verknüpft
  • Wert anpassen aktiviert
  • ein WPF-Wertbereich von 0 bis 360 konfiguriert

Jetzt wird der Drehknopf bei einen Wert von z.B. 150 um 180 Grad gedreht sein.

Minimum

Definiert den niedrigsten WPF-Wert.

Maximum

Definiert den höchsten WPF-Wert.

OK

Übernimmt Einstellungen und beendet Dialog.

Abbrechen

Verwirft Einstellungen und beendet Dialog.

Hilfe

Öffnet die Online-Hilfe.


Gültigkeit von XAML-Dateien

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Gültigkeit von XAML-Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Gültigkeit von XAML-Dateien ist an einige Voraussetzungen gebunden:

  • richtiger Namespace
  • keine Class-Referenzen
  • Skalierbarkeit

Richtige Namspace

Das WPF-Element kann ausschließlich nur WPF-Content darstellen, das heißt:

Nur XAML-Dateien mit richtigem WPF-Namespace können vom WPF-Element dargestellt werden. Dateien die einen Silverlight-Namespace verwenden, können nicht geladen oder angezeigt werden. In den meisten Fällen reicht es aber, den Silverlight-Namespace mit dem WPF-Namespace auszutauschen.

WPF-Namespace:

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

Keine Verwendung von Class-Referenzen

Da die XAML-Dateien dynamisch geladen werden, ist es nicht möglich, XAML-Dateien zu verwenden, die Referenzen auf Klassen (Schlüssel „Class" im Header) beinhalten. Funktionalität, die in einer eigenen C#-Datei programmiert wurde, kann nicht verwendet werden.

Skalierbarkeit

Soll der Inhalt eines WPF-Elements an die Größe des WPF-Elements angepasst werden, dann müssen die Controls des WPF-Elements in ein Control verschachtelt werden, das diese Funktionalität bietet, zum Beispiel eine View Box. Zusätzlich muss darauf geachtet werden, das die Elemente Höhe und Breite als automatisch konfiguriert werden.

Überprüfung einer XAML-Datei auf Korrektheit

Um zu überprüfen, ob eine XAML-Datei das richtige Format hat:

  • XAML-Datei im Internet-Explorer öffnen
    • lässt sie sich ohne zusätzliche Plugins (Java oder ähnliche) öffnen, dann kann diese Datei auch mit hoher Sicherheit von zenon geladen bzw. angezeigt werden
    • treten beim Laden der Datei Probleme auf, so werden diese im Internet-Explorer eingeblendet und es ist klar erkennbar, in welcher Zeile es Probleme gibt

Auch die Skalierung kann auf diese Art und Weise getestet werden: Ist die Datei richtig aufgebaut, wird sich der Inhalt an die Größe des Internet Explorer Fensters anpassen.

Fehlermeldung

Wird in zenon eine ungültige Datei verwendet, so wird beim Laden der Datei im WPF-Element eine Fehlermeldung im Ausgabefenster angezeigt.

Zum Beispiel:

„Fehler beim Laden vom xaml-Datei:C:\ProgramData\COPA-DATA\SQL\781b1352-59d0-437e-a173-08563c3142e9\FILES\zenon\custom\media\UserControl1.xaml

Das Attribut "Class" ist im XML-Namespace "http://schemas.microsoft.com/winfx/2006/xaml" nicht vorhanden. Zeile 7 Position 2."


Vorgefertigte Elemente

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Reihe von WPF-Elementen werden bereits mit zenon ausgeliefert oder stehen im Webshop zum Download bereit.

Alle WPF-Elemente haben Eigenschaften, welche die grafische Ausprägung des jeweiligen Elements bestimmen (Dependency Properties). Das Setzen der Werte mittels einer XAML-Datei oder die Verknüpfung der Eigenschaft über zenonkann das Aussehen in der Runtime direkt verändert werden. Die folgenden Tabellen enthalten die jeweiligen Dependency Properties, abhängig vom Control.

Elemente:

  • Rundanzeige
  • Fortschrittsanzeige
  • Bargraf vertikal
  • Temperaturanzeige
  • Analoguhr
  • Universalregler

Noch in diesem Kapitel

Rundanzeige - CircularGaugeControl

Fortschrittsanzeige - ProgressBarControl

Bargraf vertikal - VerticalBargraphControl

Temperaturanzeige - TemperatureIndicatorControl

Analoguhr - AnalogClockControl

Universalregler - UniversalReglerControl


Rundanzeige - CircularGaugeControl

Rundanzeige - CircularGaugeControl

Property

Funktion

Wert

CurrentValue

Aktueller Wert, der angezeigt werden soll.

Double

IsReversed

Skalenausrichtung, in bzw. gegen Uhrzeigersinn.

Boolean

ElementFontFamily

Elementschriftart.

Font

MinValue

Minimalwert der Skala.

Double

MaxValue

Maximalwert der Skala.

Double

ScaleRadius

Radius der Skala.

Double

ScaleStartAngle

Winkel, bei dem die Skala beginnt.

Double

ScaleLabelRotationMode

Ausrichtung der Skalenbeschriftung.

Enum:

  • None
  • Automatic
  • SurroundIn
  • SurroundOut

ScaleSweepAngle

Winkelbereich, der die Größe der Skala definiert.

Double

ScaleLabelFontSize

Schriftgröße der Skalenbeschriftung.

Double

ScaleLabelColor

Schriftfarbe der Skalenbeschriftung.

Color

ScaleLabelRadius

Radius, an dem die Skalenbeschriftung ausgerichtet ist.

Double

ScaleValuePrecision

Genauigkeit der Skalenbeschriftung.

Integer

PointerStyle

Form des Zeigers, der den Wert anzeigt.

Enum:

  • Arrow
  • Rectangle
  • TriangleCap
  • Pentagon
  • Triangle

MajorTickColor

Farbe der Hauptticks der Skala.

Color

MinorTickColor

Farbe der Nebenticks der Skala.

Color

MajorTickSize

Größe der Hauptticks der Skala.

Size

MinorTickSize

Größe der Nebenticks der Skala.

Size

MajorTicksCount

Anzahl der Hauptticks der Skala.

Integer

MajorTicksShape

Form/Art der Hauptticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksShape

Form/Art der Nebenticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksCount

Anzahl der Nebenticks der Skala.

Integer

PointerSize

Größe des Zeigers.

Size

PointerCapRadius

Größe des Zeigerbefestigungspunkts.

Double

PointerBorderBrush

Farbe des Zeigerrahmens.

Brush

PointerCapStyle

Form/Art des Zeigerbefestigungspunkts.

Enum:

  • BackCap
  • FrontCap
  • Screw

PointerCapBorderBrush

Farbe des Zeigerbefestigungspunkts.

Brush

PointerBrush

Farbe des Zeigers.

Brush

GaugeBorderBrush

Farbe des Elementrahmens.

Brush

GaugeBackgroundBrush

Farbe des Elementhintergrunds.

Brush

PointerCapColorBrush

Farbe des Zeigerbefestigungspunkts.

Brush

GaugeMiddlePlate

Radius der Elementhintergrundmittelplatte.

Double

PointerOffset

Offset des Zeigers (Verschiebung).

Double

RangeRadius

Radius der Bereichsgesamtanzeige.

Double

RangeThickness

Dicke der Bereichsgesamtanzeige.

Double

RangeStartValue

Startwert der Bereichsgesamtanzeige.

Double

RangeEndValue

Endwert der Bereichsgesamtanzeige.

Double

RangeMinEndValue

Endwert des Minimalbereichs.

Double

RangeMidEndValue

Endwert des Mittelbereichs.

Double

RangeMinColorBrush

Farbe des Minimalbereichs.

Brush

RangeMidColorBrush

Farbe des Mittelbereichs.

Brush

RangeMaxColorBrush

Farbe des Maximalbereichs.

Brush

ScaleOuterBorderBrush

Farbe der Skalenumrandung.

Brush

ScaleBackgroundBrush

Farbe des Skalahintergrunds.

Brush

ValueTextFrameStyle

Form/Art der Wertanzeige.

Enum:

  • LargeFrame
  • SmallFrame
  • None

ValueTextContent

Inhalt der Wertanzeige.

Enum:

  • Text
  • TextValue
  • Value

ValueTextSize

Schriftgröße der Werteanzeige.

Double

ValueTextColor

Schriftfarbe der Werteanzeige.

Color

IsGlasReflection

Aktivierung des Glaseffektes auf dem Element.

Boolean

GaugeOffsett

Absenkung des Rotationspunktes des gesamten Elements.

Double


Fortschrittsanzeige - ProgressBarControl

Fortschrittsanzeige - ProgressBarControl
Property | Funktion | Wert
CurrentValue | Aktueller Wert, der angezeigt werden soll. | Double
MinValue | Minimalwert des Wertebereichs. | Double
MaxValue | Maximalwert des Wertebereichs. | Double
ProgressbarDivisionCount | Anzahl der Unterteilungen der (Boxed) Fortschrittsanzeige. | Integer
VisibilityText | Sichtbarkeit der Wertanzeige. | Boolean
TextSize | Schriftgröße der Wertanzeige. | Double
TextColor | Farbe der Wertanzeige. | Color
ProgressBarBoxedColor | Farbe der Rahmen der (Boxed) Fortschrittsanzeige. | Color
ProgressBarMarginDistance | Abstand der Progressbar-Box vom Elementrand (links, oben, rechts, unten). | Double
ProgressBarInactiveBrush | Indikatorfarbe nicht aktiv. | Brush
ProgressBarActiveBrush | Indikatorfarbe aktiv. | Brush
ProgressBarPadding | Abstand der Fortschrittsanzeige von der Progressbar-Box (links, oben, rechts, unten). | Double
ElementBorderBrush | Farbe des Elementrahmens. | Brush
ElementBackgroundBrush | Farbe des Elementhintergrunds. | Brush


Bargraf vertikal - VerticalBargraphControl

Bargraf vertikal - VerticalBargraphControl
Property | Funktion | Wert
CurrentValue | Aktueller Wert, der angezeigt werden soll. | Double
MinValue | Minimalwert der Skala. | Double
MaxValue | Maximalwert der Skala. | Double
MajorTicksCount | Anzahl der Hauptticks der Skala. | Integer
MinorTicksCount | Anzahl der Nebenticks der Skala. | Integer
MajorTickColor | Farbe der Hauptticks der Skala. | Color
MinorTickColor | Farbe der Nebenticks der Skala. | Color
ElementBorderBrush | Farbe des Elementrahmens. | Brush
ElementBackgroundBrush | Farbe des Elementhintergrunds. | Brush
ElementGlasReflection | Aktivierung des Glaseffekts auf dem Element. | Visibility
ElementFontFamily | Elementschriftart. | Font
ScaleFontSize | Schriftgröße der Skala. | Double
ScaleFontColor | Schriftfarbe der Skala. | Color
IndicatorBrush | Farbe der Bargraf-Füllfarbe. | Brush
BargraphSeparation | Anzahl der Bargraf-Unterteilungstriche. | Integer
BargraphSeparationColor | Farbe der Skalenunterteilungen. | Color


Temperaturanzeige - TemperatureIndicatorControl

Temperaturanzeige - TemperatureIndicatorControl

Property

Funktion

Wert

CurrentValue

Aktueller Wert, der angezeigt werden soll.

Double

MinValue

Minimalwert der Skala.

Double

MaxValue

Maximalwert der Skala.

Double

MajorTicksCount

Anzahl der Hauptticks der Skala.

Integer

MinorTicksCount

Anzahl der Nebenticks der Skala.

Integer

TickNegativColor

Farbe des negativen Hauptticks (verlaufend zu TickPositivColor).

Color

TickPositivColor

Farbe des positiven Hauptticks (verlaufend zu TickNegativColor).

Color

MinorTickColor

Farbe der Nebenticks.

Color

ElementBorderBrush

Farbe des Elementrahmens.

Brush

ElementBackgroundBrush

Farbe des Elementhintergrunds.

Brush

ElementGlasReflection

Aktivierung des Glaseffektes auf dem Element.

Visibility

ElementFontFamily

Elementschriftart.

Font

IndicatorColor

Farbe der Indikatorfüllfarbe.

Color

IndicatorBorderColor

Farbe des Indikatorrahmens.

Color

MajorTickSize

Größe der Hauptticks der Skala.

Size

MinorTickSize

Größe der Nebenticks der Skala.

Size

ScaleLetteringDistance

Abstand der Skalenbeschriftung (vertikal), jeder x. Haupttick soll beschriftet werden.

Integer

IndicatorScaleDistance

Abstand zwischen Indikator und Skala (horizontal).

Double

ScaleFontSize

Schriftgröße der Skala.

Double

ScaleFontColor

Schriftfarbe der Skala.

Color

Unit

Einheit.

String

ElementStyle

Form/Art des Elements.

Enum:

  • SmallFrame
  • Unit
  • None


Analoguhr - AnalogClockControl

Analoguhr - AnalogClockControl

Property

Funktion

Wert

ElementStyle

Form/Art des Elements.

Enum:

  • SmallNumbers
  • BigNumbers
  • No

ElementBackgroundBrush

Farbe des Elementhintergrunds.

Brush

ElementGlasReflection

Aktivierung des Glaseffekts auf dem Element.

Visibility

Offset

Wert in Stunden (h), der die Zeitverschiebung zur Systemuhr darstellt.

Int16

OriginText

Text, der in der Uhr angezeigt wird (z. B. Ortsangabe).

String


Universalregler - UniversalReglerControl

Universalregler - UniversalReglerControl

Property

Funktion

Wert

CurrentValue

Aktueller Wert, der angezeigt werden soll.

Double

ElementFontFamily

Elementschriftart.

Font

MinValue

Minimalwert der Skala.

Double

MaxValue

Maximalwert der Skala.

Double

Radius

Double

ScaleRadius

Radius der Skala.

Double

ScaleStartAngle

Winkel, bei dem die Skala beginnt.

Double

ScaleLabelRotationMode

Ausrichtung der Skalenbeschriftung.

Enum:

  • None
  • Automatic
  • SurroundIn
  • SurroundOut

ScaleSweepAngle

Winkelbereich, der die Größe der Skala definiert.

Double

ScaleLabelFontSize

Schriftgröße der Skalenbeschriftung.

Double

ScaleLabelColor

Schriftfarbe der Skalenbeschriftung.

Color

ScaleLabelRadius

Radius, an dem die Skalenbeschriftung ausgerichtet ist.

Double

ScaleValuePrecision

Genauigkeit der Skalenbeschriftung.

Integer

ElementStyle

Darstellungsart des Elements

Enum:

  • Knob
  • Plate
  • None

MajorTickColor

Farbe der Hauptticks der Skala.

Color

MinorTickColor

Farbe der Nebenticks der Skala.

Color

MajorTickSize

Größe der Hauptticks der Skala.

Size

MinorTickSize

Größe der Nebenticks der Skala.

Size

MajorTicksCount

Anzahl der Hauptticks der Skala.

Integer

MajorTicksShape

Form/Art der Hauptticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksShape

Form/Art der Nebenticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksCount

Anzahl der Nebenticks der Skala.

Integer

BackgroundBorderBrush

Farbe des Elementrahmens.

Brush

BackgroundBrush

Farbe des Elementhintergrunds.

Brush

PointerCapColorBrush

Farbe des Zeigerbefestigungspunkts.

Brush

GaugeMiddlePlate

Radius der Elementhintergrundmittelplatte.

Double

ValueFontSize

Schriftgröße der Werteanzeige.

Double

ValueFontColor

Schriftfarbe der Werteanzeige.

Color

IsGlasReflection

Aktivierung des Glaseffektes auf dem Element.

Boolean

KnobBrush

Farbe des Drehknopfes.

Brush

IndicatorBrush

Farbe des Indikators.

Brush

IndicatorBackgroundBrush

Hintergrundfarbe des unaktiven Indikators.

Brush

KnobSize

Durchmesser des Drehknopfes.

Double

KnobIndicatorSize

Indikatorgröße des Knopfes.

Size

ElementSize

Größe des Elements.

Size

VisibilityKnob

Aktivierung des Knopfes.

Boolean

ValuePosition

Position der Wertanzeige.

Double

ValueVisibility

Aktivierung der Werteanzeige.

Boolean


Beispiele: Integration von WPF in zenon

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Beispiele: Integration von WPF in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wie XAML-Dateien erstellt und in zenon als WPF-Elemente eingebunden werden, sehen Sie an folgenden Beispielen:

  • Button als WPF-XAML in zenon einbinden
  • Bargraf als WPF-XAML in zenon einbinden

Noch in diesem Kapitel

Button als WPF-XAML in zenon einbinden

Bargraf als WPF-XAML in zenon einbinden


Button als WPF-XAML in zenon einbinden

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Beispiele: Integration von WPF in zenon -> Button als WPF-XAML in zenon einbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Button als WPF-XAML in zenon einbinden

Aufbau des Beispiels:

  • Erzeugung eines Buttons in Microsoft Expression Blend
  • einbinden in zenon
  • Verknüpfung mit einer Variablen sowie einer Funktion
  • anpassen des Buttons an die Größe des Elements
  • Button erstellen

Erzeugen Sie als ersten Schritt einen Button wie im Kapitel Button als XAML-Datei mit Microsoft Expression Blend erstellen beschrieben. Um die XAML-Datei in zenon verwenden zu können, fügen Sie diese im Projektbaum in den Ordner Dateien/Grafiken ein.

Button einbinden

Hinweis: Für die folgende Beschreibung wird ein zenon Projekt mit folgenden Inhalten verwendet:

  • ein leeres Bild als Startbild
  • eine Intern-Variable int vom Typ Int
  • eine Funktion Funktion_0 vom Typ Sollwert absetzen mit:
    • Option Direkt zu Hardware aktiviert
    • Sollwert wurde auf 45

Um den Button einzubinden:

  1. öffnen Sie das leere Bild
  2. platzieren Sie ein WPF-Element im Bild
  3. wählen Sie im Eigenschaftenfenster XAML-Datei

    Interne ID: Button als WPF-XAML in zenon einbinden

    XAML-Datei

    Auswahl der XAML-Datei für das WPF-Element. Klick auf ... öffnet Dialog zur Auswahl. Die Datei muss bereits im Projektmanager unter Dateien/Grafiken angelegt worden sein oder im Dialog über das Symbol Datei hinzufügen ausgewählt werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie die XAML-Datei aus (z. B.: MyButton.xaml) und schließen Sie den Dialog
  5. wählen Sie die Eigenschaft Konfiguration

    Interne ID: Button als WPF-XAML in zenon einbinden

    Konfiguration

    Öffnet den Dialog zur Konfiguration der XAML-Datei. Eigenschaften, Ereignisse, Transformationen und Bedienberechtigungen können zugewiesen werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Button konfigurieren

Der Konfigurationsdialog zeigt eine Vorschau der ausgewählten XAML-Datei. Im Baum werden alle in der XAML_Datei benannten Elemente aufgelistet:

  1. wählen Sie den WPF-Button, der sich in LayoutRoot->MyViewBox->MyButton befindet
  2. suchen Sie in der Registerkarte Eigenschaften den Eintrag Content, dieser beinhaltet den Text des Buttons
  3. klicken Sie in die Spalte Verknüpfungsart
  4. wählen Sie in der Dropdownliste den Eintrag Variable aus
  5. klicken Sie in die Spalte Verknüpfung
  6. der Variablenauswahldialog wird geöffnet
  7. wählen Sie die Variable int, um diese Variable mit der Eigenschaft Content zu verknüpfen

Ereignisse

Um auch Ereignisse zuzuweisen:

  1. selektieren Sie die Registerkarte Ereignisse

  2. suchen Sie den Eintrag Click, dieses Ereignis wird von WPF-Element ausgelöst, sobald der Button geklickt wird
  3. klicken Sie in die Spalte Verknüpfungsart
  4. wählen Sie in der Dropdownliste den Eintrag Funktion aus
  5. klicken Sie in die Spalte Verknüpfung
  6. der Funktionsauswahldialog wird geöffnet
  7. wählen Sie Funktion_0 aus
  8. bestätigen Sie die Änderungen mit OK
  9. fügen Sie im Bild noch ein Zahlenwert-Element ein
  10. verknüpfen Sie auch diesen Zahlenwert mit der Variablen int.
  11. kompilieren Sie die Runtime-Dateien und starten Sie die Runtime

In der Runtime wird das WPF-Element dargestellt, der Text des Buttons ist 0. Sobald Sie auf den Button klicken, wird das Click-Ereignis getriggert und die Funktion Sollwert setzen ausgeführt. Der Wert 45 wird direkt auf die Hardware abgesetzt und sowohl Zahlenwert als auch Button zeigen den Wert 45 an.

Setzen Sie über das Element Zahlenwert einen Sollwert von 30 ab, so wird auch dieser Wert vom WPF-Element übernommen.

Bedienberechtigung

Ähnlich wie ein Zahlenwert kann ein WPF-Element je nach Bedienberechtigung gesperrt (Schlosssymbol) oder bedienbar geschaltet werden. Stellen Sie beim WPF-Element die Berechtigungsebene auf 1 und legen Sie einen Benutzer Test mit Berechtigungsebene 1 an. Zusätzlich legen Sie die Funktionen Login mit Dialog und Logout an. Diese beiden Funktionen verknüpfen Sie mit 2 neuen Text-Buttons im Bild.

Im Konfigurationsdialog des WPF-Elements selektieren Sie den WPF-Button MyButton und wählen Sie die Registerkarte Eigenschaften:

  1. wählen Sie das Element IsEnabled
  2. klicken Sie in die Spalte Verknüpfungsart
  3. wählen Sie in der Dropdownliste den Eintrag Bedienberechtigung/Verriegelung aus
  4. klicken Sie in die Spalte Verknüpfung
  5. wählen Sie in der Dropdownliste die Option Bedienberechtigung vorhanden aus

  6. schließen Sie den Dialog mit OK

Kompilieren Sie die Runtime-Dateien und achten Sie darauf, auch die Bedienberechtigungen zur Übertragung auszuwählen. Nach dem Starten der Runtime wird der WPF-Button im Bild deaktiviert angezeigt und kann nicht bedient werden. Wenn Sie sich jetzt mit dem Benutzer Test einloggen, wird der Button aktiviert und kann bedient werden. Sobald Sie sich ausloggen, wird der Button wieder gesperrt.

Transformation

Um Transformationen verwenden zu können, muss die XAML-Datei noch angepasst werden:

  1. wechseln Sie ins Programm Expression Blend
  2. selektieren Sie MyButton, damit die Eigenschaften des Buttons im Eigenschaftenfenster sichtbar sind

  3. selektieren Sie unter Transform bei RenderTransform die Option Apply relative transform

    Dadurch wird in der XAML-Datei ein Block eingefügt, der zur Laufzeit die Einstellungen zur Transformation speichert.

  4. speichern Sie die Datei und ersetzen Sie im zenon Projekt die alte Version mit dieser neuen Datei
  5. öffnen Sie wieder den Konfigurationsdialog des WPF-Elements:
    1. wählen Sie den Button MyButton aus
    2. wählen Sie die Registerkarte Transformationen

    1. selektieren Sie das Element RotateTransform.Angle
    2. klicken Sie in die Spalte Verknüpfungsart
    3. wählen Sie in der Dropdownliste den Eintrag Transformationen aus
    4. klicken Sie in die Spalte Verknüpfung
    5. der Variablenauswahldialog wird geöffnet
    6. wählen Sie die Variable int, um diese Variable mit der Eigenschaft RotateTransform.Angle zu verknüpfen

Kompilieren Sie die Runtime-Dateien und starten Sie die Runtime. Loggen Sie sich als Benutzer Test ein und klicken Sie auf den Button. Der Button erhält den Wert 45 und das WPF-Element dreht sich um 45°.


Bargraf als WPF-XAML in zenon einbinden

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Beispiele: Integration von WPF in zenon -> Bargraf als WPF-XAML in zenon einbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bargraf als WPF-XAML in zenon einbinden

Aufbau des Beispiels:

  • Erzeugung eines Bargrafs in Adobe Illustrator und Umwandlung in WPF
  • einbinden in zenon
  • Verknüpfung mit Variablen
  • anpassen des Bargraf-WPF-Elements

Bargraf erstellen

Erzeugen Sie als ersten Schritt einen Bargraf wie im Kapite Workflow mit Adobe Illustrator beschrieben. Um die XAML-Datei in zenon verwenden zu können, fügen Sie diese im Projektbaum in den Ordner Dateien/Grafiken ein.

Bargraf einbinden

Hinweis: Für die folgende Beschreibung wird ein zenon Projekt mit folgenden Inhalten verwendet:

  • ein leeres Bild als Startbild
  • 4 Variablen vom Intern Treiber für
    • Skala 0
    • Skala Mitte
    • Skala hoch
    • aktueller Wert
  • eine Variable vom Mathematik Treiber für die Anzeige des aktuellen Werts (255)

Um den Bargraf einzubinden:

  1. öffnen Sie das leere Bild
  2. platzieren Sie ein WPF-Element im Bild
  3. wählen Sie im Eigenschaftenfenster XAML-Datei

    Interne ID: Bargraf als WPF-XAML in zenon einbinden

    XAML-Datei

    Auswahl der XAML-Datei für das WPF-Element. Klick auf ... öffnet Dialog zur Auswahl. Die Datei muss bereits im Projektmanager unter Dateien/Grafiken angelegt worden sein oder im Dialog über das Symbol Datei hinzufügen ausgewählt werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie die gewünschte XAML-Datei aus (z. B. bargraph_vertical.xaml) und schließen Sie den Dialog

Bargraf anpassen

Vor der Konfiguration wird die Skala der XAML-Datei, wenn nötig, angepasst:

Dazu:

  • legen Sie eine neue Mathematik-Variable an, die den neuen Wert in Bezug auf die Skalierung berechnet, zum Beispiel:
  • Variable: 0-1000
  • Mathematikvariable {im xaml-File erstellter Wert}*Variable/1000

    Dann wird die XAML-Datei konfiguriert.

Bargraf konfigurieren

  1. klicken Sie auf das WPF-Element und wählen Sie die Eigenschaft Konfiguration

    Interne ID: Bargraf als WPF-XAML in zenon einbinden

    Konfiguration

    Öffnet den Dialog zur Konfiguration der XAML-Datei. Eigenschaften, Ereignisse, Transformationen und Bedienberechtigungen können zugewiesen werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. der Konfigurationsdialog zeigt eine Vorschau der ausgewählten XAML-Datei
  3. wählen Sie den Minimum-Wert, den Mittelwert und der Maximum-Wert aus und verknüpfen Sie jeweils in der Eigenschaft Content die entsprechende Variable

  4. wählen Sie den Slider aus und verknüpfen Sie die Eigenschaft Value mit der Mathematik Variablen (in unserem Beispiel: calculation)

  5. Überprüfen Sie die Projektierung in der Runtime:


Fehlerbehandlung

Handbuch -> Bilder -> Bildelemente -> WPF-Element -> Engineering in zenon -> Fehlerbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einträge in LOG-Dateien

Eintrag | Level | Bedeutung
Xaml file found in %s with different name, using default! | Warnung | Der Name der Sammeldatei und der Name der darin enthaltenen XAML-Datei stimmt nicht überein. Um interne Konflikte zu vermeiden, wird im Arbeitsordner die Datei mit dem Name der Sammeldatei und der Endung .xaml verwendet.
no preview image found in %s | Warnung | Die Sammeldatei enhält keine gültige Vorschaugrafik (preview.png oder [Namen der XAML Datei].png). Daher kann keine Vorschau angezeigt werden.
Xaml file in %s not found or not unique! | Fehler | Die Sammeldatei enthält keine XAML-Datei oden mehrere Dateien mit der Endung .xaml. sie kann nicht verwendet werden.
Could not remove old assembly %s | Warnung | Im Arbeitsordner befindet sich ein Assembly, das durch eine neuere Version ersetzt werden soll, aber nicht gelöscht werden kann.
Could not copy new assembly %s | Fehler | Für ein Assembly im Arbeitsordner ist eine neue Version verfügbar, aber sie kann nicht dorthin kopiert werden. Möglicher Grund: z.B ist das alte Assembly noch geladen. Die alte Version wird weiter verwendet, die neue Version kann nicht benutzt werden,
file exception in %s | Fehler | Beim Zugriff auf eine Sammeldatei ist ein Dateifehler aufgetreten.
Generic exception in %s | Fehler | Beim Zugriff auf eine Sammeldatei ist ein allgemeiner Fehler aufgetreten.


Zahlenwert

Handbuch -> Bilder -> Bildelemente -> Zahlenwert

Mit dem Dynamische Element Zahlenwert stellen Sie numerische Werte dar.

Um Zahlenwert in einem Bild anzulegen:

  1. wählen Sie das Symbol Zahlenwert in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl einer numerischen Variablen öffnet sich
  5. wählen Sie die gewünschte Variable definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften

info Info

Während der Runtime gilt: Ein Dezimalwert kann sowohl als Komma als auch als Punkt eingegeben werden. Die Darstellung erfolgt immer als Punkt.


Zeigerinstrument

Handbuch -> Bilder -> Bildelemente -> Zeigerinstrument

Mit dem Dynamische Element Zeigerinstrument stellen Sie Zeigerinstrumente dar.

Um Zeigerinstrument in einem Bild anzulegen:

  1. wählen Sie das Symbol Zeigerinstrument in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl einer numerischen Variablen öffnet sich
  5. wählen Sie die gewünschte Variable definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften

Farbliche Darstellung der Grenzwertverletzung

Bei Grenzwertverletzungen kann die Farbe aus der Variablen den gesamten Bereich einfärben oder nur den Bereich ab der Grenzwertverletzung. Gesteuert wird diese Funktionalität über die Eigenschaft Explizit in der Gruppe Darstellung.

Interne ID: Zeigerinstrument

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zeigerinstrument

Explizit

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv

Hinweis: Beim Element Zeigerinstrument nur verfügbar, wenn die Darstellung als Band oder Teilkreis aktiv ist.

Interne ID: Zeigerinstrument

Teilkreis

Nur verfügbar, wenn die Anzeige als Band nicht aktiv ist:
Aktiv: Der Wert wird mit einem Teilkreis vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Teilkreis wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zeigerinstrument

Band

Nur verfügbar, wenn die Anzeige als Teilkreis nicht aktiv ist.

Unter Windows CE nicht verfügbar.
Aktiv: Der Wert wird mit einem Band vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Band wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv


Zustandselement

Handbuch -> Bilder -> Bildelemente -> Zustandselement

Mit dem Dynamische Element Zustandselement steuern Sie ein Bildsymbol. Dabei werden Eigenschaften einer verknüpften Variablen wie z.B. Farben, Blinken usw. auf ein Symbol übertragen. Sie können damit auch statische Grenzwerttexte angezeigen.

Um das Zustandselement in einem Bild anzulegen:

  1. wählen Sie das Symbol Zustandselement in der Symbolleiste Elemente oder in der Dropdownliste Dynamische Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie mit gedrückter linker Maustaste das Element auf
  4. der Dialog zur Auswahl einer Variablen öffnet sich
  5. wählen Sie die gewünschte Variable definieren Sie im Eigenschaftenfenster die gewünschten Eigenschaften

info Info

Statt dem dynamischen Element Zustandselement können auch die Dynamik-Eigenschaften eines entsprechenden Elements benutzt werden.


Bildelemente bearbeiten

Handbuch -> Bilder -> Bildelemente bearbeiten

Für Bildelemente stehen Ihnen vielfältige Bearbeitungsmöglichkeiten offen:

  • Grafische Aktionen
  • Automatisiertes Ersetzen
  • Hintergrundgrafiken
  • Funktionen Auswahldialog
  • Variablen Auswahldialog

Noch in diesem Kapitel

Grafische Aktionen

Verknüpfungen von Variablen und Funktionen ersetzen

Hintergrundgrafiken

Funktionen Auswahldialog

Variablen Auswahldialog


Grafische Aktionen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon sind auch grafische Aktionen möglich. Dafür nutzen Sie:

  • Eigenschaften des Elements
  • Befehle im Menü Bearbeiten
  • Aktionen mit der Maus:
    • Halten der Taste Strg beim Verschieben mit der Maus kopiert das Element.
    • Verschieben mit gedrückter rechter Maustaste öffnet das Kontextmenü für die Wahl, ob kopiert oder verschoben werden soll
  • das Kontextmenü

info Info

Grafische Aktionen wie Schatten oder Weichzeichner können Auswirkungen auf die Performance des Systems haben, sowohl im Editor als auch zur Runtime.

Eingabe von Werten

Für die Eingabe von Werten innerhalb definierter Grenzen stehen bei vielen Eigenschaften zusätzlich auch Schieberegler zur Verfügung. Diese sind über die Schaltfläche ... erreichbar. Wertänderungen über Schieberegler werden sofort im Eigenschaftenfeld angezeigt.

Bei der Auswahl von Farben wird die jeweils in der Palette aktivierte Farbe als Vorschau direkt im Objekt angezeigt.

Noch in diesem Kapitel

Abrundungen

Effekte für Bildelemente

Elemente bewegen

Farbverlauf und Transparenz

Format übertragen

Kopieren, einfügen und verschieben

Punkte hinzufügen und löschen

Pfeile in Vektorelementen

Raster

Schrift

Selektieren

Skalieren, zentrieren und zoomen

Tastenkombinationen

Taste einem Kontrollelement zuweisen


Abrundungen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Abrundungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Elemente Rechteck und Button sowie Polygon, Polylinie und Rohrleitung können mit Abrundungen dargestellt werden.

info Info

Rundungen stehen bei aktiver Eigenschaft Windows CE Projekt oder Wert Windows Basis für Eigenschaft Grafikqualität nur eingeschränkt zur Verfügung.

Interne ID: Abrundungen

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Abrundungen

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: Abrundungen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Abrundungen

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: Abrundungen

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Rechteck und Button

Den Rundungsgrad definieren Sie mit den Eigenschaften im Knoten Abrundung. Für jeden Eckpunkt können jeweils 2 Werte eingegeben werden:

Interne ID: Abrundungen

Abrundung

Eigenschaften für die Darstellung abgerundeter Ecken.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • X-Wert: Prozentwert für die Rundung bezogen auf die Breite des Elementes
  • Y-Wert: ist ein Prozentwert für die Rundung bezogen auf die Höhe des Elementes

0 % bezeichnet keine Rundung.
100 % bezeichnen einen Viertelkreis.

Wird die EigenschaftProportional aktiviert, kann nur der X-Wert eingegeben werden.

Interne ID: Abrundungen

Proportional

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht gesetzt ist.

Interne ID: Abrundungen

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: Abrundungen

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Für die Abrundung der Ecken kann nur der X-Wert eingegeben werden. Der Y-Wert ist immer gleich.

Der bei Alle X [%] eingegebene Prozentwert bezieht sich auf die kürzere Seite (Breite oder Höhe) des Elements.

Interne ID: Abrundungen

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Inaktiv: Die X- und Y-Werte können frei eingegeben werden. Der X-Wert bezieht auf die Breite des Elementes, der Y-Wert auf die Höhe.

Default: aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Werte können für jede Ecke separat definiert werden. Wird der Wert einer Ecke auf -1 gesetzt, dann übernimmt er seinen Rundungswert von der Eigenschaft Alle X [%] bzw Alle Y [%].

Interne ID: Abrundungen

Alle Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der Y-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wird der Wert für Alle X [%] oder Alle Y [%] geändert, werden alle Werte der entsprechenden Achse auf -1 eingesetzt. Damit können unterschiedliche Werte sehr einfach wieder vereinheitlicht werden.

Tipp: Im rechten unteren Quadranten des Elements befindet sich ein kleines gelbes Dreieck. Klicken Sie mit der Maus darauf und bewegen Sie das Dreieck bis die gewünschte Rundung erreicht ist.

Beispiel:

Auf dem Button liegt eine GIF-Datei mit transparentem Hintergrund. Für den Button wurde ein rötlicher Farbverlauf definiert. Die Rundung der Ecken wurde mit Alle X [%] und Proportional definiert, anschließend wurde dieser Wert für die linke untere Ecke individuell geändert.

info Info

Wird die Eigenschaft Über Helligkeitswerte für die Darstellung der Füllfarbe verwendet, können keine abgerundeten Ecken dargestellt werden. Wird diese Eigenschaft für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Polygon, Polylinie und Rohrleitung

Den Rundungsgrad für Polygone, Polylinien und Rohrleitungen definieren Sie mit der Eigenschaft Rundung im Knoten Darstellung. Geben Sie dazu einen Wert zwischen 0 und 1 ein.

Interne ID: Abrundungen

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Abrundungen

Rundung

Nur verfügbar, wenn in den Projekteigenschaften die Option Grafikqualität im Knoten Grafische Ausprägung/Bilder aktiviert wurde.

Interne ID: Abrundungen

Bilder

Eigenschaften für die Anzeige der Bilder in der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Definiert für Polylinien, Polygone und Rohrleitungen die Rundung.

Werte: 0,0 (keine Rundung) bis 1,0. (maximale Rundung)

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Effekte für Bildelemente

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Effekte für Bildelemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Viele grafische Elemente können zur Runtime mit Effekten hervorgehoben werden.

Weitere Effekte finden Sie im Kapitel Effekte für Schablonen.

Noch in diesem Kapitel

Glow-Effekt

Rahmen und Schatten


Glow-Effekt

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Effekte für Bildelemente -> Glow-Effekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Viele Elemente in zenon unterstützen den Glow-Effekt.

Voraussetzungen

Um Glow-Effekt für ein grafisches Element verwenden zu können, müssen folgende Voraussetzungen erfüllt sein:

  • Die Projekteigenschaft Grafische Ausprägung/Grafikqualität muss auf DirectX Hardware oder DirectX Software gesetzt sein. Details siehe auch Kapitel Grafikqualität.

    Interne ID: Glow-Effekt

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Glow-Effekt

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Glow-Effekt

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Das grafische Element muss unterstützt werden.
    Bis auf folgende Ausnahmen werden alle grafischen Elemente unterstützt: WMF, Symbole, Combi-Element, ActiveX, WPF, alle Win32 Control Elemente, Fenster und einige spezielle Kontrollelemente.
  • Das Element muss sichtbar sein.
    Ist das Element unsichtbar, so ist der Glow-Effekt automatisch auch unsichtbar, da dieser vom Element direkt abgeleitet wird.

Konfiguration

Um den Glow-Effekt für ein unterstütztes Element zu konfigurieren:

  1. stellen Sie sicher, dass die Eigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt ist
  2. erstellen Sie das Element
  3. navigieren Sie zum Eigenschaftenknoten Effekte

    Interne ID: Glow-Effekt

    Effekte

    Enthält Eigenschaften für die Konfiguration von Bild-Effekten.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. aktivieren Sie im Bereich Glow (nur DirectX) die Eigenschaft Aktivieren

    Interne ID: Glow-Effekt

    Aktivieren

    Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

    Interne ID: Glow-Effekt

    Windows CE Projekt

    Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
    Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

    Interne ID: Glow-Effekt

    RGM Datenablage

    Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
    MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
    Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

    Default: Binäre Dateien (CE kompatibel)

    Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
    Default: inaktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

    Default: inaktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Glow-Effekt

    Glow (nur DirectX)

    Eigenschaften für die Konfiguration des Glow-Effekts. Nur verfügbar, wenn Eigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. konfigurieren Sie Transparenz, Farbe, Ausbreitung und Sichtbarkeit

    Werden mehrere Eigenschaften für den gleichen Effekt konfiguriert, wird die jeweils stärkere zur Runtime ausgeführt. Details siehe Abschnitt Abhängigkeit der Konfiguration. (Zum Beispiel: Ein unsichtbarer Glow-Effekt ist immer unsichtbar, die Einstellung zum Blinken hat dann keine Auswirkung mehr.)

Defaultwerte für den Glow-Effekt:

  • Aktivieren: inaktiv
  • Nur aktiv wenn gedrückt: inaktiv

    Interne ID: Glow-Effekt

    Nur aktiv wenn gedrückt

    Nur verfügbar, wenn Eigenschaft Aktivieren aktiv ist und es sich um eine Button Element handelt.

    Aktiv: Der Glow-Effekt wird nur dargestellt, wenn der Button gedrückt ist. Der Glow-Effekt kann während des Drückens auch die Farbe wechseln, blinken oder unsichtbar geschaltet werden.

    Default: inaktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Transparenz [%]: 20 %

    Interne ID: Glow-Effekt

    Transparenz [%]

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

    Transparenzwert, mit dem der Glow-Effekt auf dem Element dargestellt wird. Einheit: in Prozent. Klick auf Schaltfläche ... öffnet Schieberegler.

    Minimum: 0%, unsichtbar

    Maximum: 100%, voll deckend

    Default: 20%

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ausbreitung [Pixel]: 15 Pixel

    Interne ID: Glow-Effekt

    Ausbreitung [Pixel]

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

    Definiert den Ausbreitungsfaktor für den Glow-Effekt. Dieser wird definiert als Anzahl an Pixel, die auf jeder Seite in die Ausbreitung mit eingerechnet werden.

    Minimum: 0, keine Ausbreitung

    Maximum: 50

    Default: 15

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Einfärben: inaktiv

    Interne ID: Glow-Effekt

    Einfärben

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

    Aktiv: Der Glow-Effekt für das Element wird eingefärbt. Damit wird der gesamte Glow Effekt mit nur einer definierten Farbe dargestellt. Die Farbe kann über die Eigenschaft Farbe oder eine in Eigenschaft Variable für Farbe definierte Variable eingestellt werden. Sind beide Eigenschaften aktiv, wird die Farbe aus Variable für Farbe verwendet.

    Interne ID: Glow-Effekt

    Variable für Farbe

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

    Name der Variablen, deren Grenzwertfarben die Glow-Farbe beeinflussen sollen. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden. Wenn keine Variable verknüpft ist, wird die in der Eigenschaft Farbe definierte Farbe verwendet.

    Default: keine Variable verknüpft

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Glow-Effekt

    Farbe

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

    Bestimmt die Farbe des Glow Effekts. Klick auf Schaltfläche ... öffnet Farbpalette zur Auswahl der Farbe. Direkte Eingabe des Hex-Werts in Feld ist möglich.

    Default: 0xFFFF90 (Gelb)

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Inaktiv: Die Farben des Elementes werden für den Glow-Effekt verwendet.

    Default: inaktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Farbe: #FFFF90 (gelb)
  • Variable für Farbe: keine
  • Variable für Sichtbarkeit: keine

    Interne ID: Glow-Effekt

    Variable für Sichtbarkeit

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

    Name der Variablen, deren Wert die Sichtbarkeit des Glow-Effekts beeinflusst. Die Sichtbarkeit wird entweder aus den Grenzwerteigenschaften dieser Variablen übernommen (Eigenschaft Sichtbarkeit von Grenzwert übernehmen aktiv) oder durch den Wertbereich bestimmt, der bei den Eigenschaften Sichtbar von und Sichtbar bis definiert ist. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden.

    Interne ID: Glow-Effekt

    Sichtbar bis

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

    Definiert den Wert, bis zu dem der Glow-Effekt sichtbar ist.
    Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
    Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
    Default: höchster möglicher Wert der inVariable für Sichtbarkeit verknüpften Variable.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Glow-Effekt

    Sichtbar von

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

    Definiert den Wert, ab dem der Glow-Effekt sichtbar ist.
    Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
    Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
    Default: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variable.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Glow-Effekt

    Sichtbarkeit von Grenzwert übernehmen

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein.

    Aktiv: Die Sichtbarkeit des Glow-Effekts wird von den Grenzwerteigenschaften der Variable beeinflusst.

    Achtung: Zumindest bei einem Grenzwert dieser Variablen muss die Eigenschaft Unsichtbar aktiv sein.

    Interne ID: Glow-Effekt

    Unsichtbar

    Aktiv: Zustand wird im dynamischen Element "Zustandselement" nicht dargestellt oder Elemente werden nicht dargestellt, wenn ihre Sichtbarkeit über diese Variable gesteuert wird.
    Inaktiv: Die Sichtbarkeit wird nicht durch die Grenzwertverletzung beeinflusst.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Inaktiv: Die Sichtbarkeit wird von den Eigenschaften des Elements beeinflusst.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Hinweis: Wenn keine Variable verknüpft ist, ist der Glow-Effekt immer sichtbar.

    Default: keine Variable verknüpft

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Sichtbarkeit von Grenzwert übernehmen: inaktiv
  • Sichtbar von: 0
  • Sichtbar bis: 0
  • Variable für Blinken: keine

    Interne ID: Glow-Effekt

    Variable für Blinken

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

    Variable, von deren Grenzwert oder Grenzwerten das Blinken für den Glow-Effekt übernommen werden soll. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

    Default: keine Variable verknüpft

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Blinkfarbe von Grenzwert übernehmen: inaktiv

    Interne ID: Glow-Effekt

    Blinkfarbe von Grenzwert übernehmen

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in Eigenschaft Variable für Blinken eien Variable definiert sein.

    Aktiv: Übernimmt Farbe für den Glow-Effekt für das Blinken aus dem aktiven Grenzwert der in Eigenschaft Blinkfarbe aus Grenzwert definierten Variablen. Diese Eigenschaft ist unabhängig von der Eigenschaft Einfärben. Der Glow-Effekt wechselt beim Blinken nicht zu unsichtbar, sondern zum aktiv eingestellten Glow Effekt.

    Interne ID: Glow-Effekt

    Blinkfarbe aus Grenzwert

    Aktiv: Übernimmt Hintergrundfarbe des Blinkens aus dem aktiven Grenzwert der Variablen für Blinken von Grenzwert übernehmen. Element wechselt beim Blinken nicht zu unsichtbar, sondern zur aktiven Hintergrundfarbe.

    Interne ID: Glow-Effekt

    Blinken von Grenzwert übernehmen

    Variable, von deren Grenzwert(en) das Blinken für das Element übernommen werden soll. Klick auf die Schaltfläche ... öffnet den Variablenauswahldialog.

    Im Gegensatz zum normalen Blinken blinkt das ganze Element und nicht nur der dargestellte Wert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Default: inaktiv

    Hinweis: Diese Farbe wird nicht berücksichtigt, wenn die Hintergrundfarbe Transparent konfiguriert ist.

    Interne ID: Glow-Effekt

    Transparent

    Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

    Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Default: inaktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • 2. Blinkzustand unsichtbar: inaktiv

    Interne ID: Glow-Effekt

    2. Blinkzustand unsichtbar

    Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in Eigenschaft Variable für Blinken eine Variable definiert sein und die Eigenschaft Blinkfarbe von Grenzwert übernehmen aktiv sein.

    Aktiv: Der Glow-Effekt wechselt beim Blinken nicht zum eingestellten Glow-Effekt, sondern zu unsichtbar. Dadurch ist ein Blinken zwischen unsichtbar und der Blinkfarbe aus dem Grenzwert möglich.

    Default: inaktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Abhängigkeiten der Konfiguration

Variable für Sichtbarkeit

Sichtbarkeit hat besonders große Auswirkungen. Ist der Glow-Effekt auf nicht sichtbar gesetzt, werden Blinken und Farben ignoriert. Abhängigkeiten:

  1. Variable für Sichtbarkeit ist verknüpft und Sichtbarkeit von Grenzwert übernehmen ist aktiv:
    • Unsichtbar im Grenzwert ist aktiviert: Glow Effekt ist nicht sichtbar.
    • Unsichtbar im Grenzwert ist nicht aktiviert:
      Der in den Eigenschaften konfigurierte Glow-Effekt wird angezeigt. Abhängig von den Einstellungen kann der Glow-Effekt auch blinken.
  2. Variable für Sichtbarkeit ist verknüpft und Sichtbarkeit von Grenzwert übernehmen ist nicht aktiv:
    • Der Variablenwert befindet sich innerhalb der Grenzen der Eigenschaften von Sichtbar von und Sichtbar bis:
      Der in den Eigenschaften konfigurierte Glow-Effekt wird angezeigt. Abhängig von den Einstellungen kann der Glow-Effekt auch blinken.
    • Der Variablenwert befindet sich außerhalb der Grenzen der Eigenschaften von Sichtbar von und Sichtbar bis:
      Der Glow-Effekt ist nicht sichtbar
  3. Variable für Sichtbarkeit ist nicht verknüpft:
    Der in den Eigenschaften konfigurierte Glow-Effekt wird angezeigt. Abhängig von den Einstellungen kann der Glow-Effekt auch blinken.

Variable für Blinken

Bei allen Zuständen, bei denen der ursprünglich konfigurierte Glow-Effekt angezeigt wird, erhält man jenen Glow-Effekt, der in den Eigenschaften eingestellt ist. Dabei kann zum Beispiel auch die Farbe aus einem Grenzwert einer eigenen Variable kommen; Details siehe Farbe aus Variable.

  1. Variable für Blinken ist verknüpft, Blinkfarbe von Grenzwert übernehmen ist aktiv und 2. Blinkzustand unsichtbar ist aktiv:
    • Grenzwert wurde verletzt:
      Glow-Effekt blinkt und wechselt zwischen eingefärbtem Glow-Effekt (aus Grenzwertverletzung) und dem ursprünglich in den Eigenschaften konfigurierten Glow-Effekt.
    • Grenzwert wurde nicht verletzt:
      Glow-Effekt blinkt nicht und es wird der ursprünglich in den Eigenschaften konfigurierte Glow-Effekt angezeigt.
  2. Variable für Blinken ist verknüpft, Blinkfarbe von Grenzwert übernehmen ist aktiv und 2. Blinkzustand unsichtbar ist nicht aktiv:
    • Grenzwertverletzung aktiv:
      Glow-Effekt blinkt und wechselt zwischen eingefärbtem Glow-Effekt (aus Grenzwertverletzung) und dem nicht dargestellten Glow-Effekt.
    • Grenzwertverletzung nicht aktiv:
      Glow-Effekt blinkt nicht und es wird der ursprünglich in den Eigenschaften konfigurierte Glow-Effekt angezeigt.
  3. Variable für Blinken ist verknüpft, Blinkfarbe von Grenzwert übernehmen ist nicht aktiv:
    • Grenzwertverletzung aktiv:
      Glow-Effekt blinkt und wechselt zwischen dem ursprünglich in den Eigenschaften konfigurierten Glow-Effekt und dem nicht dargestellten Glow-Effekt.
    • Grenzwertverletzung nicht aktiv:
      Glow-Effekt blinkt nicht und es wird der ursprünglich in den Eigenschaften konfigurierte Glow-Effekt angezeigt.
  4. Variable für Blinken ist nicht:
    Glow-Effekt kann abhängig von anderen Eigenschaften dargestellt werden.

Farbe aus Variable:

Stellt die Möglichkeit dar, die Farbe des Glow-Effekts bei der normalen Darstellung über den Grenzwert einer Variable festzulegen. Dies gilt auch für die normale Darstellung, wenn der Glow-Effekt blinkt.

  1. Variable für Farbe verknüpft:
    1. Grenzwertverletzung aktiv:
      Die Farbe aus dem verletzten Grenzwert wird verwendet.
    2. Grenzwertverletzung nicht aktiv:
      Zum Einfärben des Glow-Effekts wird die in der Eigenschaft Farbe eingestellte Farbe verwendet.
  2. Variable für Farbe nicht verknüpft:
    Zum Einfärben des Glow-Effekts wird die in der Eigenschaft Farbe eingestellte Farbe verwendet.

Einfärben:

Definiert, ob der Glow-Effekt als Abbild des eigentlichen Elementes erzeugt oder mit einer einzelnen Farbe eingefärbt wird.

  1. Einfärben aktiv und Variable für Farbe verknüpft:
    1. Grenzwertverletzung aktiv:
      Zum Einfärben des Glow Effekts wird die Farbe aus dem verletzten Grenzwert verwendet.
    2. Grenzwertverletzung nicht aktiv:
      Zum Einfärben des Glow-Effekts wird die in der Eigenschaft Farbe eingestellte Farbe verwendet.
  2. Einfärben aktiv und Variable für Farbe nicht verknüpft:
    Zum Einfärben des Glow-Effekts wird die in der Eigenschaft Farbe eingestellte Farbe verwendet.
  3. Einfärben nicht aktiv: Es wird ein Abbild des eigentlichen Elementes mit all den entsprechenden Farben des Elementes für den Glow-Effekt verwendet.

Tipps zur Konfiguration

Um gute Ergebnisse zu erhalten:

  • Wählen Sie für Transparenz [%] einen eher niedrigen Wert. Ohne Einfärbung darf der Wert etwas höher liegen als mit Einfärbung.
  • Wählen Sie für Ausbreitung [Pixel] einen nicht zu kleinen Wert. Er sollte >5 gehalten werden, damit der Effekt außerhalb des Elements sichtbar ist.
    Achtung: Zu hohe Werte (>20) können dazu führen, dass der Glow-Effekt sehr stark reduziert wird. In diesem Fall kann die Sichtbarkeit durch weitere Reduktion der Transparenz erhöht werden. Allgemein kostet der Glow-Effekt viel Performance und sollte deshalb gut überlegt eingesetzt werden. Ein höherer Wert für Ausbreitung [Pixel] kostet mehr Performance, was sich besonders bei einander nahe liegenden Elementen auswirken kann.
  • Da der Glow-Effekt (wie auch der Schatten) bei DirectX direkt vom originalen Element abgeleitet wird, haben auch dynamische Änderungen des Elementes Auswirkungen auf den Effekt. Zusätzlich können auch Bitmap Grafiken mit den Effekten ausgestattet werden: So erhält zum Beispiel ein PNG-Bild mit teiltransparenten Bereichen genauso wie eine GIF-Animation, einen korrekten Glow-Effekt, der dynamisch während der Darstellung erzeugt wird. Der Glow-Effekt wirkt wie der Schatten auch auf Text, wodurch entsprechende Effekte erzielt werden können.

Noch in diesem Kapitel

Beispiele für Glow-Effekt

Fehlerbehandlung


Beispiele für Glow-Effekt

Beispiele für Glow-Effekt

Glow-Effekt

Element ohne Glow-Effekt:

Element mit Glow-Effekt:

Farben

Default Farbe 0xFFFF90 (Gelb):

Farbe 0xFFFFFF (Weiß):

Transparenz

0% Transparenz:

20% Transparenz:

60% Transparenz:

Ausbreitung

0 Pixel Ausbreitung und 0% Transparenz:

5 Pixel Ausbreitung und 0% Transparenz:

10 Pixel Ausbreitung und 0% Transparenz:

20 Pixel Ausbreitung und 0% Transparenz:

Farbe 0xFFFF90 und 5 Pixel Ausbreitung sowie 20% Transparenz:

Farbe 0xFFFF90 und 20 Pixel Ausbreitung sowie 20% Transparenz:

Texte

5 Pixel Ausbreitung und 0% Transparenz:

Farbe 0xFF0000 und Ausbreitung 5 Pixel sowie 0% Transparenz:

Große Schrift mit 15 Pixel Ausbreitung und 0% Transparenz:

Große Schrift mit Farbe 0xFF0000 und Ausbreitung 35 Pixel sowie 20% Transparenz:

Teiltransparente Grafik

Original:

20 Pixel Ausbreitung und 20% Transparenz:

Farbe 0xFF0000 mit 20 Pixel Ausbreitung und 20% Transparenz:

Ohne Farbe, 20 Pixel Ausbreitung und 20% Transparenz plus Schatten mit 40 Pixel Abstand, 60% Transparenz, schwarzer Farbe und 5 Pixel Weichzeichner:

Element ändert sich

3D-Button in Kontrastfarben, mit 15 Pixel Ausbreitung und 0 % Transparenz auf 3D Button:

3D-Button in Kontrastfarben, gedrückt mit 15 Pixel Ausbreitung und 0 % Transparenz auf 3D Button:


Fehlerbehandlung

Fehlerbehandlung

Ausgabefenster

Eintrag | Level | Erklärung
DirectX: Bild 'Bildname' - Element 'Elementname' verwendet einen Effekt, der mit der ausgewählten Grafikqualitätseinstellung nicht darstellbar ist. | Warning | Bei einem Element ist der Glow-Effekt aktiviert. Allerdings wurde DirectX Software oder DirectX Hardware nicht ausgewählt oder ist nicht verfügbar.

Checkliste zur Fehlereingrenzung

  • Ist DirectX eingeschaltet?
  • Ist DirectX auf dem Systems verfügbar? Eine entsprechende Überprüfung kann durch das Aktivieren der Debug Meldungen im DiagViewer durchgeführt werden. Bei erfolgreicher Unterstützung kommt eine entsprechende Meldung.
  • Unterstützt das Element überhaupt den Glow-Effekt?
  • Ist das Element sichtbar?
  • Führen statische Eigenschaften dazu (zum Beispiel Transparenz), dass der Glow-Effekt nicht oder anders als gewünscht dargestellt wird?
  • Führen dynamische Eigenschaften dazu, dass der Glow-Effekt nicht oder anders als gewünscht dargestellt wird?
  • Ist eine Eigenschaft ausgewählt, die nur unter bestimmten Bedingungen das Anzeigen des Glow-Effekts hervorruft (Button Element mit der Eigenschaft „Nur aktiv wenn gedrückt")?


Rahmen und Schatten

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Effekte für Bildelemente -> Rahmen und Schatten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Elemente können durch Rahmen und Schatten erweitert werden.

Ausnahme: Zustandselemente können keinen Schatten erhalten.

info Info

Wird die Transparenz eines Objekts (z.B. der Hintergrundfarbe) geändert, ändert sich auch die Darstellung des bereits konfigurierten Schattens entsprechend. Die Werte für Farbe und Transparenz des des Schattens bleiben dabei aber gleich.

Rahmen und Schatten zuweisen

  • Um ein Element mit einem Rahmen zu versehen, wählen Sie im Knoten Rahmen/Schatten in der Eigenschaft Rahmenart Rahmen aus.

    Interne ID: Rahmen und Schatten

    Rahmenart

    Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

    Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
    Rahmen: Das Element kann mit einem Rahmen versehen werden.
    Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
    Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

    Interne ID: Rahmen und Schatten

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Rahmen und Schatten

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Interne ID: Rahmen und Schatten

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Default: Kein Rahmen/Schatten

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Rahmen und Schatten

    Rahmen/Schatten

    Eigenschaften für Rahmen und Schatten um das Element.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Um ein Element mit einem Schatten zu versehen, wählen Sie im Knoten Rahmen/Schatten in der Eigenschaft Rahmenart Schatten aus.

Für Schatten und Rahmen können Sie festlegen

  • Abstand: Abstand des Rahmens oder Schattens zum Element.
  • Rahmenfarbe: Farbe des Rahmens oder des Schattens.

Für den Rahmen können Sie festlegen

  • Linienbreite: Die Breite des Rahmens.

Für den Schatten können Sie festlegen

  • Winkel: Den Winkel in Grad, um die sich der Schatten beginnenden bei rechts außen gegen den Uhrzeigersinn verschiebt.

  • Transparenz: Transparenz des Schattens zwischen 0 und 100%, wobei 0% deckend und 100% durchsichtig ist.
  • Schattengröße: Größe des Schattens in Pixel.
  • Weichzeichnung: Verwischt die Oberflächenfarbe und macht den Übergang des Schattens weicher.
    Hinweis: ist hier ein Wert ungleich 0 eingestellt, dann beeinflusst die Berechnung des Schattens die Systemleistung.

info Info

Transparenz bei Linien oder Füllfarben eines Elements wirkt sich auch auf den Schatten aus. Zum Beispiel: Wird die Füllfarbe auf 100% transparent gesetzt, dann ist auch kein Schatten für den Füllbereich zu sehen.

Noch in diesem Kapitel

Beispiele


Beispiele

Beispiele

Schatten mit Winkel von 45 Grad um 10 Pixel versetzt

Schatten mit Winkel von 45 Grad um 30 Pixel versetzt

Schatten mit Größe 30 Pixel

Schatten mit Größe -20 Pixel

Schatten mit Größe -20 Pixel und transparentem Farbverlauf im Element

Abgerundetes Rechteck mit einer Weichzeichnung von 10


Elemente bewegen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Elemente bewegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Elemente zu bewegen benutzen Sie:

ab Version 6.50

die Eigenschaften beim jeweiligen Element:

  • Position

    Interne ID: Elemente bewegen

    Position

    Eigenschaften zu Position und Größe des Dynamischen Elements.

    Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Größe und Drehen dynamisch

    Interne ID: Elemente bewegen

    Größe und Drehen dynamisch

    Eigenschaften zur Dynamik des Elements.
    Die Darstellung des Elements wird über Zustände von Variablen zur Laufzeit dynamisch angepasst.

    Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zusätzlich dynamisieren Sie Elemente auch mit den Eigenschaften

  • Farben dynamisch im Knoten Farben

    Interne ID: Elemente bewegen

    Farben

    Farbeigenschaften des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Elemente bewegen

    Farben dynamisch

    Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Blinken im Knoten Sichtbarkeit/Blinken

    Interne ID: Elemente bewegen

    Sichtbarkeit/Blinken

    Eigenschaften für die Sichtbarkeit und das Blinken des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Elemente bewegen

    Blinken

    Eigenschaften für das Blinken des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Sichtbarkeit im Knoten Sichtbarkeit/Blinken

    Interne ID: Elemente bewegen

    Sichtbarkeit

    Eigenschaften für die Sichtbarkeit des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

bis inklusive Version 6.22 und Runtime Kompatibilität

  • Sie können alternativ das Dynamische Element Symbol bewegen verwenden


Farbverlauf und Transparenz

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Farbverlauf und Transparenz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Elemente können mit Farbverläufen versehen werden oder auf transparent geschaltet werden.

Dazu wählen Sie bei den Eigenschaften des Elements im Knoten Farben die entsprechenden Eigenschaften aus:

Interne ID: Farbverlauf und Transparenz

Farben

Farbeigenschaften des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Farbverlauf

Farbverläufe können mit folgender Ausrichtung bei folgenden Elementen eingestellt werden:

Element | Linear | Punktuell | Punktuell mit Kanten
Rechteck | ja | ja | ja
Kreis | ja | ja | nein
Kreissegment | ja | ja | nein
Polygon | ja | ja | ja
Button | ja | ja | ja

Um Farbverläufe zu definieren, wählen Sie als Füllmuster Farbverlauf.

Interne ID: Farbverlauf und Transparenz

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: Farbverlauf und Transparenz

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Sie können den Farbverlauf nun entweder über die Eigenschaften der Gruppe Farbverlauf definieren. Den Farberlauf können Sie auch mit der Maus definieren. Klicken Sie dazu auf den kleinen gelben Kreis im Element (mit Verbindungslinie zum Mittelpunkt) und bewegen Sie den Kreis, bis Sie den gewünschten Verlauf erreichen.

Interne ID: Farbverlauf und Transparenz

Farbverlauf

Eigenschaften für die Projektierung von Farbverläufen. Nur verfügbar, wenn Farbverlauf als Füllmuster ausgewählt ist.
Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Rechtecke werden bei Winkeln zwischen 45° und 135° sowie zwischen 225° und 315° horizontal ausgerichtet.

Für Polygone steht die Eigenschaft Über Helligkeitswerte nicht zur Verfügung.

Farbverlauf unter Windows CE oder bei Grafikqualität Windows Basis

Unter Windows CE oder bei der Einstellung Windows Basis für die Eigenschaft Grafikqualität lassen sich Farbverläufe für Vektorelemente nur über Helligkeitswerte realisieren. Die Eigenschaft Farbverlauf steht nicht zur Verfügung. Benutzen Sie zur Darstellung von Farbverläufen die Eigenschaften:

Interne ID: Farbverlauf und Transparenz

Farbverlauf

Nur verfügbar, wenn Füllmuster auf Farbverlauf gesetzt wurde.

Definiert den Farbverlauf für Vektorelemente.

linear: gleichmäßiger Verlauf
punktuell: Verlauf von den Rändern zum Zentrum

punktuell mit Kanten: Verlauf von den Rändern zum Zentrum mit Kantenbildung

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Farbverlauf und Transparenz

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Farbverlauf und Transparenz

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: Farbverlauf und Transparenz

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Versatz [%]: funktioniert nur für das Element Rechteck

    Interne ID: Farbverlauf und Transparenz

    Versatz [%]

    Nur verfügbar, wenn bei einem Vektorelement die Eigenschaft Farbverlauf oder beim Dynamischen Element Button die Eigenschaft Füllung gesetzt wurde auf: linear oder punktuell oder punktuell mit Kanten.

    Interne ID: Farbverlauf und Transparenz

    Füllung

    Füllung des Buttons:
    einfarbig: Kein Verlauf
    linear: gleichmäßiger Verlauf
    strahlend: Von unten bis zur Mitte Füllfarbe 1, dann Verlauf von Mitte nach oben
    punktuell: Verlauf von den Rändern zum Zentrum

    punktuell mit Kanten: Verlauf von den Rändern zum Zentrum mit Kantenbildung

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert den Abstand des Farbverlaufspunktes vom Mittelpunkt des Elements. Dabei handelt es sich um einen Prozentwert.

    Werte: 0 beschreibt den Mittelpunkt im Element, 100 den Rand.
    Hinweis: Dieser Wert kann auch außerhalb des Elements liegen und ist daher nicht auf 100 beschränkt.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Winkel [°]: funktioniert nur für das Element Rechteck

    Interne ID: Farbverlauf und Transparenz

    Winkel [°]

    Definiert die Richtung des Farbverlaufs ausgehend vom Mittelpunkt des Elements.

    Werte: 0° bis 360°

    Default: 0°

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Helligkeit aussen

    Interne ID: Farbverlauf und Transparenz

    Helligkeit aussen

    Nur verfügbar, wenn "Über Helligkeitswerte" aktiv ist:
    Helligkeit an der Aussenseite des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Helligkeit innen

    Interne ID: Farbverlauf und Transparenz

    Helligkeit innen

    Nur verfügbar, wenn "Über Helligkeitswerte" aktiv ist:
    Helligkeit in der Mitte des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beachten Sie:

Die Eigenschaft Über Helligkeitswerte muss nicht extra aktiviert werden.

Die Eigenschaft Winkel [°] kann unter Windows CE und bei bei der Einstellung Windows Basis für die Eigenschaft Grafikqualität nur in Schritten von 90° verändert werden.

Button

Für das Element Button gilt unter Windows CE und Windows Basis zusätzlich:

  • Für die Eigenschaft Füllung stehen die Werte Punktuell und und Punktuell mit Kante nicht zur Verfügung.
  • Die Eigenschaft Winkel [°] steht nicht zur Verfügung.

Transparenz

Über die Eigenschaft Transparent schalten Sie ein Element komplett transparent.

Interne ID: Farbverlauf und Transparenz

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um Elemente teilweise transparent zu schalten, nutzen Sie die Eigenschaften für Transparenz der Füllfarben, Verlaufsfarbe und der Rahmenfarbe. Hier definieren Sie die Deckkraft der Farben mit Werten zwischen 0 und 100 Prozent. Dabei ist 0 unsichtbar und 100 deckend. Alle Werte dazwischen erscheinen je nach Einstellung transparent.

Beispiele

Transparenz: Füllfarbe = 100, Füllfarbe 2 = 100

Transparenz: Füllfarbe = 50, Füllfarbe 2 = 100.

Transparenz: Füllfarbe = 0, Füllfarbe 2 = 100.

info Info

Kontrollelemente zur Steuerung von Listenfelder wie Bildlaufleisten unterstützen keine Transparenz.


Format übertragen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Format übertragen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Eigenschaften eines ausgewählten Elements auf ein anderes oder mehrere zu übertragen:

  1. Übertragen auf ein Element:
    1. Klick auf Element mit Ursprungseigenschaften -
    2. Klick auf Symbol Eigenschaften übertragen
      oder entsprechenden Befehl im Kontextmenü
    3. Klick auf Zielelement: Eigenschaften werden übertragen
  2. Übertragen auf mehrere Elemente:
    1. Quellelement auswählen -
    2. Zielelemente mit gedrückter Strg-Taste auswählen (Quell und Zielelemente sind markiert)
    3. Klick auf Symbol Eigenschaften übertragen oder entsprechenden Befehl im Kontextmenü
    4. Eigenschaften des Quellelements werden auf die Zielelemente übertragen.

Wurden mehrere Elemente als Quelle gewählt, werden die Eigenschaften des ersten gewählten Elements übertragen.

info Info

Eigenschaften über Eigenschaftenfenster übernehmen:

Werden mehrere Elemente markiert, werden die Eigenschaften des jeweils letzten markierten Elements in der Eigenschaften-Eingabe angezeigt. Wird das Eigenschaftenfenster im Modus Gruppierte Ansicht oder im Modus Alle Eigenschaften angezeigt, kann die jeweilige Eigenschaft mit Drücken der Taste Eingabe auf alle anderen markierten Elemente übertragen werden. Im Modus Dialogansich t ist das nicht möglich. Details siehe Kapitel Eigenschaftenfenster, Abschnitt Multiselekt.

Regeln für die Übertragung von Formaten

Übertragen werden:

  • Eigenschaften, die ein Element in Form und Farbe und Aussehen direkt bestimmen und nicht von einer Variablen beeinflusst werden

Nicht übertragen werden:

  • deaktivierte Eigenschaften
  • direkte Eigenschaften, die nicht sinnvoll übertragbar sind, wie Texte und Grafikdateien

    Ausnahme:

    • Grafikdateien beim Schalter werden kopiert, da man normalerweise immer die gleichen Schalter haben möchte.
    • Grafikdateien beim Button werden nicht kopiert, da hier normalerweise unterschiedliche verwendet werden.
  • Eigenschaften aus den Gruppen:
    • Berechtigung

      Interne ID: Format übertragen

      Berechtigung

      Eigenschaften für die Bedienberechtigung des Elements.

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Automatic Line Coloring

      Interne ID: Format übertragen

      Automatic Line Coloring

      Eigenschaften nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
      Eigenschaften für ALC.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Allgemein

      Interne ID: Format übertragen

      Allgemein

      Allgemeine Eigenschaften des Elements.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Position

      Interne ID: Format übertragen

      Position

      Eigenschaften zu Position und Größe des Dynamischen Elements.

      Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Größe und Drehen dynamisch

      Interne ID: Format übertragen

      Größe und Drehen dynamisch

      Eigenschaften zur Dynamik des Elements.
      Die Darstellung des Elements wird über Zustände von Variablen zur Laufzeit dynamisch angepasst.

      Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Runtime

      Interne ID: Format übertragen

      Runtime

      Eigenschaften für das Runtime-Verhalten des Elements.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • VBA

      Interne ID: Format übertragen

      VBA

      Eigenschaften für mit dem Element verknüpfte VBA Makros.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Sollwert absetzen

      Interne ID: Format übertragen

      Sollwert absetzen

      Eigenschaften zum Setzen von Sollwerten.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • alles, was direkt aus Variablen kommt
  • Variablen und Funktionsverknüpfungen


Kopieren, einfügen und verschieben

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Kopieren, einfügen und verschieben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Elemente in Bildern zu kopieren, zu verschieben oder zu löschen usw. nutzen Sie

  • Befehle im Menü Bearbeiten
  • Aktionen mit der Maus:

    Halten der Taste Strg beim Verschieben mit der Maus kopiert das Element.
    Verschieben mit gedrückter rechter Maustaste öffnet das Kontextmenü für die Wahl, ob kopiert oder verschoben werden soll

  • das Kontextmenü

Verschieben

Objekte können mit der Maus oder der Tastatur verschoben werden, ausgenommen Schablonen. In Kombination mit Funktionstasten nutzen Sie besondere Effekte beim Verschieben:

Taste | Aktion | Ergebnis
Strg | verschieben mit Maus | Objekt wird kopiert.
Umschalt | verschieben mit Maus | Objekt kann nur waagrecht und senkrecht verschoben werden.
Umschalt | verschieben mit Pfeiltasten | Jeder Tastendruck verschiebt das Objekt um 10 Pixel.
rechte Maustaste | verschieben mit Maus | Kontextmenü ermöglicht Wahl zwischen kopieren und verschieben.
Leertaste |  | Mauszeiger wird zur Verschiebe-Hand. Mit dieser kann die Arbeitsfläche des Bildes mit der linken Maustaste beliebig verschoben werden.


Punkte hinzufügen und löschen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Punkte hinzufügen und löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hinzufügen und Löschen von Punkten bei Polylinien, Polygonen und Rohrleitungen:

Hinzufügen von Punkten:

Um Eckpunkte (Stützpunkte) hinzuzufügen:

  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Hinzufügen eines Knotens im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf eine Linie des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick fügt einen Eckpunkt hinzu

Löschen von Punkten:

  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • klicken Sie mit der rechten Maustaste
  • wählen Sie im Kontextmenü den Eintrag Löschen des Knoten im selektierten Element

oder:

  • drücken Sie gleichzeitig Strg und Umschalt
  • bewegen Sie den Mauszeiger auf einen Punkt des Polyobjekts
  • der Mauszeiger ändert sich zu einem Pfeil mit einem Plus
  • ein Mausklick entfernt den Punkt


Pfeile in Vektorelementen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Pfeile in Vektorelementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für alle Vektor-Elemente, die offene Figuren darstellen, kann jeweils ein Symbol für Start und Ende der Linie definiert werden. Das gilt für:

  • Linie
  • Polylinie
  • Kreisbogen ohne Füllung
  • Kreissegment ohne Füllung

Um ein Symbol hinzuzufügen:

  1. achten Sie darauf, dass in den Projekteigenschaften die Eigenschaft Grafikqualität (Knoten Bilder) aktiviert ist

    Interne ID: Pfeile in Vektorelementen

    Bilder

    Eigenschaften für die Anzeige der Bilder in der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Pfeile in Vektorelementen

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Pfeile in Vektorelementen

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Interne ID: Pfeile in Vektorelementen

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. zeichnen Sie das Element
  3. wählen Sie in den Eigenschaften in der Gruppe Linienenden die Eigenschaften für:

    Interne ID: Pfeile in Vektorelementen

    Linienenden

    Enthält Eigenschaften für Form von Linienanfang und Linienende.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. Anfangstyp: Symbol für Linienanfang.

      Interne ID: Pfeile in Vektorelementen

      Anfangstyp

      Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.

      Definiert Symbol für Startpunkt der Linie. Klick auf Feld öffnet Dialog zur Auswahl eines Elements.

      Für Kreisbogen und Kreissegment nur verfügbar, wenn Füllmuster auf ohne gestellt wurde.

      Interne ID: Pfeile in Vektorelementen

      Füllmuster

      Auswahl des Füllmusters für das Element aus der Liste.

      Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

      Interne ID: Pfeile in Vektorelementen

      Über Helligkeitswerte

      Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
      Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

      Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

      Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    2. Endtyp: Symbol für Linienende.

      Interne ID: Pfeile in Vektorelementen

      Endtyp

      Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.

      Definiert Symbol für Endpunkt der Linie. Klick auf Feld öffnet Dialog zur Auswahl eines Elements.

      Für Kreisbogen und Kreissegment nur verfügbar, wenn Füllmuster auf ohne gestellt wurde.

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    3. Größe: Vergrößerungsfaktor für Linienbreite. Der Faktor bezieht auf den Linienbreite des Vektor-Elements wie in der Eigenschaft Linienbreite [Pixel] definiert. Default = 0.

      Interne ID: Pfeile in Vektorelementen

      Größe

      Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.

      Definiert den Vergrößerungsfaktor für die Linienbreite des Pfeils. Der Faktor bezieht sich auf die Linienbreite des Vektorelements wie in der Eigenschaft Linienbreite [Pixel] definiert.

      Für Kreisbogen und Kreissegment nur verfügbar, wennFüllmuster auf ohne gestellt wurde.

      Wert: größer oder gleich 1

      Default: 4

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Folgende Symbole stehen zur Verfügung:

Von links, bzw nach links:

Von rechts, bzw. nach rechts:

info Info

Diese Elemente stehen nicht zur Verfügung:

  • unter Windows CE, da Grafikqualität aktiviert sein muss
  • bei gefülltem Kreissegment
  • bei gefülltem Kreisbogen

Noch in diesem Kapitel

Beispiel für Pfeile


Beispiel für Pfeile

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Pfeile in Vektorelementen -> Beispiel für Pfeile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vektorelemente mit Start- und Endsymbolen mit einem Vergrößerungsfaktor von 1,5:


Raster

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Raster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Raster ermöglicht das exakte Ausrichten von Elementen im Bild.

Grundeinstellungen treffen Sie im Menü Optionen/Einstellungen:

Raster-Einstellungen |
Raster anzeigen | Aktiv: Zeigt im Hauptfenster den unter Rastertyp definierten Raster an. Inaktiv: Raster wird nicht angezeigt.
im Raster positionieren | Aktiv: Bildelemente werden immer am Raster ausgerichtet. Diese Funktion ist unabhängig von der Option Raster anzeigen.
Rasterfarbe | Definiert die Farbe des Rasters. Zur Auswahl wird die Windows Farbpalette benutzt.
Rastertyp | Legt die Art der Rasterdarstellung fest: durchzogen, gepunktet oder Schnittpunkte.
Raster-Abstand [Pixel] | Definiert den horizontalen und vertikalen Abstand zwischen einzelnen Markierungspunkten. Damit definiert er auch, wie fein abgestuft Elementgrößen dargestellt werden können. Empfohlener Rasterabstand: 10 Pixel horizontal und vertikal.

Im Kontextmenü des Bildes entscheiden Sie

Menüeintrag | Beschreibung
Raster anzeigen | Raster sichtbar oder unsichtbar schalten.
Raster verwenden | Elemente werden am Raster ausgerichtet.
Fangpunkte verwenden | Anfasspunkte der Objekte rasten bei Annäherung ein und richten sich aneinander aus.

info Info

Liegen Rasterpunkte 5 Pixel oder weniger auseinander, werden nur mehr die Rasterlinien angezeigt, die mehr als 5 Pixel auseinander liegen. Gerastert wird aber auch in den kleineren Rastern.


Schrift

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Schrift

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erstellen eines Projektes wird automatisch eine Default-Schrift angelegt. Diese wird bei neuen Objekten als Standardschrift vorgegeben. Die Default-Schrift kann nicht gelöscht werden. Wenn Sie andere Schriften benötigen:

  • erstellen Sie die gewünschte Schriftart im Knoten Schriften (Unterknoten von Bilder)
  • wählen Sie in den Objekteigenschaften die Schrift aus (Knoten Darstellung, Eigenschaft Schrift)

    Interne ID: Schrift

    Schrift

    Auswahl der Schrift, mit der die Darstellung erfolgt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Schrift

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Selektieren

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Selektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Objekte werden per Mausklick ausgewählt. Um mehrere Objekte auszuwählen:

  • halten Sie beim Klicken die Taste Umschalt oder Strg gedrückt
    oder
  • ziehen Sie ein Fangrechteck mit der Maus

Um bei Mehrfachselektion ein Objekt wieder zu deselektieren, klicken Sie es mit gedrückter Strg Taste an.

Selektionsreihenfolge ändern

Wenn Objekte aneinander ausgerichtet werden sollen, dienst das als erstes selektierte Objekt als Referenz. Sie erkennen das Referenzobjekt an den vollflächig gefüllten Anfasspunkten. Um ein anderes Objekt zum Referenzobjekt zum machen:

  1. halten Sie die Taste Umschalt gedrückt
  2. klicken Sie mit der Maus auf das Objekt, das als Referenzobjekt dienen soll

Ausrichten eines selektierten Objektes

Nähere Informationen zum Ausrichten von Objekten finden Sie in den Kapiteln Editor/Symbolleisten/Ausrichtung und Editor/Menüleiste/Bearbeiten


Skalieren, zentrieren und zoomen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Skalieren, zentrieren und zoomen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Skalieren

Sie können Elemente auf zwei Arten skalieren:

  1. proportional: Halten Sie dazu beim Skalieren die Taste Umschalt gedrückt
  2. um den Mittelpunkt: halten Sie dazu die Taste Alt gedrückt

Hinweis: Wurde für ein Element über die Eigenschaft Drehwinkel [°] ein Winkel ungleich 0 definiert, ist das Skalieren mittels Pfeiltasten nicht möglich.

Interne ID: Skalieren, zentrieren und zoomen

Drehwinkel [°]

Frei definierbarer Winkel, um den das Element gedreht wird. Positive Werte drehen gegen den Uhrzeigersinn, negative Werte im Uhrzeigersinn. Werte über 360° werden als Differenz zu 360° dargestellt (400° entspricht 40°). Es können nur ganze Zahlen eingetragen werden.

Bei gedrehten Elementen sind folgende Aktionen nicht mehr möglich:
- spiegeln
- rotieren um +/- 90°
- skalieren per Pfeiltasten

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Skalieren von Symbolen:

Enthält ein Symbol ein Element Statischer Text und ist in dieses Element Schrift eingebettet, dann wird diese Schrift:

  • im Editor skaliert
  • in der Runtime nicht skaliert

Dies gilt nur für Symbole. In allen anderen Konstellationen wird eingebetteter Text weder im Editor noch zur Runtime skaliert.

Zentrieren

Mit H kann das aktuell selektierte Objekt zentriert im Arbeitsausschnitt dargestellt werden.

Zoomen

Informationen zum Zoomen von Bildern lesen Sie im Kapitel Symbolleiste Bilder (Handbuch: Editor).


Tastenkombinationen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Tastenkombinationen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Tastenkombinationen für den Grafikeditor:

Hinweis zu Tastenkombinationen: Das Pluszeichen (+) bedeutet, Tasten werden gemeinsam gedrückt.
Zum Beispiel:

Strg+A bedeutet: Taste Strg halten und dann Taste A drücken.

Strg++ bedeutet Taste Strg halten und Taste + drücken.

Allgemein

Befehl | Tastenkombination
Hauptfenster: Inhalte mit Verschiebehand scrollen | Leer gedrückt halten
Aktuelles Bild schließen | Strg+F4
Eigenschaften öffnen | Alt+Eingabe

Auswählen

Befehl

Tastenkombination

Mehrere Objekte auswählen

Umschalt oder Strg halten

Ausgewähltes Element bei Mehrfachselektion abwählen

Strg+Mausklick

Auswahl: Reihenfolge ändern. Definiert Element, an dem sich alle anderen orientieren

Umschalt beim Auswählen halten

Verdeckte Objekte auswählen
  1. Alt drücken
  2. Objekt anklicken und bewegen

Alle Elemente eines Bildes auswähen.

Strg+A

Nächstes Element in Reihenfolge der Erstellung auswählen

Tab

Vorheriges Element in Reihenfolge der Erstellung auswählen

Umschalt+Tab

Positionieren

Befehl | Tastenkombination
Ausgewähltes Objekt verschieben. | Pfeiltasten
Um 10 Pixel je Druck auf Pfeiltaste verschieben | Umschalt+Pfeiltaste
Nur waagrecht oder nur senkrecht verschieben | Umschalt beim Verschieben halten
Zentriert ausgewähltes Objekt im Arbeitsausschnitt | H

Aktionen

Befehl | Tastenkombination
Speichert Änderungen | Strg+S
Fügt Element aus der Zwischenablage ein | Strg+V Umschalt+Einfg
Fügt Element aus der Zwischenablage an der Originalposition ein, Original und Kopie liegen deckungsgleich übereinander | Strg+Umschalt+V
Kopiert ausgewähltes Elemente | Strg+C Strg+Einfg
Kopieren statt verschieben | Strg beim Verschieben halten
Löscht ausgewähltes Element | Entf
Schneidet ausgewähltes Elementen aus | Umschalt+Entf Strg+X
Macht Änderungen rückgängig | Strg+Z Alt+Rück
Knoten im ausgewählten Element hinzufügen oder löschen. Hinzufügen: Mauszeiger wird zu Pluszeichen (+). Löschen: Mauszeiger wird zu Minuszeichen (-). Funktioniert bei Polylinie, Polygon und Rohrelement. | Strg+Umschalt
Zeichnen von Polylinien und Polygonen beenden | S
Zeichnen von Polylinien und Polygonen beenden und letzten gezeichneten Teilbereich löschen | Esc
Ausgewählte Elemente um eine Ebene höher stufen | +
Ausgewählte Elemente um eine Ebene tiefer stufen | -
Ausgewählte Elemente in den Vordergrund holen | Strg++
Ausgewählte Elemente in den Hintergrund setzen | Strg+-

Skalieren

Befehl

Tastenkombination

Größe ändern

Mauszeiger auf Anfasspunkt positionieren, so dass sich der Mauszeiger in Pfeile ändert. Danach kann mithilfe der Pfeiltasten pixelgenau bzw. bei gedrückter Umschalt Taste in Schritten von 10 Pixel positioniert werden.

Hinweis: Wurde für ein Element über die Eigenschaft Drehwinkel [°] ein Winkel ungleich 0 definiert, ist das Skalieren mittels Pfeiltasten nicht möglich.

Interne ID: Tastenkombinationen

Drehwinkel [°]

Frei definierbarer Winkel, um den das Element gedreht wird. Positive Werte drehen gegen den Uhrzeigersinn, negative Werte im Uhrzeigersinn. Werte über 360° werden als Differenz zu 360° dargestellt (400° entspricht 40°). Es können nur ganze Zahlen eingetragen werden.

Bei gedrehten Elementen sind folgende Aktionen nicht mehr möglich:
- spiegeln
- rotieren um +/- 90°
- skalieren per Pfeiltasten

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Objekt um den Mittelpunkt skalieren

Alt beim Skalieren halten.

Proportional skalieren

Umschalt beim Skalieren halten.


Taste einem Kontrollelement zuweisen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Grafische Aktionen -> Taste einem Kontrollelement zuweisen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bedienbare Elemente in einem Bild können mit einer Tastenkombination verknüpft und zur Runtime so bedient werden. Das gilt zum Beispiel für:

  • Ausführen von Kontrollelementen und zugewiesenen Funktion wie drucken, Bild bewegen usw.
  • Sollwert Absetzen (z. B. bei Schalter)
  • Fokus setzen bei bestimmten Fenstern (z.B. Kurvenliste im Erweiteren Trend oder Comboboxen im RGM)

Zur Runtime kann das die Steuerungsfunktion des Elements mit der Tastatur ausgeführt werden.

Um eine Taste einem Kontrollelement zuzuweisen:

  1. markieren Sie das Kontrollelement
  2. navigieren Sie zur Eigenschaft Tastenkombination (Objekteigenschaften -> Runtime -> Tastaturbedienung)

    Interne ID: Taste einem Kontrollelement zuweisen

    Tastaturbedienung

    Eigenschaften für die Online-Bedienung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Taste einem Kontrollelement zuweisen

    Runtime

    Eigenschaften für das Runtime-Verhalten des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Taste einem Kontrollelement zuweisen

    Tastenkombination

    Tastenkombinationen unterstützen das Ausführen bedienbarer Bildelemente. Zum Beispiel:

    - Ausführen von Kontrollelementen und Funktionen, die einem Element zugewiesenen wurden
    - Sollwert Absetzen (z. B. bei Schalter)
    - Fokus setzen bei bestimmten Fenstern (z.B. Kurvenliste im Erweiteren Trend oder Comboboxen im RGM)

    Klick auf Eingabefeld öffnet Dialog zur Definition der Tastenkombination. Im Dialog wird die gewünschte Kombination direkt eingegeben.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. klicken Sie auf die Schaltfläche ... oder in das Eingabefeld
  4. der Dialog zur Festlegung der Tastenkombination wird geöffnet

Parameter | Beschreibung
Tastenkombination | Eingabe der Tastenkombination. Klicken Sie in das Feld und drücken Sie auf der Tastatur die gewünschte Taste oder Tastenkombination, z.B.: A. Die Tastenkombination wird im Eingabefeld angezeigt.
X | Löscht die Zeichenfolge im Eingabefeld.
OK | Übernimmt Tastenkombination und schließt Dialog.
Abbrechen | Verwirft Eingabe/Änderung und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.


Verknüpfungen von Variablen und Funktionen ersetzen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Verknüpfungen von Variablen und Funktionen ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollen mehrere Variablen oder Funktionen gleichzeitig ersetzt werden, nutzen Sie am besten das automatisierte Ersetzen für:

  • Verknüpfungen ersetzen im Editor-Bild
  • Verknüpfungen ersetzen bei Bildumschaltung
  • Indizes ersetzen
  • Verknüpfte Symbole

Wie Sie automatisiertes Ersetzen für die Projektierung einsetzen, lesen Sie auch im Handbuch Effizient projektieren mit zenon im Abschnitt Elemente wiederverwenden.

Noch in diesem Kapitel

Namenskonventionen

Verknüpfungen ersetzen im Editor-Bild

Verknüpfungen ersetzen bei Bildumschaltung

Indizes ersetzen

Beispiel Variable regelbasiert ersetzen


Namenskonventionen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Verknüpfungen von Variablen und Funktionen ersetzen -> Namenskonventionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Variablen und andere Elemente sicher ersetzen zu können, sollte die Benennung systematisch und möglichst normiert erfolgen. Damit unterstützen Sie nicht nur die Wiederverwendbarkeit, sondern auch Wartung und Reverese Engineering.

Verschiedene Systeme unterstützen Sie bei der systematischen Benennung.

Zum Beispiel: Energiewirtschaft

Deutschland

  • KKS (Kraftwerk-Kennzeichen-System), Details siehe http://de.wikipedia.org/wiki/Kraftwerk-Kennzeichensystem
  • DIN 6779 (Kennzeichnungssystematik für technische Produkte und technische Produktdokumentation), Details siehe http://de.wikipedia.org/wiki/DIN_6779
  • AKZ (Anlagenkennzeichnungssystem), Details siehe http://de.wikipedia.org/wiki/Anlagenkennzeichnungssystem

International

  • KKS (Power Plant Classification System), Details siehe http://en.wikipedia.org/wiki/KKS_Power_Plant_Classification_System

Solche Normen existieren für alle Branchen. Es empfiehlt sich, deren Namenskonventionen zu benutzen.

Beispiel KKS:

In einem Energieprojekt sollten Variablen gemäß dem KKS benannt werden. Eine entsprechend benannte Variable mit der Bezeichnung C01_MDY10-QA001_QA07 sagt aus:

  • Windenergieanlage C01 (Reihe C, Nr. 1)
  • Windturbinensteuerung MDY10, Leistungsteil QA001,
  • Leistungsschutz QA07


Verknüpfungen ersetzen im Editor-Bild

Handbuch -> Bilder -> Bildelemente bearbeiten -> Verknüpfungen von Variablen und Funktionen ersetzen -> Verknüpfungen ersetzen im Editor-Bild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verknüpfte Variablen oder Funktionen können im Editor regelbasiert dauerhaft ersetzt werden. Die Ersetzung beschränkt sich nicht auf die in den Eigenschaften der Gruppe Variable / Funktion definierten Variablen oder Funktionen. Es können auch alle anderen im Bild verwendeten Variablen, wie etwa Variablen für Sichtbarkeit, Blinken, Größe und Drehen dynamisch und andere. Das regelbasierte Ersetzen funktioniert auch für mehrere Elemente in einem Bild gleichzeitig und für Elemente mit eingebetteten Symbolen.

Interne ID: Verknüpfungen ersetzen im Editor-Bild

Größe und Drehen dynamisch

Eigenschaften zur Dynamik des Elements.
Die Darstellung des Elements wird über Zustände von Variablen zur Laufzeit dynamisch angepasst.

Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfungen ersetzen im Editor-Bild

Blinken

Eigenschaften für das Blinken des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfungen ersetzen im Editor-Bild

Sichtbarkeit

Eigenschaften für die Sichtbarkeit des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfungen ersetzen im Editor-Bild

Variable / Funktion

Eigenschaften für die mit dem Element verknüpfte Variable oder Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um Variablen oder Funktionen regelbasiert direkt am Element zu ersetzen:

  1. markieren Sie die gewünschten Element und öffnen Sie mit Rechtsklick auf ein Element das Kontextmenü
  2. wählen Sie Verknüpfungen ersetzen
  3. der Dialog zum Ersetzen von Verknüpfungen öffnet sich

Eigenschaft | Beschreibung
Quelle | Eingabe des zu suchenden Teilstrings. Platzhalter * und ? können verwendet werden. Platzhalter sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.
Ziel | Eingabe des neuen Teilstrings.
Name | Tauscht Information im Variablennamen.
Kennung | Tauscht Information in der Kennung.
Groß-/ Kleinschreibung beachten | Achtet beim Tausch auf exakte Übereinstimmung der Groß-/und Kleinschreibung.
Übernehmen | Tausch gesuchte Strings der Quelle gegen die in Ziel definierten.
Variable/Funktion | Öffnet die Auswahlliste für Variablen/Funktionen bezogen auf die ausgewählte Zeile in der Liste. Klick auf Variable in der Liste definiert neue Zielvariable. Alternativ: Doppelklick auf die entsprechende Quellvariable.

Ersetzen

a) Ersetzen mit manueller Auswahl

  • wählen Sie aus der Liste das Element, das sie ersetzen, möchten als Quelle
  • wählen Sie über die Schaltfläche Variable/Funktion ein Zielelement
  • das bisherige Element wird durch das neue ersetzt

b) Automatisiert ersetzen mit Regeln

  • definieren Sie im Eingabefeld Quelle die Parameter für die Elemente, die sie ersetzen möchten
  • definieren Sie über das Eingabefeld Ziel die Parameter für die neuen Variablen/Funktionen
  • legen Sie über Name/Kennung fest, was getauscht werden soll
  • klicken Sie auf Übernehmen

Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Beispiel:

Quelle: A;b

Ziel: C;d

info Info

Die Zielvariable bzw. Zielfunktion kann sich auch in einem anderen Projekt als die Quellvariable bzw. Quellfunktion befinden.

attention Achtung

Achten Sie beim Ersetzen von Variablen auf den Typ und die Signalauflösung. Wenn Sie eine Variable durch eine im Typ nicht kompatible ersetzen, kann das zu Fehlern in der Ausführung führen. Sie werden beim Ersetzen gewarnt, die Ersetzung wird aber durchgeführt.

info Info

Ersetzen per Drag&Drop: Elemente, die nur eine Variable oder Funktion enthalten können, erlauben den Austausch per Drag&Drop. Ziehen Sie mit der Maus die neue Variable oder Funktion auf das Element. Es ersetzt automatisch das bisherige.


Verknüpfungen ersetzen bei Bildumschaltung

Handbuch -> Bilder -> Bildelemente bearbeiten -> Verknüpfungen von Variablen und Funktionen ersetzen -> Verknüpfungen ersetzen bei Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verknüpfte Variablen oder Funktionen in einem oder mehreren Elementen, aber auch Alias der ALC, können bei der Bildumschaltung ersetzt werden. Dabei werden die Elemente im Bild nicht dauerhaft ersetzt, sondern zur Runtime bei der Bildumschaltung verknüpft.

Um Verknüpfungen bei der Bildumschaltung zu ersetzen:

  1. projektieren Sie eine Funktion Bildumschaltung
  2. enthält das Bild ersetzbare Elemente, wird der Dialog zum Ersetzen geöffnet
  3. weisen Sie die Funktion einem Button zu, um zur Runtime die Bildumschaltung ausführen zu können

Eigenschaft | Beschreibung
Quelle | Eingabe des zu suchenden Teilstrings. Platzhalter * und ? können verwendet werden. Platzhalter sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.
Ziel | Eingabe des neuen Teilstrings.
Name | Tauscht Information im Variablennamen.
Kennung | Tauscht Information in der Kennung.
Groß-/ Kleinschreibung beachten | Achtet beim Tausch auf exakte Übereinstimmung der Groß-/und Kleinschreibung.
Übernehmen | Tausch gesuchte Strings der Quelle gegen die in Ziel definierten.
Variable/Funktion | Öffnet die Auswahlliste für Variablen/Funktionen bezogen auf die ausgewählte Zeile in der Liste. Klick auf Variable in der Liste definiert neue Zielvariable. Alternativ: Doppelklick auf die entsprechende Quellvariable.

Ersetzen

a) Ersetzen mit manueller Auswahl

  • wählen Sie aus der Liste das Element, das sie ersetzen, möchten als Quelle
  • wählen Sie über die Schaltfläche Variable/Funktion ein Zielelement
  • das bisherige Element wird durch das neue ersetzt

b) Automatisiert ersetzen mit Regeln

  • definieren Sie im Eingabefeld Quelle die Parameter für die Elemente, die sie ersetzen möchten
  • definieren Sie über das Eingabefeld Ziel die Parameter für die neuen Variablen/Funktionen
  • legen Sie über Name/Kennung fest, was getauscht werden soll
  • klicken Sie auf Übernehmen

Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Beispiel:

Quelle: A;b

Ziel: C;d

info Info

Die Zielvariable bzw. Zielfunktion kann sich auch in einem anderen Projekt als die Quellvariable bzw. Quellfunktion befinden.

attention Achtung

Achten Sie beim Ersetzen von Variablen auf den Typ und die Signalauflösung. Wenn Sie eine Variable durch eine im Typ nicht kompatible ersetzen, kann das zu Fehlern in der Ausführung führen. Sie werden beim Ersetzen gewarnt, die Ersetzung wird aber durchgeführt.

info Info

Ersetzen per Drag&Drop: Elemente, die nur eine Variable oder Funktion enthalten können, erlauben den Austausch per Drag&Drop. Ziehen Sie mit der Maus die neue Variable oder Funktion auf das Element. Es ersetzt automatisch das bisherige.

Verriegelungen ersetzen

In dem Dialog erscheinen neben den mit dem Bild direkt verknüpften Variablen, auch alle Variablen der in diesem Bild verwendeten Verriegelungen. Dazu gehört auch die Ergebnisvariable einer Verriegelung. Wurde eine Variable sowohl mit Elementen des Bildes und mit Verriegelungen des Bildes verknüpft, erscheinen sie im Dialog nur einmal.

In der Runtime werden die zu ersetzenden Variablen für alle Verriegelungen, die diese Variablen verwenden, ersetzt. Neben den normal mit der Verriegelung verknüpften Variablen, werden auch die mit der Verriegelung verknüpften Ergebnisvariablen für das Bild ersetzt.


Indizes ersetzen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Verknüpfungen von Variablen und Funktionen ersetzen -> Indizes ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Bildumschaltung zur Runtime können Variablen über Indizierungsregeln dynamisch (virtuell) ersetzt werden. Dabei können Variablenwerte als Teil der Ersetzungsregel verwendet werden.

attention Achtung

Da die Namen ersetzt werden, müssen Variablen und Funktionen immer unterschiedlich benannt werden. Bei Namensgleichheit würden jeweils Variablen und Funktionen ersetzt werden.

Beispiel:

Existieren eine Variable "test" und eine Funktion "test" und die Variable "test" soll ersetzt werden, würde gleichzeitig auch die Funktion "test" ersetzt.

Tipp: Benennen Sie Variablen und Funktionen jeweils mit einem Präfix (z.B var_ und func_). Damit haben Sie auch in Listen immer Überblick.

Um die Ersetzung von Indizes zu projektieren:

  1. Im Feld Quelle der Ersetzungsvorschau werden alle im Bild verwendeten Variablen und Funktionen angezeigt.
  2. Führen Sie einen Linksklick auf die Variable oder Funktion aus, für die Sie eine Indizierungsregel erstellen möchten.
  3. Die Variable/Funktion wird im Bereich Indizierungsregeln ins Feld Quelle und Ziel eingetragen.
    Alternativ können Sie die gewünschte Variable/Funktion auch direkt ins Feld Quelle bei Indizierungsregeln eintragen.
  4. Definieren Sie die Indizierungsregel.
    Der dynamische Teil der Regel wird in geschwungene Klammern eingefügt, z.B. {X01}.

    Beispiel:

    Die Quellvariable Motor1.drehzahl wird durch das Ziel Motor{X01}.drehzahl ersetzt.
    Der Platzhalter X01 wird während der Runtime durch den jeweiligen Wert der Index-Variable ersetzt.
    Die Ersetzungsregel würde somit lauten:

    Quelle: Motor1

    Ziel: Motor{X01}

  5. Übernehmen Sie diese mit einem Linksklick auf Regel hinzufügen in die Liste der Indizierungsregeln.
  6. In dieser Liste werden alle angelegten Indizierungsregeln angezeigt.
  7. Über die Schaltflächen mit dem Pfeilsymbol verändern Sie die Reihenfolge der Einträge.

    Achtung: Die Ersetzungen werden der Reihenfolge der Darstellung in der Liste abgearbeitet!

  8. Variablen, die nicht im Bild vorhanden sind, aber bei der Ersetzung verwendet werden, können über die Schaltfläche Variablen hinzufügen... ins Fenster Indizierungsvariablen eingefügt werden.
  9. Die in dieser Liste aufgeführten Variablen werden immer im Speicher gehalten, damit sich bei der Bildaufschaltung keine unnötigen Wartezeiten ergeben.

info Info

Für den Platzhalter * gelten dieselben Regeln wie bei Verknüpfungen ersetzen.

attention Achtung

Wenn Indexvariablen in einem Netzwerkprojekt verwendet werden, muss der Client zuerst den Wert vom Server holen. Dann wird die Berechnung ausgeführt. Auf Geräten mit keiner guten Hardware kann dies zu Verzögerungen der Bildumschaltung führen.
Indexvariablen sollten daher in einem Netzwerkprojekt immer auf DDE aktiv geschalten werden.

Projektübergreifend

Wenn sich das Ziel in einem anderen Projekt befindet als die Quelle, kann dies mithilfe von '#' angezeigt werden.

Example Beispiel

Quelle: VAR_1

Ziel: VAR_1 in Projekt_1

Somit geben Sie als Quelle VAR_1 und als Ziel Projekt_1#VAR_1 ein.

Quelle: UNTERPROJEKT1#VAR_1

Ziel: {X01}VAR_1

Die Indexvariable X01 ist eine Stringvariable ist und hat zur Runtime den Projektnamen inklusive # als Wert, z.B. "UNTERPROJEKT4#".


Beispiel Variable regelbasiert ersetzen

Handbuch -> Bilder -> Bildelemente bearbeiten -> Verknüpfungen von Variablen und Funktionen ersetzen -> Beispiel Variable regelbasiert ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es sollen alle Variablen mit "Tank1"im Namen durch Variablen mit "Tank4" ersetzt werden.

  1. Geben Sie in das Textfeld Quelle "Tank1" ein. Mit dem Zeichen* schließen Sie alle Variablen ein, die mit "Tank1" beginnen.
  2. Geben Sie im Textfeld Ziel "Tank4" ein.
  3. Klicken Sie auf Übernehmen.
  4. Die Variablen Tank1_max und Tank1_min werden durch die Variablen "Tank4_max und Tank4_min ersetzt.


Hintergrundgrafiken

Handbuch -> Bilder -> Bildelemente bearbeiten -> Hintergrundgrafiken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In jedem Bild kann im Hintergrund, eine Grafikdatei angezeigt werden. Diese Grafik ist in der hintersten Sichtbarkeitsebene positioniert und wird von allen anderen Elementen des Bildes überdeckt. Die Funktionalität ist analog zur Hintergrundgrafik des Windows Desktop zu sehen.

Zur Positionierung stehen Möglichkeiten wie zentriert oder gekachelt zur Verfügung. Ein freies verschieben ist nicht möglich.

Es können nur Grafikdateien verwendet werden, die bereits im Projekt im Bereich Dateien/Grafiken zur Verfügung stehen. Siehe bei: Dateien.

Tipp: Wenn Sie für mehrere Bilder die selbe Hintergundgrafik verwenden wollen, können Sie die Hintergrundgrafik bereits bei den Schablonen festlegen. Siehe bei: Hintergrundgrafiken bei Schablonen

Tipp: Alternativ kann auch ein Button mit einer Grafikdatei ohne verknüpfte Funktion zur Darstellung einer frei positionierbaren Grafikdatei verwendet werden


Funktionen Auswahldialog

Handbuch -> Bilder -> Bildelemente bearbeiten -> Funktionen Auswahldialog

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Auswahl von Funktionen wird ein gefilterter Dialog geöffnet:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Funktion gewählt werden soll.

Auswahlfenster

Auswahl der Funktion.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bereits verknüpfte Funktionen werden gelöscht

Tipp: Dieser Dialog ist in der Größe anpassbar. Die Dialoggröße und -position wird gespeichert.

Verknüpfte Funktion ändern

  1. manuell
    • öffnen Sie in der Detailansicht des Projektmanagers die Funktionen
    • ziehen Sie die gewünschte Funktion mit gedrückter linker Maustaste auf das Element
    • die bisherige Funktion wird durch die neue ersetzt
  2. automatisch
    • wählen Sie im Kontextmenü des Elements Verknüpfungen ersetzen. Details zur Vorgangsweise finden Sie im Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen.


Variablen Auswahldialog

Handbuch -> Bilder -> Bildelemente bearbeiten -> Variablen Auswahldialog

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Auswahl von Variablen wird ein gefilterter Dialog angeboten.

Tipp: Dieser Dialog ist in der Größe anpassbar. Die Dialoggröße und -position wird gespeichert.

Variablen können auch projektübergreifend genutzt werden.

Verknüpfung einer Variablen

Elemente, die nur mit einer einzelnen Variablen verknüpft werden können, öffnen folgenden Dialog:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Variable gewählt werden soll.

Auswahlfenster

Auswahl der Variablen, die verknüpft werden soll. Die Verknüpfung kann auf zwei Arten erfolgen:

  • Durch einen Doppelklick auf die gewünschte Variable: Dabei wird der Dialog automatisch geschlossen.
  • Durch Selektion der gewünschten Variable und durch anschließendes Klicken auf OK.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bereits verknüpfte Variablen werden gelöst (z.B. verknüpfte Chargenvariablen im Archivserver)

Hinweis: Wird die gewünschte Variable nicht angezeigt, kann dies mehrere Ursachen haben:

  • Sie haben einen Filter ausgewählt und die gewünschte Variable entspricht nicht diesem Filter: Überprüfen Sie ob in der Filterzeile ein Filter eingetragen ist. Die unter dem Auswahlfenster angebrachte Information über gefilterte Elemente hilft ebenfalls bei der Überpürfung von eingestellten Filtern.
  • Der Dialog wird vom Editor gefiltert aufgeschaltet und die Variable entspricht nicht diesem Filter. Das gefilterte Aufschalten erfolgt dann, wenn nur bestimmte Datentypen zulässig sind, z.b dürfen bei einem Dynamischen Element Zahlenwert keine String-Variablen verknüpft werden.
  • Sie haben das falsche Projekt im Projektbaum selektiert.

attention Achtung

Der Dialog lässt generell zwar die Auswahl mehrerer Variablen über die in Windows üblichen Tastenkombinationen zu, es kann aber in diesem Schritt nur eine verknüpft werden. Bei Mehrfachauswahl wird die als erste ausgewählte Variable dem Element zugewiesen.

Verknüpfung mehrerer Variablen

Elemente, die mit mehreren Variablen verknüpft werden können, öffnen folgenden Dialog:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Variable gewählt werden soll.

Auswahlfenster

Auswahl der Variablen durch:

  • Mit Doppelklick wird die selektierte Variable wird der Variablenliste hinzugefügt
  • Mit Drag&Drop kann die selektierte Variable in die Variablenliste gezogen werden
  • Die gewünschten Variablen selektieren. Mit Hilfe der Strg- bzw. der Umschalt-Taste ist eine Mehrfachselektion möglich. Mit Klick auf Hinzufügen werden die selektierten Variablen in die Variablenliste übernommen.

Variablenliste

Listet alle ausgewählten Variablen auf.

Hinzufügen

Fügt die aktuell im Auswahlfenster markierte Variable der Variablenliste hinzu.

Entfernen

Entfernt die in der Variablenliste markierte Variable aus der Liste.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bestimmte Verknüpfungen, wie Chargenvariablen in der Archivierung, können gelöst werden

Hinweis: Wird die gewünschte Variable nicht angezeigt, kann dies mehrere Ursachen haben:

  • Sie haben einen Filter ausgewählt und die gewünschte Variable entspricht nicht diesem Filter: Überprüfen Sie ob in der Filterzeile ein Filter eingetragen ist. Die unter dem Auswahlfenster angebrachte Information über gefilterte Elemente hilft ebenfalls bei der Überpürfung von eingestellten Filtern.
  • Der Dialog wird vom Editor gefiltert aufgeschaltet und die Variable entspricht nicht diesem Filter. Das gefilterte Aufschalten erfolgt dann, wenn nur bestimmte Datentypen zulässig sind, z.b dürfen bei einem Dynamischen Element Zahlenwert keine String-Variablen verknüpft werden.
  • Sie haben das falsche Projekt im Projektbaum selektiert.

Verknüpfte Variable ändern

Wählen Sie im Kontextmenü des Elements Verknüpfungen ersetzen. Details zur Vorgangsweise finden Sie im Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen.


Schablonen

Handbuch -> Bilder -> Schablonen

Schablonen bilden die Grundlage für das Layout der Fenster und der zur Laufzeit angezeigten Bilder. Sie strukturieren die Darstellung am Bildschirm und bestimmen die Position. Jedes Bild wird einer Schablone zugeordnet und in dem durch die Schablone definierten Bildschirmbereich angezeigt.

Schablonen bestimmen die allgemeinen Fenstereigenschaften wie Position, Größe, Aussehen und Manipulationsmöglichkeiten zur Laufzeit. Schablonen:

  • bieten Übersicht über alle in einem Projekt definierten Bildbereiche
  • können über die Eigenschaft Freie Schablonenform definieren frei gestaltet werden

    Interne ID: Schablonen

    Freie Schablonenform definieren

    Nur verfügbar, wenn Sie Freie Schablonenform aktiviert haben.

    Interne ID: Schablonen

    Freie Schablonenform

    Ermöglicht die Verwendung der freien Schablonenform für die selektierte Schablone. Dadurch ist es möglich Schablonen mit z.B. abgerundeten Ecken, Löchern usw. zu definieren.

    Aktiv: Die freie Schablonenform wird für diese Schablone und die damit verknüpften Bilder verwendet.

    Inaktiv: Freie Schablonenform steht nicht nur Verfügung. Eine bereits bestehende freie Schablonenform wird im Schablonen- und im Bildeditor nicht angezeigt.

    Default: inaktiv

    Hinweis: Steht nicht zur Verfügung für Schablone Alarmstatuszeile und nicht unter Windows CE.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definieren Sie die Form für die selektierte Schablone. Führen Sie einen Linksklick auf die Schaltfläche aus, um die entsprechende Schablone im Schablonenform-Editor zu öffnen. Dort können Sie mithilfe von Kreisen, Rechtecken, abgerundeten Rechtecken und Polygonen die Form der Schablone festlegen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ermöglichen das Zuweisen spezieller Funktionen auf alle in einer Schablone vorhandenen Bilder, z. B.:

    Bild zurück, Fokus auf Schablone setzen, Fokus von Schablone nehmen, Schablone schließen, Alarme blinkquittieren, Screenshot drucken

  • ändern alle Bilder, die auf dieser Schablone basieren
  • Bilder erscheinen zur Laufzeit immer in der gleichen Größe an der definierten Stelle und können nicht beliebig verschoben werden
  • Schablonen können bei Fokusverlust zur Runtime automatisch geschlossen werden
  • Bilder innerhalb einer Schablone können im Onlinebetrieb beliebig ausgetauscht werden

info Info

Existiert bei der Erstellung eines Bildes noch keine Schablone , dann erstellt zenon automatisch eine Default-Schablone, die den ganzen Bildschirm umfasst.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Schablone neu | Legt eine neue Schablone an.
Schabloneneditor öffnen | Öffnet den Schabloneneditor im Hauptfenster und zeigt in der Detailansicht die Liste der Schablonen an.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei. Hinweis: Beim XML-Import über den Knoten Schablonen werden vorhandene Schablonen überschrieben. In diesem Fall werden alle Bilder und deren Elemente an die neue Schablone angepasst.
Hilfe | Öffnet die Online-Hilfe.

Schablonen erstellen

Um eine Schablone zu erstellen:

  1. wählen Sie im Projektmanager im Knoten Bilder den Unterpunkt Schablonen
  2. wählen Sie im Kontextmenü Neue Schablone anlegen
  3. eine neue Schablone wird erstellt
    Die Anfangsgröße wird durch die Größe des Displays bestimmt und kann in der Monitorverwaltung festgelegt werden (Projekteigenschaften ‑> Grafische Ausprägung ‑> Monitorverwaltung)

    Interne ID: Schablonen

    Monitorverwaltung

    Der Konfigurationsdialog für die Monitorverwaltung wird geöffnet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Schablonen

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. klicken Sie in die neue Schablone und ziehen sie die Schablone über die Anfasspunkte in die gewünschte Größe
  5. positionieren sie die Schablone an der gewünschten Stelle im Fenster
  6. definieren Sie im Eigenschaften-Fenster die gewünschten Eigenschaften

attention Achtung

Schablonen im Globalprojekt und im Unterprojekt müssen unterschiedlich benannt werden.

Example Beispiel

Im gesamten Projekt sollen drei Bereiche vorhanden sein:

  • Am oberen Bildschirmrand eine Kopfzeile mit Uhrzeit und Logo.
    Für diesen Bereich wird eine Schablone "Kopfzeile" definiert. Diese legt Größe und Position der Kopfzeile fest.
  • Am unteren Bildschirmrand eine Menüzeile.
    Eine Schablone "Menüzeile" wird angelegt.
  • Dazwischen Anlagenbilder.
    Eine Schablone "Schaubild" wird angelegt.

Die Schablonen werden immer an der definierten Stelle in der definierten Größe angezeigt. Alle in der Folge gezeichneten Bilder werden einer dieser Schablonen fest zugeordnet und zur Laufzeit darin aufgeschaltet. Soll die Bildschirmaufteilung geändert werden, weil z. B. die Menüzeile oben angezeigt werden soll und die Kopfzeile als Fußzeile, muss nur die Position der Schablonen geändert werden. Die in den Schablonen enthaltenen Bilder wandern automatisch mit.

Noch in diesem Kapitel

Schablone Detailansicht Symbolleiste und Kontextmenü

Schabloneneditor

Hintergrundgrafiken bei Schablonen festlegen

Verteiltes Engineering bei Schablonen

Hauptschablonen

Effekte für Schablonen


Schablone Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Bilder -> Schablonen -> Schablone Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Menüpunkt | Aktion
Schablone neu | Fügt eine neue Schablone zur Liste hinzu und setzt den Fokus auf diesen Eintrag.
Schabloneneditor öffnen | Öffnet den Schabloneneditor im Hauptfenster.
Freie Schablonenform definieren | Wechselt ins Hauptfenster zur Definition einer freien Schablonenform.
Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien. Hinweis: Beim XML-Import über den Knoten Schablonen werden vorhandene Schablonen überschrieben. In diesem Fall werden alle Bilder und deren Elemente an die neue Schablone angepasst.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Hilfe | Öffnet die Online-Hilfe.


Schabloneneditor

Handbuch -> Bilder -> Schablonen -> Schabloneneditor

Im Schablonen Editor definieren und positionieren Sie alle Schablonen.

attention Achtung

Im Schabloneneditor können Arbeitsschritte nicht rückgängig gemacht werden. Der Menüpunkt Rückgängig (Strg+Z) steht nicht zur Verfügung.

Noch in diesem Kapitel

Öffnen des Schabloneneditors

Schablonen im Schabloneneditor anzeigen

Neue Schablone erstellen

Positionierung zur Runtime

Löschen von Schablonen


Öffnen des Schabloneneditors

Handbuch -> Bilder -> Schablonen -> Schabloneneditor -> Öffnen des Schabloneneditors

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Schabloneneditor zu öffnen:

  • klicken Sie im Projektmanager in der Detailansicht für Schablonen doppelt auf die gewünschte Schablone

    oder

  • wählen Sie Projektmanager -> Schablonen -> Kontextmenü -> Schabloneneditor öffnen

Die im Schabloneneditor dargestellte Größe hängt von der in der Monitorverwaltung eingestellten Bildschirmgröße ab. (Siehe Kapitel Monitor Verwaltung.) Wird die Monitoreinstellung im Nachhinein geändert, muss der Schabloneneditor neu geöffnet werden, damit er die neue Monitoreinstellung berücksichtigt.

Die rote Schablone für die Alarmstatuszeile wird von zenon für jedes Projekt automatisch an oberen Bildrand angelegt. Ihre Position kann über die Eigenschaften in der Gruppe Position verändert werden. Dazu muss die Eigenschaft Standardposition verwenden deaktiviert werden.

Interne ID: Öffnen des Schabloneneditors

Standardposition verwenden

aktiv: Positioniert die Schablone für die Alarmstatuszeile am oberen Bildschirmrand.

Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Öffnen des Schabloneneditors

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Schablonen im Schabloneneditor anzeigen

Handbuch -> Bilder -> Schablonen -> Schabloneneditor -> Schablonen im Schabloneneditor anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schablonen können im Schabloneneditor sichtbar oder unsichtbar geschaltet werden per:

  • Eigenschaft Anzeige im Schabloneneditor:
    aktiviert: zeigt Schablone an

    Interne ID: Schablonen im Schabloneneditor anzeigen

    Anzeige im Schabloneneditor

    Aktiv: Die ausgewählte Schablone wird im Schabloneneditor angezeigt.
    Inaktiv: Die Schablone wird im Schabloneneditor nicht angezeigt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Drag&Drop:
    unsichtbar: Schablone aus dem Hauptfenster ziehen
    sichtbar: Schablone aus der Detailansicht ins Hauptfenster ziehen
  • Detailansicht -> Ansicht im Schabloneneditor:
    unsichtbar: Checkbox deaktivieren
    sichtbar: Checkbox aktivieren

Informationen über Name und Position der Schablone erhalten Sie in der linken oberen Ecke der Schablone und per Tooltip, wenn Sie den Mauszeiger über die Schablone bewegen.

info Info

Ein Systemmenü oder eine Alarmstatuszeile werden im Schabloneneditor automatisch berücksichtigt und immer im Vordergrund dargestellt. Eine falsch positionierte Schablone kann damit zur Runtime keine wichtigen Informationen verdecken.


Neue Schablone erstellen

Handbuch -> Bilder -> Schablonen -> Schabloneneditor -> Neue Schablone erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine neue Schablone zu erstellen haben Sie zwei Möglichkeiten:

  • eine neue Schablone anlegen:
    Projektmanager -> Schablonen -> Kontextmenü -> Neue Schablone anlegen oder Detailansicht Schablonen -> Kontextmenü -> Schablone neu

    Damit wird eine neue Standardschablone in der in den Monitoreigenschaften definierten Größe angelegt.

  • eine neue Schablone aufziehen: Hauptfenster-> Kontextmenü -> Neue Schablone aufziehen

    Der Mauszeiger wird zu einem schwarzen Quadrat mit einem Kreuz in der linken oberen Ecke als Startpunkt. Damit ziehen Sie eine Schablone an der gewünschten Position in der von Ihnen definierten Größe auf.

Positionieren von Schablonen

Position und Ausrichtung einer Schablone oder einer Gruppe ausgewählter Schablonen kann im Hauptfenster über das Kontextmenü Anordnen ausgewählt werden.

Anordnen mit Fangpunkten

Wenn die Einstellung Fangpunkte verwenden aktiviert wurde, (siehe Kapitel Editor, Abschnitt Einstellungen), haften die Anfasspunkte der Schablone an denen anderer Schablonen an. Zusätzlich können Schablonen an dem Bildschirmrand und an der eventuell sichtbaren Alarmzeile (wenn diese im Projekt aktiviert wurde) anhaften.

Noch in diesem Kapitel

Schablone mit freier Schablonenform


Schablone mit freier Schablonenform

Handbuch -> Bilder -> Schablonen -> Schabloneneditor -> Neue Schablone erstellen -> Schablone mit freier Schablonenform

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können die Schablonenform mithilfe der Eigenschaft Freie Schablonenform Ihren individuellen Wünschen anpassen. Nachdem Sie diese Eigenschaft aktiviert haben, gelangen Sie auf eine der folgenden Arten in den Schablonenform-Editor:

Interne ID: Schablone mit freier Schablonenform

Freie Schablonenform

Ermöglicht die Verwendung der freien Schablonenform für die selektierte Schablone. Dadurch ist es möglich Schablonen mit z.B. abgerundeten Ecken, Löchern usw. zu definieren.

Aktiv: Die freie Schablonenform wird für diese Schablone und die damit verknüpften Bilder verwendet.

Inaktiv: Freie Schablonenform steht nicht nur Verfügung. Eine bereits bestehende freie Schablonenform wird im Schablonen- und im Bildeditor nicht angezeigt.

Default: inaktiv

Hinweis: Steht nicht zur Verfügung für Schablone Alarmstatuszeile und nicht unter Windows CE.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Klicken Sie auf die Schaltfläche der Eigenschaft Freie Schablonenform definieren

    Interne ID: Schablone mit freier Schablonenform

    Freie Schablonenform definieren

    Nur verfügbar, wenn Sie Freie Schablonenform aktiviert haben.

    Definieren Sie die Form für die selektierte Schablone. Führen Sie einen Linksklick auf die Schaltfläche aus, um die entsprechende Schablone im Schablonenform-Editor zu öffnen. Dort können Sie mithilfe von Kreisen, Rechtecken, abgerundeten Rechtecken und Polygonen die Form der Schablone festlegen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Klicken Sie auf das entsprechende Symbol in der Symbolleiste der Schablonen
  • Selektieren Sie den Menüeintrag Freie Schablonenform definieren im Kontextmenü bei der Schablonenauswahl
  • Selektieren Sie den Menüeintrag Freie Schablonenform definieren im Kontextmenü im Schabloneneditor
  • Führen Sie einen Doppelklick auf eine Schablone im Schabloneneditor aus

Hier können Sie mit den Elementen Rechteck, Kreis, abgerundetes Rechteck und Polygone die Schablone nach Ihren Wünschen erstellen.

info Info

Freie Schablonenform steht nicht zur Verfügung:

  • für Schablone Alarmstatuszeile
  • unter Windows CE

Wird die Eigenschaft Freie Schablonenform definieren deaktiviert, wird eine bereits bestehende freie Schablonenform weder im Schabloneneditor noch im Bildeditor angezeigt.

Mithilfe der Eigenschaft Flächenverwendung, entscheiden Sie, wie das jeweilige Element das Aussehen der Schablone beeinflusst. Dazu stehen Ihnen folgende Einstellungen zur Verfügung:

Interne ID: Schablone mit freier Schablonenform

Flächenverwendung

Legen Sie fest, welche Auswirkung das erstellte Element auf die Schablone haben soll.

Folgende Einstellungen stehen zur Verfügung:

Abdecken: Die Fläche des Elements wird als Bildbereich verwendet

Ausschneiden: Die Fläche des Elements wird von den darunterliegenden Flächen entfernt

Verodert: Je nachdem, ob sich unter dem Element eine abdeckende Fläche befindet oder nicht, wird wird entweder ausgeschnitten oder abgedeckt

Hinweis: Die Flächenverwendung bezieht sich immer auf die unter dem Element liegende Fläche.

Für neu angelegte Elemente wird immer die zuletzt selektierte Einstellung verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter | Beschreibung
Abdecken | Die Fläche des Elements wird als Bildbereich verwendet.
Ausschneiden | Die Fläche des Elements wird von den darunterliegenden Flächen entfernt. So können Sie z.B. "Löcher" in der Schablone erzeugen.
Verodert | Je nachdem, ob sich unter dem Element eine abdeckende Fläche befindet oder nicht, wird entweder ausgeschnitten oder abgedeckt.

info Info

Die Flächenverwendung bezieht sich immer auf die unter dem Element liegenden Flächen. Wenn Sie z.B. ein abdeckendes Element über ein ausschneidendes Element zeichnen, wird die Fläche ausgefüllt angezeigt. Wenn Sie die Reihenfolge umkehren, wird von dem abdeckenden Element das ausschneidende Element abgezogen.


Positionierung zur Runtime

Handbuch -> Bilder -> Schablonen -> Schabloneneditor -> Positionierung zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schablonen können zur Runtime an festen oder relativ definierten Positionen aufgeschaltet werden. So lassen sich zum Beispiel Keyboard-Bilder oder Popup-Bilder genau dort positionieren, wo sich der Mauszeiger bzw. das aufschaltende Element befinden. Schablone können zur Runtime aufgeschaltet werden:

  • an einer absoluten Position
  • relativ zur Mausposition
  • relativ zum Element

Absolute und relative Position werden in den Eigenschaften definiert.

Position beim Neuaufschalten beibehalten

Fenster beziehen ihre Bildschirmposition immer aus der Schablone. Werden Popup-Bilder projektiert und während der Laufzeit verschoben, wird bei der nächsten Ausführung der Bildumschaltungsfunktion das Popup-Bild wieder an die projektierte Position verschoben. Mithilfe der Eigenschaft Position beim Neuaufschalten beibehalten kann festgelegt werden, dass die Schablone ihre Position beibehält, solange sie geöffnet ist, unabhängig von Bildumschaltungen. Ist die Eigenschaft aktiv:

Interne ID: Positionierung zur Runtime

Position beim Neuaufschalten beibehalten

Aktiv: Eine Schablone, die zur Runtime manuell verschoben wurde, wird beim Aufschalten eines neues Bildes nicht auf die projektierte Position zurückgesetzt, wenn sie bereits am selben Client geöffnet ist.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Wird ein Bild in der Runtime in einer manuell verschobenen Schablone geöffnet, bleibt deren Position auch bei einer erneuten Bildumschaltung erhalten.
  • Wird ein anderes Bild in der gleichen Schablone geöffnet, bleibt deren Position erhalten. Das gilt auch für den substituierten Aufruf.

Damit kann auf jedem Client eine andere Position für eine Schablone verwendet werden, da immer die lokale Position gespeichert wird.

Absolute Positionierung

Die Schablone wird immer an den fest definierten Koordinaten aufgeschaltet. Bei allen Bildaufschaltungen, die automatisch durch das System erfolgen, wie z.B. durch die Zeitsteuerung oder eine Grenzwertverletzung, wird immer die absolute Bildschirmposition verwendet.

Relative Positionierung

Die relative Positionierung eignet sich besonders für die Aufschaltung von Popups, Tastaturbildern oder Befehlsgabe-Bildern. Sie ist bei allen Bildumschaltungen, Sollwertvorgaben mit frei definierten Keyboardbildern und allen Befehlsgabe-Bildern, die vom Benutzer manuell angestoßen werden, möglich. Dabei ist es unerheblich, ob die Aktion über eine Bildumschaltungsfunktion, Sollwertsetzen-Funktion oder direkt über ein Element angestoßen wird. Relative Positionierung steht Ihnen zur Verfügung bei:

  • dynamischen Elementen, denen man eine Funktion zuweisen kann
  • dynamischen Elementen, über die ein Sollwert abgesetzt werden kann (Button, Combi-Element)
  • Haupt- und Kontextmenüs
  • der bildtypspezifischen Funktion „Funktion ausführen" im Bild Alarmmeldeliste

Die relative Positionierung funktioniert auch in verschachtelten Funktionsaufrufen, also wenn Bildumschalten oder Sollwert setzen über ein Skript angestoßen werden. Falls das Bild bei relativer Positionierung über den Bildschirmrand ragen würde, wird es automatisch bündig am Monitorrand positioniert. Das gilt auch bei Mehrmonitorverwaltung, so dass es nicht in den benachbarten Monitor ragen kann.

Relativ zum Element

Positioniert den Bezugspunkt der Schablone relativ zu dem Element, von dem aus die Bildumschaltung angestoßen wurde (z.B. ein Button oder ein Combi-Element). Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet.

Legen Sie erst einen Bezugspunkt für Ihre Schablone fest und dann die bevorzugte Position am Element. Folgende Einstellungen stehen zur Verfügung:

Eigenschaft | Wert
Bezugspunkt Element vertikal | unten
 | oben
Bezugspunkt Element horizontal | links
 | rechts
Verschiebung vertikal in Pixel | Geben Sie die gewünschte Verschiebung ein
Verschiebung horizontal in Pixel | Geben Sie die gewünschte Verschiebung ein

Alternative Position

Legen Sie hier eine alternative Position für den Bezugspunkt der Schablone und den Bezugspunkt am Element an. Gehen Sie bei der Festlegung der alternativen Position genau so vor wie bei der Festlegung der bevorzugten Position. Die alternative Position wird verwendet, wenn die Schablone an der bevorzugten Position nicht aufgeschaltet werden kann.

Relativ zum Mauszeiger

Das Bild wird abhängig von der Position des Mauszeigers dargestellt. Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet. Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Legen Sie den Bezugspunkt der Schablone über die beiden Eigenschaften Bezugspunkt Schablone vertikal und Bezugspunkt Schablone horizontal fest. Der Bezugspunkt wird auf der Schablone mit einem roten Punkt gekennzeichnet. Folgende Einstellungen stehen Ihnen zur Verfügung:

Eigenschaft | Wert
Bezugspunkt Schablone vertikal | oben
 | unten
 | zentriert
Bezugspunkt Schablone horizontal | links
 | rechts
 | zentriert

Example Beispiel

Sie haben einen Button am rechten Bildschirmrand und positionieren ein Popup- Fenster deshalb rechts daneben:

  • Bezugspunkt Element: Rechts/zentriert
  • Bezugspunkt Schablone: Links/zentriert

Zur Runtime wird dann rechts neben dem Button genau in der Mitte zentriert das Popup-Bild aufgeschaltet. Das Popup-Bild wird den Button nicht verdecken.

Sie verwenden dieselbe Schablone auch für einen Button am linken Bildschirmrand. Das Popup-Bild könnte rechts nicht mehr vollständig aufgeschaltet werden. Es wird daher die projektierte Alternativposition verwendet. Dafür setzen Sie den

  • alternativen Bezugspunkt für das Element auf: Links/zentriert
  • den alternativen Bezugspunkt der Schablone auf Rechts/zentriert


Löschen von Schablonen

Handbuch -> Bilder -> Schablonen -> Schabloneneditor -> Löschen von Schablonen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Schablonen zu löschen können Sie:

eine oder mehrere Schablonen mit der Maus markieren und im Kontexmenü löschen wählen oder die Taste Entfdrücken

eine oder mehrere Schablonen in der Detailansicht markieren und im Kontextmenü löschen wählen oder die Taste Entfb drücken

Vor dem Löschen erfolgt eine Sicherheitsabfrage.

attention Achtung

Das Löschen von Schablonen kann nicht rückgängig gemacht werden.


Hintergrundgrafiken bei Schablonen festlegen

Handbuch -> Bilder -> Schablonen -> Hintergrundgrafiken bei Schablonen festlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In jedem Bild kann im Hintergrund, eine Grafikdatei angezeigt werden. Diese Grafik ist in der hintersten Sichtbarkeitsebene positioniert und wird von allen anderen Elementen des Bildes überdeckt. Die Positionierung erfolgt über die Eigenschaften, freies Verschieben ist nicht möglich. Es können nur Grafikdateien verwendet werden, die bereits im Projektmanager im Bereich Dateien/Grafiken zur Verfügung stehen.

Sollen mehrere Bilder die gleiche Hintergrundgrafik benutzen, wird diese mit der Schablone des Bildes definiert:

  1. klicken Sie in den Eigenschaften der Schablone im Knoten Hintergrundgrafik in die Eigenschaft Grafikdatei

    Interne ID: Hintergrundgrafiken bei Schablonen festlegen

    Grafikdatei

    Auswahl der Hintergrundgrafik als Vorlage für alle auf dieser Schablone neu definierten Bilder.
    Hinweis: Eine Änderung der Grafikdatei wirkt sich nicht auf bereits existierende Bilder aus, die auf dieser Schablone basieren.

    Mehr im Online Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Hintergrundgrafiken bei Schablonen festlegen

    Hintergrundgrafik

    In jedem Bild kann eine Grafikdatei als Hintergrund angezeigt werden. Hintergrundgrafiken für Schablonen werden automatisch allen neuen Bildern zugewiesen, die auf dieser Schablone basieren. Bereits existierende Bilder müssen nachträglich manuell angepasst werden.

    Mehr im Online Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. wählen Sie eine Datei aus dem Knoten Dateien/Grafiken im Projektmanager
  3. legen Sie mit der Eigenschaft Ausrichtung die Position fest

    Interne ID: Hintergrundgrafiken bei Schablonen festlegen

    Ausrichtung

    Nur verfügbar, nachdem eine Grafikdatei ausgewählt wurde:

    Mögliche Darstellungsarten:
    gekachelt: Originalgröße, in Kacheln nebeneinander.

    gestreckt: formatfüllend, auf Bildgröße gestreckt.

    normal: Originalgröße, in der linken oberen Ecke positioniert.
    zentriert: Originalgröße, zentriert in der Bildmitte zentriert.

    Default: normal.

    Freies Verschieben ist nicht möglich

    Hinweis: Eine Änderung der Ausrichtung wirkt sich nicht auf die Bilder aus, die auf der Schablone basieren.

    Mehr im Online Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Grafikdatei wird dann bei allen Bildern, die mit dieser Schablone neu angelegt werden, verwendet. Es kann aber weiterhin für jedes Bild eine individuelle Grafikdatei als Hintergrundbild festgelegt werden.

Achtung! Die Grafikdatei wird mit den Bildern gespeichert. Eine Änderung der Grafikdatei oder deren Ausrichtung bei der Schablone wirkt sich nur für neue Bilder aus. Für bestehende Bilder muss diese Änderung manuell nachgezogen werden.


Verteiltes Engineering bei Schablonen

Handbuch -> Bilder -> Schablonen -> Verteiltes Engineering bei Schablonen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Mehrbenutzer-Betrieb sind alle üblichen Mechanismen zum Bearbeiten und Übernehmen von Bearbeitungen implementiert. Allerdings wird im Schabloneneditor im Gegensatz zu den Bildern jede Schablone für sich behandelt und nicht das ganze Bild zur Änderung freigegeben. Schablonen, an denen keine Änderungen zugelassen wurden, sind zur besseren Übersicht mit gepunktetem Rand gekennzeichnet.


Hauptschablonen

Handbuch -> Bilder -> Schablonen -> Hauptschablonen

Über die Variable Zuletzt geöffnetes Bild können im Systemtreiber Schablonen angezeigt werden, die zuletzt geöffnet waren. Welche Schablonen in die Anzeige aufgenommen werden, wird mit der Eigenschaft Hauptschablonen im Projektmanager (Grafische Ausprägung, Runtime allgemein) definiert. Klick auf ... öffnet den Dialog zur Auswahl der Schablonen:

Interne ID: Hauptschablonen

Runtime allgemein

Enthält Einstellungen zur Runtime.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Hauptschablonen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Hauptschablonen

Hauptschablonen

Namen der Schablonen, die in der Variable Zuletzt geöffnetes Bild des Systemtreibers angeführt werden. Klick auf ... öffnet den Dialog für die Schablonenauswahl.

Hinweis: Diese Eigenschaft wirkt sich auch auf die Funktion Bild zurück aus.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehrere Einträge können per Taste Strg + Mausklick oder Umschalt + Mausklick ausgewählt werden. Klick auf OK bestätigt die Auswahl.

info Info

Diese Eigenschaft wirkt sich auch auf die Funktion Bild zurück aus.


Effekte für Schablonen

Handbuch -> Bilder -> Schablonen -> Effekte für Schablonen

Schablonen können auch mit Effekten ausgestattet werden.

Weitere Effekte für Bildelemente finden Sie im Kapitel Effekte für Bildelemente.

Noch in diesem Kapitel

Schablone hervorheben


Schablone hervorheben

Handbuch -> Bilder -> Schablonen -> Effekte für Schablonen -> Schablone hervorheben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Schablone hervorheben kann ein Bild hervorgehoben werden, um zum Beispiel die Aufmerksamkeit auf ein bestimmtes Bild zu lenken. Dazu wird die Schablone, auf der das Bild basiert hervorgehoben, indem der restliche Bereich der Runtime eingefärbt wird. Dazu werden für die Umgebung der Schablone des Bildes eine Farbe und eine Transparenz definiert, die das darunter liegende Bild überdecken. Das darunter liegende Bild kann nicht bedient werden.

Hinweis: Die Bilder müssen auf unterschiedlichen Schablonen unterschiedlicher Größe basieren. Es darf immer nur ein Bild mit dieser Eigenschaft gleichzeitig aufgeschaltet werden.

Um den Effekt zu nutzen, konfigurieren Sie das Bild, das über einem anderen, größeren aufgeschaltet wird:

  1. Navigieren Sie in den Bildeigenschaften zur Gruppe Fensterstil.

    Interne ID: Schablone hervorheben

    Fensterstil

    Eigenschaften für die äußere Erscheinung des Bildes.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Aktivieren Sie die Eigenschaft Modaler Dialog.

    Interne ID: Schablone hervorheben

    Modaler Dialog

    Aktiv: Solange das Bild in der Runtime geöffnet ist, können Elemente in einem anderen Bild nicht bedient werden (z.B für den Bildtyp “Login”). Bedient werden können allerdings Bilder, die aus dem modalen Bild heraus geöffnet wurden.
    Inaktiv: Andere Bilder können wie gewohnt bedient werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Aktivieren Sie die Eigenschaft Schablone hervorheben.

    Interne ID: Schablone hervorheben

    Schablone hervorheben

    Nur verfügbar, wenn die Eigenschaft Modaler Dialog aktiviert wurde.

    Aktiv: Die Schablone, auf der das Bild beruht, wird hervorgehoben. Dabei wird der gesamte Bereich außerhalb der Schablone mit einer eingestellten Farbe und Transparenz eingefärbt. Der Bereich der hervorgehobenen Schablone bleibt von der Einfärbung unberührt. Es darf immer nur ein Bild mit dieser Eigenschaft gleichzeitig aufgeschaltet werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. Konfigurieren Sie mit der Eigenschaft Umgebungsfarbe die Farbe, mit der die Umgebung des aktiven Bildes eingefärbt werden soll.
    Diese Eigenschaft wirkt sich immer auf die Schablone, auf der das Bild beruht, aus.

    Interne ID: Schablone hervorheben

    Umgebungsfarbe

    Nur verfügbar, wenn die Eigenschaft Schablone hervorheben aktiviert wurde.

    Bestimmt die Umgebungsfarbe der Schablone, auf der das Bild beruht. Klick auf Schaltfläche ... öffnet Auswahldialog für Farbe.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Konfigurieren Sie mit der Eigenschaft Umgebungstransparenz die Transparenz für die Eigenschaft Umgebungsfarbe.

    Interne ID: Schablone hervorheben

    Umgebungstransparenz

    Nur verfügbar, wenn die Eigenschaft Schablone hervorheben aktiviert wurde.

    Bestimmt die Transparenz der Umgebungsfarbe der Schablone, auf der das Bild beruht. Klick auf Schaltfläche ... öffnet Schieberegler für Definition der Transparenz.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  6. Projektieren Sie für das Bild einen Button, um es zur Runtime schließen zu können.

Sobald Sie dieses Bild über einem anderen aufschalten, wird der Bereich rund um die Schablone des Bildes eingefärbt und das Bild damit optisch hervorgehoben. Es ist nur dieses Bild bedienbar. Nach dem Schließen des Bildes, werden andere Bilder wieder in normaler Farbe und bedienbar angezeigt.

Beispiel

Bild wird aufgeschaltet:

Zweites Bild mit aktiviertem Effekt Schablone hervorheben wird dazugeschaltet. Alles außerhalb der Schablone des zugeschalteten Bildes wird mit der in Eigenschaft Umgebungsfarbe definierten Farbe und in Eigenschaft Umgebungstransparenz definierten Transparenz abgedeckt:


Farbpaletten

Handbuch -> Bilder -> Farbpaletten

Farbpaletten ermöglichen es, individuelle Farben in Farbpaletten zusammenzufassen. Sie können sich so ein Set von Farben definieren, dass sich bei Bedarf bequem sowohl im Editor als auch in der Runtime umschalten lässt. Alle Farben, die mit Hilfe der Palettenfarben definiert worden sind, lassen sich damit einfach austauschen.

Die Einheitliche Gestaltung von Company Designs (CD) lässt sich so sehr einfach erledigen. bei Bedarf kann das Design komplett (Palette wechseln) oder auch nur einzelne Farben (Farbe in Palette ändern) zentral geändert werden.

Der zenon Ansatz: Änderungen zentral oder gar Global mit Hilfe eines Globalprojekts lassen sich damit mühelos umsetzen.

Projektierung

Diese Paletten werden im Editor erstellt, können exportiert und importiert werden und lassen sich zur Runtime über eine Funktion umschalten. Farbpaletten lassen sich sowohl im Globalprojekt als auch im lokalen Projekt anlegen. Alle Paletten eines Projektes enthalten immer gleich viele Farben, die Anzahl der Farben kann also zwischen Globalprojekt und lokalem Projekt differieren.

Achtung: Bei Konflikten zur Runtime haben die Farbpaletten des lokalen Projektes Vorrang.

Die Farben der Farbpaletten können überall verwendet werden, wo Farben genutzt werden.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Farbpalette neu | Legt eine neue Farbpalette mit dem Standardnamen Color palette plus fortlaufender Indexnummer an.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Farbpaletten Symbolleiste und Kontextmenü Detailansicht

Farbpaletten anlegen und bearbeiten

Farben anlegen und bearbeiten

Farbpaletten im Editor verwenden

Runtime-Dateien erzeugen

Funktion Farbpalette umschalten

Export und Import

Fehlermeldungen

Beispiel für Editor und Runtime


Farbpaletten Symbolleiste und Kontextmenü Detailansicht

Handbuch -> Bilder -> Farbpaletten -> Farbpaletten Symbolleiste und Kontextmenü Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste und Kontextmenü

Nr | Symbol | Aktion
01 | Farbpalette neu | Legt eine neue Farbpalette mit dem Standardnamen Color palette plus fortlaufender Indexnummer an.
02 | Standard Funktion erzeugen | Öffnet den Dialog zur Erstellung einer Funktion zur Palettenumschaltung und aktiviert in der Dropdownliste automatisch die ausgewählte Palette.
03 | Farbpalette löschen | Löscht die Palette der markierten Farbe. Paletten können nur einzeln gelöscht werden.
04 | Farbe neu | Legt eine neue Farbe mit der Standardfarbe weiß und dem Standardnamen Color plus Indexnummer an. Neue Farben werden immer für alle Paletten des Projektes angelegt. Tipp: Vergeben Sie für Globalprojekt und lokales Projekt eindeutig unterscheidbare Namen.
05 | Farbe löschen | Löscht die ausgewählte Farbe in allen Paletten des Projektes. Hinweis: Der Befehl ist nur aktiv, wenn in allen Paletten die jeweils letzte Farbe markiert ist. Denn: Es kann immer nur die letzte Farbe einer Palette gelöscht werden, damit die Indexnummern weiter funktionieren. Weiters muss die Farbe für alle Paletten gelöscht werden, damit die Anzahl der Farben in allen Paletten ident bleibt.
06 | Kopieren | Kopiert ausgewählte Farben oder Farbpaletten in Zwischenablage.
07 | Einfügen | Fügt ausgewählte Farben oder Farbpaletten aus der Zwischenablage ein.
08 | Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
09 | Farbpalette im Editor | Öffnet eine Dropdownliste mit allen Paletten, die im lokalen Projekt und im Globalprojekt definiert wurden.
10 | Speichern | Speichert alle Änderungen in den Farbpaletten.
11 | Selektierte XML exportieren ... | Exportiert ausgewählte Paletten in eine XML-Datei.
12 | XML importieren... | Importiert Einträge aus einer XML-Datei.
13 | Eigenschaften | Öffnet das Eigenschaftenfenster.
14 | Hilfe | Öffnet die Online-Hilfe.


Farbpaletten anlegen und bearbeiten

Handbuch -> Bilder -> Farbpaletten -> Farbpaletten anlegen und bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können Farbpaletten global oder im lokalen Projekt anlegen. Globale Farbpaletten stehen in allen Projekten zur Verfügung, lokale nur in dem Projekt, in dem sie erstellt werden. Kommt es beim Absetzen zur Runtime zu Konflikten, werden die Farbpaletten des lokalen Projektes bevorzugt (siehe auch Farbpaletten zur Runtime).

Farbpalette anlegen

Um eine Farbpalette anzulegen:

  • wählen Sie den Knoten Farbpaletten (entweder unterhalb Bilder im lokalen Projekt oder im Globalprojekt)
  • wählen Sie im Kontextmenü den Befehl Farbpalette neu
  • eine neue Palette wird angelegt mit:
    • Standardname Color palette plus Indexnummer (z.B. Color palette 0)
    • gleicher Anzahl von Farben wie die bereits existierenden Paletten, alle Farben sind standardmäßig weiß

Farbpalette umbenennen

Um eine Palette individuell zu benennen:

  • selektieren Sie die Palette oder eine oder mehrere Farben der Palette
  • wählen Sie in den Eigenschaften in der Gruppe Farbpalette die Eigenschaft Palettenname

    Interne ID: Farbpaletten anlegen und bearbeiten

    Palettenname

    Name der Farbpalette.

    Default: Color palette plus Indexnummer, z. B.: Color palette 1

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Farbpaletten anlegen und bearbeiten

    Farbpalette

    Enthält die Eigenschaften der Farbpalette.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • tragen die den gewünschten Palettennamen ein
    Tipp: Achten Sie auf eindeutige Namen, die Globalprojekt und lokales Projekt klar unterscheiden

Farbpalette löschen

Um eine Palette zu löschen:

  • markieren Sie die komplette Spalte der Palette
  • wählen Sie im Kontextmenü den Befehl Farbpalette löschen oder drücken Sie Entf
  • die Palette wird ohne Sicherheitsabfrage gelöscht.
    Hinweis: Paletten können nur einzeln gelöscht werden


Farben anlegen und bearbeiten

Handbuch -> Bilder -> Farbpaletten -> Farben anlegen und bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Farbe anlegen

Um eine Farbe anzulegen:

  • selektieren Sie eine Farbe oder eine Palette
  • wählen Sie im Kontextmenü Farbe neu oder drücken Sie die Taste Einfg
  • am unteren Ende der Farbtabelle wird für alle Paletten eine neue Farbe eingefügt mit
    • Standardfarbe weiß und
    • Standardname Color plus Indexnummer, z.B. Color 10
  • definieren Sie die Farbe und vergeben Sie einen Namen

Farbe umbenennen

Um eine Farbe umzubenennen:

  • selektieren Sie die Farbe
  • wählen Sie in den Eigenschaften in der Gruppe Farbe die Eigenschaft Bezeichnung

    Interne ID: Farben anlegen und bearbeiten

    Bezeichnung

    Name der Farbe.

    Default: Color plus Indexnummer, z. B.: Color 1

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Farben anlegen und bearbeiten

    Farbe

    Enthält alle Eigenschaften der Farben für Farbpaletten.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • tragen Sie den gewünschten Namen ein
    Tipp: Unterscheiden Sie schon bei der Namensgebung zwischen Globalprojekt und lokalem Projekt, um später bei der Auswahl von Farbpaletten immer zu wissen, woher die Palette kommt

Farbe definieren

Um eine Farbe zu definieren:

  • markieren Sie die gewünschte Farbe in der Palette
  • geben Sie die Farbe ein:
    • entweder direkt in die Tabellenzelle der Detailansicht als Hexadezimalcode oder über den Auswahldialog per Klick auf ...
    • oder in den Eigenschaften in der Gruppe Farbe im Feld der Eigenschaft Farbe als Hexadezimalcode oder über den Auswahldialog per Klick auf ...

      Interne ID: Farben anlegen und bearbeiten

      Farbe

      Ermöglicht Auswahl oder Definition der Farbe. Klick auf ... öffnet eine Farbpalette zur Auswahl einer Farbe. Die Farbe kann auch als Hexadezimalcode direkt in das Feld eingegeben werden.

      Default: weiß (#FFFFFF)

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Farbe über Dialog definieren

Um vordefinierte Grundfarben aus einem Dialog zu wählen oder eigene Farben zu kreieren:

  • klicken Sie in der Detailansicht in der Zelle mit der gewünschten Farbe oder in den Eigenschaften bei Farbe auf ...
  • der Dialog zur Auswahl der Standardfarben öffnet sich

  • klicken Sie auf eine Standardfarbe, um sie zuzuweisen
  • um eigene Farben zu definieren, klicken Sie auf die Schaltfläche Farben definieren

  • definieren Sie die Farbe
  • fügen Sie sie über die Schaltfläche Farbe hinzufügen zu Benutzerdefinierten Farben hinzu
  • selektieren Sie die gewünschte Farbe
  • weisen Sie die Farbe per Klick auf OK zu

Farbe kopieren

Um mehreren Farben die gleiche Farbdefinition zuzuweisen:

  • markieren Sie im Eingabefeld der Farbe den Hexadezimalcode der gewünschten Farbe
  • kopieren Sie den Hexadezimalcode mit Strg+C oder dem Befehl Kopieren im Kontextmenü
  • fügen Sie den Hexadezimalcode bei allen Farben, die die gleiche Farbdefinition erhalten sollen, ein mit Strg+V oder dem Befehl Einfügen im Kontextmenü

Farbe löschen

Farben aus Paletten werden über ihren Index in den Paletten (= Zeilennummer im Palettenfenster) eindeutig bestimmt. Daher können Farben nur am Ende der Paletten gelöscht werden, weil sich sonst die Indizes nachfolgender Farben verändern würden. Da alle Paletten im Projekt gleich viele Farben haben müssen, können immer nur komplette Zeilen gelöscht werden. Um eine Farbe aus allen Paletten zu löschen:

  • markieren Sie die zu löschenden Zeilen, beginnend mit dem unteren Tabellenende der Palettenfarben
  • wählen Sie im Kontextmenü Farbe löschen oder drücken Sie die Taste Entf


Farbpaletten im Editor verwenden

Handbuch -> Bilder -> Farbpaletten -> Farbpaletten im Editor verwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auswahl der aktiven Palette im Editor

Im Editor kann eine Palette aus dem lokalen oder globalen Projekt als aktive Palette zur Darstellung und Farbauswahl verwendet werden.

Um eine Palette für die Darstellung im Editor zu wählen:

  • klicken Sie mit der rechten Maustaste in die Tabelle der Farbpaletten
  • wählen Sie im Kontextmenü Farbpalette im Editor
  • wählen Sie aus der sich öffnenden Dropdownliste die gewünschte Palette

Hinweis: Paletten aus dem lokalen Projekt werden vor Paletten aus dem Globalprojekt gereiht.

Achtung: Existieren im globalen und lokalen Projekt Paletten mit gleichen Namen, werden nur die Paletten aus dem lokalen Projekt zur Auswahl angeboten.

attention Achtung

Sind im globalen und lokalen Projekt nicht gleich viele Farben pro Palette projektiert, stehen bei der Auswahl aus der aktiven Palette eventuell weniger Farben zur Verfügung!

Palettendefinitionen aus dem lokalen Projekt haben immer Vorrang: Sind im lokalen Projekt Paletten mit mindestens einer Farbe projektiert, wird die Anzahl der Farben des lokalen Projekts zur Auswahl angeboten, sonst die Anzahl der Farben im Globalprojekt.

Fehlende Farben in der aktiven Palette werden weiß dargestellt.

Auswahl der Palettenfarben

Farben aus Paletten werden im Editor zugewiesen über:

  • Dialog in den Eigenschaften
  • Drag&Drop der Bezeichnung einer Farbe in das entsprechende Feld in den Eigenschaften
  • Direkte Eingabe der Bezeichnung einer Farbe in das entsprechende Feld in den Eigenschaften

Wird einem Element über die Eigenschaften eine Farbe zugewiesen, öffnet sich der Farbdialog mit zwei Registerkarten:

  • Farben: Auswahl einer bestimmten Farbe
  • Farbpaletten: Auswahl einer Palettenfarbe aus der aktiven Farbpalette

Sind weder im lokalen noch im globalen Projekt Paletten mit mindestens einer Farbe projektiert, oder lässt die Eigenschaft keine Farbauswahl aus Paletten zu, wird nur die Registerkarte Farben angezeigt.

Farben bei Mehrplatzfähigen Projekten

Änderungen an Farbpaletten können nur für alle Paletten eines Projektes gemeinsam ermöglicht, übernommen oder verworfen werden.


Runtime-Dateien erzeugen

Handbuch -> Bilder -> Farbpaletten -> Runtime-Dateien erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erzeugen der Runtime-Dateien werden die Paletten des Globalprojekts und des lokalen Projekts in eine gemeinsame Liste übertragen. Dabei kann es zu Konflikten kommen. Beachten Sie:

  • Das lokale Projekt hat immer Vorrang.
  • Jede Palette bildet die Vereinigungsmenge ab, enthält also so viele Farben wie die größte Palette.
  • Enthalten die Paletten des Globalprojekts und lokalen Projekts unterschiedlich viele Farben, werden die kürzeren Paletten mit weiß aufgefüllt, damit alle Paletten gleich viele Farben enthalten und in jeder Palette für jeden Farbindex eine Farbe verfügbar ist. Bei gleichnamigen Paletten, werden die fehlenden Farben der längeren Palette übernommen

Beispiel:

  • Im Globalprojekt existieren 3 Paletten: Global 1, Global 2 und Palette 1 mit je 10 Farben.
  • Im lokalen Projekt existieren 2 Paletten: Palette 1 und Palette 2 mit je 5 Farben.
  • In der Runtime existieren dann:
    • Palette 1: kommt aus lokalem Projekt und überschreibt Palette 1 aus Globalprojekt; sie enthält die 5 Farben aus dem lokalen Projekt plus den Farben 6 - 10 aus Palette 1 vom Globalprojekt
    • Palette 2: enthält die 5 Farben aus lokalem Projekt plus Farben 6 - 10 als weiß initialisiert
    • Global 1: enthält die 10 Farben aus dem Globalprojekt
    • Global 2: enthält die 10 Farben aus dem Globalprojekt

Farbpalette zur Runtime umschalten

Um Farben zur Runtime umzuschalten benötigen Sie die Funktion Farbpalette umschalten (siehe Kapitel Funktion Farbpalette umschalten).

Interne ID: Runtime-Dateien erzeugen

Farbpalette umschalten

Erstellt eine Funktion, um zur Runtime zwischen Farbpaletten umzuschalten.

Mehr im Online-Handbuch.

Ein Beispiel für die Umschaltung zur Runtime finden Sie im Kapitel Beispiel für Editor und Runtime.


Funktion Farbpalette umschalten

Handbuch -> Bilder -> Farbpaletten -> Funktion Farbpalette umschalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Start der Runtime wird automatisch die erste Palette im Projekt aktiv, solange nicht über ein Startscript eine andere Palette aktiviert wurde.

Die aktive Palette kann zur Runtime durch Aufruf der Funktion Farbpalette umschalten geändert werden. Alle Bilder und Elemente werden dann mit den Farben der neuen Palette neu gezeichnet.

Interne ID: Funktion Farbpalette umschalten

Farbpalette umschalten

Erstellt eine Funktion, um zur Runtime zwischen Farbpaletten umzuschalten.

Mehr im Online-Handbuch.

Die jeweils aktive Palette wird über den Namen der Palette bestimmt. Existiert keine Palette mit dem angegebenen Namen, wird die erste Palette im Projekt aktiviert.

Um die Funktion Farbpalette umschalten anzulegen:

  • wählen Sie im Projektmanager im Kontextmenü des Knotens Funktionen den Befehl Funktion neu...
  • navigieren Sie zu Anwendungen
  • wählen Sie Farbpalette umschalten aus

  • bestätigen Sie mit OK
  • Der Dialog zur Wahl der Farbpalette wird geöffnet

Parameter | Beschreibung
Farbpalette | Wählen Sie aus der Dropdownliste die gewünschte Farbpalette aus.
Diesen Dialog zur Runtime anbieten | Ermöglicht es, zur Runtime die Farbpalette neu auszuwählen.


Export und Import

Handbuch -> Bilder -> Farbpaletten -> Export und Import

Farbpaletten können in XML-Dateien exportiert und aus diesen importiert werden.

Export

Um eine Palette zu exportieren:

  • selektieren Sie die gewünschte Palette
    um mehrere Paletten auszuwählen, benutzen Sie die Tasten Strg oder Umschalt oder ziehen Sie die Maus mit gedrückter linker Maustaste über die Titelzeile der Tabelle
    (Hinweis: selektierte Paletten können nicht mehr einzeln abgewählt werden)
  • es können nur komplett selektierte Paletten, aber keinen einzelnen Farben exportiert werden
  • wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl Selektierte XML exportieren...
  • wählen Sie im sich öffnenden Dateimanager einen Speicherort und einen Namen für die XML-Datei

Import

Um eine Palette zu importieren:

  • wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl XML importieren...
  • wählen Sie im sich öffnenden Dateimanager die gewünschte Importdatei
  • die in der XML-Datei gespeicherten Paletten werden importiert
  • Achtung: Die Reihenfolge beim Exportieren wird berücksichtigt.
    Wurde also z.B. eine Palette an dritter Stelle in der Tabelle exportiert, wird sie wieder an der gleichen Stelle importiert, bzw. am Ende angehängt, wenn das Projekt weniger Paletten enthält. An dieser Stelle bereits vorhandene Paletten werden überschrieben. Das bedeutet:
    • Befinden sich Paletten an der Stelle, an die importiert wird, werden Namen und Farben der existierenden Paletten von den importierten Paletten überschrieben.
    • Wird eine Palette an eine freie Stelle importiert, wird sie am Ende der Reihe eingefügt und mit dem fortlaufenden Standardnamen benannt.
    • Weist die importierte Palette mehr Farben auf als die vorhandenen, werden bei den vorhandenen Paletten die fehlenden Farben durch weiß ergänzt.
    • Weist die importierte Palette weniger Farben auf als die vorhandenen, werden die fehlenden Farben von der überschriebenen Palette übernommen oder durch weiß ergänzt, wenn keine Palette überschrieben wurde.


Fehlermeldungen

Handbuch -> Bilder -> Farbpaletten -> Fehlermeldungen

Bei Übernahme von Elementen, zum Beispiel über XML-Import oder Copy & Paste, können eventuell Palettenfarben nicht mehr richtig dargestellt werden. Mögliche Ursachen:

  • es wurden im Projekt noch keine Farbpaletten angelegt
  • Paletten haben unterschiedliche Anzahl von Farben
  • Farben wurden gelöscht

Im Eingabefeld der Eigenschaften werden dann entsprechende Fehlertexte angezeigt, das Element wird weiß dargestellt.

Fehlermeldung | Ursache
Keine Palette geladen! | Im lokalen und globalen Projekt wurden keine Paletten projektiert.
Palettenfarbe nicht vorhanden! | In den Paletten des Projekts gibt es keine Farbe mit dem passenden Index.


Beispiel für Editor und Runtime

Handbuch -> Bilder -> Farbpaletten -> Beispiel für Editor und Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Editor

So verwenden Sie zum Beispiel Farbpaletten im Editor:

  • legen Sie ein Bild mit einem Button mit Text und grafischem Element an
  • wählen Sie in den Eigenschaften Füllfarbe

    Interne ID: Beispiel für Editor und Runtime

    Füllfarbe

    Nur verfügbar, wenn die Eigenschaft Transparent auf inaktiv geschaltet wurde.

    Interne ID: Beispiel für Editor und Runtime

    Transparent

    Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

    Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert die Füllfarbe des Elements. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Die Füllfarbe kann dynamisch geändert werden über die Eigenschaft Füllfarbe aus der Gruppe Farben dynamisch .

    Interne ID: Beispiel für Editor und Runtime

    Farben dynamisch

    Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Beispiel für Editor und Runtime

    Füllfarbe

    Name der Variable, deren Grenzwertfarben die Hintergrund-/Füllfarbe des Elements beeinflussen sollen.
    Öffnet den Variablenauswahldialog.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Hinweis: Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

    Achtung: Im Weltbild Übersichtsfenster haben Farbänderungen im Editor keine Auswirkung zur Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • klicken Sie auf ...
  • Der Dialog zur Farbwahl öffnet sich
  • wählen Sie die Registerkarte Farbpalette
  • die Farben der aktiven Farbpalette werden angezeigt
  • wählen Sie die gewünschte Farbe
  • wiederholen Sie diese Schritte für die Eigenschaften Rahmenfarbe und Textfarbe

    Interne ID: Beispiel für Editor und Runtime

    Textfarbe

    Textfarbe des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Beispiel für Editor und Runtime

    Rahmenfarbe

    Definiert die Rahmenfarbe des Elements. Die Farbe kann direkt als Hexadezimalwert eingegeben oder nach Klick auf die Schaltfläche ... gewählt werden. Bei Auswahl von Automatisch ändert sich der Farbwert abhängig vom Wert der Füllfarbe.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Bild mit Farbpalette Basic

  • klicken Sie in der Tabelle der Farbpaletten mit der rechten Maustaste in eine Zelle
  • wählen Sie im Kontextmenü Farbpalette im Editor
  • wählen Sie in der Dropdownliste eine andere Palette, zum Beispiel Palette 2
  • Bild im Editor:

In der Runtime

Zur Runtime wird das Bild mit der im Editor aktivierten Farbpalette angezeigt.

Wenn Sie eine Umschalt-Funktion projektiert haben (siehe Kapitel Funktion Farbpalette umschalten), können Sie zur Runtime die Palettenfarbe ändern.

Dazu:

  • klicken Sie auf das Element
  • wurde die Option Diesen Dialog zur Runtime anbieten aktiviert, kann zur Runtime eine neue Palette ausgesucht werden, sonst wird automatisch die in der Funktion vorgegebene Palette aufgeschaltet

  • das Element wird auf die neuen Farben umgeschaltet


Schriften

Handbuch -> Bilder -> Schriften

In zenon können alle Schriften benutzt werden, die im Betriebssystem vorhanden sind. Der Knoten Schriften befindet sich im Projektmanager unterhalb des Knotens Bilder.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Schriftliste neu | Legt eine neue Schriftliste in der Detailansicht an
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

info Info

Die gewählte Schrift muss auch auf dem Zielsystem mit der Runtime vorhanden sein. Fehlt die Schrift am Zielystem, wird automatisch eine andere, am System vorhandene Schriftart aus der gleiche Familie verwendet.

Noch in diesem Kapitel

Schriftlisten

Defaultschrift und Systemschrift

Benennung und Nummerierung von Schriften und Schriftlisten

Verbinden von Schriften mit Elementen

ClearType


Schriftlisten

Handbuch -> Bilder -> Schriften -> Schriftlisten

Per Default ist eine Schriftliste angelegt. Diese wird in der Detailansicht angezeigt, wenn der Knoten Bilder / Schriften im Projektmanager ausgewählt wurde.

Symbolleiste und Kontextmenü

Parameter | Beschreibung
Schrift neu | Legt eine neue Schrift an. Die Windows-Dialogbox 'Schriftart' wird geöffnet und die Einstellungen bzgl. Schriftart, Schnitt, Grad etc. können getroffen werden. Siehe Abschnitt Neue Schrift anlegen.
Schrift löschen | Entfernt die ausgewählte Schrift wieder aus der Schriftliste.
Schriftliste neu | Legt eine neue Schriftliste an (selbe Funktionalität wie bei Auswahl im Projektmanager). Siehe Abschnitt Neue Schriftliste anlegen.
Schriftliste löschen | Löscht die ausgewählte Schriftliste.
Speichern | Speichert die Änderungen.
Schriftliste im Editor | Zeigt alle bestehenden Schriftlisten an, die jeweils aktive ist angehakt.
XML Export selektierte | Ein Import und Export von Schriften und Schriftlisten ist möglich. Siehe Kapitel Import/Export Abschnitt Bilder/Schriften.

In den Eigenschaften der Schriftliste kann der Liste ein beliebiger Name zugeordnet werden.

attention Achtung

Nachträgliche Namensänderungen werden nicht automatisch übernommen. Wenn Sie den Namen einer Schriftliste nachträglich ändern und bereits eine Funktion Sprachumschaltung mit dieser Schriftliste angelegt haben, müssen Sie auch in dieser Funktion den Namen der Schriftliste ändern.

Schriftlisten: Globalprojekt versus Projekt

Der Editor hat immer eine Schriftliste aktiv geschaltet. Um Schriften aus dem Standardprojekt und dem Globalprojekt zu nutzen, müssen die Schriftlisten in diesen beiden Projekten gleich benannt werden.

Beachten Sie bei der Verwendung von Schriftlisten in Globalprojekten:

  • Werden Schriftlisten in einem Globalprojekt und einem Standard-Projekt gleich benannt, wird zur Runtime die Schriftliste des Standard-Projekts priorisiert.
  • Bei unterschiedlichen Namen sind im Standard-Projekt zwei Schriftlisten vorhanden, zur Runtime wird eine beliebige von beiden verwendet.

Um diesen Effekt zu vermeiden: Projektieren Sie eine Sprachumschaltfunktion mit Auswahl der Schriftliste.

Noch in diesem Kapitel

Neue Schriftliste anlegen


Neue Schriftliste anlegen

Handbuch -> Bilder -> Schriften -> Schriftlisten -> Neue Schriftliste anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Elemente mit anderen Schriftarten zu verknüpfen als in Schriftliste 1, ist es erforderlich, eine weitere Schriftliste anzulegen.

Weitere Schriftlisten anlegen:

Im Projektmanager im Knoten Bilder / Schriften kann im Kontextmenü mit dem Eintrag Schriftliste neu eine neue Schriftliste angelegt werden. Die neue Schriftliste wird in der Detailansicht des Projektmanagers angezeigt.

Auch hier wird die Defaultschrift automatisch an erster Stelle angelegt.

Aktivieren einer Schriftliste:

Um eine Schriftliste zu aktivieren, klicken Sie in die Titelleiste der gewünschten Schriftliste und wählen Sie im Kontextmenü den Eintrag Schriftliste im Editor. Dies kann im Zusammenhang mit sprachumschaltbaren Texten notwendig sein. So kann bereits im Editor festgestellt werden, wie das Element mit der Schrift in der Runtime aussehen wird. (z.B. ob die Schrift für den Button zu groß ist).Siehe dazu Kapitel: Sprachumschaltung / Fonts - Schriftarten

info Info

Für die Runtime existiert keine Default-Schriftliste. Werden mehrere Schriftlisten projektiert, muss die in der Runtime zu verwendende Schriftliste über die Sprachumschaltung festgelegt werden.


Defaultschrift und Systemschrift

Handbuch -> Bilder -> Schriften -> Defaultschrift und Systemschrift

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jedes neu angelegte Element wird mit einer Defaultschrift verknüpft. Das ist die Schrift, die dem Elementtyp zugeordnet ist. Eine Änderung der Eigenschaft Schrift eines Elementes, hat zur Folge, dass jedes neue auf diesen Elementtyp basierende Element mit der geänderten Schrift verknüpft wird. Beim Neustart des Editors wird wieder die Defaultschrift für alle Elementtypen verwendet. Die Defaultschrift hat die Eigenschaft Arial 10, unterstützt Antialiasing und befindet sich in der Schriftliste an der 2. Position.

Beim neu Erstellen eines Projektes werden folgende Schriften automatisch erstellt:

Schriftart | Schriftschnitt | Schriftgrad | Info
Arial | Standard | 8 |
Arial | Standard | 10 | Defaultschrift
Arial | Standard | 12 |
Arial | Standard | 14 |
Arial | Standard | 20 |
  • Die Defaultschrift ist anpassbar. Eine Änderung wird automatisch überall dort übernommen, wo diese Schriftart verknüpft worden ist.
  • Die Systemschrift ist nicht skalierbar, daher kann es beim Zoomen bzw. bei der automatischen Auflösungsanpassung zu Problemen kommen.
  • Die Defaultschrift kann über die Eigenschaft Schriftart geändert werden. Der Dialog entspricht dem, der dann geöffnet wird, wenn im Kontextmenü Schrift neu ausgewählt wird.

Noch in diesem Kapitel

Neue Schrift anlegen


Neue Schrift anlegen

Handbuch -> Bilder -> Schriften -> Defaultschrift und Systemschrift -> Neue Schrift anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Per Default ist eine Schriftliste angelegt, die in der Detailansicht des Projektmanagers angezeigt und mit unterschiedlichen Schriften befüllt werden kann.

Neue Schrift in der Schriftliste anlegen:

Klicken Sie in das Fenster der Detailansicht und öffnen Sie mit einem Rechtsklick das Kontextmenü. Hier wählen Sie den Eintrag 'Schrift neu'

Der Windows Dialog Schriftart wird geöffnet. Hier können folgende Einstellungen getroffen werden:

Parameter | Beschreibung
Schriftart | Sämtliche Schriften des Betriebssystems sind alphabethisch sortiert
Schriftschnitt | Fett, Kursiv etc
Schriftgrad | Schriftgröße in Pixels
Effekte | Unterstrichen, Durchgestrichen
Farbe | Auswahl der Schriftfarbe
Skript | Westlich, Kyrillisch etc.

info Info

Die Farbeinstellungen werden nicht übernommen. Texte werden in schwarz dargestellt, es sei denn die Farbe wird explizit in den Eigenschaften angepasst. Ansonsten kommt es lediglich während der Runtime (z.B. aufgrund einer Grenzwertverletzung) zu einer farblichen Veränderung von Texten.

Zu Schriften in einem Globalprojekt siehe Kapitel: Projektverwaltung / Global Projekt

attention Achtung

Alle verwendeten Schriften müssen auf allen Rechnerne, auf denenen das Projekt gestartet wird installiert sein.
Die Installation kann auch mit dem Remote Transport erfolgen. Siehe Dateien festlegen (Kopieren&Registrieren)


Benennung und Nummerierung von Schriften und Schriftlisten

Handbuch -> Bilder -> Schriften -> Benennung und Nummerierung von Schriften und Schriftlisten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Erstellung eines zenon Projekts werden automatisch 5 Default-Schriften erstellt. Die Namen der Schriftliste und der Default-Schrift hängen von der Sprache ab, in der der Editor gestartet wird. Das gilt für Standardprojekte und Globalprojekte.

Die Schriften erhalten Nummern. Nummer 1 und 2 sind Standard-Schriften. Diesen beiden Nummern können nicht geändert werden, alle anderen Nummern können individuell angepasst werden. Bei der Erstellung eines Dynamischen Elements wird diesem automatisch die Schrift mit der Nummer 2 zugewiesen.

Der Editor hat immer eine Schriftliste aktiv geschaltet. Um Schriften aus dem Standardprojekt und dem Globalprojekt zu nutzen, müssen die Schriftlisten in diesen beiden Projekten gleich benannt werden.

Hinweis: zenon Projekt, die von der Version 5.50 in eine höhere konvertiert werden, haben keine Default Schriftliste, falls das Projekt in 5.50 keine Schriften enthält.

Global und lokal

Schriften aus dem lokalen Standardprojekt haben höhere Priorität als Schriften aus dem Globalprojekt.
Zum Beispiel: Im Globalprojekt existiert eine Schrift mit der Nummer 50. Diese Schrift kann in jedem Standardprojekt im Arbeitsbereich verwendet werden, solange das Standardprojekt keine Schrift mit der Nummer 50 enthält. Gibt es im Standardprojekt ebenfalls eine Nummer 50, wird diese Schrift verwendet.

Im Standardprojekt können die Schriften mit den Nummern 1 und 2 nicht gelöscht werden. Das bedeutet: Im Globalprojekt können zwar die Schriften mit den Nummern 1 und 2 geändert werden. Sie können aber nicht im Standardprojekt verwendet werden, da diese beiden Nummern im Standardprojekt immer vorhanden sind und höher priorisiert werden. Um Schriften aus Globalprojekt und Standardprojekt zu unterscheiden, kann ein Offset benutzt werden. Zum Beispiel kann die Schrift 2 aus dem Standardprojekt im Globalprojekt zur Schrift 2002 werden.

Workaround um die Schriften 1 und 2 aus dem Globalprojekt im Standardprojekt zu verwenden: Schriftliste im Standardprojekt löschen und eine neue leere Schriftliste wie die Schriftliste im Globalprojekt benennen.

Schriftliste löschen

Wenn Schriften mit den Nummern 1 und 2 aus dem Globalprojekt im Standardprojekt genutzt werden sollen, muss die Schriftliste im Standardprojekt gelöscht werden. Dazu:

  1. erstellen Sie eine Projektsicherung
  2. falls angepasste Schriften aus einem Standardprojekt global verwendet werden sollen:
    1. führen Sie einen XML-Export der Schriftliste aus dem Standardprojekt aus
    2. führen Sie einen XML-Import der Schriftliste ins Globalprojekt aus
  3. öffnen Sie den SQL-Ordner für das Standardprojekt

    Tipp: Projekt in zenon markieren -> Ctrl+Alt+E drücken -> der Explorer öffnet den Projektordner -> navigieren Sie weiter zu zenon/system

  4. schließen Sie den Arbeitsplatz
  5. löschen Sie die Datei fonts.bin
  6. öffnen Sie den Arbeitsplatz
  7. benennen Sie die jetzt leere Schriftliste genau so wie die Schriftliste im Globalprojekt

Jetzt werden im Standardprojekt die Schriften mit der Nummer 1 und 2 aus dem Globalprojekt verwendet. Neue Elemente verwenden die Schrift mit Nummer 2 des Globalprojekts, falls dieses verfügbar ist, und die Systemschrift, falls das Globalprojekt nicht verfügbar ist.

Dynamisch und statisch

Schriften für das Vektorelement Statischer Text und für Dynamische Elemente werden unterschiedlich gespeichert. Der Grund dafür: Statischer Text kann Schriften auch einbetten.

Eingebettet bedeutet: Die Schrift ist nicht mit einer Schriftliste verbunden, sondern wird lokal und nur für dieses Element konfiguriert.

Achtung: Das bedeutet nicht, dass die Schrift ins Bild eingebettet ist und damit immer korrekt angezeigt wird. Die Schrift muss weiterhin auch am anzeigenden System vorhanden sein.

Import und Export über XML

Beim Import und Export über XML wird bei Dynamischen Elementen die Eigenschaft Name der Schrift zur Identifizierung benutzt. Ist zum Beispiel im Globalprojekt eine Schrift mit dem Namen "zenon" vorhanden und im lokalen Standardprojekt eine andere Schrift mit ebenfalls dem Namen "zenon", dann wird beim Import oder Export die Schrift des lokalen Projekts verwendet.

Interne ID: Benennung und Nummerierung von Schriften und Schriftlisten

Name

Frei vergebbare Bezeichnung, dient nur zur Information.
Default: Neue Schrift x (wobei x eine fortlaufende Zahl ist).
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Tipp: Die Schriftnamen müssen im Globalprojekt und im Standardprojekt eindeutig sein. Der Editor überprüft dies nicht.

VBA

VBA benutzt bei Dynamischen Elementen die Eigenschaft Nummer der Schrift. Hier kann der Offset für Schriften im Globalprojekt und im Standardprojekt nützlich sein.

Interne ID: Benennung und Nummerierung von Schriften und Schriftlisten

Nummer

Eindeutige Nummer der Schrift.
Die Nummer wird beim Anlegen einer Schrift vom System vergeben. Die Nummern 1 und 2 sind fix vergeben und können nicht geändert werden. Alle anderen Schriftnummern können nachträglich geändert werden, soweit die neu vergebene Nummer nicht bereits für eine andere Schrift verwendet wird.

Hinweis: Bei gleichen Nummern im Globalprojekt und im Projekt wird die Projektschrift verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zum Beispiel: Die Schrift 2 aus dem Standardprojekt wird durch 2002 aus dem Globalprojekt ersetzt. Bei Vektorelementen wird die Schriftnummer an zweiter Stelle des Fontstrings gespeichert. Im Fontstring "0 7 0 0 700 255 0 0 0 3 2 5 34 Arial" ist die Nummer der Schrift 7 und kann einfach durch 2007 aus dem Globalprojekt ersetzt werden.


Verbinden von Schriften mit Elementen

Handbuch -> Bilder -> Schriften -> Verbinden von Schriften mit Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es gibt zwei Möglichkeiten, um eine Schrift mit einem Dynamischen- oder Vektor Bildelement (z.B: Text) zu verbinden.

Parameter

Beschreibung

Drag&Drop

Die Tabelle in der Detailansicht ist wie folgt aufgebaut: Aufzählungsnummern, Schriftlisten und Schriftarten.

Mit einem Klick auf die Aufzählungsnummer der gewünschten Schrift kann diese per Drag&Drop ins gewünschte Element gezogen werden.

Eigenschaften

In den Eigenschaften des selektierten Elementes kann die Schrift ebenfalls verknüpft werden. Unter 'Darstellung /Schrift' wird der Dialog 'Element Eingabe' geöffnet.

Noch in diesem Kapitel

Eingebettete und Verknüpfte Schriften


Eingebettete und Verknüpfte Schriften

Handbuch -> Bilder -> Schriften -> Verbinden von Schriften mit Elementen -> Eingebettete und Verknüpfte Schriften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schriften können mit Elementen entweder eingebettet oder verknüpft verbunden werden.

Parameter

Beschreibung

verknüpfen

Per Default werden Schriften verknüpft.

einbetten

Für das Vektorelement Element Statischer Text besteht die Möglichkeit, die Schrift einzubetten. Die Schrift ist dann nicht mehr mit einer Schriftliste verbunden, sondern wird lokal und nur für dieses Element konfiguriert.

Achtung: Das bedeutet nicht, dass die Schrift ins Bild eingebettet ist und damit immer korrekt angezeigt wird. Die Schrift muss weiterhin auch am anzeigenden System vorhanden sein.

info Info

Skalieren von Symbolen:

Enthält ein Symbol ein Element Statischer Text und ist in dieses Element Schrift eingebettet, dann wird diese Schrift:

  • im Editor skaliert
  • in der Runtime nicht skaliert

Dies gilt nur für Symbole. In allen anderen Konstellationen wird eingebetteter Text weder im Editor noch zur Runtime skaliert.


ClearType

Handbuch -> Bilder -> Schriften -> ClearType

ClearType-Schriften können die Lesbarkeit von Schriften auf LCD-Bildschirmen in nativer Auflösung verbessern. Für Röhrenmonitore und LCDs mit interpolierter Auflösung eigenen sich oft Windows Standardschriften besser. Ob ClearType-Schriften verwendet werden, definieren Sie in den Projekteigenschaften: Knoten Grafische Ausprägung -> Bilder -> ClearType Schriften.

Interne ID: ClearType

ClearType Schriften

Aktiv: ClearType Schriften werden verwendet. Kann die Lesbarkeit von Schriften auf LCD-Bildschirmen in nativer Auflösung verbessern.

Inaktiv: Windows Standardschriften werden verwendet. Eignet sich oft für Röhrenmonitore und LCDs mit interpolierter Auflösung.
Hinweis: Wurde für die Eigenschaft Grafikqualität Windows Basis oder Windows Erweitert gewählt, muss unter Windows Vista und Windows 7 im Betriebssystem die Verwendung von ClearType-Schriften deaktiviert werden. Wurde DirectX gewählt, kann Cleartype unabhängig vom Betriebssystem ein- und ausgeschaltet werden.

Interne ID: ClearType

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ClearType

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: aktiv.

Hinweis: Änderungen der Einstellung werden für den Editor erst nach dem Neustart des Editors wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: ClearType

Bilder

Eigenschaften für die Anzeige der Bilder in der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: ClearType

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Abhängigkeiten vom Betriebssystem

Welche Auswirkungen die Option hat, hängt auch vom eingesetzten Betriebssystem ab:

  • Windows Vista und Windows 7:
    • Ist ClearType im Betriebssystem aktiv, wird ClearType unabhängig von der Einstellung in zenon benutzt.
      Ausnahme: DirectX kann Cleartype direkt an- und ausschalten.
    • Ist ClearType im Betriebssystem nicht aktiv, entscheidet die Einstellung in zenon.
  • Windows XP:
    • Die Einstellung in zenon entscheidet.
Einstellung | Einstellung der Eigenschaft Grafikqualität | Beschreibung
Aktiv (Default) |  | ClearType Schriften werden verwendet.
Inaktiv | Windows Basis Windows erweitert | Windows Standardschriften werden verwendet. Unter Windows Vista und Windows 7 muss ClearType auch im Betriebssystem deaktiviert werden.
 | DirectX Software DirectX Hardware | Cleartype kann unabhängig vom Betriebssystem ein- und ausgeschaltet werden

Achtung: Änderungen der Einstellung werden für den Editor erst nach dem Neustart des Editors wirksam.


Symbole

Handbuch -> Bilder -> Symbole

Symbole sind Bildelemente, denen Vektor- und Dynamische Bildelemente als Bildmakros zugeordnet sind. Zur Runtime kann das Farbattribut eines Symbols mittels Dynamischer Elemente (Zustandselement, Multibinärelement und Combi-Element) verändert werden.

zenon unterscheidet zwei verschiedene Symbolbibliotheken:

Symbolbibliothek

Eigenschaft

Globale Symbolbibliothek

Symbole sind in allen Projekten verfügbar.Der Knoten Globale Symbolbibliothek befindet sich im Projektmanager unterhalb der aktuell geladenen Projekte

Globale Symbole werden im zenon Programmordner gespeichert und nur beim Editorstart aktualisiert. Diese Symbole werden bei der Projektsicherung nicht gesichert.

Projekt-Symbolbibliothek

Symbole sind nur im aktuellen Projekt verfügbar.

Die Symbole werden im Projektordner gespeichert. Die Projekt-Symbolbibliothek befindet sich im aktuellen Projekt im Knoten Bilder und wird bei einer Projektsicherung mitgesichert.

Um mit beiden Bibliotheken parallel arbeiten zu können, wird die Vorschau der beiden Bibliotheken in zwei separaten Fenstern angezeigt. Die Namen der Bibliotheken werden dabei in den Registerkarten am unteren Bildrand des Hauptfensters angezeigt.

Symbole können mit Drag&Drop von einer Bibliothek in eine andere verschoben oder kopiert werden.

info Info

Skalieren von Symbolen:

Enthält ein Symbol ein Element Statischer Text und ist in dieses Element Schrift eingebettet, dann wird diese Schrift:

  • im Editor skaliert
  • in der Runtime nicht skaliert

Dies gilt nur für Symbole. In allen anderen Konstellationen wird eingebetteter Text weder im Editor noch zur Runtime skaliert.

Bildsymbole und Symbole aus Globaler Symbolbibliothek

  • Bildsymbole werden im Bild erzeugt und können nur dort bearbeitet werden. Sie werden in die Bibliothek verknüpft oder in Bilder eingebettet.
  • Symbole aus einer Bibliothek werden in der Bibliothek bearbeitet und im Bild verknüpft.

attention Achtung

Symbole aus Globale Symbolbibliothek werden je Gruppe in einer eigenen Datei (*.sys) lokal im zenon Programordner gespeichert. Diese Dateien müssen bei Mehrplatzprojekten und bei der Weitergabe von Projekten immer manuell zur Projektsicherung hinzugefügt werden. Symbole aus der lokalen Projekt-Symbolbibliothek sind in Projektsicherungen immer automatisch enthalten.

Tipp: Symbole immer in der lokalen Projekt-Symbolbibliothek speichern.

Kontextmenü Projektmanager

Menüpunkt | Aktion
XML exportieren alle.. | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert aus XML-Datei.
In neuem Fenster öffnen | Öffnet ein eigenes Fenster für Ansicht und Bearbeitung der Symbole. (Default am unteren Rand des Editors.)
Hilfe | Öffnet die Online-Hilfe.

Überprüfung verknüpfter Symbole

Verknüpfte Symbole werden auf ihr korrektes Vorhandensein überprüft:

  • beim Kompilieren der Runtime-Dateien
  • wenn beim Beenden des Editors neue Runtime-Dateien erzeugt werden

Fehlende Symbole werden im Ausgabefenster rot als fehlend markiert. Die Fehlermeldung nennt die Namen der betreffenden Bilder und Symbole.

Menü Symbole

Sobald ein Symbol in der Globalen Symbolbibliothek oder in der Projekt-Symbolbibliothek aktiviert wird, wird in der Symbolleiste der Menüpunkt Bilder durch Symbol ersetzt.

Folgende Aktionen sind möglich:

Menüpunkt

Aktion

Symbol speichern

Speichert das aktuelle Symbol.

Alle Symbole speichern

Speichert alle Symbole.

Symbolgröße/Hintergrundfarbe ändern

Öffnet den Dialog zur Konfiguration von Symbolgröße und Hintergrundfarbe.

Hinweis: Änderungen der Hintergrundfarbe betreffen immer alle Symbole in der Globalen Symbolbibliothek.

Symbolliste

Öffnet eine Liste aller Symbole, die im aktuellen Bild angezeigt werden. Für jedes Symbol werden seine grafischen Einzelbestandteile aufgelistet.

Vollbildmodus

Der Vollbildmodus blendet alle übrigen Fenster aus und zeigt nur das Hauptfenster mit allen geöffneten Dokumenten (Bilder, Reporte, ...) als Vollbild über den ganzen Bildschirm an.

Der Vollbildmodus kann beendet werden über:

  • die eingeblendete Schaltfläche zum Beenden des Vollbildmodus
  • die Tastenkombination Umschalt+F9
  • die Taste Esc

Symbol neu zeichnen

Aktualisiert die Bildschirmanzeige.

Raster anzeigen

Schaltet die Anzeige des Rasters ein oder aus.

Raster verwenden

Schaltet Verwendung des Rasters ein oder aus.

Ein: Alle Objekte werden automatisch am Raster ausgerichtet.

Fangpunkte verwenden

Schaltet Fangpunkte ein oder aus.

Verwenden: Nähert man ein Objekt dem Anfasspunkt eines anderen Objektes, dann rastet das Objekt an diesem Anfasspunkt ein.

Reihenfolge für Fokus verschieben

Öffnet Dropdownliste zur Festlegung der horizontalen oder vertikalen Reihenfolge bei Tastaturbedienung.

Reihenfolge für links/rechts: Legt die horizontale Reihenfolge fest.

Reihenfolge für oben/unten: Legt die vertikale Reihenfolge fest.

Zoomen

Ändert die Darstellungsgröße in festen Schritten zwischen 15 % und 400 %.

Screenshot aktuelles Symbol drucken

Das aktuelle Symbol wird auf dem als Standard gewählten Drucker ausgegeben. Druckereinstellung unter Datei -> Allgemeine Konfiguration -> Standard.

Vektorgrafik einfügen

Öffnet den Dialog zum Einfügen einer externen Vektorgrafik.

Noch in diesem Kapitel

Symbole Detailansicht Symbolleiste und Kontextmenü

Größe und Hintergrundfarbe konfigurieren

Eigenschaften aus Verknüpfung freigeben

Eigene Symbole erstellen und löschen

Symbole in ein Bild einfügen

Symbolliste

XML-Export und XML-Import


Symbole Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Bilder -> Symbole -> Symbole Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Symbolbibliothek wird über das Kontextmenü oder die Symbolleiste bedient:

Befehle in Kontextmenü und Symbolleiste

Symbolleiste | Kontextmenü | Funktion
1 | Symbol neu | Legt ein neues Symbol an.
3 | Symbol öffnen | Öffnet das Symbol im Symboleditor zum Bearbeiten.
2 | Symbolgruppe neu | Eine neue Symbolgruppe wird angelegt und kann mit ausgewählten Symbolen aus der Bibliothek oder selbst erstellten Symbolen befüllt werden. (Kopieren und Einfügen). Nur verfügbar in der Globalen Symbolbibliothek.
4 | Symbol als eingebettetes Symbol in Bild einfügen | Bettet das Symbol in ein Bild ein (Details siehe Unterkapitel Eingebettete Symbole).
5 | Symbol als verknüpftes Symbol in Bild einfügen | Verknüpft Symbol in Bild (Details siehe Unterkapitel Verknüpfte Symbole).
13 | Flache Ansicht | Ordnet alle Symbole in einer flachen Liste an. Erleichtert die Suche nach bestimmten Symbolen. Hinweis: In dieser Ansicht können Symbole weder erzeugt noch gelöscht werden, auch das Kopieren oder Einfügen von Symbolen aus der Zwischenablage ist nicht möglich.
14 | Hierarchische Ansicht | Ordnet alle Symbole hierarchisch in Untergruppen und stellt Abhängigkeiten dar.
6 | Kopieren | Kopiert das ausgewählte Symbol in die Zwischenablage (nur in hierarchischer Ansicht).
7 | Einfügen | Fügt das kopierte Symbol in der aktiven Gruppe ein (nur in hierarchischer Ansicht).
8 | Löschen | Löscht das selektierte Symbol bzw. die Symbolgruppe (nur in hierarchischer Ansicht). Achtung: Das Löschen kann nicht rückgängig gemacht werden!
9 | Selektierte Zelle bearbeiten | Ermöglicht das Bearbeiten der Inhalte der selektierten Zelle.
10 | Text in selektierter Zelle ersetzen | Öffnet den Dialog zum automatisierten Ersetzen von Texten (nur vorhanden, wenn Zellen, die Text enthalten können, ausgewählt wurden).
11 | Eigenschaften | Öffnet das Fenster Eigenschaften für das gewählte Symbol.
12 | Knoten erweitern/reduzieren | Erlaubt in der hierarchischen Ansicht, den gewählten Knoten oder alle Knoten zu erweitern oder reduzieren.
15 | Selektierte XML exportieren | Öffnet den Dialog zum XML-Export der gewählten Symbole. (Details siehe siehe Kapitel Import/Export Symbole.)
16 | XML importieren | Importiert Symbole aus einer XML-Datei (siehe Kapitel Import/Export Symbole).
18 | Alle Filter entfernen | Löscht alle im Spaltentitel gesetzten Filter.
19 | Hilfe | Öffnet die Hilfe zum Kontextmenü.
17 | - | Springt zurück zum Ausgangselement (nur Symbolleiste).
 | Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Größe und Hintergrundfarbe konfigurieren

Handbuch -> Bilder -> Symbole -> Größe und Hintergrundfarbe konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Symbolgröße und die Hintergrundfarbe zu konfigurieren:

  1. wählen Sie im Kontextmenü des Symbols oder im Menü Symbol den Befehl Symbolgröße/Hintergrundfarbe ändern...
  2. der Dialog zur Konfiguration wird geöffnet

Parameter | Beschreibung
Symbol Breite/Höhe | Eingabe der Höhe und Breite des Symbols inPixel.
Hintergrundfarbe im Symboleditor | Definiert Hintergrundfarbe. Klick auf Farbe öffnet Palette. Hinweis: Änderungen der Hintergrundfarbe betreffen immer alle Symbole in der Globalen Symbolbibliothek.
OK | Übernimmt Änderungen und schließt Dialog.
Abbrechen | Verwirft Änderungen und schließt Dialog.


Eigenschaften aus Verknüpfung freigeben

Handbuch -> Bilder -> Symbole -> Eigenschaften aus Verknüpfung freigeben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um verknüpfte Symbole optimal nutzen zu können, ist es manchmal erforderlich, einzelnen Eigenschaften von Symbolelementen individuelle Werte zuzuweisen. Zum Beispiel hat ein Motorsymbol eine Überschrift in der der Name enthalten ist.

Mit dieser Funktion können Sie zum Beispiel die Eigenschaft Text freigeben. Wenn das Symbol in ein Bild gezogen wird, ist die Eigenschaft Text individuell für jeden Motor einzeln änderbar.

Diese Funktionalität steht für alle Eigenschaften zur Verfügung.

Projektierung

Beim Öffnen eines Symbols wird der Symboleditor geöffnet. Der Symboleditor besteht aus einem zweigeteilten Fenster zur Bearbeitung des ausgewählten Symbols.

Im oberen Bereich wird das Symbol bearbeitet, im unteren Bereich werden die freigegebenen Eigenschaften der Elemente dieses Symbols aufgelistet. Zum Freigeben von Elementen haben Sie mehrere Möglichkeiten:

  1. Drag & Drop
    1. ziehen Sie die gewünschten Eigenschaften einzeln per Drag&Drop aus dem Eigenschaftenfenster in den unteren Bereich des Symboleditors.
    2. Hinweis: Sie müssen die Eigenschaften immer bei deren Namen anklicken (nicht beim Wert) und mit Drag & Drop in den Freigabebereich ziehen.
  2. Kontextmenü der Eigenschaft
    1. klicken Sie mit der rechten Maustaste auf den Namen der Eigenschaft
    2. wählen Sie im Kontextmenü [Eigenschaft] freigeben
    3. die Eigenschaft wird in die Liste eingetragen
  3. Symbolleiste der Eigenschaft
    1. klicken Sie mit der linken Maustaste auf den Namen der Eigenschaft
    2. klicken Sie in der Symbolleiste auf das Symbol zur Freigabe (grüner Pfeil nach oben über Textfeld)
    3. die Eigenschaft wird in die Liste eingetragen

Hinweis: Wird der Eintrag nicht angeboten oder das Symbol deaktiviert dargestellt, kann das Element nicht freigegeben werden. Mögliche Gründe:

  • kein Bildelement im Symboleditor ausgewählt
  • Eigenschaft wurde bereits freigegeben
  • Element unterstützt Freigabe nicht (z.B ActiveX)

Der Freigabebereich ist eine filterbare Liste. Sie können bei Bedarf nach einzelnen Eigenschaften filtern. Für Aktionen steht ein Kontextmenü zur Verfügung.

Kontextmenü für Freigabe-Liste:

Parameter | Beschreibung
Selektierte Eigenschaft entfernen | Entfernt Freigabe des Elements.
Rückgängig | Revidiert letzte Aktion.
Hilfe | Öffnet die Online-Hilfe.

Frei gegebene Eigenschaften bearbeiten

Wird das Symbol in einem Bild angezeigt, steht in den Eigenschaften der zusätzliche Knoten $_Elementname zur Verfügung. Darin werden alle individuell freigegebenen Eigenschaften angezeigt. Diese wurden aus dem Prinzip der Verknüpfung gelöst (freigegeben) und betreffen bei Änderungen nur dieses Symbol. Wird im Fenster Eigenschaften eines Symbols eine Eigenschaft eines der Elemente ausgewählt, so blinkt dieses Element im Bild.

Die frei gegebenen Eigenschaften können geändert werden:

  • mit den Eigenschaften im Zweig $_Elementname
  • mit dem Linked Symbol Wizard

Linked Symbol Wizard

Um frei gegebene Eigenschaften übersichtlich und bequem bearbeiten zu können, steht Ihnen der Linked Symbol Wizard zur Verfügung:

  1. führen Sie im Bild einen Doppelklick auf ein Symbol aus, das:
    1. im Bild verknüpft ist und
    2. über frei gegebene Eigenschaften verfügt
  2. der Linked Symbol Wizard öffnet sich
  3. wählen Sie die zu ändernde Eigenschaft
  4. geben Sie den neuen Wert ein
    Hinweis: Jede Änderung wird sofort übernommen!
  5. Schließen Sie den Wizard mit Klick auf Exit

Parameter | Beschreibung
Select an element in the symbol: | Auswahl eines Elements des Symbols aus der Dropdownliste.
Select the exported property to | Auswahl der frei gegebenen Eigenschaft aus Liste.
Anzeige Eigenschaft | Zeigt die zu ändernde Eigenschaft an-
Eingabefeld | Eingabe des neuen Werts der Eigenschaft über Texteingabe/Zahleneingabe, Dropdownliste oder Auswahldialog - abhängig von der Eigenschaft.
Exit | Schließt Wizard

info Info

Der Wizard unterstützt nicht alle möglichen Symboleigenschaften.


Eigene Symbole erstellen und löschen

Handbuch -> Bilder -> Symbole -> Eigene Symbole erstellen und löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbole erstellen Sie entweder im Symboleditor oder in einem Bild. Elemente eines Symbols können sein:

  • Vektor-Elemente
  • Dynamische Elemente
  • andere Symbole: Symbole können in andere eingebettete Symbole eingefügt werden

info Info

In einem Symbol enthaltene Elemente sollten nur innerhalb des Symbolbereichs platziert werden und nicht darüber hinausragen. Überragen Elemente die Symbolgrenzen, kann es bei der Darstellung in der Runtime zu Artefakten kommen. Das gilt auch für Elemente, die Symbole benutzen (zum Beispiel das Combi-Element).

Im Symboleditor:

  1. wählen Sie im Kontextmenü oder in der Symbolleiste Symbol neu
  2. klicken Sie in die Zelle für Elementname und vergeben Sie einen Namen (Punkte sind in Symbolnamen nicht erlaubt)
  3. erstellen Sie im Symboleditor das Symbol
  4. fügen Sie eventuell individuelle Eigenschaften hinzu (siehe Unterkapitel Eigenschaften aus Vererbung lösen)
  5. speichern Sie das Symbol

Im Bild:

  1. wählen Sie eines oder mehrere Elemente im Bild aus
  2. wählen Sie im Kontextmenü Symbol -> eingebettetes Symbol erzeugen (bzw -> einfügen in existierendes eingebettetes Symbol)
    oder im Menü Bearbeiten -> Symbol -> eingebettetes Symbol erzeugen
  3. speichern Sie das Bild

attention Achtung

Schriften und Grafiken in Symbolen bei projektübergreifendem Einsatz:

Schriften: Schriften werden über Ihre ID definiert. Stellen Sie sicher, dass in allen Projekten, in denen das Symbol verwendet wird, die gewünschte Schrift der gleichen ID zugeordnet ist.

Grafiken: In ein Symbol eingefügte Grafiken werden nicht mit dem Symbol abgespeichert. Die entsprechenden Grafiken müssen manuell in das Grafikverzeichnis des entsprechenden Projekts kopiert werden.

Symbole in Symbole einbetten oder verknüpfen

Sie können analog zu den Bildern auch bei der Erstellung von Symbolen bestehende Symbole einbetten oder verknüpfen (siehe Symbole in Bild einfügen). Dabei müssen Sie folgende Regeln beachten:

  • Eine Symbol darf keine Rekursion enthalten, d.h. Sie dürfen es nicht auf sich selbst verknüpfen!
  • Projektsymbole dürfen nicht projektübergreifend verknüpft werden!
  • Symbole aus der Globalen Symbolbibliothek dürfen keine Verknüpfung auf Projektsymbole beinhalten.

info Info

Sie können Symbolinhalte nur im Symboleditor bearbeiten. Wenn Sie ein eingebettetes Symbol in ein Bild einfügen, können Sie das Symbol im Bildeditor nicht bearbeiten.

attention Achtung

Sie können Symbole aus der Projektbibliothek nur innerhalb des jeweiligen Projektes verknüpfen. Ein projektübergreifendes Verknüpfen von Symbolen aus der Projektbibliothek ist nicht möglich. Um ein Symbol aus einer Projektbibliothek in einem anderen Projekt zu verwenden, können Sie es einbetten.

Symbol löschen oder auflösen

Um ein Symbol zu löschen:

  1. markieren Sie das Symbol in der Bibliothek
  2. wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl löschen

Um ein eingebettetes Symbol in einem Bild auszulösen:

  1. markieren Sie das Symbol in der Bibliothek
  2. wählen Sie im Kontextmenü Symbol -> Auflösen
  3. das Symbol wird in seine Elemente aufgelöst
  4. wurde das Symbol zur Symbolbibliothek bereits hinzugefügt, bleibt es dort unverändert erhalten, wird aber in der Symbolverwaltung gelöscht

Um ein verknüpftes Symbol zu löschen:

  1. markieren Sie das Symbol in der Bibliothek
  2. wählen Sie im Kontextmenü Löschen
  3. das Symbol bleibt in der Symbolbibliothek unverändert erhalten, wird aber in der Symbolverwaltung gelöscht

info Info

Um einzelne Elemente eines Symbols zu bearbeiten, ohne die Symbolzuordnung aufzuheben, wählen Sie:

  • bei verknüpften Symbolen: Bearbeiten im Symboleditor
  • bei eingebetteten Symbolen: Einzelbearbeitungsmodus Symbole/Elemente

Noch in diesem Kapitel

Eigene Symbole in die Bibliothek übertragen


Eigene Symbole in die Bibliothek übertragen

Handbuch -> Bilder -> Symbole -> Eigene Symbole erstellen und löschen -> Eigene Symbole in die Bibliothek übertragen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbole, die Sie in einem Bild erstellt haben, können Sie auch in eine Symbolbibliothek einfügen:

  1. wählen Sie im Kontextmenü des Symbols Symbol -> Einfügen in Symbolbibliothek
  2. der Dialog für die Symboldefinition öffnet sich
  3. wählen Sie Ihre Projektbibliothek oder die Globale Symbolbibliothek und den passenden Ordner
  4. bestätigen Sie den Dialog mit OK
  5. wechseln Sie in die gewählte Symbolbibliothek
  6. das Symbol wurde mit dem Elementnamen Eingebettetes Symbol_Nr eingetragen
  7. vergeben Sie den gewünschten Namen
  8. um das Symbol weiter zu bearbeiten oder ihm individuelle Eigenschaften zuzuweisen (siehe Eigenschaften aus Vererbung lösen), öffnen Sie das Symbol per Doppelklick oder den Kontextbefehl Symbol öffnen im Symboleditor

info Info

Ein Symbol, das aus einem Element und einem verknüpften Symbol erstellt wurde, kann nicht in die Symbolbibliothek übernommen werden. Um das Symbol einfügen zu können:

  • konvertieren Sie das verknüpfte Symbol in ein eingebettetes Symbol
  • erstellen Sie ein neues Symbol aus dem Element und dem eingebetteten Symbol

Dieses Symbol kann jetzt in die Symbolbibliothek eingefügt werden.


Symbole in ein Bild einfügen

Handbuch -> Bilder -> Symbole -> Symbole in ein Bild einfügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbole können auf zwei Arten in ein Bild eingefügt werden, als

  • Eingebettete Symbole:Diese sind nicht weiter mit dem Symbol in der Bibliothek verbunden, Änderungen am Ursprungssymbol wirken sich nicht auf das eingebettete Symbol aus.
  • Verknüpfte Symbole: Diese sind weiter mit dem Ursprungssymbol verbunden. Änderungen am Symbol in der Bibliothek verändern auch das Symbol im Bild.

attention Achtung

Sie können Symbole aus der Projektbibliothek nur innerhalb des jeweiligen Projektes verknüpfen. Ein projektübergreifendes Verknüpfen von Symbolen aus der Projektbibliothek ist nicht möglich. Um ein Symbol aus einer Projektbibliothek in einem anderen Projekt zu verwenden, können Sie es einbetten.

info Info

Wenn Sie die Eigenschaft Rahmen um Dynamische Elemente im Editor aktiviert haben, können Sie eingebettet Symbol von verknüpften Symbolen auf einen Blick unterscheiden. Bei verknüpften Symbolen wird in der oberen rechten Ecke ein Pfeilsymbol angezeigt. Sie finden diese Eigenschaft unter Optionen -> Einstellungen im Bereich Einstellungen.

Noch in diesem Kapitel

Eingebettete Symbole

Verknüpfte Symbole

Symbolauswahl im Combi Element


Eingebettete Symbole

Handbuch -> Bilder -> Symbole -> Symbole in ein Bild einfügen -> Eingebettete Symbole

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

So betten Sie ein Symbol in ein Bild ein:

  • halten Sie die Taste Strg gedrückt und ziehen Sie das Symbol per Drag&Drop ins Bild

    oder

  • wählen Sie im Kontextmenü des Symbols Symbol als eingebettetes Symbol in Bild einfügen um das Symbol in das aktuelle Bild einzubetten

Eingebettete Symbole können dann in ihre einzelnen Elemente aufgelöst werden oder ihre einzelnen Elemente können geändert werden. Dazu wählen Sie im Kontextmenü Symbol -> In Einzelbearbeitungsmodus wechseln oder im Menü Bearbeiten -> Symbol -> Einzelbearbeitungsmodus Symbole/Elemente.

Diese Symbole ändern sich nicht, wenn das Originalsymbol in der Bibliothek geändert wird, da sie nicht länger damit verknüpft sind.

Verknüpfte Variablen ersetzen

Beim Einbetten eines Symbols , das Variablen enthält, öffnet sich der Dialog zum Ersetzen von Variablen und Funktionen. Hier können Sie die vorhandenen Elemente durch die für dieses verknüpfte Symbol gewünschten automatisiert ersetzen. Details zum automatisierten Ersetzen von Variablen und Funktionen finden Sie im Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen .

Um Variablen in bereits eingefügten Symbolen zu ersetzen, wählen Sie im Kontextmenü des Symbols den Befehl Verknüpfen ersetzen.

Tipp: Achten Sie darauf, dass die Variablen von Anfang eindeutig und sinnvoll benannt werden.


Verknüpfte Symbole

Handbuch -> Bilder -> Symbole -> Symbole in ein Bild einfügen -> Verknüpfte Symbole

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verknüpfte Symbole speichern in der Symbolbibliothek keine physikalisch vorhandenen Variablen, sondern nur Variablennamen. Beim einfügen von Symbolen als Verknüpfung in ein Bild, können die im Symbol hinterlegten Variablennamen Variablen aus dem Projekt zugewiesen werden. Enthält das Projekt eine Variable, die einem im Symbol hinterlegten Variablennamen entspricht, wird diese automatisch - ohne extra Regel - verknüpft.

Symbol verknüpft einfügen

So verknüpfen Sie ein Symbol in ein Bild:

  • ziehen Sie das Symbol per Drag&Drop ins Bild

    oder

  • wählen Sie im Kontextmenü des Symbols Symbol als verknüpftes Symbol in Bild einfügen um das Symbol in das aktuelle Bild zu verknüpfen

Verknüpfte Symbole werden nur als Verweis im Bild gespeichert. Jede Änderung des Symbols in der Bibliothek wirkt sich unmittelbar auf das Symbol im Bild aus. Wird z.B. ein Dynamisches Element im Symbol hinzugefügt, so ist dies in allen Bildern, wo dieses Symbol verwendet wird, auch vorhanden.
Ausnahme: Änderungen der Symbolgröße wirken sich im Bild nur aus, wenn dort in der Symboleigenschaft Grafikgröße Originalgröße ausgewählt ist.

Interne ID: Verknüpfte Symbole

Grafikgröße

Definition der Bitmapgrösse.
Originalgrösse: Originalgrösse des verknüpften Bitmaps.
Gestreckt: Bitmapgrösse wird an die Grösse des Elements angepasst (gestreckt).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Sie können verknüpfte Symbole:

  • in eingebettete Symbole umwandeln: Kontextmenü Symbol -> Verknüpftes in eingebettetes Symbol konvertieren
  • im Symboleditor bearbeiten: Symbol -> Bearbeiten im Symboleditor
  • in ein eingebettetes Symbol einfügen: Symbol -> Einfügen in existierendes eingebettetes Symbol

Verknüpfte Symbole können nicht in ihre Elemente aufgelöst werden und ihre Elemente können im Modus Elemente bearbeiten (Kontextmenü -> Symbol -> In Einzelbearbeitungsmodus wechseln oder Menü Bearbeiten -> Symbol -> Einzelbearbeitungsmodus Symbole/Elemente) nicht geändert werden.

attention Achtung

Verwenden Sie bei verknüpften Symbolen nur eingebettete Schriften, da verknüpfte Schriften nicht mit dem Symbol skaliert werden. Damit würde sich die relative Position der Texte zur Grafik im Symbol verschieben.

Verknüpfte Variablen ersetzen

Beim verknüpften Einfügen eines Symbols , das Variablen enthält, öffnet sich der Dialog zum Ersetzen von Variablen und Funktionen. Hier können Sie die vorhandenen Elemente durch die für dieses verknüpfte Symbol gewünschten automatisiert ersetzen. Es können auch ALC Aliase, die in Elementen im Symbol verwendet werden, ersetzt werden. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Eigenschaft | Beschreibung
Quelle | Eingabe des zu suchenden Teilstrings; Wildcards * und ? sind möglich. (Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.)
Ziel | Eingabe des neuen Teilstrings.
Name | Tauscht Information im Variablennamen.
Kennung | Tauscht Information in der Kennung.
Groß-/ Kleinschreibung beachten | Achtet beim Tausch auf exakte Übereinstimmung der Groß-/und Kleinschreibung.
Zusammengesetzte Namen | Zusammengesetzte Namen erlauben. Steht für ALC ALiase nicht zur Verfügung. Diese werden immer ohne Symbolprefix verwendet.

Weitere Details zum automatisierten Ersetzen von Variablen und Funktionen finden Sie im Kapitel Verknüpfungen von Variablen und Funktionen ersetzen.

Um Variablen in bereits eingefügten Symbolen zu ersetzen, wählen Sie in den Eigenschaften im Knoten Verknüpfungsregel die Eigenschaft Vorschau.

Interne ID: Verknüpfte Symbole

Vorschau

Steht nur zur Verfügung, wenn eine Variable mit dem Symbol verknüpft ist.

Öffnet den Dialog zum Ersetzen der Verknüpfungen. Änderungen in der Vorschau werden in die Eigenschaften Quelle und Ziel übernommen und umgekehrt.

Interne ID: Verknüpfte Symbole

Ziel

Ersetzen von Variablen und/oder Funktionen in einem Symbol:
Geben Sie die neu zuzordnenden Variablen/Funktionen an. Dabei sind keine Platzhalter erlaubt. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Quellen definieren Sie zuvor über die Eigenschaft Quelle.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfte Symbole

Quelle

Ersetzen von Variablen und/oder Funktionen in einem Symbol:

Geben Sie die Quellvariablen/Quellfunktion an. Dabei können Platzhalter (?, *) verwendet werden. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Ziele definieren Sie dann über die Eigenschaft Ziel.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfte Symbole

Verknüpfungsregel

Eigenschaften für das Ersetzen der Verknüpfungen zu Variablen und/oder Funktionen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Tipp: Achten Sie darauf, dass die Variablen von Anfang eindeutig und sinnvoll benannt werden.

Beispiel:

Quelle: A;b

Ziel: C;d

Zusammengesetzte Namen

Bei aktiver Eigenschaft Zusammengesetzte Namen im Knoten Verknüpfungsregel werden die Namen der verknüpften Variablen aus dem Objektnamen des Symbols und der in Symbol definierten Variablen zusammengesetzt. Die beiden Namen werden durch einen Punkt getrennt: "Symbolname.Variable"

Interne ID: Verknüpfte Symbole

Zusammengesetzte Namen

Aktiv: Die Namen der verknüpften Variablen werden aus dem Objektnamen des Symbols und der in Symbol definierten Variablen zusammengesetzt. Die beiden Namen werden durch einen Punkt getrennt: "Symbolname.Variable"
Inaktiv: Die normalen Variablennamen werden verwendet.
Default: inaktiv
Beispiel:
Variablenname: Motor.Drehzahl
Der Symbol Objektname ist "Motor". Das Dynamisches Element, das im Symbol eingesetzt ist, hat als verknüpfte Variable den Platzhalter "Drehzahl".
Den Platzhalter "Drehzahl" kann man bei der Symbolerstellung einfach bei der Variableneigenschaft eintippen.
Zusammengesetzte Namen funktionieren auch mit verschachtelten Symbolen:
Hat man ein Symbol "Pumpe", das wiederum ein Symbol "Motor" und ein Symbol "Umrichter" mit dem Variablenplatzhalter "Leistung" enthält, dann funktioniert die Verknüpfung, wenn es im Projekt eine Variable Pumpe.Motor.Leistung und eine Variable Pumpe.Umrichter.Leistung gibt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Example Beispiel

Variablenname: Motor.Drehzahl
Der Symbol Objektname ist "Motor". Das Dynamisches Element, das im Symbol eingesetzt ist, hat als verknüpfte Variable den Platzhalter "Drehzahl".
Den Platzhalter "Drehzahl" kann man bei der Symbolerstellung einfach bei der Variableneigenschaft eintippen.

Zusammengesetzte Namen funktionieren auch mit verschachtelten Symbolen:
Hat man ein Symbol "Pumpe", das wiederum ein Symbol "Motor" und ein Symbol "Umrichter" mit dem Variablenplatzhalter "Leistung" enthält, dann funktioniert die Verknüpfung, wenn es im Projekt eine Variable Pumpe.Motor.Leistung und eine Variable Pumpe.Umrichter.Leistung gibt.


Symbolauswahl im Combi Element

Handbuch -> Bilder -> Symbole -> Symbole in ein Bild einfügen -> Symbolauswahl im Combi Element

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Combi-Elemente mit einem Symbol zu verknüpfen:

  1. wählen Sie in den Eigenschaften des Combi-Elements im Knoten Darstellung in der Eigenschaft Darstellungsart Symbol aus Bibliothek

    Interne ID: Symbolauswahl im Combi Element

    Darstellungsart

    Bitmap: Für jeden Zustand kann ein Bitmap ausgewählt werden.
    Zusätzlich kann auch die Farbe eines Bildsymbols geändert werden.
    Nur Bildsymbol: Für jeden Zustand kann einem bereits im Bild bestehenden Symbol eine Farbe zugeordnet werden.
    Symbol aus Bibliothek: Für jeden Zustand kann ein Symbol aus der Bibliothek sowie seine Linien- und Hintergrungfarbe ausgewählt werden.
    Zeichen: Für jeden Zustand kann ein Zeichen definiert werden (nur SICAM 230).
    Zustandstext & Bildsymbol: Für jeden Zustand kann ein Text definiert werden.
    Zusätzlich kann auch die Farbe eines Bildsymbols geändert werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Symbolauswahl im Combi Element

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie auf Konfiguration und Test

    Interne ID: Symbolauswahl im Combi Element

    Konfiguration und Test

    Öffnet den Dialog zur Definition der Zustände.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Konfigurationsdialog öffnet sich:

Die generellen Einstellungen für alle Darstellungsarten von Zuständen finden Sie im Kapitel Zustände.

Parameter

Beschreibung

Darstellungselement

Symbol aus Bibliothek

Klick auf das Symbol öffnet den Dialog zur Symbolauswahl.

Klick auf das X neben dem Symbol löscht das gewählte Symbol.

Verknüpfungsregel bearbeiten

Variablen und Funktionen, die im Symbol enthalten sind, können mit Hilfe von Verknüpfungsregeln ausgetauscht werden.

Achtung: Wenn ein Variablen- oder Funktionsname nicht in das Schema passt, kann diese Verknüpfung nicht ersetzt werden.

Farben

Nur aktiv, wenn im Bereich Spezifische Einstellungen die Eigenschaft Original Symbolfarben abgeschaltet ist.

Farbe

Wahl der Farbe.

Füllfarbe

Wahl der Füllfarbe.

Aus ALC

Die Farbe der verknüpften Quellen wird verwendet.

Spezifische Einstellungen

Original Symbolfarben

Aktiv: Übernimmt Originalfarbe vom Symbol. Deaktiviert Eigenschaft Farbe der Haupt-Variable übernehmen.

Interne ID: Symbolauswahl im Combi Element

Farbe der Haupt-Variable übernehmen

Aktiv: Die Füllfarbe bei eingebetteten Symbolen und Symbolen aus Bibliothek wird beim Zustand Default von der Hauptvariablen übernommen, wenn bei dieser eine Grenzwertverletzung vorliegt.
Das bedeutet: Solange eine Grenzwertverletzung der Hauptvariablen besteht, wird die Füllfarbe aus der Grenzwertfarbe übernommen. Die Farbdefinition bei den Zuständen wird also überschrieben. Weitere Zustandsattribute wie z.B. Blinken, Transparenz oder Original Symbolfarbe werden jedoch aus der Zustandsdefinition übernommen. Auf Bitmapdarstellung hat diese Eigenschaft keine Auswirkung.

Ausnahme: Ist beim Zustand Default die Eigenschaft Original Symbolfarbe aktiviert, wird immer die originale Symbolfarbe verwendet.
Inaktiv: Die Farbe der Hauptvariablen hat keinen Einfluss auf die dargestellten Farben des Combi-Elements.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Blinken

Aktiv: Symbol blinkt zur Runtime, wenn Zustand erreicht wird.


Symbolliste

Handbuch -> Bilder -> Symbole -> Symbolliste

Über Bearbeiten -> Symbol -> Symbolliste... öffnen Sie eine Liste, die alle Symbole des aktiven Bildes anzeigt:

Titel | Inhalt
Nr. | Symbolnummer
Name | Name des Symbols

Über einen Klick auf den jeweiligen Spaltentitel sortieren Sie die Symbole nach Nummer oder Name. Ein in der Symbolliste ausgewähltes Symbol wird im Bild blinkend dargestellt.


XML-Export und XML-Import

Handbuch -> Bilder -> Symbole -> XML-Export und XML-Import

Der Import/Export von Symbolen ist aus der Projekt-Symbolbibliothek und aus der Globalen Symbolbibliothek möglich. Es können einzelne, selektierte Symbole oder die gesamte Bibliothek importiert bzw. exportiert werden. Der Pfad für den Export ist frei wählbar.

Symbole exportieren

Um Symbole zu exportieren:

  1. markieren Sie die gewünschten Symbole
  2. wählen Sie im Kontextmenü der Detailansicht den Befehl Selektierte XML exportieren...
    Alternative: wählen Sie im Kontextmenü des Knotens Projekt-Symbolbibliothek den Befehl XML exportieren alle...
  3. der Auswahldialog für den Speicherort wird geöffnet
  4. wählen Sie den gewünschten Speicherort
  5. vergeben Sie einen Namen
  6. achten Sie auf den Dateityp XML
  7. bestätigen Sie mit Klick auf die Schaltfläche Speichern

Die ausgewählten Symbole werden in eine XML-Datei exportiert und können jederzeit in dieses oder andere Projekte wieder importiert werden.

Symbole importieren

Um Symbole zu importieren:

  1. wählen Sie im Kontextmenü des Knotens oder der Detailansicht von Projekt-Symbolbibliothek bzw. in der Detailansicht der Globalen Symbolbibliothek den Befehl XML importieren...
  2. der Auswahldialog für den Speicherort wird geöffnet
  3. navigieren Sie zum Speicherort der gewünschten XML-Datei
  4. wählen Sie die gewünschte Datei aus
  5. bestätigen Sie den Import mit Klick auf die Schaltfläche Öffnen

Die Symbole werden importiert.

Namenskonflikt beim Import

Beim Importieren eines Symbols wird der in der XML-Datei hinterlegte Name (Attribut ShortName) für die Benennung des neu anzulegenden Symbols verwendet. Existiert bereits ein Symbol mit dem selben Namen, wird der Import unterbrochen und eine Fehlermeldung angezeigt:

Parameter | Beschreibung
Ja | Das in der Fehlermeldung genannte Symbol wird beim Import durch das Symbol aus der XML-Datei ersetzt. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Nein | Das in der Fehlermeldung genannte Symbol wird nicht importiert, das bereits vorhandene Symbol wird beibehalten. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Ja alle | Das in der Fehlermeldung genannte Symbol wird beim Import durch das Symbol aus der XML-Datei ersetzt. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Symbole werden ersetzt.
Nein alle | Das in der Fehlermeldung genannte Symbol wird nicht importiert, das bereits vorhandene Symbol wird beibehalten. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Symbole werden beibehalten.

Hinweis: Es wird nur der ShortName verwendet. Der Dateiname spielt für die Benennung des zu importierenden Symbols keine Rolle, kann also zur Konfliktlösung nicht verwendet werden.


Sichtbarkeitsebenen

Handbuch -> Bilder -> Sichtbarkeitsebenen

Ähnlich wie in CAD-Programmen können im Editor Sichtbarkeitsebenen definiert und einzelnen Elementen zugewiesen werden. So lassen sich bei komplexen Bildern nicht benötigte Elemente einfach ausblenden und jederzeit wieder einblenden. 15 Sichtbarkeitsebenen stehen zur Verfügung. Die Zuweisung einer Ebene erfolgt über die Eigenschaft Sichtbarkeitsebene im Knoten Allgemein. Das Aktivieren und Deaktivieren von einzelnen Ebenen erfolgt über die Schaltflächen der Symbolleiste Sichtbarkeitsebenen:

Interne ID: Sichtbarkeitsebenen

Allgemein

Allgemeine Eigenschaften des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Sichtbarkeitsebenen

Sichtbarkeitsebene

Wählen Sie in der Dropdown Liste eine der 16 Sichtbarkeitsebenen (von 0 bis 15) aus. Mit der Symbolleiste Sichtbarkeitsebenen bestimmen Sie, welche Ebenen im Editor angezeigt oder ausgeblendet werden. Dadurch ist gewährleistet, dass auch komplexe Bilder übersichtlich projektiert werden können. Die Ebenen können individuell genutzt werden. Die Ebenen haben keinen Einfluss auf die Vordergrund-/Hintergrundinformation und keinen Einfluss auf die Darstellung in der Runtime.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Symbol (von links nach rechts) | Funktion
Alle Sichtbarkeitsebenen sichtbar machen | Blendet alle Ebenen ein.
Alle Sichtbarkeitsebenen unsichtbar machen | Blendet alle Ebenen aus.
Sichtbarkeitsebene <Nr> | Blendet die entsprechende Sichtbarkeitsebene ein oder aus.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

info Info

Sichtbarkeitsebenen gelten nur für den Editor und haben zur Runtime keine Auswirkung.

Hinweis Kontrollelemente: Kontrollelemente werden zur Runtime immer an an oberster Stelle angezeigt. Das gilt auch, wenn sie im Editor von anderen Elementen überdeckt werden. Damit wird sicher gestellt, dass sie immer erreichbar sind.


Bildtypen

Handbuch -> Bilder -> Bildtypen

Bilder werden in der Grundeinstellung mit dem Bildtyp Standard erzeugt. Über eine Dropdownliste können bei den Eigenschaften eines Bildes spezielle Bildtypen ausgewählt werden.

Interne ID: Bildtypen

Standard

aktiv: Alle C-Geräte an einem B-Gerät werden als sogenannte "C-Schiene" angesehen. Die C-Geräte werden damit nicht mehr direkt ausgewählt, sondern die Datenpunkte auf den C-Geräten werden so behandelt, als würden
sie auf dem B-Gerät liegen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Wird ein Bild vom Typ Standard auf einen speziellen Typ geändert, so ist der neue Bildtyp fest mit dem Bild verbunden und kann nicht mehr geändert werden.

Spezielle Bildtypen

Für spezielle Aufgaben bietet zenon eine Reihe besonderer Bildtypen an. Nach Auswahl eines speziellen Bildtyps stehen im Menü Kontrollelemente alle Bedienelemente für den jeweiligen Bildtyp zur Verfügung. Der Menüpunkt Vorlage einfügen öffnet einen Auswahldialog zum Einfügen vordefinierter Layouts mit bestimmten Kontrollelemente an definierter Position.

info Info

Spezielle Bildtypen müssen auch bei mehrfachem Einsatz nur ein Mal erstellt werden. Über die Filter der Funktion Bildumschaltung können Sie jeweils mit mit verschiedenen Daten geöffnet werden.

Spezielle Bildtypen als Startbild

Jeder Bildtyp kann theoretisch auch als Startbild benutzt werden.

Achtung: Spezielle Bildtypen werden mit leerem Filter und damit ohne Daten aufgeschaltet.

Noch in diesem Kapitel

Spezielle Bildtypen

Bildtypspezifische Funktionen

Bildfilter

HTML

Notizbuch

Video


Spezielle Bildtypen

Handbuch -> Bilder -> Bildtypen -> Spezielle Bildtypen

Spezielle Bildtypen in zenon:

Bildtyp | Beschreibung
Alarmmeldeliste | Sammelt Alarmmeldungen und zeigt sie in Listenform an.
Alarmmeldeliste Filter | Filter für die Alarmmeldeliste.
Archiv-Nachbearbeitung | Tabellarische Darstellung und Editierung von gespeicherten Archivwerten. ACHTUNG: Nur verfügbar mit Lizenz für Archivserver.
Batch | Erstellen von Vorgaben für Masterrezepte im Modul Batch Control. ACHTUNG: Nur verfügbar mit Lizenz für Batch Control.
Befehlsgabe | Darstellung von Befehlsgaben. ACHTUNG: Nur verfügbar mit Lizenz für Energy Edition.
Chronologische Ereignisliste | Sammelt Prozess- und Systemereignisse sowie Benutzervorgaben und stellt sie in Listenform dar.
Chronologische Ereignisliste Filter | Filter für die Chronologische Ereignisliste.
Energy Management System | Planung und Darstellung von Energiebezugsmanagement (Strom, Gas). ACHTUNG: Nur verfügbar mit Lizenz für Energy Managment System. Hinweis: Steht unter Windows CE nicht zur Verfügung.
Erweiterter Trend | Stellt Online- und Archivwerte als Liniengrafiken dar.
Höchstlastprognose | Bild zur Darstellung der Höchstlastprognose. ACHTUNG: Nur verfügbar mit Lizenz für SICAM 230.
HTML | Ermöglicht die Darstellung eines Bildes in HTML, angepasst an den Microsoft Internet-Explorer.
Industrial Maintenance Manager | Darstellung von Wartungsinformationen. ACHTUNG: Nur verfügbar mit Lizenz für Industrial Maintenance Manager. Hinweis: Steht unter Windows CE nicht zur Verfügung.
Industrial Performance Analyzer | Wertet Alarme aus, um Schwachstellen (Stillstandszeiten) einer Anlage zu lokalisieren. Hinweis: Steht unter Windows CE nicht zur Verfügung.
Keyboard | Erzeugt eine frei definierbare virtuelle Tastatur.
Login | Individuelle Gestaltung eines Login-Fensters.
Message Control | Bild zur Verwaltung der Message Queue in Message Control.
Notizbuch | Gibt Protokollen und Textdateien, die aus Datenbankabfragen erstellt werden bzw. als Textdateien vorhanden sind, aus.
Production & Facility Scheduler | Verwaltet Fahrpläne und Profile. ACHTUNG: Nur verfügbar mit Lizenz für Production & Facility Scheduler (PFS).
Report Generator | Zur Ausgabe von Protokollen, die mittels des erweiterten Report Generators erstellt wurden. ACHTUNG: Nur verfügbar mit Lizenz für Report Generator. Sollen Reports nur angezeigt und nicht editiert werden, ist für die Runtime keine Lizenz nötig.
Report Viewer | Dient der Anzeige von RDL-Reports für Archiv-, AML-, CEL- und Online-Werte. ACHTUNG: Nur verfügbar mit Lizenz für Reporting.
Rezeptgruppen-Manager | Verwaltet Rezepte und deren Verwendung innerhalb von Rezeptgruppen. ACHTUNG: Nur verfügbar mit Lizenz für Rezeptgruppen Manager (RGM).
S7-Graph | Wird für sequentielle Abläufe mit alternativen oder parallelen Schrittfolgen (SFC) verwendet. Stellt zur Runtime den momentanen Zustand der Ablaufsteuerung in der SPS direkt dar.
Standard-Rezepte | Zur Verwaltung von Rezepten.
Variablen-Diagnose | Zur Darstellung von Variablen in der Runtime und Absetzung von Sollwerten. Hinweis: Steht unter Windows CE nicht zur Verfügung.
Video | Zur Darstellung von Online- und gespeicherten Videoaufnahmen (*.avi). Hinweis: Steht unter Windows CE nicht zur Verfügung.
Weltbild-Übersicht | Ermöglicht es, Standardbilder, die größer sind als die Bildschirmauflösung, mit der Maus zu scrollen.
Zeitfilter | Ermöglicht generelle Filtereinstellungen für Listen. Welche Listen damit gesteuert werden, wird in der Funktion Bildumschaltung festgelegt.

Noch in diesem Kapitel

Anlegen spezieller Bildtypen

Vorlagen für Standardbilder und spezielle Bildtypen


Anlegen spezieller Bildtypen

Handbuch -> Bilder -> Bildtypen -> Spezielle Bildtypen -> Anlegen spezieller Bildtypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen speziellen Bildtyp anzulegen:

  1. erstellen Sie ein neues Bild oder wählen Sie ein vorhandenes Bild vom Typ Standard
  2. klicken Sie in den Eigenschaften im Knoten Allgemein bei Bildtyp auf den vordefinierten Typ Standard

    Interne ID: Anlegen spezieller Bildtypen

    Bildtyp

    Standard: Bildtyp für die Erstellung von Prozessbildern. Alle vektoriellen and dynamischen Elemente können verwendet werden.
    Spezielle Bildtypen: Bilder, die nicht vom Bildtyp "Standard" sind, müssen nur einmal erstellt werden und können über spezielle Filtereinstellungen der Funktion Bildumschaltung jeweils mit verschiedenen Daten geöffnet werden. Sobald ein spezieller Bildtyp ausgewählt wurde, stehen im Menü Kontrollelemente die entsprechenden Bedienelemente für den Bildtyp zur Verfügung.

    Achtung: Sobald der Bildtyp von Standard auf einen speziellen Bildtyp geändert wurde, ist er fixiert und kann nicht weiter geändert werden.

    Default: Standard

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Anlegen spezieller Bildtypen

    Allgemein

    Allgemeine Eigenschaften des Bildes.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Alternativ: Klicken Sie in der Detailansicht Bilder auf den Bildtyp des Bildes und wählen Sie aus der Dropdownliste den gewünschten Bildtyp

  3. wählen Sie aus der Dropdownliste den gewünschten Bildtyp
  4. wählen Sie im Menü Kontrollelemente die gewünschten Kontrollelemente
    • Vorlage einfügen öffnet einen Auswahldialog zum Einfügen vordefinierter Layouts mit bestimmten Kontrollelemente an definierter Position
    • Elemente, die im Bild bereits vorhanden sind, werden grau dargestellt und können nicht mehr ausgewählt werden

info Info

Einschränkung für automatisches Einfügen der Vorlagen:

Befindet sich bereits ein statisches Element, zum Beispiel ein Kontrollelement, im Bild, werden beim Einfügen der Kontrollelemente aus der Vorlage keine Rahmen und keine Rahmenbeschriftungen erzeugt.

Empfehlung: Fügen Sie nach dem Anlegen eines speziellen Bildtyps im ersten Schritt die Kontrollelemente aus der Vorlage ein und erst danach weitere Elemente.


Vorlagen für Standardbilder und spezielle Bildtypen

Handbuch -> Bilder -> Bildtypen -> Spezielle Bildtypen -> Vorlagen für Standardbilder und spezielle Bildtypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für spezielle Bildtypen wie auch Standardbilder können Vorlagen zum automatischen Einfügen und Positionieren von Elementen verwendet werden. Vorlagen können aus jedem Bild selbst erstellt werden. Für die speziellen Bildtypen werden auch vorgefertigte Vorlagen mit zenon ausgeliefert.

Vorlagen werden in komprimierten ZIP-Dateien abgelegt, die jeweils drei weitere Dateien enthalten:

  • Metadaten: XML-Datei mit der Beschreibung der Vorlage (Name, Beschreibung, Größe, usw.).
  • Bildelemente: XML-Datei mit den exportierten Elementen eines Bildes.
  • Vorschau: Bitmap-Datei mit der Vorschau der Vorlage.

Mitgelieferte Vorlage

Die mitgelieferten Vorlagen stehen in verschiedenen Auflösungen sowie optimiert für Touchscreen zur Verfügung. Diese Vorlagen können weder verändert noch gelöscht werden. Von COPA-DATA vordefinierte Vorlagen werden im Programmordner abgelegt unter: \Templates\ScreenTypes\<Name für den Bildtyp>\<Dateiname>.zip.

Benutzerdefinierte Vorlagen

Benutzer können für jeden Bildtyp eigene Vorlagen erstellen und speichern. Diese können auch bearbeitet und gelöscht werden.

Benutzerdefinierte Vorlagen werden im zenon Datenordner abgelegt unter: Templates\ScreenTypes\<Name für den Bildtyp>\<Dateiname>.zip.
Z.B.: %ProgramData%\COPA-DATA\zenon700\Templates\ScreenTypes\Alarm Message List\3e9afbcf-f93d-46d9-a199-e00effe4811c.zip.

Hinweis: Der Pfad hängt davon ab, ob er bei der Installation oder über das Startup Tool registriert wurde. Ist das nicht der Fall, wird als Datenordner der aktuelle Programmordner verwendet.

Noch in diesem Kapitel

Vorlagen verwenden

Vorlagen erstellen


Vorlagen verwenden

Handbuch -> Bilder -> Bildtypen -> Spezielle Bildtypen -> Vorlagen für Standardbilder und spezielle Bildtypen -> Vorlagen verwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Vorlagen für ein Bild zu verwenden:

  1. öffnen Sie das Bild
  2. wählen Sie im Menü Kontrollelemente den Befehl Vorlage auswählen
  3. der Dialog mit den vordefinierten und benutzerdefinierten Vorlagen wird geöffnet

    Hinweis: für Bilder vom Typ Standard stehen nur benutzerdefinierte Vorlagen zur Verfügung

  4. wählen Sie die gewünschte Vorlage
  5. klicken Sie auf Übernehmen
  6. die in der Vorlage definierten Elemente werden an den vordefinierten Positionen eingefügt

Parameter | Beschreibung
Listenfeld Vorlagen (links) | Zeigt alle vordefinierten und benutzerdefinierten Vorlagen an.
Vorschau auf Vorlage (rechts oben) | Vorschau auf das Bild bei Übernahme der gewählten Vorlage.
Beschreibung Vorlage (rechts unten | Beschreibung der Vorlage.
Bestehende Bildelemente löschen | Aktiv: Bereits bestehende Elemente im Bild werden bei Übernahme der Vorlage gelöscht.
Übernehmen | Fügt die Element der gewählten Vorlage in das Bild ein und schließt den Dialog.
Abbrechen | Schließt Dialog, ohne Elemente einzufügen.
Hilfe | Öffnet die Online-Hilfe.


Vorlagen erstellen

Handbuch -> Bilder -> Bildtypen -> Spezielle Bildtypen -> Vorlagen für Standardbilder und spezielle Bildtypen -> Vorlagen erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ordner und Vorlagen können für benutzerdefinierte vorlagen neu erstellt, gelöscht, umbenannt und verschoben werden. Mitgelieferte, vordefinierte Vorlagen können weder bearbeitet noch gelöscht werden.

Ordner oder Vorlagen erstellen

Um einen Ordner zu erstellen, wählen Sie :

  • im Dialog die Schaltfläche Order neu
  • oder im Kontextmenü den Befehl Order neu
  • oder benutzen Sie die Schaltfläche Einfg

Um eine Vorlage zu erstellen:

  1. markieren Sie in der Detailansicht das gewünschte Bild
  2. wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl Vorlage für Bildtyp erzeugen
  3. der Dialog zum Erstellen eigener Vorlagen wird geöffnet
  4. wählen Sie einen vorhandenen Ordner aus oder erstellen Sie einen neuen
  5. vergeben Sie einen Namen für die neue Vorlage
  6. fügen Sie optional eine Beschreibung hinzu
  7. bestätigen Sie mit OK
  8. die Vorlage wird im markierten Ordner hinzugefügt

Parameter | Beschreibung
Listenfeld Vorlagen (links) | Zeigt alle vordefinierten und benutzerdefinierten Vorlagen an. Ermöglicht über das Kontextmenü Ordner und Vorlagen zu löschen oder umzubenennen und Ordner hinzuzufügen.
Vorschau auf Vorlage (rechts oben) | Vorschau auf das Bild bei Übernahme der gewählten Vorlage.
Beschreibung Vorlage (rechts unten | Beschreibung der Vorlage.
Ordner neu | Erstellt neuen Ordner. Es können mehrere Ebenen angelegt werden.
Löschen | Löscht nach einer Sicherheitsabfrage ausgewählten Ordner mit allen Unterordnern.
OK | Erstellt Vorlage und schließt Dialog.
Abbruch | Schließt Dialog, ohne Vorlage zu erstellen.
Hilfe | Öffnet die Online-Hilfe.

Ordner löschen

Um einen Ordner oder eine Vorlage zu löschen:

  1. markieren Sie den Ordner oder die Vorlage
  2. wählen Sie
    1. im Dialog die Schaltfläche Löschen
    2. oder im Kontextmenü den Befehl Löschen
    3. oder benutzen Sie die Taste Entf

Der Ordner oder die Vorlage wird nach einer Sicherheitsabfrage gelöscht. Bei Ordnern werden eventuelle Unterordner mit allen enthaltenen Vorlagen gelöscht.

Ordner oder Vorlagen umbenennen

Um einen Ordner oder eine Vorlage umzubenennen:

  • wählen Sie im Kontextmenü den Befehl Umbenennen
  • oder markieren Sie das Element und öffnen mit der Taste F2 die Beschriftung zur Bearbeitung
  • oder ändern Sie bei Vorlagen den Text im Feld Name

Ordner oder Vorlagen verschieben

Ordner und Vorlagen können per Drag & Drop mit der Maus in andere Ordner verschoben werden.

Noch in diesem Kapitel

Kontextmenü Vorlage für Bildtyp erstellen


Kontextmenü Vorlage für Bildtyp erstellen

Handbuch -> Bilder -> Bildtypen -> Spezielle Bildtypen -> Vorlagen für Standardbilder und spezielle Bildtypen -> Vorlagen erstellen -> Kontextmenü Vorlage für Bildtyp erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Kontextmenü Vorlage für Bildtyp erstellen

Im Dialog zum Erstellen neuer Vorlagen stehen auch Kontextmenüs zur Verfügung.

Kontextmenü für Ordner

Parameter | Beschreibung
Ordner neu | Erstellt einen neuen Ordner unterhalb der markierten Ebene.
Löschen | Löscht den markierten Ordner nach einer Sicherheitsabfrage.
Umbenennen | Öffnet die Ordnerbeschriftung zum Umbenennen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü für Vorlagen

Parameter | Beschreibung
Löschen | Löscht die markierte Vorlage nach einer Sicherheitsabfrage.
Umbenennen | Öffnet die Vorlagenbeschriftung zum Umbenennen.
Hilfe | Öffnet die Online-Hilfe.


Bildtypspezifische Funktionen

Handbuch -> Bilder -> Bildtypen -> Bildtypspezifische Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wird in einem Bild mit einem speziellen Bildtyp ein Dynamisches Element vom Typ Button erstellt, steht in den Eigenschaften im Knoten Variable / Funktion verfügt die zusätzliche Eigenschaft Bildtypspezifische Funktion zur Verfügung. Damit lassen sich dem Button spezielle, auf den Bildtyp ausgerichtete Funktionen zuordnen.

Interne ID: Bildtypspezifische Funktionen

Bildtypspezifische Funktion

Nur verfügbar in Bildern mit einem speziellen Bildtyp (Bildtyp ist nicht "Standard"):
Name der verknüpften Bildtyp-spezifischen Funktion.
Öffnet den Dialog zur Auswahl von Bildtyp-spezifischen Funktionen.
Statt einer allgemeinen Funktion kann eine speziell auf den Bildtyp abgestimmte Funktion verknüpft werden. Diese Funktion wird ausgeführt, wenn der Button in der Runtime mit der Maus angeklickt oder die verknüpfte Tastenkombination gedrückt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bildtypspezifische Funktionen

Variable / Funktion

Eigenschaften für die mit dem Element verknüpfte Variable oder Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zum Beispiel im Erweiterten Trend:


Bildfilter

Handbuch -> Bilder -> Bildtypen -> Bildfilter

Mithilfe der Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter und Zeitfilter wird Ihnen der Bildfilter-Dialog angezeigt.

Mit den Bildfiltern haben Sie die komfortable Möglichkeit individuelle Filterseiten zu gestalten. Sie müssen dazu nicht die vordefinierten zenon Dialoge verwenden sondern können Sich eigene Filterdialoge zusammenstellen. Diese können Sie nach Gesichtspunkten wie Touchbedienbarkeit, Filterung nur von speziellen Bereichen, Sprachumschaltbarkeit usw. gestalten.

Noch in diesem Kapitel

Dialog Bildfilter

Bild vom Typ Alarmmeldeliste Filter anlegen

Bild vom Typ CEL Filter anlegen

Bild vom Typ Zeitfilter


Dialog Bildfilter

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Dialog Bildfilter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Dialog nehmen Sie grundlegende Einstellungen vor. Diese Einstellungen beeinflussen die Werte, die beim Aufschalten der zugehörigen Filterbilder in der Runtime dargestellt werden.

info Info

Nicht alle Registerkarten sind für alle Bildfiltertypen vorhanden.

Noch in diesem Kapitel

Bilder

Allgemein

Text

Zeit


Bilder

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Dialog Bildfilter -> Bilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Registerkarte definieren Sie die Bilder, die durch den Bildfilter aktualisiert werden sollen.

Folgende Einstellungen stehen Ihnen zur Verfügung:

Parameter

Beschreibung

Filter wird aus folgendem Bild übernommen

Aufrufendes Bild

Aktiv: Die Filtereinstellungen werden aus dem Bild übernommen, möchten, aus dem das Filterbild aufgerufen wird. Die Schaltfläche Bild ist ausgegraut. Sie können kein Bild explizit angeben, da bei dieser Einstellung die Filteraktualisierung immer vom aufrufenden Bild aus erfolgt.

Hinweis: Einstellungen in den Registerkarten Allgemein, Text und Zeit sind gesperrt.

Bildauswahl

Klick auf Schaltfläche öffnet den Bildauswahldialog.

Selektieren Sie das Bild, von dem der Filter - beim Betätigen des Buttons Aktualisieren in der Runtime - gelesen werden soll.

Hinweis: Es ist nur sinnvoll ein Bild zu selektieren, das den Bildfilter übernehmen bzw. füllen kann.

Das selektierte Bild wird in die Liste der zu aktualisierenden Bilder eingetragen. Wenn Sie es aus der Liste löschen, wird automatisch das nächste Bild aus der Liste hier eingetragen.

Hinweis: Nicht verfügbar, wenn Sie die Checkbox Aufrufendes Bild aktiviert haben.

Zu aktualisierende Bilder

Bildauswahl

Klick auf Schaltfläche öffnet Dialog zur Bildauswahl der Filterbilder. Wählen Sie die gewünschten Bilder.

Aktualisierung

Auf allen Monitoren aktualisieren

Aktiv: Die Bilder aus der Liste der zu aktualisierenden Bilder werden auf allen verfügbaren Monitoren aktualisiert.


Allgemein

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Dialog Bildfilter -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Registerkarte ist nur für Alarmmeldeliste und Chronologische Ereignisliste und verfügbar, und zeigt die Standard-Filter für die jeweilige Liste an. Siehe Alarmmeldeliste Filter bzw. Chronologische Ereignisliste Filter.

AML

Parameter

Beschreibung

Variablenfilter

Einschränkung auf Alarme bestimmter Variablen

Variablenname

Geben Sie den Namen oder den Teil des Namens von Variablen an, nach dem Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Kennung

Geben Sie die Kennung oder die Teilkennung von Variablen an, nach der Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Groß-/Kleinschreibung beachten

Aktiv: Groß- und Kleinschreibung wird bei der Filterung nach Variablenname und/oder Kennung beachtet.

Alarmart

Art der Alarme, die angezeigt werden.

Nur nicht quittierte Alarme

Aktiv: Es werden nur Alarme angezeigt, die vom Benutzer noch nicht quittiert wurden.

Nur gegangene Alarme

Aktiv: Es werden nur Alarme angezeigt, die schon gegangen sind; d.h. deren Werte nicht mehr im kritischen Bereich sind.

Nur anstehende Alarme

Aktiv: Es werden nur Alarme angezeigt, die noch anstehen; d.h. deren Werte sich noch im kritischen Bereich befinden.

Alarme müssen mindestens anstehen

Definieren Sie mithilfe der Spincontrols wie lange ein Alarm mindestens anstehen muss, damit er angezeigt wird. Mögliche Einstellungen:

  • Tage
  • Stunden (Std.)
  • Minuten (Min.)
  • Sekunden (Sek.)
  • Millisekunden (ms)

Datenherkunft

Anzeige aktueller oder aktueller und historischer Alarme.

Ringpuffer

Aktiv: Es werden nur Daten aus dem Ringpuffer angezeigt.

Historische Daten
Maximale Anzahl

Aktiv: Es werden Daten aus dem Ringpuffer und historische Daten aus der AML angezeigt.

Die maximale Anzahl der anzuzeigenden Daten inkludiert die Daten aus dem Ringpuffer.

Runtime-Einstellungen

Verhalten der AML zur Runtime

Liste angehalten aufschalten

Aktiv: Solange die Liste angezeigt wird, werden keine neuen Einträge hinzugefügt.

Alarm/Ereignis-Gruppen/Klassen, Alarmbereiche

Auswahl von Gruppen, Klassen und Alarmbereichen.

Alarm/Ereignis-Gruppen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Gruppen jene aus, aus denen Alarme angezeigt werden sollen.

Alarm/Ereignis-Klassen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Klassen jene aus, aus denen Alarme angezeigt werden sollen.

Alarmbereiche

Wählen Sie aus den vorhandenen Alarmbereichen jene aus, aus denen Alarme angezeigt werden sollen.


Text

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Dialog Bildfilter -> Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Registerkarte definieren Sie Standardwerte für die Textfilterung. Nur verfügbar für Alarmmeldeliste Filter und Chronologische Ereignisliste Filter.

Parameter | Beschreibung
Filtern nach |
Kein Textfilter | Der Textfilter wird nicht verwendet.
Suche nach (Wörter getrennt durch Leerzeichen) | Der Textfilter wird verwendet. Die weiteren Optionen sind freigeschalten.
Eingabefeld | Geben Sie die entsprechenden Wörter bzw. Zeichenketten ein.
Optionen |
Groß-/Kleinschreibung beachten | Aktiv: Beim Filtern wird zwischen Groß- und Kleinschreibung unterschieden.
Wörter müssen nicht vollständig im Text vorkommen | Aktiv: Auch Wortteile werden beim Filtern berücksichtigt.
Mindestens ein Wort muss im Text vorkommen | Aktiv: Mindestens ein Wort des Suchstrings muss im Text vorkommen.
Alle Wörter müssen im Text vorkommen | Aktiv: Alle Wörter des Suchstrings müssen im Text vorkommen. Die Reihenfolge spielt dabei keine Rolle.
Filtertext muss exakt im Text vorkommen | Aktiv: Der Text muss exakt wie im Suchstring definiert im vorkommen.


Zeit

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Dialog Bildfilter -> Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Definieren Sie auf dieser Registerkarte den Zeitbereich, der beim Öffnen des Filterbilds verwendet werden soll.

Folgende Einstellungen stehen Ihnen zur Verfügung:

Parameter

Option

Beschreibung

Absoluter Zeitraum

Es wird ein fixer Zeitbereich im Editor vorgegeben. Beim Ausführen der Funktion wird genau der eingestellte absolute Zeitbereich verwendet.
Beispiel: Sie möchten alle Alarme vom 1.1.2011 - 31.12.2011 sehen, dann geben Sie die entsprechenden Daten bei Von und Bis an.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Von

Definiert den Startzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Bis

Definiert den Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Relativer Zeitraum

Es wird ein relativer Zeitbereich angegeben.

Achtung! Dieser Filter wird ständig aktualisiert. Er wandert also mit.

Zum Beispiel: Sie stellen eine relative Zeit von 10 Minuten ein und schalten um 12:00 Uhr ein Bild vom Typ Alarmmeldeliste mit diesem Zeitfilter auf. Dann werden Ihnen beim Aufschalten die Alarme von 11:50 bis 12:00 angezeigt. Wenn das Bild vom Typ Alarmmeldeliste geöffnet bleibt, wird der Filter automatisch aktualisiert. Um 12:01 sehen Sie die Alarme von 11:51-12:01 usw.

Zeit

Definiert den relativen Zeitraum in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab HH:MM:SS Uhr

Es wird eine Uhrzeit angegeben, ab dem der Filter wirkt. Ist die Uhrzeit am heutigen Tag noch nicht erreicht, wird ab der entsprechenden Uhrzeit des Vortages gefiltert.

Beispiel: Sie geben 23:00:00 ein. Ist es bei der Ausführung der Funktion 23:30 Uhr, dann wird von 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist es jedoch 22:30 Uhr, dann wird vom Vortag 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag - HH:MM:SS Uhr

Es werden ein Tag und eine Uhrzeit für den Filterbeginn angegeben. Ist die angegebene Zeit im laufendem Monat noch nicht erreicht, wird die entsprechende Zeit des Vormonats verwendet.

Beispiel: Sie geben Tag 5 - 23:00:00 ein. Ist es bei der Ausführung der Funktion der 10. des Monats um 23:30 Uhr , dann wird vom 5. des Monats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. des Monats, dann wird vom 5. des Vormonats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filter wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag, Monat - HH:MM:SS Uhr

Es werden ein Monat, ein Tag und eine Uhrzeit für den Filterbeginn eingegeben. Ist die angegebene Zeit im laufenden Jahr noch nicht erreicht, wird die entsprechende Zeit des Vorjahres verwendet.

Beispiel: Sie geben Monat Oktober, Tag 5 - 23:00:00 ein. Ist bei der Ausführung der Funktion der 10. Oktober um 23:30 Uhr, dann wird vom 5. Oktober ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. Oktober, dann wird vom 5. Oktober des Vorjahres ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und der 5. Oktober 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Monaten, Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Kein Zeitfilter

Es wird kein Zeitfilter verwendet.


Bild vom Typ Alarmmeldeliste Filter anlegen

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Bild vom Typ Alarmmeldeliste Filter anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ Alarmmeldeliste Filter ermöglicht es, zur Runtime individualisierte Filtereinstellungen für die Alarmmeldeliste vorzunehmen. Es werden nur die benötigen Filter projektiert und dem Benutzer zur Verfügung gestellt. Das Aussehen lässt sich frei definieren und damit an unterschiedliche Endgeräte anpassen. Es können alle Filtereinstellungen, die auch im Filter für die Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste vorhanden sind, projektiert werden.

Damit:

  • werden nur die wirklich benötigten Filterelemente projektiert und dem Benutzer zur Verfügung gestellt
  • bekommt der Benutzer nur diese Filter angezeigt und gewinnt Übersicht
  • kann das Aussehen völlig frei definiert werden und so zum Beispiel auch eine leichte Bedienung über einen Touchscreen realisiert werden

Details zur Handhabung zur Runtime, siehe Abschnitt Alarmmeldeliste Filter benutzen.

Definition der Filterkriterien, siehe Abschnitt Filter Alarmmeldeliste Filter.

attention Achtung

Bilder vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter und Zeitfilter müssen mit einer eigenen Schablone projektiert werden. Besitzen sie die gleiche Schablone wie andere Bilder werden zur Runtime beim Schließen des Bildes alle auf dieser Schablone basierenden Bilder ebenfalls geschlossen.

Bild vom Typ Alarmmeldeliste Filter anlegen

Um ein Bild vom Typ Alarmmeldeliste Filter anzulegen:

  1. wählen Sie in der Symbolleiste oder im Kontextmenü des Knotens Bilder den Befehl Bild neu
  2. ein leeres Bild vom Typ Standard wird aufgeschaltet
  3. ändern Sie in der Detailansicht den Bildtyp, dazu
    1. klicken Sie in der Spalte Bildtyp auf Standard
    2. wählen Sie in der Dropdownliste den Eintrag Alarmmeldeliste Filter aus
  4. wählen Sie eine eigene Schablone
    (AML Filter darf nicht auf derselben Schablone wie andere Bilder basieren)
  5. klicken Sie in das Bild
  6. wählen Sie in der Menüleiste den Menüpunkt Kontrollelemente
  7. klicken Sie in der Dropdownliste auf Vorlage einfügen
  8. der Dialog zur Auswahl einer Vorlage wird geöffnet
  9. wählen Sie die gewünschte Vorlage aus
  10. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diesen am gewünschten Platz im Bild ein
  11. legen Sie eine Bildumschaltfunktion an, um das Bild zur Runtime aufrufen zu können

Elemente

Das Bild vom Typ Alarmmeldeliste Filter kann folgende Steuer- und Anzeigeelemente enthalten.

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Allgemeine Filter

Dropdownliste verschiedener allgemeiner Filter.

Alle Elemente einfügen: Allgemeine Filter

Fügt alle Elemente aus dem Bereich Allgemeine Filter an vordefinierten Plätzen ein. Elemente können individuell angeordnet werden.

Variablenfilter

Alarme welcher Variablen werden angezeigt:
  • Variablenname

Filtern nach Namen der Variablen.
  • Kennung

Filtern nach Kennung der Variablen.
  • Groß-/Kleinschreibung beachten

Groß- und Kleinschreibung bei der Filterung der Variablen beachten.

Alarmart

Welche Alarme werden angezeigt:
  • Nur nicht quittierte Alarme

nur nicht quittierte
  • Nur gegangene Alarme

nur gegangene
  • Nur anstehende Alarme

nur anstehende
  • Kommentar erforderlich

Alarme, deren Quittierung einen Kommentar erfordert
  • Mindestzeit anstehende Alarme - Tage

Nur Alarme, die mindestens seit der angegeben Zahl von Tagen anstehen.
  • Mindestzeit anstehende Alarme - Stunden

Nur Alarme, die mindestens seit der angegeben Zahl von Stunden anstehen.
  • Mindestzeit anstehende Alarme - Minuten

Nur Alarme, die mindestens seit der angegeben Zahl von Minuten anstehen.
  • Mindestzeit anstehende Alarme - Sekunden

Nur Alarme, die mindestens seit der angegeben Zahl von Sekunden anstehen.
  • Mindestzeit anstehende Alarme - Millisekunden

Nur Alarme, die mindestens seit der angegeben Zahl von Millisekunden anstehen.

Datenherkunft

Woher stammen die Daten:
  • Ringpuffer

Aus dem Ringpuffer.
  • Historische Daten

Aus einem Archiv.
  • Beschriftung: Maximale Anzahl

Text für Eingabefeld Maximale Anzahl

  • Eingabefeld: Maximale Anzahl

Eingabe der maximal anzuzeigenden Alarme bei Anzeige historischer Alarme.

0: zeigt alle an

Runtime Einstellungen

  • Liste angehalten aufschalten

Schaltet die AML in angehaltenem Zustand auf. Neue Alarme werden nicht hinzugefügt.

Alarm/Ereignis-Gruppen/Alarm/Ereignis-Klassen/Alarmbereiche

Listenfelder für gruppierte Anzeige:
  • Alarm/Ereignis-Gruppen

Alarm/Ereignis-Gruppen
  • Alarm/Ereignis-Klassen

Alarm/Ereignis-Klassen
  • Alarmbereiche

Alarmbereiche

Zeitfilter

Dropdownliste verschiedener Zeitfilter.

Alle Elemente einfügen: Absoluter Zeitraum - klassische Darstellung

Fügt alle Elemente für die Definition absoluter Zeiträume ein: Jedes Element erhält ein eigenes Feld.

Alle Elemente einfügen: Absoluter Zeitraum - kleine Darstellung

Fügt Elemente für die Definition absoluter Zeiträume in kompakter Darstellung ein.

Alle Elemente einfügen: Relativer Zeitraum

Fügt alle Elemente für die Definition relativer Zeiträume ein.

Alle Elemente einfügen: Ab HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag, Monat - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Monat-Stunden-Minuten-Sekunden ein.

Beschriftung: Zeitfiltertyp

Beschriftung für Typ des Zeitfilters.

Combobox: Zeitfiltertyp

Combobox Zeitfilterty.

Anzeige: Zeitfiltertyp

Feld für Anzeige Zeitfiltertyp.

Zeit von

Felder und Beschriftungen für Angaben "Von"-Zeit.
  • Beschriftung: Von Jahr

  • Combobox: Von Jahr

  • Beschriftung: Von Monat

  • Combobox: Von Monat

  • Beschriftung: Von Tag

  • Combobox: Von Tag

  • Beschriftung: Von Stunde

  • Combobox: Von Stunde

  • Beschriftung: Von Minute

  • Combobox: Von Minute

  • Beschriftung: Von Sekunde

  • Combobox: Von Sekunde

  • Spincontrol: Von

Zeit bis

Felder und Beschriftungen für Angaben "Bis"-Zeit.
  • Beschriftung: Bis Jahr

  • Combobox: Bis Jahr

  • Beschriftung: Bis Monat

  • Combobox: Bis Monat

  • Beschriftung: Bis Tag

  • Combobox: Bis Tag

  • Beschriftung: Bis Stunde

  • Combobox: Bis Stunde

  • Beschriftung: Bis Minute

  • Combobox: Bis Minute

  • Beschriftung: Bis Sekunde

  • Combobox: Bis Sekunde

  • Spincontrol: Bis

Absolutzeitfilter

Felder und Beschriftungen für Angaben absoluter Zeitfilter.
  • Beschriftung: Von

  • Kalenderanzeige: Von Datum

  • Datumsanzeige: Von Datum

  • Zeitanzeige: Von Zeit

  • Beschriftung: Bis

  • Kalenderanzeige: Bis Datum

  • Datumsanzeige: Bis Datum

  • Zeitanzeige: Bis Zeit

Textfilter

Dropdownliste verschiedener Textfilter.

Alle Elemente einfügen: Textfilter

Fügt alle Elemente für Textfilter ein.

Kein Textfilter

Radiobutton für Abwahl Textfilter.

Suchen nach (Wörter getrennt durch Leerzeichen)

Radiobutton für Aktvierung der Suche

Beschriftung: Suchtext

Beschriftung für Suchfeld.

Eingabefeld: Suchtext

Feld für Eingabe der Suchbegriffe.

Optionen

Optionen für Suche
  • Groß-/Kleinschreibung beachten

Groß-/Kleinschreibung muss beachtet werden.
  • Wörter müssen nicht vollständig im Text vorkommen

Es wird auch nach Fragmenten gesucht.
  • Mindestens ein Wort muss im Text vorkommen

Mindestens ein Suchbegriff von mehreren muss im Ergebnis enthalten sein.
  • Alle Wörter müssen im Text vorkommen

Alle Suichbegriffe müssen im Ergebnis enthalten sein.
  • Filtertext muss exakt im Text vorkommen

Text aus dem Eingabefeld muss exakt im ergebnis enthalten sein.

OK

Eingaben übernehmen und Bild schließen.

Abbrechen

Eingaben verwerfen und Bild schließen.

Übernehmen

Eingaben übernehmen und bild für weitere Eingaben geöffnet lassen.

Aktualisieren

Bild aktualisieren.

Filterbilder

Filterbilder ermöglichen es, einen voreingestellten Filter von einem Bild auf ein anderes zu übertragen. Der Filter des Quellbildes wird über das Zielbild gelegt. Die Bilder können auch von unterschiedlichen Bildtypen sein.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.

Aufrufdefinition

Folgende Voraussetzungen müssen erfüllt sein, damit die eingestellten Filter zur Anwendung kommen:

  1. Als Zeitbereich beim Zeitfilter wird Filter beim Zeitfiltertyp einstellen gewählt.
  2. Das Bild (Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter oder Zeitfilter) wird mithilfe eines Buttons oder eines Combi-Elements aktiviert. Nur so wird der Bezug zwischen Filterbild und Quellbild gewährleistet.
  3. Das Quellbild und das Filterbild müssen auf unterschiedlichen Schablonen oder Monitoren projektiert sein. Nur wenn das Quellbild offen ist, kann der Filter für das Filterbild aktualisiert werden. Das ist nur möglich, wenn beide Bilder nicht dieselbe Schablone oder den selben Monitor verwenden.
  4. Das aufrufende Bild muss mit dem aufzurufenden Filterbild kompatibel sein (siehe Tabelle).
Quellbild | AML Filter | CEL Filter | Zeitfilter
Archiv-Nachbearbeitung | T | T | T
Erweiterter Trend | T | T | T
Zeitfilter | T | T | X
Alarmmeldeliste Filter | X | C | T
Chronologische Ereignisliste Filter | C | X | T
Alarmmeldeliste | X | C | T
Chronologische Ereignisliste | C | X | T

Legende:

  • C: Gemeinsame Einstellungen werden aktualisiert.
  • T: Zeiteinstellungen werden aktualisiert.
  • X: Alle Einstellungen werden aktualisiert.

info Info

Keine Filterung

Das Filterbild wird nicht gefiltert, sondern mit den projektierten Werten aufgeschaltet, wenn:

  • eine der Bedingungen 1 bis 3 nicht erfüllt wird oder
  • die Einstellung Aufrufendes Bild bei der Funktion Bildumschaltung nicht aktiviert ist oder
  • das Bild nicht über ein Bildelement aufgerufen wird

In diesem Fall werden zur Runtime die Buttons Übernehmen, Schließen und Aktualisieren ausgegraut dargestellt und haben keine Funktion.


Bild vom Typ CEL Filter anlegen

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Bild vom Typ CEL Filter anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ Chronologische Ereignisliste Filter ermöglicht es, zur Runtime individualisierte Filtereinstellungen für die Chronologische Ereignisliste vorzunehmen. Es werden nur die benötigen Filter projektiert und dem Benutzer zur Verfügung gestellt. Das Aussehen lässt sich frei definieren und damit an unterschiedliche Endgeräte anpassen. Es können alle Filtereinstellungen, die auch im Filter für die Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste vorhanden sind, projektiert werden.

Damit:

  • werden nur die wirklich benötigten Filterelemente projektiert und dem Benutzer zur Verfügung gestellt
  • bekommt der Benutzer nur diese Filter angezeigt und gewinnt Übersicht
  • kann das Aussehen völlig frei definiert werden und so zum Beispiel auch eine leichte Bedienung über einen Touchscreen realisiert werden

Details zur Handhabung zur Runtime, siehe Abschnitt CEL Filter benutzen .

Definition der Filterkriterien, siehe Abschnitt Filter für Bildumschaltung CEL Filter.

attention Achtung

Bilder vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter und Zeitfilter müssen mit einer eigenen Schablone projektiert werden. Besitzen sie die gleiche Schablone wie andere Bilder werden zur Runtime beim Schließen des Bildes alle auf dieser Schablone basierenden Bilder ebenfalls geschlossen.

Bild vom Typ Chronologische Ereignisliste Filter anlegen

Um ein Bild vom Typ Chronologische Ereignisliste Filter anzulegen:

  1. wählen Sie in der Symbolleiste oder im Kontextmenü des Knotens Bilder den Befehl Bild neu
  2. ein leeres Bild vom Typ Standard wird aufgeschaltet
  3. ändern Sie in der Detailansicht den Bildtyp, dazu
    1. klicken Sie in der Spalte Bildtyp auf Standard
    2. wählen Sie in der Dropdownliste den Eintrag Chronologische Ereignisliste Filter aus
  4. wählen Sie eine eigene Schablone
    (CEL Filter darf nicht auf derselben Schablone wie andere Bilder basieren)
  5. klicken Sie in das Bild
  6. wählen Sie in der Menüleiste den Menüpunkt Kontrollelemente
  7. klicken Sie in der Dropdownliste auf Vorlage einfügen
  8. der Dialog zur Auswahl einer Vorlage wird geöffnet
  9. wählen Sie die gewünschte Vorlage aus
  10. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diesen am gewünschten Platz im Bild ein
  11. legen Sie eine Bildumschaltfunktion an, um das Bild zur Runtime aufrufen zu können

Elemente

Das Bild vom Typ Chronologische Ereignisliste Filter kann folgende Steuer- und Anzeigeelemente enthalten.

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Allgemeine Filter

Dropdownliste verschiedener allgemeiner Filter.

Alle Elemente einfügen: Allgemeine Filter

Fügt alle Elemente aus dem Bereich Allgemeine Filter an vordefinierten Plätzen ein. Elemente können individuell angeordnet werden.

Variablenfilter

Alarme welcher Variablen werden angezeigt:
  • Variablenname

Filtern nach Namen der Variablen.
  • Kennung

Filtern nach Kennung der Variablen.
  • Groß-/Kleinschreibung beachten

Groß- und Kleinschreibung bei der Filterung der Variablen beachten.

Datenherkunft

Woher stammen die Daten:
  • Ringpuffer

Aus dem Ringpuffer.
  • Historische Daten

Aus einem Archiv.
  • Beschriftung: Maximale Anzahl

Text für Eingabefeld Maximale Anzahl

  • Eingabefeld: Maximale Anzahl

Eingabe der maximal anzuzeigenden Alarme bei Anzeige historischer Alarme.

0: zeigt alle an

Runtime Einstellungen

  • Liste angehalten aufschalten

Schaltet die AML in angehaltenem Zustand auf. Neue Alarme werden nicht hinzugefügt.
  • Relativzeiten anzeigen

Schaltet zwischen der normalen Anzeige und der Relativzeit-Anzeige um, ohne dass der selektierte Eintrag den Fokus verliert.

Relativzeit: Alle Einträge werden im zeitlichen Abstand zum selektierten Eintrag angezeigt.

Die angegebene Zeit ist die Differenz-Zeit, die seit dem selektierten Ereignis verstrichen ist. Der selektierte Eintrag erhält automatisch den Zeitstempel 0. Die anderen Ereignisse haben eine:

  • positive Zeitdifferenz zum selektierten Eintrag, wenn sie später stattfanden
  • negative Zeitdifferenz zum selektierten Eintrag, (wenn sie vorher stattfanden

Alarm/Ereignis-Gruppen/Alarm/Ereignis-Klassen/Alarmbereiche

Listenfelder für gruppierte Anzeige:
  • Alarm/Ereignis-Gruppen

Alarm/Ereignis-Gruppen
  • Alarm/Ereignis-Klassen

Alarm/Ereignis-Klassen
  • Alarmbereiche

Alarmbereiche

Zeitfilter

Dropdownliste verschiedener Zeitfilter.

Alle Elemente einfügen: Absoluter Zeitraum - klassische Darstellung

Fügt alle Elemente für die Definition absoluter Zeiträume ein: Jedes Element erhält ein eigenes Feld.

Alle Elemente einfügen: Absoluter Zeitraum - kleine Darstellung

Fügt Elemente für die Definition absoluter Zeiträume in kompakter Darstellung ein.

Alle Elemente einfügen: Relativer Zeitraum

Fügt alle Elemente für die Definition relativer Zeiträume ein.

Alle Elemente einfügen: Ab HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag, Monat - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Monat-Stunden-Minuten-Sekunden ein.

Beschriftung: Zeitfiltertyp

Beschriftung für Typ des Zeitfilters.

Combobox: Zeitfiltertyp

Combobox Zeitfilterty.

Anzeige: Zeitfiltertyp

Feld für Anzeige Zeitfiltertyp.

Zeit von

Felder und Beschriftungen für Angaben "Von"-Zeit.
  • Beschriftung: Von Jahr

  • Combobox: Von Jahr

  • Beschriftung: Von Monat

  • Combobox: Von Monat

  • Beschriftung: Von Tag

  • Combobox: Von Tag

  • Beschriftung: Von Stunde

  • Combobox: Von Stunde

  • Beschriftung: Von Minute

  • Combobox: Von Minute

  • Beschriftung: Von Sekunde

  • Combobox: Von Sekunde

  • Spincontrol: Von

Zeit bis

Felder und Beschriftungen für Angaben "Bis"-Zeit.
  • Beschriftung: Bis Jahr

  • Combobox: Bis Jahr

  • Beschriftung: Bis Monat

  • Combobox: Bis Monat

  • Beschriftung: Bis Tag

  • Combobox: Bis Tag

  • Beschriftung: Bis Stunde

  • Combobox: Bis Stunde

  • Beschriftung: Bis Minute

  • Combobox: Bis Minute

  • Beschriftung: Bis Sekunde

  • Combobox: Bis Sekunde

  • Spincontrol: Bis

Absolutzeitfilter

Felder und Beschriftungen für Angaben absoluter Zeitfilter.
  • Beschriftung: Von

  • Kalenderanzeige: Von Datum

  • Datumsanzeige: Von Datum

  • Zeitanzeige: Von Zeit

  • Beschriftung: Bis

  • Kalenderanzeige: Bis Datum

  • Datumsanzeige: Bis Datum

  • Zeitanzeige: Bis Zeit

Textfilter

Dropdownliste verschiedener Textfilter.

Alle Elemente einfügen: Textfilter

Fügt alle Elemente für Textfilter ein.

Kein Textfilter

Radiobutton für Abwahl Textfilter.

Suchen nach (Wörter getrennt durch Leerzeichen)

Radiobutton für Aktvierung der Suche

Beschriftung: Suchtext

Beschriftung für Suchfeld.

Eingabefeld: Suchtext

Feld für Eingabe der Suchbegriffe.

Optionen

Optionen für Suche
  • Groß-/Kleinschreibung beachten

Groß-/Kleinschreibung muss beachtet werden.
  • Wörter müssen nicht vollständig im Text vorkommen

Es wird auch nach Fragmenten gesucht.
  • Mindestens ein Wort muss im Text vorkommen

Mindestens ein Suchbegriff von mehreren muss im Ergebnis enthalten sein.
  • Alle Wörter müssen im Text vorkommen

Alle Suichbegriffe müssen im Ergebnis enthalten sein.
  • Filtertext muss exakt im Text vorkommen

Text aus dem Eingabefeld muss exakt im ergebnis enthalten sein.

OK

Eingaben übernehmen und Bild schließen.

Abbrechen

Eingaben verwerfen und Bild schließen.

Übernehmen

Eingaben übernehmen und bild für weitere Eingaben geöffnet lassen.

Aktualisieren

Bild aktualisieren.

Filterbilder

Filterbilder ermöglichen es, einen voreingestellten Filter von einem Bild auf ein anderes zu übertragen. Der Filter des Quellbildes wird über das Zielbild gelegt. Die Bilder können auch von unterschiedlichen Bildtypen sein.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.

Aufrufdefinition

Folgende Voraussetzungen müssen erfüllt sein, damit die eingestellten Filter zur Anwendung kommen:

  1. Als Zeitbereich beim Zeitfilter wird Filter beim Zeitfiltertyp einstellen gewählt.
  2. Das Bild (Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter oder Zeitfilter) wird mithilfe eines Buttons oder eines Combi-Elements aktiviert. Nur so wird der Bezug zwischen Filterbild und Quellbild gewährleistet.
  3. Das Quellbild und das Filterbild müssen auf unterschiedlichen Schablonen oder Monitoren projektiert sein. Nur wenn das Quellbild offen ist, kann der Filter für das Filterbild aktualisiert werden. Das ist nur möglich, wenn beide Bilder nicht dieselbe Schablone oder den selben Monitor verwenden.
  4. Das aufrufende Bild muss mit dem aufzurufenden Filterbild kompatibel sein (siehe Tabelle).
Quellbild | AML Filter | CEL Filter | Zeitfilter
Archiv-Nachbearbeitung | T | T | T
Erweiterter Trend | T | T | T
Zeitfilter | T | T | X
Alarmmeldeliste Filter | X | C | T
Chronologische Ereignisliste Filter | C | X | T
Alarmmeldeliste | X | C | T
Chronologische Ereignisliste | C | X | T

Legende:

  • C: Gemeinsame Einstellungen werden aktualisiert.
  • T: Zeiteinstellungen werden aktualisiert.
  • X: Alle Einstellungen werden aktualisiert.

info Info

Keine Filterung

Das Filterbild wird nicht gefiltert, sondern mit den projektierten Werten aufgeschaltet, wenn:

  • eine der Bedingungen 1 bis 3 nicht erfüllt wird oder
  • die Einstellung Aufrufendes Bild bei der Funktion Bildumschaltung nicht aktiviert ist oder
  • das Bild nicht über ein Bildelement aufgerufen wird

In diesem Fall werden zur Runtime die Buttons Übernehmen, Schließen und Aktualisieren ausgegraut dargestellt und haben keine Funktion.


Bild vom Typ Zeitfilter

Handbuch -> Bilder -> Bildtypen -> Bildfilter -> Bild vom Typ Zeitfilter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mithilfe des Bilds vom Typ Zeitfilter ist es möglich, in der Runtime Zeitfiltereinstellungen vorzunehmen. Folgende Bildtypen können mit dem Filter beeinflusst werden:

  • Alarmmeldeliste
  • Archiv-Nachbearbeitung
  • Chronologische Ereignisliste
  • Erweiterter Trend

Der Vorteil dieses Bildtyps liegt darin, dass nur die wirklich benötigten Filterelemente projektiert werden können. Somit muss sich der Benutzer nicht mit allen möglichen Filtereinstellungen auseinandersetzen. Er bekommt nur die Filtereinstellungen angezeigt, die er benötigt. Außerdem können Sie das Aussehen völlig frei definieren und so zum Beispiel auch eine leichte Bedienung über einen Touchscreen sicherstellen.

attention Achtung

Bilder vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter und Zeitfilter müssen mit einer eigenen Schablone projektiert werden. Besitzen sie die gleiche Schablone wie andere Bilder werden zur Runtime beim Schließen des Bildes alle auf dieser Schablone basierenden Bilder ebenfalls geschlossen.

Im Bild vom Typ Zeitfilter können alle Zeitfiltereinstellungen, die auch im Filter für die Funktion Bildumschaltung auf das entsprechenden Bild vorhanden sind, projektiert werden.

Filterbilder

Filterbilder ermöglichen es, einen voreingestellten Filter von einem Bild auf ein anderes zu übertragen. Der Filter des Quellbildes wird über das Zielbild gelegt. Die Bilder können auch von unterschiedlichen Bildtypen sein.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.

Aufrufdefinition

Folgende Voraussetzungen müssen erfüllt sein, damit die eingestellten Filter zur Anwendung kommen:

  1. Als Zeitbereich beim Zeitfilter wird Filter beim Zeitfiltertyp einstellen gewählt.
  2. Das Bild (Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter oder Zeitfilter) wird mithilfe eines Buttons oder eines Combi-Elements aktiviert. Nur so wird der Bezug zwischen Filterbild und Quellbild gewährleistet.
  3. Das Quellbild und das Filterbild müssen auf unterschiedlichen Schablonen oder Monitoren projektiert sein. Nur wenn das Quellbild offen ist, kann der Filter für das Filterbild aktualisiert werden. Das ist nur möglich, wenn beide Bilder nicht dieselbe Schablone oder den selben Monitor verwenden.
  4. Das aufrufende Bild muss mit dem aufzurufenden Filterbild kompatibel sein (siehe Tabelle).
Quellbild | AML Filter | CEL Filter | Zeitfilter
Archiv-Nachbearbeitung | T | T | T
Erweiterter Trend | T | T | T
Zeitfilter | T | T | X
Alarmmeldeliste Filter | X | C | T
Chronologische Ereignisliste Filter | C | X | T
Alarmmeldeliste | X | C | T
Chronologische Ereignisliste | C | X | T

Legende:

  • C: Gemeinsame Einstellungen werden aktualisiert.
  • T: Zeiteinstellungen werden aktualisiert.
  • X: Alle Einstellungen werden aktualisiert.

info Info

Keine Filterung

Das Filterbild wird nicht gefiltert, sondern mit den projektierten Werten aufgeschaltet, wenn:

  • eine der Bedingungen 1 bis 3 nicht erfüllt wird oder
  • die Einstellung Aufrufendes Bild bei der Funktion Bildumschaltung nicht aktiviert ist oder
  • das Bild nicht über ein Bildelement aufgerufen wird

In diesem Fall werden zur Runtime die Buttons Übernehmen, Schließen und Aktualisieren ausgegraut dargestellt und haben keine Funktion.

Aktualisierung

Beim Aufruf eines Filterbilds (Alarmmeldeliste Filter, Chronologische Ereignisliste Filter, Zeitfilter), werden die in der Funktion Bildumschaltung projektierten Bilder auf zwei Arten aktualisiert:

  • Wird das Filterbild über ein Bildelement aufgerufen, werden die Zielbilder, die sich auf demselben Monitor wie das Quellbild befinden aktualisiert.
  • Wird das Filterbild auf einem anderen Weg aufgerufen oder ist die Einstellung Auf allen Monitoren aktualisieren aktiviert, werden alle projektierten Zielbilder aktualisiert.

Die Aktualisierung erfolgt, sobald Sie den Button Übernehmen anklicken oder das Filterbild mit dem Button Schließen schließen. Der Button Abbrechen verwirft die Änderungen und schließt das Filterbild.

Filtereinstellungen aktualisieren

Mithilfe des Buttons Aktualisieren, übernehmen Sie die aktuellen Filtereinstellungen des Quellbilds. Wenn das Filterbild nicht durch ein Bildelement aufgerufen wurde oder wenn die Einstellung Aufrufendes Bild nicht aktiviert wurde, wird auf allen Monitoren nach einem Bild gesucht, das zur Aktualisierung verwendet werden kann. Das erste Bild, das gefunden wird, wird dann zur Aktualisierung verwendet.


HTML

Handbuch -> Bilder -> Bildtypen -> HTML

Ermöglicht die Darstellung eines Bildes in HTML. Als Rendering Engine wird der aktuell am Rechner installierte Microsoft Internet Explorer verwendet.

Noch in diesem Kapitel

Bild vom Typ HTML anlegen

Funktion Bildumschaltung - HTML

Bedienen während der Runtime


Bild vom Typ HTML anlegen

Handbuch -> Bilder -> Bildtypen -> HTML -> Bild vom Typ HTML anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ HTML anzulegen:

  1. legen Sie ein neues Bild an
  2. wählen Sie als Bildtyp HTML
  3. ein leeres Bild wird erstellt
  4. klicken Sie in der Dropdownliste auf Vorlage einfügen
  5. der Dialog zur Auswahl einer Vorlage wird geöffnet
  6. wählen Sie die gewünschte Vorlage aus

Adressen für Navigation und Sucher werden beim Anlegen der Bildumschaltung definiert.

info Info

Die Option Vorlage einfügen fügt vordefinierte Kontrollelemente an vordefinierten Stellen im Bild ein. Alle Kontrollelemente können ergänzt, gelöscht und frei positioniert werden. Auch andere Dynamische Elemente und Vektor-Elemente können hinzugefügt werden.


Funktion Bildumschaltung - HTML

Handbuch -> Bilder -> Bildtypen -> HTML -> Funktion Bildumschaltung - HTML

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Funktion zur Aufschaltung des Bildes HTML anzulegen:

  • wählen Sie Funktion neu
  • wählen Sie Bildumschaltung
  • wählen Sie das Bild vom Typ HTML aus
  • ein Dialog zur Definition der Adressen für den Such- und den Navigationsbereich öffnet sich

Parameter | Beschreibung
Adresse Suchen | Adresse der Seite, die im Suchbereich angezeigt werden soll.
Adresse Navigation | Adresse der Seite, die im Navigationsbereich angezeigt werden soll.
Letzte Adressen merken |
Suchen | Anzahl der Adressen, die sich das System für den Suchbereich merken soll.
Navigation | Anzahl der Adressen, die sich das System für den Navigationsbereich merken soll.
Diesen Dialog zur Runtime anbieten | Aktiv: Der Dialog wird beim Aufschalten des Bildes in der Runtime angezeigt.


Bedienen während der Runtime

Handbuch -> Bilder -> Bildtypen -> HTML -> Bedienen während der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontrollelement | Beschreibung
Suchen | Suchbereichselement
Navigieren | Navigationsbereichselement Beim Klicken auf einen Link im Feld 'Suchen' wird die entsprechende Seite im Feld 'Navigieren' angezeigt. So kann im Feld 'Suchen' z.B. eine Navigationsleiste oder das Ergebnis einer Suchmaschinenabfrage angezeigt werden, ohne dass dessen Inhalt geändert wird, wenn ein Link angeklickt wird.
Suchen rückwärts | Im Suchbereich rückwärts blättern.
Suchen vorwärts | Im Suchbereich vorwärts blättern.
Suchen abbrechen | Suchen abbrechen.
Suchen Startseite | Im Suchbereich zur Startseite zurück.
Suchen Refresh | Suchbereich refreshen.
Suchen URL | Suchen nach Adressen bzw. Datei.
Navigieren rückwärts | Im Navigationsbereich rückwärts blättern.
Navigieren vorwärts | Im Navigationsbereich vorwärts blättern.
Navigieren abbrechen | Navigieren abbrechen.
Navigieren Startseite | Im Navigationsbereich zur Startseite zurück.
Navigieren Refresh | Navigationsbereich refreshen.
Navigieren URL | Navigieren nach Adressen bzw. Datei.
Filter | Filterbox aufschalten.


Notizbuch

Handbuch -> Bilder -> Bildtypen -> Notizbuch

Das Notizbuch dient zur Anzeige und (optional) Bearbeitung von Textdateien.

Noch in diesem Kapitel

Bild vom Typ Notizbuch anlegen

Funktion Bildumschaltung auf Notizbuch

Bedienen während der Runtime


Bild vom Typ Notizbuch anlegen

Handbuch -> Bilder -> Bildtypen -> Notizbuch -> Bild vom Typ Notizbuch anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Darstellungsgröße des Notizbuches wird aus der Schablonengröße abgeleitet. Welche Datei geöffnet wird, ist bei der Definition der Bildumschaltung festzulegen.

Um ein Notizbuch anzulegen:

  1. legen Sie ein neues Bild an
  2. wählen Sie als Bildtyp Notizbuch
  3. ein leeres Bild wird erstellt
  4. klicken Sie in der Dropdownliste auf Vorlage einfügen
  5. der Dialog zur Auswahl einer Vorlage wird geöffnet
  6. wählen Sie die gewünschte Vorlage aus

info Info

Vorlage einfügen fügt vordefinierte Kontrollelemente an vordefinierten Stellen im Bild ein. Alle Kontrollelemente können ergänzt, gelöscht und frei positioniert werden. Auch andere Dynamische Elemente und Vektor-Elemente können hinzugefügt werden.


Funktion Bildumschaltung auf Notizbuch

Handbuch -> Bilder -> Bildtypen -> Notizbuch -> Funktion Bildumschaltung auf Notizbuch

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Funktion zur Aufschaltung des Bildes Notizbuch anzulegen:

  • wählen Sie Funktion neu
  • wählen Sie Bildumschaltung
  • wählen Sie das Bild vom Typ Notizbuch aus
  • ein Dialog zur Definition der Datei, die angezeigt werden soll, öffnet sich

Parameter | Beschreibung
Dateiname | Auswahl der Datei, die angezeigt werden soll. Klick auf ... öffnet den Auswahldialog. Die Datei muss im Projektmanager im Knoten Dateien/Notizbuch bereits angelegt sein. Wurde noch keine entsprechende Datei angelegt, kann sie im Dialog über das Symbol Datei hinzufügen ausgewählt werden. Erlaubte Dateitypen: TXT, HTM, HTML, FRM.
nur lesen | Aktiv: Der Text kann zur Runtime nur gelesen, aber nicht editiert werden.


Bedienen während der Runtime

Handbuch -> Bilder -> Bildtypen -> Notizbuch -> Bedienen während der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontrollelement | Aktion
Button Datei | Dateiauswahl im Onlinebetrieb
Button Refresh | Anzeige im Onlinebetrieb aktualisieren
Button Speichern | Änderungen im Onlinebetrieb in eine Datei speichern
Button Speichern unter | Änderungen im Onlinebetrieb in eine Datei anderen Namens speichern
Button Drucken | Darstellung im Onlinebetrieb drucken
Button Druck en Dialog | Druckereinstellungen
Button Schließen | Alarmmeldeliste beenden
Button Spalte rechts | eine Spalte nach rechts blättern
Button Spalte links | eine Spalte nach links blättern
Button Seite rechts | eine Seite nach rechts blättern
Button Seite links | eine Seite nach links blättern
Button Zeile auf | eine Zeile nach oben blättern
Button Zeile ab | eine Zeile nach unten blättern
Button Seite auf | eine Seite nach oben blättern
Button Seite ab | eine Seite nach unten blättern
Text-Element | Anzeigefenster der Textliste


Video

Handbuch -> Bilder -> Bildtypen -> Video

Mit der Verwendung eines Bildes für die Videodarstellung sind Videoaufnahmen - online und aus gespeicherten Dateien - in zenon darstellbar. Als Format wird .avi verwendet.

Videos werden zur Runtime zentriert in der zugewiesenen Schablone abgespielt. Die Steuerung erfolgt über Kontrollelemente.

Hinweis: Die zum Abspielen des Videos benötigten Codec müssen auf dem Rechner installiert sein.

Noch in diesem Kapitel

Bild vom Typ Video anlegen

Funktion Bildumschaltung - Video

Bedienen zur Runtime


Bild vom Typ Video anlegen

Handbuch -> Bilder -> Bildtypen -> Video -> Bild vom Typ Video anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Video anzulegen:

  1. legen Sie ein neues Bild an
  2. wählen Sie als Bildtyp Video
  3. ein leeres Bild wird erstellt
  4. klicken Sie in der Dropdownliste auf Vorlage einfügen
  5. der Dialog zur Auswahl einer Vorlage wird geöffnet
  6. wählen Sie die gewünschte Vorlage aus

info Info

Vorlage einfügen fügt vordefinierte Kontrollelemente an vordefinierten Stellen im Bild ein. Alle Kontrollelemente können ergänzt, gelöscht und frei positioniert werden. Auch andere Dynamische Elemente und Vektor-Elemente können hinzugefügt werden.


Funktion Bildumschaltung - Video

Handbuch -> Bilder -> Bildtypen -> Video -> Funktion Bildumschaltung - Video

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit einem Bild des Typs Video können zur Runtime zwei Arten von Videos angezeigt werden:

  1. gespeicherte Videos (*.avi)
  2. Videos einer Überwachungskamera

Welche Bilder angezeigt werden, hängt davon ab, welche Registerkarte beim Speichern des Dialogs angezeigt wird.

info Info

Sollen sowohl Dateien als auch Onlinebilder angezeigt werden, erstellen Sie zwei Funktionen mit Bildumschaltung auf das Bild.

Um eine Funktion zur Aufschaltung des Bildes Video anzulegen:

  • wählen Sie Funktion neu
  • wählen Sie Bildumschaltung
  • wählen Sie das Bild vom Typ Video aus
  • ein Dialog zur Definition der Bildquelle öffnet sich:
    • Video-Datei
    • Video Online

Noch in diesem Kapitel

Video-Datei

Video Online


Video-Datei

Handbuch -> Bilder -> Bildtypen -> Video -> Funktion Bildumschaltung - Video -> Video-Datei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die für das Aufschalten eines Bildes des Typs Video zur Betrachtung gespeicherter Video-Dateien benötigten Parameter sind:

  • Angabe des Videos, das angezeigt werden soll
  • Einstellungen für Position, Geschwindigkeit, Lautstärke und Zoomfaktor der Anzeige

Parameter | Beschreibung
AVI-Datei | Gespeicherte Video Datei, die angezeigt werden soll.
Optionen u. Parameter |
Playbar | Anzeige eines Schiebereglers in der Video-Anzeige.
Menü | Anzeige eines Menüs zur Steuerung des Videos im Playbar (nur bei aktiviertem Playbar möglich).
Videopos Mitte | Ausgangspunkt für die Position der Video-Anzeige bei Zoom-Aktionen. Aktiv : Das gezoomte Video wird wieder in der Mitte der Schablone positioniert. Inaktiv : Der Video-Anzeigebereich wird nach rechts unten vergrößert.
Autostart | Die Video-Datei wird sofort beim Öffnen des Bildes abgespielt.
Endlose Wiedergabe | Nach dem Ende des Videos wird die Video-Datei erneut abgespielt.
Speed | Abspielgeschwindigkeit in Tausendstel der Originalgeschwindigkeit. Default: 1000 (Originalgeschwindigkeit)
Zoom | Zoom-Faktor für seitenrichtiges Vergrößern oder Verkleinern in Prozent der Originalgröße. Default: 100 (Originalgröße)
Volume | Lautstärke in Tausendstel der Originallautstärke. Default: 1000 (Originallautstärke)
TimrFreq | Hinweis: Wird aktuell nicht verwendet. Timer Frequenz. Default: 500


Video Online

Handbuch -> Bilder -> Bildtypen -> Video -> Funktion Bildumschaltung - Video -> Video Online

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die für das Aufschalten eines Bildes des Typs Video zur Anzeige einer Überwachungskamera benötigten Parameter sind:

  • Angabe des Video-Treibers
  • Einstellungen für die Aufzeichnungsoptionen, falls Videos auch aufgezeichnet werden sollten

Parameter | Beschreibung
Video - Treiber | Auswahl des zu verwendenden Video-Treibers. Hinweis: der Treiber sollte Microsoft Capturing unterstützen.
Aufzeichnungsoptionen | Optionen für die Aufzeichnung und Speicherung von Videos als AVI-Dateien oder Bitmaps. Falls nur Online-Bilder dagestellt werden sollen, werden hier keine Einstellungen benötigt.
Name od. Kurzb. | Name der zu speichernden Datei.
Automatische Namensvergabe | Name wird aus Systemzeit zur Aufzeichnung erstellt.
Aktiviere Cap. Zeit Limit | Zeitlimit für die Aufzeichnung in Sekunden.
Format | AVI oder BMP.
Autostart der Aufnahme | Die Aufnahme wird beim Öffnen des Bildes sofort gestartet.
DOS Buffers verwenden | Nur für 16-Bit Systeme relevant.
Frame Rate | Anzahl der Bilder pro Sekunde für die Aufzeichnung.
Video Buffers | Reservierter Bufferbereich für die Videoaufzeichnung in MB.
Max Drop Rate | Maximal erlaubte "Dropped Frames" in Prozent während Aufnahme. Wert: 0 bis 100 Default: 10
Video | Treiberspezifische Einstellungen.
Anzeigen ... | Einstellung abhängig vom gewählten Treiber.
Formatieren ... | Einstellung abhängig vom gewählten Treiber.
Komprimieren ... | Einstellung abhängig vom gewählten Treiber.
Quelle ... | Einstellung abhängig vom gewählten Treiber.
Audio | Einstellungen für die Tonaufzeichnung.
Audio erfassen | Aktiviert Tonaufzeichnung werden.
Audio Format | Treiberspezifische Einstellungen.


Bedienen zur Runtime

Handbuch -> Bilder -> Bildtypen -> Video -> Bedienen zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Videos werden zentriert in der Schablone angezeigt.

Kontrollelement | Beschreibung
Video online | Elemente für Steuerung eines Online-Videos.
Format | Ausgabeformat.
Quelle | Datenquelle.
Anzeigen | Video anzeige.
Kompression | Datenkompression.
Video Datei | Elemente für Steuerung einer Videodatei.
Geschwindigkeit | Abspielgeschwindigkeit.
Zoom | Vergrößerung.
Filter | Filtereinstellungen.
Start | Video abspielen.
Wiederholen | Video erneut abspielen.
Aufnahme | Video aufnehmen.
Pause | Video während des Abspielens anhalten.
Stopp/Weiter | Abspielen stoppen/wieder aufnehmen.
Eject | Auswurf.
>> | schneller Vorlauf.
<< | schneller Rücklauf.
Ende | Zum Ende des Videos spulen.
Pos1 | Zum Anfang spulen.


Bild-Funktionen

Handbuch -> Bilder -> Bild-Funktionen

Wird aus dem Kontextmenü in der Detailansicht die Standardfunktion erstellt, so erstellt zenon automatisch eine Funktion 'Bildumschaltung' für das ausgewählte Bild.

Noch in diesem Kapitel

Bildumschaltung

Bild indiziert

Bild schließen

Bild zurück

Eingabe auf Element mit Fokus aktivieren

Fokus auf Schablone setzen

Fokus verschieben

Fokus von Schablone nehmen

Menü anzeigen

Monitor zuordnen

Schablone schließen

Sollwertvorgabe für Keyboard-Bild

Übersichtsfenster anzeigen

Bildmittelpunkt verschieben


Bildumschaltung

Handbuch -> Bilder -> Bild-Funktionen -> Bildumschaltung

Die Funktion Bildumschaltung ermöglicht es, zur Runtime zwischen Prozessbildern umzuschalten.

Example Beispiel

In einem Projekt gibt es ein Bild Start und ein Bild vom Typ Alarmmeldeliste. Es soll während der Runtime möglich sein, zwischen diesen beiden Bildern umzuschalten. Dazu wird beispielsweise im Bild Start ein Button angelegt sowie eine Funktion vom Typ Bildumschaltung auf das Bild Alarmmeldeliste. Anschließend wird die Funktion mit dem Button verknüpft z.B. mittels Drag&Drop. Während der Runtime kann nun mit Betätigung des Buttons das Bild Start verlassen und das Bild Alarmmeldeliste aufgeschalten werden.

Bildumschaltung projektieren

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. navigieren Sie zum Knoten Bilder

    Interne ID: Bildumschaltung

    Bilder

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

    Mehr im Online-Handbuch

  3. wählen Sie die Funktion Bildumschaltung

    Interne ID: Bildumschaltung

    Bildumschaltung

    Diese Funktion öffnet ein ausgewähltes Bild. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

    Mehr im Online-Handbuch

  4. der Dialog zur Auswahl eines Bildes wird geöffnet
  5. wählen Sie ein Bild
  6. der Dialog zum Ersetzen von Variablen und Funktionen wird geöffnet
  7. schließen Sie den Dialog mit Klick auf OK
  8. weisen Sie die Funktion einem Button zu

Dialog Bildauswahl

Im Auswahldialog Bilder können Bilder für die Ausführung von Funktionen ausgewählt werden aus:

  • aktuellem Projekt
  • Unterprojekten
  • allen Projekten im Arbeitsbereich mit aktiver Option Projekt im Speicher halten

Parameter

Beschreibung

Fenster Projektbaum

Zeigt alle Projekte im Arbeitsbereich an. Bilder können gewählt werden aus dem aktuellen Projekt und aus allen Projekten mit aktiver Option Projekt im Speicher halten

Fenster Bilder

Auswahl des Bildes.

Werden mehrere Bilder ausgewählt, wird für die Ausführung der Funktion das erste gewählte Bild benutzt.

Diesen Dialog zur Runtime anbieten

Schaltet zur Runtime bei der Ausführung der Funktion diesen Bildauswahldialog auf.

Keine Auswahl

Hat für diese Bildauswahl keine Funktion.

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält:

  • aktueller Monitor
  • alle in der Monitorverwaltung definierten virtuellen Monitore
  • optional: Alle Monitore

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.


Bild indiziert

Handbuch -> Bilder -> Bild-Funktionen -> Bild indiziert

Mit der Verwendung dieser Funktion wird im Onlinebetrieb auf dasjenige Bild umgeschaltet, dessen Namen den Inhalt einer definierten String-Variable enthält.

Als Übergabeparameter ist eine String-Variable aus der Variablenliste auszuwählen.

Hinweis Mehr-Monitor-Systeme: Eine Monitorauswahl ist nicht möglich. Die Funktion bezieht sich immer auf den ersten Monitor.


Bild schließen

Handbuch -> Bilder -> Bild-Funktionen -> Bild schließen

Mit dieser Funktion wird zur Runtime ein definiertes Bild geschlossen. Ist bei Mehr-Monitor-Projekten ein Bild auf mehreren Monitoren aufgeschaltet, kann ausgewählt werden, welches Bild auf welchem Monitor geschlossen wird.

Um die Funktion zu projektieren:

  1. wählen Sie in der Liste der Funktionen im Knoten Bilder die Funktion Bild schließen

    Interne ID: Bild schließen

    Bild schließen

    Diese Funktion schließt ein ausgewähltes Bild.

    Mehr im Online-Handbuch

    Interne ID: Bild schließen

    Bilder

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

    Mehr im Online-Handbuch

  2. der Dialog zur Auswahl eines Bildes wird geöffnet
  3. wählen Sie das gewünschte Bild
  4. wählen Sie bei Mehr-Monitor-Projekten den virtuellen Monitor, auf dem das Bild geschlossen werden soll, aus der Dropdownliste:
    • alle
    • aktueller Monitor
    • bestimmter virtueller Monitor

Dialog Bildauswahl

Im Auswahldialog Bilder können Bilder für die Ausführung von Funktionen ausgewählt werden aus:

  • aktuellem Projekt
  • Unterprojekten
  • allen Projekten im Arbeitsbereich mit aktiver Option Projekt im Speicher halten

Parameter

Beschreibung

Fenster Projektbaum

Zeigt alle Projekte im Arbeitsbereich an. Bilder können gewählt werden aus dem aktuellen Projekt und aus allen Projekten mit aktiver Option Projekt im Speicher halten

Fenster Bilder

Auswahl des Bildes.

Werden mehrere Bilder ausgewählt, wird für die Ausführung der Funktion das erste gewählte Bild benutzt.

Diesen Dialog zur Runtime anbieten

Schaltet zur Runtime bei der Ausführung der Funktion diesen Bildauswahldialog auf.

Keine Auswahl

Hat für diese Bildauswahl keine Funktion.

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält:

  • aktueller Monitor
  • alle in der Monitorverwaltung definierten virtuellen Monitore
  • optional: Alle Monitore

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.


Bild zurück

Handbuch -> Bilder -> Bild-Funktionen -> Bild zurück

Mit dieser Funktion kann im Onlinebetrieb schnell auf zuvor aufgeschaltete Bilder zurück gewechselt werden. Dabei wird die selbe Funktion, die zum Aufschalten des Bildes benutzt wurde, noch einmal ausgeführt. Das bedeutet, dass Bildfilter nicht gespeichert werden, sondern neu erstellt werden müssen.

Die zuvor aufgeschalteten Bilder werden in einem Speicher verwaltet. Durch die Ausführung der Funktion Bildumschaltung werden die Bilder der entsprechenden freigegebenen Schablonen in den Speicher eingetragen. Die Anzahl der im Speicher verwalteten Bilder wird in der Datei project.ini projektiert.

[FUNKTIONEN]

ZURUECK_ANZAHL=10

Als Übergabeparameter werden die zu berücksichtigenden Schablonen angegeben.

Mit dem Eintrag ZURUECK_ANZAHL= wird die Größe des Speichers angegeben.

Hinweis Mehr-Monitor-Systeme: Eine Monitorauswahl ist nicht möglich. Die Funktion bezieht sich immer auf alle Monitore.


Eingabe auf Element mit Fokus aktivieren

Handbuch -> Bilder -> Bild-Funktionen -> Eingabe auf Element mit Fokus aktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion aktiviert das Element, das in der gewählten Schablone den Fokus besitzt.


Fokus auf Schablone setzen

Handbuch -> Bilder -> Bild-Funktionen -> Fokus auf Schablone setzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion setzt bei Tastaturbedienung zur Runtime den Fokus auf eine definierte Schablone.

Um die Funktion zu projektieren:

  1. wählen Sie in der Liste der Funktionen im Knoten Bilder die Funktion Fokus auf Schablone setzen

    Interne ID: Fokus auf Schablone setzen

    Fokus auf Schablone setzen

    Diese Funktion setzt den Eingabefokus auf das aktuell geöffnete Bild einer ausgewählten Schablone. So können Projekte mit reiner Tastaturbedienung erstellt werden.

    Mehr im Online-Handbuch

    Interne ID: Fokus auf Schablone setzen

    Bilder

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

    Mehr im Online-Handbuch

  2. der Dialog zur Auswahl einer Schablone wird geöffnet
  3. wählen Sie die gewünschte Schablone
  4. wählen Sie bei Mehr-Monitor-Projekten den virtuellen Monitor für die Aufschaltung der Schablone

Zur Runtime wird die mit einem Fokus versehene Schablone mit einem Rahmen dargestellt. Linienbreite und Farbe des Rahmens werden in den Projekteigenschaften im Knoten Grafische Ausprägung/Bilder definiert.

Interne ID: Fokus auf Schablone setzen

Bilder

Eigenschaften für die Anzeige der Bilder in der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Fokus auf Schablone setzen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Dialog Schablonenauswahl

Im Auswahldialog Schablonen können Schablonen für die Ausführung von Funktionen ausgewählt werden aus:

  • aktuellem Projekt
  • Unterprojekten
  • allen Projekten im Arbeitsbereich mit aktiver Option Projekt im Speicher halten

Parameter

Beschreibung

Fenster Projektbaum

Zeigt alle Projekte im Arbeitsbereich an. Schablonen können gewählt werden aus dem aktuellen Projekt und aus allen Projekten mit aktiver Option Projekt im Speicher halten

Fenster Schablonen

Auswahl der Schablone.

Werden mehrere Schablonen ausgewählt, wird für die Ausführung der Funktion die erste gewählte Schablone benutzt.

Diesen Dialog zur Runtime anbieten

Schaltet zur Runtime bei der Ausführung der Funktion diesen Schablonenauuswahldialog auf.

Keine Auswahl

Hat für diese Auswahl keine Funktion.

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält:

  • aktueller Monitor
  • alle in der Monitorverwaltung definierten virtuellen Monitore
    optional: Alle Monitore

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.


Fokus verschieben

Handbuch -> Bilder -> Bild-Funktionen -> Fokus verschieben

Diese Funktion setzt bei Tastaturbedienung zur Runtime den Fokus auf ein bestimmtes Element und kann damit zur Navigation innerhalb einer Schablone verwendet werden.

Eigenschaft | Aktion
Richtung | Festlegen der Richtung, in der der Fokus weitergegeben werden soll. Es gilt die im Editor Im Kontextmenü oder unter Bearbeiten/Reihenfolge für Fokus verschieben... festgelegte Reihenfolge
auf das Element | Festlegen des Elements, das den Fokus erhalten soll. Einzugeben ist der Objektname des Elements


Fokus von Schablone nehmen

Handbuch -> Bilder -> Bild-Funktionen -> Fokus von Schablone nehmen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion nimmt zur Runtime den Fokus von der aktuellen Schablone. Zur weiteren Tastaturbedienung muss der Fokus neu auf eine Schablone gesetzt werden.


Menü anzeigen

Handbuch -> Bilder -> Bild-Funktionen -> Menü anzeigen

Diese Funktion steuert die Anzeige von Hauptmenüs.

  1. erstellen Sie mit Funktion neu eine neue Funktion
  2. wählen Sie im Knoten Bilder die Funktion Menü anzeigen
  3. definieren Sie die auszuführende Aktion und das Hauptmenü

Parameter | Beschreibung
Aktion | Auswahl der Aktion:
Menü anzeigen | Das ausgewählte Menü wird angezeigt.
Menü ausblenden | Das ausgewählte Menü wird ausgeblendet.
Menü wechseln | Das aktuelle Menü wird ausgeblendet und das ausgewählte Menü wird angezeigt.
Wenn kein Menü vorhanden | Das ausgewählte Menü wird angezeigt, wenn derzeit kein anderes angezeigt ist.
Menü | Auswahl des Menüs.
Diesen Dialog zur Runtime anbieten | Aktiv: Bei Ausführung der Funktion zur Runtime wird dieser Dialog aufgeschaltet.


Monitor zuordnen

Handbuch -> Bilder -> Bild-Funktionen -> Monitor zuordnen

In einem Mehrmonitor-Projekt kann mittels dieser Funktion einem einzelnen reellen Monitor ein bestimmter virtueller Monitor zugewiesen werden.


Schablone schließen

Handbuch -> Bilder -> Bild-Funktionen -> Schablone schließen

Mit dieser Funktion wird zur Runtime die ausgewählte Schablone mit allen darauf basierenden Bildern geschlossen. Im Gegensatz zur Funktion Bild schließen ist die genaue Angabe des Bildnamens hier nicht erforderlich. Ist bei Mehr-Monitor-Projekten eine Schablone auf mehreren Monitoren aufgeschaltet, kann ausgewählt werden, welche Schablone auf welchem Monitor geschlossen wird.

Um die Funktion zu projektieren:

  1. wählen Sie in der Liste der Funktionen im Knoten Bilder die Funktion Schablone schließen

    Interne ID: Schablone schließen

    Schablone schließen

    Diese Funktion schließt das aktuell geöffnete Bild einer ausgewählten Schablone.

    Mehr im Online-Handbuch

    Interne ID: Schablone schließen

    Bilder

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

    Mehr im Online-Handbuch

  2. der Dialog zur Auswahl einer Schablone wird geöffnet
  3. wählen Sie die gewünschte Schablone
  4. wählen Sie bei Mehr-Monitor-Projekten den virtuellen Monitor, auf dem die Schablone geschlossen werden soll, aus der Dropdownliste:
    • alle
    • aktueller Monitor
    • bestimmter virtueller Monitor

Dialog Schablonenauswahl

Im Auswahldialog Schablonen können Schablonen für die Ausführung von Funktionen ausgewählt werden aus:

  • aktuellem Projekt
  • Unterprojekten
  • allen Projekten im Arbeitsbereich mit aktiver Option Projekt im Speicher halten

Parameter

Beschreibung

Fenster Projektbaum

Zeigt alle Projekte im Arbeitsbereich an. Schablonen können gewählt werden aus dem aktuellen Projekt und aus allen Projekten mit aktiver Option Projekt im Speicher halten

Fenster Schablonen

Auswahl der Schablone.

Werden mehrere Schablonen ausgewählt, wird für die Ausführung der Funktion die erste gewählte Schablone benutzt.

Diesen Dialog zur Runtime anbieten

Schaltet zur Runtime bei der Ausführung der Funktion diesen Schablonenauuswahldialog auf.

Keine Auswahl

Hat für diese Auswahl keine Funktion.

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält:

  • aktueller Monitor
  • alle in der Monitorverwaltung definierten virtuellen Monitore
    optional: Alle Monitore

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.


Sollwertvorgabe für Keyboard-Bild

Handbuch -> Bilder -> Bild-Funktionen -> Sollwertvorgabe für Keyboard-Bild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Sollwertvorgabe für Keyboard-Bild ist nur für Keyboard-Bild verfügbar. Zusätzlich muss das Textfeld Sollwerteingabe angelegt sein. Sie ermöglicht das Einstellen bzw. auch das Absetzten eines zuvor definierten Werts.

Interne ID: Sollwertvorgabe für Keyboard-Bild

Sollwertvorgabe für Keyboard-Bild

Diese Funktion stellt für ein Bild vom Typ Keyboard einen vordefinierten Wert ein (Vorschlagswert) oder setzt einen vordefinierten Wert ab und schließt das Bild.

Mehr im Online-Handbuch

Parameter | Beschreibung
Sollwertvorgabe | Eingabe des Sollwerts.
Aktion | Auswahl der Aktion aus Dropdownliste,. (Mögliche Aktionen siehe folgende Tabelle.)
OK | Übernimmt Eingaben, schließt Dialog und erstellt Funktion mit Wert und Aktion.
Abbrechen | Verwirft Eingaben, schließt Dialog und erstellt Funktion ohne Sollwert und Aktion.
Hilfe | Öffnet Online-Hilfe.

Aktionen in Dropdownliste:

Aktion

Beschreibung

Wert vorschlagen

Die Sollwertvorgabe wird ins Keyboard-Bild geschrieben.

Wert übernehmen

Es wird: wird:

  • die Sollwertvorgabe ins Keyboard-Bild
  • das Keyboard-Bild mit OK geschlossen

RGM: Wert übernehmen und absetzen

Wenn das Keyboard-Bild von der RGM Rezept-Tabelle aus aufgerufen wird, dann wird:

  • die Sollwertvorgabe ins Keyboard-Bild geschrieben
  • das Keyboard-Bild mit OK geschlossen
  • der Rezeptwert auf die Variable geschrieben

RGM: Wert übernehmen und Rezept speichern

Wenn das Keyboard-Bild von der RGM Rezept-Tabelle aus aufgerufen wird, dann wird:

  • die Sollwertvorgabe ins Keyboard-Bild geschrieben
  • das Keyboard-Bild mit OK geschlossen
  • das Rezept gespeichert

RGM: Wert schreiben und absetzen sowie Rezept speichern

Wenn das Keyboard-Bild von der RGM Rezept-Tabelle aus aufgerufen wird, dann wird:

  • die Sollwertvorgabe ins Keyboard-Bild geschrieben
  • das Keyboard-Bild mit OK geschlossen
  • der Rezeptwert auf die Variable geschrieben
  • das Rezept gespeichert


Übersichtsfenster anzeigen

Handbuch -> Bilder -> Bild-Funktionen -> Übersichtsfenster anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Übersichtsfenster anzeigen blendet in der Runtime ein Übersichtsfenster ein, das in einem Mehr-Monitor-System die vorhandenen reale Monitore oder Schablonen anzeigt. Per Mausklick kann ein Monitor bzw. eine Schablone angesteuert werden.

Interne ID: Übersichtsfenster anzeigen

Übersichtsfenster anzeigen

Diese Funktion öffnet ein Übersichtsfenster, sodass man auf einem Ein-Monitor-System ein Mehr-Monitor-System simulieren kann.

Mehr im Online-Handbuch

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. navigieren Sie zum Knoten
  3. wählen Sie die Funktion Übersichtsfenster anzeigen
  4. der Dialog zur Konfiguration des Übersichtsfensters wird geöffnet
  5. wählen Sie Ihre Konfiguration
  6. schließen Sie den Dialog mit Klick auf OK
  7. weisen Sie die Funktion einem Button zu

Dialog Übersichtsfenster anzeigen

Parameter | Beschreibung
Einstellungen | Die Funktion kann das Übersichtsfenster entweder nur öffnen, nur schließen oder toggeln. Auswahl erfolgt über Radiobuttons:
Anzeigen | Übersichtsfenster wird aufgeschaltet.
Toggeln | Anzeige wird umgeschaltet zwischen geöffnet und geschlossen.
Schließen | Übersichtsfenster wird geschlossen.
Anzeige der | Auswahl der Anzeige im Übersichtsfenster. Es werden entweder Schablonen oder Monitore angezeigt.
Schablonen | Das Übersichtsfenster teilt den Bildschirm in Schablonen ein.
Monitore | Das Übersichtsfenster teilt den Bildschirm in Monitore ein.
Position | Position des Übersichtsfensters auf dem Bildschirm, berechnet in Pixel vom linken oberen Rand aus.
Fenster-Style |
mit Titel | Aktiv: Das Übersichtsfenster hat eine Windows-Titelleiste.
System Menü | Aktiv: Bei aktiver Titelleiste wird das Windows-Systemmenü eingeblendet.
mit Rahmen | Aktiv: Übersichtsfenster wird mit Rahmen angezeigt. Fenstergröße kann zur Runtime durch Ziehen am Rahmen verändert werden. Auswahl der Rahmenstärke über Radiobuttons.
dünn | Dicker Rahmen.
dick | Dünner Rahmen.
Farben | Einstellung der Farben im Übersichtsfenster. Klick auf Farbe öffnet Palette.
Hintergrundfarbe | Farbe des Fensterhintergrunds
aktuelle Ansicht | Aktuell angezeigte Schablonen/Monitore.
Rahmen | Farbe des Rahmens.
selektierte | Ausgewählte Schablonen/Monitore.
OK | Übernimmt Einstellungen, schließt Dialog und erstellt Funktion mit Zuordnung.
Abbrechen | Verwirft Einstellungen, schließt Dialog und erstellt Funktion mit Standardeinstellungen.
Hilfe | Öffnet Online-Hilfe.


Bildmittelpunkt verschieben

Handbuch -> Bilder -> Bild-Funktionen -> Bildmittelpunkt verschieben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion dient dazu den Bildmittelpunkt in der Weltbildfunktionalität zu verschieben bzw. den Zoomfaktor zu verändern. Als Voraussetzung ist ein Bild zu erstellen, das größer als die Bildschirmauflösung ist. Bei der Bilddefinition ist dazu die Option Größe aus Schablonen zu deaktivieren und die Größe direkt zu definieren.

Projektierbare Einstellungen sind:

Bild | Auswahl des Bildes für den neuen Bildmittelpunkt
Bildmittelpunkt anwählen | Einstellung des Bildmittelpunkts
Objektname | Gewünschten Bildmittelpunkt über ein Objekt aus der Objektliste festlegen
Koordinaten | Gewünschten Bildmittelpunkt in Koordinaten (x,y) eingeben
Zoomstufe einstellen | Einstellung des Zoomfaktors
in % | Gewünschten Zoomfaktor in Prozent eingeben
Stufe | Gewünschten Zoomfaktor aus den definierten Zoomstufen auswählen


Chronologische Ereignisliste (CEL)

Handbuch -> Chronologische Ereignisliste (CEL)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Chronologischen Ereignisliste (CEL) können Systemereignisse und Benutzereingaben protokolliert werden, wie zum Beispiel:

  • Alarm-Quittierung
  • Alarm-Löschen
  • Sollwert-Setzen
  • Rezepte absetzen
  • Rezepte ändern
  • Archivdaten
  • Benutzeraktionen
  • Netzwerkaktionen

Die Einträge erfolgen jeweils in der Sprache, in der die zenon Runtime läuft.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

CEL projektieren

Funktionen

Bedienen zur Runtime


CEL projektieren

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bedienung der Chronologischen Ereignisliste erfolgt zur Runtime über Bilder vom Typ Chronologische Ereignisliste und Chronologische Ereignisliste Filter.

Editor

Um Ereignisse zur Runtime anzeigen und filtern zu können, muss im Editor:

  • ein Bild vom Typ C hronologische Ereignislist e projektiert werden

Zusätzlich können Sie:

  • die Anzeige von Ereignissen über Filter steuern
  • mit einem Bild vom Typ Chronologische Ereignisliste Filter die zur Runtime verfügbaren Filter anpassen

Runtime

Für die Bedienung zur Runtime werden genutzt:

  • Bildumschaltung CEL
  • Bildumschaltung CEL Filter
  • die zenon CEL-Funktionen
  • Bild vom Typ CEL Filter benutzen

Noch in diesem Kapitel

Bild vom Typ CEL anlegen

Bild vom Typ CEL Filter anlegen

Ereignisse für CEL definieren

CEL-Projektierung über Filter

CEL Ringpuffer


Bild vom Typ CEL anlegen

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> Bild vom Typ CEL anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Bild vom Typ Chronologische Ereignisliste ermöglicht, zur Runtime Systemereignisse und Benutzerhandlungen zu protokollieren und anzuzeigen. Welche Einträge angezeigt werden, wird über die Projektierung definiert. Die Anzeige kann durch Filter bei der Projektierung und zur Runtime verändert werden. Funktionen ermöglichen den Export und den Druck der angezeigten Ereignisse.

Bild vom Typ Chronologische Ereignisliste anlegen

Um ein Bild vom Typ Chronologische Ereignisliste anzulegen:

  1. wählen Sie in der Symbolleiste oder im Kontextmenü des Knotens Bilder den Befehl Bild neu
  2. ein leeres Bild vom Typ Standard wird aufgeschaltet
  3. ändern Sie in der Detailansicht den Bildtyp, dazu
    1. klicken Sie in der Spalte Bildtyp auf Standard
    2. wählen Sie in der Dropdownliste den Eintrag Chronologische Ereignisliste aus
    3. wählen Sie nicht die Hauptschablone, falls Sie das Bild zur Runtime über den Button Schließen schließen möchten
  4. klicken Sie in das Bild
  5. wählen Sie in der Menüleiste den Menüpunkt Kontrollelemente
  6. klicken Sie in der Dropdownliste auf Vorlage einfügen
  7. die Standard-Elemente werden eingefügt
  8. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diesen am gewünschten Platz im Bild ein
  9. legen Sie eine Bildumschaltfunktion an, um die CEL zur Runtime aufrufen zu können

Parameter

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Chronologische Ereignisliste

Anzeigefeld für die Liste mit ihren Ereignissen. Das Aussehen ist konfigurierbar. Spalten werden über den Filter Spalteneinstellungen bei der Bildumschaltung festgelegt oder über die Eigenschaft Spalteneinstellung CEL in den Projekteigenschaften in der Gruppe Chronologische Ereignisliste.

Interne ID: Bild vom Typ CEL anlegen

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bild vom Typ CEL anlegen

Spalteneinstellung CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

Interne ID: Bild vom Typ CEL anlegen

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Anzeige: Eingestellter Filter

Zeigt aktuell gewählten Filter an.

Filter...

Öffnet den Filterdialog.

Sortieren

Nach dem Aufschalten der CEL zur Runtime werden neue Einträge nicht chronologisch einsortiert, sondern am Ende der Liste hinzugefügt.

Klick auf den Button sortiert die Liste neu.

Zur Unterscheidung von sortierten und unsortierten Einträgen kann über die Eigenschaften sortierter Text und unsortierter Text jeweils eine unterschiedliche Farbe zugewiesen werden

Interne ID: Bild vom Typ CEL anlegen

unsortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv und nur für SICAM 230.
Textfarbe für unsortierte Einträge in der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bild vom Typ CEL anlegen

sortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Definiert Farbe des Textes für die Einträge in der Chronologischen Ereignisliste (CEL).
Hinweise:

1. Wird für die Eigenschaft Alarm/Ereignis-Klassen Farbe als Textfarbe gewählt, dann hat diese Farbe Vorrang vor der Auswahl in sortierter Text.

Interne ID: Bild vom Typ CEL anlegen

Alarm/Ereignis-Klassen Farbe

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
nicht verwenden: Die Farben der Alarm/Ereignis-Klassen werden in der CEL in der Runtime nicht verwendet.
als Textfarbe: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Textfarben für die entsprechenden Einträge verwendet. Diese überschreiben die Auswahl in der Eigenschaft sortierter Text.
als Zeilenhintergrund: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Hintergrundfarben für die entsprechenden Einträge verwendet.
Default: als Textfarbe

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

2. Für SICAM 230: Um in der Liste durchgehend die gleiche Farbe zu haben, muss für die Eigenschaft unsortierter Text die gleiche Farbe gewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Relativzeiten anzeigen

Aktiv: Relativzeiten werden angezeigt, ohne dass der selektierte Eintrag den Fokus verliert.

Stopp/Weiter

Steuert Aufnahme neuer Ereignisse in die Liste während der Anzeige:

Stopp: Es werden keine neuen Einträge an die Liste angefügt. Der Button ändert seine Beschriftung in Weiter.

Weiter: Es werden wieder neue Einträge an die Liste angefügt. Der Button ändert seine Beschriftung in Stopp. Um die neuen Einträge chronologisch einzuordnen muss der Button Sortieren betätigt werden.

Schließen

Beendet die Anzeige der Chronologischen Ereignisliste und schließt das Bild und die Schablone.

Damit nach dem Schließen das davor geöffnete Bild angezeigt wird, muss das Bild vom Typ CEL mit einer eigenen Schablone projektiert werden.

Drucken

Druckt Liste so, wie sie aktuell angezeigt wird, aus.

Drucken mit Dialog

Öffnet vor dem Drucken die Druckereinstellungen.

Beschriftung: Anzahl gesamt

Fügt zur Runtime Text "Gesamt" ein. Muss von Listenfeld Anzahl gesamt gefolgt werden.

Anzahl gesamt

Anzahl aller Ereignisse in der Liste

Info: Status CEL

Zeigt zur Runtime den Status der CEL an.

aktiv: Ereignisse werden je nach Einstellungen im Projekt protokolliert

inaktiv: Ereignisse werden nicht protokolliert

Der Status wird über die Eigenschaft CEL aktiv festgelegt. Eine Änderung wird erst nach einem Neustart der Runtime wirksam.

Beschriftung: Kommentarfeld

Fügt zur Runtime den Text "Kommentar" ein. Muss vom Listenfeld Kommentarfeld gefolgt werden.

Kommentarfeld

Listenfeld für die Eingabe eines freien Textes durch den Benutzer für das selektierte Ereignis.

Sobald das Feld den Fokus verliert, wird der Text übernommen. Um den Text in der CEL mit anzuzeigen, muss in der Spaltendefinition die Spalte Kommentar aktiviert werden.

Button Stopp/Weiter

Navigation

Steuert Elemente der Liste.
  • Zeile nach oben

Blättert eine Zeile nach oben.
  • Zeile nach unten

Blättert eine Zeile nach unten.
  • Spalte nach rechts

Blättert eine Spalte nach rechts.
  • Spalte nach links

Blättert eine Spalte nach links.
  • Seite nach oben

Blättert eine Seite nach oben.
  • Seite nach unten

Blättert eine Seite nach unten.
  • Seite nach rechts

Blättert eine Seite nach rechts.
  • Seite nach links

Blättert eine Seite nach links.

Filterprofile

Filtereinstellungen, die der Anwender in der Runtime speichern kann.

  • Profilauswahl

Profil aus Liste auswählen.

  • Speichern

Speichern einer Einstellung als Profil.

  • Löschen

Löscht ausgewähltes Profil.

info Info

Im Kontrollelement Filter anzeigen wird der aktuelle Filter angezeigt.

Bei einem:

  • Textfilter wird der Ausdruck [Txt] angezeigt
  • Relativzeitfilter wird ein Ausdruck nach folgendem Schema angezeigt:
    [T,Rel:%dd,%dh,%dm;%ds]
    Beispiel: [T,Rel:1d,0h,0m,0s] entspricht einem Tag.

Noch in diesem Kapitel

Aussehen der CEL anpassen


Aussehen der CEL anpassen

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> Bild vom Typ CEL anlegen -> Aussehen der CEL anpassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die tabellarischen Darstellung der Chronologischen Ereignisliste kann an individuelle Vorgaben angepasst werden:

Bildlaufleisten, Kopfzeile und Raster

Um Größe und Aussehen von Bildlaufleisten, der Kopfzeile und eines Rasters für die Tabelle zu definieren:

  1. aktivieren Sie in den Projekteigenschaft in der Gruppe Darstellung die Eigenschaft Erweiterte grafische Einstellungen

    Interne ID: Aussehen der CEL anpassen

    Erweiterte grafische Einstellungen

    Nur für PC verfügbar.

    Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

    Default: inaktiv.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der CEL anpassen

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie die gewünschten Eigenschaften in den Gruppen Bildlaufleisten und Kopfzeile und Raster für das Element Chronologische Ereignisliste im Bild

    Interne ID: Aussehen der CEL anpassen

    Kopfzeile und Raster

    Eigenschaften für die Kopfzeile und das Raster.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der CEL anpassen

    Bildlaufleisten

    Eigenschaften für die horizontalen und vertikalen Bildlaufleisten.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wird für die Eigenschaft Anzeigestil Grafikdateien gewählt, dann werden alle Elemente, für die keine Grafikdatei ausgewählt wird, mit einem Farbverlauf dargestellt. Bei Steuerelementen für Listen können keine transparenten Grafiken verwendet werden.

Interne ID: Aussehen der CEL anpassen

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: Aussehen der CEL anpassen

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: Aussehen der CEL anpassen

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der CEL anpassen

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: Aussehen der CEL anpassen

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der CEL anpassen

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Aussehen der CEL anpassen

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: Aussehen der CEL anpassen

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: Aussehen der CEL anpassen

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der CEL anpassen

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zur Runtime sortieren

Um zur Runtime die für die Sortierung relevante Spalte zu kennzeichnen und die Sortierreihenfolge zu bestimmen, projektieren Sie grafische Elemente für die Titelzeile:

  1. wählen Sie für die Eigenschaft Anzeigestil den Wert Grafikdateien
  2. verknüpfen Sie die Eigenschaften Aufsteigend sortiert und Absteigend sortiert jeweils mit einer Grafikdatei

    Interne ID: Aussehen der CEL anpassen

    Absteigend sortiert

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für absteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

    Interne ID: Aussehen der CEL anpassen

    Anzeigestil

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

    Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

    Interne ID: Aussehen der CEL anpassen

    Winkel [°]

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

    Minimum: 0

    Maximum: 360

    Default: 0

    Mehr im Online-Handbuch AML.

    Mehr im Online-Handbuch CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der CEL anpassen

    Versatz [%]

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

    Minimum: -100

    Maximum: 100

    Default: 0

    Mehr im Online-Handbuch AML.

    Mehr im Online-Handbuch CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der CEL anpassen

    Farbverlauf

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

    Linear: gleichmäßiger Verlauf

    Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

    Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

    Default: Linear

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der CEL anpassen

    Verlaufsfarbe

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

    Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der CEL anpassen

    Füllfarbe

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

    Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

    Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

    Default: Standard.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Default: keine Datei

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der CEL anpassen

    Aufsteigend sortiert

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für aufsteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

    Default: keine Datei

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. zur Runtime wird in der für die Sortierung relevanten Spalte die gewählte Grafik für die jeweilige Sortierrichtung angezeigt
  4. Klick auf Grafik ändert Sortierreihenfolge
  5. Klicke in Spaltentitel aktiviert Spalte für Sortierung

Kopfzeile zur Runtime bedienen

Sie können Benutzern ermöglichen, die Kopfzeile zur Runtime zu bedienen. Dadurch ist eine individuelle Anpassung der Darstellung in der Runtime möglich:

  • Spalten verschieben
  • Größe ändern
  • Sortierung ändern.

Navigieren Sie dazu in den Projekteinstellungen zur Gruppe Chronologische Ereignisliste und wählen Sie bei der Eigenschaft Kopfzeile CEL den Wert bedienbare Kopfzeile. Alternativ können Sie hier die Kopfzeile auch unbedienbar oder unsichtbar schalten.

Diese Einstellungen gelten für alle Kopfzeilen im Projekt.

info Info

Sie können die Bedienbarkeit bzw. die Sichtbarkeit der Kopfzeile für jedes Bild vom Typ Chronologische Ereignisliste individuell wieder unterbinden, indem Sie die Eigenschaft Kopfzeile anzeigen bzw.Kopfzeile bedienbar für die tabellarische Darstellung deaktivieren.

Interne ID: Aussehen der CEL anpassen

Kopfzeile bedienbar

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile selektiert haben.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Ermöglicht es die Kopfzeile für das entsprechende Listenfeld zu bedienen. Zur Runtime können Sie die einzelnen Spalten verschieben und ihre Breite verändern. Sie könne die Darstellung nach einer beliebigen Spalte sortieren.

aktiv: Die Kopfzeile ist bedienbar.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Vorschau

Mit Aktivierung der Eigenschaft Erweiterte grafische Einstellungen werden im Editor die Kopfzeile und die Bildlaufleisten als Vorschau angezeigt.So lassen sich Details wie Farben Fülleffekte, Lichteffekte oder Raster einfacher projektieren.

Achtung: Da die Größe der Bildlaufleisten in der Vorschau der Größe zur Runtime entspricht, kann die gesamte Größe des Liste im Editor von der Größe zur Runtime abweichen. Das gilt auch für die Größe der Kopfzeile und die Schrift der Kopfzeile.


Bild vom Typ CEL Filter anlegen

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> Bild vom Typ CEL Filter anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ Chronologische Ereignisliste Filter ermöglicht es, zur Runtime individualisierte Filtereinstellungen für die Chronologische Ereignisliste vorzunehmen. Es werden nur die benötigen Filter projektiert und dem Benutzer zur Verfügung gestellt. Das Aussehen lässt sich frei definieren und damit an unterschiedliche Endgeräte anpassen. Es können alle Filtereinstellungen, die auch im Filter für die Funktion Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste vorhanden sind, projektiert werden.

Damit:

  • werden nur die wirklich benötigten Filterelemente projektiert und dem Benutzer zur Verfügung gestellt
  • bekommt der Benutzer nur diese Filter angezeigt und gewinnt Übersicht
  • kann das Aussehen völlig frei definiert werden und so zum Beispiel auch eine leichte Bedienung über einen Touchscreen realisiert werden

Details zur Handhabung zur Runtime, siehe Abschnitt CEL Filter benutzen .

Definition der Filterkriterien, siehe Abschnitt Filter für Bildumschaltung CEL Filter.

attention Achtung

Bilder vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter und Zeitfilter müssen mit einer eigenen Schablone projektiert werden. Besitzen sie die gleiche Schablone wie andere Bilder werden zur Runtime beim Schließen des Bildes alle auf dieser Schablone basierenden Bilder ebenfalls geschlossen.

Bild vom Typ Chronologische Ereignisliste Filter anlegen

Um ein Bild vom Typ Chronologische Ereignisliste Filter anzulegen:

  1. wählen Sie in der Symbolleiste oder im Kontextmenü des Knotens Bilder den Befehl Bild neu
  2. ein leeres Bild vom Typ Standard wird aufgeschaltet
  3. ändern Sie in der Detailansicht den Bildtyp, dazu
    1. klicken Sie in der Spalte Bildtyp auf Standard
    2. wählen Sie in der Dropdownliste den Eintrag Chronologische Ereignisliste Filter aus
  4. wählen Sie eine eigene Schablone
    (CEL Filter darf nicht auf derselben Schablone wie andere Bilder basieren)
  5. klicken Sie in das Bild
  6. wählen Sie in der Menüleiste den Menüpunkt Kontrollelemente
  7. klicken Sie in der Dropdownliste auf Vorlage einfügen
  8. der Dialog zur Auswahl einer Vorlage wird geöffnet
  9. wählen Sie die gewünschte Vorlage aus
  10. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diesen am gewünschten Platz im Bild ein
  11. legen Sie eine Bildumschaltfunktion an, um das Bild zur Runtime aufrufen zu können

Elemente

Das Bild vom Typ Chronologische Ereignisliste Filter kann folgende Steuer- und Anzeigeelemente enthalten.

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Allgemeine Filter

Dropdownliste verschiedener allgemeiner Filter.

Alle Elemente einfügen: Allgemeine Filter

Fügt alle Elemente aus dem Bereich Allgemeine Filter an vordefinierten Plätzen ein. Elemente können individuell angeordnet werden.

Variablenfilter

Alarme welcher Variablen werden angezeigt:
  • Variablenname

Filtern nach Namen der Variablen.
  • Kennung

Filtern nach Kennung der Variablen.
  • Groß-/Kleinschreibung beachten

Groß- und Kleinschreibung bei der Filterung der Variablen beachten.

Datenherkunft

Woher stammen die Daten:
  • Ringpuffer

Aus dem Ringpuffer.
  • Historische Daten

Aus einem Archiv.
  • Beschriftung: Maximale Anzahl

Text für Eingabefeld Maximale Anzahl

  • Eingabefeld: Maximale Anzahl

Eingabe der maximal anzuzeigenden Alarme bei Anzeige historischer Alarme.

0: zeigt alle an

Runtime Einstellungen

  • Liste angehalten aufschalten

Schaltet die AML in angehaltenem Zustand auf. Neue Alarme werden nicht hinzugefügt.
  • Relativzeiten anzeigen

Schaltet zwischen der normalen Anzeige und der Relativzeit-Anzeige um, ohne dass der selektierte Eintrag den Fokus verliert.

Relativzeit: Alle Einträge werden im zeitlichen Abstand zum selektierten Eintrag angezeigt.

Die angegebene Zeit ist die Differenz-Zeit, die seit dem selektierten Ereignis verstrichen ist. Der selektierte Eintrag erhält automatisch den Zeitstempel 0. Die anderen Ereignisse haben eine:

  • positive Zeitdifferenz zum selektierten Eintrag, wenn sie später stattfanden
  • negative Zeitdifferenz zum selektierten Eintrag, (wenn sie vorher stattfanden

Alarm/Ereignis-Gruppen/Alarm/Ereignis-Klassen/Alarmbereiche

Listenfelder für gruppierte Anzeige:
  • Alarm/Ereignis-Gruppen

Alarm/Ereignis-Gruppen
  • Alarm/Ereignis-Klassen

Alarm/Ereignis-Klassen
  • Alarmbereiche

Alarmbereiche

Zeitfilter

Dropdownliste verschiedener Zeitfilter.

Alle Elemente einfügen: Absoluter Zeitraum - klassische Darstellung

Fügt alle Elemente für die Definition absoluter Zeiträume ein: Jedes Element erhält ein eigenes Feld.

Alle Elemente einfügen: Absoluter Zeitraum - kleine Darstellung

Fügt Elemente für die Definition absoluter Zeiträume in kompakter Darstellung ein.

Alle Elemente einfügen: Relativer Zeitraum

Fügt alle Elemente für die Definition relativer Zeiträume ein.

Alle Elemente einfügen: Ab HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Stunden-Minuten-Sekunden ein.

Alle Elemente einfügen: Ab Tag, Monat - HH:MM:SS Uhr

Fügt alle Elemente für die Definition von Ab-Zeitpunkten im Format Tag-Monat-Stunden-Minuten-Sekunden ein.

Beschriftung: Zeitfiltertyp

Beschriftung für Typ des Zeitfilters.

Combobox: Zeitfiltertyp

Combobox Zeitfilterty.

Anzeige: Zeitfiltertyp

Feld für Anzeige Zeitfiltertyp.

Zeit von

Felder und Beschriftungen für Angaben "Von"-Zeit.
  • Beschriftung: Von Jahr

  • Combobox: Von Jahr

  • Beschriftung: Von Monat

  • Combobox: Von Monat

  • Beschriftung: Von Tag

  • Combobox: Von Tag

  • Beschriftung: Von Stunde

  • Combobox: Von Stunde

  • Beschriftung: Von Minute

  • Combobox: Von Minute

  • Beschriftung: Von Sekunde

  • Combobox: Von Sekunde

  • Spincontrol: Von

Zeit bis

Felder und Beschriftungen für Angaben "Bis"-Zeit.
  • Beschriftung: Bis Jahr

  • Combobox: Bis Jahr

  • Beschriftung: Bis Monat

  • Combobox: Bis Monat

  • Beschriftung: Bis Tag

  • Combobox: Bis Tag

  • Beschriftung: Bis Stunde

  • Combobox: Bis Stunde

  • Beschriftung: Bis Minute

  • Combobox: Bis Minute

  • Beschriftung: Bis Sekunde

  • Combobox: Bis Sekunde

  • Spincontrol: Bis

Absolutzeitfilter

Felder und Beschriftungen für Angaben absoluter Zeitfilter.
  • Beschriftung: Von

  • Kalenderanzeige: Von Datum

  • Datumsanzeige: Von Datum

  • Zeitanzeige: Von Zeit

  • Beschriftung: Bis

  • Kalenderanzeige: Bis Datum

  • Datumsanzeige: Bis Datum

  • Zeitanzeige: Bis Zeit

Textfilter

Dropdownliste verschiedener Textfilter.

Alle Elemente einfügen: Textfilter

Fügt alle Elemente für Textfilter ein.

Kein Textfilter

Radiobutton für Abwahl Textfilter.

Suchen nach (Wörter getrennt durch Leerzeichen)

Radiobutton für Aktvierung der Suche

Beschriftung: Suchtext

Beschriftung für Suchfeld.

Eingabefeld: Suchtext

Feld für Eingabe der Suchbegriffe.

Optionen

Optionen für Suche
  • Groß-/Kleinschreibung beachten

Groß-/Kleinschreibung muss beachtet werden.
  • Wörter müssen nicht vollständig im Text vorkommen

Es wird auch nach Fragmenten gesucht.
  • Mindestens ein Wort muss im Text vorkommen

Mindestens ein Suchbegriff von mehreren muss im Ergebnis enthalten sein.
  • Alle Wörter müssen im Text vorkommen

Alle Suichbegriffe müssen im Ergebnis enthalten sein.
  • Filtertext muss exakt im Text vorkommen

Text aus dem Eingabefeld muss exakt im ergebnis enthalten sein.

OK

Eingaben übernehmen und Bild schließen.

Abbrechen

Eingaben verwerfen und Bild schließen.

Übernehmen

Eingaben übernehmen und bild für weitere Eingaben geöffnet lassen.

Aktualisieren

Bild aktualisieren.

Filterbilder

Filterbilder ermöglichen es, einen voreingestellten Filter von einem Bild auf ein anderes zu übertragen. Der Filter des Quellbildes wird über das Zielbild gelegt. Die Bilder können auch von unterschiedlichen Bildtypen sein.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.

Aufrufdefinition

Folgende Voraussetzungen müssen erfüllt sein, damit die eingestellten Filter zur Anwendung kommen:

  1. Als Zeitbereich beim Zeitfilter wird Filter beim Zeitfiltertyp einstellen gewählt.
  2. Das Bild (Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter oder Zeitfilter) wird mithilfe eines Buttons oder eines Combi-Elements aktiviert. Nur so wird der Bezug zwischen Filterbild und Quellbild gewährleistet.
  3. Das Quellbild und das Filterbild müssen auf unterschiedlichen Schablonen oder Monitoren projektiert sein. Nur wenn das Quellbild offen ist, kann der Filter für das Filterbild aktualisiert werden. Das ist nur möglich, wenn beide Bilder nicht dieselbe Schablone oder den selben Monitor verwenden.
  4. Das aufrufende Bild muss mit dem aufzurufenden Filterbild kompatibel sein (siehe Tabelle).
Quellbild | AML Filter | CEL Filter | Zeitfilter
Archiv-Nachbearbeitung | T | T | T
Erweiterter Trend | T | T | T
Zeitfilter | T | T | X
Alarmmeldeliste Filter | X | C | T
Chronologische Ereignisliste Filter | C | X | T
Alarmmeldeliste | X | C | T
Chronologische Ereignisliste | C | X | T

Legende:

  • C: Gemeinsame Einstellungen werden aktualisiert.
  • T: Zeiteinstellungen werden aktualisiert.
  • X: Alle Einstellungen werden aktualisiert.

info Info

Keine Filterung

Das Filterbild wird nicht gefiltert, sondern mit den projektierten Werten aufgeschaltet, wenn:

  • eine der Bedingungen 1 bis 3 nicht erfüllt wird oder
  • die Einstellung Aufrufendes Bild bei der Funktion Bildumschaltung nicht aktiviert ist oder
  • das Bild nicht über ein Bildelement aufgerufen wird

In diesem Fall werden zur Runtime die Buttons Übernehmen, Schließen und Aktualisieren ausgegraut dargestellt und haben keine Funktion.


Ereignisse für CEL definieren

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> Ereignisse für CEL definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Welcher Ereignisse in der Chronologischen Ereignisliste protokolliert werden, definieren Sie über:

  1. Eigenschaften der Gruppe Protokollierung im Knoten Chronologische Ereignisliste in den Projekteigenschaften

    Interne ID: Ereignisse für CEL definieren

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Ereignisse für CEL definieren

    Protokollierung

    Allgemeine Eigenschaften für die Chronologische Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Alarm-Löschen

      Interne ID: Ereignisse für CEL definieren

      Alarm-Löschen

      Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
      Aktiv: Wird ein löschpflichtiger Alarm gelöscht, erfolgt ein Eintrag in die Chronologische Ereignisliste (CEL).
      Inaktiv: Beim Löschen von Alarmen erfolgt kein Eintrag in die CEL.
      Default: inaktiv.

      Interne ID: Ereignisse für CEL definieren

      Alarmmeldeliste aktiv

      Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
      Inaktiv: Alarme werden nicht aufgezeichnet.
      Default: aktiv.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Alarm-Quittierung

      Interne ID: Ereignisse für CEL definieren

      Alarm-Quittierung

      Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
      Aktiv: Wird ein Alarm quittiert, erfolgt ein Eintrag in die Chronologische Ereignisliste (CEL).
      Inaktiv: Das Quittieren von Alarmen führt zu keinem Eintrag in der CEL.
      Default: inaktiv.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Funktion SW-Setzen

      Interne ID: Ereignisse für CEL definieren

      Funktion SW-Setzen

      Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
      Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
      Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
      Default: inaktiv
      Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

      Interne ID: Ereignisse für CEL definieren

      CEL aktiv

      Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
      Inaktiv: Keine Ereignisse werden aufgezeichnet.
      Default: aktiv

      Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Rezepte absetzen

      Interne ID: Ereignisse für CEL definieren

      Rezepte absetzen

      Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
      Keine Protokollierung: Das Absetzen von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
      Rezepte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts in der CEL protokolliert.
      Rezepte und Werte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts sowie den Namen und alten und neuen Werten der Variablen in der CEL protokolliert.
      Default: keine Protokollierung

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Rezepte ändern

      Interne ID: Ereignisse für CEL definieren

      Rezepte ändern

      Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
      Keine Protokollierung: Das Ändern von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
      Rezepte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts in der CEL protokolliert.
      Rezepte und Werte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts sowie den Namen und alten und neuen Werten der geänderten Variablen in der CEL protokolliert.
      Default: keine Protokollierung

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Archivdaten

      Interne ID: Ereignisse für CEL definieren

      Archivdaten

      Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
      Keine Protokollierung: Das Editieren von Archiven wird in der CEL nicht mitprotokolliert.
      Änderungen protokollieren: Beim Editieren von Archiven wird der Name des Archivs, der Name der Variable sowie der alte und neue Wert und der alte und neue Zeitstempel in der CEL protokolliert.
      Default: keine Protokollierung

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Archiv Auslagerung [h]

      Interne ID: Ereignisse für CEL definieren

      Archiv Auslagerung [h]

      Zeit in Stunden für Fehlerbehandlung.

      Wird beim Auslagern von Archiven ein Fehler festgestellt, erfolgt nach der eingestellten Zeitspanne ein Eintrag in die Chronologischen Ereignisliste (CEL).

      Kann eine ARX-Datei nicht gelesen werden, wird diese in .ar_ umbenannt und die nächste Datei verwendet.
      Default: 12

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Eigenschaften der Variablen
    • AML/CEL in Gruppe Grenzwerte

      Interne ID: Ereignisse für CEL definieren

      Grenzwerte

      Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

      Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

      Interne ID: Ereignisse für CEL definieren

      Reaktionsmatrix aktiv

      Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
      Inaktiv: Grenzwerte können für die Variable definiert werden.
      Default: inaktiv.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Ereignisse für CEL definieren

      AML/CEL

      Eigenschaften für die Alarm- und Chronologische Ereignisliste (CEL).

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Gruppe Protokollierung in CEL im Knoten Sollwert absetzen

      Interne ID: Ereignisse für CEL definieren

      Sollwert absetzen

      Eigenschaften für das Setzen von Sollwerten.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Ereignisse für CEL definieren

      Protokollierung in CEL

      Eigenschaften für die Protokollierung in der Chronologischen Ereignisliste (CEL).

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Sollwertänderungen protokollieren

Sollwertänderungen sind über verschiedene Mechanismen möglich. Dieser werden je nach Einstellung und Modul in der CEL protokolliert.

Parameter

Beschreibung

Protokollierung von Sollwert Setzen Sollwert absetzen

Für jede Variable kann die Protokollierung von Sollwertänderungen definiert werden. Dazu stehen in der Eigenschaft Protokollierung in der Gruppe Sollwert absetzen folgende Optionen zur Verfügung:

Interne ID: Ereignisse für CEL definieren

Protokollierung

Legt fest, wie das Sollwert Absetzen in der CEL protokolliert wird:

Alles: Alle "Sollwert absetzen" Aktionen dieser Variable über dynamische Elemente und "Sollwert setzen" Funktionen werden in der Chronologischen Ereignisliste (CEL) protokolliert.
Nichts: Keine "Sollwert absetzen" Aktionen werden in der CEL protokolliert.
Nur über Dyn. Element: Nur "Sollwert absetzen" Aktionen über dynamische Elemente werden in der CEL mitprotokolliert.
Default: Nur über Dyn. Element

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alles: Alle Änderungen über Dynamische Elemente und die Funktion Sollwert absetzen werden protokolliert.

Nichts: Änderungen werden nicht protokolliert.
Nur über Dynamische Elemente: Protokolliert nur Sollwert absetzen über Dynamische Elemente, nicht aber über die Funktion Sollwert absetzen.

Alter und neuer Wert

Mit der Eigenschaft Alter und neuer Wert wird festgelegt, ob nur neue oder auch alte Werte in das Protokoll geschrieben werden.

Interne ID: Ereignisse für CEL definieren

Alter und neuer Wert

Aktiv: Beim Ändern des Sollwerts dieser Variable werden der alte und der neue Wert in der Chronologischen Ereignisliste (CEL) protokolliert.
Inaktiv: Nur der neue Wert wird protokolliert.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Eigenschaft wirkt sich aus auf Sollwert absetzen per:

  • Dynamisches Element
  • Funktion SW absetzen
  • Sollwert setzen über VBA

Sollwert setzen über VBA

Wird die Funktion SW setzen über VBA aktiviert, werden Sollwertänderungen per VBA in der CEL protokolliert.

Interne ID: Ereignisse für CEL definieren

SW setzen über VBA

Aktiv : Setzen des Sollwerts dieser Variable über ein VBA-Makro wird in der Chronologischen Ereignisliste (CEL) protokolliert.
Inaktiv: Setzen des Sollwerts dieser Variable über ein VBA-Makro wird nicht protokolliert.
Default: aktiv

Hinweis: Bei Variablen, die im IEC870 process gateway als Befehlsvariable konfiguriert sind, wird bei aktiver Eigenschaft jeden Befehl als Sollwert Absetzen über die COM-Schnittstelle in der CEL protokolliert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Rezepte Standard und Rezeptgruppen-Manager

Für die Standard Rezepte und den Rezeptgruppen-Manager wird die Protokollierung über die Eigenschaften der Gruppe Protokollierung im Knoten Chronologische Ereignisliste gesteuert.

PFS/Scheduler

Der Production and Facility Scheduler und der Scheduler protokollieren alle Sollwertänderungen in der CEL. Diese Einstellung ist nicht konfigurierbar.

Hinweis: Es wird nur neuer Wert protokolliert. Die Eigenschaft Chronologische Ereignisliste wird nicht berücksichtigt.

Noch in diesem Kapitel

Sollwert schreiben überprüfen

Länge statischer Grenzwerttext CEL


Sollwert schreiben überprüfen

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> Ereignisse für CEL definieren -> Sollwert schreiben überprüfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Schreiben von Werten erhält der Wert ein Statusbit, dass er geschrieben wird. Ist der Schreibvorgang erfolgreich, wird das entsprechende Statusbit gesetzt:

  • WR-ACK

    Der Treiber hat einen Wert zum Schreiben bekommen.

  • WR-SUC

    Wert 1: Schreiben erfolgreich.

    Wert 0: Schreiben nicht erfolgreich, der Wert konnte nicht abgesetzt werden.

info Info

Wird ein Nachladen oder eine Server-Standby-Umschaltung ausgeführt, dann werden die anstehenden Rückmeldungen bzw. Schreibbestätigungen verworfen!

Diese Statuskombination bleibt solange bestehen, bis die nächste Wertänderung angestoßen wird. Dann gehen beide Status auf 0 bis der Schreibvorgang fertig ist. Zur Auswertung muss in der Rema folgende Bitkombination abgefragt werden:

WR-ACK, WR-SUC

Ergebnis:

  • WR-ACK 1, WR-SUC 1: Schreibvorgang erfolgreich.
  • WR-ACK 1, WR-SUC 0: Schreibvorgang nicht erfolgreich.

attention Achtung

Der Mechanismus zeigt nur, dass der Schreib Vorgang erfolgreich (oder nicht erfolgreich) auf die Steuerung abgesetzt wurde. Es bedeute nicht, dass der Wert in der Steuerung auch geändert wurde, da die Steuerung den Wert sofort wieder zurücksetzen/überschreiben kann. (Zum Beispiel beim Schreiben auf Ausgänge oder bei Wischerbits, die nur kurzfristig gesetzt werden.)

Module

Dieser Mechanismus kann bei folgenden Modulen eingesetzt werden:

  • Funktion Sollwert absetzen: Option Schreibbestätigung abwarten im Konfigurationsdialog der Funktion aktivieren.
  • Standard Rezepte: Eigenschaft Synchron schreiben aktivieren.

    Interne ID: Sollwert schreiben überprüfen

    Synchron schreiben

    Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
    Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
    Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
    Inaktiv: Es wird keine Schreibbestätigung abgewartet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Rezeptgruppen-Manager: Eigenschaft Synchron schreiben aktivieren.

Eintrag in CEL

  • Funktion Sollwert absetzen

    Für den Eintrag in der CEL muss in den Projekteigenschaften im Knoten Chronologische Ereignisliste die Eigenschaft Funktion SW-Setzen aktiviert werden. Es wird dann bei jedem Ausführen der Funktion die positive oder negative Rückmeldung in die CEL geschrieben.

    Interne ID: Sollwert schreiben überprüfen

    Funktion SW-Setzen

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
    Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
    Default: inaktiv
    Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

    Interne ID: Sollwert schreiben überprüfen

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Sollwert schreiben überprüfen

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Standard Rezepte und Rezeptgruppen Manager

    Für den Eintrag in die CEL wird eine Systemtreibervariable verwendet, die bei erfolgreich abgesetzten Rezept auf 1 geht. Eine globale Variable wird am am Server ausgewertet, eine lokale auf jedem Client, um zu erfahren, wann das zuletzt ausgeführte Rezept fertig geschrieben wurde.
    Mit diesen Variablen kann per Grenzwert oder Reaktionsmatrizen einen CEL Eintrag generiert werden. Die Abfrage erfolgt mit einer Multianalog oder einer Multibinär Rema.


Länge statischer Grenzwerttext CEL

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> Ereignisse für CEL definieren -> Länge statischer Grenzwerttext CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mithilfe der Eigenschaft Länge statischer Grenzwerttexte CEL legen Sie fest, aus wie vielen Zeichen der Meldungstext in der CEL bestehen darf. Für jede CEL-Datei wird die erlaubte Länge des Meldungstexts im Header gespeichert. Die Änderung dieser Eigenschaft wirkt sich erst dann aus, wenn eine neue CEL-Datei erzeugt wird.

Interne ID: Länge statischer Grenzwerttext CEL

Länge statischer Grenzwerttexte CEL

Länge des statischen Grenzwerttexts in der CEL in Zeichen.

Legt fest, aus wie vielen Zeichen der statische Grenzwerttext in der CEL maximal bestehen darf. Die Minimal- und Maximalwerte gelten auch für VBA/VSTA.

Minimum: 127

Maximum: 1023

Default: 127

Einschränkung: Beim dBase-Export ist die Länge auf 256 Zeichen beschränkt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Beim dBase-Export ist die Länge auf 254 Zeichen beschränkt.

CEL.BIN und Netzwerk

In der Datei CEL.BIN werden Meldungstexte als String mit variabler Länge gespeichert und ebenso im Netzwerk übertragen. Das bedeutet, dass CEL-Einträge aus dem Ringpuffer unabhängig von der Eigenschaft Länge statischer Grenzwerttexte CEL nicht längenbegrenzt sind.


CEL-Projektierung über Filter

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Anzeige der Ereignisse zur Runtime projektieren Sie über Filter. Sie haben dazu mehrere Möglichkeiten:

  1. Informationen, die zur Runtime in der CEL angezeigt werden, definieren:
    Damit legen Sie fest, welche Informationen zu einem Ereignis angezeigt werden.
    Details siehe: Spalteneinstellung für Chronologische Ereignisliste.
  2. Ereigniss für die CEL beim Aufschalten filtern und zur Runtime modifizieren:
    Damit definieren Sie Filter vor, geben am dem Bediener an der Maschine die Möglichkeit, eigene Filter zu definieren.
    Details siehe: Filter für Bildumschaltung CEL.
  3. Filter für die Runtime fest vorgeben:
    Damit erstellen Sie Filter, die auf den tatsächlichen Einsatz zugeschnitten sind und blenden nicht benötigte Filterkriterien aus.
    Details siehe: Filter für Bildumschaltung CEL-Filter.

Noch in diesem Kapitel

Spalteneinstellung für Chronologische Ereignisliste

Filter für Bildumschaltung CEL

Filter für Bildumschaltung CEL-Filter


Spalteneinstellung für Chronologische Ereignisliste

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Spalteneinstellung für Chronologische Ereignisliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Welche Informationen zur Runtime in der CEL angezeigt werden, legen Sie in den Spalteneinstellungen fest. Diese konfigurieren Sie bei einer Funktion Bildumschaltung in den Filterkriterien oder direkt in den Eigenschaften der Alarmmeldeliste im Projekt:

  1. öffnen Sie in den Projekteigenschaften den Knoten Chronologische Ereignisliste

    Interne ID: Spalteneinstellung für Chronologische Ereignisliste

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie auf die Eigenschaft Spalteneinstellung CEL

    Interne ID: Spalteneinstellung für Chronologische Ereignisliste

    Spalteneinstellung CEL

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
    Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

    Interne ID: Spalteneinstellung für Chronologische Ereignisliste

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog für die Spalteneinstellungen wird geöffnet
  4. Hinweis: Für die Berechnung der Spaltenbreite wird die durchschnittliche Zeichenbreite der gewählten Schriftart verwendet.

info Info

In den Projekteinstellungen können Sie mithilfe der Eigenschaft Spalteneinstellung AML bzw.Spalteneinstellung CEL eine Default-Einstellung für die Reihenfolge und die Größe der Spalten vornehmen. Wenn Sie eine neue Funktion vom Typ Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste oder Chronologische Ereignisliste anlegen, wird diese Einstellung als default verwendet. Die Einstellung wird in der Datei project.ini gespeichert.

Interne ID: Spalteneinstellung für Chronologische Ereignisliste

Spalteneinstellung AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

Interne ID: Spalteneinstellung für Chronologische Ereignisliste

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter

Beschreibung

Spalten

Im Listenfeld dieser Registerkarte werden Ihnen alle zur Verfügung stehenden Spaltentypen angezeigt.

Die Reihenfolge der Spaltentypen ändern Sie mithilfe von Drag&Drop im Listenfeld:

  • klicken Sie in die Spalte Spaltentyp
  • verschieben Sie die einzelnen Einträge wie gewünscht

Alternative können Sie die Reihenfolge über die Schaltflächen Selektierten Eintrag nach oben verschieben und Selektierten Eintrag nach unten verschieben anpassen.
  • Checkbox:

Auswahl, welche Spaltentypen angezeigt werden.
  • Beschreibung:

Freier Texteintrag für Beschreibung der Spalte.

Beschreibung ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.

Hinweis: Für die Spaltenbeschreibung ist die zenon Sprachumschaltung verfügbar.
  • Spaltenbreite:

Definiert die Breite der Spalte in Zeichen.

Spaltenbreite ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.
-1: Breite wird zur Runtime über durchschnittliche Zeichenbreite berechnet

Hinweis: Aus Kompatibilitätsgründen erhalten jene Spalten, deren Breite in früheren zenon Versionen nicht geändert werden konnten (Zeitangaben), automatisch den Wert -1.

  • Anzeige:

Für die Spaltentypen

  • Alarm/Ereignis-Klasse Symbol
  • Alarm/Ereignis-Gruppe Symbol
  • Alarmzustand

ist Form der Anzeige zur Runtime auswählbar. Wählen Sie aus der Dropdownliste die gewünschte Form aus.

Selektierten Eintrag nach oben verschieben

Verschiebt ausgewählten Eintrag um eine Position nach oben.

Selektierten Eintrag nach unten verschieben

Verschiebt ausgewählten Eintrag um eine Position nach unten.

Vorschaufeld

Zeigt die im Listenfeld gewählten Spalten in der dort definierten Breite.

Sie können die Spaltenbreiten auch hier anpassen, indem Sie einen Linksklick auf das rechte Ende einer Spalte ausführen, die Maustaste gedrückt halten und die Maus entsprechend nach links oder rechts bewegen.

Tabelleneinstellungen

Absteigend sortieren

Sortiert die Einträge in der Liste nach der Spalte Zeit kommt in absteigender Reihenfolge. Diese Einstellungen gilt für das Aufschalten des Bilds.
In der Runtime können Sie die Sortierreihenfolge durch eine Klick auf den Spaltenkopf ändern. Die momentan verwendete Sortierreihenfolge wird durch einen Pfeil am Spaltenkopf angezeigt.

Raster anzeigen

Blendet eine Raster bei der Darstellung der Liste zur Runtime ein.

Abwechselnde Hintergrundfarbe verwenden

Verwendet abwechselnd die Zeilenfarbe 1 und Zeilenfarbe 2 als Hintergrundfarbe für die Liste in der Runtime.
  • Zeilenfarbe 1

Farbe, die als Hintergrundfarbe für alle ungeraden Zeilen (1, 3, 5 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.
  • Zeilenfarbe 2

Farbe, die als Hintergrundfarbe für alle geraden Zeilen (2, 4, 6 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.

Anzeige in den Zeitspalten

Uhreit

Zeigt die Zeit für einen Listeneintrag in folgender Form an: HH:MM:SS

Datum

Zeigt das Datum für einen Listeneintrag in folgender Form an: TT:MM:JJJJ

Millisekunden

Erweitert den Zeiteintrag um Millisekunden.

Hinweis: Muss aktiviert werden, wenn Millisekunden in Exporten oder Druckausgaben ausgegeben werden sollen.

Tipp: Wenn Sie das automatische Keyboard in der Runtime aktivieren, wird es beim Erscheinen eines Editierfelds aufgeschalten. Damit können Sie die Spalten auch dann konfigurieren, wenn Sie einen Rechner ohne Tastatur verwenden.

attention Achtung

Die Spaltenbreite wird in Zeichen angegeben und ist von der verwendeten Schriftart abhängig. Wenn die Spaltenbreite nicht einem Vielfachen der Zeichenbreite der verwendeten Schriftart entspricht, kann es zu Abweichungen bei der tatsächlichen Spaltenbreite kommen. Das kann zur Folge haben, dass Text abgeschnitten wird bzw. ein Leeraum ensteht.

Lösung: Verwenden Sie Proportionalschriften, wie z.B. Courier New.


Filter für Bildumschaltung CEL

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Filter legen Sie fest, welche Ereignisse zur Runtime angezeigt werden sollen und welche ausgeblendet werden. Filter können im Editor und - je nach nach dem Vorgaben im Editor - zur Runtime definiert werden.

Um die Filterauswahl zur Runtime auf die Bedürfnisse des Operators zuzuschneiden, benutzen Sie statt dem Bild Chronologische Ereignisliste ein Bild vom Typ Chronologische Ereignisliste Filter.

Um eine Bildumschaltung auf ein Bild vom Typ Chronologische Ereignisliste zu projektieren:

  1. erstellen Sie eine Funktion Bildumschaltung auf ein Bild vom Typ Chronologische Ereignisliste
  2. der Filterdialog wird geöffnet und bietet mehrere Registerkarten mit Filterkriterien an:
    • Allgemein
    • Zeit
    • Spalteneinstellungen
    • Text
    • Status
    • Projekt (Steht nur im Integrationsprojekt der Mehrprojektverwaltung zur Verfügung.)
    • Anlagenmodellierung

    Optional können, wenn verknüpfte Variablen oder Indizes vorhanden sind, noch folgende Registerkarten angezeigt werden:

    • Verknüpfungen ersetzen
    • Indizes ersetzen
    • Details dazu lesen Sie im Handbuch Bilder in den Abschnitten Verknüpfungen von Variablen und Funktionen ersetzen und Verknüpfte Symbol e.

Noch in diesem Kapitel

Allgemein

Zeit

Spalteneinstellungen

Text

Status

Projekt

Anlagenmodellierung


Allgemein

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem allgemeinen Filter legen Sie fest, welcher Ereignisse angezeigt werden und welchen Zugriff Sie zur Runtime auf die Einstellung haben. Dazu unterscheiden Sie Ereignisse nach:

  • Art
  • Datenherkunft
  • Variablen
  • Alarm/Ereignis-Gruppen, Klassen und Alarmbereichen

Die folgenden Eigenschaften stehen Ihnen zur Verfügung:

Parameter

Beschreibung

Variablenfilter

Einschränkung auf Ereignisse bestimmter Variablen

Variablenname

Geben Sie den Namen oder den Teil des Namens von Variablen an, nach dem Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Kennung

Geben Sie die Kennung oder die Teilkennung von Variablen an, nach der Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Groß-/Kleinschreibung beachten

Aktiv: Groß- und Kleinschreibung wird bei der Filterung nach Variablenname und/oder Kennung beachtet.

Datenherkunft

Anzeige aktueller oder aktueller und historischer Ereignisse.

Ringpuffer

Aktiv: Es werden nur Daten aus dem Ringpuffer angezeigt.

Historische Daten
Maximale Anzahl

Aktiv: Es werden Daten aus dem Ringpuffer und historische Daten aus der CEL angezeigt.

Die maximale Anzahl der anzuzeigenden Daten inkludiert die Daten aus dem Ringpuffer.

Runtime-Einstellungen

Verhalten der CEL zur Runtime

Liste angehalten aufschalten

Aktiv: Solange die Liste angezeigt wird, werden keine neuen Einträge hinzugefügt.

(Nicht verfügbar für Funktion CEL exportieren.)

Diesen Dialog zur Runtime anbieten

Aktiv: Vor jedem Aufschalten des Bildes wird der Filterdialog geöffnet. Die Filter-Einstellungen können modifiziert werden.

Relativzeit anzeigen

Alle Einträge werden im zeitlichen Abstand zum selektierten Eintrag angezeigt.

Die angegebene Zeit ist die Differenz-Zeit, die seit dem selektierten Ereignis verstrichen ist. Der selektierte Eintrag erhält automatisch den Zeitstempel 0. Die anderen Ereignisse haben eine:

  • positive Zeitdifferenz zum selektierten Eintrag, wenn sie später stattfanden
  • negative Zeitdifferenz zum selektierten Eintrag, (wenn sie vorher stattfanden

Alarm/Ereignis-Gruppen/Klassen, Alarmbereiche

Auswahl von Gruppen, Klassen und Alarmbereichen.

Alarm/Ereignis-Gruppen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Gruppen jene aus, aus denen Alarme angezeigt werden sollen.

Alarm/Ereignis-Klassen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Klassen jene aus, aus denen Alarme angezeigt werden sollen.

Alarmbereiche

Wählen Sie aus den vorhandenen Alarmbereichen jene aus, aus denen Alarme angezeigt werden sollen.

attention Achtung

Betrifft zenon unter Windows CE: CE Systeme, auf denen der Filterdialog angezeigt werden soll, müssen über eine höhere Auflösung als 800*600 Pixel verfügen, damit der Dialog vollständig dargestellt werden kann.


Zeit

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zeitfilter bieten eine komfortable Möglichkeit, um Daten die angezeigt oder exportiert werden sollen, zu begrenzen. Die Zeitfilter sind sehr flexibel einsetzbar und können sowohl im Editor voreingestellt, als auch zur Runtime angepasst werden.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Die hier beschriebenen Mechanismen gelten bei der Bildumschaltung sowie beim Export für:

  • Alarmmeldeliste
  • Chronologische Ereignisliste
  • Archiv-Nachbearbeitung
  • Erweiterter Trend
  • Report Generator
  • Report Viewer

Die Zeitfilterung kann prinzipiell auf zwei Arten erfolgen:

  1. Zeitbereich im Editor vorgeben
    Es werden fixe Zeitbereiche verwendet. Im Editor wird ein Zeitbereich vorgegeben. In der Runtime kann nur mehr nach diesem Zeitbereich gefiltert werden. Auch andere Filter - z.B. Filtern nach Variablenname, Alarm/Ereignis-Gruppen und -Klassen usw. - sind zur Runtime nicht mehr anpassbar.
  2. Zeitfilter zur Runtime anpassbar
    Es werden vorprojektierte Zeiten verwendet. Der Zeitfilter wird im Editor vorgegeben und kann zur Runtime beliebig verändert werden.

info Info

Wird auf ein Bild referenziert, das keine Zeitfilter hat, dann werden die Zeitfilter deaktiviert.

Für die Einstellung Filter bei Zeitfiltertyp einstellen kann die Option Filterdialog in der Runtime anzeigen zwar ausgewählt werden, steht zur Runtime aber nicht zur Verfügung.

Noch in diesem Kapitel

Zeitfilter in der Runtime beliebig veränderbar (Vorprojektierte Zeiten verwenden)

Zeitbereich im Editor vorgeben


Zeitfilter in der Runtime beliebig veränderbar (Vorprojektierte Zeiten verwenden)

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Zeit -> Zeitfilter in der Runtime beliebig veränderbar (Vorprojektierte Zeiten verwenden)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitfilter in der Runtime beliebig veränderbar (Vorprojektierte Zeiten verwenden)

Bei dieser Methode geben Sie im Editor einen Zeitfilter vor. Dieser kann zur Runtime vor der Ausführung angepasst werden. Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über die Buttons Filter und Filter anzeigen verfügen
  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl die Einstellung Filter bei Zeitfiltertyp einstellen aus

    Hinweis: Die Option Filterdialog in der Runtime anzeigen kann zwar ausgewählt werden, steht zur Runtime für die Einstellung die Option Filter bei Zeitfiltertyp einstellen aber nicht zur Verfügung.

  4. wählen Sie den Zeitraum aus der Dropdownliste Zeitfiltertyp

Parameter

Option

Beschreibung

Absoluter Zeitraum

Es wird ein fixer Zeitbereich im Editor vorgegeben. Beim Ausführen der Funktion wird genau der eingestellte absolute Zeitbereich verwendet.
Beispiel: Sie möchten alle Alarme vom 1.1.2011 - 31.12.2011 sehen, dann geben Sie die entsprechenden Daten bei Von und Bis an.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Von

Definiert den Startzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Bis

Definiert den Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Relativer Zeitraum

Es wird ein relativer Zeitbereich angegeben.

Achtung! Dieser Filter wird ständig aktualisiert. Er wandert also mit.

Zum Beispiel: Sie stellen eine relative Zeit von 10 Minuten ein und schalten um 12:00 Uhr ein Bild vom Typ Alarmmeldeliste mit diesem Zeitfilter auf. Dann werden Ihnen beim Aufschalten die Alarme von 11:50 bis 12:00 angezeigt. Wenn das Bild vom Typ Alarmmeldeliste geöffnet bleibt, wird der Filter automatisch aktualisiert. Um 12:01 sehen Sie die Alarme von 11:51-12:01 usw.

Zeit

Definiert den relativen Zeitraum in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab HH:MM:SS Uhr

Es wird eine Uhrzeit angegeben, ab dem der Filter wirkt. Ist die Uhrzeit am heutigen Tag noch nicht erreicht, wird ab der entsprechenden Uhrzeit des Vortages gefiltert.

Beispiel: Sie geben 23:00:00 ein. Ist es bei der Ausführung der Funktion 23:30 Uhr, dann wird von 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist es jedoch 22:30 Uhr, dann wird vom Vortag 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag - HH:MM:SS Uhr

Es werden ein Tag und eine Uhrzeit für den Filterbeginn angegeben. Ist die angegebene Zeit im laufendem Monat noch nicht erreicht, wird die entsprechende Zeit des Vormonats verwendet.

Beispiel: Sie geben Tag 5 - 23:00:00 ein. Ist es bei der Ausführung der Funktion der 10. des Monats um 23:30 Uhr , dann wird vom 5. des Monats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. des Monats, dann wird vom 5. des Vormonats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filter wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag, Monat - HH:MM:SS Uhr

Es werden ein Monat, ein Tag und eine Uhrzeit für den Filterbeginn eingegeben. Ist die angegebene Zeit im laufenden Jahr noch nicht erreicht, wird die entsprechende Zeit des Vorjahres verwendet.

Beispiel: Sie geben Monat Oktober, Tag 5 - 23:00:00 ein. Ist bei der Ausführung der Funktion der 10. Oktober um 23:30 Uhr, dann wird vom 5. Oktober ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. Oktober, dann wird vom 5. Oktober des Vorjahres ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und der 5. Oktober 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Monaten, Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Kein Zeitfilter

Es wird kein Zeitfilter verwendet.

Bei Report Viewer und in der Archiv-Nachbearbeitung werden mit dieser Einstellung alle Einträge seit 1. 1. 2000 angezeigt.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Zeitbereich im Editor vorgeben

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Zeit -> Zeitbereich im Editor vorgeben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitbereich im Editor vorgeben

Bei dieser Methode geben Sie im Editor bereits einen fixen Zeitbereich vor, der beim Ausführen der Funktion zur Runtime angewandt wird. Zur Runtime können Sie nur noch den Startzeitpunkt festlegen, aber keine weiteren Filtereinstellungen mehr verändern.

Zum Beispiel: Sie stellen einen 30 Minuten Zeitfilter ein. In der Runtime können Sie nur mehr einstellen, wann dieser 30 Minuten Zeitraum starten soll. Sie können den Filter aber nicht auf einen Tagesfilter umstellen.

attention Achtung

Bei Verwendung dieser Filterart können Sie zur Runtime auch alle anderen Filter, die auf der Karteikarte Allgemein zur Verfügung stehen, nicht mehr anpassen! Filtern auf Text, Status und Anlagen ist weiter möglich.

Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über den Button Filter verfügen, um den Filter zur Runtime zu starten

    Tipp: Aktivieren Sie im Filterdialog in der Registerkarte Allgemein die Option Filterdialog in der Runtime anzeigen. Damit können Sie den Startzeitpunkt bereits vor Ausführung der Funktion anpassen. Lassen Sie den Filter beim Aufschalten der Funktion in der Runtime nicht anzeigen, so wird immer der aktuelle Zeitbereich verwendet. Haben Sie die Option Letzen abgeschlossenen Zeitbereich verwenden aktiviert, wird der vorangegangene Zeitbereich angezeigt.
    Zum Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option Letzten abgeschlossenen Zeitbereich verwenden wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 bis 10:29:59 gesetzt.

  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl den gewünschten Filter;
    Ausnahme: Filter bei Zeitfiltertyp einstellen - dieser ist für die Option Zeitfilter zur Runtime anpassbar vorgesehen
  4. konfigurieren Sie den ausgewählten Zeitraum

Parameter

Beschreibung

Filter bei Zeitfiltertyp einstellen

Aktiviert die Möglichkeit, den Filter zur Runtime anzupassen.

Ein Tag

Es wird auf einen ganzer Tag gefiltert:
00:00:00 Uhr bis 23:59:59 Uhr.

Eine Woche

Es wird auf eine ganze Woche gefiltert:
Montag 00:00:00 Uhr bis Sonntag 23:59:59 Uhr.

Zwei Wochen

Es wird auf zwei ganze Wochen gefiltert:
Montag 00:00:00 Uhr der ersten Woche bis Sonntag 23:59:59 Uhr der zweiten Woche.

Ein Monat

Es wird auf einen ganzer Monat gefiltert:
Erster Tag des Monats 00:00:00 Uhr bis letzer Tag des Monats 23:59:59 Uhr.

Ein Jahr

Es wird auf ein ganzes Jahr gefiltert:
1.Januar des Jahres 00:00:00 Uhr bis 31. Dezember des Jahres 23:59:59 Uhr.

15 Minuten

Es wird auf einen Zeitbereich von 15 Minuten gefiltert.

30 Minuten

Es wird auf einen Zeitbereich von 30 Minuten gefiltert.

60 Minuten

Es wird auf einen Zeitbereich von 60 Minuten gefiltert.

Relativer Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein relativer Zeitraum in Tagen, Stunden (HH), Minuten (MM) und Sekunden (SS) angegeben werden kann.

Achtung! Der gewählte Zeitraum bezieht sich auf den Aufschaltzeitpunkt. Der gefilterte Zeitbereich wird daraufhin fest eingestellt.
Beispiel: Beim Aufrufen der Funktion ist es 10:23:00. Sie stellen einen relativen Zeitraum von einer Stunde ein. Der Filter wird auf 9:23:00 - 10:23:00 eingestellt.

Absoluter Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein absoluten Zeitraum eingeben könen . Sie legen dabei den Start- und Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS) fest.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Chargen

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt in dem Sie eine Charge auswählen können. Der Zeitfilter wird dann auf den Zeitraum der Charge eingestellt. Sie können damit z.B. nach allen Alarmen oder allen CEL Einträgen die während einer Charge aufgetreten sind filtern.

Hinweis: Der Filter zeigt nur abgeschlossene Chargen an.

Chargen relativ

Nur für Erweiterter Trend.

Darstellung geht immer von Nullpunkt aus. Ermöglicht direkten Vergleich mehrerer Chargen.

Optionen

Zu allen Zeitbereichen (ausgenommen absoluter und relativer Zeitbereich sowie Chargen) sind folgende Einstellungen möglich, um den Zeitbereich anzupassen:

Parameter

Option

Beschreibung

Letzten abgeschlossenen Zeitbereich verwenden

Aktiv: Es wird immer der aktuelle Zeitbereich verwendet. Ist die Option gesetzt wird der vorangegangene Zeitbereich angezeigt.

Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 Uhr bis 10:29:59 Uhr gesetzt.

Zeitbereich nach hinten verschieben um

Aktiv: Der gesamte Zeitbereich wird um die angegeben Zeit nach hinten verschoben. Der Zeitraum bleibt von dieser Einstellung unberührt.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. In der Runtime wird der Filter nun nicht zu jeder vollen Stunde beginnen, sondern immer 5 Minuten später, also z.B. um 10:05:00 Uhr um 11:05:00 Uhr usw. Gefiltert werden nach wie vor 60 Minuten also bis 11:04:59 Uhr bzw. 12:04:59 Uhr usw.

Zeit

Definiert die Zeitverschiebung in Stunden (HH), Minuten (MM), Sekunden (SS)

Zeitraum ändern um

Aktiv: Der gefilterte Zeitraum wird verkürzt oder verlängert.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. Die Option angegeben Zeit dazuzählen ist gesetzt. In der Runtime

werden nun nicht mehr 60 Minuten gefiltert sondern 65 Minuten, also z.B. von 10:00:00 Uhr bis 11:04:59 Uhr.

Zeit

Definiert die Zeit, um die der Zeitraum verkürzt oder verlängert wird. In Stunden (HH), Minuten (MM), Sekunden (SS)

angegebene Zeit dazuzählen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verlängert

angegebene Zeit abziehen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verkürzt

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Spalteneinstellungen

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Spalteneinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Dialog definieren Sie, welche Spalten Sie sich in welcher Form, Reihenfolge und Sortierung anzeigen lassen möchten.

Hinweis: Alle Einstellungen, die Sie in dieser Registerkarte vornehmen, gelten als Default für:

  • Bild vom Typ Alarmmeldeliste
  • Bild vom Typ Alarmmeldeliste Filter
  • Alarmstatuszeile
  • Bild vom Typ Chronologische Ereignisliste
  • Bild vom Typ Chronologische Ereignisliste Filter

Diese Default-Einstellungen können bei der Definition der einzelnen Alarmfunktionen/CEL-Funktionen geändert werden.

info Info

In den Projekteinstellungen können Sie mithilfe der Eigenschaft Spalteneinstellung AML bzw.Spalteneinstellung CEL eine Default-Einstellung für die Reihenfolge und die Größe der Spalten vornehmen. Wenn Sie eine neue Funktion vom Typ Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste oder Chronologische Ereignisliste anlegen, wird diese Einstellung als default verwendet. Die Einstellung wird in der Datei project.ini gespeichert.

Interne ID: Spalteneinstellungen

Spalteneinstellung CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

Interne ID: Spalteneinstellungen

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Spalteneinstellungen

Spalteneinstellung AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

Interne ID: Spalteneinstellungen

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter

Beschreibung

Spalten

Im Listenfeld dieser Registerkarte werden Ihnen alle zur Verfügung stehenden Spaltentypen angezeigt.

Die Reihenfolge der Spaltentypen ändern Sie mithilfe von Drag&Drop im Listenfeld:

  • klicken Sie in die Spalte Spaltentyp
  • verschieben Sie die einzelnen Einträge wie gewünscht

Alternative können Sie die Reihenfolge über die Schaltflächen Selektierten Eintrag nach oben verschieben und Selektierten Eintrag nach unten verschieben anpassen.
  • Checkbox:

Auswahl, welche Spaltentypen angezeigt werden.
  • Beschreibung:

Freier Texteintrag für Beschreibung der Spalte.

Beschreibung ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.

Hinweis: Für die Spaltenbeschreibung ist die zenon Sprachumschaltung verfügbar.
  • Spaltenbreite:

Definiert die Breite der Spalte in Zeichen.

Spaltenbreite ändern: führen Sie eine Linksklick auf den entsprechenden Bereich aus. Tragen Sie im Editierfeld den gewünschten Wert ein.
-1: Breite wird zur Runtime über durchschnittliche Zeichenbreite berechnet

Hinweis: Aus Kompatibilitätsgründen erhalten jene Spalten, deren Breite in früheren zenon Versionen nicht geändert werden konnten (Zeitangaben), automatisch den Wert -1.

  • Anzeige:

Für die Spaltentypen

  • Alarm/Ereignis-Klasse Symbol
  • Alarm/Ereignis-Gruppe Symbol
  • Alarmzustand

ist Form der Anzeige zur Runtime auswählbar. Wählen Sie aus der Dropdownliste die gewünschte Form aus.

Selektierten Eintrag nach oben verschieben

Verschiebt ausgewählten Eintrag um eine Position nach oben.

Selektierten Eintrag nach unten verschieben

Verschiebt ausgewählten Eintrag um eine Position nach unten.

Vorschaufeld

Zeigt die im Listenfeld gewählten Spalten in der dort definierten Breite.

Sie können die Spaltenbreiten auch hier anpassen, indem Sie einen Linksklick auf das rechte Ende einer Spalte ausführen, die Maustaste gedrückt halten und die Maus entsprechend nach links oder rechts bewegen.

Tabelleneinstellungen

Absteigend sortieren

Sortiert die Einträge in der Liste nach der Spalte Zeit kommt in absteigender Reihenfolge. Diese Einstellungen gilt für das Aufschalten des Bilds.
In der Runtime können Sie die Sortierreihenfolge durch eine Klick auf den Spaltenkopf ändern. Die momentan verwendete Sortierreihenfolge wird durch einen Pfeil am Spaltenkopf angezeigt.

Raster anzeigen

Blendet eine Raster bei der Darstellung der Liste zur Runtime ein.

Abwechselnde Hintergrundfarbe verwenden

Verwendet abwechselnd die Zeilenfarbe 1 und Zeilenfarbe 2 als Hintergrundfarbe für die Liste in der Runtime.
  • Zeilenfarbe 1

Farbe, die als Hintergrundfarbe für alle ungeraden Zeilen (1, 3, 5 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.
  • Zeilenfarbe 2

Farbe, die als Hintergrundfarbe für alle geraden Zeilen (2, 4, 6 etc.) der Liste in der Runtime verwendet wird, wenn Sie Abwechselnde Hintergrundfarbe verwenden aktiviert haben.

Anzeige in den Zeitspalten

Uhreit

Zeigt die Zeit für einen Listeneintrag in folgender Form an: HH:MM:SS

Datum

Zeigt das Datum für einen Listeneintrag in folgender Form an: TT:MM:JJJJ

Millisekunden

Erweitert den Zeiteintrag um Millisekunden.

Hinweis: Muss aktiviert werden, wenn Millisekunden in Exporten oder Druckausgaben ausgegeben werden sollen.

Tipp: Wenn Sie das automatische Keyboard in der Runtime aktivieren, wird es beim Erscheinen eines Editierfelds aufgeschalten. Damit können Sie die Spalten auch dann konfigurieren, wenn Sie einen Rechner ohne Tastatur verwenden.

attention Achtung

Die Spaltenbreite wird in Zeichen angegeben und ist von der verwendeten Schriftart abhängig. Wenn die Spaltenbreite nicht einem Vielfachen der Zeichenbreite der verwendeten Schriftart entspricht, kann es zu Abweichungen bei der tatsächlichen Spaltenbreite kommen. Das kann zur Folge haben, dass Text abgeschnitten wird bzw. ein Leeraum ensteht.

Lösung: Verwenden Sie Proportionalschriften, wie z.B. Courier New.

info Info

Wenn Sie Variablen mit Einheiten projektiert haben, wird bei einem Eintrag der Variablen in der Chronologischen Ereignisliste diese Einheit angezeigt. Voraussetzung hierfür ist, dass Sie sich den Spaltentyp Einheit anzeigen lassen.


Text

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Filtern nach |
Kein Textfilter | Der Textfilter wird nicht verwendet.
Suche nach (Wörter getrennt durch Leerzeichen) | Der Textfilter wird verwendet. Die weiteren Optionen sind freigeschalten.
Eingabefeld | Geben Sie die entsprechenden Wörter bzw. Zeichenketten ein.
Optionen |
Groß-/Kleinschreibung beachten | Aktiv: Beim Filtern wird zwischen Groß- und Kleinschreibung unterschieden.
Wörter müssen nicht vollständig im Text vorkommen | Aktiv: Auch Wortteile werden beim Filtern berücksichtigt.
Mindestens ein Wort muss im Text vorkommen | Aktiv: Mindestens ein Wort des Suchstrings muss im Text vorkommen.
Alle Wörter müssen im Text vorkommen | Aktiv: Alle Wörter des Suchstrings müssen im Text vorkommen. Die Reihenfolge spielt dabei keine Rolle.
Filtertext muss exakt im Text vorkommen | Aktiv: Der Text muss exakt wie im Suchstring definiert im vorkommen.


Status

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Status

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Zustand der Checkbox gibt an, ob das Statusbit ausgewertet werden soll.

Status der Checkbox | Beschreibung
schwarzer Punkt | Das Statusbit wird nicht ausgewertet.
0 | Es werden nur die Einträge angezeigt, bei denen das Statusbit auf false steht.
1 | Es werden nur die Einträge angezeigt, bei denen das Statusbit auf true steht.

Example Beispiel

Ist die Checkbox SPONT auf 1 gesetzt, werden nur die Alarme angezeigt, die durch Spontanwerte hervorgerufen wurden.

Hinweis: Details zu Statusbits finden Sie im Kapitel Statusverarbeitung.


Projekt

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Projekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auswahl der Projekte, die für die CEL berücksichtigt werden sollen. Der Filter zur Auswahl von Unterprojekten steht nur im Integrationsprojekt der Mehrprojektverwaltung zur Verfügung.

Die Auswahl aus dem Integrationsprojekt und allen Unterprojekten erfolgt per Multiselect durch Halten der Taste Strg und Mausklick auf die gewünschten Projekte.


Anlagenmodellierung

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL -> Anlagenmodellierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Filter werden alle bereits erstellten Anlagenmodelle angezeigt. Über das Kontextmenü oder die Menüleiste, können neue Modelle und Gruppen angelegt werden.

Um Gruppen zum Filter hinzuzufügen:

  1. wählen Sie das gewünschte Element
  2. klicken Sie auf die Schaltfläche Hinzufügen
  3. wiederholen Sie den Vorgang, bis alle benötigten Gruppen in der Liste enthalten sind
    (Multiselect ist nicht möglich)

Um Gruppen aus dem Filter zu entfernen:

  1. wählen Sie die gewünschten Elemente
    (Multiselect: Taset Strg oder Taste Umschalt gedrückt halten und gewünschte Elemente anklicken)
  2. klicken Sie auf die Schaltfläche Entfernen

Element | Beschreibung
Anlagenmodell | bietet Modelle und Gruppen zur Auswahl an
Hinzufügen | fügt ausgewählte Gruppe zur Filterliste hinzu
Entfernen | entfernt ausgewählte Gruppe aus Filterliste


Filter für Bildumschaltung CEL-Filter

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL-Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Chronologische Ereignisliste Filter zu projektieren:

  1. erstellen Sie eine Funktion Bildumschaltung auf ein Bild vom Typ Chronologische Ereignisliste Filter
  2. der Filter wird mit allen Registerkarten angezeigt:
    • Bilder
    • Allgemein
    • Text
    • Zeit

Noch in diesem Kapitel

Bilder

Allgemein

Text

Zeit


Bilder

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL-Filter -> Bilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Registerkarte definieren Sie die Bilder, die durch den Bildfilter aktualisiert werden sollen.

Folgende Einstellungen stehen Ihnen zur Verfügung:

Parameter

Beschreibung

Filter wird aus folgendem Bild übernommen

Aufrufendes Bild

Aktiv: Die Filtereinstellungen werden aus dem Bild übernommen, möchten, aus dem das Filterbild aufgerufen wird. Die Schaltfläche Bild ist ausgegraut. Sie können kein Bild explizit angeben, da bei dieser Einstellung die Filteraktualisierung immer vom aufrufenden Bild aus erfolgt.

Hinweis: Einstellungen in den Registerkarten Allgemein, Text und Zeit sind gesperrt.

Bildauswahl

Klick auf Schaltfläche öffnet den Bildauswahldialog.

Selektieren Sie das Bild, von dem der Filter - beim Betätigen des Buttons Aktualisieren in der Runtime - gelesen werden soll.

Hinweis: Es ist nur sinnvoll ein Bild zu selektieren, das den Bildfilter übernehmen bzw. füllen kann.

Das selektierte Bild wird in die Liste der zu aktualisierenden Bilder eingetragen. Wenn Sie es aus der Liste löschen, wird automatisch das nächste Bild aus der Liste hier eingetragen.

Hinweis: Nicht verfügbar, wenn Sie die Checkbox Aufrufendes Bild aktiviert haben.

Zu aktualisierende Bilder

Bildauswahl

Klick auf Schaltfläche öffnet Dialog zur Bildauswahl der Filterbilder. Wählen Sie die gewünschten Bilder.

Aktualisierung

Auf allen Monitoren aktualisieren

Aktiv: Die Bilder aus der Liste der zu aktualisierenden Bilder werden auf allen verfügbaren Monitoren aktualisiert.


Allgemein

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL-Filter -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem allgemeinen Filter legen Sie fest, welcher Ereignisse angezeigt werden und welchen Zugriff Sie zur Runtime auf die Einstellung haben. Dazu unterscheiden Sie Ereignisse nach:

  • Art
  • Datenherkunft
  • Variablen
  • Alarm/Ereignis-Gruppen, Klassen und Alarmbereichen

Die folgenden Eigenschaften stehen Ihnen zur Verfügung:

Parameter

Beschreibung

Variablenfilter

Einschränkung auf Ereignisse bestimmter Variablen

Variablenname

Geben Sie den Namen oder den Teil des Namens von Variablen an, nach dem Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Kennung

Geben Sie die Kennung oder die Teilkennung von Variablen an, nach der Sie filtern möchten. Wildcard * ist möglich.

Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.

Groß-/Kleinschreibung beachten

Aktiv: Groß- und Kleinschreibung wird bei der Filterung nach Variablenname und/oder Kennung beachtet.

Datenherkunft

Anzeige aktueller oder aktueller und historischer Ereignisse.

Ringpuffer

Aktiv: Es werden nur Daten aus dem Ringpuffer angezeigt.

Historische Daten
Maximale Anzahl

Aktiv: Es werden Daten aus dem Ringpuffer und historische Daten aus der CEL angezeigt.

Die maximale Anzahl der anzuzeigenden Daten inkludiert die Daten aus dem Ringpuffer.

Runtime-Einstellungen

Verhalten der CEL zur Runtime

Liste angehalten aufschalten

Aktiv: Solange die Liste angezeigt wird, werden keine neuen Einträge hinzugefügt.

(Nicht verfügbar für Funktion CEL exportieren.)

Diesen Dialog zur Runtime anbieten

Aktiv: Vor jedem Aufschalten des Bildes wird der Filterdialog geöffnet. Die Filter-Einstellungen können modifiziert werden.

Relativzeit anzeigen

Alle Einträge werden im zeitlichen Abstand zum selektierten Eintrag angezeigt.

Die angegebene Zeit ist die Differenz-Zeit, die seit dem selektierten Ereignis verstrichen ist. Der selektierte Eintrag erhält automatisch den Zeitstempel 0. Die anderen Ereignisse haben eine:

  • positive Zeitdifferenz zum selektierten Eintrag, wenn sie später stattfanden
  • negative Zeitdifferenz zum selektierten Eintrag, (wenn sie vorher stattfanden

Alarm/Ereignis-Gruppen/Klassen, Alarmbereiche

Auswahl von Gruppen, Klassen und Alarmbereichen.

Alarm/Ereignis-Gruppen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Gruppen jene aus, aus denen Alarme angezeigt werden sollen.

Alarm/Ereignis-Klassen

Wählen Sie aus den vorhandenen Alarm/Ereignis-Klassen jene aus, aus denen Alarme angezeigt werden sollen.

Alarmbereiche

Wählen Sie aus den vorhandenen Alarmbereichen jene aus, aus denen Alarme angezeigt werden sollen.

attention Achtung

Betrifft zenon unter Windows CE: CE Systeme, auf denen der Filterdialog angezeigt werden soll, müssen über eine höhere Auflösung als 800*600 Pixel verfügen, damit der Dialog vollständig dargestellt werden kann.


Text

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL-Filter -> Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Filtern nach |
Kein Textfilter | Der Textfilter wird nicht verwendet.
Suche nach (Wörter getrennt durch Leerzeichen) | Der Textfilter wird verwendet. Die weiteren Optionen sind freigeschalten.
Eingabefeld | Geben Sie die entsprechenden Wörter bzw. Zeichenketten ein.
Optionen |
Groß-/Kleinschreibung beachten | Aktiv: Beim Filtern wird zwischen Groß- und Kleinschreibung unterschieden.
Wörter müssen nicht vollständig im Text vorkommen | Aktiv: Auch Wortteile werden beim Filtern berücksichtigt.
Mindestens ein Wort muss im Text vorkommen | Aktiv: Mindestens ein Wort des Suchstrings muss im Text vorkommen.
Alle Wörter müssen im Text vorkommen | Aktiv: Alle Wörter des Suchstrings müssen im Text vorkommen. Die Reihenfolge spielt dabei keine Rolle.
Filtertext muss exakt im Text vorkommen | Aktiv: Der Text muss exakt wie im Suchstring definiert im vorkommen.


Zeit

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL-Projektierung über Filter -> Filter für Bildumschaltung CEL-Filter -> Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Definieren Sie auf dieser Registerkarte den Zeitbereich, der beim Öffnen des Filterbilds verwendet werden soll.

Folgende Einstellungen stehen Ihnen zur Verfügung:

Parameter

Option

Beschreibung

Absoluter Zeitraum

Es wird ein fixer Zeitbereich im Editor vorgegeben. Beim Ausführen der Funktion wird genau der eingestellte absolute Zeitbereich verwendet.
Beispiel: Sie möchten alle Alarme vom 1.1.2011 - 31.12.2011 sehen, dann geben Sie die entsprechenden Daten bei Von und Bis an.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Von

Definiert den Startzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Bis

Definiert den Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Relativer Zeitraum

Es wird ein relativer Zeitbereich angegeben.

Achtung! Dieser Filter wird ständig aktualisiert. Er wandert also mit.

Zum Beispiel: Sie stellen eine relative Zeit von 10 Minuten ein und schalten um 12:00 Uhr ein Bild vom Typ Alarmmeldeliste mit diesem Zeitfilter auf. Dann werden Ihnen beim Aufschalten die Alarme von 11:50 bis 12:00 angezeigt. Wenn das Bild vom Typ Alarmmeldeliste geöffnet bleibt, wird der Filter automatisch aktualisiert. Um 12:01 sehen Sie die Alarme von 11:51-12:01 usw.

Zeit

Definiert den relativen Zeitraum in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab HH:MM:SS Uhr

Es wird eine Uhrzeit angegeben, ab dem der Filter wirkt. Ist die Uhrzeit am heutigen Tag noch nicht erreicht, wird ab der entsprechenden Uhrzeit des Vortages gefiltert.

Beispiel: Sie geben 23:00:00 ein. Ist es bei der Ausführung der Funktion 23:30 Uhr, dann wird von 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist es jedoch 22:30 Uhr, dann wird vom Vortag 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag - HH:MM:SS Uhr

Es werden ein Tag und eine Uhrzeit für den Filterbeginn angegeben. Ist die angegebene Zeit im laufendem Monat noch nicht erreicht, wird die entsprechende Zeit des Vormonats verwendet.

Beispiel: Sie geben Tag 5 - 23:00:00 ein. Ist es bei der Ausführung der Funktion der 10. des Monats um 23:30 Uhr , dann wird vom 5. des Monats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. des Monats, dann wird vom 5. des Vormonats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filter wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag, Monat - HH:MM:SS Uhr

Es werden ein Monat, ein Tag und eine Uhrzeit für den Filterbeginn eingegeben. Ist die angegebene Zeit im laufenden Jahr noch nicht erreicht, wird die entsprechende Zeit des Vorjahres verwendet.

Beispiel: Sie geben Monat Oktober, Tag 5 - 23:00:00 ein. Ist bei der Ausführung der Funktion der 10. Oktober um 23:30 Uhr, dann wird vom 5. Oktober ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. Oktober, dann wird vom 5. Oktober des Vorjahres ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und der 5. Oktober 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Monaten, Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Kein Zeitfilter

Es wird kein Zeitfilter verwendet.


CEL Ringpuffer

Handbuch -> Chronologische Ereignisliste (CEL) -> CEL projektieren -> CEL Ringpuffer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ereignisse werden, sobald sie auftreten, in einem Ringpuffer (cel.bin) und einer Ereignisdatei (*.cel) im Runtimeordner gespeichert.

Ringpuffer

Der Ringpuffer enthält alle anstehenden Ereignisse. Diese werden verwaltet über:

  • Zeit kommt in Millisekunden als eindeutige Signatur

Größe des Ringpuffers

Die Größe des Ringpuffers muss in den Projekteigenschaften mit der Eigenschaft Größe des Ringpuffers ausreichend dimensioniert werden.

Interne ID: CEL Ringpuffer

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Größe des CEL-Ringpuffers. Bei Überlauf des Ringpuffers (cel.bin) werden die Einträge in das CEL-Archiv (*.cel) übertragen.
Minimum: 1
Maximum: 32767
Default: 100

Interne ID: CEL Ringpuffer

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Zur Runtime werden eventuell mehr Einträge als projektiert angezeigt, da alte Einträge erst beim Aktualisieren der Liste aus der CEL entfernt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zur Runtime werden beim Aufschalten des CEL-Bildes alte Einträge in der Liste belassen. Sobald neue Einträge hinzugefügt werden, kann die Zahl der angezeigten Einträge die für den Ringpuffer projektierte Größe überschreiten. Beim Neuaufschalten der Liste werden die alten Einträge entfernt und die projektierte Größe wird wieder eingehalten. Dieses Verhalten dienst dazu, Datenverlust bei aufgeschalteter Liste zu verhindern.

Achtung: Das Anzeigen von Einträgen über die definierten Wert hinaus belegt zusätzlichen Arbeitsspeicher. Dieser wird beim Neuaufschalten nicht frei gegeben, sondern bleibt beim zuletzt erreichten Höchstwert.

Ringpuffer speichern

Der Ringpuffer wird beim Beenden der Runtime automatisch als cel.bin gespeichert. Wird die Runtime durch unerwartete Ereignisse beendet, wie Spannungsausfall, kommt es zu Datenverlust. Um das zu verhindern, kann der Ringpuffer über die Eigenschaft Ringpuffer bei Wertänderung speichern bei jedem neuen Eintrag oder über die Funktion AML- und CEL-Ringpuffer speichern manuell gespeichert werden.

Interne ID: CEL Ringpuffer

Ringpuffer bei Wertänderung speichern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Aktiv: Jede Änderung der Daten der Chronologischen Ereignisliste (CEL) bewirkt auch das Speichern der Daten (cel.bin).
Hinweis: Damit wird bei jeder Speicherung der gesamte Ringpuffer gespeichert. Das kann - vor allem bei Flash Disks - zu erheblicher Systembelastung führen.
Inaktiv: Daten der CEL (cel.bin) werden beim Beenden der Runtime oder beim Ausführen der Funktion AML- und CEL-Ringspeicher speichern gespeichert. Empfiehlt sich vor allem bei niedriger Performance. Historische Daten (*.cel) können unabhängig von dieser Einstellung bei jeder Wertänderung gespeichert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Ereignisdatei

Alle Alarme werden zeitgleich mit dem Ringpuffer in eine eigene CEL-Datei (*.cel)geschrieben. Diese wird für jeden Kalendertag automatisch erstellt und über die Eigenschaft CEL-Daten speichern verwaltet. Der Name der Datei setzt sich zusammen aus dem Buchstaben C, gefolgt vom Datum in der Form JJMMTT und der Endung .cel, z.B. C100623.aml. Diese Dateien werden für jeden Tag automatisch erstellt und müssen bei begrenztem Speicherplatz vom Anwender ausgelagert oder gelöscht werden. *.cel Dateien werden im Ordner ...\Projektordner\Computername\Projektname gespeichert.

Interne ID: CEL Ringpuffer

CEL-Daten speichern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Ringpuffer und historische Daten: Alle CEL-Einträge (*.cel) werden gespeichert.

Nur Ringpuffer: Nur eine definierte Anzahl von CEL-Einträgen (cel.bin) wird gespeichert. Die Anzahl wird über die Eigenschaft Größe des Ringpuffers definiert.
Default: Auf CE-Geräten wird nur der Ringpuffer (cel.bin) gespeichert; auf PCs werden auch die historischen Einträge (*.cel) gespeichert.
Default: Default
Die Dateien (cel.bin und *.cel) werden im Verzeichnis \Projektverzeichnis\Computername\Projektname gespeichert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Synchronisierung von Ringpuffer und Alarmdatei

Ringpuffer und CEL-Datei werden synchronisiert. Diese Synchronisierung erfolgt immer vom Ringpuffer zur CEL-Datei.

Speicherzeiträume

Die Chronologische Ereignisliste *.cel wird bei jedem neuen Eintrag gespeichert.

Der Ringpuffer (*.bin) wird gespeichert:

  • beim Beenden der Runtime
  • bei aktiver Eigenschaft Ringpuffer bei Wertänderung speichern nach jedem neuen Eintrag
  • beim Ausführen der Funktion AML- und CEL-Ringpuffer speichern

    Interne ID: CEL Ringpuffer

    AML- und CEL-Ringpuffer speichern

    Diese Funktion speichert aktuelle Alarme und Ereignisse in die Dateien ALARM.BIN und CEL.BIN.

    Mehr im Online-Handbuch

Hinweis: Ist die Option Ringpuffer bei Wertänderung speichern deaktiviert, werden nach einem Stromausfall die Einträge in der CEL und im Ringpuffer eventuell nicht mehr übereinstimmen.


Funktionen

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen

Über Funktionen werden zur Runtime die Anzeige und Handhabung der CEL gesteuert.

attention Achtung

Werden Funktionen im Netzwerk eingesetzt, beachten Sie deren Ausführungsort.

Noch in diesem Kapitel

Funktionen im Netzwerk

Bildumschaltung CEL

Bildumschaltung CEL-Filter

Funktionen für Chronologische Ereignisliste


Funktionen im Netzwerk

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen im Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Funktionen im Netzwerk eingesetzt werden, muss deren Ausführungsort beachtet werden:

Bei Funktionen, die im Netzwerk eingesetzt werden:

  • kann der Ausführungsort in manchen Fällen frei konfiguriert werden
  • ist der Ausführungsort in manchen Fällen fest vorgegeben

info Info

Skripte bündeln mehrere Funktionen. Der Ausführungsort hängt dann ab von den Einstellungen der Funktion Skript ausführen. Diese Einstellung überschreibt die Einstellungen der einzelnen Funktionen.

Ausführungsort konfigurieren

Bei Funktionen, deren Ausführungsort frei konfiguriert werden kann, stehen bei den Eigenschaften der Funktion entsprechende Parameter zur Verfügung. Um den Ausführungsort zu definieren:

  1. Navigieren Sie in den Eigenschaften der Funktion zur Gruppe Ausführung.

    Interne ID: Funktionen im Netzwerk

    Ausführung

    Nur verfügbar in Netzwerk-Projekten:
    Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Wählen Sie den gewünschten Ausführungsort durch Aktivierung der Checkbox aus. Mehrfachauswahl ist möglich:
    • Aktueller Rechner: Funktion wird auf dem aktuellen Rechner ausgeführt.

      Interne ID: Funktionen im Netzwerk

      Aktueller Rechner

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf dem Rechner ausgeführt, auf dem sie angestossen wurde.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Server: Funktion wird auf dem Server ausgeführt.

      Interne ID: Funktionen im Netzwerk

      Server

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf dem Server des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Standby: Funktion wird auf dem Server ausgeführt

      Interne ID: Funktionen im Netzwerk

      Standby

      Nur verfügbar in redundanten Netzwerk-Projekten:
      Die Funktion wird auf dem Standby-Server des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Client: Funktion wird auf allen Clients ausgeführt.

      Interne ID: Funktionen im Netzwerk

      Client

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf allen Clients des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Übersicht Funktionen im Netzwerk

Die folgende Tabelle zeigt, welche Funktionen wo ausgeführt werden.

Legende:

  • Einstellbar: Verhalten kann konfiguriert werden

    +: Ja

    -: Nein

    O: Default

  • Wenn nicht einstellbar, kennzeichnet O den Ausführungsort:
    • Aktiver Rechner
    • Server
    • Standby
    • Client

Funktion | Einstellbar | Aktueller Rechner | Server | Standby | Client
AML und CEL |  |  |  |  |
Alarme blinkquittieren | - | O |  |  |
Alarme löschen | - |  | O | O |
Alarme quittieren | - |  | O | O |
Alarm/Ereignis-Gruppe abmelden/anmelden | - | O |  |  |
Alarmmeldeliste/Alarm/Ereignis-Gruppen/Alarm/Ereignis-Klassen aktivieren/deaktivieren | - |  | O | O |
Alarmmeldeliste aktiv | - |  | O |  |
Alarmmeldeliste aktiv/inaktiv | - |  | O |  |
Alarmmeldeliste inaktiv | - |  | O |  |
AML exportieren | + | O |  |  |
AML- und CEL-Ringpuffer speichern | - |  | O | O |
CEL exportieren | + | O |  |  |
Drucken AML oder CEL | + | O |  |  |
IPA-Dokument erzeugen/drucken | - |  | O |  |
Online-Drucken ein/ausschalten | - |  | O | O |
Online-Drucken neue Seite beginnen | + | O |  |  |
Online-Drucker umschalten | - |  | O |  |
Anwendung |  |  |  |  |
Drucker wählen | + | O |  |  |
EMS starten | - |  | O |  |
EMS stoppen | - |  | O |  |
Erweiterter Trend Diagramm drucken | + | O |  |  |
Farbpalette umschalten | + | O |  |  |
Funktionen bei Grenzwerten aktiv | - |  | O | O |
Funktionen bei Grenzwerten aktiv/inaktiv | - |  | O | O |
Funktionen bei Grenzwerten inaktiv | - |  | O | O |
Hilfe aufrufen | + | O |  |  |
Nachladen | + | O |  |  |
Offene Wartungen ermitteln | - |  | O |  |
PFS - benutzerdefiniertes Ereignis anstoßen | + | O |  |  |
Projektsimulation aktivieren/deaktivieren | - | O |  |  |
Rechtsklick simulieren | + | O |  |  |
Remanentdaten speichern | + | O |  |  |
Runtime beenden | + | O |  |  |
S7-Graph Heuristik auswerten | + | O |  |  |
SAP-Funktion ausführen | + | O |  |  |
Sprachumschaltung | + | O |  |  |
Topologie - Erdschlusssuche | - |  | O |  |
Topologie - LoadShedding | - |  | O |  |
Archivserver |  |  |  |  |
Archiv beenden | - |  | O | O |
Archiv indizieren | - |  | O |  |
Archiv starten | - |  | O | O |
Archive exportieren | - | O |  |  |
Offene Archive anzeigen | - |  | O | O |
Benutzerverwaltung |  |  |  |  |
Benutzer ändern | + | O |  |  |
Login mit Dialog | + | O |  |  |
Login ohne Passwort | + | O |  |  |
Logout | + | O |  |  |
Passwort ändern | - | O |  |  |
Bilder |  |  |  |  |
ALC-Quellfarbe ändern | + | O |  |  |
Bild indiziert | - | O |  |  |
Bild schließen | + | O |  |  |
Bild zurück | - | O |  |  |
Bildmittelpunkt verschieben | + | O |  |  |
Bildumschaltung | + | O |  |  |
Eingabe auf Element mit Fokus aktivieren | +- | O |  |  |
Fokus auf Schablone setzen | + | O |  |  |
Fokus verschieben | - | O |  |  |
Fokus von Schablone nehmen | + | O |  |  |
Menü anzeigen | + | O |  |  |
Monitor zuordnen | + | O |  |  |
Runtimeprofile | + | O |  |  |
Schablone schließen | + | O |  |  |
Sollwertvorgabe für Keyboard-Bild | - | O |  |  |
Übersichtsfenster anzeigen | + | O |  |  |
Fehlerortung in elektrischen Netzen |  |  |  |  |
Erdschlussmeldung quittieren | + | O |  |  |
Erdschlusssuche beenden | + | O |  |  |
Erdschlusssuche starten | + | O |  |  |
Kurzschlussmeldung quittieren | + | O |  |  |
Message Control Hinweis: Ausführungsorte sind theoretisch frei einstellbar. Änderungen haben aber keine Auswirkung. Message Control wird immer am Server ausgeführt. |  |  |  |  |
Empfängerdatenbank anzeigen | + | O |  |  |
Sende Nachricht | + | O |  |  |
Sende Nachricht aktivieren | + | O |  |  |
Sende Nachricht deaktivieren | + | O |  |  |
Netzwerk |  |  |  |  |
Bedienberechtigung im Netz | + | O |  |  |
Redundanz Umschaltung | - |  |  | O |
Report Generator |  |  |  |  |
Drucken Report | + |  |  |  |
Report ausführen | + |  |  |  |
Report exportieren | + |  |  |  |
Rezepte |  |  |  |  |
Rezeptgruppen-Manager | - | O |  |  |
Standard-Rezept | - | O |  |  |
Standard-Rezept einzeln direkt | + | O | O | O | O
Standard-Rezept einzeln mit Auswahl | - | O |  |  |
Standard-Rezept einzeln mit Online-Auswahl | - | O |  |  |
Skript |  |  |  |  |
Skript ausführen | + | O |  |  |
Skript mit Online-Auswahl | + | O |  |  |
Variable |  |  |  |  |
Daten exportieren | - |  | O |  |
dBase Datei lesen | + | O |  |  |
Drucken Momentanwerte | + | O |  |  |
Einheitenumschaltung | + | O |  |  |
HD-Verwaltung aktiv | - |  | O | O |
HD-Verwaltung inaktiv | - |  | O | O |
HD-Verwaltung inaktiv/active | - |  | O | O |
Sollwert absetzen | - |  | O |  |
Treiberkommandos | - | O |  |  |
Treiber Simulationsabbild an Standby übertragen | - |  |  |  | O
Uhrzeit auf Variable schreiben | + | O |  |  |
Uhrzeit von Variable lesen | + | O |  |  |
VBA |  |  |  |  |
PCE-Editor öffnen | - |  | O |  |
VBA-Editor öffnen | + | O |  |  |
VBA-Makro ausführen | + | O |  |  |
VBA-Makro Dialog Anzeigen | + | O |  |  |
VSTA |  |  |  |  |
VSTA-Editor öffnen | + | O |  |  |
VSTA-Marko ausführen | + | O |  |  |
VSTA-Makro Dialog anzeigen | + | O |  |  |
Windows |  |  |  |  |
Audiodatei ausführen | + | O |  |  |
Dateioperation | + | O |  |  |
Dauerton Start | + | O |  |  |
Dauerton Stopp | + | O |  |  |
In den Hintergrund | - | O |  |  |
In den Vordergrund | - | O |  |  |
Screenshot drucken | + | O |  |  |
Starte Programm | + | O |  |  |


Bildumschaltung CEL

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Bildumschaltung CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Chronologische Ereignisliste zur Runtime aufzuschalten:

  1. legen Sie Bild vom Typ Chronologische Ereignisliste an
  2. erstellen Sie eine Funktion Bildumschaltung auf das Bild
  3. definieren Sie die gewünschten Filtereigenschaften

Zur Runtime können die Filtereigenschaften modifziert werden. Ausnahme: Im Editor wurden feste Zeitfilter definiert.

Bildumschaltung projektieren

Um eine Bildumschaltung auf ein Bild vom Typ CEL anzulegen:

  1. wählen Sie im Kontextmenü des Knotens Funktion den Befehl Funktion neu
  2. klicken Sie auf Bildumschaltung
  3. der Dialog zur Bildauswahl wird angezeigt
  4. wählen Sie das Bild vom Typ CEL
    oder legen Sie es in diesem Dialog mit Klick auf das Symbol Bild neu an
  5. der Filter wird mit allen Registerkarten angezeigt:
    • Allgemein
    • Zeit
    • Spalteneinstellungen
    • Text
    • Status
    • Projekt (Steht nur im Integrationsprojekt der Mehrprojektverwaltung zur Verfügung.)
    • Anlagenmodellierung

    Optional können, wenn verknüpfte Variablen oder Indizes vorhanden sind, noch folgende Registerkarten angezeigt werden:

    • Verknüpfungen ersetzen
    • Indizes ersetzen

  6. definieren Sie die Filter, die zur Runtime vordefiniert sein sollen
  7. bestätigen Sie die Einstellungen und schließen Sie den Dialog mit Klick auf OK
  8. verknüpfen Sie die Funktion mit einem Button, um zur Runtime auf das Bild umzuschalten und die Filtereigenschaften anzubieten

info Info

Wird auf ein Bild referenziert, das keine Zeitfilter hat, dann werden die Zeitfilter deaktiviert.


Bildumschaltung CEL-Filter

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Bildumschaltung CEL-Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Chronologische Ereignisliste Filter zur Runtime aufzuschalten:

  1. legen Sie ein Bild vom Typ Chronologische Ereignisliste Filter an
  2. erstellen Sie eine Funktion Bildumschaltung auf das Bild
  3. definieren Sie die gewünschten Filtereigenschaften

Die Filtereigenschaften lassen sich zur Runtime nur über die im Bild definierten Buttons steuern.

Bildumschaltung projektieren

Um eine Bildumschaltung auf ein Bild vom Typ Chronologische Ereignisliste Filter anzulegen:

  1. wählen Sie im Kontextmenü des Knotens Funktion den Befehl Funktion neu
  2. klicken Sie auf Bildumschaltung
  3. der Dialog zur Bildauswahl wird angezeigt
  4. wählen Sie das Bild vom Typ Chronologische Ereignisliste Filter
    oder legen Sie es in diesem Dialog mit Klick auf das Symbol Bild neu an
  5. der Filter wird mit allen Registerkarten angezeigt:
    • Bilder
    • Allgemein
    • Text
    • Zeit

  6. definieren Sie die Filter, die zur Runtime vordefiniert sein sollen
  7. bestätigen Sie die Einstellungen und schließen Sie den Dialog mit Klick auf OK
  8. verknüpfen Sie die Funktion mit einem Button, um zur Runtime auf das Bild umzuschalten und die Filtereigenschaften anzubieten


Funktionen für Chronologische Ereignisliste

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verschiedene Funktionen ermöglichen die Handhabung von Ereignissen zur Runtime.

Um eine Funktion für die Chronologische Ereignisliste zu erstellen:

  1. navigieren Sie zum Knoten Funktionen
  2. wählen Sie im Kontextmenü oder auf der Symbolleiste den Befehl Funktion neu
  3. der Dialog zur Auswahl von Funktionen wird geöffnet
  4. navigieren Sie zum Knoten AML/CEL

  5. wählen Sie die gewünschte Funktion
  6. konfigurieren Sie die Funktion, wenn nötig
  7. verknüpfen Sie die Funktion mit einem Button

Noch in diesem Kapitel

AML- und CEL-Ringpuffer speichern

CEL exportieren

Drucken AML oder CEL

Online-Drucken ein/ausschalten

Online-Drucken neue Seite beginnen

Online Drucker umschalten


AML- und CEL-Ringpuffer speichern

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste -> AML- und CEL-Ringpuffer speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion können zur Runtime der Inhalt der Ringpuffers für Alarme und Ereignisse sowie die Werte von Mathematik-Variablen (Zähler) gespeichert werden. Die Einträge werden in folgenden Dateien gespeichert:

Datei

Inhalt

Größe einstellbar über Eigenschaft

ALARM.BIN

Alarme

Größe des Ringpuffers

Interne ID: AML- und CEL-Ringpuffer speichern

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: AML- und CEL-Ringpuffer speichern

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

CEL.BIN

Einträge der Chronologischen Ereignisliste

Größe des Ringpuffers

Interne ID: AML- und CEL-Ringpuffer speichern

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Größe des CEL-Ringpuffers. Bei Überlauf des Ringpuffers (cel.bin) werden die Einträge in das CEL-Archiv (*.cel) übertragen.
Minimum: 1
Maximum: 32767
Default: 100

Interne ID: AML- und CEL-Ringpuffer speichern

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Zur Runtime werden eventuell mehr Einträge als projektiert angezeigt, da alte Einträge erst beim Aktualisieren der Liste aus der CEL entfernt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SY_MA32.BIN

Werte mathematischer Variablen (z.B. Zähler)

Um den AML-Ringpuffer zu speichern:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie AML- und CEL-Ringpuffer speichern
  3. verknüpfen Sie die Funktion mit einem Button


CEL exportieren

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste -> CEL exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion können zur Runtime die gespeicherten Ereignisse mit Filterbedingungen in eine Datei oder Datenbank exportiert werden.

Um CEL-Einträge zu exportieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie CEL exportieren
  3. der Dialog zur Auswahl der Filterkriterien öffnet sich
  4. definieren Sie die Kriterien für:
    • Exportformat
    • Allgemein
    • Zeit
    • Projekt
  5. verknüpfen Sie die Funktion mit einem Button

Noch in diesem Kapitel

Exportformat


Exportformat

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste -> CEL exportieren -> Exportformat

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Exporte sind unterschiedliche Formate möglich:

  • dBase
  • CSV
  • XML
  • SQL

info Info

Der Export nach SQL erfolgt inkrementell. Liegen bereits exportierte Daten vor, werden nur neue und geänderte Daten exportiert.

Parameter

Beschreibung

Exportformat

Auswahl des Dateityps. Mögliche Formate:

  • dBase: DBaseIV-Format (*.dbf):
  • CSV
  • XML
  • SQL

Hinweis zu dBase:

  • Dateinamen dürfen nicht länger als acht Zeichen sein.
  • Projektierte Spaltenbreite wird für Export verwendet. Ist z. B. unter Spalteneinstellungen ein Wert von 40 Zeichen eingestellt, werden auch nur maximal 40 Zeichen exportiert.
  • Es werden maximal 255 Zeichen exportiert.

Optionen

Als Unicode exportieren

Export in ASCII-Format erfolgt in Unicode.

Inkrementell exportieren

Es werden nur Unterschiede seit dem letzten Export exportiert.

Export in Datei

Festlegung der Datei, in der der Export gespeichert wird.

Dateiname

Dateiname individuell festlegen.

Maximal 32 alphanumerische Zeichen inklusive Dateiendung.

Hinweis: Bestehende Dateien gleichen Namens werden überschrieben.

Dateinamen automatisch generieren

Aktiv : Der Dateinamen wird aus einer Kurzkennung, einem Datumsschlüssel und einem individuellen Postfixautomatisch generiert.
Inaktiv : Der Dateiname wird vom Benutzer unter Dateiname eingegeben.

(Bestehende Dateien werden nicht überschrieben.)

Details siehe nächste Tabelle: Kodierung Name für automatische Namensvergabe

Postfix

Freie, individuelle Kennung. Steht nur für Dateinamen automatisch generieren zur Verfügung.

Mögliche Eingaben:

  • dBase: 1 alphanumerisches Zeichen
  • ASCII und XML: 32 alphanumerische Zeichen

Beispiel

Anzeige des vollständigen Dateinamens bei automatischer Generierung.

Eingestellter Exportordner

Anzeige des aktuell in den Projekteigenschaften eingestellten Exportpfades . (Eigenschaft Runtime-Ordner im Knoten Allgemein/Name/Ordner.)

Interne ID: Exportformat

Name/Ordner

Eigenschaften für den Namen und den Speicherplatz des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Exportformat

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Exportformat

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Export in SQL-Datenbank

Parameter für den Export in eine SQL-Datenbank

Datenbankverbindung

Konfiguration der Datenbankverbindung. Klick auf Schaltfläche ... öffnet Konfigurationsdialog.

Tabelle

Auswahl der Tabelle, in die geschrieben werden soll.

Registerkarte Allgemein

Allgemeiner Filter. Siehe Kapitel Alarmprojektierung über Filter, Abschnitt Allgemein.

Registerkarte Zeit

Zeitfilter. Siehe Kapitel Alarmprojektierung über Filter, Abschnitt Zeit.

Projekt

Projektfilter. Nur vorhanden im Integrationsprojekt der Mehrprojektverwaltung.

Konfiguration siehe Kapitel Alarmprojektierung über Filter, Abschnitt Projekt.

Kodierung Name für automatische Namensvergabe

Name

AJJMMTTP.XXX

A

Kurzkennung der Alarmmeldeliste

JJMMTT

Datumsangabe:

  • JJ: Jahr, zweistellig
  • MM: Monat, zweistellig
  • TT: Tag, zweistellig

P

Freie, individuelle Kennung:

  • dBase: 1 alphanumerisches Zeichen
  • ASCII und XML: 32 alphanumerische Zeichen

XXX

Dateiendung:

  • DBF: dBase
  • TXT: CSV
  • XML: XML

Formales

  • Format der Zeileneinträge: wird aus den Einstellungen der Eigenschaft Spalteneinstellung AML bzw.Spalteneinstellung CEL übernommen.

    Interne ID: Exportformat

    Spalteneinstellung CEL

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
    Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

    Interne ID: Exportformat

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Exportformat

    Spalteneinstellung AML

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
    Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

    Interne ID: Exportformat

    Alarmmeldeliste aktiv

    Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
    Inaktiv: Alarme werden nicht aufgezeichnet.
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Spaltentrennzeichen: Semikolon (Strichpunkt ;)

attention Achtung

Millisekunden für Druck und Export

Soll beim Drucken oder Exportieren von AML oder CEL die Zeit in Millisekunden angegeben werden, muss diese Eigenschaft im Dialog für die Spalteneinstellungen aktiviert werden. Dazu:

  • navigieren Sie in den Projekteigenschaften zum Knoten Alarmmeldeliste bzw. Chronologische Ereignisliste

    Interne ID: Exportformat

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Exportformat

    Alarmmeldeliste

    Eigenschaften für die Alarmkonfiguration.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • klicken Sie auf die Schaltfläche ... der Eigenschaft Spalteneinstellung AML bzw. Spalteneinstellung CEL
  • der Dialog für die Spalteneinstellung wird geöffnet
  • aktivieren Sie die Checkbox vor der Eigenschaft Millisekunden

Die Einstellung muss für AML und CEL jeweils extra vorgenommen werden.


Drucken AML oder CEL

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste -> Drucken AML oder CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion können zur Runtime die gespeicherten Ereignisse mit Filterbedingungen auf einem Drucker ausgegeben werden

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Drucken AML oder CEL
  3. der Dialog zur Auswahl der Liste öffnet sich

  4. wählen Sie Chronologische Ereignisliste
  5. der Dialog zur Auswahl der Filterkriterien öffnet sich
  6. definieren Sie die Kriterien für:
    • Allgemein
    • Zeit
    • Schrift: Auswahl aus den in zenon definierten Schriften
  7. verknüpfen Sie die Funktion mit einem Button

info Info

Zur Runtime kann nicht zwischen CEL und AML umgeschaltet werden. Um beide Listen drucken zu können, müssen zwei Funktionen projektiert werden.

Zeilenaufbau

Datum/Zeit gekommen | Datum/Zeit gegangen | Datum/Zeit quittiert | Langtext | Zustandstext

Die zur Verfügung stehenden Schlüsselworte für die Formatierungsdatei (BTB.FRM für Online-Druck und BTB_G.FRM für Offline-Druck) und Beispiel für deren Verwendung finden Sie im Kapitel FRM-Konfigurationsdatei im Abschnitt Bedienen zur Runtime.

Eine FRM-Datei gliedert sich in drei Teile:

  • Kopfteil: am Seitebeginn
  • Listenteil: zyklisch pro Zeile
  • Fußteil: am Seitenende

Grundsätze

Beachten Sie beim Bearbeiten von FRM-Dateien:

  • Trennung der Listenteile:
    • Kopfteil und Listenteil sowie Listenteil und Fußteil werden durch %% getrennt.

      Diese Gliederungsmarkierung darf nur je einmal für den Listenteil und den Fußteil verwendet werden.

    • Achtung: Nach der letzten Zeile müssen mindestens zwei leere Absätze folgen. Andernfalls wird die Fußzeile nicht gedruckt!
  • Positionierung der einzelnen Einträge:
    Es dürfen nur Leerzeichen verwendet werden, keine Tabulatoren.
  • Bearbeiten der FRM-Datei in einem Texteditor:
    Automatischer Zeilenumbruch muss deaktiviert werden, da sonst unerwünschte Effekte in der Formatierung auftreten können.

Schlüsselwörter

Die Einstellung der Seitenlänge wird in den Projekteigenschaften unter AML und CEL vorgenommen oder über die Dateien ALARM.frm oder ALAR_G.frm für AML bzw. BTB.frm und BTB_G.frm vür CEL.

Interne ID: Drucken AML oder CEL

AML und CEL

Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bitte beachten Sie:

  • Die Anzahl der Alarmeinträge pro Seite ergibt sich aus der vorgegebenen Anzahl an Zeilen (z.B. Zeilen pro Seite 72) abzüglich der für Kopf- und Fußtexte verwendeten Zeilen.

    Interne ID: Drucken AML oder CEL

    Zeilen pro Seite

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Anzahl der Zeilen, die beim Online-Ausdruck pro Seite gedruckt werden.
    Minimum: 0

    Interne ID: Drucken AML oder CEL

    Drucken aktiv

    Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
    Inaktiv: Kein Online-Ausdruck findet statt.
    Default: aktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Maximum: 65535
    Default: 72

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Für die Verwendung der Schlüsselworte, die die Reaktivierung auswerten (Zeit, Anzahl), muss in der Alarmverwaltung die Option Reaktiviertzeit verwenden aktiviert sein.

    Interne ID: Drucken AML oder CEL

    Reaktiviertzeit verwenden

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Aktiv: Wenn derselbe Alarm mehrmals hintereinander auftritt, wird nur eine Zeile in der Alarmmeldeliste erstellt. Zusätzliche Informationen (z.B. Alarmzähler) können in der Liste dargestellt werden.
    Inaktiv: Jeder Alarm erhält eine eigene Zeile in der Alarmmeldeliste.
    Default: inaktiv.

    Interne ID: Drucken AML oder CEL

    Alarmmeldeliste aktiv

    Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
    Inaktiv: Alarme werden nicht aufgezeichnet.
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • In der Formatierungsdatei sind Schlüsselworte und freie Texte verwendbar. Schlüsselworte können alternativ in Deutsch oder Englisch verwendet werden. Die Verwendung englischer Schlüsselwörter wird empfohlen.
  • Nicht jedes Schlüsselwort ist für jede Art von Druck (AML, CEL, online, offline) geeignet.

Die folgende Tabelle enthält Schlüsselwörter in Deutsch und Englisch und deren Einsatzmöglichkeiten:

Deutsch

Englisch

AML Offline

CEL Offline

AML Online

CEL Online

Beschreibung

Schlüsselwörter für den Listenteil

@DATZEITKOMMT

@DTRECEIVED

X

X

X

X

Datum und Zeitpunkt des Alarmauftretens

@DATZEITGEHT

@DTCLEARED

X

-

X

-

Datum und Zeitpunkt des Alarmendes

@DATZEITOK

@DTACK

X

-

X

-

Datum und Zeitpunkt der Alarmquittierung

@DATZEITREAKT

@DTREACTIVATE

X

-

X

-

Datum und Zeitpunkt der Reaktivierung:

Eigenschaft Reaktiviertzeit verwenden in Projekteigenschaften muss aktiviert sein.

@DATZEIT

@DTLASTEVENT

-

-

X

-

Datum und Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEIT

@TLASTEVENT

-

-

X

X

Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEITOK

@TACK

X

-

X

-

gibt nur Zeitpunkt der Quittierung an

@ZTKOMMT

@TRECEIVED

X

X

X

X

gibt nur Zeitpunkt des Alarmauftretens an

@ZTGEHT

@TCLEARED

X

-

X

-

gibt nur Zeitpunkt der Alarmendes an

@ZTREAKT

@TREACTIVATE

X

-

X

-

gibt nur Zeitpunkt der Reaktivierung an

@TIMELASTING

@TACTIVE

X

-

X

-

Zeit anstehend (Differenz Zeit Kommt - Zeit geht)

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@KANALNAME

@VARNAME

X

X

X

X

Variablenanme
CEL: Nur Einträge mit Variablen

@AK

@ACLASSNR

X

X

X

X

Alarm/Ereignis-Klassenname

@AG

@AGROUPNR

X

X

X

X

Alarm/Ereignis-Gruppennummer

@AGNAME

@AGROUPNAME

X

X

X

X

Name der Alarm/Ereignis-Gruppe

@AKNAME

ACLASSNAME

X

X

X

X

Name der Alarm/Ereignis-Klasse

@TAGNR

@IDENTIFICATION

X

X

X

X

Kennung (firmenspezifische Bezeichnung)

@AMELDUNG

@TEXT

X

X

X

X

Alarmmeldetext

@REAKTANZ

@NRREACTIVATE

X

-

X

-

Anzahl der Reaktivierungen

@STATUS

@STATUS

X

X

X

X

Statusinformation wie in der Alarmliste

@WERT

@VALUE

X

X

X

X

Variablenwert des Alarms

@REAKTIONSTEXT

@COMMENT

X

X

X

X

Kommentar aus der Alarmliste.

Bei Verwendung von dynamischen Grenzwerttexten nur veerfügbar, wenn Lange dynamische Grenzwerttexte AML bzw. Lange dynamische Grenzwerttexte CEL aktiviert ist.

Interne ID: Drucken AML oder CEL

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Drucken AML oder CEL

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

@USER

@USERID

X

X

X

X

AML: Anwender, der Alarm bestätigt hat.

@RECHNER

@COMPUTER

X

X

X

X

AML: Rechner, auf dem Alarm bestätigt wurde.

Schlüsselwörter für den Kopf- und Fußteil

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@SEITE

@PAGE

X

X

X

X

Seitenzahl

@HEADDATZEIT

@DTSYSTEM

X

X

X

X

Systemdatum und Systemuhrzeit

@HEADDATUM

@DSYSTEM

X

X

X

X

Systemdatum

@HEADZEIT

@TSYSTEM

X

X

X

X

Systemuhrzeit

@USER

@USERID

X

X

X

X

Benutzer, der druckt

@USERNAME

@USERNAME

X

X

X

X

Vollständiger Benutzername, der Aktivität auslöste

@RECHNER

@COMPUTER

X

X

X

X

Rechner, von deam aus gedruckt wird

[Text]

[Text]

beliebiger Text in der Ausgabezeile am Drucker

attention Achtung

Zwischen den Schlüsselwörtern muss ausreichend Platz vorgesehen werden, damit Einträge nicht überschrieben werden. Damit stellen Sie sicher, dass auch lange Grenzwert-Texte korrekt angezeigt werden.

Beispiel:

@TEXT (Leerzeichen bis hierher)

Einstellung Millisekunden

attention Achtung

Millisekunden für Druck und Export

Soll beim Drucken oder Exportieren von AML oder CEL die Zeit in Millisekunden angegeben werden, muss diese Eigenschaft im Dialog für die Spalteneinstellungen aktiviert werden. Dazu:

  • navigieren Sie in den Projekteigenschaften zum Knoten Alarmmeldeliste bzw. Chronologische Ereignisliste

    Interne ID: Drucken AML oder CEL

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Drucken AML oder CEL

    Alarmmeldeliste

    Eigenschaften für die Alarmkonfiguration.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • klicken Sie auf die Schaltfläche ... der Eigenschaft Spalteneinstellung AML bzw. Spalteneinstellung CEL

    Interne ID: Drucken AML oder CEL

    Spalteneinstellung CEL

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
    Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

    Interne ID: Drucken AML oder CEL

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Drucken AML oder CEL

    Spalteneinstellung AML

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
    Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Dialog für die Spalteneinstellung wird geöffnet
  • aktivieren Sie die Checkbox vor der Eigenschaft Millisekunden

Die Einstellung muss für AML und CEL jeweils extra vorgenommen werden.


Online-Drucken ein/ausschalten

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste -> Online-Drucken ein/ausschalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird der Onlinedruck auf einen Status gesetzt:

  • einschalten: schaltet den Online-Druck ein
  • ausschalten: schaltet den Online-Druck aus
  • aktiv/inaktiv: schaltet den Online-Druck um

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Online-Drucken ein/ausschalten
  3. der Dialog zur Auswahl der Liste öffnet sich

  4. wählen Sie die gewünschte Funktion
  5. verknüpfen Sie die Funktion mit einem Button


Online-Drucken neue Seite beginnen

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste -> Online-Drucken neue Seite beginnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion steuern Sie zur Runtime den Seitenvorschub beim Online-Drucken:

Die aktuelle Seite des Ausdruckes wird mit der projektierten Fußzeile versehen und ein Seitenvorschub auf den neuen Seitenanfang vorgenommen. Der Seitenzähler wird auf 1 zurückgesetzt und die Kopfzeile ausgedruckt.

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Online-Drucken neue Seite beginnen
  3. verknüpfen Sie die Funktion mit einem Button


Online Drucker umschalten

Handbuch -> Chronologische Ereignisliste (CEL) -> Funktionen -> Funktionen für Chronologische Ereignisliste -> Online Drucker umschalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion kann zur Laufzeit der Drucker für den Online-Ausdruck gewechselt werden.

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Online-Drucker umschalten
  3. der Dialog zur Auswahl des Druckers öffnet sich
  4. wählen Sie den gewünschten Drucker aus der Dropdownliste
  5. verknüpfen Sie die Funktion mit einem Button

Parameter | Beschreibung
Druckerwahl | Auswahl des gewünschten Druckers aus der Dropdownliste.
Diesen Dialog zur Runtime anbieten | Aktiv: Bei Ausführung der Funktion wird der Dialog aufgeschaltet und der Drucker kann zur Runtime definiert werden.


Bedienen zur Runtime

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime wird die Chronologische Ereignisliste über eine Bildumschaltungsfunktion aufgerufen.

Die zur Verfügung stehenden Kontrollelemente und das Aussehen werden im Editor projektiert.

Parameter

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Chronologische Ereignisliste

Anzeigefeld für die Liste mit ihren Ereignissen. Das Aussehen ist konfigurierbar. Spalten werden über den Filter Spalteneinstellungen bei der Bildumschaltung festgelegt oder über die Eigenschaft Spalteneinstellung CEL in den Projekteigenschaften in der Gruppe Chronologische Ereignisliste.

Interne ID: Bedienen zur Runtime

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bedienen zur Runtime

Spalteneinstellung CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

Interne ID: Bedienen zur Runtime

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Anzeige: Eingestellter Filter

Zeigt aktuell gewählten Filter an.

Filter...

Öffnet den Filterdialog.

Sortieren

Nach dem Aufschalten der CEL zur Runtime werden neue Einträge nicht chronologisch einsortiert, sondern am Ende der Liste hinzugefügt.

Klick auf den Button sortiert die Liste neu.

Zur Unterscheidung von sortierten und unsortierten Einträgen kann über die Eigenschaften sortierter Text und unsortierter Text jeweils eine unterschiedliche Farbe zugewiesen werden

Interne ID: Bedienen zur Runtime

unsortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv und nur für SICAM 230.
Textfarbe für unsortierte Einträge in der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bedienen zur Runtime

sortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Definiert Farbe des Textes für die Einträge in der Chronologischen Ereignisliste (CEL).
Hinweise:

1. Wird für die Eigenschaft Alarm/Ereignis-Klassen Farbe als Textfarbe gewählt, dann hat diese Farbe Vorrang vor der Auswahl in sortierter Text.

Interne ID: Bedienen zur Runtime

Alarm/Ereignis-Klassen Farbe

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
nicht verwenden: Die Farben der Alarm/Ereignis-Klassen werden in der CEL in der Runtime nicht verwendet.
als Textfarbe: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Textfarben für die entsprechenden Einträge verwendet. Diese überschreiben die Auswahl in der Eigenschaft sortierter Text.
als Zeilenhintergrund: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Hintergrundfarben für die entsprechenden Einträge verwendet.
Default: als Textfarbe

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

2. Für SICAM 230: Um in der Liste durchgehend die gleiche Farbe zu haben, muss für die Eigenschaft unsortierter Text die gleiche Farbe gewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Relativzeiten anzeigen

Aktiv: Relativzeiten werden angezeigt, ohne dass der selektierte Eintrag den Fokus verliert.

Stopp/Weiter

Steuert Aufnahme neuer Ereignisse in die Liste während der Anzeige:

Stopp: Es werden keine neuen Einträge an die Liste angefügt. Der Button ändert seine Beschriftung in Weiter.

Weiter: Es werden wieder neue Einträge an die Liste angefügt. Der Button ändert seine Beschriftung in Stopp. Um die neuen Einträge chronologisch einzuordnen muss der Button Sortieren betätigt werden.

Schließen

Beendet die Anzeige der Chronologischen Ereignisliste und schließt das Bild und die Schablone.

Damit nach dem Schließen das davor geöffnete Bild angezeigt wird, muss das Bild vom Typ CEL mit einer eigenen Schablone projektiert werden.

Drucken

Druckt Liste so, wie sie aktuell angezeigt wird, aus.

Drucken mit Dialog

Öffnet vor dem Drucken die Druckereinstellungen.

Beschriftung: Anzahl gesamt

Fügt zur Runtime Text "Gesamt" ein. Muss von Listenfeld Anzahl gesamt gefolgt werden.

Anzahl gesamt

Anzahl aller Ereignisse in der Liste

Info: Status CEL

Zeigt zur Runtime den Status der CEL an.

aktiv: Ereignisse werden je nach Einstellungen im Projekt protokolliert

inaktiv: Ereignisse werden nicht protokolliert

Der Status wird über die Eigenschaft CEL aktiv festgelegt. Eine Änderung wird erst nach einem Neustart der Runtime wirksam.

Beschriftung: Kommentarfeld

Fügt zur Runtime den Text "Kommentar" ein. Muss vom Listenfeld Kommentarfeld gefolgt werden.

Kommentarfeld

Listenfeld für die Eingabe eines freien Textes durch den Benutzer für das selektierte Ereignis.

Sobald das Feld den Fokus verliert, wird der Text übernommen. Um den Text in der CEL mit anzuzeigen, muss in der Spaltendefinition die Spalte Kommentar aktiviert werden.

Button Stopp/Weiter

Navigation

Steuert Elemente der Liste.
  • Zeile nach oben

Blättert eine Zeile nach oben.
  • Zeile nach unten

Blättert eine Zeile nach unten.
  • Spalte nach rechts

Blättert eine Spalte nach rechts.
  • Spalte nach links

Blättert eine Spalte nach links.
  • Seite nach oben

Blättert eine Seite nach oben.
  • Seite nach unten

Blättert eine Seite nach unten.
  • Seite nach rechts

Blättert eine Seite nach rechts.
  • Seite nach links

Blättert eine Seite nach links.

Filterprofile

Filtereinstellungen, die der Anwender in der Runtime speichern kann.

  • Profilauswahl

Profil aus Liste auswählen.

  • Speichern

Speichern einer Einstellung als Profil.

  • Löschen

Löscht ausgewähltes Profil.

info Info

Im Kontrollelement Filter anzeigen wird der aktuelle Filter angezeigt.

Bei einem:

  • Textfilter wird der Ausdruck [Txt] angezeigt
  • Relativzeitfilter wird ein Ausdruck nach folgendem Schema angezeigt:
    [T,Rel:%dd,%dh,%dm;%ds]
    Beispiel: [T,Rel:1d,0h,0m,0s] entspricht einem Tag.

Konfiguration der Anzeige

Welche Informationen in der CEL angezeigt werden, konfigurieren Sie über die Spalteneinstellung der CEL Projektierung . Die Spalteneinstellungen erreichen Sie über:

  • Projekteigenschaften -> Chronologische Ereignisliste -> Spalteneinstellung CEL (nur Registerkarte Spalteneinstellungen )

    oder

  • Funktion Bildumschaltung auf ein Bild vom Typ AML ( alle Registerkarten)

Noch in diesem Kapitel

CEL filtern

Ereignisse drucken und exportieren


CEL filtern

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> CEL filtern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ereignisse können zur Runtime gefiltert angezeigt werden über:

  • Filteranwendung zur Runtime
  • Bildumschaltung mit vordefiniertem Filter auf ein Bild vom Typ CEL

Bildumschaltung mit Filter beim Bildaufruf eines Bild vom Typ CEL

  • Bildumschaltung auf ein Bild vom Typ Chronologische Ereignisliste Filter

Filtern zur Runtime

Im Bild vom Typ CEL könne zur Runtime Filter angewandt werden. Um die in der CEL angezeigten Ereignisse zu filtern:

  1. muss der Button Filter projektiert worden sein
  2. klicken Sie auf den Button
  3. der Filterdialog der CEL wird geöffnet

Eingestellte Filter lassen sich in Profilen speichern.

Bildumschaltung auf ein Bild vom Typ Chronologische Ereignisliste

Ereignisse können vorgefiltert angezeigt werden. Dazu:

  1. projektieren Sie einen Filter für die Funktion Bildumschaltung auf ein Bild vom Typ CEL
  2. die CEL wird beim Aufruf gefiltert angezeigt
  3. wird für die Funktion die Option Diesen Dialog zur Runtime anbieten aktiviert, kann der Filter vor der Anzeige neu definiert werden
  4. weitere Filtereinstellungen zur Runtime sind über den Button Filter möglich

Bildumschaltung auf ein Bild vom Typ Alarmmeldeliste-Filter

Um dem Benutzer zur Runtime nur die Filter anzubieten, die er benötigt, verwenden Sie das Bild vom Typ Chronologische Ereignisliste Filter. Dazu:

  1. projektieren Sie eine Bildumschaltung auf ein Bild vom Typ CEL-Filter
  2. rufen Sie zur Runtime die CEL über diese Funktion auf
  3. der Benutzer hat eine auf seine Bedürfnisse zugeschnittene Alarmmeldliste

Noch in diesem Kapitel

Filterprofile

CEL-Filter benutzen


Filterprofile

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> CEL filtern -> Filterprofile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Filterprofile sind Filtereinstellungen, die der Anwender in der Runtime speichern und aufrufen kann.

Um Filterprofile verwenden zu können, müssen folgende Kontrollelemente projektiert werden:

Parameter | Beschreibung
Filterprofile | Profilverwaltung
Profilauswahl | Gespeichertes Profil auswählen (Dropdownliste)
Speichern | Einstellungen als Profil speichern (Schaltfläche)
Löschen | Profil löschen (Schaltfläche X)

Damit können Sie zur Runtime:

  • Filter speichern
  • gespeicherte Filter anwenden
  • Filterprofile löschen

Filterprofil speichern

Um ein Filterprofil zu erstellen:

  1. definieren Sie zur Runtime Filterbedingungen
  2. vergeben Sie in der Eigenschaft Filterprofile einen Namen
  3. klicken Sie auf Speichern

Filterprofil anwenden

Um ein Filterprofil anzuwenden:

  1. wählen Sie aus der Dropdownliste Eigenschaft Filterprofile einen Filter
  2. der Filter wird sofort angewandt

Filterprofil löschen

Um ein Filterprofil zu löschen:

  1. wählen Sie aus der Dropdownliste Eigenschaft Filterprofile einen Filter
  2. klicken Sie auf die Schaltfläche X
  3. das Profil wird gelöscht
  4. der gelöschte Filter wird weiter angewandt, bis ein neuer Filter definiert oder gewählt wurde


CEL-Filter benutzen

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> CEL filtern -> CEL-Filter benutzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ Chronologische Ereignisliste Filter ermöglicht es, zur Runtime individualisierte Filtereinstellungen für die Alarmmeldeliste vorzunehmen. Es können alle Filtereinstellungen, die auch im Filter für die Funktion Bildumschaltung auf ein Bild vom Typ CEL vorhanden sind, projektiert werden.

Damit:

  • werden nur die wirklich benötigten Filterelemente projektiert und dem Benutzer zur Verfügung gestellt
  • bekommt der Benutzer nur diese Filter angezeigt und gewinnt Übersicht
  • kann das Aussehen völlig frei definiert werden und so zum Beispiel auch eine leichte Bedienung über einen Touchscreen realisiert werden

Filterbilder

Filterbilder ermöglichen es, einen voreingestellten Filter von einem Bild auf ein anderes zu übertragen. Der Filter des Quellbildes wird über das Zielbild gelegt. Die Bilder können auch von unterschiedlichen Bildtypen sein.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.

Aufrufdefinition

Folgende Voraussetzungen müssen erfüllt sein, damit die eingestellten Filter zur Anwendung kommen:

  1. Als Zeitbereich beim Zeitfilter wird Filter beim Zeitfiltertyp einstellen gewählt.
  2. Das Bild (Bild vom Typ Alarmmeldeliste Filter, Chronologische Ereignisliste Filter oder Zeitfilter) wird mithilfe eines Buttons oder eines Combi-Elements aktiviert. Nur so wird der Bezug zwischen Filterbild und Quellbild gewährleistet.
  3. Das Quellbild und das Filterbild müssen auf unterschiedlichen Schablonen oder Monitoren projektiert sein. Nur wenn das Quellbild offen ist, kann der Filter für das Filterbild aktualisiert werden. Das ist nur möglich, wenn beide Bilder nicht dieselbe Schablone oder den selben Monitor verwenden.
  4. Das aufrufende Bild muss mit dem aufzurufenden Filterbild kompatibel sein (siehe Tabelle).
Quellbild | AML Filter | CEL Filter | Zeitfilter
Archiv-Nachbearbeitung | T | T | T
Erweiterter Trend | T | T | T
Zeitfilter | T | T | X
Alarmmeldeliste Filter | X | C | T
Chronologische Ereignisliste Filter | C | X | T
Alarmmeldeliste | X | C | T
Chronologische Ereignisliste | C | X | T

Legende:

  • C: Gemeinsame Einstellungen werden aktualisiert.
  • T: Zeiteinstellungen werden aktualisiert.
  • X: Alle Einstellungen werden aktualisiert.

info Info

Keine Filterung

Das Filterbild wird nicht gefiltert, sondern mit den projektierten Werten aufgeschaltet, wenn:

  • eine der Bedingungen 1 bis 3 nicht erfüllt wird oder
  • die Einstellung Aufrufendes Bild bei der Funktion Bildumschaltung nicht aktiviert ist oder
  • das Bild nicht über ein Bildelement aufgerufen wird

In diesem Fall werden zur Runtime die Buttons Übernehmen, Schließen und Aktualisieren ausgegraut dargestellt und haben keine Funktion.

Aktualisierung

Beim Aufruf eines Filterbilds (Alarmmeldeliste Filter, Chronologische Ereignisliste Filter, Zeitfilter), werden die in der Funktion Bildumschaltung projektierten Bilder auf zwei Arten aktualisiert:

  • Wird das Filterbild über ein Bildelement aufgerufen, werden die Zielbilder, die sich auf demselben Monitor wie das Quellbild befinden aktualisiert.
  • Wird das Filterbild auf einem anderen Weg aufgerufen oder ist die Einstellung Auf allen Monitoren aktualisieren aktiviert, werden alle projektierten Zielbilder aktualisiert.

Die Aktualisierung erfolgt, sobald Sie den Button Übernehmen anklicken oder das Filterbild mit dem Button Schließen schließen. Der Button Abbrechen verwirft die Änderungen und schließt das Filterbild.

Filtereinstellungen aktualisieren

Mithilfe des Buttons Aktualisieren, übernehmen Sie die aktuellen Filtereinstellungen des Quellbilds. Wenn das Filterbild nicht durch ein Bildelement aufgerufen wurde oder wenn die Einstellung Aufrufendes Bild nicht aktiviert wurde, wird auf allen Monitoren nach einem Bild gesucht, das zur Aktualisierung verwendet werden kann. Das erste Bild, das gefunden wird, wird dann zur Aktualisierung verwendet.


Ereignisse drucken und exportieren

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> Ereignisse drucken und exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einträge der CEL können dokumentiert und archiviert werden über:

  • CEL Online drucken: jedes Ereignis wird beim Anzeigen in der Liste auf einem Zeilendrucker ausgegeben
  • CEL Offline drucken: die CEL wird im aktuellen Zustand als abgeschlossene Liste ausgedruckt
  • Inhalte der CEL (gefiltert) exportieren

Der für Ausdrucke zu verwendende Drucker wird über das Menü Datei -> Allgemeine Konfiguration -> Standard definiert.

attention Achtung

Für den Ausdruck wird eine Konfigurationsdatei *.frm verwendet:

  • online: ALARM.frm
  • offline: ALAR_G.frm.

Diese FRM-Datei muss sich im Projektbaum im Abschnitt Dateien im Ordner Texte und Formate befinden.

Vorlagen für FRM_Dateien finden Sie im zenon Installationsordner im Unterordner FRM_QRF. Diese können über Datei hinzufügen in den Abschnitt Texte und Formate eingefügt und dort bearbeitet werden.

Schlüsselwörter für FRM-Dateien finden Sie im Kapitel FRM-Konfigurationsdatei.

Noch in diesem Kapitel

Online drucken

Offline drucken

FRM-Konfigurationsdatei

Ereignisse exportieren


Online drucken

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> Ereignisse drucken und exportieren -> Online drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Online-Druck wird jedes Ereignis mit Eintrag in die CEL sofort an den Drucker geschickt.

Achtung: Der Online-Druck erfolgt zeilenweise konform zum ESC/P (Epson Standard Code for Printers) und benötigt einen Epson-kompatiblen Drucker.

Um Einträge der CEL online auszudrucken:

  1. definieren Sie einen Drucker
  2. navigieren Sie in den Projekteigenschaften zum Knoten AML und CEL

    Interne ID: Online drucken

    AML und CEL

    Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren Sie die Eigenschaft Drucken aktiv

    Interne ID: Online drucken

    Drucken aktiv

    Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
    Inaktiv: Kein Online-Ausdruck findet statt.
    Default: aktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie bei der Eigenschaft Ausdruck für in der Dropdownliste Chronologische Ereignisliste aus

    Interne ID: Online drucken

    Ausdruck für

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Ermöglicht die Wahl, ob AMl oder CEL online gedruckt werden. Es kann immer nur eine der beiden Listen gedruckt werden.

    Alarmmeldeliste: Die Alarmmeldeliste (AML) wird online gedruckt.
    Chronologische Ereignisliste: Die Chronologische Ereignisliste (CEL) wird online gedruckt.
    Default: Alarmmeldeliste

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. legen Sie mit der Eigenschaft Zeilen pro Seite die Zeilenzahl fest (Default: 72)

    Interne ID: Online drucken

    Zeilen pro Seite

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Anzahl der Zeilen, die beim Online-Ausdruck pro Seite gedruckt werden.
    Minimum: 0

    Maximum: 65535
    Default: 72

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  6. konfigurieren Sie die BTB.frm
  7. fügen Sie die BTB.frm zum Knoten Dateien/Texte und Formate hinzu

Druck und Drucker zur Runtime steuern

Seitenwechsel

Seitenvorschub wird durchgeführt, wenn:

  • eine Seite vollständig beschrieben wurde
  • bei aktivem Online-Druck die Runtime beendet wird
  • die Funktion Online-Drucken neue Seite beginnen ausgeführt wird

Druck unterbrechen

Um den Online-Druck zu unterbrechen oder wieder aufzunehmen:

  • führen Sie die Funktion Online Ausdrucke ein/ausschalten aus.

Drucker wechseln und einrichten

Um zur Runtime den Drucker zu wechseln:

  • führen Sie die Funktion Online Drucker umschalten aus

Um zur Runtime den gewählten Drucker einzurichten:

  1. projektieren Sie für das Bild ein Kontrollelement Drucken mit Dialog
  2. klicken Sie zur Runtime auf den Button Drucken mit Dialog
  3. der Konfigurationsdialog wird geöffnet

Parameter

Beschreibung

Drucker

Einstellungen für den Drucker.

Name:

Auswahl des Druckers aus Dropdownliste. Liste enthält alle im Betriebssystem konfigurierten Drucker.

Eigenschaften...

Öffnet Dialog zur Konfiguration des gewählten Druckers.

Status:

Anzeige Druckerstatus. Nur Information.

Typ:

Anzeige Druckertyp. Nur Information

Standort:

Anzeige Standort des Druckers, falls konfiguriert. Nur Information.

Kommentar:

Anzeige Kommentar zum Drucker, falls konfiguriert. Nur Information.

Papier

Konfiguration des Ausdrucks.

Größe

Auswahl Papierformat aus Dropdownliste.

Quelle

Wahl der Papierzufuhr aus Dropdownliste.

Ausrichtung

Wahl der Papierausrichtung. Mögliche Parmeter:

  • Hochformat
  • Querformat

Netzwerk

Öffnet Dialog zur AUswahl eines Druckers im Netzwerk.

OK

Übernimmt Konfiguration und schließt Dialog. Zur Runtime wird damit der Druck gestartet.

Abbrechen

Verwirft Konfiguration und schließt Dialog. Zur Runtime wird damit auch der Ausdruck abgebrochen.

Formatierungsbeispiel

Projektierung in BTB.FRM:

Datum: @DSYSTEM | Alarmmeldeliste Demoprojekt | Zeit @TSYSTEM Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
%% |  |  |
@DTRECEIVED | @TCLEARED | @IDENTIFICATION | @TEXT
%% |  |  |
 | Seite | @PAGE |

Ausgabe auf dem Drucker:

Datum: 20.03.2011 | Alarmmeldeliste Demoprojekt | Zeit: 12:00 Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
20.03.2011 13:00:00 | 20.03.2011 13:03:59 | Meldung 1 | Limit überschritten
20.03.2011 13:00:00 | 13:05:35 | Demomeldung | Limit 750 erreicht
20.03.2011 13:03:59 |  | Meldung 2 | Grenzwert
20.03.2011 13:11:23 |  | Meldung 3 | aus
20.03.2011 13:03:59 | 13:12:45 | Demomeldung | aus
 | Seite | 1 |


Offline drucken

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> Ereignisse drucken und exportieren -> Offline drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Offline drucken bedeutet, dass die CEL so, wie sie im Moment zur Runtime angezeigt wird, ausgedruckt wird. Dieser Ausdruck ist eine Momentaufnahme inklusive aller gesetzter Filter und deren Einschränkungen. Der Druck erfolgt unabhängig davon, ob die Variablen die Option Drucken besitzen.

Drucken

Um die CEL offline zu drucken:

  1. definieren Sie einen Drucker
  2. konfigurieren Sie die BTB_G.frm
  3. fügen Sie die BTB_G.frm zum Knoten Dateien/Texte und Formate hinzu
  4. klicken Sie zur Runtime auf den Button Drucken oder Drucken mit Dialog.

Drucker einrichten und wechseln

Drucker wechseln und einrichten

Um zur Runtime den Drucker zu wechseln:

  • führen Sie die Funktion Online Drucker umschalten aus

Um zur Runtime den gewählten Drucker einzurichten:

  1. projektieren Sie für das Bild ein Kontrollelement Drucken mit Dialog
  2. klicken Sie zur Runtime auf den Button Drucken mit Dialog
  3. der Konfigurationsdialog wird geöffnet

Parameter

Beschreibung

Drucker

Einstellungen für den Drucker.

Name:

Auswahl des Druckers aus Dropdownliste. Liste enthält alle im Betriebssystem konfigurierten Drucker.

Eigenschaften...

Öffnet Dialog zur Konfiguration des gewählten Druckers.

Status:

Anzeige Druckerstatus. Nur Information.

Typ:

Anzeige Druckertyp. Nur Information

Standort:

Anzeige Standort des Druckers, falls konfiguriert. Nur Information.

Kommentar:

Anzeige Kommentar zum Drucker, falls konfiguriert. Nur Information.

Papier

Konfiguration des Ausdrucks.

Größe

Auswahl Papierformat aus Dropdownliste.

Quelle

Wahl der Papierzufuhr aus Dropdownliste.

Ausrichtung

Wahl der Papierausrichtung. Mögliche Parmeter:

  • Hochformat
  • Querformat

Netzwerk

Öffnet Dialog zur AUswahl eines Druckers im Netzwerk.

OK

Übernimmt Konfiguration und schließt Dialog. Zur Runtime wird damit der Druck gestartet.

Abbrechen

Verwirft Konfiguration und schließt Dialog. Zur Runtime wird damit auch der Ausdruck abgebrochen.

Formatierungsbeispiel

Projektierung in BTB_G.frm:

Datum: @DSYSTEM | Geschlossene AML Demoprojekt | Zeit @TSYSTEM Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
%% |  |  |
@DTRECEIVED | @TCLEARED | @IDENTIFICATION | @TEXT
%% |  |  |
 | Seite | @PAGE |

Ausgabe auf dem Drucker:

Datum: 20.03.2011 | Geschlossene AML Demoprojekt | Zeit: 12:00 Uhr | Text
Datum/Zeit kommt | Zeit geht | Meldetext | Zustandstext
20.03.2011 13:00:00 | 20.03.2011 13:03:59 | Meldung 1 | Limit überschritten
20.03.2011 13:00:00 | 13:05:35 | Demomeldung | Limit 750 erreicht
20.03.2011 13:03:59 |  | Meldung 2 | Grenzwert
20.03.2011 13:11:23 |  | Meldung 3 | aus
20.03.2011 13:03:59 | 13:12:45 | Demomeldung | aus
 | Seite | 1 |


FRM-Konfigurationsdatei

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> Ereignisse drucken und exportieren -> FRM-Konfigurationsdatei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

FRM-Dateien (Formatdateien) sind Konfigurationsdateien für den Ausdruck von Listen.

Eine FRM-Datei gliedert sich in drei Teile:

  • Kopfteil: am Seitebeginn
  • Listenteil: zyklisch pro Zeile
  • Fußteil: am Seitenende

Grundsätze

Beachten Sie beim Bearbeiten von FRM-Dateien:

  • Trennung der Listenteile:
    • Kopfteil und Listenteil sowie Listenteil und Fußteil werden durch %% getrennt.

      Diese Gliederungsmarkierung darf nur je einmal für den Listenteil und den Fußteil verwendet werden.

    • Achtung: Nach der letzten Zeile müssen mindestens zwei leere Absätze folgen. Andernfalls wird die Fußzeile nicht gedruckt!
  • Positionierung der einzelnen Einträge:
    Es dürfen nur Leerzeichen verwendet werden, keine Tabulatoren.
  • Bearbeiten der FRM-Datei in einem Texteditor:
    Automatischer Zeilenumbruch muss deaktiviert werden, da sonst unerwünschte Effekte in der Formatierung auftreten können.

Schlüsselwörter

Die Einstellung der Seitenlänge wird in den Projekteigenschaften unter AML und CEL vorgenommen oder über die Dateien ALARM.frm oder ALAR_G.frm für AML bzw. BTB.frm und BTB_G.frm vür CEL.

Interne ID: FRM-Konfigurationsdatei

AML und CEL

Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bitte beachten Sie:

  • Die Anzahl der Alarmeinträge pro Seite ergibt sich aus der vorgegebenen Anzahl an Zeilen (z.B. Zeilen pro Seite 72) abzüglich der für Kopf- und Fußtexte verwendeten Zeilen.

    Interne ID: FRM-Konfigurationsdatei

    Zeilen pro Seite

    Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
    Anzahl der Zeilen, die beim Online-Ausdruck pro Seite gedruckt werden.
    Minimum: 0

    Interne ID: FRM-Konfigurationsdatei

    Drucken aktiv

    Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
    Inaktiv: Kein Online-Ausdruck findet statt.
    Default: aktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Maximum: 65535
    Default: 72

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Für die Verwendung der Schlüsselworte, die die Reaktivierung auswerten (Zeit, Anzahl), muss in der Alarmverwaltung die Option Reaktiviertzeit verwenden aktiviert sein.

    Interne ID: FRM-Konfigurationsdatei

    Reaktiviertzeit verwenden

    Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
    Aktiv: Wenn derselbe Alarm mehrmals hintereinander auftritt, wird nur eine Zeile in der Alarmmeldeliste erstellt. Zusätzliche Informationen (z.B. Alarmzähler) können in der Liste dargestellt werden.
    Inaktiv: Jeder Alarm erhält eine eigene Zeile in der Alarmmeldeliste.
    Default: inaktiv.

    Interne ID: FRM-Konfigurationsdatei

    Alarmmeldeliste aktiv

    Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
    Inaktiv: Alarme werden nicht aufgezeichnet.
    Default: aktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • In der Formatierungsdatei sind Schlüsselworte und freie Texte verwendbar. Schlüsselworte können alternativ in Deutsch oder Englisch verwendet werden. Die Verwendung englischer Schlüsselwörter wird empfohlen.
  • Nicht jedes Schlüsselwort ist für jede Art von Druck (AML, CEL, online, offline) geeignet.

Die folgende Tabelle enthält Schlüsselwörter in Deutsch und Englisch und deren Einsatzmöglichkeiten:

Deutsch

Englisch

AML Offline

CEL Offline

AML Online

CEL Online

Beschreibung

Schlüsselwörter für den Listenteil

@DATZEITKOMMT

@DTRECEIVED

X

X

X

X

Datum und Zeitpunkt des Alarmauftretens

@DATZEITGEHT

@DTCLEARED

X

-

X

-

Datum und Zeitpunkt des Alarmendes

@DATZEITOK

@DTACK

X

-

X

-

Datum und Zeitpunkt der Alarmquittierung

@DATZEITREAKT

@DTREACTIVATE

X

-

X

-

Datum und Zeitpunkt der Reaktivierung:

Eigenschaft Reaktiviertzeit verwenden in Projekteigenschaften muss aktiviert sein.

@DATZEIT

@DTLASTEVENT

-

-

X

-

Datum und Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEIT

@TLASTEVENT

-

-

X

X

Uhrzeit von Alarm kommt bzw. geht bzw. quittiert bzw. reaktiviert

@ZEITOK

@TACK

X

-

X

-

gibt nur Zeitpunkt der Quittierung an

@ZTKOMMT

@TRECEIVED

X

X

X

X

gibt nur Zeitpunkt des Alarmauftretens an

@ZTGEHT

@TCLEARED

X

-

X

-

gibt nur Zeitpunkt der Alarmendes an

@ZTREAKT

@TREACTIVATE

X

-

X

-

gibt nur Zeitpunkt der Reaktivierung an

@TIMELASTING

@TACTIVE

X

-

X

-

Zeit anstehend (Differenz Zeit Kommt - Zeit geht)

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@KANALNAME

@VARNAME

X

X

X

X

Variablenanme
CEL: Nur Einträge mit Variablen

@AK

@ACLASSNR

X

X

X

X

Alarm/Ereignis-Klassenname

@AG

@AGROUPNR

X

X

X

X

Alarm/Ereignis-Gruppennummer

@AGNAME

@AGROUPNAME

X

X

X

X

Name der Alarm/Ereignis-Gruppe

@AKNAME

ACLASSNAME

X

X

X

X

Name der Alarm/Ereignis-Klasse

@TAGNR

@IDENTIFICATION

X

X

X

X

Kennung (firmenspezifische Bezeichnung)

@AMELDUNG

@TEXT

X

X

X

X

Alarmmeldetext

@REAKTANZ

@NRREACTIVATE

X

-

X

-

Anzahl der Reaktivierungen

@STATUS

@STATUS

X

X

X

X

Statusinformation wie in der Alarmliste

@WERT

@VALUE

X

X

X

X

Variablenwert des Alarms

@REAKTIONSTEXT

@COMMENT

X

X

X

X

Kommentar aus der Alarmliste.

Bei Verwendung von dynamischen Grenzwerttexten nur veerfügbar, wenn Lange dynamische Grenzwerttexte AML bzw. Lange dynamische Grenzwerttexte CEL aktiviert ist.

Interne ID: FRM-Konfigurationsdatei

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: FRM-Konfigurationsdatei

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

@USER

@USERID

X

X

X

X

AML: Anwender, der Alarm bestätigt hat.

@RECHNER

@COMPUTER

X

X

X

X

AML: Rechner, auf dem Alarm bestätigt wurde.

Schlüsselwörter für den Kopf- und Fußteil

@ANWENDUNG

@PROJECTNAME

X

X

X

X

Projektname

@SEITE

@PAGE

X

X

X

X

Seitenzahl

@HEADDATZEIT

@DTSYSTEM

X

X

X

X

Systemdatum und Systemuhrzeit

@HEADDATUM

@DSYSTEM

X

X

X

X

Systemdatum

@HEADZEIT

@TSYSTEM

X

X

X

X

Systemuhrzeit

@USER

@USERID

X

X

X

X

Benutzer, der druckt

@USERNAME

@USERNAME

X

X

X

X

Vollständiger Benutzername, der Aktivität auslöste

@RECHNER

@COMPUTER

X

X

X

X

Rechner, von deam aus gedruckt wird

[Text]

[Text]

beliebiger Text in der Ausgabezeile am Drucker

attention Achtung

Zwischen den Schlüsselwörtern muss ausreichend Platz vorgesehen werden, damit Einträge nicht überschrieben werden. Damit stellen Sie sicher, dass auch lange Grenzwert-Texte korrekt angezeigt werden.

Beispiel:

@TEXT (Leerzeichen bis hierher)


Ereignisse exportieren

Handbuch -> Chronologische Ereignisliste (CEL) -> Bedienen zur Runtime -> Ereignisse drucken und exportieren -> Ereignisse exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einträge der CEL können in unterschiedliche Formate exportiert werden:

  • dBase
  • CSV
  • XML
  • SQL

Export

Um Einträge der CEL zu exportieren

  1. legen Sie eine Funktion CEL exportieren an
  2. verknüpfen Sie die Funktion mit einem Button
  3. führen Sie die Funktion zur Runtime aus

info Info

Der Export nach SQL erfolgt inkrementell. Liegen bereits exportierte Daten vor, werden nur neue und geänderte Daten exportiert.


Controls

Handbuch -> Controls

In zenon können eigene Controls eingebunden werden. Dafür stehen zur Verfügung:

  • .NET User Controls (Implementierung in zenon siehe auch .NET Controls im Handbuch Bilder.)
  • ActiveX (Implementierung in zenon siehe auch ActiveX im Handbuch Bilder.)
  • WPF

info Info

Informationen zur Nutzung der zenon Programmierschnittstellen (PCE, VBA, VSTA) finden Sie im Handbuch Programmierschnittstellen.

Noch in diesem Kapitel

Allgemein

ActiveX

.NET User Controls

WPF-Element


Allgemein

Handbuch -> Controls -> Allgemein

Controls für zenon können über ActiveX, .NET und WPF realisiert werden. Über VBA/VSTA kann auf die zenon API zugegriffen werden.

Noch in diesem Kapitel

Auf zenon API zugreifen

Methoden


Auf zenon API zugreifen

Handbuch -> Controls -> Allgemein -> Auf zenon API zugreifen

Unter zenon kann ein ActiveX Control um spezielle Funktionen erweitert werden, um darin auf die zenon API zuzugreifen.

Auf die zenon API zugreifen

  • wählen Sie in den Projekt References mit Add References... die zenon-RT Objektbibliothek aus
  • fügen Sie die erweiterten Funktionen in den Klassencode des Controls ein

Erweiterte zenon ActiveX Funktionen

// Wird beim Initialisieren des Controls in der zenon Runtime aufgerufen.

public bool zenonInit(zenon.Element dispElement)…

// Wird beim Zerstören des Controls in der zenon Runtime aufgerufen.

public bool zenonExit()…

// Unterstützt das Control Variablenverknüpfungen.

public short CanUseVariables()…

// Com Control unterstützte Datentypen.

public short VariableTypes()…

// Maximale Anzahl der Variablen, die mit dem Control verknüpft werden können.

public short MaxVariables()…

Beispiel

Das COM Object einer zenon Variable wird in einem Member zwischengespeichert, um später im Paint Event des Controls darauf zugreifen zu können:

zenon.Variable m_cVal = null;

public bool zenonInit(zenon.Element dispElement)

{

if (dispElement.CountVariable > 0) {

try {

m_cVal = dispElement.ItemVariable(0);

if (m_cVal != null) {

object obRead = m_cVal.get_Value((object)-1);

UserText = obRead.ToString();

}

}catch { }

}

return true;

}

public bool zenonExit()

{

try {

if (m_cVal != null) {

System.Runtime.InteropServices.Marshal.FinalReleaseComObject(m_cVal);

m_cVal = null;

}

}

catch { }

return true;

}

public short CanUseVariables()

{

return 1; // die Variablen werden unterstützt

}

public short VariableTypes()

{

return short.MaxValue; // alle Daten Typen werden unterstützt

}

public short MaxVariables()

{

return 1; // maximal eine Variable soll mit dem Control Verknüpft werden

}

private void SamplesControl_Paint(object sender, PaintEventArgs e)

{

// zenon Variables has changed

try {

if (m_cVal != null) {

object obRead = m_cVal.get_Value((object)-1);

UserText = obRead.ToString();

}

} catch { }

}


Methoden

Handbuch -> Controls -> Allgemein -> Methoden

ActiveX- und .NET-Controls, die zenon Variablen verwenden, benötigen bestimmte Methoden.

Noch in diesem Kapitel

CanUseVariables

MaxVariables

VariableTypes

zenonExit

zenonExitEd

zenonInit

zenonInitEd


CanUseVariables

Handbuch -> Controls -> Allgemein -> Methoden -> CanUseVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: short CanUseVariables();

Diese Methode gibt 1 oder 0 zurück

Wert | Beschreibung
1: | Das Control kann zenon Variablen verwenden. Es können für das Dynamische Element (über den Button Variable) nur zenon Variablen mit den über die Methode VariableTypes angegebenen Typen in der von der Methode MaxVariables angegebenen Anzahl angegeben werden.
0: | Das Control kann zenon Variablen nicht verwenden oder besitzt diese Methode nicht. Es können Variablen mit allen Typen ohne Beschränkung der Anzahl angegeben werden. Diese können in der Runtime aber nur über VBA verwendet werden.


MaxVariables

Handbuch -> Controls -> Allgemein -> Methoden -> MaxVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: short MaxVariables();

Hier wird die Anzahl der Variablen festgelegt, die aus der Variablenliste ausgewählt werden können.

Wird 1 zurückgegeben, so wird in der Variablenliste die Mehrfachauswahl deaktiviert. Es erfolgt eine Warnung, wenn trotzdem mehrere Variablen ausgewählt werden.


VariableTypes

Handbuch -> Controls -> Allgemein -> Methoden -> VariableTypes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: short VariableTypes();

Der von dieser Methode zurückgegebene Wert wird als Maske für die verwendbaren Variablentypen in der Variablenliste verwendet. Der Wert ist eine UND-Verknüpfung aus folgenden Werten (definiert in zenon32/dy_type.h):

Wert 1 | Wert 2 | Entsprechung
WORT | 0x0001 | Stelle 0
BYTE | 0x0002 | Stelle 1
BIT | 0x0004 | Stelle 2
DWORT | 0x0008 | Stelle 3
FLOAT | 0x0010 | Stelle 4
DFLOAT | 0x0020 | Stelle 5
STRING | 0x0040 | Stelle 6
EIN_AUSGABE | 0x8000 | Stelle 15


zenonExit

Handbuch -> Controls -> Allgemein -> Methoden -> zenonExit

Prototyp: boolean zenonExit();

Diese Methode wird von der zenon Runtime beim Schließen des ActiveX Controls aufgerufen.

Hier sollten alle Dispatch Pointer auf Variablen freigegeben werden.


zenonExitEd

Handbuch -> Controls -> Allgemein -> Methoden -> zenonExitEd

Entspricht zenonExit und wird beim Schließen des ActiveX im Editor ausgeführt.

Damit kann auch im Editor auf Änderungen im ActiveX, z.B. Wertänderungen, reagiert werden.

Info: Steht aktuell nur für ActiveX zur Verfügung.


zenonInit

Handbuch -> Controls -> Allgemein -> Methoden -> zenonInit

Prototyp: boolean zenonInit(IDispatch*dispElement);

Mit Hilfe dieser Methode wird in der Runtime dem ActiveX Control ein Zeiger auf das Dispatch Interface des Dynamischen Elements übergeben. Über diesen Zeiger können dann die mit dem Dynamischen Element verknüpften zenon Variablen angesprochen werden.

Die Reihenfolge der übergebenen Variablen definieren Sie in der Konfiguration des ActiveX Elements mit den Schaltflächen Nach unten oder Nach oben.
Der Element-Eingabe Dialog öffnet sich nachdem Sie das ActivX Element doppelklicken oder in den Element Eigenschaften im Knoten Darstellung die Eigenschaft ActiveX Einstellungen wählen.

Interne ID: zenonInit

ActiveX Einstellungen

Auswahl des ActiveX-Elements und der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: zenonInit

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


zenonInitEd

Handbuch -> Controls -> Allgemein -> Methoden -> zenonInitEd

Entspricht zenonInit und wird beim Öffnen des ActiveX ( Doppelklick auf das ActiveX) im Editor ausgeführt.

Info: Steht aktuell nur für ActiveX zur Verfügung.


ActiveX

Handbuch -> Controls -> ActiveX

Mit ActiveX kann die Funktionalität der zenon Runtime und des Editors selbstständig erweitert werden.

In diesem Handbuch lesen Sie:

  • ActiveX Elemente entwickeln
  • Beispiel LatchedSwitch (C++)
  • Beispiel CD_SliderCtrl (C++)
  • Beispiel .NET Control als ActiveX (C#)

Informationen zum Dynamischen Element ActiveX finden Sie im Handbuch Bilder im Kapitel ActiveX .

Noch in diesem Kapitel

ActiveX Elemente entwickeln

Beispiel LatchedSwitch (C++)

Beispiel CD_SliderCtrl (C++)

Beispiel .NET Control als ActiveX (C#)


ActiveX Elemente entwickeln

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Dynamische Element ActiveX in zenon kann Variablen an das ActiveX Control weitergeben, ohne dass der Umweg über VBA verwendet werden muss, um das Control zu bedienen.

Das Control kann selbst definieren, wie viele zenon Variablen es verwenden kann und von welchem Typ sie sein dürfen. Die Properties des Controls können über das Dynamische Element festgelegt werden.

Dazu muss die Schnittstelle (Dispatch-Interface) des Controls eine Reihe bestimmter Methoden unterstützen.

Noch in diesem Kapitel

Methoden


Methoden

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jedes ActiveX-Control, das zenon Variablen verwenden kann, muss folgende Methoden enthalten:

  • CanUseVariables
  • MaxVariables
  • VariableTypes
  • zenonExit
  • zenonExitEd
  • zenonInit
  • zenonInitEd

Welche Dispatch ID die Methoden in der Schnittstelle haben, ist dabei gleichgültig. Beim Aufruf der Methoden wird in zenon die richtige ID aus dem Interface geholt.

Noch in diesem Kapitel

CanUseVariables

MaxVariables

VariableTypes

zenonExit

zenonExitEd

zenonInit

zenonInitEd


CanUseVariables

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden -> CanUseVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: short CanUseVariables();

Diese Methode gibt 1 oder 0 zurück

Wert | Beschreibung
1: | Das Control kann zenon Variablen verwenden. Es können für das Dynamische Element (über den Button Variable) nur zenon Variablen mit den über die Methode VariableTypes angegebenen Typen in der von der Methode MaxVariables angegebenen Anzahl angegeben werden.
0: | Das Control kann zenon Variablen nicht verwenden oder besitzt diese Methode nicht. Es können Variablen mit allen Typen ohne Beschränkung der Anzahl angegeben werden. Diese können in der Runtime aber nur über VBA verwendet werden.


MaxVariables

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden -> MaxVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: short MaxVariables();

Hier wird die Anzahl der Variablen festgelegt, die aus der Variablenliste ausgewählt werden können.

Wird 1 zurückgegeben, so wird in der Variablenliste die Mehrfachauswahl deaktiviert. Es erfolgt eine Warnung, wenn trotzdem mehrere Variablen ausgewählt werden.


VariableTypes

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden -> VariableTypes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: short VariableTypes();

Der von dieser Methode zurückgegebene Wert wird als Maske für die verwendbaren Variablentypen in der Variablenliste verwendet. Der Wert ist eine UND-Verknüpfung aus folgenden Werten (definiert in zenon32/dy_type.h):

Wert 1 | Wert 2 | Entsprechung
WORT | 0x0001 | Stelle 0
BYTE | 0x0002 | Stelle 1
BIT | 0x0004 | Stelle 2
DWORT | 0x0008 | Stelle 3
FLOAT | 0x0010 | Stelle 4
DFLOAT | 0x0020 | Stelle 5
STRING | 0x0040 | Stelle 6
EIN_AUSGABE | 0x8000 | Stelle 15


zenonExit

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden -> zenonExit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: boolean zenonExit();

Diese Methode wird von der zenon Runtime beim Schließen des ActiveX Controls aufgerufen.

Hier sollten alle Dispatch Pointer auf Variablen freigegeben werden.


zenonExitEd

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden -> zenonExitEd

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Entspricht zenonExit und wird beim Schließen des ActiveX im Editor ausgeführt.

Damit kann auch im Editor auf Änderungen im ActiveX, z.B. Wertänderungen, reagiert werden.

Info: Steht aktuell nur für ActiveX zur Verfügung.


zenonInit

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden -> zenonInit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prototyp: boolean zenonInit(IDispatch*dispElement);

Mit Hilfe dieser Methode wird in der Runtime dem ActiveX Control ein Zeiger auf das Dispatch Interface des Dynamischen Elements übergeben. Über diesen Zeiger können dann die mit dem Dynamischen Element verknüpften zenon Variablen angesprochen werden.

Die Reihenfolge der übergebenen Variablen definieren Sie in der Konfiguration des ActiveX Elements mit den Schaltflächen Nach unten oder Nach oben.
Der Element-Eingabe Dialog öffnet sich nachdem Sie das ActivX Element doppelklicken oder in den Element Eigenschaften im Knoten Darstellung die Eigenschaft ActiveX Einstellungen wählen.

Interne ID: zenonInit

ActiveX Einstellungen

Auswahl des ActiveX-Elements und der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: zenonInit

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


zenonInitEd

Handbuch -> Controls -> ActiveX -> ActiveX Elemente entwickeln -> Methoden -> zenonInitEd

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Entspricht zenonInit und wird beim Öffnen des ActiveX ( Doppelklick auf das ActiveX) im Editor ausgeführt.

Info: Steht aktuell nur für ActiveX zur Verfügung.


Beispiel LatchedSwitch (C++)

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Folgenden wird als Beispiel ein ActiveX Control beschrieben, das über zwei Bit-Variablen einen verriegelbaren Schalter realisiert. Die erste Variable repräsentiert den Schalter, die zweite Variable den Riegel. Die Schaltervariable kann über das ActiveX Control nur dann geändert werden, wenn die Riegelvariable den Wert 0 hat.

Der Zustand des Elements wird über vier Bitmaps angezeigt, die im zenon Editor über den Properties-Dialog des Controls ausgewählt werden können.

Noch in diesem Kapitel

Schnittstelle

Control

Methoden

Bedienung und Darstellung

zenon Interface


Schnittstelle

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Schnittstelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Control LatchedSwitch besitzt folgendes Dispatch Interface:

[ uuid(EB207159-D7C9-11D3-B019-080009FBEAA2),
helpstring(Dispatch interface for LatchedSwitch Control), hidden ]
dispinterface _DLatchedSwitch

{
properties:
// NOTE - ClassWizard will maintain property information here.
// Use extreme caution when editing this section.
//{{AFX_ODL_PROP(CLatchedSwitchCtrl)
[id(1)] boolean SollwertDirekt;
[id(2)] IPictureDisp* SwitchOn; // Aufnehmer für die Bitmaps
[id(3)] IPictureDisp* SwitchOff;
[id(4)] IPictureDisp* LatchedOn;
[id(5)] IPictureDisp* LatchedOff;
//}}AFX_ODL_PROP

methods:
// NOTE - ClassWizard will maintain method information here.
// Use extreme caution when editing this section.
//{{AFX_ODL_METHOD(CLatchedSwitchCtrl)
//}}AFX_ODL_METHOD
[id(6)] short CanUseVariables();
[id(7)] short VariableTypes();
[id(8)] short MaxVariables();
[id(9)] boolean zenonInit(IDispatch* dispElement);
[id(10)] boolean zenonExit();
[id(DISPID_ABOUTBOX)] void AboutBox();

};

Die Properties SwitchOn bis LatchedOff nehmen die Bitmaps zur Anzeige der vier Zustände des Controls auf. Die Bitmaps selbst werden in Objekten der Klasse CPictureHolder abgelegt. Über die Property SollwertDirekt wird festgelegt, ob die Eingabe von Sollwerten über einen Dialog oder direkt durch Klicken auf das Control möglich sein soll.


Control

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Implementation des Controls erfolgt über die Klasse CLatchedSwitchCtrl. Diese Klasse besitzt als Members die CPictureHolder-Objekte zur Aufnahme der Bitmaps. Ausserdem werden drei DispatchDriver für das Dynamische Element und die Variablen mitgeführt:

class CLatchedSwitchCtrl : public COleControl

{

DECLARE_DYNCREATE(CLatchedSwitchCtrl)

// Constructor

public:

CLatchedSwitchCtrl();

// Overrides

// ClassWizard generated virtual function overrides

//{{AFX_VIRTUAL(CLatchedSwitchCtrl)

public:

virtual void OnDraw(CDC* pdc, const CRect& rcBounds, const CRect& rcInvalid);

virtual void DoPropExchange(CPropExchange* pPX);

virtual void OnResetState();

virtual DWORD GetControlFlags();

//}}AFX_VIRTUAL

// Implementation

protected:

~CLatchedSwitchCtrl();

DECLARE_OLECREATE_EX(CLatchedSwitchCtrl) // Class factory and guid

DECLARE_OLETYPELIB(CLatchedSwitchCtrl) // GetTypeInfo

DECLARE_PROPPAGEIDS(CLatchedSwitchCtrl) // Property page IDs

DECLARE_OLECTLTYPE(CLatchedSwitchCtrl) // Type name and misc status

// Message maps

//{{AFX_MSG(CLatchedSwitchCtrl)

afx_msg void OnLButtonDown(UINT nFlags, CPoint point);

//}}AFX_MSG

DECLARE_MESSAGE_MAP()

// Dispatch maps

//{{AFX_DISPATCH(CLatchedSwitchCtrl)

BOOL m_sollwertDirekt;

afx_msg void OnSollwertDirektChanged();

afx_msg LPPICTUREDISP GetSwitchOn();

afx_msg void SetSwitchOn(LPPICTUREDISP newValue);

afx_msg LPPICTUREDISP GetSwitchOff();

afx_msg void SetSwitchOff(LPPICTUREDISP newValue);

afx_msg LPPICTUREDISP GetLatchedOn();

afx_msg void SetLatchedOn(LPPICTUREDISP newValue);

afx_msg LPPICTUREDISP GetLatchedOff();

afx_msg void SetLatchedOff(LPPICTUREDISP newValue);

afx_msg short CanUseVariables();

afx_msg short VariableTypes();

afx_msg short MaxVariables();

afx_msg BOOL zenonInit(LPDISPATCH dispElement);

afx_msg BOOL zenonExit();

//}}AFX_DISPATCH

CPictureHolder m_SwitchOn;

CPictureHolder m_SwitchOff;

CPictureHolder m_LatchedOn;

CPictureHolder m_LatchedOff;

DECLARE_DISPATCH_MAP()

afx_msg void AboutBox();

// Event maps

//{{AFX_EVENT(CLatchedSwitchCtrl)

//}}AFX_EVENT

DECLARE_EVENT_MAP()

double VariantToDouble(const VARIANT FAR *v);

void VariantToCString(CString *c,const VARIANT FAR *v);

BOOL IsVariantString(const VARIANT FAR *v);

BOOL IsVariantValue(const VARIANT FAR *v);

// Dispatch and event IDs

public:

CString szVariable[2];

IElement m_dElement;

IVariable m_dLatchVar, m_dSwitchVar;

enum {

//{{AFX_DISP_ID(CLatchedSwitchCtrl)

dispidSollwertDirekt = 1L,

dispidSwitchOn = 2L,

dispidSwitchOff = 3L,

dispidLatchedOn = 4L,

dispidLatchedOff = 5L,

dispidCanUseVariables = 6L,

dispidVariableTypes = 7L,

dispidMaxVariables = 8L,

dispidZenOnInit = 9L,

dispidZenOnExit = 10L,

//}}AFX_DISP_ID

};

};


Methoden

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Methoden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Methoden werden verwendet:

  • CanUseVariables
  • VariableTypes
  • MaxVariables
  • zenonInit
  • zenonExit

Noch in diesem Kapitel

CanUseVariables

VariableTypes

MaxVariables

zenonInit

zenonExit


CanUseVariables

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Methoden -> CanUseVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode gibt 1 zurück, es können also zenon Variablen verwendet werden.

short CLatchedSwitchCtrl::CanUseVariables()

{

return 1;

}


VariableTypes

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Methoden -> VariableTypes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Control kann nur mit Bit-Variablen arbeiten, daher wird 0x0004 zurückgegeben.

short CLatchedSwitchCtrl::VariableTypes()

{

return 0x0004; // Nur Bit-Variablen

}


MaxVariables

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Methoden -> MaxVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es können zwei Variablen verwendet werden, daher wird 2 zurückgegeben.

short CLatchedSwitchCtrl::MaxVariables()

{

return 2; // 2 Variablen

}


zenonInit

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Methoden -> zenonInit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Methode werden über den Dispatchpointer des Dynamischen Elements die Dispatchdriver der Variablen geholt. Über diese Pointer werden beim Klicken und beim Zeichnen des Controls die Variablenwerte geholt und gesetzt.

BOOL CLatchedSwitchCtrl::zenonInit(LPDISPATCH dispElement)

{

m_dElement = IElement(dispElement);

if (m_dElement.GetCountVariable() >= 2)

{

short iIndex = 0;

m_dSwitchVar = IVariable(m_dElement.ItemVariable(COleVariant(iIndex)));

m_dLatchVar = IVariable(m_dElement.ItemVariable(COleVariant(++iIndex)));

}

return TRUE;

}


zenonExit

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Methoden -> zenonExit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode gibt die Dispatchdriver wieder frei.

BOOL CLatchedSwitchCtrl::zenonExit()

{

m_dElement.ReleaseDispatch();

m_dSwitchVar.ReleaseDispatch();

m_dLatchVar.ReleaseDispatch();

return TRUE;

}


Bedienung und Darstellung

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Bedienung und Darstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Sollwert setzen

Zeichnen


Sollwert setzen

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Bedienung und Darstellung -> Sollwert setzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Sollwert wird über einen Klick mit der linken Maustaste auf das Control gesetzt.

Ist m_iSollwertDirekt 0, wird ein Dialog zur Auswahl des Sollwerts angezeigt, sonst wird der aktuelle Wert der Schaltervariable invertiert.

Hat die Riegelvariable den Wert 1, wird nur ein MessageBeep ausgeführt und es kann kein Sollwert über das Control gesetzt werden.

void CLatchedSwitchCtrl::OnLButtonDown(UINT nFlags, CPoint point)

{

CRect rcBounds;

GetWindowRect(&rcBounds);

COleVariant coleValue((BYTE)TRUE);

BOOL bLatch = (BOOL)VariantToDouble((LPVARIANT)&m_dLatchVar.GetValue());

BOOL bSwitch = (BOOL)VariantToDouble((LPVARIANT)&m_dSwitchVar.GetValue());

if (bLatch) // Verriegelt!!!

MessageBeep(MB_ICONEXCLAMATION);

else

{

if (m_sollwertDirekt)

{

bSwitch = !bSwitch;

}

else

{

CSollwertDlg dlg;

dlg.m_iSollwert = bSwitch ? 1 : 0;

if (dlg.DoModal() == IDOK)

{

if (dlg.m_iSollwert == 2) // Toggle

bSwitch = !bSwitch;

else

bSwitch = (BOOL)dlg.m_iSollwert;

}

}

coleValue = (double)bSwitch;

m_dSwitchVar.SetValue(coleValue);

}

COleControl::OnLButtonDown(nFlags, point);

}


Zeichnen

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> Bedienung und Darstellung -> Zeichnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Zeichnen des Controls werden über die Dispatchdriver der Variablen deren Werte geholt und entsprechend eine der vier vorgegebenen Grafiken gezeichnet. Wenn sich der Wert einer Variable ändert, wird das Control über die OnDraw-Routine aktualisiert.

void CLatchedSwitchCtrl::OnDraw(CDC* pdc, const CRect& rcBounds, const CRect& rcInvalid)

{

CRect rcBitmap = rcBounds;

rcBitmap.NormalizeRect();

if (!m_dElement)

{

m_SwitchOn.Render(pdc, &rcBounds, &rcBounds);

return;

}

BOOL bVal1 = 0, bVal2 = 0;

VARIANT vRes;

if (m_dSwitchVar) // Variable vorhanden?

{

vRes = m_dSwitchVar.GetValue();

bVal1 = (BOOL)VariantToDouble(&vRes);

}

if (m_dLatchVar) // Variable vorhanden?

{

vRes = m_dLatchVar.GetValue();

bVal2 = (BOOL)VariantToDouble(&vRes);

}

if (bVal1 && bVal2)

m_SwitchOn.Render(pdc, rcBitmap, rcBitmap);

else if (!bVal1 && bVal2)

m_SwitchOff.Render(pdc, rcBitmap, rcBitmap);

else if (bVal1 && !bVal2)

m_LatchedOn.Render(pdc, rcBitmap, rcBitmap);

else

m_LatchedOff.Render(pdc, rcBitmap, rcBitmap);

}


zenon Interface

Handbuch -> Controls -> ActiveX -> Beispiel LatchedSwitch (C++) -> zenon Interface

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit das Dispatch Interface von zenon zum Sollwertsetzen verwendet werden kann, müssen für die Variablen und das Element Klassen angelegt werden, die von COleDispatchDriver abgeleitet sind. Diese Klassen werden am einfachsten über den Class Wizard der Entwicklungsumgebung angelegt (Button Add Class, Auswahl von From a type library, zenrt32.tlb auswählen).

Bei unserem Control sind das die Klassen IElement und IVariable. Sie sind in zenrt32.h und zenrt32.cpp definiert.


Beispiel CD_SliderCtrl (C++)

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da folgende Beispiel beschreibt ein ActiveX Control, das dem Windows SliderCtrl gleicht. Diese Komponente kann mit einer zenon Variable verknüpft werden. Der Anwender kann über den Schieberegler den Sollwert einer Variable ändern. Ändert sich die Variable über ein anderes Dynamisches Element, wird der Slider aktualisiert.

Noch in diesem Kapitel

Schnittstelle

Control

Methoden

Bedienung und Darstellung

zenon Interface


Schnittstelle

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Schnittstelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Control CD_SliderCtrl besitzt folgendes Dispatch Interface:

[ uuid(5CD1B01D-015E-11D4-A1DF-080009FD837F),

helpstring(Dispatch interface for CD_SliderCtrl Control), hidden

]

dispinterface _DCD_SliderCtrl

{

properties: //*** Eigenschaften des Controls

[id(1)] short TickRaster;

[id(2)] boolean ShowVertical;

[id(3)] short LineSize;

methods: //*** Methoden des Controls (für zenon-ActiveX)

[id(4)] boolean zenonInit(IDispatch* pElementInterface);

[id(5)] boolean zenonExit();

[id(6)] short VariableTypes();

[id(7)] short CanUseVariables();

[id(8)] short MaxVariables();

[id(DISPID_ABOUTBOX)] void AboutBox();

};


Control

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Implementierung des Controls erfolgt über die Klasse CD_SliderCtrlCtrl. Diese Klasse besitzt als Member ein Windows-übliches CSliderCtrl, mit dem das Control als Subclass ediniert wird. Die Schnittstellen IVariable und IElemen t enthalten zenon Schnittstellen, die integriert werden mußten. Diese sind abgeleitet von COleDispatchDriver.

class CCD_SliderCtrlCtrl : public COleControl

{

DECLARE_DYNCREATE(CCD_SliderCtrlCtrl)

private: //*** Member-Variablen

BOOL m_bInitialized;

BOOL m_bShowVertical;

BOOL m_bTicksBoth;

long m_nRangeStart;

long m_nRangeEnd;

long m_nTickOrientation;

IVariable m_interfaceVariable;

IElement m_interfaceElement;

CSliderCtrl m_wndSliderCtrl;

public:

CCD_SliderCtrlCtrl();

//{{AFX_VIRTUAL(CCD_SliderCtrlCtrl)

public:

virtual void OnDraw (CDC* pdc, const CRect& rcBounds, const CRect& rcInvalid);

virtual BOOL PreCreateWindow(CREATESTRUCT& cs);

virtual void DoPropExchange (CPropExchange* pPX);

virtual void OnResetState ();

//}}AFX_VIRTUAL

protected:

~CCD_SliderCtrlCtrl();

//*** Methoden zur Konvertierung von Variant

double VariantToDouble(const VARIANT FAR *vValue);

DECLARE_OLECREATE_EX(CCD_SliderCtrlCtrl) // Class factory and guid

DECLARE_OLETYPELIB (CCD_SliderCtrlCtrl) // GetTypeInfo

DECLARE_PROPPAGEIDS (CCD_SliderCtrlCtrl) // Property page IDs

DECLARE_OLECTLTYPE (CCD_SliderCtrlCtrl) // Type name and misc status

//*** Methoden für die Funktionalität des SliderCtrls

BOOL IsSubclassedControl ();

LRESULT OnOcmCommand (WPARAM wParam, LPARAM lParam);

//{{AFX_MSG(CCD_SliderCtrlCtrl)

afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);

afx_msg void HScroll(UINT nSBCode, UINT nPos);

afx_msg void VScroll(UINT nSBCode, UINT nPos);

afx_msg void OnLButtonDown(UINT nFlags, CPoint point);

afx_msg void OnLButtonUp(UINT nFlags, CPoint point);

//}}AFX_MSG

DECLARE_MESSAGE_MAP()

//{{AFX_DISPATCH(CCD_SliderCtrlCtrl)

afx_msg BOOL GetTickOnBothSides();

afx_msg void SetTickOnBothSides (short nNewValue);

afx_msg BOOL GetShowVertical();

afx_msg void SetShowVertical(BOOL bNewValue);

afx_msg short GetTickOrientation();

afx_msg void SetTickOrientation (short nNewValue);

afx_msg BOOL zenonInit(LPDISPATCH pElementInterface);

afx_msg BOOL zenonExit();

afx_msg short VariableTypes();

afx_msg short CanUseVariables();

afx_msg short MaxVariables();

//}}AFX_DISPATCH

DECLARE_DISPATCH_MAP()

afx_msg void AboutBox();

//{{AFX_EVENT(CCD_SliderCtrlCtrl)

//}}AFX_EVENT

DECLARE_EVENT_MAP()

public:

enum {

//{{AFX_DISP_ID(CCD_SliderCtrlCtrl)

dispidShowVertical = 1L,

dispidTicksOnBothSides = 2L,

dispidTickOrientation = 3L,

dispidZenOnInit = 4L,

dispidZenOnExit = 5L,

dispidVariableTypes = 6L,

dispidCanUseVariables = 7L,

dispidMaxVariables = 8L,

//}}AFX_DISP_ID

};

};


Methoden

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Methoden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Methoden werden verwendet:

  • CanUseVariables
  • VariableTypes
  • MaxVariables
  • zenonInit
  • zenonExit

Noch in diesem Kapitel

CanUseVariables

VariableTypes

MaxVariables

zenonInit

zenonExit


CanUseVariables

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Methoden -> CanUseVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode gibt 1 zurück, es können also zenon Variablen verwendet werden.

short CCD_SliderCtrlCtrl::CanUseVariables()

{

return 1;

}


VariableTypes

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Methoden -> VariableTypes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Control kann mit Wort, Byte, Doppelwort und Float-Variablen arbeiten. Eine Auflistung der möglichen Datentypen finden Sie in der allgemeinen Beschreibung über diese Methode.

short CCD_SliderCtrlCtrl::VariableTypes()

{

return 0x0001 | // Wort

0x0002 | // Byte

0x0008 | // D-Wort

0x0010 | // Float

0x0020; // D-Float

}


MaxVariables

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Methoden -> MaxVariables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit diesem Control kann nur eine Variable verknüpft werden.

short CCD_SliderCtrlCtrl::MaxVariables()

{

return 1; // 1 Variablen

}


zenonInit

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Methoden -> zenonInit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Parameter dispElement enthält das Inteface für das Dynamische Element. Über dieses Element wird die verknüpfte zenon Variable ermittelt. Ist diese gültig, wird der Bereich des SliderCtrls gesetzt. Weiters werden die Einstellungen für die Darstellung (Anzahl der Ticks, ...) gesetzt. Wenn keine Variable verknüpft ist, wird ein Laufbereich von 0 bis 0 festgelegt. Somit kann das SliderCtrl nicht verändert werden. Über die Variable m_bInitialized wird festgelegt, dass Sollwerte ab jetzt abgesetzt werden können.

BOOL CCD_SliderCtrlCtrl::zenonInit(LPDISPATCH dispElement)

{

//*** Ermittle die Variable über das zenon Element

m_interfaceElement = IElement(pElementInterface);

if (m_interfaceElement.GetCountVariable() > 0) {

short nIndex = 0;

m_interfaceVariable = IVariable

(m_interfaceElement.ItemVariable(COleVariant(nIndex)));

}

//*** Initialisiere den Bereich des Slider-Ctrls

if (m_interfaceVariable) {

//*** Laufbereich festlegen

m_nRangeStart = (long) VariantToDouble(&m_interfaceVariable.GetRangeMin());

m_nRangeEnd = (long) VariantToDouble(&m_interfaceVariable.GetRangeMax());

m_wndSliderCtrl.SetRange(m_nRangeStart,m_nRangeEnd,TRUE);

//*** Nebenticks festlegen

m_wndSliderCtrl.SetTicFreq(m_nTickCount);

m_wndSliderCtrl.SetPageSize(m_nTickCount);

m_wndSliderCtrl.SetLineSize(m_nLineSize);

} else {

m_wndSliderCtrl.SetRange(0,0,TRUE);

return FALSE;

}

m_bInitialized = TRUE;

return TRUE;

}


zenonExit

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Methoden -> zenonExit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Methode werden die zenon Schnittstellen wieder freigegeben.

BOOL CCD_SliderCtrlCtrl::zenonExit()

{

m_interfaceElement.ReleaseDispatch();

m_interfaceVariable.ReleaseDispatch();

return TRUE;

}


Bedienung und Darstellung

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Bedienung und Darstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Zeichnen

Sollwert setzen


Zeichnen

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Bedienung und Darstellung -> Zeichnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über DoSuperclassPaint wird das SliderCtrl gezeichnet (da es sich um gesubclassed Control handelt). Wenn im Moment des Zeichnens der Regler verschoben wird, nimmt die Variable m_bInitialized den Wert FALSE an. Damit wird sichergestellt, dass der Wert verändert werden kann. Im Normalfall wird der Wert der Variable ermittelt und über die Methode SetPos des SliderCtrls dargestellt.

void CCD_SliderCtrlCtrl::OnDraw(CDC* pdc, const CRect& rcBounds, const CRect& rcInvalid)

{

//*** Aktualisiere die Ansicht

DoSuperclassPaint(pdc, rcBounds);

if (m_interfaceVariable && m_bInitialized) {

COleVariant cValue(m_interfaceVariable.GetValue());

int nValue = (int) VariantToDouble(&cValue.Detach());

m_wndSliderCtrl.SetPos(nValue);

}

}


Sollwert setzen

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> Bedienung und Darstellung -> Sollwert setzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der LButtonDown-Methode wird die Variable m_bInitialized auf FALSE gesetzt und im LButtonUp-Event wieder auf TRUE. Damit wird sichergestellt, dass der Wert verändert werden kann. Sonst würde die OnDraw-Routine aufgerufen und der ursprüngliche Wert dargestellt werden.

void CCD_SliderCtrlCtrl::OnLButtonDown(UINT nFlags, CPoint point)

{

m_bInitialized = FALSE;

COleControl::OnLButtonDown(nFlags, point);

}

void CCD_SliderCtrlCtrl::OnLButtonUp(UINT nFlags, CPoint point)

{

m_bInitialized = TRUE;

COleControl::OnLButtonUp(nFlags, point);

}

Ein Sollwert wird über eine Änderung des Reglers herbeigeführt. In den Methoden HScroll bzw. VScroll wird der Sollwert abgesetzt (abhängig, davon, ob es sich um einen horizontalen oder einen vertikalen Slider handelt).

void CCD_SliderCtrlCtrl::HScroll(UINT nSBCode, UINT nPos)

{

switch (nSBCode) {

case TB_LINEUP:

case TB_PAGEUP:

case TB_LINEDOWN:

case TB_PAGEDOWN:

case TB_THUMBTRACK:

case TB_THUMBPOSITION:{

//*** Sollwert ohne Dialog absetzen ?

int nValue = m_wndSliderCtrl.GetPos();

COleVariant cValue((short) nValue,VT_I2);

m_interfaceVariable.SetValue(cValue);

}

}

}


zenon Interface

Handbuch -> Controls -> ActiveX -> Beispiel CD_SliderCtrl (C++) -> zenon Interface

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit das Dispatch Interface von zenon zum Sollwertsetzen verwendet werden kann, müssen für die Variablen und das Element Klassen angelegt werden, die von COleDispatchDriver abgeleitet sind. Diese Klassen werden am einfachsten über den Class Wizard der Entwicklungsumgebung angelegt (Button Add Class, Auswahl von From a type library, zenrt32.tlb auswählen).

Bei unserem Control sind das die Klassen IElement und IVariable. Sie sind in zenrt32.h und zenrt32.cpp definiert.


Beispiel .NET Control als ActiveX (C#)

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da folgende Beispiel beschreibt ein .NET Control, das als ActiveX Control in zenon ausgeführt wird.

Die Erstellung und Integration passiert in vier Schritten:

  1. Windows Form Control erzeugen
  2. .NET User Control in Dual Control umwandeln
  3. Im Editor über VBA mit ActiveX arbeiten
  4. zenon Variablen mit dem .NET User Control verbinden

Noch in diesem Kapitel

Windows Form Control erzeugen

.NET User Control in Dual Control umwandeln

Im Editor über VBA mit ActiveX arbeiten

zenon Variablen mit dem .NET User Control verbinden


Windows Form Control erzeugen

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> Windows Form Control erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Windows Form Control zu erzeugen:

  1. Starten Sie Visual Studio 2008 und erzeugen Sie ein neues Windows Form Control Library Projekt:

  2. Benennen Sie das Default Control auf den gewünschten Controlnamen um.
    In unserem Beispiel: SampesControl.cs.

  3. Öffnen Sie den Control Designer und fügen Sie die gewünschten Controls ein, in unserem Fall eine Textbox:

  4. Controls verfügen normalerweise über Eigenschaften. Öffnen Sie den Code Designer über View Code und fügen Sie die gewünschten extern verfügbaren Properties hinzu.
    In unserem Beispiel: Extern sichtbares Property „UserText" mit get und set Zugriff, das den Text der Textbox enthält:

  5. Kompilieren Sie das Projekt.

    Das Windows Forms Control kann jetzt in anderen Windows Forms Projekten verwendet werden.

    Wichtig: Das Control muss manuell über Choose Items in die Control Toolbox eingefügt werden.


.NET User Control in Dual Control umwandeln

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> .NET User Control in Dual Control umwandeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um das .NET in ein Dual Control umzuwandeln, muss zuerst die COM-Schnittstelle für ActiveX aktiviert werden.

  1. Öffnen Sie das Projekt und aktivieren Sie unter den Build-Einstellungen die Eigenschaft Register for COM interop:

  2. Öffnen Sie die Datei AssemblyInfo.cs und
    • setzen Sie das Attribut ComVisible auf true
    • fügen Sie das Attribut ClassInterface hinzu

    [assembly: ComVisible(true)]

    [assembly: ClassInterface(ClassInterfaceType.AutoDual)]

  3. Öffnen Sie den Codedesigner über View Code und fügen Sie die notwendigen ActiveX Attribute und using Einträge hinzu. Erzeugen Sie über das Menü Tools/Create GUID eine neue GUID für das GUID-Attribut:

  4. Damit das Control auch als ActiveX Oberflächen Control auswählbar ist, müssen in die Control-Klasse noch folgende Funktionen eingefügt werden:
    • RegisterClass
    • UnregisterClass

    Danach kann das Control in der Registry registriert werden.

  5. Kompilieren Sie das Projekt erneut.

    Das Windows Form Control ist jetzt ActiveX fähig und wurde beim Rebuild automatisch registriert. Eine zusätzliche Typelib-Datei zenOnDotNetControl.tlb wurde im Outputverzeichnis erstellt.

  6. Um das Control auf einem anderen Rechner einzusetzen:
    1. kopieren Sie die DLL-Datei und die TLB-Datei auf den Zielrechner
    2. registrieren Sie die Dateien über die Kommandozeile mit:
      %windir%\Microsoft.NET\Framework\v2.0.50727\regasm.exe zenOnDotNetControl.dll /tlb:zenOnDotNetControl.tlb
  7. Fügen Sie das erweiterte Windows Form Control als ActiveX Control in den zenon Editor ein:


Im Editor über VBA mit ActiveX arbeiten

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> Im Editor über VBA mit ActiveX arbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um im zenon Editor auf die Eigenschaften des Controls zugreifen zu können:

  1. Erzeugen Sie im zenon Editor im Knoten Programmierschnittstellen/VBA-Makros ein neues Init Makro mit der Bezeichnung Init_ActiveX.

    Mit diesem Makro kann man über obElem.AktiveX auf alle externen Properties zugreifen.

  2. Weisen Sie dieses Makro über die Eigenschaften VBA/Init des ActiveX Elements dem ActiveX Control zu.

    Interne ID: Im Editor über VBA mit ActiveX arbeiten

    Init

    VBA Makro, das beim Initialisieren des Elements ausgeführt werden soll.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Im Editor über VBA mit ActiveX arbeiten

    VBA

    Eigenschaften für mit dem Element verknüpfte VBA Makros.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beispiel Init Makro

Public Sub Init_ActiveX(obElem As Element)

obElem.AktiveX.Usertext = "Den String auf das Control setzen"

End Sub


zenon Variablen mit dem .NET User Control verbinden

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon haben Sie die Möglichkeit, ein ActiveX Control um spezielle Funktionen zu erweiterten und darin auf die zenon API zuzugreifen.

Benötigte Methoden

  • public bool zenOnInit (Wird beim Control Initialisieren in der zenon Runtime aufgerufen.)
  • public bool zenOnInitED (Wird im Editor verwendet.)
  • public bool zenOnExit() (Wird beim Control-Zerstören in der zenon Runtime aufgerufen.)
  • public bool zenOnExitED() (Wird im Editor verwendet.)
  • public short CanUseVariables() (Unterstützt das Verknüpfungen von Variablen.)
  • public short VariableTypes() (Vom Control unterstützte Datentypen)
  • public MaxVariables() (Maximale Anzahl der Variablen, die mit dem Control verknüpft werden können.)

Referenz hinzufügen

  1. Wählen Sie in Microsoft Visual Studio unter Add References die zenon Runtime-Objektbibliothek aus, damit man im Control auf die zenon API zugreifen kann.

  2. Fügen Sie die erweiterten Funktionen in den Klassencode des Controlsl ein, um auf die gesamte zenon API zuzugreifen.

    In unserem Beispiel wird das COM-Objekt einer zenon Variable in einem Member zwischengespeichert, um später im Paint Event des Controls darauf zugreifen zu können.

Noch in diesem Kapitel

public bool zenOnInit(zenOn.Element dispElement)

public bool zenOnInitED(zenOn.Element dispElement)

public bool zenOnExit()

public bool zenOnExitED()

public short CanUseVariables()

public short VariableTypes()

public MaxVariables()


public bool zenOnInit(zenOn.Element dispElement)

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnInit(zenOn.Element dispElement)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Hilfe dieser Methode wird in der Runtime dem ActiveX Control ein Zeiger auf das Dispatch Interface des Dynamischen Elements übergeben. Über diesen Zeiger können dann die mit dem Dynamischen Element verknüpften zenon Variablen angesprochen werden.

Die Reihenfolge der übergebenen Variablen stellen Sie im Element-Eingabe Dialog mit den Schaltflächen Nach unten oder Nach oben ein. Der Element-Eingabe Dialog öffnet sich, wenn Sie:

  • das ActivX Element doppelklicken oder
  • im Kontextmenü Eigenschaften wählen oder
  • im Eigenschaftenfenster im Knoten Darstellung die Eigenschaft ActiveX Einstellungen wählen

    Interne ID: public bool zenOnInit(zenOn.Element dispElement)

    ActiveX Einstellungen

    Auswahl des ActiveX-Elements und der verknüpften Variable.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: public bool zenOnInit(zenOn.Element dispElement)

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


public bool zenOnInitED(zenOn.Element dispElement)

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnInitED(zenOn.Element dispElement)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Entspricht public bool zenOnInit und wird beim Öffnen des ActiveX im Editor (Doppelklick auf ActiveX) ausgeführt.


public bool zenOnExit()

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnExit()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode wird von der zenon Runtime beim Schließen des ActiveX Controls aufgerufen. Hier sollten alle Dispatch Pointer auf Variablen freigegeben werden.


public bool zenOnExitED()

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnExitED()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Entspricht public bool zenOnExit() und wird beim Schließen des ActiveX im Editor ausgeführt. Damit kann man auch im Editor auf Änderungen, etwas Wertänderungen, reagieren.


public short CanUseVariables()

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public short CanUseVariables()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode gibt 1 zurück, wenn das Control zenon Variablen verwenden kann, und 0 wenn nicht.

  • 1: Für das Dynamische Element können(über die Schaltfläche Variablen) nur zenon Variablen mit den über die Methode VariableTypes angegebenen Typen in der von der Methode MaxVariables angegebenen Anzahl angegeben werden.
  • 0: Gibt CanUseVariables 0 zurück oder besitzt das Control diese Methode nicht, können Variablen mit allen Typen ohne Beschränkung der Anzahl angegeben werden. Diese können in der Runtime aber nur über VBA verwendet werden.


public short VariableTypes()

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public short VariableTypes()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der von dieser Methode zurückgegebene Wert wird als Maske für die verwendbaren Variablentypen in der Variablenliste verwendet. Der Wert ist eine UND-Verknüpfung aus folgenden Werten (definiert in zenon32/dy_type.h):

Parameter | Wert | Beschreibung
WORD | 0x0001 | entspricht Stelle 0
BYTE | 0x0002 | entspricht Stelle 1
BIT | 0x0004 | entspricht Stelle 2
DWORD | 0x0008 | entspricht Stelle 3
FLOAT | 0x0010 | entspricht Stelle 4
DFLOAT | 0x0020 | entspricht Stelle 5
STRING | 0x0040 | entspricht Stelle 6
IN_OUTPUT | 0x8000 | entspricht Stelle 15


public MaxVariables()

Handbuch -> Controls -> ActiveX -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public MaxVariables()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier wird die Anzahl der Variablen festgelegt, die aus der Variablenliste ausgewählt werden können:

1: In der Variablenliste wird die Mehrfachauswahl deaktiviert. Es erfolgt eine Warnung, wenn trotzdem mehrere Variable ausgewählt werden.


.NET User Controls

Handbuch -> Controls -> .NET User Controls

Mit .NET Controls kann die Funktionalität der zenon Runtime und des Editors selbstständig erweitert werden.

In diesem Handbuch lesen Sie:

  • Unterschiede zwischen Control Container und ActiveX
  • Beispiel .NET Control Container
  • Beispiel .NET Control als ActiveX (C#)

Informationen zur Verwendung von .NET Controls in ActiveX finden Sie im auch Handbuch Bilder im Kapitel .NET Controls.

Noch in diesem Kapitel

Unterschiede Nutzung .Net Control in Control Container oder ActiveX

Beispiel .NET Control Container

Beispiel .NET Control als ActiveX (C#)


Unterschiede Nutzung .Net Control in Control Container oder ActiveX

Handbuch -> Controls -> .NET User Controls -> Unterschiede Nutzung .Net Control in Control Container oder ActiveX

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein .NET User Control kann:

  • über CD_DotNetControlContainer Control direkt in das zenon ActiveX-Element eingebunden werden
  • als ActiveX Control verwendet und direkt in das zenon ActiveX-Element eingebunden werden

Unterschiede zwischen Container Control und ActiveX Control sind vor allem:

CD_DotNetControlContainer Control

ActiveX Control

  • Muss nicht am Rechner registriert werden.
  • Muss als ActiveX am Rechner registriert werden (regsvr32).
  • Bei Änderungen am Control muss nur die DLL ausgetauscht werden.
  • Bei Änderungen am Control muss die TLB neu registriert werden.
  • Zugriff über VBA und VSTA nur über CD_DotNetControlContainer Methoden möglich.
  • Zugriff über VBA und VSTA sehr einfach.


Beispiel .NET Control Container

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Tutorial wird beschrieben, wie man in Visual Studio 2010 ein einfaches .NET User Control (Programmiersprache C#) erstellt und dieses anschließend mit Hilfe des zenon CD_DotNetControlContainer Controls als ActiveX in ein zenon ActiveX Element einbindet.

Noch in diesem Kapitel

Allgemeines

.Net User Control erstellen

CD_DotNetControlContainer und .NET User Control einfügen

Zugriff auf das User Control über VSTA oder VBA


Allgemeines

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> Allgemeines

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der CD_DotNetControlContainer dient als Wrapper zwischen einem User Control und dem zenon AktivX Element. Alle im folgenden Beispiel verwendeten Methoden sowie alle Public Methoden und Properties werden über den CD_DotNetControlContainer vom User Control zum ActiveX weitergegeben und können von zenon verwendet werden, auch in VBA und VSTA.

Wird im User Control auf das zenon Programming Interface referenziert, kann direkt auf zenon Objekte zugegriffen werden.

Im folgenden Beispiel werden wir:

  • ein .Net User Control erstellen
  • CD_DotNetControlContainer und .NET User Control einfügen
  • den Zugriff auf das User Control über VSTA (VBA) ermöglichen

Noch in diesem Kapitel

public bool zenOnInit(zenOn.Element dispElement)

public bool zenOnExit()

public short CanUseVariables()

public short VariableTypes()

public MaxVariables()


public bool zenOnInit(zenOn.Element dispElement)

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> Allgemeines -> public bool zenOnInit(zenOn.Element dispElement)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Hilfe dieser Methode wird in der Runtime dem ActiveX Control ein Zeiger auf das Dispatch Interface des Dynamischen Elements übergeben. Über diesen Zeiger können dann die mit dem Dynamischen Element verknüpften zenon Variablen angesprochen werden.

Die Reihenfolge der übergebenen Variablen stellen Sie im Element-Eingabe Dialog mit den Schaltflächen Nach unten oder Nach oben ein. Der Element-Eingabe Dialog öffnet sich, wenn Sie:

  • das ActivX Element doppelklicken oder
  • im Kontextmenü Eigenschaften wählen oder
  • im Eigenschaftenfenster im Knoten Darstellung die Eigenschaft ActiveX Einstellungen wählen

    Interne ID: public bool zenOnInit(zenOn.Element dispElement)

    ActiveX Einstellungen

    Auswahl des ActiveX-Elements und der verknüpften Variable.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: public bool zenOnInit(zenOn.Element dispElement)

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


public bool zenOnExit()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> Allgemeines -> public bool zenOnExit()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode wird von der zenon Runtime beim Schließen des ActiveX Controls aufgerufen. Hier sollten alle Dispatch Pointer auf Variablen freigegeben werden.


public short CanUseVariables()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> Allgemeines -> public short CanUseVariables()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode gibt 1 zurück, wenn das Control zenon Variablen verwenden kann, und 0 wenn nicht.

  • 1: Für das Dynamische Element können(über die Schaltfläche Variablen) nur zenon Variablen mit den über die Methode VariableTypes angegebenen Typen in der von der Methode MaxVariables angegebenen Anzahl angegeben werden.
  • 0: Gibt CanUseVariables 0 zurück oder besitzt das Control diese Methode nicht, können Variablen mit allen Typen ohne Beschränkung der Anzahl angegeben werden. Diese können in der Runtime aber nur über VBA verwendet werden.


public short VariableTypes()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> Allgemeines -> public short VariableTypes()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der von dieser Methode zurückgegebene Wert wird als Maske für die verwendbaren Variablentypen in der Variablenliste verwendet. Der Wert ist eine UND-Verknüpfung aus folgenden Werten (definiert in zenon32/dy_type.h):

Parameter | Wert | Beschreibung
WORD | 0x0001 | entspricht Stelle 0
BYTE | 0x0002 | entspricht Stelle 1
BIT | 0x0004 | entspricht Stelle 2
DWORD | 0x0008 | entspricht Stelle 3
FLOAT | 0x0010 | entspricht Stelle 4
DFLOAT | 0x0020 | entspricht Stelle 5
STRING | 0x0040 | entspricht Stelle 6
IN_OUTPUT | 0x8000 | entspricht Stelle 15


public MaxVariables()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> Allgemeines -> public MaxVariables()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier wird die Anzahl der Variablen festgelegt, die aus der Variablenliste ausgewählt werden können:

1: In der Variablenliste wird die Mehrfachauswahl deaktiviert. Es erfolgt eine Warnung, wenn trotzdem mehrere Variable ausgewählt werden.


.Net User Control erstellen

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> .Net User Control erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei dem User Control handelt es sich um ein einfaches Control, das es ermöglicht, über ein Eingabefeld (Textbox) einen neuen Wert zu setzen. Nach Drücken des Buttons wird der Wert auf die gewünschte zenon Variable geschrieben.

Eine weitere Funktion soll automatisch eine Wertänderung der Variable in zenon erkennen und den neuen Wert automatisch im Control anzeigen.

Arbeitsschritte

  1. Zunächst erstellen Sie ein neues Projekt in VS und verwenden dazu den Projekttypen „Windows Forms Control Library"

    Wichtig: Framework auf 3.5 einstellen!

  2. Danach benennen Sie die CS-Datei „UserControl" in „zenon_CD_DotNetControlContainer.cs" um. Die Dateien Designer.cs und .resx werden automatisch mit unbenannt.

  3. Im nächsten Schritt erstellen Sie das User Control. Dazu benötigen Sie zwei Textboxen für die Ein-und Ausgabe sowie einen Button zum Absetzen eines neuen Wertes auf die zenon Variable.
    Bennen Sie:
    • die erste Textbox „txtGetZenonVariable"
    • die zweite Textbox „txtSetZenonVariable"
    • den Button „btnSetZenonVariable"

  4. Um auf zenon Objekte zugreifen zu können, benötigen Sie eine Referenz auf das zenon Programming Interface. Dazu:
    • klicken Sie auf den Knoten „References" im Solution Explorer
    • öffnen das Kontexmenü
    • wählen Add References…
    • wechseln zur Registerkarte COM
    • wählen die zenon programming interface library aus

    Danach sollte die „zenOn" Referenz in der Liste der Referenzen sichtbar sein.

  5. Im nächsten Schritt legen Sie im Programmcode der zenon_CD_DotNetControlContainer.cs eine globale Variable vom Typ zenon.Variable an:

  6. Diese Variable wird über die public Methode zenOnInit initialisiert:

    und über die public Methode zenOnExit wieder freigegeben:

    In den folgenden Methoden wird festgelegt ob zenon Variable und Datentypen verwendet werden und wie viele Variable übergeben werden dürfen:

  7. Im nächsten Schritt legen Sie im Click-Event des Buttons btnSetZenonVariable fest, dass beim Klicken des Buttons der Wert in der Textbox txtSetZenonVariable auf den Wert der zenon Variable geschrieben und danach der Inhalt der Textbox gelöscht wird.

  8. Um auf eine Wertänderung der Variable reagieren können, benötigen Sie das Paint-Event des Controls. Das Paint-Event wird auch getriggert, wenn sich der Wert der initialisierten zenon Variable ändert und kann somit für die Aktualisierung von Werten verwendet werden. Da Variablen die im zenon ActiveX-Element referenziert sind automatisch adviced sind, kann generell auf den zenon.OnlineVariable Container im Control verzichtet werden.

Der Code im Überblick

Hier nochmals der gesamte Code im Überblick:

using System;

using System.Collections.Generic;

using System.ComponentModel;

using System.Drawing;

using System.Data;

using System.Linq;

using System.Text;

using System.Windows.Forms;

using zenOn;

namespace zenon_CD_DotNetControlContainer

{

public partial class zenon_CD_DotNetControlContainer : UserControl

{

//This will be needed to get the zenon Variable Container

zenOn.Variable m_cVal = null;

public zenon_CD_DotNetControlContainer()

{

InitializeComponent();

}

/// <summary>

/// This public Method will be called by the initialization of the control during

/// the zenon Runtime.

/// </summary>

/// <param name="dispElement"></param>

/// <returns></returns>

public bool zenOnInit(zenOn.Element dispElement)

{

//Check if zenon Variables are added to the

//Control

if (dispElement.CountVariable > 0)

{

try

{

//Take the first zenon Variable and added

//to the global Variable

m_cVal = dispElement.ItemVariable(0);

}

catch { }

}

return true;

}

// <summary>

/// This public Method will be calles by the release of the control during

/// the zenon Runtime.

/// </summary>

/// <returns></returns>

public bool zenOnExit()

{

try

{

if (m_cVal != null)

{

//Release the zenon Variable (Com-Object)

System.Runtime.InteropServices.Marshal.FinalReleaseComObject(m_cVal);

m_cVal = null;

}

}

catch { }

return true;

}

/// <summary>

/// This public Method is needed to link zenon Variables

/// to the control.

/// </summary>

/// <returns></returns>

public short CanUseVariables()

{

return 1; // Only tis Variable is supported

}

/// <summary>

/// This public Method returns the Type of

/// supported zenon Variables

/// </summary>

/// <returns></returns>

public short VariableTypes()

{

return short.MaxValue; // all Data Types supported

}

/// <summary>

/// This public Method returns the number of

/// supported zenon Variables

/// </summary>

/// <returns></returns>

public short MaxVariables()

{

return 1; // Only 1 Variable should linked to the Control

}

/// <summary>

/// This will be triggert by clicking the Button. The new Value will

/// be set to the zenon Variable

/// </summary>

/// <param name="sender"></param>

/// <param name="e"></param>

private void btnSetZenonVariable_Click(object sender, EventArgs e)

{

//Set Value from TextBox to the zenon Variable

m_cVal.set_Value(0,txtSetZenonVariable.Text.ToString());

this.txtSetZenonVariable.Text = string.Empty;

}

/// <summary>

/// This will be triggert by painting the User Control or the Value of the Variable changed.

/// After the value of the Variable changed the Control will be new painted and the new Value

/// will be set to the Textbox.

/// </summary>

/// <param name="sender"></param>

/// <param name="e"></param>

private void zenon_CD_DotNetControlContainer_Paint(object sender, PaintEventArgs e)

{

if (m_cVal != null)

{

this.txtGetZenonVariable.Text = m_cVal.get_Value(0).ToString();

return;

}

else

{

this.txtGetZenonVariable.Text = "Variable Value";

return;

}

}

}

}

Release erstellen

Zum Schluss erstellen Sie ein Release, um die fertige DLL in zenon bzw. in den CD_DotNetControlContainer einbinden zu können.

Dafür muss unbedingt in den Settings von Debug auf Release umgestellt werden.


CD_DotNetControlContainer und .NET User Control einfügen

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> CD_DotNetControlContainer und .NET User Control einfügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um das zenon Projekt vorzubereiten und den CD_DotNetControlContainer und das .NET User Control einzufügen, führen Sie folgende Schritte aus:

  1. Legen Sie eine interne Variable vom Typ String an und setzen Sie die Stringlänge auf 30.

  2. Fügen Sie im zenon Projektknoten Projekt/Dateien/Sonstige die DLL des erstellten .NET User Controls ein.

    Die DLL befindet sich im Visual Studio Projekt-Ordner unter bin\Release\zenon_CD_DotNetControlContainer.dll.

  3. Im Projekt wählen Sie das ActiveX-Element und ziehen es in ein zenon Bild.
    • Der Dialog Konfiguration wird geöffnet.
    • Wählen Sie das CD_DotNetControlContainer.Container Control aus.

  4. Um das .NET User Control in das CD_DotNetControlContainer Control einzubetten:
    • klicken Sie auf die Schaltfläche Eigenschaften…
    • ein neuer Dialog wird geöffnet

    • mit Klick auf die Schaltfläche Load wählen Sie den Pfad des Projektordners, zum Beispiel: C:\ProgramData\COPA-DATA\SQL\9888419d-251e-4595-b396-9be42367997c\FILES\zenon\custom\additional\zenon_CD_DotNetControlContainer.dll

    Durch das Einfügen der DLL im Ordner additional wird das Control automatisch beim Kopieren oder Laden der Runtime-Dateien auf einen anderen Rechner mit geschickt. Dadurch geht die Verknüpfung nicht verloren.

    Nun sollte das .NET User Control angezeigt werden.

    Bestätigen Sie den Dialog mit Klick auf OK.

  5. Im letzten Schritt verknüpfen Sie über die Schaltfläche Variablen eine Variable mit dem Control verknüpfen.

    Die erste ausgewählte Variable wird automatisch über die public Methode zenonInit mit der global definierten Variable (.NET UserControl) verknüpft. Die Verlinkung mit dem Control erfolgt aber erst nach dem Start der Runtime.

    Dann verlinken Sie noch die interne Variable mit einem Textelement.

  6. Nach dem Runtime Start ist das Control zunächst leer.

    Wird ein Wert in die zweite Textbox geschrieben und danach mit dem Button Set zenon Variable bestätigt, dann wird der Wert auf die zenon Variable geschrieben. (Das btnSetZenonVariable_Click Event wird ausgeführt.)

    Dieser wird auch im zenon Textelement angezeigt.

    Wird der Wert direkt im zenon Text-Element geändert,

    dann wird der Wert direkt über das Paint Event des .NET Controls in die erste Textbox geschrieben.


Zugriff auf das User Control über VSTA oder VBA

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control Container -> Zugriff auf das User Control über VSTA oder VBA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Beispiel wird der Zugriff über VSTA gezeigt. Die Vorgehensweise ist bei VBA die gleiche.

  1. Erweitern Sie das Control mit einen Label (label) und bennen Sie dieses lblzenonInfo. In diesem Label soll der Wert einer anderen zenon Variablen angezeigt werden. Der neue Wert soll über ein VSTA Makro gesetzt werden.

  2. Erweitern Sie den Code um ein Property (Information) und fügen get und set Eigenschaften zu dem Property hinzu. Diese erlauben es, den Text des Labels zu lesen und zu schreiben.

  3. Erstellen Sie ein neues Release für unser User Control und kopieren Sie dieses wieder in den Ordner additional des zenon Projekts.
    Nicht vergessen: zenon Editor vorher schließen!
    Löschen Sie die alte DLL und starten Sie den zenon Editor neu. Sollte sich die DLL immer noch im Ordner befinden, einfach ein zweites Mal löschen. Jetzt kann die geänderte DLL neu importiert werden. Das CD_DotNetContainerControl sowie das ActiveX werden automatisch aktualisiert.
  4. Klicken Sie im zenon Editor auf das ActiveX und öffnen Sie das Eigenschaftenfenster.

    Sie können nun die neue Eigenschaft Information im Auswahlfenster des Controls sehen und auch einen Wert setzen.

    Dieser Wert wird auch im Control gesetzt („myInformation")

  5. Um mit dem CD_DotNetControlContainer in VSTA oder VBA arbeiten zu können, benötigen Sie zunächst die Referenz auf das Control. Nach dem VSTA für das Projekt geöffnet wurde (ProjectAddin) muss die Referenz vom CD_DotNetControlContainer hinzugefügt werden.

    Zusätzlich muss auch das Assembly System.Windows.Forms hinzugefügt werden.

  6. Mit folgendem Code kann der Wert für die Control Eigenschaft Information neu gesetzt werden:

  7. Zum Schluss:
    • erstellen Sie eine zenon Funktion VSTA Makro ausführen
    • verknüpfen Sie die Funktion mit einem Button

    Zur Runtime wird das Label beim Klick auf den Button von myInformation auf New Information geändert.

    Und beim nächsten Drücken des Buttons wieder zurück geändert.


Beispiel .NET Control als ActiveX (C#)

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da folgende Beispiel beschreibt ein .NET Control, das als ActiveX Control in zenon ausgeführt wird.

Die Erstellung und Integration passiert in vier Schritten:

  1. Windows Form Control erzeugen
  2. .NET User Control in Dual Control umwandeln
  3. Im Editor über VBA mit ActiveX arbeiten
  4. zenon Variablen mit dem .NET User Control verbinden

Noch in diesem Kapitel

Windows Form Control erzeugen

.NET User Control in Dual Control umwandeln

Im Editor über VBA mit ActiveX arbeiten

zenon Variablen mit dem .NET User Control verbinden


Windows Form Control erzeugen

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> Windows Form Control erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Windows Form Control zu erzeugen:

  1. Starten Sie Visual Studio 2008 und erzeugen Sie ein neues Windows Form Control Library Projekt:

  2. Benennen Sie das Default Control auf den gewünschten Controlnamen um.
    In unserem Beispiel: SampesControl.cs.

  3. Öffnen Sie den Control Designer und fügen Sie die gewünschten Controls ein, in unserem Fall eine Textbox:

  4. Controls verfügen normalerweise über Eigenschaften. Öffnen Sie den Code Designer über View Code und fügen Sie die gewünschten extern verfügbaren Properties hinzu.
    In unserem Beispiel: Extern sichtbares Property „UserText" mit get und set Zugriff, das den Text der Textbox enthält:

  5. Kompilieren Sie das Projekt.

    Das Windows Forms Control kann jetzt in anderen Windows Forms Projekten verwendet werden.

    Wichtig: Das Control muss manuell über Choose Items in die Control Toolbox eingefügt werden.


.NET User Control in Dual Control umwandeln

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> .NET User Control in Dual Control umwandeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um das .NET in ein Dual Control umzuwandeln, muss zuerst die COM-Schnittstelle für ActiveX aktiviert werden.

  1. Öffnen Sie das Projekt und aktivieren Sie unter den Build-Einstellungen die Eigenschaft Register for COM interop:

  2. Öffnen Sie die Datei AssemblyInfo.cs und
    • setzen Sie das Attribut ComVisible auf true
    • fügen Sie das Attribut ClassInterface hinzu

    [assembly: ComVisible(true)]

    [assembly: ClassInterface(ClassInterfaceType.AutoDual)]

  3. Öffnen Sie den Codedesigner über View Code und fügen Sie die notwendigen ActiveX Attribute und using Einträge hinzu. Erzeugen Sie über das Menü Tools/Create GUID eine neue GUID für das GUID-Attribut:

  4. Damit das Control auch als ActiveX Oberflächen Control auswählbar ist, müssen in die Control-Klasse noch folgende Funktionen eingefügt werden:
    • RegisterClass
    • UnregisterClass

    Danach kann das Control in der Registry registriert werden.

  5. Kompilieren Sie das Projekt erneut.

    Das Windows Form Control ist jetzt ActiveX fähig und wurde beim Rebuild automatisch registriert. Eine zusätzliche Typelib-Datei zenOnDotNetControl.tlb wurde im Outputverzeichnis erstellt.

  6. Um das Control auf einem anderen Rechner einzusetzen:
    1. kopieren Sie die DLL-Datei und die TLB-Datei auf den Zielrechner
    2. registrieren Sie die Dateien über die Kommandozeile mit:
      %windir%\Microsoft.NET\Framework\v2.0.50727\regasm.exe zenOnDotNetControl.dll /tlb:zenOnDotNetControl.tlb
  7. Fügen Sie das erweiterte Windows Form Control als ActiveX Control in den zenon Editor ein:


Im Editor über VBA mit ActiveX arbeiten

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> Im Editor über VBA mit ActiveX arbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um im zenon Editor auf die Eigenschaften des Controls zugreifen zu können:

  1. Erzeugen Sie im zenon Editor im Knoten Programmierschnittstellen/VBA-Makros ein neues Init Makro mit der Bezeichnung Init_ActiveX.

    Mit diesem Makro kann man über obElem.AktiveX auf alle externen Properties zugreifen.

  2. Weisen Sie dieses Makro über die Eigenschaften VBA/Init des ActiveX Elements dem ActiveX Control zu.

    Interne ID: Im Editor über VBA mit ActiveX arbeiten

    Init

    VBA Makro, das beim Initialisieren des Elements ausgeführt werden soll.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Im Editor über VBA mit ActiveX arbeiten

    VBA

    Eigenschaften für mit dem Element verknüpfte VBA Makros.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beispiel Init Makro

Public Sub Init_ActiveX(obElem As Element)

obElem.AktiveX.Usertext = "Den String auf das Control setzen"

End Sub


zenon Variablen mit dem .NET User Control verbinden

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon haben Sie die Möglichkeit, ein ActiveX Control um spezielle Funktionen zu erweiterten und darin auf die zenon API zuzugreifen.

Benötigte Methoden

  • public bool zenOnInit (Wird beim Control Initialisieren in der zenon Runtime aufgerufen.)
  • public bool zenOnInitED (Wird im Editor verwendet.)
  • public bool zenOnExit() (Wird beim Control-Zerstören in der zenon Runtime aufgerufen.)
  • public bool zenOnExitED() (Wird im Editor verwendet.)
  • public short CanUseVariables() (Unterstützt das Verknüpfungen von Variablen.)
  • public short VariableTypes() (Vom Control unterstützte Datentypen)
  • public MaxVariables() (Maximale Anzahl der Variablen, die mit dem Control verknüpft werden können.)

Referenz hinzufügen

  1. Wählen Sie in Microsoft Visual Studio unter Add References die zenon Runtime-Objektbibliothek aus, damit man im Control auf die zenon API zugreifen kann.

  2. Fügen Sie die erweiterten Funktionen in den Klassencode des Controlsl ein, um auf die gesamte zenon API zuzugreifen.

    In unserem Beispiel wird das COM-Objekt einer zenon Variable in einem Member zwischengespeichert, um später im Paint Event des Controls darauf zugreifen zu können.

Noch in diesem Kapitel

public bool zenOnInit(zenOn.Element dispElement)

public bool zenOnInitED(zenOn.Element dispElement)

public bool zenOnExit()

public bool zenOnExitED()

public short CanUseVariables()

public short VariableTypes()

public MaxVariables()


public bool zenOnInit(zenOn.Element dispElement)

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnInit(zenOn.Element dispElement)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Hilfe dieser Methode wird in der Runtime dem ActiveX Control ein Zeiger auf das Dispatch Interface des Dynamischen Elements übergeben. Über diesen Zeiger können dann die mit dem Dynamischen Element verknüpften zenon Variablen angesprochen werden.

Die Reihenfolge der übergebenen Variablen stellen Sie im Element-Eingabe Dialog mit den Schaltflächen Nach unten oder Nach oben ein. Der Element-Eingabe Dialog öffnet sich, wenn Sie:

  • das ActivX Element doppelklicken oder
  • im Kontextmenü Eigenschaften wählen oder
  • im Eigenschaftenfenster im Knoten Darstellung die Eigenschaft ActiveX Einstellungen wählen

    Interne ID: public bool zenOnInit(zenOn.Element dispElement)

    ActiveX Einstellungen

    Auswahl des ActiveX-Elements und der verknüpften Variable.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: public bool zenOnInit(zenOn.Element dispElement)

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


public bool zenOnInitED(zenOn.Element dispElement)

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnInitED(zenOn.Element dispElement)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Entspricht public bool zenOnInit und wird beim Öffnen des ActiveX im Editor (Doppelklick auf ActiveX) ausgeführt.


public bool zenOnExit()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnExit()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode wird von der zenon Runtime beim Schließen des ActiveX Controls aufgerufen. Hier sollten alle Dispatch Pointer auf Variablen freigegeben werden.


public bool zenOnExitED()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public bool zenOnExitED()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Entspricht public bool zenOnExit() und wird beim Schließen des ActiveX im Editor ausgeführt. Damit kann man auch im Editor auf Änderungen, etwas Wertänderungen, reagieren.


public short CanUseVariables()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public short CanUseVariables()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Methode gibt 1 zurück, wenn das Control zenon Variablen verwenden kann, und 0 wenn nicht.

  • 1: Für das Dynamische Element können(über die Schaltfläche Variablen) nur zenon Variablen mit den über die Methode VariableTypes angegebenen Typen in der von der Methode MaxVariables angegebenen Anzahl angegeben werden.
  • 0: Gibt CanUseVariables 0 zurück oder besitzt das Control diese Methode nicht, können Variablen mit allen Typen ohne Beschränkung der Anzahl angegeben werden. Diese können in der Runtime aber nur über VBA verwendet werden.


public short VariableTypes()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public short VariableTypes()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der von dieser Methode zurückgegebene Wert wird als Maske für die verwendbaren Variablentypen in der Variablenliste verwendet. Der Wert ist eine UND-Verknüpfung aus folgenden Werten (definiert in zenon32/dy_type.h):

Parameter | Wert | Beschreibung
WORD | 0x0001 | entspricht Stelle 0
BYTE | 0x0002 | entspricht Stelle 1
BIT | 0x0004 | entspricht Stelle 2
DWORD | 0x0008 | entspricht Stelle 3
FLOAT | 0x0010 | entspricht Stelle 4
DFLOAT | 0x0020 | entspricht Stelle 5
STRING | 0x0040 | entspricht Stelle 6
IN_OUTPUT | 0x8000 | entspricht Stelle 15


public MaxVariables()

Handbuch -> Controls -> .NET User Controls -> Beispiel .NET Control als ActiveX (C#) -> zenon Variablen mit dem .NET User Control verbinden -> public MaxVariables()

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier wird die Anzahl der Variablen festgelegt, die aus der Variablenliste ausgewählt werden können:

1: In der Variablenliste wird die Mehrfachauswahl deaktiviert. Es erfolgt eine Warnung, wenn trotzdem mehrere Variable ausgewählt werden.


WPF-Element

Handbuch -> Controls -> WPF-Element

Mit dem Dynamischen Element WPF können gültige WPF/XAML-Dateien in zenon eingebunden und dargestellt werden.

info Info

Alle Marken- und Produktnamen in dieser Dokumentation sind Warenzeichen oder eingetragene Warenzeichen der jeweiligen Titelhalter.

Noch in diesem Kapitel

Grundlagen

Leitfaden für Designer

Engineering in zenon


Grundlagen

Handbuch -> Controls -> WPF-Element -> Grundlagen

XAML

XAML steht für Extensible Application Markup Language und wird ['zæ:m?l] ausgesprochen. Die von Microsoft entwickelte XML basierte Beschreibungssprache definiert die Syntax in Silverlight-Anwendungen und WPF-Oberflächen. XAML erlaubt es, Design und Programmierung zu trennen. Der Designer bereitet die grafische Oberfläche vor und erstellt Basis-Animationen, die dann vom Entwickler/Projekteur aufgegriffen werden. Der Projekteur kann diese .xaml Dateien gezielt ansteuern und entsprechend animieren.

WPF

WPF steht für Windows Presentation Foundation und bezeichnet ein Grafik-Framework, das Teil von Windows .NET Framework ist:

  • WPF stellt die Programmierumgebung dar.
  • XAML beschreibt, basierend auf XML, als Auszeichnungssprache die Oberflächenhierarchie.
    Je nach Aufbau der XAML-Datei besteht die Möglichkeit, Eigenschaften, Ereignisse und Transformationen von WPF-Elementen mit Variablen und Funktionen von zenon zu verknüpfen.
  • Das Framework vereint die verschiedenen Bereiche einer Präsentation wie Benutzerschnittstelle, Zeichnen, Grafiken, Audio, Video, Dokumente und Typographie.

WPF wird laut Microsoft mit Windows 7, Windows Vista und Windows Server 2008 ausgeliefert und ist erhältlich für Windows XP SP2 oder höher und Windows Server 2003. Zur Ausführung wird Microsoft .Net 3.5 benötigt.

Noch in diesem Kapitel

WPF in der Prozessvisualisierung

Wertübertragung von zenon an WPF

Referenzierte Objekte

Zuordnung zenon Objekt zu WPF Content

Workflows


WPF in der Prozessvisualisierung

Handbuch -> Controls -> WPF-Element -> Grundlagen -> WPF in der Prozessvisualisierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für zenon eröffnet XAML individuelle grafische Gestaltungsmöglichkeiten. Anzeigenelemente und Dynamische Elemente können unabhängig von der Projektierung grafisch angepasst werden. Zum Beispiel werden aufwändige Illustrationen erst von Designern erstellt und dann als XAML-Datei in zenon importiert und mit den gewünschten Logiken verknüpft. Dafür bieten sich viele Anwendungsmöglichkeiten an, zum Beispiel:

Dynamische Elemente im Analog-Look

Grafiken müssen nicht mehr in zenon gezeichnet werden, sondern können direkt als XAML-Datei importiert werden. Das erlaubt den Einsatz von komplexen, aufwändig illustrierte Elementen in der Prozessvisualisierung. Spiegelungen, Schatten, 3D-Effekte etc. werden zum Beispiel als Grafik unterstützt. Die an die jeweilige Industrie-Umgebung angepassten Elemente ermöglichen intuitives Bedienen, analog den Bedienelementen an der Maschine.

Aufwändige Illustrationen für intuitives Bedienen

Die Einbindung von XAML basierenden Anzeigeelementen wertet Projekte grafisch auf und ermöglicht sehr einfach die übersichtlichere Prozessdarstellung. Auf Usability optimierte Elemente vereinfachen die Bedienung. Die übersichtliche Darstellung von Daten erleichtert die Rezeption von komplexen Inhalten. Die flexible Anpassungsmöglichkeit der einzelnen Elemente erhöht den Bedienkomfort. So ist es dem Projektanten möglich, eigenständig Anzeigenwerte, Skalen und Einheiten zu bestimmen.

Übersichtliche Datenpräsentation und Zusammenfassungen

Gruppierte Anzeigenelemente ermöglichen die übersichtliche Darstellung der wichtigsten Prozessdaten, so dass der Anlagenbediener stets über aktuelle Prozessabläufe informiert ist. Grafische Auswertungen, Anzeigenwerte und Regler können in einem Element gruppiert werden und ermöglichen eine schnelle und unkomplizierte Steuerung.

Industriespezifische Darstellungen

Elemente wie Thermometer, Skalen oder Bargrafen zählen zu den Basis-Elementen der Prozessvisualisierung. Durch XAML ist es möglich, diese grafisch an die jeweilige Industrie anzupassen. So finden Anlagenbediener die etablierten und gewohnten Elemente, die sie bereits von den Maschinen kennen, in der Prozessvisualisierung am Terminal wieder.

Anpassung an das Corporate Design

Illustrationen können an die jeweiligen Stilvorgaben des Unternehmens angepasst werden, um ein durchgängiges Erscheinungsbild bis hin zum einzelnen Prozessbild zu erreichen. Als Vorlage können dazu zum Beispiel die Standard-Bedienelemente von zenon verwendet werden, die dann an Farbwelten, Hausschriften und Illustrationsstile des Corporate Designs angepasst werden.


Wertübertragung von zenon an WPF

Handbuch -> Controls -> WPF-Element -> Grundlagen -> Wertübertragung von zenon an WPF

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon arbeitet intern immer mit dem Datentyp Double oder String. Diese werden an das WPF-Element geschickt. Das WPF Element ist in einen .NET Container eingebettet. Damit der Datentyp verwendet werden kann, muss er meistens konvertiert werden. Diese Konvertierung wird von .NET automatisch durchgeführt.

Die Wertabsetzung erfolgt nach folgenden Regeln:

  • Ist der .NET-Typ (System.Object) für zenon nicht ersichtlich, wird der Wert so wie er ist an .NET geschickt. .NET muss sich selbst um die Darstellung bzw. Konvertierung kümmern.
  • Ist der .NET-Typ vom Typ Boolean (System.Boolean), dann schreibt zenon entsprechend der .NET-Konvention 0 bzw. -1.
  • Ist der .NET-Typ bekannt, wird geprüft, ob .NET den Wert konvertieren kann. Dazu wird der Konverter von .NET verwendet.
    • Ja: Der Wert wird geschickt.
    • Nein: Der Wert wird trotzdem geschickt. Reagiert .NET mit einer Fehlermeldung, wird der Wert von zenon in einen String umgewandelt und erneut geschickt.


Referenzierte Objekte

Handbuch -> Controls -> WPF-Element -> Grundlagen -> Referenzierte Objekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In WPF können nicht nur Standardobjekte wie Rechtecke, Buttons, Textfelder, etc. verwendet werden, sondern auch WPF User Controls, die als Assemblys referenziert werden.

WPF User Controls sind individuell erstellte Objekte. Zum Beispiel kann dieses Element wie ein Tacho aussehen und spezielle Eigenschaften und optische Effekte anbieten, etwa eine Eigenschaft „Value", die beim Setzen dazu führt, dass der Zeiger des Tachos sich bewegt und den Wert anzeigt.

Der Workflow dazu:

  • Das Aussehen eines User Controls wird mit Standard-Objekten gezeichnet, die von WPF angeboten werden.
  • Die Eigenschaften und Interaktionen werden programmiert.
  • Das Gesamtpaket wird kompiliert und liegt als .Net Assembly vor.

Diese Assembly kann für WPF-Projekte verwendete werden. Dafür muss es im WPF-Editor (z.B: Microsoft Expression Blend) referenziert (verknüpft) werden. Wählen Sie dazu im zenon Datei-Auswahldialog die Assembly aus:

Ab diesem Zeitpunkt können die WPF User Controls der Assembly in der Toolbox unter Custom UserControls ausgewählt und im WPF-Projekt verwendet werden.

Referenzierte Assemblys in zenon verwenden

Um eine Assembly in zenon zu verwenden, muss dieses als Datei zur Verfügung gestellt werden.
Sammeldateien vom Format .cdwpf verwalten diese eigenständig, es sind keine weiteren Konfigurationen nötig. Für Dateien vom Format .xaml müssen Assemblies zum Ordner Dateien hinzugefügt werden:

  • klicken Sie im Projektbaum auf Dateien
  • wählen Sie Sonstige
  • wählen Sie im Kontextmenü Datei hinzufügen...
  • der Dateiauswahldialog öffnet sich
  • fügen Sie die gewünschte Assembly ein

Beim Anzeigen einer WPF-Datei im WPF-Element (Editor und Runtime) werden die Assemblys aus diesem Ordner geladen. Damit ist auch sicher gestellt, dass beim Übertragen der Runtime-Dateien mittels Remote Transport alle referenzierten Assemblys auf dem Zielrechner vorhanden sind.

Eine Sammeldatei (.cdwpf) und eine gleichnamige XAML-Datei können parallel existieren. Alle Assemblies (*.dll) aus allen Sammeldateien und dem Ordner Sonstige werden in einen Arbeitsordner kopiert. Bei mehreren gleichnamigen Assemblies wird nur das mit der höchsten Dateiversion verwendet.

attention Achtung

Assemblies werden nach dem Laden erst beim Beenden der Applikation wieder entladen. Das bedeutet:

Wenn eine WPF-Datei mit einer referenzierten Assembly in zenon dargestellt wird, dann wird diese Assembly geladen und befindet sich bis zum beenden von zenon im Speicher, selbst wenn das Bild wieder geschlossen wurde. Möchten Sie eine Assembly aus dem Ordner Dateien/Sonstige entfernen, muss zuvor der Editor neu gestartet werden, damit die Assembly entladen wird.


Zuordnung zenon Objekt zu WPF Content

Handbuch -> Controls -> WPF-Element -> Grundlagen -> Zuordnung zenon Objekt zu WPF Content

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zuordung von zenon Objekten zu WPF Content erfolgt über den Namen des WPF-Objekts. Dabei ist zu beachten:

Visuelle Objekte besitzen keine Eigenschaft RuntimeNamePropertyAttribute. Daher steht in dem Moment, in dem der WPF Content geladen und erzeugt wird die Zusatzinformation Name nicht zur Verfügung.

Damit ist eine eindeutige Zuordnung von zenon Objekten auf WPF Objekte nicht mehr möglich. Daher werden im Konfigurationsdialog von zenon nur logische Objekte auflistet. Welche WPF Objekte über die Eigenschaft RuntimeNamePropertyAttribute verfügen, ist in der MSDN oder auf der Microsoft Website ersichtlich.

Workaround

Um visuelle Objekte dennoch zu dynamisieren, ist folgender Workaround möglich:

Beim visuellen Element wird dynamisierbare Eigenschaft über Databindung mit dem Text-Property einer unsichtbaren Textbox verknüpft.

Da die Textbox als logisches Objekt die Eigenschaft Name unterstützt, wird diese in zenon angezeigt.

Das Textbox-Property kann also mit zenon dynamisiert werden.

Dadurch wird indirekt auch das visuelle Objekt dynamisiert.


Workflows

Handbuch -> Controls -> WPF-Element -> Grundlagen -> Workflows

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die WPF/XAML-Technologie ermöglicht neue Workflows in der Prozessvisualisierung. Die Trennung von Design und Funktionalität sorgt für klare Aufgabenteilung zwischen Projekteur und Designer; Designvorgaben lassen sich durch die Verwendung bereits existierender Designs, die vom Projekteur nicht mehr modifiziert werden müssen, leicht erfüllen.

Am Workflow zur Erstellung von WPF-Elementen in zenon sind folgende Personen beteiligt:

  • Designer
    • illustriert Elemente
    • sorgt für grafische Aufbereitung für MS Expression Design
  • MS Expression Blend Operator
    • animiert Elemente
    • legt Variablen für die Animation der WPF-Elemente in zenon an, auf die der Projekteur zugreifen kann
  • Projekteur
    • bindet Elemente in zenon ein
    • hinterlegt Logik und Funktionalität

Wir unterscheiden:

  • Workflow mit Microsoft Expression Blend
  • Workflow mit Adobe Illustrator

Noch in diesem Kapitel

Workflow mit Microsoft Expression Blend

Workflow mit Adobe Illustrator


Workflow mit Microsoft Expression Blend

Handbuch -> Controls -> WPF-Element -> Grundlagen -> Workflows -> Workflow mit Microsoft Expression Blend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Verwendung von Microsoft Expression Blend erfolgt die Erstellung eines WPF-Elements in vier Schritten:

  1. Illustration des Elements in MS Expression Blend
  2. Element in MS Expression Design öffnen und als WPF exportieren
  3. Animation in MS Expression Blend
  4. Integration in zenon

Ein Beispiel für die Erstellung eines WPF-Elements mit Microsoft Expression Blend finden Sie im Kapitel Button als XAML-Datei mit Microsoft Expression Blend erstellen.


Workflow mit Adobe Illustrator

Handbuch -> Controls -> WPF-Element -> Grundlagen -> Workflows -> Workflow mit Adobe Illustrator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aufbauend auf traditionelle Gestaltungsabläufe mit Adobe Illustrator bietet sich folgender Workflow an:

  1. Illustration der Elemente in Adobe Illustrator
  2. Import der .ai Dateien und Aufbereitung in MS Expression Design
  3. WPF-Export aus MS Expression Design
  4. Animation in MS Expression Blend
  5. Integration in zenon

Ein Beispiel zur Erstellung finden Sie im Kapitel Workflow mit Adobe Illustrator.


Leitfaden für Designer

Handbuch -> Controls -> WPF-Element -> Leitfaden für Designer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Abschnitt informiert über die korrekte Erstellung von WPF Dateien im Microsoft Expression Blend und Adobe Illustrator. Die Tutorials zur Erstellung eines Button-Elements und eines Bargraf-Elements zeigen, wie in wenigen Schritten aus bereits existierenden Grafiken voll funktionsfähige WPF-Dateien für zenon erzeugt werden.

Folgende Werkzeuge werden dafür benützt:

  • Adobe Illustrator CS3 (AI)
  • Microsoft Expression Design 4 (ED)
  • Microsoft Expression Blend 4 (EB)
  • zenon 6.51

info Info

Sollen referenzierte Objekte (Assemblys) in WPF verwendet werden, beachten Sie die Hinweise im Kapitel Referenzierte Objekte.

Noch in diesem Kapitel

Workflow mit Microsoft Expression Blend

Workflow mit Adobe Illustrator


Workflow mit Microsoft Expression Blend

Handbuch -> Controls -> WPF-Element -> Leitfaden für Designer -> Workflow mit Microsoft Expression Blend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Microsoft Expression Blend wird ein WPF-Element:

  • illustriert
  • über MS Expression Design in das WPF-Format umgewandelt
  • animiert

Das folgende Beispiel zeigt die Illustration und Umwandlung eines Button-Elements in eine XAML-Datei.

Hinweis: Eine Test-Version von „Microsoft Expression Blend" steht auf der Microsoft Web-Seite zum Download zur Verfügung.

Noch in diesem Kapitel

Button als XAML-Datei mit Microsoft Expression Blend erstellen


Button als XAML-Datei mit Microsoft Expression Blend erstellen

Handbuch -> Controls -> WPF-Element -> Leitfaden für Designer -> Workflow mit Microsoft Expression Blend -> Button als XAML-Datei mit Microsoft Expression Blend erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Button erstellen

  1. Starten Sie Expression Blend
  2. wählen Sie die Option New Projekt

  3. wählen Sie als Projekttyp WPF
  4. vergeben Sie einen beliebigen Pfad und Namen (z.B. MyBlendProject)

    Die Einstellungen Language und Version können ignoriert werden, da keine Funktionalität programmiert werden soll.

  5. Nachdem der Dialog mit OK bestätigt wurde, erzeugt Microsoft Blend ein neues Projekt mit den gewählte Einstellungen. Expression Blend fügt eine leere XAML-Datei ein, die bereits eine Klassen-Referenz beinhaltet.
  6. Löschen Sie, die an die XAML-Datei dazugehörende, CS-Datei über das Kontextmenü.
  7. Benennen Sie die XAML-Datei MainControl.xaml auf MyButton.xaml um.
  8. Die Development-Größe der Datei wird standardmäßig auf 640 mal 480 Pixel gestellt und muss noch geändert werden:
    1. wechseln Sie in die Ansicht XAML
    2. korrigieren Sie die Größe auf 100 mal 100 Pixel
    3. löschen Sie die Klassenreferenz x:Class="MyBlendProject.MyButton"

  9. wechseln Sie in die Ansicht Design

  10. fügen Sie über die Symbolleiste einen Button ein
  11. definieren Sie die Eigenschaften
    • Width: 50
    • Height: 50
    • Margins: 25

    Damit befindet sich der Button jetzt in der Mitte des Controls.

  12. Speichern Sie die Änderungen und öffnen Sie die Datei zur Kontrolle im Internet Explorer. Sie sehen, dass der Button in der Größe von 50 x 50 Pixel dargestellt wird.

Button skalierbar machen

Wenn Sie diese Datei in diesem Zustand in zenon einbinden, wird der Button dort immer exakt die Größe von 50 x 50 Pixel haben. Da der Button skalierbar eingesetzt werden soll, wechseln Sie wieder zu Expression Blend:

  1. selektieren Sie den Button in der Baumansicht
  2. wählen Sie im Kontextmenü des Buttons Group Into->Viewbox
  3. der Button wird in einer Viewbox eingefügt
  4. definieren Sie die Eigenschaften der Viewbox
    • Width: Auto
    • Height: Auto
  5. speichern Sie die Datei

  6. Wenn Sie die Datei jetzt im Internet Explorer öffnen, wird der Button bei Größenänderungen des IE-Fensters automatisch skaliert. Diese Datei würde sich jetzt auch in zenon automatisch an Größenänderungen des WPF-Elements anpassen.

Namen ändern

Bevor Sie die Datei in zenon einbinden können, müssen Sie dem WPF-Element einen Name geben. Standardmäßig sind WPF-Elemente in Expression Blend nicht benannt, und werden mit eckige Klammer und dessen Typ gekennzeichnet. Die Zuordnung von zenon-Content auf WPF-Content geschieht über den Namen der WPF-Elemente:

  • ändern Sie in der Baumansicht den Namen
    • des Buttons auf MyButton
    • der ViewBox auf MyViewBox

Dieser Button kann jetzt als XAML-Datei in zenon eingebunden werden.


Workflow mit Adobe Illustrator

Handbuch -> Controls -> WPF-Element -> Leitfaden für Designer -> Workflow mit Adobe Illustrator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Einsatz von Adobe Illustrator wird ein WPF-Element:

  • in Adobe Illustrator illustriert
  • in MS Expression Design in ein WPF umgewandelt
  • in MS Expression Blend animiert

Das folgende Beispiel zeigt die Illustration und Umwandlung eines Bargraf-Elements in eine XAML-Datei.

Noch in diesem Kapitel

Illustration Bargraf

WPF-Export

Animation in Blend


Illustration Bargraf

Handbuch -> Controls -> WPF-Element -> Leitfaden für Designer -> Workflow mit Adobe Illustrator -> Illustration Bargraf

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Bargraf wird in Adobe Illustrator erstellt.

  1. AI: Ausgangselement Bargraf

    Illustriert in Adobe Illustrator CS3.

  2. AI: Pfadansicht Bargraf in Adobe Illustrator

    • alle Effekte müssen umgewandelt sein (Objekt -> Aussehen umwandeln)
    • alle Linien werden in Pfade umgewandelt (Objekt -> Pfad -> Konturlinie)
    • keine Filter wie Schlagschatten, Weichzeichner etc. verwenden

Hinweise zur Kompatibiltät

Illustrationen , die mit Adobe Illustrator erstellt werden, eignen sich grundsätzlich für den WPF-Export. Allerdings können nicht alle Illustrator-Effekte in Expression Design/Blend entsprechend werden. Beachten Sie:

Effekt

Beschreibung

Schnittmasken

In Adobe Illustrator erzeugte Schnittmasken werden von Expression Design nicht korrekt interpretiert. Meist werden sie in Blend als schwarze Farbflächen dargestellt.

Wir empfehlen, die Illustrationen ohne Schnittmasken anzulegen.

Filter und Effekte

Nicht jeder Adobe Illustrator Filter wird in Expression Design entsprechend übernommen: So funktionieren z.B. Weichzeichnungsfilter, Schlagschatten sowie Eckeneffekte aus Illustrator in Expression Design nicht.

Lösung:

  • Über den Befehl Objekt -> Aussehen Umwandeln in Adobe Illustrator lassen sich die meisten Effekte so umwandeln, dass sie von Expression Design korrekt gelesen werden können.
  • Eckeneffekte aus Adobe Illustrator werden von MS Design korrekt interpretiert, wenn sie in AI in Pfade umgewandelt werden.

Textfelder

Um Textfelder mit Code verknüpfen zu können, müssen diese in Expression Blend gesondert angelegt werden. „Labels" werden für dynamische Texte benötigt, für statische Informationen genügen einfache „Textfelder".

Die Möglichkeit, Textlabels zu erstellen, wird in MS Design nicht angeboten. Diese müssen direkt in MS Blend erstellt werden.

Transparenzen und Gruppentransparenzen

Zu Schwierigkeiten kann es bei der korrekten Interpretation von Transparenz-Einstellungen, insbesondere von Gruppentransparenz-Einstellungen, in Adobe Illustrator kommen.

MS Expression Blend sowie MS Expression Design bieten aber die Möglichkeit, Transparenz-Einstellungen neu anzulegen.

Ebenen multiplizieren

Diese Ebenen-Einstellungen in Adobe Illustrator werden von MS Expression Blend nicht immer richtig dargestellt.

Es gibt aber die Möglichkeit, „Ebene multiplizieren" direkt in Expression Design einzustellen.

Zeigerinstrumente und Standardpositionen

Um die Grafiken optimal für die Animation vorzubereiten, müssen Zeiger und Regler immer auf der Ausgangsposition, meist 0 oder 12:00 Uhr stehen.

So werden die Positions-Parameter für Rotationen etc. gleich richtig in Blend angegeben und eine Animation kann ohne Umrechnung von Positionsangaben erfolgen.


WPF-Export

Handbuch -> Controls -> WPF-Element -> Leitfaden für Designer -> Workflow mit Adobe Illustrator -> WPF-Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Animation in Microsoft Expression Blend werden WPF-Dateien benötigt. Wir empfehlen Microsoft Expression Design für diesen Export, da es gute Ergebnisse liefert und die meisten Illustrator Effekte korrekt interpretiert werden.

Hinweis: Im Internet wird ein gratis Plug-in für den direkten Export von WPF-Dateien aus Adobe Illustrator angeboten. Dieses Plug-in bietet einen schnellen, unkomplizierten Export aus Illustrator, ist für die aktuelle Anwendung jedoch weniger gut geeignet, da es zu grafischen Verlusten kommt. Auch Farbabweichungen vom ursprünglichen Dokument sind möglich.

Dateien im Format .ai können regulär in Expression Design importiert werden, die Pfade bleiben dabei erhalten.
Achtung: Einige geläufige Illustrator Effekte können jedoch von Expression Design nicht richtig dargestellt werden (siehe Kapitel Illustration).

In 5 Schritten exportieren wir das bereits erstellte Bargraf-Element:

  1. ED: Import
    • importieren Sie die aufbereitete Illustrator-Datei in Microsoft Expression Design über Datei -> Importieren
  2. ED: Optimierung

    • wird die Ausgangsdatei in MS Expression Design nicht richtig angezeigt, kann sie hier noch nachbearbeitet und optimiert werden
  3. ED: Auswahl

    • markieren Sie mit dem Direktauswahl-Pfeil in MS Expression Design das Element für den WPF-Export, in diesem Fall die gesamte Uhr
  4. ED: Export starten

    • starten Sie den Export über Datei -> Exportieren
    • der Dialog zur Konfiguration der Exporteinstellungen öffnet sich
  5. ED: Exporteinstellungen

    • Nehmen Sie folgende Exporteinstellungen vor:
    1. Format: XAML Silverlight 4 / WPF Canvas

      Objekte immer benennen: Mit Häkchen aktivieren

      Platzieren Sie gruppierte Objekte in einem XAML Layoutcontainer: Mit Häkchen aktivieren

    2. Text: Bearbeitbarer Textblock
    3. Linieneffekte: Alle rastern

Die exportierte Datei hat die Dateiendung .xaml. Sie wird im nächsten Schritt in MS Expression Blend aufbereitet und animiert.


Animation in Blend

Handbuch -> Controls -> WPF-Element -> Leitfaden für Designer -> Workflow mit Adobe Illustrator -> Animation in Blend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit MS Expression Blend werden:

  • die statischen XAML-Dateien aus MS Expression Design animiert
  • Variablen für die Steuerung der Effekte, die von zenon angesprochen werden können, angelegt

In 13 Schritten gelangen wir vom statischen XAML zum animierten Element, das in zenon eingebunden werden kann:

  1. EB:Projekt erstellen

    1. öffnen Sie Microsoft Expression Blend
    2. erstellen Sie ein neues Projekt
    3. wählen Sie als Projekttyp WPF -> WPF Control Library aus
    4. vergeben Sie einen Namen (in unserem Tutorial: Mein_Projekt)
    5. wählen Sie einen Speicherort
    6. wählen Sie eine Sprache (in unserem Tutorial: C#)
    7. wählen Sie die Framework Version 3.5
  2. EB: MainControl.xaml.cs löschen

    1. navigieren Sie zu MainControl.xaml.cs
    2. löschen Sie diese Datei über den Befehl Löschen im Kontextmenü
  3. EB: exportierte XAML-Datei öffnen

    1. öffnen Sie das Kontextmenü für Mein_Projekt (rechte Maustaste)
    2. wählen Sie Vorhandenes Element hinzufügen… aus
    3. wählen Sie die aus Microsoft Expression Design exportierte XAML-Datei, um diese in Microsoft Expression Blend zu öffnen
  4. EB: MainControl.xaml öffnen

    1. öffnen Sie die automatisch erstellte MainControl.xaml
    2. navigieren Sie im Bereich Objekte und Zeitachsen zum Eintrag UserControl
  5. EB: XAML-Code anpassen

    1. klicken Sie mit der rechten Maustaste auf UserControl
    2. wählen Sie im Kontextmenü XAML anzeigen
    3. löschen Sie m XAML-Code die Zeilen 7 und 9:

      x:Class="Mein_Projekt.MainControl"

      d:DesignWidth="640" d:DesignHeight="480"

  6. EB: XAML-Code überprüfen

    • Nun sollte der XAML Code so aussehen:

    <UserControl

    xmlns=http://schemas.microsoft.com/winfx/2006/xaml/presentation
    xmlns:x=http://schemas.microsoft.com/winfx/2006/xaml
    xmlns:d=http://schemas.microsoft.com/expression/blend/2008
    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"

    mc:Ignorable="d"
    x:Name="UserControl">

    <Grid x:Name="LayoutRoot"/>

    </UserControl>

  7. EB: Elemente kopieren

    1. öffnen Sie die von Expression Design importiertes XAML-Datei
    2. markieren Sie alle Elemente
    3. wählen Sie im Kontextmenü Kopieren
    4. wechseln Sie zurück zur automatisch erstellten XAML-Datei
  8. EB: Elemente einfügen

    1. klicken Sie mit der rechten Maustaste auf Layout Root
    2. wählen Sie Einfügen
  9. EB: Layouttyp anpassen

    1. klicken Sie mit der rechten Maustaste auf LayoutRoot -> Layouttyp ändern -> Viewbox
    2. nun sollte die Struktur so aussehen: UserControl -> LayoutRoot -> Grid -> Elemente
    3. vergeben sie einen Namen für LayoutRoot und Grid durch Doppelklick auf den Namen
  10. EB: Texte und Werte

    • dynamische und statische Texte werden mit Textfeldern gezeichnet
    • Werte (Zahlen) werden mit Labels ausgegeben
  11. EB: Labels einfügen

    • Labels ersetzen Zahlen, die später mittels Int-Variablen verknüpft werden sollen (muss für alle Zahlen-Elementen durchgeführt werden)
  12. EB: Eigenschaft setzen

    • um 100% anzuzeigen, setzen Sie die Eigenschaft MaxHeight des Bargrafanzeige-Elements auf 341 (die maximale Höhe des Indikator-Elements entspricht 340)
  13. EB: für Verwendung in zenon vorbereiten

    1. löschen Sie alle Namensbezeichnungen (Namen dürfen nur für Elemente vergeben werden, die über zenon angesprochen werden sollen)
    2. speichern Sie die XAML-Datei mit einem beliebigen Namen ab
    3. binden Sie die XAML-Datei in zenon ein

Tipp zur Kontrolle: Wenn die XAML-Datei im Microsoft Internet Explorer einwandfrei dargestellt wird und sich auch der Fenstergröße des Internet Explorers anpasst, wird sie auch in zenon korrekt verwendet.


Engineering in zenon

Handbuch -> Controls -> WPF-Element -> Engineering in zenon

Um WPF mit zenon nutzen zu können, muss sowohl auf dem Editor-Rechner als auch auf der Runtime Microsoft Framework 3.5 installiert sein.

Bedingungen für WPF-Darstellung in zenon

Die Dynamisierung steht zur Zeit für einfache Variablen zur Verfügung, Arrays und Strukturen können nicht dynamisiert werden. Daher sind folgende WPF-Funktionen in zenon einsetzbar:

  • Element-Eigenschaften, die einfachen Datentypen entsprechen wie String, Int, Bool usw.
  • Element-Eigenschaften vom Typ „Object", die mit einfachen Datentypen gesetzt werden können
  • Element-Ereignisse können mit Funktionen verwendet werden; die Parameter der Ereignisse sind aber in zenon nicht verfügbar und nicht auswertbar
  • Elementtransformation, für die ein RenderTransform beim Element in der XAML-Datei vorhanden ist

    Achtung: Befindet sich bei Transformationen der Content außerhalb des Bereichs des WPF-Elements, geht dieser Teil des Contents verloren, bzw. wird nicht gezeichnet

attention Achtung

Wenn Runtime Dateien für ein Projekt für eine Version vor 6.50 erzeugt werden, dann werden vorhandene WPF-Elemente nicht in die Runtime-Bilder eingebunden.

WPF-Element anlegen

Um ein WPF-Element anzulegen:

  1. wählen Sie in der Symbolleiste der Elemente das Symbol für WPF-Element oder den entsprechenden Eintrag im Menü Elemente
  2. wählen Sie im Hauptfenster den Startpunkt
  3. ziehen Sie das Element mit der Maus auf
  4. wählen Sie in den Eigenschaften in der Gruppe Darstellung die Eigenschaft XAML-Datei

    Interne ID: Engineering in zenon

    XAML-Datei

    Auswahl der XAML-Datei für das WPF-Element. Klick auf ... öffnet Dialog zur Auswahl. Die Datei muss bereits im Projektmanager unter Dateien/Grafiken angelegt worden sein oder im Dialog über das Symbol Datei hinzufügen ausgewählt werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Engineering in zenon

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. der Datei-Auswahldialog öffnet sich
  6. wählen Sie die gewünschte Datei aus
    gültige sind Dateien vom Format
    • *.xaml: Extensible Application Markup Language
    • *.cdwpf: WPF Sammeldatei, zeigt auch Vorschaubild

    (Die Datei muss bereits im Projektmanager unter Dateien/Grafiken vorhanden sein oder im Dialog neu angelegt werden.)

  7. konfigurieren Sie die Verknüpfung

info Info

Sollen referenzierte Objekte (Assemblys) in WPF verwendet werden, beachten Sie die Hinweise im Kapitel Referenzierte Objekte.

CDWPF-Dateien (Sammeldateien)

Regeln für die Verwendung von Sammeldateien:

  • Die Dateien können direkt in der ZIP-Datei liegen oder in einem gemeinsamen Ordner.
  • Der Name der XAML-Datei sollte dem Namen der Sammeldatei entsprechen.
  • Es darf nur eine XAML-Datei enthalten sein.
  • Die Vorschaugrafik sollte klein und nicht über 64 Pixel hoch sein.
    Name der Vorschaudatei: preview.png oder der Name der XAML Datei mit der Endung png.
  • Es können beliebig viele Assemblies verwendet wqerden. Die Unterscheidung erfolgt auf Basis der Dateiversion in numerischer Form.
  • Sammeldateien müssen keine Assembly enthalten.
  • Es werden alle Ordner durchsucht und nur Dateien berücksichtigt vom Typ *.dll, *.xaml oder *.png.

Darstellung unter Windows Vista und Windows 7

Enthält ein Bild vom Typ WPF einen Schieberegler und werden gleichzeitig die Aero-Effekte von Windows Vista oder Windows 7 verwendet, kann es im zenon Editor zu Refresh-Problemen kommen.

Noch in diesem Kapitel

Konfiguration der Verknüpfung

Gültigkeit von XAML-Dateien

Vorgefertigte Elemente

Beispiele: Integration von WPF in zenon

Fehlerbehandlung


Konfiguration der Verknüpfung

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Konfiguration der Verknüpfung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein WPF-Element zu konfigurieren

  1. wählen Sie in den Eigenschaften in der Gruppe Darstellung die Eigenschaft Konfiguration

    Interne ID: Konfiguration der Verknüpfung

    Konfiguration

    Öffnet den Dialog zur Konfiguration der XAML-Datei. Eigenschaften, Ereignisse, Transformationen und Bedienberechtigungen können zugewiesen werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. der Dialog mit drei Registerkarten öffnet sich mit einer Vorschau der XAML-Datei sowie der in der Datei vorhandenen Elemente

Parameter

Beschreibung

Vorhandene Elemente

Zeigt in einer Baumstruktur die benannten Elemente der Datei an. Das gewählte Element kann mit Prozessdaten verknüpft werden.

Die Zuordnung von WPF zur Prozessdaten basiert auf den Elementname. Daher werden Elemente nur angezeigt, wenn sie und die dazugehörigen übergeordneten Elemente einen Namen besitzen. Zuordnungen werden in den Registerkarten Eigenschaften, Ereignisse und Transformationen konfiguriert und angezeigt.

Vorschau

Das ausgewählte Element wird in der Vorschau blinkend dargestellt.

Eigenschaften

Konfiguration und Darstellung der Eigenschaften (Variablen, Bedienberechtigungen, Verriegelungen, verknüpfte Werte).

Ereignisse

Konfiguration und Darstellung der Ereignisse (Funktionen).

Transformationen

Konfiguration und Darstellung der Transformationen.

Name

Name der Eigenschaft.

Verknüpfung

Auswahl der Verknüpfung.

Verknüpfungsart

Art der Verknüpfung (Variable, Berechtigung, Funktion)

WPF-Info

Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).

Verknüpft

Zeigt an, ob eine Eigenschaft aktuell verwendet wird.

Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

info Info

Im Konfigurationsdialog können nur logische Objekt angezeigt werden. Visuelle Objekte werden nicht angezeigt. Hintergründe und wie visuelle Objekte dennoch dynamisiert werden können lesen Sie im Abschnitt Zuordnung zenon Objekt zu WPF Content.

Noch in diesem Kapitel

Eigenschaften

Ereignisse

Transformation


Eigenschaften

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Konfiguration der Verknüpfung -> Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Eigenschaften ermöglichen das Verknüpfen von:

  • Variablen
  • Werten
  • Bedienberechtigungen und Verriegelungen

Parameter |  | Beschreibung
Name | Name der Eigenschaft.
Verknüpfung | Verknüpfte Variable, Bedienberechtigung oder verknüpfter Wert. Klick in die Spalte öffnet den jeweiligen Auswahldialog, abhängig vom Eintrag in der Spalte Verknüpfungsart.
Verknüpfungsart | Auswahl einer Verknüpfung.
WPF-Info | Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).
Verknüpft | Zeigt an, ob eine Eigenschaft aktuell verwendet wird. Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

Verknüpfung erstellen

Um eine Verknüpfung zu erstellen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste die gewünschte Verknüpfung.

    Zur Verfügung stehen:

    • <nicht verknüpft> (löst eine bestehende Verknüpfung)
    • Bedienberechtigung/Verriegelung
    • Variable
    • Wertverknüpfung
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der gewünschten Verknüpfung öffnet sich

info Info

Eigenschaften von WPF und zenon können sich unterscheiden. Wird zum Beispiel die Eigenschaft Sichtbarkeit verknüpft, stehen in .NET drei Werte zur Verfügung:

0 - sichtbar

1 - unsichtbar

2- eingeklappt

Diese Werte müssen über die verknüpfte zenon Variable abgebildet werden.

Noch in diesem Kapitel

Variable verknüpfen

Werte verknüpfen

Bedienberechtigung oder Verriegelung verknüpfen


Bedienberechtigung oder Verriegelung verknüpfen

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Konfiguration der Verknüpfung -> Eigenschaften -> Bedienberechtigung oder Verriegelung verknüpfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bedienberechtigung oder Verriegelung verknüpfen

Bedienberechtigungen können nicht für das gesamte WPF-Element vergeben werden. Dem Element wird eine Benutzerebene zugewiesen. Berechtigungen werden innerhalb der Benutzerebene für einzelne Controls erteilt. Ist eine Berechtigung aktiv, wird der Wert 1 auf die Eigenschaft im Element geschrieben.

Um eine Bedienberechtigung oder Verriegelung mit einer WPF-Eigenschaften zu verknüpfen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Bedienberechtigung/Verriegelung
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Berechtigungen öffnet sich

Parameter | Beschreibung
Berechtigung/Verriegelung verknüpfen | Festlegung der Berechtigungen.
Verknüpfter Zustand | Auswahl der Berechtigung, die mit einem WPF-Control verknüpft wird, aus der Dropdownliste. Zum Beispiel kann Sichtbarkeit und Bedienbarkeit eines WPF-Buttons vom Status des Benutzers abhängen.

Berechtigung | Beschreibung
Bedienberechtigung vorhanden | Besitzt der Benutzer genügend Rechte, um das WPF-Element zu bedienen, wird der Wert 1 auf die Eigenschaft geschrieben.
Bedienberechtigung nicht vorhanden | Besitzt der Benutzer nicht genügend Rechte, um das WPF-Element zu bedienen, wird der Wert 1 auf die Eigenschaft geschrieben.
Nicht verriegelt | Ist das Element nicht durch die Verriegelung gesperrt, wird der Wert 1 auf die Eigenschaft geschrieben.
Verriegelt | Ist das Element durch die Verriegelung gesperrt, wird der Wert 1 auf die Eigenschaft geschrieben.
Bedienbar | Wenn die Bedienberechtigung vorhanden ist und das Element nicht verriegelt ist, dann wird der Wert 1 auf die Eigenschaft geschrieben.
Nicht bedienbar | Fehlt die Bedienberechtigung oder ist das Element verriegelt, dann wird der Wert 1 auf die Eigenschaft geschrieben.


Ereignisse

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Konfiguration der Verknüpfung -> Ereignisse

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ereignisse ermöglichen das Verknüpfen von zenon Funktionen mit einem WPF-Element.

Parameter |  | Beschreibung
Name | Name der Eigenschaft.
Verknüpfung | Verknüpfte Funktion. Klick in die Zelle öffnet den Konfigurationsdialog.
Verknüpfungsart | Auswahl einer Verknüpfung. Klick in die Zelle öffnet den Auswahldialog.
WPF-Info | Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).
Verknüpft | Zeigt an, ob eine Eigenschaft aktuell verwendet wird. Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

Funktionen verknüpfen

Um eine Verknüpfung zu erstellen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Funktion
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Funktion öffnet sich

Parameter |  | Beschreibung
Verknüpfte Funktion | Auswahl der zu verknüpfenden Funktion. Klick auf Schaltfläche ... öffnet den Dialog zur Funktionsauswahl.
OK | Übernimmt Auswahl und schließt Dialog.
Abbrechen | Verwirft Änderungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Transformation

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Konfiguration der Verknüpfung -> Transformation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das WPF-Element unterstützt keine Dreh-Funktionalität. Befindet sich zum Beispiel das WPF-Element in einem Symbol und das Symbol wird gedreht, so dreht das WPF-Element nicht mit. Daher gibt es für WPF mit Transformation einen eigenen Mechanismus, um Elementen zu drehen oder anderweitig zu transformieren. Diese Transformationen werden in der Registerkarte Transformation konfiguriert.

Achtung: Falls sich Content außerhalb des Bereichs des WPF-Elementes befindet, geht dieser Teil des Contents verloren, bzw. wird nicht gezeichnet.

Parameter

Beschreibung

Name

Name der Eigenschaft.

Verknüpfung

Auswahl der verknüpften Variablen.

Transformationen werden in XAML als Transformationsobjekte mit eigenen Eigenschaften dargestellt. Unterstützt ein Element eine Transformation, dann werden die möglichen Eigenschaften der Transformationsobjekte in der Listenansicht dargestellt. (Mehr dazu in: Button als WPF-XAML in zenon einbinden.

Wird zum Beispiel die verknüpfte Variable auf den Wert 10 gesetzt, dann wird dieser Wert auf das WPF-Ziel geschrieben und das Element von WPF um 10° gedreht.

Verknüpfungsart

Auswahl der Verknüpfungsart Transformation.

WPF-Info

Zeigt für Eigenschaften den aktuellen Wert im WPF-Content an. Für den Anwender ist direkt ersichtlich, um welche Art von Eigenschaft es sich handelt (Boolean, String, etc.).

Verknüpft

Zeigt an, ob eine Eigenschaft aktuell verwendet wird.

Per Default nicht in der Ansicht enthalten, kann über Kontextmenü->Spaltenauswahl ausgewählt werden.

Transformation verknüpfen

Um eine Transformation mit einer WPF-Eigenschaften zu verknüpfen:

  1. markieren Sie die Zeile mit der Eigenschaft, die verknüpft werden soll
  2. klicken Sie in die Zelle Verknüpfungsart
  3. wählen Sie aus der Dropdownliste Transformation
  4. klicken Sie in die Zelle Verknüpfung
  5. der Dialog zur Konfiguration der Variablen öffnet sich

Die Konfiguration ermöglicht auch Umrechnung von zenon in WPF-Einheiten.

Parameter

Beschreibung

Verknüpfte Variable

Auswahl der zu verknüpfenden Variablen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl.

Wertbereich des WPF-Elements

Angaben zur Umrechnung der Variablenwerte in WPF-Werte.

Wertbereich umrechnen

Aktiv: WPF-Einheitenumrechnung ist eingeschaltet.

Auswirkung zur Runtime: Der aktuelle zenon Wert (inkl. zenon Einheit) wird mittels normierter Minimum- und Maximum-Wert auf den WPF-Bereich umgerechnet.

Zum Beispiel: Der Wert einer Variablen variiert von 100 bis 200. Bei der Variablen ist der normierte Bereich auf 100 - 200 eingestellt. Ziel ist, diese Wertänderung mittels eines WPF-Drehknopfs darzustellen. Dafür wird:

  • bei Transformation die Eigenschaft RotateTransform.Angle mit der Variablen verknüpft
  • Wert anpassen aktiviert
  • ein WPF-Wertbereich von 0 bis 360 konfiguriert

Jetzt wird der Drehknopf bei einen Wert von z.B. 150 um 180 Grad gedreht sein.

Minimum

Definiert den niedrigsten WPF-Wert.

Maximum

Definiert den höchsten WPF-Wert.

OK

Übernimmt Einstellungen und beendet Dialog.

Abbrechen

Verwirft Einstellungen und beendet Dialog.

Hilfe

Öffnet die Online-Hilfe.


Gültigkeit von XAML-Dateien

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Gültigkeit von XAML-Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Gültigkeit von XAML-Dateien ist an einige Voraussetzungen gebunden:

  • richtiger Namespace
  • keine Class-Referenzen
  • Skalierbarkeit

Richtige Namspace

Das WPF-Element kann ausschließlich nur WPF-Content darstellen, das heißt:

Nur XAML-Dateien mit richtigem WPF-Namespace können vom WPF-Element dargestellt werden. Dateien die einen Silverlight-Namespace verwenden, können nicht geladen oder angezeigt werden. In den meisten Fällen reicht es aber, den Silverlight-Namespace mit dem WPF-Namespace auszutauschen.

WPF-Namespace:

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

Keine Verwendung von Class-Referenzen

Da die XAML-Dateien dynamisch geladen werden, ist es nicht möglich, XAML-Dateien zu verwenden, die Referenzen auf Klassen (Schlüssel „Class" im Header) beinhalten. Funktionalität, die in einer eigenen C#-Datei programmiert wurde, kann nicht verwendet werden.

Skalierbarkeit

Soll der Inhalt eines WPF-Elements an die Größe des WPF-Elements angepasst werden, dann müssen die Controls des WPF-Elements in ein Control verschachtelt werden, das diese Funktionalität bietet, zum Beispiel eine View Box. Zusätzlich muss darauf geachtet werden, das die Elemente Höhe und Breite als automatisch konfiguriert werden.

Überprüfung einer XAML-Datei auf Korrektheit

Um zu überprüfen, ob eine XAML-Datei das richtige Format hat:

  • XAML-Datei im Internet-Explorer öffnen
    • lässt sie sich ohne zusätzliche Plugins (Java oder ähnliche) öffnen, dann kann diese Datei auch mit hoher Sicherheit von zenon geladen bzw. angezeigt werden
    • treten beim Laden der Datei Probleme auf, so werden diese im Internet-Explorer eingeblendet und es ist klar erkennbar, in welcher Zeile es Probleme gibt

Auch die Skalierung kann auf diese Art und Weise getestet werden: Ist die Datei richtig aufgebaut, wird sich der Inhalt an die Größe des Internet Explorer Fensters anpassen.

Fehlermeldung

Wird in zenon eine ungültige Datei verwendet, so wird beim Laden der Datei im WPF-Element eine Fehlermeldung im Ausgabefenster angezeigt.

Zum Beispiel:

„Fehler beim Laden vom xaml-Datei:C:\ProgramData\COPA-DATA\SQL\781b1352-59d0-437e-a173-08563c3142e9\FILES\zenon\custom\media\UserControl1.xaml

Das Attribut "Class" ist im XML-Namespace "http://schemas.microsoft.com/winfx/2006/xaml" nicht vorhanden. Zeile 7 Position 2."


Vorgefertigte Elemente

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Reihe von WPF-Elementen werden bereits mit zenon ausgeliefert oder stehen im Webshop zum Download bereit.

Alle WPF-Elemente haben Eigenschaften, welche die grafische Ausprägung des jeweiligen Elements bestimmen (Dependency Properties). Das Setzen der Werte mittels einer XAML-Datei oder die Verknüpfung der Eigenschaft über zenonkann das Aussehen in der Runtime direkt verändert werden. Die folgenden Tabellen enthalten die jeweiligen Dependency Properties, abhängig vom Control.

Elemente:

  • Rundanzeige
  • Fortschrittsanzeige
  • Bargraf vertikal
  • Temperaturanzeige
  • Analoguhr
  • Universalregler

Noch in diesem Kapitel

Rundanzeige - CircularGaugeControl

Fortschrittsanzeige - ProgressBarControl

Bargraf vertikal - VerticalBargraphControl

Temperaturanzeige - TemperatureIndicatorControl

Analoguhr - AnalogClockControl

Universalregler - UniversalReglerControl


Rundanzeige - CircularGaugeControl

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente -> Rundanzeige - CircularGaugeControl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Property

Funktion

Wert

CurrentValue

Aktueller Wert, der angezeigt werden soll.

Double

IsReversed

Skalenausrichtung, in bzw. gegen Uhrzeigersinn.

Boolean

ElementFontFamily

Elementschriftart.

Font

MinValue

Minimalwert der Skala.

Double

MaxValue

Maximalwert der Skala.

Double

ScaleRadius

Radius der Skala.

Double

ScaleStartAngle

Winkel, bei dem die Skala beginnt.

Double

ScaleLabelRotationMode

Ausrichtung der Skalenbeschriftung.

Enum:

  • None
  • Automatic
  • SurroundIn
  • SurroundOut

ScaleSweepAngle

Winkelbereich, der die Größe der Skala definiert.

Double

ScaleLabelFontSize

Schriftgröße der Skalenbeschriftung.

Double

ScaleLabelColor

Schriftfarbe der Skalenbeschriftung.

Color

ScaleLabelRadius

Radius, an dem die Skalenbeschriftung ausgerichtet ist.

Double

ScaleValuePrecision

Genauigkeit der Skalenbeschriftung.

Integer

PointerStyle

Form des Zeigers, der den Wert anzeigt.

Enum:

  • Arrow
  • Rectangle
  • TriangleCap
  • Pentagon
  • Triangle

MajorTickColor

Farbe der Hauptticks der Skala.

Color

MinorTickColor

Farbe der Nebenticks der Skala.

Color

MajorTickSize

Größe der Hauptticks der Skala.

Size

MinorTickSize

Größe der Nebenticks der Skala.

Size

MajorTicksCount

Anzahl der Hauptticks der Skala.

Integer

MajorTicksShape

Form/Art der Hauptticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksShape

Form/Art der Nebenticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksCount

Anzahl der Nebenticks der Skala.

Integer

PointerSize

Größe des Zeigers.

Size

PointerCapRadius

Größe des Zeigerbefestigungspunkts.

Double

PointerBorderBrush

Farbe des Zeigerrahmens.

Brush

PointerCapStyle

Form/Art des Zeigerbefestigungspunkts.

Enum:

  • BackCap
  • FrontCap
  • Screw

PointerCapBorderBrush

Farbe des Zeigerbefestigungspunkts.

Brush

PointerBrush

Farbe des Zeigers.

Brush

GaugeBorderBrush

Farbe des Elementrahmens.

Brush

GaugeBackgroundBrush

Farbe des Elementhintergrunds.

Brush

PointerCapColorBrush

Farbe des Zeigerbefestigungspunkts.

Brush

GaugeMiddlePlate

Radius der Elementhintergrundmittelplatte.

Double

PointerOffset

Offset des Zeigers (Verschiebung).

Double

RangeRadius

Radius der Bereichsgesamtanzeige.

Double

RangeThickness

Dicke der Bereichsgesamtanzeige.

Double

RangeStartValue

Startwert der Bereichsgesamtanzeige.

Double

RangeEndValue

Endwert der Bereichsgesamtanzeige.

Double

RangeMinEndValue

Endwert des Minimalbereichs.

Double

RangeMidEndValue

Endwert des Mittelbereichs.

Double

RangeMinColorBrush

Farbe des Minimalbereichs.

Brush

RangeMidColorBrush

Farbe des Mittelbereichs.

Brush

RangeMaxColorBrush

Farbe des Maximalbereichs.

Brush

ScaleOuterBorderBrush

Farbe der Skalenumrandung.

Brush

ScaleBackgroundBrush

Farbe des Skalahintergrunds.

Brush

ValueTextFrameStyle

Form/Art der Wertanzeige.

Enum:

  • LargeFrame
  • SmallFrame
  • None

ValueTextContent

Inhalt der Wertanzeige.

Enum:

  • Text
  • TextValue
  • Value

ValueTextSize

Schriftgröße der Werteanzeige.

Double

ValueTextColor

Schriftfarbe der Werteanzeige.

Color

IsGlasReflection

Aktivierung des Glaseffektes auf dem Element.

Boolean

GaugeOffsett

Absenkung des Rotationspunktes des gesamten Elements.

Double


Fortschrittsanzeige - ProgressBarControl

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente -> Fortschrittsanzeige - ProgressBarControl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Property | Funktion | Wert
CurrentValue | Aktueller Wert, der angezeigt werden soll. | Double
MinValue | Minimalwert des Wertebereichs. | Double
MaxValue | Maximalwert des Wertebereichs. | Double
ProgressbarDivisionCount | Anzahl der Unterteilungen der (Boxed) Fortschrittsanzeige. | Integer
VisibilityText | Sichtbarkeit der Wertanzeige. | Boolean
TextSize | Schriftgröße der Wertanzeige. | Double
TextColor | Farbe der Wertanzeige. | Color
ProgressBarBoxedColor | Farbe der Rahmen der (Boxed) Fortschrittsanzeige. | Color
ProgressBarMarginDistance | Abstand der Progressbar-Box vom Elementrand (links, oben, rechts, unten). | Double
ProgressBarInactiveBrush | Indikatorfarbe nicht aktiv. | Brush
ProgressBarActiveBrush | Indikatorfarbe aktiv. | Brush
ProgressBarPadding | Abstand der Fortschrittsanzeige von der Progressbar-Box (links, oben, rechts, unten). | Double
ElementBorderBrush | Farbe des Elementrahmens. | Brush
ElementBackgroundBrush | Farbe des Elementhintergrunds. | Brush


Bargraf vertikal - VerticalBargraphControl

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente -> Bargraf vertikal - VerticalBargraphControl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Property | Funktion | Wert
CurrentValue | Aktueller Wert, der angezeigt werden soll. | Double
MinValue | Minimalwert der Skala. | Double
MaxValue | Maximalwert der Skala. | Double
MajorTicksCount | Anzahl der Hauptticks der Skala. | Integer
MinorTicksCount | Anzahl der Nebenticks der Skala. | Integer
MajorTickColor | Farbe der Hauptticks der Skala. | Color
MinorTickColor | Farbe der Nebenticks der Skala. | Color
ElementBorderBrush | Farbe des Elementrahmens. | Brush
ElementBackgroundBrush | Farbe des Elementhintergrunds. | Brush
ElementGlasReflection | Aktivierung des Glaseffekts auf dem Element. | Visibility
ElementFontFamily | Elementschriftart. | Font
ScaleFontSize | Schriftgröße der Skala. | Double
ScaleFontColor | Schriftfarbe der Skala. | Color
IndicatorBrush | Farbe der Bargraf-Füllfarbe. | Brush
BargraphSeparation | Anzahl der Bargraf-Unterteilungstriche. | Integer
BargraphSeparationColor | Farbe der Skalenunterteilungen. | Color


Temperaturanzeige - TemperatureIndicatorControl

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente -> Temperaturanzeige - TemperatureIndicatorControl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Property

Funktion

Wert

CurrentValue

Aktueller Wert, der angezeigt werden soll.

Double

MinValue

Minimalwert der Skala.

Double

MaxValue

Maximalwert der Skala.

Double

MajorTicksCount

Anzahl der Hauptticks der Skala.

Integer

MinorTicksCount

Anzahl der Nebenticks der Skala.

Integer

TickNegativColor

Farbe des negativen Hauptticks (verlaufend zu TickPositivColor).

Color

TickPositivColor

Farbe des positiven Hauptticks (verlaufend zu TickNegativColor).

Color

MinorTickColor

Farbe der Nebenticks.

Color

ElementBorderBrush

Farbe des Elementrahmens.

Brush

ElementBackgroundBrush

Farbe des Elementhintergrunds.

Brush

ElementGlasReflection

Aktivierung des Glaseffektes auf dem Element.

Visibility

ElementFontFamily

Elementschriftart.

Font

IndicatorColor

Farbe der Indikatorfüllfarbe.

Color

IndicatorBorderColor

Farbe des Indikatorrahmens.

Color

MajorTickSize

Größe der Hauptticks der Skala.

Size

MinorTickSize

Größe der Nebenticks der Skala.

Size

ScaleLetteringDistance

Abstand der Skalenbeschriftung (vertikal), jeder x. Haupttick soll beschriftet werden.

Integer

IndicatorScaleDistance

Abstand zwischen Indikator und Skala (horizontal).

Double

ScaleFontSize

Schriftgröße der Skala.

Double

ScaleFontColor

Schriftfarbe der Skala.

Color

Unit

Einheit.

String

ElementStyle

Form/Art des Elements.

Enum:

  • SmallFrame
  • Unit
  • None


Analoguhr - AnalogClockControl

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente -> Analoguhr - AnalogClockControl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Property

Funktion

Wert

ElementStyle

Form/Art des Elements.

Enum:

  • SmallNumbers
  • BigNumbers
  • No

ElementBackgroundBrush

Farbe des Elementhintergrunds.

Brush

ElementGlasReflection

Aktivierung des Glaseffekts auf dem Element.

Visibility

Offset

Wert in Stunden (h), der die Zeitverschiebung zur Systemuhr darstellt.

Int16

OriginText

Text, der in der Uhr angezeigt wird (z. B. Ortsangabe).

String


Universalregler - UniversalReglerControl

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Vorgefertigte Elemente -> Universalregler - UniversalReglerControl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Property

Funktion

Wert

CurrentValue

Aktueller Wert, der angezeigt werden soll.

Double

ElementFontFamily

Elementschriftart.

Font

MinValue

Minimalwert der Skala.

Double

MaxValue

Maximalwert der Skala.

Double

Radius

Double

ScaleRadius

Radius der Skala.

Double

ScaleStartAngle

Winkel, bei dem die Skala beginnt.

Double

ScaleLabelRotationMode

Ausrichtung der Skalenbeschriftung.

Enum:

  • None
  • Automatic
  • SurroundIn
  • SurroundOut

ScaleSweepAngle

Winkelbereich, der die Größe der Skala definiert.

Double

ScaleLabelFontSize

Schriftgröße der Skalenbeschriftung.

Double

ScaleLabelColor

Schriftfarbe der Skalenbeschriftung.

Color

ScaleLabelRadius

Radius, an dem die Skalenbeschriftung ausgerichtet ist.

Double

ScaleValuePrecision

Genauigkeit der Skalenbeschriftung.

Integer

ElementStyle

Darstellungsart des Elements

Enum:

  • Knob
  • Plate
  • None

MajorTickColor

Farbe der Hauptticks der Skala.

Color

MinorTickColor

Farbe der Nebenticks der Skala.

Color

MajorTickSize

Größe der Hauptticks der Skala.

Size

MinorTickSize

Größe der Nebenticks der Skala.

Size

MajorTicksCount

Anzahl der Hauptticks der Skala.

Integer

MajorTicksShape

Form/Art der Hauptticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksShape

Form/Art der Nebenticks der Skala.

Enum:

  • Rectangle
  • Trapezoid
  • Triangle

MinorTicksCount

Anzahl der Nebenticks der Skala.

Integer

BackgroundBorderBrush

Farbe des Elementrahmens.

Brush

BackgroundBrush

Farbe des Elementhintergrunds.

Brush

PointerCapColorBrush

Farbe des Zeigerbefestigungspunkts.

Brush

GaugeMiddlePlate

Radius der Elementhintergrundmittelplatte.

Double

ValueFontSize

Schriftgröße der Werteanzeige.

Double

ValueFontColor

Schriftfarbe der Werteanzeige.

Color

IsGlasReflection

Aktivierung des Glaseffektes auf dem Element.

Boolean

KnobBrush

Farbe des Drehknopfes.

Brush

IndicatorBrush

Farbe des Indikators.

Brush

IndicatorBackgroundBrush

Hintergrundfarbe des unaktiven Indikators.

Brush

KnobSize

Durchmesser des Drehknopfes.

Double

KnobIndicatorSize

Indikatorgröße des Knopfes.

Size

ElementSize

Größe des Elements.

Size

VisibilityKnob

Aktivierung des Knopfes.

Boolean

ValuePosition

Position der Wertanzeige.

Double

ValueVisibility

Aktivierung der Werteanzeige.

Boolean


Beispiele: Integration von WPF in zenon

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Beispiele: Integration von WPF in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wie XAML-Dateien erstellt und in zenon als WPF-Elemente eingebunden werden, sehen Sie an folgenden Beispielen:

  • Button als WPF-XAML in zenon einbinden
  • Bargraf als WPF-XAML in zenon einbinden

Noch in diesem Kapitel

Button als WPF-XAML in zenon einbinden

Bargraf als WPF-XAML in zenon einbinden


Button als WPF-XAML in zenon einbinden

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Beispiele: Integration von WPF in zenon -> Button als WPF-XAML in zenon einbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aufbau des Beispiels:

  • Erzeugung eines Buttons in Microsoft Expression Blend
  • einbinden in zenon
  • Verknüpfung mit einer Variablen sowie einer Funktion
  • anpassen des Buttons an die Größe des Elements
  • Button erstellen

Erzeugen Sie als ersten Schritt einen Button wie im Kapitel Button als XAML-Datei mit Microsoft Expression Blend erstellen beschrieben. Um die XAML-Datei in zenon verwenden zu können, fügen Sie diese im Projektbaum in den Ordner Dateien/Grafiken ein.

Button einbinden

Hinweis: Für die folgende Beschreibung wird ein zenon Projekt mit folgenden Inhalten verwendet:

  • ein leeres Bild als Startbild
  • eine Intern-Variable int vom Typ Int
  • eine Funktion Funktion_0 vom Typ Sollwert absetzen mit:
    • Option Direkt zu Hardware aktiviert
    • Sollwert wurde auf 45

Um den Button einzubinden:

  1. öffnen Sie das leere Bild
  2. platzieren Sie ein WPF-Element im Bild
  3. wählen Sie im Eigenschaftenfenster XAML-Datei

    Interne ID: Button als WPF-XAML in zenon einbinden

    XAML-Datei

    Auswahl der XAML-Datei für das WPF-Element. Klick auf ... öffnet Dialog zur Auswahl. Die Datei muss bereits im Projektmanager unter Dateien/Grafiken angelegt worden sein oder im Dialog über das Symbol Datei hinzufügen ausgewählt werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie die XAML-Datei aus (z. B.: MyButton.xaml) und schließen Sie den Dialog
  5. wählen Sie die Eigenschaft Konfiguration

    Interne ID: Button als WPF-XAML in zenon einbinden

    Konfiguration

    Öffnet den Dialog zur Konfiguration der XAML-Datei. Eigenschaften, Ereignisse, Transformationen und Bedienberechtigungen können zugewiesen werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Button konfigurieren

Der Konfigurationsdialog zeigt eine Vorschau der ausgewählten XAML-Datei. Im Baum werden alle in der XAML_Datei benannten Elemente aufgelistet:

  1. wählen Sie den WPF-Button, der sich in LayoutRoot->MyViewBox->MyButton befindet
  2. suchen Sie in der Registerkarte Eigenschaften den Eintrag Content, dieser beinhaltet den Text des Buttons
  3. klicken Sie in die Spalte Verknüpfungsart
  4. wählen Sie in der Dropdownliste den Eintrag Variable aus
  5. klicken Sie in die Spalte Verknüpfung
  6. der Variablenauswahldialog wird geöffnet
  7. wählen Sie die Variable int, um diese Variable mit der Eigenschaft Content zu verknüpfen

Ereignisse

Um auch Ereignisse zuzuweisen:

  1. selektieren Sie die Registerkarte Ereignisse

  2. suchen Sie den Eintrag Click, dieses Ereignis wird von WPF-Element ausgelöst, sobald der Button geklickt wird
  3. klicken Sie in die Spalte Verknüpfungsart
  4. wählen Sie in der Dropdownliste den Eintrag Funktion aus
  5. klicken Sie in die Spalte Verknüpfung
  6. der Funktionsauswahldialog wird geöffnet
  7. wählen Sie Funktion_0 aus
  8. bestätigen Sie die Änderungen mit OK
  9. fügen Sie im Bild noch ein Zahlenwert-Element ein
  10. verknüpfen Sie auch diesen Zahlenwert mit der Variablen int.
  11. kompilieren Sie die Runtime-Dateien und starten Sie die Runtime

In der Runtime wird das WPF-Element dargestellt, der Text des Buttons ist 0. Sobald Sie auf den Button klicken, wird das Click-Ereignis getriggert und die Funktion Sollwert setzen ausgeführt. Der Wert 45 wird direkt auf die Hardware abgesetzt und sowohl Zahlenwert als auch Button zeigen den Wert 45 an.

Setzen Sie über das Element Zahlenwert einen Sollwert von 30 ab, so wird auch dieser Wert vom WPF-Element übernommen.

Bedienberechtigung

Ähnlich wie ein Zahlenwert kann ein WPF-Element je nach Bedienberechtigung gesperrt (Schlosssymbol) oder bedienbar geschaltet werden. Stellen Sie beim WPF-Element die Berechtigungsebene auf 1 und legen Sie einen Benutzer Test mit Berechtigungsebene 1 an. Zusätzlich legen Sie die Funktionen Login mit Dialog und Logout an. Diese beiden Funktionen verknüpfen Sie mit 2 neuen Text-Buttons im Bild.

Im Konfigurationsdialog des WPF-Elements selektieren Sie den WPF-Button MyButton und wählen Sie die Registerkarte Eigenschaften:

  1. wählen Sie das Element IsEnabled
  2. klicken Sie in die Spalte Verknüpfungsart
  3. wählen Sie in der Dropdownliste den Eintrag Bedienberechtigung/Verriegelung aus
  4. klicken Sie in die Spalte Verknüpfung
  5. wählen Sie in der Dropdownliste die Option Bedienberechtigung vorhanden aus

  6. schließen Sie den Dialog mit OK

Kompilieren Sie die Runtime-Dateien und achten Sie darauf, auch die Bedienberechtigungen zur Übertragung auszuwählen. Nach dem Starten der Runtime wird der WPF-Button im Bild deaktiviert angezeigt und kann nicht bedient werden. Wenn Sie sich jetzt mit dem Benutzer Test einloggen, wird der Button aktiviert und kann bedient werden. Sobald Sie sich ausloggen, wird der Button wieder gesperrt.

Transformation

Um Transformationen verwenden zu können, muss die XAML-Datei noch angepasst werden:

  1. wechseln Sie ins Programm Expression Blend
  2. selektieren Sie MyButton, damit die Eigenschaften des Buttons im Eigenschaftenfenster sichtbar sind

  3. selektieren Sie unter Transform bei RenderTransform die Option Apply relative transform

    Dadurch wird in der XAML-Datei ein Block eingefügt, der zur Laufzeit die Einstellungen zur Transformation speichert.

  4. speichern Sie die Datei und ersetzen Sie im zenon Projekt die alte Version mit dieser neuen Datei
  5. öffnen Sie wieder den Konfigurationsdialog des WPF-Elements:
    1. wählen Sie den Button MyButton aus
    2. wählen Sie die Registerkarte Transformationen

    1. selektieren Sie das Element RotateTransform.Angle
    2. klicken Sie in die Spalte Verknüpfungsart
    3. wählen Sie in der Dropdownliste den Eintrag Transformationen aus
    4. klicken Sie in die Spalte Verknüpfung
    5. der Variablenauswahldialog wird geöffnet
    6. wählen Sie die Variable int, um diese Variable mit der Eigenschaft RotateTransform.Angle zu verknüpfen

Kompilieren Sie die Runtime-Dateien und starten Sie die Runtime. Loggen Sie sich als Benutzer Test ein und klicken Sie auf den Button. Der Button erhält den Wert 45 und das WPF-Element dreht sich um 45°.


Bargraf als WPF-XAML in zenon einbinden

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Beispiele: Integration von WPF in zenon -> Bargraf als WPF-XAML in zenon einbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aufbau des Beispiels:

  • Erzeugung eines Bargrafs in Adobe Illustrator und Umwandlung in WPF
  • einbinden in zenon
  • Verknüpfung mit Variablen
  • anpassen des Bargraf-WPF-Elements

Bargraf erstellen

Erzeugen Sie als ersten Schritt einen Bargraf wie im Kapite Workflow mit Adobe Illustrator beschrieben. Um die XAML-Datei in zenon verwenden zu können, fügen Sie diese im Projektbaum in den Ordner Dateien/Grafiken ein.

Bargraf einbinden

Hinweis: Für die folgende Beschreibung wird ein zenon Projekt mit folgenden Inhalten verwendet:

  • ein leeres Bild als Startbild
  • 4 Variablen vom Intern Treiber für
    • Skala 0
    • Skala Mitte
    • Skala hoch
    • aktueller Wert
  • eine Variable vom Mathematik Treiber für die Anzeige des aktuellen Werts (255)

Um den Bargraf einzubinden:

  1. öffnen Sie das leere Bild
  2. platzieren Sie ein WPF-Element im Bild
  3. wählen Sie im Eigenschaftenfenster XAML-Datei

    Interne ID: Bargraf als WPF-XAML in zenon einbinden

    XAML-Datei

    Auswahl der XAML-Datei für das WPF-Element. Klick auf ... öffnet Dialog zur Auswahl. Die Datei muss bereits im Projektmanager unter Dateien/Grafiken angelegt worden sein oder im Dialog über das Symbol Datei hinzufügen ausgewählt werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie die gewünschte XAML-Datei aus (z. B. bargraph_vertical.xaml) und schließen Sie den Dialog

Bargraf anpassen

Vor der Konfiguration wird die Skala der XAML-Datei, wenn nötig, angepasst:

Dazu:

  • legen Sie eine neue Mathematik-Variable an, die den neuen Wert in Bezug auf die Skalierung berechnet, zum Beispiel:
  • Variable: 0-1000
  • Mathematikvariable {im xaml-File erstellter Wert}*Variable/1000

    Dann wird die XAML-Datei konfiguriert.

Bargraf konfigurieren

  1. klicken Sie auf das WPF-Element und wählen Sie die Eigenschaft Konfiguration

    Interne ID: Bargraf als WPF-XAML in zenon einbinden

    Konfiguration

    Öffnet den Dialog zur Konfiguration der XAML-Datei. Eigenschaften, Ereignisse, Transformationen und Bedienberechtigungen können zugewiesen werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. der Konfigurationsdialog zeigt eine Vorschau der ausgewählten XAML-Datei
  3. wählen Sie den Minimum-Wert, den Mittelwert und der Maximum-Wert aus und verknüpfen Sie jeweils in der Eigenschaft Content die entsprechende Variable

  4. wählen Sie den Slider aus und verknüpfen Sie die Eigenschaft Value mit der Mathematik Variablen (in unserem Beispiel: calculation)

  5. Überprüfen Sie die Projektierung in der Runtime:


Fehlerbehandlung

Handbuch -> Controls -> WPF-Element -> Engineering in zenon -> Fehlerbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einträge in LOG-Dateien

Eintrag | Level | Bedeutung
Xaml file found in %s with different name, using default! | Warnung | Der Name der Sammeldatei und der Name der darin enthaltenen XAML-Datei stimmt nicht überein. Um interne Konflikte zu vermeiden, wird im Arbeitsordner die Datei mit dem Name der Sammeldatei und der Endung .xaml verwendet.
no preview image found in %s | Warnung | Die Sammeldatei enhält keine gültige Vorschaugrafik (preview.png oder [Namen der XAML Datei].png). Daher kann keine Vorschau angezeigt werden.
Xaml file in %s not found or not unique! | Fehler | Die Sammeldatei enthält keine XAML-Datei oden mehrere Dateien mit der Endung .xaml. sie kann nicht verwendet werden.
Could not remove old assembly %s | Warnung | Im Arbeitsordner befindet sich ein Assembly, das durch eine neuere Version ersetzt werden soll, aber nicht gelöscht werden kann.
Could not copy new assembly %s | Fehler | Für ein Assembly im Arbeitsordner ist eine neue Version verfügbar, aber sie kann nicht dorthin kopiert werden. Möglicher Grund: z.B ist das alte Assembly noch geladen. Die alte Version wird weiter verwendet, die neue Version kann nicht benutzt werden,
file exception in %s | Fehler | Beim Zugriff auf eine Sammeldatei ist ein Dateifehler aufgetreten.
Generic exception in %s | Fehler | Beim Zugriff auf eine Sammeldatei ist ein allgemeiner Fehler aufgetreten.


Dateiaufbau

Handbuch -> Dateiaufbau

Informationen für Systemadministratoren, die direkt in die INI-Dateien eingreifen wollen.

info Info

Projekteinstellungen sollten prinzipiell im Editor vorgenommen werden. Änderungen in der zenon6.ini sind Experten vorbehalten.

Noch in diesem Kapitel

Systemdateien

dBaseIV Variablendatei

project.ini

startup.ini

zenDB.ini

zenon6.ini

zenWebSrv.ini


Systemdateien

Handbuch -> Dateiaufbau -> Systemdateien

Im Folgenden finden Sie die Dokumentation der Einträge der Systemdateien.

Datei

Beschreibung

dBaseIV Variablendatei

Einstellungen der dBase IV Importdatei.

project.ini

Einstellungen für Projekt.

Die project.ini finden Sie im Runtime-Pfad des jeweiligen Projekts. Um den Pfad zu öffnen:

  • markieren Sie das Projekt
  • drücken Sie die Tastenkombination Strg+Alt+E
  • der zum Projekt gehörende SQL-Ordner wird geöffnet
  • navigieren Sie zu ...\FILES\zenon\system

startup.ini

Einstellungen des zenon Startup Tools.

zenon6.ini

Einstellungen für Visualisierungssoftware.

Die zenon6.ini finden Sie im Pfad:

Windows Vista/7: C:\ProgramData\COPA-DATA\System\

Windows XP: C:\Dokumente und Einstellungen\All users\Anwendungsdaten\COPA-DATA\System

zenDB.ini

Einstellungen der SQL Datenbank

Abarbeitung zenon6.ini

Die Einstellungen in zenon6.ini werden in folgender Reihenfolge abgearbeitet:

  1. zenon6.ini
  2. Defaultwert

Dabei wird der erste gefundene Eintrag verwendet.

Abarbeitung project.ini

Die Einstellungen in project.ini werden in folgender Reihenfolge abgearbeitet:

  1. project.ini
  2. zenon6.ini
  3. Defaultwert

Dabei wird der erste gefundene Eintrag verwendet.


dBaseIV Variablendatei

Handbuch -> Dateiaufbau -> dBaseIV Variablendatei

Für den Variablenimport und -export muss die dBaseIV-Datei folgende Struktur und Inhalte besitzen.

attention Achtung

dBase unterstützt keine Strukturen oder Arrays (komplexe Variablen).

DBF-Dateien müssen:

  • in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • nahe am Stammverzeichnis (Root) abgelegt werden

Struktur

Bezeichnung | Typ | Feldgröße | Bemerkung
KANALNAME | Char | 128 | Variablenname. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_R | C | 128 | Ursprünglicher Name einer Variablen, der durch den Eintrag unter KANALNAME ersetzt werden soll (Feld/Spalte muss manuell angelegt werden). Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_D | Log | 1 | Variable wird bei Eintrag 1 gelöscht (Feld/Spalte muss manuell angelegt werden).
TAGNR | C | 128 | Kennung. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
EINHEIT | C | 11 | Technische Maßeinheit
DATENART | C | 3 | Datenart (z.B. Bit, Byte, Wort, ...) entspricht dem Datentyp.
KANALTYP | C | 3 | Speicherbereich in der SPS (z.B. Merkerbereich, Datenbereich, ...) entspricht Treiber-Objekttyp.
HWKANAL | Num | 3 | Bus-Adresse
BAUSTEIN | N | 3 | Datenbaustein-Adresse (nur bei Variablen aus den Datenbereich der SPS)
ADRESSE | N | 5 | Offset
BITADR | N | 2 | Für Bit-Variablen: Bitadresse Für Byte-Variablen: 0=niederwertig, 8=höherwertig Für String-Variablen: Stringlänge (max. 63 Zeichen)
ARRAYSIZE | N | 16 | Anzahl der Variablen im Array für Index-Variablen ACHTUNG: Nur die erste Variable steht voll zur Verfügung. Alle folgenden sind nur über VBA oder den Rezeptgruppen Manager zugänglich
LES_SCHR | L | 1 | Lese-Schreib-Berechtigung 0: Sollwert setzen ist nicht erlaubt 1: Sollwert setzen ist erlaubt
MIT_ZEIT | L | 1 | Zeitstempelung in zenon (nur wenn vom Treiber unterstützt)
OBJEKT | N | 2 | Treiberspezifische ID-Nummer des Primitivobjekts setzt sich zusammen aus KANALTYP und DATENART
SIGMIN | Float | 16 | Rohwertsignal minimal (Signalauflösung)
SIGMAX | F | 16 | Rohwertsignal maximal (Signalauflösung)
ANZMIN | F | 16 | technischer Wert minimal (Messbereich)
ANZMAX | F | 16 | technischer Wert maximal (Messbereich)
ANZKOMMA | N | 1 | Anzahl der Nachkommastellen für die Darstellung der Werte (Messbereich)
UPDATERATE | F | 19 | Updaterate für Mathematikvariablen (in sec, eine Dezimalstelle möglich) bei allen anderen Variablen nicht verwendet
MEMTIEFE | N | 7 | Nur aus Kompatibilitätsgründen vorhanden
HDRATE | F | 19 | HD-Updaterate für hist. Werte (in sec, eine Dezimalstelle möglich)
HDTIEFE | N | 7 | HD-Eintragtiefe für hist. Werte (Anzahl)
NACHSORT | L | 1 | HD-Werte als nachsortierte Werte
DRRATE | F | 19 | Aktualisierung an die Ausgabe (für zenon DDE-Server, in sec, eine Kommastelle möglich)
HYST_PLUS | F | 16 | Positive Hysterese; ausgehend vom Messbereich
HYST_MINUS | F | 16 | Negative Hyterese; ausgehend vom Messbereich
PRIOR | N | 16 | Priorität der Variable
REAMATRIZE | C | 32 | Name der zugeordnete Reaktionsmatrix
ERSATZWERT | F | 16 | Ersatzwert; ausgehend vom Messbereich
SOLLMIN | F | 16 | Sollwertgrenze Minimum; ausgehend vom Messbereich
SOLLMAX | F | 16 | Sollwertgrenze Maximum; ausgehend vom Messbereich
VOMSTANDBY | L | 1 | Variable vom Standby Server anfordern; der Wert der Variable wird im redundanten Netzwerkbetrieb nicht vom Server sondern vom Standby-Server angefordert
RESOURCE | C | 128 | Betriebsmittelkennung. Freier String für Export und Anzeige in Listen. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
ADJWVBA | L | 1 | Nichtlineare Wertanpassung: 0: Nichtlineare Wertanpassung wird verwendet 1: Nichtlineare Wertanpassung wird nicht verwendet
ADJZENON | C | 128 | Verknüpftes VBA-Makro zum Lesen der Variablenwerte für die nichtlineare Wertanpassung.
ADJWVBA | C | 128 | Verknüpftes VBA-Makro zum Schreiben der Variablenwerte für die nichtlineare Wertanpassung.
ZWREMA | N | 16 | Verknüpfte Zählwert-Rema.
MAXGRAD | N | 16 | Maximaler Gradient für die Zählwert-Rema.

attention Achtung

Beim Import müssen Treiberobjekttyp und Datentyp in der DBF-Datei an den Zieltreiber angepasst werden, damit Variablen importiert werden.

Grenzwertdefinition

Grenzwertdefinition für Grenzwert 1 bis 4, bzw. Zustand 1 bis 4:

Bezeichnung | Typ | Feldgröße | Bemerkung
AKTIV1 | L | 1 | Grenzwert aktiv (pro Grenzwert vorhanden)
GRENZWERT1 | F | 20 | technischer Wert oder ID-Nummer der verknüpften Variable für einen dynamischen Grenzwert (siehe VARIABLEx) (wenn unter VARIABLEx 1 steht und hier -1, wird die bestehende Variablenzuordnung nicht überschrieben)
SCHWWERT1 | F | 16 | Schwellwert für den Grenzwert
HYSTERESE1 | F | 14 | wird nicht verwendet
BLINKEN1 | L | 1 | Blinkattribut setzen
BTB1 | L | 1 | Protokollierung in CEL
ALARM1 | L | 1 | Alarm
DRUCKEN1 | L | 1 | Druckerausgabe (bei CEL oder Alarm)
QUITTIER1 | L | 1 | quittierpflichtig
LOESCHE1 | L | 1 | löschpflichtig
VARIABLE1 | L | 1 | dyn. Grenzwertverknüpfung der Grenzwert wird nicht durch einen absoluten Wert (siehe Feld GRENZWERTx) festgelegt.
FUNC1 | L | 1 | Funktionsverknüpfung
ASK_FUNC1 | L | 1 | Ausführung über die Alarmverwaltung
FUNC_NR1 | N | 10 | ID-Nummer der verknüpften Funktions (steht hier -1, so wird die bestehende Funktion beim Import nicht überschrieben)
A_GRUPPE1 | N | 10 | Alarm/Ereignis-Gruppe
A_KLASSE1 | N | 10 | Alarm/Ereignis-Klasse
MIN_MAX1 | C | 3 | Minimum, Maximum
FARBE1 | N | 10 | Farbe als Windowskodierung
GRENZTXT1 | C | 66 | Grenzwerttext
A_DELAY1 | N | 10 | Zeitverzögerung
INVISIBLE1 | L | 1 | Unsichtbar

Bezeichnungen in der Spalte Bemerkung beziehen sich auf die in den Dialogboxen zur Definition von Variablen verwendeten Begriffe. Bei Unklarheiten, siehe Kapitel Variablendefinition.


project.ini

Handbuch -> Dateiaufbau -> project.ini

Hinweis: Projekteinstellungen sollten prinzipiell im Editor vorgenommen werden. Änderungen in der project.ini sind Experten vorbehalten.

Eintrag

Funktion

[DEFAULT]

BLINK=500

Blinkgeschwindigkeit bei den Dynamischen Elementen in Millisekunden.

MOUSE_FOCUS=

1: Mause-Fokus aktiv (default)
0: Mause-Fokus nicht aktiv

VERS_CHECK=

1: Überprüfung der Versionsnummern in den DLLs bei Programmstart

RELEASE=5
  • 0: Titel mit Systemmenü, Max- und Min-Buttons
  • 1: Titel mit Maximize und Minimizebutton
  • 2: Titel mit MinimizeButton
  • 3: Titel mit MaximizeButton
  • 4: Titel ohne Bedienelemente (kein Systemmenü, Minimize und Maximize-Buttons)
  • 5: kein Titel - das projektierte Bild wird um die Größe der Titelleiste nach oben verschoben. Das hat den Vorteil, daß man den kompletten Bildschirmbereich nützen kann - allerdings ist bei der Projektierung auf diese Eigenschaft zu achten.
  • 6: Titel mit Systemmenü sonst Titel mit Systemmenü, Minimize- und Maximize-Button

AUFFUELLEN=
  • 0: bei der Verwaltung der HD- und Speicher-Daten wird der jeweils ankommende Wert gespeicher.
  • 1: die Werte werden im definierten Intervall abgelegt (bei größeren Zeitabständen müssen eventuell mehrere Daten gespeichert werden)

SYSKEY=

0: Systemtasten werden nicht gesperrt
1: Systemtasten werden in der Runtime gesperrt.
Systemtasten: Alt+TAB, Alt+ESC, Alt+F4 etc.

BTB_DRUCKEN=0

1: Ausgabe der CEL-Einträge auf den Drucker
0 :AlarmEinträge auf den Drucker

ONLINE_DRUCKEN=1

1: Online Einträge (CEL oder Alarm) werden bei Bedarf mitprotokolliert.
0: Mitprotokollierung inaktiv.

CURSOR=1

1: In der Runtime wird der normale Windows-Cursor angezeigt (default)
0: Es wird der Cursor abgeschaltet (hauptsächlich für Touchbedienung)

MILLISEK=0

Sollen HD-Daten und Trends im Millisekundentakt dargestellt werden (=1) oder nicht (=0).

HDDATEN=1

HD-Verwaltung ist aktiv (1) oder inaktiv (0).

HEX=0

0: Variablenadressen werden normal engezeigt
1: Variablenadressen werden hexadezimal angezegt

GW_FKT_AT_RT_START =1

Wenn 0 dann werden beim Start der RT und anstehender Grenzwertverletzung die Grenzwertfunktionen nicht erneut ausgeführt.

LOG_FLAGSx

Ab Version 5.50, kann durch erstellen dieses Eintrages die erweiterte Logging-Funktionalität aktiviert werden. X ist durch die zu aktivierende Log-Gruppe zu ersetzen. Für jede Gruppe kann bitkodiert angegeben werden, welche Meldungen geloggt werden sollen. Diese Meldungen weden über das Windows-Debug-Interface ausgegeben. Wenn eine Errordatei erstellt wird, erfolgt auch ein Eintrag in diese.
Derzeit ist nur die Gruppe 0 für den PFS implementiert. Diese Gruppe unterstützt folgende Bits:
0 // Errors immer aktiv
1 // Warnungen
2 // Berechnung loggen
3 // Bei Berechnung übersprungene loggen.
4 // Ausführung loggen
5 // allgemeine Meldungen
6 // Schaltpunktliste nach Berechnung loggen
7 // Komplette Schaltpunktliste nach Berechnung loggen
8 // Netzwerkmeldungen loggen
9 // Konvertierung v. Profilen loggen
10 // Server, Standby Netzmeldungen loggen
11 // Meldungen zur Aktualisierung der Objektbezüge

USEREVENTNEEDMODEL=1

Wenn 0 dann werden Benutzerevents auch ohne Schicht am Tag ausgeführt.

[FUNKTIONEN]

EIN=1

ZURUECK_SCHABLONEN=

Schablonennamen, dessen Bilder in die Liste der Bilder für die Bild-Zurück Funktion aufgenommen werden (es können mehrere Schablonennamen angeführt werden, durch Unterstrich und Komma z.b.: ZURUECK_SCHABLONEN=_111,_333,_BU,)

Bei einem Intergrationsprojekt müssen die Schablonen-Namen aller Unterprojekte auch in der project.ini eingetragen werden, damit die Systemvariable auch im Unterprojekt funktioniert.

ZURUECK_ANZAHL=

Anzahl der Bilder für die Bild zurück Funktion.

PROJECTONLY=0

0: Bild zurück funktioniert Projekt übergreifend.(default)
1: Bild zurück funktioniert nur mit Projekt internen Bildern

SOUND=

Zahl von 1 bis 255, die für die Funktion Dauerton Start den Ton wählt und startet.

Interne ID: project.ini

Dauerton Start

Diese Funktion spielt eine Audiodatei (*.wav) wiederholt ab.

Mehr im Online-Handbuch

REZEPTUR_AENDERN=

1: Rezepte können zur Runtime geändert werden

0: Rezepte können nicht geändert werden

NAMEN=0

Anzeige der Funktionen nach deren Namen (1) oder Funktionen (0=default).

[ALARM]

(Ablaufsoftware)

EIN=1

Alarmverarbeitung ist bei Programmstart der Ablaufsoftware aktiv(1) oder inaktiv(0).

ALARMLISTE=03452

Bestimmt die Reihenfolge der Alarmlisteneinträge:

  • 0: eindeutiger Variablenname
  • 1: Kennung
  • 2: Alarmtext
  • 3: Zeitpunkt Alarm kommt
  • 4: Zeitpunkt Alarm geht
  • 5: Zeit der Quittierung

z.B:

ALARMLISTE=13452
Kennung-kommt-geht-quittiert-Alarmtext

NACHSCHIEBEN=0

soll in die Statuszeile der jeweils nächsten Alarm nachgeschoben werden (1), oder soll erst der nächste auftretende Alarm die Zeile wieder sichtbar machen (0).

ZEIT_TYP=6

in welchem Format die Zeit ausgegeben werden soll.

VAR_ANZ=

Anzahl der Zeichen für den Variablennamen.

TAG_ANZ=

Anzahl der Zeichen für die Kennung

ALA_ANZ=

Anzahl der Zeichen für den Alarmtext.

STAT_ANZ=

Anzahl der Zeichen für den Statustext.

USER_ANZ=

Anzahl der Zeichen für den Usernamen

COMPUTER_ANZ=

Anzahl der Zeichen für den Computernamen

RTEXT_ANZ=

Anzahl der Zeichen für den Reaktionstext

CLASS_ANZ=

Anzahl der Zeichen für die Alarm/Ereignis-Klasse

GROUP_ANZ=

Anzahl der Zeichen für die Alarm/Ereignis-Gruppe

AELTESTER=1
  • 1: Der älteste Alarm wird in der Alarmstatuszeile angezeigt.
  • 0: Der zuletzt aufgetretene Alarm wird in der Alarmstatuszeile angezeigt.

STATUS=

1: Alarmstatuszeile wird angezeigt.

0: Alarmstatuszeile wird nicht angezeigt.

MILLISEK=0
  • 0: bei Kommtzeit werden Millisekunden weder angezeigt noch ausgedruckt
  • 1: Millisekunden werden mit angezeigt

FARBE_KOMMT=rot

Textfarbe für Alarm-Kommt in der Alarmliste

FARBE_GEHT=grün

Textfarbe für Alarm-Geht in der Alarmliste

FARBE_QUIT=blau

Textfarbe für Alarm-Quittiert in der AlarmliQuittiert

BEEP=1
  • 1: Beim Auftreten des ersten Alarms wird ein Piep-Ton ausgegeben
  • 0: Es wird kein Ton ausgegeben.

STATUS_SCHRIFT=0

Index der ausgewählten Schrift für den Text in der Statuszeile. Kann in der Konfigurationsmaske für die Alarmverwaltung eingestellt werden (default 0 Systemschrift).

TITLE_NAME=

Bezeichner für den Spaltentitel, solange dieser nicht über das Element einstellbar ist (Default werden die Titel aus den sprachenabhängigen Resourcen geladen und müssen nur bei Änderung hier eingetragen werden).

TITLE_TAGNR=

siehe TITLE_NAME

TITLE_TEXT=

siehe TITLE_NAME

TITLE_COMES=

siehe TITLE_NAME

TITLE_GOES=

siehe TITLE_NAME

TITLE_QUIT=

siehe TITLE_NAME

TITLE_TIME_LASTING=

siehe TITLE_NAME

TITLE_STATUS=

siehe TITLE_NAME

TITLE_VALUE=

siehe TITLE_NAME

TITLE_USER=

siehe TITLE_NAME

TITLE_COMP=

siehe TITLE_NAME

TITLE_REACT_TIME=

siehe TITLE_NAME

TITLE_REACT_COUNT=

siehe TITLE_NAME

TITLE_REACT_STAT=

siehe TITLE_NAME

TITLE_ACT_TEXT=

siehe TITLE_NAME

TITLE_CLASS=

siehe TITLE_NAME

TITLE_GROUP=

siehe TITLE_NAME

HEADER=1

Anzeige einer Spaltenüberschrift in der Alarmliste.

HEADER_ENABLE=1

1: Spaltenüberschrift kann bedient werden

0: Spaltenüberschrift wird nur zur Anzeige verwendet

RESOURCELABEL

Beschreibung der Spalte für die Betriebsmittelkennung.

RESOURCELABEL_ANZ

Breite der Spalte für die Betriebsmittelkennung in Zeichen

COMES_ANZ

Breite der Spalte "Zeit kommt" in Zeichen

GOES_ANZ

Breite der Spalte "Zeit geht" in Zeichen

QUIT_ANZ

Breite der Spalte "Zeit quittiert" in Zeichen

REACT_TIME_ANZ

Breite der Spalte "Reaktivierte Zeit" in Zeichen

REACT_COUNT_ANZ

Breite der Spalte "Reaktiviert Anzahl" in Zeichen

REACT_STAT_ANZ

Breite der Spalte "Reaktiviert Variablenstatus" in Zeichen

TIME_LASTING_ANZ

Breite der Spalte "Zeit angestanden" in Zeichen

PREF_COMES

Default Präfix für Alarm kommt.
Default: Default:"TEXT=>> „

PREF_GOES

Default Präfix für Alarm geht
Default: Default:"TEXT=<< „

PREF_QUIT

Default Präfix für Alarm quittiert
Default: Default:"TEXT=-- „

PREF_IMAGE_COMES

Grafikdatei für Alarm kommt

PREF_IMAGE_GOES

Grafikdatei für Alarm geht

PREF_QUIT_GOES

Grafikdatei für Alarm quittiert

GROUPSYMBOL_ANZ

Breite der Spalte Alarm/Ereignis-Gruppe Symbol in Zeichen.

TITLE_GROUPSYMBOL_STYLE

Anzeigeart der Spalte Alarm/Ereignis-Gruppe Symbol.

TITLE_GROUPSYMBOL

Beschreibung der Spalte Alarm/Ereignis-Gruppe Symbol.

CLASSSYMBOL_ANZ"

Breite der Spalte Alarm/Ereignis-Klasse Symbol in Zeichen.

TITLE_CLASSSYMBOL_STYLE

Anzeigeart der Spalte Alarm/Ereignis-Klasse Symbol.

TITLE_CLASSSYMBOL

Beschreibung der Spalte Alarm/Ereignis-Klasse Symbol

TITLE_STATUSCAPTION_STYLE

Anzeigeart der Spalte Alarmzustand.

AREA_ANZ

Breite der Spalte Alarmbereich in Zeichen.

AREA

Beschreibung der Spalte Alarmbereich.

AREANR_ANZ

Breite der Spalte Alarmbereich Nummer in Zeichen.

AREANR

Beschreibung der Spalte Alarmbereich Nummer.

QUIT_IN_CEL=0

Quittieren eines Alarms wird in die chronologische Ereignisliste aufgenommen.

COLOR_CLASS=

1: Farben werden aus den Klassen genommen,
0: (Default) wie bisher (sortiert-unsortiert-Farben).

Ist ein Grenzwert mit keiner Klasse verknüpft wird die projektierte Farbe des Elementes verwendet.

COLOR_BACKGROUND=

1: Klassenfarbe wird als Hintergrundfarbe interpretiert,
0: Klassenfarbe bestimmte die Textfarbe.

Ist keine Klasse mit dem Grenzwert verknüpft, wird die Hintergrundfarbe oder die Textfarbe aus den Einstellungen des Listenelementes im Bild genommen

DYN_LIMIT_FILE=0

Dynamische Grenzwerte (Alarmverwaltung) benutzen das Kommentarfeld zur Ablage der dynamischen Inhalte (auf 80 Zeichen beschränkt). Damit ist das Kommentarfeld gesperrt. Will man das Kommentarfeld trotzdem benutzen oder will man 256 Zeichen verwenden, trägt man hier 1 ein (eine zusätzliche Datei zur A*.AML und mit der Endung D*.AML wird angelegt).

COLOR_ACKN_MARKER = xxx

Durch diesen Eintrag blinken zwei Rechtecke in der Farbe xxx bei unquittierten Alarmen. Nach Quittierung gehen diese in Dauerlicht über.

xxx wird wie folgt berechnet: RotAnteil (0-255) + 256 * GrünAnteil (0-255) + 65536*BlauAnteil(0-255)

[BTB]

Chronologische Ereignisliste

DRUCKE_SYSMLDG=1

Systemmeldungen sollen auch ausgedruckt (1) oder nur in Liste aufgenommen (0) werden.

EIN=1

Kommunikation zum Betriebstagebuch ist aktiv

FARBE_SORT=blau

Farbe für sortierte Einträge

FARBE_UNSORT=schwarz

Farbe für unsortierte Einträge

HEADER=1

Anzeige einer Spaltenüberschrift in der Liste.

HEADER_ENABLE=1

1: Spaltenüberschrift kann bedient werden

0: Spaltenüberschrift wird nur zur Anzeige verwendet

VAR_ANZ=

Anzahl der Zeichen für den Variablennamen in der Liste

TAG_ANZ=

Anzahl der Zeichen für die Variablenkennung

TXT_ANZ=

Anzahl der Zeichen für den verknüpften Text

WERT_ANZ=

Anzahl der Zeichen für den aufgetretenen Wert

STAT_ANZ=

Anzahl der Zeichen für den Status

USER_ANZ=

Anzahl der Zeichen für den Usernamen

COMPUTER_ANZ=

Anzahl der Zeichen für den Computernamen

RTEXT_ANZ=

Anzahl der Zeichen für den Reaktionstext

CLASS_ANZ=

Anzahl der Zeichen für die Alarm/Ereignis-Klasse

GROUP_ANZ=

Anzahl der Zeichen für die Alarm/Ereignis-Gruppe

ZEIT_TYP=6

>5: Ausgabe mit Datum
2,3,6 oder 7: Ausgabe mit Zeit
3 oder 7: Zeitausgabe mit Millisekunden

BTBLISTE=032

gewünschte Einträge und Reihenfolge in der Liste
0: Variablenname
1: Kennung
2: Text
3: Zeit des Auftretens
6: Statusinformation
7: Wert
8: Anwender ausgeben

SOLLWERT=0
  • Sollen die gesetzten Sollwerte im BTB mitprotokolliert werden:
    0: alle Aktionen werden aufgenommen
    1: nur über die Sollwert-Setzen-Maske vorgenommenen Änderungen
    2: keine Aktionen werden aufgenommen

ISTWERT=0
  • 0: Der aktuelle Wert wird nicht vermerkt.
  • <>0: Der aktuelle Wert wird vermerkt, wenn die Sollwertänderung in die CEL eingetragen werden.

REZEPT=1

0: kein Eintrag in der CEL
1: abgesetzte Rezepte des Rezeptgruppen-Managers werden in die CEL eingetragen

RTEXT_ANZ=45

Anzahl der Zeichen für den Reaktionstext in der chronologischen Ereignisliste.

FIRST_ENTRY=0

Beim Start der RT werden keine bestehenden Grenzwerteinträge eingelesen, erst wenn der Start erfolgte und neue Ereignisse eintreten, erfolgen neue Einträge (0). Bei 1 werden auch bestehende Grenzwertverletzungen eingetragen.

TITLE_NAME=

Bezeichner für den Spaltentitel, solange dieser nicht über das Element einstellbar ist (Default werden die Titel aus den sprachenabhängigen Resourcen geladen und müssen nur bei Änderung hier eingetragen werden).

TITLE_TAGNR=

siehe TITLE_NAME

TITLE_TEXT=

siehe TITLE_NAME

TITLE_COMES=

siehe TITLE_NAME

TITLE_STATUS=

siehe TITLE_NAME

TITLE_VALUE=

siehe TITLE_NAME

TITLE_USER=

siehe TITLE_NAME

TITLE_COMP=

siehe TITLE_NAME

TITLE_ACT_TEXT=

siehe TITLE_NAME

TITLE_CLASS=

siehe TITLE_NAME

TITLE_GROUP=

siehe TITLE_NAME

TXT_FILE=0

0 CEL-Einträge werden im Leitsystemformat (*.CEL) gespeichert
1 CEL-Einträge werden im Textformat (*.TXT) gespeichert und sind für zenon nicht mehr lesbar

NAME_BTB=

(nur wenn TXT_FILE=1)
Namenskürzel für die gespeicherten Textdateien
(default=BTB, d.h. BTBTTMM.TXT, TT=Tag MM=Monat)

SPONTAN=

1 alle neuen CEL-Einträge werden sofort eingetragen (ausser in gestoptem Zustand)
0 Änderungen werden erst beim Neuaufschalten der Liste neu geladen (Vorteil: Verringerung der Belastung im Netz)

COLOR_CLASS=

1 Farben werden aus den Klassen genommen,
0 (default) wie bisher (sortiert-unsortiert-Farben). Ist ein Grenzwert mit keiner Klasse verknüpft wird die projektierte Farbe des Elementes verwendet.

COLOR_BACKGROUND=

1 Klassenfarbe wird als Hintergrundfarbe interpretiert,
0 Klassenfarbe bestimmte die Textfarbe. Ist keine Klasse mit dem Grenzwert verknüpft, wird die Hintergrundfarbe oder die Textfarbe aus den Einstellungen des Listenelementes im Bild genommen

DYN_LIMIT_FILE=0

Dynamische Grenzwerte (Alarmverwaltung) benutzen das Kommentarfeld zur Ablage der dynamischen Inhalte (auf 80 Zeichen beschränkt). Damit ist das Kommentarfeld gesperrt. Will man das Kommentarfeld trotzdem benutzen oder will man 256 Zeichen verwenden, trägt man hier 1 ein (eine zusätzliche Datei zur A*.AML und mit der Endung D*.AML wird angelegt).

[FRM_PRNT]

LINES=

Angabe der Zeilenanzahl pro Seite bei Verwendung der FRM_PRNT.DLL (formatierte Ausgabe der Alarmliste).
Default = 0

[ELEMENTE]

TREND_ZEIT_FAKTOR=

Multiplikationsfaktor für Zeitabstände beim Zeichnen im Trend. Eine Linie wird nur gezeichnet, wenn der Abstand zwischen 2 aufgezeichneten Werten das x-Fache der nötigen Update-Rate ist. Mit dem Wert 0 wird keine Überprüfung durchgeführt (Überprüfung nur bei Vergangenheitswerten)(default 20)

[DRUCKER]

MAXPJ=90

Maximale Anzahl der Druck Jobs im Printmanager von Windows. Wenn diese Anzahl überschritten wird, so wird ein Eintrag in die CEL gemacht.

MAXNAMEN=9

Bei den Online Ausdrucken werden die einzelnen Einträge jeweils als eigene Druckaufträge abgeschickt. Um keine Namenskonflikte zu bekommen kann hier eine Nummervergeben werden (z.B.: für die Namen Alarm1, Alarm2, Alarm9).

DRUCKZEIT=2

Wenn die Alarme in einem Schwall auftreten können mehrere Einträge in einen Druckauftrag zusammengefaßt werden (es muss mindestens 2 Sekunden lang kein Alarm auftreten, um den Druckauftrag abzuschicken).

[PATH]

EXPORTPFAD=

Zuletzt eingestellter Pfad bei Export von Daten od. Tabellen in der Runtime.

REPORTS=

Tabellenpfad für BildDirekt od. Export od. Drucken Tabelle.

VIDEO=

Videopfad für *.avi Dateien in der Runtime.

LISTEN=

Listen- und Momentandrucke- Pfad für *.txt , *.qrf und *.frm Dateien.

BACKUP=

Pfad für Gesicherte Archivdateien
^ = (default = Datenbankverzeichnis).

[ARCHIV]

TRENNZEICHEN=;

Trennungszeichen für Export in ASCII-Dateien zwischen den Feldern

ARCHDIGITS=

Anzahl der Nachkommastellen beim Export von Archiven im Format TXT, XML und DBF sowie bei der Auslagerung auf einen SQL Server.
Default = 1

KANALAUSWAHL=1

Betrifft ETM-Archiv-Kanäle
1 in der Dialogbox für das auszuwählende Archiv wird die Checkbox alle Kanäle dargestellt
2 in der Dialogbox für das auszuwählende Archiv wird die Checkbox alle Kanäle ausgeblendet

SPEICHER=

Maximale Anzahl der in den Speicher zu lesenden Werte für den Erweiterten Trend, die Archiv-Nachbearbeitung, AML, CEL und die Tabellen.

Angabe in Kilobyte.

Z. B.: 2000000 für 2GB)

Default ab Version 6.20: 1000000 (=1 GB)

Achtung: Bei Archivdaten werden immer alle Werte eingelesen, auch wenn nur eine Variable angezeigt wird.

Hinweis: Vor dem Einlesen von Archivdateien (*.arx) wird der zur Verfügung stehende Platz überprüft. Wird mehr als die hier definierte Größe benötigt, wird das Einlesen abgebrochen und eine Fehlermeldung in das Protokoll des Diagnose Viewers geschrieben.

STATUSSPERRBIT=1

Hiermit wird ein Bit im Status definiert das als Archivsperre benutzt wird. Alle Werte, die dieses Bit im Status gesetzt haben, werden von der Archivierung durch den Ersatzwert mit INVALID ersetzt.
Zulässige Werte 0 bis 31.
Defaulteinstellung : -1 (inaktiv)

ZEIT_AUTOMATISCH=0

1: Für die Folgearchive wird eine automatische Zeitkorrektur um 1 Sekunde durchgeführt (z.B: um einen Wert von 24:00 Uhr auf den letzten Tag zu setzen => 23.59).
0: keine Korrektur.

CLIENTS_LOAD_LOCAL=0

1: Archivdateien werden am Client lokal gelesen und nicht vom Server geholt. Dies funktioniert nicht mit Chargenauswahl. Nur für das Archivformat *.arx und SQL-Auslagerung.

Achtung: Das setzen dieses Eintrags führt nicht dazu, dass die von der Runtime erzeugten Daten mit dem zenon Client synchronisiert werden. Die Archivdateien müssen manuell auf den Client kopiert werden.

SQL_MAXROWS=

Maximale Anzahl auszulesender Werte aus SQL. Eintrag erfolgt in 1.000er Schritten. 100 = 100.000 Werte.

Ab Version 6.50 wird zusätzlich automatisch überprüft, dass mindestens 10% Speicher frei sind.

[ARCHEDIT]

DATUMBREITE=

Zeichenanzahl der Datumsspalte in Archiv-Listbox.

VARIABLEBREITE=

Zeichenanzahl der Spalte für Variablenname.

WERTBREITE=

Zeichenanzahl der Wertspalte.

EINHEITBREITE=

Zeichenanzahl der Spalte für Maßeinheit.

STATUSBREITE=

Zeichenanzahl der Spalte für Status.

ZUSTANDBREITE=

Zeichenanzahl der Spalte für Grenzwerttext.

KENNUNGBREITE=

Zeichenanzahl der Spalte für Kennung der Variablen.

ARCHEDITFONT=

Schriftart

o.g. Einstellungen lassen sich Online mit Kontrollelement (Ansicht) einstellen

KURZBEZEICHNUNG=

1 Archivkurzbezeichnung wird in Tabelle angezeigt
0 Archivkurzbezeichnung wird nicht angezeigt

ZWANGSSPEICHERN=0

1 Nachführen von allen Einträgen in Folgearchiven
0 Nur geänderte Einträge nachführen (default)

[EXPORT]

OK_MESSAGEBOX=1

Messagebox Daten wurden erfolgreich exportiert.
1 Messagebox erscheint am Bildschirm.
0 Messagebox wird unterdrückt.

FILEEXIST_MESSAGEBOX

Messagebox Datei überschreiben
1 Messagebox erscheint am Bildschirm.
0 Messagebox wird unterdrückt.

FILEEXIST_OVERWR_APP_CAN=

0 OVERWRITE Datei wird überschrieben.
1 APPEND Datensätze werden angehängt.
2 CANCEL Export wird abgebrochen.

MAX_LAENGE=32

Maximale Länge des Variablennamen bei der Archivierung in die DBF-Datei, Default=32

[EW_TREND]

ANZEIGE_GWTEXT=0

Anzeige des GW-Textes kann ein- bzw. ausgeschaltet werden (betrifft Kurvenabscannen).

[PS3]

COM=com1:96,n,8,2

Einstellung der seriellen Schnittstelle

TYPE=PS32

Einstellung der SPS-Types der Verwendung findet (PS32/PS3XX)

[SAT-DRIVER]

Parameter des SAT-Treibers

DDE-SERVER=2

Version von DDE-Server
2 DDE-Server 2.0
3 DDE-Server 3.0
Defaultwert ist 2. Wird in den Versionen 3.51 und höher benutzt.

BUFFER_SIZE=300

Größe des Puffers, der Richtung Runtime geschickt wird. Der Puffer wird nach Bedarf vergrößert bis maximal BUFFER_SIZE_MAX.

BUFFER_SIZE_MAX=10000

Maximale Größe des Puffers der Richtung zenon RT (SICAM 230 RT) geschickt wird.

INTERN_BUFFER_SIZE=2000

Ab der Version 3.50 wird für die Kommunikation mit dem DDE-Server ein Ringpuffer verwendet. Seine Größe (Anzahl Werte die zwischengespeichert werden können) wird hier definiert.

TIMER_TIMEOUT_MSEC=500

Dauer der Pufferung in Millisekunden. Der Puffer kann auch öfter entleert werden.(Wenn z.B. die Daten vom gleichen Datenpunkt schnell nacheinander kommen oder beim Überlaufen des Puffers)

EZ_PUFFERGROESSE=200

Größe des Puffers für die Echtzeitdaten.

[RT]

Runtime-Einstellungen

CURSOR_STEPS=2

Anzahl der Bildpunkte, um die sich der Cursor bewegt, wenn er mit der Tastatur bedient wird.

ERSTE_TASTE=0

Werden Funktionen über einen Tastendruck ausgeführt, können alle mit dieser Taste verknüpften Funktionen ausgeführt werden (=0) oder nur die 1. gefundene Funktion (=1).

SELECTION_NORMAL=1

Kennzeichnung eines selektierten Eintrages in einer Listbox (Alarm oder Cel) mit einem Balken (=1) oder einem Rahmen (=0).

WITH_ACTION=1

für die Bedienung der Elemente wird das 1. Element unter dem Cursor verwendet (WITH_ACTION = 0) oder das 1. Element unter dem Cursor, das mit einer Aktion verknüpft ist (WITH_ACTION = 1).

NOT_WORKING_AKTIV=0

Es kann eingestellt werden, ob nach einer eingestellten Zeit ohne Bedienung eine Funktion automatisch ausgeführt werden soll. Mit diesem Eintrag wird die Ausführung ein- (=1) oder abgestellt (=0).

NOT_WORKING_TIME=60

Hier kann die Zeit in Minuten angegeben werden, nach der die oben genannte Funktion ausgeführt wird.

NOT_WORKING_FUNC=0

Nummer der Funktion, die nach der vergangenen Zeit ausgeführt werden soll.

WIN_CE=0

handelt es sich um ein CE compatibles Projekt (=1 manche Funktionen sind nicht zugänglich) oder nicht (=0..default: voller Funktionsumfang je nach Version).

TOUCHSCREEN=1

Automatisches Keyboard für Touchscreens anzeigen

[STATUS]

STATUS0=

Text für die Statusinformation, wenn Bit0 gesetzt ist. Es kann ein Kurz- und ein Langtext durch ; getrennt eingegeben werden.

STATUSx=

Wie STATUS0 mit Nummern x = 1 bis 63.

[TABELLE]

TRENNZEICHEN=

Trennzeichen der einzelnen Zellen beim Exportieren in der Runtime in *.TXT Format (z. B. - od. Tabulator mit TAB)

[SYSTEMTREIBER]

UPDATE_SEK=5

Zykluszeit des Systemtreibers in Sekunden.

WISCHER_BOXEN=
  • 0: Statt Hinweismessageboxen wird in der Runtime ein Beep ausgegeben (über Systemvariable können eigene Hinweisbilder aufgeschalten werden)
  • 1: Hinweismessageboxen werden wie bisher angezeigt.

WISCHER_BOXEN_USERLEVEL=

Nur aktiv, wenn WISCHER_BOXEN=1

  • 0: Bei unzureichender Bedienberechtigung wird Fehlermeldung angezeigt.
  • 1: Bei unzureichender Bedienberechtigung wird keine Fehlermeldung angezeigt..

[PROJEKTLINKS]

Parameter für gelinkte Projekte

LINK1=PROJEKTNAME

Definition Projektnamen

LINKPATH1=PROJEKTPFAD

Definition Projektpfad

GLINK=PROJEKTNAME

Definition Global Projektname

GLINKPATH=PROJEKTPFAD

Definition Global Projektpfad

[NETZ]

Netzwerk

SERVER=[Wert]

Wert -1:Netzwerk inaktiv, Einzelplatzrechner.
Wert >= 0: Netzwerk aktiv.

SERVER1=COMPUTER1

Server

SERVER2=COMPUTER2

Standby-Server

RELOADDELAY_SEC=

Nachladeverzögerung für Clients in Sekunden bei großen Netzwerkprojekten.

0: keine Verzögerung

[TOKEN]

Verwaltung der Bedienberechtigung im Netz

ACTIVE=0

Die Verwaltung der Bedienberechtigung kann mit diesem Eintrag aktiviert (=1) oder deaktiviert werden (=0).

QUIT_TIMEOUT=60

Wenn ein Client die Bedienberechtigung besitzt muss er diese zyklisch bestätigen. Fällt diese Bestätigung die hier eingestellte Zeit aus, verliert der Client den Token automatisch.

QUESTION_TIMEOUT=60

Wenn ein Rechner den Token benötigt, diesen aber ein anderer Rechner besitzt, wird um die Abgabe des Token abgefragt. Der den Token besitzende Rechner hat die hier eingestellte Zeit, um auf die Frage zu antworten.

[ED_REMOTE]

Remote Transport

DEVICE=1

Geräteart
0 Seriell
1 TCP/IP

CONFIG=CDSBG024;PORT=95;TIMEOUT=10

Geräte Konfigurationsstring für Serielle Baudrate oder für TCP/IP Portnummer

[DIRLIST]

Verzeichnisse für den Remote Transport

GLOBAL_AKTIV=1

0 Globalprojekt nicht abgleichen
1 Globalprojekt auch abgleichen

PROJECTBASE=Pfad

Ziel Basis Projektpfad

BITMAP=Pfad

Ziel Bitmappfad

BITMAP_AKTIV=1

0: Pfad nicht überprüfen
1: Pfad überprüfen

LISTEN=Pfad

Ziel Listenpfad

LISTEN_AKTIV=1

0: Pfad nicht überprüfen
1: Pfad überprüfen

VIDEO=Pfad

Ziel Videopfad

VIDEO_AKTIV=1

0: Pfad nicht überprüfen
1: Pfad überprüfen

REPORTS=Pfad

Ziel Reportpfad

REPORTS_AKTIV=1

0: Pfad nicht überprüfen
1: Pfad überprüfen

SOURCE_0=Pfad

Quelle Userpfad oder Datei

TARGET_0=Pfad

Zielverzeichnis für Userpfad oder Datei

AKTIV_0=1

0: Pfad nicht überprüfen
1: Pfad überprüfen

TYPE_0=0

0: Pfad nicht überprüfen
1: Pfad überprüfen

COMMENT_0=String

Userkommentar

[TEXTLIST]

Einstellungen für Sprachlisten

File#x=36

Der Editor merkt sich für das Fenster mit den Stringlisten die Dateien der Spalten (x=Nummer der Spalte z.B: 2).

Width#x=36

Der Editor merkt sich für das Fenster mit den Stringlisten die Breite der Spalte mit den Schlüsselwörtern (x=Nummer der Spalte z.B: 2).

TRANSLATE=1

1.Texte in den Bilder im Editor werden über die Sprachtabelle übersetzt.
0.Originaltexte anzeigen (z.B: @key).

TRANSLATE_INDEX=1

Index der Spalte, über die die Sprachübersetzung im Editor läuft.

[VERSION]

Informationen über die zenon Version, mit der das Projekt zuletzt bearbeitet wurde.
(Version ist nur aufwärts Kompatibel.)

VERSION1=

Der Editor merkt sich für das Projekt die Versionsnummer

VERSION2=

Der Editor merkt sich für das Projekt die Version

SP=

Zu jeder Version wird auch die Nummer des Service-Packs gespeichert.

PROJECT_VERSION_ACTIVE=

0: Versionierung inaktiv

1: Versionierung aktiv

Default: 0

XML_EXPORT_ACTIVE=

0: kein XML-Export bei Versionierung

1: XML-Export für Versionierung aktiv

Default: 0

PROJ_MAJOR=

Die vom Benutzer vergebene Nummer der Hauptversion.

PROJ_MINOR=

Die vom System automatisch inkrementierte Detail-Versionsnummer.

PROJ_TIMESTAMP=

Der Zeitpunkt der letzten Projektsicherung in UTC als Sekunden.

[PASSWORD]

Einstellungen für die Passwortverwaltung

LOGTEMP =1

Temporäres Einloggen für die Ausführung einer Funktion erlauben (1) oder verbieten (0).

[RS232LOG]

Einstellungen für die Protokollierung der seriellen Schnittstelle

LOGCOMx=0

Bei 1 wird eine Protokolldatei mit allen Daten welche über die serielle Schnittstelle x gesendet bzw. empfangen werden geschrieben. Die Logdatei hat den Namen LOG_COMxxx.TXT und liegt im Verzeichnis von welchem der Treiber gestartet wurde.

[RTDATEN]

Einstellungen für die Erzeugung Runtime änderbarer Daten

NOOVERWRITE_REZEPTE=0

Bei 1 wird die Rezeptgruppen DB nicht neu erzeugt und übertragen, wenn sie schon existiert

NOOVERWRITE_REZEPTUREN=0

Bei 1 wird rezeptur.cmp nicht neu erzeugt und übertragen, wenn sie schon existiert

NOOVERWRITE_PASSWORT=0

Bei 1 wird passwort.cmp nicht neu erzeugt und übertragen, wenn sie schon existiert

NOOVERWRITE_FPM=0

Bei 1 wird die fpm.cmp nicht neu erzeugt und übertragen, wenn sie schon existiert

[ERRORLOG]

Einstellungen für Erstellung und Inhalt der Fehlerdateien

CE_DRV_ERROR_FILE=0

Bei 1 wird auch unter CE ein Errorfile vom Treiber erzeugt.

[LON_32]

Einstellungen zum LON-Treiber

DIAG_LEVEL=0

Je nach Level werden Aktionen in der Fehlerdatei mitprotokolliert:
0 keine Protokollierung (Default)
1 Fehler
2 Schreiben
3 Lesen
4 Advise / Unadvise
5 Intern

[S7TCP32]

Einstellungen für den Treiber S7TCP32

FS=0

Bei 1 werden die Typen F&S DB Bit, F&S DB Byte, F&S Bit und F&S Byte angezeigt.

[TRANSPASS]

Remote Transport Passwort (auf Entwicklungsstation)

KEY=***

Passwort für Remote Transport

FIX=0

1: gespeichert

0: nicht gespeichert

NET=

Ist dieser Eintrag ungleich 0, so sendet der Editor nach dem Aufbau einer Remote Transport Verbindung eine Anfrage nach den Daten für die Konfiguration der Verschlüsselung ans Remote Gerät. Der Eintrag wird vom Dialog Verbindung aufbauen gesetzt und unmittelbar nach dem Versenden der Anfrage auf 0 zurückgesetzt.

[WORLDVIEW]

Weltbild-Darstellung

MarkCenter=
  • 0: keine Markierung einer ausgewählten Station
  • 1: bewirkt bei Anwahl einer Station eine kurzzeitige Markierung der Station im Bild

[PFM]

Einstellungen für Production and Facility Manager

AnzeigenMitStrg=

Steuert Anzeige des Dialogs beim Einfügen von kopierten Fahrplänen.

Werte:

  • 1: Der Dialog wird nur angezeigt, wenn beim Einfügen des Fahrplans die Taste Strg gedrückt wird.
  • 0: Der Dialog wird immer angezeigt.

Einträge ändern und übernehmen

Um Einträge, die in der project.ini gemacht werden, zu übernehmen, empfiehlt sich folgende Vorgehensweise:

  1. Projekt identifizieren: GUID notieren(die ersten 4-6 Stellen sind ausreichend) und Arbeitsbereich schließen bzw. Editor beenden
  2. zum SQL-Ordner navigieren: Im SQL Verzeichnis befindet sich ein Ordner mit der GUID Nummer
  3. zur project.ini navigieren: Unter /FILES/zenon/system in diesem GUID-Ordner befindet sich die Datei project.ini
  4. project.ini bearbeiten: Änderungen in der project.ini vornehmen, speichern und schließen
  5. Editor öffnen: Editor wieder öffnen bzw. das Projekt laden, geänderten Runtime-Dateien erzeugen und übertragen

info Info

Die project.ini wird unabhängig vom Projektnamen immer als project.ini im Pfad Project_SQL_Ordner/FILES/zenon/system/project.ini gespeichert.

Tipp: Markieren Sie das Projekt im Projektmanager -> drücken Sie die Tastenkombination Strg+Alt+E -> der Explorer öffnet den Ordner Project_SQL_directory/FILES/


startup.ini

Handbuch -> Dateiaufbau -> startup.ini

Hinweis: Einstellungen sollten prinzipiell im Startup-Tool vorgenommen werden. Änderungen in der startup.ini sind Experten vorbehalten.
Zur Zeit sind nur die Einstellungen zur Verschlüsselung der Kommunikation im Netzwerk dokumentiert.

Eintrag | Funktion
[Settings] |
USE_ENCRYPTION= | Verschlüsselung aktivieren oder deaktivieren: 0: inaktiv 1: aktiv Eintrag wird nach dem Setzen und Speichern im Startup Tool in die zenon6.ini übernommen.
ENCRYPTION_PWD | Hier wird das Passworts nach seiner Erstellung automatisch verschlüsselt eingetragen. Das Passwort wird rechnerabhängig verschlüsselt, daher führt ein identisches Passwort bei unterschiedlichen Rechnern zu unterschiedlichen Inhalten dieses Eintrags. Eintrag wird nach dem Setzen und Speichern im Startup Tool in die zenon6.ini übernommen.
PWD_VALIDATION= | Hash zur Überprüfung, ob sich die zur Verschlüsselung benutzen Daten verändert haben.


zenDB.ini

Handbuch -> Dateiaufbau -> zenDB.ini

Einträge in der zenDB.ini definieren die Verbindung zum SQL Server. Diese werden mit dem Startup Tool festgelegt.

Einträge in die zenDB.ini

Ab Version 7.00 SP0

Eintrag | Default Wert | Erklärung
[PATH] | keiner | Pfad
DB60_SQL2008= | keiner | Definiert den Pfad, unter dem die SQL-Datenbanken für die zenon Editor Projekte abgelegt werden. Beispiel: DB60_SQL2008=C:\ProgramData\COPA-DATA\SQL2008R2\
[CONNECTION_SQL2008] |  | Verbindungseinstellungen für SQL Server 2008 R2
USER= | Startup Tool: keiner Sonst: zenOnSrv | Definiert den Benutzernamen, mit dem sich der zenDBSrv am SQL Server anmeldet.
PW= | Startup Tool: keiner Sonst: srv_700 | Definiert das Passwort, das der zenDBSrv zur Authentifizierung gegenüber dem SQL Server verwendet. Das Passwort wird in der zenDB.ini verschlüsselt abgelegt. Der unverschlüsselte Defaultwert kann dennoch zum Verbindungsaufbau verwendet werden, da aufgrund dessen Länge der Entschlüsselungsversuch fehlschlägt und der Defaultwert direkt zum Verbindungsaufbau verwendet wird. Hinweis: Jede Komponente schreibt diesen Wert verschlüsselt in die INI-Datei.
SQLINSTANCE= | Startup Tool: keiner Sonst: localhost | Definiert die SQL Server Instanz, zu der sich der zenDBSrv verbindet. Mit dem Default-Wert kann keine Verbindung aufgebaut werden, da er keinen Instanznamen enthält. Vor dem Verbindungsaufbau wird „localhost" im Instanznamen durch den aktuellen Computernamen ersetzt. Beispiel: SQLINSTANCE=localhost\ZENON_2008R2
SQLPROVIDER= | Startup Tool: keiner Sonst: SQLNCLI10.1 | Optionaler Eintrag für den Provider, den der zenDBSrv verwendet, um die Datenbankverbindung herzustellen. Der Default Wert entspricht dem SQL Server 2008 R2 Native Client. Beispiel: SQLPROVIDER=SQLNCLI10.1

Version 6.51 SP0

Eintrag | Default Wert | Erklärung
[PATH] |  | Pfad
DB60_SQL2005= | keiner | Definition des Pfades. Beispiel: DB60_SQL2005=C:\ProgramData\COPA-DATA\SQL\
[CONNECTION_SQL2005] |  |
SQLSERVICE_SQL2005= | localhost\ZENON_DEV | Name des Service, der die SQL Server Instanz startet. Muss dem Eintrag PROVIDER_SQL2005= im Abschnitt Data Source entsprechen! Beispiel: SQLSERVICE_SQL2005=MSSQL$ZENON_DEV
USER= | keiner | Benutzer. Beispiel: USER=zenOnSrv
PW= | keiner | Passwort. Wird im Startup Tool vergeben und hier verschlüsselt abgelegt. Beispiel: PW=0x9C 0x94 0xC6 0x50 0x15 0x80 0x79 0x06 0x32 0xED 0x4E 0xE1 0x15 0xDD 0x7C 0x90
SQLINSTANCE= | keiner | SQL Instant. Beispiel: SQLINSTANCE=localhost\ZENON_DEV

Ab Version 6.21 SP0 bis Version 6.50 SP0

Eintrag

Default Wert

Erklärung

[PATH]

Pfad

DB60_SQL2005=

Keiner

Definition des Pfades.

Beispiel:
DB60_SQL2005=C:\ProgramData\COPA-DATA\SQL\

[CONFIG]

SQLSERVICE_SQL2005=

localhost\ZENON_DEV

Name des Service, der die SQL Server Instanz startet. Muss dem Eintrag Data Source im Abschnitt PROVIDER_SQL2005= entsprechen!
Beispiel:

SQLSERVICE_SQL2005=MSSQL$ZENON_DEV

PROVIDER_SQL2005=

Eintrag für den Provider, den der zenDBSrv verwendet, um die Datenbankverbindung herzustellen.
Beispiel:

PROVIDER_SQL2005=Provider=SQLNCLI.1;Password=srv_601;Persist Security Info=True;User ID=zenOnSrv;Initial Catalog=%s;Data Source=localhost\ZENON_DEV;

Bis Version 6.20 SP4

Eintrag | Default Wert | Erklärung
[PATH] |  | Pfad
DB60= |  | Beispiel: DB60=C:\SQL\
[CONFIG] |  |
SQLSERVICE= | MSSQL$ZENON | Definiert den Pfad, unter dem die SQL-Datenbanken für die zenon Editor Projekte abgelegt werden.
Provider= |  | Eintrag für den Provider, den der zenDBSrv verwendet, um die Datenbankverbindung herzustellen. Beispiel: Provider=Provider=SQLOLEDB.1;Password=zenon;Persist Security Info=False;User ID=sa;Initial Catalog=%s;Data Source=localhost\ZENON


zenon6.ini

Handbuch -> Dateiaufbau -> zenon6.ini

Hinweis: Projekteinstellungen sollten prinzipiell im Editor vorgenommen werden. Änderungen in der zenon6.ini sind Experten vorbehalten.

Parameter

Beschreibung

[DEFAULT]

Defaulteinstellungen

DEFANWENDUNG30=

Name des aktiven Projekts, das bei Programmstart geladen wird

DEFWORKSPACE=

Name des aktiven Arbeitsbereichs, der bei Programmstart geladen wird

LANGUAGE=

Voreingestellte Sprache
default = GERMAN
ENGLISH, ITALIAN

TIMER_FKT=

Wiederholrate bei der Zeitsteuerung
default = 5000 ? 5 Sekunden

WARTE_ZEIT=

Datenbank-Transaktionen werden nach der projektierten Zeit [s] erneut versucht.
Transaktionsbeginn wird in einer Schleife durchgeführt.
Default = 10

SERIAL7=

Seriennummer für Dongle- und Softwarelizensierung.

ACTIVATIONKEY7=

Verschlüsselte Aktivierung für Dongle- und Softwarelizensierung.

INTERVALL=900

Bei der Definition einer neuen Funktion in der Zeitsteuerung wird dieser Eintrag als Vorschlag für den Zyklus verwendet
(900 = 15 Minuten).

SERIALIZE=

Bilder Online als Binärdateien ablegen
0: nicht aktiv (default)
1: aktiv

STARTDELAY=

Verzögerung des Runtime-Starts beim Booten in ms.
Bei Problemen beim automatischen Starten des Betriebsystems kann der Start der Runtime mit dieser Einstellung verzögert werden. Damit hat das Betriebssystem entsprechend mehr Zeit, alle nötigen Dienste zu starten.

SCREENPROFILE=

Ausgewähltes Monitorprofil für diesen Rechner.

AUTOEXCEPTTIME=

Zeit für die Anzeige der Exception-Box in Sekunden.
Fehlt dieser Eintrag oder wird er auf 0 gesetzt, dann wird die Box angezeigt bis sie mit OK bestätigt wird.

RT_CXMAINFRAME=

Breite der Auflösung aller Monitore minus 1 Pixel.

Speichert gemeinsam mit RT_CYMAINFRAME= die Position und Größe des Runtime Fensters.

RT_CYMAINFRAME=

Breite der Auflösung aller Monitore minus 1 Pixel.

Achtung: Ist die Taskleiste eingeblendet, muss deren Höhe einbezogen werden und entsprechend mehr Pixel müssen subtrahiert werden.

Speichert gemeinsam mit RT_CXMAINFRAME= die Position und Größe des Runtime Fensters.

[FUNKTIONEN]

Funktionsverwaltung

LIST_BOX=

Letzte linke Position der Eingabemaske.

Format: links,oben,rechts,unten

kein Eintrag = Defaultposition verwenden

[DRUCKER]

Druckerzuordnung

ALARM=

Drucker für die Alarmmeldeliste oder CEL.

ALARM_OFFL=

Für Offline Ausdrucke kann ein eigener Drucker definiert werden. Ist kein Eintrag vorhanden, wird der Alarmdrucker verwendet.

ALARM_OFFL_PAGE=

Einstellung der Seite für den Alarmdrucker.

HDDRUCKER=

Drucker für Hard-Copy.

HDDRUCKER_PAGE=

Einstellung der Seite für den HardDisk Drucker.

LISTDRUCKER=

Drucker für allgemeine Listen.

LISTDRUCKER_PAGE=

Einstellung der Seite für den Listendrucker.

WERTE=

Drucker für die Ausgabe der Momentanwerte.

WERTE_PAGE=

Einstellung der Seite für den Wertedrucker.

[PATH]

Pfadeinstellung

EXE=

Pfad der EXE-Dateien (Programmordner).

VBF30=

Pfad zur aktuellen Projektdatenbank.

BILDER=

Pfad der BLD-Dateien.

DLL=

Pfad der DLL-Dateien (Programmordner).

GRAPHIK=

Pfad der Grafik-Dateien für den Grafikimport.

BITMAP=

Pfad der Bitmap-Dateien:

  • *.bmp
  • *.wmf
  • *.jpg
  • *png

ZUORDNUNG=

Nur mehr aus Kompatibilitätsgründen vorhanden.

EXPORTARV=

Pfad für manuell ausgelagerte Archive (*.arv).

WEB_PROJECT_PATH=

Pfad für die Runtime-Dateien des Webclients. Wenn dieser Eintrag nicht vorhanden ist, wird der Ordner %temp%\zenWebCli verwendet.

[EXPORT]

Export

AML_CEL_NEU=1

Export in dBase-Datei im Standardformat (0) oder wie im Editor für die entsprechenden Listenfenster projektierten Spalten (1).

[STATISCH]

Editoreinstellung

SUCHE=

Radius in Pixel für die Feststellung, wann ein Punkt eines Polygonzuges gleich einem anderen sein soll.
Default = 5

[SAT-DRIVER]

Einstellungen SAT-Treiber

DATENPUNKTAUFZEICHNEN=0

Adresse des in CS_PROT.TXT zu protokollierenden Datenpunktes .

Defaultwert: 0 - kein Datenpunkt wird protokolliert.

Ab Version 3.51 muss hier der Name der Variable eingetragen werden.

DATENPUNKTAUFZEICHNEN2=

Siehe DATENPUNKTAUFZEICHNEN.

DATENPUNKTAUFZEICHNEN3=

Siehe DATENPUNKTAUFZEICHNEN.

DATENPUNKTAUFZEICHNEN4=

Siehe DATENPUNKTAUFZEICHNEN.

CHECK_VARIABLES=0
  • 1: Die Variablen werden überprüft und die Ergebnisse in die Datei SAT_PROT.TXT geschrieben.
    Es werden alle Variablen, die nur auf einer Seite (DDE-Server oder SICAM 230) angemeldet sind, protokolliert.

Default: 0

KDA_BUFFERSIZE=200

Puffergröße.

KDA_TIMER_MSEC=30000

Abfragezyklus.

[RT]

DRIVER_QUE=0

Größe der Sendequeue zur Runtime.
(0=unbegrenzt)

DRIVER_COUNT=0

TMP-Eintrag für Treiber und Runtime

DYNRAHMEN=

Rahmen um Dynamische Elemente im Onlinebetrieb darstellen.
0: nicht darstellen
1: darstellen

RECT_ANZ=50

Einstellung für Optimierungsmaßnahmen.

Die neu darzustellenden Bereiche eines Bildes werden in Rechtecken gesammelt und anschließend neu gezeichnet. Nach Erreichen des festgelegten Werts werden die neuen Zeichenbereiche zum ersten Rechteck hinzugefügt.

[EDITOR]

Einstellungen im Editor

LASTWORKSPACE=1

1: Letzter Arbeitsbereich wird automatisch geladen
0: Editor startet ohne Arbeitsbereich zu laden

WORKSPACEVIEW=1

1: Arbeitsbereichsansicht aktiv
0: Arbeitsbereichsansicht inaktiv

SPOT=

Größe der Eckpunkte der Elemente
Default = 2

SUCHE=

Feststellen für gleichen Punkt bei Verschiebung
Default = 2

DYNRAHMEN=

Rahmen um die Dynamischen Elemente im Editor anzeigen:
0: nicht aktiv
1: aktiv (Default)

RASTER=

Im Raster positionieren:
0: nicht aktiv
1: aktiv (Default)

RASTER_GRID=

Raster anzeigen:
0: nicht aktiv (Default)
1: aktiv

RASTER_ABSTAND_X=

Rasterabstand horizontal in Pixel.
Default = 5

RASTER_ABSTAND_Y=

Rasterabstand vertikal in Pixel.
Default = 5

KOORD_GLOBAL=

Anzeigekoordinatenart:
0: Pixelkoordinaten (Default)
1: Weltkoordinaten

EINGABE_SOFORT=0

Aufruf der Eingabemaske eines Elements bei Erzeugung:

  • 0: nein
  • 1: sofort

SELECT_INVERSE=1

Inversion des Hintergrunds:

  • 1: Selektion eines Elements wird durch die Inversion des Hintergrundes dargestellt. Bei manchen Farben (z.B: dunkelgrau) ist diese schwer zu erkennen.
  • 0: Bei 0 wird dafür die Farbe von SELECT_COLOR verwendet.

SELECT_COLOR=rot

Farbe, die im Editor für die Kennzeichnung der selektierten Elemente verwendet wird, wenn SELECT_INVERSE inaktiv ist.

RUECK_ANZ=10

Anzahl der Aktionen, die rückgängig gemacht werden können.

KONVERT=0

Beim Einlesen von Projekten vor Version 3.51 SP3 kann es zu Verschiebungen der Elemente kommen. Um dies zu verhindern, werden beim Öffnen eines Bildes zusätzliche Checkboxen angeboten, über die die Konvertierung eingestellt werden kann.

1: aktiv

WINDOW=3,109,181,589,661

Der Editor merkt sich beim Schließen seine aktuelle Position und legt diese in der zenon6.ini ab. Beim nächsten Start wird er an der gespeicherten Position gestartet.

Erste Zahl: legt fest,ob das Fenster minimiert, maximiert oder normal dargestellt wird.

Weitere Zahlen: Position von der linken oberen Ecke aus.

KEY_WIDTH=36

Der Editor merkt sich für das Fenster mit den Stringlisten die Breite der Spalte mit den Schlüsselwörtern.

SYMBOL_COLOR=16777215 (=weiss)

Hintergrundfarbe des Symbols im Symboleditor, um den verfügbaren Zeichenbereich besser erkennen zu können.

POST_BUILD_STEP=

Nach dem Erzeugen von Runtime-Dateien wird das hier angegebene Programm automatisch ausgeführt:

Parameter1: Projektname

Parameter2: Projektpfad

[VBA]

Parameter für Visual Basic for Applications

EIN=1

VBA aktivieren
0: aus
1: ein

EVENT=1

VBA Events (Ereignisse) aktivieren
0: aus
1: ein

BREAK=1

VBA Meldungsbox bei Fehler mit Abfrage für Debuggen während der Runtime aktivieren
1: ein (default)
0: aus

[VSTA]

Parameter für VSTA

ON=1

1: VSTA aktiviert (default)

0: VSTA deaktiviert

CSHARP=1

VSTA Programmiersprache für Editor ->

1: C#

0: VB.NET

LOADED=1

1: VSTA Add-in für Editor wird beim Start geladen

0: Beim Editor-Start wird über einen Dialog abgefragt, ob das VSTA Add-in geladen werden soll.
Hinweis: Führt ein fehlerhaftes Add-in zum Absturz des Editors, wird der Eintrag automatisch auf 0 gesetzt.

[SYMBOL]

SICHTBAR=

Legt fest, ob Symbolliste bei Programmstart sichtbar ist:
1: sichtbar (default)
0: nicht sichtbar

SUBSTITUTE=

Soll beim Einfügen eines Symbols in einem Bild die Ersetzen-Funktion verwendet werden

  • 1: Ja (Default)
  • 0: nein

Die Funktion wirkt sich nur bei Elementen aus, die mit mindestens einer Variablen verknüpft sind.

VORSCHAU=

Legt fest. ob das Vorschaufenster angezeigt wird:

  • 1: ja (Default)
  • 0: nein

Abschalten (0) spart Platz im Editor.

BREITE=

Eingestellte Bildschirmbreite bei der letzten Bearbeitung.

HOEHE=

Eingestellte Bildschirmhöhe bei der letzten Bearbeitung.

LINKS=

Definiert linken Rand des Fensters.

RECHTS=

Definiert rechten Rand des Fensters.

TOP=

Definiert oberen Rand des Fensters.

BOTTOM=

Definiert unteren Rand des Fensters.

STRETCHED=1

Anzeige der Symbole im Vorschaufenster:

  • 1: Anpassung an Größe des
  • 0: Seitenverhältnis wird beibehalten

[VarListBox]

Einstellungen für Variablenliste

SINGLE=

Position der Variablenliste (Einfachselektion) bei der letzten Anzeige (kein Eintrag Defaultgröße).

Format: links, oben, rechts, unten

MULTI=

Rechte Position der Variablenliste (Mehrfachselektion) bei der letzten Anzeige (kein Eintrag =Defaultgröße).

Format: links, oben, rechts, unten

[ALARM]

Alarmverwaltung

RAS_AML_INIT=0

0: inaktiv (Default)
1: Beim Start des RAS Clients werden alle AML-Dateien kopiert

[NETZ]

Netzwerk-Einstellungen

QUESIZE=5000

Im Netzwerk maximale Objektanzahl in Queue.
Default = 5000

NET_TIMEOUT_MSEC=

Timeout für Netzwerkkommunikation in Millisekunden.
Default = 30000

NET_NETMODULE_TIMEOUT_MSEC=

Timeout für Modulkommunikation in Millisekunden.
Default = 30000

NET_CONNECTCOUNT=

Wiederholungen des TCP/IP Connects am Client.

0: sofortige Wiederholung
Default = 0

NET_CONNECTWAIT_MSEC=30000

Wartezeit nach einem fehlgeschlagenen TCP/IP Connect am Client in Millisekunden .
Default = 30000

USEIPV6=

Regelt die Verwendung von IPv6.

1: Aktiv, alle TCP-Verbindungen werden ausschließlich über IPv6 aufgebaut.

0: Inaktiv, alle TCP-Verbindungen werden ausschließlich über IPv4 aufgebaut.

Dualer Betrieb ist nicht möglich.

Hinweis: Wird diese Option geändert, müssen alle laufenden zenon Prozesse neu gestartet werde. Das betrifft insbesondere zenAdminSrv, zenSysSrv, zenLogSrv und zenDBSrv.

Folgende Komponenten sind von der Einstellung nicht betroffen:

  • Treiberkommunikation mit den Steuerungen
  • Protokollkommunikation in den ProcessGateway-Plugins
  • Workbench- und Runtimekommunikation in zenon Logic

Achtung: Funktioniert nur ab Version 7. Bei aktiver Option können keine Versionen vor 7 gestartet werden.

WAN=

Client-Verbindung zum Server :
0: LAN (default)
1: WAN

WAN_IDLETIME=

WAN Leerlaufzeit.
Nach dieser Zeit wird die Verbindung zum Server oder Client geschlossen.
Default = 30000 ms

TIMESYNCH=

1: = Zeit wird mit einem Serverprojekt abgeglichen (Default)
0: =Zeit wird nicht abgeglichen (z.B für Kreisredundanz)

USE_ENCRYPTION=

Verschlüsselung aktivieren oder deaktivieren:

0: inaktiv

1: aktiv

ENCRYPTION_PWD

Hier wird das Passworts nach seiner Erstellung automatisch verschlüsselt eingetragen. Das Passwort wird rechnerabhängig verschlüsselt, daher führt ein identisches Passwort bei unterschiedlichen Rechnern zu unterschiedlichen Inhalten dieses Eintrags.

PWD_VALIDATION=

Hash zur Überprüfung, ob sich die zur Verschlüsselung benutzten Daten verändert haben.

NET_PROXYPORT=

Port für die Verbindung vom Webclient zum Webserver: Webserver lauscht am Port, Webclient verbindet sich zum Port.
Default:

  • TCP: 1102
  • HTTP: 8080

POLLING_INTERVALL=

Wartezeit in Millisekungen, bis der Webclient erneut eine HTTP-GET-Anfrage zum Webserver sendet, wenn der Puffer für eine Verbindung leer ist.

Default: 2000

[IPADDR]

Nur unter Windows CE.

Da unter CE keine HOSTS Datei unterstützt wird, werden Computernamen über eine Zuordnungsliste den IP-Adressen zugeordnet.

Man benötigt diese Liste nur in Netzen ohne DNS. Ist ein DNS-Server vorhanden, löst Windows CE den Namen selbst auf.
Die Liste kann nur von Hand mit einem Texteditor eingestellt werden. Im Normalfall muss nur die Adresse des projektierten Servers eingetragen werden.

COMPUTERNAME1=

Ordnet dem Computer die IP-Adresse zu. Zum Beispiel:

COMPUTERNAME1=192.52.109.62

COMPUTERNAME2=192.52.109.63

Achtung: Alle Einträge (Computernamen) müssen großgeschrieben sein, sonst werden sie nicht erkannt

[MESSAGE CONTROL]

Einstellungen für das Modul Message Control.

Einträge und deren Konfiguration siehe Abschnitt Message Control.

[TERMINAL]

Einstellungen für Terminalserver

CLIENT=

Mögliche Werte:

  • 0: Die Runtime kann nur einfach gestartet werden. Ein Betrieb am Terminal Server ist nicht möglich.
  • 1: Terminalserver wird verwendet. Die Runtime kann mehrfach gestartet werden, alle Einstellungen für Terminal Server Betrieb werden von der Runtime automatisch vorgenommen.

Default: 0

CLIENT_NO_FILE_ALIGN=

Parameter für Abgleich der Clients mit Server:

  • 0: Projekte werden immer von allen Clients nachgeladen.
  • 1: selektiver Abgleich aktiv.
    Nur der zenon Client, der in der Konsolen-Session des Terminal-Servers gestartet wird, gleicht die Runtime-Dateien mit dem zenon Server ab

SERIALIZE=

Definition der Bildauflösung:

  • 0: Bildauflösung individuell, alle Bilder werden für jeden Client neu berechnet
  • 1: Erster gestarteter Client legt Bildauflösung fest.

[editor/CustomMenu]

Einträge für das benutzerdefinierte Menü im Editor

Name#0=

Eintrag im Menü für Programm 0.

File#0=

Name der auszuführenden Datei für Menüeintrag 0.

Arguments#0=

Parameter für Programmausführung.

[PASSWORD]

Einstellungen für die Passwortverwaltung

LOGOFF=0

Zeit in Minuten für automatisches Ausloggen ohne Bedienaktion.

[Befehlsgabe]

TYP=

Type des Befehlsfensters
(Sonderanwendung = DBAG)

POSITION=

Definiert Position und Größe der Login/Logout-Maske:
xlinks, xrechts, yoben, yunten
Wertbereich von 0 bis 1
Default: 0.001 , 0.999 , 0.835 , 0.964

SCHRIFT=

Schriftart im Onlinebetrieb
default = -13,0,0,0,400,0,0,0,0,3,2,1,34,Arial

CODE=

Codenummernabfrage
0: aus (default)
1: ein

Befehlsstring=

Protokollierung von Befehl: in CEL bei Befehlsgabe
1: = aktiv (default)

CodeKontrolle=

Plausibilitätsprüfung bei Codenummernabfrage:
0: aus (default)
1: ein

TASTE=

Tastenbelegung für Zweihandbedienung
kein Eintrag -> Einhand
RETURN
SPACE
F2..F12
A..Z 0..9
default = keiner

[TRANSPASS]

Remote Transport Passwort (auf Remote Station)

KEY=***

Passwort für Remote Transport

FIX=0

1: gespeichert

0: nicht gespeichert

InitWait=0

Wartezeit bei einem lokalen Treiberstart. zenon RT wartet eingestellten Zeitraum in Millisekunden, damit der Treiber richtig startet.

Wird erfahrungsgemäß nur unter Windows 95 wegen schlechtem Multitasking-Verhalten gebraucht.

Richtwert: =500 ms

[STATISCH]

SUCHE=5

Beendigung eines Polygonzuges: Radius in Pixel für die Feststellung, wann ein Punkt gleich einem anderen sein soll. Ist der Eintrag nicht vorhanden, wird der Defaultwert angenommen.

Default: 5

[EW_TREND]

AUTOSKALIERUNG=0

Definiert, ob Autoskalierung per Default aktiviert ist oder nicht.

[SYS_REMOTE]

Verwaltung der Remote Transport Parameter im Netzwerk.

Konfiguration des Diagnose Servers siehe Kapitel: Konfiguration Diagnose Server über zenon6.ini

CONFIG=

Konfigurationsstring für zenSysSrv . Remote Transport und Diagnose-System verwenden bis inklusive Version 6.51 SP0 die gleiche Serverkonfiguration. Details für Konfiguration, vor allem ab Version 7 siehe Kapitel: Konfiguration Diagnose Server über zenon6.ini

Der String besteht aus folgenden Teilen: DEVICE=[Device];HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout].

  • DEVICE: setzt die verwendete Kommunikationsart.
    TCP/IP und seriell stehen zur Verfügung.
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Verbindungs-Timeoutzeit in Sekunden an.
  • BAUD: gibt die Verbindungsgeschwindigkeit einer seriellen Verbindung an.

Konfiguration PC:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=1101
  • TIMEOUT=10

Konfiguration CE:

  • DEVICE=COM1
  • BAUD=115200

[SIMULATOR]

OFFSET=0

Offset für Steuervariablen im Simulator.

DWBEGIN=

Beginn der DWORD Variablenadressen.

DWEND=

Ende der DWORD Variablenadressen.

FLOATBEGIN=

Beginn der Float Variablenadressen.

FLOATEND=

Beginn der Float Variablenadressen.

UPDATE=

Updaterate in Millisekunden.
Default: 500 (= 0,5 Sekunden)

BACKUP=1

0: HD-Werte werden nicht auf Festplatte gesichert.
1: HD-Werte werden auf Festplatte gesichert (Default).

MAXHDVALS=1024

Gibt den größten Offsetbereich-1 bei den HD-Daten an. Bei HD-String muss der Offset um 4 unterhalb dieses Wertes bleiben.

Default: 1024

DIAG_LEVEL=
  • 1: Diagnose in der Fehlerdatei mitschreiben (Sollwerte setzen)
  • Default: 0

info Info

Die zenon6.ini finden Sie im Pfad:

Windows Vista/7: C:\ProgramData\COPA-DATA\System\

Windows XP: C:\Dokumente und Einstellungen\All users\Anwendungsdaten\COPA-DATA\System

Noch in diesem Kapitel

Konfiguration Diagnose Server über zenon6.ini

Message Control


Konfiguration Diagnose Server über zenon6.ini

Handbuch -> Dateiaufbau -> zenon6.ini -> Konfiguration Diagnose Server über zenon6.ini

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 7 werden Remote Transport und Diagnose über zwei unterschiedliche Dienste abgewickelt. Sind auf einem Gerät sowohl alte als auch neue Diagnose Clients bzw. Diagnose Server vorhanden, können diese über INI-Einträge unabhängig voneinander konfiguriert werden. So können zum Beispiel die LOG-Einträge von alten Diagnose Clients umgeleitet werden, ohne dass die LOG-Einträge neuer Diagnose Clients berührt werden.

Diagnose Server vor Version 7.00 SP0

INI Eintrag

Erklärung

[SYS_REMOTE]

Abschnitt in zenon6.ini.

Enthält Parameter für zenSysSrv (Remote Transport und Diagnose Server).

LOGDirectory=

Definiert Ordner für die LOG-Dateien.

Ist der Eintrag nicht vorhanden, wird als Standardwert der LOG-Ordner im ProgramData-Ordner der verwendeten Version herangezogen.

Beispiel:
LOGDirectory= %ProgramData%\COPA-DATA\zenon651\LOG

CONFIG=

Konfigurationsstring für den Diagnose Server und den zenSysSrv . Remote Transport und Diagnose-System verwenden bis inklusive Version 6.51 SP0 die gleiche Serverkonfiguration. Der String besteht aus folgenden Teilen: DEVICE=[Device];HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart.
    TCP/IP und seriell stehen zur Verfügung.
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.
  • BAUD: gibt die Verbindungsgeschwindigkeit einer seriellen Verbindung an.

Konfiguration PC:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=1101
  • TIMEOUT=10

Konfiguration CE:

  • DEVICE=COM1
  • BAUD=115200

LOGMinFreeDiskSpace=

Definiert Speicherplatz in MB, der mindestens auf der Festplatte frei bleiben muss. Bevor dieser Wert unterschritten wird, werden LOG-Dateien gelöscht.

Default: 1024

LOGMaxUsedDiskSpace=

Definiert den maximal für LOG-Dateien verwendeten Speicherplatz in MB auf der Festplatte. Wird dieser Wert überschritten, werden LOG-Dateien gelöscht.

Default: 1024

LOGMinUsedDiskSpace=

Definiert Speicherplatz in MB auf der Festplatte, der belegt wird, auch wenn keine LOG-Dateien vorhanden sind.

Default: 5

LOGLogLifeTime=

Definiert die Lebensdauer der LOG-Dateien in Sekunden. Ältere LOG-Dateien werden gelöscht.

Default: 1209600 (entspricht 14 Tagen)

LOGImageCnt=

Definiert die Anzahl der LOG-Einträge, nach denen alle inkrementellen LOG-Felder geschrieben werden.

Default: 0

LOGLogUpdateTime=

Anzahl von Millisekunden, nach der erhaltene LOG-Einträge in eine LOG-Datei geschrieben werden.

Default: 2000

LOGMaxBufferedRecs=

Definiert die Anzahl an LOG-Einträgen, die gepuffert werden, wenn nicht in Dateien geschrieben werden kann.

Default: 10240

LOGMaxLogFileSize=

Maximale Größe einer LOG-Datei in Byte. Hat eine LOG-Datei diese Größe erreicht, wird sie geschlossen und eine neue LOG-Datei wird erstellt.

Default: 5242880 (entspricht 5 MB)

LOGCheckDiskTime=

Definiert das Intervall in Sekunden, in dem der von LOG-Dateien belegte Speicherplatz geprüft wird.

Default: 60

INIT=

Aktion beim Starten der Anwendung unter Windows CE :

  • 0: sofort wieder beenden
  • 1 (oder anderer Wert größer 2): Listening Port öffnen und in System Tray minimieren
  • 2: nur Oberfläche anzeigen

Default: 1

Hinweis: Im Zuge der Trennung von zenSysServ und zenLogServ für zenon 7.00 wurde dieser Defaultwert auch für andere Versionen umgestellt. Davor war der Defaultwert 2.

Diagnose Server ab Version 7.00 SP0

INI Eintrag

Erklärung

[LOGGING_SYSTEM]

Abschnitt in zenon6.ini.

Enthält Parameter für Diagnose Server. Betrifft nur zenLogSrv und hat keine Auswirkung auf zenSysSrv.

LOGDirectory=

Definiert Ordner für die LOG-Dateien.

Ist der Eintrag nicht vorhanden, wird als Standardwert verwendet:

der aus der Registry extrahierte Pfad
z.B. %ProgramData%\COPA-DATA\LOG

der LOG-Ordner im ProgramData-Verzeichnis des zenLogSrv, falls in der Registry kein Pfad definiert wird
z.B. %ProgramData%\COPA-DATA\zenon700\LOG

CONFIG=

Konfigurationsstring für den Diagnose Server. Der String besteht aus folgenden Teilen: DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart und muss immer auf TCP/IP gesetzt werden
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.

Konfiguration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=50780
  • TIMEOUT=10

LOGMinFreeDiskSpace=

Definiert Speicherplatz in MB, der mindestens auf der Festplatte frei bleiben muss. Bevor dieser Wert unterschritten wird, werden LOG-Dateien gelöscht.

Default: 1024

LOGMaxUsedDiskSpace=

Definiert den maximal für LOG-Dateien verwendeten Speicherplatz in MB auf der Festplatte. Wird dieser Wert überschritten, werden LOG-Dateien gelöscht.

Default: 1024

LOGMinUsedDiskSpace=

Definiert Speicherplatz in MB auf der Festplatte, der belegt wird, auch wenn keine LOG-Dateien vorhanden sind.

Default: 5

LOGLogLifeTime=

Definiert die Lebensdauer der LOG-Dateien in Sekunden. Ältere LOG-Dateien werden gelöscht.

Default: 1209600 (entspricht 14 Tagen)

LOGImageCnt=

Definiert die Anzahl der LOG-Einträge, nach denen alle inkrementellen LOG-Felder geschrieben werden.

Default: 0

LOGLogUpdateTime=

Anzahl von Millisekunden, nach der erhaltene LOG-Einträge in eine LOG-Datei geschrieben werden.

Default: 2000

LOGMaxBufferedRecs=

Definiert die Anzahl an LOG-Einträgen, die gepuffert werden, wenn nicht in Dateien geschrieben werden kann.

Default: 10240

LOGMaxLogFileSize=

Maximale Größe einer LOG-Datei in Byte. Hat eine LOG-Datei diese Größe erreicht, wird sie geschlossen und eine neue LOG-Datei wird erstellt.

Default: 5242880 (entspricht 5 MB)

LOGCheckDiskTime=

Definiert das Intervall in Sekunden, in dem der von LOG-Dateien belegte Speicherplatz geprüft wird.

Default: 60

INIT=

Aktion beim Starten der Anwendung unter Windows CE:

  • 0: sofort wieder beenden
  • 1 (oder anderer Wert größer 2): Listening Port öffnen und in System Tray minimieren
  • 2: nur Oberfläche anzeigen

Default: 1

Diagnose Client vor Version 7.00 SP0:

INI Eintrag

Erklärung

[SYS_REMOTE]

Abschnitt in zenon6.ini.

Enthält Parameter für Diagnose Client.

LOG_CONFIG=

Hier wird ein Konfigurationsstring für den Diagnose Client abgelegt. Der String besteht aus folgenden Teilen: DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart und muss immer auf TCP/IP gesetzt werden
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.

Konfiguration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=1101
  • TIMEOUT=10

Diagnose Client ab Version 7.00 SP0

INI Eintrag

Erklärung

[LOGGING_SYSTEM]

Abschnitt in zenon6.ini.

Enthält Parameter für Diagnose Client.

LOG_CONFIG=

Hier wird ein Konfigurationsstring für den Diagnose Client abgelegt. Der String besteht aus folgenden Teilen:

DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart und muss immer auf TCP/IP gesetzt werden
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.

Konfiguration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=50780
  • TIMEOUT=10

Hinweise

INIT unter CE

Unter Windows CE wird dringend empfohlen, den Eintrag INIT= (im Abschnitt [LOGGING_SYSTEM]bzw. [SYS_REMOTE]) nicht auf den Wert 2 zu setzen.

Grund: Der Wert 2 führt dazu, dass sowohl SysSrvCE als auch LogSrvCE nur die Oberfläche anzeigen und den Listening Port nicht öffnen.
Möchte nun ein Diagnose Client eine Verbindung aufbauen, schlägt das fehl. Da Diagnose Clients in diesem Fall den LogSrvCE als Prozess starten und dieser den Port nicht öffnet, startet jeder einzelne Diagnose Client einen solchen Prozess. Das führt zu vielen parallelen LogSrvCE Prozessen und zu einer Verzögerung beim Starten der Diagnose Clients, da diese beim Herstellen der Diagnose-Verbindung auf das Timeout der Verbindung warten.

zenLogSrv auf einem System mit verschiedenen Versionen

Wird der zenLogSrv auf einem System mit verschiedenen Versionen als zentraler lokaler Diagnose Server verwendet, muss der Eintrag LOG_CONFIG im Abschnitt [SYS_REMOTE] wie folgt lauten:
DEVICE=TCP/IP;HOST=localhost;PORT=5780;TIMEOUT=10

Grund: Ältere Clients verwenden dann den zenLogSrv als Diagnose Server. Neue Clients machen das automatisch. Am PC wird dieser als Dienst automatisch beim Systemstart gestartet, unter CE muss er händisch gestartet werden.

Achtung: Ist der Port nicht erreichbar, starten ältere Clients den zenSysSrv und versuchen erneut eine Verbindung mit diesem herzustellen.


Message Control

Handbuch -> Dateiaufbau -> zenon6.ini -> Message Control

Die globalen Eigenschaften für den Versand von Nachrichten im Modul Message Control werden in der zenon6.ini im Abschnitt [MESSAGE CONTROL] gespeichert.

Eintrag | Erklärung
[MESSAGE CONTROL] | Abschnitt in der zenon6.ini
Outlook_Profile= | Name des Outlook Profils, das für den Versand benutzt werden soll. Default: leer
Outlook= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
Subject= | Eindeutige ID, die eingehende Mails wieder enthalten müssen, um in Message Control verarbeitet zu werden. Default: leer
Telephone_Timeout= | Zeit in Minuten, nach der eine stehende Verbindung abgebrochen und beendet werden soll. Zeitintervall muss länger sein als die für das Abspielen und Bestätigen der Nachricht benötigte Zeit. Default: 1
Telephone_WelcomeMessageCount= | Anzahl der Wiederholungen für den Willkommenstext. Default: 5
Telephone_IgnoreDisconnect= | 1: Ein Verbindungsabbruch (z. B. Empfänger beendet Gespräch) wird ignoriert und die Nachricht wird vollständig abgespielt, bevor die Leitung geschlossen wird. 0: Nachricht wird abgebrochen, wenn Verbindung abbricht. Default: 0
Telephone= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
Speech= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
Speech_Rate= | Geschwindigkeit der Stimme. Minimum: -10 Maximum: 10 Default: 0
Speech_Volume= | Lautstärke der Stimme. Zahl entspricht dem Prozentwert vom Maximalwert der gewählten Stimme. Maximum: 100 Minimum: 1 0: Wert vom Betriebssystem wird ohne Änderung übernommen. Default: 0
Speech_Name= | Auswahl der Stimme und Sprache Default: leer
SMSGateway= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
SMSGateway_Inbox= | Eingangsordner für SMS-Versand. Default: leer
SMSGateway_Outbox= | Ausgangsordner für SMS-Versand. Default: leer
SMSGateway_Statusbox= | Ordner für Statusmeldung bei SMS-Versand. Default: leer
SMSGateway_Prefix= | Anfangsbuchstabe der SMS-Dateien. Länge: 1 Zeichen Default: F
SMSGateway_SemaphorPrefix= | Anfangsbuchstabe der Sperrdatei. Länge: 1 Zeichen Default: S
SMSGateway_OriginId= | Absenderkennung für SMS-Versand. Default: leer
SMSGateway_TimeOut= | Timeout-Zeit für ausgehende Nachrichten in Minuten. Legt fest, nach welcher Zeitspanne einen Nachricht als "nicht erfolgreich verschickt" interpretiert wird. Default: 60
SMSGateway_SmartAlarm= | Smartalarming wird verwendet. Default: 0
SMTP_POP_MAIL= | Der Eintrag bestimmt, ob die Versandart aktiv ist. 1: aktiv 0: inaktiv Default: 0
SMTP_SRV_IS_POP= | Der Eintrag bestimmt, ob der POP3 Server als SMTP Server verwendet wird. 1: POP 3 ist SMTP 0: POP3 und SMTP sind unterschiedliche Server Default: 0
SMTP_SERVER= | Der vom Benutzer eingegebene SMTP Server. Default: leer
SMTP_PORT= | Definiert den verwendeten Port am SMTP Server. Default: 25
SMTP_SECURITY= | Art der Absicherung der Verbindung zum SMTP Server. 0: keine Absicherung 1: SSLv2 und SSLv3 2: TLSv1 Default: 0
SMTP_AUTH= | Authentifizierung am Postausgangsserver. 0: keine Absicherung 1: vor Versand am POP3 Server anmelden 2: SMTP AUTH Default: 0
SMTP_OTHER_CREDS= | Legt fest, ob der Postausgangsserver andere Anmeldedaten als der Posteingangsserver verwendet. 0: inaktiv 1: aktiv Default: 0
SMTP_USER= | Benutzername für den Postausgangsserver gespeichert. Default: leer
SMTP_PASSWORD= | Hex-Dump des verschlüsselten Passwortes zur Authentifizierung am Postausgangsserver. Default: leer
SMTP_SUBJECT= | Betreff für ausgehende E-Mails und zur Erkennung, ob eine eingehende E-Mail am Server für die Versandart relevant ist. Default: MsgCtrl_Alert
SMTP_USER_IS_ADDR= | Definiert, ob der Benutzername für die Authentifizierung gegenüber dem Postausgangsserver als Absenderadresse für ausgehende Mails verwendet wird. 1: aktiv 0: inaktiv Default: 0
SMTP_OUT_ADDR= | Adresse für ausgehende E-Mails. Default: leer
POP_SERVER= | POP3 Server gespeichert. Default: leer
POP_PORT= | Definiert den verwendeten Port am POP3 Server. Default: 110
POP_SECURITY= | Art der Absicherung der Verbindung zum POP3 Server. 0: keine Absicherung 1: SSLv2 und SSLv3 2: TLSv1 Default: 0
POP_APOP= | Legt fest, ob das APOP-Kommando verwendet werden soll. 1: aktiv 0: inaktiv Default: 0
POP_KEEP_MAILS= | Legt fest, ob gelesene E-Mails am Server belassen werden. 1: E-Mails werden nach dem Abruf am Server nicht gelöscht 0: E-Mails werden nach dem Abruf am Server gelöscht Default: 0
POP_USER= | Benutzername für den Posteingangsserver. Default: leer
POP_PASSWORD= | Hex-Dump des verschlüsselten Passwortes zur Authentifizierung am Posteingangsserver gespeichert. Default: leer
POP_POLL_INTERVALL= | Minimaler Abstand zwischen zwei POP3-Abfragen in Sekunden. MInimal: 10 Default: 60
GSM_SMS= | Aktivierung von SMS über GMS als Versandart. 0: aktive nicht 0: inaktiv Default: 0 Der Eintrag entspricht in der Message32.ini dem Eintrag [GSM] à On und wird beim Importieren/Exportieren der INI-Einstellungen berücksichtigt.
GSM_SMS_COM= | COM-Port, der für die Verbindung zum Modem verwendet wird. Default: leer
GSM_SMS_SMSC= | Telefonnummer der Kurzmitteilungszentrale des GSM-Providers. Default: leer
GSM_SMS_PIN= | PIN-Code, der zur Authentifizierung gegenüber dem Modem verwendet wird. Default: leer

info Info

Da manche Eigenschaften die Werte anderer Eigenschaften übernehmen können und sich die zuletzt eingegebenen Werte merken, müssen die Werte der INI-Einträge nicht immer mit den im Editor angezeigten Werten der Eigenschaften übereinstimmen. Betroffen sind davon folgende Eigenschaften, wenn sie als nicht verfügbar dargestellt werden:

SMTP_SERVER -> Serveradresse

Interne ID: Message Control

Serveradresse

Nur verfügbar, wenn Posteingangsserver für ausgehende E-Mails verwenden inaktiv ist.

Interne ID: Message Control

Posteingangsserver für ausgehende E-Mails verwenden

Aktiv: Der Posteingangsserver wird als Server für den Postausgang verwendet. Diese Eigenschaft betrifft nur die Serveradresse.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Vollständige Adresse des SMTP Servers.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SMTP_USER -> Benutzername

Interne ID: Message Control

Benutzername

Benutzername für den Postausgangsserver.

Nur verfügbar, wenn Andere Anmeldedaten als am Posteingangsserver verwenden aktiviert wurde. Ist die Eigenschaft inaktiv, wird der Benutzername aus der Eigenschaft Benutzername in der Gruppe Posteingangsserver angezeigt. Sonst wird der zuletzt eingegebene Benutzername für den Postausgangsserver angezeigt.

Interne ID: Message Control

Posteingangsserver

Eigenschaften für die Konfiguration des POP3 Servers für den Posteingang.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Message Control

Benutzername

Benutzername für die Anmeldung am Posteingangsserver (POP3).

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Message Control

Andere Anmeldedaten als am Posteingangsserver verwenden

Nur verfügbar, wenn für die Eigenschaft Authentifizierung am Postausgangsserver SMTP Authentifizierung am Postausgangsserver verwenden gewählt wurde.

Interne ID: Message Control

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Für die Authentifizierung am Postausgangsserver werden andere Anmeldedaten als am Posteingangsserver verwendet.

Inaktiv: Anmeldedaten für den Posteingangsserver werden auch Postausgangsserver verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SMTP_PASSWORD -> Passwort

Interne ID: Message Control

Passwort

Passwort für den Postausgangsserver.

Nur verfügbar, wenn die Eigenschaft Andere Anmeldedaten als am Posteingangsserver verwenden aktiviert wurde. Ist die Eigenschaft inaktiv, ist das in der Eigenschaft Passwort der Gruppe Posteingangsserver definierte Passwort hinterlegt.

Interne ID: Message Control

Passwort

Passwort für die Anmeldung am Posteingangsserver (POP3).

Das Passwort wird verschlüsselt gespeichert und nur für die Authentifizierung entschlüsselt. Bei der Eingabe werden keine Zeichen im Klartext angezeigt. Das Feld zeigt immer 16 Zeichen an, unabhängig von der tatsächlichen Länge des Passworts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Das Passwort wird verschlüsselt gespeichert und nur für die Authentifizierung entschlüsselt. Bei der Eingabe werden keine Zeichen im Klartext angezeigt. Das Feld zeigt immer 16 Zeichen an, unabhängig von der tatsächlichen Länge des Passworts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SMTP_OUT_ADDR -> Adresse für ausgehende E-Mails

Interne ID: Message Control

Adresse für ausgehende E-Mails

Nur verfügbar, wenn die Eigenschaft Benutzername ist Adresse für ausgehende E-Mails inaktiv oder nicht verfügbar ist.

Interne ID: Message Control

Benutzername ist Adresse für ausgehende E-Mails

Nur verfügbar, wenn die EigenschaftAuthentifizierung am Postausgangsserver einen anderen Wert als keine Authentifizierung enthält.

Aktiv: Der für die Authentifizierung am SMTP Server verwendete Benutzername wird auch als Absenderadresse für die ausgehende E-Mails verwendet.

Inaktiv: der in der Eigenschaft Adresse für ausgehende E-Mails definierte Absender wird verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Absenderadresse für ausgehende E-Mails.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


zenWebSrv.ini

Handbuch -> Dateiaufbau -> zenWebSrv.ini

Einstellungen für den zenon Webserver.

Parameter

Beschreibung

[DEFAULT]

Basiseinstellungen.

INIT=

Einstellung für Aktivierung des zenon Webservers.

Andere Einstellung als 0: Webserver wurde von Systemsteuerung aus gestartet.

USE_HTTP_PROXY=

Legt fest, ob die Verbindung über TCP oder über HTTP erfolgt.

  • 0: TCP wird verwendet.
  • Nicht 0: HTTP Tunnelling wird verwendet.

Wert kann direkt über den Konfigurationsdialog des Webservers gesetzt werden

[PROXY]

Datenaustausch zwischen zenon Webserver und Systemsteuerung.

REMOVE_CLIENT

Dieser Eintrag meldet an den zenon Webserver, wenn in der Systemsteuerung ein angemeldeter Client entfernt wurde.

MAX_CLIENT

Maximale Anzahl an Client. (Abhängig von Lizenz.)

AKT_CLIENT

Aktuelle Anzahl angemeldeter Clients.

SERIAL7=

Seriennummer für zenon Webserver.

ACTIVATIONKEY7=

Verschlüsselte Aktivierungsnummer für zenon Webserver.

LICENCEINFO

Lizenzinformation, wie sie in der Systemsteuerung angezeigt wird:

  • Demo Webserver Pro
  • Demo Webserver
  • Runtime Webserver Pro
  • Runtime Webserver

[CLIENTLIST]

Liste der angemeldeten Clients.

NAME_[Index 00 aufwärts]

Name des angemeldeten Clients.

Hinweis: Die Einträge in [PROXY] und [CLIENTLIST] werden beim Starten des zenon Webservers gelöscht. Bekommt der Dienst ein Steuerkommando von der Systemsteuerung, werden die Einträge nach Bedarf geschrieben bzw. gelesen.

info Info

Die zenWebSrv.ini finden Sie im Pfad %cd_system%.


Diagnose Viewer

Handbuch -> Diagnose Viewer

Alle zenon Module wie z.B. Editor, Runtime, Treiber, usw. schreiben Meldungen in eine gemeinsame LOG-Datei. Diese kann man mit dem Programm Diagnose Viewer, das mit zenon mitinstalliert wird, auslesen und konfigurieren. Es ermöglicht das Lesen bestehender LOG-Dateien, Online-Logging, speichern der aktuellen Ansicht, Parametrieren der Diagnose-Clients und Diagnose-Server. Den Diagnose Viewer starten Sie unter Start/Alle Programme/zenon/Tools 7.00 -> Diagnose Viewer.

Der Diagnose Viewer steht nur in englischer Sprache zur Verfügung.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Verwendung von IPv6

Der Diagnose Server funktioniert auch mit Diagnose Clients, die über IPv6-Adressen angesprochen werden. Dafür wurde das Format der LOG-Dateien angepasst. Der Diagnose Viewer liest nur das neue Format der LOG-Dateien. Werden Dateien von älteren zenon Versionen geöffnet (oder umgekehrt), wird die IP-Adresse des Diagnose Clients nicht korrekt angezeigt.

Treiberanalyse

zenon Treiber protokollieren alle Fehler in Log-Dateien. Der Standardordner für die Log-Dateien ist der Ordner LOG unterhalb des Ordners ProgramData, zum Beispiel: C:\ProgramData\zenon \zenon700\LOG für die zenon Version 7.00 SP0. Log-Dateien sind Textdateien mit einer speziellen Struktur.

Achtung: Mit den Standardeinstellungen zeichnet ein Treiber nur Fehlerinformationen auf. Mit dem Diagnose Viewer kann bei den meisten Treibern die Diagnose-Ebene auf „Debug" und „Deep Debug" erweitert werden. Damit protokolliert der Treiber auch alle anderen wesentlichen Aufgaben und Ereignisse.

Im Diagnose Viewer kann man auch:

  • eben erstellte Einträge live mitverfolgen
  • die Aufzeichnungseinstellungen anpassen
  • den Ordner, in dem die Log-Dateien gespeichert werden, ändern

Hinweise:

  1. Unter Windows CE werden aus Ressourcegründen auch Fehler standardmäßig nicht protokolliert.
  2. Der Diagnose Viewer zeigt alle Einträge in UTC (Koordinierter Weltzeit) an und nicht in der lokalen Zeit.
  3. Der Diagnose Viewer zeigt in seiner Standardeinstellung nicht alle Spalten einer Log-Datei an. Um mehr Spalten anzuzeigen, aktivieren Sie die Eigenschaft Add all columns with entry im Kontextmenü der Spaltentitel.
  4. Bei Verwendung von reinem Error-Logging befindet sich eine Problembeschreibung in der Spalte Error text. In anderen Diagnose-Ebenen befindet sich diese Beschreibung in der Spalte General text.
  5. Viele Treiber zeichnen bei Kommunikationsprobleme auch Fehlernummern auf, die die SPS ihnen zuweist. Diese werden in Error text und/oder Error code und/oder Driver error parameter(1 und 2) angezeigt. Hinweise zur Bedeutung der Fehlercodes erhalten Sie in der Treiberdokumentation und der Protokoll/SPS-Beschreibung.
  6. Stellen Sie am Ende Ihrer Tests den Diagnose-Level von Debug oder Deep Debug wieder zurück. Bei Debug und Deep Debug fallen beim Protokollieren sehr viele Daten an, die auf der Festplatte gespeichert werden und die Leistung Ihres Systems beeinflussen können. Diese werden auch nach dem Schließen des Diagnose Viewers weiter aufgezeichnet.

Noch in diesem Kapitel

Allgemeines

Topologie des Diagnose-Systems

Standard-Ablauf

Diagnose Server

Diagnose Client

Diagnose Viewer - Auswertungsprogramm

Filtermöglichkeiten

Lesen der LOG-Dateien

Struktur der Log-Datei

Fehlerbehandlung und Meldungen


Allgemeines

Handbuch -> Diagnose Viewer -> Allgemeines

Das zenon Diagnose-System besteht aus drei Teilen:

  • Diagnose Server: lokaler oder in zenon6.ini eingestellter LogSrv
  • Diagnose Clients: alle Module, Treiber, Services etc, die Meldungen absetzen
  • Diagnose Viewer: Auswertungsprogramm

Versionen

Ab Version 7.00 wird für das Diagnose System als Dienst der zenLogSrv statt des zenSysSrv verwendet. Das bedeutet:

  • Diagnose Systeme bis Version 6.51 und ab Version 7.00 sind jeweils untereinander kompatibel.
  • Die Diagnose Mechanismen von zenon 6.51 SP0 und zenon 7.00 SP0 sind nicht kompatibel.
Kompatibilität | Diagnose Server 6.51 SP0 und früher | Diagnose Server 7.00 SP0 und höher
Diagnose Client 6.51 SP0 und früher | kompatibel | inkompatibel
Diagnose Viewer 6.51 SP0 und früher | kompatibel | inkompatibel
Diagnose Client 7.00 SP0 und höher | inkompatibel | kompatibel
Diagnose Viewer 7.00 SP0 und höher | inkompatibel | kompatibel

Mit dem Diagnose Viewer Version 7.00 SP0 und höher können LOG-Dateien, die von einem Diagnose Server Version 6.51 SP0 (oder früher) erstellt wurden, geöffnet werden. Der umgekehrte Fall funktioniert nicht.

Standardports

  • ab Version 7: 50780 (Port des Dienstes zenLogSrv)
  • bis inklusive Version 6.51: 1101 (Port des Dienstes zenSysSrv)

Kann der Port nicht geöffnet werden, beendet sich der jeweilige Dienst.

attention Achtung

Ist der Port, zu dem sich der Diagnose Viewer verbinden soll, geschlossen, dann wird versucht, den lokalen Diagnose Server zu starten. Damit wird sicher gestellt, dass lokal geloggt wird, wenn ein Diagnose Server im Netzwerk nicht verfügbar ist.

Speicherbelegung

Der Dienst zenLogSrv puffert LOG-Einträge bis sie in die LOG-Datei geschrieben werden können. Steigt der Verbrauch an Arbeitsspeicher durch den zenLogSrv kontinuierlich an, ist das ein Hinweis darauf, dass nicht in die LOG-Datei geschrieben werden kann.


Topologie des Diagnose-Systems

Handbuch -> Diagnose Viewer -> Topologie des Diagnose-Systems

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Topologie des Diagnose-Systems unterscheidet sich in den Versionen bis 6.51 SP0 und ab 7.00 SP0.

Topologie vor zenon 7.00 SP0

Das Schema zeigt alle möglichen Verbindungen, für die der zenSysSrv Version zuständig ist. Jeder Pfeil repräsentiert eine Netzwerkverbindung zwischen den Anwendungen. Alle Anwendungen verbinden sich zum zenSysSrv auf Port 1101, unabhängig davon, ob Client und Server sich auf dem selben Rechner befinden oder über ein Netzwerk kommunizieren.

  1. Der Editor sendet Log-Einträge sowie Kommandos und Daten des Remote Transport an den zenSysSrv. Der zenSysSrv sendet die Konfiguration der Diagnose Clients (Editor, Runtime, Treiber, Webserver, Webclient usw.) und die Remote Transport Daten an den Editor.
  2. Der Diagnose Viewer sendet Diagnose-Kommandos, Diagnose-Konfigurationen und Log-Einträge an den zenSysSrv. Der zenSysSrv sendet Diagnose-Daten und die Diagnose Client Konfiguration an den Diagnose Viewer.
  3. Der zenSysSrv sendet die Diagnose Client Konfiguration an die Diagnose Clients. Die Diagnose Clients senden Log-Einträge an den zenSysSrv.

Der zenSysSrv reagiert entsprechend auf jede eingehende Nachricht:

  • Log-Einträge werden in LOG-Dateien geschrieben.
  • Remote Transport Kommandos (Runtime starten, Dateien hochladen / rücklesen, …) werden ausgeführt.
  • Diagnose-Kommandos (setze Server/Client Konfiguration, beginne Online Logging, …) werden ausgeführt.

Topologie ab zenon 7.00 SP0

Das Schema zeigt alle möglichen Verbindungen, für die der zenSysSrv und der zenLogSrv (ab Version 7.00 SP0) zuständig sind. Jeder Pfeil repräsentiert eine Netzwerkverbindung zwischen den Anwendungen. Alle Anwendungen verbinden sich zum zenLogSrv auf Port 50780. Der Editor verbindet sich zum zenSysSrv auf Port 1101. Dabei ist es egal, ob Client und Server sich auf demselben Rechner befinden oder über ein Netzwerk kommunizieren.

  1. Der Editor sendet Kommandos und Daten des Remote Transport an den zenSysSrv. Der zenSysSrv sendet Daten des Remote Transport an den Editor.
  2. Der Editor sendet Log-Einträge an den zenLogSrv. Der zenLogSrv sendet die Konfiguration des Diagnose Clients an den Editor.
  3. Der Diagnose Viewer sendet Diagnose-Kommandos, Diagnose-Konfigurationen und Log-Einträge an den zenLogSrv. Der zenLogSrv sendet Diagnose-Daten und die Konfiguration der Diagnose Clients an den Diagnose Viewer.
  4. Der zenSysSrv sendet Log-Einträge an den zenLogSrv. Der zenLogSrv sendet die Konfiguration der Diagnose Clients an den zenSysSrv.
  5. Der zenLogSrv sendet die Konfiguration der Diagnose Clients an die Diagnose Clients. Die Diagnose Clients senden Log-Einträge an den zenLogSrv.

Der zenSysSrv reagiert auf: eintreffende Remote Transport Kommandos.
Der zenLogSrv reagiert auf eintreffende Diagnose-Kommandos und Log-Einträge

Beispiel

In einer Umgebung mit einem zentralen Diagnose Server wird auf einem Gerät die Runtime gestartet. Basierend auf der Runtime-Version wird die Konfiguration aus der zenon6.ini gelesen. Versionen vor 7.00 SP0 lesen den Eintrag LOG_CONFIG aus [SYS_REMOTE], neuere Versionen lesen diesen Eintrag aus [LOGGING_SYSTEM]. Mit dieser Konfiguration wird versucht, eine Diagnose-Verbindung herzustellen. (Details siehe Standard-Ablauf.) Jede weitere von der Runtime geladene Komponente (Treiber, zenNetSrvusw.) bauen ebenfalls eine Diagnose-Verbindung auf.


Standard-Ablauf

Handbuch -> Diagnose Viewer -> Standard-Ablauf

Standardmäßig werden von den Clients an den Diagnose Server nur Fehlermeldungen (Errors) gemeldet.

Der Diagnose Server speichert die erhaltenen Meldungen in TXT-Dateien mit einer speziellen Struktur. Der Standardordner für die LOG-Dateien ist der Ordner LOG unterhalb des Ordners ProgramData. Zum Beispiel: %ProgramData%\COPA-DATA \LOG.
Weitere Informationen finden Sie im Handbuch Installation und Updates im Kapitel Dateistruktur.

Hinweis: Unter Windows CE werden aus Ressourcegründen per Default auch keine Fehlermeldungen erstellt.

Um nicht nur Fehlermeldungen, sondern andere zur Diagnose wichtige Informationen an den Diagnose Server zu melden, müssen die entsprechenden Einstellungen für den Client getroffen werden.

Auch das Verhalten des Servers kann konfiguriert werden.

Konfiguration

Die Konfiguration der Verbindung erfolgt in der zenon6.ini, unterteilt in:

  • Diagnose Clients
  • Diagnose Server
  • Versionen um sicherzustellen, dass die Konfigurationen der Versionen sich nicht gegenseitig beeinträchtigen

Auch die Konfiguration des Diagnose Viewer ermöglicht Einstellungen für die Verbindung zu konfigurieren:

  • Einstellungen des Servers
  • Verbindungseinstellung Diagnose Server Connection
  • Diagnose Client
  • Diagnose Viewer - Auswertungsprogramm

Die Konfiguration der Verbindungen für Server und Client wird per zenon6.ini empfohlen.

Ablauf

Der Diagnose Server ist:

  • am PC ein Dienst.
    Der Dienst startet mit dem Hochfahren des Betriebssystems automatisch. Der lokale Dienst kann nur einmal gestartet werden.
  • unter CE eine Anwendung.
    Unter CE kann nur ein Prozess den Port nutzen. Eventuell zusätzlich gestartete Prozesse beenden sich wieder, da der Port nicht geöffnet werden kann. Ist die lokale Konfiguration des Diagnose Servers unter CE so eingestellt, dass nur die Oberfläche angezeigt werden soll (INIT=2), können durch die Versuche der Diagnose Clients, den lokalen Diagnose Server zu starten, mehrere Prozesse entstehen.

Sobald ein Diagnose Client aktiv wird, werden folgende Schritte ausgeführt:

  1. Der Diagnose Client liest die Konfiguration aus der zenon6.ini und verwendet diese. Ist in der zenon6.ini keine Konfiguration vorhanden, wird die Standardkonfiguration (Diagnose Server=localhost:50780) verwendet.
  2. Der Diagnose Client versucht eine Verbindung zum Diagnose Server aufzubauen:

    Aufbau gelingt:

    1. Die Diagnose-Verbindung steht und Log-Einträge werden gesendet.

    Aufbau scheitert:

    1. Der Diagnose Client versucht, den lokalen Diagnose Server zu starten und diesen zu verwenden.
      Am PC wird versucht, den Dienst zu starten.
      Unter CE wird versucht, den Prozess zu erzeugen.
    2. Der Diagnose Client versucht eine Verbindung zum lokalen Diagnose Server aufzubauen. Gelingt dies, steht die Diagnose-Verbindung und Log-Einträge werden gesendet.

    Gelingt kein Verbindungsaufbau, werden keine Log-Einträge erstellt.

Noch in diesem Kapitel

Einträge in zenon6.ini

Windows CE


Einträge in zenon6.ini

Handbuch -> Diagnose Viewer -> Standard-Ablauf -> Einträge in zenon6.ini

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration von zenSysSrv und zenLogSrv erfolgt über die zenon6.ini. Dabei wird zwischen den Versionen ab 7.00 und bis inklusive 6.51 unterschieden. Damit können auf einem Gerät sowohl alte als auch neue Diagnose Clients und Diagnose Server unabhängig von einander konfiguriert werden. So können zum Beispiel die LOG-Einträge von alten Diagnose Clients umgeleitet werden, ohne dass die LOG-Einträge neuer Diagnose Clients berührt werden.

Diagnose Server vor Version 7.00 SP0

INI Eintrag

Erklärung

[SYS_REMOTE]

Abschnitt in zenon6.ini.

Enthält Parameter für zenSysSrv (Remote Transport und Diagnose Server).

LOGDirectory=

Definiert Ordner für die LOG-Dateien.

Ist der Eintrag nicht vorhanden, wird als Standardwert der LOG-Ordner im ProgramData-Ordner der verwendeten Version herangezogen.

Beispiel:
LOGDirectory= %ProgramData%\COPA-DATA\zenon651\LOG

CONFIG=

Konfigurationsstring für den Diagnose Server und den zenSysSrv . Remote Transport und Diagnose-System verwenden bis inklusive Version 6.51 SP0 die gleiche Serverkonfiguration. Der String besteht aus folgenden Teilen: DEVICE=[Device];HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart.
    TCP/IP und seriell stehen zur Verfügung.
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.
  • BAUD: gibt die Verbindungsgeschwindigkeit einer seriellen Verbindung an.

Konfiguration PC:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=1101
  • TIMEOUT=10

Konfiguration CE:

  • DEVICE=COM1
  • BAUD=115200

LOGMinFreeDiskSpace=

Definiert Speicherplatz in MB, der mindestens auf der Festplatte frei bleiben muss. Bevor dieser Wert unterschritten wird, werden LOG-Dateien gelöscht.

Default: 1024

LOGMaxUsedDiskSpace=

Definiert den maximal für LOG-Dateien verwendeten Speicherplatz in MB auf der Festplatte. Wird dieser Wert überschritten, werden LOG-Dateien gelöscht.

Default: 1024

LOGMinUsedDiskSpace=

Definiert Speicherplatz in MB auf der Festplatte, der belegt wird, auch wenn keine LOG-Dateien vorhanden sind.

Default: 5

LOGLogLifeTime=

Definiert die Lebensdauer der LOG-Dateien in Sekunden. Ältere LOG-Dateien werden gelöscht.

Default: 1209600 (entspricht 14 Tagen)

LOGImageCnt=

Definiert die Anzahl der LOG-Einträge, nach denen alle inkrementellen LOG-Felder geschrieben werden.

Default: 0

LOGLogUpdateTime=

Anzahl von Millisekunden, nach der erhaltene LOG-Einträge in eine LOG-Datei geschrieben werden.

Default: 2000

LOGMaxBufferedRecs=

Definiert die Anzahl an LOG-Einträgen, die gepuffert werden, wenn nicht in Dateien geschrieben werden kann.

Default: 10240

LOGMaxLogFileSize=

Maximale Größe einer LOG-Datei in Byte. Hat eine LOG-Datei diese Größe erreicht, wird sie geschlossen und eine neue LOG-Datei wird erstellt.

Default: 5242880 (entspricht 5 MB)

LOGCheckDiskTime=

Definiert das Intervall in Sekunden, in dem der von LOG-Dateien belegte Speicherplatz geprüft wird.

Default: 60

INIT=

Aktion beim Starten der Anwendung unter Windows CE :

  • 0: sofort wieder beenden
  • 1 (oder anderer Wert größer 2): Listening Port öffnen und in System Tray minimieren
  • 2: nur Oberfläche anzeigen

Default: 1

Hinweis: Im Zuge der Trennung von zenSysServ und zenLogServ für zenon 7.00 wurde dieser Defaultwert auch für andere Versionen umgestellt. Davor war der Defaultwert 2.

Diagnose Server ab Version 7.00 SP0

INI Eintrag

Erklärung

[LOGGING_SYSTEM]

Abschnitt in zenon6.ini.

Enthält Parameter für Diagnose Server. Betrifft nur zenLogSrv und hat keine Auswirkung auf zenSysSrv.

LOGDirectory=

Definiert Ordner für die LOG-Dateien.

Ist der Eintrag nicht vorhanden, wird als Standardwert verwendet:

der aus der Registry extrahierte Pfad
z.B. %ProgramData%\COPA-DATA\LOG

der LOG-Ordner im ProgramData-Verzeichnis des zenLogSrv, falls in der Registry kein Pfad definiert wird
z.B. %ProgramData%\COPA-DATA\zenon700\LOG

CONFIG=

Konfigurationsstring für den Diagnose Server. Der String besteht aus folgenden Teilen: DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart und muss immer auf TCP/IP gesetzt werden
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.

Konfiguration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=50780
  • TIMEOUT=10

LOGMinFreeDiskSpace=

Definiert Speicherplatz in MB, der mindestens auf der Festplatte frei bleiben muss. Bevor dieser Wert unterschritten wird, werden LOG-Dateien gelöscht.

Default: 1024

LOGMaxUsedDiskSpace=

Definiert den maximal für LOG-Dateien verwendeten Speicherplatz in MB auf der Festplatte. Wird dieser Wert überschritten, werden LOG-Dateien gelöscht.

Default: 1024

LOGMinUsedDiskSpace=

Definiert Speicherplatz in MB auf der Festplatte, der belegt wird, auch wenn keine LOG-Dateien vorhanden sind.

Default: 5

LOGLogLifeTime=

Definiert die Lebensdauer der LOG-Dateien in Sekunden. Ältere LOG-Dateien werden gelöscht.

Default: 1209600 (entspricht 14 Tagen)

LOGImageCnt=

Definiert die Anzahl der LOG-Einträge, nach denen alle inkrementellen LOG-Felder geschrieben werden.

Default: 0

LOGLogUpdateTime=

Anzahl von Millisekunden, nach der erhaltene LOG-Einträge in eine LOG-Datei geschrieben werden.

Default: 2000

LOGMaxBufferedRecs=

Definiert die Anzahl an LOG-Einträgen, die gepuffert werden, wenn nicht in Dateien geschrieben werden kann.

Default: 10240

LOGMaxLogFileSize=

Maximale Größe einer LOG-Datei in Byte. Hat eine LOG-Datei diese Größe erreicht, wird sie geschlossen und eine neue LOG-Datei wird erstellt.

Default: 5242880 (entspricht 5 MB)

LOGCheckDiskTime=

Definiert das Intervall in Sekunden, in dem der von LOG-Dateien belegte Speicherplatz geprüft wird.

Default: 60

INIT=

Aktion beim Starten der Anwendung unter Windows CE:

  • 0: sofort wieder beenden
  • 1 (oder anderer Wert größer 2): Listening Port öffnen und in System Tray minimieren
  • 2: nur Oberfläche anzeigen

Default: 1

Diagnose Client vor Version 7.00 SP0:

INI Eintrag

Erklärung

[SYS_REMOTE]

Abschnitt in zenon6.ini.

Enthält Parameter für Diagnose Client.

LOG_CONFIG=

Hier wird ein Konfigurationsstring für den Diagnose Client abgelegt. Der String besteht aus folgenden Teilen: DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart und muss immer auf TCP/IP gesetzt werden
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.

Konfiguration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=1101
  • TIMEOUT=10

Diagnose Client ab Version 7.00 SP0

INI Eintrag

Erklärung

[LOGGING_SYSTEM]

Abschnitt in zenon6.ini.

Enthält Parameter für Diagnose Client.

LOG_CONFIG=

Hier wird ein Konfigurationsstring für den Diagnose Client abgelegt. Der String besteht aus folgenden Teilen:

DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: setzt die verwendete Kommunikationsart und muss immer auf TCP/IP gesetzt werden
  • HOST: wird auf den Rechnernamen des Diagnose Servers gesetzt.
  • PORT: gibt den zu verwendenden Port an.
  • TIMEOUT: gibt die Timeoutzeit der Verbindung in Sekunden an.

Konfiguration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=50780
  • TIMEOUT=10

Hinweise

INIT unter CE

Unter Windows CE wird dringend empfohlen, den Eintrag INIT= (im Abschnitt [LOGGING_SYSTEM]bzw. [SYS_REMOTE]) nicht auf den Wert 2 zu setzen.

Grund: Der Wert 2 führt dazu, dass sowohl SysSrvCE als auch LogSrvCE nur die Oberfläche anzeigen und den Listening Port nicht öffnen.
Möchte nun ein Diagnose Client eine Verbindung aufbauen, schlägt das fehl. Da Diagnose Clients in diesem Fall den LogSrvCE als Prozess starten und dieser den Port nicht öffnet, startet jeder einzelne Diagnose Client einen solchen Prozess. Das führt zu vielen parallelen LogSrvCE Prozessen und zu einer Verzögerung beim Starten der Diagnose Clients, da diese beim Herstellen der Diagnose-Verbindung auf das Timeout der Verbindung warten.

zenLogSrv auf einem System mit verschiedenen Versionen

Wird der zenLogSrv auf einem System mit verschiedenen Versionen als zentraler lokaler Diagnose Server verwendet, muss der Eintrag LOG_CONFIG im Abschnitt [SYS_REMOTE] wie folgt lauten:
DEVICE=TCP/IP;HOST=localhost;PORT=5780;TIMEOUT=10

Grund: Ältere Clients verwenden dann den zenLogSrv als Diagnose Server. Neue Clients machen das automatisch. Am PC wird dieser als Dienst automatisch beim Systemstart gestartet, unter CE muss er händisch gestartet werden.

Achtung: Ist der Port nicht erreichbar, starten ältere Clients den zenSysSrv und versuchen erneut eine Verbindung mit diesem herzustellen.


Windows CE

Handbuch -> Diagnose Viewer -> Standard-Ablauf -> Windows CE

Unter Windows CE wird der Diagnose Server als Anwendung gestartet.

Bei der Konfiguration der Verbindung beachten Sie die Empfehlung zum Parameter INIT:

Unter Windows CE wird dringend empfohlen, den Eintrag INIT= (im Abschnitt [LOGGING_SYSTEM]bzw. [SYS_REMOTE]) nicht auf den Wert 2 zu setzen.

Grund: Der Wert 2 führt dazu, dass sowohl SysSrvCE als auch LogSrvCE nur die Oberfläche anzeigen und den Listening Port nicht öffnen.
Möchte nun ein Diagnose Client eine Verbindung aufbauen, schlägt das fehl. Da Diagnose Clients in diesem Fall den LogSrvCE als Prozess starten und dieser den Port nicht öffnet, startet jeder einzelne Diagnose Client einen solchen Prozess. Das führt zu vielen parallelen LogSrvCE Prozessen und zu einer Verzögerung beim Starten der Diagnose Clients, da diese beim Herstellen der Diagnose-Verbindung auf das Timeout der Verbindung warten.

Oberflächen unter CE

Transport Service (zenSysSrv)

Parameter

Beschreibung

Start

Öffnet den Listening Port und ermöglicht dem zenSysSrv Remote Transport Befehle zu empfangen.

Browse

Öffnet einen Dialog zum Durchsuchen des Dateisystems.

Stop

Beendet das Empfangen von Remote Transport Befehle und schließt den Listening Port wieder.

Configuration

Auswahl einer verfügbaren Serverkonfiguration aus Dropdownliste. Neue Verbindungen können nicht konfiguriert werden. Konfiguration der Verbindungen siehe Abschnitt Einträge in zenon6.ini.
Verfügbar sind:

  • Konfiguration aus der zenon6.ini
  • Standardkonfiguration für TCP/IP
  • Standardkonfigurationen für COM1 bis COM4

Hide

Minimiert die Oberfläche in den System Tray.

Exit

Beendet die Anwendung und schließt bei Bedarf zuvor den Listening Port.

X
(Schaltfläche rechts oben)

Minimiert die Oberfläche in den System Tray.

Logging Service (zenLogSrv)

Parameter

Beschreibung

Start

Öffnet den Listening Port und ermöglicht dem zenLogSrv LOG-Einträge zu empfangen.

Stop

Beendet das Empfangen von LOG-Einträgen und schließt den Listening Port wieder.

Configuration

Auswahl aus verfügbaren Konfigurationen aus Dropdownliste. Neue Verbindungen können nicht konfiguriert werden. Konfiguration der Verbindungen siehe Abschnitt Einträge in zenon6.ini.
Verfügbar sind:

  • Konfiguration aus der zenon6.ini
  • Standardkonfiguration für TCP/IP

Hide

Minimiert die Oberfläche in den System Tray.

Exit

Beendet die Anwendung und schließt bei Bedarf zuvor den Listening Port.

X
(Schaltfläche rechts oben)

Minimiert die Oberfläche in den System Tray.


Diagnose Server

Handbuch -> Diagnose Viewer -> Diagnose Server

Der Diagnose Server:

  • Erstellt und verwaltet die LOG-Dateien.
  • Der Server ist:
    • ab zenon 7.00 als zenLogSrv implementiert
    • bis inklusive zenon 6.51 in den zenSysService integriert.
  • Die Konfiguration des Servers wird aus der zenon6.ini gelesen.
  • Der Server schreibt die erhaltenen LOG-Daten in die LOG-Datei.
  • Der Speicherort der Dateien ist konfigurierbar. Standard: %ProgramData%\COPA-DATA\LOG\
  • LOG-Dateien haben die Benennung LOG<YYMMTThhmmss>.txt.
  • Der Server ist multiclientfähig. Mehrere Auswertungen können sich gleichzeitig zum Server verbinden.
  • Es besteht die Möglichkeit, sich online auf den Server zu verbinden, um die aktuellen Logging-Vorgänge mitzuverfolgen.
  • Es besteht die Möglichkeit, sich zu anderen als dem lokal laufenden Diagnose Server zu verbinden und dieselben Aufgaben (Server konfigurieren, Clients konfigurieren, Online-Logging) durchzuführen wie am lokalen Server.
  • Beim aktuellen Server (mit dem der Diagnose Viewer verbunden ist) können die Parameter modifiziert werden. Falls eine Modifizierung bei einem anderen Diagnose Server nötig ist, kann unter Menü Datei - Verbinden mit... die Serververbindung geändert werden.
  • Im Menü ist der Eintrag Settings - Server configuration nur verfügbar, wenn gerade kein Online-Logging verwendet wird.

Noch in diesem Kapitel

Systemintegritätsüberprüfung

Einstellungen des Servers


Systemintegritätsüberprüfung

Handbuch -> Diagnose Viewer -> Diagnose Server -> Systemintegritätsüberprüfung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Runtime-Start wird ein Überwachungsthread mit hoher Priorität gestartet. Der Überwachungsthread überprüft alle 10 Sekunden kritische Systemparameter und schreibt entsprechende Warnungen oder Fehler in das Modul Supervisor des Diagnose Servers.

Folgende Parameter werden überprüft.

Parameter | Grenzwert
Warnschwelle für benutzte Handles | > 5000
Fehlerschwelle für benutzte Handles | > 9000
Warnschwelle für benutze GDI-Objekte | > 5000
Fehlerschwelle für benutze GDI-Objekte | > 9000
Warnschwelle für CPU-Last für den Hauptthread | > 70 %
Fehlerschwelle für CPU-Last für den Hauptthread | > 90 %
Warnschwelle für CPU-Last gesamt | > 70 %
Warnschwelle für CPU-Last gesamt | > 90 %
Warnschwelle für freien Hauptspeicher | < 30 %
Fehlerschwelle für freien Hauptspeicher | < 10 %
Warnschwelle für OnTimer im mainframe | > 1000 ms
Fehlerschwelle für OnTimer im mainframe | > 5000 ms


Einstellungen des Servers

Handbuch -> Diagnose Viewer -> Diagnose Server -> Einstellungen des Servers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Diagnose Server kann über Einträge in der zenon6.ini konfiguriert werden oder über den Dialog Server configuration im Diagnose Client. Es wird empfohlen, die Einstellungen über zenon6.ini vorzunehmen.

Konfiguration über zenon6.ini

Siehe Abschnitt Einträge in zenon6.ini.

Konfiguration über Dialog

Um den Diagnose Server über den Dialog zu konfigurieren:

  1. starten Sie den Diagnose Viewer
  2. öffnen Sie den Eintrag File Connect to...
  3. konfigurieren Sie den gewünschten Server
    (Beachten Sie die korrekte Wahl des Ports, abhängig von der Version!)
  4. öffnen Sie den Eintrag Settings -> Server configuration
  5. konfigurieren Sie die mitzuloggenden Ereignisse
  6. schließen Sie den Dialog mit Klick auf OK

Hinweis: Alle Änderungen werden mit Bestätigung des Dialogs in die zenon6.ini geschrieben.

Konfiguration der Ereignisse, die vom Diagnose Viewer mitgeloggt werden:

Parameter | Beschreibung
Modules | Auswahl des zu konfigurierenden Moduls.
Messagelevel | Auswahl der zu loggenden Ereignisse. Default: Errors
LOGImageCnt | Anzahl der Einträge, nach denen alle inkrementellen Felder geschrieben werden. Default: 0 (nicht aktiv)
LOGMinFreeDiskSpace | Es wird laufend geprüft, ob weniger als der konfigurierte minimale freie Plattenplatz verfügbar ist. Die ältesten LOG-Dateien werden gelöscht. Minimaler freier Plattenplatz bevor LOG-Dateien gelöscht werden in MB. Default: 1024 MB
LOGMaxUsedDiskSpace | Maximal verwendeter Plattenplatz für das Log in MB. Default: 1024 MB
LOGMinUsedDiskSpace | Minimal verwendeter Plattenplatz unabhängig ob LOGMinFreeDiskSpace unterschritten ist in MB. Default: 5 MB
LOGLogUpdateTime | Zeit in ms nach welcher die erhaltenen Einträge gespeichert werden. Default: 2000 ms
LOGMaxBufferedRecs | Der Server puffert den Inhalt sämtlicher inkrementeller Log-Felder für die verschiedenen Applikationen, um Abbilder dieser in die LOG-Datei schreiben zu können. Bei Neubeginn einer LOG-Datei und nach konfigurierbarer Anzahl von Log-Einträgen wird ein komplettes Abbild, für alle Adressen in die LOG-Datei geschrieben. Die Daten, die empfangen werden, werden in die LOG-Dateien geschrieben. Die Eintragung erfolgt nicht direkt sondern über einen Zwischenpuffer. Es kann konfiguriert werden, ob die Daten verzögert oder sofort geschrieben werden. Anzahl der gepufferten Einträge, wenn diese nicht gespeichert werden können. Default: 10240
LOGMaxLogFileSize | Der Server schreibt die erhaltenen LOG-Daten in die LOG-Datei. Wenn diese die konfigurierte Größe erreicht, wird eine neue Datei begonnen. Maximale Größe einer einzelnen LOG-Datei in Byte. Default: 5 MB
LOGDirectory | Ordner, in den die LOG-Dateien geschrieben werden. Default: %ProgramData%\COPA-DATA \LOG\
LOGLogLifeTime | Es wird laufend geprüft ob die Lebenszeit der LOG-Dateien abgelaufen ist. Die älteren LOG-Dateien werden gelöscht. Anzahl der Sekunden welche die LOG-Dateien aufbewahrt werden. Default: 14 Tage
LOGCheckDiskTime | Abstand in s, in dem der belegte Plattenplatz überprüft wird. Default: 60 s
Message level for all modules | Einstellungen werden für alle Module übernommen.
Default values | Standardeinstellungen wieder herstellen.
Accept | Einstellungen für dieses Modul übernehmen.
Cancel | Verwirft Änderungen und schließt Dialog.
OK | Übernimmt Änderungen und schließt Dialog.


Diagnose Client

Handbuch -> Diagnose Viewer -> Diagnose Client

Alle Programme, die LOG-Einträge erstellen, sind Diagnose Clients. Diese Log-Einträge werden via TCP/IP zum Diagnose Server gesendet. Server-Rechner und Port werden - abhängig von der eingesetzten Verion - aus der lokalen zenon6.ini eingelesen und kontaktiert. Schlägt die Verbindung fehl, wird dies zyklisch versucht:

  • Ist der Diagnose Server nicht erreichbar wird alle 500ms ein Reconnect versucht.
  • Wenn nach der halben Timeoutzeit keine Verbindung erstellt werden konnte, wird versucht den Dienst zenSysSrv bzw. zenLogSrv zu starten.

Die Einstellungen werden über den Eintrag LOG_CONFIG= im Abschnitt [SYS_REMOTE] (bis 6.51) bzw. [LOGGING_SYSTEM] (ab 7.00) konfiguriert.

Konfiguration Diagnose Client

Um den Diagnose Client über den Dialog zu konfigurieren:

  1. starten Sie den Diagnose Viewer
  2. öffnen Sie den Eintrag Settings -> Client configuration
    (nur verfügbar, wenn Logging inaktiv ist)
  3. markieren Sie einen Client
  4. klicken Sie auf List of parameters
  5. der Dialog zur Konfiguration wird geöffnet
  6. konfigurieren Sie den Client
  7. schließen Sie den Dialog mit Klick auf OK
  8. wiederholen Sie den Vorgang eventuell für weitere Clients

Clientliste

Parameter | Beschreibung
Clients | Listet alle verfügbaren Clients auf.
Refresh | Aktualisiert Liste der Clients.
List of parameters | Öffnet Dialog zur Konfiguration des ausgewählten Clients.
Close | Schließt Dialog.

Client konfigurieren

Die Standard Module, die ausgewählt werden können:

Parameter

Beschreibung

Modules

Auswahl des zu konfigurierenden Moduls.

Liste setzt sich zusammen aus Standardmodulen und Modulen, die vom jeweiligen Client abhängen.

  • General: Allgemeine Meldungen
  • Net: Netzwerkmeldungen
  • Proxy: Meldungen des zenon Proxy
  • Db: Meldungen vom ZenDbSrv
  • SysSrv: Meldungen vom ZenSysSrv
  • Driver: Meldungen eines Treibers
  • Log: Meldungen vom Logging
  • SAT: SICAM 230 spezifische Meldungen

Messagelevel

Art der zu loggenden Informationen.

All

Wählt alle aus.

None

Wählt alle ab.

Message Level for all Modules

Weist markierte Message Level allen Modulen zu.

Max Buffered records

Anzahl der Einträge, die gepuffert werden, wenn keine Verbindung zum Server besteht.
Default: 256

OK

Übernimmt alle Änderungen und schließt Dialog.

Cancel

Verwirft alle Änderungen und schließt Dialog.

Accept

Übernimmt alle Änderungen und lässt Dialog geöffnet.

Default values

Trägt die Standardwerte ein.


Diagnose Viewer - Auswertungsprogramm

Handbuch -> Diagnose Viewer -> Diagnose Viewer - Auswertungsprogramm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Diagnose Viewer dient zur Anzeige der LOG-Daten. Er verbindet sich mit dem Diagnose Server, um die Daten online anzuzeigen oder historische LOG-Dateien abzurufen. LOG-Dateien enthalten nicht nur die LOG-Daten, es werden zusätzliche auch für die Auswertung notwendige Informationen wie Spaltenüberschriften mit abgelegt.

Um eine LOG-Datei anzuzeigen:

  1. wählen Sie File -> Open
  2. der Dialog zur Auswahl einer LOG-Datei wird mit Fokus auf den konfigurierte Standard-Ordner geöffnet
  3. wählen Sie die gewünschte Datei
  4. die LOG-Datei wird angezeigt

  5. Doppelklick auf einen Eintrag öffnet die Detailansicht

Erkennung Queue-Überlauf bei Treiber

Werden Meldungen eines Treibers aufgrund von Queue-Überlaufen gelöscht, setzen Diagnose Clients und Diagnose Server beim Schreiben eines neuen Eintrags für alle aktivierten Module eine Markierung im neuen Eintrag, dass ältere Einträge aus der Queue gelöscht wurden. Die in den geöffneten LOG-Dateien enthaltenen Überlaufkennungen werden gezählt:

Parameter | Beschreibung
Spalte Record version | Diese Spalte muss in der Spaltenauswahl enthalten sein. Sie zeigt die Version des Datensatzes an. Eine Version 8x markiert Overflows.
Zähler 82 | 8 verweist auf Overflow, 2 auf die betroffene Version des Datensatzes.
Statuszeile: queue overflows | Bei aktivierter Statuszeile wird hier die Anzahl der Overflows angezeigt.

Hinweis: Nicht alle in die LOG-Datei geschriebenen Einträge werden auch dargestellt. Wurde ein nicht dargestellter LOG-Datensatz mit einem Überlauf markiert, wird dieser beim nächsten von diesem Client visualisierten Datensatz angezeigt. Sind mehrere nicht dargestellte Einträge hintereinander mit einem Überlauf markiert, kann der Zähler in der Statuszeile von der Anzahl der Datensätze mit Überlaufmarkierung abweichen.

Noch in diesem Kapitel

Globale Einstellungen


Globale Einstellungen

Handbuch -> Diagnose Viewer -> Diagnose Viewer - Auswertungsprogramm -> Globale Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Einträge sind in Englischer Sprache.

Parameter

Beschreibung

File

Befehle im Menü File.

Open

Öffnet Dialog zur Auswahl einer im TXT-Format gespeicherten LOG-Datei. Jede neu geöffnete LOG-Datei wird in einem eigenen Fenster angezeigt.

Open to active document

Jede ausgewählte LOG-Datei wird zum aktiven Fenster hinzugefügt.

Close

Schliesst das aktuelle Fenster.

Save

Speichert die LOG-Datei des aktuellen Fensters.

Save as

Speichert die aktuelle Ansicht des aktiven Fensters (z.B. nach Filtereinstellungen) in eine anzugebende Datei.

Remote Download

Nur verfügbar, wenn Verbindung mit einem Remote Diagnose Server besteht. Ermöglicht den Download von Loggingdateien des Remote-Servers in den lokalen LOG-Ordner. Ein Unterordner mit Namen des Rechners wird angelegt. Es werden nur die Dateien angeboten, die sich geändert haben oder neu sind.

Connect to

Dialog zur Verbindungsauswahl wird geöffnet.

Online

Aktiviert die Online-Fehlerbetrachtung.
Wird das Online-Logging gestartet, werden alle erhaltenen Einträge ausgegeben. Der gleiche Filterdialog wie beim Dateilesen kann auch hier eingestellt werden.

Unterschied: Ist keine Logverbindung ausgewählt, werden alle erhaltenen Logeinträge angezeigt, ansonsten nur die von den ausgewählten Clients.

Wird der Filter in Bezug auf die Logverbindung modifiziert, gehen alle Einträge, die nicht den Filterbedingungen entsprechen, verloren. (LOG-Datei wird dennoch angelegt und alle Einträge werden gespeichert.) Angezeigte Einträge können gespeichert werden.

Offline

Deaktiviert die Online-Fehlerbetrachtung (Default).

Exit

Beendet den Diagnose Viewer.

Noch in diesem Kapitel

Verbindungseinstellung Diagnose Server Connection

Spalteneinstellungen


Verbindungseinstellung Diagnose Server Connection

Handbuch -> Diagnose Viewer -> Diagnose Viewer - Auswertungsprogramm -> Globale Einstellungen -> Verbindungseinstellung Diagnose Server Connection

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Diagnose Viewer verbindet sich beim Starten automatisch mit einem ausgewählten Standard-Server. Falls kein Standard-Server definiert ist, wird localhost als Standardserver verwendet. Die Serverkonfiguration kann auch über die zenon6.ini erfolgen (empfohlen).

Diagnose Server auswählen

Klick auf File -> Connect to... öffnet Dialog zur Auswahl eines Servers:

Parameter

Beschreibung

Liste Server

Listet alle konfigurierten Server auf und zeigt an:

  • Status
  • Name
  • Port
  • Timeout

OK

Übernimmt Einstellungen und schließt Dialog.

Cancel

Verwirft Einstellungen und schließt Dialog.

New Server

Öffnet Dialog zur Konfiguration eines neuen Servers.

Delete Server

Ausgewählter Server Eintrag wird aus der Liste gelöscht.

Edit Server

Öffnet Dialog zur Konfiguration des ausgewählten Servers.

Connect to

Baut Verbindung zum ausgewählten Server auf.

As default

Selektierter Server Eintrag wird zum Standard Server.

Diagnose Server erstellen und bearbeiten

Klick auf New Server oder Edit Server im Dialog Diagnosis Server connection öffnet Dialog zur Konfiguration der Server:

Parameter | Beschreibung
Server name | Name des Rechners zu dem Verbunden werden soll. Auf diesem muss laufen: bis Version 6.51: der zenSysSrv ab Version 7.00: der zenLogSrv
Port | Port des Dienstes auf dem Zielrechner: bis Version 6.51: 1101 ab Version 7.00: 50780
Timeout | Zeit in Sekunden, in der auf eine Antwort vom Sysservice gewartet wird. Default: 10 s
OK | Übernimmt Einstellungen und schließt Dialog.
Cancel | Verwirft Einstellungen und schließt Dialog.


Spalteneinstellungen

Handbuch -> Diagnose Viewer -> Diagnose Viewer - Auswertungsprogramm -> Globale Einstellungen -> Spalteneinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Menü kann unter Settings -> Column settings eine Anzahl von vordefinierten Spalten ausgewählt werden. Beim Öffnen einer neuen Datei werden automatisch diese Spalten mit deren Einträgen angezeigt. Es werden ebenfalls die Reihenfolge und die Spaltenbreite der Auswahl berücksichtigt. Die Spaltenbreite muss beim Öffnen auf Autosize gestellt sein.

Parameter | Beschreibung
available | verfügbare Spalten
selected | Spalten, die angezeigt werden
> | fügt bei available ausgewählte Spalten zu selected hinzu
>> | fügt alle bei available verfügbaren Spalten zu selected hinzu
< | entfernt bei selected ausgewählte Spalten
<< | entfernt alle bei selected verfügbaren Spalten
^ | reiht ausgewählte Einträge eine Stufe höher (Multiselect möglich)
v | reiht ausgewählte Einträge eine Stufe tiefer (Multiselect möglich)
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.

Spalten können auch im Kontextmenü konfiguriert werden:

Parameter | Beschreibung
Add all columns with entry | Fügt alle Spalten, die Einträge enthalten hinzu.
Remove Column | Blendet die selektierte Spalte aus.
Remove all empty columns | Blendet alle Spalten ohne Eintragt aus.
Column width automatic | Die Breite der selektierten Spalte wird automatisch an den längsten Eintrag angepasst.
All columns widths automatic | Die Breite aller Spalten wird automatisch an den jeweils längsten Eintrag angepasst.


Filtermöglichkeiten

Handbuch -> Diagnose Viewer -> Filtermöglichkeiten

Um Filter zu definieren, öffnen Sie den entsprechenden Filterdialog über die entsprechenden Symbole oder die Registerkarten des Filters.

Symbolleiste Filter

Um die Symbolleiste benutzen zu können, muss diese im Menü View über den Eintrag Icon bar aktiviert werden.

Symbol | Tooltip | Beschreibung
1 | Change pre-filter settings | Öffnet Dialog mit fünf Registerkarten zur Definition der Filter.
2 | Change pre-filter for IP-ProcessID-LogID | Öffnet Registerkarte IP address - Process No - Log ID.
3 | Change pre-filter for modules | Öffnet Registerkarte Modules.
4 | Change pre-filter for additional columns | Öffnet Registerkarte Additional columns.
5 | Change pre-filter for time interval | Öffnet Registerkarte Time interval.
6 | Change pre-filter for coloring | Öffnet Registerkarte Colors.

Filterdialog

Registerkarten | Beschreibung
IP-ProcessID-LogID | Öffnet die Registerkarte IP address - Process No - Log ID zur Konfioguration der Verbindungen, die geloggt werden sollen.
Modules | Öffnet die Registerkarte Modules für die zu loggenden Module.
Additional columns | Öffnet die Registerkarte Additional columns zur Auswahl von zusätzlich anzuzeigenden Spalten.
Time interval | Öffnet die Registerkarte Time interval. zur Definition der Zeitfilter.
Colors | Öffnet die Registerkarte Colors zur Auswahl der farblichen Hervorhebung von Informationen.

Noch in diesem Kapitel

IP address - Process No - Log ID

Modules

Additional columns

Time interval

Colors


IP address - Process No - Log ID

Handbuch -> Diagnose Viewer -> Filtermöglichkeiten -> IP address - Process No - Log ID

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der Verbindungen und Prozesse, die angezeigt werden sollen.

Parameter | Beschreibung
available | Liste der verfügbaren Verbindungen.
selected | Liste der ausgewählten Verbindungen.
Pfeiltasten | Fügen ausgewählte (>) oder alle (>>) Verbindungen zur Liste selected hinzu oder entfernen Sie aus dieser (< bzw. <<).
OK | Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft alle Änderungen aller Registerkarten und schließt Dialog.


Modules

Handbuch -> Diagnose Viewer -> Filtermöglichkeiten -> Modules

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auswahl der Module, die angezeigt werden sollen.

Parameter | Beschreibung
Module filter active | Aktiv: Es wird auf Module gefiltert. Damit werden nur noch LOG-Datensätze angezeigt, die einem selektierten Modul zugeordnet sind.
available | Zur Verfügung stehende Module.
selected | Ausgewählte Module.
Pfeiltasten | Fügen ausgewählte (>) oder alle (>>) Verbindungen zur Liste selected hinzu oder entfernen Sie aus dieser (< bzw. <<).
OK | Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft alle Änderungen aller Registerkarten und schließt Dialog.


Additional columns

Handbuch -> Diagnose Viewer -> Filtermöglichkeiten -> Additional columns

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auswahl der zusätzlich anzuzeigenden Spalten.

Parameter | Beschreibung
available | Liste der verfügbaren Spalten. Alle in der Datei vorkommenden Felddefinitionen werden angezeigt.
selected | Liste der ausgewählten Spalten.
Pfeiltasten | Fügen ausgewählte (>) oder alle (>>) Verbindungen zur Liste selected hinzu oder entfernen Sie aus dieser (< bzw. <<).
OK | Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft alle Änderungen aller Registerkarten und schließt Dialog.


Time interval

Handbuch -> Diagnose Viewer -> Filtermöglichkeiten -> Time interval

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration des Zeitfilters für die Darstellung der Einträge.

Parameter | Beschreibung
Start time: | Auswahl des Datums und Zeitpunkts, ab dem Einträge angezeigt werden. Default: aktuelles Datum
End time: | Auswahl des Datums und Zeitpunkts bis zu dem Einträge angezeigt werden. Default: aktuelles Datum
Reset time interval | Setzt Filter auf Standardwert zurück.
OK | Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft alle Änderungen aller Registerkarten und schließt Dialog.


Colors

Handbuch -> Diagnose Viewer -> Filtermöglichkeiten -> Colors

Auswahl der farblichen Kennzeichnung von Informationen.

Parameter | Beschreibung
Colors for: | Auswahl der Farbe
IP address | Aktiv: Unterschiedliche IP-Adressen werden unterschiedlich eingefärbt.
Modules | Aktiv: Unterschiedliche Module werden unterschiedlich eingefärbt.
Log connection | Aktiv: Unterschiedliche Namen der LOG-Verbindung werden unterschiedlich eingefärbt.
no colors | Aktiv: Einträge werden nicht eingefärbt.
OK | Übernimmt alle Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft alle Änderungen aller Registerkarten und schließt Dialog.


Lesen der LOG-Dateien

Handbuch -> Diagnose Viewer -> Lesen der LOG-Dateien

Es können ein bis mehrere LOG-Dateien gleichzeitig in einer Auswertung geöffnet werden.

Zur Einschränkung der Anzeige muss ein Vorfilter eingestellt werden.

Dies ist mittels fünf Registerkarten möglich. Dieser Filter kann nachträglich verändert werden. Ist der Filter eingestellt, werden nur die Einträge angezeigt, die diese Filterbedingungen erfüllen. Die Einträge werden chronologisch aufgelistet.

Eine weitere Filtermöglichkeit besteht durch die Filterspalten. Pro Spalte können unterhalb der Spaltenüberschrift Filterbedingungen eingegeben werden. Die Felder unterstützen Regular Expressions, wodurch auch komplexe Filterbedingungen gebildet werden können.

Die Liste ist durch Anklicken der Spaltenüberschrift aufsteigend oder absteigend sortierbar.

Angezeigte Einträge können gespeichert werden.

Felder in der LOG-Datei:

Parameter | Beschreibung
IP address/Process ID/Log ID | Diese Felder identifizieren den Client und ermöglichen die Zuordnung der Meldung.
Name of log connection | Zeigt den Verbindungsnamen an.
Thread ID | ID des Threads von welchem aus die Meldung eingetragen wurde.
Timestamp | Zeitpunkt der Meldungserstellung in UTC.
Message Level | Enthält den Names des Messagelevels welcher die Meldung eingetragen hat.
Module | Name des Moduls welches die Meldung eingetragen hat.

Optionale Felder mit fixer ID.

ID | Konstante | Erklärung
1 | logid_logname | Name der Logging-Verbindung
2 | logid_threadname | Threadbenennung
3 | logid_sourcefile | Sourcefilebenennung
4 | logid_sourceline | Sourceline
5 | logid_assertcond | Assertbedingung
6 | logid_compname | Computername
7 | logid_funcname | Funktionsname
8 | logid_prjname | Projektname
9 | logid_prjguid | Projektguid
A | logid_prjpath | Projektpfad
B | logid_tx | Gesendete Daten
C | logid_rx | Empfangene Daten
D | logid_serialport | Nummer d. seriellen Schnittstelle
E | logid_baud | Baudrate
F | logid_dtr | Dtr Einstellung
10 | logid_rts | Rts Einstellung
11 | logid_bytesize | Serielle Zeichenlaenge
12 | logid_parity | Paritaet
13 | logid_stopbit | Anzahl der Stopbit
14 | logid_ctsflow | CTS
15 | logid_dsrflow | Dsr
16 | logid_dsrsens | Dsr sensitivity
17 | logid_port | Netzwerk Portnummer
18 | logid_srvname | Servername
19 | logid_sbname | Standby-Name
1A | logid_cliname | Client-Name
1B | logid_srvIP | Server IP-Adresse
1C | logid_sbIP | Standby IP-Adresse
1D | logid_cliIP | Client IP-Adresse
1E | logid_bindump | Binaerpuffer
1F | logid_ptr | Pointer
20 | logid_classname | Klassenname
21 | logid_errcode | Errorcode
22 | logid_dllinstance | DLL Instanzhandle
23 | logid_dllname | DLL Name
24 | logid_errpar1 | Treiber error-parameter 1
25 | logid_errpar2 | Teiber error-parameter 2
26 | logid_trace | Trace Meldung
27 | logid_errortxt | Fehlertext
28 | logid_errorfile | Fehlerdateiname
29 | logid_succeedcond | Bedingung für Erfolg
2A | logid_succeedvalue | Wert wenn erfolgreich
2B | logid_net | Netzadresse
2C | logid_db | Datenbaustein
2D | logid_ofs | Offset
2E | logid_bit | Bitnummer
2F | logid_area | Bereich in Steuerung
30 | logid_dir | Gibt die Richtung der Kommunikation mittels String an.
31 | logid_txt | Allgemeiner Text
32 | logid_mainvers | Hautpversionsnsummer
33 | logid_minorvers | Unterversionsnummer
34 | logid_buildvers | Build Nummer
35 | logid_sp | Servicepack
36 | logid_hotfix | Hotfixnummer
37 | logid_clisrc | Client welcher das Kommando ausgesendet hat
38 | logid_clidst | Client welcher als Ziel für das Kommando gilt
39 | logid_pvid | Datenpunktnummer (Kanalnummer)
3A | logid_pvname | Datenpunktname
3B | logid_pvvalue | Wert des Datenpunktes
3C | logid_pvstatus | Status des Datenpunktes
3D | logid_pvtime | Zeitstempel des Datenpunktes in s
3E | logid_duration | Zeitdauer in ms
3F | logid_cnt | Anzahl, Zähler


Struktur der Log-Datei

Handbuch -> Diagnose Viewer -> Struktur der Log-Datei

Log-Dateien sind ANSI-Textfiles. Die einzelnen Felder werden mittels Tabulatorzeichen getrennt. Als Endezeichen wir CR+LF verwendet. Hierdurch können diese Dateien im Notepad geöffnet werden.

Log-Dateien enthalten die Informationen sequentiell, zeitlich nicht sortiert.

Noch in diesem Kapitel

Meldungsebenen

Suchfunktion

Profile


Meldungsebenen

Handbuch -> Diagnose Viewer -> Struktur der Log-Datei -> Meldungsebenen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Unterteilung der Log-Meldungen werden acht Gruppen geschaffen: Diese sind Bit-kodiert und können somit auch kombiniert werden.

1 | Fehlermeldungen
2 | Warnungen
4 | Erfolgsmeldungen
8 | TRACE
16 | ASSERT
32 | Log-Meldungen
64 | Debug
128 | Erweitertes Debug


Suchfunktion

Handbuch -> Diagnose Viewer -> Struktur der Log-Datei -> Suchfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über View/Find kann im aktuellen Fenster gesucht werden. Alle Treffer werden markiert.


Profile

Handbuch -> Diagnose Viewer -> Struktur der Log-Datei -> Profile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Spalteneinstellungen können als Profile gespeichert werden:

Um Profile zu speichern:

  1. geben Sie im Feld in der Symbolleiste einen Namen ein
  2. klicken Sie auf das Symbol mit der Diskette direkt rechts daneben

Um Profile zu laden:

  1. wählen Sie aus der Combobox ein gespeichertes Profil
  2. klicken Sie auf das zweite Symbol rechts davon mit der Diskette

Die Profile werden als *.lvs Datei gespeichert.


Fehlerbehandlung und Meldungen

Handbuch -> Diagnose Viewer -> Fehlerbehandlung und Meldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler

Fehler

Mögliche Ursachen

Der Port kann nicht geöffnet werden.
  • Eine andere Anwendung verwendet den Port.
    Prüfen mit "netstat".
  • Die Ports bei den Einträgen
    [SYS_REMOTE] CONFIG und
    [LOGGING_SYSTEM] CONFIG
    sind identisch. zenLogSrv und zenSysSrv versuchen dann den gleichen Port zu öffnen.

Diagnose Clients starten den zenLogSrv nicht
  • Der zenAdminSrv wurde beendet. Ohne diesen kann der Dienst nicht gestartet werden.
  • Der zenLogSrv ist am PC nicht als Dienst registriert. In diesem Fall in der Kommandozeile eingeben: zenLogSrv.exe –Service
  • Diagnose Clients sind nicht von der Version 7.00SP0 oder höher. Der zenLogSrv wird erst ab dieser Version verwendet.
  • Unter Windows CE: Die einzelnen Komponenten (Runtime, SysSrvCE, LogSrvCE) liegen in unterschiedlichen Ordnern. Diese müssen sich im gleichen Ordner befinden, sonst können sich die Komponenten nicht gegenseitig finden.

Unter CE werden viele Prozesse von SysSrvCE.exe bzw. von LogSrvCE.exe angelegt.
  • Einer der beiden Einträge in der zenon6.ini
    [SYS_REMOTE] INIT oder
    [LOGGING_SYSTEM] INIT
    hat den Wert 2.
    Dies führt dazu, dass die Anwendung nur die Oberfläche zeigt und den Listening Port nicht öffnet. Jeder Diagnose Client versucht dann, den Prozess zu starten, da er sich nicht zum Diagnose Server verbinden kann.

Diverse Prozesse stürzen ab.

(Unhandeled Exceptions des Diagnose Server beim Empfangen von LOG-Meldungen bzw. Konfigurationskommandos oder des Diagnose Clients und Diagnose Viewers beim Hochfahren bzw. Erhalten der Konfiguration)
  • Die Versionen passen nicht zusammen. Diagnose Clients, Diagnose Server und Diagnose Viewer müssen entweder alle Version 7.00 SP0 und höher ODER alle Version 6.51 SP0 und früher haben (siehe Kompatibilität).

LOG-Einträge

Eintrag

Erklärung

SysSrv received not supported network message!

Der zenSysSrv hat ein Netzwerktelegramm empfangen, das nicht unterstützt wird. Beispiel: LOG-Einträge.

LogSrv received not supported network message!

Der zenLogSrv hat ein Netzwerktelegramm empfangen, das nicht unterstützt wird. Beispiel: Remote Transport Befehle.

Could not open listening port. Server will be stopped.

Der zenLogSrv oder der zenSysSrv konnte seinen Listening Port nicht öffnen. Die Fehlermeldung wird wie folgt protokolliert:

  • zenLogSrv und zenSysSrv am PC:
    Eintrag in die Windows-Ereignisanzeige.
  • zenSysSrv unter CE:
    Message-Box für den Benutzer und LOG-Eintrag an den Diagnose Server.
  • zenLogSrv unter CE:
    Message Box für den Benutzer.

Folgende LOG-Einträge werden unterschiedlichen Systemen zugeordnet. Der erste Teil der Meldung gibt an, ob Dienst oder Client betroffen sind:

  • SysSrv: zenSysSrv
  • SysCli: Client zum zenSysSrv
  • LogSrv: zenLogSrv
  • LogCli: Diagnose Client
Eintrag | Erklärung
[SysSrv/LogSrv/SysCli/LogCli] Info InitString [String] | Eine Netzwerkverbindung wurde mit dem angezeigten Konfigurationsstring initialisiert. Server öffnen Ports und Clients verbinden sich zu den Servern.
[SysSrv/LogSrv/SysCli/LogCli] WINSOCK ERROR | Bei einer Netzwerkoperation ist ein Ausnahemfehler aufgetreten. Details werden ebenfalls ausgegeben.
[SysSrv/LogSrv] Accept Failed! | Eine eingehende Verbindung von einem Client konnte nicht angenommen werden.
[SysSrv/LogSrv/SysCli/ LogCli] Write Faild | Es konnten nicht alle zu sendenden Daten gesendet werden. Die Anzahl der gesendeten Bytes und die Anzahl zu sendender Bytes werden angegeben.
[SysSrv/LogSrv] Client [String] in List Delete! | Der Client hat sich vom Server abgemeldet.
[SysSrv/LogSrv] Client [String] in List Insert | Der Client hat sich beim Server angemeldet.


Editor

Handbuch -> Editor

zenon besteht aus zwei Hauptkomponenten, dem Editor und der Runtime. Im Editor werden Projekte erstellt und gewartet, das Bedienen und Beobachten erfolgt in der Runtime. In Abschnitt Editor lernen Sie die grundlegenden Bestandteile des Editors kennen, erfahren Sie mehr über den Umgang mit Projektmanager, Symbolleisten, Menüs und Editorprofilen. Erklärungen zum Kontextmenü der Elemente in einem Bild finden Sie im Kapitel Bilder.

tutorial Lizenzinformation

Der zenon Editor ist lizenzpflichtig. Die Lizenz wird nach Anzahl der jeweils benötigten TAGs oder der IOs berechnet. Details zur Lizenzierung siehe Kapitel Lizenzierung.

Der Editor steht als zenon Supervisor und als zenon Operator für >Embedded Betriebssysteme zur Verfügung. Beide Versionen unterscheiden sich im Funktionsumfang. Details siehe Einschränkungen für zenon Operator.

SQL Server

Der zenon Editor arbeitet mit einer SQL Datenbank. Diese wird bei der Installation des zenon Editors mitinstalliert. Um eine Verbindung herzustellen verbindet sich der Editor zum zenon Datenbankserver (zenDBSrv.exe). Dieser stellt die Verbindung zum SQL Server her.

Mehrmonitor-Betrieb

Sind auf einem PC mehrere Monitore im Einsatz, können Dialoge, Symbolleisten usw. auf andere Monitore verschoben werden. Deren Position wird gespeichert und beim nächsten Start des Editors beibehalten.

info Info

Steht beim Neustart des Editors nur noch der Hauptmonitor zur Verfügung, werden verschobene Elemente eventuell im nicht sichbaren Bereich angezeigt. Um alle Elemente wieder auf dem Hauptmonitor anzuordnen, aktivieren Sie das Standardprofil. Damit werden die Positionen wieder auf Standardwerte zurückgesetzt.

Noch in diesem Kapitel

Editor starten

Kompatibilität

Oberfläche

Symbolleisten

Menüleiste

Editorprofile

Projektmanager

Hauptfenster

Eigenschaftenfenster

Eigenschaftenhilfe

Ausgabefenster

Statuszeile

Editor beenden


Editor starten

Handbuch -> Editor -> Editor starten

Um den Editor zu starten stehen Ihnen mehrere Wege zur Verfügung:

  • Klicken Sie auf das zenon Symbol auf dem PC-Desktop.
  • Aufruf über das Windows Menü Datei -> COPA-DATA -> zenon Editor.
  • Start über das Startup Tool. Dieses erlaubt das Verwalten mehrerer zenon Versionen und die Konfiguration des Editors und der Runtime vor dem Start.
  • Per Windows Autostart.

Dienst zenAdminSrv

Zum Starten des Editors muss der Dienst zenAdminSrv gestartet sein. Ist der Dienst nicht verfügbar, werden Sie mit der Fehlermeldung "Der Editor kann nicht gestartet werden, da der Dienst 'zenAdminSrv' nicht erreichbar ist!" informiert. Aktivieren Sie den Dienst und starten Sie den Editor neu.

Beim Start über Windows Autostart versucht zenon 5 Mal den Editor zu starten und bricht dann mit der Fehlermeldung, dass der Dienst nicht erreichbar ist, ab.


Kompatibilität

Handbuch -> Editor -> Kompatibilität

Der zenon Editor ist vollständig abwärtskompatibel. Projekte, die mit einer niedrigeren Version erstellt wurden, können jederzeit geöffnet und bearbeitet werden.

Beim Öffnen eines Projekts mit niedrigerer Versionsnummer:

  • wird das Projekt automatisch konvertiert
  • wird automatisch eine Sicherung des Projekts angelegt

Achtung: Konvertierte Projekte können in einem Editor mit niedrigerer Versionsnummer nicht mehr geöffnet werden. Die beim Konvertieren erstellte Projektsicherung kann aber weiterhin geöffnet und bearbeitet werden.

Kompatibilität zwischen Editor und Runtime

Mit dem zenon Editor können Runtime-Dateien für unterschiedliche Runtime-Versionen erstellt werden. Die Version der Runtime muss damit nicht mit der Version des Editors übereinstimmen. Diese Abwärtskompatibilität eignet sich besonders für den Einsatz gemischter Systeme. Zum Beispiel: Ein Projekt, das mit dem Editor 6.50 projektiert wird, kann auch mit einer Runtime 6.22 gestartet werden.

attention Achtung

Werden in einem Projekt mit einem Editor der höheren Version Eigenschaften projektiert, die in der niedrigeren Version nicht verfügbar sind, stehen diese dort nicht zur Verfügung. Das kann zur Runtime zu unerwünschten Ergebnissen führen.

Runtime-Dateien erstellen

Um im Editor Runtime-Dateien für niedrigere Versionen zu erstellen:

  1. markieren Sie das Projekt im Projektbaum
  2. navigieren Sie in den Projekteigenschaften zum Abschnitt Allgemein

    Interne ID: Kompatibilität

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. öffnen Sie die Dropdownliste der Eigenschaft RT Dateien erzeugen für

    Interne ID: Kompatibilität

    RT Dateien erzeugen für

    Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt

    6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.

    6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.

    6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.

    6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.

    6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.

    6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.

    6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

    Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie die gewünschte Version:
    • Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt
    • 6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.
    • 6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.
    • 6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.
    • 6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.
    • 6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.
    • 6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.
    • 6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.

XML

In XML exportierte Daten stehen auch für den Import in höhere Editor-Versionen zur Verfügung.

Ausnahme: Werden Daten aus dem RGM über die Exportfunktion zur Runtime direkt als XML-Datei gespeichert, können diese nicht wieder importiert werden.


Oberfläche

Handbuch -> Editor -> Oberfläche

Die Benutzeroberfläche des Editors gliedert sich in verschiedene Bereiche:

Element

Inhalt

01 - Symbolleisten:

Sammlung der Symbolleisten für den Editor und seine Module. Sie stehen zur Verfügung für:

  • Andockbare Fenster
  • Ausrichtung
  • Bilder / Symbole
  • Editorprofile
  • Elemente
  • Menüleiste
  • Production & Facility Scheduler
  • Remote Transport
  • Report Generator
  • Runtime Dateien
  • Sichtbarkeitsebenen
  • VBA-Makros

02 - Projektmanager:

Baumansicht des Projektmanagers.

03 - Detailansicht des Projektmanagers:

Details zum im Projektmanager ausgewählten Modul.

04 - Hauptfenster:

Hauptarbeitsbereich, hier werden Dokumente wie Bilder oder Reporte dargestellt.

05 - Symbolleiste Elemente:

Symbolleiste für die Elemente der Bilder - Vektorelemente und Dynamische Elemente.

06 - Eigenschaften

Zeigt Eigenschaften des ausgewählten Objekts an. Dafür stehen drei Modi zur Verfügung, die in der Symbolleiste der Eigenschaften ausgewählt werden.

07 - Eigenschaftenhilfe:

Zeigt kurze Hilfeeinträge zu Eigenschaften von Bildern, Variablen, Funktionen und anderen Elementen, die parametriert werden, an.

08 - Ausgabefenster

Anzeige von Meldungen, wenn Projekte kompiliert und zur Runtime abgesetzt werden.

09 - Statusleiste:

Zeigt Statusinformationen zur Editorbereitschaft und für Bilder an.

10 - Symbolleiste Eigenschaften:

Definiert Anzeige und Sortierung der Eigenschaften, blendet Eigenschaftenhilfe ein.

11 - Querverweisliste:

Welche Fenster angezeigt werden, wählen Sie aus:

  • in der Dropdownliste unter Optionen

Die Anordnung der Fenster lässt sich individuell anpassen. Nur das Hauptfenster kann nicht ausgeblendet werden.

Noch in diesem Kapitel

Ansicht anpassen

Fenster positionieren

Vollbildmodus

Tastenkombinationen


Ansicht anpassen

Handbuch -> Editor -> Oberfläche -> Ansicht anpassen

Alle Fenster des Editors lassen sich individuell anordnen. Die Einstellungen zur Anordnung der Fenster erreichen Sie mit einem Rechtsklick auf den Rand des Fensters. Eigene Einstellungen können als Editorprofile gespeichert werden.

Kontextmenü Fenster

Option

Status

Funktion

Unverankert

aktiv

Das ausgewählte Fenster ist am Desktop frei positionierbar. wird im Hauptfenster angezeigt. Sie können mehrere Fenster im Hauptfenster anzeigen und zwischen diesen umschalten.

Doppelklick in Titelleiste schaltet um zwischen Unverankert und Andocken.

inaktiv

(default)

Das Fenster wird angedockt. Die Eigenschaft Andocken ist aktiv.

Andocken

aktiv

(default)

Fenster können mit gedrückter linker Maustaste beliebig verschoben werden. Während des Verschiebens zeigt eine Positionierungshilfe die Position an, an der das Fenster eingefügt würde. Beim Loslassen der Maustaste wird das Fenster an die umgebenden Fenster angedockt.

Beim Umschalten von Unverankert auf Andocken wird das Fenster an seiner letzten angedockten Position eingefügt.

Doppelklick in Titelleiste schaltet um zwischen Unverankert und Andocken.

Tipp: Soll ein Fenster verschoben, aber nicht angedockt werden, halten Sie während des Verschiebens die Taste Strg gedrückt. In diesem Fall wird keine Positionierungshilfe angezeigt.

inaktiv

Fenster können mit gedrückter linker Maustaste beliebig verschoben werden. Beim Loslassen werden sie an der jeweiligen Stelle im Vordergrund angezeigt.

Die Eigenschaft Unverankert ist aktiv.

Im Hauptfenster aufschalten

aktiv

Das Fenster wird im Hauptfenster als Registerkarte angezeigt.

Alle Registerkarten werden im Hauptfenster angezeigt. Mit Klick auf den Fenstertitel wechseln Sie zwischen einzelnen Registerkarten.

Um eine Registerkarte wieder als Fenster anzuzeigen, öffnen Sie mit einem Rechtsklick auf den Fenstertitel das Kontextmenü und schalten die Eigenschaft Im Hauptfenster aufschalten auf inaktiv.

inaktiv

(default)

Fenster wird normal angezeigt.

Automatisch ausblenden

aktiv

Sobald das Fenster den Mausfokus verliert, wird es in den Hintergrund gestellt. Der Fenstertitel wird am linken Rand des Editors angezeigt.

Um das Fenster wieder in den Vordergrund zu holen, bewegen Sie die Maus über den Fenstertitel.

inaktiv

(default)

Fenster wird immer im Vordergrund angezeigt.

Schließen

Das Fenster wird geschlossen.

Um es wieder anzuzeigen, wählen Sie in der Menüleiste -> Optionen -> Fenstername


Fenster positionieren

Handbuch -> Editor -> Oberfläche -> Fenster positionieren

Positionierung

Alle Fenster im zenon Editor können beliebig am Desktop positioniert werden per:

  • Drag & Drop: Fenster werden an gewünschte Position gezogen und entweder frei platziert (Unverankert) oder angedockt.
  • Doppelklick in Titelleiste: schaltet um zwischen Unverankert und Andocken.

Positionierungshilfe

Beim Bewegen von Fenstern auf der Editoroberfläche werden Positionierungshilfen angezeigt. Diese repräsentieren Fenster bzw. seine Ränder.

Dieses Element repräsentiert einen Fensterbereich im Editor.

Dieses Element repräsentiert den Randbereich des Editors.

Fenster positionieren

Um ein Element angedockt zu positionieren:

  1. bewegen Sie das Element mit der Maus in den gewünschten Bereich
  2. die Positionierungshilfe wird eingeblendet
  3. diese repräsentiert ein Fenster und dessen Bereiche:
    1. Mitte: gesamtes Fenster
    2. oben: obere Hälfte
    3. unten: untere Hälfte
    4. rechts: rechte Hälfte
    5. links: linke Hälfte

    oder den Rand des Editors

  4. bewegen Sie die Maus in die zentrale Positionierungshilfe oder auf eine Positionierungshilfe am Rand des Editors und dort auf den gewünschten Bereich
  5. der Bereich im Editor, an dem das Element beim Loslassen der Maustaste platziert würde, wird blau eingefärbt
  6. bewegen Sie die Maus innerhalb der Positionierungshilfe bis der gewünschte Bereich blau angezeigt wird
  7. lassen Sie die Maustaste los, das Element wird platziert

Beispiele

  1. Das Fenster Eigenschaften wird angedockt verschoben.
  2. Dabei werden die Positioinierungshilfen eingeblendet.

  3. Der Mauszeiger wird über den oberen Pfeil der zentralen Positionierungshilfe geführt.
  4. Im Editor wird der Einfügebereich blau markiert.

  5. Mit dem Loslassen der Maustaste wird das Fenster an der markierten Stelle eingefügt:

  6. Jetzt wird der Mauszeiger über die obere Rand-Positionierungshilfe geführt.
  7. Im Editor wir der Einfügebereich wieder blau markiert.

  8. Mit dem Loslassen der Maustaste wird das Fenster an der markierten Stelle eingefügt:


Vollbildmodus

Handbuch -> Editor -> Oberfläche -> Vollbildmodus

Im zenon Editor können Sie das Hauptfenster in den Vollbildmodus schalten. Dazu

  • benutzen Sie die Tastenkombination Umschalt+F9
    oder
  • wählen in der Dropdownliste Fenster den Eintrag Vollbildmodus aus

Der Vollbildmodus blendet alle übrigen Fenster aus und zeigt nur das Hauptfenster mit allen geöffneten Dokumenten (Bilder, Reporte, ...) als Vollbild über den ganzen Bildschirm an.

Der Vollbildmodus kann beendet werden über:

  • die eingeblendete Schaltfläche zum Beenden des Vollbildmodus
  • die Tastenkombination Umschalt+F9
  • die Taste Esc

Im Vollbildmodus arbeiten

Im Vollbildmodus wird ein Menü zum Beenden des Modus und zum Aufschalten bestimmter Fenster und Symbolleisten eingeblendet:

Parameter

Beschreibung

Vollbild schließen

Beendet den Vollbildmodus. Alternativ auch über Tastenkombination Umschalt+F9 oder Taste Esc möglich.

Andockbare Fenster

Dropdownliste zum Öffnen der Fenster:

  • Eigenschaften
  • Eigenschaftenhilfe

Fenster werden bei erster Nutzung an fest definierter Position aufgeschaltet. Sie können dann beliebig positioniert werden und werden beim nächsten Aufschalten im Vollbildmodus an der individuell definierten Position geöffnet.

Symbolleisten

Dropdownliste zum Öffnen der Symbolleisten:

  • Bilder
  • Ausrichtung
  • Sichtbarkeitsebene
  • Elemente

Symbolleisten werden bei erster Nutzung an fest definierter Position aufgeschaltet. Sie können dann beliebig positioniert werden und werden beim nächsten Aufschalten im Vollbildmodus an der individuell definierten Position geöffnet.


Tastenkombinationen

Handbuch -> Editor -> Oberfläche -> Tastenkombinationen

Allgemein

Befehl | Tastenkombination
Hilfe starten | F1
Vollbild Modus starten/beenden | Umschalt+F9
Remote: Vollbildmodus beenden | Strg+Alt+Umschalt+F
VSTA Editor starten | Alt+F10
VBA Editor starten | Alt+F11
Wizards: Auswahl öffnen | Alt+F12
Dateiexplorer mit Fokus auf SQL-Ordner für aktuelles Projekt öffnen. Entspricht: %ProgramData%\COPA-DATA\[SQL-Ordner]\[UID]\FILES | Strg+Alt+E
Dateiexplorer mit Fokus auf Projekt-Dateien des aktuellen Projekts öffnen. Entspricht: %CD_USERDATA% Zum Beispiel: C:\Users\Public\Documents\<CD_zenon_Projects | Strg+Alt+D

Editorprofile

Befehl | Tastenkombination
Editorprofil 1 laden | Umschalt+F1
Editorprofil 2 laden | Umschalt+F2
Editorprofil 3 laden | Umschalt+F3
Editorprofil 4 laden | Umschalt+F4
Editorprofil 5 laden | Umschalt+F5
Editorprofil 6 laden | Umschalt+F6
Editorprofil 7 laden | Umschalt+F7
Editorprofil 8 laden | Umschalt+F8
aktuelle Editoransicht speichern als: |
Editorprofil 1 | Strg+Umschalt+F1
Editorprofil 2 | Strg+Umschalt+F2
Editorprofil 3 | Strg+Umschalt+F3
Editorprofil 4 | Strg+Umschalt+F4
Editorprofil 5 | Strg+Umschalt+F5
Editorprofil 6 | Strg+Umschalt+F6
Editorprofil 7 | Strg+Umschalt+F7
Editorprofil 8 | Strg+Umschalt+F8

Grafikeditor

Hinweis zu Tastenkombinationen: Das Pluszeichen (+) bedeutet, Tasten werden gemeinsam gedrückt.
Zum Beispiel:

Strg+A bedeutet: Taste Strg halten und dann Taste A drücken.

Strg++ bedeutet Taste Strg halten und Taste + drücken.

Allgemein

Befehl | Tastenkombination
Hauptfenster: Inhalte mit Verschiebehand scrollen | Leer gedrückt halten
Aktuelles Bild schließen | Strg+F4
Eigenschaften öffnen | Alt+Eingabe

Auswählen

Befehl

Tastenkombination

Mehrere Objekte auswählen

Umschalt oder Strg halten

Ausgewähltes Element bei Mehrfachselektion abwählen

Strg+Mausklick

Auswahl: Reihenfolge ändern. Definiert Element, an dem sich alle anderen orientieren

Umschalt beim Auswählen halten

Verdeckte Objekte auswählen
  1. Alt drücken
  2. Objekt anklicken und bewegen

Alle Elemente eines Bildes auswähen.

Strg+A

Nächstes Element in Reihenfolge der Erstellung auswählen

Tab

Vorheriges Element in Reihenfolge der Erstellung auswählen

Umschalt+Tab

Positionieren

Befehl | Tastenkombination
Ausgewähltes Objekt verschieben. | Pfeiltasten
Um 10 Pixel je Druck auf Pfeiltaste verschieben | Umschalt+Pfeiltaste
Nur waagrecht oder nur senkrecht verschieben | Umschalt beim Verschieben halten
Zentriert ausgewähltes Objekt im Arbeitsausschnitt | H

Aktionen

Befehl | Tastenkombination
Speichert Änderungen | Strg+S
Fügt Element aus der Zwischenablage ein | Strg+V Umschalt+Einfg
Fügt Element aus der Zwischenablage an der Originalposition ein, Original und Kopie liegen deckungsgleich übereinander | Strg+Umschalt+V
Kopiert ausgewähltes Elemente | Strg+C Strg+Einfg
Kopieren statt verschieben | Strg beim Verschieben halten
Löscht ausgewähltes Element | Entf
Schneidet ausgewähltes Elementen aus | Umschalt+Entf Strg+X
Macht Änderungen rückgängig | Strg+Z Alt+Rück
Knoten im ausgewählten Element hinzufügen oder löschen. Hinzufügen: Mauszeiger wird zu Pluszeichen (+). Löschen: Mauszeiger wird zu Minuszeichen (-). Funktioniert bei Polylinie, Polygon und Rohrelement. | Strg+Umschalt
Zeichnen von Polylinien und Polygonen beenden | S
Zeichnen von Polylinien und Polygonen beenden und letzten gezeichneten Teilbereich löschen | Esc
Ausgewählte Elemente um eine Ebene höher stufen | +
Ausgewählte Elemente um eine Ebene tiefer stufen | -
Ausgewählte Elemente in den Vordergrund holen | Strg++
Ausgewählte Elemente in den Hintergrund setzen | Strg+-

Skalieren

Befehl

Tastenkombination

Größe ändern

Mauszeiger auf Anfasspunkt positionieren, so dass sich der Mauszeiger in Pfeile ändert. Danach kann mithilfe der Pfeiltasten pixelgenau bzw. bei gedrückter Umschalt Taste in Schritten von 10 Pixel positioniert werden.

Hinweis: Wurde für ein Element über die Eigenschaft Drehwinkel [°] ein Winkel ungleich 0 definiert, ist das Skalieren mittels Pfeiltasten nicht möglich.

Interne ID: Tastenkombinationen

Drehwinkel [°]

Frei definierbarer Winkel, um den das Element gedreht wird. Positive Werte drehen gegen den Uhrzeigersinn, negative Werte im Uhrzeigersinn. Werte über 360° werden als Differenz zu 360° dargestellt (400° entspricht 40°). Es können nur ganze Zahlen eingetragen werden.

Bei gedrehten Elementen sind folgende Aktionen nicht mehr möglich:
- spiegeln
- rotieren um +/- 90°
- skalieren per Pfeiltasten

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Objekt um den Mittelpunkt skalieren

Alt beim Skalieren halten.

Proportional skalieren

Umschalt beim Skalieren halten.

Detailansicht

Befehl | Tastenkombination
Neues Element für das jeweilige Modul anlegen | Einfg
Bearbeiten der ausgewählten Spalte | F2
Kopieren eines ausgewählten Listenelements | Strg+C
Einfügen eines zuvor kopierten Listenelements | Strg+V
Entfernen eines ausgewählten Listenelements | Entf
Mehrere Elemente in der Liste hinaufscrollen | BILD auf
Mehrere Elemente in der Liste hinunterscrollen | BILD ab
Navigieren in der Liste | PFEILTASTEN

Runtime

Befehl | Tastenkombination
Runtime starten, zuvor geänderte Runtime-Dateien erzeugen. | F5
Geänderte Runtime Dateien erzeugen. | F7
Blättert durch offene Windows Fenster. | Alt+Tab
Runtime beenden. | Alt+F4
Explorer mit Fokus auf Ordner für die Runtime-Dateien öffnen. Projekt muss dazu im Projektbaum markiert sein. | Ctrl+Alt+D
Explorer mit Fokus auf Ordner mit dem Runtime-Projekt öffnen. Projekt muss dazu im Projektbaum markiert sein. | Ctrl+Alt+R


Symbolleisten

Handbuch -> Editor -> Symbolleisten

Die Haupt-Symbolleisten werden im Editor standardmäßig unterhalb der Menüleiste positioniert. Ausgenommen die Symbolleiste Elemente, diese wird rechts neben dem Hauptfenster angezeigt. Beim Bewegen der Maus über ein Symbol wird in der Statuszeile eine Information zur Funktion des Symbols angezeigt.

Folgende Haupt-Symbolleisten stehen zur Verfügung:

  • Andockbare Fenster
  • Ausrichtung
  • Bilder / Symbole
  • Editorprofile
  • Elemente
  • Menüleiste
  • Production & Facility Scheduler
  • Remote Transport
  • Report Generator
  • Runtime Dateien
  • Sichtbarkeitsebenen
  • VBA-Makros

Folgende Fenster verfügen über eigene Symbolleisten, die am oberen Fensterrand angezeigt werden:

  • Details Arbeitsbereich
  • Eigenschaften

info Info

Die Titel der Symbolleisten entsprechen immer der Sprache, die im Editor bei ihrem ersten Aufschalten aktiviert war. Wurde zum Beispiel die Symbolleiste 'Bilder' zum ersten Mal in Deutsch benutzt, behält sie ihren Namen auch dann, wenn der Editor später auf Englisch umgestellt wird.

Sollen die Namen auf eine andere Sprache umgestellt werden, müssen Sie zuerst alle Editorprofile löschen, dann den Editor in der gewünschten Sprache starten und die Symbolleisten aktivieren.

Editorprofile löschen Sie nicht in zenon, sondern auf Dateisystemebene. Details siehe Kapitel Editorprofile löschen.

Aktionen mit Symbolen und Symbolleisten

Die Optionen für die Symbolleisten werden eingestellt unter: Optionen -> Einstellungen -> Registerkarter Symbolleiste

Aktionen für Symbolleisten:

  • frei am Bildschirm positionieren
  • schließen
  • öffnen

Aktionen für Symbole:

  • löschen
  • hinzufügen

Symbolleiste positionieren

  1. klicken Sie mit der linken Maustaste in einen freien Bereich der Symbolleiste
  2. ziehen Sie die Symbolleiste an die gewünschte Stelle auf dem Bildschirm
  3. ein Rechteck zeigt an, wo und wie die Symbolleiste eingefügt wird
  4. lassen Sie die Maustaste los, um die Symbolleiste zu positionieren

Hinweis: Symbolleisten, die Dropdownlisten enthalten, können nur horizontal positioniert werden.

Symbolleiste schließen

Symbolleisten schließen Sie entweder über die Dropdownliste Optionen oder die Einstellungen unter Optionen.

Dropdownliste: schnellster Weg, um eine Symbolleiste zu schließen

  1. klicken Sie auf die Dropdownliste Optionen
  2. navigieren Sie zu Symbolleisten
  3. klicken Sie auf den Eintrag für die zu schließende Symbolleiste

Einstellungen: ermöglicht das Schließen mehrerer Symbolleisten gleichzeitig

  1. öffnen Sie das Menü Optionen -> Einstellungen -> Registerkarte: Symbolleiste
  2. entfernen Sie den den Haken neben der gewünschten Symbolleiste
  3. bestätigen Sie mit OK

Symbolleiste öffnen

Symbolleisten öffnen Sie entweder über die Dropdownliste Optionen oder die Einstellungen unter Optionen.

Dropdownliste: schnellster Weg, um eine Symbolleiste zu öffnen

  1. klicken Sie auf die Dropdownliste Optionen
  2. navigieren Sie zu Symbolleisten
  3. klicken Sie auf den Eintrag für die zu öffnende Symbolleiste

Einstellungen: ermöglicht das Öffnen mehrerer Symbolleisten gleichzeitig

  1. öffnen Sie das Menü Optionen -> Einstellungen -> Registerkarte: Symbolleiste
  2. setzen Sie den den Haken neben der gewünschten Symbolleiste
  3. bestätigen Sie mit OK

Symbole hinzufügen

  1. öffnen Sie das Menü Optionen -> Einstellungen -> Registerkarte: Befehle
  2. wählen Sie im linken Fenster eine Kategorie
  3. klicken Sie im rechten Fenster mit der linken Maustaste auf das gewünschte Symbol
  4. ziehen Sie das Symbol mit gedrückter linker Maustaste auf die gewünschte Position in der Symbolleiste

Symbole löschen

  1. öffnen Sie im Menü Optionen -> Einstellungen -> Registerkarte: Symbolleiste
  2. alle Symbole in allen Symbolleisten im Editor werden aktiviert
  3. klicken Sie mit der linken Maustaste auf das Symbol
  4. ziehen Sie das Symbol aus der Symbolleiste und lassen Sie die Maustaste los

Noch in diesem Kapitel

Symbolleiste Andockbare Fenster

Symbolleiste Ausrichtung

Symbolleiste Bilder

Symbolleiste Symbole

Symbolleiste Editorprofile

Symbolleiste Elemente

Symbolleiste Production and Facility Scheduler

Symbolleiste Remote-Transport

Symbolleiste Report Generator

Symbolleiste Runtime-Dateien

Symbolleiste Sichtbarkeitsebenen

Symbolleiste VBA-Makros

Symbolleiste Detailansicht

Symbolleiste Eigenschaften


Symbolleiste Andockbare Fenster

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Andockbare Fenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende ausgeblendete oder geschlossene Fenster können mit der Symbolleiste Andockbare Fenster wieder aktiviert werden.

Symbol (von links nach rechts) | Funktion
Projektmanager | Aktiviert den Projektmanager.
Ausgabe-Fenster | Aktiviert das Ausgabe-Fenster.
Querverweisliste | Aktiviert die Querverweisliste.
Eigenschaften-Fenster | Aktiviert das Eigenschaften-Fenster.
Eigenschaftenhilfe | Aktiviert das Eigenschaftenhilfe-Fenster.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Ausrichtung

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Ausrichtung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nr.

Symbol

Funktion

01

links ausrichten

Richtet alle markierten Elemente am linken Rand des Elements aus, das als erstes markiert wurde.

02

rechts ausrichten

Richtet alle markierten Elemente am rechten Rand des Elements aus, das als erstes markiert wurde.

03

oben ausrichten

Richtet alle markierten Elemente am oberen Rand des Elements aus, das als erstes markiert wurde.

04

unten ausrichten

Richtet alle markierten Elemente am unteren Rand des Elements aus, das als erstes markiert wurde.

05

Horizontale Mitte

Richtet das markierte Elemente an der horizontalen Bildmitte aus.

Wurden mehrere Elemente ausgewählt, richten sich alle an dem Element aus, das als erstes gewählt wurde.

06

Vertikale Mitte

Richtet das markierte Elemente an der vertikalen Bildmitte aus.

Wurden mehrere Elemente ausgewählt, richten sich alle an dem Element aus, das als erstes gewählt wurde.

07

Gleicher x-Abstand

Reiht die ausgewählten Elemente in der Reihenfolge ihrer Markierung entlang der x-Achse auf, wobei die beiden ersten Elemente den Abstand bestimmen.

08

Gleicher y-Abstand

Reiht die ausgewählten Elemente in der Reihenfolge ihrer Markierung entlang der y-Achse auf, wobei die beiden ersten Elemente den Abstand bestimmen.

09

Gleiche x-Verteilung

Verteilt alle markierten Elemente entlang der x- Achse zwischen den beiden Elementen, die als erste markiert wurden. Für diese Option müssen mindestens drei Elemente markiert sein.

10

Gleiche y-Verteilung

Verteilt alle markierten Elemente entlang der y-Achse zwischen den beiden Elementen, die als erste markiert wurden. Für diese Option müssen mindestens drei Elemente markiert sein.

11

Gleiche Breite

Markierte Elemente werden an die Breite des ersten gewählten Elements angepasst.

Hinweis: Anpassung erfolgt nach optischen Koordinaten. Details siehe Erklärung unter dieser Tabelle.

12

Gleiche Höhe

Markierte Elemente werden an die Höhe des ersten gewählten Elements angepasst.

Hinweis: Anpassung erfolgt nach optischen Koordinaten. Details siehe Erklärung unter dieser Tabelle.

13

Gleiche Größe

Markierte Elemente werden an die Höhe und Breite des ersten gewählten Elemente angepasst.

Hinweis: Anpassung erfolgt nach optischen Koordinaten. Details siehe Erklärung unter dieser Tabelle.

14

In den Vordergrund

Verschiebt ausgewählte Elemente in den Vordergrund.

15

Nach vorne

Verschiebt ausgewählte Elemente um eine Ebene nach vorne.

16

Nach hinten

Verschiebt ausgewählte Elemente um eine Ebene nach hinten.

17

In den Hintergrund

Verschiebt ausgewählte Elemente in den Hintergrund.

18

horizontal spiegeln

Spiegelt das ausgewählte Element an einer horizontalen Achse .

19

vertikal spiegeln

Spiegelt das ausgewählte Element an einer vertikalen Achse .

20

drehen um 90º

Dreht das ausgewählte um 90º gegen den Uhrzeigersinn.

21

Symbol erzeugen

Erzeugt aus allen ausgewählten Elementen ein neues Symbol.

22

Symbol auflösen

Das Symbol wird in seine ursprünglichen Elemente aufgelöst, das Symbol existiert nicht mehr.

23

Einzelbearbeitungsmodus Symbole/Element

Erlaubt es, einzelne Elemente eines Symbols zu bearbeiten. Schaltfläche schaltet zwischen Einzelbarbeitungsmodus und Symbolbearbeitungsmodus um.

24

In existierendes Symbol einfügen

Öffnet die Symbolliste, um das aktive Symbol in ein Symbol der Liste einzufügen.

25

Aus Symbol entfernen

löscht markiertes Element aus dem aktiven Symbol. Danach gehört das Element nicht mehr zum Symbol.

26

Verknüpfungen ersetzen

Öffnet den Dialog, um mit Dynamischen Elementen verknüpfte Variablen oder Funktionen zu ersetzen. Details: siehe Kapitel Ersetzen von Prozessvariablen in Dynamischen Elementen.Prozessvariablen in Dynamischen Elementen.

Prozessvariablen in Dynamischen Elementen.

Prozessvariablen in Dynamischen Elementen.

Prozessvariablen in Dynamischen Elementen.

Prozessvariablen in Dynamischen Elementen.

27

Eigenschaften übertragen

Überträgt die Eigenschaften eines ausgewählten Elements auf ein anderes oder mehrere.

  • Übertragen auf ein Element:

    Klick auf Element mit Ursprungseigenschaften -> Klick auf Symbol Eigenschaften übetragen -> Klick auf Zielelement: Eigenschaften werden übertragen

  • Übertragen auf mehrere Elemente:

    Quellelement auswählen -> Zielelemente mit gedrückter Strg-Taste auswählen (Quell und Zielelemente sind markiert, Quellelement durch schwarze Anfasspunkte hervorgehoben) -> Klick auf Symbol Eigenschaften übetragen. Eigenschaften des Quellelements werden auf die Zielelemente übertragen.

Welche Eigenschaften übertragen werden, ist abhängig von Quell- und Zielobjekt. In der Regel werden Farben, Schriftart, Textausrichtung und Umrandung übertragen.

Wurden mehrere Elemente als Quelle gewählt, werden die Eigenschaften des ersten gewählten Elements übertragen.

28

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

Anpassung gleiche Breite/Höhe/Größe

Die Größenanpassung von gedrehten und nicht-gedrehten Elementen orientiert sich an den optischen Koordinaten, nicht an den logischen. Die Ausdehnung gedrehter Elemente wird als Fläche des Rechtecks, innerhalb dessen gedachter Linien sich das gedrehte Element befindet (Bounding Rectangle), verstanden.

Zum Beispiel

Zwei Elemente vor der Anpassung:

Nach der Anpassung mittels Gleiche Höhe:


Symbolleiste Bilder

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Bilder

Für die Bearbeitung von Bildern steht eine Symbolleiste zur Verfügung. Diese wird standardmäßig unterhalb der Menüleiste angezeigt.

Symbol

(von links nach rechts)

Funktion

Bild speichern

Speichert das aktive Bild.

Alles speichern

Speichert alle geänderten Bilder.

Ausschneiden

Schneidet das aktive Bild aus und speichert es in der Zwischenablage, auch projektübergreifend. Nur verfügbar, wenn ein Element ausgewählt wurde.

Kopieren

Speichert eine Kopie des aktiven Bildes in der Zwischenablage. Nur verfügbar, wenn ein Element ausgewählt wurde.

Einfügen

Fügt ein Bild aus der Zwischenablage ein. Nur verfügbar, wenn die Zwischenablage Daten enthält.

Bild neu zeichnen

Aktualisiert die Bildschirmanzeige.

Bearbeitungsmodus

Schaltet von Zoom auf Bearbeitungsmodus um.

Rückgängig

Erlaubt es, bis zu 100 Aktionen rückgängig zu machen. Standardmäßig lassen sich 10 Aktionen rückgängig machen.

Die Anzahl der Aktionen definieren: Optionen -> Einstellungen ->Einstellungen -> Anzahl der rückgängig Aktionen. Tragen Sie hier eine Zahl zwischen 1 und 100 ein.

Zoom

Stellt zwei Zoom-Modi zur Verfügung:

  • Stufenloser Zoom:
    In der Combobox kann ein beliebiger Wert zwischen 15% und 400% eingegeben oder ein voreingestellter Wert ausgewählt werden.
  • Zoomtool:
    Über die beiden Lupensymbole (+ und -) wird im Bild per Mausklick direkt im Bild gezoomt. Drücken der Strg Taste schaltet zwischen den Modi um. Der eingestellte Zoom wird pro Bild gespeichert.

Zoom-Modus beenden: Klicken Sie auf das Symbol Bearbeitungsmodus. in der Symbolleiste Elemente.

Drucken

Der gesamte Bildschirminhalt wird auf dem als Standard gewählten Drucker ausgegeben. Druckereinstellung unter Datei -> Allgemeine Konfiguration -> Standard.

Hilfe

Ruft die Online Hilfe auf.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Symbole

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Symbole

Die Symbolbibliothek wird über das Kontextmenü oder die Symbolleiste bedient:

Befehle in Kontextmenü und Symbolleiste

Symbolleiste | Kontextmenü | Funktion
1 | Symbol neu | Legt ein neues Symbol an.
3 | Symbol öffnen | Öffnet das Symbol im Symboleditor zum Bearbeiten.
2 | Symbolgruppe neu | Eine neue Symbolgruppe wird angelegt und kann mit ausgewählten Symbolen aus der Bibliothek oder selbst erstellten Symbolen befüllt werden. (Kopieren und Einfügen). Nur verfügbar in der Globalen Symbolbibliothek.
4 | Symbol als eingebettetes Symbol in Bild einfügen | Bettet das Symbol in ein Bild ein (Details siehe Unterkapitel Eingebettete Symbole).
5 | Symbol als verknüpftes Symbol in Bild einfügen | Verknüpft Symbol in Bild (Details siehe Unterkapitel Verknüpfte Symbole).
13 | Flache Ansicht | Ordnet alle Symbole in einer flachen Liste an. Erleichtert die Suche nach bestimmten Symbolen. Hinweis: In dieser Ansicht können Symbole weder erzeugt noch gelöscht werden, auch das Kopieren oder Einfügen von Symbolen aus der Zwischenablage ist nicht möglich.
14 | Hierarchische Ansicht | Ordnet alle Symbole hierarchisch in Untergruppen und stellt Abhängigkeiten dar.
6 | Kopieren | Kopiert das ausgewählte Symbol in die Zwischenablage (nur in hierarchischer Ansicht).
7 | Einfügen | Fügt das kopierte Symbol in der aktiven Gruppe ein (nur in hierarchischer Ansicht).
8 | Löschen | Löscht das selektierte Symbol bzw. die Symbolgruppe (nur in hierarchischer Ansicht). Achtung: Das Löschen kann nicht rückgängig gemacht werden!
9 | Selektierte Zelle bearbeiten | Ermöglicht das Bearbeiten der Inhalte der selektierten Zelle.
10 | Text in selektierter Zelle ersetzen | Öffnet den Dialog zum automatisierten Ersetzen von Texten (nur vorhanden, wenn Zellen, die Text enthalten können, ausgewählt wurden).
11 | Eigenschaften | Öffnet das Fenster Eigenschaften für das gewählte Symbol.
12 | Knoten erweitern/reduzieren | Erlaubt in der hierarchischen Ansicht, den gewählten Knoten oder alle Knoten zu erweitern oder reduzieren.
15 | Selektierte XML exportieren | Öffnet den Dialog zum XML-Export der gewählten Symbole. (Details siehe siehe Kapitel Import/Export Symbole.)
16 | XML importieren | Importiert Symbole aus einer XML-Datei (siehe Kapitel Import/Export Symbole).
18 | Alle Filter entfernen | Löscht alle im Spaltentitel gesetzten Filter.
19 | Hilfe | Öffnet die Hilfe zum Kontextmenü.
17 | - | Springt zurück zum Ausgangselement (nur Symbolleiste).
 | Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Editorprofile

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Editorprofile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Editorprofile lassen sich bequem über die entsprechende Symbolleiste verwalten.

Symbol

(von links nach rechts)

Funktion

Selektiertes Editorprofil laden

Lädt das im Bereich Editorprofil auswählen selektierte Profil.

Editorprofil auswählen

Dropdownliste mit 10 Profilen.

Standardprofil laden

Setzt alle Einstellungen für Anzeige und Position von Fenstern sowie Inhalte und Anzeige von Symbolleisten auf Auslieferungszustand zurück und lädt das zenon Standardprofil.

Vordefinierte Profile laden

Lädt die von COPA-DATA vordefinierten Profile auf die ersten drei Speicherplätze und verknüpft sie mit den Modulen. Bereits bestehende Profile werden überschrieben.

Profilzuweisungen entfernen

Entfernt alle Verknüpfungen vordefinierter Profile zu den Modulen.

Automatisches Speichern der Editorprofile

Aktiv: Änderungen am aktuellen Profil werden beim Aufruf eines anderen Profils automatisch gespeichert.

Inaktiv: Änderungen werden beim Profilwechsel nicht gepeichert, beim nächsten Aufruf dieses Profils werden wieder die ursprünglichen Positionen hergestellt.

Selektiertes Editorprofil speichern

Speichert die aktuellen Fenster-Einstellungen in dem Profil, das im Bereich Editorprofil auswählen angezeigt wird.

Individuelle Namen für Editorprofile vergeben

Öffnet einen Dialog, in der individuelle Namen für Editorprofile vergeben werden können.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Elemente

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Elemente

Nr. | Symbol | Funktion
01 | Rechteck | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
02 | Linie | mit definierbarer Linienstärke, -farbe und -art
03 | abgerundetes Rechteck | Rechteck mit frei definierbar abgerundeten Ecken
04 | Ellipse/Kreis | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster (Kreis)
05 | Polygon | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
06 | Polylinie | mit Linienart und -farbe (bei Flächenbeschreibung auch Füllmuster und -farbe)
07 | Kreisbogen | mit definierbarer Linienstärke, -farbe und -art
08 | Kreissegment | zeichnet Kreissegment mit Öffnungswinkel 180º (veränderbar), definierbarer Linienstärke, -farbe und -art
10 | Statischer Text | mit Schriftfarbe und Auswahl der Schriftart
09 | Rohrleitung | mit Rahmen- und Füllfarbe; Rahmenart und Füllmuster
11 | Bargraf | Werte als Balkengrafik darstellen
12 | Zahlenwert | Werte numerisch darstellen
13 | Dynamischer Text | Grenzwerttexte anzeigen
14 | Trend-Element | einfache Liniengrafik
15 | Zeigerinstrument | Wert in Instrumentendarstellung
16 | Zustandselement | Farben aus der Zustandsprojektierung übernehmen
17 | Button | Aktionsfeld in Buttondarstellung
18 | Schalter | einfaches Befehls- bzw. Sollwertvorgabeelement
19 | Multibin | Darstellung mehrerer Prozessvariablen auf einem Bildpunkt in Farbe und Symbol (Zeichenkette)
20 | Bildalarmierung Button | Nur verfügbar mit einer SICAM 230 Lizenz
21 | Meldungselement | Darstellung von Texten aus einer Texttabelle
22 | Uhr | Datum und Uhrzeit
23 | Befehlsgabe-Element | Nur verfügbar mit einer SICAM 230 Lizenz
24 | Combi-Element | Darstellung einer oder mehrerer Variablen auf einem Bildpunkt in Farbe und Symbol (Zeichenkette)
25 | Bildalarmierung | Nur verfügbar mit einer SICAM 230 Lizenz
26 | ActiveX Element | AktivX-Elemente einfügen
27 | Universalregler | Schiebe- oder Drehregler
28 | Combo/Listbox | Werte von Variablen mit Textmeldungen verknüpfen
29 | WPF-Element | Stellt gültige WPF-XAML-Dateien dar.
30 | Bearbeitungsmodus | Schaltet aus Zoom in den Bearbeitungsmodus um
 | Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Production and Facility Scheduler

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Production and Facility Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Production Facility Scheduler lässt sich auch über eine Symbolleiste editieren.

Symbol (von links nach rechts) | Funktion
Umbennnen | Ermöglicht das Umbenennen einer Anlage.
Eigenschaften | Öffnet ein Fenster mit den Eigenschaften der Anlage.
Löschen | Löscht die ausgewählte Anlage nach Bestätigung.
Aufsteigend sortieren | Sortiert die ausgewählte Tabelle/Spalte aufsteigend.
Absteigend sortieren | Sortiert die ausgewählte Tabelle/Spalte absteigend.
Datum wechseln | Öffnet den Dialog zur Eingabe eines Datums und wechselt zu diesem Datum.
Heute anzeigen | Wechselt vom angezeigten Datum zum aktuellen Datum.
Tagesansicht | Zeigt im Kalender einen Tag an.
Wochenansicht | Zeigt im Kalender eine Woche an.
Monatsansicht | Zeigt im Kalender einen Monat an.
Vorheriges Element | Geht im Kalender entsprechend der eingestellten Anzeige um ein Element zurück (einen Tag, eine Woche oder einen Monat).
Nächstes Element | Geht im Kalender entsprechend der eingestellten Anzeige um ein Element weiter (einen Tag, eine Woche oder einen Monat).
Schaltpunktevorschau | Öffnet die Vorschau der Schaltpunkte.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Remote-Transport

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Remote-Transport

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Entwicklungsrechner kann Remote-Verbindungen zu anderen Rechnern aufbauen. Die Symbolleiste Remote-Transport stellt Funktionen für das Übertragen und Abfragen von Daten zur Verfügung.

Symbol

(von links nach rechts)

Funktion

Remote-Transport: Verbindung aufbauen

Baut eine Verbindung zum Zielrechner auf.

Remote-Transport: Verbindungseinstellungen

Öffnet Dialog zur Konfiguration der Verbindung.

Remote: Geänderte Runtime-Dateien übertragen

Überträgt alle auf dem Entwicklungsrechner geänderten Runtime-Dateien zum Zielrechner.

Remote: Alle Runtime-Dateien zurücklesen

Liest alle zur Runtime änderbaren Dateien (wie Rezepte oder Benutzerverwaltung) auf den Entwicklungsrechner zurück.

Remote: Startprojekt setzen

Setzt das Startprojekt für den Zielrechner.

Remote: Runtime starten

Startet die Runtime auf dem Zielrechner.

Remote: Runtime beenden

Beendet die Runtime auf dem Zielrechner.

Remote: Projekt nachladen

Führt auf dem Zielrechner die Funktion nachladen aus.

Remote: Desktop Verbindung starten

Startet eine Verbindung, um den Zielrechner per Remote Desktop zu bedienen.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

Weitere Symbole können über die Optionen der Symbolleiste hinzugefügt werden:

Alle Runtime-Dateien übertragen

Überträgt alle Runtime-Dateien zum Zielsystem.

Betriebssystem neu starten

Startet das Betriebssystem des Zielrechners nach einer Sicherheitsabfrage neu. Unter Windows CE wird diese Option nicht unterstützt.

Systemstatus ermitteln

Ermittelt Systemstatus des Zielrechners und schreibt Daten in das Ausgabefenster. Ermittelt werden:

  • Computername
  • Betriebssystem
  • Runtime aktiv/nicht aktiv
  • Startprojekt
  • Realer Speicher
  • Laufwerke
  • Remote Seriennummer
  • Remote Aktivierungsnummer
  • Remote zenon Version

Passwort ändern u. Lizenzierung anzeigen

Öffnet Dialog für Verbindungsaufbau.

Ermöglicht:

  • Änderung des Passworts für den Verbindungsaufbau
  • Anzeige und Änderung der Lizenzierung des Zielrechners
  • Konfiguration der Verschlüsselung am Zielrechner

Hinweis: Alle Befehle für den Remote-Transport stehen auch im Kontextmenü des Projekts zur Verfügung.


Symbolleiste Report Generator

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Report Generator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Report Generator steht im Editor eine Symbolleiste zur Verfügung. Sofern sie noch nicht sichtbar ist, wird sie aufgeschaltet durch:

  1. öffnen Sie das Menü Optionen -> Einstellungen -> Registerkarte: Symbolleiste
  2. aktivieren Sie die Checkbox neben Report Generator
  3. bestätigen Sie mit OK

Symbol (von links nach rechts) | Funktion
Report drucken | Druckt den Report am Standarddrucker aus.
Seitenansicht Report | Öffnet den Report in einer Voransicht. Der Report kann in der Voransicht vergößert oder verkleinert dargestellt werden (Zoom), man kann ihn durchblättern und drucken.
Report neu zeichnen | Aktualisiert die Ansicht.
Funktionen neu berechnen | Berechnet die Formeln im Report neu.
Funktionsassistent | Öffnet einen Dialog, der bei der Konfiguration der Funktionen unterstützt.
Schriftart | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Schriftart.
Textausrichtung | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Ausrichtung.
Rahmen | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Rahmen.
Muster | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Muster.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Runtime-Dateien

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Runtime-Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Dateien aus dem Editor zur Runtime zu übertragen oder von der Runtime in den Editor steht eine Symbolleiste zur Verfügung:

Symbol (von links nach rechts) | Funktion
Geänderte Runtime-Dateien erzeugen | Erzeugt Runtime-Dateien von allen im Editor geänderten Dateien. Im Drop-down-Menü wählen Sie, ob die Runtime-Dateien nur vom aktiven Projekt oder von allen geladenen Projekten erzeugt werden.
Alle Runtime-Dateien erzeugen | Erzeugt für alle im Editor vorhandenen Dateien die Runtime Dateien. Im Drop-down-Menü wählen Sie, ob die Runtime-Dateien nur vom aktiven Projekt oder von allen geladenen Projekten erzeugt werden.
Runtime-Dateien importieren | Zur Runtime änderbare Dateien (wie Rezepte oder Benutzerverwaltung) werden aus der Runtime zurück in den Editor gelesen.
Runtime änderbare Dateien | Öffnet Dialog zur Verwaltung der zur Runtime änderbaren Dateien.
Runtime starten | Startet die Runtime.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Symbolleiste Sichtbarkeitsebenen

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Sichtbarkeitsebenen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ähnlich wie in CAD-Programmen können im Editor Sichtbarkeitsebenen definiert und einzelnen Elementen zugewiesen werden. So lassen sich bei komplexen Bildern nicht benötigte Elemente einfach ausblenden und jederzeit wieder einblenden. 15 Sichtbarkeitsebenen stehen zur Verfügung. Die Zuweisung einer Ebene erfolgt über die Eigenschaft Sichtbarkeitsebene im Knoten Allgemein. Das Aktivieren und Deaktivieren von einzelnen Ebenen erfolgt über die Schaltflächen der Symbolleiste Sichtbarkeitsebenen:

Interne ID: Symbolleiste Sichtbarkeitsebenen

Allgemein

Allgemeine Eigenschaften des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Symbolleiste Sichtbarkeitsebenen

Sichtbarkeitsebene

Wählen Sie in der Dropdown Liste eine der 16 Sichtbarkeitsebenen (von 0 bis 15) aus. Mit der Symbolleiste Sichtbarkeitsebenen bestimmen Sie, welche Ebenen im Editor angezeigt oder ausgeblendet werden. Dadurch ist gewährleistet, dass auch komplexe Bilder übersichtlich projektiert werden können. Die Ebenen können individuell genutzt werden. Die Ebenen haben keinen Einfluss auf die Vordergrund-/Hintergrundinformation und keinen Einfluss auf die Darstellung in der Runtime.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Symbol (von links nach rechts) | Funktion
Alle Sichtbarkeitsebenen sichtbar machen | Blendet alle Ebenen ein.
Alle Sichtbarkeitsebenen unsichtbar machen | Blendet alle Ebenen aus.
Sichtbarkeitsebene <Nr> | Blendet die entsprechende Sichtbarkeitsebene ein oder aus.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

info Info

Sichtbarkeitsebenen gelten nur für den Editor und haben zur Runtime keine Auswirkung.

Hinweis Kontrollelemente: Kontrollelemente werden zur Runtime immer an an oberster Stelle angezeigt. Das gilt auch, wenn sie im Editor von anderen Elementen überdeckt werden. Damit wird sicher gestellt, dass sie immer erreichbar sind.


Symbolleiste VBA-Makros

Handbuch -> Editor -> Symbolleisten -> Symbolleiste VBA-Makros

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Makros, die mit VBA erstellt wurden, können über die Symbolleiste VBA verwaltet werden.

Symbol (von links nach rechts) | Funktion
Liste der VBA-Makros neu laden | Lädt alle in myWorkspace und in Modulen enthaltenen Public Sub Name () Makros in die Dropdownliste der Symbolleiste.
Dropdownliste Makros | Enthält alle geladenen Makros zur Auswahl.
Ausgewähltes Makro ausführen | Führt das in der Dropdownliste ausgewählte Makro aus.
Zugeordnetes Makro #<x> ausführen | Führt das dem Symbol zugeordnete Makro aus.
Makros zuordnen | Öffnet den Dialog für die Zuordnung von Makros. Bis zu 5 Makros können mit den Symbolen 1 bis 5 verknüpft werden.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

info Info

Werden im Makro-Zuordnungsdialog nicht alle in myWorkspace enthaltenen Makros zur Auswahl angeboten, dann führen Sie in der Symbolleiste die Funktion Liste der VBA-Makros neu laden aus.


Symbolleiste Detailansicht

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Detailansicht des Projektmanagers werden je nach aktiviertem Knoten passende Symbolleisten eingeblendet. Diese entsprechen den Inhalten des jeweiligen Kontextmenüs. Hilfe zu den einzelnen Symbolleisten finden Sie im jeweiligen Kapitel, zum Beispiel: Variablen Detailansicht Symbolleiste.


Symbolleiste Eigenschaften

Handbuch -> Editor -> Symbolleisten -> Symbolleiste Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Eigenschaften eines Objektes werden im Eigenschaften-Fenster angezeigt und bearbeitet. Zur Organisation des Eigenschaften-Fensters steht eine Symbolleiste zur Verfügung:

Symbol

(von links nach rechts)

Funktion

Gruppierte Ansicht

(default)

Alle Eigenschaften des ausgewählten Objekts werden logisch gruppiert und die Gruppen wahlweise alphabetisch oder logisch sortiert. Über das Kontextmenü können Einträge in die Favoriten eingefügt bzw. wieder daraus entfernt werden.

Standard für Handbuch: Hinweise im Handbuch zu den Eigenschaften gehen immer von der gruppierten Ansicht aus. Die Inhalte der Gruppen entsprechen denen der Dialogansicht.

Alle Eigenschaften

Alle Eigenschaften des ausgewählten Objekts werden in einer Liste dargestellt. Über das Kontextmenü können Einträge in die Favoriten eingefügt bzw. wieder daraus entfernt werden.

Dialogansicht

Alle Eigenschaften werden wie in der Gruppierten Ansicht logisch zusammengefasst und die Gruppen nach Anwendungspriorität sortiert in Dialogform dargestellt. In dieser Ansicht können keine Favoriten definiert werden.

Favoriten ein-/ausblenden

Blendet in den Ansichten Gruppierte Ansicht oder Alle Eigenschaften an oberster Stelle der Knoten Favoriten ein- bzw. aus. Darin werden jene Eigenschaften gesammelt, die am häufigsten gebraucht werden.

Per Default werden Favoriten vorgeschlagen.

Einträge zu den Favoriten hinzufügen oder daraus entfernen: Entweder im Kontextmenü mit dem Befehl zu den Favoriten hinzufügen oder per Drag&Drop der Eigenschaft in die Favoritenliste.

Die Reihenfolge der Eigenschaften in den Favoriten wird durch das Sortierkriterium bestimmt (aufsteigend, absteigend, logisch).

In der Dialogansicht können keine Favoriten angelegt werden.

Alle Eigenschaften ein-/ausblenden

Blendet alle Knoten in den Ansichten Gruppiert und Alle Eigenschaften ein- bzw. aus.

Logisch sortiert

(default)

Zeigt in den den Ansichten Gruppiert und Alle Eigenschaften die Eigenschaften logisch nach Anwendungshäufigkeit statt alphabetisch sortiert an.

Aufsteigend und absteigend sortiert

Zeigt in den den Ansichten Gruppiert und Alle Eigenschaften die Eigenschaften wahlweise auf- oder absteigend alphabetisch sortiert an.

Alle Knoten aufklappen / schließen

Schließt oder öffnet in den Ansichten Gruppiert und Alle Eigenschaften alle Knoten.

Ausnahme: Der Knoten der aktuell gewählten Eigenschaften bleibt beim Klick auf Alle Knoten schließen geöffnet.

Eigenschaftenhilfe einblenden

Blendet die integrierte Hilfe zu den Eigenschaften (Eigenschaftenhilfe) ein.

Eigenschaft freigeben

Symbole: Gibt die ausgewählte Eigenschaft frei.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Menüleiste

Handbuch -> Editor -> Menüleiste

Die Menüleiste enthält -je nach ausgewähltem Modul und Element - Dropdownlisten zu folgenden Elementen.

Basis

  • Datei
  • Bearbeiten
  • Bilder
  • Optionen
  • Fenster
  • Hilfe

Bilder und Symbole

Sobald ein Bild geöffnet wird, ergänzen neue Menüpunkte die Leiste:

  • Elemente
  • Kontrollelemente

Wird die Globale Symbolbibliothek aktiviert, dann wird der Menüpunkt Bilder durch den Menüpunkt Symbole ersetzt.

Report

Beim Öffnen eines Reports:

  • wird das Menü Bilder durch Report ersetzt
  • wird das Menü Format hinzugefügt
  • werden die Befehle im Menü Bearbeiten ausgetauscht

Noch in diesem Kapitel

Datei

Bearbeiten

Bilder

Symbol

Fenster

Hilfe

Optionen


Datei

Handbuch -> Editor -> Menüleiste -> Datei

Folgende Aktionen sind möglich:

Menüpunkt

Aktion

Projekt

Öffnet den Dialog zum Anlegen eines neuen Projektes.

Bestehendes Projekt einfügen

Öffnet den Dialog, um ein bestehendes Projekt in den Editor einzufügen.

Projekt 5.50 einfügen

Öffnet den Dialog, um ein Projekt einzufügen, das mit dem Editor der Version 5.50 erstellt wurde.

Projektsicherung rücklesen

Öffnet den Dialog, um den in einer Projektsicherung gespeicherten Stand eines Projektes zu laden.

Arbeitsbereich

neu

Öffnet den Dialog zum Anlegen eines neuen Arbeitsbereichs.

öffnen

Öffnet den Dialog zum Laden eines bestehenden Arbeitsbereichs.

speichern

Speichert den aktuellen Arbeitsbereich.

speichern unter

Speichert den aktuellen Arbeitsbereich, wobei Name und Speicherort ausgewählt werden können.

schließen

Schließt den aktuellen Arbeitsbereich.

Sicherung erstellen

Öffnet den Dialog zum Sichern aller Projekte des aktuellen Arbeitsbereichs. Die Sicherung wird in einer komprimierten *.wsb Datei abgelegt.

Sicherung rücklesen

Öffnet den Dialog zum Laden der in einer Sicherung des Arbeitsbereichs gespeicherten Projekte.

Allgemeine Konfiguration

Produkt lizenzieren

Öffnet den Dialog Produkt lizenzieren für die Eingabe von Seriennummer und Aktivierungsnummer oder zum Anfordern einer Softlizenz.

Standard

Öffnet den Dialog zur Konfiguration der Standardeinstellungen für Speicherorte und für die Drucker für

  • AML
  • CEL
  • Werte
  • Protokolle
  • Screenshots
  • Notizbuch

Systemsteuerung

Öffnet die Systemsteuerung des Betriebssystems.

Screenshot drucken

Gesamter Bildschirminhalt wird auf dem als Standard gewählten Drucker ausgegeben. Druckereinstellung unter Datei -> Allgemeine Konfiguration -> Standard. Bei einem Mehrmonitorsystem wird der Bildschirm 1 gedruckt.

Visual Basic Editor

Öffnet den Visual Basic Editor.

Info: Dieser Menüeintrag ist nur vorhanden, wenn Sie VBA VSTA in der Datei zenon6.ini aktiviert haben. Aktivieren Sie VBA in dem Sie sicherstellen, dass im Bereich [VBA] den Eintrag EIN=1 vorhanden ist.

Wizards

Öffnet den Dialog zur Auswahl eines Assistenten.

Info: Dieser Menüeintrag ist nur vorhanden, wenn Sie VBA VSTA in der Datei zenon6.ini aktiviert haben. Aktivieren Sie VBA in dem Sie sicherstellen, dass im Bereich [VBA] den Eintrag EIN=1 vorhanden ist.

Update Wizards

Öffnet den Dialog für das Update eines Wizards. Details lesen Sie im Kapitel Wizards, Abschnitt Wizards updaten.

Info: Dieser Menüeintrag ist nur vorhanden, wenn Sie VBA VSTA in der Datei zenon6.ini aktiviert haben. Aktivieren Sie VBA in dem Sie sicherstellen, dass im Bereich [VBA] den Eintrag EIN=1 vorhanden ist.

Bestehende Arbeitsbereiche

Listet bereits bestehende Arbeitsbereiche auf. Die letzten 5 gewählten werden angezeigt.

Beenden

Beendet den zenon Editor.


Bearbeiten

Handbuch -> Editor -> Menüleiste -> Bearbeiten

Bilder und Symbole

Bei Auswahl eines Bildes oder Symbols stellt das Menü Bearbeiten spezielle Funktionen zur Verfügung.

Folgende Aktionen sind möglich:

Menüpunkt | Aktion
Rückgängig | Macht die letzte Aktion rückgängig. Die Anzahl der möglichen Rückgängig-Aktionen wird unter Optionen -> Einstellungen definiert. Achtung: Im Schabloneneditor können Aktionen nicht rückgängig gemacht werden.
Ausschneiden | Schneidet markierte Objekte aus und speichert sie im Zwischenspeicher.
Kopieren | Kopiert markierte Objekte und speichert sie im Zwischenspeicher.
Einfügen | Fügt kopierte oder ausgeschnittene Objekte aus dem Zwischenspeicher ein. Elemente werden immer zentriert im Arbeitsausschnitt eingefügt. Bei mehreren Objekten bleiben die Positionen der Objekte zueinander gleich.
An gleicher Position einfügen | Die Kopie des Objektes wird an der selben Position wie ihr Original eingefügt.
Löschen | Löscht markierte Objekte.
Alles markieren | Markiert alle Objekte im Hauptfenster.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
Verknüpfungen ersetzen | Öffnet den Dialog, um mit Dynamischen Elementen verknüpfte Variablen oder Funktionen zu ersetzen. Details: siehe Kapitel Ersetzen von Prozessvariablen in Dynamischen Elementen.
Element Position | Ändert die Position markierter Elemente. ALT-Taste+ linker Mausklick wählt Elemente aus tieferen Ebenen aus.
Vordergrund | Verschiebt ausgewählte Elemente in den Vordergrund.
Hintergrund | Verschiebt ausgewählte Elemente in den Hintergrund.
Vorwärts | Verschiebt ausgewählte Elemente um eine Ebene nach vorne.
Rückwärts | Verschiebt ausgewählte Elemente um eine Ebene nach hinten.
Ausrichten | Positioniert markierte Elemente neu.
Links | Markierte Elemente werden nach links verschoben.
Rechts | Markierte Elemente werden nach rechts verschoben.
Oben | Markierte Elemente werden nach oben verschoben.
Unten | Markierte Elemente werden nach unten verschoben.
Anordnen | Ordnet Elemente neu an. Ausgangspunkt ist jeweils das erste markierte Element.
gleiche Breite | Markierte Elemente werden an die Breite des ersten gewählten Elementes angepasst. Hinweis: Bei gedrehten Elementen orientiert sich die Breite an den optischen Koordinaten, nicht an den logischen. Details siehe Kapitel Symbolleiste Ausrichtung.
gleiche Höhe | Markierte Elemente werden an die Höhe des ersten gewählten Elementes angepasst. Hinweis: Bei gedrehten Elementen orientiert sich die Höhe an den optischen Koordinaten, nicht an den logischen. Details siehe Kapitel Symbolleiste Ausrichtung.
gleiche Größe | Markierte Elemente werden an die Höhe und Breite des ersten gewählten Elementes angepasst. Hinweis: Bei gedrehten Elementen orientiert sich die Größe an den optischen Koordinaten, nicht an den logischen. Details siehe Kapitel Symbolleiste Ausrichtung.
horizontale Mitte | Markierte Elemente werden in die horizontale Mitte des ersten selektierten Elementes verschoben.
vertikale Mitte | Markierte Elemente werden in die vertikale Mitte des ersten selektierten Elementes verschoben.
gleicher x-Abstand | Markierte Elemente werden so angeordnet, dass der Abstand auf der x-Achse zwischen ihnen gleich ist, wobei die ersten beiden Elemente den Abstand bestimmen.
gleicher y-Abstand | Markierte Elemente werden so angeordnet, dass der Abstand auf der y-Achse zwischen ihnen gleich ist, wobei die ersten beiden Elemente den Abstand bestimmen.
gleiche x-Verteilung | verteilt alle markierten Elemente entlang der x- Achse zwischen den beiden Elementen, die als erste markiert wurden. Für dies Option müssen mindestens drei Elemente markiert sein.
gleiche y-Verteilung | verteilt alle markierten Elemente entlang der y-Achse zwischen den beiden Elementen, die als erste markiert wurden. Für dies Option müssen mindestens drei Elemente markiert sein.
horizontal spiegeln | Spiegelt das ausgewählte Element an einer horizontalen Achse.
vertikal spiegeln | Spiegelt das ausgewählte Element an einer vertikalen Achse.
drehen 90º | Dreht das ausgewählte um 90º gegen den Uhrzeigersinn.
Tastatur-Reihenfolge links/rechts | Blendet eine Schablone ein, mit der die horizontale Reihenfolge bestimmt wird, in der die Bildelemente über die Funktion Fokus setzen angesprungen werden.
Tastatur-Reihenfolge oben/unten | Blendet eine Schablone ein, mit der die vertikale Reihenfolge bestimmt wird, in der die Bildelemente über die Funktion Fokus setzen angesprungen werden.
Symbol |
Erzeugen | Erzeugt aus allen ausgewählten Elementen ein neues Symbol.
Auflösen | Das Symbol wird in seine ursprünglichen Elemente aufgelöst; das Symbol existiert nicht mehr.
Einzelbearbeitungsmodus Symbole/Element | Erlaubt es, einzelne Elemente eines Symbols zu bearbeiten. Schaltet um zwischen Einzelbarbeitungsmodus und Symbolbearbeitungsmodus.
Einfügen in existierendes Symbol | Öffnet die Symbolliste, um das aktive Symbol in ein Symbol der Liste einzufügen.
Aus Symbol entfernen | Löscht das markierte Element aus dem aktiven Symbol. Danach gehört das Element nicht mehr zum Symbol.
Verknüpftes in eingebettetes Symbol konvertieren | Konvertiert ein verknüpftes in ein eingebettetes Symbol. Das Symbol verliert damit seine Verbindung zum Originalsymbol in der Bibliothek und kann nur noch lokal geändert werden. Diese Konvertierung kann nicht rückgängig gemacht werden.
Symbolliste | Öffnet eine Liste aller Symbole, die im aktuellen Bild angezeigt werden. Für jedes Symbol werden seine grafischen Einzelbestandteile aufgelistet.
Reihenfolge für Fokus verschieben | Öffnet Dropdownliste zur Festlegung der horizontalen oder vertikalen Reihenfolge bei Tastaturbedienung.
Reihenfolge für links/rechts | Legt die horizontale Reihenfolge fest.
Reihenfolge für oben/unten | Legt die vertikale Reihenfolge fest.

Reporte

Für Reporte stellt das Menü Bearbeiten folgende Einträge zur Verfügung:

Befehl

Beschreibung

Ausschneiden

Schneidet markierten Bereich aus und kopiert ihn in Zwischenspeicher.

Kopieren

Fügt Inhalt des Zwischenspeichers ein.

Einfügen

Kopiert markierten Bereich in Zwischenspeicher.

Einfügen erweitert

Stellt erweiterte Einfügeoptionen für Zelloperationen zur Verfügung:
  • Alles

Fügt alles aus dem Zwischenspeicher ein.
  • Formeln

Fügt nur Formeln ein
  • Wert

Fügt nur Werte ein. Der Bezug zu Formeln geht verloren.
  • Format

Übernimmt nur das Format.

Füllen

Kopiert Inhalt der ersten Zelle einer Markierung und überträgt ihn auf alle weiteren markierten Zellen.

  • nach unten

Die Füllung erfolgt nach unten.
  • nach rechts

Die Füllung erfolgt nach rechts.

Entfernen

Entfernt aus markierten Zellen:
  • Alles

Alles.
  • Inhalt

Nur Inhalte.
  • Format

Nur Formate.

Spalte/Zeile löschen

Löscht markierte Spalten bzw. Zeilen.

Spalte/Zeile einfügen

Fügt neue Spalten bzw. Zeilen ein. Die Einfügung erfolgt über der Zeile oder links der Spalte. Es werden so viele Zeilen/Spalten eingefügt, wie im Tabellenblatt markiert sind.

Suchen/ersetzen

Öffnet den Dialog zum Suchen und Ersetzen im Tabellenblatt.


Bilder

Handbuch -> Editor -> Menüleiste -> Bilder

Folgende Aktionen sind möglich:

Menüpunkt | Aktion
Bild speichern | Speichert das aktuelle Bild.
Alle Bilder speichern | Speichert alle Bilder.
Bild neu zeichnen | Aktualisiert die Bildschirmanzeige.
Raster anzeigen | Schaltet die Anzeige des Rasters ein oder aus.
Raster verwenden | Schaltet Verwendung des Rasters ein oder aus. Ein: Alle Objekte werden automatisch am Raster ausgerichtet.
Fangpunkte verwenden | Schaltet Fangpunkte ein oder aus. Verwenden: Nähert man ein Objekt dem Anfasspunkt eines anderen Objektes, dann rastet das Objekt an diesem Anfasspunkt ein.
Zoomen | Ändert die Darstellungsgröße in festen Schritten zwischen 15 % und 400 %.
Screenshot aktuelles Bild drucken. | Das aktuelle Bild wird auf dem als Standard gewählten Drucker ausgegeben. Druckereinstellung unter Datei -> Allgemeine Konfiguration -> Standard.
Vektorgrafik einfügen | Öffnet den Dialog zum Einfügen einer externen Vektorgrafik.

info Info

Sobald ein Bildelement aktiv ist, wird das Menü Elemente angezeigt. Dieses bietet alle Vektorelemente und Dynamischen Elemente analog zur Symbolleiste Elemente zur Auswahl an. Bei der Auswahl spezieller Bildtypen wird zusätzlich das Menü Kontrollelemente eingeblendet. Dieses stellt passend zum gewählten Bildtyp vordefinierte Kontrollelemente zur Verfügung.


Symbol

Handbuch -> Editor -> Menüleiste -> Symbol

Folgende Aktionen sind möglich:

Menüpunkt

Aktion

Symbol speichern

Speichert das aktuelle Symbol.

Alle Symbole speichern

Speichert alle Symbole.

Symbolgröße/Hintergrundfarbe ändern

Öffnet den Dialog zur Konfiguration von Symbolgröße und Hintergrundfarbe.

Hinweis: Änderungen der Hintergrundfarbe betreffen immer alle Symbole in der Globalen Symbolbibliothek.

Symbolliste

Öffnet eine Liste aller Symbole, die im aktuellen Bild angezeigt werden. Für jedes Symbol werden seine grafischen Einzelbestandteile aufgelistet.

Vollbildmodus

Der Vollbildmodus blendet alle übrigen Fenster aus und zeigt nur das Hauptfenster mit allen geöffneten Dokumenten (Bilder, Reporte, ...) als Vollbild über den ganzen Bildschirm an.

Der Vollbildmodus kann beendet werden über:

  • die eingeblendete Schaltfläche zum Beenden des Vollbildmodus
  • die Tastenkombination Umschalt+F9
  • die Taste Esc

Symbol neu zeichnen

Aktualisiert die Bildschirmanzeige.

Raster anzeigen

Schaltet die Anzeige des Rasters ein oder aus.

Raster verwenden

Schaltet Verwendung des Rasters ein oder aus.

Ein: Alle Objekte werden automatisch am Raster ausgerichtet.

Fangpunkte verwenden

Schaltet Fangpunkte ein oder aus.

Verwenden: Nähert man ein Objekt dem Anfasspunkt eines anderen Objektes, dann rastet das Objekt an diesem Anfasspunkt ein.

Reihenfolge für Fokus verschieben

Öffnet Dropdownliste zur Festlegung der horizontalen oder vertikalen Reihenfolge bei Tastaturbedienung.

Reihenfolge für links/rechts: Legt die horizontale Reihenfolge fest.

Reihenfolge für oben/unten: Legt die vertikale Reihenfolge fest.

Zoomen

Ändert die Darstellungsgröße in festen Schritten zwischen 15 % und 400 %.

Screenshot aktuelles Symbol drucken

Das aktuelle Symbol wird auf dem als Standard gewählten Drucker ausgegeben. Druckereinstellung unter Datei -> Allgemeine Konfiguration -> Standard.

Vektorgrafik einfügen

Öffnet den Dialog zum Einfügen einer externen Vektorgrafik.


Fenster

Handbuch -> Editor -> Menüleiste -> Fenster

Folgende Aktionen sind möglich:

Menüpunkt

Aktion

Vollbildmodus

Der Vollbildmodus blendet alle übrigen Fenster aus und zeigt nur das Hauptfenster mit allen geöffneten Dokumenten (Bilder, Reporte, ...) als Vollbild über den ganzen Bildschirm an.

Der Vollbildmodus kann beendet werden über:

  • die eingeblendete Schaltfläche zum Beenden des Vollbildmodus
  • die Tastenkombination Umschalt+F9
  • die Taste Esc

Schließen

Schließt das aktive Fenster

Teilen

Teilt das Hauptfenster und ordnet die aktiven Fenster entsprechend an.

Liste der Fenster

Zeigt offene Fenster an. Es werden maximal 9 Fenster gelistet.

Fenster

Öffnet Dialog um offene Fenster im Hauptfenster zu verwalten:

  • aktivieren
  • speichern (Mehrfachauswahl möglich)
  • schließen (Mehrfachauswahl möglich)

Das aktive Fenster wird vorausgewählt. werden.


Hilfe

Handbuch -> Editor -> Menüleiste -> Hilfe

Folgende Aktionen sind möglich:

Menüpunkt

Aktion

Info über

Öffnet ein Fenster mit Informationen über zenon:

  • Seriennummer
  • Aktivierungsnummer
  • lizenzierte Tags/IOs
  • lizenzierte Module

Im Info-Fenster kann über einen Schieberegler navigiert werden. Klick in das Fenster oder Druck auf die Taste Esc schließt das Info-Fenster.

Getting Started

Ruft den Abschnitt Tutorials in der Online-Hilfe auf.

Hilfe

Ruft die Online-Hilfe auf.


Optionen

Handbuch -> Editor -> Menüleiste -> Optionen

Folgende Aktionen sind möglich:

Menüpunkt | Aktion
Einstellungen | Öffnet den Dialog zur Konfiguration der allgemeinen Einstellungen, Menüs, Symbolleisten und Befehle.
Editor Editorprofile verwalten | Öffnet das Untermenü zur Verwaltung der Editorprofile.
Hauptfenster mit Registerkarten | Schaltet im Hauptfenster die mehrfache Bildansicht über Registerkarten ein oder aus.
Statuszeile | Blendet die Statuszeile des Editors ein oder aus. Diese ist nicht identisch mit der Statuszeile in der Detailansicht des Projektmanagers.
Projektmanager | Blendet das Fenster Projektmanager ein.
Ausgabefenster | Blendet das Ausgabe-Fenster ein.
Querverweisliste | Blendet die Querverweisliste ein.
Eigenschaftenfenster | Blendet das Eigenschaften-Fenster ein.
Eigenschaftenhilfe | Blendet das Fenster mit der Eigenschaftenhilfe ein
Symbolleisten | Dropdownliste zum Ein- und Ausblenden von Symbolleisten.
Update Windows CE Runtime | Öffnet die Software zum Updaten einer Windows CE Runtime.
Neuen Menüeintrag definieren | Öffnet den Dialog, um externe Programme als eigenen Menüeintrag einzubinden. Tipp: Wurde bereits ein weiterer Menüeintrag erstellt, wird dieser an dieser Stelle angezeigt. Neue und zusätzliche Menüeinträge werden erstellt unter Optionen -> Einstellungen -> Menü Tools.

Noch in diesem Kapitel

Einstellungen

Menü Tools

Farbschema

Befehle

Symbolleisten


Einstellungen

Handbuch -> Editor -> Menüleiste -> Optionen -> Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Dialog Einstellungen legen Sie die Grundeinstellungen für zenon fest.

Option | Aktion
Editor und Runtime |
ausgewählte Sprache | Wählen Sie die Sprache für die Oberfläche des Editors. Für einen Sprachwechsel muss der Editor neu gestartet werden. Die Standardsprache des Editors ist Englisch.
Rahmen um Dynamische Elemente | Aktiv: Stellt Dynamische Elemente mit einem Positionsrahmen dar. Dabei können Sie zwischen Editor und Runtime differenzieren.
Fehlerbericht nicht an Microsoft senden | Aktiv: Verhindert bei Programmabstürzen das Senden eines Fehlerberichts an Microsoft.
Editor Optionen |
Letzten aktiven Arbeitsbereich laden | Aktiv: Beim Starten des Editors werden die letzten aktiven Arbeitsbereiche geladen und im Projektbaum angezeigt (Default). Inaktiv: Beim Starten des Editors wird kein Arbeitsbereich geladen. Über das Kontextmenü können bestehende Projekte und Arbeitsbereiche geöffnet oder neue erstellt werden.
Filter in Dateiansicht berücksichtigt Groß-/Kleinschreibung | Aktiv: Der Filter in der Listenansicht unterscheidet zwischen großen und kleinen Buchstaben. Inaktiv: Der Filter in der Listenansicht behandelt große und kleine Buchstaben gleich (Default).
Logische Sortierung von Texten in Detailansicht | Aktiv: Dateinamen mit Zahlen werden in der Listenansicht logisch sortiert, z. B. 1, 2, 10, 11 Inaktiv: Dateinamen mit Zahlen werden in der Listenansicht alphabetisch sortiert, z. B. 1, 10, 11, 2
Assistenten verwenden | Aktiv: Bei der der Erstellung von Archiven, Combi-Elementen und Universalregler wird automatisch die Hilfe eines Assistenten angeboten. Inaktiv: Archive, Combi-Elemente und Universalregler werden manuell konfiguriert.
Bildbearbeitung |
Eingabe der Eigenschaften bei Erzeugung | Aktiv: Wenn Sie ein Dynamisches Element erstellen, werden automatisch die Dialogboxen für Detaileinstellungen wie z. B. Variablenauswahl geöffnet. Inaktiv: Das Dynamische Element wird gezeichnet, die dazugehörigen Eigenschaften müssen separat definiert werden.
'Verknüpfungen anpassen' Dialog beim Einfügen von Symbolen | Aktiv: Beim Einfügen eines Symbols in ein Bild wird der Dialog Verknüpfungen ersetzen geöffnet. Inaktiv: Der Dialog wird nicht geöffnet. Verknüpfungen können jederzeit über den Befehl Verknüpfungen ersetzen im Kontextmenü ersetzt werden.
Pixelabstand bis zum Positionswechsel | Verhindert ungewolltes Verschieben von Elementen. Bevor ein Element tatsächlich verschoben wird, muss es mindestens um die angegebenen Pixelanzahl bewegt werden.
Anzahl der rückgängig Aktionen | Erlaubt es, bis zu 100 Aktionen rückgängig zu machen. Standardmäßig lassen sich 10 Aktionen rückgängig machen. Tragen Sie eine Zahl zwischen 1 und 100 ein.
Raster-Einstellungen |
Raster anzeigen | Aktiv: Zeigt im Hauptfenster den unter Rastertyp definierten Raster an. Inaktiv: Raster wird nicht angezeigt.
im Raster positionieren | Aktiv: Bildelemente werden immer am Raster ausgerichtet. Diese Funktion ist unabhängig von der Option Raster anzeigen.
Rasterfarbe | Definiert die Farbe des Rasters. Zur Auswahl wird die Windows Farbpalette benutzt.
Rastertyp | Legt die Art der Rasterdarstellung fest: durchzogen, gepunktet oder Schnittpunkte.
Raster-Abstand [Pixel] | Definiert den horizontalen und vertikalen Abstand zwischen einzelnen Markierungspunkten. Damit definiert er auch, wie fein abgestuft Elementgrößen dargestellt werden können. Empfohlener Rasterabstand: 10 Pixel horizontal und vertikal.
Fangpunkte |
Fangpunkte verwenden | Elemente verfügen über Fangpunkte. Wenn man sich beim Verschieben eines Objektes dem Anfassungspunkt eines anderen Objektes nähert, so rastet der Anfassungspunkt des selektierten Objektes an diesem ein und richtet sich an diesem aus.
Größe der Fangpunkte bei Bildern | Definiert die Größe des Fangbereichs in Pixel (quadratische Eckpunkte). Geben Sie eine Zahl zwischen 1 und 20 ein.
Größe der Fangpunkte im Schabloneneditor | Definiert die Größe des Fangbereichs in Pixel (quadratische Eckpunkte) für das Ausrichten von Schablonen an anderen Schablonen bzw. den Bildschirmrändern. Geben Sie eine Zahl zwischen 1 und 40 ein.
Eckpunkte |
Hintergrund invertieren | Aktiv: Eckpunkte werden invertiert zum Hintergrund dargestellt.
Größe der Eckpunkte | Definiert die Größe der quadratischen Eckpunkte zum Anfassen eines Elements in Pixel. Geben Sie eine Zahl zwischen 1 und 20 ein.


Menü Tools

Handbuch -> Editor -> Menüleiste -> Optionen -> Menü Tools

Im Dialog Menü Tools binden Sie externe Programme in die Menüstruktur des Editors ein. Individuell eingebundene Programme werden am Ende des Menüpunktes Optionen angezeigt.

Option | Aktion
Menüinhalte | Listet alle bereits integrierten externen Programme auf.
Neu | Fügt einen neuen Menüeintrag hinzu.
Löschen | Löscht einen bestehenden Eintrag aus dem Menü.
Hinauf | Verschiebt den ausgewählten Menüeintrag in der Liste und im Menü nach oben.
Hinunter | Verschiebt den ausgewählten Menüeintrag in der Liste und im Menü nach unten.
Menü-Text | Name, mit dem das neue Menü in den Optionen angezeigt wird.
Datei | Name und Pfad des externen Programms, das aufgerufen werden soll (*.exe Datei).
Parameter | zusätzliche Schalter für den Programmaufruf, z. B. Dateinamen.

Example Beispiel

Menü-Text: Texteditor

Datei: C:\Windows\notepad.exe

Parameter: C:\test.txt

Ruft Notepad auf und öffnet die Datei test.exe. Ist diese Datei nicht vorhanden, wird angeboten, sie zu erstellen.


Farbschema

Handbuch -> Editor -> Menüleiste -> Optionen -> Farbschema

In dieser Registerkarte definieren Sie das Farbschema für den Editor.

Parameter | Beschreibung
Farbschema für Editor | Klick auf Dropdownliste öffnet Liste mit Auswahlmöglichkeit.
Vorschau | Ändert Farbschema des Editors. Dialogfenster bleibt geöffnet.
OK | Übernimmt Änderungen und schließt Dialog.
Abbrechen. | Verwirft Änderungen und schließt Dialog.


Befehle

Handbuch -> Editor -> Menüleiste -> Optionen -> Befehle

Im Dialog Befehle definieren Sie, welche Befehle in den Symbolleisten zur Verfügung stehen.

Option | Aktion
Kategorien | Auswahl der Kategorie, die den gewünschten Befehl enthält.
Befehle | Liste der zur Verfügung stehenden Befehle.
Beschreibung | Text für Tooltip. Wird die Maus über eine Schaltfläche geführt, wird die Beschreibung als Tooltip angezeigt.

Symbole hinzufügen

  1. öffnen Sie das Menü Optionen -> Einstellungen -> Registerkarte: Befehle
  2. wählen Sie im linken Fenster eine Kategorie
  3. klicken Sie im rechten Fenster mit der linken Maustaste auf das gewünschte Symbol
  4. ziehen Sie das Symbol mit gedrückter linker Maustaste auf die gewünschte Position in der Symbolleiste

Symbole löschen

  1. öffnen Sie im Menü Optionen -> Einstellungen -> Registerkarte: Symbolleiste
  2. alle Symbole in allen Symbolleisten im Editor werden aktiviert
  3. klicken Sie mit der linken Maustaste auf das Symbol
  4. ziehen Sie das Symbol aus der Symbolleiste und lassen Sie die Maustaste los

info Info

Um Änderungen an einer Symbolleiste rückgängig zu machen und den Auslieferungszustand herzustellen, wechseln Sie zur Registerkarte Symbolleiste. Wählen Sie die betreffende Symbolleiste und klicken Sie auf die Schaltfläche Zurücksetzen bzw. auf Alle zurücksetzen, um alle Symbolleisten in den Auslieferungszustand zu versetzen.


Symbolleisten

Handbuch -> Editor -> Menüleiste -> Optionen -> Symbolleisten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Dialog Symbolleisten definieren Sie Aussehen und Sichtbarkeit von Symbolleisten.

Option | Aktion
Symbolleisten | Checkbox aktiv: Symbolleiste wird im Editor angezeigt.
Zurücksetzen | Stellt Ausgangszustand für markierte Symbolleiste wieder her.
Alle zurücksetzen | Stellt Ausgangszustand für alle Symbolleisten wieder her.


Editorprofile

Handbuch -> Editor -> Editorprofile

Der Editor startet in einer Standard-Einstellung mit vordefinierten Fenstern. Sie können Fenster beliebig anordnen und aktivieren. Details dazu lesen Sie im Kapitel Ansicht anpassen. Ihre persönlichen Einstellungen verwalten Sie in Profilen. Diese erreichen Sie über

  • die Symbolleiste Editorprofile

    (siehe: Editorprofile mit Symbolleiste verwalten)

  • den Unterpunkt Editorprofile verwalten in den Optionen der Menüleiste

    (siehe Editorprofile über das Menü verwalten)

  • per Tastenkombinationen

    (siehe Editorprofile mit Tastenkombinationen verwalten)

Sie können einzelnen Modulen Editorprofile auch per Kontextmenü zuweisen (siehe Editorprofile im Kontextmenü auswählen) oder vordefinierte Profile nutzen.

info Info

Bei geteilten Fenstern - wie dem Projektmanager mit Hauptansicht und Detailansicht - gilt die Definition der Breite immer für das gesamte Fenster. Das korrekte Verhältnis der Fensterelemente wird beim Start und beim Beenden des Editors festgelegt.

Wird das Verhältnis der Fensterelemente zueinander verändert, führt ein Aufrufen eines Profils nur zur Einstellung des kompletten Fensters auf die definierten Werte. Das Verhältnis von zum Beispiel Hauptansicht und Detailansicht zueinander wird nicht verändert.

Noch in diesem Kapitel

Vordefinierte Profile

Editorprofile mit Symbolleiste verwalten

Editorprofile über das Menü verwalten

Editorprofile mit Tastenkombinationen verwalten

Editorprofile im Kontextmenü auswählen

Editorprofile löschen

Dialog für Namen der Editorprofile


Vordefinierte Profile

Handbuch -> Editor -> Editorprofile -> Vordefinierte Profile

In zenon stehen Ihnen drei vordefinierte Profile zur Verfügung. Sie optimieren das Layout des Editors bei einer einer Auflösung von 1280 x 1024 für:

  • Variablen und Listenansicht: Profil 1 auf Speicherplatz P1.
  • Bilder: Profil 2 auf Speicherplatz P2.
  • Standard für allgemeine Aufgaben: Profil 3 auf Speicherplatz P3.

Vordefiniertes Profil auswählen

Sie können diese Profile aktivieren oder deaktivieren. Dazu nutzen Sie entweder die Symbole in der Symbolleiste für Editorprofile oder:

  1. öffnen Sie das Menü Optionen
  2. klicken Sie auf Editorprofile verwalten
    • Vordefinierte Profile laden: lädt die vordefinierten Profile auf die ersten drei Speicherplätze und verknüpft sie mit den Modulen. Bereits bestehende Profile werden überschrieben.
    • Profilzuweisungen entfernen: Entfernt alle Verknüpfungen vordefinierter Profile zu den Modulen.

Um die Profile zu nutzen, wählen Sie beim gewünschten Modul im Kontextmenü Editorprofil -> [Profilnummer]

Fehlermeldung beim Aufschalten vordefinierter Profile

Erhalten Sie bei der Auswahl eines vordefinierten Profils eine Fehlermeldung mit dem Hinweis auf den zenAdminSrv, kann dies zwei Ursachen haben:

  1. Der Dienst zenAdminSrv läuft mit einer niedrigeren Versionsnummer als der aktuelle Editor.
    Lösung: Aktualisieren Sie den Dienst.
  2. Die Profile wurden aus dem Standardverzeichnis entfernt:
    Lösung: Kopieren Sie die Datei Predefined Editor Profiles.epf in den Ordner C:\ProgramData\COPA-DATA\zenonxxx\EdProfiles (xxx entspricht der aktuellen zenon Versionsnummer).

Profile

Profil 1: Variablen

Optimierte Darstellung für die Bearbeitung von Variablen und Listenansichten.

Profil 2: Bilder

Optimierte Darstellung für das Bearbeiten von Bildern.

Profil 3: Standard

Standard-Ansicht, optimiert für Module, die nicht auf Listen basieren.


Editorprofile mit Symbolleiste verwalten

Handbuch -> Editor -> Editorprofile -> Editorprofile mit Symbolleiste verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Symbolleiste für Editorprofile wird im Editor standardmäßig in der Mitte der zweiten Symbolreihe angezeigt. Falls sie deaktiviert wurde, klicken Sie mit der rechten Maustaste neben die Symbolleisten und wählen Sie Editorprofile. Sie erhalten folgende Symbolleiste:

Symbol

(von links nach rechts)

Funktion

Selektiertes Editorprofil laden

Lädt das im Bereich Editorprofil auswählen selektierte Profil.

Editorprofil auswählen

Dropdownliste mit 10 Profilen.

Standardprofil laden

Setzt alle Einstellungen für Anzeige und Position von Fenstern sowie Inhalte und Anzeige von Symbolleisten auf Auslieferungszustand zurück und lädt das zenon Standardprofil.

Vordefinierte Profile laden

Lädt die von COPA-DATA vordefinierten Profile auf die ersten drei Speicherplätze und verknüpft sie mit den Modulen. Bereits bestehende Profile werden überschrieben.

Profilzuweisungen entfernen

Entfernt alle Verknüpfungen vordefinierter Profile zu den Modulen.

Automatisches Speichern der Editorprofile

Aktiv: Änderungen am aktuellen Profil werden beim Aufruf eines anderen Profils automatisch gespeichert.

Inaktiv: Änderungen werden beim Profilwechsel nicht gepeichert, beim nächsten Aufruf dieses Profils werden wieder die ursprünglichen Positionen hergestellt.

Selektiertes Editorprofil speichern

Speichert die aktuellen Fenster-Einstellungen in dem Profil, das im Bereich Editorprofil auswählen angezeigt wird.

Individuelle Namen für Editorprofile vergeben

Öffnet einen Dialog, in der individuelle Namen für Editorprofile vergeben werden können.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

Um Editorprofile zu exportieren oder zu importieren, wählen Sie die entsprechende Option im Hauptmenü unter Optionen -> Editor Editorprofile verwalten.


Editorprofile über das Menü verwalten

Handbuch -> Editor -> Editorprofile -> Editorprofile über das Menü verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Menü wählen Sie zur Verwaltung Ihrer Editorprofile Optionen -> Editor Editorprofile verwalten.

Sie haben folgende Möglichkeiten:

Option | Funktion
Benennen | Öffnet einen Dialog, in der individuelle Namen für Profile vergeben werden können.
Standardprofil laden | Setzt alle Fenster-Einstellungen auf Auslieferungsstandard zurück und lädt das zenon Standardprofil.
Exportieren | Öffnet den Dateimanager und speichert die Einstellungen als .zip Datei an einem beliebig wählbaren Speicherort ab.
Importieren | Öffnet den Dateimanager, um gespeicherte Einstellungen als .zip Datei von einem beliebig wählbaren Speicherort zu importieren.

Um individuelle Editorprofile auszuwählen oder zu speichern, benutzen Sie die entsprechenden Funktionen der Symbolleiste oder Tastenkombinationen.


Editorprofile mit Tastenkombinationen verwalten

Handbuch -> Editor -> Editorprofile -> Editorprofile mit Tastenkombinationen verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Aktionen sind möglich:

Befehl | Tastenkombination
Editorprofil 1 laden | Umschalt+F1
Editorprofil 2 laden | Umschalt+F2
Editorprofil 3 laden | Umschalt+F3
Editorprofil 4 laden | Umschalt+F4
Editorprofil 5 laden | Umschalt+F5
Editorprofil 6 laden | Umschalt+F6
Editorprofil 7 laden | Umschalt+F7
Editorprofil 8 laden | Umschalt+F8
aktuelle Editoransicht speichern als: |
Editorprofil 1 | Strg+Umschalt+F1
Editorprofil 2 | Strg+Umschalt+F2
Editorprofil 3 | Strg+Umschalt+F3
Editorprofil 4 | Strg+Umschalt+F4
Editorprofil 5 | Strg+Umschalt+F5
Editorprofil 6 | Strg+Umschalt+F6
Editorprofil 7 | Strg+Umschalt+F7
Editorprofil 8 | Strg+Umschalt+F8


Editorprofile im Kontextmenü auswählen

Handbuch -> Editor -> Editorprofile -> Editorprofile im Kontextmenü auswählen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Projektmanager können für jedes Projekt und jeden Unterbereich eines Projektes Editorprofile im Kontextmenü ausgewählt und dauerhaft zugewiesen werden: Klick mit rechter Maustaste auf den Zweig -> Editorprofile -> auswählen.

Eine Zuweisung lässt sich aufheben, indem man im Kontextmenü 'keines' wählt.

Diese Vorauswahl ist für alle Zweige und Module möglich, ausgenommen Energy Management System und Globale Symbolbibliothek.


Editorprofile löschen

Handbuch -> Editor -> Editorprofile -> Editorprofile löschen

Die Editorprofile werden in einer eigenen INI Datei gespeichert. Um Ihre Profildaten zurückzusetzen, löschen Sie am besten den kompletten Ordner, der die Profileinstellungen enthält:

Löschen Sie den Ordner Editor. Sie finden diesen je nach Betriebssystem unter:

Windows Vista, Windows 7: C:\Users\USERNAME\AppData\Local\COPA-DATA\zenon\Editor

Windows XP: C:\Dokumente und Einstellungen\USERNAME\Lokale Einstellungen\Anwendungsdaten\COPA-DATA\zenon\Editor

Hinweis: USERNAME müssen Sie durch den Benutzernamen des angemeldeten Windows Benutzers ersetzen.


Dialog für Namen der Editorprofile

Handbuch -> Editor -> Editorprofile -> Dialog für Namen der Editorprofile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für Editorprofile können Sie individuelle Namen vergeben: direkt in der Symbolleiste, per Tastenkombination oder über einen Dialog. Den Dialog erreichen Sie über:

  • Symbolleiste, Symbol Individuelle Namen für Editorprofile vergeben oder
  • Menü -> Optionen -> Editor Editorprofile verwalten -> Benennen

Geben Sie in die Felder nach der Editorprofil-Kurzbezeichnung individuelle Namen ein. Mit den Tastenkombinationen Umschalt+F1 bis Umschalt+F8 können Sie die ersten 8 Editorprofile im Editor jederzeit aufrufen. Oder Sie wählen das gewünschte Editorprofil über das entsprechende Symbol in der Symbolleiste aus.


Projektmanager

Handbuch -> Editor -> Projektmanager

Der Projektmanager befindet sich standardmäßig am linken Bildschirmrand direkt unter den Symbolleisten. Er kann in zwei Ansichten angezeigt werden:

  • Projektbaum
  • Netzwerktopologie

Projektbaum

Der Projektbaum beinhaltet :

  • auf der linken Seite den Arbeitsbereich mit den Projekten und der Globale Symbolbibliothek:
    • Im Arbeitsbereich befinden sich alle geladenen Projekte mit ihren Variablen, Funktionen, Bildern usw.
    • Die Globale Symbolbibliothek enthält vordefinierte Grafiken und bietet die Möglichkeit, neue Grafiken zu kreieren.
  • auf der rechten Seite eine Detailansicht:

    Diese listet alle Elemente und Einstellungen für den in der Baumansicht gewählten Abschnitt auf.

Netzwerktopologie

Die Ansicht Netzwerktopologie stellt alle Projekte im Arbeitsbereich topologisch dar und ermöglicht die Überprüfung aller beteiligten Netzwerkkomponenten, sowie einen Remote Transport der Runtime dateien auf die eingebundenen Rechner.

Details dazu lesen Sie im Abschnitt Netzwerk im Kapitel Netzwerktopologie auf Gültigkeit prüfen.

Noch in diesem Kapitel

Arbeitsbereich

Detailansicht des Projektmanagers

Dateien

Globale Symbolbibliothek

Auswahldialoge


Arbeitsbereich

Handbuch -> Editor -> Projektmanager -> Arbeitsbereich

Im Arbeitsbereich werden folgende Komponenten eines Projekts verwalten:

  • Variablen
    • Treiber
    • Datentypen
    • Reaktionsmatrix
    • Zuweisungen
    • Alarm
    • Maßeinheiten
  • Bilder
    • Schablonen
    • Schriften
    • Farbpaletten
    • Projektsymbole
  • Funktionen
    • Skripte
  • Sprachdatei
  • Archivserver
  • Rezepte
    • Rezepte Standard
    • Rezeptgruppen-Manager
  • Zeitsteuerung
  • Programmierschnittstellen
    • Process Control Engine
    • VBA Makros
    • VSTA
  • zenon Logic IEC 61131-3 Programmierumgebung
  • Production and Facility Scheduler
  • Verriegelungen
  • Befehlsgabe
  • Energy Management System
  • Message Control
  • Menüs
  • Report-Generator
  • Benutzerverwaltung
  • SAP Interface
  • Dateien: fügt externe Dateien ein. Diese werden nicht mit zenon bearbeitet, sondern mit einem externen Programm.
    • Grafiken
    • Sprachtabellen
    • Hilfe
    • Multimedia
    • Listen
    • Treiber
    • Sonstige
  • Änderungshistorie
  • Projektsicherungen

Die Verfügbarkeit einzelner Komponenten kann von der gewählten Lizenz abhängen. Welche Module Sie lizenziert haben, überprüfen Sie mit einem Klick auf Hilfe -> Info über ...

Für Lizenzerweiterungen wenden Sie sich an Ihren Vertriebspartner oder an sales@copadata.com.

info Info

Einzelne Elemente des Projektmanagers, wie Variablen oder Funktionen, lassen sich in einem eigenen Fenster darstellen. Klicken Sie dafür im Kontextmenü auf In neuem Fenster öffnen. Auf diese Weisen können Sie zum Beispiel Variablen und Funktionen gleichzeitig bearbeiten.


Detailansicht des Projektmanagers

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wird in der Baumansicht des Projektmanagers ein Element ausgewählt, dann zeigt die die Detailansicht alle dazu gehörigen Objekte und deren Eigenschaften an.

Bei tabellarischer Darstellung können Sie:

Aktion

Vorgehensweise

Spalten frei wählen:

Rechtsklick auf einen Spaltentitel -> Kontextmenü -> Spaltenauswahl

Spaltenbreite verändern:

  • im Spaltentitel die Maus auf der Trennlinie bewegen bis der Mauszeiger die Form eine Kreuzes annimmt
  • linke Maustaste gedrückt halten
  • Spalte auf gewünschte Breite ziehen

Spalten sortieren:

Mausklick auf den Spaltentitel sortiert die Liste entgegengesetzt zur aktuellen Sortierung (aufsteigend/absteigend).

Spalte formatieren

Rechtsklick auf einen Spaltentitel -> Kontextmenü -> Spalten formatieren

Eigenschaften gruppieren

Rechtsklick auf einen Spaltentitel -> Kontextmenü -> nach dieser Spalte gruppieren bzw:

Rechtsklick auf einen Spaltentitel -> Kontextmenü -> Gruppierung aufheben

Darstellung an Fensterbreite anpassen

Rechtsklick auf einen Spaltentitel -> Kontextmenü -> Größe an Fensterbreite anpassen

Spalten entfernen

Rechtsklick auf einen Spaltentitel -> Kontextmenü -> Diese Spalte entfernen

Kontextmenü

Befehl | Aktion
Aufsteigend | sortiert Spalte aufsteigend
Absteigend | sortiert Spalte absteigend
Nach dieser Spalte gruppieren | gruppiert Elemente entsprechend dieser Spalte
Gruppierung aufheben | hebt vorhandene Gruppierung auf
Spaltenauswahl... | öffnet Dialog zur Auswahl der Spalten, die angezeigt werden sollen
Spalte formatieren... | öffnet Dialog zur Formatierung der Spalte
Größe an Fensterbreite anpassen | verteilt alle Spalten auf die gesamte Fenstergröße
Diese Spalte entfernen | entfernt Spalte aus der Ansicht

Statuszeile

Bei Listen zeigt die Statuszeile der Detailansicht Informationen zu vorhandenen, gefilterten und ausgewählten Elementen an.

Example Beispiel

Anzeige Statuszeile Detailansicht: 39 gesamt / 30 gefiltert / 2 selektiert bedeutet

  • 39 Elemente sind vorhanden
  • 30 werden aufgrund der Filtereinstellungen angezeigt
  • 2 wurden ausgewählt

Bei Variablen wird zusätzlich die Zahl der verbrauchten und lizenzierten Tags bzw. IOs angezeigt,

z. B. 32 Tag verwendet / unbegrenzt Tags verfügbar.

info Info

Detaillierte Informationen zur Bearbeitung und Verwaltung der Elemente finden Sie im Kapitel Einträge bearbeiten und in der Beschreibung der jeweiligen Elemente.

Noch in diesem Kapitel

Einträge bearbeiten

Symbolleiste Detailansicht

Navigation in der Listenansicht

Listeneinträge filtern

Text in selektierter Spalte ersetzen

Text in Grenzwerten ersetzen

Spalten anzeigen und ausblenden

Spalten-Eigenschaften


Einträge bearbeiten

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Einträge bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Einträge zu bearbeiten, stehen Ihnen verschiedene Möglichkeiten zur Verfügung:

Weg

Vorgangsweise

Symbolleiste Detailansicht

  • Markieren Sie die gewünschte Zelle mit der linken Mausetaste.
  • Wählen Sie in der Symbolleiste die Schaltfläche Selektierte Zelle bearbeiten.

Kontextmenü
  • Klicken Sie mit der rechten Maustaste in die gewünschte Zelle.
  • Wählen Sie im Kontextmenü den Eintrag Selektierte Zelle bearbeiten.

Verzögerter Doppelklick

  • Markieren Sie die gewünschte Zelle mit einem verzögerten Doppelklick (zweimal langsam anklicken).

Eigenschaften-Fenster

  • Markieren Sie das gewünschte Element.
  • Editieren Sie im Fenster Eigenschaften den gewünschten Eintrag.

F2-TASTE

  • Markieren Sie die gewünschte Zelle mit der linken Mausetaste.
  • Drücken Sie die Taste F2.

info Info

Beim Klick in eine Zelle wird die gesamte Zeile markiert. Welche Zelle Sie selektiert haben, erkennen Sie am Fernglas-Symbol im Spaltentitel.

attention Achtung

Ausnahmen

  • In der Detailansicht können nur Eigenschaften geändert werden, die auch im Eigenschaften-Fenster änderbar sind. So ist z. B. der Name einer Systemtreibervariablen nicht editierbar.
  • Die Änderungshistorie ist aufgrund der FDA-Richtlinien generell nicht änderbar.
  • Bei Projektsicherungen ist nur der Sicherungsname editierbar.


Symbolleiste Detailansicht

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Symbolleiste Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Am oberen Rand der Detailansicht können Sie in einer Symbolleiste alle Funktionen benutzen, die Sie auch im Kontextmenü finden. Je nachdem, was Sie im Projektbaum selektiert haben (z.B. Bilder, Variablen, Symbole, etc.), sehen Sie unterschiedliche Schaltflächen in der Symbolleiste.

Schaltflächen, die Sie momentan nicht benutzen können, sind deaktiviert.

Symbolleiste

Nr. | Symbol | Aktion
01 | Variable neu | Öffnet den Dialog zur Erstellung einer neuen Variablen.
02 | Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
03 | Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
04 | Löschen | Löscht ausgewählte Einträge.
05 | Standard-Funktion erzeugen | Öffnet den Assistenten zur Auswahl der Variablen und Sollwerte und erstellt eine passende Funktion. Die Aktion wird im Ausgabefenster dokumentiert.
06 | Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
07 | Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
08 | Text in Grenzwert ersetzen | Öffnet Dialog zur Auswahl der Dynamischen Eigenschaft und in Folge den Dialog zum Suchen und Ersetzen.
09 | Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
10 | Alle erweitern | Dropdownliste, um alle oder ausgewählte Knoten zu erweitern oder zu reduzieren.
11 | Aktivieren | Aktiviert ausgewählte Elemente einer Strukturvariablen.
12 | Deaktivieren | Deaktiviert ausgewählte Elemente einer Strukturvariablen.
13 | Alle aktivieren | Aktiviert alle inaktiven Elemente einer Strukturvariablen.
14 | Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
15 | XML importieren | Importiert XML-Dateien.
16 | S7-Projekt importieren | Importiert ein Simatic S7 Projekt.
17 | Aktivieren | Aktiviert oder deaktiviert erweiterte Filtereinstellungen.
18 | Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
19 | Filter entfernen | Entfernt alle Filtereinstellungen.
20 | Hilfe | Öffnet die Online-Hilfe.

Kontextmenü

Menüpunkt | Aktion
Variable neu | Öffnet den Dialog zur Erstellung einer neuen Variablen.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Standard-Funktion erzeugen | Öffnet den Dialog zur Auswahl der Variablen und Sollwerte.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Text in Grenzwert ersetzen | Öffnet Dialog zur Auswahl der Dynamischen Eigenschaft und in Folge den Dialog zum Suchen und Ersetzen.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Knoten erweitern/reduzieren | Öffnet ein Submenü zum Erweitern und Schließen der Knoten.
Alle aktivieren | Aktiviert alle inaktiven Elemente einer Strukturvariablen.
Aktivieren | Aktiviert ausgewählte Elemente einer Strukturvariablen.
Deaktivieren | Deaktiviert ausgewählte Elemente einer Strukturvariablen.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Erweiterter Import/Export | Öffnet Menü für Import und Export von S7-Projekten, dBase und csv.
Variablenverwendung | Erstellt Projektanalyse der ausgewählten Variablen im aktuellen Projekt und zeigt diese als Ergebnisliste in einem eigenen Fenster an.
Erweiterter Filter | Öffnet Submenü zum Aktivieren und Deaktivieren von Filter bzw. zum Entfernen aller Filtereinstellungen.
Verknüpfte Elemente | Zeigt mit dem Variablen verknüpfte Elemente an.
Hilfe | Öffnet die Online-Hilfe.


Navigation in der Listenansicht

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Navigation in der Listenansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um in einer Liste zu navigieren:

  1. Klicken Sie in die Spalte, in der gesucht werden soll.
  2. Tippen Sie das erste Zeichen ein, um die Suche zu starten. Existiert kein Eintrag mit diesem Anfangsbuchstaben, wird die Suche gleich wieder beendet.
  3. Der erste gefundene Eintrag wird markiert. Ein Eingabefeld wird eingeblendet. Das erste Zeichen des Zellentextes ist markiert.
    Hinweis: In diesem Feld können Sie nur Suchkriterien eingeben, aber nicht den Namen des Elements editieren.
  4. Geben Sie weitere Zeichen ein, um die Suche einzugrenzen. Wird kein passender Eintrag gefunden, wird das eingegebene Zeichen verworfen und die Markierung bleibt auf der aktuellen Position.
  5. Sind mehrere Einträge zum Suchkriterium vorhanden, navigieren Sie mit den Tasten Strg+Nach-oben oder Strg+Nach-unten.
  6. Mit der RÜCKTASTE wird das letzte Zeichen des Suchkriteriums gelöscht und eine neue Suche mit den verbleibenden Zeichen begonnen. Mit Löschen des letzten Zeichens, wird die Suche beendet.

Sortierung

Für die Sortierung der Listenansicht können auch mehrere Spalten gleichzeitig ausgewählt werden.

  1. klicken Sie in die den Spaltenkopf der Spalte mit dem ersten Sortierkriterium
  2. halten Sie die Umschalttaste gedrückt und klicken Sie in den Titel der Spalte mit dem zweiten Sortierkriterium;
  3. Sie können so beliebig viele Spalten hinzufügen

    Zum Beispiel: Sortierung nach Datenbaustein und Offset zeigt dann zuerst alle Datenbausteine an und alle dazugehörigen Adressen korrekt sortiert.

Tipp: Zweiter Klick auf den Spaltentitel ändert Sortierreihenfolge.


Listeneinträge filtern

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Listeneinträge filtern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Elemente der Detailansicht könne nach verschiedenen Kriterien gefiltert und sortiert werden. Über die Schaltfläche Alle Filter entfernen in der Symbolleiste der Detailansicht oder den Befehl Alle Filter entfernen im Kontextmenü werden alle Filtereinstellungen zurückgesetzt.

Methode

Vorgangsweise

Alphabetische Sortierung

Mausklick auf den Titel einer Spalte: Die Liste wird nach der entsprechenden Spalte sortiert. Ein nochmaliger Mausklick auf den Spaltenkopf dreht die Sortierreihenfolge um.

Vergabe von Filterkriterien

Direkt unter dem Spaltentitel befindet sich ein Feld für Filterkriterien. Hier werden Kriterien eingegeben.

Es werden dann nur noch Objekte angezeigt, die dem eingegebenen Filterkriterium entsprechen.

Um wieder alle Objekte anzuzeigen, muss das Filterkriterium gelöscht werden.

Ein Klick in den Filterbereich öffnet eine Dropdownliste, die die letzen verwendeten Filter dieser Spalte beinhaltet.

Filtern nach Checkboxen

Listen mit Checkboxen (z. B. Templates) können nach aktiven bzw. inaktiven Checkboxen sortiert und gefiltert werden.

Die Sortierung funktioniert auf die gleiche Weise wie die alphabetische Sortierung.

Für die Filterung finden Sie in der Zelle unter dem Spaltentitel eine Dropdownliste mit der Auswahl für aktive, inaktive oder alle Checkboxen.

Platzhalter

Für die Filterkriterien stehen Platzhalter zur Verfügung:

  • * ersetzt eine Zeichenfolge.
    Beispiel: *1 filtert auf alle Elemente, die mit dem Zeichen 1 enden, z. B. Variable1.
    Wildcards können nur als Präfix oder Suffix verwendet werden.
  • ? ersetzt ein einzelnes Zeichen
    Beispiel: Variable? filtert alle Elemente, die mit der Zeichenfolge Variable beginnen und ein zusätzliches Zeichen haben, z. B. Variable1, Variable2, Variable3 ...

Logische Verknüpfung

Filterwörter können mit den logischen Ausdrücken AND und OR verknüpft werden. Das funktioniert auch in Verbindung mit Wildcards (*), aber nicht mit Platzhalter für ein einzelnes Zeichen (?).

Zellinhalte als Filterkriterium

Wörter oder Zeichenfolgen aus einer Zelle der Detailansicht können als Filter definiert werden:

  • Markieren Sie den gewünschten Eintrag.
  • Halten Sie die ALT-Ttaste gedrückt und klicken Sie auf die Zelle.
  • Der Eintrag wird in einem Editierfeld frei gegeben.
  • Markieren Sie eine beliebige Zeichenfolge mit der Maus.
  • Ziehen Sie den markierten Teil mit gedrückter linker Maustaste (Drag&Drop) auf die Filterzeile des Spaltenkopfes.
  • Die gewählte Zeichenfolge wird zum neuen Filtertetxt.

Filterwirkung verknüpfte Elemente

Über die Option verknüpfte Elemente lassen sich Elemente anzeigen, die mit dem aktuellen Element verbunden sind. Gelangt man über diese Option zu einem Element in die Detailansicht, z. B. zu einer Variablen, wird dieses Element unabhängig von den aktuellen Filtereinstellungen angezeigt. Ist es im aktuellen Filter nicht enthalten, dann wird es am Ende der Liste dennoch angezeigt und wird automatisch ausgewählt.

Eigenschaften ändern

Nachdem ein Objekt in der Detailansicht ausgewählt oder mittels Kontextmenü angelegt wurde, lassen sich im Eigenschaftenfenster die Parameter definieren und ändern.

Dabei sind mehrfache Auswahlen erlaubt. Wurden mehrere Objekte gleichzeitig markiert, dann können deren Eigenschaften gemeinsam geändert werden.

Einträge und Änderung im Eigenschaftenfenster gelten für alle markierten Objekte. Bisherige Einträge werden überschrieben. Im Eigenschaftenfenster stehen nur noch jene Eigenschaften zur Verfügung, die für alle ausgewählten Einträge gültig sind.

Erweiterte Filter bei Variablen

Für Variablen steht ein Dialog zur Verfeinerung der Filter zur Verfügung. Sie erreichen ihn über:

  • das Symbol Erweiterten Filter aktivieren in der Symbolleiste der Detailansicht oder
  • den Befehl Erweiterter Filter im Kontextmenü

Die Standard-Filter werden damit um die Elemente Datentypen, Auswahlflags und Stringfilter (Variablenname, Kennung, Reaktionsmatrix) erweitert.


Text in selektierter Spalte ersetzen

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Text in selektierter Spalte ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon unterstützt suchen und ersetzen für Strings, z. B. Bildnamen, Variablennamen, Variablenkennung. Sie können Texte in aktiven Spalten und in Grenzwert ersetzen.

attention Achtung

Es werden nur Texte berücksichtigt, die sich in geöffneten Strukturen (Variablen oder Datentypen) befinden. Geschlossene Strukturen existieren für den Editor nicht als Ziel und müssen vor der Suche erweitert werden.

Text in selektierter Spalte ersetzen:

  1. Aktivieren Sie den Dialog über das Symbol Text in selektierter Spalte ersetzen oder den gleichlautenden Befehl im Kontextmenü.
  2. Definieren Sie im Dialog die Parameter für Suche und Ersetzen.
  3. Die Ersetzungen werden in der aktiven Spalte vorgenommen. Welche Spalte aktiv ist, erkennen Sie am Symbol Fernglas neben dem Spaltentitel.

attention Achtung

Wird in der Variablenkennung Sprachumschaltung verwendet (erkennbar am Schlüsselwort @), muss für korrektes Suchen und Ersetzen die Projekteigenschaft Nicht übersetzte Schlüsselwörter anzeigen aktiviert sein. Zum Aktivieren:

Interne ID: Text in selektierter Spalte ersetzen

Nicht übersetzte Schlüsselwörter anzeigen

Einstellung für die Darstellung von Schlüsselwörter, die in keiner der Sprachdateien existieren:

Aktiv: Darstellung zur Runtime als Schlüsselwort, zum Beispiel: @Text.
Inaktiv: Darstellung zur Runtime ohne vorangestelltes @, zum Beispiel: Text

Hinweis: Existiert das Schlüsselwort in einer der Sprachdateien, verfügt jedoch über keine Übersetzung, wird zur Runtime kein Text angezeigt (leerer String).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • navigieren Sie in den Projekteigenschaften zum Knoten Grafische Ausprägung

    Interne ID: Text in selektierter Spalte ersetzen

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • aktivieren Sie die Checkbox der Eigenschaft Nicht übersetzte Schlüsselwörter anzeigen


Text in Grenzwerten ersetzen

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Text in Grenzwerten ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Texte in Grenzwerten zu ersetzen:

  • Aktivieren Sie den Dialog über das Symbol Text in Grenzwerten ersetzen oder den gleichlautenden Befehl im Kontextmenü.
  • Wählen Sie im Auswahlfenster die gewünschte Dynamische Eigenschaft aus.

  • Sie gelangen in den Dialog für Text in Grenzwerten ersetzen.

attention Achtung

Es werden nur Texte berücksichtigt, die sich in geöffneten Strukturen (Variablen oder Datentypen) befinden. Geschlossene Strukturen existieren für den Editor nicht als Ziel und müssen vor der Suche erweitert werden.


Spalten anzeigen und ausblenden

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Spalten anzeigen und ausblenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die in der Detailansicht verfügbaren Spalten können Sie nach Ihren Wünschen ein- und ausblenden und in beliebiger Reihenfolge anordnen. Die folgenden Einstellungen werden bei manchen Bildern auch über Dialoge der Bildumschaltung erreicht.

Spalten ein- und ausblenden

  1. klicken Sie mit der rechten Maustaste auf einen Spaltentitel
  2. und wählen Sie im Kontextmenü Spaltenauswahl
  3. im folgenden Dialog wählen Sie Spalten aus oder ab:

    mehrere Spalten markieren Sie, wie vom Betriebssystem gewohnt, durch Halten von Umschalt oder Strg

  4. Verfügbare Spalten listet alle noch verfügbaren Spalten auf. Ausgewählte Spalten zeigt alle aktiven Spalten an.

Schaltfläche | Funktion
Hinzufügen | Verschiebt die markierten Spalten aus den verfügbaren zu den ausgewählten. Nach der Bestätigung des Dialogs mit OK werden sie in der Detailansicht angezeigt.
Alle hinzufügen | Verschiebt alle verfügbaren Spalten zu den ausgewählten Spalten.
Entfernen | Entfernt die markierten Spalten aus den ausgewählten und zeigt sie in der Liste der verfügbaren Spalten an. Nach der Bestätigung des Dialogs mit OK werden sie aus der Detailansicht entfernt.
Alle entfernen | Entfernt alle Spalten aus der Liste der ausgewählten Spalten.
Nach oben | Verschiebt den ausgewählten Eintrag nach oben. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
Nach unten | Verschiebt den ausgewählten Eintrag nach unten. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.

Spalten anordnen

Die Reihenfolge der Spalten kann beliebig angeordnet werden. Dazu haben Sie zwei Möglichkeiten:

  1. Im Dialog Spalten-Eigenschaften über die Schaltflächen Nach oben und Nach unten.
  2. In der Detailansicht des Projektmanager per Drag&Drop mit der Maus:
    • Klicken Sie mit der Maus in den gewünschten Spaltentitel.
    • Halten Sie die linke Maustaste gedrückt.
    • Ziehen Sie den Spaltentitel an die gewünschte Stelle. Zwei rote Pfeile markieren den Platz, wo die Spalte eingefügt wird.
    • Platzieren Sie die Spalte durch Loslassen der Maustaste.


Spalten-Eigenschaften

Handbuch -> Editor -> Projektmanager -> Detailansicht des Projektmanagers -> Spalten-Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Verfügbare Spalten

Liste der über Spaltenauswahl bereit gestellten Spalten. Die hier selektierte Spalte wird über die Einstellungen der Sektion Parameter konfiguriert.

Parameter

Einstellungen für ausgewählte Spalte.

Beschriftung

Name für Spaltentitel. Der Spaltentitel ist online sprachumschaltbar. Dazu müsen Sie ein @ Zeichen vor den Namen eingeben.

Breite

Breite der Spalte in Zeichen.
Berechnung: Zahl mal durchschnittlicher Zeichenbreite der gewählten Schriftart.

Ausrichtung

Ausrichtung.

Mögliche Einstellungen:

  • Linksbündig: Text wird in der Spalte am linken Rand ausgerichtet.
  • Zentriert: Text wird in der Spalte zentriert dargestellt.
  • Rechtsbündig: Text wird in der Spalte am rechten Rand ausgerichtet.

Spaltenfilter im Prozessbild sperren

Aktiv: Der Filter für diese Spalte kann zur Runtime nicht verändert werden.

Hinweis: Nur verfügbar für:

  • Batch Control
  • Erweiterter Trend
  • Message Control
  • Rezeptgruppen-Manager

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Dateien

Handbuch -> Editor -> Projektmanager -> Dateien

Externe Dateien können über den Knoten Dateien im Projektmanager in ein Projekt integriert werden. Um externe Dateien zu bearbeiten, muss ein entsprechendes Programm vorhanden sein. Das heißt: Sie können zum Beispiel ein Video einbinden. Um es zu bearbeiten, müssen Sie aber über entsprechende Software verfügen. zenon verwaltet diese Dateien nur.

Diese externen Dateien stehen Ihnen zur Verfügung:

  • Grafiken
  • Hilfe
  • Multimedia
  • Texte und Formate
  • Treiber
  • Report Viewer
  • Sonstige

Unterordner

An den Knotenpunkten Hilfe, Listen, Multimedia und Sonstige können Unterordner angelegt werden. Benutzen Sie dafür den Befehl Neuer Ordner im Kontext-Menü. Mit Hilfe von Unterordnern lassen sich Sprachumschaltungen zur Laufzeit auch auf Dokumente anwenden.

Kontextmenü

Menüpunkt | Aktion
Grafikdatei importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Sprachtabelle importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Hilfedatei importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Multimediadatei importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Listendatei importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Treiberdatei importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Reportvorlage importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Sonstige Datei importieren | Öffnet den Dateimanager zur Auswahl einer Datei.
Help | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Grafiken

Hilfe

Multimedia

Texte und Formate

Treiber

Report Viewer

Sonstige


Grafiken

Handbuch -> Editor -> Projektmanager -> Dateien -> Grafiken

Grafikdateien für Hintergrundgrafiken oder Dynamische Elemente. Folgende Formate sind zulässig:

  • *.bmp
  • *.gif
  • *.jpg
  • *.png
  • *.wmf
  • *.XAML Hinweis: Nur für WPF-Element verfügbar! Die XAML Dateien verfügen über keine Vorschau in der Detailansicht!

Kontextmenü

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Ordner neu | Fügt einen neuen Unterordner ein.
Ordner umbenennen | Ermöglicht das Umbenennen selbst erstellter Unterordner.
Ordner löschen | Löscht den ausgewählten selbst erstellten Ordner nach einer Sicherheitsabfrage.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Grafiken Symbolleiste und Kontextmenü


Grafiken Symbolleiste und Kontextmenü

Handbuch -> Editor -> Projektmanager -> Dateien -> Grafiken -> Grafiken Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Grafiken

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Datei extern bearbeiten | Öffnet das im Betriebssystem als Standard definierte Programm zur Bearbeitung der gewählten Datei.
Datei extern bearbeiten mit | Öffnet eine Liste zur Bearbeitung der gewählten Datei.geeigneter Programme.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Hilfe

Handbuch -> Editor -> Projektmanager -> Dateien -> Hilfe

Ordner für Hilfedateien für die Runtime-Hilfe des Projekts. Diese werden als *.chm Format gespeichert.

Kontextmenü

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Ordner neu | Fügt einen neuen Unterordner ein.
Ordner umbenennen | Ermöglicht das Umbenennen selbst erstellter Unterordner.
Ordner löschen | Löscht den ausgewählten selbst erstellten Ordner nach einer Sicherheitsabfrage.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Hilfe Symbolleiste und Kontextmenü


Hilfe Symbolleiste und Kontextmenü

Handbuch -> Editor -> Projektmanager -> Dateien -> Hilfe -> Hilfe Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Hilfe

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Datei extern bearbeiten | Öffnet das im Betriebssystem als Standard definierte Programm zur Bearbeitung der gewählten Datei.
Datei extern bearbeiten mit | Öffnet eine Liste zur Bearbeitung der gewählten Datei.geeigneter Programme.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Multimedia

Handbuch -> Editor -> Projektmanager -> Dateien -> Multimedia

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Audio- und Videodateien lassen sich in folgenden Formaten einbinden:

  • *.avi
  • *.mp3
  • *.mpeg
  • *.wav

Beachten Sie, dass für die Wiedergabe dieser Dateien auf dem Runtime-Rechner die entsprechenden Codecs vorhanden sein müssen.

Kontextmenü

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Ordner neu | Fügt einen neuen Unterordner ein.
Ordner umbenennen | Ermöglicht das Umbenennen selbst erstellter Unterordner.
Ordner löschen | Löscht den ausgewählten selbst erstellten Ordner nach einer Sicherheitsabfrage.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Multimedia Symbolleiste und Kontextmenü


Multimedia Symbolleiste und Kontextmenü

Handbuch -> Editor -> Projektmanager -> Dateien -> Multimedia -> Multimedia Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Multimedia

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Datei extern bearbeiten | Öffnet das im Betriebssystem als Standard definierte Programm zur Bearbeitung der gewählten Datei.
Datei extern bearbeiten mit | Öffnet eine Liste zur Bearbeitung der gewählten Datei.geeigneter Programme.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Texte und Formate

Handbuch -> Editor -> Projektmanager -> Dateien -> Texte und Formate

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Texte und Formate sind:

  • Textdateien für die Anzeige im Projekt
    Dateiendung: .txt
  • Formatdateien für die Formatierung von Ausdrucken
    Dateiendung: .frm
  • HTML Dateien für die Anzeige im HTML-Bild
    Dateiendung: .htm oder .html

Kontextmenü

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Ordner neu | Fügt einen neuen Unterordner ein.
Ordner umbenennen | Ermöglicht das Umbenennen selbst erstellter Unterordner.
Ordner löschen | Löscht den ausgewählten selbst erstellten Ordner nach einer Sicherheitsabfrage.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Texte und Formate Symbolleiste und Kontextmenü


Texte und Formate Symbolleiste und Kontextmenü

Handbuch -> Editor -> Projektmanager -> Dateien -> Texte und Formate -> Texte und Formate Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Texte und Formate

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Datei extern bearbeiten | Öffnet das im Betriebssystem als Standard definierte Programm zur Bearbeitung der gewählten Datei.
Datei extern bearbeiten mit | Öffnet die gewählte Datei im Standardeditor des Dateiformats oder bietet eine Auswahl geeigneter Editoren an.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Treiber

Handbuch -> Editor -> Projektmanager -> Dateien -> Treiber

Treiberdateien können in folgenden Formaten eingebunden werden:

  • *.cfg
  • *.iso
  • *.tcp
  • *.bur
  • *.fms
  • *.bec
  • *.ovd
  • *.nmp
  • *.ini
  • *.h11
  • *.lst
  • *.dde
  • *.lon
  • *.opc
  • *.ecs

Normalerweise kann das Eintragen hier entfallen. Die Dateien werden beim Anlegen des Treibers automatisch erzeugt und hier gespeichert.

Kontextmenü

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Ordner neu | Fügt einen neuen Unterordner ein.
Ordner umbenennen | Ermöglicht das Umbenennen selbst erstellter Unterordner.
Ordner löschen | Löscht den ausgewählten selbst erstellten Ordner nach einer Sicherheitsabfrage.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Treiber Symbolleiste und Kontextmenü


Treiber Symbolleiste und Kontextmenü

Handbuch -> Editor -> Projektmanager -> Dateien -> Treiber -> Treiber Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Treiber

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Datei extern bearbeiten | Öffnet das im Betriebssystem als Standard definierte Programm zur Bearbeitung der gewählten Datei.
Datei extern bearbeiten mit | Öffnet eine Liste zur Bearbeitung der gewählten Datei.geeigneter Programme.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Report Viewer

Handbuch -> Editor -> Projektmanager -> Dateien -> Report Viewer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Reportvorlagen sind Dateien im Format RDL 2.0, die im zenon Report Viewer geöffnet, angezeigt und bearbeitet werden können.

Kontextmenü

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Report Definitionsdatei.
Ordner neu | Fügt einen neuen Unterordner ein.
Ordner umbenennen | Ermöglicht das Umbenennen selbst erstellter Unterordner.
Ordner löschen | Löscht den ausgewählten selbst erstellten Ordner nach einer Sicherheitsabfrage.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Hinweis: Nur vorhanden, wenn Report Generator und Report Viewer lizensiert sind.

Noch in diesem Kapitel

Report Viewer Symbolleiste und Kontextmenü


Report Viewer Symbolleiste und Kontextmenü

Handbuch -> Editor -> Projektmanager -> Dateien -> Report Viewer -> Report Viewer Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Reportvorlagen

Menüpunkt | Aktion
Report Definitionsdatei neu | Erstellt eine neue RDL-Dateien auf Basis der mitgelieferten default.rdl.
Report Definitionsdatei öffnen | Öffnet die mit RFL-Dateien verknüpfte Software zum Bearbeiten einer bestehenden Definitionsdatei. Standardmäßig sucht zenon erst nach dem MS Report Builder, dann nach dem MS Report Designer.
Zurück zu Ausgangselement springen | Springt bei verknüpften Elementen zurück zu dem Element, von dem aus die Reportvorlage angesprungen wurde. Im Kontextmenü nur vorhanden, wenn verknüpfte Elemente vorhanden sind.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Bestehende Report Definitionsdatei importieren | Öffnet Dialog zum Import bestehender Report Definitionsdateien. Diese müssen vom Typ RDL 2.0 sein.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Hilfe | Öffnet die Online-Hilfe.


Sonstige

Handbuch -> Editor -> Projektmanager -> Dateien -> Sonstige

Ordner für Ablage beliebiger Dateiarten.

Kontextmenü

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Ordner neu | Fügt einen neuen Unterordner ein.
Ordner umbenennen | Ermöglicht das Umbenennen selbst erstellter Unterordner.
Ordner löschen | Löscht den ausgewählten selbst erstellten Ordner nach einer Sicherheitsabfrage.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Sonstige Symbolleiste und Kontextmenü


Sonstige Symbolleiste und Kontextmenü

Handbuch -> Editor -> Projektmanager -> Dateien -> Sonstige -> Sonstige Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Sonstige

Menüpunkt | Aktion
Datei hinzufügen | Öffnet den Dateimanager zur Auswahl einer Datei.
Datei extern bearbeiten | Öffnet das im Betriebssystem als Standard definierte Programm zur Bearbeitung der gewählten Datei.
Datei extern bearbeiten mit | Öffnet eine Liste zur Bearbeitung der gewählten Datei.geeigneter Programme.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Globale Symbolbibliothek

Handbuch -> Editor -> Projektmanager -> Globale Symbolbibliothek

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon bringt in der Globalen Symbolbibliothek eigene, vordefinierte Grafiken mit. Während die Symbole im Ordner Bilder nur dem jeweils aktuellen Bild zur Verfügung stehen, können die Symbole der Globalen Symbolbibliothek in jedes Projekt übernommen werden .

Es können auch eigene Symbole erstellt, Symbole zusammengefasst oder verknüpft werden. Details dazu lesen Sie im Kapitel Bilder/Symbole.

Der Editor speichert den Zustand der Symbolordner ab (offen oder geschlossen), auch nach Verlassen der Symbolbibliothek oder Schließen des Editors.


Auswahldialoge

Handbuch -> Editor -> Projektmanager -> Auswahldialoge

In zenon stehen eigene Dialoge und gefilterte Listen für die Auswahl bestimmter Elemente zur Verfügung. Diese sind im gesamten System gleich und listen die aktuellen Projekte und deren Unterprojekte. Sie stehen zur Verfügung für:

  • Benutzer
  • Bilder
  • Dateien
  • Datentypen
  • Funktionen
  • Schablonen
  • Treiber
  • Variablen

Details zu Ansichten lesen Sie im Kapitel Detailansicht des Projektmanagers, Informationen zum Filtern der Listen finden Sie im Unterkapitel Listeneinträge filtern.

Detaillierte Informationen zu den Auswahldialogen für Funktionen und Variablen und das Ersetzen bereits gewählter Funktionen oder Variablen finden Sie in den Unterkapiteln:

  • Funktionen
  • Variablen

Noch in diesem Kapitel

Funktionen Auswahldialog

Variablen Auswahldialog

Schablonen

Dateien

Bilder

Filterbilder

Benutzer

Treiber

Datentypen


Funktionen Auswahldialog

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Funktionen Auswahldialog

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Auswahl von Funktionen wird ein gefilterter Dialog geöffnet:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Funktion gewählt werden soll.

Auswahlfenster

Auswahl der Funktion.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bereits verknüpfte Funktionen werden gelöscht

Tipp: Dieser Dialog ist in der Größe anpassbar. Die Dialoggröße und -position wird gespeichert.

Verknüpfte Funktion ändern

  1. manuell
    • öffnen Sie in der Detailansicht des Projektmanagers die Funktionen
    • ziehen Sie die gewünschte Funktion mit gedrückter linker Maustaste auf das Element
    • die bisherige Funktion wird durch die neue ersetzt
  2. automatisch
    • wählen Sie im Kontextmenü des Elements Verknüpfungen ersetzen. Details zur Vorgangsweise finden Sie im Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen.


Variablen Auswahldialog

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Variablen Auswahldialog

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Auswahl von Variablen wird ein gefilterter Dialog angeboten.

Tipp: Dieser Dialog ist in der Größe anpassbar. Die Dialoggröße und -position wird gespeichert.

Variablen können auch projektübergreifend genutzt werden.

Verknüpfung einer Variablen

Elemente, die nur mit einer einzelnen Variablen verknüpft werden können, öffnen folgenden Dialog:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Variable gewählt werden soll.

Auswahlfenster

Auswahl der Variablen, die verknüpft werden soll. Die Verknüpfung kann auf zwei Arten erfolgen:

  • Durch einen Doppelklick auf die gewünschte Variable: Dabei wird der Dialog automatisch geschlossen.
  • Durch Selektion der gewünschten Variable und durch anschließendes Klicken auf OK.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bereits verknüpfte Variablen werden gelöst (z.B. verknüpfte Chargenvariablen im Archivserver)

Hinweis: Wird die gewünschte Variable nicht angezeigt, kann dies mehrere Ursachen haben:

  • Sie haben einen Filter ausgewählt und die gewünschte Variable entspricht nicht diesem Filter: Überprüfen Sie ob in der Filterzeile ein Filter eingetragen ist. Die unter dem Auswahlfenster angebrachte Information über gefilterte Elemente hilft ebenfalls bei der Überpürfung von eingestellten Filtern.
  • Der Dialog wird vom Editor gefiltert aufgeschaltet und die Variable entspricht nicht diesem Filter. Das gefilterte Aufschalten erfolgt dann, wenn nur bestimmte Datentypen zulässig sind, z.b dürfen bei einem Dynamischen Element Zahlenwert keine String-Variablen verknüpft werden.
  • Sie haben das falsche Projekt im Projektbaum selektiert.

attention Achtung

Der Dialog lässt generell zwar die Auswahl mehrerer Variablen über die in Windows üblichen Tastenkombinationen zu, es kann aber in diesem Schritt nur eine verknüpft werden. Bei Mehrfachauswahl wird die als erste ausgewählte Variable dem Element zugewiesen.

Verknüpfung mehrerer Variablen

Elemente, die mit mehreren Variablen verknüpft werden können, öffnen folgenden Dialog:

Element

Beschreibung

Projektbaum

Definition des Projekts, aus dem die Variable gewählt werden soll.

Auswahlfenster

Auswahl der Variablen durch:

  • Mit Doppelklick wird die selektierte Variable wird der Variablenliste hinzugefügt
  • Mit Drag&Drop kann die selektierte Variable in die Variablenliste gezogen werden
  • Die gewünschten Variablen selektieren. Mit Hilfe der Strg- bzw. der Umschalt-Taste ist eine Mehrfachselektion möglich. Mit Klick auf Hinzufügen werden die selektierten Variablen in die Variablenliste übernommen.

Variablenliste

Listet alle ausgewählten Variablen auf.

Hinzufügen

Fügt die aktuell im Auswahlfenster markierte Variable der Variablenliste hinzu.

Entfernen

Entfernt die in der Variablenliste markierte Variable aus der Liste.

Keine Auswahl

Je nach Element:

  • der Dialog wird abgebrochen
  • bestimmte Verknüpfungen, wie Chargenvariablen in der Archivierung, können gelöst werden

Hinweis: Wird die gewünschte Variable nicht angezeigt, kann dies mehrere Ursachen haben:

  • Sie haben einen Filter ausgewählt und die gewünschte Variable entspricht nicht diesem Filter: Überprüfen Sie ob in der Filterzeile ein Filter eingetragen ist. Die unter dem Auswahlfenster angebrachte Information über gefilterte Elemente hilft ebenfalls bei der Überpürfung von eingestellten Filtern.
  • Der Dialog wird vom Editor gefiltert aufgeschaltet und die Variable entspricht nicht diesem Filter. Das gefilterte Aufschalten erfolgt dann, wenn nur bestimmte Datentypen zulässig sind, z.b dürfen bei einem Dynamischen Element Zahlenwert keine String-Variablen verknüpft werden.
  • Sie haben das falsche Projekt im Projektbaum selektiert.

Verknüpfte Variable ändern

Wählen Sie im Kontextmenü des Elements Verknüpfungen ersetzen. Details zur Vorgangsweise finden Sie im Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen.


Schablonen

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Schablonen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Auswahldialog Schablonen können Schablonen für die Ausführung von Funktionen ausgewählt werden aus:

  • aktuellem Projekt
  • Unterprojekten
  • allen Projekten im Arbeitsbereich mit aktiver Option Projekt im Speicher halten

Parameter

Beschreibung

Fenster Projektbaum

Zeigt alle Projekte im Arbeitsbereich an. Schablonen können gewählt werden aus dem aktuellen Projekt und aus allen Projekten mit aktiver Option Projekt im Speicher halten

Fenster Schablonen

Auswahl der Schablone.

Werden mehrere Schablonen ausgewählt, wird für die Ausführung der Funktion die erste gewählte Schablone benutzt.

Diesen Dialog zur Runtime anbieten

Schaltet zur Runtime bei der Ausführung der Funktion diesen Schablonenauuswahldialog auf.

Keine Auswahl

Hat für diese Auswahl keine Funktion.

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält:

  • aktueller Monitor
  • alle in der Monitorverwaltung definierten virtuellen Monitore
    optional: Alle Monitore

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.


Dateien

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Auswahldialog Dateien können Dateien des aktuellen Projektes bzw. der Unterprojekte in einer filterbaren Ansicht ausgewählt werden:

  • Um eine Datei aus einem Projekt auszuwählen, muss diese im Knoten Dateien/Grafiken im Projektmanager bereits vorhanden sein.
  • Um eine Datei direkt aus einem beliebigen Ordner des Rechners auszuwählen, muss die Eigenschaft Direkte Dateiauswahl aktiviert werden.


Bilder

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Bilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Auswahldialog Bilder können Bilder für die Ausführung von Funktionen ausgewählt werden aus:

  • aktuellem Projekt
  • Unterprojekten
  • allen Projekten im Arbeitsbereich mit aktiver Option Projekt im Speicher halten

Parameter

Beschreibung

Fenster Projektbaum

Zeigt alle Projekte im Arbeitsbereich an. Bilder können gewählt werden aus dem aktuellen Projekt und aus allen Projekten mit aktiver Option Projekt im Speicher halten

Fenster Bilder

Auswahl des Bildes.

Werden mehrere Bilder ausgewählt, wird für die Ausführung der Funktion das erste gewählte Bild benutzt.

Diesen Dialog zur Runtime anbieten

Schaltet zur Runtime bei der Ausführung der Funktion diesen Bildauswahldialog auf.

Keine Auswahl

Hat für diese Bildauswahl keine Funktion.

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält:

  • aktueller Monitor
  • alle in der Monitorverwaltung definierten virtuellen Monitore
  • optional: Alle Monitore

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.


Filterbilder

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Filterbilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Bildumschaltung auf ein Bild mit Filter auf andere Bilder (AML Filter, CEL Filter) wird ein Dialog zur Bildauswahl aufgeschaltet für:

  • aufrufendes Bild
  • zu aktualisierende Bilder

Bildauswahl aufrufendes Bild

Parameter | Beschreibung
Fenster Projektbaum | Zeigt das aktuelle Projekt an. Bilder können nur aus diesem Projekt gewählt werden.
Fenster Bilder | Auswahl der Bildes. Werden mehrere Bilder ausgewählt, erfolgt die Bildumschaltung auf das erste gewählte Bild.
Keine Auswahl | Hat für diese Bildauswahl keine Funktion.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

Bildauswahl zu aktualisierende Bilder

Parameter | Beschreibung
Fenster Projektbaum | Zeigt das aktuelle Projekt an. Bilder können nur aus diesem Projekt gewählt werden.
Fenster Bilder | Auswahl der Bilder. Mehrfachauswahl ist möglich. Hinzufügen über Doppelklick oder Schaltfläche Hinzufügen.
Fenster Auswahl | Listet alle ausgewählten Bilder auf.
Hinzufügen | Fügt im Fenter Bilder markierte Elemente zum Auswahlfenster hinzu.
Entfernen | Löscht markierte Elemente aus Auswahlfenster.
Keine Auswahl | Entfernt alle aktuell verknüpften Bilder.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.


Benutzer

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Benutzer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auswahl von Benutzern des aktiven Projekts, aller Unterprojekte und dem Globalprojekt.

Parameter | Beschreibung
Liste Arbeitsbereich | Anzeige und Auswahl der Projekte, aus denen Benutzer ausgewählt werden können.
Liste Benutzer | Anzeige der Benutzer des ausgewählten Projekts. Diese Liste kann gefiltert werden.
Keine Auswahl | Ein bereits ausgewählter Benutzer wird wieder abgewählt.
OK | Übernimmt Änderungen und schließt Dialog.
Abbrechen | Verwirft Änderungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Treiber

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Treiber

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Auswahldialog Treiber können die Treiber des aktuellen Projektes bzw. der Unterprojekte in einer filterbaren Ansicht ausgewählt werden.


Datentypen

Handbuch -> Editor -> Projektmanager -> Auswahldialoge -> Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Auswahldialog Datentypen können die Datentypen des aktuellen Projektes bzw. der Unterprojekte in einer filterbaren Ansicht ausgewählt werden.


Hauptfenster

Handbuch -> Editor -> Hauptfenster

Im Hauptfenster werden Dokumente wie Bilder, Reporte usw. angezeigt und bearbeitet. Das Hauptfenster lässt sich als einziges Fenster nicht ausblenden.

Mehrere Dokumente parallel öffnen

Sie können im Hauptfenster mehrere Bilder gleichzeitig anzeigen. Diese Funktion aktivieren Sie über: Optionen -> Hauptfenster mit Registerkarten . Die Bilder sind über Registerkarten am oberen Rand des Hauptfensters erreichbar und können über Optionen im Menüpunkt Fenster angeordnet werden.

Um offene Bilder zu schließen, benutzen Sie die Tastenkombination Strg+F4, das Kontextmenü oder den Befehl Fenster -> Schließen.

Kontextmenü Dokumente

Ein Rechtsklick auf die Registerkarte eines Dokuments öffnet ein Kontextmenü:

Parameter | Beschreibung
Speichern | Speichert das Dokument.
Schließen | Schließt dieses Dokument.
Alle anderen schließen | Schließt alle anderen Dokumente.

Elemente im Bild positionieren

Elemente mit einem Klick auf das Symbol in der Symbolleiste Elemente aktivieren und mit der Maus im Hauptfenster aufziehen.

Zum Bewegen des Elements stehen mehrere Möglichkeiten zur Verfügung:

  • Schnell bewegen: Element anklicken und mit der Maus positionieren
  • Exakt positionieren: Element anklicken und mit den Pfeiltasten positionieren
  • Drehen: Element mit dem "Griff" über der linken oberen Ecke beliebig drehen


Eigenschaftenfenster

Handbuch -> Editor -> Eigenschaftenfenster

Im Eigenschaftenfenster werden die Parameter und Eigenschaften von Objekten angezeigt, die im Projektmanager in der Detailansicht ausgewählt wurden bzw. von Elementen, die in einem Bild selektiert wurden. Im Eigenschaftenfenster geben Sie Werte und Parameter ein oder ändern diese für markierte Objekte und Elemente.

Die Einstellungen zur Ansicht, zur Sortierung und zu den Favoriten werden für den nächsten Neustart des Editors gespeichert. Beim Bearbeiten der Eigenschaften von Elementen im Eigenschaftenfenster wird bei Neuauswahl eines Elementes automatisch die zuletzt bearbeitete Eigenschaft angezeigt.

Multiselekt

Wenn Sie mehrere Objekte parallel auswählen (Multiselekt), werden alle Eigenschaften, die in ausgewählten Elementen unterschiedlich sind, im Eigenschaftenfenster orange hinterlegt oder rot ausgezeichnet dargestellt. Die Eigenschaften des jeweils letzten gewählten Elements. werden angezeigt. In der Ansicht Gruppierte Ansicht und Alle Eigenschaften kann eine ausgewählte Eigenschaften dann per Drücken der Taste Eingabe auf alle anderen markierten Objekte übertragen werden. (In der Dialogansicht nicht möglich.)

Example Beispiel

Mehrere Objekte mit unterschiedlichen Füllfarben sind markiert. Das letzte markierte Element hat die Füllfarbe grün. Die Eigenschaft Füllfarbe wird dann als grün angezeigt, der Wert #32CD32 ist rot markiert. Klick in das Eingabefeld und Druck auf die Taste Eingabe überträgt die Eigenschaft grün auf alle markierten Elemente.

Interne ID: Eigenschaftenfenster

Füllfarbe

Nur verfügbar, wenn die Eigenschaft Transparent auf inaktiv geschaltet wurde.

Interne ID: Eigenschaftenfenster

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Definiert die Füllfarbe des Elements. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Die Füllfarbe kann dynamisch geändert werden über die Eigenschaft Füllfarbe aus der Gruppe Farben dynamisch .

Interne ID: Eigenschaftenfenster

Farben dynamisch

Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Eigenschaftenfenster

Füllfarbe

Name der Variable, deren Grenzwertfarben die Hintergrund-/Füllfarbe des Elements beeinflussen sollen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Achtung: Im Weltbild Übersichtsfenster haben Farbänderungen im Editor keine Auswirkung zur Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Tastaturbedienung

In den Eigenschaften kann auch mit der Tastatur navigiert werden:

Taste | Funktion
Tab oder Nach oben | Wechselt zur nächsten Eigenschaft.
Umschalt+Tab oder Nach unten | Wechselt zur vorangegangenen Eigenschaft.
Eingabe oder Nach rechts | Öffnet einen Knoten.
Nach links | Schließt einen Knoten.
Pos 1 | Springt zum ersten Knoten.
Ende | Springt zum letzen Knoten.

Symbolleiste

Die Eigenschaften eines Objektes werden im Eigenschaften-Fenster angezeigt und bearbeitet. Zur Organisation des Eigenschaften-Fensters steht eine Symbolleiste zur Verfügung:

Symbol

(von links nach rechts)

Funktion

Gruppierte Ansicht

(default)

Alle Eigenschaften des ausgewählten Objekts werden logisch gruppiert und die Gruppen wahlweise alphabetisch oder logisch sortiert. Über das Kontextmenü können Einträge in die Favoriten eingefügt bzw. wieder daraus entfernt werden.

Standard für Handbuch: Hinweise im Handbuch zu den Eigenschaften gehen immer von der gruppierten Ansicht aus. Die Inhalte der Gruppen entsprechen denen der Dialogansicht.

Alle Eigenschaften

Alle Eigenschaften des ausgewählten Objekts werden in einer Liste dargestellt. Über das Kontextmenü können Einträge in die Favoriten eingefügt bzw. wieder daraus entfernt werden.

Dialogansicht

Alle Eigenschaften werden wie in der Gruppierten Ansicht logisch zusammengefasst und die Gruppen nach Anwendungspriorität sortiert in Dialogform dargestellt. In dieser Ansicht können keine Favoriten definiert werden.

Favoriten ein-/ausblenden

Blendet in den Ansichten Gruppierte Ansicht oder Alle Eigenschaften an oberster Stelle der Knoten Favoriten ein- bzw. aus. Darin werden jene Eigenschaften gesammelt, die am häufigsten gebraucht werden.

Per Default werden Favoriten vorgeschlagen.

Einträge zu den Favoriten hinzufügen oder daraus entfernen: Entweder im Kontextmenü mit dem Befehl zu den Favoriten hinzufügen oder per Drag&Drop der Eigenschaft in die Favoritenliste.

Die Reihenfolge der Eigenschaften in den Favoriten wird durch das Sortierkriterium bestimmt (aufsteigend, absteigend, logisch).

In der Dialogansicht können keine Favoriten angelegt werden.

Alle Eigenschaften ein-/ausblenden

Blendet alle Knoten in den Ansichten Gruppiert und Alle Eigenschaften ein- bzw. aus.

Logisch sortiert

(default)

Zeigt in den den Ansichten Gruppiert und Alle Eigenschaften die Eigenschaften logisch nach Anwendungshäufigkeit statt alphabetisch sortiert an.

Aufsteigend und absteigend sortiert

Zeigt in den den Ansichten Gruppiert und Alle Eigenschaften die Eigenschaften wahlweise auf- oder absteigend alphabetisch sortiert an.

Alle Knoten aufklappen / schließen

Schließt oder öffnet in den Ansichten Gruppiert und Alle Eigenschaften alle Knoten.

Ausnahme: Der Knoten der aktuell gewählten Eigenschaften bleibt beim Klick auf Alle Knoten schließen geöffnet.

Eigenschaftenhilfe einblenden

Blendet die integrierte Hilfe zu den Eigenschaften (Eigenschaftenhilfe) ein.

Eigenschaft freigeben

Symbole: Gibt die ausgewählte Eigenschaft frei.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

Noch in diesem Kapitel

Gruppierte Ansicht

Dialogansicht

Alle Eigenschaften

Favoriten

Eigenschaften sortieren


Gruppierte Ansicht

Handbuch -> Editor -> Eigenschaftenfenster -> Gruppierte Ansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Gruppierte Ansicht ist per Default ausgewählt. Sie fasst logisch zusammengehörende Eigenschaften in Gruppen zusammen.

Über die Symbolleiste kann Alle Eigenschaften aus- und wieder eingeblendet werden.

info Info

Hinweise im Handbuch zu den Eigenschaften gehen immer von der gruppierten Ansicht aus. Die Inhalte der Gruppen entsprechen denen der Dialogansicht.


Dialogansicht

Handbuch -> Editor -> Eigenschaftenfenster -> Dialogansicht

Die Dialogansicht fasst Eigenschaften in Gruppen zusammen und präsentiert diese in Dialogform.

In der Dialogansicht können keine Favoriten angelegt werden und keine Eigenschaften ausgeblendet werden.


Alle Eigenschaften

Handbuch -> Editor -> Eigenschaftenfenster -> Alle Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alle Eigenschaften werden in einer alphabetisch sortierten Liste angeboten.

Über die Symbolleiste kann Alle Eigenschaften aus- und wieder eingeblendet werden.


Favoriten

Handbuch -> Editor -> Eigenschaftenfenster -> Favoriten

Die Ansichten Gruppiert und Alle Eigenschaften verfügen über einen Knoten Favoriten an oberster Stelle des Fensters. Hier werden Eigenschaften angezeigt, die häufig benötigt werden.

Per Default werden Favoriten vorgeschlagen. Um eigene Einträge hinzuzufügen:

  • führen Sie einen Rechtsklick auf die gewünschte Eigenschaft aus
  • wählen Sie im Kontextmenü <Eigenschaft> zu Favoriten hinzufügen
  • die Reihenfolge der Eigenschaften in den Favoriten wird durch das Sortierkriterium bestimmt (aufsteigend, absteigend, logisch).

Um Einträge zu entfernen:

  • führen Sie einen Rechtsklick auf die gewünschte Eigenschaft aus
  • wählen Sie im Kontextmenü <Eigenschaft> aus Favoriten entfernen

Favoriten können über die entsprechende Schaltfläche in der Symbolleiste sichtbar oder unsichtbar geschaltet werden.
Achtung: In der Dialogansicht können keine Favoriten angelegt werden.


Eigenschaften sortieren

Handbuch -> Editor -> Eigenschaftenfenster -> Eigenschaften sortieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Sortierkriterium wird über die Schaltflächen Logisch sortiert, aufsteigend sortiert und absteigend sortiert in der Symbolleiste definiert. Per Default werden die Eigenschaften logisch sortiert dargestellt. Es besteht die Möglichkeit, sie alphabetisch zu ordnen.

Logisch sortiert

Die Eigenschaften werden logisch nach ihrer wahrscheinlichen Nutzung sortiert. Diese Sortierung sind für die Ansichten Gruppiert und Alle Eigenschaften möglich.

Aufsteigend/absteigend sortieren

Die Eigenschaften werden alphabetisch auf- oder absteigend sortiert. Diese Sortierungen sind für die Ansichten Gruppiert, Alle Eigenschaften und die Favoriten möglich.

Knoten schließen und aufklappen

In den Ansichten Gruppiert und Alle Eigenschaften ist es möglich, alle Knoten zu schließen und wieder aufzuklappen. Der Knoten der aktuellen Eigenschaften wird nicht geschlossen, wenn Alle Knoten schließen selektiert wird.


Eigenschaftenhilfe

Handbuch -> Editor -> Eigenschaftenhilfe

Unterhalb der Eigenschaften kann ein eigenes Fenster mit der Eigenschaftenhilfe eingeblendet werden.

.

Um die Eigenschaftenhilfe einzublenden:

  • wählen Sie in der Symbolleiste der Eigenschaften das Symbol Eigenschaftenhilfe einblenden (rechts außen)

  • oder wählen Sie im Menü Optionen den Befehl Eigenschaftenhilfe
  • oder führen Sie einen rechten Mausklick auf eine beliebige Titelleiste aus und wählen Sie im Kontextmenü den Befehl Eigenschaftenhilfe

Um die Eigenschaftenhilfe zu schließen:

  • klicken Sie auf das X am rechten Rand der Titelleiste

Im Gegensatz zur über die Taste F1 erreichbaren Online-Hilfe wird in dieser integrierten Eigenschaftenhilfe nur die jeweils ausgewählte Eigenschaft beschrieben. Sie erhalten kurze Hinweise zur aktuell gewählten Eigenschaft und einen Link in die ausführlichere Online-Hilfe.

Die Eigenschaftenhilfe lässt sich wie alle anderen Fenster abdocken und frei am Bildschirm positionieren.


Ausgabefenster

Handbuch -> Editor -> Ausgabefenster

Das Ausgabe-Fenster zeigt Statusinformationen und Fehlermeldungen beim Starten des Editors sowie beim Kompilieren und Übertragen eines Projekts an. Die Informationen sind in verschiedene Typen eingeteilt:

  • Fehler
  • Warnungen
  • Meldungen

Diese Informationen können individuell ein- und ausgeblendet werden. Die Einstellungen, welche Informationen angezeigt werden, bleiben beim Schließen des Editors erhalten und gelten auch für die Anzeige von neu hinzukommende Informationen. Es gehen allerdings keine Informationen verloren, da sich die Einstellungen nur auf die Anzeige und nicht auf das Sammeln von Informationen auswirken.

Beispiel: Werden Warnungen ausgeblendet, dann sind solange keine Warnungen sichtbar, bis die Anzeige wieder eingeschaltet wird. Ab diesem Zeitpunkt sind wieder alle Warnungen sichtbar. Auch die in der Zwischenzeit aufgelaufenen Warnungen werden dann angezeigt.

Die blauen Informationsmeldungen können nicht ausgeblendet werden, da es sich dabei um projektbezogene Meldungen handelt, die immer sichtbar bleiben müssen.

Symbolleiste und Kontextmenü

Symbole und Kontextmenü bieten die gleichen Optionen. Die Symbole bedeuten von links nach rechts:

Symbol/Eintrag Kontextmenü | Beschreibung
Fehler anzeigen | Aktiv: Fehler werden in roter Farbe angezeigt. Inaktiv: Fehler werden ausgeblendet. Der gewählte Zustand kann mit Warnungen und Meldungen kombiniert werden und wird beim Schließen des Editors gespeichert.
Warnungen anzeigen | Aktiv: Warnungen werden in oranger Farbe angezeigt. Inaktiv: Warnungen werden ausgeblendet. Der gewählte Zustand kann mit Fehler und Meldungen kombiniert werden und wird beim Schließen des Editors gespeichert.
Meldungen anzeigen | Aktiv: Meldungen werden in schwarzer Farbe angezeigt. Inaktiv: Meldungen werden ausgeblendet. Der gewählte Zustand kann mit Fehler und Warnungen kombiniert werden und wird beim Schließen des Editors gespeichert.
Speichern | Speichert den gesamten Inhalt des Ausgabefensters in eine LOG-Datei. Speicherort und Dateiname können frei gewählt werden.
Kopieren | Kopiert markierten Text des Ausgabefensters in die Zwischenablage.
Löschen | Löscht den gesamten Inhalt des Ausgabefenster. Nach dem Ausführen dieser Aktion gibt es keine Möglichkeit mehr auf den gelöschten Inhalt des Ausgabefensters zuzugreifen.
Suchen | Öffnet den Dialog für die Suche nach Text innerhalb des Ausgabefensters.
Hilfe | Öffnet diese Hilfeseite.

Example Beispiel

Löschen Sie über das entsprechende Symbol oder das Kontextmenü den Inhalt des Ausgabefensters und erzeugen Sie dann Runtime-Dateien. Sie erhalten im Ausgabefenster die entsprechenden Informationen. Diese Informationen sind von blauen Meldungen umschlossen.

  1. Klicken Sie auf das Symbol Meldungen: Die Standardmeldungen (schwarze Textfarbe) werden ausgeblendet.
  2. Erzeugen Sie erneut Runtime-Dateien, die Meldungen bleiben weiter ausgeblendet.
  3. Blenden Sie jetzt auch die Anzeige von Fehler (rot) und Warnungen (orange) aus.
  4. Die blauen projektbezogenen Meldungen bleiben weiter sichtbar.
  5. Erzeugen Sie erneut Runtime-Dateien und blenden Sie Meldungen wieder ein: Alle seit dem Löschen des Ausgabefensters erzeugten Meldungen sind wieder sichtbar.


Statuszeile

Handbuch -> Editor -> Statuszeile

Die Statuszeile des Editors enthält abhängig vom gewählten Objekt Informationen über:

  • Bereitschaft des Editors.
  • Funktion des Symbols, über dem sich der Mauszeiger befindet.
  • Position des Mauszeigers in Bildern.
  • Art und Name des aktiven Elements in einem Bild.
  • Startpunkt (x/y-Achse) sowie Breite und Höhe des aktiven Elements in einem Bild.
    Der 0/0 Punkt der Achse liegt in der linken oberen Ecke.

Bei Reports ist die Statuszeile ohne Funktion.


Editor beenden

Handbuch -> Editor -> Editor beenden

Beim Beenden des Editors werden wie beim Schließen oder Wechseln des Arbeitsplatzes alle Projekte auf Änderungen überprüft. Projekte, deren Runtime-Dateien noch nicht erzeugt wurden, werden in einem Dialog aufgelistet und zum Erzeugen angeboten.

Parameter | Beschreibung
Ja | Die Runtime-Dateien aller Projekte in der Liste werden erzeugt. Danach wird der Editor beendet.
Nein | Runtime-Dateien werden nicht erzeugt. Der Editor wird beendet.
Abbruch | Runtime-Dateien werden nicht erzeugt. Der Editor wird nicht beendet.


Energy Edition

Handbuch -> Energy Edition

Bei der zenon Energy Edition handelt es sich um ein Paket mit speziellen Funktionalitäten für die Energie- beziehungsweise die Verfahrenstechnik. Dabei profitiert der Anwender von einfach zu implementierenden Funktionalitäten, die ihm rasch eine individuelle Anpassung der Applikation an physikalische Gegebenheiten ermöglichen.

tutorial Lizenzinformation

Für Editor und Runtime lizenzpflichtig.

Für die Energy Edition stehen zusätzlich zur Verfügung:

  • ALC (Automatic Line Coloring): Bereits in der Lizenz für die Energy Edition enthalten, stellt grundlegende Eigenschaften der Linieneinfärbung zur Verfügung.
  • Topologisches Element Trafo
  • Topologie-Paket: Benötigt zusätzliche Lizenzierung am Server (nicht am Client) und erweitert ALC um:
    • Mehrfachversorgung
    • gesicherte Versorgung
    • Topologische Verriegelungen
    • Topologisches Element Trenner
    • Fehlerortung und Erdschlusssuche

Noch in diesem Kapitel

Automatic Line Coloring (ALC) - Topologie

Befehlsgabe


Automatic Line Coloring (ALC) - Topologie

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die topologische Einfärbung von Leitungen dient zur einfachen automatischen Dynamisierung von Leitungen in der Verfahrenstechnik (für Medien) sowie in der elektrischen Energieverteilung (für Strom). Damit lassen sich die prozessgesteuerten Einfärbungen von topologischen Netzen einfach realisieren.

Aufgrund der Projektierung im Bild wird die Leitungsstruktur einschließlich ihrer angeschlossenen verfahrenstechnischen Elemente (z.B. Tanks und Ventile, bzw. Generatoren, Schalter und Verbraucher) intern als Modell nachgebildet und der Medienfluss während der Runtime dargestellt.

Um bildübergreifende Modelle zu ermöglichen, ist die gesamte Projektierung sowie Konfiguration immer projektweit. Es ergibt sich somit pro Projekt ein gesamtes Topologisches Modell, das zur Berechnung der Leitungszustände und schließlich zur Färbung der einzelnen Leitungen herangezogen wird.

Die gesamte Topologie wird dabei aus dem grafischen Design unter Anordnung der Elemente automatisch erstellt. Es sind keine weiteren projektiertechnischen Maßnahmen notwendig.

info Info

Der ALC Algorithmus durchläuft von einer Quelle ausgehend jeden Schalter pro Richtung nur einmal.

Detailbilder

Für die Darstellung von Einzelbildern kann mit der Hilfe von Alias ein Teilbereich aus dem Topologischen Netz herausgenommen und einzeln dargestellt werden. Ein Detailbild kann mit den Daten unterschiedlicher Anlagenteile, z.B. Abgängen oder Teilnetzen, dargestellt werden.

Lizenzierung

Für Editor und Runtime (Einzelplatz, Server, Standby) lizenzpflichtig. Nicht lizenzpflichtig für Runtime-Client. Lizenzierung erfolgt über zenon Energy Edition.

  • ALC: In der Lizenz für die Energy Edition enthalten, stellt grundlegende Eigenschaften der Linieneinfärbung zur Verfügung.
  • Topologie-Paket: Benötigt zusätzliche Lizenzierung am Server (nicht am Client) und erweitert ALC um:
    • Mehrfachversorgung
    • gesicherte Versorgung
    • Topologische Verriegelungen
    • Topologische Elemente Trafo und Trenner
    • Fehlerortung (ab Version 6.50)

Noch in diesem Kapitel

ALC Elemente

Konfiguration

ALC-Quellenfarbe ändern

Detailbilder

Fehlerortung in elektrischen Netzen


ALC Elemente

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Automatic Line Coloring (ALC) ermöglicht es, Leitungen abhängig vom Prozesszustand einzufärben. Als verfahrenstechnisches Element wird das Combi-Element verwendet. ALC dient zur einfachen automatischen Dynamisierung von Leitungen in der Verfahrenstechnik (für Medien) sowie topologischen Netzen in der elektrischen Energieverteilung (für Strom).

Projektierung

Für die Projektierung werden zwei Typen von Bildelementen mit verschiedener Funktion unterschieden. Zum einen sind dies Verfahrenstechnische Elemente (Quelle, Schalter, Trenner, Senke, Trafo bzw. Link) und zum anderen Leitungen.

Dabei ist es so, dass die verfahrenstechnischen Elemente eine Funktion und eine Farbe (Quelle und Trafo) besitzen. Wenn die verfahrenstechnischen Elemente aktiv sind, übernehmen die abgehenden Leitungen bei Quelle und bei Trafo die Farbe dieser Elemente bzw. nehmen bei Schalter und bei Link die Farbe der Eingangsleitung des Elements an. Bei Inaktivität der verfahrenstechnischen Elemente wird die Farbe der Leitungen aus der Projektierung im Element übernommen.

Die verschiedenen Funktionen dieser Elemente werden in den Eigenschaften des Combi Elementes zugewiesen.

Beispiel

Eine Quelle verfügt über eine angeschlossene Leitung. An diese Leitung ist ein Schalter angeschlossen. Daran ist wiederum eine zweite Leitung angeschlossen. Wenn die Quelle aktiv ist, wird die erste Leitung bis zum Schalter mit der in den Projekteigenschaften des Automatic Line Coloring definierten Farbe der Quelle eingefärbt. Die weitere Leitung wird erst dann eingefärbt, wenn der Schalter geschlossen ist.

Quelle inaktiv

Quelle aktiv

Schalter geschlossen

Undefiniert oder gestört

info Info

Befindet sich das verfahrenstechnische Element im Zustand undefiniert oder gestört, wird dies automatisch erkannt. Die abgehenden Leitungen und alle weiteren Elemente werden für beide Status in der Farbe der vordefinierten Quelle undefiniert angezeigt.

Noch in diesem Kapitel

Verfahrenstechnische Elemente

Leitungen

Überprüfung der Projektierung


Verfahrenstechnische Elemente

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verfahrenstechnische Elemente werden in zenon mit einem Combi Element erstellt und bestimmen je nach Zustand die Einfärbung der angeschlossenen Leitung.

Folgende Einstellungen stehen zur Verfügung:

Eigenschaft

Beschreibung

Funktionstyp

Gibt den verfahrenstechnischen Typ des Combi-Elements an.
  • Abschluss

Für Sammelschienenende. Unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
  • Quelle

Dient als Lieferant für eine Farbe. Ist die Quelle aktiv (Wert: 1), bekommen alle angeschlossenen Leitungen, die in den Elementeigenschaften die Option Farbe aus ALC gesetzt haben, die Farbe der Quelle zugewiesen. Die Farbe ist durch die in den Projekteigenschaften für die Quelle definierte Quellfarbe bestimmt. (z.B. Tanks oder Generatoren). Eine Quelle ist ein Einpol, dem eine statische Quellenummer zugeordnet ist. Die Quelle ist über den Zustand ihrer Hauptvariable schaltbar. Quellen gelten grundsätzlich als netzsynchron und kuppelbar.

Interne ID: Verfahrenstechnische Elemente

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""
  • Generator

Ein Generator verhält sich prinzipiell wie eine Quelle, nur dass er grundsätzlich als eigenständig und nicht-netzsynchron angenommen wird.
  • Schalter

Damit können Leitungen unterbrochen werden. Ist der Schalter geschlossen/aktiv (Wert: 1), dann ist die Verbindung zwischen zwei Leitungen geschlossen und die Leitung verfärbt sich bis zum nächsten Schalter mit der definierten Farbe der Quelle. Ein Schalter leitet in diesem Fall die Quellen-Farbe der Eingangsleitung an die Ausgangsleitung weiter.

Ist der Zustand des Schalters gestört oder undefiniert oder Status INVALID, verfärbt sich die Leitung in die Farbe undefiniert aus der ALC Konfiguration in den Projekteigenschaften. Ein Schalter liefert somit an seinem Ausgang (Anschluss 2) anstatt der eingehenden Quellennummer die Quellennummer 0 (undefiniert).

Beispiel: siehe Abschnitt Beispiel Schalter - Farben aus ALC.
  • Trenner

Ein Trenner verhält sich prinzipiell wie ein Schalter. Allerdings darf ein Trenner im Topologischen Modell nicht unter Spannung geschalten werden. Ein Zustand (Ein, Aus, Zwischenstellung, gestört) wird über seine Hauptvariable bestimmt.
  • Schieber

Ein Schieber (ein Ventil) verhält sich ähnlich wie ein Schalter, wird aber für Wasser- und Gasleitungen verwendet.

Werte der Hauptvariable:

Schieber AUS: Wert 0 -> Schieber geschlossen -> kein Wasserfluss

Schieber EIN: Wert 1 -> Schieber komplett geöffnet -> Wasserfluss

Schieber DIF: Wert 2 -> Schieber teilweise geöffnet -> Wasserfluss

Schieber STO: Wert 3 -> Schieber gestört
  • Senke

Damit wird das Ende der Leitung festgelegt. Die Senke hat keinen Einfluss auf die Farbberechnung, sondern wird ausschließlich dazu verwendet, dass das Modell vollständig abgebildet werden kann. Soll mit externen Programmen (z.B. VBA) auf das Modell zugegriffen werden, dann ist die Senke unter Umständen für weitere Berechnungen erforderlich, und damit auch zu projektieren.
In Energieprojekten wird die Senke zur Darstellung von Verbrauchern verwendet. Diese werden zur Berechnung der ALC - Verriegelungen (Befehlsgruppen) 'Verbraucher würde unterversorgt' herangezogen.
  • Trafo

Ein Trafo ist gleichzeitig eine Senke und eine Quelle. Er dient dazu die Eingangsfarbe (Eingangsquelle) gegen eine Ausgangsfarbe (Trafo eigene Quelle) auszutauschen.
Erst wenn der Trafo eine aktive Eingangsleitung hat, wird die Ausgangsleitung ebenfalls aktiv geschaltet. Die Ausgangsleitung bekommt jedoch nicht die Farbe der Eingangsleitung wie beim Schalter, sondern die Farbe der Trafo eigenen Quelle. Bei jedem Trafo muss daher eine Quelle eingestellt werden. Ein Trafo kann nicht aktiv oder inaktiv geschaltet werden, er ist immer aktiv.

Rückspeisefähiger Trafo:

Um einen rückspeisefähigen Trafo zu erhalten, müssen Sie bei Quelle für Rückspeisung eine Andere Quelle als UNDEFINED [0] selektieren. Das bedeutet, dass sich der Trafo in beiden Richtungen - vom Eingang zum Ausgang (Vorwärtsrichtung) und auch vom Ausgang zum Eingang (Rückwärtsrichtung) - gleich verhält. Der einzige Unterschied besteht darin, dass zur Weiterverbreitung die Quellnummer der Eigenschaft Quelle für Rückspeisung und nicht die der Eigenschaft Quelle verwendet wird.

Interne ID: Verfahrenstechnische Elemente

Quelle

Nur verfügbar, wenn ein Funktionstyp Quelle oder Trafo ausgewählt ist:
Auswahl der verknüpften Quelle/Trafos.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verfahrenstechnische Elemente

Quelle für Rückspeisung

Nur verfügbar, wenn Sie bei der Eigenschaft Funktionstyp Trafo selektiert haben.

Interne ID: Verfahrenstechnische Elemente

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Auswahl der verknüpften Trafos.

Wenn Sie eine andere Quelle als UNDEFINED [0] selektieren, ist der Trafo rückwärtsspeisefähig. Das bedeutet, dass sich der Trafo in beiden Richtungen - vom Eingang zum Ausgang (Vorwärtsrichtung) und auch vom Ausgang zum Eingang (Rückwärtsrichtung) - gleich verhält. Der einzige Unterschied besteht darin, dass zur Weiterverbreitung die Quellnummer der Eigenschaft Quelle für Rückspeisung und nicht die der Eigenschaft Quelle verwendet wird.

Hinweis: Fehlerhafte Netzzustände oder fehlerhafte Projektierungen, wie z.B. gleichzeitige Speisung von Eingang und Ausgang oder Kurzschluss von Eingang und Ausgang werden nicht speziell eingefärbt. Das bedeutet, dass sich der rückwärtsspeisefähiger Trafo verhält wie zwei antiparallel geschaltete Trafos, die nicht rückwärtsspeisefähig sind.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Fehlerhafte Netzzustände oder fehlerhafte Projektierungen, wie z.B. gleichzeitige Speisung von Eingang und Ausgang oder Kurzschluss von Eingang und Ausgang werden nicht speziell eingefärbt. Das bedeutet, dass sich der rückwärtsspeisefähiger Trafo verhält wie zwei antiparallel geschaltete Trafos, die nicht rückwärtsspeisefähig sind.
  • Link

Ein Link ist dazu da, um eine Leitung an einer anderen Stelle fortzuführen. Wird ein Link durch eine Leitung 'versorgt', so sind alle anderen Links mit derselben identischen Link-Nummer ebenfalls genau mit dieser Quelle(n) versorgt. Dabei spielt es keine Rolle, ob sich die Links auf demselben Bild oder auf völlig unterschiedlichen Bildern im Projekt befinden. Damit lassen sich Bildübergreifende Leitungen realisieren. Es ist zulässig, dass es mehr als zwei Links mit derselben Link-Nummer im Projekt gibt.

Links können durch mehrere Leitungen gleichzeitig versorgt werden bzw. mehrere Abgänge versorgen. Prinzipiell gibt es keine Unterscheidung wischen Zu- und Abgängen. Die Quelleninformationen werden an alle angeschlossene Leitung weitergegeben.
Achtung: Zwei Link Elemente dürfen nicht direkt mit einer Leitung verbunden werden. Es muss sich dazwischen immer ein anderes verfahrenstechnisches Element (Schalter/Trenner oder Trafo) befinden.
Ein Link kann nicht aktiv oder inaktiv geschaltet werden, er ist immer aktiv

Link-Nummer

Für den Funktionstyp Link wird hier die Link-Nummer frei eingestellt. Alle identischen Link-Nummern im Projekt korrelieren miteinander. Genaue Beschreibung beim Funktionstyp 'Link'.
Diese Eigenschaft ist nur aktiv, wenn als Funktionstyp 'Link' gewählt wurde.

Quelle

Hier erfolgt die Zuweisung der Quelle zum Element. Zur Auswahl in der Auswahlbox stehen alle Quellen, die in der ALC Konfiguration (bei den Projekteigenschaften) vergeben wurden. Angezeigt werden die Quellennamen.
Diese Eigenschaft ist nur aktiv, wenn als Funktionstyp 'Quelle', 'Trafo' oder 'Generator' gewählt wurde.

Damit dem Schalter der Zustand (geöffnet, geschlossen, gestört) mitgeteilt werden kann, muss im jeweiligen Element eine Variable des IEC Datentyps BOOL oder Integer als Hauptvariable verknüpft sein. Analog wird bei der Quelle der Zustand (aktiv/inaktiv) über die verknüpfte Hauptvariable ausgewertet.

Bei den Funktionstypen Quelle und Trafo wird die angegebene Quellennummer über geöffnete bzw. geschlossene Schalter bis zu den Verbrauchern (Senken) weitergeleitet. Aus der überlagerten Summe der speisenden Quellennummern werden die Zustände und somit die Farben aller angeschlossenen Leitungen und verfahrentechnischen Elemente berechnet.

info Info

Für die Schaltung werden nur die ersten beiden Bits berücksichtigt. Das erste Bit stellt die eigentlich Schaltung dar. 0 entspricht dabei aus und 1 entspricht an.

Das zweite Bit ist das Fehlerbit. Nur wenn es 0 ist, liegt kein Fehler vor.

Zustände

  • Ein Schalter und eine Quelle sind eingeschaltet, wenn der Wert der verknüpften Variable 1 ist.
  • Ein Schalter ist gestört, wenn der Wert der verknüpften Variable >1 ist oder den INVALID Status hat.
    Ein gestörter Schalter liefert an seinem Ausgang (Anschluss 2) anstatt der eingehenden Quellennummer die Quellennummer 0 (undefiniert). In Richtung vom Ausgang zum Eingang verhält sich der Schalter wie offen.

    Hinweis: Hat die (Rückmelde-)Variable eines Schalters den Status INVALID, so wird das gesamte nachfolgende Netz INVALID, weil der Zustand des Netzes nicht bekannt ist. Der Zustand INVALID wird über nachfolgende geschlossene Schalter weitergeleitet (geroutet).

attention Achtung

Wird in den einzelnen Zuständen die Farbe und Füllfarbe aus ALC aktiviert, werden auch die verfahrenstechnischen Elemente durch den Zustand der angeschlossenen Leitungen zur Laufzeit eingefärbt.

Noch in diesem Kapitel

Beispiel Schalter - Farben aus ALC

Anschlusspunkte bei verfahrenstechnischen Elementen

Eingang/Ausgang tauschen


Beispiel Schalter - Farben aus ALC

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente -> Beispiel Schalter - Farben aus ALC

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beispiel 1

Combi-Element mit Wertzustand 00 und Linienfarbe aus ALC:

  1. Projektierung im Editor:
    • Combielement mit Wertzustand 00
    • Linienfarbe aus ALC aktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe: grün
    • Farbe unbespannt: weiß
    • Schalterzustand: aus/offen (Wert 0)

Beispiel 2

Combi-Element mit Wertzustand 01 und Farben aus ALC:

  1. Projektierung im Editor
    • Combielement mit Wertzustand 01
    • Linienfarbe aus ALC aktiv
    • Füllfarbe aus ALC aktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe: grün
    • Farbe unbespannt: weiß
    • Schalterzustand: ein/geschlossen (Wert 1)

Beispiel 3

Combi-Element Wertzustand 00 ohne Farben aus ALC:

  1. Projektierung im Editor:
    • Combielement mit Wertzustand 00
    • Linienfarbe aus ALC nicht aktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe: grün
    • Farbe unbespannt und Konstruktionsfarbe der Linie: weiß
    • definierte Linien- und Füllfarben des Combielements: schwarz
    • Schalterzustand: aus/offen (Wert 0)

Beispiel 4

Combi-Element Wertzustand 01 ohne Farben aus ALC:

  1. Projektierung im Editor
    • Combielement mit Wertzustand 01
    • Linienfarbe aus ALC inaktiv
    • Füllfarbe aus ALC inaktiv

  2. ergibt zur Runtime bei:
    • Quellenfarbe = grün
    • Farbe unbespannt und Konstruktionsfarbe der Linie: weiß
    • definierte Linien- und Füllfarben des Combielements: schwarz
    • Schalterzustand: ein/geschlossen (Wert 1)


Anschlusspunkte bei verfahrenstechnischen Elementen

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente -> Anschlusspunkte bei verfahrenstechnischen Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Projektieren erfolgt der Anschluss einer Leitung (z.B. Linie) an ein verfahrenstechnisches Element (Combi-Element) durch überlappende Projektierung im Bild an so genannnten 'Fangpunkten' am Combi-Element. Bei jedem Anschlusspunkt kann nur eine Leitungen gleichzeitig 'angeschlossen' werden. Alle Leitungen, deren Leitungsanfänge sich im unten definierten Bereich befinden, gelten als angeschlossen (Topologie aus Grafik).

attention Achtung

Verwenden Sie ALC Elemente nur im ungedrehten Zustand, denn:

Die Berechnung des Topologischen Modells für ALC erfolgt im Editor auf Basis der Positionen der Elemente im ungedrehten Zustand und ohne Berücksichtigung etwaiger Dynamiken.

In der folgenden Grafik werden die möglichen Anschlusspunkte genauer dargestellt:

X = 1/3 Breite

Y = 1/3 Breite (max. 10 Pixel)

Z = 1/3 Höhe

W = 1/3 Höhe (max. 10 Pixel)

info Info

Befindet sich eine Leitung außerhalb des oben dargestellten Bereichs, wird keine Verbindung erkannt und es erfolgt daher keine Einfärbung der Leitung. Auch für alle nachfolgenden Leitungen wird damit die Einfärbung nicht stimmen.

Bei Quellen, Senken und bei Links können prinzipiell alle beschriebenen Anschlusspunkte verwendet werden.

attention Achtung

Bei Quellen und Senken darf immer nur ein einziger Anschlusspunkt gleichzeitig verwendet werden (welcher ist egal). Werden mehrere Anschlusspunkte gleichzeitig benutzt, kann es zu undefinierten Zuständen kommen.

Bei Elementen des Typs 'Link' können auch mehrere Anschlusspunkte gleichzeitig verwendet werden. Die eingehenden Farbinformationen werden gleichmäßig auf alle Leitungen verteilt.

Bei Schaltern/Trennern/Schiebern und Trafos erfolgt der Anschluss 1 (Versorgung) links oder oben und Anschluss 2 (Abgang) rechts oder unten. Diese Reihenfolge kann mit der Eigenschaft Eingang/Ausgang tauschen geändert werden.

Interne ID: Anschlusspunkte bei verfahrenstechnischen Elementen

Eingang/Ausgang tauschen

Nur verfügbar, wenn als Funktionstyp Trafo, Schalter, Schieber oder Trenner eingestellt wurde.

Interne ID: Anschlusspunkte bei verfahrenstechnischen Elementen

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Verschiebt den Eingang des ALC-Elements nach rechts oder unten und den Ausgang nach links oder oben.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Bei Schaltern und Trafos muss darauf geachtet werden, dass jeweils nur ein Versorgungsanschlusspunkt und ein Abgangsanschlusspunkt verwendet wird. Die gleichzeitige Verwendung mehrerer Versorgungs- oder Abgangversorgungspunkten führt zur Inkonsistenz und ist daher nicht zulässig.

info Info

Für alle verfahrenstechnische Elemente gilt: Pro Anschlusspunkt darf nur eine einzige Leitung angeschlossen werden. Abzweigungen können nicht direkt am Element realisiert werden, sondern müssen mit Hilfe von Leitungen projektiert werden.


Eingang/Ausgang tauschen

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Verfahrenstechnische Elemente -> Eingang/Ausgang tauschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein Trafo, ein Trenner oder ein Schalter projektiert wird, können Eingang und Ausgang vertauscht werden. Dazu:

  1. wählen Sie als Funktionstyp entweder Trafo, Trenner oder Schalter

    Interne ID: Eingang/Ausgang tauschen

    Funktionstyp

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
    Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
    Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
    Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
    keine Funktion: Das Element hat im ALC keine Funktion.
    Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
    Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
    Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
    Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
    Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
    Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
    Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. aktivieren Sie cie Checkbox Eingang/Ausgang tauschen

    Interne ID: Eingang/Ausgang tauschen

    Eingang/Ausgang tauschen

    Nur verfügbar, wenn als Funktionstyp Trafo, Schalter, Schieber oder Trenner eingestellt wurde.

    Aktiv: Verschiebt den Eingang des ALC-Elements nach rechts oder unten und den Ausgang nach links oder oben.

    Default: inaktiv

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Eingang wird dann rechts oder unten und der Ausgang links oder oben gesetzt.

Überblick

Konfiguration Gerät | Eingang | Ausgang
normal | links | rechts
normal | oben | unten
getauscht | rechts | links
getauscht | unten | oben


Leitungen

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Leitungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Leitungen werden durch die Vektorelemente Linie, Polylinie und Rohrleitung repräsentiert.

Ist für eine Leitung die Eigenschaft Farben aus ALC aktiviert, so wird die Farbgebung aus der ALC-Konfiguration bestimmt. Leitungen werden je nach Zustand der verfahrenstechnischen Elemente und der ALC-Einstellungen automatisch vom System eingefärbt.

Dabei wird die Farbe im Normalfall von der höchst-prioren Quellennummer, des durch die Leitung fließenden Mediums, bestimmt, bzw. bleibt bei 'leer/unbespannt' so wie im Bild bei 'Farben statisch' oder bei 'Farben dynamisch' projektiert.

Die Darstellungsart definieren Sie über die Dropdownlisten:

  • Vorrang bei Darstellung
  • Mehrfachversorgung darstellen
  • Gesicherte Versorgung darstellen

In den Eigenschaften der Leitungen stehen Ihnen folgende Optionen zur Verfügung:

Parameter

Beschreibung

Farbe aus ALC

Interne ID: Leitungen

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiviert die automatische Linienfärbung für dieses Vektorelement. Das bedeutet: Ist die Quelle, die die Leitung versorgt aktiv, und sind alle Schalter/Ventile, die von der Quelle zur Leitung führen, geschlossen, so wird die Leitung eingefärbt. Bei Versorgung der Leitung durch nur eine einzige Quelle wird die projektierte Quellenfarbe zur Einfärbung verwendet. Die Linienbreite wird nicht beeinflusst.

Vorrang bei Darstellung

Interne ID: Leitungen

Vorrang bei Darstellung

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.

Definiert den Vorrang der Darstellung, wenn das Element mit mehreren aktiven Quellen verbunden ist.
Mehrfachversorgung: Das Element wird entsprechend den Regeln der Mehrfachversorgung dargestellt.
gesicherte Versorgung: Das Element wird entsprechend den Regeln der gesicherten Versorgung dargestellt.
Kein Vorrang: Die Einfärberegeln für Mehrfachversorgung und für Gesicherte Versorgung werden gleichzeitig angewandt, falls beide Kriterien erfüllt werden

Default: Mehrfachversorgung
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Definiert, ob Mehrfachversorgung, gesicherte Versorgung oder beide dargestellt werden.
Default: Mehrfachversorgung

Gesicherte Versorgung

Das Element wird entsprechend den Regeln der gesicherten Versorgung dargestellt.

Eine Leitung gilt dann als gesichert versorgt, wenn sie von mindestens zwei verschiedenen Schaltern oder Trafos mit einer Nicht-Systemquelle versorgt wird. Systemquellen tragen nicht zur gesicherten Versorgung bei, schließen sie aber auch nicht aus.

Mehrfachversorgung

Das Element wird entsprechend den Regeln der Mehrfachversorgung dargestellt.

Eine Leitung gilt dann als mehrfach versorgt, wenn sie von mindestens zwei verschiedenen Quellen versorgt wird. Dabei ist ohne Belang, ob es sich um System- oder um Benutzerquellen handelt und von welcher Seite die Leitung von den Quellen versorgt wird.

kein Vorrang

Die Einfärberegeln für Mehrfachversorgung und für Gesicherte Versorgung werden gleichzeitig angewandt, falls beide Kriterien erfüllt werden. Das bedeutet:

Ist eine Leitung

  • mehrfach und gesichert versorgt,
  • der Vorrang auf kein Vorrang eingestellt,
  • die Darstellung für Mehrfachversorgung auf zwei höchstpriore Quellen gesetzt,
  • die Darstellung für gesicherte Versorgung auf doppelte Breite gesetzt,

dann wird die Linie doppelt breit und zweifärbig gestrichelt dargestellt.

Mehrfachversorgung darstellen

Interne ID: Leitungen

Mehrfachversorgung darstellen

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.
Definiert die Darstellungsart, wenn das Element mit mehreren aktiven Quellen verbunden ist:
höchst-priore Quelle: Es wird nur die Farbe der Quelle mit der höchsten Priorität verwendet.
zwei höchst-priore Quellen: Die unterschiedlichen Farben der beiden Quellen mit der höchsten Priorität werden strichliert dargestellt.
alternative Farbe: Alternative Farbe für die Einfärbung bei Mehrfachversorgung.

Default: höchst-priore Quelle

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wird eine Leitung durch mehrere unterschiedliche Quellen gleichzeitig versorgt, spricht man von einer Mehrfachversorgung. Hier definieren Sie, wie mehrfach versorgte Leitungen dargestellt werden.

Default: höchst-priore Quelle

höchst-priore Quelle

Die Leitung übernimmt immer die Linienfarbe jener Quelle, die die höchste Priorität hat.
Hinweis: Prioritäten entsprechen der in der ALC Konfiguration gewählten Reihenfolge.

zwei höchst-priore Quellen

Relevant für Leitungen, die durch zwei oder mehrere unterschiedliche Quellen gespeist werden. Die zwei Quellen mit der höchsten Priorität bestimmen die Farbgebung. Die Leitung wird mit diesen beiden Farben gestreift dargestellt. Die Strichelungslänge kann über die Eigenschaft Strichelungslänge mehrfachversorgt festgelegt werden.

Interne ID: Leitungen

Strichelungslänge mehrfachversorgt

Nur verfügbar, wenn die Eigenschaft Mehrfachversorgung darstellen den Wert zwei höchstpriore Quellen hat.

Definiert die Strichelungslänge in Pixel für die gestrichelte ALC-Einfärbung bei Mehrfachversorgung.

Minmal: 0 (automatische Strichelungslänge)

Maximal: 32767

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Systemquellen gelten bei Mehrfachversorgung wie echte Quellen und färben Linien zweifärbig, falls sie entsprechend konfiguriert wurden.

alternative Farbe

Die in der Eigenschaft Alternative Farbe definierte Farbe wird verwendet.

Interne ID: Leitungen

Alternative Farbe

Nur verfügbar, wenn die Eigenschaft Mehrfachversorgung darstellen den Wert alternative Farbe hat.

Alternative Farbe für die ALC Einfärbung bei Mehrfachversorgung.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Strichelungslänge mehrfachversorgt

Definiert die Strichelungslänge in Pixel von Linien, Polylinien oder Rohrleitungen für die gestrichelte ALC-Einfärbung bei zwei höchstpriore Quellen für Mehrfachversorgung darstellen.

  • Minmal: 0 (automatische Strichelungslänge)
  • Maximal: 32767
  • Default: 0

Alternative Farbe

Alternative Farbe für die ALC Einfärbung von Linien, Polylinien oder Rohrleitungen bei Mehrfachversorgung.

gesicherte Versorgung darstellen

Interne ID: Leitungen

gesicherte Versorgung darstellen

Steht nur zur Verfügung, wenn Farbe aus ALC aktiviert wurde.

Auswahl, wie die gesicherte Versorgung dargestellt werden soll:

  • doppelte Breite
  • doppelte Helligkeit
  • normal

Default: normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wird eine Leitung durch eine einzige Quelle mehrfach (parallel) versorgt, spricht man von einer 'Gesicherten Versorgung'. Hier definieren Sie wie 'Gesicherte Versorgung' dargestellt wird.

Eine Leitung wird immer dann gesichert versorgt dargestellt, wenn sie von mindestens zwei Schaltern mit einer echten Quelle (nicht Systemquelle) versorgt wird.

Default: normal

doppelte Breite

Relevant für Leitungen, die von ein und derselben Quelle mehrfach (gesichert) versorgt werden. Ist das der Fall, wird die Leitung mit der doppelten projektierten Breite gezeichnet. (Beispiel: Eine Leitung mit Linienbreite 5 wird bei gesicherter Versorgung mit Linienbreite 10 dargestellt).
Wird diese Leitung durch zwei oder mehrere unterschiedliche Quellen (Mehrfachversorgung) versorgt, ändert sich die Linienbreite nicht!

Die Farbe wird immer durch die höchst-priore Quelle vorgegeben!

doppelte Helligkeit

Relevant für Leitungen, die von ein und derselben Quelle mehrfach (gesichert) versorgt werden. Ist das der Fall wird die Leitung mit der doppelten projektierten Helligkeit gezeichnet.
Wird diese Leitung durch zwei oder mehrere unterschiedliche Quellen (Mehrfachversorgung) versorgt, ändert sich die Linienfarbe nicht!
Wird diese Leitung von einer einzigen Quelle (gesicherte Versorgung) mehrfach versorgt, so wird die Leitung mit doppelter Helligkeit gezeichnet.
Formel für die Berechnung der doppelten Helligkeit:

  1. Die eingestellte RGB-Farbe wird in den HLS Farbraum umgerechnet.
  2. L (also Luminanz = Helligkeit) wird neu berechnen mit NeueLuminanz = 240*3/4 + L/4
  3. Der Farbwert wird mit der neuen Helligkeit wieder in den RGB Farbraum zurückgerechnet.

Die Farbe wird immer durch die höchst-priore Quelle vorgegeben!

normal

Das Element wird in der Farbe der Quelle und der projektierten Breite dargestellt.

Alias verwenden

Interne ID: Leitungen

Alias verwenden

Nur verfügbar, wenn Farbe aus ALC aktiv ist.
Aktiv: Alias wird verwendet. Das Element bezieht zur Runtime seine ALC-Farbe von einem anderen Element im topologischen Modell, ohne selbst Teil des Modells zu sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: ALias wird benutzt.

Alias

Interne ID: Leitungen

Alias

Nur verfügbar, wenn Farbe aus ALC aktiv ist.

Definiert Quellelement für Alias verwenden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines vorhandenen Elements.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Öffnet Dialog zur Auswahl eines Alias

info Info

Die Quellenfarben und die Prioritäten der Quellen werden bei den Projekteigenschaften eingestellt.

Benutzerdefinierte Quellen müssen eine ID höher als 9 haben. IDs bis 9 sind für Systemquellen reserviert.

info Info

Die Berechnung der Farbe einer Leitung zur Runtime wird nach folgender Prioritätenliste durchgeführt:

  1. Automatic Line Coloring (höchste Priorität, überlagert alle anderen Einstellungen)
  2. Farben dynamisch
  3. Farben statisch

Noch in diesem Kapitel

Beispiel

Anschlusspunkte bei Leitungen


Beispiel

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Leitungen -> Beispiel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es wird im Folgenden angenommen, dass der 'Quelle 0' die Farbe blau zugewiesen ist, während 'Quelle 1' die Farbe rot hat. Außerdem ist 'Quelle 0' die höchstpriore Quelle.

Quelle 0

Quelle 1

Daraus ergeben sich für die verschiedenen Optionen folgende beispielhafte Darstellungen:

 | Linie / Polylinie | Rohrleitung
höchst-priore Quelle |  |
zwei höchst-priore Quellen |  |
doppelte Breite |  |
doppelte Helligkeit |  |


Anschlusspunkte bei Leitungen

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Leitungen -> Anschlusspunkte bei Leitungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Projektieren erfolgt der Anschluss einer Leitung (Linie, Polylinie oder Rohrleitung) an eine weitere Leitung durch überlappende Projektierung im Bild an so genannten 'Fangpunkte' der Leitungen. Die Fangpunkte - eigentlich sind es Fangbereiche - befinden sich jeweils am Anfang und am Ende einer jeden Leitung und sind am Anfangs- bzw. Endpunkt jeweils ± 3 Pixel groß.

Example Beispiel

Der Anfangspunkt einer Leitung hat die Koordinaten (Startpunkt x/ Startpunkt y): 150/100 Pixel.
Daraus ergibt sich ein Fangbereich von (x / y): 147 - 153 / 97 - 103 Pixel.

Befindet sich der Leitungsanfang oder das Ende dieser Leitung, einer oder mehrerer weiteren Leitungen innerhalb dieses Bereichs, wird automatisch eine Verknüpfung hergestellt, ohne dass es dafür weiterer Einstellungen bedarf. Eine reine Überlappung der Fangbereiche der einzelnen Linien ist nicht ausreichend!

In der folgenden Grafik wird der Fangbereich grafisch dargestellt (Die grünen Leitungen haben mit der schwarzen Leitung eine Verbindung, die rote Leitung nicht.):

info Info

An jedem Fangpunkt können beliebig viele Leitungen miteinander verbunden werden.

attention Achtung

Befindet sich eine Leitung außerhalb des oben dargestellten Fangbereichs (z.B. die roten Leitungen in der Grafik), wird keine Verbindung erkannt und es erfolgt daher keine Einfärbung der Leitung. Auch für alle nachfolgenden Leitungen wird damit die Einfärbung nicht stimmen.

Leitungskreuzungen lassen sich sehr einfach realisieren, indem die Enden der Leitungen sich nicht im Fangbereich befinden:

attention Achtung

Verwenden Sie ALC Elemente nur im ungedrehten Zustand, denn:

Die Berechnung des Topologischen Modells für ALC erfolgt im Editor auf Basis der Positionen der Elemente im ungedrehten Zustand und ohne Berücksichtigung etwaiger Dynamiken.


Überprüfung der Projektierung

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC Elemente -> Überprüfung der Projektierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projektieren Sie die gewünschten verfahrenstechnischen Elemente und Leitungen in einem oder mehreren Bildern und speichern Sie diese Bilder. Jetzt können Sie mithilfe von Alle Runtime-Dateien erzeugen oder Geänderte Runtime-Daten erzeugen überprüfen, ob in Ihren Bildern Fehler oder Konflikte vorhanden sind. Sollten Fehler und/oder Konflikte vorhanden sein, werden entsprechenden Fehlermeldungen oder Warnungen im Ausgabefenster angezeigt.

info Info

Klicken Sie die entsprechende Zeile im Ausgabefenster doppelt an. Das Bild mit dem fehlerhaften Bildelement wird automatisch geöffnet. Wenn sich das fehlerhafte Bildelement in einem Symbol befindet, wird automatisch das entsprechenden Symbol selektiert.

Folgende Fehlermeldungen können angezeigt werden.

  • ALC: Bild '%s' - An der Leitung '%s' sind zwei Link-Elemente mit unterschiedlicher Link-Nummer angeschlossen. (Doppelklick öffnet das Bild und selektiert die Leitung)
  • ALC: Bild '%s' - Am Element '%s' sind mehr als zwei Anschlusspunkte belegt. Pro Element darf jeweils nur ein Eingang und ein Ausgang verwendet werden. (Doppelklick öffnet das Bild und selektiert das Element

Folgende Warnungen können angezeigt werden.

  • ALC: Bild '%s' - Die Alias-Leitung '%s' ist an eine nicht Alias-Leitung angeschlossen. (Doppelklick öffnet das Bild und selektiert die Leitung)
  • ALC: Bild '%s' - Das Alias-Element '%s' ist an eine Nicht-Alias-Leitung angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)
  • ALC: Bild '%s' - Das Nicht-Alias-Element '%s' ist an eine Alias-Leitung angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)
  • ALC: Bild '%s' - Die Leitung '%s' ist nur einseitig angeschlossen. (Doppelklick öffnet das Bild und selektiert die Leitung)
  • ALC: Bild '%s' - Das Element '%s' ist nicht angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)
  • ALC: Bild '%s' - Das Element '%s' ist nur einseitig angeschlossen. (Doppelklick öffnet das Bild und selektiert das Element)

In den Fehlermeldungen bzw. Warnungen werden die entsprechenden Elemente mithilfe der Element-Referenz identifiziert. Diese Referenz dient auch als Verknüpfungsschlüssel bei ALC-Aliasen.


Konfiguration

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Modus der Einfärbung für UNDEFINED

Konfiguration der Quellen

Konfiguration der Topologischen Verriegelung


Modus der Einfärbung für UNDEFINED

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Modus der Einfärbung für UNDEFINED

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Zustand UNDEFINED kann die Einfärbung des Netzes in zwei Modi erfolgen:

  • Standard
  • Versorgung vorrangig

Die Einstellung erfolgt über die Projekteigenschaft Automatic Line Coloring/Modus der Einfärbung.

Interne ID: Modus der Einfärbung für UNDEFINED

Modus der Einfärbung

Legt den Modus der Einfärbung für den Zustand UNDEFINED fest. Klick auf Dropdownliste öffnet Auswahl:

- Standard: Die Quellenfarbe wird ausgehend von jeder eingeschalteten Quelle im Netz verteilt, solange der nächste Schalter geschlossen ist.

- Versorgung vorrangig: Färbt nur Leitungen ein, die von zumindest einer Quelle potenziell versorgt sind, aber von keiner Quelle eindeutig.

Default: Standard

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Modus der Einfärbung für UNDEFINED

Automatic Line Coloring

Eigenschaften nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Eigenschaften für ALC.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Standard

Die Graphensuche beginnt bei einer Quelle und durchschreitet das gesamte Netz so, dass jeder geschlossene Schalter (Schaltervariable hat Wert 1) pro Richtung nur einmal durchwandert wird und somit keine Zyklen entstehen. Dabei wir jeder besuchte Knoten (=Leitungssegment) mit der Quellenfarbe eingefärbt. Als Knoten werden direkt zusammenhängende Leitungen/Linien bezeichnet.

Trifft die Suche auf einen Schalter, dessen Schaltervariable einen der folgenden Status hat, wird ab diesem Punkt die UNDEFINED Farbe zum Einfärben verwendet:

  • INVALID [Wert: beliebig],
  • ist gestört [Wert: 3]
  • ist in Zwischenstellung [Wert: 2])

Die Graphensuche wird ab nun in gleicher Form weitergeführt. Jeder Schalter wird pro Richtung nur einmal mit der UNDEFINED Farbe durchwandert. Damit kann jeder Schalter pro Quelle maximal vier Mal durchwandert werden:

  1. mit Quellennummer in Vorwärtsrichtung,
  2. mit Quellennummer in Rückwärtsrichtung,
  3. mit UNDEFINED in Vorwärtsrichtung,
  4. mit UNDEFINED in Rückwärtsrichtung

Versorgung vorrangig

Mit der Einstellung Versorgung vorrangig werden nur Leitungen als UNDEFINED eingefärbt, die von zumindest einer Quelle potenziell versorgt sind, aber von keiner Quelle eindeutig. Ist eine Leitung von zumindest einer Quelle eindeutig versorgt, so kann sie von einer anderen Quelle keinen UNDEFINED Einfärbung mehr erhalten.

Diese Suche erfolgt zweistufig:

  • Im ersten Schritt wird wie bei Standard von jeder eingeschalteten Quelle ausgehend die Quellenfarbe im Netz verteilt, solange der nächste Schalter geschlossen ist. Ist der Schalter geöffnet oder gestört/undefiniert, wird die Suche beendet.
  • Im zweiten Schritte wird die Suche bei jedem gestört/undefiniert Schalter begonnen, der einseitig versorgt ist, und die UNDEFINED Farbe auf der unversorgten Seite im Netz verteilt. Diese Suche betrachtet auch Schalter als geschlossen, die gestört/undefined sind und verbreitet somit die UNDEFINED Farbe so lange im Netz, bis sie auf einen eindeutig geöffneten Schalter stößt. Zusätzlich wird die Suche beendet, wenn ein Leitungssegment erreicht wird, welches bereits versorgt ist.


Konfiguration der Quellen

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Konfiguration der Quellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration der Quellen, z.B. deren Bezeichnung und Farben (Reihenfolge und Priorität), erfolgt projektbezogen in den Projekteigenschaften unter ALC Konfiguration.

Für jede einzelne Quelle können folgende Parameter konfiguriert werden:

Parameter

Beschreibung

Nummer

Interne eindeutige fortlaufende Nummer, damit die Quellen eindeutig zugeordnet werden können. Diese Nummer wird vom System automatisch vergeben, und kann nicht geändert werden.

Achtung: Die IDs 0 bis 9 sind für Systemquellen reserviert und dürfen nicht benutzerspezifisch verwendet werden.

Name

Logische Bezeichnung für die Quelle (z.B.: 'Wasser' oder 'geerdet'). Diese Bezeichnung wird auch bei der Auswahl der Quelle beim Combi-Elementen verwendet. Die Bezeichnung können Sie ändern, indem Sie mit der linken Maustaste die Quellenbezeichnung anklicken. Dadurch wird in einen Editiermodus umgeschaltet. Mit der 'Enter' Taste oder durch Selektion einer anderen Quelle wird die Änderung übernommen.

Hinweis: Die Bezeichnungen sind nicht sprachumschaltbar.

Vordergrund

Vordergrundfarbe der jeweiligen Quelle. Diese wird für das Zeichnen von Linien, Polylinien sowie als äußere Farbe für Rohrleitungen verwendet.

Hintergrund

Hintergrundfarbe der jeweiligen Quelle. Diese wird als Hintergrundfarbe bei Rohrleitungen und verfahrenstechnischen Elementen (Combi-Element) verwendet.

Die Konfiguration der Farben kann direkt über die Eingabe des entsprechenden Hexadezimal-Codes erfolgen. Dazu klicken Sie mit der linken Maustaste die Farbbezeichnung an, dann wird in einen Editiermodus umgeschaltet. Mit der 'Enter' Taste oder durch Selektion einer anderen Quelle wird die Änderung auch hier übernommen.

Alternativ kann die Farbauswahl auch mittels eines Dialoges getroffen werden. Bei aktivieren des Hexadezimal-Codes erscheint in dieser Spalte die Schaltfläche ... Beim Anklicken dieser gelangen Sie jetzt in die Farbauswahl.

Der hexadezimale Farbcode beschreibt einen RGB Farbwert und setzt sich wie folgt zusammen: #RRGGBB.

Element | Bedeutung
# | Kennzeichnung dafür, dass ein Hexadezimaler Farbcode verwendet wird.
RR | 2 Stellen für den Rotwert der Farbe in Hexadezimaler Nomenklatur. 0-255 entspricht 0-FF
GG | 2 Stellen für den Grünwert der Farbe in Hexadezimaler Nomenklatur. 0-255 entspricht 0-FF
BB | 2 Stellen für den Blauwert der Farbe in Hexadezimaler Nomenklatur. 0-255 entspricht 0-FF

Mit den Schaltflächen Neu und Löschen werden neue Quellen angelegt bzw. bestehende Quellen gelöscht.

attention Achtung

Einschränkungen beim Löschen der Quellen:

Die Quellen mit der ID 0 bis 9 sind für Systemquellen reserviert und können nicht gelöscht werden.

Nur die Quelle mit der höchsten ID kann gelöscht werden.

info Info

Die Reihenfolge in dieser Liste entspricht der Priorität der Quellen, wobei das erste Element die höchste Priorität erhält.

Um die Prioritäten der einzelnen Quellen untereinander zu verändern, können Sie diese mit den Pfeil-Schaltflächen durchführen.


Konfiguration der Topologischen Verriegelung

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Konfiguration der Topologischen Verriegelung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit können topologische Verriegelungen aus der ALC für die Befehlsgabe konfiguriert werden.

info Info

Dieser Dialog ist nur verfügbar, wenn sowohl die Energy Edition als auch das Modul Automatic Line Coloring lizenziert sind (Topologiepaket).

Folgende Bedingungen stehen dabei zur Verfügung. Die hier getroffenen Einstellungen gelten global für das gesamte Topologische Modell:

Parameter | Beschreibung
Spannung gegen Erde | Verriegelung ist aktiv, wenn ein Schalter/Trenner geschlossen werden soll, an dessen einem Anschluss geerdetes Potential anliegt und dessen anderer Anschluss bespannt oder undefiniert ist.
Schalthandlung in Gebiet mit undefiniertem Zustand | Verriegelung ist aktiv, wenn ein Schalter/Trenner geschlossen werden soll, bei dem beide Anschlüsse auf 'undefiniert' oder 'gestört' liegen.
Trenner unter Last | Verriegelung ist aktiv, wenn für das Einschalten bzw. Ausschalten bestimmte Bedingungen erfüllt werden. Bedingungen: siehe Abschnitt "Trenner unter Last - Verriegelungsbedingungen".
Verbraucher würde nicht mehr versorgt werden | Verriegelung ist aktiv, falls nach der Schalthandlung (mittels Schalter oder Trenner) eingeschalteter Verbraucher spannungslos wäre der vorher versorgt war.
Bereich mit undefiniertem Zustand würde größer werden | Verriegelung ist aktiv, wenn ein Schalter/Trenner geschlossen werden soll, bei dem ein Anschluss auf 'undefiniert' oder 'gestört' liegt und der andere nicht.

Wenn Sie bei einer dieser Verriegelungen in die Spalte Status klicken, öffnet sich eine Dropdownliste mit drei Auswahlmöglichkeiten:

Parameter | Beschreibung
nicht prüfen | Die ausgewählte Bedingung wird in diesem Projekt (topologischen Modell) nicht berücksichtigt.
entriegelbar | Die ausgewählte Bedingung wird in diesem Projekt überprüft. Trifft die Bedingung zu, so kann sie der Benutzer mithilfe der Befehlsgabe entriegeln (Bild vom Typ Befehlsgabe). Die Entriegelung wird in der Chronologischen Ereignisliste mitprotokolliert.
nicht entriegelbar | Die ausgewählte Bedingung wird in diesem Projekt überprüft. Der Benutzer kann sie nicht entriegeln.

Ausnahme Topologische Verriegelung

Die Topologische Verriegelung wird nicht ausgeführt, wenn:

  • die Variable eines Schalters den Status Revision hat
    oder
  • die Variable handnachgeführt oder auf Ersatzwert eingestellt wird und dabei auf den selben Variablenwert geschaltet wird wie der Ausgangswert, also wenn der Schalter:
    • auf AUS ist und danach auf AUS nachgeführt oder ersetzt wird
    • auf EIN ist und danach auf EIN nachgeführt bzw. ersetzt wird

Noch in diesem Kapitel

Trenner unter Last - Verriegelungsbedingungen


Trenner unter Last - Verriegelungsbedingungen

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Konfiguration -> Konfiguration der Topologischen Verriegelung -> Trenner unter Last - Verriegelungsbedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Topologische Verriegelung Trenner unter Last darf ein Trenner geschaltet werden, wenn eine der folgenden Bedingungen zutrifft:

Beim Einschalten:

Vor dem Schalten:

  • sind das linke und das rechte Leitungssegment von der gleichen Quelle bespannt
  • ist das linke Leitungssegment spannungsfrei, das rechte Leitungssegment geerdet
  • ist das linke Leitungssegment geerdet, das rechte Leitungssegment spannungsfrei
  • ist das linke Leitungssegment unbelastet
  • ist das rechte Leitungssegment unbelastet

Beim Ausschalten:

Nach dem Schalten:

  • wären das linke und das rechte Leitungssegment von der gleichen Quelle bespannt
  • wäre das linke Leitungssegment spannungsfrei, das rechte Leitungssegment geerdet
  • wäre das linke Leitungssegment geerdet, das rechte Leitungssegment spannungsfrei
  • wäre das linke Leitungssegment unbelastet
  • wäre das rechte Leitungssegment unbelastet

info Info

Bedeutung von "unbelastet"

Für den Zustand unbelastet müssen alle diese Bedingungen erfüllt werden:

  • Alle am Leitungssegment angeschlossenen Schalter und Trenner sind geöffnet.
  • Alle am Leitungssegment angeschlossenen Quellen und Verbraucher sind ausgeschaltet.
  • Es darf kein Trafo am Leitungssegment angeschlossen sein.
  • Es darf sich nicht um einen Leitung handeln, an der ausschließlich dieser Trenner angeschlossen ist (offene Leitung).


ALC-Quellenfarbe ändern

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> ALC-Quellenfarbe ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion ALC-Quellenfarbe ändern kann die Vordergrund- und Hintergrundfarbe einer ALC-Quelle für die Einfärbung zur Runtime vorübergehend geändert werden. Die Änderung bleibt bis zum Beenden der Runtime, Nachladen oder erneuten Ausführung der Funktion geändert. Um die Funktion zu erstellen:

Interne ID: ALC-Quellenfarbe ändern

ALC-Quellenfarbe ändern

Funktion zur Konfiguration der ALC-Quellenfarben bei Fehlerortung in elektrischen Netzen.

Mehr im Online-Handbuch.

  • wählen Sie Funktion neu
  • navigieren Sie zum Knoten Bilder
  • wählen Sie ALC-Quellenfarbe ändern

  • der Dialog zur Definition der Linienfarbe und der Füllfarbe öffnet sich
  • definieren Sie die gewünschten Farben

Eigenschaft | Funktion
Quelle | Dropdownliste zur Auswahl der Quelle und Anzeige der aktuell zugewiesenen Farben. Diese Farben sind hier nicht änderbar.
Neue Farbe für Quelle | Klick auf Farbe öffnet Dialog zur Auswahl einer Farbe.


Detailbilder

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Detailbilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Darstellung von Einzelbildern kann mit der Hilfe von Alias ein Teilbereich aus dem Topologischen Netz herausgenommen und einzeln dargestellt werden. Die Bildelemente im Detailbild werden zwar nicht in das topologische Model mit aufgenommen, beziehen aber trotzdem ihre ALC-Farben aus dem Modell. Sie beziehen sich dazu auf einen Alias der Bildelemente aus dem Gesamtbild.

Alias anlegen

Alias können angelegt werden für die Elemente:

  • Linie
  • Polylinie
  • Rohrleitung
  • Combi-Element

Um ein Quellelement als Alias anzulegen:

  • aktivieren Sie in den Eigenschaften des Elements Alias verwenden

    Interne ID: Detailbilder

    Alias verwenden

    Nur verfügbar, wenn Farbe aus ALC aktiv ist.
    Aktiv: Alias wird verwendet. Das Element bezieht zur Runtime seine ALC-Farbe von einem anderen Element im topologischen Modell, ohne selbst Teil des Modells zu sein.

    Interne ID: Detailbilder

    Farbe aus ALC

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
    Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
    Inaktiv: Die Standard-Farbe wird verwendet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    (dazu muss ALC lizenziert sein und die Eigenschaft Farbe aus ALC aktiv)

  • klicken Sie bei der Eigenschaft Alias auf die Schaltfläche ...

    Interne ID: Detailbilder

    Alias

    Nur verfügbar, wenn Farbe aus ALC aktiv ist.

    Definiert Quellelement für Alias verwenden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines vorhandenen Elements.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Dialog zur Auswahl des Elements öffnet sich

Parameter

Beschreibung

Bild

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Bildes.

Verfügbare ALC-Elemente

Zeigt die zum Bild gehörigen Elemente mit Elementname, Art des Elements und Funktionstyp an. Klick auf ein Element wählt Alias aus.

Filter

Die Elemente können nach allen Spalten gefiltert werden. Beim Setzen eines Filters werden die angebotenen Möglichkeiten aller anderen Filter auf sinnvoll kombinierbare Werte reduziert.

  • Name: Eingabe eines freien Suchbegriffs mit Wildcards (*). Die letzten 12 Suchbegriffe werden bis zum Beenden des Editors in einer Liste angeboten.
  • Element: Auswahl aus Dropdownliste.
  • Funktionstyp: Auswahl aus Dropdownliste.

Klick auf ... öffnet gespeicherte Suche bzw. Dropdownliste.

Bei aktiviertem Filter löscht Klick auf Schaltfläche X den Filter.

Ausgewählter Alias

Zeigt das im Feld Verfügbare ALC-Elemente ausgewählte Element an.

Keine Auswahl

Entfernt ausgewähltes Element.

OK

Speichert Auswahl und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.

info Info

Bei der Auswahl eines Elements für einen Alias können nur Elemente und Bilder aus dem selben Projekt gewählt werden, in dem der Alias definiert wird. Elemente aus Unterprojekten oder parallelen Projekten stehen nicht zur Verfügung.

Ersetzung von Aliasnamen

Alias können bei der Bildumschaltung über Verknüpfung ersetzen ausgetauscht werden. Ein Detailbild kann daher mit den Daten unterschiedlicher Anlagenteile, z.B. Abgängen oder Teilnetzen, dargestellt werden. Die Ersetzung von Aliasnamen erfolgt analog zu jener von Variablen und Funktionen. Auch die Ersetzung in Elementen, die in Symbolen verwendet werden, ist möglich. Als Auswahldialog für das Ziel wird der gleiche Dialog wie bei der Eigenschaft Alias geöffnet.

Hinweis: Die Substituierung über Indexvariablen ist nicht möglich.


Fehlerortung in elektrischen Netzen

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Fehlerortung kennzeichnet Netzteile, die mit Erdschlusss oder Kurzschluss behaftet sind, durch spezielle Einfärbungen im ALC. Quellen für die Fehlersuche sind so genannte Erdschluss- bzw. Kurzschlussmelder, die einem Leistungsschalter zugeordnet sind. Erdschluss- und Kurzschlussmelder befinden sich immer am Ausgang des Leistungsschalter-Elements. Fehleranzeigen sind im Bild fixiert und müssen manuell zurückgesetzt werden.

info Info

Diese Funktionalität ist nur verfügbar, wenn sowohl die Energy Edition als auch das Modul Automatic Line Coloring lizenziert sind (Topologiepaket).

Fehlerortung

Die Fehlerortung läuft lokal. Jeder Client im Netzwerkbetrieb hat sein unabhängiges Modell und kann somit unabhängig Erd- und Kurzschlüsse in verschiedenen Netzteilen suchen.

Die Fehlerortung in elektrischen Netzen teilt sich in:

  • Erdschlusssuche
  • Kurzschlusssuche

Um die Fehlerortung zur projektieren

  • benötigen Sie eine Lizenz für ALC und zenon Energy Edition
  • legen Sie die entsprechenden Bilder an
  • konfigurieren Sie ALC auf den entsprechenden Combi-Elementen (Schalter, Trafos, Trenner, Schieber)
  • konfigurieren Sie Leitungen so, dass sie ihre Einfärbung über ALC erhalten

Für die Fehlerortung stehen Ihnen zur Runtime spezielle Funktionen zur Verfügung:

  • Erdschlusssuche starten
  • Erdschlussmeldung quittieren
  • Erdschlusssuche beenden
  • Kurzschlussmeldung quittieren

Einfärbungen

Fehler lassen sich durch eine spezielle Einfärbung der Leitungen im ALC anzeigen. Zur Runtime wechselt die per ALC zugewiesene Farbe automatisch sobald sich der Zustand der Leitung ändert. Die projektierten Einfärbungen können zur Runtime vorübergehend über die Funktion ALC-Quellenfarbe ändern geändert werden.

Meldungen werden in der Reihenfolge ihres Eintreffens bearbeitet. Bei Konflikten

  • haben die Farben für Fehleranzeige den Vorrang
  • haben Kurzschlussmeldungen Vorrang vor Erdschlussmeldungen

Noch in diesem Kapitel

Erdschlusssuche

Kurzschlusssuche


Erdschlusssuche

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Erdschlusssuche dient dazu, potenziell erdschlussbehaftete Netzteile durch Einfärbung zu markieren. Die Farbe wird aus der Projektierung der ALC-Quellenfarben für die Quelle GROUND FAULT bezogen.

Welche Netzteile potenziell erdschlussbehaftet sind, wird aus den Erdschlussmeldungen von Erdschlusserkennungsgeräten (Erdschlusssanzeiger, Schutzgerät mit Erdschlussserfassung) abgeleitet. Für Erdschlussmeldungen gilt:

  • Jedes Gerät kann ein bis drei Erdschlussmeldungen besitzen.
  • Erdschlussmeldungen werden entweder per Dauermeldungsverarbeitung oder per Wischermeldungsverarbeitung behandelt.
  • Bei Erdschlusserkennungsgeräten mit Richtung kann die Richtung vor- oder nacheilend zur Auslösung sein.
    • Voreilend: Zuerst kommt die Meldung, dann das Wischerbit.
    • Nacheilend: Zuerst kommt das Wischerbit, dann die Meldung.

info Info

Ein potenziell erdschlussbehafteter Netzteil wird erst dann als nicht mehr erdschlussbehaftet betrachtet, wenn dieser erfolgreich bespannt wurde.

Projektierung

Um die Erdschlusssuche zu projektieren:

  1. weisen Sie dem Combi-Element, das den Schalter repräsentiert, den Funktionstyp Schalter zu

    Interne ID: Erdschlusssuche

    Funktionstyp

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
    Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
    Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
    Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
    keine Funktion: Das Element hat im ALC keine Funktion.
    Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
    Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
    Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
    Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
    Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
    Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
    Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie Modus der Erdschlusssuche, Erschlusssanzeige und Erdschlusserkennung Auslösung
  3. legen Sie die Funktionen für Erdschlusssuche starten, Erschlusssmeldung quittieren und Erdschlusssuche beenden an

info Info

Um auch in vermaschten Netzen Erdschlüsse eingrenzen zu können, wird pro Pfad beginnend bei einer Quelle nur ein erdschlussbehafteter Bereich gesucht.

Noch in diesem Kapitel

Modus der Erdschlusssuche

Erdschlussserkennungstyp

Erschlussanzeige

Erdschlusserkennung Auslösung

Erdschlusssuche starten

Erschlusssmeldung quittieren

Erdschlusssuche beenden


Modus der Erdschlusssuche

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Modus der Erdschlusssuche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Erdschlusssuche kann wahlweise:

  • den potenziell erdschlussbehafteten Netzteil einfärben
    oder
  • das gesamte Netz, in dem sich ein Erdschluss befindet

Der Modus der Einfärbung wird definiert über die Eigenschaft Modus der Erdschlusssuche.

Interne ID: Modus der Erdschlusssuche

Modus der Erdschlusssuche

Legt fest, ob bei der Erdschlusssuche der potenziell erdschlussbehaftete Netzteil eingefärbt wird oder das gesamte Netz, in dem sich ein Erdschluss befindet.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um die Eigenschaft zu projektieren:

  • navigieren Sie in den Projekteigenschaften zum Knoten Automatic Line Coloring

    Interne ID: Modus der Erdschlusssuche

    Automatic Line Coloring

    Eigenschaften nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
    Eigenschaften für ALC.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • wählen Sie in der Dropdownliste der Eigenschaft Modus der Erdschlusssuche den gewünschten Modus
    • Netzteil einfärben: färbt nur den potenziell erdschlussbehaftete Netzteil ein
    • Ganzes netz einfärben: färbt das gesamte zusammenhängende Netz, in welchem sich ein Erdschluss befindet, ein

Diese Einstellung kann zur Laufzeit über das Objektmodell der zenon API geändert werden. Dabei wird die Erdschlusssuche komplett neu durchgerechnet.


Erdschlussserkennungstyp

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlussserkennungstyp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Einstellung Typ werden Richtung und Art der Meldungsverarbeitung für das Combi-Element vom Typ Schalter festgelegt. Zur Projektierung:

Interne ID: Erdschlussserkennungstyp

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Erdschlussserkennungstyp

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Erdschlussserkennungstyp

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Erdschlusserkennung

    Interne ID: Erdschlussserkennungstyp

    Erdschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Erdschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie bei der Eigenschaft Typ den gewünschten Typ mit Richtung und Art der Meldungsverarbeitung
    • Richtung:
      gibt an, ob die steigende Flanke der Auslösungsmeldung oder die steigende Flanke einer Richtung vorher kommt
    • voreilend: bei steigender Flanke der Auslösungsmeldung wird der aktuelle Zustand der Richtung verwendet
    • nacheilend: nach steigender Flanke der Auslösungsmeldung wird auf die erste steigende Flanke einer Richtung gewartet, trifft diese nicht innerhalb von 2 Sekunden ein, wird das Erdschlusserkennungsgerät als ungerichtet betrachtet
    • Meldungsverarbeitung:
      gibt an, wie Meldungen verarbeitet werden
    • keine: normaler Schalter, Meldungen werden nicht verarbeitet
    • Dauermeldungsverarbeitung: neu eintreffende Meldungen werden als neue Erdschlussauslösung berücksichtig
    • Wischermeldungsverarbeitung: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

Hinweis: Die Unterscheidung zwischen Dauermeldungsverarbeitung und Wischermeldungsverarbeitung bezieht sich nur auf die Verarbeitung der Meldung, nicht auf deren Art. Eine Wischermeldungsverarbeitung muss sich also nicht auf ein Wischer-Bit beziehen.

attention Achtung

Um intermittierende Erdschlüsse zu unterdrücken, werden Erdschlussmeldungen, die in kürzeren Abständen als 2s eintreffen, ignoriert.


Erschlussanzeige

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erschlussanzeige

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die bei Anzeige verknüpfte Variable ist eine Ausgangsvariable der Fehlerortung und zeigt den erfassten Zustand des Erdschlusserkennungsgeräts an. Das ist nötig, da alle Meldungen intern bis zum Quittieren gespeichert bleiben, also nicht zwingend dem aktuellen Zustand der Meldevariablen entsprechen.

Interne ID: Erschlussanzeige

Anzeige

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Ausgangsvariable der Fehlerortung fest, um den Zustand des Erdschlusserkennungsgeräts anzuzeigen. Die hier verknüpfte Variable sollte eine lokale Variable sein, um Probleme im Netzwerkbetrieb zu verhindern. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: Erschlussanzeige

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Erschlussanzeige

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei jeder Erfassung einer Änderung wird ein Sollwert auf diese Variable abgesetzt. Dabei sind die Werte wie folgt:

Wert | Bedeutung
0 | kein Erdschluss
1 | Erdschluss vorwärts
2 | Erdschluss rückwärts
3 | Erdschluss ungerichtet
4 | Fehlerzustand -> beide Richtungen haben angesprochen

info Info

Um Probleme im Netzwerkbetrieb zu verhindern, sollte die hier verknüpfte Variable eine lokale Variable sein.


Erdschlusserkennung Auslösung

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlusserkennung Auslösung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Auslösung wird die Variable für die Meldung des Erdschlusserkennungsgeräts definiert. Sie kann Informationen enthalten über das Vorhandensein eines Erdschlusses und die Richtung der Erdschlusses aus Sicht des Erdschlusserkennungsgeräts. Dabei wird unterschieden zwischen:

Interne ID: Erdschlusserkennung Auslösung

Auslösung

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable fest, die die Erkennung eines Erdschlusses anzeigt. Bei gerichteten Erdschlussmeldern muss zusätzlich die Richtung (Rückwärts oder Vorwärts) definiert werden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: Erdschlusserkennung Auslösung

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Erdschlusserkennung Auslösung

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Erdschlusserkennung Auslösung

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Erdschlusserkennung Auslösung

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ungerichteten Erdschlussmeldern
  • gerichteten Erdschlussmeldern mit Auslösemeldung
  • gerichteten Erdschlussmeldern ohne Auslösemeldung

Um die Variable für die Auslösung zu projektieren:

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Erdschlusserkennung Auslösung

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Erdschlusserkennung

    Interne ID: Erdschlusserkennung Auslösung

    Erdschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Erdschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. für ungerichtete Erdschlussmelder

      klicken Sie bei der Eigenschaft Auslösung auf die Schaltfläche ...

      wählen Sie im sich öffnenden Dialog die gewünschte Variable

      die Eigenschaften für die Richtung bleiben leer

    2. für gerichtete Erdschlussmelder mit Auslösemeldung

      verknüpfen Sie die Variable mit der Auslösung und ergänzen Sie die entsprechend Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

    3. für gerichtete Erdschlussmelder ohne Auslösemeldung

      verknüpfen Sie die Variable mit der entsprechenden Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

      die Eigenschaft Auslösung bleibt leer

Hinweis: Sprechen bei einem gerichteten Erdschlusserkennungsgerät mit Vorwärts beide Richtungen an, so wird dieses als fehlerhaft betrachtet und ignoriert.


Erdschlusssuche starten

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlusssuche starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Erdschlusssuche starten dient zur Lokalisierung eines Erdschlusses und hat zur Runtime zwei Auswirkungen:

Interne ID: Erdschlusssuche starten

Erdschlusssuche starten

Funktion zum Starten der Erdschlusssuche.

Mehr im Online-Handbuch.

  1. Meldungen aller Erdschlusserkennungsgeräte, die mit Wischermeldungsverarbeitung projektiert wurden, werden ignoriert.
  2. Der Suchalgorithmus wird geändert: Schalthandlungen können den erdschlussbehafteten Bereich nur noch verkleinern. Neu eintreffende Erdschlussmeldungen vergrößern den potenziell erdschlussbehafteten Bereich also nicht.

Um die Funktion Erdschlusssuche starten zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Erdschlusssuche starten

  • verknüpfen Sie die Funktion mit einem Button


Erschlusssmeldung quittieren

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erschlusssmeldung quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion Erdschlussmeldung quittieren kann zur Runtime ein intern erfasster Erdschluss eines Erdschlusserkennungsgeräts quittiert werden. Dabei wird der intern gelatchte Erdschlusszustand zurückgesetzt, wenn der Zustand noch ansteht, oder als quittiert markiert. Eine erfasste Erdschlussmeldung wird intern nur gelöscht, wenn diese quittiert ist und nicht mehr ansteht.

Interne ID: Erschlusssmeldung quittieren

Erdschlussmeldung quittieren

Funktion zum Quittieren einer Erdschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Regeln beim Quittieren:

  • Wurde eine Variable verknüpft, die einer Auslösungs- oder Richtungsvariable eines Erdschlusserkennungsgeräts entspricht, so wird nur diese spezielle Erdschlussmeldung quittiert.
  • Wurde keine Variable verknüpft, werden alle Erdschlussmeldungen quittiert.
  • Das Quittieren kann auch über das Objektmodell der zenon API erfolgen.

Um die Funktion Erdschlussmeldung quittieren zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Erdschlussmeldung quittieren

  • der Dialog zur Auswahl einer Variablen öffnet sich
  • verknüpfen Sie die gewünschte Variable mit der Funktion
  • verknüpfen Sie die Funktion mit einem Button


Erdschlusssuche beenden

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Erdschlusssuche -> Erdschlusssuche beenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion Erdschlusssuche beenden Sie zur Runtime die Erdschlusssuche.

Interne ID: Erdschlusssuche beenden

Erdschlusssuche beenden

Funktion zum Beenden der Erdschlusssuche.

Mehr im Online-Handbuch.

Um die Funktion zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Erdschlusssuche beenden

  • verknüpfen Sie die Funktion mit einem Button


Kurzschlusssuche

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Kurzschlusssuche dient dazu, potenziell kurzschlussbehaftete Netzteile durch Einfärbung entsprechend zu markieren. Die Farbe wird aus der Projektierung der ALC-Quellenfarben für die Quelle SHORT FAULT bezogen.

Welche Netzteile potenziell kurzschlussbehaftet sind, wird aus Kurzschlussmeldungen abgeleitet. Ein Kurzschlusserkennungsgerät (Kurzschlussanzeiger, Schutzgerät) kann ein bis drei Kurzschlussmeldungen besitzen. Bei Kurzschlusserkennungsgeräten mit Richtung kann die Richtung vor- oder nacheilend zur Auslösung sein. Ein potenziell kurzschlussbehafteter Netzteil wird erst dann als nicht mehr kurzschlussbehaftet betrachtet, wenn dieser erfolgreich bespannt wurde.

Projektierung

Um die Kurzschlusssuche zu projektieren:

  1. weisen Sie dem Combi-Element, das den Schalter repräsentiert, den Funktionstyp Schalter zu

    Interne ID: Kurzschlusssuche

    Funktionstyp

    Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
    Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
    Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
    Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
    keine Funktion: Das Element hat im ALC keine Funktion.
    Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
    Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
    Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
    Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
    Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
    Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
    Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie Kurzschlusssanzeige undKurzschlussserkennung Auslösung
  3. legen Sie die Funktion für Kurzschlusssmeldung quittieren an

Noch in diesem Kapitel

Kurzschlussserkennungstyp

Kurzschlusssanzeige

Kurzschlussserkennung Auslösung

Kurzschlusssmeldung quittieren


Kurzschlussserkennungstyp

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlussserkennungstyp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Einstellung Typ werden Richtung und Art der Meldungsverarbeitung für das Combi-Element vom Typ Schalter festgelegt. Zur Projektierung:

Interne ID: Kurzschlussserkennungstyp

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Kurzschlussserkennungstyp

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Kurzschlussserkennungstyp

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Kurzschlusserkennung

    Interne ID: Kurzschlussserkennungstyp

    Kurzschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Kurzschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie bei der Eigenschaft Typ den gewünschten Typ
    • Richtung:
      gibt an, ob die steigende Flanke der Auslösungsmeldung oder die steigende Flanke einer Richtung vorher kommt
    • voreilend:
      bei steigender Flanke der Auslösungsmeldung wird der aktuelle Zustand der Richtung verwendet
    • nacheilend:
      nach steigender Flanke der Auslösungsmeldung wird auf die erste steigende Flanke einer Richtung gewartet, trifft diese nicht innerhalb von 2 Sekunden ein, wird das Kurzschlusserkennungsgerät als ungerichtet betrachtet
    • Meldungsverarbeitung:
      gibt an, wie Meldungen verarbeitet werden
    • keine:
      normaler Schalter, Meldungen werden nicht verarbeitet
    • Dauermeldungsverarbeitung:
      neu eintreffende Meldungen werden als neue Erdschlussauslösung berücksichtig


Kurzschlusssanzeige

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlusssanzeige

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die bei Anzeige verknüpfte Variable ist eine Ausgangsvariable der Fehlerortung und zeigt den erfassten Zustand des Kurzschlusserkennungsgeräts an. Das ist nötig, da alle Meldungen intern bis zum Quittieren gespeichert bleiben, also nicht unbedingt dem aktuellen Zustand der Meldevariablen entsprechen.

Interne ID: Kurzschlusssanzeige

Anzeige

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.

Interne ID: Kurzschlusssanzeige

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Kurzschlusssanzeige

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Ausgangsvariable der Fehlerortung fest, um den Zustand des Kurzschlusserkennungsgeräts anzuzeigen. Die hier verknüpfte Variable sollte eine lokale Variable sein, um Probleme im Netzwerkbetrieb zu verhindern. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei jeder Erfassung einer Änderung wird ein Sollwert auf diese Variable abgesetzt. Dabei sind die Werte wie folgt:

Wert | Bedeutung
0 | kein Kurzschluss
1 | Kurzschluss vorwärts
2 | Kurzschluss rückwärts
3 | Kurzschluss ungerichtet


Kurzschlussserkennung Auslösung

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlussserkennung Auslösung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Auslösung wird die Variable für die Meldung des Kurzschlusserkennungsgeräts definiert. Sie kann Informationen enthalten über das Vorhandensein eines Kurzschlusses und die Richtung der Kurzschlusses aus Sicht des Kurzschlusserkennungsgeräts.Dabei wird unterschieden zwischen:

Interne ID: Kurzschlussserkennung Auslösung

Auslösung

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.

Interne ID: Kurzschlussserkennung Auslösung

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: Kurzschlussserkennung Auslösung

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt die Variable für die Meldung des Kurzschlusserkennungsgeräts fest. Bei gerichteten Kurzschlussmeldern muss zusätzlich die Richtung (Vorwärts oder Rückwärts) definiert werden. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Variablen.

Interne ID: Kurzschlussserkennung Auslösung

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Kurzschlussserkennung Auslösung

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ungerichteten Kurzschlussmeldern
  • gerichteten Kurzschlussmeldern mit Auslösemeldung
  • gerichteten Kurzschlussmeldern ohne Auslösemeldung

Um die Variable für zu projektieren:

  1. navigieren Sie in den Eigenschaften des Combi-Elements zum Knoten Automatic Line Coloring

    Interne ID: Kurzschlussserkennung Auslösung

    Automatic Line Coloring

    Eigenschaften für Automatic Line Coloring (ALC).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. öffnen Sie den Knoten Kurzschlusserkennung

    Interne ID: Kurzschlussserkennung Auslösung

    Kurzschlusserkennung

    Enthält die Eigenschaften zur Fehlerortung von Kurzschlüssen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. für ungerichtete Kurzschlussmelder

      klicken Sie bei der Eigenschaft Auslösung auf die Schaltfläche ...

      wählen Sie im sich öffnenden Dialog die gewünschte Variable

      die Eigenschaften für die Richtung bleiben leer

    2. für gerichtete Kurzschlussmelder mit Auslösemeldung

      verknüpfen Sie die Variable mit der Auslösung und ergänzen Sie die entsprechend Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

    3. für gerichtete Kurzschlussmelder ohne Auslösemeldung

      verknüpfen Sie die Variable mit der entsprechenden Richtung:

      vorwärts: verknüpfen Sie eine Variable mit der Eigenschaft Vorwärts

      rückwärts: verknüpfen Sie eine Variable mit der Eigenschaft Rückwärts

      die Eigenschaft Auslösung bleibt leer


Kurzschlusssmeldung quittieren

Handbuch -> Energy Edition -> Automatic Line Coloring (ALC) - Topologie -> Fehlerortung in elektrischen Netzen -> Kurzschlusssuche -> Kurzschlusssmeldung quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion Kurzschlussmeldung quittieren kann zur Runtime ein intern erfasster Kurzschluss eines Kurzschlusserkennungsgeräts quittiert werden. Dabei wird der intern gelatchte Erdschlusszustand zurückgesetzt, wenn der Zustand noch ansteht, oder als quittiert markiert. Eine erfasste Kurzschlussmeldung wird intern nur gelöscht, wenn diese quittiert ist und nicht mehr ansteht.

Interne ID: Kurzschlusssmeldung quittieren

Kurzschlussmeldung quittieren

Funktion zum Quittieren einer Kurzschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Regeln beim Quittieren:

  • Wurde eine Variable verknüpft, die einer Auslösungs- oder Richtungsvariable eines Kurzschlusserkennungsgeräts entspricht, so wird nur diese spezielle Kurzschlussmeldung quittiert.
  • Wurde keine Variable verknüpft, werden alle Kurzschlussmeldungen quittiert.
  • Das Quittieren kann auch über das Objektmodell der zenon API erfolgen.

Um die Funktion Kurzschlussmeldung quittieren zu projektieren:

  • legen Sie eine neue Funktion an
  • navigieren Sie zum Knoten Fehlerortung in elektrischen Netzen
  • wählen Sie die Funktion Kurzschlussmeldung quittieren

  • wählen Sie im sich öffnenden Dialog die gewünschte Variable
  • verknüpfen Sie die Funktion mit einem Button


Befehlsgabe

Handbuch -> Energy Edition -> Befehlsgabe

Die Befehlsgabe dient primär zum gesicherten Schalten von Variablen in der Energietechnik. Gesichert heißt, dass überprüft wird ob die Schalthandlung aufgrund der projektierten Verriegelungsbedingung und der dynamisch aktualisierten Topologie (aktueller physikalischer Zustand des topologischen Netzwerks) erlaubt ist. Die Projektierung der Topologie und der Topologischen Verriegelungen erfolgt über die ALC (Automatic Line Coloring).

Eine Variable für die Befehlsgabe besteht im Regelfall immer aus 2 physikalischen Variablen: einer Rückmeldevariable, sowie einer Befehlsvariable. Abhängig von der auszuführenden Aktion, werden diese auf eine der beiden Variablen ausgeführt.

Example Beispiel

' Doppelbefehl Ein' : Setzt das Kommando beziehungsweise den neuen Wert auf die Befehlsvariable ab. Anhand der Rückmeldevariable erfolgt eine Überprüfung über den Erfolg der angestossenen Aktion.

Die Synchronisierung der Aktionen aus der Befehlsgabe erfolgt dabei über ein im Treiber laufzeitüberwachtes, zyklisch aktualisiertes Kommunikationsobjekt. Dieses Objekt wird automatisch der Rückmeldevariable zugeordnet. Eine Aktivierung eines solchen Objektes wird im System durch die Aktivierung des 'Select' Status ausgewertet.

'Statusvorgabe Aus' : Setzt alle aktiven Status der Rückmeldevariable zurück, die Befehlsvariable ist von dieser Aktion nicht betroffen.

Zweistufige Bedienhandlungen werden im Regelfall über ein Kontextmenü und dem Bildtyp „Befehlsgabe“ ausgeführt. Für diesen stehen spezifische Kontrollelemente zur Verfügung. Diese ermöglichen eine individuelle optische und funktionelle Gestaltung der Befehlsgabe. So können zum Beispiel individuelle Aktionen direkt auf Aktionsbuttons gelegt werden, diese Aktionen sind danach für den Bediener dirket anwählbar. Dieser Bildtyp beinhaltet außerdem alle nötigen Voraussetzungen um Funktionalitäten wie die Entriegelung, zweistufige Ausführung, Zweihandbedienung, Sperre, etc. zu realisieren. Der Aufruf eines solchen Bildes erfolgt dabei über eine Funktion, direkt am Element (anstatt des Sollwert setzen Dialoges) oder über ein Kontextmenü.

Aus den Befehlsgruppen und dem aktuellen Zustand des topologischen Modells ergibt sich während der Laufzeit, ob eine Aktion (Schalthandlung) zu einem bestimmten Zeitpunkt erlaubt ist (keine Verriegelungsbedingung anstehend), verboten ist (eine nicht entriegelbare Bedingung ansteht) oder nach Entriegelung (entriegelbare Verriegelung ansteht) ausgeführt werden darf.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Befehlsgabe neu | Legt eine neue Befehlsgabe an.
XML exportieren alle | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Maßeinheiten aus einer XML-Dateien.
Editorprofil | Öffnet die Dropdownliste zur Auswahl eines Editorprofils.
Hilfe | Öffnet die Online-Hilfe.

info Info

Verriegelungen können auf Verriegelungsebene exportiert, importiert und über die Zwischenablage ausgetauscht und dupliziert werden.

attention Achtung

Alle nachfolgend angeführten Funktionalitäten sind nur dann verfügbar, wenn die 'Energy Edition' lizenziert wurde.

Noch in diesem Kapitel

Befehlsgabe Detailansicht Symbolleiste und Kontextmenü

Projektieren im Editor

Bedienen zur Runtime


Befehlsgabe Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Energy Edition -> Befehlsgabe -> Befehlsgabe Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Befehlsgabe und Verriegelung

Menüpunkt | Aktion
Befehlsgruppe neu | Erstellt eine neue Verriegelung und öffnet den Dialog zur Auswahl der Variablen.
XML exportieren alle | Exportiert alle Einträge in XML-Datei.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Kopieren | Kopiert ausgewählte Bedingung.
Einfügen | Fügt Bedingung aus Zwischenablage ein.
Löschen | Löscht ausgewählte Bedingung.
Umbenennen | Ermöglicht das Umbenennen eines Elements.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Gruppe Aktionen

Menüpunkt | Aktion
Befehl neu | Legt einen neuen Befehl an und öffnet die Eigenschaften.
Sollwertvorgabe neu | Legt eine neue Sollwertvorgabel an und öffnet die Eigenschaften.
Statusvorgabe neu | Legt eine neue Statusvorgabe an und öffnet die Eigenschaften.
Ersetzen neu | Legt eine neue Ersetzung an und öffnet die Eigenschaften.
Freigeben neu | Legt eine neue Freigabe an und öffnet die Eigenschaften.
Nachführen neu | Legt eine neue Freigabe an und öffnet die Eigenschaften.
Blockieren neu | Legt eine neue Blockierung an und öffnet die Eigenschaften.
Sperre neu | Legt eine neue Sperre an und öffnet die Eigenschaften.
Revision neu | Legt eine neue Revision an und öffnet die Eigenschaften.
Einfügen | Fügt Bedingung aus der Zwischenablage ein.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü einzelne Aktion

Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Menüpunkt | Aktion
Bedingung hinzufügen | Legt eine neue Bedingung an.
Kopieren | Kopiert ausgewählte Bedingung.
Einfügen | Fügt Bedingung aus Zwischenablage ein.
Löschen | Löscht ausgewählte Bedingung.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Bedingung

Menüpunkt | Aktion
Kopieren | Kopiert ausgewählte Bedingung.
Einfügen | Fügt Bedingung aus Zwischenablage ein.
Löschen | Löscht ausgewählte Bedingung.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Gruppe Variablen

Menüpunkt | Aktion
Variable hinzufügen | Öffnet Dialog zur Auswahl einer Variablen
Einfügen | Fügt Bedingung aus Zwischenablage ein.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü einzelne Variable

Menüpunkt | Aktion
Verknüpfte Elemente | Öffnet Dropdownliste mit verknüpften Elementen.
Kopieren | Kopiert ausgewählte Variable
Einfügen | Fügt Variable aus Zwischenablage ein.
Löschen | Löscht ausgewählte Variable.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Öffnet die Online-Hilfe.


Projektieren im Editor

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wie Sie eine Befehlsgabe Schritt für Schritt projektieren und ausführen, erfahren Sie im Tutorial Befehlsgabe.

info Info

Verwenden Sie auch für Tests nach Möglichkeit den IEC-60870 101/104 Treiber. Dieser Treiber unterstützt im vollen Umfang die Auswertung des COT (Cause of Transmission). Dabei handelt es sich um eine erweiterte Funktionalität zur Kommunikationsüberwachung. Eine Auswertung dieser Kommunikationsstatus kann in den Reaktionsmatrixen Multi-Numerisch und Multi-Binär erfolgen.

Noch in diesem Kapitel

Bild vom Typ Befehlsgabe anlegen

Grenzwerte und Reaktionsmatrizen für Schaltrichtungstexte

Variablen anlegen

Befehlsgabe definieren

Menü erzeugen

Import und Export

Runtime Dateien erzeugen - Starten der Runtime


Bild vom Typ Befehlsgabe anlegen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Bild vom Typ Befehlsgabe anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Anlegen des Befehlsgabe-Bildes im Editor erfolgt durch Definition eines neuen Bildes vom Typ Befehlsgabe. Nähere Informationen zu den vordefinierten Bildtypen finden Sie im Handbuch Bilder/Vordefinierte Bildtypen.

Das Bild 'Befehlsgabe' wird für die Benutzerinteraktion mittels Befehlsgabe während der Runtime verwendet (ein- und zweistufige Befehlsgabe). Es ermöglicht dem Bediener, die zur Befehlsausführung notwendigen Aktivitäten durchzuführen. Dies kann z.B. das Entriegeln einer anstehenden Befehlsgruppe oder die Bestätigung der Ausführung bei einer zweistufigen Befehlsgabe sein.

info Info

Bei der Verwendung der Einstufigen Befehlsgabe, kann auch ein Kontextmenü oder eine Standard Funktion verwendet werden. Der Bildtyp Befehlsgabe wird dann nicht im Projekt benötigt.

Bei diesem Bildtyp stehen spezifische Kontrollelemente zur Verfügung, welche die für die Befehlsgabe notwendige Bedienhandlungen ermöglichen und aktuelle Informationen über den Zustand der auszuführenden Aktion visualisieren. (z.B. Anzeige der Schaltrichtung)

Nach dem Öffnen des Bildes wird ein leeres Bild aufgeschaltet. Die Standard-Kontrollelemente erstellen Sie über das Menü Kontrollelemente/Vorlage einfügen.

info Info

Unter den Gruppen finden Sie eine Zusammenstellung von Kontrollelementen die Sie für spezifische Aktionen benötigen. z.B. alle Kontrollelemente zum Sperren eines Elementes. Sie sparen sich das manuelle zusammen suchen der Kontrollelemente.


Grenzwerte und Reaktionsmatrizen für Schaltrichtungstexte

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Grenzwerte und Reaktionsmatrizen für Schaltrichtungstexte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der ersten Stufe der zweistufigen Befehlsgabe werden für Aktionen vom Typ 'Befehl' Benutzer definierbare Schaltrichtungstexte (z.B. im Kontextmenü) angezeigt. Diese Texte können über die Grenzwerte oder die Reaktionsmatrizen -Zustände definiert werden.

Diese Texte ermöglichen dem Benutzer ein besseres Verständnis beziehungsweise einen besseren Überblick über die in der Runtime zur Verfügung stehenden Aktionen (z.B. 'Befehl: Trenner öffnen')

Damit haben Sie zusätzlich die Möglichkeit, unterschiedliche Texte für jede Variable, die die gleiche Verriegelung verwendet, zu vergeben, ohne dass Sie dafür Anpassungen an der Bedienoberfläche vornehmen müssen.

info Info

Durch das Auslesen der Schaltrichtungstexte aus den Grenzwerteinstellungen, sind diese Texte natürlich auch voll sprachumschaltbar.

Standardtexte für Schaltrichtung

Grenzwert | Standardtext
Aus | @OFF
Ein | @ON
Diff | @INTER
Stör | @FAULT
Keine | @NONE
Direkt | @DIR


Variablen anlegen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Variablen anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen müssen zum einen mit 'Schaltrichtungstexten' und zum anderen mit den zugehörigen 'Befehlsgruppen' verknüpft werden. Wurde eine der beiden Einstellungen nicht vorgenommen, werden in der Runtime keine Aktionen zur Auswahl angeboten.

info Info

Durch die unterschiedliche Verwendung von Grenzwerten / Reaktionsmatrizen für die Befehls-/Rückmeldevariable, können individuelle Schaltrichtungstexte für die Aktionen angezeigt werden. Immer abhängig davon, auf welche der Variablen die auszuführende Aktion ausgeführt wird.

Noch in diesem Kapitel

Projektübergreifende Variablen


Projektübergreifende Variablen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Variablen anlegen -> Projektübergreifende Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

attention Achtung

Für die Funktionalitäten der Befehlsgabe wird vorausgesetzt, dass die in den Befehlsgruppen verwendeten Variablen sich im gleichen Projekt befinden.

Wird dennoch eine Variable aus einem anderen Projekt verwendet (z.B. untergeordnetes Projekt in der Mehrprojektverwaltung), werden die Befehlsgruppe, die Rückmeldevariable, die Aktionsvariable und das Aktionsspezifisches Bild (vom Bildtyp 'Befehlsgabe') auch in diesem anderen Projekt erwartet.

info Info

Für die Verriegelungen durch den Prozess können allerdings auch projektübergreifende Variablen verwendet werden. Die oben genannte Einschränkungen gilt nur für Variablen der Befehlsgruppe.


Befehlsgabe definieren

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wählen Sie im Projektbaum den Eintrag Befehlsgabe und öffnen Sie das Kontextmenü. Wählen Sie Befehlsgruppe neu.

Nach Anlegen einer neuen Befehlsgruppe wird diese in der Detailansicht des Projektmanagers mit dem Standardnamen „Befehlsgruppe + Index “ eingefügt. Der Index wird durch eine fortlaufende Nummer ersetzt. Dieser Name dient im System zur eindeutigen Identifizierung der Verriegelung.

info Info

Die Namen für die Befehlsgruppen können völlig frei vergeben werden. Allerdings ist darauf zu achten, dass diese im Projekt eindeutig sein müssen (gilt für Allgemeine Verriegelungen und Befehlsgruppen).

Für die Befehlsgruppen stehen folgende Parameter zur Verfügung:

Parameter

Beschreibung

Name

Interne ID: Befehlsgabe definieren

Name

Eindeutiger Name der Verriegelung oder Befehlsgabe.
Default: Verriegelung/Befehlsgruppe x (wobei x eine fortlaufende Zahl ist).
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch zum Erstellen einer:

- Verriegelung

- Befehlsgabe

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Benennung der Befehlsgruppe. Muss eindeutig über alle Verriegelungen im Projekt sein. Dieser Name wird später dann bei der Variable, die diese Verriegelung verwendet, angezeigt. Die eigentliche Zuordnung erfolgt jedoch über eine eindeutige, fortlaufend numerische ID. Der Name ist nur für die GUI, Export und Import.

Variablenname der Rückmeldung

Interne ID: Befehlsgabe definieren

Variablenname der Rückmeldung

Variablenname bzw. die Maske für das Ersetzen der Rückmeldevariable.
Ein im Namen vorkommendes Sternchen (*) dient als Platzhalter für den Ersetzungstext. Es kann nur ein Platzhalter im Namen verwendet werden. Bei der Eingabe der Maske ist darauf bedacht zu nehmen, dass dieser Name bei der Ersetzung auch einen vorhandenen Variablennamen ergibt.
Wenn die hier verwendete Variable (ersetzt oder absolut) zum Zeitpunkt des Erzeugens der Runtime Dateien nicht vorhanden ist, steht diese Befehlsgruppe in der Runtime nicht zur Verfügung. Eine entsprechende Meldung weist beim Erzeugen von Runtime Dateien auf diesen Fehler hin.
Direkte Eingabe oder öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hier ist der Variablenname bzw. die Maske für die Ersetzung der Rückmeldevariable abzulegen.

Ein im Namen vorkommender ‚*’ dient als Platzhalter für den Ersetzungstext. Es kann nur ein Platzhalter im Namen verwendet werden. Bei der Eingabe der Maske ist darauf bedacht zu nehmen, dass dieser Name bei der Ersetzung auch einen vorhandenen Variablennamen ergibt.

Wenn die hier verwendete Variable (ersetzt oder absolut) zum Zeitpunkt der Kompilierung nicht vorhanden ist, steht diese Befehlsgruppe in der RT nicht zur Verfügung. Eine entsprechende Meldung weist beim Kompilieren auf diesen Fehler hin.

Set status PROGRESS

Interne ID: Befehlsgabe definieren

Set status PROGRESS

Aktiv: Bei den Aktionen Befehl und Nachführen wird das Statusbit In Bearbeitung (PROGRESS) bei der Rückmeldevariable gesetzt, wenn die Aktionen in der Runtime angestoßen werden.
Das Bit dient dazu eine grafische Anzeige zu realisieren, um dem Benutzer anzuzeigen, dass gerade eine Aktion ausgeführt wird. Mit Hilfe eines Combielements oder einer Reaktionsmatrix können Sie das Statusbit abfragen und eine grafische Anzeige umsetzen.

Inaktiv: Das Statusbit wird nicht gesetzt.

Default: inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wenn aktiviert, dann wird bei den Aktionen Befehl und Nachführen das Statusbit In Bearbeitung (PROGRESS) beschrieben. Der Wert auf welchem das Statusbit gesetzt wird, hängt von der Schaltrichtung der Aktion ab.

Das Statusbit wird auf 1 gesetzt wenn:

  • Die Rückmeldezustand/Schaltrichtung der Aktion EIN oder AUS ist.

    Interne ID: Befehlsgabe definieren

    Rückmeldezustand/Schaltrichtung

    Nicht verfügbar bei den Aktionen: Blockieren, Sperre und Freigeben.
    Definiert den erwarteten Wert bzw. Status der Rückmeldevariable nach Aktionsausführung. Die möglichen Eingaben unterscheiden sich je nach Aktion .
    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Die Rückmeldevariable nicht bereits den Wert der eingestellten Schaltrichtung hat.

Das Statusbit wird bei der Prüfung der Verriegelungen gesetzt und bleibt auf den Wert bis das Bild wieder in Stufe 1 zurückkehrt bzw. geschlossen wird.
Das impliziert auch, dass der Status während die Laufzeitüberwachung und/oder Flankenverzögerung aktiv ist, gesetzt bleibt.

Wir die Ausführung der Aktion durch ein Kontextmenü angestoßen oder ist die Aktion einstufig, wird das Statusbit entsprechend gesetzt.

Laufzeitüberwachung

Interne ID: Befehlsgabe definieren

Laufzeitüberwachung

Bestimmt Ablauf der Laufzeitüberwachung.

  • keine: Keine Laufzeitüberwachung.
  • über Rückmeldevariable: Der Wert der Rückmeldevariable wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.
  • über Übertragungsursache: COT (Cause of Transmission) wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.
    Für die Aktion 'Befehl' werden die Status für die Übertragungsursache (Cause of Transmission=COT) ausgewertet.
    Wird innerhalb des bei der Aktion projektierten Timeout der COT-Ablauf nicht erfolgreich beendet, wird das Statusbit TIMEOUT gesetzt. Die Überwachung wird nur aktiviert, wenn der zu schreibende Wert ungleich dem aktuellen Wert der Aktionsvariable ist.

    Interne ID: Befehlsgabe definieren

    Timeout

    Nur verfügbar bei den Aktionen 'Befehl' und 'Sollwertvorgabe':
    Für die Laufzeitüberwachung verwendetes Timeout in Sekunden.
    Minimum: 0.
    Maximum: 4294967295.
    Default: 30.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: keine.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Es gibt folgende Einstellung für diese Dropdownliste:

  • keine: Die Laufzeitüberwachung ist deaktiviert.
  • über Rückmeldevariable: Der Wert der Rückmeldevariable wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.
  • über Übertragungsursache: Laufzeitüberwachung in ihrer ursprünglichen Form. Cause of Transmission (COT) wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.

Bild modal

Interne ID: Befehlsgabe definieren

Bild modal

Aktiv: Unabhängig von der Eigenschaft 'Modaler Dialog' des Bildes wird das Befehlsbild modal aufgeschalten. D.h. andere Bilder sind erst wieder bedienbar, nachdem das Bild geschlossen wurde.
Inaktiv: Das Befehlsbild wird normal aufgeschalten.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wenn aktiviert dann wird das Bild unabhängig der gewählten Einstellung „Modaler Dialog“ beim Bild, modal angezeigt.

Bildtitel aus Rückmeldevariable

Interne ID: Befehlsgabe definieren

Bildtitel aus Rückmeldevariable

Aktiv: Die Kennung der Rückmeldeariable wird als Bildtitel verwendet.
Inaktiv: Der Name des Bildes wird als Bildtitel verwendet.
Default: inaktiv.
Achtung: Zur Aktivierung des Bildtitels muss zusätzlich in der entsprechenden Schablone die Eigenschaft Titel aktiviert werden.

Interne ID: Befehlsgabe definieren

Titel

Nur verfügbar, wenn ein Rahmen für die Schablone ausgewählt ist:
Aktiv: Windows-Titelleisten für die Bilder dieser Schablone verwenden. Die Bilder können in der Runtime verschoben werden.
Inaktiv: Keine Titelleiste verwenden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Kennung der Rückmeldevariable wird im Bildtitel angezeigt. Dies erfolgt nur wenn das Bild auch einen Titel bei der Schablone projektiert hat.

Text ist Online sprachübersetzbar.

Befehlsbild

Interne ID: Befehlsgabe definieren

Befehlsbild

Name des zu öffnenden Bildes, wenn kein aktionsspezifisches Bild definiert ist und das Bild nicht über die Funktion Bildumschaltung geöffnet wird.

Hinweis: Wird die Befehlsgabe durch ein Sollwertsetzen beim Element initiiert, muss hier ein Bild verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Name des aufzuschaltenden Bildes wenn kein aktionspezifisches Bild definiert ist und nicht über die Funktion „Bild direkt“ das Bild geöffnet wird.

Schalterfallerkennung

Interne ID: Befehlsgabe definieren

Schalterfallerkennung

Steht nur zur Verfügung, wenn die Eigenschaft Set status PROGRESS aktiviert ist.

Aktiv: Überwacht Rückmeldevariable auf unerwarteten Wertwechsel von <> 0 auf 0.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Steht nur zur Verfügung, wenn die Eigenschaft Set status PROGRESS aktiviert ist.

Aktiv: Rückmeldevariable wird auf unerwarteten Wertwechsel von <> 0 auf 0 überwacht

Bei aktiver Erkennung werden alle Variablen, deren Status oder Wert in der Formel für die Schalterfallerkennung verwendet wird, beim Programmstart nach dem Laden aller Projekte zum Lesen aktiviert und bleiben dies die gesamte Runtime-Laufzeit. Damit können Variablen aller zur Runtime geladenen Projekte verwendet werden, unabhängig von der Ladereihenfolge.

Erkennungsunterdrückung

Interne ID: Befehlsgabe definieren

Erkennungsunterdrückung

Eingabe der Formel, mit der die Erkennung eines Schalterfalls unterdrückt wird. Klick auf die Schaltfläche ... öffnet den Formeleditor.

Für die Formel können alle Variablen der Verriegelung verwendet werden, Namensersetzungen wie bei der Definition der Verriegelungsbedingungen einer Aktion sind möglich.

Hinweis: Variablen, die in der Formel verwendet werden, können bei der Verriegelung nicht gelöscht werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eingabe der Formel, mit der die Erkennung eines Schalterfalls unterdrückt wird. Klick auf die Schaltfläche ... öffnet Formeleditor.

Für die Formel können alle Variablen der Verriegelung verwendet werden, Namensersetzungen wie bei der Definition der Verriegelungsbedingungen einer Aktion sind möglich.

Hinweis: Variablen, die in der Formel verwendet werden, können bei der Verriegelung nicht gelöscht werden.

Noch in diesem Kapitel

Aktionen

Befehls Bedingungen


Aktionen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Befehlsgruppen beinhalten immer einen Satz an vordefinierten Aktionen, welche im Regelfall auf eine spezifische Variable (ein spezifisches Gerät) angepasst sind. So können zum Beispiel unterschiedliche Befehlsgruppen für verschiedene topologische Elemente (Schalter / Trenner etc.) individuell und zentral definiert werden.

Jeder Aktion innerhalb einer Befehlsgruppe wird eine definierte Befehlsvariable zugewiesen. Die Rückmeldevariable wird zentral für die gesamte Befehlsgruppe definiert.

Namensersetzung

Um die Defintion der Variablen zu vereinfachen bzw. zu verallgemeinern, können diese Variablenbezüge (für Befehls- und Rückmeldevariable) über eine Namensersetzung definiert werden. Dabei können Wildcards verwendet werden. (Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.) Durch diese flexible Definition können allgemein gültige Verriegelungsbedingungen sehr einfach definiert werden. Damit wird auch die Zahl der zu definierenden Befehlsgruppe deutlich reduziert.

Example Beispiel
  • Defintion der Befehlsvariablen '*_BE'
  • Definition der Rückmeldevariablen '*_RM'

Die Befehlsgabe ergänzt zur Laufzeit automatisch den Namen der Befehlsvariable um den Namen der Rückmeldevariable, die im Prozessbild angezeigt/angewählt wird. Beide Variablen unterscheiden sich im Namen nur durch deren Endung.

Aktionstypen

Die Aktionstypen sind die zur Verfügung stehenden Schaltbefehle. Je nach Befehl werden unterschiedliche Aktivitäten ausgeführt.

Im System steht eine Vielzahl von Aktionen zur Verfügung. Folgende Aktionstypen können für Befehlsgruppen definiert werden:

Aktionstyp

Anmerkung
  • Befehl

  • Sollwertvorgabe

  • Statusvorgabe

  • Freigeben

Kann pro Befehlsgruppe nur einmal projektiert werden.
  • Nachführen

  • Ersetzen

  • Sperre

Kann pro Befehlsgruppe nur einmal projektiert werden.
  • Revision

  • Blockieren

Kann pro Befehlsgruppe nur einmal projektiert werden.

In der Detailansicht der Befehlsgabe werden die Aktionen im Baum mit der jeweils gewählten Schaltrichtung und bei direktem Sollwertsetzen mit dem gewählten Sollwert angezeigt.

attention Achtung

Die Bezeichnung der Aktionstypen in der Eigenschaft Menü ID muss eindeutig sein, damit sie im Kontextmenü eindeutig identifizierbar sind. Verfügen zwei Aktionen über die gleiche ID, werden Sie im Aktionsbaum mit einem speziellen Symbol M markiert.

Interne ID: Aktionen

Menü ID

Eindeutige ID der Aktion. Die Menü ID wird für die Erstellung von Kontextmenüs zur Runtime verwendet. Werden zwei Aktionen mit der gleichen ID ausgestattet, werden sie im Aktionsbaum mit einem speziellen Symbol markiert.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktionstyp Befehl

Dieser wird im System je nach Befehlstyp als 'Einzelbefehl' oder 'Doppelbefehl' verwendet.

Bei Ausführung des Befehls wird der projektierte 'Befehlsgabezustand ( 0 oder 1) auf die Befehlsvariable geschrieben. Welcher Wert bei der Rückmeldevariable aufgrund des Befehls erwartet wird, ist bei der Eigenschaft Rückmeldezustand/Schaltrichtung '(Ein/Aus/keine)' zu definieren.

Interne ID: Aktionen

Rückmeldezustand/Schaltrichtung

Nicht verfügbar bei den Aktionen: Blockieren, Sperre und Freigeben.
Definiert den erwarteten Wert bzw. Status der Rückmeldevariable nach Aktionsausführung. Die möglichen Eingaben unterscheiden sich je nach Aktion .
Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schaltrichtung | Wert der Rückmeldevariable
Keine | Wird sich nicht ändern
Aus | Wert wird 0 sein
Ein | Wert wird 1 sein

Bei Einzelbefehlen erfolgt ein automatisches Rücksetzen auf 0 oder 1 (abhängig von der Schaltrichtung) nach der projektierten 'Flankenverzögerung'. Dies unterbleibt, wenn bei der Befehlsvariable SBO aktiviert wurde.

info Info

Ist bei Aktionsausführung der aktuelle Wert der Rückmeldevariable unterschiedlich zu dem in der Schaltrichtung eingestellten Wert bzw. wurde die Schaltrichtung Ein oder Aus definiert, wird das Statusbit In Bearbeitung ( PROGRESS ) gesetzt.

Aktionstyp Sollwertvorgabe

Bietet die Möglichkeit, einen beliebigen numerischen Wert auf die selektierte Befehlsvariable zu schreiben. Das Befehlsgabefenster bietet dazu eigene Kontrollelemente an, die eine Vorgabe des Sollwertes ermöglichen. Mit der Eigenschaft Rückmeldezustand/Schaltrichtung wird definiert, wie der Sollwert gesetzt werden soll:

Schaltrichtung

Wert der Rückmeldevariable

DIR

Sollwert wird direkt gesetzt. Der abzusetzende Wert wird über die Eigenschaft Sollwert festgelegt.

Interne ID: Aktionen

Sollwert

Nur verfügbar, wenn Eigenschaft Rückmeldezustand/Schaltrichtung auf DIR gesetzt wurde.

Definiert den abzusetzenden Sollwert.

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der auszugebende Text kann über einen Grenzwert/ein Rema für den Zustand/Wert 5 projektiert werden. Ist das nicht der Fall, wird ein Standardtext verwendet.

Soll/Ist-Vergleich wird nicht unterstützt. Der Aktionsbutton einer Aktion, deren Wert dem Istwert entspricht, ist nicht gesperrt. Die Aktion kann mehrfach hintereinander ausgeführt werden.

Sollwert

Wert vom Kontrollelement Sollwert wird auf die Rückmeldevariable geschrieben.

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Interne ID: Aktionen

SW setzen aktiv

Aktiv: Diese Variable für "Sollwert setzen" Aktionen freigeben.
Inaktiv: Diese Variable ist schreibgeschützt.
Default: aktiv

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Beim direkten Sollwert Setzen werden weder die Grenzen der verknüpften Variablen überprüft, noch, ob das Sollwert Setzen für diese Variable generell zulässig ist.

Aktionstyp Statusvorgabe

Je nach Definition der 'Schaltrichtung' wird folgendes ausgeführt:

Schaltrichtung | Aktion
Aus | Die in der Liste 'Modifizierbare Status' projektierten Status werden alle auf 0 zurückgesetzt.
Ein | Die in der Liste 'Modifizierbare Status' projektierten Status werden alle auf 1 (aktiv) gesetzt.
Keine | Die in der Liste 'Modifizierbare Status' projektierten Status müssen in der RT über das Kontroll Element „Status setzen“ definiert werden. Jeder Status wird individuell definiert.

Verändern Sie in der Runtime einen Status, so wird die Änderung in der Chronologischen Ereignisliste mitprotokolliert (Status inklusive Wert). Sie haben die Möglichkeit, dies in der Runtime sprachumschaltbar zu machen.

info Info

Bei allen Statusvorgaben erfolgt immer ein Beschreiben der Rückmeldevariable.

Aktionstyp Freigeben

Hinweis: Die Aktion kann zur Runtime nur ausgeführt werden, wenn bei der selektierten Rückmeldevariable das Statusbit Ersatzwert ( ALT_VAL ) aktiv ist (Wert: 1).

Die Aktion Freigeben setzt das Statusbit Ersatzwert ( ALT_VAL ) auf 0 (inaktiv) zurück. Ist auch das Statusbit Abgeschaltet ( OFF ) aktiv, wird es ebenfalls auf 0 (inaktiv) gesetzt. Nach Ausführung der Aktion Freigeben empfängt die Runtime den aktuellen Wert vom Treiber für die Rückmeldevariable.

Hinweis: Dieser Aktionstyp kann pro Befehlsgruppe nur einmal projektiert werden.

Aktionstyp Nachführen

info Info

Handnachführung bedeutet:

Nachführen eines nicht ferngemeldeten Schalters in zenon.

Nachgeführt wird üblicherweise auf eine Merker-Variable (ohne Prozessbezug). Bei einer Merker-Variablen sollte eigentlich nie ein I-Bit anstehen. Eine Variable mit Prozessbezug nachzuführen, ist nicht sinnvoll, aber möglich.

Verhalten:

Aus Sicht des Treibers ist Nachführen ein ganz normales Sollwertsetzen.

Gegensatz dazu: Ersetzen

Der Prozesswert eines ferngemeldeten Schalters wird temporär (z.B. wegen Revision, ...) durch einen Ersatzwert ausgetauscht.

Der Aktionstyp Nachführen setzt den Wert der selektierten Rückmeldevariable entsprechend der Einstellung der Schaltrichtung:

Schaltrichtung

Aktion

Aus

0

Diff

2

DIR

Sollwert wird direkt gesetzt. Der abzusetzende Wert wird über die Eigenschaft Sollwert festgelegt.

Der auszugebende Text kann über einen Grenzwert/ein Rema für den Zustand/Wert 5 projektiert werden. Ist das nicht der Fall, wird ein Standardtext verwendet.

Soll/Ist-Vergleich wird nicht unterstützt. Der Aktionsbutton einer Aktion, deren Wert dem Istwert entspricht, ist nicht gesperrt. Die Aktion kann mehrfach hintereinander ausgeführt werden.

Ein

1

Sollwert

Wert vom Kontrollelement Sollwert wird auf die Rückmeldevariable geschrieben.

Stör

3

attention Achtung

Beim direkten Sollwert Setzen werden weder die Grenzen der verknüpften Variablen überprüft, noch, ob das Sollwert Setzen für diese Variable generell zulässig ist.

info Info

Das Statusbit In Bearbeitung (PROGRESS) wird gesetzt, wenn:

  • bei Aktionsausführung der aktuelle Wert der Rückmeldevariable unterschiedlich zu dem in der Schaltrichtung eingestellten Wert ist
    und
  • die Schaltrichtung Ein oder Aus definiert wurde

Aktionstyp Ersetzen

Die Rückmeldevariable wird auf den Status Ersatzwert ( ALT_VAL ) gesetzt. Zusätzlich wird der durch die 'Schaltrichtung' definierte Wert auf die Rückmeldevariable abgesetzt.

Schaltrichtung | Status
Aus | 0
Ein | 1
Diff | 2
Stör | 3
Keine | 4

Aktionstyp Sperre

Ermöglicht das Sperren einer Rückmeldevariable für die Aktionen der Befehlsgabe.

info Info

Wird über die Aktion Sperre ein Switch gesperrt, wird das Statusbit M1 gesetzt.

Voraussetzung dazu sind im System vorhandene Benutzer, welche über einen projektierten 'Sperrcode' verfügen. Ein Sperren bzw. Entsperren einer Rückmeldevariable kann nur über die korrekte Eingabe eines 'Sperrcodes' erfolgen.

Dabei kann dieselbe Variable auch von mehreren Benutzern parallel gesperrt werden. Aktionen für die Rückmeldevariable sind erst wieder möglich, wenn alle Sperren durch Eingabe des Sperrcodes aufgehoben wurden.

Es können keine Aktionen ausgeführt werden, wenn

  • die gesperrte Variable als Aktionsvariable verwendet wird
  • Aktionen der Befehlsvariablen die gesperrte Variable als Rückmeldevariable verwenden

Der Sperrcode kann für jeden Benutzer individuell definiert werden. Diese Parametrierung erfolgt direkt bei einem bereits definierten Benutzer mittels der Eigenschaft 'Sperrcode'.

Die Einstellung des Sperrcodes kann auch zur Laufzeit, Online für einen bestehenden Benutzer vorgenommen werden.

Zur Laufzeit können Benutzer, welche noch über eine aktive Befehlssperre verfügen, nicht gelöscht werden.

attention Achtung

Benutzer können sehr wohl über die Entwicklungsumgebung gelöscht werden. Dies hat zur Folge, dass beim Neustart oder Nachladen die definierten Sperren verloren gehen.

In der Verwaltung gesperrte (deaktivierte) Benutzer können keine Befehlssperre aktivieren oder deaktivieren.

info Info

Informationen über aktive Sperren werden auch im redundanten Netzwerk abgeglichen und stehen daher nach einem Server Wechsle zur Verfügung.

Über ein eigenes Kontrollelement ('Sperrliste') kann eine Liste der aktuellen Sperren im Befehlsgabebild angezeigt werden.

Hinweis: Dieser Aktionstyp kann pro Befehlsgruppe nur einmal projektiert werden.

Aktionstyp Revision

Setzt das Statusbit Revision der Rückmeldevariable auf den bei Rückmeldezustand/Schaltrichtung projektierten Wert.

Schaltrichtung | Status
Aus | Setzen auf 0
Ein | Setzen auf 1

Aktionstyp Blockieren

Durch Ausführen dieser Aktion wird die Rückmeldevariable abgeschalten.

Setzt das Statusbit OFF der Rückmeldevariable.

Hinweis: Dieser Aktionstyp kann pro Befehlsgruppe nur einmal projektiert werden.

Noch in diesem Kapitel

Aktion erzeugen

Aktionen ausführen


Aktion erzeugen

Aktion erzeugen

Aktionen definieren die für die Befehlsgruppen möglichen Schaltbefehle. Durch selektieren des Elementes 'Aktion' in der Detailansicht der Befehlsgruppe, kann mittels der rechten Maustaste eine neue Aktion definiert werden. Details zu den definierten Aktionen werden nach Anlegen auch in der Detailansicht angezeigt (z.B. 'Doppelbefehl: *_BE [EIN,1].

Die weiteren Einstellungen für die Aktionen erfolgen danach im Eigenschaftenfenster. Dabei sind einzelne Eigenschaften, abhängig vom Aktionstyp, inaktiv.

Zur Verfügung stehende Eigenschaften:

Eigenschaft

Beschreibung

Variable

Variable, auf die geschrieben wird. Bei manchen Aktionen ist dies die Rückmeldevariable. In diesem Falle ist das Feld gesperrt.

Ein im Namen vorkommender ‚*’ dient als Platzhalter für den Ersetzungstext. Es kann nur ein Platzhalter im Namen verwendet werden.

Wenn die hier verwendete Variable (ersetzt oder absolut) zum Zeitpunkt der Kompilierung nicht vorhanden ist, steht diese Aktion in der RT nicht zur Verfügung. Eine entsprechende Meldung weist beim Kompilieren auf diesen Fehler hin.

Initialisierung: Keine Zuordnung

Typ

Legt den Typ vom Befehl fest. Mögliche Einstellungen sind Einzel- oder Doppelbefehl.

Doppelbefehl

Schreibt den Wert der Einstellung „Befehlsgabezustand“.

Einzelbefehl:

Wie Doppelbefehl jedoch wird automatisch nach der Flankenverzögerung ein erneutes Schreiben mit dem Wert 0 ausgeführt. Dieses Schreiben ist nicht mehr Laufzeitüberwacht.

Bei allen anderen Aktionen gesperrt.

Initialisierung: Einzelbefehl

Schaltrichtung

Definiert den erwarteten Wert bzw. Status der Rückmeldevariable nach Aktionsausführung.

Bei den Aktionen Blockieren, Sollwert, Sperre und Freigeben gesperrt.

Initialisierung: Aus

Befehsgabezustand

Definiert den Wert, welcher bei der Aktion „Befehl“ als Wert auf die Befehlsvariable geschrieben wird.

Bei allen Aktionen außer „Einzelbefehl“ und „Doppelbefehl“ gesperrt.

Initialisierung: 0

CEL Eintrag unterdrücken

Wenn aktiv dann wird bei Aktionsausführung kein Eintrag in der CEL erstellt.

Initialisierung: Inaktiv

Timeout

Für die Laufzeitüberwachung verwendetes Timeout. Ist nur bei den Aktionen Befehl und Sollwertvorgabe verfügbar. Maßeinheit sind Sekunden

Initialisierung: 30

Flankenverzögerung

Zeit in Millisekunden welche bei einem Einzelbefehl das Schreiben von 0 verzögert wird.

Nur bei der Aktion „Einzelbefehl“ freigegeben.

Es wird nicht gewartet bis die Laufzeitüberwachung beendet ist.

Initialisierung: 1000 ms

Modifizierbare Status

Liste der mittels der Aktion „Status setzen“ veränderbaren Status.

Nur bei der Aktion „Statusvorgabe“ freigegeben.

Initialisierung: Keine Modifizierbar

Soll / Ist Vergleich

Wenn aktiviert, dann wird geprüft ob der Wert der Rückmeldevariable bereits der Schaltrichtung entspricht. Wenn ja, wird eine entriegelbare Verriegelungsmeldung angezeigt.

Initialisierung: Inaktiv

Menü spez. Bild

Bild vom Typ „Power“ welches bei der Aktivierung der Aktion über das Kontextmenü vom Element aktiviert wird. Wenn kein Bild eingetragen ist, wird das Bild, welches bei der Befehlsgruppe eingetragen ist, verwendet. Ein projektiertes, jedoch nicht vorhandenes Bild erzeugt eine Fehlermeldung beim Kompilieren und die Aktion wird nicht übernommen.

Initialisierung: Keine Zuordnung

Befehlsbutton

Zuordnung der Aktion zu einem Aktionsbutton im Bild definiert bei der Befehlsgruppe. Wenn die Befehlsgruppe mit einem anderen Bild verwendet wird (z.B. über Funktion) bleibt trotzdem die Zuordnung zu dem Aktionsbutton bestehen. Mit anderen Worten die Aktion wird immer auf den Button mit der zugeordneten Aktions-ID gelegt. Fehlt ein solcher, ist diese Aktion im Bild nicht verfügbar. In der Auswahlliste werden nur die noch nicht zugeordneten Aktionsbuttons angeboten.

Diese Einstellung ist gesperrt wenn bei der Befehlsgruppe kein Bild zugeordnet wurde oder bei dem Aktionstyp „Sperre“.

Initialisierung: Keine Zuordnung

Automatisch schließen

Wenn aktiv dann wird das Bild nach Ausführung der Aktion automatisch geschlossen.

Initialisierung: Inaktiv

Zweihandbedienung

Wenn aktiv dann wird das Control „Ausführen 2“ nur freigegeben wenn die Taste „Strg“ gehalten wird.

Ist gesperrt wenn keine zweistufige Ausführung.

Initialisierung: Inaktiv

Zweistufig

Wenn aktiv wird erst nach Betätigung des Controls „Ausführen 2“ die Aktion ausgeführt. Wenn nicht aktiv dann wird die Aktion nach entriegeln der letzten Verriegelung bzw. wenn keine Verriegelung ansteht sofort ausgeführt.

Bei Aktion „Sperre“ gesperrt.

Initialisierung: Aktiv

info Info

Durch Selektieren einzelner Eigenschaften erhalten Sie in der Embedded Help zusätzliche Informationen zur Funktionalität angezeigt.

info Info

Einmal definierte Aktionen und Befehls Bedingungen können in XML exportiert / importiert werden. Damit können Sie sehr einfach archiviert oder in anderen Applikationen wieder verwendet werden.

info Info

Der Status kann über den Befehl Statusvorgabe gesetzt werden.


Aktionen ausführen

Aktionen ausführen

Die Befehlsgabe in der Energy Edition kann an mehreren Stellen genutzt werden. Dem Anwender bleibt dabei überlassen welche Variante er einsetzen möchte. Auch gleichzeitige (Element bezogene) Verwendung der unterschieldichen Verwendungsarten ist jederzeit möglich.

1

Aufruf über eine Funktion Bildumschaltung auf ein Bild vom Typ Befehlsgabe.

2

Aufruf über Bildelement vom Typ Bargraf, Uhr, Universal Regler, Zahlenwert, Zeigerinstrument oder Zustandselement.

Zur Aktivierung muss die Element-Eigenschaft Sollwert setzen über den Wert Befehlsgabe haben.

3

Aufruf über Bildelement vom Typ Bargraf, Uhr, Universal Regler, Zahlenwert, Zeigerinstrument oder Zustandselement.

Zur Aktivierung muss die Element-Eigenschaft Sollwert setzen über den Wert Eingabemaske oder Element haben(z.B. Befehlsgabe als Ersatz für das Sollwert setzen).

4

Aufruf über ein Kontextmenü wenn die Eigenschaft Aktionstyp den Wert Befehlsgabe hat.

5

Aufruf über ein Kontextmenü wenn die Eigenschaft Aktionstyp den Wert Sollwert hat.

Noch in diesem Kapitel

Bildumschaltung auf Bild Befehlsgabe

Bildelement Befehlsgabe

Bildelement Sollwert

Kontextmenü Befehlsgabe

Kontextmenü Sollwert


Bildumschaltung auf Bild Befehlsgabe

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Bildumschaltung auf Bild Befehlsgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bildumschaltung auf Bild Befehlsgabe

Wenn bei der Funktion „Bildumschaltung“ als Bild ein Bild vom Typ „Befehlsgabe“ ausgewählt wird, erhält der Projektierdialog für die Funktion folgende Einstellungsseite:

Parameter | Beschreibung
Variable welche die Befehlsgabe definiert | Die hier projektierte Variable definiert die zu verwendende Befehlsgruppe. Über den Namen der selektierten Variable ermittelt das Bild die passende Rückmeldevariable und die damit verknüpfte Aktionsvariable.
Initialstufe | Definiert den Schritt (Zustand) in welchem das Befehlsgabebild aufgeschaltet wird. Stufe 1: Das Bild wird aufgeschaltet und wartet auf Aktionsdefinition und Ausführung. Aktionsausführungen müssen manuell durch den Benutzer durchgeführt werden. Sperre: Das Bild wird im Befehlsschritt für die Aktions Sperre geöffnet.


Bildelement Befehlsgabe

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Bildelement Befehlsgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bildelement Befehlsgabe

Wird bei einem Bildelement in den Eigenschaften für die Einstellung „Sollwert setzen über“ die Option „Befehlsgabe“ definiert, kann während der Runtime durch anklicken (linke Maustaste) des Elements das Befehlsgabefenster geöffnet werden. Das zu öffnende Bild ist bei der Befehlsgruppe der beim Element verknüpften Variablen definiert. Die Rückmeldevariable wird ebenso automatisch aus der Befehlsgruppe ermittelt.

info Info

Bei der gewählten Option 'Befehlsgabe' wird das Befehlsgabe Fenster statt dem 'Sollwert setzen' Dialog aufgeschalten.

Folgende Bildelementtypen unterstützen die Befehlsgabe:

1 | Zahlenwert
2 | Textelement
3 | Bargraph
4 | Zeigerinstrument
5 | Zustandselement
6 | Uhr
7 | Universalregler

Wenn die dem Element zugeordnete Variable keine Befehlsgruppe definiert hat oder die Rückmeldevariable der Befehlsgruppe nicht existiert, wird ein Fehlereintrag für den Diagnose Viewer erzeugt und das Bild nicht geöffnet.


Bildelement Sollwert

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Bildelement Sollwert

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bildelement Sollwert

Wird für ein Element bei der Einstellung „Sollwert setzen über“ die Option „Eingabemaske“ oder „Element“ verwendet und verfügt die dem Element zugeordnete Variable über eine Befehlsgruppe, so werden auch alle Änderungen am Sollwert über die Befehlsgruppe durchgeführt. Damit ein Wert geschrieben wird, sind folgende Voraussetzungen zu erfüllen:

  • Die Befehlsgruppe muss die Aktion „Sollwert setzen“ projektiert haben und die resultierende Aktionsvariable ist die Variable des ausgewählten Bildelementes.
  • Keine Verriegelungsbedingung darf das ausführen der Aktion verhindern.

info Info

Wenn eine der vorher genannten Voraussetzungen verletzt ist, wird das Schreiben nicht ausgeführt, kein Sollwert wird auf die Variable geschrieben.


Kontextmenü Befehlsgabe

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Kontextmenü Befehlsgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Kontextmenü Befehlsgabe

Die Befehlsgabe kann auch über ein Kontextmenü direkt am Element angestoßen werden. Dabei handelt es sich um die am meisten verwendete Einsatzvariante. Das Kontextmenü stellt in diesem Zusammenhang bereits die erste Stufe der zweistufigen Befehlsgabe dar.

Das Menü muss über einen Eintrag vom Aktionstyp Befehlsgabe verfügen. Die Anzeige der einzelnen Aktionen wird automatisch durch das Menü definiert. Abhängig vom 'Namen' des Menü-Eintrages kann dabei selektiv die Anzeige der Aktionen beeinflusst werden.

Beim Erzeugen einer neuen Aktion in der Befehlsgabe, wird eine Menü-ID entsprechend des Aktionstyps und der Schaltrichtung für die Eigenschaft Aktionstyp erzeugt und in der Dropdownliste angeboten. Entspricht der Inhalt einer für den Aktionstyp und die Schaltrichtung als Standardtext definierten ID, dann wird der Inhalt angepasst, wenn sich der Aktionstyp oder die Schaltrichtung ändern.

Interne ID: Kontextmenü Befehlsgabe

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um ein Kontextmenü für die Befehlsgabe zu erstellen:

  1. erstellen Sie in der Befehlsgabe die gewünschten Aktionen
  2. wählen Sie in den Eigenschaften des Kontextmenü-Eintrags als Aktionstyp Befehlsgabe
  3. wählen Sie mit der Eigenschaft Menü ID die gewünschte Aktion und Schaltrichtung über die Dropdownliste

    Interne ID: Kontextmenü Befehlsgabe

    Menü ID

    Name des Menüeintrags.

    Bei Aktionstyp Befehlsgabe sind die in der Befehlsgabe bereits definierte Aktionen aus einer Dropdownliste auswählbar.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. vergeben Sie in der Eigenschaft Text eine eindeutige Bezeichnung
    Hinweis: Wird für Text kein Eintrag definiert, wird das Feld automatisch mit der Bezeichnung "Befehlsgabe" gefüllt.

    Interne ID: Kontextmenü Befehlsgabe

    Text

    Beschriftung des Menüeintrags im Menü. Der Eintrag muss eindeutig sein. Sind mehrere Einträge mit gleichem Text vorhanden, wird zur Runtime nur der erste dieser Menüeinträge angezeigt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Die Bezeichnung in der Eigenschaft Text muss eindeutig sein. Werden gleichen Bezeichner vergeben, werden weitere Menüpunkt mit gleicher Bezeichnung nicht angezeigt.

Da automatisch erzeugte Menüpunkte mit gleicher Aktion den gleichen Text ergeben, stehen für diese Makros zur Verfügung.

Die Zeichenfolge ID_CMD_AUTO ist für automatisch erzeugte Menüpunkte reserviert. Diese müssen immer mit Makros verwendet werden, das sonst nur der Menüpunkt eingefügt wird.

Aktionen für Aktionstyp Befehlsgabe

Aktion | Schaltrichtung | Menü-ID
ID_CMD_AUTO |  | Dieser Menüpunkt zeigt automatisch alle möglichen Aktionen für ein Element an, sofern kein direkter Menüpunkt aus der Liste bereits verwendet wird.
Einzelbefehl | EIN (1) | ID_CMD_EBEF_ON
Einzelbefehl | AUS (1) | ID_CMD_EBEF_OFF
Einzelbefehl | KEINE | ID_CMD_EBEF_NONE
Doppelbefehl | EIN (1) | ID_CMD_DBEF_ON
Doppelbefehl | AUS (2) | ID_CMD_DBEF_OFF
Doppelbefehl | KEINE | ID_CMD_DBEF_NONE
Sollwert | KEINE | ID_CMD_SVALUE
Sollwert | DIREKT | ID_CMD_SVALUE_DIR
Statusvorgabe | KEINE | ID_CMD_STATE
Statusvorgabe | EIN (1) | ID_CMD_STATE_ON
Statusvorgabe | AUS (0) | ID_CMD_STATE_OFF
Ersetzen | KEINE | ID_CMD_REPL_NONE
Ersetzen | EIN (1) | ID_CMD_REPL_ON
Ersetzen | AUS (0) | ID_CMD_REPL_OFF
Ersetzen | STÖR | ID_CMD_REPL_DEF
Ersetzen | DIFF | ID_CMD_REPL_DIFF
Nachführen | KEINE | ID_CMD_UPD_NONE
Nachführen | EIN (1) | ID_CMD_UPD_ON
Nachführen | AUS (0) | ID_CMD_UPD_OFF
Nachführen | DIFF | ID_CMD_UPD_DIFF
Nachführen | STÖR | ID_CMD_UPD_DEF
Nachführen | DIREKT | ID_CMD_UPD_DIR
Blockieren | KEINE | ID_CMD_BLOCK
Freigeben | KEINE | ID_CMD_UNLOCK
Sperren | KEINE | ID_CMD_LOCK
Revision | AUS (0) | ID_CMD_REV_OFF
Revision | EIN (1) | ID_CMD_REV_ON

Benennungen der Menüpunkte für das Kontextmenü

1. Automatische Erzeugung

Einträge, die über ID_CMD_AUTO erzeugt werden, erhalten automatisch einen Namen nach dem Schema: 'Aktionsnamen' plus 'Grenzwertext der Schaltrichtung'.

2. Manuell aus Tabelle

Werden die Menü-Einträge aus der Tabelle erzeugt, muss für jede Aktion unter 'Darstellung - Text' ein Text für den Eintrag im Kontextmenü definiert werden.

Namen für die Menüpunkte:

Befehl, Sollwert, Status, Ersetzen, Freigeben, Nachführen, Blockieren, Sperre, Revision

Aktionstexte

Aktion | Text
Einzelbefehl Doppelbefehl | Text wird aus dem Grenzwert entsprechend der Schaltrichtung übernommen.
Nachführen Ersetzen | Wird eine Schaltrichtung (ungleich zu 'keine') definiert, wird der Text aus dem Grenzwert entsprechend der Schaltrichtung angezeigt.
Status | 'AUS' oder 'EIN' abhängig von der eimgestellten Schaltrichtung.
Revision | Text aus dem Grenzwert entsprechend der Schaltrichtung.
Sonstige | Es wird kein spezieller Aktionstext angezeigt.

Example Beispiel

Angezeigter Text für einen Doppelbefehl mit definiertem Grenzwert:

'Befehl: Schaltrichtung EIN'

info Info
  • Alle angezeigten Texte sind mit den Standard-Mechanismen sprachumschaltbar. Siehe dazu auch: Welche Texte sind sprachumschaltbar?
  • Alle angezeigten Menü Einträge werden automatisch alphabetisch sortiert.

Die aktuell zu verwendende Befehlsgruppe wird über die Variable ermittelt, die mit dem Bildelement verknüpft ist. Wenn die Variable keine Befehlsgruppe zugeordnet hat oder die Rückmeldevariable nicht existiert, wird das Kontextmenü zur Runtime nicht angezeigt (eine entsprechende Fehlermeldung wird am Diagnose Server eingetragen).

info Info

In Abhängigkeit von der Befehlsgruppe werden die Menüpunkte der Befehlsgabe dargestellt. Der Menüpunkt wird nur angezeigt, wenn die mit ihm verbundene Aktion existiert. Daraus ergibt sich, dass wenn die Variable des Elements die Befehlsvariable ist, nur die Aktionen für die Befehlsvariable, plus Aktion „Sperre“ angezeigt werden können. Aktionen für die Rückmeldevariable werden automatisch ausgeblendet.

Bedingungen

Die Menüpunkte werden nur freigegeben wenn die entsprechenden Aktionen ausführbar sind. Folgende Bedingungen sind Voraussetzung:

  • Alle Menüpunkte sind gesperrt, wenn bei der Rückmeldevariable das Statusbit SELECT(10) aktiv ist.
  • Alle Menüpunkte sind gesperrt, wenn die Rückmeldevariable nicht ermittelt werden konnte.
  • Alle Menüpunkte sind gesperrt, wenn die Rückmeldevariable keinen Wert hat und dieser auch nicht innerhalb 30 Sekunden angefordert werden konnte.
  • Am Internet Client ohne Schreibberechtigung sind die Menüpunkte gesperrt.
  • Die Menüpunkte sind gesperrt, wenn die Verbindung zum Server fehlt.
  • Der Menüpunkt, welcher mit der Aktion „Freigeben“ verbunden ist, wird gesperrt, wenn bei der Aktionsvariable nicht das Statusbit ERSATZWERT(27) aktiv ist.
  • Der Menüpunkt, welcher mit der Aktion „Ersetzen“ verbunden ist, dessen Schaltrichtung dem Wert der Aktionsvariable entspricht, ist gesperrt.
  • Alle Menüpunkte bis auf jenen welcher mit der Aktion „Sperre“ verbunden ist, sind gesperrt, wenn bei der Rückmeldevariable eine Änderungssperre aktiv ist.
  • Wenn bei der Rückmeldevariable das Statusbit REVISION(9) aktiv ist, sind die Aktionen „Sollwert“, „Ersetzen“, „Nachführen“ und „Befehl“ gesperrt.
  • Solange bei der Befehlsgruppe eine Laufzeitüberwachung, Flankenbildung oder SBO aktiv ist, werden alle Menüpunkte gesperrt. Dies ergibt sich da das Statusbit SELECT ebenfalls aktiv bleibt.
  • Der Menüpunkt welcher mit der Aktion „Revision“ verbunden ist, dessen Schaltrichtung dem Wert der Aktionsvariable entspricht, ist gesperrt.

Noch in diesem Kapitel

Makros für Kontextmenü

Fehlermeldungen

Ausführen von Aktionen


Makros für Kontextmenü

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Kontextmenü Befehlsgabe -> Makros für Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Makros für Kontextmenü

Ein Makro ist eine definierte Zeichenfolge, die bei der Menüpunkterzeugung zur Runtime welche durch einen anderen Text ersetzt wird. Beinahe alle Makros können pro Menüpunkt mehrfach vorkommen. Sie können auch als Ergebnis weitere Makros beinhalten. Dabei muss die Expansionsreihenfolge beachtet werden. Makros sind bei der Menüprojektierung case insensitive. Wenn Makros als Ergebnis ein Makro beinhalten, muss das Makro in Großbuchstaben im Ergebnis enthalten sein. Die Eingabe erfolgt mit $ als Prefix und Suffix.

Die Reihenfolge der Expansion erfolgt von links nach rechts in folgender Priorität.

  1. $NOTE$
  2. $TAG$
  3. $REMA<Zustand>$
  4. $RDIR$
  5. $ALL$
  6. $DIR$
  7. $ACT$
  8. $NOTE$

Makro

Beschreibung

$NOTE$

Der gesamte Text inklusive dem Makro wird als Bemerkung interpretiert. Ist der resultierende Text leer, wird das Makro $ALL$ eingesetzt.

$TAG$

Wird durch die Kennung der Aktionsvariable ersetzt.

Die Kennung kann durch die Onlinesprachübesetzung übersetzt werden. Wenn kein Übersetzungszeichen (@) enthalten ist, wird automatisch die gesamte Kennung zur Übersetzung markiert.

$REMA<Zustand>$

<Zustand> ist ein Rema- oder Grenzwertzustand, dessen Text zur Ersetzung verwendet wird.

Ist der Zustand nicht vorhanden, wird der Menüpunkt nicht dargestellt.

Der Grenzwerttext wird vor der Makroexpansion entsprechend der Platzierung von @ sprachübersetzt.

Zustand kann eine Zahl zwischen -231 und 231-1 sein. Führende Leerzeichen und ein Vorzeichen sind erlaubt. Wenn nicht auf eine Zahl konvertierbare Zeichen enthalten sind oder die Zahl außerhalb des angegebenen Bereiches ist, wird der Menüpunkt nicht dargestellt.

$RDIR$

Text für die Schaltrichtung aus Reaktionsmatrix/Grenzwert wie im Makro $DIR$, ausgenommen:

  • Aktion Sollwert setzen direkt
    Der Text wird aus Rema/Grenzwert vom Zustand, der dem Wert des zu setzenden Sollwertes entspricht, genommen.
  • Aktion Status ein und Status aus
    Text wird aus Rema/Grenzwert für den Zustand ein bzw aus genommen.
  • Aktion Nachführen direkt
    Der Text wird aus Rema/Grenzwert vom Zustand, der dem Wert des zu setzenden Sollwertes entspricht, genommen.

$ALL$

Ergibt Aktionsbenennung: Schaltrichtung.

Entspricht der Kombination der Makros $ACT$: $DIR$

$DIR$

Schaltrichtung der Aktion.

$ACT$

Aktionsbenennung der Aktion.

$NOTE$

Als letztes Makro wird nochmals das Bemerkungsmakro geprüft und der Text rechts davon inklusive Makro gelöscht.

Ist der resultierende Text leer oder besteht er nur aus Leerzeichen, wird der Menüpunkt nicht eingefügt.

Automatisch erzeugte Menüpunkte

Automatisch erzeugte Menüpunkte werden bei ID_CMD_AUTO als Menü-ID erzeugt. In diesem Fall müssen immer Makros verwendet werden, da ansonsten nur ein Menüpunkt eingefügt wird.

Kompatibilität

Vor Version 6.51 wurde Text bei automatischen Menüpunkten ignoriert. Bei der Konvertierung von Projekten, die mit Versionen vor 6.51 erstellt wurden, werden vor dem projektierten Text die Makros $ALL$$NOTE$ eingefügt. Damit verhalten sich diese Menüpunkte genau so wie bisher.

Online Sprachumschaltung

Die Beschriftung für den Menüpunkt in der Eigenschaft Text wird vor der Makroexpansion ab dem Zeichen @ sprachübersetzt.

Interne ID: Makros für Kontextmenü

Text

Beschriftung des Menüeintrags im Menü. Der Eintrag muss eindeutig sein. Sind mehrere Einträge mit gleichem Text vorhanden, wird zur Runtime nur der erste dieser Menüeinträge angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Ist beim Makro $TAGS$ kein Übersetzungsindikator (@) enthalten, wird der komplette Text übersetzt.


Fehlermeldungen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Kontextmenü Befehlsgabe -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Fehlermeldungen

Beim Aufschalten den Menüs in der Laufzeitumgebung, wird dessen Inhalt auf konsistenz geprüft. Bei auftretenden Fehler werden entsprechende Fehlermeldungen für das Online Diagnosetool ausgegeben. Folgende Meldungen können auftreten:

Parameter | Beschreibung
Menüpunkt für Befehlsgabe unterdrückt da Name mehrfach im Menü! | Das Menü beinhaltet bereits einen Menüpunkt mit einem in der Befehlsgabe verwendeten Bezeichner. Verwenden Sie die bei der Befehlsgabe verwendeten Namen für keine sonstigen Menüpunkte.
Menüpunkt für Befehlsgabe unterdrückt da Benennung mehrfach im Menü! | Es ist bereits ein Menüpunkt mit der gleichen Benennung im Menü. Automatisch erzeugte Menüpunkt werden nicht eingefügt, wenn bereits ein Menüpunkt mit der gleichen Benennung im Menü ist.
Text für Menüeintrag kann nicht ermittelt werden! | Die Benennung eines automatisch erzeugten Menüpunkt konnte nicht ermittelt werden. Dies deutet meist auf einen fehlenden Grenzwertext hin.
Keine Befehlsgruppe bei Variable vom Bildelement verknüpft! | Die dem Bildelement zugeordnete Variable hat keine oder eine nicht mehr gültige Befehlsgruppe verknüpft. Entsprechende Fehlermeldungen werden beim Compilieren ausgegeben.
Rückmeldevariable nicht existent! | Die bei der Befehlsgruppe verwendete Rückmeldevariable existiert nicht.
Select nicht aktivierbar! | Statusbit SELECT(10) konnte nicht innerhalb der Timeoutzeit aktiviert werden.


Ausführen von Aktionen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Kontextmenü Befehlsgabe -> Ausführen von Aktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Ausführen von Aktionen

Nach Aktivierung eines Menüpunktes für die Befehlsgabe, wird die zugeordnete Aktion ausgeführt. Das Ausführen über Menü aktiviert im ersten Schritt das setzen des Statusbits 'SELECT'. Nur wenn dies erfolgreich war, wird die Ausführung der eigentlichen Aktion (zum Beispiel 'Doppelbefehl' begonnen).

Anschließend erfolgt ein Öffnen des Befehlsgabefensters wenn eines der folgenden Kriterien erfüllt ist:

  • Wenn die auszuführende Aktion „Sollwert setzen“, „Status setzen“ mit Eingabe oder „Nachführen Sollwert“ ist, wird das der Aktion zugeordnete Bild im Schritt „Stufe 1“ geöffnet. Im Bild kann dann der zu schreibende Sollwert / Status definiert werden.
  • Wenn die auszuführende Aktion „Sperre“ ist, wird das aktionsspezifische Bild mit dem Schritt „Sperre“ aufgerufen
  • Wenn eine anstehende Verriegelungsbedingung die Ausführung verhindert, wird das bei der Aktion projektierte Bild im Schritt „Entriegelung“ aufgerufen. Hierzu zählt auch, wenn SBO nicht fehlerfrei aktiviert werden konnte.
  • Wenn eine zweistufige Ausführung bei der Aktion projektiert ist, wird das aktionsspezifische Bild im Schritt „Stufe 2“ aufgerufen.
  • Wenn bei der Aktion kein spezifisches Bild projektiert wurde, wird das Bild, welches zentral bei der Befehlsgruppe projektiert wurde, geöffnet.

Das interne Select und das SBO werden an das Bild weitergegeben.

info Info

Trifft keine der oben genannten Bedingungen zu, wird die Aktion sofort, ohne weitere Bedienhandlungen ausgeführt.


Kontextmenü Sollwert

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Aktionen -> Aktionen ausführen -> Kontextmenü Sollwert

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Kontextmenü Sollwert

Ist die einem Bildelement zugeordnete Variable mit einer Befehlsgruppe verknüpft, wird auch das Schreiben eines Sollwertes über die Befehlsgabe abgehandelt. Voraussetzung dafür ist, dass bei der Befehlsgabe eine Aktion „Sollwert setzen“ vorhanden ist. Fehlt diese, wird das Absetzen des Sollwertes nicht ausgeführt.

info Info

Eine anstehende Verriegelungsbedingung verhindert das Schreiben eines Sollwertes.


Befehls Bedingungen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Befehlsgruppen beinhalten zum einen die Definition der Schalt Aktionen, zum anderen auch die Defintion der Befehls Bedingungen. Befehls Bedingungen sind optionale Parameter die Appliaktions spezifisch definiert werden können.

Jede Aktion innerhalb einer Befehlsgruppe kann zusätzlich um 'Befehlsbedingungen' erweitert werden. Diese Prozess gesteuerten Verriegelungen verhindern ein ungewolltes ausführen von Aktionen, abhängig vom aktuellen Prozess Zustand.

Die Befehlsgruppen bestehen im wesentlichen aus drei wesentlichen Teilen:

Parameter | Beschreibung
Aktionen | Diese definieren, welcher Befehl ausgeführt wird, auf welche Variablen diese Aktionen angewendet werden sollen und parametrieren die internen Verriegelungen.
Bedingungsvariablen | Diese definieren, welche Variablen in den Befehlsbedingungen verwendet werden können.
Befehlsbedingungen | Durch diese Bedingungen wird das Ausführen von Befehlen zusätzlich vom aktuellen Prozesszustand abhängig gemacht.

seealso Siehe auch

Verriegelungen

Noch in diesem Kapitel

Befehls Bedingungen definieren

Formeleditor


Befehls Bedingungen definieren

Befehls Bedingungen definieren

Zu jeder Aktion kann eine beliebige Anzahl von Befehls Bedingungen definiert werden. Durch diese Bedingungen kann die Ausführbarkeit einer Aktion zusätzlich eingeschränkt werden. Diese Bedingungen werden durch Formeln definiert, in denen Variablen aus den aktiven Projekten verwendet werden können. Die Formel spricht dabei die verknüpften Variablen über den Index in der Bedingung an.

info Info

Die Bedingungsvariable wird wenn ein ‚*’ in der Definition verwendet wird automatisch ersetzt.

Noch in diesem Kapitel

Bedingungsvariable definieren

Verriegelungsbedingung

Interne Verriegelungsbedingungen

Befehlsgabe im Verteilten Engineering


Bedingungsvariable definieren

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Befehls Bedingungen definieren -> Bedingungsvariable definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bedingungsvariable definieren

In einem ersten Schritt müssen die Variablen definiert werden, welche später bei den Formeln der Befehls Bedingungen verwendet werden können. Werden später zur Laufzeit die definierten Bedingungen durch die verknüpften Prozessvariablen erfüllt. stehen dem Anwender die jeweiligen Aktionen zur Verfügung.

info Info

Wird eine Variable nachträglich gelöscht, welche in einer Befehls Bedingung verwendet wird, erfolgt eine Index Anpassung innerhalb der Bedingung. Die nachfolgenden Variablen werden nach vorne gereiht und die Formeln automatisch angepasst.

Um eine Befehls Bedingung zu definieren, empfiehlt sich folgende Vorgehnsweise:

Example Beispiel
  1. In der Detailansicht der Befehlsgabe selektieren Sie den Knoten Variable und wählen im Kontextmenü die Option 'Neu'.
  2. Im Auswahl Dialog selektieren Sie eine Prozessvariable die als Grundlage für die Formeln der Befehls Bedingungen fungiert. Den Variablenauswahldialog können Sie optional abbrechen um eine leere Definition zu erzeugen. Für diese leere verknüpfung können Sie über einen '*' die automatische Ersetzung definieren.
  3. Selektieren Sie eine bereits bestehende Aktion und für die diese in der Detailansicht den Knoten 'Bedingungen'. Mittels 'Bedingung neu' kann hier für jede Aktion eine beliebige Anzah an Bedingungen definiert werden. Die Defintion erfolgt durch Formeln, nicht erfüllte Bedingungen bewirken dass Sperren der entsprechenden Aktion in der Runtime.

Die weiteren Einstellungen (z.B das Zuordnen der Verriegelung zu einer Variable) erfolgen im Eigenschaftenfenster. Die Eigenschaften werden detailliert in der Eigenschaften Hilfe beschrieben.


Verriegelungsbedingung

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Befehls Bedingungen definieren -> Verriegelungsbedingung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Verriegelungsbedingung

Für jede Aktion kann eine beliebige Anzahl von Befehls Bedingungen definiert werden. Diese werden vor Ausführung der jeweiligen Aktion geprüft. Schlägt eine Überprüfung fehl, kann die entsprechende Aktion zur Laufzeit nicht angewählt werden.

Definiert werden die Bedingungen in Form von Formeln. Dieser Syntax ist analog zur Defintion der Formeln im Formel Editor zu sehen.

Zusätzlich werden vor Aktionsausführung folgende Verriegelungstypen mit überprüft (zusätzlich zu den Befehlsgruppen):

Interne Verriegelungsbedingungen

Diese Bedingungen werden vor jeder Aktionsausführung automatisch überprüft, ohne dass der Projektant Einfluss darauf nehmen kann. Diese Interne Verriegelungsbedingungen sind vom System vorgegeben und dienen der Plausibilitätsprüfung.

Example Beispiel

Select konnte nicht aktiviert werden.

Topologische Verriegelungsbedingungen

Diese Bedingungen ergeben sich aus dem aktuellen topologischen Zustand zur Laufzeit. Die Defintion dieser Bedingungen erfolgt in den 'Konfiguration der Topologischen Verriegelungen' Einstellungen


Interne Verriegelungsbedingungen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Befehls Bedingungen definieren -> Interne Verriegelungsbedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Interne Verriegelungsbedingungen

Mit Hilfe der internen Verriegelungsbedingungen werden die grundlegenden Voraussetzungen für die Aktionsausführung geprüft (Plausibilitätsprüfung). Die Eregbnisse, beziehungsweise das ansprechen einer Verriegelung wird zur Laufzeit im Befehlsgabefenster als Verriegelungsbedingung angezeigt.

Parameter | Beschreibung
Zustand schon vorhanden | Zu setzender Zustand entspricht bereits dem aktuellen Wert der Rückmeldevariable. Diese Überprüfung ist nur aktiv wenn für die Befehlsgruppe der 'Soll/Ist- Vergleich' aktiviert wurde. Diese Verriegelung ist entriegelbar.
Interner Fehler aufgetreten | Befehlsgabe kann die Prüfung nicht ausführen. Tritt auf wenn der Datentyp der Aktionsvariable für diese Aktion nicht erlaubt ist. Beispiel: Aktion 'Einzelbefehl Ein' für Stringvariablen Diese Verriegelung ist nicht entriegelbar.
kein Verriegelungsobjekt | Befehlsgruppe konnte nicht ermittelt werden. Diese Verriegelung ist nicht entriegelbar.
Aktion nicht definiert | Auszuführende Aktion konnte nicht ermittelt werden. Diese Verriegelung ist nicht entriegelbar.
Differenz zwischen lokaler und globaler Verriegelung | Einzelbefehl Parameter nicht konsistent. Fehler in der Parametrierung Diese Verriegelung ist nicht entriegelbar.
Ein oder mehrere Werte sind nicht verfügbar | Wert der Bedingungsvariable nicht verfügbar. Sperrcode: 14 Wert der Bedingungsvariable gestört. Sperrcode: 15 Diese Verriegelung ist nicht entriegelbar.
Sperrverwaltung nicht gültig | Die Verwaltung der Sperren konnte nicht geladen werden und ist ungültig. Diese Verriegelung ist nicht entriegelbar.
Variable gegen Änderungen gesperrt | Befehlsgabe durch die Rückmeldevariable (Staus) gesperrt. Diese Verriegelung ist nicht entriegelbar.
SBO abgelehnt | Es wurde die Aktivierung des Select von der Steuerung abgelehnt. Diese Verriegelung ist nicht entriegelbar.
Timeout bei SBO Aktivierung | Innerhalb der Timeoutzeit wurde keine Bestätigung für die Aktivierung (positiv oder negativ) erhalten. Diese Verriegelung ist nicht entriegelbar.
Timeout bei SBO Deaktivierung | Innerhalb der Timeoutzeit wurde keine Bestätigung für die Deaktivierung (positiv oder negativ) erhalten. Diese Verriegelung ist nicht entriegelbar.
Timeout bei Ausführung | Die Aktionsausführung wurde nicht innerhalb der Timeoutzeit als beendet gemeldet. Diese Verriegelung ist nicht entriegelbar.
SBO abgelaufen | Die Steuerung hat den Ablauf der SBO Aktivierung gemeldet. Diese Verriegelung ist nicht entriegelbar.


Befehlsgabe im Verteilten Engineering

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Befehls Bedingungen definieren -> Befehlsgabe im Verteilten Engineering

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Befehlsgabe im Verteilten Engineering

info Info

Da die Befehls Bedingungen und die Allgemeinen Verriegelungen (Standard Funktionalität / ohne Energy Edition) in der gleichen Struktur im Editor abgelegt sind, wird für beide Knoten im Projektbaum das Auschecksymbol (Änderungen ermöglichen) ident gesetzt. Alle Aktionen auf die Befehls Bedingungen betreffen auch die allgemeinen Verriegelungen und umgekehrt.

Als gelöscht markierte Variablen werden für die Kompilierung der Befehlsbedingungen als nicht existent betrachtet. Beim compilieren werden entsprechende Fehlermedlungen im Ausgabefenster angezeigt.


Formeleditor

Formeleditor

Der Formeleditor unterstützt bei der Erstellung von Formeln mit logischen oder vergleichenden Operatoren beim Combi-Element, bei Verriegelungen und Befehlsgabe. Werden für eine Formel zusätzliche Variablen benötigt, erstellen Sie diese im Bereich Formelvariablen des Zustandsfensters mit Klick auf die Schaltfläche Hinzufügen. Vorhandene Formeln werden in der Zustandsliste durch den Buchstaben F angezeigt.

Formel erstellen

Klicken Sie im Zustandsfenster auf die Schaltfläche Formel. Der Formeleditor öffnet sich

Im linken Fenster wählen Sie die Bits für Ihre Formel aus.

Rechts finden Sie die Operatoren für logische und vergleichende Operationen.

Im Bereich Formel wird die erstellte Formel angezeigt.

info Info

Es können bis zu 99 Variablen in einer Formel verknüpft werden. X01 bis X99. Die Länge der Formel darf dabei 4096 Zeichen nicht überschreiten.

Die Bedeutung der Bits:

Parameter

Beschreibung

Wert-Bits

Es stehen 32 Wert-Bits (von 0 -31) zur Verfügung. Sie beschreiben den Variablenwert bitweise. Für BOOL'sche Variablen hat nur das Bit 0 Bedeutung, für SINT und USINT die Bits 0-7 usw...

Hinweis: Die Auswertung bezieht sich immer auf den Rohwert (Signalbereich) der Variablen und nicht auf den umgerechneten Messwert.

Status-Bits

Stellt die gängigsten Status-Bits zur Verfügung. Die genaue Definition und Verwendung der Status-Bits finden Sie in der Liste Status-Bits.

unquittiert

Unquittiert wird wie ein ganz normales Status-Bit behandelt, wird hier aber separat angeführt, da es nicht zu den klassischen Variablen Status gehört.

Wert und Status

Alle Werte (Wert-Bits und Status-Bits) in den Formeln werden als Binärwerte betrachtet und können dann logisch mit UND bzw. ODER sowie anderen logischen Ausdrücken verbunden werden.
Eine Ausnahme bilden der Gesamtwert und der Gesamtstatus. Damit man damit auf einen boole'schen Ausdruck kommt, muss man diesen Gesamtwert zuerst mit einer Konstante bitweise verodern. Dazu wird der Operator & verwendet.
Bei Ergebnis 0 (False) der bitweisen Veroderung ergibt sich der Binärwert 0 (False), ansonsten 1 (True).

Beispiel: siehe Kapitel Beispiel bitweise Veroderung

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.

Werden außerhalb des Formeleditors andere Einstellungen für den aktuellen Zustand gemacht, so werden diese mit der Formel mit einem logischen UND verknüpft.

Für Beispiele siehe Abschnitt Beispiele für Formeln.

info Info

Formeln mit binären X-Werten und bitweiser Verknüpfung können mit maximal 2 binären Werten benutzt werden. Werden mehr Werte benötigt, muss die Verknüpfung ohne binäre X-Werte erfolgen.

Beispiel:

X01.Value & X02.Value -> funktioniert

X01.Value & X02.Value & X03.Value -> funktioniert nicht

Aber:

X01.00 AND X02.00 AND X03.00 AND X04.00 AND X05.00 -> funktioniert

Noch in diesem Kapitel

Liste Status-Bits

Logische Operatoren

Bitformeln

Vergleichsoperatoren

Beispiele für Formeln


Liste Status-Bits

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Formeleditor -> Liste Status-Bits

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Liste Status-Bits
Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Details zur Statusverarbeitung lesen Sie im Kapitel Statusverarbeitung.


Logische Operatoren

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Formeleditor -> Logische Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Logische Operatoren

Logische Verknüpfungen: Variablen werden nur auf den logischen Wert '0' überprüft, ist der Wert ungleich '0', wird er mit '1' definiert.

Im Unterschied zur Bitformel kann der technische Bereich durch einen Streckungsfaktor verändert werden -> ungleich '0' oder '1'.

Operator | Bedeutung
AND | logisch 'UND'
NOT | Negation
OR | logisch 'ODER'
XOR | logisch 'EXKLUSIV ODER'

Die Operator haben in der Formelberechnung folgende Priorität:

Priorität | Operator
1 | & (Operator für Bitformeln)
2 | NOT
3 | AND
4 | XOR/OR

info Info

Es können bis zu 99 Variablen in einer Formel verknüpft werden. X01 bis X99.

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.


Bitformeln

Bitformeln

Bitformeln besitzen nur einen logischen Low- oder Highzustand. Im Unterschied zu logischen Formeln ist der Rohwert bereits fix vordefiniert (0,1).

Operator | Beschreibung
& | AND
| | OR

Noch in diesem Kapitel

Beispiel bitweise Veroderung


Beispiel bitweise Veroderung

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Formeleditor -> Bitformeln -> Beispiel bitweise Veroderung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Beispiel bitweise Veroderung

Sie wollen abfragen, ob eines der Anwenderstatus Bits 1-8 (M1 ... M8) von der Variable X01 gesetzt ist.

Normale Formel:

X01.M1 OR X01.M2 OR X01.M3 OR X01.M4 OR X01.M5 OR X01.M6 OR X01.M7 OR X01.M8
Diese Abfrage kann durch die bitweise Veroderung des Gesamtstatus wesentlich erleichtert werden.

Bitweise Veroderung:

X01.Status & 0xFF

Die Konstante kann, wie oben beschrieben, Hexadezimal eingegeben werden:

0xFF entspricht dezimal 256, das sind die ersten acht Statusbits (Binär 11111111). Steht eines dieser Bits auf 1, dann ist das Ergebnis dieser bitweisen Veroderung 1 (True), ansonsten 0 (False).

Sollen z. B. alle Anwender Status-Bits außer dem Anwender Status-Bit M7 abgefragt werden, wäre der Binäre Ausdruck dafür: 10111111. Bit 7 ist nicht interessant, steht daher auf 0. Das entspricht Hexadezimal 0xBF. Der Ausdruck für die Formel ist dann: X01.Status & 0xBF.

Statt mit einer Konstante bitweis zu verodern, kann man den Wert auch direkt mit einer dezimalen Zahl vergleichen. Ist ein Vergleich falsch, ergibt sich der Binärwert 0 (False), ansonsten 1 (True).

Beispiel:

Sie wollen abfragen, ob ein Wert der Konstanten 202 entspricht. Die Formel lautet:

X01.Wert = 202

Entspricht der Wert der Konstanten 202, so ist das Ergebnis dieses Vergleiches 1 (True), ansonsten 0 (False).

Hinweis: Die bitweise Veroderung funktioniert mit dem Oder-Zeichen (|) analog zu diesem Beispiel.


Vergleichsoperatoren

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Formeleditor -> Vergleichsoperatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Vergleichsoperatoren

Vergleichoperatoren dienen zum direkten Vergleich von zwei numerischen Werten. Das Ergebnis dieses Vergleichs wird in Form eines Binärzustandes dargestellt. „0“ wenn die Bedingung nicht erfüllt ist und „1“ wenn die Bedingung erfüllt ist.

Operator | Beschreibung
< | kleiner
> | größer
<= | kleiner gleich
>= | größer gleich
= | ist gleich
<> | ungleich

Links und rechts vom Vergleichs Operator muss ein (Gesamt-)Wert oder (Gesamt-)Status stehen, Einzelbits können mit diesen Vergleichsoperatoren nicht verwendet werden.

Rechts vom Vergleichs Operator kann auch eine Konstante stehen. Die Konstanten können nur Ganzzahlen sein, ein Vergleich mit Gleitkommazahlen ist nicht möglich.
Im Combi-Element werden diese Konstanten als hexadezimale Werte oder Dezimalwerte eingegeben. Hexadezimale Zahlen werden beim Klick auf OK automatisch in Dezimalzahlen umgewandelt (z.B. entspricht 0x64 dem numerischen Wert 100).

Example Beispiel

X01.Wert >= X02.Wert
Das Ergebnis ist „1“ wenn der Wert von X01 größer oder gleich dem Wert X02 ist

X01.Wert = 0x64
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 entspricht (= Hex 0x64)

(X01.Wert = 0x64) OR (X01.Wert = 0x65)
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 oder 101 entspricht (= Hex 0x64 und Hex 0x65)


Beispiele für Formeln

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Befehlsgabe definieren -> Befehls Bedingungen -> Formeleditor -> Beispiele für Formeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Beispiele für Formeln

Einfache logische UND Verknüpfung zwischen zwei Werte Bits

Example Beispiel

Formel: X01.03 AND X02.03

Diese Formel ergibt den Zustand WAHR, wenn sowohl Bit 3 der Variablen 1 als auch Bit 3 der Variablen 2 den Wert 1 hat.

Der Wert oder Status einer Variable analog vergleichen

Example Beispiel

(X01.Wert> X02.Wert)

Analoge Vergleiche auf logischer Basis miteinander vergleichen

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert)

Vergleiche mit Werte- und Status-Bits

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert) OR (X01.03 = X02.03)

Einen Wert mit einem dezimalen oder hexadezimalen Wert vergleichen

Example Beispiel

Formel: (X01.Wert = 111)

Formel: (X01.Wert = 0x6F)

Wird ein hexadezimaler Wert verwendet, so wird dieser mit dem Klick auf OK später in dezimale Schreibweise umgewandelt. Wurde ein dezimaler Wert angegeben und bestätigt, wird dieser beim erneuten Öffnen weiter als dezimaler Wert angezeigt.

info Info

Bei der Eingabe von Zahlen ist es nicht möglich, ein Komma oder einen Punkt zu verwenden.


Menü erzeugen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Menü erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Befehlsgabe kann auch über ein Kontextmenü aktiviert werden. Kontextmenüs werden im Editor über den Knoten Menüs erstellt und in den Eigenschaften des Elements, auf das Sie sich beziehen, definiert.

Ein Menü-Eintrag kann einen von drei verschiedenen Inhalten haben:

Parameter

Beschreibung

Aktionstyp

Interne ID: Menü erzeugen

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt fest, welche Art von Aktion über den entsprechenden Menü-Eintrag zur Runtime ausgeführt werden soll. Nicht alle Aktionstypen stehen im Hauptmenü zur Verfügung, manche sind nur über das Kontextmenü projektierbar.

  • Alarme quittieren (nur Kontextmenü)
  • Befehlsgabe (nur Kontextmenü)
  • Blinken quittieren (nur Kontextmenü)
  • Funktion
  • Hilfe
  • Keine Aktion
  • Sollwert absetzen
  • VBA Makro (nur Kontextmenü)

Untermenü

Interne ID: Menü erzeugen

Untermenü

Der Menüeintrag führt keine Aktion aus, sondern öffnet ein Untermenü.

Default: Inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Öffnet zur Runtime ein Untermenü.

Trennlinie

Eine horizontale Linie trennt Menüeinträge.

Text unterstreichen: Die Eingabe eines & bewirkt, dass das folgende Zeichen unterstrichen dargestellt wird.

Einträge projektieren

Um einen Menüeintrag im Hauptmenü oder Kontextmenü zu projektieren:

  1. aktivieren Sie die entsprechende Menüzelle
  2. wählen Sie in den Eigenschaften:
    • Aktionstyp: abhängig von Menüart
      siehe auch: Aktionstypen Hauptmenü und Aktionstypen Kontextmenü
    • Menü ID: ID des Eintrags
      Hinweis: Bei Befehlsgabe stehen die in der Befehlsgabe vordefinierten Typen mit fester ID zur Verfügung

      Interne ID: Menü erzeugen

      Menü ID

      Name des Menüeintrags.

      Bei Aktionstyp Befehlsgabe sind die in der Befehlsgabe bereits definierte Aktionen aus einer Dropdownliste auswählbar.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Text: eindeutige Beschriftung der Menüzelle

      Interne ID: Menü erzeugen

      Text

      Beschriftung des Menüeintrags im Menü. Der Eintrag muss eindeutig sein. Sind mehrere Einträge mit gleichem Text vorhanden, wird zur Runtime nur der erste dieser Menüeinträge angezeigt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Die Bezeichnung in der Eigenschaft Text muss eindeutig sein. Werden gleiche Bezeichner vergeben, werden weitere Menüpunkt mit gleicher Bezeichnung nicht angezeigt.

Details zur Definition von Kontextmenüs für die Befehlsgabe lesen Sie im Kapitel Menüs/Befehlsgabe.


Import und Export

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Import und Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

seealso Siehe auch

Siehe Kapitel Import und Export / Befehlsgruppen.

info Info

Kopieren in die Zwischenablage

Über die Zwischenablage kann nur auf Ebene der gesamten Befehlsgruppe ein Kopieren oder Einfügen ausgeführt werden. Einzel Aktionen können nicht kopiert werden.

Bereits bestehende Befehlsgruppen erhalten beim Einfügen einen neuen Namen.


Runtime Dateien erzeugen - Starten der Runtime

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Runtime Dateien erzeugen - Starten der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erzeugen der Runtimedateien für die Befehlsgruppen wird eine Prüfung auf Fehlprojektierung und die korrekte Ersetzung durchgeführt.

Für jede Prozessvaraible, welcher eine Befehlsgruppe zugeordnet hat, wird eine spezifische Version der Befehlsgruppe für zenon erzeugt. In dieser sind nur mehr die Aktionen enthalten, welche über diese Variable ausgelöst werden dürfen.

Example Beispiel

Die Befehlsgruppe zur Befehlsvariable hat nur mehr Aktionen auf diese Befehlsvariable. Mit Ausnahme der Aktion „Sperre“ diese ist auch bei der Befehlsvariable verfügbar.

info Info

Das Kompilieren der Befehlsgabe muss auch bei Änderungen an den Variablen ausgelöst werden.

Noch in diesem Kapitel

Verknüpfungen ersetzen

Fehler beim Runtime-Dateien erzeugen


Verknüpfungen ersetzen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Runtime Dateien erzeugen - Starten der Runtime -> Verknüpfungen ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Wiederverwendbarkeit der Befehlsgruppe zu erhöhen, besteht die Möglichkeit die Variablenbezüge zu ersetzen. Die Ersetzung ist bei der Rückmelde-, Befehls- und Bedingungsvariable möglich.

Bei der Ersetzung wird der Platzhalter ‚*’ automatisch durch den Namen der Variablen, die der Befehlsgabe zugeordnet ist, ersetzt.

Example Beispiel

Nehmen wir an wir haben die Variablen xyz_RM, abcRM und bool_RM.

Unsere Maske ist ‚*_RM’.

Variablenname | Ersetzungstext | Ergebnis | Bemerkung
xyz_RM | xyz | xyz_RM | Variable ist existent, Zuordnung erfolgreich
abcRM | <leer> | _RM | Die Maske passt nicht, da _ fehlt. Variable nicht existent.
bool_RM | bool | bool_RM | Variable ist existent, Zuordnung erfolgreich

info Info

Wird erkannt, dass die Variable, für welchen die Befehlsgruppe kompiliert werden soll, der Rückmeldevariable entspricht. So wird der Ersetzungstext durch die Rückmeldevariable festgelegt. Ansonsten wird der Ersetzungstext durch die Aktionsvariable der ersten zur Variablen passenden Aktion definiert.

Konnte der Ersetzungstext erfolgreich ermittelt werden, wird der Platzhalter '*' durch diesen ersetzt.

Daher sollten bei der Bezeichnung folgende Punkte berücksichtigt werden:

  • Die Namen der Variablen und der Maske sollten so gewählt werden, dass diese eindeutig zugeordnet werden können.
  • Die Namen der Variablen, welche für die Rückmelde-, Befehls- und Bedingungsvariable verwendet werden, sollten über den gleichen Ersetzungstext erzeugbar sein.
  • Wenn die Rückmeldevariable ersetzt wird aber die Befehlsvariable nicht, ist besonderes darauf zu achten, dass die Befehlsgruppe welche für die Befehlsvariable erzeugt wird, auch die erwartete Rückmeldevariable verwendet.
  • Ein weiterer Prüflauf stellt für die Befehlsgruppe bei der Rückmeldevariable sicher, dass sie nur Aktionen beinhaltet, deren Aktionsvariable bei ihrer kompilierten Verriegelung die gleiche Rückmeldevariable verwenden. Aktionen, die gegen diese Regel verstoßen, erzeugen eine Warnung und werden entfernt.


Fehler beim Runtime-Dateien erzeugen

Handbuch -> Energy Edition -> Befehlsgabe -> Projektieren im Editor -> Runtime Dateien erzeugen - Starten der Runtime -> Fehler beim Runtime-Dateien erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erzeugen der Runtime-Dateien für die Befehlsgabe erfolgt eine umfangreiche Prüfung auf Fehlprojektierung und nicht vorhandene Bezüge.

info Info

Ein Fehler hat immer zur Folge, dass das Objekt, welches den Fehler verursacht während der Runtime nicht zur Verfügung steht.

Wenn die Befehlsgruppe einen Fehler hat, wird der Variablen keine Befehlsgruppe zugeordnet. Das hat während der Runtime zur Folge das alle Bedienhandlungen gesperrt sind.

Eine Warnung wird erzeugt wenn die Projektierung ein Problem erzeugen würde oder aber Fehlerfrei funktioniert.

In den Fehlermedlungen werden folgende Platzhalter verwendet:

<VERNAME> | Platzhalter wird in der Fehlermeldung durch den Namen der Befehlsgruppe ersetzt.
<VERRM> | Platzhalter wird in der Fehlermeldung durch den Namen der Rückmeldevariable ersetzt.
<AUFVAR> | Platzhalter wird in der Fehlermeldung durch den Namen der Variablen, der die Befehlsgruppe zugeordnet ist, ersetzt.
<ACTVAR> | Platzhalter wird in der Fehlermeldung durch den Namen der Variablen der Aktion ersetzt.
<Aktionsbezeichnung> | Platzhalter wird in der Fehlermeldung durch die Benennung der Aktion ersetzt.
<VARNAME> | Platzhalter wird durch Variable in der Visualisierung ersetzt.

Folgende Fehlermeldungen können beim Erzeugen der Runtime-Dateien auftreten:

Meldungstext | Beschreibung
<VERNAME>: Verriegelungs-PV <VERRM> existiert nicht! | Bedingungsvariable für allgemeine Verriegelung ist nicht vorhanden.
Variable '<AUFVAR>' verwendet nicht vorhandene Befehlsgabe! | Variable verwendet eine nicht vorhandene Befehlsgabe.
(<AUFVAR>) Befehlsgabe '<VERNAME>' enthält keine Aktionen! | Befehlsgruppen ohne Aktion werden nicht in die Laufzeit übernommen. Diese Meldung kann auch ein Folgefehler sein.
(<AUFVAR>) Rückmeldevariable '<VARRM>' verwendet nicht die Befehlsgruppe '<VERNAME>' | Es wird eine Rückmeldevariable verwendet welche eine andere Befehlsgruppe verwendet. Die Rückmeldevariable muss immer mit der Verriegelung verknüpft sein, welche sie als Rückmeldevariable verwendet.
(<AUFVAR>) Rückmeldevariable '<VARRM>' für Befehlsgabe '<VERNAME>' verwendet einen Treiber ohne Prozesskopplung! | Die Rückmeldevariable muss auf einen prozessgekoppelten Treiber liegen.
(<AUFVAR>) Befehlsgabe '<VERNAME>' enthält nach der Kompilierung keine Aktionen! | Eine Befehlsgruppe ohne Aktionen ist nicht sinnvoll.
(<AUFVAR>) Rückmeldevariable '<VARRM>' von Befehlsgabe '<VERNAME>' nicht vorhanden! | Die verwendete Rückmeldevariable ist nicht vorhanden oder als gelöscht markiert.
(<AUFVAR>) Befehlsgabe '<VERNAME>' verwendet Bild '<Bild GUID>'(<BILDNAME>) welches nicht vom Typ Power ist! | Diese Meldung ist eine Warnung. Wenn bei der Ausführung eine Bedienhandlung nötig wird, kann diese nicht durchgeführt werden.
(<AUFVAR>) Befehlsgabe '<VERNAME>' verwendet nicht vorhandenes Bild '<Bild GUID>'! | Das der Befehlsgruppe zugeordnete Bild existiert nicht.
(<AUFVAR>) Ersetzte Aktionsvariable '<ACTVAR>' für Aktion '<Aktionsbezeichnung>' von Befehlsgabe '<VERNAME>' nicht vorhanden! | Die Aktionsvariable ist nach Ersetzungen nicht vorhanden oder als gelöscht markiert.
(<AUFVAR>) Aktion '<Aktionsbezeichnung>' bei Befehlsgabe '<VERNAME>' verwendet die nicht existierende Variable '<ACTVAR>' | Die Aktion verwendet eine Variable, die im Projekt nicht vorhanden oder als gelöscht markiert ist.
(<AUFVAR>) Aktionsvariable '<ACTVAR>' für Aktion '<Aktionsbezeichnung>' von Befehlsgabe '<VERNAME>' verwendet einen Treiber ohne Prozesskopplung! | Die einer Aktion zugeordnete Variable darf auf keinen internen Treiber liegen.
<VERNAME>(<AUFVAR>): Aktion '<Aktionsbezeichnung>' existiert bereits! | Pro Aktionsvariable dürfen folgende Aktionen nur einmal pro Befehlsgruppe projektiert sein: Doppelbefehl mit gleichen Befehlsgabezustand. Nachführen mit gleicher Schaltrichtung. Ersetzen mit gleicher Schaltrichtung. Revision mit gleicher Schaltrichtung. Einzelbefehl Sollwertvorgabe Freigeben Blockieren Sperre
<VERNAME>(<AUFVAR>): Aktion '<Aktionsbezeichnung>': Einzel- und Doppelbefehl für gleiche Befehlsvariable nicht möglich! | Einzel- und Doppelbefehl dürfen nicht gemeinsam verwendet werden.
(<AUFVAR>) Aktion '<Aktionsbezeichnung>' bei Befehlsgabe '<VERNAME>' verwendet Bild '<Bild GUID>('<Bildname>') welches nicht vom Typ Power ist! | Diese Meldung ist eine Warnung. Es werden keine Bedienhandlungen möglich sein.
(<AUFVAR>) Aktion '<Aktionsbezeichnung>' bei Befehlsgabe '<VERNAME>' verwendet nicht vorhandenes Bild '<Bild GUID>'! | Der Aktion ist ein nicht vorhandenes Bild zugeordnet.
<VERNAME>(<AUFVAR>): Verriegelungs-PV '<VARNAME>' existiert nicht! | Ersetzte Bedingungsvariable existiert nicht.
(<AUFVAR>) Variable '<VARNAME>' von Aktionsverriegelungsbedingung der Befehlsgabe '<VERNAME>' existiert nicht! | Variable der Verriegelungsbedingung nicht vorhanden.
(<AUFVAR>) Aktionsvariable '<VARANME>' der Aktion '<Aktionsbezeichnung>' von Befehlsgruppe '<VERNAME>' verwendet eine andere Befehlsgruppe! | Die bei einer Befehlsgruppe verwendeten Aktionsvariablen dürfen nur mit keiner oder der Befehlsgruppe wo sie verwendet werden verknüpft sein.
(<AUFVAR>) Befehlsvariable <ACTVAR> hat keine gültig kompilierte Verriegelung! Aktion <Aktionsbezeichnung> entfernt. | Die in der Aktion verwendete Aktionsvariable hat keine kompilierte Befehlsgruppe. Diese Meldung kann auch ein Folgefehler sein.
(<AUFVAR>) Befehlsvariable <ACTVAR> verwendet Rückmeldevariable <VARNAME>! Aktion <Aktionsbezeichnung> entfernt. | Die kompilierte Befehlsgruppe bei der Rückmeldevariable beinhaltet eine Aktionen, deren Aktionsvariable nicht die gleiche Rückmeldevariable wie <AUFVAR> verwendet. Hinweis: Bei der Rückmeldevariable dürfen keine Aktionen möglich sein, die andere Rückmeldevariablen verändern,


Bedienen zur Runtime

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Kommandoeingaben durch einen Benutzer zur Runtime wird im Hintergrund automatisch eine Laufzeitüberwachung durchgeführt.

Noch in diesem Kapitel

Ablauf Cause of Transmission (COT)

Kontrollelemente des Bildtyps Befehlsgabe

Nachladen

Protokollierung in der CEL

Rückmeldevariable sperren

Serverwechsel im Redundanzbetrieb

Laufzeit beenden


Ablauf Cause of Transmission (COT)

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Ablauf Cause of Transmission (COT)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Übertragungsursache (COT) informiert zenon die Steuerung, ob die Variable geschrieben werden soll beziehungsweise, ob das Schreiben erfolgreich war. Die Aktionsvariable erhält entsprechend der Stufe des Befehls eine COT. Im Hintergrund überprüft dann das Modul Befehlsgabe, ob die Rückmeldevariable ihren Wert und den COT entsprechend dem Kommando ändert.

Der Ablauf im Hintergrund:

  1. Der Wert und COT_act (6) wird auf die Aktionsvariable abgesetzt.
  2. Auf die Rückmeldevariable wird das Statusbit PROGRESS gesetzt.
  3. Erhält die Steuerung den Wert COT_act, wird auf die Folgewerte COT_actcon (7) oder COT_actterm (10) gewartet.
  4. Beenden des Ablaufs:
    1. Der Ablauf wird beendet, wenn beide folgende Bedingungen erfüllt wurden:
    • COT_actterm wurde empfangen

      und

    • der Wert der Rückmeldevariablen entspricht der Schaltrichtung (Eigenschaft Rückmeldezustand/Schaltrichtung).
      Welche der beiden Bedingungen zuerst eintritt, ist ohne Bedeutung. Sobald beide vorhanden sind, wird der Ablauf beendet.

      Interne ID: Ablauf Cause of Transmission (COT)

      Rückmeldezustand/Schaltrichtung

      Nicht verfügbar bei den Aktionen: Blockieren, Sperre und Freigeben.
      Definiert den erwarteten Wert bzw. Status der Rückmeldevariable nach Aktionsausführung. Die möglichen Eingaben unterscheiden sich je nach Aktion .
      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. Wird nur eine oder keine der beiden Bedingungen aus Punkt 5a innerhalb der projektierten Time-out Zeit erfüllt, dann wird:
      - der Ablauf beendet und
      - das Statusbit TIMEOUT der Rückmeldevariable aktiviert
  5. Das Statusbit PROGRESS wird zurückgesetzt.

Hinweis: Wertänderungen der Rückmeldevariablen werden erst nach Erhalt von COT_act akzeptiert.

info Info

COT können zur Laufzeit - so wie auch alle anderen Statusbits - über Multi-Numerische oder Multi-Binäre Reaktionsmatrizen ausgewertet werden.

Hinweis: COT wird nicht nur von IEC870, sondern auch auch von einigen anderen Energy Treibern - in unterschiedlicher Ausprägung - unterstützt. Manche Treiber unterstützen COT, obwohl das Protokoll selbst keine COT beinhaltet (z.B. DNP3). Details finden Sie in der jeweiligen Treiberdokumentation.


Kontrollelemente des Bildtyps Befehlsgabe

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Kontrollelemente des Bildtyps Befehlsgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime stehen folgende Kontrollelemente zur Verfügung:

Bezeichner

Kontrolltyp

Default

Aktionsbuttons

Text

Buttons welchen eine Aktion zugeordnet werden kann. Durch anklicken im Bild wird die zugeordnete Aktion aktiviert und das Bild wechselt in den Schritt „Entriegelung“

Der Button wird nicht angezeigt wenn:

- Dem Button bei der aktuellen Befehlsgruppe keine Aktion zugeordnet ist.

- Die Variable mit welchem das Bild aufgeschaltet wurde die Befehlsvariable ist und die dem Button zugeordnete Aktion nicht die Befehlsvariable als Aktionsvariable verwendet. Wenn dem Button jedoch die Aktion „Sperre“ zugeordnet ist, ist er sichtbar.

Der Button wird gesperrt angezeigt wenn:

- Das Bild sich nicht im Schritt „Stufe 1“ befindet.

- Die Rückmeldevariable eines der Statusbit I_KENNUNG(18), AUS(20) oder NICHT_AKTUELL(29) gesetzt hat und die zugeordnete Aktion auf die Befehlsvariable schreibt.

- Die Rückmeldevariable den Status REVISION(9) aktiv hat und die zugeordnete Aktion auf die Befehlsvariable schreibt.

- Die Rückmeldevariable den Status REVISION(9) aktiv hat und die zugeordnete Aktion „Nachführen“ ist.

- Die zugeordnete Aktion „Freigeben“ ist und die Rückmeldevariable nicht den Status Ersatzwert(27) aktiv hat

- Die zugeordnete Aktion „Nachführen“ ist und der Wert der Rückmeldevariable der Schaltrichtung entspricht.

- Die zugeordnete Aktion „Ersetzen“ ist und der Wert der Rückmeldevariable der Schaltrichtung entspricht.

- Die Rückmeldevariable den Status REVISION(9) aktiv hat und die zugeordnete Aktion „Ersetzen“ ist.

- Die zugeordnete Aktion „Revision“ ist und der Wert der Rückmeldevariable der Schaltrichtung entspricht.

Aktion1

Aktion2

RM TTA

Text

Name der Rückmeldevariable

X

RM Kennung

Text

Kennung der Rückmeldevariable

X

Aktionsvariable Einheit

Text

Einheit der aktuellen Aktionsvariable.

X

Aktionsvariable Status setzen

Liste

Definiert den zu setzenden Status für die Aktion „Statusvorgabe“ für die Schaltrichtung „Keine“. Die Stati werden auf den aktuellen Zustand gesetzt und bei Änderung aktualisiert.

Ist gesperrt wenn die aktive Aktion nicht „Status setzen“ ist.

Schaltrichtung

Text

Die bei der aktiven Aktion projektierte Schaltrichtung. Die Texte sind bei der Einstellung „Schaltrichtung“ dokumentiert.

Je nach aktiver Aktion wird folgender Text angezeigt:

Befehl, Revision, Nachführen, Ersetzen: Text aus Grenzwert je nach Schaltrichtung.

Status: Ein oder Aus

Sonstige: leer

X

Ausführen Stufe 2

Button

Bringt die Aktion zur Ausführung.

Dieses Control ist nur sichtbar wenn das Bild sich in Schritt „Stufe 2“ befindet.

Das Control ist gesperrt wenn:

- Zweihandbedienung projektiert wurde und die Taste „Strg“ nicht gedrückt ist.

- Die Rückmeldevariable den Status REVISION(9) gesetzt hat und die aktive Aktion „Befehl“, „Sollwert“, „Ersetzen“ oder „Nachführen“ ist.

Der Button bereits angeklickt wurde.

X

Aktionsvariable Minimum

Numerisch

Minimumwert der Aktionsvariable.

Ist nicht sichtbar wenn die Aktionsvariable den Datentyp „String“ hat.

Aktionsvariable Maximum

Numerisch

Maximumwert der Aktionsvariable.

Ist nicht sichtbar wenn die Aktionsvariable den Datentyp „String“ hat.

Scrollbalken

Numerisch

Sollwertvorgabe mittels Scrollbalken. Setzt den Wert im Control „Sollwert“ bzw. wird von diesem gesetzt.

Ist nicht sichtbar wenn die Aktionsvariable den Datentyp „String“ hat.

Das Control ist gesperrt wenn:

- Keine Aktion aktiv ist.

- Das Bild nicht im Schritt „Stufe 1“ ist

Sollwert

Numerisch, Text

Ermöglicht die Eingabe des Sollwert.

Durch anklicken des Controls wird dieses in den Editiermode geschaltet und die Sollwerteingabe möglich. Mit Enter wird der Editiermode wieder verlassen.

Der neue Wert wird jedoch erst beim anklicken des Control „Ausführen“ gesetzt.

Für die Aktion „Sollwert“ wird mittels dieses Controls der zu setzende Wert vorgegeben

Das Control ist gesperrt wenn:

- Die Rückmeldevariable den Status REVISION(9) gesetzt hat.

- Keine Aktion aktiv ist.

- Das Bild nicht im Schritt „Stufe 1“ ist

RM Wert

Text

Wert der Rückmeldevariable

X

RM Status

Text

Enthält den Status der Rückmeldevariable in der Kurzformbenennung.

X

RM Einheit

Text

Einheit der Rückmeldevariable

X

Verriegelungstext

Text

Text der anstehenden Verriegelung.

Text ist Online sprachübersetzbar

X

Entriegeln

Bei anstehender, entriegelbarer Verriegelung kann mit diesem Button diese entriegelt werden.

Dieses Control wird nur angezeigt wenn das Bild sich im Schritt „Entriegeln“ befindet.

Das Control ist gesperrt wenn die anstehende Verriegelung nicht entriegelbar ist.

X

Beenden

Button

Schließt das Bild ohne Aktionsausführung.

Der Button ist nur in einem modalen Bild sichtbar.

Für modale Bilder ist dieser Button wichtig um das Bild im Fehlerfalle wieder verlassen zu können!

Abbruch

Button

Bricht den Ablauf der Befehlsgabe ab und kehrt in den Schritt „Stufe 1“ zurück.

Der Button ist gesperrt wenn das Bild im Schritt „Stufe 1“ ist.

X

Sperrliste

Liste

Enthält die bei der Rückmeldevariable aktivierten Sperren.

Ist gesperrt wenn die Befehlsgruppe keine Aktion „Sperre“ projektiert hat.

Text ist Online sprachübersetzbar

Benutzerkennung

Eingabefeld

Nimmt die Benutzerkennung für die Sperre auf.

Ist gesperrt wenn die Befehlsgruppe keine Aktion „Sperre“ projektiert hat.

Sperrcode

Eingabefeld

Für die Eingabe des benutzerspezifischen Sperrcode.

Ist gesperrt wenn die Befehlsgruppe keine Aktion „Sperre“ projektiert hat.

Sperre ausführen

Button

Aktiviert eine Sperre durch für den beim Control „Benutzerkennung“ angegeben Benutzer.

Ist gesperrt wenn die Befehlsgruppe keine Aktion „Sperre“ projektiert hat.

Diese Bedienhandlung wird, wenn durch die Projektierung nicht unterdrückt, in der CEL protokolliert.

Entsperren

Button

Entfernt die Sperre durch den bei Benutzerkennung angegeben Benutzer.

Ist gesperrt wenn die Befehlsgruppe keine Aktion „Sperre“ projektiert hat.

Diese Bedienhandlung wird, wenn durch die Projektierung nicht unterdrückt, in der CEL protokolliert.

Ausführen

Button

Wert von Control „Sollwert“ oder „Status setzen“ übernehmen.

Dieses Control ist nur sichtbar wenn das Bild sich im Schritt „Stufe 1“ befindet.

Das Control ist zusätzlich zu der generellen Sperre gesperrt wenn:

- Die aktive Aktion nicht „Status setzen“, „Sollwert“ oder „Nachführen Sollwert“ ist

- Der Wert im Control „Sollwert“ für die Aktionsvariable nicht gültig ist.

Bemerkung

Eingabefeld

Bemerkung zur Sperre.

Aktionsvariable Status

Text

Status der aktiven Aktionsvariable in Kurzformbenennung.

X

Aktionsvariable Name

Text

Name der aktiven Aktionsvariable.

X

Aktionsvariable Kennung

Text

Kennung der aktiven Aktionsvariable.

X

Aktionsvariable Wert

Text

Wert der aktiven Aktionsvariable.

X

Aktive Aktion

Text

Bezeichnung der aktiven Aktion.

X

Noch in diesem Kapitel

Blockierte oder gesperrte Elemente


Blockierte oder gesperrte Elemente

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Kontrollelemente des Bildtyps Befehlsgabe -> Blockierte oder gesperrte Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Generelle Sperre der Controls

Es sind einige Voraussetzungen zu erfüllen, damit die Controls im Bild freigeschaltet werden. Da diese zumeist mehrere Controls betrifft, werden diese nicht jedes mal beim Control angeführt, sondern hier dokumentiert.

  1. Alle Controls bis auf Beenden sind gesperrt wenn:
  • das Bild nicht Besitzer des aktiven Select ist
  • die Aufschaltvariable keine Verriegelung projektiert hat
  • die Rückmeldevariable nicht vorhanden ist
  • die Rückmeldevariable noch mit keinen Wert versorgt wurde
  • die Rückmeldevariable den Status „Select“ nicht gesetzt hat
  • eine Aktion für die Aktionsvariable läuft
  • eine Laufzeitüberwachung für die Aktionsvariable läuft
  • auf die SBO Bestätigung gewartet wird
  • die Daten der Sperre übertragen werden
  • die Daten der Sperre ungültig sind
  • für die selektierte Variable der Status INVALID aktiv ist
  • der aktuell angemeldete Benutzer nicht über die nötige Berechtigungsebene verfügt
  1. Alle Controls bis auf Beenden und die Controls für die Sperre sind gesperrt wenn:
  • eine der Sperrbedingungen von Punkt 1 aktiv ist
  • die Rückmeldevariable gegen Befehlsgaben gesperrt wurde
  • das Statusbit S_MERKER_1(0), also die Befehlssperre, bei der Rückmeldevariable gesetzt ist

Befehlsgabe

  • Aktionsbuttons: Aktionsbuttons werden gesperrt, wenn die Berechtigungsebene des angemeldeten Benutzers die Ausführung verbietet.
  • Entriegeln: Entriegelung ist nur möglich, wenn der Benutzer über die dafür nötige Berechtigungsebene verfügt.
  • Kontextmenü: Menüpunkte, die einer Befehlsgabe-Aktion zugeordnet sind, können nur ausgewählt werden, wenn der angemeldete Benutzer über die nötige Berechtigungsebene verfügt.

Aufschaltung des Bildes mit Initialstufe 'Sperre'

Wenn das Bild mit der Initialstufe „Sperre“ aufgeschaltet wird, werden alle bis auf die folgenden Controls im Bild ausgeblendet:

  • RM TTA
  • RM Kennung
  • RM Wert
  • RM Status
  • RM Maßeinheit
  • Sperrcode
  • Benutzerkennung
  • Sperre ausführen


Nachladen

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Nachladen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit folgenden Auswirkungen muss gerechnet werden, wird ein Online Nachladen angestoßen:

Wenn eine Laufzeitüberwachung, Flankenbildung oder SBO aktiv ist, wird das Nachladen so lange verzögert bis diese beendet sind.

Ein geöffnetes Bild vom Typ Befehlsgabe wird geschlossen und der Ablauf nach dem Nachladen in Abhängigkeit des aktuellen Schrittes wieder begonnen:

Schritt vor dem Nachladen | Verhalten nach dem Nachladen
Stufe 1 | Bild wird wieder für Stufe 1 aufgeschalten
Entriegelung oder Stufe 2 | Schritt Entriegelungsstufe wird aktiviert. Die Verriegelungsprüfung wird erneut ausgeführt.
Sperre | Sperre wird wieder aktiviert

Vor dem erneuten Aufschalten wird die Aufschaltvariable, Rückmeldevariable, Befehlsvariable, Befehlsgruppe und Aktion neu ermittelt. Wenn eines der Objekte nicht mehr vorhanden ist werden die Controls gesperrt.

Wenn bei der Aufschaltvariable die Befehlsgruppe entfernt oder getauscht wurde, wird das Bild mit gesperrten Controls aufgeschaltet. Das Bild ist dann erneut aufzuschalten bzw. die Befehlsgabe ist dann erneut auszuführen.

Wenn die Befehlsgruppe bei der Rückmeldevariable entfernt oder getauscht wurde, werden alle Sperren gegen Befehlsgabe von der Variablen entfernt.

Wenn ein Benutzer welcher eine Befehlssperre aktiviert hatte nicht mehr existiert, wird die Sperre entfernt. Das Statusbit S_MERKER_1(0) wird entsprechend aktualisiert.


Protokollierung in der CEL

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Protokollierung in der CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der CEL werden neben den Schaltaktionen folgende Benutzerhandlungen protokolliert.

Parameter | Beschreibung
Entriegeln | Das Entriegeln einer anstehenden Verriegelung wird in der CEL vermerkt.
Aktion ausführen | Wenn die Aktionseinstellung „CEL-Eintrag unterdrücken“ nicht aktiv ist, dann wird die Aktionsausführung in der CEL protokolliert.


Rückmeldevariable sperren

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Rückmeldevariable sperren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine gesperrte Rückmeldevariable hat das Statusbit S_MERKER_1(0) gesetzt. Durch Eingabe des Benutzernamen sowie dem bei der Benutzerdefinition projektierten Sperrcode kann die Sperre aktiviert oder deaktiviert werden. Pro Benutzer kann eine Sperre aktiviert werden. Die aktiven Sperren sind remanent und werden auch nach einem System Neustart wieter berücksichtigt.

info Info

Für die Sperren erfolgt eine automatische Synchronisation im Netzwerk, diese können daher auch im Redundanz Betrieb eingesetzt werden.


Serverwechsel im Redundanzbetrieb

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Serverwechsel im Redundanzbetrieb

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn der prozessführende Server sich ändert, geht das Selektobjekt verloren und die Befehlsgabe muss erneut ausgeführt werden. Das Gleiche gilt für das SBO.


Laufzeit beenden

Handbuch -> Energy Edition -> Befehlsgabe -> Bedienen zur Runtime -> Laufzeit beenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

So lange aktive Aktionen im System noch anstehen, wird das ordnungsgemäße beenden der Runtime (z.B. über einen Funktionsaufruf) verzögert.

Auch während der SBO Ablauf aktiv ist, wird das Beenden verzögert. Wenn SBO aktiv ist, wird eine Deaktivierung durchgeführt.

info Info

Speziell bei der Aktion „Einzelbefehl“ mit Laufzeitüberwachung und oder Flankenbildung bei einstufiger Ausführung, kann sich diese Situation ergeben. Die Laufzeit wird beendet nachdem die Aktion abgeschlossen wurde.


Energy Management System (EMS)

Handbuch -> Energy Management System (EMS)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Energy Management System ist ein Werkzeug zur Unterstützung der betriebswirtschaftlichen Betriebsführung. Es dient zur Umsetzung eines Energiebezugsmanagements bei kleinen bis mittleren Energieerzeugern, aber auch bei Industrieunternehmen, deren Energiebezug über Sonderverträge geregelt ist.

Das Modul inkludiert dabei zwei hochwertige Funktionalitäten zur Unterstützung des Anwenders:

  • Prognose (Kurzfristprognose): Zur Vermeidung von Lastspitzen und zur Automatisierung des Lastabwurfes.
  • Optimierung: Optimierung des gemittelten Energiebezuges einer Verrechnungsperiode.

Der Fokus liegt auf energietechnischen Anlagen, das Modul kann aber auch problemlos für Mischanlagen aus Strom- und Gasnetzen eingesetzt werden. Für Gasnetze wurden spezielle Prognose- und Optimierungsmodelle implementiert.

tutorial Lizenzinformation

Für Editor und Runtime lizenzpflichtig.

Kontextmenü Projektmanager

Menüpunkt | Aktion
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Einleitung

Funktionsweise des Gesamtsystems

Methode des EMS

Mehrstufige Blockheizkraftwerke (BHKWs)

Parametrierung des EMS

Interner Status der Komponenten

Erzeugen der Runtime-Dateien

Bedienen des EMS zur Runtime


Einleitung

Handbuch -> Energy Management System (EMS) -> Einleitung

Die Aufgabe eines Energy Management Systems (EMS) ist es, die wirtschaftliche Betriebsführung von Sondervertragskunden wie Energieversorgungsunternehmen (EVU) oder Industriebetrieben zu optimieren. Als wesentliche Hilfsmittel dazu werden Energie-Trendrechnungen eingesetzt, die als Basis für eine automatisierte Energiebezugsoptimierung dienen.

Die Situation in Elektrizitäts- und Gasnetzen unterscheidet sich teilweise wesentlich und bedingt daher in einem EMS eine unterschiedliche Betrachtung im Hinblick auf Prognose und Optimierung.

Noch in diesem Kapitel

Ausgangssituation im Elektrizitätsbereich

Ausgangssituation im Gasbereich

Ziele einer wirtschaftlichen Betriebsführung


Ausgangssituation im Elektrizitätsbereich

Handbuch -> Energy Management System (EMS) -> Einleitung -> Ausgangssituation im Elektrizitätsbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Elektrizitätsbereich kommt in der Regel ein Tarif zur Anwendung, der sowohl die vom Lieferanten getätigten Investitionen/Baukosten, als auch die anfallenden Kosten für die Energieerzeugung und Netzerhaltung berücksichtigt.

Zur Festlegung des Leistungspreises werden bei diesen Unternehmen daher in der Regel einige der im Jahr angefallenen höchsten Leistungen herangezogen. Die Ermittlung der gemittelten Leistung erfolgt in einer festgelegten Messperiode, üblicherweise 15 oder 30 Minuten. Ferner wird im Arbeitspreis die bezogene Energie verrechnet. Die auf dieser Basis geschlossenen Verträge sind im Normalfall langfristig gültig.


Ausgangssituation im Gasbereich

Handbuch -> Energy Management System (EMS) -> Einleitung -> Ausgangssituation im Gasbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Gasbereich lassen sich Lastspitzen durch Entnahmen aus Gasspeichern sowie durch Nutzung der Speichermöglichkeiten im Gasnetz (Druckanpassung) und umschaltbare bzw. abschaltbare Verbraucher kompensieren.

In Gasspeichern oder im Netz können dazu Gasmengen präventiv eingelagert werden, um diese bei Bedarf zu entnehmen. Dazu kommt der Einsatz von außervertraglich zur Verfügung gestellten Gaskontingenten, die als Spotgas bezeichnet werden.


Ziele einer wirtschaftlichen Betriebsführung

Handbuch -> Energy Management System (EMS) -> Einleitung -> Ziele einer wirtschaftlichen Betriebsführung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ziel der wirtschaftlichen Betriebsführung im Elektrizitäts- und Gasbereich ist es, vom Lieferanten möglichst viel Energie zum vertraglich festgelegten, möglichst niedrigen Leistungspreis zu beziehen (Optimierung).

Einsparungspotenzial ergibt sich in solchen Konstellationen durch das Vermeiden teurer Leistungsspitzen. Die Leistungsspitzen innerhalb einer Messperiode lassen sich durch gezielte regelnde Eingriffe reduzieren:

  • Lastabwurf bei schaltbaren Verbrauchern
  • Einsatz der Eigenerzeugung

Dazu ist es notwendig, die mittlere Leistung einer Messperiode vorherzusehen (Prognose). So lässt sich eine drohende Überschreitung der festgelegten Bezugsleistungsgrenze rechtzeitig erkennen und man kann entsprechend regelnd eingreifen.


Funktionsweise des Gesamtsystems

Handbuch -> Energy Management System (EMS) -> Funktionsweise des Gesamtsystems

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Strom- und Gasbereich funktionieren durchaus ähnlich. Da es aber technisch nicht möglich ist, Strom in nennenswerten Mengen zu speichern, sind die Vertragsbedingungen der Stromlieferung auf diesen Umstand abgestimmt.

Im Gasbereich müssen dagegen nicht nur die Vertragsbedingungen eingehalten werden, sondern es sind auch Maßnahmen zur Speicherung des Energieträgers erforderlich.

Noch in diesem Kapitel

Funktion des Systems im Strombereich

Funktion des Systems im Gasbereich

Grundsätzliche Überlegungen


Funktion des Systems im Strombereich

Handbuch -> Energy Management System (EMS) -> Funktionsweise des Gesamtsystems -> Funktion des Systems im Strombereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Versorgung mit elektrischer Energie beträgt die Messperiode oder Verrechnungsperiode in der Regel 15 oder 30 Minuten. In dieser Zeit wird die an den Übergabestellen erfasste mittlere Bezugsleistung (im folgenden als Leistung oder Last bezeichnet) bzw. die äquivalente Energiemenge ermittelt und verrechnet.

Der Leistungspreis richtet sich üblicherweise nach den höchsten 3 Werten, die für die Messperiode in unterschiedlichen Monaten angefallen sind. Der Leistungspreis ist dann über einen längeren Vertragszeitraum gültig.

Die zur Berechnung des Leistungspreises herangezogene mittlere Leistung, lässt sich reduzieren, wenn entstehende Lastspitzen durch gezielte Eingriffe begrenzt werden. Eingriffsmöglichkeiten bestehen für diese kurzfristige Bezugsoptimierung durch den Einsatz von:

  • Lastabwurf schaltbarer Verbraucher
  • Erhöhung der Eigenerzeugung

Das Ziel der Strombezugsoptimierung ist, die vertraglich festgelegte oder angestrebte Bezugsleistung (Soll-Leistung oder Grenzleistung) innerhalb einer Messperiode in keinem Fall zu überschreiten. Bei entsprechend hohem Leistungsbedarf soll diese aber auch nur wenig unterschritten werden, um ein Maximum an Energie zu beziehen.

Realisiert wird die Bezugsoptimierung durch eine Trendrechnung als Kurzzeitprognose. Mit den im Bearbeitungsintervall (meist 30, 60 oder 180 Sekunden) erfassten Messwerten wird dazu eine Trendanalyse durchgeführt und der ermittelte Trend bis zum Periodenende hochgerechnet.


Funktion des Systems im Gasbereich

Handbuch -> Energy Management System (EMS) -> Funktionsweise des Gesamtsystems -> Funktion des Systems im Gasbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Versorgung mit Gas beträgt die Messperiode in der Regel eine Stunde oder einen Tag. In dieser Zeit wird die an den Übernahmestellen ermittelte Gasmenge bewertet.

Auch hier ist bei Überschreitung der Grenze ein hoher Leistungspreis zu zahlen. Die Festlegung des Leistungspreises bei Überschreitung der vereinbarten Bezugsmenge ist aber viel spezifischer als im Strombereich geregelt.

Prinzipiell wird auch in Gasnetzen angestrebt, die vereinbarte Bezugsgrenze nicht zu überschreiten.

Eingriffsmöglichkeiten bestehen durch den Einsatz von:

  • Lastabwurf schaltbarer Verbraucher
  • Eigenerzeugung von Gas in Flüssiggasanlagen
  • Umschaltung von Heizkesseln auf andere Brennstoffe
  • Umschaltung der Blockheizkraftwerken auf andere Brennstoffe
  • Entnahme von Gas aus Speichern

Die Entnahme von Gas aus Speichern ist insofern bedeutsam, da möglicherweise nur kleine Mengen zur Disposition stehen, die aber zu den Spitzenzeiten vorhanden sein müssen. Unabhängig von der gespeicherten Menge muss auf jeden Fall eine Strategie für die Wiedereinspeicherung von Gas über kurze oder lange Zeiträume festgelegt werden.

Handlungsmöglichkeiten

Das Überschreiten der Bezugsgrenze wird bei Stundenverträgen durch eine Verbrauchshochrechnung mit Abschaltung oder Umschaltung der Verbraucher verhindert.

Auch eine Ausdehnung auf einen (Gas-)Tag ist prinzipiell möglich. Allerdings gibt es am Tag Zeitbereiche mit einem Trendverhalten, das zu unrealistisch großen Mengen am Tagesende führt. Darüber hinaus wird kein Ausgleich der Mengen zwischen Tag und Nacht berücksichtigt. Daher ist das System für diesen Fall so aufgebaut, dass:

  • eine Prognose des Verbrauches erfolgt
  • eine Planung erstellt wird, die sicher stellt, dass der vereinbarte Bezug nicht überschritten wird
  • eine Kurzfristhochrechnung überwacht, ob die eingeplanten Maximalmengen nicht überschritten werden


Grundsätzliche Überlegungen

Handbuch -> Energy Management System (EMS) -> Funktionsweise des Gesamtsystems -> Grundsätzliche Überlegungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf den folgenden Seiten finden Sie Überlegungen und Beispiele, die es Anwendern erleichtern, beeinflussbare Elemente Ihrer Anlage zu identifizieren und auszuwählen. Es geht um die Frage, welche Elemente oder Geräte durch ein EMS sinnvoll direkt oder indirekt beeinflusst werden können.

Noch in diesem Kapitel

Optionen zur Lastbeeinflussung im Strombereich

Optionen zur Lastbeeinflussung im Gasbereich

Lastcharakteristika der Verbraucher


Optionen zur Lastbeeinflussung im Strombereich

Handbuch -> Energy Management System (EMS) -> Funktionsweise des Gesamtsystems -> Grundsätzliche Überlegungen -> Optionen zur Lastbeeinflussung im Strombereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Option

Beschreibung

Direkt schaltbare Verbraucher

Zu dieser Gruppe gehören Verbraucher, die kurzzeitig abschaltbar sind, ohne Produktionsprozesse störend zu unterbrechen (Industrieöfen, Pumpen für Wasservorratsbehälter etc.).

Die Lasten haben einen festen Wert und sind üblicherweise vom Verbraucher abhängig und daher bekannt oder messbar.

Direktheizungen

Diese Verbraucher sind aufgrund ihres Speichereffektes ohne wesentliche Minderung der Versorgungsqualität kurzzeitig unterbrechbar (Heizungen in Warmwasserspeichern, elektrisch betriebene Fußbodenheizungen etc.).

Die Lasten bestehen aus einem konstanten und einem temperaturabhängigen Anteil. Die Last ist außerdem von der vorausgegangenen Abschaltdauer abhängig.

Monovalente Wärmepumpen

Diese Pumpen werden üblicherweise wie Direktheizungen betrieben.

Der temperaturabhängige Anteil ist stärker ausgeprägt und steigt mit fallender Außentemperatur (Pumpen zur Wärmeerzeugung inkl. Klimageräte) oder steigt mit ansteigender Außentemperatur (Klimageräte). Die Last ist von der vorhergegangenen Abschaltdauer abhängig.

Bivalente Wärmepumpen

Diese können unter den eingesetzten Brennstoffen wählen und werden unterhalb einer gewissen Temperatur von der eigenen Steuerung oder durch die Optimierung auf einen anderen Energieträger umgeschaltet.

Für die Verbraucher entstehen dabei keine Versorgungseinschränkungen. Da die Umschaltung nicht ständig erfolgen soll, werden diese Komponenten nur langfristig und restriktiv umgeschaltet.

Das Lastverhalten steigt bei fallender Temperatur bis zum Umschaltpunkt, um dann gänzlich zu verschwinden.

Nachtspeicherheizungen

Diese Verbraucher werden planmäßig oder nach der freien Leistung zur Niedertarifzeit mit Energie versorgt. Sie sind in der übrigen Zeit abgeschaltet.

Die Last ist wesentlich von der Außentemperatur abhängig. Es macht sich bemerkbar, wie viele Heizungen anspringen (begrenzt durch die installierte Leistung) und wie lange diese aufgeladen werden.

Spitzenlastaggregate und Notstromaggregate

Diese Aggregate können nach Bedarf zu und abgeschaltet werden. In einigen Fällen sind die Aggregate regelbar. Da der Anlauf mit zusätzlichen Kosten beim Verschleiß verbunden ist, sollte die Anzahl der Einsätze eingeschränkt werden. Außerdem sollten diese Aggregate nach der Einschaltung auch eine Mindestbetriebsdauer zur Vermeidung thermischer Schäden berücksichtigen.

Blockheizkraftwerke (BHKW)

Diese Aggregate werden vorrangig zur Wärmeerzeugung gebaut und werden beim Einsatz urch den Wärmebedarf geführt (Wärmevorrang).

Einige Aggregate sind auch direkt zur Stromerzeugung einsetzbar (Stromvorrang). Diese Betriebsweise ist, wenn nicht gleichzeitig die Wärme abgenommen wird, normalerweise unwirtschaftlich. Daher ist der Einsatz nur bei entsprechendem Wärmebedarf oder der Möglichkeit der Wärmespeicherung vorteilhaft.

Die Lastreduktion in Bezug auf die Übernahmestelle ist von den Nenngrößen und bei geregelten oder wärmegeführten Maschinen vom Arbeitspunkt der Aggregate abhängig.

Die Zusammenfassung von Aggregaten zu Gruppen ist durchaus üblich. Nach dem Wärmebedarf wird dann eine bestimmte Anzahl aus der Gruppe eingesetzt. Die maximale Leistungsabsenkung im Strombereich ist durch die Anzahl und Nennleistung der nicht eingesetzten Aggregate gegeben.

Spannungsabsenkung

Im Strombereich ist es in einigen Netzen möglich, die Spannung abzusenken. Dazu werden die Transformatoren zur Mittelspannungsebene auf eine niedrigere Stufe gestellt.

Die Spannungsabhängigkeit der Verbraucher (ohmsche Lasten) bewirkt hier einen anderen Lastbedarf, sofern nicht untergeordnete Regelungen die Spannung oder Leistung wieder angleichen.

Der Effekt in Form der Lastreduktion ist von der Netzlast, der möglichen Spannungsabsenkung (Minimalspannungen müssen eingehalten werden) und auch von der Verbraucherzusammensetzung abhängig.


Optionen zur Lastbeeinflussung im Gasbereich

Handbuch -> Energy Management System (EMS) -> Funktionsweise des Gesamtsystems -> Grundsätzliche Überlegungen -> Optionen zur Lastbeeinflussung im Gasbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Option | Beschreibung
Direkt schaltbare Verbraucher | Zu dieser Gruppe gehören die Verbraucher, die kurzzeitig ausschaltbar sind, ohne irgendwelche Produktionsprozesse störend zu unterbrechen.
Heizkessel oder Blockheizkraftwerkaggregate | Diese sind je nach Bauart auf einen anderen Brennstoff (z.B. von Gas auf Öl) umschaltbar.
Gasspeicher | Diese stehen je nach Unternehmen in unterschiedlichsten Größen zur Verfügung. Auch das Rohrnetz kann bei entsprechendem Volumen, meist verbunden mit der geografischen Ausdehnung und geeigneten Betriebsweise, als Speicher verwendet werden. Für den Ausgleich von Spitzen kann dann Gas aus Speichern entnommen werden.


Lastcharakteristika der Verbraucher

Handbuch -> Energy Management System (EMS) -> Funktionsweise des Gesamtsystems -> Grundsätzliche Überlegungen -> Lastcharakteristika der Verbraucher

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Rekonstruktion des eigentlich geforderten Lastbedarfs müssen für das Lastverhalten der abgeschalteten Komponenten Modelle verwendet werden, die unterschiedlichen Klassen zugeordnet werden können.

Art | Beschreibung
Konstante Leistung | Beim Einschalten läuft ein Aggregat (Pumpe, Ofen) mit definierter Leistungsaufnahme an. Entsprechend reduziert sich beim Ausschalten der Verbrauch direkt um die Leistungsaufnahme. In diesem Fall ist die Angabe der Nennleistung als Konstante ausreichend.
Direkt temperaturabhängig | Eine Temperaturabhängigkeit der Verbraucher ist direkt von den Witterungseinflüssen abhängig und steigt bei Wärmeleistung etwa proportional zum negativen Gradienten der Außentemperatur. In Bezug auf Kühlleistung kehrt sich das Verhalten um.
Ladezeitmodell | Dabei macht sich die Temperatur einerseits in der Höhe der Einschaltleistung bemerkbar und andererseits durch die Länge der darauffolgenden Ladezeit bis zum Abfall der Leistung, wenn alle Wärmespeicher aufgeladen sind.
Abhängigkeit von der Ausschaltdauer | Dabei werden abhängig von der vorausgegangenen Ausschaltdauer - infolge der zwischenzeitlichen Auskühlung oder Erwärmung - mehr oder weniger viele Verbraucher eingeschaltet, die sich dann nach kurzer Zeit wieder ausschalten.
Abhängigkeit vom Produktionsprozess | Im Industriebereich kann es, bedingt durch Produktionsprozesse, zu Verhalten kommen, die keinem Verhaltensmuster oder Abhängigkeiten unterliegen und die nur durch die Produktionsfahrpläne bestimmt sind.


Methode des EMS

Handbuch -> Energy Management System (EMS) -> Methode des EMS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das EMS für elektrische Energie (Strom) basiert auf einer Zeitreihenanalyse, wobei der bisher gemessene Leistungsverlauf analysiert und in die Zukunft extrapoliert wird. Der Prognosehorizont des EMS entspricht der Restzeit in der jeweiligen Messperiode.

Noch in diesem Kapitel

Eingangswerte

Das Modell der Kurzfristprognose

Arbeitsweise der Bezugsregelung

Überlagerung von Fahrplaneingaben


Eingangswerte

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Eingangswerte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das EMS erwartet als Eingangswert einen Zählwert oder Rechenwert, der von den Treibern geliefert oder in zenon als Ergebnis einer mathematischen Formel gebildet wird.

Achtung: Es muss sicher gestellt werden, dass dieser im Aktualisierungsintervall genau einmal geliefert wird. Es dürfen keine Werte fehlen und keine Werte doppelt geliefert werden.

Die Dimension: MW, kW , kWh oder m3

Das System ist ausgelegt auf Basis von kW und Stunde. Daher sind die in allen Parametrierungsmasken geforderten Leistungen und Energiemengen auf diese Größe und Dimension bezogen. Die EMS-Funktionen rechnen intern aber dimensionsfrei. Daher ist es eigentlich unbedeutend, in welcher Dimension die Werte angeliefert und interpretiert werden, solange diese auf die gleiche Basis bezogen sind. Es kann als Basiseinheit kW oder MW angesetzt werden.

Im Gasbereich kann anstelle der Energiemengen auch mit Norm m3 gerechnet werden. Dabei muss aber auch hier die Vergleichbarkeit der Kubikmeter gegeben sein, was nur durch die Norm und nicht durch die Betriebskubikmeter gegeben ist. Die Umrechnung der Kubikmeter in Energiemengen und deren zeitlicher Bezug ist nicht notwendig.

info Info

Da das EMS bei Ausfällen eine Komponente darstellt, die große Kosten verursachen kann, ist die Sicherung der Eingangswerte besonders wichtig. Es empfiehlt sich, durch den Einsatz von sinnvollen Ersatzwerten bzw. durch eine Ersatzwertstrategie diese Werteingänge für das Modul sicher zu stellen.


Das Modell der Kurzfristprognose

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Das Modell der Kurzfristprognose

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für eine Hochrechnung des momentanen Leistungsverlaufes ist es notwendig, ein mathematisches Modell des Leistungsverlaufes zu bilden. Durch Extrapolation des Leistungsverlaufes mit diesem Modell über die Restzeit der laufenden Verrechnungsperiode wird der erwartete Leistungswert am Periodenende geschätzt.

Leistungstrend

Zur Zeit des Periodenendes T ist die Leistung P prog (T) zu ermitteln. Für die Ermittlung des momentanen Leistungstrends wird eine lineare Funktion in Form eines Polygones ersten Grades angesetzt, die bis zum Periodenende extrapoliert wird.

P prog (T) = P konst (t) + P trend (t) * ( T - t )

Die mathematisch anzusetzenden Polygonkoeffizienten p0, p1 sind hier zum leichteren Verständnis nach Ihrer physikalischen Bedeutung benannt.

Koeffizient | Beschreibung
P prog | prognostizierter Leistungswert
P konst | Leistungskonstante (Höhe der letzten Werte)
P trend | Leistungstrend (linearer Anstieg/Abfall)
T | Zeitpunkt des Endes des Messintervalls
t | aktueller Zeitpunkt

Energietrend

Daraus abgeleitet ergibt sich der Energietrend bis zum Periodenende E (T) durch die Funktion

E prog (T) =P mittel (t) * t + P konst (t) * (T - t) + ½ * P trend (t) * (T - t)

Koeffizient | Beschreibung
E prog | prognostizierter Energiewert
P mittel | Leistungsmittelwert (aus Zählwert)

Der erste Summand stellt die bis zum Zeitpunkt t ermittelte Energie dar. Diese kann, wie in der Formel, über den Leistungsmittelwert gegeben sein, oder auch als direkt ermittelter Energiewert E (t).

Der zweite Summand schreibt die bisherige konstante Leistung bis zum Periodenende fort und ermittelt daraus den konstanten Energieanteil.

Der dritte Summand beschreibt den zusätzlichen Einfluss aus dem Trend.

Bezüglich der Energieberechnung für die eigentliche Verrechnung ist ein Wert erforderlich, der am Messperiodenanfang exakt zurück gesetzt wird. Es ist daher nicht möglich, extern gefilterte Werte dafür zu verwenden.

Aus der obigen Formel ist der Mittelwert am Periodenende bestimmbar:

P prog mittel (T) = E prog (T) / T

Parameter | Beschreibung
P prog mittel | Prognostizierter mittlerer Leistungswert

Noch in diesem Kapitel

Berechnung der Korrekturleistung

Istwert- und Realwertprognose

Absenkung der Bezugsgrenze


Berechnung der Korrekturleistung

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Das Modell der Kurzfristprognose -> Berechnung der Korrekturleistung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Innerhalb der laufenden Messperiode darf bei einzuhaltender mittleren Leistung

P grenz = Bezugsgrenze

bezogen werden, was über der Messperiode T der Energiemenge

E grenz = P grenz * T

entspricht.

Durch Vergleich dieser Energie mit der am Periodenende erwarteten Energie E prog (T) ist die energiemengenmäßige Über-/Unterschreitung des Bezuges

E korr = E prog (T) - E grenz

ermittelbar, die bei Überschreitung durch entsprechende Schaltungen auszugleichen ist, und die bei Unterschreitung ausgeglichen werden kann.

Dabei ist zu beachten, dass zum Zeitpunkt t nur noch die Restzeit (T - t) verfügbar ist. Damit wird eine größere Korrekturleistung

P korr (t) = E korr / (T - t)

erforderlich.


Istwert- und Realwertprognose

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Das Modell der Kurzfristprognose -> Istwert- und Realwertprognose

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Prognose wird im EMS Modul für mehrere Trends durchgeführt.

  • Der erste Trend wird über den Bezug gelegt. Dieser Trend bestimmt als Istwertprognose den Anstieg des Lastbedarfs.
  • Ein zweiter Trendfaktor berücksichtigt die in der Vergangenheit erfolgten Schaltungen.
  • Ein dritter Trendfaktor ermittelt den Einfluss der in der Zukunft erfolgenden Schaltungen.

Die Trendfunktionen werden übereinandergelegt und ergeben die Realwertprognose. Diese beschreibt, den eigentlich zu erwartenden Lastverlauf zum Ende der Verrechnungsperiode.


Absenkung der Bezugsgrenze

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Das Modell der Kurzfristprognose -> Absenkung der Bezugsgrenze

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da der Lasttrend nie ganz exakt vorausgesagt werden kann und sich auch Abweichungen bei den Annahmen für die schaltbaren Lasten einstellen, ist es notwendig, den eigentlichen Bezugssollwert aus Sicherheitsgründen etwas zu unterschreiten.

Daher ist bei der Parametrierung eine Sicherheitsabstand [%] in Prozent vorgesehen, um den die Bezugsgrenze im Minimum unterschritten werden muss, damit Zuschaltungen ausgelöst werden.

Interne ID: Absenkung der Bezugsgrenze

Sicherheitsabstand [%]

Sicherheitsabstand zur Bezugsgrenze in Prozent. Der Sicherheitsabstand wird auch von den Eigenschaften Hysterese Zuschalten [%] und Hysterese Abschalten [%] beeinflusst.

Interne ID: Absenkung der Bezugsgrenze

Hysterese Abschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Zuschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Absenkung der Bezugsgrenze

Hysterese Zuschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Abschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Default: 0

Achtung: Wird der Bereich zu groß dimensioniert, kann eventuell die Bezugsgrenze überschritten werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um diese Grenze kann durch Hysterese Zuschalten [%] und Hysterese Abschalten [%] eine Hysterese aufgebaut werden. Dabei eliminiert Hysterese Zuschalten [%] einen Teil der Sicherheitsabstand [%].

attention Achtung

Achten Sie unbedingt darauf, dass Hysterese Zuschalten [%] in jedem Fall kleiner als der Sicherheitsabstand [%] gewählt wird. Anderenfalls reagiert das System zu spät auf die Überschreitungen der Bezugsgrenze.


Arbeitsweise der Bezugsregelung

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Arbeitsweise der Bezugsregelung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Closed Loop Betrieb

Die Bezugsregelung wird im Regelfall im Closed Loop Betrieb eingesetzt. Dabei werden Aufgrund der Ergebnisse des Optimierungsteils Zu- und Abschaltungen berechnet. Die Schaltungen werden direkt durch die entsprechenden Schaltbefehle ausgelöst.

info Info

Im EMS Modul müssen nicht die unmittelbaren Schaltpunkte bei den Geräten verwendet werden. Der Anwender kann sich applikativ entscheiden, ob er direkte Schaltungen ermöglichen möchte oder diese erst durch den Benutzer endgültig freigegeben werden.

attention Achtung

Der unkontrollierte Einsatz des Closed Loop Betriebes in einer unbesetzten Umgebung erfordert eine intensive Erprobungsphase. Dabei müssen alle von der Regelung durchgeführten Schaltungen vom Bediener kontrolliert werden. Eine solche Erprobungsphase ist auf Größe und Komplexität des Systems abzustimmen. Es kann, durchaus erforderlich sein, den Erprobungszeitraum bis zu einem Jahr auszudehnen.

Noch in diesem Kapitel

Leistungsermittlung der Verbraucher

Schaltungsablauf


Leistungsermittlung der Verbraucher

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Arbeitsweise der Bezugsregelung -> Leistungsermittlung der Verbraucher

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Leistungsermittlung der Verbraucher ist in Bezug auf die Beurteilung des durch Schaltungen erwarteten Effektes besonders bedeutend. Problematisch ist, dass die Leistung der abgeschalteten Verbraucher üblicherweise nicht direkt messbar ist und teilweise nur geschätzt werden kann.

Im System sind zwei Mechanismen zur Leistungsermittlung realisiert

  • Vorgabe eines festen Wertes durch Parametrierung.

    Der Wert (z.B. die Nennleistung) wird von der Optimierung als fest angesehen und ist immer verfügbar.

  • Messung des aktuellen Wertes.

    Eine Messung ermittelt diesen Wert und zenon bildet ihn mittels einer Prozessvariable in den Geräten ab.

Der Anfangswert für die Leistung des Verbrauchers wird durch eine gezielte Abfrage des Variablenwerts beim Start der Optimierung bestimmt. Um Fehler durch Schwankungen zu kompensieren, errechnet die Optimierung aus den nachfolgend eintreffenden Messwerten einen gleitenden Mittelwert.

info Info

Ist eine Komponente beim Start der Optimierung ausgeschaltet, ist deren Leistungswert Null. Daher kann von der SCADA-Funktion kein gültiger Leistungswert als Voraussetzung für den Komponenteneinsatz ermittelt werden. Die Komponente muss einmal von Hand eingeschaltet werden.

attention Achtung

Solange nicht mindestens ein Wert eingetroffen ist, ist der Leistungswert für die Komponente nicht bekannt und kann für die Optimierung nicht verwendet werden.

Noch in diesem Kapitel

Primäre Faktoren

Sekundäre Faktoren


Primäre Faktoren

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Arbeitsweise der Bezugsregelung -> Leistungsermittlung der Verbraucher -> Primäre Faktoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Energiemenge

Entscheidend für die Verbraucherauswahl ist grundsätzlich die abzuschaltende/zuzuschaltende Energiemenge.

Ist die geforderte Energiemenge nicht exakt schaltbar, wird sie bei einer Abschaltanforderung als Minimalwert und bei einer Zuschaltanforderung als Maximalwert betrachtet. Damit liegt man hinsichtlich der Einhaltung der Bezugsgrenze auf der sicheren Seite.

info Info

Die Energiemenge kann auch während der Runtime durch eine Prozessvariable dynamisch angepasst werden.

Verfügbarkeit

Die Verfügbarkeit steuert, ob der Verbraucher generell einsetzbar ist. Die Verfügbarkeit kann mit der Hand gesetzt werden und wird immer dann zurückgenommen, wenn die Komponente betriebsbedingt nicht einsetzbar ist (z.B. bei Revisionen) oder nicht von der Optimierung eingesetzt werden soll.

Auch Bedingungen, die sich aus dem Prozess ergeben, können über die Verfügbarkeit der Komponente deren Einsatzmöglichkeit in der Optimierung steuern.

info Info

Die Verfügbarkeit kann auch zur Runtime durch eine Prozessvariable dynamisch angepasst werden. So können z.B. durch einen Scheduler oder Production & Facility Scheduler auch Fahrpläne bezüglich der Verfügbarkeit realisiert werden.


Sekundäre Faktoren

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Arbeitsweise der Bezugsregelung -> Leistungsermittlung der Verbraucher -> Sekundäre Faktoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sperrzeiten und Freigabezeiten der Verbraucher

Mit den Sperrzeiten lässt sich steuern, zu welchen Zeiten die Komponenten der Optimierung nicht zur Verfügung stehen. Die Zeiten, die nicht als Sperrzeiten ausgewiesen sind, stellen die Freigabezeiten dar.

attention Achtung

Die Komponenten werden innerhalb der Sperrzeiten nicht von der Optimierung beeinflusst - oder nur in der freigegebenen Richtung. Daher verbleiben die Komponenten in dem Zustand, den sie am Ende der Freigabezeit erreicht haben.

Minimal- und Maximalschaltzeiten

Zu jedem einsetzbaren Verbraucher und Erzeuger kann die Minimal- und Maximalzeit für die einzelnen Schaltzustände (Ein/Aus) angegeben werden. Die Zeit gibt an, welche Zeitdauer mindestens verstreichen muss, bis eine Schaltung in Gegenrichtung ausgelöst werden kann.

Wichtig ist der Parameter für Aggregate, da zur Vermeidung thermischer Schäden und Verrußungen diese nach dem Einschalten nicht unmittelbar wieder abgeschaltet werden dürfen. So muss zum Beispiel nach dem Aktivieren der diverser Heizungsgruppen eine gewisse Zeit verstreichen, damit diese überhaupt einschalten.

Schalthäufigkeit

Sind Verbraucher und Erzeuger in einem gewissen Zeitraum nur begrenzt häufig schaltbar, so werden für die Komponente bei Überschreiten der Anzahl keine weiteren Schalthandlungen mehr ausgeführt. Zur Parametrierung muss neben der Anzahl auch ein Zeitbereich angegeben werden.

Example Beispiel

Maximal 25 Schaltungen in 12 Stunden

Schaltprioritäten

Die Schaltungen der Komponenten werden nach einem Prioritätenschema geplant. Dabei werden Zuschalt- und Abschaltpriorität gesondert geführt. Die Prioritäten können vom Benutzer nach Betriebserfordernissen festgelegt werden. Eine Komponente mit der höchsten Priorität (höchster numerischen Wert) wird zuerst geschaltet.

Besteht die Anforderung, Komponenten in geordneter Reihenfolge zu schalten, indem der zuerst eingeschaltete Verbraucher als letzter wieder ausgeschaltet wird, so ist über alle Komponenten ein Nummernschema zu legen: aufsteigend für erste Einschaltung und absteigend für letzte Ausschaltung .

info Info

Sind in einer Anlage für mehrere Geräte die gleichen Prioritätsstufen vergeben, stellt das EMS Modul automatisch sicher, dass im Mittel alle Geräte gleicher Stufe einer identen Anzahl von Schalthandlungen unterzogen werden.


Schaltungsablauf

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Arbeitsweise der Bezugsregelung -> Schaltungsablauf

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Begriff Abschaltanforderung seitens der Optimierung bezieht sich immer auf die Reaktion des Verbrauchers, der durch seine Abschaltung den Lastbedarf und damit die Bezugsleistung senkt. Die Abschaltanforderung kann dementsprechend auch durch die Einschaltung eines Aggregates erfüllt werden.

Abläufe bei einer Schaltung

Verzögerungszeit für das Einschalten (Einschalttotzeit)

Entspricht der Zeit von der Ausgabe des Schaltbefehles bis zum Erreichen der Nennleistung.

Die Zeit bis zum Erreichen der Last kann - abhängig vom Gerät - beträchtlich sein, z. B. Aggregathochlauf und Synchronisation, rückwärtsgesteuerte Heizungen etc.

Verzögerungszeit für das Ausschalten (Ausschalttotzeit)

Zeit von der Ausgabe des Schaltbefehles bis zum vollständigen Abfall der Leistung. Auch hier muss die Zeit für die Befehlsausgabe zur Zeit bis zum vollständigen Leistungsabfall addiert werden.

Vorwarnzeit für Ein und Ausschalten (Länge vorwarnzeit)

Die Schaltzeiten werden zum exakten Ausregeln der Energiemengen auf Sekunden genau geplant. Damit dem Benutzer Gelegenheit gegeben wird, die Zeiten im Open Loop Betrieb auch einzuhalten, ist eine gewisse Vorlaufzeit zur Durchführung der Schaltung erforderlich. Diese wird durch die Länge Vorwarnzeit definiert. Hierdurch erhält der Bediener die Information über durchzuführende Schaltungen, noch bevor diese ausgeführt werden müssen.

Interne ID: Schaltungsablauf

Länge Vorwarnzeit

Zeit, im Format hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Schaltvorwarnung kann vom System eine Vorwarnung für den Benutzer ausgegeben werden, damit der Benutzer informiert wird, bevor es zur eigentlichen Schalthandlung kommt.

Interne ID: Schaltungsablauf

Schaltvorwarnung

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Da das EMS Modul von der Durchführung der Schaltungen ausgeht, sollten im Hinblick auf die Genauigkeit des Prognoseergebnisses die vorgeschlagenen Schaltungen zeitgerecht ausgeführt werden.

Taktik der Schaltungsplanung

Die Schaltungsauswahl geschieht generell so, dass möglichst wenig Schaltungen durchzuführen sind. Dies beruhigt den Netzbetrieb und erhält die Verfügbarkeit der Verbraucher, die, durch einen Maximalwert in der Schaltungszahl begrenzt, eingesetzt werden dürfen. Ferner werden Konflikte bei der Befehlsausgabe der Schaltungen minimiert.

Der Einsatz von Komponenten mit viel größerer Leistung als für die Korrektur notwendig, ist durch eine gezielte Zeitsteuerung möglich. Die Komponenten werden so kurzzeitig eingesetzt, dass diese die geforderte Energie kompensieren.

Schaltungsunterdrückung am Anfang der Messperiode

Am Anfang einer Messperiode werden gegebenenfalls größere Schaltungen durchgeführt oder zum Ausgleich der Energiemengen am Periodenende große Abweichungen zum eigentlichen Leistungsmittelwert eingestellt. Es ist daher notwendig, dem System am Anfang der Messperiode Gelegenheit zu geben, sich an die neuen Verhältnisse anzupassen.

Daher ist im System eine Totzeit Beginn Tarifintervall parametrierbar. In dieser Zeit werden keine Schalthandlungen durch die Optimierung ausgelöst.

Interne ID: Schaltungsablauf

Totzeit Beginn Tarifintervall

Zeit in hh:mm:ss am Anfang eines Verrechnungsintervalls. In diesem Zeitraum werden keine Schalthandlungen durch die Optimierung vorgenommen, da die Prognoseergebnisse noch zu ungenau sind.

Default: 00:00:00

Maximalwert: 23:59:59

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Erfolgt über einen längeren Zeitraum keine Rückmeldung auf einen durch das EMS ausgeführten Schaltbefehl (auf der Rückmeldevariable), geht dieses von einer fehlerhaften Aktion aus und wird versuchen, eine weitere Schalthandlung (am nächsten zur Verfügung stehenden Gerät) auszuführen. Es ist daher immer sicher zu stellen, dass die korrekten Rückmeldungen über den Erfolg der Schaltaktion an das EMS übermittelt werden.


Überlagerung von Fahrplaneingaben

Handbuch -> Energy Management System (EMS) -> Methode des EMS -> Überlagerung von Fahrplaneingaben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Schaltung von Aggregaten und Verbrauchern nach festen Zeiten über den Scheduler oder den Production & Facility Scheduler ist bei vielen Anwendungen notwendig. Da keine explizite Kopplung zwischen diesen Modulen und der Kurzfristoptimierung existiert, werden diese Schaltungen in ihrer Auswirkung bezüglich des Leistungstrends nicht überwacht und auch nicht im Trend des Leistungsbezuges dargestellt. Sie wirken hinsichtlich des Ergebnisses störend in der Kurzfristoptimierung.

Damit sich diese Störungen nicht drastisch auswirken, sollten externe Schaltungen so parametriert werden, dass diese am Periodenwechsel stattfinden. Ist dies nicht möglich, sind diese unmittelbar nach Periodenwechsel einzuplanen, damit der Störeinfluss auf die Regelung noch kompensiert werden kann. Derartige Schaltungen sollten innerhalb der Totzeit Beginn Tarifintervall abgeschlossen sein und die Auswirkung der Schaltung auf den Eingangszählwert sollten vorliegen.

Interne ID: Überlagerung von Fahrplaneingaben

Totzeit Beginn Tarifintervall

Zeit in hh:mm:ss am Anfang eines Verrechnungsintervalls. In diesem Zeitraum werden keine Schalthandlungen durch die Optimierung vorgenommen, da die Prognoseergebnisse noch zu ungenau sind.

Default: 00:00:00

Maximalwert: 23:59:59

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Mehrstufige Blockheizkraftwerke (BHKWs)

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mehrstufige BHKWs können als eine Komponente betrachtet werden. Es sind BHKWs von 2 bis n Stufen modellierbar.

Die Steuerung der BHKWs erfolgt über einen Sollwert. Zusätzlich können verschiedene Leistungsstufen definiert werden, die dieser Sollwert annehmen kann. Die tatsächliche Leistung des BHKWs wird über einen Messwert (Prozessvariable) erfasst und an das EMS zurückgesendet.

attention Achtung

Ein BHKW ist erst bei Erreichen der Nennleistung für das EMS verfügbar. Durch Projektierung wird das Verfügbarkeitsflag entsprechend gesetzt. Das BHKW kann vom EMS nicht ausgeschaltet, sondern nur auf Nennleistung zurückgefahren werden.

Noch in diesem Kapitel

Sollwert Verarbeitung bei BHKWs

Schaltplanungen bei BHKWs

Prioritäten von BHKWs

Zeitabhängige Restriktionen bei BHKWs

Handschaltungen bei BHKWs


Sollwert Verarbeitung bei BHKWs

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs) -> Sollwert Verarbeitung bei BHKWs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Menge der Werte, die der Sollwert annehmen kann, entspricht der Anzahl der definierten Leistungsstufen. Der Wert, der durch den Sollwert angenommen werden kann, entspricht immer genau einem der definierten Werte für die Leistungsstufen. Der Sollwert wird vom EMS mit keiner anderen Zahl belegt.

Die Initialisierung erfolgt mit der aktuell gemessenen Leistung. Falls dieser Wert keine definierte Stufe trifft, wird die vom Wert her nächst kleinere Stufe angenommen. Das BHKW gilt jedoch als nicht verfügbar, solange die gemessene Leistung keiner Stufe entspricht. Bei einer Störung der gemessenen Leistung ist das BHKW nicht verfügbar und der Sollwert wird erst bei Eintreffen eines gültigen Messwertes initialisiert.

Da eine gemessene Leistung nicht unbedingt genau einem Sollwert entsprechen muss, wird eine Hysterese um den Sollwert definiert. Eine Stufe gilt dann als erreicht oder eingestellt, sobald ein aktueller Leistungswert in dem Hysteresebereich um den gegebenen Sollwert liegt. Die Hysterese kann pro BHKW separat definiert werden.

Bei der Belegung des Sollwertes dürfen die definierten Stufen nicht übersprungen werden. Der Sollwert wird also vom EMS nur auf die nächst höhere oder niedrigere Stufe eingestellt.

Eine Sollwertgabe erfolgt nur, wenn das BHKW zu diesem Zeitpunkt eine eindeutige Stufenstellung (unter Berücksichtigung der Hysterese) aufweist. Andernfalls ist das BHKW nicht verfügbar, da die gemessene Leistung keiner Stufe entspricht.


Schaltplanungen bei BHKWs

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs) -> Schaltplanungen bei BHKWs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Einplanung von Sollwertgaben für ein BHKW sind die Bedingungen für die Sollwertgabe zu beachten. Sind zur Abdeckung der Last mehrere Stufen eines BHKWs notwendig, darf beim Abfahren des Schaltplans immer nur von einer Stufe auf die nächste geschaltet werden. Dazu müssen die Sollwertgaben auf die einzelnen Stufen unter Berücksichtigung der Verzögerungszeiten für das Ab- oder Zuschalten von Stufen eingeplant werdenn.

attention Achtung

Es ist zu berücksichtigen, dass auch Vorwarnungen nur bei einer definierten Stufenstellung gegeben werden. Deswegen muss man die Länge der Vorwarnzeit für die einzelnen Stufen bei den Schaltplanungen beachten.


Prioritäten von BHKWs

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs) -> Prioritäten von BHKWs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein BHKW hat eine fest definierte Einschalt- und Ausschaltpriorität. Die Werte können auch über Prozessvariablen gesteuert werden, so dass Prioritäten flexibel gesteuert werden können. Die Übernahme einer neuen Priorität erfolgt dann zum nächsten Tarifintervallwechsel.

Die Prioritäten werden nicht für jede Stufe unterschiedlich festgelegt, sondern gelten für das ganze BHKW.

Wenn mindestens zwei BHKWs die gleiche Priorität besitzen, wird das rollierende Prioritätenverfahren angewandt. Eine wichtigere Bedingung für diese BHKWs mit gleicher Priorität ist, dass sie möglichst auf die gleichen Stufen eingestellt sind, bzw. sich höchstens um eine Stufe unterscheiden. Voraussetzung dafür ist, dass sowohl die Einschaltprioritäten als auch die Ausschaltprioritäten dieser BHKWs gleich sind.

Der interne Referenzzähler für die Schalthäufigkeit wird bei BHKWs beim Einschalten hochgezählt. Das trifft genau dann zu, wenn der aktuelle Leistungswert von einer Leistungsstufe in die nächst größere Stufe übergeht. Bei Stromverbrauchern wird der Referenzzähler beim Ausschalten der Komponente inkrementiert. Somit wird innerhalb einer Prioritätenstufe das Hin und Herschalten zwischen zwei Blockheizkraftwerkstufen mit dem Ein und Ausschalten eines Verbrauchers verglichen.


Zeitabhängige Restriktionen bei BHKWs

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs) -> Zeitabhängige Restriktionen bei BHKWs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

BHKWS bedürfen einer speziellen Behandlung im Hinblick auf deren Zeitverhalten. Spezielle Anforderungen müssen zu den Laufzeiten bei einem Stufenwechsel und bei der Verzögerungszeit durch das EMS berücksichtigt werden.

Noch in diesem Kapitel

Laufzeiten nach Stufenwechsel

Ablauf der Verzögerungszeit


Laufzeiten nach Stufenwechsel

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs) -> Zeitabhängige Restriktionen bei BHKWs -> Laufzeiten nach Stufenwechsel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die minimalen und maximalen Laufzeiten eines BHKWs müssen pro Stufe festgelegt werden. Anstatt von vier Zeiten für eine Komponente (minimale Einschaltzeit, minimale Ausschaltzeit, maximale Einschaltzeit, maximale Ausschaltzeit) gibt es für die Modellierung der BHKWs mit Stufen nur noch die beiden Zeiten für die minimale und maximale Laufzeit (Einschaltzeit) je Stufe.

Die minimale Laufzeit (Einschaltzeit) einer Stufe gibt an, welche Zeit das BHKW mindestens auf dieser Stufe laufen muss. Nach Erreichen einer Stufe muss die Optimierung mindestens diese Zeitspanne warten, bis eine neue Sollwertgabe für die nächst kleinere Stufenstellung erfolgen kann.

Die maximale Laufzeit einer Stufe gibt an, wie lange ein BHKW mit dieser Stufe höchstens laufen darf. Mit Ausnahme der niedrigsten Stufe (Nennleistung), wird das BHKW nach Ablauf dieser Zeit eine Stufe zurück geschaltet. Dabei gilt eine Stufe auch als aktiv, wenn das BHKW tatsächlich auf einer höheren Stufe fährt. Die maximalen Laufzeiten der einzelnen Stufen müssen hinsichtlich anderer Restriktionen (minimale Laufzeiten, Vorwarnungen) aufeinander abgestimmt sein, so dass ein rechtzeitiges Zurückschalten auf eine niedrigere Stufe möglich ist. Die Optimierung muss auch Sollwertgaben auf eine höhere Stufe unterdrücken, wenn die maximale Laufzeit z.B. aufgrund der minimalen Laufzeit der höheren Stufe nicht mehr eingehalten werden kann.

info Info

Durch Handschaltungen kann es eventuell zu Verletzungen der vorgegebenen Restriktionen kommen, die vom EMS nicht abgefangen werden können.

Für die niedrigste Stufe (Nennleistung) hat die maximale Laufzeit eine andere Bedeutung als für die übrigen Stufen. Die maximale Laufzeit der niedrigsten Stufe gibt an, wie lange das BHKW auf dieser Stufe höchstens alleine laufen darf. Danach muss das BHKW auf die nächst höhere Stufe eingestellt werden.

Beispiel für die Parametrierung der einzelnen Stufen:

Stufe | 0 | 1 | 2 | 3 | 4
Leistung | 100 | 200 | 300 | 400 | 500
minimale Einschaltzeit (in Sekunden) | -- | 60 | 60 | 60 | 60
Vorwarnzeit (in Sekunden) | -- | 210 | 0 | 0 | 0
Verzögerungszeit Zuschalten (in Sekunden) | -- | 30 | 30 | 30 | 30
Verzögerungszeit Abschalten (in Sekunden) | -- | 30 | 30 | 30 | 30
Minimaler Wert für die maximale Einschaltzeit (in Sekunden) | 210 | 240 | 180 | 120 | 60

Die anzugebenden Zeiten in der Parametrierung für das Ab- bzw. Zuschalten beziehen sich immer auf die Stufe, für die sie angegeben werden. Das heißt, eine Abschaltzeit die für eine Stufe parametriert ist, wird berücksichtigt, wenn von dieser Stufe auf die niedrigere Stufe zurück "geschaltet" wird. Eine Zuschaltzeit wird berücksichtigt, wenn auf diese Stufe, von einer niedrigeren Stufe, hoch "geschaltet" wird.

Da die niedrigste Stufe den Lauf des BHKWs mit Nennleistung repräsentiert, sind hier keine Angaben für die minimale Laufzeit, die Vorwarnzeit, sowie für die Verzögerungszeit Zuschalten und die Verzögerungszeit Abschalten erforderlich.

Die minimal zulässigen Werte für die maximalen Einschaltzeiten der jeweiligen Stufen ergeben sich wie folgt:

  • Bei der ersten Stufe:

    Vorwarnzeit der nächst höheren Stufe

  • Bei der letzten Stufe:

    maxi/minimale Einschaltzeit, Vorwarnzeit der letzten Stufe

  • Bei allen anderen Stufen:

    maxi/minimale Einschaltzeit, Vorwarnzeit der nächst höheren Stufe

    + Verzögerungszeit Zuschalten der nächst höheren Stufe

    + minimaler Wert für die maximale Einschaltzeit der nächst höheren Stufe

    + Vorwarnzeit der nächst höheren Stufe

    + Verzögerungszeit Abschalten der nächst höheren Stufe

Falls bei einem BHKW die maximale Einschaltzeit einer Stufe unter dem errechneten minimalen Wert für die maximale Einschaltzeit liegt, wird das BHKW als nicht verfügbar behandelt und eine entsprechende Verfügbarkeitskennung für die Einsatzbereitschaft gesetzt.


Ablauf der Verzögerungszeit

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs) -> Zeitabhängige Restriktionen bei BHKWs -> Ablauf der Verzögerungszeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Sollwert bleibt auf einer Stufe eingestellt, bis diese Stufe erreicht ist oder die definierte Verzögerungszeit abgelaufen ist. Im letzteren Fall wird der Sollwert bezüglich der aktuell gemessenen Leistung neu initialisiert. Dabei muss geprüft werden, auf welche Stufe die aktuelle Leistung trifft. Folgende Fälle sind zu beachten:

  • Der aktuelle Leistungswert entspricht der alten Stufe:

    Der Sollwert hatte keine Wirkung und wird auf den alten Wert zurückgesetzt.

  • Der aktuelle Wert entspricht keiner Stufe:

    Es kann geprüft werden, ob sich die aktuelle Leistung dem neuen Sollwert genähert hat.
    In diesem Fall kann der eingestellte Sollwert beibehalten werden, andernfalls muss dieser neu initialisiert werden.

  • Der aktuelle Wert entspricht einer anderen Stufe:

    Die Leistung des BHKWs hat sich entgegen der Sollwertgabe verhalten. Dieses entspricht einer Handschaltung trotz Verfügbarkeit für das EMS. Für das weitere Vorgehen siehe Handschaltungen.

Schaltplanungen auf die nächsten Stufen, müssen überarbeitet bzw. ausgetauscht werden, wenn ein vorher eingestellter Sollwert einer Schaltung für ein BHKW nicht erreicht wird. Bei weiteren Schalthandlungen werden andere Komponenten bevorzugt eingesetzt.


Handschaltungen bei BHKWs

Handbuch -> Energy Management System (EMS) -> Mehrstufige Blockheizkraftwerke (BHKWs) -> Handschaltungen bei BHKWs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Falls ein Messwert der aktuellen Leistung sich ohne Sollwertgabe außerhalb der vom EMS eingestellten Stufe bewegt, wird die Komponente als nicht verfügbar angenommen, da sie offensichtlich zu dieser Zeit nicht vom EMS regelbar ist.

Tritt ein Messwert der aktuellen Leistung wieder in den Hysteresebereich einer definierten Leistungsstufe, so wird der Unterschied zum eingestellten Sollwert festgestellt und eine Differenz bei der Stufeneinstellung als Handschaltung angenommen. Der Sollwert wird auf die neu erkannte Stufe eingestellt.

Eine erkannte Handschaltung wird zur Prognose übertragen, damit diese in der Trendberechnung berücksichtigt werden kann.


Parametrierung des EMS

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die EMS Projektierung erfolgt über eine hierarchische Baumansicht, in der den einzelnen Objekten abhängig von ihrem Typ entsprechende Unterobjekte hinzugefügt werden können. Unterobjekte werden durch Auswahl des entsprechenden Menüeintrags im Kontextmenü des gewählten Knotens hinzugefügt.

Alle Objekten verfügen über die Eigenschaften Name und Kennung. Die Parametrierung der einzelnen Objekte erfolgt über das Eigenschaften-Fenster.

Interne ID: Parametrierung des EMS

Kennung

Optionale Eingabe eines längeren Namens oder einer detaillierten Beschreibung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Parametrierung des EMS

Name

Eindeutige Bezeichnung zur Identifizierung von Geräten, Gebieten und Anlagen im EMS.

Achtung: Namen sollten über alle Netze/Versorgungsgebiete im EMS eindeutig sein.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alle im Eigenschaften-Fenster einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

info Info

Alle genannten bzw. gezeigten Einstellungen sind nur bei lizenziertem EMS Modul sichtbar. Das lizenzierte EMS Modul ist ein eigenes Element im Projektbaum. Über diesen Eintrag können die Einstellungen im EMS Modul vorgenommen werden.

attention Achtung

Innerhalb des EMS Moduls sollten alle vorhandenen Einheiten (Netze, Verbrauchergruppen, Erzeuger, Verbraucher etc.) eindeutige Namen bekommen, um eine einwandfreie Funktion der Prognose und Optimierung zu gewährleisten.

Alle Objekte verfügen über folgende Menüeinträge:

Menü/Eintrag | Erklärung
Ausschneiden | Ausgewählte(s) Objekt(e) ausschneiden und in die Zwischenablage kopieren.
Kopieren | Ausgewählte(s) Objekt(e) in die Zwischenablage kopieren.
Einfügen | Objekt(e) aus Zwischenablage einfügen. Eingefügt werden können jeweils nur Objekte der gleichen oder direkt untergeordneten Ebene in der Objektstruktur, ausgehend vom ausgewählten Knoten.
Löschen | Ausgewählte(s) Objekt(e) inklusive aller Unterobjekte löschen.
XML exportieren alle… | Gesamte Projektierung in XML-Datei exportieren.
Selektierte XML exportieren… | Selektierte Objekte inklusive Unterobjekte in XML Datei exportieren.
XML importieren… | Objekte aus XML Datei importieren. Importiert werden können jeweils nur Objekte (sowie deren exportierte Unterobjekte) der dem ausgewählten Knoten direkt untergeordneten Ebene in der Objektstruktur.
info Info
Alle Prozessvariablenwerte, die im EMS Modul für die Angabe/Anpassung von Zeitwerten während der Runtime (z.B. Min. Einschaltzeit Variable) zur Anwendung kommen, werden als Sekundenwerte interpretiert. Ein numerischer Wert von 300 würde also einer Zeitspanne von 5 Minuten entsprechen (=300 Sekunden).

Um eine korrekte Funktionalität des EMS zu gewährleisten, müssen für ein Versorgungsgebiet mindestens folgende Variablen angelegt werden:

  • Aktueller Verbrauch

    Interne ID: Parametrierung des EMS

    Aktueller Verbrauch

    Variable, die den aktuellen Wert des Gebietsverbrauchs beinhaltet. Der Wert muss die Zählerdifferenz pro Zeiteinheit der Summe der Verbräuche des Versorgungsgebietes darstellen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Achtung: Stellen Sie sicher, dass der Wert zyklisch übertragen wird, da er die kurzfristige Optimierungsrechnung auslöst.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Bezugsgrenze

    Interne ID: Parametrierung des EMS

    Bezugsgrenze

    Variable, die die aktuell eingestellte Bezugsleistungsgrenze enthält. Ändert sich ihr Wert zur Runtime, wird auch die Bezugsleistungsgrenze für eine Verrechnungsperiode geändert. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Startverbrauch Prognose

    Interne ID: Parametrierung des EMS

    Startverbrauch Prognose

    Variable, die den den Startwert der Prognosegeraden am Anfang des Prognosezeitraums enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Erster Schaltwert

    Interne ID: Parametrierung des EMS

    Erster Schaltwert

    Variable, die den errechneten Bezugsmittelwert, zu dem die nächste Schalthandlung ausgeführt wird, enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Achtung: Diese Variable muss für den Intern Treiber projektiert werden, um eine einwandfreie Funktion zu gewährleisten.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Prognose Fehlerbereich

    Interne ID: Parametrierung des EMS

    Prognose Fehlerbereich

    Variable, die den möglichen Prognosefehler des Prognoseendwertes enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Endverbrauch Prognose

    Interne ID: Parametrierung des EMS

    Endverbrauch Prognose

    Variable, die den Endwert der Prognosegerade zum Ende der Verrechnungsperiode enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Letzter Schaltwert

    Interne ID: Parametrierung des EMS

    Letzter Schaltwert

    Variable, die die Summe der Bezugsmittelwerte, zu denen in der aktuellen Periode noch Schaltaktionen geplant sind, enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Achtung: Diese Variable muss für den Intern Treiber projektiert werden, um eine einwandfreie Funktion zu gewährleisten.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ist-Abweichung brutto

    Interne ID: Parametrierung des EMS

    Ist-Abweichung brutto

    Variable für die mittlere Abweichung der Realwertprognose. Diese entspricht der Differenz zwischen prognostiziertem Mittelwert der Realwertprognose und der Bezugsleistungsgrenze. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ist-Abweichung netto

    Interne ID: Parametrierung des EMS

    Ist-Abweichung netto

    Variable für die mittlere Abweichung der Istwertprognose. Diese entspricht der Differenz zwischen prognostiziertem Mittelwert der Istwertprognose und der Bezugsleistungsgrenze. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Im Kontextmenü für ein Versorgungsgebiet finden man die Option "Variablen anlegen". Diese erzeugt bei Auswahl automatisch Variablen für die oben gelisteten Properties und verknüpft diese gleichzeitig mit den Eigenschaften.

Folgende Variablen müssen für ein Erzeuger/Verbraucher mindestens angelegt werden um eine korrekte Funktionalität des EMS zu gewährleisten:

  • Schaltzustand beim Verbraucher

    Interne ID: Parametrierung des EMS

    Schaltzustand

    Variable, die den aktuellen Schaltzustand des Verbrauchers liefert (EIN oder AUS). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Schaltzustand beim Erzeuger

    Interne ID: Parametrierung des EMS

    Schaltzustand

    Variable, an die der aktuelle Schaltzustand des Erzeugers (AUS oder EIN) geschickt werden sollt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Verfügbarkeitsflag

    Interne ID: Parametrierung des EMS

    Verfügbarkeitsflag

    Variable, die angibt, ob der Erzeuger für das EMS verfügbar ist, und somit geschalten werden kann. Ist die Verfügbarkeit gegeben, verbleibt der Erzeuger in seinem zuletzt gültigen Schaltzustand. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Minimalanforderungen

EMS Detailansicht Symbolleisten und Kontextmenüs

Daten für das EMS

Netze

Versorgungsgebiet

Verbrauchergruppe

Erzeuger

Verbraucher

Gasnetz spezifische Elemente

Sperrzeiten

Anlegen eines Prozessbildes

Projektieren der Bild-Umschaltfunktion

Funktionen Start/Stopp anlegen

Schaltvorschau projektieren


Minimalanforderungen

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Minimalanforderungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Versorgungsgebiet

Für die korrekte Funktionalität des EMS müssen für ein Versorgungsgebiet mindestens folgende Variablen angelegt werden:

  • Aktueller Verbrauch

    Interne ID: Minimalanforderungen

    Aktueller Verbrauch

    Variable, die den aktuellen Wert des Gebietsverbrauchs beinhaltet. Der Wert muss die Zählerdifferenz pro Zeiteinheit der Summe der Verbräuche des Versorgungsgebietes darstellen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Achtung: Stellen Sie sicher, dass der Wert zyklisch übertragen wird, da er die kurzfristige Optimierungsrechnung auslöst.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Bezugsgrenze

    Interne ID: Minimalanforderungen

    Bezugsgrenze

    Variable, die die aktuell eingestellte Bezugsleistungsgrenze enthält. Ändert sich ihr Wert zur Runtime, wird auch die Bezugsleistungsgrenze für eine Verrechnungsperiode geändert. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Startverbrauch Prognose

    Interne ID: Minimalanforderungen

    Startverbrauch Prognose

    Variable, die den den Startwert der Prognosegeraden am Anfang des Prognosezeitraums enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Erster Schaltwert

    Interne ID: Minimalanforderungen

    Erster Schaltwert

    Variable, die den errechneten Bezugsmittelwert, zu dem die nächste Schalthandlung ausgeführt wird, enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Achtung: Diese Variable muss für den Intern Treiber projektiert werden, um eine einwandfreie Funktion zu gewährleisten.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Prognose Fehlerbereich

    Interne ID: Minimalanforderungen

    Prognose Fehlerbereich

    Variable, die den möglichen Prognosefehler des Prognoseendwertes enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Endverbrauch Prognose

    Interne ID: Minimalanforderungen

    Endverbrauch Prognose

    Variable, die den Endwert der Prognosegerade zum Ende der Verrechnungsperiode enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Letzter Schaltwert

    Interne ID: Minimalanforderungen

    Letzter Schaltwert

    Variable, die die Summe der Bezugsmittelwerte, zu denen in der aktuellen Periode noch Schaltaktionen geplant sind, enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Achtung: Diese Variable muss für den Intern Treiber projektiert werden, um eine einwandfreie Funktion zu gewährleisten.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ist-Abweichung brutto

    Interne ID: Minimalanforderungen

    Ist-Abweichung brutto

    Variable für die mittlere Abweichung der Realwertprognose. Diese entspricht der Differenz zwischen prognostiziertem Mittelwert der Realwertprognose und der Bezugsleistungsgrenze. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ist-Abweichung netto

    Interne ID: Minimalanforderungen

    Ist-Abweichung netto

    Variable für die mittlere Abweichung der Istwertprognose. Diese entspricht der Differenz zwischen prognostiziertem Mittelwert der Istwertprognose und der Bezugsleistungsgrenze. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Im Kontextmenü für ein Versorgungsgebiet finden Sie die Option Variablen anlegen. Diese erzeugt automatisch Variablen für die oben gelisteten Eigenschaften und verknüpft sie mit diesen. Ausgenommen sind die Eigenschaften Aktueller Verbrauch und Bezugsgrenze, diese müssen manuell angelegt werden.

Erzeuger/Verbraucher

Für die korrekte Funktionalität des EMS müssen für einen Erzeuger/Verbraucher mindestens folgende Variablen angelegt werden:

  • beim Erzeuger
    • Schaltzustand

      Interne ID: Minimalanforderungen

      Schaltzustand

      Variable, an die der aktuelle Schaltzustand des Erzeugers (AUS oder EIN) geschickt werden sollt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

      Mehr im Online Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Standby-Leistung Variable
      oder Wert für Eigenschaft Standby-Leistung

      Interne ID: Minimalanforderungen

      Standby-Leistung

      Geben Sie hier die Nennleistung des Erzeugers ein.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Minimalanforderungen

      Standby-Leistung Variable

      Dieser Variablenwert überschreibt zur Laufzeit den fix projektierten Wert der Nennleistung. Damit kann die aktuell erbrachte Nennleistung eines Erzeugers während der Laufzeit angepasst werden, zum Beispiel wenn der Leistungswert über einen Messpunkt erfasst wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • beim Verbraucher
    • Schaltzustand

      Interne ID: Minimalanforderungen

      Schaltzustand

      Variable, die den aktuellen Schaltzustand des Verbrauchers liefert (EIN oder AUS). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Nennleistung Variable
      oder Wert für Eigenschaft Nennleistung

      Interne ID: Minimalanforderungen

      Nennleistung

      Nennleistung des Verbrauchers in kW.

      Dieser Wert kann über Zuweisung einer Variablen in der Eigenschaft Nennleistung Variable zur Runtime dynamisch angepasst werden.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Minimalanforderungen

      Nennleistung Variable

      Die aktuell bezogene Nennleistung eines Verbrauchers kann während der Laufzeit über eine Variable angepasst werden, z.B. wenn der Leistungswert über einen Messpunkt erfasst wird. Dieser Variablenwert überschreibt zur Runtime den fix projektierten Wert der Nennleistung. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • beim Erzeuger und Verbraucher
    • Verfügbarkeitsflag

      Interne ID: Minimalanforderungen

      Verfügbarkeitsflag

      Variable, die angibt, ob der Erzeuger für das EMS verfügbar ist, und somit geschalten werden kann. Ist die Verfügbarkeit gegeben, verbleibt der Erzeuger in seinem zuletzt gültigen Schaltzustand. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


EMS Detailansicht Symbolleisten und Kontextmenüs

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> EMS Detailansicht Symbolleisten und Kontextmenüs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eintrag | Aktion
Neu | Erzeugt ein neues Objekt, abhängig von der Position im Baum.
Gasnetz neu | Erzeugt ein neues Gasnetz.
Kopieren | Kopiert ausgewähltes Element in Zwischenablage.
Einfügen | Fügt Objekte aus Zwischenablage ein.
Löschen | Löscht ausgewähltes Element nach Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert alle ausgewählten Elemente in eine XML-Datei.
XML importieren… | Importiert Objekte aus XML-Datei.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Ruft die EMS Online Hilfe auf.

Kontextmenü Netze

Eintrag | Aktion
Stromnetz neu | Erzeugt ein neues Stromnetz.
Gasnetz neu | Erzeugt ein neues Gasnetz.
Einfügen | Fügt Objekte vom Typ Netz ein.
XML exportieren alle... | Exportiert alle definierten Netze in eine XML-Datei.
XML importieren… | Importiert Objekte vom Typ Netz.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Ruft die EMS Online Hilfe auf.

Weitere Kontextmenüs:

Stromnetze

Gasnetze

Noch in diesem Kapitel

Stromnetze

Gasnetze


Stromnetze

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> EMS Detailansicht Symbolleisten und Kontextmenüs -> Stromnetze

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Netz_Strom

Eintrag | Aktion
Versorgungsgebiet neu | Legt ein neues Versorgungsgebiet an.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Gasspeicher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Versorgungsgebiet

Eintrag | Aktion
Erzeuger neu | Legt einen neuen Erzeuger im selektierten Versorgungsgebiet an.
Verbrauchergruppe neu | Erstellt eine neue Verbrauchergruppe im Versorgungsgebiet.
Variablen anlegen | Legt automatisch alle minimal erforderlichen Variablen für das selektierte Versorgungsgebiet an und verknüpft sie mit den passenden Eigenschaften.
Ausschneiden | Ohne Funktion beim Versorgungsgebiet.
Kopieren | Kopiert das aktuell selektierte Versorgungsgebiet. Das Kopieren mehrerer Versorgungsgebiete über Multiselekt ist möglich.
Einfügen | Eingefügt werden können Objekte vom Typ Versorgungsgebiet.
Löschen | Löscht das aktuell selektierte Versorgungsgebiet. Das Löschen mehrerer Versorgungsgebiete über Multiselekt ist möglich.
Selektierte XML exportieren... | Exportiert das aktuell selektierte Versorgungsgebiet. Das Exportieren mehrerer Versorgungsgebiete über Multiselekt ist möglich.
XML importieren … | Importiert werden können Objekte vom Typ Versorgungsgebiet.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Erzeuger (Gruppe)

Eintrag | Aktion
Erzeuger neu | Legt neue Erzeuger für das aktuell selektierte Versorgungsgebiet an.
Einfügen | Fügt Objekte vom Typ Erzeuger ein.
XML exportieren alle... | Exportiert alle Erzeuger des Versorgungsgebietes.
XML importieren… | Importiert Objekte vom Typ Erzeuger.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Erzeuger

Eintrag | Aktion
Erzeuger neu | Legt neue Erzeuger für das aktuell selektierte Versorgungsgebiet an.
Einfügen | Fügt Objekte vom Typ Erzeuger ein.
XML exportieren alle... | Exportiert alle Erzeuger des Versorgungsgebietes.
XML importieren… | Importiert Objekte vom Typ Erzeuger.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Verbrauchergruppen (Gruppe)

Eintrag | Aktion
Verbrauchergruppe neu | Legt eine neue Verbrauchergruppe an.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe ein
XML exportieren alle... | Exportiert die Verbrauchergruppe inklusive aller in der Gruppe definierten Verbraucher.
XML importieren… | Importiert Objekte vom Typ Verbrauchergruppe.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Verbrauchergruppe

Eintrag | Aktion
Verbraucher neu | Legt einen neuen Verbraucher in der selektierten Verbrauchergruppe an.
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Verbraucher

Eintrag | Aktion
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.


Gasnetze

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> EMS Detailansicht Symbolleisten und Kontextmenüs -> Gasnetze

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Netz_Gas

Eintrag | Aktion
Versorgungsgebiet neu | Legt ein neues Versorgungsgebiet an.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Gasspeicher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Versorgungsgebiet

Eintrag | Aktion
Gasspeicher neu | Legt einen neuen Gasspeicher im selektierten Versorgungsgebiet an.
Flüssiggasanlage neu | Legt eine neue Flüssiggasanlage im selektierten Versorgungsgebiet an.
Verbrauchergruppe neu | Erstellt eine neue Verbrauchergruppe im Versorgungsgebiet.
Variablen anlegen | Legt automatisch alle minimal erforderlichen Variablen für das selektierte Versorgungsgebiet an und verknüpft sie mit den passenden Eigenschaften.
Kopieren | Kopiert das aktuell selektierte Versorgungsgebiet. Das Kopieren mehrerer Versorgungsgebiete über Multiselekt ist möglich.
Einfügen | Eingefügt werden können Objekte vom Typ Versorgungsgebiet.
Löschen | Löscht das aktuell selektierte Versorgungsgebiet. Das Löschen mehrerer Versorgungsgebiete über Multiselekt ist möglich.
Selektierte XML exportieren... | Exportiert das aktuell selektierte Versorgungsgebiet. Das Exportieren mehrerer Versorgungsgebiete über Multiselekt ist möglich.
XML importieren … | Importiert werden können Objekte vom Typ Versorgungsgebiet.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Gasspeicher

Eintrag | Aktion
Gasspeicher neu | Legt einen neuen Gasspeicher für das ausgewählte Versorgungsgebiet an.
Einfügen | Fügt Objekte vom Typ Erzeuger ein.
XML exportieren alle... | Exportiert alle Erzeuger des Versorgungsgebietes.
XML importieren… | Importiert Objekte vom Typ Erzeuger.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Flüssiggasananlagen

Eintrag | Aktion
Flüssiggasanlage neu | Legt eine neue Flüssiggasanlage für das ausgewählte Versorgungsgebiet an.
Einfügen | Fügt Objekte vom Typ Erzeuger ein.
XML exportieren alle... | Exportiert alle Erzeuger des Versorgungsgebietes.
XML importieren… | Importiert Objekte vom Typ Erzeuger.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Verbrauchergruppen

Eintrag | Aktion
Verbrauchergruppe neu | Legt eine neue Verbrauchergruppe an.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe ein
XML exportieren alle... | Exportiert die Verbrauchergruppe inklusive aller in der Gruppe definierten Verbraucher.
XML importieren… | Importiert Objekte vom Typ Verbrauchergruppe.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Verbrauchergruppe

Eintrag | Aktion
Gasspeicher neu | Legt einen neuen Gasspeicher im selektierten Versorgungsgebiet an.
Flüssiggasanlage neu | Legt eine neue Flüssiggasanlage im selektierten Versorgungsgebiet an.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Gasspeicher (Gruppe)

Eintrag | Aktion
Gasspeicher neu | Legt einen neuen Gasspeicher an.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Gasspeicher

Eintrag | Aktion
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Gasspeicher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Flüssiggasananlagen (Gruppe)

Eintrag | Aktion
Flüssiggasanlage neu | Legt einen neuen Flüssiggasanlage an.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Flüssiggasananlage

Menü/Eintrag | Erklärung
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Flüssiggasanlage ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert werden können Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Kontextmenü Verbraucher

Eintrag | Aktion
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
Eigenschaften | Öffnet das Eigenschaften-Fenster.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.


Daten für das EMS

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Daten für das EMS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das EMS benötigt zur Trendrechnung und Optimierung eine historische Datenbasis. Sind keine historischen Daten für die Datenpunkte vorhanden, kann das EMS Modul die Berechnungen nicht starten. Es wird damit kein berechneter Wert für die Endverbrauch Prognose angezeigt.

Interne ID: Daten für das EMS

Endverbrauch Prognose

Variable, die den Endwert der Prognosegerade zum Ende der Verrechnungsperiode enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Das EMS Modul verfügt aktuell über keine Schnittstelle zum Archivserver Modul. Für die Kurzfristoptimierung ist dies auch nicht nötig, dazu reichen die historischen Daten, die über die Option Harddisk Datenspeicherung aufgezeichnet werden, völlig aus.

Interne ID: Daten für das EMS

Harddisk Datenspeicherung

Eigenschaften für das Speichern von Variablenwerten auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Für die Aufzeichnung der HD Daten empfehlen sich dabei, abhängig von der Periodenlänge, folgende Einstellungen:

Anzahl der Vergangenheitswerte

Als Richtlinie kann nach folgender Faustregel vorgegangen werden:

Der durch die Harddisk Datenspeicherung zur Verfügung gestellte Historische Daten Bereich muss zumindest dem 1,5 fachen des*Prognosehorizont entsprechen. Ist keine ausreichende Datentiefe vorhanden, wird die Berechnung der Optimierung nicht gestartet.

Interne ID: Daten für das EMS

Prognosehorizont

Dauer einer Verrechnungsperiode in hh:mm:ss. Die Trendrechnung und die Optimierung verwenden diese Zeit als Berechnungshorizont. In der Regel werden 15, 30 oder 60 Minuten als Werte verwendet.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Am Beginn des Prognosehorizont benötigt das EMS einen Aktueller Verbrauch für das angezeigte Versorgungsgebiet. Dabei muss der neue Wert während des übernächsten Optimierungszyklus an das EMS übergeben werden, also bei einem Optimierungszyklus von 30 Sekunden im Bereich zwischen Sekunde 30 und Sekunde 60.

Interne ID: Daten für das EMS

Optimierungszyklus

Zyklus in hh:mm:ss, in dem die kurzfristige Optimierung rechnet. Die Anzeige des Bildes wird nach jeder Optimierung aktualisiert, mindestens aber einmal pro Zyklus.

Default: 00:00:30

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Daten für das EMS

Aktueller Verbrauch

Variable, die den aktuellen Wert des Gebietsverbrauchs beinhaltet. Der Wert muss die Zählerdifferenz pro Zeiteinheit der Summe der Verbräuche des Versorgungsgebietes darstellen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Achtung: Stellen Sie sicher, dass der Wert zyklisch übertragen wird, da er die kurzfristige Optimierungsrechnung auslöst.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Erhält das EMS in diesem Zeitraum keinen neuen Wert, wird eine erneute Initialisierung des EMS erst wieder zur nächsten Verrechnungsperiode ausgeführt.


Netze

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Netze

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Sammelknoten enthält alle im Projekt angelegten Netze, bietet aber selbst keine Einstellmöglichkeiten.

Optionen:

Menü/Eintrag | Erklärung
Stromnetz neu | Erzeugt ein neues Stromnetz.
Gasnetz neu | Erzeugt ein neues Gasnetz.
Einfügen | Fügt Objekte vom Typ Netz ein.
XML exportieren alle... | Exportiert alle definierten Netze in ein XML File.
XML importieren… | Importiert Objekte vom Typ Netz.
Hilfe | Ruft die EMS Online Hilfe auf.

Für jedes neu angelegte Netz muss ein eindeutiger Name vergeben werden. Zur leichteren Identifikation kann optional für jedes Netze auch eine freie Kennung vergeben werden, diese ist aber nicht Pflicht. Gasnetze enthalten einige zusätzliche Einstellungen.

Interne ID: Netze

Kennung

Optionale Eingabe eines längeren Namens oder einer detaillierten Beschreibung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Netze

Name

Eindeutige Bezeichnung zur Identifizierung von Geräten, Gebieten und Anlagen im EMS.

Achtung: Namen sollten über alle Netze/Versorgungsgebiete im EMS eindeutig sein.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Pro Projekt kann immer nur 1 Strom und 1 Gasnetz angelegt bzw. verwaltet werden.

Noch in diesem Kapitel

Gasnetze


Gasnetze

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Netze -> Gasnetze

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Gasnetzes enthalten zusätzliche Konfigurationsmöglichkeiten. Über diese lassen sich netzweite Parameter wie Temperatur oder Charakteristische Tage sowie Summenergebnisse wie Bereinigter Verbrauch oder Prognose für das gesamte Netz konfigurieren.

Interne ID: Gasnetze

Prognose

Variable, an die der prognostizierte Verbrauch der Gruppe geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Gasnetze

Bereinigter Verbrauch

Variable, an die der Gruppenverbrauch geschickt wird, bereinigt um die Werte von Verbraucherabschaltungen und Speichereinsätzen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Gasnetze

Charakteristische Tage

Variable für Tageskennung (Wochen- oder Feiertag). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Gasnetze

Temperatur

Variable für den Wert der Temperatur. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alle im Eigenschaften-Fenster der Gasnetze einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.


Versorgungsgebiet

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Versorgungsgebiet

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Versorgungsgebiet stellt die Stufe der Objekthierarchie dar, auf deren Basis die Prognose und Optimierung erfolgt.

info Info

Um das EMS für ein Versorgungsgebiet zu starten, muss eine Funktion vom Typ "EMS starten" mit dem Versorgungsgebiet als Parameter ausgeführt werden.

Einstellungen für das Versorgungsgebietes eines Stromnetzes

Für Versorgungsgebiete stehen Einstellungen zur Verfügung für:

  • Eingangswerte: Definiert Variablen für den Bezug der aktuellen Werte und Bezugsgrenzen.

    Interne ID: Versorgungsgebiet

    Eingangswerte

    Einstellungen für aktuelle Werte und Bezugsgrenzen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Berechnete Werte: Einstellungen, um Parameter für die Prognose und Optimierung mit Hilfe von Prozessvariablen zur Runtime anzupassen.

    Interne ID: Versorgungsgebiet

    Berechnete Werte

    Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung während der Laufzeit angepasst werden. Damit können abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess angepasst werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Parameter: Wichtige Einstellungen für die Optimierung des Versorgungsgebietes mit direkter Auswirkung auf die Schalt-Handlungen des EMS.

    Interne ID: Versorgungsgebiet

    Parameter

    Diese Einstellungen beeinflussen grundlegend die Optimierung für das selektierte Versorgungsgebiet. Änderungen dieser Parameter haben direkten Einfluss auf die durch das EMS automatisch vorgenommenen Schalt-Operationen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Statusinformation: Einstellung, welche Variable über Verfügbarkeit des EMS Bildes informiert.

    Interne ID: Versorgungsgebiet

    Statusinformation

    Definiert Informationsübermittlung zum Status des EMS.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alle in den jeweiligen Gruppen einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt

Kontextmenü Einträge

Menü/Eintrag | Erklärung
Erzeuger neu | Legt einen neuen Erzeuger im selektierten Versorgungsgebiet an.
Verbrauchergruppe neu | Erstellt eine neue Verbrauchergruppe im Versorgungsgebiet.
Variablen anlegen | Legt automatisch alle minimal erforderlichen Variablen für das selektierte Versorgungsgebiet an und verknüpft sie mit den passenden Eigenschaften.
Ausschneiden | Ohne Funktion beim Versorgungsgebiet.
Kopieren | Kopiert das aktuell selektierte Versorgungsgebiet. Das Kopieren mehrerer Versorgungsgebiete über Multiselekt ist möglich.
Einfügen | Eingefügt werden können Objekte vom Typ Versorgungsgebiet.
Löschen | Löscht das aktuell selektierte Versorgungsgebiet. Das Löschen mehrerer Versorgungsgebiete über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Versorgungsgebiete des selektierten Netzes.
Selektierte XML exportieren... | Exportiert das aktuell selektierte Versorgungsgebiet. Das Exportieren mehrerer Versorgungsgebiete über Multiselekt ist möglich.
XML importieren … | Importiert werden können Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Noch in diesem Kapitel

Zusätzliche Parameter für Gas Versorgungsgebiete


Zusätzliche Parameter für Gas Versorgungsgebiete

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Versorgungsgebiet -> Zusätzliche Parameter für Gas Versorgungsgebiete

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Versorgungsgebiet stellt die Stufe der Objekthierarchie dar, auf deren Basis Prognose und Optimierung erfolgen.

info Info

Um das EMS für ein Versorgungsgebiet zu starten, muss eine Funktion vom Typ "EMS starten" mit dem Versorgungstyp als Parameter ausgeführt werden.

Versorgungsgebiete für ein Gasnetz verfügen über Spezifische Gas-Parameter, mit denen zum Beispiel Bereinigter Verbrauch, Prognose und Optimale Last definiert werden, aber auch das Verhältnis zwischen Flüssiggaseinspeisung und Bezug. Alle einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

Interne ID: Zusätzliche Parameter für Gas Versorgungsgebiete

Optimale Last

Variable, an die das Ergebnis der Lastverteilung für die Gruppe geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Parameter für Gas Versorgungsgebiete

Prognose

Variable, an die der prognostizierte Verbrauch der Gruppe geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Parameter für Gas Versorgungsgebiete

Bereinigter Verbrauch

Variable, an die der Gruppenverbrauch geschickt wird, bereinigt um die Werte von Verbraucherabschaltungen und Speichereinsätzen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Parameter für Gas Versorgungsgebiete

Spezifische Gas-Parameter

Diese Eigenschaften stehen nur für Netze, Versorgungsgebiete und Verbrauchergruppen in Gasnetzen zur Verfügung.

Diese Parameter beeinflussen die Auswahl der Geräte, die durch die Optimierung automatisch geschalten werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Kontextmenü Einträge:

Menü/Eintrag | Erklärung
Gasspeicher neu | Legt einen neuen Gasspeicher im selektierten Versorgungsgebiet an.
Flüssiggasanlage neu | Legt eine neue Flüssiggasanlage im selektierten Versorgungsgebiet an.


Verbrauchergruppe

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Verbrauchergruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einzelne Verbraucher werden in Verbrauchergruppen zusammengefasst. Dabei kann jede Verbrauchergruppe eine beliebige Anzahl an Verbrauchern beinhalten.

Kontextmenü Einträge am Knoten "Verbrauchergruppen":

Menü/Eintrag | Erklärung
Verbrauchergruppe neu | Legt eine neue Verbrauchergruppe an.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe ein
XML exportieren alle... | Exportiert die Verbrauchergruppe inklusive aller in der Gruppe definierten Verbraucher.
XML importieren… | Importiert Objekte vom Typ Verbrauchergruppe.
Hilfe | Öffnet die Hilfe für das EMS Modul.

info Info

Diese Einstellungen für Verbrauchergruppen sind in Strom- und Gasnetzen ident.

Kontextmenü-Einträge am Knoten einer Verbrauchergruppe:

Menü/Eintrag | Erklärung
Verbraucher neu | Legt einen neuen Verbraucher in der selektierten Verbrauchergruppe an.
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Noch in diesem Kapitel

Zusätzliche Parameter für Gas Verbrauchergruppen


Zusätzliche Parameter für Gas Verbrauchergruppen

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Verbrauchergruppe -> Zusätzliche Parameter für Gas Verbrauchergruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einzelne Verbraucher werden in Verbrauchergruppen zusammengefasst. Dabei kann jede Verbraucher Gruppe eine beliebige Anzahl an Verbrauchern beinhalten.

Verbrauchergruppen im Gasnetz verfügen über zusätzliche Einstellungen wie Bereinigter Verbrauch oder Prognose mit Konfiguration oberer und unterer Prognosefehler. Dazu kommen noch Optimale Last, Aktueller Verbrauch und Tagesenergie.

Interne ID: Zusätzliche Parameter für Gas Verbrauchergruppen

Tagesenergie

Variable für Gruppenverbräuche der Verrechnungsperiode des Tages. Fungiert als Merker-Variable in Zukunftsarchiven. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Parameter für Gas Verbrauchergruppen

Aktueller Verbrauch

Variable, an die der aktuelle Gruppenverbrauch mit Verbraucherabschaltungen geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Parameter für Gas Verbrauchergruppen

Optimale Last

Variable, an die das Ergebnis der Lastverteilung für die Gruppe geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Parameter für Gas Verbrauchergruppen

Prognose

Variable, an die der prognostizierte Verbrauch der Gruppe geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Parameter für Gas Verbrauchergruppen

Bereinigter Verbrauch

Variable, an die der Gruppenverbrauch geschickt wird, bereinigt um die Werte von Verbraucherabschaltungen und Speichereinsätzen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Kontextmenü Einträge

Menü/Eintrag | Erklärung
Gasspeicher neu | Legt einen neuen Gasspeicher im selektierten Versorgungsgebiet an.
Flüssiggasanlage neu | Legt eine neue Flüssiggasanlage im selektierten Versorgungsgebiet an.

attention Achtung

Ein Flüssiggasspeicher kann über den Knoten "Versorgungsgebiet" erst angelegt werden, wenn ein Gasspeicher mir der Option Rohrnetzspeicher angelegt wurde.

Interne ID: Zusätzliche Parameter für Gas Verbrauchergruppen

Rohrnetzspeicher

aktiv: Dieser Gasspeicher ist ein Rohrnetzspeicher.

Damit im Versorgungsgebiet ein Flüssiggasspeicher angelegt werden kann, muss zuvor ein Rohrnetzspeicher definiert werden.

Achtung: Pro Versorgungsgebiet kann nur ein Rohrnetzspeicher definiert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Das direkte Anlegen eines Flüssiggasspeichers (ohne Gasspeicher) ist nur in einer Verbrauchergruppe möglich.


Erzeuger

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Erzeuger

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über den Knoten Erzeuger können über das Kontextmenü Neue Erzeuger für das selektierte Stromnetz erzeugt werden.

Erzeuger dienen zur Senkung der aktuellen Bezugsleistung. Für jeden Erzeuger ist es prinzipiell möglich, diesen zuzuschalten oder auf höhere Last (Spitzenleistung) zu schalten. Ein Zu- oder Höher Schalten eines Verbrauchers wirkt sich unmittelbar mindernd auf den aktuellen Leistungsbezugswert (Akt. Verbrauchsmittelwert) aus .

Interne ID: Erzeuger

Akt. Verbrauchsmittelwert

Prozessvariable mit aktuellem Verbrauchsmittelwert (Ergebnis aus den erfassten Messwerten). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Erzeuger

Spitzenleistung

Geben Sie hier die gewünschte Spitzenleistung ein. Das EMS Modul kann ausgehend von der Nennleistung auf diesen Wert für Spitzenleistung umschalten. Der Bezugswert wird um die geschaltete Leistungsdifferenz reduziert.

Wenn der Erzeuger nur über eine zuschaltbare Leistung verfügt und es damit keine Grundleistung gibt, dann ist nur die Spitzenleistung des Erzeugers einzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Kontextmenü Einträge am Knoten "Erzeuger":

Menü/Eintrag | Erklärung
Erzeuger neu | Legt neue Erzeuger für das aktuell selektierte Versorgungsgebiet an.
Einfügen | Fügt Objekte vom Typ Erzeuger ein.
XML exportieren alle... | Exportiert alle Erzeuger des Versorgungsgebietes.
XML importieren… | Importiert Objekte vom Typ Erzeuger.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Eigenschaften

Für Erzeuger lassen sich neben Name und Kennung Eigenschaften in verschiedenen Gruppen definieren:

  • Leistung/Priorität: Bestimmt das grundlegende Verhalten von Geräten in Stromnetzen.

    Interne ID: Erzeuger

    Leistung/Priorität

    Diese Eigenschaften stehen nur für Geräte in Stromnetzen zur Verfügung. Sie bestimmen das grundlegende Verhalten der im Stromnetz relevanten Geräte.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Schaltzeiten: Vorgabe von unterschiedlichen Laufzeiten oder zeitlichen Anforderungen an einzelne Geräte.

    Interne ID: Erzeuger

    Schaltzeiten

    Das EMS kann mit Hilfe dieser Parameter unterschiedliche Laufzeiten oder zeitliche Anforderungen an einzelne Geräte berücksichtigen. Die Schaltzeiten sind ein wesentlicher Einflussfaktor zur Auswahl eines Gerätes für einen Schaltvorgang.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Schalthäufigkeit: Festlegung der maximalen Schalthäufigkeit pro Zeiteinheit.

    Interne ID: Erzeuger

    Schalthäufigkeit

    Enthält Parameter zur Bestimmung der Max. Schalthäufigkeit pro Zeiteinheit.

    Interne ID: Erzeuger

    pro Zeiteinheit

    Zeiteinheit in hh:mm:ss für die Max. Schalthäufigkeit.

    Maximalwert: 23:59:59

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Erzeuger

    Max. Schalthäufigkeit

    Maximale Anzahl der Schalthandlungen pro Zeiteinheit. Ein- und Ausschalten werden jeweils als eine separate Schalthandlungen berücksichtigt. Auch das Schalten von Nenn- auf Spitzenleistung wird als eine Schalthandlung gewertet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Schaltvariablen: Prozessvariablen zur Anpassung wichtiger Parameter während der Runtime.

    Interne ID: Erzeuger

    Schaltvariablen

    Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung zur Runtime angepasst werden. Damit lassen sich abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess anpassen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Sperrzeiten: Schließt einzelne Geräte des EMS aus der Optimierung aus.

    Interne ID: Erzeuger

    Sperrzeiten

    Mittels frei definierbarer Zeitbereiche können einzelne Geräte des EMS aus der Optimierung ausgeschlossen werden. Geräte mit einer definierten Sperrzeit werden in diesem Zeitraum nicht vom EMS berücksichtigt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Schaltstufen: Definiert Schaltstufen für Blockheizkraftwerke.

    Interne ID: Erzeuger

    Schaltstufen

    Diese Einstellungen stehen nur für Erzeuger in Stromnetzen zur Verfügung.

    Blockheizkraftwerke unterscheiden sich von Standard-Erzeugern durch das Vorhandensein von vordefinierten Schaltstufen. Ein BHKW kann nur Leistungswerte annehmen, die auch als Schaltstufe definiert wurden. Das EMS kann auch nur Schaltungen von einer auf die nächst höhere oder nächst kleinere Schaltstufe vornehmen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alle einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

attention Achtung

Die Schaltpriorität wird vom EMS über alle definierten Geräte berücksichtigt. Das heißt, der selbe Nummernkreis kommt bei Erzeugern und Verbrauchern zur Anwendung. Es müssen daher die Prioritäten immer für alle definierten Geräte betrachtet werden, da keine Unterscheidung zwischen Erzeugern und Verbrauchern getroffen wird.

Kontextmenü-Einträge für einen selektierten Erzeuger:

Menü/Eintrag | Erklärung
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Noch in diesem Kapitel

Schaltstufen


Schaltstufen

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Erzeuger -> Schaltstufen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Sonderfall im EMS stellen die BHKWs (Blockheizkraftwerke) dar. Diese spezielle Form von Erzeugern können Ihre Leistung in Stufen anpassen. Um ein BHKW zu definieren, können an einem beliebigen Verbraucher im EMS Schaltstufen definiert werden.

Grundlegend können für jedes BHKW unter dem Knoten Schaltstufen Einstellungen zur Sollwert-Variable, zum aktuellen Verbrauch und zur Hysterese vorgenommen werden.

Interne ID: Schaltstufen

Hysterese

Die Hysterese definiert den erlaubten Bereich, in dem der aktuelle Wert noch einer der Schaltstufen zugeordnet werden kann. Liegt ein Verbrauchswert nicht innerhalb der Hysterese einer der projektierten Schaltstufen, gilt das BHKW für das EMS als inaktiv.

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Schaltstufen

Sollwert-Variable

Globale Sollwertvariable, die das BHKW schaltet. Die einzelnen Werte bzw. Variablen an den LeistungsstufenStufen dienen lediglich zur Angabe der Stufenleistung. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Schaltstufen

Schaltstufen

Diese Einstellungen stehen nur für Erzeuger in Stromnetzen zur Verfügung.

Blockheizkraftwerke unterscheiden sich von Standard-Erzeugern durch das Vorhandensein von vordefinierten Schaltstufen. Ein BHKW kann nur Leistungswerte annehmen, die auch als Schaltstufe definiert wurden. Das EMS kann auch nur Schaltungen von einer auf die nächst höhere oder nächst kleinere Schaltstufe vornehmen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Für jedes BHKW kann eine beliebige Anzahl von Schaltstufen definiert werden:

Jede Schaltstufe bietet dabei Einstellmöglichkeiten zur Leistung und zur Vorwarnung vor Schalthandlungen sowie zum Ein- und Ausschalten. Alle einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

attention Achtung

Werden für einen Erzeuger Schaltstufen definiert, überschreiben diese Einstellungen die Standard-Parameter des Erzeugers. Eine entsprechende Warnung wird beim Kompilieren im Ausgabefenster ausgegeben. "


Verbraucher

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Verbraucher

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verbraucher stellen im EMS Modul die wesentlichen Elemente zum Lastabwurf dar. Mittels Zu- bzw. Abschaltungen von Verbrauchern kann das EMS direkt regelnd eingreifen und hilft damit, Spitzenlasten zu vermeiden.

Kontextmenü Einträge für eine selektierte Verbrauchergruppe:

Menü/Eintrag | Erklärung
Verbraucher neu | Legt einen neuen Verbraucher im aktuell selektierten Versorgungsgebiet an.l
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Eigenschaften

Für Verbraucher lassen sich neben Name und Kennung Eigenschaften in verschiedenen Gruppen definieren:

Leistung/Priorität: Bestimmt das grundlegende Verhalten von Geräten in Stromnetzen.

Interne ID: Verbraucher

Leistung/Priorität

Diese Eigenschaften stehen nur für Geräte in Stromnetzen zur Verfügung. Sie bestimmen das grundlegende Verhalten der im Stromnetz relevanten Geräte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schaltzeiten: Vorgabe von unterschiedlichen Laufzeiten oder zeitlichen Anforderungen an einzelne Geräte.

Interne ID: Verbraucher

Schaltzeiten

Das EMS kann mit Hilfe dieser Parameter unterschiedliche Laufzeiten oder zeitliche Anforderungen an einzelne Geräte berücksichtigen. Die Schaltzeiten sind ein wesentlicher Einflussfaktor zur Auswahl eines Gerätes für einen Schaltvorgang.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schalthäufigkeit: Festlegung der maximalen Schalthäufigkeit pro Zeiteinheit.

Interne ID: Verbraucher

Schalthäufigkeit

Enthält Parameter zur Bestimmung der Max. Schalthäufigkeit pro Zeiteinheit.

Interne ID: Verbraucher

pro Zeiteinheit

Zeiteinheit in hh:mm:ss für die Max. Schalthäufigkeit.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verbraucher

Max. Schalthäufigkeit

Maximale Anzahl der Schalthandlungen pro Zeiteinheit. Ein- und Ausschalten werden jeweils als eine separate Schalthandlungen berücksichtigt. Auch das Schalten von Nenn- auf Spitzenleistung wird als eine Schalthandlung gewertet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schaltvariablen: Prozessvariablen zur Anpassung wichtiger Parameter während der Runtime.

Interne ID: Verbraucher

Schaltvariablen

Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung während der Laufzeit angepasst werden. Damit können abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Sperrzeiten: Schließt einzelne Geräte des EMS aus der Optimierung aus.

Interne ID: Verbraucher

Sperrzeiten

Mittels frei definierbarer Zeitbereiche können einzelne Geräte des EMS aus der Optimierung ausgeschlossen werden. Geräte mit einer definierten Sperrzeit werden in diesem Zeitraum nicht vom EMS berücksichtigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alle einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

Kontextmenü Einträge für einen selektierten Verbraucher

Menü/Eintrag | Erklärung
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Noch in diesem Kapitel

Zusätzliche Einstellungen für Gas-Verbraucher


Zusätzliche Einstellungen für Gas-Verbraucher

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Verbraucher -> Zusätzliche Einstellungen für Gas-Verbraucher

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verbraucher stellen im EMS Modul die wesentlichen Elemente zum Lastabwurf dar. Mittels Zu- bzw. Abschaltungen von Verbrauchern kann das EMS direkt regelnd eingreifen und hilft damit, Spitzenlasten zu vermeiden.

Verbraucher in Gasnetzen verfügen über zusätzliche Einstellungen zur Leistung wie Anteil an Gruppe [%], Erlös [€/kWh]/Priorität und Angaben zur minimalen und maximalen Temperatur. Alle einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

Interne ID: Zusätzliche Einstellungen für Gas-Verbraucher

Erlös [€/kWh]/Priorität

Erlös des Verbrauchers in € pro kWh oder Schaltpriorität.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000001

Default: 1.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zusätzliche Einstellungen für Gas-Verbraucher

Anteil an Gruppe [%]

Anteil der Leistung des Verbrauchers an der Gesamtleistung der Verbrauchergruppe in Prozent.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Gasnetz spezifische Elemente

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Gasnetz spezifische Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Folgenden sind die Geräte und Elemente beschrieben, die in Gasnetzen zum Einsatz kommen. In Stromnetzen stehen die hier dokumentierten Einstellungen nicht zur Verfügung.

Noch in diesem Kapitel

Gasspeicher

Flüssiggasanlage


Gasspeicher

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Gasnetz spezifische Elemente -> Gasspeicher

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mittels Gasspeichern ist es möglich, die Speicherkapazitäten in einem Gas-Versorgungsgebiet zu modellieren. Sie können dazu an folgenden Stellen verwendet werden:

  1. Als Gasspeicher im Versorgungsgebiet
  2. Als Rohrnetzspeicher kann ein Gasspeicher die Speicherkapazität einen geografisch ausgedehnten Rohrnetzes darstellen.
  3. Als Gasspeicher in Verbrauchergruppen.

Kontextmenü Einträge für eine selektierte Gasspeichergruppe:

Menü/Eintrag | Erklärung
Gasspeicher neu | Legt einen neuen Gasspeicher an.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Eigenschaften

Neben Name und Kennung lassen sich spezifische Eigenschaften für Gasspeicher in verschiedenen Gruppen definieren:

Typ/Leistung: Einstellungen für das grundlegende Verhalten der Geräte im Gasnetz.

Interne ID: Gasspeicher

Typ/Leistung

Diese Eigenschaften stehen nur für Geräte in Gasnetzen zur Verfügung.

Die hier getroffenen Einstellungen bestimmen das grundlegende Verhalten der im Gasnetz relevanten Geräte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schaltvariablen: Prozessvariablen zur Anpassung wichtiger Parameter während der Runtime.

Interne ID: Gasspeicher

Schaltvariablen

Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung während der Laufzeit angepasst werden. Damit können abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Füllstände: Hier werden dem EMS die wichtigen Informationen über Füllstände sowie Minimal- und Maximalwerte mitgeteilt.

Interne ID: Gasspeicher

Füllstände

Diese Eigenschaften stehen nur für Gasspeicher und Flüssiggasanlagen in Gasnetzen zur Verfügung.

Füllstände stellen die wichtigsten Parameter für Gasspeicher dar. Kennt das EMS den aktuellen Füllstand bzw. die Minimal- und Maximalwerte, kann es in Zeiten des Überschusses die Speicher auffüllen bzw. in Zeiten des Bedarfs entleeren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schaltzeiten: Vorgabe von unterschiedlichen Laufzeiten oder zeitlichen Anforderungen an einzelne Geräte.

Interne ID: Gasspeicher

Schaltzeiten

Das EMS kann mit Hilfe dieser Parameter unterschiedliche Laufzeiten oder zeitliche Anforderungen an einzelne Geräte berücksichtigen. Die Schaltzeiten sind ein wesentlicher Einflussfaktor zur Auswahl eines Gerätes für einen Schaltvorgang.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alle einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

Kontextmenü Einträge für einen selektierten Gasspeicher:

Menü/Eintrag | Erklärung
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe.
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Gasspeicher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die aktuell selektierte Verbrauchergruppe. Das Exportieren mehrerer Gruppen über Multiselekt ist möglich.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.


Flüssiggasanlage

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Gasnetz spezifische Elemente -> Flüssiggasanlage

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Flüssiggasanlagen sind im EMS die klassischen Speichermodule für Gas. Sie dienen im wesentlichen für den Ausgleich von Spitzen. Im Falle einer Leistungsspitze kann Gas aus Speichern entnommen werden.

Kontextmenü-Einträge für eine selektierte Gasspeichergruppe:

Menü/Eintrag | Erklärung
Flüssiggasanlage neu | Legt einen neuen Flüssiggasanlage an.
Einfügen | Fügt Objekte vom Typ Verbrauchergruppe, Verbraucher ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
XML importieren … | Importiert Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.

Eigenschaften

Neben Name und Kennung lassen sich spezifische Eigenschaften für Flüssiggasanlagen in verschiedenen Gruppen definieren:

Typ/Leistung: Einstellungen für das grundlegende Verhalten der Geräte im Gasnetz.

Interne ID: Flüssiggasanlage

Typ/Leistung

Diese Eigenschaften stehen nur für Geräte in Gasnetzen zur Verfügung.

Die hier getroffenen Einstellungen bestimmen das grundlegende Verhalten der im Gasnetz relevanten Geräte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schaltvariablen: Schaltvariablen: Prozessvariablen zur Anpassung wichtiger Parameter während der Runtime.

Interne ID: Flüssiggasanlage

Schaltvariablen

Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung während der Laufzeit angepasst werden. Damit können abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Füllstände: Hier werden dem EMS die wichtigen Informationen über Füllstände sowie Minimal- und Maximalwerte mitgeteilt.

Interne ID: Flüssiggasanlage

Füllstände

Diese Eigenschaften stehen nur für Gasspeicher und Flüssiggasanlagen in Gasnetzen zur Verfügung.

Füllstände stellen die wichtigsten Parameter für Gasspeicher dar. Kennt das EMS den aktuellen Füllstand bzw. die Minimal- und Maximalwerte, kann es in Zeiten des Überschusses die Speicher auffüllen bzw. in Zeiten des Bedarfs entleeren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Schaltzeiten: Vorgabe von unterschiedlichen Laufzeiten oder zeitlichen Anforderungen an einzelne Geräte.

Interne ID: Flüssiggasanlage

Schaltzeiten

Das EMS kann mit Hilfe dieser Parameter unterschiedliche Laufzeiten oder zeitliche Anforderungen an einzelne Geräte berücksichtigen. Die Schaltzeiten sind ein wesentlicher Einflussfaktor zur Auswahl eines Gerätes für einen Schaltvorgang.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alle einstellbaren Eigenschaften werden beim Klick auf die jeweilige Eigenschaft im Hilfefenster erklärt.

Kontextmenü Einträge für eine selektierten Flüssiggasanlage:

Menü/Eintrag | Erklärung
Ausschneiden | Ohne Funktion bei der Verbrauchergruppe
Kopieren | Kopiert die aktuell selektierte Verbrauchergruppe. Das Kopieren mehrerer Gruppen über Multiselekt ist möglich.
Einfügen | Fügt Objekte vom Typ Flüssiggasanlage ein.
Löschen | Löscht die aktuell selektierte Verbrauchergruppe. Das Löschen mehrerer Gruppen über Multiselekt ist möglich.
XML exportieren alle... | Exportiert alle Verbrauchergruppen des selektierten Netzes.
Selektierte XML exportieren... | Exportiert die ausgewählten Einträge in eine XML-Datei.
XML importieren … | Importiert werden können Objekte vom Typ Versorgungsgebiet.
Hilfe | Öffnet die Hilfe für das EMS Modul.


Sperrzeiten

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Sperrzeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sowohl bei Erzeugern als auch bei Verbrauchern ist es möglich, Zeiten zu definieren, in denen Schalthandlungen nur teilweise oder gar nicht durchgeführt werden dürfen. Es können pro Verbraucher/Erzeuger beliebig viele Sperrzeiten angegeben werden.

info Info

In Gasnetzen stehen Sperrzeiten nur bei Verbraucher zur Verfügung.

Pro Element kann eine beliebige Anzahl von Sperrzeiten definiert werden. Es ist darauf zu achten, dass sich diese nicht gegenseitig überlappen. In diesem Fall ist es möglich, dass ein Gerät durch das EMS Modul nicht mehr geschalten werden kann.

info Info

Die Sperrzeit-Parameter werden im Projekt fix eingestellt und können zur Runtime nicht geändert werden.


Anlegen eines Prozessbildes

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Anlegen eines Prozessbildes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bedienung des EMS Moduls erfolgt während der Runtime über ein Bild vom Typ Energy Management System. Dieses Bild muss zunächst im Editor angelegt werden. (Nähere Informationen zu den vordefinierten Bildtypen finden Sie in Bilder/Vordefinierte Bildtypen'.)

Nach dem Öffnen des Bildes wird ein leeres Bild aufgeschaltet. Kontrollelemente können Sie über das Menü Kontrollelemente einfügen.


Projektieren der Bild-Umschaltfunktion

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Projektieren der Bild-Umschaltfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen einer Bild-Umschaltfunktion für ein Bild vom Typ Energy Management System wird folgender Dialog zur Parametrierung angeboten:

Durch eine Bildumschaltung wird zur Runtime das EMS Bild geöffnet. Für diesen Bildaufruf können die folgenden Parameter eingestellt werden:

Eigenschaft | Beschreibung
Netze | Auswahl des Netzes. In der Auswahlbox Versorgungsgebiet werden daraufhin die für die Anzeige zur Verfügung stehenden Gebiete angezeigt.
Versorgungsgebiete | Das selektierte Versorgungsgebiet wird in der Laufzeit n der Optimierung zur Anzeige gebracht. Pro Prozessbild ist immer nur die Anzeige eines Versorgungsgebietes möglich. Allerdings besteht die Möglichkeit, mehrere Bilder des Typs Energy Management System parallel zu öffnen, damit können auch mehrere Versorgungsgebiete parallel angezeigt werden.
Aktueller Wert | Feld dient nur zur Anzeige, der Wert kann nicht geändert werden. Angezeigt wird die Variable der Eigenschaft Aktueller Wert des aktuell selektierten Gebietes.
Endwert Prognose | Feld dient nur zur Anzeige, der Wert kann nicht geändert werden. Angezeigt wird die Variable der Eigenschaft Endwert Prognose des aktuell selektierten Gebietes.
Prognose Mittelwert | Feld dient nur zur Anzeige, der Wert kann nicht geändert werden. Angezeigt wird die Variable der Eigenschaft Prognose Mittelwert des aktuell selektierten Gebietes.
Bezugsgrenze | Feld dient nur zur Anzeige, der Wert kann nicht geändert werden. Angezeigt wird die Variable der Eigenschaft Bezugsgrenze des aktuell selektierten Gebietes.
Skala oben | Obere Grenze der Wertbereichsskala für die Anzeige der Kennlinie im EMS Bild.
Skala unten | Untere Grenze der Wertbereichsskala für die Anzeige der Kennlinie im EMS Bild.
Verrechnungsperiode (min.) | Feld dient nur zur Anzeige, der Wert kann nicht geändert werden. Zeigt die aktuell eingestellte Länge der Verrechnungsperiode für das ausgewählte Versorgungsgebiet an.
Wertfarbe und Breite | Farbe und Linienstärke zur Darstellung der Elemente für den aktuellen und den prognostizierten Mittelwert.
Achsenfarbe und Breite | Farbe und Linienstärke zur Darstellung der Diagrammachsen.
Kurvenfarbe und Breite | Farbe und Linienstärke zur Darstellung der Diagrammkurve (Anzeige der aktueller Werte und geplante Schaltungen).
Schrift Achse | Parametrierung der Schrift, die für die Achsbeschriftungen in der Trendkurve verwendet wird.

Schaltvorschau

Für die Projektierung der Schaltvorschau, definieren Sie in der Registerkarte Schaltvorschau Spalteneinstellungen die Filtereinstellungen für die Anzeige zur Runtime. Details dazu finden Sie im Kapitel Schaltvorschau Spalteneinstellungen.


Funktionen Start/Stopp anlegen

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Funktionen Start/Stopp anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für jedes Versorgungsgebiet muss die Optimierung zur Runtime extra gestartet werden. Dazu benutzen Sie die Funktion EMS starten.
Um gestartete Versorgungsgebiete zu stoppen, legen Sie eine Funktion EMS stoppen an.

Hinweis: Diese Funktionen werden nur am Server ausgeführt.

attention Achtung

In der Runtime werden alle gestarteten Versorgungsgebiete von der Lizenzierung erfasst. Achten Sie auf ausreichende Lizenzierung.

Tipp: Stoppen Sie die Optimierung von Versorgungsgebieten, wenn diese nicht benötigt wird, um Ihre Lizenz optimal zu nutzen. Um Versorgungsgebiete regelmäßig, z.B. in der Nacht oder in bestimmten Schichten, zu stoppen, können Sie die Funktionen EMS starten/EMS stoppen über den Production and Facility Scheduler steuern.

EMS starten

  • wählen Sie Funktion neu
  • klicken Sie im Knoten Anwendungen auf EMS starten
  • der Dialog zur Auswahl des Versorgungsgebietes öffnet sich

  • wählen Sie erst das gewünschte Netz
  • wählen Sie dann das gewünschte Versorgungsgebiet
  • mit Klick auf OK wird die Funktion erstellt

EMS stoppen

  • wählen Sie Funktion neu
  • klicken Sie im Knoten Anwendungen auf EMS stoppen
  • der Dialog zur Auswahl des Versorgungsgebietes öffnet sich

  • wählen Sie erst das gewünschte Netz
  • wählen Sie dann das gewünschte Versorgungsgebiet
  • mit Klick auf OK wird die Funktion erstellt


Schaltvorschau projektieren

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Schaltvorschau projektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Geplante Schalthandlungen können zur Runtime als Vorschau angezeigt werden.

Um die Schaltvorschau zur Runtime zu projektieren:

  1. Verknüpfen Sie beim gewünschten EMS Versorgungsgebiet über die Eigenschaft Geplante Schaltungen (Gruppe Statusinformation) eine String-Variable, die vom EMS System die Liste aller geplanten Schalthandlungen erhält.

    Interne ID: Schaltvorschau projektieren

    Statusinformation

    Definiert Informationsübermittlung zum Status des EMS.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Schaltvorschau projektieren

    Geplante Schaltungen

    Ermöglicht die Verknüpfung einer String-Variablen, die alle geplanten Schalthandlungen aus dem EMS erhält. Klick auf die Schaltfläche ... öffnet Dialog zur Variablenauswahl.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Tipp: Am sinnvollsten ist dazu eine String-Variable am Intern-Treiber.
    Für Server-Betrieb setzen Sie die Berechnung auf Netzwerk. Damit wird die Variable im gesamten zenon Netz verteilt.

  2. Definieren Sie den gewünschten Inhalt der Schaltvorschau. Öffnen Sie dazu die Registerkarte EMS Schaltvorschau Spalteneinstellungen im Dialog der Bildumschaltungsfunktion auf das EMS Bild.
  3. Fügen Sie in das EMS Bild das Kontrollelement Tabellarische Darstellung: Schaltvorschau ein.

    Farben und Schrift passen Sie über dessen Eigenschaften an.

Sprachumschaltung

Alle in der Schaltvorschau dargestellten Informationen sind über die Sprachtabelle sprachumschaltbar.

Für die Spaltentitel kann dazu im Filter-Dialog der Name eingestellt werden. Wählt man hier Namen der Form @Schaltzeit, @Objektname oder ähnlich, so werden diese zur Runtime mit den entsprechenden Einträgen der Sprachtabelle ersetzt.

Außerdem können alle Inhalte der Schaltvorschau ersetzt werden:

  1. Objektnamen werden ersetzt indem in der EMS Projektierung die Objektnamen ebenfalls mit @ angegeben werden. z.B.: @Erzeuger1
  2. Akt.Wert und Schaltwert können entweder numerische Inhalte aufweisen (bei Stufen-BHKWs) oder @On/@Off

Noch in diesem Kapitel

Schaltvorschau Spalteneinstellungen

Schaltvorschau zur Runtime


Schaltvorschau Spalteneinstellungen

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Schaltvorschau projektieren -> Schaltvorschau Spalteneinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Spalteneinstellung definieren Sie, welche Angaben in welcher Reihenfolge angezeigt werden.

Hinweis: Alle in der Schaltvorschau dargestellten Informationen sind über die Sprachtabelle sprachumschaltbar:
Wählen Sie Namen mit einem vorangestellten @, z.B. @Schaltzeit, damit diese zur Runtime mit den entsprechenden Einträgen der Sprachtabelle ersetzt werden.

Im Listenfeld dieser Registerkarte werden Ihnen alle zur Verfügung stehenden Spaltentypen angezeigt. Mithilfe einer Checkbox entscheiden Sie, welche Spaltentypen angezeigt werden. Sie können die Beschreibung und die Spaltenbreite jedes Spaltentyps ändern, indem Sie eine Linksklick auf den entsprechenden Bereich ausführen und im sich öffnenden Editierfeld den gewünschten Wert eintragen.

Parameter | Beschreibung
Spaltentyp | Typ der Spalte. Nicht editierbar. Anzeige zur Runtime wird per Checkbox aktiviert oder deaktiviert.
Beschreibung | Definiert Überschrift der jeweiligen Spalte. Kann auch sprachumschaltbar konfiguriert werden. Wert ist editierbar.
Breite | Definiert die Breite der Spalte in Pixel. Diese kann auch durch Ziehen mit der Maus in der Liste mit horizontaler Anzeige der Spaltennamen festgelegt werden. Wert ist editierbar.
Selektierten Eintrag nach oben verschieben | Verschiebt ausgewählte Spalte nach oben. Verschieben ist auch per Drag & Drop möglich.
Selektierten Eintrag nach unten verschieben | Verschiebt ausgewählte Spalte nach unten. Verschieben ist auch per Drag & Drop möglich.
Feld mit horizontaler Anzeige der Spaltennamen | Zeigt die in der Liste aktivierten Spalten an. Durch Ziehen mit dem Mauszeiger an den Spaltengrenzen kann die Spaltengröße definiert werden.

attention Achtung

Die Spaltenbreite ist von der verwendeten Schriftart abhängig. Wenn die Spaltenbreite nicht einem Vielfachen der Zeichenbreite der verwendeten Schriftart entspricht, kann es zu Abweichungen bei der tatsächlichen Spaltenbreite kommen.


Schaltvorschau zur Runtime

Handbuch -> Energy Management System (EMS) -> Parametrierung des EMS -> Schaltvorschau projektieren -> Schaltvorschau zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime zeigt das Bild Schaltvorschau die anstehenden Schalthandlungen mit Zeitpunkt und Konsequenz an:


Interner Status der Komponenten

Handbuch -> Energy Management System (EMS) -> Interner Status der Komponenten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Intern werden im EMS unterschiedliche Status für die Geräte mitgeführt. Diese Status können auf einer Prozessvariable abgebildet werden. Es empfiehlt sich, die Status mittels einer Reaktionsmatrix zu überwachen und z.B. in der Chronologischen Ereignisliste auszuwerten.

Die Variable "Interner Schaltzustand" von Geräten kann folgende Werte annehmen:

Allgemeine Gründe (Gültig für alle Komponenten)

Wert | Beschreibung
0 | Nicht belegt (Hochlauf).
100 | Einsatz ist möglich.
101 | Keine Schaltanforderung der HP.
102 | Deaktiviert bis zum Ende des Tarifintervalls.
103 | Der Schaltvorwarnbefehl ist ungültig.
104 | Nicht mehr genug Zeit, um vorzuwarnen.
105 | Die Vorwarnzeit ist noch nicht abgelaufen.
106 | Leistungszuschaltung am Tarifintervallende wegen Parametrierung nicht möglich.
107 | Der Schaltzustand kann nicht ermittelt werden.
200 | Verzögerungszeit ist noch nicht abgelaufen
201 | Komponente ist auf "nicht verfügbar" geschaltet.
202 | Verfügbarkeitsmeldung ist ungültig.
203 | Keine PV zum Ermitteln des aktuellen Betriebszustandes definiert.
204 | Parametrierung gestört.
205 | Totzeit ist noch nicht abgelaufen.
206 | Meldung des aktuellen Schaltzustandes ist ungültig.
207 | Noch keine Daten für den gleitenden Mittelwert der Leistung vorhanden.
208 | Aktueller Leistungswert ist ungültig.
209 | Ist "unbedingt" geschaltet (Fahrplan Mittelfrist).
210 | Textadresse oder Wert für die Einschaltpriorität ist ungültig.
211 | Textadresse oder Wert für die Ausschaltpriorität ist ungültig.
212 | Sperrzeit ist aktiv, Sperrzeittyp AUS.
213 | Sperrzeit ist aktiv, Sperrzeittyp EIN.
214 | Maximale Anzahl der Schaltungen ist bereits erreicht.
215 | Schaltbefehl ist nicht einsetzbar.
216 | Minimale Schaltzeit ist noch nicht erreicht.
217 | Fahrplandaten sind noch nicht vollständig geschrieben.
218 | Allgemeines Problem.
219 | Befehls-PV zum Schalten nicht einsatzbereit.
220 | Kein Befehl zum Senden der Schaltvorwarnung definiert.
221 | Erweiterte Parametrierung für minimale Einschaltzeit pro Zeiteinheit nicht gültig.
222 | Restriktion "Minimale Einschaltzeit pro Zeiteinheit einhalten" wegen anderer Restriktion nicht möglich.
223 | Unbedingt eingeschaltet wegen "minimaler Einschaltzeit pro Zeiteinheit".
250 | Variable oder Wert für die minimale Einschaltzeit ist ungültig.
251 | Variable oder Wert für die minimale Ausschaltzeit ist ungültig.
252 | Variable oder Wert für die maximale Einschaltzeit ist ungültig.
253 | Variable oder Wert für die maximale Ausschaltzeit ist ungültig.
254 | Restriktionen nicht plausibel.

Gründe für Speicher

Wert | Beschreibung
4000 | Aktueller Füllstand ist ungültig.
4001 | Aktuelle Ausspeicherung (Istwert) ist ungültig.
4001 | Ausspeicherung unbedingt, wegen Handwertvorgabe.
4003 | Speicherleistung begrenzt wegen Füllstandsbegrenzung.
4004 | Speicher ist voll.
4005 | Sollwert für Speicher nicht definiert.
4006 | Maximale Einspeicherleistung und maximale Ausspeicherleistung sind beide 0.
4007 | PV zum Messen des aktuellen Füllstands ungültig.

Gründe für BHKWs (Erzeuger)

Wert | Beschreibung
5000 | Aktuelle Leistung entspricht keiner Stufenleistung.
5001 | BHKW läuft nicht unterhalb der Nennleistung.
5002 | Das BHKW hat nur eine Stufe und kann nicht geschaltet werden.
5003 | Das BHKW läuft mit Nennleistung und kann nicht weiter herunter geschaltet werden.
5004 | Die höchste eingeschaltete Stufe kann aufgrund der minimalen Einschaltzeit pro Zeiteinheit nicht abgeschaltet werden.
5005 | Das BHKW läuft bereits auf der höchsten Stufe.
5006 | Die Variable zum Messen der aktuellen Leistung ist ungültig.
5007 | Die Vorwarnung für eine Stufe wurde ausgegeben, es wird auf die Sollwertgabe gewartet.
5008 | Die Variable für den Sollwert ist nicht gültig.
5009 | Die Reihenfolge der Leistungsvorgaben durch Variablen ist nicht aufsteigend.
5010 | Der Wert einer parametrierten maximalen Einschaltzeit einer Stufe ist zu gering.
5011 | Maximale Laufzeit einer Stufe wurde erreicht und Stufen werden abgeschaltet.


Erzeugen der Runtime-Dateien

Handbuch -> Energy Management System (EMS) -> Erzeugen der Runtime-Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach der Projektierung der Funktionen EMS starten bzw. EMS stoppen wird beim Übersetzen der Runtime-Dateien eine Konsistenzprüfung der EMS-Projektierung vorgenommen. Bei Problemen erfolgt eine entsprechende Ausgabe im Ausgabefenster (z. B. wenn notwendige Variablen nicht belegt wurden).

Runtime startet nicht

Lässt sich ein Projekt in der Runtime nicht starten, kann das unterschiedliche Gründe haben:

  • fehlerhafte Projektierung
  • fehlende Lizenz: Bei der Funktion EMS starten wird eine Lizenzprüfung vorgenommen. Fehlt die erforderliche Lizenz, startet das EMS nicht und ein entsprechender Eintrag wird im Log eingetragen.


Bedienen des EMS zur Runtime

Handbuch -> Energy Management System (EMS) -> Bedienen des EMS zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bilder für das Energy Management System ermöglichen die Überwachung der Prognose und Optimierung zur Runtime in Form eines Trendbildes.

Mit Hilfe der Kontrollelemente werden die einzelnen Bedienelemente im Bild angeordnet (Prognosebereich und die Anzeige des aktuell ausgeschalteten Versorgungsgebietes).

Ein Prognose kann zum Beispiel so aussehen:

info Info

Das Bild zur Runtime dient der reinen Anzeige der Optimierungs- und Prognosedaten. Über das Bild können keinerlei Eingriffe vorgenommen werden. Parameter für das EMS Modul werde ausschließlich über Variablen gesteuert.


Erweiterter Trend

Handbuch -> Erweiterter Trend

Das Erweiterte Trend Modul dient zur Darstellung von Online-Werten und historischen Werten (Archivwerte) von Prozess- und abgeleiteten Prozessvariablen in Kurvenform. Es ermöglicht die Rücklesbarkeit von historischen Daten. Das Scrollen im ETM bietet eine Lineal- und Zoomfunktion sowie eine Trendanalyse. Im Unterschied zum Dynamischen Element Trend ist Zoomen, Blättern, Abfragen und Skalieren von Onlinewerten und Werten aus Archiven möglich. Für die Verwendung der Funktion muss das Modul lizenziert sein.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig.

Hinweis: Funktionsreduzierte Erweiterter Trend Starter Edition ist bereits in Standardlizenz enthalten.

Erweiterter Trend Starter Edition

Im Standardumfang der TAG-basierten Version am PC ist eine reduzierte Version des Erweiterten Trend Moduls enthalten. Die Starter Edition basiert auf dem standard Erweiterten Trend Modul.

Die Erweiterter Trend Modul Starter Edition hat folgende Einschränkungen:

  • kein XY Trend
  • keine 2. Zeitachse
  • Kurvenanzahl begrenzt auf 8 Kurven
  • keine Logarithmische Darstellung
  • keine Abtastung

Zusätzliche Einschränkungen bei Verwendung in Windows CE Projekten siehe Handbuch zenon unter Windows CE, Kapitel Einschränkungen für zenon.

Achtung!

Ist im Editor nur die Erweiterter Trend Modul Starter Edition lizenziert, können die oben genannten Einschränkungen nicht projektiert werden.

Ist in der Runtime nur die Erweiterter Trend Modul Starter Edition lizenziert, können Bildumschaltungsfunktionen die den oben genannten Regeln nicht entsprechen nicht ordnungsgemäß ausgeführt werden. Das ETM Bild wird dann mit dem default Filter (=leerer Filter) aufgeschaltet. Es erfolgt ein Eintrag im Diagnose Server.

Beispiel: Sie versuchen in der Runtime eine Bildumschaltungsfunktion auf ein ETM Bild mit 10 Kurven durchzuführen. Das Trendbild wird zwar geöffnet, es werden jedoch keine Kurven angezeigt.

Lizenzierung

Am PC kann die Erweiterte Trend Modul Starter Edition jederzeit datenkompatibel zum vollwertigen Erweiterten Trend Modul erweitert werden (Lizenzerweiterung). Sind sowohl die Erweiterter Trend Modul Starter Edition als auch das Erweiterte Trend Modul lizenziert, stehen alle Funktionalitäten des ETM zur Verfügung.
Für I/O lizenzierte Versionen steht die Starter Edition nicht zur Verfügung.

Für die Windows CE 6.0 Runtime ist die Erweiterte Trend Modul Starter Edition gemeinsam mit der Archivserver Starter Editon optional erhältlich. Für ältere Windows CE Versionen stehen beide Module nicht zur Verfügung.

Noch in diesem Kapitel

Projektieren im Editor

Bedienen zur Runtime


Projektieren im Editor

Handbuch -> Erweiterter Trend -> Projektieren im Editor

Noch in diesem Kapitel

Bild vom Typ Erweiterter Trend anlegen

Anlegen eines neuen Diagramms

Projektierungsabfolge

PROJECT.INI Einträge für den erweiterten Trend

Filterprofile

Funktionen


Bild vom Typ Erweiterter Trend anlegen

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Bild vom Typ Erweiterter Trend anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bedienung des Erweiterten Trends erfolgt während der Runtime über ein Bild vom Typ Erweiterter Trend. Dieses Bild muss zunächst im Editor angelegt werden.

Um ein Bild vom Typ Erweiterter Trend anzulegen:

  1. wählen Sie in der Symbolleiste oder im Kontextmenü des Knotens Bilder den Befehl Bild neu
  2. ein leeres Bild vom Typ Standard wird aufgeschaltet
  3. ändern Sie in der Detailansicht den Bildtyp, dazu
    1. klicken Sie in der Spalte Bildtyp auf Standard
    2. wählen Sie in der Dropdownliste den Eintrag Erweiterter Trend aus
  4. klicken Sie in das Bild
  5. wählen Sie in der Menüleiste den Menüpunkt Kontrollelemente
  6. klicken Sie in der Dropdownliste auf Vorlage einfügen
  7. die Standard-Elemente werden eingefügt
  8. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diesen am gewünschten Platz im Bild ein

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Buttons

vordefinierte Bedienelemente

Diagrammbutton

Diagrammparameter ändern

Kurvenbutton

Kurvenparameter ändern

Diagrammeinstellungen

aktiviert Dialog für Diagrammeinstellungen und Cursor-Ausgabe

Zoomenbutton

Darstellung vergrößern

Rezoomenbutton

Darstellung verkleinern

Zoom +

verringert Zeitabstände der Darstellung

Zoom -

vergrößert Zeitabstände der Darstellung

Refreshbutton

Darstellung aktualisieren

Rückwärtsbutton

Auf der Zeitachse zurück scrollen (Historie)

Vorwärtsbutton

Auf der Zeitachse vorwärts scrollen (Aktuell)

Stopbutton

Bildschirm nicht aktualisieren

Playbutton

Bildschirm aktualisieren

Cursor ein/aus

Werte abfragen

Doppelcursor ein/aus

Werte, die zwischen 2 Cursor liegen, anzeigen.

Cursor ein Pixel nach links

Setzt Cursor ein Pixel nach links.

Wird gleichzeitig die Taste Umschalt gedrückt, wird der Cursor um 10 Pixel bewegt.

Cursor ein Pixel nach rechts

Setzt Cursor ein Pixel nach rechts.

Wird gleichzeitig die Taste Umschalt gedrückt, wird der Cursor um 10 Pixel bewegt.

Drucken

Druckt Diagramm.

Hinweis: Ausdrucke über den Button Drucken des Bildes Erweiterer Trend unterscheiden sich im Ergebnis eventuell vom Drucken über die Funktion Erweiterter Trend Diagramm drucken. Die Funktion geht von einem Fenster der Größe 1000 x 700 aus. Drucken über den Button geht von der im Editor definierten Proportion aus.

Druckdialog

Wahl des Druckers vor dem Ausdruck des Diagramms

In Zwischenablage kopieren

Darstellung in die Zwischenablage kopieren

Rückwärtsbutton viertel

verschiebt angezeigten Zeitraum um ein Viertel der gewählten Maßeinheit zurück

Vorwärtsbutton viertel

verschiebt angezeigten Zeitraum um ein Viertel der gewählten Maßeinheit nach vorne

X-Achsenbutton

öffnet Dialog für Einstellungen der X-Achse

Angezeigte Daten exportieren

exportiert alle sichtbaren Daten aller angezeigten Kurven in eine CSV-Datei

Fenster

Darstellungen

Diagrammfenster

Fenster zur Anzeige der Liniengrafik

Diagramm-Name

zeigt Diagramm-Name an

Cursor-Ausgabefenster

zeigt Position des Cursors im Diagrammfenster und die unter Diagrammeinstellungen und Cursor-Ausgabe festgelegten Werte an

Kurvenliste

Dropdownliste der Kurven

Erweiterte Kurvenliste

Kurvenliste, die zur Runtime bearbeitet werden kann:

  • Kurvenname
  • Titel
  • Farbe
  • Y-Achse
  • Aktiv

Hinweis: Steht unter Windows CE nicht zur Verfügung und wird dort durch die normale Kurvenliste ersetzt.

Filterprofile

Profilverwaltung

Profilauswahl

Gespeichertes Profil auswählen

Speichern

Einstellungen als Profil speichern

Löschen

Profil löschen

info Info

Die Kontrollelemente Cursor ein Pixel nach links und Cursor ein Pixel nach rechts bewegen den Cursor, sofern er aktiv ist, und nicht den Trend. Anstelle der Kontrollelemente können auch die Pfeiltasten der Tastatur benutzt werden. Wird beim Bewegen mittel Pfeiltasten oder Kontrollelementen die Taste Umschalt gedrückt gehalten, erfolgt die Bewegung in 10-Pixel-Schritten.


Anlegen eines neuen Diagramms

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein neues Diagramm anzulegen, projektieren Sie eine Bildumschaltung auf das Bild vom Typ Erweiterter Trend. Dabei wird der Dialog zur Konfiguration des Diagramms geöffnet:

Projektierbare Eigenschaften sind:

Parameter

Beschreibung

Datenherkunft

Onlinedaten

Verwenden Sie aktuelle Onlinewerte und gespeicherte Werte zur Darstellung in Diagrammen.

Arraydaten

Verwenden Sie Variablen mit Array-Werten zur Darstellung in Diagrammen.

Die Darstellung von Variablen mit Array-Werten funktioniert genauso wie die XY-Darstellung. Allerdings müssen Sie keinen Zeitfilter und keine X-Variable selektieren. Im Dialog X-Achse geben Sie bei Skala Von und Bis die entsprechenden Arrya-Indizes der Quelldaten ein.

Hinweis: Arraydaten meint nicht Array-Variablen, sondern die Eigenschaft Größe Blockarray, die bei einer Variablen eingestellt werden kann.

Interne ID: Anlegen eines neuen Diagramms

Größe Blockarray

Nur mehr aus Kompatibilitätsgründen vorhanden.
Bis Version 5.50 Definition der Block-Array-Größe.
Achtung: Im Intern Treiber zwar einstellbar, aber zur Runtime ohne Funktion (Wert immer 0).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Archivdaten

Verwenden Sie in der Datenbank gespeicherten Archivwerte (ARX Format oder SQL Daten) zur Darstellung in Diagrammen.

Info: Archive im XML-, dBase- oder TXT-Format werden nach Ablauf des Speicherzykluses nicht mehr angezeigt.

Daten vom Backupordner einlesen

Nur verfügbar, wenn Sie das Optionsfeld Archivdaten selektiert haben.

Für die Darstellung werden die historischen Daten aus dem Backupordner verwendet.

Darstellung

Diagramm-Name

Frei projektierbarer Diagrammname kann in Kontrollelement dargestellt werden.
Falls der String im Diagrammnamen die Zeichenkombination %c% enthält, wird diese zur Runtime durch die Chargennamen ersetzt, die die Filtervoraussetzungen erfüllen. Zum Beispiel:
Diagrammname = Diagramm1_%C%_Ende
ergibt in der Runtime
Diagramm1_Charge1_Ende

Schrift

Auswahl bzw. Einstellung der benutzerdefinierten Schrift für die Achsenbeschriftungen und die Wertanzeigen

Diagrammeinstellungen und Cursor Ausgabe

Öffnet den Dialog zur Festlegung weiterer Einstellungen für die Anzeige des Diagramms (siehe Diagrammeinstellungen und Cursor Ausgabe).

Scrollweite [%]

Festlegen des Bildscrollens, wenn der rechte Diagrammrand erreicht ist.
Achtung: nur bei Diagrammen mit Onlinewerten.

Refreshrate [s]

Festlegen der Bildaktualisierung in Sekunden.

  • Bei Onlinedaten und Arraydaten muss der Wert größer 0 sein.
  • Bei Onlinedaten und Arraydaten ist keine statische Aufschaltung möglich.
  • Bei Archivdaten passt sich Refreshrate dynamisch an die Ladezeit der Daten an. Dauert das Laden länger als das halbe Refresh-Intervall, wird die Refreshrate verdoppelt.
    Alternativ kann der Wert für Refreshrate auf 0 gesetzt werden.
    Das hat zur Folge, dass die angezeigten Daten nicht aktualisiert werden.
    Diese Einstellung ist hilfreich, wenn eine große Datenmenge im ETM angezeigt werden soll. Wenn in diesem Fall Refreshrate auf einen zu kleinen Wert gestellt ist, kann das zu einer Endlosschleife führen.

Refreshrate optimieren: Beim Einlesen von Archivdaten wird am Beginn und am Ende von Server (auch Einzelplatz) und Client eine Log-Meldung erstellt, die mit dem Diagnose Viewer gelesen werden kann. Damit kann ermittelt werden, wie lange das Lesen der Daten dauert und die Refreshrate entsprechend gewählt werden.

Offset [s]

Verschieben des Nullpunktes der Zeitachse um den angegebenen Wert in Sekunden.

X-Achse

XT-Anzeige

Darstellung der Kurven über die Zeit.

XY-Anzeige

Darstellung der Kurven über eine andere Variable.

X-Achse und Zeitfilter/Zeitachse und Zeitfilter

Öffnet den Dialog für die Einstellungen der X-Achse/Zeitachse und des Zeitfilters (siehe X-Achse und Zeitfilter).

Die Projektierung des Zeitbereiches erfolgt analog der Projektierung des Zeitfilters in AML und CEL (siehe Kapitel Zeitfilter im Handbuch Alarmmeldeliste).

Kurven

Kurve hinzufügen

Öffnet den Dialog zur Variablenauswahl.

Kurve löschen

Klicken Sie auf diese Schaltfläche, um die selektierten Kurven zu löschen.

erweiterte Kurvenliste

Öffnet Dialog Spalteneinstellungen zur Konfiguration der Spalten für die erweiterte Kurvenliste.

Kurve bearbeiten

Öffnet den Dialog für die Kurveneinstellungen und die Einstellungen für die Y-Achse (siehe Kurve bearbeiten).

Kurve anzeigen

Für jede selektierte Kurve können Sie mithilfe dieser Checkbox entscheiden, ob sie beim Aufschalten des Diagramms angezeigt werden soll.

Wenn Sie die Checkbox deaktivieren, können Sie die Kurve dann im Bild Erweiterter Trend selektieren und sich anzeigen lassen.

Das erste x rechts neben dem Kurvennamen zeigt an, ob Sie die Checkbox für diese Kurve aktiviert haben.

Y-Achse für die Kurve anzeigen

Für jede selektierte Kurve können Sie mithilfe dieser Checkbox entscheiden, ob die Y-Achse für diese Kurve beim Aufschalten des Diagramms angezeigt werden soll.

Wenn Sie die Checkbox deaktivieren, können Sie die Y-Achse für die Kurve dann im Bild Erweiterter Trend selektieren und sich anzeigen lassen.

Das zweite x rechts neben dem Kurvennamen zeigt an, ob Sie die Checkbox für diese Kurve aktiviert haben.

Optionen

Druckeinstellungen

Öffnet den Dialog für die Druckeinstellungen. Sie können Diagramme sowohl ausdrucken als auch in eine Datei speichern (siehe Diagramm drucken).

Einstellungen exportieren

Exportiert die eingestellten Diagrammparameter (Variablen, Rahmen, Zeiten etc.) in eine DRG-Datei.

Einstellungen importieren

Importiert die eingestellten Diagrammparameter (Variablen, Rahmen, Zeiten etc.) aus einer DRG-Datei.

OK, Abbruch, Hilfe

Schaltflächen für Bestätigung der Einstellungen, Abbruch und Aufruf der Hilfe.

Hinweis: Schaltfläche OK ist erst nach der Projektierung mindestens einer Kurve aktiv.

Jede Trendkurve wird mit einem eigenen Namen versehen. Um die Übersichtlichkeit nicht zu verlieren, sollten nicht zu viele Trendkurven gleichzeitig angezeigt werden. Die Projektierung kann für mehr Variablen erfolgen, die dann in der Runtime frei aktiviert werden können.

info Info

Mithilfe des Optionsfeld Arraydaten, können Sie die Anzeige auf Variablen einschränken, die auf einem Treiber basieren, der Variablen mit Array-Werten unterstützt.

Arraydaten

Um Variablen mit Arraydaten anzuzeigen:

  • definieren Sie bei den entsprechenden Variablen die Eigenschaft Größe Blockarray in der Gruppe Zusätzliche Einstellungen, zum Beispiel 10

    Interne ID: Anlegen eines neuen Diagramms

    Zusätzliche Einstellungen

    Erweiterte Eigenschaften für die Variable.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • wählen Sie bei der Funktion Bildumschaltung auf das ETM-Bild die Eigenschaft Arraydaten:

In der Variablenansicht des RGM ist erkennbar, dass jede Variable als 10er Block existiert (0 bis 9):

Ergebnis zur Runtime

Beim Runtimestart ist das ETM-Bild noch leer:

Sobald die Rezeptwerte abgesetzt wurden, werden die Werte der Variablen mit Blockarrays angezeigt:

Noch in diesem Kapitel

Kurveneinstellungen

Y-Achsenparameter

Diagrammeinstellungen und Cursor-Ausgabe

Projektierung der Zeit- bzw. Wertachse (X-Achse)

Spalteneinstellungen für erweiterte Kurvenliste


Kurveneinstellungen

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Kurveneinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für jede Trendkurve können die Kurveneigenschaften parametriert werden.

Parameter

Beschreibung

Kurve

Kurvenname

Frei definierbarer Kurvenname.
Defaultmäßig wird der Variablenname eingetragen.

Hinweis: Eine nachträgliche Änderung des Variablennames hat keinen Einfluß auf den bestehenden Kurvennamen.

Linienbreite [Pixel]

Definieren Sie die Breite der Kurve in Pixel.

Abstand vom oberen Rand [Pixel]

Nur für die Gantt-Darstellung verfügbar.

Definieren Sie den Abstand in Pixel vom Gantt Chart bis zum oberen Diagrammrand.

Darstellungsform

Festlegen der Linienart für die Trendkurve. Mögliche Darstellungsformen:

  • Linie
  • Striche
  • Punkte
  • Strich-Punkt
  • Strich-Punkt-Punkt

Hinweis: Wurde in der Eigenschaft Grafikqualität Windows Basis gewählt, können im Erweiterten Trend bei einer Linienbreite größer 1 nur durchgezogene Linien dargestellt werden.

Interne ID: Kurveneinstellungen

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Kurveneinstellungen

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: Kurveneinstellungen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interpolation

Werte werden mittels Polylinie verbunden (Stützstellen); ist die Option nicht gesetzt, werden die Wertänderungen als Liniensprünge dargestellt (Stufendarstellung)

Kurve verlängern

Die Kurve wird vom letzten vorhandenen Datenpunkt bis zum rechten Rand verlängert

Flächendarstellung

Statt als Linien werden die Werte als Flächen dargestellt

Gantt-Darstellung

Aktiviert die Gantt-Darstellung für diese Kurve. Der Kurvenname wird als Beschriftung verwendet. Hinweise zu Einschränkungen siehe Abschnitte Gantt-Darstellung und Y-Achsenparameter.

Grenzwert anzeigen

Nur für die Gantt-Darstellung verfügbar.

Der numerische Grenzwert wird dargestellt.

Grenzwerttext anzeigen

Nur für die Gantt-Darstellung verfügbar.

Die Bezeichnung des Grenzwerts wird dargestellt.

Farbe

Kurvenfarbe

Definieren Sie die Kurvenfarbe.

Füllfarbe

Definieren Sie die Füllfarbe. Dies hat nur Auswirkung, wenn Sie die Einstellung Flächendarstellung selektiert haben.

Transparenz Füllfarbe [%]

Definieren Sie die Transparenz der Füllfarbe. Dadurch können Sie vermeiden, dass Kurven von Kurven mit Flächendarstellung überdeckt werden. 0 bedeutet keine Transparenz. 100 bedeutet völlige Transparenz.

Hinweis: Unter Windows CE nicht verfügbar.

Anzeigeverschiebung

Tage

Verschiebt die Kurve um die eingestellte Anzahl an Tagen.

Stunden

Verschiebt die Kurve um die eingestellte Anzahl an Stunde.

Minuten

Verschiebt die Kurve um die eingestellte Anzahl an Sekunden.

Monatswechsel

Verschiebt die Kurve um einen Monat.

Jahreswechsel

Verschiebt die Kurve um ein Jahr.

Noch in diesem Kapitel

Gantt-Darstellung


Gantt-Darstellung

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Kurveneinstellungen -> Gantt-Darstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mithilfe der Gantt-Darstellung können Sie den Zustand einer Anlage im Erweiterten Trend visualisieren. Sie können sich z.B. anzeigen lassen, wann sich eine Anlage im Betrieb, in Wartung, in Ruhe usw. befunden hat. Durch die Darstellung im Erweiterten Trend ist es möglich, die Zustände der Anlage mit Prozesskennlinien zu vergleichen. Sie können so Rückschlüsse über das Verhalten der Anlage ziehen. Beispielsweise stellen Sie ein abnormales Verhalten der Prozesskennlinie fest, sehen aber anhand des Gantt Charts, dass sich die Anlage zu dieser Zeit in Wartung befunden hat.

Projektierung

Bei der Gantt-Darstellung werden die Grenzwerte oder Reaktionsmatritzen zur Auswertung herangezogen und nicht die eigentlichen Werte der entsprechenden Variablen. Die Anzeige spiegelt den Zustand der Anlage wider, der genaue Wert spielt keine Rolle.

Die einzelnen Gantt Charts werden im oberen Rahmen des Kontrollelements Diagramm angezeigt. Achten SIe darauf, dass Sie den Rahmen groß genug projektieren, damit es nicht zu Anzeigeproblemen kommt.

Als Grundlage für die Farbe des jeweiligen Gantt Charts wird der verletzte Grenzwert oder die Reaktionsmatrix verwendet. Dabei wird immer auf die aktuell projektierten Grenzwerte und Zustände der Rema verwendet. Wenn Sie diese ändern, werden auch historische Auswertungen mit den aktuellen Werten dargestellt. Es gibt keine Historie für die Grenzwerte oder Zustände der Rema.

Kurvenparamter

Für die Kurveneinstellungen gilt:

  • der Kurvenname wird als Beschriftung verwendet
  • Parameter werden in der Registerkarte Kurveneinstellungen eingestellt:
    • Abstand vom oberen Rand
    • Grenzwert anzeigen
    • Grenzwerttext anzeigen

    Werden die Optionen Grenzwert anzeigen und Grenzwerttext anzeigen gemeinsam verwendet, erfolgt die Anzeige als:
    Grenzwerttext/Grenzwert

  • Eigenschaften der Beschriftung werden in der Registerkarte Y-Achse eingestellt:
    • Farbe
    • Position in % der Breite der X-Achse (gemessen von links)

Folgende Einstellungen der Y-Achse stehen für Gantt-Darstellungen nicht zur Verfügung:

  • Horizontale Gitternetzlinie anzeigen
  • Achsentyp
  • Skala
  • Exponentielle Darstellung
  • Achsenunterteilung


Y-Achsenparameter

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Y-Achsenparameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem und im Dialog Kurveneinstellungen werden die Kurven-Parameter definiert.

Parameter

Beschreibung

Darstellung

Parameter für Darstellung der Kurven zur Runtime.

Achsentitel

Benennung der Achse.

Position

Positionierung der Lage der Y-Achxe auf der X-Achxe in Prozent der Länge der X-Achse.

  • 0 = links,
  • 100 = rechts

Farbe

Definition der Achsenfarbe.

Achtung: Unabhängig von der Trendkurvenfarbe projektierbar.

Horizontale Gitternetzlinien anzeigen

Anzeige von Hilfslinien an den Hauptticks.

(Für Gantt-Darstellung nicht verfügbar.)

Achsentyp

Festlegen der Skalierung der Y-Achse.

(Für Gantt-Darstellung nicht verfügbar.)

Linear

Lineare Teilung der Y-Achse.

(Für Gantt-Darstellung nicht verfügbar.)

Logarithmisch

Logarithmische Teilung der Y-Achse

Skala

Darstellungsbereich der Prozessvariablen innerhalb ihrer projektierten technischen Grenzen festlegen (Lupenfunktion).

(Für Gantt-Darstellung nicht verfügbar.)

Von

Startwert Skalierung.

Default: -32768

Bis

Endwert Skalierung.

Default: 32768

Beschriftung

Lage der Achsenbeschriftung

Links der Achse

Werte werden liks der Achse angezeigt.

Rechts der Achse

Werte werden rechts der Achse angezeigt.

Exponentielle Darstellung

Werte werden exponentiell dargestellt.

(Für Gantt-Darstellung nicht verfügbar.)

Einheit ausblenden

Aktiv: Einheit für Achsenbeschriftung wird nicht angezeigt. Ermöglicht die Darstellung mehrer Variablen mit unterschiedlichen Einheiten.

Default: inaktiv

(Für Gantt-Darstellung nicht verfügbar.)

Achsenunterteilung

Festlegen der Achsenunterteilung.

(Für Gantt-Darstellung nicht verfügbar.)

Anzahl Hauptticks

Anzahl der Hauptticks mit Wertanzeige.

Länge Hauptticks (Pixel)

Länge der Hauptticks in Pixel.

Anzahl Nebenticks

Anzahl der Unterteilungen zwischen zwei Hauptticks.

Anzahl Hauptticks automatisch

Automatische Einstellung von Skalierung und Achsenunterteilung im Onlinebetrieb.

Nach der Projektierung der Trendkurven- und der zugehörigen Y-Achsen-Parameter wird mit der Betätigung des Buttons OK die neue Trendkurve in das Diagramm übernommen. Sie wird im Diagramm als verfügbare Trendkurve (Trendkurvenname, Prozessvariablenname) angezeigt.

Für jede Trendkurve ist dann die entsprechende Verarbeitungsart (aktiv, mit Y-Achse) festzulegen. Die Projektierung erfolgt durch die Markierung der Trendkurve im Fenster und Setzen der entsprechenden Option.


Diagrammeinstellungen und Cursor-Ausgabe

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Diagrammeinstellungen und Cursor-Ausgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Weitere Festlegungen für die Darstellung des Diagramms können Sie mithilfe der Schaltfläche Diagrammeinstellungen und Cursor-Ausgabe definieren.

Folgende Einstellungen stehen Ihnen zur Verfügung.

Parameter | Beschreibung
Abstand Diagramm zum Fensterrahmen [Pixel] |
Oben | Abstand zwischen dem oberen Rand des Kontrollelementes und der darin dargestellten Trendkurven (Achtung: Platz für spätere optionale Einblendung der gespeicherten Informationen bei aktivem Zeiger)
Unten | Abstand zwischen dem unteren Rand des Kontrollelementes und der X-Achse (Ursprung 0% Y-Achse) (Achtung: Platz zur zweizeiligen Beschriftung der X-Achse bei der projektierten benutzerdefinierten Schriftart)
Links | Abstand zwischen dem linken Rand des Kontrollelementes und der Y-Achse (Ursprung 0% X-Achse) (Achtung: Platz zur linksseitigen Beschriftung der Y-Achse bei der projektierten benutzerdefinierten Schriftart)
Rechts | Abstand zwischen dem rechten Rand des Kontrollelementes und der Y-Achse (Ursprung 100% X-Achse) (Achtung: Platz zur rechtsseitigen Beschriftung der Y-Achse bei der projektierten benutzerdefinierten Schriftart)
Farben |
Hintergrundfarbe | Hintergrundfarbe der dargestellten Grafik
Gitternetzfarbe | Farbe des überlagerten Gitternetzes
Cursor-Ausgabe |
Kopfzeile im Abtastfenster im Kompatibilitätsmodus anzeigen | Aktiv: Für zenon Versionen vor 6.51 SP0 werden für das "Abtastfenster im Kompatibilitätsmodus" Spaltenüberschriften angezeigt. Wird zum Beispiel für die Anzeige konvertierter Projekte zur Runtime verwendet. Für Projekt ab Version 6.51 nicht nötig. Hier werden alle Spaltentitel in der Abtastliste angezeigt.
Datum | Spaltenbreite für den Zeitstempel in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Variable | Spaltenbreite für den Variablennamen in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Wert | Spaltenbreite für den Wert in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Einheit | Spaltenbreite für die Einheit in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Zustand | Spaltenbreite für den Zustand in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Status | Spaltenbreite für den Status in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Werte zwischen erstem und zweitem Cursor |
Minimum | Spaltenbreite des Minimalwerts zwischen ersten und zweitem Cursor in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Mittelwert | Spaltenbreite des Mittelwerts zwischen ersten und zweitem Cursor in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Maximum | Spaltenbreite des Maximalwerts zwischen ersten und zweitem Cursor in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Zeit-Differenz | Spaltenbreite der Zeit-Differenz zwischen ersten und zweitem Cursor in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Wert-Differenz | Spaltenbreite der Wert-Differenz zwischen ersten und zweitem Cursor im Cursor-Ausgabefenster. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Summe | Spaltenbreite der Summe der Messpunkte zwischen ersten und zweitem Cursor in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Standardabweichung | Spaltenbreite der Standardabweichung zwischen ersten und zweitem Cursor in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.
Anzahl Messpunkte | Spaltenbreite der Anzahl der Messpunkte zwischen ersten und zweitem Cursor in der Cursor-Ausgabeliste. Mithilfe der Checkbox können Sie diese Spalte aktivieren.

info Info

Die Titel der Kopfzeile der Cursor-Ausgabeliste sind mithilfe der Sprachumschaltung beliebig veränderbar.

Um die Kopfzeile auch bei der Konvertierung von älteren Projekten zur Verfügung zu stellen, können Sie entweder die vorhandene Cursor-Ausgabeliste löschen und durch die Neue ersetzen oder sich aktivieren die Checkbox Kopfzeile anzeigen.

Wenn Sie Projekt für eine zenon Version älter als 6.51 SP0 erstellen, können Sie nach dem Einstellen der Runtime-Zielversion die entsprechende Cursor-Ausgabeliste einfügen.

Noch in diesem Kapitel

Aussehen der Cursor-Ausgabeliste anpassen


Aussehen der Cursor-Ausgabeliste anpassen

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Diagrammeinstellungen und Cursor-Ausgabe -> Aussehen der Cursor-Ausgabeliste anpassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Aussehen der Cursor-Ausgabeliste kann an individuelle Vorgaben angepasst werden:

Bildlaufleisten, Kopfzeile und Raster

Um Größe und Aussehen von Bildlaufleisten, der Kopfzeile und eines Rasters für die Tabelle zu definieren:

  1. aktivieren Sie in den Projekteigenschaft in der Gruppe Darstellung die Eigenschaft Erweiterte grafische Einstellungen

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Erweiterte grafische Einstellungen

    Nur für PC verfügbar.

    Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

    Default: inaktiv.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie die gewünschten Eigenschaften in den Gruppen Bildlaufleisten und Kopfzeile und Raster für das Element Alarmmeldeliste im Bild

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Kopfzeile und Raster

    Eigenschaften für die Kopfzeile und das Raster.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Bildlaufleisten

    Eigenschaften für die horizontalen und vertikalen Bildlaufleisten.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wird für die Eigenschaft Anzeigestil Grafikdateien gewählt, dann werden alle Elemente, für die keine Grafikdatei ausgewählt wird, mit einem Farbverlauf dargestellt. Bei Steuerelementen für Listen können keine transparenten Grafiken verwendet werden.

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zur Runtime sortieren

Um zur Runtime die für die Sortierung relevante Spalte zu kennzeichnen und die Sortierreihenfolge zu bestimmen, projektieren Sie grafische Elemente für die Titelzeile:

  1. wählen Sie für die Eigenschaft Anzeigestil den Wert Grafikdateien
  2. verknüpfen Sie die Eigenschaften Aufsteigend sortiert und Absteigend sortiert jeweils mit einer Grafikdatei

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Absteigend sortiert

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für absteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Anzeigestil

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

    Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Winkel [°]

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

    Minimum: 0

    Maximum: 360

    Default: 0

    Mehr im Online-Handbuch AML.

    Mehr im Online-Handbuch CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Versatz [%]

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

    Minimum: -100

    Maximum: 100

    Default: 0

    Mehr im Online-Handbuch AML.

    Mehr im Online-Handbuch CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Farbverlauf

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

    Linear: gleichmäßiger Verlauf

    Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

    Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

    Default: Linear

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Verlaufsfarbe

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

    Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Füllfarbe

    Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

    Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

    Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

    Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

    Default: Standard.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Default: keine Datei

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

    Aufsteigend sortiert

    Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

    Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für aufsteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

    Default: keine Datei

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. zur Runtime wird in der für die Sortierung relevanten Spalte die gewählte Grafik für die jeweilige Sortierrichtung angezeigt
  4. Klick auf Grafik ändert Sortierreihenfolge
  5. Klicke in Spaltentitel aktiviert Spalte für Sortierung

Kopfzeile zur Runtime bedienen

Sie können Benutzern ermöglichen, die Kopfzeile zur Runtime zu bedienen. Dadurch ist eine individuelle Anpassung der Darstellung in der Runtime möglich:

  • Spalten verschieben
  • Größe ändern
  • Sortierung ändern.

Navigieren Sie dazu in den Projekteinstellungen zur Gruppe Alarmmeldeliste und wählen Sie bei der Eigenschaft Kopfzeile AML den Wert bedienbare Kopfzeile. Alternativ können Sie hier die Kopfzeile auch unbedienbar oder unsichtbar schalten.

Diese Einstellungen gelten für alle Kopfzeilen im Projekt.

info Info

Sie können die Bedienbarkeit bzw. die Sichtbarkeit der Kopfzeile für jedes Bild vom Typ Alarmmeldeliste individuell wieder unterbinden, indem Sie die Eigenschaft Kopfzeile anzeigen bzw. Kopfzeile bedienbar für die tabellarische Darstellung deaktivieren.

Interne ID: Aussehen der Cursor-Ausgabeliste anpassen

Kopfzeile bedienbar

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile selektiert haben.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Ermöglicht es die Kopfzeile für das entsprechende Listenfeld zu bedienen. Zur Runtime können Sie die einzelnen Spalten verschieben und ihre Breite verändern. Sie könne die Darstellung nach einer beliebigen Spalte sortieren.

aktiv: Die Kopfzeile ist bedienbar.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Vorschau

Mit Aktivierung der Eigenschaft Erweiterte grafische Einstellungen werden im Editor die Kopfzeile und die Bildlaufleisten als Vorschau angezeigt.So lassen sich Details wie Farben Fülleffekte, Lichteffekte oder Raster einfacher projektieren.

Achtung: Da die Größe der Bildlaufleisten in der Vorschau der Größe zur Runtime entspricht, kann die gesamte Größe des Liste im Editor von der Größe zur Runtime abweichen. Das gilt auch für die Größe der Kopfzeile und die Schrift der Kopfzeile.


Projektierung der Zeit- bzw. Wertachse (X-Achse)

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Projektierung der Zeit- bzw. Wertachse (X-Achse)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die X-Achse kann in zwei unterschiedlichen Projektierungen verwendet werden:

  • YT-Anzeige (Zeitaches): Darstellung der Trendkurven über den projektierten Zeitbereich.
    Bei der Projektierung der Zeitachse sind der Zeitbereich, die Chargen und die Achsendarstellung definierbar.
  • XY-Anzeige: Darstellung der Werte über eine Variable oder abgeleitete Variable (Ortskurven, Arbeitspunkte etc.).

Um die X-Achse zu projektieren:

  1. wählen Sie im Dialog der Bildumschaltung im Bereich X-Achse die Anzeigeart (YT-Anzeige, XY-Anzeige)
  2. klicken Sie auf die Schaltfläche Zeitachse und Zeitfilter
  3. definieren Sie die gewünschten Eigenschaften
  4. Bestätigen Sie mit OK
    (Sollten bei Wahl von Onlinedaten Zeitparameter von den in der Gruppe Hardisk Datenspeicherung projektierten Werten abweichen, wird über einen Dialog die Übernahme passender Einstellungen angeboten.)

    Interne ID: Projektierung der Zeit- bzw. Wertachse (X-Achse)

    Hardisk Datenspeicherung

    Eigenschaften für die Hardisk-Daten (HDD) Verwaltung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

YT-Anzeige

XY-Anzeige

Zeit


YT-Anzeige

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Projektierung der Zeit- bzw. Wertachse (X-Achse) -> YT-Anzeige

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Position

Position der X-Achse bezogen auf die Höhe der Y-Achse. Prozentwert zwischen 0 und 100. Zum Beispiel:

0 %: am unteren Ende der Y-Achse.

100 %: am oberen Ende der Y-Achse.

50 %: in der Mitte der Y-Achse.

Farbe

Festlegen der Achsenfarbe.

Hinweis: unabhängig von der Trendkurvenfarbe projektierbar.

Vergleich mit 2. Zeitraum

Aktiv: Vergleich mit einem zweiten Zeitraum anzeigen.

Nur für Archive mit Online-Filter möglich.

Pro Archivvariable werden zwei Zeitbereiche gleichzeitig dargestellt (z.B. Wochengegenüberstellung). Beim Aufschalten werden zwei Trends aufgeschaltet; der zweite Zeitbereich wird auf der entgegengesetzten Beschriftungsseite der Zeitachse in der Gitternetzlinienfarbe dargestellt.

Vertikale Gitternetzlinie anzeigen

Aktiv: Darstellung von Hilfslinien an den Hauptticks.

Echtzeit Darstellung

Aktiv: Die Achse wird mit den vorhandenen Zeitmarken versehen.

Inaktiv: Der Aufschaltzeitpunkt wird als 00:00 definiert und es wird relativ in die Vergangenheit beschriftet ... -01:00

Skala

Definiert Werte der Skala über Checkboxen:

JJ: Jahr

MM: Monat
TT: Tag

HH: Stunde

MM: Minuten

SS: Sekunde

MS: Millisekunde

Beschriftung

Lage der Achsenbeschriftung

Oberhalb der Achse

oben

Unterhalb der Achse

unten

Achsenunterteilung

Festlegen der Achsenunterteilung

Anzahl Hauptticks

Anzahl der Hauptunterteilungen mit Wertanzeige

Länge Hauptticks

Länge der Hauptunterteilungslinien (Pixel)

Anzahl Nebenticks

Anzahl der Unterteilungen zwischen zwei Hauptunterteilungen

Diesen Dialog zur Runtime anzeigen

Bei der Bildumschaltung zur Runtime wird dieser Dialog geöffnet.

Cursor

Darstellung des Cursors.

Größe Anfasspunkt [Pixel]

Durchmesser des kreisförmigen, mittig dargestellten Anfasspunkts zur erleichterten Bedienung der Lineale, z. B. im Touch-Betrieb.

  • 0: kein Anfasspunkt (kompatibel mit Projekten vor Version 7)
  • >0: Anfasspunkt wird entsprechend des eingegebenen Werts dargestellt

Default: 0

Maximal: 100


XY-Anzeige

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Projektierung der Zeit- bzw. Wertachse (X-Achse) -> XY-Anzeige

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Variable für X-Achse

Auswahl und Markierung einer dem Diagramm zugeordneten Prozessvariablen. Diese wird für die X-Achse verwendet.

Farbe

Festlegen der Achsenfarbe.

Hinweis: Unabhängig von der Trendkurvenfarbe projektierbar.

Achsentitel

Text der Achsenbeschriftung zur Runtime.

Position

Lage der X-Achse im Diagramm (0=unten, 100=oben).

Vertikale Gitternetzlinie anzeigen

Aktiv: Darstellung von Hilfslinien an den Hauptticks.

Achsentyp

Festlegen der Skalierung der X-Achse.
  • Linear

Lineare Teilung der X-Achse.
  • Logarithmisch

Logarithmische Teilung der X-Achse.

Skala

Darstellungsbereich der Prozessvariablen innerhalb ihrer projektierten technischen Grenzen festlegen (Lupenfunktion).

Beschriftung

Lage der Achsenbeschriftung:

Oberhalb der Achse

Werte werden über der Achse angezeigt.

Unterhalb der Achse

Werte werden unterhalb der Achse angezeigt.

Achsenunterteilung

Festlegen der Achsenunterteilung.

Anzahl Hauptticks

Anzahl der Hauptunterteilungen mit Wertanzeige.

Länge Hauptticks

Länge der Hauptunterteilungslinien (Pixel).

Anzahl Nebenticks

Anzahl der Unterteilungen zwischen zwei Hauptunterteilungen.

Anzahl Hauptticks automatisch

Automatische Einstellung von Skalierung und Achsenunterteilung im Onlinebetrieb.

Diesen Dialog zur Runtime anzeigen

Bei der Bildumschaltung zur Runtime wird dieser Dialog geöffnet.

attention Achtung

Anzeige x-Achse im Diagramm ab Version 6.51

Aus Performancegründen werden Archivdaten für die X-Achse nicht mehr automatisch geladen. Um die X-Achse im Diagramm dennoch anzuzeigen:

  • fügen Sie die für die Variable für X-Achse gewählte Variable auch als Kurve im Diagramm hinzu
  • deaktivieren Sie die Anzeige für diese Kurve

info Info

Weichen bei Onlinewerten die Zeitparameter von den in der Gruppe Hardisk Datenspeicherung projektierten Werten ab, wird über einen Dialog die Übernahme passender Einstellungen angeboten.

Interne ID: XY-Anzeige

Hardisk Datenspeicherung

Eigenschaften für die Hardisk-Daten (HDD) Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Zeit

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Projektierung der Zeit- bzw. Wertachse (X-Achse) -> Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zeitfilter bieten eine komfortable Möglichkeit, um Daten die angezeigt oder exportiert werden sollen, zu begrenzen. Die Zeitfilter sind sehr flexibel einsetzbar und können sowohl im Editor voreingestellt, als auch zur Runtime angepasst werden.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Die hier beschriebenen Mechanismen gelten bei der Bildumschaltung sowie beim Export für:

  • Alarmmeldeliste
  • Chronologische Ereignisliste
  • Archiv-Nachbearbeitung
  • Erweiterter Trend
  • Report Generator
  • Report Viewer

Die Zeitfilterung kann prinzipiell auf zwei Arten erfolgen:

  1. Zeitbereich im Editor vorgeben
    Es werden fixe Zeitbereiche verwendet. Im Editor wird ein Zeitbereich vorgegeben. In der Runtime kann nur mehr nach diesem Zeitbereich gefiltert werden. Auch andere Filter - z.B. Filtern nach Variablenname, Alarm/Ereignis-Gruppen und -Klassen usw. - sind zur Runtime nicht mehr anpassbar.
  2. Zeitfilter zur Runtime anpassbar
    Es werden vorprojektierte Zeiten verwendet. Der Zeitfilter wird im Editor vorgegeben und kann zur Runtime beliebig verändert werden.

info Info

Wird auf ein Bild referenziert, das keine Zeitfilter hat, dann werden die Zeitfilter deaktiviert.

Für die Einstellung Filter bei Zeitfiltertyp einstellen kann die Option Filterdialog in der Runtime anzeigen zwar ausgewählt werden, steht zur Runtime aber nicht zur Verfügung.

Noch in diesem Kapitel

Zeitfilter in der Runtime beliebig veränderbar

Zeitbereich im Editor vorgeben


Zeitfilter in der Runtime beliebig veränderbar

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Projektierung der Zeit- bzw. Wertachse (X-Achse) -> Zeit -> Zeitfilter in der Runtime beliebig veränderbar

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitfilter in der Runtime beliebig veränderbar

Bei dieser Methode geben Sie im Editor einen Zeitfilter vor. Dieser kann zur Runtime vor der Ausführung angepasst werden. Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über die Buttons Filter und Filter anzeigen verfügen
  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl die Einstellung Filter bei Zeitfiltertyp einstellen aus

    Hinweis: Die Option Filterdialog in der Runtime anzeigen kann zwar ausgewählt werden, steht zur Runtime für die Einstellung die Option Filter bei Zeitfiltertyp einstellen aber nicht zur Verfügung.

  4. wählen Sie den Zeitraum aus der Dropdownliste Zeitfiltertyp

Parameter

Option

Beschreibung

Absoluter Zeitraum

Es wird ein fixer Zeitbereich im Editor vorgegeben. Beim Ausführen der Funktion wird genau der eingestellte absolute Zeitbereich verwendet.
Beispiel: Sie möchten alle Alarme vom 1.1.2011 - 31.12.2011 sehen, dann geben Sie die entsprechenden Daten bei Von und Bis an.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Von

Definiert den Startzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Bis

Definiert den Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Relativer Zeitraum

Es wird ein relativer Zeitbereich angegeben.

Achtung! Dieser Filter wird ständig aktualisiert. Er wandert also mit.

Zum Beispiel: Sie stellen eine relative Zeit von 10 Minuten ein und schalten um 12:00 Uhr ein Bild vom Typ Alarmmeldeliste mit diesem Zeitfilter auf. Dann werden Ihnen beim Aufschalten die Alarme von 11:50 bis 12:00 angezeigt. Wenn das Bild vom Typ Alarmmeldeliste geöffnet bleibt, wird der Filter automatisch aktualisiert. Um 12:01 sehen Sie die Alarme von 11:51-12:01 usw.

Zeit

Definiert den relativen Zeitraum in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab HH:MM:SS Uhr

Es wird eine Uhrzeit angegeben, ab dem der Filter wirkt. Ist die Uhrzeit am heutigen Tag noch nicht erreicht, wird ab der entsprechenden Uhrzeit des Vortages gefiltert.

Beispiel: Sie geben 23:00:00 ein. Ist es bei der Ausführung der Funktion 23:30 Uhr, dann wird von 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist es jedoch 22:30 Uhr, dann wird vom Vortag 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag - HH:MM:SS Uhr

Es werden ein Tag und eine Uhrzeit für den Filterbeginn angegeben. Ist die angegebene Zeit im laufendem Monat noch nicht erreicht, wird die entsprechende Zeit des Vormonats verwendet.

Beispiel: Sie geben Tag 5 - 23:00:00 ein. Ist es bei der Ausführung der Funktion der 10. des Monats um 23:30 Uhr , dann wird vom 5. des Monats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. des Monats, dann wird vom 5. des Vormonats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filter wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag, Monat - HH:MM:SS Uhr

Es werden ein Monat, ein Tag und eine Uhrzeit für den Filterbeginn eingegeben. Ist die angegebene Zeit im laufenden Jahr noch nicht erreicht, wird die entsprechende Zeit des Vorjahres verwendet.

Beispiel: Sie geben Monat Oktober, Tag 5 - 23:00:00 ein. Ist bei der Ausführung der Funktion der 10. Oktober um 23:30 Uhr, dann wird vom 5. Oktober ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. Oktober, dann wird vom 5. Oktober des Vorjahres ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und der 5. Oktober 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Monaten, Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Kein Zeitfilter

Es wird kein Zeitfilter verwendet.

Bei Report Viewer und in der Archiv-Nachbearbeitung werden mit dieser Einstellung alle Einträge seit 1. 1. 2000 angezeigt.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Zeitbereich im Editor vorgeben

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Projektierung der Zeit- bzw. Wertachse (X-Achse) -> Zeit -> Zeitbereich im Editor vorgeben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitbereich im Editor vorgeben

Bei dieser Methode geben Sie im Editor bereits einen fixen Zeitbereich vor, der beim Ausführen der Funktion zur Runtime angewandt wird. Zur Runtime können Sie nur noch den Startzeitpunkt festlegen, aber keine weiteren Filtereinstellungen mehr verändern.

Zum Beispiel: Sie stellen einen 30 Minuten Zeitfilter ein. In der Runtime können Sie nur mehr einstellen, wann dieser 30 Minuten Zeitraum starten soll. Sie können den Filter aber nicht auf einen Tagesfilter umstellen.

attention Achtung

Bei Verwendung dieser Filterart können Sie zur Runtime auch alle anderen Filter, die auf der Karteikarte Allgemein zur Verfügung stehen, nicht mehr anpassen! Filtern auf Text, Status und Anlagen ist weiter möglich.

Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über den Button Filter verfügen, um den Filter zur Runtime zu starten

    Tipp: Aktivieren Sie im Filterdialog in der Registerkarte Allgemein die Option Filterdialog in der Runtime anzeigen. Damit können Sie den Startzeitpunkt bereits vor Ausführung der Funktion anpassen. Lassen Sie den Filter beim Aufschalten der Funktion in der Runtime nicht anzeigen, so wird immer der aktuelle Zeitbereich verwendet. Haben Sie die Option Letzen abgeschlossenen Zeitbereich verwenden aktiviert, wird der vorangegangene Zeitbereich angezeigt.
    Zum Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option Letzten abgeschlossenen Zeitbereich verwenden wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 bis 10:29:59 gesetzt.

  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl den gewünschten Filter;
    Ausnahme: Filter bei Zeitfiltertyp einstellen - dieser ist für die Option Zeitfilter zur Runtime anpassbar vorgesehen
  4. konfigurieren Sie den ausgewählten Zeitraum

Parameter

Beschreibung

Filter bei Zeitfiltertyp einstellen

Aktiviert die Möglichkeit, den Filter zur Runtime anzupassen.

Ein Tag

Es wird auf einen ganzer Tag gefiltert:
00:00:00 Uhr bis 23:59:59 Uhr.

Eine Woche

Es wird auf eine ganze Woche gefiltert:
Montag 00:00:00 Uhr bis Sonntag 23:59:59 Uhr.

Zwei Wochen

Es wird auf zwei ganze Wochen gefiltert:
Montag 00:00:00 Uhr der ersten Woche bis Sonntag 23:59:59 Uhr der zweiten Woche.

Ein Monat

Es wird auf einen ganzer Monat gefiltert:
Erster Tag des Monats 00:00:00 Uhr bis letzer Tag des Monats 23:59:59 Uhr.

Ein Jahr

Es wird auf ein ganzes Jahr gefiltert:
1.Januar des Jahres 00:00:00 Uhr bis 31. Dezember des Jahres 23:59:59 Uhr.

15 Minuten

Es wird auf einen Zeitbereich von 15 Minuten gefiltert.

30 Minuten

Es wird auf einen Zeitbereich von 30 Minuten gefiltert.

60 Minuten

Es wird auf einen Zeitbereich von 60 Minuten gefiltert.

Relativer Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein relativer Zeitraum in Tagen, Stunden (HH), Minuten (MM) und Sekunden (SS) angegeben werden kann.

Achtung! Der gewählte Zeitraum bezieht sich auf den Aufschaltzeitpunkt. Der gefilterte Zeitbereich wird daraufhin fest eingestellt.
Beispiel: Beim Aufrufen der Funktion ist es 10:23:00. Sie stellen einen relativen Zeitraum von einer Stunde ein. Der Filter wird auf 9:23:00 - 10:23:00 eingestellt.

Absoluter Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein absoluten Zeitraum eingeben könen . Sie legen dabei den Start- und Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS) fest.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Chargen

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt in dem Sie eine Charge auswählen können. Der Zeitfilter wird dann auf den Zeitraum der Charge eingestellt. Sie können damit z.B. nach allen Alarmen oder allen CEL Einträgen die während einer Charge aufgetreten sind filtern.

Hinweis: Der Filter zeigt nur abgeschlossene Chargen an.

Chargen relativ

Nur für Erweiterter Trend.

Darstellung geht immer von Nullpunkt aus. Ermöglicht direkten Vergleich mehrerer Chargen.

Optionen

Zu allen Zeitbereichen (ausgenommen absoluter und relativer Zeitbereich sowie Chargen) sind folgende Einstellungen möglich, um den Zeitbereich anzupassen:

Parameter

Option

Beschreibung

Letzten abgeschlossenen Zeitbereich verwenden

Aktiv: Es wird immer der aktuelle Zeitbereich verwendet. Ist die Option gesetzt wird der vorangegangene Zeitbereich angezeigt.

Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 Uhr bis 10:29:59 Uhr gesetzt.

Zeitbereich nach hinten verschieben um

Aktiv: Der gesamte Zeitbereich wird um die angegeben Zeit nach hinten verschoben. Der Zeitraum bleibt von dieser Einstellung unberührt.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. In der Runtime wird der Filter nun nicht zu jeder vollen Stunde beginnen, sondern immer 5 Minuten später, also z.B. um 10:05:00 Uhr um 11:05:00 Uhr usw. Gefiltert werden nach wie vor 60 Minuten also bis 11:04:59 Uhr bzw. 12:04:59 Uhr usw.

Zeit

Definiert die Zeitverschiebung in Stunden (HH), Minuten (MM), Sekunden (SS)

Zeitraum ändern um

Aktiv: Der gefilterte Zeitraum wird verkürzt oder verlängert.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. Die Option angegeben Zeit dazuzählen ist gesetzt. In der Runtime

werden nun nicht mehr 60 Minuten gefiltert sondern 65 Minuten, also z.B. von 10:00:00 Uhr bis 11:04:59 Uhr.

Zeit

Definiert die Zeit, um die der Zeitraum verkürzt oder verlängert wird. In Stunden (HH), Minuten (MM), Sekunden (SS)

angegebene Zeit dazuzählen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verlängert

angegebene Zeit abziehen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verkürzt

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Spalteneinstellungen für erweiterte Kurvenliste

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Spalteneinstellungen für erweiterte Kurvenliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Spalteneinstellungen für die Anzeige der erweiterten Kurvenliste zur Runtime zu konfigurieren:

  1. klicken Sie im Dialog der Bildumschaltung auf die Schaltfläche erweiterte Kurvenliste
  2. der Dialog zur Konfiguration der Spalten wird geöffnet

Parameter | Beschreibung
Listenfeld | Darstellung der konfigurierten Spalten.
Spaltenauswahl | Öffnet Dialog zur Auswahl der Spalten.
Spaltenformat | Öffnet Dialog zur Formatierung der Spalten.
OK | Übernimmt alle Änderungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Spaltenauswahl

Spaltenformat


Spaltenauswahl

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Spalteneinstellungen für erweiterte Kurvenliste -> Spaltenauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier konfigurieren Sie die zur Runtime anzuzeigenden Spalten.

Schaltfläche | Funktion
Hinzufügen | Verschiebt die markierten Spalten aus den verfügbaren zu den ausgewählten. Nach der Bestätigung des Dialogs mit OK werden sie in der Detailansicht angezeigt.
Alle hinzufügen | Verschiebt alle verfügbaren Spalten zu den ausgewählten Spalten.
Entfernen | Entfernt die markierten Spalten aus den ausgewählten und zeigt sie in der Liste der verfügbaren Spalten an. Nach der Bestätigung des Dialogs mit OK werden sie aus der Detailansicht entfernt.
Alle entfernen | Entfernt alle Spalten aus der Liste der ausgewählten Spalten.
Nach oben | Verschiebt den ausgewählten Eintrag nach oben. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
Nach unten | Verschiebt den ausgewählten Eintrag nach unten. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Spaltenformat

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Anlegen eines neuen Diagramms -> Spalteneinstellungen für erweiterte Kurvenliste -> Spaltenformat

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier werden die Spalten formatiert.

Parameter

Beschreibung

Verfügbare Spalten

Liste der über Spaltenauswahl bereit gestellten Spalten. Die hier selektierte Spalte wird über die Einstellungen der Sektion Parameter konfiguriert.

Parameter

Einstellungen für ausgewählte Spalte.

Beschriftung

Name für Spaltentitel. Der Spaltentitel ist online sprachumschaltbar. Dazu müsen Sie ein @ Zeichen vor den Namen eingeben.

Breite

Breite der Spalte in Zeichen.
Berechnung: Zahl mal durchschnittlicher Zeichenbreite der gewählten Schriftart.

Ausrichtung

Ausrichtung.

Mögliche Einstellungen:

  • Linksbündig: Text wird in der Spalte am linken Rand ausgerichtet.
  • Zentriert: Text wird in der Spalte zentriert dargestellt.
  • Rechtsbündig: Text wird in der Spalte am rechten Rand ausgerichtet.

Spaltenfilter im Prozessbild sperren

Aktiv: Der Filter für diese Spalte kann zur Runtime nicht verändert werden.

Hinweis: Nur verfügbar für:

  • Batch Control
  • Erweiterter Trend
  • Message Control
  • Rezeptgruppen-Manager

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Projektierungsabfolge

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Projektierungsabfolge

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Ablauf der erweiterten Trendprojektierung ist wie folgt:

Parameter | Beschreibung
neues Bild vom Typ erweiterter Trend erstellen, | eigene Schablone oder die bereits bestehende von einem weiteren erweiterten Trend zuordnen, Kontrollelemente im neuen Bild platzieren
Funktion zur Diagrammdarstellung über Bildumschaltung | Funktion 'Bildumschaltung' anlegen und das Bild vom 'Erweiterter Trend' auswählen und anschließend mit Parametern versehen
Eintrag in der Datei PROJECT.INI |


PROJECT.INI Einträge für den erweiterten Trend

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> PROJECT.INI Einträge für den erweiterten Trend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Datei PROJECT.INI sind für den erweiterten Trend folgende Einträge möglich.

Parameter | Beschreibung
[DEFAULT] |
MILLISEK= | 1 - Darstellung im Millisekundenraster, 0 - minimal im Updateraster
[EW_TREND] |
ANZEIGE_GWTEXT= | 1 - Grenzwerttext anzeigen (default), 0 - nicht anzeigen
[ARCHIV] | Archivprojektierung
ARCHDIGITS= | Anzahl der Nachkommastellen beim Export von Archiven im Format TXT, XML und DBF sowie bei der Auslagerung auf einen SQL Server. default = 1
TRENNZEICHEN= | Trennzeichen bei Auslagerung auf ASCII default = ;
SPEICHER= | maximale Anzahl der für den erweiterten Trend, die Archiv-Nacheditierung und den Reports in den Speicher zu lesenden Werte default = 1000
KANALAUSWAHL= | für ETM-Archivkanäle Checkbox für alle Kanäle bei der Auswahl 1 = darstellen (default) 2 = nicht darstellen
SQL_MAXROWS= | Maximale Anzahl auszulesender Werte aus SQL. Eintrag erfolgt in 1.000er Schritten. 100 = 100.000 Werte. Ab Version 6.50 wird zusätzlich automatisch überprüft, dass mindestens 10% Speicher frei sind.


Filterprofile

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Filterprofile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Filterprofile sind Filtereinstellungen, die der Anwender in der Runtime speichern kann. Zur Verwendung der Filterprofile gibt es im Menü Kontrollelemente ein Untermenü Filterprofile mit folgenden Elementen:

Parameter | Beschreibung
Filterprofile | Profilverwaltung
Profilauswahl | Gespeichertes Profil auswählen (Dropdownliste)
Speichern | Einstellungen als Profil speichern (Schaltfläche)
Löschen | Profil löschen (Schaltfläche)

In der Runtime können nun die Filterbedingungen geändert werden. Dann ist ein beliebiger, eindeutiger Name für die getroffenen Einstellungen in das Element Profilauswahl einzutragen. Mit der Schaltfläche Speichern wird das Profil dann gespeichert und steht bei zukünftigen Sitzungen zur Verfügung.

Nicht mehr benötigte Profile können nach Auswahl im Element Profilauswahl mit der Schaltfläche Löschen wieder gelöscht werden.


Funktionen

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Funktion Bildumschaltung - Erweiterter Trend

Harddisk Datenspeicherung

Erweiterter Trend Diagramm drucken


Funktion Bildumschaltung - Erweiterter Trend

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Funktionen -> Funktion Bildumschaltung - Erweiterter Trend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Definition eines Trenddiagramms erfolgt nach der Projektierung eines Bilds vom Typ Erweiterter Trend durch die Verwendung der Funktion Bildumschaltung.

Projektierbare Eigenschaften sind:

Parameter

Beschreibung

Datenherkunft

Onlinedaten

Verwenden Sie aktuelle Onlinewerte und gespeicherte Werte zur Darstellung in Diagrammen.

Arraydaten

Verwenden Sie Variablen mit Array-Werten zur Darstellung in Diagrammen.

Die Darstellung von Variablen mit Array-Werten funktioniert genauso wie die XY-Darstellung. Allerdings müssen Sie keinen Zeitfilter und keine X-Variable selektieren. Im Dialog X-Achse geben Sie bei Skala Von und Bis die entsprechenden Arrya-Indizes der Quelldaten ein.

Hinweis: Arraydaten meint nicht Array-Variablen, sondern die Eigenschaft Größe Blockarray, die bei einer Variablen eingestellt werden kann.

Interne ID: Funktion Bildumschaltung - Erweiterter Trend

Größe Blockarray

Nur mehr aus Kompatibilitätsgründen vorhanden.
Bis Version 5.50 Definition der Block-Array-Größe.
Achtung: Im Intern Treiber zwar einstellbar, aber zur Runtime ohne Funktion (Wert immer 0).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Archivdaten

Verwenden Sie in der Datenbank gespeicherten Archivwerte (ARX Format oder SQL Daten) zur Darstellung in Diagrammen.

Info: Archive im XML-, dBase- oder TXT-Format werden nach Ablauf des Speicherzykluses nicht mehr angezeigt.

Daten vom Backupordner einlesen

Nur verfügbar, wenn Sie das Optionsfeld Archivdaten selektiert haben.

Für die Darstellung werden die historischen Daten aus dem Backupordner verwendet.

Darstellung

Diagramm-Name

Frei projektierbarer Diagrammname kann in Kontrollelement dargestellt werden.
Falls der String im Diagrammnamen die Zeichenkombination %c% enthält, wird diese zur Runtime durch die Chargennamen ersetzt, die die Filtervoraussetzungen erfüllen. Zum Beispiel:
Diagrammname = Diagramm1_%C%_Ende
ergibt in der Runtime
Diagramm1_Charge1_Ende

Schrift

Auswahl bzw. Einstellung der benutzerdefinierten Schrift für die Achsenbeschriftungen und die Wertanzeigen

Diagrammeinstellungen und Cursor Ausgabe

Öffnet den Dialog zur Festlegung weiterer Einstellungen für die Anzeige des Diagramms (siehe Diagrammeinstellungen und Cursor Ausgabe).

Scrollweite [%]

Festlegen des Bildscrollens, wenn der rechte Diagrammrand erreicht ist.
Achtung: nur bei Diagrammen mit Onlinewerten.

Refreshrate [s]

Festlegen der Bildaktualisierung in Sekunden.

  • Bei Onlinedaten und Arraydaten muss der Wert größer 0 sein.
  • Bei Onlinedaten und Arraydaten ist keine statische Aufschaltung möglich.
  • Bei Archivdaten passt sich Refreshrate dynamisch an die Ladezeit der Daten an. Dauert das Laden länger als das halbe Refresh-Intervall, wird die Refreshrate verdoppelt.
    Alternativ kann der Wert für Refreshrate auf 0 gesetzt werden.
    Das hat zur Folge, dass die angezeigten Daten nicht aktualisiert werden.
    Diese Einstellung ist hilfreich, wenn eine große Datenmenge im ETM angezeigt werden soll. Wenn in diesem Fall Refreshrate auf einen zu kleinen Wert gestellt ist, kann das zu einer Endlosschleife führen.

Refreshrate optimieren: Beim Einlesen von Archivdaten wird am Beginn und am Ende von Server (auch Einzelplatz) und Client eine Log-Meldung erstellt, die mit dem Diagnose Viewer gelesen werden kann. Damit kann ermittelt werden, wie lange das Lesen der Daten dauert und die Refreshrate entsprechend gewählt werden.

Offset [s]

Verschieben des Nullpunktes der Zeitachse um den angegebenen Wert in Sekunden.

X-Achse

XT-Anzeige

Darstellung der Kurven über die Zeit.

XY-Anzeige

Darstellung der Kurven über eine andere Variable.

X-Achse und Zeitfilter/Zeitachse und Zeitfilter

Öffnet den Dialog für die Einstellungen der X-Achse/Zeitachse und des Zeitfilters (siehe X-Achse und Zeitfilter).

Die Projektierung des Zeitbereiches erfolgt analog der Projektierung des Zeitfilters in AML und CEL (siehe Kapitel Zeitfilter im Handbuch Alarmmeldeliste).

Kurven

Kurve hinzufügen

Öffnet den Dialog zur Variablenauswahl.

Kurve löschen

Klicken Sie auf diese Schaltfläche, um die selektierten Kurven zu löschen.

erweiterte Kurvenliste

Öffnet Dialog Spalteneinstellungen zur Konfiguration der Spalten für die erweiterte Kurvenliste.

Kurve bearbeiten

Öffnet den Dialog für die Kurveneinstellungen und die Einstellungen für die Y-Achse (siehe Kurve bearbeiten).

Kurve anzeigen

Für jede selektierte Kurve können Sie mithilfe dieser Checkbox entscheiden, ob sie beim Aufschalten des Diagramms angezeigt werden soll.

Wenn Sie die Checkbox deaktivieren, können Sie die Kurve dann im Bild Erweiterter Trend selektieren und sich anzeigen lassen.

Das erste x rechts neben dem Kurvennamen zeigt an, ob Sie die Checkbox für diese Kurve aktiviert haben.

Y-Achse für die Kurve anzeigen

Für jede selektierte Kurve können Sie mithilfe dieser Checkbox entscheiden, ob die Y-Achse für diese Kurve beim Aufschalten des Diagramms angezeigt werden soll.

Wenn Sie die Checkbox deaktivieren, können Sie die Y-Achse für die Kurve dann im Bild Erweiterter Trend selektieren und sich anzeigen lassen.

Das zweite x rechts neben dem Kurvennamen zeigt an, ob Sie die Checkbox für diese Kurve aktiviert haben.

Optionen

Druckeinstellungen

Öffnet den Dialog für die Druckeinstellungen. Sie können Diagramme sowohl ausdrucken als auch in eine Datei speichern (siehe Diagramm drucken).

Einstellungen exportieren

Exportiert die eingestellten Diagrammparameter (Variablen, Rahmen, Zeiten etc.) in eine DRG-Datei.

Einstellungen importieren

Importiert die eingestellten Diagrammparameter (Variablen, Rahmen, Zeiten etc.) aus einer DRG-Datei.

OK, Abbruch, Hilfe

Schaltflächen für Bestätigung der Einstellungen, Abbruch und Aufruf der Hilfe.

Hinweis: Schaltfläche OK ist erst nach der Projektierung mindestens einer Kurve aktiv.

Jede Trendkurve wird mit einem eigenen Namen versehen. Um die Übersichtlichkeit nicht zu verlieren, sollten nicht zu viele Trendkurven gleichzeitig angezeigt werden. Die Projektierung kann für mehrere Variablen erfolgen, die dann in der Runtime frei aktiviert werden können.


Harddisk Datenspeicherung

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Funktionen -> Harddisk Datenspeicherung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollen Online-Variablen im Erweiterten Trend angezeigt werden, empfiehlt sich eine Abstimmung der Werte für das Speichern der Variablenwerte auf der Festplatte. Wurde bei der Konfiguration der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend die Option Onlinedaten gewählt, wird beim Schließen des Dialog ein Dialog für die Festlegung von Zykluszeit und Anzahl der Werte geöffnet.

Dieser Dialog schlägt optimale Werte für das Speichern der Variablenwerte auf der Festplatte vor. Mit Klick auf OK werden die Werte übernommen und in die entsprechenden Eigenschaften bei den Variablen eingetragen. Abbrechen erstellt die Bildumschaltung, ohne die Werte bei den Variablen zu ändern. Diese können auch manuell angepasst werden.

Parameter

Beschreibung

Vorschlag für zu speichernde Werte

Vom System vorgeschlagene Werte für die Eigenschaften der Gruppe Hardisk Datenspeicherung.

Interne ID: Harddisk Datenspeicherung

Hardisk Datenspeicherung

Eigenschaften für die Hardisk-Daten (HDD) Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Anzahl

Anzahl der Werte, die geschrieben werden. Entspricht Wert, der in die Eigenschaft Anzahl Werte eingetragen wird.

Interne ID: Harddisk Datenspeicherung

Anzahl Werte

Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
Werteanzahl für die Ablage von Onlinewerten auf der Festplatte (Ringspeicher) für die Auswertung im Dynamischen Element Trend, für Onlinedaten im Erweiterten Trend oder den Export/Import der Werte.

Interne ID: Harddisk Datenspeicherung

Harddisk Datenspeicherung aktiv

Aktiv: Variablenwerte werden auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element "Trendelement" oder den Export/Import der Werte gespeichert.

Inaktiv: Keine Variablenwerte werden gespeichert.

Default: inaktiv.

Die HD-Daten brauchen je gespeicherten HD-Wert 24 Bytes Platz, unabhängig vom zu speichernden Variablentyp. Neben dem Wert werden noch folgende Informationen gespeichert:
- Zeit, zu der der Wert gemessen wurde.
- Millisekunden beim Einlesen des Wertes.
- Status des Wertes um Elemente entsprechend anzupassen.
- Zähler für eindeutige Kennung des Wertes (Spontantreiber).

Hinweis: Die Datenspeicherung wird auch bei der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend aktiviert, wenn Onlinedaten ausgewertet werden.
Variablen vom Typ String werden von der Harddisk-Datenspeicherung nicht unterstützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zykluszeit [s]

Zykluszeit in Sekunden. Entspricht Wert, der in die Eigenschaft Zykluszeit [s] eingetragen wird.

Interne ID: Harddisk Datenspeicherung

Zykluszeit [s]

Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
Intervallzeit [in Sekunden] für die Ablage von Onlinewerten auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element Trend, für Onlinedaten im Erweiterten Trend oder den Export/Import der Werte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Listenfeld

Zeigt aktuelle Werte der Variablen an, die durch die vorgeschlagenen Werte ersetzt werden sollen.

Vorschlag übernehmen

Schreibt vorgeschlagene Werte in die jeweiligen Eigenschaften der Variablen und schließt Dialog.

Ist die Eigenschaft Harddisk Datenspeicherung aktiv deaktiviert, wird sie aktiviert.

Vorschlag ablehnen

Schließt Dialog, ohne die Werte bei den Variablen zu ersetzen. Diese können jederzeit manuell geändert werden.

Hilfe

Öffnet die Online-Hilfe

Bei den Variablen finden Sie die Einstellungen in der Gruppe Harddisk Datenspeicherung. Diese umfasst die Eigenschaften:

Interne ID: Harddisk Datenspeicherung

Harddisk Datenspeicherung

Eigenschaften für das Speichern von Variablenwerten auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Harddisk Datenspeicherung aktiv: Schaltet Datenspeicherung ein oder aus.
  • Anzahl Werte: Anzahl der Werte, die gespeichert werden.
  • Zykluszeit [s]: Zykluszeit in Sekunden.
  • Aufzeichnungsart: Art der Speicherung:

    Interne ID: Harddisk Datenspeicherung

    Aufzeichnungsart

    Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
    Harddisk-Daten (zyklisch): Zyklisches Schreiben der Werte auf die Festplatte.
    Nachsortierte Werte (RDA): Die Werte werden blockweise vom Treiber auf die Festplatte geschrieben. (Für Post-Mortem-Analyse bei Fehler auf der Steuerung geeignet.)

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Harddisk-Daten (zyklisch): Zyklisches Schreiben der Werte auf die Festplatte.
    • Nachsortierte Werte (RDA): Die Werte werden blockweise vom Treiber auf die Festplatte geschrieben.
      Eignet sich für Post-Mortem-Analyse. Steuerung muss dafür konfiguriert werden, im Fehlerfall Daten zu speichern und nach erneuter Inbetriebnahme auf die festplatte zu schreiben.


Erweiterter Trend Diagramm drucken

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Funktionen -> Erweiterter Trend Diagramm drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mithilfe dieser Funktion können Sie Diagramme des Erweiterten Trends ausdrucken oder in einer Datei (JPG oder BMP) speichern, ohne dass Sie das Bild vom Typ Erweiterter Trend aufschalten müssen.

Sie finden die Funktion in der Funktionsliste im Knoten Anwendungen.

Hinweis: Ausdrucke über den Button Drucken des Bildes Erweiterer Trend unterscheiden sich im Ergebnis eventuell vom Drucken über die Funktion Erweiterter Trend Diagramm drucken. Die Funktion geht von einem Fenster der Größe 1000 x 700 aus. Drucken über den Button geht von der im Editor definierten Proportion aus.

Noch in diesem Kapitel

Allgemein

Kopf-/Fußzeile

Überschrift/Kommentar


Allgemein

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Funktionen -> Erweiterter Trend Diagramm drucken -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Ausgabe |
Drucker | Wenn Sie dieses Optionsfeld selektieren, wird das Diagramm auf dem Drucker ausgegeben, den Sie als Drucker für Screenshots definiert haben. Siehe auch Kapitel Drucker.
Datei | Wenn Sie dieses Optionsfeld selektieren, wird das Diagramm als Datei gespeichert. Mithilfe der Dropdownliste legen Sie fest, ob das Diagramm als JPG oder BMP gespeichert wird. Im Feld neben der Dropdownliste wird der Name der Datei angezeigt. Den Namen können Sie mithilfe der folgenden beiden Optionsfelder und der Checkbox Mit Präfix definieren.
Freier Name | Wenn Sie dieses Optionsfeld selektieren, können Sie einen beliebigen Namen für die Datei in das Eingabefeld eingeben.
Automatischer Name | Wenn Sie dieses Optionsfeld selektieren, wird der Dateiname automatisch in folgendem Format erstellt. YYYYMMDD_HHMM
Mit Präfix | Nur verfügbar, wenn Sie Automatischer Name selektiert haben. Geben Sie einen beliebigen Präfix für den automatisch erstellten Dateinamen ein.
Breite [Pixel] | Geben Sie die Breite für die Grafikdatei in Pixel an.
Höhe [Pixel] | Geben Sie die Höhe für die Grafikdatei in Pixel an.
Legende |
Anzeigen | Aktivieren Sie die Checkbox, wenn Sie die Legende zusammen mit dem Diagramm ausdrucken möchten. In der Legende ist z.B. aufgeführt, welche Farbe welche Kurve hat.
Seitenbereich |
Auf eine Seite drucken | Aktivieren Sie die Checkbox, wenn Sie die Legende auf derselben Seite wie das Diagramm sein soll.


Kopf-/Fußzeile

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Funktionen -> Erweiterter Trend Diagramm drucken -> Kopf-/Fußzeile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Ausdruck eines Erweiterten Trend Diagramms können zusätzliche Informationen für die Kopf- und Fußzeile für den Ausdruck projektiert werden. Mithilfe der vier Symbole können Sie Datum, Uhrzeit, Diagramm-Name und Seitenzahl einfügen.


Überschrift/Kommentar

Handbuch -> Erweiterter Trend -> Projektieren im Editor -> Funktionen -> Erweiterter Trend Diagramm drucken -> Überschrift/Kommentar

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Ausdruck eines Erweiterten Trend Diagramms können Sie zusätzlich eine Überschrift mit Kommentar projektieren. Mithilfe der vier Symbole können Sie Datum, Uhrzeit, Diagramm-Name und Seitenzahl einfügen.


Bedienen zur Runtime

Handbuch -> Erweiterter Trend -> Bedienen zur Runtime

Im Online-Betrieb wird das Fenster für den Erweiterten Trend über einen Funktionsaufruf (z.B. Button) geöffnet. Es wird die Online-Maske des im Editor vordefinierten Bildes aufgeschaltet.

Mit erweiterter Kurvenliste:

Für die Bedienung des Erweiterten Trends und die Anzeigen stehen je nach Projektierung unterschiedliche Kontrollelemente zur Verfügung. Projektierbar sind:

Element

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Buttons

vordefinierte Bedienelemente

Diagrammbutton

Diagrammparameter ändern

Kurvenbutton

Kurvenparameter ändern

Diagrammeinstellungen

aktiviert Dialog für Diagrammeinstellungen und Cursor-Ausgabe

Zoomenbutton

Darstellung vergrößern

Rezoomenbutton

Darstellung verkleinern

Zoom +

verringert Zeitabstände der Darstellung

Zoom -

vergrößert Zeitabstände der Darstellung

Refreshbutton

Darstellung aktualisieren

Rückwärtsbutton

Auf der Zeitachse zurück scrollen (Historie)

Vorwärtsbutton

Auf der Zeitachse vorwärts scrollen (Aktuell)

Stopbutton

Bildschirm nicht aktualisieren

Playbutton

Bildschirm aktualisieren

Cursor ein/aus

Werte abfragen

Doppelcursor ein/aus

Werte, die zwischen 2 Cursor liegen, anzeigen.

Cursor ein Pixel nach links

Setzt Cursor ein Pixel nach links.

Wird gleichzeitig die Taste Umschalt gedrückt, wird der Cursor um 10 Pixel bewegt.

Cursor ein Pixel nach rechts

Setzt Cursor ein Pixel nach rechts.

Wird gleichzeitig die Taste Umschalt gedrückt, wird der Cursor um 10 Pixel bewegt.

Drucken

Druckt Diagramm.

Hinweis: Ausdrucke über den Button Drucken des Bildes Erweiterer Trend unterscheiden sich im Ergebnis eventuell vom Drucken über die Funktion Erweiterter Trend Diagramm drucken. Die Funktion geht von einem Fenster der Größe 1000 x 700 aus. Drucken über den Button geht von der im Editor definierten Proportion aus.

Druckdialog

Wahl des Druckers vor dem Ausdruck des Diagramms

In Zwischenablage kopieren

Darstellung in die Zwischenablage kopieren

Rückwärtsbutton viertel

verschiebt angezeigten Zeitraum um ein Viertel der gewählten Maßeinheit zurück

Vorwärtsbutton viertel

verschiebt angezeigten Zeitraum um ein Viertel der gewählten Maßeinheit nach vorne

X-Achsenbutton

öffnet Dialog für Einstellungen der X-Achse

Angezeigte Daten exportieren

exportiert alle sichtbaren Daten aller angezeigten Kurven in eine CSV-Datei

Fenster

Darstellungen

Diagrammfenster

Fenster zur Anzeige der Liniengrafik

Diagramm-Name

zeigt Diagramm-Name an

Cursor-Ausgabefenster

zeigt Position des Cursors im Diagrammfenster und die unter Diagrammeinstellungen und Cursor-Ausgabe festgelegten Werte an

Kurvenliste

Dropdownliste der Kurven

Erweiterte Kurvenliste

Kurvenliste, die zur Runtime bearbeitet werden kann:

  • Kurvenname
  • Titel
  • Farbe
  • Y-Achse
  • Aktiv

Hinweis: Steht unter Windows CE nicht zur Verfügung und wird dort durch die normale Kurvenliste ersetzt.

Filterprofile

Profilverwaltung

Profilauswahl

Gespeichertes Profil auswählen

Speichern

Einstellungen als Profil speichern

Löschen

Profil löschen

info Info

Die Kontrollelemente Cursor ein Pixel nach links und Cursor ein Pixel nach rechts bewegen den Cursor, sofern er aktiv ist, und nicht den Trend. Anstelle der Kontrollelemente können auch die Pfeiltasten der Tastatur benutzt werden. Wird beim Bewegen mittel Pfeiltasten oder Kontrollelementen die Taste Umschalt gedrückt gehalten, erfolgt die Bewegung in 10-Pixel-Schritten.

info Info

Die Refreshrate passt sich beim Archiv-Trend dynamisch an die Ladezeit der Daten an. Dauert das Laden länger als das halbe Refresh-Intervall, wird die Refreshrate verdoppelt.

Cursor

Klicken Sie auf den Button Cursor ein/aus, um den Abtastungsmodus zu starten. Es erscheint ein Cursor in der Mitte des Diagramms. Sie können den Cursor bewegen, indem Sie auf ihn klicken und bei gedrückter Maustaste die Maus bewegen. Alternativ können Sie auch die Tastatur verwenden. Drücken Sie Nach-links oder Nach-rechts, um den Cursor in kleinen Schritten zu bewegen. Um größere Schritte auszuführen, halten Sie zusätzlich die Umschalttaste gedrückt. Den zugehörigen Wert sehen Sie im Cursor-Ausgabefenster. Klicken Sie erneut auf den Button Cursor ein/aus, um den Abtastmodus zu beenden. Sie können sich folgende Informationen im Cursor-Ausgabefenster anzeigen lassen:

Parameter | Beschreibung
Datum | Datum/Zeit des gespeicherten Wertes
Variable | Variablenname des gespeicherten Wertes
Wert | technischer Wert des gespeicherten Wertes
Einheit | Einheit des gespeicherten Wertes
Zustand | Zustandstext (Grenzwerttext) des gespeicherten Wertes
Status | Status des gespeicherten Wertes
Minimum | Minimalwert des Darstellungszeitraums (optional)
Mittelwert | Mittelwert des Darstellungszeitraums (optional)
Maximum | Maximalwert des Darstellungszeitraums (optional)

Um die angezeigten Informationen und die jeweiligen Spaltenbreiten zu verändern, klicken Sie auf die Schaltfläche Diagrammeinstellungen... ; das Fenster Diagrammeinstellungen und Cursor-Ausgabe öffnet sich:

Im Bereich Cursor-Ausgabe stellen Sie die Spaltenbreiten für die verschiedenen Informationen im Cursor-Ausgabefenster ein. Mithilfe der Checkbox entscheiden Sie, welche Spalten Sie angezeigt bekommen.

Doppelcursor ein/aus

Wenn Sie das Kontrollelement Doppelcursor ein/aus projektiert haben, haben Sie die Möglichkeit einen zweiten Cursor im Diagramm zu verwenden. Damit ist eine Abtastung mit zwei Cursor möglich. Klicken Sie auf den Button Doppelcursor an/aus, um sich zwei Cursor einen am linken und einen am rechten Ende des Diagrammfensters anzeigen zu lassen. Sie können den zweiten Cursor mit der Maus oder auch mit der Tastatur bewegen. Dazu halten sie Strg gedrückt und drücken Sie Nach-links oder Nach-rechts, um den Cursor in kleinen Schritten zu bewegen. Um größere Schritte auszuführen, halten Sie zusätzlich die Umschalttaste gedrückt.

Sie können sich die Werte zwischen erstem und zweitem Cursor im Cursor-Ausgabefenster anzeigen lassen. Die Spalten, die Ihnen zur Verfügung stehen, können Sie im Dialog Diagrammeinstellungen und Cursor-Ausgabe nach Ihren Vorstellungen anpassen.

info Info

Bei der Darstellungsart Arrydaten ist der Doppelcursor nicht verfügbar.

Diagrammeinstellungen

Aus der bestehenden Projektierung, die im Editor vorgenommen wurde, können zur Laufzeit temporäre Änderungen (ohne Speicherung) vorgenommen werden. Klicken Sie dazu auf die Schaltfläche Diagramm..., um das Fenster Diagramm anlegen zu öffnen (siehe Screenshot).

Mögliche Änderungen sind:

Parameter | Beschreibung
Aktiv | Aktiviert und deaktiviert die Anzeige der Kurve
Y-Achse | Darstellung der Y-Achse zur Kurve
Kurve ändern | Ändern der Eigenschaften der selektierten Trendkurve
Diagrammeinstellungen und Cursor-Ausgabe | Einstellungen der Diagrammparameter (Diagrammhintergrund, Rahmengrenzen, Farbe, Spaltenbreiten etc.)
Schrift | benutzerdefinierte Schrift für X- und Y-Achsenbeschriftung sowie Wertanzeige
Refreshrate | Aktualisierung des Diagramms bei Onlinedaten

Noch in diesem Kapitel

Daten exportieren

Erweiterte Kurvenliste bedienen

Filter bei Bildumschaltung

Hinweise zur Onlinebedienung

Schnelle Änderung der Achsenparameter im Onlinebetrieb


Daten exportieren

Handbuch -> Erweiterter Trend -> Bedienen zur Runtime -> Daten exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Als Kontrollelement kann für Erweiterter Trend ein Button Alle Daten exportieren ins Bild eingefügt und zur Runtime genutzt werden. Dabei werden alle sichtbaren Daten aller angezeigten Kurven in einer Textdatei im CSV-Format gespeichert.

Format der CSV-Datei

  • Die Ausgabe erfolgt in eine Unicode Textdatei.
  • Trennzeichen: Semikolon (;)
  • Speicherort und Dateiname können im Speicherdialog frei gewählt werden.
  • Die Datei hat keinen Header.
  • Die Daten werden in der Textdatei dieser Reihenfolge angezeigt:

    Variablenname;Kennung;Wert;Einheit;Status;Zeit

Eigenschaft

Format

Variablenname:

Zeichenkette

Kennung:

Zeichenkette

Wert:
  • bis zu 8 Stellen vor dem Dezimaltrenner,
  • 8 Stellen hinter dem Dezimaltrenner

Einheit:

Zeichenkette

Status:

Zeichenkette

Zeit:

dd.mm.yyyy hh:mm:ss.ms

Ist eine exportierte Variableneigenschaft leer, wird nichts ausgegeben.

Beispiel: MyVarREAL_4;;978.45000000;;SPONT;09.09.2011 09:37:44.443

attention Achtung

Werden viele Kurven zum Export ausgewählt, kann die Datensammlung erhebliche Zeit in Anspruch nehmen.


Erweiterte Kurvenliste bedienen

Handbuch -> Erweiterter Trend -> Bedienen zur Runtime -> Erweiterte Kurvenliste bedienen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wird im Editor die erweiterte Kurvenliste projektiert, so können Kurven zur Runtime bearbeitet werden. Es ist möglich:

  • nach Name, Titel, Farbe, Y-Achse und Aktivierung zu filtern
  • Kurvennamen zu bearbeiten
  • Titel zu bearbeiten
  • Farben zu bearbeiten
  • Y-Achse zu aktivieren oder zu deaktivieren
  • Kurven zu aktivieren oder zu deaktivieren

Um ein Element zu bearbeiten, klicken Sie in die entsprechende Zelle der Liste.

info Info

Unter Windows CE kann die erweiterte Kurvenliste nicht dargestellt werden und wird dort durch die normale Kurvenliste ersetzt.

Checkboxen mit Grafik gestalten

Checkboxen können mit Grafiken individuell gestaltet werden. Dazu konfigurieren Sie im Editor die entsprechenden Eigenschaften der Kurvenliste:

  • Ein

    Interne ID: Erweiterte Kurvenliste bedienen

    Ein

    Auswahl einer Grafik, die zur Runtime den Status „Wert ist 1 und Eigenschaft kann editiert werden" darstellt.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ein (inaktiv)

    Interne ID: Erweiterte Kurvenliste bedienen

    Ein (inaktiv)

    Auswahl einer Grafik, die zur Runtime den Status „Wert ist 1 und Eigenschaft kann nicht editiert werden" darstellt.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Aus

    Interne ID: Erweiterte Kurvenliste bedienen

    Aus

    Auswahl einer Grafik, die zur Runtime den Status „Wert ist 0 und Eigenschaft kann editiert werden" darstellt.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Aus (inaktiv)

    Interne ID: Erweiterte Kurvenliste bedienen

    Aus (inaktiv)

    Auswahl einer Grafik, die zur Runtime den Status „Wert ist 0 und Eigenschaft kann nicht editiert werden" darstellt.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Als Grafikdateien können ... Die definierte Grafik wird zur Runtime mit Rücksicht auf die Seitenverhätnisse (Aspect Ratio) gezeichnet.


Filter bei Bildumschaltung

Handbuch -> Erweiterter Trend -> Bedienen zur Runtime -> Filter bei Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie ein Bild vom Typ Erweiterter Trend aufschalten, wird Ihnen folgender Filter angezeigt

Parameter

Beschreibung

Chargenfilter

Auf der linken Seite können Sie aus den verfügbaren Archiven das gewünschte auswählen. Auf der rechten Seite werden Ihnen die verfügbaren Chargen angezeigt. Sie haben die Möglichkeit dort die Chargen zu filtern.

Chargenname

In dieser Spalte werden Ihnen die Namen aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen alphabetisch aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie eine Zeichenfolge eingeben. Nur Chargen mit der jeweiligen Zeichenfolge werden angezeigt.

Startdatum

In dieser Spalte wird Ihnen das Startdatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Startzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Startdatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Startzeit

Nur verfügbar, wenn Sie ein Startdatum eingeben.

In dieser Spalte wird Ihnen die Startzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Startzeit manuell festlegen.

Hinweis: '*' bedeutet 0:00:00 Uhr.

Enddatum

In dieser Spalte wird Ihnen das Enddatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Endzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Enddatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Endzeit

Nur verfügbar, wenn Sie ein Enddatum eingeben.

In dieser Spalte wird Ihnen die Endzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Endzeit manuell festlegen.

Hinweis: '*' bedeutet 23:59:59 Uhr.

Dauer

Diese Spalte zeigt Ihnen die Dauer aller verfügbaren Chargen an. Sie dient nur der Anzeige.

info Info

Es werden auch noch nicht abgeschlossene Chargen angezeigt, falls sie den Filterkriterien entsprechen.

info Info

Der Wert der Chargenvariable wird beim Beginn der Charge sowohl in die Index-Datei also auch in den Header der ARX-Datei geschrieben. Bei jeder Änderung dieser Variable werden diese Einträge angepasst. Beim Abschließen der Charge wird der aktuelle Wert der Chargenvariable endgültig in die Index-Datei und in den Header geschrieben.

Erst wenn eine Charge abgeschlossen ist, ist der Chargenname festgeschrieben.


Hinweise zur Onlinebedienung

Handbuch -> Erweiterter Trend -> Bedienen zur Runtime -> Hinweise zur Onlinebedienung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der aktuelle Diagrammname kann auf einem Kontrollelement beim Aufschalten des Diagramms im Onlinebetrieb eingeblendet werden.

Die Betätigung des Buttons Zoomen gibt die Möglichkeit, die vorhandenen Werte in einer feineren Auflösung und in einem kleineren Intervall (X- und Y-Achse) darzustellen. Der Zoomvorgang wird nach der Betätigung und dem Aufziehen eines Bereiches auf dem Diagramm aktiviert. Es ist ein mehrfaches Zoomen möglich. Ein Zoomen ist nur dann möglich, wenn der gewählte Bereich mindestens eine Unterteilung pro Achse umfasst.

Die Betätigung des Buttons Rezoomen schaltet den Zoomfaktor in den Stufen zurück, in denen er vorher definiert wurde.

Werden im erweiterten Trend Archivwerte angezeigt oder ist die laufende Aktualisierung der Onlinedaten abgeschaltet, werden die aktuellen Werte der Kurven mit der Betätigung des Buttons Refresh bis zum aktuellen Zeitpunkt neu eingelesen. Oder es wird über die unter Diagramm vorgegebene Refreshzeit aktualisiert.

Ein Blättern im erweiterten Trend über die dargestellte X-Achse hinaus ist mit der Verwendung der Buttons << (ältere Werte anzeigen) bzw. >> (aktuellere Werte anzeigen) möglich. Werden Onlinedaten angezeigt, ist maximal die zur Prozessvariablen definierten HD-Eintragtiefe darstellbar. Sind Archivwerte dargestellt, ist die Projektierung der in der Datenbank gespeicherten Archive ausschlaggebend.

Bei Onlinedaten und durchlaufender Aktualisierung springt die Darstellung bei jedem Refresh immer an den aktuellsten Eintrag. D.h., ist ein Blättern erwünscht, muss bei Onlinedaten die laufende Aktualisierung abgeschaltet werden. Das Abschalten erfolgt mit der Betätigung des Buttons Stopp. Ein Blättern und Zoomen ist möglich. Soll die laufende Aktualisierung wieder aktiviert werden, ist der Button Play zu betätigen. Mit dem nächsten Refreshzyklus des Diagramms werden die neuen Daten und der neue X-Achsenbereich aktualisiert.

info Info

Online-Variablen im Erweiterten Trend:

Die Online-Variablen für den Erweiterten Trend werden im Editor projektiert und können zur Runtime nicht mehr verändert werden. Bei der Konfiguration im Editor wird auch der HDD-Ringpuffer für die Variable konfiguriert. Zur Runtime ist es nicht möglich, den Ringpuffer für Variablen zu erstellen oder zu ändern. Daher können Kurven von Online-Variablen zur Runtime nicht angepasst werden.

Variablen aus Archiven können auch zur Runtime weiter hinzugefügt werden.

Die angezeigten Informationen sind:

Element | Beschreibung
Kurvenfarbe | Text in der Farbe, in der die Kurve projektiert ist
Datum | Datumstempel des abgefragten Wertes
Zeit | Zeitstempel des abgefragten Wertes
Name | Kurvenname
Wert | technischer Wert
Grenzwertanzeige | Anzeige eines gesetzten Grenzwertes, wenn Einstellung in Datei project.ini [EW_TREND] ANZEIGE_GWTEXT=1 Grenzwerttext 0 = nicht anzeigen 1 = anzeigen (default)


Schnelle Änderung der Achsenparameter im Onlinebetrieb

Handbuch -> Erweiterter Trend -> Bedienen zur Runtime -> Schnelle Änderung der Achsenparameter im Onlinebetrieb

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Werte angezeigter Kurven exakt festzustellen, können die X-Achse und Y-Achse verschoben werden. Das Verschieben ist möglich über:

  • Drag&Drop mit der linken Maustaste
    • X-Achse vertikal verschieben
    • Y-Achse horizontal verschieben
      Die Y-Achse wird beim Verschieben dupliziert: Während die Kopie bewegt wird, bleibt die Originalachse am Platz.
  • rechten Mausklick auf die Achse, um den Dialog zur Konfiguration zu öffnen:
    Dialog X-Achse
    Dialog Y-Achse

Erneutes Aufschalten des Bildes setzt Verschiebung zurück.


Funktionen

Handbuch -> Funktionen

Die Eingriffe der Benutzer in zenon werden über benutzerdefinierte Projektfunktionen realisiert. Alle in einem Projekt verwendeten Funktionen basieren auf den vorhandenen Systemfunktionen. Es handelt sich um vordefinierte Makros, die vom Projektanten einfach benutzt und parametriert werden können.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Funktion neu | Öffnet den Assistenten zum Anlegen einer neuen Funktion.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei.
Nicht verwendete Funktionen anzeigen | Erstellt Projektanalyse für nicht verwendete Funktionen im aktuellen Projekt und zeigt diese als Ergebnisliste in einem eigenen Fenster an.
In neuem Fenster öffnen... | Öffnet ein eigenes Fenster für Ansicht und Bearbeitung der Funktionen. (Default am unteren Rand des Editors.)
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Übersicht Funktionen in zenon

Funktionen Detailansicht Symbolleiste und Kontextmenü

Projektieren im Editor

Systemfunktionen

Ausführungsreihenfolge während der Runtime


Übersicht Funktionen in zenon

Handbuch -> Funktionen -> Übersicht Funktionen in zenon

Funktionen sind in folgende Gruppen geordnet:

  • AML und CEL
  • Anwendung
  • Archivserver
  • Benutzerverwaltung
  • Bilder
  • Fehlerortung in elektrischen Netzen
  • Message Control
  • Netzwerk
  • Report Generator
  • Rezepte
  • Skript
  • Variable
  • VBA
  • VSTA
  • Windows

Noch in diesem Kapitel

AML und CEL

Anwendung

Archivserver

Benutzerverwaltung

Bilder

Fehlerortung in elektrischen Netzen

Message Control

Netzwerk

Report Generator

Rezepte

Skript

Variable

VBA

VSTA

Windows


AML und CEL

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> AML und CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit der Alarmmeldeliste (AML ) und der Chronologischen Ereignisliste (CEL).

Funktion | Beschreibung
Alarme blinkquittieren | Diese Funktion quittiert das Blinken aller Elemente des aktuell geöffneten Bildes einer ausgewählten Schablone.
Alarme löschen | Diese Funktion löscht gefilterte Alarme.
Alarme quittieren | Diese Funktion quittiert gefilterte Alarme.
Alarm/Ereignis-Gruppe abmelden/anmelden | Diese Funktion schaltet die Verbindung zur SPS für eine ausgewählte Alarm/Ereignis-Gruppe aus oder ein.
Alarmmeldeliste aktiv | Diese Funktion schaltet die gesamte Alarmmeldeliste ein.
Alarmmeldeliste aktiv/inaktiv | Diese Funktion schaltet die gesamte Alarmmeldeliste ein oder aus.
Alarmmeldeliste inaktiv | Diese Funktion schaltet die gesamte Alarmmeldeliste aus.
Alarmmeldeliste, Alarm/Ereignis-Gruppen, Alarm/Ereignis-Klassen, aktivieren/deaktiviere | Diese Funktion schaltet eine Alarm/Ereignis-Gruppe, eine Alarm/Ereignis-Klasse oder die gesamte Alarmmeldeliste ein oder aus.
AML exportieren | Diese Funktion exportiert gefilterte Einträge der Alarmmeldeliste in ein externes Format.
AML- und CEL-Ringpuffer speichern | Diese Funktion speichert aktuelle Alarme und Ereignisse in die Dateien ALARM.BIN und CEL.BIN sowie Werte von Mathematik-Variablen (Zähler) in die Datei SY_MA32.BIN.
CEL exportieren | Diese Funktion exportiert gefilterte Einträge der Chronologischen Ereignisliste (CEL) in ein externes Format.
Drucken AML oder CEL | Diese Funktion druckt gefilterte Einträge der Alarmmeldeliste (AML) oder der Chronologischen Ereignisliste (CEL) aus.
IPA Dokument erzeugen | Diese Funktion erzeugt eine IPA-Auswertung und schreibt sie in eine HTML-Datei oder druckt diese aus.
Online Ausdrucke ein/ausschalten | Diese Funktion schaltet den Online-Ausdruck der Alarmmeldeliste oder der Chronologischen Ereignisliste (CEL) ein oder aus.
Online-Drucken neue Seite beginnen | Diese Funktion beendet bei aktiviertem Online-Druck eine Seite und beginnt eine neue. Die Seitennummer wird auf 1 zurück gesetzt
Online Drucker umschalten | Diese Funktion schaltet den Online-Ausdruck auf einen ausgewählten Drucker um. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.


Anwendung

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Anwendung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit Projekt-Einstellungen.

Funktion | Beschreibung
Drucker wählen | Diese Funktion öffnet einen Dialog, in dem der Benutzer Drucker für die verschiedenen Druckaufgaben auswählen kann.
EMS starten | Mithilfe dieser Funktion wird die Optimierung für ein selektiertes Versorgungsgebiet im EMS-Modul gestartet. Diese Funktion wird nur am Server ausgeführt.
EMS stoppen | Mithilfe dieser Funktion wird die Optimierung für ein selektiertes Versorgungsgebiet im EMS-Modul gestoppt. Diese Funktion wird nur am Server ausgeführt.
Erweiterter Trend Diagramm drucken | Mithilfe dieser Funktion können Sie Diagramme des Erweiterten Trends ausdrucken oder in einer Datei (JPG oder BMP) speichern, ohne dass Sie das Bild vom Typ Erweiterter Trend aufschalten müssen.
Farbpalette umschalten | Erstellt eine Funktion, um zur Runtime zwischen Farbpaletten umzuschalten.
Funktionen bei Grenzwerten aktiv | Diese Funktion schaltet die Funktionsverwaltung ein. Automatisch ausgeführte Funktionen (z.B. durch Zeitsteuerung, Grenzwertverletzung, etc.) werden ausgeführt.
Funktionen bei Grenzwerten aktiv/inaktiv | Diese Funktion schaltet die Funktionsverwaltung ein oder aus. Automatisch ausgeführte Funktionen (z.B. durch Zeitsteuerung, Grenzwertverletzung, etc.) werden (nicht) ausgeführt.
Funktionen bei Grenzwerten inaktiv | Diese Funktion schaltet die Funktionsverwaltung aus. Automatisch ausgeführte Funktionen (z.B. durch Zeitsteuerung, Grenzwertverletzung, etc.) werden nicht ausgeführt.
Hilfe aufrufen | Diese Funktion öffnet eine ausgewählte Hilfeseite aus einer CHM-Datei.
Nachladen | Diese Funktion lädt nur geänderte oder alle Runtime-Dateien nach.
Offene Wartungen ermitteln | Diese Funktion bildet aktuell anstehende Wartungen aus dem IMM gefiltert auf Statusvariablen ab.
PFS - benutzerdefiniertes Ereignis anstoßen | Diese Funktion führt ein zuvor vom Benutzer angelegtes PFS-Ereignis aus.
Rechtsklick simulieren | Diese Funktion interpretiert den nächsten Mausklick als einen Rechtsklick.
Remanentdaten speichern | Erlaubt das Speichern der Daten für die konfigurierten Module. Zur Auswahl stehen: AML-Ringpuffer, CEL-Ringpuffer, System Treiber und Mathematik Treiber, Intern Treiber, Remanentabbilder aller Treiber, Sperrung der Befehlsgabe.
Runtime beenden | Diese Funktion beendet die zenon Runtime.
S7-Graph Heuristik | Diese Funktion ermöglicht es Ihnen, die S7-Graph Heuristik durchzuführen, ohne dass das Bild vom Typ S7-Graph aktiv ist.
SAP Funktion ausführen | Ermöglicht den Aufruf einer SAP Funktion zur Runtime.
Sprachumschaltung | Diese Funktion schaltet in mehrsprachigen Projekten auf eine ausgewählte Sprache um.
Topologie - Kurzschlusssuche | Aufruf der Kurzschlusssuche.
Topologie - LoadShedding | Ermittelt den Versorgungszustand von topologischen Verbrauchern bildet diesen auf Variablen ab.


Archivserver

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Archivserver

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für das optionale Modul Archivserver.

Funktion | Beschreibung
Archiv beenden | Diese Funktion beendet ein ausgewähltes Archiv des optionalen Moduls Archivserver.
Archiv indizieren | Diese Funktion indiziert Archive.
Archiv starten | Diese Funktion startet ein ausgewähltes Archiv des optionalen Moduls Archivserver.
Archive exportieren | Diese Funktion exportiert gefilterte Archiveinträge des optionalen Moduls Archivserver in ein externes Format.
Offene Archive anzeigen | Diese Funktion zeigt eine Liste der laufenden Archive des optionalen Moduls Archivserver an.


Benutzerverwaltung

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Benutzerverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für die Benutzerverwaltung.

Funktion | Beschreibung
Benutzer ändern | Diese Funktion öffnet einen Dialog, in dem ein eingeloggter Administrator Benutzer anlegen, editieren oder löschen kann.
Login mit Dialog | Diese Funktion öffnet den Standard-Login-Dialog.
Login ohne Passwort | Diese Funktion loggt einen ausgewählten Benutzer ein ohne nach seinem Passwort zu fragen.
Logout | Diese Funktion loggt den aktuell eingeloggten Benutzer aus.
Passwort ändern | Diese Funktion öffnet einen Dialog, wo der aktuell eingeloggte Benutzer sein Passwort ändern kann.


Bilder

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Bilder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

Funktion

Beschreibung

ALC-Quellenfarben

Funktion zur Konfiguration der ALC-Quellenfarben bei Fehlerortung in elektrischen Netzen.

Bild indiziert

Diese Funktion öffnet ein Bild, dessen Name eine ausgewählte Variable beinhaltet.

Bild schließen

Diese Funktion schließt ein ausgewähltes Bild.

Bild zurück

Diese Funktion schaltet auf das vorher geöffnete Bild der ausgewählten Schablone zurück.

Bildmittelpunkt verschieben

Diese Funktion scrollt und/oder zoomt in einem Weltbild.

Bildumschaltung

Diese Funktion öffnet ein ausgewähltes Bild. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Hinweis: Ohne Dialog wird die Funktion mit höchster Priorität (1) ausgeführt. Wird vor der Ausführung ein Dialog ausgeschaltet, wird die Priorität auf hoch (2) heruntergestuft.

Eingabe auf Element mit Fokus aktivieren

Diese Funktion löst die Funktionalität des Elements aus, das gerade den Eingabefokus hat.

Fokus auf Schablone setzen

Diese Funktion setzt den Eingabefokus auf das aktuell geöffnete Bild einer ausgewählte Schablone. So können Projekte mit reiner Tastaturbedienung erstellt werden.

Fokus verschieben

Diese Funktion setzt den Eingabefokus auf ein bestimmtes Element in einem Bild, dessen Schablone den Fokus hat.

Fokus von Schablone nehmen

Diese Funktion entfernt den Eingabefokus von dem aktuell geöffneten Bild einer ausgewählte Schablone. So können Projekte mit reiner Tastaturbedienung erstellt werden.

Menü anzeigen

Diese Funktion öffnet oder schließt ein ausgewähltes Hauptmenü. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Monitor zuordnen

Diese Funktion weist einem ausgewählten virtuellen Monitor einen ausgewählten realen Monitor zu. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Runtimeprofile

Erstellt eine Funktion, mit der zur Runtime die Profilverwaltung geöffnet, ein Profil erstellt oder ein Profil geladen werden kann.

Schablone schließen

Diese Funktion schließt das aktuell geöffnete Bild einer ausgewählten Schablone.

Sollwertvorgabe für Keyboard-Bild

Diese Funktion stellte einen vordefinierten Wert ein oder setzt einen vordefinierten Wert im Bild vom Typ Keyboard ab.

Übersichtsfenster anzeigen

Diese Funktion öffnet ein Übersichtsfenster. Damit kann auf einem einem Ein-Monitor-System ein Mehr-Monitor-System simuliert werden.


Fehlerortung in elektrischen Netzen

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Fehlerortung in elektrischen Netzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Enthält Funktionen zur Fehlerortung in elektrischen Netzen.

Funktion | Beschreibung
Erdschlussmeldung quittieren | Funktion zum Quittieren einer Erdschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.
Erdschlusssuche beenden | Funktion zum Beenden der Erdschlusssuche.
Erdschlusssuche starten | Funktion zum Starten der Erdschlusssuche.
Kurzschlussmeldung quittieren | Funktion zum Quittieren einer Kurzschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.


Message Control

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für das optionale Modul Message Control.

Funktion | Beschreibung
Aktuelle Queue speichern | Speichert zur Runtime aktuelle Message Queue.
Gruppen/Klassen/Bereiche/Anlagen unterdrücken | Ermöglicht das Versaenden von Nachrichten für bestimme Alarme zu unterdrücken.
Sende Nachricht | Erestrellt eine Funktion zum Versenden von Nachrichten.
Sende Nachricht aktivieren | Aktiviert Message Control zur Runtime für das aktive Projekt.
Sende Nachricht deaktivieren | Deaktiviert Message Control zur Runtime für das aktive Projekt.


Netzwerk

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit einem Netzwerk.

Funktion | Beschreibung
Bedienberechtigung im Netz | Diese Funktion holt oder gibt die Bedienberechtigung im Netzwerk frei.
Redundanz-Umschaltung | Diese Funktion tauscht den Server und den Standby-Server des Projekts aus.


Report Generator

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Report Generator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für das optionale Modul Report Generator.

Funktion | Beschreibung
Drucken Report | Diese Funktion druckt einen ausgewählten Report des optionalen Moduls Report Generator.
Report ausführen | Diese Funktion führt einen ausgewählten Report des optionalen Moduls Report Generator aus.
Report exportieren | Diese Funktion exportiert einen ausgewählten Report des optionalen Moduls Report Generator in ein externes Format.


Rezepte

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Rezepte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit Standard-Rezepten und Rezepten des optionalen Moduls Rezeptgruppen Manager.

Funktion | Beschreibung
Rezeptgruppen-Manager | Diese Funktion schreibt, liest, kopiert, importiert oder exportiert ein ausgewähltes Rezept des optionalen Moduls Rezeptgruppen Manager (RGM). Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.
Standard-Rezept | Diese Funktion schreibt, liest, kopiert, importiert oder exportiert ein ausgewähltes Standard-Rezept. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.
Standard-Rezept einzeln direkt | Diese Funktion sendet die Werte eines ausgewählten Standard-Rezepts an die Steuerung.
Standard-Rezept einzeln mit Auswahl | Diese Funktion öffnet einen Dialog, indem der Benutzer ein Standard-Rezept ändern oder ausführen kann.
Standard-Rezept einzeln mit Online-Auswahl | Diese Funktion öffnet einen Dialog, indem der Benutzer ein Standard-Rezept auswählen und ausführen und/oder ändern kann.


Skript

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Skript

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit Skripten.

Funktion | Beschreibung
Skript ausführen | Diese Funktion führt ein ausgewähltes Skript aus.
Skript mit Online-Auswahl | Diese Funktion öffnet einen Dialog, in dem der Benutzer ein Skript auswählen und ausführen kann.


Variable

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit Variablen.

Funktion | Beschreibung
Daten exportieren | Diese Funktion exportiert auf der Festplatte gespeicherte Werte (*.HDD) ausgewählter Variablen in ein externes Format.
dBase Datei lesen | Diese Funktion liest eine ausgewählte dBase-Datei und führt sie als ein Rezept aus.
Drucken Momentanwerte | Diese Funktion druckt aktuelle Werte ausgewählter Variablen aus.
Einheitenumschaltung | Schaltet zwischen Basiseinheit und Umrechnungseinheit um.
HD-Verwaltung inaktiv | Diese Funktion schaltet die Harddisk-Datenspeicherung aus. HDD-Dateien werden nicht geschrieben.
HD-Verwaltung aktiv | Diese Funktion schaltet die Harddisk-Datenspeicherung ein. HDD-Dateien werden geschrieben.
HD-Verwaltung inaktiv/aktiv | Diese Funktion schaltet die Harddisk-Datenspeicherung ein oder aus. HDD-Dateien werden (nicht) geschrieben.
Sollwert absetzen | Diese Funktion sendet für eine ausgewählte Variable einen neuen Wert zur Steuerung.
Treiber Kommandos | Diese Funktion sendet ein ausgewähltes Kommando zu einem ausgewählten Treiber. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.
Treiber Simulationsabbild an Standby übertragen | Wird nur am Standby-Server ausgeführt. Fordert bei Ausführung vom Server ein Abbild für die ausgewählten Treiber. Der Treiber hat dafür 5 Sekunden Zeit.
Uhrzeit auf Variable schreiben | Diese Funktion liest die Systemzeit des Betriebssystems und schreibt sie auf eine String-Variable in der Steuerung. So kann die Systemzeit der Steuerung mit der des Betriebssystems synchronisiert werden.
Uhrzeit von Variable lesen | Diese Funktion liest die Zeit aus einer String-Variable der Steuerung und setzt die Systemzeit des Betriebssystems entsprechend. So kann die Systemzeit der Steuerung mit der des Betriebssystems synchronisiert werden.


VBA

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> VBA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit VBA-Makros.

Funktion | Beschreibung
PCE-Editor öffnen | Diese Funktion öffnet den Editor des optionalen Moduls Process Control Engine (PCE).
VBA-Editor öffnen | Diese Funktion öffnet den VBA-Editor.
VBA-Makro ausführen | Diese Funktion führt ein ausgewähltes VBA-Makro aus. Achtung: Der VBA Event project inactive wird vor AUTO_END_xxx Skripte ausgeführt. Daher wird in Skripten die zenon Funktion VBA-Makro ausführen dann nicht mehr ausgeführt, da VBA zu diesem Zeitpunkt nicht mehr läuft. VBA-Makros, die in "AUTOEND" ausgeführt werden sollen, müssen über Project.Inactive aufgerufen werden.
VBA-Makro Dialog anzeigen | Diese Funktion öffnet der VBA Makro Dialog.


VSTA

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> VSTA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit VSTA.

Funktion | Beschreibung
VSTA-Editor öffnen | Diese Funktion öffnet den VSTA-Editor.
VSTA-Makro ausführen | Diese Funktion führt ein ausgewähltes VSTA-Makro aus.
VSTA Makro-Dialog anzeigen | Diese Funktion öffnet den VSTA Makro-Dialog.


Windows

Handbuch -> Funktionen -> Übersicht Funktionen in zenon -> Windows

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Gruppe beinhaltet Funktionen für den Umgang mit Betriebssystem-Funktionalität.

Funktion | Beschreibung
Audiodatei ausführen | Diese Funktion spielt eine ausgewählte Audiodatei (*.wav) einmalig ab.
Dateioperation | Diese Funktion kopiert, löscht oder verschiebt ausgewählte Dateien. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.
Dauerton Start | Diese Funktion spielt eine Audiodatei (*.wav) wiederholt ab.
Dauerton Stopp | Diese Funktion stoppt das wiederholte Abspielen einer Audiodatei (*.wav).
In den Hintergrund | Diese Funktion schaltet die zenon Runtime in den Hintergrund.
In den Vordergrund | Diese Funktion schaltet die zenon Runtime in den Vordergrund.
Screenshot drucken | Diese Funktion druckt entweder den aktuellen Bildschirm oder das aktuell geöffnete Bild einer ausgewählten Schablone aus. Der Ausdruck kann wahlweise auf ein Fax umgeleitet werden.
Starte Programm | Diese Funktion startet ein externes Programm. Übergabeparameter können definiert werden. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.


Funktionen Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Funktionen -> Funktionen Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Funktion neu | Öffnet den Dialog zur Erstellung einer neuen Funktion.
Parameter | Öffnet den Dialog zur Eingabe der Parameter.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien.
Funktionsverwendung... | Erstellt Projektanalyse der ausgewählten Funktion im aktuellen Projekt und zeigt diese als Ergebnisliste in einem eigenen Fenster an.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Hilfe | Öffnet die Online-Hilfe.


Projektieren im Editor

Handbuch -> Funktionen -> Projektieren im Editor

Noch in diesem Kapitel

Neue Funktion anlegen und bearbeiten

Auswahl einer Funktion

Löschen von Funktionen

Einfügen von Funktionen aus anderen Projekten


Neue Funktion anlegen und bearbeiten

Handbuch -> Funktionen -> Projektieren im Editor -> Neue Funktion anlegen und bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Neue Funktion anlegen:

Im Kontextmenü des Knotens 'Funktionen' im Projektmanager, stehen folgende Befehle zur Verfügung:

Parameter | Beschreibung
Funktion neu ... | Eine neue Funktion wird angelegt und kann über die Eigenschaften im Eigenschaften Fenster parametriert werden.
Skript neu | Ein neues Skript (Funktionsbündel) wird angelegt.
XML exportieren alle ... | Alle Funktionen in eine XML-Datei exportieren. Siehe Kapitel Import/Export.
XML importieren ... | Funktionen aus einer XML-Datei importieren. Siehe Kapitel Import/Export.
In neuem Fenster öffnen... | Öffnet die Detailansicht der Funktionen in einem neuen Fenster.
Profil | Siehe Kapitel Profile.


Auswahl einer Funktion

Handbuch -> Funktionen -> Projektieren im Editor -> Auswahl einer Funktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine neue Funktion anzulegen, wird er Eintrag 'Funktion neu' ausgewählt. Der Funktions-Auswahl-Dialog öffnet sich. Ist eine Funktion selektiert, finden Sie unterhalb des Dialoges die Dialoghilfe. Dort wird die selektierte Funktion kurz erläutert. Genauere Informationen finden Sie im Kapitel Übersicht Funktionen.

Wenn Sie eine Funktion ausgewählt und mit OK bestätigt haben, ist diese angelegt. Die Parameter dieser neue Funktion können nun im Eigenschaften-Fenster definiert werden.

Wenn Sie nach Ihrer Auswahl den 'Hilfe'-Button im Dialog betätigen, werden Sie direkt in die Onlinehilfe der entsprechenden Funktion weitergeleitet.

Wie im Eigenschaften-Fenster steht auch hier eine individuell anpassbare Favoritenansicht zur Verfügung. Der Knoten „Favoriten“ steht immer zu Beginn der Liste. Per Default sind dort die Funktionen „Bildumschaltung“ und „Sollwert setzen“ eingetragen. Eine beliebige Funktion kann mittels Kontextmenu oder per Drag&Drop zu den Favoriten hinzugefügt bzw. von dort entfernt werden.

Unterhalb des Dialoges wird die Dialoghilfe angezeigt, in der die selektierte Funktion kurz beschrieben wird. Eine Übersicht über die einzelnen Funktionen, die ausgwählt werden können finden Sie auch im Abschnitt Übersicht Funktionen.


Löschen von Funktionen

Handbuch -> Funktionen -> Projektieren im Editor -> Löschen von Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Funktion zu löschen, muss diese in der Detailansicht ausgewählt werden und die Entfernen Taste gedrückt werden.


Einfügen von Funktionen aus anderen Projekten

Handbuch -> Funktionen -> Projektieren im Editor -> Einfügen von Funktionen aus anderen Projekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Funktionen können aus anderen Projekten desselben Arbeitsbereichs eingefügt werden.

Dies ist bei Bildern (Bild Start-Ende-Funktion, Buttons), Grenzwerten, Zeitsteuerung, Scheduler, Skripte, Menüs, Projekten (automatische Funktionsausführung, Archiv) möglich.


Systemfunktionen

Handbuch -> Funktionen -> Systemfunktionen

Noch in diesem Kapitel

Anwendung - Funktionen

Windows - Funktionen


Anwendung - Funktionen

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Allgemeine zenon Funktionen

Noch in diesem Kapitel

Drucker wählen

Funktionen bei Grenzwerten aktiv

Funktionen bei Grenzwerten inaktiv

Funktion bei Grenzwerten aktiv/inaktiv

Nachladen

Programm verlassen

Rechtsklick simulieren

Remanentdaten speichern


Drucker wählen

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Drucker wählen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Drucker für die verschiedenen Listen werden grundsätzlich in der Allgemeinen Konfiguration festgelegt.

Mit der Verwendung dieser Funktion kann im Onlinebetrieb die Druckerauswahl geändert werden. Diese Funktion benötigt keine Parameter.

Die Einstellungen der Drucker erfolgen wie im Kapitel Konfiguration/Standard/Drucker beschrieben.


Funktionen bei Grenzwerten aktiv

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Funktionen bei Grenzwerten aktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion wird die Verwaltung von Grenzwertfunktionen zur Runtime aktiv geschaltet.


Funktionen bei Grenzwerten inaktiv

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Funktionen bei Grenzwerten inaktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion wird die Verwaltung von Grenzwertfunktionen zur Runtime inaktiv geschaltet.


Funktion bei Grenzwerten aktiv/inaktiv

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Funktion bei Grenzwerten aktiv/inaktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion werden Grenzwertfunktionen zur Runtime zwischen den beiden Zuständen 0 und 1 umgeschaltet. Der in der Datei zenon6.ini gespeicherte Zustand wird beim Starten der Runtime eingelesen:

[FUNKTIONEN]

EIN=0 -> inaktiv

EIN=1 -> aktiv


Nachladen

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Nachladen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion lädt geänderte Runtime-Dateien, ohne dass die Runtime dafür beendet werden muss.

info Info

Werden Namen von Server oder Standby-Server im Editor geändert, können diese nicht nachgeladen werden. Sie werden erst mit einem Neustart der Runtime aktualisiert.


Programm verlassen

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Programm verlassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird die Runtime definiert heruntergefahren (Protokollierung in CEL, Schließen der Archive, Ausführung des Scriptes AUTOEND etc.).

Es sind keine Übergabeparameter notwendig.

attention Achtung
  • Der VBA Event project inactive wird vor AUTO_END_xxx Skripte ausgeführt. Daher wird in Skripten die zenon Funktion VBA-Makro ausführen dann nicht mehr ausgeführt, da VBA zu diesem Zeitpunkt nicht mehr läuft. VBA-Makros, die in "AUTO_END" ausgeführt werden sollen, müssen über Project.Inactive aufgerufen werden.
  • Zyklische Archive dürfen nicht im Skript AUTOEND angegeben werden.


Rechtsklick simulieren

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Rechtsklick simulieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Ausführen dieser Funktion in der Runtime wird der nächste Mausklick bzw. Antippen eines Touchscreens als Klick mit der rechten Maustaste interpretiert.

Dieser Funktion dient dazu auch auf Touchscreens etwa Kontextmenüs zugänglich zu machen.

Es sind keine Übergabeparameter notwendig.


Remanentdaten speichern

Handbuch -> Funktionen -> Systemfunktionen -> Anwendung - Funktionen -> Remanentdaten speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Remanentdaten speichern ermöglicht es, zur Runtime jederzeit Remanentdaten zu speichern. Die Funktion kann importiert und exportiert werden. Um die Funktion zu konfigurieren:

Interne ID: Remanentdaten speichern

Remanentdaten speichern

Erlaubt das Speichern der Daten für die konfigurierten Module. Zur Auswahl stehen: AML-Ringpuffer, CEL-Ringpuffer, System Treiber und Mathematik Treiber, Intern Treiber, Remanentabbilder aller Treiber und Sperrung der Befehlsgabe.

Mehr im Online-Handbuch.

  1. wählen Sie Funktion neu
  2. navigieren Sie zum Knoten Anwendung
  3. wählen Sie Remanentdaten speichern
  4. der Dialog zur Auswahl der Module öffnet sich

Modul | Beschreibung
AML-Ringpuffer | Aktiv: AML-Ringpuffer wird gespeichert.
CEL-Ringpuffer | Aktiv: CEL-Ringpuffer wird gespeichert.
System Treiber und Mathematik Treiber | Aktiv: Daten des System Treibers und des Mathematik Treibers werden gespeichert.
Intern Treiber | Aktiv: Daten des Intern Treibers werden gespeichert.
Remanentabbilder aller Treiber | Aktiv: Daten aller Treiber werden gespeichert.
Sperrung der Befehlsgabe | Aktiv: Daten der Sperrung der Befehlsgabe werden gespeichert.

Falls beim Speichern Fehler auftreten, werden diese im Fehlerprotokoll gespeichert.

info Info

Wenn die Runtime im Simulationsmodus läuft (Projektsimulation aktiv), speichert die Funktion Remanentdaten speichern keine Werte von folgenden Treibern:

  • Intern Treiber
  • Mathematik Treiber
  • System Treiber


Windows - Funktionen

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Funktionen die im Betriebssystem etwas auslösen.

Noch in diesem Kapitel

Audiodatei ausführen

Dateioperationen

Dauerton Start

Dauerton Ende

Screenshot drucken

In den Hintergrund

In den Vordergrund

Starte Programm


Audiodatei ausführen

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> Audiodatei ausführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird während der Runtime die angegebene Audiodatei (*.wav) mit jedem Funktionsaufruf einmal abgespielt. Als Übergabeparameter ist die Audiodatei anzugeben.


Dateioperationen

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> Dateioperationen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann während der Runtime eine definierte Dateioperation (kopieren, verschieben und löschen) erfolgen.

Als Übergabeparameter sind die Dateioperation und die Dateiparameter anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Projektierbare Dateioperationen:

Parameter | Beschreibung
kopieren | Dateien von einem Namen und Pfad auf einen neuen Namen und Zielpfad kopieren. Übergabeparameter werden beachtet.
verschieben | Dateien von einem Namen und Pfad auf einen neuen Namen und Zielpfad verschieben und danach im Quellpfad löschen. Übergabeparameter werden beachtet.
löschen | Dateien löschen. Übergabeparameter werden beachtet.

Wird die angegebene Quelle nicht gefunden (Datei oder Pfad ist nicht vorhanden bzw. fehlerhaft), wird die Funktion nicht ausgeführt. Standardmäßig wird keine Fehlermeldung angezeigt. Sie können optional über die Optionen eine Fehlermeldung erzwingen; dies wird aber nicht empfohlen, da damit die Runtime oder weitere Funktionsabarbeitungen eventuell blockiert werden.

Nach der Festlegung der Dateioperation sind weitere Optionen projektierbar.

Parameter

Beschreibung

Quelle/Ziel

Geben Sie den Pfad zu Quelle und Ziel an. Sie können dabei für Quelle und Ziel auch Wildcards (*) verwenden. (Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.)
Sie haben drei Möglichkeiten, den Pfad zu definieren:

  • absolut (Sie können zur Eingabe auch den Button '...' hinter dem Textfeld benutzen.
  • relativ zum Runtimeordner (Link: mehr zum Runtimeordner)
  • relativ zum Datenordner. (Link: mehr zum Datenordner).

Zum Beispiel:

absolut:
Quelle 'C:\temp\datenbank.mdb' nach Ziel 'D:\backup\' -> Die Datei 'datenbank.mdb' wird in den Ordner 'D:\backup\' kopiert. Damit das Kopieren funktioniert, muss der Zielordner bereits existieren und er muss unbedingt mit einem Backslash abgeschlossen werden.

relativ:
Relativ zum Datenordner: '*.aml' nach Ziel 'D:\backup\' kopiert alle Dateien der Alarmmeldeliste in den Ordner 'D:\backup\'.

Dateien umbenennen :
Das Umbenennen einzelner Dateien ist möglich. Z. B. kopiert 'C:\temp\datenbank.mdb' nach Ziel 'D:\backup\backupdb.mdb' die Datei 'datenbank.mdb' in den Ordner 'D:\backup\' und benennt sie dabei in 'backupdb.mdb' um.

Das Umbenennen mehrerer Dateien gleichzeitig über Wildcards ist nicht möglich.

Unterordner berücksichtigen

Sucht Dateien auch in Unterordnern des Quellpfades und erstellt dessen Baumstruktur auch im Zielverzeichnis.

Existierende Dateien überschreiben

Existiert die Quelldatei bereits im Zielverzeichnis, wird sie mit der aktuellen Datei überschrieben.

Fehlermeldungen anzeigen

Ist kopieren oder verschieben nicht möglich, wird eine Fehlermeldung als Systemmeldung ausgegeben. Aktivierung dieser Option wird nicht empfohlen, da damit die Runtime oder weitere Funktionsabarbeitungen eventuell blockiert werden.

Dialog zur RT anzeigen

Im Onlinebetrieb wird vor der Ausführung der Funktion eine Dialogmaske aufgeschaltet, in der die Parameter angepasst werden können (Dateioperation, Quelle, Ziel etc.). Die geänderten Einstellungen bleiben während der Laufzeit des Onlinebetriebes erhalten. In dieser Dialogmaske fehlt die Option mit Dialogbox vor der Ausführung .

Nur ausführen, wenn Datei(en)

Dateioperation wird nur bei definiertem Zeitkriterium ausgeführt (Tage, Stunden).

älter als

Die Datei muss älter sein als der angegebene Zeitraum. Dabei bedeutet '1 Tag' immer 24 Stunden ab Ausführungszeitpunkt.

jünger als

Die Datei muss jünger sein als der angegebene Zeitraum. Dabei bedeutet '1 Tag' immer 24 Stunden ab Ausführungszeitpunkt.
Hinweis: 'nicht älter als' muss größer sein als 'nicht jünger als'.


Dauerton Start

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> Dauerton Start

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird während der Runtime die angegebene Audiodatei (*.wav) mit einem Funktionsaufruf immer wieder abgespielt bis die Funktion Dauerton Stopp ausgeführt wird. Als Übergabeparameter ist die Audiodatei anzugeben.


Dauerton Ende

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> Dauerton Ende

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion beendet das wiederholte Abspielen einer Audiodatei (*.wav) , das mit der Funktion Dauerton Start angestoßen wurde.


Screenshot drucken

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> Screenshot drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann zur Runtime ein Screenshot vom gesamten Monitor oder von Schablonen ausgedruckt werden (Prozessbilder, Listen, Trendkurven, etc.). Schablonen werden mittels Doppelklick ausgewählt.

Als Übergabeparameter sind die Schablone und Zusatzoptionen anzugeben. Die Projektierung der Funktion erfolgt über folgenden Dialog.

Eigenschaft

Beschreibung

Ausgewählter Druckbereich

Anzeige des gewählten Bereichs.

Druckbereich definieren

Auswahl des zu druckenden Bereichs.

Gesamter Bildschirmbereich

Druckt Screenshot des gesamten Bildschirms. Bei Mehr-Monitor-Systemen wird der Inhalt des Standardmonitors gedruckt.

Schablonenliste

Nur verfügbar, wenn die Eigenschaft Gesamter Bildschirmbereich inaktiv ist.

Wählen Sie die gewünschte Schablone per Doppelklick. Diese wird im Feld Ausgewählter Druckbereich angezeigt.

Hinweis: Wenn die gewählte Schablone zur Runtime nicht aktiv ist, wird nichts gedruckt.

Monitor

Nur verfügbar, wenn eine Schablone gewählt wurde und die Eigenschaft Gesamter Bildschirmbereich inaktiv ist.

Wählen Sie den gewünschten Monitor aus der Dropdownliste:

  • alle
  • aktueller Monitor
  • bestimmter virtueller Monitor

Hinweis: Wenn Sie eine Schablone ausgewählt haben, die über mehrere Monitore geht, müssen Sie aktueller Monitor auswählen, damit die gesamte Schablone gedruckt wird.

Druckoptionen

Mit Heftrand

Beim Druck wird ein Randbereich zum Heften berücksichtigt.

Invertiert

Kehrt Hell-/Dunkel-Bereiche um.

Fax

Der Druck wird auf ein Fax umgeleitet. Dafür muss in den Druckereinstellungen als Drucker für Screenshots ein Faxgerät gewählt werden.


In den Hintergrund

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> In den Hintergrund

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird während der Runtime die Darstellung von zenon in den Hintergrund geschaltet. Der Eintrag SYSKEY in der Datei project.ini wird nicht berücksichtigt. Die Anwahl anderer Applikationen (Programmanager) ist möglich.

[DEFAULT] |
... |
SYSKEY= | 0 - Systemtasten aktiv
 | 1 - Systemtasten gesperrt (default)

Es sind keine Übergabeparameter notwendig.


In den Vordergrund

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> In den Vordergrund

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird während der Runtime die Darstellung von zenon in den Vordergrund geschaltet. Alle anderen Applikationen werden in den Hintergrund geschaltet (Ausnahme: Applikationen mit der Eigenschaft immer im Vordergrund). Der Eintrag SYSKEY in der Datei project.ini wird berücksichtigt.

Eintrag | Bedeutung
[DEFAULT] |
SYSKEY= | 0 - Systemtasten aktiv
 | 1 - Systemtasten gesperrt (Default)

Es sind keine Übergabeparameter notwendig.

info Info

Beim in der Vordergrund Schalten der Runtime wird das Runtime-Fenster als oberstes Fenster definiert. Damit wird die Alarmstatuszeile überdeckt. Um die Alarmstatuszeile wieder in den Vordergrund zu holen, können Sie:

  • Systemtasten aktivieren (Projekteigenschaft Systemtasten sperren deaktivieren) und mit Alt+Tab die Alarmstatuszeile wieder in den Vordergrund holen

    Interne ID: In den Vordergrund

    Systemtasten sperren

    Aktiv: Systemtasten wie Alt+Esc, Strg+Esc, Alt+Tab, Alt-F4 etc. werden in der Runtime gesperrt.
    Inaktiv: Systemtasten werden nicht gesperrt.
    Default: inaktiv

    Mehr im Online-Handbuch

    Hinweis: Weitere Systemtasten können zur Runtime über Keyblock Runtime Start gesperrt werden.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • die Windows Taskbar aktivieren und auf das Fenster Status klicken
  • die Runtime wieder in den Hintergrund schalten
  • die Runtime neu starten


Starte Programm

Handbuch -> Funktionen -> Systemfunktionen -> Windows - Funktionen -> Starte Programm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann während der Runtime ein anderes Programm (*.EXE) gestartet werden. Beim Funktionsaufruf können Übergabeparameter für das zu startenden Programm mit angegeben werden.

Als Übergabeparameter ist die Programmdatei (*.EXE) anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Projektierbare Eigenschaften sind:

Parameter | Beschreibung
Name | Name der auszuführenden Datei; Suche und Auswahl über Button möglich
Parameter | Übergabeparameter zum Programm
diesen Dialog zur Laufzeit anbieten | Programm und Parameter im Onlinebetrieb beim Funktionsaufruf ändern

Die Auswahl des Programms erfolgt über eine Dialogmaske.

Für den Start des Programmes muss es in einem Suchpfad (Systemumgebung unter Windows NT) vorhanden sein. Benutzerdefinierte Programme (Visual-Basic) sollten im zenon Installationspfad abgelegt werden.

Bei aufgeschalteter Alarmliste und selektiertem Alarm in der Liste kann dem Programmaufruf der Namen der Variablen als Parameter (für externe Datenbankinformationssysteme) übergeben werden. Der Parameter wird als Schlüsselwort übergeben.

Parameter | Beschreibung
@alarm.name | Name der Variablen
@alarm.unit | Einheit der verknüpften Variablen
@alarm.value | Wert, der den Eintrag ausgelöst
@alarm.stext | entsprechender Grenzwerttext
@alarm.ctime | Zeit kommt (Wert in Sekunden seit 1.1.1970)
@alarm.ctimemilli | dazugehörenden Millisekunden
@alarm.gtime | Zeit geht
@alarm.gtimemilli | dazugehörenden Millisekunden
@alarm.qtime | Zeit quittiert
@alarm.user | Benutzer, der quittiert hat
@alarm.identification | Kennung der Variablen

Ist keine Alarmliste aufgeschaltet, mehrere oder kein Alarm in der Liste selektiert, wird kein Übergabeparameter übergeben. Sind mehrere Alarmlisten aufgeschaltet (globale und selektive Liste), wird der selektierte Eintrag der 1. gefundenen Liste verwendet.

Bei aufgeschalteter Chronologischer Ereignisliste und selektiertem Eintrag in der Liste kann dem Programmaufruf der Namen der Variablen als Parameter (für externe Datenbankinformationssysteme) übergeben werden. Der Parameter wird als Schlüsselwort übergeben.

Parameter | Beschreibung
@cel.name | Name der Variablen
@cel.unit | Einheit der verknüpften Variablen (nur wenn Variable verknüpft ist)
@cel.value | Wert, der den Eintrag ausgelöst hat (nur wenn über Grenzwertverletzung ausgelöst)
@cel.stext | entsprechender Grenzwerttext
@cel.ctime | Zeit kommt (Wert in Sekunden seit 1.1.1970)
@cel.ctimemilli | dazugehörenden Millisekunden
@cel.user | Benutzer, der quittiert hat
@cel.identification | Kennung der Variable

Ist keine Chronologische Ereignisliste aufgeschaltet, mehrere oder kein Eintrag in der Liste selektiert, wird kein Übergabeparameter übergeben. Sind mehrere Chronologische Ereignislisten aufgeschaltet (globale und selektive Liste), wird der selektierte Eintrag der 1. gefundenen Liste verwendet.

Weitere mögliche Übergabeparameter sind:

@picture

Bild, aus dem heraus die Funktion aufgerufen wurde

Bei der Verwendung dieser Funktion sind die Rückwirkungen der gestarteten Programme auf das Gesamtsystem zu berücksichtigen (benötigte Ressourcen, Multitasking, Programmsicherheit etc.).


Ausführungsreihenfolge während der Runtime

Handbuch -> Funktionen -> Ausführungsreihenfolge während der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Ausführung von Funktionen in der Runtime geschieht in 3 Prioritätsstufen:

  • Priorität 1: Immediate (wird sofort ausgeführt)
  • Priorität 2: High (vor Ausführung wird ein Dialog aufgeschaltet)
  • Priorität 3: Low

Wird für eine Funktion mit der Priorität 1 vor der Ausführung ein Dialog ausgeschaltet, wird die Priorität auf 2 heruntergestuft.

Innerhalb eine Projektes werden alle Funktionen eines Skripts in die selbe Queue eingereiht. Im Skript werden alle Funktionen in einer Prioritätsebene ausgeführt, was garantiert, dass die Funktionen hintereinander ausgeführt werden.

Example Beispiel

Über ein Skript wird über die Funktion Bildumschaltung Bilder verschiedener Projekte eine Bildanordnung aktiviert, die von der Reihenfolge der Ausführung abhängt (Bilder liegen über anderen Bildern).

Priorität der Ausführung zur Runtime

Funktionsgruppen

Funktionen

Priorität

AML und CEL

Steuerung der Alarm- und CEL-Verwaltung

  • Alarme blinkquittieren

1

  • Alarme löschen

1

  • Alarme quittieren

1

  • Alarm/Ereignis-Gruppe abmelden/anmelden

1

  • Alarmmeldeliste aktiv

1

  • Alarmmeldeliste aktiv/inaktiv

1

  • Alarmmeldeliste inaktiv

1

  • Alarmmeldeliste, Alarm/Ereignis-Gruppen, Alarm/Ereignis-Klassen aktivieren/deaktivieren

1

  • AML- und CEL-Ringpuffer speichern

1

  • Drucken AML oder CEL

3

  • Exportieren Alarme

2

  • Exportieren CEL

2

  • IPA-Dokument erzeugen/drucken

1

  • Online-Drucken ein/ausschalten

1

  • Online-Drucken neue Seite beginnen

?

  • Online-Drucker umschalten

3

Anwendung

Anwendungen aufrufen

  • Drucker wählen

3

  • Erweiterter Trend Diagramm drucken

1

  • Farbpalette umschalten

2

  • Funktionen bei Grenzwerten inaktiv/aktiv

1

  • Funktionen bei Grenzwerten aktiv

1

  • Funktionen bei Grenzwerten inaktiv

1

  • Hilfe aufrufen

3

  • Nachladen

1

  • Offene Wartungen ermitteln

3

  • PFS-Ereignis anstoßen

1

  • Programm verlassen

3

  • Rechtsklick simulieren

3

  • Remanentdaten speichern

1

  • S7-Graph Heurisitk auswerten

1

  • Simulation ein/ausschalten

1

  • Sprachumschaltung

2

Archivserver

Steuerung der Archive

1

  • Archiv beenden

1

  • Archiv indizieren

1

  • Archiv starten

1

  • Archive aktive

2

  • Export Archive

1

Benutzerverwaltung

Benutzerverwaltung

  • Benutzer ändern

3

  • Login mit Dialog

2

  • Login ohne Passwort

2

  • Logout

2

  • Passwort ändern

2

Bilder

Bilder wählen und steuern

  • ALC Quellfarbe ändern

1

  • Bild indiziert

1

  • Bild schließen

2

  • Bild zurück

1

  • Bildmittelpunkt verschieben

1

  • Bildumschaltung

1

  • Eingabe auf Element mit Fokus aktivieren

1

  • Fokus auf Schablone setzen

1

  • Fokus verschieben

1

  • Fokus von Schablone nehmen

1

  • Menü anzeigen

1

  • Monitor zuordnen

1

  • Runtimeprofile

1

  • Schablone schließen

1

  • Übersichtsfenster

1

Fehlerortung in elektrischen Netzen

  • Erdschlussmeldung quittieren

1

  • Erdschlusssuche beenden

1

  • Erdschlusssuche starten

1

  • Kurzschlussmeldung quittieren

1

Message Control

Versenden von Nachrichten (Message Control)

  • Aktuelle Queue speichern

    Interne ID: Ausführungsreihenfolge während der Runtime

    Aktuelle Queue speichern

    Speichert zur Runtime ein Abbild der aktuellen Queue.

    Mehr in der Online-Hilfe.

1

  • Gruppen/Klassen/Bereiche/Anlagen unterdrücken

    Interne ID: Ausführungsreihenfolge während der Runtime

    Gruppen/Klassen/Bereiche/Anlagen unterdrücken

    Deaktiviert oder aktiviert Elemente der Liste, für die keine Nachrichten verschickt werden sollen.

    Mehr in der Online-Hilfe.

1

  • Sende Nachricht

    Interne ID: Ausführungsreihenfolge während der Runtime

    Sende Nachricht

    Diese Funktion sendet eine Nachricht des optionalen Moduls Message Control.

    Mehr im Online-Handbuch

1

  • Sende Nachricht aktivieren

    Interne ID: Ausführungsreihenfolge während der Runtime

    Sende Nachricht aktivieren

    Diese Funktion schaltet das Senden von Nachrichten des optionalen Moduls Message Control ein.

    Mehr in der Online-Hilfe.

1

  • Sende Nachricht deaktivieren

    Interne ID: Ausführungsreihenfolge während der Runtime

    Sende Nachricht deaktivieren

    Diese Funktion schaltet das Senden von Nachrichten des optionalen Moduls Message Control aus.

    Mehr im Online-Handbuch

1

Netzwerk

Netzwerkfunktion

  • Bedienberechtigung im Netz

1

  • Redundanz Umschaltung

1

Report - Generator

Funktionen für Reporte

  • Drucken Report

2

  • Exportieren Report

2

  • Report ausführen

2

Rezepte

Steuerungen der Rezepte

  • Rezeptgruppen-Manager

2

  • Standard-Rezept

2

  • Standard-Rezept einzeln direkt

2

  • Standard-Rezept einzeln mit Auswahl

2

  • Standard-Rezept einzeln mit Online-Auswahl

2

Skript

Funktionsblöcke (Skripte) ausführen

  • Skript ausführen

1

  • Skript mit Online-Auswahl

2

Variable

Funktionen für Variablen

  • Daten- exportieren

3

  • dBase Datei lesen

2

  • Drucken Momentanwerte

2

  • Maßeinheitenumschaltung

2

  • HD-Verwaltung aktiv

1

  • HD-Verwaltung inaktiv

1

  • HD-Verwaltung inaktiv/aktiv

1

  • Sollwert absetzen

1

  • Treiber Kommandos

2

  • Treiber Simulationsabbild an Standby übertragen

1

  • Uhrzeit auf Variable schreiben

1

  • Uhrzeit von Variable lesen

1

VBA

VBA-Funktionen

  • PCE-Editor öffnen

3

  • VBA-Editor öffnen

3

  • VBA-Makro ausführen

3

  • VBA-Makro Dialog anzeigen

3

VSTA

VSTA Funktionen

  • VSTA-Editor öffnen

3

  • VSTA-Makro ausführen

3

  • VSTA-Makro Dialog anzeigen

3

Windows

  • Audiodatei ausführen

2

  • Dateioperation

3

  • Dauerton Start

1

  • Dauerton Stopp

1

  • In den Hintergrund

2

  • In den Vordergrund

2

  • Screenshot drucken

2

  • Starte Programm

2


Import - Export

Handbuch -> Import - Export

Teile eines Projekts (z.B Funktionen, Variablen, Bilder etc) lassen sich in zenon importieren bzw. aus zenon exportieren. So können Elemente in anderen Projekten genutzt, gesichert oder extern bearbeitet werden.

tutorial Lizenzinformation

Import und Export sind für die meisten Formate in der Standardlizenz enthalten.

Ausnahme: SQL-Export muss zusätzlich lizenziert werden.

Noch in diesem Kapitel

Allgemeines

Archive

Bilder

Benutzer

Datentypen

Funktionen

Menüs

Reaktionsmatrizen

Rezepte Standard

Rezeptgruppen

Variablen

Verriegelungen

Zeitsteuerung

Zuweisungen

Fehlermeldungen


Allgemeines

Handbuch -> Import - Export -> Allgemeines

Die exportierten Dateien können extern bearbeitet und in das gleiche oder ein anderes Projekt importiert werden.

attention Achtung

Beim XML Import/Export ist keine Abwärtskompatibilität gegeben. Daten aus älteren zenon Versionen können übernommen werden. Die Übergabe von Daten aus neueren Versionen an ältere wird nicht unterstützt.

Folgende Funktionalitäten eines Projekts stehen für den Import/Export zur Verfügung:

  • Variablendefinition
    • Datentypen
    • Reaktionsmatrizen
    • Zuweisungen
  • Bilder
    • Schablonen
    • Schriften
  • Funktionen
    • Skript-Funktionen
  • Archivserver
  • Rezepte Standard
  • Rezeptgruppen Manager
  • Zeitsteuerung
  • Verriegelungen
  • Menü-Verwaltung
  • Benutzerverwaltung

Dabei lassen sich entweder alle Objekte eines Typs exportieren oder nur einzelne Objekte.

  • Alle Objekte: Auswahl der Verzweigung des Projektmanagers -> Kontextmenü XML Export alle...
  • Einzelne Objekte: Auswahl eines oder mehrerer Objekte in der Detailansicht -> Kontextmenü XML Export selektierte...

Die Objekte werden beim Import/Export nach ihrem Namen identifiziert, nicht nach ihrer internen ID, d.h. wenn Objekte in ein anderes Projekt importiert werden, haben sie dort nicht die gleiche interne ID!

Beim Import zeigt ein Fortschrittsbalken den Status des Imports/Exports an.

attention Achtung

Wenn beim Import im Projekt ein Element gleichen Namens bereits existiert, so wird es durch das Element aus der Import-Datei überschrieben! (Einzige Ausnahmen sind die Datentypen.)

Die Eigenschaften der Objekte werden in der Export-Datei mit ihrer internen Bezeichnung aufgelistet, die auch für den Zugriff mit VBA verwendet wird.

Die einzelnen Eigenschaften werden in der Eigenschaften-Hilfe detailliert beschrieben.

Eigenschaften, die in der XML-Datei nicht vorhanden sind (z.B. gelöscht wurden), werden beim neuen Anlegen eines Elements mit den Default-Werten belegt. Bei bereits im Projekt vorhandenen Elementen werden die in der XML-Datei nicht vorhandenen Eigenschaften nicht verändert.

Example Beispiel

Eine Variable wird das erste Mal ohne Offset importiert. Der Offset wird mit dem Default-Wert 0 initialisiert. Mit dem S7-Import wird der Offset auf 100 geändert. Später wird die Variable ein zweites Mal importiert, wobei in der Import-Datei der Offset immer noch fehlt. Der Offset 100 bleibt erhalten.

attention Achtung

Die zu importierende XML-Datei muss konsistent sein. Beim Import der Datei erfolgt keine Plausibilitätsprüfung. Wenn in den importierten Daten Fehler sind, kann es zu unerwünschten Effekten im Projekt kommen bis hin zu Abstürzen.

Dies muss vor allem auch beachtet werden, wenn in einer XML-Datei nicht alle Eigenschaften vorhanden sind und diese dann durch Default-Werte gesetzt werden! z.B.: Eine binäre Variable hat einen Grenzwert von 300.


Archive

Handbuch -> Import - Export -> Archive

Die Export-Datei für die Archive gliedert sich in:

Archivliste

Beim Import/Export der Archive werden die betroffenen Variablen bzw. Funktionen nicht automatisch mit exportiert/importiert. Es sollte gegebenen Falls darauf geachtet werden, dass vorher ein entsprechender Import/Export durchgeführt wird. Es können alle Archive gleichzeitig oder selektierte Archive exportiert/importiert werden.


Bilder

Handbuch -> Import - Export -> Bilder

Bilder exportieren

Mit den Bildern werden auch die darin enthaltenen Variablen und Funktionen exportiert. Die Export-Datei für die Bilder enthält:

  • Bilder
  • Schablonen
  • Symbole
  • Variablen
  • Funktionen

Um Bilder zu exportieren:

  1. markieren Sie die gewünschten Bilder
  2. wählen Sie im Kontextmenü der Detailansicht den Befehl Selektierte XML exportieren...
    Alternative: wählen Sie im Kontextmenü des Knotens Bilder den Befehl XML exportieren alle...
  3. der Auswahldialog für den Speicherort wird geöffnet
  4. wählen Sie den gewünschten Speicherort
  5. vergeben Sie einen Namen
  6. achten Sie auf den Dateityp XML
  7. bestätigen Sie mit Klick auf die Schaltfläche Speichern

Die ausgewählten Bilder werden in eine XML-Datei exportiert und können jederzeit in dieses oder andere Projekte wieder importiert werden.

Bilder importieren

Um Bilder zu importieren:

  1. wählen Sie im Kontextmenü des Knotens Bilder oder der Detailansicht Bilder den Befehl XML importieren
  2. der Auswahldialog für den Speicherort wird geöffnet
  3. navigieren Sie zum Speicherort der gewünschten XML-Datei
  4. wählen Sie die gewünschte Datei aus
  5. bestätigen Sie den Import mit Klick auf die Schaltfläche Öffnen

Die Bilder werden importiert.

Namenskonflikt beim Import

Beim Importieren eines Bildes wird der in der XML-Datei hinterlegte Name (Attribut ShortName) für die Benennung des neu anzulegenden Bildes verwendet. Existiert bereits ein Bild mit dem selben Namen, wird der Import unterbrochen und eine Fehlermeldung angezeigt:

Parameter | Beschreibung
Ja | Das in der Fehlermeldung genannte Bild wird beim Import durch das Bild aus der XML-Datei ersetzt. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Nein | Das in der Fehlermeldung genannte Bild wird nicht importiert, das bereits vorhandene Bild wird beibehalten. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Ja alle | Das in der Fehlermeldung genannte Bild wird beim Import durch das Bild aus der XML-Datei ersetzt. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Bilder werden ersetzt.
Nein alle | Das in der Fehlermeldung genannte Bild wird nicht importiert, das bereits vorhandene Bild wird beibehalten. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Bilder werden beibehalten.

Hinweis: Es wird nur der ShortName verwendet. Der Dateiname spielt für die Benennung des zu importierenden Bildes keine Rolle, kann also zur Konfliktlösung nicht verwendet werden.

Variablen und Funktionen in Bildern

Dynamische Elemente und Schablonen werden automatisch mit Bildern automatisch importiert. Variablen und Funktionen müssen vorher separat aus dieser Datei importiert werden.

Es werden dabei nur Variablen und Funktionen der ersten Ebene berücksichtigt, d.h. Variablen und Funktionen die direkt im Bild verknüpft sind. Da sich einerseits Funktionen auf Variablen beziehen können (z.B. Sollwert setzen) andererseits aber auch Variablen auf Funktionen (z.B. Grenzwert-Funktionen), kann es nötig sein, zuerst die Variablen, dann die Funktionen und dann noch einmal die Variablen zu importieren. Erst dann werden sämtliche Verknüpfungen korrekt übernommen.

Beispiel: Ein Bild enthält einen Button mit einer Funktion Sollwert absetzen auf eine Variable. Mit dem Bild wird die Funktion importiert, nicht aber die Variable.

info Info

Hier empfiehlt sich der Einsatz des XML Import Wizards.

Noch in diesem Kapitel

Schablonen

Schriften

Symbole


Schablonen

Handbuch -> Import - Export -> Bilder -> Schablonen

Schablonen können unabhängig von den Bildern exportiert/importiert werden.

Die Schablonen werden mit den ursprünglich definierten Koordinaten (abhängig von der Auflösung auf dem Quellrechner) exportiert. Beim Import ist darauf zu achten, dass die Schablonen nicht automatisch an die Auflösung des Zielrechners angepasst werden.


Schriften

Handbuch -> Import - Export -> Bilder -> Schriften

Beim Export von Schriften werden exportiert:

  • Schriftliste
  • Schriften

Alle diese Daten werden mit den Schriften automatisch importiert.


Symbole

Handbuch -> Import - Export -> Bilder -> Symbole

Der Import/Export von Symbolen ist aus der Projekt-Symbolbibliothek und aus der Globalen Symbolbibliothek möglich. Es können einzelne, selektierte Symbole oder die gesamte Bibliothek importiert bzw. exportiert werden. Der Pfad für den Export ist frei wählbar.

Symbole exportieren

Um Symbole zu exportieren:

  1. markieren Sie die gewünschten Symbole
  2. wählen Sie im Kontextmenü der Detailansicht den Befehl Selektierte XML exportieren...
    Alternative: wählen Sie im Kontextmenü des Knotens Projekt-Symbolbibliothek den Befehl XML exportieren alle...
  3. der Auswahldialog für den Speicherort wird geöffnet
  4. wählen Sie den gewünschten Speicherort
  5. vergeben Sie einen Namen
  6. achten Sie auf den Dateityp XML
  7. bestätigen Sie mit Klick auf die Schaltfläche Speichern

Die ausgewählten Symbole werden in eine XML-Datei exportiert und können jederzeit in dieses oder andere Projekte wieder importiert werden.

Symbole importieren

Um Symbole zu importieren:

  1. wählen Sie im Kontextmenü des Knotens oder der Detailansicht von Projekt-Symbolbibliothek bzw. in der Detailansicht der Globalen Symbolbibliothek den Befehl XML importieren...
  2. der Auswahldialog für den Speicherort wird geöffnet
  3. navigieren Sie zum Speicherort der gewünschten XML-Datei
  4. wählen Sie die gewünschte Datei aus
  5. bestätigen Sie den Import mit Klick auf die Schaltfläche Öffnen

Die Symbole werden importiert.

Namenskonflikt beim Import

Beim Importieren eines Symbols wird der in der XML-Datei hinterlegte Name (Attribut ShortName) für die Benennung des neu anzulegenden Symbols verwendet. Existiert bereits ein Symbol mit dem selben Namen, wird der Import unterbrochen und eine Fehlermeldung angezeigt:

Parameter | Beschreibung
Ja | Das in der Fehlermeldung genannte Symbol wird beim Import durch das Symbol aus der XML-Datei ersetzt. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Nein | Das in der Fehlermeldung genannte Symbol wird nicht importiert, das bereits vorhandene Symbol wird beibehalten. Bei einem erneuten Konflikt wird die Fehlermeldung wieder aufgeschaltet.
Ja alle | Das in der Fehlermeldung genannte Symbol wird beim Import durch das Symbol aus der XML-Datei ersetzt. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Symbole werden ersetzt.
Nein alle | Das in der Fehlermeldung genannte Symbol wird nicht importiert, das bereits vorhandene Symbol wird beibehalten. Diese Einstellung wird bei weiteren Fehlern durch Namensgleichheiten automatisch verwendet. Alle betroffenen Symbole werden beibehalten.

Hinweis: Es wird nur der ShortName verwendet. Der Dateiname spielt für die Benennung des zu importierenden Symbols keine Rolle, kann also zur Konfliktlösung nicht verwendet werden.


Benutzer

Handbuch -> Import - Export -> Benutzer

Die Export-Datei für die Benutzer gliedert sich in:

Benutzerliste

Lokal im Projekt angelegte Benutzer können exportiert/importiert werden.

attention Achtung

Die Passwörter der Benutzer werden verschlüsselt exportiert! Daher können diese direkt in der Export-Datei nicht geändert werden.


Datentypen

Handbuch -> Import - Export -> Datentypen

Die Export-Datei für die Datentypen gliedert sich in:

Datentypliste

Siehe auch Abschnitt: Import von Variablen und Datentypen.

Noch in diesem Kapitel

Datentypen von Hand anlegen


Datentypen von Hand anlegen

Handbuch -> Import - Export -> Datentypen -> Datentypen von Hand anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

attention Achtung

Nur für Experten

Sollte ein Datentyp von Hand in der XML-Datei angelegt werden, sollte die folgende Definition verwendet werden:

info Info

<Apartment ShortName=' zenon(R) type list' Version=' 0x00000000' >
<Type TypeID=' 3' IsComplex=' FALSE' >
<Name>UINT</Name>
</Type>
</Apartment>

Die restlichen Eigenschaften der Datentypdefinition sollten weggelassen werden.


Funktionen

Handbuch -> Import - Export -> Funktionen

Beim Import/Export der Funktionen werden die betroffenen Variablen, etc. nicht automatisch mit exportiert/importiert. Es sollte gegebenen Falls darauf geachtet werden, dass vorher ein Import/Export der betroffenen Objekte durchgeführt wird.

info Info

Ab zenon 6.50 werden Zeitinformationen in einer XML-basierten Funktion in UTC (Sekunden seit dem 01.01.1970, 0 Uhr). Diese betrifft z.B. Funktion Bildumschaltung auf folgende Bildtypen:

  • Alarmmeldeliste
  • Alarmmeldeliste Filter
  • Archiv-Nachbearbeitung
  • Chronologische Ereignisliste
  • Chronologische Ereignisliste Filter
  • Erweiterter Trend
  • Production & Facility Scheduler
  • Report
  • Zeitfilter

Bei älteren zenon Versionen als 6.50, wird diese Zeitinformation stringbasiert gespeichert (z.B. 02.01.1970 01:00:00).

Noch in diesem Kapitel

Skripte


Skripte

Handbuch -> Import - Export -> Funktionen -> Skripte

Die Export-Datei für die Skripte gliedert sich in:

Skriptenliste

Beim Import/Export der Skripte werden die betroffenen Funktionen nicht automatisch mit exportiert/importiert. Es sollte gegebenen Falls darauf geachtet werden, dass vorher ein Funktionenimport/-export durchgeführt wird.

Jedes Skript scheint in der Export-Datei mit einer eigenen Sektion auf, die den Namen des Skripts und die Namen der verknüpften Funktionen beinhaltet.


Menüs

Handbuch -> Import - Export -> Menüs

Die Export-Datei für die Menüs gliedert sich in:

Menüliste

Beim Import/Export der Menüs werden die betroffenen Variablen, Funktionen, Hilfeseiten und Makros nicht automatisch mit exportiert/importiert. Es sollte gegebenenfalls darauf geachtet werden, dass vorher ein entsprechender Import/Export durchgeführt wird.


Reaktionsmatrizen

Handbuch -> Import - Export -> Reaktionsmatrizen

Die Export-Datei für die Reaktionsmatrizen gliedert sich in:

Reaktionsmatrizenliste


Rezepte Standard

Handbuch -> Import - Export -> Rezepte Standard

Die Export-Datei für die Standard Rezepte gliedert sich in:

Rezeptliste

Variablenliste

Treiberliste

Datentypliste

Mit den Standard Rezepten werden also auch die darin enthaltenen Variablen exportiert. Die Rezepte werden automatisch importiert. Die Variablen müssen vorher separat aus dieser Datei importiert werden.

Zusätzlich zum XML Import/Export steht bei den Standard Rezepten auch ein ASCII Import zur Verfügung.
Achtung: Beim ASCII-Import können Rezepte nur einzeln importiert werden.

Beim Rezept wird der Rohwert gespeichert. Dieser wird über VBA und beim Export von Rezepten über XML verwendet.


Rezeptgruppen

Handbuch -> Import - Export -> Rezeptgruppen

Die Export-Datei für die Rezepte des Rezeptgruppen Managers gliedert sich in:

  • Rezeptgruppenliste

Beim Import/Export der Rezeptgruppen und ihrer Rezepte werden die betroffenen Variablen nicht automatisch mit exportiert/importiert. Es sollte gegebenenfalls darauf geachtet werden, dass vorher ein Variablenimport/-export durchgeführt wird.

Die XML-Datei ist auf der Basis von Rezeptgruppen aufgebaut, d.h. es werden einzelne Rezeptgruppen importiert (mit deren Variablen und Rezepten und Rezeptwerten). Nach einem Import werden bestehende Rezeptwerte, welche nicht im Importfile stehen, noch vorhanden sein. Gleiches gilt für Rezepte und verknüpfte Variablen.

Beim Import eines einzelnen Rezeptes aus der Rezeptgruppe gilt: Die zugehörige Rezeptgruppe muss selektiert sein. Eine entsprechende Meldung wird im Ausgabefenster angezeigt.

info Info

Der RGM unterstützt neben XML auch den ASCII-Import von Rezepten.
Achtung: Beim ASCII-Import können Rezepte nur einzeln importiert werden.


Variablen

Handbuch -> Import - Export -> Variablen

Variablen können mit zenon exportiert und importiert werden:

  • XML: Export und Import; beim Import werden die Daten analysiert und bei Konflikten Lösungsmöglichkeiten angeboten
  • CSV: Export und Import; beim Import werden vorhandene Daten überschrieben
  • DBF: Export und Import; beim Import werden vorhandene Daten überschrieben
  • S7: Import
  • TwinCAT Projekt: Import

Export

Die Export-Datei für die Variablen gliedert sich in:

  • Variablenliste
  • Treiberliste
  • Datentypliste

Mit den Variablen werden also auch die Treiber und die Datentypen exportiert. Siehe auch Handbuch Variablen, Kapitel Daten exportieren.

attention Achtung

Auch in einer XML-Datei muss unbedingt ein Treiber angegeben sein, sonst werden keine Variablen importiert! Zu beachten ist auch, dass die Treibereigenschaften in der XML-Datei projektabhängig sind.

Import

Beim Import von Variablen wird von zenon eine Dialogbox geöffnet, in der ein Quelltreiber aus der XML-Datei einem Zieltreiber im Projekt zugeordnet werden kann. Alle Variablen des Quelltreibers werden dann als Variablen für den Zieltreiber importiert. Die Datentypen werden mit den Variablen automatisch importiert. Die Treiber müssen vor dem Import im Projekt angelegt sein. Siehe Abschnitt Import von Variablen und Datentypen.

attention Achtung

Änderungen für Variablen werden in einer unsortierten Liste gesammelt. Daher kann nur eine Änderung pro Variable je Import übernommen werden. Sollen mehrere Änderungen pro Variable übernommen werden, muss dies über mehrere Import-Vorgänge realisiert werden.

Beispiel: Würde die gleiche Variable im gleichen Import-Vorgang sowohl umbenannt als auch gelöscht werden, kann der Import zu einer nicht gelöschten, aber umbenannten Variablen in der Projektierung führen.

Import von Struktur-Variablen:

Strukturen

Strukturen, die sich von bestehenden unterscheiden, können in bereits bestehende Strukturen importiert werden. Darauf basierende Variablen werden automatisch angepasst:

  • Die Strukturelemente werden über ihren Namen identifiziert.
  • Bei bereits bestehenden Strukturelementen wird der Typ angepasst, sofern er sich unterscheidet.
  • Nicht bestehende Elemente werden hinzugefügt.
  • Elemente, die es im neuen Strukturdatentyp nicht gibt, werden entfernt.

Inaktive Variablen

Beim Import von Strukturvariablen werden sowohl aktive als auch inaktive Variablen importiert. Vorhandene Elemente werden beim Import nicht überschrieben. Wird also in einem Projekt eine inaktive Variable importiert und anschließend aktiviert, bleibt sie auch nach einem erneuten XML-Import aktiv.

Noch in diesem Kapitel

Import und Export von Variablen und Datentypen

XML-Import

CSV-Import

CSV-Export

S7-Projekt

dBase Import und Export


Import und Export von Variablen und Datentypen

Handbuch -> Import - Export -> Variablen -> Import und Export von Variablen und Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Import/Export von Variablen gilt:

  • Der Import/Export darf nicht aus dem Globalprojekt gestartet werden.
  • Der Start erfolgt über:
    • Kontextmenü zu Variablen bzw. Datentyp im Projektbaum
    • oder Kontextmenü einer Variablen bzw. eines Datentyps
    • oder Symbol in der Symbolleiste Variablen

attention Achtung

Beim Import/Überschreiben von existierenden Datentypen werden alle Variablen geändert, die auf diesem existierenden Datentyp basieren.

Beispiel:

Es existiert ein Datentyp XYZ abgeleitet vom Typ INT mit Variablen, die auf diesem Datentyp basieren. Ihre zu importierende XML-Datei enthält ebenfalls einen Datentyp mit Namen XYZ, allerdings abgeleitet vom Typ STRING. Wird dieser Datentyp importiert, so wird der existierende Datentyp überschrieben und bei allen auf ihm basierenden Variablen der Typ angepasst. D.h. die Variablen sind jetzt STRING- und keine INT-Variablen mehr.


XML-Import

Handbuch -> Import - Export -> Variablen -> XML-Import

Beim XML- Import von Variablen oder Datentypen werden diese nach der Treiberzuordnung von zenon analysiert. Der Benutzer hat anschließend die Möglichkeit zu bestimmen, was mit den jeweiligen Variablen/Datentypen geschehen soll:

  • importieren
  • überschreiben
  • nicht importieren.

Angeboten werden jeweils nur sinnvolle Aktionen.

Folgende Konflikte verhindern den Import:

  • Der Datentyp existiert bereits und die zugehörige Variable kann nicht auf den zu importierenden Datentyp konvertiert werden.
  • Der Datentyp ist komplex und die Elemente des existierenden unterscheiden sich von dem zu importierenden durch Anzahl oder Name.
  • Der Datentyp ist komplex, die Elemente sind zwar gleich, aber unterscheiden sich in ihren Datentypen wobei eine Konvertierung zugehöriger Variablen nicht möglich ist.
  • Die Variable ist von einem Typ, der nicht importiert werden kann (s.o.).
  • Die Variable ist von einem anderen Typ als die bestehende (einfach/komplex).
  • Die Treiberzuordnung für die Variable ist nicht korrekt (der zugeordnete Treiber unterstützt die entsprechende Datenart und/oder den entsprechenden Bereich nicht).

Parameter

Beschreibung

Zu importierende Elemente

Listet alle Variablen und Datentypen, die importiert werden sollen, auf. Bei komplexen Variablen werden die zugehörigen einfachen Variablen angezeigt. Strukturierte Typen können aufgeklappt werden und zur Information werden die Elemente des Strukturdatentyps angezeigt.

Symbole zeigen an, ob das Element importiert werden kann (grüner Haken(, nicht importiert werden kann (rotes X) oder eine Konflikt gelöst werden muss (blaues Symbol).

Import-Details

Beschreibt Importstatus und bietet Lösungsmöglichkeiten bei Konflikten.

Beschreibung

Beschreibt den Status des Elements.

Mögliche Aktionen

Erklärt die möglichen Aktionen.

Aktion

Dropdownliste mit den möglichen Aktionen und der aktuell ausgewählten Aktion. Gibt es nur eine mögliche Aktion, dann ist diese vorausgewählt und lässt sich auch nicht ändern.

Datentyp/Variable neu importieren

Die Variable/der Datentyp existiert noch nicht und wird durch den Import neu angelegt. (Default)

Nicht vom Benutzer änderbar.

Datentyp/Variable nicht importieren

Die Variable/der Datentyp existiert schon und es gibt Konflikte.

Nicht vom Benutzer änderbar.

Datentyp/Variable importieren

Die Variable/der Datentyp existiert schon, es gibt keine Konflikte.

Der Benutzer kann entscheiden, ob die Variable/der Datentyp überschrieben oder nicht importiert werden soll. Per Default wird die Variable/der Datentyp überschrieben.

info Info

Ein Strukturdatentyp im Projekt hat drei Strukturelemente, ein gleichnamiger Datentyp in der XML-Datei hat vier Strukturelemente. Alle auf diesem Datentyp basierenden Variablen der Export-Datei werden nicht in das Projekt importiert.

Noch in diesem Kapitel

Treiber zuordnen

Bereiche zuordnen

Fehlerbehandlung Import

Variablen XML-Datei extern bearbeiten


Treiber zuordnen

Handbuch -> Import - Export -> Variablen -> XML-Import -> Treiber zuordnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem Befehl Import wird der Dialog zur Treiberzuordnung geöffnet:

Parameter | Beschreibung
Zuordnungstabelle | Zeigt die aktuelle Zuordnung an.
Treiber-Objekttyp zuordnen | Öffnet den Dialog zur Zuordnung der Treiber-Objekttypen.
Treiberzuordnung aufheben | Löst bestehende Zuordnungen.
Treiberliste | Listet alle bestehenden Treiber des Projekts auf.
Neuen Treiber anlegen | Öffnet Dialog, um neuen Treiber anzulegen.
Treiber zuordnen | Ordnet den ausgewählten Treiber der Treiberliste dem in der Zuordnungstabelle ausgewählten Treiber zu
OK | Übernimmt Einstellungen, schließt Dialog und startet Import.
Abbrechen | Verwirft Einstellungen und schließt Dialog ohne zu importieren.
Hilfe | Öffnet Online-Hilfe.

Neuen Treiber erstellen

Während des Imports können über die Schaltfläche Neuer Treiber neue Treiber angelegt und zugeordnet werden. Dabei wird der Dialog zum Anlegen und Konfigurieren neuer Treiber geöffnet.


Bereiche zuordnen

Handbuch -> Import - Export -> Variablen -> XML-Import -> Bereiche zuordnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Zuordnungstabelle | Zeigt die aktuelle Zuordnung an.
Zuordnung aufheben | Löst bestehende Zuordnungen.
Treiber-Objekttypen des Zieltreibers | Liste der zur Verfügung stehenden Treiber-Objekttypen.
Treiber-Objekttyp zuordnen | Ordnet den ausgewählten Treiber-Objekttyp des Zieltreibers dem in der Zuordnungstabelle ausgewählten Treiber-Objekttyp zu.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Fehlerbehandlung Import

Handbuch -> Import - Export -> Variablen -> XML-Import -> Fehlerbehandlung Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Werden beim Variablenimport Inkompatibilitäten festgestellt, wird ein Dialog zur Fehlerbehandlung geöffnet.

Parameter | Beschreibung
Zu importierende Elemente | Liste der Elemente, die importiert werden sollen. Fehlerhafte Elemente werden gekennzeichnet.
Import Details | Details zum Import.
Beschreibung | Fehlerbeschreibung.
Mögliche Aktionen | Erklärung der Aktionen, die für diesen Fehler gesetzt werden können.
Aktionen | Dropdownliste zur Auswahl der gewünschten Aktion.
OK | Übernimmt Aktionen, schließt Dialog und importiert Variablen.
Abbrechen | Verwirft Eingaben und bricht den Import der Variablen ab.


Variablen XML-Datei extern bearbeiten

Handbuch -> Import - Export -> Variablen -> XML-Import -> Variablen XML-Datei extern bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

XML-Dateien können nach dem Export bzw. vor dem Import mit einem externen Programm bearbeitet werden.

attention Achtung

Das externe Bearbeiten von XML-Dateien ist nur für Experten gedacht.
Fehlerhafte Importe können Ihr Projekt beschädigen oder zerstören. Legen Sie vor jeder Bearbeitung eine Projektsicherung an.

Die Header-Definition muss folgende Attribute enthalten:

Parameter | Beschreibung
ShortName | Name der Variable
DriverID | ID des Treibers Bitte beachten Sie, dass die Kennung für jeden Treiber projektabhängig ist. Die genaue Kennung des Treibers erhalten Sie, indem Sie in Ihrem Projekt einen Treiber und eine zugehörige Variable anlegen und mittels XML exportieren.
TypeID | ID für den Datentyp ACHTUNG: die TYPEID ist auch projektabhängig. Details finden Sie unter Import für Datentypen.
HWObjectType | Kennung für den Treiber-Objekttyp Hier wird der Bereich auf der Steuerung definiert z.B. Datenbaustein Bereich, Merker Bereich, Ausgang, Eingang, usw. Bitte beachten Sie, dass nicht jeder Treiber alle Objekttypen unterstützt. Welcher Treiber welchen Objekttyp unterstützt, sehen Sie in der jeweiligen Dokumentation des Treibers. Die genauen Kennungen sind in der Kategorie tpKanaltypes im VBA Objektkatalog aufgelistet.
HWObjectName | Name für den Treiber-Objekttyp Redundante Information zu HWObjectType. Diese Eigenschaft dient nur der Information.
IsComplex | TRUE = Strukturvariable FALSE = einfache Variable
Matrix | Name der verknüpften Reaktionsmatrix Diese Eigenschaft ist leer, wenn keine Reaktionsmatrix verknüpft ist.

Syntax-Beispiele für die Bearbeitung der XML-Datei:

Nr. | Beispiel | Ausdruck | Kommentar
1. | Anlegen einer neuen Variablen beim Importieren | <Variable ShortName='WIZ_VAR_10' DriverID='4' TypeID='2' HWObjectType='8' HWObjectName='SPS-Merker' IsComplex='FALSE' Matrix=''> |
2. | Löschen einer bestehenden Variablen beim Importieren | <Variable ShortName='WIZ_VAR_10' Delete='TRUE' DriverID='4' TypeID='2' HWObjectType='8' HWObjectName='SPS-Merker' IsComplex='FALSE' Matrix=''> | War die Variable im zenon Projekt vorhanden wird diese unter Verwendung des Attributes Delete gelöscht. Bitte achten Sie darauf, dass das Attribut nicht leer ist. Das heißt, es muss z.B. TRUE oder FALSE enthalten. Der Inhalt des Eintrages wird in diesem Fall nicht ausgewertet.
3. | Umbenennen einer bestehenden Variablen beim Importieren | <Variable ShortName='WIZ_VAR_10' Delete='TRUE' DriverID='4' TypeID='2' HWObjectType='8' HWObjectName='SPS-Merker' IsComplex='FALSE' Matrix='' NewName='Standard_1'> | Beim Umbenennen wird die Variable zunächst importiert, und danach erst umbenannt. Sie können also auf Wunsch der Variable geänderte Eigenschaften übertragen, und diese gleichzeitig umbenennen. Existiert eine Variable mit dem neuen Namen bereits, schlägt das Umbenennen fehl. Ein Eintrag im Ausgabefenster gibt Ihnen darüber Auskunft.


CSV-Import

Handbuch -> Import - Export -> Variablen -> CSV-Import

Variablen können mit zenon in CSV-Dateien exportiert und aus CSV-Dateien importiert werden, zum Beispiel um sie in Microsoft Excel weiter zu bearbeiten. In CSV exportierte Variablen werden immer als TXT-Datei im Unicode-Format gespeichert.

Wurden beim Export die Kompatibilitätsgrenzen von Microsoft Excel überschritten und der Export trotz Warnung durchgeführt, enthält die zu importierende TXT-Datei nicht alle exportierten Daten.

Spezifikation des Formats

  • Trennzeichen: Tab
  • Dateiendung: .txt
  • Codierung: Die exportierte Datei ist Unicode kodiert. Die zu importierende Datei muss ebenfalls Unicode kodiert sein.

Kompatibilität mit Microsoft Excel

Export nach Excel

Um exportierte Variablen in CSV-Dateien korrekt in Microsoft Excel importieren zu können, beachten Sie:

  • Format:
    Damit Microsoft Excel das richtige Dezimaltrennzeichen verwendet, muss bei den Regional- und Sprachoptionen im Betriebssystem das Format auf Englisch eingestellt sein. Achtung: Diese Einstellung ist bei Verwendung von Dezimaltrennzeichen zwingend, da die Werte sonst falsch interpretiert bzw. gespeichert werden.
  • Unicode:
    Die Dateien müssen in Microsoft Excel als Unicode Text (.txt) gespeichert werden. Gespeichert werden sie als TXT-Dateien. Unter älteren Microsoft Excel Versionen kann die Bezeichnung auch leichte Abweichungen aufweisen.
    Achtung: Wird ein anderes Format verwendet, können die Daten nicht mehr korrekt importiert werden!
  • @ Zeichen:
    Microsoft Excel interpretiert @ Zeichen in einer Zelle nicht als Text und lässt deshalb eventuell keine Bearbeitung zu. Um Zellen mit @ Zeichen bearbeiten zu können, muss der Zelltyp (Kategorie) von Standard auf Text umgestellt werden. Dazu
    • markieren Sie die Zelle oder die Spalte
    • wählen Sie nach einem Rechtsklick auf die Zelle im Kontextmenü den Befehl Zellen formatieren
    • stellen Sie im Dialog die Kategorie auf Text
  • Maximalwerte:
    • Microsoft Excel 97-2003: 65536 Zeilen, 256 Spalten
    • Microsoft Excel 2007: 1048576 Zeilen, 16384 Spalten

attention Achtung

Bei mehr als 16384 bzw. 256 Spalten und bei mehr als 1048576 bzw. 65536 Zeilen erscheint jeweils eine Abfrage ob entsprechend weniger dynamische Eigenschaften (wenn möglich) exportiert werden sollen. Bei Auswahl der Limitierung werden dann so viele dynamische Eigenschaften wie möglich exportiert.

Statische Eigenschaften werden nicht limitiert.

Reicht das entfernen der dynamischen Eigenschaften nicht aus, so erscheint zusätzlich ein entsprechender Hinweis.

Bei der maximalen Anzahl an Variablen muss berücksichtigt werden, dass der Header eine eigene Zeile benötigt.

Import aus Excel

Beim Import aus Excel darf die letzte (leere) Zeile nicht gelöscht werden, sonst kann die CSV-Datei nicht in zenon importiert werden.

Noch in diesem Kapitel

Mindestvoraussetzungen

Variablen beim Import löschen oder umbenennen

Kompatibilität mit Microsoft Excel

Beispiel für Import


Mindestvoraussetzungen

Handbuch -> Import - Export -> Variablen -> CSV-Import -> Mindestvoraussetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Definition der Formate

Format | Inhalt
VariableName | Name, den die Variable tragen soll
DriverName | Bezeichnung des vorhandenen Treibers
DriverType | Typ des vorhandenen Treibers
HWObjectType | Nummer des Treiber Objekttyps, da der Name sprachabhängig ist . Wird auch als Kanaltyp bezeichnet und kann entweder durch Export einer entsprechenden Variablen oder mit Hilfe der Treiber-Dokumentation herausgefunden werden.
TypeName | Name des vorhandenen Datentyps

Inhalte

  • Treiber vom importierten DRIVERTYPE und dem importierten DRIVERNAME muss existieren:
    Kann kein Treiber mit dem DRIVERTYPE und dem DRIVERNAME gefunden werden, wird versucht, die Variable mit einem ähnlichen Treiber zu verknüpfen. Dabei wird zuerst nach einem Treiber nur mit dem DRIVERTYPE, danach nur mit dem DRIVERNAME gesucht. Kann auf diese Weise kein Treiber für eine Zuordnung gefunden werden, wird versucht die Variable mit dem Intern Treiber, danach mit einem vorhandenen Treiber zu verknüpfen. Wenn kein Treiber vorhanden ist oder der Variable kein Treiber zugeordnet werden kann, wird die Variable nicht importiert. Mit dem Dialog Treiber-Zuordnung (siehe Kapitel Import von Variablen und Datentypen) kann die entsprechende Verknüpfung noch vor dem Import der Variablen erstellt und/oder geändert werden. Dieser Dialog wird nach Auswahl der zu importierenden Datei geöffnet.
  • Simpler Datentyp mit dem importierten TYPENAME und dem importierten HWOBJECTTYPE:
    Ist der Datentyp mit dem entsprechenden TYPENAME nicht vorhanden, wird die Variable nicht importiert. Nachdem alle weiteren Variablen abgearbeitet bzw. importiert wurden, wird im Ausgabefenster gemeldet, wie viele Variablen aufgrund von fehlenden Datentypen nicht importiert werden konnten.

Header

Es muss ein Header existieren, der die Eigenschaftswerte beschreibt:
Der Header beschreibt die Eigenschaften auf Spaltenbasis. Der erste Eintrag im Header gilt immer für den ersten Eintrag bei den Werten, der zweite Eintrag im Header gilt immer für den zweiten Eintrag bei den Werten usw. Die Anzahl der Felder im Header muss der maximal vorkommenden Anzahl an Feldern der gesamten Datei entsprechen.

  • Der Header
    muss nicht in der ersten Zeile des Files stehen, muss aber die erste bzw. oberste Zeile von allen Zeilen sein.
  • Groß-/Kleinschreibung
    • spielen im Header keine Rolle.
    • wird bei Eigenschaftswerten berücksichtigt.
  • Der Header muss durchgängig und ohne Lücken sein.
    Befindet sich ein leeres Feld (Bereich zwischen Trennzeichen) im Header, wird der Import abgebrochen.
    Definition leeres Feld: Zwei aufeinander folgende Trennzeichen ohne Inhalt dazwischen.
  • Führende und abschließende Leerzeichen
    innerhalb eines Feldes (egal ob mit oder ohne Anführungszeichen) werden als solche interpretiert. Es werden keine Leerzeichen entfernt. Deshalb muss der Wert bzw. das Feld ganz genau stimmen.
  • Das Trennzeichen
    sollte am Ende einer Zeile nicht mehr vorkommen, außer es handelt sich um ein existentes Feld, das einen leeren Wert besitzt.
  • Sämtliche Felder (Bereich zwischen Trennzeichen), in denen das Trennzeichen vorkommt, müssen in Anführungszeichen stehen.
    Davon ist jeweils nur das entsprechende Feld betroffen. Die restlichen Felder, welche nicht diese Kriterien erfüllen, müssen auch nicht in Anführungszeichen stehen. Tabulator-Trennzeichen werden innerhalb eines Feldes, welches in Anführungszeichen steht, automatisch entfernt.
  • Wenn Anführungszeichen verwendet werden sollen,
    muss das gesamte Feld (Bereich zwischen Trennzeichen) in Anführungszeichen stehen und zusätzlich jedes gewollte Anführungszeichen direkt verdoppelt werden. Die Anzahl an Anführungszeichen muss also immer einer geraden Zahl entsprechen.
    Beispiele:
    • T"e"st wird zu "T""e""st",
    • "AB"C" wird zu """AB""C""",
    • AB"C wird zu "AB""C"
  • Nur zwei Anführungszeichen in einem Feld ohne Text dazwischen sind nicht für leere Werte gültig.
  • Leer gelassene Felder (2 direkt aufeinander folgende Trennzeichen)
    werden als für diese Spalte nicht existierender Eintrag interpretiert. Ist das Feld, einer für die Variable existierender Eigenschaft, leer und somit nicht gesetzt, wird der Standardwert dieser Eigenschaft verwendet.
  • Existieren weniger Felder für Werte als im Header festgelegt,
    werden die restlichen nicht existierenden Felder für Werte als als leere Felder interpretiert.
  • Ist die Anzahl an Werten bzw. Felder
    in einer Zeile größer als die Anzahl an die im Header festgelegten Felder, so werden die letzten bzw. betroffenen Werte/Felder ignoriert.
  • Strichpunkt und Beistrich
    können in Feldern (ohne Anführungszeichen) beliebig verwendet werden.
  • Punkte
    werden bei numerischen Werten immer als Dezimaltrennzeichen gewertet.
  • Es dürfen leere Zeilen existieren.
    Diese werden ignoriert.

Namen, Verknüpfungen und Ersetzungen

  • Jede Variable muss ihren eigenen Namen in der Datei haben.
    Kommen mehrere Variablen mit dem gleichen Namen vor, so wird die erste importiert, alle weiteren werden ignoriert.
  • Verknüpfungen müssen existieren.
    Reaktionsmatrix, Funktionen, Variablen, Alarmbereiche, Alarm/Ereignis-Gruppen, Alarm/Ereignis-Klassen, Verriegelungen usw. werden beim Import nur verknüpft, wenn diese im Projekt auch existieren. Existiert das Element mit dem Namen nicht, so wird kein Element verknüpft. Wenn eine Eigenschaft nicht verknüpft werden kann, so werden die restlichen Eigenschaften davon unabhängig trotzdem importiert.
  • Dynamische Eigenschaften (wie zum Beispiel Grenzwerte) haben eine gemeinsame Identifizierung und eine Laufnummer.
    Die Laufnummer beginnt bei 0. Die Bezeichnung erfolgt ähnlich dem XML Export Format. (z.B.: Limits_8_Active, Limits_8_Text, Limits_8_LimitValue, …)
  • Array Variablen und Variablen von komplexen Datentypen werden weder exportiert, noch importiert.
  • Vorhandene komplexe Variablen werden beim Importieren nicht überschrieben.
  • Der Import einer Variable wird bei Existenz des gleichen Namens in einem Kindelement einer vorhandenen komplexe Variablen zugelassen. Wenn z. B. der Name der zu importierenden Variable ABC.DEF ist und die Variable DEF im zenon Editor ein Kind von der Variable ABC im Editor ist, so wird die Variable trotzdem eingefügt.
  • Alle Eigenschaften die importiert bzw. exportiert werden haben ähnliche Spalten-/Headernamen wie beim XML Import bzw. Export. Die Spalten-/Headernamen können am Leichtesten durch Export einer entsprechenden Variable herausgefunden werden.
  • Bei einigen Treibern gib es treiberspezifische Eigenschaften. Um die entsprechenden Spalten-/Headernamen herauszufinden eignet sich am besten ein Export einer Variable mit dem entsprechenden Treiber.

Beschränkungen

Eigenschaften, die nicht exportiert bzw. importiert werden:

  • ID_ComplexVariable
  • ID_Complex
  • HWObjectName
  • ID_DriverTyp
  • DriverID
  • TypeID
  • IsComplex
  • Alle IsLocal bzw. Flag Eigenschaften
  • IsSWProtokol, IsSW_Akt und IsSW_VBA


Variablen beim Import löschen oder umbenennen

Handbuch -> Import - Export -> Variablen -> CSV-Import -> Variablen beim Import löschen oder umbenennen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Import können Variablen gelöscht oder umbenannt werden. Das Löschen erfolgt via Eintrag im Feld KANAL_D, das Umbenennen via Eintrag im Feld KANAL_R. Die zu löschende oder umzubenennende Variable wird im Feld VariableName definiert.

Variablen löschen

Variablen werden gelöscht, wenn im Feld KANAL_D und im Feld VariableName der CSV-Datei gültige Einträge erkannt werden.

Feld | Funktion | gültig, wenn
KANAL_D | Setzt Löschbefehl. | 1
VariableName | Name der zu löschenden Variablen | Eintrag, der nicht ausschließlich aus nichtdruckbaren Zeichen besteht

Zum Löschen können auch CSV-Dateien verwendet werden, die nur aus diesen beiden Feldern bestehen (Short-Format).

Variablen umbenennen

Variablen werden umbenannt, wenn im Feld KANAL_R und im Feld VariableName der CSV-Datei gültige Einträge erkannt werden.

Feld | Funktion | gültig, wenn
KANAL_R | Zu ersetzender Originalname der Variablen. | Eintrag, der nicht ausschließlich aus nichtdruckbaren Zeichen besteht
VariableName | Neuer Variablenname. | Eintrag, der nicht ausschließlich aus nichtdruckbaren Zeichen besteht

Zum Umbenennen können auch CSV-Dateien verwendet werden, die nur aus diesen beiden Feldern bestehen (Short-Format).

attention Achtung

Wird in einer Zeile sowohl die Umbenennung als auch die Löschung beauftragt, wird die Variable gelöscht.

Meldungen im Ausgabefenster

Werden beim CSV-Import Variablen gelöscht oder umbenannt, werden im Ausgabefenster des Editors Meldungen zum Erfolg oder misserfolg der Aktionen ausgegeben:

Meldung

Level

Beschreibung

Umzubenennende Variable '%s' nicht vorhanden.

Warning

Die umzubenennende Variable, referenziert durch den im Feld KANAL_R angegebenen Variablennamen, existiert nicht.

Zu löschende Variable '%s' nicht vorhanden.

Warning

Die zu löschende Variable, referenziert durch den im Feld VariableName angegebenen Variablennamen, existiert nicht.

Die Variable '%s' wurde in '%s' umbenannt.

Normal

Die Variable wurde erfolgreich umbenannt.

Die Variable '%s' wurde gelöscht.

Normal

Die Variable wurde erfolgreich gelöscht.

%i von %i Variable(n) umbenannt.

Normal

bzw. Warning

Diese Meldung wird nur ausgegeben, wenn Umbenennungen durch gültige, also nicht leere KANAL_R Felder durchzuführen sind. Der erste Platzhalter (%i) entspricht der Anzahl der erfolgreich durchgeführten, der zweite Platzhalter der Anzahl der beauftragten Umbenennungen.

Konnten nicht alle Umbenennungen erfolgreich durchgeführt werden, wird die Ausgabe als Warnung formatiert.

%i von %i Variable(n) gelöscht.

Normal

bzw.

Warning

Diese Meldung wird nur ausgegeben, wenn Löschungen durch gültige KANAL_D Felder (numerischer Wert 1) durchzuführen sind. Der erste Platzhalter (%i) entspricht der Anzahl der erfolgreich durchgeführten, der zweite Platzhalter der Anzahl der beauftragten Löschungen.

Konnten nicht alle Löschungen erfolgreich durchgeführt werden, wird die Ausgabe als Warnung formatiert.


Kompatibilität mit Microsoft Excel

Handbuch -> Import - Export -> Variablen -> CSV-Import -> Kompatibilität mit Microsoft Excel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Export nach Excel

Um exportierte Variablen in CSV-Dateien korrekt in Microsoft Excel importieren zu können, beachten Sie:

  • Format:
    Damit Microsoft Excel das richtige Dezimaltrennzeichen verwendet, muss bei den Regional- und Sprachoptionen im Betriebssystem das Format auf Englisch eingestellt sein. Achtung: Diese Einstellung ist bei Verwendung von Dezimaltrennzeichen zwingend, da die Werte sonst falsch interpretiert bzw. gespeichert werden.
  • Unicode:
    Die Dateien müssen in Microsoft Excel als Unicode Text (.txt) gespeichert werden. Gespeichert werden sie als TXT-Dateien. Unter älteren Microsoft Excel Versionen kann die Bezeichnung auch leichte Abweichungen aufweisen.
    Achtung: Wird ein anderes Format verwendet, können die Daten nicht mehr korrekt importiert werden!
  • @ Zeichen:
    Microsoft Excel interpretiert @ Zeichen in einer Zelle nicht als Text und lässt deshalb eventuell keine Bearbeitung zu. Um Zellen mit @ Zeichen bearbeiten zu können, muss der Zelltyp (Kategorie) von Standard auf Text umgestellt werden. Dazu
    • markieren Sie die Zelle oder die Spalte
    • wählen Sie nach einem Rechtsklick auf die Zelle im Kontextmenü den Befehl Zellen formatieren
    • stellen Sie im Dialog die Kategorie auf Text
  • Maximalwerte:
    • Microsoft Excel 97-2003: 65536 Zeilen, 256 Spalten
    • Microsoft Excel 2007: 1048576 Zeilen, 16384 Spalten

attention Achtung

Bei mehr als 16384 bzw. 256 Spalten und bei mehr als 1048576 bzw. 65536 Zeilen erscheint jeweils eine Abfrage ob entsprechend weniger dynamische Eigenschaften (wenn möglich) exportiert werden sollen. Bei Auswahl der Limitierung werden dann so viele dynamische Eigenschaften wie möglich exportiert.

Statische Eigenschaften werden nicht limitiert.

Reicht das entfernen der dynamischen Eigenschaften nicht aus, so erscheint zusätzlich ein entsprechender Hinweis.

Bei der maximalen Anzahl an Variablen muss berücksichtigt werden, dass der Header eine eigene Zeile benötigt.

Import aus Excel

Beim Import aus Excel darf die letzte (leere) Zeile nicht gelöscht werden, sonst kann die CSV-Datei nicht in zenon importiert werden.


Beispiel für Import

Handbuch -> Import - Export -> Variablen -> CSV-Import -> Beispiel für Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Import einer Variable seien folgende Informationen in der Datei gegeben:

VariableName | DriverName | DriverType | HWObjectType | TypeName
Test | MeinTreiber | Intern | 33 | MeinDatentyp

Bevor die Datei importiert werden kann, muss sichergestellt werden, dass ein Treiber mit dem Namen „MeinTreiber" und dem Typ Intern im Projekt angelegt wurde. Dieser Treiber muss den Kanaltyp bzw. HWObjectType unterstützen. Zusätzlich muss der Datentyp „MeinDatentyp" existieren. Nach Auswahl der Datei für den Import, erscheint der Dialog für die Treiber-Zuordnung. Darin können alle zu importierenden Variablen eines im Projekt angelegten Treibers mit einem anderen Treiber verknüpft werden. Wenn der gleiche Treiber gewünscht ist, kann der Dialog direkt mit OK bestätigt werden. Danach erfolgt der Import der Variablen.


CSV-Export

Handbuch -> Import - Export -> Variablen -> CSV-Export

Variablen können mit zenon in CSV-Dateien exportiert und aus CSV-Dateien importiert werden, zum Beispiel um sie in Mircosoft Excel weiter zu bearbeiten.

Ausnahme: Komplexe Datentypen und Arrayvariablen dürfen nicht exportiert werden.

attention Achtung

Der Export erfolgt in eine Tabulator separierte Unicode Textdatei mit der Endung .txt statt .csv.

Hintergrund: Microsoft Excel speichert CSV Dateien als ANSI Text Datei mit ; als Separator. Beim Speichern als CSV in Excel wird Unicode entfernt. Damit wären die Exportdaten für das Projekt irreparabel beschädigt.

Exportoptionen

  1. Export aller exportierbaren Variablen im Projekt
  2. Exportieren ausgewählter exportierbarer Variablen
    • nur verfügbar, wenn mindestens eine exportierbare Variable ausgewählt wurde

Beim Exportieren der Variablen wird ein Dialog zur Wahl des Speicherorts und des Dateinamens angeboten. Die Dateiendung ist fest mit .txt vorgegeben.

Befinden sich für das Verarbeiten in Microsoft Excel zu viele Eigenschaften in der zu exportierenden Datei, wird das weitere Vorgehen abgefragt:

  • Eigenschaften oder Zeilen abschneiden:
    Es werden dann zum Beispiel nur ein Teil der Grenzwerte oder nur ein Teil der Variablen exportiert (hängt vom Fall der Limitierung ab). In erster Linie werden Informationen nicht exportiert, die in älteren Microsoft Excel Versionen nicht verarbeitet werden können. Die exportierte Datei kann mit einem externen Programm bearbeitet werden.
  • Alle Eigenschaften exportieren
  • Export abbrechen

Kompatibilität mit Microsoft Excel

Export nach Excel

Um exportierte Variablen in CSV-Dateien korrekt in Microsoft Excel importieren zu können, beachten Sie:

  • Format:
    Damit Microsoft Excel das richtige Dezimaltrennzeichen verwendet, muss bei den Regional- und Sprachoptionen im Betriebssystem das Format auf Englisch eingestellt sein. Achtung: Diese Einstellung ist bei Verwendung von Dezimaltrennzeichen zwingend, da die Werte sonst falsch interpretiert bzw. gespeichert werden.
  • Unicode:
    Die Dateien müssen in Microsoft Excel als Unicode Text (.txt) gespeichert werden. Gespeichert werden sie als TXT-Dateien. Unter älteren Microsoft Excel Versionen kann die Bezeichnung auch leichte Abweichungen aufweisen.
    Achtung: Wird ein anderes Format verwendet, können die Daten nicht mehr korrekt importiert werden!
  • @ Zeichen:
    Microsoft Excel interpretiert @ Zeichen in einer Zelle nicht als Text und lässt deshalb eventuell keine Bearbeitung zu. Um Zellen mit @ Zeichen bearbeiten zu können, muss der Zelltyp (Kategorie) von Standard auf Text umgestellt werden. Dazu
    • markieren Sie die Zelle oder die Spalte
    • wählen Sie nach einem Rechtsklick auf die Zelle im Kontextmenü den Befehl Zellen formatieren
    • stellen Sie im Dialog die Kategorie auf Text
  • Maximalwerte:
    • Microsoft Excel 97-2003: 65536 Zeilen, 256 Spalten
    • Microsoft Excel 2007: 1048576 Zeilen, 16384 Spalten

attention Achtung

Bei mehr als 16384 bzw. 256 Spalten und bei mehr als 1048576 bzw. 65536 Zeilen erscheint jeweils eine Abfrage ob entsprechend weniger dynamische Eigenschaften (wenn möglich) exportiert werden sollen. Bei Auswahl der Limitierung werden dann so viele dynamische Eigenschaften wie möglich exportiert.

Statische Eigenschaften werden nicht limitiert.

Reicht das entfernen der dynamischen Eigenschaften nicht aus, so erscheint zusätzlich ein entsprechender Hinweis.

Bei der maximalen Anzahl an Variablen muss berücksichtigt werden, dass der Header eine eigene Zeile benötigt.

Import aus Excel

Beim Import aus Excel darf die letzte (leere) Zeile nicht gelöscht werden, sonst kann die CSV-Datei nicht in zenon importiert werden.


S7-Projekt

Handbuch -> Import - Export -> Variablen -> S7-Projekt

Um S7-Projekte in zenon zu verwenden, können Sie den automatischen Import verwenden. Dabei werden die von Ihnen benötigten Variablen in zenon angelegt.

Eine Übernahme der WinCC Namen ist möglich. Dabei kann zwischen zenon, WinCC und kombinierten Namen gewählt werden. Für WinCC Namen ist es möglich, technologische Stufen auszuwählen und das Trennzeichen anzugeben.

info Info

Der S7-Import unterstützt keine Strukturen. Strukturdefinitionen aus dem S7-Projekt werden aufgelöst und als flache Listen importiert. Auch andere Treiber bieten die Möglichkeit, Variablen aus dem Steuerungsprogramm einzulesen (z.B. OPC, Codesys, Bernecker und Rainer, ...).

Noch in diesem Kapitel

Allgemein

S7-Projekt importieren

Stationen auswählen

Variablen auswählen


Allgemein

Handbuch -> Import - Export -> Variablen -> S7-Projekt -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie finden den Import im Kontextmenü des Knoten Variablen im Projektmanagers. Führen Sie einen Rechtsklick auf den Knoten Variablen aus, um das Kontextmenü anzuzeigen. Sie erreichen das Kontextmenü auch, wenn Sie den Knoten Variablen selektiert haben und dann einen Rechtsklick in der Detailansicht des Projektmanagers ausführen.

Klicken Sie auf Erweiterter Import/Export -> S7-Projekt importieren. Im anschließenden Dialog selektieren Sie den entsprechenden Treiber, der für die Kommunikation mit der SPS verwendet wird, und bestätigen mit OK.

info Info

Beim Import von PCS7-Projekten muss für das jeweilige Projekt das Unterverzeichnis CSV_export existieren. Darin muss für jede Station des Projekts eine CSV-Datei mit dem gleichen Namen wie die Station vorhanden sein. Beim Import werden die hierarchischen Namen aus dieser Datei verwendet.


S7-Projekt importieren

Handbuch -> Import - Export -> Variablen -> S7-Projekt -> S7-Projekt importieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein S7-Projekt importieren zu können, muss es lokal auf der Festplatte oder im Netzwerk zur Verfügung stehen. Das Projekt darf nicht gleichzeitig von einem Step7 Programm geöffnet sein.

attention Achtung

Vor dem Import muss in Step 7 bzw. PC S7 alles übersetzt worden sein, damit alle Objekte in zenon übernommen werden können.

Importdialog

Folgende Einstellungen stehen Ihnen zur Verfügung.

Parameter

Beschreibung

Projektauswahl

S7-Projektdatei

Selektieren Sie die gewünschte Projektdatei (*.s7p).

Zieltreiber

Hier sehne Sie noch einmal den Treiber, den Sie zuvor selektiert haben. Eine Änderung ist hier nicht mehr möglich.

Projektstruktur

Sobald Sie eine Projektdatei selektiert habe, wird die Struktur des selektierten Projekts hier angezeigt.

Optionen

Nur BuB verwenden

Aktivieren Sie diese Optionen, wenn Sie nur Variablen importieren möchten die mit Bedienen und Beobachten (BuB) gekennzeichnet sind.

Variablen-Benennung

Name wird aus Technologischen Ebenen gebildet

Entscheiden Sie, welche der Technologischen Ebenen (1 - 5 und Kreis) aus der CFC-Programmierung Sie für die Namensgebung der Varibalen verwenden möchten.

Trennzeichen

Definieren Sie hier das Zeichen, das zwischen den Technologischen Ebenen steht.

Interne Nomenklatur

Verwendet die interne Nomenklatur für die erstellten Objekte.

Beispiel: S0 (für Netzadresse = 0)

WinCC Nomenklatur

Verwendet die WinCC Nomenklatur für die erstellten Objekte.

Beispiel: S7-Programm

Kombiniert

Verwendet für die Namen der angelegten Objekte sowohl die interne Nomenklatur als auch die WinCC Nomenklatur. Als Trennzeichen wird ein Punkt verwendet.

Importziel

Variablenliste

Die Variablen werden in die zenon Variablenliste importiert. Beim Import wird überprüft, ob mit dem jeweiligen Namen schon eine Variable existiert. Wenn das der Fall ist, werden zenon spezifische Attribute beibehalten, d.h. es findet ein Merging zwischen den importierten Variablen und den vorhanden Variablen statt.

Datei

Die Variablen werden in die angegebene Datei (*.dbf) importiert. Diese Datei können Sie bearbeiten und dann in zenon importieren.

Hinweis: Achten Sie darauf, dass beim Erstellen der DBF-Datei Informationen verloren gehen können auf Grund von beschränkten Feldgrößen.

Bestätigen Sie den Dialog mit Ausführen.

info Info

Die Einstellungen, die Sie in diesem Dialog machen, werden gespeichert. Beim nächsten Aufruf des Dialogs werden Ihre zuletzt getätigten Einstellungen wieder angezeigt.


Stationen auswählen

Handbuch -> Import - Export -> Variablen -> S7-Projekt -> Stationen auswählen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Selektieren Sie die gewünschten Stationen.

Der Dialog zeigt Ihnen alle verfügbaren Stationen der selektierten Projektdatei. Mithilfe der Schaltfläche Alle auswählen selektieren Sie alle verfügbaren Stationen auf einmal. Über die Schaltfläche Einstellungen gelangen Sie zu einem Filterdialog. Wenn Sie für eine Station einen Filter definieren, wird das durch ein Filter-Symbol auf der jeweiligen Station angezeigt.

Wenn Sie die gewünschten Stationen selektiert und die entsprechenden Einstellungen vorgenommen haben, klicken Sie auf OK.

Es werden alle den Einstellungen entsprechenden Variablen im nächsten Dialog angezeigt. Dieser Vorgang kann je nach Umfang des Projekts einige Zeit in Anspruch nehmen. Mithilfe der Schaltfläche Abbrechen können Sie entweder den gesamten Import abbrechen oder den aktuellen Bereich überspringen. Wenn Sie den aktuellen Bereich überspringen, geht der Import mit dem nächsten Bereich weiter. Die Variablen, die im übersprungenen Bereich vorhanden sind, werden nicht importiert.

Noch in diesem Kapitel

Einstellungen der Stationen


Einstellungen der Stationen

Handbuch -> Import - Export -> Variablen -> S7-Projekt -> Stationen auswählen -> Einstellungen der Stationen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Dialog können Sie Filter setzen und diverse Einstellungen vornehmen.

Folgende Einstellungen stehen Ihnen zur Verfügung.

Parameter

Beschreibung

Einstellungen

Netzadresse

Gibt die Netzadresse an und beeinflusst den Stationsnamen.

Hinweis: Beginnt immer bei 0.

Vorfilter

Aktiv (ergibt keinen Vergleich der zu importierenden und existierenden Variablen zum Löschen!)

Aktivieren Sie diese Einstellung, um die Filteroptionen freizuschalten.

Datebausteine

Selektieren Sie die Datenbausteine, aus denen Sie Variablen importieren möchten. Mithilfe der Tasten Strg und UMSCHALT können Sie mehrere Datenbausteine selektieren.

Datentypen

Selektieren Sie die Datentypen, auf den die Variablen basieren, die Sie importieren möchten. Mithilfe der Tasten Strg und UMSCHALT können Sie mehrere Datentypen selektieren.

Bereiche

Selektieren Sie den gewünschten Bereich. Zur Auswahl stehen:

  • Alle Bereiche
  • Nur Bausteine
  • Keine Bausteine

Bearbeitungsoptionen

Nur nicht vorhandene Variablen anbieten

Es werden nur die Variablen zum Import angeboten, die noch nicht in zenon existieren.

Nach zu löschenden Variablen suchen

Nach der Variablenauswahl werden alle Variablen, die nicht im S7-Projekt vorhanden sind angezeigt. Sie können aus dem zenon Projekt gelöscht werden.

Nicht aktiv, wenn Aktiv (ergibt keinen Vergleich der zu importierenden und existierenden Variablen zum Löschen!) aktiviert ist.

Präfix

Kein

Die importierten Variablen bekommen keine Präfix vor den Namen.

Netzadresse

Die importierten Namen bekommen die Netzadresse gefolgt von einem Punkt als Präfix vor den Namen.

Freie Eingabe

Geben Sie den gewünschten Präfix im Eingabefeld an. Beim Import der Variablen wird der eingegebene Präfix getrennt mit einem Punkt vor den Variablennamen gesetzt.

Hinweis: Achten Sie darauf, dass Sie beim nochmaligen Import den gleichen Präfix verwenden, da ansonsten die Variablen doppelt angelegt werden.

Nachdem Sie die gewünschten Einstellungen vorgenommen haben, bestätigen Sie den Dialog mit OK.


Variablen auswählen

Handbuch -> Import - Export -> Variablen -> S7-Projekt -> Variablen auswählen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alle für den Import vorhandenen Variablen werden Ihnen angezeigt. Es stehen für jede Variable folgende Informationen zur Verfügung: Variablenname, Kommentar, Datenbereich, Datentyp, Datenbaustein, Offset, Bit, Attribute und Adressinformation. Sie können die Liste für jede Spalte aufsteigend oder absteigend sortieren und gegebenenfalls einen Filtertext eingeben. Die Spalte Adressinformation enthält die kumulierten Informationen der jeweiligen Variable.

In der Baumansicht können Sie entweder das ganze Projekt oder die einzelnen Stationen selektieren. Je nach Auswahl werden die entsprechenden Variablen angezeigt. Selektieren Sie die gewünschten Variablen und klicken Sie auf die Schaltfläche Hinzufügen, um die Variablen zum Import hinzuzufügen. Die selektierten Variablen erscheinen im unteren Bereich des Dialogs. Um Variablen von dort zu entfernen selektieren Sie die gewünschten Variablen und klicken Sie auf die Schaltfläche Lösen.

info Info

Mithilfe von Strg bzw. Umschalt können Sie mehrere Einträge gleichzeitig selektieren.

  • Bei gedrückter Strg-Taste können mehrere einzelne Einträge ausgewählt werden.
  • Wenn Sie Umschalt gedrückt halten und zwei Einträge anklicken, werden alle Einträge ausgewählt, die sich zwischen den beiden Einträgen befinden.
  • Bei gleichzeitigem Drücken und Halten von Strg und Umschalt und Auswählen von zwei Einträgen,werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.

Wenn Sie alle gewünschten Variablen hinzugefügt haben, bestätigen Sie den Dialog mit OK. Die Variablen werden in zenon angelegt.


dBase Import und Export

Handbuch -> Import - Export -> Variablen -> dBase Import und Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Daten können nach dBase exportiert und aus dBase importiert werden.

Import DBF-Datei

Um den Import zu starten:

  1. führen Sie einen Rechtsklick auf die Variablenliste aus
  2. wählen Sie im Dropdownmenü von Erweiterter Export/Import ... den Befehl dBase importieren
  3. folgen Sie dem Importassistenten

Das Format der Datei ist im Kapitel Dateiaufbau beschrieben.

info Info

Beachten Sie:

  • Treiberobjekttyp und Datentyp müssen in der DBF-Datei an den Zieltreiber angepasst werden, damit Variablen importiert werden.
  • dBase unterstützt beim Import keine Strukturen oder Arrays (komplexe Variablen).

Export DBF-Datei

Um den Export zu starten:

  1. führen Sie einen Rechtsklick auf die Variablenliste aus
  2. wählen Sie im Dropdownmenü von Erweiterter Export/Import ... den Befehl dBase exportieren
  3. folgen Sie dem Exportassistenten

attention Achtung

DBF-Dateien:

  • müssen in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • dürfen im Pfadnamen keinen Punkt (.) enthalten.
    Z.B. ist der Pfad C:\users\Max.Mustermann\test.dbf ungültig.
    Gültig wäre: C:\users\MaxMustermann\test.dbf
  • müssen nahe am Stammverzeichnis (Root) abgelegt werden, um die eventuelle Beschränkungen für Dateinamenlänge inklusive Pfad zu erfüllen: maximal 255 Zeichen

Das Format der Datei ist im Kapitel Dateiaufbau beschrieben.

info Info

dBase unterstützt beim Export keine Strukturen oder Arrays (komplexe Variablen).

Noch in diesem Kapitel

dBaseIV Variablendatei


dBaseIV Variablendatei

Handbuch -> Import - Export -> Variablen -> dBase Import und Export -> dBaseIV Variablendatei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Variablenimport und -export muss die dBaseIV-Datei folgende Struktur und Inhalte besitzen.

attention Achtung

dBase unterstützt keine Strukturen oder Arrays (komplexe Variablen).

DBF-Dateien müssen:

  • in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • nahe am Stammverzeichnis (Root) abgelegt werden

Struktur

Bezeichnung | Typ | Feldgröße | Bemerkung
KANALNAME | Char | 128 | Variablenname. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_R | C | 128 | Ursprünglicher Name einer Variablen, der durch den Eintrag unter KANALNAME ersetzt werden soll (Feld/Spalte muss manuell angelegt werden). Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_D | Log | 1 | Variable wird bei Eintrag 1 gelöscht (Feld/Spalte muss manuell angelegt werden).
TAGNR | C | 128 | Kennung. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
EINHEIT | C | 11 | Technische Maßeinheit
DATENART | C | 3 | Datenart (z.B. Bit, Byte, Wort, ...) entspricht dem Datentyp.
KANALTYP | C | 3 | Speicherbereich in der SPS (z.B. Merkerbereich, Datenbereich, ...) entspricht Treiber-Objekttyp.
HWKANAL | Num | 3 | Bus-Adresse
BAUSTEIN | N | 3 | Datenbaustein-Adresse (nur bei Variablen aus den Datenbereich der SPS)
ADRESSE | N | 5 | Offset
BITADR | N | 2 | Für Bit-Variablen: Bitadresse Für Byte-Variablen: 0=niederwertig, 8=höherwertig Für String-Variablen: Stringlänge (max. 63 Zeichen)
ARRAYSIZE | N | 16 | Anzahl der Variablen im Array für Index-Variablen ACHTUNG: Nur die erste Variable steht voll zur Verfügung. Alle folgenden sind nur über VBA oder den Rezeptgruppen Manager zugänglich
LES_SCHR | L | 1 | Lese-Schreib-Berechtigung 0: Sollwert setzen ist nicht erlaubt 1: Sollwert setzen ist erlaubt
MIT_ZEIT | L | 1 | Zeitstempelung in zenon (nur wenn vom Treiber unterstützt)
OBJEKT | N | 2 | Treiberspezifische ID-Nummer des Primitivobjekts setzt sich zusammen aus KANALTYP und DATENART
SIGMIN | Float | 16 | Rohwertsignal minimal (Signalauflösung)
SIGMAX | F | 16 | Rohwertsignal maximal (Signalauflösung)
ANZMIN | F | 16 | technischer Wert minimal (Messbereich)
ANZMAX | F | 16 | technischer Wert maximal (Messbereich)
ANZKOMMA | N | 1 | Anzahl der Nachkommastellen für die Darstellung der Werte (Messbereich)
UPDATERATE | F | 19 | Updaterate für Mathematikvariablen (in sec, eine Dezimalstelle möglich) bei allen anderen Variablen nicht verwendet
MEMTIEFE | N | 7 | Nur aus Kompatibilitätsgründen vorhanden
HDRATE | F | 19 | HD-Updaterate für hist. Werte (in sec, eine Dezimalstelle möglich)
HDTIEFE | N | 7 | HD-Eintragtiefe für hist. Werte (Anzahl)
NACHSORT | L | 1 | HD-Werte als nachsortierte Werte
DRRATE | F | 19 | Aktualisierung an die Ausgabe (für zenon DDE-Server, in sec, eine Kommastelle möglich)
HYST_PLUS | F | 16 | Positive Hysterese; ausgehend vom Messbereich
HYST_MINUS | F | 16 | Negative Hyterese; ausgehend vom Messbereich
PRIOR | N | 16 | Priorität der Variable
REAMATRIZE | C | 32 | Name der zugeordnete Reaktionsmatrix
ERSATZWERT | F | 16 | Ersatzwert; ausgehend vom Messbereich
SOLLMIN | F | 16 | Sollwertgrenze Minimum; ausgehend vom Messbereich
SOLLMAX | F | 16 | Sollwertgrenze Maximum; ausgehend vom Messbereich
VOMSTANDBY | L | 1 | Variable vom Standby Server anfordern; der Wert der Variable wird im redundanten Netzwerkbetrieb nicht vom Server sondern vom Standby-Server angefordert
RESOURCE | C | 128 | Betriebsmittelkennung. Freier String für Export und Anzeige in Listen. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
ADJWVBA | L | 1 | Nichtlineare Wertanpassung: 0: Nichtlineare Wertanpassung wird verwendet 1: Nichtlineare Wertanpassung wird nicht verwendet
ADJZENON | C | 128 | Verknüpftes VBA-Makro zum Lesen der Variablenwerte für die nichtlineare Wertanpassung.
ADJWVBA | C | 128 | Verknüpftes VBA-Makro zum Schreiben der Variablenwerte für die nichtlineare Wertanpassung.
ZWREMA | N | 16 | Verknüpfte Zählwert-Rema.
MAXGRAD | N | 16 | Maximaler Gradient für die Zählwert-Rema.

attention Achtung

Beim Import müssen Treiberobjekttyp und Datentyp in der DBF-Datei an den Zieltreiber angepasst werden, damit Variablen importiert werden.

Grenzwertdefinition

Grenzwertdefinition für Grenzwert 1 bis 4, bzw. Zustand 1 bis 4:

Bezeichnung | Typ | Feldgröße | Bemerkung
AKTIV1 | L | 1 | Grenzwert aktiv (pro Grenzwert vorhanden)
GRENZWERT1 | F | 20 | technischer Wert oder ID-Nummer der verknüpften Variable für einen dynamischen Grenzwert (siehe VARIABLEx) (wenn unter VARIABLEx 1 steht und hier -1, wird die bestehende Variablenzuordnung nicht überschrieben)
SCHWWERT1 | F | 16 | Schwellwert für den Grenzwert
HYSTERESE1 | F | 14 | wird nicht verwendet
BLINKEN1 | L | 1 | Blinkattribut setzen
BTB1 | L | 1 | Protokollierung in CEL
ALARM1 | L | 1 | Alarm
DRUCKEN1 | L | 1 | Druckerausgabe (bei CEL oder Alarm)
QUITTIER1 | L | 1 | quittierpflichtig
LOESCHE1 | L | 1 | löschpflichtig
VARIABLE1 | L | 1 | dyn. Grenzwertverknüpfung der Grenzwert wird nicht durch einen absoluten Wert (siehe Feld GRENZWERTx) festgelegt.
FUNC1 | L | 1 | Funktionsverknüpfung
ASK_FUNC1 | L | 1 | Ausführung über die Alarmverwaltung
FUNC_NR1 | N | 10 | ID-Nummer der verknüpften Funktions (steht hier -1, so wird die bestehende Funktion beim Import nicht überschrieben)
A_GRUPPE1 | N | 10 | Alarm/Ereignis-Gruppe
A_KLASSE1 | N | 10 | Alarm/Ereignis-Klasse
MIN_MAX1 | C | 3 | Minimum, Maximum
FARBE1 | N | 10 | Farbe als Windowskodierung
GRENZTXT1 | C | 66 | Grenzwerttext
A_DELAY1 | N | 10 | Zeitverzögerung
INVISIBLE1 | L | 1 | Unsichtbar

Bezeichnungen in der Spalte Bemerkung beziehen sich auf die in den Dialogboxen zur Definition von Variablen verwendeten Begriffe. Bei Unklarheiten, siehe Kapitel Variablendefinition.


Verriegelungen

Handbuch -> Import - Export -> Verriegelungen

Die Export-Datei für die Verriegelungen gliedert sich in:

  • Verriegelungenliste

Beim Import/Export der Verriegelungen werden die betroffenen Variablen nicht automatisch mit exportiert/importiert. Es sollte gegebenen Falls darauf geachtet werden, dass vorher ein Variablen- Import/Export durchgeführt wird.

Noch in diesem Kapitel

Befehlsgruppen


Befehlsgruppen

Handbuch -> Import - Export -> Verriegelungen -> Befehlsgruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Export

Die Befehlsgruppen können selektiv oder alle gemeinsame exportiert werden.

info Info

Die Befehlsgruppen und allgemeinen Verriegelungen werden nicht gemeinsam exportiert!

Import

Die Beziehung zwischen bestehenden Befehlsgruppen und zu importierender wird über den Name hergestellt. Wenn bereits eine Befehlsgruppe mit dem Namen besteht, wird diese aktualisiert.

Wenn bereits eine allgemeine Verriegelung mit dem Namen besteht, wird eine neue Befehlsgruppe mit neuen Namen angelegt.

Nicht existente Befehlsgruppen werden angelegt.

In der Importdatei vorhandene allgemeine Verriegelungen werden nicht importiert.

Absolute Variablenbezüge werden über den Namen hergestellt.

Neu angelegte Befehlsgruppen bekommen eine eindeutige noch nie verwendete ID zugewiesen


Zeitsteuerung

Handbuch -> Import - Export -> Zeitsteuerung

Die Export-Datei für die Zeitsteuerung gliedert sich in:

Zeitfunktionenliste

Funktionenliste

Mit den Zeitfunktionen werden also auch die darin enthaltenen Funktionen exportiert. Die Zeitfunktionen werden automatisch importiert. Die Funktionen müssen vorher separat aus dieser Datei importiert werden.


Zuweisungen

Handbuch -> Import - Export -> Zuweisungen

Die Export-Datei für die Zuweisungen gliedert sich in:

Zuweisungenliste

Beim Import/Export der Zuweisungen werden die betroffenen Variablen nicht automatisch mit exportiert/importiert. Es sollte gegebenen Falls darauf geachtet werden, dass vorher ein Variablenimport/-export durchgeführt wird.


Fehlermeldungen

Handbuch -> Import - Export -> Fehlermeldungen

Fehler beim Import oder Export werden im Ausgabefenster angezeigt.

Fehlermeldung | Mögliche Ursache und Lösung
Fehler: "Die Datei kann nicht geöffnet werden, weil sie von einem anderen Benutzer geöffnet ist." | Datei ist für Bearbeitung gesperrt. Benutzer muss Datei frei geben, bevor der Import/Export erneut durchgeführt wird.
Fehler: "Datenbank kann nicht erzeugt oder geöffnet werden." | Eventuell fehlen die rechte zur Erzeugung der Datei oder die datei ist korrupt.
Fehler: "Variable ist ungültig und wurde nicht gespeichert." | Variable ist ungültig. Alle Parameter der Variablen überprüfen.
Fehler: "Variable konnte nicht in die Datenbank aufgenommen werden." | Fehler bei der Aufnahme in die Datenbank.
Fehler: "Variable enthält eine ungültige Hardware-Adresse." | Eine Hardware-Adresse der Variable ist nicht korrekt. Adresse vor dem Neuimport korrigieren.
Fehler: "Treiber stellt kein Objekt zum Im-/Export bereit, Im-/Export wird nicht ausgeführt." | Der gewählte Treiber verfügt über keine Objekte, die importiert/exportiert werden können.
Fehler: "Variable kann nicht gelöscht werden, weil sie nicht vorhanden ist." | Eine zum Löschen ausgewählte Variable existiert nicht mehr.
Warnung: "Variable mit dem neuen Namen existiert bereits, Import wird mit altem Namen durchgeführt." | Eine Variable, die beim Import umbenannt werden soll, wird nicht umbenannt, da bereits eine Variable mit gleichem Namen vorhanden ist. Sie wird mit dem ursprünglichen Namen importiert.
Warnung: "Variable kann nicht umbenannt werden, und wird neu angelegt." | Eine Variable, die umbenannt werden soll, kann nicht umbenannt werden. Sie wird

Fehler beim XML-Import werden in einem eigenen Dialog behandelt und gelöst.


Industrial Maintenance Manager (IMM)

Handbuch -> Industrial Maintenance Manager (IMM)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Industrial Maintenance Manager (IMM) dient zur Pflege von Maschinen- und Wartungsdaten. Serviceintervalle können bequem geplant und verwaltet werden. Auf einen Blick ist feststellbar, welche Geräte, Anlagen, Maschinen usw. heute/in dieser Woche/nächstes Monat usw. gewartet werden müssen. Ebenso wird mitprotokolliert, welche Wartungsarbeiten in der Vergangenheit durchgeführt worden sind.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig.

Noch in diesem Kapitel

Funktionalitäten

Einschränkungen

Vorarbeiten

Bild vom Typ IMM anlegen

Wartungsarbeit

Dateneingabe

Integration in den Prozess

Bedienen während der Runtime

Funktionen


Funktionalitäten

Handbuch -> Industrial Maintenance Manager (IMM) -> Funktionalitäten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Geräte können kopiert und eingefügt werden; dem Gerätenamen wird eine _#fortlaufendeNummer angefügt.
  • Die Listenansicht kann im Bildfilter angepasst werden. Spaltenauswahl, Spaltenbreite, Spaltenname und deren Reihenfolge können modifiziert werden.
  • Jede Listenansicht kann man sich als html via Stylesheet anzeigen und drucken lassen.
  • Das Anlagenkennzeichen kann nur über das Kontextmenu im Baum angelegt werden.
  • Mehrhierarchische Anlagenkennzeichen
  • Geräte können über das Kontextmenu im Baum oder der Liste angelegt werden, vorausgesetzt eine Anlage wurde im Baum selektiert. Diese Anlage wird dann automatisch als Anlagenkennzeichen im Gerät eingefügt.
  • Per Klick auf den Spaltenkopf werden die Elemente alphabethisch sortiert.
  • Mehrprojektfähig
  • Server-Client
  • Das Löschen von Geräten unterliegt einem Benutzerlevel, welches zwei Arten zu Löschen vorsieht. Einmal ein Löschen in dem Sinne, dass die Daten in der Datenbank erhalten bleiben und somit die Historieneinträge nicht verloren gehen. Dabei wird in der Datenbank das Flag ACTIVE auf 0 gesetzt. Zum anderen ein endgültiges Löschen: alle Daten aus der Datenbank inkl. der Wartungsarbeiten und der Historie werden dabei gelöscht.
  • Die Checkboxen in der Baumansicht bei den Anlagenkennzeichungen (AKZ) sind ein Filter. Wenn gesetzt, werden nur die Geräte, Historieneinträge und Wartungen angezeigt, die zu dieser AKZ gehören.


Einschränkungen

Handbuch -> Industrial Maintenance Manager (IMM) -> Einschränkungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Modul speichert die Daten in einer Microsoft SQL Server Datenbank (Alle SQL Server Versionen ab SQL Server 2000 sind möglich). Der MS SQL Server ist nicht im Lieferumfang von zenon enthalten. Sie können jedoch die SQL Server Express Edition, die mit dem zenon Editor mitinstalliert wird, nutzen.

Andere Datenbankserver wie z.B. Oracle werden nicht unterstützt.


Vorarbeiten

Handbuch -> Industrial Maintenance Manager (IMM) -> Vorarbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Datenbank

Projektierung


Datenbank

Handbuch -> Industrial Maintenance Manager (IMM) -> Vorarbeiten -> Datenbank

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Erstellen einer eigenen Datenbank:

Starten Sie eine neue Instanz der Eingabeaufforderung (Cmd.exe).

Starten des Dienstprogrammes osql.exe.

osql.exe -E -S Computername / Instanzname

Anweisungen für das erzeugen einer Datenbank

1> CREATE DATABASE Datenbankname

2> GO

Datenbankname

beliebiger Name der Datenbank. zB: Maintenance

Mit exit beenden Sie das Dienstprogramm osql.exe.


Projektierung

Handbuch -> Industrial Maintenance Manager (IMM) -> Vorarbeiten -> Projektierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es werden 4 Tabellen in der Datenbank erzeugt. Die Namen der Tabellen sind frei wählbar.

attention Achtung

Tabellenname: maximal 128 Zeichen,
Das erste Zeichen muss eines der folgenden Zeichen sein: a-z, A-Z, Unterstrich-Zeichen
Im Anschluss daran können die folgenden Zeichen verwendet werden: a-z, A-Z, Dezimalzahlen, Unterstrich-Zeichen

Wartungsprotokoll Datenbank:

Stammdaten:

Wartungsarbeit:

Historie:

Dokumente:

Datenbankverbindung

In den Projekteigenschaften unter „Industrial Maintenance Managers“ kann im Feld neben der Beschriftung „Datenbank:“ der ODBC String manuell bearbeitet werden. Wenn Sie den Button der Projekteigenschaft aktivieren wird folgende Dialogbox geöffnet:

Neu...

Klicken Sie auf diese Schaltfläche, um eine neue Dateidatenquelle hinzuzufügen.

Wählen Sie im Dialogfeld Neue Datenquelle erstellen den Treiber SQL Server und klicken Sie auf Weiter , um den Namen oder den Speicherort des neuen Datei-DSN anzugeben

Klicken Sie erneut auf Weiter um eine Zusammenfassung der neuen Informationen anzuzeigen.

Klicken Sie auf Fertig stellen um das treiberspezifische Setup-Dialogfeld anzuzeigen.

Wenn Sie einen Servernamen aus der Liste auswählen, sind keine weiteren Konfigurationseinstellungen erforderlich.

Klicken Sie erneut auf Weiter .

Klicken Sie erneut auf Weiter .

Nun können Sie die früher erzeugte Datenbank auswählen.

Klicken Sie auf Fertig stellen .

Sie können nun die projektierte Verbindung testen.


Bild vom Typ IMM anlegen

Handbuch -> Industrial Maintenance Manager (IMM) -> Bild vom Typ IMM anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ IMM zu erstellen:

  1. legen Sie ein neues Bild an
  2. wählen Sie als Bildtyp aus der Dropdownliste Industrial Maintenance Manager (IMM)
  3. wählen Sie im Menü Kontrollelemente den Befehl Vorlage einfügen
  4. die Standard-Elemente werden eingefügt
  5. wählen Sie nach Bedarf zusätzliche Elemente aus und fügen Sie diese am gewünschten Platz im Bild ein
  6. legen Sie eine Bildumschaltfunktion an, um das Bild zur Runtime aufrufen zu können

Parameter | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Liste | Liste der Vorgänge, die zur Runtime angezeigt werden.
Anlagen-Kennzeichen neu | Erstellt ein neues Anlagen-Kennzeichen.
Anlagen-Kennzeichen löschen | Löscht ausgewähltes Anlagenkennzeichen.
Gerät neu | Fügt ein neues Gerät ein.
Gerät bearbeiten | Ermöglicht die Bearbeitung des ausgewählten Geräts.
Gerät inaktiv | Schaltet Gerät auf inaktiv.
Gerät löschen | Löscht Gerät.
Gerätetausch | Führt Gerätetausch durch.
Zählertausch | Führt Zählertausch durch.
Kopieren | Kopiert ausgewähltes Element in Zwischenablage.
Einfügen | Fügt ausgewähltes Element aus Zwischenablage ein.
Wartung bearbeiten | Ermöglicht das Bearbeiten einer Wartung.
Wartung durchführen | Schaltet auf Wartung durchführen.
Reparatur durchführen | Schaltet auf Reparatur durchführen.
Liste drucken | Druckt Liste aus.
Details drucken | Druckt Details.
Filter | Wendet Filter an.
Aktualisieren | Aktualisiert Ansicht.
Filterprofile | Verwaltung der filterprofile.
Profilauswahl | Wahl eines Filters aus Dropddownliste.
Speichern | Speichert gewählten Filter.
Löschen | Löscht gewählten Filter.

Noch in diesem Kapitel

Ansicht zur Runtime


Ansicht zur Runtime

Handbuch -> Industrial Maintenance Manager (IMM) -> Bild vom Typ IMM anlegen -> Ansicht zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn das Bild vom Typ IMM zur Runtime aufgeschaltet wird, wird es in zwei Bereiche aufgeteilt dargestellt:.

Noch in diesem Kapitel

Linke Seite: Tree

Rechte Seite: Liste


Linke Seite: Tree

Handbuch -> Industrial Maintenance Manager (IMM) -> Bild vom Typ IMM anlegen -> Ansicht zur Runtime -> Linke Seite: Tree

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Stammdaten | Als Unterknoten werden die Anlagen-Kennzeichnen verwendet. Diese Unterknoten haben eine Checkbox um die Auswahl einzugrenzen. Diese Auswahl bestimmt die Ausgabe in der Liste. Es werden bei den Stammdaten, den Wartungsarbeiten und in der Historie nur mehr die Daten angezeigt, die zu den ausgewählten Anlagen gehören.
Historie | Hier werden die Historiendaten nach Zeiträumen gefiltert. Unter freier Filter kommt ein Dialog, zur Auswahl eines beliebigen Zeitraumes.
Wartungsarbeiten | Hier werden die anstehenden Wartungsarbeiten nach Zeiträumen gefiltert. Unter freier Filter kommt ein Dialog, zur Auswahl eines beliebigen Zeitraumes.


Rechte Seite: Liste

Handbuch -> Industrial Maintenance Manager (IMM) -> Bild vom Typ IMM anlegen -> Ansicht zur Runtime -> Rechte Seite: Liste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier wird die Auswahl in der Baumansicht in Listenform dargestellt. Die Liste kann nach jeder Spalte auf oder absteigend sortiert werden.

Zusätzlich gibt es in dieser Ansicht ein Kontextmenü, das je nach Selektion in der Baumansicht andere Funktionen zur Verfügung stellt.

Auswahl Stammdaten:

Befehl

Beschreibung

Gerät neu

Unter Gerät neu können neue Stammdaten angelegt werden. Die Eingabe erfolgt über einen Dialog mit drei Eigenschaftsblättern. Auf dem ersten Blatt werden die Daten zu dem Gerät eingegeben. Auf dem Blatt Wartungsarbeiten können zu dem Gerät eine beliebige Anzahl an Wartungsarbeiten angelegt werden. Als Übersicht werden die Titel der Wartungsarbeiten auf diesem Blatt in einer Liste dargestellt. Auf dem letzten Blatt kann dem Gerät noch eine beliebige Anzahl an Dokumenten zugeordnet werden. Diese werden wie die Wartungsarbeiten der Übersicht halber in einer Liste dargestellt. Durch Doppelklick auf ein Dokument wird das jeweilige Dokument angezeigt, sofern das zugehörige Programm installiert ist.

Gerät bearbeiten

Wie bei Gerät neu, nur dass hier die Felder mit den bereits vorhandenen Daten aufgefüllt werden. Es muss dazu ein Gerät selektiert sein.

Gerätetausch

Hier werden die Variablen für Schaltspiel- und Betriebsstundenzähler verändert! Auf diesen beruht die Berechnung für die Fälligkeit der Wartung. Wird ein Gerätetausch gemacht, erfolgt ein Historieneintrag. Weiters wird das Wartungsintervall zurückgesetzt und die neuen Variablenwerte als Ausgangswerte für die Wartungsberechnung verwendet.

Die Gerätedaten bleiben gleich, nur die verknüpften Variablen ändern sich. Diese sind über einen Dialog einzugeben. Falls die Variable nicht existiert, wird eine Warnung ausgegeben, dass momentan keine gültige Variable mit dem Gerät verknüpft ist.

Zählertausch

Wird ein Zähler getauscht, bleibt die Variable dieselbe, es wird hier der Zählerstand (Variablenwert) verändert. Wird ein Zählertausch gemacht, erfolgt ein Historieneintrag. Wahlweise kann hier das Wartungsintervall zurückgesetzt werden.

Es kann ein neuer Startwert für das ersetzte Gerät eingetragen werden

Gerät löschen

Das selektierte Gerät kann gelöscht werden. Es werden alle zugehörigen Daten (Wartungsarbeiten, Historiendaten und Dokumente) gelöscht. Als Sicherheit wird noch einmal abgefragt, ob die Daten wirklich gelöscht werden sollen.

Hinweis: Einen Zeilenumbruch erzeugen Sie mit der Tastenkombination Strg+Eingabe.

Folgende Zugriffsmöglichkeiten auf Dateien werden unterstützt.

Lokale Laufwerke | Lokale Festplatte
UNC-Pfad | z. B. \\Servername\Freigabename
Verbundene Laufwerke | Freigebene Festplatte eines Netzwerkcomputers

attention Achtung

Voraussetzung: Um die Dokumente anzeigen zu können, muss ein entsprechender Viewer installiert sein. Z.B. Adobe Acrobat Reader für .pdf Dateien.

Gerätetausch

Zählertausch

Auswahl Wartungsarbeiten

Durch Doppelklick auf eine Wartungsarbeit, werden die Daten zu dieser Wartungsarbeit angezeigt. Die Daten können aber nicht verändert werden.

Reperatur durchführen

Wird eine Reparatur durchgeführt, erfolgt erstens ein Historieneintrag und weiters wird die Wartungsarbeit als nicht! erledigt für dieses Intervall angesehen und bleibt somit in der Fälligskeitsliste. Es erfolgt ein Historieneintrag.

So wie Wartung durchführen, nur dass eine extra Abfrage kommt, ob die Zähler aktualisiert werden sollen oder nicht.

Liste drucken

Die dargestellte Liste wir eins-zu-eins in eine XML-Datei geschrieben und mittels Stylesheet in einem html-Browser dargestellt. Diese HTML-Datei kann nun gespeichert oder direkt ausgedruckt werden.

Details drucken

Die Daten zu der selektierten Wartungsarbeit werden ausgegeben.

Wartung bearbeiten

Hier können die Daten zu der selektierten Wartungsarbeit bearbeitet werden.

Wartung durchführen

Wird eine Wartung durchgeführt werden die Zähler aktualisiert und ein Historieneintrag generiert. Außerdem wird die Wartungsarbeit als erledigt für dieses Intervall angesehen und somit aus der Fälligkeitsliste entfernt.

Unter Dokumente werden die verknüpften Dateien in einer Liste angezeigt. Mittels Doppelklick auf eine Datei, wird diese geöffnet, sofern ein passendes Programm installiert ist.

Auswahl Historie

Hier gibt es nur einen Menüeintrag und zwar Liste drucken . Gleiche Vorgehensweise wie bei Wartungsarbeit - Liste drucken .


Wartungsarbeit

Handbuch -> Industrial Maintenance Manager (IMM) -> Wartungsarbeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Berechnung einer anstehenden Wartung ist das Kernstück des IMM. Eine Wartungsarbeit kann drei verschieden Wartungsintervalle haben:

- einen Zeitraum in Tagen

- einen Betriebsstundenzähler oder

- einen Schaltspielzähler.

Anhand dieser Intervalle wird die Fälligkeit der Wartungen berechnet.

Kommt eine Wartung in den Warnbereich, erscheint diese in der Liste für anstehende Wartungen mit dem Vermerk, dass die Warnstufe erreicht ist. Wird das Wartungsintervall erreicht, wird die Wartung auf fällig gesetzt und ist auch in der Liste für die Wartungen zu sehen.

Die Funktion Wartungen ermitteln

Mit der Funktion Wartungen ermitteln werden aus dem IMM die Liste aller anstehenden Wartungen im ausgewählten Zeitraum geholt. Diese anstehenden Wartungen werden dann zur Bestimmung der projektierten anlagenspezifischen Statuswerte verwendet.

Dabei werden auf die jeweiligen Statusvariablen numerische Sollwerte in der Höhe der Gesamtanzahl der anstehenden Wartungen abgesetzt, die sich in Anlagen befinden, die dem zugehörigen Filterkriterium entsprechen.

Wenn Sie eine neue Funktion Wartungen ermitteln im Editor anlegen, erscheint der folgende Konfigurationsdialog:

Zeitraum | Hier wird der Zeitraum ausgewählt, in welchem die anstehenden Wartungen ermittelt werden (siehe IMM)

Noch in diesem Kapitel

Zeitraum

Betriebsstunden- und Schaltspielzähler


Zeitraum

Handbuch -> Industrial Maintenance Manager (IMM) -> Wartungsarbeit -> Zeitraum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Wartungsarbeiten-Daten Eingabe kann ein Zeitraumintervall in Tagen eingegeben werden. Zusätzlich kann noch eine Vorwarndauer angegeben werden, was bedeutet: so viele Tage vor Ablauf des Zeitraumintervalls soll die Wartungsarbeit als anstehende Wartungsarbeit als Fälligkeit Warnung gewertet werden. (Meldung 'Wartung in xx Tagen fällig'.)

Wird der Zeitraum oder Zählerstand des Wartungsintervalles erreicht, wird die Wartung mit dem Text 'Wartungsintervall überschritten' eingetragen.

Das Datum der letzten durchgeführten Wartung wird bei jeder Durchführung aktualisiert. Bei Ersteingabe der Wartungsarbeit wird dieses Datum auf das Inbetriebnahmedatum gesetzt.


Betriebsstunden- und Schaltspielzähler

Handbuch -> Industrial Maintenance Manager (IMM) -> Wartungsarbeit -> Betriebsstunden- und Schaltspielzähler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Berechnung für eine anstehende Wartung wird die Differenz des alten Zählerstands bei der letzten Wartung und des aktuellen durch die Anzahl der verstrichenen Tage seit der letzten Wartung dividiert und zu dem alten hinzuaddiert. Ist dieser größer als erlaubt, wird die Wartung als anstehend ausgewertet und in der Liste angezeigt.

Sollte eine Variable einen geringeren Wert als bei der letzten Wartung haben, bekommt man eine Mitteilung.


Dateneingabe

Handbuch -> Industrial Maintenance Manager (IMM) -> Dateneingabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Variablenwerte werden nur dann in die Wartungsdaten eingepflegt, wenn die Wartungsarbeit neu angelegt wird. Ansonsten bleibt der alte Wert bestehen.

Wird ein Gerät angelegt und keine Variablen verknüpft, bleibt in der dazugehörigen Wartungsarbeit der Initialwert stehen. Auch bei dieser Konstellation werden die Variablenwerte in der Wartungsarbeit nicht überschrieben, wenn die Variablen nachträglich eingefügt werden. Es wird eine Mittelung ausgeworfen, falls die zur Wartungsberechnung benötigte Variable noch den Initialwert hat. Der Variablenwert lässt sich nur mehr durch Ausführen einer Reparatur, eines Gerätetausch oder einer Wartungsarbeit ändern.


Integration in den Prozess

Handbuch -> Industrial Maintenance Manager (IMM) -> Integration in den Prozess

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Mitteilung über Erfolg der Wartungsarbeit: Dem Gerät kann eine Integer-Variable zugeordnet werden. Weiters muss man in der Wartungsarbeit den Rückgabewert dieser Variable definieren. Ist keine Unterscheidung der einzelnen Wartungsarbeiten gewünscht, kann hier immer der selbe Wert eingegeben werden. Wird kein Wert angegeben, wird auch kein Wert in der Variable gesetzt.
  • Rückmeldung im Prozess: Zu jeder Wartungsarbeit kann eine Variable verknüpft werden, die den Status der Wartung beinhaltet. (Status Ok 0 und Status fällig 1)


Bedienen während der Runtime

Handbuch -> Industrial Maintenance Manager (IMM) -> Bedienen während der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Funktionen sind verfügbar:

  • Gerät neu : Ein neues Gerät anlegen. Es muss eine Anlagenkennzeichnung selektiert sein.
  • Gerät bearbeiten : Ein Gerät bearbeiten. Es muss ein Gerät selektiert sein.
  • Gerät inaktiv : Ein Gerät inaktiv schalten, d.h. Daten werden nicht mehr angezeigt, bleiben aber in der Datenbank erhalten.
  • Wartung durchführen : Es muss eine Wartung selektiert sein, um diese durchzuführen.
  • Aktualisieren : Es werden die Daten aus der Datenbank und die Variablen neu eingelesen.
  • Filter : Schaltet den Bildfilterdialog auf, um Spalten zu modifizieren.
  • Drucken : Generiert ein html mit der gewünschten Listenansicht. Es wird genau die aktuelle Ansicht wiedergegeben. Es können die Historie und die anstehenden Wartungen gedruckt werden.
  • Details drucken : Die Details zu einer Wartungsarbeit als html betrachten. Es muss hierzu natürlich eine Wartungsarbeit selektiert sein.


Funktionen

Handbuch -> Industrial Maintenance Manager (IMM) -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Bildumschaltung

Offene Wartungen ermitteln


Bildumschaltung

Handbuch -> Industrial Maintenance Manager (IMM) -> Funktionen -> Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erstellen einer Funktion zur Bildumschaltung auf ein Bild vom Typ IMM wird der Dialog zur Konfiguration der Spalteneinstellungen angeboten. Diese können getrennt konfiguriert werden für:

  • Stammdaten
  • Wartungsarbeiten
  • Historie

Noch in diesem Kapitel

Stammdaten

Wartungsarbeiten

Historie


Stammdaten

Handbuch -> Industrial Maintenance Manager (IMM) -> Funktionen -> Bildumschaltung -> Stammdaten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der anzuzeigenden Stammdaten:

  • aktueller Betriebsstunden-Zähler
  • aktueller Schaltspiel-Zähler
  • Anlagen-Kennzeichen
  • Bezeichnung
  • Fabrikat
  • Gerät
  • Inbetriebnahmedatum
  • Seriennummer
  • Status
  • Typ
  • Zeitraum seit letzter Wartung

Parameter | Beschreibung
Spaltentyp | Definition per Checkbox, welche Spalten zur Runtime angezeigt werden. Benennung nicht editierbar. Aktiv: Spalte wird zur Runtime angezeigt.
Beschreibung | Definiert Überschrift der jeweiligen Spalte. Kann auch sprachumschaltbar konfiguriert werden. Wert ist editierbar.
Breite | Definiert die Breite der Spalte in Pixel. Diese kann auch durch Ziehen mit der Maus in der Liste mit horizontaler Anzeige der Spaltennamen festgelegt werden. Wert ist editierbar.
Selektierten Eintrag nach oben verschieben | Verschiebt ausgewählte Spalte nach oben. Verschieben ist auch per Drag & Drop möglich.
Selektierten Eintrag nach unten verschieben | Verschiebt ausgewählte Spalte nach unten. Verschieben ist auch per Drag & Drop möglich.
Feld mit horizontaler Anzeige der Spaltennamen | Zeigt die in der Liste aktivierten Spalten an. Durch Ziehen mit dem Mauszeiger an den Spaltengrenzen kann die Spaltengröße definiert werden.


Wartungsarbeiten

Handbuch -> Industrial Maintenance Manager (IMM) -> Funktionen -> Bildumschaltung -> Wartungsarbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der anzuzeigenden Wartungsarbeiten:

  • aktueller Betriebsstunden-Zähler
  • aktueller Schaltspiel-Zähler
  • Anlagen-Kennzeichen
  • Bezeichnung
  • Fälligkeit
  • Gerät
  • Intern - Extern
  • Kommentar
  • Status
  • Wartungsarbeit
  • Zeitraum seit letzter Wartung

Parameter | Beschreibung
Spaltentyp | Definition per Checkbox, welche Spalten zur Runtime angezeigt werden. Benennung nicht editierbar. Aktiv: Spalte wird zur Runtime angezeigt.
Beschreibung | Definiert Überschrift der jeweiligen Spalte. Kann auch sprachumschaltbar konfiguriert werden. Wert ist editierbar.
Breite | Definiert die Breite der Spalte in Pixel. Diese kann auch durch Ziehen mit der Maus in der Liste mit horizontaler Anzeige der Spaltennamen festgelegt werden. Wert ist editierbar.
Selektierten Eintrag nach oben verschieben | Verschiebt ausgewählte Spalte nach oben. Verschieben ist auch per Drag & Drop möglich.
Selektierten Eintrag nach unten verschieben | Verschiebt ausgewählte Spalte nach unten. Verschieben ist auch per Drag & Drop möglich.
Feld mit horizontaler Anzeige der Spaltennamen | Zeigt die in der Liste aktivierten Spalten an. Durch Ziehen mit dem Mauszeiger an den Spaltengrenzen kann die Spaltengröße definiert werden.


Historie

Handbuch -> Industrial Maintenance Manager (IMM) -> Funktionen -> Bildumschaltung -> Historie

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der anzuzeigenden Historie:

  • Anlagen-Kennzeichen
  • Benutzer
  • Bezeichnung
  • Datum
  • Gerät
  • Kommentar
  • Wartungsarbeit
  • Zählerstand bei Wartung

Parameter | Beschreibung
Spaltentyp | Definition per Checkbox, welche Spalten zur Runtime angezeigt werden. Benennung nicht editierbar. Aktiv: Spalte wird zur Runtime angezeigt.
Beschreibung | Definiert Überschrift der jeweiligen Spalte. Kann auch sprachumschaltbar konfiguriert werden. Wert ist editierbar.
Breite | Definiert die Breite der Spalte in Pixel. Diese kann auch durch Ziehen mit der Maus in der Liste mit horizontaler Anzeige der Spaltennamen festgelegt werden. Wert ist editierbar.
Selektierten Eintrag nach oben verschieben | Verschiebt ausgewählte Spalte nach oben. Verschieben ist auch per Drag & Drop möglich.
Selektierten Eintrag nach unten verschieben | Verschiebt ausgewählte Spalte nach unten. Verschieben ist auch per Drag & Drop möglich.
Feld mit horizontaler Anzeige der Spaltennamen | Zeigt die in der Liste aktivierten Spalten an. Durch Ziehen mit dem Mauszeiger an den Spaltengrenzen kann die Spaltengröße definiert werden.


Offene Wartungen ermitteln

Handbuch -> Industrial Maintenance Manager (IMM) -> Funktionen -> Offene Wartungen ermitteln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Offene Wartungen ermitteln holt für einen ausgewählten Zeitraum die Liste aller anstehenden Wartungen aus dem IMM. Diese werden zur Bestimmung der projektierten anlagenspezifischen Statuswerte verwendet.

Bei Ausführung der Funktion:

  • werden auf die jeweiligen Statusvariablen numerische Sollwerte abgesetzt; diese Sollwerte entsprechen der Gesamtzahl der anstehenden Wartungen, die sich in Anlagen befinden und der Zuordnung von Anlagenkennzeichen zu Statusvariablen entsprechen
  • werden auch die am Gerät und an der Wartung projektierten Statusvariablen der Wartungs aktualisiert

Um die Funktion zu projektieren:

  • wählen Sie Funktion neu...
  • öffnen Sie den Zweig Anwendung
  • wählen Sie Offene Wartungen ermitteln
  • der Dialog zur Konfiguration der Funktion öffnet sich

Parameter | Beschreibung
Zeitraum | Zeitraum, für den die anstehenden Wartungen ermittelt werden. Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.
Anlagenkennzeichen | Eingabe der Anlagenkennzeichen, die einer Statusvariablen zugeordnet werden sollen. Form: Anlagekennzeichen werden durch Komma getrennt als Liste eingegeben. Anlagekennzeichen dürfen auch Wildcards beinhalten. (Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.)
Statusvariable | Numerische Variable, die bei Funktionsausführung die Anzahl offener Wartungen in den unter Anlagenkennzeichen angegebenen Anlagen als Sollwert erhält.
Zuordnungen | Liste der Zuordnungen von Anlagenkennzeichen zu Statusvariablen.
Hinzufügen | Fügt eine Zuordnungszeile hinzu.
Entfernen | Löscht die ausgewählte Zuordnung.

Example Beispiel

In Anlage1 stehen 2 Wartungen an, in Anlage2 steht 1 Wartung an.
Anlage1 und Anlage2 sind die einzigen Anlagen in diesem Beispiel.
Die Funktion ist analog dem oben dargestellten Screenshot projektiert.

Die Statusvariablen erhalten folgende Sollwerte:

Wartungen_heute_alle = 3

Wartungen_heute_alle2 = 3

Wartungen_heute_Anlage1_2 = 3

Wartungen_heute_Anlag1 = 2

Wartungen_heute_Anlag2 = 1

info Info

Die Funktion wird im Netzwerkbetrieb immer nur am Server ausgeführt.


Industrial Performance Analyzer

Handbuch -> Industrial Performance Analyzer

Der Industrial Performance Analyzer (IPA) dient dazu, Alarmdaten und damit einhergehende Standzeiten in verschiedenen Listenansichten anzuzeigen und auszuwerten. Der IPA greift auf eine SQL Datenbank zu, in der Alarme – entsprechende Projektierung vorausgesetzt – gespeichert werden.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig.

Durch die verschiedenen Filtereinstellungen bietet der IPA eine größtmögliche Flexibilität. Sie können z.B. auf einzelne Bereiche Ihrer Anlage filtern und sich so nur die Alarme anzeigen lassen, die in diesem Bereich aufgetreten sind. Der IPA ermöglicht auch das Aufspüren von Schwachstellen Ihrer Anlage. Dies ist vor allem bei der Inbetriebnahme hilfreich, um etwaigen Anlaufschwierigkeiten auf den Grund zu gehen und zu beheben. Im Zusammenspiel mit dem Modul Production & Facility Scheduler (PFS) ermöglicht der IPA Ihnen, pausenbereinigte Standzeiten anzuzeigen. Von den tatsächlichen Standzeiten werden die Pausenzeiten subtrahiert. Damit sehen Sie sozusagen die Nettostandzeit Ihrer Anlage. Außerdem kann der IPA Schichtzeiten und Schichtnamen aus dem PFS übernehmen. Dies erleichtert das Projektieren und spart Zeit. Außerdem müssen die Schichtzeiten und Schichtnamen nur an einer Stelle gewartet werden. Weiterhin ist sichergestellt, dass der PFS und der IPA dieselben Daten verwenden.

info Info

Der Industrial Performance Analyzer ist für den PC-Einsatz konzipiert und greift daher auf Maus und Tastatur als Eingabegeräte zu. Die vollständige Bedienbarkeit über einen Touchscreen ist nicht gegeben.

Noch in diesem Kapitel

Grundsätzliche Funktionsweise

Projektieren im Editor

Bedienung während der Runtime


Grundsätzliche Funktionsweise

Handbuch -> Industrial Performance Analyzer -> Grundsätzliche Funktionsweise

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alle Alarmdaten, die entsprechend projektiert wurden (siehe Variablen), werden in einer SQL Datenbank gespeichert. Unterstützt werden ODBC-fähige Datenbanken wie z.B. Oracle SQL Server, Microsoft SQL Server, Microsoft MSDE, MySQL Server etc. Diese können sowohl lokal als auch im Netzwerk zur Verfügung stehen.

In der Runtime werden die entsprechenden Alarmdaten in einen Puffer gespeichert und von dort zyklisch in die angegebene Datenbank geschrieben. Die Zykluszeit wird beim Projektieren im Editor festgelegt (siehe Allgemeine Einstellungen).

Es ist möglich, dass mehrere Runtime Projekte in dieselbe Datenbank schreiben.

Durch die zentrale Speicherung der Alarmdaten ist eine hohe Datensicherheit und eine hohe Verfügbarkeit der Alarmdaten gewährleistet.

In der zenon Runtime wird die Auswertungsdarstellung über ein Bild vom Typ Industrial Performance Analyzer realisiert.


Projektieren im Editor

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie müssen folgende Einstellungen vornehmen, um in der Runtime Alarmdaten mit dem Industrial Performance Analyzer darzustellen und auszuwerten.

Noch in diesem Kapitel

Allgemeine Einstellungen

Variablen

Sprachumschaltung

Bild vom Typ Industrial Performance Analyzer

Funktion Bildumschaltung

Funktion IPA Dokument erzeugen/drucken


Allgemeine Einstellungen

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Unter den Projekteigenschaften finden Sie den Bereich Industrial Performance Analyzer. Hier definieren Sie Einstellungen für den IPA, die Ihr gesamtes Projekt betreffen.

Die folgenden Eigenschaften stehen Ihnen zur Verfügung:

Parameter | Beschreibung
IPA aktiv | Selektieren Sie diese Eigenschaft, um den IPA einzuschalten.
Datenbank | Definieren Sie die Datenbank, in die der IPA die Alarmdaten ablegen soll (siehe Datenbank)
Tabellenname | Geben Sie einen freien Namen für die Tabelle Ihrer IPA Daten an. Eine Tabelle mit diesem Namen wird beim ersten Datenbankzugriff der Runtime automatisch in der Datenbank erzeugt.
Speicherzyklus | Definieren Sie das Intervall, in dem die Alarmdaten aus dem Puffer in die Datenbank geschrieben werden sollen. Werte aus der Praxis liegen zwischen 2 und 5 Minuten.
Puffergröße | Geben Sie an, wie viele Alarme im Puffer gespeichert werden sollen. Am Ende jedes Zyklus wird der Pufferinhalt in die Datenbank gespeichert. Danach ist der Puffer wieder leer. Wenn innerhalb eines Zyklus mehr als die angegebene Anzahl an Alarmen auftritt, gehen zuerst die ältesten Alarme verloren.
Schicht aus PFS | Selektieren Sie diese Eigenschaft, um die Zeiten für die definierten Schichten aus dem Production & Facility Scheduler zu übernehmen. Wenn Sie diese Eigenschaft aktivieren, können Sie sich bei der Auswertung der Alarme pausenbereinigte Standzeiten anzeigen lassen.
Schicht aus Variable | Selektieren Sie ein Variable vom Typ INT. Zusammen mit der Eigenschaft Schichtname aus Liste, können Sie so Zahlenwerten Schichtnamen zuordnen.
Zeitfilter vordefiniert | Definieren Sie verschiedenen Zeitfilter, auf die Sie in der Runtime zurückgreifen können.
Alarmursache | Definieren Sie verschiedene Alarmursachen, auf die sie in der Runtime zurückgreifen können.
Anlagen-Kennzeichnung | Definieren Sie verschiedene Anlagen-Kennungen, auf die sie in der Runtime zurückgreifen können.
Anlagen-Kennzeichnung über | Entscheiden Sie, ob Sie den Beginn der Kennung einer Variablen oder den Beginn des Variablennamens als Teil der Anlagen-Kennzeichnung verwenden wollen.
Schichtname aus PFS | Selektieren Sie diese Eigenschaft, um die Schichtnamen für die definierten Schichten aus dem Production & Facility Scheduler zu übernehmen.
Schichtname aus Liste | Definieren Sie zu Zahlenwerten Schichtnamen. Über den Zahlenwert der Variablen, die Sie unter Schichtname aus Variable angegeben haben, wird in der Runtime zum jeweiligen Alarm der hier definierte Schichtname angezeigt.
Zum Löschen | Wählen Sie in der Dropdownliste, die Berechtigungsebene, über die ein Benutzer verfügen muss, um Datenbankeinträge des Industrial Performance Analyzers zu löschen.
Zum Editieren | Wählen Sie in der Dropdownliste, die Berechtigungsebene, über die ein Benutzer verfügen muss, um Datenbankeinträge des Industrial Performance Analyzers zu bearbeiten.

Noch in diesem Kapitel

Datenbank

Zeitfilter vordefinieren

Alarmursachen

Anlagen-Kennzeichnung

Schichtname aus Liste


Datenbank

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Datenbank

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Eigenschaft Datenbank, klicken Sie auf die Schaltfläche mit den drei Punkten, um in den Auswahldialog für die Dateidatenquelle zu gelangen.

  1. Um eine neue DSN-Datei zu erzeugen, klicken Sie auf Neu....
  2. Selektieren Sie im folgenden Dialog den Eintrag SQL Server und klicken Sie auf Weiter.
  3. Geben Sie einen Namen für die Datenquelle an und klicken Sie erneut auf Weiter.
  4. Klicken Sie auf Fertig stellen, um den Dialog zu beenden.
  5. Unter Server den entsprechenden SQL-Server selektieren und Weiter klicken.
  6. Im folgenden Dialog müssen Sie nichts verändern. Klicke Sie auf Weiter.
  7. Aktivieren Sie die Checkbox Die Standarddatenbank ändern auf: und selektieren Sie die gewünschte Datenbank. Weiter klicken.
  8. In diesem Dialog müssen Sie erneut keine Änderungen vornehmen. Fertig stellen klicken, um den Dialog zu schließen.

Der abschließenden Dialog zeigt Ihnen nochmals Ihre Einstellungen. Sie können hier die Datenquelle testen. Bestätigen Sie diesen und den folgenden Dialog mit OK.


Zeitfilter vordefinieren

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Zeitfilter vordefinieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Auswahl dieser Einstellung, erhalten Sie folgenden Dialog.

Parameter | Beschreibung
Hinzufügen... | Fügen Sie eine neue Filterzeit hinzu. Im erscheinenden Dialog vergeben Sie einen eindeutigen Namen und stellen die Beginn- und Endezeit ein.
Ändern... | Nur aktiv, wenn Sie einen bestehenden Dialog selektiert haben. Im erscheinenden Dialog können Sie den Namen, die Beginnzeit und die Endezeit ändern.
Löschen | Nur aktiv, wenn Sie einen oder mehrere bestehenden Dialoge selektiert haben. Löscht die selektierten Zeitfilter ohne Rückfrage.

Die hier definierten Zeitfilter stehen Ihnen in der Runtime zur Verfügung. Sie können zum Beispiel die Zeiten ihrer Schichten (Frühschicht, Spätschicht usw.) hier einmal definieren und können dann im Bild vom Typ Industrial Performance Analyzer bei der Filterung auf diese Zeitbereiche zugreifen.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Noch in diesem Kapitel

Zeitfilter vordefiniert hinzufügen


Zeitfilter vordefiniert hinzufügen

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Zeitfilter vordefinieren -> Zeitfilter vordefiniert hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über den Dialog Definition fügen Sie neue Zeitfilter hinzu oder ändern bereits bestehende.

Parameter | Beschreibung
Name | Eindeutiger Name des Zeitfilters
Beginnzeit | Zeitpunkt, ab dem der Zeitfilter gültig ist.
Endezeit | Zeitpunkt, ab dem der Zeitfilter endet.


Alarmursachen

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Alarmursachen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Auswahl dieser Einstellung, erhalten Sie folgenden Dialog.

Parameter | Beschreibung
Hinzufügen... | Fügen Sie eine neue Alarmursache hinzu. Im erscheinenden Dialog vergeben Sie eine eindeutige Nummer und einen eindeutigen Namen.
Ändern... | Nur aktiv, wenn Sie einen bestehenden Dialog selektiert haben. Im erscheinenden Dialog können Sie die Nummer und den Namen ändern.
Löschen | Nur aktiv, wenn Sie einen oder mehrere bestehenden Dialoge selektiert haben. Löscht die selektierten Alarmursachen ohne Rückfrage.

Die hier definierten Alarmursachen stehen Ihnen in der Runtime zur Verfügung. Im Bild vom Typ Industrial Performance Analyzer können Sie jedem Alarm eine Alarmursache zuordnen. Sie selektieren die Alarmursachen aus einer Liste, die Sie hier verwalten.

Noch in diesem Kapitel

Alarmursachen hinzufügen


Alarmursachen hinzufügen

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Alarmursachen -> Alarmursachen hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über den Dialog Alarmursachen fügen Sie neue Ursachen hinzu oder ändern bereits bestehende.

Parameter | Beschreibung
Nummer | Eindeutige Nummer der Alarmursache.
Name | Eindeutige Ursache.


Anlagen-Kennzeichnung

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Anlagen-Kennzeichnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Auswahl dieser Einstellung, erhalten Sie folgenden Dialog.

Parameter | Beschreibung
Hinzufügen... | Fügen Sie eine neue Anlagen-Kennzeichnung hinzu. Im erscheinenden Dialog vergeben Sie eine Namen für die Anlagenkennzeichnung.
Ändern... | Nur aktiv, wenn Sie einen bestehenden Dialog selektiert haben. Im erscheinenden Dialog können Sie den Namen der Anlagen-Kennzeichnung ändern.
Löschen | Nur aktiv, wenn Sie einen oder mehrere bestehenden Dialoge selektiert haben. Löscht die selektierten Anlagen-Kennzeichnungen ohne Rückfrage.

Die hier definierten Anlagen-Kennzeichnungen stehen ihnen in der Runtime zur Verfügung. Die Anlagen-Kennzeichnung kann als Präfix im Namen der Variablen oder in der Kennung der Variablen vorkommen (siehe Eigenschaft Anlagen-Kennzeichnung über in Allgemeine Eigenschaften). Der Präfix wird durch das Zeichen _ beendet. Eine Zuordnung zu einer Anlagen-Kennzeichnung erfolgt nur, wenn eine erstellte Anlagen-Kennzeichnung genau dem Präfix entspricht.

Example Beispiel

Anlagen-Kennzeichnung:

  • Anlage11

Variablenname oder Variablenkennung:

  • Anlage1_Variable1
  • Anlage11_Variable1

Nur die Variable Anlage11_Variable1 wir der erstellten Anlagen-Kennzeichnung Anlage11 zugeordnet.

Die Anlagen-Kennzeichnung hilft Ihnen dabei, nach den gewünschten Anlagen zu filtern.

Noch in diesem Kapitel

Anlagen-Kennzeichnung hinzufügen


Anlagen-Kennzeichnung hinzufügen

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Anlagen-Kennzeichnung -> Anlagen-Kennzeichnung hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über den Dialog Anlagen-Kennzeichnung fügen Sie neue Anlagen-Kennzeichnungen hinzu oder ändern bereits bestehende.

Parameter | Beschreibung
Anlagen-Kennzeichnung | Name für die Anlagen-Kennzeichnung.


Schichtname aus Liste

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Schichtname aus Liste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Auswahl dieser Einstellung, erhalten Sie folgenden Dialog.

Parameter | Beschreibung
Hinzufügen... | Fügen Sie einen neuen Schichtnamen hinzu. Im erscheinenden Dialog vergeben Sie eine eindeutige Nummer und einen eindeutigen Namen.
Ändern... | Nur aktiv, wenn Sie einen bestehenden Dialog selektiert haben. Im erscheinenden Dialog können Sie die Nummer und den Namen ändern.
Löschen | Nur aktiv, wenn Sie einen oder mehrere bestehenden Dialoge selektiert haben. Löscht die selektierten Schichtnamen ohne Rückfrage.

Die hier definierten Schichtnamen stehen Ihnen in der Runtime zur Verfügung. Sie helfen Ihnen bei der Filterung, um nur die Alarme anzuzeigen, die in der jeweiligen Schicht aufgetreten sind.

Noch in diesem Kapitel

Schichtname aus Liste hinzufügen


Schichtname aus Liste hinzufügen

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Allgemeine Einstellungen -> Schichtname aus Liste -> Schichtname aus Liste hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über den Dialog Schichtbezeichnung fügen Sie neue Schichten hinzu oder ändern bereits bestehende.

Parameter | Beschreibung
Nummer | Eindeutige Nummer der Schicht.
Name | Eindeutiger Name der Schicht.


Variablen

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit Alarme in der IPA-Datenbank gespeichert werden, müssen Sie bei jeder Variablen, die hierfür in Betracht kommt, die Eigenschaft in IPA-Datenbank speichern aktivieren. Nur Alarme von Variablen, bei den diese Eigenschaft aktiviert ist, werden in der Datenbank gespeichert und können dann im Bild vom Typ Industrial Performance Analyzer angezeigt und ausgewertet werden.

attention Achtung

Im Grenzwerttext der Variablen und in der Variablenkennung dürfen nur für SQL-Statements zugelassene Zeichen vorkommen.


Sprachumschaltung

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Sprachumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Industrial Performance Analyzer steht die Sprachumschaltung für folgende Bereiche zur Verfügung:

  • Alarm/Ereignis-Gruppen und Alarm/Ereignis-Klassen
  • Anlagen-Kennzeichnung

    Hinweis: Da die Verwendung von '@' bei Variablennamen nicht erlaubt ist, ist die Sprachumschaltung für Anlagen-Kennzeichnung nur verfügbar, wenn Sie Anlagen-Kennzeichnung über Variablenkennung selektiert haben.

  • Alarmursache
  • Schichtname

    Hinweis: Da die Verwendung von '@' im Production & Facility Manager nicht erlaubt ist, ist die Sprachumschaltung für Schichtname nur verfügbar, wenn Sie entsprechende Einträge bei Schichtname aus Liste projektiert haben.

Sie müssen die Begriffe, für die die Sprachumschaltung angewendet werden soll, mit '@' kennzeichnen. Außerdem müssen Sie sicherstellen, dass in der Sprachtabelle entsprechende Einträge vorhanden sind.


Bild vom Typ Industrial Performance Analyzer

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Bild vom Typ Industrial Performance Analyzer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Alarmdaten, die der Industrial Performance Analyzer in der Datenbank speichert, während der Runtime anzuzeigen und auszuwerten, benötigen Sie ein Bild vom Typ Industrial Performance Analyzer.

Legen Sie ein neues Bild an (siehe Bilder) und selektieren Sie als Bildtyp Industrial Performance Analyzer. Über das Menü Kontrollelemente fügen Sie mit dem Menüeintrag Vorlage einfügen die Standard-Elemente für den Bildtyp Industrial Performance Analyzer ein. Alternativ können Sie auch die benötigten Kontrollelemente über das Menü Kontrollelemente einfügen.

Folgenden Kontrollelemente sind projektierbar:

Kontrollelement | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Liste | Tabellarische Darstellung der Alarmdaten. Die Informationen werden aus der Tabelle in der Datenbank gelesen und hier dargestellt.
Datenbank aktualisieren | Liest die Daten aus der Datenbank erneut ein.
Filter... | Öffnet den Filterdialog
Filter zurück | Lädt die letzte Filtereinstellung. Die letzten 10 Filtereinstellungen werden gespeichert.
Filter zurücksetzen | Deaktiviert alle Filtereinstellungen.
Dokument erzeugen | Erzeugt ein Dokument mit den ausgewählten Daten und öffnet es. Die Daten werden in Tabellenform dargestellt.
Diagramm erzeugen | Stellt die ausgewählten Daten in einem Diagramm dar.
Diagramm Einstellungen | Definition zum Layout des Diagramms; z.B. Balken- oder Tortendiagramm.
Aktuelle Ansicht | Textfeld, das in ausgewählte Listentyp anzeigt.
Statuszeile | Textfeld, das die gewählten Filtereinstellungen anzeigt.
Filterprofile | Speichert online eingestellte Filter und Ansichten als Profil.
Profile speichern | Speichern einer Einstellung als Profil.
Profile löschen | Löscht ausgewähltes Profil.
Profilauswahl | Aktiviert Profil aus Liste.


Funktion Bildumschaltung

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Funktion Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie eine Funktion Bildumschaltung (siehe Funktionen) auf ein Bild vom Typ Industrial Performance Analyzer erstellen, wird Ihnen der IPA-Filterdialog angezeigt. Hier können Sie Filter setzen und Einstellungen vornehmen, die bei der Umschaltung auf das Bild vom Typ Industrial Performance Analyzer berücksichtigt werden.

Details zu den Einstellungen im Filterdialog finden Sie im Kapitel Filter.


Funktion IPA Dokument erzeugen/drucken

Handbuch -> Industrial Performance Analyzer -> Projektieren im Editor -> Funktion IPA Dokument erzeugen/drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion können Sie automatisch eine IPA-Auswertung erzeugen und als HTML-Dokument abspeichern oder am Windows-Standarddrucker ausdrucken. Sie finden die Funktion unter der Gruppierung AML und CEL.

Die Filtermöglichkeiten und die Filterprojektierung entsprechen der Funktion Bildumschaltung auf das Bild vom Typ Industrial Performance Analyzer. Auf der Registerkarte Zieldokument wählen Sie aus, ob die Auswertung auf den Windows-Standarddrucker oder in eine Datei im Exportverzeichnis ausgegeben werden soll.

Wenn Sie die Auswertung in eine Datei speichern wollen, aktivieren Sie die Checkbox Auf Datei und geben Sie einen Namen an.

attention Achtung

Beachten Sie, dass Sie den Dateinamen inklusive .html angeben müssen, damit Ihr System die erzeugte Datei problemlos erkennt und Sie sie sofort mit einem geeigneten Programm öffnen können.

Beispiel für Dateiname:

IPA_010109.html

Wenn Sie die Checkbox nicht aktivieren, wird die Auswertung ausgedruckt.


Bedienung während der Runtime

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bedienung des IPAs in der Runtime erfolgt über das Bild vom Typ Industrial Performance Analyzer. Das Bild wird mit den im Editor projektierten Filter- und Übergabeparameter aufgeschalten. Sie erhalten also die Darstellung, die Sie im Editor definiert haben.

Jede Anzeige hat ihre eigenen Default-Sortierung der Spalten (siehe Kapitel Filter). Sie können auch selbst nach jeder beliebigen Spalte sortieren, indem Sie einen Linksklick auf den jeweiligen Spaltenkopf ausführen. Wenn Sie nach mehreren Spalten sortieren möchten, halten Sie Strg gedrückt und klicken Sie nacheinander die gewünschten Spalten an. Dadurch erhalten Sie eine kaskadierte Sortierung. Wenn Sie nicht mehr die Default-Sortierung verwenden, zeigt ein Pfeil neben dem Spaltennamen an, das nach dieser Spalte sortiert ist. Die Sortierung kann sowohl aufsteigend als auch absteigend erfolgen. Der erste Linksklick auf eine Spalte sortiert die Einträge absteigend. Ein weiterer Linksklick wechselt zwischen den Sortierrichtungen.

Zur Bedienung des Industrial Performance Analyzers und zur Darstellung der Alarmdaten stehen Ihnen die im Editor projektierten Kontrollelemente zur Verfügung (siehe Bild vom Typ Industrial Performance Analyzer).

Einträge löschen

Sie können nur mit dem internen Industrial Performance Analyzer Einträge aus der Datenbank löschen. Um einen Eintrag zu löschen, führen Sie einen Rechtsklick auf den gewünschten Eintrag aus. Im erscheinenden Kontextmenü selektieren Sie den Eintrag selektierte Zeile aus Datenbank löschen. Wenn Sie über die benötigte Berechtigung zum Löschen verfügen, wird der Eintrag gelöscht (siehe Allgemeine Einstellungen).

Alarmursache und Kommentar

Wenn Sie zu einem Alarm eine Alarmursache und/oder einen Kommentar hinzufügen möchten, haben Sie zwei Möglichkeiten. Führen Sie einen Doppelklick auf die gewünschte Zeile aus. Im folgenden Dialog können Sie eine Alarmursache aus der Dropdownliste Alarmursache selektieren und einen freien Kommentar in das Feld Kommentar eingeben.

Sie erreichen den Dialog auch, indem Sie auf die gewünschte Zeile einen Rechtsklick ausführen und im Kontextmenü Alarmursache bearbeiten selektieren.

Noch in diesem Kapitel

Filter

Dokument erzeugen

Diagramm


Filter

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mithilfe des Filterdialogs bestimmen Sie das Aussehen des Bilds vom Typ Industrial Performance Analyzer. Sie entscheiden welche Alarme Sie angezeigt bekommen und nach welchen Kriterien diese sortiert werden.

Jede Listenart zeigt bestimmte Spalten und hat eine Default-Sortierung. Die Listenarten sind in Summenliste, Statistikliste und Einzelliste unterteilt.

Summenliste

Listenname | verfügbare Spalten | Default-Sortierung
Klassenbezogen | Alarm/Ereignis-Klasse, Anzahl, Gesamtdauer | Spalte: Anzahl, beginnend mit der größten Anzahl
Einzelstörungsbezogen | Variable, Kennung, Anzahl, Gesamtdauer, Brutto Gesamtdauer, Grenzwerttext, Alarm/Ereignis-Klasse, Alarm/Ereignis-Gruppe, Anlage, Projekt | Spalte: Anzahl, beginnend mit der größten Anzahl
Gruppenbezogen | Alarm/Eereignis-Gruppe, Anzahl, Gesamtdauer | Spalte: Anzahl, beginnend mit der größten Anzahl
Anlagenbezogen | Anlage, Anzahl, Gesamtdauer | Spalte: Anzahl, beginnend mit der größten Anzahl

Statistikliste

Listenname | verfügbare Spalten | Default-Sortierung
Gesamtstörungsdauer einer Anlage | Anlage, Gesamtdauer | Spalte: Gesamtdauer, beginnend mit dem längsten Alarm
n kürzeste Alarme | Status, Variable, Kennung, Beginn, Dauer, Bruttodauer, Alarm/Eereignis-Klasse, Alarm/Ereignis-Gruppe, Grenzwerttext, Schichtbeginn, Schichtende, Anlage, Projekt, Alarmursache, Kommentar | Spalte: Dauer, beginnend mit dem kürzesten Alarm
n häufigste Alarme | Anzahl, Variable, Kennung, Beginn, Gesamtdauer, Brutto Gesamtdauer, Alarm/Ereignis-Klasse, Alarm/Ereignis-Gruppe, Grenzwerttext, Anlage, Projekt, Alarmursache, Kommentar | Spalte: Anzahl, beginnend mit der größten Anzahl
n längste Alarme | Status, Variable, Kennung, Beginn, Dauer, Bruttodauer, Alarm/Ereignis-Klasse, Alarm/Ereignis-Gruppe, Grenzwerttext, Schichtbeginn, Schichtende, Anlage, Projekt, Alarmursache, Kommentar | Spalte: Dauer, beginnend mit dem längsten Alarm
n letzte Alarme | Status, Variable, Kennung, Beginn, Dauer, Bruttodauer, Alarm/Ereignis-Klasse, Alarm/Ereignis-Gruppe, Grenzwerttext, Schichtbeginn, Schichtende, Anlage, Projekt, Alarmursache, Kommentar | Spalte: Beginn, beginnend mit dem ältesten Alarm

Die gewünschte Anzahl n, geben Sie neben n= ein.

Einzelliste

Listenname | verfügbare Spalten | Default-Sortierung
Alarmmeldeliste | Status, Variable, Kennung, Beginn, Dauer, Bruttodauer, Alarm/Ereignis-Klasse, Alarm/Ereignis-Gruppe, Grenzwerttext, Schichtbeginn, Schichtende, Anlage, Projekt, Alarmursache, Kommentar | Spalte: Beginn, beginnend mit dem ältesten Alarm

Noch in diesem Kapitel

Datenbank und Ansicht

Datum/Zeit

Anlagen-Kennzeichnung

Alarm/Ereignis-Klassen

Alarmgruppen

Sonstiges

Schichtbeginn

Schichtende

Alarmursache

Spaltendefinition


Datenbank und Ansicht

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Datenbank und Ansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wählen Sie hier die gewünschte Ansicht unter Ansicht aus.

Die Felder DSN-Name und Tabelle zeigen Ihnen die Verbindung zum gewählten SQl-Server und den Namen der Tabelle, in der IPA die Alarmdaten speichert. Diese Felder dienen rein der Information. Sie können hier keine Änderungen vornehmen (siehe Datenbank). Einstellungen können Sie über diese Eigenschaften tätigen:

Parameter | Beschreibung
Raster anzeigen | Blendet ein Raster bei der Darstellung der Alarmdaten ein.
n= | Geben Sie an, wie viele Einträge die Ansichten n kürzest Alarme, n häufigsten Alarme, n längste Alarme und n letzte Alarme enthalten sollen.


Datum/Zeit

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Datum/Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um diesen Filter zu verwenden, aktivieren Sie die Checkbox Aktiv. Wenn Sie jetzt den Dialog mit OK verlassen, werden Ihre Einstellungen auf die Darstellung angewandt. Wenn Sie die Checkbox Aktiv deaktivieren, bleiben Ihre Einstellungen erhalten. Sie werden allerdings nicht auf die Darstellung angewandt.

Selektieren Sie im Datumsfilter Heute, Gestern, Vorgestern oder Wählbar. Bei Selektion von Wählbar, geben Sie einen frei definierbaren Datumsbereich ein. Wenn Sie die Option mit Uhrzeit aktivieren, geben für das Start- bzw. Endedatum noch die gewünschte Uhrzeit an. Wenn Sie mit Uhrzeit nicht aktivieren, beginnt der Zeitbereich am Startdatum um 0 Uhr und endet am Endedatum um 24 Uhr.

Selektieren Sie im Zeitfilter Wählbar oder Selbstdefiniert. Bei Selektion von Wählbar, geben Sie einen frei definierbaren Zeitbereich ein. Bei Selektion von Selbstdefiniert, wählen Sie Zeitbereiche aus, die Sie zuvor im Editor erstellt haben. Sie Kapitel Zeitfilter vordefinieren.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

info Info

Die Zeitbereiche unter Zeit sind tagesbezogen, d.h. sie beziehen sich auf jeden Tag, der unter Datum selektiert wurde. Wenn unter Datum der Punkt Wählbar selektiert wurde, bei Start der 01.10.2008 und bei Ende der 05.10.2008, dann bezieht sich der Zeitbereich, der unter Zeit selektiert wurde, auf jeden der fünf Tage des Intervalls vom 1. bis zum 5. Oktober.


Anlagen-Kennzeichnung

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Anlagen-Kennzeichnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um diesen Filter zu verwenden, aktivieren Sie die Checkbox Aktiv. Wenn Sie jetzt den Dialog mit OK verlassen, werden Ihre Einstellungen auf die Darstellung angewandt. Wenn Sie die Checkbox Aktiv deaktivieren, bleiben Ihre Einstellungen erhalten. Sie werden allerdings nicht auf die Darstellung angewandt.

Im Filter der Anlagen-Kennzeichnung können eine oder mehrere Anlagen aktiviert werden. Die Einträge in der linken Liste können markiert und mit der Pfeiltaste in die rechte Liste verschoben werden.

Die Alarme der Anlagen in der rechten Liste werden dargestellt.

Die Anlagen-Kennzeichnung erfolgt über den Präfix im Variablennamen oder in der Variablenkennung, je nach Ihrer Projektierung (siehe Allgemeine Einstellungen). Sie verwalten die Liste der Anlagen-Kennzeichnung im Editor unter Anlagen-Kennzeichnung.

info Info

Bei der Filterung können mehrer Einträge ausgewählt werden. Dies geschieht mithilfe von Strg bzw. Umschalt.Bei gedrückter Strg-Taste können mehrer einzelne Einträge ausgewählt werden. Wenn Sie Umschalt drücken, werden alle Einträge ausgewählt, die sich zwischen den beiden ausgewählten Einträgen befinden. Bei gleichzeitigem Drücken von Strg und Umschalt werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Alarm/Ereignis-Klassen

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Alarm/Ereignis-Klassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um diesen Filter zu verwenden, aktivieren Sie die Checkbox Aktiv. Wenn Sie jetzt den Dialog mit OK verlassen, werden Ihre Einstellungen auf die Darstellung angewandt. Wenn Sie die Checkbox Aktiv deaktivieren, bleiben Ihre Einstellungen erhalten. Sie werden allerdings nicht auf die Darstellung angewandt.

Im Filter der Alarm/Ereignis-Klassen können eine oder mehrere Alarm/Ereignis-Klassen aktiviert werden. Die Einträge in der linken Liste können markiert und mit der Pfeiltaste in die rechte Liste verschoben werden.

Die Alarme der Klassen in der rechten Liste werden dargestellt.

info Info

Bei der Ansicht in der Runtime wird nur der Name der Alarm/Ereignis-Klasse angezeigt. Dadurch wird eine bessere Sortierung der Einträge erreicht. Die Nummer der Alarm/Ereignis-Klasse wird nicht angezeigt

info Info

Bei der Filterung können mehrer Einträge ausgewählt werden. Dies geschieht mithilfe von Strg bzw. Umschalt.Bei gedrückter Strg-Taste können mehrer einzelne Einträge ausgewählt werden. Wenn Sie Umschalt drücken, werden alle Einträge ausgewählt, die sich zwischen den beiden ausgewählten Einträgen befinden. Bei gleichzeitigem Drücken von Strg und Umschalt werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Alarmgruppen

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Alarmgruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um diesen Filter zu verwenden, aktivieren Sie die Checkbox Aktiv. Wenn Sie jetzt den Dialog mit OK verlassen, werden Ihre Einstellungen auf die Darstellung angewandt. Wenn Sie die Checkbox Aktiv deaktivieren, bleiben Ihre Einstellungen erhalten. Sie werden allerdings nicht auf die Darstellung angewandt.

Im Filter der Alarm/Ereignis-Gruppen können eine oder mehrere Alarm/Ereignis-Gruppen aktiviert werden. Die Einträge in der linken Liste können markiert und mit der Pfeiltaste in die rechte Liste verschoben werden.

Die Alarme der Gruppen in der rechten Liste werden dargestellt.

info Info

Bei der Ansicht in der Runtime wird nur der Name der Alarm/Ereignis-Gruppe angezeigt. Dadurch wird eine bessere Sortierung der Einträge erreicht. Die Nummer der Alarm/Ereignis-Gruppe wird nicht angezeigt.

info Info

Bei der Filterung können mehrer Einträge ausgewählt werden. Dies geschieht mithilfe von Strg bzw. Umschalt.Bei gedrückter Strg-Taste können mehrer einzelne Einträge ausgewählt werden. Wenn Sie Umschalt drücken, werden alle Einträge ausgewählt, die sich zwischen den beiden ausgewählten Einträgen befinden. Bei gleichzeitigem Drücken von Strg und Umschalt werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Sonstiges

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Sonstiges

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Registerkarte sind einige zusätzliche Filterfunktionen verfügbar.

Parameter | Beschreibung
Alarmdauer | Filterung nach der Alarmdauer. Nur Alarme deren Dauer in diesem Zeitfenster liegen werden berücksichtigt.
Alarmhäufigkeit | Filterung nach der Alarmhäufigkeit. Nur Alarme deren Häufigkeit in diesem Bereich liegen werden berücksichtigt. Diese Filter kann nur aktiviert werden, wenn in der Ansicht der Listendarstellung n häufigsten Alarme gewählt wurde.
Alarmzustand | Filterung nach Alarmzustand. Wählen Sie eine dieser Möglichkeiten: anstehend, gegangen oder beides.
Grenzwerttextfilter | Filterung nach dem Grenzwerttext des Alarmes. Entweder über den Text z.B. 'Test' zeigt alle Alarme an, die im Alarmtext 'Test' enthalten (wählbar Groß-/Kleinschreibung beachten), oder mittels Regular expressions.
Variablenkennungstextfilter | Filterung nach dem Kennungstext des Alarmes. Entweder über den Text oder mittels Regular expressions.
Projektfilter | Filterung nach dem Projekt aus dem die Alarme in die Datenbank eingetragen wurden. Soll nach mehreren Projekten gefiltert werden, können diese durch das Zeichen ',' getrennt eingegeben werden.

Noch in diesem Kapitel

Regular expressions


Regular expressions

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Sonstiges -> Regular expressions

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Regular expressions bezeichnet ein Textmuster, das aus normalen Zeichen (z.B. Buchstaben, Ziffer etc.) und Sonderzeichen, so genannten Metazeichen, besteht. Bei der Filterung oder Durchsuchung von Texten, können Sie damit eine bestimmte Zeichenfolge definieren.

info Info

Regular expressions sind nicht mit Wildcards – z.B. * entspricht beliebigen Zeichen – zu verwechseln. Regular expressions sind um ein vielfaches leistungsfähiger und ermöglichen Ihnen, Ihre Suche genau zu definieren.

Die folgende Tabelle enthält eine vollständige Liste der Metazeichen und deren Verhalten im Kontext von regular expressions:

Metazeichen | Beschreibung
\ | Markiert das nächste Zeichen als Sonderzeichen, Literal, Rückverweis oder oktales Escapezeichen. Beispielsweise entspricht n dem Zeichen n. \n entspricht einem Zeilenendezeichen. Die Sequenz \\ entspricht \, und \( entspricht (.
^ | Entspricht der Position am Anfang der Eingabezeichenfolge.
$ | Entspricht der Position am Ende der Eingabezeichenfolge.
* | Entspricht dem vorherigen Zeichen oder Teilausdruck nullmal oder mehrere Male. Zum Beispiel entspricht zo* den Zeichenfolgen "z, zo, zoo usw.
+ | Entspricht dem vorherigen Zeichen oder Teilausdruck einmal oder mehrere Male. Zum Beispiel entspricht zo+ den Zeichenfolgen zo, zoo usw., jedoch nicht z.
? | Entspricht dem vorherigen Zeichen oder Teilausdruck null‑ oder einmal. Beispielsweise entspricht do(es)? der Zeichenfolge do in do oder does.
{n} | n ist eine nicht negative ganze Zahl. Entspricht genau n‑mal dem Zeichen. Beispielsweise entspricht o{2} nicht dem o in Bob, jedoch den beiden o in food.
{n,} | n ist eine nicht negative ganze Zahl. Entspricht mindestens n‑mal dem Zeichen. Beispielsweise entspricht o{2,} nicht dem o in Bob, jedoch allen o in foooood. o{1,} ist gleichbedeutend mit o+. o{0,} ist gleichbedeutend mit o*.
{n,m} | m und n sind nicht negative ganze Zahlen, wobei n <= m ist. Entspricht dem Zeichen mindestens n-mal und höchstens m-mal. Beispielsweise entspricht o{1,3} den ersten drei o in fooooood. o{0,1} ist gleichbedeutend mit o?. Hinweis: Sie dürfen kein Leerzeichen zwischen das Komma und die Zahlen setzen.
? | Wenn dieses Zeichen unmittelbar auf einen der anderen Quantifizierer folgt (*, +, ?, {n}, {n,}, {n,m}), ist das Vergleichsmuster "nicht gierig". Ein nicht gieriges Muster sucht nach einer Entsprechung eines möglichst kleinen Teils der gesuchten Zeichenfolge, während das standardmäßige "gierige Muster" nach einer Entsprechung eines möglichst großen Teil der gesuchten Zeichenfolge sucht. Beispielsweise entspricht o+? in der Zeichenfolge oooo einem einzigen o, während o+ allen o entspricht.
. | Entspricht jedem beliebigen einzelnen Zeichen außer \n. Soll die Entsprechung ein beliebiges Zeichen einschließlich \n sein, verwenden Sie ein Muster wie [\s\S].
(muster) | Ein Teilausdruck, der muster entspricht und die Entsprechung erfasst. Sollen die Entsprechungen runde Klammern ( ) sein, verwenden Sie \( oder \).
(?:muster) | Ein Teilausdruck, der muster entspricht, aber die Entsprechung nicht erfasst, d. h. eine Entsprechung ohne Erfassung, die nicht für die spätere Verwendung gespeichert wird. Dies ist zum Kombinieren von Teilen eines Musters mit dem "oder"-Zeichen (|) nützlich. Beispielsweise kann der Ausdruck industr(?:y|ies) schneller eingegeben werden als industry|industries.
(?=muster) | Ein Teilausdruck, der eine positive Lookahead-Suche durchführt, die eine Entsprechung für die Zeichenfolge an jedem Punkt sucht, an dem ein der Zeichenfolge entsprechendes Muster beginnt. Dies ist eine Entsprechung ohne Erfassung, d. h. die Entsprechung wird nicht für die spätere Verwendung gespeichert. Beispielsweise entspricht Windows (?=XP|VISTA) Windows in Windows XP, aber nicht Windows in Windows 7. Lookaheads verbrauchen keine Zeichen, d. h. nach dem Auftreten einer Entsprechung beginnt die Suche nach der nächsten Entsprechung unmittelbar nach der letzten Entsprechung, und nicht nach den Zeichen, die die Lookahead-Suche enthielten.
(?!muster) | Ein Teilausdruck, der eine negative Lookahead-Suche durchführt, die eine Entsprechung für die Suchzeichenfolge an jedem Punkt sucht, an dem ein nicht der Zeichenfolge entsprechendes Muster beginnt. Dies ist eine Entsprechung ohne Erfassung, d. h. die Entsprechung wird nicht für die spätere Verwendung gespeichert. Beispielsweise entspricht Windows (?!=XP|VISTA) Windows in Windows 7, aber nicht Windows in Windows XP. Lookaheads verbrauchen keine Zeichen, d. h. nach dem Auftreten einer Entsprechung beginnt die Suche nach der nächsten Entsprechung unmittelbar nach der letzten Entsprechung, und nicht nach den Zeichen, die die Lookahead-Suche enthielten.
x|y | Entspricht entweder x oder y. Beispielsweise entspricht z|food - z oder food. (z|f)ood entspricht zood oder food.
[xyz] | Eine Zeichengruppe. Entspricht einem beliebigen der eingeschlossenen Zeichen. Beispiel: [abc] entspricht dem a in plain.
[^xyz] | Eine negative Zeichengruppe. Entspricht einem beliebigen nicht eingeschlossenen Zeichen. Beispiel: [^abc] entspricht dem p in plain.
[a-z] | Ein Zeichenbereich. Entspricht einem beliebigen Zeichen im angegebenen Bereich. Beispiel: [a-z] entspricht jedem Kleinbuchstaben im Bereich von a bis z.
[^a-z] | Ein negativer Zeichenbereich. Entspricht einem beliebigen Zeichen, das sich nicht im angegebenen Bereich befindet. Beispiel: [^a-z] entspricht jedem Buchstaben, der nicht im Bereich von a bis z vorhanden ist.
\b | Entspricht einer Wortgrenze, d. h. der Position zwischen einem Wort und einem Leerzeichen. Beispiel: er\b entspricht dem er in never, aber nicht dem er in verb.
\B | Entspricht einer anderen als einer Wortgrenze. Beispiel: er\B entspricht dem er in verb, aber nicht dem er in never.
\cx | Entspricht dem durch x angegebenen Steuerzeichen. Beispielsweise entspricht \cM Strg+M oder einem Wagenrücklaufzeichen. Der Wert von x muss im Bereich von A bis Z oder von a bis z liegen. Andernfalls wird angenommen, dass c ein literales c‑Zeichen ist.
\d | Entspricht einer Ziffer. Gleichbedeutend mit [0-9].
\D | Entspricht einem anderen Zeichen als einer Ziffer. Gleichbedeutend mit [^0-9].
\f | Entspricht einem Seitenvorschubzeichen. Gleichbedeutend mit \x0c und \cL.
\n | Entspricht einem Zeilenendezeichen. Gleichbedeutend mit \x0a und \cJ.
\r | Entspricht einem Wagenrücklaufzeichen. Gleichbedeutend mit \x0d und \cM.
\s | Entspricht einem beliebigen Leerraumzeichen, z.B. Leerzeichen, Tabulator, Seitenvorschub usw. Gleichbedeutend mit [ \f\n\r\t\v].
\S | Entspricht einem anderen Zeichen als einem Leerraumzeichen. Gleichbedeutend mit [^ \f\n\r\t\v].
\t | Entspricht einem Tabulatorzeichen. Gleichbedeutend mit \x09 und \cI.
\v | Entspricht einem vertikalen Tabulatorzeichen. Gleichbedeutend mit \x0b und \cK.
\w | Entspricht einem beliebigen Wortzeichen einschließlich dem Unterstrich. Gleichbedeutend mit [A-Za-z0-9_].
\W | Entspricht einem beliebigen Nichtwortzeichen. Gleichbedeutend mit [^A-Za-z0-9_].
\xn | Entspricht n, wobei n ein hexadezimaler Escapewert ist. Hexadezimale Escapewerte müssen genau zwei Stellen lang sein. Beispiel: \x41 entspricht A. \x041 ist gleichbedeutend mit \x04 & 1. Ermöglicht die Verwendung von ASCII-Codes in regulären Ausdrücken.
\num | Entspricht num, wobei num eine positive ganze Zahl ist. Ein Verweis zurück auf erfasste Entsprechungen. Beispiel: (.)\1 entspricht zwei aufeinander folgenden, identischen Zeichen.
\n | Gibt entweder einen oktalen Escapewert oder einen Rückverweis an. Wenn vor \n mindestens n erfasste Teilausdrücke stehen, ist n ein Rückverweis. Andernfalls ist n ein oktaler Escapewert, wenn n eine oktale Ziffer ist (0‑7).
\nm | Gibt entweder einen oktalen Escapewert oder einen Rückverweis an. Wenn vor \nm mindestens nm erfasste Teilausdrücke stehen, ist nm ein Rückverweis. Wenn vor \nm mindestens n erfasste Teilausdrücke stehen, ist n ein Rückverweis, auf den das Literal m folgt. Wenn keine der vorangehenden Bedingungen zutrifft, entspricht \nm dem oktalen Escapewert nm, wenn es sich bei n und m um oktale Ziffern (0-7) handelt.
\nml | Entspricht dem oktalen Escapewert nml, wenn n eine oktale Ziffer ist (0‑3) und m und l oktale Ziffern sind (0‑7).
\un | Entspricht n, wobei n ein als vier hexadezimale Ziffern dargestelltes Unicode-Zeichen ist. Beispiel: \u00A9 entspricht dem Copyright-Sonderzeichen (©).


Schichtbeginn

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Schichtbeginn

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um diesen Filter zu verwenden, aktivieren Sie die Checkbox Aktiv. Wenn Sie jetzt den Dialog mit OK verlassen, werden Ihre Einstellungen auf die Darstellung angewandt. Wenn Sie die Checkbox Aktiv deaktivieren, bleiben Ihre Einstellungen erhalten. Sie werden allerdings nicht auf die Darstellung angewandt.

Im Filter Schichtbeginn können eine oder mehrere Schichten aktiviert werden. Die Einträge in der linken Liste können markiert und mit der Pfeiltaste in die rechte Liste verschoben werden.

Der Filter Schichtbeginn bezieht sich auf die Schicht die zu der Zeit von Alarm kommt aktiv war. Die Liste mit den Schichtnamen verwalten Sie im Editor unter Schichtname aus Liste.

info Info

Bei der Filterung können mehrer Einträge ausgewählt werden. Dies geschieht mithilfe von Strg bzw. Umschalt.Bei gedrückter Strg-Taste können mehrer einzelne Einträge ausgewählt werden. Wenn Sie Umschalt drücken, werden alle Einträge ausgewählt, die sich zwischen den beiden ausgewählten Einträgen befinden. Bei gleichzeitigem Drücken von Strg und Umschalt werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Schichtende

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Schichtende

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um diesen Filter zu verwenden, aktivieren Sie die Checkbox Aktiv. Wenn Sie jetzt den Dialog mit OK verlassen, werden Ihre Einstellungen auf die Darstellung angewandt. Wenn Sie die Checkbox Aktiv deaktivieren, bleiben Ihre Einstellungen erhalten. Sie werden allerdings nicht auf die Darstellung angewandt.

Im Filter Schichtende können eine oder mehrere Schichten aktiviert werden. Die Einträge in der linken Liste können markiert und mit der Pfeiltaste in die rechte Liste verschoben werden.

Der Filter Schichtende bezieht sich auf die Schicht die zu der Zeit von Alarm geht aktiv war. Die Alarme der Schichten in der rechten Listbox werden dargestellt. Die Liste mit den Schichtnamen verwalten Sie im Editor unter Schichtname aus Liste.

info Info

Bei der Filterung können mehrer Einträge ausgewählt werden. Dies geschieht mithilfe von Strg bzw. Umschalt.Bei gedrückter Strg-Taste können mehrer einzelne Einträge ausgewählt werden. Wenn Sie Umschalt drücken, werden alle Einträge ausgewählt, die sich zwischen den beiden ausgewählten Einträgen befinden. Bei gleichzeitigem Drücken von Strg und Umschalt werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Alarmursache

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Alarmursache

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um diesen Filter zu verwenden, aktivieren Sie die Checkbox Aktiv. Wenn Sie jetzt den Dialog mit OK verlassen, werden Ihre Einstellungen auf die Darstellung angewandt. Wenn Sie die Checkbox Aktiv deaktivieren, bleiben Ihre Einstellungen erhalten. Sie werden allerdings nicht auf die Darstellung angewandt.

Im Filter Alarmursachen können eine oder mehrere Alarmursachen aktiviert werden. Die Liste der Alarmursachen verwalten Sie im Editor unter Alarmursachen.

info Info

Bei der Filterung können mehrer Einträge ausgewählt werden. Dies geschieht mithilfe von Strg bzw. Umschalt.Bei gedrückter Strg-Taste können mehrer einzelne Einträge ausgewählt werden. Wenn Sie Umschalt drücken, werden alle Einträge ausgewählt, die sich zwischen den beiden ausgewählten Einträgen befinden. Bei gleichzeitigem Drücken von Strg und Umschalt werden alle dazwischen liegenden Einträge ausgewählt und die zuvor ausgewählten Einträge werden beibehalten.


Spaltendefinition

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Filter -> Spaltendefinition

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte passen Sie die voreingestellten Spalten Ihren Bedürfnissen an.

Parameter | Beschreibung
Listenansicht | Aus dem Dropdown Menü die gewünschte Liste selektieren.
Spalten | In dieser Liste sind alle Spalten aufgeführt, die für die gewählte Listenansicht verfügbar sind.
Custom | Aktivieren Sie diese Checkbox, um die voreingestellten Werte für Spaltentitel und -breite anzupassen.
Spaltentitel | Neuen Titel für selektierte Spalte eingeben.
Spaltenbreite | Definieren Sie die Breite für die selektierte Spalte in Pixel. Wenn Sie 0 eingeben, wird die Spalte ausgeblendet.


Dokument erzeugen

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Dokument erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zusätzlich zur Ansicht der Alarmdaten kann ein Dokument im HTML-Format erzeugt werden. Diese Dokumente können ausgedruckt oder gespeichert werden.

Nachdem alle gewünschten Filterungen und Sortierungen vorgenommen wurden, kann das Dokument durch Linksklick auf den Button Dokument erzeugen generiert werden.

Das Layout des Dokumentes wird durch XSL-Dateien (Stylesheet) bestimmt. Folgende vordefinierte Dateien sind vorhanden:

XSL-Datei | Beschreibung
Single_list.xsl | Einzelalarmdarstellungen
Statistical_duration.xsl | statistische Darstellung der Gesamtstörungsdauer einer Anlage
Statistical_frequency.xsl | statistische Darstellung der n häufigsten Alarme, n kürzesten Alarme, n längsten Alarme, n letzten Alarme
Sum_list_equipment.xsl | anlagenbezogene Summenliste
Sum_list_single_alarm.xsl | einzelstörungsbezogene Summenliste
Sum_list_group.xsl | gruppenbezogene Summenliste
Sum_list_class.xsl | klassenbezogene Summenliste

Diese Stylesheets liegen in den jeweiligen Ordnern bei:

  • Windows XP: C:\Dokumente und Einstellungen/All Users/Anwendungsdaten/COPA-DATA/zenon/ipa
  • Windows Vista\Windows 7: C:\ProgramData\COPA-DATA\zenon650\IPA\

Werden in den jeweiligen Ordnern mehrere Stylesheet-Dateien gefunden, wird mit einem Dialog abgefragt, welche Vorlage verwendet werden soll.


Diagramm

Handbuch -> Industrial Performance Analyzer -> Bedienung während der Runtime -> Diagramm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die summierten Listendarstellungen und für die Statistikliste n häufigste Alarme kann neben dem Dokument auch ein Diagramm erzeugt werden.

Mit den Einstellungen des Diagramms wird sein Layout bestimmt.

In der Registerkarte Diagramm allgemein kann zwischen folgenden Diagrammen ausgewählt werden:

Diagrammart | Beschreibung
Horizontales Balkendiagramm | Balkendiagramm wird horizontal dargestellt.
Vertikales Balkendiagramm | Balkendiagramm wird vertikal dargestellt.
Tortendiagramm | Beim Tortendiagramm kann zwischen der 3D oder der 2D Darstellung gewählt werden.

Die summierten Alarme werden bezogen auf die Zeit oder auf die Anzahl dargestellt. Unter dem Eintrag Diverses wird die Farbe der Balken bestimmt. Auch die Anzeige des Rasters wird hier aktiviert.

In der Registerkarte Beschriftung werden Font und Farbe der Diagrammbeschriftung gewählt. Mit dem Style wird der darzustellende Beschriftungstext bestimmt.

In der Registerkarte Legende wird der Schriftfont und die Schriftfarbe gewählt. Es wird definiert, wie die Legende dargestellt wird und an welcher Position sie relativ zur Grafik angeordnet sein soll.


Installation und Updates

Handbuch -> Installation und Updates

Bei der ersten Installation von zenon wie auch bei Service Packs und Upgrades startet die Installationsroutine automatisch und führt Sie durch den gesamten Installationsvorgang. Falls Sie den Autostart von DVDs deaktiviert haben, starten Sie die Installation durch Ausführen der Datei start.exe im Wurzelverzeichnis Ihrer zenon DVD.

Für die Installation der zenon Runtime auf Systemen mit Windows XP Embedded beachten Sie bitte die Hinweise zur administrativen Installation im Kapitel Runtime für Windows XP Embedded. Die Installation von zenon für Windows CE wird im Kapitel Runtime für Windows CE beschrieben.

info Info

Erhalten Sie bei einer Installation die Fehlermeldung, dass ein Dienst nicht gestartet werden konnte, dann:

  • starten Sie erst den Rechner neu
  • starten Sie dann das zenon Setup neu

Noch in diesem Kapitel

Systemvoraussetzungen

Pfade für Setup und im Betrieb

zenon Standardinstallation

zenon Runtime unter Windows XP Embedded

zenon für Windows CE

zenon Logic Runtime für Windows CE

zenon Webserver

zenon Webclient

Updates (Build Setups), Service Packs und Upgrades

FAQ

Technische Unterstützung


Systemvoraussetzungen

Handbuch -> Installation und Updates -> Systemvoraussetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon 7.00 kann auf allen aktuellen Microsoft Betriebssystemen eingesetzt werden. Die darunterliegende Hardware ist dafür unerheblich. Das Betriebssystem abstrahiert Hardwarefunktionen soweit, dass der Einsatz von zenon auf beliebiger Hardware normalerweise uneingeschränkt möglich ist.

zenon wird immer auf den neuesten Versionen der Betriebssysteme mit den neuesten verfügbaren Servicepacks und Hotfixes getestet. Sie können also normalerweise davon Ausgehen, dass zenon auf den neuesten Servicepacks und Hotfixes auch einsetzbar ist.

Leider kann es vorkommen, dass Microsoft Änderungen in Servicepacks, Hotfixes oder Patches herausbringt, die Inkompatibilitäten bewirken und die Funktionsfähigkeit der Software beeinflussen.

Sollte das der Fall sein, ist COPA-DATA stets darum bemüht eine aktualisierte Version zu veröffentlichen, die diese Einschränkungen umgeht. Bitte wenden Sie sich in so einem Fall an den Support: support@copadata.com.

Noch in diesem Kapitel

Betriebssystem

Zusätzliche Software

Benutzerrechte

Hardwarevoraussetzungen

Dateistruktur

Freie Ports


Betriebssystem

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Betriebssystem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Unterstütze PC-Betriebssysteme

  • Windows XP Professional
    • Runtime: ab Service Pack 2
      Hinweis: starke Verschlüsselung wird erst ab Service Pack 3 unterstützt
    • Entwicklungsumgebung (x86 und x64 Version): ab Service Pack 3
  • Windows XP Embedded ab Service Pack 2 - nur für die Runtime.
    Hinweis: Die Installation muss aufgrund technischer Beschränkungen in Windows XP Embedded manuell durchgeführt werden.
  • Windows Embedded Standard 2009 (vorausgesetzt, alle notwendigen Betriebssystemkomponenten sind vorhanden) - nur Runtime.
  • Windows Embedded Standard 7 (vorausgesetzt, alle notwendigen Betriebssystemkomponenten sind vorhanden) - nur Runtime.
  • Windows Vista (Business, Enterprise und Ultimate Version, jeweils x86 und x64 Versionen).
  • Windows 7 (Professional, Enterprise und Ultimate Version, jeweils x86 und x64 Versionen).
  • Windows Server 2003 ab Service Pack 1 (alle Editionen, x86 und x64 Versionen)
  • Windows Server 2008 (alle Editionen)
  • Windows Server 2008 R2 (alle Editionen)

Hinweise:

  • Alle Betriebssysteme werden auch in der Multilingual Version unterstützt.
  • Itanium Prozessoren werden für kein Betriebssystem unterstützt.

attention Achtung

Automatische Windows-Updates beeinflussen Installation

Wird während des zenon Setups ein Update des Windows Betriebssystems ausgeführt, kann das zu Problemen bei der Installation von zenon führen. Um das zu vermeiden:

  • deaktivieren Sie das automatische Windows-Update für den Zeitraum der Installation
    oder
  • führen Sie Windows-Updates vor der Installation von zenon aus

Microsoft .NET Framework

zenon benötigt für VSTA und WPF das Microsoft .NET Framework 3.5 oder höher. Sollte das Framework nicht installiert sein, wird es unter Windows XP, Vista, Server 2003 und Server 2008 automatisch installiert.

Unter Windows 7 und Windows Server 2008 R2 ist das .NET Framework eine Betriebssystemkomponente und kann daher nicht automatisch installiert werden. Das Setup bringt daher eine Fehlermeldung und bricht ab. Das .NET Framework muss unter diesen Betriebssystemen manuell aktiviert werden: Systemsteuerung -> Programme und Funktionen -> Windows Funktionen aktivieren oder deaktivieren.

Unterstütze Windows CE-Betriebssysteme:

  • Windows CE 5.0
  • Windows CE 6.0
  • Windows Mobile 5.0
  • Windows Mobile 6.0
  • Windows Mobile 6.1

Welche Prozessoren unter den verschiedenen Windows CE-Betriebssystemen unterstützt werden, lesen Sie im Kapitel CE Versionen/Prozessorunterstützung. Eine installationsanleitung für die Runtime unter Windows CE finden Sie im Kapitel Runtime.

Überblick

 | Windows XP Embedded | Windows XP/Server 2003 | Windows Vista/Windows 7/ Server 2008 (R2) | Windows CE
Editor |  | X | X |
Runtime | X | X | X |
Runtime für Windows CE |  |  |  | X
Webserver | X | X | X | X
Webclient | X | X | X |

info Info

Wenn Sie immer die aktuellste Version (Service Pack) des entsprechenden Betriebssystems verwenden, vermeiden Sie Kompatibilitätsprobleme und Sicherheitslücken.


Zusätzliche Software

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Zusätzliche Software

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

SQL Server

Der zenon Editor arbeitet mit einer SQL Datenbank. Diese wird bei der Installation des zenon Editors mitinstalliert:

  • Bis inklusive Version 6.20 SP4: SQL-Server 2000 (MSDE)
  • Ab Version 6.21 SP0: SQL Server 2005 Express
  • Ab Version 7.00 SP0: SQL Server 2008R2 SP1 Express

attention Achtung

Beachten Sie bei einem Wechsel der Version des SQL Servers: Projekte müssen in der ursprünglichen Version gesichert und exportiert und dann in der neuen Version wieder zurückgelesen werden.

Dongle

  • Die für den Dongleschutz erforderliche Software Wibu-Key oder CodeMeter wird immer automatisch mitinstalliert bzw. bei Updates erneuert.


Benutzerrechte

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Benutzerrechte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Installation sind Windows Administratorrechte erforderlich.

Für den laufenden Betrieb sind Standard Windows Benutzerrechte erforderlich. Die Benutzerkontensteuerung (UAC) kann auf höchster Sicherheitsstufe aktiviert sein.


Hardwarevoraussetzungen

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Hardwarevoraussetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

PC Version und CE Version von zenon stellen unterschiedliche Ansprüche an die benötigte Hardware. In diesem Kapitel finden Sie die Hardwarevoraussetzungen für die einzelnen Versionen von Editor und Runtime sowie Webserver und Webclient.

Der Editor nutzt als Datenbankserver einen Microsoft SQL Server und stellt höhere Ansprüche an die Hardware als die Runtime. Sollen Editor und Runtime gleichzeitig auf einem System laufen, addieren sich die Voraussetzungen.

attention Achtung

Wir empfehlen Grafikkarten mit eigenem Grafikspeicher. Shared Memory Grafikkarten beanspruchen eventuell zu viel Arbeitsspeicher und führen damit zu Leistungseinbußen.

Noch in diesem Kapitel

Editor

Runtime

Runtime unter Windows XP Embedded

Runtime für Windows CE

Webserver

Webclient


Editor

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Hardwarevoraussetzungen -> Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mindestanforderungen beziehen sich auf eine Komplettinstallation des Editors. Für umfangreiche Projekte oder mehrere gleichzeitig geladene Projekte muss die Hardware entsprechend leistungsstärker sein.

Hardware | Mindestanforderung | Empfohlen
CPU | Pentium IV. | Dual Core.
Arbeitsspeicher | Windows XP: ab 512 MB. Windows Vista/7: ab 1024 MB. Hinweis: Je mehr Projekte Sie gleichzeitig im Speicher halten, desto höher ist der Speicherbedarf. | Windows XP: 1024 MB. Windows Vista/7: 4096 MB.
Festplatte | Mindestens 2 GB freier Speicherplatz für die Komplettinstallation plus Speicherplatz für die Projekte. |
Bildschirmauflösung | Extended VGA mit 1024 x 768. | Doppelmonitorsystem: 2 mal 1680 x 1050.
Grafikkarte | 64 MB dedizierter Speicher. Karten mit Shared Memory können zu Leistungseinbußen führen. |
Eingabegeräte | Standardtastatur und Standardmaus. |
DVD Laufwerk | Für Installation empfohlen. Die Installation ist aber auch über das Netzwerk möglich. |
Parallele oder USB Schnittstelle | Bei Dongle-Lizenzierung für Dongle erforderlich. Bei Netzwerkdongle nur für Dongleserver nötig. |
Netzwerkanschluss (optional) | 10 MBit/s mit TCP/IP Protokoll für Remote Transport, Netzwerkdongle, Projektsicherungen auf zentralem Dateiserver, mehrplatzfähiger Editor usw. | 100 MBit/s.


Runtime

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Hardwarevoraussetzungen -> Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mindestanforderungen beziehen sich auf eine Komplettinstallation der Runtime. Für umfangreiche Projekte oder mehrere gleichzeitig geladene Projekte muss die Hardware entsprechend leistungsstärker sein.

Hardware | Mindestanforderung | Empfohlen
CPU | Pentium System mit 400 MHz | Dual Core.
Arbeitsspeicher | Windows XP: ab 256 MB. Windows Vista/7: ab 512 MB. Hinweis: Projekte mit großen Datenmengen, Netzwerkprojekte, mehrere parallele Projekte und Projekte im Redundanzbetrieb benötigen mehr Speicher. | Windows XP: 2048 MB. Windows Vista/7: 4096 MB.
Festplatte | 1 GB freier Speicherplatz für Runtime-Installation plus Speicherplatz für die Projekte. Achtung: Wenn Sie historische Daten aufzeichnen (z. B. Archivdaten oder Alarm-/CEL-Daten), muss ausreichend Festplattenplatz zur Verfügung stehen bzw. bei der Projektierung dafür gesorgt werden, dass die historischen Daten ausgelagert oder gelöscht werden. | 80 GB freier Speicherplatz.
Bildschirmauflösung | VGA mit 640 x 480. |
Grafikkarte | 64 MB dedizierter Speicher. Karten mit Shared Memory können zu Leistungseinbußen führen. |
Eingabegeräte | Tastatur und/oder Maus. Auch die Bedienung über einen Touchscreen ist möglich. Für den Touchscreen stehen Ihnen viele individuelle, gestaltbare Softkeyboards zur Verfügung. |
DVD Laufwerk (optional) | Für Installation empfohlen. Installation auch über Netzwerk oder andere Datenträger möglich. |
Parallele oder USB Schnittstelle (optional) | Für Dongle empfohlen. Auch Netzwerkdongle möglich. |
Netzwerkanschluss (optional) | 64 kBits/s für Standard Client/Server Projekte. 100 Mbit/s Fullduplex für Redundanzbetrieb. | 100 Mbit/s Fullduplex für Standard Client/Server Projekte.
Remoteverbindung (optional) | Minimalvoraussetzung: Wählmodem mit 9600 Bits/s. | 1 MBit/s Fullduplex.
WAN Einsatz (optional) | Beliebige Verbindung über Router, z.B. per ISDN oder DSL. Die Datenübertragung ist im WAN technisch bedingt langsamer als im lokalen Netzwerk. Beachten Sie die möglichen Datenübertragungsraten der von Ihnen eingesetzten WAN-Technik bereits bei der Projekterstellung. |
Message Control (optional) | Die Voraussetzungen dafür finden Sie im Kapitel Message Control. |
Schnittstellen (optional) | Die nötigen Schnittstellen hängen von den Anforderungen der SPS und/oder Busanbindung ab, z. B.: serielle RS232 oder RS422/485 Schnittstellen, ISA/PCI Steckplätze, usw. |


Runtime unter Windows XP Embedded

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Hardwarevoraussetzungen -> Runtime unter Windows XP Embedded

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mindestanforderungen beziehen sich auf eine an das Betriebssystem Windows XP Embedded angepasste reduzierte Installation der Runtime. Für umfangreiche Projekte muss die Hardware entsprechend leistungsstärker sein.

Da unter Windows XP embedded meist weniger Speicherplatz auf dem Speichermedium zur Verfügung steht, gibt es die Möglichkeit die zenon Runtime ohne VSTA und andere nicht unbedingt erforderliche Zusatzsoftware zu installieren. Die Anleitung zur reduzierten Installation finden Sie im Kapitel Runtime unter Windows XP Embedded.

Diese Tabelle gibt nur die geänderten Anforderungen gegenüber der Standard Installation wieder. Die restlichen Parameter sind wie bei Hardwarevoraussetzungen für die Runtime beschrieben.

Hardware

Mindestanforderung

Empfohlen

Arbeitsspeicher

256 MB.

Hinweis: Projekte mit großen Datenmengen, Netzwerkprojekte, mehrere parallele Projekte und Projekte im Redundanzbetrieb benötigen mehr Speicher.

2048 MB.

Speichermedium

512 MB freier Speicherplatz für die Runtime
plus 256 MB auf der C‑Partition
plus Speicherplatz für die Projekte.

Installation: Beachten Sie die Anleitung im Kapitel Runtime unter Windows XP Embedded.

Achtung: Wenn Sie historische Daten aufzeichnen (z. B. Archivdaten oder Alarm-/CEL-Daten), muss ausreichend Festplattenplatz zur Verfügung stehen bzw. bei der Projektierung dafür gesorgt werden, dass die historischen Daten ausgelagert oder gelöscht werden.

80 GB.


Runtime für Windows CE

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Hardwarevoraussetzungen -> Runtime für Windows CE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mindestanforderungen beziehen sich auif eine Komplettinstallation der Runtime für Windows CE. Für umfangreiche Projekte muss die Hardware entsprechend leistungsstärker sein.

Hardware | Mindestanforderung | Empfohlen
CPU | Mindestens 400 MHz | 1 GHz.
Arbeitsspeicher | 64 MB. | 256 MB für Windows CE 5.0. 1024 MB für Windows CE 6.0.
Speichermedium | 64 MB freier Speicherplatz. Permanent beschreibbarer remanenter Speicher für Projektdaten | 256 MB freier Speicherplatz oder mehr.
Netzwerkanschluss | Für Standard Client/Server Projekte: 10 Mbit/s Fullduplex. |


Webserver

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Hardwarevoraussetzungen -> Webserver

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mindestanforderungen beziehen sich auf eine Komplettinstallation des Webservers. Für umfangreiche Projekte oder mehrere gleichzeitig geladene Projekte muss die Hardware entsprechend leistungsstärker sein.

Hardware | Mindestanforderung | Empfohlen
CPU | Pentium IV. |
Arbeitsspeicher | Windows XP: ab 512 MB. Windows Vista/7: ab 1024 MB. |
Festplatte | 256 MB freier Speicherplatz. | 1 GB freier Speicherplatz.
Netzwerkanschluss | 10 Mbit/s Fullduplex. | 100 Mbit/s Fullduplex.
Remoteverbindung (optional) | Minimalvoraussetzung: Wählmodem mit 9600 Bits/s. | 1 MBit/s Fullduplex.


Webclient

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Hardwarevoraussetzungen -> Webclient

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mindestanforderungen beziehen sich auf eine Komplettinstallation des Webclients. Für umfangreiche Projekte oder mehrere gleichzeitig geladene Projekte muss die Hardware entsprechend leistungsstärker sein.

Hardware | Mindestanforderung | Empfohlen
CPU | Pentium IV. | Dual Core
Arbeitsspeicher | Windows XP: ab 512 MB. Windows Vista/7: ab 1024 MB. |
Festplatte | 64 MB freier Speicherplatz für Webclient plus Speicherplatz für die Projekte. | 80 GB freier Speicherplatz.
Netzwerkanschluss | 10 Mbit/s Fullduplex. | 100 Mbit/s Fullduplex.
Remoteverbindung (optional) | Minimalvoraussetzung: Wählmodem mit 9600 Bits/s. | 1 MBit/s Fullduplex.

attention Achtung

Der Webclient benötigt ActiveX und wird offiziell nur für den Internet Explorer unterstützt. Für Mozilla/Firefox steht er damit nicht zur Verfügung.

Möglicher Workaround: Einbettung des Internet Explorers in einen Tab des Mozilla/Firefox (Plugin: IE Tab). Informationen dazu finden Sie auf den entsprechenden Websites zu Mozilla/Firefox.


Dateistruktur

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Dateistruktur

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Dateistruktur wird während der Installation angelegt bzw. erweitert.

Dabei werden die zenon Programmdateien in einem Ordner abgelegt, der während der Installation angegeben wird.

Zusätzlich wird während der Installation nach einem Ordner für die SQL-Datenbanken der Projekte gefragt. Auf dem Speichermedium für die Projektablage (SQL, Bilder usw.) muss genügend freier Platz reserviert sein, da hier alle aktuellen und künftigen Projektdaten abgelegt werden.

Ordner | Windows XP | Windows Vista/7
Programmordner | C:\Programme\COPA-DATA\zenon6xxx | C:\Program Files\COPA-DATA\zenon6xxx
Programmdatenordner, z.B. Globale Symbole, Druckvorlagen, Log-Dateien, usw. | C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\COPA-DATA\zenon6xxx | C:\ProgramData\COPA-DATA\zenon6xxx
Datenbankordner (SQL) | C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\COPA-DATA\SQL | C:\ProgramData\COPA-DATA\SQL
Systemordner | C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\COPA-DATA\System | C:\ProgramData\COPA-DATA\System
Einstellungen Editor und Profile | C:\Dokumente und Einstellungen\UserName\Lokale Einstellungen\Anwendungsdaten\COPA-DATA\zenon\Editor | C:\Users\UserName\AppData\Local\COPA-DATA\zenon\Editor
Einstellungen Diagnose Viewer | C:\Dokumente und Einstellungen/UserName\Lokale Einstellungen\Anwendungsdaten\COPA-DATA\zenon\DiagView | C:\Users\UserName\AppData\Local\COPA-DATA\zenon\DiagView

Definition Runtimeordner und Datenordner

Runtimeordner

Der Editor erzeugt die Runtime-Dateien im Runtime-Ordner, beziehungsweise werden sie per Remote Transport in diesen Ordner übertragen. Der Runtime-Ordner wird beim Erzeugen eines Projektes mit angegeben und kann nachträglich in den Projekteigenschaften geändert werden. Bei Remote-Übertragung wird der Runtime-Ordner in den Einstellungen für den Remote Transport festgelegt.

Datenordner

Die Runtime speichert alle zur Laufzeit erzeugten Datendateien, wie etwa Alarmdateien, Archivdateien usw. im Datenordner. Standardmäßig wird der Datenordner als Unterordner zum Runtimeordner angelegt. Er erhält automatisch den Namen des Rechners, auf dem die Runtime läuft. Diesen Speicherort kann in den Projekteigenschaften (Allgemein/Datenordner)geändert werden.

Interne ID: Dateistruktur

Datenordner

Leer: Der Standardpfad wird für das Speichern von Alarmmeldeliste, Chronologischer Ereignisliste (CEL), Harddisk-Daten, Archivdaten etc.verwendet (Projektpfad\Rechnername\Projektname).
Pfad: Der hier eingegebene Pfad wird zum Speichern der Daten verwendet ("Eingegebener Pfad\Rechnername\Projektname").
Achtung: Falls der eingegebene Pfad nicht existiert (Netzwerkprobleme, Wechseldatanträger nicht vorhanden), werden von der Runtime keine Daten mehr geschrieben. Das bedeutet: 100% Datenverlust. Die Runtime bleibt bedienbar, muss aber neu gestartet werden. Die Verfügbarkeit des Ordners kann mit der Systemtreibervariablen Runtime Datenordner nicht verfügbar überprüft werden.
Tipp: Setzen Sie den Datenordner nie auf ein entfernbares Laufwerk, wie einen USB Stick oder ein Netzlaufwerk. Daten am besten lokal aufzeichnen und extern sichern

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Dateistruktur

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Tipp: Setzen Sie den Datenordner nie auf ein entfernbares Laufwerk wie einen USB Stick oder ein Netzlaufwerk. Daten am besten lokal aufzeichnen und extern sichern

Achtung: Falls der angegebene Pfad nicht existiert oder nicht ansprechbar ist, werden von der Runtime keine Daten mehr geschrieben. Das bedeutet: 100% Datenverlust. Die Runtime bleibt bedienbar, muss aber neu gestartet werden, sobald der Pfad wieder verfügbar ist. Die Verfügbarkeit des Ordners kann mit der Systemtreibervariablen Runtime Datenordner nicht verfügbar überprüft werden.


Freie Ports

Handbuch -> Installation und Updates -> Systemvoraussetzungen -> Freie Ports

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon und zenon Logic benötigen für die Kommunikation im Netzwerk bestimmte Kommunikationsports. Wenn andere Programme, wie z. B. bereits installierte SQL-Server, diese Ports belegen, kann dies die Kommunikation von zenon stören.

So übeprüfen Sie die Belegung der Ports:

  1. Geben Sie auf der Komandozeile netstat -a -n -o ein.

    Die Kommandozeile erhalten Sie unter Windows mit:

    • Windowstaste+R
    • geben Sie cmd ein und bestäigen Sie mit OK
    • ein DOS-Eingabefenster öffnet sich
    • geben Sie hier den netstat Befehl ein
  2. Sie erhalten eine Liste mit allen aktiven TCP/IP und UDP Ports.
  3. Überprüfen Sie bei den abhörenden Ports (Status: ABHÖREN) ob für die von zenon und zenon Logic benötigten Ports die Prozess-ID (PID) den Prozessen von zenon und zenon Logic entspricht.

    Diese PIDs finden Sie im Fenster Prozesse des Windows Task Managers; aktivieren Sie dazu im Menü Ansicht/Spalten auswählen die Spalte PID.

  4. Verwendet andere Software diese Ports, konfigurieren Sie diese Software um. In zenon können die Ports nicht verändert werden.

    In zenon Logic können die Ports frei definiert werden.

Portbelegung durch zenon und zenon Logic

Anwendung | Beschreibung | Port
stratonrt[k].exe | zenon Logic Runtime | 1200-1210 (veränderbar) 4500-4510 (veränderbar) 7000-7010 (veränderbar) 9000-9010 (veränderbar)
zennetsrv.exe | Netzwerkdienst | 1100-1100 (fix)
zensyssrv.exe | Transportservice | 1101-1101 (fix)
zendbsrv.exe | Datenbankdienst | 1103-1103 (fix)
zenAdminsrv.exe | Verwaltungsdients | 50777-50777 (fix)
zenvnc.exe | Remote Desktop Dienst | 5600-5600 (fix) 5610-5610 (fix)
CodeMeter.exe | Code Meter Dongel Dienst | 22350 (veränderbar, muss aber unverändert bleiben)
WkSvW32.exe | WibuKey Netzwerkdienst | 22347 (fix)


Pfade für Setup und im Betrieb

Handbuch -> Installation und Updates -> Pfade für Setup und im Betrieb

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Pfade für zenon:

  • Setup
  • Editor
  • Runtime

info Info

Viele Standardpfade können Sie sich mit dem set Kommando anzeigen lassen:

  • starten Sie die Kommandozeile (Eingabe cmd im Windows Startbereich)
  • geben Sie den Befehl set ein
  • mit Klick auf die Taste Eingabe werden Standardordner für Windows und zenon angezeigt

Hinweis: Da absolute Pfade sich in verschiedenen Betriebssystemen unterscheiden können, werden in diesem Kapitel Pfade immer als Windows Umgebungsvariablen angezeigt. Zum Beispiel %ProgramData% statt C:\ProgramData.

Setup

Beim Setup werden Pfade gesetzt für:

  • Prerequisits
  • zenon Editor
  • zenon SQL-Ordner

Nur die Pfade für zenon Editor und zenon SQL-Ordner sind anpassbar.
Das Setup benötigt Administratorrechte, das gilt auch für die Änderung der Installationspfade.

Prerequisits

Die Installationspfade der Prerequisits entsprechen den Standardpfaden der jeweiligen Hersteller und sind beim Setup nicht änderbar.

Welche Prerequisits installiert werden, hängt ab von der Installationsart:

  • zenon Editor
  • zenon Runtime
  • zenon Webclient
  • zenon Logic Runtime
Prerequisit | Editor | Runtime | Webclient | zenon Logic Runtime
Microsoft .NET Framework 3.5 Sp1 | + | + | - | -
Microsoft .NET Framework 4.0 | + | + | - | -
Microsoft Visual C++ 2005 Redistributables | + | + | - | +
Microsoft Visual C++ 2008 Redistributables | + | + | + | +
Microsoft SQL-Server 2005 Express (bis 6.51) | + | - | - | -
Microsoft SQL-Server 2008R2 SP1 Express (ab 7.00) | + | - | - | -
VSTA | + | + | - | -
OPC-Core Components (bis 6.22 SP1) | + | + | - | -
Wibu key Dongle Software 6.0 x86/x64 | + | + | - | -
COPA-DATA Multiple Network Protocol Driver x86/x64 | + | + | - | +
CodeMeter Dongle Software x86/x64 | + | + | - | -
DirectX Redistributables (ab 7.00) | + | + | - | -
Report Viewer 10.0 (ab 7.00) | + | + | + | -

zenon

Die Installation von zenon Editor setzt zwei Pfade:

  • zenon Editor:
    • 32-Bit Systeme: %ProgramFiles%\COPA-DATA\zenon [Version]
    • 64-Bit Systeme: %ProgramFiles(x86)%\COPA-DATA\zenon [Version]

    Diese Pfade können bei der Installation angepasst werden.

  • zenon SQL-Ordner:
    • bis Version 6.51: %ProgramData%\COPA-DATA\SQL\
    • ab Version 7.00: %ProgramData%\COPA-DATA\SQL2008R2\

    Diese Pfade können manuell über die zenDB.ini geändert werden.

zenon Editor

Im zenon Editor werden standardmäßig folgende Pfade benutzt:

Objekt | Pfad
Arbeitsplatz | %CD_USERDATA% Zum Beispiel: C:\Users\Public\Documents\zenon_Projects
Projekte | %CD_USERDATA% Zum Beispiel: C:\Users\Public\Documents\<CD_zenon_Projects Tipp für Tastenkombination: Projekt markieren -> Strg+Alt+D
SQL-Ordner des Projekts | %ProgramData%\COPA-DATA\[SQL-Ordner]\[UID]\FILES Tipp für Tastenkombination: Projekt markieren -> Strg+Alt+E
project.ini | %ProgramData%\COPA-DATA\[SQL-Ordner]\[UID]\FILES\zenon\system
zenon6.ini | %ProgramData%\COPA-DATA\System Zum Beispiel: C:\ProgramData\COPA-DATA\System
Sicherung | %ProgramData%\COPA-DATA\[SQL-Ordner]\UID]\BACKUP %ProgramData%\COPA-DATA\[SQL-Ordner\UID]\FILES\[Projekte]
Kompilierte Dateien | %CD_USERDATA%\[Arbeitsbereich]\[Projekt]\RT
Externe Dateien | %CD_USERDATA%\[Arbeitsbereich]\[Projekt]\RT\FILES\... Hinweis: Im Projekt einstellbar über Eigenschaft Dateiablage. Interne ID: Pfade für Setup und im Betrieb Dateiablage Der Konfigurationsdialog für die Projekt-Pfade wird geöffnet. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""
Systemdateien | Windows Systemordner.

<CD_PRO DUCTNAME>Runtime

Im zenon Editor werden standardmäßig folgende Pfade benutzt:

Objekt | Pfad
Projekte | %CD_USERDATA%\[Arbeitsbereich]\[Projekt]\RT
Externe Dateien | %CD_USERDATA%\[Arbeitsbereich]\[Projekt]\RT\FILES\...
Exportierte Archive, Chronologische Ereignislisten und Alarmmeldeliste | %CD_USERDATA%\[Arbeitsbereich]\[Projekt]\Export Hinweis: Wird bei erstem Export angelegt.
Systemdateien | Windows Systemordner.

zenon Logic

Pfade für zenon Logic werden analog zu den zenon Pfaden angelegt.


zenon Standardinstallation

Handbuch -> Installation und Updates -> zenon Standardinstallation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon startet automatisch seine Installationsroutine und führt Sie durch den gesamten Installationsvorgang. Alternativ starten Sie die Installation durch Ausführen der Datei start.exe im Wurzelverzeichnis Ihrer zenon DVD.

Wählen Sie die gewünschte, lizenzierte Version:

  • zenon Supervisor
  • zenon Energy Edition
  • zenon Pharma Edition
  • zenon Operator

Klick auf das entsprechende Symbol öffnet den entsprechenden Installationsdialog.

Hier finden Sie Optionen für:

  • zenon Entwicklungsumgebung:

    Installiert die zenon Entwicklungsumgebung (Editor und Runtime) auf Ihrem System.

  • zenon Runtime:

    Installiert nur die zenon Runtime auf Systemen, die keinen Editor benötigen.

  • zenon XPembeded:

    Öffnet eine ANleitung zur manuellen Installation der Runtime unter Windows XP embedded

  • zenon Webserver:

    Installiert den aktuellen zenon Webserver und Webclient

  • Dokumentation:

    Das komplette zenon Handbuch als PDF-Dokumente.

    Sie können die Hilfe auf der DVD öffnen oder auf Ihren Rechner kopieren. Über die Schaltfläche sel.kopieren kopieren Sie alle Dokumente, die Sie mittels Checkbox im Verzeichnisbaum markiert haben. Einzelne Dateien können nicht per Multiselect kopiert oder geöffnet werden.

  • Tools:

    Hier finden Sie PDF Reader, Treiber von Drittherstellern, XML-Editierprogramme, HTML Hilfe Workshop und weitere Tools, zum Beispiel zur Datenbankadministration.

  • Info:

    Zeigt Ihnen zenon Highlights, Neuerungen Ihrer zenon Version, COPA-DATA Unternehmenspräsentation, COPA-DATA Vertriebsnetz, Informationen zu zenon Logic und eine Übersicht zur Lizenzierung.

    Hinweis: Die Informationen liegen als Powerpoint-Präsentation vor und werden über einen auf der DVD integrierten Viewer angezeigt. Beim ersten Start werden Sie aufgefordert, die Nutzungsbedingungen zu akzeptieren. Bitte bestätigen Sie diese, es wird dabei keine Software auf Ihrem Rechner installiert.

Demo-Projekt

Standardmäßig wird eine Demo-Projekt mitinstalliert, das Ihnen beispielhaft mögliche Einsatzszenarien in verschiedenen Branchen zeigt. Details dazu finden Sie im Handbuch im Abschnitt zenon Demo-Projekt.

Noch in diesem Kapitel

Fehlerbehandlung


Fehlerbehandlung

Handbuch -> Installation und Updates -> zenon Standardinstallation -> Fehlerbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollte die Installation nicht korrekt ablaufen, erhalten Sie eine Fehlermeldung. Für Hilfe durch das Technische Consulting der COPA-DATA:

  • erzeugen Sie über die entsprechende Schaltfläche eine zip-Datei
  • erstellen Sie nach Möglichkeit einen Screenshot der Fehlermeldung
  • schicken Sie Datei und Screenshot an support@copadata.com

Falls Sie das Meldungsfenster schon geschlossen haben, finden Sie die Log-Dateien mit den Installationsinformationen:

  • für 7.00:

    Vista/Windows 7: C:\Users\User.COPA-DATA\AppData\Local\Temp

    XP: C:\Dokumente und Einstellungen\Admin\Lokale Einstellungen\Temp

  • für SQL-Server:

    Vista/Windows 7: C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG

    XP: C:\Programme\Microsoft SQL Server\90\Setup Bootstrap\LOG

    Tipp: Die Datei Summary.txt gibt einen Anhaltspunkt, wo das Problem liegen könnte.

info Info

Firewalls: bei der Installation konfiguriert zenon automatisch die Soft-Firewall von Windows. Firewalls anderer Hersteller müssen vor der Installation vom Anwender korrekt konfiguriert werden.

Häufige Fehlerquellen bei der Installation:

  • Virenscanner ist aktiv und blockiert die Installation durch fehlerhaftes Erkennen von Viren. Lösung: Rechner vom Netzwerk abhängen, Virenscanner deaktivieren, Installation durchführen
  • Soft-Firewall wurde nicht korrekt konfiguriert. Lösung: Rechner vom Netzwerk abhängen, Firewall deaktivieren, Installation durchführen
  • Fehlerhafte SQL-Installation ist im System bereits vorhanden. Lösung: Projektbackups erstellen sofern noch möglich, SQL Server deinstallieren, SQL Verzeichnis umbenennen, Installation erneut starten.


zenon Runtime unter Windows XP Embedded

Handbuch -> Installation und Updates -> zenon Runtime unter Windows XP Embedded

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Installation der zenon Runtime auf einem System mit Windows XP Embedded müssen die Einschränkungen von Windows XP Embedded beachtet werden. Vor allem können das .NET Framework und damit auch VSTA auf Windows XP Embedded nicht installiert werden, da dies von Microsoft nicht unterstützt wird. Außerdem steht auf dem Speichermedium auf dem Laufwerk C:\ oft nicht genügend Platz für eine Standardinstallation zur Verfügung, der Microsoft Installer entpackt die Setup Dateien aber immer im Laufwerk C.

Die Installation von zenon muss daher als sogenannte administrative Installation ausgeführt werden.

Dazu erzeugen Sie ein Verzeichnis mit den nötigen Installationsdateien und kopieren dieses auf einen Datenträger, der vom Zielsystem gelesen werden kann, zum Beispiel ein verbundenes Netzlaufwerk, CD, USB Stick, Flash Drive usw.

Vorbereitung administrative Installation

Sie finden alle benötigten Programme auf der zenon DVD:

  • DVD_ROOT\Setup\Setup_RT.exe
  • DVD_ROOT\Additional_Software\Visual C++ 2005 Redistributables\vcredist_x86.exe
  • DVD_ROOT\Additional_Software\Visual C++ 2008 Redistributables\vcredist_x86.exe
  • DVD_ROOT\Additional_Software\Wibu Key Dongle Software x86\WkRt-Int.exe

Um den Installationsdatenträger vorzubereiten:

  • Führen Sie die Setup-Datei der Runtime auf der Kommandozeile mit dem Parameter /a aus.

    Die Datei befindet sich im Verzeichnis DVD_ROOT\Setup. Die Kommandozeile starten Sie unter Windows mit der Tastenkombination Windowstaste+R.
    Der Befehl lautet: DVD_ROOT\Setup\Setup_DEV.exe /a
    Beispiel: G:\Setup\Setup_DEV.exe /a

  • Ein Assistent führt Sie durch die Erstellung des Setups. Dabei haben Sie die Wahl der Sprache für die Erstellung des Setups. Für die spätere Installation unter Windows XP Embedded ist nur Englisch als Sprache verfügbar.
  • Geben Sie während der Erstellung des Setups ein Zielverzeichnis an.
  • In dieses Verzeichnis werden alle für die zenon Runtime benötigten Installationsdateien entpackt.
  • Kopieren Sie das erstellte Verzeichnis auf einen Datenträger, der vom Zielsystem gelesen werden kann.
  • Kopieren Sie auch die Dateien vcredist_x86.exe und WkRt-Int.exe aus den jeweiligen DVD-Verzeichnissen auf den Datenträger für die Installation.
  • Auf dem Zielsystem müssen mindestens 512 MB freier Speicherplatz für die Runtime plus 256 MB auf der C‑Partition zur Verfügung stehen plus Speicherplatz für die Projekte.

Adminstrative Installation auf Windows XP Embedded

Installieren Sie die Dateien in folgender Reihenfolge auf dem Zielsystem

  1. Microsoft Visual C++ 2005 Redistributables
  2. Microsoft Visual C++ 2008 Redistributables
  3. WIBU-KEY Dongle Software bzw. Code Meter Dongle Software
  4. 7.00 Runtime

Installation der Microsoft Visual C++ Redistributables

Führen Sie die Datei vcredist_x86.exe vom erstellten Installationsmedium aus und folgen Sie den Anweisungen des Assistenten. Sollten die Microsoft Visual C++ Redistributables bereits auf dem System vorhanden sein, werden Sie gefragt, ob sie die vorhandene Installation reparieren oder entfernen möchten.

Installation der 'WIBU-KEY' Dongle Software

Führen Sie die Datei WkRt-Int.exe vom erstellten Installationsmedium aus und folgen Sie den Anweisungen des Assistenten.

Hinweis: Bei einer reinen Softlizenzierung ist die Installation der Dongelsoftware nicht erforderlich.

Installation der zenon Runtime

Um zenon zu installieren, rufen Sie auf der Kommandozeile die Installationsdatei SCADA_xxx.msi mit den entsprechenden Parametern für Quelle und Ziel auf (xxx steht für die jeweilige Version von zenon):

%SOURCEPATH%\SCADA_xxx.msi SETUPEXEDIR="%SOURCEPATH%" LZ ="1" TYPE="RT" /l*v "%TEMP%\scada.log"

Parameter | Beschreibung
%SOURCEPATH% | Quelle für Installationsdateien wie z. B. verbundenes Netzwerklaufwerk, USB-Speicher usw.
SETUPEXEDIR | Ordner, der die Setupdatei enthält, entspricht %SOURCEPATH%
l*v | Aktiviert das Logging der Installation. Wichtig für die Fehlersuche nach einer unvollständigen Installation.
%TEMP% | Temporäres Verzeichnis, in das die Log-Datei geschrieben wird. Dieses muß existieren.
LZ= | Aktiviert Lizenztool 0 = ohne Lizenztool 1 = mit Lizenztool Fehlt der Eintrag, wird die installation ohne Lizenztool gestartet.
TYPE= | RT = Runtime Installation ED = Editor Installation (default)

Example Beispiel

X:\Setup_RT\SCADA_xxx.msi SETUPEXEDIR="X:\Setup_DEV" /l*v "c:\temp\scada.log"

Parameter | Beschreibung
X:\Setup_DEV | Netzwerkpfad mit Installationsdateien
scada.log | Name der Log-Datei
c:\temp | Ablagepfad der Log-Datei

info Info

Wird während der Installation nach der Datei cdprotdrv.sys gefragt, so finden Sie diese auf dem Daternträger mit den Installationsdateien im selben Pfad wie die SCADA_xxx.msi im Verzeichnis \program files\COPA-DATA\zenonxxx\Profinet\DRV. Außerdem ist diese Datei auf dem Windows XP Embedded System im geichen Pfad \program files\COPA-DATA\zenonxxx\Profinet\DRV vorhanden.


zenon für Windows CE

Handbuch -> Installation und Updates -> zenon für Windows CE

Die PC-Version für Windows CE wird automatisch mit der zenon Runtime mit installiert.

Bestandteile

Die CE Version von zenon setzt sich aus folgenden Komponenten zusammen:

  • zenon CE Runtime
  • Sprach DLLs
  • Netzwerk DLL
  • Treiber DLLs
  • zenon6.ini
  • Transportservice

Voraussetzungen für Installation der Runtime auf Remote-Systemen

  • Die Versionen für PC und Windows CE von zenon müssen die gleiche Versionsnummer und das gleiche Service Pack aufweisen. CE muss am PC bereits installiert sein.
  • Auf dem CE Terminal muss der Transportservice (SysSrvCE.exe) von zenon installiert und gestartet sein oder eine ActiveSync-Verbindung bestehen. Hinweise zur manuellen Installation über Datenträger finden Sie im Kapitel Manuelle Installation und Runtime-Update.
  • Das CE Terminal, auf das die neuen Daten übertragen werden sollen, muss für den ordnungsgemäßen Transport über mindestens 8 Megabyte freien Speicher "Program Memory" verfügen. Dieser Parameter kann über das Control Panel Systemeigenschaften angepasst werden.

Vorgangsweise

Details zu Kompatibilität, Installation und Update finden Sie in den Kapiteln:

  • CE Versionen / Prozessorunterstützung
  • Update Windows CE Runtime

info Info

Die Runtime für Windows CE wird mit dem Remote Transport lizenziert. Wenn Sie die Verbindung zum Zielsystem aufbauen, können Sie die Seriennummer und die Lizenzierungsnummer für die CE Version eingeben. Die Seriennummer wird am CE Gerät in der Datei zenon6.ini gespeichert, die Aktivierungsnummer in der Registry.

info Info

Beim Start von zenonrce.exe wird auch die Datei syssrvce.exe ausgeführt. Diese stellt sicher, dass immer eine TCP-Verbindung aufgebaut werden kann. Damit werden lange Wartezeiten vermieden und es ist nur eine Datei für die Autostart-Funktionalität nötig.

Noch in diesem Kapitel

CE - Versionen und Prozessorunterstützung

Systemdateien

Update Windows CE Runtime

Manuelle Installation und Runtime-Update

Pocket PCs (PDA - Handheld PC)

Fehlerbehandlung


CE - Versionen und Prozessorunterstützung

Handbuch -> Installation und Updates -> zenon für Windows CE -> CE - Versionen und Prozessorunterstützung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der aktuellen zenon Version 7.00 werden folgende Windows CE Versionen und Prozessoren unterstützt:

  • CE 5.00 für x86
  • CE 5.00 für ARMV4/V5
  • CE 6.00 für x86
  • CE 6.00 für ARMV4/V5

info Info

Informationen zu unterstützten CE Versionen und Prozessoren für frühere zenon Version finden Sie in der jeweiligen Dokumentation oder erhalten Sie beim COPA-DATA Support.


Systemdateien

Handbuch -> Installation und Updates -> zenon für Windows CE -> Systemdateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime für Windows CE setzt das Vorhandensein unterschiedlichster Systemdateien voraus. Fehlt eine dieser Dateien, so erzeugt das Betriebssystem eine Fehlermeldung beim Starten der Runtime, dass eine oder mehrere Komponenten nicht gefunden wurden. Folgende Systemdateien sind unbedingt erforderlich:

Datei | Beschreibung
mfc90u.dll | Erforderlich für die Runtime. Es kommt eine Fehlermeldung beim Starten, wenn diese Datei nicht vorhanden ist.
msvcr90.dll | Erforderlich für die Runtime. Es kommt eine Fehlermeldung beim Starten, wenn diese Datei nicht vorhanden ist.
atl90.dll | Nicht erforderlich für das Starten der Runtime, aber für den Einsatz eines Treibers mit Netzwerkanbindung oder den Einsatz von zenon im Netzwerk. Wenn diese Datei nicht vorhanden ist, kann das Gerät nicht als Client fungieren bzw. funktionieren TCP/IP Treiberanbindungen nicht.
IMGDECMP.dll | Nicht erforderlich für das Starten der Runtime, aber erforderlich für die Darstellung von Transparenz, wenn Alpha Blending im Betriebssystem nicht integriert ist. Eine Animation ist bei GIF Dateien unter Windows CE nicht möglich.
VBSCRIPT.dll + JSCRIPT.dll | Nicht erforderlich für das Starten der Runtime. Diese Datei wird benötigt für die PCE (Process Control Engine).

Einige dieser Systemdateien werden mit der Installation von zenon für CE mit installiert und können z.B. mit dem UpdateCE Tool auf das CE Gerät übertragen werden. Alle diese Systemdateien sollten bereits vom Gerätehersteller in das Betriebssystem-Image des CE Geräts integriert werden.

attention Achtung

Für Hersteller von Windows CE Betriebsystemimages:
CE Versionen vor 6.0 benötigen die Datei toolhelp.dll. Damit die Datei am CE Gerät vorhanden und die Toolhelp.h im SDK auch verfügbar ist, aktivieren Sie im Platform Manager folgenden Eintrag:
Core OS -> Display Based Device ->Core OS Services -> Debugging Tools -> Toolhelp API. Hiermit ist die Toolhelp.dll im Image mit dabei.
Tipp: Verwenden Sie immer das aktuellste Servicepack des Platform Builder.

Hinweis: Die toolhelp.dll wird für Windows CE 6 nicht benötigt und soll mit CE 6 nicht verwendet werden.


Update Windows CE Runtime

Handbuch -> Installation und Updates -> zenon für Windows CE -> Update Windows CE Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Update der Windows CE Runtime durchzuführen:

  • stellen Sie sicher, dass der zenon Transport Service (SysSrvCE.exe) auf dem CE Gerät läuft
  • vergewissern Sie sich, dass sie keine Remote Verbindung mittels zenon Editor zum Gerät aufgebaut haben
  • wählen Sie im zenon Menü Optionen den Befehl Update Windows CE Runtime
  • der Dialog zur Übertragung von Runtime-Dateien öffnet sich
  • konfigurieren Sie die Verbindung
  • definieren Sie die zu übertragenden Dateien
  • wählen Sie die Version aus
  • starten Sie das Update

Verbindung konfigurieren

Die Verbindung zum Windows CE Gerät konfigurieren Sie in der Registerkarte Connection.

Parameter | Beschreibung
Serial | Einstellung für serielle Verbindung zum Windows CE Gerät, Port muss ausgewählt werden.
TCP/IP | Einstellungen für TCP/IP Verbindung zum Windows CE Gerät.
Adress | IP Adresse.
Name | Name.
Syssrvce.exe starts with these settings | Einstellung für Start der syssrvce.exe.
Serial | Aktiv: serielle Verbindung wird gewählt, Port muss ausgewählt werden.
TCP/IP | Aktiv: TCP/IP Verbindung wird gewählt.
Connection with MS ActiveSync | Einstellungen zur Verbindung über MS ActiveSync
Use MS ActiveSync for initial transport of syssrvce.exe | Aktiv: syssrvce.exe wird beim ersten Transport über MS ActiveSync übertragen.
Destination folder | Zielordner.
Help | Öffnet die Online-Hilfe
Save | Speichert alle Änderungen.
Exit | Schließt das Update CE Tool und bietet zuvor das Speichern noch nicht gesicherter Änderungen an.

Zu übertragende Dateien definieren

Parameter | Beschreibung
Files to update | Dateien, die übertragen werden sollen.
HMI Runtime | Aktiv: Überträgt zenon Dateien zum Zielgerät. Default: aktiv
PLC Runtime | Aktiv: Überträgt zenon Logic Dateien zum Zielgerät. Default: inaktiv
OS system files | Aktiv: Überträgt nötige Dateien des Betriebssystems. Default: aktiv
Update zenon6.ini | Überträgt die zenon6.ini zum Zielgerät. Damit werden auch die Lizenzinformationen am Zielgerät geändert.
Options |
Language | Gewünschte Sprache am Zielsystem. Default: English
HMI drivers | Auswahl der zu übertragenden HMI Treiber.
Availabel | Liste der zur Verfügung stehenden Treiber.
Selected | Liste der ausgewählten Treiber.
Add | Fügt markierte Treiber zur Liste der ausgewählten Treiber hinzu.
Add all | Fügt alle Treiber zur Liste der ausgewählten Treiber hinzu.
Remove | Löscht markierte Treiber aus der Liste der ausgewählten Treiber.
Remove all | Löscht alle Treiber aus der Liste der ausgewählten Treiber.
Help | Öffnet die Online-Hilfe
Save | Speichert alle Änderungen.
Exit | Schließt das Update CE Tool und bietet zuvor das Speichern noch nicht gesicherter Änderungen an.

Version auswählen

Wählen Sie in der Registerkarte Versions die passende Version aus, falls sie nicht automatisch erkannt wurde.

Parameter | Beschreibung
WinCE version | Version des Windows CE Betriebssystems am Zielgerät. Klick auf Schaltfläche öffnet Dropdownliste zur Auswahl.
Processor type | Prozessor des Geräts.
Source path | Pfad zum Ordner, der die Dateien enthält. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl des Ordners.
New | Fügt neuen, leeren Eintrag in Liste ein.
Delete | Löscht den ausgewählten Eintrag aus der Liste,
Test | Überprüft Einstellungen.
Help | Öffnet die Online-Hilfe
Save | Speichert alle Änderungen.
Exit | Schließt das Update CE Tool und bietet zuvor das Speichern noch nicht gesicherter Änderungen an.

Update starten

Um die Verbindung herzustellen:

  • klicken Sie in der Registerkarte Update auf die Schaltfläche Start.

  • die Daten für die Übertragung werden überprüft und in einem Fenster angezeigt
  • starten Sie mit einem Klick auf die Schaltfläche Next die Übertragung zum Zielgerät

Falls die Übertragung aufgrund fehlender Dateien nicht gestartet werden kann, erhalten Sie eine Fehlermeldung mit der Liste der fehlenden Dateien:

  • Falls Sie die Fehlermeldung "The current update was not completed" erhalten, wurde die Installation unterbrochen oder nicht korrekt beendet.

info Info

Soll zenVNCServer.exe per Update ersetzt werden, wird dieser beendet und nach dem Update wieder gestartet. Dazu muss die Datei zenVNCSrvCE.exe in der

UpdateCE.ini im Abschnitt [SOURCES_FILES_GENERAL]folgende Einträge enthalten (per default vorhanden):

  • zenVNCSrvCE.exe
  • zenVNCCfgCE.exe


Manuelle Installation und Runtime-Update

Handbuch -> Installation und Updates -> zenon für Windows CE -> Manuelle Installation und Runtime-Update

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Installation und Update sind auch ohne Remote Transport und ActiveSync möglich. Dazu werden die erforderlichen Dateien manuell auf eine Speicherkarte für das CE Gerät kopiert. Dafür müssen Sie CE Version und Prozessortyp das CE Geräts kennen.

Folgende Dateien müssen zwingend aus dem jeweiligen Verzeichnis für die richtige Plattform auf die für das CE Gerät bestimmte Speicherkarte kopiert werden:

  • zenonRCE.exe (Runtime)
  • LogCliLibCE.dll (Diagnose dll)
  • zenon6.ini (Konfigurationsdatei)
  • Cd_tooCE.dll (Hilfsdll)
  • ZenNetSrvCE.dll (Netzerk)
  • Eine der folgenden Sprach dlls: RChineCE.dll, RCzechCE.dll, REngliCE.dll, RFrancCE.dll, RGermaCE.dll, RItaliCE.dll, RRussiCE.dll, RSpaniCE.dll (Die ausgewählte Sprache wird in der Datei zenon6.ini festgelegt.)
  • syssrvce.exe (Transportservice und Diagnose Server)
  • atl90.dll (Systemdatei, ev. im Betriebssystem enthalten)
  • mfc90u.dll (Systemdatei, ev. im Betriebssystem enthalten)
  • msvcr90.dll (Systemdatei, ev. im Betriebssystem enthalten)

Weitere Dateien wie zum Beispiel die Treiber oder die Remotedesktopsoftware (zenVNCCfgCE.exe und zenVNCSrvCE.exe) sind optional.


Pocket PCs (PDA - Handheld PC)

Handbuch -> Installation und Updates -> zenon für Windows CE -> Pocket PCs (PDA - Handheld PC)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Pocket PCs werden ab Version 7 nicht mehr unterstützt.


Fehlerbehandlung

Handbuch -> Installation und Updates -> zenon für Windows CE -> Fehlerbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mögliche Fehler:

Fehler | Mögliche Lösung
Verbindungsfehler bei Update über COM. | Geöffneter Windows Explorer verzögert die Zugriffszeit. Explorer schließen behebt das Problem.
Transportservice funktioniert nicht. | Version des Transportservice überprüfen. Mindestens: Version 5.21 SP3 oder höher bzw. der Version 5.50 SP1 oder höher.
Runtime Update Programm kann keine Verbindung aufbauen. | Beenden Sie offene Verbindungen des Editors zum CE Transportservice.


zenon Logic Runtime für Windows CE

Handbuch -> Installation und Updates -> zenon Logic Runtime für Windows CE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Installation der zenon Logic Runtime (PLC Runtime) auf einem Windows CE System läuft ähnlich ab wie die Installation der Runtime für Windows CE.

Voraussetzung: Lauffähiger Transportservice unter CE.

Die zenon Logic Runtime für Windows CE setzt sich aus folgenden Komponenten zusammen:

  • zenon Logic Runtime
  • Sprach DLL
  • zenon Logic IO Treiber
  • zenon6.ini

Installation

  • Wählen Sie im zenon Menü Optionen/Update Windows CE Runtime.
  • Der Dialog zur Übertragung von Runtime-Dateien öffnet sich.
  • Aktivieren Sie im Fenster Files die Checkbox PLC Runtime, um die für zenon Logic nötigen Dateien in das CE Ausführungsverzeichnis zu kopieren.
  • Wechseln Sie zur Registerkarte Connection.

  • Definieren Sie die Verbindung zum Windows CE Gerät. Geben Sie die IP-Adresse oder den seriellen Port an.
  • Falls auch die zenon6.ini übertragen werden soll, wählen Sie Update zenon6.ini aus. Damit werden auch die Lizenzinformationen am Zielgerät geändert.
  • Wählen Sie im Fenster CE Runtime versions die passende Version aus, falls sie nicht automatisch erkannt wurde.

Update

Funktioniert wie im Kapitel Update Windows CE Runtime beschrieben.

Achtung: In der Registerkarte Files muss die Option PLC Runtime aktiviert werden!

info Info

Unter Windows CE 6.0 werden die MFC-Dateien immer übertragen


zenon Webserver

Handbuch -> Installation und Updates -> zenon Webserver

Um den zenon Webserver oder Webserver Pro zu installieren:

  1. Aktivieren Sie die WWW-Dienste auf dem Rechner.

    Der Ordner C:\inetpub\wwwroot muss existieren.

  2. Legen Sie die zenon DVD in das Laufwerk ein, der Startbildschirm wird angezeigt.

    Falls Sie Autostart von CD/DVD deaktiviert haben, führen Sie die start.exe auf der CD aus.

  3. Wählen Sie zenon Webserver aus.
  4. Folgen Sie der Installationsroutine.
  5. Starten Sie den Computer neu.

Die Setup-Dateien für den Webclient finden Sie nach der Installation in Unterverzeichnissen des Webserver-Installationspfades (xxx steht für die jeweilige Version von zenon), z.B.: C:/Programme/COPA-DATA/zenonWebServer/zenon/controlversions/Versionxxx/zenon_WEB_Client_Setup_GERMAN.EXE
oder

C:/Inetpub/wwwroot/zenon/controlversions/Versionxxx/zenon_WEB_Client_Setup_GERMAN.EXE

Es werden auch die Beispiel-Webseiten (index*.html und init*.html) mitinstalliert. Diese sind im Unterverzeichnis zenon des Webserver-Installationspfades zu finden, z.B.:
C:/Programme/zenonWebServer/zenon/index.htm
oder
C:/Inetpub/wwwroot/zenon/index.html

info Info

Der Dienst für den zenon Webserver wird nur in der lizenzierten Version automatisch gestartet. Im Demo-Modus muss der Webserver manuell über die Webserver-Konsole in den Systemeigenschaften gestartet werden.

Weiterführende Informationen

Details zum Webserver lesen Sie im Handbuch Web Server und Web Server Pro, zur Lizenzierung im Handbuch Lizenzierung.


zenon Webclient

Handbuch -> Installation und Updates -> zenon Webclient

Der zenon Webclient besteht vor allem aus einem ActiveX Control, das Informationen in einem Browser darstellt. Die Darstellung erfolgt dabei 1:1 wie bei einem normalen Client. Die Verbindung zum Runtime Server erfolgt über den zenon Webserver mittels TCP/IP Kommunikation.

Die Setup-Dateien für den Webclient finden Sie nach der Installation in Unterverzeichnissen des Webserver-Installationspfades (xxx steht für die jeweilige Version von zenon), z.B.: C:/Programme/COPA-DATA/zenonWebServer/zenon/controlversions/Versionxxx/zenon_WEB_Client_Setup_GERMAN.EXE
oder

C:/Inetpub/wwwroot/zenon/controlversions/Versionxxx/zenon_WEB_Client_Setup_GERMAN.EXE

Alle Webclient-Setups sind digital signiert und können problemlos auch im Internet zum Download bereit gestelllt werden. Weitere Webclient-Setups finden Sie auf der zenon Webserver CD im Verzeichnis Web Client Versions. Für jede Version stehen auch entsprechende Sprachversionen zur Verfügung.

info Info

Der WEB Client sendet Error- und Log-Files. Der nötige Diagnose Server wird bei einer Installation des WEB Client mitinstalliert.


Updates (Build Setups), Service Packs und Upgrades

Handbuch -> Installation und Updates -> Updates (Build Setups), Service Packs und Upgrades

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Update (Build Setup)

Ein Update wird über die bestehende Installation installiert und ersetzt nur geänderte Dateien durch neue Versionen. Alle Projekte und individuellen Einstellungen bleiben erhalten. Beachten Sie, dass Build Setups nie zu 100% qualitätsgesichert sind. Es werden nur die enthaltenen Fehlerbehebungen getestet. Sollten durch eine Fehlerbehebung unerwünschte Nebeneffekte auftreten, können diese unter Umständen bei den Tests nicht auffallen. COPA-DATA empfiehlt daher immer den Einsatz von Service Packs. Diese durchlaufen immer den kompletten Qualitätssicherungsprozess.

Service Pack

Service Packs enthalten immer eine komplette Version von zenon. Es werden also nicht einfach Dateien ausgetauscht, sondern die Installationsroutine entfernt die bisherige Version und installiert die neue. Bei der Installation eines Service Packs bleiben alle Ihre Projekte und individuellen Einstellungen erhalten. Projekte werden bei der Installation nicht in die neue Version konvertiert. Erst beim ersten Öffnen im Editor erfolgt die Konvertierung des jeweiligen Projektes in die neue Version. Eine Dialogbox weist auf den Vorgang hin. Die bisherige Version wird automatisch gesichert.

Ein Service Pack beinhaltet immer alle Fehlerbehebungen aller vorangegangenen Build-Setups.

Upgrade

Wenn Sie eine neue Version von zenon installieren möchten, starten Sie die Installationsroutine. Bei der Installation wird die neue Version parallel zur bisherigen Version installiert. Alle Ihre Projekte und individuellen Einstellungen bleiben erhalten. Projekte werden bei der Installation nicht in die neue Version konvertiert. Erst beim ersten Öffnen im Editor erfolgt die Konvertierung des jeweiligen Projektes in die neue Version. Eine Dialogbox weist auf den Vorgang hin. Die bisherige Version wird automatisch gesichert. Möchten Sie nur die jeweils aktuellste Version verwenden, deinstallieren Sie die Vorgängerversion über die entsprechende Routine der Windows Systemsteuerung.

attention Achtung

Wenn ein Updgrade den Wechsel des SQL Servers mit sich bringt (z. B. Update von zenon 6.51 auf zenon 8.2), muss vor der Installation eine Sicherung aller Projekte oder des Arbeitsplatzes erfolgen. Diese Sicherung wird nach der Installtion wieder eingespielt. Details zur Vorgehensweise siehe auch Abschnitt Mehrbenutzer-Projekte/Update mit Wechsel des SQL Servers.

Möchten Sie mehrere Versionen von zenon parallel betreiben, so managen Sie diese über das Startup Tool. Es kann immer nur jeweils eine Version gestartet werden. Welche Version gestartet wird, legen Sie im Startup Tool fest, das beim Start alle nötigen Einstellungen automatisch vornimmt. Details dazu lesen Sie im Kapitel Startup Tool.

info Info

Neue Versionen (Service Pack, Upgrade) bringen immer strukturelle Änderungen mit sich. Bei der Installation bleiben die Projekte und Einstellungen erhalten. Beim ersten Öffnen im Editor werden Projekte in die neue Version konvertiert, gleichzeitig wird eine automatische Sicherungskopie der alten Version erstellt.

Konvertierte Projekte können in Vorgängerversionen nicht mehr bearbeitet werden. Ab Version 6.2 kann der Editor Projekte für unterschiedliche Runtime-Versionen erzeugen.

Wichtige Hinweise zur Konvertierung von Projekten finden Sie im Revisionstext. Dieser wird mit dem Service Pack/Update auf der Installations-DVD im Bereich Information ausgeliefert und steht Ihnen auch online zur Verfügung.

Mehrbenutzer-Projekte

Um den Wechsel zu einer neuen zenon Version in Mehrbenutzer-Projekten ohne Datenverlust zu gewährleisten:

  1. Auf allen Clients alle ausgecheckten Elemente einchecken -> Änderungen übernehmen.
    Es darf nichts mehr ausgecheckt sein. Dies gilt für alle Projekte.
  2. Am Server-Rechner die neue zenon Version installieren.
  3. Alle Server-Projekte in die neue Version konvertieren: Dazu alle Projekte auf dem Server-Rechner im Editor einmal laden.
  4. Die neuen zenon Version auf den Client-Rechnern installieren.
  5. Projekte auf Clients laden und neu auschecken.

Update mit Wechsel des SQL Servers

Wenn ein Upgrade den Wechsel des SQL Servers mit sich bringt (z. B. Upgrade von zenon 6.51 auf zenon 8.2), sind weitere Schritte nötig. Diese Schritte werden durchgeführt:

  • nachdem alle Projekte eingecheckt wurden
  • bevor die neue Version installiert wird

Ablauf beim Wechsel des SQL Servers:

  1. checken Sie auf allen Clients alle ausgecheckten Elemente ein -> Änderungen übernehmen.
  2. öffnen Sie am Mehrbenutzer-Server den Editor in der Ausgangsversion
  3. erstellen Sie Sicherungen aller Projekte, die Sie mit der neuen Version bearbeiten oder öffnen möchten
    • entweder als einzelne Projektsicherungen
    • oder als Sicherung des kompletten Arbeitsplatzes
  4. installieren Sie die neue Version auf dem Server
  5. konvertieren Sie alle Server-Projekte in die neue Version indem Sie die zuvor erstellten Projektsicherungen im Editor einmal laden
  6. installieren Sie das Update auf jedem Client
  7. übertragen Sie die Projekte vom Mehrbenutzer-Server aus auf die Clients
    (beachten Sie den neuen Namen der SQL Instanz)
  8. die Projekte sind konvertiert, synchronisiert und einsatzbereit

Achtung: Stellen Sie sicher, dass die Einstellungen der Firewall den Datenverkehr vom Mehrbenutzer-Server zu den Clients und umgekehrt zulässt.


FAQ

Handbuch -> Installation und Updates -> FAQ

Fehler bei der Installation treten vor allem auf, wenn das Ersetzen oder Erstellen von Dateien durch Virenscanner oder bereits vorhandene Installationen verhindert wird. Hier finden Sie die häufigsten Ursachen für Installationsfehler und deren Lösung.

zenon

Problem

Lösung

Installation wird abgebrochen.

Typische Fehlermeldung: Error 1304. Error writing to file...

Virenscanner deaktivieren, nicht benötigte Programme schließen.

Rollback nach OPCenum.exe - Fehler.

Eventuell können bereits vorhandene Teile des OPC-Servers nicht überschrieben werden.

  • Löschen Sie folgende Dateien:
    - C:\Windows\System32\OPC*.dll
    - C:\Windows\System32\OPCenum.exe
  • Löschen Sie den Ordner:
    C:\Programme\Gemeinsame Dateien\OPC Foundation
  • Löschen Sie alle Registry-Einträge, die opcenum enthalten.

Demo-Projekte wurden installiert, werden aber nicht angezeigt. Neue Projekte können nicht angelegt werden.

Überprüfen Sie den Rechnernamen. Dieser:

  • darf maximal 15 Zeichen lang sein
  • muss den Konventionen der NetBIOS Computernamens entsprechen

Fehlermeldung, dass ein Dienst nicht gestartet werden konnte.
  • starten Sie erst den Rechner neu
  • starten Sie dann das zenon Setup neu

SQL Server 2008

Problem

Lösung

Der zenDBSrv kann keine Verbindung zur Datenbank herstellen.

Mögliche Ursachen:

  • Instanz des SQL Servers ist nicht korrekt oder läuft nicht.
  • Einträge in der zenDB.ini sind nicht korrekt.
  • Falsches Passwort.
  • zenDBCli.dll oder zenDBSrv wurden nicht korrekt registriert.

Logeintrag:

Invalid Connection Configuration: No SQL Server Instance!

In der zenDB.ini ist keine SQL Server Instanz für die Datenbankverbindung konfiguriert. Ohne Instanz kann der zenDBSrv sich nicht verbinden und beendet sich daher selbst.

SQL Server 2005

Problem

Lösung

SQL Server lässt sich nicht installieren.

Bei der Installation des SQL Servers werden folgende Komponenten mitinstalliert:

  • Microsoft SQL Server 2005
  • Microsoft SQL Server Native Client
  • Microsoft SQL Server VSS Writer
  • Microsoft SQL Server Setup Suport Files (English)
  • MSXML 6.0 Parser

Ist eine dieser Komponenten durch eine frühere Installation bereits vorhanden, kann die Installation fehlschlagen.

Kontrollieren Sie, ob zu installierende Komponenten bereits vorhanden sind und deinstallieren Sie diese.

Auch die Log-Datei des SQL Servers kann Anhaltspunkte für Fehlerursachen geben: Sie finden diese als summary.txt im Ordner C:\Programme\Microsoft SQL Server\90\Setup Bootstrap\LOG.

Fehlermeldung:
The sa password must meet SQL Server password policy requirements. For strong password guidelines, see Authentication Mode, in SQL Server Books Online.

Deaktivieren Sie das HP ProtectTool Credential Manager.

Fehlermeldung:
Die Installation des Microsoft SQL-Servers 2005 Express Edition + .Net Framework 2.0 ist fehlgeschlagen. Setup wird beendet.

Überprüfen Sie die Anforderungen des SQL Servers:

  • Speicher
  • Prozessor

WebClient 6.22
IPA findet die XSL Dateien nicht.

Erstellen Sie folgende fehlende Einträge in der Registry:

HKLM\SOFTWARE\COPA-DATA\DataDir

  • UserData
  • System
  • ProgramData_6220
  • ProgramDir_6220

Hinweis: Behoben ab 6.22 SP1

SQL Server lässt sich nicht installieren.

Wurde zenon deinstalliert, kann eine neuerliche Installation fehlschlagen, wenn bei der Deinstallation Ordner bestehen bleiben.

Lösung: Löschen oder umbenennen der Unterordner

  • Data
  • Template Data

im Ordner %program files%\Microsoft SQL Server\MSSQL.x\MSSQL.

SQL Server 2005 auf Toshiba Computer

Problem

Lösung

In der SQL Log-Datei (z.B. SQLSetup0006_AUTOTRONIC031_SQL.log), die während der Installation erstellt wird finden sich folgende Fehlermeldungen:

  • Error Code: 1067
    MSI (s) (48!3C) [09:25:30:515]: Product: Microsoft SQL Server 2005 Express Edition --
  • Error 29503. The SQL Server service failed to start. For more information, see the SQL Server Books Online topics, "How to: View SQL Server 2005 Setup Log Files" and "Starting SQL Server Manually."
    The error is (1067) The process terminated unexpectedly.
  • Error 29503. The SQL Server service failed to start. For more information, see the SQL Server Books Online topics, "How to: View SQL Server 2005 Setup Log Files" and "Starting SQL Server Manually."
    The error is (1067) The process terminated unexpectedly.

Ursache für diese Fehler ist meistens ein fehlender Schlüssel in der Windows Registry.
In diesem Fall:

  • Deinstallieren Sie alle SQL-relevante Software wie
    Microsoft SQL Server 2005, Microsoft SQL Server Native Client, Microsoft SQL Server Setup Support Files, Microsoft SQL Server Server VSS Writer, ...
  • öffnen Sie regedit
  • navigieren Sie zum Schlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servi ces\Tcpip\Parameters
  • führen Sie einen Rechtsklick auf Parameters aus
  • wählen Sie Neu -> Zeichenfolge
  • tippen Sie Domain als neuen Wert ein
  • drücken Sie die Taste Eingabe und beenden Sie Regedit
  • führen Sie die separate Installation des SQL Servers 2005 auf zenon DVD -> Additional_Software\SQL Server 2005 Express Edition aus
  • führen Sie dazu die Datei Install.bat aus
  • installieren Sie nach erfolgreicher Installation von SQL Server 2005 erneut zenon


Technische Unterstützung

Handbuch -> Installation und Updates -> Technische Unterstützung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Basic Support

Falls Sie Unterstützung bei der Installation benötigen, helfen Ihnen unsere Mitarbeiter im Technischen Consulting gerne.

Anwender mit Basic-Support erreichen die Hotline unter der E-Mail-Adresse support@copadata.com.

Advanced und Premium Support

Wenn Sie einen Wartungsvertrag Advanced oder Premium besitzen, nutzen Sie bitte die dort angegebene Telefonnummer oder E-Mailadresse. Falls Sie Ihren kostenlosen Wartungsvertrag Basic auf Advanced oder Premium erweitern möchten, beraten Sie unsere Vertriebsmitarbeiter (sales@copadata.com) gerne.


Keyblock Runtime Start

Handbuch -> Keyblock Runtime Start

Keyblock Runtime Start ist ein Programm, mit dem sowohl die zenon Runtime gestartet wird, aber auch alle Windows Systemtasten gesperrt werden. Tastenkombinationen wie Windows-Taste oder Strg+Alt+Entf haben dann keine Auswirkung mehr.

Diese Funktionalität ist dann erforderlich, wenn die zenon Runtime als "Shell" laufen soll. Benutzer können damit nicht mehr auf das Betriebssystem zugreifen, sondern nur mehr in der zenon Oberfläche arbeiten.
Voraussetzung dafür ist, dass die Projekteigenschaft Runtime-Titel auf Kein Titel (gesamter Schirm) gesetzt ist. Dann arbeitet zenon im Vollbildmodus und die Runtime kann nicht minimiert werden.

Interne ID: Keyblock Runtime Start

Runtime-Titel

Darstellung des Runtime-Hauptfensters.

kein Titel: Vollflächige Darstellung ohne Anzeige einer Titelleiste, .

Titel mit Min. und Max. Schaltfläche: Das Fenster kann in der Größe verändert und verschoben werden. Schließen ist nicht möglich (auch nicht über Kontextmenü, Aufgabenleiste oder die Tastenkombination Alt+F4). Rechtsklick auf Titelleiste öffnet Kontextmenü.

Titel mit System, Min. und Max. Schaltfläche: Das Fenster kann in der Größe verändert und verschoben, sowie per per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

Titel mit Systemmenü: Das Fenster kann verschoben und per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

Titel ohne Schaltflächen: Das Fenster kann verschoben und per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

Default: kein Titel

Achtung: Wenn diese Eigenschaft im Editor geändert wird, muss die Runtime neu gestartet werden. Nachladen alleine funktioniert nicht, da zur Übernahme das Hauptfenster der Runtime erst geschlossen und dann neu geöffnet werden muss.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Verwendung

Runtime-Dateien schützen


Verwendung

Handbuch -> Keyblock Runtime Start -> Verwendung

Um Keyblock Runtime Start zu nutzen:

  1. öffnen Sie im Windows Startordner unter COPA-DATA die zenon Tools
  2. wählen Sie Keyblock Runtime Start aus
  3. das Programm startet und startet automatisch die Runtime
  4. das Programm sperrt alle Zugriffe auf das Betriebssystem:
    • gesperrte Tastenkombinationen:

      Strg+Esc

      Alt+Tab

      Alt+Esc

      Alt+F4

      Windows-Taste
      Mit Sperre der Systemtasten wird auch die normale Bedienung von Bildlaufleisten während der Runtime mit der Maus blockiert. Diese Blockierung kann mit dem Kontextmenü umgangen werden.

    • Ausblendung der Systemsteuerung im Startmenü
    • Sperre der Taskleiste für Bedienung
    • Unterbinden von

      Ändern von Kennwörtern

      Beenden von Windows

      Abmelden

      Computer sperren

      Benutzer wechseln

    • Ausblendung aller Elemente im Taskmanager

info Info

Wird Keyblock Runtime Start mit dem Autostart Mechanismus des Betriebsystems gestartet:

  • ist zu beachten, dass das Autostart Verzeichnis benutzerspezifisch ist: Loggt sich ein anderer Benutzer ein, wird das Programm nicht ausgeführt.
  • kann durch Drücken der Taste Umschalt beim Betriebssystemstart das Abarbeiten der Autostart-Programme unterbunden werden.

Diese Sperrung lässt sich während der Runtime nicht umgehen. Wird die Runtime normal beendet, sind die System-Einschränkungen wieder aufgehoben. Soll die Runtime ohne dieser Einschränkungen bedienbar sein, muss die Runtime statt Keyblock Runtime Start gestartet werden.

attention Achtung

Achten Sie darauf, dass in Ihrem Projekt eine Möglichkeit zum Beenden der Runtime projektiert ist. Besteht keine Möglichkeit, die Runtime regulär zu beenden:

  • kann sie nur über das hardwaremäßige Ausschalten des Rechners beendet werden
  • bleiben auch nach dem Neustart alle Systemtasten blockiert

Um Systemtasten nach einem irregulären Beenden (zum Beispiel bei Stromausfall) wieder zugänglich zu machen:

  • starten Sie die die Runtime wieder mit Keyblock Runtime Start
  • beenden Sie die Runtime regulär über einen Beenden-Button


Runtime-Dateien schützen

Handbuch -> Keyblock Runtime Start -> Runtime-Dateien schützen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Zugang zu den Runtime-Dateien kann stark eingeschränkt und damit gut geschützt werden. Dabei wird nur einem einzigen Windows-Benutzer lesender und schreibender Zugriff auf den Runtime-Ordner gestattet. Alle anderen Windows Benutzer haben keinerlei Rechte im Runtime-Ordner, auch keine Leserechte. Bediener zur Runtime loggen sich als zenon Benutzer ein.

Um den Zugang zum Dateisystem zu beschränken:

  1. Erstellen Sie nur einen einzigen Windows-Benutzer (zum Beispiel: zenon_ADMIN), der zenon starten darf sowie Lese- und Schreibrechte im zenon Runtime-Ordner hat.
  2. Unterbinden Sie für alle anderen Windows-Benutzer den Zugriff auf den zenon Runtime-Ordner - inklusive Leserechte!
  3. Unterbinden Sie jeglichen Remote-Zugriff auf den Benutzer zenon_ADMIN.
  4. Sperren Sie jegliche Software für Fernwartung oder Remote-Zugang wie zenon Remote Desktop.
  5. Stellen Sie sicher, dass zenon nur gestartet werden kann, wenn dieser Benutzer (zenon_ADMIN) eingeloggt ist.
    Da andere Windows-Benutzer keine Leserechte haben, startet die Runtime nur im Kontext dieses Benutzers (zenon_ADMIN).
  6. Stellen Sie sicher, dass zenon als Shell läuft:
    1. erstellen Sie dazu einen zenon Autostart mit Keyblock Runtime Start
    2. aktivieren Sie die Eigenschaft Systemtasten sperren in der Gruppe Runtime Einstellungen der Projekteigenschaften

      Interne ID: Runtime-Dateien schützen

      Runtime Einstellungen

      Eigenschaften für das Runtime-Verhalten des Projekts.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Runtime-Dateien schützen

      Systemtasten sperren

      Aktiv: Systemtasten wie Alt+Esc, Strg+Esc, Alt+Tab, Alt-F4 etc. werden in der Runtime gesperrt.
      Inaktiv: Systemtasten werden nicht gesperrt.
      Default: inaktiv

      Mehr im Online-Handbuch

      Hinweis: Weitere Systemtasten können zur Runtime über Keyblock Runtime Start gesperrt werden.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    3. starten Sie zenon im Vollbildmodus: Eigenschaft Runtime-Titel auf Kein Titel setzen

      Interne ID: Runtime-Dateien schützen

      Runtime-Titel

      Darstellung des Runtime-Hauptfensters.

      kein Titel: Vollflächige Darstellung ohne Anzeige einer Titelleiste, .

      Titel mit Min. und Max. Schaltfläche: Das Fenster kann in der Größe verändert und verschoben werden. Schließen ist nicht möglich (auch nicht über Kontextmenü, Aufgabenleiste oder die Tastenkombination Alt+F4). Rechtsklick auf Titelleiste öffnet Kontextmenü.

      Titel mit System, Min. und Max. Schaltfläche: Das Fenster kann in der Größe verändert und verschoben, sowie per per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

      Titel mit Systemmenü: Das Fenster kann verschoben und per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

      Titel ohne Schaltflächen: Das Fenster kann verschoben und per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

      Default: kein Titel

      Achtung: Wenn diese Eigenschaft im Editor geändert wird, muss die Runtime neu gestartet werden. Nachladen alleine funktioniert nicht, da zur Übernahme das Hauptfenster der Runtime erst geschlossen und dann neu geöffnet werden muss.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    4. beachten Sie bei der Konfiguration auch Mehrmonitor-Systeme
    5. unterbinden Sie den Explorer-Start
    6. bieten Sie keine Dateiauswahldialoge an
      (in diesem Fall dürfen keine Funktionen, die vom Benutzer zur Runtime Dateiauswahl verlangen, projektiert werden)

Damit ist der Zugang zum zenon Dateisystem geschützt.


Keyboard

Handbuch -> Keyboard

Keyboards dienen bei zenon als virtuelle Tastaturen, die an Geräten ohne Hardware-Tastatur Eingaben zur Runtime ermöglichen. Keyboards werden mit einem Bild vom Typ Keyboard projektiert. zenon stellt automatisch generierte und vom Anwender projektierbare Keyboards zur Verfügung.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Automatisches Keyboard

Automatische Keyboards werden zum Beispiel bei Sollwertvorgaben vom System erzeugt und automatisch aufgeschaltet. Sie können vom Anwender nicht verändert werden. Selbst projektierte Keyboards können frei definiert werden.

Jedes Dynamische Element und jeder Wert im Rezeptgruppen-Manager bringt ein eigenes automatisches Keyboard mit.

Taskleiste zur Runtime

Wird zur Runtime ein Keyboard aufgeschaltet, bleibt es auch offen, wenn die Runtime minimiert wird. In der Taskleiste des Betriebsystems wird eine Dropdownliste für das Keyboard angezeigt.

attention Achtung

Individuell angepasste Bilder vom Typ Keyboard funktionieren unter Umständen mit dem Browser Mozilla Firefox nicht korrekt.

Ursache: Mozilla Firefox lädt neue Fenster im Hintergrund, ohne ihnen den Fokus zu geben. Individuell angepasste Keyboard-Bilder werden aber geschlossen, sobald sie den Fokus verlieren.

Lösung: Benutzen Sie einen anderen Browser wie z.B. Microsoft Internet Explorer, Apple Safari oder Google Chrome.

Automatische Keyboards sind nicht betroffen!

Hardware Tastaturen und virtuelle Keyboards im Mischbetrieb

Virtuelle Keyboards verhalten sich im Betriebssystem wie Hardware-Tastaturen. Wenn virtuelle Keyboards gemeinsam mit Hardware-Tastaturen eingesetzt werden, beeinflussen sich diese gegenseitig. Einstellungen auf der Hardware-Tastatur, z. B. Feststellung der Umschalttaste, wirken sich auf das virtuelle Keyboard aus und umgekehrt.

Beispiele:

  • Wird auf der Hardware-Tastatur die Feststelltaste für die Umschalttaste (Shift-Lock) gedrückt, gilt das auch für das virtuelle Keyboard. In diesem Fall wird auch die Zifferneingabe am Automatischen Keyboard abgeschaltet.
  • Wird auf der Hardware-Tastatur die Taste Num gedrückt, um den Ziffernblock auszuschalten, funktioniert auch der Tastenblock am virtuellen Keyboard nicht mehr.

Noch in diesem Kapitel

Bild vom Typ Keyboard anlegen

Tasten für Rezeptgruppen-Manager

Automatisches Keyboard


Bild vom Typ Keyboard anlegen

Handbuch -> Keyboard -> Bild vom Typ Keyboard anlegen

Um ein Bild vom Typ Keyboard anzulegen:

  1. wählen Sie im Kontextmenü im Knoten Bilder im Projektmanager den Befehl Bild neu
  2. wählen Sie in der Detailansicht des neuen Bildes in der Dropdownliste den Bildtyp Keyboard
  3. wählen Sie in den Eigenschaften der Gruppe Allgemein als Name ein vordefiniertes Keyboard oder vergeben Sie einen freien Namen:

    Interne ID: Bild vom Typ Keyboard anlegen

    Name

    Eindeutiger Name des Bildes.
    Default: Picture x (wobei x eine fortlaufende Zahl ist).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Bild vom Typ Keyboard anlegen

    Allgemein

    Allgemeine Eigenschaften des Bildes.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Achtung: Keyboardbilder mit reservierten Namen habe Vorrang vor selbst definierten Namen

  4. fügen Sie über das Menü Kontrollelemente die gewünschten Tastatur-Elemente hinzu
  5. Tipp: Wird ein Bild vom Typ Keyboard statt als Modaler Dialog über den ganzen Bildschirm aufgerufen, kann es vorkommen, dass Menüs verdeckt werden. Projektieren Sie in diesem Fall eine Funktion Schablone schließen, die Ihnen erlaubt, die geöffnete Keyboard-Schablone zu schließen.

    Interne ID: Bild vom Typ Keyboard anlegen

    Schablone schließen

    Diese Funktion schließt das aktuell geöffnete Bild einer ausgewählten Schablone.

    Mehr im Online-Handbuch

    Interne ID: Bild vom Typ Keyboard anlegen

    Modaler Dialog

    Aktiv: Solange das Bild in der Runtime geöffnet ist, können Elemente in einem anderen Bild nicht bedient werden (z.B für den Bildtyp “Login”). Bedient werden können allerdings Bilder, die aus dem modalen Bild heraus geöffnet wurden.
    Inaktiv: Andere Bilder können wie gewohnt bedient werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Verwenden Sie das Kontrollelement Sollwerteingabe nur für Keyboards, die zur Sollwerteingabe angelegt werden (SETVALUEKBD, SETSTRINGKBD). Es wird automatisch mit der Variablen des Dynamischen Elements, das den Sollwert erhalten soll, verbunden. Beim Einsatz mit normalen Keyboards kann es daher zu unerwünschten Ergebnissen kommen.

Für Keyboards die zur Sollwertvorgabe dienen, muss das Kontrollelement Sollwertvorgabe jedoch zwingend im Bild projektiert sein. Ansonsten ist keine Werteingabe und auch kein Sollwert absetzen möglich

Tastenbeschriftung

Die Beschriftung der Tastatur kann wahlweise frei definiert oder vom Betriebssystem übernommen werden. Aktivieren oder deaktivieren Sie dazu in den Eigenschaften des Bildes Automatische Beschriftung im Knoten Allgemein. Dabei gilt:

Interne ID: Bild vom Typ Keyboard anlegen

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  1. Aktiv:
    • Im Editor können Buchstaben, Zahlen und F-Tasten nicht mehr verändert werden, Funktionstasten wie Umschalt oder Tab können weiter individuell beschriftet werden.
    • Zur Runtime wird die Beschriftung der alphanumerischen Tasten von den Einstellungen des Betriebssystems übernommen.
  2. Inaktiv:
    • Die Beschriftung der Tasten kann im Editor angepasst werden.
    • Zur Runtime wird die alternative Beschriftung dargestellt.
  3. Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung der Eigenschaft Automatische Beschriftung.

Reservierte Namen

Für den Bildtyp Keyboard wurden folgende Namen reserviert:

Name

Beschreibung

DIALOGKBD

Ist ein Bild dieses Namens vorhanden, wird es zur Runtime immer dann geöffnet, wenn ein Dialog aufgeschaltet wird, z.B. Eingabe eines neuen Rezeptnamens im RGM.

Achtung: Das DIALOGKBD ist nicht für die Verwendung mit dem Kontrollelement Sollwerteingabe vorgesehen und auch nicht dafür geeignet. Die Benutzung in dieser Kombination kann zur Runtime zu Fehlern führen.

SETBOOLKBD

Ist ein Bild dieses Namens vorhanden, wird es zur Runtime immer dann geöffnet, wenn eine Eingabe für Binärvariablen erforderlich ist.

SETSTRINGKBD

Ist ein Bild dieses Namens vorhanden, so wird es zur Runtime anstelle der Standard-Eingabemaske für Stringvariablen verwendet.

SETVALUEKBD

Ist ein Bild dieses Namens vorhanden, so wird es zur Runtime anstelle der Standard-Eingabemaske für numerische Variablen verwendet. Das Kontrollelement Sollwerteingabe muss in die Tastatur eingefügt werden.

Achtung: Bei aktivierter Festelltaste können in einem Keyboard vom Typ SETVALUEKBD keine Eingaben gemacht werden, da statt der Zahlen, die entsprechenden Sonderzeichen eingegeben würden.
Ausnahme: Französische Tastaturen benötigen zur Zahleneingabe die Umschaltaste oder die Festelltaste.

Keyboardbilder mit reservierten Namen haben zur Runtime Vorrang vor anderen Keyboardbildern, auch vor dem Bild Automatisches Keyboard bei Touchbedienung.

attention Achtung

Ist im Projekt

  • ein Bild vom Typ Keyboard mit dem reservierten Namen DIALOGKBD vorhanden
  • und gleichzeitig eine Bild vom Typ Login
  • und ist die Eigenschaft Automatisches Keyboard in der Gruppe Touchbedienung aktiviert

    Interne ID: Bild vom Typ Keyboard anlegen

    Touchbedienung

    Eigenschaften für die Touchbedienung.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Bild vom Typ Keyboard anlegen

    Automatisches Keyboard

    Für Projekte mit Touchscreen.
    Aktiv: Es wird automatisch ein Keyboard Fenster aufgeschaltet, wenn eine Eingabe notwendig ist (z.B: beim Sollwert setzen oder einloggen).
    Inaktiv: Kein Keyboard Fenster wird geöffnet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

dann dürfen diese Bilder nicht auf der selben Schablone basieren.

Das DIALOGKBD würde in diesem Fall immer automatisch verwendet werden.


Tasten für Rezeptgruppen-Manager

Handbuch -> Keyboard -> Tasten für Rezeptgruppen-Manager

Unter Kontrollelemente -> RGM spezifisch finden Sie spezifische Kontrollelemente für den Rezeptgruppen-Manager :

Element

Beschreibung

Wert absetzen

Der Sollwert wird auf die Variable abgesetzt und das Keyboard wird geschlossen.

Rezept speichern

Das Rezept wird gespeichert und das Keyboard geschlossen.

Wert absetzen und Rezept speichern

Der Sollwert zur Variablen abgesetzt, das Rezept gespeichert und das Keyboard geschlossen.

{Wertanzeigen als 1} bis {Wertanzeigen als 32}

Tasten können mit Grenzwerten aus einer Reaktionsmatrix verknüpft werden. Dazu muss die betroffene Variable

  • mit einer Numerischen Reaktionsmatrix oder Stringreaktionsmatrix verknüpft sein und
  • „ist gleich" Zustände beinhalten

Zur Laufzeit werden belegte Tasten eingeblendet. Klick auf den Button schreibt verknüpften Wert als Vorschlag für den Rezeptwert ins Eingabefenster.


Automatisches Keyboard

Handbuch -> Keyboard -> Automatisches Keyboard

Automatische Keyboards werden vom System erzeugt und bei Eingaben zur Runtime automatisch aufgeschaltet. Sie können vom Anwender nicht verändert werden. Ist ein Keyboard mit dem reservierten Namen DIALOGKBD vorhanden, wird es anstelle des automatischen Keyboards aufgeschaltet.

Position definieren

Für das automatische Keyboard können Sie eine Bevorzugte Position und ergänzend eine Alternative Position definieren. Die Einstellungen dazu treffen Sie in den Eigenschaften des Projekts im Bereich Touchbedienung.

Interne ID: Automatisches Keyboard

Touchbedienung

Eigenschaften für die Touchbedienung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Automatisches Keyboard

Alternative Position

Eigenschaften für die alternative Position, an der das automatische Keyboard relativ zum ausgewählten Element geöffnet wird, wenn es an der bevorzugten Position nicht geöffnet werden kann.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Automatisches Keyboard

Bevorzugte Position

Eigenschaften für die bevorzugte Position, an der das automatische Keyboard relativ zum ausgewählten Element geöffnet wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Findet die Tastatur an der bevorzugten Position nicht genügend Platz, wird sie an der Alternativposition dargestellt. Reicht auch dort der Platz nicht aus, wird die Position vom System definiert. Die Positionen legen Sie über die Kombination von jeweils vier Werten fest.

Eigenschaft | Beschreibung
Horizontal Interne ID: Automatisches Keyboard Horizontal Horizontale Position des automatischen Keyboards für die bevorzugte Position. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Links (Default) positioniert die linke Ecke des Keyboards relativ zur linken oberen oder unteren Ecke des Elements. Rechts positioniert die rechte Ecke des Keyboards relativ zur rechten oberen oder unteren Ecke des Elements.
Verschiebung horizontal [Pixel] Interne ID: Automatisches Keyboard Verschiebung horizontal [Pixel] Horizontaler Abstand (in Pixeln) zum ausgewählten Element für die bevorzugte Position des automatischen Keyboards. Default: 2. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Horizontaler Abstand (in Pixeln) zum ausgewählten Element für die bevorzugte Position des automatischen Keyboards. Positive Werte verschieben die Tastatur nach rechts, negative nach links. Default: 2.
Vertikal Interne ID: Automatisches Keyboard Vertikal Vertikale Position des automatischen Keyboards für die bevorzugte Position. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Mit Oben (Default) oder Unten positionieren Sie die Tastatur oberhalb oder unterhalb des Elements.
Verschiebung vertikal [Pixel] Interne ID: Automatisches Keyboard Verschiebung vertikal [Pixel] Vertikaler Abstand (in Pixeln) zum ausgewählten Element für die bevorzugte Position des automatischen Keyboards. Default: 2. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Vertikaler Abstand (in Pixeln) zum ausgewählten Element für die bevorzugte Position des automatischen Keyboards. Positive Werte verschieben die Tastatur nach oben, negative nach unten. Default: 2.


Lizenzierung

Handbuch -> Lizenzierung

Um zenon als Editor und/oder Runtime einsetzen zu können, muss das Produkt lizenziert werden. Solange zenon nicht lizenziert wurde, läuft es im Demo Modus.

Um zenon zu lizenzieren:

  1. öffnen Sie Start -> Alle Programme -> COPA-DATA -> Licensing 7.00

    oder:

    öffnen Sie im zenonEditor Datei -> Allgemeine Konfiguration -> Produkt lizenzieren...

  2. der Dialog zur Eingabe der Lizenzdaten öffnet sich
  3. wählen Sie zenon Editor/Runtime
  4. geben Sie Seriennummer und AKtivierungsnummer ein

    Die Daten dazu finden Sie:

    • auf Ihrem Lizenzsschein
    • auf dem Lizenzaufkleber
    • in der Lizenzdatei License.txt

      Pfad Vista/7: C:\Users\Public\Documents\zenon_Projects\

      Pfad XP: C:\Dokumente und Einstellungen/All Users/Anwendungsdaten/COPA-DATA/zenon700

    Hinweis: Achten Sie bei der Eingabe auf Groß-/Kleinschreibung!

  5. nach dem Neustart des Editors/der Runtime nutzen Sie zenon mit der eingegebenen Lizenz

Dialog zur Lizenzierung

Parameter | Beschreibung
Editor/Runtime | Aktiv: Lizenz gilt für den zenon Editor und/oder die zenon Runtime.
Webserver | Aktiv: Lizenz gilt für den zenon Webserver.
Analyzer | Aktiv: Lizenz gilt für den zenon Analyzer.
Seriennummer | Seriennummer der Lizenz. Sollte bereits eine Lizenz vorhanden sein, wird deren Lizenznummer hier angezeigt.
Aktivierungsnummer | Aktivierungsnummer der Lizenz. Sollte bereits eine Lizenz vorhanden sein, wird deren Aktivierungsnummer hier angezeigt.
OK | Daten übernehmen und zenon beim nächstern Neustart mit dieser Lizenz starten.
Abbrechen | Eingaben verwerfen und zenon mit bisheriger oder ohne Lizenz nutzen.
Softlizenz anfordern | Öffnet Assistent zur Anforderung einer Softlizenz.

Noch in diesem Kapitel

Demo-Modus

Versionsinformation

Passende Lizenzgröße auswählen

Arten der Lizenzierung

Kommandozeilenparameter für Lizenzierungstool

Remote-Lizenzierung

Besonderheiten beim Server-Client-Betrieb


Demo-Modus

Handbuch -> Lizenzierung -> Demo-Modus

Wurde der Editor nicht lizenziert, läuft der Editor im Demo-Modus. Wurde die Runtime nicht lizenziert, läuft die Runtime im Demo-Modus.

Demo-Modus | Bedingungen
Editor: | Der Editor läuft die ersten 40 Starts 30 Minuten lang mit dem Hinweis, dass es sich um den Demo-Modus handelt. Ab dem 41. Start wird die Zeit auf 10 Minuten reduziert.
Runtime: | Eine nicht lizenzierte Runtime läuft 30 Tage oder 40 Starts, je nachdem welcher Wert zuerst erreicht wird. Ab dem 41 Start oder 31. Tag läuft die Runtime nur noch 10 Minuten.

Im Start-Bildschirm von Editor oder Runtime wird auf die Anzahl der verbleibenden Starts aufmerksam gemacht.


Versionsinformation

Handbuch -> Lizenzierung -> Versionsinformation

Welche Lizenz Sie aktuell nutzen und welche Module darin inkludiert sind, sehen Sie beim Start von zenon im Startbildschirm oder nach einem Klick auf Info über... im Menü Hilfe:

Parameter | Beschreibung
Editor Version | Versionsnummer des Editor.
Seriennummer | Seriennummer der Lizenz.
Aktivierungsnummer | Aktivierungsnummer der Lizenz.
Ablaufzeit (optional) | Bei befristeter Lizenz Information über Ablaufdatum der Lizenz.
Feld mit Modulen: | Information über lizenzierte Module.

Im Menu Hilfe lässt sich mit dem Eintrag Info über eine Dialogbox öffnen, die Information über die zenon Version und die Lizenzierung gibt.


Passende Lizenzgröße auswählen

Handbuch -> Lizenzierung -> Passende Lizenzgröße auswählen

Die Lizenzen für Editor und Runtime werden nach Anzahl der jeweils benötigten TAGs oder der IOs berechnet.

Berechnung über Tags

1 TAG entspricht 1 Variablen. Für die Ermittlung der Lizenzgröße wird die Summe der TAGs folgender Treiber herangezogen:

  • SPS-Treiber und Bus Treiber

Nicht gezählt werden Variablen von:

  • Intern Treiber
  • System Treiber
  • Mathematik Treiber
  • Simulator Treiber

Tags können Sie für Editor und Runtime jeweils in folgenden Abstufungen lizenzieren:

  • 64 TAGs
  • 128 TAGs
  • 256 TAGs
  • 512 TAGs
  • 1.024 TAGs
  • 2.048 TAGs
  • 4.096 TAGs
  • 8.192 TAGs
  • 16.384 TAGs
  • 65536 TAGs
  • unbegrenzt

Ein Lizenzupdate auf eine höhere Zahl von Tags ist jederzeit möglich.

Berechnung über IOs

Lizenzen können auch auf Basis von I/Os vergeben werden. Für die Ermittlung der Lizenzgröße wird die Summe der IOs folgender Treiber herangezogen:

  • SPS-Treiber und Bus Treiber

Nicht gezählt werden Variablen von:

  • Intern Treiber
  • System Treiber
  • Mathematik Treiber
  • Simulator Treiber

Berechnung

Datenart | Wertigkeit
1 Bit | 1 I/Os
1 Byte | 8 I/Os
1 WORD | 16 I/Os
1 DWORD | 16 I/Os
1 Float | 16 I/Os
1 String ( max. 64 Zeichen ) | 16 I/Os

Sollten Sie den gewünschten Datentyp in dieser Auflistung nicht finden, liegt das am ausgewählten Treiber. Manche Treibern haben eine spezifische Benennung der Datentypen. Nähere Informationen dazu finden Sie in der Treiberdokumentation des Treibers, den Sie verwenden. Diese finden Sie entweder in der Online Hilfe unter dem Knoten Treiber oder als PDF-Datei auf unserer CD/DVD oder zum Download auf unserer Website www.copadata.com.

Example Beispiel

96 binäre und 20 numerische Werte sollen in zenon visualisiert werden:

Multiplizieren Sie die 20 numerischen Werte mit 16 und erhalten so 320 I/Os. Diese addieren Sie zu den 96 binären Werten addieren. Als Ergebnis erhalten Sie 416 I/Os, die nun die Basis für die Auswahl der Lizenzgröße sind.

Anzeige in zenon

In der Statuszeile der Detailansicht der Variablen können folgende Informationen ausgelesen werden:

  • Wieviele I/Os werden derzeit verwendet
  • Wieviele I/Os sind lizenziert

Im Beispiel:

  • 3799/550/1: 3799 Einträge sind vorhanden, durch Filterung werden aber nur 550 angezeigt, ein Eintrag ist markiert.
  • Für Projekt 22730 ist eine unbegrenzte Anzahl von Variablen lizenziert.


Arten der Lizenzierung

Handbuch -> Lizenzierung -> Arten der Lizenzierung

Sie können zenon auf unterschiedliche Weise lizenzieren:

  • Softlizenzierung: Fragt beim Start des Editors oder der Runtime eine eindeutige PC-Identifikationsnummer ab.
    Merkmale:
    • Lizenz kann nicht entwendet werden
    • Lizenz ist rechnerbezogen
    • praktisch für Notebooks
  • Donglelizenzierung: Fragt beim Start des Editors oder Runtime einen Hardwaredongle an der parallelen oder USB-Schnittstelle ab.

    Dongles stehen Ihnen zur Verfügung als:

    • Dongle am Einzelplatz:
    • Netzwerkdongle: Auf einem zentralen Dongle im Netzwerk wird eine bestimmte Anzahl an Lizenzen aufgebucht, die gleichzeitig als concurrent use Lizenzen nutzbar sind.

    Merkmale für Dongels:

    • einfache Handhabung
    • Lizenz kann durch Umstecken von einem Rechner auf den anderen übertragen werden oder im Netzwerk genutzt werden
    • kein Problem bei Festplattendefekten

info Info

Ist keine gültige Lizenz vorhanden oder wurden alle verfügbaren Lizenzen im Netzwerk vergeben, dann startet der Editor oder die Runtime im Demo-Modus.

Noch in diesem Kapitel

Softlizenzierung

Donglelizenzierung


Softlizenzierung

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Softlizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Softlizenz weist einem Rechner eine eindeutige Identifikation zu. Dabei werden bestimmte Komponenten des Rechners überprüft. Diese Lizenz funktioniert immer nur auf einem bestimmten Rechner. Soll sie auf einen anderen Rechner übertragen werden oder ändern sich zu viele Komponenten des lizenzierten Rechners, muss sie neu ausgestellt werden.

Um eine Softlizenz zu erhalten:

  1. wählen Sie im Menü Datei: Allgemeine Konfiguration -> Produkt lizenzieren
  2. der Dialog zur Lizenzierung öffnet sich
  3. klicken Sie auf Softlizenz anfordern
  4. geben Sie die Seriennummer des Produkts ein
  5. klicken Sie auf Lizenzanforderung für Softlizenzierung
  6. geben Sie Ihre Kontaktdaten ein
  7. zum Versenden haben Sie zwei Möglichkeiten:
    1. automatisch
    • wählen Sie mit der Schaltfläche Senden an die gewünschte COPA-DATA Organisation
    • mit Klick auf OK wird die Lizenzanforderung über Ihr E-Mailprogramm versandt
    • über die Schaltfläche Drucken, können Sie Ihr Exemplar ausdrucken oder an ein verbundenes Faxgerät schicken
    1. manuell
    • klicken Sie auf die Schaltfläche Fertig stellen
    • die Lizenzanforderung wird als Textdatei gespeichert, ein Info-Fenster informiert Sie über Name und Speicherort
    • die Datei wird im Texteditor automatisch geöffnet
    • schicken Sie die Datei per E-Mail oder Fax an Ihren Vertriebspartner

Sobald Sie Ihre Lizenzdaten erhalten haben, öffnen Sie den Lizenzierungsdialog erneut und geben Sie Ihre Aktivierungsnummer ein.


Donglelizenzierung

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Donglelizenzierung wird ein Dongle bei einer Einzelplatzlizenz direkt am Rechner oder bei einer Netzwerklizenz auf einem Netzwerkrechner angeschlossen. zenon nutzt zwei Donglesysteme:

  • Wibu-Key
  • CodeMeter

Beide Systeme werden bei der Installation von zenon automatisch mitinstalliert. Anwender, die bereits mit Wibu-Key arbeiten, erhalten neue Lizenzen weiterhin für ihre Wibu-Key Dongles.

In der Regel sind bei lokal genutzten Dongles keine weiteren Einstellungen nötig. Der Einsatz von Netzwerkdongles kann individuelle Konfigurationen nötig machen. Diese nehmen Sie in der jeweiligen Dongle-Software vor. Details dazu lesen Sie in den Kapiteln Wibu-Key und CodeMeter.

Noch in diesem Kapitel

Wibu-Key

CodeMeter


Wibu-Key

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> Wibu-Key

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wibu-Key kann am Einzelplatz oder im Netzwerk eingesetzt werden. Der Dongle muss an einem USB Port oder Parallel Port am lokalen Rechner oder als Server auf einem Netzwerkrechner aktiv sein.

Um die Einstellungen des Sticks zu überprüfen:

  1. öffnen Sie die Systemsteuerung
  2. öffnen Sie WIBU-KEY
  3. wählen Sie den zu überprüfenden Stick am lokalen Rechner oder im Netzwerk

    um Server-Wibu-Boxen im Netzwerk aufzulisten, klicken Sie auf die Schaltfläche Einlesen

  4. überprüfen Sie, ob die Zahl in der letzten Spalte der zweiten Zeile identisch mit den Anfangsziffern des Sticks ist

Mehr zum Betrieb im Netzwerk lesen Sie im Kapitel Netzwerkdongle.

Noch in diesem Kapitel

Netzwerkdongle


Netzwerkdongle

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> Wibu-Key -> Netzwerkdongle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Wibu-Key im Netzwerk als Dongle einzusetzen, müssen Server und Client entsprechend konfiguriert sein:

  • Konfiguration Server
  • Konfiguration Client

attention Achtung

WibuyKey nutzt den Port 22347. Dieser Port ist fix eingestellt und kann nicht geändert werden. Beachten Sie:

  • Wird eine andere Firewall als die im Windows Betriebssystem integrierte Firewall verwendet, muss dieser Port frei gegeben werden, sofern sie den Wibu-Key als Netzwerkdongle nutzen möchten.

Noch in diesem Kapitel

Server einrichten

Client einrichten


Server einrichten

Server einrichten

Auf dem Dongleserver muss der Wibu-Key-Server laufen. Der Wibu-Key-Server kann entweder als Applikation (z.B. starten über Autostart) oder als Dienst konfiguriert werden.

Beim Installieren der Wibu-Key-Software müssen die Optionen

32 Bit WkNet/WkLAN Netzwerk Server

Installieren als NT Dienst mit Autostart

ausgewählt werden, damit der Wibu-Key-Server als Dienst installiert wird (empfohlen).

Um den Wibu-Key-Server als Applikation zu starten, muss eine Verknüpfung mit der Datei WkSvW32.exe im AUTOSTART von Windows angelegt werden.

Die Datei ist im Verzeichnis C:/Programme/WIBU-KEY/Server/ zu finden.


Client einrichten

Client einrichten

In der Systemsteuerung müssen für den Client einige Netzwerkeinstellungen gemacht werden. Unter Wibu-Key-Subsysteme wird ausgewählt, welche Art von Netzwerkzugang verwendet wird. Wir verwenden WkLan.

Unter Servername/IP-Adresse wird entweder der Name des Servers, seine IP-Adresse oder eine Maske für die IP-Adresse angegeben. Mit Suchen wird die Liste mit allen gefundenen Dongleservern gefüllt.

Die Einträge werden in der Reihenfolge der Liste abgearbeitet, und können auch kombiniert werden.

Steht als erster Eintrag ein bestimmter Server, wird überprüft, ob auf diesem Rechner der Dongleserverdienst läuft, und ob ein richtiger Dongle auf diesem Rechner ist (schneller!). Wird kein Dongle gefunden, und steht als weiterer Eintrag eine Filtermaske, werden alle Rechner im Netzwerk, deren IP-Adresse der Maske entspricht, überprüft.

Auf der Seite Inhalt sollte(n) dann der (die) Server mit den gefundenen Dongles angezeigt werden:


CodeMeter

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> CodeMeter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

CodeMeter kann am Einzelplatz oder im Netzwerk eingesetzt werden. Der CodeMeter USB-Stick muss an einem USB Port am lokalen Rechner oder als Server auf einem Netzwerkrechner aktiv sein. Die Firmware des Dongles muss mindestens Version 1.16 sein.

attention Achtung

Wird der Dongle im laufenden Betrieb entfernt, schließt sich der Editor. Der Editor öffnet sich dann im Demo-Modus bis eine gültige Lizenz erkannt wird.

Zur Konfiguration starten Sie die Administrationsanwendung CodeMeter Kontrollzentrum über: Windows Desktop -> Start -> Alle Programme -> CodeMeter -> CodeMeter Control Center.

Das CodeMeter Kontrollzentrum öffnet sich mit 3 Registerkarten:

Lizenz: enthält Informationen zu den gefundenen Dongles.

Ereignisse: Zeigt Anzahl der angeschlossenen Sticks, der Lizenz-Einträge, der gefundenen Firm-Items und alle Zugriffe auf den CodeMeter Runtime-Server an. Um die Einträge dauerhaft zu protokollieren, aktivieren Sie im Menü Datei den Eintrag Protokollierung.

Ausleihe: konfiguriert das Ausleihen von Lizenzen.

Lizenz

Parameter | Beschreibung
Lizenz | Listet alle aktiven CodeMeter Sticks auf
Name | Individueller Name des ausgewählten Sticks, kann über die Schaltfläche rechts davon vergeben werden.
Serien-Nr._ | Seriennummer des ausgewählten Sticks.
Version | Version der Firmeware des ausgewählten Sticks.
Status | Status des ausgewählten CodeMeter Sticks.
Deaktiviert | Der angeschlossene Stick ist deaktiviert und kann von keiner Anwendung verwendet werden.
Aktiviert solange angeschlossen | Der Stick ist aktiviert solange er angeschlossen ist, nach dem Entfernen vom PC wird er automatisch deaktiviert.
Aktiviert | Der Stick ist voll aktiviert und bleibt dies auch nach dem Entfernen. Empfohlener Status: Stellt sicher, dass bei Verlust des Sticks nicht von Unbefugten auf Lizenzen und persönlichen Daten (z.B.: CmPasswordManager) zugegriffen werden kann.
Lizenzaktualisierung | Startet den Assistenten zum Hinzufügen, Ändern und Löschen von Lizenzen.
Auswerfen | Gibt den Stick frei zum Entfernen.
Kennwort ändern | Ermöglicht das Ändern des Kennworts.
CodeMeter ist gestartet/CodeMeter ist gestoppt | Information, ob der CodeMeter Dienst läuft. Kann im Menü Aktion geändert werden.
WebAdmin | Startet den Webbrowser mit der Administrationsoberfläche für Netzwerkdongles. Dazu muss der Port 22350 offen sein, Details siehe Kapitel Administration Netzwerk.

Noch in diesem Kapitel

Zertifizierte Uhrzeit aktualisieren

Administration Netzwerk

Lizenz anfordern

Lizenz anpassen

Fehlerbehebung


Zertifizierte Uhrzeit aktualisieren

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> CodeMeter -> Zertifizierte Uhrzeit aktualisieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können die im Dongle gespeicherte zertifizierte Uhrzeit über die CodeMeter Zeitserver aktualisieren. Dazu benötigen Sie einen aktiven Internetzugang.

Um die Uhrzeit zu aktualisieren:

  1. Starten Sie den CodeMeter WebAdmin
  2. Überprüfen Sie Ihre Netzwerkeinstellungen:
    1. Sind die Proxy-Einstellungen im CodeMeter Webadmin korrekt?
    2. Sind Ihre Zugangsdaten aktuell?
  3. Navigieren zum Menü Inhalt -> CmStick
  4. Klicken Sie auf die Schaltfläche Aktualisieren.
  5. Sie erhalten einen Hinweis, dass damit alle Sticks aktualisiert werden.
  6. Klicken Sie auf OK.
  7. Sie erhalten eine Information über die durchgeführte Aktualisierung. Bei einer Fehlermeldung überprüfen Sie vor allem Ihre Zugangsdaten.


Administration Netzwerk

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> CodeMeter -> Administration Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Administration im Netzwerk starten Sie die WebAdmin-Oberfläche durch Klick auf die Schaltfläche WebAdmin im CodeMeter Kontrollzentrum. Detaillierte Informationen zu den einzelnen Einstellungen finden Sie in der CodeMeter WebAdmin-Hilfe. Sie erreichen diese über die Schaltfläche Hilfe im WebAdmin. Die wichtigsten Optionen und Hinweise finden Sie auch in diesem Dokument:

  • Verwaltung CodeMeter Sticks
  • Verwaltung Lizenzen
  • Lizenzdaten sichern
  • Einstellungen Netzwerk
  • Einstellungen Proxy

attention Achtung

Der CodeMeter WebAdmin nutzt den Port 22350. Beachten Sie:

  • Wird eine andere Firewall als die im Windows Betriebssystem integrierte Firewall verwendet, muss dieser Port frei gegeben werden.
  • Wird der Port geändert, kann die WebAdmin-Oberfläche nicht mehr gestartet werden, da der Port Teil der Adresse ist, z.B: http://localhost:22350/Content.html?BoxSerial=2-1355435

    In diesem Fall, ermitteln Sie über entsprechende Freeware-Tools oder mit Windows Bordmitteln den aktuell verwendeten Port und tragen diesen in die Adresszeile des Browsers statt 22350 ein. Ändern Sie danach im WebAdmin den Port wieder auf 22350.

Noch in diesem Kapitel

CodeMeter Sticks

Lizenzen

Netzwerk und Proxy


CodeMeter Sticks

CodeMeter Sticks

Der WebAdmin startet mit der Ansicht Inhalt/CmStick.

Hier wählen Sie in einer Dropdownliste den gewünschten Dongle, sehen dessen Daten und Status wie im Kontrollzentrum konfiguriert.

Parameter | Beschreibung
CmStick | Dropdownliste der erkannten Sticks.
Name | Zeigt den im Kontrollzentrum vergebenen Namen an.
Hardware | Hardwareversion des Sticks.
Erstes Laufwerk | Laufwerksinformationen zum Stick, Laufwerksgrößen nur bei Sticks mit Flashspeicher.
Status | Aktivierungsstatus wie im Kontrollzentrum definiert.
Zertifizierte Uhrzeit | Die im Stick gespeicherte zertifizierte Uhrzeit. Wird über die Schaltfläche Aktualisieren angepasst. Hinweis: Zum Aktualisieren über den CodeMeter Timeserver benötigen Sie einen aktiven Internet-Zugang. Achten Sie auf korrekte Netzwerkeinstellungen, vor allem auf aktuelle Zugangsdaten.
Box Zeit | Gespeicherte interne Zeit des Sticks.
System Zeit | Lokale Zeit des CodeMeter Runtime-Servers.
Freier Speicher | Frei verfügbarer Speicher auf dem Stick. Um den Speicher zu defragmentieren, klicken Sie auf die Schaltfläche Defragmentieren.


Lizenzen

Lizenzen

Ihre Lizenzen verwalten Sie in der Registerkarte Lizenzen im Menü Inhalt.

  • Wählen Sie in der Dropdownliste den gewünschten Dongle aus.
  • Unterhalb der Zwischenüberschrift Ing. Punzenberger COPA-DATA GmbH finden Sie Informationen zu den Lizenzen dieses Dongles.

Parameter | Beschreibung
Product Code | Numerischer Wert für Produkt. Klick auf die Ziffer führt zu Details.
Name | Ing. Punzenberger COPA-DATA GmbH
Nutzungseinheiten | Falls zutreffend, Anzeige der verbleibenden Nutzungseinheiten.
Verfallsdatum | Falls zutreffend, Anzeige des Verfallsdatums. Ab diesem Zeitpunkt schaltet zenon in den Demo-Modus.
Aktivierungsdatum | Falls zutreffend, Anzeige des Aktivierungsdatums. Vor diesem Zeitpunkt schaltet zenon in den Demo-Modus.
Lizenzanzahl | Gesamtzahl der Lizenzen
  • Klicken Sie auf die Ziffer in der Spalte Product Code für Details.

Parameter | Beschreibung
Dongle Number | Muss mit der Nummer des aktiven Dongles übereinstimmen.

Laufzeitbeschränkungen

Ein Dongle kann auch mit einer Laufzeitbeschränkung belegt sein:

  • Verfallsdatum
  • Nutzungszeitraum

Verfallsdatum

Der Dongle wird mit einem Verfallsdatum ausgestattet.

In der Registerkarte Lizenzen im Menü Inhalt wird das Verfallsdatum in der Spalte Verfallsdatum mit Datum und Uhrzeit im UTC-Format angegeben.

Nutzungszeitraum

Der Dongle wird mit einem Nutzungszeitraum ausgestattet. Dieser beginnt mit der ersten Nutzung von zenon Editor oder Runtime zu laufen. Um den Zeitraum zu überprüfen:

  • navigieren Sie zur Registerkarte Lizenzen im Menü Inhalt
  • klicken Sie im Eintrag unter Ing. Punzenberger COPA-DATA GmbH auf die Ziffer in der Spalte Product Code
  • das Fenster Product Item Details öffnet sich
  • in der Zeile Nutzungszeitraum sehen Sie den lizenzierten Zeitraum und das Startdatum mit Uhrzeit im UTC-Format


Netzwerk und Proxy

Netzwerk und Proxy

Für die fehlerfreie Kommunikation mit einem Netzwerkdongle und den Start des WebAdmins sind korrekte Netzwerkeinstellungen Voraussetzung.

Parameter

Beschreibung

Netzwerk Adresse

Auswahl einer IP-Adresse, auf die sich der CodeMeter Runtime-Server verbinden soll.

Standard: Alle.
Die Verbindung erfolgt dann zum ersten gefundenen Code-Meter Runtime-Server.

Die Auswahl einer dezidierten Adresse ist vor allem notwendig, wenn der Rechner als Netzwerk-Lizenzserver fungiert und über mehrere
Netzwerkkarten verfügt.

Netzwerk Port

Port für die CodeMeter Kommunikation im Netzwerk.

Standard: 22350

Der Wert kann individuell angepasst werden. In diesem Fall muss sicher gestellt werden, dass alle CodeMeter Runtime-Server den selben Port benutzen.

Empfehlung: Port nicht verändern.

UDP Antwortzeit

Maximaler Antwortzeitraum in dem eine UDP-Anfrage beantwortet werden muss.

Standard: 1000 Millisekunden.

Starte als Server

Aktiv: Der Rechner wird zum CodeMeter Netzwerkserver und stellt seine Lizenzen im Netzwerk zur Verfügung.

Server Suchliste

Hier können durch Eingabe von Rechnernamen oder IP-Adressen bestimmte CodeMeter Netzwerkserver definiert werden. Es wird dann ausschließlich nach den in der Liste definierten Servern gesucht. Damit lassen sich Anfragen von Clients an definierte CodeMeter Netzwerkserver leiten.

Hinweis: Befindet sich ein CodeMeter Server in einem anderen Subnetz, verwenden Sie für die Suchliste die IP-Adresse.

Diese Suchliste sollte nur verwedet werden, wenn der CM Stick im Netzwerk nicht gefunden werden kann.

Einstellungen Proxy

Für den Zugang zu Diensten von CodeMeter im Internet wie Zeitserver, tragen Sie hier die für Ihr Unternehmen gültigen Zugangsdaten ein.

attention Achtung

CodeMeter merkt sich diese Zugangsdaten. Wenn Sie Ihr Zugangspasswort regelmäßig ändern, müssen Sie das Passwort auch in den Proxy-Einstellungen des CodeMeter WebAdmin ändern!


Lizenz anfordern

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> CodeMeter -> Lizenz anfordern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Lizenzen für CodeMeter anzufordern oder Lizenzen zu aktualisieren, wählen Sie im CodeMeter Kontrollzentrum in der Registerkarte Lizenzen die Schaltfläche Lizenzaktualisierung. Der Assistent zur Lizenzaktualisierung startet:

Entscheiden Sie, ob Sie:

  • eine Lizenz anfordern
  • eine Lizenzaktualisierung einspielen
  • eine Quittung für COPA-DATA erzeugen möchten

Lizenzanforderung

Bei Lizenzanforderungen können Sie:

  • eine bestehende Lizenz von COPA-DATA erweitern
  • eine neue Lizenz von COPA-DATA anlegen

  • Um eine weitere Lizenz von COPA-DATA hinzuzufügen:
    • wählen Sie Ing. Punzenberger COPA-DATA GmbH aus
  • Um eine neue Lizenz von COPA-DATA anzulegen:
    • geben Sie den CodeMeter FirmCode, den Sie con COPA-DATA erhalten haben, ein.
  • Wählen Sie den Speicherort für Ihre Lizenzanforderung.


Lizenz anpassen

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> CodeMeter -> Lizenz anpassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können den Umfang Ihrer Lizenz hinsichtlich Umfang und Laufzeit jederzeit anpassen. Dazu:

  1. ordern Sie bei COPA-DATA die gewünschte Änderung
  2. Sie erhalten eine *.WibuCmRaU-Datei für Ihren Dongle
  3. installieren Sie diese:
    1. entweder per Doppelklick auf Die Datei
    2. oder indem Sie die Datei auf das CodeMeter Kontrollzentrum ziehen
  4. Sie erhalten eine Meldung über die erfolgreiche Aktualisierung Ihrer Lizenz

    Sollten Sie eine Fehlermeldung 229 erhalten, ist die Lizenz auf dem Dongle bereits aktuell

Sollte es nötig sein, für Ihre Lizenzanforderung eine .WibuCmRaC-Datei zu erstellen oder die .WibuCmRaU-Datei mit der Aktualisierung manuell einzuspielen, folgen Sie den Anweisungen im Abschnitt Lizenz manuell aktualisieren.

Noch in diesem Kapitel

Lizenz anfordern oder aktualisieren


Lizenz anfordern oder aktualisieren

Lizenz anfordern oder aktualisieren

Um ihre Lizenz manuell zu aktualisieren:

  1. erzeugen Sie eine .WibuCmRaC-Datei
  2. schicken Sie die Datei an COPA-DATA
  3. Sie erhaltern eine aktualisierte .WibuCmRaU-Datei zurück
  4. spielen Sie diese auf den Dongle ein

WibuCmRaC-Datei erzeugen

  1. stellen Sie sicher, dass der CodeMeter-Dongle mit Ihrem Computer verbunden ist
  2. öffnen Sie das CodeMeter Kontrollzentrum, z.B. über Start -> Programme -> CodeMeter -> CodeMeter Control Center
  3. klicken Sie auf der Registerkarte Lizenz auf die Schaltfläche Lizenz aktualisieren
  4. der Assistent zur Lizenzaktualisierung startet
  5. klicken Sie auf Weiter

  6. wählen Sie Lizenzanforderung erzeugen und klicken Sie Weiter

  7. wählen Sie Bestehende Lizenz erweitern
  8. klicken Sie auf Weiter

  9. im folgenden Dialog klicken Sie erneut Weiter
  10. wählen Sie den gewünschten Speicherortfür die entsprechende .WibuCmRaC-Datei
  11. klicken Sie auf Anwenden
  12. die .WibuCmRaC-Datei wird erzeugt
  13. schicken Sie die Datei an sales@copadata.com

WibuCmRaU-Datei installieren

Sie erhalten von COPA-DATA eine aktualisierte *.WibuCmRaU-Datei zurück.

Diese installieren Sie per Doppelklick auf die Datei auf dem Dongle.

Alternativ:

  1. öffnen Sie das CodeMeter Kontrollzentrum
  2. wählen Sie Lizenzaktualisierung einspielen
  3. folgen Sie den Anweisungen des Installationsassistenten


Fehlerbehebung

Handbuch -> Lizenzierung -> Arten der Lizenzierung -> Donglelizenzierung -> CodeMeter -> Fehlerbehebung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler

Lösung

zenon läuft nur im Demo-Modus.

Überprüfen Sie

  • Ihre Lizenzen
  • die Verbindung zum Netzwerkdongle
  • ob die Lizenzinformationen (SERIAL7= und ACTIVATIONKEY7=) richtig in der zenon6.ini eingetragen wurden. Achten Sie auch auf mögliche Leerzeichen hinter der Seriennummer (SERIAL7=) oder dem Aktivierungskey (ACTIVATIONKEY7=).
    Pfad zur zenon6.ini:
    Vista/7: C:\ProgramData\COPA-DATA\System
    XP: C:\Documents and Settings\All Users\Application Data\COPA-DATA\System

Dongle wird nicht gefunden.
  • Überprüfen Sie die Netzwerkeinstellungen.
  • Befindet sich der Stick in einer anderen Domäne, fügen Sie ihn zur Serverliste hinzu.
  • Erhöhen Sie die UDP-Antwortzeit.

Zertifizierte Uhrzeit kann nicht aktualisiert werden.

Überprüfen Sie:

  • Proxy-Einstellungen, vor allem Zugangsdaten und Passwort
  • Liste der Zeitserver unter Einstellungen -> Zeitserver
    z.B.: cmtime.codemeter.com, cmtime.codemeter.de, cmtime.codemeter.fr, cmtime.codemeter.us

Fehlermeldung bei Aktualisierung der Lizenz:

Fehler beim Update des CmSticks x-xxxxxxx:
Dieses Update kann nicht mehr eingespielt werden. Der Inhalt des CmSticks ist auf einem neueren Stand, Fehler 229.

Das Update für diese LIzenz wurde bereits auf den Dongle übertragen. Der Dongle ist auf dem aktuellsten Stand.


Kommandozeilenparameter für Lizenzierungstool

Handbuch -> Lizenzierung -> Kommandozeilenparameter für Lizenzierungstool

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Lizenzierungstool kann per Kommandozeile mit folgenden Flags als Parameter gesteuert werden:

Die Übergabe eines Parameters erfolgt, indem ein '/' oder ein '-' dem Parameter vorangestellt wird:

z.B.: /silent oder -silent

Parameter | Beschreibung
request | Zwingt das Programm dazu, dass der erste Dialog nicht angezeigt wird, sondern gleich der Dialog der Anforderung des Aktivierungsschlüssels. (Es spielt dabei keine Rolle, ob das Flag /silent oder –silent in der Verwendung ist.)
sernum:<num> | zwingt das Programm dazu, dass die Seriennummer nicht aus der Datei zenon6.ini gelesen, sondern die übergebene <num> für die Lizenzierung verwendet wird.
actkey:<key> | Zwingt das Programm dazu, dass der Aktivierungsschlüssel nicht aus der Datei zenon6.ini gelesen, sondern der übergebene <key> für die Lizenzierung verwendet wird.
silent | Zwingt das Programm dazu, keine Dialoge anzuzeigen. Die Datei License.txt wird trotzdem geschrieben.
mailto:<addr> | Funktioniert nur in Verbindung mit dem Flag silent und zwingt das Programm dazu, die Lizenzanforderung per E-Mail an die angegebene <addr> Adresse zu senden.


Remote-Lizenzierung

Handbuch -> Lizenzierung -> Remote-Lizenzierung

Um einem Rechner eine Lizenz per Remote-Verbindung zuzuweisen:

  1. wählen Sie im Kontextmenü des Projekts Remote-Transport -> Passwort ändern u. Lizenzierung anzeigen
  2. starten Sie den Remote-Transport
  3. sobald die Verbindung besteht, wird die Lizenzierung des Remote-Rechners angezeigt

  4. geben Sie Seriennummer und Aktivierungsnummer Ihres Lizenzscheins ein
  5. bestätigen Sie die Eingaben mit Klick auf OK


Besonderheiten beim Server-Client-Betrieb

Handbuch -> Lizenzierung -> Besonderheiten beim Server-Client-Betrieb

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Lizenzierung von Modulen im Server-Client-Betrieb kommt es zu folgenden Besonderheiten:

Archivserver

Folgende Fälle werden unterschieden:

  • Server und Client lizenziert: Archive können am Client geöffnet und bearbeitet werden
  • Server lizenziert und Client nicht lizenziert: Archive können am Client geöffnet, aber nicht bearbeitet werden
  • Client nicht lizenziert und standalone gestartet: Archivfenster kann geöffnet werden, die einzelnen Archive jedoch nicht

Automatic Line Coloring

Folgende Fälle werden unterschieden:

  • Server lizenziert und Client nicht lizenziert: ALC Funktionalität ist uneingeschränkt verfügbar
  • Client nicht lizenziert und standalone gestartet: ALC Funktionälität ist nicht verfügbar

info Info

Wenn der Server für die Energy Edition lizenziert ist, ist auch ALC lizenziert.

Energy Management System

Folgende Fälle werden unterschieden:

  • Server lizenziert und Client nicht lizenziert: EMS Funktionalität ist uneingeschränkt verfügbar
  • Client nicht lizenziert und standalone gestartet: EMS Funktionälität ist nicht verfügbar


Maßeinheitenumschaltung

Handbuch -> Maßeinheitenumschaltung

Die Maßeinheitenumschaltung ermöglichen das Umrechnen und Umschalten von Basiseinheiten in sogenannte Umrechnungseinheiten, zum Beispiel Meter in Yard oder Meter in Dezimeter, Zentimeter und Millimeter. Eine Basiseinheit beinhaltet den Ausgangswert für eine Umrechnung. Die Umrechnungseinheit enthält den im Verhältnis zur Basiseinheit umgerechneten Wert. Beide verfügen über eine Maßeinheitenbezeichnung. Für die Umrechnungseinheiten können ein Faktor, ein Offset und eine Kommaverschiebung bezogen auf die zugehörige Basiseinheit definiert werden.

Interne ID: Maßeinheitenumschaltung

Kommaverschiebung

Korrektur der Nachkommastellen. Um diesen Wert wird die Anzahl der Kommastellen in der Umrechnungseinheit gegenüber der Basiseinheit verschoben.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Maßeinheitenumschaltung

Offset

aus Primäreinheit (d für y=kx+d)

Angabe des Umrechungsoffsets mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (d für y=kx+d bzw. b für y=mx+b).

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Maßeinheitenumschaltung

Faktor

Angabe des Umrechnungsfaktors mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (k für y=kx+d bzw. m für y=mx+b).

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei der Parametrierung einer Variablen kann eine Basiseinheit ausgewählt werden. Über die Funktion Maßeinheitenumschaltung kann zur Runtime zwischen verschiedenen Maßeinheiten umgeschaltet werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Basiseinheit neu | Legt eine neue Basiseinheit an.
XML exportieren alle | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Maßeinheiten aus einer XML-Dateien.
Hilfe | Öffnet die Online-Hilfe.

info Info

Die Maßeinheitenumschaltung darf nicht gemeinsam mit der Report-Funktion variablerw verwendet werden. Diese Report-Funktion stellt für ältere Projekte eine Einheitenumschaltung zur Verfügung. Wird eine in der Maßeinheitenumschaltung definierte Einheit einer Variablen mit dieser Report-Funktion zur Runtime geändert, muss die Konfiguration in der Maßeinheitenumschaltung neu erfolgen.

Noch in diesem Kapitel

Maßeinheiten Detailansicht Symbolleiste und Kontextmenü

Maßeinheiten projektieren

Basiseinheit einer Variablen zuweisen

Funktion Maßeinheitenumschaltung

Runtime


Maßeinheiten Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Maßeinheitenumschaltung -> Maßeinheiten Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Maßeinheiten Detailansicht

Menüpunkt | Aktion
Basiseinheit neu | Legt eine neue Basiseinheit an.
XML exportieren alle | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Maßeinheiten aus einer XML-Dateien.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü und Symbolleiste Basiseinheit/Umrechnungseinheit

Menüpunkt | Aktion
Basiseinheit neu | Legt eine neue Basiseinheit an.
Umrechnungseinheit neu | Legt eine neue Umrechnungseinheit für die übergeordnete Basiseinheit an.
Verknüpfte Elemente: Zurück zu Ausgangselement springen | Dropdownliste mit Link zurück zu dem Element, von dem aus man zur Einheit gekommen ist. Nur vorhanden, wenn Einheit mit anderem Element verknüpft ist.
Umbenennen | Ermöglicht das Umbenennen der Maßeinheit. Achtung: Werden Maßeinheiten umbenannt, so müssen alle Maßeinheiten, die bereits mit Variablen verknüpft sind oder in Funktionen verwendet werden, bei der jeweiligen Variablen bzw. in der jeweiligen Funktion manuell angepasst werden. Siehe auch: Basiseinheit einer Variablen zuweisen und Funktion Maßeinheitenumschaltung.
XML exportieren alle | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Maßeinheiten aus einer XML-Dateien.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Hilfe | Öffnet die Online-Hilfe.


Maßeinheiten projektieren

Handbuch -> Maßeinheitenumschaltung -> Maßeinheiten projektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Umrechnung müssen Sie eine Basiseinheit und eine Umrechnungseinheit anlegen, sowie die Parameter für Umrechnung festlegen. Die Umrechnung erfolgt nach der Formel y=kx+d (Österreich) bzw. y=mx+b Deutschland). Jede Basiseinheit kann einer Variablen als Maßeinheit zugewiesen werden.

Um eine neue Basiseinheit anzulegen:

  • wählen Sie im Projektmanager den Knoten Maßeinheiten
  • führen Sie einen Rechtsklick auf Maßeinheiten aus
  • wählen Sie aus dem Kontextmenü den Befehl Basiseinheit neu
  • ein neuer Eintrag wird in der Liste angelegt
  • vergeben Sie eine Bezeichnung für die Maßeinheit
  • legen Sie eine Umrechnungseinheit an

Um eine neue Umrechnungseinheit anzulegen:

  • führen Sie einen Rechtsklick auf eine Basiseinheit aus
  • wählen Sie aus dem Kontextmenü den Befehl Umrechnungseinheit neu
  • ein neuer Eintrag wird in der Liste angelegt
  • vergeben Sie eine Bezeichnung für die Maßeinheit
  • legen Sie einen Faktor für die Umrechnung fest

    Interne ID: Maßeinheiten projektieren

    Faktor

    Angabe des Umrechnungsfaktors mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (k für y=kx+d bzw. m für y=mx+b).

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • legen Sie einen Wert für die Kommaverschiebung fest

    Interne ID: Maßeinheiten projektieren

    Kommaverschiebung

    Korrektur der Nachkommastellen. Um diesen Wert wird die Anzahl der Kommastellen in der Umrechnungseinheit gegenüber der Basiseinheit verschoben.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • legen Sie einen Wert für den Offset fest

    Interne ID: Maßeinheiten projektieren

    Offset

    aus Primäreinheit (d für y=kx+d)

    Angabe des Umrechungsoffsets mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (d für y=kx+d bzw. b für y=mx+b).

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Basiseinheit einer Variablen zuweisen

Handbuch -> Maßeinheitenumschaltung -> Basiseinheit einer Variablen zuweisen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Basiseinheiten weisen Sie einer Variablen in der Eigenschaft Maßeinheit (Knoten Allgemein) zu.

Interne ID: Basiseinheit einer Variablen zuweisen

Allgemein

Allgemeine Eigenschaften der Variable oder des Datentyps.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Basiseinheit einer Variablen zuweisen

Maßeinheit

Technische Einheit der Variablen für die Darstellung zur Runtime. Wurden im Modul Einheiten bereits Basiseinheiten erstellt, stehen diese in einer Dropdownliste zur Auswahl zur Verfügung.
Maximum: 50 Zeichen.
Default: leer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Sie können hier freie Bezeichnungen für Maßeinheiten vergeben. Soll die Maßeinheitenumrechnung zur Runtime genutzt werden, wählen Sie eine zuvor definierte Basiseinheit aus der Dropdownliste aus.

Tipp: Falls Sie eine freie Bezeichnung vergeben, legen Sie am besten gleich im Anschluss im Knoten Maßeinheiten die Basiseinheit mit gleichem Namen an.

Damit zur Runtime umgerechnet werden kann, müssen Sie eine Funktion Maßeinheitenumschaltung anlegen.

attention Achtung

Wird eine Maßeinheit nachträglich umbenannt, so wird die Umbenennung bei bereits verknüpften Variablen nicht automatisch nachgezogen.

Um bereits verknüpfte Maßeinheiten umzubenennen:

  • wählen Sie die Detailansicht im Projektmanager
  • wählen Sie die Spalte Maßeinheiten oder fügen Sie diese der Ansicht hinzu, falls sie noch nicht angezeigt wird
  • wählen Sie im Kontextmenü den Befehl Text in selektierter Spalte ersetzen
  • suchen Sie im sich öffnenden Dialog nach dem alten Namen und ersetzen Sie ihn durch den neuen


Funktion Maßeinheitenumschaltung

Handbuch -> Maßeinheitenumschaltung -> Funktion Maßeinheitenumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit zur Runtime zwischen Maßeinheiten umgeschaltet werden kann, legen Sie eine Funktion Maßeinheitenumschaltung an:

  • wählen Sie im Projektmanager den Knoten Funktion
  • wählen Sie im Kontextmenü den Befehl Funktion neu
  • navigieren Sie zu Variable
  • wählen Sie die Funktion Maßeinheitenumschaltung

    Hinweis: Das Ausführen der Funktion Maßeinheitenumschaltung löst auch einen Refresh des Reports aus, falls dieser gerade angezeigt wird.

  • der Dialog zur Parametrierung der Maßeinheitenumschaltung öffnet sich:

Eigenschaft | Beschreibung
Maßeinheitenumschaltung | Dialog zum Zuweisen von Umrechnungseinheiten zu Basiseinheiten.
Basiseinheit | Liste der angelegten Basiseinheiten.
Umschalten in | Dropdownliste zur Auswahl der Umrechnungseinheit. Es kann entweder eine projektierte Umrechnungseinheit oder die Basiseinheit gewählt werden. Projektierte Umrechnungseinheit: Zur Runtime wird auf diese umgeschaltet. <Basiseinheit>: Die Basiseinheit bleibt zur Runtime aktiv.

info Info

Beim XML-Export dieser Funktion werden die Maßeinheiten nicht mit exportiert. Diese müssen separat exportiert werden.

attention Achtung

Wird eine Maßeinheit nachträglich umbenannt, so wird die Umbenennung der Basiseinheit in den Funktionen automatisch berücksichtigt. Umrechnungseinheiten müssen manuell geändert werden.


Runtime

Handbuch -> Maßeinheitenumschaltung -> Runtime

In der Runtime wird jeder Variablenwert bei jeder Ein- oder Ausgabe zusätzlich zur standardmäßig verwendeten Umrechnung von Signal- auf Messbereicheinheiten umgerechnet.

  • Ausgabe: Über die Funktion Maßeinheitenumschaltung wird eine Umrechnungseinheit für eine Variable aktiviert. Der Wert in Messbereichseinheiten wird mit dem darin eingestellten Offset und Faktor beaufschlagt. Zudem wird für die Umwandlung des Wertes in einen String die an der Variable eingestellte Anzahl der Nachkommastellen entsprechend korrigiert.
  • Eingabe: Die Umrechnung erfolgt analog zur Ausgabe in umgekehrter Richtung.

Einschränkungen:

  • Beim Export werden die umgeschalteten Einheiten exportiert.
  • Werte, die als String gespeichert sind, werden für die Ausgabe nicht erneut umgerechnet. Diese Werte bleiben in der Maßeinheit, die zum Zeitpunkt des Erstellens des Strings aktiv war. Insbesondere trifft dies alle Werte, die in den Text eines CEL-Eintrags eingefügt werden, wie „Sollwert geändert von ALT auf NEU" usw.
  • Betriebsstunden und Schaltspielzähler im Industrial Maintenance Manager werden immer in Basiseinheiten angezeigt.
  • Leistungen im EMS-Fenster werden immer in Basiseinheit angezeigt.

VBA

Zugriffe auf Werte über VBA erfolgen immer in Basiseinheiten. Zum Beispiel liefert Variable.Value keinen maßeinheitenumgeschalteten Wert, da es sich um keine Wertausgabe handelt. Damit auch über VBA die Maßeinheitenumschaltung genutzt werden kann, wurden 4 neue Funktionen an Variable. eingebaut:

Keyword | Beschreibung
SecondaryUnitName | liefert den Namen der eingestellten Umrechnungseinheit
SecondaryUnitDigits | liefert die Nachkommastellen der eingestellten Umrechnungseinheit
CalcSecondaryUnitValue | rechnet Wert der Basiseinheit in den Wert der Umrechnungseinheit um
CalcPrimaryUnitValue | rechnet Wert der Umrechnungseinheit in den Wert der Basiseinheit um


Menüs

Handbuch -> Menüs

Im Menü-Editor werden Windows-konforme Menüs erstellt. Es gibt zwei Arten von Menüs:

  • Hauptmenüs
  • Kontextmenüs

Hinweis: Das Betriebssystem erlaubt keine eigenen Menüs für einzelne Bilder oder Schablonen.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Hauptmenü neu | Fügt ein neues Hauptmenü in die die Menüliste der Detailansicht ein.
Kontextmenü neu | Fügt ein neues Kontextmenü in die die Menüliste der Detailansicht ein.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Profil | Öffnet die Dropdownliste mit vordefinierten Profilen.
Help | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Projektieren im Editor

Bedienen während der Runtime


Projektieren im Editor

Handbuch -> Menüs -> Projektieren im Editor

Selektieren Sie den Eintrag Menü im Projektmanager, um den Menü-Editor in der Detailansicht zu öffnen. Es stehen Hauptmenüs und Kontextmenüs zur Auswahl. Über das Kontextmenü (Eintrag Hauptmenü neu oder Kontextmenü neu) können Sie neue Menüs erstellen. Diese werden anschließend im rechten Teil der Detailansicht angezeigt. Menüs können exportiert und importiert werden. Nähere Informationen finden Sie im Kapitel Import-Export/Menüs.

attention Achtung

Voraussetzung, damit Hauptmenüs während der Runtime angezeigt werden: In den Projekteigenschaften muss die Eigenschaft Hauptmenüs aktiv (Knoten Grafische Ausprägung) aktiviert werden.

Interne ID: Projektieren im Editor

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Projektieren im Editor

Hauptmenüs aktiv

Aktiv: Damit wird am oberen Rand des Runtime-Fensters ein Balken für die Darstellung der Menüs reserviert.
Inaktiv: In der Runtime werden keine Hauptmenüs angezeigt.
Default: inaktiv.

ACHTUNG: Wenn Hauptmenüs verwendet werden, muss diese Option aktiviert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Neuen Menüeintrag anlegen

Um einen neuen Menüeintrag anzulegen:

  1. markieren Sie den letzten Eintrag
  2. bestätigen Sie mit der Taste Eingabe
  3. eine neues leeres Eingabefeld wird erstellt

Neues Untermenü anlegen

Um ein neues Untermenü anzulegen, aktivieren Sie im übergeordneten Menüeintrag die Eigenschaft Untermenü. Damit wird ein neues Eintragfeld für das Untermenü geöffnet.

Interne ID: Projektieren im Editor

Untermenü

Der Menüeintrag führt keine Aktion aus, sondern öffnet ein Untermenü.

Default: Inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Menüeintrag verschieben

  1. markieren Sie den gewünschten Eintrag (Mehrfachselektion ist möglich)
  2. ziehen Sie ihn mit gedrückter linker Maustaste an die neue Position
  3. Hinweis: Wenn Sie Untermenüs zu einem Menüeintrag verschieben, der nicht als Untermenü definiert ist, werden die Einträge als Hauptmenüs angelegt
    Verschieben Sie den obersten Eintrag, werden alle Untermenüs mitverschoben.

Menüeintrag kopieren

  1. markieren Sie den gewünschten Eintrag (Mehrfachselektion ist möglich)
  2. wählen Sie im Kontextmenü oder in der Symbolleiste Kopieren
  3. wählen Sie den Ablageort für die Kopie

    Hinweis: Wenn Sie Untermenüs zu einem Menüeintrag kopieren, der nicht als Untermenü definiert ist, werden die Einträge als Hauptmenüs angelegt.
    Kopieren Sie den obersten Eintrag, werden alle Untermenüs mitkopiert.

  4. wählen Sie im Kontextmenü oder in der Symbolleiste Einfügen
  5. ziehen Sie ihn mit gedrückter linker Maustaste an die neue Position

Menüeintrag umbenennen

  1. wählen Sie den Menüeintrag aus und bearbeiten Sie ihn durch:
    • Doppelklick oder verzögerten Doppelklick auf den Eintrag
      oder
    • Drücken der Taste F2 oder der Taste Eingabe bei ausgewähltem Eintrag
      oder
    • Wahl des Befehls Umbenennen im Kontextmenü oder in der Symbolleiste
  2. der aktuelle Eintrag wird markiert
  3. tragen Sie den neuen Namen ein
  4. bestätigen Sie die Änderung durch:
    • Drücken der Taste Eingabe
    • Wechsel zu einem anderen Menüeintrag
  5. oder verwerfen Sie die Änderung durch Drücken der Taste Esc

Mehrfachselektion

Um mehrere Einträge gleichzeitig zu bearbeiten_

  • halten Sie die Taste Strg gedrückt und klicken Sie auf die Einträge

    oder

  • halten Sie die Taste Umschalt gedrückt und klicken Sie auf die Einträge

    oder

  • halten Sie die Taste Umschalt gedrückt und benutzen Sie die Pfeiltasten der Tastatur

Um einen Eintrag wieder abzuwählen, klicken Sie bei weiter gehaltener Taste Strg oder Umschalt auf den Eintrag.

Um alle abzuwählen und nur einen Eintrag zu aktivieren, klicken Sie auf den gewünschten Eintrag.

Noch in diesem Kapitel

Menüs Detailansicht Symbolleiste und Kontextmenü

Einträge definieren


Menüs Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Menüs -> Projektieren im Editor -> Menüs Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste

Menüpunkt | Aktion
Hauptmenü neu | Fügt ein neues Hauptmenü in die die Menüliste der Detailansicht ein.
Kontextmenü neu | Fügt ein neues Kontextmenü in die die Menüliste der Detailansicht ein.
Standard-Funktion erzeugen | Öffnet den Dialog zur Auswahl einer Aktion und erstellt eine passende Funktion. Die Aktion wird im Ausgabefenster dokumentiert.
Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
Kopieren | Kopiert ausgewählten Eintrag in Zwischenablage.
Einfügen | Fügt Inhalt der Zwischenablage ein.
Löschen | Löscht den ausgewählten Eintrag ohne weitere Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert Einträge aus XML-Datei.
Umbennnen | Öffnet Menüeintrag zum Umbenennen.
Eigenschaften | Öffnet das Eigenschaften-Fenster für den Eintrag.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Runtime Menüs

Menüpunkt | Aktion
Hauptmenü neu | Fügt ein neues Hauptmenü in die die Menüliste der Detailansicht ein.
Kontextmenü neu | Fügt ein neues Kontextmenü in die die Menüliste der Detailansicht ein.
Help | Öffnet die Online-Hilfe.

Kontextmenü Hauptmenüs

Menüpunkt | Aktion
Hauptmenü neu | Fügt ein neues Hauptmenü in die die Menüliste der Detailansicht ein.
Help | Öffnet die Online-Hilfe.

Kontextmenü Kontextmenüs

Menüpunkt | Aktion
Kontextmenü neu | Fügt ein neues Kontextmenü in die die Menüliste der Detailansicht ein.
Help | Öffnet die Online-Hilfe.

Kontextmenü Menüs

Menüpunkt | Aktion
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert Einträge aus XML-Datei.
Löschen | Löscht den ausgewählten Eintrag ohne weitere Sicherheitsabfrage.
Standard-Funktion erzeugen | Öffnet den Dialog zur Auswahl einer Aktion. und erstellt eine passende Funktion. Die Aktion wird im Ausgabefenster dokumentiert.
Eigenschaften | Öffnet das Eigenschaften-Fenster für den Eintrag.
Hilfe | Öffnet die Online-Hilfe.


Einträge definieren

Handbuch -> Menüs -> Projektieren im Editor -> Einträge definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Menü-Eintrag kann einen von drei verschiedenen Inhalten haben:

Parameter

Beschreibung

Aktionstyp

Interne ID: Einträge definieren

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Legt fest, welche Art von Aktion über den entsprechenden Menü-Eintrag zur Runtime ausgeführt werden soll. Nicht alle Aktionstypen stehen im Hauptmenü zur Verfügung, manche sind nur über das Kontextmenü projektierbar.

  • Alarme quittieren (nur Kontextmenü)
  • Befehlsgabe (nur Kontextmenü)
  • Blinken quittieren (nur Kontextmenü)
  • Funktion
  • Hilfe
  • Keine Aktion
  • Sollwert absetzen
  • VBA Makro (nur Kontextmenü)

Untermenü

Interne ID: Einträge definieren

Untermenü

Der Menüeintrag führt keine Aktion aus, sondern öffnet ein Untermenü.

Default: Inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Öffnet zur Runtime ein Untermenü.

Trennlinie

Eine horizontale Linie trennt Menüeinträge.

Text unterstreichen: Die Eingabe eines & bewirkt, dass das folgende Zeichen unterstrichen dargestellt wird.

Einträge projektieren

Um einen Menüeintrag im Hauptmenü oder Kontextmenü zu projektieren:

  1. aktivieren Sie die entsprechende Menüzelle
  2. wählen Sie in den Eigenschaften:
    • Aktionstyp: abhängig von Menüart
      siehe auch: Aktionstypen Hauptmenü und Aktionstypen Kontextmenü
    • Menü ID: ID des Eintrags
      Hinweis: Bei Befehlsgabe stehen die in der Befehlsgabe vordefinierten Typen mit fester ID zur Verfügung

      Interne ID: Einträge definieren

      Menü ID

      Name des Menüeintrags.

      Bei Aktionstyp Befehlsgabe sind die in der Befehlsgabe bereits definierte Aktionen aus einer Dropdownliste auswählbar.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Text: eindeutige Beschriftung der Menüzelle

      Interne ID: Einträge definieren

      Text

      Beschriftung des Menüeintrags im Menü. Der Eintrag muss eindeutig sein. Sind mehrere Einträge mit gleichem Text vorhanden, wird zur Runtime nur der erste dieser Menüeinträge angezeigt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Die Bezeichnung in der Eigenschaft Text muss eindeutig sein. Werden gleiche Bezeichner vergeben, werden weitere Menüpunkt mit gleicher Bezeichnung nicht angezeigt.

Noch in diesem Kapitel

Aktionstypen Hauptmenü

Aktionstypen Kontextmenü

Grafische Ausprägungen

Untermenü


Aktionstypen Hauptmenü

Handbuch -> Menüs -> Projektieren im Editor -> Einträge definieren -> Aktionstypen Hauptmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter | Beschreibung
Funktion | Eine definierte Funktion von zenon wird durch Auswahl des Menü-Eintrags in der Runtime ausgeführt.
Hilfe | Eine Hilfeseite aus einer CHM-Datei wird angezeigt.
Keine Aktion | Es wird keine Aktion ausgeführt.
Sollwert setzen | Durch Auswahl des Menü-Eintrages Sollwert setzen kann zur Runtime ein fixer Wert abgesetzt oder ein Variablenwert um einen bestimmten Wert erhöht oder verringert werden. Die Eingabe erfolgt über die Sollwert-Eingabe-Maske zenon. Ist eines der 3 Keyboardbilder (SETVALUEKBD, SETBOOLKBD oder SETSTRINGKBD) im Projekt vorhanden, wird dieses automatisch verwendet. Für diese Aktion kann eine Variable direkt definiert werden oder bei Verwendung als Kontextmenü-Eintrag kann die Variable aus einem angeklickten Element übernommen werden.


Aktionstypen Kontextmenü

Handbuch -> Menüs -> Projektieren im Editor -> Einträge definieren -> Aktionstypen Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Parameter | Beschreibung
Funktion | Eine definierte Funktion von zenon wird durch Auswahl des Menü-Eintrags in der Runtime ausgeführt.
Hilfe | Eine Hilfeseite aus einer CHM-Datei wird angezeigt.
Keine Aktion | Es wird keine Aktion ausgeführt.
Sollwert setzen | Durch Auswahl des Menü-Eintrages Sollwert setzen kann zur Runtime ein fixer Wert abgesetzt oder ein Variablenwert um einen bestimmten Wert erhöht oder verringert werden. Die Eingabe erfolgt über die Sollwert-Eingabe-Maske zenon. Ist eines der 3 Keyboardbildern (SETVALUEKBD, SETBOOLKBD oder SETSTRINGKBD) im Projekt vorhanden, wird dieses automatisch verwendet. Für diese Aktion kann eine Variable direkt definiert werden, oder bei Verwendung als Kontextmenü-Eintrag kann die Variable aus einem angeklickten Element übernommen werden.
VBA-Makro | Ein VBA-Makro wird durch Auswahl des Menü-Eintrags in der Runtime ausgeführt. Sie können nur die VBA-Makros selektieren, die als Init-Event deklariert sind.
Alarme quittieren | Die Alarme aller Variablen die mit dem dynamischen Element verknüpft sind, auf das sich das Kontextmenü bezieht, werden quittiert.
Blinken quittieren | Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe | Öffnet das definierte Befehlsgabe Fenster (nur in Verbindung mit Energy-Lizenz)

Noch in diesem Kapitel

Befehlsgabe


Befehlsgabe

Handbuch -> Menüs -> Projektieren im Editor -> Einträge definieren -> Aktionstypen Kontextmenü -> Befehlsgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erzeugen einer neuen Aktion in der Befehlsgabe, wird eine Menü-ID entsprechend des Aktionstyps und der Schaltrichtung für die Eigenschaft Aktionstyp erzeugt und in der Dropdownliste angeboten. Entspricht der Inhalt einer für den Aktionstyp und die Schaltrichtung als Standardtext definierten ID, dann wird der Inhalt angepasst, wenn sich der Aktionstyp oder die Schaltrichtung ändern.

Interne ID: Befehlsgabe

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um ein Kontextmenü für die Befehlsgabe zu erstellen:

  1. erstellen Sie in der Befehlsgabe die gewünschten Aktionen
  2. wählen Sie in den Eigenschaften des Kontextmenü-Eintrags als Aktionstyp Befehlsgabe
  3. wählen Sie mit der Eigenschaft Menü ID die gewünschte Aktion und Schaltrichtung über die Dropdownliste

    Interne ID: Befehlsgabe

    Menü ID

    Name des Menüeintrags.

    Bei Aktionstyp Befehlsgabe sind die in der Befehlsgabe bereits definierte Aktionen aus einer Dropdownliste auswählbar.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. vergeben Sie in der Eigenschaft Text eine eindeutige Bezeichnung
    Hinweis: Wird für Text kein Eintrag definiert, wird das Feld automatisch mit der Bezeichnung "Befehlsgabe" gefüllt.

    Interne ID: Befehlsgabe

    Text

    Beschriftung des Menüeintrags im Menü. Der Eintrag muss eindeutig sein. Sind mehrere Einträge mit gleichem Text vorhanden, wird zur Runtime nur der erste dieser Menüeinträge angezeigt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Die Bezeichnung in der Eigenschaft Text muss eindeutig sein. Werden gleichen Bezeichner vergeben, werden weitere Menüpunkt mit gleicher Bezeichnung nicht angezeigt.

Da automatisch erzeugte Menüpunkte mit gleicher Aktion den gleichen Text ergeben, stehen für diese Makros zur Verfügung.

Die Zeichenfolge ID_CMD_AUTO ist für automatisch erzeugte Menüpunkte reserviert. Diese müssen immer mit Makros verwendet werden, das sonst nur der Menüpunkt eingefügt wird.

Aktionen für Aktionstyp Befehlsgabe

Aktion | Schaltrichtung | Menü-ID
ID_CMD_AUTO |  | Dieser Menüpunkt zeigt automatisch alle möglichen Aktionen für ein Element an, sofern kein direkter Menüpunkt aus der Liste bereits verwendet wird.
Einzelbefehl | EIN (1) | ID_CMD_EBEF_ON
Einzelbefehl | AUS (1) | ID_CMD_EBEF_OFF
Einzelbefehl | KEINE | ID_CMD_EBEF_NONE
Doppelbefehl | EIN (1) | ID_CMD_DBEF_ON
Doppelbefehl | AUS (2) | ID_CMD_DBEF_OFF
Doppelbefehl | KEINE | ID_CMD_DBEF_NONE
Sollwert | KEINE | ID_CMD_SVALUE
Sollwert | DIREKT | ID_CMD_SVALUE_DIR
Statusvorgabe | KEINE | ID_CMD_STATE
Statusvorgabe | EIN (1) | ID_CMD_STATE_ON
Statusvorgabe | AUS (0) | ID_CMD_STATE_OFF
Ersetzen | KEINE | ID_CMD_REPL_NONE
Ersetzen | EIN (1) | ID_CMD_REPL_ON
Ersetzen | AUS (0) | ID_CMD_REPL_OFF
Ersetzen | STÖR | ID_CMD_REPL_DEF
Ersetzen | DIFF | ID_CMD_REPL_DIFF
Nachführen | KEINE | ID_CMD_UPD_NONE
Nachführen | EIN (1) | ID_CMD_UPD_ON
Nachführen | AUS (0) | ID_CMD_UPD_OFF
Nachführen | DIFF | ID_CMD_UPD_DIFF
Nachführen | STÖR | ID_CMD_UPD_DEF
Nachführen | DIREKT | ID_CMD_UPD_DIR
Blockieren | KEINE | ID_CMD_BLOCK
Freigeben | KEINE | ID_CMD_UNLOCK
Sperren | KEINE | ID_CMD_LOCK
Revision | AUS (0) | ID_CMD_REV_OFF
Revision | EIN (1) | ID_CMD_REV_ON
info Info
Weiter Informationen zur Verwendung von Kontextmenüs in der Befehlsgabe lesen im Handbuch Energy Edition im Abschnitt Kontextmenü Befehlsgabe.

Noch in diesem Kapitel

Makros für Kontextmenü


Makros für Kontextmenü

Makros für Kontextmenü

Ein Makro ist eine definierte Zeichenfolge, die bei der Menüpunkterzeugung zur Runtime welche durch einen anderen Text ersetzt wird. Beinahe alle Makros können pro Menüpunkt mehrfach vorkommen. Sie können auch als Ergebnis weitere Makros beinhalten. Dabei muss die Expansionsreihenfolge beachtet werden. Makros sind bei der Menüprojektierung case insensitive. Wenn Makros als Ergebnis ein Makro beinhalten, muss das Makro in Großbuchstaben im Ergebnis enthalten sein. Die Eingabe erfolgt mit $ als Prefix und Suffix.

Die Reihenfolge der Expansion erfolgt von links nach rechts in folgender Priorität.

  1. $NOTE$
  2. $TAG$
  3. $REMA<Zustand>$
  4. $RDIR$
  5. $ALL$
  6. $DIR$
  7. $ACT$
  8. $NOTE$

Makro

Beschreibung

$NOTE$

Der gesamte Text inklusive dem Makro wird als Bemerkung interpretiert. Ist der resultierende Text leer, wird das Makro $ALL$ eingesetzt.

$TAG$

Wird durch die Kennung der Aktionsvariable ersetzt.

Die Kennung kann durch die Onlinesprachübesetzung übersetzt werden. Wenn kein Übersetzungszeichen (@) enthalten ist, wird automatisch die gesamte Kennung zur Übersetzung markiert.

$REMA<Zustand>$

<Zustand> ist ein Rema- oder Grenzwertzustand, dessen Text zur Ersetzung verwendet wird.

Ist der Zustand nicht vorhanden, wird der Menüpunkt nicht dargestellt.

Der Grenzwerttext wird vor der Makroexpansion entsprechend der Platzierung von @ sprachübersetzt.

Zustand kann eine Zahl zwischen -231 und 231-1 sein. Führende Leerzeichen und ein Vorzeichen sind erlaubt. Wenn nicht auf eine Zahl konvertierbare Zeichen enthalten sind oder die Zahl außerhalb des angegebenen Bereiches ist, wird der Menüpunkt nicht dargestellt.

$RDIR$

Text für die Schaltrichtung aus Reaktionsmatrix/Grenzwert wie im Makro $DIR$, ausgenommen:

  • Aktion Sollwert setzen direkt
    Der Text wird aus Rema/Grenzwert vom Zustand, der dem Wert des zu setzenden Sollwertes entspricht, genommen.
  • Aktion Status ein und Status aus
    Text wird aus Rema/Grenzwert für den Zustand ein bzw aus genommen.
  • Aktion Nachführen direkt
    Der Text wird aus Rema/Grenzwert vom Zustand, der dem Wert des zu setzenden Sollwertes entspricht, genommen.

$ALL$

Ergibt Aktionsbenennung: Schaltrichtung.

Entspricht der Kombination der Makros $ACT$: $DIR$

$DIR$

Schaltrichtung der Aktion.

$ACT$

Aktionsbenennung der Aktion.

$NOTE$

Als letztes Makro wird nochmals das Bemerkungsmakro geprüft und der Text rechts davon inklusive Makro gelöscht.

Ist der resultierende Text leer oder besteht er nur aus Leerzeichen, wird der Menüpunkt nicht eingefügt.

Automatisch erzeugte Menüpunkte

Automatisch erzeugte Menüpunkte werden bei ID_CMD_AUTO als Menü-ID erzeugt. In diesem Fall müssen immer Makros verwendet werden, da ansonsten nur ein Menüpunkt eingefügt wird.

Kompatibilität

Vor Version 6.51 wurde Text bei automatischen Menüpunkten ignoriert. Bei der Konvertierung von Projekten, die mit Versionen vor 6.51 erstellt wurden, werden vor dem projektierten Text die Makros $ALL$$NOTE$ eingefügt. Damit verhalten sich diese Menüpunkte genau so wie bisher.

Online Sprachumschaltung

Die Beschriftung für den Menüpunkt in der Eigenschaft Text wird vor der Makroexpansion ab dem Zeichen @ sprachübersetzt.

Interne ID: Makros für Kontextmenü

Text

Beschriftung des Menüeintrags im Menü. Der Eintrag muss eindeutig sein. Sind mehrere Einträge mit gleichem Text vorhanden, wird zur Runtime nur der erste dieser Menüeinträge angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Ist beim Makro $TAGS$ kein Übersetzungsindikator (@) enthalten, wird der komplette Text übersetzt.


Grafische Ausprägungen

Handbuch -> Menüs -> Projektieren im Editor -> Einträge definieren -> Grafische Ausprägungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Menüs können grafisch durch folgende Eigenschaften beeinflusst werden

Parameter | Beschreibung
Grafikdatei Interne ID: Grafische Ausprägungen Grafikdatei Grafikdatei, die im ganz linken Bereich angezeigt wird. Mehr im Online Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Zeigt im ganz linken Bereich eine Grafikdatei an.
Hintergrundgrafik Interne ID: Grafische Ausprägungen Hintergrundgrafik Eigenschaften für die Hintergrundgrafik des Menüeintrags. Mehr im Online Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Legt hinter den Menüeintrag eine Grafikdatei. Die Ausrichtung kann entweder in Originalgröße oder gestreckt erfolgen.
Häkchen Interne ID: Grafische Ausprägungen Häkchen Vor dem Menüeintrag wird ein Häkchen angezeigt. Dies dient nur zur grafischen Darstellung. Default: inaktiv. Mehr im Online Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Zeigt im ganz linken Bereich ein Häckchen an. Dieses Häckchen hat keinerlei Einfluss auf die Verfügbarkeit der verknüpften Funktionalität sondern dient nur der Anzeige. Eine Steuerung der Anzeige und der Funktionalität in der Runtime kann nur über VBA/VSTA erfolgen.
Sichtbar Interne ID: Grafische Ausprägungen Sichtbar Steuert, ob der Menüeintrag zur Runtime angezeigt wird. Default: aktiv Mehr im Online Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Aktiviert: Menüeintrag wird zur Runtime angezeigt und verknüpfte Funktionalität steht zur Verfügung. Eine Steuerung der Sichtbarkeit zur Runtime kann nur über VBA/VSTA erfolgen.
Trennlinie aktiv Interne ID: Grafische Ausprägungen Trennlinie aktiv Aktiv: Statt eines Menüeintrags wird eine horizontale Trennlinie eingefügt. Breite und Farbe der Linie können definiert werden. Default: inaktiv Mehr im Online Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Zeigt an Stelle des Menüeintrags eine waagrechte Trennlinie zur logischen Unterteilung des Menüs an. Die Trennlinie kann in der Breite von 0 bis 50 Pixel und in der Farbe frei definiert werden.


Untermenü

Handbuch -> Menüs -> Projektieren im Editor -> Einträge definieren -> Untermenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Untermenüs zu erstellen:

  1. aktivieren Sie die Eigenschaft Untermenü

    Interne ID: Untermenü

    Untermenü

    Der Menüeintrag führt keine Aktion aus, sondern öffnet ein Untermenü.

    Default: Inaktiv.

    Mehr im Online Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. rechts davon wird ein neues leeres Menüfeld erstellt
  3. definieren Sie die Einträge für das Untermenü oder weitere Untermenüs

Untermenüs werden durch einen Pfeil nach rechts angezeigt. Untermenüs können auch geschachtelt aufgebaut werden.


Bedienen während der Runtime

Handbuch -> Menüs -> Bedienen während der Runtime

Die Menüs des Menü-Editors entsprechen in Ihrer Bedienung den aus Windows-Anwendungen gewohnten Funktionalität.

Menüs werden zur Runtime fix in der linken oberen Ecke platziert.

Hinweis: Bei anstehenden Alarmen kann die Alarmzeile die Menüs überdecken. Menüs können in diesem Fall erst bedient werden, wenn die Alarme quittiert wurden. Um das zu vermeiden, projektieren Sie die die Alarmstatuszeile an eine andere Stelle oder aktivieren Sie Rahmen für die Schablone.

Noch in diesem Kapitel

Menüs zur Runtime anzeigen


Menüs zur Runtime anzeigen

Handbuch -> Menüs -> Bedienen während der Runtime -> Menüs zur Runtime anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Hauptmenüs zur Runtime anzuzeigen, muss eine entsprechen Funktion angelegt und verknüpft werden.

Kontextmenüs werden in den Eigenschaften der betreffenden Dynamischen Elemente definiert.

Noch in diesem Kapitel

Hauptmenüs anzeigen

Kontextmenüs anzeigen


Hauptmenüs anzeigen

Handbuch -> Menüs -> Bedienen während der Runtime -> Menüs zur Runtime anzeigen -> Hauptmenüs anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion steuert die Anzeige von Hauptmenüs.

  1. erstellen Sie mit Funktion neu eine neue Funktion
  2. wählen Sie im Knoten Bilder die Funktion Menü anzeigen
  3. definieren Sie die auszuführende Aktion und das Hauptmenü

Parameter | Beschreibung
Aktion | Auswahl der Aktion:
Menü anzeigen | Das ausgewählte Menü wird angezeigt.
Menü ausblenden | Das ausgewählte Menü wird ausgeblendet.
Menü wechseln | Das aktuelle Menü wird ausgeblendet und das ausgewählte Menü wird angezeigt.
Wenn kein Menü vorhanden | Das ausgewählte Menü wird angezeigt, wenn derzeit kein anderes angezeigt ist.
Menü | Auswahl des Menüs.
Diesen Dialog zur Runtime anbieten | Aktiv: Bei Ausführung der Funktion zur Runtime wird dieser Dialog aufgeschaltet.
info Info
Im zenon Web Client (Web Server und Web Server Pro) werden Hauptmenüs nicht angezeigt. Unter CE (zenon unter Windows CE) können Menüs nur in den Standards, die Windows CE unterstützen, angezeigt werden. Andere Farben und Schriften als die Windows Farben und Schriften können in den Menüs unter CE nicht explizit ausgewählt werden.

Wird aus dem Kontextmenü in der Detailansicht die Standardfunktion erstellt, so erstellt zenon automatisch eine Funktion 'Menü anzeigen' für das ausgewählte Menü.


Kontextmenüs anzeigen

Handbuch -> Menüs -> Bedienen während der Runtime -> Menüs zur Runtime anzeigen -> Kontextmenüs anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenüs können zur Runtime für Dynamische Elemente genutzt werden. Um ein Kontextmenü zur Runtime anzuzeigen, verknüpfen Sie das Kontextmenü mit dem dem gewünschten Dynamische Element.

Dazu:

  1. navigieren Sie in den Eigenschaften des Dynamischen Elements zum Knoten Runtime

    Interne ID: Kontextmenüs anzeigen

    Runtime

    Eigenschaften für das Runtime-Verhalten des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. wählen Sie die Eigenschaft Kontextmenü

    Interne ID: Kontextmenüs anzeigen

    Kontextmenü

    Kontextmenü für das Element.
    Ein Klick mit der rechten Maustaste auf das Element öffnet das Kontextmenü in der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie das gewünschte Kontextmenü aus der Dropdownliste

attention Achtung

Kontextmenüs werden über ihren Namen referenziert. Das heißt: Wird ein Kontextmenü umbenannt, geht die Verknüpfung mit dem Dynasmischen Element verloren und muss neu erstellt werden.


Message Control

Handbuch -> Message Control

Das optionale Modul Message Control ermöglicht den automatisierten Versand von Nachrichten und deren Quittierung. Der Versand wird über eine Funktion ausgelöst, die mit einem Ereignis verknüpft werden kann. Als Medien für den Versand stehen zur Verfügung:

  • E-Mail über Microsoft Outlook
  • E-Mail über SMTP
  • SMS über GSM-Modem
  • SMS über einen SMS-Gateway
  • Sprachnachricht mit Audiodatei über Modem an Telefon
  • Sprachnachricht Text-to-Speech über Modem an Telefon

Der Status der Übertragung kann in der Chronologischen Ereignisliste (CEL) protokolliert werden.

Die Konfiguration erfolgt in zwei Abschnitten:

  • Allgemeine Einstellungen zum Versand: in den Eigenschaften der Gruppe Message Control des Arbeitsbereichs.

    Interne ID: Message Control

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Interne ID: Message Control

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Projektspezifische Einstellungen: in den Eigenschaften des Knotens Message Control im jeweiligen Projekt.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby) lizenzpflichtig. Für Clients nicht verfügbar.

Kontextmenü projektspezifische Einstellungen im Projektmanager

Menüpunkt | Aktion
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Kompatibilität mit Version 6.xx

Voraussetzungen

Message Control konfigurieren

Message Control zur Runtime

Meldungen und Fehlerbehandlung


Kompatibilität mit Version 6.xx

Handbuch -> Message Control -> Kompatibilität mit Version 6.xx

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Änderungen von Version 7 gegenüber älteren Versionen

Ab Version zenon 7.00 SP0 unterscheidet sich das Modul Message Control in Technik und Konfiguration grundlegend von früheren Versionen.

Wichtige technische Änderungen:

  • es wird kein COM-Server mehr verwendet
  • die Zusatzkomponente der Firma DerDack wird nicht mehr verwendet
  • die ZenMsgQueue wird durch ein eigenes Bild vom Typ Message Control ersetzt
  • die Konfiguration erfolgt in den Eigenschaften Message Control des Arbeitsplatzes (Versand) und den Eigenschaften Projektspezifische Einstellungen für das Modul Message Control im Projekt (projektspezifisch)

    Interne ID: Kompatibilität mit Version 6.xx

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Kompatibilität mit Version 6.xx

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • es gibt keine Detailansicht mehr
  • das Schichtenmodell und die Kalenderfunktionalität wurden entfernt
  • es gibt keine Runtime änderbaren Dateien mehr
  • E-Mailversand ist möglich über Outlook oder einen SMTP Server, wobei SMTP den Versand von Anhängen erlaubt
  • die Konfiguration der Versandarten wird nicht länger in einer eigenen messag32.ini gespeichert, sondern in der zenon6.ini
  • Auswertung Grenzwerttexte: Bisher war die Auswertung von zusammengesetzten Texten im Modul Message Control unterschiedlich zur Auswertung von Standard-Grenzwerttexten. Ab Version 7.00 werden beide gleich ausgewertet: @StringTabelle+%var1

Details zur Konfiguration lesen Sie im Kapitel Message Control konfigurieren.

attention Achtung

Nur Projekte ab Version 5.50 SP7 können nach Version 7 konvertiert werden.

Konvertierung

Aufgrund der tief gehenden Änderungen kann bei der Konvertierung keine 100% Kompatibilität garantiert werden. Das gilt auch für das Kompilieren von RT-Dateien für ältere Versionen. Beachten Sie beim Konvertieren vor allem:

  • Benutzer:
    • Benutzer mit gleichem Name (Vorname Nachname) vorhanden: Benutzer wird verwendet und Informationen werden ergänzt.
    • Kein entsprechender Benutzer vorhanden: Es wird ein neuer Benutzer angelegt, die Verknüpfung zum Ersatzmann und zur Benutzergruppe werden aufgelöst. Der Benutzer wird in die bestehende oder die bei der Konvertierung erstellte Gruppe eingetragen.
  • Benutzergruppen:
    • Benutzergruppe mit gleichem Name vorhanden: Benutzergruppe wird verwendet und Informationen werden ergänzt.
    • Keine entsprechende Benutzergruppe vorhanden: Es wird eine neue Benutzergruppe angelegt.
  • Funktionen:

    Die Funktion Empfängerdatenbank anzeigen wurde entfernt:
    Diese Funktion kann mit dem Editor nicht mehr erzeugt werden. Beim Konvertieren wird sie aber nicht gelöscht. Ihr Aufruf zur Runtime bleibt ohne Wirkung und erzeugt einen LOG-Eintrag.

  • Paging:
    Paging steht als Versandart nicht mehr zur Verfügung. Bestehende Funktionen mit Versandart Paging werde beim Konvertieren geändert auf Versandart GSM. Eine Meldung im Ausgabefenster weist darauf hin. Nach der Konvertierung müssen die Einstellungen der Funktion überprüft werden.
  • RT änderbare Dateien:
    Da die Benutzerverwaltung geändert wurde, werden keine RT änderbaren Dateien für Message Contreol benötigt. Es gibt in Version 7 auch keine Möglichkeit, alte Runtime-Daten zurückzulesen. Werden die Runtime-Dateien eines Projekts vor Version 7 benötigt, müssen diese in einem Editor vor zenon 7 zurückgelesen und dann konvertiert werden.
  • Schichten und Kalender:
    Die Funktionalität für Schichten und Kalender wurde entfernt. Bestehende Funktionen mit Zieltyp Schicht werde beim Konvertieren geändert auf Zieltyp Gruppe. Es wird allerdings keine Gruppe verknüpft. Eine Meldung im Ausgabefenster weist darauf hin. Nach der Konvertierung müssen die Einstellungen der Funktion überprüft werden.
  • SMS-Gateway:
    Da die einfache Schnittstelle keine technische Möglichkeit bietet, Nachrichten eindeutig zuordnen zu können, wird ab Version 7 nur noch die erweiterte Schnittstelle unterstützt. Beim Konvertieren muss sicher gestellt werden, dass auch der SMS-Server der Firma Dialogs entsprechend konfiguriert wird. Sonst schlägt der Versand fehl.

Import und Export

Bisherige Versionen von Message Control und Versionen ab zenon 7.00 SP0 speichern ihre Einstellungen in unterschiedlichen Dateien:

  • bis inklusive Version 6.51 SP0: message32.ini
  • ab Version 7.00 SP0: zenon6.ini

Einstellungen importieren

Wird eine ältere Version von zenon in Version 7 oder höher geöffnet, werden die Einstellungen aus der bisherigen message32.ini übernommen und soweit möglich angepasst. Die Projektierung muss immer manuell überprüft werden, da nicht alle Einstellungen 100% korrekt konvertiert werden können. So werden zum Beispiel Schichtpläne Gruppen zugewiesen, die noch weiter konfiguriert werden müssen.

Einstellungen exportieren

Die Konfiguration kann aus Version 7 in die message32.ini für ältere Versionen geschrieben werden. Dazu klicken Sie auf die globale Arbeitsbereich-Eigenschaft Message Control/Einstellungen in Messag32.ini exportieren (v6.XX) und bestätigen Sie die Sicherheitsabfrage.

Interne ID: Kompatibilität mit Version 6.xx

Einstellungen in Messag32.ini exportieren (v6.XX)

Speichert Einstellungen, die ab Version 7 getroffen werden, für Versionen 6.xx in der messag32.ini. Klick auf Schaltfläche startet Export. Aktuelle Einstellungen der messag32.ini werden nach einer Sicherheitsabfrage überschrieben. Die Einstellungen der messag32.ini dienen der Kompatibilität und betreffen nur zenon Versionen 6.xx. Ab Version 7 werden die Einstellungen in der zenon6.ini gespeichert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Achtung: Mit dem Ausführen der Eigenschaft Einstellungen in Messag32.ini exportieren (v6.XX) werden alle entsprechenden Einträge in der message32.ini überschrieben. Die INI-Datei kann damit Einträge enthalten, die im bisherigen Modul Message Control nicht ausgeführt werden können oder Konfigurationen unbrauchbar machen.


Voraussetzungen

Handbuch -> Message Control -> Voraussetzungen

Die Voraussetzungen für den Einsatz von Message Control hängen von den gewünschten Übertragungsmedien ab:

Medium

Voraussetzung

E-Mail über Microsoft Outlook:

Laufende Instanz von Microsoft Outlook.

E-Mail über SMTP:

Der Runtime-Server, der den Versand durchführt, muss an ein Netzwerk angeschlossen sein.

Ein E-Mail-Account muss verfügbar sein. Die Server mit dem Zugang zum Account müssen erreichbar sein.

SMS über GMS:

Ein GSM-Modem muss an den Computer angeschlossen und über eine serielle Schnittstelle (COM-Port) ansprechbar sein. USB-Modems erstellen bei der Installation in der Regel einen virtuellen COM-Port, über den sie angesprochen werden können.

SMS über SMS-Gateway:

SMS-Server der Firma DIALOGS Software GmbH.

Sprachausgabe:

Voice-Modem mit DTMF-Funktionalität.

Text to Speech Engine. (Teilweise in Betriebssystem enthalten. Kann durch eigenes Text-To-Speech Paket bei COPA-DATA erweitert werden.)

Telefon:

Voice-Modem mit DTMF-Funktionalität.

Wird ein ISDN-Adapter verwendet, muss dieser folgende Funktionen unterstützen:

  • Unterstützung von Sprachnachrichten (LINEMEDIAMODE_AUTOMATEDVOICE)
  • Unterstützung von DTMF-Signalen (für die Entgegennahme des PIN-Codes bei der Quittierung einer Nachricht)
  • Unterstützung des Telephony Application Programming Interface (TAPI)

Einschränkungen

  • Das Modul steht unter WIndows CE nicht zur Verfügung.


Message Control konfigurieren

Handbuch -> Message Control -> Message Control konfigurieren

Message Control wird konfiguriert über:

  • globale Eigenschaften der Medien für den Versand
  • projektspezifische Eigenschaften für die Nachricht
  • Funktionen, die zur Runtime ausgeführt werden, für Versand und Verwaltung der Nachrichten

Nachrichten können verschickt und quittiert werden als:

  • E‑Mail
  • SMS
  • Sprachnachricht

Nachrichtenversand konfigurieren

Um den Versand einer Nachricht zu konfigurieren:

  1. wählen Sie das Medium für den Versand
  2. aktivieren Sie für dieses Medium die Eigenschaft Versandart aktiv

    Interne ID: Message Control konfigurieren

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. konfigurieren Sie das Medium
  4. konfigurieren Sie die projektspezifischen Eigenschaften
  5. konfigurieren Sie die Benutzer bzw. Benutzergruppen, die über das Medium erreicht werden sollen
  6. erstellen Sie eine Funktion Sende Nachricht und

    verknüpften Sie die Funktion:

    1. mit einem Button oder
    2. mit der Eigenschaft Funktion bei jenen Grenzwerten, die bei Verletzung, dieses Nachricht verschicken sollen

      Interne ID: Message Control konfigurieren

      Funktion

      Funktion, die in der Runtime automatisch ausgeführt werden soll, wenn der Grenzwert verletzt wird.
      Ist der Zustand als Alarm definiert, kann die spontane Funktionsausführung unterbunden werden (Option "Aufruf über die Alarm-Verwaltung").
      Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Konfiguration der Nachricht

Eine Nachricht setzt sich aus mehreren Teilen zusammen:

  • Betreff: wird für E-Mails definiert über:
    • Betreff (Id) in den globalen Einstellungen für Outlook

      Interne ID: Message Control konfigurieren

      Betreff (Id)

      Eindeutiger Betreff der ausgehenden Nachricht. Dieser dient bei eingehenden Nachrichten als Kriterium, ob die Nachricht für Message Control bestimmt ist und verarbeitet werden soll.

      Eingehenden E-Mails müssen diesen Text im Betreff enthalten, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Betreff nicht enthalten, werden nicht an Message Control weitergeleitet.

      Mindestlänge: 4 Zeichen

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • E-Mail Betreff in den globalen Einstellungen für E‑Mails über SMTP

      Interne ID: Message Control konfigurieren

      E-Mail Betreff

      Eingabe des Betreffs für ausgehende E-Mails.

      Eingehenden E-Mails müssen diesen Text ebenfalls im Betreff stehen haben, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Text nicht enthalten, werden weder an Message Control weitergeleitet noch vom Server gelöscht.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Eigenschaft Dynamischer Teil des Betreffs in den projektspzifischen Einstellungen für E‑Mail über SMTP oder Outlook

      Interne ID: Message Control konfigurieren

      Dynamischer Teil des Betreffs

      Definiert den projektspezifischen Teil des Betreffs ausgehender und eingehender Nachrichten. Wird zusammen mit der Eigenschaft E-Mail Nachricht (Outlook)/Betreff (Id) bzw.E-Mail Nachricht (SMTP) /E-Mail Betreff in den globalen Message Control Versandeinstellungen verwendet. Eingehende Nachrichten werden auf diesen Inhalt zur Weiterleitung an Message Control gefiltert.

      Interne ID: Message Control konfigurieren

      Message Control

      Gruppe für projektübergreifende Einstellungen im Message Control.

      Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

      Interne ID: Message Control konfigurieren

      Projektspezifische Einstellungen

      Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

      Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Message Control konfigurieren

      E-Mail Nachricht (SMTP)

      Einstellungen zum E-Mail-Versand per SMTP.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Message Control konfigurieren

      E-Mail Nachricht (Outlook)

      Gruppe für Einstellungen der Versandart Outlook.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Der Text kann Platzhalter beinhalten für:

      • Schlüssel aus der Sprachtabelle
      • Name einer Variablen
      • zusammengesetzter Eintrag in der Sprachtabelle

      Syntax: $ kennzeichnet Text; Textteile werden durch Semikolon (;)getrennt, der Text muss mit einem Semikolon (;)enden.
      Beispiel: $@Achtung;%Var1;

      Eine Liste der Parameter finden Sie im Kapitel Grenzwerttext Parameter.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Begrüßung und Fehleingabe: wird für Sprachnachrichten definiert über:
    • Sprachnachricht Text-To-Speech über Modem

      bzw.

    • Sprachnachricht mit Audiodatei über Modem
  • Nachrichtentext: wird für E-Mails, SMS und Sprachnachrichten definiert in:
    • der Option Konstanter Text

Verwaltung der Messsage Queue konfigurieren

Um die Nachrichten zur Runtime zu verwalten:

  1. erstellen Sie ein Bild vom Typ Message Control
  2. erstellen und konfigurieren Sie eine Funktion Bildumschaltung auf dieses Bild
  3. verknüpfen Sie die Funktion mit einem Button

Damit können zur Runtime Nachrichten auf ihren Status überprüft und die Message Queue überwacht werden.

Message Control zur Runtime

Um Message Control zur Runtime einzusetzen_:

  1. aktivieren Sie Message Control über
    • Eigenschaft Aktiv bei Runtimestart: Wird diese Eigenschaft aktiviert, startet Message Control mit der Runtime automatisch.

      Interne ID: Message Control konfigurieren

      Aktiv bei Runtimestart

      Aktiv: Message Control wird mit der Runtime gestartet.

      Default: aktiv

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Funktion Sende Nachricht aktivieren: Wird diese Funktion aufgerufen, wird Message Control gestartet. Nachrichten werden erst ab diesen Zeitpunkt verarbeitet.

Beim normalen Beenden der Runtime wird ein Abbild der aktuelle Nachrichten-Queue gespeichert. Dieses Abbild kann auch während der Laufzeit jederzeit über die Funktion Aktuelle Queue speichern erstellt werden. Message Control kann zur Runtime über die Funktion Sende Nachricht deaktivieren beendet werden.

Nachricht unterdrücken

Message Control führt einer Liste mit deaktivierten Elementen. Deaktiviert bedeutet, dass deren Alarme keine Meldung auslösen.

Ist bei eine Grenzwertverletzung eine Funktion Sende Nachricht verknüpft, werden Nachrichten nur erstellt und verschickt, wenn weder die Variable noch der Alarm unterdrückt sind.

  • Die Variable ist unterdrückt, wenn ihr Bereich oder eine der verknüpften Anlagengruppen in der Liste unterdrückter Elemente vorhanden ist.
  • Der Alarm ist unterdrückt, wenn die Alarm/Ereignis-Gruppe, die Alarm/Ereignis-Klasse oder der Alarmbereich in der Liste unterdrückter Elemente vorhanden ist.

Diese Liste kann mit der Funktion Gruppen/Klassen/Bereiche/Anlagen unterdrücken zur Runtime geändert werden. Es können Alarme und Anlagen aktiviert oder deaktiviert werden. Unterdrückte Einträge werden in der CEL geloggt, sofern für die Eigenschaft In CEL protokollieren alle Bestätigungen oder nur negative Bestätigungen gewählt wurde.

Interne ID: Message Control konfigurieren

In CEL protokollieren

Legt fest, welche Ereignisse in der CEL protokolliert werden. Auswahl aus Dropdownliste:

- alle Bestätigungen

- keine Bestätigungen

- nur negative Bestätigungen

- nur positive Bestätigungen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Das Aktivieren oder Deaktivieren von Einträgen erfolgt remanent im Netzwerk. Werden zum Beispiel für Wartungszwecke die Alarme eines Anlagenteils abgeschaltet, bleibt diese Einstellung auch nach dem Beenden der Runtime aktiv und wird beim Neustart wieder angewendet.

Noch in diesem Kapitel

Allgemeine Einstellungen zum Versand

Projektspezifische Einstellungen

Bild vom Typ Message Control anlegen

Benutzerverwaltung

Funktionen


Allgemeine Einstellungen zum Versand

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die für den Versand von Nachrichten eingesetzten Medien werden global definiert und können von jedem Projekt und jedem Arbeitsbereich genutzt werden.

Als Medien für den Versand stehen zur Verfügung:

  • E-Mail-Nachricht über Outlook
  • E-Mail-Nachricht über SMTP
  • SMS-Nachricht über GSM-Modem
  • SMS-Nachricht über SMS-Gateway
  • Sprachnachricht Audiodatei über Modem
  • Sprachnachricht Text-to-Speech über Modem

Um die Eigenschaften zu konfigurieren:

  1. markieren Sie den Arbeitsbereich
  2. wählen Sie in den Eigenschaften die Gruppe Message Control

    Interne ID: Allgemeine Einstellungen zum Versand

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Interne ID: Allgemeine Einstellungen zum Versand

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren und konfigurieren Sie die gewünschten Medientypen

Die Einstellungen werden in der zenon6.ini im Bereich [Message Control] gespeichert.

Noch in diesem Kapitel

E-Mail-Nachricht über Outlook

E-Mail-Nachricht über SMTP

SMS-Nachricht über GSM-Modem

SMS-Nachricht über SMS-Gateway

Sprachnachricht Audiodatei über Modem

Sprachnachricht Text-to-Speech über Modem

Einträge zenon6.ini


E-Mail-Nachricht über Outlook

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand -> E-Mail-Nachricht über Outlook

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Versand einer Nachricht als E-Mail mit Microsoft Outlook muss:

  • die Versandart über die Eigenschaft Versandart aktiv aktiviert worden sein

    Interne ID: E-Mail-Nachricht über Outlook

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • auf dem ausführenden Rechner eine laufende Instanz von Microsoft Outlook mit Verbindung zum Netzwerk/Internet vorhanden sein

Sind die Nachrichten quittierpflichtig, muss dafür gesorgt sein, das das Postfach innerhalb der Zeit, die für die Quittierung zur Verfügung steht abgefragt wird. Dieser Zeitraum wird mit der Funktion Sende Nachricht (Registerkarte Empfangsbestätigung) festgelegt.

Konfiguration

  1. Aktivieren Sie die Versandart über die Eigenschaft Versandart aktiv.
  2. Definieren Sie über die Eigenschaft Profil den Namen des Outlook-Profils, das benutzt werden soll.

    Interne ID: E-Mail-Nachricht über Outlook

    Profil

    Name des Outlook Profils, das für den Versand benutzt werden soll. Auswahl aus Dropdownliste.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Legen Sie über die Eigenschaft Betreff (Id) einen eindeutigen Betreff fest.
    Dieser Betreff dient als Kriterium für die Weiterleitung eingehender Nachrichten an das Modul Message Control. E-Mails, die diese ID nicht enthalten, werden nicht an Message Control weitergeleitet. Er muss:

    Interne ID: E-Mail-Nachricht über Outlook

    Betreff (Id)

    Eindeutiger Betreff der ausgehenden Nachricht. Dieser dient bei eingehenden Nachrichten als Kriterium, ob die Nachricht für Message Control bestimmt ist und verarbeitet werden soll.

    Eingehenden E-Mails müssen diesen Text im Betreff enthalten, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Betreff nicht enthalten, werden nicht an Message Control weitergeleitet.

    Mindestlänge: 4 Zeichen

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • mindestens vier Zeichen Länge aufweisen
    • bei Antworten unverändert belassen werden
  4. Konfigurieren Sie die Eigenschaften für Projektspezifische Einstellungen.

    Interne ID: E-Mail-Nachricht über Outlook

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Interne ID: E-Mail-Nachricht über Outlook

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Konfigurieren Sie Benutzer und Benutzergruppen.
  6. Legen Sie benötigte Funktionen an und verknüpfen Sie diese mit Buttons oder Ereignissen.

Verhalten zur Laufzeit

  1. Sobald die Runtime gestartet wird, werden Nachrichten abgerufen.
  2. Nachrichten werden entsprechend den Einstellungen zusammengesetzt und verschickt, sobald eine entsprechende Funktion ausgeführt wird.
  3. Antwortet ein Benutzer auf eine Nachricht, wird dessen Antwort beim Nachrichten abruf gelesen und an Message Control übergeben.
  4. Dieses führt die Quittierung durch.


E-Mail-Nachricht über SMTP

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand -> E-Mail-Nachricht über SMTP

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Versand einer Nachricht als E-Mail über einen SMTP-Server muss:

  • die Versandart über die Eigenschaft Versandart aktiv aktiviert worden sein

    Interne ID: E-Mail-Nachricht über SMTP

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • auf dem ausführenden Rechner eine Verbindung zum Mail-Server vorhanden sein
  • ein E-Mail Account definiert sein
  • der Mail-Server mit seinen Zugangsdaten konfiguriert sein

Sind die Nachrichten quittierpflichtig, muss dafür gesorgt sein, das das Postfach innerhalb der Zeit, die für die Quittierung zur Verfügung steht abgefragt wird. Dieser Zeitraum wird mit der Funktion Sende Nachricht (Registerkarte Empfangsbestätigung) festgelegt.

Konfiguration

  1. Aktivieren Sie die Versandart über die Eigenschaft Versandart aktiv.
  2. Konfigurieren Sie die Eigenschaften für:
    • Posteingangsserver

      Interne ID: E-Mail-Nachricht über SMTP

      Posteingangsserver

      Eigenschaften für die Konfiguration des POP3 Servers für den Posteingang.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Postausgangsserver

      Interne ID: E-Mail-Nachricht über SMTP

      Postausgangsserver

      Eigenschaften für die Konfiguration des SMTP Servers für den Postausgang.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Konfigurieren Sie die Eigenschaften für Projektspezifische Einstellungen.
  4. Konfigurieren Sie Benutzer und Benutzergruppen.
  5. Legen Sie benötigte Funktionen an und verknüpfen Sie diese mit Buttons oder Ereignissen.

Verhalten zur Laufzeit

  1. Sobald die Runtime gestartet wird, werden Nachrichten abgerufen.
  2. Nachrichten werden entsprechend den Einstellungen zusammengesetzt und verschickt, sobald eine entsprechende Funktion ausgeführt wird.
  3. Antwortet ein Benutzer auf eine Nachricht, wird dessen Antwort beim Nachrichtenabruf gelesen und an Message Control übergeben.
  4. Dieses führt die Quittierung durch.

Es kann immer nur ein Thread Verbindungen öffnen. Eine Verbindung wird immer für den Thread geöffnet, der sie benötigt, und sofort nach Beendigung des Datenaustausches geschlossen.Während eine Nachricht gesendet wird, kann kein anderer Thread den Posteingang abfragen oder ebenfalls eine Nachricht senden. Wird der Posteingang abgefragt, kann ebenfalls kein anderer Thread eine Abfrage starten oder Nachrichten senden.

Tritt bei einem der Abläufe ein Fehler auf, wie Authentifizierung fehlgeschlagen oder Kommando nicht unterstützt, werden alle aktiven Verbindungen geschlossen.

Die korrekten Einstellungen für die Konfiguration sind beim Anbieter des verwendeten E-Mail Accounts erhältlich.

Abläufe

Abruf eingehender E-Mails

  1. Aufbau einer Verbindung zum parametrierten Posteingangsserver und dem entsprechenden Port.
    Ob die Verbindung gesichert oder ungesichert erfolgt, hängt ab von den Einstellungen der Eigenschaft Verschlüsselung.

    Interne ID: E-Mail-Nachricht über SMTP

    Verschlüsselung

    Auswahl der Verschlüsselung für die Verbindung. Klick öffnet Dropdownliste für Auswahl. Mögliche Optionen:

    keine: die Verbindung wird ungesichert aufgebaut.

    SSL Version 2 und 3: die Verbindung wird mit dem hybriden Verschlüsselungsmodell SSL aufgebaut.

    TLS Version 1: die Verbindung wird mit TLS aufgebaut. TLS Version1 ist der Nachfolger von SSL und entspricht SSL 3.1.

    Default: SSL Version 2 und 3

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Alle Mails im Posteingang werden durch die Kommandos STAT und RETR abgerufen. Auf Basis des Betreffs wird entschieden, ob eine E‑Mail relevant ist. Nicht relevante Nachrichten werden übersprungen. Relevante Nachrichten werden an Message Control weitergeleitet und - solange die Eigenschaft Gelesene E-Mails am Server belassen deaktiviert ist - mit dem Kommando DELE vom Server gelöscht.

    Interne ID: E-Mail-Nachricht über SMTP

    Gelesene E-Mails am Server belassen

    Aktiv: E-Mails werden nach dem Abruf am Server nicht gelöscht.

    Default: inaktiv

    Hinweis: : Da POP3 keinerlei Möglichkeit zum Filtern der Mails beim Abrufen beinhaltet, werden immer alle im Posteingang vorhandenen Mails abgerufen. Ist diese Eigenschaft aktiv, steigt der Speicherverbauch am Server und die Performance beim ABruf kann sinken.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Die Verbindung wird durch Senden des QUIT Kommandos und anschließendes Schließen der Verbindung beendet.

Versand einer E-Mail

  1. Je nach Einstellung wird eine gesicherte oder ungesicherte Verbindung zum SMTP-Server aufgebaut.
  2. Wenn konfiguriert, wird die SMTP Authentifizierung über das AUTH Kommando durchgeführt.
  3. Die zu versendende Nachricht wird im MIME-Format mit den SMTP Kommandos MAIL, RCPT und DATA übertragen.
  4. Die SMTP Verbindung wird durch Senden des QUIT Kommandos und anschließendes Schließen der Verbindung beendet.
  5. Falls eine POP3-Verbindung besteht, wird auch diese geschlossen.


SMS-Nachricht über GSM-Modem

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand -> SMS-Nachricht über GSM-Modem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Versand einer Nachricht als SMS über ein GSM-Modem muss:

  • die Versandart über die Eigenschaft Versandart aktiv aktiviert worden sein

    Interne ID: SMS-Nachricht über GSM-Modem

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ein GSM-Modem an den sendenden Rechner angeschlossen und über eine serielle Schnittstelle (COM-Port) ansprechbar sein
    Hinweis: USB-Modems erstellen bei der Installation in der Regel einen virtuellen COM-Port, über den sie angesprochen werden können.
  • das GSM-Modem eventuell mit einer Herstellersoftware initialisiert werden, damit es sich ins GSM-Netz einwählen kann

Konfiguration

  1. Aktivieren Sie die Versandart über die Eigenschaft Versandart aktiv.
  2. Wählen Sie über die Eigenschaft Modemanschluss (seriell) den COM-Port des Modems aus der Dropdownliste aus.
    Der korrekte Port wird in den Systemeigenschaften beim Modem angezeigt.
    Hinweis: Nach einem Neuanschluss des Modems oder Neustart des Computers muss das Modem eventuell wieder mit der Herstellersoftware initialisiert werden, bevor es mit Message Control verwendet werden kann. Der COM-Port kann mit einem Neuanschluss des Modems oder Neustart des Computers wechseln.

    Interne ID: SMS-Nachricht über GSM-Modem

    Modemanschluss (seriell)

    Auswahl des COM-Ports, an dem das Modem ansprechbar ist. Klick öffnet Dropdownliste zur Auswahl. Korrekter Port kann in der Systemsteuerung in der Gruppe Telefon und Modem ausgelesen werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Geben Sie in der Eigenschaft PIN-Code, falls nötig, die PIN für das Modem ein.

    Interne ID: SMS-Nachricht über GSM-Modem

    PIN-Code

    Eingabe der PIN für das Modem. Eintrag darf nur aus Ziffern bestehen. Wird für die Verwendung des Modems kein PIN benötigt, wird der Wert dieser Eigenschaft ignoriert.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. Überprüfen Sie die Verbindung mit Klick auf Verbindung prüfen.

    Interne ID: SMS-Nachricht über GSM-Modem

    Verbindung prüfen

    Klick auf Schaltfläche testet Verbindung zum Modem. Es wird getestet:

    1. Öffnen und Vorbereiten des in der Eigenschaft Modemanschluss (seriell) definierten COM-Ports.

    2. Antwort des Modemsa.

    3. PIN-Authentifizierung, wenn benötigt.

    4. Modemkonfiguration. Für die Konfiguration wird für Nummer der Kurzmitteilungszentrale ein Dummy-Eintrag verwendet, da die Gültigkeit dieser Telefonnummer erst durch das Versenden einer SMS geprüft werden kann.

    Interne ID: SMS-Nachricht über GSM-Modem

    Nummer der Kurzmitteilungszentrale

    Eingabe der Telefonnummer des SMSC (Kurzmitteilungszentrale) des verwendeten GSM-Providers. Eintrag muss eine gültige Telefonnummer sein und darf nur aus Ziffern bestehen. Ein führendes + als Kennzeichen für internationale Vorwahl ist erlaubt.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Der Erfolg oder Misserfolg des Tests wird in einer Meldung angezeigt. Fehlerinformationen werden in die LOG-Dateien geschrieben.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Geben Sie in das Eigenschaftenfeld Nummer der Kurzmitteilungszentrale die Rufnummer für die Kurzmitteilungszentrale ein.
  6. Konfigurieren Sie die Eigenschaften für Projektspezifische Einstellungen.

    Interne ID: SMS-Nachricht über GSM-Modem

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Interne ID: SMS-Nachricht über GSM-Modem

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  7. Konfigurieren Sie Benutzer und Benutzergruppen.
  8. Legen Sie benötigte Funktionen an und verknüpfen Sie diese mit Buttons oder Ereignissen.

Verhalten zur Laufzeit

  1. Sobald die Runtime gestartet wird, wird die Verbindung zum Modem aufgebaut und konfiguriert.
  2. Nachrichten werden abgerufen.
  3. Nachrichten werden entsprechend den Einstellungen zusammengesetzt und verschickt, sobald eine entsprechende Funktion ausgeführt wird.
  4. Antwortet ein Benutzer auf eine Nachricht, wird dessen Antwort beim Abruf gelesen und an Message Control übergeben.
  5. Dieses führt die Quittierung durch.
  6. Liegen nach dem Abruf keine unvollständigen mehrteiligen Nachrichten mehr vor, werden die gelesenen Nachrichten am Modem gelöscht.
  7. Beim Beenden der Runtime wird die Verbindung zum Modem getrennt.

info Info

Wir das Modem neu angeschlossen oder der Rechner neu gestartet, wird empfohlen:

  • Führen Sie die vom GSM-Betreiber gelieferte Konfigurationssoftware aus, damit das Modem initialisiert wird und sich zum Netz verbindet.
  • Überprüfen Sie in der Systemsteuerung, ob das Modem nach dem erneuten Anschließen wieder den gleichen COM-Port verwendet.

Konstanten, Timeouts und Parameter

Eintrag

Wert

Erklärung

Timeout für AT Befehle

10000 ms

Das Modem hat 10 Sekunden Zeit, auf die Übermittlung eines AT-Kommandos zu antworten.

SMS Polling-Intervall

20000 ms

Alle 20 Sekunden wird geprüft, ob neue SMS eingegangen sind und diese gelesen. Sind keine unvollständigen mehrteiligen SMS vorhanden, werden alle gelesenen Nachrichten gelöscht.

COM-Timeouts

schreiben: 5 Sekunden

lesen: sofortige Rückgabe

Zum Schreiben der Bytes auf den COM-Port (max. 400 bei SMS-PDU mit Maximalgröße) stehen 5 Sekunden Zeit zur Verfügung.

Beim Lesen vom COM-Port wird der aktuelle Inhalt des Empfangspuffers ausgelesen und sofort zurückgesprungen.

COM-State-Konfiguration
  • Baud: 9600
  • Binärmodus
  • Paritäts-Check: inaktiv
  • Clear-to-Send und Data-Set-Ready: nicht überwacht
  • Data-Terminal-Ready und Request-To-Send Flow Control: aktiviert
  • Bit pro Byte: 8
  • Parität: Keine
  • Stop Bit:1

Standardkonfiguration einer seriellen Schnittstelle.

Puffer

Grenze

Maximalwert

Erklärung

Größe des Sendepuffers und Größe des Empfangspuffers für die serielle Schnittstelle in Byte

4096

Die einzelnen PDUs sind maximal 400 Byte groß. Beim Versenden einer SMS werden die PDUs einzeln hintereinander gesendet.

Beim Empfangen werden alle seit dem letzten Polling-Intervall gekommenen SMS auf einmal als Block abgefragt. Das Modem kann damit mindestens 10 PDUs auf einmal in den Empfangspuffer der seriellen Schnittstelle schieben.

Größe des Gesamtpuffers für Konvertierungen und eingehende SMS in Byte

12288

Da eine SMS-PDU maximal 400 Byte im Empfangspuffer belegt, können innerhalb eines Polling-Intervalls von 20 Sekunden mit diesem Puffer maximal 30 SMS-Teile mit Maximalgröße empfangen werden.

Die Maximalgröße einer zu versendenden SMS beträgt 6144 Unicode-Zeichen.


SMS-Nachricht über SMS-Gateway

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand -> SMS-Nachricht über SMS-Gateway

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Versand einer Nachricht als SMS über ein SMS-Gateway muss:

  • die Versandart über die Eigenschaft Versandart aktiv aktiviert worden sein

    Interne ID: SMS-Nachricht über SMS-Gateway

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ein SMS-Server der Firma DIALOGS GmbH vorhanden und konfiguriert sein

Ablauf

Konfiguration

  1. Aktivieren Sie die Versandart über die Eigenschaft Versandart aktiv.
  2. Konfigurieren Sie Ausgangsordner, Eingangsordner und Statusordner.

    Interne ID: SMS-Nachricht über SMS-Gateway

    Statusordner

    Ordner des SMS-Servers für Statusmeldung bei SMS-Versand.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: SMS-Nachricht über SMS-Gateway

    Eingangsordner

    Eingangsordner des SMS-Servers für den SMS-Versand.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: SMS-Nachricht über SMS-Gateway

    Ausgangsordner

    Ausgangsordner des SMS-Servers für den SMS-Versand.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Konfigurieren Sie den Anfangsbuchstabe der SMS-Dateien.
    Dieser Anfangsbuchstabe ist eindeutig für das Projekt. Wird ein SMS-Gateway von mehreren Projekten benutzt, muss für jedes Projekt ein eindeutiger Präfix definiert werden.

    Interne ID: SMS-Nachricht über SMS-Gateway

    Anfangsbuchstabe der SMS-Dateien

    Anfangsbuchstabe der SMS-Dateien. Muss für jedes Projekt eindeutig sein.

    Länge: 1 Zeichen

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. Anfangsbuchstabe der Sperr/Semaphor-Dateien konfigurieren: Legt Anfangbuchstabe für die Sperr/Semaphor-Dateien. Dieser Anfangsbuchstabe ist eindeutig für das Projekt. Wird ein SMS-Gateway von mehreren Projekten benutzt, muss für jedes Projekt ein eindeutiger Präfix definiert werden.

    Interne ID: SMS-Nachricht über SMS-Gateway

    Anfangsbuchstabe der Sperr/Semaphor-Dateien

    Anfangsbuchstabe der Sperrdatei. Muss für jedes Projekt eindeutig sein.

    Länge: 1 Zeichen

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Konfigurieren Sie die Eigenschaft Smart Alarming.
    Wird die Eigenschaft aktiviert, dann werden SMS wie folgt behandelt:

    Interne ID: SMS-Nachricht über SMS-Gateway

    Smart Alarming

    Aktiv: Smartalarming wird verwendet.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Alle ausgehenden Nachrichten werden überprüft. Beginnt eine Nachricht mit dem Text ALARM!, dann wird die Nachricht nicht im normalen Format (ID; Nachricht) gesendet, sondern im Format: ALARM! ID; Nachricht.
    • Mit dem Versand einer Nachricht, die mit ALARM! beginnt, ird das Mobiltelefon des Empfängers automatisch auf „sehr laut“ geschaltet, sofern das Telefon dies unterstützt.
    • Auch eingehenden Nachrichten werden auf diese Zeichenkette überprüft.
      Befindet sich an Position 6 ein Rufzeichen (!), dann werden die ersten 6 Stellen abgeschnitten und die Nachricht von Message Control weitergeleitet.
  6. Konfigurieren Sie die Eigenschaften für Projektspezifische Einstellungen.

    Interne ID: SMS-Nachricht über SMS-Gateway

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Interne ID: SMS-Nachricht über SMS-Gateway

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  7. Konfigurieren Sie Benutzer und Benutzergruppen.
  8. Legen Sie benötigte Funktionen an und verknüpfen Sie diese mit Buttons oder Ereignissen.

Verhalten zur Laufzeit

  1. Sobald die Runtime gestartet wird, werden Nachrichten abgerufen.
  2. Nachrichten werden entsprechend den Einstellungen zusammengesetzt und verschickt, sobald eine entsprechende Funktion ausgeführt wird.
  3. Antwortet ein Benutzer auf eine Nachricht, wird dessen Antwort beim Nachrichtenabruf gelesen und an Message Control übergeben.
  4. Dieses führt die Quittierung durch.


Sprachnachricht Audiodatei über Modem

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand -> Sprachnachricht Audiodatei über Modem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Versand einer Sprachnachricht als Audiodatei muss:

  • die Versandart über die Eigenschaft Versandart aktiv aktiviert worden sein

    Interne ID: Sprachnachricht Audiodatei über Modem

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • im Knoten Dateien/Multimedia Audiodateien jeweils eine Audiodatei hinterlegt werden für:
    • Begrüßung
    • Nachricht
    • Fehleingabe
  • ein Modem an den sendenden Rechner angeschlossen und konfiguriert sein
  • das Telefongerät des Empfängers DTMF-fähig sein

Ablauf

Konfiguration

  1. Aktivieren Sie die Versandart über die Eigenschaft Versandart aktiv.
  2. Konfigurieren Sie die Einstellungen für Timeout und Begrüßungstext wiederholen.

    Interne ID: Sprachnachricht Audiodatei über Modem

    Begrüßungstext wiederholen

    Anzahl der Wiederholungen für den Willkommenstext.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Sprachnachricht Audiodatei über Modem

    Timeout

    Zeit in Minuten, nach der eine stehende Verbindung abgebrochen und beendet werden soll. Zeitintervall muss länger sein als die für das Abspielen und Bestätigen der Nachricht benötigte Zeit.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Wählen Sie über die Eigenschaft Leitungsname das Modem für den Versand aus.
    Die Auswahl erfolgt aus einer Dropdownliste, die alle in der Systemsteuerung konfigurierten Modems auflistet.

    Interne ID: Sprachnachricht Audiodatei über Modem

    Leitungsname

    Auswahl des zu verwenden Modems aus Dropdownliste.

    Wird keine Dropdownliste angezeigt, dann wurde für diesen Rechner kein Modem konfiguriert.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. Konfigurieren Sie die Eigenschaften für Projektspezifische Einstellungen.

    Interne ID: Sprachnachricht Audiodatei über Modem

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Interne ID: Sprachnachricht Audiodatei über Modem

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Konfigurieren Sie Benutzer und Benutzergruppen.
  6. Legen Sie benötigte Funktionen an und verknüpfen Sie diese mit Buttons oder Ereignissen.
  7. Diese Methode ist quittierpflichtig.

Verhalten zur Laufzeit

  1. Sobald eine Funktion die Versandmethode aufruft, wird über das Modem ein Anruf initiert.
  2. Sobald der Anruf entgegengenommen wird, werden die Begrüßung und die Nachricht abgespielt.
  3. Die Nachricht muss vom Empfänger mit dem jeweils gültigen Code quittiert werden:
    • PIN-Code für Bestätigung

      Interne ID: Sprachnachricht Audiodatei über Modem

      PIN-Code

      PIN Code, mit dem der Benutzer den Empfang der Nachricht bestätigt.

      Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft NA-Code unterscheiden.

      Interne ID: Sprachnachricht Audiodatei über Modem

      NA-Code

      Not-Available-Code, mit dem der Benutzer die Annahme der Nachricht verweigern kann.

      Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft PIN-Code unterscheiden.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • NA-Code für Ablehnung

    Der Empfänger kann zusätzlich:

    • die eben gehörte Datei durch Drücken der Raute-Taste (#) am Telefon erneut abrufen
    • eine Eingabe durch Drücken der Stern-Taste (*) rückgängig machen; in diesem Fall wird erneut die Begrüßung abgespielt


Sprachnachricht Text-to-Speech über Modem

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand -> Sprachnachricht Text-to-Speech über Modem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Versand einer Sprachnachricht per Text-to-Speech muss:

  • die Versandart über die Eigenschaft Versandart aktiv aktiviert worden sein

    Interne ID: Sprachnachricht Text-to-Speech über Modem

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ein Modem an den sendenden Rechner angeschlossen und konfiguriert sein
  • das Telefongerät des Empfängers DTMF-fähig sein
  • Eine Text-to-Speech (TTS) Engine installiert sein

Ablauf

Konfiguration

  1. Aktivieren Sie die Versandart über Eigenschaft Versandart aktiv.
  2. Konfigurieren Sie die Einstellungen für Timeout und Begrüßungstext wiederholen

    Interne ID: Sprachnachricht Text-to-Speech über Modem

    Begrüßungstext wiederholen

    Anzahl der Wiederholungen für den Willkommenstext.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Sprachnachricht Text-to-Speech über Modem

    Timeout

    Zeit in Minuten, nach der eine stehende Verbindung abgebrochen und beendet werden soll. Zeitintervall muss länger sein als die für das Abspielen und Bestätigen der Nachricht benötigte Zeit.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Wählen Sie über die Eigenschaft Leitungsname das Modem für den Versand aus.
    Die Auswahl erfolgt aus einer Dropdownliste, die alle in der Systemsteuerung konfigurierten Modems auflistet.

    Interne ID: Sprachnachricht Text-to-Speech über Modem

    Leitungsname

    Auswahl des zu verwenden Modems aus Dropdownliste.

    Wird keine Dropdownliste angezeigt, dann wurde für diesen Rechner kein Modem konfiguriert.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. Definieren Sie über die Eigenschaft Stimme Sprache und Stimme.
    Hinweis: Zusätzliche Stimmen und Sprachen erhalten Sie bei Ihrem COPA-DATA Vertriebspartner.

    Interne ID: Sprachnachricht Text-to-Speech über Modem

    Stimme

    Auswahl der Stimme und Sprache aus Dropdownliste.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Konfigurieren Sie die Eigenschaften für Projektspezifische Einstellungen.

    Interne ID: Sprachnachricht Text-to-Speech über Modem

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Interne ID: Sprachnachricht Text-to-Speech über Modem

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  6. Konfigurieren Sie Benutzer und Benutzergruppen.
  7. Legen Sie benötigte Funktionen an und verknüpfen Sie diese mit Buttons oder Ereignissen.
  8. Diese Methode ist quittierpflichtig.

Verhalten zur Laufzeit

  1. Sobald eine Funktion die Versandmethode aufruft, wird über das Modem ein Anruf initiert.
  2. Sobald der Anruf entgegengenommen wird, werden die Begrüßung und die Nachricht abgespielt.
  3. Die Nachricht muss vom Empfänger mit dem jeweils gültigen Code quittiert oder abgelehnt werden.
    • PIN-Code für Bestätigung

      Interne ID: Sprachnachricht Text-to-Speech über Modem

      PIN-Code

      PIN Code, mit dem der Benutzer den Empfang der Nachricht bestätigt.

      Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft NA-Code unterscheiden.

      Interne ID: Sprachnachricht Text-to-Speech über Modem

      NA-Code

      Not-Available-Code, mit dem der Benutzer die Annahme der Nachricht verweigern kann.

      Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft PIN-Code unterscheiden.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • NA-Code für Ablehnung

    Der Empfänger kann zusätzlich:

    • die eben gehörte Datei durch Drücken der Raute-Taste (#) am Telefon erneut abrufen
    • eine Eingabe durch Drücken der Stern-Taste (*) rückgängig machen; in diesem Fall wird erneut die Begrüßung abgespielt

info Info

Abhängig vom Betriebssystem und installierter Software sind bereits Stimmen und Sprachen hinterlegt, auf die zenon zugreifen kann. Weitere Stimmen und Sprachen erhalten Sie bei Ihrem COPA-DATA Vertriebspartner. Verfügbar sind aktuell: Deutsch, Englisch (US, UK, Indisch), Französisch und Spanisch.


Einträge zenon6.ini

Handbuch -> Message Control -> Message Control konfigurieren -> Allgemeine Einstellungen zum Versand -> Einträge zenon6.ini

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Message Control wird vor allem über globale und projektspezifische Eigenschaften konfiguriert. In der zenon6.ini werden die globalen Eigenschaften der Medien im Abschnitt [Message Control] abgebildet:

Eintrag | Erklärung
[MESSAGE CONTROL] | Abschnitt in der zenon6.ini
Outlook_Profile= | Name des Outlook Profils, das für den Versand benutzt werden soll. Default: leer
Outlook= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
Subject= | Eindeutige ID, die eingehende Mails wieder enthalten müssen, um in Message Control verarbeitet zu werden. Default: leer
Telephone_Timeout= | Zeit in Minuten, nach der eine stehende Verbindung abgebrochen und beendet werden soll. Zeitintervall muss länger sein als die für das Abspielen und Bestätigen der Nachricht benötigte Zeit. Default: 1
Telephone_WelcomeMessageCount= | Anzahl der Wiederholungen für den Willkommenstext. Default: 5
Telephone_IgnoreDisconnect= | 1: Ein Verbindungsabbruch (z. B. Empfänger beendet Gespräch) wird ignoriert und die Nachricht wird vollständig abgespielt, bevor die Leitung geschlossen wird. 0: Nachricht wird abgebrochen, wenn Verbindung abbricht. Default: 0
Telephone= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
Speech= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
Speech_Rate= | Geschwindigkeit der Stimme. Minimum: -10 Maximum: 10 Default: 0
Speech_Volume= | Lautstärke der Stimme. Zahl entspricht dem Prozentwert vom Maximalwert der gewählten Stimme. Maximum: 100 Minimum: 1 0: Wert vom Betriebssystem wird ohne Änderung übernommen. Default: 0
Speech_Name= | Auswahl der Stimme und Sprache Default: leer
SMSGateway= | Versand aktiv? 0: inaktiv 1: aktiv Default: 0
SMSGateway_Inbox= | Eingangsordner für SMS-Versand. Default: leer
SMSGateway_Outbox= | Ausgangsordner für SMS-Versand. Default: leer
SMSGateway_Statusbox= | Ordner für Statusmeldung bei SMS-Versand. Default: leer
SMSGateway_Prefix= | Anfangsbuchstabe der SMS-Dateien. Länge: 1 Zeichen Default: F
SMSGateway_SemaphorPrefix= | Anfangsbuchstabe der Sperrdatei. Länge: 1 Zeichen Default: S
SMSGateway_OriginId= | Absenderkennung für SMS-Versand. Default: leer
SMSGateway_TimeOut= | Timeout-Zeit für ausgehende Nachrichten in Minuten. Legt fest, nach welcher Zeitspanne einen Nachricht als "nicht erfolgreich verschickt" interpretiert wird. Default: 60
SMSGateway_SmartAlarm= | Smartalarming wird verwendet. Default: 0
SMTP_POP_MAIL= | Der Eintrag bestimmt, ob die Versandart aktiv ist. 1: aktiv 0: inaktiv Default: 0
SMTP_SRV_IS_POP= | Der Eintrag bestimmt, ob der POP3 Server als SMTP Server verwendet wird. 1: POP 3 ist SMTP 0: POP3 und SMTP sind unterschiedliche Server Default: 0
SMTP_SERVER= | Der vom Benutzer eingegebene SMTP Server. Default: leer
SMTP_PORT= | Definiert den verwendeten Port am SMTP Server. Default: 25
SMTP_SECURITY= | Art der Absicherung der Verbindung zum SMTP Server. 0: keine Absicherung 1: SSLv2 und SSLv3 2: TLSv1 Default: 0
SMTP_AUTH= | Authentifizierung am Postausgangsserver. 0: keine Absicherung 1: vor Versand am POP3 Server anmelden 2: SMTP AUTH Default: 0
SMTP_OTHER_CREDS= | Legt fest, ob der Postausgangsserver andere Anmeldedaten als der Posteingangsserver verwendet. 0: inaktiv 1: aktiv Default: 0
SMTP_USER= | Benutzername für den Postausgangsserver gespeichert. Default: leer
SMTP_PASSWORD= | Hex-Dump des verschlüsselten Passwortes zur Authentifizierung am Postausgangsserver. Default: leer
SMTP_SUBJECT= | Betreff für ausgehende E-Mails und zur Erkennung, ob eine eingehende E-Mail am Server für die Versandart relevant ist. Default: MsgCtrl_Alert
SMTP_USER_IS_ADDR= | Definiert, ob der Benutzername für die Authentifizierung gegenüber dem Postausgangsserver als Absenderadresse für ausgehende Mails verwendet wird. 1: aktiv 0: inaktiv Default: 0
SMTP_OUT_ADDR= | Adresse für ausgehende E-Mails. Default: leer
POP_SERVER= | POP3 Server gespeichert. Default: leer
POP_PORT= | Definiert den verwendeten Port am POP3 Server. Default: 110
POP_SECURITY= | Art der Absicherung der Verbindung zum POP3 Server. 0: keine Absicherung 1: SSLv2 und SSLv3 2: TLSv1 Default: 0
POP_APOP= | Legt fest, ob das APOP-Kommando verwendet werden soll. 1: aktiv 0: inaktiv Default: 0
POP_KEEP_MAILS= | Legt fest, ob gelesene E-Mails am Server belassen werden. 1: E-Mails werden nach dem Abruf am Server nicht gelöscht 0: E-Mails werden nach dem Abruf am Server gelöscht Default: 0
POP_USER= | Benutzername für den Posteingangsserver. Default: leer
POP_PASSWORD= | Hex-Dump des verschlüsselten Passwortes zur Authentifizierung am Posteingangsserver gespeichert. Default: leer
POP_POLL_INTERVALL= | Minimaler Abstand zwischen zwei POP3-Abfragen in Sekunden. MInimal: 10 Default: 60
GSM_SMS= | Aktivierung von SMS über GMS als Versandart. 0: aktive nicht 0: inaktiv Default: 0 Der Eintrag entspricht in der Message32.ini dem Eintrag [GSM] à On und wird beim Importieren/Exportieren der INI-Einstellungen berücksichtigt.
GSM_SMS_COM= | COM-Port, der für die Verbindung zum Modem verwendet wird. Default: leer
GSM_SMS_SMSC= | Telefonnummer der Kurzmitteilungszentrale des GSM-Providers. Default: leer
GSM_SMS_PIN= | PIN-Code, der zur Authentifizierung gegenüber dem Modem verwendet wird. Default: leer

info Info

Da manche Eigenschaften die Werte anderer Eigenschaften übernehmen können und sich die zuletzt eingegebenen Werte merken, müssen die Werte der INI-Einträge nicht immer mit den im Editor angezeigten Werten der Eigenschaften übereinstimmen. Betroffen sind davon folgende Eigenschaften, wenn sie als nicht verfügbar dargestellt werden:

SMTP_SERVER -> Serveradresse

Interne ID: Einträge zenon6.ini

Serveradresse

Nur verfügbar, wenn Posteingangsserver für ausgehende E-Mails verwenden inaktiv ist.

Interne ID: Einträge zenon6.ini

Posteingangsserver für ausgehende E-Mails verwenden

Aktiv: Der Posteingangsserver wird als Server für den Postausgang verwendet. Diese Eigenschaft betrifft nur die Serveradresse.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Vollständige Adresse des SMTP Servers.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SMTP_USER -> Benutzername

Interne ID: Einträge zenon6.ini

Benutzername

Benutzername für den Postausgangsserver.

Nur verfügbar, wenn Andere Anmeldedaten als am Posteingangsserver verwenden aktiviert wurde. Ist die Eigenschaft inaktiv, wird der Benutzername aus der Eigenschaft Benutzername in der Gruppe Posteingangsserver angezeigt. Sonst wird der zuletzt eingegebene Benutzername für den Postausgangsserver angezeigt.

Interne ID: Einträge zenon6.ini

Posteingangsserver

Eigenschaften für die Konfiguration des POP3 Servers für den Posteingang.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Einträge zenon6.ini

Benutzername

Benutzername für die Anmeldung am Posteingangsserver (POP3).

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Einträge zenon6.ini

Andere Anmeldedaten als am Posteingangsserver verwenden

Nur verfügbar, wenn für die Eigenschaft Authentifizierung am Postausgangsserver SMTP Authentifizierung am Postausgangsserver verwenden gewählt wurde.

Interne ID: Einträge zenon6.ini

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Für die Authentifizierung am Postausgangsserver werden andere Anmeldedaten als am Posteingangsserver verwendet.

Inaktiv: Anmeldedaten für den Posteingangsserver werden auch Postausgangsserver verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SMTP_PASSWORD -> Passwort

Interne ID: Einträge zenon6.ini

Passwort

Passwort für den Postausgangsserver.

Nur verfügbar, wenn die Eigenschaft Andere Anmeldedaten als am Posteingangsserver verwenden aktiviert wurde. Ist die Eigenschaft inaktiv, ist das in der Eigenschaft Passwort der Gruppe Posteingangsserver definierte Passwort hinterlegt.

Interne ID: Einträge zenon6.ini

Passwort

Passwort für die Anmeldung am Posteingangsserver (POP3).

Das Passwort wird verschlüsselt gespeichert und nur für die Authentifizierung entschlüsselt. Bei der Eingabe werden keine Zeichen im Klartext angezeigt. Das Feld zeigt immer 16 Zeichen an, unabhängig von der tatsächlichen Länge des Passworts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Das Passwort wird verschlüsselt gespeichert und nur für die Authentifizierung entschlüsselt. Bei der Eingabe werden keine Zeichen im Klartext angezeigt. Das Feld zeigt immer 16 Zeichen an, unabhängig von der tatsächlichen Länge des Passworts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

SMTP_OUT_ADDR -> Adresse für ausgehende E-Mails

Interne ID: Einträge zenon6.ini

Adresse für ausgehende E-Mails

Nur verfügbar, wenn die Eigenschaft Benutzername ist Adresse für ausgehende E-Mails inaktiv oder nicht verfügbar ist.

Interne ID: Einträge zenon6.ini

Benutzername ist Adresse für ausgehende E-Mails

Nur verfügbar, wenn die EigenschaftAuthentifizierung am Postausgangsserver einen anderen Wert als keine Authentifizierung enthält.

Aktiv: Der für die Authentifizierung am SMTP Server verwendete Benutzername wird auch als Absenderadresse für die ausgehende E-Mails verwendet.

Inaktiv: der in der Eigenschaft Adresse für ausgehende E-Mails definierte Absender wird verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Absenderadresse für ausgehende E-Mails.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Projektspezifische Einstellungen

Handbuch -> Message Control -> Message Control konfigurieren -> Projektspezifische Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die projektspezifischen Einstellungen erreichen Sie über die Eigenschaften des Knotens Message Control im jeweiligen Projekt. Sie enthalten Eigenschaften für die Konfiguration der Nachricht und deren Zustellung. Generelle Eigenschaften für die Versandmedien werden in den Eigenschaften Message Control des Arbeitsbereichs konfiguriert.

Interne ID: Projektspezifische Einstellungen

Message Control

Gruppe für projektübergreifende Einstellungen im Message Control.

Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

Interne ID: Projektspezifische Einstellungen

Projektspezifische Einstellungen

Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktivierung von Message Control für das Projekt

Message Control kann zur Runtime aktiviert werden über:

  • Eigenschaft Aktiv bei Runtimestart: Wird diese Eigenschaft aktiviert, startet Message Control mit der Runtime automatisch.

    Interne ID: Projektspezifische Einstellungen

    Aktiv bei Runtimestart

    Aktiv: Message Control wird mit der Runtime gestartet.

    Default: aktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Funktion Sende Nachricht aktivieren: Wird diese Funktion aufgerufen wird Message Control gestartet. Nachrichten werden erst ab diesen Zeitpunkt verarbeitet.

Message Control kann zur Runtime über die Funktion Sende Nachricht deaktivieren beendet werden.

Projektspezifische Eigenschaften

In den projektspezifischen Eigenschaften kann festgelegt werden:

  • Dynamischer Teil des Betreffs über die Eigenschaft Dynamischer Teil des Betreffs: Eingehende Nachrichten werden auf diesen Inhalt zur Weiterleitung an Message Control gefiltert.

    Interne ID: Projektspezifische Einstellungen

    Dynamischer Teil des Betreffs

    Definiert den projektspezifischen Teil des Betreffs ausgehender und eingehender Nachrichten. Wird zusammen mit der Eigenschaft E-Mail Nachricht (Outlook)/Betreff (Id) bzw.E-Mail Nachricht (SMTP) /E-Mail Betreff in den globalen Message Control Versandeinstellungen verwendet. Eingehende Nachrichten werden auf diesen Inhalt zur Weiterleitung an Message Control gefiltert.

    Interne ID: Projektspezifische Einstellungen

    E-Mail Betreff

    Eingabe des Betreffs für ausgehende E-Mails.

    Eingehenden E-Mails müssen diesen Text ebenfalls im Betreff stehen haben, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Text nicht enthalten, werden weder an Message Control weitergeleitet noch vom Server gelöscht.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projektspezifische Einstellungen

    E-Mail Nachricht (SMTP)

    Einstellungen zum E-Mail-Versand per SMTP.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projektspezifische Einstellungen

    Betreff (Id)

    Eindeutiger Betreff der ausgehenden Nachricht. Dieser dient bei eingehenden Nachrichten als Kriterium, ob die Nachricht für Message Control bestimmt ist und verarbeitet werden soll.

    Eingehenden E-Mails müssen diesen Text im Betreff enthalten, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Betreff nicht enthalten, werden nicht an Message Control weitergeleitet.

    Mindestlänge: 4 Zeichen

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projektspezifische Einstellungen

    E-Mail Nachricht (Outlook)

    Gruppe für Einstellungen der Versandart Outlook.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Der Text kann Platzhalter beinhalten für:

    • Schlüssel aus der Sprachtabelle
    • Name einer Variablen
    • zusammengesetzter Eintrag in der Sprachtabelle

    Syntax: $ kennzeichnet Text; Textteile werden durch Semikolon (;)getrennt, der Text muss mit einem Semikolon (;)enden.
    Beispiel: $@Achtung;%Var1;

    Eine Liste der Parameter finden Sie im Kapitel Grenzwerttext Parameter.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Protokollierung der Nachricht über die Eigenschaft In CEL protokollieren: In der Chronologischen Ereignisliste können Nachrichten nach unterschiedlichen Kriterien protokolliert werden:

    Interne ID: Projektspezifische Einstellungen

    In CEL protokollieren

    Legt fest, welche Ereignisse in der CEL protokolliert werden. Auswahl aus Dropdownliste:

    - alle Bestätigungen

    - keine Bestätigungen

    - nur negative Bestätigungen

    - nur positive Bestätigungen

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • alle Nachrichten
    • keine
    • nur Nachrichten, die abgelehnt oder nicht beantwortet wurden
    • nur Nachrichten, die quittiert wurden
  • Kennzeichnung des Status der Nachricht über Farbe und Grafik: Die Spalte Status des Bildes Message Control kann über eine Grafik und Farbe den Status einer Nachricht darstellen.

Konfiguration der Nachricht

Eine Nachricht setzt sich zusammen aus:

  1. Statischer Teil: Unveränderbarer Betreff, der in den globalen Einstellungen für E-Mails definiert wird.
  2. Dynamischer Teil: Projektspezifischer Teil des Betreffs. Wird mit der Eigenschaft Dynamischer Teil des Betreffs festgelegt.

Aufbau des dynamische Teils des Betreffs:

  • $: kennzeichnet "formatierten" Text.
  • Textteile werden als Parameter betrachtet, wenn sie
    • mit einem Semikolon (;)vom restlichen Text getrennt sind und
    • mit einem Semikolon (;)enden.

Ein Parameter kann sein:
- Schlüssel aus der Sprachtabelle
- Name einer Variablen
- zusammengesetzter Eintrag in der Sprachtabelle

Paramter

Zur Runtime

Aktion

Schlüssel:

@MyText

Es wird überprüft, ob für die aktuelle Sprache in der Sprachtabelle einen Eintrag für @MyText vorhanden ist.
  • Vorhanden: Eintrag wird in die Nachricht eingefügt.
  • Nicht vorhanden: Je nach Einstellung der Projekteigenschaft Nicht übersetzte Schlüsselwörter anzeigen wird entweder @MyText oder MyText in die Nachricht eingefügt.

    Interne ID: Projektspezifische Einstellungen

    Nicht übersetzte Schlüsselwörter anzeigen

    Einstellung für die Darstellung von Schlüsselwörter, die in keiner der Sprachdateien existieren:

    Aktiv: Darstellung zur Runtime als Schlüsselwort, zum Beispiel: @Text.
    Inaktiv: Darstellung zur Runtime ohne vorangestelltes @, zum Beispiel: Text

    Hinweis: Existiert das Schlüsselwort in einer der Sprachdateien, verfügt jedoch über keine Übersetzung, wird zur Runtime kein Text angezeigt (leerer String).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Variable:

%Var1

Es wird überprüft, ob die Variable vorhanden ist und der Wert gelesen werden kann.

  • Vorhanden: Wert der Variablen wird genommen und als String in der Text eingefügt.
  • Nicht vorhanden/nicht lesebar: Der Text xxx wird in die Nachricht eingefügt.

Zusammengesetzter Eintrag:

@StringTabelle+%var1Text

Es wird überprüft, ob:

  • 1. die Variable vorhanden ist und der Wert gelesen werden kann. Wert wird als String an den Präfix-Text („MultipleText") angehängt.
  • 2. für den Text in der Sprachtabelle ein Eintrag vorhanden ist
  • Variable und Text vorhanden:
    Text wird in die Nachricht eingefügt.
    Beispiel: Wert der Variable ist 33. Dann wird in der der Sprachtabelle nach @StringTabelle33 gesucht und der dazu gehörende Text eingefügt.
  • Nicht vorhanden: Je nach Einstellung der Projekteigenschaft Nicht übersetzte Schlüsselwörter anzeigen wird entweder @MyText oder MyText in die Nachricht eingefügt.

Beispiel: $@Achtung;%Var1;


Bild vom Typ Message Control anlegen

Handbuch -> Message Control -> Message Control konfigurieren -> Bild vom Typ Message Control anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit einem Bild vom Typ Message Control verwalten Sie zur Runtime die Message-Queue eines Projekts.

Um ein Bild vom Typ Message Control anzulegen:

  1. legen Sie ein neues Bild an
  2. wählen Sie in der Dropdownliste für den Bildtyp Message Control
  3. klicken Sie in das Bild
  4. wählen Sie Menü Kontrollelemente -> Vorlage einfügen
  5. die Kontrollelemente werden in das Bild eingefügt
  6. erstellen Sie eine Funktion für die Bildumschaltung und verknüpfen Sie diese mit einem Button, um das Bild zur Runtime aufschalten zu können

Kontrollelemente | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Buttons | Buttons für Aktionen zur Runtime.
Aktualisieren | Aktualisiert Ansicht. Die aktuellen Daten werden aus der Message Queue in das Bild geladen. Der Zeitpunkt der letzten Aktualisierung kann über das Feld Letzte Aktualisierung angezeigt werden.
Löschen | Löscht ausgewählten Eintrag aus der Liste. Es können nur Nachrichten gelöscht werden, die noch nicht verschickt wurden.
Filter | Öffnet Dialog zur Konfiguration der Filter für die Ansicht.
Stopp/Weiter | Startet und stoppt zyklische Aktualisierung der Liste.
Fenster | Listen und Felder, die zur Runtime angezeigt werden können.
Anzahl der Nachrichten | Zahl der aktuell vorhandenen Nachrichten.
Letzte Aktualisierung | Zeitpunkt der letzten Aktualisierung.
unterdrückte Alarm/Ereignis-Gruppen | Alarm/Ereignis-Gruppen, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
unterdrückte Alarm/Ereignis-Klassen | Alarm/Ereignis-Klassen, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
unterdrückte Alarm/Ereignis-Bereiche | Alarm/Ereignis-Bereiche, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
unterdrückte Anlagen | Anlagen, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
Nachrichten-Warteliste | Liste der Nachrichten. Enthält Nachrichten, die verschickt, bestätigt oder gelöscht wurden oder noch zu verschicken sind. Die Nachrichten werden nur angezeigt und können nicht mehr bearbeitet werden. Spaltenüberschriften können individuell benannt werden und sind durch Voranstellung des Zeichens @ sprachumschaltbar.
Filterprofile | Profilverwaltung
Profilauswahl | Öffnet Dialog zur Auswahl eines Profils.
Speichern | Speichert aktuelle Einstellungen als Profil.
Löschen | Löscht Profil.
Import | Öffnet Dialog zum Import von Profilen aus Datei.
Export | Öffnet Dialog zum Export von Profilen in Datei.
info Info
Die Spalten der Liste können im Editor über die Filter für die Funktion Bildumschaltung konfiguriert werden, zur Runtime über Bildumschaltung -> Dialog in der RT anzeigen oder den Button Filter. Spalten der Liste können mit individuellen Beschriftungen versehen werden und sind sprachumschaltbar.


Benutzerverwaltung

Handbuch -> Message Control -> Message Control konfigurieren -> Benutzerverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Benutzer und Benutzergruppen für Message Control werden in der zenonBenutzerverwaltung angelegt und verwaltet. Damit ein Benutzer in Message Control verwendet werden kann, muss in der Benutzerverwaltung die Eigenschaft Message Control Benutzer bzw. Message Control Gruppe aktiv gesetzt sein.

Interne ID: Benutzerverwaltung

Message Control Gruppe

Aktiv: Benutzergruppe wird von Message Control verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Benutzerverwaltung

Message Control Benutzer

Aktiv: Benutzer wird von Message Control verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Benutzer und Benutzergruppen werden über Namen referenziert.

Benutzer

Parameter | Beschreibung
Message Control Benutzer | Aktiv: Der Benutzer wird vom Modul Message Control verwendet.
Telefon | Nummer des Festnetztelefons des Benutzers. Wird für Text-to-Speech verwendet. Eingabe in Ziffern. Ein führendes + als Abkürzung für 00 der internationalen Ländervorwahl ist erlaubt.
Mobiltelefon | Nummer des Mobiltelefons des Benutzers. Wird für Nachrichten über GSM und SMS verwendet. Eingabe in Ziffern, ein führendes + als Abkürzung für 00 der internationalen Ländervorwahl ist erlaubt.
E-Mail | E-Mail Adresse des Benutzers.
Ersatzperson | Auswahl einer Ersatzperson, falls der Benutzer nicht erreicht wird oder die Annahme der Nachricht verweigert. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl.
PIN-Code | PIN-Code, mit dem der Benutzer die Nachricht bestätigt.
NA-Code | PIN-Code, mit dem der Benutzer die Annahme der Nachricht verweigert (not available). Nachricht wird dann an nächsten Benutzer in der Liste gesendet.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

attention Achtung

Die Quittier-Codes für PIN (Bestätigung) und NA (Ablehnung) müssen sich unterscheiden und sollten nicht zu ähnlich gewählt werden.

Sind beide Codes ident, wird der Code als PIN und damit als Bestätigung der Nachricht interpretiert.

Wird ein unbekannter Code empfangen, wird bei SMS und E‑Mail die Nachricht an die Ersatzperson geschickt, bei Sprachnachrichten die Fehlernachricht abgespielt.

Reihenfolge innerhalb der Benutzergruppe

Benutzer können über die Eigenschaft Benutzerreihenfolge innerhalb einer Benutzergruppe gereiht werden.

Interne ID: Benutzerverwaltung

Benutzerreihenfolge

Legt Reihenfolge der Benutzer in der Gruppe fest. Klick auf Schaltfläche ... öffnet Dialog zur Konfiguration der Reihenfolge.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter | Beschreibung
Benutzer | Liste aller verfügbarer Benutzer
Nach oben | Reiht ausgewählten Benutzer um eine Position nach oben.
Nach unten | Reiht ausgewählten Benutzer um eine Position nach unten.
OK | Übernimmt Änderungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen aller Registerkarten und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

Zur Runtime wird die Reihenfolge der Benutzer aus der globale Benutzerverwaltung an die in dieser Eigenschaft definierte Reihenfolge angefügt. Lokale Benutzer werden also immer vor globalen Benutzern angezeigt.

info Info

Details zur Benutzerverwaltung in zenon lesen Sie im Handbuch Benutzerverwaltung.


Funktionen

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Funktionen steuern die Verwendung von Message Control zur Runtime.

Damit werden:

  • Message Control eingeschaltet und ausgeschaltet
  • Nachrichten verschickt
  • das Bild vom Typ Message Control zur Verwaltung der Nachrichten-Queue aufgeschaltet
  • die Nachrichten-Queue gespeichert
  • Elemente für Nachrichten unterdrückt

Noch in diesem Kapitel

Bildumschaltung auf ein Bild vom Typ Message Control

Aktuelle Queue speichern

Gruppen/Klassen/Bereiche/Anlagen unterdrücken

Sende Nachricht

Sende Nachricht aktivieren

Sende Nachricht deaktivieren


Bildumschaltung auf ein Bild vom Typ Message Control

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Bildumschaltung auf ein Bild vom Typ Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit einer Bildumschaltung auf ein Bild vom Typ Message Control rufen Sie zur Runtime das Bild auf, um die Message Queue zu überwachen. Um die Bildumschaltung zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Bildumschaltung

    Interne ID: Bildumschaltung auf ein Bild vom Typ Message Control

    Bildumschaltung

    Diese Funktion öffnet ein ausgewähltes Bild. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

    Mehr im Online-Handbuch

  3. der Auswahldialog für das Bild wird geöffnet
  4. wählen Sie das gewünschte Bild vom Typ Message Control
  5. der Dialog zur Konfiguration der Spalteneinstellungen wird geöffnet
  6. konfigurieren Sie die Spalten
  7. schließen Sie die Konfiguration mit Klick auf OK ab
  8. verknüpfen Sie die Funktion mit einem Button, um sie zur Runtime aufrufen zu können

Noch in diesem Kapitel

Spalteneinstellungen


Spalteneinstellungen

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Bildumschaltung auf ein Bild vom Typ Message Control -> Spalteneinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellungen für das Filtern der Nachrichten

Parameter | Beschreibung
Listenfeld | Darstellung der konfigurierten Spalten.
Spaltenauswahl | Öffnet Dialog zur Auswahl der Spalten.
Spaltenformat | Öffnet Dialog zur Formatierung der Spalten.
OK | Übernimmt alle Änderungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Spaltenauswahl

Spaltenformat


Spaltenauswahl

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Bildumschaltung auf ein Bild vom Typ Message Control -> Spalteneinstellungen -> Spaltenauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Spaltenauswahl

Konfiguration der zur Runtime anzuzeigenden Spalten.

Schaltfläche | Funktion
Hinzufügen | Verschiebt die markierten Spalten aus den verfügbaren zu den ausgewählten. Nach der Bestätigung des Dialogs mit OK werden sie in der Detailansicht angezeigt.
Alle hinzufügen | Verschiebt alle verfügbaren Spalten zu den ausgewählten Spalten.
Entfernen | Entfernt die markierten Spalten aus den ausgewählten und zeigt sie in der Liste der verfügbaren Spalten an. Nach der Bestätigung des Dialogs mit OK werden sie aus der Detailansicht entfernt.
Alle entfernen | Entfernt alle Spalten aus der Liste der ausgewählten Spalten.
Nach oben | Verschiebt den ausgewählten Eintrag nach oben. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
Nach unten | Verschiebt den ausgewählten Eintrag nach unten. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Spaltenformat

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Bildumschaltung auf ein Bild vom Typ Message Control -> Spalteneinstellungen -> Spaltenformat

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Spaltenformat

Formatierung der Spalten.

Parameter

Beschreibung

Verfügbare Spalten

Liste der über Spaltenauswahl bereit gestellten Spalten. Die hier selektierte Spalte wird über die Einstellungen der Sektion Parameter konfiguriert.

Parameter

Einstellungen für ausgewählte Spalte.

Beschriftung

Name für Spaltentitel. Der Spaltentitel ist online sprachumschaltbar. Dazu müsen Sie ein @ Zeichen vor den Namen eingeben.

Breite

Breite der Spalte in Zeichen.
Berechnung: Zahl mal durchschnittlicher Zeichenbreite der gewählten Schriftart.

Ausrichtung

Ausrichtung.

Mögliche Einstellungen:

  • Linksbündig: Text wird in der Spalte am linken Rand ausgerichtet.
  • Zentriert: Text wird in der Spalte zentriert dargestellt.
  • Rechtsbündig: Text wird in der Spalte am rechten Rand ausgerichtet.

Spaltenfilter im Prozessbild sperren

Aktiv: Der Filter für diese Spalte kann zur Runtime nicht verändert werden.

Hinweis: Nur verfügbar für:

  • Batch Control
  • Erweiterter Trend
  • Message Control
  • Rezeptgruppen-Manager

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Aktuelle Queue speichern

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Aktuelle Queue speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion speichert ein Abbild der aktuellen Message Queue. Wird die Runtime normal beendet, wird dieses Abbild durch ein beim Beenden der Runtime gültiges Abbild der Queue ersetzt. Um diese Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie in der Gruppe Message Control die Funktion Aktuelle Queue speichern

    Interne ID: Aktuelle Queue speichern

    Message Control

    Diese Gruppe beinhaltet Funktionen für das optionale Modul Message Control.

    Mehr im Online-Handbuch

  3. verknüpfen Sie die Funktion mit einem Button, um sie zur Runtime aufrufen zu können

Dieser Funktion wird immer am prozessführenden Rechner ausgeführt.


Gruppen/Klassen/Bereiche/Anlagen unterdrücken

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Gruppen/Klassen/Bereiche/Anlagen unterdrücken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Message Control führt einer Liste mit deaktivierten Elementen. Deaktiviert bedeutet, dass deren Alarme keine Meldung auslösen. Diese Liste kann mit dieser Funktion geändert werden. Es können Alarme und Anlagen aktiviert oder deaktiviert werden. Die Projektierung erfolgt im Editor und kann zur Runtime für Änderungen frei gegeben werden.

Ist bei einem Grenzwerte eine Funktion Sende Nachricht verknüpft, werden Nachrichten nur erstellt und verschickt, wenn weder die Variable noch der Alarm unterdrückt sind.

Interne ID: Gruppen/Klassen/Bereiche/Anlagen unterdrücken

Sende Nachricht

Diese Funktion sendet eine Nachricht des optionalen Moduls Message Control.

Mehr im Online-Handbuch

Interne ID: Gruppen/Klassen/Bereiche/Anlagen unterdrücken

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: Gruppen/Klassen/Bereiche/Anlagen unterdrücken

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Die Variable ist unterdrückt, wenn ihr Bereich oder eine der verknüpften Anlagengruppen in der Liste unterdrückter Elemente vorhanden ist.
  • Der Alarm ist unterdrückt, wenn die Alarm/Ereignis-Gruppe, die Alarm/Ereignis-Klasse oder der Alarmbereich in der Liste unterdrückter Elemente vorhanden ist.

Unterdrückte Einträge werden in der CEL geloggt, sofern für die Eigenschaft In CEL protokollieren alle Bestätigungen oder nur negative Bestätigungen gewählt wurde.

Interne ID: Gruppen/Klassen/Bereiche/Anlagen unterdrücken

In CEL protokollieren

Legt fest, welche Ereignisse in der CEL protokolliert werden. Auswahl aus Dropdownliste:

- alle Bestätigungen

- keine Bestätigungen

- nur negative Bestätigungen

- nur positive Bestätigungen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Funktion projektieren

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie in der Gruppe Message Control die Funktion Gruppen/Klassen/Bereiche/Anlagen unterdrücken

    Interne ID: Gruppen/Klassen/Bereiche/Anlagen unterdrücken

    Message Control

    Diese Gruppe beinhaltet Funktionen für das optionale Modul Message Control.

    Mehr im Online-Handbuch

  3. der Dialog zur Konfiguration der zu unterdrückenden oder aktivierenden Elemente wird geöffnet
  4. konfigurieren Sie die Elemente
  5. schließen Sie den Dialog mit Klick auf OK
  6. verknüpfen Sie die Funktion mit einem Button, um sie zur Runtime aufrufen zu können

Registerkarte Allgemein

Parameter

Beschreibung

Alarm/Ereignis-Gruppen

Liste der konfigurierten Alarm/Ereignis-Gruppen.

Alarmbereiche

Liste der konfigurierten Alarmbereiche.

Alarm/Ereignis-Klassen

Liste der konfigurierten Alarm/Ereignis-Klassen.

Aktivieren

Aktiv: Beim Aufruf der Funktion werden die ausgewählten Elemente in die Liste der unterdrückten Elemente eingefügt.

Deaktivieren

Aktiv: Beim Aufruf der Funktion werden die ausgewählten Elemente aus der Liste der unterdrückten Elemente entfernt.

Dialog zur Runtime anzeigen

Beim Aufruf der Funktion wird dieser Dialog geöffnet und der Anwender kann die Konfiguration vor Ausführung anpassen.

Der Dialoge wird zur Runtime am aktuellen Rechner aufgeschaltet. Im Netzwerkbetrieb wird der Dialog bei Aufruf am Client auch am Client aufgeschaltet.

OK

Übernimmt Einstellungen aus allen Registerkarten und schließt Dialog.

Abbrechen

Verwirft Einstellungen aus allen Registerkarten und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.

Die Auswahl von Elemente aus einer Liste erfolgt über Mausklick. Mehrfachauswahl ist möglich. Dazu reicht ein weiterer Mausklick, es müssen keine zusätzlichen Tasten gedrückt werden. Erneuter Klick auf ein ausgewähltes Element, wählt das Element wieder ab.

Registerkarte Anlagenmodellierung

Eigenschaft | Beschreibung
Symbolleiste | Siehe Kapitel Symbolleiste und Kontextmenü Detailansicht.
Hinzufügen | Fügt ausgewählte Gruppen und Ebenen zur Auswahl hinzu.
Entfernen | Löscht ausgewählte Elemente aus der Auswahl.
OK | Übernimmt Einstellungen aus allen Registerkarten und schließt Dialog.
Abbrechen | Es wird kein Element ausgewählt.
Hilfe | Öffnet Online-Hilfe.

Gruppen hinzufügen

  • wählen Sie das gewünschte Anlagenmodell
  • wählen Sie eine Anlagengruppe oder Ebene, Elemente auf der gleichen hierarchischen Stufe können per Multiselect gleichzeitig ausgewählt werden (Taste Strg gedrückt halten)
  • fügen Sie diese über die Schaltfläche Hinzufügen zur Liste im untern Bereich des Dialogs hinzu
  • Untergruppen werden nicht automatisch hinzugefügt
  • es können beliebig viele Gruppen verknüpft werden

Gruppen löschen

  • wählen Sie in der Liste im unteren Bereich des Dialogs die gewünschten Elemente
  • klicken Sie auf die Schaltfläche Entfernen

Hinweis: Änderungen in einem Baum-Element bleiben erhalten, unabhängig davon, ob die Schaltfläche Abbrechen betätigt wird. Abbrechen bedeutet nur, dass kein Element ausgewählt wird.

Zur Runtime

Beim Ausführen der Funktion wird die im Dialog konfigurierte Einstellung als Request zum prozessführende Rechner geschickt. Dort wird sie dann ausgewertet.


Sende Nachricht

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion ermöglicht den Versand von Nachrichten zur Runtime. Dazu verknüpfen Sie die Funktion mit:

  • einem Alarm (Funktion für Gruppe Klasse oder Bereich)
  • einem Grenzwert (Eigenschaft Grenzwerte/Funktion),

    Interne ID: Sende Nachricht

    Funktion

    Funktion, die in der Runtime automatisch ausgeführt werden soll, wenn der Grenzwert verletzt wird.
    Ist der Zustand als Alarm definiert, kann die spontane Funktionsausführung unterbunden werden (Option "Aufruf über die Alarm-Verwaltung").
    Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Sende Nachricht

    Grenzwerte

    Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

    Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

    Interne ID: Sende Nachricht

    Reaktionsmatrix aktiv

    Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
    Inaktiv: Grenzwerte können für die Variable definiert werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • einer Reaktionsmatrix (Funktion)
  • der Zeitsteuerung (über Button oder PFS)

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie in der Gruppe Message Control die Funktion Sende Nachricht

    Interne ID: Sende Nachricht

    Sende Nachricht

    Diese Funktion sendet eine Nachricht des optionalen Moduls Message Control.

    Mehr im Online-Handbuch

    Interne ID: Sende Nachricht

    Message Control

    Diese Gruppe beinhaltet Funktionen für das optionale Modul Message Control.

    Mehr im Online-Handbuch

  3. der Dialog zur Konfiguration wird geöffnet

  4. konfigurieren Sie
    • Versandart
    • Nachricht
    • Empfangsbestätigung
  5. schließen Sie den Dialog mit Klick auf OK
  6. verknüpfen Sie die Funktion

info Info

Die Funktion Sende Nachricht wird zur Runtime immer am prozessführenden Rechner ausgeführt.

Noch in diesem Kapitel

Versandart

Nachricht

Empfangsbestätigung


Versandart

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht -> Versandart

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden Versandart, Empfänger und Methode konfiguriert.

Parameter

Beschreibung

Versandart

Auswahl der Versandart aus Dropdownliste. In der Liste werden nur Medien angezeigt, deren Eigenschaft Versandart aktiv in den Message Control Eigenschaften des Arbeitsbereichs aktiviert wurde.

Interne ID: Versandart

Versandart aktiv

Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Empfänger

Einstellungen zum Empfänger.

Typ

Auswahl des Empfängertyps aus Dropdownliste. Mögliche Auswahl:

  • Benutzergruppe: Versand an eine Gruppe.
    Auswahl einer Gruppe bei Umschaltung der Option oder über Option Empfängername.
    In der Option Methode erfolgt die Definition der Versandmethode an die Gruppe.
  • Benutzer: Versand an einen einzelnen Benutzer (und die in seinem Profil definierte Ersatzperson). Auswahl des Benutzers bei Umschaltung der Option oder über Eigenschaft Empfängername.

Methode

Nur verfügbar, wenn für die Option Typ Benutzergruppe gewählt wurde.

Auswahl der Versandmethode aus Dropdownliste. Mögliche Methoden:

  • Gruppenruf: Alle Benutzer der Gruppe erhalten die Nachricht parallel.
    (Hinweis: Diese Methode entspricht in Versionen vor zenon 7.00 dem Versandtyp Gruppe-Versand.)
  • Folgeruf: Die Nachricht wird den Benutzern entsprechend der in der Gruppe definierten Reihenfolge der Reihe nach zugestellt bis der erste positiv quittiert. Die Gruppe wird nur einmal durchlaufen. Erfolgt keine positive Quittierung, wird der Versand beendet.
  • Endlosfolgeruf: Entspricht prinzipiell dem Folgeruf, allerdings mit Wiederholung: Nach dem letzten Empfänger wird die Gruppe wieder von oben beginnend durchlaufen. Der Versand erfolgt bis zur ersten positiven Quittierung.

Empfängername

Nur verfügbar, wenn Option Name von Variable inaktiv ist.

Öffnet Dialog zur Auswahl eines Empfängers oder einer Empfängergruppe - abhängig von Auswahl in der Option Typ.

Name von Variable

Aktiv: Zur Runtime wird die Variable gelesen und über deren Wert ein Benutzer oder eine Benutzergruppe aus der Benutzerverwaltung ausgelesen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

OK

Übernimmt alle Änderungen und schließt Dialog.

Dialog kann nur geschlossen werden, wenn alle nötigen Optionen konfiguriert wurden.

Abbrechen

Verwirft alle Änderungen und schließt Dialog. Funktion wird ohne Ziel erstellt.

Hilfe

Öffnet Online-Hilfe.


Nachricht

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht -> Nachricht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte wird der Inhalt der Nachricht definiert. Angebotene Optionen und Konfiguration hängen von der Auswahl des Versandmediums in der Option Versandart auf der Registerkarte Versandart ab.

Die Konfiguration der Nachrichten erfolgt individuell für:

  • E-Mail über Outlook und SMS über GMS oder SMS-Gateway
  • E-Mail über SMTP
  • Sprachnachricht über Modem mit Audiodatei
  • Sprachnachricht über Modem mit Text-To-Speech

info Info

Werden Parameter oder Werte von zusätzlichen Variablen in die Nachricht inkludiert, dann sind diese Variablen nicht automatisch beim Treiber angemeldet. Ist eine Variable zu dem Zeitpunkt, an dem die Funktion ausgeführt wird, nicht angemeldet, muss die Anmeldung währen der Aktion erfolgen. Das kann unter bestimmten Umständen (z.B. bei langsamer serieller Kommunikation zur Hardware) zur Verzögerung führen, da gewartet werden muss bis der erste Wert vom Treiber kommt und von der Funktion ausgewertet werden kann.

Noch in diesem Kapitel

E-Mail über Outlook und SMS über GSM oder SMS-Gateway

E-Mail über SMTP

Sprachnachricht mit Audiodatei über Modem

Sprachnachricht Text-To-Speech über Modem

Grenzwerttext Parameter

Parameter für formatierten Text


E-Mail über Outlook und SMS über GSM oder SMS-Gateway

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht -> Nachricht -> E-Mail über Outlook und SMS über GSM oder SMS-Gateway

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
E-Mail über Outlook und SMS über GSM oder SMS-Gateway

Konfiguration des Nachrichtentexts für:

  • E-Mail über Outlook
  • SMS über GSM-Modem
  • SMS über SMS-Gateway

Parameter

Beschreibung

Freier Nachrichtentext

Fester Bestandteil der Nachricht.

Dieser Text wird auf Platzhalter durchsucht:

  • $: kennzeichnet "formatierten" Text. Der Text wird dann auf Parameter geparst.
  • Textteile werden als Parameter betrachtet, wenn sie mit einem Semikolon (;)vom restlichen Text getrennt sind und mit einem Semikolon (;)enden.
  • Ein Parameter kann sein:
    - Schlüssel aus der Sprachtabelle
    - Name einer Variablen
    - zusammengesetzter Eintrag in der Sprachtabelle

Parameter können aus der Liste der Grenzwerttext Parameter kopiert werden.

Text aus Grenzwert

Eigenschaften für zusätzliche Parameter aus Grenzwerten.

aktiv

Aktiv: Fügt zum konstanten Text zusätzliche Parameter aus dem Grenzwert hinzu. Konfiguration erfolgt über Optionen:

  • von Variable
  • von verletzter Variable
  • Liste Grenzwerttext Parameter

Achtung: Ist diese Option aktiv, können nur noch Grenzwertverletzungen die Funktion auslösen.

von Variable

Parameter werden von der definierten Variablen übernommen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

von verletzter Variable

Parameter werden von der Variablen, deren Grenzwert verletzt wurde, übernommen.

Liste Grenzwerttext Parameter

Auswahl der Parameter aus Liste durch Aktivierung der jeweiligen Checkbox. Reihenfolge wird durch Drag & Drop mit der Maus oder über die Schaltflächen Eintrag nach oben verschieben und Eintrag nach unten verschieben festgelegt.

Spalte Platzhalter:
Zeigt Platzhalter, die im freien Nachrichtenetxt verwendet werden können, an.
Wird die Option von Variable oder von verletzter Variable oder die Variablenauswahl geändert, wird der Beispielteintrag angepasst. Platzhalter können kopiert werden.

Aufbau: %Variable%Parameter; (Herkunft)

  • %: Prozentzeichen als Präfix für Variablen und Paramter
  • Variable: Variable. Wird keine Variable angegeben, bezieht sich der folgende Parameter auf die Hauptvariable.
  • Paramter: Parameter
  • ;: Semikolon beendet Zeichenfolge
  • Herkunft: Nur Information, wird nicht für freien Text verwendet. Zeigt an, mit welchen Variablen der Parameter verwendet werden kann :
    Hauptvariable über Grenzwert
    Hauptvariable über AML
    Zusatzvariable über Grenzwert oder AML

Details siehe Abschnitt Grenzwerttext Parameter.

Werden ungültige Parameter verwendet, dann wird in der Nachricht eine entsprechende Fehlermeldung mit ausgegeben:
<ungültiger Parameter: 'Parameter'>.

Eintrag nach oben verschieben

Reiht ausgewähltes Element um eine Stufe höher.

Eintrag nach unten verschieben

Reiht ausgewähltes Element um eine Stufe tiefer.

Diesen Dialog zur Runtime anbieten

Aktiv: Zur Runtime wird vor Ausführung der Funktion dieser Dialog geöffnet.

Achtung - Verhalten zur Runtime:

  • Die Funktion wird zur Runtime immer am prozessführenden Rechner ausgeführt. Wird die Funktion auf einem Client gestartet, dann wird der Dialog am prozessführenden Rechner angezeigt.
  • Erfolgt keine Eingabe, wird der Dialog nach 30 Sekunden automatisch geschlossen und die Funktion ausgeführt.
  • Wird der Dialog bearbeitet und mit OK geschlossen, werden Änderungen übernommen und die Funktion wird ausgeführt.
  • Wird der Dialog mit Abbrechen geschlossen, wird keine Nachricht verschickt. Dieser Vorgang wird in der CEL dokumentiert, sofern für die Eigenschaft In CEL protokollieren alle Bestätigungen oder nur negative Bestätigungen gewählt wurde.

    Interne ID: E-Mail über Outlook und SMS über GSM oder SMS-Gateway

    In CEL protokollieren

    Legt fest, welche Ereignisse in der CEL protokolliert werden. Auswahl aus Dropdownliste:

    - alle Bestätigungen

    - keine Bestätigungen

    - nur negative Bestätigungen

    - nur positive Bestätigungen

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

OK

Übernimmt alle Änderungen und schließt Dialog.

Dialog kann nur geschlossen werden, wenn alle nötigen Optionen konfiguriert wurden.

Abbrechen

Verwirft alle Änderungen und schließt Dialog. Funktion wird ohne Ziel erstellt.

Hilfe

Öffnet Online-Hilfe.


E-Mail über SMTP

E-Mail über SMTP

E-Mail über SMTP

Konfiguration des Nachrichtentexts für:

  • E-Mail über SMTP

Parameter

Beschreibung

Freier Nachrichtentext

Fester Bestandteil der Nachricht.

Dieser Text wird auf Platzhalter durchsucht:

  • $: kennzeichnet "formatierten" Text. Der Text wird dann auf Parameter geparst.
  • Textteile werden als Parameter betrachtet, wenn sie mit einem Semikolon (;)vom restlichen Text getrennt sind und mit einem Semikolon (;)enden.
  • Ein Parameter kann sein:
    - Schlüssel aus der Sprachtabelle
    - Name einer Variablen
    - zusammengesetzter Eintrag in der Sprachtabelle

Parameter können aus der Liste der Grenzwerttext Parameter kopiert werden.

Anhang

Konfiguration eines Anhangs an die E-Mail. Als Anhang verschickt werden können Bilddateien (Screenshots). Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Datei. Diese muss im Knoten Dateien/Grafiken hinterlegt sein.

Beim Versand der Nachricht wird die ausgewählte Datei als Attachement an die E-Mail angefügt.

von Variable

Aktiv: Auswahl einer String-Variablen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Zur Runtime wird der Wert der Stringvariablen übernommen und geprüft, ob der Ordner Grafiken eine Datei enthält, deren Name dem Stringwert entspricht.

Text aus Grenzwert

Eigenschaften für zusätzliche Parameter aus Grenzwerten.

aktiv

Aktiv: Fügt zum konstanten Text zusätzliche Parameter aus dem Grenzwert hinzu. Konfiguration erfolgt über Optionen:

  • von Variable
  • von verletzter Variable
  • Liste Grenzwerttext Parameter

Achtung: Ist diese Option aktiv, können nur noch Grenzwertverletzungen die Funktion auslösen.

von Variable

Parameter werden von der definierten Variablen übernommen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

von verletzter Variable

Parameter werden von der Variablen, deren Grenzwert verletzt wurde, übernommen.

Liste Grenzwerttext Parameter

Auswahl der Parameter aus Liste durch Aktivierung der jeweiligen Checkbox. Reihenfolge wird durch Drag & Drop mit der Maus oder über die Schaltflächen Eintrag nach oben verschieben und Eintrag nach unten verschieben festgelegt.

Spalte Platzhalter:
Zeigt Platzhalter, die im freien Nachrichtenetxt verwendet werden können, an.
Wird die Option von Variable oder von verletzter Variable oder die Variablenauswahl geändert, wird der Beispielteintrag angepasst. Platzhalter können kopiert werden.

Aufbau: %Variable%Parameter; (Herkunft)

  • %: Prozentzeichen als Präfix für Variablen und Paramter
  • Variable: Variable. Wird keine Variable angegeben, bezieht sich der folgende Parameter auf die Hauptvariable.
  • Paramter: Parameter
  • ;: Semikolon beendet Zeichenfolge
  • Herkunft: Nur Information, wird nicht für freien Text verwendet. Zeigt an, mit welchen Variablen der Parameter verwendet werden kann :
    Hauptvariable über Grenzwert
    Hauptvariable über AML
    Zusatzvariable über Grenzwert oder AML

Details siehe Abschnitt Grenzwerttext Parameter.

Werden ungültige Parameter verwendet, dann wird in der Nachricht eine entsprechende Fehlermeldung mit ausgegeben:
<ungültiger Parameter: 'Parameter'>.

Eintrag nach oben verschieben

Reiht ausgewähltes Element um eine Stufe höher.

Eintrag nach unten verschieben

Reiht ausgewähltes Element um eine Stufe tiefer.

Diesen Dialog zur Runtime anbieten

Aktiv: Zur Runtime wird vor Ausführung der Funktion dieser Dialog geöffnet.

Achtung - Verhalten zur Runtime:

  • Die Funktion wird zur Runtime immer am prozessführenden Rechner ausgeführt. Wird die Funktion auf einem Client gestartet, dann wird der Dialog am prozessführenden Rechner angezeigt.
  • Erfolgt keine Eingabe, wird der Dialog nach 30 Sekunden automatisch geschlossen und die Funktion ausgeführt.
  • Wird der Dialog bearbeitet und mit OK geschlossen, werden Änderungen übernommen und die Funktion wird ausgeführt.
  • Wird der Dialog mit Abbrechen geschlossen, wird keine Nachricht verschickt. Dieser Vorgang wird in der CEL dokumentiert, sofern für die Eigenschaft Einträge in die CEL alle Bestätigungen oder nur negative Bestätigungen gewählt wurde.

OK

Übernimmt alle Änderungen und schließt Dialog.

Dialog kann nur geschlossen werden, wenn alle nötigen Optionen konfiguriert wurden.

Abbrechen

Verwirft alle Änderungen und schließt Dialog. Funktion wird ohne Ziel erstellt.

Hilfe

Öffnet Online-Hilfe.


Sprachnachricht mit Audiodatei über Modem

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht -> Nachricht -> Sprachnachricht mit Audiodatei über Modem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Sprachnachricht mit Audiodatei über Modem

Konfiguration des Nachrichtentexts für:

  • Sprachnachrichten über Modem mit einer Audiodatei.

Parameter

Beschreibung

Begrüßung

Auswahl der Datei, die den Text für die Begrüßung enthält.

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Datei. Diese muss im Knoten Datei/Multimedia hinterlegt sein.

Die Datei kann zum Testen über die Schaltfläche Abspielen abgehört werden.

Nachricht

Auswahl der Datei, die den Text für die Nachricht enthält.

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Datei. Diese muss im Knoten Datei/Multimedia hinterlegt sein.

Die Datei kann zum Testen über die Schaltfläche Abspielen abgehört werden.

Fehleingabe

Auswahl der Datei, die den Text bei Fehleingaben durch den Empfänger enthält.

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Datei. Diese muss im Knoten Datei/Multimedia hinterlegt sein.

Die Datei kann zum Testen über die Schaltfläche Abspielen abgehört werden.

Diesen Dialog zur Runtime anbieten

Aktiv: Zur Runtime wird vor Ausführung der Funktion dieser Dialog geöffnet.

Achtung - Verhalten zur Runtime:

  • Die Funktion wird zur Runtime immer am prozessführenden Rechner ausgeführt. Wird die Funktion auf einem Client gestartet, dann wird der Dialog am prozessführenden Rechner angezeigt.
  • Erfolgt keine Eingabe, wird der Dialog nach 30 Sekunden automatisch geschlossen und die Funktion ausgeführt.
  • Wird der Dialog bearbeitet und mit OK geschlossen, werden Änderungen übernommen und die Funktion wird ausgeführt.
  • Wird der Dialog mit Abbrechen geschlossen, wird keine Nachricht verschickt. Dieser Vorgang wird in der CEL dokumentiert, sofern für die Eigenschaft Einträge in die CEL alle Bestätigungen oder nur negative Bestätigungen gewählt wurde.

OK

Übernimmt alle Änderungen und schließt Dialog.

Dialog kann nur geschlossen werden, wenn alle nötigen Optionen konfiguriert wurden.

Abbrechen

Verwirft alle Änderungen und schließt Dialog. Funktion wird ohne Ziel erstellt.

Hilfe

Öffnet Online-Hilfe.


Sprachnachricht Text-To-Speech über Modem

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht -> Nachricht -> Sprachnachricht Text-To-Speech über Modem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Sprachnachricht Text-To-Speech über Modem

Konfiguration des Nachrichtentexts für:

  • Sprachnachrichten über Modem mit Text-to-Speech.

Parameter

Beschreibung

Begrüßung

Eingabe des Textes, der zur Begrüßung über die Text-to-Speech Engine abgespielt werden soll. .

Der Text kann zum Testen über die Schaltfläche Abspielen abgehört werden.

Nachricht

Eingabe des Textes, der als Nachricht über die Text-to-Speech Engine abgespielt werden soll.

Der Text kann zum Testen über die Schaltfläche Abspielen abgehört werden.

Fehleingabe

Eingabe des Textes, der bei Fehleingaben durch den Empfänger über die Text-to-Speech Engine abgespielt werden soll.

Der Text kann zum Testen über die Schaltfläche Abspielen abgehört werden.

Diesen Dialog zur Runtime anbieten

Aktiv: Zur Runtime wird vor Ausführung der Funktion dieser Dialog geöffnet.

Achtung - Verhalten zur Runtime:

  • Die Funktion wird zur Runtime immer am prozessführenden Rechner ausgeführt. Wird die Funktion auf einem Client gestartet, dann wird der Dialog am prozessführenden Rechner angezeigt.
  • Erfolgt keine Eingabe, wird der Dialog nach 30 Sekunden automatisch geschlossen und die Funktion ausgeführt.
  • Wird der Dialog bearbeitet und mit OK geschlossen, werden Änderungen übernommen und die Funktion wird ausgeführt.
  • Wird der Dialog mit Abbrechen geschlossen, wird keine Nachricht verschickt. Dieser Vorgang wird in der CEL dokumentiert, sofern für die Eigenschaft Einträge in die CEL alle Bestätigungen oder nur negative Bestätigungen gewählt wurde.

OK

Übernimmt alle Änderungen und schließt Dialog.

Dialog kann nur geschlossen werden, wenn alle nötigen Optionen konfiguriert wurden.

Abbrechen

Verwirft alle Änderungen und schließt Dialog. Funktion wird ohne Ziel erstellt.

Hilfe

Öffnet Online-Hilfe.


Grenzwerttext Parameter

Grenzwerttext Parameter

Parameter, die bei den Versandarten E-Mail über Outlook und SMS über GSM oder SMS-Gateway und E-Mail über SMTP sowie für die Eigenschaft Dynamischer Teil des Betreffs verwendet werden können.

Interne ID: Grenzwerttext Parameter

Dynamischer Teil des Betreffs

Definiert den projektspezifischen Teil des Betreffs ausgehender und eingehender Nachrichten. Wird zusammen mit der Eigenschaft E-Mail Nachricht (Outlook)/Betreff (Id) bzw.E-Mail Nachricht (SMTP) /E-Mail Betreff in den globalen Message Control Versandeinstellungen verwendet. Eingehende Nachrichten werden auf diesen Inhalt zur Weiterleitung an Message Control gefiltert.

Interne ID: Grenzwerttext Parameter

Message Control

Gruppe für projektübergreifende Einstellungen im Message Control.

Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

Interne ID: Grenzwerttext Parameter

Projektspezifische Einstellungen

Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grenzwerttext Parameter

E-Mail Betreff

Eingabe des Betreffs für ausgehende E-Mails.

Eingehenden E-Mails müssen diesen Text ebenfalls im Betreff stehen haben, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Text nicht enthalten, werden weder an Message Control weitergeleitet noch vom Server gelöscht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grenzwerttext Parameter

E-Mail Nachricht (SMTP)

Einstellungen zum E-Mail-Versand per SMTP.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grenzwerttext Parameter

Betreff (Id)

Eindeutiger Betreff der ausgehenden Nachricht. Dieser dient bei eingehenden Nachrichten als Kriterium, ob die Nachricht für Message Control bestimmt ist und verarbeitet werden soll.

Eingehenden E-Mails müssen diesen Text im Betreff enthalten, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Betreff nicht enthalten, werden nicht an Message Control weitergeleitet.

Mindestlänge: 4 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grenzwerttext Parameter

E-Mail Nachricht (Outlook)

Gruppe für Einstellungen der Versandart Outlook.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Text kann Platzhalter beinhalten für:

  • Schlüssel aus der Sprachtabelle
  • Name einer Variablen
  • zusammengesetzter Eintrag in der Sprachtabelle

Syntax: $ kennzeichnet Text; Textteile werden durch Semikolon (;)getrennt, der Text muss mit einem Semikolon (;)enden.
Beispiel: $@Achtung;%Var1;

Eine Liste der Parameter finden Sie im Kapitel Grenzwerttext Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter können verwendet werden mit:

  • Variablen:
    • Hauptvariablen
    • Zusatzvariablen
  • bei Ausführung der Funktion über:
    • AML
    • Grenzwertverletzung

Es stehen für Hauptvariablen, Zusatzvariablen und je nach Funktionsaufruf teilweise unterschiedliche Parameter zur Verfügung.

Achtung: Werden zusätzliche Variablen mit Hilfe einen Platzhalter eingefügt, so müssen diese Variablen wenn sie zum Zeitpunkt der Funktionsausführungnicht angemeldet sind, zuerst angemeldet und gelesen werden. Damit wird der Versand verzögert. Zusätzliche Variablen sollten daher nur mit Vorsicht verwendet werden.

Aufbau und Bedeutung der Parameter

Aufbau

%Variable%Parameter; (Herkunft)

  • %: Prozentzeichen als Präfix für Variablen
  • Variable: Variable (optional)
    Wird keine Variable angegeben, bezieht sich der folgende Parameter auf die Hauptvariable
  • %: Prozentzeichen als Präfix für Paramter
  • Paramter: Parameter
  • ;: Semikolon beendet Zeichenfolge

Z. B. : %S7TCP-IP_LineStateBusy%UserId;

Paramter

Parameter

Hauptvariable - Aufruf über Grenzwert

Hauptvariable - Aufruf über AML

Zusatzvariable AML/Grenzwert

%Name

(Variablenname:)

Name der Variablen, entspricht Eigenschaft Name.

Interne ID: Grenzwerttext Parameter

Name

Eindeutiger Name der Variable. Das Zeichen # ist nicht erlaubt.
Hinweis: Für Treiber, die auf einer zenon Logic Verbindung beruhen, ist ein Präfix zu beachten. Details siehe Abschnitt Anlegen von B und B Variablen in zenon Logic im Handbuch.
Änderungen des Variablennamens müssen in den Programmierumgebungen (VBA, VSTA, PCE) nachgezogen werden.

Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Name der Variablen, entspricht Eigenschaft Name.

Name der Variablen, entspricht Eigenschaft Name.

%Identification

(Kennung)

Beschreibung der Variablen, entspricht Eigenschaft Kennung.

Interne ID: Grenzwerttext Parameter

Kennung

Frei definierbarer String für die Identifikation der Variable oder des Datentyps.

Beispiel: Kann bei der Online-Sprachumschaltung anstatt des Variablennamens verwendet werden, da dieser nicht sprachumschaltbar ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beschreibung der Variablen, entspricht Eigenschaft Kennung.

Beschreibung der Variablen, entspricht Eigenschaft Kennung.

%LimitText

(Grenzwerttext)

Grenzwerttext des Alarmobjekts mit Auswertung des Dynamischen Grenzwerttexts.

Grenzwerttext des Alarmobjekts mit Auswertung des Dynamischen Grenzwerttexts.

Text des Zuzustands wie in Eigenschaft Grenzwerttext definiert.

Grenzwerttext

Dieser Text wird zur Runtime bei Grenzwertverletzungen, je nach Einstellung, in der Alarmmeldeliste, der Chronologischen Ereignisliste und/oder der Alarmstatuszeile ausgegeben.

Dynamischer Grenzwerttext: erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen und der Reaktionsmatrizen einzufügen. Dabei lässt sich auch ein fixer Text über einen Index mit Schlüsselwörter aus einer Sprachtabelle verknüpfen. Das führt zu einigen Begrenzungen:
Statischer Text wird im Speicherbereich für den Grenzwert abgelegt, wofür maximal 128 Zeichen zur Verfügung stehen. Die Werte der veknüpften Variablen werden im Speicherbereich für den Kommentartext abgelegt, begrenzt auf maximal 80 Zeichen.

Die Begrenzungen kann umgangen werden durch die Erweiterung für lange dynamische Grenzwerttexte. Aktivieren Sie dazu Lange dynamische Grenzwerttexte CEL bzw. Lange dynamische Grenzwerttexte AML. Variablenwerte für dynamische Grenzwerttexte werden dann in eine eigene Datei ausgelagert. Achtung: Bei der Verwendung von dynamischen Grenzwerten kann kein Kommentar eingegeben werden.

Interne ID: Grenzwerttext Parameter

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grenzwerttext Parameter

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

%MessageCreateTimeStamp

(Zeitstempel der Nachricht)

Zeitpunkt, zu dem die Nachricht erstellt wird. (Funktionsaufruf, nicht Verletzung oder Versand.)

Zeitpunkt, zu dem die Nachricht erstellt wird. (Funktionsaufruf, nicht Verletzung oder Versand.)

Zeitpunkt, zu dem die Nachricht erstellt wird. (Funktionsaufruf, nicht Verletzung oder Versand.)

%ResourceLabel

(Betriebsmittelkennung)

Text für Betriebsmittelkennung der Variablen, entspricht Eigenschaft Betriebsmittelkennung.

Interne ID: Grenzwerttext Parameter

Betriebsmittelkennung

Beliebiger String.
Wird im Leitsystem intern nicht verwendet, steht aber beim Export von Werten zur Verfügung um eine Zuordnung der exportierten Werte für Management-Systeme (z.B. ERP) zu ermöglichen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Text für Betriebsmittelkennung der Variablen, entspricht Eigenschaft Betriebsmittelkennung

Text für Betriebsmittelkennung der Variablen, entspricht Eigenschaft Betriebsmittelkennung

%LimitTimeReceived

(Zeit Alarm kommt)

Zeitstempel des Alarmobjekts.

Zeitstempel des Alarmobjekts.

-

%%

(Aktueller Wert)

Kein Parameter. Wert der Variablen beim Funktionsaufruf (ohne Einheit).

Kein Parameter. Wert der Variablen beim Funktionsaufruf (ohne Einheit)

Kein Parameter. Wert der Variablen beim Funktionsaufruf (ohne Einheit)

%VariableStatus

(Status)

Status der Variablen als String (beim Funktionsaufruf).

Status der Variablen als String (beim Funktionsaufruf).

Status der Variablen als String (beim Funktionsaufruf).

%VariableTimeStamp

(Zeitstempel der Variable)

Zeitstempel der Variablen (beim Funktionsaufruf).

Zeitstempel der Variablen (beim Funktionsaufruf).

Zeitstempel der Variablen (beim Funktionsaufruf).

%MessageTimeAcknowledge

(Restzeit zum Bestätigen)

Verfügbare Zeit für Quittierung in MInuten. Nur vorhanden, wenn Empfangsbestätigung erforderlich aktiviert wurde.

Verfügbare Zeit für Quittierung in MInuten. Nur vorhanden, wenn Empfangsbestätigung erforderlich aktiviert wurde.

Verfügbare Zeit für Quittierung in MInuten. Nur vorhanden, wenn Empfangsbestätigung erforderlich aktiviert wurde.

%Address

(Adresse)

Adresse.

Adresse.

Adresse.

%Unit

(Einheit)

Technische Einheit entsprechend der Eigenschaft Maßeinheit.

Interne ID: Grenzwerttext Parameter

Maßeinheit

Technische Einheit der Variablen für die Darstellung zur Runtime. Wurden im Modul Einheiten bereits Basiseinheiten erstellt, stehen diese in einer Dropdownliste zur Auswahl zur Verfügung.
Maximum: 50 Zeichen.
Default: leer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Technische Einheit entsprechend der Eigenschaft Maßeinheit.

Technische Einheit entsprechend der Eigenschaft Maßeinheit.

%AlarmArea

(Alarmbereich)

Alarmbereich der Hauptvariable.

Alarmbereich der Hauptvariable.

Alarmbereich der Zusatzvariable.

%LimitTimeAcknowledged

(Zeit Alarm quittiert)

-

Zeitstempel des Alarmobjekts.

-

%UserId

(Benutzerkennung)

-

Benutzerkennung des Benutzers, der die Aktion angestoßen hat. Entspricht Eigenschaft Benutzername .

Interne ID: Grenzwerttext Parameter

Benutzername

Eindeutige Kennung, mit der sich der Benutzer einloggen muss.
Bei diversen Benutzeraktionen kann diese Zeichenfolge in der Chronologischen Ereignisliste (CEL) angezeigt werden. In der CEL gibt es eine eigene Spalte für die Anzeige dieser Information. Zusätzlich kann diese Information auch mit Hilfe einer Systemtreiber-Variablen angezeigt werden.
Maximum: 20 Zeichen.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

-

%UserName

(Benutzername)

-

Vollständiger Name des Benutzers, der die Aktion angestoßen hat. Entspricht Eigenschaft Vollständiger Name.

Interne ID: Grenzwerttext Parameter

Vollständiger Name

Name des Benutzers.
Beim diversen Benutzeraktionen kann diese Zeichenfolge in der Chronologischen Ereignisliste (CEL) angezeigt werden. Das sollte der volle Name der Benutzers sein. In der CEL gibt es eine eigene Spalte für die Anzeige dieser Information. Zusätzlich kann diese Information auch mit Hilfe einer Systemtreiber-Variable angezeigt werden.

ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

-

%ComputerName

(Computername)

-

Name des Rechners, an dem die Aktion angestoßen wurde.

-

%Comment

(Kommentar)

-

Kommentar des Alarmobjekts.

-

%AlarmGroup

(Alarmgruppe)

Alarmgruppe des Alarmobjekts (als Text).

Alarmgruppe des Alarmobjekts (als Text).

Alarmgruppe des Alarmobjekts (als Text).

%AlarmClass

(Alarmklasse)

Alarmklasse des Alarmobjekts (als Text).

Alarmklasse des Alarmobjekts (als Text).

Alarmklasse des Alarmobjekts (als Text).

%AlarmTimeActive

(Zeit Alarm anstehend)

-

Zeit, die der Alarm ansteht.

-

Fehlerbehandlung

Werden ungültige Parameter verwendet, dann wird in der Nachricht eine entsprechende Fehlermeldung mit ausgegeben:
<ungültiger Parameter: 'Parameter'>.

Dieser Text kann mit Hilfe der Sprachumschaltung geändert und übersetzt werden. Dafür müssen zwei Schlüsselwörter angelegt werden:

  • <ungültiger Parameter:
  • >

Werden Parameter im falschen Kontext verwendet oder kann ein Parameter nicht gelesen werden (z. B.weil eine Variable nicht vorhanden ist) wird statt des Werts die Zeichenfolge IDS_STRING2501 (---) in die Nachricht eingefügt. Dieser Text kann auch mit Hilfe der Sprachumschaltung geändert werden.


Parameter für formatierten Text

Parameter für formatierten Text

Text in einer Nachricht wird auf Platzhalter und Parameter geparst.

  • $: kennzeichnet "formatierten" Text.
  • Textteile werden als Parameter betrachtet, wenn sie
    • mit einem Semikolon (;)vom restlichen Text getrennt sind und
    • mit einem Semikolon (;)enden.
  • Ein Parameter kann sein:
    - Schlüssel aus der Sprachtabelle
    - Name einer Variablen
    - zusammengesetzter Eintrag in der Sprachtabelle

Paramter

Zur Runtime

Aktion

Schlüssel:

@MyText

Es wird überprüft, ob für die aktuelle Sprache in der Sprachtabelle einen Eintrag für @MyText vorhanden ist.
  • Vorhanden: Eintrag wird in die Nachricht eingefügt.
  • Nicht vorhanden: Je nach Einstellung der Projekteigenschaft Nicht übersetzte Schlüsselwörter anzeigen wird entweder @MyText oder MyText in die Nachricht eingefügt.

    Interne ID: Parameter für formatierten Text

    Nicht übersetzte Schlüsselwörter anzeigen

    Einstellung für die Darstellung von Schlüsselwörter, die in keiner der Sprachdateien existieren:

    Aktiv: Darstellung zur Runtime als Schlüsselwort, zum Beispiel: @Text.
    Inaktiv: Darstellung zur Runtime ohne vorangestelltes @, zum Beispiel: Text

    Hinweis: Existiert das Schlüsselwort in einer der Sprachdateien, verfügt jedoch über keine Übersetzung, wird zur Runtime kein Text angezeigt (leerer String).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Variable:

%Var1

Es wird überprüft, ob die Variable vorhanden ist und der Wert gelesen werden kann.

  • Vorhanden: Wert der Variablen wird genommen und als String in der Text eingefügt.
  • Nicht vorhanden/nicht lesebar: Der Text xxx wird in die Nachricht eingefügt.

Zusammengesetzter Eintrag:

@StringTabelle+%var1Text

Es wird überprüft, ob:

  • 1. die Variable vorhanden ist und der Wert gelesen werden kann. Wert wird als String an den Präfix-Text („MultipleText") angehängt.
  • 2. für den Text in der Sprachtabelle ein Eintrag vorhanden ist
  • Variable und Text vorhanden:
    Text wird in die Nachricht eingefügt.
    Beispiel: Wert der Variable ist 33. Dann wird in der der Sprachtabelle nach @StringTabelle33 gesucht und der dazu gehörende Text eingefügt.
  • Nicht vorhanden: Je nach Einstellung der Projekteigenschaft Nicht übersetzte Schlüsselwörter anzeigen wird entweder @MyText oder MyText in die Nachricht eingefügt.

Beispiel: $@Achtung;%Var1;


Empfangsbestätigung

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht -> Empfangsbestätigung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden die nötigen Bestätigungen und die Reaktion darauf definiert.

Parameter

Beschreibung

Empfangsbestätigung

Einstellungen für Quittierung.

Empfangsbestätigung erfoderlich

Aktiv: Die Nachricht wird erst aus der Message-Queue entfernt, wenn innerhalb der Wartezeit eine Empfangsbestätigung eingetroffen ist oder die Wartezeit abgelaufen ist.

Für Sprachnachrichten ist diese Option immer aktiv und kann nicht deaktiviert werden.

Wartezeit

Zeit in Minuten, die auf eine Empfangsbestätigung gewartet wird, bevor die Nachricht an eine Ersatzperson weitergeleitet wird.

Bestätigungscodes

Einstellungen für Quittierungscodes.

Nachrichtspezifische Codes verwenden

Inaktiv: Die in den Eigenschaften der Benutzerverwaltung festgelegten Codes für Message Control Benutzer/PIN-Code und Message Control Benutzer/NA-Code werden verwendet.

Interne ID: Empfangsbestätigung

NA-Code

Not-Available-Code, mit dem der Benutzer die Annahme der Nachricht verweigern kann.

Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft PIN-Code unterscheiden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Empfangsbestätigung

PIN-Code

PIN Code, mit dem der Benutzer den Empfang der Nachricht bestätigt.

Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft NA-Code unterscheiden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Empfangsbestätigung

Message Control Benutzer

Aktiv: Benutzer wird von Message Control verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Die in den folgenden Optionen PIN-Code und NA-Code definierten Codes werden zur Bestätigung verwendet.

PIN-Code

Individueller Code zum Bestätigen der Nachricht.

NA-Code

Individueller Code zum Ablehnen der Nachricht.

Funktionsausführung

Auswahl der Funktionen, die ausgeführt werden sollen, nachdem eine Nachricht bestätigt, abgelehnt oder gar nicht quittiert wurde.

bei Bestätigung

Funktionen, die ausgeführt werden, wenn die Nachricht bestätigt wird.

Klick auf Schaltfläche Auswählen öffnet Dialog zur Auswahl der Funktionen.

bei fehlender Bestätigung

Funktionen, die ausgeführt werden, wenn keine Reaktion auf die die Nachricht erfolgt.

Klick auf Schaltfläche Auswählen öffnet Dialog zur Auswahl der Funktionen.

bei negativer Bestätigung

Funktionen, die ausgeführt werden, wenn der Empfang der Nachricht abgelehnt wird.

Klick auf Schaltfläche Auswählen öffnet Dialog zur Auswahl der Funktionen.

OK

Übernimmt alle Änderungen und schließt Dialog.

Dialog kann nur geschlossen werden, wenn alle nötigen Optionen konfiguriert wurden.

Abbrechen

Verwirft alle Änderungen und schließt Dialog. Funktion wird ohne Ziel erstellt.

Hilfe

Öffnet Online-Hilfe.


Sende Nachricht aktivieren

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht aktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion schaltet Message Control für das Projekt, in dem sich die Funktion befindet, ein. Beim Aufruf der Funktion wird das Projekt bei Message Control angemeldet. Ab diesen Zeitpunkt werden Nachrichten erstellt und übertragen.

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie in der Gruppe Message Control die Funktion Sende Nachricht aktivieren

    Interne ID: Sende Nachricht aktivieren

    Sende Nachricht aktivieren

    Diese Funktion schaltet das Senden von Nachrichten des optionalen Moduls Message Control ein.

    Mehr in der Online-Hilfe.

  3. die Funktion wird erstellt

Hinweis: Um ein Projekt sicher bei Runtimestart anzumelden, aktivieren Sie die Eigenschaft Aktiv bei Runtimestart in der Eigenschaftengruppe Projektspezifische Einstellungen für Message Control.

Interne ID: Sende Nachricht aktivieren

Projektspezifische Einstellungen

Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

Interne ID: Sende Nachricht aktivieren

Message Control

Gruppe für projektübergreifende Einstellungen im Message Control.

Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Sende Nachricht aktivieren

Aktiv bei Runtimestart

Aktiv: Message Control wird mit der Runtime gestartet.

Default: aktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Sende Nachricht deaktivieren

Handbuch -> Message Control -> Message Control konfigurieren -> Funktionen -> Sende Nachricht deaktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion schaltet Message Control für das Projekt, in dem sich die Funktion befindet, ab. Beim Aufruf der Funktion werden alle Nachrichten des Projektes aus der Message-Queue entfernt und das Projekt wird von Message Control abgemeldet. Danach wird die Nachrichten-Queue des Projekts geleert. So lange Message Control für ein Projekt deaktiviert ist, können keine neuen Nachrichten erstellt oder übertragen werden.

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie in der Gruppe Message Control die Funktion Sende Nachricht deaktivieren

    Interne ID: Sende Nachricht deaktivieren

    Sende Nachricht deaktivieren

    Diese Funktion schaltet das Senden von Nachrichten des optionalen Moduls Message Control aus.

    Mehr im Online-Handbuch

  3. die Funktion wird erstellt


Message Control zur Runtime

Handbuch -> Message Control -> Message Control zur Runtime

Zur Runtime wird Message Control entweder automatisch gestartet (Eigenschaft Aktiv bei Runtimestart aktiv) oder über die Funktion Sende Nachricht aktivieren.

Interne ID: Message Control zur Runtime

Aktiv bei Runtimestart

Aktiv: Message Control wird mit der Runtime gestartet.

Default: aktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wenn Message Control aktiv ist und ein für den Nachrichtenversand definiertes Ereignis eintritt, wird:

  • eine dafür konfigurierte Nachricht verschickt
  • deren Quittierung ausgewertet
  • die für die Quittierung verwendeten Funktionen ausgeführt

attention Achtung

Beim Auswerten der Nachrichten im E-Mail-Ordner werden alle Nachrichten mit passender Betreff-Zeile ausgewertet und auf den Status "gelesen" gesetzt. Werden im Postfach für Message Control auch andere Nachrichten empfangen, können diese eventuell auf "gelesen" gesetzt werden.

Verwaltung zur Runtime

Die Message Queue kann über ein Bild vom Typ Message Control gemanagt werden.

Beendet wird Message Control über das Beenden der Runtime oder die Funktion Sende Nachricht deaktivieren.

Zeitstempel in Alarmverwaltung und Message Control

Beim Aufruf der Funktion Sende Nachricht wird eine Kopie des Alarmobjekts an die Funktion übertragen. Der Text der Nachricht wird beim Aufruf der Funktion erstellt und übersetzt. Wird die Funktion über die AML aufgerufen, so verwendet sie eine Kopie des Alarmobjektes aus der AML. Der Inhalt entspricht so immer einer aktuellen Kombination aus Prozess und Alarm-Status.

Message Queue Remanenz

Wird die Runtime normal beendet, dann wird ein Image der aktuellen Nachrichten-Queue erstellt und gespeichert. Dieses Image wird beim Starten der Runtime wieder geladen und von Message Control abgearbeitet. Die Daten werden in einer Datei mit den Namen MessageRT_Image.bin gespeichert. Folgende Daten werden gespeichert:

  • Aktuellen Nachrichten in der Queue
  • Unterdrückte Alarm-Gruppen
  • Unterdrückte Alarm-Klasse
  • Unterdrückte Bereiche
  • Unterdrückte Anlagen

Netzwerk

Informationen zum Verhalten im Netzwerk finden Sie im Kapitel Netzwerk.

Quittierung

Jeder Nachricht ist über eine GUID eindeutig identifizierbar. Je nach konfigurierten Medien und Versandart, können Nachrichten auch über andere Medien quittiert werden. Details zur Quittierung von Nachrichten lesen Sie im Kapitel Nachrichten quittieren.

Sprachumschaltung

Texte innerhalb der Nachrichten sind komplett sprachumschaltbar. Ausgewertet werden dafür:

  • der Bereich Konstanter Text
  • der Parameter Dynamischer Grenzwert Text
  • Grenzwerttext eines Grenzwert in der AML/CEL

Die im Bild vom Typ Messag Control auswählbare Spalten sind sprachumschaltbar, wenn dementsprechend konfiguriert.

Noch in diesem Kapitel

Bild vom Typ Message Control aufschalten

Nachrichten quittieren

Netzwerk


Bild vom Typ Message Control aufschalten

Handbuch -> Message Control -> Message Control zur Runtime -> Bild vom Typ Message Control aufschalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ Message Control stellt zur Runtime eine Kopie der aktuellen Message Queue und Kontrollelemente zur Auswertung und Filterung zur Verfügung. Der Inhalt der im Listenfeld Nachrichtenliste dargestellten Elemente entspricht dem Zeitpunkt der AUfschaltung des Bildes und wird nicht automatisch aktualisiert. Die Darstellung kann mit einem Klick auf den Button Aktualisieren jederzeit aktualisiert werden. Der Button Stopp/Weiter ermöglicht eine zyklische Aktualisierung. Ein Textfeld zeigt den Zeitpunkt der letzten Aktualisierung an.

Die Nachrichtenliste enthält Nachrichten, die

  • auf den Versand warten
  • gerade versendet werden
  • bereits versendet wurden
  • bestätigt wurden
  • gelöscht wurden

Unterdrückte Gruppen, Klassen, Bereiche und Anlagen, deren Alarme nicht in der Liste angezeigt werden, werden in eigenen Listenfeldern angezeigt.

Die Spalten der Nachrichtenliste können individuell konfiguriert werden (siehe Filter) und mit eigenen Spaltenüberschriften versehen werden. Diese Beschriftungen sind sprachumschaltbar.

Kontrollelemente | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Buttons | Buttons für Aktionen zur Runtime.
Aktualisieren | Aktualisiert Ansicht. Die aktuellen Daten werden aus der Message Queue in das Bild geladen. Der Zeitpunkt der letzten Aktualisierung kann über das Feld Letzte Aktualisierung angezeigt werden.
Löschen | Löscht ausgewählten Eintrag aus der Liste. Es können nur Nachrichten gelöscht werden, die noch nicht verschickt wurden.
Filter | Öffnet Dialog zur Konfiguration der Filter für die Ansicht.
Stopp/Weiter | Startet und stoppt zyklische Aktualisierung der Liste.
Fenster | Listen und Felder, die zur Runtime angezeigt werden können.
Anzahl der Nachrichten | Zahl der aktuell vorhandenen Nachrichten.
Letzte Aktualisierung | Zeitpunkt der letzten Aktualisierung.
unterdrückte Alarm/Ereignis-Gruppen | Alarm/Ereignis-Gruppen, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
unterdrückte Alarm/Ereignis-Klassen | Alarm/Ereignis-Klassen, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
unterdrückte Alarm/Ereignis-Bereiche | Alarm/Ereignis-Bereiche, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
unterdrückte Anlagen | Anlagen, für die Meldungen unterdrückt wurden und deren Alarme daher nicht in der Message Queue angezeigt werden.
Nachrichten-Warteliste | Liste der Nachrichten. Enthält Nachrichten, die verschickt, bestätigt oder gelöscht wurden oder noch zu verschicken sind. Die Nachrichten werden nur angezeigt und können nicht mehr bearbeitet werden. Spaltenüberschriften können individuell benannt werden und sind durch Voranstellung des Zeichens @ sprachumschaltbar.
Filterprofile | Profilverwaltung
Profilauswahl | Öffnet Dialog zur Auswahl eines Profils.
Speichern | Speichert aktuelle Einstellungen als Profil.
Löschen | Löscht Profil.
Import | Öffnet Dialog zum Import von Profilen aus Datei.
Export | Öffnet Dialog zum Export von Profilen in Datei.


Nachrichten quittieren

Handbuch -> Message Control -> Message Control zur Runtime -> Nachrichten quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nachrichten können vom Empfänger bestätigt oder angelehnt werden. Abhängig vom Medium, sind Nachrichten entweder immer oder optional quittierpflichtig.

Medium

Quittierpflichtig

  • -: nein
  • +: ja

E-Mail-Nachricht über Outlook

-

E-Mail-Nachricht über SMTP

-

SMS-Nachricht über GSM-Modem

-

SMS-Nachricht über SMS-Gateway

-

Sprachnachricht Audiodatei über Modem

+

Sprachnachricht Text-to-Speech über Modem

+

Wird eine Nachricht nicht, falsch oder ablehnend quittiert, wird sie an die nächste Ersatzperson verschickt. Beim Quittieren von Nachrichten können verknüpfte Funktionen ausgeführt werden.

Bestätigung projektieren

Um Bestätigung oder Ablehnung der Nachricht zu projektieren:

  1. Öffnen Sie in der Funktion Sende Nachricht die Registerkarte Empfangsbestätigung.
  2. Aktivieren Sie die Checkbox Empfangsbestätigung erforderlich (bei Sprachnachrichten immer aktiv).
  3. Definieren Sie die Wartezeit (Timeout), innerhalb der die Nachricht quittiert werden muss.
    Nach Ablauf der Wartezeit wird die Nachricht an die nächste projektierte Person geschickt.
  4. Konfigurieren Sie die Codes für Bestätigung (PIN) oder Ablehnung (NA-Code) über:
    1. die Eigenschaften des Benutzers:
      Message Control Benutzer -> PIN-Code und NA-Code

      Interne ID: Nachrichten quittieren

      NA-Code

      Not-Available-Code, mit dem der Benutzer die Annahme der Nachricht verweigern kann.

      Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft PIN-Code unterscheiden.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Nachrichten quittieren

      PIN-Code

      PIN Code, mit dem der Benutzer den Empfang der Nachricht bestätigt.

      Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft NA-Code unterscheiden.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Nachrichten quittieren

      Message Control Benutzer

      Aktiv: Benutzer wird von Message Control verwendet.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      oder

    2. in der Funktion über:
      Checkbox Nachrichtenspezifische Codes verwenden -> PIN-Code und NA-Code

    Werden Codes sowohl über Eigenschaften als auch die Funktion projektiert, gelten die Codes der Funktion.
    Tipp: Werden Codes über die Funktion gesetzt, empfiehlt es sich, im Nachrichtentext einen Hinweis darauf zu setzen, damit der Empfänger den richtigen Code für Aktivierung oder Ablehnung verwendet.

  5. Definieren Sie die Funktionen, die nach Empfang der Codes ausgeführt werden sollen für:
    1. die Nachricht wurde bestätigt
    2. die Nachricht wurde weder bestätigt noch abgelehnt
    3. die Nachricht wurde abgelehnt
  6. Schließen Sie den Dialog mit Klick auf die Schaltfläche OK

Quittieren zur Runtime

Beim Versenden erhält jede quittierpflichtige Nachricht eine eigene, eindeutige Kennung (GUID). Über diese Kennung werden alle Aktionen der Nachricht zugeordnet. Ist eine Nachrichten quittierpflichtig, wird die Kennung automatisch in den Text der Nachricht eingefügt.

Um eine Nachricht zu quittieren, muss der Empfänger je nach Medium Nachrichtennummer und PIN in einem definierten Format senden.

Schriftliche Nachrichten können so auch über andere Versandwege als die projektierten quittiert werden. Dazu muss:

  • die Nachricht als E-Mail oder SMS verschickt worden sein
  • die Antwort als E-Mail oder SMS erfolgen
  • die GUID in der Antwort enthalten sein
  • der Code für die Quittierung in der Antwort enthalten sein
  • das für die Antwort benutzte Medium konfiguriert sein

E‑Mails quittieren

So wird eine E-Mail quittiert:

  • Der Anwender schickt die Nachricht per Antwortfunktion seines E-Mail-Programms zurück.
  • Der Betreff darf bei E-Mail nicht verändert werden, muss aber durch vorangestellte zwei Buchstaben wie RE: oder AW: als Antwort kenntlich sein.
    Die für Outlook in Betreff (Id) bzw. für SMTP in E-Mail Betreff definierten Inhalte müssen unverändert bleiben. Über diese wird die Nachricht beim Empfang in zenon identifiziert und zugewiesen.

    Interne ID: Nachrichten quittieren

    E-Mail Betreff

    Eingabe des Betreffs für ausgehende E-Mails.

    Eingehenden E-Mails müssen diesen Text ebenfalls im Betreff stehen haben, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Text nicht enthalten, werden weder an Message Control weitergeleitet noch vom Server gelöscht.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Nachrichten quittieren

    Betreff (Id)

    Eindeutiger Betreff der ausgehenden Nachricht. Dieser dient bei eingehenden Nachrichten als Kriterium, ob die Nachricht für Message Control bestimmt ist und verarbeitet werden soll.

    Eingehenden E-Mails müssen diesen Text im Betreff enthalten, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Betreff nicht enthalten, werden nicht an Message Control weitergeleitet.

    Mindestlänge: 4 Zeichen

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Der Antworttext muss enthalten:
    • GUID
    • Semikolon (;) als Trennzeichen
    • PIN-Code oder NA-Code

    z. B.: 43d3c61d-ccc9-4c76-bc2c-61c2d12b0db3;0246

  • Message Control identifiziert E-Mails für Message Control anhand des Betreffs.
    Achtung: Der Betreff der Antwort muss als Antwort gekennzeichnet sein. Dazu wird der die Nachricht beim Empfang darauf untersucht, ob sie mit zwei Buchstaben wie RE: oder AW: beginnt.
  • Message Control wertet GUID und Code aus und führt dann die in der Funktion Sende Nachricht festgelegten Funktionen aus.

Hinweis: Falls das Medium SMS konfiguriert wurde, kann eine per E-Mail verschickte Nachricht auch mit SMS quittiert werden.

SMS quittieren

So wird eine SMS quittiert:

  • Der Anwender schickt die Nachricht per Antwortfunktion seines Telefons zurück.
  • Der Antworttext muss enthalten:
    • GUID
    • Semikolon (;) als Trennzeichen
    • PIN-Code oder NA-Code

    z. B.: 43d3c61d-ccc9-4c76-bc2c-61c2d12b0db3;0246

  • Message Control wertet GUID und Code aus und führt dann die in der Funktion Sende Nachricht festgelegten Funktionen aus.

Hinweis: Falls das Medium E-Mail konfiguriert wurde, kann eine per SMS verschickte Nachricht auch mit einer E-Mail quittiert werden.

Sprachnachricht

Sprachnachrichten sind immer quittierpflichtig. So wird eine Sprachnachricht quittiert:

  • Das Telefongerät des Empfängers muss DTMF-fähig sein.
  • Das empfangende Modem an der Anlage muss DTMF-fähig sein.
  • Die Nachricht wird dem Empfänger mit Begrüßung und Nachrichtentext vorgelesen.
  • Der Empfänger quittiert die Nachricht über Tastensignale mit PIN-Code oder NA-Code.
  • Der Empfänger kann:
    • Nachrichten wiederholen lassen:
      Dazu drückt er am Telefon die Taste #. Die zuvor gesendete Botschaft (Begrüßung, Nachricht oder Fehlermeldung) wird wiederholt.
    • Gesendeten Code zurücksetzen:
      Dazu drückt er am Telefon die Taste *. Der zuvor von ihm gesendete Code (PIN oder NA) wird annuliert. Die Wiedergabe der Nachricht startet wieder mit der Begrüßung.
  • Message Control wertet den Code aus und führt dann die in der Funktion Sende Nachricht festgelegten Funktionen aus.

Hinweis: Sprachnachrichten müssen immer telefonisch quittiert werden.


Netzwerk

Handbuch -> Message Control -> Message Control zur Runtime -> Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Netzwerk wird die Message Queue zwischen Server und Standby-Server permanent synchronisiert. Werden neue Nachrichten am Server erstellt, so werden diese zum Standby übertragen. Beim Hochfahren des Servers bzw. Standby-Servers wird die Message Queue mit dem prozessführenden Server bzw. Standby-Server abgeglichen. Da Server und Standby-Server unterschiedliche Ressourcen nützen, können Nachrichten nur am versendenden Rechner quittiert werden.

Ebenso wird die Liste der unterdrückten Elemente abgeglichen und remanent gespeichert.

Die Funktion Sende Nachricht wird nur am prozessführenden Rechner durchgeführt. Der Versand vom Client wird nicht unterstützt.

Benutzer

Benutzer werden über die zenon Benutzerverwaltung bearbeitet. Benutzer können daher am Server, Standby-Server und Client bearbeitet werden. Die Bearbeitung über Webserver und Webclient ist ebenfalls möglich.

Keine Ressourcenteilung

Server und Standby-Server dürfen keine Ressourcen teilen. Es dürfen auch keine identen Ressourcen für unterschiedliche Medien am gleichen Rechner verwendet werden. Das bedeutet:

  • E-Mail (SMTP): Server und Standby-Server verwenden unterschiedliche E-Mail-Accounts.
  • E-Mail (Outlook): Server und Standby-Server verwenden unterschiedliche Outlook Profile.
  • GSM: Server und Standby-Server verwenden unterschiedliche Modems und SIM-Karten mit unterschiedlichen Telefonnummern.
  • SMS (SMS-Gateway): Server und Standby-Server verwenden unterschiedliche Modems und unterschiedliche Telefonnummern.
  • Sprachnachricht: Server und Standby-Server verwenden unterschiedliche Modems und unterschiedliche Telefonnummern.
  • Jeder Rechner:

    Verwendet jeweils ein eigenes Modem und eine eigene Telefonnummer für:

    • SMS über GSM
    • SMS über SMS-Gateway
    • Sprachnachricht mit Audiodatei
    • Sprachnachricht Text-to-Speech

    Verwendet unterschiedliche Accounts für:

    • Outlook
    • E-Mail über SMTP

Verhalten beim Ausfall

Fällt der Server aus, dann verschickt der Standby-Server nach seiner Hochstufung zum Server alle bestätigungspflichtigen Nachrichten in der Message-Queue erneut. Das kann zum doppelten Versand von Nachrichten führen, sichert aber deren korrekte Quittierung, da Nachrichten nur am versendenden Rechner quittiert werden können.

Nach einem Ausfall, der zum Neustart des Rechners führt, müssen GSM-Modems eventuell neu initialisiert und deren COM-Ports überprüft werden.


Meldungen und Fehlerbehandlung

Handbuch -> Message Control -> Meldungen und Fehlerbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Meldungen, Hinweise und Fehler können mit dem Diagnose Viewer in einem eigenen Modul [Message Control] mitgeloggt und angezeigt werden. Details zu den Meldungen finden Sie im Abschnitt LOG-Einträge.

Netzwerk

Der Netzwerkverkehr kann mit Wireshark mitgelesen werden. Wenn die Übertragung ungesichert durchgeführt wird, sind im Capture sämtliche an den Server gesendeten Befehle und dessen Antworten im Klartext ersichtlich. Bei verschlüsselten Verbindungen kann der SSL / TLS Handshake geprüft werden, nicht jedoch der Austausch von Nutzdaten.

Server

Zum Prüfen, ob ein Server gewisse Kommandos unterstützt, kann eine Telnet-Session zu dem Server aufgebaut werden.

Der Telnet-Client kann unter Windows 7 wie folgt installiert werden:

  1. Systemsteuerung öffnen.
  2. Programme und Funktionen öffnen.
  3. Windows Funktionen aktivieren oder deaktivieren öffnen.
  4. Checkbox vor Telnet-Client aktivieren.
  5. Dialog mit OK beenden.
  6. Der Telnet Client wird installiert.

In der Kommandozeile kann die Verbindung nun durch den Befehl telnet [Servername oder IP-Adresse] [Port zB 25 oder 110] geöffnet werden.

Mailserver

Die Verbindung zum Mailserver kann mit einem Mail-Client-Programm (z. B. Outlook) geprüft werden. Wird eine unverschlüsselte Verbindung verwendet, kann die Analyse mit Wireshark die unterstützten SMTP und POP3 Befehle aufzeigen.

DNS

Die Namensauflösung kann mit einem Programm wie nslookup überprüft werden. nslookup kann sowohl Namen in IP-Adressen als auch IP-Adressen in Namen auflösen. Dazu muss in IP-Konfiguration des Rechners ein gültiger DNS Server eingetragen sein.

GSM

Zur Analyse bei Problemen mit GSM können zum Beispiel verwendet werden:

  • Serial Port Monitoring:
    Kann die Kommunikation zwischen zenon und dem GSM-Modem überwachen.
  • HyperTerminal:
    Ermöglicht es, AT-Befehle ans Modem zu schicken.
    Hinweis: Wird von Microsoft nur bis Windows XP ausgeliefert. Kann für andere Betriebssysteme manuell kopiert oder durch andere Tools ersetzt werden.

Noch in diesem Kapitel

Checkliste

LOG-Einträge


Checkliste

Handbuch -> Message Control -> Meldungen und Fehlerbehandlung -> Checkliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Auftreten von Problemen überprüfen Sie:

Problem

Mögliche Ursache

Lösung

SMTP-Mail

Ausgehende Mails werden nicht gesendet, eingehende Mails werden nicht empfangen.

Die Versandart ist nicht korrekt konfiguriert. Hinweis darauf sind LOG-Meldungen wie „inaktive Versandart", „Server nicht erreichbar", „Benutzer nicht auffindbar", „SMTP / POP3 Authentifizierung fehlgeschlagen".
  • Ist die Eigenschaft Versandart aktiv aktiviert?

    Interne ID: Checkliste

    Versandart aktiv

    Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ist der Benutzer, an den die Mail gehen soll, als „Message Control Benutzer" gesetzt (Eigenschaft Message Control Benutzer aktiviert)?

    Interne ID: Checkliste

    Message Control Benutzer

    Aktiv: Benutzer wird von Message Control verwendet.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Wurde für den Benutzer eine E-Mail-Adresse konfiguriert?
  • Werden die Benutzerdaten nach einer Änderung zur Runtime übertragen (Eigenschaft RT änderbare Daten)?

    Interne ID: Checkliste

    RT änderbare Daten

    Der Konfigurationsdialog für die Runtime änderbaren Daten wird geöffnet.
    Standard-Rezepte, Rezeptgruppen-Manager, Scheduler oder Production and Facility Scheduler und Benutzerverwaltung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Stimmt die Konfiguration der Versandart? Mit Daten des E-Mail-Anbieters vergleichen.

Der Server ist korrekt eingetragen, aber nicht erreichbar (Fehlermeldungen beim Verbindungsaufbau).
  • Funktioniert die Namensauflösung?
  • Ist der Server erreichbar (Ping)?
  • Erlaubt die Firewall den Aufbau einer Verbindung zum eingestellten Port? Sowohl die Rechner-Firewall als auch die Domain-Firewall kann das blockieren. Mit Telnet prüfen.

Der Server unterstützt ein Kommando nicht (Fehlermeldung mit „Command not Supported" oder ähnlichem in der LOG-Datei).
  • Prüfen, ob der Server das Kommando unterstützt (z.B. mit Thunderbird oder Telnet).
  • Wenn möglich, eine andere Konfiguration wählen (z.B. SMTP AUTH Kommandos können durch „Vor E-Mail-Versand am Posteingangsserver anmelden" umgangen werden. APOP kann deaktiviert und durch Vebutzer und Passwort ersetzt werden.

Der Server verlangt eine verschlüsselte Verbindung. Da unverschlüsselt gesendet wird, bricht und der Server die Verbindung ab.
  • In diesem Fall zeigt die Analyse mit Wireshark, dass der Server „STARTTLS" sendet. Da dieses Kommando nicht unterstützt wird, sollte die Verbindung über SSL oder TLS abegesichert werden.

Der Server unterstützt den gewählten Absicherungsmechanismus nicht (Fehlermeldungen beim Aufbau einer verschlüsselten Verbindung).
  • Andere Absicherungskonfiguration oder Klartextübertragung auswählen.

SMS-GMS

zenon kann keine Verbindung zum Modem aufbauen.
  • Falscher COM-Port (File-Not-Found-Fehler beim Öffnen des COM-Ports).
  • COM-Port belegt (zB durch die Konfigurationssoftware des Herstellers, Access-Denied-Fehler beim Öffnen des COM-Ports).
  • Fehler beim Konfigurieren des COM-Ports/Modem antwortet nicht.
  • Das Modem unterstützt den SMS-PDU-Modus nicht (AT+CMGF-Fehlermeldung oder PDU-ModeFehlermeldung im Log)
  • Braucht das Modem vielleicht einen PIN / stimmt dieser nicht? (PIN-Fehlermeldungen im LOG)
  • Wurde zu oft versucht, sich mit einem falschen PIN anzumelden? (PUK-Fehlermeldungen im LOG) In diesem Fall ist die Verbindung zwischen zenon und dem Modem erst wieder möglich, wenn der PUK händisch eingegeben und somit die Sperre aufgehoben wurde.
  • COM-Port und Modem-Konfiguration überprüfen.
  • PIN überprüfen, eventuell manuell mit PUK wieder frei geben.

Verbindung wird hergestellt, aber Senden und Empfangen funktionieren nicht
  • Wurde zuerst mit der Herstellersoftware eine Verbindung zwischen dem Modem und dem GSM-Netz hergestellt? Die Verbindung zum Netz wird meistens erst nach Aufrufen der Herstellersoftware aufgebaut!
  • Das Modem hat trotzdem keinen Kontakt zum Netz (mit Herstellersoftware prüfen): Platz mit besserem Empfang suchen.
  • Die eingegebene SMSC-Telefonnummer stimmt nicht (vor Eingabe in zenon / erstmaligen Verbindungsaufbau (auch über „Modem prüfen!!) die SMSC mit HyperTerminal vom Modem laden und aufschreiben)
  • Fehlermeldungen im LOG anschauen
  • Modem erstmals mit Herstellersoftware mit GSM-Netz verbinden.
  • Anderen Aufstellungsort für Modem wählen.
  • Rufnummer überprüfen.


LOG-Einträge

Handbuch -> Message Control -> Meldungen und Fehlerbehandlung -> LOG-Einträge

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einträge in der LOG-Datei des Diagnose Viewers.

Diverse Meldungen

Ebene | Eintrag | Erklärung
ERRORS | Error while initializing the profile list. | Beim Ermitteln der zur Verfügung stehenden Outlook-Profile ist ein Fehler aufgetreten.
logLe_MSG | Logging on to default mapi profile %s | Wenn kein Profil ausgewählt wurde, ermittelt die Versandart das 1. Profil, und loggt sich damit ein.
ERRORS | The default profile could not be determined. | Es ist ein Fehler aufgetreten beim Ermitteln des 1. zur Verfügung stehenden Outlook-Profils.
ERRORS | Logon to mapi profile(%s) failed. Error code = %d | Das Anmelden auf dem angegebenen Profil war nicht möglich.
MSG | Logging on to mapi profile %s | Login auf Profil [Name].
ERRORS | An error occured while initialising the MAPI. | Beim initialisieren der MAPI ist ein Fehler aufgetreten.
MSG | Loggin off of MAPI profile %s. | Ausloggen aus Profil [Name].
ERRORS | An error occured while uninitialising the MAPI. | Beim Deinitialisieren der MAPI ist ein Fehler aufgetreten.
ERRORS | The Message '%s' could not be send, no connection to Outlook present: make sure it's running and a valid profile has been set. | Die Nachricht [Name] konnte nicht verschickt werden, weil kein Verbindung zur Outlook vorhanden ist. Stellen Sie sicher, dass eine Outlook-Instanz läuft und ein gültiges Profil eingetragen wurde.
DEBUG | Sending mail to user '%s' using address: %s. | Es wird einen Nachricht für den Benutzer [Name] vorbereitet und an die Adresse [ verschickt].
DEBUG | Current Message %Nachricht Inhalt% | Der aktuelle Nachricht (Inhalt, Settings,etc) wird im Log getraced.
DEBUG | Mail to user '%s' was successfully added to the outbox. | Der Nachricht an Benutzer [Name] wurde erfolgreich in die Outbox von Outlook übertragen.
ERRORS | Mail to user '%s' failed. | Der Nachricht an Benutzer [Name] konnte nicht in die Outbox von Outlook übertragen werden.
ERRORS | Error while using MAPI to create and transfer a mail into the Outlook-outbox. | Bei der Verwendung der MAPI beim Erstellen und Übertragen einer Nachricht in die Outlook Outbox ist ein Fehler aufgetreten.
ERRORS | Error while using MAPI to hook into the fnevNewMail-Event of Outlook. | Beim Erstellen des fnevNewMail-Event hook ist ein Fehler aufgetreten .
ERRORS | An error occured while initializing TAPI. | Bei der Initialisiereing der TAPI ist ein Fehler aufgetreten.
ERRORS | An error occured while trying to open the line %s. | Beim öffnen der Leitung [] ist ein Fehler aufgetreten.
DEBUG | The line %s has been opened. | Die Leitung [] wurde erfolgreich geöffnet.
ERRORS | No line selected. | Für diese Versandart wurde keine Leitung definiert.
DEBUG | The line %s has been closed. | Die Leitung [] wurde erfolgreich geschlossen.
ERRORS | An error occured while closing the line %s. | Beim Schließen der Leitung [] ist ein Fehler aufgetreten.
DEBUG | The current call be terminated now. | Es ist ein Anruf aktiv, dieser wird jetzt beendet.
DEBUG | The is no call in progress, nothing to terminate. | Es ist kein Anruf aktiv, es kann nichts beendet werden.
DEBUG | Attaching to current call. | Der Versandart hängt sich an den aktiven Anruf an.
ERRORS | The current call is not our call,can't attach! | Der aktuelle Anfruf ist nicht der richtige Anruf und wird nicht verwendet.
ERRORS | The call status of the current call returns an error! | Der Status des aktuellen Anrufs ist "Fehler".
DEBUG | The #-sign was entered: Repeating the last message. | # wurde eingegeben: Die letzte Nachricht wird wiederholt.
DEBUG | The *-sign was entered: Clearing the current key. | Es wurde ein * eingegeben, der aktuelle eingegebene Code wird zurückgesetzt.
ERRORS | The incoming message does not contain a seperator (';')for the unique message ID: %s | Das Layout der eingehenden Nachricht ist ungültig. Es fehlt das Trennzeichen.
DEEPDEBUG | Project %s signed on. | Das Projekt wird bei Message Control angemeldet.
DEEPDEBUG | Project %s signed off. | Das Projekt wird bei der Engine abgemeldet.
ERRORS | An attempt was made to add a message %s to the engine queue, but the message its project is not signed on with the engine! | Ein Projekt, das nicht angemeldet ist, hat versucht eine Nachricht [Inhalt] an Message Control zu übertragen.
DEEPDEBUG | The message %s is added to the Queue. | Der Nachricht mit der Guid [Nummer] wurde in die Queue eingefügt.
ERRORS | An attempt was made to add messages to the engine queue, but owner project %s is not signed on with the engine! | Ein Projekt, das nicht angemeldet ist, hat versucht mehrere Nachrichten an Message Control zu übertragen.
ERRORS | An attempt was made to remove a message %s from the engine queue, but owner project %s is not signed on with the engine! | Ein Projekt, das nicht angemeldet ist, hat versucht eine Nachricht [Guid] von Message Control zu entfernen.
ERRORS | An attempt was made to remove messages from the engine queue, but the owner project %s is not signed on with the engine! | Ein Projekt, das nicht angemeldet ist, hat versucht mehrere Nachrichten von Message Control zu entfernen.
DEEPDEBUG | All messages for project %s will be removed. | Alle Nachrichten vom Projekt [Name] werden von Message Control entfernt.
ERRORS | And old function 'Edit user database' was executed, but this function is no longer required/supported, execution interupted! | Es wurde einen Funktion "Benutzerdatenbank anzeigen/bearbeiten" ausgeführt. Diese Funktion ist nur in Versionen bis zenon 6.51 enthalten. Ab zenon 7 gibt es sie nicht mehr.
ERRORS | Line is busy -> try again… | Der Leitung ist besetzt, der Anruf wird später nochmals versucht.
ERRORS | Sending message to user %s." | Aktuelle Nachricht wird verschickt an Benutzer [Nummer/Adresse]
ERRORS | Current Message: | Aktuelle Nachricht [Text/Datei] wird verschickt.
DEBUG | Connected | Es wurde eine Verbindung hergestellt.
DEBUG | Valid Acknowlegde-code entered. | Es wurde ein gültiger PIN-Code zum Bestätigen der Nachricht eingegeben.
DEBUG | Valid NegAcknowlegde-code entered. | Es wurde ein gültiger NA-Code zum Ablehnen der Nachricht eingegeben..
DEBUG | Invalid code '%s' entered. | Es wurde ein ungültiger Code eingegeben.
ERRORS | Inbox folder %s invalid!. | Der konfigurierte Inbox-Ordner existiert nicht.
ERRORS | Outbox folder %s invalid!. | Der konfigurierte Outbox-Ordner existiert nicht.
ERRORS | Statusbox folder %s invalid!. | Der konfigurierte Statusbox-Ordner existiert nicht.
ERRORS | Prefix %s invalid!. | Das konfigurierte Präfix ist ungültig. Die Länge muss exakt 1 Zeichen sein.
ERRORS | Semaphor prefix %s invalid!. | Der konfigurierte Semaphorpräfix ist ungültig. Die Länge muss exakt 1 Zeichen sein.
DEBUG | Send SMS to user %s. | Es wirde eine SMS an den Benutzer [Adresse] verschickt.
DEBUG | SMS to user %s transmitted to the outbox. | Es wurde eine SMS an den Benutzer [Adresse] in die Outbox übertragen.
ERRORS | SMS to user %s could not be placed in the outbox. | Eine SMS an den Benutzer [Adresse] konnte nicht in die Outbox übertragen werden.
WARNINGS | Index exceeded 99999, starting from 0. | Maximaler Index für die Dateiname erreicht, es wird neu bei 0 angefangen.
DEEPDEBUG | Last index set to %d. | Der letzt verwendete Index wurde auf [Wert] gesetzt.
ERRORS | Could not set last index set to %d. | Der Index konnte nicht auf [Wert] gesetzt werden.
ERRORS | Inbox SMS-File for semaphor file: %s; is not found! Deleted the SEMA file! | In der Inbox wurde zwar einen Semaphordatei gefunden, aber keine dazu gehörende SMS-Datei.
ERRORS | StatusBox Status-File for semaphor file: %s; is not found! Deleted SEMA file! | In der Statusbox wurde zwar einen Semaphordatei gefunden, aber keine dazu gehörende Status-Datei.
DEEPDEBUG | MessageChangedNotify received for Message %s ignored (no longer Mainstation)! | Das Projekt bekam eine Changed notification für Message mit GUID [Nummer] von Message Control, ist aber nicht mehr prozessführende Instanz.
DEEPDEBUG | Sending changed notification for message %s to SB. | Das Nachrichtenobjekt mit GUID [Nummer]s hat sich geändert, das "neue" Objekt wird zum Standby-Server verschickt.
DEEPDEBUG | A changed notification of message(%s) was received, the old message object will be updated! | Das Projekt bekam ein Änderungstelegramm für die Nachricht mit der GUID [Nummer]. Das lokale (alte) Objekt wird aktualisiert.
ERRORS | Couldn't send changed notification for Message %s to SB. | Der Versuch, ein Änderungstelegramm für Nachricht mit GUID [Nummer]zum Standby-Server zu schicken, ist fehlgeschlagen.
DEEPDEBUG | Sending remove notification for message %s to SB. | Das Nachrichtenobjekt mit GUID [Nummer] wurde entfernt, es wird ein Remove Telegramm zum Standby-Server verschickt.
DEEPDEBUG | A remove notification of message(%s) was received, the message object will be removed from the list. (%s) | Das Projekt bekamm ein Remove-Telegramm für Nachricht mit GUID [Nummere]. Das lokale (alte) Objekt wird gelöscht.
ERRORS | Couldn't send remove notification for Message %s to SB. | Der Versuch, ein Remove-Telegramm für Nachricht mit GUID [Nummer] zum Standby-Server zu schicken, ist fehlgeschlagen.
DEEPDEBUG | Sending added notification for message %s to SB. | Das Nachrichtenobjekt mit GUID [Nummer] wurde erstellt. Das "neue" Objekt wird auch zum Standby-Server verschickt.
DEEPDEBUG | An addded notification of message(%s) was received, the message object will be added to the list. (%s) | Das Projekt bekam ein Add-Telegramm für einen Nachricht mit GUID [Nummer]. Das neue Objekt wird eingefügt.
ERRORS | Couldn't send added notification for message %s to SB. | Der Versuch, ein Add-Telegramm für die Nachricht mit GUID [Nummer] zum Standby-Server zu schicken, ist fehlgeschlagen.
DEEPDEBUG | Sending MessageCtrl-StateChanged to SB. | Es wird ein MessageControl-StateChange Telegramm zum Standby-Server verschickt.
ERRORS | Couldn't send MessageCtrl-StateChanged notification to SB. | Der Versuch, ein MessageControl-StateChange Telegramm für die Nachricht mit GUID [Nummer] zum Standby-Server zu schicken, ist fehlgeschlagen.
DEEPDEBUG | An update of the message control state was received. The local state will be updated! | Das Projekt bekam ein MessageControl-StateChange-Telegramm für eine Nachricht mit GUID [Nummer]. Das neue Objekt wird eingefügt.
DEBUG | Sending MessageDeleteRequest for %d messages to Mainstation. | Es wird ein Delete-Request für [Anzahl] Nachrichten zum prozessführenden Rechner verschickt.
DEBUG | MessageDeleteRequest Response: %d messages were deleted from the queue. | Es wurde ein Delete-Response empfangen: [Anzahl] Nachrichten wurden aus der Queue entfernt.
DEBUG | Couldn't send MessageDeleteRequest notification to Mainstation. | Der Versuch, ein Delete-Request-Telegramm zum prozessführende Rechner zu schicken, ist fehlgeschlagen.
DEBUG | Requesting File alignment from mainstation. | Es wird ein Abgleich-Request zum prozessführende Rechner verschickt.
DEBUG | File alignment request could not be send to mainstation. | Der Versuch, ein Abgleich-Request zum prozessführende Rechner zu verschicken, ist fehlgeschlagen.
DEEPDEBUG | A getqueue request was received, sending queue. | Es wurde ein Abgleich-Request empfangen. Die aktuelle Queue und der aktuelle Status werden verschickt.
DEEPDEBUG | A delete message(s) request was received! | Es wurde ein Delete-Request-Telegramm empfangen.
DEEPDEBUG | SB state: %s(%u) | Der Status des Standby-Servers hat sich geändert und ist jetzt %s (%d).
DEEPDEBUG | Switch to server:%s | Die aktuelle Instanz wird zum Server hochgestuft.
DEEPDEBUG | Switch to standby:%s | Die aktuelle Instanz wird zum Standby-Server heruntergestuft.
DEEPDEBUG | An ChangeSuppressionRequest was received. The local suppression-state will be updated! | Es wurde ein ChangeSuppression-Request empfangen. Der lokale Suppresion-Status wird aktualisiert.
DEEPDEBUG | Messaging TimeOut watchdog activated for Project '%s' | Für das Projekt [Name] wurde die TimeOut- Überwachung gestartet.
MSG | MessageControl has been activated. | Message Control wurde aktiviert.
MSG | MessageControl has been deactivated. | Message Control wurde deaktiviert.
DEEPDEBUG | Messaging-Queue is being saved. | Die aktuelle Message-Queue wird gespeichert.
ERRORS | Error occured while saving Messaging-Queue. | Beim Speichern der Message-Queue ist ein Fehler aufgetreten.
WARNINGS | A Send-Message function was executed for a Group which does not contain any Message Control users! | Es wurde eine Sende-Nachricht-Funktion für eine Gruppe ausgeführt, die leer ist oder keine für Message Control aktivierten Benutzer beinhaltet.
DEEPDEBUG | The Message (%s) was removed from the project queue. | Der Nachricht mit Guid [Nummer] wurde aus der Queue entfernt.
ERRORS | Update failure: An existing instance of message '(%s)' could not be found in the local map! | Der Nachricht mit Guid [Nummer] konnte nicht aktualisiert werden, da sie nicht gefunden wurde.
ERRORS | Messaging canceled: The user (%s) which was defined as the destination for the message %s could not be found! | Der gewählte Ziel-Benutzer konnte nicht gefunden werden, der Versand wird abgebrochen.
DEBUG | The next user (%s) for the group (%s) will be notified, previous user was:%s | Der nächste Benutzer [Name]aus der Benutzergruppe [Name] wird benachrichtigt, der Benutzer davor war Benutzer [Name].
ERRORS | Messaging canceled: The next user for the Group (%s) could not be determined, has the group been deleted or empty? | Der nächste Benutzer für Benutzergruppe [Name] konnte nicht ermittelt werden. Wurde die Gruppe gelöscht oder ist sie leer? Der Versand wird abgebrochen.
DEBUG | Messaging canceled: The end of the user list for the Group (%s) has been reached. | Das Ende der Benutzergruppe [Name] wurde erreicht, der Versand wird abgebrochen.
ERRORS | The message %s should not be acknowledged! | Es wurde versucht, eine Nachricht [ID] zu bestätigen, obwohl die Nachricht gar nicht bestätigt werden muss/kann.
MSG | The incoming message for %s contains the correct Ack-Code. | Die eingehende Nachricht [ID] beinhaltet einen gültigen PIN-Code zum Bestätigen der Nachricht.
MSG | The incoming message for %s contains the correct NegAck-Code. | Die eingehende Nachricht [ID] beinhaltet einen gültigen NA-Code zum Ablehnen der Nachricht.
MSG | The incoming message for %s does not contain a valid code. | Die eingehende Nachricht [ID] beinhaltet keinen gültigen Code.
ERRORS | The user (%s) which was the defined destination for the outgoing message %s could not be found! | Der Benutzer [Name] der als Zielperson für Nachricht [ID] gewählt wurde, konnte nicht gefunden werden!
DEBUG | The Message %s was successfully sent to %s! | Die Nachricht [ID] wurde erfolgreich an [Empfänger] verschickt.
DEBUG | The Message %s was NOT successfully sent to %s! | Die Nachricht [ID] konnte nicht an [Empfänger] verschickt werden.
DEBUG | The Message %s was not successfully sent to %s, and will be send again! | Die Nachricht [ID] konnte nicht an [Empfänger] verschickt werden und wird erneut verschickt.
DEBUG | The sending of message %s was completed. | Der Versandprozess für Nachricht [ID] ist abgeschlossen.
ERRORS | msgNotify_TimeOut received for message %s, which is no longer present in the queue! | Es wurde einen TimeOut-Notification für Nachricht [ID] von Message Control empfangen, obwohl diese Nachricht gar nicht (mehr) in der Queue ist.
ERRORS | msgNotify_Finished received for message %s, which is no longer present in the queue! | Es wurde einen Finished-Notification für Nachricht [ID] von Message Controlempfangen, obwohl diese Nachricht gar nicht (mehr) in der Queue ist.
DEBUG | The message %s should have been acknowledged by now, handling TimeOut. | Der Nachricht [ID] hätte bereits bestätigt werden sollen, TimeOut wird verarbeitet.
DEBUG | The message %s should have been Sent by now, handling hardware TimeOut. | Der Nachricht [ID] hätte bereits verschickt werden sollen, TimeOut wird verarbeitet.
MSG | Selected dispatcher '%s' is busy->try again... | Der gewählte Versandart [Art] ist beschäftigt: Es wird später nochmals versucht.
ERRORS | Selected dispatcher '%s' could not send message %s. | Die gewählte Versandart [Art] konnte die Nachricht [ID] nicht verschicken.
DEEPDEBUG | Firing MessageCreated | MessageCreated wird gefired.
DEEPDEBUG | MessageCreated fired | MessageCreated wurde gefired.
DEEPDEBUG | Firing MessageSent | MessageSent wird gefired.
DEEPDEBUG | MessageSent fired | MessageSent wurde gefired.
DEEPDEBUG | Firing MessageSendError | MessageSendError wird gefired.
DEEPDEBUG | MessageSendError fired | MessageSendError wurde gefired.
DEEPDEBUG | Firing MessageAcknowledged | MessageAcknowledged wird gefired.
DEEPDEBUG | MessageAcknowledged fired | MessageAcknowledged wurde gefired.
DEEPDEBUG | Firing MessageNegAcknowledged | MessageNegAcknowledged wird gefired.
DEEPDEBUG | MessageNegAcknowledged fired | MessageNegAcknowledged wurde gefired.
DEEPDEBUG | Firing MessageAcknowledgeTimeOut | MessageAcknowledgeTimeOut wird gefired.
DEEPDEBUG | MessageAcknowledgeTimeOut fired | MessageAcknowledgeTimeOut wurde gefired.
DEEPDEBUG | Firing MessageDeleted | MessageDeleted wird gefired.
DEEPDEBUG | MessageDeleted fired | MessageDeleted wurde gefired.
DEEPDEBUG | Firing MessageIn: (Identfier:'%s',Message:'%s') | MessageIn wird gefired, Id-Wert ist %s, NachrichtText ist %s
DEEPDEBUG | MessageIn fired: (Identfier:'%s',Message:'%s') | MessageIn wurde gefired, Id-Wert ist %s, NachrichtText ist %s
DEEPDEBUG | Current message count is (%d) | Es befinden sich [Anzahl] Nachrichten in der Queue. (Eintrag wird erstellt beim Erzeugen und Löschen von Nachrichten.)
ERRORS | Can't find a user with id %s | Der Benutzer [Name]konnte nicht gefunden werden. (Wird erstellt, wenn einkommende Nachrichten abgehandelt werden, möglicherweise wurde der Benutzer gelöscht.)

E-Mail per SMTP/POP

Ebene | Eintrag | Erklärung
DEBUG | Sent E-Mail successfully to [Zieladresse] | Eine ausgehende E-Mail wurde erfolgreich an den Postausgangsserver (SMTP) übergeben. Das bedeutet nicht, dass die E-Mail bis zum Empfänger durchgekommen ist!
DEBUG | Received E-Mail successfully from [Absenderadresse] | Eine E-Mail wurde erfolgreich vom Posteingangsserver (POP3) geholt.
DEBUG | Creating an encrypted [SMTP / POP3] Connection using [SSLv2 and SSLv3 / TLSv1] | Eine verschlüsselte Verbindung zu einem der Server wird hergestellt. Welcher Absicherungsmechanismus verwendet wird und zu welchem Server (Protokollinfo: SMTP für ausgehend, POP3 für eingehend) die Verbindung aufgebaut wird, steht in der LOG-Meldung.
DEBUG | Creating an unencrypted [SMTP / POP3] Connection | Eine unverschlüsselte Verbindung zu einem der Server wird aufgebaut.
DEBUG | Connection to [SMTP / POP3] Server established successfully | Eine Verbindung zu einem der Server wurde erfolgreich hergestellt.
DEBUG | Connection to [SMTP / POP3] Server closed | Eine Verbindung zu einem der Server wurde geschlossen.
DEBUG | Authenticating to SMTP Server using SMTP AUTH [PLAIN / LOGIN] | Die Authentifizierung gegenüber dem Postausgangsserver wird mit dem angegebenen Mechanismus durchgeführt.
DEBUG | Authenticating to SMTP Server using POP3 Server Connection | Zur Authentifizierung gegenüber dem Postausgangsserver wird eine Verbindung zum Posteingangsserver hergestellt.
DEBUG | Connection to [SMTP / POP3] Server [Servername] Port [Port] ready to go | Der Verbindungsaufbau und die Authentifizierung am angegebenen Server waren erfolgreich. Die Verbindung ist bereit zur Datenübertragung.
DEBUG | Authenticating to POP3 Server using [APOP command / USER and PASS commands] | Die Authentifizierung am Posteingangsserver wird mit dem angegebenen Mechanismus durchgeführt.
WARNING | No Subject for the E-Mail specified | Es wurde kein Betreff für eine ausgehende Mail angegeben. Das ist zwar kein Fehler, aber eine Mail ohne Betreff kann einen Spamfilter dazu veranlassen, die Mail zu blockieren.
WARNING | No Text for the E-Mail specified | Es wurde kein Text für eine ausgehende Mail angegeben. Das ist zwar kein Fehler, aber eine Mail ohne Text kann einen Spamfilter dazu veranlassen, die Mail zu blockieren.
WARNING | The Server did not respond an OK Code to EHLO. Response: [Antwort des SMTP Server] | Der Postausgangsserver hat mit einem Fehlercode auf das EHLO Kommando geantwortet (Antwort in der LOG-Meldung enthalten). Der SMTP Server unterstützt keine Extensions. Die Extensions kommen bei der SMTP Authentifizierung zum Einsatz. Das ist deshalb kein Fehler, da SMTP Authentifizierung nicht verwendet werden muss und die betroffenen Funktionen selbst eine Fehlererkennung durchführen.

SMS

Ebene

Eintrag

Erklärung

ERROR

[Telefonnummer] is not a valid SMSC telephone number!

Die eingegebene Telefonnummer der Kurzmitteilungszentrale ist ungültig.

Dabei werden nur die enthaltenen Zeichen (evtl. + am Anfang, sonst nur Ziffern), nicht aber die tatsächliche Existenz der Telefonnummer oder ob diese wirklich eine Kurzmitteilungszentrale ist, geprüft!

ERROR

[Telefonnummer] is not a valid telephone number!

Die eingegebene Empfängertelefonnummer ist ungültig. Dabei werden nur die enthaltenen Zeichen (evtl. + am Anfang, sonst nur Ziffern), nicht aber die tatsächliche Existenz der Telefonnummer geprüft!

ERROR

Error on opening the port [COM-Port]: [Fehlernummer in HEX]

Der angegebene serielle Anschluss konnte nicht geöffnet werden. Die angegebene Fehlernummer kann in der MSDN Library nachgeschlagen werden und gibt Hinweise auf die möglichen Gründe des Fehlers.

ERROR

Error on configuring the port [COM-Porp] [state / timeouts / buffers]: [Fehlernummer in HEX]

Der angegebene COM-Port konnte nicht konfiguriert werden. Es werden State, Timeouts und Puffer konfiguriert. Die angegebene Fehlernummer kann in der MSDN Library nachgeschlagen werden.

ERROR

The total input buffer ([Zahl] bytes) is too small for the [Zahl] bytes received from the modem.

Der Eingangspuffer ist zu klein, als dass alle vom Modem gesendeten Daten aufgenommen werden können. Der Eingangspuffer wird mit einer Größe von 12 KB angelegt. Zum Empfangen einer SMS mit der Maximalgröße werden etwa 400 Byte benötigt. Kommen innerhalb eines Polling-Intervalls (siehe unten) mehr als 12 KB SMS-Daten, so kommt es zu diesem Fehler.

ERROR

The modem returned an error to the [AT-Kommando] command: [Fehlermeldung]

Das Modem hat auf ein AT-Kommando mit einer Fehlermeldung reagiert. Die Fehlermeldung wird an die LOG-Meldung angehängt. In der Fehlermeldung kann ein AT-Fehlercode enthalten sein.

Wenn eine Authentifizierung über einen PIN-Code notwendig ist, wird dieser mit dem Commando AT+CPIN übermittelt. Wird ein falscher Code eingegeben, beantwortet das Modem diese Anfrage mit einem Fehler.

ERROR

The modem did not respond to the [AT-Kommando] command.

Beim Warten auf die Antwort des Modems auf ein AT-Kommando kam es zu einem Timeout .

ERROR

The modem did not switch in SMS PDU mode.

Das Modem hat das AT-Kommando zum Aktivieren des SMS-PDU-Modus zwar mit OK bestätigt, diesen jedoch nicht aktiviert.

ERROR

The modem did not apply the SMSC telephone number.

Das Modem hat das AT-Kommando zum Einstellen der Telefonnummer der Kurzmitteilungszentrale zwar mit OK bestätigt, die Telefonnummer jedoch nicht als Kurzmitteilungszentrale gespeichert.

ERROR

Error: not connected

Es wurde versucht, eine SMS zu senden, empfangen oder löschen und es konnte davor keine Verbindung zum Modem hergestellt werden.

ERROR

The modem returned an error to the transmission of the PDU: [Fehlermeldung]

Das Modem hat auf die Übermittlung einer SMS-PDU mit einer Fehlermeldung geantwortet. Die Fehlermeldung wird an die LOG-Meldung angehängt. In der Fehlermeldung kann ein AT-Fehlercode enthalten sein.

ERROR

The modem did not respond to transmission of the PDU.

Beim Warten auf die Antwort des Modems auf die Übermittlung einer SMS-PDU kam es zu einem Timeout.

ERROR

Error on writing data: [Fehlernummer in HEX]

Beim Versenden von Daten über den seriellen Anschluss kam es zu einem Fehler. Die Fehlernummer kann in der MSDN Library nachgeschlagen werden.

ERROR

Not all bytes have been sent.

Obwohl die Funktion zum Senden von Daten über den seriellen Anschluss keinen Fehler meldete, wurden nicht alle Daten gesendet.

ERROR

Error on reading data: [Fehlernummer in HEX]

Beim Empfangen von Daten über den seriellen Anschluss kam es zu einem Fehler. Die Fehlernummer kann in der MSDN Library nachgeschlagen werden.

ERROR

The source SMSC telephone number [Telefonnummer] contains the not supported character [Zeichen]

Die beim SMS-Empfang erhaltene Telefonnummer der Kurzmitteilungszentrale des Absenders enthält ein ungültiges Zeichen.

ERROR

The source telephone number [Telefonnummer] contains the not supported character [Zeichen]

Die beim SMS-Empfang erhaltene Telefonnummer des Absenders enthält ein ungültiges Zeichen.

ERROR

The syntax of the timestamp [Zeitstempel] is incorrect.

Der beim SMS-Empfang erhaltene Zeitstempel vom GSM-Netz entspricht nicht dem erwarteten Format.

ERROR

The byte [Byte als HEX] could not be converted.

Ein in der PDU enthaltenes Byte konnte nicht von einem HEX-String in eine Zahl umgewandelt werden.

ERROR

Insufficient buffer to convert SMS text [Text]

Der Puffer zum Konvertieren ausgehender SMS (12 KB à 6144 Zeichen) ist nicht ausreichend.

ERROR

The format flag [Byte als HEX] is not supported.

Die Formatierung einer eingehenden SMS ist nicht unterstützt.

ERROR

Could not convert [Byte als HEX] from GSM 7-Bit-Alphabet. Baselanguage: [Byte als HEX], Extensionlanguage [Byte als HEX]

Ein im 7-Bit-SMS-Datenteil enthaltenes Zeichen konnte nicht aufgelöst werden. Die verwendeten Alphabete Basistabelle und Erweiterungstabelle) werden als Language Identifier (siehe Standard 3GPP TS 23.038 V10.0.0 (2011-03) angehängt.

ERROR

Insufficient data to decode multilanguage fragmented SMS!

Eine SMS wurde in mehreren Teilen empfange, wobei die einzelnen Teile unterschiedliche Alphabete verwenden. Die für die Konvertierung benötigten Informationen über die Alphabete sind jedoch nicht vollständig.

ERROR

The input byte stream is not a valid unicode text.

Eine empfangene Unicode-SMS enthält keinen gültigen Unicode-Text (nur gerade Byteanzahl ist gültig, da bei Unicode 2 Byte pro Zeichen).

ERROR

Insufficient Buffer to decode PDU

Beim Decodieren einer PDU wurde der 12-KB-Puffer zu klein.

ERROR

The PDU is not a valid byte stream.

Eine empfangene PDU ist nicht ein gültiger Hex-Dump eines Byte-Streams.

ERROR

The PDU length does not match the SMS text length

Die Anzahl der in einer empfangenen PDU enthaltenen Bytes passt nicht zur Längenangabe in den SMS-Steuerdaten.

ERROR

The Modem requests the PUK.

Das Modem verlangt zur Authentifizierung den Personal Unlock Key (PUK). Dieser wird vom Message Control nicht verwendet und daher wird der Verbindungsaufbau zum Modem mit einem Fehler abgebrochen. Nach mehrmaliger Falscheingabe des PIN-Codes verlangt die SIM-Karte im Modem den PUK zur Authentifizierung, wobei der PIN-Code neu gesetzt werden muss.

Achtung: Fehleingaben des PUK können zur Unbrauchbarkeit der SIM-Karte führen!

ERROR

The Modem responded with an unknown PIN Status: [Antwort des Modems]

Die Abfrage des PIN-Status des Modems brachte ein nicht erwartetes Ergebnis. Die Antwort des Modems auf die Abfrage des PIN-Status wird an die LOG-Meldung angehängt.

ERROR

The Modem requests a PIN and the PIN-Input is empty.

Das Modem verlangt eine Authentifizierung mit einem PIN-Code, es wurde vom Anwender jedoch keiner eingegeben.

ERROR

The Modem did not respond with READY-State after PIN-Authentication: [String]

Obwohl die Übermittlung des PIN-Codes vom Modem mit OK bestätigt wurde, ist der PIN-Status des Modems nicht auf "READY" (keine PIN-Eingabe mehr erforderlich) gesetzt worden. Die Antwort des Modems auf die Abfrage des PIN-Status wird an die LOG-Meldung angehängt.

DEBUG

Port [COM-Port] opened successfully

Der angegebene serielle Anschluss wurde erfolgreich geöffnet.

DEBUG

Modem configured successfully for SMS-PDU-Mode and SMSC [Telefonnummer]

Das Modem wurde erfolgreich für den SMS-PDU-Modus und die angegebene Telefonnummer der Kurzmitteilungszentrale konfiguriert.

DEBUG

Connection to modem closed.

Die Verbindung zum Modem und die serielle Schnittstelle wurden geschlossen.

DEBUG

SMS successfully sent to [Telefonnummer]

Eine SMS wurde erfolgreich an die angegebene Telefonnummer versendet.

DEBUG

Successfully received SMS from [Telefonnummer]

Eine SMS wurde erfolgreich von der angegebenen Telefonnummer empfangen.

DEBUG

The Modem does not need a PIN.

Das Modem verlangt nicht nach einer PIN-Authentifizierung.

DEBUG

Authentication with the PIN succeeded.

Die Authentifizierung mit dem konfigurierten PIN-Code war erfolgreich.

OpenSSL Library

Errorcodes und die Errormessages aus der OpenSSL Library im Format „Errorcode: [Code]. Errormessage: [String]".

Die Antworten der Server haben folgende Struktur:

  • Antworten vom POP3 Server beginnen nur dann mit „OK", wenn kein Fehler vorlag.
  • Antworten vom SMTP Server beginnen mit einem dreistelligen Statuscode:
    • 2xx = OK
    • 3xx = warte auf Daten
    • 4x und 5 xx = Fehler

Ebene

Eintrag

Erklärung

ERROR

No Destination E-Mail-Address specified

Bei einer ausgehenden Mail wurde keine Zieladresse eingegeben.

ERROR

Creating SSL/TLS Method failed. Errorcode: [Code]. Errormessage: [String]

Die zum Aufbau der abgesicherten Verbindung notwendige SSL/TLS Methode konnte nicht erstellt werden.

ERROR

Creating Connection failed. Errorcode: [Code]. Errormessage: [String]

Das Objekt für eine Verbindung (sowohl abgesichert als auch Klartext) konnte nicht erstellt werden.

ERROR

Reading SSL Structure failed. Errorcode: [Code]. Errormessage: [String]

Das Auslesen der SSL / TLS Struktur einer abgesicherten Verbindung ist fehlgeschlagen.

ERROR

Opening Connection failed. Errorcode: [Code]. Errormessage: [String]

Eine Verbindung (sowohl abgesichert als auch Klartext) konnte nicht hergestellt werden.

ERROR

The Server did not respond an OK Code to HELO. Response: [Antwort des SMTP Servers]

Der Postausgangsserver hat weder auf das EHLO noch auf das HELO Kommando mit einer OK-Meldung geantwortet (Die Antwort wird an die LOG-Meldung angehängt). Der Server wird als nicht erreichbar angesehen.

ERROR

The Server did not send a Waiting-For-Data-Response to the AUTH LOGIN [command / user data]: [Antwort des SMTP Server]

Der Postausgangsserver hat nicht die erwartete Antwort auf das AUTH LOGIN Kommando oder den dazugehörigen Benutzernamen gesendet. Die Antwort wird an die LOG-Meldung angehängt.

ERROR

The Server did not send an OK-Response to the AUTH LOGIN password data: [Antwort des SMTP Server]

Der SMTP Server hat die AUTH LOGIN Passwortdaten nicht mit OK bestätigt. Die Anmeldung ist fehlgeschlagen.

ERROR

The Server did not send a Waiting-For-Data-Response to the AUTH PLAIN command: [Antwort des SMTP Server]

Der Postausgangsserver hat nicht die erwartete Antwort auf das AUTH PLAIN Kommando gesendet. Die Antwort wird an die LOG-Meldung angehängt

.

ERROR

The Server did not send an OK-Response to the AUTH PLAIN data: [Antwort des SMTP Server]

Der SMTP Server hat die AUTH PLAIN Daten nicht mit OK bestätigt. Die Anmeldung ist fehlgeschlagen. Die Antwort wird an die LOG-Meldung angehängt.

ERROR

SMTP AUTH should be used, but the Server neither supports AUTH LOGIN nor the minimum implementation AUTH PLAIN

SMTP Authentication soll verwendet werden, der Server hat bei der EHLO-Antwort jedoch die benötigten Befehle nicht in der Liste unterstützter Extension-Befehle angeführt.

Benötigt werden: AUTH LOGIN und AUTH PLAIN, letzteres ist laut RFC 2554 die minimale Implementierung.

ERROR

[SMTP / POP3] not connected

Es wurde versucht Daten an den Postausgangsserver zu senden oder Daten vom Posteingangsserver zu holen, obwohl keine Verbindung zum Server steht.

ERROR

The Server did not send an OK-Response to the MAIL command: [Antwort des SMTP Server]

Der Postausgangsserver hat das MAIL Kommando (Versenden einer neuen Mail) nicht mit OK bestätigt. Die Antwort wird an die LOG-Meldung angehängt.

ERROR

The Server did not send an OK-Response to the RCPT command: [Antwort des SMTP Server]

Der Postausgangsserver hat das RCPT Kommando (fügt einen Empfänger hinzu) nicht mit OK bestätigt. Die Antwort wird an die LOG-Meldung angehängt.

ERROR

The Server did not send a Waiting-For-Data-Response to the DATA command: [Antwort des SMTP Server]

Der Postausgangsserver hat nicht die erwartete Antwort auf das DATA Kommando (Maildaten werden übertragen) gesendet. Die Antwort wird an die LOG-Meldung angehängt.

ERROR

The Server did not send an OK-Respone to the transmitted Data: [Antwort des SMTP Server]

Der Postausgangsserver hat die gesendeten Maildaten nicht mit OK bestätigt. Die Antwort wird an die LOG-Meldung angehängt.

ERROR

APOP Authentication is required but the Server did not send APOP Data

Zur Anmeldung am Posteingangsserver soll das APOP Kommando verwendet werden, der Posteingangsserver hat jedoch nicht die benötigten Daten geliefert.

ERROR

Creating APOP Digest failed. Errorcode: [Code]. Errormessage: [String]

Der MD5-Hash zur APOP-Authentifizierung konnten nicht erstellt werden.

ERROR

The Server did not send an OK-Response to the [POP3-Kommando] command: [Antwort des POP3 Server]

Der Posteingangsserver hat ein Kommando nicht mit OK bestätigt. Die Antwort wird an die LOG-Meldung angehängt.

Folgende Kommandos können hiervon betroffen sein: APOP, USER, PASS, STAT, RETR, DELE.

Hinweis: Wenn beim Kommando DELE noch der Hinweis „Could not delete Mail" entahlten ist, wurde eine E-Mail zwar empfangen, konnte aber nicht gelöscht werden. Da die E-Mail erfolgreich empfangen wurde, wird sie an Message Control weitergeleitet.

ERROR

The OK-Response to the STAT command did not have the expected Format: [Antwort des POP3 Server]

Die Antwort des Posteingangsserver auf das STAT Kommando entsprach nicht der Formatdefinition laut RFC 1939.

Format: OK<Leerzeichen>[Anzahl der Mails im Postfach]<Leerzeichen>[Gesamtgröße aller Mails im Postfach in Bytes]

ERROR

[Sending / Receiving] Data failed. Errorcode: [Code]. Errormessage: [String]

Das Senden oder Empfangen von Daten über eine OpenSSL Netzwerkverbindung ist fehlgeschlagen.


Monitorverwaltung

Handbuch -> Monitorverwaltung

Die Monitorverwaltung ermöglicht die einfache Organisation von mehreren Monitoren.

Aufgaben der Monitorverwaltung :

  • Betrieb: Gemischter Betrieb von Ein- und Mehrmonitor-Systemen.
    Zum Beispiel werden in einem Leitstand drei Monitore eingesetzt, auf einem Client zwei und das Notebook des Wartungstechnikers verfügt nur über einen Monitor.
  • Bildausgabe: Freie Ausgabe eines Bildes auf beliebige Monitore und Änderung der Zuordnung Bild -> Monitor in der Runtime.
    Alle Bildtypen (z.B. AML, Menüs) und Funktionen (z.B. Bildquittierung), die diesem Bild bzw. dieser Schablone zugeordnet sind, werden automatisch übernommen.
  • Anpassung der Auflösung: Einbindung von Rechnern mit verschiedenen Auflösungen in ein Projekt.
    Zum Beispiel: Die Monitorauflösung bei der Projektierung beträgt 1680 x 1050. Die Auslösung am Zielgerät beträgt 1024 x 768. In diesem Fall passt zenondie Auflösung zwar automatisch richtig an, durch das unterschiedliche Seitenverhältnis werden aus Kreisen aber zwangsläufig Ellipsen. Mit der Monitorverwaltung ist es möglich, die Zielauflösung für die Runtime korrekt anzupassen.

Einstellungen in zenon und Windows

Die Monitorverwaltung wirkt sich auf Schablonen und Bilder in zenon aus. Es empfiehlt sich, die Größe der Schablonen auf die Größe des anzeigenden Monitors bzw. der anzeigenden Monitore anzupassen. Größere Schablonen ragen in andere Monitore hinein oder werden nicht komplett angezeigt..

Dialogboxen - auch jene in zenon - unterliegen den Windows-Einstellungen.

attention Achtung

Bei Nutzung mehrerer Projekte gilt:

  • Werden mehrere Projekte im Speicher gehalten, bestimmt das aktive Projekt die zur Verfügung stehenden Monitoreinstellungen für alle geladenen.
  • Ist das aktive Projekt ein Einzelmonitor-Projekt, kann in Mehrmonitor-Projekten kein Zielmonitor ausgewählt werden.
  • Bei Mehrprojektverwaltung gelten In der Runtime immer die Einstellungen des Integrationsprojektes.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Konzept und Voraussetzungen

Projektieren im Editor

Funktionen der Monitorverwaltung

Beispielkonfiguration

Monitorverwaltung zur Runtime


Konzept und Voraussetzungen

Handbuch -> Monitorverwaltung -> Konzept und Voraussetzungen

Mit der Monitorverwaltung werden Bilder auf virtuellen Monitoren aufgeschaltet. Virtuelle Monitore werden real vorhandenen Monitoren zugeordnet. Diese Zuordnung kann über Monitorprofile individuell eingestellt werden. Damit lassen sich Projekte für unterschiedliche Konfigurationen individualisieren.

Die Monitorverwaltung beruht auf:

  • Fixierung der Default-Auflösung für ein Projekt.
    Zum Beispiel 2048*768 bei zwei Monitoren mit einer Auflösung von je 1024*768.
  • Benennung real vorhandener Monitore.
  • Definition von virtuellen Monitoren, die den realen Monitoren zugeordnet werden.
    Virtuelle Monitore ermöglichen es z.B., ein 3-Monitor-System (3 reale und 3 virtuelle Monitore) auf einem 1-Monitor-System (1 realer und 3 virtuelle Monitore) darzustellen.
  • Möglichkeit, im Editor und zur Runtime die Zuordnung virtueller auf reale Monitore zu ändern.
    Damit kann zum Beispiel ein virtueller Monitor statt auf den projektierten auf einen anderen realen Monitor verschoben werden.
  • Übersichtsfenster mit einer Schablonen- oder Monitorübersicht.
    Dieses ermöglicht durch Auswahl der gewünschten Bildfläche im Fenster die schnelle Monitoranwahl. Dies kann auch über optional einblendbare Bildlaufleisten erfolgen.

Ablauf

Bei Nutzung mehrerer Monitore:

  • werden Bilder bei der Bildumschaltung virtuellen Monitoren zugewiesen
  • virtuelle Monitore können beliebig auf real vorhandene Monitore rangiert werden

Damit kann ein Projekt auch auf unterschiedlichen Systemen mit unterschiedlicher Monitorzahl ohne Umprojektierung korrekt angezeigt werden

Projektierung

Die Monitorverwaltung hat unterschiedliche Auswirkungen auf:

  • neue Projekte
  • bestehende Projekte

Empfehlung Arbeitsablauf: Erstellen Sie bei einem neuen Projekt erst die Monitorverwaltung, bevor Sie Schablonen und Bilder definieren.

attention Achtung

Bildschirmauflösung: Benutzen Sie für optimale Darstellung zur Runtime die Standardeinstellung des Betriebssystems (100%).

Noch in diesem Kapitel

Voraussetzung für die Runtime

Neues Projekt

Bestehendes Projekt anpassen


Voraussetzung für die Runtime

Handbuch -> Monitorverwaltung -> Konzept und Voraussetzungen -> Voraussetzung für die Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit die Monitorverwaltung auf einem Mehrmonitorsystem richtig arbeitet, muss in der zenon6.ini die tatsächlich vorhandene Monitorauflösung eingestellt werden.

Ausnahme: Beim zenon Webclient sind diese Einstellungen nicht notwendig.

INI-Einträge

Folgende INI-Einträge sind im Bereich[DEFAULT] erforderlich:

Eintrag | Bedeutung
[DEFAULT] | Abschnitt, in dem der Eintrag erfolgt.
SCREENPROFILE= | Ausgewähltes Monitorprofil für diesen Rechner. Name der Konfiguration. Zum Beispiel: ScreenProfile=Standard Wird am Projektierungsrechner über die Konfiguration der allgemeinen Einstellungen festgelegt. Auf anderen Rechnern muss es eventuell über einen manuellen Eintrag in der zenon6.ini definiert werden.
RT_CXMAINFRAME= | Breite der Auflösung aller Monitore minus 1 Pixel. Zum Beispiel bei zwei Bildschirmen mit je 1280 Pixel Breite: RT_CXMAINFRAME=2559
RT_CYMAINFRAME= | Höhe der Auflösung aller Monitore minus 1 Pixel. Zum Beispiel bei Bildschirmhöhe von 1024 Pixel: RT_CYMAINFRAME=1023 Achtung: Ist die Windows Taskleiste eingeblendet, muss deren Höhe einbezogen werden und entsprechend mehr Pixel müssen subtrahiert werden.

Achtung: Die Angaben müssen um 1 Pixel niedriger sein als die tatsächliche Monitorgröße, da bei 0 zu zählen begonnen wird.

attention Achtung

Folgende Konfigurationen können dazu führen, dass nichts dargestellt wird oder nur der erste Bildschirm Bilder anzeigt:

  • Wenn die in der INI definierten Werte größer als die tatsächlich zur Verfügung stehende Fläche ist, dann wird unter Umständen nichts dargestellt.
    Lösung: Angaben in der INI korrigieren.
  • Wenn die Windows Taskleiste fix dargestellt wird, werden Bider eventuell nur am ersten Monitor dargestellt.
    Lösung: Windows Taskleiste auf Taskleiste automatisch ausblenden stellen.
    Oder: RT_CYMAINFRAME so definieren, dass nicht in die Taskleiste hineingezeichnet wird, z.B. RT_CYMAINFRAME=1023 statt 1280.


Neues Projekt

Handbuch -> Monitorverwaltung -> Konzept und Voraussetzungen -> Neues Projekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Definieren Sie die Bildschirmauflösung vor Beginn der Projektierung. Diese Einstellung sollte später nicht mehr verändert werden, da dies zu Verzerrungen der Bilder führen kann, wenn die Relation Breite/Höhe der Auflösungen nicht übereinstimmt.

Wenn ein neues Projekt erstellt wird, wird die Bildschirmauflösung für die Monitorverwaltung automatisch an die aktuelle Bildschirmauflösung angepasst. Soll ein Projekt auf einem Rechner mit einer anderen Auflösung laufen, passen Sie die Einstellungen vor Beginn der Projektierung entsprechend an.

Um Bilder verschiedenen realen Monitoren in unterschiedlicher Kombination zuordnen zu können, definieren Sie entsprechend viele virtuelle Monitore.


Bestehendes Projekt anpassen

Handbuch -> Monitorverwaltung -> Konzept und Voraussetzungen -> Bestehendes Projekt anpassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Änderungen der Monitorverwaltung in bestehenden Projekten, müssen alle Bildumschaltungen angepasst werden.

Die Monitorverwaltung kann dennoch auch bestehenden Projekten Vorteile bringen. Zum Beispiel:

  • Vermeidung von doppelten Bildern für unterschiedliche Auflösungen.
  • Einbindung von Rechnern mit unterschiedlicher Anzahl von Monitoren in ein Netzwerkprojekt.
    Um den Änderungsaufwand gering zu halten, arbeiten Sie bei der Einbindung von Rechnern mit geringerer Monitoranzahl am besten mit einem Übersichtsfenster. Damit können alle Monitore schnell angewählt werden.


Projektieren im Editor

Handbuch -> Monitorverwaltung -> Projektieren im Editor

Im Editor definieren Sie die Verwaltung für:

  • neue Projekte
  • bestehende Projekte

Um die Monitorverwaltung zu konfigurieren:

  1. navigieren Sie in den Projekteigenschaften zum Knoten Grafische Ausprägung

    Interne ID: Projektieren im Editor

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie in der Untergruppe Runtime allgemein in die Eigenschaft Monitorverwaltung

    Interne ID: Projektieren im Editor

    Monitorverwaltung

    Der Konfigurationsdialog für die Monitorverwaltung wird geöffnet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projektieren im Editor

    Runtime allgemein

    Enthält Einstellungen zur Runtime.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Konfigurationsdialog wird geöffnet
  4. definieren Sie die allgemeinen Einstellungen
  5. definieren Sie die individuelle Einstellungen für unterschiedliche Profile

attention Achtung

Die Koordinaten von Schablonen beziehen sich bei absoluter Positionierung immer auf die obere linke Ecke des Hauptbildschirms. Dieser muss der äußerst linke Bildschirm im System sein.

Eine Beispiel für die Konfiguration eines Projekts mit unterschiedlichen Monitoreinstellungen finden Sie im Abschnitt Beispielkonfiguration.

Noch in diesem Kapitel

Allgemeine Einstellungen

Individuelle Einstellungen


Allgemeine Einstellungen

Handbuch -> Monitorverwaltung -> Projektieren im Editor -> Allgemeine Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dialog zur Konfiguration der allgemeinen Monitoreigenschaften:

Eigenschaft | Beschreibung
Reale Monitore | Anzahl der real vorhandenen Monitore (Hardware). Die Einstellungen der Monitore definieren Sie auf den Profilseiten. (Siehe Abschnitte Individuelle Einstellungen undProjektierung Reale Monitore).
Anzahl | Zeigt Zahl aktuell definierter realer Monitore an.
Virtuelle Monitore | Anzahl der virtuellen Monitore. Die Einstellungen der Monitore definieren Sie auf den Profilseiten. (Siehe Abschnitte Individuelle Einstellungen und Projektierung Virtuelle Monitore).
Anzahl | Zeigt Zahl aktuell definierter virtueller Monitore als V_00 bis V_nn an. Der erste reale Monitor wird von zenon als Standardmonitor konfiguriert.
Ändern | Klick auf Schaltfläche öffnet Dialog zur Festlegung der Anzahl virtueller Monitore.
Namen | Liste der Namen der virtuellen Monitore.
Umbenennen... | Öffnet Dialog zur Benennung virtueller Monitore. Freie Texteingabe mit maximal 15 Zeichen.
Monitorprofile | Definiert zentral Monitorprofile für die Runtime. Jedes Monitorprofil erhält eine eigene Registerkarte zur individuellen Konfiguration. Die Festlegung von Monitorprofilen für andere Rechner muss eventuell manuelle über einen INI-Eintrag erfolgen.
Kopieren... | Legt ein neues Profil auf Basis des selektierten Profils an und öffnet den Dialog zur Vergabe eines Namens.
Umbenennen... | Öffnet den Dialog zum Bennen eines Profils.
Löschen... | Löscht das ausgewählte Profil ohne Sicherheitsabfrage.
Monitorprofil, das auf diesem Rechner von der Runtime geladen wird | Öffnet die Dropdownliste zur Auswahl des Profils, das zur Runtime benutzt werden soll. Hinweis: Auf einem Remote-Rechner muss das Profil eventuell manuell in die Datei zenon6.ini eingetragen werden.
Bildschirmauflösung | Auflösung, in der das Projekt in der Runtime laufen wird. (Summe aller Bildschirme.) Tipp: Legen Sie diese Einstellung vor dem Beginn der Projektierung fest. Spätere Veränderungen können zu Verzerrungen in der Darstellung führen, wenn die Relation Breite/Höhe der Auflösungen nicht übereinstimmt! Standard: Auflösung des aktuellen Rechners.
Von aktuellem Bildschirm übernehmen | Übernimmt die Auflösung des aktuell aktiven Bildschirms als Auflösung für das Monitorprofil.
OK | Übernimmt Änderungen und schließt Dialog.
Abbrechen | Verwirft Änderungen und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

attention Achtung

Der erste virtuelle Monitor wird in zenon als Standardmonitor benutzt.

Monitorprofil auf Runtimerechner festlegen

Wenn Sie auf einem PC nur die Runtime, nicht aber den Editor installiert haben, können Sie das gewünschte Monitorprofil folgendermaßen festlegen:

  1. Öffnen Sie die Datei zenon6.ini mit einem Texteditor
  2. navigieren Sie zum Abschnitt [DEFAULT]
  3. fügen Sie folgenden Eintrag ein:
    ScreenProfile=Name des Monitorprofils
  4. speichern Sie die Datei und schließen Sie den Texteditor

info Info

Am zenon Webclient wird standardmäßig immer das Profil Standard geladen. Sie können aber über den Eintrag SCREENPROFILE= in der zenon6.ini ein anderes Monitorprofil vorgeben.


Individuelle Einstellungen

Handbuch -> Monitorverwaltung -> Projektieren im Editor -> Individuelle Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jedes Monitorprofil wird in der Konfiguration durch eine eigene Registerkarte repräsentiert. Hier legen Sie die Einstellungen für reale und virtuelle Monitore sowie das Verhalten zur Runtime fest.

Eigenschaft | Beschreibung
Online-Auswahlmenü | Verhalten des Online-Auswahlmenüs zur Runtime.
Online-Auswahlmenü anzeigen | Aktiv: Menü wird zur Runtime beim Bildwechsel aufgeschalten und bietet die Monitore an, für die die Eigenschaft Online-Auswahlmenü aktiviert wurde.
Anzeigedauer | Zeit in Sekunden während der das Online-Auswahlmenü aufgeschalten bleibt.
Beschriftung für Schaltfläche "Abbrechen" ändern | Aktiv: Schaltfläche, mit der das Online-Auswahlmenü geschlossen werden kann, wird wird zur Runtime angezeigt. Beschriftung der Schaltfläche kann beliebig geändert werden. = % zeigt die verbleibenden Sekunden bis zum automatischen Abbruch an.
ESC-Taste schließt Auswahlmenü | Aktiv: Das Online-Auswahlmenü kann auch mit der Taste Esc geschlossen werden.
Erscheinungsbild der Runtime | Definiert Anzeigeoptionen zur Runtime
Anzeige an Bildschirmauflösung anpassen | Aktiv: Die Projektauflösung wird an die Monitorauflösung des aktuellen Rechners angepasst. Inaktiv: die Auflösung wird für das Projekt fixiert, d.h. es erfolgt keine Anpassung des Projektes an die verfügbare Monitorauflösung.
Titelleiste bei Anpassung berücksichtigen | Aktiv: Die Titelhöhe wird im Schabloneneditor und in der Runtime berücksichtigt. Diese Eigenschaft ist aus Kompatibilitätsgründen vorhanden und wird normalerweise nicht benötigt.
Hauptmenü bei Anpassung berücksichtigen | Aktiv: Die Menühöhe wird im Schabloneneditor und in der Runtime berücksichtigt. Diese Eigenschaft ist aus Kompatibilitätsgründen vorhanden und wird normalerweise nicht benötigt.
Bildlaufleisten anzeigen | Aktiv: Zur Runtime werden Bildlaufleisten angezeigt. Ermöglicht Navigation in Bildern, die die Monitorgröße übersteigen.
Reale Monitore | Liste mit allen realen Monitoren und den ihnen zugewiesenen Eigenschaften.
Ändern | Öffnet den Dialog zum Definieren der individuellen Eigenschaften des selektierten realen Monitors.
Virtuelle Monitore | Liste mit allen virtuellen Monitoren und den ihnen zugewiesenen Eigenschaften. Bildumschaltungen beziehen sich auf virtuelle Monitore. Virtuelle monitore werden zur Runtime realen Monitoren zugewiesen.
Ändern | Öffnet den Dialog zum Definieren der individuellen Eigenschaften des selektierten virtuellen Monitors.

Noch in diesem Kapitel

Projektierung Reale Monitore

Projektierung Virtuelle Monitore


Projektierung Reale Monitore

Handbuch -> Monitorverwaltung -> Projektieren im Editor -> Individuelle Einstellungen -> Projektierung Reale Monitore

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klick auf Schaltfläche Ändern im Abschnitt Reale Monitore in der Registerkarte für die individuelle Einstellung eines Monitorprofils öffnet den Dialog zur Konfiguration realer Monitore.

Parameter | Beschreibung
Name | Name das Monitors. Freie Texteingabe mit maximal 15 Zeichen.
Position | Beschreibt die Position und Auflösung des Monitors. Z.B.: Monitor links: 0/0/1680/1050 Monitor rechts: 1680/0/3360/1050
Monitor existiert nicht, daher zuordnen zu | Aktiv: Ermöglicht in Dropdownliste die Auswahl eines anderen realen Monitors, dem dieser zugeordnet wird, zum Beispiel, weil er aktuell nicht mit dem Rechner verbunden ist. Zur Runtime wird dann der Monitor auf dem zugewiesenen angezeigt. Bildlaufleisten ermöglichen das Scrollen zwischen beiden Monitorbildern.
Im Online-Auswahlmenü anzeigen | Aktiv: Zur Runtime wird dieser Monitor bei jeder Bildumschaltung, die eine individuelle Auswahl des Monitors ermöglicht, im Menü angeboten.


Projektierung Virtuelle Monitore

Handbuch -> Monitorverwaltung -> Projektieren im Editor -> Individuelle Einstellungen -> Projektierung Virtuelle Monitore

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klick auf Schaltfläche Ändern im Abschnitt Virtuelle Monitore in der Registerkarte für die individuelle Einstellung eines Monitorprofils öffnet den Dialog zur Konfiguration virtueller Monitore.

Parameter

Beschreibung

Name

Anzeige des Namens. Dieser kann in der Registerkarte Allgemeine Einstellungen geändert werden.

Zuordnung einstellen

Einstellungen für die Zuordnung des Monitors.

Im Online -Auswahlmenü anzeigen

Aktiv: zur Runtime wird bei jeder Bildaufschaltung, die diesem Monitor zugeordnet wurde, das Menü zur Auswahl eines realen Monitor angeboten.

Zuordnen zu realem Monitor

Ordnet den virtuellen Monitor einem realen Monitor fix zu. Zur Runtime kann diese Zuordnung über die Funktion Monitor zuordnen geändert werden.

Interne ID: Projektierung Virtuelle Monitore

Monitor zuordnen

Diese Funktion weist einem ausgewählten virtuellen Monitor einen ausgewählten realen Monitor zu. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Funktionen der Monitorverwaltung

Handbuch -> Monitorverwaltung -> Funktionen der Monitorverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über zenon Funktionen kann die Monitorverwaltung zur Runtime gesteuert werden.

Zur Verfügung stehen:

  • Einstellungen bei der Bildumschaltung: Der Dialog für die Bildauswahl wird um Einstellungen für die Monitorzuordnung erweitert.
  • Monitor zuordnen: Ermöglicht es, einen virtuellen Monitor zur Runtime einem realen Monitor zuzuordnen.
  • Übersichtsfenster anzeigen: Schaltet zur Runtime ein Übersichtsfenster auf oder schließt es. Das Fenster zeigt alle projektieren realen Monitore oder Schablonen an und ermöglicht das schnelle Auswählen und Umschalten.

Einstellungen für die Monitorauswahl stehen auch zur Verfügung für die Funktionen:

  • Fokus auf Schablone setzen
  • Schablone schließen
  • Bild schließen

Noch in diesem Kapitel

Einstellungen bei Bildumschaltung

Monitor zuordnen

Übersichtsfenster anzeigen


Einstellungen bei Bildumschaltung

Handbuch -> Monitorverwaltung -> Funktionen der Monitorverwaltung -> Einstellungen bei Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sobald die Monitorverwaltung auf mehr als einen Monitor konfiguriert wird, stehen bei der Bildumschaltung im Auswahldialog der Bilder zusätzliche Optionen für die die Auswahl des Monitors zur Verfügung, auf dem das Bild dargestellt werden soll:

Parameter

Beschreibung

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält alle in der Monitorverwaltung definierten virtuellen Monitore plus den Eintrag aktueller Monitor.

Virtueller Monitor: Das Bild wird auf dem Bildschirm, der mit dem gewählten virtuellen Monitor verknüpft ist, aufgeschaltet.

Wurde dem virtuellen Monitor in der Konfiguration kein realer Monitor zugewiesen sondern die Option Online-Auswahlmenü anzeigen, dann wird zur Runtime ein Auswahlfenster für die Wahl eines realen Monitors angeboten.

Aktueller Monitor: Öffnet das Bild immer auf dem Monitor, von dem der Aufruf kommt. Zum Beispiel:
Der Button für das Öffnen der AML wird auf dem linken Monitor gedrückt, dann wird die AML auf dem linken Monitor aufgeschaltet. Wird der Button für die Aufschaltung der AML auf dem rechten Monitor gedrückt, dann wird die AML rechts aufgeschaltet,

In der Funktionsübersicht wird bei der Funktion in Klammer angezeigt, auf welchem Monitor das Bild angezeigt wird.

Zum Beispiel:

START (V_00) bedeutet: Die Umschaltung erfolgt auf das Bild START und dieses wird am virtuellen Monitor V_00 angezeigt.
REL bedeutet Anzeige auf dem aktuellen Monitor.

Online-Auswahlmenü

Wenn in der Runtime ein Funktion Bildumschaltung mit aktiver Option Online-Auswahlmenü anzeigen ausgeführt wird, dann wird vor dem Ausführen der Funktion ein Menü zur Monitorauswahl aufgeschaltet. Die Inhalte des Menüs und die Anzeigedauer werden in der Monitorkonfiguration festgelegt.


Monitor zuordnen

Handbuch -> Monitorverwaltung -> Funktionen der Monitorverwaltung -> Monitor zuordnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktion Monitor zuordnen können virtuelle Monitore zur Runtime realen Monitoren zugeordnet werden, unabhängig von der projektierten Zuweisung.

Interne ID: Monitor zuordnen

Monitor zuordnen

Diese Funktion weist einem ausgewählten virtuellen Monitor einen ausgewählten realen Monitor zu. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. navigieren Sie zum Knoten Bilder

    Interne ID: Monitor zuordnen

    Bilder

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

    Mehr im Online-Handbuch

  3. wählen Sie die Funktion Monitor zuordnen
  4. der Dialog zur Zuordnung eines virtuellen zu einem realen Monitors wird geöffnet
  5. erstellen Sie eine Zuordnung
  6. schließen Sie den Dialog mit Klick auf OK
  7. weisen Sie die Funktion einem Button zu

Dialog Monitorzuordnung

Parameter | Beschreibung
Name | Auswahl des virtuellen Monitors aus Dropdownliste. Alle in der Monitorverwaltung konfigurierten virtuellen Monitore werden aufgelistet.
Zuordnung einstellen | Auswahl der Zuordnung über Radiobuttons:
Im Online-Auswahlmenü anzeigen | Schaltet zur Runtime einen Dialog zur Auswahl des gewünschten realen Monitors auf.
Zuordnen zu realem Monitor | Ordnet virtuellen Monitor einem realen Monitor zu. Monitor wird aus Dropdownliste ausgewählt. Liste enthält alle in der Monitorverwaltung konfigurierten realen Monitore.
OK | Übernimmt Einstellungen, schließt Dialog und erstellt Funktion mit Zuordnung.
Abbrechen | Verwirft Einstellungen, schließt Dialog und erstellt Funktion ohne konkrete Zuordnung.
Hilfe | Öffnet Online-Hilfe.

Die Funktionen werden in der Detailansicht mit dem Ziel der Zuweisung angezeigt.

Zum Beispiel:

  • V_00,(ONLINE): Zuordnung des virtuellen Monitors V_00 zu einem realen Monitor erfolgt zur Runtime über das Online-Auswahlmenü.
  • ???,???: Zuordnungsdialog wurde abgebrochen, es wird keine Funktion ausgeführt.
  • V_00,Left screen: Der virtuelle Monitor V_00 wird dem realen Monitor Left screen zugeordnet.


Übersichtsfenster anzeigen

Handbuch -> Monitorverwaltung -> Funktionen der Monitorverwaltung -> Übersichtsfenster anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Übersichtsfenster anzeigen blendet in der Runtime ein Übersichtsfenster ein, das in einem Mehr-Monitor-System die vorhandenen reale Monitore oder Schablonen anzeigt. Per Mausklick kann ein Monitor bzw. eine Schablone angesteuert werden.

Interne ID: Übersichtsfenster anzeigen

Übersichtsfenster anzeigen

Diese Funktion öffnet ein Übersichtsfenster, sodass man auf einem Ein-Monitor-System ein Mehr-Monitor-System simulieren kann.

Mehr im Online-Handbuch

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. navigieren Sie zum Knoten Bilder

    Interne ID: Übersichtsfenster anzeigen

    Bilder

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

    Mehr im Online-Handbuch

  3. wählen Sie die Funktion Übersichtsfenster anzeigen
  4. der Dialog zur Konfiguration des Übersichtsfensters wird geöffnet
  5. konfigurieren Sie das Übersichtsfenster
  6. schließen Sie den Dialog mit Klick auf OK
  7. weisen Sie die Funktion einem Button zu

Dialog Übersichtsfenster anzeigen

Parameter

Beschreibung

Einstellungen

Die Funktion kann das Übersichtsfenster entweder nur öffnen, nur schließen oder toggeln. Auswahl erfolgt über Radiobuttons:

Anzeigen

Aktiv: Übersichtsfenster wird aufgeschaltet.

Toggeln

Aktiv: Anzeige wird umgeschaltet zwischen geöffnet und geschlossen.

Schließen

Aktiv: Übersichtsfenster wird geschlossen.

Anzeige der

Auswahl der Anzeige im Übersichtsfenster. Es werden entweder Schablonen oder Monitore angezeigt.

Schablonen

Aktiv: Das Übersichtsfenster teilt den Bildschirm in Schablonen ein.

Monitore

Aktiv: Das Übersichtsfenster teilt den Bildschirm in Monitore ein.

Position

Position des Übersichtsfensters auf dem Bildschirm, berechnet in Pixel vom linken oberen Rand aus für:

  • oben
  • unten
  • links
  • rechts

Fenster-Style

mit Titel

Aktiv: Das Übersichtsfenster hat eine Windows-Titelleiste.

System Menü

Aktiv: Bei aktiver Titelleiste wird das Windows-Systemmenü eingeblendet.

mit Rahmen

Aktiv: Übersichtsfenster wird mit Rahmen angezeigt. Fenstergröße kann zur Runtime durch Ziehen am Rahmen verändert werden. Auswahl der Rahmenstärke über Radiobuttons.
  • dünn

Aktiv: Dicker Rahmen.
  • dick

Aktiv: Dünner Rahmen.

Farben

Einstellung der Farben im Übersichtsfenster. Klick auf Farbe öffnet Palette.

Hintergrundfarbe

Farbe des Fensterhintergrunds.

aktuelle Ansicht

Aktuell angezeigte Schablonen/Monitore.

Rahmen

Farbe des Rahmens.

selektierte

Ausgewählte Schablonen/Monitore.

OK

Übernimmt Einstellungen, schließt Dialog und erstellt Funktion mit Zuordnung.

Abbrechen

Verwirft Einstellungen, schließt Dialog und erstellt Funktion mit Standardeinstellungen.

Hilfe

Öffnet Online-Hilfe.


Beispielkonfiguration

Handbuch -> Monitorverwaltung -> Beispielkonfiguration

In diesem Beispiel sehen Sie mögliche Konfiguration für folgende Projektanforderung:

  1. 1 Server mit 2 Monitoren mit einer Auflösung von jeweils 1680 x 1050
  2. 1 Client mit einem Monitor mit einer Auflösung von 1680 x 1050
  3. 1 Notebook für das Service-Team mit einer Auflösung von 1024 x 768

Aufgabe

Wir konfigurieren das Projekt so, dass es am Server mit 2 Bildschirmen visualisiert werden kann. Für den Client passen wir die Einstellungen so an, dass alle Ausgaben auf einem einzigen Bildschirm angezeigt werden. Und für das Service-Notebook ändern wir zusätzlich die Auflösung der Anzeige. Im Betrieb muss am betreffenden Runtime-Rechner nur das entsprechende Monitorprofil gewählt werden, um die korrekte Anzeige zu erhalten.

Konfiguration starten

  1. Die Grundkonfiguration erfolgt in der Monitorkonfiguration:
    navigieren Sie zu Projekteigenschaften -> Grafische Ausprägung -> Runtime allgemein

    Interne ID: Beispielkonfiguration

    Runtime allgemein

    Enthält Einstellungen zur Runtime.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Beispielkonfiguration

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie auf die Eigenschaft Monitorverwaltung

    Interne ID: Beispielkonfiguration

    Monitorverwaltung

    Der Konfigurationsdialog für die Monitorverwaltung wird geöffnet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog für die Monitorkonfiguration wird geöffnet
  4. konfigurieren Sie zuerst die allgemeinen Einstellungen
  5. konfigurieren Sie dann die individuellen Einstellungen für:
    1. den Server mit 2 Monitoren
    2. den Client mit einem Monitor
    3. das Notebook für das Service-Team

Noch in diesem Kapitel

Konfiguration allgemein

Konfiguration Server mit 2 Monitoren

Konfiguration Client mit einem Monitor

Konfiguration Notebook Service-Team

Weitere Konfiguration


Konfiguration allgemein

Handbuch -> Monitorverwaltung -> Beispielkonfiguration -> Konfiguration allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Konfiguration werden zuerst:

  • allgemeine Einstellungen festgelegt, wie Anzahl der virtuellen und realen Monitore
  • Profile für die 3 unterschiedlichen Konfigurationen angelegt

Allgemeine Einstellungen

Monitore

Für unser Beispiel definieren wir:

  • 2 reale Monitore
  • 3 virtuelle Monitore:
    • je einen für Prozessbilder
    • einen für die beliebige Aufschaltung der Menüleiste: Damit können wir immer bestimmen, ob die Menüleiste rechts oder links aufgeschaltet wird, ohne die Prozessbilder zu beeinflussen.

Zur Erinnerung: Virtuelle Monitore sind Ziel der Bildumschaltungen. Diese werden zur Runtime realen Monitoren zugewiesen. Man hat damit die Möglichkeit, zwischen den realen und den virtuellen Monitoren zu rangieren. Ist zum Beispiel der zweite Monitor nicht vorhanden, wie beim Notebook, kann die Ausgabe der Bilder einfach auf den linken Monitor geleitet werden, ohne die Projektierung der Funktionen zu ändern.

Auflösung

Ein wichtiger Faktor ist auch die eingestellte Auflösung. Dies ist die Bezugsgröße für die Anpassung. Sie wird vor Beginn der Projektierung einmalig eingestellt und sollte nachträglich nicht mehr verändert werden. Wird diese Einstellung nachträglich geändert, so werden alle Koordinaten der Elemente in den Bildern neu berechnet.

Wir tragen unsere Zielauflösung von 1680 x 1050 ein.

Monitorprofile

Für jede Konfiguration unseres Beispiels legen wir ein eigenes Profil an. In unserem Beispiel:

  • Server 2 Mon
  • Client 1 Mon
  • Notebook small

Dazu:

  1. markieren Sie das Profil Standard
  2. klicken Sie auf kopieren
  3. der Dialog zum Umbenennen wird geöffnet
  4. geben Sie den neuen Namen ein (die Länge ist auf 15 Zeichen begrenzt)
  5. klicken Sie auf OK
  6. wiederholen Sie den Vorgang für alle weiteren Profile

Jedes Profil erhält in der Monitorkonfiguration eine eigene Registerkarte für die individuelle Konfiguration.

Wir beginnen mit der Registerkarte Server 2 Mon.


Konfiguration Server mit 2 Monitoren

Handbuch -> Monitorverwaltung -> Beispielkonfiguration -> Konfiguration Server mit 2 Monitoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die erste Konfiguration bezieht sich auf unseren Server mit 2 Monitoren.

Wir werden konfigurieren:

  • das Online-Auswahlmenü
  • das Erscheinungsbild zur Runtime
  • die realen Monitore
  • die virtuellen Monitore

Online-Auswahlmenü

Das Online-Auswahlmenü ermöglicht es, zur Runtime auszuwählen, auf welchem realen Monitor ein Bild aufgeschaltet wird. Dazu muss:

  • die Option Online-Auswahlmenü aktiviert sein
  • in der Zuweisung des virtuellen Monitors die Option Im Online-Auswahlmenü anzeigen gewählt worden sein
    oder

    eine Funktion Monitor zuordnen projektiert worden sein

Für unser Beispiel:

  • aktivieren Sie die Option
  • wählen Sie eine Anzeigedauer von 10 Sekunden: wurde bis dahin keine Aktion gesetzt, wird das Menü wieder ausgeblendet
  • aktivieren Sie die Option Beschriftung: damit wird zur Runtime im Menü eine Schaltfläche Abbrechen angeboten
  • beschriften Sie die Schaltfläche mit Cancel = %: im Menü wird damit die verbleibende Zeit bis zum Abbruch angezeigt
  • aktivieren Sie die Option Esc-Taste schließt Auswahlmenü: damit wird das Menü zur Runtime auch Per Druck auf die Taste Esc geschlossen

Zur Runtime wird dann bei einer Bildumschaltung auf einen virtuellen Monitor mit Online-Auswahlmenü das Menü angezeigt:

Zur Wahl stehen die realen Monitore M_00 und M_01. Bis zum Abbruch sind noch 10 Sekunden Zeit für eine Wahl. Klick auf Cancel oder Druck auf die Taste Esc würde das Menü sofort beenden.

Bildschirmeinstellungen zur Runtime

Für die darstellung des Bildschirms zur Runtime:

  • deaktivieren Sie die Option Anzeige an Bildschirmauflösung anpassen: damit bleibt die Anzeige immer in der projektierten Größe. (Bei aktiver Option würde die Anzeige an die aktuelle Auflösung angepasst werden.)
  • aktivieren Sie die Option Bildlaufleisten anzeigen: damit werden zur Runtime Bildlaufleisten angeboten, die das Scrollen im Bild ermöglichen

Konfiguration reale Monitore

Am Server stehen zwei Monitore zur Verfügung. Die beiden realen Monitore aus dem Beispielprojekt werden entsprechend konfiguriert.

Der zweite Monitor zum Beispiel erhält die entsprechenden Koordinaten, um an horizontal rechts an den ersten Monitor anzuschließen.

Der Name kann für jede Konfiguration extra eingestellt werden. Um die Monitore zu konfigurieren:

  1. öffnen Sie der Reihe nach jeden der beiden Monitore mit Klick auf die Schaltfläche Ändern
  2. vergeben Sie einen Namen, in unserem Beispiel einfach M_00 und M_01
  3. deaktivieren Sie die Option Monitor existiert nicht ... (diese benötigen wir in den anderen Konfigurationen)
  4. tragen Sie die Koordinaten ein,
    gerechnet wird von der linken obern Ecke des linken Monitors
  5. aktivieren Sie die Option Im Online-Auswahlmenü anzeigen, damit der Monitor für die Online-Auswahl zur Runtime zur Verfügung steht

Konfiguration virtuelle Monitore

In dieser Konfiguration werden die virtuellen Monitore den realen zugeordnet.

Zur Erinnerung: Bildumschaltungen verweisen auf virtuelle Monitore. Die Zuweisung der virtuellen Monitore entscheidet, auf welchem realen Monitor das Bild wirklich aufgeschaltet wird.

In unserem Beispiel stehen drei virtuelle Monitore zur Verfügung. Die beiden ersten werden jeweils einem realen Monitor zugewiesen. Der dritte virtuelle Monitor soll ermöglichen, die Menüleiste beliebig aufzuschalten. Dieser wird keinem realem Monitor zugewiesen, sondern diese Zuweisung soll im Online-Auswahlmenü angeboten werden.

Um die ersten beiden virtuellen Monitore zuzuweisen:

  1. öffnen Sie der Reihe nach jeden der beiden Monitore mit Klick auf die Schaltfläche Ändern
  2. die Namen werden nur angezeigt, sie sind für alle Profile gleich und können nur global in der Registerkarte Allgemein geändert werden
  3. wählen Sie Zuordnung zu realem Monitor
  4. wählen Sie aus der Dropdownliste den gewünschten realen Monitor
    • M_00 für Monitor left
    • M_01 für Monitor right

Die Konfiguration des dritten virtuellen Monitor erfolgt analog.

Unterschied: statt Zuordnen zu realem Monitor wählen Sie die Option Im Online-Auswahlmenü anzeigen.

Damit ist das Profil für den Server mit 2 Monitoren fertig konfiguriert.

Wechseln Sie jetzt zur Registerkarte Client 1 Mon.


Konfiguration Client mit einem Monitor

Handbuch -> Monitorverwaltung -> Beispielkonfiguration -> Konfiguration Client mit einem Monitor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration für den Client mit einem Monitor entspricht im Wesentlichen der Konfiguration des Servers. Allerdings steht hier nur ein Bildschirm zur Verfügung. Damit ergeben sich zwei wesentliche Unterschiede:

  1. der zweite reale Monitor muss auf den ersten gemappt werden
  2. das Online-Auswahlmenü für die Menüleiste ist überflüssig, sie wird direkt zugewiesen

Bei den realen Monitoren:

  1. öffnen Sie die Konfiguration des Monitore M_01
  2. aktivieren Sie die Option Monitor existiert nicht, daher zuordnen zu
  3. wählen Sie aus der Dropdownliste M_00

Das Online-Auswahlmenü wird zur Runtime nicht benötigt, Sie können die Optionen aber aktiv lassen.

Bei den virtuellen Monitoren:

  1. öffnen Sie die Konfiguration des Monitors Menu bar
  2. aktivieren Sie die Option Zuordnen zu realem Monitor
  3. wählen Sie aus der Dropdownliste M_00

Die gesamte Konfiguration für Client 1 Mon sieht nun so aus:

In unserem Beispiel fehlt nun noch die Konfiguration des Notebooks. Wechseln Sie dazu zur Registerkarte Notebook small.


Konfiguration Notebook Service-Team

Handbuch -> Monitorverwaltung -> Beispielkonfiguration -> Konfiguration Notebook Service-Team

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration des Notebooks für das service-team enstpricht der Konfiguration des Client-rechners mit einem Monitor. Allerdings unterscheidet sich die Auflösung. Diese muss angepasst werden. Dazu:

  1. öffnen Sie die Konfiguration des realen Monitors M_00
  2. geben Sie die entsprechenden Koordinaten ein,
    in unserem Beispiel: 0/0/1024/768

Die Auflösung wurde nun an die reale Auslösung des Notebooks angepasst, der Monitor M_01 wird wie beim Client-Rechner auf den Monitor M_00 umgeleitet. Zur Laufzeit bekommen Sie Bildlaufleisten, mit denen Sie die Anzeige scrollen können.

Alle anderen Einstellungen entsprechen denen des Client Rechners:

Beenden Sie die Konfiguration mit Klick auf die Schaltfläche OK.


Weitere Konfiguration

Handbuch -> Monitorverwaltung -> Beispielkonfiguration -> Weitere Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Projekt müssen Sie in der Folge noch:

  • bei Bildumschaltungen wählen, auf welchem virtuellen Monitor das Bild aufgeschaltet werden soll
  • auf den unterschiedlichen Rechnern das jeweils zu nutzender Monitorprofil festlegen (für den Projektierungsrechner wählen Sie das Profil in der Monitorkonfiguration)
  • bei Funktionen wie Fokus auf Schablone setzen, Schablone schließen oder Bild schließen entscheiden, für welche Monitore die Aktion gilt
  • eventuell eine Funktion Monitor zuordnen projektieren, um zur Runtime virtuelle Monitore unabhängig von der Ausgangskonfiguration realen Monitoren zuweisen zu können
  • ein Übersichtsfenster projektieren, um zur Runtime bequem navigieren zu können


Monitorverwaltung zur Runtime

Handbuch -> Monitorverwaltung -> Monitorverwaltung zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime stehen verschiedenen Möglichkeiten zur Verfügung,

  • Monitore zu wählen
    und
  • zwischen Monitoren zu navigieren

info Info

Wird die Runtime über eine Remote-Desktop-Verbindung gestartet, dann wird die Auflösung des Remote-Rechners verwendet. Die Auflösung unterscheidet sich damit möglicherweise von der projektierten, womit Verschiebungen in der Darstellung auftreten können.

Die Auflösung des entfernten Monitors kann auch per INI Datei festgelegt werden (siehe Abschnitt Monitorprofil auf Runtimerechner festlegen im Kapitel Allgemeine Einstellungen).

Noch in diesem Kapitel

Monitorwahl zur Runtime

Navigation zur Runtime


Monitorwahl zur Runtime

Handbuch -> Monitorverwaltung -> Monitorverwaltung zur Runtime -> Monitorwahl zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime stehen verschiedenen Möglichkeiten zur Verfügung, virtuelle Monitore realen Monitoren zuzuweisen:

  • Online-Auswahlmenü bei Aufschaltung
  • Funktion Monitor zuordnen

Online-Auswahlmenü

Wenn in der Runtime ein Funktion Bildumschaltung mit aktiver Option Online-Auswahlmenü anzeigen ausgeführt wird, dann wird vor dem Ausführen der Funktion ein Menü zur Monitorauswahl aufgeschaltet. Die Inhalte des Menüs und die Anzeigedauer werden in der Monitorkonfiguration festgelegt.

Funktion Monitor zuordnen

Die Funktion Monitor zuordnen ermöglicht es, das Online-Auswahlmenü unabhängig von einer Bildumschaltung aufzurufen und virtuelle Monitore einem realen Monitor zuzuweisen.


Navigation zur Runtime

Handbuch -> Monitorverwaltung -> Monitorverwaltung zur Runtime -> Navigation zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime kann zwischen Monitoren navigiert werden über:

  • Übersichtsfenster
  • Bildlaufleisten

Übersichtsfenster

Übersichtsfenster werden als Funktion projektiert. Entweder wird für das Anzeigen und Schließen des Übersichtsfensters jeweils eine eigene Funktion erstellt oder man benutzt die Funktion Toggeln, um zwischen ein- und ausschalten des Fensters zu wechseln.

Zur Runtime wird mit Ausführen der Funktion ein Fenster eingeblendet. Dieses zeigt die komplette zur Verfügung stehende Bildschirmfläche an, unterteilt in Monitore oder in Schablonen. Für die Anzeige von Schablonen und Monitoren müssen jeweils unterschiedliche Funktionen projektiert werden.

Per Mausklick werden im Fenster Monitore oder Schablonen ausgewählt.

Bildlaufleisten

Mit Bildlaufleisten kann schnell zwischen Bildschirmen navigiert werden. Bildlaufleisten werden angezeigt, wenn:

  • in der individuellen Konfiguration des Monitorprofils die Eigenschaft Bildlaufleisten anzeigen aktiviert wurde
  • ein realer Monitor auf einen anderen realen Monitor gemappt wird


Multitouch

Handbuch -> Multitouch

Touchscreens können mit zenon auch per Multitouch-Gesten bedient werden. Multitouch muss in den Projekteigenschaft aktiviert werden. Dazu:

  1. navigieren Sie zur Gruppe Touchbedienung

    Interne ID: Multitouch

    Touchbedienung

    Eigenschaften für die Touchbedienung.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. aktivieren Sie die Eigenschaft Multitouch aktiv

    Interne ID: Multitouch

    Multitouch aktiv

    Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
    Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Projekte müssen für die Verwendung von Multitouch angepasst werden. Ein Beispielprojekt erhalten Sie bei Ihrem zenon Berater.

Noch in diesem Kapitel

Beispielprojekt

Navigation mit Multitouch im Weltbild


Beispielprojekt

Handbuch -> Multitouch -> Beispielprojekt

Dieses Beispielprojekt ist für eine Auflösung von 1920x1080 konzipiert. Es enthält :

  • Startseite
  • Navigation
  • Alarmzeile
  • Bild vom Typ Login

Startseite

Die Startseite zeigt eine Übersicht der gesamten Produktionslinie. Es sind mehrere Maschinen-Icons gleichzeitig sichtbar, zu den anderen Maschinen kann mittels Geste gescrollt werden. Tap auf ein Icon wechselt zu der gewählten Maschine. Im Bild sind noch vorhanden:

  • Alarmzeile an der Oberkante: Zeigt den letzten Alarm der gesamten Linie an. Die Alarmzeile können Sie herausziehen und bekommen dann die die gesamte Alarmmeldeliste angezeigt.
  • Login Button: Ermöglicht das Anmelden unterschiedlicher Benutzer.
  • Exit Button: Beendet die Runtime und ist nur von Benutzern mit Administratorrechten bedienbar.

Navigation

Die Navigation bildet im unteren Bildbereich mit Icons die gesamte Produktionslinie einem horizontalen Scrollbereich ab. Zusätzlich ist ein Energy-Weltbild vorhanden. Dieses wird über den unten mittig positionierten Button angewählt. Die Anwahl einer Maschine erfolgt durch Tap auf ein sichtbares Icon. In diesem Projekt kann nur die Maschine Füller ausgewählt werden. Hält man das Machinen-Icon Füller lange gedrückt, erscheint ein Glow-Effekt. Die Liste kann per Swipe-Geste gescrollt werden, ein Tap auf die scrollende Liste stoppt diese wieder.

Die Scrollgeschwindigkeit wird anhand der Beschleunigung der Drag-Bewegung unterschieden:

  • langsam: folgt dem Finger
  • schneller: eilt hinterher

Beim Aufschalten des Startbildes ist die Navigation auf das Icon Füller zentriert.

Alarmzeile

An der Oberkante des Bildschirms ist eine Alarmzeile positioniert. Diese zeigt den letzten Alarm der gesamten Linie an. Sie kann zur Alarmmeldeliste geöffnet werden.
Bedienung:

  • Öffnen:
    • Ein Tap auf die Leiste öffnet die AML bis zur Hälfte des Bildschirmes.
    • Die AML kann auch per Geste auf eine individuell gewünschte Größe herunter gezogen werden.
  • Schließen:
    • Ein Tap außerhalb der Schablone schließt die geöffnete die AML.
    • Die AML kann auch manuell wieder hinauf geschoben werden.

Login-Bild

Das Login-Bild bietet eine Gesten-basierte Anmeldung im Stil von Windows 8. Bevor eine Passworteingabe erfolgt, muss ein Benutzer mittels Tap ausgewählt werden. Anschließend kann mittels Hoovering die Passworteingabe des selektierten Benutzers starten. Zum Beispiel:

Administrator:

Wartung:

Operator:

Zusätzlich gibt es einen Logout Button, der bei Betätigung den derzeit angemeldeten Benutzer abmeldet und das Login-Bild öffnet. Das Login-Bild ist ein modaler Dialog, der den Hintergrund abdunkelt.

Noch in diesem Kapitel

Maschinenbildschirm

VSTA Code

Grundsätzliches Multitouch

FAQs


Maschinenbildschirm

Handbuch -> Multitouch -> Beispielprojekt -> Maschinenbildschirm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Maschinenbildschirm bietet die Alarmzeile mit der gleichen Funktionalität wie auf der Startseite, gefiltert auf die Maschine.

Weiters gibt es das Workspace-Konzept mit frei positionierbaren Fenstern, die bei Nichtgebrauch in einem Dock abgelegt werden. Der Workspace erstreckt sich über mehrere Bildschirme, zu denen entweder mittels Swipe-Geste, Tab-Navigation oder per Navigationsbutton gewechselt werden kann. Im unteren Bereich gibt es noch einen Freischaltbereich für Zweihandbedienung und einen Home Button. Rechts oben befindet sich eine bedienbare Anzeige für den Workspace.

Dock

Icons können aus dem Dock auf den Workspace gezogen werden, wo diese dann als Faceplate in einer definierten Grundgröße erscheinen. Ist ein Faceplate auf dem Workspace platziert, wird dessen Icon deaktiviert dargestellt. Wird ein Faceplate geschlossen, wird dessen Icon wieder aktiviert dargestellt. Tap & Hold auf ein deaktiviertes Icon lokalisiert ein offenes Faceplate und springt zu dem von ihm benützten Workspace.

Workspace

Auf jedem der vier frei personalisierbaren Workspaces können beliebig viele Faceplates personenspezifisch positioniert und skaliert werden.

  • Faceplate an den vertikalen Bildschirmrand ziehen: Nach einer Verzögerung von 2 Sekunden wird auf den nächsten Workspace gewechselt und das Faceplate kann frei positioniert werden.
  • Faceplate an den vertikalen Bildschirmrand schießen (Swipe-Geste): Das Faceplate wird auf den nächsten Workspace befördert, der aktuelle Workspace bleibt geöffnet.
  • Faceplate schließen/entfernen: Faceplate auf das Dock ziehen oder durch eine Swipe-Geste nach unten.
    Optional kann jedes Faceplate mittels des rechts oben befindlichen X Buttons geschlossen werden.

Die aufgeschalteten Faceplates, deren Position, Größe etc. werden im Benutzerprofil gespeichert. Ein Faceplate kann per Zoom/Pinch-Geste vergrößert bzw. verkleinert werden. Jedes Faceplate kann auch verschoben werden. EIn selektiertes Faceplate tritt mittels Z-Order-Manipulation in den Vordergrund, bleibt aber immer hinter der Alarmzeile. Beim nächsten Login werden die Positions- und Größendaten der einzelnen Faceplates ausgelesen und dementsprechend positioniert.

Zweihandbedienung

In der linken unteren Ecke gibt es einen Aktivierungsbereich für die Zweihandbedienung. Wird ein verriegeltes Element betätigt, wird der Aktivierungsbereich blinkend dargestellt und ein verriegeltes Element kann darüber entriegelt werden.

Möglichkeiten der Zweihandbedienung:

  • Button: z.B. Home
  • Sollwerteingabe: Keyboard wird aufgeschaltet und Sollwert kann eingegeben werden,
  • Tipp-Betrieb

Eine Berücksichtigung der Aktivierungsreihenfolge (Freischaltung vor Aktion) ist im Demoprojekt projektiert. Beim Tipp-Betrieb (Faceplate Operation) wird ständig die aktive Freischaltung überprüft.

Kreismenü

Zur schnelleren Navigation zwischen den Workspaces wurde ein Kreismenü implementiert. Diese wird bei Tap&Hold auf eine beliebige Stelle des Workspace aktiviert und erscheint rund um den Finger. Die Auswahl des Workspaces erfolgt durch Draggen des Finger in einen der Bereiche, die Umschaltung erfolgt beim Loslassen. Die Aktion kann durch Draggen außerhalb bzw. innerhalb des Menübereichs abgebrochen werden.

Home Button

In der rechten unteren Ecke befindet sich ein Home Button. Über diesen kann zum Startbildschirm gewechselt werden. Der Home Button ist nur per Zweihandbedienung aktivierbar.


VSTA Code

Handbuch -> Multitouch -> Beispielprojekt -> VSTA Code

Klassenbeschreibung

MultiTouchManagement

Komplettes Handling der gesamten Multitouchanwendung. Hier werden beim Erzeugen der MultitouchManagement-Klasse die Klassen LoginWindow, NaviationsWindow und WindowManagement instanziert.

LoginWindow

In dieser Klasse stehen die wesentlichen Bestandteile der Benutzeranmeldung und Passwortmustererkennung.

NavigationWindow

Behandelt das Faceplate-Positionierungsbild "Icon" und managt den gesamten Öffnungsprozesses der jeweilig aufzuschaltenden Faceplates.

WindowManagement

Ist für die Abarbeitung aller Touchevents aller Faceplates zuständig (verschieben, skalieren usw.). Zusätzlich kümmert sich diese Klasse um die Sicherung und das Lesen aller während der Laufzeit benötigten Faceplate-Informationen.

WindowProperties

Für jedes Faceplate wird eine eigene Instanz instanziert, die alle nötigen Daten des Faceplates bereitstellt. Alle Instanzen werden im Sinne der Datenerhaltung beim Beenden der Runtime in eine XML Datei ausgelagert und liefert somit beim Runtimestart die letzen gültigen Einstellungen der Faceplates.


Grundsätzliches Multitouch

Handbuch -> Multitouch -> Beispielprojekt -> Grundsätzliches Multitouch

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Events

Wenn man die Projekteigenschaft Multitouch aktiv aktiviert, bekommt man in der Runtime bei entsprechender Eventhandler Deklaration die Events für TouchManipulationStartEvent, TouchManipulationDeltaEvent und TouchManipulationCompleteEvent. Mittels der Methode SetupTouchInertia können die Trägheitsparameter bildspezifisch definiert werden. Die folgende Darstellung zeigt einen schematischen Ablauf der gefeuerten Events:

Interne ID: Grundsätzliches Multitouch

Multitouch aktiv

Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Grundsätzlich wird zuerst ein TouchManipulationStartEvent gefeuert. Solange man nun die Geste ausführt, werden TouchManipulationDeltaEvents und bei Ende der Touchgeste ein abschließendes TouchManipulationCompleteEvent gefeuert. Der übergebene Parameter lContacts gibt die Anzahl der aktuell am Bildschirm vorhandenen Finger wider.

Nach Abschluss der Touchgeste werden aufgrund der in der Methode SetupTouchInertia übergebenen Werte durch den Inertiaprozessor die Trägheitswerte berechnet und wiederum durch TouchManipulationDeltaEvents und die durch den Inertiaprozessor berechneten Trägheitswerte mit einem einmaligen TouchManipulationCompleteEvent abgeschlossen.

Da sich während der vom Interiaprozessor berechneten Trägheitswerte keine Finger auf dem Bildschirm befinden, weist der übergebene lContacts Parameter den Wert 0 auf. Die Anzahl der vom Inertiaprozessor benötigten TouchManipulationDeltaEvents ist von den von der Methode SetupTouchInertia übergebenen Parametern abhängig. Je nach Trägheit benötigt der Interiaprozessor mehr oder weniger Events um die Geste abzuschließen.

Wird während der Feuerung der berechneten Interiaevents eine weitere Geste gestartet, kommen keine weiteren TouchManipulationDeltaEvents der alten Geste. Nach einen abschließenden TouchManipulationCompleteEvents werden sofort wieder die Events für die neue Geste mittels einem TouchManipulationStartEvents gestartet.

Zusätzlich werden aber auch die Events TouchEvent, ElementMouseOver, ElementLeftButtonDown und ElementLeftButtonUp bei einer Geste gefeuert.

Natives MultiTouch im Weltbild

Um Zoomen und Scrollen mit VBA/VSTA Events zu realisieren, darf die Bild-Eigenschaft Multitouch für Zoomen und Scrollen nicht aktiv sein. Aktiviert man diese Eigenschaft, kümmert sich zenon um die Abhandlung der Zoom- und Scroll-Gesten im projektierten Weltbild. Mehr dazu siehe Abschnitt: Navigation mit Multitouch im Weltbild.

Interne ID: Grundsätzliches Multitouch

Multitouch für Zoomen und Scrollen

Aktiv: Für Zoomen und Scrolling im Weltbild können Multitouch-Gesten verwendet werden, ohne dass diese in VSTA programmiert werden müssen. Ist diese Eigenschaft aktiv, werden keine VBA/VSTA Events für Multitouch-Gesten erzeugt.

Nur verfügbar, wenn die Eigenschaft Multitouch aktiv aktiviert wurde und Größe aus Schablone nicht aktiv ist.

Interne ID: Grundsätzliches Multitouch

Größe aus Schablone

Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
Default: aktiv.

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


FAQs

Handbuch -> Multitouch -> Beispielprojekt -> FAQs

Oft gestellt Fragen und praktische Antworten.

Hinweis: Die Eigenschaften Name für Objektliste und Hilfe-Kapitel können in zenon als frei definierbare Eigenschaften verwendet werden.

Interne ID: FAQs

Hilfe-Kapitel

Hilfe-Kapitel, das für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Name der zugrunde liegenden HTML Seite.
Achtung: Dieser Eintrag berücksichtigt Groß-/Kleinschreibung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: FAQs

Name für Objektliste

Element wird in die Stationsliste des Weltbildes mit dem hier angegebenen Text eingetragen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wie füge ich ein neues Faceplate ein?

Das Beispielprojekt besteht aus 13 aufschaltbaren Faceplates, welche als Icons im Navigationsbld Navigation_Bottom dargestellt sind. Um einen Zusammenhang zwischen den einzelnen Icons und den aufzuschaltenden Faceplates zu generieren, muss die Namenskonvention eingehalten werden. Die Namen der jeweiligen Icons müssen exakt gleich mit den Namen der dazugehörigen Bilder sowie auch deren Schablonen übereinstimmen. Eine Verbindung zwischen den Bildern kann nur hergestellt werden, wenn diese Ist diese Kette (Icon - Schablone - Bild) eingehalten wird.

Um die jeweiligen Bilder aufschalten zu können, muss natürlich auch eine Bildumschaltfunktion projektiert werden. Diese wird mit dem Präfix "scr" und dem Namen des Faceplates benannt. Wird diese Namenskonvention eingehalten, dann wird das gesamte Handling anschließend vom Multitouch Management übernommen.

Wie erzeuge ich Feedback, wenn der gedrückte Button bzw. das Wertanzeige-Element Zweihandbedienung erfordert?

Um die Zweihandbedienung zu gewährleisten, müssen beide Druckpunkte jeweils auf einem eigenen Bild mit einer eigenen Schablone bereitgestellt werden. Im Beispielprojekt heißt dieses Bild Enabler.

Beim Projektieren muss bei zweihandbedienbaren Elementen das Interlocking mit der enableArea verknüpft werden. Durch diese Projektierung erfolgt automatisch ein Feedback, sobald der Enabler (Zweihandbedienung) nicht gedrückt ist. Dieses Element ist erst bedienbar, wenn der Enabler gedrückt ist.

Wie erzeuge ich einen Tippbetrieb-Button?

Um einen Button mit einer Tippbetriebfunktionalität zu erzeugen:

  • stellen Sie sicher, dass der Name dieses Buttons den Teilnamen "HOLD" beinhaltet
  • navigieren Sie in den Elementeigenschaften zum Knoten Runtime

    Interne ID: FAQs

    Runtime

    Eigenschaften für das Runtime-Verhalten des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • geben Sie in die Eigenschaft Name für Objektliste einen Bezug nach folgendem Muster ein: Variablenname|Wertänderung
    (Ein Beispiel finden Sie im Bild Faceplate_Operation beim Button ^^^.)

Wie erzeuge ich einen Button für das Wechseln des Workspace?

Dazu können Sie das vorgefertigte Symbol Tab benutzen. Die Variable demoCurrentWorkspace bildet im gesamten Projekt den Wert des aktuell aktiven Workspace ab. Folgende Einstellungen manipulieren die Variable und richten alle geöffneten Bilder neu aus:

Gruppe tab_inactive:D

die Eigenschaft Hilfe-Kapitel in der muss den Eintrag WorkspaceSwitch enthalten.

die Eigenschaft Name für Objektliste muss einen Eintrag nach folgendem Muster enthalten: demoCurrentWorkspace|PAGE (zum Beispiel: demoCurrentWorkspace|3)

Wie erzeuge ich einen neuen Benutzer?

Im Bild Login muss für die Anmeldung eines Benutzers ein benutzerspezifisches Muster auf die 16 möglichen Quadrate gezeichnet werden. Sobald man das erste Rechteck berührt, wird die Passworteingabe gestartet. Sie wird beendet, sobald der Finger den Bildschirm wieder verlässt. Sofort nach Eingabe des Musters Patterns wird das Passwortes verifiziert. Bei positiver Bestätigung erfolgt automatisch die Anmeldung.

Im Hintergrund wird während der Eingabe des Passwortmusters ein typographisches Passwort erstellt, das über eine Funktion mit den projektierten Projektbenützer verglichen werden kann. Das erste Rechteck wird als 'A', das zweite Rechteck als 'B' usw. interpretiert und durch reihenabhängiges Hoovering der Rechtecke zu einem zusammenhängenden Passwortes zusammengesetzt.

Um einen neuen Benutzer hinzuzufügen:

  • legen Sie in der Benutzerverwaltung einen neuen Benutzer an
  • erstellen Sie ein personen bezogenes Passwortes
  • sorgen Sie dafür, dass der Benutzer im Bild Login auswählbar ist und projektieren Sie die selben Eigenschaften wir für die bereits projektierten Buttons der Benutzerauswahl

Wie schalte ich das Kreismenü auf?

Das Kreismenü wird aufgeschaltet:

  • an einem Finger, der sich auf dem Workspace befindet
    und
  • sich länger als 800 ms nicht bewegt

Im daraufhin um den Finger positionierten Kreismenü hat man die Möglichkeit, durch einfaches Draggen des Fingers zwischen den Workspaces auf den gewünschten Workspace zu wechseln.

Wie filtere ich die frei herunterziehbare AML ?

Die AML bleibt immer aufgeschaltet und die maschinenbezogene Filterung wird durch die einfach aufzurufende Filtermöglichkeiten der Bildumschaltfunktion auf das Bild AML und AML-collapsed durchgeführt.

Wie schalte ich eine Maschine auf?

Maschinen werden durch eine fixe Reihenfolge von Abläufen wie Anpassungen der Filter, Bildumschaltfunktionen, Aufschaltung des maschinenbezogenen Navigationsbereichs, Positionierung der maschinenabhängigen Faceplates usw. dargestellt. In diesem Beispielprojekt wird die Abfolge der aufzurufenden Funktionen in einen zenon Skript projektiert, das beim Auslösen des Maschinen-Icons im Startbild aufgerufen wird.

Wo werden die Informationen der Faceplates gespeichert?

Größe, Position, Workspace, Sichtbarkeit und Skalierungsfaktor werden in eine Konfigurationsdatei geschrieben. Diese befindet sich in einem Unterordner des Ordners %HOMEPATH%\AppData\Local\Ing._Punzenberger_COPA-DA\.


Navigation mit Multitouch im Weltbild

Handbuch -> Multitouch -> Navigation mit Multitouch im Weltbild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Multitouch-Gesten für Zoomen und Scrollen eignen sich auf Touchpanels auch zur Navigation im Weltbild. Dazu ist kein Bild vom Typ Weltbild-Übersicht nötig. Um Multitouch-Gesten zur Navigation im Weltbild verwenden zu können, müssen diese:

  • entweder über die Eigenschaft Multitouch für Zoomen und Scrollen aktiviert

    Interne ID: Navigation mit Multitouch im Weltbild

    Multitouch für Zoomen und Scrollen

    Aktiv: Für Zoomen und Scrolling im Weltbild können Multitouch-Gesten verwendet werden, ohne dass diese in VSTA programmiert werden müssen. Ist diese Eigenschaft aktiv, werden keine VBA/VSTA Events für Multitouch-Gesten erzeugt.

    Nur verfügbar, wenn die Eigenschaft Multitouch aktiv aktiviert wurde und Größe aus Schablone nicht aktiv ist.

    Interne ID: Navigation mit Multitouch im Weltbild

    Größe aus Schablone

    Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
    Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
    Default: aktiv.

    Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Navigation mit Multitouch im Weltbild

    Multitouch aktiv

    Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
    Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • oder über VBA/VSTA implementiert werden

Zoomen und scrollen über Eigenschaft Multitouch für Zoomen und Scrollen

Um Multitouch ohne VBA/VSTA zu verwenden:

  1. aktivieren Sie in den Projekteigenschaften im Knoten Touchbedienung die Eigenschaft Multitouch aktiv

    Interne ID: Navigation mit Multitouch im Weltbild

    Touchbedienung

    Eigenschaften für die Touchbedienung.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. deaktivieren Sie bei den Eigenschaften des Bildes im Knoten Größe die Eigenschaft Größe aus Schablone

    Interne ID: Navigation mit Multitouch im Weltbild

    Größe

    Eigenschaften für die Größe und die Position des Bildes, die aus der verknüpften Schablone übernommen werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren Sie bei den Eigenschaften des Bildes im Knoten Allgemein die Eigenschaft Multitouch für Zoomen und Scrollen

    Interne ID: Navigation mit Multitouch im Weltbild

    Allgemein

    Allgemeine Eigenschaften des Bildes.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Damit kann im Bild bei Touchbedienung mit Multitouch-Gesten gescrollt und gezoomt werden. VBA/VSTA Events für Zoomen und Scrollen werden damit deaktiviert.

Zoomen und scrollen über VBA/VSTA

Um Zoomen und Scrollen mit VBA/VSTA Events zu realisieren darf die Eigenschaft Multitouch für Zoomen und Scrollen nicht aktiv sein.

Im DynPicture stehen zur Verfügung:

  • Property

    int ZoomLevel: Gibt den aktuelle Zoomlevel im Weltbild an (gültiger Wert nur in der Runtime und für ein Weltbild).

  • Methode

    SetZoomAndPos(float ZoomX, float ZoomY, int ZoomLevel, int CursorX, int CursorY, int PosX, int PosY, int PosMode):

    ZoomX -> Neuer Zoomfaktor X-Richtung, wenn nicht benutzt,auf 0 setzen

    ZoomY -> Neuer Zoomfaktor Y-Richtung, wenn nicht benutzt,auf 0 setzen

    ZoomLevel -> Zoom Level, wenn nicht benutzt, auf -1 setzen

    CursorX -> Cursorposition X

    CursorY -> Cursorposition Y

    PosX -> Neue Position X (siehe PosMode)

    PosY -> Neue Position Y (siehe PosMode)

    PosMode -> Koordinaten in Pos

    -1 = PosX, PosY werden ignoriert

    0 = Mittelpunkt , Original Koordinaten

    1 = Mittelpunkt , gezoomte Koordinaten

    2 = links oben , Original Koordinaten

    3 = links oben , gezoomte Koordinaten

    4 = Gezoomte Koordinaten des Cursors von links oben
    Die Position des Fensters wird so verändert, dass nach dem Zoomvorgang der Mauszeiger noch immer über der selben Stelle des Bildes liegt

Achtung: ZoomX, ZoomY und ZoomLevel können nie gleichzeitig verwendet werden. Entweder wird ein ZoomLevel angegeben oder Zoomfaktoren für X-Achse und Y-Achse.


Netzwerk

Handbuch -> Netzwerk

zenon Netzwerke lassen sich sehr schnell und sicher einrichten und konfigurieren.

zenon im Netzwerk ermöglicht Ihnen:

  • den Aufbau von verteilten Systemen (Dezentralisierung)
  • gleichzeitiges Arbeiten auf mehreren Stationen (siehe Verteiltes Engineering)
  • vollwertigen Zugriff auf Projektierung und Runtime von verschiedenen Rechnern
  • Nutzung von Webserver und Webclient für mobilen Zugriff
  • Überblick von allen Arbeitsplätzen aus (Aktionen wie Quittieren von Alarmen an einem Arbeitsplatz sind bei allen anderen sichtbar)
  • zentrales Protokollieren und Archivieren

Als Netzwerktopologien unterstützt zenon Client-Server, Multi-Server und Multi-Client-Multi-Server.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Einfache Verwaltung des zenon Netzwerks

Die durchdachte Netzwerkfunktionalität von zenon ermöglicht es, Projekte auf unterschiedlichen Servern einzusetzen und sehr effizient komplexe Netzwerkkonstellationen zu erstellen. Die einzelnen Stationen können so konfiguriert werden, dass dabei nur die Projektinhalte sichtbar sind, die für die Tätigkeiten an diesem Ort nötig sind. Der zenon Editor unterstützt Anwender dabei, das Netzwerk zu verwalten.

Die integrierte Topologieverwaltung stellt die Zusammenhänge der einzelnen Projekte mit den zugehörigen Servern grafisch dar. Eine Prüfroutine kontrolliert die konfigurierte Struktur auf Vollständigkeit und Konfigurationsfehler. Projektierungsfehler sind schnell ermittelt. Mit den Netzwerkknotenfunktionen prüft zenon auch, ob die gewählte Netzwerktopologie grundsätzlich funktionieren kann.

info Info

Beachten Sie bei Netzwerkprojekten, auf welchen Rechnern Module und Funktionen verwaltet und ausgeführt werden.

WAN

Innerhalb eines Netzwerkes überträgt zenon Daten standardmäßig spontan – und ist damit schon für den Einsatz im WAN optimiert. Je nach Konfiguration empfiehlt sich auch, den Watchdogverkehr zwischen Client und Server einzuschränken. Die Kommunikationsstrecke zwischen Client und Server kann automatisch geschlossen werden. Die Router bauen nur dann eine Verbindung auf, wenn wirklich ein Datenaustausch notwendig ist.

WEB Server

Der zenon Webserver ermöglicht den Zugriff auf die Runtime per Intranet oder Internet. Dafür sind keine Projektanpassungen erforderlich. Der Zugriff erfolgt über den Webclient. Dieser bietet dasselbe Look & Feel wie die zenon Runtime. zenon WEB Server steht zur Verfügung als:

  • zenon WEB Server: Reine Beobachtungsfunktionalität
  • zenon WEB Server Pro: Komplette Bedien- und Beobachtungsfunktionalität. Über das Web kann direkt in Prozesse eingegriffen werden.

Noch in diesem Kapitel

Voraussetzungen

zenon Netzwerk einrichten

Starke Verschlüsselung der Netzwerkkommunikation

Remote Transport im Netzwerk

zenon am Terminalserver

Netzwerktopologie verwalten und prüfen

Redundanz

Routing

Bedienberechtigung im Netzwerk

zenon Funktionen im Netzwerk

Verhalten von zenon Modulen im Netzwerk

Netzwerkmeldungen vom Systemtreiber


Voraussetzungen

Handbuch -> Netzwerk -> Voraussetzungen

Voraussetzung für den zenon Netzwerkbetrieb ist ein funktionsfähiges Windows-Netzwerk. Das Anzeigen der Netzwerk-Rechner im Windows Explorer genügt nicht, um das Funktionieren des zenon Netzwerkes zu gewährleisten.

Allgemein

Folgende Voraussetzungen müssen prinzipiell vorliegen:

  • TCP/IP als Netzwerk-Protokoll.
  • Funktionierende Namensauflösung, wahlweise über DNS, WINS oder lokale HOST-Dateien.
  • Freier TCP Port 1100:
    Wenn ein Netzwerkprojekt geladen wird, startet die zenon Runtime automatisch den Netzwerkdienst zenNetSrv. Dieses Programm öffnet den Port 1100. Dieser muss daher remote erreichbar sein und darf nicht durch eine Firewall blockiert werden.

zenon Netzwerke funktionieren sicher mit diesen Betriebssystemen:

  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows Server 2003/2008

IPv6

Das zenon Netzwerk erlaubt wahlweise die Verwendung von IPv6 oder IPv4. Dualer Betrieb ist nicht möglich. Die Einstellung wird getroffen über:

  • Network configuration im Startup Tool
    oder
  • in der zenon6.ini

Wird diese Einstellung geändert, müssen alle laufenden zenon Prozesse neu gestartet werde. Das betrifft insbesondere zenAdminSrv, zenSysSrv, zenLogSrv und zenDBSrv.

Folgende Komponenten sind von der Einstellung nicht betroffen, diese nutzen immer IPv4:

  • Treiberkommunikation mit den Steuerungen
  • Protokollkommunikation in den ProcessGateway-Plugins
  • Workbench- und Runtimekommunikation in zenon Logic

attention Achtung

IPv6 funktioniert nur ab Version 7. Bei aktiver Option können keine Versionen vor 7 gestartet werden.

Verwendete Ports

Für die Kommunikation innerhalb von zenon werden ausschließlich TCP-Ports - keine UDP-Ports - verwendet. Im Netzwerk benötigt zenon folgende Ports:

Dienste | Datei | Aufgabe | TCP-Port
Netzwerkdienst | zenNetSrv.exe | Runtime-Kommunikation. | 1100
Transportservice | zenSysSrv.exe | Datenübertragung mittels Remote Transport (Editor) und Diagnose Server. | 1101
zenon Webserver | zenWebsrv.exe | Protokollumsetzer zwischen Webclient und Runtime. | 1102

Voraussetzungen überprüfen

Namensauflösung

Um die Namensauflösung zu überprüfen:

  1. starten Sie die Windows Kommandozeile (cmd.exe)
  2. führen folgenden Befehl aus: ping RECHNERNAME
  3. bei korrekter Namensauflösung erhalten Sie die IP-Adresse des Rechners mit Laufzeit als Antwort, sonst eine Fehlermeldung

TCP Ports

Um die Erreichbarkeit des TCP Ports 1100 zu überprüfen:

  1. starten Sie die Runtime mit einem Netzwerkprojekt auf einem Remote-Rechner:
    damit wird das Programm zenNetSrv.exe gestartet und der TCP Port 1100 geöffnet
  2. starten Sie die Windows Kommandozeile (cmd.exe)
  3. führen Sie folgenden Befehl aus: telnet RECHNERNAME 1100
  4. sobald ein Verbindungsaufbau zustande kommt, wird das Kommandozeilenfenster ganz schwarz
    (Beenden des Kommandozeile: Befehl Schließen im Kontextmenü oder Klick auf X des Programmfensters), ansonsten erscheint eine Fehlermeldung

Hinweis: Unter Windows Vista/7 müssen Sie den Telnet-Befehl erst installieren. Eine Anleitung dazu finden Sie in der Hilfe zum Betriebssystem (Suche nach: Telnet).

Noch in diesem Kapitel

Zeitsynchronisation im Netzwerk


Zeitsynchronisation im Netzwerk

Handbuch -> Netzwerk -> Voraussetzungen -> Zeitsynchronisation im Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei netzwerkbasierenden Projekten müssen alle Rechner im Netzwerk zeitsynchron arbeiten. Die nötige Synchronisation übernimmt zenon automatisch.

In einer Topologie mit Kreisredundanz oder mit mehreren Servern, empfiehlt es sich, die die Zeitsynchronisation über DCF (Funkuhr) oder die Windows Kommandos zu verwenden. In diesem Fall muss die automatische Zeitsynchronisation in zenon deaktiviert werden.

attention Achtung

Beträgt der Zeitunterschied zwischen Server und Client mehr als 5 Sekunden, werden keine Dateien mehr synchronisiert.

Automatische Zeitsynchronisation in zenon deaktivieren

Soll die Zeitsynchronisation manuell ein- oder ausgeschaltet werden, ist ein Eintrag in der zenon6.ini nötig:

[Netz]

TIMESYNCH=1 -> automatische Zeitsynchronisation aktiv (default)

TIMESYNCH=0 -> automatische Zeitsynchronisation inaktiv

Example Beispiel

[Netz]

TIMESYNCH=0

Externe Zeitsynchronisation über das Betriebssystem

Wurde die automatische Zeitsynchronisation in zenon deaktiviert, kann die Synchronisation über das Betriebssystem erfolgen. Dazu muss ein Zeitserver definiert werden (mit oder ohne DCF77), der die Zeitsynchronisation der anderen Rechner übernimmt.

In der klassischen Client- Server/Standby Topologie ist der aktuelle Server der aktive Uhrzeit-Master. Dieser sollte sich selbst mit DCF (Funkuhr) oder über die Windows Time Kommandos aktuell halten. Der jeweilige Client holt die aktuelle Uhrzeit vom Server (abhängig von der eingestellten Timoutzeiten) und aktualisiert seine eigene Uhrzeit damit. Die Kommunikation erfolgt über SNTP (System Network Time Protokoll), das die Verzögerung der Übertragung berücksichtigt.

info Info

Watchdog

Die Zeitsynchronisation erfolgt periodisch zur eingestellten Timeoutzeit.

Bei Verwendung der Standardeinstellung von 30 Sekunden für die Eigenschaft Timeout [s], schickt der Netzwerkdienst (zenNetSrv.exe) jedes Clients während des Online-Betriebs alle 10 Sekunden einen Watchdog an den Netzwerkdienst (zenNetSrv.exe) des Servers. Wenn der Server innerhalb von 30 Sekunden zumindest einen der drei Watchdogs beantwortet, geht der jeweilige Client davon aus, dass die Netzwerkverbindung in Ordnung ist.

Interne ID: Zeitsynchronisation im Netzwerk

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: Zeitsynchronisation im Netzwerk

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Konfiguration in den Projekteigenschaften:

Knoten Netzwerk, Eigenschaft Timeout [s]). Der am Client eingeloggte User muss berechtigt sein, die Zeit am Rechner umzustellen.

Interne ID: Zeitsynchronisation im Netzwerk

Netzwerk

Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

zenon6.ini

Auf Clients oder Remote-Rechner ohne zenon Editor, erfolgt die Einstellung über die zenon6.ini:

[Netz]

NET_TIMEOUT_MSEC=30000

(Timeout in Millisekunden, Default: 30000.)

Beachten Sie die zusätzlich nötige Konfiguration im WAN.

Befehle unter Windows

Zur externen Synchronisation unter Windows geben Sie folgenden Befehl mit den jeweils nötigen Argumenten in die Konsole der Befehlseingabe ein:

NET TIME [\\Computername | /DOMAIN[:Domänenname] : /RTSDOMAIN[:Domänenname]] [/SET] [/YES]

Argument

Beschreibung

NET TIME
  • synchronisiert die Uhr des Computers mit der eines anderen Computers oder einer anderen Domäne
    oder
  • zeigt die Uhrzeit für einen Computer oder eine Domäne an

Wird dieser Befehl ohne weitere Argumente ausgeführt, dann werden das aktuelle Datum und die aktuelle Uhrzeit des Computers angezeigt, der als Zeitserver für die Domäne bestimmt wurde.

Computername

Der Name des Computers, der überprüft oder synchronisiert werden soll.

DOMAIN[:Domänenname]

Die Uhrzeit wird mit dem primären Domänencontroller der Domäne Domänenname synchronisiert.

RTSDOMAIN[:Domänenname]

Die Uhrzeit des Computers wird mit einem zuverlässigen Zeitserver aus der Domäne Domänenname synchronisiert.

/SET

Synchronisiert die Uhr des Computers mit der Uhr des angegebenen Computers bzw. der angegebenen Domäne. Nach Absetzen des Befehls erfolgt die Anzeige der Server-Uhrzeit und die Abfrage, ob diese Zeit gesetzt werden soll.

/YES

Zeigt die aktuelle Serverzeit an und synchronisiert diese mit dem lokalen rechner ohne weitere Abfrage oder Bestätigung.

Example Beispiel

NET TIME \\Server /SET /YES

Noch in diesem Kapitel

Zeitsynchronisation im WAN


Zeitsynchronisation im WAN

Handbuch -> Netzwerk -> Voraussetzungen -> Zeitsynchronisation im Netzwerk -> Zeitsynchronisation im WAN

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im WAN und bei Wählverbindungen bedeutet die Standard-Vorgabe von 30 Sekunden für den Watchdog, dass die Verbindung permanent aufrecht erhalten würde.

Wählen Sie im WAN eine Timeout [s] Zeit, die nur im gewünschten Abstand Verbindungen aufbaut. Beachten Sie: je länger der Timeout, desto später werden Serverausfälle erkannt. Wählen Sie zum Beispiel als Zeit für Timeout [s] 64.800, dann beträgt die Timeout-Zeit 18 Stunden. Es wird also alle 6 Stunden eine Verbindung aufgebaut und ein Watchdog geschickt. Ein Serverausfall wird damit erst nach 18 Stunden bemerkt.

Interne ID: Zeitsynchronisation im WAN

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: Zeitsynchronisation im WAN

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Beim Starten des Clients wird immer eine fixe Timeout-Zeit von 30 Sekunden verwendet.

Funktion Bildumschaltung

Bei einer Bildumschaltung werden aktiv Daten angefordert. Ablauf:

  • Es wird überprüft, ob innerhalb der letzten 30 Sekunden ein Watchdog zum Server abgeschickt wurde.
  • Ist das nicht der Fall, wird sofort ein Watchdog zum Server geschickt, auf dessen Rückmeldung 40 Sekunden gewartet wird.
  • Wird ein Server-Ausfall erkannt, versucht der zenon Netzwerk-Dienst automatisch alle 30 Sekunden einen Reconnect durchzuführen.

Dies würde im WAN-Betrieb zu einem permanenten Verbindungsaufbau führen. Dieses Verhalten kann über Einträge in der zenon6.ini geändert werden:

  1. Öffnen Sie die zenon6.in.
  2. Navigieren Sie zum Abschnitt
    [NETZ].
  3. Erstellen oder bearbeiten Sie den Eintrag

    NET_CONNECTWAIT_MSEC=30000
    Dieser definiert den Wert für einen Reconnect in Millisekunden.

    Maximalwert: Timeoutzeit

  4. Erstellen oder bearbeiten Sie den Eintrag

    NET_CONNECTCOUNT=0

    Dieser definiert die Anzahl der Wiederholungen für einen Reconnect pro Zyklus.

    Default ist 0 Wiederholungen, das bedeutet 1 Reconnect-Versuch.


zenon Netzwerk einrichten

Handbuch -> Netzwerk -> zenon Netzwerk einrichten

Im zenon Netzwerk arbeiten Sie mit :

Parameter

Beschreibung

Server:

Rechner mit Verbindung zur Steuerung. Der Server übernimmt exklusiv die Verwaltung von Prozess und Projektdaten. Die Kommunikation wird über einen Watchdog überprüft.

Bei einem Serverausfall übernimmt der Standby-Server dessen Aufgaben, sofern ein Standby definiert wurde. Sobald der Server wieder bereit ist, übernimmt er automatisch seine Aufgaben und synchronisiert alle Daten.

Standby-Server:

Übernimmt in redundanten Systemen die Rolle des Servers, wenn dieser ausfällt. Im Netzwerk verhält er sich wie ein Client, speichert aber ebenso wie der Server alle Daten. Bei Hardware-Redundanz kommuniziert der Standby eigenständig bidirektional mit der redundanten Steuerung.

Der Standby arbeitet mit einem internen Puffer. Damit wird Datenverlust in der Totzeit zwischen Serverausfall und Übernahme der Serverrolle durch den Standby vermieden.

Clients:

Jeder Rechner, auf dem eine Runtime gestartet wird, ist ein Client. Clients verbinden sich zum Server, um Daten vom Prozess zu erhalten oder abzusetzen.

Datenserver:

Der Datenserver ist ein Rechner, der direkt Prozesskommunikation hat, aber keine Serveraufgaben übernimmt. Im Normalbetrieb liefert der Datenserver alle Daten an den Server, der sich um die Datenhaltung und Datenverteilung kümmert. Bei einem Netzwerk- oder Serverausfall arbeitet der Datenserver als Einzelplatzsystem weiter, und garantiert damit die Bedienbarkeit der Anlage. Sobald die Serververbindung wieder hergestellt werden kann, erfolgt ein Datenabgleich.
Einsatzgebiet: Vor-Ort-Bediensystem mit leistungsschwacher Hardware, z.B. IPC oder CE-Terminal. Die komplette Datenarchivierung und Datenverteilung erfolgt auf dem Datenserver. Bei einem Serverausfall bleibt die Möglichkeit zur Bedienung Vor-Ort erhalten. Bei einem klassischen Client Server Modell ist das nicht der Fall.

info Info

Server und Client werden nicht rechnerbezogen, sondern projektbezogen definiert.

Werden Namen von Server oder Standby-Server geändert, können diese nicht nachgeladen werden. Sie werden erst mit einem Neustart der Runtime aktualisiert.

Topologien

zenon unterstützt mehrere Netzwerk-Topologien:

  • Client-Server-Netzwerk: Auf dem Server und auf allen Clients läuft das selbe Projekt.
  • Multi-Server-Netzwerk: Ein Client kann auf verschiedene Server zugreifen und so die Daten verschiedener Projekte zur selben Zeit darstellen.
  • Multi-Client-Multi-Server Modell: Alle Clients und Server kommunizieren miteinander. Aus jedem Projekt kann auch auf andere Projekte zugegriffen werden.Konfiguration in zenon

Netzwerk konfigurieren

Um ein Projekt netzwerkfähig zu machen:

  1. navigieren Sie in den Projekteigenschaften zum Knoten Netzwerk

    Interne ID: zenon Netzwerk einrichten

    Netzwerk

    Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. aktivieren Sie die Eigenschaft Netzwerk aktiv

    Interne ID: zenon Netzwerk einrichten

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. definieren Sie über die Eigenschaft Server den Rechner, der im Projekt die Serverrolle übernimmt
    Hinweis: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden.

    Interne ID: zenon Netzwerk einrichten

    Server

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

    Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nach Bedarf konfigurieren Sie in diesem Abschnitt noch

  • Routing: Eigenschaft Routing aktiv

    Interne ID: zenon Netzwerk einrichten

    Routing aktiv

    Aktiv: Der Rechner fungiert als Knotenrechner und kann Pakete routen. Dabei laufen alle Netzwerkpakete von außerhalb über diesen Rechner.
    Diese Einstellung kann zu Engpässen führen und beeinflusst die möglichen Netzwerktopologien . Ein Einsatz ist in speziellen Netzwerkkonstellationen sinnvoll, z.B. bei WAN-Netzwerken oder gerouteten Netzwerken. Es wird daher empfohlen, die Einstellung zu deaktivieren.

    Default: inaktiv

    Mehr im Online Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Standby-Server: Eigenschaft Standby

    Interne ID: zenon Netzwerk einrichten

    Standby

    Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
    Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

    Interne ID: zenon Netzwerk einrichten

    Timeout [s]

    Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

    Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
    Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

    Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
    Achtung: Server und Standby müssen identische Systemzeit haben.
    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Redundanz: Eigenschaft Redundanztyp

    Interne ID: zenon Netzwerk einrichten

    Redundanztyp

    Nur verfügbar, wenn bei der Eigenschaft Standby ein Rechner eingetragen wurde.

    zenon unterstützt zwei Redundanztypen:

    Softwareredundanz: Das System besteht aus einer Steuerung und zwei redundanten Leitsystem-Rechnern. Beide Rechner müssen Verbindung zur Steuerung haben. Beide Rechner kommunizieren mit der Steuerung und halten gleichzeitig die Daten aus der Steuerung aktuell. Die Kommunikation zur Steuerung übernimmt der Rechner mit Server-Funktion. Der Server kommuniziert also bidirektional, der Standby unidirektional. Fällt der Server aus, übernimmt der Standby-Server die bidirektionale Kommunikation mit der Steuerung.

    Hardwareredundanz: Das System besteht aus zwei redundanten Steuerungen und zwei redundanten Leitsystem-Rechnern. Jeder Rechner kommuniziert mit einer Steuerung bidirektional. Beide Rechner und beide Steuerungen gleichen ihre Daten ab. Fällt eine Komponente im ersten System aus, übernimmt das zweite System.

    Default: Softwareredundanz

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Beenden-Benachrichtigung: Legt fest, ob beim Beenden der Runtime auf einem Server die Clients mit 70 Sekunden Vorlauf benachrichtigt werden

    Interne ID: zenon Netzwerk einrichten

    Beenden-Benachrichtigung

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Aktiv: Beim Beenden der Runtime auf einem Server wird auf allen verbundenen Clients eine Meldung angezeigt, die das Beenden der Runtime anzeigt. Das Beenden der Runtime wird um 70 Sekunden verzögert, damit auf den Clients Eingaben noch korrekt abgeschlossen werden können.
    Inaktiv: Die Runtime auf dem Server wird ohne Anzeige einer Meldung auf den Clients sofort geschlossen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Damit haben Sie die grundlegenden Eigenschaften konfiguriert. Wiederholen Sie diese Schritte für alle Clients im zenon Netzwerk. Entfernte Rechner können auch mit Remote Transport eingerichtet werden.

attention Achtung

Namensvergabe für Server und Standby-Server: "localhost" darf nicht verwendet werden.

Noch in diesem Kapitel

Client-Server Modell

Multi-Server Modell

Multi-Client-Multi-Server Modell

Mehrprojektverwaltung

Horizontale Transparenz

Optimierung großer Projekte


Client-Server Modell

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Client-Server Modell

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Client-Server-Modell greifen Client und Server auf dasselbe Projekt zu. Am Client wird das Server-Projekt als aktuelles Projekt gestartet.

Für die Einrichtung des Client-Server Modells wird auf jedem Rechner:

  • die Eigenschaft Netzwerk aktiv aktiviert

    Interne ID: Client-Server Modell

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • in die Eigenschaft Server der Name des Servers eingetragen

    Interne ID: Client-Server Modell

    Server

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

    Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Empfehlung: Der Server sollte der leistungsstärkste Rechner im Netzwerk sein.

Im zenon Client-Server Netzwerk:

  • hat nur der Server eine direkte Verbindung zur SPS
  • verwaltet der Server alle Prozessdaten (z.B. Onlinedaten, Archivdaten, Alarme, Rezepte, etc.)
  • verwaltet der Server alle Projektdaten (z.B. Bilder, Funktionen, definierte Variablen, etc.)
  • wird jeder andere Rechner, der dasselbe Projekt startet, automatisch als Client definiert und erkannt
  • baut jeder Client bei jedem Runtime-Start
    • die Verbindung zum Server auf,
    • gleicht die Projektdaten ab und
    • stellt die aktuellen Prozessdaten dar

info Info

Windows CE ist vollständig integriert. Systeme unter Windows CE können als Server und Client eingesetzt werden.

Noch in diesem Kapitel

Server einrichten

Einrichten der Clients


Server einrichten

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Client-Server Modell -> Server einrichten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Server stellt die Verbindung zur SPS her und verwaltet alle Daten, sowohl Online-Daten als auch Projektierungsdaten. Clients gleichen ihre Daten mit den Daten des Servers ab.

Um den Server einzurichten:

  1. aktivieren Sie die Eigenschaft Netzwerk aktiv

    Interne ID: Server einrichten

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie über die Eigenschaft Server den Rechner, der im Projekt die Serverrolle übernimmt
    Hinweis: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden.

    Interne ID: Server einrichten

    Server

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

    Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. achten Sie auf die korrekte Konfiguration der Intern Variablen
  4. erstellen Sie, falls nötig, AUTOSTART und AUTOEND Skripte für die Clients

attention Achtung

Namensvergabe für Server und Standby-Server: "localhost" darf nicht verwendet werden.

Wenn der Entwicklungsrechner, auf dem Sie das Projekt erstellt haben, zugleich der Runtime Server ist, ist der Server fertig eingerichtet.

Konfiguration Intern Variable

Wurden bereits Variablen angelegt, bevor das Projekt als Netzwerk-Projekt definiert wurde, sind Intern Variablen lokal definiert. Sie werden also auf jedem Client lokal ausgeführt. Sollen auch diese Variablen im Netzwerk mit dem Server abgeglichen werden:

  1. navigieren Sie in den Eigenschaften der Intern Variablen zur Gruppe Interne Variable

    Interne ID: Server einrichten

    Interne Variable

    Eigenschaften für interne Variablen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. wählen Sie in der der Dropdownliste der Eigenschaft Berechnung den Wert Netzwerk

    Interne ID: Server einrichten

    Berechnung

    Lokal: Die interne Variable wird bei Netzwerk-Projekten lokal d.h. auf dem Client ausgewertet bzw. verwaltet.
    D.h. der Wert der Variable kann auf jedem Client unterschiedlich sein und auch die Grenzwerte werden lokal ausgewertet.
    Netzwerk: Die interne Variable wird bei Netzwerk-Projekten auf dem Server des Projekts ausgewertet bzw. verwaltet. Sie hat auf dem Server und auf allen Clients denselben Wert.
    Default: lokal.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Lokal: Die Variable wird auf dem Client verwaltet.Der Wert der Variable kann auf jedem Client unterschiedlich sein. Auch Grenzwerte werden lokal ausgewertet.
    • Netzwerk: Die Variable wird auf dem Server des Projekts ausgewertet und verwaltet. Sie hat auf dem Server und auf allen Clients denselben Wert.

Skripte für Clients

Sollen auf den Clients spezielle Bilder gestartet oder Funktionen ausgeführt werden, müssen entsprechende Skripte eingerichtet werden:

  • AUTOSTART_CLIENT: Wird beim Systemstart ausgeführt und definiert alle lokal auszuführenden Prozesse beim Neustart des Clients. Zum Beispiel z.B. Start eines spzuiellen Startbildes.
  • AUTOEND_CLIENT: Wird beim Beenden ausgeführt und definiert alle lokal auszuführenden Prozesse beim Beenden des Clients. Zum Beispiel Ausgänge zurücksetzen.

Die beiden Skripte laufen auf dem Server.


Einrichten der Clients

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Client-Server Modell -> Einrichten der Clients

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Clients können per Hand oder per Remote Transport eingerichtet werden. Empfohlen wird die Einrichtung per Remote Transport.

Dabei gilt:

  • Sollte der Entwicklungsrechner auch ein Client sein, so starten Sie hier einfach lokal die Runtime.
  • Alle anderen Clients richten Sie entweder per RemoteTransport oder von Hand ein.
  • Sollen auf den Clients spezielle Abläufe ausgeführt werden, muss auf dem Server jeweils ein Skript erstellt werden, das das Verhalten beim Start (Skript AUTOSTART_CLIENT) und beim Beenden (Skript AUTOEND_CLIENT) definiert.

Noch in diesem Kapitel

Client mit RemoteTransport einrichten

Client manuell einrichten

Verhalten zur Runtime


Client mit RemoteTransport einrichten

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Client-Server Modell -> Einrichten der Clients -> Client mit RemoteTransport einrichten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Als Standard überträgt der Remote Transport Dateien immer zu dem Rechner, der in den Netzwerk-Einstellungen als Server definiert ist. Um Clients vom Entwicklungsrechner aus per Remote Transport einzurichten, muss vor dem Einrichten des Clients die Übertragungsrichtung neu konfiguriert werden.

Um Clients per Remote transport einzurichten:

  1. Öffnen Sie in den Projekteigenschaften den Knoten Allgemein.

    Interne ID: Client mit RemoteTransport einrichten

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Klicken Sie auf die Eigenschaft Remote-Transport.

    Interne ID: Client mit RemoteTransport einrichten

    Remote-Transport

    Der Konfigurationsdialog für den Remote Transport wird geöffnet.
    Der Remote Transport dient dem transportieren, nachladen, starten und beenden eines Projekts auf einem entfernten Rechner und dem anfordern des aktuellen Status.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Der Dialog Remote Transport wird geöffnet.
  4. Tragen Sie in Verbindung unter Name den Namen des Clients im Netzwerk ein.
    Mehrere Clients trennen Sie durch Strichpunkt (;).
  5. Schließen Sie die Projekt-Verwaltung mit OK.
  6. Bauen Sie eine Online-Verbindung zum Client auf.
    Für die weitere Nutzung des Remote-Transport benutzen Sie am besten die Symbole der Symbolleiste.
  7. Transportieren Sie mit dem Remote Transport alle Runtime-Dateien zum Client.
  8. Setzen Sie mit dem Remote Transport das Startprojekt für den Client.
  9. Starten Sie mit dem Remote Transport die Runtime auf dem Client.
  10. Beenden Sie die Online-Verbindung.


Client manuell einrichten

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Client-Server Modell -> Einrichten der Clients -> Client manuell einrichten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Clients für den Start der Runtime zu konfigurieren:

  1. Schließen Sie zenon Editor und zenon Runtime.
  2. Öffnen Sie die Datei zenon6.ini mit einem Texteditor.
    Sie finden die Datei im Ordner C:\ProgramData\COPA-DATA\System\
  3. Entfernen Sie die Zeile VBF30 =.... oder kommentieren Sie dies Zeile aus.

    Dieser Eintrag legt fest, welches Projekt die Runtime beim Start laden soll.

  4. Lassen Sie den Editor geschlossen und starten Sie die Runtime.
  5. In einem Dialog wird abgefragt, welches Projekt geladen werden soll.

  6. Aktivieren Sie die Checkbox Projekt von Runtime-Server laden

  7. Tragen Sie ein:
    1. Runtime-Server: Rechner, der als Server eingerichtet wurde. Name kann direkt eingetragen oder über die Schaltfläche ... aus einer Liste ausgewählt werden.
    2. Projektname: Name des Projekts, das auf dem Server läuft.
    3. Projekt-Zielordner: Ordner für Runtime auf der lokalen Festplatte des Clients. Sie können entweder ein bestehendes Verzeichnis über die Schaltfläche ... auswählen oder von Hand eintippen. Wird per Hand ein noch nicht existierender Ordner von Hand eingegeben, wird dieser automatisch angelegt.
    4. Bestätigen Sie die Eingaben mit OK.
  8. Die zenon Runtime:
    1. baut nun eine Verbindung zum Runtime Server auf
    2. kopiert dessen Runtime Dateien in den Projekt-Zielordner
    3. startet die Runtime
    4. fordert gegebenenfalls zu einem Neustart der Runtime auf
  9. Der Eintrag VBF30=... in der Datei zenon6.ini wird auf den Projekt-Zielordner gesetzt.

    Damit startet die Runtime auf dem Client bei jedem weiteren Start automatisch das Netzwerk-Projekt.

Wiederholen Sie diesen Vorgang für jeden Client.


Verhalten zur Runtime

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Client-Server Modell -> Einrichten der Clients -> Verhalten zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Netzwerkprojekte lassen sich zur Runtime von Server und Clients gleich bedienen und werden gleich visualisiert. Ist beim Start der Runtime kein gültiges Projekt definiert, wird der Dialog zur Festlegung des Runtime-Projekts geöffnet. Details siehe Abschnitt Client manuell einrichten.

Unterschiede zwischen Server und Client:

  • Nur der Server des Projekts hat eine Verbindung zur Hardware und verwaltet die Prozessdaten.
  • Die Clients erhalten vom Server:
    • aktuelle Werte der Variablen
    • Systemmeldungen der Chronologischen Ereignisliste
    • Alarminformationen
    • Rezepte
    • archivierte Daten

Die Übertragung vom Server zum Client erfolgt spontan und ereignisgesteuert.

Überwachung der Verbindung

Bei Verwendung der Standardeinstellung von 30 Sekunden für die Eigenschaft Timeout [s], schickt der Netzwerkdienst (zenNetSrv.exe) jedes Clients während des Online-Betriebs alle 10 Sekunden einen Watchdog an den Netzwerkdienst (zenNetSrv.exe) des Servers. Wenn der Server innerhalb von 30 Sekunden zumindest einen der drei Watchdogs beantwortet, geht der jeweilige Client davon aus, dass die Netzwerkverbindung in Ordnung ist. Diese Standardeinstellung kann im Editor in der Netzwerk-Konfiguration geändert werden: Abschnitt Netzwerk der Projekteigenschaften, Eigenschaft Timeout [s] mit Default 30 Sekunden.

Interne ID: Verhalten zur Runtime

Netzwerk

Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verhalten zur Runtime

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: Verhalten zur Runtime

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Multi-Server Modell

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Multi-Server Modell

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon definiert und unterscheidet in einem Projekt zwischen:

  • Server
  • Standby-Server
  • Clients

Daher ist es problemlos möglich, verschiedene Server-, Client- und Standby-Projekte gleichzeitig und parallel auf einem Rechner laufen zu lassen.

In Verbindung mit der Fähigkeit des Projektmanagers, hierarchische Baumstrukturen zu kreieren, bieten sich eine Vielzahl an Möglichkeiten und Netzwerkapplikationen.

Das Multi-Server Modell unterscheidet zwischen:

  • Unterstationen
  • Bereichszentralen
  • Zentralen

Die einzelnen Rechner agieren jeweils als Server für ihr eigenes Projekt.

Hierarchie

Die Hierarchie der Projekte wird im Projekt Manager festgelegt. Dazu ziehen Sie ein Projekt per Drag&Drop auf ein übergeordnetes Projekt.

Übergeordnete Projekte können jeweils auf alle ihnen untergeordneten Projekte zugreifen. Untergeordnete Projekte können auf gleichrangige und übergeordnete Projekte zugreifen. Für den reibungslosen Zugriff beachten Sie:

  • alle beteiligten Projekte müssen die Eigenschaft Netzwerk aktiv aktiviert haben

    Interne ID: Multi-Server Modell

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • das Zielprojekt muss auf einem Rechner als Server laufen,
    dieser Rechner muss vom anfragenden Rechner aus erreichbar sein
    (Der Server hat das Integrationsprojekt und alle Unterprojekte gestartet.)
  • anfragendes Projekt und Zielprojekt müssen auch auf dem anfragenden Rechner gestartet sein

Beispiel: Wenn das Projekt SUB1 am Rechner B Zugriff auf das darüber liegende Projekt Integration1 am Server A möchte, muss:

  • Server A von Rechner B aus erreichbar sein
  • bei Integration 1 und SUB1 jeweils die Eigenschaft Netzwerk aktiv auf aktiv gesetzt sein
  • Integration 1 mit allen Subprojekten am Server A gestartet sein
  • Integration 1 und SUB1 am Rechner B gestartet sein

attention Achtung

Innerhalb von Multi-Server Systemen darf jeder Projektname nur einmal vergeben werden.


Multi-Client-Multi-Server Modell

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Multi-Client-Multi-Server Modell

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Modell kann ein PC Server für ein Projekt und gleichzeitig Client für ein anderes sein. Ein einziger PC kann auch gleichzeitig Multiserver (Server für mehrere Projekte) und Multiclient (Client für mehrere Projekte) sein. Realisiert wird diese Struktur über die zenon Mehrprojektverwaltung.

Das Multi-Client-Multi-Server Modell bildet die Grundlage für:

  • zenon Horizontale Transparenz
  • zenon Kreisredundanz


Mehrprojektverwaltung

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mehrprojektverwaltung ermöglicht dezentrale Lösungen. Unterprojekte können als Serverprojekte auf verschiedenen Rechnern betrieben werden.

Damit können:

  • im Editor mehrere Projekte in einem Arbeitsbereich gleichzeitig bearbeitet werden
  • zur Runtime mehrere Projekte gleichzeitig gestartet und so projektübergreifend direkt auf Variablen, Funktionen, Archive usw. aus anderen Projekten zugegriffen werden

info Info

Mehrprojektverwaltung steht unter zenon Operator nicht zur Verfügung. Hier können pro Arbeitsbereich jeweils nur ein Projekt und ein Globalprojekt angelegt und verwaltet werden.

Struktur

Voraussetzung ist ein Integrationsprojekt, das in der Runtime als Startprojekt geladen wird.

zenon baut einen mehrhierarchischen Projektbaum auf, an dessen Spitze das Integrationsprojekt steht. Die Mehrprojektverwaltung ermöglicht es, die Projekte in eine logische Verbindung zueinander zu setzen.

info Info

Die Topologie konfigurieren und überprüfen Sie mit der zenon Netzwerktopologie.

Effizient arbeiten mit der Mehrprojektverwaltung und der Projekthierarchie

zenon ermöglicht es, Daten und Bilder der bestehenden Projekte konsequent wiederzuverwenden. Die zenon Mehrprojektverwaltung schafft eine logische Verbindung zwischen den einzelnen Projekten und setzt diese in eine hierarchische Verbindung zueinander. Der Anwender kann diese Projekthierarchie grafisch im zenon Editor abbilden, indem er die Projekte mit der Maus an die gewünschte Position zieht und damit einen mehrhierarchischen Projektbaum aufbaut.

Das in der Hierarchie am höchsten stehende Projekt ist das Integrationsprojekt. Alle anderen Projekte sind diesem Projekt untergeordnet. In der Projektstruktur stehen die Daten der einzelnen Projekte projektübergreifend zur Verfügung.

Die zenon Mehrprojektstruktur ist vergleichbar mit einem Aktenordner:

  • Es können jederzeit zusätzliche Blätter – zenon Projekte – hinzugefügt werden. Der Ordner umfasst automatisch immer alle Informationen der darin abgelegten Blätter. Man kann jederzeit durch die Seiten blättern und sich alle Informationen ansehen, ohne die einzelnen Blätter herauslösen zu müssen. In der zenon Mehrprojektstruktur können Anwender zwischen den einzelnen Bildern oder Projekten wechseln, ohne diese herausnehmen zu müssen.
  • Das Integrationsprojekt lässt sich mit dem Inhaltsverzeichnis des Aktenordners vergleichen. Es dient als zentrales Navigationsprojekt und ermöglicht es, Bilder oder Daten aus den untergeordneten Projekten anzuzeigen. Die einzelnen Projekte sind autark und können auch weiterhin autark betrieben werden. Der Zugriff von einem Projekt auf die Daten oder Bilder eines anderen Projekts erfolgt über die zenon Standardschnittstellen. Erweiterungen oder Projektänderungen erfolgen direkt in den einzelnen Projekten. Eventuelle Wartungsarbeiten haben nur auf das jeweilige Projekt Einfluss, das Gesamtsystem bleibt davon unberührt.

Mehrprojektverwaltung bedeutet

  • Kleine überschaubare Strukturen.
  • Einfache, schnelle und übersichtliche Wartung einzelner Projekte.
    Zum Beispiel können einzelne Projekte gezielt außer Betrieb genommen werden, ohne die anderen zu beeinflussen. Ebenso können Projekte auf unterschiedliche Rechner aufgeteilt werden.
  • Ausgereifte Lastverteilung.
  • Projektübergreifende Bedienung, da alle auf einem Rechner befindlichen Projekte gleichzeitig aktiv sind.
  • Mehrhierarchische Netzwerkstruktur ermöglicht das Zusammenfassen von Daten (Messwerte, Alarme, Betriebsmeldungen, Archivdaten usw.) in einem übergeordneten Projekt.
  • Keine Beschränkung der Projektanzahl pro Rechner.
  • Zusammenfassbar zu großen Leitständen.
  • Knotenstruktur – physikalische Netzwerktrennung.

Noch in diesem Kapitel

Das Integrationsprojekt

Definition der Struktur im Editor

Projekte übertragen und starten

Projekte verwalten


Das Integrationsprojekt

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Das Integrationsprojekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Integrationsprojekt verwaltet Unterprojekte, auf die in der Runtime zugegriffen werden kann. Das I-Projekt kann in der Mehrprojektveraltung als reines Verwaltungsprojekt eingesetzt oder auch als vollwertiges Projekt genutzt werden. Wird das Integrationsprojekt als Startprojekt gesetzt, werden in der Runtime alle unterlagerten Projekte automatisch mit gestartet.

In einem Integrationsprojekt können Sie mit wenigen Mausklicks zentrale Alarmmeldelisten oder Chronologische Ereignislisten über alle integrierten Projekte erstellen. So werden zum Beispiel alle Alarme der Projekte in der Alarmmeldeliste des Integrationsprojekts angezeigt und chronologisch sortiert.

attention Achtung

Achten Sie bei der Gestaltung der Mehrprojektverwaltung auf eine funktionierende Navigation.


Definition der Struktur im Editor

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Definition der Struktur im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Struktur des Netzwerks wird im Editor einfach durch Drag & Drop erstellt. Sie benötigen zusätzlich zu den produktiven Projekten ein Integrationsprojekt (I-Projekt), das alle anderen Projekte verwaltet. Da Einzelplatzprojekte keine Daten an Clients liefern, muss in jedem Projekt ein Server definiert werden. Das Integrationsprojekt kann auch zusätzlich ein Produktivprojekt sein.

Beispiel

In diesem Beispiel werden drei Projekte verwendet:

  • Produktivprojekt PRO1
  • Produktivprojekt PRO2
  • Integrationsprojekt I-PRO

Um die Struktur zu erstellen:

  1. erstellen Sie:
    • I-PRO
    • PRO1
    • PRO2
    • und definieren Sie je einen Server
  2. ziehen Sie im Projekt-Manager PRO1 mit gedrückter linker Maustaste auf I-PRO
  3. verfahren Sie mit PRO2 ebenso
  4. PRO1 und PRO2 werden im Projekt-Manager jetzt als Zweige des Projekts I-PRO angezeigt

Damit ist die hierarchische Struktur des Netzwerks erstellt.

info Info

Damit Elemente der Unterprojekte, wie Bilder, Variablen oder Funktionen ausgewählt werden können, muss die Funktion "Projekt im Speicher halten" (Kontextmenü des Projekts) aktiviert sein.


Projekte übertragen und starten

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Projekte übertragen und starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der topologischen Struktur werden alle Unterprojekte eines Integrationsprojekts automatisch auf die jeweiligen Ziele übertragen. Ist das Integrationsprojekt auch das Startprojekt, werden alle Unterprojekte mitgestartet.

Details zur Netzwerktopologie lesen Sie im Kapitel Netzwerktopologie verwalten und prüfen. Die Konfiguration der Rechner mit einem Beispiel für die automatische Übertragung der Subprojekte finden Sie im Abschnitt Konfiguration Rechner im Netz.

Projekte manuell übertragen und starten

Um Projekt manuell zu übertragen und zu starten:

  • Transportieren Sie mit dem Remote Transport alle Runtime-Dateien von PRO1 zum entsprechenden Server.
  • Setzen Sie mit dem Remote Transport das Startprojekt für den Server von PRO1.
  • Starten Sie mit dem Remote Transport die Runtime auf dem Server von PRO1.
  • Beenden Sie die Online-Verbindung.
  • Verfahren Sie mit PRO2 ebenso.


Projekte verwalten

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Projekte verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um auf die Daten von Unterprojekten zuzugreifen, stehen Ihnen mehrere Möglichkeiten zur Verfügung, zum Beispiel:

  • Navigation zwischen Projekten
  • Variablen oder Funktionen eines anderen Projekts nutzen
  • Rezepte auf unterschiedliche Variablen in unterschiedlichen Projekten absetzen
  • Archive projektübergreifend erstellen
  • gemeinsame AML oder CEL für verschiedene Projekte erstellen

attention Achtung

Beachten Sie bei der Konfiguration, auf welchen Geräten - Server, Standby, Client - welche Module und Funktionen ausgeführt werden. Eine Liste der möglichen Konfigurationen finden Sie hier: Verhalten von Modulen im Netzwerk.

Noch in diesem Kapitel

Navigation zwischen Projekten

Variablen und Funktionen

Rezepte

Archive

Alarme und CEL


Navigation zwischen Projekten

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Projekte verwalten -> Navigation zwischen Projekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Verwaltung mehrer Projekte in einem Integrationsprojekt ist es unbedingt nötig, dafür zu sorgen, dass man zur Runtime jederzeit von einem Unterprojekt in ein anderes oder ins Integrationsprojekt wechseln kann. Dazu erstellen Sie eine Schablone, die sich immer im Vordergrund befindet und platzieren dort Navigationsschaltflächen.

Bildumschaltung auf Unterprojekte

Um zwischen Projekten umzuschalten, benutzen Sie die zenon Funktion Bildumschaltung. Damit die Navigation immer zur Verfügung steht, erstellen Sie im ersten Schritt eine Schablone, die sich immer im Vordergrund befindet:

  1. erstellen Sie eine neue Schablone, die Platz für die Navigation bietet
  2. weisen Sie ihr die Eigenschaft Immer im Vordergrund zu

    Interne ID: Navigation zwischen Projekten

    Immer im Vordergrund

    Aktiv: Kein anderes Bild überdeckt diesen Bereich im Onlinebetrieb. Bilder im Hintergrund können aber bedient werden.
    Inaktiv: Bilder dieser Schablone können von anderen Bildern überdeckt werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren Sie die Eigenschaften Rahmenart und Titel

    Interne ID: Navigation zwischen Projekten

    Titel

    Nur verfügbar, wenn ein Rahmen für die Schablone ausgewählt ist:
    Aktiv: Windows-Titelleisten für die Bilder dieser Schablone verwenden. Die Bilder können in der Runtime verschoben werden.
    Inaktiv: Keine Titelleiste verwenden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Navigation zwischen Projekten

    Rahmenart

    Rahmenart des Bildes.
    Dicker Rahmen: Ein dicker Rahmen wird um das Bild dargestellt. Die Größe des Bildes kann in der Runtime verändert werden.
    Dünner Rahmen: Ein dünner Rahmen wird um das Bild dargestellt.
    Kein Rahmen: Kein Rahmen wird um das Bild dargestellt.
    Default: Kein Rahmen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. (damit kann die Schablone zur Runtime verschoben werden)
  5. erstellen Sie auf Basis dieser Schablone ein Bild mit Schaltflächen zur Navigation

Beispiel Umschaltung zwischen PRO1 und PRO2

  1. Legen Sie eine neue Funktion Bildumschaltung an.
  2. Ist mehr als ein Projekt im aktuellen Arbeitsbereich vorhanden, wird der Dialog zur Bildauswahl auf die Auswahl eines Projekts erweitert.

  3. Wählen Sie PRO1.
  4. Wählen Sie das Startbild von PRO1 aus und schließen Sie den Dialog mit OK.
  5. Wiederholen Sie den Vorgang für PRO2.
  6. Fügen Sie im Bild zur Navigation zwei Textbuttons mit der Beschriftung PRO1 und PRO2 ein.
  7. Verknüpfen Sie die beiden Textbuttons mit den erstellten Funktionen.

attention Achtung

zenon überprüft im Editor nicht, ob die Netzwerk-Struktur in der Runtime auch tatsächlich einen Zugriff auf das ausgewählte Projekt/Bild erlaubt.

Zum Beispiel kann im Editor im Projekt PRO1 eine Bildumschaltung auf ein Bild im Integrationsprojekt erstellt werden. Diese Umschaltung würde aber in der Runtime nicht funktionieren!


Variablen und Funktionen

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Projekte verwalten -> Variablen und Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können über Dynamische Elemente direkt auf Variablen und Funktionen aus anderen Projekten desselben Arbeitsbereichs zugreifen.

Beispiel Variable

  1. Öffnen Sie das Startbild des I-PRO.
  2. Fügen Sie ein neues Dynamisches Element Zahlenwert ein.
  3. Jetzt öffnet sich der Variablenauswahl-Dialog.

  4. Hier können Sie nicht nur Variablen aus dem I-PRO auswählen. Um eine Variable eines anderer Projekts zu wählen:
    1. klicken Sie auf ein Projekt im linken Listenbereich
    2. Sie bekommen die dazugehörigen Variablen angeboten
    3. wählen Sie die gewünschte Variable
  5. Wählen Sie eine Variable aus dem PRO1 oder PRO2 aus.

Da das I-PRO ein Client zum Server PRO1 und PRO2 ist, wird die Verbindung in der Runtime einwandfrei funktionieren.

Für Funktionen gehen Sie analog vor.

attention Achtung

zenon überprüft im Editor nicht, ob die Netzwerk-Struktur in der Runtime auch tatsächlich einen Zugriff auf das ausgewählte Projekt und seine Variablen/Funktionen erlaubt.

Zum Beispiel kann im Editor im Projekt PRO1 eine Variable aus dem Integrationsprojekt gewählt werden. Diese Verbindung würde aber in der Runtime nicht funktionieren!


Rezepte

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Projekte verwalten -> Rezepte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können in einem Rezept Werte auf Variablen verschiedener Projekte des Arbeitsbereichs absetzen.

Beispiel Rezept

  1. Öffnen Sie im Projekt I-PRO den Knoten Rezepte.
  2. Legen Sie unter Rezepte Standard ein neues Rezept mit dem Namen REZEPT1 an.
  3. Öffnen Sie das Kontextmenü des REZEPT1 und wählen Sie Variable hinzufügen.
  4. Der Variablenauswahl-Dialog wird geöffnet.

  5. Hier können Sie nicht nur Variablen aus dem I-PRO auswählen. Um Variablen anderer Projekte zu wählen:
    1. Klicken Sie auf ein Projekt im linken Listenbereich.
    2. Sie bekommen die dazugehörigen Variablen angeboten.
    3. Wählen Sie Variablen aus dem PRO1 und aus dem PRO2 aus.
    4. In der Variablenliste des Rezepts wird dann vor dem Variablennamen auch der Name des jeweiligen Projekts angeführt.

Da das I-PRO ein Client zu den Servern PRO1 und PRO2 ist, wird die Verbindung in der Runtime einwandfrei funktionieren.

attention Achtung

zenon überprüft im Editor nicht, ob die Netzwerk-Struktur in der Runtime auch tatsächlich einen Zugriff auf das ausgewählte Projekt und seine Variablen erlaubt.

Zum Beispiel kann im Editor im Projekt PRO1 eine Variable aus dem Integrationsprojekt gewählt werden. Diese Verbindung würde aber in der Runtime nicht funktionieren!


Archive

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Projekte verwalten -> Archive

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können in einem Archiv Werte von Variablen verschiedener Projekte des Arbeitsbereichs aufzuzeichnen. Die so aufgezeichneten Werte können wie die Daten normaler Archive gefiltert, in Listen oder als Trends angezeigt sowie ausgedruckt oder exportiert werden.

Beispiel Archiv

  1. Öffnen Sie im Projekt I-PRO den Knoten Archivserver.
  2. Legen Sie ein neues Archiv mit dem Namen BA - BASIS an.
  3. Öffnen Sie das Kontextmenü der Variablenliste und wählen Sie Variable hinzufügen.
  4. Der Variablenauswahl-Dialog wir geöffnet.

  5. Hier können Sie nicht nur Variablen aus dem I-PRO auswählen. Um Variablen anderer Projekte zu wählen:
    1. klicken Sie auf ein Projekt im linken Listenbereich
    2. Sie bekommen die dazugehörigen Variablen angeboten
    3. wählen Sie die gewünschte Variable
  6. Wählen Sie Variablen aus dem PRO1 und aus dem PRO2 aus.
  7. In der Variablenliste des Archivs wird vor dem Variablennamen der Name des jeweiligen Projekts angeführt.

Da das I-PRO ein Client zu den Servern PRO1 und PRO2 ist, wird die Verbindung in der Runtime einwandfrei funktionieren.

attention Achtung

zenon überprüft im Editor nicht, ob die Netzwerk-Struktur in der Runtime auch tatsächlich einen Zugriff auf das ausgewählte Projekt und seine Variablen erlaubt.

Zum Beispiel kann im Editor im Projekt PRO1 eine Variable aus dem Integrationsprojekt gewählt werden. Diese Verbindung würde aber in der Runtime nicht funktionieren!

Redundanz

Nach Abschluss der Variablenauswahl weist eine Meldungsbox darauf hin, dass in redundanten Systemen unter Umständen die lückenlose Aufzeichnung nicht gewährleistet ist.

attention Achtung

Das I-PRO ist in dieser Struktur nur ein Client für die beiden Server PRO1 und PRO2. Daher bekommt es seine Daten auch von den beiden Server-Projekten. Fällt einer dieser beiden Server aus, bekommt das I-PRO die entsprechenden Daten nicht mehr. Es würden also Ersatzwerte im Archiv stehen!

Um die lückenlose Aufzeichnung zu gewährleisten, führen Sie alle Projekte, die Daten ins Archiv liefern sollen, redundant aus.


Alarme und CEL

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Mehrprojektverwaltung -> Projekte verwalten -> Alarme und CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon können Sie Systemmeldungen und Alarme aus verschiedenen Projekten eines Arbeitsbereichs gemeinsam in einer Liste anzeigen lassen. Diese Einträge können dann wie die Daten normaler Alarmmeldelisten oder Chronologischer Ereignislisten gefiltert, angezeigt, ausgedruckt oder exportiert werden.

Beispiel AML

  1. Legen Sie ein Bild des Bildtyps Alarm an.
  2. Fügen Sie über Kontrollelemente -> Vorlagen einfügen Kontrollelemente in das Bild ein.
  3. Erstellen Sie eine Funktion Bildumschaltung auf dieses Bild.
  4. Der Filterdialog für Alarmlisten wird geöffnet.
  5. Öffnen Sie die Registerkarte Projekt.
  6. Wählen Sie die Projekte aus, die inder AML des I-PRO angezeigt werden sollen.
    Mehrfachauswahl Taste Strg plus Mausklick.)

  7. Öffnen Sie die Registerkarte Spalteneinstellungen.
  8. Wählen Sie für die Anzeige in der Runtime auch die Eigenschaft Projektname.
    So behalten Sie zur Runtime Überblick, aus welchem Projekt ein Alarm kommt.


Horizontale Transparenz

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Horizontale Transparenz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die horizontale Transparenz erhöht die Performance zur Runtime durch:

  • Zusammenarbeit der Maschinenbediener
  • Kommunikation der Ist-Werte und Soll-Werte der Performance-Indikatoren

Horizontale Transparenz wird durch die Mehrprojektverwaltung in zenon ermöglicht. Damit können alle Projekte, die sich auf der gleichen Ebene befinden, auf einem Rechner aufgeschaltet werden.

Beispiel

Mehrere Terminals gehören zu einer Maschine. Jedes hat sein eigenes Visualisierungsprojekt. Mit Hilfe der „Horizontalen Transparenz“ lässt sich auf allen Terminals jeweils das eigene Projekt und alle anderen Projekte, die sich auf der gleichen Ebene befinden aufschalten und bedienen. So kann von jedem Terminal aus die komplette Maschine überwacht und bedient werden.


Optimierung großer Projekte

Handbuch -> Netzwerk -> zenon Netzwerk einrichten -> Optimierung großer Projekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Große Netzwerkprojekte können mit Standardeinstellungen den zenon Server beim gleichzeitigen Nachladen über längere Zeit auslasten.
Groß bedeutet:

  • Runtimedateien mit 10 MB oder größer
  • mehr als 50 Clients

In diesem Fall muss das Verhalten beim Nachladen eventuell optimiert werden, damit nicht alle Clients gleichzeitig Daten nachladen. Das bewirken Sie durch den Eintrag RELOADDELAY_SEC 0 in der project.ini. Damit wird das Nachladen um einen Zufallswert verzögert.
Dazu:

  1. öffnen Sie die project.ini im Ordner Project_SQL_Ordner/FILES/zenon/system/
    Tipp: Markieren Sie das Projekt im Projektmanager und drücken Sie die Tastenkombination Strg+Alt+E, der Explorer öffnet den Ordner Project_SQL_directory/FILES/
  2. navigieren Sie zum Abschnitt [NETZ]
  3. erstellen Sie den Eintrag RELOADDELAY_SEC 0
  4. wählen Sie für 0 einen Wert für die Verzögerung

Beim Nachladen wird für jeden Client eine zufällige Verzögerung in Sekunden gesetzt, die zwischen 0 und dem gewählten Wert liegt. 0 bedeutet keine Verzögerung.

Der gewählte Wert hat keinen Einfluss auf Einzelplatzprojekte, am Server und am Standby

Hinweis: Dieser Eintrag sollte nur in sehr großen Projekten bei merkbarer Verzögerung beim Nachladen gesetzt werden. In Normalprojekten sind die Standardeinstellungen performanter.


Starke Verschlüsselung der Netzwerkkommunikation

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon ermöglicht die starke Verschlüsselung der Kommunikation im zenon Netzwerk. Die starke Verschlüsselung funktioniert ab zenon Version 7.0 für alle unterstützten Betriebssysteme (ausgenommen Windows XP SP2) und für den Webclient.

Bei aktiver Verschlüsselung erfolgt die Kommunikation zwischen Server, Client und Webclient verschlüsselt, der zenon Webserver leitet Datenpakete nur weiter und ist von der Verschlüsslung nicht betroffen.

info Info

Netzwerkkommunikation wurde auch in früheren Versionen in zenon verschlüsselt. Mit Version 7 ändert sich die Methode. Der Begriff "Verschlüsselung" im Zusammenhang mit zenon 7 oder höher meint immer starke Verschlüsselung.

Noch in diesem Kapitel

Grundlagen

Verschlüsselung aktivieren

Passwort Netzwerkverschlüsselung

Checkliste bei Fehler

Fehlermeldungen


Grundlagen

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Grundlagen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Verschlüsselung für die zenon Runtime steht ab Version 7.0 zur Verfügung. Bei eingeschalteter Verschlüsselung ist die Kommunikation mit niedrigeren zenon Versionen nicht möglich. Die Verschlüsselung beeinträchtigt keine zenon Funktionalitäten.

Grundlagen Verschlüsselung ab zenon 7.00

Um die starke Verschlüsselung des zenon Netzwerks zu nutzen, beachten Sie:

  • Das Passwort wird rechnerbezogen individuell verschlüsselt und in der zenon6.ini abgelegt. Das bedeutet vor allem:
    • Das Passwort kann nicht durch kopieren der zenon6.ini auf einen anderen Rechner übertragen werden.
    • Ändern sich Hardwarekomponenten, vor allem im Bereich Netzwerkadapter, wird das Passwort eventuell ungültig und muss neu eingegeben werden.
  • Die Verschlüsselung muss immer für alle Server, Clients und Webclients im zenon Netzwerk eingeschaltet oder abgeschaltet werden. Die Kommunikation zwischen verschlüsselten und unverschlüsselten Systemen ist nicht möglich. Webserver fungieren nur als Proxy-Rechner und sind von der Verschlüsselung nicht betroffen.
  • Wird die Verschlüsselung auf einem Rechner aktiviert, gilt sie immer für alle Projekte dieses Rechners mit aktiver Eigenschaft Netzwerk aktiv.

    Interne ID: Grundlagen

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Kompatibilität

Die Verschlüsselung ist nicht kompatibel mit Versionen vor zenon 7.00 SP0. Das bedeutet:

System 1 | System 2 | Kommunikation
zenon 7 verschlüsselt | zenon 7 verschlüsselt | ja
zenon 7 unverschlüsselt | zenon 7 unverschlüsselt oder zenon vor Version 7 unverschlüsselt | ja
zenon 7 verschlüsselt | zenon 7 unverschlüsselt oder zenon vor Version 7 unverschlüsselt | nein

Fehler werden in den Log-Dateien des Diagnose Viewers protokolliert.

Beispiel:

Die folgende Abbildung zeigt ein Beispiel eines Netzwerks mit Server, Standby, zwei Clients, einem Webserver und zwei Webclients. Auf allen Geräten läuft zenon 7.00 SP0. Die Geräte wurden wie folgt konfiguriert:

  • Beim Server wird die Verschlüsselung über das Startup Tool aktiviert.
  • Per Remote Transport wird beim Übertragen der Runtime-Dateien auch die Verschlüsselung am Standby-Server und am Client A aktiviert.
  • Client B und Webclient B kommunizieren noch unverschlüsselt.
  • Am Webclient A wird die verschlüsselung per Network communication encryption (zenWebCryptConfig.exe) aktiviert.
  • Da der Webserver die Datenpakete nicht auswertet, sondern direkt weiterleitet, benötigt er keine Verschlüsselung. Theoretisch kann dieser auch eine ältere Versionsnummer haben, und die Webclients können dennoch verschlüsselte Verbindungen aufbauen.

Diese Konfiguration führt zu folgenden Ergebnis:

  • Der Standby-Server kommuniziert erfolgreich mit dem Server.
  • Der Client A kann sich beim Server anmelden und Daten austauschen.
  • Da Client B unverschlüsselte Nachrichten schickt und diese vom Server wegen der aktiven Verschlüsselung verworfen werden, kann Client B nicht mit dem Server kommunizieren und ist damit offline.
  • Der Webclient A meldet sich über den Webserver beim Server an und kann Daten austauschen.
  • Die unverschlüsselten Nachrichten vom Webclient B werden vom Webserver an den Server weitergeleitet, von diesem aber verworfen. WebClient B kann nicht mit dem Server kommunizieren und ist damit offline.

Sobald die Verschlüsselung per Remote Transport oder Startup Tool Konfiguration am Client B und per Network communication encryption am Webclient B aktiviert wird, können auch diese Verbindungen zum Server aufbauen.


Verschlüsselung aktivieren

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Verschlüsselung aktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Verschlüsselung kann über verschiedene Wege aktiviert werden:

  • lokal über das Startup Tool
  • per Remote Transport
  • im Webclient

Tipp

Für die schnelle, bequeme Aktivierung der Verschlüsselung im Netzwerk empfiehlt sich, die Konfiguration von einem Rechner aus per Remote Transport durchzuführen. Das bringt folgende Vorteile:

  • Die Konfiguration kann nach dem Verbindungsaufbau durch wenige Klicks von einem Gerät auf ein anderes übertragen werden:
    • Remote Verschlüsselung konfigurieren aktivieren
    • Klick auf Von zenon6.ini lesen
    • Klick auf OK
  • Alle Konfigurationen können von einem Rechner aus erfolgen.
  • Tippfehler beim Eingeben des Passworts werden zwar durch die Passwortbestätigung abgefangen, aber für den Fall, dass in den beiden Eingabefeldern der gleiche Tippfehler gemacht wurde, stellt die Übertragung der eigenen Konfiguration durch Remote Transport sicher, dass dennoch alle Rechner das gleiche Passwort verwenden.

Noch in diesem Kapitel

lokal über Startup Tool

per Remote Transport

im Webclient


lokal über Startup Tool

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Verschlüsselung aktivieren -> lokal über Startup Tool

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Verschlüsselung am lokalen Rechner zu aktivieren:

  1. öffnen Sie das zenon Startup Tool
  2. falls Sie mehrere zenon Version parallel betreiben, markieren Sie die gewünschte Version
  3. klicken Sie auf Application -> Options
  4. der Dialog für die Einstellungen des zenon Startup Tools wird geöffnet
  5. wählen Sie die Registerkarte Encrypt network communication

  6. aktivieren Sie die Checkbox Encrypt network communication
  7. tragen Sie das Passwort ein und verifizieren Sie es
  8. bestätigen Sie den Dialog mit Klick auf OK


per Remote Transport

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Verschlüsselung aktivieren -> per Remote Transport

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Verschlüsselung kann auf entfernten Rechnern per Remote Transport aktiviert werden. Das ist allerdings nur möglich, wenn die Remote-Verbindung mit einem Passwort geschützt ist.

Um die Verschlüsselung per Remote Verbindung zu aktivieren:

  1. klicken Sie auf die entsprechende Schaltfläche in der Symbolleiste Remote-Transport

    oder wählen Sie im Kontextmenü des Projekts: Remote-Transport -> Verbindung aufbauen

  2. der Dialog für den Verbindungsaufbau wird geöffnet

  3. geben Sie das Verbindungspasswort ein oder erstellen Sie eines, falls noch keines gesetzt wurde
  4. aktivieren Sie die Checkbox Verschlüsselung der Netzwerkkommunikation konfigurieren
  5. klicken Sie auf OK
  6. der Dialog zur Verschlüsselung der Netzwerkkommunikation wird geöffnet

  7. aktivieren Sie die Checkbox Netzwerkkommunikation verschlüsseln
  8. vergeben Sie ein Passwort (Kriterien siehe Abschnitt "Passwort Netzwerkverschlüsselung)
  9. bestätigen Sie den Dialog mit Klick auf die Schaltfläche OK.


im Webclient

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Verschlüsselung aktivieren -> im Webclient

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Netzwerkkommunikation kann auch für den Zugriff mit dem zenon Webclient verschlüsselt werden. Um mit einem Webclient auf ein verschlüsseltes Netzwerk zuzugreifen:

  1. starten Sie im Startmenü die Verknüpfung \Programme\COPA-DATA\Network communication encryption
    oder die Datei zenWebCryptConfig.exe im zenon Programmordner.
  2. der Dialog zur Konfiguration wird geöffnet

  3. aktivieren Sie die Checkbox vor Encrypt network communication
  4. tragen Sie das Passwort ein und bestätigen Sie es
  5. schließen Sie den Dialog mit Klick auf die Schaltfläche OK


Passwort Netzwerkverschlüsselung

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Passwort Netzwerkverschlüsselung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für das Passwort zur Verschlüsselung der Kommunikation im Netzwerk gilt:

  • Minimale Länge: 8 Zeichen
  • Maximale Länge: 20 Zeichen
    Die angezeigte Länge wird immer auf 20 Zeichen gesetzt, um die tatsächliche Länge zu verbergen.
  • Erlaubte Zeichen:
    • Buchstaben: A - Z; a - z
    • Ziffern: 0 - 9
    • Sonderzeichen
  • Verbotene Zeichen:
    • Leerzeichen
    • Taste Eingabe (Return-Taste)
  • Zusammensetzung: ein Passwort muss mindestens 1 Ziffer und 1 Buchstaben enthalten


Checkliste bei Fehler

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Checkliste bei Fehler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Fehlern überprüfen Sie :

  • Haben alle Rechner Netzwerkzugang und funktioniert die Namensauflösung?
  • Wurde die Eigenschaft Netzwerk aktiv beim Projekt im Editor aktiviert?

    Interne ID: Checkliste bei Fehler

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Läuft auf für Projekte mit Verschlüsselung auf allen Rechnern die zenon Runtime in der Version 7.00 SP0 oder höher?
  • Ist bei Projekten mit Verschlüsselung die Konfiguration auf allen Rechnern korrekt?
    (USE_ENCRYPTION Einstellung in der zenon6.ini: Auf allen Rechnern gleichermaßen entweder auf 0, auf 1 oder nicht vorhanden.)
  • Sind die benötigten Funktionen verfügbar (vor allem auf CE Terminals)?
    • Nicht vorhandene Funktionen führen dazu, dass sich die Runtime gar nicht starten lässt.
  • Ist der Service-Provider oder einer der Algorithmen nicht verfügbar, wird beim Starten der Runtime eine Fehlermeldung in die Log-Datei geschrieben.
  • Wurde das Passwort korrekt gesetzt?
  • Wurde auf einem der beteiligten rechner nach der Konfiguration der Verschlüsselung die Hardware verändert?
  • Funktioniert ein Ping auf den Rechner?
    • Ja: Netzwerkverbindung vorhanden, Fehler liegt in der Kommunikation.
    • Nein: Netzwerk überprüfen.
  • Ist eine Verbindung mit Telnet möglich?
    • Verbindung wird hergestellt: Beide Rechner kommunizieren auf gleicher Ebene. Passwort überprüfen.
    • Verbindung wird hergestellt und wieder verloren: Ein Rechner kommuniziert verschlüsselt, einer unverschlüsselt.
    • Verbindung fehlerhaft: zenon Runtime läuft auf Zielrechner nicht.

    Hinweis: Telnet muss auf neueren Windows Betriebssystemen extra installiert werden. Die Verbindung erfolgt in der Regel über den Port 1100.
    Der Telnet-Befehl lautet dann: open [IPAdresse] 1100

Fehler werden in den Log-Dateien des Diagnose Viewers protokolliert.


Fehlermeldungen

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler werden entweder im Ausgabefenster des zenon Editors oder in Pop-ups angezeigt und/oder in den Log-Dateien des Diagnose Viewers protokolliert.

Keine Verbindung

Wurde ein Client mit einem falschen Verschlüsselungspasswort (ungleich dem Passwort am Server ab) konfiguriert, dann ist das an folgenden Ereignissen erkennbar:

  • Der Client ist offline, obwohl der Server durch Ping erreichbar ist.
  • Der Server schreibt Fehlermeldungen in die Log-Datei:

    SysMod Error: Serialize in Object Project: [Projektname] Modul: [Modulnummer]

    oder:

    NET Error During Decryption [Fehlernummer]

Hinweisboxen und Fehlermeldungen

Auf Fehler bei der Verschlüsselung wird durch Hinweisboxen (Pop-ups) und Einträge in Log-Dateien oder im zenon Ausgabefenster hingewiesen.

Noch in diesem Kapitel

Fehlermeldungen in Pop-ups

Fehlermeldungen im Ausgabefenster

Fehlermeldungen in Log-Dateien


Fehlermeldungen in Pop-ups

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Fehlermeldungen -> Fehlermeldungen in Pop-ups

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Startup Tool und Webclient

Folgenden Fehlermeldungen werden vom zenon Startup Tool als Pop-up für die lokale Verschlüsselung oder vom Network communication encryption für die Konfiguration des Webclients ausgegeben. Diese Meldungen sind immer in Englisch.

Fehlermeldung

Erklärung

The network password has to be entered in both textboxes!

Beim Konfigurieren der Verschlüsselung hat der Benutzer eines der beiden Eingabefelder (Passwort oder Passwortbestätigung) leer gelassen.

The entered network password and the retyped network password are different!

Der Inhalt des Eingabefeldes für die Passwortbestätigung unterscheidet sich vom Inhalt des Eingabefeldes für das Passwort.

The network password does not fullfill the password conventions!

Password conventions:
Minimum length = 8 symbols
Maximum length = 20 symbols
At least one character of the latin charset
At least one number
The blank character is not allowed

Das eingegebene Passwort erfüllt nicht die Passwortkonventionen. Die Passwortkonventionen werden in der Fehlermeldung ebenfalls angezeigt.

The network password could not be encrypted!

Beim Verschlüsseln des Netzwerkpasswortes ist ein Fehler aufgetreten.

The network encryption configuration in the files zenon6.ini and startup.ini are invalid.

Please enter a new configuration and register any item with the startup tool to update both files with valid configurations.

Beim Öffnen der Registerkarte Encrypt network communication im zenon Startup Tool wurde festgestellt, dass weder die zenon6.ini noch die startup.ini gültige Konfigurationen für die Netzwerkverschlüsselung enthalten. Eine neue Konfiguration muss eingegeben werden.

The network encryption configuration in the file zenon6.ini is invalid.

As the configuration in the file startup.ini is valid, the file zenon6.ini will be updated with a valid configuration when any item is registered with the startup tool.

Prüfung beim Öffnen der Registerkarte Encrypt network communication im zenon Startup Tool ergab: Die Verschlüsselungskonfiguration in der zenon6.ini ist ungültig, aber die Verschlüsselungskonfiguration in der startup.ini ist gültig.

Die ungültige Konfiguration in der zenon6.ini wird beim nächsten Registrieren eines Eintrags mit der gültigen Konfiguration aus der startup.ini überschrieben.

The network encryption configuration in the file startup.ini is invalid.

The file zenon6.ini currently contains a valid configuration. Upon registration of any item with the startup tool the file zenon6.ini will be updated with the invalid configuration from the file startup.ini. Please enter a new configuration to ensure both files contain valid confirugations after the registration of an item.

Prüfung beim Öffnen der Registerkarte Encrypt network communication im zenon Startup Tool ergab: Die Verschlüsselungskonfiguration in der zenon6.ini ist gültig, aber die Verschlüsselungskonfiguration in der startup.ini ist ungültig.

Beim nächsten Registrieren eines Eintrags wird auch die Konfiguration in der zenon6.ini ungültig. Eine neue Konfiguration muss eingegeben werden, um sicherzustellen, dass beide INI-Datein gültige Konfigurationen beinhalten.

The netowrk encryption password in zenon6.ini is invalid

Das aus der zenon6.ini ausgelesene Passwort ist ungültig.

Das Passwort für die Netzwerkverschlüsselung ist ungültig und muss neu eingegeben werden!

Meldung beim Runtime-Start, wenn das Passwort nicht verifiziert werden kann.

Remote Transport

Folgenden Fehlermeldungen werden vom Remote Transport bei der Verschlüsselung eines entfernten Rechners als Pop-up ausgegeben.

Fehlermeldung | Erklärung
Zur Konfiguration der Netzwerkverschlüsselung muss die Remote Transport Verbindung Passwortgeschützt sein! | Es wurde versucht, die Remote Verschlüsselung zu konfigurieren ohne die Remote Transport Verbindung über ein Passwort zu authentifizieren.
Das Netzwerkpasswort muss in beiden Textboxen eingegeben werden! | Beim Konfigurieren der Verschlüsselung hat der Benutzer eines der beiden Eingabefelder (Passwort oder Passwortbestätigung) leer gelassen.
Die Passwortbestätigung stimmt nicht mit dem Passwort überein! | Der Inhalt des Eingabefeldes für die Passwortbestätigung unterscheidet sich vom Inhalt des Eingabefeldes für das Passwort.
Das eingegebene Passwort entspricht nicht den Passwortkriterien! Passwortkriterien: Mindestens 8 Zeichen Höchstens 20 Zeichen Mindestens ein Buchstabe Mindestens eine Zahl Kein Leerzeichen | Das eingegebene Passwort erfüllt nicht die Passwortkonventionen. Die Passwortkonventionen werden in der Fehlermeldung angezeigt.
Beim Verschlüsseln des Netzwerkpasswortes ist ein Fehler aufgetreten! | Beim Verschlüsseln des Netzwerkpasswortes ist ein Fehler aufgetreten. Bei der Konfiguration über Remote Transport wird bei diesem Fehler eine genauere Fehlermeldung ins Log geschrieben.
Beim Entschlüsseln des Netzwerkpasswortes aus der zenon6.ini ist ein Fehler aufgetreten! | Das in der zenon6.ini abgelegte Passwort konnte nicht entschlüsselt werden.
Die Verschlüsselungskonfiguration in der zenon6.ini ist ungültig und muss neu eingegeben werden! | Das aus der zenon6.ini ausgelesene Passwort ist ungültig. Das Passwort muss neu festgelegt werden.


Fehlermeldungen im Ausgabefenster

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Fehlermeldungen -> Fehlermeldungen im Ausgabefenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler werden im Ausgabefenster über Meldungenangezeigt:

Meldung | Level | Erklärung
Der Server meldet einen Fehler beim Zusammenstellen der Daten für die Verschlüsselungskonfiguration! | ERROR | Der Remote zenSysSrv meldet einen Fehler beim Zusammenstellen der Informationen für die Verschlüsselung des Passwortes für die Netzwerkverschlüsselung. Die Adapterinformationen konnten nicht ausgelesen werden.
*** Die Konfiguration der Netzwerkverschlüsselung am Remote Gerät wurde aktualisiert: | AKZENT | Diese Meldung steht am Beginn der Abschlussmeldung nach einer Konfiguration der Verschlüsselung an einem Remote Gerät über Remote Transport. Danach folgt eine Meldung bezüglich des Erfolgs der Remote Konfiguration.
Der Server meldet einen Fehler beim Speichern der Verschlüsselungskonfiguration! | ERROR | Der Remote zenSysSrv meldet einen Fehler beim Speichern der Verschlüsselungskonfiguration auf dem Remote Gerät. Die Konfiguration wurde nicht gespeichert.
Die Verschlüsselungskonfiguration wurde erfolgreich am Server gespeichert. | TEXT | Der Remote zenSysSrv meldet, dass die Verschlüsselungskonfiguration erfolgreich gespeichert wurde.
Die Version des Remote zenSysSrv ist zu niedrig! Die Verschlüsselung kann nicht konfiguriert werden! | ERROR | Es wurde versucht, die Verschlüsselung auf einem Remote Gerät, dessen zenSysSrv eine Version vor 7.00 SP0 hat, zu konfigurieren. Die Verschlüsselung steht erst ab zenon Version 7.00 SP0 zur Verfügung; daher kann ein früherer zenSysSrv diese auch nicht konfigurieren.


Fehlermeldungen in Log-Dateien

Handbuch -> Netzwerk -> Starke Verschlüsselung der Netzwerkkommunikation -> Fehlermeldungen -> Fehlermeldungen in Log-Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Verschlüsselung

Fehler im verschlüsselten Netzwerkverkehr werden in Log-Einträgen dokumentiert. Die Error-IDs der Fehlermeldungen in der nachfolgenden Tabelle sind System- oder COM-Error-Codes. Nähere Informationen dazu finden Sie in der MSDN Library.

LOG Eintrag

Level

Erklärung

NET Error During Acquiring Cryptography Context [Error-ID]

ERRORS

Das Erzeugen eines Service Providers für die Verschlüsselung ist fehlgeschlagen.

NET Error During Creating Hash [Error-ID]

ERRORS

Das Erstellen eines Hash-Wertes ist fehlgeschlagen.

NET Error During Using Hash [Error-ID]

ERRORS

Das Verarbeiten eines Hash-Wertes ist fehlgeschlagen.

NET Error During Destroying Hash [Error-ID]

ERRORS

Das Freigeben eines nicht mehr benötigten Hashwertes ist fehlgeschlagen.

NET Error During Deriving Key [Error-ID]

ERRORS

Das Erstellen des Schlüssels für die symmetrische Verschlüsselung ist fehlgeschlagen.

NET Error During Configuring Key [Error-ID]

ERRORS

Das Setzen der Parameter für die symmetrische Verschlüsselung ist fehlgeschlagen.

NET Error Cryptography Not Initialized!

ERRORS

Eine Ver- oder Entschlüsselungsfunktion wurde aufgerufen, das Initialisieren der benötigten Parameter (Service Provider, Schlüssel) ist aber fehlgeschlagen.

NET Error Invalid Pointer passed!

ERRORS

Einer Ver- oder Entschlüsselungsfunktion wurden ungültige Parameter übergeben.

NET Error Message Length Must Not Be 0!

ERRORS

Die Ver- oder Entschlüsselungsfunktion wurde mit einer leeren Nachricht aufgerufen.

NET Error During Buffer Length Calaulation [Error-ID]

ERRORS

Die Berechnung der benötigten Puffergröße für die Verschlüsselung ist fehlgeschlagen.

NET Error Buffer Length Must Not Be 0!

ERRORS

Der zur Ver- oder Entschlüsselung übergebene Puffer ist nicht angelegt worden.

NET Error During Decryption 0x%x

ERRORS

Bei der Entschlüsselung ist ein Fehler aufgetreten.

NET Error During Encryption 0x%x

ERRORS

Bei der Verschlüsselung ist ein Fehler aufgetreten.

NET Error: Encryption Is Required And Project [Projekt] Received Plaintext Network Message

ERRORS

Die Verschlüsselung ist aktiv und eine unverschlüsselte Nachricht wurde empfangen. Die Nachricht wird in diesem Fall verworfen.

NET Error: Encryption Is Not Supported And Project [Projekt] Received Encrypted Network Message

ERRORS

Die Verschlüsselung ist nicht aktiv und eine verschlüsselte Nachricht wurde empfangen. Die Nachricht wird in diesem Fall verworfen.

NET Cryptography Successfully Initialized

DEBUG

Die zur Ver- und Entschlüsselung benötigten Parameter wurden erfolgreich initialisiert. Die Parameter werden beim Starten der Runtime initialisiert.

NET Uninitializing Cryptography

DEBUG

Die zur Ver- und Entschlüsselung benötigten Parameter werden freigegeben. Dies geschieht beim Beenden der Runtime. Wird die Log-Verbindung vor dem Freigeben getrennt, erscheint die Nachricht nicht im Diagnose Viewer

NET Error During Buffer Size Calculation [Error ID]

ERRORS

Beim Berechnen der notwendigen Puffergröße für das Zusammenstellen der Informationen für die Ver- oder Entschlüsselung des Netzwerkpassworts ist ein Fehler aufgetreten.

NET Error During Buffer Size Calculation: No Adapters

ERRORS

Der Rechner verfügt über keinen Netzwerkadapter. Daher kann das Netzwerkpasswort nicht ver- oder entschlüsselt werden.

NET Error During Adapter Info Query [Error ID]

ERRORS

Beim Auslesen der Adapterinformationen für die Ver- oder Entschlüsselung des Netzwerkpassworts ist ein Fehler aufgetreten.

NET Error Passwort Not Properly Formatted

ERRORS

Der HexDump des verschlüsselten Netzwerkpassworts ist in einem ungültigen Format.

NET Error During Decrypting Password [Error ID]

ERRORS

Beim Entschlüsseln des Netzwerkpassworts ist ein Fehler aufgetreten.

NET Error During Encrypting Password [Error ID]

ERRORS

Beim Verschlüsseln des Netzwerkpassworts ist ein Fehler aufgetreten.

NET Cryptography Is Disabled

DEBUG

Die Verschlüsselung des Netzwerkverkehrs ist deaktiviert.

NET Error No Password

ERRORS

Die Verschlüsselung ist aktiv, aber es ist kein Passwort eingetragen.

NET Error Password Could Not Be Decrypted

ERRORS

Das Passwort für die Netzwerkverschlüsselung konnte nicht entschlüsselt werden.

NET Password successfully loaded

DEBUG

Das Passwort für die Netzwerkverschlüsselung wurde erfolgreich geladen.

Network Cryptography Disabled By Remote Configuration

DEBUG

Der zenSysSrv meldet, dass die Verschlüsselung des Netzwerkverkehrs auf dem Rechner durch die Remote Transport Konfiguration deaktiviert wurde.

Network Cryptography Enabled By Remote Configuration

DEBUG

Der zenSysSrv meldet, dass die Verschlüsselung des Netzwerkverkehrs auf dem Rechner durch die Remote Transport Konfiguration aktiviert wurde.

Network Cryptography Remote Configuration Error

ERRORS

Eine von Remote Transport gesendete Konfiguration für die Netzwerkverschlüsselung ist fehlerhaft.

Error During Buffer Size Calculation [Error ID]

ERRORS

Beim Berechnen der notwendigen Puffergröße für das Zusammenstellen der Informationen für die Ver- oder Entschlüsselung des Netzwerkpasswortes für die Konfiguration über Remote Transport ist ein Fehler aufgetreten.

Error During Buffer Size Calculation: No Adapters

ERRORS

Der Rechner verfügt über keinen Netzwerkadapter. Daher kann das Netzwerkpasswort nicht ver- oder entschlüsselt und daher nicht per Remote Transport (muss dann wohl über COM verbunden sein) gesetzt werden. Die Verwendung der Netzwerkverschlüsselung auf einem Rechner ohne Netzwerkadapter ist jedoch sinnlos.

Error During Adapter Info Query [Error ID]

ERRORS

Beim Auslesen der Adapterinformationen für die Ver- oder Entschlüsselung des Netzwerkpassworts für die Konfiguration über Remote Transport ist ein Fehler aufgetreten.

NET Error During Decrypting Password: The Password is Invalid!

ERRORS

Das Passwort ist nicht mehr gültig, da sich die

Ausgangsdaten für die rechnerabhängige Verschlüsselung geändert haben.

Dieser Fehler kann durch erneutes Konfigurieren des Passwortes behoben werden.

Meistens wird der Entschlüsselungsprozess jedoch vor der Gültigkeitsprüfung des Passwortes bereits abgebrochen, da sich das alte Passwort mit den neuen Entschlüsselungsdaten nicht entschlüsseln lässt.

Das führt zum Fehler „NET Error During Decrypting Password 0x80090005", welcher statt „NET Error During Decrypting Password: The Password is Invalid!" angezeigt wird. In weiterer Folge führt ein ungültig gewordenes Passwort auf dem betroffenen Rechner beim Versenden und Empfangen von Netzwerkpaketen zu Fehlermeldungen. Die Fehlermeldung „NET Error Cryptography Not Initialized!" wird in die Log-Datei geschrieben.


Remote Transport im Netzwerk

Handbuch -> Netzwerk -> Remote Transport im Netzwerk

Mit Remote Transport werden Dateien zu anderen Rechnern übertragen. Grundlagen und Details zum Remote Transport finden Sie im Handbuch Remote Transport.

Über die Symbolleiste Remote Transport steuern Sie die Aktionen. Die Einstellungen zu Verbindung und zu übertragenden Dateien treffen Sie in den Projekteinstellungen. Die Pfade des Entwicklungsrechners müssen den Pfaden der Runtime-Rechner zugeordnet werden. Damit ist auch das Aktualisieren der Runtime-Dateien bei laufendem Projekt möglich. Die aktualisierten Dateien werden mittels der Funktion Nachladen in das laufende Projekt übernommen.

Hinweis: Für Verbindungen zu CE-Geräten siehe Abschnitt Windows CE im Handbuch Remote Transport.

Verbindung erstellen und Speicherort auswählen

  1. Öffnen Sie in den Projekteigenschaften den Knoten Allgemein.

    Interne ID: Remote Transport im Netzwerk

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Klicken Sie auf die Eigenschaft Remote-Transport.

    Interne ID: Remote Transport im Netzwerk

    Remote-Transport

    Der Konfigurationsdialog für den Remote Transport wird geöffnet.
    Der Remote Transport dient dem transportieren, nachladen, starten und beenden eines Projekts auf einem entfernten Rechner und dem anfordern des aktuellen Status.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Der Dialog Remote Transport wird geöffnet.

Parameter

Beschreibung

Transportmedium

Seriell

Übertragung über eine serielle Verbindung, z.B. auf ein CE Terminal.
  • Port

Auswahl des COM-Ports für die serielle Verbindung.

TCP/IP

Übertragung per TCP/IP in einem Netzwerk oder über ein Modem.
  • Rechnername oder IP-Adresse

Der Rechnername oder die TCP/IP Adresse wird als Ziel angegeben:

  • Eingabe des Rechnernamens manuell oder über Klick auf Schaltfläche ...
  • Eingabe der IP-Adresse manuell

Die IP-Adresse muss dem Format der eingestellten IP-Version (IPv4 oder IPv6) entsprechen.

Hinweis: Bei Verbindung mit Namen können auch Portnummern verwendet werden. Zum Beispiel: Runtime1;PORT=1105

Quelle/Ziel

Liste der Verbindungen.

In der ersten Zeile kann ein Ziel für den obersten Ordner der Struktur definiert werden. Rechtsklick in Zelle öffnet Kontextmenü zur Auswahl.

Achtung: Dieser Pfad muss auf dem Zielsystem permanent vorhanden sein. Also kein eingebundenes Netzlaufwerk und kein Wechseldatenträger.

aktiv

Definiert zu übertragende optionale Dateien.

Projekt-Basispfad kann nicht abgewählt werden.

Quelle

Ordner für Dateien, die übertragen werden.

Ziel

Zielordner.

Ziele für den obersten Ordner und neue Einträge können definiert werden.

Unterordner können nicht verändert werden. Damit ist sicher gestellt, dass am Zielsystem zur Runtime alle Dateien gefunden werden.

Hinweis: Der Default-Ordner ist der in den Projekteigenschaften definierte Runtime-Ordner. Wird der Zielordner manuell eingetragen, achten Sie darauf, dass er mit dem Projektnamen endet. Dies ist wichtig für die Mehrprojektverwaltung. Zum Beispiel:
C:\Users\Public\Documents\zenon_Projects\MY_PROJECT

Bearbeitung

Art der Übertragung. Kann für obersten Ordner und neue Einträge frei gewählt werden. Rechtsklick öffnet Dropdownliste:

  • Kopieren: kopiert Dateien
  • Kopieren und registrieren: kopiert Dateien und registriert sie im System. Hilfreich für ActiveX Elemente und für Schriften (ttf-Dateien).
  • Kopieren und ausführen: kopiert Dateien und führt sie dann aus

Beschreibung

Für neue Einträge optionale Texteingabe zur Beschreibung der zu übertragenden Dateien.

attention Achtung

Beim Redundanzbetrieb gilt: Wenn Treiber verwendet werden, die eine Konfigurationsdatei benötigen, muss der Eintrag \zenon\custom\drivers deaktiviert werden.

attention Achtung

Beachten Sie die Auswirkungen der Einstellungen, wenn das Projekt im Netzwerk eingesetzt wird!

Zum Beispiel:

Die Übertragung von Grafiken wird deaktiviert, weil diese schon am Server liegen. Dann wird ein Client gestartet. Der Client stellt fest, dass die Grafiken nicht übertragen werden sollen und holt sich diese daher auch nicht ab. Am Client werden dann keine Grafiken angezeigt.

Oder es werden umgekehrt Dateien zum Client übertragen, die dort vorhandene Dateien überschreiben.

Dateien zur Übertragung

Mit dem Remote Transport werden folgende Dateien ins Zielsystem übertragen. Dabei werden immer alle Dateien in den Verzeichnissen übertragen:

  1. Standard

    Alle Dateien, die sich im Runtime Verzeichnis des Projekts befinden.
    Diese Dateien bestimmen das Aussehen und Verhalten des Projekts und werden standardmäßig übertragen:

    1. alle Bilddateien (Bildname.zpp)
    2. amlcel.cmp
    3. archiv.cmp
    4. fpm.cmp
    5. functions.cmp
    6. project.cmp
    7. projekt.mdb (nicht für CE!)
    8. remas.cmp
    9. rezepturen.cmp
    10. scripts.cmp
    11. templates.cmp
    12. variables.cmp
    13. zuweisung.cmp
    14. Plus: project.ini und projekt.vba, die sich immer im Projektverzeichnis befinden

info Info

Nicht übertragen werden standardmäßig Dateien mit den Endungen:

  • .hot
  • .ho
  • .ret
  • .re
  1. Optional

    Zusätzlich müssen alle Dateien übertragen werden, die in das Projekt eingebunden wurden. Die Auswahl erfolgt über die Checkbox aktiv der Remote Transport Einstellungen. Diese Dateien befinden sich in folgenden Unterverzeichnissen des Projektverzeichnisses:

    1. \zenon\custom\graphics: für Grafiken
    2. \zenon\custom\lists: für Sprachtabellen
    3. \zenon\custom\media: für alle Mediendateien
    4. \zenon\custom\reports: für die Tabellen des Report Generators
    5. \zenon\custom\help: für Hilfedateien
    6. \zenon\custom\additional: für zusätzliche Dateien
    7. \zenon\custom\drivers: für Treiber
    8. \straton: für zenon Logic

    Empfehlung: Projekt-Basispfad, Grafiken, Sprachtabellen, Reporttabellen und Mediadateien immer übertragen.
    Aus dem Projekt-Basispfad werden standardmäßig übertragen: Die Dateien project.ini, Projekt.vba, Monitor.mon und das Verzeichnis Projekt.

    Standardmäßig werden von zenon immer Relativpfade und keine Absolutpfade verwendet, damit am Zielsystem die Dateien wiedergefunden werden.

    Für die optional zu übertragenden Dateien sollten die ursprünglichen Pfade verwendet werden (leeres Feld bei Ziel), damit diese von zenon auch am Zielsystem wieder gefunden werden.

  2. Startprojekt setzen

    Für die Runtime muss das Startprojekt in der zenon6.ini eingetragen werden. Dazu klicken Sie auf die Schaltfläche Remote Runtime Startprojekt setzen in der Symbolleiste Remote Transport. Dabei werden folgende Einträge gesetzt:

    [PATH]

    VBF30=Projektpfad

    [DEFAULT]

    DEFANWENDUNG30=Projektname

Globalprojekt

Wenn sich im Arbeitsbereich ein Globalprojekt befindet, wird dieses automatisch zum Transport angeboten. Keine zusätzlichen Einstellungen müssen getroffen werden. Es werden immer alle für das Globalprojekt notwendigen Dateien übertragen!

Remote steuern im Netzwerk

Wählen Sie im Kontextmenü des Projekts -> Remote Transport -> <Befehl>:

Parameter

Beschreibung

Verbindung aufbauen

Über den Dienst zenSysSvr wird eine Verbindung zum Zielgerät aufgebaut. Auf beiden Geräten muss der Dienst zenSysSvr bzw. auf einem CE Gerät der Dienst SysSrvCE.exe gestartet sein. Die Versionen müssen identisch sein.

Geänderte Runtime Dateien übertragen

Wird diese Einstellung ausgewählt, so werden nur die Runtime-Dateien übertragen, die sich seit der letzen Übertragung geändert haben. Sind auf dem Zielgerät keine Runtime-Dateien vorhanden, werden alle Runtime-Dateien übertragen.

Alle Runtime Dateien übertragen

Wird dieser Eintrag aktiviert, werden alle Runtime-Dateien (neu) übertragen. Ausgenommen sind die Dateien für z.B. Standard-Rezepturen oder Message-Control die explizit von der Übertragung ausgenommen wurden, über die Einstellung: 'RT Änderbare Daten'.

Alle Runtime Dateien rücklesen

Wird diese Einstellung ausgewählt, so werden alle Runtime-Dateien der Module Rezepte, Rezeptgruppen Manager, Message Control, Benutzer Verwaltung und Production and Facility Scheduler (PFS) vom Zielsystem in das lokale Runtime-Verzeichnis zurückgelesen. Anschließend können die Änderungen in der Runtime über die Option 'Importiere Runtime-Dateien im Editor eingelesen werden.

Projekt als Startprojekt setzen

Das ausgewählte Projekt wird als Startprojekt gesetzt. Bei jedem Runtime-Start wird dieses Projekt geladen.

Runtime starten

Die Runtime wird gestartet.

Runtime beenden

Die Runtime wird beendet.

Projekt nachladen

Das Projekt wird nachgeladen. Geänderte Runtime-Dateien werden eingelesen.

Betriebssystem neu starten

Das Gerät, mit dem die Verbindung besteht, wird nach einer Sicherheitsabfrage neu gestartet. Es muss gegebenenfalls neu am Betriebssystem angemeldet werden. Unter Windows CE wird diese Option nicht unterstützt.

System Status ermittlen

Es wird ermittelt, ob die Runtime auf dem Zielgerät läuft, mit welchem Status und welche zenon Version dort installiert ist. Ermittelt werden:

  • Computername
  • Betriebssystem
  • Runtime aktiv/nicht aktiv
  • Startprojekt
  • Realer Speicher
  • Laufwerke
  • Remote Seriennummer
  • Remote Aktivierungsnummer
  • Remote zenon Version

Passwort ändern und Lizenzierung anzeigen

Öffnet Dialog für Verbindungsaufbau.

Ermöglicht:

  • Änderung des Passworts
  • Anzeige und Änderung der Lizenzierung
  • Konfiguration der Verschlüsselung

Remote Desktop Verbindung starten

Startet eine Verbindung, um den Zielrechner per Remote Desktop zu bedienen.

Batch-Modus

Im Batch-Modus können mehrere Rechner gleichzeitig angesprochen werden. Dazu

  1. Erstellen Sie eine Datei hosts.txt.A-Z
  2. Tragen Sie für jeden Rechner in eine eigene Zeile die IP-Adresse ein

    Beispiel:

    HOST=192.168.0.24;
    HOST=192.168.0.15;

  3. Tragen Sie in der Zieladresse des Remote Transport ein: HOST=&hosts.txt;
  4. Fügen Sie im Verzeichnis \zenon\custom\additional die hosts.txt ein.

Starke Verschlüsselung

Informationen zur starken Verschlüsselung im Netzwerk per Remote Transport finden Sie im Kapitel Verschlüsselung aktivieren/per Remote Transport.


zenon am Terminalserver

Handbuch -> Netzwerk -> zenon am Terminalserver

Die zenon Runtime kann auch in Verbindung mit einer Terminalserver-Lösung eingesetzt werden. Der Editor ist auf einem Terminal Server nicht lauffähig.

info Info

Berücksichtigen Sie, dass der Name des Terminal-Clients aufgelöst wird. Beim Einsatz einer Firewall ist darauf zu achten, dass entsprechende Ports freigeschaltet werden.

Terminalserver werden von mehreren Herstellern angeboten. Alle Tests mit zenon erfolgten mit dem Windows Terminalserver.

attention Achtung

Für den Einsatz mit einem Terminalserver muss zenon mit einem Netzwerk-Dongle lizenziert werden.

Noch in diesem Kapitel

Arbeitsweise von Terminal Servern

Vorteile und Nachteile

Arbeitsweise zenon am Terminalserver

Erforderliche Einstellungen

Remote Desktop versus Terminal Server


Arbeitsweise von Terminal Servern

Handbuch -> Netzwerk -> zenon am Terminalserver -> Arbeitsweise von Terminal Servern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Terminal Server erlauben es, mehrere voneinander getrennte Shell-Instanzen (Desktops) auf einem Rechner (dem HOST Rechner) zu starten.

Verbindet sich ein Terminal Client mit dem Server, bekommt er seine eigene Oberfläche zugewiesen. Am Client läuft nur ein kleines Programm, das die grafischen Daten anzeigt, die vom Server gesendet werden. Alle Programme, die am Client gestartet werden, laufen am Terminal Server. Zum Client werden nur die Bildinformationen (grafische Daten) über das Netzwerk übertragen.


Vorteile und Nachteile

Handbuch -> Netzwerk -> zenon am Terminalserver -> Vorteile und Nachteile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vorteile

  • Es muss nur ein Rechner (der Terminalserver) gewartet werden.
  • Clients müssen nicht sehr performant sein (Thin Clients).
  • Clients können unterschiedliche Betriebssysteme haben (Windows 7, Windows CE, Linux, Unix usw.).
  • Hohe Datensicherheit am Client.

Nachteile

  • Alle gestarteten Programme aller Instanzen laufen auf einem Rechner (dem Terminalserver). Dieser:
    • muss ausreichend Rechnerleistung für alle gestarteten Programme bereitstellen
    • muss über ausreichend RAM für alle gestarteten Programme verfügen
  • Alle Anschlüsse müssen geteilt werden. z.B. Netzwerkadapter, COM Ports, Parallele Ports.
  • Die Netzwerkbelastung wird entsprechend hoch, da sowohl die Daten der Programme, als auch die grafischen Daten für die Clients über das Netzwerk übertragen werden..
  • Alle gestarteten Programme nutzen dasselbe Dateisystem und dieselben Dateien. Für zenon bedeutet das:
    • jeder Client erhöht den Speicherbedarf
    • die Bildauflösung wird vom ersten gestarteten Client festgelegt. Sollen Bilder in unterschiedlichen Auflösungen genutzt werden, kann dies über einen Eintrag in der zenon6.ini (SERIALIZE=0) am Terminalserver realisiert werden. Damit werden alle Bilder für jeden Client neu berechnet, was die nötige Leistung am Terminalserver weiter erhöht.


Arbeitsweise zenon am Terminalserver

Handbuch -> Netzwerk -> zenon am Terminalserver -> Arbeitsweise zenon am Terminalserver

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf einem Terminal Server kann nur ein zenon Client laufen. zenon als Server oder als Einzelplatzsystem sind nicht möglich.

Schematische Darstellung

So könnte die Topologie eines Terminal-server Netzwerkes mit zenon aussehen:

Parameter | Beschreibung
A. | zenon Runtime Server
B. | Terminal Server und n-facher Runtime Client
C. | n Terminal Clients (nur grafische Anzeige)


Erforderliche Einstellungen

Handbuch -> Netzwerk -> zenon am Terminalserver -> Erforderliche Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da die zenon Runtime als Client am Terminal Server mehrfach gestartet wird, müssen mehrere Einstellungen angepasst werden.

Allgemein

  1. INI-Eintrag

    In der zenon6.ini muss folgender Eintrag am Terminal Server hinzugefügt werden. Am Runtime Server sind keine Einstellungen erforderlich.
    [TERMINAL]
    CLIENT=1

    1: Die Runtime kann mehrfach gestartet werden, alle Einstellungen für Terminal Server Betrieb werden von der Runtime automatisch vorgenommen.
    0: Die Runtime kann nur einfach gestartet werden. Ein Betrieb am Terminal Server ist nicht möglich. (Default Einstellung)

  2. Automatische Anpassung der Bildauflösung

    Standardmäßig definiert der erste Client am Terminalserver die Bildauflösung. Diese kann über einen Eintrag in der zenon6.ini am Terminal Server angepasst werden:

    [TERMINAL]

    SERIALIZE=0

  3. Bis Version 6.21
    Der Netzwerkdienst (zennetsrv.exe) muss als Standard COM Server und nicht als Dienst registriert werden. Dafür muss das Programm von der Kommandozeile aus mit der Option -regsrv gestartet werden.
    zum Beispiel: C:/Programme/COPA-DATA/zenon700/zenNetSrv.exe -regsrv

    Anmerkung: Ab Version 6.21 ist das die default Registrierung und muss nicht mehr extra eingestellt werden.

  4. Übertragung

    Der Transportservice (zensyssrv.exe) muss als Windows Dienst registriert und gestartet werden und nicht als Standard-Exe. Dafür wird:

    1. das Programm von der Kommandozeile aus mit der Option -service gestartet.

      Zum Beispiel: C:/Programme/COPA-DATA/zenOn700/zenSysSrv.exe -service

    2. dann der Windows Dienste-Manager gestartet. Der Dienst wird bei jedem Rechnerneustart automatisch gestartet.

    Bitte beachten Sie, dass das Startup Tool und auch das Setup den Transportservice immer als Standard-EXE registrieren. Daher muss der Transportservice nach jedem Ausführen des Startup Tools bzw. nach jeder Neuinstallation wieder neu als Windows Dienst registriert werden.

  5. Runtime-Ordner

    Der Runtime Ordner muss von allen Benutzern aus beschreibbar sein. Alle Windows Benutzer (Windows-Benutzer: Jeder) im Windows Explorer müssen vollständigen Zugriff auf den Runtime-Ordner und alle Unterordner haben.

  6. zenprocess.exe umbenennen

    Wenn ein Anwender im Terminal-Betrieb die Runtime beendet, beendet die zenprocess.exe auch die Runtimes aller anderen Anwender. Um das zu verhindern, muss die Datei zenprocess.exe im Terminal-Betrieb umbenannt werden. Die zenprocess.exe wird dann nicht mehr gestartet. Die Datei befindet sich im zenon Installationsordner.

Selektives Nachladen von Einzelprojekten

Projekte können auch selektive abgeglichen werden. In diesem Fall laden Clients Projekte nur nach, wenn Projektänderungen vorliegen. Um das selektive Nachladen zu aktivieren:

  1. öffnen Sie die zenon6.ini mit einem Texteditor
  2. navigieren Sie zum Abschnitt [TERMINAL]
  3. editieren oder erstellen Sie den Eintrag: CLIENT_NO_FILE_ALIGN=
  4. mögliche Werte:

    0: Projekte werden immer von allen Clients nachgeladen

    1: selektiver Abgleich aktiv, nur der zenon Client, der in der Konsolen-Session des Terminal-Servers gestartet wird, gleicht die Runtime-Dateien mit dem zenon Server ab

Der Konsolen-Client schreibt nach nach dem Abgleich der Runtime-Dateien die Datei reloadindicator.tmp in den Ordner, der die project.ini des Projekts enthält. Die Session-Clients am Terminal-Server prüfen alle 10 Sekunden, ob diese Datei vorhanden ist. Ist sie vorhanden und ist ihr Datei-Zeitstempel neuer als der Zeitpunkt ihres letzten Nachladens, lädt ein Session-Client automatisch nach.

Eintrag zenon6.ini für selektives Nachladen

[TERMINAL]

CLIENT=1

CLIENT_NO_FILE_ALIGN=1

SERIALIZE=0


Remote Desktop versus Terminal Server

Handbuch -> Netzwerk -> zenon am Terminalserver -> Remote Desktop versus Terminal Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Terminalserver unterscheiden sich von Remote Desktop Programmen oder dem zenon Remot Desktop vor allem durch die angezeigten Informationen:

Remote Desktop | Terminalserver
Alle angeschlossenen Stationen sehen immer ein und denselben Desktop. Wenn z.B. ein Benutzer ein Programm startet, sehen alle dasselbe Programm, denselben Mauszeiger, dieselbe Tastatureingab usw. | Jede verbundene Station hat ihren eigenen Desktop - eine eigene Instanz. Nur sie sieht, was darauf passiert. Mausaktionen und Tastatureingaben betreffen nur diese eine Instanz.
 | Das bedeutet auch: In jeder Instanz kann ein Programm extra gestartet werden kann, z. B. ein Texteditor. Das Programm läuft dann auf dem Terminal Server mehrfach und benötigt damit auch mehr Ressourcen.


Netzwerktopologie verwalten und prüfen

Handbuch -> Netzwerk -> Netzwerktopologie verwalten und prüfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Netzwerktopologie wird in einer eigenen Registerkarte des Projektmanagers angezeigt. Sie besteht aus drei Bereichen:

  • Topologiebaum (links oben): zeigt aktive Projekte; das Globalprojekt wird nicht angezeigt
  • Ergebnisbaum (rechts oben): nur Resultatanzeige; repräsentiert den Topologiebaum eines ausgewählten Rechners
  • Rechnerliste (unten): Listendarstellung und Konfiguration der Rechner im Netzwerk

Noch in diesem Kapitel

Topologiebaum

Ergebnisbaum

Rechnerliste

Fehlermeldungen der Topologieprüfung


Topologiebaum

Handbuch -> Netzwerk -> Netzwerktopologie verwalten und prüfen -> Topologiebaum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Topologiebaum stellt aktive Projekte in topologischer Form dar. Angezeigt werden:

Parameter

Beschreibung

Projektname

Wird in der Registerkarte Projektbaum festgelegt und kann hier nicht geändert werden.

Netzwerk aktiv

Zeigt an, ob das Netzwerk für dieses Projekt aktiv ist. Die Einstellung kann über die Eigenschaft Netzwerk aktiv geändert werden.

Interne ID: Topologiebaum

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Server

Zeigt den für dieses Projekt definierten Server an. Die Einstellung kann über das Kontextmenü, das Symbol in der Symbolleiste oder die Eigenschaft Server geändert werden.

Interne ID: Topologiebaum

Server

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Standby

Zeigt den für dieses Projekt definierten Standby-Server an. Die Einstellung kann über das Kontextmenü, das Symbol in der Symbolleiste oder die Eigenschaft Standby geändert werden.

Interne ID: Topologiebaum

Standby

Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

Interne ID: Topologiebaum

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
Achtung: Server und Standby müssen identische Systemzeit haben.
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Symbolleiste und Kontextmenü Topologiebaum

Eigenschaft | Beschreibung
Rechner als Server setzen | Definiert den in der Rechnerliste markierten Rechner als Server für das im Topologiebaum markierte Projekt.
Rechner als Standby setzen | Definiert den in der Rechnerliste markierten Rechner als Standby-Server für das im Topologiebaum markierte Projekt.
Server löschen | Löscht den für das markierte Projekt definierten Server.
Standby löschen | Löscht den für das markierte Projekt definierten Standby-Server.
Hilfe | Öffnet die Online-Hilfe.


Ergebnisbaum

Handbuch -> Netzwerk -> Netzwerktopologie verwalten und prüfen -> Ergebnisbaum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Ergebnisbaum repräsentiert den Projektbaum des in der Rechnerliste selektierten Rechners ab dem Projekt, das für den selektierten Rechner als Startprojekt gesetzt ist, und zeigt dessen Projekteinstellungen an.

Der Ergebnisbaum ist leer, wenn:

  • das Startprojekt des selektierten Rechners nicht gefunden wurde
  • mehr als ein Rechner in der Liste selektiert wurde

Parameter

Beschreibung

Projektname

Projekte, die dem ausgewählten rechner zugewiesen sind.

Rolle

Rolle des Rechners:

  • Server
  • Standby
  • Client

Server

Name des Rechners, der zur Runtime als Server fungiert.

Standby

Name des Rechners, der zur Runtime als Standby-Server fungiert.

Überprüfungsergebnis

Zeigt detaillierte Fehlermeldungen zur Topologieprüfung an.


Rechnerliste

Handbuch -> Netzwerk -> Netzwerktopologie verwalten und prüfen -> Rechnerliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Rechnerliste zeigt alle Netzwerkteilnehmer an und ermöglicht deren Konfiguration. Die Liste bezieht sich auf den Arbeitsbereich und wird bei jeder Arbeitsbereichssicherung gesichert.

Parameter

Beschreibung

Rechnername

Name des Rechners. Kann geändert werden über

  • Klick in Zelle: Klick auf ... öffnet Dropdownliste der aktuell im Netzwerk verfügbaren Rechner.
  • Eintrag Rechner editieren in Kontextmenü oder Symbolleiste.
  • Eigenschaft Rechnername.

    Interne ID: Rechnerliste

    Rechnername

    Name des Zielrechners im Netzwerk. Klick auf Schaltfläche ... öffnet Dropdownliste mit im Netzwerk angemeldeten Rechnern.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Startprojekt

Dem Rechner zugewiesenes Startprojekt. Kann geändert werden über:

  • Klick in Zelle: Auswahl aus Dropdownliste.
  • Eintrag Startprojekt setzen in Kontextmenü oder Symbolleiste: Setzt das im Topologiebaum selektierte Projekt als Startprojekt.
  • Eigenschaft Startprojekt.

    Interne ID: Rechnerliste

    Startprojekt

    Startprojekt für den Zielrechner. Klick auf Dropdownliste öffnet Liste bereits vorhandener Projekte.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Startprojekt Runtime-Ordner

Ordner für Projektdateien des Zielrechners. Die Dateien des Startprojekts werden in diesem Ordner abgelegt, alle anderen Projekte relativ dazu, entsprechend der Struktur der eingestellten Runtime-Ordner am lokalen PC.

Interne ID: Rechnerliste

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zum Beispiel:
Startprojekt Runtime-Ordner: C:\Projekte\Top = Ablageort für Startprojekt.
Unterprojekte werden abgelegt in C:\\Projekte .

Interne ID: Rechnerliste

Startprojekt Runtime-Ordner

Runtime-Ordner des Startptrojekts am Zielrechner. Die Dateien des Startprojekts werden in diesem Ordner abgelegt, alle anderen Projekte relativ dazu, entsprechend der Struktur am lokalen PC. Verwenden Sie den Projektnamen als Ordnername, um automatisch die gleiche Struktur wie am Engineering-Rechner zu erzeugen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Tipp: Verwenden Sie den Projektnamen als Ordnername, um automatisch die gleiche Struktur wie am Engineering-Rechner zu erzeugen.

Der Startprojekt Runtime-Ordner kann geändert werden über:

  • Doppelklick auf Rechner: Öffnet Dialog zur Konfiguration des Rechners.
  • Klick in Zelle: Manueller Eintrag möglich.
  • Eigenschaft Startprojekt Runtime-Ordner.

Überprüfungsergebnis

Zeigt das Ergebnis der Topologieprüfung an.

  • In Ordnung: Alle Projekte sind fehlerfrei.
  • Fehler gefunden - Details siehe Detailansicht: Eines oder mehrere Projekte haben einen Fehler.
  • Schwerer Fehler gefunden - Details siehe Detailansicht: Ein Projekt hat einen schweren Fehler. Schwere Fehler beenden die weitere Prüfung.
  • Nicht geprüft, da ein schwerer Fehler in Struktur vorhanden ist: Rechner wurde nicht vollständig geprüft, da die Prüfung durch einen schweren Fehler beendet wurde.

Detaillierte Fehlermeldungen werden im Ergebnisbaum angezeigt.

Symbolleiste und Kontextmenü Rechnerliste

Eintrag | Beschreibung
Rechner hinzufügen... | Öffnet den Dialog zur Konfiguration der Rechner im Netzwerk.
Rechner editieren... | Öffnet den Dialog zur Konfiguration der Rechner im Netzwerk mit für diesen Rechner eingetragenen Daten.
Rechner löschen | Löscht Rechner nach Sicherheitsabfrage aus Topologie. Hinweis: Achten Sie darauf, dass das Löschen von Server oder Standby-Server zu schweren Fehlern in der Topologie führt.
Startprojekt setzen | Setzt das im Topologiebaum selektierte Projekt als Startprojekt.
Runtimedateien aller Projekte des Rechner übertragen | Überträgt alle für den ausgewählten Rechner gültigen Projekte auf den Zielrechner. Das Ergebnis wird in einem Informationsfenster angezeigt.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Dialog Konfiguration Rechner im Netz


Dialog Konfiguration Rechner im Netz

Handbuch -> Netzwerk -> Netzwerktopologie verwalten und prüfen -> Rechnerliste -> Dialog Konfiguration Rechner im Netz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Rechner im Netzwerk zu konfigurieren, sind folgende Angaben nötig:

Parameter

Beschreibung

Rechnername

Klick auf ... öffnet Dropdownliste der aktuell im Netzwerk verfügbaren Rechner.

Startprojekt

Auswahl aus Dropdownliste.

Startprojekt Runtime-Ordner:

Ordner für Projektdateien des Zielrechners. Die Dateien des Startprojekts werden in diesem Ordner abgelegt, alle anderen Projekte relativ dazu, entsprechend der Struktur der eingestellten Runtime-Ordner am lokalen PC.

Interne ID: Dialog Konfiguration Rechner im Netz

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Tipp: Verwenden Sie den Projektnamen als Ordnername, um automatisch die gleiche Struktur wie am Engineering-Rechner zu erzeugen.

Zum Beispiel:
Projektname = I-Project
Bei Startprojekt Runtime-Ordner tragen Sie ein: C:\Projects\I-Project
Die Unterprojekte werden relativ davon abgelegt in C:\Projects\Projektname, z.B.:
Der Projektname ist SubProject1, dann liegt der Runtime Ordner dafür in C:\Projects\SubProject1.

Interne ID: Dialog Konfiguration Rechner im Netz

Startprojekt Runtime-Ordner

Runtime-Ordner des Startptrojekts am Zielrechner. Die Dateien des Startprojekts werden in diesem Ordner abgelegt, alle anderen Projekte relativ dazu, entsprechend der Struktur am lokalen PC. Verwenden Sie den Projektnamen als Ordnername, um automatisch die gleiche Struktur wie am Engineering-Rechner zu erzeugen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Voraussetzung: Die Runtime-Ordner sind auf ihren Default Einstellungen belassen worden und die Projekte wurden in einer Ebene im Editor angelegt.

Ist dies nicht der Fall, kann es passieren, dass die Unterprojekte nicht übertragen werden können, da der Relativ-Ordner vom Startprojekt aus gesehen nicht erzeugbar ist.

Beispiel: Das Integrationsprojekt hat als Runtime-Ordner eingestellt: C:\Workspace\Projects\I-Project. Das Subprojekt hat als Runtime -Ordner eingestellt: C:\Subproject. Der Startprojekt Runtime-Ordner wird auf C:\Project eingestellt. Das Subprojekt kann nicht übertragen werden, weil der Relativ-Ordner wäre ..\..\Project. Das funktioniert nicht, weil der Runtime-Ordner für das Subproject dann unterhalb von C:\ liegen würde.
Abhilfe: Projekteigenschaft Runtime-Ordner richtig stellen. Am besten so, dass die Runtime Ordner für alle Projekte auf der selben Ebene liegen.


Fehlermeldungen der Topologieprüfung

Handbuch -> Netzwerk -> Netzwerktopologie verwalten und prüfen -> Fehlermeldungen der Topologieprüfung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Prüfung der Topologie wird immer ausgeführt, wenn sich Einstellungen, welche die Topologie betreffen, ändern. So kann für jede Änderung sofort deren Auswirkung beobachtet werden. Die Topologie wird auch überprüft, wenn auf die topologische Ansicht umgeschaltet wird.

Implementierte Prüfungen

  • Ist das in der Topologie definierte Projekt im Projektbaum vorhanden?
  • Wurde ein Server definiert?
  • Wurden für Standby und Server unterschiedliche Rechner definiert?
  • Kann der Client seinen Server/Standby erreichen?
  • Kann der Server seine Clients erreichen?
  • Kann der Standby seine Clients erreichen?
  • Ist der Server für ein Projekt in der Topologie vorhanden?
  • Ist der Standby für ein Projekt in der Topologie vorhanden?
  • Ist im Pfad vom Client zum Server ein Rechner mehrfach enthalten?

Nicht geprüft wird

  • Wird ein Client vom Server nur auf einem Pfad aktualisiert oder existieren mehrere Pfade?

Client zum Server

  • Erreicht der Client seinen Server über die Kette der Server?
  • Wurde ein Rechner, der routet, auf seinen Standby umgeschaltet?

    Info: Der Server muss für den Client auch über den Standby des Projekts, das routet, erreicht werden können.

Fehlermeldungen

Fehler, die bei der Topologieprüfung erkannt werden, werden im Ergebnisbaum in der Spalte Überprüfungsergebnis angezeigt.

Fehler

Ursache

Lösung

Das Startprojekt ist nicht bekannt!

Startprojekt kann nicht gefunden werden.

Projektkonfiguration richtig stellen bzw. fehlendes Projekt in Arbeitsbereich einbinden.

Der Rechner ist als Server und als Standby eingetragen!

Server und Standby-Server müssen unterschiedliche Rechner sein.

Definieren Sie unterschiedliche Rechner als Server und Standby-Server.

Es ist kein Rechner als Server eingetragen!

Das Projekt ist ein Netzwerkprojekt, es wurde aber kein Server projektiert.

Definieren Sie einen Rechner als Server.

Das Projekt wird auf Rechner (Name) nicht gestartet! Das ist aber erfoderlich, da in höheren Hierarchiebenen darauf zugegriffen wird.

Das Projekt ist auf dem genannten Rechner nicht geladen. Das Projekt wird aber über diesen geroutet.

Topologie bzw. Startprojekt für den Rechner anpassen oder die Eigenschaft Routing aktiv deaktivieren.

Interne ID: Fehlermeldungen der Topologieprüfung

Routing aktiv

Aktiv: Der Rechner fungiert als Knotenrechner und kann Pakete routen. Dabei laufen alle Netzwerkpakete von außerhalb über diesen Rechner.
Diese Einstellung kann zu Engpässen führen und beeinflusst die möglichen Netzwerktopologien . Ein Einsatz ist in speziellen Netzwerkkonstellationen sinnvoll, z.B. bei WAN-Netzwerken oder gerouteten Netzwerken. Es wird daher empfohlen, die Einstellung zu deaktivieren.

Default: inaktiv

Mehr im Online Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zirkularer Zugriff auf den Server: Der Rechner (Name)verweist wieder auf den Client (Name)!

Der Routingpfad vom Client zum Server läuft im Kreis. Der Rechner, der als Knoten fungiert, verweist wieder auf den Client.

Topologie bzw. Startprojekt für den Rechner anpassen oder die Eigenschaft Routing aktiv deaktivieren.

Zirkularer Zugriff auf den Standby: Der Rechner (Name)verweist wieder auf (Name)!

Der Routingpfad vom Client zum Standby läuft im Kreis. Der Rechner, der als Knoten fungiert, verweist wieder auf den Client.

Topologie bzw. Startprojekt für den Rechner anpassen oder die Eigenschaft Routing aktiv deaktivieren.

Der Rechner (Name) ist in der Liste der Rechner nicht enthalten

Rechner fehlt in der Liste der rechner für die Topologie.

Rechner zur Topologie hinzufügen.

Nicht geprüft, da ein schwerer Fehler in der Topologie vorhanden ist

Aufgrund eines schwerwiegenden Fehlers wurde keine Prüfung vorgenommen.

Schwerwiegenden Fehler beseitigen.

Zirkularer Zugriffspfad: (Rechnernamen)

Der Routingpfad vom Client zu seinem Server/Standby läuft im Kreis.

Das Feld „Rechnernamen" enthält die Namen der Rechner, die beteiligt sind.

Aufbau: Der erste Rechner ist immer der Client. Das Trennzeichen zwischen den Rechnernamen gibt an, ob der folgende Rechner Server oder Standby ist.

  • > kennzeichnet den folgenden Rechner als Server.
  • „+" kennzeichnet den folgenden Rechner als Standby.

Z.B.: Rechner1+Rechner2>Rechner3

Topologie bzw. Startprojekt für den Rechner anpassen oder die Eigenschaft Routing aktiv deaktivieren.

Es ist ein zirkularer Zugriff vom Server zum Client vorhanden!

Bei der Suche des Client-Rechners entsprechend der Knoten wird er Server gefunden.

Topologie bzw. Startprojekt für den Rechner anpassen oder die Eigenschaft Routing aktiv deaktivieren.

Der Server (Name) erreicht diesen Client nicht!

Der Pfad vom angegeben Server zum Client ist nicht geschlossen. Der Client ist in der Client-Liste am Server enthalten, wird jedoch nicht aktualisiert. (Die blauen Punkte verschwinden am Client nicht.)

Topologie bzw. Startprojekt für den Rechner anpassen oder die Eigenschaft Routing aktiv deaktivieren.


Redundanz

Handbuch -> Netzwerk -> Redundanz

Redundanz sorgt dafür, dass auch bei einem Serverausfall Prozesse nicht unterbrochen werden und keine Datenverluste entstehen. Bei redundanten Systemen wird unterschieden zwischen:

  • Software-Redundanz: Nur der Server schreibt auf die Steuerung. Der Standby hat nur lesenden Zugriff.
  • Hardware-Redundanz: Steuerungen sind ebenfalls redundant ausgelegt. Standby schreibt auf Standby-Steuerung.

Die Auswahl dazu treffen Sie bei der Konfiguration des Standby-Servers.

info Info

Redundanz steht unter zenon Operator nicht zur Verfügung. Redundanzeinstellungen werden ignoriert.

Software-Redundanz

Software-Redundanz besteht aus: einer Steuerung und zwei redundanten Rechnern (Server und Standby-Server).

Im Betrieb kommuniziert der Server bidirektional mit der Steuerung, der Standby kommuniziert lesend mit der Steuerung. Der Standby synchronisiert sich mit dem Server.

Beim Ausfall des Servers:

  • stuft sich der Standby zum Server hoch
  • sorgt die stoßfreie Redundanz für lückenlosen Datenbestand auch während der Totzeit zwischen Ausfall und Umschaltung
  • kommuniziert der Standby als Server bidirektional mit der Steuerung

Hardware-Redundanz

Software-Redundanz besteht aus: zwei redundanten Steuerungen und zwei redundanten Rechner (Server und Standby-Server).

Im Betrieb kommuniziert der Server bidirektional mit einer Steuerung, der Standby bidirektional mit der zweiten Steuerung. Der Standby synchronisiert sich mit dem Server, die zweite Steuerung mit der ersten Steuerung.

Beim Ausfall des Servers oder der Steuerung des Servers:

  • stuft sich der Standby zum Server hoch
  • kommuniziert der Standby als Server mit seiner Steuerung
  • sorgt die stoßfreie Redundanz für lückenlosen Datenbestand auch während der Totzeit zwischen Ausfall und Umschaltung

Redundanz mit zenon

Ausfallsicherheit durch Redundanz wird erreicht, indem jeder Projekt-Server von einem zweiten Server, den sogenannten Standby-Server, abgesichert wird.

zenon ermöglicht Ihnen die die Konfiguration von:

  • Stoßfreier Redundanz: verhindert Datenverlust bei Serverausfall, bereits mit 2 Rechner realisierbar.

    Der Standby erkennt einen Serverausfall und übernimmt automatisch die komplette Funktionalität des Servers. Um Datenverluste in der Zeitspanne zwischen Serverausfall und Erkennen des Ausfalls (Todzeit) zu verhindern, puffert der Standby alle anfallenden Daten. Nach einem Serverausfall wird dieser Puffer nachgetragen, so dass keinerlei Datenverlust entsteht.

  • Kreisredundanz: sichert mehrere Projekte gleichzeitig ab,bereits mit 3 Rechner realisierbar.

    Verbindung von stoßfreier Redundanz mit Mehrprojektveraltung.

Beide Redundanzformen können sehr einfach projektiert werden. Details zur Konfiguration redundanter Netzwerke finden Sie hier:

  • zenon Stoßfreie Redundanz
  • zenon Kreisredundanz
  • Redundanz für zenon Logic und zenon (Handbuch zenon Logic Runtime)

Für die zenon Redundanz müssen nur Server und Standby-Server definiert werden. Server und Standby Server können auch weiterhin als Bedienarbeitsplätze verwendet werden. Projektänderungen werden am Projektserver eingepflegt, der Standby Server und die angeschlossenen Clients führen den Online-Datenabgleich automatisch durch. Alle Rechner haben immer denselben Projektstand.

info Info

Steht nur eine SPS zur Verfügung, die nur Einwegkommunikation bietet, kann in den allgemeinen Einstellungen der Treiberkonfiguration die Option Am Standby-Server stoppen aktiviert werden. Damit wird der Treiber am Standby-Server gestoppt und erst beim Hochstufen wieder gestartet.

Noch in diesem Kapitel

Stoßfreie Redundanz

zenon Kreisredundanz

Redundancy Management Tool


Stoßfreie Redundanz

Handbuch -> Netzwerk -> Redundanz -> Stoßfreie Redundanz

Stoßfreie Redundanz verhindert bei Serverausfällen den Verlust von Daten. Auch die Todzeit zwischen Ausfall und Erkennen des Ausfalls wird abgesichert.

Für stoßfreie Redundanz eines Projekts benötigen Sie lediglich zwei einfache, handelsübliche PCs:

Ablauf Stoßfreie Redundanz

  • Ein Server und ein Standby-Server sind gemeinsam für ein Projekt zuständig.
  • Der Server hat wie im normalen Client-Server Netzwerk die Hoheit über alle Daten.
  • Der Standby-Server erhält alle Daten vom Server und bleibt voll bedienfähig.
  • Der Standby-Server zeichnet eigenständig alle historischen Daten wie Alarme, CEL und Archive auf und gleicht Rezepte, Benutzer, etc. mit der Server ab.
  • Da die Informationen immer vom Server kommen, sind alle Daten garantiert aktuell und konsistent.
  • Fällt der Server aus, stuft sich der Standby zum Server hoch und übernimmt alle Aufgaben. Auch in der Todzeit (zwischen Ausfall und Erkennen des Ausfalls) gehen keine Daten verloren (stoßfreie Redundanz).
  • Alle angeschlossenen Clients erfahren vom Ausfall des Servers und verbinden sich automatisch zum neuen Server.
  • Wenn der ursprüngliche Server wieder online geht
    • verbindet er sich zum Standby Server
    • gleicht die Daten ab
    • stuft sich wieder zum Server hoch.

    Auch dabei gehen keine Daten verloren.

  • Alle angeschlossenen Clients inklusive Standby ordnen sich wieder dem Server unter.

Konfiguration Stoßfreie Redundanz

  1. definieren Sie einen Standby-Server
  2. der Standby puffert ständig alle anfallenden Daten
  3. beim Ausfall des Servers übernimmt der Standby
  4. der Puffer wird nachgetragen und damit die Todzeit abgesichert

Spezielle Konstellationen in der Kommunikation von Server und Standby-Server

Beachten Sie die Kommunikationsregeln zwischen Server und Standby in folgender Konstellation:

  • der Server steht -> der Standby-Server läuft -> der Server wird gestartet -> der Server holt sich alle Runtime-Daten vom Standby

In Ausnahmefällen kann es dabei zu Konflikten kommen:

  1. Projektänderungen bei gestopptem Server
  2. Serverrolle unklar bedingt durch Netzwerkprobleme

1. Projektänderungen bei gestopptem Server

Wenn Sie währende eines Serverstillstands Änderungen im Projekt vornehmen und diese vor dem Abgleich nur auf diesem Server einspielen, werden diese Änderungen wieder überschrieben, wenn sich der Server die Daten vom Standby holt.

Um das zu verhindern: Spielen Sie geänderte Daten vor dem Update auch am Standby ein.

2. Serverrolle unklar bedingt durch Netzwerkprobleme

In Ausnahmesituationen kann es dazu kommen, dass beide Rechner sich in der Rolle des Servers sehen. Ursache kann zum Beispiel der Verlust der Netzwerkverbindung durch Switchausfall, lockere Netzwerkabel etc. sein. In diesem Fall ist die Kommunikation zwischen Server, Standby-Server und Clients abhängig vom Fehlerbild.

Wird in dieser Konstellation das Fehlerbild aufgelöst und beide Server kommunizieren wieder miteinander, dann hat der projektierte Server die Datenhoheit. Das bedeutet: Aktuelle Daten des Standby-Servers könnten überschrieben werden.

Um das zu verhindern:

  1. Überprüfen Sie immer mit der Systemvariable aktueller Server:
    Sie sehen, in welcher Rolle sich die Runtime befindet, und entdecken doppelte Server.
  2. Beenden Sie das zenon Projekt auf dem Server, der die Netzwerkverbindung verloren hat.
  3. Stellen Sie dann die Netzwerkverbindung wieder her.
  4. Starten Sie das zenon Projekt am Server neu.
  5. Das Projekt startet dann als Standby, aktualisiert seine Daten und wechselt erst dann zur Server-Rolle zurück.

Tipp: Überwachen Sie die Netzwerkverbindung mit dem Redundancy Management Tool.

Noch in diesem Kapitel

Einrichten eines Standby-Servers


Einrichten eines Standby-Servers

Handbuch -> Netzwerk -> Redundanz -> Stoßfreie Redundanz -> Einrichten eines Standby-Servers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Standby-Server einzurichten:

  1. Öffnen Sie in den Projekt-Eigenschaften im Editor die Gruppe Netzwerk.

    Interne ID: Einrichten eines Standby-Servers

    Netzwerk

    Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Tragen Sie in der Eigenschaft Standby den Namen des Rechners ein, der als redundanter Server dienen soll. (Der Rechner muss eine Verbindung zur Steuerung haben.)

    Interne ID: Einrichten eines Standby-Servers

    Standby

    Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
    Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

    Interne ID: Einrichten eines Standby-Servers

    Timeout [s]

    Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

    Interne ID: Einrichten eines Standby-Servers

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
    Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

    Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Einrichten eines Standby-Servers

    Server

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

    Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
    Achtung: Server und Standby müssen identische Systemzeit haben.
    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Sie können den Rechnernamen eintragen:

    1. durch Auswahl aus Dropdownliste nach Klick auf die Schaltfläche ...
    2. von Hand eintippen

wählen Sie in der Eigenschaft Redundanztyp die gewünschte Redundanzform aus der Dropdownliste aus:

Interne ID: Einrichten eines Standby-Servers

Redundanztyp

Nur verfügbar, wenn bei der Eigenschaft Standby ein Rechner eingetragen wurde.

zenon unterstützt zwei Redundanztypen:

Softwareredundanz: Das System besteht aus einer Steuerung und zwei redundanten Leitsystem-Rechnern. Beide Rechner müssen Verbindung zur Steuerung haben. Beide Rechner kommunizieren mit der Steuerung und halten gleichzeitig die Daten aus der Steuerung aktuell. Die Kommunikation zur Steuerung übernimmt der Rechner mit Server-Funktion. Der Server kommuniziert also bidirektional, der Standby unidirektional. Fällt der Server aus, übernimmt der Standby-Server die bidirektionale Kommunikation mit der Steuerung.

Hardwareredundanz: Das System besteht aus zwei redundanten Steuerungen und zwei redundanten Leitsystem-Rechnern. Jeder Rechner kommuniziert mit einer Steuerung bidirektional. Beide Rechner und beide Steuerungen gleichen ihre Daten ab. Fällt eine Komponente im ersten System aus, übernimmt das zweite System.

Default: Softwareredundanz

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Software-Redundanz:

    Das System besteht aus einer Steuerung und zwei redundanten Leitsystem-Rechnern. Beide Rechner müssen Verbindung zur Steuerung haben. Beide Rechner kommunizieren mit der Steuerung und halten gleichzeitig die Daten aus der Steuerung aktuell. Die Kommunikation zur Steuerung übernimmt der Rechner mit Server-Funktion. Der Server kommuniziert also bidirektional, der Standby unidirektional. Fällt der Server aus, übernimmt der Standby-Server die bidirektionale Kommunikation mit der Steuerung.

    Nur zenon ist redundant ausgeführt. Die Steuerung ist nicht redundant.

  • Hardware-Redundanz:

    Das System besteht aus zwei redundanten Steuerungen und zwei redundanten Leitsystem-Rechnern. Jeder Rechner kommuniziert mit einer Steuerung bidirektional. Beide Rechner und beide Steuerungen gleichen ihre Daten ab. Fällt eine Komponente im ersten System aus, übernimmt das zweite System.

    Sowohl zenon als auch Steuerung werden redundant ausgeführt.


zenon Kreisredundanz

Handbuch -> Netzwerk -> Redundanz -> zenon Kreisredundanz

Die zenon Kreisdredundanz ermöglicht die stoßfreie Redundanz mehrerer Projekte mit geringem Einsatz von Hardware. B

Normalerweise werden für jedes redundante Projekt 2 Rechner benötigt: ein Server und ein Standby. 3 Projekte benötigen damit zum Beispiel mindestens 6 Rechner. Mit der zenon Kreisredundanz genügen bereits drei Rechner, um drei Projekte abzusichern. Für jedes weitere Projekt kommt ein PC hinzu. zenon verbindet dafür die Mehrprojektverwaltung mit der stoßfreien Redundanz.

Konzept der Kreisredundanz

Kreisredundanz nutzt die Möglichkeit der Mehrprojektverwaltung: Auf einem PC können mehrere Projekte gleichzeitig laufen. Jeder PC ist einmal Server und einmal Standby für sein Nachbarprojekt, und kann auch noch Client für andere Projekte sein. So ergibt sich ein Kreis. Anstelle von zum Beispiel 4 Rechner und Lizenzen für 2 Projekte, 6 für 3 oder 8 für 4, benötigen Sie nur mehr die Hälfte.

Topologie mit drei Projekten

  • Auf Rechner 1 läuft das Projekt A als Serverprojekt und das Projekt B als Standbyprojekt.
  • Auf Rechner 2 läuft das Projekt B als Serverprojekt und das Projekt C als Standbyprojekt.
  • Auf Rechner 3 läuft das Projekt C als Serverprojekt und das Projekt A als Standbyprojekt.

    Der Kreis ist geschlossen.

  • Jeder Rechner kann gleichzeitig Client für alle Projekte sein.
  • Aufwand: 3 Rechne rund 3 Runtime-Lizenzen

Normalerweise würde man in diesem Beispiel 6 Rechner und 6 Runtime-Lizenzen benötigen. Die zenon Kreisredundanz ist selbstverständlich nicht auf drei Projekte beschränkt, sondern es können beliebig viele Projekte im Kreis zusammengeführt werden. Da die Rechner zusätzlich auch Clients anderer Projekte sein können, lässt sich auf diese Weise einfach und preiswert eine ausfallsichere, hochverfügbare Fertigungslinie realisieren.

Zeitsynchronisation bei zenon Kreisredundanz

Ist die zenon Zeitsynchronisation aktiv, bekommen der Standby und die Clients die aktuelle Zeit immer vom Server. Beim Einsatz der zenon Kreisredundanz ist das nicht sinnvoll, da die einzelnen PCs gleichzeitig Server und Standby sind. Damit würde sich zum Beispiel Rechner 1 die Zeit von Rechner 2 holen, Rechner 2 von Rechner 3 usw.

Empfehlung: Deaktivieren Sie in diesen Fall die zenon Zeitsynchronisation und führen Sie eine externe Zeitsynchronisation durch. Eine Anleitung dazu finden Sie im Abschnitt Zeitsynchronisation im Netzwerk.


Redundancy Management Tool

Handbuch -> Netzwerk -> Redundanz -> Redundancy Management Tool

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Redundancy Management Tool überwacht den Netzwerkadapter und dessen Verbindung zum Netzwerk. Verliert das Gerät die Verbindung zum Netzwerk, zum Beispiel durch Entfernen des Netzwerkkabels, stoppt das Redundancy Management Tool die Runtime. Dieser Vorgang kann vom Bediener innerhalb einer konfigurierbaren Zeitspanne abgebrochen werden. Wird die Verbindung zum Netzwerk wieder hergestellt, startet das Redundancy Management Tool die Runtime erneut.

Start und Konfiguration

Das Redundancy Management Tool kann als Dialog oder per Kommandozeile konfiguriert werden.

Um den Dialog zu öffnen,stehen drei Wege zur Verfügung:

  • Aus dem Windows Startordner: Start -> Alle Programme -> COPA-DATA -> Tools -> Redundancy Management Tool
  • Über das Startup Tool: Tools -> zenon_redman
  • Direktstart der Datei zenon_redman.exe aus dem zenon Programmordner

Nach dem Start wird das Redundancy Management Tool als Symbol im rechten Bereich der Windows Taskleiste angezeigt. Doppelklick auf das Symbol öffnet den Konfigurationsdialog:

Parameter

Beschreibung

Status

Status des Netzwerkadapters.

Network adapter connection state

Information über den Status:

  • Connected: Verbindung zum Netzwerk besteht.
  • Disconnected: Verbindung zum Netzwerk wurde unterbrochen.

Runtime state

Status der zenon Runtime

  • Running: Runtime läuft.
  • Stopped by Redundancy Management Tool: Runtime wurde vom Tool beendet.
  • Stopped: Runtime läuft nicht.

Settings

Einstellungen.

Monitored network adapter

Auswahl des zu überwachenden Netzwerkadapters aus Dropdownliste. Liste zeigt alle im Gerät gefundenen Adapter an.

Runtime shutdown delay

Einstellung der Verzögerungszeit in Sekunden vor dem Beenden der Runtime. In dieser Zeitspanne kann der Bediener das Beenden der Runtime unterbrechen.

  • Maximaler Wert: 2147483647 s.
    Werte darüber werden als 0 interpretiert.

Apply

Übernimmt Einstellungen, schreibt Werte in die INI-Datei und schließt Dialog.

INI-Datei

Bei der Konfiguration über den Dialog wird im Pfad %ProgramData%\COPA-DATA\System die Datei RedMan.ini angelegt. Sie enthält folgende Einträge.

Parameter | Beschreibung
[DEFAULT] |
ADAPTER= | Gewählte LAN-Verbindung-
DELAY= | Wert für Verzögerungszeit.

Kommandozeile

Das Redundancy Management Tool kann auch über die Kommandozeile gestartet werden.

Mögliche Parameter:

  • ADAPTER=‘Name‘: Legt den zu überwachenden Netzwerkadapter fest.
  • DELAY=‘Sekunden‘: Gibt die Wartezeit nach Verbindungsausfall an.
    Maximaler Wert: 2147483647. Werte darüber werden als 0 interpretiert.
  • HELP,?: Zeigt Hilfe zu den Kommandozeilenparametern an

info Info

Bei der Konfiguration über Kommandozeile:

  • werden diese Einstellungen direkt übernommen
  • wird die Konfiguration im Dialog deaktiviert
  • wird keine INI-Datei geschrieben

Im Runtime-Betrieb

Während des Runtime-Betriebs überwacht das Redundancy Management Tool kontinuierlich die Netzwerkverbindung. Wird die Verbindung unterbrochen, zeigt das Redundancy Management Tool eine Warnmeldung an und beendet die Runtime nach der konfigurierten Verzögerungszeit.

Sobald die Verbindung wieder verfügbar ist, startet das Redundancy Management Tool die Runtimewieder.

Klick auf die Schaltfläche Cancel unterbricht den Countdown und verhindert das Beenden der Runtime. Wird die Verbindung wiederhergestellt, dann wird bei einem erneuten Ausfall der Dialog wieder angezeigt. Der Benutzer kann erneut abbrechen oder das Tool die Runtime beenden lassen.

Der aktuelle Status der Verbindung und der Runtime wird auch im Konfigurationsdialog immer angezeigt:

Fehlerbehandlung

Fehlermeldungen

Fehler werden durch Popup-Meldungen angezeigt:

Meldung | Bedeutung
GetAdapterAddresses not supported on this patform! Error code '%u'! | Betriebssystemversion wird nicht unterstützt
GetAdapterAddresses did not return information about network adapters. Error code '%u'! | Keine Netzwerkadapter gefunden.

LOG-Dateien des Diagnosis Viewers

In den LOG-Dateien des Dignosis Viewer werden dokumentiert:

Eintrag | Debug Level | Bedeutung
Network link '%s' down for '%u' seconds. zenon runtime will be terminated. | Fehler | Netzwerkverbindung ausgefallen: Die Runtime wird beendet.
Network link '%s' is up. Restarting zenon runtime now. | Information | Netzwerkverbindung wieder verfügbar: Die Runtime wird neu gestartet


Routing

Handbuch -> Netzwerk -> Routing

Beim Routing werden die Pakete der untergeordneten Projekte über den Server vom ersten Client Projekt (ECP) im Zweig gesendet.

  • Anwendungsbeispiel: Kann in einer Konstellation von mehreren Rechnern nicht jeder Rechner jeden anderen erreichen, muss ein Rechner als Router agieren.
  • Technische Umsetzung: Der Server und der Standby der untergelagerten Projekte werden auf den des ECP abgeändert; das ist der zur Laufzeit aktive Server/Standby.

    Interne ID: Routing

    Standby

    Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
    Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

    Interne ID: Routing

    Timeout [s]

    Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

    Interne ID: Routing

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
    Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

    Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
    Achtung: Server und Standby müssen identische Systemzeit haben.
    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Routing

    Server

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

    Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Routing allgemein

Basisregeln

Zwei grundlegende Regeln sollten bei der Projektierung von Netzwerkstrukturen mit Routing beachtet werden. Sollte einer dieser Regeln nicht eingehalten werden, kann es abhängig von der jeweiligen Struktur zu Kommunikationsproblemen oder anderen unerwünschten Effekten kommen.

  • Regel 1: Server und Ebenen
    Ein Computer der als Server agiert, darf nur innerhalb einer Ebene (Kreisredundanz) mehrfach als Server bzw. Standby verwendet werden. In einer Ebene darüber oder darunter darf er nicht mehr als Server definiert werden!
  • Regel 2: Einzelplatz-Projekte

    Ist das Startprojekt ein Einzelplatz-Projekt, dann kann darunter nur eine einzige Ebene von Netzwerk-Projekten verwendet werden.

Client sendet zu seinem Server

  • Der Client sendet das Paket zu dem im Projekt zur Runtime aktiven Server.
  • Ist das Projekt auf diesem Rechner nicht Server, wird das Paket solange weitergesendet, bis es am Server angekommen.
  • Diese Funktionalität wird durch ein Integrationsprojekt nicht beeinflusst.

Server sendet zu einem Client mit Routing

  1. Wenn der Server eine direkte Clientverbindung zum Client hat, wird das Paket dorthin gesendet.
  2. Wenn keine Clientverbindung zum Zielrechner besteht, sendet der Server das Paket zu allen Rechnern auf denen ein Projekt läuft, wofür er Server ist.
  3. Wenn der Knoten eine direkte Clientverbindung zum Client hat, wird das Paket dorthin gesendet.
  4. Wenn der Rechner als Knoten fungiert, dann wird das Paket zu allen Rechnern, die sich zum Knotenrechner verbunden haben gesendet. Wenn der Zielrechner gleich dem Quellrechner ist, wird das Paket nicht weiter gesendet.
  5. Der Ablauf wird bei Punkt 3 weitergeführt.

Hinweis: Die Punkte 2 und 4 werden nur ausgeführt, wenn auf diesen Rechnern das Routing aktiv ist.

info Info

Server und Standby muss auf den Client-Rechnern nicht den projektierten entsprechen, sondern können sich je nach Netzwerktopologie auf dem jeweiligen Rechner ändern.

Was ist eine Clientverbindung?

Als Clientverbindung wird eine Netzservice-Verbindung bezeichnet, die durch einen Client zum prozessführenden Server oder Standby aufgebaut wird. Erkennbar ist das daran, dass die Verbindung zum Port 1100 am Zielrechner besteht.

attention Achtung

Es ist nicht garantiert, das ein zu einer funktionsfähig definierten Topologie hinzugefügter reiner Client-Rechner funktionieren wird. Speziell auf reinen Client-Rechner kann sich durch das Routing ergeben, dass manche Projekte durch den Server nicht erreicht werden können.

Regeln für Routing vor zenon 6.50:

  1. Das erste Client Netzwerkprojekt eines Zweiges auf einen PC definiert für alle untergeordneten Projekte im Zweig den Server und den Standby. Das gilt auch
    • wenn ein untergeordnetes Projekt auf diesem PC Server oder Standby wäre
    • für Projekte, die eigentlich keinen Standby-Server haben
  2. Wenn das übergeordnete Projekt kein Netzwerkprojekt ist oder kein Server, werden die Zweige der Unterprojekte des Startprojektes parallel betrachtet. Damit können unterschiedliche Rechner Server für die Unterprojekte sein. Für die Zweige gelten die Regeln aus Punkt 1.
  3. Einzelplatzprojekte werden für die Topologie nicht beachtet, ausgenommen das Startprojekt.
  4. Wenn das Startprojekt nicht Server ist (also Einzelplatz, Client oder Standby nicht prozessführend), wird im Netzservice das Routing nicht aktiviert. Das betrifft nur die Richtung vom Server zum Client.

Regeln für Routing ab zenon 6.50:

Standardmäßig ist ab Version 6.50 die Eigenschaft Routing aktiv deaktiviert.

Interne ID: Routing

Routing aktiv

Aktiv: Der Rechner fungiert als Knotenrechner und kann Pakete routen. Dabei laufen alle Netzwerkpakete von außerhalb über diesen Rechner.
Diese Einstellung kann zu Engpässen führen und beeinflusst die möglichen Netzwerktopologien . Ein Einsatz ist in speziellen Netzwerkkonstellationen sinnvoll, z.B. bei WAN-Netzwerken oder gerouteten Netzwerken. Es wird daher empfohlen, die Einstellung zu deaktivieren.

Default: inaktiv

Mehr im Online Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Ohne Routing

Wenn beim Startprojekt am Rechner die Eigenschaft Routing aktiv nicht aktiv ist, wird nicht geroutet. Jedes Projekt verbindet sich dann zum entsprechenden Rechner, wo es Server ist, direkt. Der Rechner ist dann kein Knoten und Pakete werden von diesem auch nicht geroutet.

Mit Routing

Die Regeln wie vor 6.50 bleiben gültig.

Ausnahme:

  • Ein Projekt, das auf dem Rechner Server oder Standby ist, bleibt Server oder Standby, auch wenn das übergeordnete Projekt einen anderen Server oder Standby verwendet.

Routing überprüfen

Um Routingeinstellungen zu überprüfen, verwenden Sie die Vorgangsweise aus "Netzwerktopologie verwalten".

Noch in diesem Kapitel

Beispiel für Routing


Beispiel für Routing

Handbuch -> Netzwerk -> Routing -> Beispiel für Routing

Routing für:

  • PC3 P1 + P1_1 über PC1
  • PC1/P1_1 über PC2

Ausgangslage

Die folgende Grafik enthält die Rechner, die darauf laufenden Projekte und die projektierten Servernamen.

  • PC1 ... PC4 = Rechner 1 bis 4
  • Px = Projekt-Nummer
  • IPRJ = Integrationsprojekt
  • S = Server
  • CL = Client

Server zur Runtime:

PC1 |
IPRJ | PC1
P1 | PC2
P1_1 | PC2

PC2 |
P1 | PC2
P1_1 | PC4

PC3 |
IPRJ | PC1
P1 | PC1
P1_1 | PC1

PC4 |
P1_1 | PC4

Beispiel

Wird ein Paket von PC3/P1_1 zu seinem Server gesendet, ist der Weg wie folgt:

PC3/P1_1 -> PC1 -> PC2 -> PC4

Verbindungen zwischen den Rechnern:

Client baut Verbindung auf | Server
PC3 | PC1
PC1 | PC2
PC2 | PC4


Bedienberechtigung im Netzwerk

Handbuch -> Netzwerk -> Bedienberechtigung im Netzwerk

Ein Netzwerk-Projekt kann in der Grundeinstellung von allen Stationen aus bedient werden. Bedienen bedeutet hier: Aktiv in den Prozess eingreifen, also: Werte absetzen, Rezepte ausführen, Alarme quittieren, etc.

Damit besteht die gefahr, dass zwei Benutzer auf zwei verschiedenen Stationen gleichzeitig auf dieselbe Variable einen Wert absetzen wollen. In diesem Fall:

  • werden beide Aktionen ausgeführt
  • der zuletzt eingegebene Wert überschreibt alle früheren

In zenon haben Sie die Möglichkeit, die Bedienung des Projekts jeweils nur auf einer Station zuzulassen. In diesem Fall muss sich ein Benutzer die Bedienberechtigung im Netz auf seine Station holen, bevor er das Projekt bedienen kann. Das Aufschalten von Bildern, das Lesen der Listen, etc. ist nach wie vor jederzeit auf jeder Station möglich.

Ablauf

Bei aktiver Eigenschaft Bedienberechtigung aktiv:

Interne ID: Bedienberechtigung im Netzwerk

Bedienberechtigung aktiv

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
Default: inaktiv.

Interne ID: Bedienberechtigung im Netzwerk

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Soll eine aktive Bedienung erfolgen, muss die Berechtigung geholt werden.
  • Ist die Bedienung durch einen anderen Rechner gesperrt, wird auf dem sperrenden Rechner ein Dialog geöffnet.
  • Der sperrende Benutzer kann die Berechtigung frei geben oder weiter sperren.
  • Erfolgt keine Antwort, wird die Berechtigung nach einem voreingestellten Timeout freigegeben.
  • Wird ein Verbindungsabbruch im Netzwerk erkannt, dann wird die Bedienberechtigung für diesen Rechner zurückgesetzt.

Details siehe Kapitel:

  • Bedienberechtigung konfigurieren
  • Bedienberechtigung zur Runtime

Systemvariable für die Bedienberechtigung

Die Systemvariable infomiert zur Bedienberechtigung:

  • Rechner mit der Bedienberechtigung: Rechnername, der über die Bedienberechtigung verfügt (String)
  • Bedienberechtigung hier vorhanden: Rechner besitzt die Bedienberechtigung (Bool)
  • Bedienberechtigung verweigert: Rechner fordert Bedienberechtigung an, erhält sie aber nicht (Bool)

Details siehe Kapitel Netzwerkmeldungen vom Systemtreiber.

Noch in diesem Kapitel

Bedienberechtigung konfigurieren

Bedienberechtigung zur Runtime


Bedienberechtigung konfigurieren

Handbuch -> Netzwerk -> Bedienberechtigung im Netzwerk -> Bedienberechtigung konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Bedienberechtigung im Netzwerk zu ermöglichen, müssen Sie:

  • Bedienberechtigungen aktivieren und Timeouts einstellen
  • Funktionen für die Bedienung zur Runtime projektieren
  • das Verhalten der Benutzerverwaltung im Netzwerk beachten

Bedienberechtigung aktivieren

Diese Bedienberechtigung im Netz muss in den Projekt-Eigenschaften aktiviert werden.

  • Navigieren Sie in den Projekt-Eigenschaften zur Gruppe Netzwerk.

    Interne ID: Bedienberechtigung konfigurieren

    Netzwerk

    Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Aktivieren Sie die Eigenschaft Bedienberechtigung aktiv.

    Interne ID: Bedienberechtigung konfigurieren

    Bedienberechtigung aktiv

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
    Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
    Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
    Default: inaktiv.

    Interne ID: Bedienberechtigung konfigurieren

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Legen Sie den Timeout für Abfrage [s] fest:

    Interne ID: Bedienberechtigung konfigurieren

    Timeout für Abfrage [s]

    Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
    Wird die Bedienberechtigung im Netzwerk von einer Station blockiert, kann diese von einem anderen Rechner angefordert werden. Innerhalb des hier festgelegten Zeitraums muss diese Anfrage beantwortet werden. Nach Ablauf der Frist ohne Antwort erhält die anfragende Station automatisch die Berechtigung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert den Zeitraum, in dem ein Rechner auf eine Freigabeanforderunge antworten kann. Nach Ablauf der Zeit wird die die Bedienberechtigung automatisch freigegeben.

    Default: 60 Sekunden

  • Legen Sie den Timeout für Bedienberechtigung [s] fest:

    Interne ID: Bedienberechtigung konfigurieren

    Timeout für Bedienberechtigung [s]

    Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
    Innerhalb dieses Zeitraumes muss sich der Rechner (Client), der die Bedienberechtigung besitzt, beim Server melden. Passiert das nicht, wird die Bedienberechtigung automatisch freigegeben.
    Achtung: Dieser Wert muss kleiner sein als die in der Eigenschaft Timeout [s] eingestellte Zeit.

    Interne ID: Bedienberechtigung konfigurieren

    Timeout [s]

    Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

    Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
    Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

    Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Definiert den Zeitraum, in dem sich ein Rechner, der die Bedienberechtigung besitzt, beim Server melden muss. Nach Ablauf der Zeit wird die die Bedienberechtigung automatisch freigegeben. Damit werden Verbindungsabbrüche im Netzwerk erkannt. Die Bedienberechtigung kann damit nicht durch einen unerreichbaren Rechner blockiert werden.

    Default: 60 Sekunden.

    Achtung: Wählen Sie den Zeitraum kürzer als den Netzwerk-Timeout in der Eigenschaft Timeout [s]

Funktionen für die Bedienberechtigung zur Runtime

Um sich Bedienberechtigungen zu holen oder diese frei zu geben, müssen zur Runtime entsprechende Funktionen zur Verfügung stehen. Dazu zeichnen Sie zwei Buttons, die mit den entsprechenden Funktionen belegt werden:

  • Bedienberechtigung holen: Holt Berechtigung auf den eigenen Rechner
  • Bedienberechtigung freigeben: Gibt Berechtigung ohne explizite Anfrage wieder frei

Bedienberechtigung holen

  1. Legen Sie eine neue Funktion an.
  2. Wählen Sie aus der Gruppe Netzwerk die Funktion Bedienberechtigung im Netz.
  3. Der Auswahldialog für Berechtigungen im Netz wird geöffnet.

  4. Wählen Sie holen.

Wir diese Funktion zur Runtime ausgeführt, kann die Bedienberechtigung auf die eigene Station geholt werden.

Bedienberechtigung freigeben

  1. Legen Sie eine neue Funktion an.
  2. Wählen Sie aus der Gruppe Netzwerk die Funktion Bedienberechtigung im Netz.
  3. Der Auswahldialog für Berechtigungen im Netz wird geöffnet.

  4. Wählen Sie freigeben.

Wir diese Funktion zur Runtime ausgeführt, kann die Bedienberechtigung wieder freigegeben werden.


Bedienberechtigung zur Runtime

Handbuch -> Netzwerk -> Bedienberechtigung im Netzwerk -> Bedienberechtigung zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei aktiver Eigenschaft Bedienberechtigung aktiv werden aktive Bedienhandlungen zur Runtime nur ausgeführt, wenn die Bedienberechtigung für die Station besteht.

Interne ID: Bedienberechtigung zur Runtime

Bedienberechtigung aktiv

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
Default: inaktiv.

Interne ID: Bedienberechtigung zur Runtime

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beispiel

Ein Sollwert soll auf eine Variable abgesetzt werden:

  • Der Sollwert wird nicht an die Hardware gesendet.
  • Stattdessen öffnet sich eine Meldungsbox mit der Information, dass Sie keine Bedienberechtigung für dieses Projekt besitzen.
  • Klicken Sie auf den Button zum Holen der Bedienberechtigung.

Blockiert kein anderer Rechner die Bedienberechtigung:

Ist die Berechtigung frei verfügbar:

  • erhalten Sie die Berechtigung
  • können Sie jetzt den Sollwert absetzen
  • können Sie nach der Bedienhandlung mit der Funktion Bedienberechtigung freigeben diese wieder anderen zur Verfügung stellen

Blockiert ein anderer Rechner die Bedienberechtigung:

Ist die Berechtigung blockiert:

  • wird auf dem blockierenden Rechner ein Dialog geöffnet
  • der Bediener des blockierenden Rechners muss die Bedienberechtigung explizit freigeben
    • Ja: Bedienberechtigung wird an den anderen Rechner übergeben
    • Nein: Bedienberechtigung bleibt blockiert
    • Keine Reaktion: Countdown entsprechend der in der Eigenschaft Timeout für Bedienberechtigung [s] definierten Timeout-Zeit läuft ab. Bei 00:00 wird die Bedienberechtigung automatisch freigegeben.

      Interne ID: Bedienberechtigung zur Runtime

      Timeout für Bedienberechtigung [s]

      Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
      Innerhalb dieses Zeitraumes muss sich der Rechner (Client), der die Bedienberechtigung besitzt, beim Server melden. Passiert das nicht, wird die Bedienberechtigung automatisch freigegeben.
      Achtung: Dieser Wert muss kleiner sein als die in der Eigenschaft Timeout [s] eingestellte Zeit.

      Interne ID: Bedienberechtigung zur Runtime

      Timeout [s]

      Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

      Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
      Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

      Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


zenon Funktionen im Netzwerk

Handbuch -> Netzwerk -> zenon Funktionen im Netzwerk

Beim Einsatz von Funktionen im Netzwerk muss der Ausführungsort beachtet werden. Für manche Funktionen kann der Ausführungsort frei konfiguriert werden, für andere ist dieser festgelegt.

Spezielle Funktionen für das Netzwerk sind:

  • Bedienberechtigung im Netz
  • Redundanz-Umschaltung

Noch in diesem Kapitel

Bedienberechtigung im Netz

Redundanz-Umschaltung


Bedienberechtigung im Netz

Handbuch -> Netzwerk -> zenon Funktionen im Netzwerk -> Bedienberechtigung im Netz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um sich Bedienberechtigungen zu holen oder diese frei zu geben, müssen zur Runtime entsprechende Funktionen zur Verfügung stehen. Dazu zeichnen Sie zwei Buttons, die mit den entsprechenden Funktionen belegt werden:

  • Bedienberechtigung holen: Holt Berechtigung auf den eigenen Rechner
  • Bedienberechtigung freigeben: Gibt Berechtigung ohne explizite Anfrage wieder frei

Bedienberechtigung holen

  1. Legen Sie eine neue Funktion an.
  2. Wählen Sie aus der Gruppe Netzwerk die Funktion Bedienberechtigung im Netz.
  3. Der Auswahldialog für Berechtigungen im Netz wird geöffnet.

  4. Wählen Sie holen.

Wir diese Funktion zur Runtime ausgeführt, kann die Bedienberechtigung auf die eigene Station geholt werden.

Bedienberechtigung freigeben

  1. Legen Sie eine neue Funktion an.
  2. Wählen Sie aus der Gruppe Netzwerk die Funktion Bedienberechtigung im Netz.
  3. Der Auswahldialog für Berechtigungen im Netz wird geöffnet.

  4. Wählen Sie freigeben.

Wir diese Funktion zur Runtime ausgeführt, kann die Bedienberechtigung wieder freigegeben werden.


Redundanz-Umschaltung

Handbuch -> Netzwerk -> zenon Funktionen im Netzwerk -> Redundanz-Umschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion kann zur Runtime zwischen Server und Standby-Server umgeschaltet werden. Der aktuelle Server wird damit zum Standby und umgekehrt. Der Wechsel ist permanent bis:

  • die Funktion erneut ausgeführt wird

    oder

  • Runtime-Dateien aus dem Editor nachgeladen werden

Praktische Einsatzszenarien sind zum Beispiel: Wartungsarbeiten am Server, bessere Hardware-Kopplung des Standbys usw.

info Info

Diese Funktion eignet sich nicht zum Testen der Redundanz, da das Verhalten nicht dem Verhalten bei einem Server-Ausfall entspricht.

Um die Funktion zu projektieren:

  1. Legen Sie eine neue Funktion an.
  2. Wählen Sie in der Gruppe Netzwerk die Funktion Redundanz-Umschaltung.

    (Weiter Konfigurationen sind nicht nötig.)

  3. Verknüpfen Sie die Funktion mit einem Button.


Verhalten von zenon Modulen im Netzwerk

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Netzwerkprojekten ist zu beachten, wie sich einzelne Module und Funktionen im Netzwerk verhalten.

Noch in diesem Kapitel

AML und CEL

Archivierung

Benutzerverwaltung

Dateien

Erweiterter Trend

Funktionen

Message Control

Programmierschnittstellen

Report Generator

Rezepte

Skripte

Treiber - Variablen - Rema

Zeitsteuerung

Zuweisungen


AML und CEL

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> AML und CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarmierung

Alarmierung wird vom Server verwaltet. Der Server beantwortet Anfragen der Clients zur Alarmierung. Änderungen werden zwischen Server und Standby abgeglichen.

Chronologische Ereignisliste

Die CEL wird auf dem Server verwaltet. Änderungen werden zwischen Server und Standby abgeglichen.


Archivierung

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Archivierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Archivierung wird auf dem Server ausgeführt.

Der Server synchronisiert die Archivdaten mit dem Strandby und beantwortet Anfragen der Clients.


Benutzerverwaltung

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Benutzerverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Benutzerverwaltung wird am Server verwaltet. Ablauf eines Logins:

  1. Die Login-Anfrage wird an den Server geschickt.
  2. Dieser antwortet mit der Liste der berechtigten Benutzer.
  3. Der Client verifiziert die Daten.

Werden an einem Client zur Runtime Änderungen an der Benutzerverwaltung vorgenommen, wird die vollständige Benutzerliste vom Client zum Server gesandt.


Dateien

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dateien

Beim Datenaustausch zwischen Server und Standby werden Listen für die Dateien aller Module erstellt. Der Server überwacht diese Listen auf Änderungen. Festgestellte Änderungen werden zum Standby übertragen.

attention Achtung

Während der Erstellung der Listen reagiert der Server nicht auf Watchdogs, die vom Standby geschickt werden. Beachten Sie das bei der Festlegung der Zeit für die Eigenschaft Timeout [s] in den Netzwerkeigenschaften.

Interne ID: Dateien

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: Dateien

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mit dem Remote Transport werden folgende Dateien ins Zielsystem übertragen. Dabei werden immer alle Dateien in den Verzeichnissen übertragen:

  1. Standard

    Alle Dateien, die sich im Runtime Verzeichnis des Projekts befinden.
    Diese Dateien bestimmen das Aussehen und Verhalten des Projekts und werden standardmäßig übertragen:

    1. alle Bilddateien (Bildname.zpp)
    2. amlcel.cmp
    3. archiv.cmp
    4. fpm.cmp
    5. functions.cmp
    6. project.cmp
    7. projekt.mdb (nicht für CE!)
    8. remas.cmp
    9. rezepturen.cmp
    10. scripts.cmp
    11. templates.cmp
    12. variables.cmp
    13. zuweisung.cmp
    14. Plus: project.ini und projekt.vba, die sich immer im Projektverzeichnis befinden

info Info

Nicht übertragen werden standardmäßig Dateien mit den Endungen:

  • .hot
  • .ho
  • .ret
  • .re
  1. Optional

    Zusätzlich müssen alle Dateien übertragen werden, die in das Projekt eingebunden wurden. Die Auswahl erfolgt über die Checkbox aktiv der Remote Transport Einstellungen. Diese Dateien befinden sich in folgenden Unterverzeichnissen des Projektverzeichnisses:

    1. \zenon\custom\graphics: für Grafiken
    2. \zenon\custom\lists: für Sprachtabellen
    3. \zenon\custom\media: für alle Mediendateien
    4. \zenon\custom\reports: für die Tabellen des Report Generators
    5. \zenon\custom\help: für Hilfedateien
    6. \zenon\custom\additional: für zusätzliche Dateien
    7. \zenon\custom\drivers: für Treiber
    8. \straton: für zenon Logic

    Empfehlung: Projekt-Basispfad, Grafiken, Sprachtabellen, Reporttabellen und Mediadateien immer übertragen.
    Aus dem Projekt-Basispfad werden standardmäßig übertragen: Die Dateien project.ini, Projekt.vba, Monitor.mon und das Verzeichnis Projekt.

    Standardmäßig werden von zenon immer Relativpfade und keine Absolutpfade verwendet, damit am Zielsystem die Dateien wiedergefunden werden.

    Für die optional zu übertragenden Dateien sollten die ursprünglichen Pfade verwendet werden (leeres Feld bei Ziel), damit diese von zenon auch am Zielsystem wieder gefunden werden.

  2. Startprojekt setzen

    Für die Runtime muss das Startprojekt in der zenon6.ini eingetragen werden. Dazu klicken Sie auf die Schaltfläche Remote Runtime Startprojekt setzen in der Symbolleiste Remote Transport. Dabei werden folgende Einträge gesetzt:

    [PATH]

    VBF30=Projektpfad

    [DEFAULT]

    DEFANWENDUNG30=Projektname

Globalprojekt

Wenn sich im Arbeitsbereich ein Globalprojekt befindet, wird dieses automatisch zum Transport angeboten. Keine zusätzlichen Einstellungen müssen getroffen werden. Es werden immer alle für das Globalprojekt notwendigen Dateien übertragen!

attention Achtung

Beträgt der Zeitunterschied zwischen Server und Client mehr als 5 Sekunden, werden keine Dateien mehr synchronisiert.


Erweiterter Trend

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Erweiterter Trend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Erweiterte Trend zeigt Informationen aus Archiven und von Online-Daten an. Diese Daten werden am Server gespeichert.

Der Server synchronisiert geänderte Daten mit dem Standby und beantwortet Anfragen der Clients,.


Funktionen

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Funktionen, die im Netzwerk eingesetzt werden:

  • kann der Ausführungsort in manchen Fällen frei konfiguriert werden
  • ist der Ausführungsort in manchen Fällen fest vorgegeben

info Info

Skripte bündeln mehrere Funktionen. Der Ausführungsort hängt dann ab von den Einstellungen der Funktion Skript ausführen. Diese Einstellung überschreibt die Einstellungen der einzelnen Funktionen.

Ausführungsort konfigurieren

Bei Funktionen, deren Ausführungsort frei konfiguriert werden kann, stehen bei den Eigenschaften der Funktion entsprechende Parameter zur Verfügung. Um den Ausführungsort zu definieren:

  1. Navigieren Sie in den Eigenschaften der Funktion zur Gruppe Ausführung.

    Interne ID: Funktionen

    Ausführung

    Nur verfügbar in Netzwerk-Projekten:
    Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Wählen Sie den gewünschten Ausführungsort durch Aktivierung der Checkbox aus. Mehrfachauswahl ist möglich:
    • Aktueller Rechner: Funktion wird auf dem aktuellen Rechner ausgeführt.

      Interne ID: Funktionen

      Aktueller Rechner

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf dem Rechner ausgeführt, auf dem sie angestossen wurde.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Server: Funktion wird auf dem Server ausgeführt.

      Interne ID: Funktionen

      Server

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf dem Server des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Standby: Funktion wird auf dem Server ausgeführt

      Interne ID: Funktionen

      Standby

      Nur verfügbar in redundanten Netzwerk-Projekten:
      Die Funktion wird auf dem Standby-Server des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Client: Funktion wird auf allen Clients ausgeführt.

      Interne ID: Funktionen

      Client

      Nur verfügbar in Netzwerk-Projekten:
      Die Funktion wird auf allen Clients des Projekts ausgeführt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Übersicht Funktionen im Netzwerk

Die folgende Tabelle zeigt, welche Funktionen wo ausgeführt werden.

Legende:

  • Einstellbar: Verhalten kann konfiguriert werden

    +: Ja

    -: Nein

    O: Default

  • Wenn nicht einstellbar, kennzeichnet O den Ausführungsort:
    • Aktiver Rechner
    • Server
    • Standby
    • Client

Funktion | Einstellbar | Aktueller Rechner | Server | Standby | Client
AML und CEL |  |  |  |  |
Alarme blinkquittieren | - | O |  |  |
Alarme löschen | - |  | O | O |
Alarme quittieren | - |  | O | O |
Alarm/Ereignis-Gruppe abmelden/anmelden | - | O |  |  |
Alarmmeldeliste/Alarm/Ereignis-Gruppen/Alarm/Ereignis-Klassen aktivieren/deaktivieren | - |  | O | O |
Alarmmeldeliste aktiv | - |  | O |  |
Alarmmeldeliste aktiv/inaktiv | - |  | O |  |
Alarmmeldeliste inaktiv | - |  | O |  |
AML exportieren | + | O |  |  |
AML- und CEL-Ringpuffer speichern | - |  | O | O |
CEL exportieren | + | O |  |  |
Drucken AML oder CEL | + | O |  |  |
IPA-Dokument erzeugen/drucken | - |  | O |  |
Online-Drucken ein/ausschalten | - |  | O | O |
Online-Drucken neue Seite beginnen | + | O |  |  |
Online-Drucker umschalten | - |  | O |  |
Anwendung |  |  |  |  |
Drucker wählen | + | O |  |  |
EMS starten | - |  | O |  |
EMS stoppen | - |  | O |  |
Erweiterter Trend Diagramm drucken | + | O |  |  |
Farbpalette umschalten | + | O |  |  |
Funktionen bei Grenzwerten aktiv | - |  | O | O |
Funktionen bei Grenzwerten aktiv/inaktiv | - |  | O | O |
Funktionen bei Grenzwerten inaktiv | - |  | O | O |
Hilfe aufrufen | + | O |  |  |
Nachladen | + | O |  |  |
Offene Wartungen ermitteln | - |  | O |  |
PFS - benutzerdefiniertes Ereignis anstoßen | + | O |  |  |
Projektsimulation aktivieren/deaktivieren | - | O |  |  |
Rechtsklick simulieren | + | O |  |  |
Remanentdaten speichern | + | O |  |  |
Runtime beenden | + | O |  |  |
S7-Graph Heuristik auswerten | + | O |  |  |
SAP-Funktion ausführen | + | O |  |  |
Sprachumschaltung | + | O |  |  |
Topologie - Erdschlusssuche | - |  | O |  |
Topologie - LoadShedding | - |  | O |  |
Archivserver |  |  |  |  |
Archiv beenden | - |  | O | O |
Archiv indizieren | - |  | O |  |
Archiv starten | - |  | O | O |
Archive exportieren | - | O |  |  |
Offene Archive anzeigen | - |  | O | O |
Benutzerverwaltung |  |  |  |  |
Benutzer ändern | + | O |  |  |
Login mit Dialog | + | O |  |  |
Login ohne Passwort | + | O |  |  |
Logout | + | O |  |  |
Passwort ändern | - | O |  |  |
Bilder |  |  |  |  |
ALC-Quellfarbe ändern | + | O |  |  |
Bild indiziert | - | O |  |  |
Bild schließen | + | O |  |  |
Bild zurück | - | O |  |  |
Bildmittelpunkt verschieben | + | O |  |  |
Bildumschaltung | + | O |  |  |
Eingabe auf Element mit Fokus aktivieren | +- | O |  |  |
Fokus auf Schablone setzen | + | O |  |  |
Fokus verschieben | - | O |  |  |
Fokus von Schablone nehmen | + | O |  |  |
Menü anzeigen | + | O |  |  |
Monitor zuordnen | + | O |  |  |
Runtimeprofile | + | O |  |  |
Schablone schließen | + | O |  |  |
Sollwertvorgabe für Keyboard-Bild | - | O |  |  |
Übersichtsfenster anzeigen | + | O |  |  |
Fehlerortung in elektrischen Netzen |  |  |  |  |
Erdschlussmeldung quittieren | + | O |  |  |
Erdschlusssuche beenden | + | O |  |  |
Erdschlusssuche starten | + | O |  |  |
Kurzschlussmeldung quittieren | + | O |  |  |
Message Control Hinweis: Ausführungsorte sind theoretisch frei einstellbar. Änderungen haben aber keine Auswirkung. Message Control wird immer am Server ausgeführt. |  |  |  |  |
Empfängerdatenbank anzeigen | + | O |  |  |
Sende Nachricht | + | O |  |  |
Sende Nachricht aktivieren | + | O |  |  |
Sende Nachricht deaktivieren | + | O |  |  |
Netzwerk |  |  |  |  |
Bedienberechtigung im Netz | + | O |  |  |
Redundanz Umschaltung | - |  |  | O |
Report Generator |  |  |  |  |
Drucken Report | + |  |  |  |
Report ausführen | + |  |  |  |
Report exportieren | + |  |  |  |
Rezepte |  |  |  |  |
Rezeptgruppen-Manager | - | O |  |  |
Standard-Rezept | - | O |  |  |
Standard-Rezept einzeln direkt | + | O | O | O | O
Standard-Rezept einzeln mit Auswahl | - | O |  |  |
Standard-Rezept einzeln mit Online-Auswahl | - | O |  |  |
Skript |  |  |  |  |
Skript ausführen | + | O |  |  |
Skript mit Online-Auswahl | + | O |  |  |
Variable |  |  |  |  |
Daten exportieren | - |  | O |  |
dBase Datei lesen | + | O |  |  |
Drucken Momentanwerte | + | O |  |  |
Einheitenumschaltung | + | O |  |  |
HD-Verwaltung aktiv | - |  | O | O |
HD-Verwaltung inaktiv | - |  | O | O |
HD-Verwaltung inaktiv/active | - |  | O | O |
Sollwert absetzen | - |  | O |  |
Treiberkommandos | - | O |  |  |
Treiber Simulationsabbild an Standby übertragen | - |  |  |  | O
Uhrzeit auf Variable schreiben | + | O |  |  |
Uhrzeit von Variable lesen | + | O |  |  |
VBA |  |  |  |  |
PCE-Editor öffnen | - |  | O |  |
VBA-Editor öffnen | + | O |  |  |
VBA-Makro ausführen | + | O |  |  |
VBA-Makro Dialog Anzeigen | + | O |  |  |
VSTA |  |  |  |  |
VSTA-Editor öffnen | + | O |  |  |
VSTA-Marko ausführen | + | O |  |  |
VSTA-Makro Dialog anzeigen | + | O |  |  |
Windows |  |  |  |  |
Audiodatei ausführen | + | O |  |  |
Dateioperation | + | O |  |  |
Dauerton Start | + | O |  |  |
Dauerton Stopp | + | O |  |  |
In den Hintergrund | - | O |  |  |
In den Vordergrund | - | O |  |  |
Screenshot drucken | + | O |  |  |
Starte Programm | + | O |  |  |


Message Control

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Message Control ist servergebunden.

  • Daten werden auf dem Server verwaltet.
  • Nachrichten werden immer vom Server verschickt.
  • Änderungen müssen auf dem Server durchgeführt werden.
  • Änderungen, die auf einem Client durchgeführt werden, gehen verloren.

info Info

Über die Eigenschaften in der Gruppe Ausführung bei den Funktionen, kann theoretisch ein anderer Ausführungsort als der Server definiert werden. Diese Einstellungen sind aber ohne Auswirkung. Die entsprechenden Funktionen werden weiterhin automatisch am Server ausgeführt.

Interne ID: Message Control

Ausführung

Nur verfügbar in Netzwerk-Projekten:
Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Programmierschnittstellen

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Programmierschnittstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VBA und VSTA

Code in VBA oder VSTA wird standardmäßig immer lokal auf dem System ausgeführt, auf dem er gestartet wird.

Der Ausführungsort kann aber über den Aufruf per Funktion alternativ definiert werden.

PCE

Die PCE wird immer lokal auf dem System ausgeführt, auf dem sie gestartet wird.


Report Generator

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Report Generator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die *.xrs Dateien des Report Generators werden auf allen Systemen im Netzwerk (Clients. Standby, Server) synchronisiert.

Editor

Wird die Datei im zenon Editor modifiziert und auf den Server übertragen, schickt der Server dies geänderte Datei per Push-Dienst an alle anderen Rechner im Netzwerk.

Runtime

Wird die Datei zur Runtime geändert, werden die Änderungen nur temporär gespeichert und beim nächsten Reload oder Neustart der Runtime wieder ersetzt.


Rezepte

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Rezepte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Ausführung von Rezepten unterscheidet sich für Standard-Rezepte und den RGM.

Standard-Rezepte

Standard-Rezepte werden auf Server und Standby verwaltet.

Soll zur Runtime ein Standard-Rezept durch einen Benutzer geändert werden, fordert der Client vom Server die vollständige Liste der Rezepte an. Bei Änderungen wird die Liste der Rezepte zurück zum Server geschickt.

info Info

Diese Liste ist nicht identisch mit des Datei rezepturen.cmp

Wird ein Rezept zur Runtime am Client verändert und ausgeführt, wird es mit den neuen Werten ausgeführt. Beim Beenden des Standard-Rezepts wird das Speichern der Änderungen angeboten.

Rezeptgruppen-Manager

Bei Laden des Bildes Rezeptgruppen-Manager auf dem Client wird vom Server eine Liste aller Rezeptnamen angefordert. Sobald ein Rezept ausgewählt wird, wird es vom Server geladen.


Skripte

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Skripte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Skripte bündeln mehrere Funktionen. Der Ausführungsort hängt ab von den Einstellungen der Funktion Skript ausführen. Diese Einstellung überschreibt die Einstellungen der einzelnen Funktionen.

Die Ausführung von Skripten im Netzwerk wird mit vordefinierten Kripten gesteuert:

Skript | Beschreibung | Ausführungsort
AUTOSTART | Skript wird beim Runtimestart automatisch noch vor dem Laden des Startbildschirms ausgeführt, wenn das Projekt das Runtime-Startprojekt ist. Beim Start untergeordneter Projekte wird es nicht ausgeführt. | Netzwerkprojekt: Server Einzelplatzprojekt: Aktiver Rechner
AUTOEND | Skript wird beim Beenden der Runtime automatisch ausgeführt, wenn das Projekt das Runtime-Startprojekt ist. Beim Beenden untergeordneter Projekte wird es nicht ausgeführt. | Netzwerkprojekt: Server Einzelplatzprojekt: Aktiver Rechner
AUTOSTART_CLIENT | Skript wird beim Runtimestart auf einem Client automatisch noch vor dem Laden des Startbildschirms ausgeführt, wenn das Projekt das Runtime-Startprojekt ist. Beim Start untergeordneter Projekte wird es nicht ausgeführt. | Client
AUTOEND_CLIENT | Skript wird beim Beenden der Runtime auf einem Client automatisch ausgeführt, wenn das Projekt das Runtime-Startprojekt ist. Beim Beenden untergeordneter Projekte wird es nicht ausgeführt. | Client
AUTOSTART_SRVPRJ | Skript wird beim Runtimestart eines beliebigen Projekts auf dem Projektserver automatisch noch vor dem Laden des Startbildschirms ausgeführt. | Server
AUTOSTART_SRVPRJ | Skript wird beim Beenden der Runtime eines beliebigen Projekts auf dem Projektserver automatisch ausgeführt. | Server


Treiber - Variablen - Rema

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Treiber - Variablen - Rema

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im zenon Netzwerk kommunizieren nur Treiber und Standby mit der Steuerung. Clientanfragen werden über den Server geleitet. Dieser holt die Informationen von der SPS und leitet sie an den Client weiter. Grenzwerte werden vom Server überwacht.

Treiber

Treiber werden nur am Server ausgeführt.

Interne Variablen

Bei internen Variablen kann in zenon für jede einzelne Variable festgelegt werden, ob sie lokal oder im Netzwerk berechnet wird. Dazu:

  1. navigieren Sie zum Knoten Interne Variable in den Eigenschaften der internen Variablen

    Interne ID: Treiber - Variablen - Rema

    Interne Variable

    Eigenschaften für interne Variablen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. legen Sie über die Eigenschaft Berechnung den Ausführungsort fest:

    Interne ID: Treiber - Variablen - Rema

    Berechnung

    Lokal: Die interne Variable wird bei Netzwerk-Projekten lokal d.h. auf dem Client ausgewertet bzw. verwaltet.
    D.h. der Wert der Variable kann auf jedem Client unterschiedlich sein und auch die Grenzwerte werden lokal ausgewertet.
    Netzwerk: Die interne Variable wird bei Netzwerk-Projekten auf dem Server des Projekts ausgewertet bzw. verwaltet. Sie hat auf dem Server und auf allen Clients denselben Wert.
    Default: lokal.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. Lokal: Die interne Variable wird bei Netzwerk-Projekten lokal d.h. auf dem Client ausgewertet bzw. verwaltet. Die Werte werden nicht mit anderen Rechnern im Netzwerk synchronisiert.
      Achtung: Die Grenzwerte lokal berechneter Variablen werden auch lokal überwacht. Das hat zur Folge:
      - Der Wert der Variable kann auf jedem Client unterschiedlich sein.
      - Funktionen werden ausgeführt.
      - Alarmierung funktioniert nicht, das Alarme nur vom Server verwaltet werden.
    2. Netzwerk: Die interne Variable wird bei Netzwerk-Projekten auf dem Server des Projekts ausgewertet bzw. verwaltet. Sie hat auf dem Server und auf allen Clients denselben Wert.

Funktionen und interne Variablen

  1. Berechnung im Netzwerk: Client

    Ein Grenzwert einer im Netzwerk berechneten internen Variablen löst eine Funktion aus, die auf einem Client ausgeführt werden soll. Bei der Grenzwertverletzung werden am Server folgende Log-Einträge generiert.

    Der Server ist zuständig für Grenzwertverletzungen und löst damit die Funktion auf dem Client aus.

  2. Berechnung im Netzwerk: Standby statt Client

    Ein Grenzwert einer im Netzwerk berechneten internen Variablen löst eine Funktion aus, die auf einem Client ausgeführt werden soll. Es ist allerdings kein Client verfügbar, sondern nur ein Standby. Bei der Grenzwertverletzung werden am Server folgende Log-Einträge generiert.

    Der Server behandelt den Standby als Client.

  3. Berechnung im Netzwerk: Standby

    Ein Grenzwert einer im Netzwerk berechneten internen Variablen löst eine Funktion aus, die auf einem Standby ausgeführt werden soll. Bei der Grenzwertverletzung werden am Server folgende Log-Einträge generiert.

    Der Server schickt dem Standby eine Nachricht, die Funktion auszuführen.

  4. Berechnung im Netzwerk: Client und Standby

    Ein Grenzwert einer im Netzwerk berechneten internen Variablen löst eine Funktion aus, die auf einem Client und dem Standby ausgeführt werden soll. Bei der Grenzwertverletzung werden am Server folgende Log-Einträge generiert.

    Der Server löst die Funktion auf dem Client aus und schickt dem Standby eine Nachricht, die Funktion auszuführen.

Rema

Reaktionsmatrizen werden auf Client und Server berechnet.

Wird eine Funktion über eine Rema ausgeführt, wird der Ort der Ausführung durch die Einstellungen bei der Funktion bestimmt.


Zeitsteuerung

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Zeitsteuerung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zeitsteuerung wird auf Server und Standby ausgeführt.

Die ausgelöste Funktion wird auf jenem System ausgeführt, das in den Einstellungen zur Funktionsausführung gewählt wurde.


Zuweisungen

Handbuch -> Netzwerk -> Verhalten von zenon Modulen im Netzwerk -> Zuweisungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zuweisungen werden auf dem Server ausgeführt und nur für die Ursprungsvariable.

Zuweisungen der Clients werden immer ignoriert.


Netzwerkmeldungen vom Systemtreiber

Handbuch -> Netzwerk -> Netzwerkmeldungen vom Systemtreiber

Folgende Systemtreibervariablen stehen Ihnen zu diesem Thema zur Verfügung:

Name

Datentyp

Kommentar

Aktueller Server

STRING

lokal

Rechnername des aktuell prozessführenden Servers
Wenn der Name aus der Hostsdatei bezogen wird, ist dies der dort eingetragene Name. Bei DNS ist dies der voll adressierte Rechnerdomainname (Fully Qualified Domain Name).

Hinweis: Bei deaktiviertem Netzwerk sendet die Variable den Status INVALID. Die Variable Aktueller Standby-Server bleibt dagegen leer.

Aktueller Standby-Server

STRING

lokal

Rechnername des aktuell nicht prozessführenden Servers.
Wenn der Name aus der Hostsdatei bezogen wird, ist dies der dort eingetragene Name. Bei DNS ist dies der voll adressierte Rechnerdomainname (Fully Qualified Domain Name).

Anzahl der angeschlossenen Clients

UDINT

Liefert die Anzahl der aktuell an den Server angeschlossenen Clients. Diese Anzahl beinhaltet auch einen eventuell vorhandenen Standby Server.

Bedienberechtigung verweigert

BOOL

Zeigt an, ob eine angeforderte Bedienberechtigung im Netzwerk verweigert wird. Dabei wird der Wert der Variable nur für kurze Zeit geändert und danach auf den Ausgangszustand zurückgesetzt.
0 = Anforderung Bedienberechtigung akzeptiert
1 = Anforderung Bedienberechtigung abgelehnt

Bedienberechtigung hier vorhanden (ja(1)/nein(0))

BOOL

Anzeige, ob die Bedienberechtigung für das aktuelle Projekt am lokalen Rechner vorhanden ist.
0 = Nein
1 = Ja

Bedienberechtigung: Rechner, der sie besitzt.

STRING

Zeigt den Namen des Rechners, der die Bedienberechtigung für das aktuell eingestellte Projekt besitzt.

Namen der angeschlossenen Clients

STRING

Liefert die Namen der aktuell an den Server angeschlossenen Clients. Diese beinhalten auch einen eventuell vorhandenen Standby Server.

Netz-Timeoutzeit [Millisekunden]

UDINT

Anzeige der in der Projektkonfiguration eingestellten Timeoutzeit für das zenon Netzwerk in Millisekunden.

Redundanz-Umschaltung

BOOL

Eine Binärvariable, die kurzzeitig den Wert 1 annimmt wenn vom System eine Redundanzumschaltung zwischen Server und Standby Server vorgenommen wird.
0 = keine Redundanz Umschaltung
1 = Redundanz Umschaltung

Server ausgefallen

BOOL

lokal

Zeigt an, dass die Verbindung zum prozessführenden Server verloren wurde.
Je nach Netztopologieposition des Rechners heißt das:

• Dominanter Server: In der Zeit wo er noch nicht prozessführender Server ist, wechselt der Wert auf TRUE wenn die Verbindung zum prozessführende Server abgerissen ist. Nach dem Abgleich immer FALSE.

• Nicht dominanter Server: Geht auf TRUE wenn die Verbindung zum dominanten Server, welcher prozessführend war abgerissen ist. Wechselt wieder auf FALSE wenn der SB sich zum prozessführenden Server hochgestuft hat.

AUSWERTUNG: Am besten über eine REMA, da die Alarmverwaltung sich zu diesem Zeitpunkt ebenfalls umstuft und gerade vom SB übernommen wird. Der Online Container ist auch nicht geeignet, da bei der Redundanzumschaltung die Variablen neu initialisiert werden.

• Client: Geht auf TRUE wenn die Verbindung zum prozessführenden Server abgerissen ist. Wechselt wieder auf FALSE wenn der Client sich auf den SB-Rechner, welcher nun prozessführender Server ist, angemeldet hat .

Server beendet

BOOL

lokal

Zeigt das reguläre Beenden des prozessführenden Servers an.
Wechselt den Wert auf TRUE wenn der prozessführende Server regulär beendet wurde. Ist FALSE wenn ein prozessführender Server im Netz ist.

Je nach Netztopologieposition des Rechners heißt das:

• Dominanter Server: In der Zeit wo er noch nicht prozessführender Server ist, wechselt der Wert auf TRUE wenn sich der prozessführende Server beendet hat.

• Nicht dominanter Server: Geht auf TRUE wenn der dominante Server, welcher prozessführend ist, sich beendet hat. Wechselt wieder auf FALSE wenn der SB sich zum prozessführenden Server hochgestuft hat.

AUSWERTUNG: Am besten über eine REMA, da die Alarmverwaltung sich zu diesem Zeitpunkt ebenfalls umstuft und gerade vom SB übernommen wird. Der Online Container ist auch nicht geeignet, da bei der Redundanzumschaltung die Variablen neu initialisiert werden.

• Client: Geht auf TRUE wenn der dominante Server sich beendet hat. Wechselt wieder auf FALSE wenn der Client sich auf den SB-Rechner, welcher nun prozessführender Server ist, angemeldet hat.
Ist auch innerhalb der Zeit TRUE, wo sich der prozessführende nicht dominante Server wieder zum nicht prozessführenden Server zurückstuft.

Server-Standby im Dateiabgleich

BOOL

Eine Binärvariable, die den Wert 1 annimmt, wenn sich der Server und der Standby Server im Dateiabgleich nach einer Redundanzumschaltung befinden.
0 = kein Dateiabgleich
1 = Dateiabgleich aktiv

Standalone/Server/Standby-Server/Client

DINT

Gibt den Typ des Lokalen Rechners im Netzwerkverbund an.
-1 = Einzelplatz
0 = Client
1 = Server
2 = Standby Server

Standby-Server ausgefallen

BOOL

Wechselt auf TRUE wenn die Verbindung zum aktuell nicht prozessführenden Server unerwartet beendet wurde. Bei bestehender Verbindung ist der Wert FALSE.

Je nach Netztopologieposition des Rechners heißt das:

• Dominanter Server: Erst ab dem Zeitpunkt, wo der Standby prozessführender Server wurde, verhält sich Variable wie beschrieben.

• Nicht dominanter Server: Wenn innerhalb des Dateiabgleichs mit dominantem, aber nicht prozessführendem Server die Verbindung abreißt, wechselt der Wert auf TRUE. Immer FALSE, wenn nicht prozessführender Server.

• Client: Wie prozessführender Server.

Standby-Server beendet

BOOL

Ist am prozessführenden Server TRUE, wenn der nicht prozessführende Server regulär beendet wurde und keine Verbindung mehr besteht. Wechselt auf FALSE wenn der nicht prozessführende Server sich beim prozessführenden Server angemeldet hat.

Je nach Netztopologieposition des Rechners heißt das:

• Dominanter Server: Erst ab dem Zeitpunkt, an dem der Standby prozessführender Server wurde, verhält sich Variable wie beschrieben.

• Nicht dominanter Server: Wenn innerhalb des Dateiabgleichs mit dominantem, aber nicht prozessführendem Server dieser beendet wurde, wechselt der Wert auf TRUE. Immer FALSE, wenn nicht prozessführender Server.

• Client: Wie prozessführender Server.

Standby-Server gestartet

BOOL

Ist TRUE wenn der nicht prozessführende Server sich beim prozessführenden Server angemeldet hat, der Dateiabgleich ausgeführt wurde und die Verbindung zwischen den Rechnern aufrecht ist.

Je nach Netztopologieposition des Rechners heißt das:

• Dominanter Server: Erst ab dem Zeitpunkt, an dem der Standby prozessführender Server wurde, verhält sich Variable wie beschrieben.

• Nicht dominanter Server: Wird TRUE, wenn der dominante nicht prozessführende Server startet. Wechselt auf FALSE, wenn der Rechner prozessführender Server wird.

• Client: Wie prozessführender Server.

Umschaltung Server zum Standby

BOOL

Eine Binärvariable, die den Wert 1 annimmt, wenn im Zuge der Redundanzumschaltung der Server zum Standby Server wird.
0 = eingetragener Server ist als Server im Netzwerkverbund vorhanden.
1 = eingetragener Server ist als Standby Server im Netzwerk vorhanden.

Umschaltung Standby zum Server

BOOL

Eine Binärvariable, die den Wert 1 annimmt, wenn im Zuge der Redundanzumschaltung der Standby Server zum Server wird.
0 = eingetragener Standby Server ist als Standby Server im Netzwerkverbund vorhanden.
1 = eingetragener Standby Server ist als Server im Netzwerk vorhanden.


OPC-Server

Handbuch -> OPC-Server

Der OPC Server stellt die im Projekt verwendeten Variablen allen handelsüblichen OPC Client Tools zur Verfügung.

Für viele Einsätze empfiehlt sich die Verwendung des OPC UA Servers. Dieser ist Teil des COPA-DATA Process Gateways.

tutorial Lizenzinformation

Für Editor und Runtime lizenzpflichtig.

Noch in diesem Kapitel

Vergleich OPC Server und OPC UA Server

Technischer Hintergrund

Installation des OPC Servers

Registrierung des OPC Servers

Lizenzierung des OPC Servers

Einstellungen in zenon

Ausbrowsen des OPC Servers

Starten und stoppen des OPC Servers

Logging

Asynchrone Leseanforderungen

REMOTE Zugriff über DCOM


Vergleich OPC Server und OPC UA Server

Handbuch -> OPC-Server -> Vergleich OPC Server und OPC UA Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die OPC UA Server Technik hat den OPC Server abgelöst. In den meisten Einsatzgebieten empfiehlt sich die Verwendung des OPC UA Servers.

OPC Server

  • OPC Task Force seit 1995
  • einheitliche Schnittstelle in der Automatisierungstechnik
  • baut auf Microsofts COM/DCOM Technologie auf
  • Seit 1996 OPC Foundation
  • mehrere Spezifikationen für unterschiedliche Anwendungsfälle

OPC UA Server

  • Erste Vision 2003
  • Freigabe 2006, noch nicht alle Teile

Vergleich OPC Server mit OPC UA Server

Parameter | OPC Server | OPC UA Server
Datenmodell | eingeschränkt | für alle Anwendungsgebiete
Implementierung | herstellerabhängig | herstellerunabhängig
Interoperabilität | nein | ja
Konfiguration | aufwändig | einfach
Netzwerk-Einsatz | nicht empfohlen (Sicherheit); Windows CE nicht einsetzbar | ja
Netzwerk-Technologie | DCOM (fehleranfällig, instabil) | OPC UA TCP binary Protocol
Performance | niedrig | hoch
Plattformen | nur Windows | unabhängig
Redundanz | nein | ja
Ressourcenbedarf | hoch | niedriger
Serviceorientierte Architektur | nein | ja
Sicherheit | veraltet | nach aktuellen Standards
Verbindungssicherheit | nein | gegeben
Windows CE | nein | ja


Technischer Hintergrund

Handbuch -> OPC-Server -> Technischer Hintergrund

Das OPC-Konzept ist für die Anwendung in der Zell- Leitebene konzipiert. Dabei stellt derOPC Server Prozessdaten aus der Leitebene zur Verfügung.

OPC Clients und OPC Server

Bild 1. OPC Servers

OPC definiert Objekte, die durch Objektinterfaces beschrieben sind. Im OPC Server existieren zwei Ausprägungen der Objektinterfaces, die von einem OPC Client angesprochen werden können (Bild 2):

- Das COM-Custom-Interface

- Das OLE-Automation-Interface

Bild 2. Objektinterface des OPC-Servers

Das COM-Interface wird von funktionspointerorientierten Sprachen, wie C++ genutzt. Über das Automation Interface kann mit Scriptsprachen, wie Visual Basic, kommuniziert werden.

Ein OPC Server besteht aus drei hierarchisch abgestuften Objekten:

- dem Server

- Gruppen und

- Items.

Bild 3. OPC-Objekthierarchie

Ein OPC Server bildet die realen Objekte auf Items (Variablen) ab. Diese Items sind innerhalb des OPC Servers eindeutig. Der Client organisiert die Items in einer oder mehreren OPC Gruppen.

Noch in diesem Kapitel

Allgemeine OPC Server Information

Item Adressierung

Gruppeninformation

Unterstütze OPC Spezifikationen


Allgemeine OPC Server Information

Handbuch -> OPC-Server -> Technischer Hintergrund -> Allgemeine OPC Server Information

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Der OPC Server ist ein Out of Prozess Server.
  • Der OPC Server läuft in einem STA Singel Thread Apartment.
  • Der OPC Server ist als COM Server MULTIPLEUSE Registriert. Das heißt das der Server nur einmal als Prozess Instanz läuft und sich mehrere OPC Clients an den selben Server anmelden.
  • Der OPC Server funktioniert zurzeit nur lokal.


Item Adressierung

Handbuch -> OPC-Server -> Technischer Hintergrund -> Item Adressierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da in der Runtime mehrere Projekte gleichzeitig gestartet sein können, muss der OPC Server unterscheiden können von welchem Projekt die Variablen kommen. Daher bildet der Server die Prozessvariablen nach folgender Nomenklatur ab: Projektname.Variablenname

Example Beispiel

Projekt1.Istwert

Projekt1 = Projektname des Projekts das gerade in der Runtime läuft

. (Punkt) = Trennzeichen

Istwert = Variablenname einer Variable


Gruppeninformation

Handbuch -> OPC-Server -> Technischer Hintergrund -> Gruppeninformation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Gruppenname kann beliebig gewählt werden. z.B Testgruppe1.

Die Updaterate in der Gruppe wird im OPC Server nicht berücksichtigt, weil der OPC Server eine spontane Datenverbindung zur Runtime hat. Damit wird jede Wertänderung an den OPC Server übertragen, ohne zyklisch den Wert anzufragen.

info Info

OPC Clients müssen für jedes zenon Projekt eigene Gruppen erstellen.


Unterstütze OPC Spezifikationen

Handbuch -> OPC-Server -> Technischer Hintergrund -> Unterstütze OPC Spezifikationen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

OPC Data Access Servers Version 1.0

OPC Data Access Servers Version 2.0

Unterstütze OPC Interfaces:

Interfaces | unterstützt
IOPCServer | Ja
IOPCBrowseServerAddressSpace | Ja
IOPCServerPublicGroups | Nein
IPersistFile | Ja
IOPCCommon (ab 2.0) | Ja
IOPCSyncIO | Nein
IOPCItemProperties (ab 2.0) | Ja
IConnectionPointContainer (ab 2.0) | Ja


Installation des OPC Servers

Handbuch -> OPC-Server -> Installation des OPC Servers

Der OPC Server wird bei der Installation standardmäßig mitinstalliert und registriert. Sollten Sie bei einer benutzerdefinierten Installation den OPC Server nicht installiert haben, müssen Sie diesen nachträglich installieren. Über die Systemsteuerung - Software können Sie die bestehende Installation verändern.

Für den Einsatz des OPC Servers, müssen Sie noch die OPC Core Components installieren. Sie finden sie auf der Installations-DVD bei den Zusatzprogrammen.


Registrierung des OPC Servers

Handbuch -> OPC-Server -> Registrierung des OPC Servers

Der OPC Server muss richtig registriert sein. Sollten Sie Probleme haben den OPC Server von einem OPC Client aus zu finden, müssen Sie den OPC Server neu registrieren.

Dazu gehen Sie wie folgt vor:

  1. zenon Startup Tool öffne
  2. In der rechten Menüleiste Tools selektieren
  3. Aus der Liste zenOPCSrv selektieren
  4. Unter Command Line Parameters -Service selektieren
  5. Start klicken

Damit ist die Registrierung des OPC Servers abgeschlossen.


Lizenzierung des OPC Servers

Handbuch -> OPC-Server -> Lizenzierung des OPC Servers

Der OPC Server läuft nur, wenn er ordnungsgemäß lizenziert ist. Ansonsten bekommen Sie folgende Fehlermeldung:

Die Lizenzierung erfolgt mittels des Standard Lizenzverfahrens. Sie müssen bei der Bestellung des OPC Servers angeben, auf welchem Rechner der OPC Server installiert wird, und welche Runtime Seriennummer Sie dort verwenden. Sie bekommen dann von der Lizenzierungsstelle eine neue Seriennummer und Aktivierungsnummer für diesen Rechner. Darin ist der OPC Server freigeschaltet. Diese Nummer müssen Sie über das Tool Lizenzanforderung (Start - Programme - COPA-DATA - Lizenzanforderung) in die zenon6.ini eintragen.


Einstellungen in zenon

Handbuch -> OPC-Server -> Einstellungen in zenon

Damit der OPC Server Daten von der Runtime bekommt, muss VBA aktiviert sein. Bitte überprüfen Sie daher ob folgende Einstellungen in der zenon6.ini richtig gesetzt sind:

[VBA]

EVENT=1 Schaltet den Eventmechanismus für die VBA - COM Schnittstelle ein bzw. aus. Default =0. Sie müssen diese Einstellung auf jeden Fall auf 1 setzen.

attention Achtung

Wenn der Eventmechanismus in der Runtime deaktiviert ist, können Sie mit dem OPC Server zwar schreibend auf die Variablen zugreifen, der lesende Zugriff funktioniert jedoch nicht!
Der OPC Server bekommt dann keine Änderungsevents von der Runtime. Alle verbundenen OPC Clients werden bei der Verbindungsqualität gestört anzeigen!

Ansonsten sind keine weiteren Einstellungen in notwendig.

Der OPC Server liest die laufende Runtime aus, und bietet alle Variablen aller laufenden Projekte zur Verbindung an.

info Info

Sobald die Runtime gestartet ist, können Sie alle Variablen von allen Projekten, die in der Runtime verfügbar sind, auslesen. Das ist unabhängig davon, ob die enthaltenen Projekte Einzelplatz, Client oder Server Projekte sind.


Ausbrowsen des OPC Servers

Handbuch -> OPC-Server -> Ausbrowsen des OPC Servers

OPC Clients verwenden zwei unterschiedliche Verfahren um OPC Server zu erkennen und die Variableninformationen des Servers auszubrowsen. Das Erkennen der auf dem PC installierten OPC Server kann auf zwei Arten erfolgen:

  • Auslesen der Registry
  • Ausbrowsen mittels Zusatzprogramm OPCEnum.exe

Das Zusatzprogramm OPCEnum wird nicht mitausgeliefert. Es kann daher sein, dass ein OPC Client den OPC Server nicht findet, da er dieses Ausbrowsverfahren verwendet. Lesen Sie in der Beschreibung des OPC Clients, ob das Ausbrowsverfahren auf Auslesen der Registry umgestellt werden kann. (Beim Matrikon OPC Explorer finden Sie das unter Optionen.) Wenn das nicht der Fall ist, müssen Sie das Programm OPCEnum installieren.

Tipp: Wenn Sie den frei verfügbaren Matrikon OPC Simulator Server installieren, wird OPCEnum mit installiert.

info Info

Der OPC Server bietet beim Ausbrowsen alle Variablen an, die in der laufenden Runtime vorhanden sind. Sie müssen also sicherstellen, dass die Runtime läuft, bevor Sie mit dem Ausbrowsen von Variablen beginnen.


Starten und stoppen des OPC Servers

Handbuch -> OPC-Server -> Starten und stoppen des OPC Servers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der OPC Server wird automatisch vom ersten OPC Client, der sich mit dem Server verbindet gestartet, und mit dem letzen Client, der die Verbindung trennt gestoppt.


Logging

Handbuch -> OPC-Server -> Logging

Zum Überwachen und Auswerten der Aktivitäten des zenon OPC Servers wird der Diagnose Viewer benutzt.


Asynchrone Leseanforderungen

Handbuch -> OPC-Server -> Asynchrone Leseanforderungen

Das OPC-Interface IAsyncIO als auch das OPC-Interface IAsyncIO2 unterstützen mehrere asynchrone Leseanforderungen.


REMOTE Zugriff über DCOM

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM

Mittels DCOM Technologie kann von einem OPC Client über das netzwerk auf den zenon OPC Server lesend und schreiben zugegriffen werden.

attention Achtung

Der OPC Server ist für lokale Anwendung optimiert, der Einsatz im Netzwerk wird ausdrücklich nicht empfohlen!
Die Kommunikation über das Netzwerk arbeitet bei OPC über die Microsoft Technologie DCOM, die als fehleranfällig und instabil gilt. Besonders Verbindungsabrisse, z.B. bei Abstecken des Netzwerkkabels, und sehr lange Timeoutzeiten sind im industriellen Einsatz problematisch .

Empfohlene Lösung:

  • Einsatz eines OPC_UA Servers
    oder
  • Auf dem Rechner, auf dem der OPC Client läuft wird eine zenon Runtime installiert und arbeitet als Client zu den gewünschten Projekten. Zu diesem Client wird der zenon OPC Server gestartet. So kann eine lokale Kopplung zenon OPC Server - OPC Client erreicht werden.

attention Achtung

Beachten Sie, dass immer der User der OPC Client Applikation sich beim Server anmeldet. In bestimmten Fällen muss das nicht der am Client PC angemeldet Benutzer sein.
Das ist dann der Fall, wenn die Applikation mit einem anderen User gestartet wird. Das tritt beispielsweise dann auf, wenn die Runtime (mit einem OPC Client Treiber, der sich auf den Remote OPC Server verbindet) mittels des Remote Transport gestartet wird. Dann läuft der OPC Client im Kontext des lokalen SYSTEM Users und im Kontext des angemeldeten Benutzers.
In jedem Fall müssen Sie den richtigen Benutzer am OPC Server PC bei den Zugriffsberechtigungen eintragen!!

Noch in diesem Kapitel

Windows Firewall

Generelle Berechtigung

DCOM Konfiguration

Remote Ausbrowsen des OPC Servers


Windows Firewall

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> Windows Firewall

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Windows XP SP2 blockt die Windows Firewall alle eingehenden Verbindungen. Es werden daher auch die Verbindungsversuche des OPC Clients auf den OPC Server unterbunden. Sie müssen daher die Firewall entweder komplett deaktivieren oder richtig konfigurieren.

Da zum Zeitpunkt der Erstellung dieses Tutorials die passende Konfiguration nicht eruierbar war, können wir im Moment nur empfehlen die Windows Firewall komplett zu deaktivieren.


Generelle Berechtigung

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> Generelle Berechtigung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit der OPC Client sich am OPC Server PC anmelden kann, und dort die entsprechenden Rechte bekommt den OPC Server zu starten und zu konfigurieren, müssen Sie den Benutzer - in dessen Kontext der OPC Client läuft - Administratorrechte am Server PC einräumen.

Starten Sie dazu die Systemsteuerung am OPC Server PC und öffnen Sie den Eintrag Benutzerkonten. Fügen Sie mit Hinzufügen... den Benutzer ein, mit dem der OPC Client sich anmeldet und fügen Sie den Benutzer in die Gruppe Administratoren ein Siehe Beispiel 'user' im Screenshot

info Info

Am besten verwenden Sie am OPC Server und am OPC Client denselben Windows Benutzer und fügen den Benutzer in beiden Gruppen in die Gruppe Administratoren ein.
Achtung! Es reicht nicht aus, auf beiden Rechnern einen lokalen Benutzer mit demselben Namen anzulegen. Es muss derselbe Domänen-Benutzer sein!


DCOM Konfiguration

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> DCOM Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese müssen Sie nur am OPC Server PC vornehmen. Am Client PC sollten keine Einstellungen erforderlich sein.

Noch in diesem Kapitel

PC-weite Einstellungen

Applikationsspezifische Einstellungen


PC-weite Einstellungen

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> DCOM Konfiguration -> PC-weite Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Starten Sie das Programm DCOMCNFG aus dem Windows/System32 Verzeichnis.

Öffnen Sie den Konsolenstamm und wechseln Sie zu Komponentendienste - Computer - Arbeitsplatz.

Im Kontextmenü des Arbeitsplatzes wählen Sie Eigenschaften

Im erscheinenden Dialog müssen Sie auf den Registerkarten Allgemein, Optionen, Standardprotokolle und MSDTC im Normalfall nichts einstellen.

Wechseln Sie auf die Registerkarte Standardeigenschaften. Dort müssen Sie sicherstellen, dass Die Option DCOM auf diesem Computer aktivieren aktiv ist. Die restlichen Einstellungen sollten nicht relevant sein.

Folgende Einstellungen sind getestet:

  • COM Internetdienste aktivieren - nicht aktiv
  • Standardauthentifizierungsebene - Verbinden
  • Standarditentitätswechselebene - Identifizieren
  • Zusätzliche Sicherheit für Verweisprotokollierung - nicht aktiv

Auf der Registerkarte COM-Standardsicherheit finden Sie die Einstellungen für die Zugriffsberechtigungen

attention Achtung

Die Limit Einstellungen für die Zugriffsberechtigungen und die Start- und Aktivierungsberechtigungen sind erst ab Windows XP SP2 verfügbar.

Ab diesem Betriebsystem müssen diese Einstellungen aber unbedingt gesetzt werden, da sonst der Remote Zugriff vom Betriebssystem unterbunden wird!!

Für Windows XP bis SP1 gilt: Die Standard Zugriffsberechtigungen und Standard Start- und Aktivierungsberechtigungen können gelassen werden wie Sie sind, da die Berechtigungen direkt beim OPC Server applikationsspezifisch eingestellt werden.

Ab Windows XP SP2 gilt: Sie müssen die Limits sowohl der Zugriffsberechtigungen, als auch der Start- und Aktivierungsberechtigung bearbeiten.

Noch in diesem Kapitel

Zugriffsberechtigung setzen

Startberechtigung setzen


Zugriffsberechtigung setzen

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> DCOM Konfiguration -> PC-weite Einstellungen -> Zugriffsberechtigung setzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klicken Sie auf Limits bearbeiten... Im nun erscheinenden Dialog können Sie die Zugriffsberechtigungen setzen. Fügen Sie im ersten Schritt die notwendigen User hinzu (In unserem Beispiel der Praktikant) und aktivieren Sie bei Remotezugriff Zulassen! Ebenso müssen Sie unbedingt beim User ANONYMOUS-ANMELDUNG bei Remotzugriff Zulassen aktivieren.

attention Achtung

Entfernen Sie niemals den User ANONYMOUS-ANMELDUNG bzw. verweigern Sie niemals den Lokalen Zugriff!
Sie unterbinden damit jeglichen COM Daten-Verkehr auf Ihrem Rechner!

info Info

Den Entfernen Sie niemals den User ANONYMOUS-ANMELDUNG bzw. verweigern Sie niemals den Lokalen Zugriff!
Sie unterbinden damit jeglichen COM Daten-Verkehr auf Ihrem Rechner!User ANONYMOUS-ANMELDUNG müssen Sie nur hier richtig konfigurieren. Bei allen anderen Einstellungen ist jener Benutzer ausreichend, mit dem sich der OPC Client anmeldet.


Startberechtigung setzen

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> DCOM Konfiguration -> PC-weite Einstellungen -> Startberechtigung setzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wie bei der Zugriffsberechtigung müssen Sie den/die OPC Client User hinzufügen und bei allen Berechtigungen Zulassen aktivieren


Applikationsspezifische Einstellungen

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> DCOM Konfiguration -> Applikationsspezifische Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die sicherheitspezifischen Einstellungen sollten Sie direkt bei der Applikation einstellen und nicht bei den Standardeinstellungen unter Arbeitsplatz vornehmen.

Starten Sie das Programm DCOMCNFG aus dem Windows/System32 Verzeichnis.

Öffnen Sie den Konsolenstamm und wechseln Sie zu Komponentendienste - Computer - Arbeitsplatz - DCOM Konfiguration. Es kann vorkommen, dass nicht korrekt registrierte Programme aufgelistet werden. Bestätigen Sie die erscheinenden Messageboxen mit Ja. Dadurch werden die Programme in der Registry eingetragen..

Suchen Sie den OPC Server aus der Liste und klicken Sie mit der rechten Maustaste auf den OPC Server. Im Kontextmenü wählen Sie Eigenschaften.

info Info

DerOPC Server ist unabhängig von der zenon Version. Der OPC Server kann daher mit einem anderen Namen eingetragen sein, als Ihre Versionsnummer der Installation ist. Normalerweise werden Sie den Namen OPC Server for Version 5.21 angezeigt bekommen. Lassen Sie sich dadurch nicht verwirren, das hat keinerlei Einfluss auf die Funktionalität. Wichtig ist die eindeutige Anwendungs - ID (AppID). Diese muss richtig sein. Die AppID des OPC Servers ist: {CA2AF1F9-C031-42B7-8BF3-6C6041B23EAC}
Überprüfen Sie dabei gleich, ob der Pfad auch zum richtigen OPC Server zeigt. Den Pfad des registrierten OPC Servers sehen Sie unter Lokaler Pfad

In dem sich öffnenden Dialog müssen Sie folgende Einstellungen treffen

Auf der Registerkarte Allgemein: Authentifizierungsebene: Verbinden

Auf der Registerkarte Ausführungsort: Anwendung auf diesem Computer ausführen

Auf der Registerkarte Sicherheit:

Start- und Aktivierungsberechtigung | Anpassen selektieren. Durch Klick auf Bearbeiten... kommen Sie in den Berechtigungsdialog. Fügen Sie die notwendige Benutzer hinzu und erteilen Sie ihnen die alle Berechtigungen
Zugriffsberechtigung | Anpassen selektieren. Durch Klick auf Bearbeiten... kommen Sie in den Berechtigungsdialog. Fügen Sie die notwendige Benutzer hinzu und erteilen Sie ihnen alle Zugriffsberechtigung
Konfigurationsberechtigung | Anpassen selektieren. Durch Klick auf Bearbeiten... kommen Sie in den Berechtigungsdialog. Fügen Sie die notwendige Benutzer hinzu und erteilen Sie ihnen die Konfigurationsberechtigung Vollzugriff und Lesen

Auf der Registerkarte Endpunkte: Klicken Sie auf Hinzufügen und fügen Sie Verbindungsorientiertes TCP/IP mit Standardpunkte verwenden hinzu.

Auf der Registerkarte Identität: Wählen Sie Interaktiver Benutzer


Remote Ausbrowsen des OPC Servers

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> Remote Ausbrowsen des OPC Servers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wie schon bei Ausbrowsen des OPC Servers beschrieben stehen zwei Verfahren zur Verfügung wie ein OPC Client den OPC Server erkennen und ausbrowsen kann. Auch beim Remote ausbrowsen kann der OPC Client beide Verfahren benutzen.

Noch in diesem Kapitel

Ausbrowsen mittels Registry Eintrag

Ausbrowsen mittels OPC Enum


Ausbrowsen mittels Registry Eintrag

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> Remote Ausbrowsen des OPC Servers -> Ausbrowsen mittels Registry Eintrag

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der OPC Client muss das Ausbrowsen per Registry unterstützen und entsprechend konfiguriert sein. Des Weiteren muss der Zugriff auf die Registry des Remote Servers möglich sein.


Ausbrowsen mittels OPC Enum

Handbuch -> OPC-Server -> REMOTE Zugriff über DCOM -> Remote Ausbrowsen des OPC Servers -> Ausbrowsen mittels OPC Enum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Programm OPCEnum.exe muss am OPC Server PC installiert sein (wird nicht mitgeliefert). Das OPCEnum Programm muss wie der OPC Server in der DCOM Konfiguration richtig konfiguriert werden (Zugriffsberechtigung für den Remote OPC Client erteilen. Die Einstellungen können Sie analog den Einstellungen des OPC Servers vornehmen). Ansonsten kann der OPC Client keine DCOM Verbindung zum OPCEnum Programm aufbauen und damit funktioniert auch das Ausbrowsen nicht.


PLC Diagnosis

Handbuch -> PLC Diagnosis

Mit der PLC-Diagnosis können Programmdetails einer Steuerung direkt in der Visualisierung in einem Bild angezeigt werden. Je nach Steuerung stehen unterschiedliche Funktionalitäten zur Verfügung. Derzeit existieren die S7-Graph Schrittkettenanalyse zur Darstellung von Schrittketteninformationen von S7 Steuerungen und der zenon Logic Monitoring Viewer zur Darstellung von allen Programmen die in der zenon Logic Runtime (Soft SPS) abgearbeitet werden.

Während der Runtime werden die momentan aktiven Schritte der SPS grafisch angezeigt. Alarminformationen könne direkt in die Alarm-Verwaltung übernommen werden.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig. Für zenon Operator und unter Windows CE als lizenzpflichtiges Modul verfügbar.

Noch in diesem Kapitel

S7-Graph

zenon Logic Monitoring Viewer


S7-Graph

Handbuch -> PLC Diagnosis -> S7-Graph

Sie haben die Möglichkeit ein Bild vom Typ S7-Graph in zenon anzulegen. In diesem Bild können Sie sich die Schrittkette, den aktiven Schritt, den Namen der Schrittkette, die Nummer der Schrittkette usw. einer S7 Steuerung mit S7-Graph Programmierung anzeigen lassen.

Noch in diesem Kapitel

Umstieg von ActiveX CD_Graph7Diag.ocx zu Bild vom Typ S7-Graph

Voraussetzungen für den automatischen Import

Daten aus S7-Graph Projekt importieren

Bild vom Typ S7-Graph

Filter für Bildumschaltung

Funktion S7-Graph Heuristik auswerten

Beschreibung der Operandenanalyse


Umstieg von ActiveX CD_Graph7Diag.ocx zu Bild vom Typ S7-Graph

Handbuch -> PLC Diagnosis -> S7-Graph -> Umstieg von ActiveX CD_Graph7Diag.ocx zu Bild vom Typ S7-Graph

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktionalität des ActiveX CD_Graph7Diag.ocx wurde vom Bild vom Typ S7-Graph und der Funktion S7-Graph Heuristik auswerten abgelöst. Um vom ActiveX auf das Bild und die Funktion zu wechseln oder um S7-Graph in zenon darzustellen, führen Sie die folgenden Schritte aus:

  1. Wenn nicht schon geschehen, führen Sie den S7-Graph Import durch, damit die benötigten Variablen und Dateien angelegt werden.
  2. Bild vom Typ S7-Graph anlegen.
  3. Funktion Bildumschaltung auf das Bild vom Typ S7-Graph anlegen. Im erscheinenden Filterdialog die entsprechenden Variablen und Dateien angeben (siehe Filter für Bildumschaltung).
  4. Wenn Sie die Heuristik benötigen, legen Sie die Funktion S7-Graph Heuristik auswerten an und geben dort auch die entsprechenden Variablen und Dateien an (siehe Funktion S7-Graph Heuristik auswerten).

Änderung gegenüber dem ActiveX

  • Buttons KOP und FUP sind jetzt eigenständige Kontrollelemente
  • Heuristik ist losgelöst von der eigentlichen Darstellung, deshalb wird dafür eine eigene Funktion benötigt
  • Buttons vor und zurück ermöglichen jetzt die schrittweise Navigation in der Schritt-Detailansicht


Voraussetzungen für den automatischen Import

Handbuch -> PLC Diagnosis -> S7-Graph -> Voraussetzungen für den automatischen Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Obwohl das Importieren weitgehend automatisch abläuft, müssen Sie im S7-Graph Projekt einige Vorkehrungen treffen, um einen Import von Schrittketten in zenon zu ermöglichen. Folgende Voraussetzungen müssen erfüllt sein:

1. Bausteineinstellungen

Die korrekte Baustein-Konfiguration muss gewährleistet sein.

Nehmen Sie die folgenden Einstellungen in der Registerkarte Übersetzen/Speichern vor:

Parameter | Eintrag
FB Parameter | anwenderdefiniert
Schnittstellenbeschreibung | Individuelle Strukturen / In AS laden
Ablauffähigkeit | Standard FC erforderlich
Ketteneigenschaften | Kriterieanalysedaten im DB

Nehmen Sie die folgende Einstellung in der Registerkarte Meldung vor:

Parameter | Eintrag
Meldungsbehandlung | Melden mit ALARM_SQ / ALARM_S

2. Quellen generieren

Für jede zu importierende Schrittkette muss eine aktuelle Quelle generiert werden. Dies erfolgt im S7-Graph Editor über Datei -> Quelle generieren. Beachten Sie, dass der Name der Quelle mit dem FB-Namen der Schrittkette übereinstimmen muss. Für eine Schrittkette in Funktionsbaustein 12 muss die Bezeichnung der Quelle also FB12 (bzw. fb12) lauten.

3. Instanz-DB Nummer

Um eine Zuordnung vom Funktionsbaustein der Schrittkette zum entsprechenden Instanz-Datenbaustein (Instanz-DB) zu ermöglichen, dürfen Sie die standardmäßige Einstellung (DB-Nummer = FB-Nummer) nicht abändern.


Daten aus S7-Graph Projekt importieren

Handbuch -> PLC Diagnosis -> S7-Graph -> Daten aus S7-Graph Projekt importieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Führen Sie einen Rechtsklick auf den Eintrag Variablen im Projektmanager aus. Im erscheinenden Kontextmenü selektieren Sie den Menüeintrag Erweiterter Import/Export und dann aus S7-Graph Projekt importieren.... Alternativ erreichen Sie dieses Kontextmenü auch, wenn Sie im Projektmanager den Eintrag Variable bereits selektiert haben und dann in der Detailansicht des Projektmanagers einen Rechtsklick ausführen.

Selektieren Sie den entsprechenden Treiber, der für die Kommunikation mit der SPS verwendet wird, und bestätigen Sie den Dialog mit OK.

attention Achtung

Vor dem Import muss in Step 7 bzw. PC S7 alles übersetzt worden sein, damit alle Objekte in zenon übernommen werden können.

S7-Graph Projekt importieren

info Info

Die Einstellungen, die Sie in diesem Dialog machen werden gespeichert. Beim nächsten Aufruf des Dialogs werden Ihre zuletzt getätigten Einstellungen wieder angezeigt.

Folgende Einstellungen stehen Ihnen zur Verfügung.

Parameter | Beschreibung
Projektauswahl |
S7-Projektdatei | Selektieren Sie die gewünschte Projektdatei (*.s7p).
Zieltreiber | Hier wird Ihnen der zuvor selektierte Treiber angezeigt. Sie können ihn hier nicht ändern.
Elemente für S7-Graph erzeugen |
Instanz-DB Variable | Erzeugt Variable vom Typ USINT, die den Instanz-Datenbaustein der Schrittkette abbildet. Sämtliche Zustandsinformationen werden über diese Variable kommuniziert
Meldungsvariable | Erzeugt interne Variable vom Typ STRING, die den Zustandstext der Heuristik anzeigt.
Reaktionsmatrix | Erzeugt eine Reaktionsmatrix vom Typ numerisch. Die Reaktionsmatrix dient zur Verknüpfung mit den Alarm-S Variablen. Dadurch wird durch sie in zenon eine Alarm ausgelöst. Der Import von Alarmen für S7-Graph erfolgt über den PDiag Import Wizard.
Alarme quittierpflichtig | Wenn Sie diese Checkbox aktivieren, sind alle über die Reaktionsmatrix angelegten Alarme quittierpflichtig.
Variablen Benennung |
Trennzeichen | Definieren Sie hier das Zeichen, das zwischen der Nomenklatur und dem Namen der Schrittkette steht.
Interne Nomenklatur | Verwendet die interne Nomenklatur für die erstellten Objekte. Beispiel: S0 (für Netzadresse = 0)
WinCC Nomenklatur | Verwendet die WinCC Nomenklatur für die erstellten Objekte. Beispiel: S7-Programm
Kombiniert | Verwendet für die Namen der angelegten Objekte sowohl die interne Nomenklatur als auch die WinCC Nomenklatur. Als Trennzeichen wird ein Punkt verwendet.

Bestätigen Sie den Dialog mit Ausführen.

Selektieren Sie im folgenden Dialog die gewünschten Stationen (CPU). Dieser Dialog unterstützt auch eine Mehrfachselektion. Sie können mehrere Schrittketten gleichzeitig selektieren, wenn Sie während der Selektion Strg bzw. die Umschalttaste gedrückt halten. Sie können hier die Netzadresse zur Kommunikation einstellen.Bestätigen Sie den Dialog mit OK. Es wird eine Analyse des S7-Projekts durchgeführt. Je nach Größe des Projekts, kann dies einige Zeit in Anspruch nehmen.

Im nächsten Dialog selektieren Sie die Schrittketten, die Sie importieren möchten. Dieser Dialog unterstützt auch eine Mehrfachselektion. Sie können mehrere Schrittketten gleichzeitig selektieren, wenn Sie während der Selektion Strg bzw. die Umschalttaste gedrückt halten. Wenn für eine Schrittkette keine Quelle gefunden wurde, wird dies im Kommentar mit dem Eintrag !! Quelle fehlt !! angezeigt. Diese Schrittketten können nicht importiert werden. Bestätigen Sie den Dialog mit OK. Jetzt wird der Import durchgeführt und die entsprechenden Objekte in zenon angelegt. Es werden auch die Quelle der Schrittkette (*.gr7) und die Symbolik der Schrittkette (*.seq) importiert. Sie werden im zenon Editor unter Dateien -> Sonstige -> S7-Graph gespeichert.

Noch in diesem Kapitel

Sprachumschaltung


Sprachumschaltung

Handbuch -> PLC Diagnosis -> S7-Graph -> Daten aus S7-Graph Projekt importieren -> Sprachumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Texte in der S7-Graph Kette können sprachumschaltbar projektiert werden. Sprachumschaltbarkeit wird in zenon in der Regel mit einem vorangestellten @ gekennzeichnet. Im SIMATIC-Manager ist es allerdings nicht möglich, Schlüsselwörter mit vorangestelltem @-Zeichen zu erzeugen. Daher erfolgt die Sprachumschaltung über Textvergleich:

  1. in die Sprachtabelle werden die entsprechenden Elemente ohne @ eingetragen
  2. es werden alle dynamischen Felder des Bildes durchsucht und versucht, eine Übersetzung zu finden für:
    • Information: Name der aktiven Schrittkette
    • Information: Name des aktiven Schritts
    • alle Texte aus Grafische Darstellung: Aktive Schritte
    • alle Texte aus Grafische Darstellung: Gesamte Kette
    • alle Texte der Information: Symboltabelle
  3. statischen Feldern muss das Schlüsselzeichen @ vorangestellt werden und es muss ein Eintrag in der Sprachtabelle erzeugt werden für:
    • Schritt zurück
    • Schritt vor
    • KOP/FUP umschalten

Die Anzeige der Texte für Schritte und Transitionen sowie der Texte in der der Symboltabelle erfolgt automatisch, wenn die entsprechenden Einträge in den .GR7 beziehungsweise .SEQ-Dateien vorhanden sind.

Details zur Sprachumschaltung lesen Sie im Handbuch Sprachumschaltung.


Bild vom Typ S7-Graph

Handbuch -> PLC Diagnosis -> S7-Graph -> Bild vom Typ S7-Graph

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Bild vom Typ S7-Graph löst die Funktionalität des ActiveX CD_Graph7Diag.ocx ab.

Um das Bild anzulegen:

  1. wählen Sie Bild neu
  2. wählen Sie in der Dropdownliste S7-Graph
  3. bennen Sie das Bild
  4. fügen Sie über den Menüpunkt Kontrollelemente -> Vorlage einfügen die Standardelemente ein
  5. ergänzen Sie eventuell weitere benötige Elemente über die Unterpunkte des den Menüpunkts Kontrollelemente

Parameter | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Grafische Darstellung | Elemente für die grafische Darstellung.
Aktive Schritte | Darstellung des aktiven Schritts oder der aktiven Schritte aus der projektierten Schrittkette.
Gesamte Kette (nicht default) | Gesamtansicht einer Schrittkette. Stellt alle projektierten Ketten dar. Wird mit Buttons Kette vor und Kette zurück gesteuert.
Information | Elemente zur Information.
Name der aktiven Schrittkette | Zeigt den Name der aktiven Schrittkette an.
Name des aktiven Schritts | Zeigt den Namen des aktiven Schritts an.
Nummer des aktiven Schritts | Zeigt die Nummer des aktiven Schritts an.
Symboltabelle | Zeigt in zwei Spalten jeweils die Adresse und den dazugehörigen Symbolnamen an.
Steuerung | Elemente für die Steuerung.
KOP/FUP umschalten | Mit diesem Button können Sie zwischen den Darstellungsarten KOP und FUP umschalten.
Schritt vor (nicht default) | Navigiert zur Runtime um einen Schritt vor.
Schritt zurück (nicht default) | Navigiert zur Runtime um einen Schritt zurück.
Kette vor (nicht default) | Navigiert zur Runtime in der Darstellung Gesamte Kette bei mehreren Ketten im Funktionsblock um eine Kette vor.
Kette zurück (nicht default) | Navigiert zur Runtime in der Darstellung Gesamte Kette bei mehreren Ketten im Funktionsblock um eine Kette zurück.


Filter für Bildumschaltung

Handbuch -> PLC Diagnosis -> S7-Graph -> Filter für Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie die Funktion Bildumschaltung auf ein Bild vom Typ S7-Graph anwenden, wird Ihnen folgender Dialog angezeigt.

Parameter | Beschreibung
S7-Graph Dateien |
S7-Graph Quelle | Selektieren Sie die vom S7-Graph Import generierte Datei (*.gr7). In dieser Datei ist die gesamte Logik (Schritte, Transitionen, Überwachungen etc.) der Schrittkette enthalten.
Symbol-Zuordnungsdatei | Selektieren Sie die vom S7-Graph Import generierte Datei (*.seq). In dieser Datei ist die Zuordnung von absoluten Operanden (entspricht physikalischen Adressen) zu symbolischen Operanden bzw. Symbolik (entspricht logischen Bezeichnern) enthalten. Beispiel: Eingang "E 1.0 = Taster 1"
Variable |
Instanz-DB Variable | zenon Variable, die den Instanz-Datenbaustein der Schrittkette abbildet. Sämtliche Zustandsinformationen werden über diese Variable kommuniziert.
Darstellung |
Darstellungsart | Wählen Sie, ob Sie die Darstellung als Kontaktplan (KOP) oder als Funktionsplan (FUP) möchten. Wenn Sie in Ihrem Bild den Button KOP/FUP umschalten projektieren, können Sie zur Runtime zwischen den beiden Darstellungsarten umschalten.
Linienbreite [Pixel] | Legen Sie die Linienstärke in Pixel der Verbindungslinien zwischen den Elementen fest.
Schrift | Aus der Dropdownliste selektieren Sie die gewünschte Schriftart für sämtliche Beschriftungen im Bild vom Typ S7-Graph.
Farben | Farben für die die Zustände High Pegel und Low Pegel sowie für die Symbole definieren. Klicken Sie auf das jeweilige farbige Rechteck, um die Farbe zu ändern.


Funktion S7-Graph Heuristik auswerten

Handbuch -> PLC Diagnosis -> S7-Graph -> Funktion S7-Graph Heuristik auswerten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion ermöglicht es Ihnen, die S7-Graph Heuristik durchzuführen, ohne dass das Bild vom Typ S7-Graph aktiv ist. So kann z.B. auch durch eine S7-PDiag Fehlermeldung über eine Alarm-S Variable eine Auswertung durchgeführt werden.

Die folgenden Eigenschaften stehen Ihnen zur Verfügung.

Parameter | Beschreibung
S7-Graph Dateien |
S7-Graph Quelle | Selektieren Sie die vom S7-Graph Import generierte Datei (*.gr7). In dieser Datei ist die gesamte Logik (Schritte, Transitionen, Überwachungen etc.) der Schrittkette enthalten.
Symbol-Zuordnungsdatei | Selektieren Sie die vom S7-Graph Import generierte Datei (*.seq). In dieser Datei ist die Zuordnung von absoluten Operanden (entspricht physikalischen Adressen) zu symbolischen Operanden bzw. Symbolik (entspricht logischen Bezeichnern) enthalten. Beispiel: Eingang "E 1.0 = Taster 1"
Variablen |
Instanz-DB Variable | zenon Variable, die den Instanz-Datenbaustein der Schrittkette abbildet. Sämtliche Zustandsinformationen werden über diese Variable kommuniziert.
Meldungsvariable | Variable vom Typ STRING, die den Zustandstext der Heuristik anzeigt.


Beschreibung der Operandenanalyse

Handbuch -> PLC Diagnosis -> S7-Graph -> Beschreibung der Operandenanalyse

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um auf einen Blick erkennen zu können, welcher Schritt gestört ist und welche Operanden in den Transitionen dafür verantwortlich sind, wird die Meldungsvariable mit einer aussagekräftigen Meldung gefüllt. Diese wird durch folgende Schritte generiert:

Noch in diesem Kapitel

1. Suchen des gestörten Schrittes

2. Auswahl der bearbeiteten Transition

3. Finden der fehlenden Operanden


1. Suchen des gestörten Schrittes

Handbuch -> PLC Diagnosis -> S7-Graph -> Beschreibung der Operandenanalyse -> 1. Suchen des gestörten Schrittes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ist die übergebene Alarm-Variable vom Typ UDINT, so beinhaltet diese bei Auftreten eines Fehlers die Nummer des gestörten Schrittes, die für die weitere Auswertung verwendet wird. Wird hingegen lediglich eine BOOL Variable übergeben, so wird der erste aktive Schritt verwendet der gerade gestört ist.


2. Auswahl der bearbeiteten Transition

Handbuch -> PLC Diagnosis -> S7-Graph -> Beschreibung der Operandenanalyse -> 2. Auswahl der bearbeiteten Transition

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollten im gestörten Schritt mehrere Transitionen zu folgenden Schritten existieren, so wird nur die Transition mit der niedrigsten Transitionsnummer ausgewertet.


3. Finden der fehlenden Operanden

Handbuch -> PLC Diagnosis -> S7-Graph -> Beschreibung der Operandenanalyse -> 3. Finden der fehlenden Operanden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die so ermittelte mögliche Störungsursache wird in der Meldungsvariablen dargestellt. Der Inhalt dieser Variablen wird aktualisiert, wenn Sie die Funktion S7-Graph Heuristik auswerten ausführen.

Um nun in der festgelegten Transition die fehlenden Operanden zu ermitteln wird der Bedingungsbaum hierarchisch durchwandert. Am einfachsten kann dies in der FUP-Darstellung veranschaulicht werden (siehe unten Beispieldarstellungen). Bei Antreffen eines Operators wird dann folgende Fallunterscheidung getroffen:

UND

Es werden alle Pfade weiterverfolgt, die zum Zeitpunkt der Auswertung nicht erfüllt sind (also in der Abbildung rot aufscheinen).

ODER

Für jeden Pfad wird dessen Erfüllungsgrad, also das Verhältnis von erfüllten Eingängen zur Gesamtzahl der ankommenden Eingänge, berechnet. Anschließend wird nur derjenige Pfad weiter verfolgt, der den höchsten Erfüllungsgrad aufweist. Bei mehreren Pfaden mit selbem Erfüllungsgrad wird der Erste verwendet.

Durch diese Systematik wird eine möglichst kleine, aber dennoch mit hoher Wahrscheinlichkeit aussagekräftige, Menge an Operanden gefunden, die für das Weiterschalten in den nächsten Schritt von Bedeutung sind.

Bei den Beispieldarstellungen würde der Algorithmus also lediglich den Operanden M102.2 liefern, da dieser die kleinstmögliche Menge von Operanden darstellt, die nötig ist, um die gestörte Transition in einen ungestörten Zustand zu versetzen.


zenon Logic Monitoring Viewer

Handbuch -> PLC Diagnosis -> zenon Logic Monitoring Viewer

info Info

Dieses Tool dient der visuellen Darstellung und Auswertung von zenon Logic Programmen. Mit dem Monitoring Viewer können die Vorgänge in der zenon Logic Runtime direkt im zenon Bild angezeigt werden.

Noch in diesem Kapitel

Voraussetzungen

Einbindung des ActiveX in zenon Bild

Darstellung des ActiveX im zenon Bild zur Laufzeit


Voraussetzungen

Handbuch -> PLC Diagnosis -> zenon Logic Monitoring Viewer -> Voraussetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab zenon 6.20 SP3 wird das ActiveX X5Monitoring.ocx, das die zenon Logic Programmdarstellung durchführt, in das zenon Programmverzeichnis installiert und im Betriebssystem registriert. In früheren zenon Versionen muss Installation und Registrierung manuell erfolgen.

Dieses Programm ist derzeit nur für die PC Variante von zenon verfügbar.

Für den Betrieb des zenon Logic Monitoring Viewers wird eine Lizenz für die PLC Diagnosis benötigt.

Damit der zenon Logic Monitoring Viewer den aktuellen Programmcode anzeigen kann muss zuerst der Wizard zenon Logic Monitoring Bilder in der zenon Logic Workbench angestoßen werden. In der zenon Logic Workbench unter Tools > Monitoring Applikation erstellen... wird der Wizard aufgerufen.

Dieser Wizard ist lizenzpflichtig.

Beim Durchlauf des Wizards können verschiedene Eigenschaften verändert werden. Z.B. kann die Berechtigung zum betrachten von Programmen und forcen von Variablen-Werten definiert werden (völlig gesperrt, Passwort geschützt, offen).

Der Wizard erstellt eine <ProjektName>.K5m Datei und legt diese in den zenon Projektpfad ab.


Einbindung des ActiveX in zenon Bild

Handbuch -> PLC Diagnosis -> zenon Logic Monitoring Viewer -> Einbindung des ActiveX in zenon Bild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wählen Sie in zenon Editor das Dynamische Element ActiveX aus und ziehen Sie die gewünschte Fläche im zenon Bild auf. Darauf öffnet sich ein Dialog für die Auswahl des ActiveX Controls. Wählen Sie X5Monitoring Control aus und klicken Sie auf Eigenschaften....

Im folgenden Dialog geben Sie den Pfad der Datei welche mit dem Monitoring Builder erstellt wurde ein und stellen die Kommunikationsparameter ein:

info Info

Wurden beim Durchlaufen des Monitoring Builder Wizards keine Pfade geändert, so liegt das Monitoring File im SQL Verzeichnis, des zenon Projekts. Finden Sie die GUID heraus (z.B. durch nachsehen in den zenon Logic Projekt Eigenschaften in zenon) und browsen Sie die *.K5m Datei aus. Sie finden Sie normalerweise im Standard Pfad

C:\ProgramData\COPA-DATA\SQL\<GIUID>/FILES/straton/<zenon Logic Projekt Name>/<zenon Logic Projekt Name.K5m>.

info Info

Verwenden Sie bei den Connection settings nur IP Adressen und keine Rechnernamen! Läuft die zenon Logic Applikation auf dem selben Rechner wie zenon so geben Sie für Localhost 127.0.0.1 ein.

Mit einem Doppelpunkt (:) getrennt geben Sie nach der IP Adresse den Runtime Port der zenon Logic Runtime ein. Meistens ist dieser 1200.


Darstellung des ActiveX im zenon Bild zur Laufzeit

Handbuch -> PLC Diagnosis -> zenon Logic Monitoring Viewer -> Darstellung des ActiveX im zenon Bild zur Laufzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bestätigen Sie die beiden Dialoge mit OK. Nach den Erstellen der zenon Runtime Dateien und dem Starten der zenon und zenon Logic Runtime wird der SPS Code im entsprechenden zenon Bild angezeigt:

Je nach im Monitoring Builder Wizard eingestellter Berechtigung könne nun Programme betrachtet bzw. Werte geforct werden.


Process Gateway

Handbuch -> Process Gateway

Das Process Gateway dient zur Kopplung mit übergeordnete Systeme. Teile des zenon Prozessabbildes aus anderen Anwendungen können zur Verfügung gestellt und aktualisiert werden.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig.

Noch in diesem Kapitel

Allgemeines

Voraussetzungen

Installation

Konfiguration Process Gateway

DEC

DNP3 Slave

IEC870 Slave

MODBUS Slave

OPC UA Server

SNMP Agent

SQL


Allgemeines

Handbuch -> Process Gateway -> Allgemeines

Das Process Gateway versteht sich als Add-On zur Runtime und ist nur in Verbindung mit dieser lauffähig.


Voraussetzungen

Handbuch -> Process Gateway -> Voraussetzungen

Runtime: Auf dem Rechner, auf welchem das Process Gateway laufen soll, muss vor Start des Add-Ons die Runtime mit passender Release-Version und einem der Konfiguration entsprechenden geladenen Projekt gestartet werden. Wird die Runtime beendet, so terminiert auch das Add-On automatisch.

info Info

Das Process Gateway benutzt COM Interface, um auf zenon Daten zuzugreifen. Das COM Interface wird von VBA benutzt und ist nur verfügbar, wenn in der Datei zenon6.ini unter [VBA] der Eintrag EIN=1 vorhanden ist.

Module: Für das Process Gateway existieren verschiedene Module, die die Kommunikation mit externen Anwendungen übernehmen. Diese Module sind zur Zeit:

Datei | Anbindung an
AccessDEC.dll | Hundamp;S-DEC-System
AccessMODBUS.dll | Modbus-Master
AccessSQL.dll | SQL-Datenbanken
AccessDNP3.dll | DNP3-Master
AccessIEC870Sl.dll | IEC 60870-Master
AccessSNMP.dll | SNMP-Client
AccessOPCUA.dll | OPC UA Client

attention Achtung

Bei Verwendung des Modbus Slave unterstützt das Process Gateway nur:

  • Function Code 3: Read Mulitple Registers
  • Function Code 16: Write Multiple Registers


Installation

Handbuch -> Process Gateway -> Installation

Das Add-On besteht nur aus der Datei zenProcGateway.exe. Diese wird vorzugsweise in den zenon Installationsordner kopiert. Prinzipiell ist aber jeder Ordner als Installationsordner möglich. Das Modul, mit dem das Process Gateway verwendet werden soll, muss sich ebenfalls im selben Ordner wie die zenProcGateway.exe befinden. Ausnahme: SNMP
Die Konfigurationsdatei zenProcGateway.ini wird im Systemordner abgelegt. In dieser Datei muss ein Eintrag DLL in der Sektion [GENERAL] auf den Namen des Moduls gesetzt werden.

Modul | Eintrag in zenProcGateway.ini
DEC | [GENERAL] DLL=AccessDEC.dll
SQL | [GENERAL] DLL=AccessSQL.dll
MODBUS | [GENERAL] DLL=AccessMODBUS.dll
DNP3 | [GENERAL] DLL=AccessDNP3.dll
IEC870Sl | [GENERAL] DLL=AccessIEC870Sl.dll
SNMP | [GENERAL] DLL=AccessSNMP.dll
OPCUA | [GENERAL] DLL=AccessOPCUA.dll

Falls eine andersnamige Konfigurationsdatei verwendet werden soll (z.B. für Multiinstanzbetrieb), so muss zenProcGateway.EXE mit dem Kommandozeilenparameter /ini:<file> gestartet werden. Auch diese Datei muss im Systemordner liegen.

Example Beispiel

zenProcGateway.EXE /ini:MyConfig.INI

Wird das Gateway ohne gültige Konfigurationsdatei gestartet oder enthält diese Datei keine Angabe zum Kommunikationsmodul, so wird nach dem Start eine Auswahlliste aller verfügbaren Kommunikationsmodule angeboten.


Konfiguration Process Gateway

Handbuch -> Process Gateway -> Konfiguration Process Gateway

Noch in diesem Kapitel

Projektkonfiguration

Modulkonfiguration

Sicherheitskonfiguration


Projektkonfiguration

Handbuch -> Process Gateway -> Konfiguration Process Gateway -> Projektkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wird in der Konfigurationsdatei (zenProcGateway.INI) kein spezieller Projektname eingestellt, so beziehen sich alle Angaben auf das erste von der Runtime geladene Projekt (Dachprojekt). In einem Mehrprojektsystem kann auf ein beliebiges Projekt in der Hierarchie zugegriffen werden, indem der Eintrag Project der Sektion [GENERAL] in der Konfigurationsdatei (zenProcGateway.INI) auf den Projektnamen gesetzt wird.


Modulkonfiguration

Handbuch -> Process Gateway -> Konfiguration Process Gateway -> Modulkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration der einzelnen Module ist vom jeweiligen Modul abhängig. Mit dem Konfigurations-Button wird der entsprechende Konfigurationsdialog des Moduls aufgerufen.


Sicherheitskonfiguration

Handbuch -> Process Gateway -> Konfiguration Process Gateway -> Sicherheitskonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um das Process Gateway vor unbefugter Benutzung zu schützen, kann das Programm versteckt ausgeführt werden. Wird es von der Kommandozeile mit dem Parameter /hide (bzw. -hide) aufgerufen, startet das Process Gateway unsichtbar und kann nicht konfiguriert und beendet werden. Das Process Gateway beendet sich automatisch, wenn zenon beendet wird.


DEC

Handbuch -> Process Gateway -> DEC

Noch in diesem Kapitel

Modulkonfiguration

Logging

Konfigurationsdatei: spezifische Einträge für AccessDEC


Modulkonfiguration

Handbuch -> Process Gateway -> DEC -> Modulkonfiguration

Nach Klick auf den Konfigurations-Button erscheint folgender Dialog:

Hier können zum einen die Variablen, die gekoppelt werden sollen, ausgewählt werden. In der linken Liste werden alle in zenon verfügbaren Variablen angezeigt. Diese können selektiert werden und mit dem '>'-Button in die In DEC exportiert Liste verschoben werden. Mit dem '<'-Button können sie wieder entfernt werden. Wird eine Variable in die Exportiert-Liste verschoben, erscheint ein Dialog zur Nameszuordnung der zenon Variable zur DEC-Variable:

Die Zuordnung erfolgt über die vierstellige Pressennummer und den vierstelligen Parameter-Name. Eingegebene Zeichen werden automatisch in Grossbuchstaben umgewandelt. Die so ausgewählten Variablen werden dann in zenon bzw. im angebundenen DEC-System laufend synchronisiert.

Im unteren Teil des Konfigurations-Dialogs kann die TCP/IP-Verbindung zum DEC-System konfiguriert werden.

Die Portnummer bezeichnet den Port, auf dem das Process Gateway auf eingehende Verbindungen wartet.

Das Timeout ist die Zeit ohne Antwort, nach der eine Verbindung abgebrochen wird.


Logging

Handbuch -> Process Gateway -> DEC -> Logging

Alle vom DEC-System empfangenen Telegramme und die Antwort vom Process Gateway können mitprotokolliert werden.

Dazu muss in der Konfigurationsdatei in der Sektion [DEC] ein Eintrag LOGFILE mit dem Namen des Logfiles existieren. Dieses wird dann im selben Verzeichnis wie zenProcGateway.EXE selbst angelegt.

Beispiel für so einen Eintrag:
[DEC]
LOGFILE=zenProcGateway.log


Konfigurationsdatei: spezifische Einträge für AccessDEC

Handbuch -> Process Gateway -> DEC -> Konfigurationsdatei: spezifische Einträge für AccessDEC

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfigurationsdatei muss im Systemordner liegen.

Parameter | Beschreibung
[DEC] |
LOGFILE | Name des Logfiles (wenn gewünscht, z.B. zenProcGateway.log)
PORT | Port Nummer, auf dem das Process Gateway auf Verbindungsversuche wartet
TCPTIMEOUT | Timeout-Intervall, nachdem eine Verbindung beendet wird
REFRESHRATE | Zeitintervall in Millisekunden, in dem das Prozessabbild von zenon auf Änderungen überprüft wird.


DNP3 Slave

Handbuch -> Process Gateway -> DNP3 Slave

Noch in diesem Kapitel

Modulkonfiguration

Logging

Konfigurationsdatei: spezifische Einträge für Access DNP3

LATCH_ON und LATCH_OFF

Device Profile


Modulkonfiguration

Handbuch -> Process Gateway -> DNP3 Slave -> Modulkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach Betätigung des Buttons Konfiguration öffnet sich der folgende Dialog:

Hier können die Variablen ausgewählt werden, die verbunden werden sollen. Auf der linken Seite sind alle in zenon verfügbaren Variablen aufgelistet. Dort können sie ausgewählt und mit dem Button > in die DNP3 Exportliste verschoben werden. Mit dem Button < können sie wieder zurück verschoben werden.

Wenn eine Variable in die Exportliste verschoben wird, öffnet sich ein Dialog für die Namenszuweisung der zenon Variable zu einer Objekt- und Punktnummer in DNP3:

Die so ausgewählten Variablen sind dann auf dem DNP3 Slave verfügbar und werden kontinuierlich zwischen zenon und der DNP3 Objektdatenbank synchronisiert.

Im unteren Teil des Konfigurationsdialogs kann die serielle bzw. TCP/IP Verbindung für den DNP3 Slave konfiguriert werden.

Die folgenden Einstellungen sind für die Konfiguration der seriellen Schnittstelle verfügbar:

Parameter | Beschreibung
COM | Die serielle Schnittstelle für den Zugriff auf den DNP3 Slave
Databit | Nummer des Datenbits (Default: 8)
Stopbit | Nummer des Stopbits (Default: 1)
Baudrate | Baudrate der seriellen Schnittstelle (Default: 9600)
Parity | Paritätseinstellung gerade/ungerade/keine (Default: keine)

Für die Konfiguration über TCP/IP kann nur der Listener-Port definiert werden; er sollte 20000 sein.

Für die DNP3 Session müssen die lokale (Slave) und die remote (Master) Verknüpfungsadresse der Session konfiguriert werden. Nur eine active Session wird unterstützt, egal ob seriell oder TCP/IP verwendet wird.


Logging

Handbuch -> Process Gateway -> DNP3 Slave -> Logging

Die gesamte Diagnoseinformation des DNP3 Layer kann in einer Textdatei protokolliert werden.

Um Logging zu aktivieren muss ein Eintrag LOGFILE mit dem Namen der Logdatei in der Sektion [DNP3] der Konfigurationsdatei existieren. Diese Logdatei wird dann im gleichen Verzeichnis wie zenProcGateway.exe erzeugt.

Beispiel für diesen Eintrag:
[DNP3]
LOGFILE=zenProcGateway.log


Konfigurationsdatei: spezifische Einträge für Access DNP3

Handbuch -> Process Gateway -> DNP3 Slave -> Konfigurationsdatei: spezifische Einträge für Access DNP3

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfigurationsdatei muss im Systemordner liegen.

Parameter | Beschreibung
[DNP3] |
SERIAL | serielle Kommunikation (1) oder Kommunikation über TCP/IP (0)
COMPORT | serielle Schnittstelle (COM1 = 0, COM2 = 1,...)
BAUD | Baudrate der seriellen Schnittstelle
BYTESIZE | Anzahl der Datenbits der seriellen Schnittstelle
PARITY | Paritätseinstellungen der seriellenSchnittstelle(0=keine,1=ungerade,2=gerade)
STOPBITS | Anzahl der Stopbits der seriellen Schnittstelle (0=1, 1=1.5, 2=2)
LINKADDRLOC | Verknüpfungsadresse für die lokale Session
LINKADDRREM | Verknüpfungsadresse für die Remote Session
PORT | TCP/IP Port

[VARIABLES] |
COUNT | Anzahl der zu exportierenden Variablen
NAME_n | Name der Variable mit der Nummer n (0<=n<COUNT)
OBJECT_n | DNP3 Objekttyp der Variable mit der Nummer n (0<=n<COUNT)
POINT_n | DNP3 Punktnummer der Variable mit der Nummer n (0<=n<COUNT)


LATCH_ON und LATCH_OFF

Handbuch -> Process Gateway -> DNP3 Slave -> LATCH_ON und LATCH_OFF

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Command Control Code von der Steuerung wird über das Process Gateway auf USINT Variablen als 8-Bit Wert geschrieben. Für die Übergabe an zenon Variablen gilt:

Zielvariable des Befehls | Ergebnis
BOOL: | Sollwert LATCH_ON: 1 Sollwert LATCH_OFF: 0
USINT: | Sollwert entspricht Control Code.
alle anderen Variablen: | Befehl schlägt fehl.


Device Profile

Handbuch -> Process Gateway -> DNP3 Slave -> Device Profile

Die Vorlage für das Device Profile für das DNP3 Process Gateway wird vom Setup mit installiert. Sie finden die Datei DNP3_ProcessGateway.xml im folgenden Ordner:

  • 32-Bit Systeme: %ProgramFiles%\COPA-DATA\zenon [Version]\Templates\Dnp3\ProcessGateway\
  • 64-Bit Systeme: %ProgramFiles(x86)%\COPA-DATA\zenon [Version]\Templates\Dnp3\ProcessGateway\


IEC870 Slave

Handbuch -> Process Gateway -> IEC870 Slave

Sprache

Der Treiber und seine Dialoge zur Konfiguration stehen ausschließlich in Englisch zur Verfügung.

Struktur

Steuerungen, die mit dem IEC870SI-Treiber angesprochen werden, sind in Sektoren unterteilt. Diese enthalten IOs (Information Objects), welche die eigentlichen Variablen repräsentieren. IOs beziehen sich auf eine Variable des Prozessleitsystems.

Mit dem IEC870SI Treiber können Sie mehrere Steuerungen konfigurieren. Je nach Protokoll sind diese direkt einem Master zugeordnet oder werden von einem Master abgefragt.

Identifizierung und Adressierung

  • 870-101: Die Steuerung wird durch die Link-Adresse identifiziert.
  • 870-104: Die Steuerung wird durch die IP-Adresse des Masters identifiziert.
  • Sektor: Wird durch COA adressiert.
  • IO: Wird durch type identification und IOA adressiert.

In den folgenden Kapiteln lesen Sie, wie Sie den IEC870SI-Treiber konfigurieren, wie die Kommunikation abläuft und Hinweise zur Kompatibilität.

info Info

Bei Variablen, die im IEC870 Process Gateway als Befehlsvariable konfiguriert sind, wird bei aktiver Eigenschaft SW setzen über VBA (GruppeProtokollierung in CEL) jeder Befehl als Sollwert Absetzen über die COM-Schnittstelle in der CEL protokolliert.

Interne ID: IEC870 Slave

Protokollierung in CEL

Eigenschaften für die Protokollierung in der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: IEC870 Slave

SW setzen über VBA

Aktiv : Setzen des Sollwerts dieser Variable über ein VBA-Makro wird in der Chronologischen Ereignisliste (CEL) protokolliert.
Inaktiv: Setzen des Sollwerts dieser Variable über ein VBA-Makro wird nicht protokolliert.
Default: aktiv

Hinweis: Bei Variablen, die im IEC870 process gateway als Befehlsvariable konfiguriert sind, wird bei aktiver Eigenschaft jeden Befehl als Sollwert Absetzen über die COM-Schnittstelle in der CEL protokolliert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Modulkonfiguration

Kommunikation

Fehleranalyse

Interoperability


Modulkonfiguration

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vorbemerkung

Im IEC870SI-Treiber stehen Ihnen viele Einstellungsmöglichkeiten zur Verfügung. Listen in den Konfigurationsfenstern sind generell sortierbar. Um die Sortierreihenfolge zu ändern, klicken Sie einfach auf den Spaltentitel.

Konfiguration:

Die Einstellungen für die Protokolle 101 und 104 unterscheiden sich.

Im Hauptfenster entscheiden Sie, welches Protokoll Sie nutzen möchten und legen Sie allgemeine Einstellungen fest:

  • 'Protocol 870-101' gibt die Einstellungen für das Protokoll 101 frei und sperrt alle anderen Eingabemöglichkeiten.
  • 'Protocol 870-104' gibt die Einstellungen für das Protokoll 104 frei und sperrt alle anderen Eingabemöglichkeiten.

Unter 'Device' und 'Sector' definieren Sie alle spezifischen Geräteeinstellungen.

Noch in diesem Kapitel

870-101

870-104

Device

Sektor

104 settings

XML-Datei


870-101

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> 870-101

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellungen im Hauptfenster für IEC870-101:

Name

Funktion

Protocol

870-101

aktiviert Protokoll 101, schaltet alle für 101 spezifischen Einstellfelder frei und sperrt Einstellungen für 104.

Configuration file

Name der Konfigurationsdatei. In diese werden alle aktiven Einstellung gesichert und aus ihr werden sie auch wieder ausgelesen. Der eingegebene Name muss ein gültiger Dateiname sein, sonst können die Daten nicht gesichert werden. In diesem Fall erhalten Sie eine entsprechende Fehlermeldung.

Eingegeben wird nur der Dateiname ohne Pfad. Die Dateiendung XML muss nicht explizit angegeben werden, sie wird beim Speichern automatisch ergänzt. Als Pfad wird immer das aktuelle INI-Verzeichnis verwendet.

Der Dateiname wird automatisch in die INI-Datei des Process Gateways als Konfiguration eingetragen.
Die INI Datei finden Sie im System-Verzeichnis des Prozessleitsystems als 'SCADAProcGateway.ini' - SCADA ist Platzhalter für den Namen des Prozessleitsystems.

Import

Lädt Konfigurationsdaten aus einer XML-Konfigurationsdatei. Die aktuellen Einstellungen werden durch jene in der Datei ersetzt. Die aktuelle Einstellung beim „Configuration file“ bleibt erhalten.

Export

Sichert die aktuellen Einstellungen in eine Datei.

Achtung: Ein Device, das noch die beim Anlegen vergebene Default-ID '????' hat, wird nicht exportiert. Um es zu exportieren, konfigurieren Sie zuvor das Gerät im Konfigurationsfenster Device

Link address size

101

Länge des Datenfeldes “Link address size” nach FT1.2 Frame.
Gültige Eingabe: 1 oder 2 octet
Diese Einstellung muss mit jener am Master übereinstimmen.

COM-Port

101

Nummer der seriellen Schnittstelle.
Verfügbare Schnittstellen: 1 bis 64

Baud

101

Schnittstellengeschwindigkeit.
Das Zeichenformat entspricht TF 1.2 (870-5-1 6.2.4.2.1 R6) 8e1.
RTS ist aktiviert, wenn gesendet wird.
Langsamste Baudrate: 110, schnellste 256000

Devices

Liste der konfigurierten Geräte.

101 master polling timeout [s]

Gibt die Zeit in Sekunden an, in der der Master eine Abfrage an den Slave ausführen muss. Wenn innerhalb dieser Zeit keine Abfrage erfolgt, wird die Verbindung beendet.

Wenn Sie 0 eingeben, deaktivieren Sie die Überwachung.

Add

Fügt ein neues Gerät mit Standardeinstellungen hinzu. Dieses erhält standardmäßig die ungültige ID '????' und ungültige IP/Link-Adressen. Bevor Sie es verwenden oder exportieren können, muss das Gerät konfiguriert werden.

Delete

Löscht das ausgewählte Gerät. Wurde kein Gerät gewählt, ist die Schaltfläche gesperrt.

OK

Übernimmt alle vorgenommenen Einstellungen. Diese werden sofort in die aktuelle Konfigurationsdatei (wie in 'Configuration file' definiert) gesichert.
Achtung: Mit Klick auf 'OK' werden alle bestehenden Masterverbindungen beendet und die Kommunikation wird mit den neuen Einstellungen neu gestartet. Dabei kann es zu Kommunikationsfehlern kommen.

Cancel

Verwirft alle bisherigen Änderungen. Es wird nichts gespeichert.

Help

Ruft wie auch der Druck auf die Taste F1 die Hilfe auf. Ist die Hilfedatei auf Ihrem System nicht verfügbar, wenden Sie sich an den COPA-DATA Support unter: support@copadata.com


870-104

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> 870-104

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellungen im Hauptfenster für IEC870-104:

Name

Funktion

Protocol 870-104

aktiviert Protokoll 104, schaltet alle für 104 spezifischen Einstellfelder frei und sperrt Einstellungen für 101.

Configuration file

Name der Konfigurationsdatei. In diese werden alle aktiven Einstellung gesichert und aus ihr werden sie auch wieder ausgelesen. Der eingegebene Name muss ein gültiger Dateiname sein, sonst können die Daten nicht gesichert werden. In diesem Fall erhalten Sie eine entsprechende Fehlermeldung.

Eingegeben wird nur der Dateiname ohne Pfad. Die Dateiendung XML muss nicht explizit angegeben werden, sie wird beim Speichern automatisch ergänzt. Als Pfad wird immer das aktuelle INI-Verzeichnis verwendet.

Der Dateiname wird automatisch in die INI-Datei des Process Gateways als Konfiguration eingetragen.
Die INI Datei finden Sie im System-Verzeichnis des Prozessleitsystems als 'SCADAProcGateway.ini' - SCADA ist Platzhalter für den Namen des Prozessleitsystems.

Import

Lädt Konfigurationsdaten aus einer XML-Konfigurationsdatei. Die aktuellen Einstellungen werden durch jene in der Datei ersetzt. Die aktuelle Einstellung beim „Configuration file“ bleibt erhalten.

Export

Sichert die aktuellen Einstellungen in eine Datei.

Achtung: Ein Device, das noch die beim Anlegen vergebene Default-ID '????' hat, wird nicht exportiert. Um es zu exportieren, konfigurieren Sie zuvor die Steuerung im Konfigurationsfenster Sektor

Port

TCP-Port, auf den sich die Master verbinden. Die Norm definiert diesen fix als 2404.
Unser Treiber erlaubt Ihnen aber, mehrere Instanzen des Process Gateways gleichzeitig laufen zu lassen. Daher ist der Port einstellbar:
Gültige Portnummern: 1200 bis 65535

Devices

Liste der konfigurierten Geräte.

Add

Fügt ein neues Gerät mit Standardeinstellungen hinzu. Dieses erhält standardmäßig die ungültige ID '????' und ungültige IP/Link-Adressen. Bevor Sie es verwenden oder exportieren können, muss das Gerät konfiguriert werden.

Delete

Löscht das ausgewählte Gerät. Wurde kein Gerät gewählt, ist die Schaltfläche gesperrt..

OK

Übernimmt alle vorgenommenen Einstellungen. Diese werden sofort in die aktuelle Konfigurationsdatei (wie in 'Configuration file' definiert) gesichert.
Achtung: Mit Klick auf 'OK' werden alle bestehenden Masterverbindungen beendet und die Kommunikation wird mit den neuen Einstellungen neu gestartet. Dabei kann es zu Kommunikationsfehlern kommen.

Cancel

Verwirft alle bisherigen Änderungen. Es wird nichts gespeichert.

Help

Ruft wie auch der Druck auf die Taste F1 die Hilfe auf. Ist die Hilfedatei auf Ihrem System nicht verfügbar, wenden Sie sich an den COPA-DATA Support unter: support@copadata.com


Device

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> Device

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Abschnitt 'Device' des Hauptfensters legen Sie die Einstellungen des Gerätes fest.

Eintrag

Protokoll

Funktion

Name

101
104

Name des Gerätes zur leichteren Identifizierung.

Ip address

104

IP-Adresse des Master. Über diese wird das Device erkannt, mit welchem der Master kommuniziert. Alle IP Adressen ausgenommen 255.255.255.255 sind erlaubt.

Hinweis: Wird das Protokoll umgestellt, geht der aktuelle Wert verloren.

Link address

101

Link-Adresse. Über die im TF 1.2 Frame enthaltene Link-Adresse legt der Master fest, für welches Device das Kommando gilt. Über Link-Adressen kann ein Master mit mehreren Devices kommunizieren. Der erlaubte Bereich hängt von der Einstellung „link address size“ in den Haupteinstellungen ab.
Link address size = 1 gilt für 0 bis 254
Link address size = 2 gilt für 0 bis 65534

Hinweis: Wird das Protokoll umgestellt, geht der aktuelle Wert verloren.

COA size

101

Definiert die Länge der COA (common object address). Die COA size ist nur bei 101 einstellbar, bei 104 wird der Wert entsprechend der Norm fix auf 2 gestellt
Auswahl der Adressgröße aus Dropdownliste. Gültig:

  • 1 octet
  • 2 octets

COT size

101

Definiert die Länge der COT (cause of transmission). Die COT size ist nur bei 101 einstellbar, bei 104 wird der Wert entsprechend der Norm fix auf 2 gestellt.

Auswahl der Adressgröße aus Dropdownliste. Gültig:

  • 1 octet
  • 2 octets

IOA size

101

Definiert die Länge der IOA (information object address). Die IOA size ist nur bei 101 einstellbar, bei 104 wird der Wert entsprechend der Norm fix auf 3 gestellt.

Auswahl der Adressgröße aus Dropdownliste. Gültig:

  • 1 octet
  • 2 octets
  • 3 octets

Commands active

101
104

Diese Option erlaubt bei Aktivierung das Schreiben. Process information in control direction werden ausgeführt. Ist die Option inaktiv, wird eine Eintrag im Fehlerprotokoll erzeugt.

Über eine Variable in zenon (IOA 2) kann diese Einstellung individualisiert werden.

Max APDU size

104

Maximale Länge der APDU Daten wie in der Norm 870-5-104 5 definiert.
Gültig: zwischen 25 und 253.

Max. user data

101

Maximale Länge der user data wie in TF1.2 870-5-2 3.2 definiert.
Gültig: zwischen (19 + LAF-Size + COA-Size + COT-Size + IOA-Size) und (255).

Short pulse length

101
104

Definiert die Länge des Pulses für den Qualifier of Command in der Ausprägung 'short pulse duration' (QOC = 1) in Millisekunden.
Gültige Werte: 0 bis 4294967295
Im Debug-Modus wird bei einem Wert größer/gleich 10000 auch bei QOC = 0 eine Pulsbildung ausgelöst. Damit ermöglicht Ihnen unsere IEC870-Treiber das Testen der Pulsbildung.

Long pulse length

101
104

Definiert die Länge des Pulses für den Qualifier of Command in der Ausprägung 'long pulse duration' (QOC = 2) in Millisekunden.
Gültige Werte: 0 bis 4294967295.

File transfer directory

101
104

Definiert das Verzeichnis, in dem die Dateien für den Verzeichnis- und Dateitransfer abgelegt sein müssen.


Sektor

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> Sektor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Teilfenster Sector listet alle im Gerät definierten Sektoren auf. Wenn Sie einen Sektor auswählen, werden dessen Information Objects (IOs) angezeigt.

Einstellungen Sector | Funktion
Add | Aktiviert den Dialog zur Erstellung eines neuen Sektors. Mit OK wird der Dialog beendet und ein neuer Sektor erstellt.
Edit | Aktiviert den Dialog zur Bearbeitung des ausgewählten Sektors. Ein Doppelklick auf den Sektor in der Liste ruft ebenfalls den Editor auf. Wurde kein Sektor ausgewählt, ist die Schaltfläche inaktiv.
Delete | Löscht den ausgewählten Sektor. Wurde kein Sektor ausgewählt, ist die Schaltfläche inaktiv.
Einstellungen IO | Funktion
Add | Aktiviert den Dialog für die Erstellung neuer IOs. Mit 'OK' wird der Dialog beendet und ein neues IO erstellt. Wurde kein Sektor ausgewählt, ist die Schaltfläche inaktiv.
Edit | Aktiviert den Dialog zur Bearbeitung des ausgewählten IOs. Ein Doppelklick auf das IO in der Liste ruft ebenfalls den Editor auf. Wurde kein IO ausgewählt, ist die Schaltfläche inaktiv.
Delete | Löscht das ausgewählte IO. Wurde kein IO ausgewählt, ist die Schaltfläche inaktiv.

Sektoren bearbeiten

Einstellung

Funktion

Name

Beliebiger Name. Er erleichtert die Identifizierung des Sektors.

COA

Die COMMON ADDRESS OF ASDUs (IEC 60870-5-101 7.2.4), unter welcher der Sektor angesprochen wird .
Diese Nummer muss geräteseitig eindeutig sein (1..254).

Time for Background scan [min]

Unterstützt die Anforderungen der IEC 60870-5-101 Norm Kapitel 7.4.13 "Background scan". Die Werte werden mit der COT = 2 verschickt. Zykluszeitangabe erfolgt in Minuten.

Im eingestellten Zeitraster erfolgt für alle IOs mit aktivierter Option "Background scan" eine zyklische Wertübertragung.

Eine zyklische Wertübertragung findet nur dann statt wenn innerhalb der eingestellten Zeit noch kein Spontanwert übertragen wurde.

Bei Wert "0" ist die zyklische Wertübertragung für diesen Sektor deaktiviert.

Time for periodic transfer [s]

Unterstützung der zyklischen Datenübertragung entsprechend der Norm (IEC 60870-5-5 6.3). Die Werte werden mit der COT = 1 verschickt. Zykluszeitangabe erfolgt in Sekunden.

Die zyklische Wertübertragung erfolgt für alle IOs mit aktivierter Option "Periodic data transfer". IOs werden zyklisch und nicht spontan übertragen.

Bei Wert "0" ist die zyklische Wertübertragung für diesen Sektor deaktiviert.

Transmition of integrated totals

Auswahl des Übertragungsmodus (sehe IEC 60870-5-101 7.4.8) für die Integrated Totals - die IOs von Typ:

  • 15 (M_IT_NA_1)
  • 16 (M_IT_TA_1)
  • 37 (M_IT_TB_1)

Es wird kein Reset unterstützt. Ein FRZ mit Reset erzeugt eine Warnung.

Bei Mode A bis D werden die IOs sofort nach dem Verbinden des Masters von zenon/zenon Logic angefordert. Wertänderungen der Integrated Totals IOs werden in einem eigenen Puffer verwaltet. Dieser kann den größeren Wert puffern von (IT IO Anzahl) * 4, bzw. 2048 Wertänderungen.

With general interrogation

Integrated Totals werden bei der Generalabfrage (C_IC_NA_1) mit übertragen.

Mode A: Local freeze with spontaneous transmission

Integrated Totals werden bei Wertänderung übertragen.

Mode B: Local freeze with counter interrogation

Integrated Totals werden nur bei einer Counter Interrogation Command (C_CI_NA_1) übertragen. Dazu wird nach Aktivierung der Abfrage maximal 5 Sekunden gewartet bis alle ITs mit Werten versorgt sind. ITs ohne Wert werden mit dem Qualifier invalid übertragen. Die Wertänderungen werden bis zum Abschluss der Abfrage gepuffert (freeze active). Alle ITs übertragen somit den Wert von dem Zeitpunkt, an dem das letzte IT mit einem Wert versorgt wurde.

Mode C: freeze and transmit by counter interrogation Transmition of integrated totalscommands

Wie mode B.

Mode D: freeze by counter interrogation command, frozen values spontaneous

Übertragung wie bei Mode C, nach Abschluss der Abfrage wird Mode A aktiviert.

OK

Mit Betätigung der Schaltfläche OK wird überprüft, ob die COA beim Gerät frei ist. Wird sie bereits verwendet, erhalten Sie eine Fehlermeldung. Ist sie frei, wird die Einstellung übernommen und der Dialog geschlossen.

Cancel

Verwirft alle Einträge und beendet den Dialog.

Help

Ruft so wie auch die Taste F1 die Hilfe auf. Sollte die Hilfedatei bei Ihnen nicht angezeigt werden, wenden Sie sich bitte an: support@copadata.com

Transmition of integrated totals:

XML Felder

Parameter | Beschreibung
Version | Ab Version 3 wird das Feld CNT_MODE erwartet.
CNT_MODE | Projektierter Mode der Integrated Totals IOs.

Projektierter Modus

Parameter | Beschreibung
0 | Mit Generalabfrage. (Default)
1 | Mode A
2 | Mode B
3 | Mode C
4 | Mode D

Fehlercodes

Code | Beschreibung
13 | Advise for integrated totals fail.
14 | Queue overrun. Integrated totals values lost.
572 | Counter interrogation. Unsupported QCC.
573 | Counter interrogation. Unexpected IOA.
574 | Counter interrogation. Unsupported COT.
575 | Buffer for integrated totals interrogation data to small.

Warnungen

Code | Beschreibung
1011 | QCC FRZ is only partly supported.
1012 | Counter interrogation already active.

Fehlermeldungen

Meldung | Beschreibung
Unsupported qualifier of counter interrogation. <command> | Unbekannter QCC. RQT wird nur mit 5 unterstützt.
Counter interrogation processed without reset. < command> | Warnung. Reset wird nicht unterstützt.
Can't advise IT data point. Device:(<device>)<device> Sector:(<COA>)<Sektorname> adv:0x<Advise-ID> | Datenpunkte für Integrated Totals konnten nicht angefordert werden.
IT Values lost, queue full! Device:(<device>)<device> Sector:(<COA>)<Sektorname> <Wertänderung> | Der Puffer für die Wertänderungen der IT IOs ist voll. Die Wertänderung wurde verloren.

Noch in diesem Kapitel

Einstellungen für Information Objects

Zuordnung der Datentypen


Einstellungen für Information Objects

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> Sektor -> Einstellungen für Information Objects

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellungen für Information Objects

Einstellung

Funktion

Information object address

Definiert die Adresse, unter der das IO angesprochen wird (IEC 60870-5-101 7.2.5). Diese muss in Verbindung mit der Type-ID (Type identifications) beim Sektor eindeutig sein.

Type identification

Enthält die unterstützten Type identifications (IEC 60870-5-101 7.2.1).

Diese Einstellung wird auch Type-ID benannt.

Sie bestimmt auch, welche Variable des Prozessleitsystems aufgrund ihrer Datenart dem IO zugeordnet werden darf.

SCADA variable

Definiert die dem IO zugeordnete Variable aus dem Prozessleitsystem.
Syntax: <Projektname>#<Variablenname> definiert den Projektbezug.
Variablen ohne Projektbezug werden im Standardprojekt erwartet.
Bei der Eingabe wird geprüft ob die angegebene Variable im entsprechenden Projekt vorhanden ist und eine mit der type identification kompatible Datenart hat.
Die Schaltfläche '...' aktiviert den Dialog zur Variablenauswahl. Details dazu lesen Sie im Abschnitt 'Variable selection'.
(SCADA ist Platzhalter für den Namen des Prozessleitsystems.)

Data transfer

Bestimmt die Art der Datenübertragung für die IOs

Spontaneous

Datenübertragung der IOs erfolgt spontan.

Spontaneous - values will be queued when master is offline

Die Daten werden so lange gepuffert, bis sie vom Master wieder gelesen werden. Alle gepufferten Daten werden mit dem Status COT_spont (3) gesendet. Der letzte gepufferte Wert wird nochmals mit dem Status COT_inrogen (20) gesendet.

Die Pufferung kann für die Type-IDs <30..37> aktiviert werden:

M_SP_TB_1, M_DP_TB_1, M_ST_TB_1, M_BO_TB_1, M_ME_TD_1, M_ME_TE_1, M_ME_TF_1 und M_IT_TB_1

Für alle anderen Type-IDs ist die Einstellung nicht verfügbar.

Background scan

IOs werden entsprechend der IEC60870 Norm als Background Scan übertragen. Datenpunkt der innerhalb der eingestellten Background Scanzeit keinen neuen Spontanwert erhält, wird automatisch durch das Gateway nach Ablauf der Zeit verschickt. Die Wertübertragung findet nur dann statt wenn innerhalb der eingestellten Zeit noch kein Spontanwert übertragen wurde.

Einstellung ist inaktiv wenn der Backgroundscan beim Sektor gesperrt ist (Time=0) oder wenn die verwendete Type-ID den Backgroundscan nicht unterstützt.

Die Type-ID=1,3,5,7,9,11,13 unterstützen einen Backgroundscan:

M_SP_NA_1, M_DP_NA_1, M_ST_NA_1, M_BO_NA_1 , M_ME_NA_1, M_ME_NB_1, M_ME_NC_1

Für alle anderen Type-ID ist die Einstellung nicht verfügbar.

Periodic data transfer

Periodischer Datentransfer entsprechend der IEC 60870-5-5-6.3 Norm.

IOs werden zyklisch und nicht spontan übertragen.

Einstellung ist inaktiv wenn die Periodische Übertragung beim Sektor gesperrt ist (Time=0) oder wenn die verwendete Type-ID die Periodische Übertragung nicht unterstützt.

Die Type-ID=9,11,13 unterstützen eine Periodische Übertragung:

M_ME_NA_1, M_ME_NB_1, M_ME_NC_1

Für alle anderen Type-ID ist die Einstellung nicht verfügbar.

Off

Wertänderungen werden nicht übertragen. Für das IO wird bei einer General Interrogation (GI) kein Wert geliefert.

Sequences of events

Diese Einstellungen definieren das IO spezifische Verhalten für SOE. Die SOE Übertragung (siehe IEC Norm 60870-5-101 7.4.11.3.1) kann nur für die Type-IDs <30..37> aktiviert werden:

M_SP_TB_1, M_DP_TB_1, M_ST_TB_1, M_BO_TB_1, M_ME_TD_1, M_ME_TE_1, M_ME_TF_1 und M_IT_TB_1

Inactive

Datenpunkt wird für SOE Aufzeichnung nicht verwendet.

Wird automatisch für alle Type-IDs verwendet welche kein SOE unterstützen.

All events

Jede Wert- bzw. Statusänderung löst das Schreiben in die geöffnete Datei aus.

Einstellung ist gesperrt wenn Type-ID nicht für die SOE Funktionalität vorgesehen ist.

Raising Edge

Wenn der Wert von 0 auf <> 0 wechselt, löst dies das Schreiben in die geöffnete Datei aus.

Einstellung ist gesperrt wenn Type-ID nicht für die SOE Funtionalität vorgesehen ist.

Falling Edge

Wenn der Wert von <> 0 auf 0 wechselt, löst dies das Schreiben in die geöffnete Datei aus.

Einstellung ist gesperrt wenn Type-ID nicht für die SOE Funtionalität vorgesehen ist.

Raising + Falling Edge

Ein Wertwechsel von 0 auf <> 0 bzw. von <> 0 auf 0, löst das Schreiben in die geöffnete Datei aus.

Einstellung ist gesperrt wenn Type-ID nicht für die SOE Funtionalität vorgesehen ist.

File trigger

Wenn Aufgrund der vorher beschriebenen Einstellungen ein Wert geschrieben werden soll, wird bei aktiviertem File trigger eine neue Datei erzeugt und geöffnet, sofern diese noch nicht geöffnet ist. Das Triggerereignis selbst wird auch in die SOE Datei geschrieben.

Einstellung ist gesperrt wenn Type-ID nicht für die SOE Funtionalität vorgesehen ist.

OK

Mit Betätigung der Schaltfläche OK werden die Einstellungen überprüft. Sind diese zulässig, werden sie übernommen und der Dialog geschlossen.

Cancel

Verwirft alle Einträge und beendet den Dialog.

Help

Ruft so wie auch die Taste F1 die Hilfe auf. Sollte die Hilfedatei bei Ihnen nicht angezeigt werden, wenden Sie sich bitte an: support@copadata.com

info Info

Die Kommunikation für Spontaneous Datatransfer, Background scan und Periodic data transfer beginnt erst nach der ersten empfangenen Generalabfrage (C_IC_NA_1). Für Background scan und Periodic data transfer der Zyklusstart der Übertragung wird pro IO berechnet ab dem Zeitpunkt der Antwort auf die Generalabfrage.

Data point selection

Dieser Dialog listet die verfügbaren Projekte und deren Variablen auf.

Projekte

Ein Stern (*) kennzeichnet das Defaultprojekt.

Variablen

Die Liste der Variablen ist gefiltert. Angezeigt werden nur Variablen, die mit der beim IO gewählten 'type identification' verwendbar sind. Die Auswahl eines Projektes aktualisiert die Liste der Variablen.

OK

Übernimmt die ausgewählte Variable. Alternativ kann die Variable auch per Doppelklick übernommen werden. Beim Aufschalten werden das aktuell eingestellte Projekt und die Variable ausgewählt.

Die gleiche Variable kann mehrfach verwendet werden:
bei mehreren IOs beim gleichen Sektor oder anderen Sektoren,
beim gleichen Gerät oder einem anderen.

Wird bei geöffnetem Dialog in der Runtime nachgeladen, dann werden alle Listen geleert und nach Abschluss des Nachladens wieder gefüllt.

Cancel

Verwirft alle Einträge und beendet den Dialog.

Help

Ruft so wie auch die Taste F1 die Hilfe auf. Sollte die Hilfedatei bei Ihnen nicht angezeigt werden, wenden Sie sich bitte an: support@copadata.com


Zuordnung der Datentypen

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> Sektor -> Zuordnung der Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In folgender Tabelle werden die zenon Datentypen den Datentypen im Process Gateway gegenübergestellt.

Process Gateway |  | zenon
IEC 60870-5-101 ASDU | Type Identification | Datentyp | Kommentar
M_SP_NA_1 | 1 | BOOL |
M_SP_TA_1 | 2 | BOOL |
M_SP_TB_1 | 30 | BOOL |
M_DP_NA_1 | 3 | USINT |
M_DP_TA_1 | 4 | USINT |
M_DP_TB_1 | 31 | USINT |
M_ST_NA_1 | 5 | USINT | Entspricht gesamten VTI (IEC60870-5-101 7.2.6.5). Bit 8 ist das Transient Bit.
M_ST_TA_1 | 6 | USINT | Entspricht gesamten VTI (IEC60870-5-101 7.2.6.5). Bit 8 ist das Transient Bit.
M_ST_TB_1 | 32 | USINT | Entspricht gesamten VTI (IEC60870-5-101 7.2.6.5). Bit 8 ist das Transient Bit.
M_BO_NA_1 | 7 | UDINT |
M_BO_TA_1 | 8 | UDINT |
M_BO_TB_1 | 33 | UDINT |
M_ME_NA_1 | 9 | REAL |
M_ME_TA_1 | 10 | REAL |
M_ME_TD_1 | 34 | REAL |
M_ME_NB_1 | 11 | INT |
M_ME_TB_1 | 12 | INT |
M_ME_TE_1 | 35 | INT |
M_ME_NC_1 | 13 | REAL |
M_ME_TC_1 | 14 | REAL |
M_ME_TF_1 | 36 | REAL |
M_IT_NA_1 | 15 | DINT |
M_IT_TA_1 | 16 | DINT |
M_IT_TB_1 | 37 | DINT |
M_EI_NA_1 | 70 | USINT | eine Wertänderung von 126 auf 127 veranlasst, dass End of initialization an den Master gesendet wird
C_SC_NA_1 | 45 | BOOL | spiegelt die Befehlsrichtung während der Ausführung
C_SC_TA_1 | 58 | BOOL | spiegelt die Befehlsrichtung während der Ausführung
C_DC_NA_1 | 46 | USINT | spiegelt die Befehlsrichtung während der Ausführung
C_DC_TA_1 | 59 | USINT | spiegelt die Befehlsrichtung während der Ausführung
C_RC_NA_1 | 47 | USINT | spiegelt die Befehlsrichtung während der Ausführung
C_RC_TA_1 | 60 | USINT | spiegelt die Befehlsrichtung während der Ausführung
C_SE_NA_1 | 48 | REAL | spiegelt die Befehlsrichtung während der Ausführung
C_SE_TA_1 | 61 | REAL | spiegelt die Befehlsrichtung während der Ausführung
C_SE_NB_1 | 49 | INT | spiegelt die Befehlsrichtung während der Ausführung
C_SE_TB_1 | 62 | INT | spiegelt die Befehlsrichtung während der Ausführung
C_SE_NC_1 | 50 | REAL | spiegelt die Befehlsrichtung während der Ausführung
C_SE_TC_1 | 63 | REAL | spiegelt die Befehlsrichtung während der Ausführung
C_BO_NA_1 | 51 | UDINT | spiegelt die Befehlsrichtung während der Ausführung
C_BO_TA_1 | 64 | UDINT | spiegelt die Befehlsrichtung während der Ausführung
C_RD_NA_1 | 102 | - | wird automatisch ausgeführt und die Ausführung wird nicht an zenon abgespiegelt
C_CS_NA_1 | 103 | BOOL | die Enable-Variable der Zeitsynchronisierung
C_RP_NA_1 | 105 | USINT | QRP während der Ausführung
F_DR_TA_1 | 126 | USINT | für spontane Verzeichnisübertragung


104 settings

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> 104 settings

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Registerkarte 104 settings stellen Sie die Timeout-Zeiten und APDUs ein.

Folgende Einstellungen stehen Ihnen zur Verfügung.

Parameter | Beschreibung
104 time outs. [ms] 0 disable the timeout |
T0 time-out of connection establishment | Timeout für den Verbindungsaufbau. Wertbereich 0 - 4294967295 Standardwert: 30000
T1 Time-out send or test APDUs | Timeout für Frame-Bestätigung durch den Master. Wertbereich: 0 - 4294967295 Standardwert: 15000
T2 Time-out for ack. in case of no data msg. | Timeout, innerhalb dessen eine Bestätigung durch den Master erfolgen soll, wenn kein Datenaustausch zu Stande kommt. Wertbereich: 0 - 4294967295 Standardwert: 10000
T3 Time-out for sending test frames | Zeit, nach der ein U-Frame zum Master gesendet wird, wenn keine Daten zu übertragen sind. Wertbereich: 0 - 4294967295 Standardwert: 20000
APDUs |
k Max. diff. receive seq. no. to send state | Anzahl der maximal durch den Master noch nicht bestätigten I-Frames. Wertbereich: 0 - 4294967295 Standardwert: 12
w Latest ack. after rec. w I format APDUs | Anzahl der erhaltenen I-Frames, nachdem eine Bestätigung gesendet wird. Wertbereich: 0 - 4294967295 Standardwert: 8
Set to default | Stellt die Standartwerte für die Einstellungen her.


XML-Datei

Handbuch -> Process Gateway -> IEC870 Slave -> Modulkonfiguration -> XML-Datei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration des IEC870SI wird als XML-Datei abgelegt. Unterschiedliche Konfigurationen können Sie über die Schaltflächen 'Export' und 'Import' im Hauptfenster exportieren und wieder einlesen.

Die aktive Konfiguration wird in der INI-Datei vermerkt, zum Beispiel:
[IEC 870]
SETTINGS=IEC870SLAVE.XML

Der Name ist frei wählbar, der Pfad entspricht dem der INI-Datei.

Aufbau der XML-Datei

Die Namen der meisten Felder lassen intuitiv auf deren Bedeutung schließen. Die Einstellungen entsprechen jenen, welche im Dialog zugelassen sind.

Die Werte und Struktur der XML-Datei werden beim Lesen verifiziert. Fehlerhafte Einträge führen zu einer Fehlermeldung, die auch protokolliert wird.

attention Achtung

XML-Einträge sind case sensitive. Achten Sie auf Groß- und Kleinschreibung.

Name | Eigenschaft
process_gateway_IEC870Slave | Der Wurzelknoten muss diesen Namen haben, sonst wird der Ladevorgang mit einem Fehler beendet.
VERSION | Beinhaltet die aktuelle Version der Attribute und Knoten.
Device_x | Knoten für die Geräte-Konfiguration. X wird durch eine laufende Nummer beginnend mit 1 ersetzt. Diese Knotenbenennung ist nicht zwingend. Für jeden Knoten wird ein Device erzeugt.
LinkAdr | Im Protokoll 101 wir hier die 'link address' gesetzt. Diese muss für alle Geräte eindeutig sein. Für das Protokoll 104 hat der Eintrag keine Bedeutung.
IpAdr | Im Protokoll 104 wird hier die IP-Adresse des Masters eingetragen. Diese muss bei allen Geräten eindeutig sein. Für das Protokoll 101 hat der Eintrag keine Bedeutung.
Sector_x | Anzahl der Knoten pro konfiguriertem Sektor. X wird durch die COA ersetzt. Diese Knotenbenennung ist nicht zwingend. Für jeden Knoten wird ein Sektor erzeugt.
IO_x | Anzahl der Knoten pro information object. X wird durch eine laufende Nummer beginnend mit 1 ersetzt. Diese Knotenbenennung ist nicht zwingend. Für jeden Knoten wird ein IO erzeugt.
ScadaVar | Beim Laden wird verifiziert ob die angegebene Variable beim Projekt existiert. Variablen ohne Projektbezug werden im Defaultprojekt gesucht. [ScadaProjektName#]ScadaVariablenName. (Scada steht für den Namen des Prozessleitsystems.)
TypeId | Type identification. Es wird beim Laden geprüft, ob die Typ-ID mit dem angegebenen Variablendatentyp möglich ist.
COA | Common object address. Muss pro Sektor beim Device eindeutig sein.
IOA | Information object address. In Kombination mit der Type-ID muss diese pro Sektor eindeutig sein.
Is101active | Mit dem Wert '1' wird das Protokoll 101 aktiv geschaltet, sonst ist 104 aktiv.
BSTime | Zeit für Backgroundscan. Einheit: ms. 0 deaktiviert den Backgroundscan. Default: 0
CYTime | Zeit für zyklischen Datentransfer Einheit: ms. 0 deaktiviert den zyklischen Transfer. Default: 0 Verfügbar ab Version 2
KindOfTransfer | Gibt die Art der Datenübertragung beim IO an. 0 Spontan. Ist auch der Defaultwert. 1 Backscan 2 Zyklisch 3 Aus 4 Spontaner Transfer mit Pufferung Default: 0 Verfügbar ab Version 3
DeActDPIStd | DPI /DCS konforme (IEC60870 konform) Datenübertragung oder Leitsystem internes Format
Version | 6: kennzeichnet ein XML File mit den nachfolgenden Feldern für SOE Unterstützung
EnableSOE | 0 = inaktiv 1 = SOE aktiv
MaxBufferedFilesSOE | Anzahl der maximal gepufferten SOE Dateien.
AutodeleteFilesSOE | 0 = kein Autodelete 1 = Autodelete bei wenn maximale Fileanzhal erreicht
MaxEventsPerFileSOE | Maximale Anzahl der ASDU's pro File
PostTrgToSOE | Post trigger timeout in [ms]
FileToSOE | File timeout in [ms]
Information Object Einstellung für die SOE Unterstützung | Zusätzliche Einstellungen die für eine SOE Unterstützung am Information Object getroffen werden müssen.
Version | 4: kennzeichnet ein XML File mit den nachfolgenden Feldern für SOE Unterstützung
KindOfTransfer | Definiert wann eine Aktualisierung eine Übertragung auslöst. 0 Spontan 1 Background scan 2 Periodic 3 Keine Übertragung
TrgSOE | 0 = inaktiv 1 = IO fungiert als Trigger
EvDetectionSOE | Bestimmt wann eine Änderung am Wert bzw. Status des IO ein schreiben in die SOE Datei auslösen kann. 0 SOE deaktiviert 1 Alle Änderungen 2 Steigende Flanke 3 Fallende Flanke 4 Steigende und fallende Flanke

Beispiel Konfiguration für das Protokoll 101:

Beispiel Konfiguration für das Protokoll 104:


Kommunikation

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation

In diesem Kapitel lesen Sie Details zur Kommunikation im Process Gateway:

  • Startup
  • Generalabfrage
  • Reset
  • Wertänderung
  • Priorität
  • Read
  • Process Initialized
  • Dateitransfer
    • Ablage und Benennung von Dateien für Transfer
    • Spontane Verzeichnisübertragung
  • Sequence of Events (SOE)
    • Warnungen
    • Fehlermeldungen
  • Zeit-Synchronisierung
  • DPI/DCS Mapping
  • Select Before Operate
  • Qualifier of command
  • Invalid Bit Handling
  • Normalized Values
  • Monitoring command
  • Interner Typ T00
  • Pulsbildung
  • Nachladen
  • Broadcasts
  • Echtzeit ungültig - Statusbit T_INVAL

Noch in diesem Kapitel

Startup

Generalabfrage

Reset

Wertänderung

Priorität

Read

Process initialized

Dateitransfer

Sequence of Events (SOE)

Zeit-Synchronisierung

DPI/DCS Mapping

Select Before Operate

Qualifier of command

INVALID-Bit Handling

Normalized Values

Monitoring command

Interner Typ T00 (Statusvariablen)

Pulsbildung

Nachladen

Broadcasts

Echtzeit ungültig - Statusbit T_INVAL


Startup

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Startup

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Start des Process Gateways lädt dieses den konfigurierten Treiber.

Der Treiber versucht dann, seine aktive Konfiguration aus der in der INI eingetragenen Datei zu lesen. Ist dies nicht möglich, wird eine Fehlermeldung angezeigt und der Konfigurationsdialog geöffnet.

Wenn der Konfigurationsdialog nicht mit OK verlassen wird, beendet sich die Applikation.

attention Achtung

Wird die Applikation unsichtbar gestartet, dann wird kein Konfigurationsdialog aufgeschaltet. Bei einer ungültigen oder fehlenden Konfiguration wird das Process Gateway automatisch beendet.


Generalabfrage

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Generalabfrage

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Generalabfrage löst im Treiber den Verbindungsaufbau zur Runtime aus. Sie ist Voraussetzung für die Kommunikation per Spontaneous Datatransfer, Background scan und Periodic data transfer. Diese Verbindung wird sektorweise aufgebaut.

Sollte die Verbindung nicht etabliert werden können, erfolgt eine negative Bestätigung der Generalabfrage. Eine für den Sektor bereits aktive Generalabfrage wird beendet und eine Warnung protokolliert.

Wertänderungen für IOs, deren Wert bereits dem Master gemeldet wurde, werden gepuffert solang die GA läuft.

Während eines Nachladevorgangs kann die Verbindung zur RT nicht hergestellt werden. Die Generalabfrage schlägt dann fehl.


Reset

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Reset

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Master muss in der Lage sein, eine Unterbrechung der Kommunikation zu erkennen, um mit einer neuen Generalabfrage reagieren zu können. Daher werden keine process commands ausgeführt, solange der Master keinen Reset veranlasst hat.

Immer wenn Datenverlust möglich ist (Wertänderungen wurden verloren), wird ein Reset erzwungen .

101
Bis der Funktionscode für den Reset (0) empfangen wird, werden alle Kommandos abgelehnt. Der Code löst den Reset im LinkLayer und Applikationslayer aus.

104
Durch den Abbau der Verbindung erkennt der Master die Unterbrechung sofort und beginnt erneut mit dem Initialisierungsablauf. Der Reset wird ausgelöst, wenn sich ein Master verbindet.

Reset process command
Durch Anlegen eines IO vom Typ C_RP_NA_1 mit IOA 0 kann der Erhalt des Kommandos im Prozessleitsystem erkannt werden.
Der Wert der Variablen wird auf '0' und dann auf den Wert von QRP gesetzt.


Wertänderung

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Wertänderung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Treiber erhält sämtliche Wertänderungen der angeforderten Variablen.

Da dadurch die Liste der noch nicht zum Master übertragenen Prozessinformationen sehr groß werden kann, ist die Liste der gepufferten Wertänderungen begrenzt.

Limit: wenigstens 2048 Werte bzw. 4 x Anzahl der IOs pro Sektor.

Sobald die Liste dieses Maximum überschreitet, wird die Masterverbindung beendet. Somit wird der Master aufgefordert, die nächste Verbindung mit einer Generalabfrage anzufangen und sich aktuelle Wertänderungen zu holen.

Wertänderungen können protokolliert werden.


Priorität

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Priorität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Treiber unterstützt class1 und class2 Daten.

Sämtlicher Dateitransfer wird als class 2 abgearbeitet. Damit ist sicher gestellt, dass Wertänderungen auch während eines Filetransfers an den Master übertragen werden.


Read

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Read

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Maximal 2048 Read Anforderungen können gleichzeitig aktiv sein. Sobald diese Grenze erreicht wird, werden weitere Readrequests abgelehnt.

Für jedes IO mit der angeforderten IOA wird ein Readrequest ausgeführt.
Es können auch mehrere Anforderungen für ein IO gleichzeitig aktiv sein.
Read Anforderungen werden auch dann abgearbeitet, wenn die Generalabfrage noch nicht beendet ist.


Process initialized

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Process initialized

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vom Prozessleitsystem kann veranlasst werden, dass das Kommando M_EI_NA_1 (End of initialization) an den Master gesendet wird. Dafür

  • legen Sie einen IO vom Typ M_EI_NA_1 (T70) mit IOA '0' an.

Die Übertragung wird ausgelöst, wenn der aktuelle Wert der Variablen 126 ist und dieser auf 127 geändert wird. Als COI (Cause of initialization) wird 2 (remote reset) verwendet.


Dateitransfer

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Dateitransfer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Dateitransfer gilt:

  • im AFQ UI4 werden die Werte 1-4 unterstützt
  • im SCQ UI4 werden die Werte 0–6 unterstützt;
    0 und 1 sind beide 'select file'

Wird bei einem bereits aktiven Dateitransfer ein neuer Transfer angestoßen, dann wird der laufende Transfer abgebrochen und der neue wird ausgeführt.

Noch in diesem Kapitel

Ablage und Benennung

Spontane Verzeichnisübertragung


Ablage und Benennung

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Dateitransfer -> Ablage und Benennung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ablage und Benennung werden nach folgendem Schema definiert:

<Konfiguriertes Verzeichnis>\<COA>\<IOA>.<NOF>

Als NOF (Name of file) wird nur 1 = 'transparent file' unterstützt.
Die maximal übertragbare Dateigröße ist auf 16.711.680 Bytes begrenzt.

Beispiel

Ordner in der Modulkonfiguration: C:\TEMP\IEC870

Datei 1100.1: für IO von Sektor COA=151 und IOA 1100

Ablageort: C:\TEMP\IEC870\151\1100.1


Spontane Verzeichnisübertragung

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Dateitransfer -> Spontane Verzeichnisübertragung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die spontane Übertragung der Dateien im Verzeichnis für den Dateitransfer kann vom Prozessleitsystem ausgelöst werden. Dazu:

  • legen Sie einen IO vom Typ F_DR_TA_1 (T126) mit der IOA '0' an
Wert | Bedeutung
Wechsel von 1 auf 2 | Übertragung wird gestartet
3 | Übertragung läuft
4 | Übertragung wurde beendet
5 | Fehler bei der Übertragung

Verschachtelte Aktivierung wird verhindert.


Sequence of Events (SOE)

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Sequence of Events (SOE)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellungen im Hauptfenster für SOE:

Einstellung SOE | Funktion
Use sequences of events | Wenn aktiv dann ist SOE für das slektierte Device aktiviert. Bei inaktiv werden alle SOE Einstellungen an den IOs ignoriert. Default: inaktiv
Buffered SOE Files | Wird die eingestellte Anzahl der SOE Dateien im Verzeichnis für den Sektor erreicht, wird ein spontaner Directory transfer (Typ ID "F_DT_TA_1") ausgelöst. Bei der doppelten Anzahl von Dateien im Verzeichnis wird begonnen die älteste Datei zu löschen (Ringpuffer Funktionalität. Wertbereich 1 bis 1024. Default: 1024
Events per File | Anzahl der Wertänderungen welche in eine Datei geschrieben werden bevor diese geschlossen wird. Wertbereich: 1 bis 4096. Default: 512
SOE file auto deleting | Wenn aktiv dann wird auf Reaktion für Typ ID "F_AF_NA_1" (Bestätigung für Datei) für eine SOE Datei diese automatisch gelöscht.
Post trigger timeout | Wenn innerhalb dieses Zeitraums kein neuer ASDU in die Datei geschrieben wird, so wird diese geschlossen. Mit jedem geschriebenen ASDU beginnt der Zeitraum von neuem. Wertbereich: 100ms bis 120000ms Default: 1000ms
File timeout | Maximale Zeit welche die Datei geöffnet bleibt (unabhängig von der Anzahl der Events). Wertbereich: 100ms bis 120000ms Default: 5000ms

Erster Wert

Der Datenaustausch für SOE beginnt sofort wenn das Gateway fertig initialisiert ist. Der Datenaustausch für Daten in monitoring direction beginnt erst wenn ein Master sich verbunden hat und eine General Interrogation (GI) auslöst. Der erste Wert welcher zur Initialisierung kommt, löst kein Event aus und wird somit auch nicht in die Datei eingetragen. Das Gleiche gilt wenn die Runtimenach dem Nachladen wieder bereit für einen Datenaustausch ist.

File transfer

Es wird im Zuge der SOE Funktiponalität zu transparent (1) auch event (3) als NOF unterstützt.

Es wird kein automatischer File transfer bei überscheiten der maximalen Anzahl zu puffernden SOE Dateien ausgeführt.

Die IEC 60870 Norm beschreibt dies mit „may be activated" Das Gateway unterstützt im aktuellen Ausbau keinen durch den Salve aktivierten Filetransfer .

Directory Transfer

Es wird im Zuge der SOE Funktiponalität zu transparent (1) auch event (3) als NOF unterstützt.

Automatischer directory transfer:

Entsprechend der IEC 60870 Norm wird bei den folgenden Gründen eine automatische spontane Verzeichnisübertragung bei existierenden Dateien für SOE aktiviert:

  • 24 Stunden nach der letzten automatischen Verzeichnisübertragung.
  • wenn sich der Master verbindet
  • wenn die maximale Anzahl der zu puffernden Dateien überschritten wurde

Noch in diesem Kapitel

Warnungen

Fehlermeldungen


Warnungen

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Sequence of Events (SOE) -> Warnungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Warnmeldung | Bedeutung
Sequences of events for device <Devicename> sector <Sectorname> are activated but no trigger defined | Das Device hat SOE aktiviert, beim Sektor existiert ein IO mit aktiven SOE aber bei keinem IO wurde der Trigger aktiviert. Ohne Trigger wird keine Datei erzeugt. Mindestens ein IO beim Sektor muss den Trigger aktiviert haben.
SOE value change without trigger and file is closed. Value lost! Device:(<Device ID>)<Device-Name> Sector:(<COA>)<Sektorname> <Wertinformation> | Eine Wertänderung wurde nicht geschrieben da die SOE Datei nicht geöffnet ist. Code:1010


Fehlermeldungen

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Sequence of Events (SOE) -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Fehlermeldung | Bedeutung
Sequence of events active but no directory for the file transfer defined! | SOE Dateien werden im Verzeichnis für den Dateitransfer abgelegt. Es muss somit ein Verzeichnis für den Dateitransfer vorhanden sein.
SOE Values lost, queue full! Device:(<Device ID>)<Device-Name> Sector:(<COA>)<Sektorname> <Wertinformation> | Der Datenaustausch zu Stack wird für IO’s welche SOE aktiviert haben über eine Queue ausgeführt. Diese kann den größeren Wert von 2048 oder 4 * Anzahl der SOE IO’s beim Sektor Einträge aufnehmen. Wenn diese Anzahl überschritten ist, wird diese Fehlermeldung erzeugt und die Wertänderung ist verloren. Errorcode: 6
Can't create subdirectory for file transfer. Device:(<Device ID>)<Devicename> Sector:(<COA>)<Sektorname> system error:<Systemfehlercode> | Für SOE wird automatisch das Unterverzeichnis für den Sektor im Verzeichnis für den Dateitransfer erzeugt. Dieser Fehler zeit an das dieses Verzeichnis nicht erzeugt werden konnte. SOE steht dann für diesen Sektor NICHT zur Verfügung. Errorcode: 10
Systemfehlercode | Beinhaltet den vom Betriebssystem zurückgegebenen Fehlercode.
Can't advise SOE data point. Device:(<Device ID>)<Devicename> Sector:(<COA>)<Sektorname> adv:0x<Advise-ID> | Datenpunktanforderung für SOE IO’s ist fehlgeschlagen. SOE steht für diesen Sektor NICHT zur Verfügung. Errorcode: 11
Write asdu to file <Dateiname> fail! Device:(<Device ID>)<Devicename> Sector:(<COA>)<Sektorname> <Value> system error: <Systemfehlercode> | Schreiben des ASDU in SOE Datei fehlgeschlagen. Errorcode: 8
Illegal file name <Dateiname> detected! Device:(<Device ID>)<Devicename> Sector:(<COA>)<Sektorname> | Dateinamen für den Dateitransfer haben ein definiertes Format <IOA>.<NOF>. Die Datei hält sich nicht an diese Konvention. Errorcode: 12
Auto delete for file failed! System error: <Systemfehlercode> <Dateitransferinformation> | Errorcode: 9
Dateitransferinformation | Enthält die Information welche den Dateitransfer identifiziert.


Zeit-Synchronisierung

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Zeit-Synchronisierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit die Zeitsynchronisierung ausgeführt wird, muss bei einem beliebigen Device/Sektor ein InformationObject von Typ 103 zu einer Prozessvariable verbunden werden. Das erste IO welches den Typ 103 verwendet wird als Enable verwendet.

Diese Variable muss einen Wert <> 0 haben und keinen der folgenden Status gesetzt:

  • Blocked Bit 44
  • gestört Bit 18
  • abgeschaltet Bit 20 oder Ersatzwert Bit 27

Das nicht ausführen des Kommandos Aufgrund des fehlenden Enables (bzw. Statuszustand) führt zu keinem Verbindungsabbau.

Die fehlende Projektierung der Enable-Variable beziehungsweise der fehlende Wert der Enable Variable führt zu einem Verbindungsabbau.

Der Verbindungsaufbau der Enable-Variable zum Leitsystem erfolgt wenn der Reset am Device ausgeführt wird.


DPI/DCS Mapping

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> DPI/DCS Mapping

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es kann konfiguriert werden ob DPI/DCS (double-point information/double command state) konform zur Norm oder in der zenon internen Darstellung übertragen wird. Default ist die Übertragung (zwischen dem Process Gateway und einem IEC 60870 Master) entsprechend der Norm.

Einstellung

Funktionalität

Deactivate standard

Aktiv: Mapping wird deaktiviert. Werte für DPI/DCS entsprechen den Werten von zenon.

Inaktiv: Werte für DPI/DCS werden wie folgt gemappt, was auch das Standardsverhalten für die Befehlsgabe garantiert:

  • zenon Wert 0 = DPI/DCS Wert 1 (= OFF)
  • zenon Wert 1 = DPI/DCS Wert 2 (= ON)
  • zenon Wert 2 = DPI Wert 0
  • zenon Wert 3 = DPI Wert 3

Diese Einstellung wird automatisch aktiviert, wenn eine XML-Datei mit Version 1 eingelesen wird.


Select Before Operate

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Select Before Operate

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Empfängt das Process Gateway eine Einzel oder Doppelbefehl inklusive eines Select Kommandos wird dieses Select immer mit N_CONF (P/N Bit) = 0 (Success) beantwortet.


Qualifier of command

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Qualifier of command

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein empfangene Einzelbefehl - ein ASDU mit Type identification 45 (C_SC_NA_1) - mit Qualifier of Command (QoC) wirkt sich auf eine zenon Variable wie folgt aus:

  • QoC 0: Undefiniert entsprechend IEC-Standard. Verhält sich im Slave wie QoC 3 (persistent output).
  • QoC 1: Short pulse. Die zenon Variable nimmt den Wert 1 an und wechselt nach der in den Process Gateway Einstellungen definierten Zeit auf 0.
  • QoC 2: Long pulse). Die zenon Variable nimmt den Wert 1 an und wechselt nach der in den Process Gateway Einstellungen definierten Zeit auf 0.
  • QoC 3: Persistent output. Die zenon Variable nimmt den Wert 1 an und behält den Wert 1 bei. Dieser muss für die Entgegennahme weiterer Einzelbefehle zurückgesetzt werden.


INVALID-Bit Handling

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> INVALID-Bit Handling

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Empfängt das Process Gateway ein INVALID-Bit für ein zu versendendes Information Object (aus dem Leitsystem) werden folgende Qualitätsbits für das Information Object vor dem Versenden gesetzt:

  • NT (Not Topical)
  • IV (Invalid)


Normalized Values

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Normalized Values

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

OV_870 Bits, die die Variablen in zenon bereits haben, werden zum Master gesendet.

Wenn Werte für Normalized Values den Normbereich (-1 bis 1-2-15) unterschreiten oder überschreiten, wird das OV_870 Bit gesetzt, auch wenn in zenon die Variable das Statusbit nicht habt.


Monitoring command

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Monitoring command

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Monitoring command single, double and regulating unterstützt Qualifier 0 bis 3.
0 ist default und wird wie 1 verwendet.

Command state wird als Wert bei der SCADA Variablen gesetzt


Interner Typ T00 (Statusvariablen)

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Interner Typ T00 (Statusvariablen)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der interne Typ T00 dient zur Kommunikation zwischen dem Slave und dem Prozessleitsystem.

Bei den Statusvariablen kann jede numerische zenon Variable zugeordnet werden. Dies ermöglicht es die interne Variable als Quelle für eine Type ID zu verwenden.

IOA 1

Variable liefert die Statusinformation ob bereits eine Verbindung zu einem Master besteht. Legen Sie einen IO vom Typ T00 mit der IOA '1' an. Der Wert wechselt bei der Verbindung von 0 auf 1.

IOA 2

Es kann durch eine zenon Variable pro Sektor entschieden werden, ob Kommandos in control direction ausgeführt werden. Im Unterschied zum Device-Enable wird beim Sektor bezogenen dynamischen enable, die Verbindung zum Master nicht abgebaut wenn ein Schreibkommando kommt und dieses abgelehnt wird. Abgelehnte Kommandos erhalten als Bestätigung act_con + PN. Abgelehnte Kommandos erzeugen eine Warnung.

Die zenon Variable muss vom Typ UINT od. DWORD sein und wird bei T00 (Internal status) mit IOA 2 zugeordnet. Wenn der Wert der Variable <> 0 ist, sind die Kommandos frei gegeben. Die Variable darf keinen Status IV (IEC 60870 Qualifier invalid) haben. Wenn kein IO projektiert ist, sind die Kommandos immer freigegeben.

Diese Einstellung kann über die Eigenschaft Commands active global geschaltet werden.

info Info

Zugehörige Warnmeldung:

Commands for sector deactivated, execution prohibited. <Kommandotext>

Warnung: 1009 Kommando in Control-Richtung wurde empfangen, aber Aufgrund eines fehlenden enable abgelehnt.

IOA 3

Statusvariable wird auf 1 gesetzt wenn die Anzahl der SOE Dateien im Transferverzeichnis die Anzahl der maximal gepufferten Dateien überschreitet.

IOA 4

Variable liefert Statusinformationen über die aktuell od. zuletzt bearbeitete SOE Datei:

0 - Initialisierung. Solange keine SOE Datei geschrieben wurde.

1 - SOE Datei ist geöffnet

2 - Datei wurde geschlossen

3 - Zu viele SOE Dateien im Verzeichnis

4 - Fehler beim Schreiben der SOE Datei

5 - Fehler beim Erzeugen der SOE Datei

IOA 5

Variable liefert Statusinformation über den Dateitransfer.

0 - Kein Transfer aktiv

1 - Sektion wird selektiert

2 - Sektion wird angefordert

3 - Auf Sektionbestätigung wartend

4 - Auf Dateitransferbestätigung wartend

255 - Fehler beim Transfer

IOA 6

Variable liefert die Anzahl der im Transferverzeichnis vorhandenen SOE Dateien.


Pulsbildung

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Pulsbildung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Treiber unterstützt die Pulsbildung.
Sobald die Zeit für den Puls abgelaufen ist, wird der Wert OFF auf die Variable geschrieben.

Sobald die Kommunikation beendet wird, wird auch für alle noch aktiven Puls-Variablen der Puls beendet, also ein OFF geschrieben.

Die Kommunikation wird beendet, wenn:

  • die Process Gateway Applikation beendet wird
  • eine neue Konfiguration aktiviert wird
  • die Runtime ein Nachladen ausführt
  • die Liste der gepufferten Wertänderungen beim Sektor übergelaufen ist

Wird ein Puls für eine noch laufende Pulsbildung erneut veranlasst, wird die laufende Pulsbildung beendet. Die Variable erhält den Wert OFF.

Hinweis: Für SCS (single command state) der Wert OFF beträgt immer 0, für DCS (double command state) ein OFF beträgt 1 oder 0, je nach die "DPI/DCS mapping" Einstellung.


Nachladen

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Nachladen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wird eines der Projekte in der Runtime nachgeladen, dann wird die Verbindung zu allen Projekten abgebaut, welche die IOs beim Sektor verwenden. Das Gerät (device) mit dem entsprechenden Sektor benötigt einen Reset. Das bedeutet: Die Verbindung zum Master wird abgebaut.

Solange das Nachladen nicht abgeschlossen ist, kann keine Verbindung zur Runtime aufgebaut werden. Damit ist auch keine Generalabfrage möglich.


Broadcasts

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Broadcasts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Broadcasts werden für folgende TYP IDs unterstützt:

Typ ID

ID C_IC_NA_1

C_CS_NA_1


Echtzeit ungültig - Statusbit T_INVAL

Handbuch -> Process Gateway -> IEC870 Slave -> Kommunikation -> Echtzeit ungültig - Statusbit T_INVAL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Empfängt der IEC870 Treiber einen Echtzeitstempel, der als ungültig markiert ist, setzt er das Statusbit T_INVAL. In diesem Fall wird mit der lokalen PC-Zeit gestempelt. Im IEC870Slave des Process-Gateways wird dieses Statusbit in Melderichtung im Zeitstempel weitergeleitet.


Fehleranalyse

Handbuch -> Process Gateway -> IEC870 Slave -> Fehleranalyse

Sollte es zu Kommunikationsproblemen kommen, bietet dieses Kapitel Hilfen, um den Fehler zu finden.

Noch in diesem Kapitel

Analysetool

Fehlercodes

Checkliste


Analysetool

Handbuch -> Process Gateway -> IEC870 Slave -> Fehleranalyse -> Analysetool

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Process Gateway verhält sich wie ein zenon Treiber und schreibt Meldungen in eine gemeinsame Log-Datei. Um sie korrekt und übersichtlich anzuzeigen, benutzen Sie das Programm Diagnose Viewer, das mit zenon mitinstalliert wird. Sie finden es unter Start/Alle Programme/zenon/Tools 7.00 -> Diagviewer. Generell gilt:

zenon Treiber protokollieren alle Fehler in Log-Dateien. Der Standardordner für die Log-Dateien ist der Ordner LOG unterhalb des Ordners ProgramData, zum Beispiel: C:\ProgramData\zenon \zenon700\LOG für die zenon Version 7.00 SP0. Log-Dateien sind Textdateien mit einer speziellen Struktur.

Achtung: Mit den Standardeinstellungen zeichnet ein Treiber nur Fehlerinformationen auf. Mit dem Diagnose Viewer kann bei den meisten Treibern die Diagnose-Ebene auf „Debug" und „Deep Debug" erweitert werden. Damit protokolliert der Treiber auch alle anderen wesentlichen Aufgaben und Ereignisse.

Im Diagnose Viewer kann man auch:

  • eben erstellte Einträge live mitverfolgen
  • die Aufzeichnungseinstellungen anpassen
  • den Ordner, in dem die Log-Dateien gespeichert werden, ändern

Hinweise:

  1. Unter Windows CE werden aus Ressourcegründen auch Fehler standardmäßig nicht protokolliert.
  2. Der Diagnose Viewer zeigt alle Einträge in UTC (Koordinierter Weltzeit) an und nicht in der lokalen Zeit.
  3. Der Diagnose Viewer zeigt in seiner Standardeinstellung nicht alle Spalten einer Log-Datei an. Um mehr Spalten anzuzeigen, aktivieren Sie die Eigenschaft Add all columns with entry im Kontextmenü der Spaltentitel.
  4. Bei Verwendung von reinem Error-Logging befindet sich eine Problembeschreibung in der Spalte Error text. In anderen Diagnose-Ebenen befindet sich diese Beschreibung in der Spalte General text.
  5. Viele Treiber zeichnen bei Kommunikationsprobleme auch Fehlernummern auf, die die SPS ihnen zuweist. Diese werden in Error text und/oder Error code und/oder Driver error parameter(1 und 2) angezeigt. Hinweise zur Bedeutung der Fehlercodes erhalten Sie in der Treiberdokumentation und der Protokoll/SPS-Beschreibung.
  6. Stellen Sie am Ende Ihrer Tests den Diagnose-Level von Debug oder Deep Debug wieder zurück. Bei Debug und Deep Debug fallen beim Protokollieren sehr viele Daten an, die auf der Festplatte gespeichert werden und die Leistung Ihres Systems beeinflussen können. Diese werden auch nach dem Schließen des Diagnose Viewers weiter aufgezeichnet.

Hinweis: Process Gateway steht unter Windows CE nicht zur Verfügung.

info Info

Weitere Informationen zum Diagnose Viewer finden Sie im Kapitel Diagnose Viewer.

Noch in diesem Kapitel

Logging


Logging

Handbuch -> Process Gateway -> IEC870 Slave -> Fehleranalyse -> Analysetool -> Logging

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Treiber unterstützt ein umfangreiches Logging für:

  • Clientname
  • zenProcGateway_IEC870Slave
  • Module

Clientname

Wie der Name des Clients im Diagnoseviewer angezeigt wird, hängt von der Konfiguration ab. Daher ändert sich auch der Name, wenn der TCP-Port, der COM-Port oder das Protokoll geändert wird. In diesem Falle können sich auch die Einstellungen für das Logging ändern.

Wird der Process Gateway mehrfach mit den gleichen Einstellungen gestartet, wird auch der gleiche Clientname verwendet. Die Fehlermeldungen der beiden Instanzen lassen sich durch die Prozess-ID unterscheiden.

Example Beispiel

zenProcGateway_IEC870Slave

  • 104 Protokoll mit Standartport 2404
  • 101 wenn COM1 selektiert.
  • Wurde die Konfiguration noch nicht gelesen, sind Fehlermeldungen beim Startup immer unter diesen Client sichtbar.

zenProcGateway_IEC870Slave:COM4

  • 101 mit COM4.
    Der Name enthält den verwendeten COM-Port.

zenProcGateway_IEC870Slave:Port:12345

  • 104 mit Port 12345.
    Der Name enthält den Port für die Masteranbindung.

Module

Fehlermeldungen werden für alle Module angezeigt:

  • IEC870 Slave
  • OSI2
  • OSI7
  • SCADA-Runtime (ScadaRT)

IEC870 Slave

Betrifft die Anbindung zum Process Gateway und dessen Konfiguration.

Informationen zu:

  • Fehler bei der Projektierung

OSI2

Betrifft die Protokollebene. Hier ist das Framing mit den entsprechenden Funktionen implementiert.

Informationen zu:

  • Empfangene Daten als Byte Dump
  • Gesendete Daten als Byte Dump
  • Function codes für 101
  • Fehler auf dieser Ebene, z.B. im Framing
  • APCI für 104 (870-5-104 5)

Levels

  • Msg: Frame Interpretierung
  • Debug:
    Empfangene und gesendete Daten
    Frame Auswertung.
    Neue Master Verbindung.
  • Deep Debug: Jede Abfrage, ob Zeichen vorhanden. Produziert sehr viele Loggingeinträge!

OSI7

Betrifft die Applikationsebene.
Hier werden die Kommandos interpretiert und ausgeführt.

Informationen zu:

  • Protokollierung der 'process and system information'
  • Fehler in den ASDUs

Levels:

  • Warning: Rekursive interrogation
  • Msg: Process information, System information
  • Debug: Bestätigte I-Frames
  • Deep Debug: Interrogation Durchläufe. Produziert sehr viele Loggingeinträge!

SCADA-Runtime (ScadaRT)

Meldungen zur Anbindung an die Runtime:

Informationen zu:

  • angeforderte und abgemeldete Variablen
  • aktualisierte Variablen
  • Deaktivierung des Projekts

Levels

  • Debug:
    geänderte Werte
    Projekt inaktiv


Fehlercodes

Handbuch -> Process Gateway -> IEC870 Slave -> Fehleranalyse -> Fehlercodes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Fehlercodes können im Diagnoseviewer angezeigt werden:

Fehlercode | Bedeutung
570 | Wertänderung für unbekanntes zyklisches IO
571 | Transferpuffer zu klein um ein zyklisches IO zu übertragen


Checkliste

Handbuch -> Process Gateway -> IEC870 Slave -> Fehleranalyse -> Checkliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Ist der COM Port von einer anderen Anwendung belegt, bzw. stimmen seine Einstellungen ?
  • Ist das Gerät (die SPS), mit dem versucht wird eine Kommunikation herzustellen, an das Stromversorgungsnetz angeschlossen ?
  • Ist das Verbindungskabel zwischen Steuerung (SPS) und PC bzw. IPC korrekt angeschlossen ?
  • Wurde die „Error – Textdatei“ analysiert (Welche Fehler sind aufgetreten) ?
  • Zur weiteren Fehleranalyse senden Sie bitte die Projektsicherung und die LOG Datei des DiagViewes an Ihren zuständigen Support.


Interoperability

Handbuch -> Process Gateway -> IEC870 Slave -> Interoperability

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

This companion standard presents sets of parameters and alternatives from which subsets must be selected to implement particular telecontrol systems. Certain parameter values, such as the choice of 'structured' or'unstructured' fields of the informationobject address of ASDUs represent mutually exclusive alternatives. This means that only one value of the defined parameters is admitted per system. Other parameters, such as the listed set of different process information incommand and in monitor direction allow the specification of the complete set orsubsets, as appropriate for given applications. This clause summarizes theparameters of the previous clauses to facilitate a suitable selection for aspecific application. If a system is composed of equipment stemming from different manufacturers, it is necessary that all partners agree on the selected parameters.

The interoperability list is defined as in IEC 60870-5-101 and extended with parameters used in this standard. The text descriptions of parameters which are not applicable to this companion standard are strike-through (corresponding check box is marked black).

NOTE In addition, the full specification of a system may require individual selection of certain parameters for certain parts of the system, such as the individual selection of scaling factors for individually addressable measured values.

The selected parameters should bemarked in the white boxes as follows:

[ ] Function or ASDU is not used
[ X ] Function or ASDU is used as standardized (default)
[ R ] Function or ASDU is used in reverse mode
[ B ] Function or ASDU is used in standard and reverse mode

The possible selection (blank, X , R , or B ) is specified for each specific clause or parameter.

A black check box indicates that the option cannot be selected in this companion standard.

1. System or device

(system-specific parameter, indicate definition of a system or a device by marking one of the following with ' X ')

[ ] System definition
[ ] Controlling station definition (Master)
[ X ] Controlled station definition (Slave)

2. Network Configuration: 101 only

(network-specific parameter, all configurations that are used are to be marked ' X ')

[ X ] Point-to-point | [ X ] Multipoint
[ X ] Multiple point to point | [ ] Multipoint-star

3. Physical Layer: 101 only

(network-specific parameter, all interfaces and data rates that are used are to be marked ' X ')

Transmission speed (control direction)

Unbalanced interchange Circuit V.24/V.28 Standard | Unbalanced interchange Circuit V.24/V.28 Recommended if >1 200 bit/s | Balanced interchange Circuit X.24/X.27
[ ] 100 bit/s | [ X ] 2400 bit/s | [ ] 2400 bit/s
[ ] 200 bit/s | [ X ] 4800 bit/s | [ ] 4800 bit/s
[ X ] 300 bit/s | [ X ] 9600 bit/s | [ ] 9600 bit/s
[ X ] 600 bit/s | [ X ] 19200 bit/s | [ ] 19200 bit/s
[ X ] 1200 bit/s | [ X ] 38400 bit/s | [ ] 38400 bit/s
 | [ X ] 56000 bit/s | [ ] 56000 bit/s
 | [ X ] 57600 bit/s | [ ] 64000 bit/s
 | [ X ] 115200 bit/s |
 | [ X ] 128000 bit/s |
 | [ X ] 256000 bit/s |

Transmission speed (monitor direction)

Unbalanced interchange Circuit V.24/V.28 Standard | Unbalanced interchange Circuit V.24/V.28 Recommended if >1 200 bit/s | Balanced interchange Circuit X.24/X.27
[ ] 100 bit/s | [ X ] 2400 bit/s | [ ] 2400 bit/s
[ ] 200 bit/s | [ X ] 4800 bit/s | [ ] 4800 bit/s
[ X ] 300 bit/s | [ X ] 9600 bit/s | [ ] 9600 bit/s
[ X ] 600 bit/s | [ X ] 19200 bit/s | [ ] 19200 bit/s
[ X ] 1200 bit/s | [ X ] 38400 bit/s | [ ] 38400 bit/s
 | [ X ] 56000 bit/s | [ ] 56000 bit/s
 | [ X ] 57600 bit/s | [ ] 64000 bit/s
 | [ X ] 115200 bit/s |
 | [ X ] 128000 bit/s |
 | [ X ] 256000 bit/s |

4. Link layer: 101 only

(network-specific parameter, all options that are used are to be marked ' X '. Specify the maximum frame length. If a non-standard assignment of class 2 messages is implemented for unbalanced transmission, indicate the Type ID and COT of all messages assigned to class 2.)

Frame format FT 1.2, single character 1 and the fixed time out interval are used exclusively in this companion standard.

Link transmission | Frame length [octets] | Address field of the link
[ ] Balanced transmission | [255] Maximum length L (both directions)* | [ ] not present (balanced transmission only)
[ X ] Unbalanced transmission |  | [ X ] One octet
 |  | [ X ] Two octets
 |  | [ X ] Structured
 |  | [ X ] Unstructured

*may be reduced by the system

When using an unbalanced link layer, the following ASDU types are returned in class 2 messages (low priority) with the indicated causes of transmission:

[ ] The standard assignment of ASDUs to class 2 messages is used as follows:

Type identification | Cause of transmission
9, 11, 13, 21 | <1>

[ X ] A special assignment of ASDUs to class 2 messages is used as follows:

Type identification | Cause of transmission
120 - 126 | All (as specified in the standard)

Note: (In response to a class 2 poll, a controlled station may respond with class 1 data when there is no class 2 data available).

5. Application Layer

Transmission mode for application data

Mode 1 (Least significant octet first), as defined in 4.10 of IEC 60870-5-4, is used exclusively in this companion standard.

Common address of ASDU

(system-specific parameter, all configurations that are used are to be marked ' X ')

ASDU adress
101 only [ X ] One octet | [ X ] Two octets

Information object address

(system-specific parameter, all configurations that are used are to be marked ' X ')

Object adress
101 only [ X ] One octet | [ X ] Structured
101 only [ X ] Two octets | [ X ] Unstructured
[ X ] Three octets |

Cause of transmission

(system-specific parameter, all configurations that are used are to be marked ' X ')

Cause of transmission
101 only [ X ] One octet | [ X ] Two octets (with originator address) Originator address is set to zero if not used.

Length of APDU: 104 only

(system-specific parameter, specify the maximum length of the APDU per system)
The maximum length of APDU for both directions is 253. The maximum length may be reduced by the system.

[ 253 ] Maximum length of APDU per system

Selection of standard ASDUs

Process information in monitor direction

(station-specific parameter, mark each Type ID ' X ' if it is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

Mark | Parameter | Type
[ B ] | <1>: = Single-point information | M_SP_NA_1
[ B ] | <2>: = Single-point information with time tag | M_SP_TA_1
[ B ] | <3>: = Double-point information | M_DP_NA_1
[ B ] | <4>: = Double-point information with time tag | M_DP_TA_1
[ B ] | <5>: = Step position information | M_ST_NA_1
[ B ] | <6>: = Step position information with time tag | M_ST_TA_1
[ B ] | <7>: = Bitstring of 32 bit | M_BO_NA_1
[ B ] | <8>: = Bitstring of 32 bit with time tag | M_BO_TA_1
[ B ] | <9>: = Measured value, normalized value | M_ME_NA_1
[ B ] | <10>: = Measured value, normalized value with time tag | M_ME_TA_1
[ B ] | <11>: = Measured value, scaled value | M_ME_NB_1
[ B ] | <12>: = Measured value, scaled value with time tag | M_ME_TB_1
[ B ] | <13>: = Measured value, short floating point value | M_ME_NC_1
[ B ] | <14>: = Measured value, short floating point value with time tag | M_ME_TC_1
[ B ] | <15>: = Integrated totals | M_IT_NA_1
[ B ] | <16>: = Integrated totals with time tag | M_IT_TA_1
[ ] | <17>: = Event of protection equipment with time tag | M_EP_TA_1
[ ] | <18>: = Packed start events of protection equipment with time tag | M_EP_TB_1
[ ] | <19>: = Packed output circuit information of protection equipment with time tag | M_EP_TC_1
[ ] | <20>: = Packed single-point information with status change detection | M_SP_NA_1
[ ] | <21>: = Measured value, normalized value without quality descriptor | M_ME_ND_1
[ B ] | <30>: = Single-point information with time tag CP56Time2a | M_SP_TB_1
[ B ] | <31>: = Double-point information with time tag CP56Time2a | M_DP_TB_1
[ B ] | <32>: = Step position information with time tag CP56Time2a | M_ST_TB_1
[ B ] | <33>: = Bitstring of 32 bit with time tag CP56Time2a | M_BO_TB_1
[ B ] | <34>: = Measured value, normalized value with time tag CP56Time2a | M_ME_TD_1
[ B ] | <35>: = Measured value, scaled value with time tag CP56Time2a | M_ME_TE_1
[ B ] | <36>: = Measured value, short floating point value with time tag CP56Time2a | M_ME_TF_1
[ B ] | <37>: = Integrated totals with time tag CP56Time2a | M_IT_TB_1
[ ] | <38>: = Event of protection equipment with time tag CP56Time2a | M_EP_TD_1
[ ] | <39>: = Packed start events of protection equipment with time tag CP56Time2a | M_EP_TE_1
[ ] | <40>:= Packed output circuit information of protection equipment with time tag CP56Time2a | M_EP_TF_1

Either the ASDUs of the set <2>, <4>, <6>, <8>, <10>, <12>, <14>, <16>, <17>, <18>, <19> or of the set <30> – <40> are used.

Process information in control direction

(station-specific parameter, mark each Type ID ' X ' if it is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

Mark | Parameter | Type
[ X ] | <45>: = Single command | C_SC_NA_1
[ X ] | <46>: = Double command | C_DC_NA_1
[ X ] | <47>: = Regulating step command | C_RC_NA_1
[ X ] | <48>: = Set point command, normalized value | C_SE_NA_1
[ X ] | <49>: = Set point command, scaled value | C_SE_NB_1
[ X ] | <50>: = Set point command, short floating point value | C_SE_NC_1
[ X ] | <51>: = Bitstring of 32 bit | C_BO_NA_1
[ X ] | <58>: = Single command with time tag CP56Time2a | C_SC_TA_1
[ X ] | <59>: = Double command with time tag CP56Time2a | C_DC_TA_1
[ X ] | <60>: = Regulating step command with time tag CP56Time2a | C_RC_TA_1
[ X ] | <61>: = Set point command, normalized value with time tag CP56Time2a | C_SE_TA_1
[ X ] | <62>: = Set point command, scaled value with time tag CP56Time2a | C_SE_TB_1
[ X ] | <63>: = Set point command, short floating point value with time tag CP56Time2a | C_SE_TC_1
[ X ] | <64>:= Bitstring of 32 bit with time tag CP56Time2a | C_BO_TA_1

Either the ASDUs of the set <45> – <51> or of the set <58> – <64> are used.

System information in monitor direction

(station-specific parameter, mark ' X ' if used)

Mark | Parameter | Type
[ X ] | <70> : = End of initialization | M_EI_NA_1

System information in control direction

(station-specific parameter, mark each Type ID ' X ' if it is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

Mark | Parameter | Type
[ X ] | <100>: = Interrogation command* | C_IC_NA_1
[ X ] | <101>: = Counter interrogation command | C_CI_NA_1
[ X ] | <102>: = Read command | C_RD_NA_1
[ X ] | <103>: = Clock synchronization command (option see 7.6)* | C_CS_NA_1
[ ] | <104>: = Test command | C_TS_NA_1
[ X ] | <105>: = Reset process command | C_RP_NA_1
[ ] | <106>: = Delay acquisition command | C_CD_NA_1
[ ] | <107>: = Test command with time tag CP56Time2a | C_TS_TA_1

*also Broadcast (with Common Address of ASDU = 0xFF or 0xFFFF)

Parameter in control direction

(station-specific parameter, mark each Type ID ' X ' if it is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

Mark | Parameter | Type
[ ] | <110>: = Parameter of measured value, normalized value | P_ME_NA_1
[ ] | <111>: = Parameter of measured value, scaled value | P_ME_NB_1
[ ] | <112>: = Parameter of measured value, short floating point value | P_ME_NC_1
[ ] | <113>: = Parameter activation | P_AC_NA_1

File transfer

(station-specific parameter, mark each Type ID ' X ' if it is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

Mark | Parameter | Type
[ X ] | <120>: = File ready | F_FR_NA_1
[ X ] | <121>: = Section ready | F_SR_NA_1
[ X ] | <122>: = Call directory, select file, call file, call section | F_SC_NA_1
[ X ] | <123>: = Last section, last segment | F_LS_NA_1
[ X ] | <124>: = Ack file, ack section | F_AF_NA_1
[ X ] | <125>: = Segment | F_SG_NA_1
[ X ] | <126>: = Directory {blank or X, only available in monitor (standard) direction} | F_DR_TA_1

Type identifier and Cause of transmission assignments

(station-specific parameters)

Shaded boxes: option not required.
Blank: functions or ASDU not used.

Mark Type Identification/Cause of transmission combinations:
' X ' if only used in the standard direction;
' R ' if only used in the reverse direction;
' B ' if used in both directions.

Type identification |  | Cause of transmission
 |  | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 20 to 36 | 37 to 41 | 44 | 45 | 46 | 47
<1> | M_SP_NA_1 |  | B | B |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |
<2> | M_SP_TA_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<3> | M_DP_NA_1 |  | B | B |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |
<4> | M_DP_TA_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<5> | M_ST_NA_1 |  | B | B |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |
<6> | M_ST_TA_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<7> | M_BO_NA_1 |  | B | B |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |
<8> | M_BO_TA_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<9> | M_ME_NA_1 | B | B | B |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |
<10> | M_ME_TA_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<11> | M_ME_NB_1 | B | B | B |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |
<12> | M_ME_TB_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<13> | M_ME_NC_1 | B | B | B |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |
<14> | M_ME_TC_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<15> | M_IT_NA_1 |  |  | B |  | X |  |  |  |  |  |  |  |  | X1 | X |  |  |  |
<16> | M_IT_TA_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  | X |  |  |  |
<17> | M_EP_TA_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<18> | M_EP_TB_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<19> | M_EP_TC_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<20> | M_PS_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<21> | M_ME_ND_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<30> | M_SP_TB_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<31> | M_DP_TB_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<32> | M_ST_TB_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<33> | M_BO_TB_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<34> | M_ME_TD_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<35> | M_ME_TE_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<36> | M_ME_TF_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |
<37> | M_IT_TB_1 |  |  | B |  | X |  |  |  |  |  |  |  |  |  | X |  |  |  |
<38> | M_EP_TD_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<39> | M_EP_TE_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<40> | M_EP_TF_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<45> | C_SC_NA_1 |  |  |  |  |  | X | X | X2 | X2 | X |  |  |  |  |  |  |  | X | X
<46> | C_DC_NA_1 |  |  |  |  |  | X | X | X2 | X2 | X |  |  |  |  |  |  |  | X | X
<47> | C_RC_NA_1 |  |  |  |  |  | X | X | X2 | X2 | X |  |  |  |  |  |  |  | X | X
<48> | C_SE_NA_1 |  |  |  |  |  | X | X | X2 | X2 | X |  |  |  |  |  |  |  | X | X
<49> | C_SE_NB_1 |  |  |  |  |  | X | X | X2 | X2 | X |  |  |  |  |  |  |  | X | X
<50> | C_SE_NC_1 |  |  |  |  |  | X | X | X2 | X2 | X |  |  |  |  |  |  |  | X | X
<51> | C_BO_NA_1 |  |  |  |  |  | X | X | X2 | X2 | X |  |  |  |  |  |  |  | X | X
<58> | C_SC_TA_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X | X
<59> | C_DC_TA_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X | X
<60> | C_RC_TA_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X | X
<61> | C_SE_TA_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X | X
<62> | C_SE_TB_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X | X
<63> | C_SE_TC_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X | X
<64> | C_BO_TA_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X | X
<70> | M_EI_NA_1* |  |  |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<100> | C_IC_NA_1 |  |  |  |  |  | X | X | X | X | X |  |  |  |  |  |  |  | X |
<101> | C_CI_NA_1 |  |  |  |  |  | X | X |  |  | X |  |  |  |  |  |  |  | X |
<102> | C_RD_NA_1 |  |  |  |  | X |  |  |  |  |  |  |  |  |  |  |  | X | X | X
<103> | C_CS_NA_1 |  |  |  |  |  | X | X |  |  |  |  |  |  |  |  |  | X | X |
<104> | C_TS_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<105> | C_RP_NA_1 |  |  |  |  |  | X | X |  |  |  |  |  |  |  |  |  | X | X |
<106> | C_CD_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<107> | C_TS_TA_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<110> | P_ME_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<111> | P_ME_NB_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<112> | P_ME_NC_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<113> | P_AC_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
<120> | F_FR_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  | X |  |  |  |  | X |
<121> | F_SR_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  | X |  |  |  |  | X |
<122> | F_SC_NA_1 |  |  |  |  | X |  |  |  |  |  |  |  | X |  |  |  | X | X |
<123> | F_LS_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  | X |  |  |  |  | X |
<124> | F_AF_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  | X |  |  |  | X | X |
<125> | F_SG_NA_1 |  |  |  |  |  |  |  |  |  |  |  |  | X |  |  |  |  | X |
<126> | F_DR_TA_1* |  |  | X |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |

* Blank or X only

1 Optional.

2 Slave confirms deactivations of write command (TI <45> ... <64>) but corresponding activation is already transferred to execution; actcon and actterm were already sent .

COT | Cause of Transmission |
<0> | not used |
<1> | periodic, cyclic | per/cyc
<2> | background scan | back
<3> | spontaneous | spont
<4> | initialized | init
<5> | request or requested | req
<6> | activation | act
<7> | activation confirmation | actcon
<8> | deactivation | deact
<9> | deactivation confirmation | deactcon
<10> | activation termination | actterm
<11> | return information caused by a remote command | retrem
<12> | return information caused by a local command | retloc
<13> | file transfer | file
<14...19> | reserved |
<20> | interrogated by station interrogation | inrogen
<21...36> | interrogated by interrogation of the group 1..16 | inro1..16
<37> | requested by general counter request | reqcogen
<38...41> | requested by counter interrogation of the group 1 ... 4 | reqco1..4
<42, 43> | reserved |
<44> | unknown type identification |
<45> | unknown cause of transmission |
<46> | unknown common address of ASDU |
<47> | unknown information object address |
<48, 63> | for special use (private range) |

6. Basic application functions

Station initialization

(station-specific parameter, mark 'X' if function is used)

[ ] Remote initialization

Cyclic data transmission

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions)

[ X ] Cyclic data transmission

Read procedure

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions)

[ X ] Read procedure

Spontaneous transmission

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions)

[ B ] Spontaneous transmission

Double transmission of information objects with cause of transmission spontaneous

(station-specific parameter, mark each information type ' X ' where both a Type ID without time and corresponding Type ID with time are issued in response to a single spontaneous change of a monitored object)

The following type identifications may be transmitted in succession caused by a single status change of an information object. The particular information object addresses for which double transmission is enabled are defined in a project-specific list.

[ ] Single-point information M_SP_NA_1, M_SP_TA_1, M_SP_TB_1 and M_PS_NA_1
[ ] Double-point information M_DP_NA_1, M_DP_TA_1 and M_DP_TB_1
[ ] Step position information M_ST_NA_1, M_ST_TA_1 and M_ST_TB_1
[ ] Bitstring of 32 bit M_BO_NA_1, M_BO_TA_1 and M_BO_TB_1 (if defined for a specific project)
[ ] Measured value, normalized value M_ME_NA_1, M_ME_TA_1, M_ME_ND_1 and M_ME_TD_1
[ ] Measured value, scaled value M_ME_NB_1, M_ME_TB_1 and M_ME_TE_1
[ ] Measured value, short floating point number M_ME_NC_1, M_ME_TC_1 and M_ME_TF_1

Station interrogation

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ X ] global |  |
[ ] group 1 | [ ] group 7 | [ ] group 13
[ ] group 2 | [ ] group 8 | [ ] group 14
[ ] group 3 | [ ] group 9 | [ ] group 15
[ ] group 4 | [ ] group 10 | [ ] group 16
[ ] group 5 | [ ] group 11 | Information object addresses assigned to each group must be shown in a separate table.
[ ] group 6 | [ ] group 12

Clock synchronization

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ X ] Clock synchronization

[ ] Day of week used
[ ] RES1, GEN (time tag substituted/ not substituted) used
[ B ] SU-bit (summertime) used

optional, see 7.6

Command transmission

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ X ] Direct command transmission
[ X ] Direct set point command transmission
[ X ] Select and execute command
[ X ] Select and execute set point command
[ ] C_SE ACTTERM used

[ X ] No additional definition
[ X ] Short-pulse duration (duration determined by a system parameter in the outstation)
[ X ] Long-pulse duration (duration determined by a system parameter in the outstation)
[ X ] Persistent output

[ ] Supervision of maximum delay in command direction of commands and set point commands
[ ] Maximum allowable delay of commands and set point commands

Transmission of integrated totals

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ X ] Mode A: Local freeze with spontaneous transmission
[ X ] Mode B: Local freeze with counter interrogation
[ X ] Mode C: Freeze and transmit by counter-interrogation commands
[ X ] Mode D: Freeze by counter-interrogation command, frozen values reported spontaneously

[ X ] Counter read
[ X ] Counter freeze without reset
[ ] Counter freeze with reset
[ ] Counter reset

[ X ] General request counter
[ ] Request counter group 1
[ ] Request counter group 2
[ ] Request counter group 3
[ ] Request counter group 4

Parameter loading

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ ] Threshold value
[ ] Smoothing factor
[ ] Low limit for transmission of measured values
[ ] High limit for transmission of measured values

Parameter activation

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ ] Act/deact of persistent cyclic or periodic transmission of the addressed object

Test procedure

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ ] Test procedure

File transfer

(station-specific parameter, mark 'X' if function is used).
File transfer in monitor direction

[ X*] Transparent file
[ ] Transmission of disturbance data of protection equipment
[ X ] Transmission of sequences of events
[ ] Transmission of sequences of recorded analogue values

* a data can be transparently transported by the system but not generated or evaluated. Maximum file size is 16711680 bytes.

File transfer in control direction

[ ] Transparent file

Background scan

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ X ] Background scan

Acquisition of transmission delay

(station-specific parameter, mark ' X ' if function is only used in the standard direction, ' R ' if only used in the reverse direction, and ' B ' if used in both directions).

[ ] Acquisition of transmission delay

Definition of time outs: 104 only

Parameter | Default value | Remarks | Selected value
t0 | 30 s | Time-out of connection establishment | not fixed
t1 | 15 s | Time-out of send or test APDUs | not fixed
t2 | 10 s | Time-out for acknowledges in case of no data messages; t2 < t1 | not fixed
t3 | 20 s | Time-out for sending test frames in case of a long idle state; t3 > t1 | not fixed

Recommended range for timeouts t0 - t2 : 1s to 255s, accuracy 1s

Recommended range for timeout t3 : 0s to 48hrs, accuracy 1s
Long timeouts for t3 may be needed in special cases where satellite links or dialup connections are used (e.g. to establish connection and collect values only once per day or week). For dialup connections it may be necessary to give up the connection supervision completely. This is achievable by setting the timeout t3 to zero.

Maximum number of outstanding I format APDUs k and latest acknowledge APDUs (w): 104 only

Parameter | Default value | Remarks | Selected value
k | 12 APDUs | Maximum difference receive sequence number to send state variable | not fixed
w | 8 APDUs | Latest acknowledge after receiving w I format APDUs | not fixed

Recommended range of values k: 1 to 32767 (215–1) APDUs, accuracy 1 APDU

Recommended range of values w: 1 to 32767 APDUs, accuracy 1 APDU (Recommendation: w should not exceed two-thirds of k)

Portnumber: 104 only

Parameter | Default value | Remarks
Portnumber | 2404 | not fixed

Redundant connections

[ ] Number N of redundancy group connections used

RFC 2200 suite

RFC 2200 is an official Internet Standard which describes the state of standardization of protocols used in the Internet as determined by the Internet Architecture Board (IAB). It offers a broad spectrum of actual standards used in the Internet. The suitable selection of documents from RFC 2200 defined in this standard for given projects has to be chosen by the user of this standard.

[ ] Ethernet 802.3
[ ] Serial X.21 interface
[ ] Other selection from RFC 2200:

List of valid documents from RFC 2200
1. ..........................................................................
2. ..........................................................................
3. ..........................................................................
4. ..........................................................................
5. ..........................................................................
6. ..........................................................................
7. etc.


MODBUS Slave

Handbuch -> Process Gateway -> MODBUS Slave

Noch in diesem Kapitel

Modulkonfiguration

Hardware-Adresse des MODBUS-Systems

Konfigurationsdatei: spezifische Einträge für AccessMODBUS


Modulkonfiguration

Handbuch -> Process Gateway -> MODBUS Slave -> Modulkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach Klick auf die Schaltfläche Konfiguration erscheint folgender Dialog:

Hier können zum einen die Variablen, die gekoppelt werden sollen, ausgewählt werden. In der linken Liste werden alle in zenon verfügbaren Variablen angezeigt. Diese können selektiert werden und mit dem '>'-Button in die In MODBUS exportiert Liste verschoben werden. Mit dem '<'-Button können sie wieder entfernt werden. Wird eine Variable in die Exportiert-Liste verschoben, erscheint ein Dialog zur Nameszuordnung der zenon Variable zu einem Offset in MODBUS:

Die so ausgewählten Variablen werden dann in zenon bzw. im MODBUS-System laufend synchronisiert.

Im unteren Teil des Konfigurations-Dialogs kann die serielle bzw. TCP/IP-Verbindung zum MODBUS-System konfiguriert werden.

Für die Konfiguration der seriellen Schnittstelle sind folgende Einstellungen möglich:

Com | Die serielle Schnittstelle, über die auf das MODBUS-System zugegriffen wird.
Datenbit | Anzahl der Daten-Bits. Default: 8
Stopbit | Anzahl der Stop-Bits. Default: 1
Baudrate | Baudrate der seriellen Schnittstelle. Default: 9600
Parität | Paritätseinstellung: Gerade (Even)/Ungerade (Odd)/Keine (No) (default: No)
Slave Adress | Modbus Unit ID. Default: 1

Für die Konfiguration über TCP/IP lassen sich der Port und die Timeoutzeit in Sekunden einstellen.


Hardware-Adresse des MODBUS-Systems

Handbuch -> Process Gateway -> MODBUS Slave -> Hardware-Adresse des MODBUS-Systems

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das MODBUS-System vom Process Gateway hat eine einstellbare MODBUS-Hardware-Adresse. Diese wird im Konfigurationsdialog über die Eigenschaft Slave Adress eingestellt. Als Standard wird die Adresse 1 vorgegeben.


Konfigurationsdatei: spezifische Einträge für AccessMODBUS

Handbuch -> Process Gateway -> MODBUS Slave -> Konfigurationsdatei: spezifische Einträge für AccessMODBUS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfigurationsdatei muss im Systemordner liegen.

Parameter | Beschreibung
[MODBUS] |
COMPORT | Serielle Schnittstelle (COM1 = 0, COM2 = 1,...). Kann über Konfigurationsdialog eingestellt werden.
BAUD | Baudrate der seriellen Schnittstelle. Kann über Konfigurationsdialog eingestellt werden.
BYTESIZE | Anzahl Datenbits der seriellen Schnittstelle
PARITY | Paritätseinstellungen der seriellen Schnittstelle: 0=No 1=Odd 2=Even Kann über Konfigurationsdialog eingestellt werden.
STOPBITS | Anzahl Stoppbits der seriellen Schnittstelle 0=1 1=1.5 2=2 Kann über Konfigurationsdialog eingestellt werden.
TIMEOUT | Timeoutintervall bei serieller Kommunikation in Millisekunden
HWADDRESS | Hardwareadresse des MODBUS-Systems. Default: 1 Kann über Konfigurationsdialog eingestellt werden.
REFRESHRATE | Updatezeit in Millisekunden
SERIELL | Serielle oder TCP/IP Kommunikation: 1 = seriell 0 = TCP/IP Kann über Konfigurationsdialog eingestellt werden.
PORT | TCP/IP-Port
TCPTIMEOUT | TCP/IP-Timeout Intervall in Sekunden

Parameter | Beschreibung
[VARIABLES] |
COUNT | Anzahl der zu exportierenden Variablen
NAME_n | Name der n-ten Variable
OFFSET_n | Modbus-Adresse der Variable


OPC UA Server

Handbuch -> Process Gateway -> OPC UA Server

Der OPC Server stellt die im Projekt verwendeten Variablen allen handelsüblichen OPC Client Tools zur Verfügung.

Der Vorläufer des OPC UA Servers ist der OPC Server. Dieser ist nicht Teil des Process Gateways.

Der OPC UA Treiber und alle Dialoge stehen nur in englischer Sprache zur Verfügung.

info Info

Der OPC UA Server kann für alle zenon Versionen ab 5.50 eingesetzt werden.

Noch in diesem Kapitel

Vergleich OPC Server und OPC UA Server

Modulkonfiguration

Start

Verbindung

Sicherheit

Alarme und Zustände

Service Sets

Fehlermeldungen


Vergleich OPC Server und OPC UA Server

Handbuch -> Process Gateway -> OPC UA Server -> Vergleich OPC Server und OPC UA Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die OPC UA Server Technik hat den OPC Server abgelöst. In den meisten Einsatzgebieten empfiehlt sich die Verwendung des OPC UA Servers.

OPC Server

  • OPC Task Force seit 1995
  • einheitliche Schnittstelle in der Automatisierungstechnik
  • baut auf Microsofts COM/DCOM Technologie auf
  • Seit 1996 OPC Foundation
  • mehrere Spezifikationen für unterschiedliche Anwendungsfälle

OPC UA Server

  • Erste Vision 2003
  • Freigabe 2006, noch nicht alle Teile

Vergleich OPC Server mit OPC UA Server

Parameter | OPC Server | OPC UA Server
Datenmodell | eingeschränkt | für alle Anwendungsgebiete
Implementierung | herstellerabhängig | herstellerunabhängig
Interoperabilität | nein | ja
Konfiguration | aufwändig | einfach
Netzwerk-Einsatz | nicht empfohlen (Sicherheit); Windows CE nicht einsetzbar | ja
Netzwerk-Technologie | DCOM (fehleranfällig, instabil) | OPC UA TCP binary Protocol
Performance | niedrig | hoch
Plattformen | nur Windows | unabhängig
Redundanz | nein | ja
Ressourcenbedarf | hoch | niedriger
Serviceorientierte Architektur | nein | ja
Sicherheit | veraltet | nach aktuellen Standards
Verbindungssicherheit | nein | gegeben
Windows CE | nein | ja


Modulkonfiguration

Handbuch -> Process Gateway -> OPC UA Server -> Modulkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Start

Um das Process Gateway mit dem Modul OPC UA zu starten, muss dieses in der zenProcGateway.ini eingetragen sein. Beim ersten Start des Process Gateways mit dem Modul OPC UA wird die Konfiguration der Zertifikate abgefragt.

Sofern keine eigenen Zertifikate eingesetzt werden, sollten die Zertifikate mit Klick auf Ja automatisch erstellt werden.

Nach dem Start des Process Gatways werden statistische Informationen zur Anzahl der Updates im angezeigten Zeitraum und Zahl der fehlgeschlagenen Updates angezeigt. In diesem Dialog kann auch die Konfiguration gestartet werden.

Parameter | Beschreibung
Exit | Schließt Process Gateway.
Configuration | Öffnet Konfigurationsdialog.
Help | Öffnet Hilfe.

Um Server und Variablen zu konfigurieren:

  1. klicken Sie auf Configuration
  2. im sich öffnenden Dialog konfigurieren Sie:
    • Server
    • Variablen

Noch in diesem Kapitel

Server

Variablen


Server

Handbuch -> Process Gateway -> OPC UA Server -> Modulkonfiguration -> Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klick auf Configuration im Process Gateway Statistikdialog öffnet den Konfigurationsdialog:

Parameter

Beschreibung

Name

Name des Servers, wie er am Client angezeigt wird.

Port

TCP Port über den der Client die Verbindung herstellt.

Default: 4840

Certificate revocation list path

Datei mit allen ungültigen Schlüsseln.

Certificate trust list path

Pfad, der alle vertrauenswürdigen Schlüssel enthält. Sollte dem des Serverzertifikats entsprechen.

Server certificate path

Öffentlicher Schlüssel des Servers. Wird vom Client zum Verschlüsseln der Nachrichten verwendet.

Server private key path

Privater Schlüssel des Servers. Wird vom Server zum Entschlüsseln der Nachrichten des Clients benutzt.

Accept secure connections only

Aktiv: Nur sichere Verbindungen werden für den Verbindungsaufbau akzeptiert, jeweils mit Signatur oder mit Signatur und Verschlüsselung:

  • Basic128Rsa15:
    RSA15 als Key Wrap-Algorithmus und
    128-bit Basic als Algorithmus für die Nachrichtenverschlüsselung
  • Basic256:
    256-bit Basic als Algorithmus für die Nachrichtenverschlüsselung

Default: inaktiv

Trust all client certificates

Aktiv: Alle Client-Zertifikate werden akzeptiert, die Verbindung wird aufgebaut.

Inaktiv: Alle Clients, die sich mit dem Server verbinden wollen, müssen ein gültiges Zertifikat übermitteln. Dieses Zertifikat wird zusätzlich darauf überprüft, ob es sich in der Liste der bekannten Client-Zertifikate (Certificate trust list path) befindet.

Use zenon authentication

Aktiv: Clients können sich am Server nur mit gültiger Benutzerkennung und Passwort anmelden.

Hinweis: Die Benutzerverwaltung muss aktiv sein.

Inaktiv: Anonyme Anmeldung ist möglich.

Archive for historical data

Archiv für historische Daten. AUswahl aus Dropdownliste. Archiv muss bereits angelegt sein.

OK

Bestätigt alle Einstellungen und schließt den Dialog.

Achtung: Alle aktiven Verbindungen werden beendet und der Server wird mit den neuen Einstellungen neu gestartet. Dabei können Verbindungsfehler auftreten.

Cancel

Verwirft alle geänderten Einstellungen und schließt den Dialog.

Help

Öffnet die Online-Hilfe.


Variablen

Handbuch -> Process Gateway -> OPC UA Server -> Modulkonfiguration -> Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen

Variablen für das OPC UA Process Gateway können automatisch oder individuell ausgewählt werden.

attention Achtung

Variablen, für die im Editor die Eigenschaft SW setzen aktiv nicht gesetzt wurde, können von einem OPC UA Client nicht beschrieben werden.

Interne ID: Variablen

SW setzen aktiv

Aktiv: Diese Variable für "Sollwert setzen" Aktionen freigeben.
Inaktiv: Diese Variable ist schreibgeschützt.
Default: aktiv

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Variablen definieren

Werden in der OPC UA Server Konfiguration keine Variablen definiert, dann werden alle Variablen aus dem zenon Projekt zum OPC UA Address Space hinzugefügt. Damit sind alle Variablen (auch Systemvariablen) für die Clients sichtbar. Dabei wird für jede Variable ein eigener Knoten (Node) mit automatisch vergebenem numerischen Identifier und Namespace Index 80 vergeben.

Bei der manuellen Konfiguration (mindestens eine konfigurierte Variable), werden die vom Benutzer definierten Werte verwendet. Standardmäßig werden ebenfalls der Namespace Index 80 und ein String Identifier mit dem Variablennamen eingetragen.

Parameter

Beschreibung

Available in zenon

Liste der vorhandenen Variablen.

Exported to OPC UA

Liste der exportierten Variablen.

Node Id

Namespace index

Definiert den Namespace Index in der Node ID für die ausgewählte OPC UA Variable.

Der Wert:

  • darf nicht leer sein
  • muss numerisch sein
  • muss größer 0 sein

Identifier

Definiert den Identifier in der Node ID für die selektierte OPC UA Variable.

  • Bei einer numerischen Eingabe wird automatisch ein numerischer Identifier erzeugt.
  • Wird eine GUID eingegeben, wird ein GUID Identifier erzeugt, andernfalls wird der Identifier als String behandelt.
    GUID-Form: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)

Das Feld darf nicht leer sein.

Um Variablen nach OPC UA zu exportieren:

  1. wählen Sie in Available in zenon die gewünschten Variablen aus (Mehrfachselektion ist möglich)
  2. klicken Sie auf den Pfeil Richtung Exported to OPC UA

Um alle Variablen zu exportieren:

  • klicken Sie auf den Doppelpfeil

Als Browsename und Displayname wird der zenon Variablenname verwendet.

info Info

Bei zenon Variablen mit einem Slash (/) im Namen, wird der / durch einen Punkt (.) ersetzt. Die durch Slash getrennten Teile des Namens werden in eigenen Unterordnern gespeichert.

Beispiel: Die zenon Variable "Static/Scalar/Int32" wird aufgeteilt in:

  • eine OPC UA Variable "Int32"
  • in einem Ordner "Scalar",
  • der ein Unterordner des Ordners "Static" ist

Das funktioniert mit allen Datentypen, mehrdimensionalen Arrays, Umlauten im Namen und Slashes am Ende.


Start

Handbuch -> Process Gateway -> OPC UA Server -> Start

Beim Start lädt das Process Gateway den konfigurierten Treiber.

Der Treiber versucht, die aktive Konfiguration aus der angegebenen INI-Datei auszulesen. Ist das nicht möglich, wird eine Fehlermeldung ausgegeben und der Konfigurationsdialog geöffnet. Wird die Konfiguration nicht mit OK bestätigt, wird das Process Gateway geschlossen.

attention Achtung

Wir die Anwendung als unsichtbar gestartet, wird auch kein Konfigurationsdialog angezeigt. Ist die Konfiguration ungültig oder nicht vorhanden, wird das Process Gateway automatisch geschlossen.


Verbindung

Handbuch -> Process Gateway -> OPC UA Server -> Verbindung

Das OPC UA Process Gateway unterstützt nur das OPC UA TCP binary Protocol und beinhaltet keinen Discovery Server. Der Client muss also direkt zum Server verbinden. Die Verbindungsadresse entspricht dem Schema: opc.tcp://hostname.of.server:port.

Die Verbindung kann gesichert werden.


Sicherheit

Handbuch -> Process Gateway -> OPC UA Server -> Sicherheit

Das Modul verwendet die OPC UA entsprechenden Sicherheitsprozeduren (signieren und verschlüsseln von Nachrichten) wie im Standard definiert. Zertifikate können je nach Einstellung überprüft oder pauschal akzeptiert werden.

Sichere Verbindungen

Wird die Option Accept secure connections only aktiviert, dann akzeptiert der Server nur noch Verbindungen, die als Security Mode entweder Sign oder Sign & Encrypt verwenden. Außerdem muss vom Client als Security Policy Basic128Rsa15 oder Basic256 benutzt werden. Bei deaktivierter Option wird jede beliebige Kombination von Security Mode und Security Policy akzeptiert.

Benutzerverwaltung

Ist im zenon Projekt die Benutzerverwaltung aktiviert und mindestens ein Benutzer angelegt, dann steht die Option Use zenon user authentication zur Verfügung. Wird sie aktiviert, haben nur noch Clients, die eine gültige Benutzer/Passwort Kombination senden, Zugriff auf die Daten des OPC UA Servers. Ist sie inaktiv, findest keine Überprüfung statt und es werden sowohl anonyme Verbindungen als auch alle Benutzer/Passwort-Kombinationen akzeptiert.


Alarme und Zustände

Handbuch -> Process Gateway -> OPC UA Server -> Alarme und Zustände

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das OPC UA Process Gateway unterstützt das zenon Informationsmodell für Alarme und Zustände. Es wird aktiviert, sobald eine Variable über mindestens einen Grenzwert verfügt.

Ab der Aktivierung kann ein verbundener Client über Grenzwertverletzungen einer Variablen informiert werden. Er ist auch auch in der Lage, den Alarm wie in der zenon Runtime zu bestätigen.

Die OPC Gewichtung, wie im Standard definiert, wird auf den Index der mit dem Grenzwert verbundenen Alarm/Ereignis-Klassen abgebildet. Der Index einer Alarm/Ereignis-Klasse wird vom zenon Editor mit jeder neuen Alarm/Ereignis-Klasse automatisch hochgezählt und kann in den Eigenschaften überprüft werden. Es werden bis zu 20 Klassen mit folgender Zuordnung unterstützt:

OPC UA Bereich | zenon Alarm/Ereignis-Klasse | OPC Gewichtung
HIGH | 20 | 1000
 | 19 | 950
 | 18 | 900
 | 17 | 850
MEDIUM HIGH | 16 | 800
 | 15 | 750
 | 14 | 700
 | 13 | 650
MEDIUM | 12 | 600
 | 11 | 550
 | 10 | 500
 | 9 | 450
MEDIUM LOW | 8 | 400
 | 7 | 350
 | 6 | 300
 | 5 | 250
LOW | 4 | 200
 | 3 | 150
 | 2 | 100
 | 1 | 50

Wenn eine Variable mit keiner Alarm/Ereignis-Klasse verknüpft ist, wird die niedrigst mögliche Einstufung 1 (LOW) verwendet.

Abbildung zenon Alarme als Objekt

zenon Variablen und darauf bezogene Alarme werden im OPC UA Server als Objekte abgebildet.

Der Screenshot zeigt die Einbindung des zenon Projekts (TEST651) und der zenon Variablen (WIZ_VAR_10, WIZ_VAR_11, WIZ_VAR_12) als Objekte im oberen Bereich. Darunter die Alarme durch Erreichen der Grenzwerte erzeugten Alarme (Limit 750 reached! usw).

Logging

Der Treiber unterstützt eine umfangreiche Logging-Funktion über den Diagnose Viewer.


Service Sets

Handbuch -> Process Gateway -> OPC UA Server -> Service Sets

Service Set | Wird unterstützt
Discovery Service Set |
FindServers | ja
GetEndpoints | ja
RegisterServer | nein
SecureChannel Service Set |
OpenSecureChannel | nein
CloseSecureChannel | nein
Session Service Set |
CreateSession | ja
ActivateSession | ja
CloseSession | ja
Cancel | nein
NodeManagement Service Set |
AddNodes | nein
AddReferences | nein
DeleteNodes | nein
DeleteReferences | nein
View Service Set |
Browse | ja
BrowseNext | nein
TranslateBrowsePathsToNodeIds | ja
RegisterNodes | nein
UnregisterNodes | nein
Query Service Set |
QueryFirst | nein
QueryNext | nein
Attribute Service Set |
Read | ja
HistoryRead | nein
Write | ja
HistoryUpdate | nein
Method Service Set |
Call | ja
MonitoredItem Service Set |
CreateMonitoredItems | ja
ModifyMonitoredItems | ja
SetMonitoringMode | ja
SetTriggering | nein
DeleteMonitoredItems | ja
Subscription Service Set |
CreateSubscription | ja
ModifySubscription | ja
SetPublishingMode | ja
Publish | ja
Republish | ja
TransferSubscriptions | nein
DeleteSubscriptions | ja


Fehlermeldungen

Handbuch -> Process Gateway -> OPC UA Server -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehlermeldungen in Logs:

Fehlermeldung | Debug Level | Beschreibung
Failed to validate client certificate | Error | Das Client-Zertifikat konnte nicht validiert werden. Es ist entweder ungültig (eventuell Gültigkeitsdatum überschritten) oder es wurde in der Liste der bekannten Client-Zertifikate nicht gefunden. Eine zusätzliche Information inklusive eine Fehlernummer beschreibt den Fehler genauer.
Wrong user/password supplied while trying to activate session (User: %s) | Error | Benutzerauthentifizierung fehlgeschlagen. Der Name des zu authentifizierenden Benutzers wird angezeigt.
Login of user '%s' succeeded. | Deep Debug | Benutzerauthentifizierung erfolgreich.
Variable '%s' could not be added to OPC UA address space, because node '%s' with the same node identifier already exists | Error | Eine vom Benutzer definierte Variable konnte nicht angelegt werden, da bereits eine andere Variable mit dem selben Identifier existiert.


SNMP Agent

Handbuch -> Process Gateway -> SNMP Agent

Noch in diesem Kapitel

SNMP Architektur

Management Information Base (MIB)

MIB Aufbau

Modulkonfiguration

Konfigurationsdatei: spezifische Einträge für Access SNMP

Konfiguration des Windows SNMP Agent


SNMP Architektur

Handbuch -> Process Gateway -> SNMP Agent -> SNMP Architektur

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Windows SNMP Agent unterstützt die SNMP Version 2 (SNMPv2c). Unterstützt werden die SNMP Funktionen (GET, GETNEXT, GETBULK, SET, TRAP).

Nähere Details wie Microsoft SNMP implementiert hat finden sie auf der Microsoft Technet Website unter: “How SNMP Works” http://technet2.microsoft.com/windowsserver/en/library/bf555774-2d63-4e96-b432-c4b7bcac6b531033.mspx

Windows Betriebssystemkomponenten mit der Verbindung zum Process Gateway und der Runtime:


Management Information Base (MIB)

Handbuch -> Process Gateway -> SNMP Agent -> Management Information Base (MIB)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Management Information Base (MIB) ist in Form einer Baumstruktur organisiert, in welcher der SNMP Agent die Variablen = (OID – Object Identifier) zur Verfügung stellt. Unterhalb der Aufbau der MIB Struktur mit der Ergängung um die Variablen die über das Process Gateway bereitgestellt werden.


MIB Aufbau

Handbuch -> Process Gateway -> SNMP Agent -> MIB Aufbau

Infoblockstruktur ist immer vorhanden |  |  |  |
OID | Beschreibung | Datentyp | Zugriff | Änderung wird als Trap versendet
1.3.6.1.4.1.300.1.1.0 | copadata.info.statusinfo, Runtime ist (Online, Offline) | string | lesen | ja
1.3.6.1.4.1.300.1.2.0 | copadata.info.statusval, Runtime ist 1=Online 0=Offline | integer | lesen | ja
1.3.6.1.4.1.300.1.3.0 | copadata.info.watchdog | integer | lesen | nein
1.3.6.1.4.1.300.1.4.0 | copadata.info.project, Projektname von wo das Process Gateway die Variablen liest | string | lesen | nein

Variablenstruktur (Tabelle) wird je nach Konfiguration vom Process Gateway dynamisch angepasst |  |  |  |
OID | Beschreibung | Datentyp | Zugriff | Änderung wird als Trap versendet
1.3.6.1.4.1.300.2.1.0 | copadata.variables.ifNumber, Anzahl der konfigurierten Variablen=OID | integer | lesen | ja
1.3.6.1.4.1.300.2.2.1.X | copadata.variables.ifTables.ifIndex, Konfigurierter OID-Index aus der Process Gateway Konfiguration | integer | lesen | nein
1.3.6.1.4.1.300.2.2.2.X | copadata.variables.ifTables.ifName, Variablenname | string | lesen | nein
1.3.6.1.4.1.300.2.2.3.X | copadata.variables.ifTables.ifValue, Variablenwert als Integer. Alle numerischen Datentypen werden auf einen SNMP Integerdatentyp formatiert. ACHTUNG bei real und double gehen die nachkommerstellen verloren. | integer | je nach Konfiguration im Process Gateway | nein
1.3.6.1.4.1.300.2.2.4.X | copadata.variables.ifTables.ifValueAsString, Variablenwert als string. Alle numerischen Datentypen werden auf einen SNMP Stringdatentyp formatiert. | string | je nach Konfiguration im Process Gateway | ja
1.3.6.1.4.1.300.2.2.5.X | copadata.variables.ifTables.ifStatus, Variablen Statuswert | integer | lesen | ja
1.3.6.1.4.1.300.2.2.6.X | copadata.variables.ifTables.ifTimestamp, Variablen Zeitstempel | integer | lesen | ja


Modulkonfiguration

Handbuch -> Process Gateway -> SNMP Agent -> Modulkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach Betätigung des Buttons Konfiguration öffnet sich der folgende Dialog:

Hier können die Variablen ausgewählt werden, die verbunden werden sollen. Auf der linken Seite sind alle in zenon verfügbaren Variablen aufgelistet. Dort können sie ausgewählt und mit dem Button > in die SNMP Exportliste verschoben werden. Mit dem Button < können sie wieder zurück verschoben warden. Wenn eine Variable in die Exportliste verschoben wird, öffnet sich ein Dialog für die Namenszuweisung der zenon Variable zu einer OID Adresse in der SNMP Struktur:

Die so ausgewählten Variablen sind dann auf dem SNMP Server verfügbar und werden kontinuierlich zwischen zenon und der SNMP OID Struktur synchronisiert. Man kann pro OID Adresse definieren, ob man diese per SNMP SET schreiben darf. Der genau Aufbau pro OID Adresse ist im Kapitel “MIB Aufbau” beschrieben.


Konfigurationsdatei: spezifische Einträge für Access SNMP

Handbuch -> Process Gateway -> SNMP Agent -> Konfigurationsdatei: spezifische Einträge für Access SNMP

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfigurationsdatei muss im Systemordner liegen.

Parameter | Beschreibung
[SNMP] |
REFRESHRATE | Updatezeit in Millisekunden

Parameter | Beschreibung
[VARIABLES] |
COUNT | Anzahl der zu exportierenden Variablen
NAME_n | Name der Variable mit der Nummer n (0<=n<COUNT)
PARAM_n | Parameter SNMP OID Tabellenoffset und der Information R=nur lesen RW=lesen uns schreiben mit der Nummer n (0<=n<COUNT)

Export von Variablen

Für den erfolgreichen Export muss der Projektname in der zenProcgateway.ini im Pfad %CD_SYSTEM% korrekt eingetragen werden. Der Eintrag erfolgt in:

[DEFAULT]
PROJECT=

Achtung: Bei falschen oder fehlenden Einträge wird das Gateway ohne weitere Fehlermeldung geschlossen. Die Variablen stehen damit nicht zur Verfügung.


Konfiguration des Windows SNMP Agent

Handbuch -> Process Gateway -> SNMP Agent -> Konfiguration des Windows SNMP Agent

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit der SNMP Agent von Windows (SNMP.exe) die zenon MIB Teilstruktur zur Verfügung stellt, muss die Process Gateway Datei AccessSNMP.dll in der Registry entsprechend konfiguriert werden:

  1. Installation des Windows SNMP Service über die Systemsteuerung:
    • bis Windows Vista über Modul: Software -> Windowskomponenten hinzufügen
    • ab Windows Vista über Modul: Programm und Funktionen -> Windows-Funktionen aktivieren oder deaktivieren
  2. Installation des Process Gateway mit der Datei AccessSNMP.dll in den Ordner %Program Files (x86)%\COPA-DATA\zenon 7.00
  3. Mit dem Registry Editor folgende Schlüssel und Zeichenfolge hinzufügen:
    1. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\ExtensionAgents]
      Name=ProcessGateway
      Wert=SOFTWARE\COPA-DATA\SNMP\CurrentVersion
    2. [HKEY_LOCAL_MACHINESOFTWARE\COPA-DATA\SNMP\CurrentVersion]
      Name=Pathname
      Wert=C:\Program Files (x86)\COPA-DATA\zenon 7.00
  4. Start des SNMP-Dienst.
    Dieser lädt über die Registrykonfiguration die Process Gateway Datei AccessSNMP.dll.
    Weitere Konfigurationseinstellungen für den Windows SNMP Dienst: Systemsteuerung -> Verwaltung -> Dienste -> SNMP-Dienst -> Eigenschaften
    1. Registerkarte Traps: Festlegung, an welche IP Adressen im Netzwerk Traps versendet werden:

    • Communityname: muss auf Manager und Agent ident sein
    • Trapziele: Adressen der Ziele als Hostnamen, IP-Adressen oder IPX-Adressen
    1. Registerkarte Sicherheit: Festlegung der Rechte, mit denen ein SNMP Client auf den SNMP Agent zugreift:

    • Rechte: Muss auf "LESEN SCHREIBEN" gesetzt sein
    • Community: muss auf Manager und Agent ident sein


SQL

Handbuch -> Process Gateway -> SQL

Noch in diesem Kapitel

Modulkonfiguration

Variablenauswahl

Tabellenerzeugung

Betrieb im Redundanzsystem

Konfigurationsdatei: spezifische Einträge für AccessSQL

Tabellenformat


Modulkonfiguration

Handbuch -> Process Gateway -> SQL -> Modulkonfiguration

Die Konfiguration der Datenbankanbindung besteht aus zwei Teilen.

  1. OLE-DB Ankopplung: Diese OLE-DB Ankopplung kann im Konfigurationsdialog über die Auswahl-Schaltfläche für den Connect-String definiert werden. Dazu wird der Standarddialog für Datenverknüpfungseigenschaften aufgerufen.
  2. Zusätzlich kann der Name der Tabelle definiert werden, falls der Standardname ONLINE_VALUES nicht verwendet werden soll.
    Dies kann über den Eintrag TABLE in der Sektion [DATABASE] in der Konfigurationsdatei (zenProcGateway.ini) eingestellt werden. Die Einstellungen werden beim Start des Add-Ons übernommen.

attention Achtung

Werden Tabellennamen händisch in der Konfigurationsdatei (zenProcGateway.ini) definiert, müssen diese Tabellennamen auch per Hand in der Datenbank geändert bzw. erstellt werden.

Oracle Datenbanken

Die Verwendung des Process Gateways und der AccessSQL.dll in Verbindung mit Oracle Datenbanken kann Fehler verursachen: Mit manchen ODBC-Treibern kommt es vor, dass keine Online-Werte in die Datenbank geschrieben werden. Die erweiterte ODBC Protokollierung gibt dann die Fehlermeldung "1843" aus.

Das Problem kann durch den Austausch des ODBC-Treibers behoben werden. So funktioniert zum Beispiel der ODBC-Treiber 9.02.00.05 für Oracle 9.2.


Variablenauswahl

Handbuch -> Process Gateway -> SQL -> Variablenauswahl

Im Konfigurationsdialog können die in das SQL-Prozessabbild zu schreibenden zenon Variablen definiert werden. Dazu müssen die im zenon Projekt verfügbaren Variablen - aufgelistet in der linken Liste - in das zu exportierende Abbild - aufgelistet in der rechten Liste - übernommen werden.


Tabellenerzeugung

Handbuch -> Process Gateway -> SQL -> Tabellenerzeugung

Die Tabellenstruktur der SQL-Datenbank wird nach dem Verlassen des Konfigurationsdialogs mit OK automatisch erzeugt. Für den Fall, dass sie händisch angelegt werden, gilt:


Betrieb im Redundanzsystem

Handbuch -> Process Gateway -> SQL -> Betrieb im Redundanzsystem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im redundanten Betrieb stehen zwei verschiedene Varianten zur Auswahl. In der ersten Variante läuft die SQL-Datenbank auf beiden Serven lokal und das Process Gateway läuft auf ebenfalls auf beiden Servern. Da es sich ausschließlich um Online-Werte handelt, ist kein zusätzliche Abgleich zwischen den Datenbanken notwendig. Großer Nachteil dieser Variante ist die hohe Netzwerklast, die durch die zusätzliche Anforderung der Onlinewerte am Standby-Server erzeugt wird.

In der zweiten Variante läuft das Process Gateway nur am Runtime-Server und schreibt seine Daten in eine lokale oder entfernte SQL-Datenbank. In dieser Variante wird zwischen Runtime- und Standby-Server keine zusätzliche Netzwerklast erzeut und es wird im Falle der entfernten SQL-Datenbank der Server nicht durch externe Abfragen in dieser Datenbank belastet.


Konfigurationsdatei: spezifische Einträge für AccessSQL

Handbuch -> Process Gateway -> SQL -> Konfigurationsdatei: spezifische Einträge für AccessSQL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfigurationsdatei muss im Systemordner liegen.

Parameter | Beschreibung
[DATABASE] |
INITSTRING | OLE-DB Connect-String zur SQL-Datenbank
TABLE_ONL | Name der Tabelle, welche das Prozessabbild empfängt
TABLE_VAR | Name der Tabelle, welche die Variablen-IDs empfängt
REFRESHRATE | maximale Refreshrate in Millisekunden

Parameter | Beschreibung
[VARIABLES] |
COUNT | Anzahl der zu exportierenden Variablen
NAME_n | Name der n-ten Variable (0


Tabellenformat

Handbuch -> Process Gateway -> SQL -> Tabellenformat

Noch in diesem Kapitel

Tabelle für Prozessabbild

Tabelle für Variablen-IDs


Tabelle für Prozessabbild

Handbuch -> Process Gateway -> SQL -> Tabellenformat -> Tabelle für Prozessabbild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
VARIABLE | int[4] | ID der zenon Variable
VALUE | varchar[64] | aktueller Wert als String
VALUE_NUM | float | aktueller Wert als float
TIMESTAMP | int[4] | Zeitstempel des aktuellen Wertes (als UNIX Zeit)
TIMESTAMP2 | datetime | Zeitstempel des aktuellen Wertes (als datetime)
STATUS | int[4] | Statuswort des aktuellen Wertes


Tabelle für Variablen-IDs

Handbuch -> Process Gateway -> SQL -> Tabellenformat -> Tabelle für Variablen-IDs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
VARIABLE | int[4] | ID der zenon Variable
NAME | varchar[128] | Name der Leitsytsme-Variable


Production and Facility Scheduler (PFS)

Handbuch -> Production and Facility Scheduler (PFS)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Production & Facility Scheduler (PFS) ermöglicht das Ausführen von Aktionen (z.B. Ändern des Sollwertes einer Variablen, Ausführung einer Funktion) an einen Zeitraum gekoppelt oder nach einem zeitlichen Muster.

tutorial Lizenzinformation

Für Editor und Runtime lizenzpflichtig.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Zeitmodellgruppe neu | Öffnet den Assistenten zum Anlegen einer neuen Zeitmodellgruppe.
Ereignis neu | Legt ein neues Ereignis an.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Allgemein

Symbolleiste und Kontextmenü PFS

Ansichten im Production and Facility Scheduler

Projektieren mit dem Production and Facility Scheduler

Weiterführende Projektierung im Production and Facility Scheduler

Objekttypen

Eigenschaften

Dialoge

Funktion PFS-Ereignis anstoßen

Bildumschaltung - PFS

Bildtyp Production and Facility Scheduler


Allgemein

Handbuch -> Production and Facility Scheduler (PFS) -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das optionale Modul Production & Facility Scheduler (PFS) ermöglicht die Ausführung von Aktionen gekoppelt an einen Zeitraum oder nach einem zeitlichen Muster.

Der PFS kann sowohl im Editor wie auch zur Runtime projektiert werden. Die Projektierung zur Laufzeit kann durch Vergabe von Rechten eingeschränkt werden. Zur Runtime gemachte Projektierungen können in den Editor zurückgelesen werden, sind jedoch ansonst eigenständig.

Sämtliche Uhrzeitangaben sind unabhängig von Zeitzonen sowie Sommer- und Winterzeit.

info Info

Sollte das Projekt nach dem Starten des Editors nicht angezeigt werden:

  • öffnen Sie das Menü Option
  • wählen Sie den Befehl Projektmanager


Symbolleiste und Kontextmenü PFS

Handbuch -> Production and Facility Scheduler (PFS) -> Symbolleiste und Kontextmenü PFS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbol | Beschreibung
Erstellen | Legt abhängig vom ausgewählten Element ein neues Element an und öffnet den dazugehörigen Dialog.
Ausschneiden | Schneidet ausgewähltes Element aus.
Kopieren | Kopiert ausgewähltes Element.
Einfügen | Fügt Element aus der Zwischenablage ein.
Löschen | Löscht ausgewähltes Element.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü

Menüpunkt

Aktion

Speichern

Speichert Änderungen in der Projektierung des PFS.

Verwerfen

Verwirft alle Änderungen seit dem letzten Speicherzeitpunkt.

Eigenschaften

Öffnet den Dialog zur Konfiguration von:

  • Zeitumstellung
  • Feiertage
  • Tabellenfarbe
  • Schichtzeiten aufzeichnen

Schaltpunktvorschau

Öffnet den Dialog für die Schaltpunktvorschau.

Filter-Kriterien

Öffnet den Dialog zur Auswahl der Filter.

Hilfe

Öffnet die Online-Hilfe.

info Info

Erklärungen zu Kontextmenüs einzelner Elemente des Baumes und der Tabellen finden Sie in den jeweiligen Kapiteln, vor allem in Unterkapiteln zu Objekttypen.


Ansichten im Production and Facility Scheduler

Handbuch -> Production and Facility Scheduler (PFS) -> Ansichten im Production and Facility Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Visualisierung des PFS teilt sich in zwei Bereiche auf: Die hierarchische Baumansicht links und die Tabelleansicht rechts.

Noch in diesem Kapitel

Baumansicht

Tabelleansicht


Baumansicht

Handbuch -> Production and Facility Scheduler (PFS) -> Ansichten im Production and Facility Scheduler -> Baumansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Baumansicht ermöglicht einem einfach zu erkennen, auf welcher Ebene sich ein Objekt befindet und zu wem es gehört. Die Zusammengehörigkeit wird durch Ebenenlinien dargestellt. Da das Verhalten eines Objektes von seiner Zugehörigkeit abhängt, ist dies wichtig.
Jeder Objekttyp hat ein, über die Maustaste für das Kontextmenü erreichbares, speziell auf den Objekttyp abgestimmtes Kontextmenü.

In diesem Bereich können die Objekte, wenn erlaubt auch kopiert, verschoben und gelöscht werden.


Tabelleansicht

Handbuch -> Production and Facility Scheduler (PFS) -> Ansichten im Production and Facility Scheduler -> Tabelleansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der rechte Teil des PFS - Bereich stellt in Abhängigkeit des selektierten Typ in der Baumansicht, die Daten des Objektes dar. Bei manchen Objekten wird in diesem Bereich eine weitere Projektierung vorgenommen (z.B. bei Fahrplänen) oder es wird nur die aktuelle Projektierung angezeigt, welche nicht unmittelbar geändert werden kann. Z.B. Ereignisse.

Wenn Umprojektierungen in der Tabellenansicht vorgenommen werden können, ist über die Maustaste für das Kontextmenü, ein solches erreichbar. Mit diesem werden dann die gewünschten Änderungen ausgelöst.

Manche Objekte ermöglichen auch eine direkte Eingabe von Daten in die Tabellenzelle. Z.B Uhrzeiten bei Fahrplänen.


Projektieren mit dem Production and Facility Scheduler

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Abschnitt werden wir schrittweise unser erstes PFS Projekt erstellen und im Zuge dessen folgendes durchführen:

  • Erstellen von Zeitmodell-Gruppen, Modellen und Fahrplänen.
  • Erstellen von absoluten und relativen Uhrzeiten mit Variablen bzw. Funktionsverknüpfung.
  • Erstellen von benutzerdefinierten Ereignissen und Verwendung dieser.
  • Einsatz der Editiermöglichkeiten wie kopieren, verschieben und löschen.
  • Verknüpfung der Fahrpläne und Modelle im Kalender.
  • Überprüfung der Projektierung mittels der Schaltpunktvorschau.
  • Ausführen der Fahrpläne zur Laufzeit.

Voraussetzung ist das Verständnis für die Erstellung von Projekten, Variablen, Funktionen, Schablonen und Bildern. Es wird diesbezüglich nur mehr auf die den PFS betreffenden Einstellungen eingegangen. Wenn in der Projektierung der zuvor genannten Funktionalität Unklarheiten bestehen, sehen Sie diesbezüglich in den entsprechenden Abschnitten der Dokumentation nach.

info Info

Bezeichner in Tabellen wie etwa Kalender, Fahrpläne, Ereignissen usw. werden immer in der Sprache angezeigt, in der das Projekt erstellt wurde.

Noch in diesem Kapitel

Aufgabenstellung

Schritt 1: Vorbereitung

Schritt 2: Einstellungen Production and Facility Scheduler

Schritt 3: Zeitmodell-Gruppen erstellen

Schritt 4: Modelle erstellen

Schritt 5: Schichten und Pausen erstellen

Schritt 6: Feiertagsmodell definieren

Schritt 7: Benutzerdefiniertes Ereignis Hupendauer

Schritt 8: Überlegungen zur Fahrplanstruktur

Schritt 9: Fahrplan für die Halle

Schritt 10: Überlegungen zu den Uhrzeiten

Schritt 11: Uhrzeiten für Fahrplan Halle

Schritt 12: Schaltpunkte Fahrplan Halle

Schritt 13: Fahrplan Linie I

Schritt 14: Fahrplan Linie II

Schritt 15: Überlegungen zur Kalenderzuordnung

Schritt 16: Kalenderzuordnung durchführen

Schritt 17: Überprüfung der Projektierung

Schritt 18: PFS zur Laufzeit

Schritt 19: Ausführung zur Laufzeit

Schritt 20: Resümee


Aufgabenstellung

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Aufgabenstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Unsere Aufgabe besteht darin eine Werkshalle (Halle I) mit zwei Produktionslinien (Linie I und Linie II), welche von 06:00 bis 18:00 in einer Schicht produzieren, zu beheizen sowie das Licht zu schalten. Die Heizung braucht eine Vorheizzeit von 2 Stunden für Linie I und 1 Stunde für Linie II, wobei Produktionslinie I auf 83º und Produktionslinie II auf 45º aufzuheizen ist. Wenn keine Produktion erfolgt, soll die Heizung auf 20º abgesenkt werden. Das Licht sollte 10 Minuten früher ein bzw. später abgeschaltet werden. Schichtbeginn und Ende bzw. Pausenbeginn und Ende, soll mit einem 6 Sekunden Hupton signalisiert werden. Pausen sind um 9 Uhr für 15 Minuten, um 12 Uhr für eine Stunde und um 15 Uhr für 15 Minuten. Es wird 5 Tage produziert, an Feiertagen und Wochenenden ist produktionsfrei. Unsere Halle steht in Österreich. Alle 6 Stunden soll die Abwasserpumpe für 30 Sekunden aktiviert werden.


Schritt 1: Vorbereitung

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 1: Vorbereitung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Schritt werden wir die Vorbereitungen für die Projektierung des PFS durchführen. Es wird das Projekt erstellt, ein Treiber eingebunden und die Variablen erstellt.

  1. Erstellen Sie ein neues Projekt mit dem Namen PfsSample in einem neuen Arbeitsbereich.
  2. Gehen Sie im Kontextmenü des Projekts auf Runtime-Dateien -> RT änderbare Dateien...
  3. Deaktivieren Sie die Checkbox Nicht neu erzeugen und übertragen für den Fahrplan-Manager. Hierdurch werden Änderungen am PFS im Editor neu kompiliert, die zur Laufzeit gemachten Änderungen gehen jedoch verloren.
  4. Deaktivieren Sie die Checkbox Nicht dekompilieren für den PFS. Die zur Laufzeit gemachten Änderungen werden durch dekompilieren in den Editor übernommen.
  5. Binden Sie den Simulatortreiber ein. Alle Einstellungen werden unverändert übernommen.
  6. Erstellen Sie folgende Variablen:
    • HD-Bit; Offset 10; Bit 0; Name: Hupe
    • HD-Bit; Offset 10; Bit 1; Name: Licht I
    • HD-Bit; Offset 10; Bit 2; Name: Licht II
    • HD-Bit; Offset 10; Bit 3; Name: Abwasserpumpe
    • HD-Wort; Offset 11; Name: Heizung P I
    • HD-Wort; Offset 12; Name: Heizung P II
  7. Aktivieren Sie den PFS durch Klicken auf den entsprechenden Knoten im Projektmanager. Sie sollten nun den leeren PFS-Arbeitsbereich sehen.
  8. Vergrößern Sie das Projektfenster, indem im Fensterkontextmenü erlaube andocken deaktiviert oder bewegen im Hauptfenster aktiviert wird. Für die Projektierung im PFS ist ein großer Sichtbereich auf das Projektfenster von Vorteil.


Schritt 2: Einstellungen Production and Facility Scheduler

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 2: Einstellungen Production and Facility Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Schritt projektieren wir die PFS weit gültigen Einstellungen. Zur korrekten Ermittlung der Feiertage ist das Land, in welchem unser PFS-Projekt ausgeführt werden soll, bekannt zugeben.


Schritt 3: Zeitmodell-Gruppen erstellen

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 3: Zeitmodell-Gruppen erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Schritt werden wir eine neue Zeitmodell-Gruppe erstellen und diese entsprechend konfigurieren.

Bei uns wird die Halle I als Zeitmodell-Gruppe abgebildet, da wir speziell auf diese Halle zugeschnittene Modelle (siehe auch Objekt Zeitmodelle) benötigen. Immer wenn für einen Kalendertag mehrere unterschiedliche Modelle benötigt werden, ist eine Aufteilung in mehrere Zeitmodell-Gruppen notwendig.

Klappen sie den Hauptknoten Production & Facility Scheduler auf. Sie sehen nun 3 weitere Einträge. Zeitmodell-Gruppen, Ereignisse und Kalender.

Aktivieren Sie beim Eintrag Zeitmodell-Gruppen das Kontextmenü und klicken Sie auf Erstellen. Es wird nun die Seite Zeitmodell-Gruppen-Eigenschaften, der Zeitmodell-Gruppe eingeblendet. Das Feld Bezeichnung ist noch leer, da wir eine neue Zeitmodell-Gruppe erstellen.

Geben Sie bei der Bezeichnung Halle I ein, so soll unsere neue Zeitmodell-Gruppe heißen. Die Bezeichnung der Zeitmodell-Gruppe muss PFS-weit einmalig sein. In unseren Fall ist das sicher gegeben.

Der Tagesbeginn mit 00:00:00 und das Ende mit 23:59:59 können so bleiben. Dies definiert den Zeitmodellgruppen-Zyklus für einen vollen Tag.

Wenn die Zeitmodell-Gruppenbezeichnung gültig ist, können mit OK die Einstellungen übernommen werden und die neue Zeitmodell-Gruppe wird erstellt.

Sie sehen nun einen neuen Eintrag bei Zeitmodell-Gruppen welcher Halle I benannt ist, mit zwei weiteren Einträgen: Fahrplänen und Zeitmodelle.


Schritt 4: Modelle erstellen

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 4: Modelle erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Modelle werden zur Auflösung der relativen Uhrzeiten benötigt und beinhalten die Schichten und Pausen.

Selektieren Sie Erstellen im Kontextmenü von Zeitmodelle.

Es wird nun ein neues Zeitmodell mit der Bezeichnung Neues Zeitmodell erstellt. Der Eintrag befindet sich automatisch im Modus umbenennen, erkennbar durch das Eingabefeld. Geben Sie nun als Bezeichnung Werktag ein. Sollten Sie irrtümlich woanders hinklicken, wird das Umbenennen beendet und die Modellbezeichnung Neues Zeitmodell bleibt bestehen. Durch zwei Klicks (kein Doppelklick) auf Neues Zeitmodell wird dieses in den Umbenennenmodus geschaltet. Über den Eintrag Umbenennen im Kontextmenü ist dies ebenfalls möglich. Die eingegebene Bezeichnung muss bei der Zeitmodell-Gruppe einmalig sein.


Schritt 5: Schichten und Pausen erstellen

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 5: Schichten und Pausen erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Schichten sind für die Auflösung der relativen Schaltzeiten von entscheidender Bedeutung. Dies betrifft nicht nur die Relativereignisse Schicht Beginn und Schicht Ende, sondern auch die Erkennung von Produktionsbeginn und Produktionsende.

Selektieren Sie die oberste Zelle in der Spalte Schichten/Pausen . Über den Kontextmenüpunkt Schicht erstellen erzeugen Sie eine neue Schicht. Geben Sie für die Schicht eine eindeutige Bezeichnung ein. Wir benennen die Schicht Schicht 1. Mit der Tabulatortaste oder Maus wechseln wir zur Spalte Einschaltzeit . Unsere Schicht soll um 06:00:00 beginnen und bis 18:00:00 dauern. Somit geben wir bei der Einschaltzeit 06:00:00 an und bei der Ausschaltzeit 18:00:00.

Schichten sind grau hinterlegt, Pausen weiß.

Unsere Werktätigen haben sich auch Pausen verdient, welche wir nun definieren. Selektieren Sie hierzu in der Zeile der Schicht, eine der Zellen und aktivieren das Kontextmenü. Mit Pause erstellen legen wir eine neue Pause an. Wir benennen die neue Pause mit Vormittag. Unsere erste Pause ist um 09:00:00 und soll bis 09:15:00 dauern.

Nun erstellen wir die Mittagspause. Benennung Mittagspause; Beginn: 12:00:00 Ende: 13:00:00.

Es bleibt noch die Nachmittagspause über, welche auch erstellt werde soll. Benennung: Nachmittag; Beginn: 15:00:00 Ende 15:15:00.

Unser Modell Werktag sollte nun wie folgt projektiert sein:


Schritt 6: Feiertagsmodell definieren

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 6: Feiertagsmodell definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da wir an Feiertagen nicht produzieren, ein Feiertag jedoch auch auf einen Montag bis Freitag fallen kann, benötigen wir ein Modell speziell für die Feiertage. Dieses Modell ist sehr einfach, da es keine Schichten enthält. Wir nutzen hierbei aus, dass ein Modell für einen Sondertag, vorrang gegenüber den Defaultmodellen für Montag bis Sonntag hat. Die Betonung liegt auf Defaultmodellen. Eine Einzeltagzuordnung hat eine höhere Priorität als der Sondertag, dies jedoch nur als Erklärung. Ein Modell ohne Schichten ist gleichbedeutend, wie wenn kein Modell zum Tag verknüpft ist.

Erstellen Sie entsprechend Schritt 4 ein Modell mit der Bezeichnung Feiertag. Es werden keinerlei Schichten bei dem Modell definiert.


Schritt 7: Benutzerdefiniertes Ereignis Hupendauer

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 7: Benutzerdefiniertes Ereignis Hupendauer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Unsere Aufgabe besteht unter anderem auch darin, eine Hupe jeweils zum Schicht- und Pausenbeginn bzw. zum Schicht- und Pausenende 6 Sekunden hupen zu lassen. Diese 6 Sekunden Hupdauer kann sehr schön über ein benutzerdefiniertes Ereignis gelöst werden.

Was ist ein benutzerdefiniertes Ereignis? Benutzerdefinierte Ereignisse gehören zu den Relativschaltzeiten, wobei das Besondere daran ist, dass sie vom Projektanten erstellt werden können. Angestoßen wird ein benutzerdefiniertes Ereignis durch Aufruf der Funktion PFS-Ereignis anstoßen. Hierdurch wird der Zeitpunkt des Funktionsaufruf als Trigger für das benutzerdefiniertes Ereignis eingetragen. Entsprechend versetzt um den projektierten Offset erfolgt dann die Ausführung des Ereignisses.

Nach den Grundlagen zur Erstellung. Öffnen Sie beim Eintrag Ereignisse das Kontextmenü und erzeugen Sie ein neues Ereignis mit Erstellen. Das Ereignis wird mit der Benennung Neues Benutzer-Ereignis erzeugt und ist im Umbenennungsmode. Wir kennen dies bereits vom Modell. Ändern Sie die Bezeichnung auf Hupendauer. Die Bezeichnung muss PFS weit einmalig sein.

Gehen Sie in die Funktionsverwaltung und fügen Sie die Funktion PFS-Ereignis anstoßen für das benutzerdefinierte Ereignis Hupendauer hinzu.


Schritt 8: Überlegungen zur Fahrplanstruktur

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 8: Überlegungen zur Fahrplanstruktur

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die uns gestellt Aufgabe beinhaltet zwei Produktionslinie, diese werden wir in getrennten Fahrplänen abbilden. Gleichzeitig gibt es aber Aufgaben welche bei beiden Linien gleich sind. Beide sollen das Licht 10 Minuten vor Schichtbeginn einschalten und 10 Minuten länger an lassen. Dies werden wir in einem übergeordneten Fahrplan darstellen. Wir machen uns hierbei die Möglichkeit der Vererbung von Uhrzeiten vom Vorgänger zum Nachfolger zu nutze. Es ist jedoch nur der Schaltzeitpunkt gleich, jede Linie hat ihr eigenes Licht. Die Abwasserpumpe muss auch bedient werden, dies erfolgt ebenfalls im übergeordneten Fahrplan.

Dann ist noch die Hupe zu projektieren. Diese ist für beide Linien gleich, da nur einmal in der Halle vorhanden, also kommt diese in den übergeordneten Fahrplan.

Fahrplan der Halle. Bezeichnung Halle. Wir müssen die Hupe projektieren, die Abwasserpumpe und die Uhrzeiten vom Licht.

Fahrplan Linie I: Untergeordneter Fahrplan von Halle. Bezeichnung Linie I; Licht muss geschaltet werden. Temperatur setzen.

Fahrplan Linie II: Untergeordneter Fahrplan von Halle. Bezeichnung Linie II; Licht muss geschaltet werden. Temperatur setzen.

Ausgehend von diesen Überlegungen erstellen wir nun die Fahrpläne.


Schritt 9: Fahrplan für die Halle

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 9: Fahrplan für die Halle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der erste zu erstellende Fahrplan enthält die Schaltpunkte für die Halle I. Des weiteren enthält er alle Schaltzeiten welche in den untergeordneten Fahrplänen gleich sein sollen.

Beginnen wir mit der Erstellung unseres ersten Fahrplanes. Klappen Sie hierzu die Zweige Production & Facility Scheduler , Zeitmodell-Gruppen , Halle I in der Baumansicht auf, damit der Eintrag Fahrpläne bei der Zeitmodell-Gruppe Halle I sichtbar wird. Aktivieren Sie das Kontextmenü von Fahrpläne und klicken Sie auf Erstellen. Es werden Ihnen nun die Einstellungen zum Fahrplan präsentiert. Geben Sie bei Bezeichnung den Fahrplannamen Halle an. Der Fahrplan soll aktiv sein(Checkbox bei Fahrplan aktiv gesetzt), und ist kein Strukturfahrplan(Checkbock bei Struktur-Fahrplan deaktiviert).

Wir müssen das benutzerdefiniertes Ereignis Hupendauer auslösen können. Hierzu fügen wird diese Funktion zu den verwendeten Funktionen vom Fahrplan hinzu. Aktivieren Sie das Kontextmenü der Funktionsliste und klicken Sie auf Funktionen hinzufügen. Übernehmen Sie die zuvor definierte Funktion PFS - Ereignis anstoßen [Hupendauer]. Diese Funktion wird nun zur Funktionsliste vom Fahrplan hinzugefügt und kann von diesem dann verwendet werden.

Des weitern wollen wir auf die Variablen Hupe und Abwasserpumpe schreiben, um die Hupe und Pumpe zu aktivieren. Hierzu müssen wir diese Variablen zu der Variabelliste vom Fahrplan hinzufügen. Mittels Kontextmenü wird Variablen hinzufügen aktiviert. In der daraufhin angezeigten Variabelliste können die gewünschten Variablen durch Doppelklick in die Liste der verfügbaren Variablen oder durch Selektion und Anfügen , hinzugefügt werden.

Nach Ausführung dieser Aktionen sollte der Fahrplan wie folgt projektiert sein.


Schritt 10: Überlegungen zu den Uhrzeiten

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 10: Überlegungen zu den Uhrzeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Uhrzeit legt den Zeitpunkt wann ein Schaltpunkt ausgeführt wird fest. Es gibt zwei Typen von Uhrzeiten:

Die absolute Uhrzeit: Bei diesem Typ wird eine Uhrzeit direkt vorgegeben. Der Schaltpunkt wird zu dieser Zeit ausgeführt oder nicht, die Zeit der Ausführung ändert sich nicht. Die Ausführung unterbleibt nur wenn der Fahrplan deaktiviert, der Schaltpunkt deaktiviert oder der Fahrplan nicht für den Tag verknüpft wurde. Dieser Typ ist ideal, wenn der Zeitpunkt der Ausführung absolut feststeht.

Die relative Uhrzeit: Hier hängt der tatsächliche Ausführungszeitpunkt, von der Art des Ereignisses, von der Platzierung der Modelle im Kalender, ob es sich um einen Feiertag handelt und vielem mehr ab. Die Bedingungen der Ausführung sind detailliert bei Zeittyp relativ dokumentiert. Kurz gesagt der Ausführungszeitpunkt hängt von weiteren Faktoren ab, darum relativ. Der Vorteil dieses Typs ist es, dass sich bei Änderung des Bezuges, automatisch alle Ausführungszeiten mit ändern. Der Nachteil soll aber auch nicht verschwiegen werden. Durch den nicht direkt ersichtlichen Ausführungszeitpunkt sind sie nicht so übersichtlich wie die absoluten Zeiten. Durch die Schaltpunktvorschau wird dieses Problem jedoch gelöst.

Welche Zeiten brauchen wird nun für die Lösung unserer Aufgabe? Um dies beantworten zu können sehen wir uns kurz an was und warum etwas ausgeführt bzw. geschaltet werden soll.

Da wäre die Hupe. Diese soll bei jedem Schicht- und Pausenbeginn, sowie bei jedem Schicht- und Pausenende für 6 Sekunden hupen. Der Hupbeginn bezieht sich direkt auf die Schicht bzw. Pause. Wir kennen Beginn und Ende der Schichten bzw. Pausen. Es wäre somit möglich diese Zeiten direkt zu verwenden. Wenn sich jedoch die Schicht ändert, müssten diese Zeiten mit angepasst werden, es ist sogar so, dass davon anhängige Zeiten (Abschaltung der Hupe) mit angepasst werden müssten. Dies ist fehleranfällig! Durch Verwendung der Relativzeiten Schichtbeginn , Schichtende , Pausenbeginn und Pausenende geht dies automatisch. Die 6 Sekunden Hupdauer erreichen wir durch unser benutzerdefiniertes Ereignis mit 6 Sekunden Offset für die Hupenabschaltung.

Das Licht der Produktionslinien. Sind ebenfalls direkt von der Schicht abhängig, werden daher als Schichtbeginn und Schichtende ausgeführt.

Die Temperaturen der Produktionslinie. Sind ebenfalls direkt von der Schicht abhängig.

Die Abwasserpumpe. Diese soll in einem definierten Abstand, alle 6 Stunden für 30 Sekunden aktiviert werden. Ein Bezug zu der Schicht oder Pause ist nicht gegeben. Hier bieten sich absolute Zeiten an.

Nachdem wir nun die Zeitpunkte der Ausführung analysiert haben, können wir an die Projektierung gehen.


Schritt 11: Uhrzeiten für Fahrplan Halle

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 11: Uhrzeiten für Fahrplan Halle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wir beginnen mit der Erstellung der Einschaltzeitpunkte für die Abwasserpumpe. Hierzu selektieren Sie die Zelle in der ersten Zeile bei der Spalte Zeittyp. Mit dem Kontextmenüpunkt Zeitraster erstellen, rufen wir den Dialog zum Erstellen eines Zeitrasters auf. Nach Aktivierung der Checkbox als zyklische Zeit werden die weiteren Felder freigeschalten.

Füllen Sie den Dialog entsprechend der Abbildung. Durch die von uns gewählten Einstellungen werden vier absolute Uhrzeiten erstellt. Um 0Uhr, 6Uhr, 12Uhr und 18Uhr.

30 Sekunden später soll die Pumpe wieder abgeschalten werden. Also erstellen wird nochmals 4 Schaltzeiten 30 Sekunden zu den bereits erstellen versetzt. Den Versatz erreichen wird indem bei der Startzeit 00:00:30 eingegeben wird.

Nun projektieren wir die Hupe. Aktivieren Sie im Kontextmenü der Tabellenansicht den Menüpunkt Uhrzeit erstellen. Es wird nun eine neue absolute Zeit erstellt. Nun wir brauchen aber eine relative Zeit. Wechseln Sie in die Spalte Zeittyp der gleichen Zeile und ändern den Typ auf relativ. Wenn nun in die Spalte Uhrzeit gewechselt wird, verschwindet die Zeit und eine Auswahlbox mit dem verfügbaren Relativereignissen wird aufgeschaltet. Selektieren Sie Schichtbeginn. Der Offset bleibt 0, da die Hupe unmittelbar bei Schichtbeginn einschalten soll. Die Hupe soll nicht nur den Schichtbeginn verkünden, sondern auch Schichtende, Pausenbeginn und Pausenende. Erstellen Sie 3 weitere relative Uhrzeiten mit den entsprechenden Relativereignissen. Die Hupe soll nach 6 Sekunden abgeschaltet werden. Fügen Sie hierzu eine relative Uhrzeit mit dem Relativereignis Hupendauer hinzu. Hupendauer ist unser zuvor angelegtes benutzerdefiniertes Ereignis. Als Offset geben wird 0,1 Minuten, entspricht 6 Sekunden an. Das bestimmt die Hupdauer.

Jetzt kommt die Heizung an die Reihe. Erstellen Sie 2 Relativzeiten, für Schichtbeginn, Offset -120 und Offset -60

Es fehlen noch die Zeiten für das Licht. Erstellen Sie 2 Relativzeiten, für Schichtbeginn, Offset -10 und Schichtende Offset 10.


Schritt 12: Schaltpunkte Fahrplan Halle

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 12: Schaltpunkte Fahrplan Halle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zeiten definieren den Zeitpunkt der Ausführung, nun müssen wir noch definieren was zu der jeweiligen Zeit geschehen soll. Hierfür sind die Schaltpunkte vorgesehen.

Beginnen wir mit der Abwasserpumpe. Selektieren Sie die absolute Zeit 00:00:00 . Im Kontextmenü den Menüpunkt Schaltpunkt erstellen anklicken. Unmittelbar nach der selektierten Zeit wird eine neue Zeile eingefügt, welche den Schaltpunkt darstellt. Schaltpunkt beinhalten die Spalten Aktiv, Verknüpfungstyp, Verknüpfungen, Aktion und Passwort. Sehen wir uns diese Felder kurz näher an.

Aktiv: Ermöglicht den Schaltpunkt zu deaktivieren. Hierdurch kann die Schaltpunktausführung unterbunden werden.

Verknüpfungstyp: Legt fest ob eine Variable geändert oder z.B. eine Funktion ausgeführt werden soll. Die weiteren Typen sind beim Objekt Schaltpunkt dokumentiert.

Verknüpfungen: Je nach Verknüpfungstyp wird hier die Variable oder Funktion ausgewählt.

Aktion: Beim Verknüpfungstyp Variabel beinhaltet dieses Feld den zu schreibenden Sollwert. Für Funktionen ist dieses Feld gleichbedeutend wie Aktiv.

Passwort: Ermöglicht für die Laufzeitprojektierung eine Berechtigung für die Änderung vorzugeben.

Definieren wir nun den Schaltpunkt. Die aktuell selektierte Spalte ist der Verknüpfungstyp . Hier selektieren wir aus der Combobox Variable . Nun in die Spalte Verknüpfungen wechseln. Aus der Combobox Abwasserpumpe auswählen. Zur Spalte Aktion wechseln. Eine 1 eingeben. Hierdurch wird um 00:00:00 bei der Variable Abwasserpumpe der Sollwert auf 1 gesetzt.

Erstellen Sie nun folgende Schaltpunkte wie zuvor beschrieben:

  • 00:00:30 Variable Abwasserpumpe Sollwert: 0
  • 06:00:00 Variable Abwasserpumpe Sollwert: 1
  • 06:00:30 Variable Abwasserpumpe Sollwert: 0
  • 12:00:00 Variable Abwasserpumpe Sollwert: 1
  • 12:00:30 Variable Abwasserpumpe Sollwert: 0
  • 18:00:30 Variable Abwasserpumpe Sollwert: 1
  • 18:00:30 Variable Abwasserpumpe Sollwert: 0

Jetzt kommt die Hupe an die Reihe. Für die Hupe haben wir mehrere Relativzeiten vorgesehen.
Schichtbeginn Offset 0, Schichtende Offset 0, Pausenbeginn Offset 0, Pausenende Offset 0 und Hupendauer Offset 0,1.
Für Beginn und Ende müssen jeweils 2 Schaltpunkte ausgeführt werden. Der erste muss die Hupe aktivieren. Der zweite muss das benutzerdefinierte Ereignis Hupendauer triggern.
Die Relativzeit Hupendauer muss die Hupe wieder abschalten. Erstellen wir nun die benötigen Schaltpunkte. Anders als zuvor bei der Abwasserpumpe haben wir hier 4 Zeiten, bei welchen wir mehrere Schaltpunkte benötigen. Wir könnten nun z.B. bei der Zeit Schichtbeginn Offset 0 zwei mal Schaltpunkte hinzufügen ausführen. Es gibt jedoch auch eine einfachere Möglichkeit. Selektieren Sie hierzu die Zeit Schichtbeginn Offset 0. Im Kontextmenü Schaltpunkte hinzufügen aktivieren. Es wird Ihnen nun der Dialog Schaltpunkte angezeigt. Selektieren Sie die Funktion PFS Ereignis [Hupendauer] und die Variable Hupe. Jeweils mit Hinzufügen in die Ergebnisliste übernehmen. Nach OK werden 2 Schaltpunkte entsprechenden Typs und Verknüpfung erstellt. Für den Schaltpunkt Variable Hupe muss der Sollwert noch auf 1 gesetzt werden. Mit der gleichen Vorgangsweise die Schaltpunkte für die Relativzeiten Schichtende, Pausenbeginn und Pausenende ausführen. Als letzten Schaltpunkt für die Hupe erstellen wir bei der Relativzeit Hupdauer einen Schaltpunkt der die Variable Hupe auf 0 setzt.

info Info

Ein Dezimalwert kann sowohl mit 'Komma' als auch mit 'Punkt' angegeben werden, das Dezimalzeichen wird automatisch in einen 'Punkt' umgewandelt.


Schritt 13: Fahrplan Linie I

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 13: Fahrplan Linie I

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei unseren Strukturüberlegungen haben wir uns entschieden, die Temperatur sowie das Licht in eigenen untergeordneten Fahrplänen zu behandeln.

Erstellen wir nun den Fahrplan für die Linie I. Hierzu selektieren wir in der Baumansicht den Fahrplan Halle. Über die Kontextmenüoption Erstellen aktivieren wir, den uns bereits bekannten Fahrplan Eigenschaftsdialog. Die Bezeichnung soll Linie I sein, wir fügen keine Variablen hinzu. Hierdurch haben wir die Möglichkeit das nachträgliche Ändern von Variablen- und Funktionsverknüpfungen kennen zulernen.

Selektieren Sie beim neuen Fahrplan Linie I, in der Baumansicht die Variablenlist e. Über das Kontextmenü und Variable hinzufügen, verknüpfen wird die Variablen Licht I und Heizung P I mit dem Fahrplan.

Wenn der Fahrplan Linie I selektiert ist, werden in der Tabelle bereits alle im Vorgänger definierten Zeiten grau hinterlegt angezeigt. Grau hinterlegte Zeiten kennzeichnen vom Vorgänger geerbte Zeiten. Wenn die Definition beim Vorgänger geändert wird, ändern sich automatisch diese Zeiten mit.

Definieren wir nun die Schaltpunkte für die Temperatur sowie das Licht. Die Vorgangsweise ist die selbige wie beim Fahrplan Halle.


Schritt 14: Fahrplan Linie II

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 14: Fahrplan Linie II

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Erstellen Sie einen neuen Fahrplan Linie II mit den entsprechenden Schaltpunkten lt. Aufgabe.


Schritt 15: Überlegungen zur Kalenderzuordnung

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 15: Überlegungen zur Kalenderzuordnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zeiten in den Fahrplänen haben keinen Datumsbezug, dieser wird durch Zuordnung eines Tages im Kalender hergestellt. Für absolute und relative Zeiten wird diese Zuordnung getrennt vorgenommen. Diese Zuordnung kann für jede Zeitmodell-Gruppe durchgeführt werden.

Noch in diesem Kapitel

Absolute Zeiten

Relative Zeiten


Absolute Zeiten

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 15: Überlegungen zur Kalenderzuordnung -> Absolute Zeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für absolute Zeiten ist die Verknüpfung des Fahrplan zum Kalendertag entscheidend. Es werden hierbei folgende Verknüpfungsarten unterstützt:

Fahrplan an diesen Tag verwenden.

Fahrplan an diesen Tag nicht verwenden.

Fahrplan an Feiertagen verwenden.

Fahrplan für den Wochentag verwenden.


Relative Zeiten

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 15: Überlegungen zur Kalenderzuordnung -> Relative Zeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die relativen Zeiten ist die Modellzuordnung zum Tag, sowie die Schichten im Modell entscheidend. Es werden hierbei folgende Verknüpfungsarten unterstützt:

Modell für diesen Tag verwenden.

Feiertagsmodell, wenn der Tag ein Feiertag ist

Modell für den Wochentag verwenden.


Schritt 16: Kalenderzuordnung durchführen

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 16: Kalenderzuordnung durchführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Selektieren Sie den Eintrag Kalender in der Baumansicht. In der Tabelle wird nun der aktuelle Monat dargestellt. Jede Woche hat die Zeilen Modelle - Halle I und Fahrpläne - Halle I. Selektieren Sie die Zelle Fahrpläne - Halle I vom Montag. Über den Kontextmenüpunkt Fahrpläne auswählen aktivieren Sie den Dialog für die Fahrplanauswahl. Selektieren Sie den Fahrplan Halle und fügen Sie diesen mit Hinzufügen in die Ergebnisliste hinzu. Es wird nun die volle Kennung Halle I. Halle vom Fahrplan übernommen. Beim verlassen mit OK , wird nun der Dialog für den Aktivierungszeitraum angezeigt. Unser Fahrplan soll wöchentlich, ohne Enddatum, an den Tagen Montag bis Sonntag ausgeführt werden. Die Zuordnung zum Sondertag wird bei den Eigenschaften vom Fahrplan Halle Kalender-Belegung durchgeführt. Es wäre auch möglich die Wochentagzuordnung dort durchzuführen. Für die Fahrpläne Linie I und Linie II braucht keine Kalenderzuordnung durchgeführt werden, da diese keine Schaltpunkte zu einer absoluten Zeit definieren.

Für die Relativzeiten brauchen wir die Modellzuordnung, welche wir wie folgt durchführen. Selektieren Sie die Zelle Modelle Halle I Montag. Über den Kontextmenüpunkt Modelle auswählen wird der Dialog für die Modellverknüpfung aktiviert. Selektieren Sie das Modell Werktag und fügen Sie dieses in die Ergebnisliste hinzu. Beim Beenden des Dialoges mit Ok wird noch gefragt ob das Modell als default eingetragen werden soll. Wählen Sie Ja, wird für jeden Montag dieses Modell verknüpft, ansonst nur an diesem einen Montag. Wir aktivieren unser Modell für jeden Montag. Diese Vorgangsweise können wir für Dienstag bis Freitag wiederholen. Die einfachere Möglichkeit ist jedoch bei der Zeitmodell-Gruppe Halle I die Seite Eigenschaften - Kalender Belegung zu aktivieren und dort die Zuordnung vorzunehmen. Wählen Sie für Dienstag bis Freitag das Modell Werktag und für Sondertag Feiertag aus. Wenn wir nun wieder auf die Kalenderansicht wechseln, sehen wir die Zuordnung der Modelle zum Tag.


Schritt 17: Überprüfung der Projektierung

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 17: Überprüfung der Projektierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bereits im Editor besteht die Möglichkeit die Projektierung der Fahrpläne und Kalenderzuordnung zu überprüfen. Möglich wird dies durch die Schaltpunktvorschau. Wobei in der Vorschau jeder beliebige Zeitraum betrachtet werden kann, auch vergangene.


Schritt 18: PFS zur Laufzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 18: PFS zur Laufzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Laufzeit werden die aktivierten Schaltpunkte sekündlich abgearbeitet und ausgeführt. Dies beginnt mit dem Starten des Laufzeitsystem und ist aktiv bis zur Beendung.

Der PFS beinhaltet aber auch die Möglichkeit, die Projektierung voll in der Laufzeitumgebung durchzuführen, wobei die Unterschiede zum Editor gering ausfallen.

Die Unterschiede bestehen in folgendem:

  • Die Bedienberechtigungen für anzeigen, bearbeiten, hinzufügen und löschen von Einträgen sind aktiv.
  • Kontextmenüfunktionen können durch Schalter im MDI-Fenster aktiviert werden.
  • Die Schaltpunktvorschau löst benutzerdefinierte Ereignisse anhand der bestehenden Triggerzeitpunkte für das Ereignis auf.
  • Das Speichern der geänderten Projektierung aktiviert diese sofort.

Für unsere Tests zur Laufzeit projektieren Sie:

  • Ein Startbild mit der Fensterart Standard.
  • Ein PFS-Bild mit der Fenster-Art Production undamp; Facility Scheduler.
  • Im PFS-Bild die Default-Objekte.
  • Im Startbild einen Button welcher mittels Bilddirekt auf das PFS Bild umschaltet. Filtereinstellungen werden keine vorgenommen.
  • Im Startbild mehrere Anzeigefelder um die Zustände der Variablen zu visualisieren.


Schritt 19: Ausführung zur Laufzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 19: Ausführung zur Laufzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Ausführung eines Absolutschaltpunktes sind Datum und Zeit entscheidend. Relative und absolute Zeiten, die keinen Datumsbezug haben, werden mittels der Kalenderzuordnung zu Absolutschaltpunkten aufgelöst. Um nun unsere Tests ausführen zu können, müssen wir bei der Systemzeit manipulieren, es sei denn Sie haben viel Zeit und warten bis der Tag vorüber gegangen ist.

Änderungen an der Zeit bleiben dem PFS jedoch nicht verborgen und haben je nach Projektierung und Änderung der Zeit unterschiedliche Reaktionen zur Folge. Sehen wir uns hierzu die Eigenschaften vom Production & Facility Scheduler an. Die Seite Zeitumstellung definiert das Verhalten des PFS, wenn sich die Uhrzeit ändert.

Noch in diesem Kapitel

Positive Zeitumstellung

Negative Zeitumstellung


Positive Zeitumstellung

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 19: Ausführung zur Laufzeit -> Positive Zeitumstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schaltpunkte nachholen bewirkt das Ausführen sämtlicher Schaltpunkte von der Ausgangszeit bis zur korrigierten Zeit zum Zeitpunkt der korrigierten Zeit.

Schaltpunkte neu berechnen veranlasst eine Neuberechnung der Schaltpunkte, ab der korrigierten Zeit. Schaltpunkte vom Ausgangszeitpunkt bis vor der korrigierten Zeit werden nicht ausgeführt.


Negative Zeitumstellung

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 19: Ausführung zur Laufzeit -> Negative Zeitumstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schaltpunkte verwerfen führt keine Neuberechnung durch, was zur Folge hat das erst wieder Schaltpunkte ausgeführt werden, wenn der Ausgangszeitpunkt erreicht wird.

Schaltpunkte neu berechnen erstellt die Absolutschaltpunkte ab der korrigierten Zeit neu. Hierdurch werden die Schaltpunkte nochmals ausgeführt.

Die für die Zeitkorrektur gemachten Aussagen gelten nur wenn die Laufzeitumgebung nicht beendet wird. Bei einem Neustart erfolgt die Berechnung immer entsprechend der aktuellen Systemzeit. Des weiteren muss die gemachte Zeitänderung die Zeittoleranz überschreiten.

In Kenntnis wie sich der PFS bei Zeitänderung verhält, wird empfohlen für die Überprüfung der Ausführung die Zeit nur zu erhöhen. Wenn die Zeit zurückgestellt werden soll, die Laufzeitumgebung beenden, die Zeit ändern und neu zu starten.

Starten Sie das Laufzeitsystem und ändern Sie die Uhrzeit. Speziell z.B. um 12 Uhr ist ein spannender Augenblick. Um diese Zeit müsste die Hupe für 6 Sekunden aktiv sein. Testen Sie dies.

Da wir nun einen Trigger für das benutzerdefinierte Ereignis Hupendauer haben, ist der Ausführungszeitpunkt in der Schaltpunktvorschau ersichtlich. Ausführungszeitpunkt 12:00:06.


Schritt 20: Resümee

Handbuch -> Production and Facility Scheduler (PFS) -> Projektieren mit dem Production and Facility Scheduler -> Schritt 20: Resümee

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wir haben in diesen 20 Schritten die grundlegenden Teile des PFS kennen gelernt. Es sollte Ihnen nun möglich sein, eigenständig PFS-Projekte zu erstellen.

Die Aufteilung der Schaltzeiten in 3 Fahrpläne ist nicht unbedingt notwendig, wurde aber zur Veranschaulichung der geerbten Zeiten so ausgeführt. Der Projektierungsaufwand wäre mit nur einem Fahrplan geringer.

Nochmals kurz die benötigten Schritte:

  1. Erstellen der benutzerdefinierten Ereignisse.
  2. Erstellen der Zeitmodell-Gruppe.
  3. Erstellen der Modelle.
  4. Erstellen des Fahrplans.
  5. Erstellen der absoluten Zeiten.
  6. Erstellen der relativen Zeiten.
  7. Erstellen der Schaltpunkte.
  8. Verknüpfen des Fahrplans im Kalender für die absoluten Zeiten.
  9. Verknüpfen der Modelle im Kalender für die relativen Zeiten.


Weiterführende Projektierung im Production and Facility Scheduler

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Drag and Drop

Filterung der PFS Projektierung

Massenbearbeitung

Strukturfahrpläne

Projektierung Bild direkt für PFS-Fenster

Berechtigungen zur Laufzeit

PFS im Netzwerk

Konvertierung von Projekten

VBA-Schnittstelle


Drag and Drop

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> Drag and Drop

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Drop Funktionalität an. Mittels dieser können Objekte schnell und einfach von einem zum anderen verschoben werden. Im Wesentlichen entspricht der Ablauf einem Ausschneide- Einfügevorgang. Es muss beachtet werden, dass Objekte nur zu Objekten der gleichen Art verschoben werden können. Der Mauscursor zeigt visuell an, wenn die Ablage nicht erlaubt ist. Die Ablage eines Objektes auf ein verbotenes Ziel bricht den Vorgang ab. Diesen Umstand kann man sich zu nutze machen, wenn versehentlich das falsche Objekt aufgenommen wurde.


Filterung der PFS Projektierung

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> Filterung der PFS Projektierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit zunehmender Anzahl von Zeitmodell-Gruppen, Modellen, Fahrplänen und Schaltzeiten wird es schwieriger bestimmte Objekte zu finden bzw. die Übersicht zu bewahren. Um dieses Problem zu mildern, wurde eine Filterung implementiert. In der Baumansicht kann mit der Option Filter-Kriterien im Kontextmenü von Production & Facility Scheduler der Filter-Dialog aktiviert werden. Die eigentliche Dokumentation des Filterdialogs können Sie beim PFS Filterdialog nachlesen, wir konzentrieren uns hier auf die Anwendung.

Die Filterung wird jeweils bei der Anzeige des Objektes durchgeführt. Ein Objekt, das nicht dem Filter entspricht, wird nicht angezeigt. Es ist jedoch weiter vorhanden. Dies kann Verwirrung auslösen, wenn z.B. ein neuer Fahrplan erstellt wird und die Bezeichnung auf einen gefilterten Fahrplan gesetzt wird. Dies löst eine Fehlermeldung aus, dass die Bezeichnung doppelt vorhanden ist.

Wenn neue Objekte erstellt werden, die nicht dem Filter entsprechen, bleiben diese sichtbar bis zur nächsten Aktualisierung der Anzeige. Beispielsweise das Erstellen einer Uhrzeit, die außerhalb des Filters liegt. Solange der Fahrplan nicht verlassen wird, bleibt diese sichtbar. Bei der nächsten Aktualisierung verschwindet diese, ist jedoch weiterhin vorhanden. Der Filter wird erst neu angewandt, wenn die Ansicht neu aufgeschaltet wird.

Im Kalender werden die verknüpften Fahrpläne und Modelle ebenfalls gefiltert.


Massenbearbeitung

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> Massenbearbeitung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wer kennt nicht folgendes Problem: Alle absoluten Zeiten zwischen 06:00:00 und 20:00:00 sollen um 00:43:25 verschoben werden. Schon sitzt man da, berechnet und korrigiert die Zeiten, das vielleicht für duzende Zeiten. Genau für Anforderungen dieser Art wurde die Massenbearbeitung integriert. Sie ermöglicht auf Fahrplanebene, entsprechend zum Typ der Spalte, an den selektierten Zellen Modifikationen auszuführen. Unser zuvor beschriebenes Problem ist hierdurch mit wenigen Mausklicks und Eingaben lösbar.

In Zusammenarbeit mit dem Filter, ergibt sich nochmals die Möglichkeit die Menge der zu bearbeitenden Elemente einzuschränken.

Die folgenden Spalten unterstützen die Massenbearbeitung:

Parameter | Beschreibung
Zeittyp | Ermöglicht die Änderung des Zeittyps.
Uhrzeit | Für absolute Zeiten kann die Zeit verändert werden. Hierzu wird der Dialog Zeit ändern aufgerufen.
Offset | Für relative Zeiten kann der Offset verändert werden. Hierzu wird der Dialog Offset ändern aufgerufen.
Aktiv | Die Aktivierung kann verändert werden.
Aktion | Je nach Verknüpfungstyp kann der Wert, die Aktivierung od. das auszuführende Makro verändert werden. Hierzu wird der Dialog Wert ändern aufgerufen.


Strukturfahrpläne

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> Strukturfahrpläne

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Strukturfahrpläne dienen zur visuellen Strukturierung der Fahrpläne in der Baumansicht. Ein Fahrplan wird zum Strukturfahrplan durch setzen der Checkbox Struktur-Fahrplan bei den Fahrplan Eigenschaften.

Strukturfahrpläne haben keine zugeordneten Variablen und Funktionen sowie auch keine Zeiten und Schaltpunkte. Der Strukturfahrplan kann untergeordnete Fahrpläne aufnehmen und damit für diese eine logische Zusammengehörigkeit visualisieren.


Projektierung Bild direkt für PFS-Fenster

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> Projektierung Bild direkt für PFS-Fenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Filterdialog für die Funktion Bilddirekt auf PFS-Bilder ermöglicht die anzuzeigenden Daten zu spezifizieren, sowie die Darstellung der Tabelle anzupassen.

Parameter | Beschreibung
Filterung der Baumansicht | Selektieren Sie das bei Bildaufschaltung zu aktivierende Objekt. Das Objekt muss den Filterkriterien entsprechen bzw. der Filter wird deaktiviert. Siehe hierzu auch Filter Baumansicht für Bild direkt.
Filterung der Tabellenansicht | Legt fest welches Format die Tabellenansicht hat. Siehe hierzu auch Filter Tabellenansicht für Bild direkt.


Berechtigungen zur Laufzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> Berechtigungen zur Laufzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zu jedem Objekt in der Baumansicht können, je nach Funktionalität vom Objekt, Berechtigungen vergeben werden. Zur Laufzeit darf der aktuell eingeloggte Benutzer die Funktion nur ausführen wenn er über die entsprechende Passwortebene verfügt. Die Berechtigung bezieht sich immer auf das Objekt.

Wenn der Benutzer nicht über das Recht verfügt ein Objekt zu sehen, so wird das Objekt sowie alle seine untergeordneten Objekte verborgen. Dies obwohl er vielleicht für ein untergeordnetes Objekt die Anzeigeberechtigung besitzt.

Die Berechtigung zum Ändern, schließt auch das Recht ein die Berechtigungen zu ändern.


PFS im Netzwerk

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> PFS im Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der PFS kann im Netzwerk eingesetzt werden, wobei die Schaltpunktausführung nur am Server erfolgt. Ein eventuell vorhandener Standby - Server arbeitet die Schaltpunktliste zwar entsprechend ab, führt diese jedoch nicht aus. Die Synchronisierung der Abarbeitung erfolgt über die Systemzeit.

Das Verhalten des PFS beim Hochstufen des Standby zum Server, kann projektiert werden. Das Problem bei der Umstufung ist, dass der Sb nicht mit Sicherheit weis, wann die letzte Schaltung vom Server ausgeführt wurde. Hierfür wurde bei den Eigenschaften , Zeitumstellung vom Production & Facility Scheduler die Einstellmöglichkeit SB-Umschaltung verwerfen vorgesehen.

Schaltpunkte verwerfen | Mit der Schaltpunktabarbeitung wird an der aktuellen Position im Sb fortgefahren. Dies hat eventuell zur Folge, dass Schaltpunkte nicht ausgeführt werden.
Schaltpunkte neu berechnen | Die Schaltpunkte werden ab der aktuellen Zeit - 30 Sekunden erneut berechnet und sofort ausgeführt. Dies hat eventuell zur Folge, dass Schaltpunkte doppelt ausgeführt werden.

Wenn der Server wieder im Netz verfügbar ist und sich der Standby runterstuft, wird der Server mit den aktuellen PFS-Daten synchronisiert. Hiermit ist sichergestellt, dass die Schaltpunktausführung nahtlos weiterläuft.

Server | Führt die Schaltpunkte aus. Speichert die Projektierung für den PFS. Umprojektierungen von Clients verwerfen Umprojektierungen, welche noch nicht gesichert wurden ohne Nachfrage.
Client | Keine Schaltpunktausführung. Projektdaten können editiert werden. Hinweis wenn sich die Projektdaten durch externe Projektänderung verändert haben. Triggerzeitpunkt für Benutzerevents entspricht der Systemzeit am Client.
Standby | Solange Sb entsprechend Client Projektierbares verhalten beim Hochstufen. Speichert die Projektierung für den PFS.


Konvertierung von Projekten

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> Konvertierung von Projekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein Projekt welches mit einer Version vor 5.50 erstellt wurde, aktiviert wird, werden die Profile in Fahrplan-Strukturen umgewandelt. Die Profile werden ab der Version 5.50 nicht mehr unterstützt. Für jedes Profil wird ein Struktur-Fahrplan erstellt, der die verknüpften Fahrpläne enthält. Die verknüpften Fahrpläne enthalten die Zeiten, die innerhalb der Profil Ein/- Ausschaltzeiten lagen.

Die Tagesinformation der Profil-Fahrpläne wird in den Kalender übernommen.

Der Verlauf der Projektierung wird im Ausgabefenster des Editors festgehalten.


VBA-Schnittstelle

Handbuch -> Production and Facility Scheduler (PFS) -> Weiterführende Projektierung im Production and Facility Scheduler -> VBA-Schnittstelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der PFS enthält eine Vba-Schnittstelle, die im Vba-Objekt Project integriert ist. Des weiteren ist es möglich, Schaltpunkte mit einem VBA-Makro vom Typ Execute_Value zu verknüpfen. In diesem Fall wird der Schaltpunkt als Parameter an das VBA-Makro übergeben.

Das VBA-Makro ist in weiterer Folge für die Ausführung der Schalthandlung verantwortlich.


Objekttypen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Objekte enthalten die für sie durchgeführte Projektierung. Es werden zwei Arten von Objekttypen unterschieden:

Editierbare Objekttypen und Fest vorgegebene Objekttypen

Noch in diesem Kapitel

Fest vorgegebene Objekttypen

Editierbare Objekttypen

Objekt Production and Facility Scheduler

Objekt Zeitmodell-Gruppen

Objekt editierbare Zeitmodell-Gruppen

Objekt Fahrpläne

Objekt editierbare Fahrpläne

Objekt Funktionsliste

Objekt Uhrzeit

Objekt Schaltpunkt

Objekt Zeitmodelle

Objekt editierbare Modelle

Objekt Schicht

Objekt Pause

Objekt Ereignisse

Objekt Benutzer-Ereignisse

Objekt Kalender

Objekt Variablenliste

Objekt Funktionen


Fest vorgegebene Objekttypen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Fest vorgegebene Objekttypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Objekttypen sind wenn ihr Vorgängerobjekt erstellt wurde und die Anzeigeberechtigung gegeben ist, immer vorhanden. Sie können weder verschoben, umbenannt noch gelöscht werden. Wenn diese Objekte unterdrückt werden, sind auch alle Kindobjekte unzugänglich.
Z.B.: Zeitmodell-Gruppen haben immer die festen Objekttypen Fahrpläne und Zeitmodelle.


Editierbare Objekttypen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Editierbare Objekttypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Objekttypen werden entsprechend der benötigten Anzahl bei der Projektierung erstellt.


Objekt Production and Facility Scheduler

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Production and Facility Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dies ist das Wurzelobjekt für den gesamten PFS. In diesem Objekt werden Einstellungen vorgenommen welche für den gesamten PFS gültig sind. Es ist ein fest vorgegebenes Objekt.

Parameter | Beschreibung
Speichern | Speichert die gemachten Änderungen ab. Zur Laufzeit werden die Einstellungen bei den Laufzeitdaten abgespeichert, sowie eine Neuberechnung der Schaltpunkte aufgrund der geänderten Projektierung vorgenommen.
Verwerfen | Nach Bestätigung der Sicherheitsabfrage werden sämtliche gemachten Änderungen unwiederbringlich verworfen.
Eigenschaften | Ruft die Einstellungsseiten für die PFS-Eigenschaften auf.
Schaltpunktvorschau | Aktiviert die Schaltpunktvorschau.
Filter Krieterien | Aktiviert den Filterdialog.
Hilfe | Die Hilfe wird aktiviert.


Objekt Zeitmodell-Gruppen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Zeitmodell-Gruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Objekt beinhaltet alle definierten Zeitmodell-Gruppen des PFS. Es ist ein fest vorgegebenes Objekt.

Parameter | Beschreibung
Erstellen | Erstellt eine neue Zeitmodell-Gruppe und ruft die Seite der Eigenschaften für die neue Zeitmodell-Gruppe auf.
Einfügen | Wenn ein Zeitmodell-Gruppe in der Zwischenablage liegt, kann dieses als Kopie eingefügt werden. Kopien erhalten eine fortlaufende Nummer, um die eindeutige Benennung zu wahren.
Berechtigung | Aktiviert den Dialog für die Rechte des Objektes.
Hilfe | Hilfe aufrufen.


Objekt editierbare Zeitmodell-Gruppen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt editierbare Zeitmodell-Gruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zeitmodell-Gruppen kapseln die ihnen zugehörigen Fahrpläne und Zeitmodelle. Des weiteren werden darin grundlegende Einstellungen für relative Schaltzeiten vorgenommen.

Im Kalender kann für jede Zeitmodell-Gruppe die Zuordnung der Fahrpläne und Modelle pro Tag durchgeführt werden.

Jede Zeitmodell-Gruppe beinhaltet die fest vorgegebenen Objekte Fahrpläne und Zeit-Modelle.

Parameter | Beschreibung
Kopieren | Kopiert die selektierte Zeitmodell-Gruppe bzw. selektierten Zeitmodell-Gruppe in die Zwischenablage.
Umbenennen | In der Baumansicht wechselt bei der Zeitmodell-Gruppe die Bezeichnung in den Editiermodus. Es kann nun die Bezeichnung verändert werden. Die neue Bezeichnung muss PFS weit einmalig sein.
Löschen | Löscht alle selektierten Zeitmodell-Gruppen nach einer Sicherheitsabfrage.
Eigenschaften | Aktiviert die Seite mit den Zeitmodell-Gruppeneinstellungen.
Berechtigungen | Aktiviert den Dialog für die Berechtigungen.
Hilfe | Aktiviert die Hilfe.


Objekt Fahrpläne

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Fahrpläne

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Objekt beinhaltet sämtliche Fahrpläne 1. Ordnung. Es ist ein fest vorgegebenes Objekt.

Kontextmenü

Menüpunkt | Aktion
Erstellen | Erstellt einen neuen Fahrplan.
Einfügen | Fügt einen Fahrplan aus der Zwischenablage ein.
Berechtigungen | Öffnet den Dialog für die Berechtigungen.
Hilfe | Öffnet die Onlinehilfe.

Noch in diesem Kapitel

Neuer Fahrplan Kontextmenü

Kontextmenü Zeitansicht neuer Fahrplan


Neuer Fahrplan Kontextmenü

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Fahrpläne -> Neuer Fahrplan Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Erstellen | Erstellt einen neuen Fahrplan.
Kopieren | Kopierte ausgewählte Fahrpläne.
Ausschneiden | Schneidet ausgewählte Fahrpläne aus.
Einfügen | Fügt Fahrpläne aus der Zwischenablage ein.
Inaktiv/Aktiv | Schaltet für ausgewählte Fahrpläne zwischen den Status aktiv und inaktiv um.
Umbenennen | Ermöglicht das Umbenennen der Fahrplannamen.
Löschen | Löscht die ausgewählten Fahrpläne nach einer Sicherheitsabfrage.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Berechtigungen | Öffnet den Dialog für die Berechtigungen.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Zeitansicht neuer Fahrplan

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Fahrpläne -> Kontextmenü Zeitansicht neuer Fahrplan

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die angezeigten Menüeinträge hängen ab vom Bereich, an dem der Rechtsklick ausgeführt wird. Einträge, die nicht immer angezeigt werden, erhalten den Zusatz (optional).

Menüpunkt | Aktion
Zeitraster erstellen | Öffnet den Dialog zur Erstellung eines Zeitrasters.
Uhrzeit erstellen | Fügt einen neue Uhrzeit in die Liste ein.
Schaltpunkt erstellen | Erstellt einen neuen Schaltpunkt.
Schaltpunkte erstellen | Öffnet den Dialog zur Erstellung mehrerer Schaltpunkte.
Uhrzeit löschen | Löscht die ausgewählte Uhrzeit.
Schaltpunkte löschen | Löscht den ausgewählten Schaltpunkt.
Zeit ändern (optional) | Öffnet den Dialog zum Ändern der Uhrzeit.
Absoluter Zeitpunkt (optional) | Aktiviert die Option Relativer Zeitpunkt
Relativer Zeitpunkt (optional) | Aktiviert die Option Absoluter Zeitpunkt
Alle Werte aktiv (optional) | Setzt Werte aktiv.
Alle Werte inaktiv (optional) | Setzt Werte inaktiv.
Hilfe | Öffnet die Online-Hilfe.


Objekt editierbare Fahrpläne

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt editierbare Fahrpläne

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fahrpläne sind das Herz des PFS. Sie enthalten die für die Ausführung wichtigen Objekte Uhrzeit und Schaltpunkte.

Die Fahrpläne können wiederum Fahrpläne aufnehmen, wobei die Kindfahrpläne alle im Elternfahrplan definierten Uhrzeiten erben. Für die Schachtelungstiefe besteht keine Einschränkung.

Parameter | Beschreibung
Erstellen | Erstellt einen neuen Kindfahrplan und ruft für diesen die Einstellungsseiten auf.
Kopieren | Die selektierten Fahrpläne werden in die Zwischenablage kopiert.
Ausschneiden | Die selektierten Fahrpläne werden ausgeschnitten. Ausgeschnittene Fahrpläne werden speziell gekennzeichnet, verschwinden jedoch erst wenn diese in einen anderen Fahrplan eingefügt werden. Das Einfügen eines ausgeschnittenen Fahrplan in sich selbst bzw. bei seinen unmittelbaren Vorgänger ist nicht möglich.
Einfügen | Fügt die Fahrpläne aus der Zwischenablage ein. Die Benennung des eingefügten Fahrplan wird hierbei geändert, um die Eindeutigkeit zu wahren.
Inaktiv/Aktiv | Aktiviert bzw. deaktiviert den Fahrplan. Die Schaltpunkte deaktivierter Fahrpläne werden nicht ausgeführt.
Umbenennen | Ermöglicht die Änderung der Fahrplanbenennung. Die neue Bezeichnung muss auf gleicher Ebene eindeutig sein.
Löschen | Löscht die selektierten Fahrpläne und ihre Kindfahrpläne nach einer Sicherheitsabfrage.
Eigenschaften | Ruft die Einstellungsseite für die Fahrplaneigenschaften auf.
Berechtigungen | Ruft den Dialog für die Berechtigungen auf.
Hilfe | Aktiviert die Onlinehilfe.


Objekt Funktionsliste

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Funktionsliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Objekt enthält die dem Fahrplan zugeordneten Funktionen. Nur dem Fahrplan zugeordnete Funktionen können von diesem auch verwendet werden. Dies ist ein fest vorgegebenes Objekt.

Kontextmenü Funktionsliste

Menüpunkt | Aktion
Funktion hinzufügen | Ermöglicht eine neue Funktion dem Fahrplan zuzuordnen. Nach aufblenden der Liste, der definierten Funktionen, selektieren Sie die gewünschte Funktion und übernehmen diese mit OK .
Funktion einfügen | Fügt die Funktionen aus der Zwischenablage ein.
Berechtigungen | Öffnet den Dialog für die Berechtigungen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Funktion

Menüpunkt | Aktion
Kopieren | Kopiert ausgewählte Funktionen.
Ausschneiden | Schneidet ausgewählte Funktionen aus.
Funktion ersetzen | Öffnet den Dialog zum Ersetzen der ausgewählten Funktionen.
Funktion entfernen | Löscht ausgewählte Funktionen aus der Liste.
Berechtigungen | Ruft den Dialog für die Berechtigungen auf.
Hilfe | Aktiviert die Onlinehilfe.


Objekt Uhrzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Uhrzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Uhrzeit definiert den Zeitpunkt, wann der damit verknüpfte Schaltpunkt ausgeführt werden soll.

Es gibt 2 Arten von Zeittypen:

  • absolute
  • relative

Die definierten Uhrzeiten werden an die Kindfahrpläne weitergegeben und in diesen grau hinterlegt.

Noch in diesem Kapitel

Zeittyp absolut

Zeittyp relativ

Offset

Kontextmenü Uhrzeit


Zeittyp absolut

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Uhrzeit -> Zeittyp absolut

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Uhrzeit ist direkt im Feld Uhrzeit definiert. Wenn der Fahrplan mit einem Tag verknüpft ist, werden die dem Zeitpunkt zugeordneten aktiven Schaltpunkte ausgeführt. Das Feld Offset ist ohne Bedeutung.

Der Zeitmodell-Gruppenzyklus bzw. die Modellzuordnung ist ohne Bedeutung.


Zeittyp relativ

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Uhrzeit -> Zeittyp relativ

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei diesem Zeittyp wird bei der Uhrzeit ein Ereignis ausgewählt. Dieses Ereignis wird in der Vorschau oder zur Laufzeit in einen Absolutschaltpunkt umgewandelt. Die Kriterien, nach denen der Absolutschaltpunkt erzeugt wird, hängen ab vom Ereignis und der damit zusammenhängenden Projektierung. Bei jedem Ereignis kann ein Offset angegeben werden, der den Ausführungszeitpunkt entsprechend verschiebt.

Parameter

Beschreibung

Zyklusbeginn

Wird täglich um Mitternacht ausgeführt.

Zyklusbeginn ohne Produktion

Wird an den Tagen geschaltet, die mit keiner Schicht verknüpft sind. Der Zeitpunkt ist der Tagesbeginn der Zeitmodell-Gruppe.

Ein Tag ist auch dann produktionsfrei, wenn z.B. die letzte Schicht erst um 02:00:00 Uhr desselben Tages endet.

Zyklusbeginn mit Produktion

Wird an den Tagen geschaltet, an denen Schichten eingetragen sind. Der Zeitpunkt ist der Tagesbeginn der Zeitmodell-Gruppe.

Produktionsbeginn

Wird zum Beginn der ersten Schicht ausgeführt, sofern die erste Schicht jene ist, die einem Tag ohne Produktion folgt.

Produktionsende

Wird am Ende der letzten Schicht ausgeführt, wenn auf diese letzte Schicht ein Tag ohne Produktion folgt. Damit ist die Schicht am Ende eines Tages kein Produktionsende, wenn am nächsten Tag weiter produziert wird.

Schichtbeginn

Wird zum Beginn jeder Schicht ausgeführt.

Schichtende

Wird am Ende jeder Schicht ausgeführt.

Pausenbeginn

Wird zum Beginn jeder Pause ausgeführt.

Pausenende

Wird am Ende jeder Pause ausgeführt.

Benutzerdefiniertes Ereignis

Sämtliche benutzerdefinierten Ereignisse können zugeordnet werden. Der Schaltpunkt wird beim Eintreten des Triggerereignis für das benutzerdefinierte Ereignis angestoßen.

Schichtbeginn erste Schicht

Wird am Beginn der ersten Schicht im Zeitmodell-Gruppenzyklus ausgeführt

Schichtende letzte Schicht

Wird am Ende der letzten Schicht im Zeitmodell-Gruppenzyklus ausgeführt.

Schichtfrei Beginn

Wird am Ende der Schicht geschalten, wenn der Beginn der nächsten Schicht um mehr als 1 Sekunde versetzt ist.

Schichtfrei Ende

Wird am Beginn der Schicht geschalten welche auf eine schichtfreie Zeit folgt.

Schichtfrei Beginn ohne Produktionsende

Wird bei Beginn der schichtfreien Zeit geschalten, wenn nicht gleichzeitig ein Produktionsende erfolgt.

Schichtfrei Ende ohne Produktionsbeginn

Wird am Ende der schichtfreien Zeit geschalten, wenn nicht gleichzeitig ein Produktionsbeginn erfolgt.

Schichtbeginn erste Schicht ohne Produktionsbeginn

Wird am Beginn der ersten Schicht geschalten, wenn nicht gleichzeitig ein Produktionsbeginn erfolgt.

Schichtbeginn letzte Schicht ohne Produktionsende

Wird am Ende der letzten Schicht geschalten, wenn nicht gleichzeitig ein Produktionsende erfolgt.

Schichtbeginn ohne Produktionsbeginn

Wird am Beginn der Schicht geschalten, wenn nicht gleichzeitig ein Produktionsbeginn erfolgt.

Schichtende ohne Produktionsende

Wird am Ende der Schicht geschalten, wenn nicht gleichzeitig ein Produktionsende erfolgt.


Offset

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Uhrzeit -> Offset

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei relativen Zeiten kann der Ausführungszeitpunkt mittels Offset verändert werden. Der Offset kann maximal +/- 1 Tag-1 Sekunde sein. Bei benutzerdefinierten Ereignissen kann nur ein positiver Offset eingegeben werden. Der Offset wird in Minuten angegeben, wobei die Sekunden hinter der Kommastelle in 1/100 Minuten eingegeben werden können.

Parameter | Beschreibung
Zeitraster erstellen | Ruft die Einstellungsseite für das zyklische Erstellen einer Absolutzeit auf.
Uhrzeit erstellen | Erstellt eine neue Uhrzeit.
Schaltpunkt erstellen | Erstellt einen neuen Schaltpunkt zu der Uhrzeit.
Schaltpunkte erstellen | Ermöglicht für mehrere Variablen bzw. Funktionen Schaltpunkte in einem Arbeitsgang zu definieren, wenn vorher noch kein Schaltpunkt erstellt wurde.
Uhrzeit löschen | Löscht die markierten Uhrzeiten mit allen Schaltpunkten.
Schaltpunkte löschen | Löscht die markierten Schaltpunkte.
Absolute Zeit | Ändert den Zeittyp auf absolut.
Relative Zeit | Ändert den Zeittyp auf relativ.
Hilfe | Aktiviert die Onlinehilfe.


Kontextmenü Uhrzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Uhrzeit -> Kontextmenü Uhrzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die nicht dokumentierten Menüpunkte entsprechen jenen beim Kontextmenü Zeittyp.

  • Zeit ändern: Dieser Menüpunkt aktiviert den Dialog für die Zeitänderung.


Objekt Schaltpunkt

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Schaltpunkt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Schaltpunkt definiert die Aktion welche ausgeführt werden soll, wenn der Ausführungszeitpunkt gekommen ist.

Noch in diesem Kapitel

Aktiv

Verknüpfungstyp

Verknüpfungen

Aktion

Berechtigungen


Aktiv

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Schaltpunkt -> Aktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hiermit kann die Ausführung des Schaltpunkt freigegeben bzw. verhindert werden.


Verknüpfungstyp

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Schaltpunkt -> Verknüpfungstyp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Verknüpfungstyp definiert, was ausgeführt werden soll. Folgende Verknüpfungen sind möglich:

Parameter | Beschreibung
Variable | Sollwert setzen, mit dem bei Aktion angegeben Wert, wird ausgeführt.
Funktion | Die bei Aktion angegebene Funktion wird aufgerufen.
VBA Makro mit Variable | Das unter Macro -> Browse -> ModuleScheduler -> ExecuteValue definierte Makro mit einer Referenz auf die angegebene Variable wird aufgerufen.
VBA Makro mit Funktion | Das unter Macro -> Browse > ModuleScheduler > ExecuteValue definierte Makro mit einer Referenz auf die angegebene Funktion wird aufgerufen.


Verknüpfungen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Schaltpunkt -> Verknüpfungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Enthält die Liste der mit dem Fahrplan verknüpften Variablen bzw. Funktionen.


Aktion

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Schaltpunkt -> Aktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Je nach Verknüpfungstyp hat die Zelle folgende Bedeutung:

Parameter | Beschreibung
Variable | Sollwert der bei der Variable gesetzt werden soll.
Funktion | Enthält den Zustand von Aktiv.
VBA Makro mit Variable | Name des aufzurufenden Makros.
VBA Makro mit Funktion | Name des aufzurufenden Makros.


Berechtigungen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Schaltpunkt -> Berechtigungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Bearbeitung zur Laufzeit nötige Berechtigungsebene.


Objekt Zeitmodelle

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Zeitmodelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Objekt enthält alle bei der Zeitmodell-Gruppe definierten Zeitmodelle. Dies ist ein fest vorgegebenes Objekt.

Ein Zeitmodell enthält die Definition der Schichten und Pausen, welche für die entsprechenden Relativereignisse benötigt werden.

Kontextmenü Zeitmodell

Menüpunkt | Aktion
Zeitmodell neu | Erstellt ein neues Zeitmodell.
Einfügen | Fügt Zeitmodelle aus der Zwischenablage ein.
Berechtigungen | Öffnet den Dialog für die Berechtigungen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Zeitmodell

Menüpunkt | Aktion
Kopieren | Kopiert ausgewählte Modelle.
Ausschneiden | Schneidet ausgewählte Modelle aus.
Umbenennen | Ermöglicht das Umbenennen des Zeitmodells.
Löschen | Löscht ausgewählte Modelle.
Berechtigungen | Ruft den Dialog für die Berechtigungen auf.
Hilfe | Aktiviert die Online-Hilfe.

Noch in diesem Kapitel

Kontextmenü Zeitmodellgruppe


Kontextmenü Zeitmodellgruppe

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Zeitmodelle -> Kontextmenü Zeitmodellgruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Zeitmodellgruppe

Menüpunkt | Aktion
Erstellen | Erstellt ein neues Zeit-Modell. Für das neue Zeit-Modell kann sofort ein neuer, eindeutiger Name vergeben werden.
Einfügen | Fügt die Zeit-Modelle aus der Zwischenablage ein.
Berechtigungen | Öffnet den Dialog für die Berechtigungen.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Zeitmodell

Menüpunkt | Aktion
Speichern | Speichert Änderungen in der Projektierung des PFS.
Verwerfen | Verwirft alle Änderungen seit dem letzten Speicherzeitpunkt.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Schaltpunktvorschau | Öffnet den Dialog für die Schaltpunktvorschau.
Filter-Kriterien | Öffnet den Dialog zur Auswahl der Filter.
Hilfe | Öffnet die Online-Hilfe.


Objekt editierbare Modelle

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt editierbare Modelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com


Objekt Schicht

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Schicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Zeitmodell beinhaltet die Schichten. Die Schichten werden zur Auflösung der Relativereignisse benötigt. Schichten dürfen sich nicht überlappen und müssen innerhalb des Zeitmodell-Gruppenzyklus sein.

Die Schichten werden in der Tabellenansicht grau hinterlegt dargestellt.

Parameter | Beschreibung
Schicht erstellen | Erstellt eine neue Schicht.
Pause erstellen | Erstellt eine neue Pause bei der Schicht.
Schicht löschen | Löscht die Schicht mit allen Pausen.
Hilfe | Aktiviert die Online-Hilfe.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.


Objekt Pause

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Pause

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zu einer Schicht können mehrere Pausen definiert werden. Die Pausen dürfen sich nicht überlappen und müssen innerhalb der Schicht sein.

Parameter | Beschreibung
Pause erstellen | Erstellt eine neue Pause bei der Schicht.
Pause löschen | Löscht die Pause bei der Schicht.
Hilfe | Onlinehilfe aktivieren.


Objekt Ereignisse

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Ereignisse

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Objekt enthält sämtliche benutzerdefinierten Ereignisse des PFS. Dies ist ein fest vorgegebenes Objekt.

Parameter | Beschreibung
Erstellen | Erstellt ein neues benutzerdefinierte Ereignis. Für das neue Ereignis muss ein eindeutiger Name vergeben werden.
Einfügen | Fügt die benutzerdefinierten Ereignisse aus der Zwischenablage ein.
Berechtigungen | Aktiviert den Dialog für die Berechtigungen.
Hilfe | Aktiviert die Onlinehilfe.


Objekt Benutzer-Ereignisse

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Benutzer-Ereignisse

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Benutzer-Ereignisse sind vom Benutzer kreierbare Ereignisse. Sie werden PFS weit definiert. Angestoßen werden diese, durch eintragen eines Triggerzeitpunkt, mittels der Funktion PFS - Ereignis anstoßen . Die Anzahl der Benutzer-Ereignisse ist nur durch den zur Verfügung stehenden Speicher begrenzt.

Im Editor werden Benutzer-Ereignisse in der Schaltpunktvorschau, aufgrund der fehlenden Trigger nicht aufgelöst. Zur Laufzeit werden die Trigger max. 14 Tage im Speicher gehalten, um die Analyse vergangener Schaltpunkte zu ermöglichen. Beim Beenden der Laufzeitumgebung werden sämtliche Trigger gelöscht.

Das Tabellenfenster enthält die Auflistung aller definierten Benutzer-Ereignisse (grau hinterlegt) und die damit verknüpften Fahrpläne.

Kontextmenü Ereignis

Menüpunkt | Aktion
Erstellen | Erstellt ein neues Benutzer-Ereignis.
Einfügen | Fügt ein Benutzer-Ereignis aus der Zwischenablage ein.
Berechtigungen | Ruft den Dialog für die Berechtigungen auf.
Hilfe | Aktiviert die Onlinehilfe.

Kontextmenü Benutzer-Ereignis

Menüpunkt | Aktion
Kopieren | Kopiert die ausgewählten Benutzer-Ereignisse in die Zwischenablage.
Umbenennen | Ermöglicht, dem Ereignis eine neue Bezeichnung zu geben.
Löschen | Löscht die ausgewählten Benutzer-Ereignisse.
Berechtigungen | Aktiviert den Dialog für die Berechtigungen.
Hilfe | Aktiviert die Onlinehilfe.


Objekt Kalender

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die bei einem Fahrplan definierten relativen und absoluten Schaltzeiten haben keinen Tagesbezug, nur die Uhrzeit wird definiert. Mit dem Kalender wird nun definiert, an welchen Tagen welcher Fahrplan ausgeführt werden soll. Hierfür können für jede Zeitmodell-Gruppe das aktive Modell und die aktiven Fahrpläne pro Tag festgelegt werden.

Der Kalender ist in mehreren Ansichten verfügbar, je nachdem wie detailliert die Information gewünscht wird.

Kontextmenü Kalender

Menüpunkt | Aktion
Erstellen | Erstellt einen neuen Kalender.
Einfügen | Fügt einen Kalender aus der Zwischenablage ein.
Berechtigungen | Ruft den Dialog für die Berechtigungen auf.
Hilfe | Aktiviert die Onlinehilfe.

info Info

Im Kalender können Sie einzelne Tage als Sondertage definieren. An diesen Tagen werden dann die Fahrpläne ausgeführt, die für Sondertage definiert sind. Als Sondertage kann jeder Tag (Montag - Sonntag) definiert werden.

Noch in diesem Kapitel

Absolute Uhrzeit

Relative Uhrzeit

Monatsansicht

Wochenansicht

Tagesansicht

Arten der Modellzuordnung

Arten der Fahrplanzuordnung

Modellzuordnung in der Kalenderansicht

Kontextmenü Modell

Kontextmenü Fahrplan


Absolute Uhrzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Absolute Uhrzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die absoluten Schaltpunkte an einen bestimmten Tag auszuführen, muss der entsprechende Fahrplan mit dem Tag verknüpft werden. Hierzu ist die Zelle Fahrpläne am gewünschten Tag zu selektieren. Über das Kontextmenü wird nun der Dialog für die Fahrplanauswahl aufgerufen und die Verknüpfung erstellt. Die Kennung der verknüpften Fahrpläne wird in die Zelle eingetragen. In der Tagesansicht kann diese detailliert eingesehen werden.


Relative Uhrzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Relative Uhrzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Auflösung der relativen Uhrzeiten zu einem Absolutschaltpunkt ist die Modellverknüpfung bzw. Nichtverknüpfung zu einem Tag entscheidend. Der Kalendertag beginnt immer mit dem Tagesbeginn der Zeitmodell-Gruppe. Wenn der Zeitmodell-Gruppenzyklus über den Tag geht, gehören Zeiten, welche vor dem Tagesbeginn liegen zum Vortag.

z.B. Tagesbeginn 02:00:00 Tagesende 01:59:59. Wenn nun ein Trigger für ein benutzerdefiniertes Ereignis am Montag dem 15.10.2001 um 00:30:00 kommt, so wird das Modell vom Sonntag 14. verwendet. Wenn der Trigger um 02:00:00 kommt, wird das Modell vom Montag verwendet.

Z.B: Tagesbeginn 06:00:00 Tagesende 21:59:59. Wenn nun ein Trigger für einbenutzerdefiniertes Ereignis am Montag dem 15.10.2001 um 00:30:00 kommt, so wird das Modell vom Montag 15. verwendet.


Monatsansicht

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Monatsansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Monatsansicht wird versucht den ganzen Monat im Kalender darzustellen. Wenn der verfügbare Anzeigeplatz nicht ausreicht, wird versucht den aktuellen Tag im Sichtbereich darzustellen. Der große Anzeigezeitraum soll einen schnellen Überblick ermöglichen.

Durch Doppelklick auf eine Fahrplanzelle, werden diese Fahrpläne in der Tabellenansicht zur Bearbeitung geöffnet.

Kontextmenü Monatsansicht

Menüpunkt | Aktion
Modelle auswählen | Öffnet den Dialog zur Auswahl eines Modells.
Fahrpläne auswählen | Öffnet den Dialog zur Auswahl von Fahrplänen.
Tagesansicht | Schaltet um auf Tagesansicht.
Wochenansicht | Schaltet um auf Wochenansicht.
Monatsansicht | Schaltet um auf Monatsansicht.
Zu Heute wechseln | Wechselt zum aktuellen Datum.
Wechseln zu Datum | Öffnet den Dialog zur Auswahl eines Datums.
Vorheriges Element anzeigen | Springt zum vorangegangenen Element.
Nächstes Element anzeigen | Springt zum nächsten Element.
Hilfe | Aktiviert die Onlinehilfe.


Wochenansicht

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Wochenansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Wochenansicht stellt die Zuordnung wochenweise dar.

Kontextmenü Wochenansicht

Menüpunkt | Aktion
Modelle auswählen | Öffnet den Dialog zur Auswahl eines Modells.
Fahrpläne auswählen | Öffnet den Dialog zur Auswahl von Fahrplänen.
Tagesansicht | Schaltet um auf Tagesansicht.
Wochenansicht | Schaltet um auf Wochenansicht.
Monatsansicht | Schaltet um auf Monatsansicht.
Zu Heute wechseln | Wechselt zum aktuellen Datum.
Wechseln zu Datum | Öffnet den Dialog zur Auswahl eines Datums.
Vorheriges Element anzeigen | Springt zum vorangegangenen Element.
Nächstes Element anzeigen | Springt zum nächsten Element.
Hilfe | Aktiviert die Onlinehilfe.


Tagesansicht

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Tagesansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Tagesansicht bietet detaillierte Information über die Verknüpfung der Fahrpläne zum Tag.

Kontextmenü Tagesansicht

Menüpunkt | Aktion
Fahrpläne auswählen | Öffnet den Dialog zur Auswahl von Fahrplänen.
Fahrplan anzeigen | Öffnet den ausgewählten Fahrplan in einem externen Fenster.
Tagesansicht | Schaltet um auf Tagesansicht.
Wochenansicht | Schaltet um auf Wochenansicht.
Monatsansicht | Schaltet um auf Monatsansicht.
Zu Heute wechseln | Wechselt zum aktuellen Datum.
Wechseln zu Datum | Öffnet den Dialog zur Auswahl eines Datums.
Vorheriges Element anzeigen | Springt zum vorangegangenen Element.
Nächstes Element anzeigen | Springt zum nächsten Element.
Als Default | Der Fahrplan soll jeweils am aktuellen Wochentag ausgeführt werden.
Als Einzeltag | Der Fahrplan wird nur an diesen Tag ausgeführt.
Löschen | Wenn der Fahrplan als default eingetragen ist dann wird für diesen Tag eine Ausnahme erstellt. Bei einer Ausführung nur an diesen Tag wird die Einzeltagausführung gelöscht.
Hilfe | Aktiviert die Onlinehilfe.


Arten der Modellzuordnung

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Arten der Modellzuordnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei den Modellen werden folgende Zuordnungsarten unterstützt:

Modell für diesen Tag verwenden.

Feiertagsmodell, wenn der Tag ein Feiertag ist

Modell für den Wochentag verwenden.


Arten der Fahrplanzuordnung

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Arten der Fahrplanzuordnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Zuordnung der Fahrpläne zu einem Tag werden unterstützt:

Fahrplan an diesen Tag verwenden.

Fahrplan an diesen Tag nicht verwenden.

Fahrplan am Feiertag verwenden, wenn der Tag ein Feiertag ist.

Fahrplan für den Wochentag verwenden.


Modellzuordnung in der Kalenderansicht

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Modellzuordnung in der Kalenderansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Modelle können auch direkt in der Kalenderansicht zugeordnet werden. Nach Selektion der Zelle für die Modelle einer Zeitmodell-Gruppe, eines Tages, werden sämtliche verfügbaren Modelle der Zeitmodell-Gruppe aufgelistet. Durch Auswahl eines Modell wird dieses für den aktuellen Tag zugeordnet. Beim Verlassen der Zelle wird noch abgefragt, ob das Modell als Defaultmodell für den Tag verwendet werden soll.


Kontextmenü Modell

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Kontextmenü Modell

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Kontextmenü kann in den Ansichten Monat- und Wochenkalender nach Selektion des Model-Feldes über die Maustaste für das Kontextmenü aktiviert werden.

Parameter | Beschreibung
Modelle auswählen | Ruft den Dialog zur Modellauswahl auf.
Modell anzeigen | Aktiviert die Tabellenansicht Modellbearbeitung.
Tagesansicht | Wechseln zur Tagesansicht.
Wochenansicht | Wechseln zur Wochenansicht.
Zu Heute wechseln | Wechselt zur Tagesansicht für das heutige Datum.
Wechseln zu Datum | Wechselt zur Tagesansicht für das ausgewählt Datum.
Voriges Element | Blättert Seitenweise zurück.
Nächstes Element | Blättert Seitenweise nach vor.
Als Default | Definiert das aktuelle Modell als Standardmodell für den Wochentag, bei der Zeitmodell-Gruppe.
Löschen | Löscht die Modellzuordnung zum Tag. Wenn es sich bei der Zuordnung um das Standardmodell für den Tag handelt, wird die Wochentagszuordnung bei der Zeitmodell-Gruppe gelöscht.
Hilfe | Aktiviert die Onlinehilfe.


Kontextmenü Fahrplan

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Kalender -> Kontextmenü Fahrplan

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Kontextmenü wird nach Selektion der Zelle für die Fahrpläne an einem Tag, bei einer Zeitmodell-Gruppe über die Maustaste für das Kontextmenü, aktiviert. Nicht speziell dokumentierte Menüfunktionen entsprechen jenen beim Kontextmenü Modell.

Parameter

Beschreibung

Fahrpläne auswählen

Ruft den Dialog zur Fahrplanauswahl auf.

Fahrplan anzeigen

Aktiviert die Tabellenansicht Fahrplanbearbeitung.

Als Default

Der Fahrplan wird für den gewählten Wochentag als Standard eingetragen.

Als Einzeltag

Der Fahrplan wird nur an diesen Tag ausgeführt.

Löschen

Öffnet einen Dialog zur Auswahl, was gelöscht werden soll:

  • Alle Elemente löschen: Alle Fahrpläne dieses Typs werden gelöscht.
  • Nur dieses Element löschen: Für dieses Element wird an diesem gewählten Tag eine Ausnahme erstellt.


Objekt Variablenliste

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Variablenliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Objekt enthält die dem Fahrplan zugeordneten Variablen. Nur dem Fahrplan zugeordnete Variablen können bei den Schaltpunkten verwendet werden. Dies ist ein fest vorgegebenes Objekt.

Kontextmenü Variablenliste

Menüpunkt | Aktion
Variable hinzufügen | Fügt eine neue Variable zum Fahrplan hinzu. Dies ist auch zur Laufzeit möglich.
Variable einfügen | Fügt die Variablen aus der Zwischenablage ein.
Berechtigungen | Öffnet den Dialog für die Berechtigungen auf.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Variable

Menüpunkt | Aktion
Kopieren | Kopiert ausgewählte Variablen.
Ausschneiden | Schneidet ausgewählte Variablen aus.
Variable ersetzen | Öffnet den Dialog zum Ersetzen der ausgewählten Variablen.
Variable entfernen | Löscht ausgewählte Variablen aus der Liste.
Berechtigungen | Ruft den Dialog für die Berechtigungen auf.
Hilfe | Aktiviert die Onlinehilfe.

Noch in diesem Kapitel

Objekt Variablen


Objekt Variablen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Variablenliste -> Objekt Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei den mit einem Fahrplan verknüpften Variablen, kann mittels der Schaltpunkte, der Sollwert verändert werden.

Parameter | Beschreibung
Kopieren | Kopiert die selektierten Variablen in die Zwischenablage.
Ausschneiden | Kopiert die selektierten Variablen in die Zwischenablage und markiert diese zum Löschen. Gelöscht werden die Variablen erst wenn diese bei einem anderen Fahrplan eingefügt werden. Schaltpunkte welche diese Variable verwenden, werden gelöscht.
Variable ersetzen | Ermöglicht, eine Variable gegen eine andere Variable zu tauschen. Wenn die neue Variable bereits beim Fahrplan vorhanden ist, wird die ursprüngliche Variable gelöscht. Alle Schaltpunkte, welche die ursprüngliche Variable verwenden, werden auf die neue Variable übertragen.
Variable entfernen | Entfernt die Zuordnung der Variable zum Fahrplan. Schaltpunkte welche diese Variable verwenden, werden gelöscht.
Berechtigungen | Aktiviert den Dialog für die Berechtigungen.
Hilfe | Aktiviert die Onlinehilfe.


Objekt Funktionen

Handbuch -> Production and Facility Scheduler (PFS) -> Objekttypen -> Objekt Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die mit dem Fahrplan verknüpften Funktionen können bei den Schaltpunkten zugeordnet und dadurch ausgeführt werden.

Parameter | Beschreibung
Kopieren | Kopiert die selektierten Funktionen in die Zwischenablage.
Ausschneiden | Die selektierten Funktionen werden in die Zwischenablage kopiert und zum Löschen vorgemerkt. Gelöscht werden die Funktionen erst wenn diese bei einem anderen Fahrplan eingefügt werden. Schaltpunkt welche diese Funktion verwenden, werden gelöscht.
Funktion ersetzen | Ermöglicht die selektierte Funktion auf eine andere Funktion zu tauschen. Alle Schaltpunkte welche die Quellenfunktion verwenden, werden auf die Zielfunktion umgeändert. Wenn die Zielfunktion bereits beim Fahrplan verknüpft ist, wird die Zuordnung der Quellfunktion gelöscht.
Funktion entfernen | Entfernt die Zuordnung der Funktion zum Fahrplan. Schaltpunkte welche diese Funktion verwenden werden gelöscht.
Berechtigungen | Aktiviert den Dialog mit den Berechtigungen.
Hilfe | Aktiviert die Onlinehilfe.


Eigenschaften

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Eigenschaften des Production & Facility Schedulers zu konfigurieren:

  • klicken Sie mit der rechten Maustaste auf Production & Facility Scheduler in der Detailansicht des Projektmanagers
  • wählen Sie im Kontextmenü Eigenschaften
  • wählen Sie die Registerkarte, die Sie bearbeiten möchten
    • Zeitumstellung: bietet Einstellungen für die Umschaltungen zwischen Sommer- und Winterzeit
    • Feiertage: konfiguriert Feiertage
    • Tabellenfarben: definiert Farben der Schaltpunkte
    • Schichtzeiten aufzeichnen: ermöglicht die Aufzeichnung von Schichtdaten

Noch in diesem Kapitel

Zeitumstellung

Feiertage

Tabellenfarben

Schichtzeiten aufzeichnen

Verknüpfung einer Anlagenmodellgruppe

Editierbare Zeitmodell-Gruppen

Editierbare Fahrpläne


Zeitumstellung

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Zeitumstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Seite wird das Verhalten bei Umstellung der Systemzeit (etwa Umstellung Sommerzeit-Winterzeit) festgelegt.

Mögliche Einstellungen sind:

Parameter | Beschreibung
Positive Zeitumstellung | Die Uhrzeit wird vorgestellt, die Systemzeit in die Zukunft gesetzt (z.B. Sommerzeit)
Schaltpunkte nachholen | Aktionen, die zwischen der aktuellen Zeit und der neu eingestellten Zeit liegen, werden sofort nach der Umstellung ausgeführt.
Schaltpunkte neu berechnen | Aktionen, die zwischen der aktuellen Zeit und der neu eingestellten Zeit liegen, werden übergangen und nicht ausgeführt. Die Schaltpunkt werden neu berechnet.
Negative Zeitumstellung | Die Uhrzeit wird zurückgestellt, die Systemzeit in die Vergangenheit gesetzt (z.B. Winterzeit)
Schaltpunkte verwerfen | Die Schaltpunkte werden nicht neu berechnet. Es werden erst wieder Schaltpunkte beim Erreichen der Ausgangszeit ausgeführt.
Schaltpunkte neu berechnen | Aktionen, die zwischen der aktuellen Zeit und der neu eingestellten Zeit liegen, werden neu berechnet (d. h. bei erneutem Erreichen der definierten Zeit wieder ausgeführt). Dies hat die doppelte Ausführung der Schaltpunkte im korrigierten Zeitraum zur Folge.
SB Umschaltung | Standby Server Umschaltung, gültig für die Timeout Zeit bei der Redundanzumstellung
Schaltpunkte verwerfen | Die Schaltpunktausführung beginnt entsprechend der aktuellen Position am Standby. Schaltpunkte im Umschaltungszeitraum werden eventuell nicht ausgeführt.
Schaltpunkte neu berechnen | Die Schaltpunkte werden von der aktuellen Zeit -30 Sekunden neu berechnet und ausgeführt. Dies kann eine doppelte Schaltpunktausführung zur Folge haben.
Toleranzbereich für Zeitabweichung | Toleranz, um welche sich die Systemzeit ändern darf, ohne eine Neuberechnung der Schaltpunkte nach oben beschriebenen Kriterien auszulösen.


Feiertage

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Feiertage

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Seite dient der Auswahl der landesbezogenen Feiertage.

Die Basis-Daten für die Feiertage befinden sich in der Datei Feiertage.txt im Ordner %programdata%\COPA-DATA\zenon[Version]. Sie kann mit einem Text-Editor bearbeitet werden.

Die Einträge für ein Land beginnen durch Benennung des Landes, eingeschlossen in eckigen Klammern, und anschließender Kennziffer wie in Microsoft Office verwendet. Die Definition der Feiertage erfolgt dann ab der nächsten Zeile, durch Angabe von Namen und Datum des Feiertages.

Zum Beispiel:

[Austria] 45

Allerheiligen,2006/11/1

Allerheiligen,2007/11/1

Allerheiligen,2008/11/1

Allerheiligen,2009/11/1

Allerheiligen,2010/11/1

Allerheiligen,2011/11/1

Allerheiligen,2012/11/1

Christi Himmelfahrt,2006/5/25

Christi Himmelfahrt,2007/5/17

Christi Himmelfahrt,2008/5/1

Christi Himmelfahrt,2009/5/21

Christi Himmelfahrt,2010/5/13

Christi Himmelfahrt,2011/6/2

Christi Himmelfahrt,2012/5/17

Mariä Himmelfahrt,2006/8/15

Mariä Himmelfahrt,2007/8/15

Mariä Himmelfahrt,2008/8/15

Mariä Himmelfahrt,2009/8/15

Mariä Himmelfahrt,2010/8/15

Mariä Himmelfahrt,2011/8/15

Mariä Himmelfahrt,2012/8/15

...


Tabellenfarben

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Tabellenfarben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier werden die Farben für die Darstellung der Schaltpunkte im Kalender definiert.

Folgende Einstellungen sind möglich:

Parameter | Beschreibung
Tage |
Default | Kalendertag ohne Besonderheiten
Sondertag | Datum ist ein Feiertag
Umstellung Sommerzeit -> Winterzeit | Datum der Sommer-Winterzeitumstellung
Umstellung Winterzeit -> Sommerzeit | Datum der Winter- Sommerzeitumstellung
Zeit Modelle |
Default | Zeitmodell für diesen Wochentag aktiv
Ausnahme | Zeitmodell nur an diesem Tag
Sondertag | Zeitmodell für Feiertage verwenden
Fahrpläne |
Default | Fahrplan ist an diesem Wochentag aktiv
Sondertag | Fahrplan ist an diesem Sondertag aktiv.
Auslassen | Fahrplan ist nur an diesen Tag nicht aktiv.
Einzeltag | Fahrplan ist nur an diesem Tag aktiv.
Mehrfacheintrag | Mehrere Eigenschaften treffen zu.


Schichtzeiten aufzeichnen

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Schichtzeiten aufzeichnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Production & Facility Scheduler können die Schichtdaten gespeichert und archiviert werden. Jede abgeschlossene Schicht wird dann in einer SQL-Datenbank gespeichert.

attention Achtung

Damit historische Schichtdaten in einer SQL-Datenbank gespeichert werden können, muss die entsprechende Zeitmodellgruppe mit einer Anlagenmodellgruppe verknüpft sein.

Die gespeicherten Daten können auch mit dem zenon Analyzer ausgewertet werden.

Um das Aufzeichnen von Schichtzeiten zu aktivieren:

  • klicken Sie mit der rechten Maustaste auf Production & Facility Scheduler in der Detailansicht des Projektmanagers
  • wählen Sie im Kontextmenü Eigenschaften
  • wählen Sie die Registerkarte Schichtzeiten aufzeichnen

  • aktivieren Sie die Eigenschaft Aufzeichnung aktivieren
  • wählen Sie die SQL-Datenbank, in der die Daten gespeichert werden sollen
  • der Tabellenname wird nach folgendem Muster erstellt: ProjektGUID_SCHICHT_GUID der Anlagengruppe
    Zum Beispiel: 292af0ac-d33d-4123-8484-e359cd0a6ae3_SHIFT_989ef705-d6a6-4b81-9eb5-f76483ecaac1
  • erstellen Sie eine Verknüpfung zwischen der Zeitmodellgruppe der Schicht und einer Anlagenmodellgruppe

    Hinweis: Werden mehrere Anlagenmodellgruppen verknüpft, werden historische Schichtdaten in entsprechend mehreren Tabellen gespeichert. Wird die Verknüpfung einer Anlagenmodellgruppe mit einer Zeitmodellgruppe geändert, dann wird eine neue Tabelle erstellt. Dabei werden keine Daten der bisherigen Tabelle übernommen. Die bisherige Tabelle wird auch nicht gelöscht.

Zur Runtime werden die Schichtdaten zyklisch kontrolliert und jene Schichten und Pausen in der Datenbank gespeichert, die seit der letzten Speicherung beendet wurden. Die Speicherung der Schichtdaten erfolgt immer am aktiven Server. Pausen werden nur gespeichert, wenn die Schicht beendet ist und gespeichert wird, denn Pausen enthalten die ID der Schicht.

Beim Starten der Runtime werden alle beendeten Schichten und Pausen in die Datenbank übertragen, die seit der letzten Speicherung aufgetreten sind, auch über einen Zeitraum von mehreren Tagen bzw. Wochen. Wird die Runtime am Standby-Server gestartet und die Runtime am Server läuft nicht oder kann nicht erreicht werden, dann befüllt auch der Standby-Server die Datenbank mit den Daten seit der letzten Speicherung.

Hinweis: Gilt nicht im Simulationsmodus.

Tabelle der Schichtaufzeichnung

Die Tabelle enthält folgende Spalten:

Spaltentitel | Typ | Inhalt
ID | int | Primärschlüssel.
REFERENCE | nvarchar(128) | Speichert GUID der Schichten und Pausen.
VISUALNAME | nvarchar(128) | Name der Schicht oder der Pause.
START | datetime | Startzeitpunkt der Schicht oder Pause in UTC. Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.
END | datetime | Endzeitpunkt der Schicht oder Pause in UTC. Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.
BREAK | boolean | TRUE, wenn es eine Pause ist.
PARENT_ID | int | Name der Schicht, wenn sie eine Pause bezeichnet.
SAVETIME | int | Zeitpunkt der Speicherung in die Datenbank.

Fehlermeldungen

Ist die Datenbank nicht erreichbar, wird im Diagnosis Server folgender Eintrag gesetzt:

Error when opening data connectionn in CFpmStorage::OpenDataConnection with HRESULT: 80040154

Noch in diesem Kapitel

Datenbank verknüpfen


Datenbank verknüpfen

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Schichtzeiten aufzeichnen -> Datenbank verknüpfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Dialog zur Verknüpfung einer Datenbank kommt vom Betriebssystem.

Wie die Datenbankverknüpfung in der Regel erfolgt, sehen Sie am folgenden Beispiel. Informationen zu den einzelnen Einstellungen erhalten Sie für jede Registerkarte beim Klick auf die Schaltfläche Hilfe über die Microsoft Hilfefunktion.

  1. der Dialog startet mit der Registerkarte Verbindung
  2. öffnen Sie die Registerkarte Allgemein

  3. wählen Sie den Provider Microsoft OLE DB Provider for SQL Server
  4. übernehmen Sie diesen per Doppelklick oder Klick auf die Schaltfläche Weiter
  5. die Registerkarte Verbindung wird geöffnet

  6. wählen Sie aus der Dropdownliste den Server
  7. wählen Sie die Anmeldeinformation, in der Regel die integrierte Sicherheit
  8. wählen Sie die Datenbank aus
    Tipp: die GUID des Projekts finden Sie in der Projekteigenschaft Projekt ID im Knoten Allgemeinn

    Interne ID: Datenbank verknüpfen

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Datenbank verknüpfen

    Projekt ID

    Jedes Projekt wird durch eine eindeutige GUID identifiziert. Diese Eigenschaft kann nicht geändert werden.
    Das ist auch der Name der Unterverzeichnisses im SQL-Verzeichnis, wo das Projekt gespeichert ist.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  9. klicken Sie auf Verbindung testen
    • optional können Sie in der Registerkarte Erweitert Netzwerkeinstellungen, Timeout und Zugriffsrechte konfigurieren (für diese Verbindung in der Regel nicht nötig)
    • optional können Sie in der Registerkarte Alle einzelne Details konfigurieren (für diese Verbindung in der Regel nicht nötig)
  10. bestätigen Sie mit KLick auf OK
  11. die Verbindung zum SQL Server wird eingetragen


Verknüpfung einer Anlagenmodellgruppe

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Verknüpfung einer Anlagenmodellgruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Anlagengruppen mit einer Zeitmodellgruppe zu verbinden:

  1. wählen Sie die Zeitmodell-Gruppe
  2. wählen Sie im Kontextmenü den Befehl Eigenschaften
  3. der Dialog für die Einstellungen des Zeitmodells wird geöffnet
  4. wählen Sie die Registerkarte Anlagenmodellierung

  5. wählen Sie die gewünschten Anlagengruppen aus
  6. fügen Sie diese über die Schaltfläche Hinzufügen ein
  7. bestätigen Sie mit OK, sobald alle gewünschten Anlagengruppen hinzugefügt wurden

Hinweis: Die Verknüpfung von Anlagenmodellgruppen mit einer Zeitmodellgruppe ist Voraussetzung für das Aufzeichnen von Schichtzeiten in einer SQL-Datenbank. Werden mehrere Anlagenmodellgruppen verknüpft, werden historische Schichtdaten in entsprechend mehreren Tabellen gespeichert. Wird die Verknüpfung einer Anlagenmodellgruppe mit einer Zeitmodellgruppe geändert, dann wird eine neue Tabelle mit der GUID der neuen Anlagenmodellgruppe erstellt. Dabei gilt:

  • Die Daten der bisherigen Tabelle werden nicht übernommen.
  • Die bisherige Tabelle wird nicht gelöscht.


Editierbare Zeitmodell-Gruppen

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Editierbare Zeitmodell-Gruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zeitmodell-Gruppen-Eigenschaften ermöglichen die Anpassung der Zeitmodell-Gruppenzykluszeit sowie Modellzuordnungen. Die Dialogbox wird über das Kontextmenü einer bestehenden Zeitmodell-Gruppe und den Befehl Eigenschaften... geöffnet.

Noch in diesem Kapitel

Zeitmodell-Gruppen Eigenschaften

Defaultzuordnung der Modelle


Zeitmodell-Gruppen Eigenschaften

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Editierbare Zeitmodell-Gruppen -> Zeitmodell-Gruppen Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Einstellungsseite beinhaltet die Benennung sowie den Zeitmodell-Gruppenzyklus.

Folgende Einstellmöglichkeiten sind vorgesehen:

Einstellung | Erklärung
Bezeichnung | Legt die Benennung der Zeitmodell-Gruppe fest. Dieses Feld darf nicht leer sein und die Bezeichnung muss PFS weit einmalig sein.
Tagesbeginn | Definiert den Tagesbeginn bei der Zeitmodell-Gruppe.
Tagesende | Definiert das Tagesende bei der Zeitmodell-Gruppe.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.


Defaultzuordnung der Modelle

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Editierbare Zeitmodell-Gruppen -> Defaultzuordnung der Modelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Einstellungsseite ermöglicht die Definition eines Defaultmodell zu jedem Wochentag sowie zu Feiertagen.


Editierbare Fahrpläne

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Editierbare Fahrpläne

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Einstellungsseiten ermöglichen die Konfiguration des Fahrplanes vorzunehmen und die Kalenderzuordnung durchzuführen. Die Dialogbox wird über das Kontextmenü eines bestehenden Fahrplans und dem Befehl Eigenschaften... geöffnet.

Noch in diesem Kapitel

Kontextmenü Uhrzeit

Kalenderbelegung


Kontextmenü Uhrzeit

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Editierbare Fahrpläne -> Kontextmenü Uhrzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Seite wird der Fahrplan konfiguriert und die zur Verfügung stehenden Variablen bzw. Funktionen zugeordnet.

Parameter | Beschreibung
Bezeichnung | Gibt den Namen des Fahrplans an. Der Name muss auf der gleichen Ebene eindeutig sein.
Fahrplan aktiv | Setzt den Fahrplan aktiv oder inaktiv. Die Schaltpunkte inaktiver Fahrpläne werden nicht ausgeführt.
Struktur Fahrplan | Ein Strukturfahrplan hat keine zugeordneten Funktionen und Variablen. Er dient nur zur Strukturierung der Fahrpläne.
Funktionsliste | Enthält die beim Fahrplan angemeldeten Funktionen. Die Bearbeitung erfolgt entsprechend dem Objekt Funktionen.e
Variablenliste | Enthält die beim Fahrplan angemeldeten Variablen. Die Bearbeitung erfolgt entsprechend dem Objekt Variablen.


Kalenderbelegung

Handbuch -> Production and Facility Scheduler (PFS) -> Eigenschaften -> Editierbare Fahrpläne -> Kalenderbelegung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Einstellungsseite kann die Wochentagszuordnung für den Fahrplan durchgeführt werden.

Kalenderbelegung

Aktiviert den Fahrplan am entsprechenden Wochentag. Siehe hierzu auch beim Kalender.


Dialoge

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

PFS Schaltpunktvorschau

PFS Filterdialog

Berechtigungen

Zyklisches erstellen von Schaltzeiten

Fahrplanauswahl

Fahrpläne Aktivierungszeitraum

Modellauswahl

Tabellenansicht Fahrplanbearbeitung

Tabellenansicht Modellbearbeitung

Zeit ändern

Offset anpassen

Wert ändern

Schaltpunkte erstellen

Duplizieren


PFS Schaltpunktvorschau

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> PFS Schaltpunktvorschau

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In die Schaltpunktvorschau des Production & Facility Schedulers gelangt man über das Kontextmenü.

Die Schaltpunktvorschau ist ein leistungsfähiges Diagnosewerkzeug, mit dem die Projektierung des PFS überprüft werden kann. Es wird hierbei, für die der Filterung entsprechenden, absoluten und relativen Schaltpunkte, die absolute Ausführungszeit ermittelt und dargestellt. Es kann somit untersucht werden, wie sich die gemachten Änderungen auswirken werden, bevor diese zur Anwendung kommen. Diese Vorschau kann auch für historische Zeiten angewendet werden. Die Ermittlung erfolgt jedoch immer aufgrund der aktuellen Projektierung.

Benutzerdefinierte Ereignisse können im Editor nicht aufgelöst werden. Zur Laufzeit werden die Triggerzeitpunkte der benutzerdefinierten Ereignisse maximal 14 Tage lang im Speicher gehalten und somit sind historische Ausführungszeiten nur für diesen Zeitraum rückverfolgbar.

Es besteht die Möglichkeit, die projektierten Objekte zu filtern, um z.B. nur einen speziellen Fahrplan zu untersuchen.

Bei Beenden mit OK werden die gemachten Einstellungen gespeichert und stehen beim nächsten Aufruf wieder zur Verfügung.

Suchmaske in Textfelder

Die Felder Zeitmodell-Gruppe, Fahrplan, Variable und Funktion unterstützen bei der Filterung Platzhalterzeichen:

Platzhalter | Bedeutung
Text | Benennung muss Text sein.
*Text | Benennung muss mit Text enden.
Text* | Benennung muss mit Text beginnen.
T??t | Benennung kann an der 2. und 3. Stelle beliebige Zeichen enthalten.

Eigenschaft

Beschreibung

Auswahl der Filter-Kriterien

Zeitmodell-Gruppe

Definiert den Filter für die zu berücksichtigenden Anlagen. Nur Schaltpunkte der entsprechenden Anlagen werden in die Vorschau aufgenommen.
ACHTUNG: Groß/Kleinschreibung wird beachtet!

Fahrplan

Definiert den Filter für die zu berücksichtigenden Fahrpläne. Nur Schaltpunkte der entsprechenden Fahrpläne werden in die Vorschau aufgenommen.
ACHTUNG: Groß/Kleinschreibung wird beachtet!

Variable

Definiert den Filter für die zu berücksichtigenden Variablen. Nur Schaltpunkte die mit entsprechenden Variablen verknüpft sind und der Maske entsprechen, werden aufgenommen.
ACHTUNG: Groß/Kleinschreibung wird beachtet!

Funktion

Definiert den Filter für die zu berücksichtigenden Funktionen. Nur Schaltpunkte die mit Funktionen verknüpft sind und der Maske entsprechen, werden aufgenommen.
ACHTUNG: Groß/Kleinschreibung wird beachtet!

Filtern der

Auswahl der Daten, die für die Erstellung der Vorschau verwendet werden, über Dropdownliste:

  • editierte Daten
    berücksichtigt die veränderten Daten zur Ermittlung der Vorschau. Dadurch wird es möglich, die Projektierung vor dem Speichern zu überprüfen.
  • gespeicherte Daten
    erstellt die Vorschau aufgrund der Projektierung, die für die Schaltpunktausführung verwendet wird.

Schaltpunkt-Kriterien

Hier wird der Zeitraum definiert, für den die Vorschau erstellt werden soll.

Vorschau

Beginnt die Ermittlung der Ausführungszeiten, entsprechend der gemachten Vorgabe.

Enthält die Tabelle mit den Schaltpunkten, die im gewünschten Zeitraum zur Ausführung kommen und den Filterkriterien entsprechen. Schaltpunkte, welche deaktiviert sind oder Schaltpunkte von Fahrplänen, welche deaktiviert sind, werden speziell hervorgehoben.


PFS Filterdialog

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> PFS Filterdialog

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem Filterdialog können die sichtbaren Objekte im PFS auf die dem Filter entsprechenden Objekte eingeschränkt werden.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Der Filter ermöglicht, für sämtliche Objekttypen eine Filtermaske vorzugeben. Bei aktiven Filter wird das Symbol des gefilterten Zweiges mit einem Trichter zur Kennzeichnung der Filterung versehen. Die Filterung unterscheidet Groß- Kleinschreibung.

Die Felder Zeitmodell-Gruppe, Fahrplan, Variable und Funktion unterstützen bei der Filterung Platzhalterzeichen:

Platzhalter | Bedeutung
Text | Benennung muss Text sein.
*Text | Benennung muss mit Text enden.
Text* | Benennung muss mit Text beginnen.
T??t | Benennung kann an der 2. und 3. Stelle beliebige Zeichen enthalten.

Wenn Kind-Objekte dem Filterkriterium entsprechen, so sind auch die Eltern-Objekte sichtbar, auch wenn diese nicht dem Filter entsprechen. Die Ausnahme von dieser Regel ist die Zeitmodell-Gruppe. Wenn der Zeitmodell-Gruppenfilter nicht entspricht, wird die gesamte Zeitmodell-Gruppe nicht angezeigt, auch wenn untergeordnete Objekt dem Filter entsprechen.


Berechtigungen

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Berechtigungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ermöglicht die Definition der Benutzerpasswortebene welche benötigt wird, um die entsprechenden Aktionen beim Objekt ausführen zu können. Wenn das Objekt eine Funktionalität nicht unterstützt, ist diese Einstellung gesperrt.

Wenn die Berechtigungen zur Laufzeit editiert werden, können diese nur auf Ebenen umkonfiguriert werden, auf welche der angemeldete Benutzer ebenfalls Rechte besitzt.

Berechtigungen werden nur zur Laufzeit ausgewertet.

Parameter | Beschreibung
Anzeigen | Ebene um das Objekt und alle seine untergeordneten Zweige anzuzeigen.
Erstellen | Ebene um das Erstellen von Unterobjekten zu ermöglichen bzw. zu sperren.
Ändern | Ebene um die Einstellungen oder Berechtigungen des Objekts zu ändern.
Umbenennen | Ebene welche das Umbenennen ermöglicht
Löschen | Ebene um das Objekt und alle seine Unterobjekte zu löschen.


Zyklisches erstellen von Schaltzeiten

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Zyklisches erstellen von Schaltzeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Dialog ermöglicht in einem Arbeitsgang mehrere, absolute Schaltzeiten mit einem definierten Zeitraum für einen konfigurierbaren Bereich zu erstellen.

Diese Dialogbox wird über das Kontextmenü der Tabellenansicht eines Fahrplans und dem Befehl Zeitraster erstellen geöffnet.

Parameter | Beschreibung
Zyklus / Uhrzeit | Definiert die Zeit oder den Erstellungsraster.
Als zyklische Zeit | Wenn aktiviert dann werden mehrere Schaltzeiten erstellt.
Passwortlevel | Wird derzeit nicht unterstützt. Sollte 0 sein.
Startzeit | Zeit mit der die Erstellung beginnt.
Endzeit | Zeit mit der die Erstellung endet.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.


Fahrplanauswahl

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Fahrplanauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Dialog werden die Fahrpläne, für welche eine Verknüpfung zum Tag erstellt werden soll, ausgewählt. Durch Selektion der gewünschten Fahrpläne und Hinzufügen werden diese in die Liste der verknüpften Fahrpläne übernommen.

Dieser Dialog wird über das Kontextmenü der Tagesansicht des Kalenders und dem Befehl Fahrpläne auswählen... geöffnet.


Fahrpläne Aktivierungszeitraum

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Fahrpläne Aktivierungszeitraum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Dialog ermöglicht es, die ausgewählten Fahrpläne für einen Zeitraum oder nach einem Muster im Kalender zur Ausführung einzutragen.

Um den Dialog zu öffnen:

  1. führen Sie in der Kalenderansicht einen Rechtsklick auf die Zeile oder Zelle mit Fahrplan aus
  2. wählen Sie im Kontextmenü Fahrpläne auswählen
  3. der Dialog zur Fahrplanauswahl wird geöffnet

  4. markieren Sie die gewünschten Fahrpläne und bestätigen Sie mit Klick auf OK
  5. der Dialog für Einstellung der Seriendauer wird geöffnet

Parameter

Beschreibung

Seriendauer

Einstellung für die Dauer der Serie.

Kein Enddatum

Ausführung beginnt mit Erstellung der Serie und hat kein Enddatum.(Default-Einstellung.)

Serie wird wöchentlich ausgeführt.

Beginnt am

Datum für Start.

Endet am

Datum für Ende.

Serienmuster

Art der Ausführung.

Detailfeld

Optionen für Serienmuster, abhängigi von der Wahl von:

  • Täglich
  • Wöchentlich
  • Monatlich
  • Jährlich

Täglich

Ausführung kann im Detailfeld eingestellt werden auf:

  • Alle [Zahl] Tage: Eingabe einer Zahl für Durchführungsrhythmus.
    Default: 1
  • Jeden Arbeitstag: Serie wird an jedem Arbeitstag (laut eingestelltem Feiertagskalender) ausgeführt.

Wöchentlich

Ausführung kann im Detailfeld auf bestimmte Wochentage eingestellt werden.

Monatlich

Ausführung kann im Detailfeld eingestellt werden auf:

  • am: Wahl des Datums
  • jeden Monats: Eingabe einer Zahl für Durchführungsrhythmus.

Jährlich

Ausführung kann im Detailfeld eingestellt werden auf ein bestimmtes Datum.

Ausgewählte Fahrpläne

Liste der ausgewählten Fahrpläne.

Auswahl

Klick auf Schaltfläche öffnet Dialog zur Fahrplanauswahl.

OK

Übernimmt Eingaben und schließt Dialog.

Abbrechen

Verwirft Eingaben und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Modellauswahl

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Modellauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Dialog ermöglicht die Zuordnung eines Modell pro Zeitmodell-Gruppe zum Tag.

  1. klicken Sie auf die Zelle Modelle in der Kalenderansicht

  2. wählen Sie im Kontextmenü Modelle auswählen
  3. wählen Sie das gewünschte Modell
  4. klicken Sie auf die Schaltfläche Hinzufügen
  5. bestätigen Sie den Dialog mit Klick auf OK


Tabellenansicht Fahrplanbearbeitung

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Tabellenansicht Fahrplanbearbeitung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rechtsklick auf einen Fahrplan in der Kalenderansicht öffnet das Kontextmenü. Der Befehl Fahrplan anzeigen öffnet den Dialog zur Konfiguration.

Diese Ansicht ermöglicht das Bearbeiten der im Kalender verknüpften Fahrpläne. Der Funktionsumfang entspricht jener der Tabelle Uhrzeit bzw. Schaltpunkt.


Tabellenansicht Modellbearbeitung

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Tabellenansicht Modellbearbeitung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rechtsklick auf ein Zeitmodell in der Kalenderansicht öffnet das Kontextmenü. Der Befehl Modell anzeigen öffnet den Dialog zur Konfiguration.

Diese Ansicht ermöglicht die Bearbeitung des im Kalender verknüpften Modell. Die Bearbeitungsmöglichkeiten entsprechen jener der Schichten und Pausen.


Zeit ändern

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Zeit ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit diesem Dialog können die selektierten Uhrzeiten um einen Offset verschoben werden.

Die Dialogbox wird mit dem Kontextmenü eines selektierten Zeiteintrags und dem Befehl Zeit ändern geöffnet.


Offset anpassen

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Offset anpassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ermöglicht, die selektierten Offsets zu verändern.

Die Dialogbox wird mit dem Kontextmenü eines selektierten Offsets und dem Befehl Offset anpassen geöffnet.


Wert ändern

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Wert ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ermöglicht die selektierten Zellen der Spalte Aktion zu ändern.

Die Dialogbox wird mit dem Kontextmenü eines selektierten Wertes und dem Befehl Wert ändern geöffnet.

Parameter

Beschreibung

Variable

Wert ändern um

Ändert den Inhalt der aktuell selektierten Zellen um den eingestellten Betrag.

Wert ändern auf

Ändert den Inhalt der aktuell selektierten Zellen auf den eingestellten Betrag.

Linear erhöhen beginnend bei

Ändert den Inhalt der aktuelle selektierten Zellen eingestellten Betrag. Der Betrag wird pro geänderte Zelle um eins erhöht.

Linear verringern beginnend bei

Ändert den Inhalt der aktuelle selektierten Zellen eingestellten Betrag. Der Betrag wird pro geänderte Zelle um eins verringert.

Funktion

Status ändern auf

Ändert die Aktivierung der selektierten Schaltpunkte auf den eingestellten Zustand:

  • aktiv
  • inakltiv

Makro

Makro ändern auf

Ändert Makro auf das ausgewählte Makro.


Schaltpunkte erstellen

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Schaltpunkte erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Dialogbox wird mit dem Kontextmenü eines selektierten Zeiteintrags und dem Befehl Schaltpunkte erstellen geöffnet.

Selektieren Sie in der oberen Liste jene Einträge, für welche Schaltpunkte erstellt werden sollen und übernehmen Sie diese durch Hinzufügen in die untere Liste.

info Info

Schaltpunkte werden in der Runtime aus Sicherheitsgründen per Default immer als inaktiv angelegt und müssen dezidiert aktiviert werden, damit sie funktionieren. Im Editor werden Schaltpunkt per Default als aktiv angelegt. .


Duplizieren

Handbuch -> Production and Facility Scheduler (PFS) -> Dialoge -> Duplizieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Dialog kann beim Kopieren eines Fahrplans aufgerufen werden, um zu steuern:

  • ob unterlagerte Kind-Fahrpläne beim Einfügen mit kopiert werden
  • ob beim Einfügen Variablen substituiert werden

Parameter | Beschreibung
nur den aktuellen Fahrplan duplizieren | Fügt nur den Fahrplan der obersten Ebene ein.
den aktuellen Fahrplan und die Kind-Fahrpläne duplizieren | Der Fahrplan wird mit allen seinen untergeordneten Fahrplänen eingefügt. Bei deaktiviertem Dialog ist dies die Standardvorgehensweise.
Substitute-Dialog einblenden | Blendet den Ersetzungsdialog ein. Dieser ermöglicht den Austausch von Variablen beim Einfügen.
Dialogfeld nur bei gedrückter Strg-Taste anzeigen | Unterdrückt den Dialog. Es werden immer der Fahrplan und alle Kind-Fahrpläne ohne Ersetzungen kopiert. Durch Drücken der Taste Strg beim Einfügevorgang kann die Dialoganzeige erzwungen werden. Hinweis: Diese Funktion kann auch über einen Eintrag in der project.ini gesteuert werden: [PFM] AnzeigenMitStrg = [Wert] Werte: 1: Der Dialog wird nur angezeigt, wenn beim Einfügen des Fahrplans die Taste Strg gedrückt wird. 0: Der Dialog wird immer angezeigt.
OK | Übernimmt Eingaben und schließt Dialog.
Abbrechen | Verwirft Eingaben und schließt Dialog.
Help | Öffnet Online-Hilfe.


Funktion PFS-Ereignis anstoßen

Handbuch -> Production and Facility Scheduler (PFS) -> Funktion PFS-Ereignis anstoßen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann im Onlinebetrieb ein definiertes PFS-Ereignis angestoßen werden, auf das sich relative Zeiten im PFS beziehen.


Bildumschaltung - PFS

Handbuch -> Production and Facility Scheduler (PFS) -> Bildumschaltung - PFS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Filter Baumansicht für Bildumschaltung

Filter Tabellenansicht für Bildumschaltung


Filter Baumansicht für Bildumschaltung

Handbuch -> Production and Facility Scheduler (PFS) -> Bildumschaltung - PFS -> Filter Baumansicht für Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Einstellmöglichkeiten entsprechen dem PFS Filterdialog. Als zusätzliche Option kann noch konfiguriert werden, ob der Filterdialog vor der Bildaktivierung aufgeschalten wird. Das in der Baumansicht selektiert Objekt wird bei Bildaufschaltung wieder selektiert.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.


Filter Tabellenansicht für Bildumschaltung

Handbuch -> Production and Facility Scheduler (PFS) -> Bildumschaltung - PFS -> Filter Tabellenansicht für Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Einstellungsseite ermöglicht, für die verschiedenen Tabellenansichten, die Spalten und Beschriftung dieser festzulegen.

Parameter | Beschreibung
Verfügbare Felder | Je nach Ansicht werden die möglichen Spalten in der Liste aufgeführt. Nur die aktivierten Spalten werden später auch dargestellt.
Beschriftung | Enthält die Überschrift der Tabelle. Dieser Text kann mittels @ als zu übersetzend gekennzeichnet werden.
Breite | Spaltenbreite
Ausrichtung | Ausrichtung der Spaltenüberschrift.
Objekte | Enthält die verschiedenen Objekte für welche die Ansichten konfiguriert werden können.
Gewünschte Ansicht | Enthält die möglichen Ansichten für das Objekt.


Bildtyp Production and Facility Scheduler

Handbuch -> Production and Facility Scheduler (PFS) -> Bildtyp Production and Facility Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung eines Bildes Production & Facility Scheduler lassen sich Fahrpläne und Profile verwalten.

Der Bildtyp steht nur dann zur Verfügung, wenn der PFS lizenziert wurde, sonst kann lediglich ein Bild des Typs Scheduler ausgewählt werden. (Nähere Informationen zu den vordefinierten Bildtypen finden Sie im 'Bilder / Vordefinierte Bildtypen'.)

Das Anlegen des PFS-Bildes im Editor erfolgt durch Definition eines neuen Bildes der Bildtyp Production & Facility Scheduler .

Nach dem Öffnen des Bildes wird ein leeres Bild aufgeschaltet und in der Menüzeile wird die Dropdownliste Kontrollelemente gefüllt.

Projektierbare Kontrollelemente sind:

Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Allgemein |
Speichern |
Verwerfen |
Schaltpunktvorschau |
Filter-Kriterien |
Auschneiden |
Kopieren ... |
Einfügen ... |
Umbenennen |
Löschen |
Eigenschaften ... |
Einstellungen ... |
Aufsteigend |
Absteigend |
Listen |
Fahrplan-Fenster |
Buttons |
Zeitmodell-Gruppe | - Zeitmodell-Gruppe erstellen
Fahrplan | - Fahrplan erstellen ... - Fahrplan aktivieren - Variable hinzufügen ... - Variable entfernen - Funktion entfernen - Verknüpfungen ersetzen ... - Zeitraster erstellen ... - Uhrzeit erstellen ... - Schaltpunkt erstellen - Schaltpunkte erstellen ... - Uhrzeit löschen - Schaltpunkte löschen
Zeitmodell | - Zeitmodell erstellen ... - Schicht erstellen - Pause erstellen - Schicht löschen - Pause löschen
Ereignis | - Ereignis erstellen
Kalender | - Modelle auswählen ... - Fahrpläne auswählen ... - Diesen Tag anzeigen - Zu Heute wechseln - Wechseln zu Datum ... - Als Default - Als Einzeltag - Vorwärts - Rückwärts - Tagesansicht - Wochenansicht - Monatsansicht
Massenbearbeitung | - Alle Werte aktiv - Alle Werte inaktiv - Absolute Zeit - Relative Zeit - Zeit ändern ... - Wert ändern ... - Ereignis auswählen ... - Offset anpassen ...

Mit der Betätigung des Menüpunktes Vorlage einfügen im Menü Kontrollelemente werden vordefinierte Kontrollelemente mit Standardwerten auf vordefinierte Positionen geladen.

Nähere Informationen zu geänderten Runtime-Dateien finden Sie im Kapitel Projekt und Arbeitsbereich / RT änderbare Dateien.


Programmierschnittstellen

Handbuch -> Programmierschnittstellen

In zenon stehen verschiedene Schnittstellen zur Einbindung eigener Programme oder zur Automatisierung der Projektierung zur Verfügung:

  • Process Control Engine (PCE)
  • VBA
  • VSTA

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü

Menüpunkt | Aktion
PCE-Editor öffnen | Öffnet den PCE-Editor
VBA-Editor öffnen | Öffnet den VBA-Editor
VSTA-Editor öffnen | Öffnet den VSTA-Editor.
Editorprofil | Öffnet die Dropdownliste zur Auswahl eines Editorprofils.
Hilfe | Öffnet die Online-Hilfe.

info Info

Informationen zur Erstellung und Implementierung von Controls (ActiveX, .NET, WPF) finden Sie im Handbuch Controls.

VBA- und VSTA-Editor öffnen

VBA-Editor

VBA startet für Arbeitsplatz und Projekt die gleiche Entwicklungsumgebung. Um den VBA Editor zu öffnen:

  1. navigieren Sie zum Knoten Programmierschnittstellen
  2. führen Sie einen Rechtsklick auf VBA-Makros aus
  3. wählen Sie im Kontextmenü VBA-Editor öffnen...

Alternative: drücken Sie die Tastenkombination Alt+F11

VSTA-Editor

VSTA stellt für Arbeitsplatz und Projekt getrennte Entwicklungsumgebungen zur Verfügung. Es kann jeweils nur eine von beiden genutzt wird. Beim Start wird jede andere bereits geöffnete VSTA Entwicklungsumgebung geschlossen.

Um den VSTA-Editor für den Arbeitsbereich zu öffnen:

  1. drücken Sie die Tastenkombination Alt+F10
  2. der Code für den Arbeitsbereich und alle geladenen Projekte wird angezeigt

Um den VSTA-Editor für das aktuell geladene Projekt zu öffnen:

  1. navigieren Sie zum Knoten Programmierschnittstellen
  2. führen Sie einen Rechtsklick auf VSTA
  3. wählen Sie im Kontextmenü VSTA-Editor öffnen...
  4. der Editor wird für das aktuell geladene Projekt geöffnet

Noch in diesem Kapitel

Process Control Engine (PCE)

VBA

VSTA

Object Model


Process Control Engine (PCE)

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

info Info

Die Process Control Engine (PCE) bietet die Möglichkeit zyklische Abläufe in VB Script oder Java Script zu programmieren (übergesetzte Leitfunktionen). Die PCE eignet sich besonders für lang andauernde Funktionen, die im Hintergrund ablaufen (z.B. aufwändige Export-Funktionen). Im Gegensatz zu VBA unterstützt die PCE Multithreading.

Noch in diesem Kapitel

Der PCE Editor

Vorgangsweise

VBScript - Einführung


Der PCE Editor

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die PCE befindet sich im Projektmanager unter dem Eintrag Skripting. Der PCE Editor wird über das Kontextmenü PCE Editor öffnen geöffnet.

Noch in diesem Kapitel

Der Taskmanager

Der Editierbereich

Das Ausgabefenster

Die Menüs des PCE Editors

Die Symbolleiste des PCE Editors


Der Taskmanager

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Der Taskmanager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Taskmanager des PCE Editors zeigt die angelegten Tasks und die damit verbundenen Variablen an.

Ein Doppelklick auf einen Task öffnet diesen im Editierbereich. Mit der rechten Maustaste lässt sich das Kontextmenü eines Tasks öffnen.

Das Kontextmenü eines Tasks bietet vier Einträge:

Parameter | Beschreibung
Task-Eigenschaften... | Öffnet den Eigenschaften-Dialog des Tasks.
Task Variablen... | Öffnet den Variablenauswahl-Dialog. So können weitere Variablen zum Task hinzugefügt werden.
Task entfernen | Löscht den Task ohne weitere Abfrage.
Task kompilieren | Kompiliert den Task.


Der Editierbereich

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Der Editierbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Editierbereich des PCE Editors wird der Code für die Tasks in VB Script oder Javascript eingegeben.


Das Ausgabefenster

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Das Ausgabefenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com


Die Menüs des PCE Editors

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Menüs des PCE Editors

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Menü Datei

Menü Bearbeiten

Menü Ausführen

Menü Ansicht

Menü Fenster

Menü Hilfe


Menü Datei

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Menüs des PCE Editors -> Menü Datei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Menü Datei beinhaltet folgende Befehle:

Parameter | Beschreibung
Speichern | Speichert neue bzw. geänderte Tasks.
Drucken | Druckt den aktiven Task.
Schließen | Schließt den PCE Editor.


Menü Bearbeiten

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Menüs des PCE Editors -> Menü Bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Menü Bearbeiten beinhaltet folgende Befehle:

Parameter | Beschreibung
Rückgängig | Macht die zuletzt ausgeführte Aktion rückgängig.
Wiederholen | Wiederholt die zuletzt ausgeführte Aktion.
Ausschneiden | Verschiebt einen Text in die Windows-Zwischenablage.
Kopieren | Kopiert einen Text in die Windows-Zwischenablage.
Einfügen | Fügt einen Text aus der Windows-Zwischenablage ein.
Löschen |
Alles auswählen | Markiert den gesamten Text im Task.
Suchen | Sucht einen Text im geöffneten Task.
Nächsten suchen | Geht zur nächsten Fundstelle im Task.
Vorherigen suchen | Geht zur vorherigen Fundstelle im Task.
Ersetzen... | Ersetzt einen Text im Task durch einen anderen.
Bookmarks | Verwaltung von Lesezeichen im Code des Tasks.
- setze Bookmark | Setzt im Code an der markierten Stelle ein Lesezeichen.
- nächste Bookmark | Springt im Code zum nächsten Lesezeichen.
- vorherige Bookmark | Springt im Code zum vorherigen Lesezeichen.
- lösche alle Bookmarks | Löscht alle Lesezeichen aus dem Code.


Menü Ausführen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Menüs des PCE Editors -> Menü Ausführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Menü Ausführen beinhaltet folgende Befehle:

Alle Tasks speichern u. neustarten |
Task kompilieren | Kompiliert den Task.


Menü Ansicht

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Menüs des PCE Editors -> Menü Ansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Menü Ansicht beinhaltet folgende Befehle:

Parameter | Beschreibung
Einstellungen | Öffnet den Einstellungen-Dialog des PCE Editors.
Taskmanager | Öffnet/schließt das Taskmanagerfenster.
Ausgabefenster | Öffnet/schließt das Ausgabefenster.
Status Bar | Öffnet/schließt die Statusleiste.


Menü Fenster

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Menüs des PCE Editors -> Menü Fenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Menü Fenster beinhaltet folgende Befehle:

Schließen

Anordnen

Teilen

Symbole anordnen

Liste der geöffneten Fenster


Menü Hilfe

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Menüs des PCE Editors -> Menü Hilfe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Menü Hilfe beinhaltet folgende Befehle:

Befehl

Aktion

Hilfe

Öffnet die Online-Hilfe.

Info über...

Öffnet ein Fenster mit Informationen über zenon:

  • Seriennummer
  • Aktivierungsnummer
  • lizenzierte Tags/IOs
  • lizenzierte Module

Im Info-Fenster kann über einen Schieberegler navigiert werden. Klick in das Fenster oder Druck auf die Taste Esc schließt das Info-Fenster.


Die Symbolleiste des PCE Editors

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Der PCE Editor -> Die Symbolleiste des PCE Editors

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die wichtigsten Befehle des PCE Editors lassen sich auch über die Icons in der Symbolleiste ausführen.

Folgende Icons stehen zur Verfügung:

Parameter | Beschreibung
Schließen | Schließt den PCE Editor.
Alles speichern | Speichert neue bzw. geänderte Tasks.
Aktives Fenster drucken | Druckt den aktiven Task.
Ausschneiden | Verschiebt einen Text in die Windows-Zwischenablage.
Kopieren | Kopiert einen Text in die Windows-Zwischenablage.
Einfügen | Fügt einen Text aus der Windows-Zwischenablage ein.
Rückgängig | Macht die zuletzt ausgeführte Aktion rückgängig.
Wiederholen | Wiederholt die zuzletzt ausgeführte Aktion.
Suchen | Sucht einen Text im geöffneten Task.
Nächsten suchen | Geht zur nächsten Fundstelle im Task.
Vorherigen suchen | Geht zur vorherigen Fundstelle im Task.
Ersetzen... | Ersetzt einen Text im Task durch einen anderen.
Alle Tasks speichern und neustarten |
Debugger starten |
Nächste Bookmark | Springt im Code zum nächsten Lesezeichen.
Setze Bookmark | Setzt im Code an der markierten Stelle ein Lesezeichen.
Vorherige Bookmark | Springt im Code zum vorherigen Lesezeichen.
Lösche alle Bookmarks | Löscht alle Lesezeichen aus dem Code.


Vorgangsweise

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Erstellen eines Tasks

Eingabe des Codes

Funktion PCE anzeigen

Ausführen von Tasks


Erstellen eines Tasks

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Erstellen eines Tasks

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über das Kontextmenü des Taskmanagers kann ein neuer Task erstellt werden.

Noch in diesem Kapitel

Eigenschaften des Tasks

Variablen des Tasks


Eigenschaften des Tasks

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Erstellen eines Tasks -> Eigenschaften des Tasks

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach dem Anlegen des Tasks öffnet sich automatisch der Eigenschaften-Dialog des Tasks.

Folgende Eigenschaften können eingestellt werden:

Parameter | Beschreibung
Name | Eindeutige Bezeichnung des Tasks.
Typ | Tasks können zyklisch oder einmalig ausgeführt werden. Zyklisch : der Task wird zyklisch in dem unter Zuerreichende Zykluszeit angegebenen Intervall ausgeführt. Einmalig : der Task wird ein einziges Mal ausgeführt.
Priorität | Prozesspriorität für das Betriebssystem-Multithreading ( Leerlauf , Niedrig , Normal , Hoch , Höchste , Zeitkritisch ). Default: Normal Hauptprozess : der Task läuft im gleichen Thread wie die Runtime. Wenn der Task in eine Warteschleife gerät oder gar abstürzt, beeinflusst das auch die Runtime.
Scriptdatei | Auswahl der Scriptdatei: VB-Dateien (*.vbs) für VB Script oder JS-Dateien (*.js) für Javascript. Beim erstmaligen Öffnen des Tasks im Editierbereich wird die entsprechende Datei angelegt.
Startart | System start : der Task wird automatisch mit der Runtime gestartet. (Dies ist die einzige Möglichkeit, wie die PCE unter Windows CE verwendet werden kann, da Windows CE kein VBA unterstützt.) Ereignisgesteuert : der Task wird über ein VBA-Makro und die Anweisung thisProject.Tasks.Item(Taskname).Run gestartet.
Zu erreichende Zykluszeit | Bei zyklischen Tasks die Zykluszeit in Millisekunden, die erreicht werden soll. Wird diese Zykluszeit nicht erreicht, so wird der Task so schnell wie möglich ausgeführt.

Zum nachträglichen Ändern der Eigenschaften lässt sich der Dialog auch über das Kontextmenü des Tasks und den Befehl Task-Eigenschaften... öffnen.


Variablen des Tasks

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Erstellen eines Tasks -> Variablen des Tasks

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach der Eingabe der Eigenschaften öffnet sich automatisch der Variablenauswahl-Dialog. Hier werden die Variablen ausgewählt, die im Task verarbeitet werden sollen.

Es sollten hier alle Variablen verknüpft werden, die im Task gelesen oder geschrieben werden sollen. Es besteht zwar auch die Möglichkeit über das Variablen-Objekt auf Variablen zuzugreifen, aber nur die direkt mit dem Task verknüpften Variablen werden automatisch beim Initialisieren des Tasks vor der Ausführung eingelesen.

Die Variablen müssen die folgende Syntax haben:

Task.Value("Variablenname")=123

Zum nachträglichen Ändern der Variablenauswahl lässt sich der Dialog auch über das Kontextmenü des Tasks und den Befehl Task Variablen... öffnen.


Eingabe des Codes

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Eingabe des Codes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Durch einen Doppelklick auf einen Task im Taskmanager wird der Task im Editierbereich geöffnet. Wird der Task das erste Mal geöffnet, so wird nun die entsprechende VBS- bzw. JS-Datei angelegt.

Vier Prozeduren werden automatisch angelegt:

Parameter | Beschreibung
Task_Init() | Diese Prozedur wird automatisch beim Starten des Tasks ausgeführt.
Task_Main() | Diese Prozedur wird entweder einmal (Typ einmalig) oder zyklisch (Typ zyklisch) ausgeführt.
Task_Exit() | Diese Prozedur wird automatisch vor dem Beenden des Tasks ausgeführt.
Task_Timer(lTimerId) | Diese Prozedur wird, solange der entsprechende Timer läuft, zyklisch ausgeführt. Die Zykluszeit wird mit dem Starten des entsprechenden Timers als Parameter übergeben.

Die PCE verwendet grundsätzlich dasselbe Objekt-Modell wie VBA (siehe VBA Tutorials). Bei der Verwendung von VBA Objekten (ausser dem Objekt Task) geht allerdings die Multithreading-Fähigkeit verloren, da auf diese Objekte nur aus dem Hauptthread heraus zugegriffen werden kann.

attention Achtung

Nicht alle Funktionen des COM Interfaces sind Multithreadingfähig und dürfen daher nur im Hauptthread Kontext verwendet werden. Diese bedeudet, wenn im PCE Task eine andere Eigenschaft als Im Hauptprozess eingestellt ist, dann darf aus der PCE kein Zugriff auf den Hauptthread erfolgen. Erfolgt trotzdem ein Zugriff auf das COM Interface, kann es zu undefinierten Systemzuständen wie einem einfrieren der Runtime kommen.

Von besonderer Wichtigkeit ist allerdings die Collection Tasks und das Objekt Task.

Noch in diesem Kapitel

Die Collection Tasks

Das Objekt Task


Die Collection Tasks

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Eingabe des Codes -> Die Collection Tasks

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Count

Item

Parent


Das Objekt Task

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Eingabe des Codes -> Das Objekt Task

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

ActualCycleTime

Eigenschaft

Tatsächlich erreichte Zykluszeit des Tasks

CountVariable

Eigenschaft

Anzahl der mit dem Task verknüpften Variablen

CycleTime

Eigenschaft

Eingestellte Zykluszeit des Tasks

DynProperties

Eigenschaft

ErrorNumber

Eigenschaft

ErrorString

Eigenschaft

Exit

Ereignis

Init

Ereignis

ItemVariable

Methode

Main

Ereignis

MemValue

Eigenschaft

Mit Task.MemValue(Name)=Wert wird eine interne Variable angelegt und ein Wert wird ihr zugewiesen. Die Variable muss vorher nicht deklariert werden.

Diese Variable kann auch von anderen Tasks aus gelesen werden. Somit erlaubt sie die Übergabe eines Wertes von einem Task an einen anderen.

Name

Eigenschaft

Name des aktuellen Tasks

Parent

Eigenschaft

Die Collection Tasks

Priority

Eigenschaft

Priorität des aktuellen Tasks

Run

Methode

Startet einen Task

Sleep

Methode

Hält einen Task an

StartTimer

Methode

Die Methode StartTimer startet einen Timer des Tasks.

Status

Eigenschaft

Stop

Methode

Stoppt einen Task

StopTimer

Methode

Die Methode StopTimer stoppt einen Timer des Tasks.

Timer

Ereignis

Type

Eigenschaft

Value

Eigenschaft

Mit Task.Value(Name einer verknüpften Variable)=Wert kann aus einem Task einer Variable des zugehörigen Projekts ein Wert zugewiesen werden.


Funktion PCE anzeigen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Funktion PCE anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die zenon Funktion PCE anzeigen kann der PCE Editor aus der Runtime geöffnet werden.


Ausführen von Tasks

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Ausführen von Tasks

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Tasks mit Systemstart ausführen

Tasks ereignisgesteuert ausführen


Tasks mit Systemstart ausführen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Ausführen von Tasks -> Tasks mit Systemstart ausführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn in der Konfiguration des Tasks die Startart auf System start gesetzt wurde, wird der Task automatisch mit dem Starten der Runtime gestartet.

Dies ist die einzige Möglichkeit, wie die PCE unter Windows CE verwendet werden kann, da Windows CE kein VBA unterstützt.


Tasks ereignisgesteuert ausführen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Ausführen von Tasks -> Tasks ereignisgesteuert ausführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Am PC

Am CE Terminal


Am PC

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Ausführen von Tasks -> Tasks ereignisgesteuert ausführen -> Am PC

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Am PC

Ein Task kann auch ereignisgesteuert gestartet werden. In diesem Fall muss die Startart auf ereignisgesteuert gesetzt werden. Nun wird der Task nicht mehr automatisch mit der Runtime gestartet.

Um den Task durch das Drücken eines Buttons, durch eine Grenzwertverletzung oder durch ein anderes Ereignis starten zu können muss ein VBA-Makro erstellt werden. Die VBA Anweisung zum Starten des Tasks lautet:

thisProject.Tasks.Item(Taskname).Run

Der Task wird automatisch in einem eigenen Thread gestartet, wenn in der Konfiguration nicht die Priorität Hauptprozess angegeben wurde.

Mit der folgenden VBA Anweisung kann der Task jederzeit wieder beendet werden:

thisProject.Tasks.Item(Taskname).Stop


Am CE Terminal

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> Vorgangsweise -> Ausführen von Tasks -> Tasks ereignisgesteuert ausführen -> Am CE Terminal

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Am CE Terminal

Da Windows CE kein VBA unterstützt, ist die obige Vorgehensweise auf einem CE Terminal nicht möglich. Es gibt jedoch eine Möglichkeit auch hier Tasks ereignisgesteuert aufzurufen.

Dazu wird ein Task mit der Startart System start erstellt. Dieser Task wird also automatisch mit der Runtime gestartet. Zudem erhält dieser Task die Priorität Hauptprozess, sodass er im selben Thread wie die Runtime läuft. Mit diesem Task werden nun Bit-Variablen verknüpft, die das ereignisgesteuerte Ausführen der anderen Tasks übernehmen. Die Anweisung zum Starten eines anderen Tasks lautet:

Parent.Item(Taskname).Run

Dieser Task wird nun automatisch in einem eigenen Thread gestartet, wenn in der Konfiguration nicht die Priorität Hauptprozess anegeben wurde.

Mit der folgenden Anweisung kann der Task jederzeit wieder beendet werden:

Parent.Item(Taskname).Stop


VBScript - Einführung

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Datentypen

Variablen

Konstanten

Operatoren

Steuern der Programmausführung

Verwenden von Schleifen zum Wiederholen von Code

Arten von Prozeduren

Konventionen für die Programmierung


Datentypen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Variant

Untertypen des Datentyps Variant


Variant

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Datentypen -> Variant

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VBScript kennt nur einen Datentyp namens Variant. Variant ist eine besondere Art von Datentyp, der je nach Verwendung verschiedene Arten von Informationen aufnehmen kann. Weil Variant der einzige Datentyp in VBScript ist, geben alle Funktionen in VBScript diesen Datentyp zurück.

Im einfachsten Fall kann Variant numerische Werte oder Zeichenfolgen enthalten. Ein Variant verhält sich wie eine Zahl, wenn Sie ihn in einem numerischen Zusammenhang verwenden, und wie eine Zeichenfolge, wenn Sie ihn wie eine Zeichenfolge verwenden. Wenn Sie also mit Daten arbeiten, die wie Zahlen aussehen, interpretiert VBScript diese als Zahlen und verfährt entsprechend. Natürlich können Sie immer dafür sorgen, dass sich Zahlen wie Zeichenfolgen verhalten, indem Sie diese in Anführungszeichen ( ) einschließen. Wenn Sie mit Daten arbeiten, die nur als Zeichenfolgen interpretiert werden können, behandelt VBScript diese als Zeichenfolgen.


Untertypen des Datentyps Variant

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Datentypen -> Untertypen des Datentyps Variant

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die einfache Einteilung in numerische Werte und Zeichenfolgen hinaus kann bei Variant-Werten zwischen weiteren Arten von numerischen Informationen unterschieden werden. Numerische Informationen können beispielsweise ein Datum oder eine Uhrzeit darstellen. In Verbindung mit anderen Datums- oder Uhrzeitinformationen wird das Ergebnis immer als Datum oder Uhrzeit ausgedrückt. Natürlich stehen auch viele verschiedene Arten numerischer Informationen zur Verfügung, angefangen von booleschen Werten bis hin zu großen Fließkommazahlen. Diese unterschiedlichen Informationskategorien, die ein Variant aufnehmen kann, werden als Untertypen bezeichnet. Meistens genügt es, einem Variant einfach die gewünschten Daten zuzuweisen, damit er sich entsprechend verhält.

Die folgende Tabelle zeigt die verschiedenen Untertypen von Daten, die ein Variant enthalten kann.

Untertyp | Bedeutung
Empty | Variant ist nicht initialisiert. Der Wert ist 0 bei numerischen Variablen und eine Null-Zeichenfolge () bei Zeichenfolgenvariablen.
Null | Variant enthält absichtlich keine gültigen Daten.
Boolean | Enthält entweder TRUE oder FALSE.
Byte | Enthält eine ganze Zahl von 0 bis 255.
Integer | Enthält eine ganze Zahl von -32.768 bis 32.767.
Currency | -922,337,203,685,477.5808 bis 922,337,203,685,477.5807.
Long | Enthält eine ganze Zahl von -2.147.483.648 bis 2.147.483.647.
Single | Enthält eine Fließkommazahl einfacher Genauigkeit von -3,402823E38 bis -1,401298E-45 für negative Werte und von 1,401298E-45 bis 3,402823E38 für positive Werte.
Double | Enthält eine Fließkommazahl doppelter Genauigkeit von -1,79769313486232E308 bis -4,94065645841247E-324 für negative Werte und von 4,94065645841247E-324 bis 1.79769313486232E308 für positive Werte.
Date (Time) | Enthält eine Zahl, die ein Datum vom 1. Januar 100 bis zum 31. Dezember 9999 darstellt.
String | Enthält eine Zeichenfolge variabler Länge, die bis zu etwa 2 Milliarden Zeichen lang sein kann.
Object | Enthält ein Objekt.
Error | Enthält eine Fehlernummer.


Variablen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Variable ist ein praktischer Platzhalter, der auf eine Stelle im Speicher des Computers verweist, an der Sie Programmdaten speichern können, die sich während der Ausführung des Skripts ändern kann. Sie können beispielsweise eine Variable namens KlickZaehler einrichten, um zu speichern, wie oft ein Benutzer auf ein Objekt in einer bestimmten Web-Seite klickt. Es ist unwichtig, wo sich die Variable im Computerspeicher befindet. Wichtig ist, dass Sie nur ihren Namen angeben müssen, um den Wert der Variablen abzurufen oder zu ändern. In VBScript haben Variablen immer den grundlegenden Datentyp Variant.

Noch in diesem Kapitel

Deklarieren von Variablen

Einschränkungen für Namen

Gültigkeitsbereich und Lebensdauer von Variablen

Zuweisen von Werten zu Variablen

Skalare Daten und Datenfelder


Deklarieren von Variablen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Variablen -> Deklarieren von Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie deklarieren Variablen in Ihrem Skript explizit mit den Anweisungen Dim, Public und Private. Beispiel:

Dim GradFahrenheit

Sie deklarieren mehrere Variablen, indem Sie diese jeweils durch Kommas voneinander trennen. Beispiel:

Dim Oben, Unten, Links, Rechts


Einschränkungen für Namen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Variablen -> Einschränkungen für Namen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für Variablennamen gelten die Standardregeln zum Benennen von Sprachelementen in VBScript. Für Variablennamen gilt:

  • Sie müssen mit einem Zeichen aus dem Alphabet beginnen.
  • Sie dürfen keinen Punkt enthalten.
  • Sie dürfen nicht länger als 255 Zeichen sein.
  • Sie müssen innerhalb des Gültigkeitsbereichs, für den sie deklariert werden, eindeutig sein.


Gültigkeitsbereich und Lebensdauer von Variablen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Variablen -> Gültigkeitsbereich und Lebensdauer von Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie eine Variable in einer Prozedur deklarieren, kann normalerweise nur Code innerhalb dieser Prozedur auf den Variablenwert zugreifen oder ihn ändern, d.h. die Variable hat einen lokalen Gültigkeitsbereich und wird als Variable auf Prozedurebene bezeichnet.

Wenn Sie eine Variable außerhalb einer Prozedur deklarieren, ist sie für alle Prozeduren in Ihrem Skript sichtbar. Diese Art von Variable auf Skriptebene hat die Skriptebene als Gültigkeitsbereich.

Die Zeitspanne, in der eine Variable existiert, wird als ihre Lebensdauer bezeichnet. Die Lebensdauer einer Variablen auf Skriptebene reicht vom Zeitpunkt der Deklaration bis zur Beendigung des Skripts. Die Lebensdauer einer lokalen Variablen beginnt mit der Deklarationsanweisung am Anfang der Prozedur und endet mit Beendigung der Prozedur.

Lokale Variablen eignen sich gut als temporärer Speicherplatz während der Ausführung einer Prozedur. Sie können lokale Variablen mit demselben Namen in mehreren Prozeduren verwenden, da jede nur von der Prozedur erkannt wird, in der sie deklariert wurde.


Zuweisen von Werten zu Variablen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Variablen -> Zuweisen von Werten zu Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Werte werden einer Variablen durch einen Ausdruck zugewiesen, bei dem die Variable auf der linken Seite des Ausdrucks und der zuzuweisende Wert auf der rechten Seite des Ausdrucks steht. Beispiel:

B = 200


Skalare Daten und Datenfelder

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Variablen -> Skalare Daten und Datenfelder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Meistens weisen Sie einer deklarierten Variablen nur einen einzelnen Wert zu. Solche Variablen werden skalare Variablen genannt. In anderen Fällen ist es sinnvoll, einer Variablen mehrere zusammenhängende Werte zuzuweisen. In diesen Fällen können Sie eine Variable erstellen, die eine Folge von Werten enthalten kann. Solche Variablen nennt man Datenfeldvariablen. Datenfeldvariablen werden fast genauso deklariert wie skalare Variablen. Der einzige Unterschied besteht darin, dass bei der Deklaration von Datenfeldvariablen auf den Namen Klammern folgen. Im folgenden Beispiel wird ein eindimensionales Datenfeld mit 11 Elementen deklariert:

Dim A(10)

Obwohl in Klammern die Zahl 10 angegeben wird, enthält dieses Datenfeld 11 Elemente, weil alle Datenfelder in VBScript nullbasiert sind, d.h. mit dem Index Null beginnen. In einem nullbasierten Datenfeld ist die Anzahl der Elemente immer um Eins höher als der in Klammern angegebene Wert. Diese Art von Datenfeld nennt man Datenfeld fester Größe.

Zur Zuweisung von Daten an die Elemente des Datenfelds verwenden Sie einen Index im Datenfeld. Mit Indizes von Null bis 10 können den Elementen eines Datenfelds auf folgende Weise Werte zugewiesen werden:

A(0) = 256

A(1) = 324

A(2) = 100

. . .

A(10) = 55

Auf ähnliche Weise (mit einem Index im Datenfeld) kann der Wert eines beliebigen Datenfeldelements wieder abgerufen werden. Beispiel:

. . .

EineVariable = A(8)

. . .

Datenfelder sind nicht auf eine einzige Dimension beschränkt. Sie können bis zu 60 Dimensionen angeben, obwohl sich die meisten Menschen nur drei oder vier Dimensionen vorstellen können. Mehrere Dimensionen werden durch Angabe von mehreren Datenfeldgrößen zwischen den Klammern deklariert und jeweils durch ein Komma voneinander getrennt. Im folgenden Beispiel ist die Variable Tabelle1 ein zweidimensionales Datenfeld mit 6 Zeilen und 11 Spalten:

Dim Tabelle1(5, 10)

In einem zweidimensionalen Datenfeld gibt die erste Zahl immer die Anzahl der Zeilen und die zweite Zahl die Anzahl der Spalten an.

Sie können auch Datenfelder deklarieren, deren Größe sich während des Ablaufs Ihres Skripts ändern kann. Solche Datenfelder werden als dynamische Datenfelder bezeichnet. Das Datenfeld wird in einer Prozedur anfänglich mit einer Dim -Anweisung (wie jedes andere Datenfeld auch) oder mit einer ReDim -Anweisung deklariert. Der Unterschied besteht darin, dass zwischen den Klammern keine Größe oder Anzahl von Dimensionen angegeben wird. Beispiel:

(Dim EinDatenfeld()

ReDim AnderesDatenfeld)

Um ein dynamisches Datenfeld verwenden zu können, müssen Sie anschließend die Zahl der Dimensionen und deren Größen mit ReDim festlegen. Im folgenden Beispiel setzt ReDim die anfängliche Größe des dynamischen Datenfelds auf 25. Eine nachfolgende ReDim -Anweisung ändert die Größe auf 30, verwendet aber das Schlüsselwort Preserve, so dass der Inhalt des Datenfelds bei der Größenänderung erhalten bleibt.

ReDim EinDatenfeld(25)

. . .

ReDim Preserve EinDatenfeld(30)


Konstanten

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konstanten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Konstante ist ein aussagekräftiger Name, der an Stelle einer Zahl oder einer Zeichenfolge verwendet wird und dessen Wert sich nie ändert. VBScript legt eine Anzahl integrierter Konstanten fest. Weitere Informationen zu diesen integrierten Konstanten finden Sie im VBScript-Sprachverzeichnis.

Sie können benutzerdefinierte Konstanten in VBScript mit der Const-Anweisung erstellen. Damit können Sie Zeichenfolgenkonstanten oder numerische Konstanten einen sinnvollen Namen zuweisen. Anschließend können Sie ihnen Literalwerte zuweisen und sie in Ihrem Skript verwenden. Beispiel:

Const Zeichenfolge1 = Dies ist eine Zeichenfolge.

Const MeinAlter = 49

Beachten Sie, dass das Zeichenfolgenliteral in Anführungszeichen () eingeschlossen ist. Anführungszeichen eignen sich am besten, um Zeichenfolgenwerte von numerischen Werten zu unterscheiden. Datums-/Uhrzeitliterale werden in Nummernzeichen (#) eingeschlossen. Beispiel:

Const AbgabeTermin = #6-1-97#

Weil es zwischen den auf diese Weise erstellten Konstanten und normalen Variablen keinen funktionellen Unterschied gibt, sollten Sie ein Namensschema verwenden, um Konstanten von Variablen zu unterscheiden. Dies schützt Sie davor, einer Konstanten während der Skriptausführung versehentlich einen neuen Wert zuzuweisen. Sie können z.B. den Präfix vb oder con für Ihre Konstantennamen verwenden, oder Sie können Ihre Konstantennamen groß schreiben. Sorgen Sie auf jeden Fall dafür, dass eine Unterscheidung zwischen Konstanten und Variablen möglich ist. Dadurch vermeiden Sie Probleme, wenn Sie komplexere Skripten erstellen.


Operatoren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VBScript verfügt über eine Vielzahl von Operatoren, u.a. für arithmetische, Vergleichs-, Verkettungs- und logische Operationen.

Noch in diesem Kapitel

Operatorvorrang

Arithmetische Operatoren

Vergleichs-Operatoren

Logische Operatoren


Operatorvorrang

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Operatoren -> Operatorvorrang

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn in einem Ausdruck mehrere Operatoren vorkommen, wird jeder Bestandteil in einer vordefinierten Reihenfolge ausgewertet und aufgelöst. Diese Reihenfolge wird als Operatorvorrang bezeichnet. Sie können den Operatorvorrang mit Klammern übergehen und die Auswertung von Bestandteilen eines Ausdrucks vor anderen Bestandteilen erzwingen. Operationen innerhalb von Klammern werden immer vor den Operationen außerhalb von Klammern ausgeführt. Innerhalb der Klammern gilt jedoch der normale Operatorvorrang.

Wenn ein Ausdruck Operatoren verschiedener Kategorien enthält, werden zuerst arithmetische, dann Vergleichs- und schließlich logische Operatoren ausgewertet. Alle Vergleichsoperatoren haben denselben Rang, d.h. sie werden in der Reihenfolge ihres Auftretens von links nach rechts ausgewertet. Arithmetische und logische Operatoren werden in folgender Reihenfolge ausgewertet.


Arithmetische Operatoren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Operatoren -> Arithmetische Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Beschreibung | Symbol
Potenzierung | ^
Unäre Negation | -
Multiplikation | *
Division | /
Ganzzahlige Division | /
Modulo-Arithmetik | Mod
Addition | +
Subtraktion | -
Zeichenfolgenverkettung |


Vergleichs-Operatoren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Operatoren -> Vergleichs-Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Beschreibung | Symbol
Gleichheit | =
Ungleichheit | <>
Kleiner als | <
Größer als | >
Kleiner oder gleich | <=
Größer oder gleich | >=
Objektäquivalenz | Is


Logische Operatoren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Operatoren -> Logische Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn in einem Ausdruck mehrere Operatoren vorkommen, wird jeder Bestandteil in einer vordefinierten Reihenfolge ausgewertet und aufgelöst. Diese Reihenfolge wird als Operatorvorrang bezeichnet. Sie können den Operatorvorrang mit Klammern übergehen und die Auswertung von Bestandteilen eines Ausdrucks vor anderen Bestandteilen erzwingen. Operationen innerhalb von Klammern werden immer vor den Operationen außerhalb von Klammern ausgeführt. Innerhalb der Klammern gilt jedoch der normale Operatorvorrang.

Wenn ein Ausdruck Operatoren verschiedener Kategorien enthält, werden zuerst arithmetische, dann Vergleichs- und schließlich logische Operatoren ausgewertet. Alle Vergleichsoperatoren haben denselben Rang, d.h. sie werden in der Reihenfolge ihres Auftretens von links nach rechts ausgewertet. Arithmetische und logische Operatoren werden in folgender Reihenfolge ausgewertet.


Steuern der Programmausführung

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Steuern der Programmausführung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können den Ablauf eines Skripts mit Bedingungs- und Schleifenanweisungen steuern. Mit Hilfe von Bedingungsanweisungen können Sie VBScript-Code schreiben, mit dem Entscheidungen getroffen und Aktionen wiederholt werden können.

Noch in diesem Kapitel

Treffen von Entscheidungen mit Hilfe von If...Then...Else

Treffen von Entscheidungen mit Select Case


Treffen von Entscheidungen mit Hilfe von If...Then...Else

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Steuern der Programmausführung -> Treffen von Entscheidungen mit Hilfe von If...Then...Else

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Anweisung If...Then...Else wird verwendet, um zu bestimmen, ob eine Bedingung True oder False ist, und um anzugeben, ob je nach Ergebnis eine oder weitere Anweisungen ausgeführt werden. Im allgemeinen ist die Bedingung ein Ausdruck, der einen Vergleichsoperator zum Vergleichen eines Wertes oder einer Variablen mit einem/r anderen verwendet. Informationen zu Vergleichsoperatoren finden Sie unter Vergleichsoperatoren. If...Then...Else -Anweisungen können nach Bedarf auf beliebig vielen Ebenen verschachtelt werden.

Noch in diesem Kapitel

Ausführen von Anweisungen, wenn eine Bedingung True ist

Ausführen bestimmter Anweisungen, wenn eine Bedingung True ist, und Ausführen anderer Anweisungen, wenn eine Bedingung False ist

Entscheiden zwischen mehreren Alternativen


Ausführen von Anweisungen, wenn eine Bedingung True ist

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Steuern der Programmausführung -> Treffen von Entscheidungen mit Hilfe von If...Then...Else -> Ausführen von Anweisungen, wenn eine Bedingung True ist

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Ausführen von Anweisungen, wenn eine Bedingung True ist

Um nur eine Anweisung auszuführen, wenn eine Bedingung True ist, verwenden Sie die einzeilige Syntax für die If...Then...Else -Anweisung. Das folgende Beispiel zeigt die einzeilige Syntax. Beachten Sie, dass in diesem Beispiel das Schlüsselwort Else weggelassen wird.

Sub FixDate()
Dim myDate
myDate = #2/13/95#
If myDate < Now Then myDate = Now
End Sub

Zum Ausführen von mehr als einer Codezeile müssen Sie die mehrzeilige oder Blocksyntax verwenden. Diese Syntax enthält die Anweisung End If , wie im folgenden Beispiel gezeigt:

Sub AlertUser(value)
If value = 0 Then
AlertLabel.ForeColor = vbRed
AlertLabel.Font.Bold = True
AlertLabel.Font.Italic = True
End If
End Sub

Ausführen, wenn eine Bedingung True ist, verwenden Sie die einzeilige Syntax für die If...Then...Else -Anweisung. Das folgende Beispiel zeigt die einzeilige Syntax. Beachten Sie, dass in diesem Beispiel das Schlüsselwort Else weggelassen wird.

Sub FixDate()
Dim myDate
myDate = #2/13/95#
If myDate < Now Then myDate = Now
End Sub

Zum Ausführen von mehr als einer Codezeile müssen Sie die mehrzeilige oder Blocksyntax verwenden. Diese Syntax enthält die Anweisung End If , wie im folgenden Beispiel gezeigt:

Sub AlertUser(value)
If value = 0 Then
AlertLabel.ForeColor = vbRed
AlertLabel.Font.Bold = True
AlertLabel.Font.Italic = True
End If
End Sub


Ausführen bestimmter Anweisungen, wenn eine Bedingung True ist, und Ausführen anderer Anweisungen, wenn eine Bedingung False ist

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Steuern der Programmausführung -> Treffen von Entscheidungen mit Hilfe von If...Then...Else -> Ausführen bestimmter Anweisungen, wenn eine Bedingung True ist, und Ausführen anderer Anweisungen, wenn eine Bedingung False ist

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Ausführen bestimmter Anweisungen, wenn eine Bedingung True ist, und Ausführen anderer Anweisungen, wenn eine Bedingung False ist

Mit der Anweisung If...Then...Else können Sie zwei Blöcke mit ausführbaren Anweisungen definieren: ein Block wird ausgeführt, wenn die Bedingung True ist, der andere wird ausgeführt, wenn die Bedingung False ist.

Sub AlertUser(value)
If value = 0 Then
AlertLabel.ForeColor = vbRed
AlertLabel.Font.Bold = True
AlertLabel.Font.Italic = True
Else
AlertLabel.Forecolor = vbBlack
AlertLabel.Font.Bold = False
AlertLabel.Font.Italic = False
End If
End Sub


Entscheiden zwischen mehreren Alternativen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Steuern der Programmausführung -> Treffen von Entscheidungen mit Hilfe von If...Then...Else -> Entscheiden zwischen mehreren Alternativen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Entscheiden zwischen mehreren Alternativen

Mit Hilfe einer Variation der If...Then...Else -Anweisung können Sie aus mehreren Alternativen auswählen. Durch das Hinzufügen der Klausel ElseIf können Sie die Funktionalität der If...Then...Else -Anweisung erweitern, so dass der Programmablauf auf mehreren Möglichkeiten basiert.

Beispiel:
Sub ReportValue(value)
If value = 0 Then
MsgBox value
ElseIf value = 1 Then
MsgBox value
ElseIf value = 2 then
Msgbox value
Else
Msgbox Wert ausserhalb des Bereichs!
End If


Treffen von Entscheidungen mit Select Case

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Steuern der Programmausführung -> Treffen von Entscheidungen mit Select Case

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Select Case -Struktur bietet eine Alternative zu If...Then...ElseIf , um gezielt einen Anweisungsblock aus mehreren Anweisungsblöcken auszuführen. Eine Select Case -Anweisung bietet dieselbe Funktionalität wie die If...Then...Else -Anweisung, macht den Code jedoch effizienter und leichter lesbar.

Eine Select Case -Struktur arbeitet mit einem einzelnen Testausdruck, der einmalig auf der obersten Ebene der Struktur ausgewertet wird. Das Ergebnis der Struktur wird dann mit den Werten für jeden Case in der Struktur verglichen. Gibt es eine übereinstimmung, wird der mit diesem Case verknüpfte Anweisungsblock ausgeführt:

Select Case Document.Form1.CardType.Options(SelectedIndex).Text
Case MasterCard
DisplayMCLogo
ValidateMCAccount
Case Visa
DisplayVisaLogo
ValidateVisaAccount
Case American Express
DisplayAMEXCOLogo
ValidateAMEXCOAccount
Case Else
DisplayUnknownImage
PromptAgain
End Select


Verwenden von Schleifen zum Wiederholen von Code

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Durchlaufen von Schleifen ermöglicht Ihnen, eine Anweisungsgruppe wiederholt auszuführen. Einige Schleifen wiederholen Anweisungen, bis eine Bedingung falsch ( False ) wird, andere wiederholen Anweisungen, bis eine Bedingung wahr ( True ) wird. Es gibt auch Schleifen, die Anweisungen in einer bestimmten Anzahl wiederholen.

Die folgenden Schleifenanweisungen sind in VBScript verfügbar:

Parameter | Beschreibung
Verwenden von Do-Schleifen : | Schleife durchlaufen, solange oder bis eine Bedingung True ist.
Verwenden von While...Wend : | Schleife durchlaufen, solange eine Bedingung True ist.
Verwenden von For...Next : | Verwendet einen Zähler, der angibt, wie oft Anweisungen ausgeführt werden.
Verwenden von For Each...Next : | Wiederholt eine Anweisungsgruppe für jedes Element in einer Auflistung oder jedes Element in einem Datenfeld.

Noch in diesem Kapitel

Verwenden von Do-Schleifen

Verwenden von While...Wend

Verwenden von For...Next

Verwenden von For Each...Next


Verwenden von Do-Schleifen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code -> Verwenden von Do-Schleifen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können Do...Loop -Anweisungen verwenden, um einen Anweisungblock mehrmals auszuführen, ohne dass die Anzahl der Durchläufe festgelegt ist. Die Anweisungen werden entweder wiederholt, solange eine Bedingung True ist oder bis eine Bedingung True wird.

Noch in diesem Kapitel

Wiederholung von Anweisungen, während eine Bedingung True ist

Wiederholen einer Anweisung, bis eine Bedingung True wird

Beenden einer Do...Loop-Anweisung aus der Schleife heraus


Wiederholung von Anweisungen, während eine Bedingung True ist

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code -> Verwenden von Do-Schleifen -> Wiederholung von Anweisungen, während eine Bedingung True ist

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Wiederholung von Anweisungen, während eine Bedingung True ist

Verwenden Sie das Schlüsselwort While , um eine Bedingung in einer Do...Loop -Anweisung zu überprüfen. Sie können die Bedingung überprüfen, bevor die Schleife ausgeführt wird (wie im folgenden Beispiel ChkFirstWhile gezeigt), oder Sie können sie überprüfen, nachdem die Schleife mindestens einmal ausgeführt wurde (wie im Beispiel ChkLastWhile gezeigt). Wenn in der ChkFirstWhile-Prozedur myNum auf 9 anstatt auf 20 festgelegt wird, werden die Anweisungen in der Schleife niemals ausgeführt. In der ChkLastWhile-Prozedur werden die Anweisungen in der Schleife nur einmal ausgeführt, weil die Bedingung bereits False ist.

Sub ChkFirstWhile()
Dim counter, myNum
counter = 0

myNum = 20

Do While myNum > 10

myNum = myNum - 1

counter = counter + 1

Loop

MsgBox 'Die Schleife wurde ' & counter & ' mal wiederholt.'

End Sub

Sub ChkLastWhile()

Dim counter, myNum

counter = 0

myNum = 9

Do
myNum = myNum - 1
counter = counter + 1

Loop While myNum > 10

MsgBox 'Die Schleife wurde ' & counter & ' mal wiederholt.'

End Sub


Wiederholen einer Anweisung, bis eine Bedingung True wird

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code -> Verwenden von Do-Schleifen -> Wiederholen einer Anweisung, bis eine Bedingung True wird

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Wiederholen einer Anweisung, bis eine Bedingung True wird

Sie können das Schlüsselwort Until auf zwei Arten verwenden, um eine Bedingung in einer Do...Loop -Anweisung zu überprüfen. Sie können die Bedingung überprüfen, bevor die Schleife ausgeführt wird (wie im folgenden Beispiel ChkFirstUntil gezeigt), oder Sie können sie überprüfen, nachdem die Schleife mindestens einmal ausgeführt wurde (wie im Beispiel ChkLastUntil gezeigt). Solange die Bedingung False ist, wird die Schleife durchlaufen.

Sub ChkFirstUntil()

Dim counter, myNum

counter = 0

myNum = 20

Do Until myNum = 10

myNum = myNum - 1

counter = counter + 1

Loop

MsgBox 'Die Schleife wurde ' & counter & ' mal wiederholt.'

End Sub

Sub ChkLastUntil()

Dim counter, myNum

counter = 0

myNum = 1

Do

myNum = myNum + 1

counter = counter + 1

Loop Until myNum = 10

MsgBox 'Die Schleife wurde ' & counter & ' mal wiederholt.'

End Sub


Beenden einer Do...Loop-Anweisung aus der Schleife heraus

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code -> Verwenden von Do-Schleifen -> Beenden einer Do...Loop-Anweisung aus der Schleife heraus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Beenden einer Do...Loop-Anweisung aus der Schleife heraus

Sie können eine Do...Loop -Schleife beenden, indem Sie die Exit Do -Anweisung verwenden. Da die Schleifenausführung gewöhnlich nur in bestimmten Situationen beendet werden soll, z.B. um eine Endlosschleife zu vermeiden, sollten Sie die Exit Do -Anweisung im True -Anweisungsblock einer If...Then...Else -Anweisung verwenden. Wenn die Bedingung False ist, wird die Schleife normal ausgeführt.

Im folgenden Beispiel wird myNum ein Wert zugewiesen, der eine Endlosschleife verursacht. Die If...Then...Else Anweisung überprüft, ob dieser Zustand eintritt, und verhindert die endlose Wiederholung.

Sub ExitExample()

Dim counter, myNum

counter = 0

myNum = 9

Do Until myNum = 10

myNum = myNum - 1

counter = counter + 1

If myNum < 10 Then Exit Do

Loop

MsgBox 'Die Schleife wurde ' & counter & ' mal wiederholt.'

End Sub


Verwenden von While...Wend

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code -> Verwenden von While...Wend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die While...Wend -Anweisung wird in VBScript für Entwickler zur Verfügung gestellt, die mit ihrer Verwendung vertraut sind. Aufgrund der eingeschränkten Flexibilität von While...Wend wird jedoch empfohlen, stattdessen Do...Loop zu verwenden.


Verwenden von For...Next

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code -> Verwenden von For...Next

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können For...Next -Anweisungen verwenden, um genau festzulegen, wie oft ein Anweisungblock ausgeführt werden soll. Für Schleifen verwenden Sie eine Zählervariable, deren Wert mit jeder Wiederholung der Schleife vergrößert oder verkleinert wird.

Beispielsweise hat die folgende Prozedur zur Folge, dass eine Prozedur mit dem Namen MyProc 50 mal ausgeführt wird. Die For -Anweisung gibt als Zählervariable x an und legt den zugehörigen Start- und Endwert fest. Die Next -Anweisung zählt die Zählervariable jeweils um 1 hoch.

Sub DoMyProc50Times()

Dim x

For x = 1 To 50

MyProc

Next

End Sub

Mit dem Schlüsselwort Step können Sie die Zählervariable um den darin angegebenen Wert vergrößern oder verkleinern. Im folgenden Beispiel wird die Zählervariable j bei jedem Schleifendurchlauf um 2 hochgezählt. Wenn die Schleife beendet ist, enthält total die Summe von 2, 4, 6, 8 und 10.

Sub DoMyProc50Times()

Dim x

For x = 1 To 50

MyProc

Next

End Sub

Zum Verkleinern der Zählervariable verwenden Sie einen negativen Wert für Step . Sie müssen einen Endwert angeben, der kleiner als der Startwert ist. Im folgenden Beispiel wird die Zählervariable myNum bei jedem Schleifendurchlauf um 2 verkleinert. Wenn die Schleife beendet ist, enthält total die Summe von 16, 14, 12, 10, 8, 6, 4 und 2.

Sub NewTotal()

Dim myNum, total

For myNum = 16 To 2 Step -2

total = total + myNum

Next

MsgBox 'Die Summe ist ' & total

End Sub


Verwenden von For Each...Next

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Verwenden von Schleifen zum Wiederholen von Code -> Verwenden von For Each...Next

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine For Each...Next -Schleife ist einer For...Next -Schleife ähnlich. Anstatt die Anzahl der Schleifendurchläufe zum Wiederholen der Anweisungen anzugeben, wird in einer For Each...Next -Schleife eine Anweisungsgruppe für jedes Element in einer Auflistung von Objekten oder für jedes Element in einem Datenfeld ausgeführt. Dies ist besonders dann hilfreich, wenn nicht bekannt ist, wieviele Elemente in einer Gruppe enthalten sind.

Im folgenden HTML-Codebeispiel wird der Inhalt eines Dictionary -Objekts verwendet, um Text in mehrere Textfelder einzusetzen:

<HTML>

<HEAD><TITLE>Formulare und Elemente</TITLE></HEAD>

<SCRIPT LANGUAGE='VBScript'>

<!--

Sub cmdChange_OnClick

Dim d 'Erstellen einer Variablen

Set d = CreateObject('Scripting.Dictionary')

d.Add '0', 'Athen' 'Einige Schlüssel und Elemente hinzufügen

d.Add '1', 'Belgrad'

d.Add '2', 'Kairo'

For Each I in d

Document.frmForm.Elements(I).Value = D.Item(I)

Next

End Sub

-->

</SCRIPT>

<BODY>

<CENTER>

<FORM NAME='frmForm'

<Input Type = 'Text'><p>

<Input Type = 'Text'><p>

<Input Type = 'Text'><p>

<Input Type = 'Text'><p>

<Input Type = 'Button' NAME='cmdChange' VALUE='Hierauf klicken'><p>

</FORM>

</CENTER>

</BODY>

</HTML>


Arten von Prozeduren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Arten von Prozeduren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Sub-Prozeduren

Function-Prozeduren

Übergeben von Daten an bzw. aus Prozeduren

Verwenden von Sub- und Function-Prozeduren im Code


Sub-Prozeduren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Arten von Prozeduren -> Sub-Prozeduren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Sub -Prozedur ist eine Folge von VBScript-Anweisungen, die zwischen den Anweisungen Sub und End Sub eingeschlossen ist, und die Aktionen ausführt, aber keine Werte zurückgibt. Eine Sub -Prozedur kann Argumente (Konstanten, Variablen oder Ausdrücke, die von einer aufrufenden Prozedur übergeben wurden) übernehmen. Wenn eine Sub -Prozedur keine Argumente hat, muss ihre Sub -Anweisung ein leeres Klammernpaar enthalten ().

Die folgende Sub -Prozedur verwendet zwei integrierte (oder eingebaute) VBScript-Funktionen, MsgBox und InputBox , um einen Benutzer zur Eingabe von Informationen aufzufordern. Dann zeigt sie das Ergebnis einer Berechnung an, die auf diesen Informationen basiert. Die Berechnung wird in einer mit VBScript erstellten Function -Prozedur ausgeführt. Diese wird in der Behandlung der nachfolgenden Function -Prozedur ebenfalls gezeigt.

Sub KonvertTemp()

temp = InputBox('Geben Sie die Temperatur in Fahrenheit ein.', 1)

MsgBox 'Die Temperatur ist ' & Celsius(temp) & ' Grad Celsius.'

End Sub


Function-Prozeduren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Arten von Prozeduren -> Function-Prozeduren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Function -Prozedur ist eine Folge von VBScript-Anweisungen, die zwischen den Anweisungen Function und End Function eingeschlossen ist. Eine Function -Prozedur ist einer Sub -Prozedur ähnlich, kann aber auch einen Wert zurückgeben. Eine Function -Prozedur kann Argumente (Konstanten, Variablen oder Ausdrücke, die von einer aufrufenden Prozedur übergeben werden) übernehmen. Wenn eine Function -Prozedur keine Argumente hat, muss ihre Function -Anweisung ein leeres Klammernpaar enthalten. Eine Function -Prozedur gibt Werte zurück, indem ihrem Namen in einer oder mehreren Anweisung(en) der Prozedur ein Wert zugewiesen wird. Der Typ des Rückgabewerts einer Function -Prozedur ist immer ein Variant .

Die Funktion Celsius im folgenden Beispiel berechnet aus Gradwerten in Fahrenheit die entsprechenden Werte in Grad Celsius. Beim Aufruf der Funktion aus der Sub -Prozedur KonvertTemp wird eine Variable mit dem Argumentwert an die Funktion übergeben. Das Ergebnis der Berechnung wird an die aufrufende Prozedur zurückgegeben und in einem Meldungsfeld angezeigt.

Sub KonvertTemp()

temp = InputBox('Geben Sie die Temperatur in Fahrenheit ein.', 1)

MsgBox 'Die Temperatur ist ' & Celsius(temp) & ' Grad Celsius.'

End Sub

Function Celsius(GradF)

Celsius = (GradF - 32) * 5 / 9

End Function


Übergeben von Daten an bzw. aus Prozeduren

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Arten von Prozeduren -> Übergeben von Daten an bzw. aus Prozeduren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jedes Datenelement wird Ihrer Prozedur über ein Argument übergeben. Argumente dienen als Platzhalter für die Daten, die Sie Ihrer Prozedur übergeben möchten. Wenn Sie eine Prozedur mit der Sub - oder der Function -Anweisung erstellen, müssen nach dem Namen der Prozedur Klammern angegeben werden. Alle Argumente werden zwischen diesen Klammern angegeben und durch Kommas getrennt. In der folgenden Prozedur ist beispielsweise GradF ein Platzhalter für den Wert, der an die Funktion Celsius zur Konvertierung übergeben wird:

Function Celsius(GradF)

Celsius = (GradF - 32) * 5 / 9

End Function


Verwenden von Sub- und Function-Prozeduren im Code

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Arten von Prozeduren -> Verwenden von Sub- und Function-Prozeduren im Code

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Function -Prozedur in Ihrem Code zu verwenden, müssen Sie diese auf der rechten Seite einer Variablenzuweisung oder in einem Ausdruck verwenden.

Beispiele:

Temp = Celsius(GradF)

oder

MsgBox 'Die Temperatur beträgt ' & Celsius(GradF) & ' Grad Celsius.'

Um eine Sub -Prozedur aus einer anderen Prozedur aufzurufen, müssen Sie lediglich den Namen der Prozedur zusammen mit den erforderlichen Argumenten (durch Kommas getrennt) eingeben. Die Call -Anweisung ist nicht erforderlich, wenn Sie sie jedoch verwenden, müssen Sie die Argumente in Klammern einschließen.

Das folgende Beispiel zeigt zwei Aufrufe der Prozedur MeineProz. In einem Fall wird die Call -Anweisung im Code verwendet, im anderen nicht. Beide Aufrufe haben genau dieselbe Wirkung.

Call MeineProz(erstesArg, zweitesArg)

MeineProz erstesArg, zweitesArg


Konventionen für die Programmierung

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konventionen für die Programmierung sind Vorschläge, die Ihnen das Schreiben von Code mit der Microsoft Visual Basic Scripting Edition erleichtern sollen.

Konventionen für die Programmierung umfassen unter anderem folgende Richtlinien:

Namenskonventionen für Objekte, Variablen und Prozeduren

Konventionen für Kommentare

Richtlinien für die Formatierung und das Einrücken von Text

Der wichtigste Grund für einheitliche Konventionen für die Programmierung ist die Standardisierung der Code-Struktur und des Programmierstils für ein oder mehrere Skripten, damit der Code für Sie und andere leichter lesbar und verständlicher ist. Mit sinnvollen Konventionen für die Programmierung erhalten Sie präzisen, lesbaren und eindeutigen Code, der den für andere Programmiersprachen verwendeten Konventionen entspricht und so intuitiv wie möglich ist.

Noch in diesem Kapitel

Namenskonventionen für Konstanten

Namenskonventionen für Variablen

Gültigkeitsbereich von Variablen

Aussagekräftige Variablen- und Prozedurnamen

Namenskonventionen für Objekte

Konventionen für Code-Kommentare


Namenskonventionen für Konstanten

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Namenskonventionen für Konstanten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Frühere Versionen von VBScript besaßen keine Mechanismen für die Erstellung benutzerdefinierter Konstanten. Konstanten wurden, wenn notwendig, wie Variablen implementiert und von anderen Variablen dadurch unterschieden, dass nur Großbuchstaben verwendet wurden. Mehrere Wörter wurden durch den Unterstrich (_) getrennt.

Beispiele:

BENUTZER_LISTE_MAX
NEUE_ZEILE

Obwohl dieser Weg, Konstanten zu kennzeichnen, noch funktioniert, können Sie eine andere Art der Namensgebung verwenden. Sie können echte Konstanten mit Hilfe der Const -Anweisung anlegen. Diese Konvention verwendet ein Format mit gemischter Groß- und Kleinschreibung, in dem Konstanten das Präfix con vorangestellt wird.

Zum Beispiel:

conIhreEigeneKonstante


Namenskonventionen für Variablen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Namenskonventionen für Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Lesbarkeit und die Konsistenz zu verbessern, verwenden Sie in VBScript die in der folgenden Tabelle aufgeführten Präfixe zusammen mit aussagekräftigen Variablennamen.

Untertyp | Präfix | Beispiel
Boolean | bln | blnGefunden
Byte | byt | bytRasterDaten
Date (Time) | dtm | dtmStart
Double | dbl | dblToleranz
Error | err | errBestellNr
Integer | int | intAnzahl
Long | lng | lngEntfernung
Object | obj | objAktuell
Single | sng | sngDurchschnitt
String | str | strVorname


Gültigkeitsbereich von Variablen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Gültigkeitsbereich von Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen sollten immer mit dem kleinstmöglichen Gültigkeitsbereich definiert werden. VBScript-Variablen können einen der folgenden Gültigkeitsbereiche haben.

Gültigkeitsbereich | Variablendeklaration in | Sichtbarkeit
Prozedurebene | Ereignis-, Function- oder Sub-Prozedur | Sichtbar in der Prozedur, in der sie deklariert wird.
Skriptebene | HEAD-Abschnitt einer HTML-Seite, außerhalb jeder Prozedur | Sichtbar in jeder Prozedur des Skripts.

Noch in diesem Kapitel

Präfixe für den Gültigkeitsbereich von Variablen


Präfixe für den Gültigkeitsbereich von Variablen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Gültigkeitsbereich von Variablen -> Präfixe für den Gültigkeitsbereich von Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Präfixe für den Gültigkeitsbereich von Variablen

Mit zunehmender Skriptgröße wird es immer wichtiger, die Gültigkeitsbereiche der Variablen schnell unterscheiden zu können. Dies wird durch einen Gültigkeitsbereichs-Präfix aus einem Buchstaben vor dem Typ-Präfix erreicht, ohne die Variablennamen übermäßig zu verlängern.

Gültigkeitsbereich | Präfix | Beispiel
Prozedurebene | keiner | dblGeschwindigkeit
Skriptebene | s | sblnBerechnungInArbeit


Aussagekräftige Variablen- und Prozedurnamen

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Aussagekräftige Variablen- und Prozedurnamen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Rumpf eines Variablen- oder Prozedurnamens sollte Groß- und Kleinschreibung verwendet werden. Der Name sollte so ausführlich sein wie nötig, um den Zweck der Variablen zu beschreiben. Darüber hinaus sollten Prozedurnamen mit einem Verb beginnen, wie z.B. InitialisiereFeldName oder SchliesseDialogfeld.

Für häufig verwendete oder lange Ausdrücke sind Standardabkürzungen zu empfehlen, um die Namen kurz zu halten. Im allgemeinen sind Variablennamen mit mehr als 32 Zeichen schwer lesbar. Stellen Sie sicher, dass die verwendeten Abkürzungen im gesamten Skript einheitlich sind. Der grundlose Wechsel zwischen Zhl und Zaehl innerhalb eines oder mehrerer zusammenhängender Skripten kann Probleme bereiten.


Namenskonventionen für Objekte

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Namenskonventionen für Objekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die folgende Tabelle führt die empfohlenen Konventionen für die verschiedenen Objekte auf, die beim Programmieren in VBScript verwendet werden.

Objekttyp | Präfix | Beispiel
3D-Grundfläche (3D panel) | pnl | pnlGruppe
Animierte Schaltfläche (animated button) | ani | aniMailBox
Check box | chk | chkReadOnly
Kombinationsfeld (combo box), Dropdown-Listenfeld (drop-down list box) | cbo | cboDeutsch
Befehlsschaltfläche (command button) | cmd | cmdExit
Standarddialogfeld (common dialog) | dlg | dlgDateiOeffnen
Rahmen (frame) | fra | fraSprache
Horizontale Bildlaufleiste (horizontal scroll bar) | hsb | hsbLautstaerke
Abbildung (image) | img | imgSymbol
Bezeichnungsfeld (label) | lbl | lblHilfeMeldung
Linie (line) | lin | linVertikal
Listenfeld (list box) | lst | lstVersicherungsnummern
Drehfeld (Spin) | spn | spnSeiten
Textfeld (text box) | txt | txtNachname
Vertikale Bildlaufleiste (vertical scroll bar) | vsb | vsbRate
Bildlauffeld (Slider) | sld | sldSkala


Konventionen für Code-Kommentare

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Konventionen für Code-Kommentare

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jede Prozedur sollte mit einem kurzen Kommentar beginnen, der den Zweck der Prozedur beschreibt. Diese Beschreibung sollte nicht auf die Implementierungsdetails (wie die Operationen durchgeführt werden) eingehen, weil sich diese im Laufe der Zeit ändern können, was zu unnötigen Wartungsarbeiten bei den Kommentaren oder, noch schlimmer, zu falschen Kommentaren führen kann. Der Code selbst und ggf. nötige Kommentare im Code beschreiben die Implementierung.

Die an eine Prozedur übergebenen Argumente sollten beschrieben werden, wenn ihr Zweck nicht offensichtlich ist und wenn die Prozedur die Argumente in einem bestimmten Wertebereich erwartet. Rückgabewerte von Funktionen und andere Variablen, die von der Prozedur geändert werden, vor allem über Argumente, die als Referenz übergeben werden, sollten ebenfalls am Anfang jeder Prozedur beschrieben werden.

Die Kommentare im Prozedurkopf sollten folgende Abschnittsüberschriften enthalten. Beispiele finden Sie im nachfolgenden Abschnitt Code-Formatierung.

Abschnittsüberschrift | Kommentar
Zweck | Was die Prozedur tut (nicht, wie sie es tut).
Annahmen | Liste der Auswirkungen dieser Prozedur auf externe Variablen, Steuerelemente oder andere Elemente.
Auswirkungen | Liste der Auswirkungen dieser Prozedur auf externe Variablen, Steuerelemente oder andere Elemente.
Eingehende Werte | Erläuterung jedes Arguments, das nicht offensichtlich ist. Jedes Argument sollte in einer separaten Zeile mit Kommentaren im Code beschrieben werden.
Rückgabewerte | Erklärung des zurückgegebenen Wertes.

Berücksichtigen Sie folgende Punkte:

Die Deklaration jeder wichtigen Variablen sollte einen Kommentar im Code enthalten, der die Verwendung der deklarierten Variablen beschreibt.

Variablen, Steuerelemente und Prozeduren sollten so klar benannt werden, dass Kommentare im Code nur noch für komplexe Implementierungsdetails nötig sind.

Sie sollten am Anfang Ihres Skripts eine übersicht einfügen, die das Skript beschreibt und die Objekte, Prozeduren, Algorithmen, Dialogfelder und andere Systemabhängigkeiten auflistet. Manchmal kann ein Stück Pseudo-Code helfen, einen Algorithmus zu beschreiben.

Noch in diesem Kapitel

Code-Formatierung


Code-Formatierung

Handbuch -> Programmierschnittstellen -> Process Control Engine (PCE) -> VBScript - Einführung -> Konventionen für die Programmierung -> Konventionen für Code-Kommentare -> Code-Formatierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Code-Formatierung

Sie sollten mit dem Platz auf dem Bildschirm möglichst sparsam umgehen und trotzdem den Code so formatieren, dass die logische Struktur und Verschachtelung deutlich wird. Hier sind einige Hinweise:

  • Normal verschachtelte Blöcke sollten um vier Leerzeichen eingerückt sein.
  • Der übersichtskommentar einer Prozedur sollte um ein Leerzeichen eingerückt sein.
  • Die Anweisungen auf höchster Ebene, die auf den übersichtskommentar folgen, sollten um vier Leerzeichen eingerückt sein. Jeder verschachtelte Block sollte jeweils um weitere vier Leerzeichen eingerückt werden.

Beispiel:

Der folgende Code entspricht den VB Script Code Konventionen:

  • Zweck: Sucht das erste Vorkommen des angegebenen Benutzers im Datenfeld BenutzerListe.
  • Eingaben: strBenutzerListe(): Zu durchsuchende Benutzerliste.
  • strZielBenutzer: Name des zu suchenden Benutzers.
  • Rückgabewerte: Index des ersten Vorkommens von strZielBenutzer im Datenfeld strBenutzerListe.
    Wenn der gesuchte Benutzer nicht gefunden wird: -1.

Function intSucheBenutzer (strBenutzerListe(), strZielBenutzer)

Dim i ' Schleifenzähler.

Dim blnGefunden ' 'Ziel gefunden'-Attribut.

intSucheBenutzer = -1

i = 0 ' Schleifenzähler initialisieren

Do While i <= Ubound(strBenutzerListe) and Not blnGefunden

If strBenutzerListe(i) = strZielBenutzer Then

blnGefunden = True ' Flag auf True setzen

intSuche Benutzer = i ' Rückgabewert für Schleifenzähler setzen

End If

i = i + 1 ' Schleifenzähler erhöhen

Loop

End Function


VBA

Handbuch -> Programmierschnittstellen -> VBA

Mit VBA kann die Funktionalität von zenon selbstständig erweitert werden.

Die Möglichkeiten VBA in zenon einzusetzen am Beispiel spezieller Lösungsmöglichkeiten für die Projektrealisierung werden beschrieben.

Kontextmenü

Menüpunkt | Aktion
VBA-Editor öffnen | Öffnet den VBA-Editor.
VBE exportieren alle | Öffnet den Dialog zur Auswahl des Speicherorts für den VBE-Export.
VBE importieren | Öffnet den Dialog zur Auswahl der VBE-Importdatei.
Editorprofile | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

info Info

Wenn VBA-Makros im Editor geändert werden:

  • werden die Runtime-Dateien kompiliert und zur Runtime übertragen
  • wird die Runtime neu geladen
  • werden VSTA-Elemente ebenfalls neu geladen, selbst wenn keine Änderungen in VSTA erfolgt sind

VBA startet für Arbeitsplatz und Projekt die gleiche Entwicklungsumgebung. Um den VBA Editor zu öffnen:

  1. navigieren Sie zum Knoten Programmierschnittstellen
  2. führen Sie einen Rechtsklick auf VBA-Makros aus
  3. wählen Sie im Kontextmenü VBA-Editor öffnen...

Alternative: drücken Sie die Tastenkombination Alt+F11

Noch in diesem Kapitel

VBA Symbolleiste und Kontextmenü Detailansicht

Grundlagen

Makros im Editor

Entwicklung von Wizards in VBA

Frequently asked Questions

Beispiele


VBA Symbolleiste und Kontextmenü Detailansicht

Handbuch -> Programmierschnittstellen -> VBA -> VBA Symbolleiste und Kontextmenü Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste

Menüpunkt | Aktion
VBA-Makro neu | Legt ein neues Makro an und öffnet den Makro-Editor.
VBA-Editor öffnen | Öffnet den VBA-Editor.
Speichern | Speichert Makros.
Entfernen | Löscht das ausgewählte Element.
VBE exportieren alle | Öffnet den Dialog zur Auswahl des Speicherorts für den VBE-Export.
VBE importieren | Öffnet den Dialog zur Auswahl der VBE-Importdatei.
Umbenennen | Ermöglicht umbenennen des ausgewählten Markos.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Module

Menüpunkt | Aktion
VBA-Editor öffnen | Öffnet den VBA-Editor.
Speichern | Speichert Makros.
VBE exportieren alle | Öffnet den Dialog zur Auswahl des Speicherorts für den VBE-Export.
VBE importieren | Öffnet den Dialog zur Auswahl der VBE-Importdatei.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Makro

Menüpunkt | Aktion
VBA-Makro neu | Legt ein neues Makro an und öffnet den VBA-Editor.
Hilfe | Öffnet die Online-Hilfe.


Grundlagen

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen

Beschreibt die Grundlagen der Programmiersprache VBA - Visual Basic for Applications

Noch in diesem Kapitel

Objekteigenschaften - PROPERTIES

Objektmethoden - METHODS

Objektereignisse - EVENTS

VBA Objektmodell in zenon

Wie setzt man VBA Makros ein?

Wie bindet man ein ActiveX - Element in zenon ein?

Zugriff über externes Programm

Funktionsweise einer OnlineVariable

Liste Status-Bits

Lasso für Auswahl Dynamischer Elemente zur Runtime


Objekteigenschaften - PROPERTIES

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Objekteigenschaften - PROPERTIES

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Objekteigenschaft (Property) ist ein bestimmtes Attribut des Objekts. Im Falle eines Variablen-Objekts kann das z.B der Wert, der Name oder die Kennung sein. Im Falle eines Kreis-Objekts etwa die Position oder die Farbe des Kreises im Bild. Jedes Objekt besitzt mindestens ein Property (in der Regel sind es mehrere), jedes Property besitzt einen bestimmten Wert. Während der Property Name ein Text ist, besitzt der Property Value einen Wert zwischen 0 und z.B. 1000.

Das Besondere an Properties ist, daß sie durch Ändern der Eigenschaftswerte in einem VBA-Programm das Verhalten oder Aussehen des Objekts verändern können. Geben Sie etwa dem Property Value (Wert) des Variablenobjekts einen anderen Wert, erreichen Sie dadurch, dass die aktuell selektierte Variable den von Ihnen gewünschten Wert erhält. Nicht jedem Property können Sie einen neuen Wert geben. So ist Property Count (Anzahl) des Variablenobjekts fix, denn die Anzahl der Variablen wird durch die angelegten Variablen bestimmt. Indem Sie Count einen höheren Wert geben, fügen Sie keine neuen Variablen hinzu. Einige Properties sind daher Nur-Lese-Eigenschaften, d.h. ihr Wert kann nur gelesen werden.


Objektmethoden - METHODS

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Objektmethoden - METHODS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Neben den Properties kann jedes Objekt Methoden besitzen. Eine Methode ist kein Attribut, sondern eine Aufforderung an das Objekt, etwas zu tun. So besitzt eine Form die Methode Show. Was bewirkt diese Methode? Sie fordert die Form auf, sich am Bildschirm darzustellen. Entsprechend verschwindet die Form, unter Verwendung des Unload-Befehls wieder.

Der Vorteil einer Methode ist, dass der Programmierer nichts über den Aufbau des Objekts wissen muss und vor allem keine Gelegenheit erhält, an den internen Daten des Objekts zu drehen.

Der Aufruf der Show-Methode bzw. des Unload-Befehls sieht wie folgt aus:

frmSollwert.Show bzw. Unload frmSollwert

Wenn Sie zum Beispiel eine andere Form aufschalten wollen, bleibt die Methode gleich, es ändert sich lediglich der Name der Form (Objektname).

frmChange.Show bzw. Unload frmChange

Ein und dieselbe Methode kann daher auf verschiedene Objekttypen angewendet werden. Jedoch nicht alle Objekte müssen zwangsläufig Methoden besitzen.


Objektereignisse - EVENTS

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Objektereignisse - EVENTS

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auch wenn Sie sich beim Umgang mit Objekten zu 90% mit Properties und Methoden beschäftigen, gibt es noch eine dritte Kategorie von Merkmalen, über die ein Objekt verfügen kann: Events. Einige Objekte in der Objekthierarchie können auf Events reagieren. Events passieren beim Arbeiten mit zenon von alleine.

Example Beispiel

Wann immer ein Bild aufgeschalten wird, wird in dem dahinterstehenden Picture-Objekt ein Open-Event ausgelöst. Als Programmierer können Sie innerhalb der sogenannten Ereignissprozedur (Prozedur, die bei Eintreten eines Ereignisses aufgerufen wird) Anweisungen festlegen, die bestimmen, was in diesem Fall passieren soll. Ein Beispiel dafür ist die Änderung einer Variablen. Man könnte ein Event, welches auf die Wertänderung einer Variablen reagiert, erzeugen.


VBA Objektmodell in zenon

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> VBA Objektmodell in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Grundsätzlich gibt es in der Projektstruktur immer wieder eine Objektliste und Objekte.

Beispiel:

Projects – Project

Variables – Variable

Elements – Element

Mehr zum Objektmodells finden Sie:

  • in der VBA-Hilfe

  • in der grafischen Übersicht, die Sie bei COPA-DATA komplett als gedruckte Übersicht erhalten

  • im Object-Browser von VBA


Wie setzt man VBA Makros ein?

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Wie setzt man VBA Makros ein?

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein neues Makro zu erstellen, wählt man im Fenster Projektinfo in der Registerkarte Makro Browser ein gewünschtes Ereignis, bei dem das neue Makro ausgeführt werden soll.

Durch Klicken der rechten Maustaste auf dieses Ereignis, öffnet sich ein Menü.

Wählen Sie den Menüpunkt Makro neu. Dadurch wird von zenon eine Prozedur generiert:

Public Sub LeftClickUp_Sollwert(obElem As Element)
End Sub

Wenn bereits ein Makro besteht, kann dieses durch Anklicken mit der rechte Maustaste, bearbeitet, gelöscht oder umbenannt werden.

attention Achtung

Wenn Sie den Menüpunkt Makro umbenennen wählen, achten Sie darauf, dass Sie nicht den Namen des Ereignisses - z.B.: LeftClickUp_..., - des derzeitigen Namens ändern. Ansonsten wird die Namensänderung nicht durchgeführt. Außerdem müssen Sie, wenn Sie den Makronamen ändern, auch den Namen des aufzurufenden Unterprogramms per Hand im VBA-Editor ändern.

Nachdem man die von zenon generierte Prozedur mit dem auszuführenden Quellcode gefüllt hat, muss man das erzeugte Makro mit einem Element verbinden.

Durch einen Doppelklick auf ein gewünschtes Element, erscheinen die Element-Eigenschaften auf dem Bildschirm.

Auf der Registerkarte Ereignisse, verbindet man das Makro mit dem Element.

Durch einen Klick mit der linken Maustaste, wird das Ereignis LeftClickDown des Elements ausgelöst und das verbundene Makro ausgeführt.

Noch in diesem Kapitel

Einbinden von bereits bestehenden Makros


Einbinden von bereits bestehenden Makros

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Wie setzt man VBA Makros ein? -> Einbinden von bereits bestehenden Makros

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um bereits bestehende Makros in ein anderes Projekt einzubinden, gehen Sie so vor:

  1. Exportieren Sie im VBA-Editor alle benötigten Formulare und Module und importieren diese in das gewünschte Projekt.
  2. Ereignisbezogene Makros, in ModulElement.bas, werden jetzt noch nicht im Makro Browser angezeigt. Darum müssen Sie jetzt die Makros im Makro Browser neu anlegen.

    Am einfachsten ist es, wenn Sie den Namen des bereits bestehenden Makros verwenden.

    z.B..
    LeftClickUp_ DateSet2
    LeftClickUp_ DateSet4
    LeftClickUp_ TimeSet
    Draw_ Date2
    Draw_ Date4
    Draw_ Time

  3. Beim Anlegen von Makros, generiert zenon Prozeduren, die den gleichen Namen haben wie die bereits bestehenden Makros. Diese neu generierten Prozeduren müssen Sie löschen.
  4. Verbinden Sie die Makros wie gewohnt mit einem Dynamischen Element.

info Info

Wenn der Simulator-Mode des SAIA-Treibers verwendet wird, aber die Hardware nicht angeschlossen ist, vergessen Sie nicht, den Treiber zu stoppen.


Wie bindet man ein ActiveX - Element in zenon ein?

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Wie bindet man ein ActiveX - Element in zenon ein?

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein ActiveX-Element wird wie ein Dynamisches Element einfach in einem Bild auf die gewünschte Größe aufgezogen, es öffnet sich ein Fenster, in dem Sie ein ActiveX-Element auswählen müssen.

  • Wenn in der oben dargestellten Liste das Element ausgewählt wurde, können Sie diesem eine Variable zuordnen. Dazu klicken Sie auf den Button Variable... und wählen Sie eine Variable aus bzw. legen eine neue an.
  • Als nächsten Schritt geben wir unserem ActiveX-Element einen Objektnamen, über diesen wir später in VBA darauf zugreifen können.
  • In unserem Beispiel vergeben wir den Objektnamen Slider6_DW18, da es sich um ein Slider-ActiveX-Element handelt, das mit der Variable Datenwort 18 verknüpft ist.
  • Nun muss das Slider-Element über den VBA-Editor aktiviert und weiterbearbeitet werden.
  • Dazu legen wir ein neues Makro an, wie bereits im Kapitel "Wie setzt man VBA Makros ein?" beschrieben.

Das Makro Init_Slider übergibt das zu initialisierende Element an ein Unterprogramm im Objekt thisProject, wodurch ein Projektbezug auf das aktuelle Projekt hergestellt wird:

Public Sub Init_Slider(obElem As Element)
thisProject . Init _ Slider obElem
End Sub

Wie im Makro Init_Slider wird auch im Draw_SliderValue, das Element dem Objekt thisProject übergeben.

Public Sub Draw_SliderValue (obElem As Element, ByVal hdc As OLE _ HANDLE )
thisProject.Draw_Slider obElem
obElem.Draw hdc
End Sub

Im Objekt thisProject wird der unten angeführte Quellcode eingetragen.

Public Declarations
Public WithEvents obSlider As Slider
Public obSliderPV As Variable
Public Sub Init_Slider (obElem As Element)
Set obSlider = obElem.ActiveX

'ActiveX exists
If obSlider Is Nothing Then
Exit Sub
End If
Set obSliderPV = obElem . ItemVariable(0)
'variable exists
If obSliderPV Is Nothing Then
Exit Sub
End If
obSlider.Max = obSliderPV.RangeMax
obSlider.Min = obSliderPV.RangeMin
obSlider.TickFrequency = 1000
obSlider.LargeChange = 25
obSlider.SmallChange = 1
obSlider.Value = obSliderPV.Value

End Sub

Public Sub Draw _ Slider ( obElem As Element )
Dim vVar As Variant
Dim obDynPic As DynPicture

Set obSliderPV = obElem.ItemVariable ( 0 )
Set obDynPic = thisProject.DynPictures. Item (BILD_1)
'variable exists
If obSliderPV Is Nothing Then
Exit Sub
End If


Zugriff über externes Programm

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Zugriff über externes Programm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um über ein externes Programm wie zum Beispiel Visual Basic auf zenon Daten zugreifen zu können wird die COM-Schnittstelle verwendet. Diese COM-Schnittstelle ist jene, die auch von VBA verwendet wird. Es gibt also nur ein paar kleine Unterschiede, die aber bedacht werden müssen.

Noch in diesem Kapitel

Visual Basic 6


Visual Basic 6

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Zugriff über externes Programm -> Visual Basic 6

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um auf die COM-Schnittstelle zugreifen zu können, muss diese eingebunden weden:

Mittels dieser Typelibrary kommt man auf das zenon Applicationsobjekt (die Runtime).

Da es hier kein thisProject - Objekt gibt, muss man dieses erstellen um an die Daten zu kommen.

Dim obProject As zenon.Project
Set obProject = zenon.Application.Projects.Item(PROJEKTNAME)

Wenn das VB-Projekt bei allen zenon Projekten funktionieren und sozusagen unabhängig vom Projektnamen sein soll, kann es auch so gesetzt werden:

Set obProject = zenon.Application.Projects.Item(0)

Wenn das Projektobjekt (thisProject) angelegt wurde, kann zum Beispiel auf die Variablen lesend und schreibend zugegriffen werden.

Lesen:

Wert = obProject.Variables.Item(Variablenname).Value

Schreiben:

obProject.Variables.Item(Variablenname).Value = Wert


Funktionsweise einer OnlineVariable

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine VBA - OnlineVariable kann man sich wie einen Container vorstellen, dieser Container beinhaltet Variablen, die natürlich hinein gegeben werden müssen. Ändert sich nun der Wert einer im Container befindlichen Variablen, wird dies durch ein Ereignis bekanntgegeben.

Noch in diesem Kapitel

Funktionsweise des Ereignisses

Container definieren und anlegen

Variablen in den Container geben

Ereignis anlegen

Ereignis aktivieren

Ausschalten des Ereignisses

Entfernen beim Beenden


Funktionsweise des Ereignisses

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable -> Funktionsweise des Ereignisses

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn der Container aktiviert wird (Container.Define), werden alle im Container befindlichen Variablen einmal angereizt, damit der aktuelle Wert der Variablen bekannt wird. Es wird also die Prozedur „Container_VariableChange“ für jede im Container befindliche Variable einmal ausgeführt. Wenn alle Variablen dann initialisiert wurden, tritt das Ereignis immer dann in Kraft, wenn sich im Container der Wert einer Variablen ändert.

Es ist somit ausgeschlossen, dass ein Wert ausgelesen wird, der nicht dem aktuellen Wert der Variable entspricht.


Container definieren und anlegen

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable -> Container definieren und anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Definition:

Public WithEvents Container As OnlineVariable

Mit dieser Codezeile wird der Container definiert.

Anlegen:

Set Container = thisProject . OnlineVariables . CreateOnlineVariables ( Containername )


Variablen in den Container geben

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable -> Variablen in den Container geben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Container . Add Variablenname1
Container . Add Variablenname2
Container . Add Variablenname3
Container . Add Variablenname4
...

Dieser Vorgang wird solange wiederholt, bis sich alle gewünschten Variablen im Container befinden.


Ereignis anlegen

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable -> Ereignis anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Private Sub Container_VariableChange(ByVal obVar As zenon.IVariable)

...

End Sub

Dieses Ereignis wird automatisch angelegt, wenn in der linken Combobox am oberen Rand des BA-Editors der Container ausgewählt wird. Es wird dann die obige Prozedur in den Sourcecode eingefügt. Es wird mittels „obVar“ die Variable mitgegeben, deren Wert sich geändert hat. Es kann beim Eintreten des Ereignisses dann z.B. der aktuelle Wert abgefragt werden (ob-Var.Value). Welche Eigenschaften und Werte von der Variablen abgefragt werden können, ist aus der Objekthierarchie in der VBA-Dokumentation ersichtlich.


Ereignis aktivieren

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable -> Ereignis aktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Container.Define

Diese Befehlszeile aktiviert die Überwachung der Variablen im Container. Erst wenn der Befehl „Define“ ausgeführt wird, ist der Container aktiv.


Ausschalten des Ereignisses

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable -> Ausschalten des Ereignisses

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Container.Undefine

Mit diesem Befehl wird die Überwachung im Container wieder abgeschaltet, das Ereignis (VariableChange) wird ab diesem Zeitpunkt nicht mehr ausgeführt.


Entfernen beim Beenden

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Funktionsweise einer OnlineVariable -> Entfernen beim Beenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um beim Beenden der Runtime wirklich nichts mehr im Speicher zu lassen, muss der Container spätestens beim Beenden der Runtime wieder entfernt werden.

thisProject . OnlineVariables . DeleteOnlineVariables ( Containername )

Erst wenn dieserer Container gelöscht wurde, kann ein anderer Container mit dem gleichen Namen neu angelegt werden.


Liste Status-Bits

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Liste Status-Bits

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Details zur Statusverarbeitung lesen Sie im Kapitel Statusverarbeitung.


Lasso für Auswahl Dynamischer Elemente zur Runtime

Handbuch -> Programmierschnittstellen -> VBA -> Grundlagen -> Lasso für Auswahl Dynamischer Elemente zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dynamische Elemente, die mit einer Variablen oder Funktion verknüpft sind, können zur Runtime mit dem Lasso vorausgewählt und damit für Events genutzt werden.

Mit der Methode SelElements können zur Runtime vom Bediener selektierte Dynamische Elemente als ausgewählt identifiziert werden. Diese DynPicture.SelElements können dann für Events wir Drag&Drop benutzt werden.

Selektion per Lasso

Um zur Runtime Elemente mit dem Lasso auszuwählen muss:

  • in den Projekteigenschaften die Eigenschaft Runtime Einstellungen/Runtime Lasso aktiv sein

    Interne ID: Lasso für Auswahl Dynamischer Elemente zur Runtime

    Runtime Lasso

    Aktiv: Durch Bewegen der Maus mit gedrückter linker Maustaste können in der Runtime mehrere Elemente selektiert werden. Auf diese Elemente kann dann ein VBA-Makro zugreifen.
    Inaktiv: Die Lassofunktionalität wird nicht verwendet.
    Default: inaktiv
    Hinweis: Lasso funktioniert nur für Elemente, die 'Über Tastatur erreichbar' sind und mit denen eine Variable oder Funktion verknüpft ist. Statische Elemente werden nicht ausgewählt. Die Lassofunktion kann für einzelne Bildelemente über die Eigenschaft Runtime/mit Lasso auswählbart aktiviert oder deaktiviert werden.

    Interne ID: Lasso für Auswahl Dynamischer Elemente zur Runtime

    mit Lasso auswählbar

    Die Auswahl per Lasso zur Runtime ermöglicht die Identifizierung von Dynamischen Elementen für die Verwendung mit VBA Events.
    Aktiv: Das Element kann zur Runtime mit dem Lasso ausgewählt werden.
    Inaktiv: Das Element kann zur Runtime nicht ausgewählt werden.
    Default: aktiv

    Achtung: Damit das Element zur Runtime auswählbar ist, muss zusätzlich in den Projekteigenschaften die Eigenschaft Runtime Einstellungen/Runtime Lasso aktiviert sein!

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Lasso für Auswahl Dynamischer Elemente zur Runtime

    Runtime

    Eigenschaften für das Runtime-Verhalten des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Lasso für Auswahl Dynamischer Elemente zur Runtime

    Runtime Einstellungen

    Eigenschaften für das Runtime-Verhalten des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • in den Eigenschaften des Dynamischen Elements die Eigenschaft Runtime/mit Lasso auswählbar aktiv sein

Zur Runtime stehen mehrere Methoden zur Auswahl von Elementen zur Verfügung:

  • Elemente auswählen: Linksklick in einen freien Bildbereich und mit gedrückter Maustaste das Lasso über Bildelemente ziehen.
  • Auswahl erweitern: Strg+Mausklick auf ein Element, um es zusätzlich zu selektieren/deselektieren
  • Elemente hinzufügen: Beim Lasso aufspannen Strg gedrückt halten fügt neue Elemente zur bestehenden Selektion hinzu.
  • Auswahl aufheben: Ein Lasso aufspannen, das keine Elemente enthält.


Makros im Editor

Handbuch -> Programmierschnittstellen -> VBA -> Makros im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Makros können im Editor über eine konfigurierbare Symbolleiste ausgeführt werden. Dazu werden Makros mit Schaltflächen in der Symbolleiste VBA verknüpft.

Weiters können Makros natürlich manuell über den VBA Editor ausgeführt werden.

Mit Wizards können immer wiederkehrende Projektierarbeiten automatisch ausgeführt oder ganze Projekte auf Knopfdruck erstellt werden. Exemplarisch werden schon einige Wizards mit zenon ausgeliefert, die nach Belieben erweitert und ergänzt werden können. Sie helfen bei der Erstellung von Projekten, beim Import und Export, bei der Variablenerstellung und vielem mehr. Details dazu finden Sie im Kapitel Wizards.

Editor-Events

Editor-Events sind Bestandteil des VBA-Workspace und ermöglichen es, auf Events in der Workspace-Programmierung zu reagieren, z.B. für Wizards oder Remote Transport. Zum Beispiel:

  • OnElementCreated
  • OnElementDeleted
  • OnElementDoubleClicked
  • OnObjectCreated
  • ...

Alle Events und Informationen dazu finden Sie in der Hilfe zum Object Model.

Noch in diesem Kapitel

Symbolleiste VBA-Makros

Zuordnung der Makros


Symbolleiste VBA-Makros

Handbuch -> Programmierschnittstellen -> VBA -> Makros im Editor -> Symbolleiste VBA-Makros

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Makros, die mit VBA erstellt wurden, können über die Symbolleiste VBA verwaltet werden.

Symbol (von links nach rechts) | Funktion
Liste der VBA-Makros neu laden | Lädt alle in myWorkspace und in Modulen enthaltenen Public Sub Name () Makros in die Dropdownliste der Symbolleiste.
Dropdownliste Makros | Enthält alle geladenen Makros zur Auswahl.
Ausgewähltes Makro ausführen | Führt das in der Dropdownliste ausgewählte Makro aus.
Zugeordnetes Makro #<x> ausführen | Führt das dem Symbol zugeordnete Makro aus.
Makros zuordnen | Öffnet den Dialog für die Zuordnung von Makros. Bis zu 5 Makros können mit den Symbolen 1 bis 5 verknüpft werden.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

info Info

Werden im Makro-Zuordnungsdialog nicht alle in myWorkspace enthaltenen Makros zur Auswahl angeboten, dann führen Sie in der Symbolleiste die Funktion Liste der VBA-Makros neu laden aus.


Zuordnung der Makros

Handbuch -> Programmierschnittstellen -> VBA -> Makros im Editor -> Zuordnung der Makros

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Makros können über eine Schaltfläche in der Symbolleiste aufgerufen werden. Maximal fünf Makros können so verknüpft werden. Über die Schaltfläche Makros zuordnen wird der Dialog zur Makrozuordnung geöffnet.

Parameter | Beschreibung
Makro # | Makro-Nummer entspricht Nummer der Schaltfläche in der Symbolleiste. Klick auf ... öffnet Dialog zur Auswahl des Makros.
OK | Erstellt Verknüpfungen zu den Schaltflächen und schließt den Dialog.
Abbrechen | Verwirft alle Änderungen und schließt den Dialog.
Hilfe | Öffnet die Online-Hilfe.

Parameter | Beschreibung
Vorhandene Auswahl | Liste der Makros, die verknüpft werden können.
Keine Auswahl | Löscht vorhandene Zuordnung für diese Schaltfläche.
OK | Ordnet gewähltes Makro der Schaltfläche zu.
Abbrechen | Verwirft alle Änderungen und schließt den Dialog.
Hilfe | Öffnet die Online-Hilfe.


Entwicklung von Wizards in VBA

Handbuch -> Programmierschnittstellen -> VBA -> Entwicklung von Wizards in VBA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6 ist es möglich, die Projektierung von Projekten über Wizards zu automatisieren. Dadurch können oft zu wiederholende Tätigkeiten in einen Wizard ausgelagert werden, der die gewünschten Aktionen durchführt, z.B. Anlegen eines Projekts, Erstellen der Schablonen und Bilder nach einem definierten Standard.

Eine andere Einsatzmöglichkeit für Wizards sind automatisierte Änderungen an einem bestehenden Projekt, z.B. Änderung von Eigenschaften dynamischer Elemente in allen Bildern eines bestehenden Projekts.

Als Basis für die Wizards dienen Microsoft Visual Basic for Applications (VBA) und das zenon Objektmodell.

Derzeit stehen folgende Wizards zur Verfügung:

  • Project-Wizard
  • Import-Wizard
  • World view wizard
  • Find VBA-Text wizard
  • Wizard for keyword-creation
  • Wizard for keyword-translation
  • Wizard for creating variables

Die Wizards stehen als VBA-Quellcode Dateien auf der Installations-DVD zur Verfügung. Neue Wizards können über die VBA-Umgebung eingebunden werden.

Noch in diesem Kapitel

Verwendung eines Wizards

Aufbau eines Wizards

Integration in VBA

Entwicklung eines Wizards

Aktualisierung von Wizards


Verwendung eines Wizards

Handbuch -> Programmierschnittstellen -> VBA -> Entwicklung von Wizards in VBA -> Verwendung eines Wizards

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Menü befehl Wizards im Menü Datei öffnet die Wizard-Auswahl. In diesem Dialog werden alle freigeschaltenen Wizards nach Ihrer Kategorie angezeigt.

Sollten Wizards keine Kategorie beinhalten, so wird automatisch ein Eintrag Nicht verknüpft erstellt. Unter diesem Eintrag werden alle nicht-verknüpften Assistenten aufgelistet.

Durch Auswahl eines Wizards und Betätigen der OK-Schaltfläche wird der ausgewählte Wizard aktiviert.

info Info

Wizards unterstützen nur single user project und keine multi-user Umgebung.


Aufbau eines Wizards

Handbuch -> Programmierschnittstellen -> VBA -> Entwicklung von Wizards in VBA -> Aufbau eines Wizards

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Wizard ist eine UserForm, die im applikationsspezifischen Knoten der Applikation abgelegt wird. Diese UserForm besteht in der Regel aus einem Multiseiten-Element, in dem die einzelnen Schritte des Wizards dargestellt werden.

Durch eine Weiter Schaltfäche wird die nächste Seite des Multiseiten-Elements angezeigt. Alle Eingaben müssen temporär abgelegt werden - die Erstellung von Objekten, z.B. Schablonen, Bilder, ... darf erst beim Fertig stellen des Wizards erfolgen.

info Info

UserForms, die als Wizard verwendet werden sollten, müssen einige public Methoden enthalten, die die Informationen über den Wizard an das Leitsystem liefern. Fehlen diese Routinen in einer UserForm, so wird diese nicht als Wizard behandelt.


Integration in VBA

Handbuch -> Programmierschnittstellen -> VBA -> Entwicklung von Wizards in VBA -> Integration in VBA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Wizards sind im applikationsspezifischen Knoten ZWorkspace untergebracht. Dieses Objekt stellt den geladenen Workspace im Editor dar und steht nur im zenon Editor zur Verfügung.

Alle Objekte in diesem VBA-Projekt können über das MyWorkspace-Objekt auf den aktuellen Workspace zugreifen. Dieser ist immer mit dem derzeit aktiven Projekt verknüpft, auf dass Sie über die ActiveDocument-Eigenschaft zugreifen können.

Die Inhalte des ZWorkspace-Objekts sind in der Datei ZenWorkspace.vba enthalten. Diese wird mit der erstmaligen Installation der Version 6 ins Installationsverzeichnis kopiert. Durch später folgende Updates wird diese Datei nicht überschrieben. Zur Aktualisierung von Wizards erhalten Sie am Ende des Tutorials weitergehende Informationen.


Entwicklung eines Wizards

Handbuch -> Programmierschnittstellen -> VBA -> Entwicklung von Wizards in VBA -> Entwicklung eines Wizards

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Tutorial erstellt einen Wizard zum Anlegen von Variablen zu einem projektierten Treiber.

Starten Sie die VBA-Umgebung aus dem zenon Editor und wechseln Sie in den Ordner ZWorkspace/Formulare. Diese Datei enthält die Grundlagen für die Entwicklung eines Wizards. Ändern Sie den Namen der UserForm.

Sollte der Wizard in dem oben genannten Ordner nicht zur Verfügung stehen, können Sie diesen über den Befehl Datei importieren importieren.

info Info

Zur Entwicklung eines Wizards sind Kenntnisse über das zenon Objektmodell und VBA erforderlich. Diese Themane werden in diesem Tutorial nicht näher erläutert.

Erstellen Sie die oben dargestellte Oberfläche. Wechseln Sie anschließend ins Code-Modul der UserForm und scrollen Sie bis ans Ende der Datei. Dort befinden sich folgende Methoden:

  • Public Function GetWizardName () As String

    Liefert den eindeutigen Namen des Wizards zurück. Ändern Sie den Inhalt in Wizard for creating variables

  • Public Function GetWizardInfo () As String

    Liefert eine kurze Beschreibung, die in der Wizard-Auswahl angezeigt wird, zurück. Ändern Sie den Inhalt in Wizard for creating variables to a selected driver

  • Public Function GetWizardCategory () As String

    Liefert die Kategorie des Wizards zurück. In der Wizardauswahl werden die Wizards kategorisiert in einer Baumstruktur dargestellt. Ändern Sie den Inhalt in Variables.

  • Public Function IsZenOnWizard () As Boolean

    Anzeigen des Wizards in der Wizardauswahl. Liefert diese Methode False zurück, so wird der Wizard nicht angezeigt, z.B. weil dieser noch nicht fertig ist. Ändern Sie den den Returntypen auf True.

Diese Methoden lieferen die Informationen über den Wizard, die vom Leitsystem abgefragt werden. Zu beachten ist, dass ein Wizard nur in der Wizard Auswahl angezeigt wird, wenn die Methode IsZenOnWizard True zurückliefert.

Wechseln Sie in das Initialize-Ereignis der UserForm und ändern Sie die Inhalte des String-Arrays m_strCaption. Da unser Wizard nur aus zwei Schritten besteht, können Sie die anderen Zuweisungen löschen.

Fügen Sie folgende Definitionen im oberen Bereich des Code-Moduls ein:

Private m_obDriver As Driver
Private m_obVarType As VarType
Private m_nChannelType As Integer

Erstellen Sie eine Methode zum Initialisieren der Treiber-Combobox. Aufgabe der Routine ist es, alle projektierten Treiber des aktuellen Projekts in der ComboBox darzustellen.

cbDriver.Clear
Dim nIndex As Long
For nIndex = 0 To MyWorkspace.ActiveDocument.Drivers.Count - 1
Dim obDriver As Driver
Set obDriver = MyWorkspace.ActiveDocument.Drivers.Item(nIndex)
If (Not obDriver Is Nothing) Then
cbDriver.AddItem
obDriver.Name
End If
Next nIndex
If (cbDriver.ListCount > 0) Then
cbDriver.ListIndex = 0
End If

Weiters benötigen wir eine Routine, die alle projektierten Variablentypen des Projekts in einer ComboBox darstellt.

If (Not m_obDriver Is Nothing) Then
cbVarType.Clear
Dim nIndex As Long , nSelect As Integer
For nIndex = 0 To MyWorkspace.ActiveDocument.VarTypes.Count - 1
Dim obVarType As VarType
Set obVarType = MyWorkspace.ActiveDocument.VarTypes.Item(nIndex)
If ( Not obVarType Is Nothing And obVarType.IsSimple = True) Then
cbVarType.AddItem
obVarType.Name
If (obVarType.Name = INT) Then
nSelect = nIndex
End If
End If
Next nIndex
cbVarType.ListIndex = nSelect
End If

Beim Aufschalten des Wizards werden die bereits projektierten Variablen durchlaufen, um nach einem freien Start-Offset für die neu zu erstellenden Variablen zu suchen. Dies geschieht über die folgende Methode.

Private Function FindHighestOffsetVar() As Long
On Error GoTo Error
Dim nIndex As Long , nOffset As Long
For nIndex = 0 To MyWorkspace.ActiveDocument.Variables.Count - 1

Dim obVar As Variable
Set obVar = MyWorkspace.ActiveDocument.Variables.Item(nIndex)
If ( Not obVar Is Nothing) Then
If (obVar.Offset > nOffset) Then
nOffset = obVar.Offset
End If
End If
Next nIndex
FindHighestOffsetVar = nOffset
Exit Function
Error : MsgBox
Error occurs: + Err.Description + Source + Err.Source
End Function

Wechseln Sie ins Intialize-Ereignis der UserForm und erweitern Sie diese Methode um folgende Zeilen:

txtStart.Value = CStr(FindHighestOffsetVar + 1)

InitializeDriver

Die Zuweisung auf txtStart setzt den vorgeschlagenen Start-Offset für die zu erstellenden Variablen. Über die Methode InitializeDriver wird die ComboBox mit den projektierten Treibern gefüllt.

Erstellen Sie ein Change-Ereignis für die Treiber-Combobox und fügen Sie folgenden Code ein. Nach Auswahl eines Treibers werden die Variablentypen ermittelt. Das ausgewählte Treiber-Objekt wird in der Variable m_obDriver für die spätere Verwendung abgelegt.

Private Sub cbDriver_Change()
cmdNext.Enabled = True
Set m_obDriver = MyWorkspace.ActiveDocument.Drivers.Item(cbDriver.Value)
If ( Not m_obDriver Is Nothing) Then
InitializeVarType
End If
End Sub

Erstellen Sie eine Ereignisbehandlung Change für die VarType-Combobox und fügen Sie folgenden Code ein. Der ausgewählte Variablentyp wird in der Variable m_obVarType für die spätere Verwendung abgelegt.

Private Sub cbVarType_Change()
Set m_obVarType = MyWorkspace.ActiveDocument.VarTypes.Item(cbVarType.Value)
End Sub

Nun müssen wir nur mehr die Ereignisroutine zum Erstellen der Variablen mit den getroffenen Einstellungen erstellen. Dies geschieht über die Finish-Schaltfläche.

Private Sub cmdFinish_Click()
On Error GoTo Error
If (cbVarType.ListIndex = -1) Then
MsgBox 'Please select a variable type'
cbVarType.SetFocus
Exit Sub
End If
If (txtStart.Value = Or txtCount.Value = Or txtStep.Value = ) Then
MsgBox 'Please enter Start-Offset', 'count of creating variables and the step'
txtStart.SetFocus
End If
If (m_obVarType Is Nothing) Then
MsgBox 'Variable type + cbVarType.Name + doesnt exist!'
Exit Sub
End If
Dim nPrvMousePtr As Integer
nPrvMousePtr = MousePointer
MousePointer = fmMousePointerHourGlass
DoEvents
Dim strName As String
Dim nIndex As Long , nVarIndex As Integer
Dim nStartOff As Long , nStep As Integer
nVarIndex = 1
nStartOff = CLng (txtStart.Value)
nStep = CLng (txtStep.Value)
For nIndex = 0 To CLng (txtCount.Value - 1)
Dim obVar As Variable
strName = txtName.Value + _ + CStr (nIndex + 1)
'*** Guaranteeing uniqueness of the variable name
Dim bResult As Boolean
bResult = False
Do
Set obVar = MyWorkspace.ActiveDocument.Variables.Item(strName)
If (obVar Is Nothing) Then
bResult = True
Else
nVarIndex = nVarIndex + 1
strName = txtName.Value + _ + CStr (nVarIndex)
End If
Loop While
bResult = False
'*** Create variable
Set obVar = MyWorkspace.ActiveDocument.Variables.CreateVar (strName, m_obDriver, tpSPSMerker, m_obVarType)
If ( Not obVar Is Nothing) Then
obVar.Offset = nStartOff
nStartOff = nStartOff + nStep
End If
Next nIndex
MousePointer = nPrvMousePtr
Unload Me
Exit Sub
Error :
MousePointer = nPrvMousePtr
MsgBox Error occurs: + Err.Description + Source + Err.Source
End Sub

Beim Fertig stellen des Wizards wird überprüft, ob die getroffenen Einstellungen gültig sind. Ist dies nicht der Fall, so wird eine Fehlermeldung ausgegeben und der User aufgefordert, die Fehleingabe zu korrigieren.

Sind die getroffenen Einstellungen in Ordnung, so werden die Variablen erstellt. Die Variablen werden mit einem Namen und dem Index benannt. Existiert bereits eine gleichnamige Variable im Projekt, so wird der nächste freie Index ermittelt. In unserem Code-Beispiel wird immer eine Variable vom Kanaltyp SPS-Merker erstellt. Mit jedem Schleifendurchlauf wird der Offset für die Variable erhöht.


Aktualisierung von Wizards

Handbuch -> Programmierschnittstellen -> VBA -> Entwicklung von Wizards in VBA -> Aktualisierung von Wizards

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Wizards zu aktualisieren,:

  1. wählen Sie im Menü Datei den Eintrag Update Wizards
  2. ein Dialog zum Update vorhandener Wizards wird geöffnet
  3. wählen Sie die gewünschten Wizards aus
  4. schalten Sie mit Klick auf Update starten das Update

Ist ein Wizard oder eine Klasse bereits im Arbeitsbereich vorhanden, wird eine Warnungs anzeigt.

attention Achtung

Bereits vorhandene Wizards werden beim Update überschrieben. Individuelle Änderungen am Wizard gehen damit verloren.


Frequently asked Questions

Handbuch -> Programmierschnittstellen -> VBA -> Frequently asked Questions

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Kapitel werden einige häufig gestellte Fragen beantwortet. Weiter Lösungen finden Sie auch online im COPA-DATA Anwender-Forum.

Noch in diesem Kapitel

Warum bleibt der Button gedrückt?

Makro wird nicht beim 1. Klick ausgeführt

Makros funktionieren in der RT nicht mehr?

Windows CE und VBA


Warum bleibt der Button gedrückt?

Handbuch -> Programmierschnittstellen -> VBA -> Frequently asked Questions -> Warum bleibt der Button gedrückt?

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein Button z.B. mit einem LeftClickUp - Ereignis verknüpft ist, muss am Ende der Prozedur das LeftClickUp ausgeführt werden.

Public Sub LeftClickUp_Schalter(obElem As Element)
frmSchalter.Show

obElem.LeftClickUp
End Sub


Makro wird nicht beim 1. Klick ausgeführt

Handbuch -> Programmierschnittstellen -> VBA -> Frequently asked Questions -> Makro wird nicht beim 1. Klick ausgeführt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Lösung entspricht der aus der Frage: Warum bleibt der Button gedrückt:

Wenn ein Button z.B. mit einem LeftClickUp - Ereignis verknüpft ist, muss am Ende der Prozedur das LeftClickUp ausgeführt werden.

Public Sub LeftClickUp_Schalter(obElem As Element)
frmSchalter.Show

obElem.LeftClickUp
End Sub


Makros funktionieren in der RT nicht mehr?

Handbuch -> Programmierschnittstellen -> VBA -> Frequently asked Questions -> Makros funktionieren in der RT nicht mehr?

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Effekt kann auftreten, wenn in der Runtime der VBA-Editor geöffnet ist und dann auf Stop/Start gedrückt wird um VBA zu stoppen/starten. Es werden in diesem Fall die Objekte (OnlineVariablen, Bildobjekte,...) ungültig, da diese den Bezug verlieren wenn eine erneute Initialisierung stattfindet.


Windows CE und VBA

Handbuch -> Programmierschnittstellen -> VBA -> Frequently asked Questions -> Windows CE und VBA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VBA steht im CE-Editor für Wizards zur Verfügung. In der Runtime wird VBA nicht unterstützt. Details zum Editor finden Sie im Kapitel Projekte für CE erstellen.


Beispiele

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele

Hier finden Sie einige Beispiele für VBA

Noch in diesem Kapitel

MouseEvents and ActiveX Control initialization

Variableninformationen anzeigen

Variablenwerte lesen und schreiben

Variablen lesen und schreiben und Online Variablen implementieren

Dialog mehrfach nutzen

Alarm – Events and ActiveX Control handling

Zugriff auf Alarme

Schalter setzen (Arbeiten mit Prozessvariablen)


MouseEvents and ActiveX Control initialization

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> MouseEvents and ActiveX Control initialization

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Option Explicit

Public Sub Init_ActiveX(obElem As Element)

'Initializing ActiveX...

thisProject.Init_MSChart_AX obElem

End Sub

Public Sub LeftClickUp_Sample1(obElem As Element)

'Initializing Userform...

frmSample1.InitForm obElem

'Show Userform

frmSample1.Show

End Sub

Public Sub LeftClickUp_Sample2(obElem As Element)

'Initializing Userform...

frmSample2.InitForm obElem

'Show Userform

frmSample2.Show

End Sub

Public Sub LeftClickUp_Sample3(obElem As Element)

'Initializing Userform...

frmSample3.InitForm obElem

'Show Userform

frmSample3.Show

End Sub

Public Sub LeftClickUp_Sample4(obElem As Element)

Dim NewForm As New frmSample4

'Initializing NEW Userform...

NewForm.InitForm obElem

'Show NEW Userform

NewForm.Show (0)

End Sub


Variableninformationen anzeigen

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> Variableninformationen anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablenname für geklicktes Element anzeigen:

Option Explicit

Dim obVar As Variable

'User defined Public Procedure for initializing Objects

Public Sub InitForm(obElem As Element)

'set the variable object like the linked variable of the element

Set obVar = obElem.ItemVariable(0)

'write variable name into the textbox

txtVarName.Text = obVar.Name

End Sub

Private Sub cmdExit_Click()

'close Userform

Unload Me

End Sub


Variablenwerte lesen und schreiben

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> Variablenwerte lesen und schreiben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Werte aus einer Variablen auslesen und zurückschreiben:

Option Explicit

Dim obVar As Variable

'User defined Public Procedure for initializing Objects

Public Sub InitForm(obElem As Element)

'set the variable object like the linked variable of the element

Set obVar = obElem.ItemVariable(0)

'write variable name into the textbox

txtVarName.Text = obVar.Name

End Sub

Private Sub cmdExit_Click()

'close Userform

Unload Me

End Sub

Private Sub cmdRead_Click()

'read value from variable and write into textbox

txtValue.Text = obVar.Value

End Sub

Private Sub cmdWrite_Click()

'write text as value to variable

obVar.Value = txtValue.Text

'or changing text to value before writing...

'obVar.Value = Val(txtValue.Text)

End Sub


Variablen lesen und schreiben und Online Variablen implementieren

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> Variablen lesen und schreiben und Online Variablen implementieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variableninformationen auslesen, Werte schreiben und Online Variablen implementieren:

Option Explicit

Dim obVar As Variable

Dim WithEvents zOnlineVariable As OnlineVariable

'User defined Public Procedure for initializing Objects

Public Sub InitForm(obElem As Element)

'set the variable object like the linked variable of the element

Set obVar = obElem.ItemVariable(0)

'write variable name into the textbox

txtVarName.Text = obVar.Name

'create an OnlineVariable container

Set zOnlineVariable = thisProject.OnlineVariables.CreateOnlineVariables("OLV")

'add variables to the container (by name of the variable)

zOnlineVariable.Add obVar.Name

End Sub

Private Sub cmdExit_Click()

'close Userform

Unload Me

End Sub

Private Sub cmdRead_Click()

'read value from variable and write into textbox

txtValue.Text = obVar.Value

End Sub

Private Sub cmdWrite_Click()

'write text as value to variable

obVar.Value = txtValue.Text

'or changing text to value before writing...

'obVar.Value = Val(txtValue.Text)

End Sub

Private Sub cmdOLV_Start_Click()

'start the OnlineVariable - Define

'the VariableChange Event will be executed

zOnlineVariable.Define

End Sub

Private Sub cmdOLV_Stop_Click()

'stop the OnlineVariable - UnDefine

'the VariableChange Event will be stopped

zOnlineVariable.Undefine

End Sub

Private Sub zOnlineVariable_VariableChange(ByVal obVar As IVariable)

'write actual value into textbox

txtOLV.Text = obVar.Value

End Sub

Private Sub UserForm_Terminate()

'the VariableChange Event will be stopped if running

zOnlineVariable.Undefine

'delete OnlineVariable container

thisProject.OnlineVariables.DeleteOnlineVariables ("OLV")

End Sub


Dialog mehrfach nutzen

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> Dialog mehrfach nutzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Userforms können mehrfach genutzt werden:

Option Explicit

Dim obVar As Variable

Dim WithEvents zOnlineVariable As OnlineVariable

Dim strOLVName As String

Public Sub InitForm(obElem As Element)

'set the variable object like the linked variable of the element

Set obVar = obElem.ItemVariable(0)

'write variable name into the textbox

txtVarName.Text = obVar.Name

'create name for Online Container

strOLVName = "OLV_" & obElem.Name

'get existing online container

Set zOnlineVariable = thisProject.OnlineVariables.Item(strOLVName)

'check if online container exists

If zOnlineVariable Is Nothing Then

'create an OnlineVariable container

Set zOnlineVariable = thisProject.OnlineVariables.CreateOnlineVariables(strOLVName)

'add variables to the container (by name of the variable)

zOnlineVariable.Add obVar.Name

End If

End Sub

Private Sub cmdExit_Click()

Unload Me 'close Userform

End Sub

Private Sub cmdRead_Click()

'read value from variable and write into textbox

txtValue.Text = obVar.Value

End Sub

Private Sub cmdWrite_Click()

'write text as value to variable

obVar.Value = txtValue.Text

'or changing text to value before writing...

'obVar.Value = Val(txtValue.Text)

End Sub

Private Sub cmdOLV_Start_Click()

'the VariableChange Event will be executed

zOnlineVariable.Define

End Sub

Private Sub cmdOLV_Stop_Click()

'the VariableChange Event will be stopped

zOnlineVariable.Undefine

End Sub

Private Sub zOnlineVariable_VariableChange(ByVal obVar As IVariable)

'write actual value into textbox

txtOLV.Text = obVar.Value

End Sub

Private Sub UserForm_Terminate()

'the VariableChange Event will be stopped if running

zOnlineVariable.Undefine

'delete OnlineVariable container

thisProject.OnlineVariables.DeleteOnlineVariables (strOLVName)

End Sub


Alarm – Events and ActiveX Control handling

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> Alarm – Events and ActiveX Control handling

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Option Explicit

Dim WithEvents obChart As MSChart

Dim WithEvents zOLV As OnlineVariable

Dim WithEvents zAlarm As Alarm

'procedure is executed on startup of the zenon runtime

Private Sub Project_Active()

'init the alarm object for events

Set zAlarm = thisProject.Alarm

End Sub

'procedure is executed when an Alarm comes

Private Sub zAlarm_AlarmComes(ByVal obItem As IAlarmItem)

Dim strInfo As String

'write specific information about the alarm into a StringVariable

strInfo = obItem.Text & " - " & obItem.Name

thisProject.Variables.Item("Var_Comes").Value = strInfo

End Sub

'procedure is executed when an Alarm has gone

Private Sub zAlarm_AlarmGoes(ByVal obItem As IAlarmItem)

Dim strInfo As String

'write specific information about the alarm into a StringVariable

strInfo = obItem.Text & " - " & obItem.Name

thisProject.Variables.Item("Var_Goes").Value = strInfo

End Sub

'procedure is executed when an Alarm was acknowledged by a user

Private Sub zAlarm_AlarmAcknowledged(ByVal obItem As IAlarmItem)

Dim strInfo As String

'write specific information about the alarm into a StringVariable

strInfo = obItem.Text & " - " & obItem.Name

thisProject.Variables.Item("Var_Acknowledged").Value = strInfo

End Sub

'procedure is executed on terminating the zenon Runtime

Private Sub Project_Inactive()

'free the alarm object

Set zAlarm = Nothing

'delete OnlineVariable for Chart actualization...

thisProject.OnlineVariables.DeleteOnlineVariables "CHART"

End Sub

'procedure for MSChart ActiveX initialization...

Public Sub Init_MSChart_AX(YourAX As Element)

Set obChart = YourAX.AktiveX

obChart.RowCount = 3

obChart.ColumnCount = 1

Set zOLV = thisProject.OnlineVariables.Item("CHART")

'does existing OnlineVariable exist?

If zOLV Is Nothing Then

'if not, create it...

Set zOLV = thisProject.OnlineVariables.CreateOnlineVariables("CHART")

zOLV.Add "Internal_UINT_001"

zOLV.Add "Internal_UINT_002"

zOLV.Add "Internal_UINT_003"

End If

zOLV.Undefine 'if not stopped, refreshing not possible

'START watching variables...

zOLV.Define

End Sub

'event on Variable change - refresh chart...

Private Sub zOLV_VariableChange(ByVal obVar As IVariable)

'setting values to display in chart control

Select Case obVar.Name

Case "Internal_UINT_001"

obChart.Row = 1

obChart.RowLabel = "Var1"

obChart.Data = obVar.Value

Case "Internal_UINT_002"

obChart.Row = 2

obChart.RowLabel = "Var2"

obChart.Data = obVar.Value

Case "Internal_UINT_003"

obChart.Row = 3

obChart.RowLabel = "Var3"

obChart.Data = obVar.Value

End Select

End Sub

'event of the Chart AX...

Private Sub obChart_DblClick()

MsgBox "You have DoubleClicked the ActiveX!"

End Sub


Zugriff auf Alarme

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> Zugriff auf Alarme

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beschreibung:

Im Formular frmAlarm kann ein Alarm der sich im Speicher befindet in einer Combobox ausgewählt werden. Nach der getroffenen Auswahl werden alle Daten den Alarm betreffend in die darunter angeordneten Textboxen eingetragen (Gruppe, Klasse, Variable, ...).

Um frmAlarm anzuzeigen, verwenden wir ein Ereignis unabhängiges Makro, da wir bei diesem Beispiel keinen Bezug zu einem Element benötigen.

Sub Alarm ()
frmAlarm.Show
End Sub

'Das Makro wird über eine Funktion Makro ausführen...ausgeführt.

'Bei Aufschalten der Form wird diese initialisiert und somit folgende Prozedur ausgeführt.Diese Prozedur ist dafür zuständig, dass die in der Form angelegte Combobox alle augenblicklich im Speicher befindlichen Alarme erhält.

Private Sub UserForm _ Initialize ()

'fill combobox with all AlarmItems
Dim i As Integer
Dim obAlarmItems As AlarmItems
Dim obAlarm As Alarm

Set obAlarm = thisProject.Alarm
Set obAlarmItems = obAlarm.AlarmItems (*)

If obAlarmItems.Count = 0 Then
MsgBox (# Alarms = 0 )
Exit Sub
End If

For i = 0 To obAlarmItems.Count - 1
cmbAlarmItems.AddItem obAlarmItems.Item ( i ). Name
Next i

txtAktiv.Text = obAlarm.Aktiv
cmbAlarmItems.Text = cmbAlarmItems.List ( 0 )
End Sub

'Wenn nun ein Alarm aus der Combobox ausgewählt wird reagiert das Change - Ereigniss der Combobox.
Private Sub cmbAlarmItems _ Change ()

'put actual properties from AlarmItem in textboxes
Dim obAlarmItems As AlarmItems
Dim obAlar As Alarm

Set obAlarm = thisProject.Alarm
Set obAlarmItems = obAlarm.AlarmItems (*)
txtComputer.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Computer
txtCountreactivated.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Countreactivated
txtName.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ). Name
txtProjectname.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Projectname
txtStatus.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Status
txtStatusreactivated.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Statusreactivated
txtTagname.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Tagname
txtTimecomes.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Timecomes
txtTimegoes.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Timegoes
txtTimequitted.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Timequitted
txtTimereactivated.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Timereactivated
txtUser.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).User
txtUsertext.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Usertext
txtValue.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).Value
tbGroup.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).AlarmGroup
tbClass.Text = obAlarmItems.Item ( cmbAlarmItems.ListIndex ).AlarmClass
End Sub


Schalter setzen (Arbeiten mit Prozessvariablen)

Handbuch -> Programmierschnittstellen -> VBA -> Beispiele -> Schalter setzen (Arbeiten mit Prozessvariablen)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Beispiel zeichnet man eine Pumpe, die aus einem Kreis und einem Dreieck besteht. Das Dreieck definieren Sie als eigenes Symbol. Darüber wird ein Multibin-Element gelegt und mit drei Bitmerker-Variablen verbunden.

Außerdem legt man fest, welche Farbe das Dreieck in der Mitte bei einer Wertänderung der Variablen bekommt.

Zunächst verbindet man das Multibin-Element mit einem Makro, das eine Form frmSchalter erscheinen lässt.

Über die Form frmSchalter kann man den Wert der drei Bitmerker-Variablen ändern.

info Info

Nur eine der drei Variablen darf den Wert 1 enthalten. (d.h. wird eine Variable auf 1 gesetzt, müssen die zwei anderen auf 0 gesetzt werden)

Um dieses Makro mehrere Male in einem Projekt mit Bezug auf verschiedene Variablen zu verwenden, dürfen Sie mit dem Multibin-Element nur Bitmerker-Variablen verbinden, die bereits im Variablennamen enthalten welchen Zustand der Pumpe sie steuern.

z.B.:
Variable_Auto
Variable_Hand
Variable_Revi

info Info

Die Endungen _Auto, _Hand und _Revi sind im Quellcode des Beispiels fix vorgegeben.

Durch diese 5-stellige Endungen der Variablennamen kann nun festgestellt werden, welche Variable beim Klick auf einen der ToggleButtons auf 1 gesetzt wird und welche auf 0.

Im Makro LeftClickUp_Schalter wird ein Unterprogramm FindVariable in der From frmSchalter aufgerufen, diesem wird das angeklickte Element obElem mit übergeben.

Public Sub LeftClickUp_Schalter (obElem As Element)
frmSchalter.FindVariable obElem
position (pixel to points = (pixel * 0.75))
frmSchalter.Top = obElem.Bottom * 0.75
frmSchalter.Left = obElem.Left * 0.75
frmSchalter.Show
obElem.LeftClickUp
End Sub

Modulglobale Variablen Deklaration:

Dim cmdLast As ToggleButton
Dim strHand As String
Dim strAuto As String
Dim strRevi As String
Im Unterprogramm FindVariable werden zuerst alle Variablen, die das mitgegebene Element anbietet, überprüft.

Je nach Endung (_Auto, _Hand oder _Revi) werden die Variablennamen den oben deklarierten String-Variablen zugewiesen.

Außerdem wird ermittelt, welchen Zustand die Variable hat, und je nach Wert (1 oder 0) wird auch der jeweilige ToggleButton gedrückt oder nicht.

Beim öffnen der Form frmSchalter wird der Name des derzeit gedrückten ToggleButtons in eine String Variable geschrieben. Für den Fall daß sich der User entscheidet, seine Wertänderungen abzubrechen, werden die ursprünglichen Werte wieder hergestellt.

Public Sub FindVariable (obElem As Element)
Dim i As Integer
Dim obVariable As Variable

For i = 0 To obElem . CountVariable - 1
Select Case Right $( obElem . ItemVariable ( i ). Name , 5 )
Case _ Auto
strAuto = obElem . ItemVariable ( i ). Name

Case _ Hand
strHand = obElem . ItemVariable ( i ). Name

Case _ Revi
strRevi = obElem . ItemVariable ( i ). Name
End Select
Next i

Set obVariable = thisProject . Variables . Item ( strHand )
If obVariable . Value = 1 Then
tbHand . Value = True
Set cmdLast = tbHand
End If

Set obVariable = thisProject . Variables . Item ( strAuto )
If obVariable . Value = 1 Then
tbAuto . Value = True
Set cmdLast = tbAuto
End If

Set obVariable = thisProject . Variables . Item ( strRevi )
If obVariable . Value = 1 Then
tbRev . Value = True
Set cmdLast = tbRev
End If

If tbHand . Value = False And tbAuto . Value = False And tbRev . Value = False Then
tbOff . Value = True
Set cmdLast = tbOff
End If
End Sub

Die selbst erzeugte Function VarExists überprüft lediglich, ob die verbundenen Variablen auch existieren, falls dies nicht zutrifft, wird eine Fehlermeldung ausgegeben: Variable doesn't exist.

Function VarExists ()

Dim obVariable As Variable
Set obVariable = thisProject . Variables . Item (strHand)

If obVariable Is Nothing Then
MsgBox (Variable doesnt extist)
VarExitsts = False
Exit Function
End If

Set obVariable = thisProject . Variables . Item (strAuto)
If obVariable Is Nothing Then
MsgBox ( Variable doesnt extist )
VarExitsts = False
Exit Function
End If

Set obVariable = thisProject . Variables . Item (strRev)
If obVariable Is Nothing Then
MsgBox ( Variable doesnt extist )
VarExitsts = False
Exit Function
End If

VarExists = True
End Function

Wenn der User auf Abbrechen klickt, wird die Wertänderung zurück gesetzt und der ursprüngliche Zustand wieder hergestellt.

Private Sub cmdExit _ Click ()
cmdLast.Value = True
Unload Me
End Sub

Private Sub cmdOk _ Click ()
Unload Me
End Sub

Wenn ein ToggleButton gedrückt ist, darf kein anderer ToggleButton gedrückt sein.

Private Sub tbAuto_Change ()
If tbAuto . Value = False And tbHand.Value = False And tbRev . Value = False Then
tbOff . Value = True
End Sub

Im Click-Erreignis eines jeden ToggleButtons wird überprüft, ob dieser nicht gedrückt ist und ob die Variable existiert. Treffen beide Zustände zu, werden die Werte den verbunden Variablen übergeben.


VSTA

Handbuch -> Programmierschnittstellen -> VSTA

Mit Visual Studio Tools for Applications (VSTA) kann die Funktionalität der zenon Runtime und des Editors selbstständig um .NET Programmierung erweitert werden.

VSTA steht mit Einschränkungen auch für Webserver und Webclient zur Verfügung.

info Info

Wenn VBA-Makros im Editor geändert werden:

  • werden die Runtime-Dateien kompiliert und zur Runtime übertragen
  • wird die Runtime neu geladen
  • werden VSTA-Elemente ebenfalls neu geladen, selbst wenn keine Änderungen in VSTA erfolgt sind

VSTA stellt für Arbeitsplatz und Projekt getrennte Entwicklungsumgebungen zur Verfügung. Es kann jeweils nur eine von beiden genutzt wird. Beim Start wird jede andere bereits geöffnete VSTA Entwicklungsumgebung geschlossen.

Um den VSTA-Editor für den Arbeitsbereich zu öffnen:

  1. drücken Sie die Tastenkombination Alt+F10
  2. der Code für den Arbeitsbereich und alle geladenen Projekte wird angezeigt

Um den VSTA-Editor für das aktuell geladene Projekt zu öffnen:

  1. navigieren Sie zum Knoten Programmierschnittstellen
  2. führen Sie einen Rechtsklick auf VSTA
  3. wählen Sie im Kontextmenü VSTA-Editor öffnen...

der Editor wird für das aktuell geladene Projekt geöffnet

Noch in diesem Kapitel

Grundlagen

Erstellung eines VSTA-Projektes

Beispiele


Grundlagen

Handbuch -> Programmierschnittstellen -> VSTA -> Grundlagen

VSTA ist eine Entwicklungsumgebung der Firma Microsoft, die auf der .NET-Technologie basiert. Es ist zum Verständnis notwendig, grundlegende Kenntnisse zur objektorientierten Programmierung, zu .NET und zu C#/Visual Basic.NET zu besitzen.

info Info

VSTA wird vom zenon Web Client nicht unterstützt.

Noch in diesem Kapitel

Einrichten der VSTA-Umgebung

Zugriff auf das Objektmodell in zenon

Funktionen in zenon

Debuggen eines VSTA Add-ins

Neue Events in VSTA

Erstellen eines Backups von VSTA-Projekten


Einrichten der VSTA-Umgebung

Handbuch -> Programmierschnittstellen -> VSTA -> Grundlagen -> Einrichten der VSTA-Umgebung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Standardmäßig ist die Unterstützung für VSTA in zenon bereits aktiviert. Beim Deaktivieren der VBA-Unterstützung ist auch die VSTA-Umgebung nicht mehr verfügbar.

Durch folgenden Eintrag in der C:\Users\All Users\COPA-DATA\System\zenon6.ini kann die VSTA-Umgebung manuell aktiviert bzw. deaktiviert werden:

VSTA aktivieren | VSTA deaktivieren
[VSTA] ON=1 | [VSTA] ON=0

Die Unterstützung für VBA wird folgendermaßen aktiviert bzw. deaktiviert:

VBA aktivieren | VBA deaktivieren
[VBA] EIN=1 | [VBA] EIN=0

Danach steht die Entwicklungsumgebung für VSTA in zenon zur Verfügung.

info Info

VSTA ermöglicht die Entwicklung von Projekten in den Programmiersprachen C# und Visual Basic .NET. Als Standardsprache für VSTA-Projekte im Editor ist C# vorgesehen. Über folgenden Eintrag kann die Sprache auf Visual Basic.NET geändert werden:

[VSTA]

CSHARP=0


Zugriff auf das Objektmodell in zenon

Handbuch -> Programmierschnittstellen -> VSTA -> Grundlagen -> Zugriff auf das Objektmodell in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In VSTA kann auf das zenon-Objektmodell zugegriffen werden, welches auch in VBA verwendet wird. Das Objektmodell bietet hierbei in beiden Entwicklungsumgebungen die selbe Funktionalität.

attention Achtung

Wegen Einschränkungen in der Benennung von VSTA-Objekten wurden einige Änderungen am Objektmodell durchgeführt. Diese finden Sie in der untenstehenden Tabelle

Property alt | Property neu
IDriver.Name | IDriver.Identification
IDriver.Driver | IDriver.Name
Event alt | Event neu
IApplication.Close | IApplication.OnClose
IZenWorkspace.Startup | IZenWorkspace.OnStartup
IZenWorkspace.Exit | IZenWorkspace.OnExit

Der Zugriff geschieht in VSTA über das Objekt this und ersetzt somit das VBA-Objekt MyWorkspace. Die darauffolgenden Methoden und Objekte sind identisch. In der folgenden Methode wird eine Schablone mit dem Namen "TemplateName" in zenon erzeugt.

public void Macro1()

{

this.ActiveDocument.Templates().Create("TemplateName", true);

}

info Info

Anders als in VBA wird in VSTA Wert auf Groß- und Kleinschreibung sowie auf Klammern nach Funktionsnamen gelegt.

Um die Methode in zenon aufzurufen, muss das Projekt mittels folgender Schritte gespeichert und kompiliert werden:

  1. Klick auf File -> Save MyWorkspace.cs speichert das Projekt.
  2. Klick auf Build -> Build WorkspaceAddin kompiliert das Projekt.

Danach steht die Methode als Makro in der VBA-Makro-Toolbar im zenon Editor zur Verfügung. Sollten im Makro-Zuordnungsdialog nicht alle im MyWorkspace enthaltenen Makros zur Auswahl angeboten werden, sollte die Funktion „Liste der VBA-Makros neu laden“ in der Toolbar ausgeführt werden.

info Info

VSTA-Makros mit Parameter, z.B. Public void MacroWithParam(string mString), werden nicht unterstützt und auch nicht in der Makro Symbolleiste angeboten.


Funktionen in zenon

Handbuch -> Programmierschnittstellen -> VSTA -> Grundlagen -> Funktionen in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für VSTA wurden in zenon neue Funktionen entwickelt. Diese befinden sich in der Funktionsgruppe "VSTA".

Parallel zu bestehenden VBA-Funktionen wurden ähnliche Funktionen für VSTA implementiert:

Funktionsname

Beschreibung

VSTA-Editor öffnen

öffnet den VSTA-Editor in der Runtime

VSTA-Makro ausführen

Im Editor kann ein VSTA-Makro ausgewählt werden, das beim Ausführen der Funktion in der Runtime gestartet wird.

Hinweis: VSTA Makros mit Parameter, z.B. Public void MacroWithParam(string mString),werden nicht unterstützt. Sie werden weder bei der Projektierung im Editor noch beim Start der Funktion zur Runtime angeboten.

VSTA-Makro Dialog anzeigen

In der Runtime wird ein Dialog angezeigt, in welchem die vorhandenen VSTA-Makros angezeigt, ausgewählt und ausgeführt werden können


Debuggen eines VSTA Add-ins

Handbuch -> Programmierschnittstellen -> VSTA -> Grundlagen -> Debuggen eines VSTA Add-ins

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über den VSTA-Editor ist das Debuggen von selbst geschriebenen Add-ins möglich. Dabei gilt zu beachten, dass Projekt Add-ins nur in der zenon Runtime, Workspace Add-ins nur im zenon Editor debuggt werden können.

Eine Debug-Session wird über das Menü Debug - Start Debugging gestartet. Breakpoints können wie im VBA-Editor über einen Linksklick in die graue Breakpoint-Leiste am linken Rand neben der betreffenden Zeile gesetzt werden.

info Info

Beachten Sie beim Debuggen von Runtime Add-ins:

Die in zenon geänderten Runtime-Dateien müssen vor dem Start des Debuggers erneut erzeugt.


Neue Events in VSTA

Handbuch -> Programmierschnittstellen -> VSTA -> Grundlagen -> Neue Events in VSTA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da beim Kompilieren von geändertem Code, dem Starten einer Debug-Session oder dem Beenden einer Debug-Session eine Terminierung eines Add-ins geschieht, wurden in VSTA neue Events implementiert. Diese ermöglichen beispielsweise das Auswerten und Freigeben einer Objekt-Referenz und das Speichern von vorhandenen Daten.

Für jede Terminierung existieren zwei Events. Das erste Event wird kurz vor der Terminierung gestartet, das zweite nach dem Start einer neuen Add-in-Session.

Event | Beschreibung
OnPreVSTADebugStart | Wird getriggert kurz bevor eine Debug-Session gestartet wird. Beim Start wird ein aktives Add-in entladen, Referenzen müssen freigegeben und vorhandene Daten gegebenenfalls gespeichert werden.
OnVSTADebugStart | Wird getriggert nachdem eine Debug-Session gestartet wurde.
OnPreVSTADebugStop | Wird getriggert kurz bevor eine Debug-Session gestoppt wird. Beim Stoppen einer Debug-Session wird das Add-in entladen, Referenzen müssen freigegeben werden und vorhandene Daten gegebenenfalls gespeichert werden.
OnVSTADebugStopped | Wird getriggert nachdem eine Debug-Session gestoppt wurde.
OnPreVSTAUpdate | Wird vorm Entladen des Add-ins getriggert, wenn eine neue Version des Add-ins erfolgreich erzeugt wurde.
OnPostVSTAUpdate | Wird beim Laden einer neuen Version des Add-ins getriggert.


Erstellen eines Backups von VSTA-Projekten

Handbuch -> Programmierschnittstellen -> VSTA -> Grundlagen -> Erstellen eines Backups von VSTA-Projekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VSTA-Projekte in der Runtime werden automatisch beim Erstellen der Runtime-Dateien gezippt und sind in Sicherungen des Arbeitsbereiches enthalten.

VSTA-Projekte im Editor müssen jedoch manuell gesichert werden. Im Ordner C:/ProgramData/COPA-DATA/*version*/VSTAWorkspace/ befinden sich die VSTA-Editorprojekte.


Erstellung eines VSTA-Projektes

Handbuch -> Programmierschnittstellen -> VSTA -> Erstellung eines VSTA-Projektes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ähnlich zu VBA existiert in VSTA die Möglichkeit, sowohl Projekte für den Editor als auch für die Runtime zu erstellen. Prinzipiell sind Projekte im Editor in der Programmiersprache C# realisiert. Für die Runtime stehen sowohl C# als auch Visual Basic .NET zur Verfügung.

info Info

Innerhalb des VSTA-Editors kann immer nur ein Projekt gleichzeitig angezeigt werden. Zusätzlich kann immer nur eine Instanz des VSTA-Editors aktiv sein. Beim Start des VSTA-Editors wird eine eventuell bereits vorhandene Instanz geschlossen.

Noch in diesem Kapitel

VSTA-Projekte im Editor

VSTA-Projekte in der Runtime

Entwicklung von Wizards in VSTA


VSTA-Projekte im Editor

Handbuch -> Programmierschnittstellen -> VSTA -> Erstellung eines VSTA-Projektes -> VSTA-Projekte im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erstellen eines Projekts für den zenon-Editor wird ein VSTA Add-in für den Workspace geladen. Um das Add-in zu bearbeiten, muss der VSTA-Editor über Datei - VSTA-Editor öffnen... geöffnet werden. Die Benutzeroberfläche des VSTA-Editors ist identisch mit der Visual Studio-Entwicklungsumgebung der Firma Microsoft.

info Info

Über das Menü Help / Contents kann die Hilfe des VSTA-Editors aufgerufen werden. Diese Hilfe gibt einen Überblick über die Funktionen des Editors, die Features des .NET Frameworks und der Programmierung in Visual Basic.NET und C#.

Das VSTA-Add-in besteht grundsätzlich aus der Klasse MyWorkspace. Diese Klasse kann nun um eigene Methoden erweitert werden. Die Klasse beherbergt per Default welche folgende zwei Methoden:

Funktion | Beschreibung
MyWorkspace_Startup | wird automatisch beim Start von zenon, nach dem Erstellen eines Builds und beim Start einer Debug-Session ausgeführt.
MyWorkspace_Shutdown | wird automatisch beim Beenden von zenon, vor dem Erstellen eines neuen Builds und beim Beenden einer Debug-Session ausgeführt.

attention Achtung

Die Methodennamen dürfen ausschließlich mit Macro (beispielsweise Macro1, MacroVSTA) beginnen, keine Parameter beinhalten und müssen als Public definiert sein. Zudem dürfen der Klassenname und andere von VSTA erstellte Methoden und Events nicht verändert werden.

Um die Methode in zenon aufzurufen, muss das Projekt mittels folgender Schritte gespeichert und kompiliert werden:

  1. Klick auf File -> Save MyWorkspace.cs speichert das Projekt.
  2. Klick auf Build -> Build WorkspaceAddin kompiliert das Projekt.

Danach steht die Methode als Makro in der VBA-Makro-Toolbar im zenon Editor zur Verfügung. Sollten im Makro-Zuordnungsdialog nicht alle im MyWorkspace enthaltenen Makros zur Auswahl angeboten werden, sollte die Funktion „Liste der VBA-Makros neu laden“ in der Toolbar ausgeführt werden.


VSTA-Projekte in der Runtime

Handbuch -> Programmierschnittstellen -> VSTA -> Erstellung eines VSTA-Projektes -> VSTA-Projekte in der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein VSTA-Projekt für die Runtime zu erstellen, muss die VSTA-Umgebung aufgerufen werden. Dazu gehen Sie wie folgt vor:

  1. Im Projektmanager öffnen Sie den Punkt Programmierschnittstellen.
  2. Öffnen Sie das Kontextmenü von VSTA.
  3. Klicken Sie auf VSTA-Editor öffnen...

Wählen Sie im nun erschienenen Auswahldialog die gewünschte Sprache. Daraufhin wird ein Projekt in der gewünschten Programmiersprache angelegt.

info Info

Die gewünschte Sprache kann später nicht mehr geändert werden, daher wird dieser Dialog nur beim ersten Mal angezeigt.

In diesem Projekt wird von zenon eine Klasse namens ThisProject angelegt, welche folgende zwei Methoden beherbergt:

Funktion | Beschreibung
ThisProject_Startup | wird automatisch beim Start der Runtime ausgeführt
ThisProject_Shutdown | wird automatisch beim Beenden der Runtime ausgeführt

Die Klasse kann nun um eigene Methoden erweitert werden.

attention Achtung

Die Methodennamen dürfen ausschließlich mit Macro (beispielsweise Macro1, MacroVSTA) beginnen, keine Parameter beinhalten und müssen als Public definiert sein. Zudem dürfen der Klassenname und andere von VSTA erstellte Methoden und Events nicht verändert werden.

Es besteht über das zenon-Objektmodell Zugriff auf alle Runtime-Funktionalitäten. Editorspezifische Funktionen können wie in VBA nicht verwendet werden.

Die zenon-Runtime wird beim Starten des Debuggers automatisch gestartet. Weitere Informationen sind im Kapitel Debuggen eines VSTA-Add-ins zu finden.

info Info

Über das Menü Help / Contents kann die Hilfe des VSTA-Editors aufgerufen werden. Diese Hilfe gibt einen Überblick über die Funktionen des Editors, die Features des .NET Frameworks und der Programmierung in Visual Basic.NET und C#.


Entwicklung von Wizards in VSTA

Handbuch -> Programmierschnittstellen -> VSTA -> Erstellung eines VSTA-Projektes -> Entwicklung von Wizards in VSTA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die VSTA-Umgebung bietet wie VBA die Möglichkeit, eigene Wizards zu entwickeln.

Um in einem Formular auf das zenon-Objektmodell zugreifen zu können, muss eine Referenz darauf an das Formular übergeben werden. Dazu wird eine Methode in der Klasse MyWorkspace erstellt. Im folgenden Beispiel wird ein Formular mit dem Namen Wizard instanziert und die Methode ZenonInstance mit einer Referenz auf das zenon-Objektmodell als Parameter aufgerufen. Über den Aufruf ShowDialog() wird das Wizard-Formular angezeigt.

public void Macro1()

{

Form1 Wizard = new Form1();

Wizard.ZenonInstance(this.Application);

Wizard.ShowDialog();

}

Im Code des Formulars muss eine Member-Variable angelegt werden, die das zenon-Objektmodell übernimmt.

public zenOn.IApplication m_Zenon=null;

Zuletzt wird die Methode ZenonInstance erstellt. Diese Methode nimmt die Referenz auf das Objektmodell entgegen und setzt es auf das Objekt m_Zenon.

public void ZenonInstance(zenOn.IApplication app)

{

m_Zenon = app;

}

Nun können eigene Klassen und Methoden im Formular entwickelt werden, die auf das Objektmodell zugreifen. Alle Methoden, Objekte und Attribute stehen über das Objekt m_Zenon zur Verfügung.


Beispiele

Handbuch -> Programmierschnittstellen -> VSTA -> Beispiele

Hier finden Sie einige Beispiele für die Verwendung von VSTA sowohl in der Runtime als auch im Editor.

Noch in diesem Kapitel

Erstellen von Variablen im zenon-Editor

Schreiben von Projektinformationen in das zenon-Ausgabefenster

Auslesen von Variablen in zenon über Regular Expressions


Erstellen von Variablen im zenon-Editor

Handbuch -> Programmierschnittstellen -> VSTA -> Beispiele -> Erstellen von Variablen im zenon-Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Beispiel wird eine Textdatei geöffnet und der Inhalt dazu benutzt, um im zenon-Editor Variablen anzulegen. Die Textdatei beinhaltet eine beliebige Anzahl an Zeilen. Jede Zeile beinhaltet dabei den Namen und den Datentyp einer Variable, diese sind durch ein Komma getrennt (Beispiel: Variable1,BOOL).

Die Methode Macro1 sucht zuerst nach dem Intern-Treiber im zenon-Editor. Danach wird dem Benutzer ein Dateiauswahl-Dialog angezeigt, in welchem er die Textdatei auswählen muss. Die Methode liest daraufhin die Textdatei ein und erstellt die Variablen. Die Methode GetDataType wird dazu benötigt, um bei der Erstellung der Variablen den zugehörigen Datentyp zu ermitteln und zuweisen zu können.

using System;

using System.Windows.Forms;

using System.IO;

namespace WorkspaceAddin

{

[System.AddIn.AddIn("MyWorkspace", Version = "1.0", Publisher = "", Description = "")]

public partial class MyWorkspace

{

private void MyWorkspace_Startup(object sender, EventArgs e)

{

}

private void MyWorkspace_Shutdown(object sender, EventArgs e)

{

}

public zenOn.IVarType GetDataType(zenOn.IVarType vType, string strVType)

{

//gets the corresponding vartypes for bool, int, real and strings

switch (strVType)

{

case "BOOL":

vType = this.ActiveDocument.VarTypes().Item("BOOL");

break;

case "INT":

vType = this.ActiveDocument.VarTypes().Item("INT");

break;

case "REAL":

vType = this.ActiveDocument.VarTypes().Item("REAL");

break;

case "STRING":

vType = this.ActiveDocument.VarTypes().Item("STRING");

break;

default:

vType = this.ActiveDocument.VarTypes().Item("INT");

break;

}

return vType;

}

public void Macro1()

{

//create objects that will take the intern driver and the variable type

zenOn.IDriver zInternDriver = null;

zenOn.IVarType vType = null;

//search for the Intern driver and throw exception if no driver was found

try

{

for (int nDriverCount = 0; nDriverCount < this.ActiveDocument.Drivers().Count; nDriverCount++)

{

if (this.ActiveDocument.Drivers().Item(nDriverCount).Name == "Intern")

{

zInternDriver = this.ActiveDocument.Drivers().Item(nDriverCount);

}

}

}

catch (Exception xDrv)

{

MessageBox.Show("Unable to find zenon 'Intern' driver. Error: " + xDrv.Message);

throw;

}

this.ActiveDocument.Variables().DoAutoSave(false);

try

{

OpenFileDialog VarFileSelect = new OpenFileDialog();

String[] strVarLine = new String[2];

//show file dialog

if (VarFileSelect.ShowDialog() == DialogResult.OK)

{

string strLine = string.Empty;

//open new stream reader with selected file

StreamReader ImportStream = new StreamReader(VarFileSelect.FileName, System.Text.Encoding.Default);

//read in line by line, split the lines when a ',' occurs and create variables

while ((strLine = ImportStream.ReadLine()) != null)

{

strVarLine = strLine.Split(new Char[] { ',' });

this.ActiveDocument.Variables().CreateVar(strVarLine[0], zInternDriver, zenOn.tpKanaltypes.tpSystemVariable, GetDataType(vType,strVarLine[1]));

}

ImportStream.Close();

}

}

catch (Exception xFileRd)

{

MessageBox.Show("An error occured while opening the file: " + xFileRd.Message);

throw;

}

this.ActiveDocument.Variables().DoAutoSave(true);

}

#region VSTA generated code

private void InternalStartup()

{

this.Startup += new System.EventHandler(MyWorkspace_Startup);

this.Shutdown += new System.EventHandler(MyWorkspace_Shutdown);

}

#endregion

}

}


Schreiben von Projektinformationen in das zenon-Ausgabefenster

Handbuch -> Programmierschnittstellen -> VSTA -> Beispiele -> Schreiben von Projektinformationen in das zenon-Ausgabefenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Beispiel wird veranschaulicht, wie über VSTA auf das Ausgabefenster des zenon-Editors zugegriffen werden kann. Die Methode namens Macro1 liest dazu die im Projekt angelegten Prozessbilder aus, ermittelt die jeweils dazugehörige Schablone und ermittelt alle verfügbaren Treiber sowie deren Bezeichnung.

using System;

namespace WorkspaceAddin

{

[System.AddIn.AddIn("MyWorkspace", Version = "1.0", Publisher = "", Description = "")]

public partial class MyWorkspace

{

private void MyWorkspace_Startup(object sender, EventArgs e)

{

}

private void MyWorkspace_Shutdown(object sender, EventArgs e)

{

}

public void Macro1()

{

string strPicName = string.Empty;

string strCorTemp = string.Empty;

string strDriverName = string.Empty;

string strDrvDesc = string.Empty;

//print start string into output window

this.Application.DebugPrint(" --------------START--------------", zenOn.tpDebugPrintStyle.tpMsg);

//go through all pictures and print name and used template into output window

for (int i = 0; i < this.ActiveDocument.DynPictures().Count; i++)

{

strPicName = this.ActiveDocument.DynPictures().Item(i).Name;

strCorTemp = this.ActiveDocument.DynPictures().Item(i).get_DynProperties("Template").ToString();

this.Application.DebugPrint(" Picture '" + strPicName + "' uses Template '" + strCorTemp + "'",zenOn.tpDebugPrintStyle.tpMsg);

}

//print seperator string into output window

this.Application.DebugPrint(" ------------------------------",zenOn.tpDebugPrintStyle.tpMsg);

//go through all drivers and print name and description into output window

for (int i = 0; i < this.ActiveDocument.Drivers().Count; i++)

{

strDriverName = this.ActiveDocument.Drivers().Item(i).Name;

strDrvDesc = this.ActiveDocument.Drivers().Item(i).Identification;

this.Application.DebugPrint(" Driver '" + strDriverName + "' has description '" + strDrvDesc + "'", zenOn.tpDebugPrintStyle.tpMsg);

}

//print end string into output window

this.Application.DebugPrint(" ---------------END---------------", zenOn.tpDebugPrintStyle.tpMsg);

}

#region VSTA generated code

private void InternalStartup()

{

this.Startup += new System.EventHandler(MyWorkspace_Startup);

this.Shutdown += new System.EventHandler(MyWorkspace_Shutdown);

}

#endregion

}

}


Auslesen von Variablen in zenon über Regular Expressions

Handbuch -> Programmierschnittstellen -> VSTA -> Beispiele -> Auslesen von Variablen in zenon über Regular Expressions

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im folgenden Beispiel werden zenon-Variablen in einem Runtime-Projekt ausgelesen und in eine lokale Textdatei gespeichert.

Mittels Regular Expressions werden nur Variablen gelesen, deren Name mit 3 Zahlen und einem darauffolgenden Unterstrich beginnen (beispielsweise "001_var" oder "234_xyz"). Der Benutzer wird danach aufgefordert, einen Ordner auszuwählen. In diesem Ordner wird eine Textdatei mit einem zeitabhängigen Dateinamen angelegt. In diese Datei werden Name, Kennung und aktueller Wert aller zutreffenden Variablen mit einem Strichpunkt getrennt gespeichert.

info Info

Möglicherweise müssen manuell Referenzen hinzugefügt werden, um das Beispiel in der zenon-Runtime auszuführen. Dazu öffnen Sie im Project Explorer das Kontextmenü und klicken auf Add Reference... Die in diesem Beispiel benötigten Referenzen lauten wie folgt:

  • Microsoft.VisualStudio.Tools.Applications.Runtime.v9.0
  • System
  • System.AddIn
  • System.Data
  • System.Windows.Forms
  • System.Xml
  • zenonVSTAProxy6500

using System;

using System.Text.RegularExpressions;

using System.IO;

using System.Windows.Forms;

namespace ProjectAddin

{

[System.AddIn.AddIn("ThisProject", Version = "1.0", Publisher = "", Description = "")]

public partial class ThisProject

{

private void ThisProject_Startup(object sender, EventArgs e)

{

}

private void ThisProject_Shutdown(object sender, EventArgs e)

{

}

public void Macro1()

{

string sFilename = string.Empty;

string strName = string.Empty;

string strDescription = string.Empty;

string strValue = string.Empty;

//define regular expression pattern

Regex rexMatch = new Regex("^([0-9]){3}[_]");

try

{

sFilename = FolderSelection("Select place to store the variable information");

//create stream writer to the .txt file

StreamWriter MatchedVariables = new StreamWriter(sFilename, true);

//run through all variables in zenon

for (int i = 0; i < this.Variables().Count; i++)

{

//if name of the variable matches the pattern, get name, tag name and current value

if (rexMatch.IsMatch(this.Variables().Item(i).Name))

{

strName = this.Variables().Item(i).Name;

strDescription = this.Variables().Item(i).Tagname;

strValue = this.Variables().Item(i).get_Value(0).ToString();

//write information to the .txt file

MatchedVariables.WriteLine(strName + ";" + strDescription + ";" + strValue);

}

}

//close stream

MatchedVariables.Close();

}

catch (Exception xFS)

{

MessageBox.Show ("An error occured -> " + xFS.Message);

throw;

}

}

private string FolderSelection(String strCaption)

{

string strSelectedPath = string.Empty;

//create a dialog for selecting the output folder

FolderBrowserDialog FolderSelectionDialog = new FolderBrowserDialog();

FolderSelectionDialog.Description = strCaption;

try

{

if (FolderSelectionDialog.ShowDialog() == DialogResult.OK)

{

//if selection was valid, get the current date, put it to file date format

//then create a txt file with the name "zenonVar" and the corresponding date

DateTime currentTime = DateTime.Now;

strSelectedPath = FolderSelectionDialog.SelectedPath + "\\zenonVar" + currentTime.ToFileTime() + ".txt";

}

}

catch (Exception xFD)

{

MessageBox.Show("An error occured: "+xFD.Message);

throw;

}

return strSelectedPath;

}

#region VSTA generated code

private void InternalStartup()

{

this.Startup += new System.EventHandler(ThisProject_Startup);

this.Shutdown += new System.EventHandler(ThisProject_Shutdown);

}

#endregion

}

}


Object Model

Handbuch -> Programmierschnittstellen -> Object Model

In diesem Bereich finden Sie die Hilfe zum zenon Object Model. Diese Modell gilt gleichermaßen für VBA, VSTA, PCE und die externe COM Schnittstelle.


Projektsicherung

Handbuch -> Projektsicherung

Ein Projekt besteht aus Editor und Runtime-Dateien. Eine Übertragung von Runtime Dateien ist z.B. mittels Remote Transport möglich. Dieses Kapitel beschäftigt sich mit dem Sichern und Rücklesen der Editor-Dateien eines Projektes.

Die Projektsicherung erstellt eine ZIP-Datei mit dem gesicherten Projektstand. Diese Sicherung kann dann auf dem gleichen Rechner oder einem anderen wieder eingelesen werden. Projektsicherungen können auch versioniert werden.

Im Projektmanager findet sich ein eigener Knoten 'Projektsicherungen'. Siehe auch Kapitel Editor Projektmanager. Im Kontextmenü dieses Eintrags kann zwischen 'Sicherung erstellen' und 'Sicherung importieren' gewählt werden.

attention Achtung

Projektsicherungen, die mit zenon und dem SQL Server Express (SQL Server 2005) erstellt werden, können nicht in einen MSDE Datenbankserver (bzw. SQL Server 2000) zurückgelesen werden!

attention Achtung

Symbole aus Globale Symbolbibliothek werden je Gruppe in einer eigenen Datei (*.sys) lokal im zenon Programordner gespeichert. Diese Dateien müssen bei Mehrplatzprojekten und bei der Weitergabe von Projekten immer manuell zur Projektsicherung hinzugefügt werden. Symbole aus der lokalen Projekt-Symbolbibliothek sind in Projektsicherungen immer automatisch enthalten.

Tipp: Symbole immer in der lokalen Projekt-Symbolbibliothek speichern.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Sicherung erstellen | Öffnet den Dialog zur Erstellung einer Projektsicherung.
Sicherung importieren | Öffnet den Dateimanager zur Auswahl einer Sicherungsdatei und importiert diese in die Liste.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Projektieren im Editor

Versionierung


Projektieren im Editor

Handbuch -> Projektsicherung -> Projektieren im Editor

Im Projektmanager / Knoten Projektsicherungen wird im Kontextmenü Sicherung erstellen ausgewählt.

Folgende Dialogbox wird aufgeschalten, wenn ein Projektstand gesichert werden soll:

Dateiname

Name der ZIP-Datei für die Projektsicherung

Da der Dienst zenDbSrv.exe nur mit lokalen Rechten und nicht den Rechten des eingeloggten Benutzers läuft, ist keine Sicherung auf ein Netz-Laufwerk möglich!

Die Projektsicherung wird unter C:/SQL/Backup/Projektname gespeichert. Für jedes Projekt wird ein eigener Ordner angelegt.

Wird er Eintrag Projektsicherung im Projektmanager ausgewählt (Siehe auch Kapitel Editor Projektmanager), werden die einzelnen Projektsicherungen in der Detailansicht des Projektmanagers angezeigt.

Noch in diesem Kapitel

Projektsicherung Detailansicht Symbolleiste und Kontextmenü

Projekt sichern und exportieren

Projektsicherung rücklesen

Arbeitsbereich sichern und rücklesen

Projekt löschen


Projektsicherung Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Projektsicherung -> Projektieren im Editor -> Projektsicherung Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Sicherung erstellen | Öffnet den Dialog zur Erstellung einer Projektsicherung.
Sicherung rücklesen | Stellt das Projekt auf den in der Sicherungsdatei gespeicherten Zustand zurück.
Sicherung als neues Projekt rücklesen | Erstellt ein neues Projekt mit den Daten der Sicherungsdatei.
Löschen | Löscht ausgewählte Einträge.
Sicherung exportieren | Öffnet den Dialog zur Auswahl eines Ordners für die Sicherungsdatei und exportiert diese.
Sicherung importieren | Öffnet den Dateimanager zur Auswahl einer Sicherungsdatei und importiert diese in die Liste.
Selektierte Sicherungen in Änderungshistorie vergleichen | Nur aktive bei Mehrfachselektion. Es wird die älteste und jüngste Version ermittelt. Daraus wird ein Zeitfilter erstellt, mit dem zur Änderungshistorie gewechselt wird, wo Unterschiede der markierten Projektsicherungen angezeigt werden.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet ausgewählte Zelle im Bearbeitungsmodus.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Hilfe | Öffnet die Online-Hilfe.


Projekt sichern und exportieren

Handbuch -> Projektsicherung -> Projektieren im Editor -> Projekt sichern und exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekt sichern

Um eine Projektsicherung zu erstellen, klicken Sie im Projektmanager mit der rechten Maustaste auf Projektsicherung und wählen Sicherung erstellen aus.

Der Dialog für die Projektsicherung wird geöffnet:

Parameter | Beschreibung
Dateiname | Name der ZIP-Datei für die Projektsicherung.
Beschreibung | Freier Text als Kommentar.

attention Achtung

Da der Dienst zenDbSrv.exe nur mit lokalen Rechten und nicht mit den Rechten des eingeloggten Benutzers läuft, ist keine Sicherung auf ein Netz-Laufwerk möglich!

zenon legt die Projektsicherung abhängig vom Betriebssystem in einem eigenen, vordefinierten Ordner ab.

Ordner | Windows XP | Windows Vista
Datenbankordner (SQL) | C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\COPA-DATA\SQL\BACKUP | %ProgramData%\COPA-DATA\[SQL-Ordner]\UID]\BACKUP

info Info

Auch bei der Sicherung des ARbeitsbereichs werdenalle Projekte des Arbeitsbereichs gesichert. Diese sind allerdings nicht im Knoten Projektsicherung enthalten und können auch nicht einzeln rückgesichert werden.

Projekt exportieren

Sie können Ihre Sicherungen jederzeit aus zenon exportieren (z.B. zum Versenden, auf einen anderen Rechner zu transportieren). Führen Sie einen Rechtsklick auf die gewünschte Projektsicherung aus und selektieren Sicherung exportieren im Kontextmenü . Im darauf folgenden Dialog selektieren Sie den Ordner und bestätigen mit OK.

Falls die Projektsicherung länger als 1 Sekunde dauert, wird eine Fortschrittsanzeige eingeblendet.
Informationen zur Sicherung (z.B. Erfolg/Misserfolg) finden Sie im Ausgabefenster.

Alle Sicherungen zu einem Projekt sehen Sie in der Detailansicht sobald Sie im Projektmanager auf Projektsicherungen klicken.

(Siehe auch Projektmanager, Detailansicht des Projektmanagers)


Projektsicherung rücklesen

Handbuch -> Projektsicherung -> Projektieren im Editor -> Projektsicherung rücklesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projektsicherungen können zurückgelesen werden über:

  • den Arbeitsbereich
  • den Knoten Projektsicherungen

Arbeitsbereich

  1. wählen Sie Kontextmenü des Arbeitsbereichs den Befehl Projektsicherung rücklesen...
  2. der Auswahldialog zur Auswahl der Projektsicherung wird geöffnet

Parameter

Beschreibung

Sicherungsdatei

Auswahl der Datei, die zurückgelesen werden soll.

Klick auf Schaltfläche ... öffnet Dateiauswahldialog.

neues Projekt erzeugen

Aktiv: ein neues Projekt wird in der Datenbank angelegt.

Sicherungsdetails

Angaben zum Projekt, das rückgesichert werden soll:

  • Name
  • Projekt ID
  • Editorversion
  • Projektversion (nur wenn Versionierung aktiv ist)
  • Beschreibung

Alle Angaben werden aus dem rückzulesenden Projekt übernommen und dienen nur zur Information. Sie können in diesem Dialog nicht geändert werden.

OK

Angaben werden übernommen und das ausgewählte Projekt wird wieder eingelesen.

Abbrechen

Verwirft alle Angaben und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.

Knoten Projektsicherungen

  1. navigieren Sie zum Knoten Projektsicherungen
  2. markieren Sie die gewünschte Projektsicherung
    Hinweis: Sollte die gewünschte Sicherung nicht vorhanden sein, importieren Sie diese.
  3. wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl Sicherung rücklesen
  4. die Projektsicherung wird nach einer Sicherheitsabfrage zurückgelesen und automatisch aktiviert

attention Achtung

Projekt,

  • die mit dem SQL Server 2005 Express erstellt wurden, können nicht mehr auf SQL-Server 2000 (MSDE) verwendet werden
  • die mit dem SQL Server 2008 R2 erstellt wurden, können nicht mehr mit SQL Server 2005 Express verwendet werden

Projektsicherung importieren

Im Knoten Projektsicherungen des Projektmanager wird im Kontextmenü Sicherung importieren ausgewählt. Das Projekt wird zunächst importiert und erst im nächsten Schritt rückgesichert.

Zunächst wird automatisch geprüft, ob diese gewünschte Sicherungsdatei des Projekts bereits existiert. Wenn diese noch nicht besteht, wird die importierte Datei in die Liste der Sicherungen mit aufgenommen. Alle Projekte, die importiert, aber noch nicht rückgesichert wurden, werden in die Liste der Sicherungen in der Detailansicht des Projektmanagers mit aufgenommen.

Dort findet sich eine Auflistung aller Sicherungen, die jemals für ein Projekt erstellt wurden. Die Beschreibungen sind in der Liste änderbar.

Projektsicherung exportieren und importieren

Eine Projektsicherung zu exportieren oder zu importieren kann erforderlich sein, wenn die Editor-Dateien eines Projekts auf einem anderen Rechner eingesetzt werden sollen. Im Falle des Exports wird die Sicherungsdatei aus dem Ordner %ProgramData%\COPA-DATA\[SQL-Ordner]\Projectname auf ein anderes Laufwerk (z.B: USB-Stick)überspielt. Sowohl Export als auch Import sind ein Kopier- und kein Verschiebevorgang.

Projektsicherung löschen

Die Sicherungsdateien werden aus dem Ordner %ProgramData%\COPA-DATA\[SQL-Ordner]\Projectname gelöscht.

Fehlerbehandlung

Fehler | Lösung
Projektsicherung wird nicht angezeigt. | Der Knoten Projektsicherungen listet nur Projekte auf, die im Standard SQL/Backup-Ordner enthalten sind. Projekte,aus anderen Pfaden können manuell importiert werden.
Schaltfläche OK im Rücklesedialog ist nicht bedienbar. | Die ausgewählte ZIP-Datei enthält ungültige Daten. Eventuell wurde eine Arbeitsplatzsicherung oder eine andere ZIP-Datei ausgewählt.
Historie der Projecktsicherungen ist nicht mehr verfügbar. | Das Projekt wurde umbenannt und die Historie damit nicht mehr verfügbar. Die Sicherungsdatei ist aber nach wie vor vorhanden und kann manuell importiert oder über das Kontextmenü des Arbeitsbereichs zurückgelesen werden.


Arbeitsbereich sichern und rücklesen

Handbuch -> Projektsicherung -> Projektieren im Editor -> Arbeitsbereich sichern und rücklesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sicherung eines Arbeitsbereichs erstellen

Wählen Sie im Kontextmenü des Arbeitsbereichs den Eintrag Arbeitsbereich -> Sicherung erstellen aus. Sicherungen von Arbeitsbereichen werden als *.wsb Dateien gespeichert. Der Name kann beliebig gewählt werden.

Hinweis: Mit dem Arbeitsbereich werden auch alle Projekte des Arbeitsbereichs gesichert. Diese sind allerdings nicht im Knoten Projektsicherung enthalten und können auch nicht einzeln rückgesichert werden.

Sicherung rücklesen

Bei geöffnetem/geschlossenem Arbeitsbereich:

Wählen Sie im Kontextmenü des Arbeitsbereichs den Eintrag Arbeitsbereich / Sicherung rücklesen aus. Sie können nun eine Sicherung selektieren und den Ordner festlegen, in den der Arbeitsbereich rückgelesen werden soll.


Projekt löschen

Handbuch -> Projektsicherung -> Projektieren im Editor -> Projekt löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Projekt zu löschen wählen Sie im Kontextmenü des Projektes den Eintrag Projekt / löschen .

attention Achtung

Beim Löschen eines Projektes werden alle offenen Datenbank-Verbindungen getrennt. Bei der Projektrücksicherung eines bestehenden Projektes ist das nicht der Fall.


Versionierung

Handbuch -> Projektsicherung -> Versionierung

Projektsicherungen können versioniert werden. Versionen werden durch fortlaufende Nummerierung und Datum/Uhrzeit ihrer Erstellung identifiziert und gereiht.

Um die Versionierung zu aktivieren:

  1. navigieren Sie in den Projekteigenschaften zum Knoten Allgemein

    Interne ID: Versionierung

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. navigieren Sie zum Bereich Versionierung

    Interne ID: Versionierung

    Versionierung

    Eigenschaften für die Versionierung von Projektsicherungen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren Sie die Eigenschaft Versionierung aktiv

    Interne ID: Versionierung

    Versionierung aktiv

    Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

    Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

    Inaktiv: keine Versionierung der Projektsicherungen.

    Default: inaktiv

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. vergeben Sie in der Eigenschaft Hauptversion eine Hauptnummer

    Interne ID: Versionierung

    Hauptversion

    Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

    Vom Benutzer zu vergebende Nummer. Diese wird intern mit einer Detailnummer, getrennt durch einen Punkt, ergänzt und als Projektversion dargestellt.

    Interne ID: Versionierung

    Projektversion

    Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

    Zeigt Projektversion an. Die Versionsnummer besteht aus der vom Benutzer vergebenen Nummer der Hauptversion und der intern hinter dem Punkt vergebenen Detailnummer.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Achtung: Willkürliche Veränderungen dieser Nummer beeinflussen die Konsistenz der Versionierung.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Damit wird bei jeder Projektsicherung eine Nummer für die Projektversion erstellt. Diese besteht aus der Hauptversion und einer intern vergebenen Detailnummer, getrennt durch einen Punkt. Diese Detailnummer wird mit jeder Projektsicherung um eins erhöht. Die Version einer Projektsicherung wird angezeigt in:

  • der Detailansicht des Knotens Projektsicherung
  • im Dialog zum Rücklesen eine Sicherung in den Arbeitsbereich

Die Nummer der Projektversion wird beim Übertragen der Runtime-Dateien mit Remote Transport oder über Netzwerk Topologie geprüft und kann über VBA oder eine Systemtreibervariable ausgelesen werden. Falls im Editor eine andere Version geladen ist, wird eine Warnung ausgegeben. Tritt beim Übertragen der Runtime-Dateien über das Netzwerk ein Konflikt auf, kann für alle Projekte, die zu diesem Rechner übertragen werden sollen und bei denen Konflikte bestehen, die Übertragung akzeptiert oder abgelehnt werden.

Der gesamte Stand des Projekts kann auch als XML-Export in die Projektsicherung aufgenommen werden.

info Info

Die Versionierung funktioniert auch im Verteilten Engineering. Dabei muss die project.ini für eine Sicherung am Server für Änderungen gesperrt werden können. XML-Dateien werden aber nur bei lokaler Sicherung gespeichert.

Sicherung der korrekten Reihenfolge

In der Versionierung kann die Hauptversion frei vergeben werden. Auf Basis dieser Hauptnummer wird die Detailnummer mit jeder neuen Sicherung automatisch von 0 hinaufgezählt. Wird die Hauptversion geändert, beginnt die Vergabe der Detailnummer von Neuem bei 0.

Achten Sie auf durchgängige Hauptversion und durchgängige Versionierung. Da Benutzer die Hauptversion frei ändern können, besteht die Möglichkeit:

  • willkürlicher Reihenfolgen

    z.B. 2.1 wird von 1.0 gefolgt

  • mehrfacher Verwendung der gleichen Nummer

    z.B. 1.0, 1.1, 1.2, 1.0

  • die Versionierung vorübergehend abzuschalten

    Das bedeutet: Projektsicherungen ohne Versionsnummer werden vermischt mit versionierten Sicherungen

Um für Überblick über die Reihenfolge der einzelnen Projektsicherungen zu sorgen, wird in der project.ini auch die Zeit des Erstellens der Sicherung gespeichert.

XML-Export

Bei aktiver Eigenschaft XML-Export aktiv wird innerhalb der Projektsicherung eine komprimierte Datei namens VERSION.ZIP angelegt. Diese enthält als XML-Export Daten aus:

Interne ID: Versionierung

XML-Export aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Bei jeder Projektsicherung wird eine XML-Datei (Version.zip) eingefügt. Diese enthält 24 XML-Dateien mit den Sicherungen der einzelnen Module.

Hinweis: Bei Mehrplatzfähigen Projekten nur bei lokaler Sicherung.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Variablen
  • Datentypen
  • Reaktionsmatrizen
  • Zuweisungen
  • Alarmen
  • Maßeinheiten
  • Bildern
  • Schablonen
  • Schriftlisten
  • Farbpaletten
  • Projekt-Symbolbibliothek
  • Funktionen
  • Archivserver
  • Rezepten
  • Rezeptgruppen-Manager
  • Zeitsteuerung
  • VBA-Makros
  • Verriegelungen
  • Befehlsgabe
  • EMS
  • Menüs
  • Benutzerverwaltung
  • Benutzergruppen
  • SAP Interface

Der Inhalt der Dateien entspricht dem, der beim manuellen XML-Export erzeugt wird.

Der Inhalt dieser Xml Dateien entspricht dem, was auch beim üblichen Export als Xml erzeugt wird.Bei mehrplatzfähigen Projekten werden XML-Exporte nur bei lokaler Sicherung erstellt.

Systemvariable

Analog der Eigenschaft Projektversion existiert auch eine Systemvariable Versionsstring des Projekts im Thema Systeminfo.

Noch in diesem Kapitel

Fehlerbehandlung


Fehlerbehandlung

Handbuch -> Projektsicherung -> Versionierung -> Fehlerbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler bei der Versionierung werden in Log-Dateien, im Ausgabefenster und in Popup-Meldungen angezeigt und behandelt.

Diagnosis Viewer

Einträge in LOG-Dateien:

Eintrag | Erklärung
Error BackupDatabase: Skip on an Error in BackupXml: [Pfad] | Fehler beim Erstellen von VERSION.ZIP mit den Xml-Export Dateien während der Projektsicherung. Die Sicherung wurde erstellt, aber die Xml-Dateien fehlen.
GetDBBackupStatus: BINARY.ZIP not exists: [Pfad] | Beim Lesen der Versionierung einer Projektsicherung wurde die Datei BINARY.ZIP nicht gefunden, die Sicherung ist beschädigt.
GetDBBackupStatus: project.ini not exists: [Pfad] | Beim Lesen der Versionierung einer Projektsicherung wurde die Datei project.ini nicht gefunden, die Sicherung ist beschädigt.

Augabefenster

Einträge im Ausgabefenster:

Output Window Eintrag

Erklärung, was bedeutet dieser?

Die Übertragung des Projekts '%s' wurde abgelehnt

Zwei mögliche Ursachen:

  • Bei der Versionsüberprüfung trat ein Konflikt auf und der Benutzer hat die Übertragung abgelehnt.
  • Bei der Versionsüberprüfung trat ein Fehler auf.

Kein Projektpfad definiert

Fehler bei der Versionsüberprüfung.

Popup-Meldungen

Fehlermeldungen in Popups:

Fehlermeldung

Erklärung

Die Version %d.%d des Projekts am Zielrechner stimmt nicht überein: Soll es trotzdem übertragen werden?

Beim Übertragen der Runtime-Dateien mit Remote Transport:

Für das Projekt wurde die Versionierung aktiviert und die Versionsnummer des Projekts im Editor stimmt nicht mit der Versionsnummer in der project.ini am Zielrechner überein.

Mögliche Reaktionen:

  • Ja:
  • Nein: keine Übertragung

Am Computer %s stimmt die Version %d.%d des Projekts %s nicht überein: Soll es trotzdem übertragen werden?

Beim Übertragen der Runtime-Dateien mit Netzwerk-Topologie:

Für ein oder mehrere Projekte wurde die Versionierung aktiviert und die Versionsnummer dieses Projekts im Editor stimmt nicht mit der Versionsnummer in der project.ini am Zielrechner überein.

Mögliche Reaktionen:

  • Ja: Übertragung wird fortgesetzt
  • Nein: keine Übertragung
  • Ja alle: Übertragung wird ohne weitere Nachfrage für alle betroffenen Projekte fortgesetzt
  • Nein alle: Übertragung wird ohne weitere Nachfrage für alle betroffenen Projekte abgebrochen

Dieser Dialog wird wieder aufgeschaltet, wenn bei der Übertragung zu einem weiteren Zielrechner wieder ein Versionskonflikt auftritt.

Das Projekt kann nicht gesichert werden, weil 'project.ini' gesperrt ist!

Beim Erstellen eine Projektsicherung für ein mehrplatzfähiges Projekt mit Versionierung muss die Versionsnummer in der project.ini erhöht werden. Dies ist nicht möglich, weil die project.ini für Änderungen gesperrt ist.


Projektkonvertierung

Handbuch -> Projektkonvertierung

Beim Einsatz neuer Versionen von zenon müssen Projekte, die mit vorhergehenden Versionen erstellt wurden, in die neue Version konvertiert werden. Sind beim Konvertieren bestimmte Eigenschaften oder Änderungen zu beachten, werden diese in den Hinweisen zur Konvertierung in diesem Handbuch beschrieben.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Konvertierung beim Update und Downgrade

Wenn Sie zenon auf eine höhere Version updaten, werden Projekte beim öffnen in der neuen Version automatisch in die höhere Version konvertiert. Ab diesem Zeitpunkt kann das Projekt in älteren Editor-Versionen nicht mehr bearbeitet werden. Es wird aber automatisch auch eine Projektsicherung des konvertierten Projekts in der Ausgangsversion erstellt.

Das Konvertieren eines Projektes, das in einer höheren Version erstellt wurde, in eine niedrigere Version (Downgrade) ist nicht möglich.

Abwärtskompatibilität

Ab Version 6.21 sind Projekte für die Runtime abwärtskompatibel. Sie können also in einem Editor mit höherer Versionsnummer bearbeitet werden. Die Runtime-Abwärtskompatibilität eignet sich besonders für den Einsatz gemischter Versionen, etwa: Ein Projekt, das mit Version 6.50 projektiert wird, kann auch auf einer Runtime, die noch unter 6.22 läuft, eingesetzt werden.

attention Achtung

Werden in einem Projekt mit einem Editor der höheren Version Eigenschaften projektiert, die in der niedrigeren Version nicht verfügbar sind, kann das zur Runtime zu ungewünschten Ergebnissen führen.

Noch in diesem Kapitel

Empfohlene Vorgangsweise Runtime-Dateien konvertieren

Konvertierung von Version 2.20 auf 3.04

Konvertierung von Version 3.04, 3.50 auf 3.52

Konvertierung von Version 3.52 auf 5.11

Konvertierung Version 3.52 auf 5.x oder 6.x

Konvertierung von Version 5.11 auf 5.50

Konvertierung von Version 5.50 auf 6.01

Konvertierung von Version 5.50 nach S7 dBase Export

Konvertierung von Version 6.01 auf 6.20

Konvertierung von Version 5.50 auf Version > 6.22SP1

Konvertierung von Version x auf Version 6.21

Konvertierung von Version x auf Version 6.22

Konvertierung von Version X auf Version 6.50

Konvertierung von Version X auf Version 6.51

Konvertierung von Version X auf Version 7.00


Empfohlene Vorgangsweise Runtime-Dateien konvertieren

Handbuch -> Projektkonvertierung -> Empfohlene Vorgangsweise Runtime-Dateien konvertieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Achten Sie bei der Projektkonvertierung darauf, dass auch zur Runtime änderbare Dateien korrekt konvertiert werden.

Um zur Runtime änderbare Dateien zu konvertieren:

  1. Importieren Sie die Dateien von der Runtime in die Ausgangsversion des Editors.
  2. Führen Sie das Update auf die neue Version durch.
  3. Navigieren Sie in den Projekteigenschaften zum Abschnitt Allgemein.

    Interne ID: Empfohlene Vorgangsweise Runtime-Dateien konvertieren

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. Klicken Sie auf die Eigenschaft RT änderbare Daten.

    Interne ID: Empfohlene Vorgangsweise Runtime-Dateien konvertieren

    RT änderbare Daten

    Der Konfigurationsdialog für die Runtime änderbaren Daten wird geöffnet.
    Standard-Rezepte, Rezeptgruppen-Manager, Scheduler oder Production and Facility Scheduler und Benutzerverwaltung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Der Dialog für die Einstellungen der zur Runtime änderbaren Dateien öffnet sich.

  6. Deaktivieren Sie alle Checkboxen in der Spalte Nicht neu erzeugen und übertragen
  7. Kompilieren Sie das Projekt (Alle Runtime-Dateien erzeugen)
  8. Ändern Sie die Checkboxen in der Eigenschaft RT änderbare Daten wieder auf den Status vor der Konvertierung


Konvertierung von Version 2.20 auf 3.04

Handbuch -> Projektkonvertierung -> Konvertierung von Version 2.20 auf 3.04

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Reorganisieren der Datenbank


Reorganisieren der Datenbank

Handbuch -> Projektkonvertierung -> Konvertierung von Version 2.20 auf 3.04 -> Reorganisieren der Datenbank

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  1. Anlegen eines temporären Verzeichnisses und eines Unterverzeichnisses. Name des Unterverzeichnisses: XX. Z. B.: C:/TEMP/XX wobei C:/TEMP der Pfad der Originaldatenbank und C:/TEMP/XX der Pfad für die reorganisierte Datenbank ist. Vergessen Sie nicht Ihre Orginaldatenbank zu sichern.
  2. Kopieren der Originaldatenbank und REV.BAT und DATAMGR.RDL ins C:/TEMP
  3. Kopieren der neuen DBD-Files (der neuen Datenbank) und der Datei DBAREORG.EXE in das XX-Verzeichnis.
  4. Pfade auf das Verzeichnis setzen, in dem sich DBREV.EXE und INITDB.EXE befinden, bzw. kopieren dieser Dateien sowohl nach C:/TEMP als auch nach C:/TEMP/XX. Prüfen, ob diese beiden Programme ohne Pfadangabe im DOS-Fenster gestartet werden können.
  5. Achten Sie darauf, dass genug Platz im DOS-Speicherbereich zur Verfügung steht (min. 500 K)
  6. Aufrufen der Batch-Datei REV.BAT im DOS-Fenster

    Inhalt:

    del *.taf

    del *.log

    cd xx

    del *.taf

    del *.log

    initdb datamgr

    cd..

    dbrev -r -v -q -s datamgr.rdl datamgr xx/datamgr
  7. Starten der DBAREORG.EXE aus dem zenon Verzeichnis von Windows aus (Datei ausführen).
  8. Einstellung des Pfades in dem sich die Datenbank befindet (XX) über CONVERT 2xx -> 3xx und PFADEINSTELLUNGEN.
  9. Über CONVERT 2xx -> 3xx und KONVERTIERE die Reorganisation starten.
  10. Reorganisation ist beendet. Die neue Datenbank befindet sich im XX-Pfad. Sofern vorhanden löschen Sie bitte die TAF-Dateien aus dem XX-Pfad heraus. Die Originaldatenbank befindet sich weiterhin im TEMP-Verzeichnis.
  11. Ist die Reorganisation beim ersten Mal nicht gelungen, so muss mit Punkt 1 wieder begonnen werden, da sonst ja die reorganisierte Datenbank ein weiteres Mal konvertiert werden würde.

Ergebnis des Reorganisierens: | es wurden alle Bilder konvertiert
 | es wurden alle Variablen konvertiert
 | es wurden alle Funktionen konvertiert, jedoch muß die Verknüpfung der Funktionen neu vorgenommen werden. Ausnahme: die Bilddirekt-Funktion muß nicht mehr neu verknüpft werden
 | es wird ein log-File (DBAREORG.LOG) angelegt (in dem Verzeichnis aus dem DBAREORG.EXE gestartet wurde), in welchem die Information bez. der nicht verknüpften Funktionen steht

Noch in diesem Kapitel

Reorganisieren der Datenbank bei Änderung der Strukturen


Reorganisieren der Datenbank bei Änderung der Strukturen

Handbuch -> Projektkonvertierung -> Konvertierung von Version 2.20 auf 3.04 -> Reorganisieren der Datenbank -> Reorganisieren der Datenbank bei Änderung der Strukturen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  1. Anlegen eines temporären Unterverzeichnisses. Name des Unterverzeichnisses: XX
  2. Kopieren der neuen DBD-Files in das XX-Verzeichnis.
  3. Aufrufen der Batch-Datei REV.BAT:

    Inhalt:

    del *.taf

    del *.log

    cd xx

    del *.taf

    del *.log

    initdb datamgr

    cd..

    dbrev -r -v -q datamgr xx/datamgr


Konvertierung von Version 3.04, 3.50 auf 3.52

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Betriebssystem

AML/CEL-Export

AML/CEL, Archive

Netzwerkbetrieb

Archive

Layer

Kreisbögen

Abwärtskompatibilität

Datenbank

Rückdoku (QRF-Abfragen)

Amerikanische Zeitformate

Alarmdrucker

Symbole

Zoomfunktion

Projektsicherung

Filter für Systemfenster

Export Variable

Element Text verknüpfen


Betriebssystem

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Betriebssystem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Version 3.52 ist nur unter Windows NT 4.0 und WIN 95 lauffähig.


AML/CEL-Export

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> AML/CEL-Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Exportname der AML/CEL-Einträge hat sich geändert. Jetzt Ajjmmdd.TXT bzw. Cjjmmdd.TXT. Für den Export gibt es nun eine Funktion, die z.B. über die Zeitsteuerung aufgerufen werden kann. Die alten Einstellungen entfallen.


AML/CEL, Archive

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> AML/CEL, Archive

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es werden jetzt grundsätzlich Archive für AML und CEL geschrieben. Diese Tagesarchive haben keine Dateibegrenzung. Deshalb ist gegebenen Falls eine Löschfunktion zu projektieren. Damit stellen Sie sicher, dass nicht die ganze Speicherkapazität der Festplatte mit den Archiven gefüllt wird (siehe Funktion Dateioperationen). Beim Einlesen der Archive wird der verfügbare Speicher über folgenden zenon6.ini-Eintrag begrenzt.

[ARCHIV]

...

SPEICHER=1000 (default=1000, entspricht 1MB)


Netzwerkbetrieb

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Netzwerkbetrieb

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Treiber sind auf lokal umzustellen. Im Abschnitt [Befehlsgabe] der zenon6.ini ist der Eintrag Treiber= zu löschen.


Archive

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Archive

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Archive werden jetzt in einem Unterverzeichnis zum Projektpfad gespeichert. Bestehende ARV-Dateien werden beim ersten Neustart verschoben.


Layer

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Layer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es werden keine Layer mehr beim DXF-Import unterstützt. Layer werden jetzt als Symbole bezeichnet.


Kreisbögen

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Kreisbögen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kreisbögen sind durch Kreissegmente ersetzt worden. Bestehende Kreisbögen werden bis zur Änderung beibehalten.


Abwärtskompatibilität

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Abwärtskompatibilität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Version 3.52 ist nicht abwärtskompatibel. (Betrifft z.B, zenon.ini, Symbole und Funktionsverwaltung)


Datenbank

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Datenbank

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es wird eine neue Datenbankstrukturdatei ausgeliefert. (DATAMGR.DBD,20.11.1996,14.759 Byte)

Diese Datei wird bei Chargenarchiven benötigt und ist in das Projektverzeichnis zu kopieren.

*.TAF und *.LOG Dateien im Projektverzeichnis löschen.


Rückdoku (QRF-Abfragen)

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Rückdoku (QRF-Abfragen)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In den QRF-Dateien sind die Abfragen für TTA und Langtext geändert worden.

  • field TTA = dwkanalNr translate using 1 display as left (30);
  • field LANGTEXT = dwkanalNr translate using 6 display as left (39);


Amerikanische Zeitformate

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Amerikanische Zeitformate

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Als Zeitformat wird AM/PM nicht unterstützt.


Alarmdrucker

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Alarmdrucker

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Ausfall des Alarmdruckers wird jetzt automatisch auf den Windows-Standarddrucker umgeschaltet. Soll keine Druckausgabe erfolgen, so ist im Editor die Anzeige des Alarmdruckers zu löschen.


Symbole

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Symbole

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbole müssen nach Neuskalierung vor der Ablage in der Symbolbibliothek aufgelöst und neu zugeordnet werden. Bitmaps in Symbolen müssen getrennt gesichert werden. Symboldateien werden im Verzeichnis ../zenon abgelegt.


Zoomfunktion

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Zoomfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zoomfunktion darf zur Kontrolle und zum Bearbeiten von Elementen benutzt werden.


Projektsicherung

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Projektsicherung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Datenbank besteht jetzt aus den Dateien:

*.VBF

*.IDX

*.DAT

*.BIN

*.DBD

*.INI

*.MDB

*.MIB (für NWM III)

*.NWM (für NWM III)

*.EMS (für 230 EMS)

Für das Sichern der Archive (*.ARV,*.CEL,*.AML) ist das entsprechende Unterverzeichnis zu berücksichtigen.

attention Achtung

Die Datei ALARM.BIN im Archivverzeichnis speichert den letzten Zustand der AML beim Beenden der Runtime und sollte nicht gesichert werden.


Filter für Systemfenster

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Filter für Systemfenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wir empfehlen die Filter für die Systemfenster bezüglich der neuen Funktionalität (z.B. Scheduler, Archivzugriffe für AML/CEL) zu prüfen.


Export Variable

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Export Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Verwendung der Exportdatei unter DBASE, Foxpro muss die max. Spaltenbreite für Variablenname und Langtext von 128 Zeichen auf max. 100 Zeichen begrenzt werden.

Hierzu ist folgender zenon6.ini-Eintrag erforderlich.

[EXPORT]

MAX_LAENGE= z.B. 40


Element Text verknüpfen

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.04, 3.50 auf 3.52 -> Element Text verknüpfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Texte sind jetzt bei alten Projekten nicht mehr zentriert, sondern linksbündig ausgerichtet. Dies lässt sich über die Elementparametrierung ändern. Sollten bei bestehenden Projekten dadurch umfangreiche Anpassungen erforderlich sein, bitte wie folgt vorgehen:

  1. zenon6.ini [Editor] Konvert=1 eintragen
  2. Im Editor unter Bild öffnen Option alte Textelemente setzen und betreffendes Bild öffnen und abspeichern. Vorgang für jedes betroffende Bild wiederholen.
  3. zenon6.ini [Editor] Konvert=1 löschen


Konvertierung von Version 3.52 auf 5.11

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.52 auf 5.11

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Arbeiten welche in der Version 3.52 durchgeführt werden

Arbeiten welche in der Version 5.11 durchgeführt werden


Arbeiten welche in der Version 3.52 durchgeführt werden

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.52 auf 5.11 -> Arbeiten welche in der Version 3.52 durchgeführt werden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Vorarbeiten

Gedrehte Schriften

Bildnamen mit Sonderzeichen


Vorarbeiten

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.52 auf 5.11 -> Arbeiten welche in der Version 3.52 durchgeführt werden -> Vorarbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Sicherheit sollte ein Backup des Projekts in der alten Version erstellt werden.

Die Projektdatenbank sollte mit dem mitgelieferten Tool mit DBCHECK in der Version 3.52 überprüft werden. Treten bei der Überprüfung Fehler auf, so können diese mit dem ebenfalls mitgelieferten Tool DBFIX in der Version 3.52 repariert werden.


Gedrehte Schriften

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.52 auf 5.11 -> Arbeiten welche in der Version 3.52 durchgeführt werden -> Gedrehte Schriften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Gedrehte Schriften verhalten sich, was die Positionierung betrifft, in der Version 3.52 anders als in der Version 5.50 und müssen nachbearbeitet werden.

Um eine mit der Version 3.52 kompatible Darstellung zu erreichen, muss in der project.ini folgender Eintrag gesetzt werden.

[Version]

TEXT352=1


Bildnamen mit Sonderzeichen

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.52 auf 5.11 -> Arbeiten welche in der Version 3.52 durchgeführt werden -> Bildnamen mit Sonderzeichen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bildnamen dürfen keine Sonderzeichen wie / / : * ? < > | Ä Ö Ü enthalten, da die Bilder als Dateien abgespeichert werden. Das Windows Betriebssystem erlaubt keine solchen Sonderzeichen.

Sollten bereits bestehende Bildnamen diese Sonderzeichen enthalten, so müssen diese Bildnamen in der Vorgängerversion z.B.: 3.52 geändert werden, bevor sie in die Version 5.x übernommen werden können.

attention Achtung

Auch alle Funktionen, die ungültige Bildnamen enthalten müssen geändert werden.

Wird diese Änderung nicht durchgeführt, werden die betroffenen Bilder nicht konvertiert, und stehen dann in der Version 5.x nicht zur Verfügung.

attention Achtung

Wenn ein 3.5X Projekt fehlende Schablonen bzw. leere Zuweisungen hat, kommt beim Hochstarten der Runtime 5.11 zu folgender Fehlermeldung: Es wurde versucht auf eine Datei hinter dem Dateiende zuzugreifen und die Runtime stürzt ab.

Daher sind alte 3.5X Projekte auf fehlende Schablonen bzw. leere Zuweisungen vor dem Konvertieren zu prüfen.


Arbeiten welche in der Version 5.11 durchgeführt werden

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.52 auf 5.11 -> Arbeiten welche in der Version 5.11 durchgeführt werden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Version 5.11 muss installiert werden.

Noch in diesem Kapitel

Lizenzierung


Lizenzierung

Handbuch -> Projektkonvertierung -> Konvertierung von Version 3.52 auf 5.11 -> Arbeiten welche in der Version 5.11 durchgeführt werden -> Lizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Lizenznummern der Version 5.x sind mit den Lizenznummern der Vorgängerversionen nicht mehr kompatibel. Für Updates müssen neue Lizenznummern bestellt werden, und im Editor eingetragen werden. Lizenzierungen für alle Versionen bis 3.52 bleiben davon unberührt, da die neuen Seriennummern unter neuen Einträgen in der zenon.ini gespeichert werden:

[DEFAULT]

SERIAL5=xxx

ACTIVATIONKEY5=xxx

In den Start-ICONs darf jetzt kein Anmeldename mehr hinterlegt werden.

Ein bestehendes Projekt muss in einen neuen Arbeitsbereich integriert werden.

Der Simulator-Treiber arbeitet jetzt mit dem gleichen Treibermodell wie alle anderen Treiber. Unter Treiber/Konfiguration ist Hardware auszuwählen.

Nach dem Einlesen eines 3.52-Projektes und der Umsetzung der Bilder muss das richtige Monitorprofil ausgewählt werden und der Editor neu gestartet werden.

In der zenon.ini gibt es einen Eintrag, der die Größe des Treiber Puffers definiert. Als Faustregel für den Wert gilt Variablenanzahl mal 10.

[RT]

DRIVER_QUE =50000

Falls dieser Wert zu klein ist, kommt es zu Aktualisierungsproblemen in der Visualisierung.

Es wird empfohlen, einen Überlauf zu alarmieren. Dafür steht ein Systemvariable zur Verfügung: Projektinfo/Treiber-Queue


Konvertierung Version 3.52 auf 5.x oder 6.x

Handbuch -> Projektkonvertierung -> Konvertierung Version 3.52 auf 5.x oder 6.x

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Dynamisches Element Schalter konvertieren


Dynamisches Element Schalter konvertieren

Handbuch -> Projektkonvertierung -> Konvertierung Version 3.52 auf 5.x oder 6.x -> Dynamisches Element Schalter konvertieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schalter, die in einem Projekt der Version 3.52 angelegt wurden, müssen beim Umstieg auf eine höhere zenon Version per XML-Export konvertiert werden.

Vorgangsweise in der neuen zenon Version:

  1. Kontextmenü Bilder -> XML exportieren alle
  2. Bilder in neue Datei exportieren
  3. Kontextmenü Bilder -> XML importieren
  4. exportierte Datei auswählen und importieren


Konvertierung von Version 5.11 auf 5.50

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.11 auf 5.50

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Arbeiten welche in der Version 5.11 durchgeführt werden

Arbeiten welche in der Version 5.50 durchgeführt werden


Arbeiten welche in der Version 5.11 durchgeführt werden

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.11 auf 5.50 -> Arbeiten welche in der Version 5.11 durchgeführt werden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es wird empfohlen vor der Konvertierung ein Backup des Istzustandes zu erstellen. Gesichert werden müssen Projektierungsdaten, sowie Runtime änderbare Dateien.

Die Projektdatenbank sollte überprüft und gegebenenfalls repariert werden. Nähere Hinweise dazu befinden sich auf der Installations CD unter Software/TOOLS/DB_TOOLS/DB_DOKU.DOC.


Arbeiten welche in der Version 5.50 durchgeführt werden

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.11 auf 5.50 -> Arbeiten welche in der Version 5.50 durchgeführt werden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Version 5.50 muss installiert werden.

Nach dem Start des Editors kann der alte Arbeitsbereich geöffnet werden. Die Projekte werden dann automatisch konvertiert.

Nach dem generieren der Runtime Dateien kann die Runtime gestartet werden.


Konvertierung von Version 5.50 auf 6.01

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

attention Achtung

Nicht übersetzte Schlüsselwörter in der Sprachtabelle werden bei der Konvertierung gelöscht.

Noch in diesem Kapitel

Arbeiten welche in der Version 5.50 durchgeführt werden

Arbeiten welche in der Version 6.01 durchgeführt werden


Arbeiten welche in der Version 5.50 durchgeführt werden

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 5.50 durchgeführt werden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vor der Konvertierung müssen die Daten zuerst auf den Projektierungsrechner zurückgelesen werden. Erst dann darf mit der Konvertierung begonnen werden.

Im Eigenschaften-Fenster des Projekts finden Sie unter 'Allgemein' den Dialog 'RT änderbare Daten'. Hier legen Sie fest, welche Daten geändert werden sollen. Mehr Information hierzu unter RT änderbare Daten.

Noch in diesem Kapitel

Funktions-Namen

Projekte

In der Runtime änderbare Projektierungsdaten (Benutzer, Rezepte usw.)

Daten

Profile

3S Arti Treiber (ab SP2)


Funktions-Namen

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 5.50 durchgeführt werden -> Funktions-Namen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es ist darauf zu achten, dass keine doppelten Funktions-Namen im Projekt vorhanden sind. Da in der Version 5.50 nicht unbedingt Funktions-Namen vergeben werden müsse, überprüft zenon nicht auf Eindeutigkeit. Dies ist für die Version 5.50 auch nicht nötig. In der Version 6.x werden die Funktionen allerdings nach ihrem Namen identifiziert.


Projekte

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 5.50 durchgeführt werden -> Projekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bevor Sie ein 5.50 Projekt im Editor Version 6 öffnen können müssen Sie zuerst das Projekt konvertieren. (Datei - Projekt 5.50 einfügen...) Dabei bleibt das alte Projekt erhalten und es wird eine Kopie davon im Datenbankserver erstellt. Bitte beachten Sie, dass diverse externe Dateien und Verzeichnisse in die neue Editor und Runtime Verzeichnisstruktur nicht übernommen werden. Diese Dateien/Verzeichnisse müssen von Ihnen manuell angepasst bzw. in die Projekte eingefügt werden (Im Projektbaum unter Dateien)

Dies betrifft z.B.: benutzerdefinierte Unterverzeichnisse im Projektverzeichnis, erweiterte Listenverzeichnisse, Datenbanken, Exportverzeichnisse, usw....


In der Runtime änderbare Projektierungsdaten (Benutzer, Rezepte usw.)

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 5.50 durchgeführt werden -> In der Runtime änderbare Projektierungsdaten (Benutzer, Rezepte usw.)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Müssen vor der Konvertierung in den Editor rückgelesen werden, damit keine Änderungen die in der Runtime gemacht wurden verloren gehen.


Daten

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 5.50 durchgeführt werden -> Daten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die von der Runtime generierten Dateien wie z.B. AML-, CEL-Dateien, HD-Daten, Bin-Files usw. sind kompatibel. Diese müssen manuell in die entsprechenden Runtime Verzeichnisse der Version 6 umkopiert werden. Bitte beachten Sie, dass die Daten beim ersten mal Starten der Runtime konvertiert werden. Bei sehr großen Datenmengen müssen Sie entsprechend Zeit dafür einplanen.


Profile

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 5.50 durchgeführt werden -> Profile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Profile für die Alarmierung, Erweitertem Trend usw. werden in Version 5.50 in der Datei mit dem Namen des Projekts und der Endung zrt gespeichert. Bsp.: Für das Projekt Messung heißt die Datei Messung.zrt. Diese Datei müssen Sie nach der Konvertierung des Projekts in project.zrt umbenennen. Danach müssen Sie die Datei in dasselbe Verzeichnis im RT Pfad legen, in dem sich auch die project.ini befindet.


3S Arti Treiber (ab SP2)

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 5.50 durchgeführt werden -> 3S Arti Treiber (ab SP2)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim 3S Arti Treiber hat sich der Name der Variablen-Zuordnungsdatei geändert. Daher muss die Datei bevor neue Variablen aus der Steuerung ausgebrowst werden, umbenannt werden. Genauere Information dazu finden Sie in der Treiberdokumentation.


Arbeiten welche in der Version 6.01 durchgeführt werden

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 6.01 durchgeführt werden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Version 6.01 muss installiert werden.

Noch in diesem Kapitel

Lizenzierung

Benutzerverwaltung/Passwortsystem

Konfigurationseinstellungen

Simulator-Treiber

Bildfunktionen


Lizenzierung

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 6.01 durchgeführt werden -> Lizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Lizenznummern der Version 6.x sind mit den Lizenznummern der Vorgängerversionen nicht mehr kompatibel. Für Updates müssen neue Lizenznummern bestellt werden, und im Editor eingetragen werden. Lizenzierungen für alle Versionen bis 5.x bleiben davon unberührt, da die neuen Seriennummern unter neuen Einträgen in der zenon6.ini anstelle der zenon.ini gespeichert werden.


Benutzerverwaltung/Passwortsystem

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 6.01 durchgeführt werden -> Benutzerverwaltung/Passwortsystem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Benutzerverwaltung der Version 6.x gibt es die neue Eigenschaft Administrator. Nur mehr Administratoren dürfen Benutzerdaten in der Runtime verändern. Da es diese Eigenschaft in den älteren Versionen noch nicht gegeben hat, bleibt sie bei den bestehenden Benutzern als Default nicht aktiviert. Sollten Benutzer in der Runtime Benutzerdaten ändern können, so muss dies in der Version 6.x nachprojektiert werden!


Konfigurationseinstellungen

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 6.01 durchgeführt werden -> Konfigurationseinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Außerdem sind alle Eigenschaften der Projekte sowie die Einstellungen unter Optionen/Einstellungen zu überprüfen.

Nachdem die zenon.ini durch die zenon6.ini ersetzt wurde, müssen auch eventuelle manuelle Änderungen (z.B. für die Archivierung der Eintrag SPEICHER=) in der zenon.ini von Hand in die zenon6.ini kopiert werden.


Simulator-Treiber

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 6.01 durchgeführt werden -> Simulator-Treiber

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da auch die aktuellen Einstellungen des Simulator-Treibers in der zenon.ini gespeichert sind, werden diese für das Runtime Verhalten nun aus der zenon6.ini verwendet. Hier stehen nach der neuen Installation aber noch die Default-Einstellungen. Diese sollten nach der Installation auf die Einstellungen aus der alten zenon.ini geändert werden.

Nach dem Erzeugen der Runtime Dateien kann die Runtime gestartet werden.


Bildfunktionen

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf 6.01 -> Arbeiten welche in der Version 6.01 durchgeführt werden -> Bildfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Version 5.50 (und früheren) konnten nur Skripte (nicht aber Funktionen) mit Bildern verknüpft werden, die automatisch beim Öffnen bzw. Schließen des Bildes ausgeführt wurden.

In der Version 6.01 (und späteren) können nur mehr Funktionen mit Bildern verknüpft werden, daher gehen die Bezüge zu den Skripten verloren. Die gewünschten Funktionen müssen also erneut mit den entsprechenden Bilern verknüpft werden.


Konvertierung von Version 5.50 nach S7 dBase Export

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 nach S7 dBase Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Konvertierung eines 5.50 Projekts kann es zu einem Konvertierungsfehler kommen. Typische Fehlermeldung:
"Fehler Treiber 'SIMUL32 - SIMULATORTREIBER' Variable 'Sub_VISU_E1_IGEF' Type für Primitivobjekt '34' Datenart 8 nicht definiert."

Ursache:

Die Variablen wurden

  • auf einem S7-Treiber angelegt
  • als dBase exportiert
  • und dann auf dem Simualtortreiber wieder importiert

Lösung

  • Variablen mit zenon 5.50 als dBase exportieren
  • in der dBase-Datei Kanaltyp und Datenart kontrollieren und den Treiber entsprechend anpassen


Konvertierung von Version 6.01 auf 6.20

Handbuch -> Projektkonvertierung -> Konvertierung von Version 6.01 auf 6.20

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekte der Version 6.01 müssen beim ersten Laden im aktuellen Editor konvertiert werden. Dabei wird automatisch eine Sicherung des Projekts im Verzeichnis /SQL/Backup erstellt.

attention Achtung

Nicht übersetzte Schlüsselwörter in der Sprachtabelle werden bei der Konvertierung gelöscht.

Noch in diesem Kapitel

Archivauslagerung in SQL Datenbank

Mehrplatzfähige Projekte von 6.20 auf 6.20 SP1 konvertieren


Archivauslagerung in SQL Datenbank

Handbuch -> Projektkonvertierung -> Konvertierung von Version 6.01 auf 6.20 -> Archivauslagerung in SQL Datenbank

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Datenbanktabelle <Projektname>_<Kurzbezeichnung> wurde um zwei zusätzliche Spalten erweitert:

  • GUID: char 36. Nimmt die Projekt-GUID der Variable aus einem fremden Projekt auf oder ist NULL, wenn die Variable aus dem eigenen Projekt kommt.
  • STRVALUE: varchar. Nimmt die archivierten String-Werte auf. Bei einer numerischen Variable hat das Feld den Wert NULL.
    Die Größe des varchar Datenfeldes hängt von der längsten zu archivierenden String-Variable ab. Die Länge der String-Variable wird bei den Variableneigenschaften eingestellt.

Die Datenbanktabelle <Projektname>_VARIABLES wurde um eine zusätzliche Spalte erweitert:

  • GUID: char 36. Nimmt die Projekt-GUID der Variable aus einem fremden Projekt auf oder ist NULL, wenn die Variable aus dem eigenen Projekt kommt.

Diese neuen Spalten müssen entweder in der SQL-Datenbank manuell hinzugefügt werden, oder sie werden vom Editor aus hinzugefügt. Im Editor müssen Sie bei allen betroffenen Archiven auf die Speicherkarte Speichern wechseln. Dort öffnen Sie den Verbindungsstring zur Datenbank und bestätigen den Dialog. Beim Schließen des Dialogs werden die Änderungen in der Datenbank durchgeführt.

attention Achtung

Wenn Sie diese Änderungen nicht durchführen, werden keine Archivdaten in die SQL-Datenbank ausgelagert!


Mehrplatzfähige Projekte von 6.20 auf 6.20 SP1 konvertieren

Handbuch -> Projektkonvertierung -> Konvertierung von Version 6.01 auf 6.20 -> Mehrplatzfähige Projekte von 6.20 auf 6.20 SP1 konvertieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mehrplatzfähige Projekte können nur dann konvertiert werden, wenn keine Elemente in Bearbeitung sind. Alle Mitarbeiter müssen ihre Änderungen daher vorher übernehmen.

Sollte das aus irgendeinem Grund nicht möglich sein, muss zuerst eine Projektsicherung des Projekts am Projektdatenbank-Server gemacht werden und diese sofort wieder zurückgesichert werden. Dabei werden alle In Bearbeitung Informationen zurückgesetzt.

attention Achtung

Alle Änderungen an lokalen Projektständen gehen dabei verloren.

Die Konvertierung kann nur auf jenem Rechner durchgeführt werden, auf dem sich die zentrale Projektdatenbank befindet. Befindet sich diese auf einem Rechner, auf dem kein Editor installiert ist (Standalone Datenbankserver), muss zuerst auf diesem Rechner der 6.20 SP1 Editor installiert werden. Erst dann kann die Konvertierung auf diesem Rechner durchgeführt werden.


Konvertierung von Version 5.50 auf Version > 6.22SP1

Handbuch -> Projektkonvertierung -> Konvertierung von Version 5.50 auf Version > 6.22SP1

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Konvertierung eines Projektes der Version 5.50 mit aktiver Eigenschaft Windows CE Projekt in eine Version höher als 6.22.SP1 werden Rezeptgruppen nicht in die höhere Version konvertiert.

Interne ID: Konvertierung von Version 5.50 auf Version > 6.22SP1

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: Konvertierung von Version 5.50 auf Version > 6.22SP1

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hintergrund: Mit aktiver Eigenschaft Windows CE Projekt wird der Speichertyp auf binary gesetzt bevor die RGM Datenbank konvertiert wird. Damit können in der neuen Version keine neuen Rezeptgruppen mehr angelegt werden.

Lösung: Deaktivieren Sie die Eigenschaft Windows CE Projekt vor der Konvertierung.

Sie können dazu entweder:

  • das Projekt im Editor der Version 5.50 öffnen und die Eigenschaft deaktivieren
    oder
  • in der INI-Datei des Projekts den entsprechenden Eintrag ändern. Dazu:
    • öffnen Sie die <projectname>.ini des projekts
    • navigieren Sie zum Abschnitt [RT]
    • setzen Sie den Eintrag WIN_CE=0


Konvertierung von Version x auf Version 6.21

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.21

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

zenon Webclient CAB-Datei nicht mehr verfügbar


zenon Webclient CAB-Datei nicht mehr verfügbar

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.21 -> zenon Webclient CAB-Datei nicht mehr verfügbar

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die automatische Installation der zenon Webclients mittels CAB-Datei ist aufgrund der Sicherheitseinschränkungen durch Windows VISTA/7 nicht mehr möglich.


Konvertierung von Version x auf Version 6.22

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.22

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Funktionsberechtigungen bei Alarme quittieren

Report Generator Funktion fixed

VBA - Direkter Variablenzugriff per Request ist nicht mehr möglich

RGM - Datenbank geändert

Schablonen - Maximale Länge des Namens


Funktionsberechtigungen bei Alarme quittieren

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.22 -> Funktionsberechtigungen bei Alarme quittieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab zenon Version 6.22 wurden in den Projekteigenschaften unter Funktionsberechtigungen die bestehenden Berechtigungen zum Quittieren von Alarmen durch drei neue Berechtigungen ersetzt. Die alte Funktionsberechtigung 'Alarm quittieren' entfällt somit.

Bei der Konvertierung von bestehenden Projekten werden die neuen Funktionsberechtigungen mit der Berechtigung der alten vorbelegt. Das heißt, war vorher für die Funktionsberechtigung 'Alarm quittieren' z.B. die Berechtigungsgruppe 15 notwendig, ist diese Berechtigungsgruppe auch für die drei neuen Funktionen erforderlich.

Für die Editor Abwärtskompatibilität ist es eventuell erforderlich, dass aus den drei neuen Funktiosberechtigungen die Berechtigungsgruppe auf die alte Funktion übertragen werden muss. Dazu wird dann die höchste Berechtigungsgruppe verwendet. Das heißt, wenn die Funktionen „Alarm quittieren über Alarmzeile“ die Berechtigungsgruppe 5, „Alarm quittieren über Bilder“ die Berechtigungsgruppe 2 und „Alarm quittieren über Funktion“ Die Berechtigungsgruppe 12 haben, bekommt die Funktion „Alarm quittieren“ für die älteren Versionen die Berechtigungsgruppe 12.

info Info

Hinweis zur online Kompatibilität in der Runtime: Wird ein Projekt kleiner zenon Version 6.22 mit der aktuellen Version gestartet, bekommt man die drei neuen Funktionen zur Einstellung angeboten. Es wird jedoch nach dem oben beschriebenen Mechanismus nur höchste Berechtigungsgruppe für die Abarbeitung übernommen. Das alte Projekt kann die neue Funktionalität nicht nutzen.


Report Generator Funktion fixed

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.22 -> Report Generator Funktion fixed

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion fixed() verfügt in Versionen bis 5.50 auch über das Argument no_seps. Das Argument ist optional und steuert die Anzeige von Tausendertrennzeichen.

Dieses Argument hat keine Auswirkung auf die Darstellung mehr, da Tausendertrennzeichen in zenon generell nicht mehr verwendet werden.


VBA - Direkter Variablenzugriff per Request ist nicht mehr möglich

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.22 -> VBA - Direkter Variablenzugriff per Request ist nicht mehr möglich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VBA gibt unseren Kunden ein mächtiges Werkzeug zur Projektgestaltung. In der Praxis hat sich gezeigt, dass beim Zugriff auf Variablen über VBA es immer wieder zu Verwechslungen in der Verwendung der Methoden „Advise" über einen Online Container und „Request" mit direktem Aufruf kam. Zu viele Requests können die Kommunikation stark verlangsamen.

Wir haben uns daher entschieden, den Wunsch vieler Kunden umzusetzen und diese Fehlerquelle zu schließen. Variablen können damit über VBA jetzt nur noch per „Advise" angesprochen werden.

Für bestehende Projekte bringt das Inkompatibilitäten mit sich. Sie sind davon betroffen, wenn Sie Variablen über VBA per „Request" ansprechen. In diesem Fall müssen Sie diese Projekte ändern. Nach der Anpassung profitieren Sie allerdings auch von performanterer Kommunikation im Projekt.

Neu:

Der direkte lesende Variablenzugriff mit VBA ist nur mehr dann möglich, wenn die Variable am Treiber angemeldet (advised) ist und auch einen Wert hat, d.h. IsOnline() true ist. Reine Spontanabfragen (Requests) sind nicht mehr möglich.

Die folgenden Funktionen auf dem "Variable"-Objekt liefern einen Fehler wenn das nicht der Fall ist:

  • Value
  • StatusValue
  • StatusExtValue
  • StatusString
  • LastUpdateTime
  • LastUpdateTimeMilliSeconds

Das bedeutet, dass bestehende Projekte nach der Konvertierung in der Runtime nicht mehr laufen, da die genannten Funktionen fehlschlagen.

Lösungsmöglichkeiten:

  • Definieren Sie für alle betroffenen Variablenzugriffe einen Online Container.
    Vorteil: Die Variablen werden nur dann angefordert, wenn Sie sie wirklich benötigen.
    Nachteil: Erhöhter Programmieraufwand
  • Stellen Sie bei allen betroffenen Variablen bei den Variableneigenschaften in der Gruppe "Zusätzliche Einstellungen" - "DDE aktiv".
    Vorteil: Einfach umsetzbar.
    Nachteil: Alle Variablen werden ständig vom Treiber angefordert.

attention Achtung

Eingeschränkte Kompatibilität!

Überprüfen Sie nach der Projektkonvertierung in die aktuelle Version unbedingt alle Runtime VBA Makros, ob auf Variablen direkt zugegriffen wird. Wenn das der Fall ist, müssen Sie die oben angeführten Maßnahmen treffen!


RGM - Datenbank geändert

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.22 -> RGM - Datenbank geändert

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In 6.22 SP1wurde das Format der verwendeten Datenbank zur Datenablage modifiziert. Das bedeutet, dass beim Konvertieren des Projekts im Editor die Datenbank automatisch umgewandelt wird.

Wenn Sie Rezeptgruppenmanager Daten in der Runtime geändert haben müssen Sie wie folgt vorgehen:

  1. Starten Sie den Editor in der Ausgangsversion bevor sie das Projekt konvertieren.
  2. Stellen Sie bei der Projekteigenschaft RT änderbare Daten sicher, dass die Daten des Rezeptgruppen Managers zurückgelesen und dekompiliert werden können.

    Interne ID: RGM - Datenbank geändert

    RT änderbare Daten

    Der Konfigurationsdialog für die Runtime änderbaren Daten wird geöffnet.
    Standard-Rezepte, Rezeptgruppen-Manager, Scheduler oder Production and Facility Scheduler und Benutzerverwaltung.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Wenn Sie die Runtime auf einem Remote System betreiben: Bauen Sie Verbindung zum Remote System auf und lesen Sie die Runtime Dateien zurück. Die Funktionalität finden Sie in der Remote Transport Symbolleiste.
  4. Lesen Sie die Runtime Daten zurück in den Editor. Dazu verwenden Sie den Befehl Importiere Runtime Dateien der Symbolleiste Runtime Dateien.
  5. Schließen Sie den alten Editor, und starten Sie den neuen Editor. Nun können Sie das Projekt gefahrlos in die neue Version konvertieren. Alle Daten werden in der neuen Version zur Verfügung stehen.

attention Achtung

Alte Rezeptgruppenmanager Datenbanken von Versionen kleiner 6.22 SP1 können in der Runtime 6.22 SP1 und höher nicht mehr eingelesen werden! Wenn die Daten nicht - wie oben beschrieben - über den Editor konvertiert werden, verlieren Sie alle Änderungen an den Rezepten bzw. Rezeptgruppen, die Sie in der Runtime durchgeführt haben.

Windows CE

Wird ein Projekt mit aktiver Option Windows CE Projekt konvertiert, werden die Daten in zenon 6.22 automatisch binär gespeichert. Das hat zur Folge, dass es beim Öffnen des RGM den Anschein hat, als wären alle Rezepte verschwunden.

Interne ID: RGM - Datenbank geändert

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: RGM - Datenbank geändert

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Schablonen - Maximale Länge des Namens

Handbuch -> Projektkonvertierung -> Konvertierung von Version x auf Version 6.22 -> Schablonen - Maximale Länge des Namens

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schablonennamen dürfen maximal 29 Zeichen lang sein. In einer Vorversion war es möglich, Namen mit 30 Zeichen anzulegen. Vor dem Konvertieren eines Projekts müssen alle Schablonennamen mit 30 Zeichen auf 29 Zeichen reduziert werden.


Konvertierung von Version X auf Version 6.50

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.50

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekte von älteren Versionen werden beim ersten Laden im aktuellen Editor automatisch konvertiert. Dabei wird automatisch eine Sicherung des Projekts im Verzeichnis /SQL/Backup erstellt.

attention Achtung

Lesen Sie vor der Konvertierung die Runtime änderbaren Daten in das Editorprojekt in der alten Version zurück. Sonst gehen diese verloren!

Noch in diesem Kapitel

zenon Logic

Erweiterte grafische Einstellungen für AML und CEL

Statusbits - Neue Kurzbezeichner

Strukturen für UDFBs in zenon Logic

VSTA und VBA - Benennung von Objekten


zenon Logic

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.50 -> zenon Logic

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Konvertierung von zenon Logic Projekten muss folgendes beachtet werden:

attention Achtung

Für zenon Logic gilt:

  • Alle Projekte müssen nach der Konvertierung in der Workbench neu kompiliert werden, damit sie in der zenon Logic Runtime funktionieren.
  • Projekte aus einer Vorversion, die nicht in Version 6.50 konvertiert wurden, sind in einer Runtime der Version 6.50 nicht lauffähig.


Erweiterte grafische Einstellungen für AML und CEL

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.50 -> Erweiterte grafische Einstellungen für AML und CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6.50 verfügen das Kontrollelement Alarmmeldeliste im Bild Alarmmeldeliste (AML) und das Kontrollelement Ereignisliste im Bild Chronologische Ereignisliste (CEL) über die Eigenschaft Erweiterte grafische Einstellungen.

Interne ID: Erweiterte grafische Einstellungen für AML und CEL

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese aktiviert die Verwendung und Anpassung der horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters für das Kontrollelement über die entsprechenden Eigenschaften in der Gruppe Kopfzeile und Raster.

Interne ID: Erweiterte grafische Einstellungen für AML und CEL

Kopfzeile und Raster

Eigenschaften für die Kopfzeile und das Raster.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Werden Projekte von früheren Versionen nach Version 6.5x konvertiert, fehlt die Eigenschaft Erweiterte grafische Einstellungen. Um auf die Eigenschaft zugreifen zu können, muss das Kontrollelement Alarmmeldeliste bzw. Ereignisliste aus dem Bild gelöscht und neu angelegt werden.


Statusbits - Neue Kurzbezeichner

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.50 -> Statusbits - Neue Kurzbezeichner

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kurzbezeichner für Statusbits unterscheiden sich seit Version 6.20 in den unterschiedlichen Sprachen. Mit zenon Version 6.50 wurden einheitliche Kurzbezeichnungen eingeführt. Um die Kompatibilität mit früheren Versionen zu wahren, können in der project.ini die neuen Kurzbezeichner in die bisherigen übersetzt werden. Sie finden in diesem Kapitel:

  1. Liste der neuen Kurzbezeichner inklusive Vergleich zu bisherigen Kurzbezeichnern
  2. Liste der Kurzbezeichner mit Langbezeichnung
  3. Anleitung, um alte Kurzbezeichner in der project.ini wieder zu aktivieren

1. Status Kurzbezeichner neu

Bit Nr. | Ab 6.50 Alle | Bis 6.50 Deutsch | Bis 6.50 Englisch | Bis 6.50 Französisch | Bis 6.50 Italienisch | Bis 6.50 Spanisch | Bis 6.50 Russisch
0 | M1 | ST_M1 | ST_M1 | ST_M1 | ST_M1 | ST_M1 | ST_M1
1 | M2 | ST_M2 | ST_M2 | ST_M2 | ST_M2 | ST_M2 | ST_M2
2 | M3 | ST_M3 | ST_M3 | ST_M3 | ST_M3 | ST_M3 | ST_M3
3 | M4 | ST_M4 | ST_M4 | ST_M4 | ST_M4 | ST_M4 | ST_M4
4 | M5 | ST_M5 | ST_M5 | ST_M5 | ST_M5 | ST_M5 | ST_M5
5 | M6 | ST_M6 | ST_M6 | ST_M6 | ST_M6 | ST_M6 | ST_M6
6 | M7 | ST_M7 | ST_M7 | ST_M7 | ST_M7 | ST_M7 | ST_M7
7 | M8 | ST_M8 | ST_M8 | ST_M8 | ST_M8 | ST_M8 | ST_M8
8 | NET_SEL | SELEC | SELEC | SELEC | SELEC | SELEC | ?????
9 | REVISION | REV | REV | REV | REV | REV | ???
10* | PROGRESS | LAUF | DIREC | DIREC | RUN | LAUF | ???
11 | TIMEOUT | LZÜ | RTE | DRT | RTE | LZÜ | ???
12 | MAN_VAL | HWERT | MVALUE | VAL_M | V_MAN | VWERT | ?????
13 | M14 | ST_14 | ST_14 | ST_14 | ST_14 | ST_14 | ST_14
14 | M15 | ST_15 | ST_15 | ST_15 | ST_15 | ST_15 | ST_15
15 | M16 | ST_16 | ST_16 | ST_16 | ST_16 | ST_16 | ST_16
16 | GI | GA | GI | RG | IG | CG | ??
17 | SPONT | SPONT | SPONT | SPONT | SPONT | SPONT | SPONT
18 | INVALID | I-BIT | I-BIT | I-BIT | NV-BIT | I-BIT | I-Bit
19 | T_CHG_A | SO/WI | SU/WI | ET/HI | ES/IN | VE/IN | ??/??
20 | OFF | N_AKT | N_UPD | N_RAF | N_UPD | N_AKT | N_AKT
21 | T_EXTERN | EZ_E | RT_E | HR_E | RT_E | EZ_E | EZ_E
22 | T_INTERN | EZ_I | RT_I | HR_E | RT_I | EZ_E | EZ_E
23 | N_SORTAB | NSORT | NSORT | NTRI | NORD | NSORT | ??????
24 | FM_TR | SM_TR | DM_TR | MD_TR | SM_TR | SM_TR | SM_TR
25 | RM_TR | LM_TR | RM_TR | MM_TR | RM_TR | LM_TR | ??_??
26 | INFO | INFO | INFO | INFO | INFO | INFO | INFO
27 | ALT_VAL | EWERT | AVALUE | VALR | RVAL | EWERT | ?????
28 | RES28 | RES13 | RES13 | RES13 | RES13 | RES13 | RES13
29 | N_UPDATE | !AKTUAL | !AKTUAL | !AKTUAL | !ATTUALE | !ACTUAL | !?????????
30 | T_STD | WINTER | WINTER | HIVER | INVERNO | INVIERNO | ????
31 | RES31 | RES16 | RES16 | RES16 | RES16 | RES16 | RES16
32 | COT0 | UEK0 | TCB0 | CTB0 | CTB0 | TCB0 | ???0
33 | COT1 | UEK1 | TCB1 | CTB1 | CTB1 | TCB1 | ???1
34 | COT2 | UEK2 | TCB2 | CTB2 | CTB2 | TCB2 | ???2
35 | COT3 | UEK3 | TCB3 | CTB3 | CTB3 | TCB3 | ???3
36 | COT4 | UEK4 | TCB4 | CTB4 | CTB4 | TCB4 | ???4
37 | COT5 | UEK5 | TCB5 | CTB5 | CTB5 | TCB5 | ???5
38 | N_CONF | PN_BIT | PN_BIT | PN_BIT | PN_BIT | PN_BIT | PN_BIT
39 | TEST | T_BIT | T_BIT | T_BIT | T_BIT | T_BIT | T_BIT
40 | WR_ACK | WR-ACK | WR-ACK | ECR-ACK | WR-ACK | WR-ACK | WR-ACK
41 | WR_SUC | WR-SUC | WR-SUC | ECR-OK | WR-SUC | WR-SUC | WR-SUC
42 | NORM | NORM | NORM | NORM | NORM | NORM | ????
43 | N_NORM | ABNORM | DEVNORM | DEVNORM | Fuori norma | DEVNORM | ???????
44 | BL_870 | BL_BIT | BL_BIT | BL_BIT | BL_BIT | BL_BIT | BL_BIT
45 | SB_870 | SB_BIT | SB_BIT | SB_BIT | SB_BIT | SB_BIT | SB_BIT
46 | NT_870 | NT_BIT | NT_BIT | NT_BIT | NT_BIT | NT_BIT | NT_BIT
47 | OV_870 | OV_BIT | OV_BIT | OV_BIT | OV_BIT | OV_BIT | OV_BIT
48 | SE_870 | SE_BIT | SE_BIT | SE_BIT | SE_BIT | SE_BIT | SE_BIT
49 | T_INVAL | TIME_INVAL | TIME_INVAL | TIME_INVAL | TIME_INVAL | TIME_INVAL | TIME_INVAL
50 | RES50 | RES50 | RES50 | RES50 | RES50 | RES50 | RES50
51 | RES51 | RES51 | RES51 | RES51 | RES51 | RES51 | RES51
52 | RES52 | RES52 | RES52 | RES52 | RES52 | RES52 | RES52
53 | RES53 | RES53 | RES53 | RES53 | RES53 | RES53 | RES53
54 | RES54 | RES54 | RES54 | RES54 | RES54 | RES54 | RES54
55 | RES55 | RES55 | RES55 | RES55 | RES55 | RES55 | RES55
56 | RES56 | RES56 | RES56 | RES56 | RES56 | RES56 | RES56
57 | RES57 | RES57 | RES57 | RES57 | RES57 | RES57 | RES57
58 | RES58 | RES58 | RES58 | RES58 | RES58 | RES58 | RES58
59 | RES59 | RES59 | RES59 | RES59 | RES59 | RES59 | RES59
60 | RES60 | RES60 | RES60 | RES60 | RES60 | RES60 | RES60
61 | RES61 | RES61 | RES61 | RES61 | RES61 | RES61 | RES61
62 | RES62 | RES62 | RES62 | RES62 | RES62 | RES62 | RES62
63 | RES63 | RES63 | RES63 | RES63 | RES63 | RES63 | RES63

* Hinweis: Der Status Nr. 10 wurde in der Version 6.50 auf D_DIREC umbenannt und ab der Version 6.51 auf PROGRESS geändert.

2. Kurzbezeichnung - Langbezeichnung

Ab Version 6.50 sind die Kurzbezeichner in allen Sprachen gleich. Die Langbezeichner sind weiterhin sprachabhängig:

Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

3. Aktivierung alter Kurzbezeichner

Wenn Sie die Kurzbezeichner, wie vor Version 6.50, sprachabhängig benutzen möchten, können Sie das durch einen Eintrag in der project.ini ermöglichen. Die ersetzten Kurzbezeichner gelten für:

  • VBA
  • Rezeptgruppen-Manager
  • Dialoge des Combielements
  • Dialoge der Rema

So öffnen Sie die project.ini

  1. markieren Sie das Projekt im Projektmanager
  2. drücken Sie die Tastenkombination Strg+Alt+E
  3. das SQL-Verzeichnis von zenon öffnet sich im Explorer
  4. C:\ProgramData\COPA-DATA\[SQL-Ordner]\[UID]\FILES
  5. navigieren Sie zu \zenon\system\
  7. öffnen Sie die project.ini mit einem Texteditor

Zuordnung neuer zu sprachabhängigen Kurzbezeichnern

Kopieren Sie aus der folgenden Tabelle den Eintrag der gewünschten Sprache ab [STATUS] bis inklusive STATUS63=RES63 und fügen Sie diesen in die project.ini ein.

Deutsch | Englisch | Französisch
[STATUS] STATUS0=ST_M1 STATUS1=ST_M2 STATUS2=ST_M3 STATUS3=ST_M4 STATUS4=ST_M5 STATUS5=ST_M6 STATUS6=ST_M7 STATUS7=ST_M8 STATUS8=SELEC STATUS9=REV STATUS10=LAUF STATUS11=LZÜ STATUS12=HWERT STATUS13=ST_14 STATUS14=ST_15 STATUS15=ST_16 STATUS16=GA STATUS17=SPONT STATUS18=I-BIT STATUS19=SO/WI STATUS20=N_AKT STATUS21=EZ_E STATUS22=EZ_I STATUS23=NSORT STATUS24=SM_TR STATUS25=LM_TR STATUS26=INFO STATUS27=EWERT STATUS28=RES13 STATUS29=!AKTUAL STATUS30=WINTER STATUS31=RES16 STATUS32=UEK0 STATUS33=UEK1 STATUS34=UEK2 STATUS35=UEK3 STATUS36=UEK4 STATUS37=UEK5 STATUS38=PN_BIT STATUS39=T_BIT STATUS40=WR-ACK STATUS41=WR-SUC STATUS42=NORM STATUS43=ABNORM STATUS44=BL_BIT STATUS45=SB_BIT STATUS46=NT_BIT STATUS47=OV_BIT STATUS48=SE_BIT STATUS49=TIME_INVAL STATUS50=RES50 STATUS51=RES51 STATUS52=RES52 STATUS53=RES53 STATUS54=RES54 STATUS55=RES55 STATUS56=RES56 STATUS57=RES57 STATUS58=RES58 STATUS59=RES59 STATUS60=RES60 STATUS61=RES61 STATUS62=RES62 STATUS63=RES63 | [STATUS] STATUS0=ST_M1 STATUS1=ST_M2 STATUS2=ST_M3 STATUS3=ST_M4 STATUS4=ST_M5 STATUS5=ST_M6 STATUS6=ST_M7 STATUS7=ST_M8 STATUS8=SELEC STATUS9=REV STATUS10=DIREC STATUS11=RTE STATUS12=MVALUE STATUS13=ST_14 STATUS14=ST_15 STATUS15=ST_16 STATUS16=GI STATUS17=SPONT STATUS18=I-BIT STATUS19=SU/WI STATUS20=N_UPD STATUS21=RT_E STATUS22=RT_I STATUS23=NSORT STATUS24=DM_TR STATUS25=RM_TR STATUS26=INFO STATUS27=AVALUE STATUS28=RES13 STATUS29=!AKTUAL STATUS30=WINTER STATUS31=RES16 STATUS32=TCB0 STATUS33=TCB1 STATUS34=TCB2 STATUS35=TCB3 STATUS36=TCB4 STATUS37=TCB5 STATUS38=PN_BIT STATUS39=T_BIT STATUS40=WR-ACK STATUS41=WR-SUC STATUS42=NORM STATUS43=DEVNORM STATUS44=BL_BIT STATUS45=SB_BIT STATUS46=NT_BIT STATUS47=OV_BIT STATUS48=SE_BIT STATUS49=TIME_INVAL STATUS50=RES50 STATUS51=RES51 STATUS52=RES52 STATUS53=RES53 STATUS54=RES54 STATUS55=RES55 STATUS56=RES56 STATUS57=RES57 STATUS58=RES58 STATUS59=RES59 STATUS60=RES60 STATUS61=RES61 STATUS62=RES62 STATUS63=RES63 | [STATUS] STATUS0=ST_M1 STATUS1=ST_M2 STATUS2=ST_M3 STATUS3=ST_M4 STATUS4=ST_M5 STATUS5=ST_M6 STATUS6=ST_M7 STATUS7=ST_M8 STATUS8=SELEC STATUS9=REV STATUS10=DIREC STATUS11=DRT STATUS12=VAL_M STATUS13=ST_14 STATUS14=ST_15 STATUS15=ST_16 STATUS16=RG STATUS17=SPONT STATUS18=I-BIT STATUS19=ET/HI STATUS20=N_RAF STATUS21=HR_E STATUS22=HR_E STATUS23=NTRI STATUS24=MD_TR STATUS25=MM_TR STATUS26=INFO STATUS27=VALR STATUS28=RES13 STATUS29=!AKTUAL STATUS30=HIVER STATUS31=RES16 STATUS32=CTB0 STATUS33=CTB1 STATUS34=CTB2 STATUS35=CTB3 STATUS36=CTB4 STATUS37=CTB5 STATUS38=PN_BIT STATUS39=T_BIT STATUS40=ECR-ACK STATUS41=ECR-OK STATUS42=NORM STATUS43=DEVNORM STATUS44=BL_BIT STATUS45=SB_BIT STATUS46=NT_BIT STATUS47=OV_BIT STATUS48=SE_BIT STATUS49=TIME_INVAL STATUS50=RES50 STATUS51=RES51 STATUS52=RES52 STATUS53=RES53 STATUS54=RES54 STATUS55=RES55 STATUS56=RES56 STATUS57=RES57 STATUS58=RES58 STATUS59=RES59 STATUS60=RES60 STATUS61=RES61 STATUS62=RES62 STATUS63=RES63

Italienisch | Spanisch | Russisch
[STATUS] STATUS0=ST_M1 STATUS1=ST_M2 STATUS2=ST_M3 STATUS3=ST_M4 STATUS4=ST_M5 STATUS5=ST_M6 STATUS6=ST_M7 STATUS7=ST_M8 STATUS8=SELEC STATUS9=REV STATUS10=RUN STATUS11=RTE STATUS12=V_MAN STATUS13=ST_14 STATUS14=ST_15 STATUS15=ST_16 STATUS16=IG STATUS17=SPONT STATUS18=NV-BIT STATUS19=ES/IN STATUS20=N_UPD STATUS21=RT_E STATUS22=RT_I STATUS23=NORD STATUS24=SM_TR STATUS25=RM_TR STATUS26=INFO STATUS27=RVAL STATUS28=RES13 STATUS29=!ATTUALE STATUS30=INVERNO STATUS31=RES16 STATUS32=CTB0 STATUS33=CTB1 STATUS34=CTB2 STATUS35=CTB3 STATUS36=CTB4 STATUS37=CTB5 STATUS38=PN_BIT STATUS39=T_BIT STATUS40=WR-ACK STATUS41=WR-SUC STATUS42=NORM STATUS43=Fuori norma STATUS44=BL_BIT STATUS45=SB_BIT STATUS46=NT_BIT STATUS47=OV_BIT STATUS48=SE_BIT STATUS49=TIME_INVAL STATUS50=RES50 STATUS51=RES51 STATUS52=RES52 STATUS53=RES53 STATUS54=RES54 STATUS55=RES55 STATUS56=RES56 STATUS57=RES57 STATUS58=RES58 STATUS59=RES59 STATUS60=RES60 STATUS61=RES61 STATUS62=RES62 STATUS63=RES63 | [STATUS] STATUS0=ST_M1 STATUS1=ST_M2 STATUS2=ST_M3 STATUS3=ST_M4 STATUS4=ST_M5 STATUS5=ST_M6 STATUS6=ST_M7 STATUS7=ST_M8 STATUS8=SELEC STATUS9=REV STATUS10=LAUF STATUS11=LZÜ STATUS12=VWERT STATUS13=ST_14 STATUS14=ST_15 STATUS15=ST_16 STATUS16=CG STATUS17=SPONT STATUS18=I-BIT STATUS19=VE/IN STATUS20=N_AKT STATUS21=EZ_E STATUS22=EZ_E STATUS23=NSORT STATUS24=SM_TR STATUS25=LM_TR STATUS26=INFO STATUS27=EWERT STATUS28=RES13 STATUS29=!ACTUAL STATUS30=INVIERNO STATUS31=RES16 STATUS32=TCB0 STATUS33=TCB1 STATUS34=TCB2 STATUS35=TCB3 STATUS36=TCB4 STATUS37=TCB5 STATUS38=PN_BIT STATUS39=T_BIT STATUS40=WR-ACK STATUS41=WR-SUC STATUS42=NORM STATUS43=DEVNORM STATUS44=BL_BIT STATUS45=SB_BIT STATUS46=NT_BIT STATUS47=OV_BIT STATUS48=SE_BIT STATUS49=TIME_INVAL STATUS50=RES50 STATUS51=RES51 STATUS52=RES52 STATUS53=RES53 STATUS54=RES54 STATUS55=RES55 STATUS56=RES56 STATUS57=RES57 STATUS58=RES58 STATUS59=RES59 STATUS60=RES60 STATUS61=RES61 STATUS62=RES62 STATUS63=RES63 | [STATUS] STATUS0=ST_M1 STATUS1=ST_M2 STATUS2=ST_M3 STATUS3=ST_M4 STATUS4=ST_M5 STATUS5=ST_M6 STATUS6=ST_M7 STATUS7=ST_M8 STATUS8=????? STATUS9=??? STATUS10=??? STATUS11=??? STATUS12=????? STATUS13=ST_14 STATUS14=ST_15 STATUS15=ST_16 STATUS16=?? STATUS17=SPONT STATUS18=I-Bit STATUS19=??/?? STATUS20=N_AKT STATUS21=EZ_E STATUS22=EZ_E STATUS23=?????? STATUS24=SM_TR STATUS25=??_?? STATUS26=INFO STATUS27=????? STATUS28=RES13 STATUS29=!????????? STATUS30=???? STATUS31=RES16 STATUS32=???0 STATUS33=???1 STATUS34=???2 STATUS35=???3 STATUS36=???4 STATUS37=???5 STATUS38=PN_BIT STATUS39=T_BIT STATUS40=WR-ACK STATUS41=WR-SUC STATUS42=???? STATUS43=??????? STATUS44=BL_BIT STATUS45=SB_BIT STATUS46=NT_BIT STATUS47=OV_BIT STATUS48=SE_BIT STATUS49=TIME_INVAL STATUS50=RES50 STATUS51=RES51 STATUS52=RES52 STATUS53=RES53 STATUS54=RES54 STATUS55=RES55 STATUS56=RES56 STATUS57=RES57 STATUS58=RES58 STATUS59=RES59 STATUS60=RES60 STATUS61=RES61 STATUS62=RES62 STATUS63=RES63


Strukturen für UDFBs in zenon Logic

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.50 -> Strukturen für UDFBs in zenon Logic

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6.50 stehen in zenon die zenon Logic UDFB Datentypen nicht mehr zur Verfügung. Um die Kompatibilität mit Version 6.22 zu erhalten, können sie in zenon mit einem Projekt-Prefix angelegt werden: "PROJEKTNAME/UDFBName". Dazu muss die K5DBXS.ini um einen Eintrag ergänzt werden:

  1. öffnen Sie die K5DBXS.ini
  2. navigieren Sie zum Abschnitt [XS]
  3. erstellen Sie den Eintrag UseUDFBPrefix=1

Bei Fragen zur Anpassung unsichtbarer UDFBs wenden Sie sich bitte an support@copadata.com oder die in Ihrem Supportvertrag genannte Hotline.


VSTA und VBA - Benennung von Objekten

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.50 -> VSTA und VBA - Benennung von Objekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aufgrund von Einschränkungen in der Benennung von Objekten in VSTA wurden einige Änderungen am Objektmodel durchgeführt. Diese Änderungen wirken sich auf VBA-Code aus, da dieser weiter auf die alten Namen zugreift und damit nicht mehr funktioniert.

Folgende Änderungen wurden durchgeführt:

  • IDriver
    • Name -> Identification:

      Das Property Name hat nicht den Namen, sondern die Identification vom Treiber zurück geliefert. Es wurde in Identification umbenannt.

    • Driver -> Name:

      Driver ist inkompatibel mit VSTA, da dieses Property den Namen des Treiber zurückliefert. Es umbenannt in Name.

  • IApplication
    • Close -> Methode: Close / Event: OnClose:

      IApplication hat sowohl eine Methode als auch einen Event mit Namen Close. Das ist mit VSTA inkompatibel. Das Event wurde in OnClose umbenennt.

  • IZenWorkspace
    • Startup -> OnWorkspaceStartup
    • Exit -> OnWorkspaceExit

      Da diese beide Namen für VSTA-interne Events verwendet werden, wurden sie OnWorkspaceStartup und OnWorkspaceExit geändert.

attention Achtung

Überprüfen Sie VBA Code auf geänderte Namen und passen Sie ihn entsprechend der neuen Modelle an.


Konvertierung von Version X auf Version 6.51

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekte von älteren Versionen werden beim ersten Laden im aktuellen Editor automatisch konvertiert. Dabei wird automatisch eine Sicherung des Projekts im Verzeichnis /SQL/Backup erstellt.

attention Achtung

Maßnahmen Vor der Konvertierung:

Lesen Sie vor der Konvertierung die Runtime änderbaren Daten in das Editorprojekt in der alten Version zurück. Sonst gehen diese verloren!

Noch in diesem Kapitel

Berechnung Spaltenbreite

Einstellungen SQL Datenbank

Erweiterter Trend XY-Achse

GUID bei Projektkonvertierung von Version 5.50

Klickbare Buttons Combi-Element

Kontextmenüs Befehlsgabe

Schichtzeiten im PFS aufzeichnen

Symbolfarben der Globalen Symbolbibliothek von Farbpalette auf absolute Farbe konvertieren

Wizards - VBA/VSTA Properties entfernt

Zeichen # in Objektnamen nicht zulässig


Berechnung Spaltenbreite

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Berechnung Spaltenbreite

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6.51 wird für die Berechnung von Spaltenbreiten (z.B. Alarmmeldeliste oder CEL) die durchschnittliche Zeichenbreite der gewählten Schriftart verwendet. Davor wurde ein Defaultwert verwendet. Das kann dazu führen, dass nach der Konvertierung Spalten in anderer Breite als erwartet dargestellt werden.


Einstellungen SQL Datenbank

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Einstellungen SQL Datenbank

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6.51 kann im Startup Tool die SQL-Instanz definiert werden und das Passwort wird verschlüsselt abgelegt.

Dafür wurde der Dialog zur Einstellung der Datenbankeigenschaften geändert. Neue Einträge sind höherprior als bestehende. Die Anzeige der Dialoge wird automatisch an die gewählte Version (vor 6.51, ab 6.51) angepasst.

Neue Einträge

Die zenondb.ini enthält ab Version 6.51 neue Einträge:

CONNECTION_SQL2005]

USER=zenOnSrv

PW=0x9C 0x94 0xC6 0x50 0x15 0x80 0x79 0x06 0x32 0xED 0x4E 0xE1 0x15 0xDD 0x7C 0x90

SQLINSTANCE=RECHNERNAME\ZENON_DEV

Diese ersetzen den Eintrag:

[CONFIG]

PROVIDER_SQL2005

Sollten die neuen Einträge nicht vorhanden oder leer sein, wird dieser Eintrag weiter verwendet.

Kompatibilität

Solange keine Eigenschaft geändert wird, bleiben die bestehenden Einträge weiterhin gültig. Wird jedoch für eine Version ab 6.51 ein Eintrag geändert, gelten die neuen Einträge. Ältere Versionen müssen dann extra gewartet werden! Die Einstellungen für Versionen vor 6.51 finden Sie im Kapitel Database vor Version 6.51.

Achtung: Da die Verschlüsselung des Benutzerpassworts im neuen Dialog über das Startup Tool erfolgt, müssen ab Version 6.51 alle Einstellungen zwingend über das Startup Tool vorgenommen werden.


Erweiterter Trend XY-Achse

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Erweiterter Trend XY-Achse

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aus Performancegründen werden Archivdaten für die X-Achse ab Version 6.51 im Erweiterter Trend Diagramm nicht mehr automatisch geladen. Um die X-Achse im Diagramm dennoch anzuzeigen:

  • fügen Sie die für die Variable für X-Achse gewählte Variable auch als Kurve im Diagramm hinzu
  • deaktivieren Sie die Anzeige für diese Kurve


GUID bei Projektkonvertierung von Version 5.50

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> GUID bei Projektkonvertierung von Version 5.50

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Konvertierung von Projekten der Version 5.50 ist zu beachten, dass bei der Konvertierung mehrerer Projekte jeweils eine eigene GUID erzeugt werden muss.

Ursache

In der project.ini der Version 5.50 steht ein Eintrag GUID, der eine Projekt-GUID beinhaltet. Konvertiert man ein Projekt in Version 6.x wird diese GUID verwendet.

In zenon 5.50 war es möglich, Ordner auf Dateiebene zu kopieren, dann das Projekt im Editor zu öffnen und umzubenennen. Diese Projektkopie enthielt immer noch die originale GUID in der INI-Datei, was für 5.50 kein Problem darstellte.

Werden nur zwei solche Projekte in Version 6.x konvertiert, wird die Konvertierung beim zweiten Projekt mit dem Hinweis abgebrochen, dass die GUID bereits vorhanden ist.

Lösung

Für die Konvertierung mehrerer kopierter Projekte aus 5.50 gibt es drei mögliche Wege:

  1. Speichern unter
    • Projekt A konvertieren
    • in Version 6.x "Projekt speichern unter" ausführen
    • eine neue GUID wird erzeugt
    • Orginalprojekt löschen
    • Projekt B konvertieren

    Achtung: Diese Methode ist nicht für Globalprojekte geeignet.

  2. Projektsicherung
    • Projekt A konvertieren
    • in Version 6.x Projektsicherung erstellen
    • Orginalprojekt löschen
    • Sicherung mit "Projektsicherung rücklesen" wieder herstellen und dabei die Eigenschaft "Neues Projekt erzeugen" aktivieren.

    Hinweis: Diese Methode eignet sich auch für Globalprojekte.

  3. project.ini bearbeiten
    • project.ini der Version 5.50 öffnen. In dieser Version heisst die "project.ini" Projektname.ini
    • den Eintrag mit der GUID löschen
    • konvertieren
    • eine neue GUID wird erzeugt

    Hinweis: Wird dieses Projekt nochmals mit Version 5.50 geöffnet wird ebenfalls eine neue GUID erzeugt und in die INI-Datei eingetragen.


Klickbare Buttons Combi-Element

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Klickbare Buttons Combi-Element

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6.51 können im Combi-Element für die Option Symbol aus Bibliothek klickbare Buttons in beliebiger Form erstellt werden.

Bei Projekten für frühere Versionen wird die Eigenschaft Symbolform bestimmt Klickbereich (Knoten Darstellung) als inaktiv behandelt.

Interne ID: Klickbare Buttons Combi-Element

Symbolform bestimmt Klickbereich

Ermöglicht es, einen klickbaren Button mit beliebiger Form zu erstellen. Steht nur für Option Symbol aus Bibliothek des Combi-Elements zur Verfügung.

Aktiv: Die Symbolform wird als Klickbereich verwendet, jedes Element im Symbol wird einzeln für den Klickbereich berücksichtigt.

Inaktiv: Die Form des Combi-Elements (gesamtes Rechteck) wird als Klickbereich verwendet.

Default: inaktiv

Achtung: Unter Windows CE nicht verfügbar.

Eigenschaft steht ab Version 6.51 zur Verfügung. Bei Projekten für frühere Versionen wird die Eigenschaft als inaktiv behandelt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Kontextmenüs Befehlsgabe

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Kontextmenüs Befehlsgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vor Version 6.51 wurde Text bei automatischen Menüpunkten ignoriert. Bei der Konvertierung von Projekten, die mit Versionen vor 6.51 erstellt wurden, werden vor dem projektierten Text automatisch die Makros $ALL$$NOTE$ eingefügt. Damit verhalten sich diese Menüpunkte genau so wie bisher.


Schichtzeiten im PFS aufzeichnen

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Schichtzeiten im PFS aufzeichnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Aufzeichnung von Schichtzeiten im Production and Facility Scheduler wurde in Version 6.50 der Tabellenname für die Aufzeichnung fest mit PFSSHIFTHISTORY bezeichnet.

Ab Version 6.51 wird er nach folgendem Muster erstellt: ProjektGUID_SCHICHT_GUID der Anlagengruppe
Zum Beispiel: 292af0ac-d33d-4123-8484-e359cd0a6ae3_SHIFT_989ef705-d6a6-4b81-9eb5-f76483ecaac1.


Symbolfarben der Globalen Symbolbibliothek von Farbpalette auf absolute Farbe konvertieren

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Symbolfarben der Globalen Symbolbibliothek von Farbpalette auf absolute Farbe konvertieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Verwendung von Farbpaletten wird nur der Palettenindex gespeichert. Die tatsächliche Farbe wird zur Runtime zugeordnet.

Problem

Werden in Versionen vor zenon 6.51 Farben für Symbole der Globalen Symbolbibliothek über Palettenfarben (ähnliche Funktion wie Farbpaletten ab 6.51) definiert und werden die Farben eines Symbols in Version 6.51 geändert, so werden mit dem Neustart des Editors alle benutzerdefinierten Farben der Symbole an die Änderung angepasst. Diese Aktion ist aus Kompatibilitätssicht korrekt. Allerdings können auch absolute Farben benötigt werden.

Lösung

Wird die Symbolbibliothek in zenon 6.51 neu gespeichert, werden die Paletten-Indizes durch absolute Farben ersetzt.

Vorgangsweise:

  1. Aktivieren und öffnen Sie das Projekt mit den korrekten Palettenfarbe in zenon 6.51.
  2. Fügen Sie in die Globale Symbolbibliothek ein neues Symbol ein.
  3. Speichern Sie die Globale Symbolbibliothek. Diese wird im neuen Format gespeichert.
  4. Schließen Sie den Editor und starten Sie ihn neu.
  5. Benennen Sie das neu erstellte Symbol um und speichern Sie.
  6. In der Globalen Symbolbibliothek werden Palettenfarben durch absolute Farben ersetzt.


Wizards - VBA/VSTA Properties entfernt

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Wizards - VBA/VSTA Properties entfernt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Filter für Bildumschaltungsfunktionen auf ein Bild vom Typ Erweiterter Trend wurden folgende dynamischen Properties entfernt, da sie keine Funktion hatten:

  • PictFilter[0].Curve["0 "].VarInfo.Channel
  • sowie ArvName, Titel, Group und Amplitude des selben Objekts

Sollten Sie diese Properties in einem Wizard verwenden, müssen Sie diese entfernen.


Zeichen # in Objektnamen nicht zulässig

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 6.51 -> Zeichen # in Objektnamen nicht zulässig

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6.51 ist das Zeichen # für Objektnamen wie Variablen oder Funktionen nicht mehr zulässig. Das Zeichen kann bei der Bennung über die Oberfläche nicht eingegeben werden.

Hintergrund: Ein # im Namen kann zum Beispiel beim Import zu Problemen führen.


Konvertierung von Version X auf Version 7.00

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekte von älteren Versionen werden beim ersten Laden im aktuellen Editor automatisch konvertiert. Dabei wird automatisch eine Sicherung des Projekts im Verzeichnis /SQL/Backup erstellt. Die automatisch generierten Backups haben ab Version 7.00 den verwendeten SQL Server im Dateinamen, z.B.:
before converted to 7.00 SP0 (sql server 2008 r2).zip

attention Achtung

Maßnahmen vor der Konvertierung:

Lesen Sie vor der Konvertierung die Runtime änderbaren Daten in das Editorprojekt in der alten Version zurück. Sonst gehen diese verloren!

Noch in diesem Kapitel

Benutzerverwaltung mit Active Directory

Diagnose Server mit neuem Dienst

Dynamische Combo-/Listbox

IPv6

Lizenzierung

Message Control

RGM - Fehlerverhalten bei Bildumschaltung

RGM Rezept lesen - neue Bedingungen

Treiber Allan Bradley RS-Linx

Umstellung SQL Server


Benutzerverwaltung mit Active Directory

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> Benutzerverwaltung mit Active Directory

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 7.00 SP0 ist Active Directory nur noch für die Benutzerverwaltung in der zenon Runtime verfügbar. Das bedeutet für den zenon Editor:

  • AD Benutzer werden für den Editor nicht verwendet.
  • AD Benutzer werden im Editor nicht mehr validiert.
  • Über AD kann keine Anmeldung am Editor erfolgen.

Achtung: Sollten Sie in einem Projekt die Anmeldung am zenon Editor über Active Directory realisiert haben, dann muss vor der Konvertierung des Projekts ein zenon Benutzer mit allen nötigen Rechten angelegt werden.


Diagnose Server mit neuem Dienst

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> Diagnose Server mit neuem Dienst

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit zenon 7.00 SP0 wird das Diagnose System umgestellt. Alle Logging Aufgaben werden ab dieser Version über den Dienst zenLogSrv abgewickelt. Der Dienst zenSysServ ist nur noch für Remote-Transport-Aktivitäten zuständig. Die maximale Anzahl der Module pro Diagnose Client wurde von 32 auf 64 erhöht.

Das bedeutet:

  • Diagnose Systeme bis Version 6.51 und ab Version 7.00 sind jeweils kompatibel zueinander.
  • Die Diagnose Mechanismen von zenon 6.51 SP0 und zenon 7.00 SP0 sind nicht kompatibel.
Kompatibilität | Diagnose Server 6.51 SP0 und früher | Diagnose Server 7.00 SP0 und höher
Diagnose Client 6.51 SP0 und früher | kompatibel | inkompatibel
Diagnose Viewer 6.51 SP0 und früher | kompatibel | inkompatibel
Diagnose Client 7.00 SP0 und höher | inkompatibel | kompatibel
Diagnose Viewer 7.00 SP0 und höher | inkompatibel | kompatibel

Mit dem Diagnose Viewer Version 7.00 SP0 und höher können Log-Dateien, die von einem Diagnose Server Version 6.51 SP0 (oder früher) erstellt wurden, geöffnet werden. Der umgekehrte Fall funktioniert nicht.


Dynamische Combo-/Listbox

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> Dynamische Combo-/Listbox

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 7 können Combo-/Listboxen auch dynamisch erstellt werden. Über die Eigenschaft Einträge aus Stringvariable wird festgelegt, ob die Einträge der Box im Editor festgelegt oder über eine verknüpfte Stringvariable erstellt werden.

Interne ID: Dynamische Combo-/Listbox

Einträge aus Stringvariable

Aktiv: Einträge für Combo-/Listbox werden über die in der Eigenschaft Variable ausgewählte Stringvariable definiert.

Interne ID: Dynamische Combo-/Listbox

Variable

Nur verfügbar, wenn Eigenschaft Einträge aus Stringvariable aktiv ist.

Auswahl der Stringvariable, die die Einträge für Combo-/Listbox enthält. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Inaktiv: Einträge werden im Editor über den Dialog der Eigenschaft Einträge definiert.

Interne ID: Dynamische Combo-/Listbox

Einträge

Nur verfügbar, wenn die Eigenschaft Einträge aus Stringvariable inaktiv ist.

Klick auf Schaltfläche ... öffnet den Dialog zur Definition der Einträge für eine statische List-/Combobox.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beim Konvertieren von Projekten einer Version von zenon 7, werden die neuen Eigenschaften mit gültigen Werten belegt:

  • statische Combo-/Listboxen (Eigenschaft Einträge aus Stringvariable inaktiv)
  • keine Sichtbarkeitsvariable (Eigenschaft Variable leer)

Werden Dateien für einen ältere Version erstellt oder gespeichert, werden die Eigenschaften für dynamische Combo-/Listboxen nicht geladen/geladen um Abwärtskompatibilität zu gewährleisten.


IPv6

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> IPv6

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab zenon Version 7 kann IPv6 im Netzwerk verwendet werden.

Das zenon Netzwerk erlaubt wahlweise die Verwendung von IPv6 oder IPv4. Dualer Betrieb ist nicht möglich. Die Einstellung wird getroffen über:

  • Network configuration im Startup Tool
    oder
  • in der zenon6.ini

Achtung: IPv6 funktioniert nur ab Version 7.
Bei aktiver Option können keine Versionen vor 7 gestartet werden. Das betrifft insbesondere zenAdminSrv, zenSysSrv, zenLogSrv und zenDBSrv.

Folgende Komponenten sind von der Einstellung nicht betroffen, diese nutzen immer IPv4:

  • Treiberkommunikation mit den Steuerungen
  • Protokollkommunikation in den ProcessGateway-Plugins
  • Workbench- und Runtimekommunikation in zenon Logic

Diagnose Viewer

Der Diagnose Server funktioniert auch mit Diagnose Clients, die über IPv6-Adressen angesprochen werden. Dafür wurde das Format der Log-Dateien angepasst. Der Diagnose Viewer liest nur das neue Format der Log-Dateien. Werden Dateien von älteren zenon Versionen geöffnet (oder umgekehrt), wird die IP-Adresse des Diagnose Clients nicht korrekt angezeigt.


Lizenzierung

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> Lizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Version 7.00 wird die Lizenzierung umgestellt. Um vorhandene zenon Versionen auf Version 7.00 umzustellen, muss eine Lizenz für Version 7.00 erworben werden und die neue Aktivierungsnummer eingegeben werden. Die Seriennummer bleibt unverändert.

Die Einträge in der zenon6.ini lauten jetzt:

[DEFAULT]

SERIAL7=

ACTIVATIONKEY7=


Message Control

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version zenon 7.00 SP0 unterscheidet sich das Modul Message Control in Technik und Konfiguration grundlegend von früheren Versionen.

Wichtige technische Änderungen:

  • es wird kein COM-Server mehr verwendet
  • die Zusatzkomponente der Firma DerDack wird nicht mehr verwendet
  • die ZenMsgQueue wird durch ein eigenes Bild vom Typ Message Control ersetzt
  • die Konfiguration erfolgt in den Eigenschaften Message Control des Arbeitsplatzes (Versand) und den Eigenschaften Projektspezifische Einstellungen für das Modul Message Control im Projekt (projektspezifisch)

    Interne ID: Message Control

    Projektspezifische Einstellungen

    Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

    Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Message Control

    Message Control

    Gruppe für projektübergreifende Einstellungen im Message Control.

    Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • es gibt keine Detailansicht mehr
  • das Schichtenmodell und die Kalenderfunktionalität wurden entfernt
  • es gibt keine Runtime änderbaren Dateien mehr
  • E-Mailversand ist möglich über Outlook oder einen SMTP Server, wobei SMTP den Versand von Anhängen erlaubt
  • die Konfiguration der Versandarten wird nicht länger in einer eigenen messag32.ini gespeichert, sondern in der zenon6.ini
  • Auswertung Grenzwerttexte: Bisher war die Auswertung von zusammengesetzten Texten im Modul Message Control unterschiedlich zur Auswertung von Standard-Grenzwerttexten. Ab Version 7.00 werden beide gleich ausgewertet: @StringTabelle+%var1

Details zur Konfiguration lesen Sie im Kapitel Message Control konfigurieren.

attention Achtung

Nur Projekte ab Version 5.50 SP7 können nach Version 7 konvertiert werden.

Konvertierung

Aufgrund der tief gehenden Änderungen kann bei der Konvertierung keine 100% Kompatibilität garantiert werden. Das gilt auch für das Kompilieren von RT-Dateien für ältere Versionen. Beachten Sie beim Konvertieren vor allem:

  • Benutzer:
    • Benutzer mit gleichem Name (Vorname Nachname) vorhanden: Benutzer wird verwendet und Informationen werden ergänzt.
    • Kein entsprechender Benutzer vorhanden: Es wird ein neuer Benutzer angelegt, die Verknüpfung zum Ersatzmann und zur Benutzergruppe werden aufgelöst. Der Benutzer wird in die bestehende oder die bei der Konvertierung erstellte Gruppe eingetragen.
  • Benutzergruppen:
    • Benutzergruppe mit gleichem Name vorhanden: Benutzergruppe wird verwendet und Informationen werden ergänzt.
    • Keine entsprechende Benutzergruppe vorhanden: Es wird eine neue Benutzergruppe angelegt.
  • Funktionen:

    Die Funktion Empfängerdatenbank anzeigen wurde entfernt:
    Diese Funktion kann mit dem Editor nicht mehr erzeugt werden. Beim Konvertieren wird sie aber nicht gelöscht. Ihr Aufruf zur Runtime bleibt ohne Wirkung und erzeugt einen LOG-Eintrag.

  • Paging:
    Paging steht als Versandart nicht mehr zur Verfügung. Bestehende Funktionen mit Versandart Paging werde beim Konvertieren geändert auf Versandart GSM. Eine Meldung im Ausgabefenster weist darauf hin. Nach der Konvertierung müssen die Einstellungen der Funktion überprüft werden.
  • RT änderbare Dateien:
    Da die Benutzerverwaltung geändert wurde, werden keine RT änderbaren Dateien für Message Contreol benötigt. Es gibt in Version 7 auch keine Möglichkeit, alte Runtime-Daten zurückzulesen. Werden die Runtime-Dateien eines Projekts vor Version 7 benötigt, müssen diese in einem Editor vor zenon 7 zurückgelesen und dann konvertiert werden.
  • Schichten und Kalender:
    Die Funktionalität für Schichten und Kalender wurde entfernt. Bestehende Funktionen mit Zieltyp Schicht werde beim Konvertieren geändert auf Zieltyp Gruppe. Es wird allerdings keine Gruppe verknüpft. Eine Meldung im Ausgabefenster weist darauf hin. Nach der Konvertierung müssen die Einstellungen der Funktion überprüft werden.
  • SMS-Gateway:
    Da die einfache Schnittstelle keine technische Möglichkeit bietet, Nachrichten eindeutig zuordnen zu können, wird ab Version 7 nur noch die erweiterte Schnittstelle unterstützt. Beim Konvertieren muss sicher gestellt werden, dass auch der SMS-Server der Firma Dialogs entsprechend konfiguriert wird. Sonst schlägt der Versand fehl.


RGM - Fehlerverhalten bei Bildumschaltung

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> RGM - Fehlerverhalten bei Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wird für die Bildumschaltung des RGM ein Rezept fehlerhaft ausgewählt durch:

  • Rezept in Runtime nicht vorhanden
  • keine Auswahl getroffen
  • Rezept nicht im Filter enthalten

dann ändert sich das Verhalten der Dropdownliste Rezept zur Runtime:

  • bis inklusive Version 6.51 SP0 wurde das erste Rezept in der Liste angeboten
  • ab Version 7.00 SP0 bleibt die Auswahl leer.


RGM Rezept lesen - neue Bedingungen

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> RGM Rezept lesen - neue Bedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 7.00 SP0 wird beim Einlesen von Variablenwerten in Rezepte(Teachen) überprüft:

  • ob die Werte der Eigenschaften min. Wert und max. Wert eingehalten werden
  • welchen Status die Variable hat

Werden die Werte unter- oder überschritten oder hat die Variable den Status INVALID, werden die Werte nicht mehr ins Rezept geschrieben und nicht mehr gespeichert.

Es werden zusätzliche Systemvariablen ausgewertet. Ab Version 7.00 mögliche Variablenwerte:

  • 0: Wird vor dem Lesen gesetzt und ändert sich erst, wenn der Lesevorgang abgeschlossen ist.
  • 1: Lesen erfolgreich beendet.
  • 2: Beim Lesen ist ein nicht näher definierte Fehler aufgetreten.
  • 3: Mindestens eine Variable beim Lesen hat den Status INVALID.
  • 4: Mindestens ein Wert ist außerhalb der Min-Max Grenzen.
  • 5: Beim Lesen ist ein Timeout (30000 + 100*VarCount in [ms]) aufgetreten.


Treiber Allan Bradley RS-Linx

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> Treiber Allan Bradley RS-Linx

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Treiber unterstützt ab Version 7.00 SP0 Unsolicited Messages. Damit ändert sich die Konfiguration des Treibers. Diese erfolgt jetzt in den Registerkarten:

  • Allgemein: Unverändert
    Hinweis: Bei Verwendung von Unsolicited Messages sollte die Update Zeit Global deaktiviert werden
  • Konfiguration: Die bisherige KT-Nummer wird durch die Bezeichnung des RS-LINX Treibers ersetzt.
  • Unsolicited Messages Konfiguration: Neu. Einstellungen für Unsolicited Messages.

attention Achtung

In bestehenden Projekten muss die Treiberkonfiguration angepasst werden.


Umstellung SQL Server

Handbuch -> Projektkonvertierung -> Konvertierung von Version X auf Version 7.00 -> Umstellung SQL Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit zenon 7.00 SP0 wird der Microsoft SQL Server 2008 R2 Express installiert und für zenon Projekte verwendet. Der zenon Editor verbindet sich ab Version 7.00 standardmäßig nur zum SQL Server 2008 R2. Projekte, deren Datenbanken in einer anderen SQL-Server-Instanz (z.B. ZENON_DEV bei SQL Server 2005) liegen, können nicht geöffnet werden.

Die SQL Server Instanz, zu der sich der zenDBSrv verbindet, kann über das Startup Tool geändert werden. Das Startup Tool setzt in der zenDB.ini die entsprechenden Einträge für die jeweilige zenon Version:

  • vor 6.00: keine Datenbank
  • 6.00 bis 6.20: Einträge für SQL Server 2000 (MSDE)
  • 6.21 bis 6.51: Einträge für SQL Server 2005 Express Edition
    bei 6.51 wird das Passwort verschlüsselt abgelegt
  • Version 7.00 und höher: Einträge für den SQL Server 2008 R2 Express Edition mit verschlüsseltem Passwort

Ein Doppelbetrieb von SQL Server 2005 Instanz „ZENON_DEV" und SQL Server 2008 R2 Instanz „ZENON_2008R2" ist nicht möglich.

attention Achtung

Projekte aus früheren zenon Versionen müssen unbedingt in der Ursprungsversion exportiert und dann in zenon 7.00 zurückgelesen werden.

Tipp: Wurde kein Export durchgeführt und steht keine entsprechende Version mehr zur Verfügung, kann der Transfer manuell erfolgen:

  • kopieren Sie den kompletten Ordner inkulsive GUID an den neuen Ort
  • stellen Sie manuell die Datenbankverbindung her

Projektkonvertierung

Für die Konvertierung von Projekten vor Version 7.00 wird folgende Vorgangsweise empfohlen:

  1. Projektsicherungen in der Version, aus der konvertiert werden soll, erstellen.
  2. Projektsicherungen auf die Festplatte exportieren.
  3. zenon Editor 7.00 Editor.
  4. Neuen Arbeitsbereich erstellen.
  5. Die Projektsicherungen in den neuen Arbeitsbereich rücklesen.

Die Projektsicherungen können auch im selben Arbeitsbereich im 7.00 Editor rückgelesen werden. Da die GUID beim Rücklesen einer Projektsicherung gleichbleibt, kann der Arbeitsbereich in zenon 7.00 und in Versionen zwischen 6.21 und 6.51 geöffnet werden.

info Info

Obwohl die Projekte gleich heißen und die gleiche GUID haben, sind Projekte aus zenon 7.00 Projekte aufgrund der anderen SQL Server Instanz unabhängig von den Projekten aus zenon 6.21 bis 6.51. Sicherungen in zenon 7.00 scheinen im Editor 6.21 bis 6.51 nicht auf. Daher wird empfohlen, diese in einem neuen Arbeitsbereich abzulegen.


Projektsimulation

Handbuch -> Projektsimulation

Mithilfe der Projektsimulation haben Sie die Möglichkeit zwischen Simulationsmodus und Hardwaremodus umzuschalten. Im Simulationsmodus können Sie Abläufe zu Testzwecken simulieren. Dabei werden Schalthandlungen durchgeführt, Rezepte abgesetzt, Sollwerte gesetzt etc., ohne dass diese Operationen tatsächlich zum Prozess (z.B. zu einer Steuerung) gesendet werden.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig.

Bei Einzelplatzprojekten ist eine Lizenz für den Client nötig. Bei Serverprojekten muss nur der Server/Standby über eine Lizenz verfügen.

Wird am Server die Lizenzierung geändert, müssen die Clients neu gestartet werden, damit die Lizenz übernommen wird.

Simulationsbetrieb

Im Simulationsmodus:

  • werden alle Treiber im Modus Treibersimulation programmiert gestartet
  • werden keine Daten extern gespeichert:
    • SQL-Auslagerung wird nicht ausgeführt
    • Einträge für die IPA-Datenbank werden nicht erzeugt
    • vorhandene IPA-Einträge können nicht gelöscht, editiert oder kommentiert werden
  • werden PFS-Schichtdaten nicht in die Datenbank geschrieben
    (Das Speichern wird nach Runtimestart im Hardwaremodus nachgeholt.)

Noch in diesem Kapitel

Allgemein

Systemtreibervariable - Runtime-Zustand (Simulation)

Skripte

Besonderheiten im Simulationsmodus

Online Sprachübersetzung

Simulationsabbilder

Dateien im Simulationsabbild

Runtime Kommandozeilenparameter

Einschränkungen


Allgemein

Handbuch -> Projektsimulation -> Allgemein

Sie können nur in die Projektsimulation umschalten, wenn alle Projekte in der Runtime entweder Einzelplatz- oder Clientprojekte sind. Der Simulationsmodus "trennt" den Rechner bzw. die Runtime vom Netzwerk. Außerdem werden alle Treiber in Treibersimulation - programmiert gestartet. Demnach hat kein Treiber mehr eine Prozesskopplung.

Nach der Umschaltung in den Simulationsmodus wird die Runtime neu gestartet und verhält sich so, als wären alle Projekte als Einzelplatzprojekt projektiert.

Noch in diesem Kapitel

Umschalten in Simulationsmodus

Umschalten in Hardwaremodus

Simulationsabbild erzeugen

Funktion Projektsimulation aktivieren/deaktivieren


Umschalten in Simulationsmodus

Handbuch -> Projektsimulation -> Allgemein -> Umschalten in Simulationsmodus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie in den Simulationsmodus umschalten, werden folgende Schritte ausgeführt:

  1. Rufen Sie die Funktion zur Umschaltung in den Simulationsmodus auf.
  2. Es erfolgt eine Prüfung, ob alle Projekte in den Simulationsmodus geschaltet werden dürfen oder bereits im Simulationsmodus sind.
  3. Die Schritte von Simulationsabbild erzeugen werden durchgeführt.
  4. Für jedes Projekt wird ein Eintrag in der jeweiligen Chronologischen Ereignisliste erzeugt, der das Umschalten in den Simulationsmodus vermerkt.
  5. Die Runtime beendet sich und startet zenProcess mit zusätzlicher Parametrierung.
  6. zenProcess wartet bis die Runtime sich beendet hat und starte sie dann im Simulationsmodus.
  7. Die Runtime erkennt den Kommandozeilenparameter und startet alle Projekte als Einzelplatzprojekte.
  8. Das Verzeichnis für die Runtime-Daten ist jetzt das Simulationsverzeichnis. Das Verzeichnis der Runtime-Daten des Hardwaremodus wird nicht verändert.
  9. Die Projekte werden gestartet. Die Treiber starten im Modus Treibersimulation programmiert und werden mit dem Variablenabbild aus dem Simulationsverzeichnis geladen. Lokale Variablen erhalten ihre Werte aus dem lokalen Abbild. Das Variablenabbild wird auf die programmierte Simulation angewandt. Wird in der programmierten Treibersimulation die Variable sofort im ersten Zyklus eines Programms geändert, hat die Variable in der zenon Runtime dadurch als ersten Wert nicht den ursprünglichen Wert wie in der Runtime mit Hardwarekopplung, sondern den Wert, der in der Simulation geändert wurde.
  10. Das Abbild für die internen Treiber wird geladen.
  11. Für jedes Projekt wird ein Eintrag in der jeweiligen Chronologischen Ereignisliste erzeugt, der im Simulationsmodus gestartet wurde.
  12. Die Systemtreibervariable erhält den Wert für den Simulationsmodus.

Diese Punkte werden für alle Projekte in der Runtime durchgeführt, außer Sie haben es explizit anders angegeben.


Umschalten in Hardwaremodus

Handbuch -> Projektsimulation -> Allgemein -> Umschalten in Hardwaremodus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei jedem Runtime-Start ist der Hardwaremodus verfügbar, auch wenn nicht vom Simulationsmodus in den Hardwaremodus umgeschaltet wurde. Folgenden Schritte werden ausgeführt:

  1. Rufen Sie die Funktion zur Umschaltung in den Hardwaremodus auf.
  2. Das Treiberabbild (Prozesstreiber und interne Treiber) und das Abbild der zenon Logic Simulation wird gespeichert.
  3. Die Runtime beendet sich und startet zenProcess mit zusätzlicher Parametrierung.
  4. zenProcess wartet bis die Runtime sich beendet hat und starte sie dann mit den Startparametern für die Prozesskopplung.
  5. Die Runtime starte und lädt die Projekte und Runtime-Daten - ggf. vom Server.
  6. Die Treiber werden mit den Daten der lokalen Variablen vor der Simulation initialisiert.
  7. Wenn nötig wird das Simulationsabbild an den Server übertragen. Dies können Sie mit entsprechender Kommandozeilenparametrierung aktivieren.


Simulationsabbild erzeugen

Handbuch -> Projektsimulation -> Allgemein -> Simulationsabbild erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alle von der Runtime veränderbaren Dateien und Variablen werden im Simulationsabbild zusammengefasst. Wenn Sie ein Simulationsabbild erzeugen werden folgende Schritte durchgeführt:

  1. Alle Datenpunkte von allen Projekten werden angefordert, um sie mit aktuellen Daten zu versorgen.
  2. Im lokalen Simulationsabbild werden, je nach selektiertem Modus, die nicht benötigten Dateien gelöscht (Ausnahme: Mit existierendem Simulationsabbild initialisieren):
    1. Mit Prozessabbild und Runtime-Daten initialisieren (ohne Archivdateien): Das lokale Simulationsverzeichnis wird komplett gelöscht.
    2. Mit Prozessabbild und Runtime-Daten initialisieren (mit Archivdateien): Alle Archivdateien (*.ARX und *.ARS) werden im lokalen Simulationsverzeichnis gelöscht.
  3. Je nachdem welche Einstellungen Sie für die Funktion Projektsimulation aktivieren/deaktivieren vorgenommen haben, werden von allen Projekten die entsprechenden Projektdaten, Runtime-Daten und Variablendaten geholt. Für AML, CEL und HDD wird der aktuelle Zustand gesichert, lokal bei einem Einzelplatzprojekt und am Server bei einem Serverprojekt (Ausnahme: Mit existierendem Simulationsabbild initialisieren).

    Interne ID: Simulationsabbild erzeugen

    Projektsimulation aktivieren/deaktivieren

    Diese Funktion ermöglicht es Ihnen, zwischen Simulationsmodus und Hardwaremodus umzuschalten. Außerdem können Sie die Art des Simulationsmodus bzw. des Hardwaremodus auswählen.

    Mehr im Online-Handbuch

  4. Die in der Runtime änderbaren Projektdateien (z.B. Daten für PFS, Benutzer usw.) werden vom Simulationsabbild auf die entsprechende Datei im Projektverzeichnis kopiert (Ausnahme: Mit existierendem Simulationsabbild initialisieren).
  5. Es wird solange gewartet, bis alle Datenpunkte eine Wert bekommen haben. Der Fortschrittsbalken zeigt die Namen der Datenpunkte an. Die Anzeige ist auf 60 Zeichen beschränkt und zeigt nicht den zugehörigen Wert an. Die Wartezeit ist nicht begrenzt.
  6. Eine Variablenabbild aller Treiber wird erzeugt und die internen Treiber sicheren ihre Daten. Diese Abbilder werden im Rechnerverzeichnis abgelegt. Wenn Sie das Abbild in Simulation erzeugen, beinhaltet es auch das Abbild der Treibersimulation programmiert.
  7. Erneute Übertragung der veränderten Dateien wie in Punkt 3 bis Punkt 6.
  8. Das Variablenabbild wird mit dem lokalen Simulationsverzeichnis abgeglichen.
  9. Da Variablenabbild für lokale Variablen wird gesichert außer wenn ein Abbild in Simulation erzeugt wird.

Diese Punkte werden für alle Projekte in der Runtime durchgeführt, außer Sie haben es explizit anders angegeben.


Funktion Projektsimulation aktivieren/deaktivieren

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mithilfe der Funktion Projektsimulation aktivieren/deaktivieren schalten Sie zwischen dem Simulationsmodus und dem Hardwaremodus um.

Interne ID: Funktion Projektsimulation aktivieren/deaktivieren

Projektsimulation aktivieren/deaktivieren

Diese Funktion ermöglicht es Ihnen, zwischen Simulationsmodus und Hardwaremodus umzuschalten. Außerdem können Sie die Art des Simulationsmodus bzw. des Hardwaremodus auswählen.

Mehr im Online-Handbuch

Die zwei Modi können unter unterschiedlichen Voraussetzungen gestartet werden. Diese werden in den folgenden Kapiteln erklärt:

  • Simulationsmodus aktivieren:
    • Mit Prozessbild initialisieren
    • Mit Prozessbild und Runtime-Dateien initialisieren (ohne Archivdateien)
    • Mit Prozessbild und Runtime-Dateien initialisieren (mit Archivdateien)
    • Mit existierendem Simulationsabbild initialisieren
  • Hardwaremodus aktivieren:
    • Prozesskopplung aktivieren
    • Prozesskopplung aktivieren und Simulationsabbild auf Server übertragen
    • Simulationsabbild erzeugen (RT im Simulationsmodus) Simulationsabbild auf Server übertragen (RT im Hardwaremodus)

Weiters stehen Ihnen folgende generellen Optionen zur Verfügung:

Parameter

Beschreibung

Name des Simulationsabbilds (Computername, wenn leer)

Geben Sie hier den gewünschten Namen für das Simulationsabbild ein.

Hinweis: Es wird nur der Name des Ordners gespeichert.

Wenn Sie nicht explizit einen Namen angeben, wird der Name des Computers verwendet.

Fehlermeldungen in der Runtime anzeigen

Aktivieren Sie diese Checkbox, wenn Sie in der Runtime eine Fehlermeldung erhalten wollen, wenn die Funktionsausführung fehlerhaft war.

Diesen Dialog zur Runtime anbieten

Aktivieren Sie diese Checkbox, wenn Sie auch während der Runtime den Dialog angezeigt bekommen möchten.

Hinweis: In der Runtime sind die Einstellungen für die Modusauswahl gesperrt. Wenn Sie Prozesskopplung aktivieren selektiert haben, ist auch die Eingabe für den Namen des Prozessbilds gesperrt.

info Info

Wenn sich ein Projekt in der Runtime z. B. gerade beim Nachladen befindet oder nachgeladen werden soll oder oder in VBA ein Dialog geöffnet ist, wird die Funktion Projektsimulation aktivieren/deaktivieren nicht sofort ausgeführt. Sobald keine Verzögerungsgrund mehr vorliegt, wird die Funktion automatisch ausgeführt.

Noch in diesem Kapitel

Mit Prozessbild initialisieren

Mit Prozessbild und Runtime-Dateien initialisieren (ohne Archivdateien)

Mit Prozessbild und Runtime-Dateien initialisieren (mit Archivdateien)

Mit existierendem Simulationsabbild initialisieren

Prozesskopplung aktivieren

Prozesskopplung aktivieren und Simulationsabbild auf Server übertragen

Simulationsabbild erzeugen (RT im Simulationsmodus) Simulationsabbild auf Server übertragen (RT im Hardwaremodus)


Mit Prozessbild initialisieren

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren -> Mit Prozessbild initialisieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hierbei wird ein Abbild aller lokalen Variablen erzeugt und die in der Runtime modifizierbare Projektdaten werden gesichert. Danach wird die Runtime im Simulationsmodus neu gestartet.

Wird nur ausgeführt, wenn sich das Projekt nicht bereits im Simulationsmodus befindet.

info Info

Alle existierenden Daten im Abbild werden gelöscht. Für die Initialisierung werden nur die aktuellen Variablenwerte herangezogen.


Mit Prozessbild und Runtime-Dateien initialisieren (ohne Archivdateien)

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren -> Mit Prozessbild und Runtime-Dateien initialisieren (ohne Archivdateien)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hierbei wird ein Abbild aller lokalen Variablen und sämtlicher Dateien aus dem Rechnerverzeichnis (Ausnahme: Archivdaten) erzeugt und die in der Runtime modifizierbare Projektdaten werden gesichert. Danach wird die Runtime im Simulationsmodus neu gestartet.

info Info

Alle existierenden Daten im Abbild werden gelöscht. Für die Initialisierung werden nur die aktuellen Variablenwerte herangezogen

info Info

Beachten Sie, dass alle historischen Alarme und CEL-Dateien umkopiert werden. Diese kann je nach Umfang der anfallenden Dateien einige Zeit in anspruch nehmen.


Mit Prozessbild und Runtime-Dateien initialisieren (mit Archivdateien)

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren -> Mit Prozessbild und Runtime-Dateien initialisieren (mit Archivdateien)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hierbei wird ein Abbild aller lokalen Variablen und sämtlicher Dateien aus dem Rechnerverzeichnis erzeugt - eventuell lokal im Abbild vorhandene Archivdaten werden nicht gelöscht - und die in der Runtime modifizierbare Projektdaten werden gesichert. Danach wird die Runtime im Simulationsmodus neu gestartet.

info Info

Alle existierenden Daten im Abbild werden gelöscht. Für die Initialisierung werden nur die aktuellen Variablenwerte herangezogen

info Info

Beachten Sie, dass alle historischen Alarme und CEL-Dateien und Archivdateien umkopiert werden. Diese kann je nach Umfang der anfallenden Dateien einige Zeit in Anspruch nehmen.

info Info

Hierbei bleiben die alten Archive erhalten. Die Archivierung fängt beim Runtime-Start an, die fehlenden Archive aufzufüllen, falls Sie das so projektiert haben. Diese kann je nach Umfang einige Zeit in Anspruch nehmen.


Mit existierendem Simulationsabbild initialisieren

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren -> Mit existierendem Simulationsabbild initialisieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hierbei wird ein vorhandenes Simulationsabbild vom Server zum Client übertragen. Bei einem Einzelplatzprojekt findet keine Übertragung statt. Der jeweilige Zustand der lokalen Variablen wird gesichert und die Runtime wird auf Grundlage des Simulationsabbilds neu gestartet. Die Runtime wird auch neu gestartet, wenn sie sich bereits im Simulationsmodus befindet. Wenn das der Fall war, wird jedoch kein Treiberabbild der lokalen Variablen für den Star im Hardwaremodus gespeichert.

info Info

Durch die Möglichkeit sich ein Simulationsabbild (mithilfe von Simulationsabbild erzeugen) zu erstellen, können Sie eine Simulation immer wieder von genau der gleichen Stelle und unter den gleichen Voraussetzungen beginnen. Im Abbild werden nicht nur die Variablenwerte gespeichert, sonder auch der jeweilige Zustand der Treibersimulation programmiert. Da das Abbild vom Server (falls vorhanden) übertragen wird, haben Sie auch die Möglichkeit, dass mehrere Clients mit demselben Abbild arbeiten. Beim Runtime-Start wird das Abbild vom Server umkopiert. Dabei werden nur die Änderungen übertragen.


Prozesskopplung aktivieren

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren -> Prozesskopplung aktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hierbei schalten Sie vom Simulationsmodus in den Hardwaremodus um. Dafür wird das Abbild der lokalen Variablen verwendet.

Beim Beenden des Simulationsmodus wird das Simulationsabbild gespeichert, so dass der letzte Stand des Simulationsmodus bei Bedarf wieder hergestellt werden kann. Falls eine Serververbindung besteht, wird das Simulationsabbild zum Server übertragen und dort gespeichert.

attention Achtung

Wenn gleichzeitig von mehreren Clients ein Übertragung für das gleiche Simulationsabbild erfolgt, ist nicht garantiert, dass das abgelegte Simulationsabbild funktionsfähig ist.


Prozesskopplung aktivieren und Simulationsabbild auf Server übertragen

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren -> Prozesskopplung aktivieren und Simulationsabbild auf Server übertragen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mithilfe der Projektsimulation haben Sie die Möglichkeit zwischen Simulationsmodus und Hardwaremodus umzuschalten. Im Simulationsmodus können Sie Abläufe zu Testzwecken simulieren. Dabei werden Schalthandlungen durchgeführt, Rezepte abgesetzt, Sollwerte gesetzt etc., ohne dass diese Operationen tatsächlich zum Prozess (z.B. zu einer Steuerung) gesendet werden.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig.

Bei Einzelplatzprojekten ist eine Lizenz für den Client nötig. Bei Serverprojekten muss nur der Server/Standby über eine Lizenz verfügen.

Wird am Server die Lizenzierung geändert, müssen die Clients neu gestartet werden, damit die Lizenz übernommen wird.

Simulationsbetrieb

Im Simulationsmodus:

  • werden alle Treiber im Modus Treibersimulation programmiert gestartet
  • werden keine Daten extern gespeichert:
    • SQL-Auslagerung wird nicht ausgeführt
    • Einträge für die IPA-Datenbank werden nicht erzeugt
    • vorhandene IPA-Einträge können nicht gelöscht, editiert oder kommentiert werden
  • werden PFS-Schichtdaten nicht in die Datenbank geschrieben
    (Das Speichern wird nach Runtimestart im Hardwaremodus nachgeholt.)

Zusätzlich wird das Simulationsabbild an den Server übertragen und steht somit auch anderen Clients zur Verfügung.


Simulationsabbild erzeugen (RT im Simulationsmodus) Simulationsabbild auf Server übertragen (RT im Hardwaremodus)

Handbuch -> Projektsimulation -> Allgemein -> Funktion Projektsimulation aktivieren/deaktivieren -> Simulationsabbild erzeugen (RT im Simulationsmodus) Simulationsabbild auf Server übertragen (RT im Hardwaremodus)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hierbei erzeugen Sie ein Simulationsabbild und speichern es unter dem angegebenen Namen lokal ab, wenn Sie sich im Simulationsmodus befinden.

Im Hardwaremodus wird das Simulationsabbild zum Server übertragen, falls vorhanden und dort unter dem angegebenen Namen gespeichert.

info Info

Hiermit können Sie sich ein Abbild der momentanen Zustände erstellen und abspeichern. Zu einem beliebigen späteren Zeitpunkt können Sie dann genau an dieser Stelle mit den gleichen Voraussetzungen weiter machen.


Systemtreibervariable - Runtime-Zustand (Simulation)

Handbuch -> Projektsimulation -> Systemtreibervariable - Runtime-Zustand (Simulation)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Systemtreibervariable Runtime-Zustand (Simulation) gibt an, in welchem Zustand sich die Runtime gerade befindet. Die Variable finden Sie unter dem Thema Systeminfo. Folgende Zustände sind vorhanden:

Zustand | Beschreibung
0 | Prozesskopplung - die Runtime befindet sich im Hardwaremodus.
1 | In Simulation auf Prozesskopplung wechseln
2 | Mit Prozesskopplung auf Simulation wechseln
3 | In Simulation - die Runtime befindet sich im Simulationsmodus


Skripte

Handbuch -> Projektsimulation -> Skripte

Für den Simulationsmodus stehen Ihnen diese Skripte zur Verfügung, die automatisch ausgeführt werden:

Skript | Beschreibung
AUTOSTART_SIMUL | Wenn die Runtime im Simulationsmodus startet, wird automatisch das Skript mit dem Namen AUTOSTART_SIMUL ausgeführt, wenn es vorhanden ist.
AUTOEND_SIMUL | Wenn die Runtime den Simulationsmodus beendet, wird automatisch das Skript mit dem Namen AUTOEND_SIMUL ausgeführt, wenn es vorhanden ist.


Besonderheiten im Simulationsmodus

Handbuch -> Projektsimulation -> Besonderheiten im Simulationsmodus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Unterschiede bestehen zwischen dem Hardwaremodus und dem Simulationsmodus:

  • Backupverzeichnis wird nicht verwendet
  • Archive werden nicht ausgelagert
  • Archive werden nur im zenon Format gespeichert
  • Die Funktion Archive exportieren kann nicht ausgeführt werden
  • SQL-Datenauslagerung ist für verschiedene Module deaktiviert
  • Das Message Control ist deaktiviert
  • zenon Logic Runtimes werden nicht gestartet
  • Es wird kein Datenaustausch mit einer zenon Logic Runtime über einen zenon Treiber vorgenommen
  • Keine Simulation am zenon Webclient und unter Windows CE
  • Variablen vom SB bleiben ohne Wert
  • Umschalten der Treiber zwischen Hardware und Simulation wird nicht ausgeführt
  • Ein Skript wird eventuell nicht fertig ausgeführt, wenn eine Funktion, die den Neustart der Runtime veranlasst, im Skript ausgeführt wird
  • Das Simulationsprogramm, das in der Treibersimulation programmiert enthalten ist wird auch für die Projektsimulation verwendet
  • Im Simulationsmodus speichert die Funktion Remanentdaten speichern keine Werte von folgenden Treibern:
    • Intern Treiber
    • Mathematik Treiber
    • System Treiber


Online Sprachübersetzung

Handbuch -> Projektsimulation -> Online Sprachübersetzung

Definieren Sie die Texte für die Sprachübersetzung für alle Projekte im Startprojekt. Ebenso definieren Sie die Funktion im Startprojekt. Hierdurch ist gewährleistet, dass Sie den Onlinetext im richtigen Projekt haben. Eventuelle Fehlermeldungen werden ebenfalls beim entsprechenden Projekt eingetragen.


Simulationsabbilder

Handbuch -> Projektsimulation -> Simulationsabbilder

Um eine Wiederherstellen zu gewährleisten, müssen die Werte der Variablen von den Treibern in den folgenden Dateien gespeichert werden:

Dateiname | Beschreibung
Drv'Treiber-ID'.sim | In diesen Datei werden die Werte aller Datenpunkte am jeweiligen Treiber gespeichert. Die Dateien werden benötigt, um nach Neustart der Runtime in Simulation die aktuellen Werte wieder herzustellen. Wenn die Dateien während des Simulationsmodus erzeugt wurden, ist auch ein Abbild der programmierbaren Simulation beinhaltet.
Drv'Treiber-ID'.lsim | In diesen Dateien sind für den jeweiligen Treiber die Werte der lokalen Variablen gespeichert. Wenn die Runtime mit Prozesskopplung startet und diese Dateien gefunden werden, erhalten die lokalen Variablen die Werte aus den Dateien. Anschließend werden die Dateien gelöscht. Dies geschieht auch, wenn die Runtime manuell gestartet wird.
Drv'Treiber-ID'.lssim | Speichert das Abbild der lokalen Variablen, das in das Simulationsabbild aufgenommen wird.


Dateien im Simulationsabbild

Handbuch -> Projektsimulation -> Dateien im Simulationsabbild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein Abbild für die Simulation erzeugt wird, werden aus verschiedenen Quellen Dateien und Verzeichnisse in das Abbild übernommen. Bei aktiver Simulation wird dann auf diese Dateien zugegriffen und nicht mehr auf die Originalen, die z. B. im Rechnerverzeichnis gespeichert sind.

Aus dem Systemverzeichnis des Projekts werden folgende Dateien in das Systemverzeichnis des Abbilds kopiert:

  • project.mdb
  • rezepturen.cmp
  • rezepturenrt.cmp
  • fpm.cmp
  • password.cmp
  • passwordrt.cmp

und folgende Verzeichnisse:

  • system\rgm_fb
  • system\rt_profiles
  • system\reports

Aus dem Rechnerverzeichnis werde alle Dateien bis auf die mit der Endung *.lsim übernommen. Für den Modus Simulation ohne Abbild, werden die Dateien *.sim, internvar.bin, sy_ma32.bin und uservar.bin übernommen. Für den Modus Simulation ohne Archive werden alle Dateien bis auf die mit der Endung *.arx und *.ars übernommen.


Runtime Kommandozeilenparameter

Handbuch -> Projektsimulation -> Runtime Kommandozeilenparameter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime erkennt durch die Kommandozeilenparameter, ob im Simulationmodus oder im Hardwaremodus gestartet werden soll. Wenn keine der beiden folgenden Parameter angegeben wurde, startet die Runtime im Hardwaremodus.

Diese Parameter können auch bei einem manuellen Start angegeben werden.

Parameter

Beschreibung

SIMUL

Mit diesem Parameter geben Sie an, dass die Runtime im Simulationsmodus gestartet werden soll.

SIMUL[=Abbildname]
  • Abbildname

Dieser Zusatz ist optional und definiert den Namen des Simulationsabbilds, das für den Simulationsmodus verwendet werden soll.
Wenn Sie keinen Abbildnamen angeben, wird der Rechnername verwendet.

REALMODE

Mit diesem Parameter geben Sie an, dass die Runtime im Hardwaremodus gestartet werden soll.

REALMODE[=Abbildname]
  • Abbildname

Dieser Zusatz ist optional und definiert den Namen des Simulationsabbilds, das nach dem Start an den Server übertragen werden soll. Wenn Sie keinen Abbildnamen angeben, findet keine Übertragung statt.

CANCEL

Mit diesem Parameter brechen Sie den Umschaltvorgang ab. Die Runtime wird beendet, jedoch nicht neu gestartet.

RESTART

Nach einer Wartezeit von 30 Sekunden, werden auch die "hängenden" Prozesse beendet und die Runtime neu gestartet.

zenProcess

Die Applikation zenProcess.exe wird verwendet um die zenon Runtime beim Umschalten zwischen den beiden Modi - Simulationsmodus und Hardwaremodus - neu zu starten. Dabei wird gewartet, bis sich alle Prozesse der Runtime beendet haben. Solange werden die Anzahl und einige Namen - maximal 5 - der laufenden Prozesse, auf deren Beendigung gewartet wird, angezeigt. Anschließend wird die Runtime neu gestartet.


Einschränkungen

Handbuch -> Projektsimulation -> Einschränkungen

Folgende Einschränkungen sind bekannt:

  • Das Modul Batch Control wird in der Simulation nicht unterstützt.


Projektverwaltung und Arbeitsbereich

Handbuch -> Projektverwaltung und Arbeitsbereich

Jedes Projekt ist einem Arbeitsbereich zugeordnet.

Die Arbeitsbereiche und Projekte werden im Projektmanager angezeigt.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Arbeitsbereich

Projekt

Intergrationsprojekt

Globalprojekt

Projektierung des Projektfilters

Konfiguration


Arbeitsbereich

Handbuch -> Projektverwaltung und Arbeitsbereich -> Arbeitsbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Innerhalb eines Arbeitsbereiches können mehrere Projekte angelegt und verwaltet werden. Alle Daten, die für einen Arbeitsbereich definiert und gespeichert werden, sind Bestandteil der zenon Datenbank.

Die Verwaltung mehrerer Projekte in einem Arbeitsbereich bietet sich dann an, wenn mehrere Projekte in einer Anlage über ein Netzwerk verbunden laufen sollten. Zur gleichen Zeit können auch mehrere Projekte bearbeitet werden.

Alternativ kann ein weiterer Arbeitsbereich in einem anderen Verzeichnis für die Aufnahme der Projekte generiert werden.

Example Beispiel

/KUNDE1/PROJEKT: (ein oder mehrere Projekte im Arbeitsbereich)

/KUNDE2/PROJEKT: (ein oder mehrere Projekte im Arbeitsbereich)

Die Struktur der Datenbank wird durch Schema-Dateien definiert. Sie sind die Grundlage bei einer vollständigen Neuerstellung einer Projektdatenbank. Für den Rezeptgruppen- Manager ist eine zusätzliche Datenbankdatei im MS-ACCESS Format (MDB) vorhanden.

attention Achtung

Es sind keine vorprojektierten Daten vorhanden!

Noch in diesem Kapitel

Neuen Arbeitsbereich anlegen

Arbeitsbereich speichern

Bestehenden Arbeitsbereich bearbeiten

Arbeitsbereich sichern und rücklesen


Neuen Arbeitsbereich anlegen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Arbeitsbereich -> Neuen Arbeitsbereich anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es gibt zwei Möglichkeiten, um einen neuen Arbeitsbereich anzulegen:

  • Dropdownliste > Datei -> Arbeitsbereich -> Neu oder
  • Kontextmenü des Eintrags Arbeitsbereich im Projektbaum / Eintrag Arbeitsbereich / Neu

Parameter | Beschreibung
Name | Vergeben Sie einen frei wählbaren Namen für Ihren neuen Arbeitsbereich. Der Default-Name <Arbeitsbereich> ist ungültig und muss ersetzt werden.
Speicherstelle | Selektieren Sie einen Ordner in dem Sie Ihren neuen Arbeitsbereich speichern wollen. Als Default-Speicherstelle wird das Benutzerverzeichnis vorgeschlagen.
Arbeitsbereichdatei | Der Pfad wird automatisch mit Ihren Angaben erstellt


Arbeitsbereich speichern

Handbuch -> Projektverwaltung und Arbeitsbereich -> Arbeitsbereich -> Arbeitsbereich speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es gibt zwei Möglichkeiten, um einen Arbeitsbereich zu speichern:

  • Dropwdownliste / Datei / Arbeitsbereich / Speichern bzw. Speichern unter oder
  • Kontextmenü des Eintrags Arbeitsbereich im Projektbaum / Eintrag Arbeitsbereich / Speichern bzw. Speichern unter

Wenn Sie den Eintrag Speichern unter wählen, können Sie die Speicherstelle selbst definieren. In diesem Fall wird ein bestehender Arbeitsbereich unter neuem Namen gespeichert.

Parameter | Beschreibung
Name | Vergeben Sie einen frei wählbaren Namen, unter dem Sie Ihren Arbeitsbereich speichern wollen. Der Default-Name <Arbeitsbereich> ist ungültig und muss ersetzt werden.
Speicherstelle | Selektieren Sie einen Ordner in dem Sie Ihren neuen Arbeitsbereich speichern wollen. Als Default-Speicherstelle wird das Benutzerverzeichnis vorgeschlagen.
Arbeitsbereichdatei | Der Pfad wird automatisch mit Ihren Angaben erstellt

Die Arbeitsbereiche werden als *.WSP-Dateien gespeichert.

info Info

Befindet sich ein Projekt mit einer niedrigeren Versionsnummer als der Editor im Arbeitsbereich, kann der Menüeintrag "Arbeitsbereich/speichern unter..." nicht ausgewählt werden. Dieses Projekt muss erst zur Editor-Version konvertiert werden, bevor der Arbeitsbereich gespeichert werden kann.


Bestehenden Arbeitsbereich bearbeiten

Handbuch -> Projektverwaltung und Arbeitsbereich -> Arbeitsbereich -> Bestehenden Arbeitsbereich bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es gibt zwei Möglichkeiten, um einen bestehenden Arbeitsbereich zu öffnen:

  • Pulldownmenü / Datei / Arbeitsbereich / Öffnen oder
  • Kontextmenü des Eintrags Arbeitsbereich im Projektbaum / Eintrag Arbeitsbereich / Öffnen


Arbeitsbereich sichern und rücklesen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Arbeitsbereich -> Arbeitsbereich sichern und rücklesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Informationen zum Sichern und Rücklesen von bestehenden Arbeitsbereichen finden Sie im Kapitel Projektsicherungen / Abschnitt Arbeitsbereich sichern und rücklesen.


Projekt

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt

Ist der Arbeitsbereich geöffnet, können ein oder mehrere Projekte aus dem Projektmanager bearbeitet oder neu ausgewählt werden. Ein bereits bestehendes Projekt kann jederzeit in den geöffneten Arbeitsbereich eingefügt werden.

Noch in diesem Kapitel

Neues Projekt anlegen

Projekt speichern

Bestehendes Projekt einfügen

Bestehendes Projekt bearbeiten

Projektbezüge ersetzen

Projekt sichern und rücklesen

Projekt aus Arbeitsbereich entfernen

Projekt löschen


Neues Projekt anlegen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Neues Projekt anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es gibt zwei Möglichkeiten, um ein neues Projekt anzulegen:

  • Dropdownmenü -> Datei ->Projekt neu oder
  • Kontextmenü des Eintrags Arbeitsbereich im Projektbaum / Eintrag Projekt neu

Parameter

Beschreibung

Projekttyp

Wählen Sie zwischen Standardprojekt und Globalprojekt aus.

Projektname

Vergeben Sie einen frei wählbaren Namen für das Projekt. Der Default-Name <Projekt> ist ungültig und muss ersetzt werden.

Erlaubt sind: Ziffern, Buchstaben und folgende Sonderzeichen:
$, -, @, _, {}, ~, !, ()

Basisordner

Ordner, in dem das neue Projekt gespeichert werden soll.

Arbeitsbereich

Wahl des Arbeitsbereichs:

  • An aktiven Arbeitsbereich anhängen:
    Das neue Projekt wird an den Arbeitsbereich angehängt, der gerade aktiv ist. Als Default-Speicherstelle wird der Pfad des Arbeitsbereiches vorgeschlagen.
  • Neuen Arbeitsbereich erzeugen:
    Mit dem Projekt wird auch ein neuer Arbeitsbereich erstellt. Der Arbeitsbereichname wird automatisch im Fekld Runtime-Ordner eingefügt.

Arbeitsbereichname

Vergeben Sie einen frei wählbaren Namen für Ihren neuen Arbeitsbereich. Der Default-Name <Arbeitsbereich> ist ungültig und muss ersetzt werden.

Runtime-Ordner

Der Standard-Speicherplatz für den Runtime-Ordner ist bereits voreingestellt. Dieser kann hier geändert werden.

Hinweis: Unterhalb des Runtime-Ordners wird automatisch der Datenordner für Runtime-Dateien angelegt. Dessen Pfad kann über die Eigenschaft Allgemein/Datenordner individuell geändert werden. Beachten Sie dabei, dass der Pfad immer erreichbar sein muss, da sonst Runtime-Daten nicht mehr geschrieben werden können.

Interne ID: Neues Projekt anlegen

Datenordner

Leer: Der Standardpfad wird für das Speichern von Alarmmeldeliste, Chronologischer Ereignisliste (CEL), Harddisk-Daten, Archivdaten etc.verwendet (Projektpfad\Rechnername\Projektname).
Pfad: Der hier eingegebene Pfad wird zum Speichern der Daten verwendet ("Eingegebener Pfad\Rechnername\Projektname").
Achtung: Falls der eingegebene Pfad nicht existiert (Netzwerkprobleme, Wechseldatanträger nicht vorhanden), werden von der Runtime keine Daten mehr geschrieben. Das bedeutet: 100% Datenverlust. Die Runtime bleibt bedienbar, muss aber neu gestartet werden. Die Verfügbarkeit des Ordners kann mit der Systemtreibervariablen Runtime Datenordner nicht verfügbar überprüft werden.
Tipp: Setzen Sie den Datenordner nie auf ein entfernbares Laufwerk, wie einen USB Stick oder ein Netzlaufwerk. Daten am besten lokal aufzeichnen und extern sichern

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Neues Projekt anlegen

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Optionen

Mehrplatzfähiges Projekt

Aktiv: Mehrere Benutzer können ein Projekt gleichzeitig bearbeiten (Details siehe Verteiltes Engineering.)

Projektserver

Auswahl des Projektservers für Mehrplatzfähige Projekte.


Projekt speichern

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Projekt speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Projekt unter einem neuen Namen zu speichern, muss im Kontextmenü des Projektes der Eintrag Projekt / Speichern unter ausgewählt werden. Im Dialog können Sie den neuen Projektnamen angeben.

Wenn Sie einen Projekt unter einem bereits existierenden Namen speichern, werden Sie per Hinweisbox darauf aufmerksam gemacht.

info Info

Es ist mit dieser Funktionalität z.B. auch möglich, eine Kopie eines vorhandenen Projektes zu erstellen, die dann verändert werden kann.

Dazu wird das Projekt A im Kontextmenü mit Speichern unter kopiert und kann anschliessend entsprechend angepasst werden. Anschliessend wird es als Projekt B gespeichert (wieder Kontextmenü Speichern unter).

Je nachdem in wie vielen Punkten sich die beiden Projekte voneinander unterscheiden sollen, kann diese Möglichkeit eine Zeitersparnis gegenüber Import/Export von Projektteilen bieten.


Bestehendes Projekt einfügen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Bestehendes Projekt einfügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein bestehendes Projekt in den Arbeitsbereich einzufügen:

  • führen Sie einen Rechtsklick auf den Arbeitsbereich aus
  • wählen Sie den Befehl Bestehendes Projekt einfügen
  • der Dialog zur Projektauswahl wird geöffnet

Um detaillierte Informationen zu den einzelnen Projekten, vor allem zum Typ, zu erhalten, öffnen Sie den Projektknoten im Auswahlfenster. Sie erhalten Informationen zu:

Information | Beschreibung
Projekt ID | Eindeutige ID des Projekts.
Projekt Version | Editorversion mit der das Projekt erstellt/bearbeitet wurde.
System-Datenbank Version | Version der System-Datenbank.
System-Tabelle Version | Version der System-Tabelle.
Typ: | Zeigt Projekttyp an: Standardprojekt oder Globalprojekt.
Verbundene lokale Projektkopien | Nur bei Mehrplatzfähigen Projekten (gekennzeichnet durch den Buchstaben M im Symbol): Anzeige der Projektkopien auf anderen Rechnern.


Bestehendes Projekt bearbeiten

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Bestehendes Projekt bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Auswahl eines bestehenden Projektes erfolgt über den Projektmanager durch einfaches Anklicken mit der linken Maustaste. Klicken Sie mit der rechten Maustaste in den Projektmanager erhalten Sie folgendes Kontextmenü.

Verfügbare Funktionen sind:

Parameter | Beschreibung
Runtime Dateien |
- Erzeuge geänderte | geänderte Runtime Dateien für das aktive Projekt erzeugen
- Erzeuge alle | alle Runtime Dateien für das aktive Projekt erzeugen
- Importieren | In der Runtime änderbare Dateien werden in den Editor-Pfad zurückgelesen - Standard Rezepte - Rezepte des Rezeptgruppen Managers - User Verwaltung - Fahrpläne und Profile
Projekt als Startprojekt | setzen des Runtime Startprojekts für den aktuellen Rechner
Starte Runtime | Runtime wird mit dem als Startprojekt gesetzten Projekt gestartet
Projekt aktiv | aktives Projekt für die Toolbars des Editors und die Querverweisliste setzen. Alle anderen Projekte, die nicht die Option Projekt im Speicher halten gesetzt haben, werden deaktiviert.
Projekt im Speicher halten | das Projekt bleibt im Arbeitsspeicher, auch wenn ein anderes Projekt aktiviert wird
Projekt |
- Umbenennen | Ändert den Namen des Projektes
- Speichern unter ... | speichert das Projekt unter einem neuen Namen in einem neuen Verzeichnis ab
- Eigenschaften | öffnet das Eigenschaften-Fenster mit den Projekt-Eigenschaften
- Aus Arbeitsbereich entfernen | entfernt das Projekt aus dem aktuellen Arbeitsbereich ohne es jedoch physikalisch zu löschen
- Löschen | Löscht das Projekt physikalisch
- Sicherung erstellen... | Erstellt eine Sicherung des Projekts
- Sicherung rücklesen... | Liest einen gesicherten Projektstand zurück in den aktuellen Arbeitsbereich
Projekt Remote Transport | öffnet das Untermenü Projekt Remote Transport Das Untermenü Projekt Remote Transport bietet folgende Funktionen:
- Verbindung aufbauen | die Remote Verbindung zum Zielrechner wird aufgebaut
- Geänderte Runtime Dateien übertragen | nur geänderte Runtime Dateien werden auf den Zielrechner transportiert
- Alle Runtime Dateien übertragen | alle Runtimedateien werden auf den Zielrechner transportiert
- Alle Runtime Dateien zurücklesen | die in der Runtime änderbaren Dateien (z.B. Rezepte, User-Verwaltung, etc.) werden zu den Editordateien zurückgelesen
- Projekt als Startprojekt | das Startprojekt für den Zielrechner wird gesetzt
- Starte Runtime | die Runtime auf dem Zielrechner wird gestartet
- Beende Runtime | die Runtime auf dem Zielrechner wird beendet
- Projekt Nachladen | die Funktion Nachladen wird auf dem Runtime-Rechner ausgeführt
- Fehler Dateien anfordern | die Fehlerdatei vom Zielrechner wird angeordert
- Neustart OS | das Betriebssystem auf dem Zielrechner wird neu gestartet
- System Status ermitteln | der Systemstatus des Zielrechners wird ermittelt
- Remote Passwort ändern | das Passwort für den Remote Zugriff auf den Projektrechner wird geändert
Profil | Öffnet ein Untermenü, in dem ein angelegtes Profil ausgwählt werden kann (siehe Kapitel Editor Bediensystem)
Hilfe | Öffnet die Online-Hilfe

Jedes Projekt kann über ein Passwort (Kapitel Passwortschutz) geschützt werden, d.h. beim Öffnen des Projektes wird das im Projekt definierte Passwort abgefragt. Ist die Eingabe korrekt, wird das Projekt geöffnet.


Projektbezüge ersetzen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Projektbezüge ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Werden Projekte kopiert, müssen deren Bezüge zu übergeordneten Projekten eventuell neu zugeordnet werden. Der Assistent Projektbezüge ersetzen unterstützt das automatisierte Ersetzen von Projektbezüge auf Bilder, Variablen und Funktionen. Es wird automatisch nach allen Projektbezügen gesucht, die anschließend durch die Bilder, Funktionen, Variablen eines anderen auswählbaren Projektes ersetzt werden können.

Um Projektbezüge zu ersetzen:

  1. müssen Arbeitsbereich und Unterprojekte gespeichert sein
  2. wählen Sie im Kontextmenü des Intergrationsprojekt den Befehl Projektbezüge ersetzen
  3. der Dialog zur Auswahl eines Projekts wird geöffnet
  4. wählen Sie die gewünschten Zuordnungen aus
  5. bestätigen und schließen Sie den Dialog mit Klick auf OK

Parameter

Beschreibung

Ersetzungsliste

Liste der Projektzuordnung für das Ersetzen von Bezügen:

  • Projekt alt:
    Enthält automatisch alle Quellprojekte. Ist diese Liste leer, dann existieren im Arbeitsbereich keine übergeordneten Projektemit Verknüpfungen zu Unterprojekten.
  • Projekt neu:
    Projekt, das die Bezüge übernehmen soll. Auswahl aus Liste mögliche Projekte durch Klick auf Schaltfläche mit Pfeil.

mögliche Projekte

Projekte, mit denen Quellprojekte ersetzt werden können. Auswahl:

  • gewünschtes Projekt alt markieren
  • gewünschtes neues Projekt markieren
  • auf Schaltfläche mit Pfeil nach links klicken

Zuordnung aufheben:

  • gewünschte Zuordnung in Ersetzungsliste markieren
  • auf Schaltfläche mit Pfeil nach rechts klicken

OK

Übernimmt Zuordnung und führt Ersetzung durch.

Anzahl der ersetzten Projektbezüge wird im Ausgabefenster angezeigt.

Abbrechen

Verwirft Einstellungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Projekt sichern und rücklesen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Projekt sichern und rücklesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Informationen zum Sichern und Rücklesen von bestehenden Projekten finden Sie im Kapitel Projektsicherungen.


Projekt aus Arbeitsbereich entfernen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Projekt aus Arbeitsbereich entfernen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Projekt aus dem Arbeitsbereich in dem es sich befindet zu entfernen, wählen Sie im Kontextmenü des Projektes den Eintrag Projekt / aus Arbeitsbereich entfernen .

Das Projekt ist dadurch nicht gelöscht. Siehe Abschnitt Projekt löschen.


Projekt löschen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projekt -> Projekt löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Informationen zum Löschen von Projekten finden Sie im Kaptiel Projektsicherungen / Projekt löschen.


Intergrationsprojekt

Handbuch -> Projektverwaltung und Arbeitsbereich -> Intergrationsprojekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon bietet die Möglichkeit der mehr-hierarchischen Projektstruktur. In einem solchen Fall wird beispielsweise ein Integrationsprojekt (Dachprojekt) mit mehreren Unterprojekten realisiert.

Als zentrale Stelle enthält das Integrationsprojekt die Übersichtsbilder, in denen die Prozesswerte der Unterprojekte dargestellt werden.

Example Beispiel

Über die Rezepturen im Integrationsprojekt werden Sollwertvorgaben zentral verwaltet um die einzelnen Projekten optimal steuern zu können.

Mittels projektübergreifender Archive im Integrationsprojekt können die Daten der Unterprojekte an einer zentralen Stelle gesammelt werden.

Es ist möglich, Variablen aus Unterprojekten im Integrationsprojekt zu verwenden.

Nähere Informationen zum Projektbezüge ersetzen finden Sie im Abschnitt Projektbezüge ersetzen.

attention Achtung

Benennung von Schablonen: Vermeiden Sie gleiche Namen für Schablonen in Integrations- und Unterprojekten. Denn:

  • Ist eine Schablone mit gleichem Namen bereits geöffnet, so wird diese zum Aufschalten des Bildes verwendet - unabhängig von ihrer Projektzugehörigkeit.
  • Falls noch keine Schablone mit passendem Namen geöffnet ist, wird jene aus dem Projekt des Bildes verwendet.

Dateipfade

Subprojekte, die beim Erstellen am gleichen Ordnerknoten wie das Integrationsprojekt, liegen, verwenden immer dieselbe Struktur wie das Integrationsprojekt. Jedes Sub-Projekt wird in der Project.ini mit relativem Pfad zum Integrationsprojekt eingetragen. Wird der Runtime-Pfad für das Integrationsprojekt verändert, ändern sich auch die Pfade für die Subprojekte. Damit ist sicher gestellt, dass die Runtime die nötigen Pfade findet.

Noch in diesem Kapitel

Kopieren der Unterprojekte


Kopieren der Unterprojekte

Handbuch -> Projektverwaltung und Arbeitsbereich -> Intergrationsprojekt -> Kopieren der Unterprojekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um zu verhindern, dass nach Kopieren der Unterprojekte die Verknüpfungen des Integrationsprojekt auf die falschen Unterprojekte verweisen, bietet zenon die Möglichkeit Projektbezüge zu ersetzen oder den kompletten Arbeitsbereich zu kopieren.

Auch ohne eine Kopie vom Integrationsprojekt erstellen zu müssen, können die Verknüpfungen vom Integrationsprojekt zum Unterprojekt gezielt durch die Verknüpfungen mit einer Kopie eines Unterprojektes ersetzt werden.

Noch in diesem Kapitel

Kopieren des kompletten Arbeitsbereiches


Kopieren des kompletten Arbeitsbereiches

Handbuch -> Projektverwaltung und Arbeitsbereich -> Intergrationsprojekt -> Kopieren der Unterprojekte -> Kopieren des kompletten Arbeitsbereiches

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es wird vom kompletten Arbeitsbereich eine Kopie erstellt. Für jedes Projekt wird ein „Speichern unter“ durchgeführt und es entsteht eine neue GUID. Die Projekte behalten aber ihren Originalnamen. Der Arbeitsbereich wird automatisch mit den neuen Projekten geladen. Bei dieser Lösung wird das gesamte Integrationsprojekt nach Variablen- und Funktionsverknüpfungen durchsucht, die auf andere Projekte zeigen. In diese Verknüpfungen wird die GUID des Originalprojektes durch die des kopierten Unterprojektes ausgetauscht. Mit dieser Lösung kann das Unterprojekt angepasst werden und mit dem „fertigen“ Integrationsprojekt sofort zum Einsatz kommen.


Globalprojekt

Handbuch -> Projektverwaltung und Arbeitsbereich -> Globalprojekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Unter einem Globalprojekt versteht man ein Projekt, das selbst nicht an den Prozess gekoppelt ist.

info Info

Pro Arbeitsbereich kann nur ein Globalprojekt angelegt und genutzt werden.

Das Globalprojekt verfügt über eine Reihe von Modulen, die allen Projekten im Arbeitsbereich zur Verfügung stehen. Sind Objekt sowohl im Globalprojekt als auch im Lokalprojekt vorhanden, haben die Elemente im Lokalprojekt Vorrang.

Modul

Beschreibung

Variablen -> Alarm

Gruppierung der Alarme in Gruppen, Klassen und Bereiche.

Schablonen

Im Lokalprojekt nicht vorhandene Schablonen werden vom Global Projektaus dem Globalprojektennung dient der Name.

Schriftlisten

Eine lokal nicht vorhandene Schriftliste wird aus dem Globalprojekt übernommen. Als Kennung dient der Name. Beachten Sie die Konsequenzen gleicher Namen in Global- und Lokalprojekt.

Farbpaletten

Alle Paletten eines Projektes enthalten immer gleich viele Farben, die Anzahl der Farben kann also zwischen Globalprojekt und lokalem Projekt differieren.

Achtung: Bei Konflikten zur Runtime haben die Farbpaletten des lokalen Projektes Vorrang.

Sprachdatei

Sprachdateien werden in Sprachtabellen verwaltet und auf Ebene der Schlüsselwörter und Dateinamen zusammengeführt. Im Lokalprojekt nicht vorhandene Schlüsselwörter werden aus dem Globalprojekt übernommen.

Benutzerverwaltung

Benutzer werden über die Kennung zusammengeführt. Lokal nicht vorhandene Benutzer werden aus dem Globalprojekt übernommen.

Achtung: Benutzer aus dem Global Projekt werden zwar in der Runtime in allen Unter-Projekten angezeigt, können aber nicht über die Runtime Benutzerverwaltung geändert werden.

Dateien

Im Lokalprojekt nicht vorhandene Dateien werden aus dem Globalprojekt übernommen.

Änderungshistorie

Dokumentiert alle Änderungen im Globalprojekt.

Anlagenmodellierung

Bildet alle Ebenen eiens Unternehmens entsprechend ISA S88 und S95 ab. Wird im Globalprojekt erstellt und in den Lokalprojekten verwendet.

Projektsicherungen

Für Sicherung des Globalprojekts.

info Info

Es ist nicht möglich, den VBA Editor im Globalprojekt zu öffnen.


Projektierung des Projektfilters

Handbuch -> Projektverwaltung und Arbeitsbereich -> Projektierung des Projektfilters

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Verwendung eines Projektfilters wird in vielen Funktionen genutzt (Bildumschaltung, Export, Drucken, etc.) und soll hier zentral dargestellt werden.

attention Achtung

Dieser Filter steht nur in Netzwerk-Projekten mit Unterprojekten zur Verfügung und dient dem Zugriff auf die darunterliegenden Projekte.


Konfiguration

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfiguration eines Projekts erfolgt über:

Parameter | Beschreibung
Allgemeine Konfiguration | Produkt lizenzieren Standard Systemsteuerung
Projekt Konfiguration | Projekt Alarm Verwaltung Chronologische Ereignisliste Monitor Verwaltung Benutzerverwaltung Projektsicherung Projekt umbenennen Projekt speichern unter...

Noch in diesem Kapitel

Standard

Projektverwaltung


Standard

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Standard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Anwahl des Menüpunktes Datei/Standard Konfiguration/Standard sind Einstellungen ohne Projektbezug für folgende Eigenschaften möglich:

Parameter | Beschreibung
Drucker | globale Druckereinstellungen für alle Projekte der Datenbank
Verzeichnisse | Definitionen für neuanzulegende Projekte

Noch in diesem Kapitel

Drucker

Ordner allgemein


Drucker

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Standard -> Drucker

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Drucker können für die folgenden Funktionen zugeordnet werden:

Parameter | Beschreibung
für Online-Drucken AML oder CEL | Onlinealarmmeldeliste oder chronologische Ereignisliste (Allgemeine Einstellungen unter 'Alarm und CEL' in den Projekteigenschaften oder über die Dateien ALAR.FRM bzw. BTB.FRM).
für Offline-Drucken AML oder CEL | Offlinealarmmeldeliste oder chronologische Ereignisliste (Mittels 'Drucken' -Button im jeweiligen Bild. Format über die Dateien ALAR_G.FRM bzw. BTB_G.FRM).
für auszugebende Werte und Protokolle | Dieser Drucker wird für Reports benutzt und wenn die Funktion 'Aktuellen Wert drucken' gewählt ist.
für Screenshots | Drucker für Screenshots.
für Notizbuch | Ausgabe geschlossener Protokolle und Texte aus Listenfenstern.

Um einen Drucker auszuwählen:

  1. klicken Sie in die Dropdownliste
  2. alle am Rechner installierten Drucker werden zur Auswahl angeboten

Um die Seiteneinstellungen zu konfigurieren:

  1. klicken Sie auf die Schaltfläche ... neben dem Drucker
  2. der Dialog zur Seiteneinrichtung wird geöffnet

Parameter

Beschreibung

Drucker

Einstellungen für den Drucker.

Name:

Auswahl des Druckers aus Dropdownliste. Liste enthält alle im Betriebssystem konfigurierten Drucker.

Eigenschaften...

Öffnet Dialog zur Konfiguration des gewählten Druckers.

Status:

Anzeige Druckerstatus. Nur Information.

Typ:

Anzeige Druckertyp. Nur Information

Standort:

Anzeige Standort des Druckers, falls konfiguriert. Nur Information.

Kommentar:

Anzeige Kommentar zum Drucker, falls konfiguriert. Nur Information.

Papier

Konfiguration des Ausdrucks.

Größe

Auswahl Papierformat aus Dropdownliste.

Quelle

Wahl der Papierzufuhr aus Dropdownliste.

Ausrichtung

Wahl der Papierausrichtung. Mögliche Parmeter:

  • Hochformat
  • Querformat

Netzwerk

Öffnet Dialog zur AUswahl eines Druckers im Netzwerk.

OK

Übernimmt Konfiguration und schließt Dialog. Zur Runtime wird damit der Druck gestartet.

Abbrechen

Verwirft Konfiguration und schließt Dialog. Zur Runtime wird damit auch der Ausdruck abgebrochen.

info Info

Für unterschiedliche Druckerschnittstellen sind gleiche Drucker mit unterschiedlichen Parametern verwendbar.


Ordner allgemein

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Standard -> Ordner allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Registerkarte Ordner werden die Standard-Dateipfade für die unten angeführten Kategorien definiert. Klick auf die Schaltfläche ... öffnet Explorer zum Definieren des Speicherorts für die gewählte Dateiart. Die hier definierten Speicherorte werden bei neuen Projekten als Standardordner übernommen und können in den Projekteigenschaften über die Option Dateiablage geändert werden. Die Speicherorte werden relativ zum Runtime-Ordner angelegt.

Interne ID: Ordner allgemein

Dateiablage

Der Konfigurationsdialog für die Projekt-Pfade wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter | Beschreibung
Grafiken | Grafikdateien Default: \Graphics
Exportierte Dateien | Pfad für exportierte Archive, chronologische Ereignisliste, Alarmmeldeliste. Default: \Export
Zuordnungen | Pfad für Zuordnungen. Default: \Allocation
Rückleseordner für Archive | Ordner für das Rücklesen von Archiv-Backup-Dateien. Default: \Backup
Ausgelagerte Archive | Ordner, in dem ausgelagerte Archive gespeichert werden. Default: \ExportArv
Online Hilfe | Ordner für Online-Hilfe. Default: \ONLINE_HELP


Projektverwaltung

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Projektverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In den Projekteigenschaften werden alle Details eines Projekts konfiguriert. Um die Eigenschaften konfigurieren zu können, muss:

  • das Projekt im Projektbaum markiert sein
  • das Eigenschaften-Fenster aufgeschaltet sein

    (Aufschaltung über Kontextmenü des Projekts oder Menü Optionen)

Noch in diesem Kapitel

Projektinfo

Ordner projektbezogen

Grafikqualität

Runtime änderbare Dateien


Projektinfo

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Projektverwaltung -> Projektinfo

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Informationen über das Projekt können eingegeben werden:

Parameter | Beschreibung
Autor | Autor des Projekts
Manager | Manager des Projekts
Firma | Firma für das Projekt
Kommentar | Freier Kommentar für das Projekt


Ordner projektbezogen

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Projektverwaltung -> Ordner projektbezogen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Auswahl der Eigenschaft Dateiablage in den Projekteigenschaften Allgemein wird der Dialog zum Definieren der Speicherorte geöffnete. Die darin bereits enthaltenen Orte wurden aus den allgemeinen Einstellungen für Ordner übernommen. Klick auf die Schaltfläche ... öffnet Explorer zum Definieren des Speicherorts für die gewählte Dateiart. Die Speicherorte werden relativ zum Runtime-Ordner angelegt.

Interne ID: Ordner projektbezogen

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Ordner projektbezogen

Dateiablage

Der Konfigurationsdialog für die Projekt-Pfade wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter | Beschreibung
Grafiken | Grafikdateien Default: \Graphics
Exportierte Dateien | Pfad für exportierte Archive, chronologische Ereignisliste, Alarmmeldeliste. Default: \Export
Zuordnungen | Pfad für Zuordnungen. Default: \Allocation
Rückleseordner für Archive | Ordner für das Rücklesen von Archiv-Backup-Dateien. Default: \Backup
Ausgelagerte Archive | Ordner, in dem ausgelagerte Archive gespeichert werden. Default: \ExportArv
Online Hilfe | Ordner für Online-Hilfe. Default: \ONLINE_HELP


Grafikqualität

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Projektverwaltung -> Grafikqualität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon kann die Qualität der dargestellten Grafik auf die Ressourcen des Systems abgestimmt werden. Die Einstellung erfolgt über die Projekteigenschaft Grafikqualität in der Gruppe Grafische Ausprägung. Folgende Einstellungen sind möglich:

Interne ID: Grafikqualität

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grafikqualität

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Grafikqualität

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.
  • Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.
  • DirectX Software: Grafikberechnungen werden von der CPU erledigt. Es können, abhängig von den darzustellenden Grafiken, mehrere CPUs verwendet werden. Die Verwendung von DirectX Software kann eine hohe Auslastung der CPU erzeugen.
  • DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert, wodurch die Performance gesteigert werden kann. Wird diese Einstellung vom verwendeten System nicht unterstützt, schaltet zenon automatisch auf DirectX Software um. Prinzipiell ist DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

attention Achtung
  • Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.
  • DirectX Darstellung wird nur in der Runtime unterstützt.

DirectX

DirectX ermöglicht eine höhere Grafikqualität als Windows Basis oder Windows Erweitert. So kann DirectX im Gegensatz zu Windows Basis/Erweitert die Eigenschaften Antialiasing verwenden und ClearType Schriften unabhängig von den Einstellungen des Betriebssystems ein- und ausschalten. Die Antialiasing-Qualität von DirectX ist höher als bei Windows Erweitert.

Interne ID: Grafikqualität

ClearType Schriften

Aktiv: ClearType Schriften werden verwendet. Kann die Lesbarkeit von Schriften auf LCD-Bildschirmen in nativer Auflösung verbessern.

Inaktiv: Windows Standardschriften werden verwendet. Eignet sich oft für Röhrenmonitore und LCDs mit interpolierter Auflösung.
Hinweis: Wurde für die Eigenschaft Grafikqualität Windows Basis oder Windows Erweitert gewählt, muss unter Windows Vista und Windows 7 im Betriebssystem die Verwendung von ClearType-Schriften deaktiviert werden. Wurde DirectX gewählt, kann Cleartype unabhängig vom Betriebssystem ein- und ausgeschaltet werden.

Default: aktiv.

Hinweis: Änderungen der Einstellung werden für den Editor erst nach dem Neustart des Editors wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Grafikqualität

Antialiasing verwenden

Nur verfügbar, wenn Grafikqualität aktiviert ist.

Schaltet die Kantenglättung von Linien ein. Dadurch werden vor allem schräge Linien grafisch wesentlich ansprechender dargestellt. Der Treppeneffekt entfällt. Wurde in der Eigenschaft Grafikqualität DirectX Software oder DirectX Hardware gewählt, kann Antialiasing unabhängig von den Betriebssystemeinstellungen ein- und ausgeschaltet werden. Die Antialiasing Qualität von DirectX ist höher als bei Windows Erweitert.

Antialising kann die Bildumschaltzeiten besonders bei älteren Betriebssystemen (bis Windows XP) verlängern.

Mögliche Optionen sind:

Ein: Kantenglättung immer aktiv

Aus: Kantenglättung deaktiviert

Default: Bei Windows Vista, Windows 7 und neueren Betriebssystemen ist die Kantenglättung aktiviert, bei älteren Betriebssystemen (Windows XP, Server 2003) deaktiviert.

Default: Default

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um DirectX verwenden zu können, müssen einige Voraussetzungen erfüllt werden:

Voraussetzung

Erklärung

DirectX Hardware oder DirectX Software muss aktiviert sein.

In den Projekteigenschaften muss für die Eigenschaft Grafische Ausprägung DirectX Hardware oder DirectX Software gewählt werden.

Das Betriebssystem muss DirectX 11 unterstützen.

DirectX Hardware und DirectX Software funktionieren nur auf Betriebssystemen mit DirectX11 Unterstützung:

  • Microsoft Windows Vista SP2 inkl. Plattform Update und Windows 7
  • Windows XP und Windows CE werden nicht unterstützt

Wenn das System DirectX 11 nicht unterstützt, wird automatisch auf Windows Erweitert umgeschaltet.

Die aktuelle DirectX Runtime muss installiert sein.

Diese wird für zenon mit dem Setup mit installiert. Für den Webclient muss sie manuell installiert werden.

Das Bild oder Element müssen DirectX unterstützen.

Nur unterstützte Elemente bzw. Bilder können mit DirectX dargestellt werden.

Bei DirectX Hardware müssen die Mindestvoraussetzungen erfüllt werden.

Details siehe Mindestvoraussetzungen Grafikkarte. Werden diesen nicht erfüllt, wird automatisch auf DirectX Software umgeschaltet.

Steht vom Betriebssystem keine Hardwarebeschleunigung zur Verfügung (zum Beispiel bei Remote Desktop), kann DirectX Hardware eventuell nicht verwendet werden.

Mindestvorraussetzungen Grafikkarte für DirectX Hardware

Für den Einsatz von DirectX Hardware müssen folgende Mindesvoraussetzungen erfüllt werden:

Parameter | Mindestvoraussetzung | Empfohlen
Grafikkarte: | Dezidierte DirectX 11 AMD oder nVidia Grafikkarte | Dezidierte DirectX 11 AMD oder nVidia Grafikkarte
Grafikspeicher: (Tatsächlich benötigte Größe ist abhängig von Anzahl der aufgeschalteten Bilder und dargestellten Elemente.) | 512 MB VRAM | 1 GB VRAM
Treiber Grafikkarte: | Aktuellster Treiber des Grafikkartenherstellers

Um die Grafikkartenunterstützung für DirectX Hardware zu überprüfen, kann das Windows Betriebssystem-Tool dxdiag.exe verwendet werden. Damit kann die DirectX Hardwarefähigkeit der Grafikkarte und des Treibers unter Anzeige mit dem Wert DDI-Version überprüft werden. Der Wert 11 zum Beispiel steht für DirectX 11.

Unterschiede DirectX zu Windows Erweitert

DirectX unterscheidet sich von Windows Erweitert hinsichtlich Qualität, Performance und Ressourcenbedarf. Einige der wichtigsten Unterschiede:

  • Skalierungen, Verzerrungen und Rotationen von Objekten werden mit Antialiasing dargestellt. Antialiasing funktioniert auch mit Transformationen.
  • Schatten werden als korrektes Ebenbild des eigentlichen Elementes dargestellt. Auch Texte und teiltransparente Bitmaps haben einen komplett korrekten Schatten. Dynamische Änderungen werden berücksichtigt: Bei gedrücktem Button ändert sich zum Beispiel auch der Schatten.
  • Glow-Effekt ermöglicht das Glühen eines Elementes über das Ebenbild des eigentlichen Elements. Auch Texte und teiltransparente Bitmaps haben einen korrekten Glow-Effekt. Dynamische Änderungen werden berücksichtigt: Bei gedrücktem Button ändert sich zum Beispiel auch der Glow-Effekt.

info Info

Die Verwendung von WMF- oder EMF-Grafiken mit DirectX kann zu Einbußen bei der Performance führen.

Beispiele

Gedrehte dynamische Elemente

Mit Windows Erweitert:

Mit DirectX:

Treppenbildung an den Rändern ist reduziert, Texte werden korrekt positioniert.

Halbtransparenter Button mit Schatten

Mit Windows Erweitert:

Mit DirectX:

Korrekter Schatten mit sichtbarem Text.

Schatten eines Buttons mit Bitmap

Links wird ein Bitmap-Button mit Schatten dargestellt, rechts das gleiche Bild mit der Eigenschaft Transparent aktiv.

Interne ID: Grafikqualität

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mit Windows Erweitert:

Mit DirectX:

Noch in diesem Kapitel

Fehlerbehandlung DirectX


Fehlerbehandlung DirectX

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Projektverwaltung -> Grafikqualität -> Fehlerbehandlung DirectX

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler werden im Diagnose Viewer ausgegeben.

DirectX wird nicht initialisiert

Kann DirectX beim Aufschalten eines Bildes oder im laufenden Betrieb nicht initialisiert werden, dann:

  • wird eine Fortschrittsanzeige angezeigt
  • wird versucht, DirectX neu zu initialisieren
  • läuft die Runtime normal weiter solange die Fortschrittsanzeige angezeigt wird
  • kann versucht werden, das Problem zu beheben (Treiberinstallation, ...)

Die Fortschrittsanzeige kann vom Benutzer durch Klick auf die Schaltfläche Abbrechen beendet werden. Nach dem Abbrechen wird die Runtime beendet und eine Fehlernachricht angezeigt, die nur mit Klick auf OK beendet werden kann.

Hinweis: Bei Fehlern, die ein Reinitialisieren von DirectX unmöglich machen, wird sofort eine Fehlernachricht angezeigt.

Diagnose Viewer

DirectX stellt im Diagnose Viewer individuelle Nachrichten bereit, mit jeweils:

  • einer Fehlermeldung
  • möglichen Gründen für den Fehler
  • Fehlercodes

Die Ausgabe erfolgt in einem eigenen Modul DirectX. Bei Fehlern wird der Fehlertext im Textfeld Error ausgegeben, bei Warnungen und Debug Hinweisen wird die entsprechende Meldung im Textfeld General ausgegeben:

  • Für das erfolgreiche Aufschalten eines Bildes wird mindestens eine DEBUG-Erfolgsmeldung ausgegeben.
  • Warnungen weisen auf Ereignisse hin, die den Betrieb beeinflussen können.
  • Tritt ein nicht behebbarer Fehler auf, wird eine Fehlermeldung (Error) ausgegeben.

info Info

Wird eine Meldung in der Tabelle im Diagnose Viewer nicht komplett angezeigt, öffnen Sie den Eintrag durch einen Doppelklick, um die gesamte Meldung anzuzeigen.

Checkliste für Fehlerüberprüfung

  • Eine entsprechende Überprüfung, ob DirectX funktioniert, kann durch das Aktivieren der Debug Meldungen im Diagnose Viewer durchgeführt werden. Bei erfolgreicher Unterstützung kommt eine entsprechende Meldung.
  • Kommen DirectX-spezifische Warnungen oder Fehlermeldungen im Diagnose Viewer?
  • Ist in der Projekteigenschaft Grafikqualität DirectX Hardware oder DirectX Software eingestellt?

    Interne ID: Fehlerbehandlung DirectX

    Grafikqualität

    Einstellung für Qualität der Grafikdarstellung.
    DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

    Mögliche Auswahl:

    Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

    Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

    DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

    DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

    Default: Windows Erweitert

    Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

    Hinweise:
    Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
    Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

    Mehr im Online-Handbuch

    Interne ID: Fehlerbehandlung DirectX

    Linienbreite [Pixel]

    Linienbreite (in Pixel).
    Minimum: 0
    Die Linienbreite ist in diesem Fall 1 Pixel.
    Maximum: 65535
    Default: 1
    Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

    Interne ID: Fehlerbehandlung DirectX

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Werden die Mindestanforderungen an DirectX erfüllt? Details zur Mindestanforderung siehe Kapitel Grafikqualität.
    • Wird DirectX 11 vom Betriebssystem unterstützt?
    • Ist die aktuelle DirectX Runtime installiert?
    • Wird DirectX Hardware von der Grafikkarte unterstützt?

      Um die Grafikkartenunterstützung für DirectX Hardware zu überprüfen, kann das Windows Betriebssystem-Tool dxdiag.exe verwendet werden. Damit kann die DirectX Hardwarefähigkeit der Grafikkarte und des Treibers unter Anzeige mit dem Wert DDI-Version überprüft werden. Der Wert 11 zum Beispiel steht für DirectX 11.

  • Wird DirectX vom Bild bzw. Element unterstützt?
  • Funktioniert die Darstellung mit Windows Basis bzw. Windows Erweitert korrekt?
  • Funktioniert die Darstellung mit einem anderen Treiber korrekt?
  • Funktioniert die Darstellung mit einer Grafikkarte eines anderen Herstellers korrekt?


Runtime änderbare Dateien

Handbuch -> Projektverwaltung und Arbeitsbereich -> Konfiguration -> Projektverwaltung -> Runtime änderbare Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon gib es eine Reihe von Daten, die sowohl im Editor als auch in der Runtime geändert werden können. Es sind dies Dateien für:

  • Rezeptgruppen-Manager
  • Standard-Rezepte
  • Benutzerverwaltung
  • Scheduler

Runtime-Dateien vor überschreiben schützen

Erzeugt bzw. überträgt man alle Runtime Dateien neu, so würden die in der Runtime geänderten Dateien überschrieben werden. Um ein ungewolltes Überschreiben zu verhindern, kann hier unter Nicht neu erzeugen und übertragen ausgewählt werden, welche Dateien nicht neu erzeugt bzw. übertragen werden sollten.

Editor-Dateien vor überschreiben schützen

In der Runtime geänderte Daten können wieder zurück gelesen werden. Dabei werden die entsprechenden Editor Daten überschrieben. Um ein ungewolltes Überschreiben zu verhindern kann hier unter Nicht dekompillieren ausgewählt werden, welche Dateien nicht zurück gelesen werden sollten.

Dialog RT änderbare Dateien

Den Dialog zur Konfiguration der Runtime änderbaren Dateien erreichen Sie über die Projekteigenschaften Allgemein/RT änderbare Daten:

Interne ID: Runtime änderbare Dateien

RT änderbare Daten

Der Konfigurationsdialog für die Runtime änderbaren Daten wird geöffnet.
Standard-Rezepte, Rezeptgruppen-Manager, Scheduler oder Production and Facility Scheduler und Benutzerverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Runtime änderbare Dateien

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Folgende Dateitypen sind auswählbar:

Parameter | Beschreibung
Rezeptgruppen-Manager | Rezeptgruppen und Rezepte des Rezeptgruppen-Managers. Bei der Übertragung werden neue Dateien übertragen und neue Unterordner angelegt, gelöschte Dateien und Unterordner auch auf dem Zielsystem gelöscht.
Standard-Rezepte | Standard-Rezepte.
Benutzerverwaltung | Benutzerverwaltung für Login und Rechteverwaltung zur Runtime.
Scheduler | Änderungen in den Zeitmodellen und Fahrplänen des PFS.

attention Achtung

Achten Sie bei der Projektkonvertierung darauf, Runtime änderbare Dateien ebenfalls zu konvertieren. Runtime-Dateien müssen dazu in die Ausgangsversion des Editors importiert werden und nach dem Update wieder in die Runtime zurückgespielt werden. Details siehe Kapitel Empfohlene Vorgangsweise Runtime-Dateien konvertieren im Handbuch Projektkonvertierung.

Übertragung der Dateien

Zur Runtime

Um Dateien zur Runtime zu übertragen können:

  1. alle Dateien übertragen werden
  2. nur geänderte Dateien übertragen werden

Beide Wege berücksichtigen die in RT änderbare Daten definierten Dateien.

Von der Runtime

Um Dateien von der Runtime einzulesen, stehen zwei Verfahren zur Verfügung:

  1. Alle Runtime-Dateien zurücklesen:
    1. liest alle Runtime-Dateien in den Ordner, der in der Eigenschaft Runtime-Ordner definiert wurde, ein

      Interne ID: Runtime änderbare Dateien

      Runtime-Ordner

      Verzeichnis für die Runtime-Dateien des Projekts.
      In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
      Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

      Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    2. unabhängig von den Einstellungen der Eigenschaft RT änderbare Daten
  2. Runtime-Dateien importieren:
    1. importiert die in der Eigenschaft RT änderbare Daten definierten Dateien und
    2. ersetzt die Projektierung im Editor durch diese Runtime-Dateien
    3. eignet sich, um Daten von einem Remote-System in den Editor zu übernehmen

Verbindungsfehler

Bei der Übertragung werden vorhandene Dateien entsprechend den Einstellungen überschrieben.

Treten bei der Übertragung von der oder zur Runtime Fehler auf oder reißt die Verbindung ab, müssen die Dateien komplett neu übertragen werden.


Querverweise

Handbuch -> Querverweise

Querverweise ermöglichen einen Überblick darüber, welche Module und Funktion wie verknüpft sind. zenon stellt dafür zwei Instrumente zur Verfügung:

  • Querverweisliste: zeigt Verknüpfungen im Projekt tabellarische an
  • Projektanalyse: analysiert die Verwendung von Funktion und Variablen und findet nicht Verwendete Funktionen bzw. Variablen

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Querverweisliste

Projektanalyse


Querverweisliste

Handbuch -> Querverweise -> Querverweisliste

Die Querverweisliste erstellt eine tabellarische Projektübersicht.
Sämtlichen Beziehungen zwischen Variablen, Funktionen, Bildern, Rezepturen usw. werden für Dokumentation und Rückverfolgung dargestellt. Die Querverweisliste gibt z.B. Aufschluss darüber, welche Variablen in welchen Bildern verwendet werden.

Noch in diesem Kapitel

Allgemein

Das Kontextmenü


Allgemein

Handbuch -> Querverweise -> Querverweisliste -> Allgemein

Im zenon Editor ist die Querverweisliste über das Menü Option und dem Eintrag Querverweisliste zu erreichen.

info Info

Sollte die Querverweisliste nach dem Starten des Editors nicht angezeigt werden, so können Sie dieses laden, indem Sie das Menü Option öffnen und den Menüpunkt Querverweisliste bestätigen.

Um nun die gewünschten Informationen über bestimmte Module zu erhalten, erweitern Sie einfach den entsprechenden Knoten.

Zur Verfügung stehende Knoten sind:

Parameter | Beschreibung
Archiv | Funktionen
 | Variablen
Bilder | Elemente
 | Symbole
 | Variablen
Elemente | Bilder
 | Variablen
ETM |
Funktionen | Archiv
 | Autom. Funktionsausführung
 | Bilder
 | Bitmap Button
 | PFS
 | REMA
 | Scripte
 | Text Button
 | Unsichtbarer Button
 | Variablengrenzwerte
 | Zeitsteuerung
PFS | Funktionen
 | Variablen
REMA | Funktionen
 | Variablen
Rezepte | Variablen
Rezeptgruppenmanager | Rezeptgruppen
 | Variablen
Scripte | Funktionen
Symbole | Bilder
 | Verknüpfte Symbole
Variablen | Archiv
 | Bilder
 | Elemente
 | ETM
 | Mathematik
 | PFS
 | REMA
 | Rezepte
 | Rezeptgruppenmanager
 | Zuweisungen
Zeitsteuerung | Funktionen
Zuweisungen | Variablen

Nach einem Klick auf eines der angebotenen Objekte werden die Informationen rechts in der Liste dargestellt.

Die Informationen zum ausgewählten Objekt werden in der Liste dargestellt. Der Inhalt kann durch Klick auf einen Spaltenkopf entweder auf- oder absteigend sortiert werden.

Weiters besteht die Möglichkeit einer Filterung. Dazu einfach in der Spalte, in der gefiltert werden soll, das Suchkriterium in die dafür vorgesehenen Filtertext-Eingabebox eingeben (-> Geben Sie Text hier ein). Es werden nun alle Elemente angezeigt, die dem eingegebenen Suchkriterium entsprechen. Es ist auch möglich, in mehreren Spalten gleichzeitig zu filtern. Dazu wird einfach, wie oben beschrieben, in mehreren Spalten ein Filterkriterium eingegeben. Wird ein Filter nicht mehr benötigt, so muss nur der Text aus der Filtertext-Eingabebox gelöscht werden.


Das Kontextmenü

Handbuch -> Querverweise -> Querverweisliste -> Das Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um zu den Funktionalitäten der Querverweisliste zu kommen wird mit der rechten Maustaste ein Kontextmenü geöffnet, während sich der Mauscursor im Listenfenster der Querverweisliste befindet.

Folgende Befehle stehen zur Verfügung:

Parameter | Beschreibung
Liste/Suchergebnis Drucken | Druckt den Listenbereich der Querverweisliste mit den ausgewählten Informationen
Suche Element in Liste | Öffnet eine Dialogbox zur Suche nach einem bestimmten Objekt
Funktionsaufrufe | Öffnet eine Dialogbox mit einer Liste der definierten Funktionen
Variablenverwendung | Öffnet eine Dialogbox mit einer Liste der definierten Variablen
Nicht verwendete Variablen / Funktionen / Schriften | Zeigt im Listenbereich alle nicht verwendeten Variablen/Funktionen/Schriften an
In Bildern verwendete Texte | Sucht nach in Bildern verwendeten Texten
Listenelemente selektieren | Öffnet eine Dialogbox zur Selektion eines oder mehrerer Listenelemente
Hilfe | Schaltet die Online-Hilfe auf
Löschen | Löscht nicht verwendete Elemente (Variablen, Funktionen und Schriften)

Noch in diesem Kapitel

Suche Element in Liste

Funktionsaufrufe

Variablenverwendung

Nicht verwendete Variablen/Funktionen/Schriften

Listenelemente selektieren

Liste/Suchergebnis Drucken


Suche Element in Liste

Handbuch -> Querverweise -> Querverweisliste -> Das Kontextmenü -> Suche Element in Liste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Auswahl des Befehls Suche Element in Liste aus dem Kontextmenü öffnet folgende Dialogbox:

Nach Eingabe eines oder mehrerer Anfangsbuchstaben wird in der Liste das erste entsprechende Objekt selektiert.


Funktionsaufrufe

Handbuch -> Querverweise -> Querverweisliste -> Das Kontextmenü -> Funktionsaufrufe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Auswahl des Befehls Funktionsaufrufe aus dem Kontextmenü öffnet folgende Dialogbox, in der alle definierten Funktionen des aktuellen Projekts aufgelistet sind:


Variablenverwendung

Handbuch -> Querverweise -> Querverweisliste -> Das Kontextmenü -> Variablenverwendung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Auswahl des Befehls Variablenverwendung aus dem Kontextmenü öffnet folgende Dialogbox, in der alle definierten Variablen des aktuellen Projekts aufgelistet sind:


Nicht verwendete Variablen/Funktionen/Schriften

Handbuch -> Querverweise -> Querverweisliste -> Das Kontextmenü -> Nicht verwendete Variablen/Funktionen/Schriften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Liste der nicht verwendetet Elemente (Variablen, Funktionen und Schriften) erhält das Kontextmenü einen zusätzlichen Menüeintrag Löschen.

Damit können Elemente aus der Liste ausgewählt und dann direkt hier gelöscht werden.


Listenelemente selektieren

Handbuch -> Querverweise -> Querverweisliste -> Das Kontextmenü -> Listenelemente selektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Auswahl des Befehls Listenelemente selektieren aus dem Kontextmenü öffnet folgende Dialogbox:

Folgende Optionen sind verfügbar:

Parameter | Beschreibung
von - bis | Selektion der Objekte in der Liste über die Anfangsbuchstaben.
Alle Elemente beginnend mit ... | Selektion der Elemente über einen bestimmten Anfangsbuchstaben oder Anfangsstring.


Liste/Suchergebnis Drucken

Handbuch -> Querverweise -> Querverweisliste -> Das Kontextmenü -> Liste/Suchergebnis Drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Auswahl des Befehls Liste drucken oder Suchergebnis drucken aus dem Kontextmenü öffnet folgende Dialogbox:

Folgende Optionen sind verfügbar:

Parameter | Beschreibung
Alles | Alle Elemente in der Liste werden gedruckt
Selektierte Elemente | Alle selektierten Elemente in der Liste werden gedruckt
In Datei | Durch die Aktivierung dieses Kontrollkästchens wird die Druckausgabe in eine Datei umgeleitet. Es erscheint eine Dialogbox, in der nach dem gewünschten Pfad und Dateinamen gefragt wird. Durch bestätigen mit OK wird die Datei gespeichert. Diese Datei besitzt das CSV-Format und kann später in EXCEL geladen und nach eigenen Wüschen formatiert werden. Beim Laden dieser Datei in EXCEL wird in einem Dialog nach dem Trennzeichen gefragt. Aktivieren Sie hier das Kontrollkästchen Semikolon und deaktivieren Sie alle anderen.


Projektanalyse

Handbuch -> Querverweise -> Projektanalyse

Die Projektanalyse analysiert die Verwendung von Elementen in einem Projekt.

Dabei kann:

  • die Verknüpfung mit anderen Elementen analysiert werden
  • nach nicht verwendeten Elemente gesucht werden

Die Projektanalyse steht aktuell zur Verfügung für:

  • Funktionen
  • Variablen

Verwendung eines Elements analysieren

Um ein Element zu analysieren:

  1. markieren Sie die gewünschte Variable bzw. Funktion in der Detailansicht
  2. wählen Sie im Kontextmenü den Befehl Variablenverwendung bzw. Funktionsverwendung
  3. die Ergebnisliste wird in einem eigenen Fenster aufgeschaltet

  4. über das Kontextmenü kann ein Element angesprungen werden

Nicht verwendete Elemente finden

Um nicht verwendete Elemente zu finden:

  1. markieren Sie den Knoten Variable bzw. Funktion im Projektbaum
  2. wählen Sie im Kontextmenü den Befehl Nicht verwendete Funktionen anzeigen bzw. Nicht verwendete Variablen anzeigen
  3. die Ergebnisliste wird in einem eigenen Fenster aufgeschaltet

  4. über das Kontextmenü kann ein Element angesprungen oder gelöscht werden

attention Achtung

Folgende Elemente können von der Projektanalyse nicht gefunden werden:

  • Variablen, die ausschließlich in VBA bzw. VSTA verwendet werden
  • Variablen, die in Bildern vom Typ Report Generator verwendet werden (Reportfunktionen)

Vor dem Löschen von Elementen muss überprüft werden, ob zu löschende Variablen in VBA/VSTA oder in Reportfunktionen verwendet werden.

Noch in diesem Kapitel

Ergebnisliste


Ergebnisliste

Handbuch -> Querverweise -> Projektanalyse -> Ergebnisliste

Die Ergebnisse der einzelnen Analysevorgänge werden in einem eigenen Fenster Projektanalyse als Liste angezeigt. Dieses Fenster öffnet sich, falls es noch nicht aktiv ist, automatisch nach dem Analysevorgang. Die Ergebnisse können auf zwei Arten genutzt werden:

  • Verwendung im Projekt analysieren: zu verknüpftem Elemente springen
  • nicht verwendete Elemente finden: zu angezeigtem Element springen oder angezeigtes Element löschen

Analyse Elementverwendung

Die Projektanalyse gibt ihre Ergebnis in einer Liste aus.

Diese beinhaltet:

  • Den Projektnamen
  • das Modul
  • den Namen des verknüpften Elements

Um zu einem angezeigten Element zu springen:

  1. markieren Sie das Element
  2. wählen Sie im Kontextmenü den Befehl Zu verknüpftem Element springen
  3. das verknüpfte Element wird in der Detailliste seines Modulknotens markiert

Nicht verwendete Elemente finden

Die Suche nach nicht verwendeten Elementen gibt ihre Ergebnis in einer Liste aus.

Diese beinhaltet:

  • Den Projektnamen
  • das Modul
  • den Namen des nicht verwendeten Elements

Zu Element springen

Um zu einem angezeigten Element zu springen:

  1. markieren Sie das Element
  2. wählen Sie im Kontextmenü den Befehl Zu verknüpftem Element springen
  3. das verknüpfte Element wird in der Detailliste seines Modulknotens markiert

Elemente löschen

Um ein oder mehrere Elemente zu löschen:

  1. markieren Sie die gewünschten Elemente (Multiselekt ist möglich)
  2. wählen Sie im Kontextmenü den Befehl Selektierte Elemente entfernen
  3. die Elemente werden nach einer Sicherheitsabfrage aus dem Projekt entfernt


Remote Desktop

Handbuch -> Remote Desktop

Mit dem Remote Desktop können Sie eine Remote Desktop Verbindung zu einem Remote Zielsystem aufbauen und einen Remote Rechner einfach administrieren. Das bedeutet, dass Sie von Ihrem Arbeitsplatz aus eine visuelle Verbindung zu einem anderen PC oder CE Gerät herstellen können. Sie bekommen den Desktop 1:1 so angezeigt, wie er am Zielsystem dargestellt wird.

Der Remote Desktop verfügt über eine nur betrachtende Verbindung und eine bedienende Verbindung.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Unterschiede zu Netzwerk und Windows Remote Desktop

Der Remote Desktop kann ein zenon Netzwerk nicht ersetzen. Es ist eine reine Übertragung von Bildschirminformationen. Das bedeutet, dass auf allen Rechnern die verbunden sind, dasselbe Bild angezeigt wird. Mit dem zenon Netzwerk können Sie selbstverständlich auf jedem Client unterschiedliche Bilder darstellen.

Der Remote Desktop bietet gegenüber dem Windows Remote Desktop den Vorteil, dass sich mehrere Rechner mit dem Zielsystem gleichzeitig verbinden können. Ebenso bleibt das Zielsystem selbst voll bedienbar auch wenn eine Remote Verbindung hergestellt ist. Beim Windows Remote Desktop kann immer nur vom Remote PC oder am Zielsystem bedient werden.

Aktivierung

Um Sicherheitslücken zu vermeiden, wird der Remote Desktop bei der Installation am PC nicht aktiviert. Damit Sie ihn nutzen können, müssen Sie ihn zuerst aktivieren (siehe Konfiguration). Unter Windows CE muss der Remote Desktop Dienst zenVNCSrvCE.exe manuell oder über die Windows CE Autostart-Mechanismen gestartet werden.

Der Remote Desktop wird bei der Deinstallation von zenon durch das Setup nicht deinstalliert, sondern bleibt auf dem Rechner zurück. Wie Sie ihn entfernen können, lesen Sie im Kapitel Deinstallation.

attention Achtung

Der Remote Desktop wird mit Standard-Passwörtern ausgeliefert. Wir empfehlen Ihnen, diese in der Konfigurationssoftware zu ändern (siehe Abschnitt Konfiguration).

Noch in diesem Kapitel

Aufbau

Konfiguration

Verbindung aufbauen

Einschränkungen

Voraussetzungen / Fehlersuche

Deinstallation


Aufbau

Handbuch -> Remote Desktop -> Aufbau

Der Remote Desktop besteht aus drei Komponenten:

Parameter

Beschreibung

Remote Desktop Dienst

Der Remote Desktop Dienst überträgt die Desktopinformation über das Netzwerk zur Beobachtungssoftware. Am PC hat der Dienst keinerlei Oberfläche und läuft im Hintergrund als unsichtbares Windows Programm. Er wird nicht als Windows Dienst gestartet.
Unter Windows CE ist der Dienst als Tray-Icon sichtbar.

Der Remote Desktop Dienst verfügt auch über einen integrierten HTTP-Webserver. Dieser Webserver stellt einen Einstiegspunkt für beliebige Web Browser bereit. Sie können eine visuelle Remote Desktop Verbindung direkt in Ihrem Browser starten.

Remote Desktop Konfiguration

Mit der Konfigurationssoftware bestimmen Sie das Verhalten des Dienstes.

Remote Desktop Beobachtungssoftware

Mit der Beobachtungssoftware können Sie den Remote Desktop von Ihrem PC aus ansehen. Es gibt zwei Arten dieser Software:

Eine Standard Windows Beobachtungssoftware, die Sie aus dem Remote Transport im Editor oder über das Windows Startmenü starten.

Direktverbindung per Standard Web Browser ohne Fremdsoftware. Die Darstellung des Remote Desktops erfolgt dann direkt im Web Browser.


Konfiguration

Handbuch -> Remote Desktop -> Konfiguration

Mit der Remote Desktop Konfigurationssoftware passen Sie die Remote Desktop Verbindung an Ihre Bedürfnisse an.

Einstellung

Beschreibung

Enable Remote Desktop service

Aktiviert den Remote Desktop Dienst.

Ist der Dienst deaktiviert, wird er komplett deregistriert und steht nicht mehr zur Verfügung. Er kann nur mittels dieser Konfigurationssoftware wieder aktiviert werden.

Beachten Sie, dass bei aktivem HTTP Server vor dem Deaktivieren das Passwort geändert werden sollte.

Enable built-in HTTP server

Aktiviert den eingebauten HTTP Server. Die angezeigte Startseite ist fix und kann nicht verändert werden.

Achtung: Wird der HTTP Server deaktiviert, kann die Anmeldeseite über einen Refresh des Browsers weiterhin aufgerufen werden.
Dabei wird die Seite aus dem Cache vom normalen HTTP Port (5600) auf den Remote Desktop Port (5610) umgeleitet. Damit sind auch Anmeldung und voller Zugriff weiter möglich. Um Zugriffe zu verhindern, ändern Sie das Passwort oder schließen Sie den Remote Dektop Port 5610.

Primary password

Erlaubt bedienenden Zugriff auf den Rechner.

Passwort-Behandlung:

  • Das Standard-Passwort bei der Erstinstallation ist SCADA-ALL.
    Um unbefugten Zugriff zu vermeiden, sollten Sie das Passwort ändern.
  • Die Länge des Passwortes ist auf 8 Zeichen begrenzt.
    Das Standard-Passwort SCADA-ALL kann aber eingegeben werden.
  • Das Passwort kann jederzeit ohne Kenntnis des aktuellen Passworts geändert werden.
  • Wenn Sie kein Passwort eingeben, wird eine Warnmeldung angezeigt, sobald Sie das Feld verlassen.

View-only password

Wenn Sie beim Verbindungsaufbau dieses Passwort eingeben, erhalten Sie nur betrachtenden Zugriff auf den Desktop.

Passwort-Behandlung:

  • Das Standard-Passwort bei der Erstinstallation ist SCADA.
    Um unbefugten Zugriff zu vermeiden, sollten Sie das Passwort ändern.
  • Die Länge des Passwortes ist auf 8 Zeichen begrenzt.
  • Das Passwort kann jederzeit ohne Kenntnis des aktuellen Passworts geändert werden.
  • Wenn Sie kein Passwort eingeben, wird eine Warnmeldung angezeigt, sobald Sie das Feld verlassen.

Log information to zenVNC.log

Der Remote Desktop Dienst schreibt Analyseinformationen in die Datei zenVNC.log. Die Datei befindet sich im User Temp Verzeichnis.

WWindows XP: C:\Dokumente und Einstellungen\ Benutzer \Lokale Einstellungen\Temp
Windows Vista/7: C:\Users\Default\AppData\Local\Temp

Diese Ordner können Sie nur sehen, wenn Sie in den Ordnereigenschaften des Windows Explorer die Option versteckte Dateien und Ordner anzeigen aktiviert haben.

Log detailed debugging information

Der Remote Desktop Dienst schreibt detailliertere Fehler- und Debugginginformationen in die Datei zenVNC.log. Diese Option wird nur zur umfangreichen Fehleranalyse benötigt.

Block remote input events

Wenn von außen kein bearbeitender Zugriff möglich sein soll, obwohl das Primary Passwort bekannt ist und sein soll, können Sie diese Option setzen. Bedienende Zugriffe von Remote PCs werden unterbunden. Nur beobachtende Zugriffe sind möglich.

Block remote input on local activity

Wenn am lokalen Rechner Bedienung (mit Tastatur oder Maus) stattfindet, kann von einem Remote Rechner aus nicht bedient werden. Nach der eingestellten Zeit wird die Bedienung von außerhalb wieder freigegeben.

attention Achtung

Wenn Sie die Passwörter nicht ändern, kann jeder unbemerkt auf Ihren Rechner zugreifen!!

Leere Passwörter sind erlaubt, werden jedoch ausdrücklich nicht empfohlen. Durch leere Passwörter ermöglichen Sie jedem unbemerkten Vollzugriff auf Ihren Rechner.

info Info

Alle Änderungen werden erst beim Drücken der OK Schaltfläche übernommen. Dabei wird der Remote Desktop Dienst immer neu gestartet. Verbundene Computer verlieren die Verbindung.


Verbindung aufbauen

Handbuch -> Remote Desktop -> Verbindung aufbauen

Sie haben folgende Möglichkeiten, eine Remote Desktop Verbindung herzustellen:

Integriert in den Remote Transport:

Der Remote Desktop ist direkt in zenon integriert. Sie können über das Icon Remote Desktop Verbindung starten in der Symbolleiste des Remote Transport eine Verbindung aufbauen. Als Zielsystem wird automatisch das Zielsystem, das im Remote Transport eingestellt ist, verwendet. Ist dort kein Rechner eingetragen, wird der in der Netzwerkkonfiguration eingetragene Server verwendet.

Beachten Sie, dass im Remote Transport als Transportmedium TCP/IP eingestellt sein muss.

Der Verbindungsaufbau erfolgt wie bei der Verbindung über das Startmenü, mit dem Unterschied, dass der Remote Rechnername nicht eingegeben werden muss.

Über das Startmenü:

Möchten Sie zu einem anderen Zielsystem eine Remote Desktop Verbindung aufbauen, können Sie das über die Verknüpfung im Startmenü unter Start - COPA-DATA - ToolsXX - Remote Desktop Verbindung starten durchführen.

Parameter | Beschreibung
Server | Hier geben Sie den Rechnernamen oder die IP-Adresse des Zielsystems ein.
Connection profile | Die Verbindungsprofile bestimmen die notwendige Netzwerkbandbreite. Je geringer Sie die verfügbare Bandbreite einstellen, desto stärker wird die Bilddatenübertragung komprimiert, und desto schlechter wird auch die Bilddarstellung. Diese Optionen können nur zu Beginn der Verbindung gesetzt werden, und sind nachträglich nicht mehr änderbar. Sie müssen ggf. die Verbindung trennen und wieder neu aufbauen.
Options | Öffnet den Connection Options Dialog. Die Verbindungsoptionen können Sie auch später, wenn Sie verbunden sind, noch ändern. Die Beschreibung der Optionen finden Sie im Kapitel Verbindungsoptionen.

Sobald Sie auf Connect klicken, wird die Verbindung hergestellt.

Mittels Web Browser:

Eine weitere Möglichkeit ist, eine Verbindung mittels eines Standard Web Browser herzustellen. Dazu muss die Java Runtime auf Ihrem Rechner installiert sein. Die jeweils aktuellste Version können Sie von der Java Homepage downloaden: http://www.java.com. Alternativ finden Sie ein Java-Setup auch auf der Installations-DVD. Legen Sie dazu die DVD ein und starten Sie das Installationsauswahl-Programm (Start.exe). Im Bereich Tools können Sie die Java Runtime installieren.

Starten Sie den Web Browser und geben Sie in der Adresszeile den Rechnernamen oder die IP-Adresse des Zielsystems ein, gefolgt von :5600 , z. B.: http://MyRemotePCName:5600.

info Info

Für alle Verbindungen gilt: Eine Verbindung zum lokalen PC ist nicht möglich!

Bei Verbindungsproblemen prüfen Sie bitte die Voraussetzungen.

Noch in diesem Kapitel

Authentifizierung

Standard Beobachtungssoftware

Web-Beobachtungssoftware


Authentifizierung

Handbuch -> Remote Desktop -> Verbindung aufbauen -> Authentifizierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Standard Beobachtungssoftware

Während die Verbindung hergestellt wird, wird ein Informationsdialog angezeigt, in dem Sie sich vergewissern können, dass Sie mit dem richtigen Zielsystem eine Verbindung aufbauen.

In diesem Dialog müssen Sie nur das Verbindungspasswort angeben. Ein Benutzername ist nicht erforderlich.

Web-Oberfläche

_

In diesem Dialog müssen Sie das Verbindungspasswort angeben. In der Titelzeile sehen Sie, mit welchem Remote Desktop Sie verbunden sind.

Passwörter

Damit Sie eine Verbindung aufbauen können, müssen Sie die Verbindungspasswörter kennen. Das Primary Passwort erlaubt Ihnen den Vollzugriff auf den Remote Desktop. Das View-only Passwort ermöglicht nur einen Betrachtungsmodus. Je nach verwendetem Passwort wird der dazu passende Modus gestartet. Die Länge der Passwörter ist auf 8 Zeichen begrenzt. (Details siehe Kapitel Konfiguration)

attention Achtung

Wenn serverseitig in der Konfigurationssoftware die Option 'Block remote Input Events' gesetzt ist, können Sie das Remote-System selbst bei Verwendung des Primary Passworts nicht bedienen.

info Info

Bei der Erstinstallation wird das Primary Passwort auf SCADA-ALL und das View-only Passwort auf SCADA gesetzt. Sie können die Passwörter jederzeit mit der Konfigurationssoftware am Remote System ändern (Siehe Konfiguration).


Standard Beobachtungssoftware

Handbuch -> Remote Desktop -> Verbindung aufbauen -> Standard Beobachtungssoftware

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sobald Sie eine Verbindung hergestellt haben, zeigt die Beobachtungssoftware den Bildschirminhalt des Remote Desktops an.

Weitere Einstellungen können Sie über die Symbolleiste, das Kontextmenü oder die Dropdownliste vornehmen. Selbst wenn die Symbolleiste nicht sichtbar ist, erreichen Sie das Kontextmenü mit einem Rechtsklick auf die Titelzeile der Beobachtungssoftware bzw. auf das Symbol in der Taskbar. Falls Sie den Vollbildmodus aktiviert haben, müssen Sie diesen zuerst mit der Tastenkombination <Strg><Alt><Umschalt><F> deaktivieren.

Die Symbolleiste und das Kontextmenü bieten folgende Möglichkeiten:

Parameter

Beschreibung

Connection options...

Öffnet den Dialog zum Einstellen der Verbindungsoptionen. Siehe Verbindungsoptionen

Connection info

Öffnet einen Dialog, der die aktuellen Verbindungsinformationen anzeigt.

Full Screen

Schaltet in den Vollbildmodus um, das bedeutet, dass Sie keinen Windows Rahmen mehr um die Software haben.
Wenn am Remote Rechner und am Lokalen Rechner dieselbe Monitorauflösung verwendet wird, wird das Remote Bild bildschirmfüllend dargestellt.
Wenn der Remote Rechner über eine kleinere Auflösung verfügt, wird der Remote Desktop zentriert und mit einem schwarzen Rahmen dargestellt.
Wenn der Remote Rechner über eine größere Auflösung als der lokale Rechner verfügt, wird der Remote Desktop abgeschnitten dargestellt. Bei Bewegungen mit der Maus in den nicht sichtbaren Bereich scrollt der Monitor automatisch dorthin.

Mit der Tastenkombination <Alt><Tab> können sie zwischen dem Remote Rechner und dem Lokalen Rechner hin und herschalten. Den Vollbildmodus beenden Sie mit der Tastenkombination <Strg><Alt><Umschalt><F> .

Show Toolbar

Aktiv: Symbolleiste wird angezeigt.

Request screen refresh

Bewirkt einen Refresh und damit ein Neuzeichnen des Remote Desktops, z.B, bei schlechter Darstellung.

Send Ctrl-Alt-Del

Diese Aktion hat keine Auswirkung.

Send Ctrl-Esc

Öffnet das Startmenü am Remote Desktop.

Ctrl key down

Hält am Remote Desktop die Strg Taste gedrückt. Durch einen weiteren Klick wird die Taste wieder losgelassen.

Alt key down

Hält am Remote Desktop die Alt Taste gedrückt. Durch einen weiteren Klick wird die Taste wieder losgelassen.

New connection...

Öffnet den Dialog für eine neue Remote Desktop Verbindung. Siehe Verbindung aufbauen. Die existierende Verbindung wird getrennt.

Save connection info as...

Speichert eine Verknüpfung zu dieser Verbindung als RDC Datei (Remote Desktop Communication File). Diese können Sie z. B. am Desktop ablegen. Beim Speichern werden Sie gefragt, ob Sie das Passwort in der Datei speichern möchten.
Hinweis: Das Speichern des Passwortes stellt ein Sicherheitsrisiko dar.

Durch einen Doppelklick auf die Datei wird die Verbindungssoftware gestartet und Sie werden automatisch zum eingetragenen Remote Desktop verbunden, ohne dass Sie Rechnername (und Passwort, falls sie dieses in der Datei gespeichert haben) eingeben müssen.

Disconnect

Trennt die Verbindung und beendet das Programm.

Noch in diesem Kapitel

Verbindungsoptionen


Verbindungsoptionen

Handbuch -> Remote Desktop -> Verbindung aufbauen -> Standard Beobachtungssoftware -> Verbindungsoptionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Registerkarte Connection können Sie folgendes konfigurieren:

Parameter | Beschreibung
Scale by | Skaliert die Darstellung des Remote Desktops auf die eingestellte Größe. Vorteilhaft, wenn der Remote Desktop eine größere Monitorauflösung als der lokale Rechner hat.
Full-screen mode | Schaltet in den Vollbildmodus. Den Vollbildmodus beenden Sie mit der Tastenkombination <Strg><Alt><Umschalt><F>
Deiconify on remote Bell event | Diese Einstellung hat keine Auswirkung

In der Registerkarte Globals können Sie folgendes konfigurieren:

Parameter | Beschreibung
Show toolbars by default | Zeigt die Toolbar an. Wenn die Toolbar deaktiviert wurde, kann Sie über das Kontextmenü der Software wieder aktiviert werden.
Warn at switching to the full-screen mode | Wechseln Sie in den Vollbildmodus, wird eine Warnmeldung mit einem Hinweis, wie man den Vollbildmodus wieder beendet, angezeigt.
Number of connections to remember | Die Beobachtungssoftware merkt sich die letzten Verbindungen. Beim Verbindungsaufbau können Sie in der Auswahlliste die letzten Verbindungen auswählen. Die Anzahl der gespeicherten Verbindungen stellen Sie hier ein.
Clear the list of saved connections | Löscht die Liste der gespeicherten Verbindungen.
Dot cursor | Über dem Remote Mauszeiger wird der lokale Mauszeiger als schwarzer Punkt angezeigt.
Small dot cursor | Über dem Remote Mauszeiger wird der lokale Mauszeiger als kleiner schwarzer Punkt angezeigt.
Normal arrow | Über dem Remote Mauszeiger wird der lokale Mauszeiger als Standard Windows Mauszeigerpfeil angezeigt.
No local cursor | Es wird nur der Remote Mauszeiger angezeigt.


Web-Beobachtungssoftware

Handbuch -> Remote Desktop -> Verbindung aufbauen -> Web-Beobachtungssoftware

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Oberfläche im Browser stehen Ihnen folgende Möglichkeiten zur Verfügung:

Parameter | Beschreibung
Disconnect | Beendet die Verbindung. Der Webbrowser bleibt geöffnet.
Options | Hier können Sie verschiedene Verbindungsoptionen einstellen. Diese Optionen sind nicht dokumentiert. Belassen Sie diese am besten bei den Originaleinstellungen. Die Einstellungen werden nicht gespeichert. Beim nächsten Verbindungsaufbau sind wieder die Originaleinstellungen vorhanden.
Clipboard | Ermöglicht es, textuelle Informationen von der Zwischenablage des Remote Desktops auszulesen bzw. an die Zwischenablage zu senden. Im Dialog sehen Sie die Zwischenablage des Remote Desktops. Wenn Sie den Text ändern, wird dieser durch Drücken auf Close an die Zwischenablage des Remote Desktops gesendet.
Send Ctrl-Alt-Del | Diese Option wird nicht unterstützt.
Refresh | Aktualisiert den Bildschirminhalt.


Einschränkungen

Handbuch -> Remote Desktop -> Einschränkungen

Der Remote Desktop Dienst läuft im Benutzerkontext. Er wird mit dem Anmelden des Benutzers an Windows gestartet.

Eine Remote Verbindung kann daher erst hergestellt werden, wenn ein Benutzer angemeldet ist. Ein Remote-Einloggen mit Strg-Alt-Entf ist nicht möglich. Wenn sich der Benutzer abmeldet, wird auch der Remote Desktop Dienst wieder beendet. Eventuell verbundene Beobachter verlieren die Verbindung.

Ist der Remote Rechner gesperrt, kann ebenfalls keine Verbindung hergestellt werden. Der Rechner ist auch gesperrt, wenn ein Bildschirmschoner mit der Option Kennworteingabe bei Reaktivierung aktiviert wurde.

Sind am Remote Rechner mehrere Benutzer gleichzeitig angemeldet (schnelle Benutzerumschaltung), wird der Remote Desktop Dienst mehrfach gestartet. Die Beobachtungssoftware kann sich aber immer nur auf den ersten gestarteten Dienst verbinden. Ist dieser erste Benutzer nicht aktiv, wird die Verbindung zwar aufgebaut, aber nach Eingabe des Passwortes sofort wieder geschlossen.

Die Verbindung wird auch getrennt, wenn der erste angemeldete Benutzer auf Benutzer wechseln klickt und damit inaktiv wird.


Voraussetzungen / Fehlersuche

Handbuch -> Remote Desktop -> Voraussetzungen / Fehlersuche

Damit Sie eine Verbindung zu einem Remote System herstellen können, müssen folgende Voraussetzungen erfüllt sein:

  • zenon (mind. Version 6.22 oder höher) muss installiert sein.
  • Am PC muss der Remote Desktop Dienst (zenVNCSrv.exe) aktiviert sein. Den Dienst können Sie in der Remote Desktop Konfigurationssoftware aktivieren (siehe Konfiguration). Überprüfen können Sie den Dienst im Windows Taskmanager.
  • Am Remote PC muss ein Benutzer angemeldet sein, und der Rechner darf nicht gesperrt sein. Siehe Einschränkungen.
  • Unter Windows CE müssen Sie den Remote Desktop Dienst zenVNCSrvCE.exe manuell oder mittels der Windows CE Autostart Optionen starten. Wie Sie diese aktivieren, können Sie in der Beschreibung des Geräte-Herstellers nachlesen. Überprüfen können Sie das Laufen des Dienstes im Windows CE Taskmanager (falls verfügbar).
  • Der Dienst muss in der Windows Firewall und auch in allen anderen Firewalls freigeschaltet sein, bzw. die beiden Ports 5600 (http Port) und 5610 (Remote Desktop Port) müssen freigeschaltet sein. Überprüfen können Sie das, indem Sie von einem anderen PC aus eine Telnet Verbindung auf den Port 5600 bzw. 5610 öffnen. Starten Sie dazu die Kommandozeile (cmd.exe) und geben sie folgenden Befehl ein:
    telnet RemotePCName 5610.
    Ist die Verbindung erfolgreich, erscheint ein schwarzes Fenster.
    Unter Windows Vista ist Telnet standardmäßig nicht installiert. Sie können das Programm aber mit den folgenden Schritten installieren:
    Klicken Sie auf die Schaltfläche Start, auf Systemsteuerung, auf Programme, und dann auf Windows-Funktionen ein- oder ausschalten.
    Aktivieren Sie im Dialogfeld Windows-Funktionen das Kontrollkästchen Telnet-Client und klicken Sie auf OK.
  • Die beiden Ports 5600 und 5610 dürfen nicht von anderen Programmen belegt sein, sonst werden andere Ports zufällig belegt. Die Portbelegung können Sie mit dem Windows Befehl netstat -n -a -o von der Kommandozeile aus kontrollieren. Die Prozess-ID des Remote Desktop Diensts zenVNCSrv.exe können Sie aus dem Taskmanager in der Registerkarte Prozesse ablesen. Ist diese Spalte nicht sichtbar, können Sie die Spalte PID (Prozess-ID im Menü Ansicht - Spalten Auswählen... aktivieren.
  • Wenn Sie die Verbindung über den Editor starten, müssen Sie im Remote Transport als Transportmedium TCP/IP eingestellt haben. Als Zielsystem müssen Sie entweder beim Remote Transport oder als Projektserver einen Rechner angegeben haben.
  • Schneller Benutzerwechsel unter Windows Vista wird nicht unterstützt. Die Verbindung wird dabei unterbrochen. Siehe Einschränkungen

info Info

Deaktivierung des HTTP Servers:

Wird der HTTP Server deaktiviert, kann die Anmeldeseite über einen Refresh des Browsers weiterhin aufgerufen werden.
Dabei wird die Seite aus dem Cache vom normalen HTTP Port (5600) auf den Remote Desktop Port (5610) umgeleitet. Damit sind auch Anmeldung und voller Zugriff weiter möglich. Um Zugriffe zu verhindern, ändern Sie das Passwort oder schließen Sie den Remote Dektop Port 5610.


Deinstallation

Handbuch -> Remote Desktop -> Deinstallation

Der Remote Desktop wird bei der zenon Deinstallation nicht entfernt, da er versionsübergreifend verwendet wird. Das Setup hat keine Möglichkeit zu prüfen, welche zenon Versionen noch im Einsatz sind.

Um den Remote Desktop zu entfernen, müssen Sie folgende Schritte durchführen:

Starten Sie die Konfigurationssoftware und entfernen Sie bei Enable Remote Desktop service das Häkchen und drücken Sie auf OK. Dabei wird der Remote Desktop Dienst beendet und deregistriert.

Nun können Sie die Dateien zenVNCSrv.exe, zenVNCcfg.exe und oem.dll im Ordner C:\Programme\Gemeinsame Dateien\COPA-DATA\zenVNCSrv löschen.


Remote-Transport

Handbuch -> Remote-Transport

Der Remote-Transport dient dazu, Runtime Dateien auf ein Zielsystem zu transportieren. Informationen zum Sichern und Rücklesen von Editor-Dateien finden Sie im Kapitel Projektsicherungen.

Wenn sich die Runtime und der Editor auf ein und dem selben Rechner befinden, stehen die Runtime Dateien der Runtime direkt zur Verfügung. Befindet sich die Runtime nicht auf dem selben Rechner, gibt es zwei Möglichkeiten:

  1. Der entsprechende Ordner mit den Runtime-Dateien wird freigegeben und als Netzwerklaufwerk verbunden.
  2. Die Runtime Dateien werden auf den Zielrechner kopiert.

Beim Einbinden als Netzlaufwerk hängt das Funktionieren der Runtime davon ab, dass das Netzwerk mit genügender Leistung zur Verfügung steht. Stehen die Dateien direkt am Runtime-Rechner zur Verfügung, lassen sich Ausführung und Performance besser sicher stellen.

Die Übertragung der Runtime-Dateien zu den Runtime-Rechnern kann mit dem Windows Explorer erfolgen. Einfacher, systematischer und sicherer passiert das aber mit dem zenon Remote-Transport. Der Remote-Transport stellt sicher, dass immer alle benötigten Dateien auf den Zielrechner gelangen.

attention Achtung

Bilddateien vom Typ PNG können nicht überschrieben werden, wenn die Runtime läuft.

Hintergrund: Die Runtime sperrt geöffnete .png Dateien gegen überschreiben.

Mit dem Remote-Transport können auch beliebige andere Dateien transportieren werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Funktionalitäten

Der Remote-Transport bietet über die reine Kopierfunktionalität hinaus auch noch andere Funktionalitäten:

Parameter | Beschreibung
Inkrementelles Kopieren | Der Editor erkennt automatisch, welche Dateien am Zielsystem sich von den zu übertragenden unterscheiden, und überträgt nur die geänderten.
Startprojekt setzen | Über den Remote-Transport kann das Startprojekt am Remote Rechner gesetzt werden.
Runtime starten und beenden | Die Runtime kann am entfernten Rechner gestartet und beendet werden.
Systemstatus übertragen | Der aktuelle Status des Remote PCs (Betriebssystem, zenon Version, vorhandene Laufwerke, usw.) kann abgefragt werden.
PC reboot | Ein PC kann remote neu gestartet werden.
Online Nachladen | Dabei wird die Remote Runtime online aktualisiert
Remote Desktopverbindung starten | Baut eine Remote Desktopverbindung auf
Alle Projektdateien rücklesen | Ein komplettes Projekt kann von einem Remote System zurückkopiert werden.
Dateien kopieren und registrieren | Dateien werden nicht nur kopiert, sondern am Zielsystem auch registriert. Besonders interessant für Fonts und ActiveX Elemente.
Dateien kopieren und ausführen | Ausführbare Dateien werden kopiert und gestartet.

Noch in diesem Kapitel

Symbolleiste Remote-Transport

Kontextmenü Remote-Transport

Projektieren im Editor

Verbindung aufbauen


Symbolleiste Remote-Transport

Handbuch -> Remote-Transport -> Symbolleiste Remote-Transport

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Entwicklungsrechner kann Remote-Verbindungen zu anderen Rechnern aufbauen. Die Symbolleiste Remote-Transport stellt Funktionen für das Übertragen und Abfragen von Daten zur Verfügung.

Symbol

(von links nach rechts)

Funktion

Remote-Transport: Verbindung aufbauen

Baut eine Verbindung zum Zielrechner auf.

Remote-Transport: Verbindungseinstellungen

Öffnet Dialog zur Konfiguration der Verbindung.

Remote: Geänderte Runtime-Dateien übertragen

Überträgt alle auf dem Entwicklungsrechner geänderten Runtime-Dateien zum Zielrechner.

Remote: Alle Runtime-Dateien zurücklesen

Liest alle zur Runtime änderbaren Dateien (wie Rezepte oder Benutzerverwaltung) auf den Entwicklungsrechner zurück.

Remote: Startprojekt setzen

Setzt das Startprojekt für den Zielrechner.

Remote: Runtime starten

Startet die Runtime auf dem Zielrechner.

Remote: Runtime beenden

Beendet die Runtime auf dem Zielrechner.

Remote: Projekt nachladen

Führt auf dem Zielrechner die Funktion nachladen aus.

Remote: Desktop Verbindung starten

Startet eine Verbindung, um den Zielrechner per Remote Desktop zu bedienen.

Symbolleistenoptionen

Klick auf Pfeil öffnet Submenü:

Aktiv: Symbolleiste wird angezeigt.

Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.

Weitere Symbole können über die Optionen der Symbolleiste hinzugefügt werden:

Alle Runtime-Dateien übertragen

Überträgt alle Runtime-Dateien zum Zielsystem.

Betriebssystem neu starten

Startet das Betriebssystem des Zielrechners nach einer Sicherheitsabfrage neu. Unter Windows CE wird diese Option nicht unterstützt.

Systemstatus ermitteln

Ermittelt Systemstatus des Zielrechners und schreibt Daten in das Ausgabefenster. Ermittelt werden:

  • Computername
  • Betriebssystem
  • Runtime aktiv/nicht aktiv
  • Startprojekt
  • Realer Speicher
  • Laufwerke
  • Remote Seriennummer
  • Remote Aktivierungsnummer
  • Remote zenon Version

Passwort ändern u. Lizenzierung anzeigen

Öffnet Dialog für Verbindungsaufbau.

Ermöglicht:

  • Änderung des Passworts für den Verbindungsaufbau
  • Anzeige und Änderung der Lizenzierung des Zielrechners
  • Konfiguration der Verschlüsselung am Zielrechner

Hinweis: Alle Befehle für den Remote-Transport stehen auch im Kontextmenü des Projekts zur Verfügung.


Kontextmenü Remote-Transport

Handbuch -> Remote-Transport -> Kontextmenü Remote-Transport

Die Befehle für den Remote-Transport erreichen Sie über die Symbolleiste oder das Kontextmenü des Projekts:

  1. führen Sie einen Rechtsklick auf das Projekt im Projektmanager aus
  2. wählen Sie im Kontextmenü den Knoten Remote Transport
  3. wählen Sie inder Dropdownliste den gewünschten Befehl

Befehl

Funktion

Verbindung aufbauen

Baut eine Verbindung zum Zielrechner auf.

Verbindungseinstellungen

Öffnet Dialog zur Konfiguration der Verbindung.

Geänderte Runtime-Dateien übertragen

Überträgt alle auf dem Entwicklungsrechner geänderten Runtime-Dateien zum Zielrechner.

Alle Runtime-Dateien übertragen

Überträgt alle Runtime-Dateien vom Entwicklungsrechner zum Zielrechner.

Alle Runtime-Dateien zurücklesen

Liest alle zur Runtime änderbaren Dateien (wie Rezepte oder Benutzerverwaltung) auf den Entwicklungsrechner zurück.

Projekt als Startprojekt setzen

Setzt das Startprojekt für den Zielrechner.

Runtime starten

Startet die Runtime auf dem Zielrechner.

Runtime beenden

Beendet die Runtime auf dem Zielrechner.

Projekt nachladen

Führt auf dem Zielrechner die Funktion nachladen aus.

Betriebssystem neu starten

Startet das Betriebssystem des Zielrechners nach einer Sicherheitsabfrage neu. Unter Windows CE wird diese Option nicht unterstützt.

Systemstatus ermitteln

Ermittelt Systemstatus des Zielrechners und schreibt Daten in das Ausgabefenster. Ermittelt werden:

  • Computername
  • Betriebssystem
  • Runtime aktiv/nicht aktiv
  • Startprojekt
  • Realer Speicher
  • Laufwerke
  • Remote Seriennummer
  • Remote Aktivierungsnummer
  • Remote zenon Version

Passwort ändern u. Lizenzierung anzeigen

Öffnet Dialog für Verbindungsaufbau.

Ermöglicht:

  • Änderung des Passworts für den Verbindungsaufbau
  • Anzeige und Änderung der Lizenzierung des Zielrechners
  • Konfiguration der Verschlüsselung am Zielrechner

Remote: Desktop Verbindung starten

Startet eine Verbindung, um den Zielrechner per Remote Desktop zu bedienen.


Projektieren im Editor

Handbuch -> Remote-Transport -> Projektieren im Editor

Der Remote-Transport wird in den Projekteigenschaften unter Allgemein/Remote-Transport konfiguriert und über die Symbolleiste Remote-Transport bedient.

Interne ID: Projektieren im Editor

Remote-Transport

Der Konfigurationsdialog für den Remote Transport wird geöffnet.
Der Remote Transport dient dem transportieren, nachladen, starten und beenden eines Projekts auf einem entfernten Rechner und dem anfordern des aktuellen Status.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Projektieren im Editor

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um den Remote-Transport zu konfigurieren:

  1. navigieren Sie in den Projekteigenschaften zum Knoten Allgemein
  2. klicken Sie auf die Eigenschaft Remote-Transport
  3. der Dialog zur Konfiguration der Verbindungseigenschaften und der zu übertragenden Dateien wird geöffnet

Parameter

Beschreibung

Transportmedium

Seriell

Übertragung über eine serielle Verbindung, z.B. auf ein CE Terminal.
  • Port

Auswahl des COM-Ports für die serielle Verbindung.

TCP/IP

Übertragung per TCP/IP in einem Netzwerk oder über ein Modem.
  • Rechnername oder IP-Adresse

Der Rechnername oder die TCP/IP Adresse wird als Ziel angegeben:

  • Eingabe des Rechnernamens manuell oder über Klick auf Schaltfläche ...
  • Eingabe der IP-Adresse manuell

Die IP-Adresse muss dem Format der eingestellten IP-Version (IPv4 oder IPv6) entsprechen.

Hinweis: Bei Verbindung mit Namen können auch Portnummern verwendet werden. Zum Beispiel: Runtime1;PORT=1105

Quelle/Ziel

Liste der Verbindungen.

In der ersten Zeile kann ein Ziel für den obersten Ordner der Struktur definiert werden. Rechtsklick in Zelle öffnet Kontextmenü zur Auswahl.

Achtung: Dieser Pfad muss auf dem Zielsystem permanent vorhanden sein. Also kein eingebundenes Netzlaufwerk und kein Wechseldatenträger.

aktiv

Definiert zu übertragende optionale Dateien.

Projekt-Basispfad kann nicht abgewählt werden.

Quelle

Ordner für Dateien, die übertragen werden.

Ziel

Zielordner.

Ziele für den obersten Ordner und neue Einträge können definiert werden.

Unterordner können nicht verändert werden. Damit ist sicher gestellt, dass am Zielsystem zur Runtime alle Dateien gefunden werden.

Hinweis: Der Default-Ordner ist der in den Projekteigenschaften definierte Runtime-Ordner. Wird der Zielordner manuell eingetragen, achten Sie darauf, dass er mit dem Projektnamen endet. Dies ist wichtig für die Mehrprojektverwaltung. Zum Beispiel:
C:\Users\Public\Documents\zenon_Projects\MY_PROJECT

Bearbeitung

Art der Übertragung. Kann für obersten Ordner und neue Einträge frei gewählt werden. Rechtsklick öffnet Dropdownliste:

  • Kopieren: kopiert Dateien
  • Kopieren und registrieren: kopiert Dateien und registriert sie im System. Hilfreich für ActiveX Elemente und für Schriften (ttf-Dateien).
  • Kopieren und ausführen: kopiert Dateien und führt sie dann aus

Beschreibung

Für neue Einträge optionale Texteingabe zur Beschreibung der zu übertragenden Dateien.

attention Achtung

Beim Redundanzbetrieb gilt: Wenn Treiber verwendet werden, die eine Konfigurationsdatei benötigen, muss der Eintrag \zenon\custom\drivers deaktiviert werden.

Abstand embedded

Remote steuern im Netzwerk

Wählen Sie im Kontextmenü des Projekts -> Remote Transport -> <Befehl>:

Parameter

Beschreibung

Verbindung aufbauen

Über den Dienst zenSysSvr wird eine Verbindung zum Zielgerät aufgebaut. Auf beiden Geräten muss der Dienst zenSysSvr bzw. auf einem CE Gerät der Dienst SysSrvCE.exe gestartet sein. Die Versionen müssen identisch sein.

Geänderte Runtime Dateien übertragen

Wird diese Einstellung ausgewählt, so werden nur die Runtime-Dateien übertragen, die sich seit der letzen Übertragung geändert haben. Sind auf dem Zielgerät keine Runtime-Dateien vorhanden, werden alle Runtime-Dateien übertragen.

Alle Runtime Dateien übertragen

Wird dieser Eintrag aktiviert, werden alle Runtime-Dateien (neu) übertragen. Ausgenommen sind die Dateien für z.B. Standard-Rezepturen oder Message-Control die explizit von der Übertragung ausgenommen wurden, über die Einstellung: 'RT Änderbare Daten'.

Alle Runtime Dateien rücklesen

Wird diese Einstellung ausgewählt, so werden alle Runtime-Dateien der Module Rezepte, Rezeptgruppen Manager, Message Control, Benutzer Verwaltung und Production and Facility Scheduler (PFS) vom Zielsystem in das lokale Runtime-Verzeichnis zurückgelesen. Anschließend können die Änderungen in der Runtime über die Option 'Importiere Runtime-Dateien im Editor eingelesen werden.

Projekt als Startprojekt setzen

Das ausgewählte Projekt wird als Startprojekt gesetzt. Bei jedem Runtime-Start wird dieses Projekt geladen.

Runtime starten

Die Runtime wird gestartet.

Runtime beenden

Die Runtime wird beendet.

Projekt nachladen

Das Projekt wird nachgeladen. Geänderte Runtime-Dateien werden eingelesen.

Betriebssystem neu starten

Das Gerät, mit dem die Verbindung besteht, wird nach einer Sicherheitsabfrage neu gestartet. Es muss gegebenenfalls neu am Betriebssystem angemeldet werden. Unter Windows CE wird diese Option nicht unterstützt.

System Status ermittlen

Es wird ermittelt, ob die Runtime auf dem Zielgerät läuft, mit welchem Status und welche zenon Version dort installiert ist. Ermittelt werden:

  • Computername
  • Betriebssystem
  • Runtime aktiv/nicht aktiv
  • Startprojekt
  • Realer Speicher
  • Laufwerke
  • Remote Seriennummer
  • Remote Aktivierungsnummer
  • Remote zenon Version

Passwort ändern und Lizenzierung anzeigen

Öffnet Dialog für Verbindungsaufbau.

Ermöglicht:

  • Änderung des Passworts
  • Anzeige und Änderung der Lizenzierung
  • Konfiguration der Verschlüsselung

Remote Desktop Verbindung starten

Startet eine Verbindung, um den Zielrechner per Remote Desktop zu bedienen.

Noch in diesem Kapitel

TCP/IP

Seriell

Dateien festlegen

Runtime änderbare Dateien

Windows CE


TCP/IP

Handbuch -> Remote-Transport -> Projektieren im Editor -> TCP/IP

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Remote-Transport Konfiguration wird der Name oder die IP-Adresse des Zielrechners angegeben. Die IP-Adresse muss dem Format der eingestellten IP-Version entsprechen, also IPv4-konform bei Verwendung von IPv4 und IPv6-konform sein bei Verwendung von IPv6.

Bei Verwendung des Namens, werden die zuletzt verwendeten Namen gespeichert und können über die Dropdownliste ausgewählt werden. Die Verwendung von Portnummern ist nur in Verbindung mit Namen möglich.

Automatische Einstellung bei Serverprojekten

Wenn das zu übertragende Projekt als Serverprojekt eingesetzt wird, muss in der Remote-Transport Konfiguration unter Konfigurations Parameter der Rechnername nicht angegeben werden. Der Remote-Transport verwendet in diesem Fall immer den bei Server in der Netzwerkkonfiguration eingetragenen Rechner. Damit wird sichergestellt, dass die Änderungen immer auf den Server übertragen werden, der sie dann automatisch zu allen Clients weiter überträgt!

attention Achtung

Standardmäßig verwendet der Remote-Transport den TCP Port 1101. Dieser Port darf nicht von anderen Anwendungen blockiert werden.


Seriell

Handbuch -> Remote-Transport -> Projektieren im Editor -> Seriell

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Kommunikation im Remote-Transport erfolgt standardmäßig über TCP/IP. Sie kann aber auch auf serielle Kommunikation geändert werden. So können zum Beispiel Windows CE Geräte angesprochen werden. Dazu muss:

  • über die zenon6.ini am Remote Gerät die Kommunikationsart des Transportservice geändert werden
  • im Editor der Remote-Transport konfiguriert werden

attention Achtung

Wenn die zenon6.ini bearbeitet wird, werden die Änderungen erst nach einem Neustart des Transportservice wirksam.

Einträge zenon6.ini

Wenn der Transportservice für den seriellen Transport verwendet werden soll, müssen in der zenon6.ini auf dem Zielrechner folgende Einträge manuell eingetragen werden. Hinweis: Unter Windows CE werden diese Einträge über die Oberfläche des Transportservice in der zenon6.ini automatisch generiert.

[SYS_REMOTE]

; SysService hängt an der Com Schnittstelle:

CONFIG=DEVICE=COM;

PORT=COM2;

attention Achtung

Der abschließende ; (Strichpunkt) darf nicht vergessen werden.

Mit dieser Einstellung arbeitet der Remote-Transport mit der Baudrate 115200 Bits/Sekunde. Der Editor ist standardmäßig ebenfalls auf diese Baudrate eingestellt.

Einstellungen Editor

Wählen Sie im Editor:

  1. Seriell als Transport Medium
  2. in der Dropdownliste den COM-Port des Quellrechners


Dateien festlegen

Handbuch -> Remote-Transport -> Projektieren im Editor -> Dateien festlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Welche Dateien übertragen werden, definieren Sie im Konfigurationsdialog über die Checkbox in der Spalte aktiv. Die Zeile mit den Projekt-Basispfad kann nicht abgewählt werden. Die Projektdateien werden immer übertragen.

Hinweis: Quellpfade sind immer relativ zum Projekt-Basispfad angelegt.

attention Achtung

Beachten Sie die Auswirkungen der Einstellungen, wenn das Projekt im Netzwerk eingesetzt wird!

Zum Beispiel:

Die Übertragung von Grafiken wird deaktiviert, weil diese schon am Server liegen. Dann wird ein Client gestartet. Der Client stellt fest, dass die Grafiken nicht übertragen werden sollen und holt sich diese daher auch nicht ab. Am Client werden dann keine Grafiken angezeigt.

Oder es werden umgekehrt Dateien zum Client übertragen, die dort vorhandene Dateien überschreiben.

Dateien zur Übertragung

Mit dem Remote Transport werden folgende Dateien ins Zielsystem übertragen. Dabei werden immer alle Dateien in den Verzeichnissen übertragen:

  1. Standard

    Alle Dateien, die sich im Runtime Verzeichnis des Projekts befinden.
    Diese Dateien bestimmen das Aussehen und Verhalten des Projekts und werden standardmäßig übertragen:

    1. alle Bilddateien (Bildname.zpp)
    2. amlcel.cmp
    3. archiv.cmp
    4. fpm.cmp
    5. functions.cmp
    6. project.cmp
    7. projekt.mdb (nicht für CE!)
    8. remas.cmp
    9. rezepturen.cmp
    10. scripts.cmp
    11. templates.cmp
    12. variables.cmp
    13. zuweisung.cmp
    14. Plus: project.ini und projekt.vba, die sich immer im Projektverzeichnis befinden

info Info

Nicht übertragen werden standardmäßig Dateien mit den Endungen:

  • .hot
  • .ho
  • .ret
  • .re
  1. Optional

    Zusätzlich müssen alle Dateien übertragen werden, die in das Projekt eingebunden wurden. Die Auswahl erfolgt über die Checkbox aktiv der Remote Transport Einstellungen. Diese Dateien befinden sich in folgenden Unterverzeichnissen des Projektverzeichnisses:

    1. \zenon\custom\graphics: für Grafiken
    2. \zenon\custom\lists: für Sprachtabellen
    3. \zenon\custom\media: für alle Mediendateien
    4. \zenon\custom\reports: für die Tabellen des Report Generators
    5. \zenon\custom\help: für Hilfedateien
    6. \zenon\custom\additional: für zusätzliche Dateien
    7. \zenon\custom\drivers: für Treiber
    8. \straton: für zenon Logic

    Empfehlung: Projekt-Basispfad, Grafiken, Sprachtabellen, Reporttabellen und Mediadateien immer übertragen.
    Aus dem Projekt-Basispfad werden standardmäßig übertragen: Die Dateien project.ini, Projekt.vba, Monitor.mon und das Verzeichnis Projekt.

    Standardmäßig werden von zenon immer Relativpfade und keine Absolutpfade verwendet, damit am Zielsystem die Dateien wiedergefunden werden.

    Für die optional zu übertragenden Dateien sollten die ursprünglichen Pfade verwendet werden (leeres Feld bei Ziel), damit diese von zenon auch am Zielsystem wieder gefunden werden.

  2. Startprojekt setzen

    Für die Runtime muss das Startprojekt in der zenon6.ini eingetragen werden. Dazu klicken Sie auf die Schaltfläche Remote Runtime Startprojekt setzen in der Symbolleiste Remote Transport. Dabei werden folgende Einträge gesetzt:

    [PATH]

    VBF30=Projektpfad

    [DEFAULT]

    DEFANWENDUNG30=Projektname

Globalprojekt

Wenn sich im Arbeitsbereich ein Globalprojekt befindet, wird dieses automatisch zum Transport angeboten. Keine zusätzlichen Einstellungen müssen getroffen werden. Es werden immer alle für das Globalprojekt notwendigen Dateien übertragen!

Auswahl individueller Dateien

Um eigene, individuelle Dateien zu übertragen:

  1. klicken Sie mit der rechten Maustaste in die erste leere Zelle in der Spalte Quelle
  2. wählen Sie im Kontextmenü Datei Auswahl oder Ordner Auswahl
  3. der Explorer zur Auswahl wird geöffnet
  4. wählen Sie die gewünschte Datei oder den gewünschten Ordner
  5. aktivieren Sie die Checkbox in der Spalte aktiv
  6. klicken Sie mit der rechten Maustaste in die Zelle in der Spalte Ziel
  7. definieren Sie den Ziel-Ordner
    Bleibt das Ziel leer, werden die Dateien in der selben Verzeichnisstruktur übertragen, wie unter Quelle definiert.

attention Achtung

Pfade relativ angeben!

Wenn Sie die Pfade zu Ihren individuellen Dateien relativ zum Projekt-Basispfad an. Damit wird vom Zielsystem immer die richtige Verzeichnisstruktur beibehalten.
Beispiel:

Angabe bei Quelle: /default.iso eingegeben.
Der Remote-Transport weiß dann automatisch, dass sich die Datei im Projekt-Basispfad befindet.
Verzeichnissen werden analog angegeben.

Windows CE:

Wenn das Zielgerät ein Windows CE Terminal ist, und beim Projekt-Basispfad kein explizites Ziel angegeben wurde, wird standardmäßig das Ziel /Storage Card/Data verwendet.

Aktion beim Übertragen

In der Spalte Bearbeitung kann bei hinzugefügten Zeilen eingestellt werden, wie mit den angegebenen Dateien beim Remote-Transport verfahren werden soll. Hier stehen drei Möglichkeiten zur Verfügung:

Aktion | Beschreibung
Kopieren | Die Datei wird auf das entfernte Gerät kopiert.
Kopieren&Registrieren | Die Datei wird auf das entfernte Gerät kopiert und dort in die Registry eingetragen. Tipp: Hilfreich für ActiveX Elemente und für Schriften (ttf-Dateien).
Kopieren&Ausführen | Die Datei wird auf das entfernte Gerät kopiert und dort ausgeführt.


Runtime änderbare Dateien

Handbuch -> Remote-Transport -> Projektieren im Editor -> Runtime änderbare Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon gib es eine Reihe von Daten, die sowohl im Editor als auch in der Runtime geändert werden können. Es sind dies Dateien für:

  • Rezeptgruppen-Manager
  • Standard-Rezepte
  • Benutzerverwaltung
  • Scheduler

Runtime-Dateien vor überschreiben schützen

Erzeugt bzw. überträgt man alle Runtime Dateien neu, so würden die in der Runtime geänderten Dateien überschrieben werden. Um ein ungewolltes Überschreiben zu verhindern, kann hier unter Nicht neu erzeugen und übertragen ausgewählt werden, welche Dateien nicht neu erzeugt bzw. übertragen werden sollten.

Editor-Dateien vor überschreiben schützen

In der Runtime geänderte Daten können wieder zurück gelesen werden. Dabei werden die entsprechenden Editor Daten überschrieben. Um ein ungewolltes Überschreiben zu verhindern kann hier unter Nicht dekompillieren ausgewählt werden, welche Dateien nicht zurück gelesen werden sollten.

Dialog RT änderbare Dateien

Den Dialog zur Konfiguration der Runtime änderbaren Dateien erreichen Sie über die Projekteigenschaften Allgemein/RT änderbare Daten:

Interne ID: Runtime änderbare Dateien

RT änderbare Daten

Der Konfigurationsdialog für die Runtime änderbaren Daten wird geöffnet.
Standard-Rezepte, Rezeptgruppen-Manager, Scheduler oder Production and Facility Scheduler und Benutzerverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Runtime änderbare Dateien

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Folgende Dateitypen sind auswählbar:

Parameter | Beschreibung
Rezeptgruppen-Manager | Rezeptgruppen und Rezepte des Rezeptgruppen-Managers. Bei der Übertragung werden neue Dateien übertragen und neue Unterordner angelegt, gelöschte Dateien und Unterordner auch auf dem Zielsystem gelöscht.
Standard-Rezepte | Standard-Rezepte.
Benutzerverwaltung | Benutzerverwaltung für Login und Rechteverwaltung zur Runtime.
Scheduler | Änderungen in den Zeitmodellen und Fahrplänen des PFS.

attention Achtung

Achten Sie bei der Projektkonvertierung darauf, Runtime änderbare Dateien ebenfalls zu konvertieren. Runtime-Dateien müssen dazu in die Ausgangsversion des Editors importiert werden und nach dem Update wieder in die Runtime zurückgespielt werden. Details siehe Kapitel Empfohlene Vorgangsweise Runtime-Dateien konvertieren im Handbuch Projektkonvertierung.

Übertragung der Dateien

Zur Runtime

Um Dateien zur Runtime zu übertragen können:

  1. alle Dateien übertragen werden
  2. nur geänderte Dateien übertragen werden

Beide Wege berücksichtigen die in RT änderbare Daten definierten Dateien.

Von der Runtime

Um Dateien von der Runtime einzulesen, stehen zwei Verfahren zur Verfügung:

  1. Alle Runtime-Dateien zurücklesen:
    1. liest alle Runtime-Dateien in den Ordner, der in der Eigenschaft Runtime-Ordner definiert wurde, ein

      Interne ID: Runtime änderbare Dateien

      Runtime-Ordner

      Verzeichnis für die Runtime-Dateien des Projekts.
      In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
      Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

      Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    2. unabhängig von den Einstellungen der Eigenschaft RT änderbare Daten
  2. Runtime-Dateien importieren:
    1. importiert die in der Eigenschaft RT änderbare Daten definierten Dateien und
    2. ersetzt die Projektierung im Editor durch diese Runtime-Dateien
    3. eignet sich, um Daten von einem Remote-System in den Editor zu übernehmen

Verbindungsfehler

Bei der Übertragung werden vorhandene Dateien entsprechend den Einstellungen überschrieben.

Treten bei der Übertragung von der oder zur Runtime Fehler auf oder reißt die Verbindung ab, müssen die Dateien komplett neu übertragen werden.


Windows CE

Handbuch -> Remote-Transport -> Projektieren im Editor -> Windows CE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Übertragung auf Windows CE-Systeme kann direkt erfolgen oder über Speicherkarten.

Konfiguration

  1. Stellen Sie sicher, dass in den Projekteigenschaften im Knoten Allgemein die Eigenschaft Windows CE Projekt aktiviert wurde.

    Interne ID: Windows CE

    Windows CE Projekt

    Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
    Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

    Interne ID: Windows CE

    RGM Datenablage

    Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
    MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
    Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

    Default: Binäre Dateien (CE kompatibel)

    Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
    Default: inaktiv

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Windows CE

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Der Konfigurationsdialog enthält nun neue Einträge, als Zielverzeichnis ist C:\Storage Card\Data voreingestellt.

Übertragung per Speicherkarte

Der Remote-Transport unterstützt eine spezielle Transportart, mit der das Projekt anstelle mit einer seriellen oder TCP/IP Verbindung direkt auf die Speicherkarte transportiert wird. Dazu ist ein Rechner notwendig, der die Speicherkarte (PCMCIA, ATA Karte, Compact Flash usw...) aufnehmen kann.

attention Achtung

Es muss sichergestellt sein, dass die CE Runtime und die zenon6.ini sich im Stammverzeichnis (Root) der Karte befinden!

Stecken Sie die Karte in den entsprechenden Schacht, und achten Sie darauf als welches Laufwerk das Betriebsystem die Karte verbindet. (D:, oder E:, ...)
  1. Aktivieren Sie die Checkbox Lokales Kartenlesegerät verwenden.
  2. Definieren Sie den Runtimeordner am Zielgerät.

    Beispiel: wird die Speicherkarte unter CE als \Storage Card angezeigt, dann muss als Runtimeordner am Zielgerät C:\Storage Card\Projektpfad angegeben werden! Das C:\ wird vom Remote-Transport dann automatisch entfernt.

  3. Bauen Sie eine Verbindung zum eigenen PC auf und übertragen Sie die Dateien auf die lokale Speicherkarte.
  4. Schreiben Sie den Runtimeordner am Zielgerät mit der Funktion Remote Startprojekt setzen (Symbolleiste Remote-Transport) in die zenon6.ini auf der Speicherkarte.
  5. Stecken Sie die Speicherkarte in das CE Terminal und starten Sie die Runtime.


Verbindung aufbauen

Handbuch -> Remote-Transport -> Verbindung aufbauen

Um eine Remote Verbindung aufzubauen:

  1. klicken Sie auf die entsprechende Schaltfläche in der Symbolleiste Remote-Transport

    oder wählen Sie im Kontextmenü des Projekts: Remote-Transport -> Verbindung aufbauen

  2. der Dialog für den Verbindungsaufbau wird geöffnet

Parameter | Beschreibung
Verbindungspasswort | Einstellungen für Passwort der Remote Verbindung.
Passwort | Eingabe des Passworts für den Verbindungsaufbau (optional).
Verbindungspasswort ändern | Öffnet den Dialog zu Änderung des Passworts.
Konfiguration des Zielsystems | Einstellungen für Zielsystem.
Seriennummer und Aktivierungsnummer konfigurieren | Aktiv: Die Lizenzierung des Remote-Rechners wird nach Herstellung der Verbindung angezeigt und kann geändert werden.
Verschlüsselung der Netzwerkommunikation konfigurieren | Aktiv: Nach Verbindungsherstellung kann die Verschlüsselung der Netzwerkkommuniaktion am Zielsystem aktiviert oder deaktiviert werden. Hinweis: Die Verbindung des Remote Transport muss dafür mit einem Passwort geschützt sein.
Diesen Dialog nicht mehr anzeigen | Aktiv: Dieser Dialog wird beim Verbindungsaufbau nicht mehr geöffnet. Hinweis: Um den Dialog wieder anzuzeigen, wählen Sie im Kontextmenü des Projekts Remote-Transport -> Passwort ändern u. Lizenzierung anzeigen
OK | Übernimmt Einstellungen und baut Verbindung auf.
Abbrechen | Verwirft Änderungen und schließt den Dialog, ohne eine Verbindung aufzubauen.
Hilfe | Öffnet Online-Hilfe.

Noch in diesem Kapitel

Verbindungspasswort ändern

Verschlüsselung der Netzwerkverbindung konfigurieren


Verbindungspasswort ändern

Handbuch -> Remote-Transport -> Verbindung aufbauen -> Verbindungspasswort ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um das Verbindungspasswort zu ändern:

  1. wählen Sie im Kontextmenü des Projekts Remote-Transport -> Verbindung aufbauen oder Passwort ändern u. Lizenzierung anzeigen
  2. klicken Sie im Dialog auf die Schaltfläche Verbindungspasswort ändern
  3. der Dialog zur Passwortänderung wird geöffnet

Parameter | Beschreibung
altes Passwort | Bestehendes Passwort eingeben.
neues Passwort | Neues Passwort eingeben.
Passwort bestätigen | Neues Passwort noch einmal eingeben und damit bestätigen.


Verschlüsselung der Netzwerkverbindung konfigurieren

Handbuch -> Remote-Transport -> Verbindung aufbauen -> Verschlüsselung der Netzwerkverbindung konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Netzwerkkommunikation kann mit einer starken Verschlüsselung geschützt werden. Die Verschlüsselung wird entweder lokal über das zenon Startup Tool aktiviert, direkt am zenon Webclient oder per Remote Transport im Dialog Verbindung aufbauen:

Parameter | Beschreibung
Lokale Konfiguration einlesen | Liest die die Verschlüsselungsparameter des lokalen Rechners ein.
Netzwerkkommunikation verschlüsseln | Aktiv: AM Remote-Rechner wird die Verschlüsselung des Netzwerks aktiviert.
Passwort | Passwort eintragen. Kriterien siehe Abschnitt "Passwort Netzwerkverschlüsselung" im Kapitel "Starke Verschlüsselung der Netzwerkkommunikation". Die angezeigte Länge wird immer auf 20 Zeichen gesetzt, um die tatsächliche Länge zu verbergen.
Passwort bestätigen | Passwort zur Bestätigung erneut eingeben.
OK | Speichert Änderungen und schließt Dialog.
Abbrechen | Verwirft Änderungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe

Das hier konfigurierte Passwort wird verschlüsselt in der zenon6.ini des Remote-Rechners abgelegt.

info Info

Hinweise zu Fehlermeldungen der starken Verschlüsselung finden Sie im:

Handbuch Netzwerk -> Kapitel Starke Verschlüsselung der Netzwerkkommunikation -> Abschnitt Fehlermeldungen.


Reporting

Handbuch -> Reporting

Das in zenon integrierte Reporting dient zur Dokumentation, Auswertung und Präsentation von Prozessdaten auf Basis von Online- und Archivdaten aus zenon. Das Reporting unterteilt sich in:

  • Report Generator
  • Report Viewer

Beide Reporting Varianten sind nicht unter Windows CE verfügbar.

tutorial Lizenzinformation
  • Im Editor: Beide lizenzpflichtig.
  • In der Runtime:
    Report Viewer: In der Runtime immer im Standardumfang enthalten.
    Report Generator: Zur reinen Darstellung von Reports im Standardumfang integriert. Sollen mit dem Report Generator Archivwerte bzw. Sollwerte geschrieben werden, ist auch in der Runtime eine Lizenz erforderlich.

Für umfassendes, plattformunabhängiges Reporting von der Prozessebene bis zum ERP steht der zenon Analyzer zur Verfügung. Ihr COPA-DATA Vertriebspartner informiert Sie gerne.

Noch in diesem Kapitel

Report Generator

Report Viewer


Report Generator

Handbuch -> Reporting -> Report Generator

Der Report Generator dient zur Dokumentation, Auswertung und Präsentation von Prozessdaten auf Basis von Online- und Archivdaten. Der Report Generator arbeitet zellenorientiert. Jeder Zelle können bestimmte Funktionen und Formate zugewiesen werden.

Reporte werden über den Bildtyp Report projektiert. Die Filterung, Berechnung, Ausgabe und Darstellung der Daten erfolgt über Reportfunktionen. Diese werden über Dialoge oder händisch eingetragen. Werte können gelesen und - sofern im Bild zugelassen - auch editiert werden. Der Report Generator erfüllt die Anforderungen von Regelblatt 13 und ATV H260.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Report neu | Legt einen neuen Report in der Liste der Detailansicht an.
Bestehenden Report importieren... | Öffnet den Dateimanager zur Auswahl einer bestehenden Report-Datei.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

info Info

Die Status-Bits NORM und N_NORM werden im Report nicht angezeigt, bzw. kann der Status NORM nicht über den Report geändert werden.

Noch in diesem Kapitel

Projektieren im Editor

Bedienen zur Runtime

Beispiel Archivdaten in Reports


Projektieren im Editor

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Reports zur Runtime einsetzen zu können, muss im Editor:

  • ein Bild vom Typ Report angelegt werden
  • ein Report angelegt und konfiguriert werden
  • eine Umschaltfunktion zur Runtime projektiert werden

Empfohlener Ablauf der Projektierung des Reports:

  • Report anlegen
  • Report formatieren
  • Archivfilter anlegen
  • Reportfunktionen projektieren

Noch in diesem Kapitel

Bild vom Typ Report Generator anlegen

Neuen Report anlegen

Druckereinstellungen

Datei Info

Suchen und ersetzen im Report

Formatierungen

Archivfilter einrichten

Reportfunktionen

zenon Funktionen für Report Generator


Bild vom Typ Report Generator anlegen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Bild vom Typ Report Generator anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Bild vom Typ Report werden die mit dem Report Generator erstellten Reporte zur Runtime angezeigt und bei entsprechenden Rechten konfiguriert. Die Darstellungsgröße hängt von der gewählten Schablonengröße ab. Welcher Report angezeigt wird, kann bei der Bildumschaltung festgelegt oder zur Runtime ausgewählt werden.

Um ein Bild vom Typ Report anzulegen:

  1. wählen Sie im Knoten Bilder im Kontextmenü den Befehl Bild neu
  2. wählen Sie in der Spalte Bildtyp in der Dropdownliste Report aus
  3. wählen Sie in der Menüleiste Kontrollelemente -> Vorlage einfügen
  4. ein Report mit Standardeinstellungen wird erstellt
  5. fügen Sie bei Bedarf weitere Kontrollelemente aus dem Menü Kontrollelemente hinzu
  6. erstellen Sie eine Bildumschaltung, um das Bild zur Runtime aufzuschalten

Parameter

Beschreibung

Vorlage einfügen...

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Buttons

Buttons zur Steuerung zur Runtime.

Refresh

Report vollständig neu aufbauen (Werte und Darstellung).

Drucken

Report zur Runtime ausdrucken.

Datei

Reportdatei auswählen und Filterbedingungen ändern.

Exportieren

Report exportieren.

Archiv speichern

Geänderte Werte ins Archiv zurückspeichern.

Report speichern

Report wird zur Runtime gespeichert (*.xrs).

Achtung: Beim Speichern werden Formeln und Funktionen durch die aktuellen Werte ersetzt. Die Funktionen stehen in diesen Reports (.xrs Dateien) nicht mehr zur Verfügung. Diese Reports können im Editor auch nicht mehr bearbeitet werden.

Empfehlung: Setzen Sie original Reportdateien auf den Dateistatus "schreibgeschützt" und speichern Sie Änderungen mit Speichern unter in einer neuen Datei.

Report speichern unter

Report wird zur Runtime unter einem neuen Namen gespeichert (*.xrs), wobei die Formeln und Funktionen durch die aktuellen Werte ersetzt werden.

Alle Werte lesen

Alle Werte werden vom Treiber neu eingelesen.

Selektierte Werte lesen

Ausgewählte Werte werden vom Treiber neu eingelesen.

Alle Werte absetzen

Alle Werte werden zum Treiber abgesetzt.

Selektierte Werte absetzen

Ausgewählte Werte werden zum Treiber abgesetzt.

Zeile nach oben

eine Zeile nach oben blättern

Zeile nach unten

eine Zeile nach unten blättern

Spalte nach rechts

eine Spalte nach rechts blättern

Spalte nach links

eine Spalte nach links blättern

Seite nach oben

eine Seite nach oben blättern

Seite nach unten

eine Seite nach unten blättern

Seite nach rechts

eine Seite nach rechts blättern

Seite nach links

eine Seite nach links blättern

Report

Kontrollelement für Reportdarstellung.

Report

Reportfenster zur Darstellung des Reports.

Filterprofile

Buttons für Filterprofile.

Profilauswahl

Anzeige der verfügbaren Filterprofile und Eingabe für neue Profilnamen.

Speichern

Speichert aktuelle Einstellung als Profil.

X (Speichern)

Löscht ausgewähltes Profil.

Import

Exportiert Profile.

Export

Importiert Profile.


Neuen Report anlegen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bevor ein neuer Report angelegt wird, sollte der Reportdrucker definiert werden, da die Seitenformatierung eines Reports vom eingestellten Drucker abhängig ist. Eine nachträgliche Änderung des Druckers kann eine Neuformatierung des bestehenden Reports notwendig machen.

Um einen neuen Report anzulegen:

  • navigieren Sie im Projektmanager zum Knoten Report Generator
  • wählen Sie im Kontextmenü den Befehl Report neu
  • ein neuer Report wird in der Detailansicht angelegt
  • im Hauptfenster wird ein leeres Tabellenblatt geöffnet

Funktionalitäten des Tabellenblattes:

  • Zuordnung von Prozessinformationen über Reportfunktionen
  • formatierte Darstellung von Inhalten von Zellen, Spalten und Zeilen
  • Zwischensummen
  • Zuweisung von Editiersperren

info Info

Bei der Eingabe in Zellen gilt: Ein Dezimalwert kann sowohl mit Komma als auch mit Punkt getrennt werden. Das Dezimalzeichen wird immer automatisch in einen Punkt umgewandelt.

seealso Siehe auch

Seite einrichten
Druckereinstellungen
Formatierungen
Reportfunktionen

Noch in diesem Kapitel

Menü Report

Menü Bearbeiten

Menü Format

Symbolleiste Report Generator

Kontextmenü und Symbolleiste Detailansicht

Aufbau Tabellenfenster

Kontextmenü Datenblatt


Menü Report

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen -> Menü Report

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Auswahl eines Reports wird in der Menüzeile das Menü Report eingeblendet:

Parameter

Beschreibung

Report speichern

Speichert alle Änderungen im aktiven Report. Änderungen in anderen Reporten werden nicht gespeichert.

Reportfunktionen exportieren

Exportiert alle Reportfunktionen des aktiven Reports in eine Textdatei.

Aufbau: Spalte / Zeile =Funktion(Parameter)

Report neu zeichnen

Zeichnet Report neu.

Report berechnen

Berechnet Report neu.

Seite einrichten

Öffnet den Dialog zum Einrichten der Druckseite.

Report drucken

Druckt den Report auf dem in den Standardeinstellungen für das Projekt definierten Drucker aus..

Druckbereich

Legt Druckbereiche fest oder hebt sie auf:

  • Druckbereich festlegen: definiert markierten Bereich der Tabelle als Druckbereich.
  • Druckbereich aufheben: hebt definierten Druckbereich wieder auf

Report Seitenansicht

Schaltet von Layoutansicht auf Seitenansicht um. Mit der linken Maustaste kann die Ansicht gezoomt werden.

Verlassen der Seitenansicht: Taste Esc drücken.

Reportdatei-Info

Öffnet Dialog zur Verwaltung der Informationen der Reportdatei.


Menü Bearbeiten

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen -> Menü Bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Auswahl eines Reports, stellt das Menü Bearbeiten spezielle Funktionen für Reporte zur Verfügung:

Befehl

Beschreibung

Ausschneiden

Schneidet markierten Bereich aus und kopiert ihn in Zwischenspeicher.

Kopieren

Fügt Inhalt des Zwischenspeichers ein.

Einfügen

Kopiert markierten Bereich in Zwischenspeicher.

Einfügen erweitert

Stellt erweiterte Einfügeoptionen für Zelloperationen zur Verfügung:
  • Alles

Fügt alles aus dem Zwischenspeicher ein.
  • Formeln

Fügt nur Formeln ein
  • Wert

Fügt nur Werte ein. Der Bezug zu Formeln geht verloren.
  • Format

Übernimmt nur das Format.

Füllen

Kopiert Inhalt der ersten Zelle einer Markierung und überträgt ihn auf alle weiteren markierten Zellen.

  • nach unten

Die Füllung erfolgt nach unten.
  • nach rechts

Die Füllung erfolgt nach rechts.

Entfernen

Entfernt aus markierten Zellen:
  • Alles

Alles.
  • Inhalt

Nur Inhalte.
  • Format

Nur Formate.

Spalte/Zeile löschen

Löscht markierte Spalten bzw. Zeilen.

Spalte/Zeile einfügen

Fügt neue Spalten bzw. Zeilen ein. Die Einfügung erfolgt über der Zeile oder links der Spalte. Es werden so viele Zeilen/Spalten eingefügt, wie im Tabellenblatt markiert sind.

Suchen/ersetzen

Öffnet den Dialog zum Suchen und Ersetzen im Tabellenblatt.


Menü Format

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen -> Menü Format

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Menü Format stellt Eigenschaften und Funktionen zur Formatierung der Reporttabelle zur Verfügung:

Parameter

Beschreibung

Zellen

Formatierungsoptionen für Zellen:

  • Schriftart
  • Muster
  • Rahmen
  • Ausrichtung
  • Zahlen
  • Listen

Zeile

Formatierungsoptionen für Zeilen:

  • Zeilenhöhe: öffnet Dialog für Definition der Zeilenhöhe
  • Zeilenformat: öffnet Dialog für alle Eigenschaften der Zeile

Spalte

Formatierungsoptionen für Spalten:

  • Spaltenbreite: öffnet Dialog für Definition der Spaltenbreite
  • Spaltenformat: öffnet Dialog für alle Eigenschaften der Spalte

Report

Öffnet Dialog für die Formatierung des Reports.

Funktionsassistent

Öffnet Assistent für die Erstellung von Reportfunktionen.

Filter

Öffnet Reportfilter zur Auswahl von Archiven.


Symbolleiste Report Generator

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen -> Symbolleiste Report Generator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Report Generator steht im Editor eine Symbolleiste zur Verfügung. Sofern sie noch nicht sichtbar ist, wird sie aufgeschaltet durch:

  1. öffnen Sie das Menü Optionen -> Einstellungen -> Registerkarte: Symbolleiste
  2. aktivieren Sie die Checkbox neben Report Generator
  3. bestätigen Sie mit OK

Symbol (von links nach rechts) | Funktion
Report drucken | Druckt den Report am Standarddrucker aus.
Seitenansicht Report | Öffnet den Report in einer Voransicht. Der Report kann in der Voransicht vergößert oder verkleinert dargestellt werden (Zoom), man kann ihn durchblättern und drucken.
Report neu zeichnen | Aktualisiert die Ansicht.
Funktionen neu berechnen | Berechnet die Formeln im Report neu.
Funktionsassistent | Öffnet einen Dialog, der bei der Konfiguration der Funktionen unterstützt.
Schriftart | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Schriftart.
Textausrichtung | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Ausrichtung.
Rahmen | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Rahmen.
Muster | Öffnet den Dialog zur Zellenformatierung mit Fokus auf den Reiter Muster.
Symbolleistenoptionen | Klick auf Pfeil öffnet Submenü: Aktiv: Symbolleiste wird angezeigt. Wird die Symbolleiste nicht angezeigt, kann sie über das Menü Optionen -> Symbolleisten aktiviert werden.


Kontextmenü und Symbolleiste Detailansicht

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen -> Kontextmenü und Symbolleiste Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Menüpunkt | Aktion
Report neu | Legt einen neuen Report in der Liste der Detailansicht an.
Report öffnen | Öffnet den ausgewählten Report oder legt den Fokus darauf, wenn er bereits geöffnet ist.
Standard-Funktion erzeugen | Erstellt eine zenon Funktion für den Report Generator. Die Aktion wird im Ausgabefenster dokumentiert.
Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Bestehenden Report importieren... | Öffnet den Dateimanager zur Auswahl einer bestehenden Report-Datei.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.


Aufbau Tabellenfenster

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen -> Aufbau Tabellenfenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Reporte werden beim Editieren im Editor im Hauptfenster zweigeteilt angezeigt:

  • der linke Bereich enthält die Tabelle für den Entwurf
  • der rechte Teil zeigt eine Vorschau auf die Ausgabe

Die größe der beiden Bereiche kann individuell geändert werden. Bewegen Sie dazu die Maus an den rechten Rand der Bildlaufleiste der Tabelle bis sich der Mauszeiger in eine Verschiebewerkzeug wandelt und verschieben Sie die Bildlaufleiste an die gewünschte Position.

Eingabezeile

Die Tabelle enthält am oberen Rand eine Eingabezeile. Wurde in den Eigenschaften des Reports die Eigenschaft Editieren in der Zelle aktiviert, wird diese Zeile nicht angezeigt. Eingaben müssen dann direkt in der Zelle vorgenommen werden.


Kontextmenü Datenblatt

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Neuen Report anlegen -> Kontextmenü Datenblatt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Menüpunkt

Aktion

Ausschneiden

Löscht markierte Einträge und legt sie in der Zwischenablage ab.

Kopieren

Kopiert ausgewählte Einträge in die Zwischenablage.

Einfügen

Fügt den Inhalt der Zwischenablage ein.

Einfügen erweitern

Ermöglicht Auswahl des einzufügenden Inhalts der Zwischenablage:

  • Alles: übernimmt kompletten Inhalt
  • Formeln: übernimmt nur Formeln
  • Wert: übernimmt nur Wert
  • Format: übernimmt nur Format

Füllen

Kopiert Inhalt der ersten Zelle einer Markierung und überträgt ihn auf alle weiteren markierten Zellen. Die Füllung kann wahlweise nach unten oder nach rechts erfolgen.

Entfernen

Ermöglicht Auswahl des zu löschenden Inhalts einer Zelle:

  • Alles: löscht den gesamten Inhalt mit Format
  • Inhalt: entfernt den Inhalt, belässt aber das Format
  • Format: löscht nur das Format, belässt aber den Inhalt

Spalte Zeile einfügen

Fügt oberhalb einer markierten Zeile eine neue Zeile bzw. links einer markierten Spalte eine neue Spalte ein. Werden mehrere Zeilen/Spalten markiert, wird die Anzahl der markierten Zeilen/Spalten neu eingefügt.

Spalte Zeile löschen

Löscht die markierten Zeilen bzw. Spalten

Report...

Öffnet den Dialog für die Formatierung des Reports.

Zelle...

Öffnet den Dialog für die Formatierung einer Zelle.

Spalte...

Öffnet den Dialog für die Formatierung der Spalten.

Zeile...

Öffnet den Dialog für die Formatierung der Zeilen.

Funktionen...

Öffnet den Assistenten für die Erstellung von Reportfunktionen.

Hinweis: Der Assistent bietet eine Auswahl der über 150 Funktionen an. Weitere Funktionen können händisch in die Eingabezeile des Datenblattes eingegeben werden.


Druckereinstellungen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Druckereinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Reportlayout (Seitenränder, Seitengröße) hängt ab vom konfigurierten Drucker. Die Einstellungen für den Reportdrucker ereichen Sie über Datei -> Allgemeine Konfiguration -> Standard -> Drucker für auszugebende Werte und Protokolle.

Hier definieren Sie

  • den Drucker und
    • Papierformat des Drucks
    • Papierquelle des Druckers
    • Ausrichtung des Drucks

attention Achtung

Der gewünschte Drucker muss vor der Reporterstellung ausgewählt werden, da die Seitenformatierung eines Reports von dem eingestellten Drucker abhängt. Die nachträgliche Änderung des Druckers kann eine Neuformatierung des bestehenden Reports notwendig machen.

Druckerkonfiguration

Parameter

Beschreibung

Drucker

Einstellungen für den Drucker.

Name:

Auswahl des Druckers aus Dropdownliste. Liste enthält alle im Betriebssystem konfigurierten Drucker.

Eigenschaften...

Öffnet Dialog zur Konfiguration des gewählten Druckers.

Status:

Anzeige Druckerstatus. Nur Information.

Typ:

Anzeige Druckertyp. Nur Information

Standort:

Anzeige Standort des Druckers, falls konfiguriert. Nur Information.

Kommentar:

Anzeige Kommentar zum Drucker, falls konfiguriert. Nur Information.

Papier

Konfiguration des Ausdrucks.

Größe

Auswahl Papierformat aus Dropdownliste.

Quelle

Wahl der Papierzufuhr aus Dropdownliste.

Ausrichtung

Wahl der Papierausrichtung. Mögliche Parmeter:

  • Hochformat
  • Querformat

Netzwerk

Öffnet Dialog zur AUswahl eines Druckers im Netzwerk.

OK

Übernimmt Konfiguration und schließt Dialog. Zur Runtime wird damit der Druck gestartet.

Abbrechen

Verwirft Konfiguration und schließt Dialog. Zur Runtime wird damit auch der Ausdruck abgebrochen.


Datei Info

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Datei Info

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Dialog Report -> Reportdatei-Info können Informationen zur jeweiligen Reportdatei gespeichert werden.

Parameter | Beschreibung
Dateiname | Name der Reportdatei. Nur Information, hier nicht änderbar. Kann in der Detailansicht geändert werden.
Ordner | Speicherort der Reportdatei. Nur Information, hier nicht änderbar.
Titel | Freie Texteingabe
Thema | Freie Texteingabe
Autor | Freie Texteingabe
Kommentar | Freie Texteingabe


Suchen und ersetzen im Report

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Suchen und ersetzen im Report

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um im Tabellenblatt nach Formeln, Zeichenfolgen oder Werten zu suchen und diese zu ersetzen:

  1. aktivieren Sie den gewünschten Report
  2. wählen Sie im Menü Bearbeiten den Befehl Suchen/ersetzen
  3. der Dialog zum Suchen und Ersetzen wird geöffnet

Parameter

Beschreibung

Begriffe eingeben

Einagbe der Zeichenfolgen für suchen und ersetzen.

Suchen nach

Zeichenfolge nach der gesucht wird.

Ersetzen durch

Zeichenfolge, die die gefundene ersetzt.

Ersetzen

Ersetzt aktuell angezeigte Fundstelle durch Zeichenfolge aus Ersetzen durch.

Alle ersetzen

Ersetzt alle Fundstellen durch Zeichenfolge aus Ersetzen durch.

Weitersuchen

Sucht nächstes Vorkommen der gesuchten Zeichenfolge.

Suchoptionen

Optionen für Suche

Suchen in

Auswahl aus Dropdownliste:

  • Formeln: sucht in Formeln
  • String: sucht in Zeichenfolgen
  • Wert: sucht in Werten

Suche Teilstring

Sucht auch in Teilbereichen von Zellen.

Groß-/Kleinschreibung beachten

Beachtet Groß- und Kleinschreibung bei Suche.

Schließen

Schließt Dialog.

Hilfe

Öffnet Online-Hilfe


Formatierungen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Formatierungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vor der Erstellung eines Reports sollten die nötigen Formatierungen durchgeführt werden:

  • Seite: Druckeigenschaften für Seite einrichten
  • Report: Reporteigenschaften einrichten
  • Zelle: Formatierung der Zellen festlegen (Ausrichtung, Rahmen, Schriftart, Muster, Typ, Listen)
  • Spalten und Zeilen: Formatierungen für ausgewählte Spalten oder Zeilen

Die Einstellungen erreichen Sie über die Dropdownlisten Report und Format in der Menüzeile oder über das Kontextmenü des Tabellenblattes.

Tipp: Achten Sie darauf, bei Reporten mit großen Datenmengen genügend Zeilen/Spalten für die Ausgabe vorzusehen.

Noch in diesem Kapitel

Seite einrichten

Report formatieren

Zelle formatieren

Spalten und Zeilen formatieren


Seite einrichten

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Formatierungen -> Seite einrichten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Befehl Seite einrichten... im Menü Report öffnet den Dialog zur Konfiguration der Report-Seite. Dieser enthält die beiden Registerkarten:

  • Ränder
  • Kopfzeile und Fußzeile

Noch in diesem Kapitel

Ränder

Kopfzeile und Fußzeile


Ränder

Ränder

Parameter | Beschreibung
Seitenränder einstellen | Druckrand unabhängig von der Druckereinstellung festlegen
oben | Abstand des Reports zum oberen Rand.
unten | Abstand des Reports zum unteren Rand.
links | Abstand des Reports zum linken Rand.
rechts | Abstand des Reports zum rechten Rand.
Kopfzeile | Abstand der Kopfzeile zum Text. Mögliche Werte: 0 bis 20; 0 = ausgeblendet. Der Wert muss groß genug gewählt, um die unter Kopfzeile und Fußzeile ausgewählte Schriftgröße darstellen zu können.
Fußzeile | Abstand der Fußzeile zum Text. Mögliche Werte: 0 bis 20; 0 = ausgeblendet. Der Wert muss groß genug gewählt, um die unter Kopfzeile und Fußzeile ausgewählte Schriftgröße darstellen zu können.
Allgemein |
Druckbereich | Legt den Druckbereich ausgehend von der Zelle A1 fest. Eingabe in das Textfeld: Koordinaten des Endwerts des Bereichs. Beispiel: D5 legt den Druckbereich auf die Zellen A1 bis D5 fest.
Drucker | Auswahl des Druckers für den Report. Klick auf Dropdownliste öffnet Liste aller in der zenon Druckereinstellung definierten Drucker. Default: Werte und Protokolle
Druckbereich auf Drucker anpassen | Aktiv: Der Druckbereich des Reports wird an die Einstellungen des ausgewählten Druckers angepasst.
Statische Zeilen Spalten drucken | Aktiv: Statische Zeilen und Spalten werden mitgedruckt.
Zentrierung | Ausrichtung des Reports auf der Druckseite
vertikal | Zentriert den Report vertikal.
horizontal | Zentriert den Report horizontal.
Ausrichtung | Einstellung des Seitenformates
Hochformat | Druckt im Hochformat.
Querformat | Druckt im Querformat.
Druckrichtung | Reihenfolge des Seitenausdrucks bei mehreren Seiten
Von links nach rechts | Ausdruck mehrere Seiten von links nach rechts.
Von oben nach unten | Ausdruck mehrerer Seiten von oben nach unten.


Kopfzeile und Fußzeile

Kopfzeile und Fußzeile

Parameter | Beschreibung
Kopfzeile | Definition des Kopfzeilen-Bereichs
Linker Abschnitt | Linksbündiger Text für das linke Drittel der Kopfzeile.
Mittlerer Abschnitt | Zentrierter Text für die Mitte der Kopfzeile.
Rechter Abschnitt | Rechtsbündiger Text für das rechte Drittel der Kopfzeile.
Schriftart | Öffnet Dialog für Auswahl von Schriftart, Schriftgröße und Schriftauszeichnung des Fußzeilen-Textes.
Fußzeile | Definition des Fußzeilen-Bereichs
Linker Abschnitt | Linksbündiger Text für das linke Drittel der Fußzeile
Mittlerer Abschnitt | Zentrierter Text für die Mitte der Fußzeile.
Rechter Abschnitt | Rechtsbündiger Text für das rechte Drittel der Fußzeile
Schriftart | Öffnet Dialog für Auswahl von Schriftart, Schriftgröße und Schriftauszeichnung des Fußzeilen-Textes. Achten Sie darauf, dass die Einstellungen für Kopf-/Fußzeile in Ränder so gewählt werden, dass die Schriftgröße vollständig dargestellt werden kann.
Schlüsselwörter | Schlüsselwörter für die Kopf- und Fußzeilen
&[Page] | Seitennummer
&[Pages] | Gesamtzahl der Seiten
&[Date] | Aktuelles Druckdatum
&[Time] | Aktuelle Druckzeit
&[File] | Dateiname


Report formatieren

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Formatierungen -> Report formatieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Formatierung des gesamten Reports stehen Einstellungen zur Verfügung für:

  • Allgemein: allgemeine Einstellungen für den Report
  • Spalten: allgemeines Einstellungen für Spalten wie Anzahl etc.
  • Zeilen: allgemeines Einstellungen für Zeilen wie Anzahl etc.

Zur Formatierung wählen Sie entweder den Befehl Report im Menü Format oder im Kontextmenü des Reportblattes den Befehl Report formatieren.

Noch in diesem Kapitel

Allgemein

Spalten

Zeilen


Allgemein

Allgemein

Parameter | Beschreibung
Überschrift | Reportüberschrift
Auswahl | Legt Auswahlverhalten bei Klick fest.
ganze Zeile | Aktiv: Die gesamte Zeile wird ausgewählt.
eine Zelle | Aktiv: Nur die angeklickte Zelle wird ausgewählt; Mehrfachauswahl von Zellen ist nicht möglich.
Optionen |
Automatische Berechnung | Aktiv: Berechnungen werden bei Änderung der Eingangsgrößen automatisch aktualisiert.
Raster anzeigen | Aktiv: Zeigt Gitternetzlinien im Editor an.
Editieren in der Zelle | Aktiv: Eingaben erfolgen direkt in die Zelle, die Eingabezeile im Reportfenster wird ausgeblendet.
Klick Referenz | Aktiv: Die angeklickte Zelle wird in der Eingabezeile bei Eingabe von Formeln als Reportkoordinate übernommen. Zum Beispiel: statt A12 einzugeben wir die Zelle A12 angeklickt.


Spalten

Spalten

Parameter | Beschreibung
Spalteneinstellungen |
Anzahl der Spalten | Definiert maximale Anzahl an Spalten. Gültiger Wert: 0 bis 31000.
Statische Spalten | Anzahl der Spalten, die immer angezeigt werden. Scrollen erfolgt erst nach den statischen Spalten.
Anzeigen der Buttons in der ersten Spalte | Aktiv: Blendet Zeilennummern ein.
Aktivieren der Spaltenformatierung | Aktiv: Spaltenbreite kann mit der Maus durch Ziehen der Ränder der Kopfzeile angepasst werden.


Zeilen

Zeilen

Projektierbare Eigenschaften der Zeilen sind:

Parameter | Beschreibung
Anzahl der Zeilen | Definiert maximale Anzahl an Zeilen. Gültiger Wert: 0 bis 31000.
Statische Zeilen | Anzahl der Zeilen, die immer angezeigt werden. Scrollen erfolgt erst nach den statischen Spalten.
Anzeigen der Buttons in der ersten Zeile | Aktiv: Blendet Spaltenkopf >(A, B, C, ...) ein.
Aktivieren der Zeilenformatierung | Aktiv: Zeilenbreite kann mit der Maus durch Ziehen der Ränder der Zeilennummerierung angepasst werden.


Zelle formatieren

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Formatierungen -> Zelle formatieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Formatierung der Zellen des Reportblattes stehen Einstellungen zur Verfügung für:

Ausrichtung

Rahmen

Schriftart

Muster

Zellentyp

Listen

Zur Formatierung wählen Sie:

  • im Kontextmenü des Reportblattes den Befehl Zelle formatieren, um den Dialog zu öffnen
  • oder das gewünschte Untermenü in Report -> Zellen formatieren, um den Dialog mit der entsprechenden Registerkarte zu öffnen

Noch in diesem Kapitel

Ausrichtung

Rahmen

Schriftart

Muster

Zellentyp

Combobox Listen


Ausrichtung

Ausrichtung

In der Registerkarte Ausrichtung wird die Darstellung von Zellinhalten definiert.

Für die vertikale Positionierung stehen zur Verfügung:

  • Allgemein
  • Oben
  • Mitte
  • Unten
  • Umbruch

Für die horizontale Positionierung stehen zur Verfügung:

  • Allgemein
  • Links
  • Mitte
  • Rechts

info Info

Soll Text vertikal dargestellt werden, wählen Sie in der Registerkarte Schriftart die Eigenschaft vertikal.


Rahmen

Rahmen

In der Registerkarte Rahmen legen Sie fest, ob und in welcher Form ein Rahmen um eine Zelle angezeigt wird. Sie können jede Seite des Rahmens (oben, unten, links, rechts) extra in Art und Farbe definieren:

  1. Legen Sie Art und Farbe fest.
  2. Weisen Sie diese per Klick dem gesamten Rahmen oder einer einzelnen Seite zu.

Parameter | Beschreibung
Rahmenauswahl | Klick in die Mitte aktiviert alle vier Rahmenseiten. Klick auf eine Rahmenseite aktiviert diese.
Linienart | Auswahl der Linienart aus Dropdownliste.
Linienfarbe | Auswahl der Linienfarbe aus Dropdownliste.


Schriftart

Schriftart

Für Schriften stehen die Standardeinstellungen von Windows zur Verfügung.

Parameter | Beschreibung
Schriftart | Auswahl der Schriftart.
Schriftschnitt | Auswahl des Schriftschnittes.
Schriftgrad | Auswahl des Schriftgrades in Punkt.
Effekte |
Durchgestrichen | Aktiv: Text in Zelle wird durchgestrichen dargestellt.
Unterstrichen | Aktiv: Text in Zelle wird unterstrichen.
Farbe | Wird nicht berücksichtigt!! Die Farbe muss bei der Verwendung der Schrift z.B. in einem dynamischen Element eingestellt werden
Skript | Wird nicht berücksichtigt!! Es wird durchgängig Unicode Darstellung verwendet.
Beispiel | Zeigt Auswirkungen der Auswahl auf Text in Zelle an.


Muster

Muster

In der Registerkarte Muster definieren Sie Farbe und Muster der Zelle.

Parameter | Beschreibung
Muster | Auswahl des Zellenmusters aus Dropdownliste.
Vordergrund | Auswahl der Vordergrundfarbe aus Dropdownliste.
Hintergrund | Auswahl der Hintergrundfarbe aus Dropdownliste.


Zellentyp

Zellentyp

In der Registerkarte Zellentyp legen Sie das Ausgabeformat fest. Sie haben die Wahl zwischen:

  • Allgemein: Ausgabe von Werten, Daten und Binärdaten
  • Combobox: Erstellung von Listen
  • Datentyp: Definition von Datentypen
  • Grafikdatei: Einfügen einer Grafik

Die jeweiligen Formatschlüssel werden im Kapitel Formatierungsschlüssel beschrieben.

Allgemein

Parameter

Beschreibung

Formatstrings

Auswahl des Ausgabeformats
  • Wert

Numerische Werte. Details siehe Kapitel Numerische Datentypen.
  • Datum

Datumsangaben. Details siehe Kapitel Datentypen für Datum und Uhrzeit.
  • Zeit

Zeitangaben. Details siehe Kapitel Datentypen für Datum und Uhrzeit.
  • Binärwert

Binärwerte. Details siehe Kapitel Logische Datentypen.

Gesperrt

Aktiv: Sperrt die Zelle für das Editieren im Editor und Einträge im Online-Report.

Example Beispiel

Formatstring für eine Wertausgabe:
*0.00 = beliebiger Wert mit 2 Nachkommastellen

dd/mm/yy hh:mm = 01/01/10 12:30 (entsprechend Einstellungen im Betriebssystem

Combobox

Der Zellentyp Combobox bietet Dropdownlisten zur Auswahl vordefinierter Eingaben an. Bevor dieser Zellentyp verwendet werden kann, muss in der Registerkarte Combobox Listen eine Liste erstellt worden sein.

Parameter

Beschreibung

Combobox Listenname

Name der Listendatei. Diese muss in der Registerkarte Combobox Listen bereits definiert sein.

Drophöhe

Darstellungshöhe

Dropbreite

Darstellungsbreite

Gesperrt

Aktiv: Sperrt die Zelle für das Editieren im Editor und Einträge im Online-Report.

Anzeigemodus

Art der Anzeige
  • mit Text

alphabetisch sortiert nach Text
  • mit Code

sortiert nach Code
  • mit Index

sortiert nach Reihenfolge der Eingabe der Listeneinträge

Datentyp

Mit Datentyp wird eine Eingabe-Vorlage im Report angelegt. Bestehende Funktionen werden aus dieser Zelle entfernt. Der Anwender erhält eine Vorgabe, wie Daten in die Zell einzutragen sind.

Parameter

Beschreibung

Formatstring

Eingabe des Formats, abhängig vom Datentyp.

Datentyp

  • Datum/Zeit

Eingabe eines Datums-/Zeitwerts.

Details Formatstring siehe Kapitel Datentypen für Datum und Uhrzeit.
  • Float

Eingabe eines Floatwerts.

Details Formatstring siehe Kapitel Numerische Datentypen.
  • Integer

Eingabe eines Integerwerts.

Details Formatstring siehe Kapitel Numerische Datentypen.
  • Logisch

Eingabe eines Binärwerts.

Details Formatstring siehe Kapitel Logische Datentypen.

Projektierbar: Ja/Nein; Richtig/Falsch.
  • Text

Eingabe von Text.
  • Unbestimmt

Kein Datentyp festgelegt.

Gesperrt

Aktiv: Sperrt die Zelle für das Editieren im Editor und Einträge im Online-Report.

Grafikdatei

Grafikdateien müssen vor der Auswahl im Projektmanager angelegt worden sein: Knoten Dateien -> Grafiken -> [Kontextmenü] Dateien hinzufügen.

Parameter | Beschreibung
Grafikdatei | Auswahl der Grafikdatei. Unterstützt werden die Formate BMP, JPG, GIF, PNG und WMF.
Originalgröße | Aktiv: Die Grafik wird in Originalgröße angezeigt. Inaktiv: Grafik wird an Größe der Zelle angepasst. Default: inaktiv.
Gesperrt | Aktiv: Sperrt die Zelle für das Editieren im Editor und Einträge im Online-Report.


Combobox Listen

Combobox Listen

In der Registerkarte Combobox Listen werden Listen für den Zellentyp Combobox definert.

Parameter

Beschreibung

Combobox Listen

Dropdownliste zur Auswahl vorhandener Listen.

Neu

Öffnet Dialog zur Erstellung einer neuen Liste.

Löschen

Löscht ausgewählte Liste.

Inhalt der selektierten Liste

Zeigt Inhalte der ausgewählten Liste an

Aktueller Eintrag

Konfiguration des Eintrags.

Text

Eingabe des Textes, wie er zur Runtime in der Liste erscheinen soll.

Code

Eingabe einer Zahl zur Sortierung der Liste.

0: keine Sortierung nach Code. Liste kann zur Runtime wahlweise alphabetisch oder in der Reihenfolge der Eingabe sortiert werden.

Minimalwert: 0

Maximalwert: 9999999999

Anhängen

Der neue Eintrag wird abhängig von den Einstellungen, die bei der Erstellung der Liste gewählt wurden, in Inhalt der selektierten Liste eingefügt.

  • Nicht: Eintrag wird am Ende der Liste eingefügt.
  • Nach Text: Alphabetische Reihenfolge.
  • Nach Codes: Codezahl bestimmt Reihenfolge (aufsteigend) in Liste.

Einfügen

Der neue Eintrag wird oberhalb des in Inhalt der selektierten Liste markierten Eintrags eingefügt.

Löschen

Löscht den in Inhalt der selektierten Liste ausgewählten Eintrag.

Neue Liste anlegen

Parameter | Beschreibung
Listen Name | Name der Liste
Sortieren | Sortierkriterien für Anzeige in Inhalt der selektierten Liste und zur Runtime
nicht | Eintrag wird am Ende der Liste eingefügt.
nach Text (Default) | Alphabetische Reihenfolge
nach Codes | Codezahl bestimmt Reihenfolge (aufsteigend) in Liste.


Spalten und Zeilen formatieren

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Formatierungen -> Spalten und Zeilen formatieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ist eine ganze Zeile oder eine ganze Spalte markiert, steht im Kontextmenü der Befehl Spalte formatiern bzw. Zeile formatieren zur Verfügung.

So wie in Zelle formatieren stehen Registerkarten zur Verfügung für:

Ausrichtung

Rahmen

Schriftart

Muster

Hinweis: Diese Einstellungen betreffen immer nur die Spaltenüberschrift bzw. Zeilenüberschrift. Sie haben keine Auswirkung auf die anderen Zellen einer Spalte oder Zeile. Diese müssen immer über den Dialog Zelle formatieren formatiert werden.

Zusätzlich steht in diesem Dialog eine weitere Registerkarte Spalte bzw. Zeile zur Verfügung.

Noch in diesem Kapitel

Spalte

Zeile


Spalte

Spalte

In der Registerkarte Spalte werden Eigenschaften, die die ganze Spalte betreffen, definiert:

Parameter

Beschreibung

Definition

Überschrift

Legt Spaltenüberschrift fest.

$C: Buchstaben in aufsteigender Reihenfolge der Spaltenzahl

E: expandiert die Spalte automatisch auf die richtige Anzahl von Spalten , wenn in einer ihrer Zellen eine Funktion archiv*, aml oder cel vorkommt. Werden auch andere Reportfunktionen verwendet, darf "E" nicht verwendet werden. "E" kann in einem Report mehrfach verwendet werden.
Default: $C

Breite in Pixeln

Breite der Spalte in Pixel

Optionen

Ausblenden

Aktiv: Die Spalte wird ausgeblendet.
Inaktiv: Die Spalte wird angezeigt.

Um eine ausgeblendete Spalte wieder einzublenden: Markieren Sie die beiden Nachbarspalten und setzen Sie die Eigenschaft Ausblenden auf inaktiv.

Achtung: Funktionen, die sich in ausgeblendeten Zellen befinden, werden nicht ausgeführt. Um eine Funktion auszuführen, ohne dass sie angezeigt wird: Setzen Sie die Zeilenhöhe oder Spaltenbreite auf 0.

Schutz

Aktiv: Die Zellen der Spalte werden gegen Änderungen der Formatierung geschützt.
Inaktiv: Die Zellen dieser Spalte lassen sich formatieren.


Zeile

Zeile

In dieser Dialogbox können Eigenschaften für die ganze ausgewählte Zeile definiert werden.

Parameter

Beschreibung

Definition

Überschrift

Legt Zeilenüberschrift fest.

$R: Zahlen in aufsteigender Reihenfolge der Zeilenzahl

E: expandiert die Zeile automatisch auf die richtige Anzahl von Zeilen, wenn in einer ihrer Zellen eine Funktion archiv*, aml oder cel vorkommt. Werden auch andere Reportfunktionen verwendet, darf "E" nicht verwendet werden. "E" kann in einem Report mehrfach verwendet werden.

Default: $R

Breite in Pixeln

Höhe der Zeile in Pixel.

Optionen

Ausblenden

Aktiv: Die Zeile wird ausgeblendet.
Inaktiv: Die Zeile wird angezeigt.

Um eine ausgeblendete Zeile wieder einzublenden: Markieren Sie die beiden Nachbarzeilen und setzen Sie die Eigenschaft Ausblenden auf inaktiv.

Achtung: Funktionen, die sich in ausgeblendeten Zellen befinden, werden nicht ausgeführt. Um eine Funktion auszuführen, ohne dass sie angezeigt wird: Setzen Sie die Zeilenhöhe oder Spaltenbreite auf 0.

Schutz

Aktiv: Die Zellen der Zeile werden gegen Änderungen der Formatierung geschützt.
Inaktiv: Die Zellen dieser Zeile lassen sich formatieren.


Archivfilter einrichten

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Archivfilter einrichten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollen im Report Archivwerte verwendet werden, sind diese vor der Aktivierung der Reportfunktionen zu definieren. Um den Archivfilter einzurichten:

  • wählen Sie im Menü Format den Befehl Filter

Parameter | Beschreibung
Parameter | Liste der aus Archiven ausgewählten Variablen. Die den Variablen vorangestellten nummern werden in den Archiv- und Protokollfunktionen zur Zuordnung verwendet.
Neu | Öffnet Dialog zur Auswahl von Variablen.
Ändern | Öffnet Dialog zur Auswahl von Variablen.
Löschen | Löscht ausgewählte Variable aus Liste Parameter.
Archive | Definition eines Variablenfilters. Wildcards * und ? sind am Beginn oder Ende eines Ausdrucks erlaubt.
Ersetzen durch | Eingabe des Ausdrucks, der gesuchten String ersetzen soll
Ersetzen | Führt Suche und Ersetzen durch . Ergebnis wird in einer Meldungsbox angezeigt.

Filter "Neu" oder "Ändern"

Klick auf Schaltfläche Neu oder Ändern öffnet Dialog zur Auswahl der Variablen:

Parameter | Beschreibung
Parameter | Anzeige der vorhandenen Archive. Auswahl ganzer Archive oder einzelner Variablen möglich. Jede Variable erhält automatisch eine aufsteigende Nummer, die in den Reportfunktionen für Archive angesprochen wird. Damit kann ein Report auch projektübergreifend wiederverwendet werden.
Speichern | Stellt ausgewählte Archive/Variablen dem Report zur Verfügung.
Abbrechen | Verlässt Dialog ohne Auswahl zu übernehmen.

Jede Variable erhält automatisch eine aufsteigende Nummer, die in den Reportfunktionen für Archive angesprochen wird.


Reportfunktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Gestaltung des Reports stehen verschiedene formatierende und berechnende Funktionen zur Verfügung.

  • verarbeitende Funktionen:

    definierte Zugriffe auf ausgewählte zenon Daten (Online- und Archivwerte, Benutzer, Rechnernamen etc.)

  • Reportfunktionen
    • formatierende Funktionen
    • berechnende Funktionen

Folgende Gruppen an Funktionen stehen zur Verfügung:

  • Datenbankfunktionen
  • Datum und Zeitfunktionen
  • Logische Funktionen
  • Archiv- und Protokoll-Funktionen
  • Statistische Funktionen
  • Mathematische und trigonometrische Funktionen
  • Textfunktionen
  • Rezeptgruppen Manager Funktionen
  • Sonstige Funktionen

Die am häufigsten genutzten Funktionen können mit Hilfe des Funktionsassistenten projektiert werden.

Eingabe

Die Eingabe der Funktionen erfolgt in der Eingabezeile des Reports.

Sollen mehrere Zellen die gleiche Eingabe/Funktion erhalten:

  1. markieren Sie Ausgangszelle und die Zielzelle
  2. wählen Sie im Kontextmenü den Befehl Füllen und die gewünschte Richtung (rechts oder unten)

    Verweise auf Zellenkoordinaten in der Funktion werden automatisch angepasst.

Beispiel für Eingaben

Parameter | Beschreibung
=archiv(1,wert,unten) | Alle Werte des Archivvariablen 1 werden ab der Zelle nach unten angezeigt.
=sum(A4:D4) | Die Inhalte der Zellen A4 bis D4 werden summiert. Die Zelle muss als Wert formatiert sein.
=now() | Gibt das aktuelle Datum/die aktuelle Zeit aus.

info Info

Reportfunktionen können im Editor zu Fehlermeldungen führen, wenn nicht alle für die Berechnung nötigen Angaben korrekt zur Verfügung stehen. Für die Überprüfen der Sie die korrekten Projektierung testen Sie den Report in der Runtime.

Richtung

Optionen

Bedeutung

rechts

Wert wird nach rechts eingetragen (Zeile).

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Spalte angelegt, wird der Wert nach unten (in die Spalte) eingetragen.

unten

Wert wird nach unten eingetragen (Spalte.)

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Zeile angelegt, wird der Wert nach rechts (in die Zeile) eingetragen.

info Info

Das Modul Report Generator ist in der Entwicklungsumgebung und in der Runtime (Einzelplatz, Server/Standby, Client) lizenzpflichtig.

Wird das Modul in der Runtime nicht lizenziert, sind folgende Funktionen nicht verfügbar:

  • Archive speichern (für Handeingaben)
  • und Sollwerte absetzen

Lesender Zugriff ist möglich.

Noch in diesem Kapitel

Konventionen

Funktionsassistent

Archiv- und Protokollfunktionen

Datenbankfunktionen

Datum und Zeitfunktionen

Logische Funktionen

Mathematische und trigonometrische Funktionen

Rezeptgruppen-Manager Funktionen

Statistische Funktionen

Textfunktionen

Sonstige Funktionen

Formatierungsschlüssel


Konventionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Konventionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es gelten folgende Konventionen:

Parameter | Beschreibung
Zahl: | (num); Trennzeichen für Nachkommastellen hängt ab von den Einstellungen im Betriebssystem (1,0 oder 1.0).
Bereich: | (A1:A10)
String: | Zeichenfolgen werden durch doppeltes Hochkomma (") getrennt, z.B. "ABC".
Radians: | Die Eingabe bei Winkelfunktionen erfolgt in Radians.

Umrechnung Grad in Radians

Gradmaß | Bogenmaß | Radians
0,00 | 0 | 0
45,00 | p/4 | 0,78539816339744828
90,00 | p/2 | 1,5707963267948966
135,00 | 3p/4 | 2,3561944901923448
180,00 | p | 3,1415926535897931
225,00 | 5p/4 | 3,9269908169872414
270,00 | 3p/2 | 4,7123889803846897
315,00 | 7p/4 | 5,497787143782138
360,00 | 2p | 6,2831853071795862


Funktionsassistent

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Funktionsassistent

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Funktionsassistent unterstützt bei der Projektierung von Reportfunktionen. Er stellt die am häufigsten gebrauchten Funktionen zur Verfügung. Alle anderen Funktionen werden manuell in die Eingabezeile eingegeben.

Um den Funktionsassistenten zu öffnen:

  1. klicken Sie in die gewünschte Zelle
  2. wählen Sie im Kontextmenü den Befehl Funktionen
  3. der Assistent wird geöffnet
  4. die Auswahl im Assistenten wird in die Eingabezeile übernommen;
    eventuell geöffnete Klammern müssen manuell geschlossen werden

Parameter | Beschreibung
Syntax | Ergebnis der Auswahl von Funktion und Parameter.
Funktion | Auswahl der Funktion.
Parameter | Auswahl der Parameter, die für die gewählte Funktion zur Verfügung stehen.


Archiv- und Protokollfunktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Archiv- und Protokollfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Grundlagen

Alle Archivfunktionen bauen auf der Grundfunktion archive(FILTERINDEX,PARAMETER,RICHTUNG) auf.

Die Erweiterungen werden durch zusätzliche Buchstaben im Funktionsnamen kenntlich gemacht.

Kürzel | Bedeutung | Bemerkung
r | read only | Das Archiv kann nur gelesen werden. Geänderte Werte können nicht gespeichert werden.
sp | Spalten | Bietet spezielle Formatierung zur Definition von zu verwendenden Zellen.
m | Mathematik | Wirkt nur auf Wert und Zeit.
ex | extended | Bietet Sonderbehandlungen.
w | write | Schreiben ist möglich.

Filterindex

Der Filterindex stellt die Zuordnung zwischen den in den Reportfunktionen verwendeten Nummern des Archivfilters und den Variablen aus den Archiven her.

Example Beispiel

=archive(5,"wert","unten")

FILTERINDEX = 5

Der im Filter unter Nr. 5 angeführte Eintrag wird für die Reportfunktion verwendet.

Parameter

Optionen | Möglicher Wert
wert | [1-n]
status | [1-n]
zeit | [1-n]
anzahl | [1]

Richtung

Optionen

Bedeutung

rechts

Wert wird nach rechts eingetragen (Zeile).

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Spalte angelegt, wird der Wert nach unten (in die Spalte) eingetragen.

unten

Wert wird nach unten eingetragen (Spalte.)

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Zeile angelegt, wird der Wert nach rechts (in die Zeile) eingetragen.

Alle Archivfunktionen können mit dem Funktionsassistenten erstellt werden.

Bei der Ausgabe der Statusinformation werden die Einstellungen aus der Datei project.ini im Abschnitt [STATUS] bzw. aus der intern definierten Zuordnung verwendet. Wurde die Stausbezeichnung in der project.ini geändert, wird der geänderte Name ausgegeben. (Tipp: Ermöglicht es, Projekt mit alten Statusbezeichnern kompatibel zu halten.)

Im Onlinebetrieb wird die Abfragezeit etweder im Funktionsaufruf definiert oder zur Runtime beim Öffnen einer Reportdatei vorgegeben.

Archiveinträge ändern

Sofern von den Benutzerrechten zugelassen, können Archivwerte zur Runtime auch geändert werden. Änderungen werden entweder manuell über das Kontrollelement Speichern oder automatisch beim Speichern der Reportdatei gespeichert. Der Status eines geänderten Eintrags wird automatisch auf Handwert gesetzt.

info Info

Ändern von Stringfeldern im Report: Besteht ein Text nur aus Zahlen, werden Leerzeichen beim Speichern standardmäßig entfernt. Gewünschte Leerzeichen müssen durch das ASCII Zeichen 255 (Alt+255) dargestellt werden.

Noch in diesem Kapitel

Behandlung von Archiveinträgen

Projektierung mit Funktionsassistent

archive

archiveex

archiveexr

archivem

archivemr

archivemsp

archivemspr

archiver

archivesp

archivespr

archivespw

archivew

archivetime

batch

batchnr

wmz

wmzz


Behandlung von Archiveinträgen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Archiv- und Protokollfunktionen -> Behandlung von Archiveinträgen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Behandlung von Archiveinträgen

Archiveinträge können in einem Report angezeigt und bei ausreichenden Benutzerrechten auch verändert und wieder im Archiv gespeichert werden. Für die Erstellung der Reportfunktionen zu Archiven steht ein Funktionsassistent zur Verfügung.

Lesen und schreiben von Archiveinträgen

Für die Darstellung in einem Report können folgende Inhalte eines Archiveintrags gelesen werden:

  • Wert
  • Status
  • Zeit

Folgende Archiveinträge können über Berechnungen oder Neueingabe im Report geändert und gepeichert werden :

  • Wert
  • Status

Geänderte Archiveinträge werden zur Runtime über die Schaltfläche Archiv speichern gespeichert. Das Speichern von Änderungen kann verhindert werden durch:

  • Aktivierung der Option Nur lesen in der zenon Funktion Bildumschaltung auf das Report-Bild
  • Aktivierung der Option Gesperrt im Dialog Zelle formatieren

Wird der Wert eines Archiveintrags geändert, wird bei der Speicherung im Archiv der Status auf MAN_VAL gesetzt.

Ausnahme: Wird auch der Status des Archiveintrags geändert, dann wird nur der geänderte Status eingetragen. Sollen Sicherheitsvorschriften wie die der FDA erfüllt werden, darf bei der Projektierung keine Statusänderung durch den Report erlaubt werden. Archiveinträge mit Status MAN_VAL werden beim Einlesen in einen Report blau dargestellt.

Darstellung

Archiveinträge können als Archivwertreihe oder als reihenformatierte Archivwertreihe dargestellt werden. Ausgehend von der Zelle, in der die Archivfunktion projektiert ist, werden die Archiveinträge, die im Zeitbereich des aufgeschalteten Reports liegen, nach rechts oder unten dargestellt. Wird kein Archiveintrag gefunden, so wird in der Zelle, in der die Archivfunktion definiert ist, ein - ausgegeben.

Archivwertreihe

Die eingelesenen Archiveinträge werden nacheinander ohne Leerzellen als Reihe dargestellt.

Reihenformatierte Archivwertreihe

Die eingelesenen Archiveinträge werden mit einer definierten Anzahl von

  • Archiveinträgen pro Reihe
  • Leerzellen zwischen zwei Einträgen
  • leeren Reihen zwischen den Reihen

dargestellt.

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten


Projektierung mit Funktionsassistent

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Archiv- und Protokollfunktionen -> Projektierung mit Funktionsassistent

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Projektierung mit Funktionsassistent

Reportfunktionen für Archive können Sie mit dem Funktionsassistenten projektieren:

  1. Wählen Sie im Kontextmenü der gewünschten Zelle den Befehl Funktionen.
  2. Der Assistent wird geöffnet.
  3. Wählen Sie die gewünschte Archivfunktion.

  4. Die Archivfunktion wird in die Syntax eingetragen.
  5. Klick auf Archive öffnet den Archivfilter.

  6. Wählen Sie den gewünschten Eintrag aus.

  7. Die Referenznummer des Eintrags (z. B. 4) wird in den String der Syntax übernommen.
  8. Wählen Sie den gewünschten Parameter aus, z. B. wert).

  9. Der Parameter wird in den String übernommen.
  10. Wählen Sie die gewünschte Richtung des Eintrags in die Tabelle:
    • unten: die Funktion füllt die Spalte aus
    • rechts: die Funktion füllt die Zeile aus
      Achtung: Bei verwendung der Funktion archivesp müssen entsprechende Spalten/Zeilen vorgesehen sein! Wird z.B rechts gewählt, es ist aber nur eine Spalte vorhanden, dann werden die Werte nach unten (in diese einzige vorhandene Spalte) eingetragen.

  11. Die Richtung wird in den String übernommen.
  12. Die Klammer wird geschlossen.

  13. Mit Klick auf OK wird die Funktion in die Zelle übernommen.


archive

archive

Es können Wert, Status und Zeit eines Archiveintrags eingelesen werden. Änderungen werden entweder manuell über das Kontrollelement Speichern oder automatisch beim Speichern der Reportdatei gespeichert. Der Status eines geänderten Eintrags wird automatisch auf Handwert gesetzt.

Syntax: =archive(FILTERINDEX,PARAMETER,RICHTUNG)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX |  | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | wert, status, zeit, anzahl | Der ausgewählte Parameter wird aus dem Archiv gelesen und dargestellt.
RICHTUNG | unten, rechts | Definiert Richtung, in die aufgefüllt wird, ausgehend von der Zelle, in der die Funktion angelegt wurde.

Example Beispiel

In einem Report sollen alle Archivwerte der Archivvariablen 1 nach unten ausgegeben werden:

=archive(1,"wert","unten")


archiveex

archiveex

Syntax: =archiveex(FILTERINDEX,PARAMETER,RICHTUNG,STATUS,ERSATZTEXT,NN_TEXT,NN_ERSATZWERT,ZYKLUSVERSATZ)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTERINDEX

[1-n]

Entsprechender Eintrag aus dem Archivfilter.

PARAMETER

wert, status, zeit, anzahl

Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.

RICHTUNG

unten, rechts

Auffüllen in entsprechende Richtung.

STATUS

SPONT, MAN_VAL, INVALID

Status der Werte, welche angezeigt werden sollen.

ERSATZTEXT

Text der angezeigt werden soll, wenn der Status der Archivvariablen nicht dem STATUS entspricht.

NN_TEXT

Text für die Nicht-Nachweisbarkeitsgrenze; Groß/Kleinschreibung wird nicht unterschieden.

NN_ERSATZWERT

Zellbezug oder fest eingetragener Wert möglich. Wenn in die Zelle der ERSATZTEXT eingetragen und anschließend die Tabelle gespeichert wird, wird in das Archiv der NN_ERSATZWERT eingetragen.

ZYKLUSVERSATZ

Wird nur berücksichtigt bei Filter Type:

  • Zeit-Tag
  • Zeit-Monat
  • Zeit-Jahr
  • Zeit-Woche
  • Zeit-2Wochen
  • Zeit-15Min.
  • Zeit-30Min.
  • Zeit-60Min.

Example Beispiel

=archiveex(1,"zeit","unten",SPONT,MAN_VAL,-,NN,G2,-2)


archiveexr

archiveexr

Syntax: =archiveexr(FILTERINDEX,PARAMETER,RICHTUNG,STATUS,ERSATZTEXT,NN_TEXT,NN_ERSATZWERT,ZYKLUSVERSATZ)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTERINDEX

[1-n]

Entsprechender Eintrag aus dem Archivfilter.

PARAMETER

wert, status, zeit, anzahl

Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.

RICHTUNG

unten, rechts

Auffüllen in entsprechende Richtung.

STATUS

SPONT,MAN_VAL, INVALID

Status der Werte welche angezeigt werden sollen.

ERSATZTEXT

Text der angezeigt werden soll, wenn der Status der Archivvariablen nicht dem STATUS entsprechen.

NN_TEXT

Text für die Nicht-Nachweisbarkeitsgrenze; Groß/Kleinschreibung wird nicht unterschieden.

NN_ERSATZWERT

Zellbezug oder fest eingetragener Wert möglich. Wenn in die Zelle der ERSATZTEXT eingetragen und anschließend die Tabelle gespeichert wird, wird in das Archiv der NN_ERSATZWERT eingetragen.

ZYKLUSVERSATZ

Wird nur berücksichtigt bei Filter Type:

  • Zeit-Tag
  • Zeit-Monat
  • Zeit-Jahr
  • Zeit-Woche
  • Zeit-2Wochen
  • Zeit-15Min.
  • Zeit-30Min.
  • Zeit-60Min.


archivem

archivem

Diese Funktion ermöglicht das automatische Ändern von Werten bzw. Zeiten eines Archiveintrags durch Addition einer Konstante zum Wert. Änderungen werden entweder manuell über das Kontrollelement Speichern oder automatisch beim Speichern der Reportdatei gespeichert. Der Status eines geänderten Eintrags wird automatisch auf Handwert gesetzt.

Syntax: =archivem(FILTERINDEX,PARAMETER,RICHTUNG,MATH)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTERINDEX

[1-n]

Entsprechender Eintrag aus dem Archivfilter.

PARAMETER

wert, status, zeit, anzahl

Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.

RICHTUNG

unten, rechts

Auffüllen in entsprechende Richtung.

MATH

  • Konstante: mit Vorzeichen
  • Nachkommastellen: Trennzeichen Punkt (.)
  • Korrektur einer Zeit: Angabe in Minuten

Der Wert wird eingelesen und mit der entsprechenden Manipulation im Report dargestellt. Die korrigierten Werte können mit Archiv speichern gespeichert werden.

attention Achtung

Bei jedem Speichern des Archivs werden die Werte jeweils um die angegebene Konstante korrigiert!


archivemr

archivemr

Diese Funktion ermöglicht das automatische Ändern von Werten bzw. Zeiten eines Archiveintrags durch Addition einer Konstanten zum Wert .

Syntax: =archivemr(FILTERINDEX,PARAMETER,RICHTUNG)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTERINDEX

[1-n]

Entsprechender Eintrag aus dem Archivfilter.

PARAMETER

wert, status, zeit, anzahl

Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.

RICHTUNG

unten, rechts

Auffüllen in entsprechende Richtung.

MATH

  • Konstante: mit Vorzeichen
  • Nachkommastellen: Trennzeichen Punkt (.)
  • Korrektur einer Zeit: Angabe in Minuten

attention Achtung

Geänderte Werte können im Archiv nicht gespeichert werden!

Der Wert wird eingelesen und mit der entsprechenden Manipulation im Report dargestellt. Als Parameter sind nur zeit und wert möglich.=archivemr(4,wert,rechts,6.5)

Alle eingelesenen Archivwerte werden für die Darstellung im Report um 6,50 erhöht.

=archivemr(4,zeit,rechts,-1)

Die Zeiten der Archiveinträge werden für die Darstellung im Report um 1 Minute zurück korrigiert.

Einsatzmöglichkeit: Zum Beispiel für berechnete Monatswerte, die erst nach Monatsende vorliegen (Zeitstempel z.B. 00:01:00).


archivemsp

archivemsp

Diese Funktion ermöglicht die automatische Änderung von Werten bzw. Zeiten eines Archiveintrags durch Addition einer Konstante zum Wert sowie die Festlegung der zellen für die Einträge. Der Wert wird eingelesen und mit der entsprechenden Manipulation im Report dargestellt. Änderungen werden entweder manuell über das Kontrollelement Speichern oder automatisch beim Speichern der Reportdatei gespeichert. Der Status eines geänderten Eintrags wird automatisch auf Handwert gesetzt.

Syntax: =archivemsp(FILTERINDEX,PARAMETER,RICHTUNG)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTERINDEX

[1-n]

Entsprechender Eintrag aus dem Archivfilter.

PARAMETER

wert, status, zeit, anzahl

Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.

RICHTUNG

unten, rechts

Auffüllen in entsprechende Richtung.

P1

Anzahl der in der ersten Reihe auszugebenden Archivwerte.

P2

Anzahl der Leerzellen zwischen zwei Wertausgaben.

P3

Leerzellen bis zur nächsten Wertereihe.

MATH

  • Konstante mit Vorzeichen,Konstante: mit Vorzeichen
  • Nachkommastellen: Trennzeichen Punkt (.)
  • Korrektur einer Zeit: Angabe in Minuten

attention Achtung

Bei jedem Archiv speichern werden die Werte jeweils um die angegebene Konstante korrigiert!

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Example Beispiel

=archivemsp(4,"zeit","rechts",16,1,0,-0.5)

Alle Zeiteinträge des Archiveintrags mit der Filternumme 4 werden um 30 Sekunden zurückgesetzt; es werden 16 Einträge vorgesehen mit einer Leerspalte und keiner Leerzeile.


archivemspr

archivemspr

Diese Funktion ermöglicht das automatische Ändern von Werten bzw. Zeiten eines Archiveintrags für die Darstellung im Report durch Addition einer Konstante zum Wert. Der Wert wird eingelesen und mit der entsprechenden Manipulation im Report dargestellt. Als Parameter sind nur zeit und wert möglich.

attention Achtung

Geänderten Werte können im Archiv nicht gespeichert werden!

Syntax: =archivemspr(FILTERINDEX,PARAMETER,RICHTUNG)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTERINDEX

[1-n]

Entsprechender Eintrag aus dem Archivfilter.

PARAMETER

wert, status, zeit, anzahl

Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.

RICHTUNG

unten, rechts

Auffüllen in entsprechende Richtung.

P1

Anzahl der in der ersten Reihe auszugebenden Archivwerte.

P2

Anzahl der Leerzellen zwischen zwei Wertausgaben.

P3

Leerzellen bis zur nächsten Wertereihe.

MATH

  • Konstante mit Vorzeichen,Konstante: mit Vorzeichen
  • Nachkommastellen: Trennzeichen Punkt (.)
  • Korrektur einer Zeit: Angabe in Minuten

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Example Beispiel

=archivemsp(4,"zeit","rechts",16,1,0,-0.5)

Alle Zeiteinträge des Archiveintrags mit der Filternummer 4 werden um 30 Sekunden zurückgesetzt; es werden 16 Einträge vorgesehen mit 1 Leerspalte und 0 Leerzeilen.


archiver

archiver

Diese Funktion ermöglicht es, Wert, Status und Zeit eines Archiveintrags einzulesen. Änderungen sind nicht möglich.

Syntax: =archiver(FILTERINDEX,PARAMETER,RICHTUNG)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | wert, status, zeit, anzahl | Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.
RICHTUNG | unten, rechts | Auffüllen in entsprechende Richtung.

Im Unterschied zu der Funktion archive können zur Runtime keine Handwerteingaben vorgenommen werden.

Einsatzbereich: Zum Beispiel, wenn ein Eintrag in einem Report mehrfach dargestellt werden muss, aber nur an einer Stelle editierbar sein darf. Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktionen angelegt wurden, nach unten oder rechts im Report dargestellt.


archivesp

archivesp

Es können Wert, Status und Zeit eines Archiveintrags eingelesen werden. Änderungen werden entweder manuell über das Kontrollelement Speichern oder automatisch beim Speichern der Reportdatei gespeichert. Der Status eines geänderten Eintrags wird automatisch auf Handwert gesetzt.

Syntax: =archivesp(FILTERINDEX,PARAMETER,RICHTUNG,P1,P2,P3)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [ 1-n] | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | wert, status, zeit, anzahl | Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.
RICHTUNG | unten, rechts | Auffüllen in entsprechende Richtung
P1 |  | Anzahl der in der ersten Reihe auszugebenden Archivwerte
P2 |  | Anzahl der Leerzellen zwischen zwei Wertausgaben
P3 |  | Leerzellen bis zur nächsten Wertereihe

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Bei der Ausgabe der Statusinformation werden die Einstellungen aus der Datei project.ini im Abschnitt [STATUS] bzw. aus der intern definierten Zuordnung verwendet. Wurde die Stausbezeichnung in der project.ini geändert, wird der geänderte Name ausgegeben. (Tipp: Ermöglicht es, Projekt mit alten Statusbezeichnern kompatibel zu halten.)


archivespr

archivespr

Es können Wert, Status und Zeit eines Archiveintrags nur eingelesen werden.

Syntax: =archivespr(FILTERINDEX,PARAMETER,RICHTUNG,P1,P2,P3)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX |  | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | wert, status, zeit, anzahl | Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.
RICHTUNG | unten, rechts | Auffüllen in entsprechende Richtung
P1 |  | Anzahl der in der ersten Reihe auszugebenden Archivwerte
P2 |  | Anzahl der Leerzellen zwischen zwei Wertausgaben
P3 |  | Leerzellen bis zur nächsten Wertereihe

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Im Unterschied zu der Funktion archivesp können auf den Zellen keine Handwertvorgaben vorgenommen werden. Eingesetzt werden diese Funktionen z.B., wenn ein Eintrag in einem Report mehrfach dargestellt werden muss und nur an einer Stelle editierbar sein darf. Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktionen angelegt wurden, nach unten oder rechts im Report dargestellt

Example Beispiel

=archivespr(1,"wert","unten",12,1,3)

Alle Werte des Archiveintrags mit der Filternummer 1 werden nach unten geschrieben; es sind 12 Einträge vorgesehen mit 1 Leerzeile und 3 Leerspalten.


archivespw

archivespw

Diese Funktion unterdrückt die Darstellung der eingelesenen Archiveinträge im Report und erlaubt das Definieren der zu verwendenden Zellen. Beim Speichern werden die Archiveinträge mit an anderer Stelle vorliegenden (z.B. berechneten) Werten und Status überschrieben.

Syntax: =archivespw(FILTERINDEX,PARAMETER,RICHTUNG,P1,P2,P3,SZ_WERT,SZ_STATUS)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | wert, status, zeit, anzahl | Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.
RICHTUNG | unten, rechts | Auffüllen in entsprechende Richtung.
P1 |  | Anzahl der in der ersten Reihe auszugebenden Archivwerte.
P2 |  | Anzahl der Leerzellen zwischen zwei Wertausgaben.
P3 |  | Leerzellen bis zur nächsten Wertereihe.
SZ_WERT | Startzelle Werte | Anfangszelle, ab der die berechneten Werte vorliegen.
SZ_STATUS | Startzelle Status | Statustext Vorgabe eines fixen Statustextes (z.B. MAN_VAL) oder Angabe der Anfangszelle, aus der die Statustexte übernommen werden sollen.

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Statustexte

Die Projektierung erfolgt nicht über die Eingabehilfe, sondern direkt in der Zelle. Dabei gilt:

  • Bei der Vorgabe der Statustexte müssen die definierten Kurztexte aus der Datei project.ini oder aus der systeminternen Defaultprojektierung verwendet werden. Das gilt unabhängig davon, ob die Status fix vorgegeben oder aus einer anderen Zelle eingelesen werden.
  • Mehrere Status werden durch ein Komma (,) getrennt.
  • Die berechneten Werte werden unabhängig davon, ob sich der neu berechnete Wert im Vergleich zum eingelesenen Wert geändert hat, aktualisiert.
  • Der Status wird auf Handwert (MAN_VAL) geändert.


archivew

archivew

Diese Funktion unterdrückt die Darstellung der eingelesenen Archiveinträge im Report. Beim Speichern werden die Archiveinträge mit an anderer Stelle vorliegenden (z.B. berechneten) Werten und Status überschrieben. Diese Reportfunktion kann zum Beispiel für Verdichtungen von Monatswerten auf Jahreswerte als Archivwert verwendet werden.

Syntax: =archivew(FILTERINDEX,PARAMETER,RICHTUNG,P1,P2,P3,SZ_WERT,SZ_STATUS)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | wert, status, zeit, anzahl | Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.
RICHTUNG | unten, rechts | Auffüllen in entsprechende Richtung.
SZ_WERT | Startzelle Werte | Anfangszelle, ab der die berechneten Werte vorliegen.
SZ_STATUS | Startzelle Status | Statustext Vorgabe eines fixen Statustextes (z.B. MAN_VAL) oder Angabe der Anfangszelle, aus der die Statustexte übernommen werden sollen.

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Statustexte

Die Projektierung erfolgt nicht über die Eingabehilfe, sondern direkt in der Zelle. Dabei gilt:

  • Bei der Vorgabe der Statustexte müssen die definierten Kurztexte aus der Datei project.ini oder aus der systeminternen Defaultprojektierung verwendet werden. Das gilt unabhängig davon, ob die Status fix vorgegeben oder aus einer anderen Zelle eingelesen werden.
  • Mehrere Status werden durch ein Komma (,) getrennt.
  • Die berechneten Werte werden unabhängig davon, ob sich der neu berechnete Wert im Vergleich zum eingelesenen Wert geändert hat, aktualisiert.
  • Der Status wird auf Handwert (MAN_VAL) geändert.

Example Beispiel

Verdichtungen von Monatswerten auf Jahreswerte als Archivwert:

In einem Monatsreport mit Tageswerten wird berechnet, an wie vielen Tagen ein Grenzwert x überschritten war. Die Summe der Grenzwertverletzungen wird in einer Zelle des Reports dargestellt.

  • In einem Archiv wurde ein Wert definiert, der pro Monat einen Eintrag aufweist.
  • Dieser Eintrag wird über archivew im Report eingelesen.
  • =archivew(4,"wert","unten",B12,C12)
    • 4: Variable aus Archivfilter
    • wert: Parameter der Variablen , der dargestellt werden soll
    • unten: Richtung, in die die Werte geschrieben werden
    • B12: Startzelle, entspricht der berechneten Zelle
    • C12: definiert auszugebenden Statustetxt
  • Beim Speichern der Archivwerte wird die Summe auf den Archivwert geschrieben


archivetime

archivetime

Die Funktion archivetime liefert in Abhängigkeit vom eingestellten Zeitfilter die Zeitinformation für den Start und das Ende der Archivabfrage im Onlinebetrieb.

Syntax: =archivetime(FILTERINDEX,PARAMETER)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | absolutzeitvon, absolutzeitbis | Startzeit oder Endezeit der Archivabfrage.


batch

batch

Diese Funktion gibt den ersten Chargennamen für das im Filterbereich des Reports ausgewählte Archiv aus.

Syntax: =batch(FILTERINDEX)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.

Example Beispiel

=batch(1)

Erster Chargenname für das Archiv der im Archivfilter an Stelle 1 gereihten Variablen.


batchnr

batchnr

Diese Funktion gibt verschiedene Informationen zu Chargen aus. Die Ausgabe erfolgt als Liste, die von oben nach unten oder von links nach rechts ausgewertet wird. Angezeigt werden:

  • Namen der Chargen
  • Startzeitpunkt
  • Endzeitpunkt

Syntax: =batchnr(FILTERINDEX,PARAMETER,RICHTUNG)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.
PARAMETER | namen, vonzeit, biszeit | Es wird der gewünschte Parameter aus dem Archiv gelesen und dargestellt.
RICHTUNG | unten, links | Auffüllen in entsprechende Richtung.


wmz

wmz

Die Funktion =wmz wertet im Archiv gespeicherte Zählerwerte aus. Zählerüberlauf wird nicht automatisch berücksichtigt.

Syntax: =wmz(FILTERINDEX,AKTIVIERT,ÜBERLAUF,ANFANGSWERT,ENDWERT,ZÄHLERINFO,ERRORCOUNTER)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.
AKTIVIERT | 0 = deaktiviert 1 = aktiviert |
ÜBERLAUF | Wert oder Zellbezug | Bei einem Überlauf von 1000 erkennt die Funktion, dass zwischen einem Anfangswert 998 und einem Endwert 10 eine Differenz von 12 besteht.
ANFANGSWERT | Zellbezug | Anfangswert aus dem Archiv über Zellbezug.
ENDWERT | Zellbezug | Endwert aus dem Archiv über Zellbezug.
ZÄHLERINFO | Zellbezug |
ERRORCOUNTER | Zellbezug |


wmzz

wmzz

Die Funktion wmzz(Filterindes,Richtung,aktiviert,Überlauf) wertet im Archiv gespeicherte Zählerwerte aus.

Syntax: =wmzz(Filterindes,Richtung,aktiviert,Überlauf)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
FILTERINDEX | [1-n] | Entsprechender Eintrag aus dem Archivfilter.
RICHTUNG | unten, links | Auffüllen in entsprechende Richtung.
AKTIVIERT | 0 = deaktiviert 1 = aktiviert |
ÜBERLAUF | Wert oder Zellbezug |


Datenbankfunktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Datenbankfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion ermöglicht das Auslesen von Access- oder SQL-Datenbanken.

Syntax: =sqldao (DATENBANK,SQL-ABFRAGE,PARA1,PARA2)

attention Achtung

SQLDAO funktioniert nicht mit:

  • ntext
  • sql_variant
  • nvarchar(MAX)
  • nchar(MAX)

Übergabeparameter | Bemerkung
DATENBANK | Name der *.mdb Datenbank oder des OLEDB-Providers.
SQL-ABFRAGE | Hier können Standard 'SELECT', 'INSERT', 'UPDATE', 'DELETE' und 'EXECUTE' Datenbankabfragen verwendet werden. Mit %d %d können zwei Integer-Parameter oder mit %s %s zwei String-Parameter mitgegeben werden
PARA1 | Parameter für die SQL-Abfrage
PARA2 | Parameter für die SQL-Abfrage

Projektierung mit Funktionsassistent

Sie haben Zugriff auf MS Access Datenbanken und Datenbanken mit OLEDB-Provider. Dazu verwenden Sie folgende Syntax:

Datenbank

Syntax

MS Access Datenbank

=sqldao (Datenbank,SQL-Abfrage,Para1,Para2)

Datenbanken mit OLEDB Provider

Ersetzen Sie den Verweis auf die Datenbank durch einen OLEDB-Initialisierungsstring. Diesen String können Sie

  • von Hand eingeben oder
  • per Klick auf die Schaltfläche OLEDB-Provider erzeugen.

Datenbank mit OLEDB-Provider

Klick auf die Schaltfläche OLEDB-Provider öffnet den Dialog Datenverknüpfungseigenschaften:

Hier definieren Sie die Verbindung zur gewünschten Datenbank:

  • OLEDB-Providerart
  • Datenquelle
  • Anmeldeinformationen
  • etc.

Mit Bestätigung des Dialogs durch Klick auf OK wird der Initialisierungsstring generiert und im Feld Syntax eingefügt.

Syntax: =sqldao (Provider,SQL-Abfrage,Para1,Para2)

attention Achtung

Der Initialisierungsstring muss immer mit der Zeichenfolge Provider= beginnen. Beachten Sie Groß- und Kleinschreibung, da der String case sensitive ist!

Einstellungen für MS Access und OLEDB

Übergabeparameter | Erklärung
Datenbank | Name der *.mdb Datenbank. Speicherort: Projektordner, der dem Runtime-Ordner übergeordnet ist. Z. B.: Ablageort Runtime: Unterordner von C:\Users\Public\Documents\zenon_Projects\Multi\TEST_PROJEKT Ablageort *.mdb: direkt im Ordner C:\Users\Public\Documents\zenon_Projects\Multi\TEST_PROJEKT Der Projektordner wird in den Projekteigenschaften definiert.
Provider | OLEDB-Provider; der Initialisierungsstring muss immer mit den Zeichen Provider= (case sensitive) beginnen.
SQL-Abfrage | Hier können Standard 'Select' Datenbankabfragen verwendet werden. Mit %d %d können 2 Integer Parameter oder mit %s %s 2 String Parameter mitgegeben werden.
Para1, Para2 | Parameter für die SQL-Abfrage.

Noch in diesem Kapitel

Beispiel Access

Beispiel SQL


Beispiel Access

Beispiel Access

Beispiele für MS Access

Beispieldatenbank: Adress.mdb

Name | Vorname | Straße | Wohnort | Telefon | CanAdresse
Müllner | Egon | Am Rheinberg 22 | 5020 Salzburg | 0662/329354 | 1
Roider | Jürgen | Mozartgasse 7 | 5020 Salzburg | 0662/329354 | 2
Leitner | Hans | Strubergasse 6 | 5020 Salzburg | 0662/329354 | 3
Müller | Peter | Blumengasse 6 | 80003 München | 089/234243 | 5
Weinberger | ww | Hafnergasse 5 | 7020 Klagenfurt | 0222/2222 | 6

Beispiel 1

Alle Einträge aus der Tabelle Adressen mit Feldnamen Name sollen ausgegeben werden.

Funktion: =sqldao(Adress.mdb,SELECT Adressen.name FROM Adressen ;,1,1)

Adress.mdb | Access Datenbank (muss sich im Projektdatenbankpfad befinden)
SELECT | Weist das Microsoft Jet-Datenbankmodul an, Informationen aus der Datenbank als Gruppe von Datensätzen zurückzugeben.
Adressen.name | Tabelle.Feldname
FROM | Gibt die Tabellen oder Abfragen an, in denen die in der SELECT-Anweisung aufgeführten Felder enthalten sind.
Adressen | Tabelle

Ergebnis:

Müllner

Roider

Leitner

Müller

Weinberger

Beispiel 2

  • Untere Grenze: Inhalt von Zelle E1
  • Obere Grenze: Inhalt von Zelle E2
  • Feldname für Auswertung: CanAdresse
  • Einträge aus der Tabelle Adressen mit Feldnamen Name und Vorname sollen ausgegeben werden.
  • Bedingung CanAdresse muss größer Inhalt von Zelle E1 und kleiner Inhalt von Zelle E2 sein.

Funktion: =sqldao(Adress.mdb,SELECT Adressen.name,Adressen.Vorname FROM Adressen WHERE (((Adressen.CanAdresse)>%d) AND ((Adressen.CanAdresse)<%d)) ;,E1,E2)

Adress.mdb | Access Datenbank (muss sich im Projektdatenbankpfad befinden)
SELECT | Weist das Microsoft Jet-Datenbankmodul an, Informationen aus der Datenbank als Gruppe von Datensätzen zurückzugeben.
Adressen.Name | Tabelle.Feldname
, | SQL Trennzeichen
Adressen.Vorname | Tabelle.Feldname
FROM | Gibt die Tabellen oder Abfragen an, in denen die in der SELECT-Anweisung aufgeführten Felder enthalten sind.
Adressen | Tabelle
WHERE | Gibt an, welche Datensätze der im FROM-Abschnitt aufgeführten Tabellen von einer SELECT-, UPDATE- oder DELETE-Anweisung betroffen sind.
(((Adressen.CanAdresse)>%d) | Bedingung: Tabelle.Feldname
AND | Verknüpfung
((Adressen.CanAdresse)<%d)) | Bedingung: Tabelle.Feldname
; | SQL Statement Abschluß
E1, E2: | Zellbezüge (Integer)

Ergebnis für E1 = 1, E2 = 6

Roider | Jürgen | 2
Leitner | Hans | 3
Müller | Peter | 5

info Info

Für weitere Informationen zu SQL Statements siehe Online-Hilfe von Access.


Beispiel SQL

Beispiel SQL

Beispiel für Datenbanken mit OLEDB Provider

=sqldao("Provider=SQLNCLI.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=<databasename>;Data Source=<database instance>;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=<PCNAME>;Use Encryption for Data=False;Tag with column collation when possible=False","SELECT <tablename>.<columnname> FROM <tablename>;",0,0)

Übergabeparameter | Bemerkung
DATENBANK | "Provider=SQLNCLI.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=<databasename>;Data Source=<database instance>;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=<PCNAME>;Use Encryption for Data=False;Tag with column collation when possible=False"
SQL-ABFRAGE | "SELECT <tablename>.<columnname> FROM <tablename>;"
PARA1 | 0
PARA2 | 0

Werte für Beispiel

Datenbank: "AdventureWorks"

Installation: AdventureWorksDB.msi

Quelle: http://msftdbprodsamples.codeplex.com/releases/view/4004

Rechnername: "PC1"

Authentizierung: "Windows NT"

SQL Server Instanz: "SQLEXPRESS"

SELECT

SELECT

=sqldao("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks;Data Source=.\SQLEXPRESS;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=PC1;Use Encryption for Data=False;Tag with column collation when possible=False","SELECT TOP 100 [AddressID],[AddressLine1],[AddressLine2],[City],[StateProvinceID],[PostalCode] FROM [AdventureWorks].[Person].[Address] ORDER BY AddressID;",0,0)

SELECT mit String Parameter (Zelle H2)

=sqldao("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks;Data Source=.\SQLEXPRESS;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=PC1;Use Encryption for Data=False;Tag with column collation when possible=False","SELECT TOP 100 [AddressID],[AddressLine1],[AddressLine2],[City],[StateProvinceID],[PostalCode] FROM [AdventureWorks].[Person].[Address] WHERE (City = N'%s') ORDER BY AddressID;",H2,0)

SELECT mit Numerischen Parameter (Zelle H2)

=sqldao("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks;Data Source=.\SQLEXPRESS;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=PC1;Use Encryption for Data=False;Tag with column collation when possible=False","SELECT TOP 100 [AddressID],[AddressLine1],[AddressLine2],[City],[StateProvinceID],[PostalCode] FROM [AdventureWorks].[Person].[Address] WHERE (StateProvinceID = %d) ORDER BY AddressID;",H2,0)

INSERT

=sqldao("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks;Data Source=.\SQLEXPRESS;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=PC1;Use Encryption for Data=False;Tag with column collation when possible=False","INSERT INTO [AdventureWorks].[Sales].[Currency] (CurrencyCode,Name,ModifiedDate) VALUES ('AAA','NewValue','');",0,0)

UPDATE

=sqldao("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks;Data Source=.\SQLEXPRESS;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=PC1;Use Encryption for Data=False;Tag with column collation when possible=False","UPDATE Sales.Currency SET Name = 'ModifiedValue' WHERE CurrencyCode = 'AAA';",0,0)

DELETE

=sqldao("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks;Data Source=.\SQLEXPRESS;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=PC1;Use Encryption for Data=False;Tag with column collation when possible=False","DELETE Sales.Currency WHERE CurrencyCode = 'AAA';",0,0)

EXECUTE

EXECUTE mit Numerischen Parameter (Zelle J2)

=sqldao("Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks;Data Source=.\SQLEXPRESS;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=PC1;Use Encryption for Data=False;Tag with column collation when possible=False","EXECUTE dbo.uspGetBillOfMaterials %d, '2001-05-08 12:35:29.123';",J2,0)


Datum und Zeitfunktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Datum und Zeitfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion gibt Datums- und Zeitwerte aus.

Die Formatierungsschlüssel finden Sie im Kapitel Datentypen für Datum und Uhrzeit.

Noch in diesem Kapitel

date

datevalue

day

hour

minute

month

now

second

time

today

weekday

year


date

date

Die Funktion date (iYear, iMonth, iDay) liefert das Datum aus den Zahlenwerten für Jahr (iYear), Monat (iMonth) und Tag (iDay).

Syntax: =date(iYear,iMonth,iDay)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
iYear | [0100-2200] |
iMonth | [1-12] | Werte außerhalb des Gültigkeitsbereiches werden auf die Ober- bzw. Untergrenze geändert
iDay | [1-(28,29,30,31)] | Werte außerhalb des Gültigkeitsbereiches werden auf die Ober- bzw. Untergrenze geändert

Ergebnisformat: date

Standardformatierung: dd/mm/yyyy

Example Beispiel

=date(2010,5,12) ergibt 12.05.2010

Zelle A1=2010, Zelle A2=5, Zelle A3=12, Zelle A4=date(A1,A2,A3) ergibt 12.05.2010


datevalue

datevalue

Die Funktion datevalue(date_text) liefert das Datum aus dem Datumstext (date_text).

Syntax: =datevalue(date_text)


day

day

Die Funktion day(date) ermittelt den Tag aus dem Datumswert

Syntax: =day(date)

Ergebnisformat: Integer

Example Beispiel

=now() mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10
Zelle A2=day(A1) ergibt 5


hour

hour

Die Funktion hour(time) ermittelt die Stunde aus dem Zeitwert.

Syntax: =hour(time)

Ergebnisformat: Integer

Example Beispiel

=now() mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10
Zelle A2=hour(A1) ergibt 12


minute

minute

Die Funktion minute(time) ermittelt die Minuten aus dem Zeitwert.

Syntax: =minute(time)

Ergebnisformat: Integer

Example Beispiel

=now() mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10
Zelle A2=minute(A1) ergibt 46


month

month

Die Funktion month(date) ermittelt den Monat aus dem Datumswert.

Syntax: =month(date)

Ergebnisformat: Integer

Example Beispiel

=now() mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10
Zelle A2=month(A1) ergibt 6


now

now

Die Funktion now() liefert aktuell das Datum und die Zeit.

Die Zelle wird automatisch mit dem Formatstring dd/mm/yyyy versehen.

Syntax: =now()

Example Beispiel

=now() ergibt 05.06.2010
=now() mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10


second

second

Die Funktion second(time) ermittelt die Sekunden aus dem Zeitwert.

Syntax: =second(time)

Ergebnisformat: Integer

Example Beispiel

=now() mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10
Zelle A2=second(A1) ergibt 24


time

time

Die Funktion time(iHour, iMinute, iSecond) liefert die Zeit aus den Zahlenwerten für Stunde (iHour), Minute (iMinute) und Sekunde (iSecond).

Die Zelle wird automatisch mit dem Formatstring hh:mm:ss versehen.

Syntax: =time(iHour,iMinute,iSecond)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
iHour | [0-23] | Werte außerhalb des Gültigkeitsbereiches werden auf die Ober- bzw. Untergrenze geändert
iMinute | [0-59] | Werte außerhalb des Gültigkeitsbereiches werden auf die Ober- bzw. Untergrenze geändert
iSecond | [0-59] | Werte außerhalb des Gültigkeitsbereiches werden auf die Ober- bzw. Untergrenze geändert

Ergebnisformat: time

Example Beispiel

=time(12,24,48) ergibt 12:24:48

Zelle A1=12, Zelle A2=24, Zelle A3=48 , Zelle A4=time(A1,A2,A3) ergibt 12:24:48


today

today

Die Funktion today() liefert das aktuelle Datum.

Die Zelle wird automatisch mit dem Formatstring dd/mm/yyyy versehen.

Syntax: =today()

Example Beispiel

=today() ergibt 05.06.2010
=today() mit Formatstring hh:mm:ss dd/mm/yy ergibt 00:00:00 05.06.10


weekday

weekday

Die Funktion weekday(date) ermittelt den Wochentag aus dem Datumswert.

Syntax: =weekday(date)

Ausgabewert | Wochentag
1 | Sonntag
2 | Montag
3 | Dienstag
4 | Mittwoch
5 | Donnerstag
6 | Freitag
7 | Samstag

Ergebnisformat: Integer

Example Beispiel

=now() mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10
Zelle A2=weekday(A1) ergibt 3


year

year

Die Funktion year(date) ermittelt das Jahr aus dem Datumswert.

Syntax: =year(date)

Ergebnisformat: Integer

Example Beispiel

=now()mit Formatstring hh:mm:ss dd/mm/yy ergibt 12:46:24 05.06.10
Zelle A2=year(A1) ergibt 2010


Logische Funktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Logische Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Abschnitt fasst alle logischen Funktionen des Report Generators zusammen

Noch in diesem Kapitel

and

exact

false

if

isblank

iserror

islogical

isnontext

isnumber

isref

istext

not

or

true


and

and

Die Funktion and(logical,logical) liefert den Wert WAHR, wenn beide Argumente WAHR sind.

Die Zelle wird automatisch mit dem Formatstring True;False versehen.

Syntax: =and(logical,logical)

Beispiel

Zelle A1 | Zelle A2 | Zelle A3=and(A1,A2)
false | false | false
false | true | false
true | false | false
true | true | true


exact

exact

Die Funktion exact(string1,string2) liefert den Wert WAHR, wenn beide Textstrings unter Berücksichtigung der Groß- und Kleinschreibung identisch sind.

Syntax: =exact(string1,string2)


false

false

Die Funktion false() liefert den logischen Wert FALSCH.

Die Zelle wird automatisch mit dem Formatstring True;False versehen.

Syntax: =false()

Example Beispiel

Der Eintrag in Zelle A1=false() ergibt False


if

if

Die Funktion if(exprTest,valTrue,valFalse) liefert den Inhalt von valTrue (Wert oder String), wenn das Argument exprTest WAHR ist, sonst den Inhalt von valFalse. Die Verschachtelung von if-Funktionen ist möglich, z. B. um and-Verknüpfungen zu realisieren.

Syntax: =if(exprTest,valTrue,valFalse)


isblank

isblank

Die Funktion isblank(ref) liefert den logischen Wert WAHR, wenn die Referenzzelle leer ist.

Syntax: =isblank(ref)

Beispiel

Inhalt A1 | A1 | Ergebnis
Logischer Ausdruck | Nein | False
Text | Dies ist ein Text | False
leer |  | True
Zahl | 123.00 | False
Error | #ARG! | #ARG!


iserror

iserror

Die Funktion iserror(ref) liefert den logischen Wert WAHR, wenn in der Referenzzelle ein Fehler erkannt wird.

Syntax: =iserror(ref)

Beispiel

Inhalt A1 | A1 | Ergebnis
Logischer Ausdruck | Nein | False
Text | Dies ist ein Text | False
leer |  | False
Zahl | 123.00 | False
Error | #ARG! | True


islogical

islogical

Die Funktion islogical(ref) liefert den logischen Wert WAHR, wenn die Referenzzelle einen logischen Wert beinhaltet.

Syntax: =islogical(ref)

Beispiel

Inhalt A1 | A1 | Ergebnis
Logischer Ausdruck | Nein | True
Text | Dies ist ein Text | False
leer |  | False
Zahl | 123.00 | False
Error | #ARG! | #ARG!


isnontext

isnontext

Die Funktion isnontext(ref) liefert den logischen Wert WAHR, wenn die Referenzzelle keinen Textstring beinhaltet.

Syntax: =isnontext(ref)

Beispiel

Inhalt A1 | A1 | Ergebnis
Logischer Ausdruck | Nein | True
Text | Dies ist ein Text | False
leer |  | True
Zahl | 123.00 | True
Error | #ARG! | #ARG!


isnumber

isnumber

Die Funktion isnumber(ref) liefert den logischen Wert WAHR, wenn die Referenzzelle einen numerischen Wert beinhaltet.

Syntax: =isnumber(ref)

Beispiel

Inhalt A1 | A1 | Ergebnis
Logische Verknüpfung | Nein | False
Text | Dies ist ein Text | False
leer |  | False
Zahl | 123.00 | True
Error | #ARG! | #ARG!


isref

isref

Die Funktion isref(ref) liefert den logischen Wert WAHR, wenn die Referenzzelle eine Referenz zu einer weiteren Zelle beinhaltet.

Syntax: =isref(ref)

Beispiel

Inhalt A1 | A1 | Ergebnis
Logischer Ausdruck | Nein | False
Text | Dies ist ein Text | False
leer |  | False
Zahl | 123.00 | False
Error | #ARG! | False
Referenz | =B1 | True


istext

istext

Die Funktion istext(ref) liefert den logischen Wert WAHR, wenn die Referenzzelle einen Textstring beinhaltet.

Syntax: =istext(ref)

Beispiel

Inhalt A1 | A1 | Ergebnis
Logische Verknüpfung | Nein | False
Text | Dies ist ein Text | True
leer |  | False
Zahl | 123.00 | False
Error | #ARG! | #ARG!


not

not

Die Funktion not(logical) liefert das logische Gegenteil des Arguments.

Die Zelle wird automatisch mit dem Formatstring True;False versehen.

Syntax: =not(logical)

Beispiel

Zelle A1 | Zelle A2=not(A1)
false | True
true | False


or

or

Die Funktion or(logical,logical) liefert den logischen Wert WAHR, wenn ein oder beide Argumente WAHR sind.

Die Zelle wird automatisch mit dem Formatstring True;False versehen.

Syntax: =or(logical,logical)

Beispiel

Zelle A1 | Zelle A2 | Zelle A3=or(A1,A2)
false | false | false
false | true | true
true | false | true
true | true | true


true

true

Die Funktion true() liefert den logischen Wert WAHR.

Die Zelle wird automatisch mit dem Formatstring True;False versehen.

Syntax: =true()

Example Beispiel

Der Eintrag in Zelle A1=true() ergibt True


Mathematische und trigonometrische Funktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Mathematische und trigonometrische Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für Reporte stehen gebräuchliche mathematische Funktionen zur Verfügung. Diese können nicht per Funktionsassistent projektiert werden, sondern werden direkt in die Eingabezeile eingegeben.

Noch in diesem Kapitel

abs

acos

acosh

asin

asinh

atan

atanh

atan2

ceil

column

columns

cos

cosh

degree

even

exp

fact

factdouble

floor

int

ln

log10

mod

odd

pi

product

quotient

radians

rand

randbetween

round

row

rows

sign

sin

sinh

sqrt

sqrtpi

tan

tanh

trunc


abs

abs

Die Funktion abs (num) liefert als Ergebnis den Absolutwert einer Zahl. Der Absolutwert einer Zahl ist die Zahl ohne ihr Vorzeichen.

Syntax: =abs(num)

num: ist die reelle Zahl, deren Absolutwert Sie ermitteln möchten.

Example Beispiel

=abs(2,2) ergibt 2

=abs(-2,2) ergibt 2


acos

acos

Die Funktion acos (num) liefert den Arcuskosinus einer Zahl.

Syntax: =acos(num)


acosh

acosh

Die Funktion acosh (num) liefert den inversen hyperbolischen Kosinus einer Zahl.

Syntax: =acosh(num)


asin

asin

Die Funktion asin (num) liefert den Arcussinus einer Zahl.

Syntax: =asin(num)


asinh

asinh

Die Funktion asinh (num) liefert den inversen hyperbolischen Sinus einer Zahl.

Syntax: =asinh(num)


atan

atan

Die Funktion atan (num) liefert den Arcustangens einer Zahl.

Syntax: =atan(num)


atanh

atanh

Die Funktion atanh (num) liefert den inversen hyperbolischen Tangens einer Zahl.

Syntax: =atanh(num)


atan2

atan2

Die Funktion atan2 (x,y) liefert den Arkustangens ausgehend von einer x- und einer y-Koordinate.

Syntax: =atan2(x, y)


ceil

ceil

Die Funktion ceil (num) liefert den auf die nächstgrößere Ganzzahl aufgerundeten Wert einer Zahl.

Syntax: =ceil(num)

Example Beispiel

=ceil(2,2) ergibt 3

=ceil(-2,2) ergibt -3


column

column

Die Funktion column (ref) liefert die Spaltennummer eines Bezuges (z.B. C3=2) im Wertbereich von 0 bis n.

Syntax: =column(ref)


columns

columns

Die Funktion columns (range) liefert die Anzahl der Spalten im angegebenen Bereich.

Syntax: =columns(range)


cos

cos

Die Funktion cos(num) liefert den Kosinus einer Zahl.

Syntax: =cos(num)

Beispiel

=cos(Eingabe)

 | Eingabe | Ergebnis
Grad | Radians() | Cosinus
0,00 | 0 | 1,000
45,00 | 0,78539816339744828 | 0,707
90,00 | 1,5707963267948966 | 0,000
135,00 | 2,3561944901923448 | -0,707
180,00 | 3,1415926535897931 | -1,000
225,00 | 3,9269908169872414 | -0,707
270,00 | 4,7123889803846897 | -0,000
315,00 | 5,497787143782138 | 0,707
360,00 | 6,2831853071795862 | 1,000


cosh

cosh

Die Funktion cosh(num) liefert den hyperbolischen Kosinus einer Zahl.

Syntax: =cosh(num)


degree

degree

Die Funktion degree(num) konvergiert den Radiant in Grad.

Syntax: =degree(num)

Beispiel

=degree(Eingabe)

Eingabe | Ergebnis
Radians() | Degree()
0 | 0
0,78539816339744828 | 45
1,5707963267948966 | 90
2,3561944901923448 | 135
3,1415926535897931 | 180
3,9269908169872414 | 225
4,7123889803846897 | 270
5,497787143782138 | 315
6,2831853071795862 | 360


even

even

Die Funktion even(num) liefert die nächstgrößeren geraden ganzzahligen Werte. Negative Zahlen werden von Null weg gerundet.

Syntax: =even(num)

Example Beispiel

=even(2,2) ergibt 4

=even(-2,2) ergibt -4


exp

exp

Die Funktion exp(num) potenziert die Basis e mit der als Argument angegebenen Zahl.

Syntax: =exp(num)

Example Beispiel

=exp(0) ergibt 1

=exp(1) ergibt 2,718282

=exp(10) ergibt 22026,465795


fact

fact

Die Funktion fact(int) liefert die Fakultät einer Zahl.

Syntax: =fact(int)

Example Beispiel

=fact(0) ergibt 0 (0)

=fact(1) ergibt 1 (1)

=fact(2) ergibt 2 (1*2)

=fact(3) ergibt 6 (1*2*3)

=fact(4) ergibt 24 (1*2*3*4)

=fact(5) ergibt 120 (1*2*3*4*5)


factdouble

factdouble

Die Funktion factdouble(num) liefert die Doppelfakultät einer Zahl. Dabei wird nur das Produkt jeder zweiten natürlichen Zahl gebildet.

Syntax: =factdouble(num)

Example Beispiel

=factdouble(0) ergibt 0 (0)

=factdouble(1) ergibt 1 (1)

=factdouble(2) ergibt 2 (2)

=factdouble(3) ergibt 3 (1*3)

=factdouble(4) ergibt 8 (2*4)

=factdouble(5) ergibt 15 (1*3*5)


floor

floor

Die Funktion floor(num) liefert den auf die nächstkleinere Ganzzahl abgerundeten Wert einer Zahl. Negative Zahlen werden Richtung Null gerundet.

Syntax: =floor(num)

Example Beispiel

=floor(2,2) ergibt 2

=floor(-2,2) ergibt -2


int

int

Die Funktion int(num) liefert den auf die nächstkleinere Ganzzahl abgerundeten Wert einer Zahl. Negative Zahlen werden von Null weg gerundet.

Syntax: =int(num)

Example Beispiel

=int(2,2) ergibt 2

=int(-2,2) ergibt -3


ln

ln

Die Funktion ln(num) liefert den natürlichen Logarithmus einer Zahl.

Syntax: =ln(num)

Example Beispiel

=ln(1) ergibt 0

=ln(2,718282) ergibt 1

=ln(22026,465795) ergibt 10


log10

log10

Die Funktion log10(num) liefert den Logarithmus einer Zahl zur Basis 10.

Syntax: =log10(num)

Example Beispiel

=log10(1) ergibt 0

=log10(10) ergibt 1

=log10(100) ergibt 2

=log10(1000) ergibt 3


mod

mod

Die Funktion mod(num, divisor) liefert den Rest bei der Division eines Wertes (num) durch den Divisor (divisor).

Syntax: =mod(num,divisor)

Example Beispiel

=mod(0,3) ergibt 0

=mod(1,3) ergibt 1

=mod(2,3) ergibt 2

=mod(3,3) ergibt 0

=mod(4,3) ergibt 1


odd

odd

Die Funktion odd(num) liefert nächstgrößeren ungeraden ganzzahligen Werte. Negative Zahlen werden von Null weg gerundet.

Syntax: =odd(num)

Example Beispiel

=odd(2,2) ergibt 3

=odd(-2,2) ergibt -3


pi

pi

Die Funktion pi() liefert den Wert für pi: 3,1415926535897931

Syntax: =pi()

Standardformatierung: *0.######

Example Beispiel

=pi() ergibt mit Standardformatierung 3,141593


product

product

Die Funktion product (range) liefert das Product über die Werte im definierten Bereich.

Syntax: =product(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle B1=product(A1:A10)

Zelle/Spalte | A | B
1 | 1 | 3628800
2 | 2 |
3 | 3 |
4 | 4 |
5 | 5 |
6 | 6 |
7 | 7 |
8 | 8 |
9 | 9 |
10 | 10 |

Das Ergebnis beträgt für den Bereich A1 bis A10 3628800.


quotient

quotient

Die Funktion quotient(num,divisor) liefert den ganzzahligen Anteil der Division.

Syntax: =quotient(num,divisor)

Example Beispiel

=quotient(0,3) ergibt 0

=quotient(1,3) ergibt 0

=quotient(2,3) ergibt 0

=quotient(3,3) ergibt 1

=quotient(4,3) ergibt 1


radians

radians

Die Funktion radians(num) wandelt Grad in Radiant um.

Syntax: =radians(num)

num: Eingabe in Grad

Beispiel

=radians(Eingabe)

Eingabe | Ergebnis
0,00 | 0
45,00 | 0,78539816339744828
90,00 | 1,5707963267948966
135,00 | 2,3561944901923448
180,00 | 3,1415926535897931
225,00 | 3,9269908169872414
270,00 | 4,7123889803846897
315,00 | 5,497787143782138
360,00 | 6,2831853071795862


rand

rand

Die Funktion rand() liefert bei jeder Neuberechnung der Tabelle eine Zufallszahl im Bereich zwischen 0.000 und 1.000

Syntax: =rand()


randbetween

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Mathematische und trigonometrische Funktionen -> randbetween

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
randbetween

Die Funktion randbetween(min,max) liefert bei jeder Neuberechnung der Tabelle eine Zufallszahl im Bereich von min bis max.

Syntax: =randbetween(min,max)


round

round

Die Funktion round(num,digits) rundet eine Zahl(num) auf eine bestimmte Anzahl von Dezimalstellen (digits).

Syntax: =round(num,digits)


row

row

Die Funktion row(ref) liefert die Zeilennummer der Referenzzelle im Wertbereich von 0 bis n.

Syntax: =row(ref)


rows

rows

Die Funktion rows(range) liefert die Anzahl der Zeilen innerhalb des definierten Bereiches.

Syntax: =rows(range)


sign

sign

Die Funktion sign(num) liefert den Wert

  • 1, wenn die Zahl (num) positiv ist
  • -1 wenn die Zahl negativ ist
  • 0 wenn die Zahl 0 ist

Syntax: =sign(num)

Example Beispiel

=sign(2,2) ergibt 1

=sign(-2,2) ergibt -1

=sign(0,0) ergibt 0


sin

sin

Die Funktion sin(num) liefert den Sinus einer Zahl.

Syntax: =sin(num)

num: Eingabe in Radians

Beispiel

=sin(Eingabe)

 | Eingabe | Ergebnis
Grad | Radians() | Sinus
0,00 | 0 | 0,000
45,00 | 0,78539816339744828 | 0,707
90,00 | 1,5707963267948966 | 1,000
135,00 | 2,3561944901923448 | 0,707
180,00 | 3,1415926535897931 | 0,000
225,00 | 3,9269908169872414 | -0,707
270,00 | 4,7123889803846897 | -1,000
315,00 | 5,497787143782138 | -0,707
360,00 | 6,2831853071795862 | -0,000


sinh

sinh

Die Funktion sinh(num) liefert den hyperbolischen Sinus einer Zahl.

Syntax: =sinh(num)


sqrt

sqrt

Die Funktion sqrt(num) liefert die Quadratwurzel einer Zahl.

Syntax: =sqrt(num)

Example Beispiel

=sqrt(1) ergibt 1

=sqrt(2) ergibt 1,414214

=sqrt(3) ergibt 1,732051

=sqrt(4) ergibt 2


sqrtpi

sqrtpi

Die Funktion sqrtpi(num) liefert die Quadratwurzel eines pi-Werts.

Syntax: =sqrtpi()

Example Beispiel

=sqrtpi(1) ergibt 3,141593 = 1*pi

=sqrtpi(2) ergibt 4,442883 = sqrt(2)*pi

=sqrtpi(3) ergibt 5,441398 = sqrt(3)*pi

=sqrtpi(4) ergibt 6,283185 = sqrt(4)*pi


tan

tan

Die Funktion tan(num) liefert den Tangens einer Zahl.

Syntax: =tan(num)


tanh

tanh

Die Funktion tanh(num) liefert den hyperbolischen Tangens einer Zahl.

Syntax: =tanh(num)


trunc

trunc

Die Funktion trunc(num) liefert den auf die nächstkleinere Ganzzahl abgerundeten Wert einer Zahl. Negative Zahlen werden Richtung Null gerundet.

Syntax: =trunc(num)

Example Beispiel

=trunc(2,2) ergibt 2

=trunc(-2,2) ergibt -2


Rezeptgruppen-Manager Funktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Rezeptgruppen-Manager Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit den Reportfunktionen für den Rezeptgruppen-Manager können auch Variablen aus anderen geladenen Projekten, die in den Rezepturen verwendet werden, angezeigt werden. Diese Funktionen können nur mit Bildern des Typs Rezeptgruppen-Manger verwendet werden.

Für die Projektierung steht der Funktionsassistent zur Verfügung.

Noch in diesem Kapitel

recipea

recipef

recipew


recipea

recipea

Die Funktion =recipeaInhalt) zeigt allgemeine Daten zu einem Rezept des Rezeptgruppen Managers an.

Syntax: =recipea(Inhalt)

Inhalt | Beschreibung
muser | Benutzer, der das Rezept zuletzt geändert hat.
mzeit | Zeit, der letzten Änderung.
rez | Name des Rezepts.
rezg | Name der Rezeptgruppe, zu der das Rezept gehört.
reznum | Nummer des Rezepts.
text1 bis text 8 | Benutzerkommentare 1 bis 8 des Rezepts.
text2 | Benutzerkommentar 2 des Rezepts.
version | Versionsnummer des Rezepts.
status | Status des Rezepte als Text. Z. B.: 1 - Mustertext

Example Beispiel

=recipea(reznum)


recipef

recipef

Die Funktion =recipef(Inhalt,Variable) zeigt variablenorientierte Daten zu einem Rezept des Rezeptgruppen Managers an. Diese Daten können im Report frei positioniert werden.

Syntax: =recipef(Inhalt,Variable)

Inhalt | Beschreibung
name | Name der Variablen.
kennung | Kennung der Variablen.
type | Quellentyp.
einheit | Technische Einheit der Variablen.
wert | Wert für die Variable im Rezept.
symbolik | Anzeige von Grenzwerttexten aus Rekationsmatrix oder Grenzwert als Text.
min | Minimum des erlaubten Eingabebereichs für die Variable in diesem Rezept.
max | Maximum des erlaubten Eingabebereichs für die Variable in diesem Rezept.
istwert | Ist die definierte Variable im ausgewählten Rezept nicht vorhanden, dann wird die Zelle mit - markiert.
verriegelung | Anzeige der Verriegelung . Da die Namen zur Runtime nicht verfügbar sind, werden nur die IDs der im Rezeptgruppen-Manager gewählten Verriegelung angezeigt.
sichtbarkeit | Zeigt Sichtbarkeit der Variablen an.
schattenvariable | Zeigt den Namen der verknüpften Schattenvariablen an. Zur Runtime nur Anzeige. Konfiguration im Editor.
filter | Filtertext, der im RGM gewählt wurde.
keyboard | Zeigt verknüpftes Keyboard an.
sollwertgrenzen | Ja: Übernimmt Sollwertgrenze von Variable. Zur Runtime nur Anzeige. Konfiguration im Editor.

Example Beispiel

=recipef("wert","temperature")


recipew

recipew

Die Funktion =recipew(Inhalt,Richtung) stellt variablenorientierte Daten zu einem Rezept des Rezeptgruppen Managers in Tabellenform dar.

Syntax: =recipew(Inhalt,Richtung)

Inhalt | Beschreibung
name | Name der Variablen.
kennung | Kennung der Variablen.
type | Quellentyp.
einheit | Technische Einheit der Variablen.
wert | Wert für die Variable im Rezept.
symbolik | Anzeige von Werten als Text.
min | Minimum des erlaubten Eingabebereichs für die Variable in diesem Rezept.
max | Maximum des erlaubten Eingabebereichs für die Variable in diesem Rezept.
istwert | Ist die definierte Variable im ausgewählten Rezept nicht vorhanden, dann wird die Zelle mit - markiert.
verriegelung | Anzeige der Verriegelung . Da die Namen zur Runtime nicht verfügbar sind, werden nur die IDs der im Rezeptgruppen-Manager gewählten Verriegelung angezeigt.
sichtbarkeit | Zeigt Sichtbarkeit der Variablen an.
schattenvariable | Zeigt den Namen der verknüpften Schattenvariablen an. Zur Runtime nur Anzeige. Konfiguration im Editor.
filter | Filtertext, der im RGM gewählt wurde.
keyboard | Zeigt verknüpftes Keyboard an.
sollwertgrenzen | Ja: Übernimmt Sollwertgrenze von Variable. Zur Runtime nur Anzeige. Konfiguration im Editor.

Example Beispiel

=recipew(name,unten)


Statistische Funktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Statistische Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für Reporte stehen gebräuchliche statistische Funktionen zur Verfügung. Diese können nicht per Funktionsassistent projektiert werden, sondern werden direkt in die Eingabezeile eingegeben.

Noch in diesem Kapitel

avg

count

counta

countblank

max

min

percentile

stdev

stdevp

sum

sumsq

var

varp


avg

avg

Die Funktion avg (range) liefert den Mittelwert über die Werte innerhalb des Bereiches.

Syntax: =avg(range)

Beispiel

Zelle A4= avg(A1:A3)

Zeile/Spalte | A
1 | 1
2 | 3
3 | 5
4 | 3

Der Mittelwert der Zellen A1 bis A3 ergibt 3


count

count

Die Funktion count (range) liefert die Anzahl der numerischen Werte im angegebenen Bereich.

Syntax: =count(range)

Beispiel

Zelle A5= count(A1:A4)

Zeile/Spalte | A
1 | 1
2 | Text
3 |
4 | 3
5 | 2

Die Anzahl der numerischen Werte der Zellen A1 bis A4 ergibt 2.


counta

counta

Die Funktion counta (range) liefert die Anzahl der nicht leeren Zellen im angegebenen Bereich.

Syntax: =counta(range)

Beispiel

Zelle A5=counta(A1:A4)

Zeile/Spalte | A
1 | 1
2 | text
3 |
4 | 3
5 | 3

Die Anzahl der nicht leeren Zellen im Bereich A1 bis A4 ergibt 3.


countblank

countblank

Die Funktion countblank (range) liefert die Anzahl der leeren Zellen im angegebenen Bereich.

Syntax: =countblank(range)

Beispiel

Zelle A5 = countblank(A1:A4)

Zeile/Spalte | A
1 | 1
2 | Text
3 |
4 | 3
5 | 1

Die Anzahl der leeren Zellen im Bereich von A1 bis A4 ergibt 1.


max

max

Die Funktion max (range) liefert den größten Wert aus dem angegebenen Bereich.

Syntax: =max(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle B1=max(A1:A10)

Zeile/Spalte | A | B
1 | 1 | 10
2 | 2 |
3 | 3 |
4 | 4 |
5 | 5 |
6 | 6 |
7 | 7 |
8 | 8 |
9 | 9 |
10 | 10 |

Der höchste Wert im Bereich A1 bis A10 liegt in Zelle A10 und beträgt 10.


min

min

Die Funktion min (range) liefert den kleinsten Wert aus dem angegebenen Bereich.

Syntax: =min(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle B1=min(A1:A10)

Zeile/Spalte | A | B
1 | 1 | 1
2 | 2 |
3 | 3 |
4 | 4 |
5 | 5 |
6 | 6 |
7 | 7 |
8 | 8 |
9 | 9 |
10 | 10 |

Der kleinste Wert im Bereich A1 bis A10 liegt in Zelle A1 und beträgt 1.


percentile

percentile

Die Funktion percentile (range,num) liefert als Ergebnis einen Schwellenwert, ab dem Beobachtungen akzeptiert werden.

Syntax: =percentile(range,num)

Range: ist eine Matrix oder ein Datenbereich zur Beschreibung der relativen Lage der Daten.

Num: Integer von 0-100

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle B1=percentile(A1:A10,90)

Zeile/Spalte | A | B
1 | 1 | 9,1
2 | 2 |
3 | 3 |
4 | 4 |
5 | 5 |
6 | 6 |
7 | 7 |
8 | 8 |
9 | 9 |
10 | 10 |

Der Schwellwert für den Bereich A1 bis A10 beträgt 9,1.


stdev

stdev

Die Funktion stdev (range) liefert eine Schätzung der Standardabweichung ausgehend von einer Stichprobe von Werten im definierten Bereich.

Formel:

Syntax: =stdev(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle A11=stdev(A1:A10)

Zeile/Spalte | A
1 | 745,00
2 | 730,00
3 | 732,00
4 | 768,00
5 | 769,00
6 | 747,00
7 | 718,00
8 | 723,00
9 | 766,00
10 | 739,00
11 | 18,785633

Die Standardabweichung für den Bereich A1 bis A10 wird auf Basis der Stichprobe auf 18,785633 geschätzt.


stdevp

stdevp

Die Funktion stdevp (range) liefert eine Schätzung der Standardabweichung, ausgehend von der Gesamtheit der Werte im definierten Bereich.

Formel:

Syntax: =stdevp(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle A11= stdevp(A1:A10)

Zeile/Spalte | A
1 | 745,00
2 | 730,00
3 | 732,00
4 | 768,00
5 | 769,00
6 | 747,00
7 | 718,00
8 | 723,00
9 | 766,00
10 | 739,00
11 | 17,821616

Die Standardabweichung für den Bereich A1 bis A10 wird auf 17,821616 geschätzt.


sum

sum

Die Funktion sum (range) liefert die Summe über die Werte im definierten Bereich.

Syntax: =sum(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle B1=sum(A1:A10)

Zeile/Spalte | A | B
1 | 1 | 55
2 | 2 |
3 | 3 |
4 | 4 |
5 | 5 |
6 | 6 |
7 | 7 |
8 | 8 |
9 | 9 |
10 | 10 |

Die Summe aller Werte im Bereich A1 bis A10 beträgt 55.


sumsq

sumsq

Die Funktion sumsq (range) liefert die Summe der Quadrate der Werte im definierten Bereich.

Syntax: =sumsq(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle A11=sumsq(A1:A10)

Zeile/Spalte | A | B
1 | 1 | 1
2 | 2 | 4
3 | 3 | 9
4 | 4 | 16
5 | 5 | 25
6 | 6 | 36
7 | 7 | 49
8 | 8 | 56
9 | 9 | 81
10 | 10 | 100
11 | 385 | 385

Kontrolle

Zellen B1 bis B10: Quadrate von A1 bis A10

Zelle B11= sum(B1:B10)


var

var

Die Funktion var (range) liefert eine Schätzung der Varianz ausgehend von einer Stichprobe von Werten im definierten Bereich.

Formel:

Syntax: =var(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle A11=var(A1:A10)

Zeile/Spalte | A
1 | 745,00
2 | 730,00
3 | 732,00
4 | 768,00
5 | 769,00
6 | 747,00
7 | 718,00
8 | 723,00
9 | 766,00
10 | 739,00
11 | 352,9

Die Varianz für den Bereich A1 bis A10 wird auf Basis von Stichproben auf 352,9 geschätzt.


varp

varp

Die Funktion varp (range) liefert eine Schätzung der Varianz ausgehend von der Gesamtheit der Werte im definierten Bereich.

Formel:

Syntax: =varp(range)

Beispiel

Zellen A1 bis A10: beliebige Zahlen

Zelle A11=varp(A1:A10)

Zeile/Spalte | A
1 | 745,00
2 | 730,00
3 | 732,00
4 | 768,00
5 | 769,00
6 | 747,00
7 | 718,00
8 | 723,00
9 | 766,00
10 | 739,00
11 | 317,61

Die Varianz für den Bereich A1 bis A10 wird auf 317,61 geschätzt.


Textfunktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Textfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für Reporte stehen verschiedene Textfunktionen zur Verfügung. Diese können nicht per Funktionsassistent projektiert werden, sondern werden direkt in die Eingabezeile eingegeben. Ausnahme: paint

Noch in diesem Kapitel

char

clean

code

find

fixed

left

len

lower

mid

paint

proper

replace

rept

right

search

substitute

trim

upper


char

char

Die Funktion char(code) liefert das ASCII-Zeichen, das der unter code definierten Zahl zugeordnet ist.

Syntax: =char(code)

code: Zahl zwischen 1 und 255.

Example Beispiel

=char(88) ergibt X

Enthält die Zelle A1 den Wert 35 liefert die Funktion =char (A1) als Ergebnis das Zeichen #.

Um den ASCII-Code für ein Zeichen zu ermitteln, nutzen Sie Funktion code.


clean

clean

Die Funktion clean(string) löscht alle Steuerzeichen aus einer Text-Zeichenkette.

Syntax: =clean(string)


code

code

Die Funktion code(string) liefert den ASCII-Code für das erste Zeichen in einer Text-Zeichenkette.

Ist der String in der Klammer der zu zu codierende Text, wird er unter Anführungszeichen gesetzt. Verweist er auf eine andere Zelle, wird diese eingetragen.

Syntax: =code(string)

Example Beispiel

=code("z") ergibt 122.

Die Zelle A1 enthält den Text zoom:

=code(A1) ergibt 122.

Um das einem ASCII-Code entsprechende Zeichen zu ermitteln, nutzen Sie Funktion char.

attention Achtung

Die Funktion code(string) liefert den ASCII-Code nur für das erste Zeichen in einem Textstring.


find

find

Die Funktion find(keystring,string,start) liefert die Position einer Zeichenfolge (keystring) innerhalb eines Textstrings (string). Die Position wird ab dem Startzeichen (start) im Textstring unter Berücksichtigung der Groß- und Kleinschreibung ermittelt.

Syntax: =find(keystring,string,start)

Example Beispiel

Zelle A1: cd

Zelle A2: ABCDabcd

Zelle A3: 1

Zelle A4=find(A1,A2,A3): Ergebnis =7


fixed

fixed

Die Funktion fixed(num,decimals) formatiert eine Zahl und wandelt sie in eine definierte Zeichenkette um.

Syntax: =fixed(num,decimals)

  • num: Numerischer Wert oder Zellbezug
  • decimals: Anzahl der Dezimalstellen

Example Beispiel

Zelle A1 = 12345.672

=fixed(A1,2) ergibt 12345,67

=fixed(A1,1) ergibt 12345,6

Das Trennzeichen und die Darstellung hängen auch von den regionalen Einstellungen und den Formatierungseinstellungen in Zelle ab.

Hinweis: Die Funktion fixed() ist nicht mit einem Formatstring wie der Angabe von Maßeinheiten kombinierbar.

Unterschied zu zenon 5.50 und früher

Die Funktion fixed() verfügt in Versionen bis 5.50 auch über das Argument no_seps. Das Argument ist optional und steuert die Anzeige von Tausendertrennzeichen.

Syntax: =fixed(num,decimals,no_seps)

  • no-seps:
    • 0: Tausender-Trennzeichen wird eingefügt
    • 1: Tausender-Trennzeichen wird weggelassen

In späteren Versionen werden Zahlen generell ohne Tausendertrennzeichen angezeigt.


left

left

Die Funktion left(string,num) liefert die in (num) definierte Anzahl von Zeichen aus einer Text-Zeichenkette, beginnend mit dem ersten Zeichen.

Syntax: =left(string,num)

  • string: Zeichenkette in Anführungszeichen oder Verweis auf Zelle mit Zeichenkette
  • num: Anzahl der Zeichen, die beginnend mit dem ersten ausgelesen werden sollen

Example Beispiel

Zelle A1 = abcdefgh

=left(A1,3) ergibt abc

=left(A1,5) ergibt abcde

Um Zeichen beginnend mit dem letzten Zeichen einer Zeichenkette auszulesen, benutzen Sie die Funktion right.


len

len

Die Funktion len(string) liefert die Anzahl der Zeichen einer Text-Zeichenkette.

Syntax: =len(string)

Example Beispiel

Zelle A1 = abc
=len(A1) ergibt 3

Zelle A1 = abcdefgh
=len(A1) ergibt 8


lower

lower

Die Funktion lower(string) ersetzt alle Großbuchstaben einer Text-Zeichenkette durch Kleinbuchstaben.

Syntax: =lower(string)

Example Beispiel

Zelle A1 = AbCdEf
=lower(A1) ergibt abcdef

Um Kleinbuchstaben durch Großbuchstaben zu ersetzen, verwenden Sie die Funktion upper.


mid

mid

Die Funktion mid(string,numStart,numLen) extrahiert

  • aus der definierten Zeichenkette string
  • eine neue Zeichenkette
  • mit einer durch das Argument numLen definierten Anzahl von Zeichen
  • ab der durch numStart definierten Startposition .

Syntax: =mid(string,numStart,numLen)

Example Beispiel

Zelle A1 = abcdefgh
=mid(A1,2,4) ergibt bcde


paint

paint

Die Funktion =paint(referenz)setzt die in der referenzierten Zelle angegebene Zeichenkette fort, falls diese in der referenzierten Zelle nicht genug Platz findet. So lassen sich lange Zeichenketten durch Verteilung auf mehrere Zellen gut lesbar darstellen.

Syntax: =paint(referenz)

Example Beispiel

Die Zelle A1 enthält die Zeichen: abcdefghijklmn

In Zelle A1 werden bedingt durch die Zellenbreite dargestellt: abcdefg

=paint(A1) in Zelle A2 führt zu dieser Darstellung:

A1: abcdefg

A2: hijklmn

Diese Textfunktion kann mit dem Funktionsassistenten projektiert werden.


proper

proper

Die Funktion proper(string) wandelt das erste Zeichen eines Wortes in einen Großbuchstaben und alle folgenden Zeichen in Kleinbuchstaben. Wortanfang ist das erste alphabetische Zeichen einer Zeichenkette. Enthält eine Zeichenkette mehrere nicht-alphabetische Zeichen, wird nach jedem nicht-alphabetischen Zeichen ein neues Wort begonnen.

Syntax: = proper (string)

Example Beispiel

Zelle A1 = AbCdEf
=proper(A1) ergibt Abcdef

Zelle A1 = aBcDeF
=proper(A1) ergibt Abcdef

Zelle A1 = 1aBcD2eF
=proper(A1) ergibt 1Abcd2Ef


replace

replace

Die Funktion replace(string,numStart,numLen,stringNew)

  • ersetzt in der Text-Zeichenkette string
  • ab der durch numStart definierten Zeichenposition
  • eine durch numLen definierte Anzahl von Zeichen
  • mit Zeichen aus der neuen Text-Zeichenkette stringNew

Syntax: =replace(string,numStart,numLen,stringNew)

Example Beispiel

Zelle A1 = abcdefgh
Zelle A2 = xyz
=replace(A1,3,2,A2) ergibt abxyzefgh

In diesem Beispiel werden im String abcdefgh die Zeichen cd (3. Stelle im String, Anzahl 2 Zeichen ) durch xyz ersetzt.


rept

rept

Die Funktion rept(string,num) wiederholt die Zeichenkette string so oft wie in num definiert.

Syntax: =rept(string,num)

Example Beispiel

Zelle A1 = abc
Zelle A2 = 3
=rept(A1,A2) ergibt abcabcabc


right

right

Die Funktion right(string,num) liefert die in (num) definierte Anzahl von Zeichen aus einer Text-Zeichenkette, beginnend mit dem letzten Zeichen.

Syntax: =right(string,num)

  • string: Zeichenkette in Anführungszeichen oder Verweis auf Zelle mit Zeichenkette
  • num: Anzahl der Zeichen, die beginnend mit dem letzten ausgelesen werden sollen

Example Beispiel

Zelle A1 = abcdefgh

=right(A1,3) ergibt fgh

=right(A1,5) ergibt defgh

Um Zeichen beginnend mit dem ersten Zeichen einer Zeichenkette auszulesen, benutzen Sie die Funktion left.


search

search

Die Funktion search(keystring,string,start) liefert

  • die Position eines Suchtextes keystring
  • innerhalb einer Zeichenkette string
  • ab der Startzeichenposition start

Syntax: =search(string,keystring,start)

Beispiel

Zelle A4=search(A1,A2,A3)

Zelle/Spalte | A
1 | abcdeABCDEabcde
2 | cd
3 | 1
4 | 3

Die Funktion in Zelle A4 findet den gesuchten Text cd in Zelle A1 an Position 3.


substitute

substitute

Die Funktion substitute(string,oldstring,newstring,instance)

  • ersetzt in der Zeichenkette string
  • eine durch oldstring Zeichenfolge
  • durch eine neue Zeichenkette newstring
  • wobei instance die Position von oldstring festlegt
    • instance=0 ersetzt alle gefundenen Zeichenfolgen

Die Funktion berücksichtigt die Groß- und Kleinschreibung.

Syntax: =substitute(string, oldstring, newstring, instance)

Example Beispiel

Zelle A1 = abcdef ABCDEF abcdef ABCDEF abcdef ABCDEF
Zelle A2 = XYZ

Beispiel 1:

=substitute(A1,"ABCDEF",A2,0) ergibt abcdef XYZ abcdef XYZ abcdef XYZ

In diesem Beispiel wird die Zeichenfolge ABCDEF im gesamten String abcdef ABCDEF abcdef ABCDEF abcdef ABCDEF durch XYZ ersetzt.

Beispiel 2:

=substitute(A1,"abcdef",A2,2) ergibt abcdef ABCDEF XYZ ABCDEF abcdef ABCDEF

In diesem Beispiel wird die zweite im String abcdef ABCDEF abcdef ABCDEF abcdef ABCDEF gefundene Zeichenfolge abcdef durch XYZ ersetzt.

Hinweis: Zeichenketten innerhalb der Funktion werden in Anführungszeichen ("Zeichenkette") gesetzt.


trim

trim

Die Funktion trim(string) lässt maximal ein Leerzeichen zwischen zwei Zeichen zu. Alle weiteren Leerzeichen werden entfernt.

Syntax: =trim(string)

Example Beispiel

Zelle A1 = Zu viele Leerzeichen werden auf eines reduziert .
=trim (A1) ergibt: Zu viele Leerzeichen werden auf eines reduziert.


upper

upper

Die Funktion upper(string) ersetzt alle Kleinbuchstaben einer Text-Zeichenkette durch Großbuchstaben.

Syntax: =upper(string)

Example Beispiel

Zelle A1 = AbCdEf
=upper(A1) ergibt ABCDEF

Um Großbuchstaben durch Kleinbuchstaben zu ersetzen, verwenden Sie die Funktion lower.


Sonstige Funktionen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Sonstige Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sonstige Funktionen sammelt Reportfunktionen, die keiner Unterguppe zugeordnet wurden.

Für die Projektierung steht der Funktionsassistent zur Verfügung.

Noch in diesem Kapitel

alarm

cel

alarm und cel projektieren mit Funktionsassistent

compare

comparesp

comparespsum

comparesum

computername

maxsp

minsp

parameter

select

selectmode

username

variabler

variablerw


alarm

alarm

Diese Funktion zeigt Informationen aus der Alarmverwaltung als formatierte Liste in einem Report an.

Syntax: =alarm(FILTER,PARAMETER,RICHTUNG)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTER

Konfiguration über AML-Filter.

PARAMETER
  • name
  • kennung
  • text
  • status
  • wert
  • zeitkommt
  • zeitgeht
  • zeitquittiert
  • zeitreaktiviert
  • statusreaktiviert
  • anzahlreaktiviert
  • angestanden
  • anzahl_h
  • anzahl_t
  • anzahl_m
  • benutzer
  • computer
  • bemerkung
  • klasse
  • gruppe
  • projekt
  • anzahl

Wahl der auszulesenden Filterspalte.

Hinweise:

  • projekt: Im AML-Filter nur bei Mehrbenutzerfähigen Projekten vorhanden
  • anzahl: nur für Projekt Generator
  • anzahl_h: nur für Projekt Generator
  • anzahl_t: nur für Projekt Generator
  • anzahl_m: nur für Projekt Generator

RICHTUNG
  • unten
  • links

Auffüllen in entsprechende Richtung.

Der Zeitfilter ergibt sich aus der Definition im Filter Bildumschaltung Report.

Richtung

Optionen

Bedeutung

rechts

Wert wird nach rechts eingetragen (Zeile).

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Spalte angelegt, wird der Wert nach unten (in die Spalte) eingetragen.

unten

Wert wird nach unten eingetragen (Spalte.)

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Zeile angelegt, wird der Wert nach rechts (in die Zeile) eingetragen.

info Info

Um sicherzustellen, dass die Funktion in der Runtime dynamisch Zeilen oder Spalten einfügen kann ohne andere Zeilen/Spalten zu überschreiben, muss die Beschriftung der entsprechenden Zeile oder Spalte auf E (für "Expand") gesetzt werden.


cel

cel

Diese Funktion zeigt Informationen aus der Chronologischen Ereignisliste (CEL) als formatierte Liste in einem Report an. Die Projektierung mit dem Funktionsassistenten funktioniert analog der Projektierung der Funktion aml.

Syntax: =cel(FILTER,PARAMETER,RICHTUNG)

Übergabeparameter

Gültigkeitsbereich

Bemerkung

FILTER

Konfiguration über CEL-Filter.

PARAMETER
  • name
  • kennung
  • text
  • status
  • wert
  • zeitkommt
  • benutzer
  • computer
  • bemerkung
  • klasse
  • gruppe
  • projekt
  • anzahl

Wahl der auszulesenden Filterspalte.

Hinweise:

  • projekt: Im CEL-Filter nur bei Mehrbenutzerfähigen Projekten vorhanden
  • anzahl: nur für Projekt Generator

RICHTUNG

unten, links

Auffüllen in entsprechende Richtung.

Der Zeitfilter ergibt sich aus der Definition im Filter Bildumschaltung Report.

Richtung

Optionen

Bedeutung

rechts

Wert wird nach rechts eingetragen (Zeile).

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Spalte angelegt, wird der Wert nach unten (in die Spalte) eingetragen.

unten

Wert wird nach unten eingetragen (Spalte.)

Bei der weiteren Reportgestaltung müssen genügend Zellen für die zu erwartenden Einträge frei gelassen werden.

Achtung: Wird eine Funktion archivesp mit nur einer Zeile angelegt, wird der Wert nach rechts (in die Zeile) eingetragen.

info Info

Um sicherzustellen, dass die Funktion in der Runtime dynamisch Zeilen oder Spalten einfügen kann ohne andere Zeilen/Spalten zu überschreiben, muss die Beschriftung der entsprechenden Zeile oder Spalte auf E (für "Expand") gesetzt werden.


alarm und cel projektieren mit Funktionsassistent

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Sonstige Funktionen -> alarm und cel projektieren mit Funktionsassistent

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
alarm und cel projektieren mit Funktionsassistent

Funktionen für AML und CEL können Sie mit dem Funktionsassistenten projektieren. Dieses Beispiel wird mit aml durchgeführt und funktioniert mit cel analog:

  1. Wählen Sie im Kontextmenü der gewünschten Zelle den Befehl Reportfunktionen.
  2. Der Assistent wird geöffnet.
  3. Wählen Sie alarm.

  4. Die Reportfunktion alarm wird in die Syntax eingetragen.
  5. Klick auf Variable öffnet den Filter für die AML. (Bei cel Filter für CEL.)
  6. Konfigurieren Sie den Filter.
  7. Wählen Sie den gewünschten Parameter durch Doppelklick aus, z. B. kennung).

  8. Der Parameter wird in den String übernommen.
  9. Wählen Sie die gewünschte Richtung des Eintrags in die Tabelle durch Doppelklick aus:
    • unten: die Funktion füllt die Spalte aus
    • rechts: die Funktion füllt die Zeile aus

  10. Die Richtung wird in den String übernommen.
  11. Die Klammer wird geschlossen.
  12. Mit Klick auf OK wird die Funktion in die Zelle übernommen.


compare

compare

Die Funktion compare(Bereich,"Bedingung") vergleicht Zahlen in einem angegebenen Bereich auf eine Bedingung und gibt die Anzahl der zutreffenden Zellen aus.

Syntax: =compare(Bereich,"Bedingung")

Bereich: Zellen, die für den Vergleich herangezogen werden

Bedingung: Inhalt, der für die Untersuchung relevant ist (Angabe immer in Anführungszeichen)

Example Beispiel

=compare(A1:A10,6>"=5")

Vergleicht in der Spalte A die Zellen 1 bis 10 und gibt die Anzahl der Werte aus, die größer oder gleich 5 sind.


comparesp

comparesp

Die Funktion comparesp(Startzelle,Richtung,P1,P2,P3,P4,"Bedingung") vergleicht Zahlen in einem angegebenen Bereich und einer definierten Verteilung auf eine Bedingung und gibt die Anzahl der zutreffenden Zellen aus.

Syntax: =comparesp(Startzelle,Richtung,P1,P2,P3,P4,"Bedingung")

Parameter | Beschreibung
Startzelle | Zelle mit dem ersten Wert.
Richtung | rechts oder unten
P1 | Anzahl der in der ersten Reihe auszugebenden Werte.
P2 | Anzahl der Leerzellen zwischen zwei Wertausgaben.
P3 | Leerzellen bis zur nächsten Wertereihe.
P4 | Maximale Anzahl der zu überprüfenden Werte.
Bedingung | Vergleichsbedingung. Angabe immer in Anführungszeichen.

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Example Beispiel

=comparesp(A1,unten,12,0,0,12,"=5")


comparespsum

comparespsum

Die Funktion comparespsum(Startzelle,Richtung,P1,P2,P3,P4,Bedingung) vergleicht Zahlen in einem angegebenen Bereich und einer definierten Verteilung auf eine Bedingung und gibt die Summe der zutreffenden Zellen aus.

Syntax: =comparespsum(Startzelle,Richtung,P1,P2,P3,P4,Bedingung)

Parameter | Beschreibung
Startzelle | Zelle mit dem ersten Wert.
Richtung | rechts oder unten
P1 | Anzahl der in der ersten Reihe auszugebenden Werte.
P2 | Anzahl der Leerzellen zwischen zwei Wertausgaben.
P3 | Leerzellen bis zur nächsten Wertereihe.
P4 | Maximale Anzahl der zu überprüfenden Werte.
Bedingung | Vergleichsbedingung. Angabe immer in Anführungszeichen.

Zellen ansteuern

Die Parameter P1, P2 und P3 legen fest, welche Zellen der Tabelle befüllt werden:

  • P1: Anzahl
  • P2: Leerzellen zwischen zwei Wertausgaben, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten
  • P3: Leerzellen zwischen zwei Wertreihen, abhängig von RICHTUNG (unten, rechts) entweder Leerzeilen oder Leerspalten

Alle Einträge des Zeitbereichs des Reports werden ausgehend von der Zelle, in der die Funktion angelegt wurde, nach unten oder rechts, mit der durch die Parameter P1-P3 festgelegten Reihenformatierung im Report dargestellt.

Bei Auswahl unten gilt:

  • P1 = Anzahl der mit Werten zu füllenden Zeilen
  • P2 = Leerzeilen zwischen den Werten
  • P3 = Leerspalten

Bei Auswahl rechts gilt:

  • P1 = Anzahl der zu füllenden Spalten
  • P2 = Leerspalten zwischen den Werten
  • P3 = Leerzeilen zwischen den Werten

Example Beispiel

=comparespsum(A1,unten,12,0,0,12,"=5")


comparesum

comparesum

Die Funktion comparesum(Vergleichsbereich,Summierungsreferenz,"Bedingung") vergleicht Zahlen in einem angegebenen Bereich auf eine Bedingung und gibt die Summe der zutreffenden Zahlen aus dem Referenzbereich aus.

Syntax: =comparesum(Vergleichsbereich,Summierungsreferenz,"Bedingung")

  • Bereich: Zellen, die für den Vergleich herangezogen werden
  • Summierungsreferenz: Wert, der bei erfüllter Bedingung ausgegeben wird

Bedingung: Inhalt, der für die Untersuchung relevant ist (Angabe immer in Anführungszeichen)

Example Beispiel

=comparesum(B2:B11,A2,"=5")

Die Zellen B2 bis B11 werden auf =5 untersucht. In jenen Zeilen wo dies zutrifft, werden die Werte der entsprechenden Zellen in der Spalte A summiert.


computername

computername

Die Funktion computername() liefert den Rechnernamen des Computers auf dem der Report ausgeführt wird.

Syntax: =computername()

Es sind keine Übergabeparameter notwendig.


maxsp

maxsp

Die Funktionen maxsp ermitteln aus einem Bereich den maximalen Wert und stellt ihn dar. Die Darstellung kann farbig oder unterstrichen erfolgen.

Syntax: =maxsp(range,num)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
range | A1-ATWH31000 | Maximale Anzahl von Spalten: 31000 Maximale Anzahl von Zeilen: 31000
num | -1 0-15 | -1 : unterstrichen 0 ... 15: Farbe entsprechend der Schriftfarbe im Dialog Neue Schrift anlegen (Bilder/Schriften). Die Zuordnungsliste finden Sie unter dieser Tabelle.

Zuordnung Schriftfarben

Die Schriftfarben werden aus dem Betriebssystem übernommen. Zur leichteren Orientierung finden Sie hier eine Liste der Farben, wie Sie in Windows XP, Vista und 7 verwendet wird:

Hinweis: Sollte im Betriebssystem Farben umsortiert oder neu definiert werden, ändern sich auch die für maxsp definierten Farben.

Beispiel

In der Tabelle A1 bis B4 soll der höchste Wert unterstrichen dargestellt werden.

Eingabe im Editor:

Zeile/Spalte | A | B | C
1 | 8 | 5 | =maxsp(A1:B4,-1)
2 | 20 | 2 |
3 | 12 | 10 |
4 | 32 | 14 |

Ergebnis zur Runtime


minsp

minsp

Die Funktionen minsp(range,num) ermitteln aus einem Bereich den minimalen Wert und stellt ihn dar. Die Darstellung kann farbig oder unterstrichen erfolgen.

Syntax: =minsp(range,num)

Übergabeparameter | Gültigkeitsbereich | Bemerkung
range | A1-ATWH31000 |
num | -1 0-15 | -1: unterstrichen 0 ... 15: Farbe entsprechend der Schriftfarbe im Dialog Neue Schrift anlegen (Bilder/Schriften). Die Zuordnungsliste finden Sie unter dieser Tabelle.

Zuordnung Schriftfarben

Die Schriftfarben werden aus dem Betriebssystem übernommen. Zur leichteren Orientierung finden Sie hier eine Liste der Farben, wie Sie in Windows XP, Vista und 7 verwendet wird:

Hinweis: Sollte im Betriebssystem Farben umsortiert oder neu definiert werden, ändern sich auch die für maxsp definierten Farben.

Example Beispiel

Zelle C1=minsp(A1:B4,-1)


parameter

parameter

Parameter erlauben die Definition eines Reports, der über die zenon Funktion Report ausführen und dabei verwendete unterschiedliche Übergabeparameter unterschiedliche Aufgaben erfüllt. Zum Beispiel kann damit ein einziger Report für die Darstellung der Archive mehrer Steuerungen verwendet werden. Oder ein Report stellt Werte in unterschiedlichen Maßeinheiten dar.Syntax: =parameter(Nummer)

Es stehen 10 Parameter zur Verfügung:

  • 1 - 5: Typ String
  • 6 - 10: Typ DWord

Projektierung

  1. weisen Sie im Report den passenden Zellen die gewünschten Parameter zu

  2. ergänzen Sie die Parameter mit eventuell nötigen Rechenoperationen oder Verweisen
  3. zur Runtime wählen Sie über eine Funktion Report ausführen oder die Schaltfläche Datei öffnen und die Registerkarte Parameter die Werte für die Parameter aus

Tipp: Wenn Sie in einem Report Daten unterschiedlicher Archive darstellen möchten, z.B 5 SPSen, dann definieren Sie einen gemeinsamen Report. Die Darstellung steuern Sie über 5 zenon Funktionen, die die Werte für die Parameter zur Verfügung stellen. Dieses Funktionen können Sie einfach kopieren, Sie müssen jeweils nur die Übergabewerte in der Registerkarte Parameter ändern.

Beispiele für Parameter

  • =parameter(1): weist der Zelle den Parameter (1) zu
  • =paramter(6)*A1/100: weist der Zelle den Parameter (6) zu, multipliziert den Wert, der in der Registerkarte Parameter festgelegt wurde, mit dem Wert aus der Zelle A1 und dividiert diesen durch 100


select

select

Die Funktion =select(Zelladresse) definiert die Zelle, die beim Aufschalten der Reports ausgewählt sein soll. Als Parameter ist die Adresse der Zelle zu übergeben.

Syntax: =select(Zelladresse)

Example Beispiel

=select(B3)


selectmode

selectmode

Die Funktion selectmode(Auswahlmodus) setzt den Auswahlmodus.

Syntax: =selectmode(Auswahlmodus)

Example Beispiel

=selectmode(3)


username

username

Die Funktion username liefert den aktuell an zenon angemeldeten Benutzernamen.

Syntax: =username()

Es sind keine Übergabeparameter notwendig.


variabler

variabler

Die Funktion =variabler(Variablenname,Eigenschaft) liefert Informationen zu einer Variablen.

Syntax: =variabler(Variablenname,Eigenschaft)

Parameter | Beschreibung
name | Variablenname.
text | Aktueller Grenzwerttext im Falle einer Grenzwertverletzung.
wert | Aktueller Wert der Variable.
einheit | Einheit der Variable.
kennung | Kennung der Variable.
mmin | Messbereich Minimum der Variable.
mmax | Messbereich Maximum der Variable.
status | Aktueller Status der Variable.
gw1 | Grenzwert 1 der Variable.
gw2 | Grenzwert 2 der Variable.
gw3 | Grenzwert 3 der Variable.
gw4 | Grenzwert 4 der Variable.

info Info

Der Report wird schneller erzeugt, wenn die aufgerufenen Variablen advised sind.

Projektierung mit dem Funktionsassistenten

  1. wählen Sie im Kontextmenü der Reporttabelle Reportfunktionen
  2. wählen Sie variabler
  3. klicken Sie auf die Schaltfläche Variable
  4. wählen Sie die gewünschte Variable aus:
    es können mehrere Variablen ausgewählt werden; diese werden ausgehend von der Zelle, in der die Reportfunktion definiert wird, nach unten eingetragen
  5. wählen Sie die anzuzeigende Eigenschaft

Example Beispiel

=variabler("WIZ_VAR_10","name")


variablerw

variablerw

Die Funktion variablerw(Variablenname,Eigenschaft,Aktion) liefert Informationen über Variable und schreibt Werte in Variablen.

Syntax: =variablerw(Variablenname,Eigenschaft,Aktion)

Parameter | Beschreibung
name | Variablenname.
text | Aktueller Grenzwerttext im Falle einer Grenzwertverletzung.
wert | Aktueller Wert der Variable.
einheit | Einheit der Variable. Hinweis: Darf nicht gemeinsam mit Maßeinheitenumschaltung verwendet werden. Nur zur Verwendung mit älteren Projekten. Wird eine in der Maßeinheitenumschaltung definierte Einheit einer Variablen mit dieser Report-Funktion zur Runtime geändert, muss die Konfiguration in der Maßeinheitenumschaltung neu erfolgen.
kennung | Kennung der Variable
mmin | Messbereich Minimum der Variable. Hinweis: Darf nicht gemeinsam mit Einheitenumschaltung verwendet werden.
mmax | Messbereich Maximum der Variable. Hinweis: Darf nicht gemeinsam mit Einheitenumschaltung verwendet werden.
status | Aktueller Status der Variable.
gw1 | Grenzwert 1 der Variable.
gw2 | Grenzwert 2 der Variable.
gw3 | Grenzwert 3 der Variable.
gw4 | Grenzwert 4 der Variable.

info Info

Der Report wird schneller erzeugt, wenn die aufgerufenen Variablen advised sind.

Projektierung mit dem Funktionsassistenten

  1. wählen Sie im Kontextmenü der Reporttabelle Reportfunktionen
  2. wählen Sie variabler
  3. klicken Sie auf die Schaltfläche Variable
  4. wählen Sie die gewünschte Variable aus:
    es können mehrere Variablen ausgewählt werden; diese werden ausgehend von der Zelle, in der die Reportfunktion definiert wird, nach unten eingetragen
  5. wählen Sie die anzuzeigende Eigenschaft
  6. tragen Sie die gewünschte Aktion ein

Example Beispiel

=variablerw("WIZ_VAR_10","wert","lesen"


Formatierungsschlüssel

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> Reportfunktionen -> Formatierungsschlüssel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Formatierungsschlüssel definieren die formatierte Ausgabe von Zelleninformationen in Abhängigkeit von den Zelleninhalten (Datentypen).

Die Definition erfolgt:

  • in der Dropdownliste Format -> Zellen -> Zahlen -> Registerkarte Zellentyp -> Allgemein/Formatstring

    oder

  • im Kontextmenü Reporttabelle -> Zelle -> Registerkarte Zellentyp -> Allgemein/Formatstring

Noch in diesem Kapitel

Numerische Datentypen

Logische Datentypen

Datentypen für Datum und Uhrzeit


Numerische Datentypen

Numerische Datentypen

Formatschlüssel für numerische Datentypen sind symbolische Platzhalter, die durch den formatierten Wert ersetzt werden.

  • Als 1000er-Trennzeichen wird das Komma verwendet, als Dezimaltrennzeichen der Punkt.
  • Jedes Zeichen, das keinen Formatschlüssel darstellt, wird als Textzeichen in die Ausgabe übernommen.
  • Wird kein Formatschlüssel angegeben, wird das Format *0.*als Standardeinstellung benutzt.

    Hinweis: Für die Standardeinstellung sind maximal 15 Dezimalstellen zulässig.

Formatschlüssel | Beschreibung
, (Komma) | Fügt das 1000er-Trennzeichen drei Stellen vor dem Dezimaltrennzeichen ein.
. (Punkt) | Fügt das Dezimaltrennzeichen ein.
; (Semikolon) | Trennt die Formatschlüssel für positive und negative Wertbereiche.
# | Wird nur ersetzt, wenn die entsprechende Stelle auch vorhanden ist.
* | Es werden alle Vor- bzw. Nachkommastellen angezeigt.
0 (Null) | Wenn die Stelle im Wert nicht vorhanden ist, wird sie mit Null gefüllt.
/ | Das nachfolgende Zeichen wird als Text-Zeichenkette behandelt.

Beispiele

Daten | Formatschlüssel | formatierter Text | Beschreibung
-0.2 | *0.00 | -0.20 | Es werden immer zwei Nachkommastellen ausgegeben.
123 | *00000 | 00123 | Die ersten 5-Stellen werden mit führenden Nullen ausgegeben.
104 | ->*<- | ->104<- | Zahlen werden grundsätzlich zwischen den Zeichen ->...<- ausgegeben.
0.2500 | *0.* | 0.25 | Bei Werten zwischen -1.0 und 1.0 wird immer eine führende Null ausgeben.
12 | +*0.00;-*0.00 | +12.00 | Positive Werte werden mit + und negative Werte mit - gekennzeichnet.


Logische Datentypen

Logische Datentypen

Mit den logischen Datentypen lassen sich Ja/Nein-Informationen vielfältig darstellen. Über den Formatierungsschlüssel wird der Ausgabetext festgelegt.

  • Format: Text1;Text2
  • Ausgabe:
    • positive Werte inklusive Null = Text 1
    • negative Werte = Text 2

Mit der Funktion if(exprTest,valTrue,valFalse)lassen sich die Ausgabeinformationen unabhängig von der Zellenformatierung beschreiben.

Beispiel

Daten | Formatschlüssel | formatierter Text | Beschreibung
1 |  | Ja | Wird kein Formatierungsschlüssel angegeben, wird als Default True/False verwendet.
-1 | Ja;Nein | Nein |


Datentypen für Datum und Uhrzeit

Datentypen für Datum und Uhrzeit

Für die Ausgabe von Datums- und Zeitinformationen stehen eine Vielzahl von Formatierungsschlüssel zur Verfügung. Im Eingabemodus und bei Ausgabe ohne Formatierungsschlüssel wird das unter den Windows-Ländereinstellungen definierte Ausgabeformat benutzt.

info Info

Bezeichnungen für Tage und Monate können zur Runtime sprachumschaltbar projektiert werden.

Jedes Zeichen, das keinen Formatschlüssel darstellt, wird als Textzeichen in die Ausgabe übernommen.

Formatschlüssel | Wert | Beschreibung
m | 1 - 12 | Monat numerisch kurz
mm | 01 - 12 | Monat numerisch lang
mmm | Jan - Dez | Monat kurz
mmmm | Januar - Dezember | Monat lang
d | 1 - 31 | Tag kurz
dd | 01 - 31 | Tag lang
ddd | Son - Sam | Wochentag kurz
dddd | Sonntag - Samstag | Wochentag lang
yy | 00 - 99 | Jahr kurz
yyyy | 1700 - 2900 | Jahr lang (0x wird als 190x interpretiert)
/ |  | internationales Datumstrennzeichen
h | 0 - 23 bzw. 1 - 12 | Stunde kurz, entweder 24 h oder 12 h mit ap
hh | 00 - 23 bzw. 01 - 12 | Stunde lang, entweder 24 h oder 12 h mit ap
mm | 00-59 | Minuten , nur nach h oder hh
ss | 00-59 | Sekunden
ff | 000-999 | Millisekunden
ap | am, pm (oder internationales Äquivalent) | am oder pm
: (Doppelpunkt) |  | internationales Zeittrennzeichen

Beispiel

Daten | Formatschlüssel | formatierter Text
22.09.95 14:05 | dddd dd/mm/yyyy | Freitag 22.09.1995
22.09.95 14:05 | dd/mmmm yyyy | 22.September 1995
22.09.95 14:05 | dd/mm/yy hh:mm | 22.09.95 14:05
22.09.95 14:05 | hh:mm:ff | 14:05:000


zenon Funktionen für Report Generator

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon stellt Funktionen zur Steuerung des Report Generators in der Runtime zur Verfügung.

Die Funktion Bildumschaltung schaltet auf das Bild Report um und ermöglicht die Definition von Filter.

Spezielle Funktionen ermöglichen das Drucken, Exportieren oder Ausführen eines Reports zur Runtime. Um eine zenon Funktionen für den Report Generator zu erstellen:

  1. navigieren Sie im Kontextmenü der Funktionen zu: Funktion neu -> Report Generator
  2. wählen Sie die gewünschte Funktion:
    • Drucken Report
    • Exportieren Report
    • Report ausführen

Noch in diesem Kapitel

Bildumschaltung Report

Reportfilter

Report drucken

Report exportieren

Report ausführen


Bildumschaltung Report

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Bildumschaltung Report

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Report zur Runtime zu nutzen, projektieren Sie eine Bildumschaltung auf ein Bild vom Typ Report:

  1. erstellen Sie ein neues Bild vom Typ Report
  2. wählen Sie im Knoten Funktionen im Kontextmenü den Eintrag Funktion neu
  3. wählen Sie die Funktion Bildumschaltung
  4. wählen Sie das Bild vom Typ Report
  5. der Reportfilter wird angezeigt
  6. wählen Sie die gewünschten Eigenschaften
  7. verknüpfen Sie die Funktion mit einem Button im Bild, um zur Runtime umzuschalten


Reportfilter

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Reportfilter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen von zenon Funktionen für die Konfiguration des Reports der Reportfilter angezeigt:

  • Datei: Auswahl der Reportdatei und Bedingungen zur Runtime
  • Parameter: Übergabeparamter
  • Zeit: Zeitbereich
  • Chargen: Filterung auf Charagen
  • Verknüpfungen: Funktionen ersetzen
  • Indizes: Indizes ersetzen

Noch in diesem Kapitel

Datei

Parameter

Zeit

Zeitfilter in der Runtime beliebig veränderbar

Zeitbereich im Editor vorgeben

Chargen

Verknüpfungen ersetzen

Indizes ersetzen


Datei

Datei

In der Registerkarte Datei legen Sie fest, welcher Report bei der Bildumschaltung aufgerufen wird oder ob das zur Runtime entschieden werden soll.

Parameter | Beschreibung
Format-Datei | Auswahl der im Editor projektierten Reportdatei (*.xrs).
Diesen Dialog zur Runtime anbieten | Aktiv: Zur Runtime wird dieser Filterdialog vor dem Aufschalten angeboten.
Nur lesen | Aktiv: Einträge können nur gelesen werden. Ändern und speichern ist nicht möglich.
Lese Archive vom Backupordner | Aktiv: Ausgelagerte Archive werden von dem in der ProjektkKonfiguration definierten Backupordner eingelesen.

Die Datei-Konfiguration unterscheidet sich bei:

  • Report drucken
  • Report exportieren
  • Report ausführen


Parameter

Parameter

Parameter ermöglichen es, einen Report für unterschiedliche Archive zu verwenden. Dazu werden im Report die flexibel zu verwendenden Felder mit der Reportfunktion parameter ( Nummer ) definiert. Die jeweils zu verwendenden Parameter werden in der Registerkarte Parameter der Bildumschaltfunktion festgelegt. Zum Beispiel kann damit ein einziger Report für die Darstellung der Archive mehrer Steuerungen verwendet werden. Oder ein Report stellt Werte in unterschiedlichen Maßeinheiten dar.

Es stehen 10 Parameter zur Verfügung:

  • 1 - 5: Typ String
  • 6 - 10: Typ DWord

Sollen zum Beispiel die Archivdaten von 5 SPSen dargestellt werden, wird ein Report erstellt und über 5 Umschaltfunktionen werden die 5 Parameter für die SPSen übergeben.


Zeit

Zeit

Die Zeitfilter bieten eine komfortable Möglichkeit, um Daten die angezeigt oder exportiert werden sollen, zu begrenzen. Die Zeitfilter sind sehr flexibel einsetzbar und können sowohl im Editor voreingestellt, als auch zur Runtime angepasst werden.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Die hier beschriebenen Mechanismen gelten bei der Bildumschaltung sowie beim Export für:

  • Alarmmeldeliste
  • Chronologische Ereignisliste
  • Archiv-Nachbearbeitung
  • Erweiterter Trend
  • Report Generator
  • Report Viewer

Die Zeitfilterung kann prinzipiell auf zwei Arten erfolgen:

  1. Zeitbereich im Editor vorgeben
    Es werden fixe Zeitbereiche verwendet. Im Editor wird ein Zeitbereich vorgegeben. In der Runtime kann nur mehr nach diesem Zeitbereich gefiltert werden. Auch andere Filter - z.B. Filtern nach Variablenname, Alarm/Ereignis-Gruppen und -Klassen usw. - sind zur Runtime nicht mehr anpassbar.
  2. Zeitfilter zur Runtime anpassbar
    Es werden vorprojektierte Zeiten verwendet. Der Zeitfilter wird im Editor vorgegeben und kann zur Runtime beliebig verändert werden.

info Info

Wird auf ein Bild referenziert, das keine Zeitfilter hat, dann werden die Zeitfilter deaktiviert.

Für die Einstellung Filter bei Zeitfiltertyp einstellen kann die Option Filterdialog in der Runtime anzeigen zwar ausgewählt werden, steht zur Runtime aber nicht zur Verfügung.


Zeitfilter in der Runtime beliebig veränderbar

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Reportfilter -> Zeitfilter in der Runtime beliebig veränderbar

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitfilter in der Runtime beliebig veränderbar

Bei dieser Methode geben Sie im Editor einen Zeitfilter vor. Dieser kann zur Runtime vor der Ausführung angepasst werden. Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über die Buttons Filter und Filter anzeigen verfügen
  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl die Einstellung Filter bei Zeitfiltertyp einstellen aus

    Hinweis: Die Option Filterdialog in der Runtime anzeigen kann zwar ausgewählt werden, steht zur Runtime für die Einstellung die Option Filter bei Zeitfiltertyp einstellen aber nicht zur Verfügung.

  4. wählen Sie den Zeitraum aus der Dropdownliste Zeitfiltertyp

Parameter

Option

Beschreibung

Absoluter Zeitraum

Es wird ein fixer Zeitbereich im Editor vorgegeben. Beim Ausführen der Funktion wird genau der eingestellte absolute Zeitbereich verwendet.
Beispiel: Sie möchten alle Alarme vom 1.1.2011 - 31.12.2011 sehen, dann geben Sie die entsprechenden Daten bei Von und Bis an.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Von

Definiert den Startzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Bis

Definiert den Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS)

Relativer Zeitraum

Es wird ein relativer Zeitbereich angegeben.

Achtung! Dieser Filter wird ständig aktualisiert. Er wandert also mit.

Zum Beispiel: Sie stellen eine relative Zeit von 10 Minuten ein und schalten um 12:00 Uhr ein Bild vom Typ Alarmmeldeliste mit diesem Zeitfilter auf. Dann werden Ihnen beim Aufschalten die Alarme von 11:50 bis 12:00 angezeigt. Wenn das Bild vom Typ Alarmmeldeliste geöffnet bleibt, wird der Filter automatisch aktualisiert. Um 12:01 sehen Sie die Alarme von 11:51-12:01 usw.

Zeit

Definiert den relativen Zeitraum in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab HH:MM:SS Uhr

Es wird eine Uhrzeit angegeben, ab dem der Filter wirkt. Ist die Uhrzeit am heutigen Tag noch nicht erreicht, wird ab der entsprechenden Uhrzeit des Vortages gefiltert.

Beispiel: Sie geben 23:00:00 ein. Ist es bei der Ausführung der Funktion 23:30 Uhr, dann wird von 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist es jedoch 22:30 Uhr, dann wird vom Vortag 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag - HH:MM:SS Uhr

Es werden ein Tag und eine Uhrzeit für den Filterbeginn angegeben. Ist die angegebene Zeit im laufendem Monat noch nicht erreicht, wird die entsprechende Zeit des Vormonats verwendet.

Beispiel: Sie geben Tag 5 - 23:00:00 ein. Ist es bei der Ausführung der Funktion der 10. des Monats um 23:30 Uhr , dann wird vom 5. des Monats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. des Monats, dann wird vom 5. des Vormonats ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filter wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Ab Tag, Monat - HH:MM:SS Uhr

Es werden ein Monat, ein Tag und eine Uhrzeit für den Filterbeginn eingegeben. Ist die angegebene Zeit im laufenden Jahr noch nicht erreicht, wird die entsprechende Zeit des Vorjahres verwendet.

Beispiel: Sie geben Monat Oktober, Tag 5 - 23:00:00 ein. Ist bei der Ausführung der Funktion der 10. Oktober um 23:30 Uhr, dann wird vom 5. Oktober ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert. Ist jedoch erst der 4. Oktober, dann wird vom 5. Oktober des Vorjahres ab 23:00:00 Uhr bis zum aktuellen Zeitpunkt gefiltert.

Achtung! Der Startzeitpunkt dieses Filters wird nicht automatisch aktualisiert. Es werden immer die beim Aufschalten bestehenden Zeiten verwendet, auch wenn das Bild geöffnet bleibt und der 5. Oktober 23:00:00 Uhr erreicht wird.
Der Endzeitpunkt ist bei diesem Filter nicht definiert, er wandert mit.

Zeit

Definiert den Startzeitpunkt in Monaten, Tagen, Stunden (HH), Minuten (MM), Sekunden (SS)

Kein Zeitfilter

Es wird kein Zeitfilter verwendet.

Bei Report Viewer und in der Archiv-Nachbearbeitung werden mit dieser Einstellung alle Einträge seit 1. 1. 2000 angezeigt.

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Zeitbereich im Editor vorgeben

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Reportfilter -> Zeitbereich im Editor vorgeben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Zeitbereich im Editor vorgeben

Bei dieser Methode geben Sie im Editor bereits einen fixen Zeitbereich vor, der beim Ausführen der Funktion zur Runtime angewandt wird. Zur Runtime können Sie nur noch den Startzeitpunkt festlegen, aber keine weiteren Filtereinstellungen mehr verändern.

Zum Beispiel: Sie stellen einen 30 Minuten Zeitfilter ein. In der Runtime können Sie nur mehr einstellen, wann dieser 30 Minuten Zeitraum starten soll. Sie können den Filter aber nicht auf einen Tagesfilter umstellen.

attention Achtung

Bei Verwendung dieser Filterart können Sie zur Runtime auch alle anderen Filter, die auf der Karteikarte Allgemein zur Verfügung stehen, nicht mehr anpassen! Filtern auf Text, Status und Anlagen ist weiter möglich.

Um den Filter zu erstellen:

  1. erstellen Sie eine Funktion Bildumschaltung
  2. das Bild muss über den Button Filter verfügen, um den Filter zur Runtime zu starten

    Tipp: Aktivieren Sie im Filterdialog in der Registerkarte Allgemein die Option Filterdialog in der Runtime anzeigen. Damit können Sie den Startzeitpunkt bereits vor Ausführung der Funktion anpassen. Lassen Sie den Filter beim Aufschalten der Funktion in der Runtime nicht anzeigen, so wird immer der aktuelle Zeitbereich verwendet. Haben Sie die Option Letzen abgeschlossenen Zeitbereich verwenden aktiviert, wird der vorangegangene Zeitbereich angezeigt.
    Zum Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option Letzten abgeschlossenen Zeitbereich verwenden wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 bis 10:29:59 gesetzt.

  3. wählen Sie aus der Dropdownliste Zeitbereichsauswahl den gewünschten Filter;
    Ausnahme: Filter bei Zeitfiltertyp einstellen - dieser ist für die Option Zeitfilter zur Runtime anpassbar vorgesehen
  4. konfigurieren Sie den ausgewählten Zeitraum

Parameter

Beschreibung

Filter bei Zeitfiltertyp einstellen

Aktiviert die Möglichkeit, den Filter zur Runtime anzupassen.

Ein Tag

Es wird auf einen ganzer Tag gefiltert:
00:00:00 Uhr bis 23:59:59 Uhr.

Eine Woche

Es wird auf eine ganze Woche gefiltert:
Montag 00:00:00 Uhr bis Sonntag 23:59:59 Uhr.

Zwei Wochen

Es wird auf zwei ganze Wochen gefiltert:
Montag 00:00:00 Uhr der ersten Woche bis Sonntag 23:59:59 Uhr der zweiten Woche.

Ein Monat

Es wird auf einen ganzer Monat gefiltert:
Erster Tag des Monats 00:00:00 Uhr bis letzer Tag des Monats 23:59:59 Uhr.

Ein Jahr

Es wird auf ein ganzes Jahr gefiltert:
1.Januar des Jahres 00:00:00 Uhr bis 31. Dezember des Jahres 23:59:59 Uhr.

15 Minuten

Es wird auf einen Zeitbereich von 15 Minuten gefiltert.

30 Minuten

Es wird auf einen Zeitbereich von 30 Minuten gefiltert.

60 Minuten

Es wird auf einen Zeitbereich von 60 Minuten gefiltert.

Relativer Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein relativer Zeitraum in Tagen, Stunden (HH), Minuten (MM) und Sekunden (SS) angegeben werden kann.

Achtung! Der gewählte Zeitraum bezieht sich auf den Aufschaltzeitpunkt. Der gefilterte Zeitbereich wird daraufhin fest eingestellt.
Beispiel: Beim Aufrufen der Funktion ist es 10:23:00. Sie stellen einen relativen Zeitraum von einer Stunde ein. Der Filter wird auf 9:23:00 - 10:23:00 eingestellt.

Absoluter Zeitraum

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt mit dem ein absoluten Zeitraum eingeben könen . Sie legen dabei den Start- und Endzeitpunkt in Tag, Monat, Jahr, Stunde (HH), Minute (MM), Sekunde (SS) fest.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Chargen

Für diesen Filter müssen Sie die Option Filterdialog in der Runtime anzeigen auf der Registerkarte Allgemein aktiv gesetzt haben. Ist die Option nicht gesetzt wird der Zeitbereich in der Runtime auf 0 Sekunden eingestellt.

Beim Ausführen der Funktion wird ein Dialog angezeigt in dem Sie eine Charge auswählen können. Der Zeitfilter wird dann auf den Zeitraum der Charge eingestellt. Sie können damit z.B. nach allen Alarmen oder allen CEL Einträgen die während einer Charge aufgetreten sind filtern.

Hinweis: Der Filter zeigt nur abgeschlossene Chargen an.

Chargen relativ

Nur für Erweiterter Trend.

Darstellung geht immer von Nullpunkt aus. Ermöglicht direkten Vergleich mehrerer Chargen.

Optionen

Zu allen Zeitbereichen (ausgenommen absoluter und relativer Zeitbereich sowie Chargen) sind folgende Einstellungen möglich, um den Zeitbereich anzupassen:

Parameter

Option

Beschreibung

Letzten abgeschlossenen Zeitbereich verwenden

Aktiv: Es wird immer der aktuelle Zeitbereich verwendet. Ist die Option gesetzt wird der vorangegangene Zeitbereich angezeigt.

Beispiel: Sie haben einen 30 Minuten Filter eingestellt. Beim Aufschalten der Funktion ist es 10:45. Bei deaktivierter Option wird der Filter auf den aktuellen Zeitbereich 10:30:00 Uhr bis 10:59:59 Uhr gesetzt. Bei aktivierter Option wird der Filter auf den vorangegangenen Zeitbereich 10:00:00 Uhr bis 10:29:59 Uhr gesetzt.

Zeitbereich nach hinten verschieben um

Aktiv: Der gesamte Zeitbereich wird um die angegeben Zeit nach hinten verschoben. Der Zeitraum bleibt von dieser Einstellung unberührt.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. In der Runtime wird der Filter nun nicht zu jeder vollen Stunde beginnen, sondern immer 5 Minuten später, also z.B. um 10:05:00 Uhr um 11:05:00 Uhr usw. Gefiltert werden nach wie vor 60 Minuten also bis 11:04:59 Uhr bzw. 12:04:59 Uhr usw.

Zeit

Definiert die Zeitverschiebung in Stunden (HH), Minuten (MM), Sekunden (SS)

Zeitraum ändern um

Aktiv: Der gefilterte Zeitraum wird verkürzt oder verlängert.

Beispiel: Sie haben einen 60 Minuten Filter gewählt und geben hier eine Zeit von 5 Minuten an. Die Option angegeben Zeit dazuzählen ist gesetzt. In der Runtime

werden nun nicht mehr 60 Minuten gefiltert sondern 65 Minuten, also z.B. von 10:00:00 Uhr bis 11:04:59 Uhr.

Zeit

Definiert die Zeit, um die der Zeitraum verkürzt oder verlängert wird. In Stunden (HH), Minuten (MM), Sekunden (SS)

angegebene Zeit dazuzählen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verlängert

angegebene Zeit abziehen

Der ausgewählte Zeitbereich wird um die angegebene Zeit verkürzt

attention Achtung

Wird für die Alarmmeldeliste oder die Chronologische Ereignisliste im Editor beim Zeitfilter ein anderer Zeitbereich als Filter beim Zeitfiltertyp einstellen gewählt, kann zur Runtime die Zeit vom aufrufenden Bild nicht übernommen werden.


Chargen

Chargen

Die Chargenfilterung entspricht der Filterung in den Archiven:

Parameter

Beschreibung

Chargenfilter

Auf der linken Seite können Sie aus den verfügbaren Archiven das gewünschte auswählen. Auf der rechten Seite werden Ihnen die verfügbaren Chargen angezeigt. Sie haben die Möglichkeit dort die Chargen zu filtern.

Chargenname

In dieser Spalte werden Ihnen die Namen aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen alphabetisch aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie eine Zeichenfolge eingeben. Nur Chargen mit der jeweiligen Zeichenfolge werden angezeigt.

Startdatum

In dieser Spalte wird Ihnen das Startdatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Startzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Startdatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Startzeit

Nur verfügbar, wenn Sie ein Startdatum eingeben.

In dieser Spalte wird Ihnen die Startzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Startzeit manuell festlegen.

Hinweis: '*' bedeutet 0:00:00 Uhr.

Enddatum

In dieser Spalte wird Ihnen das Enddatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Endzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Enddatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Endzeit

Nur verfügbar, wenn Sie ein Enddatum eingeben.

In dieser Spalte wird Ihnen die Endzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Endzeit manuell festlegen.

Hinweis: '*' bedeutet 23:59:59 Uhr.

Dauer

Diese Spalte zeigt Ihnen die Dauer aller verfügbaren Chargen an. Sie dient nur der Anzeige.

info Info

Es werden auch noch nicht abgeschlossene Chargen angezeigt, falls sie den Filterkriterien entsprechen.

info Info

Der Wert der Chargenvariable wird beim Beginn der Charge sowohl in die Index-Datei also auch in den Header der ARX-Datei geschrieben. Bei jeder Änderung dieser Variable werden diese Einträge angepasst. Beim Abschließen der Charge wird der aktuelle Wert der Chargenvariable endgültig in die Index-Datei und in den Header geschrieben.

Erst wenn eine Charge abgeschlossen ist, ist der Chargenname festgeschrieben.


Verknüpfungen ersetzen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Reportfilter -> Verknüpfungen ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Verknüpfungen ersetzen

Verknüpfte Variablen oder Funktionen können im Editor regelbasiert dauerhaft ersetzt werden. Die Ersetzung beschränkt sich nicht auf die in den Eigenschaften der Gruppe Variable / Funktion definierten Variablen oder Funktionen. Es können auch alle anderen im Bild verwendeten Variablen, wie etwa Variablen für Sichtbarkeit, Blinken, Größe und Drehen dynamisch und andere. Das regelbasierte Ersetzen funktioniert auch für mehrere Elemente in einem Bild gleichzeitig und für Elemente mit eingebetteten Symbolen.

Interne ID: Verknüpfungen ersetzen

Größe und Drehen dynamisch

Eigenschaften zur Dynamik des Elements.
Die Darstellung des Elements wird über Zustände von Variablen zur Laufzeit dynamisch angepasst.

Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfungen ersetzen

Blinken

Eigenschaften für das Blinken des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfungen ersetzen

Sichtbarkeit

Eigenschaften für die Sichtbarkeit des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verknüpfungen ersetzen

Variable / Funktion

Eigenschaften für die mit dem Element verknüpfte Variable oder Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um Variablen oder Funktionen regelbasiert direkt am Element zu ersetzen:

  1. markieren Sie die gewünschten Element und öffnen Sie mit Rechtsklick auf ein Element das Kontextmenü
  2. wählen Sie Verknüpfungen ersetzen
  3. der Dialog zum Ersetzen von Verknüpfungen öffnet sich

Eigenschaft | Beschreibung
Quelle | Eingabe des zu suchenden Teilstrings. Platzhalter * und ? können verwendet werden. Platzhalter sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.
Ziel | Eingabe des neuen Teilstrings.
Name | Tauscht Information im Variablennamen.
Kennung | Tauscht Information in der Kennung.
Groß-/ Kleinschreibung beachten | Achtet beim Tausch auf exakte Übereinstimmung der Groß-/und Kleinschreibung.
Übernehmen | Tausch gesuchte Strings der Quelle gegen die in Ziel definierten.
Variable/Funktion | Öffnet die Auswahlliste für Variablen/Funktionen bezogen auf die ausgewählte Zeile in der Liste. Klick auf Variable in der Liste definiert neue Zielvariable. Alternativ: Doppelklick auf die entsprechende Quellvariable.

Ersetzen

a) Ersetzen mit manueller Auswahl

  • wählen Sie aus der Liste das Element, das sie ersetzen, möchten als Quelle
  • wählen Sie über die Schaltfläche Variable/Funktion ein Zielelement
  • das bisherige Element wird durch das neue ersetzt

b) Automatisiert ersetzen mit Regeln

  • definieren Sie im Eingabefeld Quelle die Parameter für die Elemente, die sie ersetzen möchten
  • definieren Sie über das Eingabefeld Ziel die Parameter für die neuen Variablen/Funktionen
  • legen Sie über Name/Kennung fest, was getauscht werden soll
  • klicken Sie auf Übernehmen

Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Beispiel:

Quelle: A;b

Ziel: C;d

info Info

Die Zielvariable bzw. Zielfunktion kann sich auch in einem anderen Projekt als die Quellvariable bzw. Quellfunktion befinden.

attention Achtung

Achten Sie beim Ersetzen von Variablen auf den Typ und die Signalauflösung. Wenn Sie eine Variable durch eine im Typ nicht kompatible ersetzen, kann das zu Fehlern in der Ausführung führen. Sie werden beim Ersetzen gewarnt, die Ersetzung wird aber durchgeführt.

info Info

Ersetzen per Drag&Drop: Elemente, die nur eine Variable oder Funktion enthalten können, erlauben den Austausch per Drag&Drop. Ziehen Sie mit der Maus die neue Variable oder Funktion auf das Element. Es ersetzt automatisch das bisherige.

Beispiel

Es sollen alle Variablen mit "Tank1"im Namen durch Variablen mit "Tank4" ersetzt werden.

  1. Geben Sie in das Textfeld Quelle "Tank1" ein. Mit dem Zeichen* schließen Sie alle Variablen ein, die mit "Tank1" beginnen.
  2. Geben Sie im Textfeld Ziel "Tank4" ein.
  3. Klicken Sie auf Übernehmen.
  4. Die Variablen Tank1_max und Tank1_min werden durch die Variablen "Tank4_max und Tank4_min ersetzt.


Indizes ersetzen

Indizes ersetzen

Bei der Bildumschaltung zur Runtime können Variablen über Indizierungsregeln dynamisch (virtuell) ersetzt werden. Dabei können Variablenwerte als Teil der Ersetzungsregel verwendet werden.

attention Achtung

Da die Namen ersetzt werden, müssen Variablen und Funktionen immer unterschiedlich benannt werden. Bei Namensgleichheit würden jeweils Variablen und Funktionen ersetzt werden.

Beispiel:

Existieren eine Variable "test" und eine Funktion "test" und die Variable "test" soll ersetzt werden, würde gleichzeitig auch die Funktion "test" ersetzt.

Tipp: Benennen Sie Variablen und Funktionen jeweils mit einem Präfix (z.B var_ und func_). Damit haben Sie auch in Listen immer Überblick.

Um die Ersetzung von Indizes zu projektieren:

  1. Im Feld Quelle der Ersetzungsvorschau werden alle im Bild verwendeten Variablen und Funktionen angezeigt.
  2. Führen Sie einen Linksklick auf die Variable oder Funktion aus, für die Sie eine Indizierungsregel erstellen möchten.
  3. Die Variable/Funktion wird im Bereich Indizierungsregeln ins Feld Quelle und Ziel eingetragen.
    Alternativ können Sie die gewünschte Variable/Funktion auch direkt ins Feld Quelle bei Indizierungsregeln eintragen.
  4. Definieren Sie die Indizierungsregel.
    Der dynamische Teil der Regel wird in geschwungene Klammern eingefügt, z.B. {X01}.

    Beispiel:

    Die Quellvariable Motor1.drehzahl wird durch das Ziel Motor{X01}.drehzahl ersetzt.
    Der Platzhalter X01 wird während der Runtime durch den jeweiligen Wert der Index-Variable ersetzt.
    Die Ersetzungsregel würde somit lauten:

    Quelle: Motor1

    Ziel: Motor{X01}

  5. Übernehmen Sie diese mit einem Linksklick auf Regel hinzufügen in die Liste der Indizierungsregeln.
  6. In dieser Liste werden alle angelegten Indizierungsregeln angezeigt.
  7. Über die Schaltflächen mit dem Pfeilsymbol verändern Sie die Reihenfolge der Einträge.

    Achtung: Die Ersetzungen werden der Reihenfolge der Darstellung in der Liste abgearbeitet!

  8. Variablen, die nicht im Bild vorhanden sind, aber bei der Ersetzung verwendet werden, können über die Schaltfläche Variablen hinzufügen... ins Fenster Indizierungsvariablen eingefügt werden.
  9. Die in dieser Liste aufgeführten Variablen werden immer im Speicher gehalten, damit sich bei der Bildaufschaltung keine unnötigen Wartezeiten ergeben.

info Info

Für den Platzhalter * gelten dieselben Regeln wie bei Verknüpfungen ersetzen.

attention Achtung

Wenn Indexvariablen in einem Netzwerkprojekt verwendet werden, muss der Client zuerst den Wert vom Server holen. Dann wird die Berechnung ausgeführt. Auf Geräten mit keiner guten Hardware kann dies zu Verzögerungen der Bildumschaltung führen.
Indexvariablen sollten daher in einem Netzwerkprojekt immer auf DDE aktiv geschalten werden.

Projektübergreifend

Wenn sich das Ziel in einem anderen Projekt befindet als die Quelle, kann dies mithilfe von '#' angezeigt werden.

Example Beispiel

Quelle: VAR_1

Ziel: VAR_1 in Projekt_1

Somit geben Sie als Quelle VAR_1 und als Ziel Projekt_1#VAR_1 ein.

Quelle: UNTERPROJEKT1#VAR_1

Ziel: {X01}VAR_1

Die Indexvariable X01 ist eine Stringvariable ist und hat zur Runtime den Projektnamen inklusive # als Wert, z.B. "UNTERPROJEKT4#".


Report drucken

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Report drucken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Report drucken ermöglicht den Ausdruck eines Reports ohne ihn vorher aufzuschalten. Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie im Abschnitt Report Generator den Eintrag Report drucken
  3. der Dialog für den Reportfilter wird geöffnet
  4. Hinweis: Die Einstellungen der Registerkarte Datei unterscheiden sich. Die für Report drucken gültigen Einstellungen werden in diesem Kapitel erklärt, alle weiteren Einstellungen finden Sie im Kapitel Reportfilter.
  5. wählen Sie die gewünschten Eigenschaften
  6. verknüpfen Sie die Funktion mit einem Button im Bild, um zur Runtime umzuschalten

Registerkarte Datei

Parameter | Beschreibung
Format-Datei | Auswahl der im Editor projektierten Reportdatei (*.xrs).
Diesen Dialog zur Runtime anbieten | Aktiv: Zur Runtime wird dieser Filterdialog vor dem Aufschalten angeboten.
Mit Abbrechen-Dialog | Aktiv: Während der Vorbereitung des Reports für den Druck wird eine Schaltfläche zum Abbrechen des Drucks eingeblendet.
Lese Archive vom Backupordner | Aktiv: Ausgelagerte Archive werden von dem in der ProjektkKonfiguration definierten Backupordner eingelesen.

info Info

Mit der Funktion Report drucken können Archiveinträge nur gelesen werden. Schreibaktionen sind nicht möglich.


Report exportieren

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Report exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann im Onlinebetrieb ein Report im Hintergrund auf eine Datei geschrieben werden. Die Exportdatei wird im Unterordner \Export des Projektordners abgelegt. (Öffnen aus zenon: Projekt markieren, Strg+Alt+D drücken.) Als Übergabeparameter sind die Dateiparameter, die Filter und die Zeit anzugeben.

Die Funktion Report exportieren ermöglicht den Export eines Reports in eine Datei ohne ihn vorher aufzuschalten. Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie im Abschnitt Report Generator den Eintrag Report exportieren
  3. der Dialog für den Reportfilter wird geöffnet
  4. Hinweis: Die Einstellungen der Registerkarte Datei unterscheiden sich. Die für Report exportieren gültigen Einstellungen werden in diesem Kapitel erklärt, alle weiteren Einstellungen finden Sie im Kapitel Reportfilter.
  5. wählen Sie die gewünschten Eigenschaften
  6. verknüpfen Sie die Funktion mit einem Button im Bild, um zur Runtime umzuschalten

info Info

Beim Export eines Reports über die Funktion Report exportieren werden bei Maßeinheiten die umgeschalteten Einheiten exportiert. Die Basiseinheiten sind nicht Teil des Exports.

Registerkarte Datei

Parameter

Beschreibung

Format-Datei

Auswahl der im Editor projektierten Reportdatei (*.xrs).

Diesen Dialog zur Runtime anbieten

Aktiv: Zur Runtime wird dieser Filterdialog vor dem Aufschalten angeboten.

Lese Archive vom Backupordner

Aktiv: Ausgelagerte Archive werden von dem in der ProjektkKonfiguration definierten Backupordner eingelesen.

Exportdatei

Eigenschaften der Datei, in die der Report exportiert wird.

Name

Name der Datei.
Maximal 8 alphanumerische Zeichen. Wird kein Name vorgegeben und ist die Automatische namensvergabe ausgeschaltet, wird automatisch der Name dummy verwendet.

Achtung: Die Verwendung von Sonderzeichen kann zu Datenverlusten führen.

Format

Format der Exportdatei.
  • TXT

Textdatei
  • XRS

zenon Reportdatei
  • XML

XML-Datei

Automatische Namensvergabe

Aktiv: Der Dateiname wird automatisch erstellt. Er setzt sich zusammen aus der Kurzkennung und dem kodierten Datum und der gewählten Dateiendung.

Kodierung Name für automatische Namensvergabe

Kode | Bedeutung
xx | Kurzkennung: 2 Zeichen Erste beide Zeichen des unter Name vergebenen Namens oder die vom System vorgegebenen Zeichen du.
JJ | Jahr: zweistellig
MM | Monat:: zweistellig
TT | Tag: zweistellig
HH | Stunde: zweistellig
MM | Minute: zweistellig
SS | Sekunde: zweistellig

Beispiel

  • Die Reportdatei Report wird am 9. 6. 2010 um 11:52 im Format XRS exportiert
  • Automatischer Dateiname: re100506091152.xrs

info Info

Mit der Funktion Report exportieren können Archiveinträge nur gelesen werden. Schreibaktionen sind nicht möglich.


Report ausführen

Handbuch -> Reporting -> Report Generator -> Projektieren im Editor -> zenon Funktionen für Report Generator -> Report ausführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Report ausführen ermöglicht es, zur Runtime einen Report automatisch im Hintergrund auszuführen. Ist in der Tabelle eine Schreibfunktion projektiert, können im Report berechnete Werte automatisch in Archive oder in das Prozessabbild geschrieben werden.

Um die Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie im Abschnitt Report Generator den Eintrag Report ausführen
  3. der Dialog für den Reportfilter wird geöffnet

    Hinweis: Die Einstellungen der Registerkarte Datei unterscheiden sich. Die für Report ausführen gültigen Einstellungen werden in diesem Kapitel erklärt, alle weiteren Einstellungen finden Sie im Kapitel Reportfilter.

  4. wählen Sie die gewünschten Eigenschaften
  5. verknüpfen Sie die Funktion mit einem Button im Bild, um zur Runtime umzuschalten

Registerkarte Datei

Parameter | Beschreibung
Format-Datei | Auswahl der im Editor projektierten Reportdatei (*.xrs).
Diesen Dialog zur Runtime anbieten | Aktiv: Zur Runtime wird dieser Filterdialog vor dem Aufschalten angeboten.
Mit Abbrechen-Dialog | Aktiv: Während der Vorbereitung des Reports für den Druck wird eine Schaltfläche zum Abbrechen des Drucks eingeblendet.
Lese Archive vom Backupordner | Aktiv: Ausgelagerte Archive werden von dem in der ProjektkKonfiguration definierten Backupordner eingelesen.

info Info

Mit dieser Funktion werden auch alle Schreibaktionen im Report ausgeführt.


Bedienen zur Runtime

Handbuch -> Reporting -> Report Generator -> Bedienen zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime werden die Reporte über die projektieren Buttons angezeigt, konfiguriert und verwaltet. Zur Runtime stehen folgende Bedienelemente zur Verfügung:

Parameter

Beschreibung

Vorlage einfügen...

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Buttons

Buttons zur Steuerung zur Runtime.

Refresh

Report vollständig neu aufbauen (Werte und Darstellung).

Drucken

Report zur Runtime ausdrucken.

Datei

Reportdatei auswählen und Filterbedingungen ändern.

Exportieren

Report exportieren.

Archiv speichern

Geänderte Werte ins Archiv zurückspeichern.

Report speichern

Report wird zur Runtime gespeichert (*.xrs).

Achtung: Beim Speichern werden Formeln und Funktionen durch die aktuellen Werte ersetzt. Die Funktionen stehen in diesen Reports (.xrs Dateien) nicht mehr zur Verfügung. Diese Reports können im Editor auch nicht mehr bearbeitet werden.

Empfehlung: Setzen Sie original Reportdateien auf den Dateistatus "schreibgeschützt" und speichern Sie Änderungen mit Speichern unter in einer neuen Datei.

Report speichern unter

Report wird zur Runtime unter einem neuen Namen gespeichert (*.xrs), wobei die Formeln und Funktionen durch die aktuellen Werte ersetzt werden.

Alle Werte lesen

Alle Werte werden vom Treiber neu eingelesen.

Selektierte Werte lesen

Ausgewählte Werte werden vom Treiber neu eingelesen.

Alle Werte absetzen

Alle Werte werden zum Treiber abgesetzt.

Selektierte Werte absetzen

Ausgewählte Werte werden zum Treiber abgesetzt.

Zeile nach oben

eine Zeile nach oben blättern

Zeile nach unten

eine Zeile nach unten blättern

Spalte nach rechts

eine Spalte nach rechts blättern

Spalte nach links

eine Spalte nach links blättern

Seite nach oben

eine Seite nach oben blättern

Seite nach unten

eine Seite nach unten blättern

Seite nach rechts

eine Seite nach rechts blättern

Seite nach links

eine Seite nach links blättern

Report

Kontrollelement für Reportdarstellung.

Report

Reportfenster zur Darstellung des Reports.

Filterprofile

Buttons für Filterprofile.

Profilauswahl

Anzeige der verfügbaren Filterprofile und Eingabe für neue Profilnamen.

Speichern

Speichert aktuelle Einstellung als Profil.

X (Speichern)

Löscht ausgewähltes Profil.

Import

Exportiert Profile.

Export

Importiert Profile.

info Info

Als Dezimaltrennzeichen wird ein Punkt verwendet. Bei der Eingabe kann sowohl Punkt als auch Komma verwendet werden. Das Trennzeichen wird vom System automatisch umgewandelt.

Beispiel: Aus 10,5 wird 10.5

Noch in diesem Kapitel

Filter bei Bildumschaltung


Filter bei Bildumschaltung

Handbuch -> Reporting -> Report Generator -> Bedienen zur Runtime -> Filter bei Bildumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie ein Bild vom Typ Report aufschalten, wird Ihnen folgender Filter angezeigt

Parameter

Beschreibung

Chargenfilter

Auf der linken Seite können Sie aus den verfügbaren Archiven das gewünschte auswählen. Auf der rechten Seite werden Ihnen die verfügbaren Chargen angezeigt. Sie haben die Möglichkeit dort die Chargen zu filtern.

Chargenname

In dieser Spalte werden Ihnen die Namen aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen alphabetisch aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie eine Zeichenfolge eingeben. Nur Chargen mit der jeweiligen Zeichenfolge werden angezeigt.

Startdatum

In dieser Spalte wird Ihnen das Startdatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Startzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Startdatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Startzeit

Nur verfügbar, wenn Sie ein Startdatum eingeben.

In dieser Spalte wird Ihnen die Startzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Startzeit manuell festlegen.

Hinweis: '*' bedeutet 0:00:00 Uhr.

Enddatum

In dieser Spalte wird Ihnen das Enddatum aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend. Dabei werden Chargen mit dem gleichen Datum nach der Endzeit sortiert.

Im unteren Teil der Kopfzeile können Sie das Enddatum manuell festlegen oder mithilfe des angezeigten Kalenders auswählen.

Endzeit

Nur verfügbar, wenn Sie ein Enddatum eingeben.

In dieser Spalte wird Ihnen die Endzeit aller verfügbaren Chargen angezeigt. Durch einen Linksklick auf den oberen Teil der Kopfzeile, sortieren Sie die Chargen aufsteigend oder absteigend.

Im unteren Teil der Kopfzeile können Sie die Endzeit manuell festlegen.

Hinweis: '*' bedeutet 23:59:59 Uhr.

Dauer

Diese Spalte zeigt Ihnen die Dauer aller verfügbaren Chargen an. Sie dient nur der Anzeige.

info Info

Es werden auch noch nicht abgeschlossene Chargen angezeigt, falls sie den Filterkriterien entsprechen.

info Info

Der Wert der Chargenvariable wird beim Beginn der Charge sowohl in die Index-Datei also auch in den Header der ARX-Datei geschrieben. Bei jeder Änderung dieser Variable werden diese Einträge angepasst. Beim Abschließen der Charge wird der aktuelle Wert der Chargenvariable endgültig in die Index-Datei und in den Header geschrieben.

Erst wenn eine Charge abgeschlossen ist, ist der Chargenname festgeschrieben.


Beispiel Archivdaten in Reports

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Beispiel erstellen Sie Archivdaten in einem Report. Dazu:

  1. erstellen Sie einen neuen Report über das Kontextmenü und den Eintrag Report neu
  2. gestalten Sie den Titelbereich
  3. befüllen Sie den Datenenbereich
  4. legen Sie ein Bild vom Typ Report an und erstellen Sie eine Funktion

Noch in diesem Kapitel

Titelbereich

Datenbereich

Report zur Runtime anzeigen


Titelbereich

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Titelbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Titelbereich enthält in den ersten vier Zeilen:

  • Texte als Überschriften für die Daten
  • Datum und Uhrzeit
  • Firmenlogo

Der Titelbereich wird so formatiert, dass er bei längeren Reports fix bleibt und beim Scrollen nicht aus dem Blickfeld verschwindet.

Noch in diesem Kapitel

Texte

Datum und Uhrzeit

Bilder als Firmenlogo

Fixer Titelbereich bei mehrseitigen Reports


Texte

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Titelbereich -> Texte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Tragen Sie folgende Texte als Überschriften für den Report ein:

  • Time
  • Hall 1
    • Tank 1
    • Tank 2
  • Hall 2
    • Tank 1
    • Tank 2


Datum und Uhrzeit

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Titelbereich -> Datum und Uhrzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Datum und Uhrzeit des Reports werden für die Zellen A1 und E1 mit Report-Funktionen projektiert. Dazu:

  1. tragen Sie in A1 und E1 fügen jeweils die Funktion =now() ein.
  2. in beiden Zellen wird nun das aktuelle Datum angezeigt
  3. um in E1 statt dessen die Uhrzeit zu bekommen, müssen Sie die Formatierung der Zelle ändern:
    1. markieren Sie die Zelle E1
    2. öffnen Sie den Format-Dialog über das Menü Format/Zellen/Zahlen
    3. wählen Sie den Formatierungs-String wie in folgender Abbildung dargestellt

  4. das Ergebnis:


Bilder als Firmenlogo

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Titelbereich -> Bilder als Firmenlogo

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bilder in Zellen werden vom Report Generator nicht als Zellinhalt sondern als Formatierung behandelt. Daher erfolgt die Projektierung auch über die Zellformatierung:

  1. importieren Sie das gewünschte Bild im Projektmanager in den Knoten Dateien/Grafiken
  2. wählen Sie die Zelle E2 mit der linken Maustaste aus
  3. öffnen Sie mit der rechten Maustaste das Kontextmenü des Reports und wählen Sie den Befehl Zellen formatieren
  4. wechseln Sie in der Dialogbox auf die Seite Zellentyp
  5. ändern Sie den Zellentyp auf Grafikdatei
  6. wählen Sie das gewünschte Bild aus der Dropdownliste auf der rechten Seite aus

  7. das Ergebnis:


Fixer Titelbereich bei mehrseitigen Reports

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Titelbereich -> Fixer Titelbereich bei mehrseitigen Reports

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um bei mehrseitigen Reports die Zeilen- und Spaltentitel immer im Blick zu haben, müssen Sie verhindern, dass diese beim Scrollen im Report mit bewegt werden. Dazu definieren Sie feste Titelbereiche.

Um die Zeilentitel zu fixieren:

  1. wählen Sie im Menü Format den Befehl Report aus
  2. der Konfigurationsdialog wird geöffnet
  3. öffnen Sie die Registerkarte Spalten

    Neben der Gesamtanzahl der Spalten können Sie hier auch die Anzahl der Statischen Spalten angeben. Die festgelegte Anzahl der statischen Spalten wird dann nicht mehr aus dem Bild gescrollt.

  4. tragen Sie unter Statische Spalten eine 1 ein.
  5. wechseln Sie auf die Registerkarte Zeilen:

    Bei den Zeilen stehen unsere Spaltenüberschriften in den Zeilen 1 bis 4:

  6. tragen Sie unter Statische Zeilen eine 4 ein.
  7. bestätigen Sie alle Änderungen mit Klick auf die Schaltfläche OK


Datenbereich

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Datenbereich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Datenbereích:

  • projektieren Sie die Anzeige von Zeit und Werten
  • lassen Sich sich Summe und Mittelwert anzeigen

Noch in diesem Kapitel

Zeit

Werte

Summe und Mittelwert


Zeit

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Datenbereich -> Zeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Spalte A wird die Zeit der angezeigten Archivwerte dargestellt.

info Info

Als Basis wählen wir ein zyklisches Archiv. Damit erfolgen die Einträge aller Variablen zur gleichen Zeit und es genügt eine Zeit-Spalte für alle Einträge.

Um die Zeit zu projektieren:

  1. markieren Sie die Zelle A5.
  2. wählen sie im Menü Format den Befehl Funktionsassistent
  3. der Funktionsassistent wird geöffnet

  4. wählen Sie die Funktion archive mit einem Doppelklick aus
  5. die Schaltfläche Archiv wird im unteren Bereich des Dialogs angezeigt

  6. klicken Sie auf Archiv
  7. der Dialog zur Archivauswahl wird geöffnet:

  8. klicken Sie auf Neu
  9. die im Knoten Archivserver angelegten Archive werden angezeigt
  10. wählen Sie die Variablen wie im Screenshot dargestellt aus

  11. klicken Sie auf Speichern
  12. wählen Sie die Variable H1_Tank1 aus

  13. bestätigen Sie die Auswahl mit Klick auf OK
  14. der Funktionsassistent wird wieder angezeigt
  15. wählen Sie als Parameter zeit mit einem Doppelklick aus

  16. wählen Sie den Parameter unten mit einem Doppelklick aus
  17. die Funktion ist fertig projektiert (=archive(1,"zeit","unten")

  18. beenden Sie den Assistenten mit Klick auf die Schaltfläche OK

In der Spalte A wird damit ab Zeile 5 die Zeit der Variablenarchivierung nach unten fortgeschrieben.

info Info

Die Parameter müssen immer mit einem Doppelklick ausgewählt werden. Erst wenn die Funktion in der Vorschau mit einer Klammer abgeschlossen ist und keine weiteren Parameter mehr angeboten werden, ist sie vollständig parametriert. Wird die Schaltfläche OK betätigt bevor alle Parameter gewählt wurden, wird der Assistent geschlossen, bevor die Funktion fertig parametriert ist!


Werte

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Datenbereich -> Werte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Werte für die Tanks in Halle 1 und 2 projektieren Sie analog zur Projektierung der Zeit. Beachten Sie dabei folgende unterschiede:

  • Die Archiv-Variablen müssen nicht mehr angelegt werden. Sie existieren bereits und können sofort ausgewählt werden. Weisen Sie jedem Tank die entsprechende Variable zu.
  • Statt dem Parameter zeit wählen Sie den Parameter wert.

Funktion kopieren

Sobald Sie eine Funktion erstellt haben, können Sie sie in die anderen Zellen kopieren und dann entsprechend editieren:

Dazu:

  1. markieren Sie die zu ändernde Zelle
  2. klicken dann in die Editierzeile
  3. in der Funktion, die nun angezeigt wird, verweisen die Referenznummer auf die entsprechenden Archivvariablen an, wie sie in der Archivauswahl beim ersten Anlegen einer Funktion automatisch vergeben werden
  4. ersetzen Sie daher die 1 als ersten Parameter in der Spalte C durch eine 2
    in der Spalte D durch eine 3
    und in der Spalte E durch eine 4


Summe und Mittelwert

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Datenbereich -> Summe und Mittelwert

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für diesen Report proejktieren Sie nun die Anzeige von Summe und Mittelwert.

Dazu müssen Sie ermitteln, wie viele Zeilen für die Archiveinträge benötigt werden. Diese definieren Sie bereits im Report Generator. Die Anzahl der Einträge in der Liste hängt von den Filter-Einstellungen ab, mit denen der Report später aufgerufen wird (Funktionen Report ausführen, Report drucken, Report exportieren) .

In unserem Beispiel werden wir einen Zeitbereich von 2 Minuten auswählen. Da unser Archiv im Zyklus von5 Sekunden Werte aufnimmt, ergeben sich 24 Einträge für den Report. Daher:

  1. tragen Sie in Zelle A29 den Text Summe: ein
  2. tragen Sie in Zelle A30 den Text Mittelwert: ein
  3. fügen Sie in Zelle B29 die Funktion =sum(B5:B25) ein
  4. fügen Sie in Zelle B30 die Funktion =avg(B5:B25) ein.
  5. kopieren Sie die Zelle B29 nach C29, D29 und E29
  6. kopieren Sie die Zelle B30 nach C30, D30 und E30
  7. speichern Sie den Report unter dem Namen Archiv.xrs ab

info Info

Bei der Eingabe der Funktionen können Sie Zellbezeichnungen entweder eintippen oder die Entsprechende Zelle mit der Maus anklicken.

Wenn Sie im Report Generator Funktionen mit Zellenbezügen kopiert, werden die Zellbezüge automatisch angepasst.


Report zur Runtime anzeigen

Handbuch -> Reporting -> Report Generator -> Beispiel Archivdaten in Reports -> Report zur Runtime anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Report in der Runtime ansehen zu können, benötigen Sie:

  • ein Bild vom Typ Report
  • eine Funktion Bildumschaltung

Bild vom Typ Report anlegen

Um ein Bild vom Typ Report anzulegen:.

  1. legen Sie ein neues Bild mit dem Namen Report an
  2. wählen Sie alsr Bildtyp Report
  3. wählen Sie die Schablone MAIN
  4. klicken Sie in das neue Bild
  5. wählen Sie im Menü Kontrollelemente den Befehl Default
  6. ergänzen Sie eventuell weitere benötigte Kontrollelemente

Funktion erstellen

Erstellen Sie eine Funktion Bildumschaltung, um das Bild zur Runtime aufzuschalten. Dazu:

  1. fügen Sie einen neuen Button in das Startbild ein
  2. beschriften Sie ihn mit Report
  3. wechseln Sie zum Knoten Funktionen

    legen Sie eine neue Funktion an

  4. wählen Sie Bildumschaltung
  5. wählen Sie das Bild Report aus
  6. der Reportfilter wird geöffnet

  7. klicken Sie auf die Schaltfläche Format-Datei
  8. wählen Sie Archiv.xrs aus
  9. öffnen Sie die Registerkarte Zeit

  10. Setzen Sie für unser Beispiel
    1. das Zeit-Format auf Relativer Zeitraum und
    2. die Zeit auf 2 Minuten.

    Mehr über Zeitfilter lesen Sie im Handbuch Alarmverwaltung im Kapitel Zeitfilter

  11. schließen Sie den Filter mit Klick auf OK
  12. weisen Sie die Funktion dem projektierten Button zu
  13. starten Sie die Funktion zur Runtime


Report Viewer

Handbuch -> Reporting -> Report Viewer

Der Report Viewer dient dem Anzeigen von RDL-Reports von Archiv-, AML-, und CEL-Daten sowie Online-Werten. Über zwei konfigurierbare Zeitbereiche können auch zwei historische Zeitbereiche einander gegenüber gestellt werden.

RDL-Dateien, die die Reportvorlage für die Runtime darstellen, werden im Editor angelegt und bearbeitet. Im mitgelieferten Standardreport stehen bereits 7 vordefinierte Datasets zu Verfügung. Weitere Datasets können frei angelegt werden, lediglich das Tabellenschema für die vier Datenkategorien ist fest vorgegeben.

In der Bildumschaltungsfunktion auf das Bild vom Typ Report Viewer werden die Quelldaten definiert, die in der Runtime die im RDL-File angelegten Datasets versorgen. Für jeden in der RDL-Datei verwendeten Dataset muss in der Bildumschaltung ein Dataset mit gleichem Namen und gleicher Datenherkunft erzeugt werden. Für diesen können je nach Typ die Quellvariablen und Filterkriterien vorgegeben werden.

Typische Projektierungsschritte:

  1. Report Definitionsdatei neu anlegen oder importieren
  2. Bild vom Typ Report Viewer anlegen
  3. Bildumschaltungsfunktion erzeugen und Datasets konfigurieren
  4. RDL-Datei konfigurieren
  5. zur Runtime Funktion über Button oder Menü aufrufen

Noch in diesem Kapitel

Projektieren im Editor

Report Definitionsdateien

Bedienen zur Runtime

Fehlerbehandlung


Projektieren im Editor

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Report Viewer zur Runtime einsetzen zu können, müssen Sie im Editor:

  1. ein Bild vom Typ Report Viewer anlegen
  2. eine RDL-Datei erstellen oder importieren, sofern noch keine vorhanden ist
  3. eine Bildumschaltungsfunktion auf das Bild vom Typ Report Viewer anlegen
  4. in der Bildumschaltung die Datasets konfigurieren
  5. die Report Definitionsdatei (RDL) an die in zenon definierten Datasets anpassen
  6. einen Button für dem Aufruf des Report Viewers zur Runtime in das Startbild oder Menü-Bild einfügen

Ordner für Report Definitionsdateien (RDL)

RDL-Dateien werden im Projektbaum im Knoten Dateien/Report Viewer abgelegt. Bereits vorhandene RDL-Dateien können hier importiert und bearbeitet werden oder neue Dateien angelegt werden.

Kontextmenü Reportvorlagen

Menüpunkt | Aktion
Report Definitionsdatei neu | Erstellt eine neue RDL-Dateien auf Basis der mitgelieferten default.rdl.
Report Definitionsdatei öffnen | Öffnet die mit RFL-Dateien verknüpfte Software zum Bearbeiten einer bestehenden Definitionsdatei. Standardmäßig sucht zenon erst nach dem MS Report Builder, dann nach dem MS Report Designer.
Zurück zu Ausgangselement springen | Springt bei verknüpften Elementen zurück zu dem Element, von dem aus die Reportvorlage angesprungen wurde. Im Kontextmenü nur vorhanden, wenn verknüpfte Elemente vorhanden sind.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Bestehende Report Definitionsdatei importieren | Öffnet Dialog zum Import bestehender Report Definitionsdateien. Diese müssen vom Typ RDL 2.0 sein.
Alle Filter entfernen | Löscht alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Bild vom Typ Report Viewer anlegen

Bildumschaltung auf Bild vom Typ Report Viewer


Bild vom Typ Report Viewer anlegen

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bild vom Typ Report Viewer anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Report Viewer anzulegen:

  1. erstellen Sie ein neues Bild
  2. wählen Sie inder Dropdownliste den speziellen Bildtyp Report Viewer aus
  3. benennen Sie das Bild
  4. wählen Sie im Menü Kontrollelemente den Befehl Vorlage einfügen
  5. die Standardelemente werden automatisch angelegt und platziert

Parameter | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Reportfenster | Funktionen und Profile für den Report.
Aktualisieren | Lädt die Reportdefinition und die Daten neu und zeigt den den Report mit den aktualisierten Daten an.
Drucken | Druckt den Report auf dem für Werte und Protokolle definierten Drucker aus.
PDF erzeugen | Speichert den aktuell angezeigten Report als PDF-Datei im für den Export definierten Ordner.


Bildumschaltung auf Bild vom Typ Report Viewer

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bildumschaltung auf Bild vom Typ Report Viewer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Report Viewer zur Runtime zu nutzen, projektieren Sie eine Bildumschaltung auf ein Bild vom Typ Report Viewer:

  1. erstellen Sie ein neues Bild vom Typ Report Viewer
  2. wählen Sie im Knoten Funktionen im Kontextmenü den Eintrag Funktion neu
  3. wählen Sie die Funktion Bildumschaltung
  4. wählen Sie das Bild vom Typ Report Viewer
  5. der Reportfilter wird angezeigt
  6. wählen Sie die RDL-Datei aus
  7. definieren Sie die Zeitfilter
  8. erstellen Sie die gewünschten Datasets
  9. verknüpfen Sie die Funktion mit einem Button im Bild, um zur Runtime umzuschalten
  10. bearbeiten Sie die Datasets in der RDL-Datei entsprechend Ihren Einstellungen in der Bildumschaltung

Parameter

Beschreibung

Datei für Reportdefinition

RDL-Datei, die für die Reportdefinition benutzt wird. Diese Datei muss im Knoten Datei/Reportvorlagen vorliegen. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl der Datei.

Datasets

Anzeige der definierten Datasets. Die Liste enthält:

  • Dataset-Name
  • Datenherkunft
  • Zeitfilter:
    - Zeitfilter 1
    - Zeitfilter 2

Neu

Öffnet Dialog zur Erstellung einer neuen Reportdefinition.

Bearbeiten

Öffnet Dialog zur Bearbeitung der Definition des ausgewählten Elements.

Löschen

Löscht ausgewähltes Element mit dessen Definiton aus der Liste.

OK

Übernimmt alle Änderungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.

Zeitfilter

Es stehen zwei Zeitfilter zur Verfügung. Damit können zwei historische Bereiche verglichen werden.

Die Zeitfilterung kann prinzipiell auf zwei Arten erfolgen:

  1. Zeitbereich im Editor vorgeben
    Es werden fixe Zeitbereiche verwendet. Im Editor wird ein Zeitbereich vorgegeben. In der Runtime kann nur mehr nach diesem Zeitbereich gefiltert werden. Auch andere Filter - z.B. Filtern nach Variablenname, Alarm/Ereignis-Gruppen und -Klassen usw. - sind zur Runtime nicht mehr anpassbar.
  2. Zeitfilter zur Runtime anpassbar
    Es werden vorprojektierte Zeiten verwendet. Der Zeitfilter wird im Editor vorgegeben und kann zur Runtime beliebig verändert werden.

Details zur Konfiguration der Zeitfilter lesen Sie im Handbuch Alarmverwaltung im Kapitel Zeit.

Hinweis: Wird als Zeitfiltertyp die Option Kein Zeitfilter, dann werden werden zur Runtime alle Einträge seit 1. 1. 2000 angezeigt.

Noch in diesem Kapitel

Dialog Dataset neu

Datasets im Report Viewer


Dialog Dataset neu

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bildumschaltung auf Bild vom Typ Report Viewer -> Dialog Dataset neu

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein neues Dataset zu definieren:

  1. definieren Sie in der Bildumschaltung auf ein Bild vom Typ Report Viewer die zu Grunde liegende RDL-Datei
  2. klicken Sie auf die Schaltfläche Neu
  3. der Dialog zum Anlegen der Datasets wird geöffnet
  4. wählen Sie die gewünschte Datenherkunft
  5. bestätigen Sie die Auswahl mit Klick auf OK
  6. der Dialog zur Konfiguration des definierten Typs wird geöffnet

Parameter

Beschreibung

Datenherkunft

Auswahl der Datenherkunft:

  • Alarmmeldeliste
  • Chronologische Ereignisliste
  • Archivwerte
  • Online-Werte

OK

Bestätigt Auswahl und öffnet Dialog zur Konfiguration des Typs.

Abbrechen

Schließt Dialog ohne weitere Konfiguration.

Hilfe

Öffnet Online-Hilfe.


Datasets im Report Viewer

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bildumschaltung auf Bild vom Typ Report Viewer -> Datasets im Report Viewer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Einstellungen für die unterschiedlichen Datasets hängen ab vom Typ der zu konfigurierenden Datenherkunft:

  • Online-Werte
  • AML-Daten
  • CEL-Daten
  • Archiv-Daten

Noch in diesem Kapitel

Online-Werte

AML-Daten

CEL-Daten

Archivwerte


Online-Werte

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bildumschaltung auf Bild vom Typ Report Viewer -> Datasets im Report Viewer -> Online-Werte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Online-Werte

Parameter

Beschreibung

Dataset-Name

Name des Datasets:

  • muss exakt mit dem Namen des Datasets in der RDL-Datei übereinstimmen
  • darf keine Leerzeichen oder Sonderzeichen enthalten.

Variablen

Liste der ausgewählten Variablen mit:

  • Name
  • Kennung
  • Adresse
  • Projekt

Hinzufügen

Öffnet Dialog zur Auswahl mehrerer Variablen.

Entfernen

Löscht selektierte Variable aus Liste.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


AML-Daten

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bildumschaltung auf Bild vom Typ Report Viewer -> Datasets im Report Viewer -> AML-Daten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
AML-Daten

Parameter

Beschreibung

Dataset-Name

Name des Datasets:

  • muss exakt mit dem Namen des Datasets in der RDL-Datei übereinstimmen
  • darf keine Leerzeichen oder Sonderzeichen enthalten.

Zeitfilter

Auswahl des Zeitfilters. Kann zum Vergleich zweier Zeiträume einer Datenherkunft verwendet werden:

  • Zeitfilter 1
  • Zeitfilter 2

Registerkarte Allgemein

Einstellungen für:

  • Variablenfilter
  • Alarmart
  • Datenherkunft
  • Alarm/Ereignis-Gruppen, Alarm/Ereignis-Klassen und Alarmbereiche

Details siehe Handbuch Alarmverwaltung, Kapitel Allgemein.

Registerkarte Text

Einstellungen für Textfilter.

Details siehe Handbuch Alarmverwaltung, Kapitel Text.

Registerkarte Status

Angaben über Auswertung der Statusbits.

Details siehe Handbuch Alarmverwaltung, Kapitel Status .

Registerkarte Anlagenmodellierung

Details siehe HandbuchAnlagenmodellierung, Kapitel Dialog Anlagenmodellierung

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


CEL-Daten

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bildumschaltung auf Bild vom Typ Report Viewer -> Datasets im Report Viewer -> CEL-Daten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
CEL-Daten

Parameter

Beschreibung

Dataset-Name

Name des Datasets:

  • muss exakt mit dem Namen des Datasets in der RDL-Datei übereinstimmen
  • darf keine Leerzeichen oder Sonderzeichen enthalten.

Zeitfilter

Auswahl des Zeitfilters. Kann zum Vergleich zweier Zeiträume einer Datenherkunft verwendet werden:

  • Zeitfilter 1
  • Zeitfilter 2

Registerkarte Allgemein

Einstellungen für:

  • Variablenfilter
  • Datenherkunft
  • Alarm/Ereignis-Gruppen, Alarm/Ereignis-Klassen und Alarmbereiche

Details siehe Handbuch Chronologische Ereignisliste, Kapitel Allgemein.

Registerkarte Text

Einstellungen für Textfilter.

Details siehe Handbuch Alarmverwaltung, Kapitel Text.

Registerkarte Status

Angaben über Auswertung der Statusbits.

Details siehe Handbuch Alarmverwaltung, Kapitel Status .

Registerkarte Anlagenmodellierung

Details siehe HandbuchAnlagenmodellierung, Kapitel Dialog Anlagenmodellierung

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Archivwerte

Handbuch -> Reporting -> Report Viewer -> Projektieren im Editor -> Bildumschaltung auf Bild vom Typ Report Viewer -> Datasets im Report Viewer -> Archivwerte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Archivwerte

Parameter

Beschreibung

Dataset-Name

Name des Datasets:

  • muss exakt mit dem Namen des Datasets in der RDL-Datei übereinstimmen
  • darf keine Leerzeichen oder Sonderzeichen enthalten.

Zeitfilter

Auswahl des Zeitfilters. Kann zum Vergleich zweier Zeiträume einer Datenherkunft verwendet werden:

  • Zeitfilter 1
  • Zeitfilter 2

Archiv - Variablenname

Liste der ausgewählten Variablen.

Hinzufügen

Öffnet Dialog zur Auswahl mehrerer Variablen.

Entfernen

Löscht selektierte Variable aus Liste.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Report Definitionsdateien

Handbuch -> Reporting -> Report Viewer -> Report Definitionsdateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Report Definitionsdateien (RDL) müssen vom Typ 2 sein, um sie im zenon Report Viewer verwenden zu können . Typ 3 RDL-Dateien können zwar angezeigt werden, allerdings werden Features, die in Version 2 nicht vorhanden sind, als leere Fläche dargestellt.

Um eigene Datasets zu erstellen oder vorhandene zu bearbeiten, benötigen Sie entsprechende Software zum Rendern der RDL-Dateien. Dazu stehen Ihnen drei Optionen offen:

  • Microsoft Business Intelligence Development Studio:

    Wird von COPA-DATA mitgeliefert und bei der Installation von zenon mitinstalliert.

    Das Business Intelligence Development Studio besteht aus MicrosoftVisual Studio 2008 mit weiteren Projekttypen, die nur für SQL Server Business Intelligence verfügbar sind. Das Business Intelligence Development Studio ist die primäre Umgebung für Business Services Projekte wie Reporting. Es werden Vorlagen zum Erstellen der für Business Intelligence-Lösungen erforderlichen Objekte sowie Designer, Tools und Assistenten zur Verarbeitung dieser Objekte bereit gestellt.

  • Microsoft Report Builder 2.0:

    Steht auf der Microsoft Downloadseite zum Download bereit. Er stellt einen Wizard zur Konfiguration der Datasets zur Verfügung und wird für Anwender ohne spezielle Kenntnisse für die Konfiguration von RDL-Dateien empfohlen.
    Achtung: Beachten Sie vor dem Download die Microsoft Lizenzbedingungen!
    Anwender des zenon Analyzer verfügen bereits über der Report Builder 3 und die für den Report Builder benötigte SQL-Lizenz. Allerdings muss für die Bearbeitung der Datasets des Report Viewers der Report Builder 2 installiert und verwendet werden.

  • Software anderer Anbieter:

    Für die Bearbeitung der Report Definitionsdateien kann auch Software anderer Hersteller eingesetzt werden.

Sind sowohl der MS Report Builder als auch das Microsoft Business Intelligence Development Studio installiert, kann in einem Dialog das gewünschte Tool ausgewählt werden.

attention Achtung

Beachten Sie:

  • RDL-Dateien sollten immer mit dem gleichen Tool erzeugt und bearbeitet werden.
  • Die RDL-Versionen 2 und 3 dürfen nicht gemischt werden.
  • Wurde eine RDL-Datei mit dem Microsoft Business Intelligence Development Studio 2008R2 gespeichert, kann sie mit dem MS Report Builder 2.0 nicht mehr bearbeitet werden.

DataSource

Die Eigenschaften der Datasource (den Datasets übergeordnet) dürfen nicht verändert werden.

Die Standardeinstellungen sind:

Parameter | Beschreibung
Name | DataSource1
Connection | Use a connection embedded in my report
Select connection type | XML

Noch in diesem Kapitel

Default.rdl

RDL-Dateien mit MS Report Builder 2.0 erstellen und bearbeiten

RDL-Dateien mit dem Microsoft Business Intelligence Development Studio erstellen und bearbeiten

Datasets Definition


Default.rdl

Handbuch -> Reporting -> Report Viewer -> Report Definitionsdateien -> Default.rdl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die default.rdl wird aufgerufen, wenn im Editor eine neue RDL-Datei erstellt wird. In der mitgelieferten default.rdl stehen bereits 7 vordefinierte Datasets zu Verfügung, die in der Runtime mit Daten versorgt werden können:

  • Online Werte
  • AML mit Zeitfilter 1
  • AML mit Zeitfilter 2
  • CEL mit Zeitfilter 1
  • CEL mit Zeitfilter 2.
  • Archivwerte mit Zeitfilter 1
  • Archivwerte mit Zeitfilter 2

Werden mehr Datasets benötigt, so können diese mit beliebigem Namen angelegt werden. Werden weniger Datasets benötigt, müssen diese aus der RDL-Datei gelöscht werden. Die Namen der Datasets müssen mit den Dataset-Namen in der Bildumschaltung übereinstimmen.

Hinweis: Das Tabellenschema für die 4 Datenkategorien ist fest vorgegeben und darf nicht modifiziert werden.


RDL-Dateien mit MS Report Builder 2.0 erstellen und bearbeiten

Handbuch -> Reporting -> Report Viewer -> Report Definitionsdateien -> RDL-Dateien mit MS Report Builder 2.0 erstellen und bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der MS Report Builder steht auf der Microsoft Downloadseite zum kostenlosen Download bereit.
Achtung: Beachten Sie vor dem Download die Microsoft Lizenzbedingungen!
Anwender des zenon Analyzer verfügen bereits über der Report Builder 3 und die für den Report Builder benötigte SQL-Lizenz. Allerdings muss für die Bearbeitung der Datasets des Report Viewers der Report Builder 2 installiert und verwendet werden.

Installieren Sie den Report Builder und überprüfen Sie, ob er korrekt mit zenon verknüpft wurde.

RDL-Datei erstellen

Um eine neue RDL-Datei zu erstellen:

  1. Wählen Sie im zenon Editor im Knoten Datei/Report Viewer im Kontextmenü oder in der Symbolleiste den Befehl Report Definitionsdatei neu. Basierend auf einer Default-Datei wird ein neue Report Definitionsdatei erstellt.
  2. Mit einem Doppelklick auf die Datei starten Sie den Report Builder.

  3. Passen sie die Datatsets an die Projektierung in der Bildumschaltungsfunktion an, durch:
    • umbenennen: Datasets müssen ident mit den Dataset-Namen in der Bildumschaltung benannt sein
    • löschen: Datasets, die in der Bildumschaltung keine entsprechende Verknüpfung haben und damit nicht mit Daten versorgt werden, führen in der Runtime zu einer Fehlermeldung
    • neu anlegen: Datasets, die in der Bildumschaltung konfiguriert wurden, aber keine Entsprechung in der RDL-Datei haben, führen in der Runtime zu einer Fehlermeldung.
  4. Wählen Sie im Menü Insert den Befehl Table -> Table Wizard.
  5. Der Wizard wird gestartet.
  6. Wählen Sie das gewünschte Dataset.

  7. Platzieren Sie die Felder wie gewünscht.

  8. Klicken Sie auf Next und wählen Sie das Layout aus.

  9. Klicken Sie auf Next und wählen Sie den Stil der Darstellung aus.

  10. Klicken Sie auf Finish.
    Das Dataset wird mit der fertigen Tabelle angezeigt

  11. Löschen Sie die Muster-Tabelle.
  12. Platzieren Sie die neu erstellte Tabelle am gewünschten Ort.
  13. Passen Sie die Überschrift nach Wunsch an.

  14. Wiederholen Sie den Vorgang für alle zu konfigurierenden Datasets.
  15. Speichern Sie die RDL-Datei.

Ergebnis zur Runtime:

RDL-Datei bearbeiten

Um eine RDL-Datei zu bearbeiten, doppelklicken Sie die Datei oder wählen Sie den Befehl Report Definitionsdatei öffnen. Gehen Sie beim Bearbeiten analog dem Erstellen vor.

Noch in diesem Kapitel

Datasets verwalten


Datasets verwalten

Handbuch -> Reporting -> Report Viewer -> Report Definitionsdateien -> RDL-Dateien mit MS Report Builder 2.0 erstellen und bearbeiten -> Datasets verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Datasets können Sie im Report Builder:

  • umbenennen
  • löschen
  • neu erstellen

Anzahl und Benennung der Datasets einer RDL-Datei muss immer mit den in der Bildumschaltung definierten Datasets übereinstimmen.

attention Achtung

Beachten Sie:

  • Die Datasource darf nicht editiert werden.
  • Die Tabellen dürfen nicht editiert werden.

Dataset umbennnen

Um ein Dataset umzubenennen:

  1. führen Sie einen Rechtsklick auf das Dataset aus
  2. wählen Sie im Kontextmenü den Befehl Dataset Properties
  3. der Dialog zur Einstellung der Eigenschaften des Datasets wird geöffnet
  4. vergeben Sie in der Eigenschaft Name den gewünschten Namen

    Hinweis: der Name muss der Benennung in der Bildumschaltung entsprechen. Er darf keine Leerzeichen oder Sonderzeichen enthalten.

  5. lassen Sie alle anderen Einstellungen unverändert
  6. schließen Sie den Dialog mit Klick auf OK

Dataset löschen

Um ein Dataset zu löschen:

  1. markieren Sie im Fenster Report Data unterhalb der DataSource das zu löschende Dataset

  2. wählen Sie im Kontextmenü den Befehl Delete
  3. das Dataset wird nach einer Sicherheitsabfrage gelöscht

Dataset neu erstellen

Um ein Dataset neu zu erstellen:

  1. führen Sie einen Rechtsklick auf die DataSource aus
  2. wählen Sie im Kontextmenü Add Dataset

  3. ein neues Dataset wir erstellt und das Eigenschaftenfenster geöffnet

  4. vergeben Sie den gewünschten Namen

    Hinweis: der Name muss der Benennung in der Bildumschaltung entsprechen. Er darf keine Leerzeichen oder Sonderzeichen enthalten.

  5. fügen Sie die passende Query ein, dazu haben Sie drei Möglichkeiten:
    1. Query Designer: öffnet Dialog zur manuellen Eingabe der Query
    2. Import: Import aus einer bestehenden RDL-Datei
    3. manuelles Kopieren aus einem bestehenden Dataset: öffnen Sie dazu zuerst das passende Quell-Dataset, kopieren Sie den Inhalt der Query, fügen Sie den Inhalt der Query in das Feld Query im neuen Dataset ein
  6. schließen Sie den Dialog mit Klick auf OK

Query importieren

Um eine Query aus einer bestehenden RDL-Datei zu importieren:

  1. klicken Sie im Eigenschaftendialog des Datasets auf die Schaltfläche Import
  2. der Dateiauswahl-Assistent wird geöffnet
  3. suchen und öffnen Sie die gewünschte RDL-Datei
  4. der Import-Dialog wird angezeigt

  5. markieren Sie das gewünschte Dataset

  6. klicken Sie auf Import
  7. die Query des Quell-Datasets wird im aktuell geöffneten Dataset eingefügt


RDL-Dateien mit dem Microsoft Business Intelligence Development Studio erstellen und bearbeiten

Handbuch -> Reporting -> Report Viewer -> Report Definitionsdateien -> RDL-Dateien mit dem Microsoft Business Intelligence Development Studio erstellen und bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Microsoft Business Intelligence Development Studio wird mit zenon mitgeliefert und mit installiert.

Um RDL-Dateien mit dem Microsoft Business Intelligence Development Studio zu erstellen und zu bearbeiten, gehen Sie im Wesentlichen vor, wie beim Report Builder 2.0.

Unterschiede sind vor allem:

  • Damit der Report bearbeitet werden kann, muss im Microsoft Business Intelligence Development Studio zuerst ein neues Projekt vom Typ Report Server Project und eine sogenannte Solution erstellt werden.
    Diese werden automatisch angelegt, wenn Sie die RDL Datei per Doppelklick öffnen. Beim Beenden des Business Intelligence Development Studios können Sie das Projekt und die Solution im temporären Ordner speichern, dann werden Sie nicht immer wieder dazu aufgefordert.
    Die Datasets und der Report können nun im Microsoft Business Intelligence Development Studio bearbeitet werden.
  • Im Microsoft Business Intelligence Development Studio existiert kein Tabellen-Wizard, die Tabellen der Datasets müssen manuell konfiguriert werden.
  • Es findet keine Versionsprüfung statt:
    So können Features der Version 3 zu RDL-Dateien der Version 2 hinzugefügt werden. Diese werden aber zur Runtime nicht angezeigt.
  • Im Microsoft Business Intelligence Development Studio sind die Datsets von den Datatsources getrennt. Die Datatsource darf nicht verändert werden.

Anleitung

Eine umfassende Anleitung für die Verwendung des Microsoft Business Intelligence Development Studios finden Sie online auf der Microsoft Website in mehreren Sprachen:

Sprache | Link
Englisch: | http://msdn.microsoft.com/en-en/library/ms173767.aspx
Deutsch: | http://msdn.microsoft.com/de-de/library/ms173767.aspx
Französisch: | http://msdn.microsoft.com/fr-fr/library/ms173767.aspx
Italienisch: | http://msdn.microsoft.com/it-it/library/ms173767.aspx

Datasets löschen

Nicht benötigte Datasets müssen im Microsoft Business Intelligence Development Studio gelöscht werden, da diese zur Runtime Fehler verursachen können.

Um Datasets zu löschen:

  1. klicken Sie auf View
  2. wählen Sie Report Data
  3. navigieren Sie zu Datasets
  4. löschen Sie alle nicht benötigten Datasets


Datasets Definition

Handbuch -> Reporting -> Report Viewer -> Report Definitionsdateien -> Datasets Definition

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Spalten der vier verschiedenen Dataset-Typen sind fest vorgegeben.

Hinweis: Wenn zenon Analyzer Reports im Report Viewer wiederverwendet werden sollen, gilt:

  • sprachumschaltbare Texte sind bereits sprachumgeschaltet
  • einheitenumschaltbare Werte werden in Sekundäreinheit angegeben
  • Zeitstempel entsprechen der Lokalzeit des ausführenden Rechners

Dataset Definition AML

Name der Spalte | Datentyp | Bedeutung
PROJECT | String | Name des Projekts.
VARIABLE | String | Name der Variablen.
IDENTIFICATION | String | Kennung der Variablen.
TEXT | String | Eintragstext.
TIMECOMES | Date | Zeitpunkt des Auftreten des Alarms.
TIMEGOES | Date | Zeitpunkt.
TIMEACKN | Date | Zeitpunkt der Quittierung.
TIMEREACT | Date | Zeitpunkt der Reaktivierung.
COUNTREACT | Integer | Anzahl der Reaktivierungen.
STATEREACT | Integer | Status der Reaktivierung.
STATUSFLAGS | Integer | Statusbits.
VALUE | Float | Wert der Variablen.
UNIT | String | Maßeinheit.
COMMENT | String | Kommentar des Benutzers.
CLASS | String | Alarmklasse.
GROUP | String | Alarmgruppe.
USER | String | Name des Benutzers.
COMPUTER | String | Name des Computers.

Dataset Definition CEL

Name der Spalte | Datentyp | Bedeutung
PROJECT | String | Name des Projekts.
VARIABLE | String | Name der Variablen.
IDENTIFICATION | String | Kennung der Variablen.
TEXT | String | Eintragstext.
TIMECOMES | String | Zeitpunkt des Auftreten des Ereignisses.
STATUSFLAGS | Integer | Statusbits.
VALUE | Float | Wert der Variablen.
UNIT | String | Maßeinheit.
COMMENT | String | Kommentar des Benutzers.
CLASS | String | Alarmklasse.
GROUP | String | Alarmgruppe.
USER | String | Name des Benutzers.
COMPUTER | String | Name des Computers.

Dataset Definition ARCHIV

Name der Spalte | Datentyp | Bedeutung
PROJECT | String | Name des Projekts.
ARCHIVE | String | Name des Archivs.
VARIABLE | String | Name der Variablen.
IDENTIFICATION | String | Kennung der Variablen.
CHANNELSPEC | String | Variable einschließlich Verdichtungsart.
TIMESTAMP | String | Zeitstempel.
STATUSFLAGS | Integer | Statusbits.
VALUE | Float | Wert der Variablen.
UNIT | String | Maßeinheit.
STRVALUE | String | Wert als String.

Dataset Definition ONLINE

Name der Spalte | Datentyp | Bedeutung
PROJECT | String | Name des Projekts.
VARIABLE | String | Name der Variablen.
IDENTIFICATION | String | Kennung der Variablen.
TIMESTAMP | String | Zeitstempel.
STATUSFLAGS | Integer | Statusbits.
VALUE | Float | Wert der Variablen.
UNIT | String | Maßeinheit.
STRVALUE | String | Wert als String.


Bedienen zur Runtime

Handbuch -> Reporting -> Report Viewer -> Bedienen zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime wird das Bild vom Typ Report Viewer mit einer Bildumschaltfunktion aufgeschaltet. Ja nach konfigurierter Reportdefinition können Reporte für AML, CEL, Archive und Online-Werte angezeigt werden. Diese Reporte können Sie auch, wenn die entsprechenden Funktionen projektiert wurden:

  • aktualisieren: Reportdefinition und Daten neu laden und Report anzeigen
  • filteren: Filter definieren und speichern bzw. löschen
  • drucken: am für Werte und Protokolle definierten Drucker
  • exportieren: als PDF-Datei im definierten Exportordner

Parameter | Beschreibung
Aktualisieren | Lädt die Reportdefinition und die Daten neu und zeigt den den Report mit den aktualisierten Daten an. Nach Änderung der Reportdatei im Editor muss das Bild neu aufgeschaltet werden, Reload genügt nicht.
Drucken | Druckt den Report auf dem für Werte und Protokolle definierten Drucker aus.
Export | Speichert den aktuell angezeigten Report als PDF-Datei im für den Export definierten Ordner.
Filterprofile | Filtereinstellungen, die der Anwender in der Runtime speichern kann.
Profilauswahl | Profil aus Liste auswählen.
Speichern | Speichert aktuelle Einstellung als Profil.
X (Speichern) | Löscht ausgewähltes Profil.
Liste Report | Zeigt die in der Bildumschaltfunktion definierten Reports an. Die lIste kann durchsucht werden. Lange Listen werdne auf mehrere Seiten umgebrochen.

Navigation, Zoom und Suche

Die Kopfleiste des Reports bietet Elemente für:

  • Navigation
  • Zoom
  • Suche

Parameter

Beschreibung

Seitennavigation

Zeigt Anzahl der Seiten und aktuelle Seite. Ermöglicht Naviagtion im Dokument über

  • Pfeiltasten
  • Auswahl einer bestimmten Seite

Zoom

Auswahl einer Zoomstufe aus Dropdownliste:

  • Page Width (Seitenbreite)
  • Whole Page (ganze Seite)
  • 500%
  • 200%
  • 150%
  • 100% (default)
  • 75 %
  • 50 %
  • 25%

Suche

Eingabe eines Suchbegriffs im Suchfeld.

  • Find: zeigt erste Fundstelle an
  • Next: navigiert zu weiteren Fundstellen

Wildcards können nicht verwendet werden.


Fehlerbehandlung

Handbuch -> Reporting -> Report Viewer -> Fehlerbehandlung

Fehlermeldungen in Popups

Fehlermeldung | Bedeutung
DataTable missing for DataSet: <DatasetName> | Ein Dataset wird in der Reportdefinition verwendet, aber in der Konfiguration ist keine Tabelle mit diesem Namen enthalten. Der Report kann nicht angezeigt werden.
DataSet not used for DataTable: <TableName> | Eine Tabelle wurde definiert, aber die Reportdefinition verwendet diesen Namen nicht für ein Dataset. Diese Meldung tritt nur auf, nachdem eine fehlende Tabelle festgestellt wurde.


Standard-Rezepte

Handbuch -> Standard-Rezepte

Rezepte sammeln Sollwerte und Befehle in einer Vorgabeliste, die zur Runtime mit einem Funktionsaufruf ausgeführt wird.

Rezepte können sowohl im Editor als auch während der Runtime (mittels Bild vom Typ Rezept Standard) projektiert werden.

Eine Sammlung mehrerer Rezepte wird im Rezeptgruppen-Manager erstellt und verwaltet.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Projektieren im Editor

Funktion Bildumschaltung Standard-Rezept

Bedienen zur Runtime


Projektieren im Editor

Handbuch -> Standard-Rezepte -> Projektieren im Editor

Noch in diesem Kapitel

Kontextmenü Projektmanager

Kontextmenü Detailansicht

Bild vom Typ Rezept Standard anlegen

Neues Rezept anlegen

Variablen zum Rezept hinzufügen

Sollwerte ändern

Rezepte ausführen


Kontextmenü Projektmanager

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Kontextmenü Projektmanager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Rezept neu | Erstellt ein neues Rezept in der Liste und öffnet den Namen zur Bearbeitung.
XML exportieren alle... | Exportiert alle Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
ASCII importieren | Importiert aus ASCII-Datei.
Editorprofil | Öffnet Dropdownliste zur Zuweisung eines Editorprofils.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Detailansicht

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Kontextmenü Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste

Menüpunkt | Aktion
Rezept neu | Erstellt ein neues Rezept in der Liste und öffnet den Namen zur Bearbeitung.
Standard-Funktion erzeugen | Öffnet den Dialog zur Auswahl eines Rezeptes und einer Aktion und erstellt eine passende Funktion. Die Aktion wird im Ausgabefenster dokumentiert.
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Nach oben verschieben | Verschiebt Eintrag in der Rezept-Liste um eine Position nach oben.
Nach unten verschieben | Verschiebt Eintrag in der Rezept-Liste um eine Position nach unten.
Sollwert ändern | Aktiviert Zelle Sollwert zur Eingabe eines Wertes.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Selektierte ASCII exportieren | Exportiert ausgewählte Einträge in ASCII-Datei.
ASCII importieren | Importiert aus ASCII-Datei.
Umbenennen | Ermöglicht die Umbenennung des ausgewählten Rezepts. Auch per Mausklick in das Feld oder über Taste F2 möglich.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Baum in Detailansicht

Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Rezept neu | Erstellt ein neues Rezept in der Liste und öffnet den Namen zur Bearbeitung.
Rezept umbenennen | Ermöglicht die Umbenennung des ausgewählten Rezepts. Auch per Mausklick in das Feld oder über Taste F2 möglich.
Standard-Funktion erzeugen | Öffnet den Dialog zur Auswahl eines Rezeptes und zur Definition der gewünschten Aktion
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Selektierte ASCII exportieren | Exportiert ausgewählte Einträge in ASCII-Datei.
ASCII importieren | Importiert aus ASCII-Datei.
Umbenennen | Ermöglicht die Umbenennung des ausgewählten Rezepts. Auch per Mausklick in das Feld oder über Taste F2 möglich.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Details

Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Variable entfernen | Löscht ausgewählte Variable nach einer Sicherheitsabfrage.
Nach oben verschieben | Verschiebt ausgewählte Variable um eine Position nach oben.
Nach unten verschieben | Verschiebt ausgewählte Variable um eine Position nach unten.
Sollwert ändern | Öffnet die Zelle mit dem Sollwert zum Ändern.
Filter entfernen | Entfernt alle aktiven Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Bild vom Typ Rezept Standard anlegen

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Bild vom Typ Rezept Standard anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bedienung der Rezepte erfolgt während der Runtime über ein Bild vom Typ Rezept Standard. Dieses Bild muss zunächst im Editor angelegt werden. (Nähere Informationen zu den vordefinierten Bildtypen finden Sie im 'Bilder / Vordefinierte Bildtypen'.)

Nach dem Öffnen des Bildes wird ein leeres Bild aufgeschaltet. Die Standard-Kontrollelemente können Sie über deas Menü Kontrollelemente -> Vorlage einfügen erstellen.


Neues Rezept anlegen

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Neues Rezept anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein neues Rezept anzulegen wird im Projektmanager im Kontextmenü des Eintrags Rezepte / Rezepte Standard der Eintrag Rezept neu ausgewählt. Das neu anglegte Rezept wird in der Detailansicht des Projektmanagers angezeigt. In der Detailansicht erfolgt auch die weitere Projektierung.


Variablen zum Rezept hinzufügen

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Variablen zum Rezept hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach dem Anlegen eines neuen Rezept können Sie Variablen zum Rezept hinzufügen.

attention Achtung

String-Variablen können mit einem Standard-Rezept nicht auf die SPS geschrieben werden. Benutzen Sie für String-Variablen Rezeptgruppen-Manager.

Variablen werden im Dialog 'Filter: Variablenauswahl' selektiert. Die Variablen werden entweder per Doppelklick übernommen, oder indem der Button Hinzufügen betätigt wird. Ein Multiselect ist möglich. Es können auch Variablen aus untergeordneten, geladenen Projekten verwendet werden. Sämtliche Variablen, die zum Rezept hinzugefügt werden sollen, dürfen nicht schreibgeschützt sein. Wenn Sie Variablen umprojektieren (Normierung ändern), so wird auch der abzusetzende Sollwert im Rezept proportional angepasst.

info Info

Ein Dezimalwert kann sowohl mit 'Komma' als auch mit 'Punkt' angegeben werden, das Dezimalzeichen wird automatisch in einen 'Punkt' umgewandelt.

Variablen sortieren

Sie können die Variablen beliebig sortieren:

Markieren Sie die Variable, deren Reihenfolge geändert werden soll und wählen Sie eine der folgenden Aktionen:

  • mit den Pfeiltasten am rechten unteren Rand verschieben
  • im Kontextmenü 'Nach oben' oder 'Nach unten' wählen

Kontextmenü Variablenansicht

Parameter | Beschreibung
Variable hinzufügen | Öffnet Dialog zur Variablenauswahl.
Variable entfernen | Löscht ausgewählte Variablen nach Bestätigung einer Warnmeldung aus der Liste.
Nach oben verschieben | Verschiebt ausgewählte Variable um eine Position nach oben.
Nach unten verschieben | Verschiebt ausgewählte Variable um eine Position nach unten.
Sollwert ändern | Aktiviert Zelle Sollwert und markiert aktuellen Sollwert.
Alle Filter entfernen | Entfernt alle gesetzten Filter.
Hilfe | Öffnet die Online-Hilfe.


Sollwerte ändern

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Sollwerte ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Sollwert für eine Variable zu ändern können Sie entweder im Kontextmenü den Eintrag Sollwert ändern anklicken, oder direkt in der Spalte Sollwert die gewünschten Änderungen eintragen. Für die Überprüfung des Sollwertes wird der technische Minimum- und Maximumwert für jede Variable mit angezeigt. Beim Löschen von Variablen ist eine Mehrfachselektion möglich, beim Ändern nicht.

Die Variable _LASTRECIPE beinhaltet den Namen des zuletzt ausgeführten Standard-Rezeptes.

Mit Hilfe dieser Variable lässt sich eine Sortenverwaltung realisieren, da über diese Variable jederzeit die Information zur Verfügung steht, welche Sorte gerade verarbeitet wird.

Die Variable _LASTNEWRECIPE beinhaltet den Namen des zuletzt neu angelegten Standard-Rezeptes.

Die Variablen _LASTRECIPE und _LASTNEWRECIPE können auf jedem beliebigen Treiber basieren und müssen zum Schreiben freigegeben sein.

attention Achtung

Ausnahmen:

Die Variable _LASTRECIPE ist mit dem Standard-Systemtreiber nicht realisisierbar.

Die Variable _LASTNEWRECIPE ist mit dem Standard-Systemtreiber nicht realisierbar.

Noch in diesem Kapitel

Sollwert schreiben überprüfen


Sollwert schreiben überprüfen

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Sollwerte ändern -> Sollwert schreiben überprüfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Schreiben von Werten erhält der Wert ein Statusbit, dass er geschrieben wird. Ist der Schreibvorgang erfolgreich, wird das entsprechende Statusbit gesetzt:

  • WR-ACK

    Der Treiber hat einen Wert zum Schreiben bekommen.

  • WR-SUC

    Wert 1: Schreiben erfolgreich.

    Wert 0: Schreiben nicht erfolgreich, der Wert konnte nicht abgesetzt werden.

info Info

Wird ein Nachladen oder eine Server-Standby-Umschaltung ausgeführt, dann werden die anstehenden Rückmeldungen bzw. Schreibbestätigungen verworfen!

Diese Statuskombination bleibt solange bestehen, bis die nächste Wertänderung angestoßen wird. Dann gehen beide Status auf 0 bis der Schreibvorgang fertig ist. Zur Auswertung muss in der Rema folgende Bitkombination abgefragt werden:

WR-ACK, WR-SUC

Ergebnis:

  • WR-ACK 1, WR-SUC 1: Schreibvorgang erfolgreich.
  • WR-ACK 1, WR-SUC 0: Schreibvorgang nicht erfolgreich.

attention Achtung

Der Mechanismus zeigt nur, dass der Schreib Vorgang erfolgreich (oder nicht erfolgreich) auf die Steuerung abgesetzt wurde. Es bedeute nicht, dass der Wert in der Steuerung auch geändert wurde, da die Steuerung den Wert sofort wieder zurücksetzen/überschreiben kann. (Zum Beispiel beim Schreiben auf Ausgänge oder bei Wischerbits, die nur kurzfristig gesetzt werden.)

Module

Dieser Mechanismus kann bei folgenden Modulen eingesetzt werden:

  • Funktion Sollwert absetzen: Option Schreibbestätigung abwarten im Konfigurationsdialog der Funktion aktivieren.
  • Standard Rezepte: Eigenschaft Synchron schreiben aktivieren.

    Interne ID: Sollwert schreiben überprüfen

    Synchron schreiben

    Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
    Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
    Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
    Inaktiv: Es wird keine Schreibbestätigung abgewartet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Rezeptgruppen-Manager: Eigenschaft Synchron schreiben aktivieren.

Eintrag in CEL

  • Funktion Sollwert absetzen

    Für den Eintrag in der CEL muss in den Projekteigenschaften im Knoten Chronologische Ereignisliste die Eigenschaft Funktion SW-Setzen aktiviert werden. Es wird dann bei jedem Ausführen der Funktion die positive oder negative Rückmeldung in die CEL geschrieben.

    Interne ID: Sollwert schreiben überprüfen

    Funktion SW-Setzen

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
    Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
    Default: inaktiv
    Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

    Interne ID: Sollwert schreiben überprüfen

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Sollwert schreiben überprüfen

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Standard Rezepte und Rezeptgruppen Manager

    Für den Eintrag in die CEL wird eine Systemtreibervariable verwendet, die bei erfolgreich abgesetzten Rezept auf 1 geht. Eine globale Variable wird am am Server ausgewertet, eine lokale auf jedem Client, um zu erfahren, wann das zuletzt ausgeführte Rezept fertig geschrieben wurde.
    Mit diesen Variablen kann per Grenzwert oder Reaktionsmatrizen einen CEL Eintrag generiert werden. Die Abfrage erfolgt mit einer Multianalog oder einer Multibinär Rema.


Rezepte ausführen

Handbuch -> Standard-Rezepte -> Projektieren im Editor -> Rezepte ausführen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das Ausführen von Rezepten kann erfolgen:

  • während der Runtime mittels Button im Bild Rezept Standard erfolgen,
  • über im Editor projektierten Aufruf einer Funktion zur Rezeptausführung über:
    • Skript (z.B. AUSTOSTART-Skript)
    • Variablenzustand
    • Dynamisches Bildelement z.B. Button


Funktion Bildumschaltung Standard-Rezept

Handbuch -> Standard-Rezepte -> Funktion Bildumschaltung Standard-Rezept

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Bildumschaltung auf ein Standard-Rezept ermöglicht es, zur Runtime ein Bild mit einem Standard-Rezept aufzuschalten.

Um diese Funktion zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Bildumschaltung
  3. wählen Sie das gewünschte Bild vom Typ Standard-Rezept
  4. der Filterdialog öffnet sich für
    • Rezeptauswahl
    • Spalten-Eigenschaften
  5. definieren Sie Rezept und Spalten-Einstellungen
  6. schließen Sie den Dialog mit Klick auf OK

Noch in diesem Kapitel

Registerkarte Rezeptauswahl

Registerkarte Spalten-Eigenschaften


Registerkarte Rezeptauswahl

Handbuch -> Standard-Rezepte -> Funktion Bildumschaltung Standard-Rezept -> Registerkarte Rezeptauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Rezepte

Auswahl des Rezepts, das bei der Bildumschaltung angezeigt werden soll.

Diesen Dialog zur Runtime anbieten

aktiv: Zur Runtime wird bei der Bildumschaltung dieser Dialog angeboten. Das ausgewählte Rezept kann geändert werden.

inaktiv: Das Bild wird mit dem im Editor festgelegten Rezept aufgeschaltet. Keine Änderungsmöglichkeit zur Runtime.


Registerkarte Spalten-Eigenschaften

Handbuch -> Standard-Rezepte -> Funktion Bildumschaltung Standard-Rezept -> Registerkarte Spalten-Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier legen Sie fest, welche Spalten in welcher Ausprägung im Listenfeld angezeigt werden.

Parameter | Beschreibung
Verfügbare Spalten | Definition der zur Runtime angezeigten Spalten.
Parameter | Festlegung der Eigenschaften für markierte Spalte.
Beschriftung: | Beschriftung der Spalte zur Runtime.
Breite: | Breite der Spalte in Pixel.
Ausrichtung: | Textausrichtung der Spalte.


Bedienen zur Runtime

Handbuch -> Standard-Rezepte -> Bedienen zur Runtime

Im Onlinebetrieb stehen folgende Funktionen für die Rezeptverwendung zur Verfügung.

Parameter | Beschreibung
Rezept einzeln direkt | direktes Absetzen des aktivierten Rezepts
Rezept einzeln mit Auswahl | Änderung der Parameter des aktivierten Rezepts
Rezept einzeln mit Online-Auswahl | Auswahl eines Rezepts und Änderung seiner Parameter

Bei der Verwendung der Funktion Rezept einzeln mit Auswahl wird die Rezeptmaske aufgeschaltet.

Bedienbuttons sind:

Parameter

Beschreibung

Speichern

Änderungen im Rezept speichern.

Schließen

Rezepteinstellung schließen.

Absetzen

Rezept mit den aktuellen Parametern absetzen.

Variable hinzufügen

Variable mit der Variablenliste zum Rezept hinzufügen.

Variable lösen

Temporäres Löschen der selektierten Variable aus dem Rezept (dauerhaft gelöscht, wenn Rezept gespeichert wird).

Sollwert ändern

Ändern des Sollwertes der selektierten Variable.

Ein Dezimalwert kann sowohl mit 'Komma' als auch mit 'Punkt' angegeben werden, das Dezimalzeichen wird automatisch in einen 'Punkt' umgewandelt.

Achtung: Ist dieses Element im Bild nicht vorhanden, werden die Rezepte im Listenelement schreibgeschützt angezeigt.

Bei der Verwendung der Funktion Rezept einzeln mit Online-Auswahl können das Rezept und die Parameter des Rezepts gewählt und verändert werden. Es wird die Rezeptauswahl aufgeschaltet. Die Bedienung erfolgt gleich, wie die Parametrierung im Editor, nur dass keine Rezepte gelöscht werden können.

info Info

Wird ein Nachladen oder eine Server-Standby-Umschaltung angestoßen, so werden die anstehenden Rückmeldungen bzw. Schreibbestätigungen verworfen!

Nähere Informationen zu geänderten Runtime-Dateien finden Sie im Kapitel Projekt und Arbeitsbereich/RT änderbare Dateien.

Bedienberechtigung zur Runtime

Aktionen zur Runtime können mit Passwort und Berechtigungsebenen geschützt werden:

  • Beim Löschen, Speichern und Ändern von Rezepturen muss der eingeloggte Benutzer über die im Rezept projektierte Berechtigungsebene verfügen. Bei nicht ausreichender Berechtigung wird die entsprechende Funktion nicht ausgeführt.
  • Bei passwortgeschütztem Button Sollwert ändern, kann der Wert in der Tabelle nur geändert werden, wenn der Benutzer über die entsprechende Berechtigungsebene verfügt. Ist das nicht der Fall, wird bei aktivem temporärem Login der Dialog zum Login geöffnet, sobald eine Spalte zum Ändern eines Werts angeklickt wird.
  • Ist der Button Änderungen speichern mit einem Passwort geschützt und der Benutzer verfügt nicht über nicht über die benötigte Berechtigungsebene, wird nach Rezeptänderungen beim Schließen des Bildes der Dialog für temporäres Login geöffnet, um das Speichern der Änderungen zu ermöglichen.

Noch in diesem Kapitel

Bildtyp Rezept Standard

Rezept - Funktionen

Statusinformationen bei Rezepten und Rezeptgruppen Manager


Bildtyp Rezept Standard

Handbuch -> Standard-Rezepte -> Bedienen zur Runtime -> Bildtyp Rezept Standard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Steuerung der Rezepte während der Runtime erfolgt über ein Bild des Typs Rezept Standard. (Nähere Informationen zu den vordefinierten Bildtypen finden Sie im 'Bilder / Vordefinierte Bildtypen'.)

Erfolgreich vorgenommene Änderungen können in der Chronologischen Ereignisliste protokolliert werden.

info

Sämtliche Informationen gelten analog für den Rezeptgruppenmanager.

Parameter

Beschreibung

Buttons

Rezept neu

Ein neues Rezept erstellen.

Änderungen speichern

Das aktuelle Rezept unter dem gleichen Namen speichern.

Rezept lesen

Die Werte aller im ausgewählten Rezept vorkommenden Variablen werden von der Steuerung eingelesen und in das Rezept eingetragen. Die Änderungen müssen dann noch gespeichert werden!

Rezept kopieren

Das aktuelle Rezept kopieren

Rezept löschen

Das aktuelle Rezept löschen.

Rezept ändern

Das aktuelle Rezept bearbeiten.

Rezept exportieren

Aktuelles Rezept als *.txt speichern.

Rezept importieren

Aktuelles Rezept von *.txt laden.

Rezept absetzen

Die Werte aller im ausgewählten Rezept vorkommenden Variablen werden so wie in der Tabelle dargestellt in die Steuerung geschrieben.

Rezept >

Ein Rezept vorwärts blättern.

Rezept >>

Zum letzten Rezept blättern.

Rezept <

Ein Rezept rückwärts blättern.

Rezept <<

Zum ersten Rezept blättern.

Alle Werte ++

Alle Werte des ausgewählten Rezepts werden um 1 erhöht.

Alle Werte --

Alle Werte des ausgewählten Rezepts werden um 1 verringert.

Variable hinzufügen ...

Eine Variable zum ausgewählten Rezept hinzufügen. Es ist auch möglich, Variablen aus anderen geladenen Projekten zu verwenden.

Variable lösen

Eine selektierte Variable aus dem Rezept lösen

Sollwert ändern

Wert einer ausgewählten Variable im Rezept ändern. Ein Dezimalwert kann sowohl mit 'Komma' als auch mit 'Punkt' angegeben werden, das Dezimalzeichen wird automatisch in einen 'Punkt' umgewandelt.

Achtung: Ist dieses Element im Bild nicht vorhanden, werden die Rezepte im Listenelement schreibgeschützt angezeigt.

Allgemein

Rezeptname

Name des aktuell ausgewählten Rezepts

Rezepttabelle

Darstellung des ausgewählten Rezepts in tabellarischer Form.

Absetzfortschritt

Fortschrittsbalken, der das Absetzen des Rezepts anzeigt.

Das Kontrollelement zeigt den Fortschrittsbalken ja nach Platzierung und Ausprägung des Elements entweder von unten nach oben oder von links nach rechts verlaufend an.

Das Kontrollelement ist zur Runtime ausgeblendet und wird nur während des Absetzens eines Rezepts angezeigt.

Hinweis: Das Kontrollelement wird nur angezeigt, wenn die Eigenschaft Synchron schreiben aktiviert ist.

Interne ID: Bildtyp Rezept Standard

Synchron schreiben

Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
Inaktiv: Es wird keine Schreibbestätigung abgewartet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Synchrones Schreiben:

Ist die Eigenschaft Synchron schreiben aktiviert, wird das Kontrollelement Absetzfortschritt angezeigt, wenn ein Rezept zur Steuerung abgesetzt wird bis die Schreibbestätigung beim Rezeptmodul angekommen ist, unabhängig davon, ob diese positiv oder negativ ausgefallen ist. Soll auf eine negative Schreibbestätigung reagiert werden, kann das über Reaktionsmatrizen gelöst werden.

info Info

Buttons können mit Passwort und Berechtigungsebene geschützt werden. Details siehe Abschnitt Bedienen zur Runtime.


Rezept - Funktionen

Handbuch -> Standard-Rezepte -> Bedienen zur Runtime -> Rezept - Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Bedienung während der Runtime möglich zu machen, legt man die gewünschten Rezeptfunktionen an.

Wird aus dem Kontextmenü in der Detailansicht die Standardfunktion erstellt, so erstellt zenon automatisch eine Funktion Rezept Standard für das ausgewählte Rezept.

Noch in diesem Kapitel

Rezept einzeln

Rezept Standard


Rezept einzeln

Handbuch -> Standard-Rezepte -> Bedienen zur Runtime -> Rezept - Funktionen -> Rezept einzeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion Rezept einzeln steht in drei Ausprägungen zur Verfügung:

  • Rezept einzeln direkt
  • Rezept einzeln mit Auswahl
  • Rezept einzeln mit Online-Auswahl

Rezept einzeln direkt

Mit der Verwendung dieser Funktion kann während der Runtime ein definiertes Rezept direkt abgesetzt werden. Innerhalb eines Rezeptes können nur Prozessvariablen eines Treibers gewählt werden.

Als Übergabeparameter ist das Rezept anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Rezept einzeln mit Auswahl

Mit der Verwendung dieser Funktion kann während der Runtime ein definiertes Rezept vor dem Absetzen geändert (Sollwertänderung) werden.

Als Übergabeparameter ist das Rezept anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Nach der Auswahl des Rezeptes wird die Funktion in die Funktionsliste eingetragen.

Im Onlinebetrieb wird die Sollwerteinstellung des Rezeptes aufgeschaltet.

Mögliche Einstellungen in der Runtime und im Editor sind:

Parameter | Beschreibung
Variable hinzufügen | neue Variable zum Rezept hinzufügen
Variable lösen | ausgewählte Variable aus dem Rezept entfernen
Sollwert ändern | Wert der ausgewählten Variable ändern

Rezept einzeln mit Online-Auswahl

Mit der Verwendung dieser Funktion kann im Onlinebetrieb ein Rezept ausgewählt und vor dem Absetzen geändert (Sollwertänderung) werden.

Als Übergabeparameter ist ein vordefiniertes Rezept anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Während der Runtime wird die Rezeptauswahl aufgeschaltet.

Projektierbare Optionen sind:

Parameter | Beschreibung
Neu | neues Rezept anlegen
Kopieren | ausgewähltes Rezept kopieren und unter neuem Namen abspeichern
Ändern | Namen des ausgewählten Rezepts ändern
Löschen | ausgewähltes Rezept löschen

Nach der Auswahl des Rezeptes wird die Funktion in die Funktionsliste eingetragen.

Projektierbare Eigenschaften sind:

Variable hinzufügen | neue Variable zum Rezept hinzufügen
Variable lösen | ausgewählte Variable aus dem Rezept entfernen
Sollwert ändern | Wert der ausgewählten Variable ändern

Soll das Ändern der Rezepteinträge unterbunden werden, eine Auswahl der einzelnen Rezepte im Onlinebetrieb aber freigegeben werden, ist ein Eintrag in der Datei zenon6.ini vorzunehmen.

[FUNKTIONEN] |
REZEPT_AENDERN= | 0: keine Änderung erlaubt 1: Änderung erlaubt (default)


Rezept Standard

Handbuch -> Standard-Rezepte -> Bedienen zur Runtime -> Rezept - Funktionen -> Rezept Standard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann während der Runtime ein gespeichertes Rezept ausgeführt, aus der Hardware gelesen oder exportiert werden. Darüber hinaus können auch neue Rezepte importiert oder mit den aktuellen Werten aus der Hardware erstellt werden.

Um die Funktion zu erstellen:

  1. erstellen Sie eine neu Funktion
  2. wählen Sie im Knoten Rezepte die Funktion Standard-Rezept
  3. der Dialog zur Rezeptauswahl wird geöffnet
  4. in der Registerkarte Rezeptauswahl wählen Sie das aufzurufende Rezept
  5. in der Registerkarte Auszuführende Aktion bestimmen Sie die Aktion, die zur Runtime ausgeführt werden soll

Rezeptauswahl

Parameter

Beschreibung

Rezept auswählen

Auswahl des Rezepts, das gelesen oder geschrieben werden soll

Rezeptname aus Variable

Der Name des Rezepts, das gelesen oder geschrieben werden soll, wird durch die angegebene Variable definiert.

Achtung: Die Stringvariable muss zur Runtime vor der Funktionsausführung einen gültigen Rezeptnamen beinhalten, z.B. Rezept_4. Ansonsten kann die Funktion nicht ausgeführt werden.

Auszuführende Aktion

Parameter | Beschreibung
Werte absetzen | Die Werte der Variablen des ausgewählten Rezepts werden auf die Steuerung geschrieben.
Werte einlesen | Die Werte der Variablen des ausgewählten Rezepts werden aus der Steuerung gelesen und überschreiben die derzeitigen Werte im Rezept
Rezept duplizieren | Das Quellrezept legt eine Kopie seiner selbst mit dem Namen des Zielrezeptes an. Der Name des duplizierten Rezeptes wird nicht in der Variable _LASTNEWRECIPE abgelegt. Details zur Konfiguration siehe Abschnitt Rezept duplizieren weiter unten.
Rezept exportieren | Exportiert Rezept. Details zur Konfiguration siehe Abschnitt Rezept exportieren weiter unten.
Rezept importieren | Importiert Rezept aus Datei oder Variable. Details zur Konfiguration siehe Abschnitt Rezept importieren weiter unten.
Diesen Dialog zur Runtime anbieten | Bietet Dialog zur Runtime an, um Einstellungen zu ändern.

Rezept duplizieren

Parameter

Beschreibung

Zielrezept auswählen

Auswahl eines bestehenden Rezeptes, das durch die Daten des Quellrezeptes überschrieben werden soll.

Achtung: Die Daten des Zielrezepts werden dabei überschrieben.

Neues Rezept

(Name generieren)

Ein neues Rezept wird entsprechend der Standardsyntax erstellt. Dabei werden Lücken in der Rezeptreihenfolge automatisch aufgefüllt.

Beispiel: Es existieren bereits Rezept_0 und Rezept_2. Durch das erstmalige Duplizieren wird ein neues Rezept mit dem Namen Rezept_1 angelegt. Beim zweiten Duplizieren ein Rezept mit dem Namen Rezept_3.

Zielrezept aus Variable

Der Name des Zielrezeptes wird aus dem Inhalt einer String-Variablen generiert.

Hinweis: Enthält die Stringvariable des Zielrezepts keinen Text, wird automatisch ein Rezeptname vergeben.

Rezept exportieren

Parameter | Beschreibung
Dateiname automatisch generieren | Dateiname wird automatisch erstellt.
Dateiname vergeben | Klick auf Schaltfläche ... öffnet Explorer zur Auswahl eines Speicherordners und zur Vergabe eines Dateinamens.
Dateiname aus Variable | Der Name der Datei wird aus dem Inhalt einer String-Variablen generiert.

Rezept importieren

Parameter | Beschreibung
Dateiname vergeben | Klick auf Schaltfläche ... öffnet Explorer zur Auswahl eines Speicherordners und Auswahl einer Datei.
Dateiname aus Variable | Rezept wird aus verknüpfter Variable importiert


Statusinformationen bei Rezepten und Rezeptgruppen Manager

Handbuch -> Standard-Rezepte -> Bedienen zur Runtime -> Statusinformationen bei Rezepten und Rezeptgruppen Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Während der Runtime werden Statusinformationen zur Verfügung gestellt beim

  • Schreiben/Lesen
  • Exportieren/Importieren
  • und Sichern

Wird ein Rezept geschrieben, enthält die Variable das Ergebnis der Schreiboperation.

Werte

Rezept schreiben

Systemtreibervariable: Standard-Rezept/RGM-Rezept fertig abgesetzt

Wert | Ergebnis
0 | Initialisierungswert vor dem Rezept absetzen
1 | Schreiben wurde erfolgreich ausgeführt
2 | Schreiben wurde nicht ausgeführt, da Parameterfehler vorliegt
3 | Schreiben wurde nicht erfolgreich ausgeführt
4 | warte auf "fertig"
5 | Schreiben abgebrochen, da Runtime beendet wird
6 | Timeout aufgetreten

Hinweis: Ist die Netzwerkfunktionalität im Projekt aktiv, so ist für die am lokalen Rechner ausgeführte Funktion die Systemtreibervariable Standard-Rezept/RGM-Rezept fertig abgesetzt (local) relevant.

info Info

Unter Schreiben wird das Schreiben auf den Treiber verstanden. Dieser überträgt danach das Rezept zur Steuerung. Das bedeutet:

  • Eigenschaft Synchron schreiben inaktiv: Der Wert 1 für Standard-Rezept/RGM-Rezept fertig abgesetzt bedeutet nicht, dass die Werte auf der Steuerung sind. Sie wurden lediglich auf den Treiber egschrieben..

    Interne ID: Statusinformationen bei Rezepten und Rezeptgruppen Manager

    Synchron schreiben

    Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
    Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
    Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
    Inaktiv: Es wird keine Schreibbestätigung abgewartet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Eigenschaft Synchron schreiben aktiv: Die Wertänderung erfolgt erst, wenn alle Werte auf der Steuerung aktuell sind.

Hinweis: Die Fortschrittsanzeige beim Schreiben wird nur angezeigt, wenn Synchron schreiben aktiviert ist.

Rezept in Abarbeitung

Systemtreibervariable: Standard-Rezept/RGM-Rezept Funktion in Abarbeitung

Wert

Ergebnis

-1

wird ausgeführt

0

Initialisierungswert erfolgreich gelesen

1

Benutzer hat keine Bedienberechtigung

2

keine Berechtigung im Netzwerk

3

Abbruch durch Benutzer

4

Fehler - nicht alles konnte erfolgreich gelesen werden, z.B

  • Unterbrechung der Kommunikation zur Hardware vor Beginn des Einlesens
  • ein Datenbaustein ist auf der Steuerung nicht vorhanden
  • Fehler während der Übertragung aufgetreten

5

Fehler beim Speichern der Rezeptdatei

Bildtyp-spezifische Funktionen

Beim

  • Lesen (Systemtreibervariable: Standard-Rezept/RGM-Rezept alle Werte fertig gelesen),
  • Exportieren/Importieren und
  • Sichern

eines Rezeptes mittels Bildtyp-spezifischer Funktion stehen folgende Werte zur Verfügung:

Wert

Ergebnis

0

Initialisierungswert wartet auf Antwort vom Treiber

1

erfolgreich gelesen

2

Fehler beim Lesen, Exportieren/Importieren oder Sichern:

  • Unterbrechung der Kommunikation zur Hardware vor Beginn des Einlesens
  • ein Datenbaustein ist auf der Steuerung nicht vorhanden
  • Fehler während der Übertragung aufgetreten


Rezeptgruppen-Manager

Handbuch -> Rezeptgruppen-Manager

Zusätzlich zu den Rezepturen bietet der Rezeptgruppen Manager weitere Möglichkeiten:

Tabellarische Layouterstellung (Standardformat oder frei gestaltbares Format mit dem Report Generator), freie Layouterstellung mit Dynamischen Elementen, Rezept über OLE ansprechbar, indirekter Rezeptaufruf (z.B: in Abhängigkeit von einer Variable bei einem Bildaufruf), freie Gruppeneinteilung.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby und Client) lizenzpflichtig.

Ohne Lizenz ist zur Runtime lesender Zugriff möglich. Nicht zur Verfügung stehen ohne Lizenz folgende Befehle:

  • Speichern
  • Speichern unter
  • Neu
  • Export/Import

Noch in diesem Kapitel

Projektieren im Editor

Funktionen

Bedienen zur Runtime

Fehlerbehandlung

Beispiele


Projektieren im Editor

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor

Um den RGM zu projektieren, benötigen Sie in der Regel:

  • ein Bild vom Typ Rezeptgruppen-Manager
  • Rezeptgruppen und Rezepte
  • Funktionen für die Bedienung des Rezeptgruppen-Managers zur Runtime

Hinweis zur Namenskonvention: Für Rezepte sind alphanumerische Zeichen erlaubt. Ungültig sind folgende Zeichen (\"'./*?<>!|).

Noch in diesem Kapitel

Kontextmenü Projektmanager

Kontextmenüs Detailansicht

Bild vom Typ Rezeptgruppen-Manager anlegen

Anlegen einer Rezeptgruppe

Variablen für Rezeptgruppen

Rezepte zur Rezeptgruppe hinzufügen

Rezeptversion

Rezeptstatus

Liste Status-Bits

Windows CE


Kontextmenü Projektmanager

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Kontextmenü Projektmanager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Rezeptgruppe neu | Erstellt eine neue Rezeptgruppe in der Liste und öffnet den Namen zur Bearbeitung.
XML exportieren alle... | Exportiert alle Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Profil | Öffnet Dropdownliste zur Zuweisung eines Editor-Profils.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenüs Detailansicht

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Kontextmenüs Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste

Parameter | Beschreibung
Rezeptgruppe neu | Erstellt eine neue Rezeptgruppe in der Liste und öffnet den Namen zur Bearbeitung.
Rezept neu | Erstellt ein neues Rezept in der Liste und öffnet die Zelle mit dem Namen zur Bearbeitung.
Rezept bearbeiten | Öffnet den Dialog mit den Rezepten.
Variablenparameter ändern | Öffnet den Dialog mit den Rezepten.
Standardfunktion erzeugen | Öffnet den Dialog zur Auswahl eines Rezepts und Definition einer Aktion.
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Variable entfernen | Löscht ausgewählte Variable aus der Liste.
Nach oben verschieben | Verschiebt ausgewählte Variable nach oben.
Nach unten verschieben | Verschiebt ausgewählte Variable nach unten.
Duplizieren | Erstellt eine neue Rezeptgruppe mit den Inhalten der ausgewählten Rezeptgruppe und vergibt automatisch einen Namen nach dem Schema: Originalname+0, aus Default10 wird Default100.
Löschen | Löscht ausgewählten Eintrag.
Selektierte Rezeptgruppe XML exportieren | Exportiert ausgewählte Rezeptgruppe in XML-Datei.
XML importieren | Importiert aus XML-Datei.
ASCII importieren | Importiert aus ASCII-Datei.
Umbenennen | Ermöglicht das Umbenennen des ausgewählten Objekts.
Hilfe | Öffnet Online-Hilfe.

Kontextmenü Rezeptgruppen

Menüpunkt | Aktion
Rezeptgruppe neu | Erstellt eine neue Rezeptgruppe in der Liste und öffnet den Namen zur Bearbeitung.
XML exportieren alle... | Exportiert alle Einträge in XML-Datei.
XML importieren | Importiert Rezepte und Rezeptgruppen aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü ausgewählte Rezeptgruppe

Menüpunkt

Aktion

Duplizieren

Erstellt eine neue Rezeptgruppe mit den Inhalten der ausgewählten Rezeptgruppe und vergibt automatisch einen Namen nach dem Schema Originalname+[fortlaufende Nummer]:
aus Default10 wird Default100, beim erneuten Duplizieren Default101 ...

Hinweis: Mit der Gruppe verknüpfte Rezeptvariablen können beim Duplizieren der Rezeptgruppe regelbasiert ersetzt werden.

Löschen

Löscht die ausgewählte Rezeptgruppe nach einer Sicherheitsabfrage.

Anlagengruppen...

Öffnet Dialog zur Auswahl einer Anlagengruppe.

Selektierte Rezeptgruppe XML exportieren

Exportiert ausgewählte Rezeptgruppe in XML-Datei.

XML importieren

Importiert aus XML-Datei.

Umbenennen

Öffnet die Zelle mit dem Namen der Rezeptgruppe zur Bearbeitung.

Hilfe

Öffnet die Online-Hilfe.

Kontextmenü Variable

Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Variablenparameter ändern | Öffnet den Dialog mit den Rezepten.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü ausgewählte Variable

Menüpunkt | Aktion
Variable entfernen | Löscht Variable aus Liste.
Nach oben verschieben | Verschiebt Variable in Liste um einen Platz nach oben.
Nach unten verschieben | Verschiebt Variable in Liste um einen Platz nach unten.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Rezepte

Menüpunkt | Aktion
Rezept neu | Erstellt ein neues Rezept in der Liste und öffnet die Zelle mit dem Namen zur Bearbeitung.
ASCII importieren | Importiert aus ASCII-Datei.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü ausgewähltes Rezept

Menüpunkt

Aktion

Rezept bearbeiten

Öffnet den Dialog mit den Rezepten.

Neue Rezeptversion anlegen

Erstellt eine neue Version des Rezepts.

Standardfunktion erzeugen

Öffnet den Dialog zur Auswahl eines Rezepts und Definition einer Aktion.

Duplizieren als Rezeptversion

Erstellt eine neue Version des ausgewählten Rezepts.

Duplizieren

Erstellt ein neues Rezept mit den Inhalten des ausgewählten Rezepts und vergibt automatisch einen Namen nach dem Schema Originalname+[fortlaufende Nummer]:
aus Default10 wird Default100, beim erneuten Duplizieren Default101 ...

Hinweis: Quellvariablen für den Aktionstyp Verknüpfen mit Variable können beim Duplizieren des Rezepts ersetzt werden.

Löschen

Löscht das ausgewählte Rezept nach einer Sicherheitsabfrage.

Selektiertes Rezept XML exportieren

Exportiert ausgewähltes Rezept in XML-Datei.

Umbenennen

Öffnet die Zelle mit dem Namen des Rezepts zur Bearbeitung.

Hilfe

Öffnet die Online-Hilfe.


Bild vom Typ Rezeptgruppen-Manager anlegen

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Bild vom Typ Rezeptgruppen-Manager anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung eines Bildes für den Rezeptgruppen-Manager werden Rezepte zur Runtime einzeln und gruppiert verwaltet.

Das Anlegen des Bildes vom Typ Rezeptgruppen-Manager erfolgt im Editor durch Definition eines neuen Bildes des Typs Rezeptgruppen-Manager.(Nähere Informationen zu den vordefinierten Bildtypen finden Sie im Kapitel Bilder->Arten von Bildtypen.) Um ein Bild vom Typ Rezeptgruppen-Manager anzulegen:

  • legen Sie ein neues Bild an
  • wählen Sie als Bildtyp in der Dropdownliste Rezeptgruppen-Manager
  • öffnen Sie das Bild
  • wählen Sie im Menü Kontrollelemente den Befehl Vorlage einfügen oder wählen Sie eine einzelne Kontrollelemente aus
  • konfigurieren Sie das Bild

Mit Hilfe der Kontrollelemente führen Sie zur Runtime Aktionen aus.

info Info

Beim Lesen, Exportieren, Importieren und Speichern von Rezepten zur Runtime informiert eine Fortschrittsanzeige über den Verlauf der Aktion. Details siehe Kapitel Anlegen von Systemvariablen für Standard Rezepte und Rezeptgruppen-Manager

Kontrollelemente

Kontrollelement

Beschreibung

Vorlage einfügen

Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp.

Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden.

Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.

Information

Informationen zu Rezepten, Benutzer und Änderungen

Rezeptgruppen-Name

Name der aktuell ausgewählten Rezeptgruppe.

Rezeptliste

Stellt alle Rezepte/Rezeptversionen als Liste dar. Auswahl beinhaltet nur Rezepte, die beim Aufschalten des Bildes im Rezeptfilter der Funktion Bildumschaltung enthalten sind.

Zur Runtime kann jeweils ein Eintrag ausgewählt werden. Das ausgewählte Rezept wird im Bild dargestellt und kann bearbeitet werden.

Werden auch die Kontrollelemente Rezeptname und/oder Rezeptversion verwendet, wird die Auswahl immer synchronisiert. Wird die Auswahl im Kontrollelement geändert, ändert sich auch die Auswahl in der Liste und umgekehrt. Sollte ein Filterkriterium den gewählten Eintrag in der Liste ausschließen, wird in der Liste nichts ausgewählt.

Hinweise:

  • Neue Rezepte werden unabhängig von den Filterkriterien unten an die Liste angefügt.
  • Änderungen der Rezeptdaten werden erst nach dem Speichern des Rezepts dargestellt.
  • Bei den Listeninhalten sind sprachumschaltbar:
    - Überschriften in der Kopfzeile
    - Texte der Kommentare
    - Text des Rezeptstatus

Rezeptname

Name des aktuell ausgewählten Rezepts.

Default: Combobox (siehe auch Darstellung der Rezeptnamen)

Rezeptnummer

Rezeptnummer, die nach Drücken des Buttons Suche Rezept Nummer gesucht wird.

Rezeptversion

Legt eine Dropdownliste an, die zur Runtime alle Versionsnummern des gewählten Rezeptes beinhaltet.

Rezeptstatus

Legt eine Dropdownliste an, die zur Runtime alle projektierten Status enthält. Der aktuelle Status der gewählten Rezeptversion wird angezeigt.

Zur Runtime kann der Status hier geändert werden. Er wird erst mit dem Speichern des Rezepts übernommen.

Tipp: Mit dem VBA Event StatusChange kann die Änderung des Status zur Runtime überwacht bzw. abgebrochen werden.

Rezeptwertetabelle

Darstellung des ausgewählten Rezepts in tabellarischer Form.

Rezeptfilter

Dropdownliste mit Rezeptfilter.

Benutzername

Name des Anwenders, der das aktuelle Rezept zuletzt geändert hat.

Letzte Änderungszeit

Datum und Uhrzeit der letzten Änderung des aktuellen Rezepts.

Absetzfortschritt

Grafische Anzeige der Dauer des Absetzens der Rezepte.

Bearbeiten

Filter

Neue Filteroptionen für das Rezept-Fenster festlegen.

Selektierte Werte lesen

Die Werte der in der Tabelle selektierten Variablen werden von der Steuerung eingelesen und in die Tabelle eingetragen. Die Änderungen müssen dann noch gespeichert werden!

Selektierte Werte absetzen

Die Werte der in der Tabelle selektierten Variablen werden so wie in der Tabelle dargestellt in die Steuerung geschrieben.

Alle Werte lesen

Die Werte aller im ausgewählten Rezept vorkommenden Variablen werden von der Steuerung eingelesen und in das Rezept eingetragen. Die Änderungen müssen dann noch gespeichert werden!

Alle Werte lesen und speichern

Werte aus der Steuerung direkt in das Rezept schreiben und sofort speichern.

Alle Werte absetzen

Die Werte aller im ausgewählten Rezept vorkommenden Variablen werden so wie in der Tabelle dargestellt in die Steuerung geschrieben.

Alle Wert ++

Alle Werte des ausgewählten Rezepts werden um 1 erhöht.

Alle Wert --

Alle Werte des ausgewählten Rezepts werden um 1 verringert.

Alle Wert % ändern

Beim Drücken des Buttons zur Runtime werden alle Werte des ausgewählten Rezepts um den im Editfenster Werte % ändern angegebenen Prozentwert geändert, abhängig vom Vorzeichen:

  • Vorzeichen plus (+): Wert wird entsprechend erhöht
    Bsp: +20% -> 100 wird zu 120
  • Vorzeichen minus (-): Wert wird entsprechend verringert
    Bsp: -20% -> 100 wird zu 80
  • kein Vorzeichen: Prozentwert des aktuellen Werts wird neuer Wert
    Bsp: 20% -> 100 wird zu 20

Feld %

Alle Werte des ausgewählten Rezepts werden um den hier angegebenen Prozentwert erhöht (+) oder verringert (-), sobald der Button Wert alle % ändern gedrückt wird.

Alle Wert per Formel ändern

Alle Werte des ausgewählten Rezepts werden durch die im Editfenster Wert alle Math. angegebene mathematische Funktion verändert.

Feld Formel

Mathematische Funktion, durch die der Wert aller Variablen im aktuellen Rezept verändert werden soll, sobald der Button Werte alle Math. gedrückt wird.

Tabelle drucken

Die Tabelle wird ausgedruckt.

Navigation

Rezeptgruppe <

Eine Rezeptgruppe rückwärts blättern.

Rezeptgruppe >

Eine Rezeptgruppe vorwärts blättern.

Rezeptgruppen <<

Zur ersten Rezeptgruppe blättern.

Rezeptgruppen >>

Zur letzten Rezeptgruppe blättern.

Rezept <

Ein Rezept in der aktuellen Rezeptgruppe rückwärts blättern.

Rezept >

Ein Rezept in der aktuellen Rezeptgruppe vorwärts blättern.

Rezept <<

Zum ersten Rezept in der aktuellen Rezeptgruppe blättern.

Rezept >>

Zum letzten Rezept in der aktuellen Rezeptgruppe blättern.

Suche Rezept Nummer

Das erste Rezept mit der im Editfenster Quell Rezept Nummer angegebenen Nummer suchen und anzeigen.

Version <

Zur vorigen Version.

Version >

Zur nächsten Version.

Version <<

Zur ersten Version.

Version >>

Zur letzten Version.

Blättern Spalte links

In der Tabelle eine Spalte nach links blättern.

Blättern Spalte rechts

In der Tabelle eine Spalte nach rechts blättern.

Blättern Zeile auf

In der Tabelle eine Zeile aufwärts blättern.

Blättern Zeile ab

In der Tabelle eine Zeile abwärts blättern.

Blättern Seite links

In der Tabelle eine Seite nach links blättern.

Blättern Seite rechts

In der Tabelle eine Seite nach rechts blättern.

Blättern Seite auf

In der Tabelle eine Seite aufwärts blättern.

Blättern Seite ab

In der Tabelle eine Seite abwärts blättern.

Export/Import

Rezept exportieren (txt)

Exportiert aktuelles Rezept in eine TXT-Datei-

Rezept importieren (txt)

Importiert aktuelles Rezept aus einer TXT-Datei.

Rezeptgruppe exportieren (XML)

Exportiert Rezeptgruppe in eine XML-Datei.

Rezept exportieren (XML)

Exportiert aktuelles Rezept in eine XML-Datei.

Importieren von XML-Datei

Importiert Rezept bzw. Rezeptgruppe aus einer XML-Datei.

Falls die Datei über einzelne Rezepte verfügt, muss für den Import eine Rezeptgruppe ausgewählt sein.

Rezept Verwaltung

Rezept neu

Ein neues Rezept erstellen.

Rezept umbenennen

Das aktuelle Rezept umbenennen.

Rezept speichern

Das aktuelle Rezept unter dem gleichen Namen speichern.

Rezept speichern unter

Das aktuelle Rezept unter einem anderen Namen speichern.

Rezept löschen

Das aktuelle Rezept löschen.

Rezeptversion neu

Erstellt eine neue Version des Rezepts. Die Werte der neu angelegten Rezeptversion werden mit den Ersatzwerten belegt.

Tipp: Mit dem VBA Event VersionCreate kann diese Aktion überprüft werden.

Rezeptversion duplizieren

Dupliziert ausgewählte Rezeptversion. Es wird eine neue Version angelegt und die Rezeptwerte werden mit den Werten der zuvor gewählten Version belegt.

Tipp: Mit dem VBA Event VersionDuplicate kann diese Aktion überprüft werden.

Rezeptversion duplizieren und lesen

Dupliziert ausgewählte Rezeptversion und liest sie anschließend ein.

Zuerst wird eine neue Version des gewählten Rezepts angelegt. Die Rezeptwerte werden mit den Werten der gewählten Version belegt. Anschließend werden die Werte für die neue Version von der Steuerung eingelesen.

Tipp: Mit dem VBA Event VersionDuplicateRead kann diese Aktion überprüft werden.

Rezeptversion löschen

Löscht ausgewählte Rezeptversion. Ist die gewählte Rezeptversion die letzte verbliebene Version dieses Rezepts, wird damit das gesamte Rezept gelöscht.

Tipp: Mit dem VBA Event VersionDelete kann diese Aktion überprüft werden.

Status 1 - 10 setzen

Setzt einen von 10 möglichen Status.

Die Funktion setzt den Statuswert (1 - 10) auf das momentan im Bild gewählte Rezept. Um den Status für das Rezept zu übernehmen muss das Rezept anschließend gespeichert werden.

Es werden nur Status gesetzt, die auch im RGM projektiert wurden. Wird ein Statuswert, der nicht zur Verfügung steht, wird die Systemtreibervariable für RGM-Rezept Funktion in Abarbeitung auf Fehler gesetzt und ein CEL Eintrag generiert.

Hinweis: Der mit diesem Button gewählte Status wird in der Dropdownliste Rezeptstatus angezeigt. Die Liste der Rezepte zeigt dagegen immer den Zustand des Rezeptes so wie in der Datenablage an. Erst nach dem Speichern ist die Änderung des Status wirklich übernommen und wird dann in derListe der Rezepte angezeigt.

Rezeptwerte prüfen

Zum Prüfen der Rezeptwerte werden alle mit dem Rezept verknüpften Variablen eingelesen und die Momentanwerte mit den Rezeptwerten verglichen.
Die Ergebnisse werden in der Spalte Istwert farblich dargestellt. Stimmen die Werte überein, wird die entsprechende Zelle grün dargestellt, bei Abweichung rot.

Achtung: Die Funktion des Kontrollelements verwendet beim Abgleich mit der SPS Nachkommastellen. Wird bei Variablen mit dem Datentyp REAL die Eigenschaft Nachkommastellen nicht analog den Einstellungen der Steuerung konfiguriert und unterscheiden sich die Werte im Nachkommabereich, zeigt die Funktion abweichende Werte an.

Interne ID: Bild vom Typ Rezeptgruppen-Manager anlegen

Nachkommastellen

Anzahl der Nachkommastellen des Variablenwertes für die Darstellung im Leitsystem.
Minimum: 0
Maximum: 5
Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Rezeptgruppe

Rezeptgruppe neu

Eine neue Rezeptgruppe erstellen.

Rezeptgruppe bearbeiten

Neue Variablen zur Rezeptgruppe hinzufügen.

Rezeptgruppe umbenennen

Die aktuelle Rezeptgruppe umbenennen.

Rezeptgruppe speichern

Die aktuelle Rezeptgruppe unter dem gleichen Namen speichern.

Rezeptgruppe speichern unter

Die aktuelle Rezeptgruppe unter anderem Namen abspeichern.

Rezeptgruppe löschen

Die aktuelle Rezeptgruppe löschen.

Kommentar

Kommentar 1 - 8

Kommentarzeilen zum aktuellen Rezept.

Bis zu 8 Kommentare sind möglich.

Die Kommentarfelder verfügen über eine Eigenschaft Darstellung/Anzeigetext übersetzen.

Interne ID: Bild vom Typ Rezeptgruppen-Manager anlegen

Anzeigetext übersetzen

Aktiv: Die anzuzeigenden Texte werden übersetzt. Wird ein Text bearbeitet, wird der Entwurf ohne Übersetzung angezeigt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bild vom Typ Rezeptgruppen-Manager anlegen

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Kommentarfelder werden auch beim XML-Export geschrieben und beim Import gelesen.

In VBA können die Kommentarfelder über die DynProperties (Name „Commentn", n=1 bis 8) im „Recipes" Objekt gelesen und geschrieben werden

info Info

Ein Dezimalwert kann sowohl mit Komma als auch mit Punkt angegeben werden, das Dezimalzeichen wird automatisch in einen Punkt umgewandelt.

Filter

Über Kontrollelemente -> Allgemein -> Information wird dem Bild die Dropdownliste Rezeptfilter hinzugefügt. Benutzen Sie die Dropdownliste in der Runtime, um die dargestellten Variablen nach den zuvor festgelegten Filtertexten zu filtern.

Noch in diesem Kapitel

Aussehen der Rezeptliste

Darstellung der Rezeptnamen


Aussehen der Rezeptliste

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Bild vom Typ Rezeptgruppen-Manager anlegen -> Aussehen der Rezeptliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die tabellarischen Darstellung der Rezeptliste kann an individuelle Vorgaben angepasst werden:

Spalteneinstellungen

Die Spalteneinstellungen für die Darstellung zur Runtime werden bei der Konfiguration der Bildumschaltung eingestellt. Details siehe Abschnitt Spalteneinstellungen Rezeptliste.

Bildlaufleisten

Um Größe und Aussehen von Bildlaufleistens für die Tabelle zu definieren:

  1. aktivieren Sie in den Projekteigenschaft in der Gruppe Darstellung die Eigenschaft Erweiterte grafische Einstellungen

    Interne ID: Aussehen der Rezeptliste

    Erweiterte grafische Einstellungen

    Nur für PC verfügbar.

    Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

    Default: inaktiv.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Rezeptliste

    Darstellung

    Eigenschaften für die grafische Darstellung des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. definieren Sie die gewünschten Eigenschaften in den Gruppen Bildlaufleisten und Kopfzeile und Raster für das Element Alarmmeldeliste im Bild

    Interne ID: Aussehen der Rezeptliste

    Kopfzeile und Raster

    Eigenschaften für die Kopfzeile und das Raster.

    Mehr im Online-Handbuch für AML

    Mehr im Online-Handbuch für CEL

    Mehr im Online-Handbuch für ETM

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Aussehen der Rezeptliste

    Bildlaufleisten

    Eigenschaften für die horizontalen und vertikalen Bildlaufleisten.

    Mehr im Online-Handbuch für AML.

    Mehr im Online-Handbuch für CEL.

    Mehr im Online-Handbuch für ETM.

    Mehr im Online-Handbuch für RGM.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wird für die Eigenschaft Anzeigestil Grafikdateien gewählt, dann werden alle Elemente, für die keine Grafikdatei ausgewählt wird, mit einem Farbverlauf dargestellt. Bei Steuerelementen für Listen können keine transparenten Grafiken verwendet werden.

Interne ID: Aussehen der Rezeptliste

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: Aussehen der Rezeptliste

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: Aussehen der Rezeptliste

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der Rezeptliste

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: Aussehen der Rezeptliste

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: Aussehen der Rezeptliste

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Aussehen der Rezeptliste

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: Aussehen der Rezeptliste

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: Aussehen der Rezeptliste

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Aussehen der Rezeptliste

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zeilenhöhe

Über die Eigenschaft Darstellung/Zeilenhöhe [Pixel] kann die Zeilenhöhe unabhängig von der Schriftgröße definiert werden.

Interne ID: Aussehen der Rezeptliste

Zeilenhöhe [Pixel]

Nur verfügbar, wenn die Eigenschaft Erweiterte grafische Einstellungen aktiv ist.

Ermöglicht die Einstellung der Zeilenhöhe in Pixel unabhängig von der Schriftgröße.

Maximalwert: 4294967295 px
Minmalwert: 0 px - Zeilenhöhe wird an die Schriftgröße angepasst.

Default: 0

Achtung: Wird die Zeilenhöhe zu groß gewählt, wird unter umständen zur Runtime nichts angezeigt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Defaultwert ist 0 Pixel. Damit wird die Zeilenhöhe abhängig von der Schriftgröße eingestellt. Jeder Wert über 0 legt einen fixen Wert in Pixel für die Zeilenhöhe fest.

Achtung: Wird die Zeilenhöhe zu groß gewählt, wird unter Umständen zur Runtime nichts angezeigt.

Vorschau

Mit Aktivierung der Eigenschaft Darstellung/Erweiterte grafische Einstellungen werden im Editor die Kopfzeile und die Bildlaufleisten als Vorschau angezeigt.So lassen sich Details wie Farben, Fülleffekte, Lichteffekte oder Raster einfacher projektieren.

Achtung: Da die Größe der Bildlaufleisten in der Vorschau der Größe zur Runtime entspricht, kann die gesamte Größe des Liste im Editor von der Größe zur Runtime abweichen. Das gilt auch für die Größe der Kopfzeile und die Schrift der Kopfzeile.


Darstellung der Rezeptnamen

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Bild vom Typ Rezeptgruppen-Manager anlegen -> Darstellung der Rezeptnamen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Default-Einstellung werden die Rezeptnamen in einer Combobox dargestellt. Das ausgewählt Rezept wird angezeigt. Die anderen verfügbaren Rezepte können Sie mithilfe der Dropdown-Liste selektieren.

Ändern Sie die Darstellungsart von Combobox zu Listbox, indem Sie bei den Darstellungseigenschaften des entsprechenden Elements den Wert der Eigenschaft Style L von 322 auf 321 ändern. Dadurch wird in der Runtime eine Listbox mit der projektierten Größe angezeigt.

Interne ID: Darstellung der Rezeptnamen

Style L

Windows-Style des Elements, nur für internen Gebrauch.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Wenn Sie die Eigenschaft Style L auf 321 ändern, stellen Sie sicher, dass die jetzt projektierte Listbox keine anderen Elemente überdeckt. Die überdeckten Elemente können in der Runtime nicht verwendet werden.

Bei der Darstellung als Listbox können Sie durch Eingabe entsprechender Zeichen an die jeweilige Stelle in der Liste springen. Sie können auch mithilfe der Bildlaufleiste in der Liste rauf und runter scrollen.

Das Rezept, das Sie ausgewählt haben, wird immer direkt oberhalb der Liste angezeigt.

info Info

Diese Möglichkeit der unterschiedlichen Darstellung steht unter Windows CE nicht zur Verfügung.


Anlegen einer Rezeptgruppe

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Anlegen einer Rezeptgruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine neue Rezeptgruppe anzulegen, stehen zwei Wege zur Verfügung:

  1. Knoten Rezepte/Rezeptgruppen-Manager -> Kontextmenü -> Rezeptgruppe neu
  2. Detailansicht Rezeptgruppen-Manager -> Kontextmenü -> Rezeptgruppe neu

Es wird jeweils eine neue Rezeptgruppe mit Standardname erstellt. Der Name ist für die weitere Bearbeitung bereits markiert.

info Info

Soll die Rezeptgruppe als Binärdatei verwendet werden, darf der Name nur alphanumerische Zeichen enthalten.

Zu jeder Rezeptgruppe müssen Variablen und Rezepte hinzugefügt werden.


Variablen für Rezeptgruppen

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Variablen für Rezeptgruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Rezeptgruppe besteht aus den zugeordneten Prozessvariablen und den angelegten Rezepten. Alle in den Rezepten benötigten Prozessvariablen müssen zuerst im Untermenü Variable über das Kontextmenü eingefügt werden.

Um Variablen anzulegen:

  1. führen Sie einen Rechtsklick auf Variable aus
  2. wählen Sie im Kontextmenü den Befehl Variable einfügen
  3. der Dialog zur Auswahl mehrere Variablen wird geöffnet
  4. wählen sie die gewünschten Variablen aus
    Hinweis: Es können auch Variablen aus anderen geladenen Projekten ausgewählt werden
  5. bestätigen Sie mit KLick auf die Schaltfläche OK

Für die einzelnen Variablen kann eine für die entsprechende Rezeptgruppe geltende Einschränkung über Minimal- und Maximalwert projektiert werden.

info Info

Als Dezimaltrenner kann sowohl Komma als Punkt verwendet werden. Das Dezimalzeichen wird automatisch in einen Punkt umgewandelt.

Variablen sortieren

Im Rezeptgruppen Manager können Sie die Variablen beliebig sortieren:

Markieren Sie die Variable, deren Reihenfolge geändert werden soll und wählen Sie eine der folgenden Aktionen:

- im Kontextmenü Nach oben oder Nach unten wählen
- verschieben Sie die Variablen per Drag&Drop

Alternativ können Sie die Variablen auch im Variablenauswahldialog mit den Pfeiltasten am rechten unteren Rand verschieben.

Variablen entfernen

Um Variablen zu entfernen:

  1. markieren Sie die gewünschten Variablen
    (Multiselekt ist möglich)
  2. führen Sie einen Rechtsklick auf die markierten Variablen aus
  3. wählen Sie im Kontextmenü den Befehl Variable entfernen
  4. die Variablen werden nach einer Sicherheitsabfrage entfernt
    Hinweis: Die Variablen werden nur aus der Rezeptgruppe entfernt, bleiben aber im Projekt erhalten.

Noch in diesem Kapitel

Variablenparameter ändern

Rückmeldevariablen


Variablenparameter ändern

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Variablen für Rezeptgruppen -> Variablenparameter ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Kontextmenü von Variable den Menüpunkt Variablenparameter ändern wählen.

Im folgenden Dialog nehmen Sie mehrere Einstellungen vor.

Parameter | Beschreibung
Variablenname | In dieser Spalte sind alle Variablen, die in dieser Rezeptgruppe verwendet werden, aufgeführt.
min. Wert | Definieren Sie den minimalen Wert, den die Variable annehmen kann. Hinweis: Binärvariablen haben als min. Wert 0. Dieser Wert kann nicht geändert werden.
max. Wert | Definieren Sie den maximalen Wert, den die Variable annehmen kann. Hinweis: Binärvariablen haben als max. Wert 1. Dieser Wert kann nicht geändert werden.
Verriegelung | Wählen Sie über die Dropdown-Liste die gewünschte Verriegelung. (Siehe Verriegelung und Sichtbarkeit)
Sichtbarkeit | Wählen Sie eine passende Variable über Rechtsklick und selektieren des Menüpuktes Variablenauswahl aus. Alternativ geben Sie den Namen der gewünschten Variablen direkt ein. (Siehe Verriegelung und Sichtbarkeit)
Filter | Geben Sie einen Filtertext ein. (Siehe Filter.)
Keyboard | Wählen Sie ein passendes Bild über Rechtsklick und selektieren des Menüpuktes Bildauswahl aus. Alternativ geben Sie den Namen des gewünschten Bildes direkt ein. (Siehe Keyboard)

info Info

Sichtbarkeit von Variablen steuern

Um die Sichtbarkeit und Bedienung von Variablen zu steuern, stehen Ihnen zur Verfügung:

  • Filter: definiert Begriffe, nach denen die Variablen gefiltert werden können. Variablen, die nicht in den Filter passen, werden nicht angezeigt. Filter werden vom Benutzer gesteuert.
  • Sichtbarkeit: steuert die Anzeige der Variablen in der Liste über den Grenzwert einer Variablen. Variablen, die auf "nicht sichtbar" gesetzt wurden, werden nicht angezeigt. Sichtbarkeit wird vom Prozess gesteuert.
  • Berechtigungen: definiert, mit welcher Berechtigung eine Variable bedient werden kann. Variablen, für die der Nutzer keine Berechtigung hat, werden zwar angezeigt, können. aber nicht bedient werden. Berechtigungen werden vom Projekteur und vom Administrator gesteuert.

Tasten Keyboard für RGM

Keyboards dienen bei zenon als virtuelle Tastaturen, die an Geräten ohne Hardware-Tastatur Eingaben zur Runtime ermöglichen. Keyboards werden mit einem Bild vom Typ Keyboard projektiert. zenon stellt automatisch generierte und vom Anwender projektierbare Keyboards zur Verfügung.

Unter Kontrollelemente -> RGM spezifisch finden Sie spezifische Kontrollelemente für den Rezeptgruppen-Manager :

Element

Beschreibung

Wert absetzen

Der Sollwert wird auf die Variable abgesetzt und das Keyboard wird geschlossen.

Rezept speichern

Das Rezept wird gespeichert und das Keyboard geschlossen.

Wert absetzen und Rezept speichern

Der Sollwert zur Variablen abgesetzt, das Rezept gespeichert und das Keyboard geschlossen.

{Wertanzeigen als 1} bis {Wertanzeigen als 32}

Tasten können mit Grenzwerten aus einer Reaktionsmatrix verknüpft werden. Dazu muss die betroffene Variable

  • mit einer Numerischen Reaktionsmatrix oder Stringreaktionsmatrix verknüpft sein und
  • „ist gleich" Zustände beinhalten

Zur Laufzeit werden belegte Tasten eingeblendet. Klick auf den Button schreibt verknüpften Wert als Vorschlag für den Rezeptwert ins Eingabefenster.

Noch in diesem Kapitel

Verriegelung und Sichtbarkeit

Filter

Keyboard


Verriegelung und Sichtbarkeit

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Variablen für Rezeptgruppen -> Variablenparameter ändern -> Verriegelung und Sichtbarkeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sowohl über Verriegelung als auch über Sichtbarkeit ist es möglich, dem Benutzer den Zugriff auf bestimmte Bereiche der Rezept-Tabelle zu verwehren. Der Unterschied besteht darin, dass bei der Verriegelung die entsprechenden Bereiche gegraut und bei der Sichtbarkeit gar nicht dargestellt werden.

Verriegelung

In der Spalte Verriegelung ordnen Sie jeder Variablen eine Verriegelung zu. Die Dropdown-Liste zeigt Ihnen die verfügbaren Verriegelungen. In der Runtime wird die Zeile je nach Zustand der Verriegelung normal oder gegraut dargestellt. Mehr zum Thema finden Sie im Kapitel Verriegelung.

info Info

Darstellung mit Reportfunktionen

In der Runtime sind die Namen der Verriegelung nicht verfügbar. Dies führt dazu, dass nur Verriegelungs-IDs in der Rezepttabelle dargestellt werden, wenn die Verriegelung mithilfe der Funktionen recipew bzw. recipef dargestellt werden.

Sichtbarkeit

In der Spalte Sichtbarkeit orden Sie jeder Variablen eine Sichtbarkeitsvariable zu. Dazu:

  1. führen Sie einen Rechtsklick in die Zelle aus und wählen die Variable, die die Sichtbarkeit steuern soll oder tragen deren Namen direkt in die Zelle ein
  2. legen Sie für die Variable einen Grenzwert fest

Sobald die steuernde Variable den festgelegten grenzwert überschreitet, wird die zugeordnete Variable in der Rezept-Tabelle ausgeblendet.

info Info

Die Rezept-Tabelle wird nach jeder Änderung eines zugeordneten Zustands neu erstellt. Achten Sie beim Projektieren darauf, dass durch zu häufige Zustandswechsel Probleme bei der Bedienung auftreten können.


Filter

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Variablen für Rezeptgruppen -> Variablenparameter ändern -> Filter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Filter ermöglichen auf Anwenderebene Rezepte auszublenden.

Filter werden definiert über die Eigenschaft Filtertext bei den Variablen in der Detailansicht des RGM. Der Variablen wird ein frei wählbarer Filterbegriff zugeordnet. Dieser Filtertext wird benutzt, um die Ansicht im Bild vom Typ Rezeptgruppen-Manager einzuschränken. Dieser Filter kann gesetzt werden:

Interne ID: Filter

Filtertext

Definiert Filter für Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • zur Runtime im Bild Rezeptgruppen-Manager über die Dropdown-Liste Rezeptfilter
  • bei der Bildumschaltung auf das Bild Rezeptgruppen-Manager

Wenn kein Filter explizit ausgewählt wurde, werden alle Variablen dargestellt, denen kein Filtertext zugeordnet ist.

info Info

Die Filterung bezieht sich nur auf die Darstellung in der Rezept-Tabelle. Wird ein Rezept z.B. abgesetzt, werden alle Werte des Rezepts geschrieben.


Keyboard

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Variablen für Rezeptgruppen -> Variablenparameter ändern -> Keyboard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Spalte können Sie für jede Variable ein Bild vom Typ Keyboard verknüpfen. In der Runtime wird bei Linksklick auf den Wert der Variable das verknüpfte Tastaturfenster aufgeschaltet. Eine direkte Eingabe ist nicht mehr möglich. Nachdem Sie das Tastaturfenster mit OK verlassen, wird der neue Wert in der Rezept-Tabelle eingetragen. Außerdem steht Ihnen die neue Bild-Funktion Sollwertvorgabe zur Verfügung. Sie ermöglicht durch einen Klick die Übergabe eines zuvor defineirten Sollwertes.


Rückmeldevariablen

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Variablen für Rezeptgruppen -> Rückmeldevariablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit jeder Rezeptgruppe können Variablen verknüpft werden, die für die Aktionen Schreiben, Lesen, Prüfen und XML-Import mit den Rezeptdaten belegt werden. Diese RGM-spezifischen Rückmeldevariablen verhalten sich wie die globalen Systemtreibervariablen, werden aber einzelnen Rezeptgruppen zugeordnet. Damit können mehrere Rezeptgruppen parallel ausgewertet werden.

Es können beliebig viele Variablen verknüpft werden. Wurde die Eigenschaft RGM Datenablage auf MS ACcess gesetzt, beträgt die Textlänge maximal 300 Zeichen. Folgende Rezeptdaten können auf Variablen gesetzt werden:

Interne ID: Rückmeldevariablen

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Rezeptname
  • Rezeptnummer
  • Rezeptversion
  • Rezeptstatus als Text
    (in der Form „1 - Text", wobei der wobei der Text nicht übersetzt wird, was aber über das Anzeigeelement gelöst werden kann)
  • Rezeptstatus als Nummer
  • Bedienberechtigungsebene des Rezeptes
  • Zeit der letzten Änderung
  • Bediener der letzten Änderung
  • Kommentare 1-8

Rückmeldevariable erstellen

Um eine Rückmeldevariable zu erstellen:

  1. markieren Sie die Rezeptgruppe
  2. navigieren Sie zum Gewünschten Knoten
    • Feedback Rezept absetzen

      Interne ID: Rückmeldevariablen

      Feedback Rezept absetzen

      Rückmeldevariablen für Rezept absetzen.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Feedback Rezept lesen

      Interne ID: Rückmeldevariablen

      Feedback Rezept lesen

      Rückmeldevariablen für Rezept lesen.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Feedback Rezeptwerte prüfen

      Interne ID: Rückmeldevariablen

      Feedback Rezeptwerte prüfen

      Rückmeldevariablen für Rezeptwert prüfen.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Feedback XML Import

      Interne ID: Rückmeldevariablen

      Feedback XML Import

      Rückmeldevariablen für XML-Import.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. klicken Sie auf die Schaltfläche ... neben der gewünschten Eigenschaft
  4. der Dialog zur Verknüpfung der Variablen wird geöffnet

Hinweise zu den einzelnen Eigenschaften finden Sie in der Eigenschaftenhilfe. Das Ergebnis wird für alle Aktionen über Systemtreibervariablen lokal und für das Netzwerk zur Verfügung gestellt.

info Info

Änderungen über VBA werden erst nach dem neu Aufschalten des RGM sichtbar.


Rezepte zur Rezeptgruppe hinzufügen

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Rezepte zur Rezeptgruppe hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Rezept zu einer Rezeptgruppe hinzuzufügen:

  1. führen Sie einen Rechtsklick auf den Knoten Rezepte in der gewünschten Rezeptgruppe aus
  2. wählen Sie im Kontextmenü Rezept neu
  3. es wird ein neues Rezept mit Standardname erstellt, der Name ist für die weitere Bearbeitung bereits markiert
  4. vergeben Sie die gewünschten Eigenschaften zu Name, Nummer, Version, Berechtigung und Kommentare

info Info

Wird das Rezept als Binärdatei verwendet, darf der Name nur alphanumerische Zeichen enthalten.

Namensvergabe beim Erstellen

Neue Rezepte werden mit einem Defaultnamen angelegt, z.B. Rezept_0. Zusätzlich wird für jedes neue Rezept eine Rezeptnummer vergeben. Diese wird für jedes neue Rezept inkrementell erhöht.

Der Rezeptname muss eindeutig sein. Die Rezeptnummer wird nicht auf Eindeutigkeit überprüft. Diese wird nur verwendet, um über die Funktion Rezeptgruppen-Manager ein Rezept über eine Variable aufzurufen. Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept.

Example Beispiel

Es existieren bereits ein Rezept_0 mit der Rezeptnummer 0 und ein Rezept_2 mit der Rezeptnummer 2. Beim neu Anlegen, wird ein Rezept mit dem Namen Rezept_1 und der Rezeptnummer 3 angelegt.

Noch in diesem Kapitel

Bearbeiten eines Rezeptes aus der Rezeptgruppe


Bearbeiten eines Rezeptes aus der Rezeptgruppe

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Rezepte zur Rezeptgruppe hinzufügen -> Bearbeiten eines Rezeptes aus der Rezeptgruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Rezept aus einer Rezeptgruppe zu bearbeiten:

  • führen Sie einen Rechtsklick auf ein Rezept aus
  • wählen Sie den Befehl Rezept bearbeiten
  • Der Dialog Rezeptgruppen wird geöffnet

Eintrag

Beschreibung

Allgemein

Rezeptnummer

Nummer des Rezepts.

Synchron schreiben

Aktiv : Beim Schreiben eines Rezepts werden im Bild des Rezeptgruppen Managers alle Kontrollelemente gesperrt, bis vom Treiber die Rückmeldung kommt, dass alle Werte des Rezepts erfolgreich geschrieben wurden oder der eingestellte Timeout verstrichen ist.

Inaktiv : Die Werte des Rezepts werden ohne Warten auf eine Rückmeldung geschrieben. Die Kontrollelemente sind sofort wieder bedienbar. Die Rückmeldung des Treibers erfolgt über das Statusbit WR_SUC, das auf 1 gesetzt wird, sobald Werte erfolgreich geschrieben wurden.
Hinweise:

  • Diese Einstellung kann in der Runtime im Bild des Rezeptgruppen Managers über Rezept umbenennen geändert werden.
  • Die Fortschrittsanzeige funktioniert nur, wenn diese Eigenschaft aktiv ist.

Timeout [ms]

Wenn Synchron schreiben bei einem Rezept aktiviert wurde, kann hier ein Timeout eingegeben werden. Die Kontrollelemente des Bildes Rezeptgruppen Manager werden spätestens nach dieser Zeit wieder freigegeben.
Wird als Timeout der Wert 0 eingegeben, so berechnet zenon die Wartezeit wie folgt:
30000+(100*Anzahl der Datenpunkte)
Hinweis: Diese Einstellung kann in der Runtime im Bild des Rezeptgruppen Managers über Rezept umbenennen geändert werden.

Berechtigungsebene

Nur Benutzer, die für die hier eingegebene Berechtigungsebene freigegeben wurden, dürfen zur Runtime dieses Rezept ändern. Das betrifft nicht nur das manuelle Editieren des Rezepts im Bild des Rezeptgruppen Managers sondern auch das Löschen oder das Umbenennen des Rezepts sowie das Einlesen von Werten aus der Hardware für dieses Rezept.
Hinweis: Rezeptgruppen dürfen nur von einem Benutzer geändert werden, der die Berechtigung für alle enthaltenen Rezepte hat.

Listeneinträge

Variablenname

Name einer Variablen.

Nur Anzeige, keine Änderung möglich.

min. Wert

Minimaler Wert, der zur Steuerung übertragen werden kann.

Nur Anzeige, keine Änderung möglich.

max. Wert

Maximaler Wert, der zur Steuerung übertragen werden kann.

Nur Anzeige, keine Änderung möglich.

Aktion

Funktion, die auf Variablen ausgeführt wird.

Eintrag ist in Liste änderbar. Details siehe Kapitel Aktionen.

Wert oder Variable

Wert, der beim Absetzen des Rezepts zur Steuerung übertragen wird.

Wert abhängig von Aktion in Liste änderbar.

Maßeinheit

Maßeinheit einer Variablen.

Nur Anzeige, keine Änderung möglich.

info Info

Der Rezeptname muss eindeutig sein. Die Rezeptnummer wird nicht auf Eindeutigkeit überprüft. Diese wird nur verwendet, um über die Funktion Rezeptgruppen-Manager ein Rezept über eine Variable aufzurufen. Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept.

Noch in diesem Kapitel

Aktionen


Aktionen

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Rezepte zur Rezeptgruppe hinzufügen -> Bearbeiten eines Rezeptes aus der Rezeptgruppe -> Aktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Aktion zu definieren, klicken Sie in die Zelle Aktion der entsprechenden Variablen, klicken Sie auf das Symbol mit dem Pfeil und wählen Sie die gewünschte Aktion aus der Dropdownliste aus. Werden in der Zelle Wert oder Variable Einträge benötigt, klicken Sie in die Zelle und geben Sie den Wert ein. Zur Variablenauswahl klicken Sie mit rechts in die Zelle, um den Auswahldialog zu öffnen.

Aktion | Beschreibung | Eintrag in Wert oder Variable
Keine Aktion | Deaktiviert Variable in diesem Rezept. | Keine Eingabe.
Umschalten auf Spontanwert | Schaltet vom Ersatzwert auf den Spontanwert um | Keine Eingabe.
Modifizieren Spontanwert | Setzt den Spontanwert auf den Wert, der unter Wert oder Variable angegeben wird. | Sollwert eingeben.
Umschalten u. modi.Spontanwert | Schaltet vom Ersatzwert auf den Spontanwert um und setzt den Spontanwert auf den Wert, der unter Wert oder Variable angegeben wird. | Sollwert eingeben.
Umschalten auf Ersatzwert | Schaltet vom Spontanwert auf den Ersatzwert um. | Keine Eingabe.
Modifizieren Ersatzwert | Setzt den Ersatzwert auf den Wert, der unter Wert oder Variable angegeben wird. | Ersatzwert eingeben.
Umschalten u. modi. Ersatzwert | Schaltet vom Spontanwert auf den Ersatzwert um und setzt den Ersatzwert auf den Wert, der unter Wert oder Variable angegeben wird. | Ersatzwert eingeben.
Spontanwert abschalten | Schaltet Spontanwert durch Setzen des Status-Bits OFF (Bit 20) ab. | Keine Eingabe.
Spontanwert einschalten | Schaltet Spontanwert durch Zurücksetzen des OFF Bits ein. | Keine Eingabe.
Anwender Status | Statusinformation. Setzt das entsprechende Status-Bit der Variablen. Hinweis: Es können nur Status-Bits gesetzt werden, die als vom Benutzer gesetzt markiert sind. Vom System automatisch gesetzte Status-Bits sind nicht veränderbar. | Statuskurzbezeichnung eingeben mit: =1 zum Setzen =0 zum Rücksetzen Es können mehrere Status durch Semikolon ( ;) getrennt eingegeben werden. Z.B.: M1=1; M5=0
Verknüpfen mit Variable | Verknüpft Variable mit einer anderen Variablen. | Name einer Variablen. Rechtsklick in Feld öffnet Kontextmenü zum Öffnen des Dialogs zur Variablenauswahl. Der Wert der Variablen wird auf die ausgewählte Rezeptvariable übergeben. Es ist auch möglich, Variablen aus anderen geladenen Projekten zu verwenden.

attention Achtung

Wird bei einem Rezept die Funktionalität Alle Werte lesen mit der Aktion Verknüpfen mit Variable verwendet, werden weder Bedienberechtigungen abgefragt, noch wird diese Aktion protokolliert. Ist eine Protokollierung explizit gewünscht, muss diese manuell erzeugt werden, z. B. über ein VBA Makro.

Hinweis FDA: Diese Funktionalität kann daher nicht für Projekte mit strikter FDA-Norm angewandt werden!

Noch in diesem Kapitel

Sollwert schreiben überprüfen


Sollwert schreiben überprüfen

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Rezepte zur Rezeptgruppe hinzufügen -> Bearbeiten eines Rezeptes aus der Rezeptgruppe -> Aktionen -> Sollwert schreiben überprüfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Sollwert schreiben überprüfen

Beim Schreiben von Werten erhält der Wert ein Statusbit, dass er geschrieben wird. Ist der Schreibvorgang erfolgreich, wird das entsprechende Statusbit gesetzt:

  • WR-ACK

    Der Treiber hat einen Wert zum Schreiben bekommen.

  • WR-SUC

    Wert 1: Schreiben erfolgreich.

    Wert 0: Schreiben nicht erfolgreich, der Wert konnte nicht abgesetzt werden.

info Info

Wird ein Nachladen oder eine Server-Standby-Umschaltung ausgeführt, dann werden die anstehenden Rückmeldungen bzw. Schreibbestätigungen verworfen!

Diese Statuskombination bleibt solange bestehen, bis die nächste Wertänderung angestoßen wird. Dann gehen beide Status auf 0 bis der Schreibvorgang fertig ist. Zur Auswertung muss in der Rema folgende Bitkombination abgefragt werden:

WR-ACK, WR-SUC

Ergebnis:

  • WR-ACK 1, WR-SUC 1: Schreibvorgang erfolgreich.
  • WR-ACK 1, WR-SUC 0: Schreibvorgang nicht erfolgreich.

attention Achtung

Der Mechanismus zeigt nur, dass der Schreib Vorgang erfolgreich (oder nicht erfolgreich) auf die Steuerung abgesetzt wurde. Es bedeute nicht, dass der Wert in der Steuerung auch geändert wurde, da die Steuerung den Wert sofort wieder zurücksetzen/überschreiben kann. (Zum Beispiel beim Schreiben auf Ausgänge oder bei Wischerbits, die nur kurzfristig gesetzt werden.)

Module

Dieser Mechanismus kann bei folgenden Modulen eingesetzt werden:

  • Funktion Sollwert absetzen: Option Schreibbestätigung abwarten im Konfigurationsdialog der Funktion aktivieren.
  • Standard Rezepte: Eigenschaft Synchron schreiben aktivieren.

    Interne ID: Sollwert schreiben überprüfen

    Synchron schreiben

    Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
    Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
    Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
    Inaktiv: Es wird keine Schreibbestätigung abgewartet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Rezeptgruppen-Manager: Eigenschaft Synchron schreiben aktivieren.

Eintrag in CEL

  • Funktion Sollwert absetzen

    Für den Eintrag in der CEL muss in den Projekteigenschaften im Knoten Chronologische Ereignisliste die Eigenschaft Funktion SW-Setzen aktiviert werden. Es wird dann bei jedem Ausführen der Funktion die positive oder negative Rückmeldung in die CEL geschrieben.

    Interne ID: Sollwert schreiben überprüfen

    Funktion SW-Setzen

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
    Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
    Default: inaktiv
    Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

    Interne ID: Sollwert schreiben überprüfen

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Sollwert schreiben überprüfen

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Standard Rezepte und Rezeptgruppen Manager

    Für den Eintrag in die CEL wird eine Systemtreibervariable verwendet, die bei erfolgreich abgesetzten Rezept auf 1 geht. Eine globale Variable wird am am Server ausgewertet, eine lokale auf jedem Client, um zu erfahren, wann das zuletzt ausgeführte Rezept fertig geschrieben wurde.
    Mit diesen Variablen kann per Grenzwert oder Reaktionsmatrizen einen CEL Eintrag generiert werden. Die Abfrage erfolgt mit einer Multianalog oder einer Multibinär Rema.


Rezeptversion

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Rezeptversion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Rezepte können versioniert werden. Über Einstellungen im Editor sowie Funktionen und Kontrollelemente zur Runtime werden die Versionen verwaltet.

Um im Editor eine neue Rezeptversion zu erstellen haben Sie zwei Möglichkeiten:

  1. Neue Rezeptversion: Legt eine neue Version des ausgewählten Rezepts an.
    Dazu:
    1. markieren Sie das Rezept in der Detailansicht des RGM
    2. wählen Sie im Kontextmenü den Befehl Neue Rezeptversion anlegen

    oder

  2. Rezeptversion duplizieren: Legt eine Kopie dder ausgewählten Rezeptversion als neue Version an.
    Dazu:
    1. markieren Sie die Rezeptversion in der Detailansicht des RGM
    2. wählen Sie im Kontextmenü den Befehl Duplizieren als Rezeptversion

Eine neue Version des Rezepts wird unterhalb des Rezepts eingerückt angelegt. Die Versionsnummer wird in der Eigenschaft Rezeptversion automatisch vergeben. Rechts vom Originalrezept wird die Anzahl der verfügbaren Versionen angezeigt.

Interne ID: Rezeptversion

Rezeptversion

Zeigt die Versionsnummer des gewählten Rezeptes an. Nur Anzeige, keine Änderung möglich. Versionsnummer wird vom System automatisch gesetzt. Maximal können 89999 Rezeptversionen angelegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um zur Runtime eine neue Rezeptversion zu erstellen, nutzen Sie die Funktion Rezeptversion neu anlegen.

info Info

Maximal können 89999 Rezeptversionen angelegt werden.


Rezeptstatus

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Rezeptstatus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Rezeptstatus wird zur Identifizierung und Filterung eines Rezepts verwendet bei:

  • Eigenschaft Status für Rezept

    Interne ID: Rezeptstatus

    Status

    Auswahl des Rezeptstatus aus Dropdownliste. (Konfiguration der Status in Eigenschaft Rezeptgruppen Manager /Bezeichner Rezeptstatus.) Der Rezeptstatus kann pro Rezeptversion unterschiedlich eingestellt werden. Diese Eigenschaft kann auch in der Runtime verändert werden.

    Interne ID: Rezeptstatus

    Rezeptversion

    Zeigt die Versionsnummer des gewählten Rezeptes an. Nur Anzeige, keine Änderung möglich. Versionsnummer wird vom System automatisch gesetzt. Maximal können 89999 Rezeptversionen angelegt werden.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Rezeptstatus

    Bezeichner Rezeptstatus

    Konfiguration der Statusbezeichner. Klick auf Eigenschaft öffnet Dialog zur Konfiguration. Liste der Status wird bei der Statusauswahl im Rezept verwendet.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Rezeptstatus

    Rezeptgruppen Manager

    Definieren Sie die Dateiablage für den Rezeptgruppen-Manager.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Bild vom Typ RGM
  • Funktion Bildumschaltung auf RGM
  • Funktion Rezeptgruppen-Manager

Er besteht aus einem von zenon vergebenen Index und einem individuellen Statustext. Der Rezeptstatus kann pro Rezeptversion unterschiedlich eingestellt werden. Diese Eigenschaft kann zur Runtime über Funktionen und Kontrollelemente im Bild verändert werden.

Um einen Rezeptstatus zu erstellen:

  1. markieren Sie den Bezeichner Rezeptgruppen in der Detailansicht des RGM
  2. klicken Sie auf die Eigenschaft Bezeichner Rezeptstatus
  3. der Dialog zur Projektierung der Rezeptstatus wird geöffnet

Parameter

Beschreibung

Bezeichner Rezeptstatus

Erstellung und Verwaltung der Bezeichner für den Rezeptstatus.

#

Index des Status. Dieser wird automatisch vergeben.

Statustext

Statustext wie in diesem Dialog festgelegt:

  • Erstellung: Klick auf Schaltfläche Neu.
  • Bearbeiten: Mausklick in den Text ermöglicht Bearbeitung.

Dieser Text kann auch Schlüsselwörter (mit Präfix @) für die Sprachumschaltung beinhalten.

Neu

Erstellt neuen Status am Ende der Liste.

Löschen

Löscht markierten Statustext.

Befindet sich der zu löschende Status am Ende der Liste, werden Statustext und Indexnummer gelöscht.

Befindet sich der zu löschende Status nicht am Ende der Liste, wird der Text gelöscht aber der Index belassen. So können die Lücken später wieder neu belegt werden.

OK

Übernimmt Eingaben und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Liste Status-Bits

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Liste Status-Bits

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Details zur Statusverarbeitung lesen Sie im Kapitel Statusverarbeitung.


Windows CE

Handbuch -> Rezeptgruppen-Manager -> Projektieren im Editor -> Windows CE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit der Rezeptgruppen-Manager unter Windows CE einsetzbar ist, müssen die Daten des RGM in einer alternativen Ablage zur MS Access Datenbank abgelegt werden. Für Windows CE werden die Daten binär in einer Dateistruktur abgelegt.

Wenn Sie unter Projekteigenschaften -> Allgemein die Checkbox Windows CE Projekt aktivieren, werden die Daten des RGM automatisch binär angelegt.
Sie können die binäre Speicherung der Daten auch unabhängig von CE-Projekten manuell einstellen über:
Eigenschaften Rezeptgruppen -> Rezeptgruppen Manager -> RGM Datenablage -> binäre Dateien CE kompatibel).

Interne ID: Windows CE

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Windows CE

Rezeptgruppen Manager

Definieren Sie die Dateiablage für den Rezeptgruppen-Manager.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Windows CE

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Windows CE

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Eine Konvertierung der MS Access Datenbank nach binär oder umgekehrt ist nicht vorgesehen.

Bereits existierende RGM-Daten werden nicht konvertiert! Sie müssen bei Bedarf die Daten vor der Umstellung in XML exportieren. Im Anschluss können Sie das Projekt umstellen und die Daten in die neue Datenablage importieren.

Wechsel der Datenbank

Wurde beim RGM in der Eigenschaft RGM Datenablage als Datenbank MS ACCESS DB gewählt und wird dann die Checkbox Windows CE Projekt aktiviert, wird ein Hinweis zur Konvertierung aufgeschaltet:

Um die Daten der bisherigen Datenbank zu erhalten:

  1. exportieren Sie die Daten nach XML
  2. stellen Sie Datenbank um
  3. importieren Sie die XML-Datei

Filterdialog zur Runtime

Wird bei den Optionen der Rezeptwerttabelle in der Bildumschaltung die Eigenschaft Dialog zur Runtime anbieten aktiviert, stehen unter Windows CE nur eingeschränkte Optionen zur Verfügung:

  • Rezeptfilter
  • Spalteneinstellungen (für Rezepttabelle)

Rezeptauswahl, Anlagenmodellierung und Spalteneinstellungen für Rezeptliste werden nicht angeboten.

Mehrbenutzer-Projekte

In Mehrbenutzerprojekten können binäre Dateien und MS Access Datenbank unabhängig von einander ausgecheckt werden.

Im Fenster In Bearbeitung wird lokal immer nur der Status der auf diesem Rechner eingestellten Speicherart dargestellt. Werden Binärdateien verwendet, ist nicht ersichtlich, dass die Access Datenbank noch ausgechecked ist.

Damit ist folgendes Szenario möglich:

  • auf PC A ist die Access Datenbank ausgechecked
  • auf PC B wird CE-Projekt aktiviert und damit auf Binärdateien umgestellt
  • auf PC B werden die Binärdateien ausgechecked
  • auf PC B werden die Änderungen übernommen und dann mit PC A synchronisiert
  • damit wird auch auf PC A auf Binärdateien umgestellt
  • die Access Datenbank auf PC A bleibt damit weiter ausgechecked
  • erst wenn PC B wieder auf Access Datenbank umstellt, wird ersichtlich, dass auch auf PC A die Access Datenbank ausgechecked ist


Funktionen

Handbuch -> Rezeptgruppen-Manager -> Funktionen

Wird aus dem Kontextmenü in der Detailansicht die Standardfunktion erstellt, so erstellt zenon automatisch eine Funktion Rezeptgruppen Manager für das ausgewählte Rezept.

Noch in diesem Kapitel

Funktion Bildumschaltung Rezeptgruppen-Manager

Funktion Rezeptgruppen-Manager


Funktion Bildumschaltung Rezeptgruppen-Manager

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Bildumschaltung auf ein Bild vom Typ RGM definieren Sie ein Rezept, das mit der Umschaltung abgesetzt werden soll. Diese Einstellungen können auch zur Runtime vorgenommen werden, sofern die Option Dialog zur Runtime anbieten aktiv ist.

Um die Bildumschaltung zu projektieren:

  1. legen Sie eine neue Funktion an
  2. wählen Sie Bildumschaltung

    Interne ID: Funktion Bildumschaltung Rezeptgruppen-Manager

    Bildumschaltung

    Diese Funktion öffnet ein ausgewähltes Bild. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

    Mehr im Online-Handbuch

  3. wählen Sie das Bild vom Typ RGM
  4. wählen Sie Ihre Einstellungen in den einzelnen Registerkarten
    • Rezeptwerttabelle: Einstellungen für das Rezept.
    • Spalteneinstellung Rezeptwerttabelle: Einstellungen für die Anzeige zur Runtime.
    • Rezeptfilter: Definition der Rezepte einer Rezeptgruppe, die im Bild vom Typ Rezeptgruppen-Manager angezeigt werden.
    • Spalteneinstellungen Rezeptliste: Einstellungen für die Anzeige der Rezeptliste.
    • Anlagenmodellierung: Auswahl von Anlagenmodellen.

info Info

Einstellungen zur Sichtbarkeit von Variablen zur Runtime treffen Sie in:

  • Variablenparameter ändern: Filter, Sichtbarkeit
  • Bearbeiten eines Rezeptes aus der Rezeptgruppe: Berechtigungsebenen

Diese Einstellungen, beziehen sich nur auf die Darstellung in der Rezept-Tabelle. Wird ein Rezept z.B. abgesetzt, werden alle Werte des Rezepts geschrieben.

Noch in diesem Kapitel

Rezeptwerttabelle

Spalteneinstellung Rezeptwerttabelle

Rezeptfilter

Spalteneinstellungen Rezeptliste

Anlagenmodellierung


Rezeptwerttabelle

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager -> Rezeptwerttabelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte wird das Rezept, das abgesetzt werden soll, ausgewählt.

Parameter

Beschreibung

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable
  • aus einer Datei

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Hinweis: Führt die Rezeptauswahl zu einem Fehler zur Runtime (Rezept in Runtime nicht vorhanden, keine Auswahl getroffen, Rezept nicht im Filter enthalten), dann wird kein Rezept ausgewählt, die Anzeige der Dropdownliste Rezept bleibt leer.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem niedrigste Rezeptversion
  • Wert 90001 entspricht statischem höchste Rezeptversion

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Größte Version oder Kleinste Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status freigegeben.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Formatierung der Rezeptwerttabelle

Einstellungen für die Formatierung der Rezeptwerttabelle.

Tabelle

Auswahl der Reportdatei. Klick auf Schaltfläche öffnet Dropdownliste zur Auswahl:

  • Standardtabelle verwenden
  • Formatdatei für Tabelle verwenden

Standardtabelle verwenden:

Die Rezeptwerte werden zur Runtime in einer einfachen Tabelle im Bild vom Typ RGM angezeigt. Die Spalten dieser Tabelle können über die Registerkarte Spalteneinstellung Rezeptwerttabelle definiert werden.

Formatdatei für Tabelle verwenden:

Ermöglicht die Verwendung einer Reportdatei (*.xrs) für die Anzeige der Rezeptwerte. Diese Datei muss vorher im Report Generator erstellt worden sein. Klick auf Schaltfläche ... öffnet Dialog zur AUswahl der Datei.

Filter für Wertdarstellung

Auswahl des Filters, der bei der Umschaltung aktiv sein soll, um die Liste der angezeigten Rezeptwerte einzugrenzen.

Filterkriterium

Auswahl des Filters. Klick auf Beschriftung öffnet Dropdownliste zur Auswahl des Filters:

  • Filterkriterium statisch
  • Filterkriterium aus Variable

Filterkriterium statisch:

Auswahl eines Filters, der bei der Variableneigenschaft Filtertext definiert wurde.

Interne ID: Rezeptwerttabelle

Filtertext

Definiert Filter für Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Filterkriterium aus Variable:

Filterkriterium wird aus einer STRING-Variablen übernommen.

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Hinweis: Unter Windows CE und beim Aufruf über den Button Filter im RGM Bild stehen nur eingeschränkte Funktionen zur Verfügung:

  • Rezeptfilter
  • Spalteneinstellungen (für Rezepttabelle)

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

Bearbeitung im Bild sperren

Sperrt alle Kontrollelemente im Bildvom Typ RGM. Der Bediener kann keine Änderungen am RGM vornehmen.

OK

Übernimmt Einstellungen aller Registerkarten und schließt Dialog.

Abbrechen

Verwirft Änderungen für alle Registerkarten und schließt Dialog. Bei der ersten Konfiguration der Bildumschaltung wird die Funktion erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.

info Info

Der Rezeptname muss eindeutig sein. Die Rezeptnummer wird nicht auf Eindeutigkeit überprüft. Diese wird nur verwendet, um über die Funktion Rezeptgruppen-Manager ein Rezept über eine Variable aufzurufen. Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet CD_PRODUCTNAME> das zuerst gefundene Rezept.


Spalteneinstellung Rezeptwerttabelle

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager -> Spalteneinstellung Rezeptwerttabelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alle Spalten der Rezepttabelle sind frei konfigurierbar. Die Spalten können beliebig eingeblendet, gereiht und beschriftet werden. Zusätzlich kann die Zeilennummerierung ausgeblendet werden.

Parameter | Beschreibung
Spaltentyp | Typ der Spalte. Nicht editierbar. Anzeige zur Runtime wird per Checkbox aktiviert oder deaktiviert.
Beschreibung | Definiert Überschrift der jeweiligen Spalte. Kann auch sprachumschaltbar konfiguriert werden. Wert ist editierbar.
Breite | Definiert die Breite der Spalte in Zeichen. Diese kann auch durch Ziehen mit der Maus in der Liste mit horizontaler Anzeige der Spaltennamen festgelegt werden. Wert ist editierbar.
Selektierten Eintrag nach oben verschieben | Verschiebt ausgewählte Spalte nach oben. Verschieben ist auch per Drag & Drop möglich.
Selektierten Eintrag nach unten verschieben | Verschiebt ausgewählte Spalte nach unten. Verschieben ist auch per Drag & Drop möglich.
Feld mit horizontaler Anzeige der Spaltennamen | Zeigt die in der Liste aktivierten Spalten an. Durch Ziehen mit dem Mauszeiger an den Spaltengrenzen kann die Spaltengröße definiert werden.
Nummerierungsspalte anzeigen | Aktiv: Die erste Spalte der Tabelle wird mit Zeilennummer angezeigt.
OK | Übernimmt Einstellungen aller Registerkarten und schließt Dialog.
Abbrechen | Verwirft Änderungen für alle Registerkarten und schließt Dialog. Bei der ersten Konfiguration der Bildumschaltung wird die Funktion erstellt, allerdings ohne Ziel.
Hilfe | Öffnet Online-Hilfe.


Rezeptfilter

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager -> Rezeptfilter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte definieren Sie, welche Rezepte einer Rezeptgruppe im Bild vom Typ Rezeptgruppen-Manager angezeigt werden. Es werden nur Rezepte angezeigt, die im Rezeptfilter der Bildumschaltung zugelassen werden. Die Filterung basiert auf den Rezeptnamen.

info Info

Führt die Rezeptauswahl zu einem Fehler zur Runtime (Rezept in Runtime nicht vorhanden, keine Auswahl getroffen, Rezept nicht im Filter enthalten), dann wird kein Rezept ausgewählt, die Anzeige der Dropdownliste Rezept bleibt leer.

Parameter

Beschreibung

Textfilter

Definiert Filterkriterien.

Kein Textfilter

Aktiv: Der Textfilter wird nicht verwendet.

Suche nach (Wörter getrennt durch Leerzeichen)

Aktiv: Der Rezeptfilter wird verwendet. Die weiteren Einstellungsmöglichkeiten sind freigeschalten.

Eingabefeld

Geben Sie die entsprechenden Wörter bzw. Zeichenketten ein.

Groß-/Kleinschreibung beachten

Aktiv: Groß-/Kleinschreibung wird beim Filtern berücksichtigt.

Wörter müssen nicht vollständig im Rezeptnamen vorkommen

Aktiv: Die im Eingabefeld eingegebenen Ausdrücke werden auch dann berücksichtig, wenn sie im Rezeptnamen nur als Wortteil vorkommen.

Mindestens ein Wort muss im Rezeptnamen vorkommen

Aktiv: Zumindest ein Wort des Suchstrings muss im Rezeptnamen vorkommen.

Aller Wörter müssen im Rezeptnamen vorkommen

Aktiv: Sämtliche Wörter des Suchstrings müssen im Rezeptnamen vorkommen, wobei die Reihenfolge nicht berücksichtigt wird.

Filtertext muss exakt im Rezeptnamen vorkommen

Aktiv: Sämtliche Wörter des Suchstrings müssen im Rezeptnamen in der gleichen Reihenfolge vorkommen.

Erweiterter Filter

Filtereinstellungen für Version und Status.

Version

Versionsfilter: Auswahl aus Dropdownliste oder direkte Eingabe.

Dropdownliste:

  • Kleinste Version
  • Größte Version
  • Alle

Diese Einstellungen werden immer mit dem Status kombiniert.

Direkte Eingabe:

  • Nummerische Eingabe, getrennt durch ein Komma. Z.B.: 1, 2, 6

Eingaben dürfen aus Zahlen, Komma und Leerzeichen bestehen und werden auf Gültigkeit geprüft. Fehlerhafte Eingabe werden beim Bestätigen des Dialoges mit OK oder beim Wechseln der Registerkarte bemerkt. Der Dialog bleibt geöffnet und der Fokus wird auf die Combobox mit der Falscheingabe gesetzt.

Status

Filterkriterium für Status. Auswahl:

Dropdownliste:

  • Alle
  • bereits projektierter Status

Direkte Eingabe:

  • Nummerische Eingabe, getrennt durch ein Komma. Z.B.: 1, 2, 6

Statustexte sind sprachumschaltbar.

Eingaben dürfen aus Zahlen, Komma und Leerzeichen bestehen und werden auf Gültigkeit geprüft. Fehlerhafte Eingabe (z.B. Buchstaben) werden beim Bestätigen des Dialoges mit OK bemerkt. Der Dialog bleibt geöffnet und der Fokus wird auf die Combobox mit der Falscheingabe gesetzt.

OK

Übernimmt Einstellungen aller Registerkarten und schließt Dialog.

Abbrechen

Verwirft Änderungen für alle Registerkarten und schließt Dialog. Bei der ersten Konfiguration der Bildumschaltung wird die Funktion erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.

Mögliche Kombinationen des Versionsfilters mit dem Statusfilter

Versionsfilter | Statusfilter | Ergebnis
Kleinste Version | Alle | Von allen Rezepten wird nur die jeweils kleinste Versionen angezeigt.
Kleinste Version | 1,2 | Von allen Rezeptversion mit Status 1 oder 2 wird nur die jeweils kleinste Versionen angezeigt.
Größte Version | Alle | Von allen Rezepten wird nur die jeweils größte Versionen angezeigt.
Größte Version | 1,2 | Von allen Rezeptversion mit Status 1 oder 2 wird nur die jeweils größte Versionen angezeigt.
Alle | Alle | Es werden alle Rezeptversionen angezeigt.
Alle | 1,2 | Es werden alle Rezeptversionen mit dem Status 1 oder 2 angezeigt.
2,3 | Alle | Es werden die Rezeptversionen 2 und 3 unabhängig vom Status angezeigt.
2,3 | 1,2 | Es wird jeweils die Rezeptversion 2 und 3 angezeigt, wenn diese entweder den Status 1 oder 2 haben.


Spalteneinstellungen Rezeptliste

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager -> Spalteneinstellungen Rezeptliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden die Spalteneinstellungen für die Darstellung der Rezeptliste zur Runtime konfiguriert.

Achtung: Die Spalteneinstellungen für die Rezeptliste steht für CE-Projekte nicht zur Verfügung.

Parameter | Beschreibung
Listenfeld | Darstellung der konfigurierten Spalten.
Spaltenauswahl | Öffnet Dialog zur Auswahl der Spalten.
Spaltenformat | Öffnet Dialog zur Formatierung der Spalten.
OK | Übernimmt alle Änderungen und schließt Dialog.
Abbrechen | Verwirft alle Änderungen und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

Weitere Einstellungen, wie Bildlaufleisten, werden in den Eigenschaften des Listenfelds konfiguriert. Details siehe Abschnitt Aussehen der Rezeptliste.

Noch in diesem Kapitel

Spaltenauswahl

Spaltenformat


Spaltenauswahl

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager -> Spalteneinstellungen Rezeptliste -> Spaltenauswahl

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier konfigurieren Sie die zur Runtime anzuzeigenden Spalten.

Schaltfläche | Funktion
Hinzufügen | Verschiebt die markierten Spalten aus den verfügbaren zu den ausgewählten. Nach der Bestätigung des Dialogs mit OK werden sie in der Detailansicht angezeigt.
Alle hinzufügen | Verschiebt alle verfügbaren Spalten zu den ausgewählten Spalten.
Entfernen | Entfernt die markierten Spalten aus den ausgewählten und zeigt sie in der Liste der verfügbaren Spalten an. Nach der Bestätigung des Dialogs mit OK werden sie aus der Detailansicht entfernt.
Alle entfernen | Entfernt alle Spalten aus der Liste der ausgewählten Spalten.
Nach oben | Verschiebt den ausgewählten Eintrag nach oben. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
Nach unten | Verschiebt den ausgewählten Eintrag nach unten. Diese Funktion steht immer nur für einzelne Einträge zur Verfügung, Mehrfachauswahl ist nicht möglich.
OK | Übernimmt Einstellungen und schließt Dialog.
Abbrechen | Verwirft Einstellungen und schließt Dialog.
Hilfe | Öffnet Online-Hilfe.


Spaltenformat

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager -> Spalteneinstellungen Rezeptliste -> Spaltenformat

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier werden die Spalten formatiert.

Parameter

Beschreibung

Verfügbare Spalten

Liste der über Spaltenauswahl bereit gestellten Spalten. Die hier selektierte Spalte wird über die Einstellungen der Sektion Parameter konfiguriert.

Parameter

Einstellungen für ausgewählte Spalte.

Beschriftung

Name für Spaltentitel. Der Spaltentitel ist online sprachumschaltbar. Dazu müsen Sie ein @ Zeichen vor den Namen eingeben.

Breite

Breite der Spalte in Zeichen.
Berechnung: Zahl mal durchschnittlicher Zeichenbreite der gewählten Schriftart.

Ausrichtung

Ausrichtung.

Mögliche Einstellungen:

  • Linksbündig: Text wird in der Spalte am linken Rand ausgerichtet.
  • Zentriert: Text wird in der Spalte zentriert dargestellt.
  • Rechtsbündig: Text wird in der Spalte am rechten Rand ausgerichtet.

Spaltenfilter im Prozessbild sperren

Aktiv: Der Filter für diese Spalte kann zur Runtime nicht verändert werden.

Hinweis: Nur verfügbar für:

  • Batch Control
  • Erweiterter Trend
  • Message Control
  • Rezeptgruppen-Manager

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog.

Hilfe

Öffnet Online-Hilfe.


Anlagenmodellierung

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Bildumschaltung Rezeptgruppen-Manager -> Anlagenmodellierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier weisen Sie Anlagenmodelle und Ebenen zu:

Eigenschaft | Beschreibung
Symbolleiste | Siehe Kapitel Symbolleiste und Kontextmenü Detailansicht.
Hinzufügen | Fügt ausgewählte Gruppen und Ebenen zur Auswahl hinzu.
Entfernen | Löscht ausgewählte Elemente aus der Auswahl.
OK | Übernimmt Einstellungen aus allen Registerkarten und schließt Dialog.
Abbrechen | Es wird kein Element ausgewählt.
Hilfe | Öffnet Online-Hilfe.

Gruppen hinzufügen

  • wählen Sie das gewünschte Anlagenmodell
  • wählen Sie eine Anlagengruppe oder Ebene, Elemente auf der gleichen hierarchischen Stufe können per Multiselect gleichzeitig ausgewählt werden (Taste Strg gedrückt halten)
  • fügen Sie diese über die Schaltfläche Hinzufügen zur Liste im untern Bereich des Dialogs hinzu
  • Untergruppen werden nicht automatisch hinzugefügt
  • es können beliebig viele Gruppen verknüpft werden

Gruppen löschen

  • wählen Sie in der Liste im unteren Bereich des Dialogs die gewünschten Elemente
  • klicken Sie auf die Schaltfläche Entfernen

Hinweis: Änderungen in einem Baum-Element bleiben erhalten, unabhängig davon, ob die Schaltfläche Abbrechen betätigt wird. Abbrechen bedeutet nur, dass kein Element ausgewählt wird.


Funktion Rezeptgruppen-Manager

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion führt zur Runtime definierte Aktionen für ein ausgewähltes Rezept des Rezeptgruppen Managers durch.

Parameter

Beschreibung

Aktion

Auswahl der gewünschten Funktion aus Dropdownliste. Auswahl kann nachträglich nicht mehr geändert werden. Mögliche Funktionen:

  • Rezept absetzen
  • Rezept lesen
  • Rezeptwert prüfen
  • Rezept umbenennen
  • Rezeptstatus ändern
  • Rezept neu anlegen
  • Rezept löschen
  • Duplizieren
  • Duplizieren und lesen
  • Rezeptversion neu anlegen
  • Rezeptversion löschen
  • Duplizieren als neue Rezeptversion
  • Duplizieren und lesen als neue Rezeptversion
  • Rezeptwerte auf Schattenvariablen schreiben
  • Schattenvariablen auf Rezeptwerte schreiben
  • XML exportieren alles
  • XML exportieren Rezeptgruppe
  • XML exportieren Rezept
  • XML importieren
  • Detaillierte Rezeptdaten zur Dokumentation in XML speichern
  • Rezept in Textdatei exportieren
  • Rezept von Textdatei importieren

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Aktion.

Hilfe

Öffnet Online-Hilfe.

info Info

Der Rezeptname muss bei allen Funktionen eindeutig sein. Die Rezeptnummer wird nicht auf Eindeutigkeit überprüft. Diese wird nur verwendet, um über die Funktion Rezeptgruppen-Manager ein Rezept über eine Variable aufzurufen. Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept.

Noch in diesem Kapitel

Rezept absetzen

Rezept lesen

Rezeptwert prüfen

Rezept umbenennen

Rezeptstatus ändern

Rezept neu anlegen

Rezept löschen

Duplizieren

Duplizieren und lesen

Rezeptversion neu anlegen

Rezeptversion löschen

Duplizieren als neue Rezeptversion

Duplizieren und lesen als neue Rezeptversion

Rezeptwerte auf Schattenvariablen schreiben

Schattenvariablen auf Rezeptwerte schreiben

XML exportieren alles

XML exportieren Rezeptgruppe

XML exportieren Rezept

XML importieren

Detaillierte Rezeptdaten zur Dokumentation in XML speichern

Rezept in Textdatei exportieren

Rezept von Textdatei importieren


Rezept absetzen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezept absetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion setzt das ausgewählte Rezept zur Runtime ab.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezept lesen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezept lesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die aktuellen Werte der entsprechenden Variablen werden ausgelesen und in das ausgewählte Rezept geschrieben (teaching).

Beim Lesen wird überprüft, ob die Werte der Eigenschaften min. Wert und max. Wert eingehalten werden. Werden die Werte unter- oder überschritten oder hat die Variable den Status INVALID, werden die Werte nicht ins Rezept geschrieben. Fehler können über die Systemvariablen ausgewertet werden.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezeptwert prüfen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezeptwert prüfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion führt eine Rezeptprüfung durch. Dabei werden Rezeptwert und Istwert verglichen und das Ergebnis an die entsprechenden Systemvariablen ausgegeben.

Rezeptwerte können über die Funktion Rezeptgruppen-Manager überprüft werden oder per VBA.

Interne ID: Rezeptwert prüfen

Rezeptgruppen-Manager

Diese Funktion schreibt, liest, kopiert, importiert oder exportiert ein ausgewähltes Rezept des optionalen Moduls Rezeptgruppen Manager (RGM). Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch

Rezeptgruppen-Manager

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden. wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.

attention Achtung

Die Funktion verwendet beim Abgleich mit der SPS Nachkommastellen. Wird bei Variablen mit dem Datentyp REAL die Eigenschaft Nachkommastellen nicht analog den Einstellungen der Steuerung konfiguriert und unterscheiden sich die Werte im Nachkommabereich, zeigt die Funktion abweichende Werte an.

Interne ID: Rezeptwert prüfen

Nachkommastellen

Anzahl der Nachkommastellen des Variablenwertes für die Darstellung im Leitsystem.
Minimum: 0
Maximum: 5
Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

VBA

Rezeptwerte können auch automatisiert über VBA ausgeführt werden. Dazu wird die Funktion (Check()) verwendet. Sie übernimmt folgende Parameter bzw. liefert folgende Rückgabewerte:

Check(ByRef vList As Variant)as Long

  • Returnwert: entspricht den Werten der Systemvariablen RGM Rezeptwerte prüfen - Ergebnis.
  • vList: entspricht den Werten der Systemvariablen RGM Rezeptwerte prüfen - Abweichungen.
    Dabei wird für jeden Eintrag ein neuer Arrayindex verwendet (kein Zeilenvorschub).

Systemvariablen

Die Funktion führt eine Rezeptprüfung durch. Dabei werden Rezeptwert und Istwert verglichen und das Ergebnis an die entsprechenden Systemvariablen ausgegeben. Die Variablen können lokal oder global gewählt und ausgewertet werden. Variablen, die aufgrund fehlerhafter Kommunikation mit der Steuerung nicht überprüft werden können (Status INVALID) werden durch farbige Hinterlegung (rot) gekennzeichnet.

Variable

Datentyp

Beschreibung

RGM Rezeptwerte prüfen - Abweichungen (global/lokal)

STRING

Listet alle Variablenunterschiede in folgender Reihenfolge auf:

[Variablenname; Rezeptwert; Variablenwert; Einheit]

jeder Eintrag wird in eine neue Zeile geschrieben.

Voraussetzung: Die Variable RGM Rezeptwerte prüfen - Ergebnis liefert einen Wert = 1.

Achtung: Variable kann entweder global oder lokal angelegt und ausgewertet werden.

RGM Rezeptwerte prüfen - Bedienberechtigung (global/lokal)

DINT

Ebene der Bedienberechtigung des zuletzt geprüften Rezepts.

RGM Rezeptwerte prüfen - Bediener letzte Änderung (global/lokal)

STRING

Name des angemeldeten Benutzers der letzten Rezeptänderung des zuletzt geprüften Rezepts.

RGM Rezeptwerte prüfen - Ergebnis (global/lokal)

DINT

Ergebnisse der Prüfung:

  • 0: Alle Werte stimmen überein.
  • 1: Mindestens ein Variablenwert unterscheidet sich vom Rezeptwert.
  • 2: Mindestens eine Variable ist gestört (INVALID).

Fehlermeldungen:

  • -1: Ein Fehler beim Lesen der Variablenwerte ist aufgetreten.
  • -2: Die Rezeptgruppe konnte nicht geöffnet werden.
  • -3: Das Rezept konnte nicht geöffnet werden.

Achtung: Variable kann entweder global oder lokal angelegt und ausgewertet werden.

RGM Rezeptwerte prüfen - Kommentar 1 bis 8 (global/lokal)

STRING

Acht Kommentare können zu einem Rezept hinzugefügt werden. Die Variable enthält den Kommentar der jeweiligen Nummer zum zuletzt geprüften Rezept.

RGM Rezeptwerte prüfen - Rezeptgruppenname (global/(lokal)

STRING

Name der Rezeptgruppe des zuletzt überprüften Rezepts.

Voraussetzung: Die Variable RGM Rezeptwerte prüfen - Ergebnis liefert einen Wert >= -1.

Achtung: Variable kann entweder global oder lokal angelegt und ausgewertet werden.

RGM Rezeptwerte prüfen - Rezeptname (global/lokal)

STRING

Name des zuletzt überprüften Rezepts.

Voraussetzung: Die Variable RGM Rezeptwerte prüfen - Ergebnis liefert einen Wert >= -1.

Achtung: Variable kann entweder global oder lokal angelegt und ausgewertet werden.

RGM Rezeptwerte prüfen - Rezeptnummer (global/lokal)

UDINT

Nummer des zuletzt überprüften Rezepts.

Voraussetzung: Die Variable RGM Rezeptwerte prüfen - Ergebnis liefert einen Wert >= -1.

Achtung: Variable kann entweder global oder lokal angelegt und ausgewertet werden.

RGM Rezeptwerte prüfen - Rezeptstatus (global/lokal)

DINT

Status des zuletzt geprüften Rezepts als Zahl.

RGM Rezeptwerte prüfen - Rezeptstatus Text (global/lokal)

STRING

Status des zuletzt geprüften Rezepts als Text im Format: 1 - @Text

RGM Rezeptwerte prüfen - Rezeptversion (global/lokal)

DINT

Version des zuletzt geprüften Rezepts.

RGM Rezeptwerte prüfen - Zeit letzte Änderung (global/lokal)

STRING

Zeitpunkt der letzten Rezeptänderung des zuletzt geprüften Rezepts.


Rezept umbenennen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezept umbenennen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion benennt das ausgewählte Rezept und alle seine Versionen um.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Zielrezept

Auswahl, wie das Zielrezept der Umbenennung erstellt wird:

  • Zielrezeptname statisch
  • Zielrezept neu erstellen
  • Zielrezeptname aus Variable

Zielrezeptname statisch:

Auswahl eines bestehenden Rezepts aus Dropdownliste.

Zielrezeptname neu erstellen

Ein neues Rezept mit automatisch generierten Namen wird erstellt.

Zielrezeptname aus Variable:

Name des Zielrezepts wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, wird das Rezept nicht umbenannt.

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezeptstatus ändern

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezeptstatus ändern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion ändert den Status eines Rezepts.

Es wird versucht den Statuswert auf das gewählte Rezept zu setzen, anschließend wird das Rezept gespeichert. Sollte der angegebene Statuswert nicht gültig sein (0 oder ein nicht projektierter Statuswert) bleibt das Rezept unverändert und ein CEL Eintrag wird generiert. Die Variable RGM-Rezept Funktion in Abarbeitung zeigt in diesen Fall einen Fehler an (4).

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Zielrezept

Statusdefinition für Zielrezept.

Zielrezeptstatus

Auswahl des neuen Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Zielrezeptstatus statisch:

Auswahl eines bestehenden Status aus Dropdownliste.

Zielrezeptstatus aus Variable:

Rezeptstatus wird als nummerischer Variablenwert aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezept neu anlegen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezept neu anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion legt ein neues Rezept in der ausgewählten Rezeptgruppe an.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezept löschen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezept löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion löscht das ausgewählte Rezept mit allen seinen Versionen.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Duplizieren

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Duplizieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion dupliziert das ausgewählte Rezept. Die aktuellen Werte der entsprechenden Variablen werden in das neue Rezept geschrieben.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Zielrezept

Statusdefinition für Zielrezept.

Zielrezept erstellen

Einstellungen für Rezeptbenennung. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Zielrezeptname statisch
  • Zielrezept neu erstellen
  • Zielrezeptname aus Variable

Zielrezeptname statisch

Übernahme eines bestehenden Namens aus Dropdownliste.

Zielrezept neu erstellen

Der Name wird vom System neu erstellt und vergeben.

Zielrezeptname aus Variable

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Zielrezeptversion

Auswahl der Zielrezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Zielrezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Zielrezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Zielrezeptstatus

Auswahl des neuen Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Zielrezeptstatus statisch:

Auswahl eines bestehenden Status aus Dropdownliste.

Zielrezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Duplizieren und lesen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Duplizieren und lesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion dupliziert das ausgewählte Rezept. Die aktuellen Werte der entsprechenden Variablen werden in das neue Rezept geschrieben. Anschließend werden die Werte aus der Steuerung eingelesen. Können die Werte nicht eingelesen werden, dann stammen die Werte des Duplikats nicht mehr von der Steuerung, sondern werden lediglich vom Originalrezept kopiert.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Version
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Zielrezept

Statusdefinition für Zielrezept.

Zielrezept erstellen

Einstellungen für Rezeptbenennung. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Zielrezeptname statisch
  • Zielrezept neu erstellen
  • Zielrezeptname aus Variable

Zielrezeptname statisch

Übernahme eines bestehenden Namens aus Dropdownliste.

Zielrezept neu erstellen

Der Name wird vom System neu erstellt und vergeben.

Zielrezeptname aus Variable

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Zielrezeptversion

Auswahl der Zielrezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Zielrezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Zielrezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Zielrezeptstatus

Auswahl des neuen Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Zielrezeptstatus statisch:

Auswahl eines bestehenden Status aus Dropdownliste.

Zielrezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezeptversion neu anlegen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezeptversion neu anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion legt eine neue Rezeptversion für das ausgewählte Rezept an. Die Rezeptwerte werden mit den Ersatzwerten der Variablen belegt. Es können maximal 89999 Rezeptversionen angelegt werden.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezeptversion löschen

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezeptversion löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion löscht die ausgewählte Rezeptversion. Ist nur mehr eine Rezeptversion vorhanden, wird damit das gesamte Rezept gelöscht.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Duplizieren als neue Rezeptversion

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Duplizieren als neue Rezeptversion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion legt eine neue Rezeptversion für das ausgewählte Rezept an. Die Rezeptwerte werden mit den Werten des gewählten Rezeptes belegt.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Duplizieren und lesen als neue Rezeptversion

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Duplizieren und lesen als neue Rezeptversion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion legt eine neue Rezeptversion für das ausgewählte Rezept an. Die Rezeptwerte werden mit den Werten des gewählten Rezeptes belegt. Anschließend werden die Werte aus der Steuerung eingelesen. Können die Werte nicht eingelesen werden, dann stammen die Werte des Duplikats nicht mehr von der Steuerung, sondern werden lediglich vom Originalrezept kopiert.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezeptwerte auf Schattenvariablen schreiben

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezeptwerte auf Schattenvariablen schreiben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion schreibt Rezeptwerte auf eine Schattenvariable.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Schattenvariablen auf Rezeptwerte schreiben

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Schattenvariablen auf Rezeptwerte schreiben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion schreibt Werte der Schattenvariablen auf Rezeptwerte.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept. Sind die Werte der Variablen ungültig, werden keine Rezepte geöffnet.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


XML exportieren alles

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> XML exportieren alles

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion exportiert den gesamten Inhalt des RGM in eine XML-Datei.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Dateiauswahl

Einstellungen für Vergabe des Dateinamens der Exportdatei. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Dateiname statisch
  • Dateiname aus Variable
  • Dateiname automatisch generieren

Sofern kein anderer Ordner angegeben wird, wird die Exportdatei im Export-Ordner des Projekts abgelegt:

%CD_USERDATA%\[Project]\Export

Dateiname statisch:

Der Name der Exportdatei wird vom Benutzer direkt definiert. Der Dateiname kann als absoluter Pfad oder relativ zum eingestellten Exportpfad angegeben werden. Zusätzlich besteht die Möglichkeit, den Dateinamen durch Platzhalter dynamisch zu generieren.

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Ordners und Vergabe eines Namens.

Wird ein Name ohne Pfad angegeben, wird die Exportdatei in den Runtime-Ordner geschrieben.

Dateiname aus Variable:

Der Name der Exportdatei wird durch den Inhalt einer String-Variable definiert. Klick auf Schaltfläche ... öffnet Auswahldialog für Variable. Auch die Variable kann den Dateinamen mit Absolutpfad, Relativpfad und mit Platzhaltern ausgeben.

Dateiname automatisch generieren:

Der Name der Exportdatei wird automatisch erstellt. Er setzt sich zusammen aus dem Präfix RGM plus dem Platzhalter <DateTime>.

Zum Beispiel: RGM 10_11_2011 10_42_29.xml

Vorhandene Datei überschreiben

Aktiv: Eine im Ordner bereits vorhandene Datei gleichen Namens wird überschrieben.

Inaktiv: Der Export wird abgebrochen, wenn eine Datei gleichen Namens vorhanden ist.

Default: inaktiv

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.

Noch in diesem Kapitel

Platzhalter für dynamische Pfade


Platzhalter für dynamische Pfade

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> XML exportieren alles -> Platzhalter für dynamische Pfade

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Platzhalter

Bedingung

Ergebnis

<ProjectName>
  • Immer

Projektname

<DateTime>
  • Immer

Datum und die Uhrzeit im Format entsprechend der Systemeinstellungen.

Alle für Dateinamen ungültigen und unerwünschten Zeichen werden durch Unterstrich (_) ersetzt.

Für Deutsch(Deutschland) wird zum Beispiel das Datum 24.12.2001, um 16:04 Uhr und 59 Sekunden zu: 24_12_2011 16_04_59

<RGMGroupName>
  • Export einer Gruppe
  • Export eines Rezeptes
  • Import mit Gruppenauswahl

Name der ausgewählten Rezeptgruppe.

<RGMRecipeName>
  • Export eines Rezeptes

Name des ausgewählten Rezepts.

<RGMRecipeVersion>
  • Export eines Rezeptes

Versionsnummer des ausgewählten Rezepts.


XML exportieren Rezeptgruppe

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> XML exportieren Rezeptgruppe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion exportiert die ausgewählte Rezeptgruppe samt Inhalt in eine XML-Datei.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Dateiauswahl

Einstellungen für Vergabe des Dateinamens der Exportdatei. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Dateiname statisch
  • Dateiname aus Variable
  • Dateiname automatisch generieren

Sofern kein anderer Ordner angegeben wird, wird die Exportdatei im Export-Ordner des Projekts abgelegt:

%CD_USERDATA%\[Project]\Export

Dateiname statisch:

Der Name der Exportdatei wird vom Benutzer direkt definiert. Der Dateiname kann als absoluter Pfad oder relativ zum eingestellten Exportpfad angegeben werden. Zusätzlich besteht die Möglichkeit, den Dateinamen durch Platzhalter dynamisch zu generieren.

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Ordners und Vergabe eines Namens.

Wird ein Name ohne Pfad angegeben, wird die Exportdatei in den Runtime-Ordner geschrieben.

Dateiname aus Variable:

Der Name der Exportdatei wird durch den Inhalt einer String-Variable definiert. Klick auf Schaltfläche ... öffnet Auswahldialog für Variable. Auch die Variable kann den Dateinamen mit Absolutpfad, Relativpfad und mit Platzhaltern ausgeben.

Dateiname automatisch generieren:

Der Name der Exportdatei wird automatisch erstellt. Er setzt sich zusammen aus dem Präfix RGM plus dem Platzhalter <RGMGroupName>.

Zum Beispiel: <RGM GroupName>.xml ergibt für die Gruppe 1: Gruppe 1.xml.

Vorhandene Datei überschreiben

Aktiv: Eine im Ordner bereits vorhandene Datei gleichen Namens wird überschrieben.

Inaktiv: Der Export wird abgebrochen, wenn eine Datei gleichen Namens vorhanden ist.

Default: inaktiv

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.

Platzhalter für dynamische Pfade

Platzhalter

Bedingung

Ergebnis

<ProjectName>
  • Immer

Projektname

<DateTime>
  • Immer

Datum und die Uhrzeit im Format entsprechend der Systemeinstellungen.

Alle für Dateinamen ungültigen und unerwünschten Zeichen werden durch Unterstrich (_) ersetzt.

Für Deutsch(Deutschland) wird zum Beispiel das Datum 24.12.2001, um 16:04 Uhr und 59 Sekunden zu: 24_12_2011 16_04_59

<RGMGroupName>
  • Export einer Gruppe
  • Export eines Rezeptes
  • Import mit Gruppenauswahl

Name der ausgewählten Rezeptgruppe.

<RGMRecipeName>
  • Export eines Rezeptes

Name des ausgewählten Rezepts.

<RGMRecipeVersion>
  • Export eines Rezeptes

Versionsnummer des ausgewählten Rezepts.


XML exportieren Rezept

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> XML exportieren Rezept

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion exportiert das ausgewählte Rezept in eine XML-Datei. Der Name der Rezeptgruppe wird mit exportiert. Werden Rezeptgruppen nach dem Export umbenannt, geht diese Zuordnung beim Import verloren.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Dateiauswahl

Einstellungen für Vergabe des Dateinamens des Exportdatei. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Dateiname statisch
  • Dateiname aus Variable
  • Dateiname automatisch generieren

Sofern kein anderer Ordner angegeben wird, wird die Exportdatei im Export-Ordner des Projekts abgelegt:

%CD_USERDATA%\[Project]\Export

Dateiname statisch:

Der Name der Exportdatei wird vom Benutzer direkt definiert. Der Dateiname kann als absoluter Pfad oder relativ zum eingestellten Exportpfad angegeben werden. Zusätzlich besteht die Möglichkeit, den Dateinamen durch Platzhalter dynamisch zu generieren.

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Ordners und Vergabe eines Namens.

Wird ein Name ohne Pfad angegeben, wird die Exportdatei in den Runtime-Ordner geschrieben.

Dateiname aus Variable:

Der Name der Exportdatei wird durch den Inhalt einer String-Variable definiert. Klick auf Schaltfläche ... öffnet Auswahldialog für Variable. Auch die Variable kann den Dateinamen mit Absolutpfad, Relativpfad und mit Platzhaltern ausgeben.

Dateiname automatisch generieren:

Der Name der Exportdatei wird automatisch erstellt. Er setzt sich zusammen aus dem Präfix RGM plus dem Platzhalter <RGMRecipeName>.<RGMRecipeVersion>.

Zum Beispiel: <RGMRecipeName>.<RGMRecipeVersion> ergibt für das Rezept Rezept 1 mit der Version 3: Rezept 1.3.xml.

Vorhandene Datei überschreiben

Aktiv: Eine im Ordner bereits vorhandene Datei gleichen Namens wird überschrieben.

Inaktiv: Der Export wird abgebrochen, wenn eine Datei gleichen Namens vorhanden ist.

Default: inaktiv

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


XML importieren

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> XML importieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion importiert den Inhalt der angegebenen XML-Datei. Sind darin einzelne Rezepte ohne Gruppenzugehörigkeit vorhanden, dann werden diese Rezepte in die ausgewählte Gruppe importiert, sonst wird die Gruppenauswahl ignoriert:

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe, in die Rezepte ohne Zuordnung importiert werden sollen. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable
  • über Importdatei

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Sind in der XML-Datei bereits Rezeptgruppen enthalten, wird diese Einstellung ignoriert.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezeptgruppenname aus Datei.

Der Name der Rezeptgruppe wird aus der zu importierenden Datei übernommen.

Dateiauswahl

Einstellungen für Auswahl der Datei, aus der importiert wird. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Dateiname statisch
  • Dateiname aus Variable

Standardordner für exportierte Daten ist der Export-Ordner des Projekts:

%CD_USERDATA%\[Project]\Export

Dateiname statisch:

Der Name der Importdatei wird vom Benutzer direkt definiert. Der Dateiname kann als absoluter Pfad oder relativ zum eingestellten Exportpfad angegeben werden. Zusätzlich besteht die Möglichkeit, den Dateinamen durch Platzhalter dynamisch zu generieren.

Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Ordners und einer Datei.

Dateiname aus Variable:

Der Name der Importdatei wird durch den Inhalt einer String-Variable definiert. Klick auf Schaltfläche ... öffnet Auswahldialog für Variable. Auch die Variable kann den Dateinamen mit Absolutpfad, Relativpfad und mit Platzhaltern ausgeben.

Vorhandene Rezepte überschreiben

Aktiv: Bereits vorhandene Rezepte gleichen Namens werden beim Import überschrieben.

Inaktiv: Bereits vorhandene Rezepte werden nicht überschrieben. Es werden nur die neuen Rezepte angelegt.

Default: inaktiv

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Detaillierte Rezeptdaten zur Dokumentation in XML speichern

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Detaillierte Rezeptdaten zur Dokumentation in XML speichern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion exportiert detaillierte Rezeptdaten zur Dokumentation in eine XML-Datei.

Hinweis: Diese Daten können nicht mehr importiert werden. Sie sind als Grundlage für die exakte Dokumentation gedacht.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen


Rezept in Textdatei exportieren

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezept in Textdatei exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion exportiert das ausgewählte Rezept in eine Textdatei.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe und des Rezepts. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezept

Einstellungen für Rezeptauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezept statisch
  • Rezeptname aus Variable Name
  • Rezeptname aus Variable Nr.

Rezept statisch:

Auswahl eines bereits erstellten Rezepts.

Rezeptname aus Variable Name:

Rezeptname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezeptnummer aus Variable Nr.:

Rezeptnummer wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept.

Rezeptversion

Auswahl der Rezeptversion aus bereits bestehenden Versionen oder über eine Variable.

Rezeptversion statisch:

Auswahl einer bestehenden Rezeptversion aus Dropdownliste. Mögliche Auswahl:

  • bereits bestehende Rezeptversion
  • Kleinste Version;
    zusätzlich Auswahl eines Rezeptstatus möglich
  • Größte Version;
    zusätzlich Auswahl eines Rezeptstatus möglich

Rezeptversion aus Variable:

Rezeptversion wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird die Rezeptversion aus einer nummerischen Variable geholt, dann gilt:

  • Wert 90000 entspricht statischem Kleinste Version
  • Wert 90001 entspricht statischem Größte Version

Rezeptstatus

Auswahl des Rezeptstatus aus bereits bestehenden Status oder über eine Variable.

Rezeptstatus statisch:

Der Rezeptstatus wird in Kombination mit der Version gewertet. Steht nur zur Verfügung, wenn die Rezeptversion den Wert Kleinste Version oder Größte Version hat oder aus einer Variablen übernommen wird.
Beispiel: Größte Version mit Status start.

Auswahl eines Rezeptstatus aus Dropdownliste:

  • bestehender Status
  • Alle

Rezeptstatus aus Variable:

Rezeptstatus wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Hinweis: Wird der Rezeptstatus aus einer nummerischen Variable geholt, dann gilt:

  • Wert 0 wird als Alle gewertet
  • kann der Status im Rezept nicht gefunden werden, wird die Aktion abgebrochen

Dateiauswahl

Einstellungen für Vergabe des Dateinamens des Exportdatei. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Dateiname statisch
  • Dateiname aus Variable
  • Dateiname automatisch generieren

Sofern kein anderer Ordner angegeben wird, wird die Exportdatei im Export-Ordner des Projekts abgelegt:

%CD_USERDATA%\[Project]\Export

Dateiname statisch:

Der Name der Exportdatei wird vom Benutzer direkt definiert. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Ordners und Vergabe eines Namens.

Wird ein Name ohne Pfad angegeben, wird die Exportdatei in den Runtime-Ordner geschrieben.

Dateiname aus Variable:

Der Name der Exportdatei wird durch den Inhalt einer String-Variable definiert. Klick auf Schaltfläche ... öffnet Auswahldialog für Variable.

Dateiname automatisch generieren:

Der Name der Exportdatei wird automatisch erstellt. Er ssetzt sich zusammen aus dem Präfix RGM plus Datum und Uhrzeit.

Zum Beispiel: RGM 10_11_2011 10_42_29.txt

Vorhandene Datei überschreiben

Aktiv: Eine im Ordner bereits vorhandene Datei gleichen Namens wird überschrieben.

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Rezept von Textdatei importieren

Handbuch -> Rezeptgruppen-Manager -> Funktionen -> Funktion Rezeptgruppen-Manager -> Rezept von Textdatei importieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion importiert Daten aus einer Textdatei.

Parameter

Beschreibung

Aktion

Zeigt die im Dialog Funktion Rezeptgruppen-Manager ausgewählte Aktion an. Nur Anzeige, keine Auswahl möglich.

Rezeptgruppen-/
Rezeptauswahl

Auswahl der Rezeptgruppe, in die importiert werden soll. Die Auswahl kann erfolgen:

  • statisch aus vordefinierten Einträgen
  • dynamisch über Variable
  • über Importdatei

Klick auf Eigenschaft öffnet Dropdownliste zur Auswahl der Methode.

Rezeptgruppe

Einstellungen für Rezeptgruppenauswahl. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Rezeptgruppe statisch
  • Rezeptgruppenname aus Variable

Rezeptgruppe statisch:

Auswahl einer bereits erstellten Rezeptgruppe.

Rezeptgruppenname aus Variable:

Rezeptgruppenname wird aus einer Variablen übernommen. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Rezeptgruppenname aus Datei.

Der Name der Rezeptgruppe wird aus der zu importierenden Datei übernommen.

Dateiauswahl

Einstellungen für Auswahl der Datei, aus der importiert wird. Klick auf Beschriftung öffnet Dropdownliste für Auswahl:

  • Dateiname statisch
  • Dateiname aus Variable

Standardordner für exportierte Daten ist der Export-Ordner des Projekts:

%CD_USERDATA%\[Project]\Export

Dateiname statisch:

Der Name der Importdatei wird vom Benutzer direkt definiert. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Ordners und einer Datei.

Dateiname aus Variable:

Der Name der Importdatei wird durch den Inhalt einer String-Variable definiert. Klick auf Schaltfläche ... öffnet Auswahldialog für Variable.

Vorhandene Rezepte überschreiben

Aktiv: Bereits vorhandene Rezepte gleichen Namens werden beim Import überschrieben.

Runtime Einstellungen

Einstellungen für die Bedienung zur Runtime.

Dialog zur Runtime anbieten

Aktiv: Dialog wird zur Runtime für Änderungen angeboten.

Rezeptgruppenauswahl zur Runtime sperren

Aktiv: Auswahl der Rezeptgruppe wird zur Runtime gesperrt.

Steht nur zur Verfügung, wenn Dialog zur Runtime anbieten aktiv ist.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Einstellungen und schließt Dialog. Die Funktion wird erstellt, allerdings ohne Ziel.

Hilfe

Öffnet Online-Hilfe.


Bedienen zur Runtime

Handbuch -> Rezeptgruppen-Manager -> Bedienen zur Runtime

Zur Runtime steht über eine Bildumschaltung das im Editor projektierte Bild zur Verfügung.

Projektierung: Siehe Abschnitt Bild vom Typ Rezeptgruppen-Manager anlegen.

Rezeptliste

In der Liste kann jeweils ein einzelner Eintrag selektiert werden. Das gewählte Rezept wird in der Rezeptwerttabelle im Bild dargestellt und kann mit den Buttons bearbeitet werden (umbenennen, löschen, ...).

Wird die Liste gemeinsam mit den Dropdownlisten Rezeptname und/oder Rezeptversion eingesetzt, wird die Auswahl synchronisiert. Wird also die Auswahl in einer Dropdownliste geändert, ändert sich auch die Auswahl in der Rezeptiste und umgekehrt. Sollte der gewählte Eintrag in der Liste durch ein Filterkriterium nicht sichtbar sein, wird in der Liste nichts ausgewählt.

Neue Rezepte und neue Rezeptversionen werden unabhängig von den Filterkriterien am Ende der Liste angefügt. Geänderte Rezeptdaten, z.B. der Text eines Kommentares oder der Status, werden erst nach dem Speichern des Rezepts dargestellt. Texte der Kommentare und Überschriften der Spalten werden sprachübersetzt.

Gestaltung der Rezeptliste: Siehe Abschnitt Aussehen der Rezeptliste.

Rezeptname oder Rezeptnummer ändern

Der Rezeptname muss eindeutig sein. Die Rezeptnummer wird nicht auf Eindeutigkeit überprüft. Diese wird nur verwendet, um über die Funktion Rezeptgruppen-Manager ein Rezept über eine Variable aufzurufen. Sind mehrere Rezepte mit gleicher Nummer vorhanden, verwendet zenon das zuerst gefundene Rezept.

Aktualität der dargestellten Informationen

Das RGM-Bild arbeitet zur Runtime mit einer Kopie der RGM-Datenbank.

Beim Öffnen des RGM-Bildes zur Runtime wird die aktuelle Information aus der Datenbank angezeigt. Diese Anzeige wird nicht automatisch aktualisiert.

Änderungen werden wie folgt aktualisiert:

  • Ändert sich durch Ausführen einer Funktion (z.B. Rezeptgruppenmanager - alle Werte lesen) oder durch Editieren des Bildes in einem Client der Inhalt, wird die Änderung im aktuell geöffneten Bild nicht angezeigt. Um Änderungen anzuzeigen,muss das Bild geschlossen und erneut geöffnet werden. Damit wird die Datenbank neu eingelesen und die aktualisierte Stand angezeigt.
  • Neue Rezeptgruppen werden mit dem erneuten Öffnen des Bildes sofort angezeigt, Variablen eventuell erst nach einem Reload.
  • Im Editor geänderte Rezepte oder Rezeptgruppen werden erst nach einem Reload angezeigt.

attention Achtung

Wenn die Variable für die Sichtbarkeit (Eigenschaft Sichtbarkeit/Variable) ihren Wert ändert während ein RGM-Bild geöffnet ist, das diese Variable enthält, wird das RGM-Bild neu geöffnet. Nicht gespeicherte Änderungen am Bild gehen dabei verloren.

Interne ID: Bedienen zur Runtime

Variable

Name der Variablen, deren Wert die Sichtbarkeit des Elements beeinflusst. Die Sichtbarkeit wird entweder aus den Grenzwerteigenschaften dieser Variablen übernommen oder durch den Wertbereich bestimmt, der bei den Eigenschaften von und bis definiert ist.
Ein Klick auf die Schaltfläche öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden.
Wenn keine Variable verknüpft ist, ist das Element immer sichtbar.

Interne ID: Bedienen zur Runtime

bis

Nur verfügbar, nachdem eine Variable ausgewählt wurde und wenn die Sichtbarkeit nicht vom Grenzwert übernommen wird:
Größter Wert der Variable, bei dem das Element sichtbar ist.
Minimum: niedrigstmöglicher Wert der verknüpften Variable.
Maximum: höchstmöglicher Wert der verknüpften Variable.
Default: höchstmöglicher Wert der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bedienen zur Runtime

von

Nur verfügbar, nachdem eine Variable ausgewählt wurde und wenn die Sichtbarkeit nicht vom Grenzwert übernommen wird:
Kleinster Wert der Variable, bei dem das Element sichtbar ist.
Minimum: niedrigstmöglicher Wert der verknüpften Variable.
Maximum: höchstmöglicher Wert der verknüpften Variable.
Default: niedrigstmöglicher Wert der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bedienen zur Runtime

Sichtbarkeit

Eigenschaften für die Sichtbarkeit des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Wertanzeige als Text

Statusinformationen bei Rezepten und Rezeptgruppen Manager

Werte über ein Bild in ein Rezept schreiben (Schattenvariablen)


Wertanzeige als Text

Handbuch -> Rezeptgruppen-Manager -> Bedienen zur Runtime -> Wertanzeige als Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Voraussetzung

Wenn Sie in der Runtime für einen Wert auch die Bedeutung des Wertes innerhalb des Rezepts anzeigen möchten, müssen Sie einige Voraussetzungen erfüllen.

Legen Sie für die Variablen, die Sie im Rezept verwenden, eine Reaktionsmatrix vom Typ numerisch oder String an (der Typ der Reaktionsmatrix muss zum Typ der verwendeten Variable passen). In der Reaktionsmatrix definieren Sie "ist gleich" Zustände und geben die gewünschte Bedeutung - den anzuzeigenden Text - an.
Um sich Texte anzeigen zu lassen, können Sie auch Grenzwerte oder Reaktionsmatrizen vom Typ binär mit anderen Zuständen als "ist gleich" verwenden. Wenn Sie so vorgehen, können Sie jedoch die Funktionalität im Bild vom Typ Keyboard nicht nutzen.

Anzeige in der Runtime

Die Rezepttabelle im Bild vom Typ Rezeptgruppen-Manager zeigt in der Spalte Wertanzeige als Text die jeweils verknüpften Grenzwerttexte entweder aus der Reaktionsmatrix oder aus dem Grenzwert, die vom Rezeptwert verletzt sind.

In selbst-projektierten RGM-Tabellen können Sie dieselbe Funktionalität mithilfe der Funktionen recipew und recipef mit dem Parameter symbolik erreichen.

Wenn ein Rezeptwert geändert wird und dabei ein Zustand oder Grenzwert verletzt wird, wird der angezeigte Grenzwerttext sofort nachgezogen.

Einträge in die Chronologische Ereignisliste

Bei Rezeptwertänderungen oder beim Absetzen eines Rezepts (Rezeptwerts) werden nicht nur die Werte, sondern auch die entsprechenden Grenzwerttexte in den CEL-Eintrag geschrieben. Wenn kein Zustand oder Grenzwert verletzt ist, wird nur der Wert eingetragen.


Statusinformationen bei Rezepten und Rezeptgruppen Manager

Handbuch -> Rezeptgruppen-Manager -> Bedienen zur Runtime -> Statusinformationen bei Rezepten und Rezeptgruppen Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Während der Runtime werden Statusinformationen zur Verfügung gestellt beim

  • Schreiben/Lesen
  • Exportieren/Importieren
  • und Sichern

Wird ein Rezept geschrieben, enthält die Variable das Ergebnis der Schreiboperation.

Werte

Rezept schreiben

Systemtreibervariable: Standard-Rezept/RGM-Rezept fertig abgesetzt

Wert | Ergebnis
0 | Initialisierungswert vor dem Rezept absetzen
1 | Schreiben wurde erfolgreich ausgeführt
2 | Schreiben wurde nicht ausgeführt, da Parameterfehler vorliegt
3 | Schreiben wurde nicht erfolgreich ausgeführt
4 | warte auf "fertig"
5 | Schreiben abgebrochen, da Runtime beendet wird
6 | Timeout aufgetreten

Hinweis: Ist die Netzwerkfunktionalität im Projekt aktiv, so ist für die am lokalen Rechner ausgeführte Funktion die Systemtreibervariable Standard-Rezept/RGM-Rezept fertig abgesetzt (local) relevant.

info Info

Unter Schreiben wird das Schreiben auf den Treiber verstanden. Dieser überträgt danach das Rezept zur Steuerung. Das bedeutet:

  • Eigenschaft Synchron schreiben inaktiv: Der Wert 1 für Standard-Rezept/RGM-Rezept fertig abgesetzt bedeutet nicht, dass die Werte auf der Steuerung sind. Sie wurden lediglich auf den Treiber egschrieben..

    Interne ID: Statusinformationen bei Rezepten und Rezeptgruppen Manager

    Synchron schreiben

    Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
    Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
    Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
    Inaktiv: Es wird keine Schreibbestätigung abgewartet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Eigenschaft Synchron schreiben aktiv: Die Wertänderung erfolgt erst, wenn alle Werte auf der Steuerung aktuell sind.

Hinweis: Die Fortschrittsanzeige beim Schreiben wird nur angezeigt, wenn Synchron schreiben aktiviert ist.

Rezept in Abarbeitung

Systemtreibervariable: Standard-Rezept/RGM-Rezept Funktion in Abarbeitung

Wert

Ergebnis

-1

wird ausgeführt

0

Initialisierungswert erfolgreich gelesen

1

Benutzer hat keine Bedienberechtigung

2

keine Berechtigung im Netzwerk

3

Abbruch durch Benutzer

4

Fehler - nicht alles konnte erfolgreich gelesen werden, z.B

  • Unterbrechung der Kommunikation zur Hardware vor Beginn des Einlesens
  • ein Datenbaustein ist auf der Steuerung nicht vorhanden
  • Fehler während der Übertragung aufgetreten

5

Fehler beim Speichern der Rezeptdatei

Bildtyp-spezifische Funktionen

Beim

  • Lesen (Systemtreibervariable: Standard-Rezept/RGM-Rezept alle Werte fertig gelesen),
  • Exportieren/Importieren und
  • Sichern

eines Rezeptes mittels Bildtyp-spezifischer Funktion stehen folgende Werte zur Verfügung:

Wert

Ergebnis

0

Initialisierungswert wartet auf Antwort vom Treiber

1

erfolgreich gelesen

2

Fehler beim Lesen, Exportieren/Importieren oder Sichern:

  • Unterbrechung der Kommunikation zur Hardware vor Beginn des Einlesens
  • ein Datenbaustein ist auf der Steuerung nicht vorhanden
  • Fehler während der Übertragung aufgetreten


Werte über ein Bild in ein Rezept schreiben (Schattenvariablen)

Handbuch -> Rezeptgruppen-Manager -> Bedienen zur Runtime -> Werte über ein Bild in ein Rezept schreiben (Schattenvariablen)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Werte in Rezepte können zur Runtime direkt über Bilder geändert werden. Dazu werden sogenannte Schattenvariablen benutzt, die im RGM über die Funktion Rezeptgruppen-Manager gelesen und geschrieben werden können.

Interne ID: Werte über ein Bild in ein Rezept schreiben (Schattenvariablen)

Rezeptgruppen-Manager

Diese Funktion schreibt, liest, kopiert, importiert oder exportiert ein ausgewähltes Rezept des optionalen Moduls Rezeptgruppen Manager (RGM). Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch

Schattenvariable definieren

Für jede in einer Rezeptgruppe vorhandene Variable kann eine Schattenvariable definiert werden. Jede Schattenvariable kann pro Rezeptgruppe nur einmal verwendet werden. Nicht jede Variable der Rezeptgruppe muss über eine Schattenvariable verfügen. Um eine Schattenvariable zu definieren:

  1. markieren Sie die Variable der Rezeptgruppe
  2. navigieren Sie in den Eigenschaften in die Gruppe Allgemein

    Interne ID: Werte über ein Bild in ein Rezept schreiben (Schattenvariablen)

    Allgemein

    Allgemeine Eigenschaften für Variable in Rezeptgruppe.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. klicken Sie in die Eigenschaft Schattenvariable

    Interne ID: Werte über ein Bild in ein Rezept schreiben (Schattenvariablen)

    Schattenvariable

    Schattenvariablen ermöglichen zur Runtime das Ändern eines RGM Rezeptwerts über ein Bild. Für jede in einer Rezeptgruppe vorhandene Variable kann eine Schattenvariable definiert werden. Zur Runtime wird die RGM Variable über die Funktion Rezeptgruppen-Manager mit der die Aktion Rezeptwerte auf Schattenvariablen schreiben durch eine durch eine Schattenvariable ersetzt und nach einer Änderung über die Aktion Schattenvariablen auf Rezeptwert schreiben in den RGM zurückgeschrieben.

    Klick auf Schaltfläche öffnet Dialog zur AUswahl der Schattenvaríablen. Pro Rezeptgruppe kann eine Schattenvariable nur einmal verwendet werden.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. der Dialog zur Auswahl einer Variablen wird geöffnet
  5. wählen Sie die gewünschte Schattenvariable
  6. bestätigen Sie den Dialog mit OK

Ablauf Projektierung

  1. Für jede Variable, deren Werte zur Runtime über ein Bild änderbar sein sollen, definieren Sie beim Projektieren eine Schattenvariable.
    Diese legen Sie in der Eigenschaft Allgemein/Schattenvariable fest.
  2. Projektieren Sie ein Bild, das die änderbaren Rezeptwerte darstellt, zum Beispiel einen Tank.
  3. Verknüpfen Sie das Bild mit der Funktion Rezeptgruppen-Manager und wählen Sie die Aktion Rezeptwerte auf Schattenvariablen schreiben.
  4. Projektieren Sie im Bild einen Button.
  5. Verknüpfen Sie den Button mit der Funktion Rezeptgruppen-Manager und wählen Sie die Aktion Schattenvariablen auf Rezeptwerte schreiben.

Ablauf Runtime

  1. Das Bild zum Setzen der Werte für den RGM wird aufgerufen.
  2. Dabei werden die Variablen durch die Schattenvariablen substituiert.
  3. Beim Öffnen des Bildes wird die Funktion Rezeptgruppen-Manager mit der Aktion Rezeptwerte auf Schattenvariablen schreiben aufgerufen.
  4. Die Rezeptwerte werden im Bild angezeigt und können geändert werden.
  5. Geänderte Werte werden über den Button mit der die Funktion Rezeptgruppen-Manager/Schattenvariablen auf Rezeptwerte schreiben in das Rezept am RGM geschrieben.
  6. Sollte ein Fehler auftreten, kann dies über die Systemtreibervariablen und die Einträge in LOG-Dateien ausgewertet werden.


Fehlerbehandlung

Handbuch -> Rezeptgruppen-Manager -> Fehlerbehandlung

Fehler können über Systemtreibervariablen und Fehlermeldungen ausgewertet werden. Meldungen der Systemtreibervariablen finden Sie Kapitel Handbuch Systemtreibervariablen, Abschnitt Thema RGM.

Log-Dateien

Eintrag

Ebene

Bedeutung

COM Events

COM Event "RecipeCreate" returned with "bCancel == TRUE"

logLe_DEBUG

Meldung für COM Events, wenn die jeweilige Aktion über den Funktionsparameter bCancel abgebrochen wurde:

  • RecipeCreate
  • VersionCreate
  • RecipeDuplicate
  • VersionDuplicate
  • VersionDuplicateRead
  • RecipeRename
  • RecipeDelete
  • VersionDelete

Wenn die Aktion nicht in der Eventfunktion abgebrochen wurde, erscheint kein spezieller Loggingeintrag.

Schattenvariablen

RGM: Teached value out of min max range. Variable: "x1", Value: x2, FromShadow: x3

FAILED

Ein eingelesener Wert verletzt den min. Wert oder den max. Wert der Sollwertgrenzen des Rezepts.

  • x1: Name der Variable
  • x2: normierter Wert der Variable
  • x3: Hinweis Prozesswert oder Wert einer Schattenvariablen

Error while reading current value for CEL logging.

INTERNAL

Beim Einlesen der Momentanwerte für das CEL-Logging (Rezept absetzen) ist ein Fehler aufgetreten. Mögliche Ursachen:

  • ein Wert ist ausserhalb der Grenzen für min. Wert und max. Wert
    -> zusätzlicher Eintrag RGM: Teached value out of min max range. Variable: "x1", Value: x2, FromShadow: x3
  • ein Wert hat den Status INVALID
  • der Timeout wurde erreicht

Pop-up Meldungen

Meldung | Bedeutung
Der Name "Rezept\Test" enthält ungültige Zeichen (\"'./*?<>!|). | Der eingegebene Rezeptgruppenname bzw. Rezeptname entspricht nicht den Richtlinien für Namensvergabe. Klammerausdruck enthält nicht zugelassene Zeichen.
Version "7" von Rezept "Rezept1" löschen? | Sicherheitsabfrage vor dem Löschen einer Rezeptversion im RGM Bild zur Runtime..


Beispiele

Handbuch -> Rezeptgruppen-Manager -> Beispiele

Hier finden Sie Beispiele für die Projektierung:

Noch in diesem Kapitel

Schreiben der höchsten Rezeptversion mit dem Status freigegeben auf die Steuerung

Sprachumschaltung des Anzeigetextes im Element Dynamischer Text


Schreiben der höchsten Rezeptversion mit dem Status freigegeben auf die Steuerung

Handbuch -> Rezeptgruppen-Manager -> Beispiele -> Schreiben der höchsten Rezeptversion mit dem Status freigegeben auf die Steuerung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um zur Runtime die höchste Rezeptversion mit dem Status freigegeben auf die Steuerung zu schreiben:

  1. Anlegen von Statustexten für die Rezeptstatus:
    1. öffnen Sie die Eigenschaft Bezeichner Rezeptstatus im Rezeptgruppen Manager

      Interne ID: Schreiben der höchsten Rezeptversion mit dem Status freigegeben auf die Steuerung

      Rezeptgruppen Manager

      Definieren Sie die Dateiablage für den Rezeptgruppen-Manager.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      Interne ID: Schreiben der höchsten Rezeptversion mit dem Status freigegeben auf die Steuerung

      Bezeichner Rezeptstatus

      Konfiguration der Statusbezeichner. Klick auf Eigenschaft öffnet Dialog zur Konfiguration. Liste der Status wird bei der Statusauswahl im Rezept verwendet.

      Mehr in der Online-Hilfe.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    2. erstellen Sie im Dialog die Status:

      - 1 Entwurf

      - 2 geprüft

      - 3 freigegeben

      - 4 gesperrt

      - 5 gelöscht

    Tipp: Hier können Sie die Statustexte durch ein voran gestelltes @ auch als Schlüsselwörter für die Sprachumschaltung definieren (z.B.: @freigegeben).

  2. Anlegen von mehreren Rezeptversionen:
    1. legen Sie über das Kontextmenü eine neue Rezeptgruppe an
    2. verknüpfen Sie Variablen mit der Rezeptgruppe
    3. legen Sie ein neues Rezept an
    4. legen Sie eine neue Version für das Rezept an
    5. ändern Sie die den Status in der zweiten Version des Rezeptes auf 3 freigegeben
  3. Erstellen der Funktion:
    1. markieren Sie das Rezept und wählen Sie im Kontextmenü oder in der Symbolleiste Standard-Funktion erzeugen
    2. der Dialog zur Konfiguration wird geöffnet
    3. wählen Sie Rezept absetzen
    4. setzen Sie Rezeptversion auf >
    5. wählen Sie bei Rezeptstatus statisch den Eintrag 3 freigegeben

Wird die Funktion zur Runtime ausgeführt, dann wird die höchste vorhandene Version des Rezepts mit dem Status 3 - freigegeben auf die Steuerung geschrieben. Wird nun zum Beispiel eine neue Rezeptversion angelegt und erhält diese den Status 3 - freigegeben, dann wird beim nächsten Aufruf der Funktion diese neue Version auf die Steuerung geschrieben.


Sprachumschaltung des Anzeigetextes im Element Dynamischer Text

Handbuch -> Rezeptgruppen-Manager -> Beispiele -> Sprachumschaltung des Anzeigetextes im Element Dynamischer Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Sprachumschaltung für ein Element vom Typ Dynamischer Text zu benutzen, legen Sie dieses im Editor an und schalten es zur Runtime um.

Im Editor

Um ein Dynamisches Element vom Typ Dynamischer Text anzulegen und zu konfigurieren:

  1. Klicken Sie in der Symbolleiste für die Elemente auf das Symbol für Dynamischer Text und ziehen Sie das Element im Bild auf.
  2. Wählen Sie eine Stringvariable.
  3. Aktivieren Sie die Eigenschaft Anzeigetext übersetzen.

    Interne ID: Sprachumschaltung des Anzeigetextes im Element Dynamischer Text

    Anzeigetext übersetzen

    Aktiv: Die anzuzeigenden Texte werden übersetzt. Wird ein Text bearbeitet, wird der Entwurf ohne Übersetzung angezeigt.

    Default: inaktiv

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

In der Runtime

Die Sollwertvorgabe zeigt den Text als Rohwert an. Der Text ist editierbar:

Bei der ANzeige wird der Text durch die Sprachumschaltung modifiziert:


Runtime

Handbuch -> Runtime

Hier finden Sie Informationen zu Bedienmöglichkeiten während der Runtime.

zenon besteht aus der Projektierungsumgebung, dem Editor, und der Runtime:
Projekte werden im Editor erstellt, das Bedienen und Beobachten erfolgt in der Runtime.

tutorial Lizenzinformation

Die zenon Runtime ist lizenzpflichtig. Die Lizenz wird nach Anzahl der jeweils benötigten TAGs oder der IOs berechnet. Details zur Lizenzierung siehe Kapitel Lizenzierung.

Die Runtime steht als zenon Supervisor und als zenon Operator für >Embedded Betriebssysteme zur Verfügung. Beide Versionen unterscheiden sich im Funktionsumfang. Details siehe Einschränkungen für zenon Operator.

attention Achtung

Bildschirmauflösung: Benutzen Sie für optimale Darstellung zur Runtime die Standardeinstellung des Betriebssystems (100%).

Noch in diesem Kapitel

Starten der Runtime

Kompatibilität Runtime-Dateien

Bedienen zur Runtime

Runtimeprofile

Behandlung von Zeitangaben


Starten der Runtime

Handbuch -> Runtime -> Starten der Runtime

Die Runtime können Sie wie folgt starten:

  • aus dem Editor
    • mit Drücken der Taste F5
    • über das Symbol Runtime starten in der Symbolleiste Runtime Dateien
  • mit dem Startup-Tool
  • über das Windows-Startmenü
  • per Windows Autostart

Dienst zenAdminSrv

Zum Starten der Runtime muss der Dienst zenAdminSrv gestartet sein. Ist der Dienst nicht verfügbar, werden Sie mit der Fehlermeldung "Die Runtime kann nicht gestartet werden, da der Dienst 'zenAdminSrv' nicht erreichbar ist!" informiert.

Beim Start über Windows Autostart erhalten Sie die Fehlermeldung "Warten bis der Dienst 'zenAdminSrv' gestartet ist." zenon versucht dann so lange die Runtime zu starten, bis der Dienst verfügbar ist oder Sie die Fehlermeldung mit Drücken der Schaltfläche Cancel beenden. Dann wird die Runtime nicht gestartet.

Funktion "In den Vordergrund"

Die Runtime kann mit der Funktion In den Hintergrund hinter andere laufende Programm geschaltet werden. Mit der Funktion In den Vordergrund wird sie wieder in den Vordergrund geholt. info Info

Interne ID: Starten der Runtime

In den Vordergrund

Diese Funktion schaltet die zenon Runtime in den Vordergrund.

Achtung: Beim in den Vordergrund Schalten wird die Alarmstatuszeile überdeckt.

Mehr im Online-Handbuch

Interne ID: Starten der Runtime

In den Hintergrund

Diese Funktion schaltet die Runtime des Leitsystems in den Hintergrund.

Mehr im Online-Handbuch

Beim in der Vordergrund Schalten der Runtime wird das Runtime-Fenster als oberstes Fenster definiert. Damit wird die Alarmstatuszeile überdeckt. Um die Alarmstatuszeile wieder in den Vordergrund zu holen, können Sie:

  • Systemtasten aktivieren (Projekteigenschaft Systemtasten sperren deaktivieren) und mit Alt+Tab die Alarmstatuszeile wieder in den Vordergrund holen

    Interne ID: Starten der Runtime

    Systemtasten sperren

    Aktiv: Systemtasten wie Alt+Esc, Strg+Esc, Alt+Tab, Alt-F4 etc. werden in der Runtime gesperrt.
    Inaktiv: Systemtasten werden nicht gesperrt.
    Default: inaktiv

    Mehr im Online-Handbuch

    Hinweis: Weitere Systemtasten können zur Runtime über Keyblock Runtime Start gesperrt werden.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • die Windows Taskbar aktivieren und auf das Fenster Status klicken
  • die Runtime wieder in den Hintergrund schalten
  • die Runtime neu starten


Kompatibilität Runtime-Dateien

Handbuch -> Runtime -> Kompatibilität Runtime-Dateien

Die zenon Runtime arbeitet abwärtskompatibel. Die Runtime kann immer auch Projekte aus älteren Versionen laden und entsprechend dieser Version interpretieren und darstellen.

Projekte ab der Version 6.20 SP4 können direkt, also ohne vorhergehende Konvertierung, gestartet werden. Projekte mit niedrigerer Versionsnummer müssen zuvor konvertiert werden.

Auch gemischter Betrieb ist möglich. Das heißt: Mit der Mehrprojektverwaltung können gleichzeitig Projekte unterschiedlicher Versionen geladen werden und parallel laufen.

Online-Kompatibilität

Die Runtime Online-Kompatibilität ermöglicht die Interoperabilität von Runtime-Systemen (auch über Webclient) im zenon Netzwerk, selbst wenn die Version der Client-Runtime höher ist als jene der Server-Runtime.

Die aktuelle Runtime kann Projekte folgender Versionen laden:

  • 6.20 SP4
  • 6.21 SP0
  • 6.21 SP1
  • 6.22 SP0
  • 6.22 SP1
  • 6.50 SP0
  • 6.51 SP0
  • 7.00 SP0

Im Rahmen der Mehrprojektverwaltung können auch unterschiedliche Projekte geladen werden. Zum Beispiel kann das I-Projekt von der Version 7.00 sein, ein Unterprojekt von der Version 6.51 und ein weiteres Unterprojekt von der Version 6.22 SP1. Der gemischte Betrieb funktioniert auch im Netzwerkbetrieb. Damit können auch mit dem zenon Webclient Projekte unterschiedlicher Versionen gestartet werden.

Achtung: Server und Standby-Server müssen immer die gleiche Version haben.

Kompatibilität zwischen Editor und Runtime

Mit dem zenon Editor können Runtime-Dateien für unterschiedliche Runtime-Versionen erstellt werden. Die Version der Runtime muss damit nicht mit der Version des Editors übereinstimmen. Diese Abwärtskompatibilität eignet sich besonders für den Einsatz gemischter Systeme. Zum Beispiel: Ein Projekt, das mit dem Editor 6.50 projektiert wird, kann auch mit einer Runtime 6.22 gestartet werden.

attention Achtung

Werden in einem Projekt mit einem Editor der höheren Version Eigenschaften projektiert, die in der niedrigeren Version nicht verfügbar sind, stehen diese dort nicht zur Verfügung. Das kann zur Runtime zu unerwünschten Ergebnissen führen.

Runtime-Dateien erstellen

Um im Editor Runtime-Dateien für niedrigere Versionen zu erstellen:

  1. markieren Sie das Projekt im Projektbaum
  2. navigieren Sie in den Projekteigenschaften zum Abschnitt Allgemein

    Interne ID: Kompatibilität Runtime-Dateien

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. öffnen Sie die Dropdownliste der Eigenschaft RT Dateien erzeugen für

    Interne ID: Kompatibilität Runtime-Dateien

    RT Dateien erzeugen für

    Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt

    6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.

    6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.

    6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.

    6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.

    6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.

    6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.

    6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

    Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. wählen Sie die gewünschte Version:
    • Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt
    • 6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.
    • 6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.
    • 6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.
    • 6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.
    • 6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.
    • 6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.
    • 6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.


Bedienen zur Runtime

Handbuch -> Runtime -> Bedienen zur Runtime

Zur Runtime stehen Ihnen je nach Gerät und Projektierung als Eingabegeräte Maus und/oder Tastatur zur Verfügung.

Noch in diesem Kapitel

Maus

Tastaturbedienung


Maus

Handbuch -> Runtime -> Bedienen zur Runtime -> Maus

Ein Einfachklick mit der linken Maustaste auf ein Dynamisches Element öffnet (abhängig von den Einstellungen im Dynamischen Element) den Standard-Dialog für die Sollwert-Eingabe. Abhängig vom Datentyp der Variable werden folgende Dialoge aufgeschalten:

Mögliche Eingaben sind:

Kommando | Aktion
Umschalten auf Spontanwert | Anzeigen des Spontanwertes (Wert aus der Steuerung), wenn vorher der Ersatzwert angezeigt wurde bzw. der Wert abgeschaltet war.
Modifizieren Spontanwert (default) | Neuen Spontanwert in die Steuerung schreiben
Umschalten und Modi. Spontanwert | Gemeinsames Ausführen der beiden oberen Kommandos
Umschalten auf Ersatzwert | Anzeigen des Ersatzwertes (Wert aus der Variablendefinition), wenn vorher der Spontanwert angezeigt wurde
Modifizieren Ersatzwert | Neuen Ersatzwert für die Variable setzen
Umschalten und Modi. Ersatzwert | Gemeinsames Ausführen der beiden oberen Kommandos
Spontanwert abschalten | Verbindung zur Steuerung für diesen Wert durch Setzen des Status-Bits OFF (Bit 20) abschalten.
Spontanwert einschalten | Verbindung zur Steuerung für diesen Wert durch Zurücksetzen des OFF Bits wieder herstellen.
Setzen des Binärzustandes | - LOW (0) - HIGH (1)

Mögliche Eingaben sind:

Kommando | Aktion
Umschalten auf Spontanwert | Anzeigen des Spontanwertes (Wert aus der Steuerung), wenn vorher der Ersatzwert angezeigt wurdebzw. der Wert abgeschaltet war.
Modifizieren Spontanwert (default) | Neuen Spontanwert in die Steuerung schreiben.
Umschalten und Modi. Spontanwert | Gemeinsames Ausführen der beiden oberen Kommandos.
Umschalten auf Ersatzwert | Anzeigen des Ersatzwertes (Wert aus der Variablendefinition), wenn vorher der Spontanwert angezeigt wurde.
Modifizieren Ersatzwert | Neuen Ersatzwert für die Variable setzen
Umschalten und Modi. Ersatzwert | Gemeinsames Ausführen der beiden oberen Kommandos.
Spontanwert abschalten | Verbindung zur Steuerung für diesen Wert durch Setzen des Status-Bits OFF (Bit 20) abschalten.
Spontanwert einschalten | Verbindung zur Steuerung für diesen Wert durch Zurücksetzen des OFF Bits wieder herstellen.
Wert | Neuer numerischer Wert (innerhalb des erlaubten Messbereichs).

Mögliche Eingaben sind:

Kommando | Aktion
Umschalten auf Spontanwert | Anzeigen des Spontanwertes (Wert aus der Steuerung), wenn vorher der Ersatzwert angezeigt wurde bzw. der Wert abgeschaltet war.
Modifizieren Spontanwert (default) | Neuen Spontanwert in die Steuerung schreiben
Umschalten und Modi. Spontanwert | Gemeinsames Ausführen der beiden oberen Kommandos
Umschalten auf Ersatzwert | Anzeigen des Ersatzwertes (Wert aus der Variablendefinition), wenn vorher der Spontanwert angezeigt wurde
Modifizieren Ersatzwert | Neuen Ersatzwert für die Variable setzen
Umschalten und Modi. Ersatzwert | Gemeinsames Ausführen der beiden oberen Kommandos
Spontanwert abschalten | Verbindung zur Steuerung für diesen Wert durch Setzen des Status-Bits OFF (Bit 20) abschalten.
Spontanwert einschalten | Verbindung zur Steuerung für diesen Wert durch Zurücksetzen des OFF Bits wieder herstellen.
Text | Neuer Text

Lasso

Dynamische Elemente, die mit einer Variablen oder Funktion verknüpft sind, können zur Runtime mit dem Lasso vorausgewählt und damit für VBA Events genutzt werden.

Selektion per Lasso

Um zur Runtime Elemente mit dem Lasso auszuwählen muss:

  • in den Projekteigenschaften die Eigenschaft Runtime Einstellungen/Runtime Lasso aktiv sein

    Interne ID: Maus

    Runtime Lasso

    Aktiv: Durch Bewegen der Maus mit gedrückter linker Maustaste können in der Runtime mehrere Elemente selektiert werden. Auf diese Elemente kann dann ein VBA-Makro zugreifen.
    Inaktiv: Die Lassofunktionalität wird nicht verwendet.
    Default: inaktiv
    Hinweis: Lasso funktioniert nur für Elemente, die 'Über Tastatur erreichbar' sind und mit denen eine Variable oder Funktion verknüpft ist. Statische Elemente werden nicht ausgewählt. Die Lassofunktion kann für einzelne Bildelemente über die Eigenschaft Runtime/mit Lasso auswählbart aktiviert oder deaktiviert werden.

    Interne ID: Maus

    mit Lasso auswählbar

    Die Auswahl per Lasso zur Runtime ermöglicht die Identifizierung von Dynamischen Elementen für die Verwendung mit VBA Events.
    Aktiv: Das Element kann zur Runtime mit dem Lasso ausgewählt werden.
    Inaktiv: Das Element kann zur Runtime nicht ausgewählt werden.
    Default: aktiv

    Achtung: Damit das Element zur Runtime auswählbar ist, muss zusätzlich in den Projekteigenschaften die Eigenschaft Runtime Einstellungen/Runtime Lasso aktiviert sein!

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Maus

    Runtime

    Eigenschaften für das Runtime-Verhalten des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Maus

    Runtime Einstellungen

    Eigenschaften für das Runtime-Verhalten des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • in den Eigenschaften des Dynamischen Elements die Eigenschaft Runtime/mit Lasso auswählbar aktiv sein

Zur Runtime stehen mehrere Methoden zur Auswahl von Elementen zur Verfügung:

  • Elemente auswählen: Linksklick in einen freien Bildbereich und mit gedrückter Maustaste das Lasso über Bildelemente ziehen.
  • Auswahl erweitern: Strg+Mausklick auf ein Element, um es zusätzlich zu selektieren/deselektieren
  • Elemente hinzufügen: Beim Lasso aufspannen Strg gedrückt halten fügt neue Elemente zur bestehenden Selektion hinzu.
  • Auswahl aufheben: Ein Lasso aufspannen, das keine Elemente enthält.


Tastaturbedienung

Handbuch -> Runtime -> Bedienen zur Runtime -> Tastaturbedienung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime kann die Navigation und Bedienung auch zur Gänze mit der Tastatur erfolgen. Dabei wir der Fokus zuerst auf eine Schablone gelegt, dann innerhalb der Schablone mit den Pfeiltasten navigiert und mit der Taste Eingabe die Aktion ausgelöst. Die Steuerung erfolgt durch folgende Funktionen:

  • Fokus auf Schablone setzen
  • Fokus von Schablone nehmen
  • Fokus verschieben
  • Eingabe auf Element mit Fokus aktivieren

Die Reihenfolge, in der die Elemente angesteuert werden, wird durch die Vergabe von Indexnummern an die Elemente eines Bildes festgelegt. Diese Festlegung der Navigationsreihenfolge funktioniert auch mit Verknüpften Symbolen.

Die Tastaturbedienung kann auch mithilfe von frei zuordenbaren Tastenkombinationen wie z.B. Strg+M erfolgen. Die Tastenkombination können Sie bei jedem Bedienelement bei der Eigenschaft Tastenkombination hinterlegen.

Interne ID: Tastaturbedienung

Tastenkombination

Tastenkombinationen unterstützen das Ausführen bedienbarer Bildelemente. Zum Beispiel:

- Ausführen von Kontrollelementen und Funktionen, die einem Element zugewiesenen wurden
- Sollwert Absetzen (z. B. bei Schalter)
- Fokus setzen bei bestimmten Fenstern (z.B. Kurvenliste im Erweiteren Trend oder Comboboxen im RGM)

Klick auf Eingabefeld öffnet Dialog zur Definition der Tastenkombination. Im Dialog wird die gewünschte Kombination direkt eingegeben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Funktionen

Reihenfolge innerhalb Schablone festlegen

Windows Tastenkombinationen sperren


Funktionen

Handbuch -> Runtime -> Bedienen zur Runtime -> Tastaturbedienung -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Projektierung der Tastaturbedienung benutzen Sie folgende Funktionen:

Fokus auf Schablone setzen

Diese Funktion setzt bei Tastaturbedienung zur Runtime den Fokus auf eine definierte Schablone.

Um die Funktion zu projektieren:

  1. wählen Sie in der Liste der Funktionen im Knoten Bilder die Funktion Fokus auf Schablone setzen

    Interne ID: Funktionen

    Fokus auf Schablone setzen

    Diese Funktion setzt den Eingabefokus auf das aktuell geöffnete Bild einer ausgewählten Schablone. So können Projekte mit reiner Tastaturbedienung erstellt werden.

    Mehr im Online-Handbuch

    Interne ID: Funktionen

    Bilder

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

    Mehr im Online-Handbuch

  2. der Dialog zur Auswahl einer Schablone wird geöffnet
  3. wählen Sie die gewünschte Schablone
  4. wählen Sie bei Mehr-Monitor-Projekten den virtuellen Monitor für die Aufschaltung der Schablone

Zur Runtime wird die mit einem Fokus versehene Schablone mit einem Rahmen dargestellt. Linienbreite und Farbe des Rahmens werden in den Projekteigenschaften im Knoten Grafische Ausprägung/Bilder definiert.

Interne ID: Funktionen

Bilder

Eigenschaften für die Anzeige der Bilder in der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Funktionen

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Dialog Schablonenauswahl

Im Auswahldialog Schablonen können Schablonen für die Ausführung von Funktionen ausgewählt werden aus:

  • aktuellem Projekt
  • Unterprojekten
  • allen Projekten im Arbeitsbereich mit aktiver Option Projekt im Speicher halten

Parameter

Beschreibung

Fenster Projektbaum

Zeigt alle Projekte im Arbeitsbereich an. Schablonen können gewählt werden aus dem aktuellen Projekt und aus allen Projekten mit aktiver Option Projekt im Speicher halten

Fenster Schablonen

Auswahl der Schablone.

Werden mehrere Schablonen ausgewählt, wird für die Ausführung der Funktion die erste gewählte Schablone benutzt.

Diesen Dialog zur Runtime anbieten

Schaltet zur Runtime bei der Ausführung der Funktion diesen Schablonenauuswahldialog auf.

Keine Auswahl

Hat für diese Auswahl keine Funktion.

Scrollen zum Monitor

Aktiv: Zur Runtime werden Bildlaufleisten eingeblendet, die das Scrollen zum Monitor ermöglichen.

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

Monitor

Auswahl des Monitors aus Dropdownliste.

Diese enthält:

  • aktueller Monitor
  • alle in der Monitorverwaltung definierten virtuellen Monitore
    optional: Alle Monitore

Steht nur bei Mehr-Monitor-Systemen zur Verfügung.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft alle Änderungen und schließt Dialog.

Hilfe

Öffnet die Online-Hilfe.

Fokus verschieben

Diese Funktion setzt bei Tastaturbedienung zur Runtime den Fokus auf ein bestimmtes Element und kann damit zur Navigation innerhalb einer Schablone verwendet werden.

Eigenschaft | Aktion
Richtung | Festlegen der Richtung, in der der Fokus weitergegeben werden soll. Es gilt die im Editor Im Kontextmenü oder unter Bearbeiten/Reihenfolge für Fokus verschieben... festgelegte Reihenfolge
auf das Element | Festlegen des Elements, das den Fokus erhalten soll. Einzugeben ist der Objektname des Elements

Eingabe auf Element mit Fokus aktivieren

Diese Funktion aktiviert das Element, das in der gewählten Schablone den Fokus besitzt.

Fokus von Schablone nehmen

Diese Funktion nimmt zur Runtime den Fokus von der aktuellen Schablone. Zur weiteren Tastaturbedienung muss der Fokus neu auf eine Schablone gesetzt werden.


Reihenfolge innerhalb Schablone festlegen

Handbuch -> Runtime -> Bedienen zur Runtime -> Tastaturbedienung -> Reihenfolge innerhalb Schablone festlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In welcher Reihenfolge die Elemente eines Bildes bei Tastaturbedienung angesteuert werden, definieren Sie bei der Projektierung im Bild:

  1. öffnen Sie das Bild
  2. klicken Sie mit der rechten Maustaste in einen leeren Bereich
  3. wählen Sie im Kontextmenü Reihenfolge für Fokus verschieben
  4. wählen Sie in der sich öffnenden Dropdownliste Reihenfolge für links/rechts oder Reihenfolge für oben/unten
  5. jedes Element im Bild wird mit einer Nummer in der linken oben Ecke gekennzeichnet
  6. klicken Sie auf das Element, das als erstes angesteuert werden soll
  7. die Nummer des Elements ändert sich auf 1
  8. klicken Sie auf alle weiteren Elemente in der Reihenfolge, in der sie angesteuert werden sollen
    • Elemente, die bereits definiert wurden, ändern die Hintergrundfarbe der Zahl
    • Elemente, die zur Runtime nicht über die Tastatur erreicht werden können (Eigenschaft Fokus wird auf Element gesetzt inaktiv), werden mit roten Ziffern dargestellt

      Interne ID: Reihenfolge innerhalb Schablone festlegen

      Fokus wird auf Element gesetzt

      Aktiv: Das dynamische Element ist über die Tastatur bedienbar.
      Inaktiv: Das dynamische Element kann über die Tastatur nicht erreicht werden.
      Default: aktiv.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • wird mit gedrückter Taste Strg auf ein Element geklickt, so beginnt die Nummerierung mit der Indexnummer des angeklickten Elements

info Info

In den Eigenschaften der Elemente wird die Position über die Eigenschaften Fokus Position links/rechts und Fokus Position oben/unten angezeigt. Diese Eigenschaften dienen nur der Information, Indexwerte zur Positionierung können dort nicht geändert werden.

Interne ID: Reihenfolge innerhalb Schablone festlegen

Fokus Position oben/unten

Definiert die vertikale Position bei Tastaturbedienung zur Runtime. Position wird über Kontextmenü und Mauseingabe im Hauptfenster definiert und kann hier nicht verändert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Reihenfolge innerhalb Schablone festlegen

Fokus Position links/rechts

Definiert die horizontale Position bei Tastaturbedienung zur Runtime. Position wird über Kontextmenü und Mauseingabe im Hauptfenster definiert und kann hier nicht verändert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Symbole

Auch für Verknüpfte Symbole kann ein Index vergeben werden. Beim Kompilieren der Runtime-Dateien wird das Symbol aufgelöst und die im Symbol vorhandenen Elemente werden eingefügt. Dabei wird die im Symbol definierte Reihenfolge für die Ansteuerung berücksichtigt.

Example Beispiel

In einem Bild befinden sich drei Elemente : der Zahlenwert Z, der Button B und das verknüpfte Symbol VS. Das verknüpfte Symbol aus der Projektbibliothek enthält die 3 Zahlenwerte: Z1, Z2 und Z3.

Wird jetzt im Bild die Reihenfolge definiert als: B - VS - Z,
dann lautet die Reihenfolge zur Runtime: B - Z1 - Z2 - Z3 - Z.


Windows Tastenkombinationen sperren

Handbuch -> Runtime -> Bedienen zur Runtime -> Tastaturbedienung -> Windows Tastenkombinationen sperren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Onlinebetrieb können Windows-Tastenkombinationen wie ALT+TAB, ALT+ESC oder ALT+F4 gesperrt werden:

Um diese Tastenkombinationen zu sperren, deaktivieren Sie in den Projekteigenschaften im Abschnitt Runtime Einstellungen die Eigenschaft Systemtasten sperren.

Interne ID: Windows Tastenkombinationen sperren

Systemtasten sperren

Aktiv: Systemtasten wie Alt+Esc, Strg+Esc, Alt+Tab, Alt-F4 etc. werden in der Runtime gesperrt.
Inaktiv: Systemtasten werden nicht gesperrt.
Default: inaktiv

Mehr im Online-Handbuch

Hinweis: Weitere Systemtasten können zur Runtime über Keyblock Runtime Start gesperrt werden.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Windows Tastenkombinationen sperren

Runtime Einstellungen

Eigenschaften für das Runtime-Verhalten des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Gesperrt werden:

Nicht gesperrt werden:
  • Alt+Esc
  • Strg+Alt+Entf
  • Strg+Esc

  • Alt+Tab

  • Alt+F4

  • Taste Windows

alle entsprechenden Mausaktionen

Um zur Runtime alle Systemtasten zu sperren:

  • aktivieren Sie die Eigenschaft Systemtasten sperren
  • starten Sie die Runtime über Keyblock Runtime Start
  • beachten Sie die Hinweise im Kapitel Runtime-Dateien schützen


Runtimeprofile

Handbuch -> Runtime -> Runtimeprofile

Ein Runtimeprofil ist eine reproduzierbare optische Momentaufnahme eines Bildes zur Runtime, inklusive Information über:

  • Bildschema (Reihe und Position)
  • Monitorzuordnung
  • Filter

Runtimeprofile sind projekt- und benutzerbezogen.

Folgende Bildtypen unterstützen Runtimeprofile:

  • Alarmmeldeliste
  • Archiv-Nachbearbeitung
  • Chronologische Ereignisliste
  • Erweiterter Trend
  • Industrial Maintenance Manager
  • Industrial Performance Analyzer
  • Report Viewer
  • Message Control
  • Variablen-Diagnose

Jeder zenon Benutzer verfügt über einen eigenen Ordner, in dem er seine Profile verwalten kann. Administratoren können alle Profile aller Benutzer sehen und editieren sowie zum Benutzer System kopieren. Vom Benutzerkonto System können alle Benutzer Runtimeprofile laden. Es dient als Austauschkonto für Runtimeprofile.

Hinweis: Nur Administratoren können Profile in das Benutzerkonto System hineinkopieren und dort verwalten. Alle übrigen Benutzer können nur ihre eigenen Profile verwalten und die Profile des Benutzers System laden.

Vordefinierte Profile

Neben individuellen Profilen gibt es zwei vordefinierte Runtimeprofile:

  • DEFAULT: vom Benutzer erstellt und als Standardprofil ausgewählt
  • LAST: wird beim Ausloggen eines Benutzers automatisch in seinem Verzeichnis gespeichert
    Ausnahme: Das Profil LAST wird nicht gespeichert:
    • für den Benutzer System
    • bei einem temporären Login ohne Schreibrechte

Jedem zenon Benutzer kann beim Einloggen ein Startprofil zugeordnet werden.

attention Achtung

Profile können nur dann korrekt am Server gespeichert werden, wenn am Server alle Projekte vorhanden sind:

  • aus denen Bilder am Client aufgeschaltet werden
  • die mit einer Bildumschaltungsfunktion Bilder aufrufen

Das Speichern von Runtime-Profilen, die diesen Bedingungen nicht entsprechen kann zu Fehlern zur Runtime führen.

Noch in diesem Kapitel

Profil zur Runtime erstellen und laden

Profile exportieren und importieren

Profil zuordnen und verwalten

Speicherorte der Profile


Profil zur Runtime erstellen und laden

Handbuch -> Runtime -> Runtimeprofile -> Profil zur Runtime erstellen und laden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um zur Runtime ein Profil zu erstellen, muss eine entsprechende Funktion projektiert sein:

  • Profil speichern: speichert das aktuelle Profil so, wie in der Funktion definiert
  • Profilverwaltung: öffnet die Verwaltung der Profile zum Speichern, Laden, Zuweisen und Verwalten der Profile

Außerdem können zur Runtime bereits vorhandene Profile aktiviert werden:

  • Profil laden

Beim Laden eines Profils wird der Zustand wie bei der Speicherung des Profils wieder hergestellt. Es wird also der Bildaufbau inkl. aller eingestellter Filter - so wie er beim Speichern des Profils war - wiederhergestellt.

Achtung: Sind in den Eigenschaften eines Bildes bei Start-Funktion oder Ende-Funktion Bildumschaltungsfunktionen (Bildumschaltung, Bild indiziert oder Bild zurück ), werden diese nicht ausgeführt! Alle anderen Funktionstypen werden erneut ausgeführt.

Interne ID: Profil zur Runtime erstellen und laden

Ende-Funktion

Funktion, die beim Schließen des Bildes in der Runtime automatisch ausgeführt werden soll.
Öffnet den Funktionaauswahldialog.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

ACHTUNG: Das Öffnen eines anderen Bildes derselben Schablone schließt dieses Bild automatisch und führt somit auch die verknüpfte Funktion aus.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Profil zur Runtime erstellen und laden

Start-Funktion

Funktion, die beim Öffnen des Bildes in der Runtime automatisch ausgeführt werden soll.
Öffnet den Funktionsauswahldialog.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wird in den beiden Funktionen ein Skript aufgerufen, wird das komplette Skript ausgeführt. Auch alle darin enthaltenen Bildumschaltungsfunktionen. Dadurch kann es vorkommen, dass der Bildaufbau nach dem Laden des Profils nicht demjenigen beim Speichern des Profils entspricht.

Ähnlich verhält es sich mit der Bild aktiv Variable: Wird in der Variable ein Grenzwert ausgeführt der wiederum eine Bildumschaltungsfunktion enthält, wird diese ausgeführt und beeinflusst somit die Darstellung eventuell ungewollt.

Interne ID: Profil zur Runtime erstellen und laden

Bild aktiv Variable

Die hier verknüpfte Bitvariable wird auf 1 gesetzt, wenn das Bild geöffnet wird; sie wird auf 0 zurückgesetzt, wenn das Bild geschlossen wird.
Öffnet den Variablesauswahldialog gefiltert auf Bit-Variablen.

ACHTUNG: Das Öffnen eines anderen Bildes derselben Schablone schließt dieses Bild automatisch und führt somit die verknüpfte Funktion aus.

Beispiel: Die Hintergrundfarbe von Buttons in einer Bedienleiste sollte anzeigen, welches Bild gerade geöffnet ist. Die Bit-Variables, die zu den einzelnen Bildern verknüpft sind, haben alle die Grenzwertfarbe grün für den Wert 1 und die Grenzwertfarbe weiß für den Wert 0. Diese Bit-Variablen werden zu der dynamischen Hintergrundfarbe der entsprechenden Buttons verknüpft. Der Button, der das gerade geöffnete Bild aufschaltet, hat also immer die Hintergrundfarbe grün und alle anderen sind weiß.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Funktion projektieren


Funktion projektieren

Handbuch -> Runtime -> Runtimeprofile -> Profil zur Runtime erstellen und laden -> Funktion projektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um zur Runtime Profile zu laden, zu speichern und zu verwalten, projektieren Sie im Editor eine Funktion und weisen diese einer Schaltfläche zu:

  • wählen Sie Funktion neu
  • navigieren Sie zum Knoten Bilder
  • wählen Sie Runtimeprofile

    Interne ID: Funktion projektieren

    Runtimeprofile

    Erstellt eine Funktion, mit der zur Runtime die Profilverwaltung geöffnet, ein Profil erstellt oder ein Profil geladen werden kann.

    Mehr im Online-Handbuch.

  • der Dialog zur Konfiguration der Funktion wird geöffnet

Eigenschaft | Aktion
Verwaltungsdialog in der Runtime öffnen | Öffnet zur Runtime den Dialog zum Verwalten, Erstellen, Speichern und Laden von Profilen.
Profil laden | Lädt das im Dialog definierte Profil zur Runtime:
DEFAULT | Lädt das Profil DEFAULT. Dieses wurde vom Benutzer aus den vorhandenen Profilen als Standard ausgewählt.
LAST | Lädt das Profil LAST. Dieses wurde beim Ausloggen eines Benutzers automatisch in sein Verzeichnis geschrieben.
Freier Name | Lädt das Profil mit dem im Dialog vorgegebenen Namen. Existiert das Profil nicht, wird das aktuelle Profil beibehalten.
Name aus Variable | Lädt das Profil, dessen Name aus der definierten Variable erstellt wurde.
Profil speichern | Speichert das im Dialog definierte Profil.
DEFAULT | Speichert das aktuelle Profil als DEFAULT.
Freier Name | Speichert das Profil unter dem im Dialog vorgegebenen Namen.
Name aus Variable | Speichert das Profil unter dem Namen, der aus der im Dialog definierten Variable erstellt wird.


Profile exportieren und importieren

Handbuch -> Runtime -> Runtimeprofile -> Profile exportieren und importieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit den Kontrollelementen für Import und Export können Runtimeprofile auch auf andere Projekte und andere Rechner übertragen werden.

Um Profile zu exportieren:

  1. erstellen Sie im Bild die Kontrollelemente für Import und Export:
    Kontrollelemente -> Filterprofile -> Import bzw. Export
  2. starten Sie die Runtime
  3. öffnen Sie das Bild
  4. legen Sie die gewünschten Profile an
  5. speichern Sie die Profile
  6. exportieren Sie die Profile:
    diese werden in einer XML-Datei gespeichert und können in anderen Projekten beim gleichen Bildtyp importiert werden

Um Profile zu importieren:

  1. speichern Sie die XML-Datei mit den gewünschten Profilen am Runtime-Rechner falls dieser sich vom Exportrechner unterscheidet
  2. starten Sie die Runtime
  3. öffnen Sie das Bild
  4. importieren Sie die Profile

info Info

Beim Import werden alle zuvor vorhandenen Profile gelöscht. Das zur Zeit aktive Profil wird jedoch nicht geändert.

XML-Dateien können nur im jeweils passenden Bildtyp, mit dem sie erstellt wurden, importiert werden. Wird versucht, Profile eines anderen Bildtyps zu importieren, wird der Import mit einem Hinweis auf den Fehler abgebrochen.


Profil zuordnen und verwalten

Handbuch -> Runtime -> Runtimeprofile -> Profil zuordnen und verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Profile können im Editor und zur Runtime zugeordnet werden. Die Erstellung und Speicherung erfolgt zur Runtime.

Im Editor

Im Editor weisen Sie Benutzern Runtimeprofile zu:

  • im Dialog beim Anlegen eines neuen Benutzers mit der Eigenschaft Runtimeprofil das beim Login aufgerufen wird:

  • Über die Eigenschaft Runtimeprofil eines Benutzers:

    Interne ID: Profil zuordnen und verwalten

    Runtimeprofil

    Auswahl des Runtimeprofils, das dem Benutzer beim Einloggen zugewiesen werden soll. Mögliche Profile:

    keines: Kein Profil wird zugeordnet

    DEFAULT: Das Profil DEFAULT wird zugeordnet

    LAST: Das Profil LAST wird zugeordnet

    Default: keines

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • In der Dropdownliste stehen jeweils folgende Einstellungen zur Auswahl:
    • Keines: Kein Profil wird zugeordnet (Standardeinstellung)
    • DEFAULT: Das Profil DEFAULT wird zugeordnet
    • LAST: Das Profil LAST wird zugeordnet

Zur Runtime

Zur Runtime können Sie Profile über die Profilverwaltung speichern, laden, zuweisen und verwalten. Dazu muss die Funktion Runtimeprofile mit der Eigenschaft Verwaltungsdialog in der Runtime öffnen projektiert sein.

Interne ID: Profil zuordnen und verwalten

Runtimeprofile

Erstellt eine Funktion, mit der zur Runtime die Profilverwaltung geöffnet, ein Profil erstellt oder ein Profil geladen werden kann.

Mehr im Online-Handbuch.

Hinweis: Administratoren können die Profile anderer Benutzer verwalten.

Eigenschaft | Aktion
Angemeldeter Benutzer | Benutzer, der aktuell am System angemeldet ist.
Benutzer, dessen Profile verwaltet werden | Benutzer, dessen Profile angezeigt werden und verwaltet werden können.
Profile | Liste der vorhandenen Profile.
Profilname | Name des Profils.
Zuletzt geändert | Datum und Uhrzeit der letzten Änderung.
Umbenennen | Öffnet den ausgewählten Profilnamen zum Umbenennen.
Löschen | Löscht das ausgewählte Profil nach einer Sicherheitsabfrage.
Kopieren | Kopiert das ausgewählte Profil zum Benutzer System. Der Name kann dabei geändert werden. Tipp: Profile beim Benutzer System stehen allen nicht eingeloggten Benutzern zur Verfügung.
Profil speichern | Öffnet den Dialog zur Vergabe eines Profilnamens und speichert das Profil unter diesem Namen. Dabei sind nicht erlaubt: Leerzeichen sowie die Sonderzeichen / | \ : * ? ! " < > $
Profil laden | Lädt das ausgewählte Profil.
Schließen | Schließt den Dialog.

Tastenkombinationen

Taste | Aktion
F5 | Aktualisiert Liste der Profile. Bei unerwarteten Ereignissen im zenon Netzwerk wie Ausfall von Server oder Standby werden die Inhalte der Liste automatisch aktualisiert.
Esc | Schließt Dialog.
Eingabe | Lädt das ausgewählte Profil.
Einfg | Speichert den aktuellen Zustand als neues Profil.
F2 | Ermöglicht das Ändern des Namens des ausgewählten Profils.
Entf | Löscht das ausgewählte Profil nach einer Sicherheitsabfrage.


Speicherorte der Profile

Handbuch -> Runtime -> Runtimeprofile -> Speicherorte der Profile

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Profildaten werden je nach Verwendung der Runtime unterschiedlich gespeichert:

Art der Runtime | Speicherort
Server oder Standalone: | Daten werden lokal gespeichert.
Client | Daten liegen am Server und werden interaktiv angefordert und geändert.
Standby | Daten liegen am Server, werden interaktiv angefordert und geändert sowie lokal synchronisiert.


Behandlung von Zeitangaben

Handbuch -> Runtime -> Behandlung von Zeitangaben

Zeitangaben in zenon sind entweder lokale Angaben, UTC-Uhrzeiten oder Zeiträume. Grundsätzlich gilt dabei:

  • alle Zeitpunkte "von - bis" in Filter wie Bildumschaltung auf AML oder CEL werden in UTC gespeichert
  • Uhrzeiten (wie in den Modulen PFS und EMS) sind Angaben in der jeweiligen Lokalzeit (Local Time)
  • Zeiträume sind Zeitspannen in Sekunden

Ausnahmen:

  • der IPA schreibt historische Daten in Lokalzeit als "datetime" in die Datenbank
  • Uhrzeit von Variable lesen bzw. auf Variable schreiben speichert keine Zeit sondern übernimmt die als String formatierte Lokalzeit aus der Steuerung bzw. schreibt diese

UTC

UTC steht für Coordinated Universal Time. Die Zeiteinheit ist die SI-Sekunde. UTC ist die einheitliche Grundlage für die internationale Zeitbestimmung und wird über Zeitsender und andere Zeitdienste öffentlich zur Verfügung gestellt. Abhängig von der Zeitzone muss zur UTC eine bestimmte Zeitspanne addiert oder subtrahiert werden. Diese Zeitspanne kann bei einem Wechsel zur Sommerzeit um eine Stunde variieren. Beispiele:

Land | Lokalzeit
Alaska | UTC -9
Australien, Queensland | UTC +10
Bulgarien | UTC +2
Großbritannien | UTC
Korea | UTC +9
Mitteleuropa (MEZ) | UTC +1
Mitteleuropa (MEZ) Sommerzeit | UTC +2
Saudi Arabien | UTC +3
USA Ostküste | UTC -5
Vereinigte Arabische Emirate | UTC +4

Auswirkungen auf Konfigurationen

Projektierte Zeitangaben haben je nach Ausführungsort der Runtime unterschiedliche tatsächliche Uhrzeiten zur Folge. Zum Beispiel:

Am Editor wird für den PFS lokal in der Zeitzone UTC +1 der Wert 14.00 Uhr für die Ausführung einer Funktion projektiert. Nach dem Transfer der Dateien auf eine Runtime in der Zeitzone UTC +10 wird diese Funktion um 23 Uhr ausgeführt.


Runtime-Hilfe

Handbuch -> Runtime-Hilfe

zenon bietet die Möglichkeit für die laufenden Projekte in der Runtime eine kontextsensitive Hilfe zu erstellen. Diese Hilfe basiert auf HTML-Seiten die in eine CHM-Datei kompiliert werden.

Die Hilfe-Kapitel stehen in drei Kontexten zur Verfügung:

Parameter | Beschreibung
Hauptmenüs | Ein Hauptmenü-Eintrag kann direkt eine Hilfe-Seite öffnen.
Dynamische Elemente | Für das Kontextmenü jedes Dynamischen Elements kann eine eigene Hilfe-Seite definiert werden.
Funktion Aufruf der Hilfe | Funktion Hilfe aufrufen

Die Runtime-Hilfe ermöglicht die Verwendung aller gängigen Bildformate (z.B. *.jpg, *.bmp, *.gif, *.png, ...), Text Formatierungen sowie
Rück- und vorwärts Navigation.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Vorbereitungen

Projektieren im Editor

Darstellung der Hilfe

Funktion Hilfe aufrufen

Runtime-Hilfe unter CE


Vorbereitungen

Handbuch -> Runtime-Hilfe -> Vorbereitungen

HTML Help Workshop installieren:

Der HTML Help Workshop kompiliert HTML-Dateien in ein CHM-Format. Die Runtime-Hilfe basiert auf CHM-Dateien. Der HTML Help Workshop wird auf der zenon Installations-DVD mitausgeliefert.

Hilfe-Projekt erstellen:

Es gibt zahlreiche unterschiedliche Tools, mit denen HTML-Dateien erzeugt werden können. Auch in MS Word lassen sich Texte als HTML-Dateien speichern.

Ein Standard-Hilfe-Projekt (RT_Help.hpp) befindet sich auf der Installations-DVD unter /Predefined/RT_Help/Sprache. Das gewünschte Standard-Hilfe-Projekt wird in dem entsprechenden Ordner kopiert. In diesen Ordnern werden die HTM(L)-Dateien für die Hilfe kopiert.

In diesem Standard-Hilfe-Projekt sind alle notwendigen Voreinstellungen bereits getätigt.

Vorbereitungen im HTML Help Workshop:

Nachdem der HTML Help Workshop gestartet wurde, muss das Standard-Hilfe-Projekt geladen werden. Mit der Schaltfläche Add/Remove Topic Files können die HTM(L)-Dateien in das Hilfe-Projekt eingebunden werden.

Mit dem Betätigen der Schaltflächen Save and Compile oder Compile wird eine Datei RT_Help.chm im Ordner des aktuellen Hilfe-Projekts erzeugt. Alle HTM(L)-Dateien für dieses Hilfe-Projekt sind in dieser CHM-Datei enthalten.

Bei späteren Änderungen der HTM(L)-Dateien muss das Hilfe-Projekt jeweils neu kompiliert werden.

Mehrere Hilfedateien:

Sollte die Runtime-Hilfe auf mehrere Dateien aufgeteilt werden, sollten alle Dateien in den Ordner der nächsten Datei kopiert werden. Jetzt kann das Hilfe-Projekt umbenannt werden und die HTM(L)-Dateien werden durch die neuen ersetzt. Ein Kompilieren des neuen Hilfe-Projekts schließt die Erstellung der neuen Hilfedatei ab.

Vorbereitung für sprachumschaltbare Hilfe:

Nachdem das Hilfe-Projekt in einer Sprache erstellt wurde, sollten alle Dateien in den Ordner der nächsten Sprache kopiert werden. Jetzt können die HTM(L)-Dateien durch die der neuen Sprache ersetzt werden. Nach dem Starten des HTML Help Workshops muss unter den International Settings die Language auf die entsprechende Sprache geändert werden. Ein erneutes Kompilieren des Hilfe-Projekts schließt die Erstellung der Hilfe in der neuen Sprache ab.

Die Namen der Hilfe-Projekte (*.hpp, *.chm) und die Namen der HTM(L)-Dateien müssen in allen Sprachen identisch sein!


Projektieren im Editor

Handbuch -> Runtime-Hilfe -> Projektieren im Editor

Im Projektmanager unter Dateien/Hilfe können im Kontextmenü CHM Dateien hinzugefügt werden. Dabei wird die Standard-Sprache über das Kontextmenü in diese Verzweigung eingebunden. Werden hier keine Standard-Dateien eingetragen, so lassen sich in der späteren Projektierung keine Dateien auswählen!

Noch in diesem Kapitel

Sprachumschaltbarkeit

Aktualisieren von Hilfedateien

Hilfe im Hauptmenü

Hilfe für dynamische Elemente

Hilfe für Alarme


Sprachumschaltbarkeit

Handbuch -> Runtime-Hilfe -> Projektieren im Editor -> Sprachumschaltbarkeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei sprachumschaltbaren Projekten muss für jede Sprache ein eigener Unterordner angelegt werden. In diese Unterordner werden die Hilfedateien für die jeweilige Sprache eingefügt. Nötige Schritte:

  • im Kontextmenü von Dateien/Hilfe für jede Sprache eigene Unterordner anglegen, z.B. Englisch und Deutsch.
  • die Einträge in der Hilfedatei übersetzen
  • mit HTML-Help Workshop neu kompilieren
  • eine RT-Help.chm muss in jedem Sprachordner angelegt werden
    • dazu im Kontextmenü Datei hinzufügen wählen
  • alle Hilfedateien müssen dann wiederum über das Kontextmenü in die lokale Arbeitsversion geholt werden


Aktualisieren von Hilfedateien

Handbuch -> Runtime-Hilfe -> Projektieren im Editor -> Aktualisieren von Hilfedateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollten während der Projektierung die bestehenden Hilfedateien gegen neuere getauscht werden, so muss dies von Hand geschehen. Die neuen CHM-Dateien werden in das entsprechende Unterverzeichnis des Projekts kopiert. Im Editor können diese dann mit dem Befehl Änderungen ermöglichen und Änderungen übernehmen in die Datenbank des Projekts übernommen werden.


Hilfe im Hauptmenü

Handbuch -> Runtime-Hilfe -> Projektieren im Editor -> Hilfe im Hauptmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach der Auswahl des gewünschten Hauptmenüs, wird ein neuer Menüpunkt für die Hilfe angelegt. Ist dieser ausgewählt, können im Eigenschaftenfenster folgende Einstellungen getroffen werden:

Parameter

Beschreibung

Kontextmenü:

Aktionstyp

Interne ID: Hilfe im Hauptmenü

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Aktionstyp muss auf Hilfe gesetzt werden, sonst sind die weiteren Eigenschaften für die Hilfe nicht auswählbar.

Dynamisches Element:

Hilfe-Datei

Interne ID: Hilfe im Hauptmenü

Hilfe-Datei

Hilfe-Datei (*.chm), die für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Klick auf ... öffnet den Dateiauswahldialog.
Achtung: Nur Hilfe-Dateien, die im Knoten "Dateien/Hilfe" hinzugefügt wurden, stehen zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hier wird die entsprechende Hilfedatei (*.chm) aus der Standard-Sprache ausgewählt.

Diese Einstellung dient als Default, falls für das Dynamische Element keine eigene Hilfedatei definiert wurde.

Dynamisches Element:

Hilfe-Kapitel

Interne ID: Hilfe im Hauptmenü

Hilfe-Kapitel

Hilfe-Kapitel, das für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Name der zugrunde liegenden HTML Seite.
Achtung: Dieser Eintrag berücksichtigt Groß-/Kleinschreibung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hier wird das entsprechende Hilfe-Kapitel aus der ausgewählten Hilfedatei angegeben. Die Hilfe-Kapitel haben jeweils den Name der zu Grunde liegenden HTM-Datei.

Diese Einstellung dient als Default, falls für das Dynamische Element kein eigenes Hilfe-Kapitel definiert wurde.


Hilfe für dynamische Elemente

Handbuch -> Runtime-Hilfe -> Projektieren im Editor -> Hilfe für dynamische Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei jedem Dynamischen Bildelement lässt sich ein Kontextmenü auswählen. Wenn das Kontextmenü einen Eintrag mit dem Aktionstyp Hilfe aufweist, wird für das Dynamische Element eine kontextsensitive Hilfe angezeigt.

Noch in diesem Kapitel

Kontextmenü definieren

Dynamisches Element definieren


Kontextmenü definieren

Handbuch -> Runtime-Hilfe -> Projektieren im Editor -> Hilfe für dynamische Elemente -> Kontextmenü definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach der Auswahl des gewünschten Kontextmenüs, wird ein neuer Menüpunkt für die Hilfe angelegt. Die folgenden Einstellungen in den Eigenschaften sind nötig:

Parameter

Beschreibung

Kontextmenü:

Aktionstyp

Interne ID: Kontextmenü definieren

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Der Aktionstyp muss auf Hilfe gesetzt werden, sonst sind die weiteren Eigenschaften für die Hilfe nicht auswählbar.

Dynamisches Element: Hilfe-Datei

Interne ID: Kontextmenü definieren

Hilfe-Datei

Hilfe-Datei (*.chm), die für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Klick auf ... öffnet den Dateiauswahldialog.
Achtung: Nur Hilfe-Dateien, die im Knoten "Dateien/Hilfe" hinzugefügt wurden, stehen zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hier wird die entsprechende Hilfedatei (*.chm) aus der Standard-Sprache ausgewählt.

Diese Einstellung dient als Default, falls für das Dynamische Element keine eigene Hilfedatei definiert wurde.

Dynamisches Element: Hilfe-Kapitel

Interne ID: Kontextmenü definieren

Hilfe-Kapitel

Hilfe-Kapitel, das für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Name der zugrunde liegenden HTML Seite.
Achtung: Dieser Eintrag berücksichtigt Groß-/Kleinschreibung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hier wird das entsprechende Hilfe-Kapitel aus der ausgewählten Hilfedatei angegeben. Die Hilfe-Kapitel haben jeweils den Name der zu Grunde liegenden HTM-Datei.

Diese Einstellung dient als Default, falls für das Dynamische Element kein eigenes Hilfe-Kapitel definiert wurde.

Dieses Kontextmenü kann nun für verschiedene Dynamische Elemente verwendet werden.


Dynamisches Element definieren

Handbuch -> Runtime-Hilfe -> Projektieren im Editor -> Hilfe für dynamische Elemente -> Dynamisches Element definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die folgenden Einstellungen in den Eigenschaften des Dynamischen Elements sind nötig:

Parameter | Beschreibung
Kontextmenü Interne ID: Dynamisches Element definieren Kontextmenü Kontextmenü für das Element. Ein Klick mit der rechten Maustaste auf das Element öffnet das Kontextmenü in der Runtime. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Hier wird das gewünschte Kontextmenü aus der Liste ausgewählt.
Hilfe-Datei Interne ID: Dynamisches Element definieren Hilfe-Datei Hilfe-Datei (*.chm), die für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Klick auf ... öffnet den Dateiauswahldialog. Achtung: Nur Hilfe-Dateien, die im Knoten "Dateien/Hilfe" hinzugefügt wurden, stehen zur Verfügung. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Hier wird die entsprechende Hilfedatei (*.chm) aus der Standard-Sprache ausgewählt. Falls für das dynamische Element keine eigene Hilfedatei definiert wird, wird die Einstellung aus dem Kontextmenü verwendet.
Hilfe-Kapitel Interne ID: Dynamisches Element definieren Hilfe-Kapitel Hilfe-Kapitel, das für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Name der zugrunde liegenden HTML Seite. Achtung: Dieser Eintrag berücksichtigt Groß-/Kleinschreibung. Mehr im Online-Handbuch. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Hier wird das entsprechende Hilfe-Kapitel aus der ausgewählten Hilfedatei angegeben. Die Hilfe-Kapitel haben jeweils den Name der zu Grunde liegenden HTM-Datei. Falls für das dynamische Element kein eigenes Hilfe-Kapitel definiert wird, wird die Einstellung aus dem Kontextmenü verwendet.


Hilfe für Alarme

Handbuch -> Runtime-Hilfe -> Projektieren im Editor -> Hilfe für Alarme

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für jeden Alarm kann eine kontextsensitive Hilfe angeboten werden. Die entsprechenden Einstellungen werden direkt am Alarm definiert. Aufgerufen wird diese Hilfe im Alarmbild (Bildtyp Alarmmeldeliste). Nach Auswahl eines Eintrags in der Alarmmeldliste und Betätigung des Buttons Hilfe wird die entsprechende Hilfe-Seite angezeigt.

Die folgenden Einstellungen in den Eigenschaften der Grenzwerte einer Variablen sind nötig:

Interne ID: Hilfe für Alarme

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: Hilfe für Alarme

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Parameter | Beschreibung
In Alarmmeldeliste Interne ID: Hilfe für Alarme In Alarmmeldeliste Aktiv: Bei einer Grenzwertverletzung wird ein Eintrag in der Alarmmeldeliste erstellt. Inaktiv: In der Alarmmeldeliste wird kein Eintrag erstellt. Default: inaktiv Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Diese Eigenschaft muss aktiviert werden, sonst sind die weiteren Eigenschaften für die Hilfe nicht auswählbar.
Hilfe-Datei Interne ID: Hilfe für Alarme Hilfe-Datei Nur verfügbar, wenn der Grenzwert ein Alarm ist: Datei (*.chm), aus der ein Hilfe-Kapitel für diesen Alarm in der Alarmliste angezeigt werden soll. Wird hier die Zeichenfolge $PRG:xxxxxx eingegeben und die Elektroplan-Anbindung ist lizenziert, wird anstatt der Hilfe das Elektroplanprogramm mit dem angegebenen Parameter xxxxxx gestartet. Die Eigenschaft Hilfe-Kapitel wird ignoriert, darf aber nicht leer sein. Der EXE-Pfad des Elektroplan-Programms wird in der Datei zenOn6.ini im Eintrag EDOC_PATH in Sektion [PATH] definiert. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Hier wird die entsprechende Hilfedatei (*.chm) aus der Standard-Sprache ausgewählt.
Hilfe-Kapitel Interne ID: Hilfe für Alarme Hilfe-Kapitel Nur verfügbar, wenn der Grenzwert ein Alarm ist: Hilfe-Kapitel, das für diesen Alarm in der Alarmliste angezeigt werden soll. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Hier wird das entsprechende Hilfe-Kapitel aus der ausgewählten Hilfedatei angegeben. Die Hilfe-Kapitel haben jeweils den Name der zu Grunde liegenden HTM-Datei.


Darstellung der Hilfe

Handbuch -> Runtime-Hilfe -> Darstellung der Hilfe

Die Darstellung der Hilfe kann auf zwei verschiedene Arten erfolgen:

  1. Extern: über die HTML-Hilfe des Betriebssystems.
    Beachten Sie die Einschränkungen zur Sprachumschaltung!
  2. Intern: über die Hilfe im HTML-Bild

Noch in diesem Kapitel

HTML-Hilfe des Betriebssystems

Hilfe in HTML-Bild


HTML-Hilfe des Betriebssystems

Handbuch -> Runtime-Hilfe -> Darstellung der Hilfe -> HTML-Hilfe des Betriebssystems

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Art der Darstellung wird als Default verwendet. Keine weitere Projektierung ist nötig.

attention Achtung

In der Regel ist Sprachumschaltung mit der HMTL-Hilfe von Microsoft Betriebssystemen nicht möglich. Sprachumschaltbare Hilfe muss über ein HTML-Bild projektiert werden.

Ausnahme: Hilfe unter Windows CE.


Hilfe in HTML-Bild

Handbuch -> Runtime-Hilfe -> Darstellung der Hilfe -> Hilfe in HTML-Bild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein Bild des Types HTML mit dem Namen HTML-Help besteht, so wird dieses statt der HTML-Hilfe des Betriebssystems verwendet. Beim Bildnamen muss die Groß-/Kleinschreibung beachtet werden.

Die Darstellung der Hilfe erfolgt im Kontrollelement Navigieren.

info Info

Diese Anzeige der Hilfe muss unter Windows XP verwendet werden, wenn die Hilfe sprachumschaltbar sein soll.

Wenn bei Windows Vista/7 die Sprache geändert wird, nachdem der CHM-Viewer geschlossen wurde, wird bei erneutem Aufruf der Hilfe die neue Sprache dargestellt.


Funktion Hilfe aufrufen

Handbuch -> Runtime-Hilfe -> Funktion Hilfe aufrufen

Mit dieser Funktion kann eine Hilfeseite geöffnet werden für Menüs, Grenzwerte, Dynamische Bildelemente:

  1. wählen Sie im Kontextmenü des Knotens Funktionen den Befehl Funktion neu
  2. navigieren Sie zu Anwendung
  3. wählen Sie Hilfe aufrufen
  4. Der Konfigurationsdialog wird geöffnet

Parameter | Beschreibung
Hilfe-Datei | Hilfedatei (*.CHM), aus der eine Seite angezeigt werden soll. Klick auf Schaltfläche ... öffnet Explorer zur Auswahl einer CHM-Datei.
Hilefekapitel | Hilfeseite die angezeigt werden soll. Manuelle Eingabe des Dateinamens des Kapitesl vor dem Kompilieren mit Dateinamenerweiterung htm. Format: Dateiname.htm

Alle Hilfe-Aufrufe sind wie folgt einstellbar:

  • Kombination des Namens einer CHM- und einer inkludierten HTM-Datei.
  • Nur Name der HTM-Datei plus Index einer inkludierten HTM-Datei.

info Info

Beim Aufbauen einer HTML-Präsentation sollte jede einzelne HTM-Seite einen aussagekräftigen Tag-Titel erhalten, da dieser unter Windows CE angezeigt wird.


Runtime-Hilfe unter CE

Handbuch -> Runtime-Hilfe -> Runtime-Hilfe unter CE

Unter Windows CE wird die CHM-Datei entpackt und die HTM(L)-Datei im Internet Explorer oder in einem Bild vom Typ HTML angezeigt.

Bei CE-Geräten sind keine Sonderzeichen wie Umlaute, Akzente usw. erlaubt. Alle Referenzen für Windows CE Hilfeobjekte müssen innerhalb folgender Zeichen liegen:

  • A-Z
  • a-z
  • 0-9

info Info

Sprachumschaltung: Im Gegensatz zu anderen Microsoft Windows Betriebssystemen funktioniert die Sprachumschaltung zur Runtime unter Windows CE auch mit der HTML-Hilfe des Betriebssystems.

Hinweis: Jeder Aufruf der Hilfe unter Windows CE schliesst alle anderen offenen Fenster des Internet Explorers eines Benutzers.


SAP Interface

Handbuch -> SAP Interface

Um die ERP-Ebene mit der Prozessebene zu verbinden, interagiert zenon über eine bidirektionale Schnittstelle mit SAP Anwendungen. Damit haben SAP Anwender die Möglichkeiten, direkt auf die Prozessebene zuzugreifen.

Das Leitsystem sendet Meldungen zu beliebigen Vorgängen an die SAP Anwendung. Damit verknüpfen Unternehmen ihre Prozessebene über einen Closed Loop direkt mit der ERP-Ebene und haben von der Auftragsverwaltung über Rezepturen und Produktion bis zur Lieferung lückenlosen Überblick über alle Vorgänge. Zum Beispiel lässt sich so die Lagerhaltung in Echtzeit überwachen, da das Leitsystem aus der SCADA-Ebene exakte Angaben über den echten Ressourcenverbrauch liefert. Damit verfügt das Unternehmen über wichtige Basisdaten für Just-in-time Produktion, aber auch für langfristige Planung.

zenon stellt über ein integriertes Kommunikationsmodul die Möglichkeit zur Verfügung, Prozessdaten direkt in ein SAP ERP zu übermitteln. Diese Daten werden in einer SAP Umgebung unter anderem für folgende Aufgabenstellungen verwendet:

  • Kommunikation eines Status von Prozessaufträgen
  • Information über Verbrauch und Produktion von Materialien
  • Aussagen über den Status von Ressourcen
  • Kommunikation von ausgewählte Prozessereignissen

Prozessmeldungen können in SAP z.B. zur Erstellung von elektronischen Chargen- und Betriebsprotokollen verwendet werden oder zur Aktualisierung eines Prozessauftrags bzw. von Materialbeständen.

tutorial Lizenzinformation

Für Editor und Runtime (Einzelplatz, Server, Standby) lizenzpflichtig.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Speichern | Speicher Änderungen in der SAP ERP Projektierung.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Help | Öffnet die Online-Hilfe.

info Info

Messbelege:

Im Leitsystem ist es möglich, nach bestimmten Zeitplänen Werte von Prozessvariablen zu erfassen und als Messbeleg in das SAP System zu übernehmen. Diese Messbelege können im SAP System etwa für die Planung und Erzeugung von Wartungsaufgaben oder für statistische Zwecke herangezogen werden.

info Info

Wartungsmeldungen:

Zusätzlich zu den Messwerten aus den Alarmmeldungen im Leitsystem ist es möglich, auch Wartungsmeldungen im SAP System zu erzeugen. Diese können dann im SAP System, abhängig von den dort definierten Workflows, weitere Aktionen auslösen. So kann etwa aus einer Wartungsmeldung eines Anlagenteils automatisch ein Arbeitsauftrag für einen Instandhalter generiert werden.

info Info

Funktionsaufrufe:

SAP Funktionsbausteine können aus zenon aufgerufen und zur Runtime ausgeführt werden. Die zenon SAP Funktion enthält eine Liste von Objekten, die die Parameter und Tabellen des SAP Funktionsbausteins abbilden.

Noch in diesem Kapitel

Grundlagen und Voraussetzungen

Projektieren im Editor


Grundlagen und Voraussetzungen

Handbuch -> SAP Interface -> Grundlagen und Voraussetzungen

Um die direkte Integration in die SAP Welt nutzen zu können, muss auf dem Rechner, auf dem das Leitsystem läuft, zusätzlich das SAP GUI installiert werden. Die im SAP GUI mitgelieferten Programmbibliotheken sind für die Kommunikation zu einem SAP System zwingend notwendig.

Weitere Parametrierungen seitens SAP sind nicht notwendig. Zum Datenaustausch ist das installierte SAP GUI ausreichend. Die restlichen Parameter können direkt in der Entwicklungsumgebung eingegeben werden.

info Info

Die Integration mit SAP ERP wurde mit SAP Interface Version "7100.2.92.5705" getestet und freigegeben.

Über die RFC-Schnittstelle werden Aktionen im SAP System durch den Aufruf von Funktionsbausteinen ausgeführt. Funktionsbausteine werden mit dem SAP System mitgeliefert. Über die ABAP Workbench können aber auch benutzerdefinierte Funktionsbausteine programmiert werden. ABAP ist eine von SAP entwickelte Programmiersprache, in der alle Funktionsbausteine im SAP System geschrieben sind. Die Integration ins Leitsystem beschränkt sich aktuell auf die von SAP standardmäßig ausgelieferten Funktionsbausteine. Allerdings wurde im Leitsystem eine flexible Schnittstelle geschaffen, die prinzipiell auch eine Integration von kundenspezifischen Funktionsbausteinen ermöglicht. Erweiterungen der Schnittstelle können in Abstimmung mit dem Produktmarketing bzw. in Standar- Erweiterungszyklen des Produktes vorgenommen werden.

Die kompletten Beschreibungen von Funktionsbausteinen mit deren Parametern, internen Tabellen und verwendeten Strukturen können über Funktionen der RFC-API oder mithilfe verschiedener Funktionsbausteine aus dem SAP System gelesen werden.

Die Integration folgt dabei folgendem Schema:

Voraussetzungen in zenon

info Info

Im Leitsystem muss das Modul SAP Interface lizenziert sein.

Voraussetzungen im SAP ERP System

info Info

Im SAP ERP System wird das Instandhaltungsmodul (im Bereich Logistik) als Kommunikationspartner benötigt.

Noch in diesem Kapitel

Wartungsmeldungen

Messbelege

Funktionsaufrufe


Wartungsmeldungen

Handbuch -> SAP Interface -> Grundlagen und Voraussetzungen -> Wartungsmeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für das Planungssystem ist es wichtig, auch über aufgetretene Störungen, Stillstandszeiten etc. informiert zu sein. Produktivitätskennzahlen können nur sinnvoll berechnet werden, wenn auch die passenden Laufzeiten und Stillstandszeiten bekannt sind. Im SAP System werden dazu sogenannte Wartungsmeldung en verwendet.

Als Wartungsmeldung kann jeder in zenon definierte Alarm einer Prozessvariablen definiert werden. Relevante Meldungen werden in der Regel in SAP dokumentiert. Relevant sind Meldungen, zu deren Beseitigung Leistungen der Instandhaltung nötig sind.

Wartungsmeldungen werden aus zenon Alarmen erzeugt. Beim Auftreten eines Alarms bei einer der mit dem Element verknüpften Variablen wird im Instandhaltungsmodul des SAP Systems eine Wartungsmeldung angelegt. Beim Gehen Event eines Alarms wird die Wartungsmeldung über die Belegnummer gesucht, und der Zeitstempel des Geht-Ereignisses eingetragen.

Für jede Meldungsart von SAP kann in zenon eine eigene Gruppe von Meldungsarten angelegt werden. Die maßgebliche Eigenschaft einer Meldung im SAP System ist die so genannte „Meldungsart". Sie legt fest, wie die Meldung im Workflow des SAP Systems weiter bearbeitet wird. Die möglichen Meldungsarten sind im SAP System vordefiniert. Wird beim Anlegen einer Wartungsmeldung keine oder eine nicht im SAP System definierte Meldungsart angegeben, legt das SAP System keine Wartungsmeldung an, sondern gibt eine entsprechende Fehlermeldung zurück.

info Info

Optional können für jede Wartungsmeldung ein Instandhaltungswerk und ein Melder angegeben werden. Wird kein Werk oder kein Melder angegeben, trägt das SAP System Defaultwerte ein.

Jede Wartungsmeldung bezieht sich auf einen im SAP System vordefinierten Anlagenteil. Ein solcher Anlagenteil kann ein so genannter „Technischer Platz" oder ein so genanntes „Equipment" sein. Jeder Technische Platz kann wiederum Technische Plätze und/oder Equipments enthalten.

Jeder Technische Platz und jedes Equipment besitzen eine eindeutige Kennung, die beim Erzeugen der Wartungsmeldung angegeben werden muss. Die Kennung für Technische Plätze oder Equipments wird aus der Betriebsmittelkennung der verknüpften Variablen geholt. Über die Eigenschaft „Techn. Platz/Equipment" wird festgelegt, ob die Betriebsmittelkennung als Kennung für einen Technischen Platz oder für ein Equipment interpretiert wird.

Mit den so definierten Wartungsmeldungen können nun Variablen verknüpft werden. Tritt für eine der verknüpften Variablen ein Alarm auf, wird im SAP System eine Wartungsmeldung mit den festgelegten Parametern und dem Wert und Grenzwerttext der Variablen angelegt.

Die Wartungsmeldungen erhalten im SAP System eine eindeutige Belegnummer, die im Alarmeintrag der zenon Variable als Kommentar abgelegt wird. Damit ist eine Zuordnung zwischen Alarmereignis und der Belegnummer der Wartungsmeldung im SAP System möglich.

attention Achtung

Bei Alarmen mit dynamischen Grenzwerttexten steht das Kommentarfeld des Eintrages nicht zur Verfügung, stattdessen wird ein Eintrag in der Chronologischen Ereignisliste erzeugt, der eine Zuordnung von Alarm und Belegnummer erlaubt.

Noch in diesem Kapitel

Technischer Hintergrund


Technischer Hintergrund

Handbuch -> SAP Interface -> Grundlagen und Voraussetzungen -> Wartungsmeldungen -> Technischer Hintergrund

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wartungsmeldungen werden im SAP System durch Aufruf der Funktionsbausteine ALM_PM_MAINTNOT_CREATE und ALM_PM_MAINTNOT_SAVE angelegt. Beim Gehen des Alarms wird die "Geht-Zeit" durch Aufruf der FunktionsbausteIne ALM_PM_MAINTNOT_MODIFY_DATA und ALM_PM_MAINTNOT_SAVE in die zuvor erzeugte Wartungsmeldung eingetragen.

Diese Funktionsbausteine werden bei einer Standardinstallation des Instandhaltungsmoduls im SAP System angelegt und stehen ab diesem Zeitpunkt für externe Applikationen zur Verfügung.

attention Achtung

Durch individuelles Anpassen des SAP Systems an Anforderungen des Kunden kann es passieren, dass diese Funktionsbausteine nicht mehr zur Verfügung stehen! In diesem Fall gibt das SAP System die Fehlermeldung FU_NOT_FOUND zurück.

Tritt in zenon das Ereignis Alarm geht für eine der verknüpften Variablen auf, wird die zu dem Alarm gehörende Wartungsmeldung über die Belegnummer gesucht und der Zeitpunkt des Störungsendes eingetragen. Das geschieht durch einen Aufruf des Funktionsbausteins ALM_PM_MAINTNOT_MODIFY_DATA. Dem Funktionsbaustein wird im Parameter NUMBER die Belegnummer der Wartungsmeldung übergeben. Die Werte der zu ändernden Felder werden im Parameter NOTIFHEADER angegeben, im Parameter NOTIF wird durch Flags ausgewählt, welche Felder geändert werden sollen.

Die geänderte Wartungsmeldung wird anschließend durch Aufrufe der Funktionsbausteine ALM_ und BAPI_TRANSACTION_COMMIT in der SAP Datenbank gespeichert.


Messbelege

Handbuch -> SAP Interface -> Grundlagen und Voraussetzungen -> Messbelege

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In SAP Anwendungen beschreiben Messwerte einen bestimmten Zustand des Produktionssystems zu einem bestimmten Zeitpunkt im Prozessablauf. Als Messwert kann jede beliebige in zenon vorhandene Variable definiert werden. Damit können Daten protokollunabhängig aus dem Echtzeitprozess an die überlagerte Management-Ebene übergeben werden.

In vielen Fällen bietet es sich an, die Prozessdaten bereits auf Prozessebene vorzuverdichten, um dann dem SAP System kumulierte Daten zur Auswertung zu übergeben. So erhält das SAP System von zenon zum Beispiel gezielt Mittelwerte oder statistische Kennwerte, berechnet aus einer ganzen Wertereihe. Das vermeidet unnötige Überfrachtung des Managementsystems mit Rohdaten.

Messwerte und Zählerstände werden dabei zyklisch erfasst und als Messbeleg zu einem Messpunkt im SAP System abgelegt. Die Eigenschaften des Messpunkts im SAP System legen fest, ob es sich um einen Messwert oder einen Zähler handelt. Als Wert des Messbelegs wird der aktuelle Variablenwert eingetragen.

Im SAP System können für jeden technischen Platz oder jedes Equipment mehrere Messpunkte definiert werden. Beim Definieren der Messpunkte wird festgelegt, ob der Messpunkt einen Messwert oder einen Zählerstand enthält. Zählerstände müssen einen monoton steigenden Wert haben, d.h. jeder neu eingetragene Wert muss gleich oder grösser als der vorhergehende Wert sein.

Messwerte und Zählerstände von Messpunkten werden dem SAP System mittels so genannter „Messbelege" übergeben.

Im Leitsystem erfolgt die Erfassung von Messwerten über Zeitpläne. Für jeden Zeitplan kann angegeben werden, an welchen Wochentagen, und zu welchen Uhrzeiten Messwerte erfasst werden sollen. Ein Zeitplan kann entweder täglich oder nur an bestimmten Wochentagen ausgeführt werden. Für jeden Zeitplan kann weiters eine Start- und Endzeit, sowie ein Intervall angegeben werden. Zwischen der Start und der Endzeit werden jeweils im angegebenen Intervall Messwerte der verknüpften Variablen erfasst.

Mit jedem Zeitplan kann eine Reihe von Variablen verknüpft werden. Bei jeder Ausführung des Zeitplans werden die aktuellen Werte der Variablen gelesen und für jeden Variablenwert ein Messbeleg im SAP System erzeugt. Jeder Messpunkt besitzt eine eindeutige Nummer, die in den erfassten Messbeleg eingetragen werden muss. Die Nummer des Messpunktes wird aus der Betriebsmittelkennung der verknüpften Variablen ermittelt.

info Info

Die Zuordnung zwischen Leitsystem Variable und eines SAP Messpunkest erfolgt über die ID des Messpunktes im SAP System. Diese eindeutige fortlaufende Nummer muss in der Betriebsmittelkennung der Variablen im Leitsystem eingetragen werden.

Noch in diesem Kapitel

Technischer Hintergrund


Technischer Hintergrund

Handbuch -> SAP Interface -> Grundlagen und Voraussetzungen -> Messbelege -> Technischer Hintergrund

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Messbelege zu Messpunkten und Zählern werden im SAP System über den Funktionsbaustein "MEASUREM_*" erzeugt. Der Messbeleg wird einem Messpunkt oder Zähler zugeordnet. Ob es sich um einen Messpunkt oder einen Zähler handelt, wird beim Erzeugen des Messpunkts festgelegt. Der Messpunkt bzw. Zähler wird über eine im SAP System eindeutige Nummer identifiziert.

Der Messbeleg erfasst den Messzeitpunkt (Datum, Zeit), einen Messwert mit Einheit, den Melder (Erzeuger des Belegs) und einen Kurztext. Wird der Messzeitpunkt nicht angegeben, wird der Zeitpunkt der Erzeugung des Belegs eingetragen. Die Einheit des Messwertes kann ebenfalls weggelassen werden, in diesem Fall wird die beim Messpunkt/Zähler eingetragene Einheit verwendet.

Durch Setzen des Parameters COMMIT_WORK wird veranlasst, dass der Beleg sofort in die SAP Datenbank geschrieben wird. Messbelege werden im SAP System durch Aufruf des Funktionsbausteins MEASUREM_DOCUM_RFC_SINGLE_001 angelegt.

info Info

Der Funktionsbaustein MEASUREM_DOCUM_RFC_SINGLE_001 wird bei einer Standardinstallation des Instandhaltungsmoduls im SAP System angelegt.

attention Achtung

Durch individuelles Anpassen des SAP Systems an Anforderungen des Kunden kann es passieren, dass diese Funktionsbausteine nicht mehr zur Verfügung stehen. In diesem Fall gibt das SAP System die Fehlermeldung FU_NOT_FOUND zurück.


Funktionsaufrufe

Handbuch -> SAP Interface -> Grundlagen und Voraussetzungen -> Funktionsaufrufe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beliebige Funktionen im SAP System können ohne zusätzlichen Programmieraufwand in VBA und mit sehr geringem Projektieraufwand direkt aus zenon heraus aufgerufen werden. Dafür wird Im Editor die Schnittstelle des aufgerufenen Funktionsbausteins mit den erforderlichen Parametern, Tabellen und Strukturen abgebildet und mit zenon Variablen verknüpft. Der tatsächliche Funktionsaufruf erfolgt durch Ausführung einer zenon Funktion, der dieses Abbild als Parameter übergeben wird.

Funktionsbausteine

Aktionen im SAP System und die Übertragung von Daten zum SAP System werden durch den Aufruf von Funktionsbau\-stei\-nen ausgeführt. Funktionsbausteine werden mit dem SAP System mitgeliefert, über die ABAP-Work\-bench können aber auch benutzerdefinierte Funktionsbausteine programmiert werden.

Parameter

Die Datenübergabe an und von Funktionsbausteinen erfolgt über Import- bzw. Export-Parameter. Aus der Sicht des Funktionsbausteins im SAP System werden Eingabedaten „importiert", Ergebnisdaten werden „exportiert". Die Dokumentation der Funktionsbausteine im SAP System geht von dieser Sichtweise aus.

Neben Im- und Export-Parametern gibt es noch so genannte Changing-Parameter, die sowohl der Übergabe von Eingangsdaten als auch der Rückgabe von Ergebnissen dienen.

Interne Tabellen

Tabellarische Daten oder Listen können in so genannten Internen oder Temporären Tabellen an und von Funktionsbausteinen übergeben werden.

Datentypen, Strukturen

Neben den üblichen einfachen Datentypen (numerisch, Text, Datum, Zeit, etc.) können Daten auch in Strukturen übergeben werden. Daten in Tabellen werden üblicherweise als Strukturen übergeben, aber auch Parameter können strukturierte Daten aufnehmen.

Unterstützung durch das SAP System

Die kompletten Schnittstellenbeschreibungen von Funktionsbausteinen samt deren Parametern, internen Tabellen und verwendeten Strukturen können aus dem SAP System gelesen werden.

Die zenon SAP Schnittstelle macht von dieser Möglichkeit Gebrauch, indem sie einen Assistent zur Auswahl von Funktionsbausteinen und zum Einlesen der Schnittstellenbeschreibung anbietet.

Auch beim Aufruf einer SAP Funktion werden die projektierten Objekte mit der Schnittstellenbeschreibung des aufgerufenen Funktionsbaustein im SAP System abgeglichen.


Projektieren im Editor

Handbuch -> SAP Interface -> Projektieren im Editor

Das Parametrieren von Messpunkten, Wartungsmeldungen und Funktionsaufrufen in der Entwicklungsumgebung ist nur bei lizenzierter SAP Schnittstelle möglich. Ist diese lizenziert, findet sich im Projektbaum der Knoten SAP Interface mit den Einstellungen für die SAP Ankopplung. Details zu den einzustellenden Parametern sind in den folgenden Kapiteln beschrieben.

Kontextmenü Projektmanager Knoten SAP ERP

Menüpunkt | Aktion
Speichern | Speicher Änderungen in der SAP ERP Projektierung.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Help | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Symbolleiste und Kontextmenüs

Verbindungsparameter zu einem SAP System

Wartungsmeldungen

Messbelege

Funktionsaufrufe


Symbolleiste und Kontextmenüs

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbol

Aktion

Meldungsart neu

Fügt eine neue leere Meldung in die Liste ein.

Zeitplan neu

Fügt einen neuen leeren Zeitplan in die Liste ein.

SAP Funktion neu

Öffnet den Assistenten zur Auswahl eines neuen SAP Funktionsbausteins.

Variable hinzufügen

Öffnet den Dialog zur Auswahl von Variablen.

Parameter neu

Legt neuen Parameter für markierte Funktion an.

Tabelle neu

Legt neue Tabelle für markierte Funktion an.

Strukturfeld neu

Legt für markierten Parameter bzw. markierte Tabelle ein neues Strukturfeld an.

Standard-Funktion erzeugen

Legt eine zenon Funktion "SAP Funktion ausführen" für die markierte SAP Funktion an.

Zurück zu Ausgangselement springen

Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement.
Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.

Speichern

Speichert Änderungen in der SAP ERP Projektierung.

Löschen

Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.

Nach oben verschieben

Verschiebt markiertes Element in Detailansicht der Tabelle um eine Position nach oben.

Nach unten verschieben

Verschiebt markiertes Element in Detailansicht der Tabelle um eine Position nach unten.

Alle erweitern

Erweitert alle geschlossenen Strukturen.

Klick auf Pfeil neben Symbol öffnet Dropdownliste zur Auswahl von:

  • Alle erweitern
  • Alle reduzieren
  • Selektierte erweitern
  • Selektierte reduzieren

XML exportieren alle...

Exportiert alle Einträge in eine XML-Datei.

XML importieren

Importiert Einträge aus einer XML-Datei.

Eigenschaften

Öffnet das Eigenschaftenfenster.

Hilfe

Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Kontextmenü Knoten SAP ERP

Kontextmenü Knoten Wartungsmeldungen

Kontextmenü Wartungsmeldung

Kontextmenü Knoten Messbelege

Kontextmenü Zeitplan

Kontextmenü Variablenliste Wartungsmeldungen und Messbelege

Kontextmenü Funktionsaufrufe

Kontextmenü einzelne SAP Funktion


Kontextmenü Knoten SAP ERP

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü Knoten SAP ERP

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Speichern | Speichert Änderungen in der SAP ERP Projektierung.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Knoten Wartungsmeldungen

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü Knoten Wartungsmeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Meldungsart neu | Fügt eine neue leere Meldung in die Liste ein.
Alle Wartungsmeldungen XML exportieren | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Wartungsmeldung

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü Wartungsmeldung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Verknüpfte Elemente | Zeigt mit der Wartungsmeldung verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Löschen | Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in eine XML-Datei.
Eigenschaften | Öffnet Eigenschaften-Fenster.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Knoten Messbelege

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü Knoten Messbelege

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Zeitplan neu | Fügt einen neuen leeren Zeitplan in die Liste ein.
Alle Messbelege XML exportieren | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Zeitplan

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü Zeitplan

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Verknüpfte Elemente | Zeigt mit dem Zeitplan verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Löschen | Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in eine XML-Datei.
Eigenschaften | Öffnet Eigenschaften-Fenster.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Variablenliste Wartungsmeldungen und Messbelege

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü Variablenliste Wartungsmeldungen und Messbelege

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Verknüpfte Elemente | Zeigt mit der Variable verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Selektierte Variable entfernen | Löscht ausgewählte Variablen aus der Liste.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü Funktionsaufrufe

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü Funktionsaufrufe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Knoten Funktionsaufrufe

Menüpunkt | Aktion
SAP Funktion neu | Öffnet den Assistent zur Auswahl eines SAP Funktionmsbausteins.
Alle SAP Funktionen XML exportieren | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Tabelle Funktionsaufrufe

Parameter | Beschreibung
SAP Funktion neu | Neue SAP Funktion anlegen
Standardfunktion erzeugen | Legt eine neue zenon Funktion für den Aufruf der selektierten SAP Funktion an.
Verknüpfte Elemente | Zeigt mit der SAP Funktion verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Löschen | Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus XML-Datei.
RFC-Funktionsbaustein vom SAP System einlesen | Liest die Schnittstellenbeschreibung des Funktionsbausteins aus dem SAP System ein. Ist kein SAP Name angegeben, wird der Assistent zur Auswahl von Funktionsbausteinen angezeigt.
Dokumentation des RFC-Funktionsbausteins anzeigen | Liest die Dokumentation des Funktionsbaustein aus dem SAP Sys\-tem ein und zeigt sie mit Hilfe des Webbrowsers als HTML-Datei an.
Hilfe | Öffnet die Online-Hilfe.


Kontextmenü einzelne SAP Funktion

Handbuch -> SAP Interface -> Projektieren im Editor -> Symbolleiste und Kontextmenüs -> Kontextmenü einzelne SAP Funktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü SAP Funktion

Parameter | Beschreibung
Parameter neu | Neuen Parameter bei der SAP Funktion anlegen.
Tabelle neu | Neue Tabelle bei der SAP Funktion anlegen.
Standardfunktion erzeugen | Legt eine neue zenon Funktion für den Aufruf der selektierten SAP Funktion an.
Verknüpfte Elemente | Zeigt mit der SAP Funktion verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Löschen | Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in eine XML-Datei.
Eigenschaften | Öffnet Eigenschaften-Fenster.
RFC-Funktionsbaustein vom SAP System einlesen | Liest die Schnittstellenbeschreibung des Funktionsbausteins aus dem SAP System ein. Ist kein SAP Name angegeben, wird der Assistent zur Auswahl von Funktionsbausteinen angezeigt.
Dokumentation des RFC-Funktionsbausteins anzeigen | Liest die Dokumentation des Funktionsbaustein aus dem SAP Sys\-tem ein und zeigt sie mit Hilfe des Webbrowsers als HTML-Datei an.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü der Parameterliste einer SAP Funktion

Parameter

Beschreibung

Parameter neu

Neuen Parameter bei der SAP Funktion anlegen.

Tabelle neu

Neue Tabelle bei der SAP Funktion anlegen.

Strukturfeld neu

Neues Strukturfeld bei Parameter oder Tabelle anlegen.

Verknüpfte Elemente

Zeigt mit der SAP Funktion verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.

Löschen

Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.

Knoten erweitern/reduzieren

Strukturfelder von Parametern und Tabellen anzeigen oder verbergen.
  • Alle erweitern

Strukturfelder aller Parameter und Tabellen anzeigen.
  • Alle reduzieren

Strukturfelder aller Parameter und Tabellen verbergen.
  • Selektierte erweitern

Strukturfelder bei selektierten Parametern und Tabellen anzeigen.
  • Selektierte reduzieren

Strukturfelder bei selektierten Parametern und Tabellen verbergen.

Hilfe

Öffnet die Online-Hilfe.

Kontextmenü Parameterliste einer SAP Funktion mit Strukturfeld selektiert

Parameter | Beschreibung
Strukturfeld neu | Neues Strukturfeld bei Parameter oder Tabelle anlegen.
Verknüpfte Elemente | Zeigt mit der SAP Funktion verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Löschen | Löscht ausgewählte Strukturfelder.
Nach oben verschieben | Ausgewähltes Strukturfeld um eine Stelle nach oben verschieben.
Nach unten verschieben | Ausgewähltes Strukturfeld um eine Stelle nach unten verschieben.
Hilfe | Öffnet die Online-Hilfe.


Verbindungsparameter zu einem SAP System

Handbuch -> SAP Interface -> Projektieren im Editor -> Verbindungsparameter zu einem SAP System

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Verbindung zu einem SAP System aufzubauen sind einige grundlegende Parameter-Angaben notwendig. Diese werden in den Eigenschaften zu SAP ERP im Detailfenster des Projektmanagers projektiert.

Parameter | Beschreibung
SAP ERP System | Enthält Einstellungen zum gekoppelten SAP ERP System.
SAP Logon | Enthält Einstellungen für die Anmeldung am SAP system.
Meldungen | Enthält Informationen für Meldungen.
Fehlersuche | Enthält Eigenschaften zur Fehlersuche.

Details zu den einzelnen Eigenschaften finden Sie in der Eigenschaftenhilfe der jeweiligen Eigenschaft.


Wartungsmeldungen

Handbuch -> SAP Interface -> Projektieren im Editor -> Wartungsmeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für das Planungssystem ist es wichtig, auch über aufgetretene Störungen, Stillstandszeiten etc. informiert zu sein. Im SAP System werden dazu sogenannte Wartungsmeldungen verwendet. Als Wartungsmeldung kann jeder in zenon definierte Alarm einer Prozessvariablen definiert werden.

info Info

Tritt bei einer der verknüpften Variablen ein Alarm auf, wird im SAP System eine Wartungsmeldung mit der angegebenen Meldungsart und dem Grenzwerttext des Alarms angelegt. Die Nummer des Anlagenteils (Technischer Platz oder Equipment) wird aus der Betriebsmittelkennung der Variable ausgelesen.

Kontextmenü Wartungsmeldungen (Gruppe)

Menüpunkt | Aktion
Meldungsart neu | Fügt eine neue leere Meldung in die Liste ein.
Alle Wartungsmeldungen XML exportieren | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Wartungsmeldung

Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Verknüpfte Elemente | Zeigt mit der Wartungsmeldung verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Löschen | Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in eine XML-Datei.
Eigenschaften | Öffnet Eigenschaften-Fenster.
Hilfe | Öffnet die Online-Hilfe.


Messbelege

Handbuch -> SAP Interface -> Projektieren im Editor -> Messbelege

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In SAP Anwendungen beschreiben Messwerte einen bestimmten Zustand des Produktionssystems zu einem bestimmten Zeitpunkt im Prozessablauf. Als Messwert kann jede beliebige in zenon vorhandene Variable definiert werden. Damit können protokollunabhängig Daten aus dem Echtzeitprozess an die überlagerte Management-Ebene übergeben werden. Messwerte werden an ein SAP System, abhängig von einem fix definierten Zeitplan, übergeben.

info Info

Zu den in einem Zeitplan angegebenen Zeiten werden die aktuellen Werte der mit dem Zeitplan verknüpften Variablen gelesen.Für jeden Variablenwert wird je ein Messbeleg im SAP System erzeugt.

Kontextmenü Messbelege (Gruppe)

Menüpunkt | Aktion
Zeitplan neu | Fügt einen neuen leeren Zeitplan in die Liste ein.
Alle Messbelege XML exportieren | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Messbeleg

Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl von Variablen.
Verknüpfte Elemente | Zeigt mit dem Zeitplan verknüpfte Elemente in einer Dropdownliste an und ermöglicht es, zu diesen Elementen zu springen.
Löschen | Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in eine XML-Datei.
Eigenschaften | Öffnet Eigenschaften-Fenster.
Hilfe | Öffnet die Online-Hilfe.


Funktionsaufrufe

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aktionen im SAP System und die Übertragung von Daten zum SAP System werden durch den Aufruf von Funktionsbau\-stei\-nen ausgeführt. Funktionsbausteine werden mit dem SAP System mitgeliefert. Es können aber über die ABAP-Work\-bench auch eigene benutzerdefinierte Funktionsbausteine programmiert werden.

Beliebige Funktionen im SAP System können direkt aus zenon heraus aufgerufen werden. Dafür wird Im Editor die Schnittstelle des aufgerufenen Funktionsbausteins mit den erforderlichen Parametern, Tabellen und Strukturen abgebildet und mit zenon Variablen verknüpft. Der tatsächliche Funktionsaufruf erfolgt durch Ausführung einer zenon Funktion, der dieses Abbild als Parameter übergeben wird.

Hinweis: Die SAP RFC-Schnittstelle lässt jeweils nur einen gleichzeitigen Funktionsaufruf zu. Um überlappende Funktionsaufrufe zu vermeiden, kann die Aktivität mit Hilfe einer Variablen überwacht werden.

Noch in diesem Kapitel

Funktionsbaustein mit Assistent auswählen

SAP Funktionen

Dokumentation des RFC-Funktionsbausteins

Parameter, Tabellen und Strukturfelder

Variablen verknüpfen

SAP Funktionen aufrufen


Funktionsbaustein mit Assistent auswählen

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> Funktionsbaustein mit Assistent auswählen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Funktionsbaustein aus SAP auszuwählen:

  1. wählen Sie in der Detailansicht von SAP Interface den Knoten Funktionsaufrufe

  2. wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl SAP Funktion neu...
  3. der Assistent für die Auswahl des SAP Funktionsbausteins wird geöffnet (dazu muss in den Optionen des Projekts die Einstellung Assistenten verwenden aktiviert sein)

    Achtung: Testen Sie Ihr Projekt in einem Testsystem, bevor Sie SAP Funktionsbausteine in einem Produktivsystem aufrufen. Fehler beim Aufruf können die Integrität der Daten im SAP System beeinträchtigen!

  4. wählen Sie den gewünschten Funktionsbaustein aus

Parameter | Beschreibung
Funktionsbaustein auswählen | Combobox für Auswahl von SAP Funktionsbausteinen. Suchbegriff kann frei eingegeben oder aus Dropdownliste gewählt werden.
Liste Funktionsbausteine | Liste der gefundenen Funktionsbausteine, die dem Suchbegriff entsprechen.
Zurück | Schaltet zurück zum Startbildschirm des Assistenten.
Fertigstellen | Speichert Funktionsbaustein mit allen dazu gehörigen SAP Elementen in einer zenon SAP Funktion.
Abbrechen | Legt in zenon eine leere SAP Funktion an


SAP Funktionen

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> SAP Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine SAP Funktion bildet einen Funktionsbaustein aus dem SAP System in zenon ab. Sie enthält eine Liste von Objekten, die die Parameter und Tabellen des SAP Funktionsbausteins abbilden. Mit einer SAP Funktion können Variablen verknüpft werden, die Auskunft über den Aufrufzustand und das Ergebnis des letzten Aufrufs geben.

SAP Funktion anlegen

SAP Funktionen werden über den Menüpunkt SAP Funktion neu im Kontextmenü des Knotens Funktionsaufrufe oder der Liste der SAP Funktionen angelegt.

Wurde in den Optionen des Projekts die Eigenschaft Assistenten verwenden aktiviert, startet der Assistent zur Auswahl eines SAP Funktionsbausteins. Der Assistent liest die Schnittstellenbeschreibung des ausgewählten Funktionsbaustein aus dem SAP System ein und legt alle Objekte im Editor an.

Die SAP Funktion kann auch von Hand bearbeitet werden:

  • Um dabei die SAP Funktion mit der Schnittstellenbeschreibung im SAP System abzugleichen, wählen Sie im Kontextmenü den Befehl RFC-Funktionsbaustein vom SAP System einlesen. Wurde noch kein Funktionsbaustein-Name angegeben, wird der Assistent zur Auswahl von Funktionsbausteinen geöffnet. Bereits definierte Einstellungen, insbesondere verknüpfte Variablen, werden dabei nicht geändert.
  • Beim Anlegen einer SAP Funktion erhält die Eigenschaft Funktionsname einen automatisch erzeugten Namen für die SAP Funktion, dieser kann beliebig geändert werden.

    Interne ID: SAP Funktionen

    Funktionsname

    Frei vergebbare Bezeichnung für die SAP Funktion.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Die Eigenschaft RFC-Funktionsbaustein enthält den Namen des Funktionsbaustein im SAP System. Der angegebene Name muss mit dem Namen im SAP System übereinstimmen, sonst tritt beim Aufruf der SAP Funktion die Exception FU_NOT_FOUND auf.

    Interne ID: SAP Funktionen

    RFC-Funktionsbaustein

    Name des aufgerufenen Funk\-tions\-bau\-steins im SAP System.

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Fehlermeldungen

Aktivitätsüberwachung

Dokumentation des RFC-Funktionsbausteins


Fehlermeldungen

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> SAP Funktionen -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen geben Aufschluss über das Ergebnis des letzten Aufrufs der SAP Funktion. Dazu werden die Variablen verknüpft mit den jeweiligen Eigenschaften:

  • Fehlercode: enthält einen numerischen Code, der dem Ergebnis des letzten Aufrufs entspricht.

    Interne ID: Fehlermeldungen

    Fehlercode

    Numerische Variable für den Fehlercode des Funktionsaufrufs.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Fehlertext: eine kurze Beschreibung des aufgetretenen Fehlercodes.

    Interne ID: Fehlermeldungen

    Fehlertext

    String-Variable für Kurzbeschreibung des letzten aufgetretenen Fehlers.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Fehlerbeschreibung: ausführliche Beschreibung des letzten Fehlers, die von der SAP RFC-Schnittstelle erzeugt wird.

    Interne ID: Fehlermeldungen

    Fehlerbeschreibung

    String-Variable für ausführliche Be\-schreibung des letzten aufgetre\-te\-nen Fehlers.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Fehlercodes der RFC-Schnittstelle

Fehlercode | Fehlertext | Bedeutung
-1 | Keine Verbindung zum SAP System | SAP System kann nicht erreicht werden (Netzwerkfehler, Anmeldung etc.).
0 | OK | Kein Fehler aufgetreten.
1 | Error occurred | Unbestimmter Fehler, Details in der Eigenschaft Fehlerbeschreibung.
2 | Exception raised | Exception im Funktionsbaustein aufgetreten (ungültiger Parameter etc.).
3 | System exception raised, connection closed | Exception im System aufgetreten.
4 | Call received | Anderer Funktionsaufruf noch aktiv.

Hinweis:

  • Die Sprache des Fehlertextes ist von der Systemsprache der Runtime abhängig
  • Nicht alle Codes treten beim Aufruf von Funktionsbausteinen auf.


Aktivitätsüberwachung

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> SAP Funktionen -> Aktivitätsüberwachung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine mit der Eigenschaft Aktivität verknüpfte (numerische) Variable kann je nach Zustand der SAP Funktion drei verschiedene Werte annehmen:

Interne ID: Aktivitätsüberwachung

Aktivität

Numerische Variable zur Aktivitätsüberwachung der SAP Funktion. Kann z.B. für Verriegelungen verwendet werden, um überlappende Aufrufe zu verhindern.

Mögliche Werte: 0, 1, 2

0 = inaktiv

1 = in Aufrufwarteschlange eingereiht

2 = Aufruf aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • 0: Die SAP Funktion ist inaktiv und wird gerade nicht ausgeführt.
  • 1: Die SAP Funktion wird in die Aufruf-Warteschlange eingereiht (die SAP RFC-Schnittstelle lässt jeweils nur einen gleichzeitigen Funktionsaufruf zu).
  • 2: Der Funktionsaufruf wird zum SAP System gesendet, auf Antwort vom SAP System wird gewartet.
    Danach geht der Variablenwert wieder auf 0 (inaktiv).

Diese Variable kann z.B. für eine Verriegelung zur Vermeidung überlappender Funktionsaufrufe verwendet werden.


Dokumentation des RFC-Funktionsbausteins

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> SAP Funktionen -> Dokumentation des RFC-Funktionsbausteins

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Dokumentation zu einem SAP Funktionsbaustein kann über den Menüpunkt Dokumentation des RFC-Funktionsbausteins anzeigen im Kontextmenüs aufgerufen werden.

Die Dokumentation

  • muss dazu im SAP System vorhanden sein
  • wird in der Sprache des angemeldeten SAP Benutzers eingelesen
  • wird im Webbrowser im HTML-Format angezeigt.

Bereits eingelesene Dokumentationen werden im „Temp"-Ordner des aktuellen Windows-Benutzers abgelegt und beim erneuten Anzeigen von dort abgerufen.

Individuelle Gestaltung der Anzeige

Um die Anzeige der Dokumentation individuell zu gestalten:

  1. erstellen Sie ein Stylesheet mit dem Namen sapdoc.css
  2. legen Sie das Stylesheet im „Temp"-Ordner des Benutzers ab

Beispiel für ein Stylesheet

BODY,H1,H2,H3,H4,H5,H6,P,TD,TH,UL,DL,DIV {font-family: Geneva, Arial, Helvetica, sans-serif;}

BODY,TD {font-size: 90%;}

H1 {font-size: 120%; color: 1c1e41;}

H2 {font-size: 110%; color: 1c1e41;}

H3 {font-size: 100%; color: 1c1e41;}

H4 {font-size: 90%; font-style: italic; color: 1c1e41;}

H5 {font-size: 90%; font-style: normal; font-weight: lighter; color: 1c1e41;}

TH {font-size: 90%; font-weight: bold; text-align: left; color: 1c1e41;}


Dokumentation des RFC-Funktionsbausteins

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> Dokumentation des RFC-Funktionsbausteins

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Dokumentation zu einem SAP Funktionsbaustein kann über den Menüpunkt Dokumentation des RFC-Funktionsbausteins anzeigen im Kontextmenüs aufgerufen werden.

Die Dokumentation

  • muss dazu im SAP System vorhanden sein
  • wird in der Sprache des angemeldeten SAP Benutzers eingelesen
  • wird im Webbrowser im HTML-Format angezeigt.

Bereits eingelesene Dokumentationen werden im „Temp"-Ordner des aktuellen Windows-Benutzers abgelegt und beim erneuten Anzeigen von dort abgerufen.

Individuelle Gestaltung der Anzeige

Um die Anzeige der Dokumentation individuell zu gestalten:

  1. erstellen Sie ein Stylesheet mit dem Namen sapdoc.css
  2. legen Sie das Stylesheet im „Temp"-Ordner des Benutzers ab

Beispiel für ein Stylesheet

BODY,H1,H2,H3,H4,H5,H6,P,TD,TH,UL,DL,DIV {font-family: Geneva, Arial, Helvetica, sans-serif;}

BODY,TD {font-size: 90%;}

H1 {font-size: 120%; color: 1c1e41;}

H2 {font-size: 110%; color: 1c1e41;}

H3 {font-size: 100%; color: 1c1e41;}

H4 {font-size: 90%; font-style: italic; color: 1c1e41;}

H5 {font-size: 90%; font-style: normal; font-weight: lighter; color: 1c1e41;}

TH {font-size: 90%; font-weight: bold; text-align: left; color: 1c1e41;}


Parameter, Tabellen und Strukturfelder

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> Parameter, Tabellen und Strukturfelder

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Aufruf einer SAP Funktion werden Daten über Parameter und Tabellen übergeben. Die Werte der Parameter, Tabellen und deren Strukturfelder werden aus den verknüpften Variablen übernommen (Eingangsparameter) oder den verknüpften Variablen nach dem Aufruf zugewiesen (Rückgabeparameter).

Parameter, Tabellen und Strukturfelder anlegen

Parameter, Tabellen und Strukturfelder werden über das Kontextmenü in der Parameterliste einer SAP Funktion angelegt.

  • Namensvergabe
    • Beim Anlegen über das Kontextmenü erhalten die Objekte automatisch erzeugte Namen (Eigenschaft Name im SAP System). Diese müssen derart geändert werden, dass sie mit den Namen der betreffenden Objekte im SAP System übereinstimmen.

      Interne ID: Parameter, Tabellen und Strukturfelder

      Name im SAP System

      Name des Parameters, der Tabelle oder des Strukturfeldes im SAP System.

      Mehr im Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Beim Anlegen einer SAP Funktion mit Hilfe des Assistenten werden die Namen automatisch entsprechend der Schnittstellenbeschreibung im SAP System vergeben.
  • Parameter und Tabellen
    • Beim Aufruf der SAP Funktion werden nur jene Parameter und Tabellen verwendet, die auch tatsächlich in der Schnittstellenbeschreibung des Funktionsbausteins im SAP System vorhanden sind.
    • Sind nicht optionale Parameter oder Tabellen nicht projektiert oder nicht mit Variablen verknüpft, werden sie beim Aufruf der SAP Funktion mit Initialwerten belegt. In der Regel führt das zu einer Exception und damit zu einer Fehlermeldung beim Funktionsaufruf.
  • Informative Eigenschaften
    • Einige Eigenschaften von Parametern, Tabellen und Strukturfeldern (Typ, Optional und Info) haben nur informativen Charakter. Diese werden beim Anlegen einer SAP Funktion über den Assistenten mit den Informationen aus der Schnittstellenbeschreibung im SAP System belegt, können aber beliebig geändert werden.
    • Sie werden beim Aufruf der SAP Funktion nicht ausgewertet. Stattdessen werden die tatsächlichen Vorgaben der Schnittstellenbeschreibung im SAP System verwendet.


Variablen verknüpfen

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> Variablen verknüpfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Eigenschaft Variable werden Variablen mit Parametern, Tabellen und Strukturfelder einer SAP Funktion verknüpft.

Interne ID: Variablen verknüpfen

Variable

Mit dem Parameter, der Tabelle oder dem Strukturfeld verknüpfte zenon Va\-riable. Bei Tabellen in der Regel eine Array-Variable.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um Variablen zu verknüpfen:

  • benutzen Sie entweder die Eigenschaft Variable im Eigenschaftenfenster: Klick auf die Schaltfläche ... öffnet den Variablenauswahldialog
    oder
  • ziehen Sie die gewünschte Variable aus der Variablenliste direkt per Drag & Drop mit der Maus auf ein Objekt in der Parameterliste

Werden Strukturvariablen mit strukturierten Parametern und Tabellen verknüpft, so werden die Variablen der Strukturfelder nach Möglichkeit ebenfalls mit den Strukturelementen der Variable belegt.

Achtung: Das funktioniert aktuell nur beim Verknüpfen über Drag & Drop.

Aufruf einer SAP Funktion

Beim Aufruf einer SAP Funktion werden die Werte der Variablen gelesen, die mit Parametern und Tabellen für die Datenübergabe an den Funktionsbaustein verknüpft sind und den Parametern und Tabellen zugewiesen.

Umgekehrt werden die Parameter- und Tabellenwerte, die vom Funktionsaufruf zurückgegeben werden, auf die verknüpften Variablen zugewiesen.

Zeilenzahl bei Tabellen

Objekte für Tabellen können über eine Variable mit der Eigenschaft Zeilenanzahl verknüpft werden.

Interne ID: Variablen verknüpfen

Zeilenanzahl

Numerische Variable für die Anzahl der Zeilen, die aus der mit der Tabelle ver\-knüpf\-ten Variable über\-nom\-men wer\-den sollen, beziehungsweise Anzahl der beim Aufruf der SAP Funktion gelesenen Zeilen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Übernahme der Werte:

  • vor einem Funktionsaufruf: der Wert von Zeilenanzahl bestimmt, wie viele Zeilen der verknüpften (Array-)Variable in die Tabelle übernommen werden.
  • nach dem Funktionsaufruf: der Wert gibt die Anzahl der vom Funktionsaufruf zurückgegebenen Zeilen in der Tabelle an.


SAP Funktionen aufrufen

Handbuch -> SAP Interface -> Projektieren im Editor -> Funktionsaufrufe -> SAP Funktionen aufrufen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

SAP Funktionen werden über einen neuen zenon-Funktionstyp SAP Funktion ausführen aufgerufen. Die Funktion hat die (interne) ID der auszuführenden SAP Funktion als Parameter.

Um eine SAP Funktion von zenon aus zur Runtime aufzurufen:

  1. erstellen Sie eine neue zenon Funktion über Funktionen -> Kontextmenü -> Funktionen neu
  2. wählen Sie im Knoten Anwendung den Eintrag SAP Funktion ausführen
  3. der Dialog zur Konfiguration der Funktion wird geöffnet
  4. wählen Sie die gewünschte SAP Funktion aus

Parameter | Beschreibung
SAP Funktion | Dropdownnliste zur Auswahl einer SAP Funktion. Diese muss bereits im Projekt angelegt sein.
Diesen Dialog zur Runtime anbieten | Öffnet zur Runtime vor Ausführung der Funktion diesen Dialog.
OK | Erstellt Funktion mit gewählten Parametern.
Abbrechen | Erstellt Funktion ohne Parameter.
Hilfe | Öffnet Online-Hilfe.

Tipp: Im Editor kann über den Punkt Standard-Funktion erzeugen im Kontextmenü einer selektierten SAP Funktion automatisch eine Funktion angelegt werden, die die selektierte SAP Funktion in der Runtime ausführt.


Scheduler

Handbuch -> Scheduler

Der Scheduler ermöglicht die Ausführung von Aktionen gekoppelt an einen Zeitraum oder nach einem zeitlichen Muster. Dies kann zum Beispiel das Ändern des Sollwerts einer Variablen oder die Ausführung einer Systemfunktion und vieles mehr sein.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Der Scheduler arbeitet mit den absoluten Zeiten in den Fahrplänen. Folgende Funktionen stehen daher im Scheduler nicht zur Verfügung:

  • Relative Zeiten, z.B. Schichtbeginn, Schichtende, ...
  • Benutzerdefinierte Ereignisse

info Info

Im Unterschied zum lizenzpflichtigen PFS, ist der Scheduler auch unter Windows CE einsetzbar.

Wechsel zwischen Scheduler und PFS

Der Scheduler wird verwendet, wenn das Modul Production and Facility Scheduler (PFS) nicht lizenziert ist. Seine Funktion ist dem des PFS ähnlich, jedoch weniger umfangreich.

  • Ein Umstieg von Scheduler auf PFS durch Lizenzierung des Moduls ist jederzeit möglich, da die Fahrplandaten zueinander kompatibel sind.
  • Daten, die im PFS erstellt wurden, sind allerdings nicht mehr im Scheduler verwendbar!

Noch in diesem Kapitel

Erstellen eines Fahrplans

Schaltpunkte

Einstellungsmöglichkeiten des Scheduler

Erzeugen eines Sonderfahrplans

Löschen eines Sonderfahrplans

Kopieren bzw. Ersetzen von Fahrplänen

Fahrpläne bei Integrations -Projekten


Erstellen eines Fahrplans

Handbuch -> Scheduler -> Erstellen eines Fahrplans

In der Detailansicht des Schedulers kann ein neuer Fahrplan erstellt werden.

Parameter | Beschreibung
Erstellen | Erstellt einen neuen Fahrplan.
Einfügen | Fügt einen bestehenden Fahrplan ein.
Speichern | Speichert die Änderungen ab.
Verwerfen | Nach Bestätigung der Sicherheitsabfrage werden sämtliche gemachte Änderungen unwiederbringlich verworfen.
Einstellungen | Ruft die Einstellungsseiten für die Scheduler Eigenschaften auf.
Hilfe | Ruft die Onlinehilfe auf.


Schaltpunkte

Handbuch -> Scheduler -> Schaltpunkte

info Info

Schaltpunkte werden in der Runtime aus Sicherheitsgründen per Default immer als inaktiv angelegt und müssen dezidiert aktiviert werden, damit sie funktionieren. Im Editor werden Schaltpunkt per Default als aktiv angelegt. .

Noch in diesem Kapitel

Erstellen eines analogen Schaltpunkts

Erstellen eines Ein/Aus Schaltzeitpunkts

Nachbearbeiten von Schaltzeitpunkten

Farben der Schaltpunkte


Erstellen eines analogen Schaltpunkts

Handbuch -> Scheduler -> Schaltpunkte -> Erstellen eines analogen Schaltpunkts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

in analoger Schaltpunkt dient dazu, einmalig einen Sollwert auf eine numerische Variable abzusetzen (z.B. UINT, INT, etc.)

Danach können die Tage ausgewählt werden und hinzugefügt oder entfernt werden.

info Info

Es besteht die Möglichkeit, die Fahrplanobjekte per Mausselektion vorzuselektieren, beim Öffnen des Objektdialoges werden diese bereits als ausgewählte Objekte angezeigt. Zusätzlich wird auch die Start-und Endezeit entsprechend dem selektierten Bereich übernommen.

Noch in diesem Kapitel

Variablen hinzufügen

Funktionen hinzufügen


Variablen hinzufügen

Handbuch -> Scheduler -> Schaltpunkte -> Erstellen eines analogen Schaltpunkts -> Variablen hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen können ausgewählt werden. Die Beginnzeit wird eingegeben:

Parameter | Beschreibung
Beginnzeit | Zeitpunkt, wann der Schaltpunkt ausgeführt werden soll.
Variable hinzufügen | Fügt eine neue Variable zum Fahrplan hinzu. Dies ist auch zur Laufzeit möglich.
Funktion hinzufügen | Fügt eine neue Funktion zum Fahrplan hinzu. Dies ist auch zur Laufzeit möglich.
Sollwert | Erlaubt das Setzen der Sollwerte.
Entfernen | Entfernt die Zuordung der Variable oder Funktion zum Fahrplan. Schaltpunkte, welche diese Variable bzw. Funktion verwenden, werden gelöscht.

Der Sollwert für die Variablen kann frei innerhalb der Variablengrenzen definiert werden (bei Binärvariablen 0 oder 1)

In den Feldern des Min/Maxwertes wird der Messbereich der Variable angezeigt.

Der fertige Schaltplan sieht folgendermaßen aus.


Funktionen hinzufügen

Handbuch -> Scheduler -> Schaltpunkte -> Erstellen eines analogen Schaltpunkts -> Funktionen hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Funktionen für den Schaltzeitpunkt können ausgewählt werden.

Zum Start- und zum Endzeitpunkt können beliebige Funktionen auch projektübergreifend verknüpft werden. Dabei ist es möglich, mehrere bzw. für Start- und Endzeitpunkt unterschiedliche Funktionen zu verknüpfen.

info Info

Über die Funktion VBA Macro ausführen können zu den die Schaltzeitpunkten auch VBA-Macros ausgeführt werden.


Erstellen eines Ein/Aus Schaltzeitpunkts

Handbuch -> Scheduler -> Schaltpunkte -> Erstellen eines Ein/Aus Schaltzeitpunkts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Funktion einen Ein/Aus- Schaltpunkt zu definieren dient vor allem dazu über einen bestimmten Zeitraum eine Binärvariable auf 1 bzw. auf 0 zu setzen.

info Info

Zu Beginn eines solchen Schaltplans wird die Variable automatisch auf True gesetzt und am Ende auf False. Möchte man es umgekehrt, so erstellt man zuerst den Schaltzeitpunkt und durch Doppelklick gelangt man in das Menü, wo man die Sollwerte manuell einstellen kann (editieren, aktiv und inaktiv setzen oder die Uhrzeit ändern).

Im Editor über die rechte Maustaste erreichbar und in der Runtime steht eine MDI Funktion zur Verfügung.

Im Kontextmenü kann ein neuer Schaltplan erstellt werden.

info Info

Es können lediglichBinärvariablen ausgewählt werden.

Die Beginn- und Endzeit kann eingetragen werden:

Example Beispiel

Wenn ein Anwender nur eine Einschaltzeit (nur einen Schaltpunkt) braucht, dann muss er den Endzeitpunkt auf den Beginnzeitpunkt legen bzw. die Dauer auf 00:00:00 setzen. Dann können auch nur Variabeln/Funktionen zu einem definierten Startzeitpunkt projektiert werden.


Nachbearbeiten von Schaltzeitpunkten

Handbuch -> Scheduler -> Schaltpunkte -> Nachbearbeiten von Schaltzeitpunkten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Durch einen Doppelklick auf bereits projektierte Schaltzeitpunkte, wird der Nachbearbeitungs-Dialog geöffnet. In diesem können noch einmal alle Eigenschaften wie z.B. Start- und Endezeit überarbeitet werden. Zusätzlich gibt es auch die Möglichkeit neue analoge und Ein/Aus-Schaltpunkte (binäre Schaltpunkte) zu erstellen.


Farben der Schaltpunkte

Handbuch -> Scheduler -> Schaltpunkte -> Farben der Schaltpunkte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um welchen Schaltpunkt es sich handelt, wir anhand der Farben deutlich.

Parameter | Beschreibung
Grün | numerischer Schaltpunkt
Khaki | binärer Schaltpunkt
Blau | zwei überlappende binäre Schaltpunkte
Türkis | zwei überlappende Schaltpunkte, einer binär, einer numerisch


Einstellungsmöglichkeiten des Scheduler

Handbuch -> Scheduler -> Einstellungsmöglichkeiten des Scheduler

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese werden über den Eintrag Einstellungen im Kontextmenü in der Detailansicht des Schedulers geöffnet.

Noch in diesem Kapitel

Zeitumstellung

Feiertage


Zeitumstellung

Handbuch -> Scheduler -> Einstellungsmöglichkeiten des Scheduler -> Zeitumstellung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesen Einstellungen kann festgelegt werden nach welchen Zeitumstellungsvarianten berechnet werden soll.

Parameter | Beschreibung
Positive Zeitumstellung | Die Uhrzeit wird vorgestellt, die Systemzeit in die Zukunft gesetzt (z.B. Sommerzeit)
Schaltpunkte nachholen | Aktionen, die zwischen der aktuellen Zeit und der neu eingestellten Zeit liegen, werden sofort nach der Umstellung ausgeführt.
Schaltpunkte neu berechnen | Aktionen, die zwischen der aktuellen Zeit und der neu eingestellten Zeit liegen, werden übergangen und nicht ausgeführt. Die Schaltpunkte werden neu berechnet.
Negative Zeitumstellung | Die Uhrzeit wird zurückgestellt, die Systemzeit in die Vergangenheit gesetzt (z.B. Winterrzeit)
Schaltpunkte verwerfen | Die Schaltpunkte werden nicht neu berechnet. Es werden erst wieder Schaltpunkte beim Erreichen der Ausgangszeit ausgeführt.
Schaltpunkte neu berechnen | Aktionen, die zwischen der aktuellen Zeit und der neu eingestellten Zeit liegen, werden neu berechnet (d. h. bei erneutem Erreichen der definierten Zeit wieder ausgeführt). Dies hat die doppelte Ausführung der Schaltpunkte im korrigierten Zeitraum zur Folge.
SB Umschaltung | Standby Server Umschaltung, gültig für die Timeout Zeit bei der Redundanzumstellung
Schaltpunkte verwerfen | Die Schaltpunktausführung beginnt entsprechend der aktuellen Position am Standby. Schaltpunkte im Umschaltungszeitraum werden eventuell nicht ausgeführt.
Schaltpunkte neu berechnen | Die Schaltpunkte werden von der aktuellen Zeit -30 Sekunden neu berechnet und ausgeführt. Dies kann eine doppelte Schaltpunktausführung zur Folge haben.
Toleranzbereich für Zeitabweichung | Toleranz, um welche sich die Systemzeit ändern darf, ohne eine Neuberechnung der Schaltpunkte nach oben beschriebenen Kriterien auszulösen.


Feiertage

Handbuch -> Scheduler -> Einstellungsmöglichkeiten des Scheduler -> Feiertage

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Feiertage können je nach Land automatisch hinzugefügt werden.

Die Basis-Daten für die Feiertage befinden sich im zenon Programm-Verzeichnis, in der Datei Feiertage.txt und können mit jedem Text-Editor bearbeitet werden.

Die Einträge für ein Land beginnen durch Benennung des Landes eingeschlossen in eckigen Klammern und anschließender internationaler Telefonlandeskennung.

Die Definition der Feiertage erfolgt dann ab der nächsten Zeile, durch Angabe von Namen und Datum des Feiertages.

[Österreich] 45

Allerheiligen, 1998/11/01

Allerheiligen, 1999/11/01

Allerheiligen, 2000/11/01

Allerheiligen, 2001/11/01

Allerheiligen, 2002/11/01

Christi Himmelfahrt, 1998/05/21

Christi Himmelfahrt, 1999/05/13

Christi Himmelfahrt, 2000/06/01

Christi Himmelfahrt, 2001/05/24

Christi Himmelfahrt, 2002/05/09

...

Die korrekte Definition ist für die Erkennung des zu verwendenden Modells unabdingbar.

Durch einen Doppelklick auf den Plan kann die Eingabe korrigiert werden.


Erzeugen eines Sonderfahrplans

Handbuch -> Scheduler -> Erzeugen eines Sonderfahrplans

Zusätzlich zu gesetzlichen Feiertagen können beliebig viele benutzerdefinierte Sonderfahrpläne erstellt werden (Z.B. Betriebsferien). Diese können über das Kontextmenü des Schedulers als Sonderfahrplan erstellt werden. Dabei gilt die gleiche Regelung wie bei Feiertagen, existiert ein Sonderfahrplan, so werden die Schaltzeitpunkte des Standard-Fahrplans durch diesen überschrieben.

Zuerst wird die Zeit definiert.

Der Sondertag wird in der Tabelle eingetragen:

attention Achtung

Es ist nicht möglich mehrer Sondertage zugleich auszuführen. d.h. An einem Zeitraum in dem schon ein Sondertag projektiert ist, kann kein anderer mehr projektiert werden.


Löschen eines Sonderfahrplans

Handbuch -> Scheduler -> Löschen eines Sonderfahrplans

Sonderfahrpläne können im Kontextmenü mit dem Eintrag Löschen gelöscht werden. Zeitmodelle können ebenfalls über das Kontextmenü gelöscht werden, indem die Option Uhrzeit ausgewählt wird.


Kopieren bzw. Ersetzen von Fahrplänen

Handbuch -> Scheduler -> Kopieren bzw. Ersetzen von Fahrplänen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Rechte Maustaste können Fahrpläne kopiert und mittels Ersetzung mit anderen Variablen verknüpft werden. Beim Einfügen wird der Ersetzungsdialog aufgeschalten und die Ersetzung kann entweder durchgeführt werden oder mit Abbrechen kann ein identischer Fahrplan erstellt werden.


Fahrpläne bei Integrations -Projekten

Handbuch -> Scheduler -> Fahrpläne bei Integrations -Projekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein Scheduler mit Daten eines Unterprojektes aufgerufen werden soll, so ist die entsprechende Funktion des Unterprojektes aufzufrufen.

Die Daten für den Schedule kommen immer aus dem Projekt, in dem die Bildumschaltungsfunktion liegt.


Skripte

Handbuch -> Skripte

Sollen mehrere benutzerdefinierte Funktionen zu einer Abfolge verbunden werden, müssen sie zu einem Skript zusammengefasst werden.

Im System sind mehrere Skripte definiert, die automatisch abgearbeitet werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Skript neu | Legt ein neues Skript an.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

Skripte

Skript

Beschreibung

AUTOSTART

Skript wird beim Onlinestart (Einzelplatz bzw. Server) automatisch nach dem Aufschalten des Startbildes ausgeführt (am Einzelplatz bzw. Server), wenn das Projekt das Runtime-Startprojekt ist. Das Skript wird nicht ausgeführt, wenn das Projekt nicht als Startprojekt definiert ist bzw. wenn es sich um ein Subprojekt in einem Multihierarchischen Netzwerk handelt.

AUTOEND

Skript wird beim Beenden des Onlinebetriebes (Einzelplatz bzw. Server) automatisch ausgeführt (am Einzelplatz bzw. Server), wenn das Projekt das Runtime-Startprojekt ist. Das Skript wird nicht ausgeführt, wenn das Projekt nicht als Startprojekt definiert ist bzw. wenn es sich um ein Subprojekt in einem Multihierarchischen Netzwerk handelt.

Achtung:

  • Der VBA Event project inactive wird vor AUTO_END_xxx Skripte ausgeführt. Daher wird in Skripten die zenon Funktion VBA-Makro ausführen dann nicht mehr ausgeführt, da VBA zu diesem Zeitpunkt nicht mehr läuft. VBA-Makros, die in "AUTO_END" ausgeführt werden sollen, müssen über Project.Inactive aufgerufen werden.
  • Zyklische Archive dürfen nicht im Skript AUTOEND angegeben werden.

AUTOSTART_CLIENT

Skript wird beim Onlinestart des Clients automatisch vor dem Aufschalten des Startbildes am Client ausgeführt, wenn das Projekt das Runtime-Startprojekt ist.

AUTOEND_CLIENT

Skript wird beim Beenden des Onlinebetriebes des Clients automatisch am Client ausgeführt, wenn das Projekt das Runtime-Startprojekt ist.

AUTOSTART_SRVPRJ

Skript wird beim Onlinestart auf dem Rechner, der Server für das Projekt ist, automatisch vor dem Aufschalten des Startbildes ausgeführt, unabhängig davon, ob das Projekt als Startprojekt definiert wurde oder nicht bzw. wenn es sich um ein Subprojekt in einem Multihierarchischen Netzwerk handelt.

AUTOEND_SRVPRJ

Skript wird beim Beenden des Onlinebetriebes auf dem Rechner, der Server für das Projekt ist, automatisch ausgeführt, unabhängig davon, ob das Projekt als Startprojekt definiert wurde oder nicht bzw. wenn es sich um ein Subprojekt in einem Multihierarchischen Netzwerk handelt.

Für den Simulationsmodus stehen Ihnen diese Skripte zur Verfügung, die automatisch ausgeführt werden:

Skript | Beschreibung
AUTOSTART_SIMUL | Wenn die Runtime im Simulationsmodus startet, wird automatisch das Skript mit dem Namen AUTOSTART_SIMUL ausgeführt, wenn es vorhanden ist.
AUTOEND_SIMUL | Wenn die Runtime den Simulationsmodus beendet, wird automatisch das Skript mit dem Namen AUTOEND_SIMUL ausgeführt, wenn es vorhanden ist.

Noch in diesem Kapitel

Projektieren im Editor

Funktionen für Skripte

Bedienen während der Runtime


Projektieren im Editor

Handbuch -> Skripte -> Projektieren im Editor

Die Liste der definierten Skripte des aktiven Projekts wird nach der Anwahl einer Verzweigung Skripte in der Baumansicht des Projektmanager in der Tabellenansicht angezeigt.

Nachdem das Kontextmenü der Detailansicht des Projektmanagers mit der rechten Maustaste geöffnet wird, stehen abhängig davon, ob ein Skript ausgewählt ist, folgende Befehle zur Bearbeitung der Skripte zur Verfügung.

Kontextmenü Knoten Skripte

Parameter | Beschreibung
Skript neu | Erstellt ein neues Skript.
XML exportieren alle | Exportiert alle Skripte in XML-Datei.
XML importieren | Importiert Skripte aus XML-Dateien.
Einfügen | Nach dem Ausführen der Befehle Kopieren oder Ausschneiden kann mit diesem Befehl das kopierte bzw. ausgeschnittene Skript aus der Windows Zwischenablage in dasselbe Projekt eingefügt werden.
Hilfe | Öffnet die Online Hilfe.

attention Achtung

Eingabebegrenzung: Der Skript-Name ist auf maximal 31 Zeichen begrenzt.

info Info

Beim Ändern von Skriptnamen werden die Parameter der verbundenen Funktionen entsprechend geändert. Bei Mehrplatzfähigen Projekten werden Funktionen nach einer Kontrollabfrage zum Änderungen Ermöglichen automatisch angepasst. Nach erfolgreicher Änderung wird das Skript geändert.

Symbolleiste Skripte

Parameter | Beschreibung
Skript neu | Fügt ein neues Skript zur Liste hinzu.
Funktionen hinzufügen | Öffnet den Dialog zum Hinzufügen von Funktionen.
Kopieren | Kopiert das ausgewählte Skript in die Windows Zwischenablage.
Einfügen | Fügt ein die Windows Zwischenablage kopiertes Skript ein.
Löschen | Löscht das ausgewählte Skript.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien.
Umbenennen | Erlaubt das Ändern des Skript-Namens. Auch per Mausklick in das Feld oder über Taste F2 möglich.
Eigenschaften | Öffnet das Eigenschaften-Fenster für das ausgewählte Skript.
Hilfe | Öffnet die Online Hilfe.

Kontextmenü ausgewähltes Skript

Parameter | Beschreibung
Funktionen hinzufügen | Öffnet den Dialog zum Hinzufügen von Funktionen.
Skript neu | Fügt ein neues Skript zur Liste hinzu.
Skript umbenennen | Erlaubt das Ändern des Skript-Namens. Auch per Mausklick in das Feld oder über Taste F2 möglich.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien.
Standard-Funktion erzeugen | Legt eine neue Funktion Skript ausführen an.
Kopieren | Kopiert das ausgewählte Skript in die Windows Zwischenablage.
Einfügen | Fügt ein die Windows Zwischenablage kopiertes Skript ein.
Löschen | Löscht das ausgewählte Skript.
Eigenschaften | Öffnet das Eigenschaften-Fenster für das ausgewählte Skript.
Hilfe | Öffnet die Online Hilfe.

Nach dem Erstellen eines neuen Skripts wird die Eingabe eines Namens erwartet und das neue Skript erscheint in der Struktur der Detailansicht.

Kontextmenü Funktion

Parameter | Beschreibung
Nach oben verschieben | Verschiebt die ausgewählte Funktion nach oben.
Nach unten verschieben | Verschiebt die ausgewählte Funktion nach unten.
Funktion entfernen | Entfernt die ausgewählte Funktion aus dem Skript.
Hilfe | Öffnet die Online Hilfe.

Vordefinierte Skripte

Autostart

Im Skript AUTOSTART bzw. AUTOSTART_CLIENT werden die Startinformationen (z.B. Kopfzeile und Statuszeile aufschalten, Alarmausgänge rücksetzen etc.) projektiert.

Achtung: Das Startbild darf nicht im Skript AUTOSTART aufgerufen werden, da es über die Projekteigenschaft Startbild festgelegt wird.

Interne ID: Projektieren im Editor

Startbild

Beim Start der Runtime wird dieses Bild automatisch geöffnet. Das erste in einem Projekt erzeugte Bild wird hier automatisch eingetragen.
Klick auf Schaltfläche ... öffnet den Bildauswahldialog.

Hinweis: Spezielle Bildtypen als Startbild werden mit leerem Filter und damit ohne Daten aufgeschaltet

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Für das Aufschalten der immer zu einem Hauptbild zugehörigen Teilbilder (bildspezifische Menüzeilen etc.) ist ein Bildskript (z.B. B_Bildname) zu definieren (Bilderstellung). Damit wird sichergestellt, dass durch die Anwahl des Bildes über die Funktion Bildumschaltung die Anwahl aus dem Bildkatalog oder die Funktion Bild zurück immer alle Detailbilder mit aufgeschaltet werden.

Autoend

Im Skript AUTOEND bzw. AUTOEND_CLIENT werden die definierten Ende-Funktionen projektiert (Hupe quittieren, PIO-8 Ausgangsprozessvariablen rücksetzen etc.).

Achtung:

  • Zyklische Archive dürfen nicht im Skript AUTOEND angegeben werden.
  • Der VBA Event project inactive wird vor AUTO_END_xxx Skripte ausgeführt. Daher wird in Skripten die zenon Funktion VBA-Makro ausführen dann nicht mehr ausgeführt, da VBA zu diesem Zeitpunkt nicht mehr läuft. VBA-Makros, die in "AUTO_END" ausgeführt werden sollen, müssen über Project.Inactive aufgerufen werden.


Funktionen für Skripte

Handbuch -> Skripte -> Funktionen für Skripte

Über Funktionen werden Skripte zur Runtime gestartet:

  1. wählen Sie im Knoten Funktionen im Kontextmenü Funktion neu...
  2. navigieren Sie zu Skripte
  3. wählen Sie
    1. Skript ausführen, um ein im Knoten Skripte bereits existierendes Skript zur Runtime auszuführen
    2. Skript mit Online-Auswahl, um zur Runtime die Auswahl des zu startenden Skripts zu ermöglichen

Funktion "Skript ausführen"

Die Funktion Skript ausführen führt zur Runtime ein im Editor vordefiniertes Skript aus.

Funktion "Skript mit Online-Auswahl"

Mit der Verwendung dieser Funktion kann im Onlinebetrieb ein Skript vor der Ausführung aus der Skriptverwaltung ausgewählt werden.

Bei der Projektierung ist ein vordefiniertes Skript anzugeben. Dieses Skript wird in der Runtime als Standard-Auswahl in der aufgeschalteten Skript-Auswahl verwendet.

Skripte im Netzwerk

Bei aktivem Netzwerk kann für Skripte über den Eigenschaftenknoten Ausführung definiert werden, auf welchem Rechner das Skript ausgeführt wird.

Interne ID: Funktionen für Skripte

Ausführung

Nur verfügbar in Netzwerk-Projekten:
Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Beachten Sie die Prioritäten der Skriptausführung im Netzwerk

Noch in diesem Kapitel

Priorität im Netzwerk


Priorität im Netzwerk

Handbuch -> Skripte -> Funktionen für Skripte -> Priorität im Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei aktivem Netzwerk wird über den Eigenschaftenknoten Ausführung für Skripte definiert, wo das Skript ausgeführt wird:

Interne ID: Priorität im Netzwerk

Ausführung

Nur verfügbar in Netzwerk-Projekten:
Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Aktueller Rechner
  • Client
  • Server
  • Standby

Dieser Ausführungsort gilt auch für alle im Skript gesammelten Funktionen. Funktionen, denen ursprünglich ein anderer Ausführungsort zugewiesen worden war, übernehmen den neuen hier definierten Ausführungsort.

Beispiel 1: Aktueller Rechner

  • Funktion 1 wurde mit Ausführungsort Server definiert.
  • Funktion 2 wurde mit Ausführungsort Client definiert.
  • Für die Funktion Skript ausführen wurde Aktueller Rechner festgelegt.
  • Folge: Beide Skripte werden exakt auf dem Rechner ausgeführt, auf dem die Funktion Skript ausführen ausgeführt werden. Das kann ein Client, ein Server oder ein Standby sein.

Beispiel 2: Client versus Server

  • Das Skript enthält 2 Funktionen mit Ausführungsort Client.
  • Für die Funktion Skript ausführen wurde Server festgelegt.
  • Folge: Beide Skripte werden auf dem Server ausgeführt, unabhängig davon, auf welchem Rechner Skript ausführen gestartet wird.

Beispiel 3: Treiberkommandos:

Treiberkommandos werden per Default am Server und am Standby ausgeführt. Wird ein Skript mit Treiberkommandos am Client gestartet, dann wird :

  • die Funktion Treiberkommanods am Client gestartet
  • der Treiber nach Ausführung des Skripts am Server gestoppt


Bedienen während der Runtime

Handbuch -> Skripte -> Bedienen während der Runtime

Im Onlinebetrieb stehen folgende Funktionen für die Skriptverwendung zur Verfügung:

Parameter | Beschreibung
Skript ausführen | direktes Ausführen des aktivierten Skripts
Skript mit Online-Auswahl | Auswahl eines Skripts vor seiner Ausführung

Bei der Verwendung der Funktion Skript mit Onlineauswahl wird die Skriptverwaltung aufgeschaltet.

Der Anwender kann in der Runtime ein Skript aus der Liste auswählen. Nach Betätigung des Buttons OK wird das ausgewählte Skript ausgeführt.


Sprachumschaltung

Handbuch -> Sprachumschaltung

Bei der Umsetzung internationaler Projekte ist die Umschaltbarkeit der Sprache unerlässlich. Zum Beispiel bei:

  • Auslieferung eines Projektes in unterschiedlichen Sprachen
  • zentralen Diensten, auf die aus verschiedenen Ländern zugegriffen wird
  • dezentrale Anlagen, die weltweit einsehbar sind
  • verschiedensprachiger Bedienung einer Anlage

Die Sprachumschaltung ermöglicht, im Onlinebetrieb dargestellte Textinformationen in verschiedene Sprachen umzuschalten .Zur Projektierung wird in der Detailansicht des Knotens Sprachdatei eine Sprachtabelle mit den nötigen Sprachdateien angelegt.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Sprachdatei neu... | Öffnet den Dialog zum Anlegen einer neuen Sprachdatei.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Sprachumschaltbar Texte

Sprachumschaltung Detailansicht Symbolleiste und Kontextmenü

Schlüsselwörter

Sprachtabelle

Sprachdatei extern bearbeiten

Fonts - Schriftarten

Vordefinierte Schlüsselwörter - Systemtexte in CEL

Pfade für Sprachumschaltung der Runtime-Hilfe

Auslagerung von Übersetzungen

Funktion Sprachumschaltung


Sprachumschaltbar Texte

Handbuch -> Sprachumschaltung -> Sprachumschaltbar Texte

Sprachumschaltung kann eingesetzt werden bei:

  • in der Runtime angezeigten Texten:
    Z.B. Grenzwerttexte, Variablen-Kennung.
  • Zeichensätzen:
    Z.B. Arial Unicode.
  • Texten in AML, CEL und IPA:
    Zustandstexte und Systemmeldungen in der Alarmmelde - und Chronologische Ereignisliste sowie im Industrial Performance Analyzer
  • Alarm/Ereignis-Gruppen, Alarm/Ereignis-Klassen:
    Gruppen- und Klassennamen.
  • Runtime Dialoge:
    Z.B. Standard Login Fenster Alarm Filter Dialog.
  • Runtime-Hilfe:
    Die gesamte Runtime-Hilfe ist sprachumschaltbar (Vorbereitungen für sprachumschaltbare Hilfe).
  • Listenpfad:
    Umschalten von Texten für ein Bild vom Bildtyp Liste bzw. HTML Seiten für Bildtyp HTML.
  • Medienpfad:
    Umschalten von Pfaden für Grafiken, Hilfe, Multimedia, Texte und Formate sowie Report Viewer.
  • S7-Graph Schrittketten:
    Umschalten von dynamischen und statischen Elementen.

Umschaltbar sind:

Parameter | Beschreibung
Grafische Elemente | Text
 | Text verknüpfen
 | Text Button
 | Multibin
 | Combi Element
 | Universal-Regler
 | ComboListBox
Variablen | Kennung (der Variablenname ist nicht umschaltbar)
 | Einheit
 | Grenzwerttext Der dynamische Grenzwerttext ermöglicht das Einfügen aktueller Werte von Variablen in den Grenzwerttext einer anderen Variablen. Fixer Text kann dabei über einen Index mit Schlüsselwörter aus einer Sprachtabelle verknüpft werden. Details siehe: Dynamischer Grenzwerttext und Einsatz von Schlüsselwörter in Textlisten im Handbuch Variablen.
Bilder | Bildname
Rezepte | Rezeptname
Menüs | Menüs
Report Generator | Standardtexte
IPA | Texte
Alarm Verwaltung / Chronologische Ereignisliste | Listenüberschrift (Spaltenbezeichnungen), Alarm/Ereignis-Gruppen- und Alarm/Ereignis-Klassen Name
Archiv Nachbearbeitung | Listenüberschrift (Spaltenbezeichnung)
Runtime | Dialoge in der Runtime
Reaktionsmatrizen | Grenzwerttext
Tooltips | Überall, wo Signaturtexte für Dynamische Elemente definiert wurden.
Signaturtexte | Überall wo Signaturen eingesetzt werden können

Nicht umschaltbar sind:

Art | Beschreibung
Variablen | Variablenname (die Variablenkennung ist sprachumschaltbar), String Ersatzwert
Funktionen | Funktionsnamen
Schriften | Name
Schablonen | Name
Treiber | Bezeichnung (Bei Treiberauswahl eingebbar)
Datentypen | Name
Reaktionsmatrizen | Name
Zuweisungen | Name
Skript | Name
Archiv | Bezeichnung
Zeitsteuerung | Name
Process Control Engine | Taskname
Verriegelungen | Name
Menüs | Name


Sprachumschaltung Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Sprachumschaltung -> Sprachumschaltung Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Menüpunkt

Aktion

Sprachdatei neu

Fügt eine neue leere Sprachdatei in die Tabelle ein.

Standard-Funktion erzeugen

Erzeugt eine Funktion Sprachumschaltung und öffnet den Dialog zur Konfiguration.

Interne ID: Sprachumschaltung Detailansicht Symbolleiste und Kontextmenü

Sprachumschaltung

Diese Funktion schaltet in mehrsprachigen Projekten auf eine ausgewählte Sprache um.

Mehr im Online-Handbuch

Speichern

Speichert Sprachdatei.

Datei kopieren

Kopiert ausgewählte Datei in die Zwischenablage.

Schlüssel kopieren

Kopiert ausgewählte Schlüssel in die Zwischenablage.

Einfügen

Fügt Inhalt der Zwischenablage (Datei oder Schlüssel) in die Sprachtabelle ein. Die eingefügte Datei wird erst nach dem Aktualisieren der Editoransicht angezeigt.

Datei löschen

Löscht ausgewählte Sprachdatei aus der Sprachtabelle.

Schlüssel löschen

Löscht ausgewählte Schlüssel aus Sprachtabelle.

Zurück zu Ausgangselement springen

Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement.
Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.

Datei exportieren

Exportiert ausgewählte Sprachdatei ins Format TXT.

Datei importieren

Importiert Datei im Format TXT.

Erweiterter Import/Export

Optionen für den Export ins Format CSV und den Import aus CSV.

Suchen

Öffnet Dialog zur Suche nach Einträgen in der aktiven Sprachdatei.

Ersetzen

Öffnet Dialog, um Einträge in der aktiven Sprachdatei zu suchen und zu ersetzen.

Schrift für selektierte Sprachdatei

Öffnet Dropdownliste zur Auswahl der Schrift:

  • Auswahl: Dialog zur Auswahl einer Schrift wird geöffnet
  • Standardschrift: Standardschrift wird verwendet

Sprachdatei für Editor

Öffnet Dropdownliste zur Auswahl der Sprachdatei für den Editor.

Alle Filter entfernen

Entfernt alle Filtertexte aus den Spalten.

Zeichentabelle

Öffnet die Windows Zeichentabelle.

Lokale Version aktualisieren

Nur bei Verteiltem Engineering verfügbar.

Gleicht die lokale Kopie der Sprachdatei mit der Server-Datenbank ab und aktualisiert sie.

Änderungen ermöglichen

Nur bei Verteiltem Engineering verfügbar.

Sperrt Sprachdatei gegen Änderungen durch andere Anwender.

Änderungen übernehmen

Nur bei Verteiltem Engineering verfügbar.

Überträgt lokale Änderungen zur Server-Datenbank und gibt die Sprachdatei für andere Anwender wieder frei.

Änderungen verwerfen

Nur bei Verteiltem Engineering verfügbar.

Verwirft alle lokalen Änderungen und gibt die Sprachdatei für andere Anwender wieder frei.

Hilfe

Öffnet die Online-Hilfe.

info Info

Die Vorgänge Datei exportieren, kopieren, suchen und ersetzen beziehen sich jeweils auf die aktive Sprachdatei. Aktiv bedeutet:

Beim Klicken in die Tabelle wird jeweils die Datei, in deren Spalte geklickt wurde, auf aktiv gesetzt. Der Dateiname der aktiven Datei wird im Eigenschaftenfenster angezeigt und die Spalte der Datei erhält in der Spaltenüberschrift ein Fernglas-Symbol.


Schlüsselwörter

Handbuch -> Sprachumschaltung -> Schlüsselwörter

Schlüsselwörter definieren

Schlüsselwörter werden durch das Zeichen @ gekennzeichnet.

Dabei gilt:

@Text

Der gesamte Text wird übersetzt

Text@

Der Text wird nicht übersetzt

@Text@

Der Text zwischen den @ wird übersetzt

Hier gilt: Nach einer ungeraden Anzahl von @ wird der Text übersetzt (man Beginnt am Anfang des Eintrags zu zählen).

Zum Beispiel @user@Doe

  • user wird übersetzt
  • Doe nicht

Der Text zwischen dem ersten und dem zweiten @ wird übersetzt, der zwischen dem zweiten und dritten @ nicht!

Verketten

Ein Aneinanderketten von Textelementen, die übersetzt werden, und solchen, die nicht übersetzt werden, ist möglich:

@Der Benutzer@ Doe @wird ausgeloggt.

@Text1@ Text2 @Text3

  • Text 1: wird übersetzt
  • Text 2: wird nicht übersetzt
  • Text 3: wird übersetzt

Schlüsselwörter zur Runtime anzeigen

Ist einem Schlüsselwort eine Übersetzung zugeordnet, dann werden in der Runtime die übersetzten Texte angezeigt.

Ist einem Schlüsselwort keine Übersetzung zugeordnet, wird in der Runtime kein Text angezeigt.

Noch nicht übersetzte Texte können als Schlüsselwort angezeigt werden. Dazu:

  1. navigieren Sie in den Projekteigenschaften zu Grafische Ausprägung -> Runtime allgemein

    Interne ID: Schlüsselwörter

    Runtime allgemein

    Enthält Einstellungen zur Runtime.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Schlüsselwörter

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. aktivieren Sie die Eigenschaft Nicht übersetzte Schlüsselwörter anzeigen

    Interne ID: Schlüsselwörter

    Nicht übersetzte Schlüsselwörter anzeigen

    Einstellung für die Darstellung von Schlüsselwörter, die in keiner der Sprachdateien existieren:

    Aktiv: Darstellung zur Runtime als Schlüsselwort, zum Beispiel: @Text.
    Inaktiv: Darstellung zur Runtime ohne vorangestelltes @, zum Beispiel: Text

    Hinweis: Existiert das Schlüsselwort in einer der Sprachdateien, verfügt jedoch über keine Übersetzung, wird zur Runtime kein Text angezeigt (leerer String).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. nicht übersetze Texte werden dann zur Runtime durch @Schlüsselwort dargestellt


Sprachtabelle

Handbuch -> Sprachumschaltung -> Sprachtabelle

Um eine Sprachumschaltung zu projektieren, muss im Projektmanager eine Sprachtabelle angelegt werden. Dieser Sprachtabelle liegen Text-Dateien zugrunde.

Dabei gilt:

  • Die Tabelle enthält immer eine Spalte Schlüsselwort.
  • Die Spalte ZENONSTR.TXT wird automatisch angelegt. Sie ist nicht löschbar, aber erweiterbar. Beim Starten der Runtime wird automatisch diese Datei geladen.
  • Jede Sprache erhält eine eigene Spalte in der Sprachtabelle.
  • Für jede Spalte wird eine eigene Sprachdatei angelegt. In dieser wird das Schlüsselwort mit der Übersetzung gespeichert. Schlüsselwort und Übersetzung werden durch ein Pipe-Zeichen | getrennt.
  • Wird ein Schlüsselwort in die Sprachtabelle eingetragen, dann werden automatisch alle Spalten in dieser Zeile mit dem Schlüsselwort gefüllt. Dieses Schlüsselwort wird dann durch die Übersetzung der jeweiligen Sprache ersetzt.
  • Steht keine Übersetzung zur Verfügung, wird zur Runtime das Schlüsselwort angezeigt.

Noch in diesem Kapitel

Neue Sprachdatei anlegen

Darstellung und Handhabung

Schlüsselworte in der Sprachtabelle


Neue Sprachdatei anlegen

Handbuch -> Sprachumschaltung -> Sprachtabelle -> Neue Sprachdatei anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Neue Sprachdatei anzulegen:

  1. öffnen Sie das Kontextmenü des Eintrages Sprachdatei im Projektmanager
  2. wählen Sie den Eintrag Neu.
  3. der Dialog zur Erstellung einer neuen Sprachdatei wird geöffnet

  4. vergeben Sie einen frei definierbaren Namen

    Hinweis: Sonderzeichen sind nicht erlaubt; die Dateierweiterung *.txt wird automatisch gesetzt

  5. bestätigen Sie mit Klick auf die Schaltfläche OK
  6. die neue Datei wird als als äußerst rechte Spalte in die Sprachtabelle eingefügt

Mit dem Erstellen einer neuen Sprachdatei werden im Ordner für externe Binärdateien sprachabhängige Unterordner mit dem Namen der neu angelegten Datei erzeugt für:

  • Grafiken
  • Hilfe
  • Multimedia
  • Texte und Formate
  • Report Viewer


Darstellung und Handhabung

Handbuch -> Sprachumschaltung -> Sprachtabelle -> Darstellung und Handhabung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mehrzeilige Darstellung

Schlüsseltexte und Übersetzungen können mehrzeilig dargestellt werden.

Um die Zeilenhöhe individuell zu definieren:

  1. bewegen Sie die Maus in den Zeilenkopf, links von der Spalte Schlüsselwort
  2. navigieren Sie zur Trennlinie der Zeilen bis der Mauszeiger sich in Kreuz wandelt
  3. ziehen Sie die Zeile mit gedrückter linker Maustaste auf die gewünschte Höhe

Um die Zeilenhöhe automatisch anzupassen

  1. bewegen Sie die Maus in den Zeilenkopf, links von der Spalte Schlüsselwort
  2. navigieren Sie zur Trennlinie der Zeilen bis der Mauszeiger sich in Kreuz wandelt
  3. führen Sie einen Doppelklick auf die Trennlinie aus
  4. die Zeilenhöhe wird automatisch auf den Inhalt angepasst, Texte werden entsprechend der Spaltenbreite umgebrochen

Hinweis: Die eingestellten Zeilenhöhen werden beim Verlassen der Liste nicht gespeichert.

Suchen und ersetzen

In der Sprachtabelle gibt es die Möglichkeit, nach bestimmten Texten oder Textfragmenten zu suchen. Dabei können reguläre Ausdrücke verwendet werden. Die Fundstellen können auch gleichzeitig ersetzt werden. Suchen und ersetzen gilt immer für die Spalte, in der sich der Cursor befindet.

Um zu suchen und zu ersetzen:

  1. aktivieren Sie die gewünschte Spalte
  2. führen Sie einen Rechtsklick aus
  3. wählen Sie im Kontextmenü Suchen bzw. Ersetzen.

Inkrementelle Suche

  1. Durch Drücken einer beliebigen alphanumerischen Taste in der Liste wird eine inkrementelle Suche gestartet:
  2. Die nächste Zeile der aktiven Spalte, deren Text dem Suchkriterium entspricht , wird ausgewählt.
  3. Die Suche bezieht sich immer auf das erste Zeichen der Zeile. Zum Beispiel:

    r findet die Zeile, die mit mit rot beginnt, aber die nicht die Zeile, die mit grün beginnt

Sortieren

Um die Tabelle zu sortieren:

  1. klicken Sie auf den Spaltenkopf, der Spalte, die sortiert werden soll
  2. die Spalte wird sortiert, wobei die Sortierrichtung (aufsteigend/absteigend) durch einen Pfeil über der Spaltenbeschriftung angezeigt wird
  3. erneuter Klick in den Spaltenkopf ändert Sortierrichtung

Filtern

Die Sprachtabelle kann gefiltert werden. Dazu wird der Filtertext in die Kopfzeile der zu filternden Spalte eingegeben. Alle Zeilen, die nicht dem Filterkriterium entsprechen, werden aus der Liste entfernt. Im Filtertext können Wildcards „*" (mehrere Zeichen) und „?" (einzelnes Zeichen) verwendet werden. Es können mehrere Filter kombiniert werden.

Um den Filter zurückzusetzen, löschen Sie den Filtertext aus der Kopfzeile oder benutzen Sie im Kontextmenü den Befehl Alle Filter entfernen.

Kopieren und Einfügen

Über das Kontextmenü kann mit dem Befehl Datei kopieren die aktive Datei in die Zwischenablage kopiert werden. Um eine Datei aus der Zwischenablage einzufügen, wählen Sie im Kontextmenü den Befehl Einfügen.

Beim Einfügen wird zwischen dem eigenen und einem fremden Projekt unterschieden:

  • Beim Einfügen im selben Projekt wird eine neue Datei mit dem Namen „KOPIE n VON XXX.TXT" eingefügt:
    • n = Nummer der Kopie
    • XXX = Name der kopierten Datei
  • Beim Einfügen in ein anderes Projekt, wird überprüft, ob bereits eine Sprachdatei gleichen Namens existiert.
    • Existiert bereits eine Sprachdatei gleichen Namens, erfolgt eine Abfrage, ob die Datei überschrieben werden soll.
    • Existiert die Sprachdatei noch nicht, wird sie mit dem Namen der kopierten Datei ins Projekt eingefügt.

Hinweis: Schlüsseltexte können auch mit den Tastenkombinationen Ctrl+C und Ctrl+V kopiert und eingefügt werden. Für Sprachdateien ist das nicht möglich.

Umbenennen

Der Dateiname der aktiven Datei wird im Eigenschaftenfenster als Eigenschaft Dateiname angezeigt. Hier kann der Name der Sprachdateie (Spalte) geändert werden. Beim Umbenennen einer Sprachdatei werden auch die zugehörigen sprachabhängigen Unterordner in den Binärdatei-Ordnern umbenannt (siehe auch Kapitel Neue Sprachdatei anlegen).

Interne ID: Darstellung und Handhabung

Dateiname

Name der eingebundenen Datei.
Externe Dateien, die auf diese Weise eingebunden werden, werden sowohl im Runtime-Verzeichnis als auch im Datenbank-Verzeichnis des Projektes gespeichert.
Achtung: Immer wenn neue Runtime-Dateien erzeugt werden, werden die Dateien im Runtime-Ordner mit denen des Datenbank-Ordners überschrieben. Daher sollten externe Dateien nur über das Kontextmenü der entsprechenden Datei und nicht extern geändert werden, damit die Dateien auch im Datenbank-Ordner geändert werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Sprachtabelle im Editor nutzen

Schlüsselwörter können bereits während der Projektierung im Editor übersetzt und genutzt werden. So können Sie - ohne dass dafür die Runtime gestartet werden muss - zum Beispiel überprüfen, ob Textfeldlängen für alle Sprachen ausreichend dimensioniert wurden.

Um eine Sprachdatei im Editor zu nutzen:

  1. wählen Sie im Kontextmenü den Eintrag Sprachdatei für Editor
  2. wählen Sie im Submenü die gewünschte Datei
  3. die im Editor aktive Sprachdatei in wird der Spaltenüberschrift mit grüner Schriftfarbe gekennzeichnet

Schriften

Auch Schriften sind über das Kontextmenü in der Sprachtabelle umschaltbar.

Im Globalprojekt können globale Schriftlisten angelegt werden. Die dort vorhandenen Einträge stehen in allen Projekten des Arbeitsbereiches zur Verfügung.

info Info

Wird in der Listenansicht die Schriftart nicht richtig dargestellt, muss in der Systemsteuerung die Schriftart Arial Unicode aktiviert werden.

Noch in diesem Kapitel

Suchen

Ersetzen


Suchen

Handbuch -> Sprachumschaltung -> Sprachtabelle -> Darstellung und Handhabung -> Suchen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um in der Sprachtabelle zu suchen, führen Sie einen Rechtsklick in die gewünschte Spalte aus und wählen Sie im Kontextmenü den Befehl Suchen.

Parameter

Beschreibung

Suchen nach

Eingabe des Suchbegriffs.

Nur ganzes Wort suchen
  • Aktiv: Es wird nur der im Eingabefeld festgelegte Suchbegriff gefunden.
  • Inaktiv: Es werden auch Begriffe, die den Suchbegriff enthalten, gefunden.
    Beispiel: "Text" findet auch "Textur"

Groß-/Kleinschreibung
  • Aktiv: Es wird zwischen Großschreibung und Kleinschreibung unterschieden.
    Beispiel: "Text" findet nur "Text" aber nicht "text".
  • Inaktiv: Groß-Kloeinschreibung hat keinen Einfluss auf die Suchergebnisse.

Suchrichtung

Definiert Suchrichtung.

Nach oben

Aktiv: Es wird ab er markierten Zelle nach oben gesucht.

Nach unten

Aktiv: Es wird ab er markierten Zelle nach unten gesucht.

Weitersuchen

Sucht und markiert nächste Fundstelle.

Abbrechen

Beendet Suche


Ersetzen

Handbuch -> Sprachumschaltung -> Sprachtabelle -> Darstellung und Handhabung -> Ersetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um in der Sprachtabelle zu suchen und zu ersetzen, führen Sie einen Rechtsklick in die gewünschte Spalte aus und wählen Sie im Kontextmenü den Befehl Ersetzen.

Parameter

Beschreibung

Suchen nach

Eingabe des Suchbegriffs.

Ersetzen durch

Eingabe des Begriffs, der den Suchbegriff ersetzen soll.

Nur ganzes Wort suchen
  • Aktiv: Es wird nur der im Eingabefeld festgelegte Suchbegriff gefunden.
  • Inaktiv: Es werden auch Begriffe, die den Suchbegriff enthalten, gefunden.
    Beispiel: "Text" findet auch "Textur"

Groß-/Kleinschreibung
  • Aktiv: Es wird zwischen Großschreibung und Kleinschreibung unterschieden.
    Beispiel: "Text" findet nur "Text" aber nicht "text".
  • Inaktiv: Groß-Kloeinschreibung hat keinen Einfluss auf die Suchergebnisse.

Weitersuchen

Sucht und markiert nächste Fundstelle.

Ersetzen

Der gefundene Begriff wird ersetzt.

Alle ersetzen

Alle in der aktiven Spalte gefundenen Suchbegriffe werden automatisch ersetzt.

Abbrechen

Beendet Suche


Schlüsselworte in der Sprachtabelle

Handbuch -> Sprachumschaltung -> Sprachtabelle -> Schlüsselworte in der Sprachtabelle

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schlüsselworte für sprachumschaltbaren Text werden in zenon durch das Zeichen @ gekennzeichnet. In die Sprachtabelle werden Schlüsselworte ohne den Bezeichner @ eingetragen. Vorhandene Steuerzeichen @ werden automatisch entfernt.

Beim Einfügen der Einträge in die Sprachtabelle gilt:

  • pro @ werden Pakete gebildet
  • diese müssen einzeln in die Sprachtabelle eingetragen werden.

    Beispiel: Der sprachumschaltbare Text "@Der Benutzer@ Doe @wird ausgeloggt." hat in der Sprachtabelle zwei Einträge:

    • Zeile 1: Der Benutzer
    • Zeile 2: wird ausgeloggt
  • nach einem Import enthält jede Sprachdatei zuerst nur die Schlüsselwörter, die sie auch vor dem Import hatte
  • sobald in der Sprachtabelle eine Änderung erfolgt (z.B. Eintrag eines neuen Schlüsselworts) werden alle Schlüsselwörter aller Sprachdateien abgeglichen
    • jede Sprachdatei enthält dann alle Schlüsselwörter
  • alle neu in die Tabelle eingetragenen Schlüsselwörter werden immer sofort in alle vorhandenen Sprachdateien geschrieben

attention Achtung

Der Import kann zu neuen Schlüsselwörtern führen, für die dann in den bereits vorhandenen Sprachdateien keine Übersetzungen existieren. In diesem Fall werden zur Runtime die Schlüsselwörter angezeigt.

Neue Schlüssel einfügen

Neue Schlüssel werden in der letzten (leeren) Zeile eingegeben. Beim Eingeben eines neuen Schlüsseltextes werden alle Übersetzungen der Zeile mit dem neuen Schlüsseltext belegt.

Wird die Taste Einfg gedrückt, dann wird:

  1. unabhängig von der Position des Cursors in der Liste die letzte Zeile ausgewählt
  2. die Zelle für das Schlüsselwort zur Bearbeitung geöffnet

Schlüssel und Übersetzungen bearbeiten

Das Bearbeiten von Zellen in der Liste erfolgt durch Klicken auf eine Zelle in einer selektierten Zeile. Wird die Taste F2 gedrückt, wird in der aktiven Spalte die Zeile mit dem Fokus editiert.

Schlüssel und Übersetzungen löschen

Es können einzelne Übersetzungen oder ganze Schlüssel mit allen Übersetzungen geköscht werden.

Um ein Schlüsselwort mit allen Übersetzungen zu löschen:zu löschen:

  1. wählen Sie die Zeile aus
  2. drücken Sie die Taste Entf oder wählen Sie im Kontextmenü Schlüssel löschen
  3. das Schlüsselwort wird mit allen Übersetzungen ohne Sicherheitsabfrage gelöscht.
  4. es können mehrere Zeilen gleichzeitig ausgewählt und gelöscht werden (Taste Strg+Mausklick; Umschalttaste+Mausklick)

Um Übersetzungen zu löschen:

  1. wählen Sie die Zeile aus
  2. die Spalte Schlüsselwort darf nicht aktiv sein
  3. halten Sie die Umschalttaste und drücken Sie die Taste Entf
  4. die Übersetzung der aktiven Spalte wird gelöscht

Kopieren und Einfügen

Um Schlüsselworte zu kopieren:

  1. markieren Sie die gewünschten Zeilen (Mehrfachauswahl ist möglich)
  2. drücken Sie die Tastenkombination Strg+C oder wählen Sie im Kontextmenü Schlüssel kopieren
  3. die Schlüsselworte werden in die Zwischenablage kopiert

Um Schlüsselworte einzufügen:

  1. klicken Sie in die Sprachtabelle
  2. drücken Sie die Tastenkombination Strg+V oder wählen Sie im Kontextmenü Einfügen
  3. die Schlüsselworte und Übewrsetzungen werden aus der Zwischenablage in die Liste übernommen
  4. existiert ein kopierter Schlüssel bereits in der Liste, wird ein neuer Schlüssel Kopie n von XXX angelegt
    • n = Nummer der Kopie
    • XXX = Name des kopierten Schlüssels


Sprachdatei extern bearbeiten

Handbuch -> Sprachumschaltung -> Sprachdatei extern bearbeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sprachdateien können auch extern bearbeitet werden. Dazu müssen Sie exportiert werden. Der Export kann erfolgen als:

  • TXT-Datei: Bearbeitung mit Texteditor
  • CSV-Datei: Bearbeitung mit Microsoft Excel

Um eine Sprachdatei zu bearbeiten:

  1. exportieren Sie die gewünschte Datei
  2. führen Sie die Änderungen durch, je nach Exportart mit
    • Texteditor oder
    • Microsoft Excel
  3. importieren Sie die Datei wieder in den Editor

attention Achtung

Beachten Sie bei externen Änderungen:

  • Beim Import wird die neue Datei nicht einfach überschrieben, sondern mit der aktuell im Projekt vorhandenen zusammengeführt. Details siehe: Sprachdatei exportieren und importieren
  • Änderungen betreffen immer nur das Schlüsselwort und die gewählte Sprache. Alle anderen Sprachen bleiben unverändert bzw. leer.

Noch in diesem Kapitel

Sprachdatei exportieren und importieren

Bearbeitung in Textdatei

Bearbeitung in MS Excel


Sprachdatei exportieren und importieren

Handbuch -> Sprachumschaltung -> Sprachdatei extern bearbeiten -> Sprachdatei exportieren und importieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Export

Um eine Sprachdatei zu exportieren:

  1. klicken Sie in die gewünschte Spalte (für TXT-Export)
  2. öffnen Sie mit einem Rechtsklick das Kontextmenü
  3. wählen Sie die gewünschte Exportart:
    • Datei exportieren: exportiert die Tabelle in das Format TXT
      Eignet sich vor allem für Weitergabe an andere Benutzer und den Import in andere Projekte. Betrifft immer nur die gewählte Sprachdatei.
    • Erweiterter Import/Export -> CSV exportieren alle: exportiert alle vorhandenen Tabellen in das Format CSV
      Eignet sich vor allem zum externen Bearbeiten. Betrifft immer alle Sprachdateien einer Sprachtabelle.
  4. der Dialog zur Auswahl des Speicherorts und Dateinamens wird geöffnet
  5. speichern Sie die Exportdatei
  6. eine Meldung informiert über erfolgreichen Export und bietet an, den Export-Ordner zu öffnen
    • Klick auf Schaltfläche Ja öffnet Export-Ordner und schließt Dialog
    • Klick auf Schaltfläche Nein schließt Dialog

Import

Um eine Sprachdatei zu importieren:

  1. klicken Sie in die Sprachtabelle
  2. öffnen Sie mit einem Rechtsklick das Kontextmenü
  3. wählen Sie die gewünschte Importart:
    • Datei importieren: importiert eine Datei im Format TXT
    • Erweiterter Import/Export -> CSV importieren: importiert eine Datei im Format CSV
  4. der Dialog zur Auswahl der Datei wird geöffnet
  5. Klick auf OK importiert Datei

attention Achtung

Der Import kann zu neuen Schlüsselwörtern führen, für die dann in den bereits vorhandenen Sprachdateien keine Übersetzungen existieren. In diesem Fall werden zur Runtime die Schlüsselwörter angezeigt.

Import von TXT

Textdateien müssen für den Import dem Format der Sprachtabelle entsprechen: Schlüsseltext + | + Übersetzung

Beim Import wird die neue Datei nicht einfach überschrieben, sondern mit der aktuell im Projekt vorhandenen zusammengeführt:

  • Einträge, die in der Importdatei und in der des Projekts vorkommen, werden mit den importierten Einträgen überschrieben.
  • Einträge, die nur im Projekt vorkommen, werden nicht geändert.
  • Einträge, die nur in der importierten Datei vorkommen, werden neu eingefügt.
  • Existiert eine Sprachdatei der Importdatei im Projekt noch nicht, wird eine neue Datei mit dem neuen Namen angelegt.

Import von CSV

CSV-Dateien müssen für den Import dem Format der Sprachtabelle entsprechen.

  • Es müssen zulässige Spaltentrennzeichen verwendet werden:
    • Pipe (|)
    • Semikolon (;)
    • TAB (->)

    Werden andere Zeichen als Spaltentrenner verwendet, erfolgt eine Fehlermeldung .

  • Die erste Zeile muss eine Liste der Dateien enthalten, wobei als erstes ein Platzhalter für die Spalte Schlüsseltext stehen muss.
  • Die Dateien muss die Endung .csv besitzen. Ist das nicht der Fall, erfolgt eine Fehlermeldung .
  • In den weiteren Zeilen stehen der jeweilige Schlüsseltext und die durch den Spaltentrenner getrennten Übersetzungstexte. Der Schlüsseltext muss immer in der ersten Spalte stehen.
  • Existiert eine in einer Spaltenüberschrift angegebene Sprachdatei noch nicht, wird eine neue Datei mit dem angegebenen Namen angelegt.
  • Vorhandene Dateien werden analog zum Import aus einer Textdatei zusammengeführt.

Example Beispiel

Aufbau CSV-Datei :

Schlüsselwort|ZENONSTR.TXT|FRENCH.TXT|ENGLISH.TXT|GERMAN.TXT

A1004|A1004|F1004|E1004|D1004

A14|A14|F14|E14|D14

A25|A25|F25|E25|D25


Bearbeitung in Textdatei

Handbuch -> Sprachumschaltung -> Sprachdatei extern bearbeiten -> Bearbeitung in Textdatei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bearbeitung in einer Textdatei

Für Sprachdateien gilt:

  • Die Inhalte werden als Text in chronologischer Reihenfolge eingetragen.
  • Das Trennzeichen zwischen Schlüsselwort und übersetztem Begriff ist ein | (Pipe).
  • Übersetzt wird nur der Begriff nach dem Pipe-Zeichen.

Example Beispiel

|

eins|one

zwei|two

drei|three


Bearbeitung in MS Excel

Handbuch -> Sprachumschaltung -> Sprachdatei extern bearbeiten -> Bearbeitung in MS Excel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Bearbeitung in MS Excel ist ebenfalls möglich. Um eine Sprachdatei in MS Excel zu bearbeiten:

  1. exportieren Sie die Sprachtabelle in eine CSV-Datei mit der Endung .csv
  2. öffnen Sie Datei mit MS Excel (Doppelklick auf Datei)
  3. die Exportdatei wird automatisch in Excel importiert
  4. die Daten werden wie folgt angezeigt:
    • Spalte A: Schlüsselwort
    • weiter Spalten: Übersetzungen; je Spalte eien Übersetzung
    • es wird kein Trennzeichen angezeigt
  5. bearbeiten Sie die Texte wie gewünscht
  6. speichern Sie die Datei wieder als CSV-Datei.

Um die geänderten Sprachdateien in zenon zu verwenden, importieren Sie die CSV-Datei nach zenon.


Fonts - Schriftarten

Handbuch -> Sprachumschaltung -> Fonts - Schriftarten

Im Zuge der Sprachumschaltung kann es nötig sein, verschiedene Schriftarten zu verwenden, zum Beispiel eine Unicode-Schrift für ostasiatische Zeichen.

Definition über Schriftlisten

Schriften und Schriftlisten definieren Sie im Knoten Bilder/Schriften. Die hier angelegten Schriftlisten können in der Funktion Sprachumschaltung ausgewählt werden.

Hinweis: Details zu Schriften und Listen finden Sie im Kapitel Schriften im Handbuch Bilder.

Sprachdatei Schriftart direkt zuweisen

Schriftarten können der Sprachdatei auch direkt zugewiesen werden. Dies definiert aber nur die optische Darstellung in der Sprachdatei. Die Darstellung der übersetzten Texte im Editor und zur Runtime ist davon nicht betroffen; diese wird über Schriftlisten festgelegt.

Um der Sprachdatei eine Schriftart direkt zuzuweisen:

  1. selektieren Sie eine Spalte der Sprachdatei
  2. wählen Sie im Kontextmenü Schrift für selektierte Sprachdatei/Auswahl
  3. der Windows Standarddialog für die Auswahl einer Schrift wird geöffnet
  4. wählen Sie die gewünschte Schrift

    Hinweis: weitere Einstellungen des Standarddialogs wie Schriftfarbe haben hier keine Auswirkung auf die Darstellung in zenon

info Info

Schriftarten und Sprachdateien können bereits im Editor verwendet und angezeigt werden. Wählen Sie dazu im Kontextmenü:

  • der Sprachdatei: Sprachdatei für Editor -> gewünschte Datei auswählen
  • der Schriftliste: Schriftliste für selektierte Sprachdatei -> gewünschte Liste auswählen

attention Achtung

Beim Vektorelement Statischer Text können Schriften auch eingebettet werden. Diese sind über die Sprachdatei nicht änderbar.


Vordefinierte Schlüsselwörter - Systemtexte in CEL

Handbuch -> Sprachumschaltung -> Vordefinierte Schlüsselwörter - Systemtexte in CEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für alle Texte, die standardmäßig in der Runtime angezeigt werden, gibt es vordefinierte Schlüsselwörter.

Vordefinierte Schlüsselwörter finden Sie in der Datei CEL_Keys.txt im Ordner [zenon Installation]\Wizards_NotSupported\Additional

Empfehlung: Benutzen Sie für Projektierung den Language table Wizard.

Achtung: Eventuelle Änderungen werden bei einem zenon Update wieder überschrieben. Wir empfehlen, die geänderte Datei zu speichern und nach dem Update wieder in die neue Version zu kopieren.

Damit die Sprachumschaltung bei den Dialogen bzw. den vordefinierten Schlüsselwörtern für die CEL funktionieren, muss die Runtime-Sprache in Englisch eingestellt sein, da die Schlüsselwörter auf Englisch definiert sind.

Texte, die in den Spaltenüberschriften der Chronologische Ereignisliste sowie der Alarm Verwaltung verwendet werden, können über die Projekteigenschaften konfiguriert werden. Der Dialog wird aufgerufen über: Chronologische Ereignisliste -> Spalteneinstellung CEL bzw. Alarmmeldeliste -> Spalteneinstellung AML oder in der jeweiligen Funktion Bildumschaltung.

Interne ID: Vordefinierte Schlüsselwörter - Systemtexte in CEL

Bildumschaltung

Diese Funktion öffnet ein ausgewähltes Bild. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch

Interne ID: Vordefinierte Schlüsselwörter - Systemtexte in CEL

Spalteneinstellung AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

Interne ID: Vordefinierte Schlüsselwörter - Systemtexte in CEL

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Vordefinierte Schlüsselwörter - Systemtexte in CEL

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Vordefinierte Schlüsselwörter - Systemtexte in CEL

Spalteneinstellung CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

Interne ID: Vordefinierte Schlüsselwörter - Systemtexte in CEL

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Vordefinierte Schlüsselwörter - Systemtexte in CEL

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Vorgehensweise entspricht der bei Texten. Das @ zu Beginn der Meldung ermöglicht die Sprachumschaltung.


Pfade für Sprachumschaltung der Runtime-Hilfe

Handbuch -> Sprachumschaltung -> Pfade für Sprachumschaltung der Runtime-Hilfe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die zur Sprachumschaltung nötigen Dateien werden beim Erstellen einer Sprachdatei die nötigen Einträge automatisch in den Unterordnern zu Dateien angelegt:

  • Grafiken
  • Hilfe
  • Multimedia
  • Texte und Formate
  • Report Viewer

Bei der Konfiguration der Funktion Sprachumschaltung kann der entsprechende Ordner ausgewählt werden:

attention Achtung

Die Dateien müssen in den unterschiedlichen Sprachen denselben Namen haben und in verschiedenen Ordnern abgelegt sein.

Ein Default-Pfad ist im Editor bereits vorgegeben. Beim Ausführen der Funktion Sprachumschaltung wird der Pfad geändert. Es besteht die Möglichkeit, individuelle Ordner im Projektbaum unterhalb des Knotens Datei anzulegen.

info Info

Es ist möglich im Knoten Datei mehrere Ebenen von Unterordner zu erstellen. In der Funktion Sprachumschaltung können aber nur Ordner ausgewählt werden, die sich in der ersten Ebene befinden.

Wird die Sprachumschaltung nicht ausgeführt, gelten als Defaultpfade die Standardordner.

attention Achtung

In der Regel ist Sprachumschaltung zur Runtime mit der HTML-Hilfe von Microsoft Betriebssystemen nicht möglich. Sprachumschaltbare Hilfe muss über ein HTML-Bild projektiert werden.

Ausnahme: Hilfe unter Windows CE.


Auslagerung von Übersetzungen

Handbuch -> Sprachumschaltung -> Auslagerung von Übersetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Texte zur Übersetzung auszulagern:

exportieren Sie die Sprachtabelle nach CSV

lassen Sie die Texte übersetzen

importieren Sie die geändert CSV-Datei

beachten Sie, dass bei Verteiltem Engineering für die Sprachdateien Änderungen ermöglichen aktiviert sein muss, um sie bearbeiten zu können

attention Achtung

In Mehrbenutzerprojekten können Schlüsseltexte und deren Übersetzungen nur geändert werden, wenn für die Dateien Änderungen ermöglicht sind. Übersetzungstexte von Dateien, für die Änderungen nicht ermöglicht sind, können nicht selektiert und editiert werden.

Schlüsseltexte können nur geändert werden, wenn für alle Dateien Änderungen ermöglicht sind. Beim Einfügen neuer Schlüssel werden die Schlüssel nur in Dateien, für die Änderungen ermöglicht sind, eingetragen.


Funktion Sprachumschaltung

Handbuch -> Sprachumschaltung -> Funktion Sprachumschaltung

Mit dieser Funktion können zur Runtime Textinformationen mehrsprachig zur Verfügung gestellt werden, zum Beispiel für Buttons, auf eine andere Sprache umgeschaltet werden. Beim Anlegen einer neuen Sprachdatei wird automatisch ein sprachabhängiger Unterordner in den jeweiligen Ordnern für Grafik, Hilfe, Multimedia, Texte und Formate sowie Report Viewer angelegt. Dieser erhält den gleichen Namen wie die neue Sprachdatei. Die entsprechenden Dateien werden in diesem Ordner abgelegt. Der aktive Unterordner kann mit der Funktion Sprachumschaltung umgeschaltet werden. Ist im Unterordner keine Datei mit dem angegebenen Namen vorhanden, wird versucht, die Datei aus dem übergeordneten sprachunabhängigen Ordner zu laden.

Interne ID: Funktion Sprachumschaltung

Sprachumschaltung

Diese Funktion schaltet in mehrsprachigen Projekten auf eine ausgewählte Sprache um.

Mehr im Online-Handbuch

Um die Funktion zu projektieren:

  1. wählen Sie Funktion neu...
  2. navigieren Sie zum Knoten Anwendung

    Interne ID: Funktion Sprachumschaltung

    Anwendung

    Diese Gruppe beinhaltet Funktionen für den Umgang mit Projekt-Einstellungen.

    Mehr im Online-Handbuch

  3. wählen Sie Sprachumschaltung
  4. konfigurieren Sie im sich öffnenden Dialog die Sprachumschaltung

Parameter | Beschreibung
Sprachdatei | Öffnet den Dateimanager zur Auswahl einer Sprachdatei.
Schriftliste | Dropdownliste mit Liste der im Editor definierten Schriften.
Ordnerumschaltung | Enthält Pfade für benötigte Dateien.
Grafiken | Dropdownliste mit sprachabhängigen Unterordnern für Grafiken.
Hilfe | Dropdownliste mit sprachabhängigen Unterordnern für CHM-Dateien der Runtime- Hilfe.
Multimedia | Dropdownliste mit sprachabhängigen Unterordnern für Multimediadateien.
Texte und Formate | Dropdownliste mit sprachabhängigen Unterordnern für Texte und Formate
Report Definitionsdateien | Dropdownliste mit sprachabhängigen Unterordnern für Report Viewer
OK | Übernimmt Konfiguration, erstellt Funktion und schließt Dialog.
Abbrechen | Verwirft Einstellungen, schließt Dialog und erstellt Funktion ohne Ziel.
Hilfe | Öffnet Online-Hilfe.


Startup Tool

Handbuch -> Startup Tool

Das Startup Tool ermöglicht es:

  • Editor und Runtime mit bestimmten Parametern zu starten
  • unterschiedliche zenon Versionen parallel auf einem Rechner zu betreiben
    (bereits installierte zenon Versionen werden bei der Installation automatisch im Startup Tool angelegt)
  • unterschiedliche SQL-Instanzen für die gleiche zenon Version verwalten
  • Einstellungen unterschiedlicher Versionen zu verwalten
  • die Sprache des Editors und der Runtime vor dem Start zu definieren

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

attention Achtung

Das Startup Tool startet nur, wenn der Dienst zenAdminSrv läuft. Falls dieser nicht aktiv ist, kann er in der Windows Systemsteuerung unter Verwaltung/Dienste manuell gestartet werden.

Noch in diesem Kapitel

Startdialog

Properties

Meldungen beim Registrieren

Kommandozeile


Startdialog

Handbuch -> Startup Tool -> Startdialog

Im Startdialog verwalten Sie die aktuell installierten Versionen von zenon.

Schaltfläche | Funktion
Editor | startet den Editor der ausgewählten zenon Version
Runtime | startet die Runtime der ausgewählten zenon Version
Register | registriert alle Dienste der ausgewählten zenon Version
Help | öffnet die zenon Hilfe
Tools | öffnet einen Dialog zum Starten weiterer Applikationen der ausgewählten zenon Version

Vorgänge beim Starten

Beim Starten des Editors bzw. der Runtime werden die Daten aus den Starteinstellungen in die zenon6.ini Datei geschrieben. In der ini-Datei vorhandene Einstellungen werden überschrieben.

Ab Version 5 wird die Netzwerkkommunikation über die beiden Dienste zenNetSrv.exe und zenSysSrv.exe abgewickelt. Beide Dateien müssen sich im zenon Verzeichnis befinden. Da die Dienste versionsabhängig sind, müssen sie auch passend zu den Versionen registriert werden.

attention Achtung

Nach dem Konvertieren eines Projektes in eine höhere zenon Version ist dieses mit der Vorgängerversion nicht mehr editierbar bzw. lauffähig. Bei Netzwerkprojekten müssen auf Server und Clients die gleichen zenon Versionen gestartet werden.

Noch in diesem Kapitel

Application

Item

Help


Application

Handbuch -> Startup Tool -> Startdialog -> Application

Eintrag | Funktion
Options | Öffnet den Dialog zur Konfiguration der Einstellungen.
Exit | Beendet das Startup Tool.

Options

Der Eintrag Options im Menü Application öffnet die Einstellungen für das Startup Tool:

  • General: allgemeine Einstellungen
  • Encrypt network communication: Konfiguration der starken Verschlüsselung der Netzwerkkommunikation

Noch in diesem Kapitel

General

Network configuration


General

Handbuch -> Startup Tool -> Startdialog -> Application -> General

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Allgemeine Einstellungen:

Parameter

aktiv

inaktiv

Start Startup Tool mimimized

Startet das Tool minimiert. Das Tool ist über eine Schaltfläche in der Taskleiste erreichbar.

Das Kontextmenü bietet für die aktive zenon Version alle im Startdialog möglichen Aktionen an.

Öffnet das Tool auf dem Desktop (default).

Remember last registered version

Setzt die gewählte Version auf Standard und wählt sie beim nächsten Start automatisch aus. Die Version wird dann nicht erneut registriert (default).

Bietet beim Start des Startup Tools die erste Version in der Liste zur Auswahl an. Beim Start des Editors oder der Runtime wird die jeweilige Version immer neu registriert.

Register all OCX files of selected version

registriert alle OCX Dateien (ActiveX Controls), die sich im Programmverzeichnis befinden.

Diese Option stellt sicher, dass immer die zur Version passenden ActiveX Controls registriert werden (default).

Achtung: Sie hat keinen Einfluss auf die Registrierung von ActiveX Controls und COM Servern, die in den individuellen Einstellungen der jeweiligen Version angegeben werden.

registriert nur die voreingestellten Komponenten.

Diese Option beschleunigt den Registrierungsvorgang und eigent sich für alle Projekte, die auf Actice X verzichten.

Set Language for Editor or Runtime

Startet Editor oder Runtime mit der in der Auswahlliste selektierten Spracher.

Stellt sicher, dass zenon aus dem Startup Tool immer mit der definiertenSprache gestartet wird. Hat keinen Einfluss beim direkten Start der zenon.exe.

Startet Editor oder Runtime mit der in der zenon6.ini eingestellten Sprache. Das ist die zuletzt in zenon benutze oder dort unter Optionen -> Einstellungen -> Editor und Runtime ausgewählte Sprache eingestellte Sprache (default).


Network configuration

Handbuch -> Startup Tool -> Startdialog -> Application -> Network configuration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab zenon Version 7 kann:

  • IPv6 verwendet werden
  • die Übertragung im Netzwerk verschlüsselt werden.

Diese Dialog konfiguriert:

  • Timeouts
  • die Verwendung von TCP/IP über IPv4 oder IPv6
  • die starke Verschlüsselung der Netzwerkkommunikation am lokalen Rechner

Parameter

Beschreibung

General settings

Allgemeine Einstellungen.

Änderungen dieser Einstellungen werden mit der Registrierung in die zenon6.ini bzw. zenon.ini geschrieben und überschreiben dort eventuell abweichende manuelle Konfigurationen.

Geänderte Einstellungen müssen für alle Runtime-Rechner bzw. alle verbundenen Stationen durchgeführt werden. Bei Änderungen der IPv6 Einstellung muss der Rechner neu gestartet werden.

Änderungen werden beim Verlassen des Dialogs erst nach Bestätigung einer Warnmeldung mit Klick auf die Schaltfläche Ja durchgeführt.

Network communication timeout

Timeout für Netzwerkkommunikation in Sekunden.
Default = 30

Entspricht Eintrag NET_TIMEOUT_MSEC= in der zenon6.ini.

Network module timeout

Timeout für Modulkommunikation in Sekunden.
Default = 30

Entspricht Eintrag NET_NETMODULE_TIMEOUT_MSEC= in der zenon6.ini.

Time synchronisation with server project

Aktiv: Zeit wird mit einem Serverprojekt abgeglichen (default).

Inaktiv: Zeit wird nicht abgeglichen (z.B für Kreisredundanz)

Entspricht Eintrag TIMESYNCH in der zenon6.ini.

Use IPv6 for all TCP/IP connections

Aktiv: Alle TCP-Verbindungen werden ausschließlich über IPv6 aufgebaut.

Inaktiv: Alle TCP-Verbindungen werden ausschließlich über IPv4 aufgebaut.

Dualer Betrieb ist nicht möglich.

Entspricht Eintrag USEIPV6= in der zenon6.ini.

Hinweis: Wird diese Option geändert, muss der Rechner neu gestartet werden. Die Änderung muss auch auf allen verbundenen Stationen durchgeführt werden.

Folgende Komponenten sind von der Einstellung nicht betroffen:

  • Treiberkommunikation mit den Steuerungen
  • Protokollkommunikation in den ProcessGateway-Plugins
  • Workbench- und Runtimekommunikation in zenon Logic

Achtung: Funktioniert nur ab Version 7. Bei aktiver Option können keine Versionen vor 7 gestartet werden.

Encrypt network communication

Einstellungen für starke Verschlüsselung im Netzwerk.

Encrypt network communication

Aktiv: Die Kommunikation im Netzwerk wird verschlüsselt.

Password

Passwort eintragen.

Kriterien siehe Abschnitt "Passwort Netzwerkverschlüsselung" im Kapitel Starke Verschlüsselung der Netzwerkkommunikation.

Die angezeigte Länge wird immer auf 20 Zeichen gesetzt, um die tatsächliche Länge zu verbergen.

Das hier konfigurierte Passwort wird verschlüsselt in der zenon6.ini abgelegt.

Verify password

Passwort zur Bestätigung erneut eingeben.

attention Achtung

Wurden in der lokalen zenon6.ini Einträge manuell geändert, werden diese überschrieben, sobald beim Registrieren die Sicherheitsabfrage mit „Ja" bestätigt wird.

Meldungen

Erklärungen zu System- und Fehlermeldungen finden Sie im Abschnitt Meldungen beim Registrieren.

info Info

Hinweise zu Fehlermeldungen der starken Verschlüsselung finden Sie im:

Handbuch Netzwerk -> Kapitel Starke Verschlüsselung der Netzwerkkommunikation -> Abschnitt Fehlermeldungen.


Item

Handbuch -> Startup Tool -> Startdialog -> Item

Das Menü Item beinhaltet die folgenden Einträge:

Eintrag | Funktion
New | Legt einen neuen Eintrag in der Liste an und öffnet den Dialog Properties.
Delete | Löscht den ausgewählten Eintrag nach Bestätigung einer Sicherheitsabfrage.
Properties | Öffnet den Dialog Properties für den ausgewählten Eintrag.


Help

Handbuch -> Startup Tool -> Startdialog -> Help

Im Menü Help befinden sich die Einträge:

  • Help: öffnet die Online-Hilfe
  • Info about: zeigt Versionsinformationen an.


Properties

Handbuch -> Startup Tool -> Properties

Im Dialog Properties werden die Parameter jedes Eintrags definiert:

Eintrag | Funktion
General | Allgemeine Einstellungen
Database | Einstellungen zur Datenbankverbindung
Extras | Einstellungen zur Registrierung von ActiveX Controls (ocx) und COM Server (dll) sowie zum Start zusätzlicher Programme oder Batch-Dateien.

Noch in diesem Kapitel

General

Database

Extras


General

Handbuch -> Startup Tool -> Properties -> General

In diesem Abschnitt werden die Details zu den zenon Versionen eingetragen.

Die folgenden Eigenschaften stehen für einen Eintrag zur Verfügung:

General

Parameter | Beschreibung
Name | Eindeutiger Name, wie er in der Liste angezeigt werden soll. Der Eintrag ist unbedingt erforderlich.
Version | Startup Tool trägt hier automatisch die Versionsnummer von zenon ein. Dazu muss zuvor unter Path ein Programmpfad ausgewählt werden.
Programm path | Programmpfad, in dem zenon installiert wurde.

Editor

Parameter

Beschreibung

Workspace

Der gewünschte Arbeitsbereich beim Start des Editors. Sobald dieser eingetragen ist, werden alle in diesem Arbeitsbreich befindlichen Projekte automatisch in der Drop-down Liste unter Editor-Projekt angezeigt.

Editor-Project

Auswahl des Projekts, das nach dem Start im Editor aktiv sein soll.

Read back the INI settings

Aktiv: Alle geänderten Einstellungen werden nach dem Schließen des Editors selbstständig eingelesen und beim nächsten Start verwendet. Betroffen sind Workspace, Editor-Project, RT-Project und RT-Path.

Inaktiv: Beim Start des Editors werden immer die Einstellungen dieses Dialoges verwendet. Änderungen während der Arbeit mit dem Editor werden verworfen.

Runtime

Parameter | Beschreibung
RT-Project | Projekt, das als Startprojekt für die Runtime gesetzt wird.
RT-Path | Pfad des Projektes. Ist das Runtime-Projekt im Arbeitsbereich enthalten, wird der Pfad automatisch eingestellt.

info Info

Unbekannte Parameter?

Falls die Einstellungen für den Arbeitsbereichs nicht bekannt sind, nutzen Sie folgende Vorgehensweise:

  1. Name, Path und Workspace eintragen
  2. Editor-Project, RT-Project und RT-Path frei lassen
  3. Read back the INI settings aktivieren
  4. Dialog mit OK verlassen.

Nachdem der Editor einmal gestartet und wieder beendet wurde, werden die Starteinstellung automatisch aus der INI Datei übernommen.


Database

Handbuch -> Startup Tool -> Properties -> Database

Hier definieren Sie die Datenbank-Eigenschaften. Diese erlauben es, verschiedene SQL-Instanzen für verschiedene Einträge (zenon Versionen) zu verwenden.

attention Achtung

Ab Version 6.51 kann die SQL-Instanz definiert werden und das Passwort wird verschlüsselt abgelegt. Neue Einträge sind höherprior als bestehende.

Kompatibilität: Wird nichts geändert, bleiben die bestehenden Einträge weiterhin gültig. Wird jedoch für eine Version ab 6.51 ein Eintrag geändert, gelten die neuen Einträge. Ältere Versionen müssen dann extra gewartet werden! Die Einstellungen für Versionen vor 6.51 finden Sie im Kapitel Database vor Version 6.51.

Anzeige Dialog: Die Anzeige der Dialoge wird automatisch an die gewählte Version (vor 6.51, ab 6.51) angepasst.

Eintrag

Funktion

Read from zenDB.ini

Ein Klick auf die Schaltfläche liest die Einstellungen der Datei zenDB.ini aus und befüllt automatisch die Felder SQL Instance, DB Path, User und Password.

Clear all fields

Alle Eingabefelder werden geleert.

Leere Einträge werden beim Registrieren nicht in die zenDB.ini geschrieben.

SQL Instance

Auswahl der zu verwendenden Instanz des SQL Servers.

Der Name kann direkt in das Eingabefeld geschrieben oder aus der Dropdownliste ausgewählt werden.
Hinweis: Beim Klick auf die Dropdownliste wird der lokale Rechner nach Instanzen durchsucht, die dann aufgelistet werden. Die Suche kann einige Zeit in Anspruch nehmen.

DB Path

Pfad für die SQL-Datenbanken der zenon Projekte.
Zum Beispiel: C:\ProgramData\COPA-DATA\SQL\

Achtung: Der SQL Server 2005 und der SQL Server 2008 R2 müssen unbedingt getrennte Pfade verwenden.

Hintergrund: Beim Konvertieren der Projekte bleibt die GUID gleich. Bei gleichen Pfaden überschreiben die beiden Instanzen gegenseitig ihre Datenbankdateien!

User

Benutzername für die Datenbank.

Nötige Rechte

Der Benutzer muss im SQL Server über folgende Server roles verfügen:

  • public
  • sysadmin

Password

Passwort des Benutzers. Dieses wird verschlüsselt abgelegt. Die Eingabelänge wird unabhängig von der tatsächlcihen Länge immer mit 20 Zeichen angezeigt.

Achtung: Die Verschlüsselung erfolgt über das Startup Tool. Die Datenbankeinstellung muss also unbedingt mit dem Startup Tool erfolgen.

Noch in diesem Kapitel

Database vor Version 6.51


Database vor Version 6.51

Handbuch -> Startup Tool -> Properties -> Database -> Database vor Version 6.51

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellung der Datenbankeigenschaften vor zenon 6.51:

Eintrag

Funktion

Read from zenDB.ini

Ein Klick auf die Schaltfläche liest die Einstellungen der Datei zenDB.ini aus und befüllt automatisch die Felder Provider und DB Path.

Clear all fields

Alle Eingabefelder werden geleert.

Leere Einträge werden beim Registrieren nicht in die zenDB.ini geschrieben.

Provider

Verbindung zur SQL-Instanz. Wichtige Angaben sind:

  • Instanzenname
  • verwendeter Provider
  • Benutzername
  • Benutzerpasswort

Zum Beispiel:
Provider=SQLNCLI.1;
Password=srv_000;
Persist Security Info=False;
User ID=zenOnSrv;
Initial Catalog=%s;
Data Source=localhost\ZENON_DEV;

DB Path

Pfad für die SQL-Datenbanken der zenon Projekte.
Zum Beispiel: C:\ProgramData\COPA-DATA\SQL\

Achtung: Der SQL Server 2005 und der SQL Server 2008 R2 müssen unbedingt getrennte Pfade verwenden.

Hintergrund: Beim Konvertieren der Projekte bleibt die GUID gleich. Bei gleichen Pfaden überschreiben die beiden Instanzen gegenseitig ihre Datenbankdateien!

attention Achtung

Der Eintrag für Provider unterscheidet sich in diesem Dialog vom Eintrag in der zenDB.ini.

Dialog: String beginnt mit Provider=...

zenDB.ini: String beginnt mit Provider=Provider=...


Extras

Handbuch -> Startup Tool -> Properties -> Extras

Hier definieren Sie ActiveX Controls (*.ocx) oder COM Server (*.dll), die mit der jeweiligen zenon Version registriert werden sollen. Diese ocx und dll können aus beliebigen Quellen stammen, also selbst geschrieben sein oder von anderen Anbietern kommen. Außerdem können Sie hier Programm definieren, die vor dem Start oder nach dem Beenden des Editors oder der Runtime ausgeführt werden sollen.

Registrierung ActiveX Controls - COM Server

Alle hier aufgelisteten Dateien werden beim Registrieren der dazugehörigen zenon Version automatisch mitregistriert - unabhängig von der zentralen Einstellung Register.

Parameter | Beschreibung
Filename/Filepath | Liste aller zu registrierenden Dateien
Add | öffnet den Windows Dialog zum Auswählen einer zu registrierenden Datei. In diesem können Sie ocx bzw. dll Dateien einzeln auswählen und der Liste hinzufügen. Wählen Sie dazu im Auswahldialog zuerst den gesuchten Dateityp (ocx oder dll). Alle Dateien werden mit Pfadangabe gespeichert. Wenn sich der Pfad ändert, entfernen Sie den Verweis mit Remove und legen dann einen neuen an.
Remove | Entfernt alle markierten Einträge aus der Auswahlliste der zu registrierenden Dateien.

Pre und Post Start Programme

Pre Start und Post Start erlaubt Ihnen, Programme und Batchdateien) zu definieren, die vor dem Start oder nach dem Beenden von zenon ausgeführt werden sollen.

Parameter | Beschreibung
Pre Start | Externes Programm, das vor dem Start des Editors oder der Runtime gestartet werden soll.
Post Start | Externes Programm, das nach dem Beenden des Editors oder der Runtime gestartet werden soll. Achtung: Post Start wird nur aufgerufen, wenn die Option Read back the INI settings (Item->Properties->General) aktiviert wurde.


Meldungen beim Registrieren

Handbuch -> Startup Tool -> Meldungen beim Registrieren

Popup beim Registrieren

Meldung

Bedeutung

You have changed the IPv6 setting. All internal TCP/IP connections will be switched to IPv6/IPv4.

To ensure that all affected components are properly switched you have to restart the computer! You will also have to change this setting on all connected station!

Do you really want to apply the change?

Sie ändern die Einstellungen für das IP-Protokoll von IPv4 auf IPv6 oder umgekehrt.

Sie müssen nach dem Ändern den Rechner neu starten, damit alle Services entsprechend angepasst werden. Die Alle Änderung muss auch auf allen verbundenen Stationen durchgeführt werden.

Diese Änderungen werden mit der Registrierung in die zenon6.ini bzw. zenon.ini geschrieben und überschreiben dort eventuell abweichende manuelle Konfigurationen.

Gerneral network configuration settings will be changed.

You have to restart the runtime to apply the changes!

Attention: Do not forget to adept the settings on other stations as well.

Apply settings.

Are you sure this is your intent?

Sie ändern generelle Einstellungen wie Timeouts.

Diese Änderungen werden mit der Registrierung in die zenon6.ini bzw. zenon.ini geschrieben und überschreiben dort eventuell abweichende manuelle Konfigurationen.

Geänderte Einstellungen müssen für alle Runtimes angepasst werden.

Meldungen beim Registrieren

Beim Registrieren der Dienste werden alle Schritte in einem eigenen Fenster angezeigt, das nach vier Sekunden selbstständig geschlossen wird. Beim Auftreten eines Fehlers informiert eine Warnmeldung über die Ursache. Nach der Bestätigung der Meldung wird der Vorgang abgebrochen, zenon wird nicht gestartet. Mögliche Fehlermeldungen:

Meldung | Ursache | Tipp
Couldn´t find zenNetSrv Service! | Die Datei zenNetSrv.exe fehlt im zenon Programmordner oder ist in einer falschen Version vorhanden. | Die schnellste und sicherste Lösung ist meistens eine Neuinstallation von zenon.
zenNetSrv.exe still running! | Der Dienst zenNetSrv.exe konnte nicht beendet werden. | Möglicherweise läuft auf dem Rechner ein Sicherheitstool, das den Zugriff verhindert.
Couldn´t find zenSysSrv Service! | Die Datei zenSysSrv.exe fehlt im zenon Programmverzeichnis oder ist in einer falschen Version vorhanden. | Die schnellste und sicherste Lösung ist meistens eine Neuinstallation von zenon.
zenSysSrv.exe still running! | Der Dienst zenSysSrv.exe konnte nicht beendet werden. | Möglicherweise läuft auf dem Rechner ein Sicherheitstool, das den Zugriff verhindert.


Kommandozeile

Handbuch -> Startup Tool -> Kommandozeile

Das Startup Tool lässt sich auch über die Befehlszeile bedienen. Dazu muss sich die zenon_Startup.exe im Systempfad befinden. Die Datei finden Sie

  • unter Vista/7 im Ordner C:\Program Files\Common Files\COPA-DATA\STARTUP
  • unter XP im Ordner C:\Programme\Gemeinsame Dateien\COPA-DATA\STARTUP

Über die Kommandozeile können:

  • neue Einträge angelegt werden
  • vorhandene Einträge reorganisiert werden (z. B. nach dem Löschen von vorangegangenen Versionen)
  • Einträge registriert werden

Noch in diesem Kapitel

Parameter


Parameter

Handbuch -> Startup Tool -> Kommandozeile -> Parameter

Die Eingabe wird gestartet mit zenon_Startup.exe gefolgt von einem Parameter und eventuellen Feldnamen.

Parameter:

Parameter | Funktion | Feldnamen | Rückgabewert
-new | legt einen neuen Eintrag an | ja, Liste siehe new | 0 oder 1
-reorg | überprüft und reorganisiert vorhandene Einträge | nicht vorhanden | keiner
-reg | registriert Dienste | Name des Eintrag | keiner

Verwendung mehrerer Parameter gleichzeitig:

Es ist möglich, mehrere Parameter gleichzeitig zu verwenden. Werden mehrere -new Parameter gleichzeitig verwendet, kann der Rückgabewert nicht eindeutig ausgewertet werden.

Prinzipiell wird bei Mehrfachnennungen in folgender Reihenfolge vorgegangen:

  1. –new: Neue Einträge anlegen.
  2. –reg: Registrieren des angegeben Eintrages.
  3. –reorg: Entfernen aller ungültigen Einträge für gelöschte zenon Versionen.

Noch in diesem Kapitel

new - Erstellen neuer Einträge

reorg - Reorganisieren von Einträgen

reg - Registrieren von Einträgen


new - Erstellen neuer Einträge

Handbuch -> Startup Tool -> Kommandozeile -> Parameter -> new - Erstellen neuer Einträge

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Parameter -new dient zum Erstellen neuer Einträge. Er benötigt mindestens zwei Feldnamen:

  • NAME als eindeutigen Namen des Eintrags

    Sollte der Name des Eintrags bereits vorhanden sein, wird kein Eintrag angelegt.

  • PATH als Pfad, in dem zenon abgelegt wurde

Syntax

Die Syntax ist wie folgt aufgebaut: zenon_Startup.exe -> Parameter > Felkdname="TEXT"

  1. zenon_Startup.exe
  2. Leerschrit
  3. Parameter
  4. Leerschritt
  5. Feldname
  6. = Zeichen
  7. öffnende Anführungszeichen
  8. Text
  9. schließende Anführungszeichen

Example Beispiel

zenon_Startup.exe -new NAME="Neuer Eintrag" PATH="C:\Beispiel Verzeichnis\zenon"

Feldnamen

Folgende Feldnamen können genutzt werden:

Feldname | Pflichtfeld | Beschreibung
NAME | X | Eindeutige Name des Eintrags. Z.B.: NAME="Test"
PATH | X | Der Anwendungspfad, in dem sich zenon befindet. Z.B.: PATH="C:\Program Files\COPA-DATA\zenon 6.50 SP0"
PROJECT_RT | - | Name des zu startenden Runtime-Projekts. Z.B.: PROJECT_RT="Testprojekt"
PROJECT_RT_PATH | - | Das Runtime-Verzeichnis des Projekts (siehe PROJECT_RT). Z.B.: PROJECT_RT_PATH="C:\Users\Public\Documents\zenon_Projects\Testprojekt"
PROJECT_ED | - | Das Projekt, das im Editor aktiviert werden soll. Z.B.: PROJECT_ED="Testprojekt"
WSP | - | Der Arbeitsplatz, der mit dem Editor geladen werden soll. Z.B.: WSP="C:\Users\Public\Documents\zenon_Projects\DEMO622.WSP6"
SQLSRV | - | Bezeichnung des SQL Servers, der vom Editor verwendet werden soll. Z.B.: SQLSRV="MSSQL$ZENON_DEV"
PROVIDER | - | Providerstring für die Initialisierung der SQL Verbindung. Z.B.: PROVIDER="Provider=SQLNCLI.1;Password=000;Persist Security Info=False;User ID=zenOnSrv;Initial Catalog=%s;Data Source=localhost\ZENON_DEV;"
DBPATH | - | Pfad der zu verwendenden SQL-Datenbank. Z.B.: DBPATH="C:\ProgramData\COPA-DATA\SQL\"
PRESTART | - | Programmaufruf, der vor dem Starten des Editors oder der Runtime bzw. dem Registrieren dieser Version ausgeführt wird. Z.B.: PRESTART="C:\zenon Versionen\zenon 6.50\Dlls\zenVNCCli.exe"
POSTSTART | - | Programmaufruf, der nach dem Beenden des Editors ausgeführt wird. Z.B.: POSTSTART="C:\zenon Versionen\zenon 6.50\Dlls\zenVNCCli.exe" Achtung: Post Start wird nur aufgerufen, wenn im Startup Tool oder in der Startup.inidie Option Read back the INI settings (Item->Properties->General) aktiviert wurde.

Mehrere Feldnamen werden durch Leerschritte getrennt.

info Info

Pfade mit Leerzeichen müssen immer in Klammern gesetzt werden.

Rückgabewerte

0 - Ausführung fehlerfrei

1 - Eintrag konnte nicht erstellt werden


reorg - Reorganisieren von Einträgen

Handbuch -> Startup Tool -> Kommandozeile -> Parameter -> reorg - Reorganisieren von Einträgen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Parameter -reorg überprüft alle Einträge ob die verknüpfte zenon Version noch im Dateisystem vorhanden ist. Sollten die Anwendungsdateien nicht mehr gefunden werden, wird der Eintrag endgültig aus dem Startup Tool gelöscht.

Der Befehl liefert keinen Rückgabewert. Nach Ausführung wird das Startup Tool gestartet.

Beispiel: zenon_Startup.exe -reorg


reg - Registrieren von Einträgen

Handbuch -> Startup Tool -> Kommandozeile -> Parameter -> reg - Registrieren von Einträgen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Parameter –reg registriert alle benötigten Dienste im Verzeichnis des angegebenen Eintrags. Der Aufruf erfolgt über:

  • -reg "Name des Eintrags"

Sollte das Startup Tool bereits gestartet sein, wird nichts registriert, sondern das Startup Tool in den Vordergrund geholt.

Der Befehl liefert keinen Rückgabewert.

Example Beispiel

zenon_Startup.exe -reg "Version 6.50"

registriert die Version 6.50.

Voraussetzung: im Startup Tool existiert ein Eintrag mit diesem Namen.


Statusverarbeitung

Handbuch -> Statusverarbeitung

Die Statusverwaltung ermöglicht den Überblick im Netzwerk und im Prozess. Jeder Variable können eigene Attribute zugeordnet werden. Insgesamt sind 64 Status/Attribute definiert. Die gebräuchlichsten sind spontan, gestört, Handwert und Ersatzwert.

Jeder gespeicherte Wert in zenon besteht aus 3 Informationen: Wert, Zeitstempel und Status. Das heißt, bei jedem archivierten Wert wird auch der richtige Status mit abgelegt.

Für den Status stehen in der Runtime viele Auswertungsmöglichkeiten zur Verfügung, wie zum Beispiel: das Combielement, die Reaktionsmatrizen sowie der Report Generator. Status sind auch in VBA bzw. VSTA sowie im Rezeptgruppenmanager zugänglich.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Statusbits

Verwendung


Statusbits

Handbuch -> Statusverarbeitung -> Statusbits

Folgende Statusbits stehen in zenon zur Verfügung:

Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Einzelne Status sind nicht mit allen Treibern verfügbar.

Da die Status jeder Variable auch in VBA/VSTA in Form eines 64 Bit Wertes zur Verfügung stehen, ist auch die Wertigkeit (Bitnummer) in der Statusbeschreibung angegeben. Dies ist für eine individuelle Auswertung mit VBA/VSTA nötig.

Bei der Anzeige in der Runtime gibt es zwei Möglichkeiten: die Kurzform und die Langform. Diese wird in der Beschreibung durch Schrägstrich getrennt.

Für jeden Status kann ein eigener Text hinterlegt werden, der in den einzelnen Modulen (Editor wie Runtime) angezeigt wird. Wobei der Kurztext und der Langtext durch ein Semikolon (;) getrennt wird.

Dazu müssen folgende Einträge in die project.ini eingefügt werden:

[STATUS]

STATUS1=MS_K;Mein Status 00

STATUS2=ET;Eigener Text

......

STATUS64=RES;Nicht verwendet

Hinweis: Die Nummerierung beginnt hier bei 1 und nicht wie in der Tabelle angeführt mit 0

Noch in diesem Kapitel

Benutzerstatus 1 bis 8 (M1-M8) und 14 bis 16 (M14-M16)

Select im Netzwerk (NET_SEL)

Revision (REVISION)

In Bedienung (PROGRESS)

Laufzeitüberschreitung (TIMEOUT)

Handwert (MAN_VAL)

Generalabfrage (GI)

Spontan (SPONT)

Ungültig (INVALID)

Sommer/Winterzeit Ankündigung (T_CHG_A)

Abgeschaltet (OFF)

Echtzeit extern (T_EXTERN)

Echtzeit intern (T_INTERN)

Nicht sortierfähig (N_SORTAB)

Störmeldung Trafowert (FM_TR)

Laufmeldung Trafowert (RM_TR)

Info der Variable (INFO)

Ersatzwert (ALT_VAL)

Nicht aktualisiert (N_UPDATE)

Winterzeit (T_STD)

Übertragungsursache (COTx)

P/N-Bit (N_CONF)

Test-Bit (TEST)

Schreiben bestätigen (WR-ACK)

Schreiben erfolgreich (WR-SUC)

Normalzustand (NORM)

Abweichung Normalzustand (N_NORM)

BL_870

SB_870

NT_870

OV_870

SE_870

T_INVAL

Schalterfall erkannt (CB_TRIP)

Schalterfallerkennung inaktiv (CB_TR_I)


Benutzerstatus 1 bis 8 (M1-M8) und 14 bis 16 (M14-M16)

Handbuch -> Statusverarbeitung -> Statusbits -> Benutzerstatus 1 bis 8 (M1-M8) und 14 bis 16 (M14-M16)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
0 bis 7 | M1; Benutzerstatus 1 bis M8; Benutzerstatus 8 | vom Benutzer | in allen Treibern
13 bis 15 | M14; Benutzerstatus 14 bis M16; Benutzerstatus 16 | vom Benutzer | in allen Treibern

Die insgesamt 11 Benutzerstatusbits können projektspezifisch genutzt und eingesetzt werden. Anwendungsbeispiele für den Benutzerstatus sind z.B.: spezielle Verriegelungen von Befehlsgaben, oder Flags für eigene Informationen.


Select im Netzwerk (NET_SEL)

Handbuch -> Statusverarbeitung -> Statusbits -> Select im Netzwerk (NET_SEL)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
8 | NET_SEL; Select im Netzwerk | automatisch | in allen Treibern

Die Select-Kennung dient zur Selektion eines Befehlsobjektes in zenon. Bei gesetzter Selektion kann eine erneute Befehlsanwahl (z.B. von einem weiteren Arbeitsplatz) verriegelt werden.


Revision (REVISION)

Handbuch -> Statusverarbeitung -> Statusbits -> Revision (REVISION)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
9 | REVISION; Revision | vom Benutzer | in allen Treibern

Variablen können auf Revision gesetzt werden. In dieser Stellung werden die Alarmbehandlung und die Befehlsgabe vom Prozessleitsystem unterdrückt. Die aktuellen Variablenwerte werden aber nach wie vor in den Bildern angezeigt - und auch archiviert!

Damit ist es möglich, einzelne Anlagenteile von der Alarmierung und Verarbeitung vorübergehend einfach auszublenden.


In Bedienung (PROGRESS)

Handbuch -> Statusverarbeitung -> Statusbits -> In Bedienung (PROGRESS)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
10 | PROGRESS; In Bedienung | automatisch | nur in bestimmten Treibern

Das Statusbit in Bedienung dient in Verbindung mit der Befehlsgabe (nur SICAM 230 oder zenon Energy Edition) zur Anzeige, dass ein Schalter gerade bedient wird. Es wird gleichzeitig mit dem Statusbit Select im Netzwerk (NET_SEL) gesetzt. Das Bit wird als Status der Rückmeldevariable gesetzt.
Das automatische Setzen des Bits in der Runtime kann in der Befehlsgruppe durch Aktivierung der Eigenschaft Set status PROGRESS aktiviert werden.

Interne ID: In Bedienung (PROGRESS)

Set status PROGRESS

Aktiv: Bei den Aktionen Befehl und Nachführen wird das Statusbit In Bearbeitung (PROGRESS) bei der Rückmeldevariable gesetzt, wenn die Aktionen in der Runtime angestoßen werden.
Das Bit dient dazu eine grafische Anzeige zu realisieren, um dem Benutzer anzuzeigen, dass gerade eine Aktion ausgeführt wird. Mit Hilfe eines Combielements oder einer Reaktionsmatrix können Sie das Statusbit abfragen und eine grafische Anzeige umsetzen.

Inaktiv: Das Statusbit wird nicht gesetzt.

Default: inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wenn der abgesetzte Befehl mit dem Rückmeldewert übereinstimmt, wird das Bit automatisch zurückgesetzt. Es können nur die Rückmeldewerte EIN und AUS überwacht werden.


Laufzeitüberschreitung (TIMEOUT)

Handbuch -> Statusverarbeitung -> Statusbits -> Laufzeitüberschreitung (TIMEOUT)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
11 | TIMEOUT; Laufzeitüberschreitung | automatisch | nur in bestimmten Treibern

Der Status Laufzeitüberschreitung wird vom Befehlselement (nur SICAM 230) bei erkannter Überschreitung der Zeit für die Rückmeldung (Laufzeit) eines Schaltelementes gesetzt. Das Rücksetzen erfolgt durch Änderung der Rückmeldung bzw. durch eine erneute Befehlsgabe.


Handwert (MAN_VAL)

Handbuch -> Statusverarbeitung -> Statusbits -> Handwert (MAN_VAL)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
12 | MAN_VAL; Handwert | automatisch | in allen Treibern

Dieser Status wird gesetzt, sobald ein Wert in einem Archiv per Hand verändert wird. Dies kann im Report Generator oder im Bild Archivnachbearbeitung gemacht werden.


Generalabfrage (GI)

Handbuch -> Statusverarbeitung -> Statusbits -> Generalabfrage (GI)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
16 | GI; Generalabfrage | automatisch | in allen Treibern

Nach der Initialisierung der Runtime wird das erste Abbild, das gelesen wird, mit Generalabfrage bezeichnet. Das heißt, der Wert hat sich seit dem Runtime-Start noch nie geändert.


Spontan (SPONT)

Handbuch -> Statusverarbeitung -> Statusbits -> Spontan (SPONT)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
17 | SPONT; Spontan | automatisch | in allen Treibern

Aktueller Wert ist gültig. Alles OK.


Ungültig (INVALID)

Handbuch -> Statusverarbeitung -> Statusbits -> Ungültig (INVALID)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
18 | INVALID; Ungültig | automatisch | in allen Treibern

Dieses Bit ist gesetzt, wenn eine Störung in der Kommunikation mit dem Treiber vorliegt oder die einzelne Variable gestört ist. Die Auswertung einzelner Variablen wird nur von spontanen Treibern unterstützt. Die meisten zenon Treiber sind aber Treiber, die im Pollingbetrieb arbeiten, so dass damit nur eine generelle Störung in der Kommunikation angezeigt wird.


Sommer/Winterzeit Ankündigung (T_CHG_A)

Handbuch -> Statusverarbeitung -> Statusbits -> Sommer/Winterzeit Ankündigung (T_CHG_A)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
19 | T_CHG_A; Sommer/Winterzeit Ankündigung | automatisch | in bestimmten Treibern

Eine Stunde vor Umschaltung von Sommer- auf die Winterzeit oder umgekehrt, wird dieser Status gesetzt. Dieser Status kann vom Benutzer ausgewertet werden. In zenon dient dieser Status als reine Information.


Abgeschaltet (OFF)

Handbuch -> Statusverarbeitung -> Statusbits -> Abgeschaltet (OFF)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
20 | OFF; Abgeschaltet | vom Benutzer | in allen Treibern

Wird eine Variable online nicht benötigt, so kann dieser abgeschaltet werden. Damit wird dieser auch von der angeschlossenen Hardware nicht mehr gelesen und aktualisiert.

Dieser Status kann verwendet werden um z.B. noch nicht aktive Anlagenteile von der Alarmierung auszuklammern.


Echtzeit extern (T_EXTERN)

Handbuch -> Statusverarbeitung -> Statusbits -> Echtzeit extern (T_EXTERN)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
21 | T-EXTERN | automatisch | nur in bestimmten Treibern

Der Zeitstempel wurde vom externen Gerät übernommen. zenon nimmt diesen Wert, so wie er ist. Alle Module verwenden nun diesen Zeitstempel.


Echtzeit intern (T_INTERN)

Handbuch -> Statusverarbeitung -> Statusbits -> Echtzeit intern (T_INTERN)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
22 | T-INTERN | automatisch | in allen Treibern

Der Zeitstempel wird vom zenon Treiber beigegeben. Sobald der Wert korrekt gelesen wird, wird dieser gestempelt. Alle Module verwenden nun diesen Zeitstempel.


Nicht sortierfähig (N_SORTAB)

Handbuch -> Statusverarbeitung -> Statusbits -> Nicht sortierfähig (N_SORTAB)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
23 | N_SORTAB | automatisch | für IEC-Standards

Nur für SICAM 230.

Betrifft Echtzeitdatenstrom beim SSI-Protokoll. SSI wird für SK1703 verwendet und betrifft den AK-Treiber.

Status wird nicht mehr verwendet.

Ursprünglich: Wenn ein Telegramm erheblich zu spät kam, erhielt es den Status N_SORTAB, wenn es nicht mehr einsortiert werden konnte. Da nachsortiert wird, ist dieser Status mittlerweile ohne Bedeutung.


Störmeldung Trafowert (FM_TR)

Handbuch -> Statusverarbeitung -> Statusbits -> Störmeldung Trafowert (FM_TR)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
24 | FM_TR | automatisch | für IEC-Standards

Nur für SICAM 230.

Nur für SSI-Protokoll: Unplausibler Trafowert. In neueren Protokollen wird diese Information im INVALID-Bit transportiert.

SSI wird für SK1703 verwendet und betrifft den AK-Treiber.


Laufmeldung Trafowert (RM_TR)

Handbuch -> Statusverarbeitung -> Statusbits -> Laufmeldung Trafowert (RM_TR)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
25 | RM_TR | automatisch | für IEC-Standards

Nur für SICAM 230.

Betrifft SSI-Protokoll und IEC870-101: Solange gestuft wird, kommt dieses BIT mit.

SSI wird für SK1703 verwendet und betrifft den AK-Treiber.


Info der Variable (INFO)

Handbuch -> Statusverarbeitung -> Statusbits -> Info der Variable (INFO)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
26 | INFO | automatisch | für IEC-Standards

Nur für SICAM 230.

Wird nicht mehr verwendet.


Ersatzwert (ALT_VAL)

Handbuch -> Statusverarbeitung -> Statusbits -> Ersatzwert (ALT_VAL)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
27 | ALT_VAL; Ersatzwert | vom Benutzer | in allen Treibern

Um einen Wert simulieren zu können, kann auf den Ersatzwert umgeschaltet werden. Dabei wird der Wert vom Prozess komplett entkoppelt wie bei Abgeschaltet (OFF). Gleich wie beim Abschalten wird der letzte Prozesswert weiter angezeigt. Es besteht jedoch die Möglichkeit den Ersatzwert in der Runtime zu ändern, z.B. über den Sollwerteingabedialog:

  • Modifizieren Ersatzwert: Ändert nur den Ersatzwert
  • Umschalten u. modifizieren Ersatzwert: Schaltet auf Ersatzwert um und ändert diesen gleich auf den eingestellten Wert ab.
  • Modifizieren Spontanwert: Trotz Ersatzwert wird ein Sollwert zur Hardware gesendet. Die Variable behält jedoch den Ersatzwert.
  • Umschalten auf Spontanwert: Schaltet den Ersatzwert aus.

Weitere Möglichkeiten den Ersatzwert zu beeinflussen bestehen über den Rezeptgruppen Manager bzw. die Programmierschnittstellen.

War der Status beim Umschalten in den Ersatzwert der Wert ungültig (INVALID gesetzt), bleibt dieser Status erhalten. Der Wert hat dann den Status ungültig und Ersatzwert gesetzt.

Der Ersatzwert wird nicht an die angeschlossene Hardware übertragen, sondern bleibt im Prozessabbild des Rechners. Dieser Wert wird in alle zenon Module gesandt und weiterverarbeitet. So wird er z.B. archiviert und es werden Alarme erzeugt.

Über den Status können im Report diese Werte speziell gekennzeichnet werden. Damit ist einerseits Nachvollziehbarkeit gegeben, zum anderen werden nachfolgende Auswertungen weitestgehend nicht beeinflusst.

Example Beispiel

Wenn etwa ein Außentemperaturfühler defekt ist, liefert dieser einen unrealistischen Wert; z.B. -280 ºC. Der Benutzer kann nun statt diesem unrealistischen Wert einen Wert eintragen, den er am Thermometer abliest, z.B. 14ºC. Nun wird dieser Wert archiviert, alarmiert und protokolliert.

Alle Module in zenon arbeiten nun mit diesem Ersatzwert.


Nicht aktualisiert (N_UPDATE)

Handbuch -> Statusverarbeitung -> Statusbits -> Nicht aktualisiert (N_UPDATE)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
29 | N_UPDATE | automatisch | in allen Treibern

Der Status Nicht aktualisiert (N_UPDATE) wird gesetzt, wenn der Wert zwar von der Hardware angefordert ist, aber noch kein gültiger Wert gelesen werden konnte.


Winterzeit (T_STD)

Handbuch -> Statusverarbeitung -> Statusbits -> Winterzeit (T_STD)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
30 | T_STD | automatisch | in allen Treibern

Über diesen Staus wird eindeutig angegeben, ob der Zeitstempel in der Winterzeit liegt (Bit gesetzt) oder in der Sommerzeit (Bit nicht gesetzt).


Übertragungsursache (COTx)

Handbuch -> Statusverarbeitung -> Statusbits -> Übertragungsursache (COTx)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
32 - 37 | COT0 bis COT5 | automatisch | für IEC-Standards

Die Übertragungsursache (COT) laut IEC 60870 Protokoll.

Der Wert der Übertragungsursache (siehe IEC60870-5-101 7.2.3) wird auf die Statusbits 32 - 37 abgebildet. Damit können bis zu 6 COTx gesetzt werden (x steht für die Bitnummern 0 bis 5). Zum Beispiel wird das niedrigste Bit des COT-Werts auf das Statusbit 32 rangiert und in <CD_ PRODUCTNAME> COT0 benannt.

Der gesamte COT-Wert kann über eine Reaktionsmatrix (Multi-Numerisch oder Multi-Binär) zur Laufzeit ausgewertet werden. Je ein COTx Bit erhöht der Wert der Übertragungsursache wie folgt:

  • COT0 = 2^0 = 1
  • COT1 = 2^1 = 2
  • COT2 = 2^2 = 4
  • COT3 = 2^3 = 8
  • COT4 = 2^4 = 16
  • COT5 = 2^5 = 32

Beispiel

Typische COT-Werte:

Status | Wert | Übertragungsursache | Kurzbezeichnung
COT0, COT1 | 1+2 = 3 | spontaneous | COT_spont
COT0, COT1, COT2 | 1+2+4 = 7 | activation confirmation | COT_actcon
COT1, COT3 | 2+8 = 10 | activation termination | COT_actterm
COT2, COT4 | 4+16 = 20 | interrogated by station interrogation | COT_inrogen

info Info

Das Modul Befehlsgabe verwendet die Übertragungsursache für Laufzeitüberwachung von Kommandos.

Achtung:

  • Nicht alle Treiber unterstützen COT.
  • Manche Energy Treiber unterstützen nur einen auf die Laufzeitüberwachung in der Befehlsgabe begrenzten Bereich.
  • Manche Treiber unterstützen COT, obwohl das Protokoll selbst keine COT beinhaltet (z.B. DNP3). Details finden Sie in der jeweiligen Treiberdokumentation.


P/N-Bit (N_CONF)

Handbuch -> Statusverarbeitung -> Statusbits -> P/N-Bit (N_CONF)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
38 | N_CONF | automatisch | für IEC-Standards

Das P/N-Bit aus einem IEC870-5-104-Telegramm wird auf das Statusbit N_CONF rangiert.


Test-Bit (TEST)

Handbuch -> Statusverarbeitung -> Statusbits -> Test-Bit (TEST)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
39 | TEST | automatisch | für IEC-Standards

Das Test-Bit aus einem IEC870-5-104-Telegramm wird auf das Statusbit TEST rangiert.


Schreiben bestätigen (WR-ACK)

Handbuch -> Statusverarbeitung -> Statusbits -> Schreiben bestätigen (WR-ACK)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
40 | WR_ACK | automatisch | in allen Treibern

In zenon kann angegeben werden, für welche Sollwert setzen bzw. Rezept ausführen Aktionen eine Schreibbestätigung angefordert werden soll.


Schreiben erfolgreich (WR-SUC)

Handbuch -> Statusverarbeitung -> Statusbits -> Schreiben erfolgreich (WR-SUC)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
41 | WR_SUC | automatisch | in allen Treibern

Wenn für eine Sollwert setzen bzw. Rezept ausführen Aktion eine Schreibbestätigung angefordert werden soll (WR-ACK), wird nach dem Schreibvorgang dieses Statusbit gesetzt.


Normalzustand (NORM)

Handbuch -> Statusverarbeitung -> Statusbits -> Normalzustand (NORM)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
42 | NORM | automatisch | in allen Treibern

Der Normalzustand wird über die Variableneigenschaften vorgegeben und auf das Statusbit NORM abgebildet.


Abweichung Normalzustand (N_NORM)

Handbuch -> Statusverarbeitung -> Statusbits -> Abweichung Normalzustand (N_NORM)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
43 | N_NORM | automatisch | in allen Treibern

Der Treiber vergleicht bei Variablen vom Datentyp BIT den Prozesszustand mit dem vorgegebenen Normalzustand und bildet das Ergebnis auf das Statusbit N_NORM ab.


BL_870

Handbuch -> Statusverarbeitung -> Statusbits -> BL_870

Bitnummer | Anzeige | Gesetzt | Verfügbar
44 | BL_870 | automatisch | IEC870 IEC850 (teilweise)

Signalisiert IEC Status blocked nach Norm IEC 60870-101 bzw. 104. Der Wert ist für die Übertragung blockiert und bleibt in dem Status, den er inne hatte, bevor er blockiert wurde. Dieses Statusbit kann in Multireaktionsmatrizen, im Combi-Element und in der Verriegelungsformel ausgewählt werden.

In VBA können mit StatusExtValue() die oberen 32-Bits abgefragt werden, bei SetValueWithStatusEx() können alle 64 Statusbits mitgegeben werden.


SB_870

Handbuch -> Statusverarbeitung -> Statusbits -> SB_870

Bitnummer | Anzeige | Gesetzt | Verfügbar
45 | SB_870 | automatisch | IEC870 IEC850 (teilweise)

Signalisiert IEC Status substituted nach Norm IEC 60870-101 bzw. 104. Der Wert wurde durch einen Bediener oder eine automatisierte Quelle gesetzt. Dieses Statusbit kann in Multireaktionsmatrizen, im Combi-Element und in der Verriegelungsformel ausgewählt werden.

In VBA können mit StatusExtValue() die oberen 32-Bits abgefragt werden, bei SetValueWithStatusEx() können alle 64 Statusbits mitgegeben werden.


NT_870

Handbuch -> Statusverarbeitung -> Statusbits -> NT_870

Bitnummer | Anzeige | Gesetzt | Verfügbar
46 | NT_870 | automatisch | IEC870 IEC850 (teilweise)

Signalisiert IEC Status not topical nach Norm IEC 60870-101 bzw. 104. Der Wert wurde während einer bestimmten Zeitspanne nicht erfolgreich upgedatet oder ist nicht verfügbar. Dieses Statusbit kann in Multireaktionsmatrizen, im Combi-Element und in der Verriegelungsformel ausgewählt werden.

In VBA können mit StatusExtValue() die oberen 32-Bits abgefragt werden, bei SetValueWithStatusEx() können alle 64 Statusbits mitgegeben werden.


OV_870

Handbuch -> Statusverarbeitung -> Statusbits -> OV_870

Bitnummer | Anzeige | Gesetzt | Verfügbar
47 | OV_870 | automatisch | IEC870 IEC850 (teilweise)

Signalisiert Overflow nach Norm IEC 60870-101 bzw. 104. Der Wert liegt außerhalb der vordefinierten Bandbreite.


SE_870

Handbuch -> Statusverarbeitung -> Statusbits -> SE_870

Bitnummer | Anzeige | Gesetzt | Verfügbar
48 | SE_870 | automatisch | IEC870 IEC850 (teilweise)

Diese S/E-Bit wird nach Norm IEC 60870-101 bzw. 104 in Verbindung mit der Select before operate Funktionalität verwendet und dient zur Unterscheidung zwischen Select- und Execute-Zustand eines Befehls.

Werte:

  • 0 = execute
  • 1 = select


T_INVAL

Handbuch -> Statusverarbeitung -> Statusbits -> T_INVAL

Bitnummer | Anzeige | Gesetzt | Verfügbar
49 | T_INVAL | automatisch | IEC870

T_INVAL wird vom IEC870 Treiber gesetzt, wenn der empfangene Echtzeitstempel als ungültig markiert ist. In diesem Fall wird mit der lokalen Zeit des Rechners gestempelt. Im IEC870 Slave des Process Gateways wird T_INVAL in Melderichtung im Zeitstempel weitergeleitet.


Schalterfall erkannt (CB_TRIP)

Handbuch -> Statusverarbeitung -> Statusbits -> Schalterfall erkannt (CB_TRIP)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
50 | Schalterfall erkannt | automatisch | in allen Treibern; wird verwendet in Multi-Binär-Rema, Multi-Numerisch-Rema, Berechnung der Folgearchive , Combielelement, AML/CEL Status

Das Statusbit nimmt den Wert 1 an, wenn ein Schalterfall erkannt wird.

Die Erkennung erfolgt, wenn:

  • der Wert der Rückmeldevariablen von <>0 auf 0 wechselt und
    • das Statusbit CB_TR_I (51) nicht 1 ist
    • das Statusbit PROGRESS (10) nicht 1 ist
    • der Wert der Rückmeldevariable bereits definiert ist (es sich also nicht um den 1. Wert für diese Variable handelt)

Ein Wechsel des Werts von 0 auf <>0 setzt dieses Bit wieder zurück. Ebenso wenn das Statusbit PROGRESS (10) aktiv wird. Eine Änderung von CB_TR_I hat auf einen bereits erkannten Schalterfall keinen Einfluss.

Dieses Statusbit kann durch die Aktion „Status", „Status ein" oder „Status aus" explizit modifiziert werden.

Netzwerk

Im Netzwerk erfolgt die Auswertung am prozessführenden Server. Am Standby-Server wird die Auswertung durchgeführt, das Ergebnis aber nicht auf die Statusbits abgebildet. Der aktuelle Zustand von CB_TR_I und CB_TRIP werden beim Start des Standby-Servers oder Wiederverbinden abgeglichen. Handelt es sich bei der Rückmeldevariablen um eine Variable auf einem lokalen Rechner, dann wird die Auswertung auch auf dem Client-Rechnern durchgeführt.


Schalterfallerkennung inaktiv (CB_TR_I)

Handbuch -> Statusverarbeitung -> Statusbits -> Schalterfallerkennung inaktiv (CB_TR_I)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Anzeige | Gesetzt | Verfügbar
51 | Schalterfallerkennung inaktiv | automatisch als Ergebnis der Formel der Eigenschaft Erkennungsunterdrückung in der Befehlsgabe Interne ID: Schalterfallerkennung inaktiv (CB_TR_I) Erkennungsunterdrückung Eingabe der Formel, mit der die Erkennung eines Schalterfalls unterdrückt wird. Klick auf die Schaltfläche ... öffnet den Formeleditor. Für die Formel können alle Variablen der Verriegelung verwendet werden, Namensersetzungen wie bei der Definition der Verriegelungsbedingungen einer Aktion sind möglich. Hinweis: Variablen, die in der Formel verwendet werden, können bei der Verriegelung nicht gelöscht werden. Mehr im Online-Handbuch. Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | in allen Treibern; wird verwendet in Multi-Binär-Rema, Multi-Numerisch-Rema, Berechnung der Folgearchive , Combielelement, AML/CEL Status

Zeigt an, dass die Schalterfallerkennung unterdrückt ist.

Die Neuberechnung wird ausgelöst bei Statusänderung oder Wertänderung einer Variablen, die in der Befehlsgabe für Berechnungen in Formeln definiert wurde. Die Formel wird nicht ausgewertet und das Ergebnis nicht auf den Status abgebildet, wenn:

  • eine der Variablen in der Formel noch keinen definierten Wert und Status hat
    oder
  • eine der Variablen das gestört Bit gesetzt hat

Dieses Statusbit kann durch die Aktion „Status", „Status ein" oder „Status aus" explizit modifiziert werden.

Erkennung und Unterdrückung

Eine Änderung an diesem Statusbit wird erst aktiv, wenn es vom Treiber zurückgelesen wird. Das bedeutet: Die gleichzeitige Erkennung des Schalterfalls und Unterdrückung der Schalterfallerkennung funktioniert nicht.

Beispiel: Die Formel „RM.Wert<1" wird trotzdem einen Schalterfall erkennen, da zum Zeitpunkt der Wertänderung CB_TR_I noch nicht aktiv ist, sondern nur beim Treiber auf aktiv gesetzt wurde.

Netzwerk

Im Netzwerk erfolgt die Auswertung am prozessführenden Server. Am Standby-Server wird die Auswertung durchgeführt, das Ergebnis aber nicht auf die Statusbits abgebildet. Der aktuelle Zustand von CB_TR_I und CB_TRIP werden beim Start des Standby-Servers oder Wiederverbinden abgeglichen. Handelt es sich bei der Rückmeldevariablen um eine Variable auf einem lokalen Rechner, dann wird die Auswertung auch auf dem Client-Rrechern durchgeführt.


Verwendung

Handbuch -> Statusverarbeitung -> Verwendung

Noch in diesem Kapitel

Reaktionsmatrizen

Dynamische Elemente

Combi Element

Report Generator

Rezeptgruppen Manager

VBA


Reaktionsmatrizen

Handbuch -> Statusverarbeitung -> Verwendung -> Reaktionsmatrizen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In den Reaktionsmatrizen ist die wohl umfangreichste Verarbeitung von Status möglich.

Hier können einzelne Status ausgewertet werden, um Alarme auszulösen. Grundsätzlich hat man die Möglichkeit einen Status genau so zu betrachten wie einen Wert. Man kann genau so wie bei einem Wert bestimmte Aktionen auslösen.

Wie etwa:

  • Alarm auslösen
  • Eintrag in die CEL generieren
  • Funktion auslösen
  • Blinken
  • Farbänderung
  • Drucken

Beispiel:

Wenn nun ein Wert ungültig wird, so bekommt er den Status INVALID. Das geschieht etwa, wenn der Treiber die Verbindung zur SPS verliert. Nun kann man sich eine Reaktionsmatrix erstellen, durch die ein Alarm ausgelöst wird, wenn der Wert ungültig wird (INVALID). Anschließend gibt es dann alle Möglichkeiten, den Alarm auszuwerten.


Dynamische Elemente

Handbuch -> Statusverarbeitung -> Verwendung -> Dynamische Elemente

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei allen dynamischen Elementen hat man die Möglichkeit den Status der verknüpften Variable anzeigen zu lassen. Dies ist mit der Eigenschaft Status der Variable anzeigen gemeint.

Anschliessend besteht die Möglichkeit zur Laufzeit mit der rechten Maustaste den Status anzuzeigen.

Der Status wird in der Runtime durch einem Klick mit der rechten Maustaste auf ein dynamisches Element angezeigt. So lange die Taste gedrückt ist, wird nun der Variablenname so wie der aktuelle Status der Variable angezeigt.

Ist die Statusanzeige aktiviert, so wird ein aussergwöhnlicher Zustand durch ein kleines rotes Rechteck in der rechten oberen Ecke des Elementes angezeigt.

Dadurch wird ersichtlich, dass der Wert nicht mehr spontan ist. Durch die Anzeige des Status (rechte Maustaste) wird ersichtlich, dass jemand den Status auf Ersatzwert geändert hat.


Combi Element

Handbuch -> Statusverarbeitung -> Verwendung -> Combi Element

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Combi Element besteht die Möglichkeit den Status auszuwerten und grafisch aufzubereiten. Im Unterschied zu den Reaktionsmatrizen, wirkt sich die Auswertung nur im Bild aus.

Das heisst:

1 | es ändert sich die Farbe
2 | es wird ein anderes Symbol dargestellt
3 | es werden andere Texte angezeigt
4 | es werden andere Bitmaps eingeblendet
5 | Symbol wird eingefärbt


Report Generator

Handbuch -> Statusverarbeitung -> Verwendung -> Report Generator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Report Generator besteht natürlich auch die Möglichkeit den Status auszuwerten.

Dies geschieht durch die Verwendung einer Funktion variabler mit dem Status als Parameter.

Die Syntax sieht dann folgendermaßen aus:

=variabler(Temperatur_außen,status)

In der Runtime kann die Anzeige wie unten aussehen.

Temperatur_außen

21ºC

ALT_VAL


Rezeptgruppen Manager

Handbuch -> Statusverarbeitung -> Verwendung -> Rezeptgruppen Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Rezeptgruppen Manager besteht die Möglichkeit, alle Status zu lesen, anzuzeigen und zu verändern, wenn diese nicht vom Prozess (Treiber) gesetzt werden. Um Statusbits zu setzen, benutzen Sie im Dialog zum Bearbeiten eines Rezepts die Spalte Aktionen.


VBA

Handbuch -> Statusverarbeitung -> Verwendung -> VBA

In VBA stehen alle Freiheiten zur Verfügung auf den Status zuzugreifen und diesen zu verändern, wenn er nicht vom Prozess (Treiber) gesetzt wird.


Treibersimulation

Handbuch -> Treibersimulation

Wenn bei der Projektierung der dahinterliegende Prozess nicht zur Verfügung steht, kann dieser simuliert und vorab getestet werden. Dazu stehen drei Modi zur Verfügung:

  • Simulation - statisch: konstante vom Treiber simulierte Werte
  • Simulation - zählend: vom Treiber simulierte Werte werden hochgezählt
  • Simulation - programmiert: Werte werden über ein Simulationsprojekt mit zenon Logic berechnet

attention Achtung

Wird der Treiber im Modus Simulation - zählend angehalten, stoppt nur das Zählen. Die Variablen gehen nicht auf gestört. In allen anderen Betriebsarten wird der Treiber wirklich gestoppt.

Hinweis: Simulation - programmiert wird nicht unterstützt von Treibern für:

  • Interne Variablen
  • Mathematik-Variablen
  • Simulator-Variablen
  • System-Variablen

info Info

zenon Variablen, die zenon Logic IO-Variablen repräsentieren, sind im Zustand Treibersimulation programmiert im Projekt nicht verfügbar.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Simulation - statisch

Simulation - zählend

Simulation - programmiert


Simulation - statisch

Handbuch -> Treibersimulation -> Simulation - statisch

Bei statischer Simulation wird keine Kommunikation zur Steuerung aufgebaut, sondern die Werte werden vom Treiber simuliert. In diesem Modus bleiben die Werte konstant. Werte können durch die Runtime oder den Anwender geändert werden. Bei einem Neustart der Runtime mit Simulation - statisch werden diese Werte aber nicht gespeichert und gehen verloren.


Simulation - zählend

Handbuch -> Treibersimulation -> Simulation - zählend

Bei zählender Simulation wird keine Kommunikation zur Steuerung aufgebaut, sondern die Werte werden vom Treiber simuliert. In diesem Modus zählt der Treiber die Werte beginnend bei 0 innerhalb ihres Wertebereichs automatisch hoch. Ist der Maximalwert erreicht, beginnt der Zählvorgang wieder bei 0.

info Info

Bei negativen Startwerten beginnt der Zählvorgang erst bei 0.

INT verwendet zum Zählern den Maximalwert von USINT.

attention Achtung

Wird der Treiber im Modus Simulation - zählend angehalten, stoppt nur das Zählen. Die Variablen gehen nicht auf gestört. In allen anderen Betriebsarten wird der Treiber wirklich gestoppt.


Simulation - programmiert

Handbuch -> Treibersimulation -> Simulation - programmiert

Bei Simulation - programmiert wird keine Kommunikation zur Steuerung aufgebaut, sondern die Werte werden von einem frei programmierbaren Simulationsprojekt berechnet. Das Simulationsprojekt wird mit der zenon Logic Workbench erstellt und läuft in der zenon Logic Runtime ab. Es ermöglicht, Status und Zeitstempel von Variablen am Treiber zu modifizieren. Schreibbefehle auf Variablen durch zenon werden an die Simulation weitergegeben, redundante Server und Standby-Server werden synchronisiert. So lassen sich auch komplexe Abläufe simulieren.

Um das Simulationsprogramm zu starten, wählen Sie in der Treiberkonfiguration den Modus Simulation - programmiert.

info Info

Windows CE

Die Simulation - programmiert steht unter Windows CE nicht zur Verfügung.

Noch in diesem Kapitel

Editor

Treiberkonfiguration

zenon Logic Workbench

Runtime

Hinweise zu Variablen in Simulationsprojekten

Fehlermeldungen


Editor

Handbuch -> Treibersimulation -> Simulation - programmiert -> Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Projekt anlegen

Projekt löschen

Verteiltes Engineering

Treiber wechseln

XML-Export/Import


Projekt anlegen

Handbuch -> Treibersimulation -> Simulation - programmiert -> Editor -> Projekt anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Projekt für die Simulation - programmiert anlegen zu können, muss:

  • ein einzelner Prozesstreiber ausgewählt werden
  • der Projektname gültig sein.

attention Achtung

Simulation - programmiert wird nicht unterstützt von Treibern für:

  • Interne Variablen
  • Mathematik-Variablen
  • Simulator-Variablen
  • System-Variablen

Um ein Simulationsprojekt anzulegen:

  • klicken Sie in der Gruppe Treiber-Simulationsprojekt bei der Eigenschaft Bearbeiten auf Hier klicken->

    Interne ID: Projekt anlegen

    Bearbeiten

    Nur verfügbar, wenn ein Prozesstreiber gewählt wurde, der Projektname gültig ist und nur ein einzelner Treiber ausgewählt wurde. Nicht verfügbar für Treiber für die Simulator Variable.

    Klick öffnet das Simulationsprojekt in der zenon Logic Workbench. Existiert kein Simulationsprojekt für diesen Treiber, wird dieses automatisch erzeugt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt anlegen

    Treiber-Simulationsprojekt

    Beinhaltet alle Eigenschaften für die Konfiguration der Simulation - programmiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ein neues zenon Logic Projekt wird erzeugt
  • Name und Portnummern für Event-Port und Standard-Port werden automatisch vergeben; ändern Sie diese nach Belieben

    Interne ID: Projekt anlegen

    Standard-Port

    Nur verfügbar, wenn ein Simulationsprojekt erzeugt wurde.

    TCP/IP Port für die Kommunikation mit der zenon Logic Workbench. Die Portnummer muss eindeutig, im Projekt frei und auf dem Rechner, auf dem der Treiber läuft, verfügbar sein. Beim Erzeugen des Simulationsprojektes wird automatisch eine eindeutige Portnummer vergeben.

    Hinweis: Eine automatisch vergebene Portnummer ist nur für das jeweilige Projekt eindeutig. In multihierarchischen Projekten muss diese überprüft werden, um Kommunikationsfehler mit der zenon Logic Workbench/Runtime zu vermeiden.

    Minimum: 6000 (bei automatischer Vergabe, manuell: empfohlen)

    Maximum: 6999 (bei automatischer Vergabe, manuell: empfohlen)

    Default: 6000

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt anlegen

    Event-Port

    Nur verfügbar, wenn ein Simulationsprojekt erzeugt wurde.

    TCP/IP Port für den spontanen Datenaustausch. Die Portnummer muss eindeutig, im Projekt frei und auf dem Rechner, auf dem der Treiber läuft, verfügbar sein. Beim Erzeugen des Simulationsprojektes wird automatisch eine eindeutige Portnummer vergeben.

    Hinweis: Eine automatisch vergebene Portnummer ist nur für das jeweilige Projekt eindeutig. In multihierarchischen Projekten muss diese überprüft werden, um Kommunikationsfehler mit der zenon Logic Workbench/Runtime zu vermeiden.

    Minimum: 6001 (bei automatischer Vergabe, manuell: empfohlen)

    Maximum: 6998 (bei automatischer Vergabe, manuell: empfohlen)

    Default: 6001

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt anlegen

    Name

    Name des Simulationsprojektes. Ist beim Start der zenon Logic Workbench kein gültiger Name vorhanden, wird automatisch ein Name vergeben. Dieser setzt sich zusammen aus dem Treibernamen und dessen Bezeichnung.

    Bedingungen für gültige Namen:

    - darf nicht leer sein

    - muss im Projekt eindeutig sein

    - darf nur für zenon Logic erlaubte Zeichen beinhalten; verboten sind: /\:*?<>!|"

    Minimum: 1 Zeichen

    Maximum: 15 Zeichen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • die zenon Logic Workbench wird geöffnet

Die Workbench des Simulationsprojektes wird automatisch geschlossen, wenn:

  • der zenon Editor geschlossen wird
  • ein Treiber gelöscht wird, dessen Simulationsprojekt aktuell in der Workbench editiert wird
  • das Simulationsprojekt beim Treiber über die Eigenschaft Löschen gelöscht wird

    Interne ID: Projekt anlegen

    Löschen

    Nur verfügbar, wenn ein Simulationsprojekt definiert ist und nur ein Treiber ausgewählt ist.

    Löscht Simulationsprojekt nach Sicherheitsabfrage.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • das Simulationsprojekt umbenannt wird

Projektablage

Ein zenon Logic Projekt enthält viele Dateien und Ordner. Um deren Handhabung, vor allem beim Verteilten Engineering zu vereinfachen, werden sämtliche Dateien in gepackter Form in der Datei Simul_<Treiber-ID>.zip im Ordner <Sql Projekt Pfad>\FILES\zenon\custom\drivers abgelegt. Im Editor befindet sich diese Datei bei den Dateien des Treibers. Die Dateien werden beim Start der zenon Logic Workbench automatisch entpackt und beim Beenden wieder gepackt.

Variablen anlegen

Beim Anlegen von Variablen in einem Simulationsprojekt ist die Reihenfolge der Schritte wichtig:

  1. erstellen Sie die Variable
  2. wählen Sie den gültigen Datentyp in der zenon Logic Workbench aus
  3. setzen Sie erst dann die Eigenschaft embed symbol aktiv

Hintergrund: Variablen werden per Default mit dem Treiberobjekttyp SPS Merker angelegt. Dieser Objekttyp unterstützt nicht bei allen Treibern alle Datentypen. Wird eine Variable in der zenon Logic Workbench mit aktiver Eigernschaft embed symbol kopiert, muss diese Eigenschaft deaktiviert werden, um den Datentyp ändern zu können. Damit wird die Variable in zenon wieder gelöscht.

info Info

Fehlermeldung "Can not create variable"

Eine Variable kann im Simulationsobjekt nicht angelegt werden, wenn der Treiber keine Treiberobjekttypen - ausgenommen

Treibervariable - hat, die diesen Datentyp unterstützen.

Beim Aktivieren von embed symbol wird dann die Fehlermeldung "can not create variable" angezeigt.

Struktur-Datentyp

Beim Anlegen von Variablen mit einem Struktur-Datentyp:

  • werden diese, wenn möglich, mit dem Treiberobjekttyp SPS Merker angelegt
  • werden alle Treiberobjekttypen mit Ausnahme von Treibervariable probiert, bis einer für alle Elemente verwendbar ist
  • ist kein passender Treiberobjekttyp verfügbar, dann wird
    • bei Nicht-Strukturvariablen keine Variable erzeugt
    • bei Strukturvariablen der Treiberobjekttyp SPS Merker benutzt

Beispiel:

Ein Strukturdatentyp enthält Elemente vom Typ UINT und STRING. Eine Variable wird für den S7TCP Treiber erstellt und embed symbol wird aktiviert.

  • Die Variable wird nicht im SPS Merker angelegt, sondern als Erw. Datenbaustein, in dem alle Strukturelementen vorhanden sind.
  • Ein neuer Typ LINT wird hinzugefügt, dieser wird vom Erw.Datenbaustein nicht unterstützt.
  • Beim Anlegen einer neuen Variablen wird diese als Typ SPS Merker angelegt. Es kann nur die erste Komplexvariable aktiviert werden (UINT). Bei der bestehenden Strukturvariable bleibt der Objekttyp Erw. Datenbaustein und das letzte Strukturelement (LINT) kann nicht aktiviert werden.

Kompilieren der Dateien

Wenn ein Simulationsprojekt in der zenon Logic Workbench kompiliert wird, bewirkt dies in zenon das Erzeugen der Variablen und der Programmdatei der Runtime.
Beim Kompilieren wird im Runtime-Ordner \RT\FILES\zenon\custom\drivers ein Unterordner mit dem Namen des Simulationsprojekts erzeugt. In diesem Ordner wird dann die Datei mit dem Code der Simulation in SIMULRT.COD abgelegt.

Im Ausgabefenster wird beim Kompilieren folgende Meldung angezeigt:

SIMULRT.COD

Und wenn mit C-Compiler kompiliert, dann zusätzlich:

T5APP.DLL

attention Achtung

Bei Mehrplatzfähigen Projekten darf offline kein neues Simulationsprojekt erstellt werden. Dieses kann nicht mehr gelöscht werden.


Projekt löschen

Handbuch -> Treibersimulation -> Simulation - programmiert -> Editor -> Projekt löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Simulationsprojekt zu löschen:

  1. klicken Sie in der Gruppe Treiber-Simulationsprojekt bei der Eigenschaft Löschen auf die Schaltfläche Hier klicken->

    Interne ID: Projekt löschen

    Löschen

    Nur verfügbar, wenn ein Simulationsprojekt definiert ist und nur ein Treiber ausgewählt ist.

    Löscht Simulationsprojekt nach Sicherheitsabfrage.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt löschen

    Treiber-Simulationsprojekt

    Beinhaltet alle Eigenschaften für die Konfiguration der Simulation - programmiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. bestätigen Sie die Sicherheitsabfrage
  3. die ZIP-Datei mit den Projektdateien wird sofort gelöscht
  4. die zenon Logic Workbench wird beendet

Beachten Sie:

  • der Runtime-Ordner für das Simulationsprojekt bleibt bestehen
  • die Funktion Rückgängig steht für diese Aktion nicht zur Verfügung,
  • Klick auf Bearbeiten erstellt ein neues Simulationsprojekt

    Interne ID: Projekt löschen

    Bearbeiten

    Nur verfügbar, wenn ein Prozesstreiber gewählt wurde, der Projektname gültig ist und nur ein einzelner Treiber ausgewählt wurde. Nicht verfügbar für Treiber für die Simulator Variable.

    Klick öffnet das Simulationsprojekt in der zenon Logic Workbench. Existiert kein Simulationsprojekt für diesen Treiber, wird dieses automatisch erzeugt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • bei Mehrplatzfähigen Projekten:
    • muss der Treiber auf Änderungen ermöglichen konfiguriert werden, damit das Simulationsprogramm gelöscht werden kann
    • wird das Projekt auf anderen Clients nicht als gelöscht angezeigt solange es nicht synchronisiert wurde;

      der Versuch, ein gelöschtes Projekt vor dem Synchronisieren zu öffnen (Klick auf Bearbeiten), erstellt ein neues Simulationsprojekt

    • kann wie bei Einzelplatzprojekten das Löschen über Änderungen verwerfen nicht mehr rückgängig gemacht werden

attention Achtung

Das Simulationsprojekt wird beim Löschen sofort aus der lokalen Datenbank und der Server-Datenbank entfernt. Diese Aktion kann nicht rückgängig gemacht werden!

Hinweis: Auch das manuelle Löschen der ZIP-Datei bei den Dateien des Treibers führt zum Löschen des Simulationsprojekts. Voraussetzung: Die zenon Logic Workbench für diesen Treiber ist nicht geöffnet. Von dieser Vorgangsweise wird abgeraten!


Verteiltes Engineering

Handbuch -> Treibersimulation -> Simulation - programmiert -> Editor -> Verteiltes Engineering

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Mehrplatzfähigen Projekten werden alle zum Projekt gehörenden, laufenden zenon Logic Workbenches für die Treibersimulation geschlossen beim:

  • Änderungen übernehmen für Module, die bei Änderungen ermöglichen für andere Anwender komplett gesperrt werden, wie Variablen, Treiber und Datentypen
  • Änderungen verwerfen:
    • neue Projekte werden am Server nicht erzeugt
    • Änderungen am Simulationsprogramm gehen verloren
    • in der Server-Datenbank nicht vorhandene Treiberdateien werden auch in der lokalen DB gelöscht
  • Synchronisieren:
    am Simulationsprogramm lokal gemachte Änderungen gehen verloren
  • Aktualisieren der lokalen Version:
    am Simulationsprogramm lokal gemachte Änderungen gehen verloren

attention Achtung

Der Status der ZIP-Datei des Simulationsprojektes darf nicht extra modifiziert werden (Änderungen übernehmen, Änderungen ermöglichen, Änderungen verwerfen Multiuserstatus), um korrektes Änderungen übernehmen und Änderungen ermöglichen des Treibers sicher zu stellen!

Projekt löschen

Bei Mehrplatzfähigen Projekten

  • muss der Treiber auf Änderungen ermöglichen konfiguriert werden, damit das Simulationsprogramm gelöscht werden kann
  • wird das Projekt auf anderen Clients nicht als gelöscht angezeigt solange es nicht synchronisiert wurde;
    • der Versuch, ein gelöschtes Projekt vor dem Synchronisieren zu öffnen (Klick auf Bearbeiten), erstellt ein neues Simulationsprojekt

      Interne ID: Verteiltes Engineering

      Bearbeiten

      Nur verfügbar, wenn ein Prozesstreiber gewählt wurde, der Projektname gültig ist und nur ein einzelner Treiber ausgewählt wurde. Nicht verfügbar für Treiber für die Simulator Variable.

      Klick öffnet das Simulationsprojekt in der zenon Logic Workbench. Existiert kein Simulationsprojekt für diesen Treiber, wird dieses automatisch erzeugt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • kann wie bei Einzelplatzprojekten das Löschen über Änderungen verwerfen nicht mehr rückgängig gemacht werden

attention Achtung

Ein Simulationsprojekt mit dem Status Änderungen ermöglichen kann im Modus Offline nicht gelöscht werden.

Ein in einem Mehrplatzfähigen Projekt offline erzeugtes Simulationsprojekt kann somit nicht mehr gelöscht werden!


Treiber wechseln

Handbuch -> Treibersimulation -> Simulation - programmiert -> Editor -> Treiber wechseln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei einem Treiberwechsel in zenon gilt:

  • Das Simulationsprojekt bleibt erhalten.
  • Allerdings werden alle Ports auf 0 gestellt. Um funktionierende Portnummern zu erhalten, öffnen Sie das Projekt im Editor. Dabei werden automatisch neue Portnummern eingetragen. Portnummern können auch manuell vergeben werden.

attention Achtung

Treiber, die mit einem zenon Logic Projekt über die integrierte Lösung verknüpft sind, können nicht ausgetauscht werden.


XML-Export/Import

Handbuch -> Treibersimulation -> Simulation - programmiert -> Editor -> XML-Export/Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein Projekt im Modus Simulation - programmiert kann per XML exportiert werden. Es kann aber nicht als neues Projekt für einen anderen Treiber importiert werden.

Workaround:

  1. Exportieren Sie die zenon Logic Programme.
  2. Importieren Sie diese in das neue Projekt für den neuen Treiber.
  3. Ersetzen Sie per Suchen und Ersetzen die Variablen.


Treiberkonfiguration

Handbuch -> Treibersimulation -> Simulation - programmiert -> Treiberkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Konfiguration des Treibers stehen Ihnen vier Modi zur Verfügung:

  • Hardware
  • Simulation - zählend
  • Simulation - statisch
  • Simulation - programmiert

Wählen Sie den Modus Simulation - programmiert.

Noch in diesem Kapitel

Status Treibervariable

Zyklischer Abgleich


Status Treibervariable

Handbuch -> Treibersimulation -> Simulation - programmiert -> Treiberkonfiguration -> Status Treibervariable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Zustand der zenon Logic Runtime wird in der Treibervariablen SimulRTState auf Offset 60 abgebildet. Die Variable ist numerisch und kann nicht geschrieben werden. Der Wert informiert über den Status der Runtime:

Bit | Bedeutung | Erklärung
31 | ohne Applikation | Runtime hat kein Programm geladen, das Programm wurde gestoppt oder nicht in die Runtime geladen.
30 | nicht instanziert | Runtime wurde nicht nicht instanziert, zum Beispiel weil die DLL mit er Runtime nicht geladen werden konnte, zu wenig Arbeitsspeicher vorhanden ist, die DLL nicht vorhanden ist oder in falscher Version.
18 | p-code available | p-Code ist gemeinsam mit kompiliertem Code verfügbar, umschalten ist möglich.
17 | compiled code active | Runtime läuft mit kompiliertem Code (sonst: interpretierter p-Code).
16 | compiled code available | Kompilierter Code von C-Compiler ist verfügbar
15 | application is loaded | eine Applikation ist vorhanden, Runtime läuft
14 | cant start - missing handlers | Einige "C" Funktionen fehlen.
13 | active breakpoints installed | Mindestens ein Breakpoint wurde vom Debugger gesetzt.
12 | CT segment exists | Applikation wurde mit der Option "complex variables in separate segment" kompiliert.
11 | Reserved | (Intern, nur für Runtime.)
10 | sysinfo request is available | (Intern, nur für Runtime.)
9 | freeze event production | Binding überträgt keine Events.
8 | single cycle mode | (Intern, nur für Runtime und Debugger.)
7 | Reserved | (Intern, nur für Runtime.)
6 | locked variables | Mindestens eine Variable ist gesperrt.
5 | trigo functions are in degrees | Trigonometrische Funktionen werden in Grad angegeben.
4 | log message(s) in stack | (Intern, nur für Runtime.)
3 | application stopped between 2 progs | Runtime beim Debuggen zwischen zwei Schritten angehalten.
2 | application stopped on SFC breakpt | (Intern, nur für Runtime.)
1 | application stopped on error | Runtime mit schwerwiegendem Fehler angehalten, Neustart nötig.
0 | application is running | TRUE = Applikation ist im Modus "run". FALSE = Applikation pausiert im Modus "cycle to cycle" .

info Info

Die Treibervariable SimulRTState mit Offset 60 zeigt den Status der Runtime am Server an. Das gilt auch dann, wenn die Variable am Standby Server angezeigt wird.


Zyklischer Abgleich

Handbuch -> Treibersimulation -> Simulation - programmiert -> Treiberkonfiguration -> Zyklischer Abgleich

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Simulationen laufen im Netzbetrieb auf Server und Standby-Server unabhängig voneinander ab. Beim Start des Standby-Servers erfolgt ein Abgleich mit dem Server, allerdings:

  • ist dieser erste Abgleich um die Paketlaufzeit verschoben
  • führen geringe Unterschiede in der Ausführung zu wachsender Divergenz

Damit wird auch der Zustand der simulierten Variablen unterschiedlich. Um diese Unterschiede gering zu halten, nutzen Sie die Funktion Treiber Simulationsabbild an Standby übertragen zum Abgleich des Simulationsabbildes:

  • legen Sie eine neue Funktion an
  • wählen Sie Treiber Simulationsabbild an Standby übertragen

  • ein Dialog zur Auswahl der Treiber öffnet sich

  • in der Liste sind alle prozessgekoppelten Treiber (ausgenommen Simulator) verfügbar (Klick auf Spaltenkopf ändert Sortierung)
  • wählen Sie jene Treiber aus, die abgeglichen werden sollen
  • bei jedem Funktionsaufruf am Standby-Server wird für die ausgewählten Treiber vom Server ein Abbild angefordert

Durch zyklische Aktivierung können die Unterschiede im aktuellen Simulationszustand minimiert werden. Passen Sie das Raster der Ausführung an den Umfang der abzugleichenden Daten an, da dadurch Netz- und Rechnerlast erzeugt wird.

Die Ausführung der Funktion ist fix auf Standby eingestellt und kann nicht geändert werden. Sie erfolgt nur wenn:

Interne ID: Zyklischer Abgleich

Standby

Nur verfügbar in redundanten Netzwerk-Projekten:
Die Funktion wird auf dem Standby-Server des Projekts ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zyklischer Abgleich

Ausführung

Nur verfügbar in Netzwerk-Projekten:
Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Rechner Standby-Server ist
  • der Server online ist
  • das Projekt ein Netzwerkprojekt ist
  • Treiber zum Abgleich ausgewählt wurden

Um die Auswahl der Treiber zu ändern

  • klicken Sie in den Eigenschaften des Treibers in der Gruppe Allgemein in die Eigenschaft Parameter

    Interne ID: Zyklischer Abgleich

    Parameter

    Übergabeparameter der Funktion; hängt vom Typ der Funktion ab.
    Abhängig vom Typ der Funktion wird der entsprechende Parameterdialog geöffnet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Zyklischer Abgleich

    Allgemein

    Allgemeine Eigenschaften für die Funktion.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Dialog zur Auswahl der Treiber öffnet sich


zenon Logic Workbench

Handbuch -> Treibersimulation -> Simulation - programmiert -> zenon Logic Workbench

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Simulation - programmiert wird in der zenon Logic Workbench programmiert, die eng mit dem zenon Editor zusammenarbeitet. Für die Simulation werden (im Unterschied zur integrierten Lösung) nur die Variablen eines Treibers zwischen den Editoren ausgetauscht.

Definition der auszutauschenden Variablen

Beim Start der zenon Logic Workbench werden alle Variablen des Treibers, die in zenon Logic noch nicht vorhanden sind, als globale Variablen angelegt. Bei diesen ist automatisch die Einstellung Symbol einbetten aktiviert.

Sichtbarkeit

Wird in der Workbench eine neue Variable im Bereich global oder retain definiert, ist diese erst nur in zenon Logic sichtbar. Um Sie auch in zenon sichtbar zu machen, muss die Option Symbole einbetten aktiviert werden. Ab diesen Moment wird die Variable von beiden Editoren aus aktualisiert.

Wird bei der Variablen die Option Symbol einbetten deaktiviert, wird die Variable im zenon Editor gelöscht. Dieses Verhalten ermöglicht es, in zenon Logic globale bzw. retain Variablen zu definieren, die für zenon nicht sichtbar sind.

Für eine durch die zenon Logic Workbench in zenon neu erzeugte Variable, wird versucht, als Bereich SPSMERKER zuzuordnen. Falls der zenon Treiber den konfigurierten Datentyp bei dieser nicht unterstützt, wird der erste Datenbereich gesucht welcher den Datentyp unterstützt. Wird kein Bereich gefunden, kann die Variable nicht angelegt werden.

Eine Variable ist nur gesperrt, wenn es sich um ein Mehrplatzfähiges Projekt handelt und dieses noch nicht den Status Änderungen ermöglichen hat.

Projekteinstellungen

Einige Einstellungen unter Projekt -> Projekt-Parameter... -> Weitere Optionen -> Erweitert in zenon Logic haben Einfluss auf die Funktionalität der Simulation.

Einstellungen Erweitert

Beschreibung

Runtime: Ausführungsmodus

Empfehlung:

Modus: getriggert

Zykluszeit: 1/4 bis 1/3 der Treiberaktualisierungszeit
Zu häufige Wertänderungen an simulierten Variablen führen zu einer erhöhten Rechnerauslastung.

Compiler/Optionen: Symbole aller Variablen einbetten

Empfehlung: Deaktivieren.
Aktiv: Daten für eine Variable werden ausgetauscht, da durch den Symbolnamen die Zuordnung in der Runtime erfolgt.

Aber: Änderungen an der Projektierung der Variablen werden zwischen zenon und zenon Logic nicht aktualisiert. Onlinechange ist nicht mehr möglich.

Compiler/Optionen: Groß-/Kleinschreibung der Symbole beibehalten

Ohne Auswirkung: In der Runtime werden Variablennamen immer auf Großschreibung konvertiert.

Compiler/Optionen: Statusbits für Variablen mit Profil anlegen

Aktiv: Im Simulationsprogramm wird der Status der Variablen simuliert bzw. wird darauf reagiert.

„C" Compiler

Nativer Code wird unterstützt.

Name der DLL, die den kompilierten Code enthalten muss: t5app.dll.


Runtime

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Funktionalität

Runtime-Dateien

Datenaustausch

Datenhaltung

Redundanz

Status

Start/Stopp

Treiberkommandos

Variablenzuordnung

Zeitstempel


Funktionalität

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Funktionalität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Logic Runtime stellt folgende Funktionalitäten zur Verfügung:

  • Dateitransfer
  • Datentypen:
    • BOOL
    • BYTE
    • DINT
    • DWORD
    • INT
    • LINT
    • LREAL
    • REAL
    • SINT
    • STRING
    • TIME
    • UDINT
    • UINT
    • USINT
    • WORD
  • zenon Arrays (siehe auch Arrays und Simulation)
  • Datumsstempel/Zeitstempel
  • Digitale Werteaufzeichnung
  • Dynamisch angebundene Funktionsblöcke, abgelegt in t5block*.dll
  • Hot restart
  • Logging:
    • Tracemeldungen vom Programm (printf)
    • Fehlermeldungen der Runtime
    • alle an Workbench und an Diagnose Server
  • Maschinencode: Native compiled code mit C-Postcompiler (unter Windows CE nicht verfügbar)
  • Online change
  • Programmiersprachen: AWL, AS, FUP, KOP, ST
  • Retain Daten (remanente Daten)
  • Spezielle Funktionsblöcke und Features:
    • Datenserialisierung
    • dynamische Speicherbelegung
    • eingebettete Rezepte
    • eingebettete Variablenliste
    • File Management
    • Files
    • Mathe
    • Random
    • Signale
    • Stringtabellen
    • Trigometrie
    • Zeit
  • Spontane Kommunikation:
    • Wertänderungen als Event
    • 16 Verbindungen
    • Hysterese
  • UDP & TCP/IP für IEC-Sprachen
  • Variablen-Verriegelung

Noch in diesem Kapitel

Arrays und Simulation


Arrays und Simulation

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Funktionalität -> Arrays und Simulation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um mehrdimensionale Arrays bei der Treibersimulation simulieren zu können, müssen SIe in der zenon Logic Workbench die Eigenschaft Komplexe Variable in eigenem Segment speichern" aktivieren.

Arrays mit Startindex 1

Wenn bei einer Simulation Arrays mit Startindex 1 vorkommen, werden diese Arrays in der zenon Logic Workbench mit einem Index mehr erzeugt.

Example Beispiel

Eine Array verfügt in zenon über die Indizes 1 bis 4. Diese Array besitzt in der zenon Logic Workbench die Indizes 0 bis 4.

Dadurch wird sichergestellt, dass in zenon und in zenon Logic die selben Indizes verwendet werden. Der Index 0 wird nicht an den Treiber übertragen.

Wenn Sie Arrays in der zenon Logic Workbench ändern, müssen Sie diesen zusätzlichen Index beachten.


Runtime-Dateien

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Runtime-Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Erzeugen der Runtime-Dateien wird im Runtime-Ordner des Projektes im Pfad \RT\FILES\zenon\custom\drivers ein Unterordner mit dem Namen des Simulationsprojektes erzeugt. In diesem Ordner wird die Datei simulrt.cod mit dem Code der Simulation abgelegt.

Interne ID: Runtime-Dateien

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei erfolgreicher Kompilation in der Workbench und Übertragung in den Runtime-Ordner wird im Ausgabefenster des Editors folgende Meldung ausgegeben:

SIMULRT.COD

Und wenn mit C-Compiler kompiliert, dann zusätzlich:

T5APP.DLL

Remote Transport

Die Runtime-Dateien für die Simulation werden als Unterordner der Treiberdateien erzeugt. Beim Remote Transport wird der Unterordner mit sämtlichen darin enthaltenen Dateien auf den Zielrechner übertragen


Datenaustausch

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Datenaustausch

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Datenaustausch von der zenon Logic Runtime zum Treiber beginnt mit dem 2. Zyklus der zenon Logic Runtime. Damit steht der erste Durchlauf zur Verfügung, um alle Variablen in der Runtime zu initialisieren.

Ein Datenaustausch findet nur statt wenn:

  • die Variable angefordert wird und:
    • noch keinen Wert erhalten hat
    • im Treiber nicht den Status Abgeschaltet (OFF/_VSB_N_UPD) oder Ersatzwert (ALT_VAL/_VSB_AVALUE) hat
    • vom Treiber noch benötigt wird.
    • sich Wert oder Status geändert haben

Der Datenaustausch zum Treiber erfolgt asynchron zum Zyklus der Runtime. Der Treiber durchläuft die Wertänderungen einmal pro Updatezyklus. Alle geänderten Werte - ausgenommen mit Status Abgeschaltet (OFF/_VSB_N_UPD) oder Ersatzwert (ALT_VAL/_VSB_AVALUE) - werden in die Liste der zu aktualisierenden Variablen beim Treiber eingetragen und zur Runtime abgesetzt.

Funktion Treiber Simulationsabbild an Standby übertragen

Diese Funktion wird nur am Standby-Server ausgeführt (Konfiguration siehe Kapitel Zyklischer Abgleich). Am Server, der das Abbild zusammenstellt, werden die Daten synchron vom Treiber geholt. Der Treiber hat dafür 5 Sekunden Zeit. Da die Daten für das Abbild im gleichen Thread erstellt werden, in dem die Simulation läuft, muss sichergestellt sein, dass die Simulation innerhalb von 5 Sekunden abgearbeitet wird. Wird diese Zeit überschritten, wird für diesen Treiber kein Abbild übertragen.

Wertsimulation

Wertänderungen werden nicht sofort übertragen, sondern in einem Puffer abgelegt. Die Größe des Puffers beträgt 8192 Wertänderungen oder die fünffache Anzahl der Variablen, je nachdem welcher Wert größer ist. Die Verzögerung der Übertragung durch den Treiberzyklus kann bis zu 100 ms betragen. Ändert sich der Wert einer Variablen erneut während er auf die Übertragung wartet, werden sofort alle noch nicht übertragenen Werte zur Runtime abgesetzt und dann erst die neuen Werte vorgemerkt. Das kann eine erhöhte Last für Rechner und Netzwerk zur Folge haben, stellt aber sicher, dass alle Werte zur Runtime übertragen werden.

Treiber Schreibbefehl

Wenn die Simulation - programmiert projektiert und aktiv ist, werden die Schreibbefehle am Standby bis zur Runtime durchgereicht.

Schreiboperationen werden vom Treiber asynchron zur Runtime ausgeführt. Der Datenaustausch findet über einen Puffer statt. Die Größe des Puffers beträgt 8192 Wertänderungen oder die fünffache Anzahl der Variablen, je nachdem welcher Wert größer ist.

Schreibbefehle werden nach den Wertänderungen durch die Runtime durchlaufen. Kann ein Schreibbefehl nicht korrekt ausgeführt werden, wird die Fehlermeldung Write queue full! Write command for <DP-Name> lost! angezeigt.

Wenn die Statusbits aktiviert sind, wird durch das Setzen des Status Schreiben erfolgreich angezeigt, dass vom Treiber auf den Wert der Variablen geschrieben wurde. Das Runtime-Programm sollte diesen Status nach dem Bearbeiten des Schreibbefehl wieder löschen. Ein bereits aktives Statusbit verzögert ein erneutes Beschreiben durch den Treiber nicht. Schreibbefehle werden auch ausgeführt, wenn das Runtime-Programm durch einen Breakpoint gestoppt wurde.

Hinweis: Nicht alle Schreibbefehle vom Treiber müssen in der Runtime auch sichtbar werden. Wenn für eine Variable mehrere Schreibbefehle im Puffer sind, wird nur der letzte im Runtime-Programm sichtbar.

Variablen abschalten, auf Ersatzwert schalten

Wird die Variable abgeschaltet oder auf Ersatzwert geschaltet, ist das für die Runtime nicht erkennbar. Wertänderungen, die durch die Runtime ausgeführt werden, werden der Variablen im Treiber nicht zugeordnet. Wird die Variable wieder auf Spontanwert geschaltet bzw. aktiviert, wird auch der aktueller Wert aus der Runtime erneut zum Treiber übertragen. Beim Abschalten des Spontanwerts wird das Status-Bit OFF gesetzt; beim Zurückschalten auf Spontanwert wird das OFF-Bit zurückgesetzt.


Datenhaltung

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Datenhaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Retain Daten

Retain Daten werden in der Datei SimulRt<TreiberID>.ret abgelegt. Pro Simulation wird eine solche Datei erzeugt, sofern Retain-Variablen vorhanden sind. Die Datei wird beim Abgleich im Netzwerk berücksichtigt.

Treiber remanent

Die Einstellung Simulation - programmiert beim Treiberstart ist kein Kriterium, um das remanente Variablenabbild zu restaurieren.


Redundanz

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Redundanz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Start am Standby-Server

Läuft der Treiber am Standby-Server bereits, dann sollte auch das Abbild für die Simulation schon zur Verfügung stehen. In diesem Fall wird die Simulation mit diesem Abbild „Hot" gestartet. Bei fehlendem Abbild erfolgt ein Warmstart.

Funktion Treiber Simulationsabbild an Standby übertragen

Diese Funktion wird nur am Standby-Server ausgeführt (Konfiguration siehe Kapitel Zyklischer Abgleich). Am Server, der das Abbild zusammenstellt, werden die Daten synchron vom Treiber geholt. Der Treiber hat dafür 5 Sekunden Zeit. Da die Daten für das Abbild im gleichen Thread erstellt werden, in dem die Simulation läuft, muss sichergestellt sein, dass die Simulation innerhalb von 5 Sekunden abgearbeitet wird. Wird diese Zeit überschritten, wird für diesen Treiber kein Abbild übertragen.

Abgleich

Zusätzlich zu den Programmdateien der Simulation werden auch abgeglichen:

  • Retaindaten (*.ret)
  • alle *.simul Dateien
    Diese Dateiendung wird vom Simulationsprogramm für simulationsspezifische Dateien erzeugt und im Ordner mit der Rechnerbezeichnung unterhalb des Runtime-Ordners abgelegt.

    Interne ID: Redundanz

    Runtime-Ordner

    Verzeichnis für die Runtime-Dateien des Projekts.
    In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
    Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

    Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Status

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Status

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Statussimulation

Für die Statussimulation muss in zenon Logic unter Projekt -> Projekt-Parameter -> Erweitert -> Compiler -> Optionen -> Statusbits für Variablen mit Profil anlegen aktiv sein. Wird der Status einer Variablen modifiziert, löst dies die Übertragung der Variablen zum Treiber aus.

Die Änderung an folgenden Status löst keine Wertaktualisierung im Treiber aus und wird auch nicht aus der Simulation übernommen:

  • Echtzeit extern (T_EXTERN/_VSB_RT_E)
  • Echtzeit intern (T_INTERN/_VSB_RT_I)
  • Winterzeit (T_STD/_VSB_WINTER)
  • Schreiben bestätigen (WR_ACK/_VSB_WR_ACK)
  • Schreiben erfolgreich (WR_SUC/_VSB_WR_SUC)
  • Normalzustand (NORM/_VSB_NORM)
  • Abweichung Normalzustand (N_NORM/_VSB_ABNORM)
  • Select im Netzwerk (NET_SEL/_VSB_SELEC)
  • Laufzeitüberschreitung (TIMEOUT/_VSB_RTE)
  • In Bearbeitung (PROGRESS/_VSB_DIREC)
  • Abgeschaltet (OFF/_VSB_N_UPD)
  • Ersatzwert (ALT_VAL/_VSB_AVALUE)

info Info

Das Statusbit Schreiben erfolgreich (WR_SUC/_VSB_WR_SUC) steht im Runtime-Programm zur Verfügung und kann zurückgesetzt werden, um erfolgreiches Schreiben anzuzeigen.

Allerdings löst das Zurücksetzen alleine nicht das Übertragen zur zenon Runtime aus. Nur Wertänderungen werden vom Treiber zur Runtime geschickt.

Speziell behandelte Statusbits

Die folgenden Statusbits schließen sich gegenseitig aus:

Bit

Beschreibung

17: Spontan
(SPONT/_VSB_SPONT)

Status SPONTAN wird gesetzt. Dies ist auch der gesetzte Status, wenn die Statusbehandlung abgeschaltet ist oder kein Status definiert wurde. Status GI + INVALID wird gelöscht.

18: Ungültig
(INVALID/_VSB_I_BIT)

Status INVALID wird gesetzt. Status SPONTAN + GI wird gelöscht.

16: Generalabfrage
(GI/_VSB_GR)

Status Generalabfrage wird gesetzt. Status SPONTAN + INVALID wird gelöscht.

8: Select im Netzwerk
(NET_SEL/_VSB_SELEC)

Wenn dieses Statusbit aktiv ist (BSO Aktivierung/Deaktivierung), werden folgende Statusbits für eine Änderungserkennung mit 0 angenommen und auch als 0 zum Treiber übertragen:

  • Select im Netzwerk (NET_SEL)
  • Übertragungsursache (COTx)
  • Select (SE_870)
  • N_CONF (P/N-BIT)
  • Test-BIT (TEST)
  • Schreiben erfolgreich (WR_SUC)

Select before operate (SBO)

Damit auf Select Before Operate reagiert werden kann, muss im Runtime-Programm die Statussimulation verfügbar sein. Der Ablauf für Select Before Operate wird im Runtime-Programm festgelegt.

Interne ID: Status

Select Before Operate

Achtung: Diese Funktionalität wird nur von den Treibern IEC870, IEC850 und DNP3 unterstützt und nur, wenn in der Befehlsgabe für die Eigenschaft Aktionstyp Doppelbefehl gewählt wurde.

Interne ID: Status

Aktionstyp

Nur verfügbar bei der Aktion 'Befehl':
Typ des Befehls.
Doppelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand'.
Einzelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand' Nach der 'Flankenverzögerung' wird der Wert 0 geschrieben. Dieses Schreiben ist nicht mehr Laufzeit überwacht.
Default: Einzelbefehl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Bevor der Wert der Variablen in die Hardware geschrieben wird, fragt zenon ab, ob die Variable in der Hardware für die Aktion bereit ist = Select before Operate (SBO).
Achtung: Bei Einzelbefehlen wird dann das automatische Zurücksetzen des Variablenwerts nach der in der Eigenschaft Flankenverzögerung definierten Zeitspanne nicht ausgeführt.

Interne ID: Status

Flankenverzögerung

Nur verfügbar, wenn bei der Eigenschaft Aktionstyp Einzelbefehl gewählt wurde.
Nach Ablauf dieser Zeit in Millisekunden wird der Wert der Befehlsvariable - abhängig von der Schaltrichtung - auf 0 oder 1 zurückgesetzt. Das Zurücksetzen des Wertes wird nicht ausgeführt, wenn die Eigenschaft Select Before Operate der Aktionsvariable aktiviert wurde.
Minimum: 0
Maximum: 4294967295
Default: 1000
Achtung: Es wird nicht gewartet, bis die Laufzeitüberwachung beendet ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Inaktiv: Der Wert der Variable wird ohne vorherige Rückfrage in die Hardware geschrieben = Direct execute.
Default: inaktiv
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktivierung

Wenn zum Treiber ein SBO select gesendet wird, löst dies für die Runtime ein Werteschreiben mit dem Status Select im Netzwerk (NET_SEL) + Übertragungsursache (COT_act) aus.

Im Runtime-Programm muss ein entsprechender SBO-Ablauf implementiert sein und starten.

Das Statusbit Select im Netzwerk (NET_SEL) muss im Runtime-Programm zurückgesetzt werden.

Deaktivierung

Die Deaktivierung löst ein Werteschreiben mit dem Status Select im Netzwerk (NET_SEL) + Übertragungsursache (COT_deact) aus.

Im Runtime-Programm muss der SBO-Ablauf entsprechend beendet werden.

Das Statusbit Select im Netzwerk (NET_SEL) muss im Runtime-Programm zurückgesetzt werden.


Start/Stopp

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Start/Stopp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Treiber-Start

Die Werteaktualisierung beginnt am Standby-Server erst, wenn der Treiber von seinem Server das Prozessabbild erhalten hat. Das Abbild muss innerhalb des Modultimeouts eintreffen, sonst startet der Treiber ohne Abbild. Wenn sich der Standby-Server innerhalb der Wartezeit zum Server hochstuft, wird das Warten ebenfalls beendet. Treiber, die bei einem Serverprojekt oder ohne Netzwerk starten, haben keine Wartezeit. Dieses Verhalten gilt sowohl für die Simulation als auch für den Hardware-Modus.

Runtime-Start

Wenn der Treiber die Simulation - programmiert startet, wird im ersten Schritt die DLL mit der Simulations-Runtime geladen. Anschließend wird die Runtime parametriert und das Runtime-Programm startet, sofern es erfolgreich geladen werden konnte.

Ist ein Abbild der Runtime vorhanden, wird die Runtime mit diesem Hot gestartet. Sonst wird ein Warmstart ausgeführt. Ist das ebenfalls nicht möglich, wird versucht die Runtime Kalt zu starten. Ist kein gültiges Programm vorhanden, läuft die Runtime gestoppt hoch. Der Status aller Variablen wird auf INVALID gesetzt.

Das Simulationsprogramm läuft in einem eigenen Thread und ist somit völlig unabhängig vom Treiberzyklus.

info Info

Retain Variablen

Retain Daten enthalten nur den Wert der zenon Logic Variablen, nicht deren Status. Das bedeutet für den Start:

  • Warmstart: Der Status, der für eine Variable gesetzt wurde, wird wieder hergestellt - unabhängig davon, ob es sich um eine Retain Variable handelt oder nicht.
  • Kaltstart mit Retain Variablen: Nur der Wert der Retain Variablen in zenon Logic wird wieder hergestellt, nicht der Status.

Runtime stoppen

Wird die Runtime gestoppt, wird bei allen Variablen der Status INVALID gesetzt. Variablen, die angefordert werden, während die Runtime gestoppt ist, erhalten als Initialisierung den Status INVALID. Die Runtime sichert die Daten für den Warmstart und Online Change:

  • SIMULRT.HOT: enthält die Daten für den Hot-Restart.
  • SIMULRT.UPD: enthält die Daten für den Online Change.

Diese beiden Dateien werden im Ordner des Runtime-Programms erzeugt. Die Runtime muss Schreibberechtigung auf diesen Ordner besitzen.

Nachladen

  • Erneute Kompilierung des Simulationsprojektes:
    Führt zum Nachladen des entsprechenden Treibers.
  • Modifikation des Modul-Timeouts:
    Wird von der Runtime nicht als Änderung erkannt und bewirkt kein Nachladen der Treiber.

Die Standardimplementierung im Treiberkit löst beim Nachladen des Simulationsprojektes einen Hotrestart der Runtime aus. Ist dieser nicht möglich (z.B. weil das Programm unterschiedlich ist), wird ein Kaltstart mit retain ausgeführt.

Entladen der Runtime

Wenn die Runtime läuft, wird diese gestoppt. Bevor die Runtime entladen wird, werden noch alle ausstehenden Wertaktualisierungen an den Treiber übergeben. Erst dann wird die Runtime freigegeben und am PC die SimulRuntime.dll entladen.


Treiberkommandos

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Treiberkommandos

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Treiberkommandos dienen dazu, Treiber über zenon zu beeinflussen, z. B. starten und stoppen.
Die Projektierung erfolgt über die Funktion Treiber Kommandos.

Treiber stoppen/starten

Wird im Modus Simulation - programmiert der Treiber gestoppt, hat dies das Entladen der Runtime zur Folge. Alle Variablen bekommen den Status INVALID. Beim Neustart des Treibers wird die Simulation neu geladen und die Runtime gestartet.

Treiber Hardware/Simulation umschalten

Bei der Umschaltung zwischen den Modi Harware und Simulation verhält sich ein Treiber entsprechend diesem Schema:

  1. Wurde der Treiber im Editor für den Hardwaremodus konfiguriert:
    • wird der Treiber nach Ausführung der Funktion Treiberkommando mit dem Parameter Treiber in Simulationsmodus in den Modus Simulation statisch versetzt.
  2. Wurde der Treiber im Editor für einen der Simulationsmodi (statisch, zählend, programiert) konfiguriert:
    • wird der Treiber nach Ausführung der Funktion Treiberkommando mit dem Parameter Treiber in Hardwaremodus in den Hardwaremodus versetzt und kommuniziert mit der Steuerung
    • wechselt der Treiber anschließend nach Ausführung der Funktion Treiberkommando mit dem Parameter Treiber in Simulationsmodus zurück zum konfigurierten Simulationsmodus


Variablenzuordnung

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Variablenzuordnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Zuordnung der zenon Treiber zu den zenon Logic Variablen erfolgt über den auf Großbuchstaben konvertierten Namen. Wenn die zenon Runtime vom Treiber eine Variable anfordert, gibt dieser sie an die Simulation weiter. Ist keine Simulation geladen, erhält die Variable bei gestopptem Treiber den Status abgeschaltet ( OFF/VSB_N_UPD), sonst den Status ungültig (INVALID/_VSB_I_BIT). Variablen vom Treiber-Objekttyp Treibervariable werden von der Simulation nie angefordert.


Zeitstempel

Handbuch -> Treibersimulation -> Simulation - programmiert -> Runtime -> Zeitstempel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Verwendung der Zeitstempelung muss in zenon Logic der Eintrag Projekt -> Projekt-Parameter -> Erweitert -> Compiler -> Optionen ->Statusbit für Variablen mit Profil anlegen aktiv sein.

Wenn im Runtime-Programm das Datum für eine Variable gesetzt wird, wird der Wert von Datum und Zeit als Zeitstempel verwendet. Immer, wenn sich Datum bzw. Zeit einer Variablen zum letzten Zyklus ändert, löst dies eine Übertragung der Werte zum Treiber aus. Das gilt auch, wenn sich weder Wert noch Status geändert haben.

Die meisten Treiber übertragen eine neue Zeitstempelung nur dann an die Runtime, wenn sich gleichzeitig auch Wert und/oder Status ändern. Eine Ausnahme ist aber z.B. der IEC870 Treiber, der auch neue Zeitstempel von der Hardware (oder Simulation - programmiert) mit gleichem Wert und gleichem Status zur Runtime überträgt.

info Info

Es muss gewährleistet sein, dass Datum und Zeit stetig steigen. Ist das nicht der Fall, führt das zu Problemen bei der Archivierung. Das Datum muss einen Wert größer/kleiner 0 haben.

Vom Runtime-Programm gestempelte Variablen erhalten den Status Echtzeit extern (T_EXTERN/_VSB_RT_E).

Alle zum Treiber zu übertragende Variablen, die nicht von der Runtime gestempelten wurden, erhalten im Zyklus eine gemeinsame Zeitstempelung. Dadurch wird sichergestellt, dass die Zeit jener der Änderung entspricht. Diese Treiber erhalten den Status Echtzeit intern (T_INTERN/_VSB_RT_I).

Datum & Zeit

Für alle Datums- und Zeitangaben gilt:

  • Zeiten entsprechen der UTC.
  • Alle Zeiten müssen zwischen dem 02. 01. 1970 und 2038 liegen.
  • Die Konvertierung des Datums in einen String erfolgt im Format YYYY/MM/DD.
  • Die Zeit wird in das Format HH:MM:SS konvertiert.


Hinweise zu Variablen in Simulationsprojekten

Handbuch -> Treibersimulation -> Simulation - programmiert -> Hinweise zu Variablen in Simulationsprojekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen und Modifizieren von Variablen in Simulationsprojekten gilt:

  1. zenon Logic

    Wenn Variablen für ein Simulationsprojekt in der zenon Logic Workbench erstellt werden, verfügen Sie noch über keine gültige Adressierung für die Kommunikation. Wird die Kommunikation auf Hardware umgeschaltet, kann die Kommunikation unterbrochen werden, wenn die neuen Variablen ohne korrekt angepasste Adressierung in Bildern verwendet werden.

  2. Umbenennen

    Wird eine Variable in einem Simulationsprojekt umbenannt, ändert sich auch der Name der Variablen in zenon entsprechend. So müssen zum Beispiel Namen von Variablen, die in einem VBA-Projekt verwendet werden, auch im VBA-Code angepasst werden.

  3. Integrierte Lösungen

    Variablen von integrierten Lösungen wie zenon Logic, IEC 870 oder IEC 850 dürfen im Simulationsprojekt nicht umbenannt werden. Die Variablen verlieren in diesem Fall ihre Projektinformationen.
    Zum Beispiel: Wird das Project0/Global/NewVar im Simulationsprojekt umbenannt in myNeVariablenwVar wird es in zenon zu myNewVar. Nach der Umbenennung ist die Kommunikation mit der zenon Logic Runtime unmöglich.

  4. Kommunikation basierend auf Variablenname

    Variablen eines Treibers, der basierend auf Variablennamen kommuniziert, dürfen im Simulationsprojekt nicht umbenannt werden.

  5. Löschen oder Import von Variablen

    Wird eine Variable gelöscht oder importiert während in zenon Logic online change aktiv ist, werden in zenon Logic alle Variablen entfernt und neu eingefügt.

  6. Variablen mit aktivem "embed" Symbol

    Variablen, die in einem Programm vorhanden sind und deren "embed" Symbol aktiv gesetzt wurde, sind über die Shared Memory Schnittstelle nicht in zenon vorhanden. Wird eine Variable mit aktivem "embed" Symbol vom Global-Bereich in ein Programm verschoben, dann wird dabei die Variable in zenon gelöscht.


Fehlermeldungen

Handbuch -> Treibersimulation -> Simulation - programmiert -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehlermeldungen im zenonEditor:

Fehlermeldung

Ursache und Lösung

Der gewählte Name wurde bereits bei einem anderen Treiber verwendet, oder enthält ungültige Zeichen! Bitte wählen Sie einen anderen Namen.

Der neue Name des Simulationsprojekts wird bereits im Projekt verwendet oder ist nicht gültig.

  • Vergeben Sie einen gültigen Namen

Das Simulationsprojekt vom Treiber <Dateiname>/<Bezeichnung> ist nicht kompiliert und kann damit nicht genutzt werden! Bitte kompilieren Sie das Projekt in der Workbench.

Für den Treiber steht ein Simulationsprojekt zur Verfügung. Dieses wurde aber nicht kompiliert.

  • starten Sie die zenon Logic Workbench mit dem Simulationsprojekt dieses Treibers
  • kompilieren Sie das Projekt

Tipp: Ob die Simulation bei den Treibereinstellungen auf Simulation - programmiert eingestellt ist, hat keine Auswirkung

Write queue full! Write command for <Name Variable> lost!

Zeigt den Verlust eines Schreibbefehl an.


Variablen

Handbuch -> Variablen

Variablen, auch Prozessvariablen oder Datenpunkte genannt, sind die Schnittstelle zwischen der Datenquelle (SPS, Feldbus etc.) und zenon. Sie repräsentieren bestimmte Messwerte oder Zustände auf der Hardware einschließlich Eigenschaften wie Skalierung, Grenzwerte etc.

Variablen werden in der zentralen Variablenliste eines Projekts verwaltet und parametriert und sind dort von überall (Funktionen, Bilder, Archivierung etc.) zugänglich. In sogenannten Integrations- bzw. Dachprojekten kann auch auf Variablen von untergeordneten Projekten zugegriffen werden.

Eine Variable basiert immer auf zwei Komponenten: Datentyp und Treiber-Objekttyp. Beide Komponenten sind voneinander unabhängig und können daher getrennt konfiguriert werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Variable neu... | Öffnet Assistent zur Erstellung einer neuen Variablen.
XML exportieren alle... | Exportiert alle Einträge in XML-Datei.
XML importieren... | Importiert Einträge aus XML-Datei.
Erweiterter Import/Export | Öffnet Dropdownliste mit vordefinierten Import-/Exportformaten.
Nicht verwendete Variablen anzeigen | Erstellt Projektanalyse für nicht verwendete Variablen im aktuellen Projekt und zeigt diese als Ergebnisliste in einem eigenen Fenster an.
In neuem Fenster öffnen. | Öffnet ein eigenes Fenster für Ansicht und Bearbeitung der Variablen. (Default am unteren Rand des Editors.)
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Jeder Variablen können eigene Attribute zugeordnet werden. Insgesamt sind 64 Status/Attribute definiert.

Noch in diesem Kapitel

Variablen Detailansicht Symbolleiste und Kontextmenü

Benennung von Objekten

Datentypen

Treiber

Variablen erstellen, modifizieren und nutzen

Vererbungskonzept

Wertberechnung

Grenzwerte

Reaktionsmatrizen

Funktionen für Variablen

Bild Variablen-Diagnose

Maßeinheitenumschaltung


Variablen Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Variablen -> Variablen Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste

Nr. | Symbol | Aktion
01 | Variable neu | Öffnet den Dialog zur Erstellung einer neuen Variablen.
02 | Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
03 | Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
04 | Löschen | Löscht ausgewählte Einträge.
05 | Standard-Funktion erzeugen | Öffnet den Assistenten zur Auswahl der Variablen und Sollwerte und erstellt eine passende Funktion. Die Aktion wird im Ausgabefenster dokumentiert.
06 | Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
07 | Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
08 | Text in Grenzwert ersetzen | Öffnet Dialog zur Auswahl der Dynamischen Eigenschaft und in Folge den Dialog zum Suchen und Ersetzen.
09 | Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
10 | Alle erweitern | Dropdownliste, um alle oder ausgewählte Knoten zu erweitern oder zu reduzieren.
11 | Aktivieren | Aktiviert ausgewählte Elemente einer Strukturvariablen.
12 | Deaktivieren | Deaktiviert ausgewählte Elemente einer Strukturvariablen.
13 | Alle aktivieren | Aktiviert alle inaktiven Elemente einer Strukturvariablen.
14 | Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
15 | XML importieren | Importiert XML-Dateien.
16 | S7-Projekt importieren | Importiert ein Simatic S7 Projekt.
17 | Aktivieren | Aktiviert oder deaktiviert erweiterte Filtereinstellungen.
18 | Zurück zu Ausgangselement springen | Ist man über die Funktion verknüpfte Elemente in die Liste gelangt, führt das Symbol zurück zum Ausgangselement. Im Kontextmenü nur vorhanden, wenn als verknüpftes Element geöffnet.
19 | Filter entfernen | Entfernt alle Filtereinstellungen.
20 | Hilfe | Öffnet die Online-Hilfe.

Kontextmenü

Menüpunkt | Aktion
Variable neu | Öffnet den Dialog zur Erstellung einer neuen Variablen.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Standard-Funktion erzeugen | Öffnet den Dialog zur Auswahl der Variablen und Sollwerte.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Text in Grenzwert ersetzen | Öffnet Dialog zur Auswahl der Dynamischen Eigenschaft und in Folge den Dialog zum Suchen und Ersetzen.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Knoten erweitern/reduzieren | Öffnet ein Submenü zum Erweitern und Schließen der Knoten.
Alle aktivieren | Aktiviert alle inaktiven Elemente einer Strukturvariablen.
Aktivieren | Aktiviert ausgewählte Elemente einer Strukturvariablen.
Deaktivieren | Deaktiviert ausgewählte Elemente einer Strukturvariablen.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Erweiterter Import/Export | Öffnet Menü für Import und Export von S7-Projekten, dBase und csv.
Variablenverwendung | Erstellt Projektanalyse der ausgewählten Variablen im aktuellen Projekt und zeigt diese als Ergebnisliste in einem eigenen Fenster an.
Erweiterter Filter | Öffnet Submenü zum Aktivieren und Deaktivieren von Filter bzw. zum Entfernen aller Filtereinstellungen.
Verknüpfte Elemente | Zeigt mit dem Variablen verknüpfte Elemente an.
Hilfe | Öffnet die Online-Hilfe.


Benennung von Objekten

Handbuch -> Variablen -> Benennung von Objekten

Der Name eines Objektes muss in zenon eindeutig sein.

Bei der Benennung wird zwischen Groß- und Kleinschreibung unterschieden. Es können also Variable mit gleichen Namen angelegt werden, die sich nur durch die Groß-/Kleinschreibung eines Buchstabens unterscheiden. Zum Beispiel sind die Variablen test und Test zwei unterschiedliche Variablen.

info Info

Das Zeichen # ist für Variablennamen nicht zugelassen.

Achtung: Gleiche Namen, die sich nur durch Groß-/Kleinschreibung unterscheiden, können im Zusammenhang mit Treibern oder zenon Logic zu Problemen führen bei:

  1. Treiberkonfiguaration:

    Unterscheidet sich die Treiberbezeichnung nur in Groß-/Kleinschreibung, verwenden beide Treiber die gleiche Zuordnungsdatei.

  2. zenon Logic:

    zenon Logic unterscheidet nicht zwischen Groß-/Kleinschreibung. Zwei Variablen, die sich in zenon nur in Groß-/Kleinschreibung unterscheiden, können in zenon Logic nicht verwendet werden. Das betrifft Variablen:

    • für ein zenon Logic Projekt mit zenon Logic Treiber, IEC870 Treiber und IEC850 Treiber
    • die in zenon auf extern sichtbar gestellt werden
    • die einen Treiber zugeordnet sind, für den ein zenon Logic Projekt für Simulation - programmiert erstellt wurde

info Info

Empfehlung: Verwenden Sie eindeutige Objektnamen, die sich nicht nur durch Groß-/Kleinschreibung unterscheiden.


Datentypen

Handbuch -> Variablen -> Datentypen

Jede Variable basiert auf einem Datentyp (IEC Datentyp). Der Datentyp verfügt über dieselben Eigenschaften wie die Variable selbst (Maßeinheit, Signalauflösung, Grenzwerte usw.). Ausgenommen sind treiberspezifischen Eigenschaften wie z.B. die Adressierung der Steuerung. Ein Datentyp ist eine Variablenvorlage ohne Bezug zum Prozess. Dieser Prozessbezug wird erst mit dem Treiber-Objekttyp bei der Variable geschaffen.

Beim Anlegen einer neuen Variable muss ein Datentyp gewählt werden. Dabei werden alle Eigenschaften des Datentyps mit in die Variable übernommen. Die Eigenschaften werden dabei vom zugrunde liegenden Datentyp referenziert, d.h. wenn eine Eigenschaft beim Datentyp geändert wird, ändert sich diese Eigenschaft bei allen Variablen mit, die mit diesem Datentyp erstellt worden sind.

Dass ein Wert referenziert ist, sehen sie am entsprechenden Symbol im Eigenschaften-Fenster.

Diese Vererbung kann auch unterbunden werden. Genaue Informationen darüber finden Sie im Abschnitt Vererbungskonzept.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Einfacher Datentyp neu... | Öffnet Dialog zur Erstellung eines neuen Datentyps.
Strukturdatentyp neu... | Öffnet Dialog zur Erstellung eines neuen Strukturdatentyps.
XML exportieren alle... | Exportiert alle Einträge in XML-Datei.
XML importieren... | Importiert Einträge aus XML-Datei.
Hilfe | Öffnet die Online-Hilfe.

IEC Datentypen:

IEC Datentypen sind von der IEC in der Norm IEC 61131-3 genormte Datentypen. Derzeit unterstützt zenon folgende IEC-Datentypen:

Kurzbezeichnung

Langbezeichnung

Bemerkung/Wertebereich

Anzahl Bits

BOOL

Boolean

Bit: 0/1

1

BYTE

SINT

Short integer

Vorzeichenbehaftetes Byte:

-128 bis 127

8

USINT

Unsigned short integer

Byte: 0 bis 255

8

INT

Integer

Vorzeichenbehaftetes Word:

-32768 bis 32767

16

UINT

Unsigned integer

Word: 0 bis 65535

16

DINT

Double integer

Vorzeichenbehaftetes Double:

-2147483648 bis 2147483647

32

UDINT

Unsigned double integer

Double:

0 bis 4294967295

32

LINT

Long integer

Da zenon den Wertbereich einer 64bit-Zahl nicht halten kann, wird der wirkliche Zahlenbereich auf 52 Bit beschränkt. Vorzeichenbehaftete Zahlen sind im Bereich von –2251799813685248 bis 2251799813685247 möglich. Zahlen ausserhalb dieses Bereiches bewirken einen Über- bzw Unterlauf entsprechend eines 52Bit integer.

Mit voller 64 Bit Auflösung arbeiten in der zenon Runtime folgende Teile:

  1. Das shared memory VBA Interface wenn der Wert in Signalauflösung angegeben.
  2. Das shared memory zenon Logic interface.
  3. Das Treiberkit ist für den gesamten Zahlenbereich von 64 Bit tauglich und somit alle Treiber, sofern der Treiber diesen IEC Datentyp unterstützt. Derzeit sind dies Sample32, Intern und STRATON32.

RGM und Rezepte können selbst einen 52Bit Wert nicht mit voller Genauigkeit speichern.

64 bzw. 52

ULINT

Unsigned long integer

Da zenon den Wertbereich einer 64bit-Zahl nicht halten kann, wird der wirkliche Zahlenbereich auf 52 Bit beschränkt. Vorzeichenlose Zahlen sind im Bereich von 0 bis 4503599627370496 möglich. Zahlen ausserhalb dieses Bereiches bewirken einen Über- bzw Unterlauf entsprechend eines 52Bit integer.

Mit voller 64 Bit Auflösung arbeiten in der zenon Runtime folgende Teile:

  1. Das shared memory VBA Interface wenn der Wert in Signalauflösung angegeben.
  2. Das shared memory zenon Logic interface.
  3. Das Treiberkit ist für den gesamten Zahlenbereich von 64 Bit tauglich und somit alle Treiber, sofern der Treiber diesen IEC Datentyp unterstützt. Derzeit sind dies Sample32, Intern und STRATON32.

RGM und Rezepte können selbst einen 52Bit Wert nicht mit voller Genauigkeit speichern.

64 bzw. 52

REAL

Real numbers

Reale Zahl

32

LREAL

Real numbers

Reale Zahl

64

STRING

Variable-length single byte character string

ASCII String (die max. Stringlänge ist Treiberabhängig).
Die Stringlänge wird Default auf 5 Zeichen gesetzt. Beim Projektieren ist gegebenenfalls die richtige Länge anzugeben.

>= 8xStringlänge

WSTRING

Variable-length

multi-byte character string

Enthält Multi-Byte Strings, zum Beispiel Strings in Unicode Kodierung (UTF-8 etc).
Die Stringlänge wird Default auf 5 Zeichen gesetzt. Beim Projektieren ist gegebenenfalls die richtige Länge anzugeben.

>= NxStringlänge

DATE

Date

IEC-Datum in Schritten von 1 Tag

16

TIME

Duration

Zeitdauer im IEC-Format. IEC-Zeit in Schritten von 1 ms, Ganzzahl mit Vorzeichen

32

TOD

Time of day

Uhrzeit (Tageszeit) in Schritten von 1ms

32

DATE_AND_TIME

Date and time of day

Definiert einen Zeitbereich mit 64 Bit und wird in einem binärcodierten Dezimalformat gespeichert.

64

attention Achtung

In zenon werden die Datentypen DATE, TIME, TOD wie ein Datentyp UDINT im Unix-Zeitformat (vergangene Sekunden seit dem 01.01.1970) behandelt. Der Datentype DATE_AND_TIME entspricht dem Datentyp FLOAT im Unix-Zeitformat. Bei diesem wird die Zeit auf Millisekunden genau - drei Stellen hinter dem Komma - gespeichert. Erst der Treiber wandelt den in zenon verwendeten Datentyp in den entsprechenden Datentyp um und schickt den neuen Wert zur Steuerung.
Nicht alle Treiber unterstützen diese Datentypen. Ob der verwendete Treiber die Datentypen unterstützt, entnehmen Sie der entsprechenden Treiberdokumentation.

Hinweise zur Funktionsweise der Vererbung von Datentyp-Eigenschaften lesen Sie im Abschnitt Vererbungskonzept.

Noch in diesem Kapitel

Datentypen Detailansicht Symbolleiste und Kontextmenü

Arten von Datentypen


Datentypen Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Variablen -> Datentypen -> Datentypen Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Einfacher Datentyp neu | Öffnet den Dialog zum Anlegen eines Einfachen Datentyps.
Struktur-Datentyp neu | Öffnet den Dialog zum Anlegen eines Struktur-Datentyps.
Struktur-Element neu | Öffnet den Dialog zum Hinzufügen eines Struktur Elements zu einem Struktur-Datentyp.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Text in Grenzwert ersetzen | Öffnet Dialog zur Auswahl der Dynamischen Eigenschaft und in Folge den Dialog zum Suchen und Ersetzen.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien.
Erweiterter Import/Export | Öffnet Menü für Import von S/-Projekten, dBase und csv.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Arten von Datentypen

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen

Es gibt prinzipiell zwei unterschiedliche Arten von Datentypen:

  • einfache Datentypen; diese bestehen wiederum aus:
    • vorkonfigurierte einfache Datentypen
    • benutzerdefinierte einfache Datentypen
  • Struktur-Datentypen

Noch in diesem Kapitel

Vorkonfigurierte einfache Datentypen

Benutzerdefinierte einfache Datentypen

Struktur-Datentypen


Vorkonfigurierte einfache Datentypen

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Vorkonfigurierte einfache Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese werden standardmäßig mit zenon ausgeliefert und stehen beim Anlegen einer neuen Variablen sofort zur Verfügung. Sie entsprechen den In der IEC 61131-3 genormten Einfachen Datentypen wie INT, USINT usw. Sie definieren einen festgelegten Wertbereich (fixe Ober- und Untergrenze) mit einer festgelegten Anzahl an Werten. Daher können reelle Zahlen als Gleitkommazahlen nur mit einer bestimmten Genauigkeit abgebildet werden

Die Eigenschaften der Einfachen Datentypen können geändert werden. Der Name dieser Datentypen stimmt mit den Namen der zugrunde liegenden IEC Datentypen überein, dieser und der IEC Datentyp können weder geändert noch gelöscht werden.

Die Datentypen sind in zenon erst sichtbar, wenn ein Treiber im Projekt angelegt ist. Jeder Treiber bringt eine Liste mit den Datentypen mit, die er unterstützt. Ist ein IEC Datentyp nicht in der Datentyp-Liste vorhanden, wird er von keinem der eingebundenen Treiber unterstützt.

Änderungen der Eigenschaften bei den Datentypen wirken sich auf alle damit verknüpften Variablen und auch bei allen damit verknüpften Struktur-Datentypen aus!


Benutzerdefinierte einfache Datentypen

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Benutzerdefinierte einfache Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Datentypen können vom Benutzer selbst angelegt werden. Beim Anlegen wird ein bereits existierender Datentyp verwendet. Alle Eigenschaften dieses Datentyps werden beim Anlegen auf den neuen Datentyp kopiert und können anschließend geändert werden. Es besteht keine Referenz zum ursprünglich zugrunde liegenden Datentyp. Alle Datentypen könne also unabhängig voneinander konfiguriert werden.

Bei den benutzerdefinierten Datentypen können alle Eigenschaften inklusive Namen und IEC Datentyp geändert werden.

attention Achtung

Alle Variablen, die auf einem Datentyp basieren, bei dem der IEC Datentyp geändert wird, müssen eventuelle manuell nachkonfiguriert werden.

Beispiel

Ein IEC Datentyp INT wird in einen IEC Datentyp BOOL geändert. Alle Sollwertgrenzen bei allen Variablen und auch an allen Stellen, wo die Variable verwendet wurde (Bilder), stimmen nicht mehr. Besonders kritisch ist dieser Zustand, wenn die Eigenschaften bei der Variable überschrieben wurden und nicht vom Datentyp referenziert sind!

Beim Anlegen eines neuen benutzerdefinierten Datentyps sollte immer ein Datentyp verwendet werden, der über den selben IEC Datentyp verfügt wie der, den man benötigt.

attention Achtung

Vor dem nachträgliche Ändern des IEC Datentyps wird ausdrücklich gewarnt!
Am IEC Datentyp hängen sehr viele Einstellungen, die manuell nachkonfiguriert werden müssen, wenn der IEC Datentyp geändert wird. (Bsp: Signalbereich, Messbereich, Hysterese, Sollwertgrenzen, nichtlineare Wertanpassung usw...).
Bei einer Änderung des IEC Datentyps müssen alle für diesen Datentyp spezifischen Eigenschaften kontrolliert werden! Teilweise müssen die Eigenschaften vor der Änderung angepasst werden, da z.B. bei einer BOOL Variable die Signalauflösung und der Messbereich nicht mehr verändert werden können.

Noch in diesem Kapitel

Anlegen eines neuen benutzerdefinierten Datentyps

Ändern der Eigenschaften eines benutzerdefinierten Datentyps

Löschen eines benutzerdefinierten Datentyps


Anlegen eines neuen benutzerdefinierten Datentyps

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Benutzerdefinierte einfache Datentypen -> Anlegen eines neuen benutzerdefinierten Datentyps

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Öffnen Sie den Knoten Variablen und klicken Sie auf Datentypen.

Nun werden in der Liste der Detailansicht alle bereits existierenden Datentypen aufgelistet. Beim ersten Aufschalten sind nur die vordefinierten Datentypen vorhanden, die mit den IEC Datentypen namentlich übereinstimmen. Ein benutzerdefinierter Datentyp ist immer auf einem IEC Datentyp aufgebaut. Klicken Sie nun mit der rechten Maustaste in die Liste und klicken Sie im Kontextmenü auf Einfachen Datentyp erstellen....

In der nun erscheinenden Dialogbox geben Sie den Namen des benutzerdefinierten Datentyps ein und wählen einen bereits existierenden Datentyp aus. Dieser Datentyp dient als Vorlage für den neu erstellten Datentyp. Alle Eigenschaften werden dabei in den neuen kopiert. Diese können anschließend über das Eigenschaften-Fenster angepasst werden. Es bleibt dabei kein Bezug zum original Datentyp bestehen, von dem die Kopie erstellt wurde.

info Info

Der Name des Datentyps ist auf eine Länge von128 Zeichen begrenzt.

Klicken Sie auf Fertig stellen. Der neue benutzerdefinierte Datentyp erscheint nun in der Liste der einfachen Datentypen in der Detailansicht.


Ändern der Eigenschaften eines benutzerdefinierten Datentyps

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Benutzerdefinierte einfache Datentypen -> Ändern der Eigenschaften eines benutzerdefinierten Datentyps

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Änderung der Eigenschaften des benutzerdefinierten Datentyps kann im Eigenschaften-Fenster vorgenommen werden, in dem alle Eigenschaften des Datentyps nun aufgeblendet werden.

Beachten Sie bitte, dass der IEC-Datentyp nicht geändert werden sollte, da sich dadurch die Signalauflösung ändern würde.


Löschen eines benutzerdefinierten Datentyps

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Benutzerdefinierte einfache Datentypen -> Löschen eines benutzerdefinierten Datentyps

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Selektieren Sie den zu löschenden Datentyp in der Liste der Detailansicht und bestätigen Sie die Löschaktion in der folgenden Dialogbox.

attention Achtung

Wird ein benutzerdefinierter Datentyp gelöscht, werden alle Variablen, die auf diesem Datentyp aufgebaut sind, mitgelöscht.


Struktur-Datentypen

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Struktur-Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Struktur-Datentypen sind immer benutzerdefinierte Datentypen. Im Gegensatz zu den einfachen Datentypen, die nur eine flache Variablenliste zulassen, lässt sich mit ihnen eine Struktur aufbauen. Diese Struktur kann auch verschachtelt und sehr komplex sein.

Wenn eine Struktur Variable benötigt wird, muss zuerst ein Struktur-Datentyp angelegt werden. Eine Struktur besteht aus einem Struktur-Namen und Struktur-Elementen. Struktur-Elemente können einfache Datentypen oder wiederum andere Strukturen sein. Struktur-Elemente können auch Arrays (Felder) in maximal drei Dimensionen sein.

attention Achtung

Struktur-Variablen können nur beim Erzeugen angelegt werden. Eine nachträgliche Änderung ist nicht möglich.

Arrays können nur beim Erzeugen angelegt werden. Eine nachträgliche Änderung ist nicht möglich.

Sie müssen beim Erzeugen definieren, ob das Strukturelement den Typ verknüpft oder eingebettet verwendet. Nachträgliche Änderungen sind nicht möglich.

Beispiel für einen Struktur-Datentyp:

In der obigen Abbildung werden zwei Strukturen dargestellt:

Die Struktur Regler besteht aus zwei Struktur Elementen: Drehzahl Soll und einer Drehzahl Ist.

  • Das Struktur Element Drehzahl Ist wurde mit dem Datentyp INT verknüpft, d.h. dass alle Eigenschaften des vordefinierten Datentyps INT in dieses Struktur Element übernommen werden.
  • Das Struktur Element Drehzahl Soll ist in die Struktur eingebettet. Alle Eigenschaften eines Datentyps können daher beim Struktur Element selber eingestellt werden.

Die abgebildete Struktur Motor besteht aus folgenden Struktur Elementen: Leistungsaufnahme, Stromaufnahme, Spannung, Wicklungstemperatur [3] und der Struktur Drehzahl Regelung.

  • Das Struktur Element Leistungsaufnahme ist verknüpft mit dem vordefiniertem Datentyp UINT - alle Eigenschaften werden von UINT übernommen.
  • Das Struktur Element Stromaufnahme hat den Datentyp INT eingebettet - alle Eigenschaften können beim Struktur Element eingestellt werden.
  • Das Struktur Element Spannung ist verknüpft mit dem benutzerdefinierten Datentyp Spannung. Das Element bezieht alle Eigenschaften aus diesem Datentyp.
  • Das Struktur Element Wicklungstemperatur ist ein eindimensionales Array (ein Feld) von drei Elementen vom vordefinierten Datentyp SINT.
  • Das Struktur Element Drehzahl Regelung ist verknüpft mit der Struktur Regler, die bereits oben vorgestellt wurde. Strukturen in einer Struktur können nicht eingebettet werden. Sie sind immer mit der original Struktur verknüpft. Die Struktur enthält demnach zwei weitere Struktur Elemente: Drehzahl Soll und Drehzahl Ist deren Eigenschaften von der Ursprungs-Struktur übernommen werden.

Noch in diesem Kapitel

Anlegen eines Struktur-Datentyps

Einfügen von weiteren Struktur-Elementen

Ändern der Eigenschaften eines Struktur-Elements

Strukturelement verschieben

Löschen eines Struktur-Datentyps


Anlegen eines Struktur-Datentyps

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Struktur-Datentypen -> Anlegen eines Struktur-Datentyps

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

So legen Sie einen Struktur-Datentyp an:

  1. Klicken Sie mit der rechten Maustaste auf einen benutzerdefinierten Datentyp in der Liste und selektieren Sie im Kontextmenü Struktur-Datentyp neu.
  2. In der nun erscheinenden Dialogbox definieren Sie den Namen.

    Hinweis: Der Name des Datentyps ist auf 128 Zeichen begrenzt.

  3. Beenden den Vorgang mit Fertig stellen. Den Namen des Struktur Datentyps können Sie nachträglich im Eigenschaften-Fenster ändern.
  4. Eine Dialogbox wir geöffnet, mit der Sie das erste Struktur-Element erstellen.
  5. Vergeben Sie einen eindeutigen Namen.
  6. Wählen Sie den Datentyp, auf dem Das Element basieren soll, aus. Klick auf die Schaltfläche ... öffnet den Auswahldialog.

    Sie können auch Strukturen als Struktur-Element verknüpfen. Das Einbetten von Strukturen als Struktur-Element ist nicht möglich. Ebenso können Sie nur ganze Strukturen und nicht Teile einer Struktur verknüpfen.

  7. Legen Sie fest, ob der Datentyp eingebettet oder verknüpft werden soll.
  8. Definieren Sie die Array-Dimensionen an.
    Wollen Sie kein Array verwenden, geben Sie die Dimension 0 an.
  9. Beenden Sie den Vorgang mit Fertig stellen.

Einbetten oder verknüpfen

Parameter | Beschreibung
Eingebettete Struktur-Elemente | Können von ihrem Ursprungs-Datentyp unterschiedliche Eigenschaften übernehmen. Die Eigenschaften werden bei jedem Struktur-Element extra eingestellt und dort gespeichert.
Verknüpfte Struktur-Elemente | Übernehmen immer alle Eigenschaften aus dem ursprünglichen Datentyp, von dem Sie abgeleitet sind. Ändert sich der ursprüngliche Datentyp, ändern sich alle davon abgeleiteten verknüpften Struktur-Elemente mit!


Einfügen von weiteren Struktur-Elementen

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Struktur-Datentypen -> Einfügen von weiteren Struktur-Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um weitere Struktur-Elemente einzufügen:

  1. Klicken Sie mit der rechten Maustaste auf den gewünschten Struktur-Datentyp.
  2. Wählen Sie im Kontextmenü Struktur Element neu.
  3. Definieren Sie in der sich öffnenden Dialogbox
    1. eine eindeutige Bezeichnung (Name ist auf 128 Zeichen begrenzt)
    2. die Arraydimensionen und
    3. ob Sie das Struktur Element einbetten oder verknüpfen wollen.

Wenn Sie nun den Struktur-Datentyp in der Detailansicht markieren, werden die existierenden Struktur-Elemente als Unterpunkte angezeigt.


Ändern der Eigenschaften eines Struktur-Elements

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Struktur-Datentypen -> Ändern der Eigenschaften eines Struktur-Elements

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Eigenschaften eines Struktur-Elements zu ändern:

Eingebettetes Struktur-Elemente

  1. Markieren Sie das Struktur-Element in der Detailansicht.
  2. Ändern Sie die gewünschten Eigenschaften im Eigenschaften-Fenster.

Verknüpftes Struktur-Element

Bei verknüpften Struktur-Elementen können im Eigenschaften-Fenster geändert werden:

  • Name
  • Offsets
  • Array-Dimensionen
  • Beschreibung

Alle weiteren Eigenschaften müssen direkt beim Ursprungsdatentyp geändert werden.

attention Achtung

Beachten Sie, dass Änderungen am Datentyp sich unmittelbar auf alle damit verbundenen Variablen und auch auf alle anderen Struktur-Datentypen, die diesen Datentyp verknüpft haben, auswirken!

Änderungen am Datentyp werden nicht empfohlen. Diese müssen mit entsprechender Umsicht vorbereitet und durchgeführt werden. Vor allem bei Einstellungen des IEC Datentyps, des Messbereichs, der Sollwertgrenzen usw.

Unter Umständen müssen alle Variablen und alle Bilder, in denen diese Variablen verwendet werden, manuell nacharbeitet werden!


Strukturelement verschieben

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Struktur-Datentypen -> Strukturelement verschieben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Elemente eines Struktur-Datentyps können per Drag&Drop verschoben werden. Um Elemente zu verschieben:

  1. markieren Sie das gewünschte Elemente
  2. Sie können auch mehrere zusammenhängende Elemente wählen
  3. klicken Sie in die Auswahl und ziehen Sie die Elemente an die gewünschte Stelle

Bei mehrplatzfähigen Projekten wird überprüft, ob der Status des zu verändernden Datentyps auf Änderungen ermöglichen steht oder gesetzt werden kann.

Mehrere Objekte verschieben

Zusammenhängende Elemente können per Drag&Drop verschoben werden. Dabei gilt:

  • Es können nur zusammenhängende Strukturelemente verschoben werden.

  • Wird bei der Mehrfachselektion eine Lücke erkannt, wird die Drop-Aktion verweigert.


Löschen eines Struktur-Datentyps

Handbuch -> Variablen -> Datentypen -> Arten von Datentypen -> Struktur-Datentypen -> Löschen eines Struktur-Datentyps

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Struktur-Datentyp zu löschen:

  1. Klicken Sie mit der rechten Maustaste auf den Struktur Datentyp in der Liste.
  2. Wählen Sie im Kontextmenü Löschen.
  3. Der Struktur-Datentyp wird mit allen seiner Struktur- Elementen gelöscht.

attention Achtung

Beim Löschen werden auch alle Variablen, die auf diesem Struktur-Datentyp basieren, gelöscht!


Treiber

Handbuch -> Variablen -> Treiber

zenon bietet über 300 unterschiedliche Anbindungen an die verschiedensten Steuerungen, Bussysteme und Appliaktionen.

Um mit einer Datenquelle kommunizieren zu können, ist die Anbindung eines Schnittstellentreibers (Protokolltreibers) notwendig. Der Treiber stellt die Verbindung zwischen einer Steuerung und zenon her. Die Datenquelle muss aber nicht unbedingt eine Steuerung sein. Der DDE Treiber kommuniziert mit einem DDE Server, der OPC Client Treiber mit einem OPC Server, Der SNMP Treiber mit SNMP Agents usw.

Es stehen eine Vielzahl von unterschiedlichen Treibern zur Verfügung die auch parallel eingesetzt werden können.

attention Achtung

Unter Windows CE kann immer nur ein Typ eines Treibers gestartet werden.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Treiber neu... | Öffnet Dateiansicht zur Auswahl eines Treibers.
Hilfe | Öffnet die Online-Hilfe.

Beim Anlegen einer neuen Variable muss immer bestimmt werden, auf welchem Treiber die Variable liegen soll.

Die zenon Treiber sind Protokolltreiber. Sie sind nicht zu verwechseln mit Schnittstellentreibern des Betriebssystems (z.B. Treiber für eine LAN Karte oder Treiber für eine Serielle Schnittstelle). Die zenon Treiber bauen immer auf den Schnittstellentreibern des Betriebssystems auf, und kommunizieren über ein entsprechendes Protokoll (z.B. Modbus RTU, MPI, Melsec A usw...), das die jeweilige Steuerung versteht.

Grundlegende Treiber stehen in zenon kostenlos zur Verfügung. Variablen, die auf diesen Treibern basieren werden bei der Berechnung der Lizenzgröße nicht berücksichtigt:

Parameter

Beschreibung

Simulator-Treiber SIMUL32

Für interne Variablen.

Diese können als ausfallsichere Variablen (Harddisk-Daten, remanente Merker) oder als Merkertypen definiert werden; für dynamische Simulation können Merkerobjekte automatisch ihren Wert ändern.

Mathematik-Treiber MATHDR32

Variablen dieses Treibers dienen für Berechnungen von mathematischen Funktionen oder für Schaltspielzähler und Betriebsstundenzähler.

Systemtreiber Sysdrv

Variablen zur Überwachung und Steuerung der Hardware, des Netzwerks und anderer projektspezifischer Eigenschaften.

Intern-Treiber Intern

Benutzerdefinierbare Variablen ohne Verbindung zu einer Steuerung. (Ähnlich den benutzerdefinierten Variablen des Systemtreibers).

Jede Variable hat ihren individuellen Wert. Es ist also nicht möglich, z.B. Bit- oder Byte-Variablen aus einer Integer-Variable zu extrahieren.

Die Projektierungen von Adressinformationen ist nicht notwendig, die betreffenden Eigenschaften können im Eigenschaftenfenster auch nicht bearbeitet werden.

Die genauen Treiberbeschreibungen zu den einzelnen Treibern finden sich in den entsprechenden Treiber-Dokumentationen, die Ihnen über die Online-Hilfe im Kapitel Treiber und auf der Installations-DVD zur Verfügung stehen.

Beim Anlegen eines neuen Treibers bekommen Sie einen Auswahldialog in dem alle zur Verfügung stehenden Treiber enthalten sind. Die Informationen für diesen Dialog sind in den Dateien Treiber_DE.xml, Treiber_EN.xml usw. sprachabhängig gespeichert. Öffnen bzw. bearbeiten können Sie die einzelnen XML-Dateien mit dem Tool driverinfo.exe.

Noch in diesem Kapitel

Treiber Detailansicht Symbolleiste und Kontextmenü

Treiber-Objekttyp

Anlegen eines Treibers

Konfigurieren eines Treibers

Treibersimulation

Treiber austauschen

Treiber löschen

Treibervariablen

Treiber-Dokumentationen


Treiber Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Variablen -> Treiber -> Treiber Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Treiber neu | Öffnet den Dialog zur Erstellung eines neuen Treibers.
Treiber austauschen | Öffnet Auswahlfenster zur Definition eines Treibers.
Löschen | Löscht ausgewählte Einträge nach Rückfrage aus der Liste.
Treiberkonfiguration | Öffnet den Dialog zur Konfiguration des Treibers.
Variablen vom Treiber importieren | Öffnet den Dialog zum Import der Variablen.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile. Steht nur zur Verfügung, wenn Bearbeitung möglich ist.
Text in selektierter Spalte ersetzen | Öffnet einen Dialog, um in der Spalte, die den Fokus hat, nach Zeichen zu suchen und diese automatisiert zu ersetzen.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Alle Filter entfernen | Entfernt alle in der liste aktivierten Filter.
Hilfe | Öffnet die Online-Hilfe.


Treiber-Objekttyp

Handbuch -> Variablen -> Treiber -> Treiber-Objekttyp

Die Treiber-Objekttypen bestimmen, welcher Bereich einer Variablen in der Steuerung angesprochen werden soll. Derzeit verwenden alle Hersteller unterschiedliche Bezeichnungen für die Bereiche in Ihren Steuerungen. In der Siemens Welt gibt es Datenbausteine, Merker, Ein- Ausgänge usw. In der Modbus Welt sind dies Coil und Holding Register. Jeder Treiber stellt intern eine Liste mit den zur Verfügung stehenden Treiber-Objekttypen bereit. Beim Anlegen einer neuen Variablen muss bestimmt werden, welchem Bereich die Variable in der Steuerung zugewiesen ist.

Strikte Trennung zwischen Datentyp und Treiber-Objekttyp

Die strikte Trennung ermöglicht es, eine Struktur als Datentyp völlig treiberunabhängig und damit unabhängig von der Steuerung zu erstellen. Diese Struktur kann dann als Variable beliebigen Treibern zugeordnet werden. Eine Struktur lässt sich so beispielsweise über die entsprechenden Treiber 1:1 mit einer Siemens Steuerung wie auch mit einer Modbus Steuerung verknüpfen.


Anlegen eines Treibers

Handbuch -> Variablen -> Treiber -> Anlegen eines Treibers

Um einen neuen Treiber anzulegen:

  • Klicken Sie mit der rechten Maustaste im Projektmanager auf Treiber und selektieren Sie im Kontextmenü Treiber neu.
  • In der folgenden Dialogbox bietet Ihnen das Programm eine Auflistung aller verfügbaren Treiber an.

  • Selektieren Sie den gewünschten Treiber und vergeben Sie eine Bezeichnung für diesen:
    • Die Treiberbezeichnung muss eindeutig sein, d.h. wird ein und derselbe Treiber mehrmals im Projekt verwendet, so muss jeweils eine neue Bezeichnung vergeben werden.
    • Die Treiberbezeichnung ist Bestandteil des Dateinamens. Daher darf Sie nur Zeichen enthalten, die vom Betriebssystem unterstützt werden. Nicht gültige Zeichen werden durch einen Unterstrich (_) ersetzt.
    • Achtung: Die Bezeichnung kann später nicht mehr geändert werden.
  • Bestätigen Sie den Dialog mit OK. Im folgenden Dialog werden die einzelnen Konfigurationen der jeweiligen Treiber eingestellt.
  • Für ein Projekt müssen nur die jeweils notwendigen Treiber eingebunden werden. Späteres Einbinden eines weiteren Treibers ist problemlos möglich.

info Info

Bei neu angelegten Projekten oder bei bestehenden Projekten, die in eine Version ab 6.21 konvertiert werden, werden die folgenden Treiber automatisch angelegt:

  • Intern
  • MathDr32
  • SysDrv.


Konfigurieren eines Treibers

Handbuch -> Variablen -> Treiber -> Konfigurieren eines Treibers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Modus

Ermöglicht ein Umschalten zwischen Hardware und Simulationsmodus

  • Hardware:

    Die Verbindung zur Steuerung wird hergestellt.

  • Simulation - statisch

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden vom Treiber simuliert. In diesem Modus bleiben die Werte konstant bzw. die Variablen behalten die über zenon Logic gesetzen Werte. Jede Variable hat seinen eigenen Speicherbereich. z.B. zwei Variablen vom Typ Merker mit Offset 79, können zur Laufzeit unterschiedliche Werte haben und beeinflussen sich gegenseitig nicht. Ausnahme: Der Simulatortreiber.

  • Simulation - zählend

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden vom Treiber simuliert. In diesem Modus zählt der Treiber die Werte innerhalb ihres Wertebereichs automatisch hoch.

  • Simulation - programmiert

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden von einem frei programmierbaren Simulationsprojekt berechnet. Das Simulationsprojekt wird mit der zenon Logic Workbench erstellt und läuft in einer in den Treiber integrierten zenon Logic Runtime ab. Details siehe Kapitel Treibersimulation.

Update-Liste im Speicher Halten

Einmal angeforderte Variablen werden weiterhin von der Steuerung angefordert, auch wenn diese aktuell nicht mehr benötigt werden.
Dies hat den Vorteil, dass z.B. mehrmalige Bildumschaltungen nach dem erstmaligen Aufschalten beschleunigt werden, da die Variablen nicht neu angefordert werden müssen. Der Nachteil ist eine erhöhte Belastung der Kommunikation zur Steuerung.

Ausgänge schreibbar

Aktiv: Ausgänge können beschrieben werden.

Inaktiv: Das Beschreiben der Ausgänge wird unterbunden.

Hinweis: Steht nicht für jeden Treiber zur Verfügungen.

Variablenabbild remanent

Diese Option speichert und restauriert den aktuellen Wert, den Zeitstempel und die Status eines Datenpunkts.

Grundvoraussetzung: Die Variable muss einen gültigen Wert und Zeitstempel besitzen.

Das Variablenabbild wird im Modus Hardware gespeichert wenn:

  • einer der Status S_MERKER_1(0) bis S_MERKER8(7), REVISION(9), AUS(20) oder ERSATZWERT(27) aktiv ist

Das Variablenabbild wird immer gespeichert wenn:

  • die Variable vom Objekttyp Treibervariable ist
  • der Treiber im Simulationsmodus läuft. (nicht programmierte Simulation)

Folgende Status werden beim Start der Runtime nicht restauriert:

  • SELECT(8)
  • WR-ACK(40)
  • WR-SUC(41)

Der Modus Simulation - programmiert beim Treiberstart ist kein Kriterium, um das remanente Variablenabbild zu restaurieren.

Am Standby-Server stoppen

Einstellung für Redundanz bei Treibern, die nur eine Kommunikationsverbindung erlauben. Dazu wird der Treiber am Standby-Server gestoppt und erst beim Hochstufen wieder gestartet.

Achtung: Ist diese Option aktiv, ist die lückenlose Archivierung nicht mehr gewährleistet.

Aktiv: Versetzt den Treiber am nicht-prozessführenden Server automatisch in einen Stop-ähnlichen Zustand. Im Unterschied zum Stoppen über Treiberkommando erhält die Variable nicht den Status abgeschaltet, sondern einen leeren Wert. Damit wird verhindert, dass beim Hochstufen zum Server nicht relevante Werte in AML , CEL und Archiv erzeugt werden.

Update Zeit Global

Aktiv: Die eingestellte Globale Update Zeit in ms wird für alle Variablen im Projekt verwendet. Die bei den Variablen eingestellte Priorität wird nicht verwendet.
Inaktiv: Die eingestellten Prioritäten werden für die einzelnen Variablen verwendet.

Priorität

Hier werden die Pollingzeiten der einzelnen Prioritäten eingestellt. Alle Variablen mit der entsprechenden Priorität werden in der eingestellten Zeit gepollt. Die Zuordnung zu den Variablen erfolgt separat bei jeder Variablen über die Einstellungen in den Variableneigenschaften.
Mit den Prioritäten kann die Kommunikation der einzelnen Variablen auf die Wichtigkeit bzw. benötigte Aktualität abgestuft werden. Daraus ergibt sich eine verbesserte Verteilung der Kommunikationslast.

Update Zeit zyklische Treiber

Für zyklische Treiber gilt:

Beim Sollwert Setzen, Advicen von Variablen und bei Requests wird sofort ein Lesezyklus für alle Treiber ausgelöst - unabhängig von der eingestellten Update Zeit. Damit wird sicher gestellt, dass der Wert nach dem Schreiben in der Visualisierung sofort zur Verfügung steht. Update-Zeiten können damit für zyklische Treiber kürzer ausfallen als eingestellt.


Treibersimulation

Handbuch -> Variablen -> Treiber -> Treibersimulation

Wenn bei der Projektierung der dahinterliegende Prozess nicht zur Verfügung steht, kann dieser simuliert und vorab getestet werden. Dazu stehen drei Modi zur Verfügung:

  • Simulation - statisch: konstante vom Treiber simulierte Werte
  • Simulation - zählend: vom Treiber simulierte Werte werden hochgezählt
  • Simulation - programmiert: Werte werden über ein Simulationsprojekt mit zenon Logic berechnet

attention Achtung

Wird der Treiber im Modus Simulation - zählend angehalten, stoppt nur das Zählen. Die Variablen gehen nicht auf gestört. In allen anderen Betriebsarten wird der Treiber wirklich gestoppt.

Hinweis: Simulation - programmiert wird nicht unterstützt von Treibern für:

  • Interne Variablen
  • Mathematik-Variablen
  • Simulator-Variablen
  • System-Variablen

info Info

zenon Variablen, die zenon Logic IO-Variablen repräsentieren, sind im Zustand Treibersimulation programmiert im Projekt nicht verfügbar.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Simulation - statisch

Simulation - zählend

Simulation - programmiert


Simulation - statisch

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - statisch

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei statischer Simulation wird keine Kommunikation zur Steuerung aufgebaut, sondern die Werte werden vom Treiber simuliert. In diesem Modus bleiben die Werte konstant. Werte können durch die Runtime oder den Anwender geändert werden. Bei einem Neustart der Runtime mit Simulation - statisch werden diese Werte aber nicht gespeichert und gehen verloren.


Simulation - zählend

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - zählend

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei zählender Simulation wird keine Kommunikation zur Steuerung aufgebaut, sondern die Werte werden vom Treiber simuliert. In diesem Modus zählt der Treiber die Werte beginnend bei 0 innerhalb ihres Wertebereichs automatisch hoch. Ist der Maximalwert erreicht, beginnt der Zählvorgang wieder bei 0.

info Info

Bei negativen Startwerten beginnt der Zählvorgang erst bei 0.

INT verwendet zum Zählern den Maximalwert von USINT.

attention Achtung

Wird der Treiber im Modus Simulation - zählend angehalten, stoppt nur das Zählen. Die Variablen gehen nicht auf gestört. In allen anderen Betriebsarten wird der Treiber wirklich gestoppt.


Simulation - programmiert

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - programmiert

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Simulation - programmiert wird keine Kommunikation zur Steuerung aufgebaut, sondern die Werte werden von einem frei programmierbaren Simulationsprojekt berechnet. Das Simulationsprojekt wird mit der zenon Logic Workbench erstellt und läuft in der zenon Logic Runtime ab. Es ermöglicht, Status und Zeitstempel von Variablen am Treiber zu modifizieren. Schreibbefehle auf Variablen durch zenon werden an die Simulation weitergegeben, redundante Server und Standby-Server werden synchronisiert. So lassen sich auch komplexe Abläufe simulieren.

Um das Simulationsprogramm zu starten, wählen Sie in der Treiberkonfiguration den Modus Simulation - programmiert.

info Info

Windows CE

Die Simulation - programmiert steht unter Windows CE nicht zur Verfügung.

Noch in diesem Kapitel

Editor

Treiberkonfiguration

zenon Logic Workbench

Runtime

Hinweise zu Variablen in Simulationsprojekten

Fehlermeldungen


Editor

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - programmiert -> Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Projekt anlegen

Projekt löschen

Verteiltes Engineering

Treiber wechseln

XML-Export/Import


Projekt anlegen

Projekt anlegen

Um ein Projekt für die Simulation - programmiert anlegen zu können, muss:

  • ein einzelner Prozesstreiber ausgewählt werden
  • der Projektname gültig sein.

attention Achtung

Simulation - programmiert wird nicht unterstützt von Treibern für:

  • Interne Variablen
  • Mathematik-Variablen
  • Simulator-Variablen
  • System-Variablen

Um ein Simulationsprojekt anzulegen:

  • klicken Sie in der Gruppe Treiber-Simulationsprojekt bei der Eigenschaft Bearbeiten auf Hier klicken->

    Interne ID: Projekt anlegen

    Bearbeiten

    Nur verfügbar, wenn ein Prozesstreiber gewählt wurde, der Projektname gültig ist und nur ein einzelner Treiber ausgewählt wurde. Nicht verfügbar für Treiber für die Simulator Variable.

    Klick öffnet das Simulationsprojekt in der zenon Logic Workbench. Existiert kein Simulationsprojekt für diesen Treiber, wird dieses automatisch erzeugt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt anlegen

    Treiber-Simulationsprojekt

    Beinhaltet alle Eigenschaften für die Konfiguration der Simulation - programmiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • ein neues zenon Logic Projekt wird erzeugt
  • Name und Portnummern für Event-Port und Standard-Port werden automatisch vergeben; ändern Sie diese nach Belieben

    Interne ID: Projekt anlegen

    Standard-Port

    Nur verfügbar, wenn ein Simulationsprojekt erzeugt wurde.

    TCP/IP Port für die Kommunikation mit der zenon Logic Workbench. Die Portnummer muss eindeutig, im Projekt frei und auf dem Rechner, auf dem der Treiber läuft, verfügbar sein. Beim Erzeugen des Simulationsprojektes wird automatisch eine eindeutige Portnummer vergeben.

    Hinweis: Eine automatisch vergebene Portnummer ist nur für das jeweilige Projekt eindeutig. In multihierarchischen Projekten muss diese überprüft werden, um Kommunikationsfehler mit der zenon Logic Workbench/Runtime zu vermeiden.

    Minimum: 6000 (bei automatischer Vergabe, manuell: empfohlen)

    Maximum: 6999 (bei automatischer Vergabe, manuell: empfohlen)

    Default: 6000

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt anlegen

    Event-Port

    Nur verfügbar, wenn ein Simulationsprojekt erzeugt wurde.

    TCP/IP Port für den spontanen Datenaustausch. Die Portnummer muss eindeutig, im Projekt frei und auf dem Rechner, auf dem der Treiber läuft, verfügbar sein. Beim Erzeugen des Simulationsprojektes wird automatisch eine eindeutige Portnummer vergeben.

    Hinweis: Eine automatisch vergebene Portnummer ist nur für das jeweilige Projekt eindeutig. In multihierarchischen Projekten muss diese überprüft werden, um Kommunikationsfehler mit der zenon Logic Workbench/Runtime zu vermeiden.

    Minimum: 6001 (bei automatischer Vergabe, manuell: empfohlen)

    Maximum: 6998 (bei automatischer Vergabe, manuell: empfohlen)

    Default: 6001

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt anlegen

    Name

    Name des Simulationsprojektes. Ist beim Start der zenon Logic Workbench kein gültiger Name vorhanden, wird automatisch ein Name vergeben. Dieser setzt sich zusammen aus dem Treibernamen und dessen Bezeichnung.

    Bedingungen für gültige Namen:

    - darf nicht leer sein

    - muss im Projekt eindeutig sein

    - darf nur für zenon Logic erlaubte Zeichen beinhalten; verboten sind: /\:*?<>!|"

    Minimum: 1 Zeichen

    Maximum: 15 Zeichen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • die zenon Logic Workbench wird geöffnet

Die Workbench des Simulationsprojektes wird automatisch geschlossen, wenn:

  • der zenon Editor geschlossen wird
  • ein Treiber gelöscht wird, dessen Simulationsprojekt aktuell in der Workbench editiert wird
  • das Simulationsprojekt beim Treiber über die Eigenschaft Löschen gelöscht wird

    Interne ID: Projekt anlegen

    Löschen

    Nur verfügbar, wenn ein Simulationsprojekt definiert ist und nur ein Treiber ausgewählt ist.

    Löscht Simulationsprojekt nach Sicherheitsabfrage.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • das Simulationsprojekt umbenannt wird

Projektablage

Ein zenon Logic Projekt enthält viele Dateien und Ordner. Um deren Handhabung, vor allem beim Verteilten Engineering zu vereinfachen, werden sämtliche Dateien in gepackter Form in der Datei Simul_<Treiber-ID>.zip im Ordner <Sql Projekt Pfad>\FILES\zenon\custom\drivers abgelegt. Im Editor befindet sich diese Datei bei den Dateien des Treibers. Die Dateien werden beim Start der zenon Logic Workbench automatisch entpackt und beim Beenden wieder gepackt.

Variablen anlegen

Beim Anlegen von Variablen in einem Simulationsprojekt ist die Reihenfolge der Schritte wichtig:

  1. erstellen Sie die Variable
  2. wählen Sie den gültigen Datentyp in der zenon Logic Workbench aus
  3. setzen Sie erst dann die Eigenschaft embed symbol aktiv

Hintergrund: Variablen werden per Default mit dem Treiberobjekttyp SPS Merker angelegt. Dieser Objekttyp unterstützt nicht bei allen Treibern alle Datentypen. Wird eine Variable in der zenon Logic Workbench mit aktiver Eigernschaft embed symbol kopiert, muss diese Eigenschaft deaktiviert werden, um den Datentyp ändern zu können. Damit wird die Variable in zenon wieder gelöscht.

info Info

Fehlermeldung "Can not create variable"

Eine Variable kann im Simulationsobjekt nicht angelegt werden, wenn der Treiber keine Treiberobjekttypen - ausgenommen

Treibervariable - hat, die diesen Datentyp unterstützen.

Beim Aktivieren von embed symbol wird dann die Fehlermeldung "can not create variable" angezeigt.

Struktur-Datentyp

Beim Anlegen von Variablen mit einem Struktur-Datentyp:

  • werden diese, wenn möglich, mit dem Treiberobjekttyp SPS Merker angelegt
  • werden alle Treiberobjekttypen mit Ausnahme von Treibervariable probiert, bis einer für alle Elemente verwendbar ist
  • ist kein passender Treiberobjekttyp verfügbar, dann wird
    • bei Nicht-Strukturvariablen keine Variable erzeugt
    • bei Strukturvariablen der Treiberobjekttyp SPS Merker benutzt

Beispiel:

Ein Strukturdatentyp enthält Elemente vom Typ UINT und STRING. Eine Variable wird für den S7TCP Treiber erstellt und embed symbol wird aktiviert.

  • Die Variable wird nicht im SPS Merker angelegt, sondern als Erw. Datenbaustein, in dem alle Strukturelementen vorhanden sind.
  • Ein neuer Typ LINT wird hinzugefügt, dieser wird vom Erw.Datenbaustein nicht unterstützt.
  • Beim Anlegen einer neuen Variablen wird diese als Typ SPS Merker angelegt. Es kann nur die erste Komplexvariable aktiviert werden (UINT). Bei der bestehenden Strukturvariable bleibt der Objekttyp Erw. Datenbaustein und das letzte Strukturelement (LINT) kann nicht aktiviert werden.

Kompilieren der Dateien

Wenn ein Simulationsprojekt in der zenon Logic Workbench kompiliert wird, bewirkt dies in zenon das Erzeugen der Variablen und der Programmdatei der Runtime.
Beim Kompilieren wird im Runtime-Ordner \RT\FILES\zenon\custom\drivers ein Unterordner mit dem Namen des Simulationsprojekts erzeugt. In diesem Ordner wird dann die Datei mit dem Code der Simulation in SIMULRT.COD abgelegt.

Im Ausgabefenster wird beim Kompilieren folgende Meldung angezeigt:

SIMULRT.COD

Und wenn mit C-Compiler kompiliert, dann zusätzlich:

T5APP.DLL

attention Achtung

Bei Mehrplatzfähigen Projekten darf offline kein neues Simulationsprojekt erstellt werden. Dieses kann nicht mehr gelöscht werden.


Projekt löschen

Projekt löschen

Um ein Simulationsprojekt zu löschen:

  1. klicken Sie in der Gruppe Treiber-Simulationsprojekt bei der Eigenschaft Löschen auf die Schaltfläche Hier klicken->

    Interne ID: Projekt löschen

    Löschen

    Nur verfügbar, wenn ein Simulationsprojekt definiert ist und nur ein Treiber ausgewählt ist.

    Löscht Simulationsprojekt nach Sicherheitsabfrage.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Projekt löschen

    Treiber-Simulationsprojekt

    Beinhaltet alle Eigenschaften für die Konfiguration der Simulation - programmiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. bestätigen Sie die Sicherheitsabfrage
  3. die ZIP-Datei mit den Projektdateien wird sofort gelöscht
  4. die zenon Logic Workbench wird beendet

Beachten Sie:

  • der Runtime-Ordner für das Simulationsprojekt bleibt bestehen
  • die Funktion Rückgängig steht für diese Aktion nicht zur Verfügung,
  • Klick auf Bearbeiten erstellt ein neues Simulationsprojekt

    Interne ID: Projekt löschen

    Bearbeiten

    Nur verfügbar, wenn ein Prozesstreiber gewählt wurde, der Projektname gültig ist und nur ein einzelner Treiber ausgewählt wurde. Nicht verfügbar für Treiber für die Simulator Variable.

    Klick öffnet das Simulationsprojekt in der zenon Logic Workbench. Existiert kein Simulationsprojekt für diesen Treiber, wird dieses automatisch erzeugt.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • bei Mehrplatzfähigen Projekten:
    • muss der Treiber auf Änderungen ermöglichen konfiguriert werden, damit das Simulationsprogramm gelöscht werden kann
    • wird das Projekt auf anderen Clients nicht als gelöscht angezeigt solange es nicht synchronisiert wurde;

      der Versuch, ein gelöschtes Projekt vor dem Synchronisieren zu öffnen (Klick auf Bearbeiten), erstellt ein neues Simulationsprojekt

    • kann wie bei Einzelplatzprojekten das Löschen über Änderungen verwerfen nicht mehr rückgängig gemacht werden

attention Achtung

Das Simulationsprojekt wird beim Löschen sofort aus der lokalen Datenbank und der Server-Datenbank entfernt. Diese Aktion kann nicht rückgängig gemacht werden!

Hinweis: Auch das manuelle Löschen der ZIP-Datei bei den Dateien des Treibers führt zum Löschen des Simulationsprojekts. Voraussetzung: Die zenon Logic Workbench für diesen Treiber ist nicht geöffnet. Von dieser Vorgangsweise wird abgeraten!


Verteiltes Engineering

Verteiltes Engineering

Bei Mehrplatzfähigen Projekten werden alle zum Projekt gehörenden, laufenden zenon Logic Workbenches für die Treibersimulation geschlossen beim:

  • Änderungen übernehmen für Module, die bei Änderungen ermöglichen für andere Anwender komplett gesperrt werden, wie Variablen, Treiber und Datentypen
  • Änderungen verwerfen:
    • neue Projekte werden am Server nicht erzeugt
    • Änderungen am Simulationsprogramm gehen verloren
    • in der Server-Datenbank nicht vorhandene Treiberdateien werden auch in der lokalen DB gelöscht
  • Synchronisieren:
    am Simulationsprogramm lokal gemachte Änderungen gehen verloren
  • Aktualisieren der lokalen Version:
    am Simulationsprogramm lokal gemachte Änderungen gehen verloren

attention Achtung

Der Status der ZIP-Datei des Simulationsprojektes darf nicht extra modifiziert werden (Änderungen übernehmen, Änderungen ermöglichen, Änderungen verwerfen Multiuserstatus), um korrektes Änderungen übernehmen und Änderungen ermöglichen des Treibers sicher zu stellen!

Projekt löschen

Bei Mehrplatzfähigen Projekten

  • muss der Treiber auf Änderungen ermöglichen konfiguriert werden, damit das Simulationsprogramm gelöscht werden kann
  • wird das Projekt auf anderen Clients nicht als gelöscht angezeigt solange es nicht synchronisiert wurde;
    • der Versuch, ein gelöschtes Projekt vor dem Synchronisieren zu öffnen (Klick auf Bearbeiten), erstellt ein neues Simulationsprojekt

      Interne ID: Verteiltes Engineering

      Bearbeiten

      Nur verfügbar, wenn ein Prozesstreiber gewählt wurde, der Projektname gültig ist und nur ein einzelner Treiber ausgewählt wurde. Nicht verfügbar für Treiber für die Simulator Variable.

      Klick öffnet das Simulationsprojekt in der zenon Logic Workbench. Existiert kein Simulationsprojekt für diesen Treiber, wird dieses automatisch erzeugt.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • kann wie bei Einzelplatzprojekten das Löschen über Änderungen verwerfen nicht mehr rückgängig gemacht werden

attention Achtung

Ein Simulationsprojekt mit dem Status Änderungen ermöglichen kann im Modus Offline nicht gelöscht werden.

Ein in einem Mehrplatzfähigen Projekt offline erzeugtes Simulationsprojekt kann somit nicht mehr gelöscht werden!


Treiber wechseln

Treiber wechseln

Bei einem Treiberwechsel in zenon gilt:

  • Das Simulationsprojekt bleibt erhalten.
  • Allerdings werden alle Ports auf 0 gestellt. Um funktionierende Portnummern zu erhalten, öffnen Sie das Projekt im Editor. Dabei werden automatisch neue Portnummern eingetragen. Portnummern können auch manuell vergeben werden.

attention Achtung

Treiber, die mit einem zenon Logic Projekt über die integrierte Lösung verknüpft sind, können nicht ausgetauscht werden.


XML-Export/Import

XML-Export/Import

Ein Projekt im Modus Simulation - programmiert kann per XML exportiert werden. Es kann aber nicht als neues Projekt für einen anderen Treiber importiert werden.

Workaround:

  1. Exportieren Sie die zenon Logic Programme.
  2. Importieren Sie diese in das neue Projekt für den neuen Treiber.
  3. Ersetzen Sie per Suchen und Ersetzen die Variablen.


Treiberkonfiguration

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - programmiert -> Treiberkonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Konfiguration des Treibers stehen Ihnen vier Modi zur Verfügung:

  • Hardware
  • Simulation - zählend
  • Simulation - statisch
  • Simulation - programmiert

Wählen Sie den Modus Simulation - programmiert.

Noch in diesem Kapitel

Status Treibervariable

Zyklischer Abgleich


Status Treibervariable

Status Treibervariable

Der Zustand der zenon Logic Runtime wird in der Treibervariablen SimulRTState auf Offset 60 abgebildet. Die Variable ist numerisch und kann nicht geschrieben werden. Der Wert informiert über den Status der Runtime:

Bit | Bedeutung | Erklärung
31 | ohne Applikation | Runtime hat kein Programm geladen, das Programm wurde gestoppt oder nicht in die Runtime geladen.
30 | nicht instanziert | Runtime wurde nicht nicht instanziert, zum Beispiel weil die DLL mit er Runtime nicht geladen werden konnte, zu wenig Arbeitsspeicher vorhanden ist, die DLL nicht vorhanden ist oder in falscher Version.
18 | p-code available | p-Code ist gemeinsam mit kompiliertem Code verfügbar, umschalten ist möglich.
17 | compiled code active | Runtime läuft mit kompiliertem Code (sonst: interpretierter p-Code).
16 | compiled code available | Kompilierter Code von C-Compiler ist verfügbar
15 | application is loaded | eine Applikation ist vorhanden, Runtime läuft
14 | cant start - missing handlers | Einige "C" Funktionen fehlen.
13 | active breakpoints installed | Mindestens ein Breakpoint wurde vom Debugger gesetzt.
12 | CT segment exists | Applikation wurde mit der Option "complex variables in separate segment" kompiliert.
11 | Reserved | (Intern, nur für Runtime.)
10 | sysinfo request is available | (Intern, nur für Runtime.)
9 | freeze event production | Binding überträgt keine Events.
8 | single cycle mode | (Intern, nur für Runtime und Debugger.)
7 | Reserved | (Intern, nur für Runtime.)
6 | locked variables | Mindestens eine Variable ist gesperrt.
5 | trigo functions are in degrees | Trigonometrische Funktionen werden in Grad angegeben.
4 | log message(s) in stack | (Intern, nur für Runtime.)
3 | application stopped between 2 progs | Runtime beim Debuggen zwischen zwei Schritten angehalten.
2 | application stopped on SFC breakpt | (Intern, nur für Runtime.)
1 | application stopped on error | Runtime mit schwerwiegendem Fehler angehalten, Neustart nötig.
0 | application is running | TRUE = Applikation ist im Modus "run". FALSE = Applikation pausiert im Modus "cycle to cycle" .

info Info

Die Treibervariable SimulRTState mit Offset 60 zeigt den Status der Runtime am Server an. Das gilt auch dann, wenn die Variable am Standby Server angezeigt wird.


Zyklischer Abgleich

Zyklischer Abgleich

Simulationen laufen im Netzbetrieb auf Server und Standby-Server unabhängig voneinander ab. Beim Start des Standby-Servers erfolgt ein Abgleich mit dem Server, allerdings:

  • ist dieser erste Abgleich um die Paketlaufzeit verschoben
  • führen geringe Unterschiede in der Ausführung zu wachsender Divergenz

Damit wird auch der Zustand der simulierten Variablen unterschiedlich. Um diese Unterschiede gering zu halten, nutzen Sie die Funktion Treiber Simulationsabbild an Standby übertragen zum Abgleich des Simulationsabbildes:

  • legen Sie eine neue Funktion an
  • wählen Sie Treiber Simulationsabbild an Standby übertragen

  • ein Dialog zur Auswahl der Treiber öffnet sich

  • in der Liste sind alle prozessgekoppelten Treiber (ausgenommen Simulator) verfügbar (Klick auf Spaltenkopf ändert Sortierung)
  • wählen Sie jene Treiber aus, die abgeglichen werden sollen
  • bei jedem Funktionsaufruf am Standby-Server wird für die ausgewählten Treiber vom Server ein Abbild angefordert

Durch zyklische Aktivierung können die Unterschiede im aktuellen Simulationszustand minimiert werden. Passen Sie das Raster der Ausführung an den Umfang der abzugleichenden Daten an, da dadurch Netz- und Rechnerlast erzeugt wird.

Die Ausführung der Funktion ist fix auf Standby eingestellt und kann nicht geändert werden. Sie erfolgt nur wenn:

Interne ID: Zyklischer Abgleich

Standby

Nur verfügbar in redundanten Netzwerk-Projekten:
Die Funktion wird auf dem Standby-Server des Projekts ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Zyklischer Abgleich

Ausführung

Nur verfügbar in Netzwerk-Projekten:
Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Rechner Standby-Server ist
  • der Server online ist
  • das Projekt ein Netzwerkprojekt ist
  • Treiber zum Abgleich ausgewählt wurden

Um die Auswahl der Treiber zu ändern

  • klicken Sie in den Eigenschaften des Treibers in der Gruppe Allgemein in die Eigenschaft Parameter

    Interne ID: Zyklischer Abgleich

    Parameter

    Übergabeparameter der Funktion; hängt vom Typ der Funktion ab.
    Abhängig vom Typ der Funktion wird der entsprechende Parameterdialog geöffnet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Zyklischer Abgleich

    Allgemein

    Allgemeine Eigenschaften für die Funktion.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • der Dialog zur Auswahl der Treiber öffnet sich


zenon Logic Workbench

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - programmiert -> zenon Logic Workbench

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Simulation - programmiert wird in der zenon Logic Workbench programmiert, die eng mit dem zenon Editor zusammenarbeitet. Für die Simulation werden (im Unterschied zur integrierten Lösung) nur die Variablen eines Treibers zwischen den Editoren ausgetauscht.

Definition der auszutauschenden Variablen

Beim Start der zenon Logic Workbench werden alle Variablen des Treibers, die in zenon Logic noch nicht vorhanden sind, als globale Variablen angelegt. Bei diesen ist automatisch die Einstellung Symbol einbetten aktiviert.

Sichtbarkeit

Wird in der Workbench eine neue Variable im Bereich global oder retain definiert, ist diese erst nur in zenon Logic sichtbar. Um Sie auch in zenon sichtbar zu machen, muss die Option Symbole einbetten aktiviert werden. Ab diesen Moment wird die Variable von beiden Editoren aus aktualisiert.

Wird bei der Variablen die Option Symbol einbetten deaktiviert, wird die Variable im zenon Editor gelöscht. Dieses Verhalten ermöglicht es, in zenon Logic globale bzw. retain Variablen zu definieren, die für zenon nicht sichtbar sind.

Für eine durch die zenon Logic Workbench in zenon neu erzeugte Variable, wird versucht, als Bereich SPSMERKER zuzuordnen. Falls der zenon Treiber den konfigurierten Datentyp bei dieser nicht unterstützt, wird der erste Datenbereich gesucht welcher den Datentyp unterstützt. Wird kein Bereich gefunden, kann die Variable nicht angelegt werden.

Eine Variable ist nur gesperrt, wenn es sich um ein Mehrplatzfähiges Projekt handelt und dieses noch nicht den Status Änderungen ermöglichen hat.

Projekteinstellungen

Einige Einstellungen unter Projekt -> Projekt-Parameter... -> Weitere Optionen -> Erweitert in zenon Logic haben Einfluss auf die Funktionalität der Simulation.

Einstellungen Erweitert

Beschreibung

Runtime: Ausführungsmodus

Empfehlung:

Modus: getriggert

Zykluszeit: 1/4 bis 1/3 der Treiberaktualisierungszeit
Zu häufige Wertänderungen an simulierten Variablen führen zu einer erhöhten Rechnerauslastung.

Compiler/Optionen: Symbole aller Variablen einbetten

Empfehlung: Deaktivieren.
Aktiv: Daten für eine Variable werden ausgetauscht, da durch den Symbolnamen die Zuordnung in der Runtime erfolgt.

Aber: Änderungen an der Projektierung der Variablen werden zwischen zenon und zenon Logic nicht aktualisiert. Onlinechange ist nicht mehr möglich.

Compiler/Optionen: Groß-/Kleinschreibung der Symbole beibehalten

Ohne Auswirkung: In der Runtime werden Variablennamen immer auf Großschreibung konvertiert.

Compiler/Optionen: Statusbits für Variablen mit Profil anlegen

Aktiv: Im Simulationsprogramm wird der Status der Variablen simuliert bzw. wird darauf reagiert.

„C" Compiler

Nativer Code wird unterstützt.

Name der DLL, die den kompilierten Code enthalten muss: t5app.dll.


Runtime

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - programmiert -> Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Noch in diesem Kapitel

Funktionalität

Runtime-Dateien

Datenaustausch

Datenhaltung

Redundanz

Status

Start/Stopp

Treiberkommandos

Variablenzuordnung

Zeitstempel


Funktionalität

Funktionalität

Die zenon Logic Runtime stellt folgende Funktionalitäten zur Verfügung:

  • Dateitransfer
  • Datentypen:
    • BOOL
    • BYTE
    • DINT
    • DWORD
    • INT
    • LINT
    • LREAL
    • REAL
    • SINT
    • STRING
    • TIME
    • UDINT
    • UINT
    • USINT
    • WORD
  • zenon Arrays (siehe auch Arrays und Simulation)
  • Datumsstempel/Zeitstempel
  • Digitale Werteaufzeichnung
  • Dynamisch angebundene Funktionsblöcke, abgelegt in t5block*.dll
  • Hot restart
  • Logging:
    • Tracemeldungen vom Programm (printf)
    • Fehlermeldungen der Runtime
    • alle an Workbench und an Diagnose Server
  • Maschinencode: Native compiled code mit C-Postcompiler (unter Windows CE nicht verfügbar)
  • Online change
  • Programmiersprachen: AWL, AS, FUP, KOP, ST
  • Retain Daten (remanente Daten)
  • Spezielle Funktionsblöcke und Features:
    • Datenserialisierung
    • dynamische Speicherbelegung
    • eingebettete Rezepte
    • eingebettete Variablenliste
    • File Management
    • Files
    • Mathe
    • Random
    • Signale
    • Stringtabellen
    • Trigometrie
    • Zeit
  • Spontane Kommunikation:
    • Wertänderungen als Event
    • 16 Verbindungen
    • Hysterese
  • UDP & TCP/IP für IEC-Sprachen
  • Variablen-Verriegelung

Noch in diesem Kapitel

Arrays und Simulation


Arrays und Simulation

Arrays und Simulation

Um mehrdimensionale Arrays bei der Treibersimulation simulieren zu können, müssen SIe in der zenon Logic Workbench die Eigenschaft Komplexe Variable in eigenem Segment speichern" aktivieren.

Arrays mit Startindex 1

Wenn bei einer Simulation Arrays mit Startindex 1 vorkommen, werden diese Arrays in der zenon Logic Workbench mit einem Index mehr erzeugt.

Example Beispiel

Eine Array verfügt in zenon über die Indizes 1 bis 4. Diese Array besitzt in der zenon Logic Workbench die Indizes 0 bis 4.

Dadurch wird sichergestellt, dass in zenon und in zenon Logic die selben Indizes verwendet werden. Der Index 0 wird nicht an den Treiber übertragen.

Wenn Sie Arrays in der zenon Logic Workbench ändern, müssen Sie diesen zusätzlichen Index beachten.


Runtime-Dateien

Runtime-Dateien

Beim Erzeugen der Runtime-Dateien wird im Runtime-Ordner des Projektes im Pfad \RT\FILES\zenon\custom\drivers ein Unterordner mit dem Namen des Simulationsprojektes erzeugt. In diesem Ordner wird die Datei simulrt.cod mit dem Code der Simulation abgelegt.

Interne ID: Runtime-Dateien

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei erfolgreicher Kompilation in der Workbench und Übertragung in den Runtime-Ordner wird im Ausgabefenster des Editors folgende Meldung ausgegeben:

SIMULRT.COD

Und wenn mit C-Compiler kompiliert, dann zusätzlich:

T5APP.DLL

Remote Transport

Die Runtime-Dateien für die Simulation werden als Unterordner der Treiberdateien erzeugt. Beim Remote Transport wird der Unterordner mit sämtlichen darin enthaltenen Dateien auf den Zielrechner übertragen


Datenaustausch

Datenaustausch

Der Datenaustausch von der zenon Logic Runtime zum Treiber beginnt mit dem 2. Zyklus der zenon Logic Runtime. Damit steht der erste Durchlauf zur Verfügung, um alle Variablen in der Runtime zu initialisieren.

Ein Datenaustausch findet nur statt wenn:

  • die Variable angefordert wird und:
    • noch keinen Wert erhalten hat
    • im Treiber nicht den Status Abgeschaltet (OFF/_VSB_N_UPD) oder Ersatzwert (ALT_VAL/_VSB_AVALUE) hat
    • vom Treiber noch benötigt wird.
    • sich Wert oder Status geändert haben

Der Datenaustausch zum Treiber erfolgt asynchron zum Zyklus der Runtime. Der Treiber durchläuft die Wertänderungen einmal pro Updatezyklus. Alle geänderten Werte - ausgenommen mit Status Abgeschaltet (OFF/_VSB_N_UPD) oder Ersatzwert (ALT_VAL/_VSB_AVALUE) - werden in die Liste der zu aktualisierenden Variablen beim Treiber eingetragen und zur Runtime abgesetzt.

Funktion Treiber Simulationsabbild an Standby übertragen

Diese Funktion wird nur am Standby-Server ausgeführt (Konfiguration siehe Kapitel Zyklischer Abgleich). Am Server, der das Abbild zusammenstellt, werden die Daten synchron vom Treiber geholt. Der Treiber hat dafür 5 Sekunden Zeit. Da die Daten für das Abbild im gleichen Thread erstellt werden, in dem die Simulation läuft, muss sichergestellt sein, dass die Simulation innerhalb von 5 Sekunden abgearbeitet wird. Wird diese Zeit überschritten, wird für diesen Treiber kein Abbild übertragen.

Wertsimulation

Wertänderungen werden nicht sofort übertragen, sondern in einem Puffer abgelegt. Die Größe des Puffers beträgt 8192 Wertänderungen oder die fünffache Anzahl der Variablen, je nachdem welcher Wert größer ist. Die Verzögerung der Übertragung durch den Treiberzyklus kann bis zu 100 ms betragen. Ändert sich der Wert einer Variablen erneut während er auf die Übertragung wartet, werden sofort alle noch nicht übertragenen Werte zur Runtime abgesetzt und dann erst die neuen Werte vorgemerkt. Das kann eine erhöhte Last für Rechner und Netzwerk zur Folge haben, stellt aber sicher, dass alle Werte zur Runtime übertragen werden.

Treiber Schreibbefehl

Wenn die Simulation - programmiert projektiert und aktiv ist, werden die Schreibbefehle am Standby bis zur Runtime durchgereicht.

Schreiboperationen werden vom Treiber asynchron zur Runtime ausgeführt. Der Datenaustausch findet über einen Puffer statt. Die Größe des Puffers beträgt 8192 Wertänderungen oder die fünffache Anzahl der Variablen, je nachdem welcher Wert größer ist.

Schreibbefehle werden nach den Wertänderungen durch die Runtime durchlaufen. Kann ein Schreibbefehl nicht korrekt ausgeführt werden, wird die Fehlermeldung Write queue full! Write command for <DP-Name> lost! angezeigt.

Wenn die Statusbits aktiviert sind, wird durch das Setzen des Status Schreiben erfolgreich angezeigt, dass vom Treiber auf den Wert der Variablen geschrieben wurde. Das Runtime-Programm sollte diesen Status nach dem Bearbeiten des Schreibbefehl wieder löschen. Ein bereits aktives Statusbit verzögert ein erneutes Beschreiben durch den Treiber nicht. Schreibbefehle werden auch ausgeführt, wenn das Runtime-Programm durch einen Breakpoint gestoppt wurde.

Hinweis: Nicht alle Schreibbefehle vom Treiber müssen in der Runtime auch sichtbar werden. Wenn für eine Variable mehrere Schreibbefehle im Puffer sind, wird nur der letzte im Runtime-Programm sichtbar.

Variablen abschalten, auf Ersatzwert schalten

Wird die Variable abgeschaltet oder auf Ersatzwert geschaltet, ist das für die Runtime nicht erkennbar. Wertänderungen, die durch die Runtime ausgeführt werden, werden der Variablen im Treiber nicht zugeordnet. Wird die Variable wieder auf Spontanwert geschaltet bzw. aktiviert, wird auch der aktueller Wert aus der Runtime erneut zum Treiber übertragen. Beim Abschalten des Spontanwerts wird das Status-Bit OFF gesetzt; beim Zurückschalten auf Spontanwert wird das OFF-Bit zurückgesetzt.


Datenhaltung

Datenhaltung

Retain Daten

Retain Daten werden in der Datei SimulRt<TreiberID>.ret abgelegt. Pro Simulation wird eine solche Datei erzeugt, sofern Retain-Variablen vorhanden sind. Die Datei wird beim Abgleich im Netzwerk berücksichtigt.

Treiber remanent

Die Einstellung Simulation - programmiert beim Treiberstart ist kein Kriterium, um das remanente Variablenabbild zu restaurieren.


Redundanz

Redundanz

Start am Standby-Server

Läuft der Treiber am Standby-Server bereits, dann sollte auch das Abbild für die Simulation schon zur Verfügung stehen. In diesem Fall wird die Simulation mit diesem Abbild „Hot" gestartet. Bei fehlendem Abbild erfolgt ein Warmstart.

Funktion Treiber Simulationsabbild an Standby übertragen

Diese Funktion wird nur am Standby-Server ausgeführt (Konfiguration siehe Kapitel Zyklischer Abgleich). Am Server, der das Abbild zusammenstellt, werden die Daten synchron vom Treiber geholt. Der Treiber hat dafür 5 Sekunden Zeit. Da die Daten für das Abbild im gleichen Thread erstellt werden, in dem die Simulation läuft, muss sichergestellt sein, dass die Simulation innerhalb von 5 Sekunden abgearbeitet wird. Wird diese Zeit überschritten, wird für diesen Treiber kein Abbild übertragen.

Abgleich

Zusätzlich zu den Programmdateien der Simulation werden auch abgeglichen:

  • Retaindaten (*.ret)
  • alle *.simul Dateien
    Diese Dateiendung wird vom Simulationsprogramm für simulationsspezifische Dateien erzeugt und im Ordner mit der Rechnerbezeichnung unterhalb des Runtime-Ordners abgelegt.

    Interne ID: Redundanz

    Runtime-Ordner

    Verzeichnis für die Runtime-Dateien des Projekts.
    In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
    Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

    Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Status

Status

Statussimulation

Für die Statussimulation muss in zenon Logic unter Projekt -> Projekt-Parameter -> Erweitert -> Compiler -> Optionen -> Statusbits für Variablen mit Profil anlegen aktiv sein. Wird der Status einer Variablen modifiziert, löst dies die Übertragung der Variablen zum Treiber aus.

Die Änderung an folgenden Status löst keine Wertaktualisierung im Treiber aus und wird auch nicht aus der Simulation übernommen:

  • Echtzeit extern (T_EXTERN/_VSB_RT_E)
  • Echtzeit intern (T_INTERN/_VSB_RT_I)
  • Winterzeit (T_STD/_VSB_WINTER)
  • Schreiben bestätigen (WR_ACK/_VSB_WR_ACK)
  • Schreiben erfolgreich (WR_SUC/_VSB_WR_SUC)
  • Normalzustand (NORM/_VSB_NORM)
  • Abweichung Normalzustand (N_NORM/_VSB_ABNORM)
  • Select im Netzwerk (NET_SEL/_VSB_SELEC)
  • Laufzeitüberschreitung (TIMEOUT/_VSB_RTE)
  • In Bearbeitung (PROGRESS/_VSB_DIREC)
  • Abgeschaltet (OFF/_VSB_N_UPD)
  • Ersatzwert (ALT_VAL/_VSB_AVALUE)

info Info

Das Statusbit Schreiben erfolgreich (WR_SUC/_VSB_WR_SUC) steht im Runtime-Programm zur Verfügung und kann zurückgesetzt werden, um erfolgreiches Schreiben anzuzeigen.

Allerdings löst das Zurücksetzen alleine nicht das Übertragen zur zenon Runtime aus. Nur Wertänderungen werden vom Treiber zur Runtime geschickt.

Speziell behandelte Statusbits

Die folgenden Statusbits schließen sich gegenseitig aus:

Bit

Beschreibung

17: Spontan
(SPONT/_VSB_SPONT)

Status SPONTAN wird gesetzt. Dies ist auch der gesetzte Status, wenn die Statusbehandlung abgeschaltet ist oder kein Status definiert wurde. Status GI + INVALID wird gelöscht.

18: Ungültig
(INVALID/_VSB_I_BIT)

Status INVALID wird gesetzt. Status SPONTAN + GI wird gelöscht.

16: Generalabfrage
(GI/_VSB_GR)

Status Generalabfrage wird gesetzt. Status SPONTAN + INVALID wird gelöscht.

8: Select im Netzwerk
(NET_SEL/_VSB_SELEC)

Wenn dieses Statusbit aktiv ist (BSO Aktivierung/Deaktivierung), werden folgende Statusbits für eine Änderungserkennung mit 0 angenommen und auch als 0 zum Treiber übertragen:

  • Select im Netzwerk (NET_SEL)
  • Übertragungsursache (COTx)
  • Select (SE_870)
  • N_CONF (P/N-BIT)
  • Test-BIT (TEST)
  • Schreiben erfolgreich (WR_SUC)

Select before operate (SBO)

Damit auf Select Before Operate reagiert werden kann, muss im Runtime-Programm die Statussimulation verfügbar sein. Der Ablauf für Select Before Operate wird im Runtime-Programm festgelegt.

Interne ID: Status

Select Before Operate

Achtung: Diese Funktionalität wird nur von den Treibern IEC870, IEC850 und DNP3 unterstützt und nur, wenn in der Befehlsgabe für die Eigenschaft Aktionstyp Doppelbefehl gewählt wurde.

Interne ID: Status

Aktionstyp

Nur verfügbar bei der Aktion 'Befehl':
Typ des Befehls.
Doppelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand'.
Einzelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand' Nach der 'Flankenverzögerung' wird der Wert 0 geschrieben. Dieses Schreiben ist nicht mehr Laufzeit überwacht.
Default: Einzelbefehl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Bevor der Wert der Variablen in die Hardware geschrieben wird, fragt zenon ab, ob die Variable in der Hardware für die Aktion bereit ist = Select before Operate (SBO).
Achtung: Bei Einzelbefehlen wird dann das automatische Zurücksetzen des Variablenwerts nach der in der Eigenschaft Flankenverzögerung definierten Zeitspanne nicht ausgeführt.

Interne ID: Status

Flankenverzögerung

Nur verfügbar, wenn bei der Eigenschaft Aktionstyp Einzelbefehl gewählt wurde.
Nach Ablauf dieser Zeit in Millisekunden wird der Wert der Befehlsvariable - abhängig von der Schaltrichtung - auf 0 oder 1 zurückgesetzt. Das Zurücksetzen des Wertes wird nicht ausgeführt, wenn die Eigenschaft Select Before Operate der Aktionsvariable aktiviert wurde.
Minimum: 0
Maximum: 4294967295
Default: 1000
Achtung: Es wird nicht gewartet, bis die Laufzeitüberwachung beendet ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Inaktiv: Der Wert der Variable wird ohne vorherige Rückfrage in die Hardware geschrieben = Direct execute.
Default: inaktiv
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktivierung

Wenn zum Treiber ein SBO select gesendet wird, löst dies für die Runtime ein Werteschreiben mit dem Status Select im Netzwerk (NET_SEL) + Übertragungsursache (COT_act) aus.

Im Runtime-Programm muss ein entsprechender SBO-Ablauf implementiert sein und starten.

Das Statusbit Select im Netzwerk (NET_SEL) muss im Runtime-Programm zurückgesetzt werden.

Deaktivierung

Die Deaktivierung löst ein Werteschreiben mit dem Status Select im Netzwerk (NET_SEL) + Übertragungsursache (COT_deact) aus.

Im Runtime-Programm muss der SBO-Ablauf entsprechend beendet werden.

Das Statusbit Select im Netzwerk (NET_SEL) muss im Runtime-Programm zurückgesetzt werden.


Start/Stopp

Start/Stopp

Treiber-Start

Die Werteaktualisierung beginnt am Standby-Server erst, wenn der Treiber von seinem Server das Prozessabbild erhalten hat. Das Abbild muss innerhalb des Modultimeouts eintreffen, sonst startet der Treiber ohne Abbild. Wenn sich der Standby-Server innerhalb der Wartezeit zum Server hochstuft, wird das Warten ebenfalls beendet. Treiber, die bei einem Serverprojekt oder ohne Netzwerk starten, haben keine Wartezeit. Dieses Verhalten gilt sowohl für die Simulation als auch für den Hardware-Modus.

Runtime-Start

Wenn der Treiber die Simulation - programmiert startet, wird im ersten Schritt die DLL mit der Simulations-Runtime geladen. Anschließend wird die Runtime parametriert und das Runtime-Programm startet, sofern es erfolgreich geladen werden konnte.

Ist ein Abbild der Runtime vorhanden, wird die Runtime mit diesem Hot gestartet. Sonst wird ein Warmstart ausgeführt. Ist das ebenfalls nicht möglich, wird versucht die Runtime Kalt zu starten. Ist kein gültiges Programm vorhanden, läuft die Runtime gestoppt hoch. Der Status aller Variablen wird auf INVALID gesetzt.

Das Simulationsprogramm läuft in einem eigenen Thread und ist somit völlig unabhängig vom Treiberzyklus.

info Info

Retain Variablen

Retain Daten enthalten nur den Wert der zenon Logic Variablen, nicht deren Status. Das bedeutet für den Start:

  • Warmstart: Der Status, der für eine Variable gesetzt wurde, wird wieder hergestellt - unabhängig davon, ob es sich um eine Retain Variable handelt oder nicht.
  • Kaltstart mit Retain Variablen: Nur der Wert der Retain Variablen in zenon Logic wird wieder hergestellt, nicht der Status.

Runtime stoppen

Wird die Runtime gestoppt, wird bei allen Variablen der Status INVALID gesetzt. Variablen, die angefordert werden, während die Runtime gestoppt ist, erhalten als Initialisierung den Status INVALID. Die Runtime sichert die Daten für den Warmstart und Online Change:

  • SIMULRT.HOT: enthält die Daten für den Hot-Restart.
  • SIMULRT.UPD: enthält die Daten für den Online Change.

Diese beiden Dateien werden im Ordner des Runtime-Programms erzeugt. Die Runtime muss Schreibberechtigung auf diesen Ordner besitzen.

Nachladen

  • Erneute Kompilierung des Simulationsprojektes:
    Führt zum Nachladen des entsprechenden Treibers.
  • Modifikation des Modul-Timeouts:
    Wird von der Runtime nicht als Änderung erkannt und bewirkt kein Nachladen der Treiber.

Die Standardimplementierung im Treiberkit löst beim Nachladen des Simulationsprojektes einen Hotrestart der Runtime aus. Ist dieser nicht möglich (z.B. weil das Programm unterschiedlich ist), wird ein Kaltstart mit retain ausgeführt.

Entladen der Runtime

Wenn die Runtime läuft, wird diese gestoppt. Bevor die Runtime entladen wird, werden noch alle ausstehenden Wertaktualisierungen an den Treiber übergeben. Erst dann wird die Runtime freigegeben und am PC die SimulRuntime.dll entladen.


Treiberkommandos

Treiberkommandos

Treiberkommandos dienen dazu, Treiber über zenon zu beeinflussen, z. B. starten und stoppen.
Die Projektierung erfolgt über die Funktion Treiber Kommandos.

Treiber stoppen/starten

Wird im Modus Simulation - programmiert der Treiber gestoppt, hat dies das Entladen der Runtime zur Folge. Alle Variablen bekommen den Status INVALID. Beim Neustart des Treibers wird die Simulation neu geladen und die Runtime gestartet.

Treiber Hardware/Simulation umschalten

Bei der Umschaltung zwischen den Modi Harware und Simulation verhält sich ein Treiber entsprechend diesem Schema:

  1. Wurde der Treiber im Editor für den Hardwaremodus konfiguriert:
    • wird der Treiber nach Ausführung der Funktion Treiberkommando mit dem Parameter Treiber in Simulationsmodus in den Modus Simulation statisch versetzt.
  2. Wurde der Treiber im Editor für einen der Simulationsmodi (statisch, zählend, programiert) konfiguriert:
    • wird der Treiber nach Ausführung der Funktion Treiberkommando mit dem Parameter Treiber in Hardwaremodus in den Hardwaremodus versetzt und kommuniziert mit der Steuerung
    • wechselt der Treiber anschließend nach Ausführung der Funktion Treiberkommando mit dem Parameter Treiber in Simulationsmodus zurück zum konfigurierten Simulationsmodus


Variablenzuordnung

Variablenzuordnung

Die Zuordnung der zenon Treiber zu den zenon Logic Variablen erfolgt über den auf Großbuchstaben konvertierten Namen. Wenn die zenon Runtime vom Treiber eine Variable anfordert, gibt dieser sie an die Simulation weiter. Ist keine Simulation geladen, erhält die Variable bei gestopptem Treiber den Status abgeschaltet ( OFF/VSB_N_UPD), sonst den Status ungültig (INVALID/_VSB_I_BIT). Variablen vom Treiber-Objekttyp Treibervariable werden von der Simulation nie angefordert.


Zeitstempel

Zeitstempel

Für die Verwendung der Zeitstempelung muss in zenon Logic der Eintrag Projekt -> Projekt-Parameter -> Erweitert -> Compiler -> Optionen ->Statusbit für Variablen mit Profil anlegen aktiv sein.

Wenn im Runtime-Programm das Datum für eine Variable gesetzt wird, wird der Wert von Datum und Zeit als Zeitstempel verwendet. Immer, wenn sich Datum bzw. Zeit einer Variablen zum letzten Zyklus ändert, löst dies eine Übertragung der Werte zum Treiber aus. Das gilt auch, wenn sich weder Wert noch Status geändert haben.

Die meisten Treiber übertragen eine neue Zeitstempelung nur dann an die Runtime, wenn sich gleichzeitig auch Wert und/oder Status ändern. Eine Ausnahme ist aber z.B. der IEC870 Treiber, der auch neue Zeitstempel von der Hardware (oder Simulation - programmiert) mit gleichem Wert und gleichem Status zur Runtime überträgt.

info Info

Es muss gewährleistet sein, dass Datum und Zeit stetig steigen. Ist das nicht der Fall, führt das zu Problemen bei der Archivierung. Das Datum muss einen Wert größer/kleiner 0 haben.

Vom Runtime-Programm gestempelte Variablen erhalten den Status Echtzeit extern (T_EXTERN/_VSB_RT_E).

Alle zum Treiber zu übertragende Variablen, die nicht von der Runtime gestempelten wurden, erhalten im Zyklus eine gemeinsame Zeitstempelung. Dadurch wird sichergestellt, dass die Zeit jener der Änderung entspricht. Diese Treiber erhalten den Status Echtzeit intern (T_INTERN/_VSB_RT_I).

Datum & Zeit

Für alle Datums- und Zeitangaben gilt:

  • Zeiten entsprechen der UTC.
  • Alle Zeiten müssen zwischen dem 02. 01. 1970 und 2038 liegen.
  • Die Konvertierung des Datums in einen String erfolgt im Format YYYY/MM/DD.
  • Die Zeit wird in das Format HH:MM:SS konvertiert.


Hinweise zu Variablen in Simulationsprojekten

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - programmiert -> Hinweise zu Variablen in Simulationsprojekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen und Modifizieren von Variablen in Simulationsprojekten gilt:

  1. zenon Logic

    Wenn Variablen für ein Simulationsprojekt in der zenon Logic Workbench erstellt werden, verfügen Sie noch über keine gültige Adressierung für die Kommunikation. Wird die Kommunikation auf Hardware umgeschaltet, kann die Kommunikation unterbrochen werden, wenn die neuen Variablen ohne korrekt angepasste Adressierung in Bildern verwendet werden.

  2. Umbenennen

    Wird eine Variable in einem Simulationsprojekt umbenannt, ändert sich auch der Name der Variablen in zenon entsprechend. So müssen zum Beispiel Namen von Variablen, die in einem VBA-Projekt verwendet werden, auch im VBA-Code angepasst werden.

  3. Integrierte Lösungen

    Variablen von integrierten Lösungen wie zenon Logic, IEC 870 oder IEC 850 dürfen im Simulationsprojekt nicht umbenannt werden. Die Variablen verlieren in diesem Fall ihre Projektinformationen.
    Zum Beispiel: Wird das Project0/Global/NewVar im Simulationsprojekt umbenannt in myNeVariablenwVar wird es in zenon zu myNewVar. Nach der Umbenennung ist die Kommunikation mit der zenon Logic Runtime unmöglich.

  4. Kommunikation basierend auf Variablenname

    Variablen eines Treibers, der basierend auf Variablennamen kommuniziert, dürfen im Simulationsprojekt nicht umbenannt werden.

  5. Löschen oder Import von Variablen

    Wird eine Variable gelöscht oder importiert während in zenon Logic online change aktiv ist, werden in zenon Logic alle Variablen entfernt und neu eingefügt.

  6. Variablen mit aktivem "embed" Symbol

    Variablen, die in einem Programm vorhanden sind und deren "embed" Symbol aktiv gesetzt wurde, sind über die Shared Memory Schnittstelle nicht in zenon vorhanden. Wird eine Variable mit aktivem "embed" Symbol vom Global-Bereich in ein Programm verschoben, dann wird dabei die Variable in zenon gelöscht.


Fehlermeldungen

Handbuch -> Variablen -> Treiber -> Treibersimulation -> Simulation - programmiert -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehlermeldungen im zenonEditor:

Fehlermeldung

Ursache und Lösung

Der gewählte Name wurde bereits bei einem anderen Treiber verwendet, oder enthält ungültige Zeichen! Bitte wählen Sie einen anderen Namen.

Der neue Name des Simulationsprojekts wird bereits im Projekt verwendet oder ist nicht gültig.

  • Vergeben Sie einen gültigen Namen

Das Simulationsprojekt vom Treiber <Dateiname>/<Bezeichnung> ist nicht kompiliert und kann damit nicht genutzt werden! Bitte kompilieren Sie das Projekt in der Workbench.

Für den Treiber steht ein Simulationsprojekt zur Verfügung. Dieses wurde aber nicht kompiliert.

  • starten Sie die zenon Logic Workbench mit dem Simulationsprojekt dieses Treibers
  • kompilieren Sie das Projekt

Tipp: Ob die Simulation bei den Treibereinstellungen auf Simulation - programmiert eingestellt ist, hat keine Auswirkung

Write queue full! Write command for <Name Variable> lost!

Zeigt den Verlust eines Schreibbefehl an.


Treiber austauschen

Handbuch -> Variablen -> Treiber -> Treiber austauschen

Treiber können in zenon ausgetauscht werden. Die Variablen sind auch nach dem Treiberwechsel weiterhin verfügbar und funktionsfähig, sofern sie beim ausgetauschten Treiber vorhanden sind. Der Austausch der Treiberdefinition ist nur für die frei gegebenen und als kompatibel erklärten Treiber möglich.

attention Achtung

Treiber, die mit einem zenon Logic Projekt über die integrierte Lösung verknüpft sind, können nicht ausgetauscht werden.

Um einen bereits bestehenden Treiber zu tauschen:

  1. wählen Sie den zu tauschenden Treiber in der Detailansicht
  2. öffnen Sie mit einem Rechtsklick das Kontextmenü
  3. wählen Sie den Befehl Treiber austauschen
  4. der gleiche Dialog wie beim Anlegen eines Treibers wird geöffnet
  5. wählen Sie den neuen Treiber

Notwendige Einstellungen für den oder die Treiber (Schnittstellen, Interruptadresse etc.) werden bei der Variablenprojektierung definiert.

Example Beispiel

Während der Entstehungsphase eines Projektes liegt das Adresskonzept für zenon noch nicht vor. Lediglich die zu verwendenden Variablen sind festgelegt.

Um ein paralleles Bearbeiten des Projektes zu ermöglichen, wird als Treiber der Treiber für Simulator-Variablen eingebunden. Die Erstellung der Bilder mit den dynamischen Verknüpfungen und der Onlinetest (Sollwertvorgabe etc.) können vorgenommen werden.

Liegt das endgültige Adresskonzept mit der Ankopplung an zenon vor, wird der Treiber geändert und ist unter Projektbedingungen einsetzbar.

Das Ändern des Treibers ist jedoch nur unter der Voraussetzung möglich, dass der bei der Projektierung verwendete und der endgültig zum Einsatz kommende Treiber die gleichen Eigenschaften (Variablentypen) besitzen.


Treiber löschen

Handbuch -> Variablen -> Treiber -> Treiber löschen

Um einen Treiber zu löschen, wählen Sie in der Detailansicht des Treibers im Kontextmenü oder in dr Symbolleiste den Befehl Löschen. Der Löschvorgang muss über eine Sicherheitsabfrage bestätigt werden.

Achtung: Alle dazugehörigen Variablen werden ebenfalls gelöscht.


Treibervariablen

Handbuch -> Variablen -> Treiber -> Treibervariablen

Das Treiberkit implementiert eine Reihe von Treibervariablen. Diese sind unterteilt in:

  • Information
  • Konfiguration
  • Statistik und
  • Fehlermeldungen

Die Definitionen der im Treiberkit implementierten Variablen sind in der Importdatei drvvar.dbf (auf der CD im Verzeichnis: CD_Laufwerk:/Predefined/Variables) verfügbar und können von dort importiert werden.

Hinweis: Variablennamen müssen in zenon einzigartig sein. Soll nach einem Import der Treibervariablen aus drvvar.dbf ein erneuter Import durchgeführt werden, müssen die zuvor importierten Variablen umbenannt werden.

info Info

Nicht jeder Treiber unterstützt alle Treibervariablen.

Zum Beispiel werden:

  • Variablen für Modem-Informationen nur von modemfähigen Treibern unterstützt
  • Treibervariablen für den Polling-Zyklus nur für rein pollenden Treibern
  • verbindungsbezogene Informationen wie ErrorMSG nur von Treibern, die zu einem Zeitpunkt nur eine Verbindung bearbeiten

Information

Name aus Import | Typ | Offset | Erklärung
MainVersion | UINT | 0 | Haupt-Versionsnummer des Treibers.
SubVersion | UINT | 1 | Sub-Versionsnummer des Treibers.
BuildVersion | UINT | 29 | Build-Versionsnummer des Treibers.
RTMajor | UINT | 49 | zenon Hauptversionsnummer
RTMinor | UINT | 50 | zenon Sub-Versionsnummer
RTSp | UINT | 51 | zenon Servicepack-Nummer
RTBuild | UINT | 52 | zenon Buildnummer
LineStateIdle | BOOL | 24.0 | TRUE, wenn die Modemleitung belegt ist.
LineStateOffering | BOOL | 24.1 | TRUE, wenn ein Anruf rein kommt.
LineStateAccepted | BOOL | 24.2 | Der Anruf wird angenommen.
LineStateDialtone | BOOL | 24.3 | Rufton wurde erkannt.
LineStateDialing | BOOL | 24.4 | Wahl aktiv.
LineStateRingBack | BOOL | 24.5 | Während Verbindungsaufbau.
LineStateBusy | BOOL | 24.6 | Zielstation besetzt.
LineStateSpecialInfo | BOOL | 24.7 | Spezielle Statusinformation empfangen.
LineStateConnected | BOOL | 24.8 | Verbindung hergestellt.
LineStateProceeding | BOOL | 24.9 | Wahl ausgeführt.
LineStateOnHold | BOOL | 24.10 | Verbindung in Halten.
LineStateConferenced | BOOL | 24.11 | Verbindung im Konferenzmodus.
LineStateOnHoldPendConf | BOOL | 24.12 | Verbindung in Halten für Konferenz.
LineStateOnHoldPendTransfer | BOOL | 24.13 | Verbindung in Halten für Transfer.
LineStateDisconnected | BOOL | 24.14 | Verbindung beendet.
LineStateUnknow | BOOL | 24.15 | Verbindungszustand nicht bekannt.
ModemStatus | UDINT | 24 | Aktueller Modemstatus.
TreiberStop | BOOL | 28 | Treiber gestoppt Bei Treiberstop, hat die Variable den Wert TRUE und ein OFF-Bit. Nach dem Treiberstart, hat die Variable den Wert FALSE und kein OFF-Bit.
SimulRTState | UDINT | 60 | Informiert über Status der Runtime bei Treibersimulation.

Konfiguration

Name aus Import | Typ | Offset | Erklärung
ReconnectInRead | BOOL | 27 | Wenn TRUE, dann wird beim Lesen automatisch ein Neuaufbau der Verbindung durchgeführt.
ApplyCom | BOOL | 36 | Änderungen an den Einstellungen der seriellen Schnittstelle zuweisen. Das Schreiben auf diese Variable hat unmittelbar den Aufruf der Methode SrvDrvVarApplyCom zur Folge (aktuell ohne weitere Funktion).
ApplyModem | BOOL | 37 | Änderungen an den Modemeinstellungen zuweisen. Das Schreiben auf diese Variable hat unmittelbar den Aufruf der Methode SrvDrvVarApplyModem zur Folge. Diese schließt die aktuelle Verbindung und öffnet eine neue entsprechend den Einstellungen PhoneNumberSet und ModemHwAdrSet.
PhoneNumberSet | STRING | 38 | Telefonnummer, welche verwendet werden soll.
ModemHwAdrSet | DINT | 39 | Hardwareadresse, welche zu der Telefonnummer gehört.
GlobalUpdate | UDINT | 3 | Updatezeit in Millisekunden (ms).
BGlobalUpdaten | BOOL | 4 | TRUE, wenn die Updatezeit global ist.
TreiberSimul | BOOL | 5 | TRUE, wenn der Treiber in Simulation ist.
TreiberProzab | BOOL | 6 | TRUE, wenn das Prozessabbild gehalten werden soll.
ModemActive | BOOL | 7 | TRUE, wenn das Modem bei diesem Treiber aktiv ist.
Device | STRING | 8 | Name der seriellen Schnittstelle oder Name des Modem.
ComPort | UINT | 9 | Nummer der seriellen Schnittstelle.
Baudrate | UDINT | 10 | Baudrate der seriellen Schnittstelle.
Parity | SINT | 11 | Parität der seriellen Schnittstelle.
ByteSize | SINT | 14 | Bitanzahl pro Zeichen der seriellen Schnittstelle. Wert = 0, wenn der Treiber keine serielle Kommunikation herstellen kann.
StopBit | SINT | 13 | Anzahl der Stoppbits der seriellen Schnittstelle.
Autoconnect | BOOL | 16 | TRUE, wenn die Modemverbindung automatisch beim Lesen/Schreiben aufgebaut werden soll.
PhoneNumber | STRING | 17 | Aktuelle Telefonnummer.
ModemHwAdr | DINT | 21 | Hardwareadresse zur aktuellen Telefonnummer.
RxIdleTime | UINT | 18 | Wenn länger als diese Zeit in Sekunden (s) erfolgreich kein Datenverkehr stattfindet, wird die Modemverbindung beendet.
WriteTimeout | UDINT | 19 | Maximale Schreibdauer bei einer Modemverbindung in Millisekunden (ms).
RingCountSet | UDINT | 20 | So oft läutet ein hereinkommender Anruf, bevor dieser angenommen wird.
ReCallIdleTime | UINT | 53 | Wartezeit zwischen Anrufen in Sekunden (s).
ConnectTimeout | UDINT | 54 | Zeit in Sekunden (s) für Verbindungsaufbau.

Statistik

Name aus Import | Typ | Offset | Erklärung
MaxWriteTime | UDINT | 31 | Längste Zeit in Millisekunden (ms), die zum Schreiben benötigt wird.
MinWriteTime | UDINT | 32 | Kürzeste Zeit in Millisekunden (ms), die zum Schreiben benötigt wird.
MaxBlkReadTime | UDINT | 40 | Längste Zeit in Millisekunden (ms), die zum Lesen eines Datenblocks benötigt wird.
MinBlkReadTime | UDINT | 41 | Kürzeste Zeit in Millisekunden (ms), die zum Lesen eines Datenblocks benötigt wird.
WriteErrorCount | UDINT | 33 | Anzahl der Schreibfehler.
ReadSucceedCount | UDINT | 35 | Anzahl der erfolgreichen Leseversuche.
MaxCycleTime | UDINT | 22 | Längste Zeit in Millisekunden (ms), die zum Lesen aller angeforderten Daten benötigt wurde.
MinCycleTime | UDINT | 23 | Kürzeste Zeit in Millisekunden (ms), die zum Lesen aller angeforderten Daten benötigt wurde.
WriteCount | UDINT | 26 | Anzahl der Schreibversuche.
ReadErrorCount | UDINT | 34 | Anzahl der fehlerhaften Leseversuche.
MaxUpdateTimeNormal | UDINT | 56 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Normal in Millisekunden (ms).
MaxUpdateTimeHigher | UDINT | 57 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Höher in Millisekunden (ms).
MaxUpdateTimeHigh | UDINT | 58 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Hoch in Millisekunden (ms).
MaxUpdateTimeHighest | UDINT | 59 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Höchste in Millisekunden (ms).
PokeFinish | BOOL | 55 | Geht für eine Abfrage auf 1, wenn alle anstehenden Pokes ausgeführt wurden.

Fehlermeldungen

Name aus Import | Typ | Offset | Erklärung
ErrorTimeDW | UDINT | 2 | Zeit (in Sekunden seit 1.1.1970), wann der letzte Fehler auftrat.
ErrorTimeS | STRING | 2 | Zeit (in Sekunden seit 1.1.1970), wann der letzte Fehler als String auftrat.
RdErrPrimObj | UDINT | 42 | Nummer des PrimObjektes, als der letzte Lesefehler verursacht wurde.
RdErrStationsName | STRING | 43 | Name der Station, als der letzte Lesefehler verursacht wurde.
RdErrBlockCount | UINT | 44 | Anzahl der zu lesenden Blöcke, als der letzte Lesefehler verursacht wurde.
RdErrHwAdresse | UDINT | 45 | Hardwareadresse, als der letzte Lesefehler verursacht wurde.
RdErrDatablockNo | UDINT | 46 | Bausteinnummer, als der letzte Lesefehler verursacht wurde.
RdErrMarkerNo | UDINT | 47 | Merkernummer, als der letzte Lesefehler verursacht wurde.
RdErrSize | UDINT | 48 | Blockgröße, als der letzte Lesefehler verursacht wurde.
DrvError | SINT | 25 | Fehlermeldung als Nummer.
DrvErrorMsg | STRING | 30 | Fehlermeldung als Klartext.
ErrorFile | STRING | 15 | Name der Fehlerprotokolldatei.


Treiber-Dokumentationen

Handbuch -> Variablen -> Treiber -> Treiber-Dokumentationen

Informationen über alle zenon Treiber entnehmen Sie bitte der jeweiligen Treiber-Dokumentation. Diese finden Sie im Kapitel Treiber.

info Info

Sollten Sie einen Treiber oder eine Treiber-Dokumentation nicht finden, erhalten Sie Hilfe von support@copadata.com.


Variablen erstellen, modifizieren und nutzen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen können angelegt werden:

  • als einfache Variable
  • in Arrays
  • als Struktur-Variablen

Dialog Variable

Um eine neue Variable zu erstellen, gleich welchen Typs:

  1. wählen Sie im Knoten Variablen im Kontextmenü den Befehl Variable neu

  2. der Dialog zur Konfiguration der Variable wird geöffnet
  3. konfigurieren Sie die Variable
  4. welche Einstellungen möglich sind, hängt ab vom Typ der Variablen

Eigenschaft

Beschreibung

Name

Eindeutiger Name der Variablen. Ist eine Variable mit gleichem Namen im Projekt bereits vorhanden, kann keine weitere Variable mit diesem Namen angelegt werden.

Achtung: Das Zeichen # ist im Variablennamen nicht zugelassen. Bei Verwendung nicht zugelassener Zeichen kann die Variablenerstellung nicht abgeschlossen werden, die Schaltfläche Fertigstellen bleibt inaktiv.

Treiber

Wählen Sie aus der Dropdownliste den gewünschten Treiber.

Hinweis: Sollte im Projekt noch kein Treiber angelegt sein, wird automatisch der Treiber für interne Variable (Intern.exe) geladen.

Treiber-Objekttyp

Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.

Datentyp

Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.

Array-Einstellungen

Erweiterte Einstellungen für Array-Variablen. Details dazu lesen Sie im Abschnitt Arrays.

Adressierungsoptionen

Erweiterte Einstellungen für Arrays und Struktur-Variablen. Details dazu lesen Sie im jeweiligen Abschnitt.

Automatische Elementeaktivierung

Erweiterte Einstellungen für Arrays und Struktur-Variablen. Details dazu lesen Sie im jeweiligen Abschnitt.

Ableitung vom Datentyp

Messbereich, Signalbereich und Sollwert Setzen werden immer:

  • vom Datentyp abgeleitet
  • beim Ändern des Datentyps automatisch angepasst

Hinweis Signalbereich: Bei einem Wechsel auf einen Datentyp, der den eingestellten Signalbereich nicht unterstützt, wird der Signalbereich automatisch angepasst. Zum Beispiel wird bei einem Wechsel von INT auf SINT der Signalbereich auf 127 geändert. Die Anpassung erfolgt auch dann, wenn der Signalbereich nicht vom Datentyp abgeleitet wurde. In diesem Fall muss der Messbereich manuell angepasst werden.

Noch in diesem Kapitel

Einfache Variable

Arrays

Struktur-Variablen

Projektübergreifende Variablen


Einfache Variable

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Einfache Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einfache Variablen bestehen immer aus einem Datentyp und einem Treiber-Objekttyp. Sie bilden die Basis für Array-Variablen und Struktur-Variablen.

Noch in diesem Kapitel

Anlegen einer einfachen Variable

Ändern der Eigenschaften einer einfachen Variable

Löschen von einfachen Variablen


Anlegen einer einfachen Variable

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Einfache Variable -> Anlegen einer einfachen Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klicken Sie im Projektmanager mit der rechten Maustaste auf Variable und wählen Sie im Kontextmenü Variable neu...

Definieren Sie im folgenden Dialog Name, Treiber , Treiber-Objekttyp und Datentyp.

Eigenschaft | Beschreibung
Name Interne ID: Anlegen einer einfachen Variable Name Eindeutiger Name der Variable. Das Zeichen # ist nicht erlaubt. Hinweis: Für Treiber, die auf einer zenon Logic Verbindung beruhen, ist ein Präfix zu beachten. Details siehe Abschnitt Anlegen von B und B Variablen in zenon Logic im Handbuch. Änderungen des Variablennamens müssen in den Programmierumgebungen (VBA, VSTA, PCE) nachgezogen werden. Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Eindeutiger Name der Variablen. Ist eine Variable mit gleichem Namen im Projekt bereits vorhanden, kann keine weitere Variable mit gleichem Namen angelegt werden.
Treiber Interne ID: Anlegen einer einfachen Variable Treiber Treiber für die Variable. Dieser wird beim Erstellen der Variable ausgewählt und kann hier später verändert werden. Hinweis: Treiber für zenon Logic Projekte können nachträglich nicht mehr verändert werden. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Wählen Sie aus der Dropdownliste den gewünschten Treiber.
Treiber-Objekttyp Interne ID: Anlegen einer einfachen Variable Treiber-Objekttyp Abhängig vom verwendeten Teiber wird bei der Erstellung der Variable ein Objekttyp ausgewählt und kann hier später geändert werden. Siemens: Datenbaustein, Merker, Ein-/Ausgang. Modbus: Coil und Holding Register. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.
Datentyp Interne ID: Anlegen einer einfachen Variable Datentyp Datentyp der Variable; wird beim Erstellen der Variable ausgewählt und kann hier später verändert werden. ACHTUNG: Wenn der Datentyp nachträglich geändert wird, müssen alle anderen Eigenschaften der Variable überprüft bzw. angepasst werden. Mehr im Online-Handbuch Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "" | Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.

Die neu angelegte Variable wird in der Detailansicht des Projektmanagers angezeigt. Weitere Eigenschaften der Variablen editieren Sie im Eigenschaftenfenster der Variablen.


Ändern der Eigenschaften einer einfachen Variable

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Einfache Variable -> Ändern der Eigenschaften einer einfachen Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Änderungen von Variableneigenschaften werden im Eigenschaften-Fenster vorgenommen. Klicken Sie dazu die zu ändernde Variable in der Liste der Detailansicht an und geben Sie die gewünschten Änderungen im Eigenschaften-Fenster ein.

Noch in diesem Kapitel

Variable modifizieren

Fehler beim Variable modifizieren


Variable modifizieren

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Einfache Variable -> Ändern der Eigenschaften einer einfachen Variable -> Variable modifizieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Dialog Variable modifizieren wird aufgeschalten, wenn eine oder mehrere Variablen selektiert wurden und eine der folgenden Eigenschaften ausgewählt wird:

  1. Datentyp

    Interne ID: Variable modifizieren

    Datentyp

    Datentyp der Variable; wird beim Erstellen der Variable ausgewählt und kann hier später verändert werden.

    ACHTUNG: Wenn der Datentyp nachträglich geändert wird, müssen alle anderen Eigenschaften der Variable überprüft bzw. angepasst werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. Treiber

    Interne ID: Variable modifizieren

    Treiber

    Treiber für die Variable. Dieser wird beim Erstellen der Variable ausgewählt und kann hier später verändert werden.

    Hinweis: Treiber für zenon Logic Projekte können nachträglich nicht mehr verändert werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. Treiber-Objekttyp

    Interne ID: Variable modifizieren

    Treiber-Objekttyp

    Abhängig vom verwendeten Teiber wird bei der Erstellung der Variable ein Objekttyp ausgewählt und kann hier später geändert werden.
    Siemens: Datenbaustein, Merker, Ein-/Ausgang.
    Modbus: Coil und Holding Register.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. Array-Einstellungen

    Interne ID: Variable modifizieren

    Array-Einstellungen

    Eigenschaften für die Struktur von Variablen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    1. Dim 1

      Interne ID: Variable modifizieren

      Dim 1

      Größe der ersten Dimension des Arrays.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    2. Dim 2

      Interne ID: Variable modifizieren

      Dim 2

      Größe der zweiten Dimension des Arrays.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    3. Dim 3

      Interne ID: Variable modifizieren

      Dim 3

      Größe der dritten Dimension des Arrays.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    4. Startindex

      Interne ID: Variable modifizieren

      Startindex

      Wählen Sie den Startindex des Arrays aus der Dropdown-Liste aus.

      Mehr im Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  5. Offset-Berechnung

    Interne ID: Variable modifizieren

    Offset-Berechnung

    Selektieren Sie die gewünschte Berechnungsart für den Offset. Folgende Möglichkeiten stehen Ihnen zur Verfügung:

    • Adresse folgt Datentyp-Offset und Start-Offset
    • Automatische Adressierung
    • Manuelle Addressierung

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  6. Datentyp

Hier werden Einstellungen geändert, die eine Einheit bilden, und zwar für alle Variablen, welche durch Mehrfachselektion spezifiziert werden.

Modifikation, wenn mehrerer Variablen selektiert wurden:

Wenn der Wert der Eigenschaft bei allen selektierten Variablen gleich ist, wird dieser im entsprechenden Dialog angezeigt, wenn nicht bleibt der Eintrag leer. Leer bedeutet, dass die Einstellung nicht definiert wurde. Ist eine Selektion erfolgt, ist es nicht mehr möglich 'keine Selektion' vorzunehmen. Ist dies gewünscht muss er Dialog mit Abbruch verlassen werden und neu aufgeschaltet werden. (Ausnahme: Checkboxen).

Solange der Treiber nicht spezifiziert ist, enthält die Combobox Treiberobjekttyp alle Treibertypen, die bei dem Treiber der selektierten Variable möglich sind. Wird der Treiber ausgewählt, werden nur jene Treibertypen des spezifizierten Treibers angezeigt. Wenn ein Treiber von oder zu einem zenon Logic -Treiber geändert wird, wird der Name der Variable automatisch geändert und angepasst.
Beim Multiselect von Variablen haben die Checkboxen drei Zustände: ein, aus und undefiniert. Nicht definierte Felder werden bei der Variable nicht geändert. Wenn ein Feld spezifiziert wurde, legt dieses den neuen Wert für alle selektieren Variablen fest.

Prüfung vor der Modifikation:

Für jede Variable wird vor der Modifikation geprüft, ob die resultierenden Einstellungen erlaubt sind.

Example Beispiel

Beispiel für eine unerlaubte Modifikation: Eine Array-Variable und eine einfache Variable wurden selektiert, die Array-Dimension wird geändert. Fehler: Eine einfache Variable darf nachträglich nicht auf eine Array-Variable geändert werden.

Für Variablen, die nicht auf die neuen Einstellungen abgeändert werden können, wird eine Fehlermeldung generiert. Vor der Modifikation werden diese im Dialog Fehler beim Variable modifizieren, nach der Modifikation im Editor-Ausgabefenster angezeigt.


Fehler beim Variable modifizieren

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Einfache Variable -> Ändern der Eigenschaften einer einfachen Variable -> Fehler beim Variable modifizieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollte eine Änderung für eine oder mehrere Variablen unmöglich sein, wird der Dialog Fehler beim Variablen modifizieren geöffnet. Dieser dient zur Anzeige der Variablen, welche die gemachten Änderungen nicht übernehmen können. Er wird aufgeschaltet bevor eine Änderung vorgenommen wird und nur dann, wenn nicht änderbare Variablen vorhanden sind. Die Einträge sind filter- und sortierbar.

Parameter | Beschreibung
Name | Name der Variable, welche die Änderungen nicht übernehmen kann.
Treiber | Name des Treibers mit Treiberbezeichnung auf dem die Variable basiert.
Datentyp | Datentyp welchen die Variable verwendet.
Treiber-Objekttyp | Treiber-Objekttyp, den die Variable verwendet.
Meldung | Beschreibung der Ursache warum die Variable die Änderungen nicht übernehmen kann
Abbruch | Modifizieren der Variable wird beendet. Keine Modifikationen werden durchgeführt.
Alle ignorieren | Alle Variablen, welche die Änderungen nicht übernehmen können, werden ignoriert. Die Variablen, für die die Änderungen durchführbar sind, werden modifiziert. Für übergangene Variablen wird eine Meldung im Ausgabefenster erzeugt. Der Text entspricht jenem der 'Meldung'.
Zurück | Zurück zum Modifikationsdialog.
Statuszeile | Anzahl der selektierten Variable und der Hinderungsgründe. Beim Erkennen des ersten Verhinderungsgrundes wird die Variable als nicht-modifizierbar betrachtete. Es können noch weitere Hinderungsgründe vorliegen, welche nicht mehr ermittelt werden. Bei komplexen Variablen (Array oder Struktur) werden auch alle bereits aktivierten Variablen geprüft, ob diese mit den Änderungen umgehen können. Für jede nicht-modifizierbare, aktivierte Variable wird eine Meldung erzeugt. Daraus folgt, dass die Anzahl der Hinderungsgründe höher sein kann, als die Anzahl der selektierten Variablen.


Löschen von einfachen Variablen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Einfache Variable -> Löschen von einfachen Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klicken Sie mit der rechten Maustaste auf die zu löschende Variable in der Liste der Detailansicht, um die Löschoption im folgenden Kontextmenü zu erhalten:

Klicken Sie auf Löschen, erhalten Sie die folgende Sicherheitsabfrage:


Arrays

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Arrays sind Felder von Datentypen bzw. von Variablen. Wir unterscheiden:

  • Datentyp-Arrays: können nur in Strukturen realisiert werden.
  • Variablen-Arrays: lassen sich auch mit einfachen Datentypen realisieren.

Arrays können in maximal drei Dimensionen erstellt werden.

Example Beispiel

Beispiel für eine zweidimensionale Array Variable:

Drehzahl [2,3]
Diese Variable besteht aufgelöst aus 6 Variablen (2x3):

  • Drehzahl [1,1]
  • Drehzahl [1,2]
  • Drehzahl [1,3]
  • Drehzahl [2,1]
  • Drehzahl [2,2]
  • Drehzahl [2,3].

Intern werden Arrays wie Strukturen behandelt. Das betrifft besonders die Adressierung.

attention Achtung

Array-Variablen, die auf einem stratonNG oder straton32 Treiber basieren, dürfen nicht mit 1 beginnen. Ein zenon Array mit der Dimension 1,2,2 wird in zenon Logic nur als einfache Variable angelegt.

Inaktive Variablen

Einzelne Variablen eines Arrays lassen sich inaktiv schalten. Inaktive Variable

  • stehen in zenon nicht zur Verfügung
  • werden nicht beim Treiber angemeldet
  • werden bei der Berechnung der I/Os für die Lizenzgröße nicht berücksichtigt

So können in einem Array Reserve-Variablen angelegt werden, die zu einem späteren Zeitpunkt, z.B. bei einem Ausbau, aktiviert werden können.

Größe Blockarray (bis Version 5.50)

Bis Version 5.50 konnte mit der Eigenschaft Größe Blockarray die Größe des Blockarrays definiert werden. Damit ist es möglich, zum Beispiel nur eine lizenzierte Variable einzusetzen, im RGM oder in VBA aber mehrere Variablen mit Treibern, die Offset-Adressen nutzen, indirekt zu adressieren. Diese Eigenschaft ist aus Kompatibilitätsgründen weiter vorhanden.

Interne ID: Arrays

Größe Blockarray

Nur mehr aus Kompatibilitätsgründen vorhanden.
Bis Version 5.50 Definition der Block-Array-Größe.
Achtung: Im Intern Treiber zwar einstellbar, aber zur Runtime ohne Funktion (Wert immer 0).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Achtung: Der Intern Treiber unterstützt diese Eigenschaft nicht. Im Editor kann zwar ein Wert definiert werden, zur Runtime werden aber keine Variablen angezeigt (Wert immer 0).

Noch in diesem Kapitel

Array-Variable anlegen

Adressierung

Ändern der Eigenschaften eines Arrays

Aktiv/Inaktiv schalten von Array Elementen


Array-Variable anlegen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays -> Array-Variable anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einfache Array-Variablen werden wie einfache Variablen angelegt.

Eigenschaft | Beschreibung
Name | Eindeutiger Name der Variablen. Ist eine Variable mit gleichem Namen im Projekt bereits vorhanden, kann keine weitere Variable mit diesem Namen angelegt werden.
Treiber | Wählen Sie aus der Dropdownliste den gewünschten Treiber. Hinweis: Sollte im Projekt noch kein Treiber angelegt sein, wird automatisch der Treiber für interne Variable (Intern.exe) geladen.
Treiber-Objekttyp | Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.
Datentyp | Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.
Automatische Adressierung | zenon berechnet die automatische Adressvergabe. Diese ist abhängig von der Granularität des verwendeten Treiber-Objekttyps dem IEC Datentyp auf dem der verwendete Datentyp basiert
Offset Adresse folgt Datentyp-Offset und Start-Offset | Der Offset folgt dem beim zugeordneten Strukturelement projektierten Offset und Bit.
Manuelle Adressierung | Manuelle Adressierung.
Jeder Datentyp startet mit neuem Offset | Bestimmt bei automatischer Adressierung wie die einzelnen Array-Elemente positioniert werden. Aktiv: Für jedes Array Element wird ein neuer Offset anfangen. Inaktiv: Offsets werden komplett genutzt (Variablen werden aneinander gereiht).
Alle Elemente aktivieren | Aktiviert beim anlegen der neuen Array Variable alle Elemente automatisch
Elemente manuell aktivieren | Die Elemente werden beim anlegen nicht aktiviert. Sie müssen manuell in der Variablenliste aktiviert werden. Der entsprechende Vorgang wird über das Kontextmenü in der Variablenliste erreicht.


Adressierung

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays -> Adressierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Arrays werden standardmäßig automatisch adressiert. Dabei werden bei der Array-Variablen angegeben:

  • Netzadresse
  • Start-Offset
  • Datenbaustein (optional)
  • Bit-Nummer (optional)

Bei den einzelnen Array-Elementen muss nichts mehr eingestellt werden. Die Berechnung der Adresse erfolgt automatisch.

Wenn Arrays manuell adressiert werden sollen, dann muss die Option Manuelle Adressierung entweder bereits bei der Erstellung des Arrays oder zu einem späteren Zeitpunkt im Eigenschaften-Fenster aktiviert werden.

Die Adressberechnung wird neu durchgeführt bei Änderungen von:

  • Datentyp eines Arrays
  • Treiber-Objekttyp
  • Treiber
  • Array-Dimension

Noch in diesem Kapitel

Beispiel für Array mit automatischer Adressierung für eine INT Variable

Beispiel für Array mit automatischer Adressierung für eine BOOL Variable

Beispiel für Array mit manueller Adressierung:


Beispiel für Array mit automatischer Adressierung für eine INT Variable

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays -> Adressierung -> Beispiel für Array mit automatischer Adressierung für eine INT Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wir möchten ein Array von 5 Integer Variablen erzeugen.

Basiskonfiguration

Im Konfigurationsdialog der Variablen

  • Name: freie Vergabe
  • Treiber: S7 TCP/IP
  • Treiber-Objekttyp: Erw. Datenbausteine
  • Datentyp: INT
  • Array: Startindex ist 1
  • Dim 1: 5
  • Dim 2: 0
  • Adressierung: Automatische Adressierung
  • Jeder Datentyp startet mit neuem Offset: aktiv
  • Elementeaktivierung: Alle Elemente aktivieren

In der Variablenliste werden nach dem Klick auf OK die 5 gewünschten Variablen angelegt und eine entsprechende Array-Variable, in der wir die Array-Eigenschaften bestimmen können.

Detailkonfiguration

Wenn wir die Array Variable in der Detail Ansicht selektieren, können wir im Eigenschaften-Fenster die Eigenschaften des gesamten Arrays beeinflussen. Die wichtigsten Einstellungen finden wir in der Gruppe Adressierung. Dort stellen wir für das Array ein:

  • Datenbaustein
  • Netzadresse (=Busadresse)
  • Startoffset

Da wir automatische Adressierung gewählt haben, hängen alle Adressen der einzelnen Array-Elemente an diesem Startoffset. In unserem Beispiel ändern wir den Datenbaustein auf 50, die Netzadresse lassen wir auf 0 und den Offset ändern wir auf 100.

Die Granularität der S7 Datenbausteine beträgt 8 Bit. Der Datenbausteinbereich ist also BYTE orientiert. Jede INT Variable benötigt 16 Bit. Daraus ergibt sich folgende automatische Adressierung für unser Array:

Array | Netzadresse | Datenbaustein | Offset
Array of INT[1] | 0 | 50 | 100
Array of INT[2] | 0 | 50 | 102
Array of INT[3] | 0 | 50 | 104
Array of INT[4] | 0 | 50 | 106
Array of INT[5] | 0 | 50 | 108

Die Offsets sind also immer um zwei verschoben, da eine 16 Bit Variable zwei 8 Bit Offsets benötigt.

Würden wir anstelle des S7 Treibers einen S5 Treiber verwenden, ergäbe sich ein anderes Bild. Auf der S5 hat der Datenbausteinbereich nämlich eine Granularität von 16 Bit. Der Datenbausteinbereich einer S5 Steuerung ist WORT orientiert. Bei identischer Projektierung ergäbe sich folgendes Bild:

Array | Netzadresse | Datenbaustein | Offset
Array of INT[1] | 0 | 50 | 100NT
Array of INT[2] | 0 | 50 | 101
Array of INT[3] | 0 | 50 | 102
Array of INT[4] | 0 | 50 | 103
Array of INT[5] | 0 | 50 | 104

Die Offsets sind nur um eine Stelle erhöht, da eine 16 Bit Variable nur einen 16Bit Offset benötigt.


Beispiel für Array mit automatischer Adressierung für eine BOOL Variable

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays -> Adressierung -> Beispiel für Array mit automatischer Adressierung für eine BOOL Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wir gehen vor wie im Beispiel der automatischen Adressierung mit Datentyp INT, verwenden aber als Datentyp den Standard-Datentyp BOOL. Alle anderen Einstellungen bleiben wie dort beschrieben und wir erzeugen eine neue Array-Variable.

In den Eigenschaften der Array-Variable vergeben wir folgende Werte:

Datenbaustein: 50

Netzadresse: 0

Offset: 100

Bit-Nummer: 0

Beim S7 Treiber ergibt sich aus der automatischen Adressierung folgendes Bild:

Array | Netzadresse | Datenbaustein | Offset | Bit-Nummer
Array of INT[1] | 0 | 50 | 100 | 0
Array of INT[2] | 0 | 50 | 101 | 0
Array of INT[3] | 0 | 50 | 102 | 0
Array of INT[4] | 0 | 50 | 103 | 0
Array of INT[5] | 0 | 50 | 104 | 0

Eine 1 Bit Variable hat in einem 8 Bit Offset Platz. Durch die Einstellung Jeder Datentyp startet mit einem neuen Offset wurde jedes Array-Element auf einen neuen Offset gelegt.

Wählen wir diese Eigenschaft bei der Array Variable ab ergibt sich dieses geänderte Bild:

Array | Netzadresse | Datenbaustein | Offset | Bit-Nummer
Array of INT[1] | 0 | 50 | 100 | 0
Array of INT[2] | 0 | 50 | 100 | 1
Array of INT[3] | 0 | 50 | 100 | 2
Array of INT[4] | 0 | 50 | 100 | 3
Array of INT[5] | 0 | 50 | 100 | 4

Die Bits werden also hintereinander in einen Offset gelegt. Würde ein Offset nicht ausreichen wie z.B. bei einem Array von 20 BOOL Variablen, würde beim nächsten Offset weitergemacht werden. Ein Array von 20 BOOL Variablen würde also von Offset 100 Bit-Nummer 0 bis zum Offset 102 Bit-Nummer 3 reichen.


Beispiel für Array mit manueller Adressierung:

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays -> Adressierung -> Beispiel für Array mit manueller Adressierung:

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

ür die manuelle Adressierung muss in der Variablenkonfiguration die Eigenschaft Manuelle Adressierung ausgewählt werden. Dann können bei jedem Array-Element die Adressinformationen manuell vergeben werden für:

  • Netzadresse
  • Offset
  • Datenbaustein (optional)
  • Bit-Nummer (optional)

Für das Beispiel für Array mit automatischer Adressierung für eine BOOL Variable könnte das dann so aussehen:

Array | Netzadresse | Datenbaustein | Offset | Bit-Nummer
Array of INT[1] | 0 | 50 | 100 | 0
Array of INT[2] | 0 | 50 | 100 | 2
Array of INT[3] | 0 | 50 | 101 | 0
Array of INT[4] | 0 | 50 | 101 | 2
Array of INT[5] | 0 | 50 | 102 | 0

attention Achtung

Wird entweder der Startoffset des Arrays oder die Größe der Arrray-Dimension geändert, werden alle Adressinformationen (Offset und Bitadresse) neu berechnet.

Bei einer Änderung des Start-Offsets werden die Offsets der bereits aktivierten Variablen um das Delta der Änderung mitgeändert. Die Offsetdifferenz der aktivierten Variable zu ihrer Arrayvariablen bleibt also erhalten.


Ändern der Eigenschaften eines Arrays

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays -> Ändern der Eigenschaften eines Arrays

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Eigenschaften werden über das Eigenschaften-Fenster und den Dialog Variable modifizieren geändert.

Beachten Sie vor allem zwei spezielle Eigenschaften:

  • Letzter Verwendeter Offset: gibt an, welcher Offset (inklusive Bit-Nummer) bei automatischer Adressierung als letzter benutzt wurde.
  • Größe in Byte: Gibt an, wie viele Byte vom entsprechenden Array belegt wurden.

Nicht geändert werden können:

  • Name
  • Aktivierung der Elemente

Eigenschaft | Beschreibung
Treiber | Wählen Sie aus der Dropdownliste den gewünschten Treiber. Hinweis: Sollte im Projekt noch kein Treiber angelegt sein, wird automatisch der Treiber für interne Variable (Intern.exe) geladen.
Treiber-Objekttyp | Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.
Datentyp | Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.
Automatische Adressierung | zenon berechnet die automatische Adressvergabe. Diese ist abhängig von der Granularität des verwendeten Treiber-Objekttyps dem IEC Datentyp auf dem der verwendete Datentyp basiert
Offset Adresse folgt Datentyp-Offset und Start-Offset | Der Offset folgt dem beim zugeordneten Strukturelement projektierten Offset und Bit.
Manuelle Adressierung | Manuelle oder halbautomatische Adressierung.
Jeder Datentyp startet mit neuem Offset | Bestimmt bei automatischer Adressierung wie die einzelnen Array-Elemente positioniert werden. Aktiv: Für jedes Array Element wird ein neuer Offset anfangen. Inaktiv: Offsets werden komplett genutzt (Variablen werden aneinander gereiht).

Hinweis zur Änderung des IEC Datentyps

Wird der IEC Datentyp eines Arrays geändert, dann gilt:

  • Solange der Wert des aktuellen Signalbereichs innerhalb der Signalbereiche des Datentyps ist wird keine Anpassung vorgenommen.
  • Der Messbereich wird nicht angepasst.

    Ausnahme: Beim Datentyp BOOL werden immer Signal- und Messbereich angepasst.

Für die Anpassung des Signalbereichs gilt, dass der neue Signalbereich kleiner als der vorherige sein muss:

  • SingalbereichMin wird nur angepasst, wenn SignalbereichMinNeu < SignalbereichMinAlt ist
  • SignalbereichMax wird nur angepasst, wenn SignalbereichMaxNeu < SignalbereichMinAlt ist


Aktiv/Inaktiv schalten von Array Elementen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Arrays -> Aktiv/Inaktiv schalten von Array Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jedes Array Element kann separat aktiviert bzw. deaktiviert werden. Das Aktivieren wird entweder beim Anlegen des Arrays (alle Elemente aktivieren) erledigt, oder manuell über das Kontextmenü der einzelnen Array Elemente. Inaktive Array Elemente werden bei der automatischen Adressierung so berücksichtigt, als ob sie vorhanden wären. Die inaktiven Elemente sind Platzhalter die jederzeit später aktiviert werden können.


Struktur-Variablen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Struktur besteht aus einzelnen Elementen. Diese sind immer Datentypen. Beim Anlegen eines Struktur-Elements muss immer ein bereits bestehender Datentyp ausgewählt werden. Struktur Elemente können entweder eingebettet oder verknüpft sein.

Parameter | Beschreibung
Eingebettete Struktur-Elemente | Können von ihrem Ursprungs-Datentyp unterschiedliche Eigenschaften übernehmen. Die Eigenschaften werden bei jedem Struktur-Element extra eingestellt und dort gespeichert.
Verknüpfte Struktur-Elemente | Übernehmen immer alle Eigenschaften aus dem ursprünglichen Datentyp, von dem Sie abgeleitet sind. Ändert sich der ursprüngliche Datentyp, ändern sich alle davon abgeleiteten verknüpften Struktur-Elemente mit!

Struktur-Datentypen

Details zum Erstellen von Struktur-Datentypen lesen Sie im Abschnitt Datentypen/Struktur-Datentypen.

Struktur-Variablen

Struktur-Variablen basieren immer auf einem Struktur-Datentyp. Sie übernehmen daher prinzipiell den Aufbau der zugrunde liegenden Struktur. Beim Anlegen einer Struktur-Variablen können mehrere Optionen mit angegeben werden:

Parameter

Beschreibung

Arrays

Es kann gewählt werden, ob die Struktur als einzelne Struktur-Variable angelegt wird oder als Array. Bei Struktur-Arrays können bis zu drei Dimensionen eingestellt werden.

Adressierung

Die Adressierung der Struktur-Variablen kann automatisch oder manuell erfolgen. Standardmäßig wird die Adressierung automatisch berechnet. Die Adressberechnung ist dabei von der Granularität des eingesetzten Treiber-Objekttyps und der verwendeten Struktur-Elemente abhängig.

Bei der automatischen Adressierung kann jeder Datentyp bei einem neuen Offset gestartet werden.

Aktivieren von Elementen bei Struktur-Variablen

Es kann eingestellt werden, ob alle Elemente der Struktur aktiviert werden sollen oder nicht.

Aktivieren bedeutet, dass alle Elemente aktiv geschaltet werden. Aktive Variable können sofort in zenon verwendet werden. Inaktive Variable stehen in zenon nicht zur Verfügung, werden bei der Berechnung der I/Os für die Lizenzgröße nicht berücksichtigt und werden auch nicht beim Treiber angemeldet. Damit können in einer Struktur Reservebereiche angelegt werden, die zu einem späteren Zeitpunkt aktiviert werden können. Alle Elemente einer Struktur-Variablen sind jederzeit über das Kontextmenü aktivierbar beziehungsweise deaktivierbar.

Hinweis: Auch deaktivierte Struktur-Variablen werden bei der Adressberechnung berücksichtigt. Ist das nicht erwünscht, müssen die Adressen entweder manuell vergeben oder das entsprechende Struktur-Element beim Datentyp gelöscht werden.

Verhalten beim XML-Import

Strukturen

Strukturen, die sich von bestehenden unterscheiden, können in bereits bestehende Strukturen importiert werden. Darauf basierende Variablen werden automatisch angepasst:

  • Die Strukturelemente werden über ihren Namen identifiziert.
  • Bei bereits bestehenden Strukturelementen wird der Typ angepasst, sofern er sich unterscheidet.
  • Nicht bestehende Elemente werden hinzugefügt.
  • Elemente, die es im neuen Strukturdatentyp nicht gibt, werden entfernt.

Inaktive Variablen

Beim Import von Strukturvariablen werden sowohl aktive als auch inaktive Variablen importiert. Vorhandene Elemente werden beim Import nicht überschrieben. Wird also in einem Projekt eine inaktive Variable importiert und anschließend aktiviert, bleibt sie auch nach einem erneuten XML-Import aktiv.

Noch in diesem Kapitel

Anlegen von Struktur-Variablen

Ändern von Struktur-Variablen

Löschen von Struktur-Variablen


Anlegen von Struktur-Variablen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Anlegen von Struktur-Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Struktur-Variable anzulegen:

  1. legen Sie eine einfache Variable an
  2. wählen Sie als Datentyp einen Struktur-Datentyp aus
  3. wählen Sie Treiber und Treiber-Objekttyp
  4. definieren Sie die Array Dimensionen

Eigenschaft | Beschreibung
Name | Eindeutiger Name der Variablen. Ist eine Variable mit gleichem Namen im Projekt bereits vorhanden, kann keine weitere Variable mit diesem Namen angelegt werden.
Treiber | Wählen Sie aus der Dropdownliste den gewünschten Treiber. Hinweis: Sollte im Projekt noch kein Treiber angelegt sein, wird automatisch der Treiber für interne Variable (Intern.exe) geladen.
Treiber-Objekttyp | Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.
Datentyp | Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.
Automatische Adressierung | zenon berechnet die automatische Adressvergabe. Diese ist abhängig von der Granularität des verwendeten Treiber-Objekttyps und dem IEC Datentyp, auf dem der verwendete Datentyp basiert
Offset Adresse folgt Datentyp-Offset und Start-Offset | Der Offset folgt dem beim zugeordneten Strukturelement projektierten Offset und Bit.
Manuelle Adressierung | Manuelle oder halbautomatische Adressierung.
Jeder Datentyp startet mit neuem Offset | Bestimmt bei automatischer Adressierung wie die einzelnen Struktur-Elemente positioniert werden. Aktiv: Für jedes Struktur-Element wird ein neuer Offset anfangen. Ein Bit-Offset > 0 bewirkt die Erhöhung des Offset um 1. Inaktiv: Offsets werden komplett genutzt (Variablen werden aneinander gereiht).
Alle Elemente aktivieren | Aktiviert beim Anlegen der neuen Struktur-Variable alle Elemente automatisch.
Elemente manuell aktivieren | Die Elemente werden beim anlegen nicht aktiviert. Sie müssen manuell in der Variablenliste aktiviert werden. Der entsprechende Vorgang wird über das Kontextmenü in der Variablenliste erreicht.

Ausrichtung Datentypen bei automatischer Adressierung

  • Ein Treiber mit BYTE Granularität kann nur bei BOOL die Bits 0 bis 7 verwenden. Alle anderen Datentypen beginnen auf Bit 0.
  • Bei WORD: BOOL Bits 0 bis 15, U(S)INT die Bit 0 und 8. Alle anderen Datentypen beginnen auf Bit 0.
  • Bei DWORD: BOOL Bits 0 bis 31, U(S)INT die Bit 0, 8, 16, 24. (U)INT die Bit 0 und 16. Alle anderen Datentypen beginnen auf Bit 0.
  • Strings müssen immer auf Bit 0 beginnen.
    Daraus folgt: Wenn bei der aktuellen Adresse der Bitoffset > 0 ist wird die Variable auf Bit 0 und Offset+1 gelegt.

Beispiel

USINT = 8Bit, Granularität WORD = 16bit.

Die Variable kann nur auf den Bits 0 oder 8 beginnen. Wenn z.B. als Bitoffset 2 projektiert wurde und die aktuelle Adresse Offset=0 Bit=0 ist, wird die Variable auf Offset 0 Bit 8 gelegt. Würde die aktuelle Adresse Offset=0 und Bit=7 sein, auf Offset=1 Bit=0

Noch in diesem Kapitel

Einfache Struktur mit automatischer Adressierung

Struktur-Variable als Array mit automatischer Adressierung

Manuelle Adressierung


Einfache Struktur mit automatischer Adressierung

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Anlegen von Struktur-Variablen -> Einfache Struktur mit automatischer Adressierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beispiel

Im ersten Schritt erstellen wir einen Struktur-Datentyp. Dazu legen wir eine Struktur Regler mit vier Elementen an:

  • Drehzahl Soll (UINT),
  • Drehzahl Ist (USINT),
  • Array [2] von
    • Ein/Aus (BOOL) und
  • Überwachung (SINT).

Als nächstes müssen wir mit dem Dialog Variable erstellen eine Struktur-Variable erstellen, die auf diesem Datentyp basiert. Wir verwenden für dieses Beispiel:

  • den S7 TCP/IP Treiber
  • den Datenbaustein Bereich
  • die Array Dimension 0
  • die aktivierten Optionen
    • Automatische Adressierung
    • Jeder Datentyp startet mit neuem Offset
    • Alle Elemente aktivieren

In der Variablenliste wird nach dem Klick auf Fertig stellen die gewünschte Struktur mit allen Elementen angelegt.

Wenn wir die Struktur-Variable „Drehzahl-Regelung" in der Detail Ansicht selektieren, können wir im Eigenschaften-Fenster die Eigenschaften der gesamten Struktur beeinflussen. Die wichtigsten Einstellungen finden wir in der Gruppe Adressierung. Dort stellen wir den Datenbaustein, die Netzadresse (=Busadresse) und den Startoffset für die Struktur ein. Da wir automatische Adressierung gewählt haben hängen alle Adressen der einzelnen Struktur Elemente an diesem Startoffset.

In unserem Beispiel stellen wir ein:

Datenbaustein: 50

Offset: 100

Netzadresse: 0

Die Granularität der S7 Datenbausteine beträgt 8 Bit. Der Datenbausteinbereich ist also BYTE orientiert. Jede UINT Variable benötigt 16 Bit, Jede USINT Variable 8 Bit, jede BOOL Variable 1 Bit und jede SINT Variable 8 Bit.

Daraus ergibt sich folgende automatische Adressierung für unsere Struktur:

Variable | Netzadresse | Datenbaustein | Offset | Bit-Nummer
Drehzahl-Regelung.Drehzahl.Soll | 0 | 50 | 100 | 0
Drehzahl-Regelung.Drehzahl.Ist | 0 | 50 | 102 | 0
Drehzahl-Regelung.Drehzahl.Ein/Aus[1] | 0 | 50 | 104 | 0
Drehzahl-Regelung.Drehzahl.Ein/Aus[2] | 0 | 50 | 105 | 1
Drehzahl-Regelung.Drehzahl.Überwachung | 0 | 50 | 106 | 0

Letzter verwendeter Offset: 106 Bit 7

Die einzelnen Elemente der Struktur-Variable werden also optimal in die Offsets eingepasst.

Die 8 Bit Variable „Drehzahl-Regelung.Drehzahl.Soll" belegt einen Offset, die 16 Bit Variable „Drehzahl-Regelung.Drehzahl.Ist" belegt zwei Offsets, die beiden BOOL Variablen belegen in einem Offset zwei Bits und die Variable „Drehzahl-Regelung.Drehzahl.Überwachung" belegt einen Offset.

Die Adressen können nur über den Struktur Datentyp oder über die Adresseinstellungen in der Struktur-Variable, nicht aber über die einzelnen Struktur-Variablen Elemente angepasst werden. Das wäre nur bei manueller Adressierung möglich.

Würden wir anstelle des S7 Treibers einen S5 Treiber verwenden ergäbe sich ein anderes Bild. Auf der S5 hat der Datenbausteinbereich nämlich eine Granularität von 16 Bit. Der Datenbausteinbereich einer S5 Steuerung ist WORT orientiert.

Bei identischer Projektierung ergäbe sich folgendes Bild:

Variable | Netzadresse | Datenbaustein | Offset | Bit-Nummer
Drehzahl-Regelung.Drehzahl.Soll | 0 | 50 | 100 | 0
Drehzahl-Regelung.Drehzahl.Ist | 0 | 50 | 101 | 0
Drehzahl-Regelung.Drehzahl.Ein/Aus[1] | 0 | 50 | 102 | 0
Drehzahl-Regelung.Drehzahl.Ein/Aus[2] | 0 | 50 | 102 | 1
Drehzahl-Regelung.Drehzahl.Überwachung | 0 | 50 | 102 | 8

Letzter Verwendeter Offset: 102 Bit 15

Die einzelnen Elemente der Struktur-Variable werden auch hier optimal in die Offsets eingepasst.

Die 8 Bit „Drehzahl-Regelung.Drehzahl.Soll" Variable belegt einen „halben" Offset (die Bits 0 bis 7), die 16 Bit Variable „Drehzahl-Regelung.Drehzahl.Ist" belegt einen Offset. Die beiden BOOL Variable belegen nur die ersten zwei Bits des Offset 102 und daher startet die Variable „Drehzahl-Regelung.Drehzahl.Überwachung" im selben Offset wie die beiden BOOL mit Bit-Nummer 8.


Struktur-Variable als Array mit automatischer Adressierung

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Anlegen von Struktur-Variablen -> Struktur-Variable als Array mit automatischer Adressierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Array beim Strukturelement mit einfachem Datentyp

Variablen werden ausgehend vom Offset beim Strukturelement, entsprechend IEC Datentyp und Granularität gepackt adressiert. Es besteht somit kein Unterschied zu der Adressierung „gepackt".

Strukturvariable als Array

Die Adresse des ersten Strukturelements beim Index n ergibt sich aus der Adresse des letzten Strukturelements bei Index n-1 plus dem Offset beim Strukturelement.

Ist die Eigenschaft Jeder Datentyp startet mit neuem Offset

  • aktiv: beginnt der Index immer auf einem ganzen Offset (Bit ist 0, eventuell um Offset beim Strukturelement geschoben).
  • inaktiv: wird entsprechend Datentyp und Granularität „gepackt" adressiert und um den Offset vom Strukturelement verschoben. Unabhängig davon wird die Variable entsprechend Datentyp und Granularität ausgerichtet.

Beispiel

Wir verwenden dasselbe Beispiel wie im Abschnitt Einfache Struktur mit automatischer Adressierung, ändern jedoch bei den Eigenschaften der Struktur-Variable die Array Dimension 1 von 0 auf 2 ab.

Nach Klick auf Fertig stellen ergibt sich folgendes Bild in der Variablenliste:

Die bestehende Struktur wurde dahingehend abgeändert, dass nun jedes Struktur-Element zweifach zur Verfügung steht.

Für unser Beispiel mit dem S7 Treiber ergibt sich daher folgendes Bild bei der automatischen Adressierung, wenn eingestellt ist: Jeder Datentyp startet mit neuem Offset:

Variable | Netzadresse | Datenbaustein | Offset | Bit-Nummer
Drehzahl-Regelung[1].Drehzahl.Soll | 0 | 50 | 100 | 0
Drehzahl-Regelung[1].Drehzahl.Ist | 0 | 50 | 101 | 0
Drehzahl-Regelung[1].Drehzahl.Ein/Aus[1] | 0 | 50 | 103 | 0
Drehzahl-Regelung[1].Drehzahl.Ein/Aus[2] | 0 | 50 | 103 | 1
Drehzahl-Regelung[1].Drehzahl.Überwachung | 0 | 50 | 104 | 0
Drehzahl-Regelung[2].Drehzahl.Soll | 0 | 50 | 105 | 0
Drehzahl-Regelung[2].Drehzahl.Ist | 0 | 50 | 106 | 0
Drehzahl-Regelung[2].Drehzahl.Ein/Aus[2] | 0 | 50 | 108 | 0
Drehzahl-Regelung[2].Drehzahl.Ein/Aus[2] | 0 | 50 | 108 | 1
Drehzahl-Regelung[2].Drehzahl.Überwachung | 0 | 50 | 109 | 0

Letzter verwendeter Offset: 109 Bit 7

Die Array Struktur wurde genau so wie eine einfache Struktur angelegt. Das zweite Struktur Array startet genau dort, wo das erste aufhört.

Ändern wir den Treiber auf den S5 Treiber ergibt sich folgendes Bild:

Variable | Netzadresse | Datenbaustein | Offset | Bit-Nummer
Drehzahl-Regelung[1].Drehzahl.Soll | 0 | 50 | 100 | 0
Drehzahl-Regelung[1].Drehzahl.Ist | 0 | 50 | 101 | 0
Drehzahl-Regelung[1].Drehzahl.Ein/Aus[1] | 0 | 50 | 102 | 0
Drehzahl-Regelung[1].Drehzahl.Ein/Aus[2] | 0 | 50 | 102 | 1
Drehzahl-Regelung[1].Drehzahl.Überwachung | 0 | 50 | 102 | 8
Drehzahl-Regelung[2].Drehzahl.Soll | 0 | 50 | 103 | 0
Drehzahl-Regelung[2].Drehzahl.Ist | 0 | 50 | 104 | 0
Drehzahl-Regelung[2].Drehzahl.Ein/Aus[2] | 0 | 50 | 105 | 0
Drehzahl-Regelung[2].Drehzahl.Ein/Aus[2] | 0 | 50 | 105 | 1
Drehzahl-Regelung[2].Drehzahl.Überwachung | 0 | 50 | 105 | 7

Letzter verwendeter Offset: 105 Bit 15

Jeder Datentyp startet mit neuem Offset

Die Array Struktur wurde genau so wie eine einfache Struktur angelegt. Das zweite Struktur Array startet genau dort, wo das erste aufhört. Hier kann es bedingt durch die Option Jeder Datentyp startet mit neuem Offset Unterschiede geben. Ist diese Option aktiv, wird der Start des nächsten Struktur-Arrays immer auf einen neuen Offset gelegt, unabhängig davon, ob sich die nächste Struktur noch in den aktuellen Offset packen ließe.

Example Beispiel

Das letzte Struktur Element ist ein SINT (8Bit) und belegt Offset 102 Bit 0 bis 7. Die nächste Struktur würde dann beim Beispiel S5 Treiber (16 Bit Offsets) wie folgt starten:

  • Option aktiviert „Jeder Datentyp startet mit neuem Offset“: Offset 103 Bit 0
  • Option deaktiviert „Jeder Datentyp startet mit neuem Offset“: Offset 102 Bit 8. Die Strukturen würden also unmittelbar aneinander gereiht werden.


Manuelle Adressierung

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Anlegen von Struktur-Variablen -> Manuelle Adressierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Adressen können bei manueller Adressierung halbautomatisch oder komplett manuell vergeben werden.

Halbautomatische Lösung

Die Offsets und die Bit-Nummer werden bei den Struktur Elementen im Datentyp eingetragen. Dort wird allerdings nur ein relativer Offset eingestellt. Bei der Struktur-Variable wird ein Start-Offset vergeben, und alle relativen Offsets werden zu diesem Start-Offset hinzugezählt.

Beispiel

Wie in Einfache Struktur mit automatischer Adressierung erstellen wir den Struktur-Datentyp Struktur Regler. Bei den einzelnen Struktur-Elementen wird dann bei jedem Element ein beliebiger Offset eingestellt, z.B. Offset 3 beim Struktur Element Drehzahl Soll.

Bei der Struktur-Variablen wird dann beim Anlegen die Option Manuelle Adressierung gesetzt. In den Eigenschaften der Struktur-Variable wird als Start-Offset wieder 100 vergeben. zenon errechnet dann bei der Adresse der Variable „Drehzahl-Regelung.Drehzahl.Soll“ den Offset 103 (100 von der Struktur + 3 vom Struktur Element).

Soll der relative Offset zu einem späteren Zeitpunkt geändert werden, muss wie folgt vorgegangen werden:

  • Zuerst muss der Offset beim Struktur Element im Datentyp geändert werden.
  • Dann muss der Start Offset bei der Struktur Variable geändert werden (z.B auf 101).
  • Und dann wieder zurück auf den Ausgangs Offset (in unserem Beispiel 100).

Hintergrund: Die neue Adressberechnung erfolgt erst wenn der Start Offset bei der Strukturvariable geändert wird, und nicht bei einer Offset Änderung im Struktur Element.

Komplett manuelle Lösung

Projektierung im Prinzip wie bei der halbautomatischen Lösung, nur werden bei der Struktur Variable bei jedem Element die Adressen manuell vergeben.

Bei einer Änderung des Start-Offsets einer Struktur-Variable werden die Offsets der bereits aktivierten Variablen um das Delta der Änderung mitgeändert. Die Offsetdifferenz der aktivierten Variable zu ihrer Strukturvariable bleibt also erhalten.


Ändern von Struktur-Variablen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Ändern von Struktur-Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Änderungen werden über die Eigenschaften und den Dialog Variable modifizieren durchgeführt.

Nicht geändert werden können:

  • Name
  • Aktivierung der Elemente

Eigenschaft | Beschreibung
Treiber | Wählen Sie aus der Dropdownliste den gewünschten Treiber. Hinweis: Sollte im Projekt noch kein Treiber angelegt sein, wird automatisch der Treiber für interne Variable (Intern.exe) geladen.
Treiber-Objekttyp | Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.
Datentyp | Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.
Automatische Adressierung | zenon berechnet die automatische Adressvergabe. Diese ist abhängig von der Granularität des verwendeten Treiber-Objekttyps und dem IEC Datentyp, auf dem der verwendete Datentyp basiert
Offset Adresse folgt Datentyp-Offset und Start-Offset | Der Offset folgt dem beim zugeordneten Struktur-Element projektierten Offset und Bit.
Manuelle Adressierung | Manuelle oder halbautomatische Adressierung.
Jeder Datentyp startet mit neuem Offset | Bestimmt bei automatischer Adressierung wie die einzelnen Struktur-Elemente positioniert werden. Aktiv: Für jedes Struktur-Element wird ein neuer Offset anfangen. Inaktiv: Offsets werden komplett genutzt (Variablen werden aneinander gereiht).

Noch in diesem Kapitel

Ändern der Eigenschaften

Aktiveren und Deaktivieren von Struktur Elementen

Ändern der Reihenfolge


Ändern der Eigenschaften

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Ändern von Struktur-Variablen -> Ändern der Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Änderungen werden über das Eigenschaften-Fenster durchgeführt.

Beachten Sie, dass Änderungen bei der Struktur-Variable selbst sich auf die einzelnen Elemente der Struktur-Variable auswirken können (z.B. Adressberechnungen wenn Sie den Startoffset bzw. den Treiber ändern). Bei jedem Element der Struktur-Variable können die Eigenschaften separat geändert werden. Änderungen können Sie entweder bei den einzelnen Elementen vornehmen oder bei den Struktur-Elementen des zugrunde liegenden Struktur-Datentyps. Die Änderungen werden dann weitervererbt. (Siehe dazu Kapitel Vererbungskonzept)


Aktiveren und Deaktivieren von Struktur Elementen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Ändern von Struktur-Variablen -> Aktiveren und Deaktivieren von Struktur Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dazu selektieren Sie das entsprechende Element und führen im Kontextmenü die entsprechende Aktion aus. Inaktive Elemente werden bei der automatischen Adressierung so berücksichtigt, als ob sie vorhanden wären. Die inaktiven Elemente sind Platzhalter die jederzeit später aktiviert werden können.

Inaktive Variable

  • stehen in zenon nicht zur Verfügung
  • werden nicht beim Treiber angemeldet
  • werden bei der Berechnung der I/Os für die Lizenzgröße nicht berücksichtigt

Wichtige Hinweise

Beachten Sie beim Deaktivieren von Variablen:

  • Variablenbezüge in Bildelementen gehen durch das Deaktivieren verloren. Diese Bezüge können nur mehr manuell wiederhergestellt werden.
  • Wenn ein Struktur Element auf einem IEC Datentyp basiert, der beim gewählten Treiber nicht zulässig ist, dann lässt sich dieses Element nicht aktivieren.
  • Wenn Variablen deaktiviert und dann erneut aktiviert wurden, sind die dynamischen Elemente für diese Variablen im Editor nicht aktualisiert. Um diese zu aktualisieren, klicken Sie im Eigenschaftenfenster des Elements auf die entsprechende Variable.


Ändern der Reihenfolge

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Ändern von Struktur-Variablen -> Ändern der Reihenfolge

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Reihenfolge der Struktur Elemente einer Struktur Variable kann nur beim entsprechenden Struktur Datentyp erfolgen. Bei Änderungen am Struktur-Datentyp werden alle darauf basierenden Struktur Variable geändert!


Löschen von Struktur-Variablen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Struktur-Variablen -> Löschen von Struktur-Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Markieren Sie die Variable in der Detailansicht und drücken sie die Taste Entf.


Projektübergreifende Variablen

Handbuch -> Variablen -> Variablen erstellen, modifizieren und nutzen -> Projektübergreifende Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen können auch aus anderen Projekten ausgewählt und projektübergreifend verwendet werden. Das ist auch in unterschiedlichen Hierarchien möglich. Variablen aus übergeordneten, gleichrangigen und untergeordneten Projekte, aber auch Variablen aus nicht verbundenen Projekten, können beliebig genutzt werden.

Um Variablen projektübegreifend zu nutzen, müssen alle betroffenen Projekte beim Projektieren und zur Runtime:

  • geladen sein
  • im Netzwerk erreichbar sein
    Hinweis: zenon überprüft zur Runtime nicht die Erreichbarkeit im Netzwerk.

Im Projekt werden Variablen, die aus anderen Projekten stammen, in folgender Schreibweise angezeigt:
[Projektname]#[Variablenname], zum Beispiel Projekt1#WIZ_VAR_10

Sollte eine übergreifende Nutzung nicht möglich sein, werden andere Projekte im Variablenauswahldialog ausgegraut dargestellt.

Hinweis: werden Projektnamen nachträglich geändert oder Projekte kopiert, muss für die weitere korrekte Zuweisung gesorgt werden. Benutzen Sie dazu den Dialog zum Ersetzen von Projektbezügen.

attention Achtung

Beachten Sie die besonderen Bedingungen für projektübergreifende Variablen in der Befehlsgabe.


Vererbungskonzept

Handbuch -> Variablen -> Vererbungskonzept

Vererbung bedeutet, dass Eigenschaften eines Objekts an ein von diesem Objekt abgeleitetes Objekt weitergegeben werden. Das abgeleitete Objekt übernimmt prinzipiell alle Eigenschaften des Basisobjekts, kann aber einzelne Eigenschaften, oder auch alle Eigenschaften von diesem Basisobjekt abändern = überschreiben.

Im Gegensatz dazu gibt es auch die Verlinkung. Dabei werden zwar auch die Eigenschaften eines Basisobjekts übernommen, können aber beim gelinkten Objekt nicht geändert/überschrieben werden. Eine Änderung ist nur beim Basisobjekt möglich.

Für beide Fälle gilt: Wenn eine Eigenschaft im Basisobjekt geändert wird, übernehmen alle Objekte, die von diesem Basisobjekt abgeleitet sind, die Änderung mit. Die einzelnen Eigenschaften sind also nicht direkt beim abgeleiteten Objekt gespeichert, sondern werden immer vom Basisobjekt referenziert.

Ausnahme: Sobald ein Wert beim abgeleiteten Objekt überschrieben (geändert) wurde, verliert diese Eigenschaft den Bezug zum Basisobjekt (nur bei der Vererbung). Wird eine überschriebene Eigenschaft beim Basisobjekt geändert, ändert sich die Eigenschaft beim abgeleiteten Projekt nicht mehr mit. Das betrifft aber nur jene Eigenschaft, bei der die Verbindung zum Basisobjekt unterbrochen wurde. Alle anderen Eigenschaften werden nach wie vor vom Basisobjekt übernommen. Eine überschriebene Eigenschaft kann jederzeit wieder zurück in eine abgeleitete Eigenschaft umgewandelt werden.

Noch in diesem Kapitel

Vererbung in zenon

Vererben von Eigenschaften eines Datentyps bei einfachen Variablen


Vererbung in zenon

Handbuch -> Variablen -> Vererbungskonzept -> Vererbung in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon sind die Basisobjekte die Datentypen. Sowohl einfache, als auch Struktur Datentypen verknüpfen ihre Eigenschaften an die auf Ihnen aufbauenden Variablen.

Die Variablen sind die von den Datentypen abgeleiteten Objekte. Von diesen erben sie im Prinzip alle Eigenschaften. Ausnahme sind Eigenschaften, die

nur bei der Variable einstellbar sind wie z.B. die Adressierung ihren Ursprung nicht im Datentyp haben, sondern die vom Treiber-Objekttyp abhängen.

In den Strukturen gibt es die Struktur Elemente. Diese können entweder eingebettet oder verknüpft sein. Wenn sie verknüpft sind, übernehmen Sie alle Eigenschaften von dem Datentyp, mit dem Sie verknüpft sind. Alle Änderungen am Ursprungs-Datentyp werden 1:1 übernommen. Es können aber keine Eigenschaften überschrieben werden, da sie eben nur verknüpft, aber nicht vererbt sind.

Die eingebetteten Struktur Elemente eines Struktur Datentyps haben im Prinzip gar keinen Bezug mehr zu ihrem Ursprungs-Datentyp. Sie sind Kopien, bei denen alle Eigenschaften separat eingestellt werden können. Änderungen am Ursprungs-Datentyp wirken sich nicht aus. Eingebettete Struktur Elemente können jederzeit wieder in verknüpfte Struktur Elemente umgewandelt werden und umgekehrt.

Noch in diesem Kapitel

Vererbung von Eigenschaften bei Struktur Datentypen und Struktur Variablen


Vererbung von Eigenschaften bei Struktur Datentypen und Struktur Variablen

Handbuch -> Variablen -> Vererbungskonzept -> Vererbung in zenon -> Vererbung von Eigenschaften bei Struktur Datentypen und Struktur Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei den Struktur Variablen funktioniert es ganz gleich wie bei den einfachen Variablen. Nur sind die Eigenschaften entsprechend bei jedem einzelnen Struktur Element einzustellen. Jedes Element einer Struktur Variable hat seine Entsprechung in einem Struktur Element des Struktur Datentyps auf dem die Struktur Variable basiert.

Erschwerend kommt hier hinzu, dass ein Struktur Element wieder mit einem Datentyp verknüpft sein kann.

Struktur Variable Element erbt die Eigenschaften vom Struktur Element welches wiederum mit einem Datentyp verknüpft ist.

Noch komplexer stellt es sich dar, wenn Strukturen in Strukturen verwendet werden:

Variable mit Struktur in Struktur

Im obigen Beispiel ist die Variable Motor.Drehzahl Regelung. Drehzahl Ist von der Struktur Motor abgeleitet. Diese wiederum beinhaltet das Struktur Element Drehzahl Regelung, das wiederum eine Struktur ist. Diese Struktur ist in die Struktur Motor verknüpft, da Strukturen in Strukturen nur verknüpft sein können. In dieser Struktur Drehzahl Regelung findet sich wiederum der Datentyp INT verknüpft.

Wenn also in diesem Datentyp etwas geändert wird, wirken sich diese Änderungen direkt auf die Variable Motor.Drehzahl Regelung. Drehzahl Ist aus.

Änderungen an den Datentypen sollten entsprechend vorsichtig durchgeführt werden.

Das überschreiben von Eigenschaften bzw. das wiederherstellen der Ableitung vom Datentyp erfolgt wie weiter oben beschrieben.


Vererben von Eigenschaften eines Datentyps bei einfachen Variablen

Handbuch -> Variablen -> Vererbungskonzept -> Vererben von Eigenschaften eines Datentyps bei einfachen Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen einer neuen Variable sind prinzipiell alle Eigenschaften vom Datentyp vererbt. Man erkennt das daran, dass in der Eigenschaft selber ein Häkchen eingeblendet wird.

Abgeleitete Eigenschaften erkennt man am Häkchen

In diesem Beispiel sind alle Eigenschaften vom Datentyp abgeleitet bis auf die Einheit. Diese wurde in der Variable überschrieben. Wird nun die Eigenschaft Einheit im zugrundeliegenden Datentyp geändert, ändert sich die Einheit bei allen Variablen, die auf diesem Datentyp basieren. Nur nicht bei jenen Variablen, bei denen diese Eigenschaft überschrieben (geändert) wurde.

attention Achtung

Bitte beachten Sie, dass Änderungen am Datentyp immer alle Variablen mit ändern, die auf diesem Datentyp basieren (außer die Eigenschaften wurden entsprechend überschrieben).

Noch in diesem Kapitel

Überschreiben von Eigenschaften

Wiederherstellung der Eigenschaften vom Datentyp


Überschreiben von Eigenschaften

Handbuch -> Variablen -> Vererbungskonzept -> Vererben von Eigenschaften eines Datentyps bei einfachen Variablen -> Überschreiben von Eigenschaften

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eigenschaften von Variablen lassen sich auf zwei Arten überschreiben:

  • Die Eigenschaft wird per Tastatur- oder per Mauseingabe geändert. Sobald die Änderung übernommen wird, wird die Verbindung dieser Eigenschaft mit dem Datentyp getrennt.
  • Die Eigenschaft wird über das entsprechende Kontextmenü vom Datentyp getrennt. Dabei kann entweder nur die selektierte Eigenschaft vom Datentyp getrennt werden, oder alle Eigenschaften der Variable. (Screenshot!)

Sobald eine Eigenschaft überschrieben wurde verschwindet das Häkchen. Alle Änderungen im Datentyp haben danach keine Auswirkungen mehr auf diese überschriebenen Eigenschaften einer Variable.


Wiederherstellung der Eigenschaften vom Datentyp

Handbuch -> Variablen -> Vererbungskonzept -> Vererben von Eigenschaften eines Datentyps bei einfachen Variablen -> Wiederherstellung der Eigenschaften vom Datentyp

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Selektieren Sie die überschriebene Eigenschaft und wählen Sie im Kontextmenü den Eintrag Alle Werte vom Datentyp bzw. nur die '<Name>' Wert vom Datentyp aus. Die Eigenschaft bzw. alle Eigenschaften erhalten dann Ihre Ableitungs-Symbole zurück.


Wertberechnung

Handbuch -> Variablen -> Wertberechnung

Die Wertberechnung definiert über verschiedene Eigenschaften den Wertbereich einer Variable.

Flatternde Werte können über verschiedene Eigenschaften abgefangen werden, um ungewollte Reaktionen wie Alarme oder Archiveinträge zu verhindern. Dabei wird unterschieden zwischen:

  • Hysterese: Verhindert die Übertragung flatternder Werte vom Treiber zur Variablen.

    Interne ID: Wertberechnung

    Hysterese

    Eigenschaften für die Hysterese.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Hysterese für Archiv: verhindert die Erstellung von Archiveinträgen bei flatternden Wertänderungen bezogen auf den Messbereich.
  • Schwellwert: Verhindert unerwünschte Reaktionen wie Alarme bei flatternden numerischen Werten.

    Interne ID: Wertberechnung

    Schwellwert

    Es kann ein Schwellwert eingegeben werden, der für das Gehen eines Grenzwertes eingesetzt wird. Ungewollte Reaktionen bei flatternden numerischen Werten können somit vermieden werden.
    Beispiel 1: Maximalwert = 900, Schwellwert = 10, ergibt 890
    Grenzwert ist verletzt ab einem Wert 900 und verlässt den kritischen Bereich wieder, wenn er unter 890 geht.
    Beispiel 2: Minimalwert = 900, Schwellwert = 10, ergibt 910
    Grenzwert ist verletzt ab einem Wert 900 und verlässt den kritischen Bereich wieder, wenn er über 910 geht.
    Im Unterschied zur Hysterese beeinflusst diese Eigenschaft nicht die Darstellung des Wertes, sondern nur das Alarmverhalten.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Hysterese


Hysterese

Handbuch -> Variablen -> Wertberechnung -> Hysterese

Die Hysterese definiert den Bereich, innerhalb dessen eine Wertänderung ignoriert wird. Damit wird verhindert, dass flatternde Werte im Bildelement dargestellt werden und eine ständige Grenzwertverletzung auslösen.

In <CD_ PRODUCTNAME>können Hysteresen in den Eigenschaften der Variablen (Wertberechnung/Hysterese) festgelegt werden für:

Interne ID: Hysterese

Hysterese

Eigenschaften für die Hysterese.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Hysterese

Wertberechnung

Definition des Wertebereichs der Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Wertberechnungen der Variablen: Eigenschaften Positiv für Signal und Negativ für Signal für Signalbereich

    Interne ID: Hysterese

    Negativ für Signal

    Hysterese für Grenzwert bezogen auf Signalbereich.

    Hysteresebereich für Eintrag bei abnehmender Wertänderung. Werte werden nur dann als Grenzwertverletzung interpretiert, wenn die Änderung unter dem hier eingestellten Hysteresebereich liegt.
    Default: 0 (keine Hysterese)

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Hysterese

    Positiv für Signal

    Hysterese für Grenzwert bezogen auf Signalbereich.

    Hysteresebereich für Eintrag bei zunehmender Wertänderung. Werte werden nur dann als Grenzwertverletzung interpretiert, wenn die Änderung über dem hier eingestellten Hysteresebereich liegt.
    Default: 0 (keine Hysterese)

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Sich ändernde Werte, die sich innerhalb der Hysterese befinden, werden vom Treiber nicht zur Variablen übertragen.

  • Einträge in Archive bei Wertänderung: Eigenschaften Positiv für Archiv und Negativ für Archiv für Messbereich

    Interne ID: Hysterese

    Negativ für Archiv

    Hysterese für Archivierung bei Wertänderung bezogen auf Messbereich.

    Hysteresebereich für Eintrag bei abnehmender Wertänderung. Werte werden nur dann ins Archiv eingetragen, wenn die Änderung unter dem hier eingestellten Hysteresebereich liegt.
    Default: 0 (keine Hysterese)

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Hysterese

    Positiv für Archiv

    Hysterese für Archivierung bei Wertänderung bezogen auf Messbereich.

    Hysteresebereich für Eintrag bei zunehmender Wertänderung. Werte werden nur dann ins Archiv eingetragen, wenn die Änderung über dem hier eingestellten Hysteresebereich liegt.
    Default: 0 (keine Hysterese)

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Geänderte Werte, die sich innerhalb der Hysterese befinden, werden nicht ins Archiv eingetragen.

Example Beispiel

Ein Grenzwert ist mit 50° C definiert. Die Temperatur schwankt normalerweise etwas. Damit würde bei jedem Unter- oder Überschreiten der 50°-Grenze der Grenzwert verletzt und ein Alarm ausgelöst und ein Eintrag ins Archiv erfolgen.

Wird für die Variable als Hysterese definiert:

  • Positiv für Signal: 2
  • Negativ für Signal: 2

Und für das Archiv als Hysterese:

  • Positiv für Archiv: 8
  • Negativ für Signal: 6

Dann wird:

  • erst das Überschreiten von 52° und das Unterschreiten von 48° als Grenzwertverletzung gewertet
  • erst beim Überschreiten von 58° und beim Unterschreiten von 44° ein Archiveintrag erstellt

Hinweis: Hysteresen, die nur ungewollte Reaktionen (wie Alarme) auf Grenzwertverletzung bei flatternden numerischen Werten vermeiden sollen, können über Schwellwerte erzeugt werden.

info Info

Nicht jeder Treiber unterstützt Hysterese. Informationen, ob Ihr Treiber Hysterese unterstützt, finden Sie in der Dokumentation des entsprechenden Treibers.


Grenzwerte

Handbuch -> Variablen -> Grenzwerte

Grenzwerte haben die Aufgabe, bei Erreichen oder Überschreiten einer Grenze oder eines Zustandes eine Reaktion auszulösen. Die Grenze wird feststehend im Editor eingetragen oder stellt sich variabel nach dem Wert einer anderen Variablen zur Laufzeit ein. Die Reaktionsarten sind sehr vielfältig. Zum Beispiel: Farbumschläge, Alarm-, CEL Einträge, Ausdrucke, Funktionsaufrufe usw. Die Ausführung der Reaktion erfolgt in zenon.

Die Projektierung von Grenzwerten definiert das Verhalten für numerische Variablen.

Die Projektierung von Zuständen definiert das Verhalten für Binärvariablen (low, high bzw. logisch 0, 1).

Bitte beachten Sie, dass aus Gründen der Allgemeingültigkeit in weiterer Folge auch für Zustände die Bezeichnung Grenzwert verwendet wird.

Ist eine zusätzliche Auswertung der Statusinformationen der Variablen notwendig, so muss die Projektierung über Reaktionsmatrizen erfolgen.

Detaillierte Information zu den Reaktionsmatrizen finden Sie im Abschnitt Reaktionsmatrizen.

Noch in diesem Kapitel

Editorprojektierung von Grenzwerten

Grenzwerte während der Runtime

Dynamischer Grenzwerttext


Editorprojektierung von Grenzwerten

Handbuch -> Variablen -> Grenzwerte -> Editorprojektierung von Grenzwerten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Selektion einer Variablen in der Detailansicht des Projektmanagers werden im Eigenschaften-Fenster alle Eigenschaften der ausgewählten Variable angezeigt.

Um neue Grenzwerte anzulegen, klicken Sie Grenzwert neu. Sobald Sie auf Grenzwerte einfügen klicken, wird jedes Mal ein neuer Grenzwert (Grenzwert 1, Grenzwert 2 ....) in die dahinterliegende Liste eingefügt.

Alle für die Grenzwertprojektierung zur Verfügung stehenden Optionen befinden sich im Eigenschaften-Fenster und werden in der Eigenschaften-Hilfe einzeln erklärt. Diese spezifische Hilfe wird jeweils bei Markierung einer Eigenschaft automatisch eingeblendet.

Es kann eine beliebige Anzahl von Grenzwerten pro Variable definiert werden.

Öffnen Sie nun die Liste, indem Sie die auf das Pluszeichen vor der Eigenschaft Grenzwerte klicken. Alle von Ihnen angelegten Grenzwerte sind darin aufgelistet. Sie können nun einen der Grenzwerte per Mausklick selektieren, worauf sich die Liste der zu definierenden Grenzwerteigenschaften öffnet.

Noch in diesem Kapitel

Verzögerungszeit

Schwellwert

Grenzwerte aus Datentypen ableiten

Mehrfachselektion

Löschen von Grenzwerten

Überlappende Grenzwerte


Verzögerungszeit

Handbuch -> Variablen -> Grenzwerte -> Editorprojektierung von Grenzwerten -> Verzögerungszeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über die Eigenschaft Verzögerungszeit [s] kann in den Eigenschaften für den Grenzwert ein Wert für eine Zeitverzögerung projektiert werden. Dieser Wert definiert die Zeitspanne in Sekunden, in der die Grenzwertverletzung anstehen muss, damit die definierten Aktionen der Grenzwertverletzung ausgelöst werden.
Standardwert: 0 - keine Zeitverzögerung

Interne ID: Verzögerungszeit

Verzögerungszeit [s]

Zeitspanne in Sekunden, in der die Grenzwertverletzung anstehen muss. Der Wert muss mindestens die angegebene Zeitspanne ununterbrochen anstehen, damit die definierten Aktionen der Grenzwertverletzung ausgelöst werden.
AML/CEL:
- Als Zeitstempel für die Grenzwertverletzung in der AML und/oder der CEL wird der Zeitpunkt der ersten Verletzung verwendet.
- Als Wert wird der erste Wert nach der Verzögerungszeit eingetragen, also nicht der Alarm auslösende Wert.

ACHTUNG: In Kombination mit der Eigenschaft Blinken wirkt sich diese Eigenschaft im Netzwerk folgendermaßen aus:
Grenzwert mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Grenzwert mit Blinken und Verzögerung: Verknüpfte Elemente blinken nur am Server, nicht aber auf den Clients.
Alarm mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Alarm mit Blinken und Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.

Interne ID: Verzögerungszeit

Blinken

Aktiv: Dynamische Elemente, die mit dieser Variable verknüpft sind, beginnen zu blinken, sobald dieser Grenzwert verletzt wird.
Das Blinken kann durch einen rechten Doppelklick quittiert werden.
Inaktiv: Kein Blinken wird durch diesen Grenzwert hervorgerufen.
Default: inaktiv.
Achtung: In Kombination mit der Eigenschaft Verzögerungszeit [s] wirkt sich diese Eigenschaft im Netzwerk folgendermaßen aus:
Grenzwert mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Grenzwert mit Blinken und Verzögerung: Verknüpfte Elemente blinken nur am Server, nicht aber auf den Clients.
Alarm mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Alarm mit Blinken und Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Minimum: 0
Maximum: 4294967295
Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Maximalwert: 4294967295 Sekunden

Die Verzögerungszeit gilt unabhängig davon, aus welcher Richtung der Grenzwert verletzt wird.

Beispiel:

  • Projektierung
    • Grenzwert 1 liegt beim Wert 50.
    • Grenzwert 2 liegt beim Wert 100.
    • Die Verzögerungszeit beträgt 3s.
  1. Der Wert steigt auf 110.
    • Nachdem die Verletzung 3 Sekunden angedauert hat, wird die Grenzwertverletzung für den Wert 100 angezeigt.
  2. Der Wert sinkt auf 70.
    • Sobald dieser Wert 3 Sekunden angedauert hat, wird der Alarm für die Grenzwertverletzung 100 deaktiviert und eine Grenzwertverletzung für den Wert 50 angezeigt.
  3. Sinkt der Wert auf 40, wird der Alarm nach 3 Sekunden deaktiviert.

Zeitstempel und Wert

Als Zeitstempel für die Grenzwertverletzung in der AML und der CEL wird der Zeitpunkt der ersten Verletzung eingetragen.
Als Wert wird der erste Wert nach der Verzögerungszeit eingetragen, also nicht der Alarm auslösende Wert.

Legende:

Ziffer

Beschreibung

1

Zeitpunkt der Grenzwertüberschreitung.

Start der projektierten Verzögerungszeit.

Auslösender Wert.

2

Ende der projektierten Verzögerungszeit. Alarm kommt:

  • Zeit: Zeitpunkt der Grenzwertverletzung (1)
  • Angezeigter Wert: Wert nach der Verzögerungszeit (2)

attention Achtung

In Kombination mit der Eigenschaft Blinken wirkt sich diese Eigenschaft im Netzwerk folgendermaßen aus:

  • Grenzwert mit Blinken und ohne Verzögerung:
    Verknüpfte Elemente blinken am Server und auf den Clients.
  • Grenzwert mit Blinken und Verzögerung:
    Verknüpfte Elemente blinken nur am Server, nicht aber auf den Clients.
  • Alarm mit Blinken und ohne Verzögerung:
    Verknüpfte Elemente blinken am Server und auf den Clients.
  • Alarm mit Blinken und Verzögerung:
    Verknüpfte Elemente blinken am Server und auf den Clients.


Schwellwert

Handbuch -> Variablen -> Grenzwerte -> Editorprojektierung von Grenzwerten -> Schwellwert

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schwellwerte verhindern ungewollte Reaktionen bei flatternden numerischen Werten. Sie erzeugen eine Grenzwerthysterese. Der Grenzwert ist damit bei Beginn der Grenzwertverletzung ein anderer als beim Verlassen der Grenzwertverletzung.

Zum Beispiel: Grenzwert max. bei 100, Schwellwert 10. Sobald der Wert der Variable 100 erreicht, wird die Grenzwertverletzung ausgelöst. Fällt der Wert auf 95 passiert noch gar nichts. Erst wenn der Wert auf 89 sinkt, wird die Grenzwertverletzung aufgehoben.

Schwellwerte können für Maximum oder Minimum gesetzt werden. Bei Maximum bewegt sich der Schwellwert nach unten, bei Minimum nach oben.
Beispiel Maximalwert: Maximalwert = 900, Schwellwert = 10, ergibt 890
Grenzwert ist verletzt ab einem Wert 900 und verlässt den kritischen Bereich wieder, wenn er unter 890 geht.
Beispiel Minimalwert: Minimalwert = 900, Schwellwert = 10, ergibt 910
Grenzwert ist verletzt ab einem Wert 900 und verlässt den kritischen Bereich wieder, wenn er über 910 geht.
Im Unterschied zur Hysterese beeinflusst diese Eigenschaft nicht die Darstellung des Wertes, sondern nur das Alarmverhalten.


Grenzwerte aus Datentypen ableiten

Handbuch -> Variablen -> Grenzwerte -> Editorprojektierung von Grenzwerten -> Grenzwerte aus Datentypen ableiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Grenzwerte können bereits bei den Datentypen definiert werden. Die dort projektierten Grenzwerte stehen bei allen Variablen zur Verfügung, die auf dem entsprechenden Datentyp basieren. Es greift dabei das Vererbungskonzept wie weiter oben beschrieben: alle Eigenschaften gestalten sich wie beim Datentyp, und können bei jeder einzelnen Variable überschrieben werden. So kann ein Grenzwert bei einzelnen Variablen selektiv deaktiviert werden. Ein von einem Datentyp vererbter Grenzwert kann bei einer Variable nicht gelöscht werden (löschen ist nur beim Datentyp möglich). Es können einer Variablen jedoch weitere Grenzwerte hinzugefügt werden. Diese variablenspezifischen Grenzwerte können hingegen wieder bei der Variable selbst gelöscht werden.

Nähere Informationen zu den Datentypen finden Sie im Abschnitt Datentypen.


Mehrfachselektion

Handbuch -> Variablen -> Grenzwerte -> Editorprojektierung von Grenzwerten -> Mehrfachselektion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn mehrere Variablen gleichzeitig ausgewählt werden, können auch die Eigenschaften der Grenzwerte bei mehreren Variablen gleichzeitig geändert werden. Wenn eine der selektierten Variablen den zu bearbeitenden Grenzwert nicht besitzt, wird dieser dort auch nicht angelegt.

Bei der Mehrfachselektion von Variablen werden unterschiedliche Eigenschaften im Eigenschaften-Fenster rot angezeigt. (Ausschlaggebend für die Anzeige der Eigenschaften ist immer die zuerst gewählt Variable). Sind Eigenschaften nicht in allen ausgewählten Variablen vorhanden (z.B. Grenzwerte), so werden diese gelb markiert.


Löschen von Grenzwerten

Handbuch -> Variablen -> Grenzwerte -> Editorprojektierung von Grenzwerten -> Löschen von Grenzwerten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klicken Sie in den Grenzwert-Eigenschaften auf Grenzwert löschen.


Überlappende Grenzwerte

Handbuch -> Variablen -> Grenzwerte -> Editorprojektierung von Grenzwerten -> Überlappende Grenzwerte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei analogen Grenzwerten können diese überlappend projektiert werden. Dabei bemerkt zenon automatisch welcher Grenzwert gerade gültig ist.

Example Beispiel

Grenzwert 1 (Maximum) bei 100 projektiert. Grenzwert 2 (Maximum) bei 200 projektiert. Erreicht im Laufzeitsystem die Variable einen Wert von 100 bis 199 wird der Grenzwert 1 verletzt. Steigt der Wert auf größer gleich 200 wird der Grenzwert 2 verletzt.


Grenzwerte während der Runtime

Handbuch -> Variablen -> Grenzwerte -> Grenzwerte während der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon reagiert bei Binärvariablen auf das Erreichen des Zustandes (positive Flanke). Bei numerischen Variablen erfolgt die Reaktion bei Erreichen bzw. Überschreiten des eingestellten Maximalwertes (größer gleich Operation), oder bei Erreichen bzw. Unterschreiten des eingestellten Minimalwertes (kleiner gleich Operation). Man spricht dann von einer Grenzwertverletzung.

info Info

Bei Binärvariablen gibt es zwei Grenzwerte, ein 'Min'- und ein 'Max'-Grenzwert. Es gilt: Als Grenzwert 1 den 'Min'-Grenzwert, als Grenzwert 2 den 'Max'-Grenzwert angeben.

Bei der Berechnung der Grenzwerte von numerischen Variablen wird, wenn nicht durch die "Nichtlineare Wertanpassung" anders definiert, der Rohwert der Variablen (Signalauflösung) für die Verwendung im Leitsystem immer linear in den Messbereich umgerechnet.

Beispiel: Ein Temperaturfühler übergibt seinen Wert an die Steuerung. Die entsprechende Byte-Variable hat eine Signalauflösung von 0...255. Im Leitsystem hat die zugehörige Variable einen Messbereich von 0...100. Daraus ergibt sich:

Steuerung | Leitsystem
0 | 0
127 | 50
255 | 100

Ist ein Grenzwert verletzt, wenn zenon neu gestartet wird, dann wird die Reaktion sofort beim Start des Laufzeitsystems ausgeführt.

Ausnahme: Wenn als Reaktion ein Alarm- bzw. ein CEL-Eintrag definiert ist, so wird zuerst überprüft, ob dieser Eintrag bereits in der entsprechenden Liste eingetragen ist. Ist das der Fall so wird der Alarm-/CEL Eintrag nicht erneut durchgeführt! Doppelte Einträge werden somit vermieden. Die Durchführung der anderen Reaktionen erfolgt trotzdem.

attention Achtung

Es kann immer nur ein Grenzwert aktiv sein.

Details über die Umrechnung vom Signalbereich in den Messbereich finden Sie in der Eigenschaften-Hilfe des Eigenschaften-Fensters, wenn Sie die Eigenschaft 'Wert' auswählen.

Noch in diesem Kapitel

Verlassen der Grenzwertverletzung


Verlassen der Grenzwertverletzung

Handbuch -> Variablen -> Grenzwerte -> Grenzwerte während der Runtime -> Verlassen der Grenzwertverletzung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ist ein Grenzwert erreicht, wird bei einer Wertänderung innerhalb des Grenzwertbereichs keine erneute Reaktion ausgelöst.

Zum Beispiel: Ein Grenzwert ist im Bereich von 100-200 projektiert. Ändert sich der Wert von 110 auf 115 erfolgt keine weitere Reaktion. Ändert sich der Wert auf 210 erfolgt wieder eine Reaktion aufgrund des nächsten Grenzwerts.

Ungewollte Reaktionen bei flatternden numerischen Werten können über Schwellwerte verhindert werden.


Dynamischer Grenzwerttext

Handbuch -> Variablen -> Grenzwerte -> Dynamischer Grenzwerttext

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der dynamische Grenzwerttext erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen und von Reaktionsmatrizen (Rema) einzufügen. Dabei lässt sich auch ein fixer Text über einen Index mit Schlüsselwörter aus einer Sprachtabelle verknüpfen (siehe auch Einsatz von Schlüsselwörter in Textlisten). Dieser Grenzwerttext kann dann zur Runtime in der Alarmmeldeliste, in der Chronologischen Ereignisliste und/oder der Alarmstatuszeile angezeigt werden. Im Dynamischen Element Text verknüpfen und im Dynamischen Element Zustand kann der dynamische Grenzwerttext nicht angezeigt werden.

Syntax

Für die Parametrierung des Grenzwerttextes gilt folgende Nomenklatur:

Parameter | Beschreibung
$ | Kennung für einen dynamischen Grenzwerttext; dieses Zeichen muss an der ersten Stelle im Grenzwerttext angegeben werden.
; | Trennzeichen für Anweisungen. Dient zur Trennung des konstanten Textteils vom dynamischen Textteil. Bei der Trennung zu Variablen darf kein Leerzeichen zwischen dem Trennzeichen und der Variable enthalten sein.
@Text | Text aus der aktuell geladenen Sprachtabelle
%PV | Wert einer anderen Variable mit Namen „PV“
@Text+%PV | Zusammengesetztes Schlüsselwort für den Text aus der aktuell geladenen Sprachtabelle. Dabei wird der Wert der Variable „PV“ gespeichert und beim Anzeigen ein Text aus der Sprachtabelle gesucht der sich aus „Text“ und Variablenwert zusammensetzt.

Diese Textkodierung funktioniert ausschließlich in der Alarmmeldeliste und in der Chronologischen Ereignisliste. In Text-Elementen funktioniert diese Verschlüsselung nicht. Die Verwendung von zusammengesetzten Schlüsselwörtern ermöglicht dynamische Grenzwerttexte mit mehr als 80 Zeichen Länge.

Example Beispiel 1

Grenzwerttext = $@Text; X-Pos ;%Wert1; Y-Pos ;%Wert2

Es gelten folgende Voraussetzungen:

  • @Text ist ein Schlüsselwort in der Sprachtabelle entsprechend „Text aus Tabelle“
  • Wert1 ist eine Integer Variable mit dem Wert 14
  • Wert2 ist eine Integer Variable mit dem Wert 12

Ausgabe = Text aus Tabelle X-Pos 14 Y-Pos 12

Example Beispiel 2

$AUS in Stellung ;%String1

Es gelten folgende Voraussetzungen:

  • %String1 ist eine String Variable mit dem Inhalt „ORT“

Ausgabe = AUS in Stellung ORT

Example Beispiel 3

$%@Meldung_+Wert1
Es gelten folgende Voraussetzungen:

  • @Meldung_ ist der Teil eines Schlüsselworts in der Sprachtabelle
  • Wert1 ist eine Integer Variable mit dem Wert 12

Durch das zusammengesetzte Schlüsselwort ergibt sich das Schlüsselwort „Meldung_12“ und der zugehörige Text aus der Sprachtabelle wird angezeigt

Example Beispiel 4

$%@Meldung_+String1
Es gelten folgende Voraussetzungen:

  • @Meldung_ ist der Teil eines Schlüsselworts in der Sprachtabelle
  • String1 ist eine String Variable mit dem Inhalt „zenon“.

Durch das zusammengesetzte Schlüsselwort ergibt sich das Schlüsselwort „Meldung zenon“ und der zugehörige Text aus der Sprachtabelle wird angezeigt

Begrenzungen durch dynamische Grenzwerttexte

Das Speichern dynamischer Grenzwerttexte führt zu einigen Begrenzungen:

  1. Statischer Text wird im Speicherbereich für den Grenzwert abgelegt:
    Maximal 128 Zeichen.
  2. Werte der verknüpften Variablen werden im Speicherbereich für den Kommentartext abgelegt:
    Maximal 80 Zeichen.
  3. Werden dynamische Grenzwerttexte verwendet, können für diese Alarme keine Kommentare eingegeben werden.

Diese Begrenzungen lassen sich umgehen:

Erweiterung für lange dynamische Grenzwerttexte

Variablenwerte für dynamischen Grenzwerttext können in eine eigene Datei ausgelagert werden.

Voraussetzung: In den Projekteigenschaften sind in der Gruppe Alarmmeldeliste die Eigenschaft Lange dynamische Grenzwerttexte AML bzw. in der Gruppe Chronologische Ereignisliste die Eigenschaft Lange dynamische Grenzwerttexte CEL aktiv.
Statt im Kommentarfeld werden die Werte dann in einer eigenen Datei gespeichert. Pro Grenzwert stehen 264 Byte zur Verfügung. Davon werden pro Variable 10 Byte für interne Strukturinformationen genutzt.

Interne ID: Dynamischer Grenzwerttext

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Dynamischer Grenzwerttext

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Beispiel 1: Dynamischer Grenzwert mit einer Stringvariablen:
Von den 264 Byte

  • werden 10 Byte für Strukturinformationen genutzt und
  • 254 Byte bleiben für den Inhalt der Stringvariable übrig

Beispiel 2: Dynamischer Grenzwert mit einer Stringvariable und einer Wortvariable:
Von den 264 Byte werden

  • 20 Byte für Strukturinformationen genutzt
  • 2 Byte für den Inhalt der Wortvariable
  • 244 Byte bleiben für den Inhalt der Stringvariable übrig

Die fixe Begrenzung von drei Variablen pro Grenzwerttext entfällt damit.
Die Dateinamen für die zusätzlich erstellten Dateien lautet Dxxx.aml bzw. Dxxx.cel.
Für den Ringpuffer werden die zusätzlichen Informationen in aml.bin und cel.bin gespeichert.

Fehlertexte in der Runtime:

Parameter | Beschreibung
XXX | Die Variable, für die ein Wert vorliegt, hat sich geändert
--- | Wert der Variablen ist noch nicht vorhanden (kann bei Programmstart vorkommen).
>3 | Anzahl der verknüpften Variablen ist größer 3 (Wert kann daher nicht gespeichert werden).

Noch in diesem Kapitel

Dynamische Schlüsselwörter in Grenzwerttexten


Dynamische Schlüsselwörter in Grenzwerttexten

Handbuch -> Variablen -> Grenzwerte -> Dynamischer Grenzwerttext -> Dynamische Schlüsselwörter in Grenzwerttexten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alarmmeldungen Bool'scher Variablen geben bei Sammelmeldungen keine Auskunft, wodurch der Alarm ausgelöst wurde. Damit der Grenzwerttext trotzdem die Ursache für den Alarm ausdrückt, kann die Ursache mit Hilfe einer Indexvariablen übergeben werden. Mit Hilfe des Dynamischen Grenzwerttexts wird aus der Sprachtabelle (siehe Kapitel Sprachumschaltung) der richtige Text herausgesucht und angezeigt. Als Schlüsselwort wird dazu kein fixes Wort verwendet, sondern ein dynamisches. Dieses setzt sich zusammen aus Prefix+Wert der Indexvariable: %@errornr+mIndex

Der Einsatz mehrdimensionaler Schlüsselwörter (mehrere Indizes) ist möglich.
Zum Beispiel: fester Text; @Motorfehler%meinIndex1-%meinIndex2 wird zur Runtime z. B. @Motorfehler4-67. Dieses Schlüsselwort wird dann in der Sprachtabelle gesucht und der dazugehörende Text angezeigt.

Beispiele

Beispiel 1

$@error in module: ;%moduleNr;@error type: ;%@errornr+mIndex;

Erklärung:

$ definiert ein dynamischer Grenzwerttext.

@error in module: ein normales Schlüsselwort aus der Sprachtabelle

%moduleNr: wird in der Runtime ersetzt durch den Wert der Variable ModuleNr (Funktionalität des Dynamischen Grenzwerttexts)

@error type: ein normales Schlüsselwort aus der Sprachtabelle

@errornr: der erste Teil des dynamischen Schlüsselworts

+mIndex: wird in der Runtime ersetzt durch den Wert der Variable mIndex, und ergänzt das Schlüsselwort @errornr

Ergebnis:

Wert von mIndex | Schlüsselwort
1 | @errornr1
2 | @errornr2

Beispiel 2: Strings

$%@Meldung_+Index_UINT_001;/;%@Ursache_+Index_STRING_004

Hat Index_UINT_001 den Wert 4 und Index_STRING_004 den Wert 'Feuer', dann werden die Texte Meldung_4 und Ursache_Feuer in der Sprachtabelle gesucht und in der AML/CEL angezeigt.


Reaktionsmatrizen

Handbuch -> Variablen -> Reaktionsmatrizen

info Info

In einer Reaktionsmatrix (kurz Rema) können Grenzwertinformationen zentral definiert werden.
Wenn beispielsweise bei mehreren Füllständen die gleiche Füllstandsüberwachung auf Über- und Unterfüllung durchgeführt werden soll, kann dies in einer einzigen Reaktionsmatrix definiert werden. Dies ermöglicht z.B. eine Niveau- Änderung des unteren Wertes an zentraler Stelle.

Vorteile gegenüber Grenzwerten:

Reaktionsmatrizen sind mehrfach verwendbar. Eine Reaktionsmatrix kann mit mehreren Variablen, die auch auf unterschiedlichen Datentypen basieren können, verknüpft werden.

Reaktionsmatrizen können bei numerischen Variablen jede Änderung des Variablenwertes als neue Grenzwertverletzung behandeln. Bei Grenzwerten ist das nicht möglich.

Mit Reaktionsmatrizen können auch Status wie z.B. Invalid (siehe Statusverarbeitung) abgefragt werden. Dies ist mit Grenzwerten ebenfalls nicht möglich.

Nähere Informationen zu Grenzwerten finden Sie im Abschnitt Grenzwerte.

Noch in diesem Kapitel

Anlegen einer Reaktionsmatrix

Bearbeiten einer Reaktionsmatrix

Arten von Reaktionsmatrizen

Dynamische Grenzwerttexte in Reaktionsmatritzen

Liste Status-Bits


Anlegen einer Reaktionsmatrix

Handbuch -> Variablen -> Reaktionsmatrizen -> Anlegen einer Reaktionsmatrix

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Selektieren Sie Reaktionsmatrix im Projektmanager und öffnen Sie mit der rechten Maustaste das Kontextmenü. Dort wählen Sie Reaktionsmatrix neu.

Geben Sie nun in der darauf erscheinenden Dialogbox den Namen und die Art der Reaktionsmatrix an. Beachten Sie, dass diese Zuordnung später nicht mehr änderbar ist. Der Name ist jedoch später änderbar.

Die einzelnen Arten der Reaktionsmatrix werden für folgende Auswertungen verwendet:

Parameter | Beschreibung
Binär | Auswertung diskreter Zustände (Bitorientiert)
Numerisch | Auswertung analoger Zustände (Wertorientiert)
Multi-Binär | erweiterte Auswertung von 32-Bit-Variablen; die ersten 16 Bit bestimmen den Wert der Variable und werden als Zahlenwert übergeben; Umrangierung von Statusbits; Sonderfunktion (abschalten von Variablen bei gesetztem Statusbit) (Schutzdatenprojektierung - nur SAT-spezifisch)
Multi-Numerisch | erweiterte Auswertung mit gleichzeitiger Statusrangierung und Sonderfunktion (abschalten von Variablen bei gesetztem Statusbit)
String | Textvergleich


Bearbeiten einer Reaktionsmatrix

Handbuch -> Variablen -> Reaktionsmatrizen -> Bearbeiten einer Reaktionsmatrix

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Reaktionsmatrix zu bearbeiten:

  • wählen Sie die Rema in der Detailansicht aus
  • wählen Sie im Kontextmenü den gewünschten Befehl

Kontextmenü Detailansicht Rema

Parameter | Beschreibung
Reaktionsmatrix Neu | Legte eine neue Reaktionsmatrix an .
Konfiguration | Öffnet den Dialog zur Konfiguration des Remas.
Kopieren | Selektierte Reaktionsmatrix kopieren.
Einfügen | Kopierte bzw. ausgeschnittene Reaktionsmatrix einfügen.
Löschen | Selektierte Reaktionsmatrix löschen.
Selektierte XML exportieren | Exportiert ausgewählte Remas in XML-Datei.
Alle Filter entfernt. | Entfernt alle Filtereinstellungen.
Selektierte Zelle bearbeiten | Öffnet Zelle zur Bearbeitung, wenn diese in der Liste geändert werden darf.
Eigenschaften | Öffnet das Eigenschaftenfenster.
Hilfe | Öffnet die Online-Hilfe,

Dialog Zustände und Reaktionen

Durch Klick auf Konfiguration wird der Dialog zur Konfiguration der Zustände geöffnet. Die Konfigurationsmöglichkeiten hängen ab von der Art der Reaktionsmatrize.

In der Liste Zustände können auch mehrere Zustände gleichzeitig ausgewählt und bearbeitet werden. Unterschiedliche Einstellungen werden durch roten Hintergrund oder roten Rahmen hervorgehoben.

Tipp: So können Status und Werte für mehrer Zustände gleichzeitig geändert werden.

Kontextmenü Zustände

Im Listenfenster Zustände stehen folgende Befehle im Kontextmenü zur Verfügung:

Befehl | Beschreibung
Neuen Zustand anlegen | Legt einen neuen Zustand auf Basis des aktuelle ausgewählten Zustands an.
Neuen Unterzustand anlegen | Nur bei Multibinär: Legt einen neuen Unterzustand für den ausgewählten Zustand an.
Kopieren | Kopiert ausgewählten Zustand in Zwischenablage. Hinweis Multibinär: Es können nur Hauptzustände kopiert werden. Unterzustände werden mitkopiert.
Einfügen | Fügt ausgewählten Zustand aus Zwischenablage ein.
Löschen | Löscht ausgewählten Zustand aus Liste. Default-Zustand kann nicht gelöscht werden.
Test | Öffnet den Dialog zum Testen des Zustands.
Nach oben | Verschiebt ausgewählte Einträge nach oben. (Auch per Drag & Drop möglich.)
Nach unten | Verschiebt ausgewählte Einträge nach unten. (Auch per Drag & Drop möglich.)
Hilfe | Öffnet die Online-Hilfe für die jeweilige Rema.

Allgemeine Einstellungen und Definition der Werte finden Sie beim jeweiligen Rema:

  • Binär
  • Numerisch
  • String
  • Multi-Binär Zustände und Reaktionen
  • Multi-Numerisch Zustände und Reaktionen

info Info

Wird ein Nachladen oder eine Server-Standby-Umschaltung angestoßen, so werden die anstehenden Rückmeldungen bzw. Schreibbestätigungen verworfen!


Arten von Reaktionsmatrizen

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es stehen 5 Arten von Reaktionsmatrizen zur Verfügung:

  • Binär
  • Numerisch
  • String
  • Multibinär
  • Multi-Numerisch

Für die Arten Multibinär und Multinumerisch können auch AML/CEL-Text, Statusrangierung und Variablenbehandlung konfiguriert werden.

Noch in diesem Kapitel

Binär

Numerisch

String

Multireaktionsmatrizen allgemein

Test


Binär

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Binär

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Binärreaktionsmatrix wird für die Auswertung von beliebigen Zustands- und Statusbits von Variablen verwendet. Die Auswertung erfolgt dabei bit-orientiert. Es lassen sich aber auch analoge Variable damit auswerten.

Parameter

Beschreibung

Zustände

Liste der projektierten Zustände mit Wert, Status und Übertragungsursache.

Zustand neu

Legt einen neuen Zustand auf Basis des aktuelle ausgewählten Zustands an.

Unterzustand

Nur bei Multibinär: Legt einen neuen Unterzustand für den ausgewählten Zustand an.

Löschen

Löscht alle ausgewählten Zustände aus Liste.

Test

Öffnet den Dialog zum Testen des Zustands.

Nach oben

Sortiert ausgewählten Zustand nach oben.

Nach unten

Sortiert ausgewählten Zustand nach untern.

Status

Auswahl der Status.

Übertragungsursache

Zusätzlicher Status für Übertragunsgursache.

Funktion

Öffnet den Dialog zur Verknüpfung einer Funktion. Eine bereits verknüpfte Funktion kann in diesem Dialog über die Schaltfläche Keine Auswahl wieder abgewählt werden.

Aufruf über Alarmmeldeliste

Nur verfügbar, wenn in AML/CEL die Option In Alarmmeldeliste aktiviert wurde.

Aktiv: Funktion wird über AML aufgerufen.

Zusatzattribute

Grenzwertfarbe

Farbe bei Grenzwertverletzung.

Blinken

Aktiv: Blinkt bei Grenzwertverletzung.

Unsichtbar

Aktiv: Wird bei Grenzwertverletzung auf unsichtbar geschaltet.

Hilfe-Datei

Klick auf ... öffnet den Dialog zur Auswahl einer Hilfedatei im Format chm. Diese muss zuvor im Projektmanager im Knoten Dateien/Hilfe angelegt worden sein.

Zur Runtime wird die verknüpfte Hilfe-Datei geöffnet, wenn in der Alarmmeldeliste der entsprechende Alarm ausgewählt und auf den Button Hilfe aufrufen geklickt wird.

Hinweis: Die Eigenschaft kann nur konfiguriert werden, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Hilfe-Kapitel

Angabe des Hilfekapitels.

Hinweis: Steht nur zur Verfügung, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Zusatzinformation 1

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

Zusatzinformation 2

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

AML/CEL

In Alarmmeldeliste

Aktiv: Wird in AML eingetragen.

Quittierpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist quittierpflichtig.

Kommentar erforderlich

Um den Alarm quittieren zu können, muss zuvor ein Kommentar eingegeben werden. Der Benutzer muss über die dazu notwendige Funktionsberechtigung verfügen.

Löschpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist löschpflichtig.

Drucken

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Wird überden eingestellten Standarddrucker ausgedruckt.

In Chronologische Ereignisliste

Aktiv: Wird in CEL eingetragen.
Hinweis: Wenn schon der Initialwert (der erste Wert, der von der Steuerung kommt) oder der Wert beim Start der Runtime den Grenzwert verletzt oder dadurch der Rema-Zustand aktiv ist, wird kein Eintrag in der CEL erzeugt. Erst wenn die Grenzwertverletzung aufgehoben ist und dann erneut auftritt bzw. der Zustand inaktiv und dann wieder aktiv ist, wird ein CEL-Eintrag erzeugt.

Alarm/Ereignis-Gruppe

Zuweisung an eine Alarm/Ereignis-Gruppe.

Alarm/Ereignis-Klasse

Zuweisung an eine Alarm/Ereignis-Klasse.

Wert

Parameter | Beschreibung
Wert | Wertangabe.
Grenzwerttext | Text, der bei Grenzwertverletzung ausgegeben wird.
Verzögerungszeit | Zeit, die der Grenzwert verletzt sein muss, damit er aktiv wird.
Zustandstext für Zähler im Mathematik Treiber | Zuweisung einer von vier möglichen Zustandsnummern für einen Zähler im Mathematik Treiber. Die Variable muss dazu über eine Rema verfügen.

Die Definition der Kombination aus Zustands- und/oder Statuswert erfolgt über die Freigabe der Optionsfelder. Der Zustandswert ist der binär kodierte Rohwert der Variablen. Der in den Messbereich (lineare bzw. nichtlineare Wertanpassung) umgerechnete Wert wird nicht berücksichtigt!

Die Bitbelegung ist:

Zustand: |
Rohwertbit 0 gesetzt | 2^0 = 1
Rohwertbit 1 gesetzt | 2^1 = 2
Rohwertbit 2 gesetzt | 2^2 = 4 ....

Es sind zwei Verknüpfungen möglich. Die Bedeutung der Felder ist

Zustand: |
unberücksichtigt | Punkt, nicht gesetzt
auf 0 prüfen | 0, Bit wird auf den logischen Wert 0 geprüft
auf 1 prüfen | 1, Bit wird auf den logischen Wert 1 geprüft

Die Reihenfolge der Projektierung ist ausschlaggebend für die spätere Verwendung. Bei der Abarbeitung der Reaktionsmatrix im Onlinebetrieb wird die Überprüfung der Zustands- und Statusbitkombination in der obersten Zeile begonnen. Die Überprüfung im Laufzeitsystem wird bis zu der Zeile durchgeführt, die die angegebenen Bedingungen erfüllt. Alle weiteren Bedingungen werden nicht weiter überprüft. Erfüllt keine Zeile den aktuellen Variablenzustand, gilt der Defaulteintrag. Damit ist eine Priorisierung der Grenzwerttexte für die chronologische Ereignisliste, die Alarmierung und die Alarmmeldeliste möglich. Die Statuswertüberprüfung erfolgt genau so wie die Wertüberprüfung der Variable.

Auswertung

Bei Binärvariablen wird nur das Bit 0 ausgewertet. Die restlichen Bits werden nicht berücksichtigt. Bei 8 Bit Variablen (IEC Datentyp SINT, USINT) werden die Bits 0 bis 7 ausgewertet usw.

Beispiel | (Einzelmeldung mit Gestörtüberwachung)
prüfen INVALID-Bit gesetzt | ................, ............1...
prüfen Bit0 gesetzt | ...............0, ................
prüfen Bit1 gesetzt | ...............1, ................

Im obigen Beispiel wird unabhängig vom Zustand der Einzelmeldung, bei anstehendem INVALID-Bit (unterbrochene Verbindung zur Steuerung - Variable gestört) die Überprüfung nach der ersten Zeile abgeschlossen. Die Variableneigenschaften (Alarm, Blinken, CEL etc.) werden ausschließlich von diesem Zustand gesteuert. Steht das INVALID-Bit nicht mehr an, werden die anderen Zeilen abgearbeitet. Soll die Reihenfolge geändert werden, kann das mit der Selektion der entsprechenden Zeile und den Operationen Neu , Löschen , nach oben und nach unten erfolgen.


Numerisch

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Numerisch

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Numerische Reaktionsmatrix wird für die Auswertung von beliebigen Grenzwertzuständen und Statusbits der Variablen verwendet. Im Gegensatz zur Binärmatrix erfolgt die Auswertung über numerische Werte. Es wird nicht der Rohwert zur Auswertung herangezogen sondern der in den Messbereich umgerechnete Wert (nach linearer bzw. nichtlinearer Wertanpassung).

Parameter

Beschreibung

Zustände

Liste der projektierten Zustände mit Wert, Status und Übertragungsursache.

Zustand neu

Legt einen neuen Zustand auf Basis des aktuelle ausgewählten Zustands an.

Unterzustand

Nur bei Multibinär: Legt einen neuen Unterzustand für den ausgewählten Zustand an.

Löschen

Löscht alle ausgewählten Zustände aus Liste.

Test

Öffnet den Dialog zum Testen des Zustands.

Nach oben

Sortiert ausgewählten Zustand nach oben.

Nach unten

Sortiert ausgewählten Zustand nach untern.

Status

Auswahl der Status.

Übertragungsursache

Zusätzlicher Status für Übertragunsgursache.

Funktion

Öffnet den Dialog zur Verknüpfung einer Funktion. Eine bereits verknüpfte Funktion kann in diesem Dialog über die Schaltfläche Keine Auswahl wieder abgewählt werden.

Aufruf über Alarmmeldeliste

Nur verfügbar, wenn in AML/CEL die Option In Alarmmeldeliste aktiviert wurde.

Aktiv: Funktion wird über AML aufgerufen.

Zusatzattribute

Grenzwertfarbe

Farbe bei Grenzwertverletzung.

Blinken

Aktiv: Blinkt bei Grenzwertverletzung.

Unsichtbar

Aktiv: Wird bei Grenzwertverletzung auf unsichtbar geschaltet.

Hilfe-Datei

Klick auf ... öffnet den Dialog zur Auswahl einer Hilfedatei im Format chm. Diese muss zuvor im Projektmanager im Knoten Dateien/Hilfe angelegt worden sein.

Zur Runtime wird die verknüpfte Hilfe-Datei geöffnet, wenn in der Alarmmeldeliste der entsprechende Alarm ausgewählt und auf den Button Hilfe aufrufen geklickt wird.

Hinweis: Die Eigenschaft kann nur konfiguriert werden, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Hilfe-Kapitel

Angabe des Hilfekapitels.

Hinweis: Steht nur zur Verfügung, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Zusatzinformation 1

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

Zusatzinformation 2

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

AML/CEL

In Alarmmeldeliste

Aktiv: Wird in AML eingetragen.

Quittierpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist quittierpflichtig.

Kommentar erforderlich

Um den Alarm quittieren zu können, muss zuvor ein Kommentar eingegeben werden. Der Benutzer muss über die dazu notwendige Funktionsberechtigung verfügen.

Löschpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist löschpflichtig.

Drucken

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Wird überden eingestellten Standarddrucker ausgedruckt.

In Chronologische Ereignisliste

Aktiv: Wird in CEL eingetragen.
Hinweis: Wenn schon der Initialwert (der erste Wert, der von der Steuerung kommt) oder der Wert beim Start der Runtime den Grenzwert verletzt oder dadurch der Rema-Zustand aktiv ist, wird kein Eintrag in der CEL erzeugt. Erst wenn die Grenzwertverletzung aufgehoben ist und dann erneut auftritt bzw. der Zustand inaktiv und dann wieder aktiv ist, wird ein CEL-Eintrag erzeugt.

Alarm/Ereignis-Gruppe

Zuweisung an eine Alarm/Ereignis-Gruppe.

Alarm/Ereignis-Klasse

Zuweisung an eine Alarm/Ereignis-Klasse.

Wert

Parameter

Beschreibung

Wert

Festlegung der Wertangabe:

  • beliebig: eine beliebige Wertänderung verursacht die Grenzwertverletzung
  • größer: Eingabe eines Grenzwerts
  • kleiner: Eingabe eines Grenzwerts
  • gleich: Eingabe eines Grenzwerts
  • Bereich: Eingabe eines Bereichs (von ... bis)

Grenzwerttext

Text, der bei Grenzwertverletzung ausgegeben wird.

Jede Wertänderung als neue Grenzwertverletzung behandeln

Aktiv: Jede Wertänderung wird als Grenzwertverletzung angezeigt.

Verzögerungszeit

Zeit, die der Grenzwert verletzt sein muss, damit er aktiv wird.

Zustandstext für Zähler im Mathematik Treiber

Zuweisung einer von vier möglichen Zustandsnummern für einen Zähler im Mathematik Treiber. Die Variable muss dazu über eine Rema verfügen.

info Info

Ein Dezimalwert kann sowohl mit Komma als auch mit Punkt angegeben werden, das Dezimalzeichen wird automatisch in einen Punkt umgewandelt.


String

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> String

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Stringreaktionsmatrix wird für die Auswertung von Grenzwerten und Statusbits der String-Variablen verwendet. Neben der bekannten Projektierung der Grenzwert- und Statuskombinationen sind weitergehende Projektierungen möglich.

Parameter

Beschreibung

Zustände

Liste der projektierten Zustände mit Wert, Status und Übertragungsursache.

Zustand neu

Legt einen neuen Zustand auf Basis des aktuelle ausgewählten Zustands an.

Unterzustand

Nur bei Multibinär: Legt einen neuen Unterzustand für den ausgewählten Zustand an.

Löschen

Löscht alle ausgewählten Zustände aus Liste.

Test

Öffnet den Dialog zum Testen des Zustands.

Nach oben

Sortiert ausgewählten Zustand nach oben.

Nach unten

Sortiert ausgewählten Zustand nach untern.

Status

Auswahl der Status.

Übertragungsursache

Zusätzlicher Status für Übertragunsgursache.

Funktion

Öffnet den Dialog zur Verknüpfung einer Funktion. Eine bereits verknüpfte Funktion kann in diesem Dialog über die Schaltfläche Keine Auswahl wieder abgewählt werden.

Aufruf über Alarmmeldeliste

Nur verfügbar, wenn in AML/CEL die Option In Alarmmeldeliste aktiviert wurde.

Aktiv: Funktion wird über AML aufgerufen.

Zusatzattribute

Grenzwertfarbe

Farbe bei Grenzwertverletzung.

Blinken

Aktiv: Blinkt bei Grenzwertverletzung.

Unsichtbar

Aktiv: Wird bei Grenzwertverletzung auf unsichtbar geschaltet.

Hilfe-Datei

Klick auf ... öffnet den Dialog zur Auswahl einer Hilfedatei im Format chm. Diese muss zuvor im Projektmanager im Knoten Dateien/Hilfe angelegt worden sein.

Zur Runtime wird die verknüpfte Hilfe-Datei geöffnet, wenn in der Alarmmeldeliste der entsprechende Alarm ausgewählt und auf den Button Hilfe aufrufen geklickt wird.

Hinweis: Die Eigenschaft kann nur konfiguriert werden, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Hilfe-Kapitel

Angabe des Hilfekapitels.

Hinweis: Steht nur zur Verfügung, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Zusatzinformation 1

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

Zusatzinformation 2

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

AML/CEL

In Alarmmeldeliste

Aktiv: Wird in AML eingetragen.

Quittierpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist quittierpflichtig.

Kommentar erforderlich

Um den Alarm quittieren zu können, muss zuvor ein Kommentar eingegeben werden. Der Benutzer muss über die dazu notwendige Funktionsberechtigung verfügen.

Löschpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist löschpflichtig.

Drucken

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Wird überden eingestellten Standarddrucker ausgedruckt.

In Chronologische Ereignisliste

Aktiv: Wird in CEL eingetragen.
Hinweis: Wenn schon der Initialwert (der erste Wert, der von der Steuerung kommt) oder der Wert beim Start der Runtime den Grenzwert verletzt oder dadurch der Rema-Zustand aktiv ist, wird kein Eintrag in der CEL erzeugt. Erst wenn die Grenzwertverletzung aufgehoben ist und dann erneut auftritt bzw. der Zustand inaktiv und dann wieder aktiv ist, wird ein CEL-Eintrag erzeugt.

Alarm/Ereignis-Gruppe

Zuweisung an eine Alarm/Ereignis-Gruppe.

Alarm/Ereignis-Klasse

Zuweisung an eine Alarm/Ereignis-Klasse.

Wert

Parameter

Beschreibung

Wert

Festlegung der Wertangabe:

  • beliebig: eine beliebige Wertänderung verursacht die Grenzwertverletzung
  • größer: Eingabe eines Grenzwerts
  • kleiner: Eingabe eines Grenzwerts
  • gleich: Eingabe eines Grenzwerts
  • Bereich: Eingabe eines Bereichs (von ... bis)

Groß-/Kleinschreibung beachten

Beim Vergleich mit dem Grenzwertstring werden Unterschiede in der Groß-/Kleinschreibung beachtet.

Wildcards beachten

Der Grenzwertstring darf Wildcards enthalten.

(Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.)

Grenzwerttext

Text, der bei Grenzwertverletzung ausgegeben wird.

Jede Wertänderung als neue Grenzwertverletzung behandeln

Aktiv: Jede Wertänderung wird als Grenzwertverletzung angezeigt.

Verzögerungszeit

Zeit, die der Grenzwert verletzt sein muss, damit er aktiv wird.

Zustandstext für Zähler im Mathematik Treiber

Zuweisung einer von vier möglichen Zustandsnummern für einen Zähler im Mathematik Treiber. Die Variable muss dazu über eine Rema verfügen.

Example Beispiel

Beispiel 1:
In der Reihenfolge bei einer Auswertung groß nach klein:
Strings: Mein,Name,ist, Hase.
Reihenfolge der Auswertung:
ist,Name,Mein,Hase.

Begründung:
ist, fängt mit einem kleinen Buchstaben an, deswegen größer als alle andere Strings.
Name, N ist größer als M und H, Mein, M ist größer als H


Multireaktionsmatrizen allgemein

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Multireaktionsmatrizen allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Registerkarten | Beschreibung
Zustände und Reaktionen | Konfiguration der Zustände und Reaktionen, unterschiedlich für Multibinär und Multi-Numerisch.
AML/CEL-Text | Konfiguration der Ausgabe des Wertes neben dem Zustandstext in AML und CEL.
Statusrangierung | Konfiguration der Statusrangierung.
Sonderfunktionen | Konfiguration von Sonderfunktionen.

Hinweis: Die Bits NORM und N_NORM stehen in beiden Typen von Multireaktionsmatrizen zur Verfügung, nicht aber in den Standardmatrizen.

Meldungsverarbeitung

Die oberen 16 Bit (Bit 16 ... 31) werden bei der Schutzdatenprojektierung für die Meldungsverarbeitung herangezogen; in den oberen 16 Bit ist die Meldungsnummer hinterlegt.

Die Funktionsweise der multibinären Reaktionsmatrix ist für die Hauptzustände identisch zur binären Reaktionsmatrix. Bei Änderungen in den Hauptzuständen werden die entsprechenden Zustandsprojektierungen (Alarm, CEL, Text etc.) ausgeführt:

  • Hat ein Hauptzustand Unterzustände, so werden bei Erreichen des Hauptzustandes erst die Unterzustände überprüft.
  • Stimmt kein Unterzustand mit dem aktuellen Variablenzustand überein, werden die entsprechenden Zustandsprojektierungen (Alarm, CEL, Text etc.) des Hauptzustandes ausgeführt.
  • Stimmt der Unterzustand mit dem aktuellen Variablenzustand überein, werden die entsprechenden Zustandsprojektierungen (Alarm, CEL, Text etc.) des Unterzustandes ausgeführt.
  • Ändert sich der Variablenzustand vom Unterzustand auf den Hauptzustand, erfolgt keine neue Ausgabe an die chronologische Ereignisliste und die Alarmliste (z.B. Schalterfallbehandlung im SAT-System).

Beispiel:

Parameter | Beschreibung
Hauptwert | Projektierung -> Unterwertxxxxxx00 kein Alarm, CEL-Text aus -> xxxxx100 Alarm, CEL-Text Schalterfall Aus xxxxxx01 kein Alarm, CEL-Text ein xxxxxx10 Alarm, CEL-Text Differenz xxxxxx11 Alarm, CEL-Text Störung
Änderung von EIN nach AUS | kein Alarm, CEL-Eintrag ein
Änderung von EIN nach SCHALTERFALL AUS | Alarmeintrag Schalterfall Aus, CEL-TEXT Schalterfall Aus -> Quittierung des Schalterfalls (Änderung von SCHALTERFALL AUS nach AUS) gehender Alarm Schalterfall Aus, kein erneuter CEL-Text

Für die Ausgabe in der CEL und in die Prozessbilder kann der Gesamtinhalt der Variablen in zwei Teile unterteilt werden. Der eine Teil wird für die Grenzwerttextprojektierung verwendet, der zweite Teil (Wert) wird an die Bilder übergeben. (Anwendung: Schutztelegramme in SAT 1703).

Übertragungsursache

Multibinär- und Multianalog-Reaktionsmatrizen ermöglichen die Auswertung der Übertragungsursache entsprechend

der Norm IEC 60870-5-101/104. Die Übertragungsursache besteht aus:

Bit | Beschreibung
6 Bit | Wert der Übertragungsursache von 0 ... 63
1 Bit | N_CONF (P/N-Bit): 0 = positive 1 = negative Bestätigung
1 Bit | Test-Bit

In der Reaktionsmatrix kann jedem Zustand die Kennung der Übertragungsursache + N_CONF Bit (P/N-Bit) zugeordnet werden. Damit gilt der Zustand nur dann als verletzt, wenn die empfangene Übertragungsursache mit der parametrierten Übertragungsursache übereinstimmt.

Parameter | Beschreibung
Checkbox Übertragungsursache | Aktiviert die Auswertung des Eingabefeldes Übertragungsursache.
Eingabefeld Übertragungsursache | Erwartet einen Wert von 0-63 als Kennung der Übertragungsursache.

Noch in diesem Kapitel

Multi-Binär Zustände und Reaktionen

Multi-Numerisch Zustände und Reaktionen

Konfiguration AML/CEL-Text

Konfiguration Statusrangierung

Konfiguration Sonderfunktionen


Multi-Binär Zustände und Reaktionen

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Multireaktionsmatrizen allgemein -> Multi-Binär Zustände und Reaktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Multibinärreaktionsmatrix wird für die Auswertung von Wert-, Zustands- und Statusbits digitaler Variablen verwendet. Die unteren Bits (Bit 0.15) werden dabei als Wert für die Darstellung in den Bildern (dynamische Elemente) und in der Chronologischen Ereignisliste (Feld Wert) verwendet. Neben der bekannten Projektierung der Wert- und Statuskombinationen sind weitergehende Projektierungen möglich.

Parameter

Beschreibung

Zustände

Liste der projektierten Zustände mit Wert, Status und Übertragungsursache.

Zustand neu

Legt einen neuen Zustand auf Basis des aktuelle ausgewählten Zustands an.

Unterzustand

Nur bei Multibinär: Legt einen neuen Unterzustand für den ausgewählten Zustand an.

Löschen

Löscht alle ausgewählten Zustände aus Liste.

Test

Öffnet den Dialog zum Testen des Zustands.

Nach oben

Sortiert ausgewählten Zustand nach oben.

Nach unten

Sortiert ausgewählten Zustand nach untern.

Status

Auswahl der Status.

Übertragungsursache

Zusätzlicher Status für Übertragunsgursache.

Funktion

Öffnet den Dialog zur Verknüpfung einer Funktion. Eine bereits verknüpfte Funktion kann in diesem Dialog über die Schaltfläche Keine Auswahl wieder abgewählt werden.

Aufruf über Alarmmeldeliste

Nur verfügbar, wenn in AML/CEL die Option In Alarmmeldeliste aktiviert wurde.

Aktiv: Funktion wird über AML aufgerufen.

Zusatzattribute

Grenzwertfarbe

Farbe bei Grenzwertverletzung.

Blinken

Aktiv: Blinkt bei Grenzwertverletzung.

Unsichtbar

Aktiv: Wird bei Grenzwertverletzung auf unsichtbar geschaltet.

Hilfe-Datei

Klick auf ... öffnet den Dialog zur Auswahl einer Hilfedatei im Format chm. Diese muss zuvor im Projektmanager im Knoten Dateien/Hilfe angelegt worden sein.

Zur Runtime wird die verknüpfte Hilfe-Datei geöffnet, wenn in der Alarmmeldeliste der entsprechende Alarm ausgewählt und auf den Button Hilfe aufrufen geklickt wird.

Hinweis: Die Eigenschaft kann nur konfiguriert werden, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Hilfe-Kapitel

Angabe des Hilfekapitels.

Hinweis: Steht nur zur Verfügung, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Zusatzinformation 1

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

Zusatzinformation 2

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

AML/CEL

In Alarmmeldeliste

Aktiv: Wird in AML eingetragen.

Quittierpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist quittierpflichtig.

Kommentar erforderlich

Um den Alarm quittieren zu können, muss zuvor ein Kommentar eingegeben werden. Der Benutzer muss über die dazu notwendige Funktionsberechtigung verfügen.

Löschpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist löschpflichtig.

Drucken

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Wird überden eingestellten Standarddrucker ausgedruckt.

In Chronologische Ereignisliste

Aktiv: Wird in CEL eingetragen.
Hinweis: Wenn schon der Initialwert (der erste Wert, der von der Steuerung kommt) oder der Wert beim Start der Runtime den Grenzwert verletzt oder dadurch der Rema-Zustand aktiv ist, wird kein Eintrag in der CEL erzeugt. Erst wenn die Grenzwertverletzung aufgehoben ist und dann erneut auftritt bzw. der Zustand inaktiv und dann wieder aktiv ist, wird ein CEL-Eintrag erzeugt.

Alarm/Ereignis-Gruppe

Zuweisung an eine Alarm/Ereignis-Gruppe.

Alarm/Ereignis-Klasse

Zuweisung an eine Alarm/Ereignis-Klasse.

Checkbox Status

Jeder Status kann einen von 5 möglichen Zuständen annehmen. Die Definition erfolgt über Klick in die Checkbox vor dem jeweiligen Status.

Mögliche Zustände:

  • unberücksichtigt (Punkt)
  • ein (1)
  • aus (0)
  • kommend (Pfeil nach oben)
  • gehend (Pfeil nach unten)
  • wechselnd (Doppelpfeil)

Wert

Parameter | Beschreibung
Wert | Wertangabe.
Grenzwerttext | Text, der bei Grenzwertverletzung ausgegeben wird.
Verzögerungszeit | Zeit, die der Grenzwert verletzt sein muss, damit er aktiv wird.
Zustandstext für Zähler im Mathematik Treiber | Zuweisung einer von vier möglichen Zustandsnummern für einen Zähler im Mathematik Treiber. Die Variable muss dazu über eine Rema verfügen.

info Info

Ein Dezimalwert kann sowohl mit Komma als auch mit Punkt angegeben werden, das Dezimalzeichen wird automatisch in einen Punkt umgewandelt.


Multi-Numerisch Zustände und Reaktionen

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Multireaktionsmatrizen allgemein -> Multi-Numerisch Zustände und Reaktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Multi-Numerische Reaktionsmatrix wird für die Auswertung von Grenzwerten und Statusbits der Variablen verwendet. Neben der bekannten Projektierung der Grenzwert- und Statuskombinationen sind weitergehende Projektierungen möglich.

Parameter

Beschreibung

Zustände

Liste der projektierten Zustände mit Wert, Status und Übertragungsursache.

Zustand neu

Legt einen neuen Zustand auf Basis des aktuelle ausgewählten Zustands an.

Unterzustand

Nur bei Multibinär: Legt einen neuen Unterzustand für den ausgewählten Zustand an.

Löschen

Löscht alle ausgewählten Zustände aus Liste.

Test

Öffnet den Dialog zum Testen des Zustands.

Nach oben

Sortiert ausgewählten Zustand nach oben.

Nach unten

Sortiert ausgewählten Zustand nach untern.

Status

Auswahl der Status.

Übertragungsursache

Zusätzlicher Status für Übertragunsgursache.

Funktion

Öffnet den Dialog zur Verknüpfung einer Funktion. Eine bereits verknüpfte Funktion kann in diesem Dialog über die Schaltfläche Keine Auswahl wieder abgewählt werden.

Aufruf über Alarmmeldeliste

Nur verfügbar, wenn in AML/CEL die Option In Alarmmeldeliste aktiviert wurde.

Aktiv: Funktion wird über AML aufgerufen.

Zusatzattribute

Grenzwertfarbe

Farbe bei Grenzwertverletzung.

Blinken

Aktiv: Blinkt bei Grenzwertverletzung.

Unsichtbar

Aktiv: Wird bei Grenzwertverletzung auf unsichtbar geschaltet.

Hilfe-Datei

Klick auf ... öffnet den Dialog zur Auswahl einer Hilfedatei im Format chm. Diese muss zuvor im Projektmanager im Knoten Dateien/Hilfe angelegt worden sein.

Zur Runtime wird die verknüpfte Hilfe-Datei geöffnet, wenn in der Alarmmeldeliste der entsprechende Alarm ausgewählt und auf den Button Hilfe aufrufen geklickt wird.

Hinweis: Die Eigenschaft kann nur konfiguriert werden, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Hilfe-Kapitel

Angabe des Hilfekapitels.

Hinweis: Steht nur zur Verfügung, wenn die Eigenschaft In Alarmmeldeliste aktiv ist.

Zusatzinformation 1

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

Zusatzinformation 2

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

AML/CEL

In Alarmmeldeliste

Aktiv: Wird in AML eingetragen.

Quittierpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist quittierpflichtig.

Kommentar erforderlich

Um den Alarm quittieren zu können, muss zuvor ein Kommentar eingegeben werden. Der Benutzer muss über die dazu notwendige Funktionsberechtigung verfügen.

Löschpflichtig

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Ist löschpflichtig.

Drucken

Steht nur zur Verfügung, wenn In Alarmmeldeliste aktiviert ist.

Aktiv: Wird überden eingestellten Standarddrucker ausgedruckt.

In Chronologische Ereignisliste

Aktiv: Wird in CEL eingetragen.
Hinweis: Wenn schon der Initialwert (der erste Wert, der von der Steuerung kommt) oder der Wert beim Start der Runtime den Grenzwert verletzt oder dadurch der Rema-Zustand aktiv ist, wird kein Eintrag in der CEL erzeugt. Erst wenn die Grenzwertverletzung aufgehoben ist und dann erneut auftritt bzw. der Zustand inaktiv und dann wieder aktiv ist, wird ein CEL-Eintrag erzeugt.

Alarm/Ereignis-Gruppe

Zuweisung an eine Alarm/Ereignis-Gruppe.

Alarm/Ereignis-Klasse

Zuweisung an eine Alarm/Ereignis-Klasse.

Wert

Parameter

Beschreibung

Wert

Festlegung der Wertangabe:

  • beliebig: eine beliebige Wertänderung verursacht die Grenzwertverletzung
  • größer: Eingabe eines Grenzwerts
  • kleiner: Eingabe eines Grenzwerts
  • gleich: Eingabe eines Grenzwerts
  • Bereich: Eingabe eines Bereichs (von ... bis)

Grenzwerttext

Text, der bei Grenzwertverletzung ausgegeben wird.

Jede Wertänderung als neue Grenzwertverletzung behandeln

Aktiv: Jede Wertänderung wird als Grenzwertverletzung angezeigt.

Verzögerungszeit

Zeit, die der Grenzwert verletzt sein muss, damit er aktiv wird.

Zustandstext für Zähler im Mathematik Treiber

Zuweisung einer von vier möglichen Zustandsnummern für einen Zähler im Mathematik Treiber. Die Variable muss dazu über eine Rema verfügen.

info Info

Ein Dezimalwert kann sowohl mit Komma als auch mit Punkt angegeben werden, das Dezimalzeichen wird automatisch in einen Punkt umgewandelt.


Konfiguration AML/CEL-Text

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Multireaktionsmatrizen allgemein -> Konfiguration AML/CEL-Text

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte wird die Ausgabe in AML und CEL konfiguriert.


Konfiguration Statusrangierung

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Multireaktionsmatrizen allgemein -> Konfiguration Statusrangierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte wird die Stausrangierung konfiguriert. Rangiert Bits (auch negiert) auf andere Bits.

Mögliche Quellen: Wertbit 0 ... 31l

Parameter | Beschreibung
Quellbit | Quellbit aus der Listbox auswählen
NEG | Quellbit bei der Rangierung negieren
Statusbit | Zielbit aus Listbox auswählen
Übernehmen | gewählte Rangierung übernehmen
Löschen | selektierte Rangierung löschen; Achtung: Es erfolgt keine weitere Abfrage
Nach oben | selektierte Rangierung in der Reihenfolge nach oben verschieben
Nach unten | selektierte Rangierung in der Reihenfolge nach unten verschieben


Konfiguration Sonderfunktionen

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Multireaktionsmatrizen allgemein -> Konfiguration Sonderfunktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden Sonderfunktionen konfiguriert.

Variablen können bei anstehenden Statusbits automatisch abgeschaltet bzw Statusänderungen (für Rücksetzen) bei abgeschalteten Variablen durchgelassen werden. Details siehe Kapitel Statusdefinition.

Parameter | Beschreibung
Abschalten bei | Statusbits, bei der die Variable abgeschaltet werden soll; Überprüfung auf 0 oder 1 möglich
Durchlassen bei | Statusbits, bei der eine Statusänderung durchgelassen werden soll
Kein Alt-/Neu-Vergleich | es erfolgt keine Änderungsüberwachung
Kein Alt-/Neu-Vergleich bei EZ-Weg | es erfolgt keine Änderungsüberwachung auf dem Echtzeitweg


Test

Handbuch -> Variablen -> Reaktionsmatrizen -> Arten von Reaktionsmatrizen -> Test

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ermöglicht den Test der Einstellungen für die Reaktionsmatrix. Abhängig von der Konfiguration der Reaktionsmatrix wird simuliert, was beim Erreichen von definierten Werten passiert. Einträge in CEL oder AML werden simuliert. Dieses Feature betrifft SICAM 230.

Parameter | Beschreibung
Status | Zum Simulieren von Statusänderungen.
Wert | Simulieren von Wertänderungen.
Testergebnis | Ausgabe von Änderungen aus Status und Wert in CEL und AML.
SendenEZ | Änderungen in Echtzeit senden.
SendenNEZ | Änderungen senden.


Dynamische Grenzwerttexte in Reaktionsmatritzen

Handbuch -> Variablen -> Reaktionsmatrizen -> Dynamische Grenzwerttexte in Reaktionsmatritzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dynamische Grenzwerttexte können auch in Reaktionsmatritzen angezeigt werden:

$ %PV

$ @text

Siehe auch Dynamischer Grenzwerttext.

Reaktionsmatritzen können für mehrere Variablen benutzt werden.


Liste Status-Bits

Handbuch -> Variablen -> Reaktionsmatrizen -> Liste Status-Bits

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Details zur Statusverarbeitung lesen Sie im Kapitel Statusverarbeitung.


Funktionen für Variablen

Handbuch -> Variablen -> Funktionen für Variablen

Funktionen ermöglichen Ihnen, zur Runtime Befehle über einen Button oder ein Skript zu starten.

Um eine Funktion zu erstellen:

  1. wählen Sie im Kontextmenü oder in der Symbolleiste des Knotens Funktion den Befehl Funktion neu...
  2. navigieren Sie zu Variable
  3. wählen Sie die gewünschte Funktion

Noch in diesem Kapitel

Daten exportieren

dBase Datei lesen

Drucken Momentan-Werte

HD-Verwaltung aktiv

HD-Verwaltung inaktiv

HD-Verwaltung inaktiv/aktiv

Sollwert absetzen

Treiberkommandos

Uhrzeit auf Variable schreiben

Uhrzeit von Variable lesen


Daten exportieren

Handbuch -> Variablen -> Funktionen für Variablen -> Daten exportieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Funktion ermöglicht, zur Runtime Variablendaten zu exportieren.

Das Exportformat und der Dateiname werden im Editor definiert. Der Ablageort bei Ausführung zur Runtime ist der Ordner Export im Runtimeordner.

Tipp: Den Projektordner erreichen Sie, indem Sie das Projekt im Editor markieren und die Tastenkombination Strg+Alt+R drücken.

Um die Funktion zu erstellen:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Daten exportieren
  3. der Konfigurationsdialog wird geöffnet

Parameter

Beschreibung

Ausgabeformat

Format

Wählen Sie einen der möglichen Dateitypen:

  • dBase IV (*.dbf)
  • XML (*.xml)
  • CSV (*.txt)

Als Unicode

Diese Checkbox ist nur aktiv, wenn Sie als Dateityp CSV (*.txt) selektiert haben.
Aktiv: Datei wird in Unicode (UTF-16) gespeichert.

Dateinamen

Legen Sie den Dateinamen festlegen.
Bei DBF-Dateien sind maximal 8 Zeichen erlaubt.

Hinweis: Der Name ist zur Runtime nicht mehr änderbar.

Ablageort zur Runtime: Ordner Export im Runtimeordner.

Variablen

Variablenauswahl

Auswahl der zu exportierenden Variablen. Klick auf Schaltfläche öffnet Dialog zur Variablenauswahl.

Diese Auswahl ist zur Runtime nicht mehr änderbar.

Hinweis: Damit eine Variable gewählt werden kann, muss für diese die Eigenschaft Harddisk Datenspeicherung aktiv in der Gruppe Harddisk Datenspeicherung aktiv gesetzt sein.

Interne ID: Daten exportieren

Harddisk Datenspeicherung

Eigenschaften für das Speichern von Variablenwerten auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Daten exportieren

Harddisk Datenspeicherung aktiv

Aktiv: Variablenwerte werden auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element "Trendelement" oder den Export/Import der Werte gespeichert.

Inaktiv: Keine Variablenwerte werden gespeichert.

Default: inaktiv.

Die HD-Daten brauchen je gespeicherten HD-Wert 24 Bytes Platz, unabhängig vom zu speichernden Variablentyp. Neben dem Wert werden noch folgende Informationen gespeichert:
- Zeit, zu der der Wert gemessen wurde.
- Millisekunden beim Einlesen des Wertes.
- Status des Wertes um Elemente entsprechend anzupassen.
- Zähler für eindeutige Kennung des Wertes (Spontantreiber).

Hinweis: Die Datenspeicherung wird auch bei der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend aktiviert, wenn Onlinedaten ausgewertet werden.
Variablen vom Typ String werden von der Harddisk-Datenspeicherung nicht unterstützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Werte neu initialisieren

Bei den HD-Werten wird ein Ringpuffer gefüllt und mitgeführt.
Aktiv : Der Ringpuffer wird beim Export geleert und neu initialisiert.
Inaktiv : Der Ringpuffer wird beim Export beibehalten.


dBase Datei lesen

Handbuch -> Variablen -> Funktionen für Variablen -> dBase Datei lesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann im Onlinebetrieb eine DBase-Datei neu eingelesen und als Rezeptur abgesetzt werden.

Als Übergabeparameter ist die DBase-Datei anzugeben. Der Datei- und der Verzeichnisnamen müssen den DOS-Konventionen entsprechen.

In dieser Datei sind die Prozessvariablennamen und die dazugehörige Sollwerte enthalten. Ist bei der Ausführung der Funktion die definierte Prozessvariable im aktuellen Projekt enthalten, wird der in der dBase-Datei voreingestellte Wert als neuer Sollwert an die Steuerung weitergeleitet.

Die dBaseIV-Datei muss folgende Struktur und Inhalte besitzen:

Bezeichnung | Typ | Wert | Bemerkung
NAME | Char | 32 | Prozessvariablenname
WERT | Num | 20 | technischer Wert
TYP | Char | 8 | Datentyp (C=String, N=Numerisch)
DIRECTION | Char | 12 |


Drucken Momentan-Werte

Handbuch -> Variablen -> Funktionen für Variablen -> Drucken Momentan-Werte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann im Onlinebetrieb ein einfaches Protokoll der aktuellen Variablenwerte (Prozess- und abgeleitete Variablen) erzeugt werden.

Als Übergabeparameter ist eine Formatierungsdatei anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske.

Projektierbare Eigenschaften sind:

Parameter | Beschreibung
Systembuttons | OK, Abbruch und Hilfe
mit Abbruch Dialog | Abbruchdialog währen der Generierung im Onlinebetrieb anzeigen
Auswahl Format Datei | Öffnet eine Dialog Box zur Auswahl der *.FRM-Datei. Diese Datei wird mit dem Button unterhalb erzeugt. Das Format FRM wird weiter unten in diesem Kapitel beschrieben.
Format Editor Starten | Texteditor zum Erstellen der Datei starten
Schriftart | festlegen der zu verwendenden Schriftart

Wird der Button Auswahl Format-Datei gewählt, kann die Datei (Dateityp *.FRM) ausgewählt werden.

In der Formatierungsdatei werden definierte Schlüsselwörter verwendet. Im Onlinebetrieb werden anstelle der Schlüsselworte die entsprechenden Variablenparameter eingetragen.

Schlüsselwörter sind:

Schlüsselwort | Beschreibung
@TTA.name | Variablennamen ausgeben
@TTA.wert | den aktuellen technischen Wert ausgeben; Binärzustand als Wert ausgeben bzw. Stringvariableninhalte
@TTA.einheit | die zur Prozessvariablen definierte Einheit ausgeben
@TTA.text | den zur Prozessvariablen definierten Text ausgeben
@TTA.status | die aktuell anstehenden Statusbits der Prozessvariablen hintereinander mit der Kurzkennung (aus der Datei ZENON6.INI) ausgeben

Für die Formatierung der Ausgabeseite bzw. als allgemeine Informationen sind folgende Schlüsselwörter verfügbar:

Schlüsselwort | Beschreibung
%DATE | Ausgabe des aktuellen Datums
%TIME | Ausgabe der aktuellen Uhrzeit
%PAGE | Ausgabe der aktuellen Seitennummer

Textausgaben am Seitenkopf und -ende können projektiert werden. Mit einem %% sind die Bereiche (Seitenkopf, Hauptbereich, Fußbereich) vor und hinter dem Bereich zu markieren. Nach dem letzten %% sind drei Leerzeilen einzugeben.

Die Verwendung von TABs führt zu Ausgabeproblemen bei unterschiedlich langen Ausgaben. Es dürfen für die Positionierung nur Leerzeichen verwendet werden. Das Schlüsselzeichen @ wird nicht mitgezählt.

FRM-Datei PROJEKT.FRM

%%
Seitenkopftext
%%
%%
%date Messwertprotokoll der Anlage XYZ %time Uhr

Bezeichnung techn. Wert Einheit
Messwert 1 @MESSWERT1.wert bar
Messwert 2 @MESSWERT2.wert kV
Messwert 3 @MESSWERT3.wert ºC

Seite %page
%%
%%
Seitenfußtext
%%

Onlineausdruck mit der Datei PROJEKT.FRM

Seitenkopftext

21.02.1995 Meßwertprotokoll der Anlage XYZ 12:00 Uhr

Bezeichnung techn. Wert Einheit
Messwert 1 0.63 bar
Messwert 2 9.98 kV
> Messwert 3 17.3 ºC

> Seite 5

Seitenfußtext

Ist die gewünschte Formatierung der Momentanwerte enger als der Platz zwischen den TTA-Schlüsselworten, kann eine QRF-Datei mit gleichem Namen verwendet werden. In der QRF-Datei werden die Prozessvariablen auf definierte Merker bezogen. Jeder Merker (xxx) beginnt mit einem $ und wird über einen festgelegten Syntax definiert.

define $ xxx as Variable |
- xxx | freie Kurzkennung bzw. Ziffer
- Variable | Variablenname

In der FRM-Datei kann auf diese Merker zugegriffen werden. Die Variablenparameter werden dann über andere Parameter angesprochen.

$xxx.1 | Prozessvariablename
$xxx.2 | technischer Wert
$xxx.3 | Einheit
$xxx.4 | Zustandstext

Hinweis: Variablennamen mit einem Punkt müssen in Hochkomma gesetzt werden, z.B.: "Variable.Test".

Beispiel für den Aufbau der QRF-Datei

QRF-Datei MOMENT.QRF

define $001 as TTA1
define $002 as TTA2

FRM-Datei MOMENT.FRM

%%
Kopftext
%%
%%
Hauptbereich
Wert der TTA1= @$001.2
Wert der TTA2= @$002.2
%%
%%
Fußtext
%%

Onlineausdruck mit der Datei MOMENT.FRM

Kopftext
Wert der TTA1= 100.25
Wert der TTA2= 25.745
Fußtext


HD-Verwaltung aktiv

Handbuch -> Variablen -> Funktionen für Variablen -> HD-Verwaltung aktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird die HD-Verwaltung (Ablage der Onlinewerte bei projektierter HD-Eigenschaft; Onlinetrend) im Onlinebetrieb aktiv geschaltet.

Es sind keine Übergabeparameter notwendig.


HD-Verwaltung inaktiv

Handbuch -> Variablen -> Funktionen für Variablen -> HD-Verwaltung inaktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird die HD-Verwaltung (Ablage der Onlinewerte bei projektierter HD-Eigenschaft; Onlinetrend) im Onlinebetrieb inaktiv geschaltet.

attention Achtung

Es werden keine Werte mehr gespeichert! Onlinewerte werden aktualisiert. Es sind keine Übergabeparameter notwendig.


HD-Verwaltung inaktiv/aktiv

Handbuch -> Variablen -> Funktionen für Variablen -> HD-Verwaltung inaktiv/aktiv

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion wird die HD-Verwaltung (Ablage der Onlinewerte bei projektierter HD-Eigenschaft; Onlinetrend) im Onlinebetrieb zwischen den beiden Zuständen umgeschaltet. Der in der Datei project.ini gespeicherte Zustand wird beim Starten des Onlinebetriebes eingelesen.

[DEFAULT] |
... |
HDDATEN= | 0 - inaktiv
 | 1 - aktiv


Sollwert absetzen

Handbuch -> Variablen -> Funktionen für Variablen -> Sollwert absetzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Verwendung dieser Funktion kann im Onlinebetrieb ein Sollwertsetzen auf eine Variable (Sollwert, Befehl, Einzelmeldung) durchgeführt werden.

Als Übergabeparameter ist die Variable, der Sollwert und die Art der Sollwertvorgabe anzugeben. Die Projektierung der Funktion erfolgt über eine Dialogmaske. Eine Eingabe über das numerische Tastenfeld ist möglich. Dezimalzeichen des Sollwertes werden als Punkt und Beistrich akzeptiert.

Projektierbare Eigenschaften sind:

Sollwert Einstellungen:

Parameter | Beschreibung
Sollwert / Änderung um | Abzusetzender technischer Sollwert der hinterlegten Variable
direkt zur Hardware | Aktiv : Der Sollwert wird im Onlinebetrieb ohne weitere Bestätigung nach der Aktivierung der Funktion abgesetzt. Inaktiv : Vor dem Absetzen des Sollwerts wird die Sollwertmaske aufgeschaltet und der Benutzer kann in der Runtime die Einstellungen ändern.
aktuellen Wert vorschlagen | Aktiv : Der aktuell in der Steuerung anstehende Wert wird als Default vorgeschlagen oder direkt an die Hardware abgesetzt. Zusätzlich ändert sich die Beschriftung des Feldes Sollwert in Änderung um und der dort eingetragene Wert wird zum Default addiert (bei negativem Wert subtrahiert). Inaktiv : Der unter Sollwert eingetragene Wert wird als Default vorgeschlagen oder direkt an die Hardware abgesetzt.
Sollwertgrenzen von der Variable beziehen | Aktiv : Die erlaubten Sollwertgrenzen werden aus der Variablendefinition ( Bezeichnung/Sollwert setzen ) übernommen. Inaktiv : Die erlaubten Sollwertgrenzen können direkt in der Funktion eingegeben werden ( Min und Max ).
Schreibbestätigung abwarten | Aktiv : Die Funktionsausführung wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder der fix definierte Timeout von 30 Sekunden verstrichen ist. Damit kann in Scripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist. Die Rückmeldung kann auch über das Statusbit WR-SUC abgefragt werden. Inaktiv : Es wird keine Schreibbestätigung abgewartet.

Sollwert setzen bei numerischen Variablen in der Runtime:

A. | Eingabemaske | Die Eingabe erfolgt über die Sollwert-Eingabe-Maske von zenon. Ist das Keyboardbild SETVALUEKBD im Projekt vorhanden, wird dieses automatisch verwendet.
B. | Bild | in Vorbereitung
C. | Programm | über ein selbst erstelltes Programm

info Info

Ein Dezimalwert kann sowohl mit 'Komma' als auch mit 'Punkt' angegeben werden, das Dezimalzeichen wird automatisch in einen 'Punkt' umgewandelt.

Werden Binärvariablen vorgegeben (Meldung, Befehl) ändert sich die Dialogmaske.

Projektierbare Eigenschaften sind:

Parameter | Beschreibung
LOW (0) | Wert der Variablen wird auf LOW (0) gesetzt.
HIGH (1) | Wert der Variablen wird auf HIGH (1) gesetzt.
TOGGLE | Wert der Variablen wird in den komplementären (gegensätzlichen) Zustand geschaltet.
direkt zur Hardware | Aktiv : Der Sollwert wird im Onlinebetrieb ohne weitere Bestätigung nach der Aktivierung der Funktion abgesetzt. Inaktiv : Vor dem Absetzen des Sollwerts wird die Sollwertmaske aufgeschaltet und der Benutzer kann in der Runtime die Einstellungen ändern.
aktuellen Wert vorschlagen | Aktiv : Der aktuell in der Steuerung anstehende Wert wird als Default vorgeschlagen oder direkt an die Hardware abgesetzt. Inaktiv : Der unter Sollwert eingetragene Wert wird als Default vorgeschlagen oder direkt an die Hardware abgesetzt.
Schreibbestätigung abwarten | Aktiv : Die Funktionsausführung wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder der fix definierte Timeout von 30 Sekunden verstrichen ist. Damit kann in Scripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist. Die Rückmeldung kann auch über das Statusbit WR-SUC abgefragt werden. Inaktiv : Es wird keine Schreibbestätigung abgewartet.

Sollwert setzen bei Binärvariablen in der Runtime:

Parameter | Beschreibung
Eingabemaske | Die Eingabe erfolgt über die Sollwert-Eingabe-Maske von zenon. Ist das Keyboardbild SETBOOLKBD im Projekt vorhanden, wird dieses automatisch verwendet
Bild | in Vorbereitung
Programm | über ein selbst erstelltes Programm

Nach der Projektierung wird die Funktion in die Funktionsliste mit den Übergabeparametern eingetragen. Wird der Sollwert direkt an die Hardware ausgegeben, steht in der Funktionsverwaltung zusätzlich ein -> vor dem Wert.

Die Art des Mitprotokollierens der Sollwertgabe kann über die Projekt-Konfiguration CEL Verwaltung... projektiert werden.

info Info

Wird ein Nachladen oder eine Server-Standby-Umschaltung angestossen, so werden die anstehenden Rückmeldungen bzw. Schreibbestätigungen verworfen!

Noch in diesem Kapitel

Sollwert schreiben überprüfen


Sollwert schreiben überprüfen

Handbuch -> Variablen -> Funktionen für Variablen -> Sollwert absetzen -> Sollwert schreiben überprüfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Schreiben von Werten erhält der Wert ein Statusbit, dass er geschrieben wird. Ist der Schreibvorgang erfolgreich, wird das entsprechende Statusbit gesetzt:

  • WR-ACK

    Der Treiber hat einen Wert zum Schreiben bekommen.

  • WR-SUC

    Wert 1: Schreiben erfolgreich.

    Wert 0: Schreiben nicht erfolgreich, der Wert konnte nicht abgesetzt werden.

info Info

Wird ein Nachladen oder eine Server-Standby-Umschaltung ausgeführt, dann werden die anstehenden Rückmeldungen bzw. Schreibbestätigungen verworfen!

Diese Statuskombination bleibt solange bestehen, bis die nächste Wertänderung angestoßen wird. Dann gehen beide Status auf 0 bis der Schreibvorgang fertig ist. Zur Auswertung muss in der Rema folgende Bitkombination abgefragt werden:

WR-ACK, WR-SUC

Ergebnis:

  • WR-ACK 1, WR-SUC 1: Schreibvorgang erfolgreich.
  • WR-ACK 1, WR-SUC 0: Schreibvorgang nicht erfolgreich.

attention Achtung

Der Mechanismus zeigt nur, dass der Schreib Vorgang erfolgreich (oder nicht erfolgreich) auf die Steuerung abgesetzt wurde. Es bedeute nicht, dass der Wert in der Steuerung auch geändert wurde, da die Steuerung den Wert sofort wieder zurücksetzen/überschreiben kann. (Zum Beispiel beim Schreiben auf Ausgänge oder bei Wischerbits, die nur kurzfristig gesetzt werden.)

Module

Dieser Mechanismus kann bei folgenden Modulen eingesetzt werden:

  • Funktion Sollwert absetzen: Option Schreibbestätigung abwarten im Konfigurationsdialog der Funktion aktivieren.
  • Standard Rezepte: Eigenschaft Synchron schreiben aktivieren.

    Interne ID: Sollwert schreiben überprüfen

    Synchron schreiben

    Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
    Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
    Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
    Inaktiv: Es wird keine Schreibbestätigung abgewartet.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Rezeptgruppen-Manager: Eigenschaft Synchron schreiben aktivieren.

Eintrag in CEL

  • Funktion Sollwert absetzen

    Für den Eintrag in der CEL muss in den Projekteigenschaften im Knoten Chronologische Ereignisliste die Eigenschaft Funktion SW-Setzen aktiviert werden. Es wird dann bei jedem Ausführen der Funktion die positive oder negative Rückmeldung in die CEL geschrieben.

    Interne ID: Sollwert schreiben überprüfen

    Funktion SW-Setzen

    Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
    Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
    Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
    Default: inaktiv
    Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

    Interne ID: Sollwert schreiben überprüfen

    CEL aktiv

    Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
    Inaktiv: Keine Ereignisse werden aufgezeichnet.
    Default: aktiv

    Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Sollwert schreiben überprüfen

    Chronologische Ereignisliste

    Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Standard Rezepte und Rezeptgruppen Manager

    Für den Eintrag in die CEL wird eine Systemtreibervariable verwendet, die bei erfolgreich abgesetzten Rezept auf 1 geht. Eine globale Variable wird am am Server ausgewertet, eine lokale auf jedem Client, um zu erfahren, wann das zuletzt ausgeführte Rezept fertig geschrieben wurde.
    Mit diesen Variablen kann per Grenzwert oder Reaktionsmatrizen einen CEL Eintrag generiert werden. Die Abfrage erfolgt mit einer Multianalog oder einer Multibinär Rema.


Treiberkommandos

Handbuch -> Variablen -> Funktionen für Variablen -> Treiberkommandos

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Kapitel beschreibt Standardfunktionalitäten, die für die meisten zenon Treiber gültig sind. Nicht alle hier beschriebenen Funktionalitäten stehen für jeden Treiber zur Verfügung. Zum Beispiel enthält ein Treiber, der laut Datenblatt keine Modemverbindung unterstützt, auch keine Modem-Funktionalitäten.

Treiberkommandos dienen dazu, Treiber über zenon zu beeinflussen, z. B. starten und stoppen.
Die Projektierung erfolgt über die Funktion Treiber Kommandos. Dazu:

  • legen Sie eine neue Funktion an
  • wählen Sie Variablen -> Treiberkommandos
  • der Dialog zur Konfiguration wird geöffnet

Parameter

Beschreibung

Treiber

Dropdownliste mit allen im Projekt geladenen Treibern.

Aktueller Zustand

Fixer Eintrag, in aktuellen Versionen ohne Funktion.

Treiberkommando

Dropdownliste zur Auswahl des Kommandos.
  • Treiber starten (Online-Modus)

Treiber wird neu initialisiert und gestartet.
  • Treiber stoppen (Offline-Modus)

Treiber wird angehalten, es werden keine neuen Daten angenommen.

Hinweis: Ist der Treiber im Offline-Modus, erhalten alle Variablen, die für diesem Treiber angelegt wurden, den Status Abgeschaltet (OFF; Bit 20).

  • Treiber in Simulationsmodus

Treiber wird in den Simulationsmodus gesetzt.
Die Werte aller Variablen des Treibers werden vom Treiber simuliert. Es werden keine Werte von der angeschlossenen Hardware (z.B. SPS, Bussystem, ...) angezeigt.
  • Treiber in Hardwaremodus

Treiber wird in den Hardwaremodus gesetzt.
Für die Variablen des Treibers werden die Werte von der angeschlossenen Hardware (z.B. SPS, Bussystem, ...) angezeigt.
  • Treiberspezifisches Kommando

Eingabe treiberspezifischer Kommandos. Öffnet Eingabefeld für die Eingabe eines Kommandos.
  • Treiber Sollwertsetzen aktivieren

Sollwert setzen auf Treiber ist erlaubt.
  • Treiber Sollwertsetzen deaktivieren

Sollwert setzen auf Treiber wird verhindert.
  • Verbindung mit Modem aufbauen

Verbindung aufbauen (für Modem-Treiber). Öffnet Eingabefelder für Hardware-Adresse und Eingabe der zu wählenden Nummer.
  • Verbindung mit Modem trennen

Verbindung beenden (für Modem-Treiber).

Diesen Dialog zur Runtime anbieten

Dialog wird zur Runtime für Änderungen angeboten.

Treiberkommandos im Netzwerk

Wenn sich der Rechner, auf dem die Funktion Treiberkommandos ausgeführt wird, im zenon Netzwerk befindet, werden zusätzliche Aktionen ausgeführt. Ein spezielles Netzwerkkommando wird vom Rechner zum Server des Projekts gesendet, der dann die gewünschte Aktion auf seinem Treiber durchführt. Zusätzlich sendet der Server das gleiche Treiberkommando zum Standby des Projekts. Der Standby führt die Aktion auch auf seinem Treiber aus.

Dadurch ist gewährleistet, dass Server und Standby synchronisiert sind. Dies funktioniert nur, wenn Server und Standby jeweils eine funktionierende und unabhängige Verbindung zur Hardware haben.


Uhrzeit auf Variable schreiben

Handbuch -> Variablen -> Funktionen für Variablen -> Uhrzeit auf Variable schreiben

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion kann eine angeschlossene Steuerung mit dem PC synchronisiert werden. Bei Ausführung der Funktion wird die Systemzeit geholt und in eine Stringvariable im Format: DD.MM.YYYY HH:MM:SS geschrieben.

Als Parameter ist der Name der Variable anzugeben.


Uhrzeit von Variable lesen

Handbuch -> Variablen -> Funktionen für Variablen -> Uhrzeit von Variable lesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dieser Funktion kann der PC mit einer angeschlossenen Steuerung synchronisiert werden. Bei der Ausführung der Funktion wird die Stringvariable aus der SPS gelesen, und wenn die Differenz zwischen PC und SPS Zeit größer als eine Sekunde ist, wird die PC Systemzeit gesetzt und ein CEL Eintrag geschrieben. Die Stringvariable muss folgendes Format besitzen: DD.MM.YYYY HH:MM:SS.

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Als Parameter ist der Name der Variable anzugeben.


Bild Variablen-Diagnose

Handbuch -> Variablen -> Bild Variablen-Diagnose

Mit dem Bildtyp Variablen-Diagnose lassen sich Variablen in der Runtime darstellen und Sollwerte setzen. Nähere Informationen zu den vordefinierten Bildtypen finden Sie im Kapitel Bilder/Bildtypen.

Noch in diesem Kapitel

Bild vom Typ Variablen-Diagnose anlegen

Bildumschaltung - Variablen-Diagnose


Bild vom Typ Variablen-Diagnose anlegen

Handbuch -> Variablen -> Bild Variablen-Diagnose -> Bild vom Typ Variablen-Diagnose anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Variablen-Diagnose anzulegen:

  • legen Sie ein neues Bild an
  • wählen Sie als Bildtyp Variablen-Diagnose
  • ein leeres Bild wird erstellt
  • wählen Sie in der Dropdownliste des Menüs Kontrollelemente den Befehl Vorlage einfügen oder wählen Sie die gewünschten Kontrollelemente für die Bedienung zur Runtime

Kontrollelement | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Tabellarische Darstellung |
Variablen-Diagnose | Listenfenster zur Runtime.
Werte Dezimal | Die Variablenwerte in der Liste (Istwert, Sollwert) werden dezimal dargestellt.
Werte Hexadezimal | Die Variablenwerte in der Liste (Istwert, Sollwert) werden hexadezimal dargestellt.
Werte Binär | Die Variablenwerte in der Liste (Istwert, Sollwert) werden binär dargestellt.
Werte Oktal | Die Variablenwerte in der Liste (Istwert, Sollwert) werden oktal dargestellt.
Werte Dezimal Exponential | Die Variablenwerte in der Liste (Istwert, Sollwert) werden dezimal exponentiell dargestellt.
Variablen |
Variable hinzufügen | Variable in der Runtime zur Liste hinzufügen
Variable lösen | Variable in der Runtime aus der Liste entfernen.
Wertaktualisierung |
Istwert Aktualisierung Ein | Automatisches Einlesen der aktuellen Variablenwerte einschalten.
Istwert Aktualisierung Aus | Automatisches Einlesen der aktuellen Variablenwerte ausschalten.
Istwerte jetzt aktualisieren | Aktuelle Werte der Variablen neu einlesen.
Alle Variablen: Sollwerte absetzen | Sollwerte aller Variablen in die Hardware absetzen.
Selektierte Variablen: Sollwerte absetzen | Sollwerte der ausgewählten Variablen in die Hardware absetzen.
Sollwert ändern | Sollwert der ausgewählten Variable ändern.
Sonderoperationen |
Selektierte Variablen: Umschalten auf Spontanwert | Ausgewählte Variablen auf Spontanwert umschalten.
Selektierte Variablen: Umschalten auf Ersatzwert | Ausgewählte Variablen auf Ersatzwert umschalten.
Selektierte Variablen: Ersatzwert modifizieren | Ersatzwert der ausgewählten Variablen modifizieren.
Selektierte Variablen: Spontanwert einschalten | Für ausgewählte Variablen Spontanwert einschalten. Dafür wird das Status Bit OFF (Bit 20) zurückgesetzt.
Selektierte Variablen: Spontanwert abschalten | Für ausgewählte Variablen Spontanwert abschalten. Dafür wird das Status-Bits OFF (Bit 20) abgesetzt.
Selektierte Variablen: Revision einschalten | Für ausgewählte Variablen Revision einschalten. Dafür wird das Status-Bits REVISION (Bit 09) abgesetzt.
Selektierte Variablen: Revision abschalten | Für ausgewählte Variablen Revision abschalten. Dafür wird das Status-Bits REVISION (Bit 09) zurückgesetzt.
Filterpofile... |
Profilauswahl | Gespeichertes Profil auswählen
Speichern | Einstellungen als Profil speichern
Löschen | Profil löschen

info Info

Ein Dezimalwert kann sowohl mit Komma als auch mit Punkt angegeben werden, das Dezimalzeichen wird automatisch in einen Punkt umgewandelt.

Um die Variablen-Diagnose zur Runtime zu nutzen, legen Sie eine Funktion mit einer Bildumschaltung auf das Bild an.

info Info

Sie können nach den Status-Bits NORM und N_NORM filtern.


Bildumschaltung - Variablen-Diagnose

Handbuch -> Variablen -> Bild Variablen-Diagnose -> Bildumschaltung - Variablen-Diagnose

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die für das Aufschalten eines Bildes Variablen-Diagnose benötigten Parameter sind die im Bild darzustellenden Variablen und die vorgeschlagenen Sollwerte für die ausgewählten Variablen.

Um eine Funktion zur Aufschaltung des Bildes Variablen-Diagnose anzulegen:

  • wählen Sie Funktion neu
  • wählen Sie Bildumschaltung
  • wählen Sie das Bild vom Typ Variablen-Diagnose aus
  • ein Dialog zur Konfiguration öffnet sich

Parameter

Beschreibung

Variablen

Liste der Variablen und deren Eigenschaften.

Variable hinzufügen

Öffnet den Dialog zur Variablenauswahl, um eine oder mehrere Variablen hinzuzufügen.

Variable lösen

Ausgewählte Variablen werden aus dem Bild gelöst.

Sollwert ändern

Die vorgeschlagenen Sollwerte für die Variablen des Bildes können verändert werden. Sollwerte können auch durch Klick in die Zelle mit dem Sollwert geändert werden.

Optionen

Zahlenbasis für Anzeige

Definiert Darstellung der Werte zur Runtime.

Mögliche Werte:

  • Dezimal
  • Hexadezimal
  • Binär
  • Oktal
  • Dezimal Exponential

Istwerte Aktualisierung ein

Aktiv: Beim Aufschalten des Fensters zur Runtime werden die Istwerte aktualisiert.

Diesen Dialog zur Runtime anbieten

Aktiv: Der Dialog wird beim Aufschalten des Bildes in der Runtime angezeigt.

info Info

Die Spalten (Angezeigter Text, Spaltentypen und Spaltenbreiten) können Sie ändern in dem Sie einen Rechtsklick auf den Spaltentitel machen. Im Kontextmenü finden Sie die Einstellungen dafür. Diese werden vom Editor in die Runtime übertragen und können bei Bedarf auch dort mit dem selben Mechanismus geändert werden.


Maßeinheitenumschaltung

Handbuch -> Variablen -> Maßeinheitenumschaltung

Die Maßeinheitenumschaltung ermöglichen das Umrechnen und Umschalten von Basiseinheiten in sogenannte Umrechnungseinheiten, zum Beispiel Meter in Yard oder Meter in Dezimeter, Zentimeter und Millimeter. Eine Basiseinheit beinhaltet den Ausgangswert für eine Umrechnung. Die Umrechnungseinheit enthält den im Verhältnis zur Basiseinheit umgerechneten Wert. Beide verfügen über eine Maßeinheitenbezeichnung. Für die Umrechnungseinheiten können ein Faktor, ein Offset und eine Kommaverschiebung bezogen auf die zugehörige Basiseinheit definiert werden.

Interne ID: Maßeinheitenumschaltung

Kommaverschiebung

Korrektur der Nachkommastellen. Um diesen Wert wird die Anzahl der Kommastellen in der Umrechnungseinheit gegenüber der Basiseinheit verschoben.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Maßeinheitenumschaltung

Offset

aus Primäreinheit (d für y=kx+d)

Angabe des Umrechungsoffsets mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (d für y=kx+d bzw. b für y=mx+b).

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Maßeinheitenumschaltung

Faktor

Angabe des Umrechnungsfaktors mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (k für y=kx+d bzw. m für y=mx+b).

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bei der Parametrierung einer Variablen kann eine Basiseinheit ausgewählt werden. Über die Funktion Maßeinheitenumschaltung kann zur Runtime zwischen verschiedenen Maßeinheiten umgeschaltet werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Basiseinheit neu | Legt eine neue Basiseinheit an.
XML exportieren alle | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Maßeinheiten aus einer XML-Dateien.
Hilfe | Öffnet die Online-Hilfe.

info Info

Die Maßeinheitenumschaltung darf nicht gemeinsam mit der Report-Funktion variablerw verwendet werden. Diese Report-Funktion stellt für ältere Projekte eine Einheitenumschaltung zur Verfügung. Wird eine in der Maßeinheitenumschaltung definierte Einheit einer Variablen mit dieser Report-Funktion zur Runtime geändert, muss die Konfiguration in der Maßeinheitenumschaltung neu erfolgen.

Noch in diesem Kapitel

Maßeinheiten Detailansicht Symbolleiste und Kontextmenü

Maßeinheiten projektieren

Basiseinheit einer Variablen zuweisen

Funktion Maßeinheitenumschaltung

Runtime


Maßeinheiten Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Variablen -> Maßeinheitenumschaltung -> Maßeinheiten Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü Maßeinheiten Detailansicht

Menüpunkt | Aktion
Basiseinheit neu | Legt eine neue Basiseinheit an.
XML exportieren alle | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Maßeinheiten aus einer XML-Dateien.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü und Symbolleiste Basiseinheit/Umrechnungseinheit

Menüpunkt | Aktion
Basiseinheit neu | Legt eine neue Basiseinheit an.
Umrechnungseinheit neu | Legt eine neue Umrechnungseinheit für die übergeordnete Basiseinheit an.
Verknüpfte Elemente: Zurück zu Ausgangselement springen | Dropdownliste mit Link zurück zu dem Element, von dem aus man zur Einheit gekommen ist. Nur vorhanden, wenn Einheit mit anderem Element verknüpft ist.
Umbenennen | Ermöglicht das Umbenennen der Maßeinheit. Achtung: Werden Maßeinheiten umbenannt, so müssen alle Maßeinheiten, die bereits mit Variablen verknüpft sind oder in Funktionen verwendet werden, bei der jeweiligen Variablen bzw. in der jeweiligen Funktion manuell angepasst werden. Siehe auch: Basiseinheit einer Variablen zuweisen und Funktion Maßeinheitenumschaltung.
XML exportieren alle | Exportiert alle Einträge in eine XML-Datei.
XML importieren | Importiert Maßeinheiten aus einer XML-Dateien.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Hilfe | Öffnet die Online-Hilfe.


Maßeinheiten projektieren

Handbuch -> Variablen -> Maßeinheitenumschaltung -> Maßeinheiten projektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Umrechnung müssen Sie eine Basiseinheit und eine Umrechnungseinheit anlegen, sowie die Parameter für Umrechnung festlegen. Die Umrechnung erfolgt nach der Formel y=kx+d (Österreich) bzw. y=mx+b Deutschland). Jede Basiseinheit kann einer Variablen als Maßeinheit zugewiesen werden.

Um eine neue Basiseinheit anzulegen:

  • wählen Sie im Projektmanager den Knoten Maßeinheiten
  • führen Sie einen Rechtsklick auf Maßeinheiten aus
  • wählen Sie aus dem Kontextmenü den Befehl Basiseinheit neu
  • ein neuer Eintrag wird in der Liste angelegt
  • vergeben Sie eine Bezeichnung für die Maßeinheit
  • legen Sie eine Umrechnungseinheit an

Um eine neue Umrechnungseinheit anzulegen:

  • führen Sie einen Rechtsklick auf eine Basiseinheit aus
  • wählen Sie aus dem Kontextmenü den Befehl Umrechnungseinheit neu
  • ein neuer Eintrag wird in der Liste angelegt
  • vergeben Sie eine Bezeichnung für die Maßeinheit
  • legen Sie einen Faktor für die Umrechnung fest

    Interne ID: Maßeinheiten projektieren

    Faktor

    Angabe des Umrechnungsfaktors mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (k für y=kx+d bzw. m für y=mx+b).

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • legen Sie einen Wert für die Kommaverschiebung fest

    Interne ID: Maßeinheiten projektieren

    Kommaverschiebung

    Korrektur der Nachkommastellen. Um diesen Wert wird die Anzahl der Kommastellen in der Umrechnungseinheit gegenüber der Basiseinheit verschoben.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • legen Sie einen Wert für den Offset fest

    Interne ID: Maßeinheiten projektieren

    Offset

    aus Primäreinheit (d für y=kx+d)

    Angabe des Umrechungsoffsets mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (d für y=kx+d bzw. b für y=mx+b).

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Basiseinheit einer Variablen zuweisen

Handbuch -> Variablen -> Maßeinheitenumschaltung -> Basiseinheit einer Variablen zuweisen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Basiseinheiten weisen Sie einer Variablen in der Eigenschaft Maßeinheit (Knoten Allgemein) zu.

Interne ID: Basiseinheit einer Variablen zuweisen

Allgemein

Allgemeine Eigenschaften der Variable oder des Datentyps.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Basiseinheit einer Variablen zuweisen

Maßeinheit

Technische Einheit der Variablen für die Darstellung zur Runtime. Wurden im Modul Einheiten bereits Basiseinheiten erstellt, stehen diese in einer Dropdownliste zur Auswahl zur Verfügung.
Maximum: 50 Zeichen.
Default: leer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Sie können hier freie Bezeichnungen für Maßeinheiten vergeben. Soll die Maßeinheitenumrechnung zur Runtime genutzt werden, wählen Sie eine zuvor definierte Basiseinheit aus der Dropdownliste aus.

Tipp: Falls Sie eine freie Bezeichnung vergeben, legen Sie am besten gleich im Anschluss im Knoten Maßeinheiten die Basiseinheit mit gleichem Namen an.

Damit zur Runtime umgerechnet werden kann, müssen Sie eine Funktion Maßeinheitenumschaltung anlegen.

attention Achtung

Wird eine Maßeinheit nachträglich umbenannt, so wird die Umbenennung bei bereits verknüpften Variablen nicht automatisch nachgezogen.

Um bereits verknüpfte Maßeinheiten umzubenennen:

  • wählen Sie die Detailansicht im Projektmanager
  • wählen Sie die Spalte Maßeinheiten oder fügen Sie diese der Ansicht hinzu, falls sie noch nicht angezeigt wird
  • wählen Sie im Kontextmenü den Befehl Text in selektierter Spalte ersetzen
  • suchen Sie im sich öffnenden Dialog nach dem alten Namen und ersetzen Sie ihn durch den neuen


Funktion Maßeinheitenumschaltung

Handbuch -> Variablen -> Maßeinheitenumschaltung -> Funktion Maßeinheitenumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit zur Runtime zwischen Maßeinheiten umgeschaltet werden kann, legen Sie eine Funktion Maßeinheitenumschaltung an:

  • wählen Sie im Projektmanager den Knoten Funktion
  • wählen Sie im Kontextmenü den Befehl Funktion neu
  • navigieren Sie zu Variable
  • wählen Sie die Funktion Maßeinheitenumschaltung

    Hinweis: Das Ausführen der Funktion Maßeinheitenumschaltung löst auch einen Refresh des Reports aus, falls dieser gerade angezeigt wird.

  • der Dialog zur Parametrierung der Maßeinheitenumschaltung öffnet sich:

Eigenschaft | Beschreibung
Maßeinheitenumschaltung | Dialog zum Zuweisen von Umrechnungseinheiten zu Basiseinheiten.
Basiseinheit | Liste der angelegten Basiseinheiten.
Umschalten in | Dropdownliste zur Auswahl der Umrechnungseinheit. Es kann entweder eine projektierte Umrechnungseinheit oder die Basiseinheit gewählt werden. Projektierte Umrechnungseinheit: Zur Runtime wird auf diese umgeschaltet. <Basiseinheit>: Die Basiseinheit bleibt zur Runtime aktiv.

info Info

Beim XML-Export dieser Funktion werden die Maßeinheiten nicht mit exportiert. Diese müssen separat exportiert werden.

attention Achtung

Wird eine Maßeinheit nachträglich umbenannt, so wird die Umbenennung der Basiseinheit in den Funktionen automatisch berücksichtigt. Umrechnungseinheiten müssen manuell geändert werden.


Runtime

Handbuch -> Variablen -> Maßeinheitenumschaltung -> Runtime

In der Runtime wird jeder Variablenwert bei jeder Ein- oder Ausgabe zusätzlich zur standardmäßig verwendeten Umrechnung von Signal- auf Messbereicheinheiten umgerechnet.

  • Ausgabe: Über die Funktion Maßeinheitenumschaltung wird eine Umrechnungseinheit für eine Variable aktiviert. Der Wert in Messbereichseinheiten wird mit dem darin eingestellten Offset und Faktor beaufschlagt. Zudem wird für die Umwandlung des Wertes in einen String die an der Variable eingestellte Anzahl der Nachkommastellen entsprechend korrigiert.
  • Eingabe: Die Umrechnung erfolgt analog zur Ausgabe in umgekehrter Richtung.

Einschränkungen:

  • Beim Export werden die umgeschalteten Einheiten exportiert.
  • Werte, die als String gespeichert sind, werden für die Ausgabe nicht erneut umgerechnet. Diese Werte bleiben in der Maßeinheit, die zum Zeitpunkt des Erstellens des Strings aktiv war. Insbesondere trifft dies alle Werte, die in den Text eines CEL-Eintrags eingefügt werden, wie „Sollwert geändert von ALT auf NEU" usw.
  • Betriebsstunden und Schaltspielzähler im Industrial Maintenance Manager werden immer in Basiseinheiten angezeigt.
  • Leistungen im EMS-Fenster werden immer in Basiseinheit angezeigt.

VBA

Zugriffe auf Werte über VBA erfolgen immer in Basiseinheiten. Zum Beispiel liefert Variable.Value keinen maßeinheitenumgeschalteten Wert, da es sich um keine Wertausgabe handelt. Damit auch über VBA die Maßeinheitenumschaltung genutzt werden kann, wurden 4 neue Funktionen an Variable. eingebaut:

Keyword | Beschreibung
SecondaryUnitName | liefert den Namen der eingestellten Umrechnungseinheit
SecondaryUnitDigits | liefert die Nachkommastellen der eingestellten Umrechnungseinheit
CalcSecondaryUnitValue | rechnet Wert der Basiseinheit in den Wert der Umrechnungseinheit um
CalcPrimaryUnitValue | rechnet Wert der Umrechnungseinheit in den Wert der Basiseinheit um


Verriegelungen

Handbuch -> Verriegelungen

Verriegelungen dienen dazu, den Zugriff auf bestimmte zenon Objekte zur Runtime mithilfe von Variablen steuern zu können. Bedieneingaben können in Abhängigkeit von Variablen freigegeben oder unterdrückt werden. Abhängig von Prozesszuständen können Bedieneingaben aktiviert/deaktiviert werden.

Es können im Projekt beliebig viele Verriegelungen angelegt und verwendet werden. Bei jeder Verriegelung sind mehrere Verriegelungsbedingungen parallel möglich.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Verriegelbare Objekte

Alle Dynamische Elemente außer Trend-Element und Meldungselement.

Kontextmenü Projektmanager

Parameter | Beschreibung
Verriegelung neu | Legt eine neue Verriegelung an und öffnet den Dialog zur Variablenauswahl.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

info Info

Variablen für die Verriegelung können ersetzt werden. Details siehe Kapitel Ersetzen von Variablen und Funktionen in Dynamischen Elementen.

Example Beispiel

Eine Maschine ist in vollem Automatik Betrieb und darf daher nicht in den manuellen Betriebszustand umgeschaltet werden. Erst wenn ein gewisser Betriebszustand (z.B. STOP) erreicht ist darf umgeschaltet werden. Mit den Verriegelungen kann in der Visualisierungsoberfläche der Button zur Umschaltung zwischen Hand/Automatik solange gesperrt werden bis dieser Zustand (z.B. STOP) gegeben ist. Dadurch wird vermieden, dass eine Fehlbedienung zu Stande kommt.

Noch in diesem Kapitel

Kontextmenü und Symbolleiste Detailansicht

Projektieren im Editor

Bedienen während der Runtime


Kontextmenü und Symbolleiste Detailansicht

Handbuch -> Verriegelungen -> Kontextmenü und Symbolleiste Detailansicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Symbolleiste

Symbol | Beschreibung
Verriegelung neu | Erstellt eine neue Verriegelung und öffnet den Dialog zur Auswahl der Variablen.
Verriegelungsbedingung neu | Legt eine neue Verriegelungsbedinung an.
Variable hinzufügen | Öffnet Dialog zur Auswahl einer Variablen
Kopieren | Kopiert ausgewählte Bedingung.
Einfügen | Fügt Bedingung aus Zwischenablage ein.
Löschen | Löscht ausgewählte Bedingung.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Umbenennen | Ermöglicht das Umbenennen eines Elements. Auch per Mausklick in das Feld oder über Taste F2 möglich.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Verriegelungen

Menüpunkt | Beschreibung
Verriegelung neu | Legt eine neue Verriegelung an und öffnet den Dialog zur Variablenauswahl.
Einfügen | Fügt kopierte Verriegelung aus Zwischenablage ein.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü einzelne Verriegelung

Menüpunkt | Aktion
Variable hinzufügen | Öffnet den Dialog zur Auswahl einer Variablen.
Verriegelungsbedingung neu | Legt eine neue Verriegelungsbedinung an.
Kopieren | Kopiert ausgewählte Verriegelung.
Einfügen | Fügt Verriegelung aus Zwischenablage ein.
Löschen | Löscht ausgewählte Verriegelung.
XML exportieren alle | Exportiert alle Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Umbenennen | Ermöglicht das Umbenennen eines Elements. Auch per Mausklick in das Feld oder über Taste F2 möglich.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Gruppe Variablen

Menüpunkt | Aktion
Variable hinzufügen | Öffnet Dialog zur Auswahl einer Variablen
Einfügen | Fügt Bedingung aus Zwischenablage ein.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü einzelne Variable

Menüpunkt | Aktion
Verknüpfte Elemente | Öffnet Dropdownliste mit verknüpften Elementen.
Kopieren | Kopiert ausgewählte Variable
Einfügen | Fügt Variable aus Zwischenablage ein.
Löschen | Löscht ausgewählte Variable.
Eigenschaften | Öffnet das Eigenschaftenfenster für das ausgewählte Element.
Hilfe | Öffnet die Online-Hilfe.

Kontextmenü Verriegelungsbedingungen

Menüpunkt | Aktion
Verriegelungsbedingung neu | Legt eine neue Verriegelungsbedinung an.
Einfügen | Fügt Bedingung aus Zwischenablage ein.
Hilfe | Öffnet die Online-Hilfe.


Projektieren im Editor

Handbuch -> Verriegelungen -> Projektieren im Editor

Noch in diesem Kapitel

Verriegelungen erstellen

Formeleditor


Verriegelungen erstellen

Handbuch -> Verriegelungen -> Projektieren im Editor -> Verriegelungen erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Durch Auswahl von Verriegelung im Projektmanager, öffnen sich in der Detailansicht des Projektmanagers die projektierten Verriegelungen. Nach Rechtsklick auf Allgemeine Verriegelungen erscheint ein Popup Menü in dem eine neue Verriegelung angelegt werden kann.

Die neue Verriegelung kann im Eigenschaftenfenster umbenannt werden. Durch Rechtsklick auf Variablen erscheint wiederum ein Popup Menü. Damit kann zur jeweiligen Verriegelung eine oder mehrere Variablen verknüpft werden.

Die Verriegelung kann mit einer Bedingung verknüpft werden. Dazu muss zuerst im Eigenschaftenfenster eine oder mehrere neue Bedingungen angelegt werden. Bei jeder Bedingung kann dann bei der Eigenschaft Logische Verknüpfung eine boolsche Formel eingegeben werden.

info Info

Ein Element in der Visualisierungs-Oberfläche ist dann gesperrt, wenn die Verriegelungsbedingung zutrifft, also Logisch 1 - TRUE ergibt.

Verrieglen: Sind mehrere Bedingungen bei der Verriegelung projektiert, dann reicht es aus, wenn eine Bedingung erfüllt ist, um das Element zu sperren!

Mit dem Formel-Editor, der durch Klick auf die Eigenschaft Logische Verknüpfung im Eigenschaftenfenster geöffnet wird, lassen sich boolesche und analoge Formeln als Verriegelungsbedingung definieren. Der Formeleditor erlaubt die Erstellung von booleschen Ausdrücken unter Zuhilfenahmen der zugeordneten Variablen und der Logischen und Bitweisen Operatoren, wie auch Vergleichsoperatoren. Siehe auch Kapitel Bilder / Vergleichsoperatoren.

info Info

Entriegeln: Sind mehrere Bedingungen mit der Verriegelung verknüpft, so muss jede erfüllte entriegelt sein.

seealso Siehe auch

Nähere Informationen zum Formel Editor siehe Kapitel Formel Editor.


Formeleditor

Handbuch -> Verriegelungen -> Projektieren im Editor -> Formeleditor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Formeleditor unterstützt bei der Erstellung von Formeln mit logischen oder vergleichenden Operatoren beim Combi-Element, bei Verriegelungen und Befehlsgabe. Werden für eine Formel zusätzliche Variablen benötigt, erstellen Sie diese im Bereich Formelvariablen des Zustandsfensters mit Klick auf die Schaltfläche Hinzufügen. Vorhandene Formeln werden in der Zustandsliste durch den Buchstaben F angezeigt.

Formel erstellen

Klicken Sie im Zustandsfenster auf die Schaltfläche Formel. Der Formeleditor öffnet sich

Im linken Fenster wählen Sie die Bits für Ihre Formel aus.

Rechts finden Sie die Operatoren für logische und vergleichende Operationen.

Im Bereich Formel wird die erstellte Formel angezeigt.

info Info

Es können bis zu 99 Variablen in einer Formel verknüpft werden. X01 bis X99. Die Länge der Formel darf dabei 4096 Zeichen nicht überschreiten.

Die Bedeutung der Bits:

Parameter

Beschreibung

Wert-Bits

Es stehen 32 Wert-Bits (von 0 -31) zur Verfügung. Sie beschreiben den Variablenwert bitweise. Für BOOL'sche Variablen hat nur das Bit 0 Bedeutung, für SINT und USINT die Bits 0-7 usw...

Hinweis: Die Auswertung bezieht sich immer auf den Rohwert (Signalbereich) der Variablen und nicht auf den umgerechneten Messwert.

Status-Bits

Stellt die gängigsten Status-Bits zur Verfügung. Die genaue Definition und Verwendung der Status-Bits finden Sie in der Liste Status-Bits.

unquittiert

Unquittiert wird wie ein ganz normales Status-Bit behandelt, wird hier aber separat angeführt, da es nicht zu den klassischen Variablen Status gehört.

Wert und Status

Alle Werte (Wert-Bits und Status-Bits) in den Formeln werden als Binärwerte betrachtet und können dann logisch mit UND bzw. ODER sowie anderen logischen Ausdrücken verbunden werden.
Eine Ausnahme bilden der Gesamtwert und der Gesamtstatus. Damit man damit auf einen boole'schen Ausdruck kommt, muss man diesen Gesamtwert zuerst mit einer Konstante bitweise verodern. Dazu wird der Operator & verwendet.
Bei Ergebnis 0 (False) der bitweisen Veroderung ergibt sich der Binärwert 0 (False), ansonsten 1 (True).

Beispiel: siehe Kapitel Beispiel bitweise Veroderung

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.

Werden außerhalb des Formeleditors andere Einstellungen für den aktuellen Zustand gemacht, so werden diese mit der Formel mit einem logischen UND verknüpft.

Für Beispiele siehe Abschnitt Beispiele für Formeln.

info Info

Formeln mit binären X-Werten und bitweiser Verknüpfung können mit maximal 2 binären Werten benutzt werden. Werden mehr Werte benötigt, muss die Verknüpfung ohne binäre X-Werte erfolgen.

Beispiel:

X01.Value & X02.Value -> funktioniert

X01.Value & X02.Value & X03.Value -> funktioniert nicht

Aber:

X01.00 AND X02.00 AND X03.00 AND X04.00 AND X05.00 -> funktioniert

Noch in diesem Kapitel

Liste Status-Bits

Logische Operatoren

Bitformeln

Vergleichsoperatoren

Beispiele für Formeln


Liste Status-Bits

Handbuch -> Verriegelungen -> Projektieren im Editor -> Formeleditor -> Liste Status-Bits

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Bitnummer | Kurzbezeichner | Langbezeichnung | zenon Logic Bezeichner
0 | M1 | Benutzerstatus 1 | _VSB_ST_M1
1 | M2 | Benutzerstatus 2 | _VSB_ST_M2
2 | M3 | Benutzerstatus 3 | _VSB_ST_M3
3 | M4 | Benutzerstatus 4 | _VSB_ST_M4
4 | M5 | Benutzerstatus 5 | _VSB_ST_M5
5 | M6 | Benutzerstatus 6 | _VSB_ST_M6
6 | M7 | Benutzerstatus 7 | _VSB_ST_M7
7 | M8 | Benutzerstatus 8 | _VSB_ST_M8
8 | NET_SEL | Select im Netzwerk | _VSB_SELEC
9 | REVISION | Revision | _VSB_REV
10 | PROGRESS | In Bedienung | _VSB_DIREC
11 | TIMEOUT | Laufzeit Überschreitung | _VSB_RTE
12 | MAN_VAL | Handwert | _VSB_MVALUE
13 | M14 | Benutzerstatus 14 | _VSB_ST_14
14 | M15 | Benutzerstatus 15 | _VSB_ST_15
15 | M16 | Benutzerstatus 16 | _VSB_ST_16
16 | GI | Generalabfrage | _VSB_GR
17 | SPONT | Spontan | _VSB_SPONT
18 | INVALID | Ungültig | _VSB_I_BIT
19 | T_CHG_A | Sommer/Winterzeit Ankündigung | _VSB_SUWI
20 | OFF | Abgeschaltet | _VSB_N_UPD
21 | T_EXTERN | Echtzeit extern | _VSB_RT_E
22 | T_INTERN | Echtzeit intern | _VSB_RT_I
23 | N_SORTAB | Nicht sortierfähig | _VSB_NSORT
24 | FM_TR | Störmeldung Trafowert | _VSB_DM_TR
25 | RM_TR | Laufmeldung Trafowert | _VSB_RM_TR
26 | INFO | Info der Variable | _VSB_INFO
27 | ALT_VAL | Ersatzwert Wurde noch kein Wert übertragen, wird der definierte Ersatzwert verwendet, sonst der zuletzt gültige Wert. | _VSB_AVALUE
28 | RES28 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES28
29 | N_UPDATE | Nicht aktualisiert | _VSB_ACTUAL
30 | T_STD | Winterzeit | _VSB_WINTER
31 | RES31 | Reserviert für interne Verwendung (Alarmblinken) | _VSB_RES31
32 | COT0 | Übertragungsursache Bit 1 | _VSB_TCB0
33 | COT1 | Übertragungsursache Bit 2 | _VSB_TCB1
34 | COT2 | Übertragungsursache Bit 3 | _VSB_TCB2
35 | COT3 | Übertragungsursache Bit 4 | _VSB_TCB3
36 | COT4 | Übertragungsursache Bit 5 | _VSB_TCB4
37 | COT5 | Übertragungsursache Bit 6 | _VSB_TCB5
38 | N_CONF | Negative Bestätigung des Select durch Gerät (IEC 60870 [P/N]) | _VSB_PN_BIT
39 | TEST | Test-Bit (IEC 60870 [T]) | _VSB_T_BIT
40 | WR_ACK | Schreiben bestätigt | _VSB_WR_ACK
41 | WR_SUC | Schreiben erfolgreich | _VSB_WR_SUC
42 | NORM | Normalzustand | _VSB_NORM
43 | N_NORM | Abweichung Normalzustand | _VSB_ABNORM
44 | BL_870 | IEC 60870 Status: blocked | _VSB_BL_BIT
45 | SB_870 | IEC 60870 Status: substituted | _VSB_SP_BIT
46 | NT_870 | IEC 60870 Status: not topical | _VSB_NT_BIT
47 | OV_870 | IEC 60870 Status: overflow | _VSB_OV_BIT
48 | SE_870 | IEC 60870 Status: select | _VSB_SE_BIT
49 | T_INVAL | Zeit ungültig | nicht definiert
50 | CB_TRIP | Schalterfall erkannt | nicht definiert
51 | CB_TR_I | Schalterfallerkennung inaktiv | nicht definiert
52 | RES52 | reserviert | nicht definiert
53 | RES53 | reserviert | nicht definiert
54 | RES54 | reserviert | nicht definiert
55 | RES55 | reserviert | nicht definiert
56 | RES56 | reserviert | nicht definiert
57 | RES57 | reserviert | nicht definiert
58 | RES58 | reserviert | nicht definiert
59 | RES59 | reserviert | nicht definiert
60 | RES60 | reserviert | nicht definiert
61 | RES61 | reserviert | nicht definiert
62 | RES62 | reserviert | nicht definiert
63 | RES63 | reserviert | nicht definiert

info Info

In Formeln stehen alle Statusbits zur Verfügung. Für andere Verwendungen kann die Verfügbarkeit reduziert sein.

Details zur Statusverarbeitung lesen Sie im Kapitel Statusverarbeitung.


Logische Operatoren

Handbuch -> Verriegelungen -> Projektieren im Editor -> Formeleditor -> Logische Operatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Logische Verknüpfungen: Variablen werden nur auf den logischen Wert '0' überprüft, ist der Wert ungleich '0', wird er mit '1' definiert.

Im Unterschied zur Bitformel kann der technische Bereich durch einen Streckungsfaktor verändert werden -> ungleich '0' oder '1'.

Operator | Bedeutung
AND | logisch 'UND'
NOT | Negation
OR | logisch 'ODER'
XOR | logisch 'EXKLUSIV ODER'

Die Operator haben in der Formelberechnung folgende Priorität:

Priorität | Operator
1 | & (Operator für Bitformeln)
2 | NOT
3 | AND
4 | XOR/OR

info Info

Es können bis zu 99 Variablen in einer Formel verknüpft werden. X01 bis X99.

info Info

Die Status-Bits NORM und N_NORM sind nur hier im Formeleditor verfügbar und nicht über den Zustand projektierbar.


Bitformeln

Handbuch -> Verriegelungen -> Projektieren im Editor -> Formeleditor -> Bitformeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bitformeln besitzen nur einen logischen Low- oder Highzustand. Im Unterschied zu logischen Formeln ist der Rohwert bereits fix vordefiniert (0,1).

Operator | Beschreibung
& | AND
| | OR

Noch in diesem Kapitel

Beispiel bitweise Veroderung


Beispiel bitweise Veroderung

Handbuch -> Verriegelungen -> Projektieren im Editor -> Formeleditor -> Bitformeln -> Beispiel bitweise Veroderung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie wollen abfragen, ob eines der Anwenderstatus Bits 1-8 (M1 ... M8) von der Variable X01 gesetzt ist.

Normale Formel:

X01.M1 OR X01.M2 OR X01.M3 OR X01.M4 OR X01.M5 OR X01.M6 OR X01.M7 OR X01.M8
Diese Abfrage kann durch die bitweise Veroderung des Gesamtstatus wesentlich erleichtert werden.

Bitweise Veroderung:

X01.Status & 0xFF

Die Konstante kann, wie oben beschrieben, Hexadezimal eingegeben werden:

0xFF entspricht dezimal 256, das sind die ersten acht Statusbits (Binär 11111111). Steht eines dieser Bits auf 1, dann ist das Ergebnis dieser bitweisen Veroderung 1 (True), ansonsten 0 (False).

Sollen z. B. alle Anwender Status-Bits außer dem Anwender Status-Bit M7 abgefragt werden, wäre der Binäre Ausdruck dafür: 10111111. Bit 7 ist nicht interessant, steht daher auf 0. Das entspricht Hexadezimal 0xBF. Der Ausdruck für die Formel ist dann: X01.Status & 0xBF.

Statt mit einer Konstante bitweis zu verodern, kann man den Wert auch direkt mit einer dezimalen Zahl vergleichen. Ist ein Vergleich falsch, ergibt sich der Binärwert 0 (False), ansonsten 1 (True).

Beispiel:

Sie wollen abfragen, ob ein Wert der Konstanten 202 entspricht. Die Formel lautet:

X01.Wert = 202

Entspricht der Wert der Konstanten 202, so ist das Ergebnis dieses Vergleiches 1 (True), ansonsten 0 (False).

Hinweis: Die bitweise Veroderung funktioniert mit dem Oder-Zeichen (|) analog zu diesem Beispiel.


Vergleichsoperatoren

Handbuch -> Verriegelungen -> Projektieren im Editor -> Formeleditor -> Vergleichsoperatoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vergleichoperatoren dienen zum direkten Vergleich von zwei numerischen Werten. Das Ergebnis dieses Vergleichs wird in Form eines Binärzustandes dargestellt. „0“ wenn die Bedingung nicht erfüllt ist und „1“ wenn die Bedingung erfüllt ist.

Operator | Beschreibung
< | kleiner
> | größer
<= | kleiner gleich
>= | größer gleich
= | ist gleich
<> | ungleich

Links und rechts vom Vergleichs Operator muss ein (Gesamt-)Wert oder (Gesamt-)Status stehen, Einzelbits können mit diesen Vergleichsoperatoren nicht verwendet werden.

Rechts vom Vergleichs Operator kann auch eine Konstante stehen. Die Konstanten können nur Ganzzahlen sein, ein Vergleich mit Gleitkommazahlen ist nicht möglich.
Im Combi-Element werden diese Konstanten als hexadezimale Werte oder Dezimalwerte eingegeben. Hexadezimale Zahlen werden beim Klick auf OK automatisch in Dezimalzahlen umgewandelt (z.B. entspricht 0x64 dem numerischen Wert 100).

Example Beispiel

X01.Wert >= X02.Wert
Das Ergebnis ist „1“ wenn der Wert von X01 größer oder gleich dem Wert X02 ist

X01.Wert = 0x64
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 entspricht (= Hex 0x64)

(X01.Wert = 0x64) OR (X01.Wert = 0x65)
Das Ergebnis ist „1“ wenn der Wert von X01 exakt dem numerischen Wert 100 oder 101 entspricht (= Hex 0x64 und Hex 0x65)


Beispiele für Formeln

Handbuch -> Verriegelungen -> Projektieren im Editor -> Formeleditor -> Beispiele für Formeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einfache logische UND Verknüpfung zwischen zwei Werte Bits

Example Beispiel

Formel: X01.03 AND X02.03

Diese Formel ergibt den Zustand WAHR, wenn sowohl Bit 3 der Variablen 1 als auch Bit 3 der Variablen 2 den Wert 1 hat.

Der Wert oder Status einer Variable analog vergleichen

Example Beispiel

(X01.Wert> X02.Wert)

Analoge Vergleiche auf logischer Basis miteinander vergleichen

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert)

Vergleiche mit Werte- und Status-Bits

Example Beispiel

(X01.Wert> X02.Wert) AND (X01.Wert = X02.Wert) OR (X01.03 = X02.03)

Einen Wert mit einem dezimalen oder hexadezimalen Wert vergleichen

Example Beispiel

Formel: (X01.Wert = 111)

Formel: (X01.Wert = 0x6F)

Wird ein hexadezimaler Wert verwendet, so wird dieser mit dem Klick auf OK später in dezimale Schreibweise umgewandelt. Wurde ein dezimaler Wert angegeben und bestätigt, wird dieser beim erneuten Öffnen weiter als dezimaler Wert angezeigt.

info Info

Bei der Eingabe von Zahlen ist es nicht möglich, ein Komma oder einen Punkt zu verwenden.


Bedienen während der Runtime

Handbuch -> Verriegelungen -> Bedienen während der Runtime

Noch in diesem Kapitel

Verriegelungen anwenden


Verriegelungen anwenden

Handbuch -> Verriegelungen -> Bedienen während der Runtime -> Verriegelungen anwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ist eine Verriegelung mit einem der Dynamische Bildelemente verknüpft, wird dieses je nach dem Ergebnis der logischen Verknüpfung in den Bedingungen der Verriegelung verriegelt oder freigeschalten. Ist die Bedingung erfüllt - das Ergebnis logisch 1 -, ist das Element gesperrt.

Das Dynamische Element, das verriegelt werden soll, muss ausgewählt werden. In dessen Eigenschaften wird unter Runtime/Berechtigung/Verriegelung eine der projektierten allgemeinen Verriegelungen ausgewählt.

info Info

Um zur Runtime sehen zu können ob das Element verriegelt ist, kann man in den Eigenschaften des Projekts unter Benutzerverwaltung/Grafische Kennzeichnung aktiv die Anzeige eines Schlosssymbols für verriegelte Elemente einschalten.

Interne ID: Verriegelungen anwenden

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zusätzlich kann das Aussehen eines verriegelten Buttons über die Eigenschaft Verriegelte Buttons (Grafische Ausprägung) bzw. Gesperrte Buttons (Benutzerverwaltung) gestaltet werden.

Interne ID: Verriegelungen anwenden

Gesperrte Buttons

Nur verfügbar, wenn die Eigenschaft Temp. Login aktiv inaktiv ist.
Definiert das Aussehen von Buttons, die aufgrund der Einstellungen der Bedienberechtigung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Verriegelte Buttons (Grafische Ausprägung) kombiniert.

Interne ID: Verriegelungen anwenden

Temp. Login aktiv

Aktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, wird er zur Eingabe seiner Kennung und seines Passworts aufgefordert.
Inaktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, erhält er die Information, dass er dazu nicht berechtigt ist.
Default: aktiv.

Hinweis: Position und Größe der Login-Maske können in der zenon6.ini unter [Befehlsgabe] Position = definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Verriegelungen anwenden

Verriegelte Buttons

Definiert das Aussehen von Buttons zur Runtime, die aufgrund einer Verriegelung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Gesperrte Buttons (Benutzerverwaltung) kombiniert.

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Diese Eigenschaft wirkt unabhängig von der Eigenschaft Grafische Kennzeichnung aktiv. Ein grauer Button kann z.B. auch ein Schlosssymbol anzeigen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


Verteiltes Engineering

Handbuch -> Verteiltes Engineering

Die Mehrbenutzer-Funktionalität von zenon macht es möglich, dass mehrere Benutzer zur gleichen Zeit am selben Projekt arbeiten. Die Projekte werden dafür auf einem zentralen SQL Server gespeichert, während sie von mehreren Arbeitsplätzen aus zeitgleich bearbeitet werden können. In weiterer Folge wird diese zentrale Ablage des Projektes als Server DB bezeichnet.

Zum Beispiel: Ein Benutzer erstellt die Bilder, während ein anderer gleichzeitig an der Variablendefinition arbeiten kann.

info Info

Hinweise zur Terminologie:

"Einchecken" entspricht Eigenschaft Änderungen übernehmen.

"Auschecken" entspricht Eigenschaft Änderungen ermöglichen.

IP-Protokoll

Die Kommunikation im zenon Netzwerk kann wahlweise über IPv4 oder IPv6 erfolgen. Details siehe Handbuch Netzwerk, Abschnitt Voraussetzungen

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Informationen zum SQL Server

Möglichkeiten der Mehrbenutzerverwaltung

Anlegen eines neuen mehrplatzfähigen Projekts

Einzelplatzprojekt in Mehrplatzfähiges Projekt konvertieren

Mehrplatzfähiges Projekt in Einzelplatzprojekt konvertieren

Umgang mit einem Mehrplatzfähigen Projekt

Offline arbeiten


Informationen zum SQL Server

Handbuch -> Verteiltes Engineering -> Informationen zum SQL Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon ab Version 7.00 SP0

Beim Verteilten Engineering greifen alle Teilnehmer auf einen zentralen SQL Server zu. Ab zenon Version 7.00 SP0 müssen alle Teilnehmer Versionen ab 7.00 verwenden:

  • Editor: ab 7.00 SP0
  • DBSrv: ab 7.00
  • SQL-Server: SQL Server 2008 R2 Express Edition

Update

Beim Update des Projektservers auf SQL Server 2008 Express müssen alle Clients ebenfalls aktualisiert werden. SQL-Server 2005 und SQL-Server 2008 sind nicht kompatibel.


Möglichkeiten der Mehrbenutzerverwaltung

Handbuch -> Verteiltes Engineering -> Möglichkeiten der Mehrbenutzerverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Mehrbenutzerverwaltung kann genutzt werden für:

  • für Einzelplatzprojekte, um Änderungen risikolos auszuprobieren
  • einem lokalen Server mit mehreren Clients
  • einem Netzwerkserver mit mehreren Clients

Noch in diesem Kapitel

Lokaler Server

Lokaler Server auf den mehrere Clients zugreifen

Ein Server auf den mehrere Clients zugreifen


Lokaler Server

Handbuch -> Verteiltes Engineering -> Möglichkeiten der Mehrbenutzerverwaltung -> Lokaler Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Fall befinden sich sowohl die Server DB als auch die lokale Projektkopie auf ein und demselben Rechner.

Es kann auch auf einem einzelnen Rechner ein Mehrplatzfähiges Projekt angelegt werden. Das ist zum Beispiel sinnvoll, wenn Änderungen zunächst überprüft werden sollen. Dazu werden z.B. bei einem Bild 'Änderungen ermöglicht', es wird bearbeitet und zur Laufzeit überprüft. Danach können die Änderungen entweder wieder übernommen oder verworfen werden. Das Originalbild bleibt so lange bestehen, bis die Änderungen am Bild übernommen wurden.


Lokaler Server auf den mehrere Clients zugreifen

Handbuch -> Verteiltes Engineering -> Möglichkeiten der Mehrbenutzerverwaltung -> Lokaler Server auf den mehrere Clients zugreifen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf einem Rechner befindet sich die Server DB und eine lokale Projektkopie. Die Clients arbeiten lokal ebenfalls mit einer Projektkopie. Änderungen an der lokale Projektkopie werden erst dann in die Serverdatenbank übertragen, wenn die Änderungen übernommen werden. Am Server-Rechner wird ebenfalls mit der lokalen Projektkopie gearbeitet.


Ein Server auf den mehrere Clients zugreifen

Handbuch -> Verteiltes Engineering -> Möglichkeiten der Mehrbenutzerverwaltung -> Ein Server auf den mehrere Clients zugreifen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dem Zentralrechner befindet sich die Server DB. Mehrere Clients verbinden sich mit diesem Server. Lokale Projektkopien werden auf den einzelnen Clients angelegt.

Lokale Projektkopien 1-3 vom Server DB

info Info

Mischformen aus den beschriebenen Konfigurationen sind möglich. z.B. jeder Rechner hat ein oder mehrere Server DBs installiert für verschiedene Projekte und hat gleichzeitig nur eine lokale Projektkopie einer anderen Server DB.

Server ohne Logins

Auf Server, auf denen sich keine Benutzer einloggen, muss die Datei zendbsrv.exe als Dienst laufen.

Der zendbsrv startet für Logging-Aufgaben den zensyssrv. Bei den Betriebssystemen Windows Vista und Windows 7 ist das aus Sicherheitsgründen nicht per Remote Transport erlaubt. Die Datei muss manuell registriert werden:

zendbsrv.exe -service

Tipp: Registrieren Sie auch gleich die Datei zensyssrv.exe als Dienst: zensyssrv.exe -service

info Info

Sobald die beiden Dateien als Dienste registriert wurden, kann unter Windows Vista/7 der Remote Transport nicht mehr eingesetzt werden, also auch die Runtime nicht per Remote Transport gestartet werden.


Anlegen eines neuen mehrplatzfähigen Projekts

Handbuch -> Verteiltes Engineering -> Anlegen eines neuen mehrplatzfähigen Projekts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Anlegen eines neuen Projekts muss die Checkbox Mehrplatzfähiges Projekt aktiviert werden. Im Feld Projektserver wird der Server für das mehrplatzfähige Projekt angegeben oder selektiert. Wird ein Server angegeben, ist die Checkbox Mehrplatzfähiges Projekt automatisch aktiviert.

Wenn im Feld Projektserver kein Eintrag vorgenommen wird, wird das Projekt und damit die Serverdatenbank am lokalen PC angelegt. Automatisch wird auch eine lokale Projektkopie erstellt, mit welcher dann direkt im Editor gearbeitet werden kann.

Voraussetzungen:

  • Projekt-Datenbankserver (zendbsrv.exe): muss auf dem Server und auf dem Client Rechner gestartet sein
  • Firewall-Einstellungen:
    • die Programme zendbsrv.exe und sqlservr.exe müssen freigeschalten sein
    • SQL Browser muss auf Server- und Client-Seite freigeschalten sein
  • Nötige offene Ports:
    • 1103
    • 1433 für SQL Server: dieser Port kann sich ändern, daher muss der SQL Server Prozess komplett aus der Firewall ausgenommen werden
    • 1434 für SQL-Browser
  • Die Namensauflösung im Netzwerk muss funktionieren
  • Reverse-Lookup muss am Server und am Client Rechner den gleichen Rechnername zurückliefern

attention Achtung

Arbeitsbereiche sind nicht mehrplatzfähig, weil sie arbeitsplatzbezogen sind. Daher kann die Projekthierarchie auf verschiedenen Rechnern unterschiedlich konfiguriert werden. Damit die Hierarchie auf allen Rechnern gleich aufgebaut wird, ist die direkte Kommunikation zwischen den verschiedenen Benutzer notwendig.

Anlegen eines Clients für ein mehrplatzfähiges Projekt

Führen Sie folgende Schritte aus, um einen Client für ein mehrplatzfähiges Projekt anzulegen:

  1. Selektieren Sie Datei -> Bestehendes Projekt einfügen...
  2. Im folgenden Dialog selektieren Sie unter Rechnername den des Server-DB. Unter Projektauswahl selektieren Sie wieder den Rechnernamen und den Servernamen (DB)
  3. Selektieren Sie mehrplatzfähiges Projekt


Einzelplatzprojekt in Mehrplatzfähiges Projekt konvertieren

Handbuch -> Verteiltes Engineering -> Einzelplatzprojekt in Mehrplatzfähiges Projekt konvertieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Einzelplatzprojekt in ein Mehrplatzfähiges Projekt zu konvertieren:

  1. Stellen Sie sicher, dass das Globalprojekt mehrplatzfähig ist.
    Sollte es das nicht der Fall sein, entfernen Sie das vorhandene Globalprojekt aus dem Arbeitsbereich und erstellen Sie ein neues mehrplatzfähiges Globalprojekt über das Kontextmenü des Arbeitsbereichs: Projekt neu
  2. Konvertieren Sie dann das Einzelplatzprojekt: wählen Sie im Kontextmenü den Befehl Mehrplatz -> In Mehrplatzfähiges Projekt konvertieren
  3. Sie erhalten eine Warnung, dass dieser Schritt nicht rückgängig gemacht werden kann.
    Allerdings kann ein Mehrplatzfähiges Projekt über eine Projektsicherung als Einzelplatzprojekt neu erstellt werden.
  4. Bestätigen Sie die Warnung mit Klick auf die Schaltfläche Ja.

info Info

Bei der Konvertierung wird der Rechner, auf dem diese Aktion durchgeführt wird, als Datenbankserver für das Projekt definiert. Diese Eigenschaft kann später nicht mehr verändert werden.


Mehrplatzfähiges Projekt in Einzelplatzprojekt konvertieren

Handbuch -> Verteiltes Engineering -> Mehrplatzfähiges Projekt in Einzelplatzprojekt konvertieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Mehrplatzfähiges Projekt in ein Einzelplatzprojekt zu konvertieren:

  1. Sorgen Sie dafür, dass alle Projektänderungen von allen Clients übernommen wurden:
    • Projekt -> Kontextmenü -> Mehrplatz -> Synchronisieren
  2. Erstellen Sie eine Projektsicherung:
    • Knoten Projektsicherung -> Kontextmenü -> Sicherung erstellen
    • Vergeben Sie im Dialog Name und Beschreibung; Sie können auch eine lokale Projektkopie sichern.
  3. Erstellen Sie eine Rücksicherung des Projekts als neues Projekt:
    • Arbeitsbereich -> Kontextmenü -> Projektsicherung rücklesen.
    • Wählen Sie die gewünschte Projektsicherung.
    • Aktivieren Sie die Checkbox neues Projekt erzeugen.
    • Bestätigen Sie mit Klick auf OK.
    • Vergeben Sie einen neuen Projektnamen.
  4. Das Projekt wird als Einzelplatzprojekt erstellt.
    Das Mehrplatzfähige Projekt existiert parallel dazu weiter.

Hinweis: Um die lokale Projektkopie in ein Einzelplatzprojekt zu konvertieren kann im Editor beim Projekt auch die Option Projekt -> Speichern unter ... gewählt werden.


Umgang mit einem Mehrplatzfähigen Projekt

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mehrplatzfähige Projekte ermöglichen vielfältige Zugriffe auf Module. Beachten Sie beim Projektieren Mehrplatzfähiger Projekte vor allem:

  • das Vorgehen bei Änderungen ermöglichen und Änderungen übernehmen und deren Handhabung bei Änderungen in mehreren Modulen
  • Löschen von Elementen
  • Synchronisieren von Elementen
  • die Besonderheiten von VBA und RGM

Noch in diesem Kapitel

Projekt erweitern und Synchronisieren

Änderungen an bestehenden Elementen

Projekte löschen

Clientverbindung trennen

Backup Mechanismus

Änderungen ermöglichen, übernehmen und verwerfen

Löschen von Elementen

Synchronisation des Mehrplatzfähigen Projekts

Rezeptgruppen-Manager

VBA und VSTA

Beenden des Editors


Projekt erweitern und Synchronisieren

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Projekt erweitern und Synchronisieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn ein neues Element wie etwa eine Variable oder ein neues Bild angelegt wird, ist dieses Element zunächst nur lokal verfügbar und automatisch werden Änderungen am Element ermöglicht.

Werden die Änderungen übernommen, muss ein anderen Client synchronisieren, damit auch die geänderten Elemente auf seinem Rechner zur Verfügung stehen.

Wenn die Änderungen verworfen werden nachdem ein neues Element angelegt wurde, wäre es als ob es dieses Element nie gegeben hätte.

Der Unterschied zwischen einer neuen Variable und einem neuen Bild ist, dass die Variable auf anderen Rechnern nach einer Synchronisation nicht sichtbar ist, wenn die Änderungen noch nicht übernommen wurde. Ein Bild dagegen ist nach einer Synchronisation auf anderen Rechnern als in Bearbeitung sichtbar.

Siehe auch Kapitel Bilder / Abschnitt Schablonen-Editor

Nachdem ein anderer Benutzer Elemente hinzugefügt oder gelöscht hat, muss das Projekt synchronisiert werden um die Änderungen zu erhalten. Dies erfolgt im Kontextmenü des Projektes über den Eintrag Projekt/Synchronisieren.

Folgende Auswahlmöglichkeiten finden sich im Kontextmenü:

Befehl | Beschreibung
Mehrplatz/Synchronisieren | Das Projekt wird synchronisiert.
Mehrplatz/Offline Modus aktivieren | Der Offline-Modus wird eingeschaltet. Änderungen wirken sich nur lokal aus und werden nicht zentral übernommen, solange das Projekt offline ist.
Mehrplatz/Online Modus aktivieren | Der Online-Modus wird eingeschaltet. Wurden Elemente von anderen Benutzern mittlerweile bearbeitet und übernommen, überschreiben diese Änderungen aus dem Offline Modus.
Lokale Version aktualisieren | Die lokale Kopie wird mit der Server DB abgeglichen und aktualisiert. Das Projekt wird neu in den Editor geladen. Achtung: Ausgenommen sind jene Elemente/Module, die von diesem Benutzer ausgecheckt sind.

info Info

Jene Elemente die vom selben Benutzer ausgecheckt wurden, der die Synchronisation durchführt, werden durch die Synchronisation nicht überschrieben. Die lokalen Änderungen sind durch den Auscheck-Status gegen Überschreiben geschützt.

Ausnahme:
Benutzer A checkt Elemente offline aus. Benutzer B checkt Elemente online aus. Verbindet sich Benutzer A wieder mit dem Server, werden die Elemente, die von beiden Benutzern ausgecheckt sind, für Benutzer A mit den Daten von Benutzer B überschrieben. Sollte in einem Team ein Teammitglied auf Inbetriebnahme sein, empfehlen wir, in dieser Offline Phase das Projekt am Server nicht zu verändern!


Änderungen an bestehenden Elementen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Änderungen an bestehenden Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn eine Änderung an einem bestehenden Element vollzogen wird, muss der zu ändernde Teil ausgecheckt werden. Dies verhindert, dass mehrere Projektanten auf ein und dasselbe Element zugreifen können. Ein ausgechecktes Element ist für die Änderung durch andere Benutzer gesperrt.

Das Element kann nun von dem Benutzer verändert werden, der es ausgecheckt hat und somit die Änderungsrechte besitzt. Für alle anderen Benutzer ist dieses Element gesperrt.

Um an einem Element Änderungen vornehmen zu können, muss der Benutzer im Kontextmenü des Elementes den Eintrag Projekt/Änderungen ermöglichen auswählen. Es besteht die Möglichkeit, nur einzelne Elemente, z.B. eine Variable auszuchecken. Dazu wird in der Detailansicht der einzelnen Variable im Kontextmenü der Eintrag Änderungen ermöglichen aktiviert. Zudem ist es möglich, z.B. alle Variablen des Projektes auf einmal über den Hauptknoten auszuchecken.

Bei einem Mehrplatzfähigen Projekt wird der Projektbaum um den Eintrag in Bearbeitung erweitert. In der Detailansicht dieser Liste sind die ausgecheckten Elemente des aktuellen Projektes aufgelistet. Per Default werden die Spalten: Status, Element, Ziel und Modul angezeigt. Weitere Spalten lassen sich im Kontextmenü der Spaltenüberschrift mit Feldauswahl hinzufügen. Mit den zusätzlichen Spalten bietet die Liste eine Übersicht, welches Element gerade von welchem Benutzer auf welchem Rechner bearbeitet wird.

info Info

Im Umgang mit Intergrations- und Unterprojekten in der Mehrbenutzerumgebung, muss darauf geachtet werden, dass bei beiden Projekten Änderungen ermöglichen aktiviert ist, bevor das Unterprojekt unter das Integrations-Projekt gezogen wird.

Ein Element/Modul kann solange nur 'gelesen', aber nicht verändert werden, solange der Benutzer sich die Berechtigung dafür nicht geholt hat. Die Berechtigung kann über Änderungen ermöglichen im Kontextmenü des Elements erfolgen oder direkt beim Öffnen des Elements.


Projekte löschen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Projekte löschen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wird ein Projekt gelöscht, wird nur die lokale Projektkopie gelöscht. Die Server-DB bleibt weiterhin vorhanden und anderen Clients können damit weiter arbeiten. Es ist noch möglich, das Projekt wieder in den Arbeitsbereich einzufügen. Hier wird wieder eine neue lokale Projektkopie erstellt.

Löscht der Benutzer seine lokale Projektkopie, gehen alle Auscheck-Informationen, und damit auch eventuelle Änderungen, dieses Benutzers verloren.


Clientverbindung trennen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Clientverbindung trennen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Funktionionalität Clientverbindung Trennen ist es möglich, die lokale Projektkopie eines Benutzers von der Server DB zu trennen. Hiermit werden alle Auscheck-Informationen dieses Benutzers gelöscht. Änderungen an Elementen, die von diesem Benutzer gesperrt wurden, sind somit wieder möglich.

Eine Clientverbindung zu trennen kann dann notwenig sein, wenn ein Benutzer nicht im Haus ist und Elemente ausgecheckt hat, die dringend bearbeitet werden müssen oder der Rechner dieses Benutzers defekt ist.

attention Achtung

Wenn die Clientverbindung eines Benutzers getrennt wurde, und der Benutzer die lokale Projektkopie danach öffnet ist das Projekt Offline. Ein Online gehen ist danach nicht mehr möglich. Die lokale Projektkopie muss zuerst gelöscht werden und vom Server wieder eingefügt werden.

Voraussetzung:

Eine Clientverbindung kann nur dann getrennt werden, wenn der Rechner wo die lokale Projektkopie bearbeitet wurde, nicht erreichbar ist.

Über das Hauptmenü Datei -> Bestehenedes Projekt einfügen öffnet man den Projekt Database Manager. Unter dem Multi-User Projekt findet man unter verbundene lokale Projektkopien alle Benutzer, die eine lokale Projektkopie in Bearbeitung (gehabt) haben.

Mittels Trennen wird der Eintrag für diesen Benutzer aus der Server DB gelöscht. Nachdem die Cientverbindung getrennt wurde, kann der Dialog verlassen werden.

attention Achtung

Diese Aktion kann nicht mehr rückgängig gemacht werden! Falls der Benutzer auf diesem Rechner wieder Zugriff zum Multi-User Projekt gelangen möchte, muss die lokale Projektkopie gelöscht und wieder neu eingefügt werden.


Backup Mechanismus

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Backup Mechanismus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

info Info

Lokale Projektstände können gesichert werden. Solange noch nicht synchronisiert wurde, ist ein Rücksichern möglich.

Noch in diesem Kapitel

Projektsicherung

Projektsicherung rücklesen


Projektsicherung

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Backup Mechanismus -> Projektsicherung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Projektsicherung wird im Projektmanager im Knoten Projektsicherungen angestoßen.

Noch in diesem Kapitel

Projektsicherung von lokalen Projektständen

Projektsicherung von Serverprojekten


Projektsicherung von lokalen Projektständen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Backup Mechanismus -> Projektsicherung -> Projektsicherung von lokalen Projektständen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Eine Projektsicherung kann über das Kontextmenü des Moduls Projektsicherungen erstellt werden. Um eine lokale Projektsicherung zu erstellen, muss in der Dialogbox Projektsicherung erstellen die Checkbox lokale Projektkopie sichern aktiviert sein.

Lokale Projektsicherungen können nur innerhalb derselben offline Session der Sicherung durchgeführt werden.

seealso Siehe auch

Projektsicherung rücklesen von Serverprojekten


Projektsicherung von Serverprojekten

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Backup Mechanismus -> Projektsicherung -> Projektsicherung von Serverprojekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Sicherung von Serverprojekten ist von jedem Client aus anstossbar, wenn die Checkbox lokale Projektkopie sichern nicht aktiviert wurde.


Projektsicherung rücklesen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Backup Mechanismus -> Projektsicherung rücklesen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

seealso Siehe auch

Projektsicherung von lokalen Projektständen

Noch in diesem Kapitel

Projektsicherung rücklesen von lokalen Projektständen


Projektsicherung rücklesen von lokalen Projektständen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Backup Mechanismus -> Projektsicherung rücklesen -> Projektsicherung rücklesen von lokalen Projektständen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

attention Achtung

Ein Rücksichern einer lokalen Projektkopie ist nur möglich, solange noch keine Synchronisation durchgeführt wurde.
Wurde ein Projekt seit der Sicherung synchronisiert, hat der Benutzer die Möglichkeit der 'Sicherung als neues Projekt rücklesen'. Dabei wird ein Projekt als Single User Projekt rückgesichert.


Änderungen ermöglichen, übernehmen und verwerfen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Änderungen ermöglichen, übernehmen und verwerfen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Änderungen an einem Projekt vornehmen zu können, müssen die entsprechenden Elemente (Funktionen, Variablen, Bilder, ...) zur Änderung frei gegeben werden (Änderungen ermöglichen). Nach der Bearbeitung müssen die Elemente wieder für Änderungen gesperrt und zum Server übertragen werden (Änderungen übernehmen).

Hinweis: Neue und gelöschte Elemente werden immer erst bei der nächsten Synchronisierung übertragen. Wird also ein Element gelöscht, so kann es auf anderen Rechnern noch bearbeitet werden, wird allerdings nach der Synchronisierung endgültig gelöscht.

Parameter

Beschreibung

Lokale Version aktualisieren

Wurden durch andere Benutzer Änderungen am Serverprojekt vorgenommen, kann die lokale Projektkopie über diesen Menüpunkt aktualisiert werden.

Nur einzelne bestehende Elemente/Module werden aktualisiert. Neue Elemente am Server sind hierdurch allerdings nicht verfügbar, dafür ist ein Synchronisieren erforderlich.

Änderungen ermöglichen

Um Änderungen an Elementen vornehmen zu können, muss für diese der Status 'Änderungen ermöglichen' gesetzt werden. Dies kann durch das Kontextmenü des markierten Elements erreicht werden.
Um ein beschleunigtes Arbeiten zu ermöglichen, können bei Variablen Änderungen für das gesamte Modul ermöglicht werden. Das heißt, alle Variablen, Treiber und Datentypen sind für alle anderen Benutzer gesperrt.

Änderungen übernehmen

Die Änderungen werden in das Serverprojekt übertragen und übernommen. Die Elemente/Module werden für andere Benutzer wieder freigegeben.
Wurden Änderungen über das Modul ermöglicht, können diese auch nur über das Modul übernommen werden.
Das heißt, alle Variablen, Treiber und Datentypen werden übertragen und für andere Benutzer freigegeben. Das Übernehmen eines einzelnen Elements ist in diesem Fall nicht möglich.
Die in der lokalen Projektkopie durchgeführten Änderungen werden verworfen und durch den Serverstand überschrieben. Die Elemente/Module werden für andere Benutzer wieder freigegeben.

Änderungen verwerfen

Alle Variablen, Treiber und Datentypen werden verworfen und für andere Benutzer freigegeben. Das Verwerfen eines einzelnen Elements ist in diesem Fall nicht möglich.

info Info

Bei Änderungen des Projektnamens ist ein Änderungen verwerfen unmöglich. Der geänderte Projektname bleibt bestehen.

Änderungen an mehreren Modulen gleichzeitig

Wird ein Modul für Änderungen frei gegeben und werden Elemente anderer Module neu erstellt und mit diesem Modul verknüpft, dann müssen alle betroffenen Elemente/Module gleichzeitig auf Änderungen übernehmen gesetzt werden. Geben Sie zuerst die neu erstellten Elemente/Module frei und dann die bereits bestehenden. Wird nur das ursprünglich gesperrte Modul wieder frei gegeben, können neue Projektierungen verloren gehen.

Beispiel:

  • Auf einem Client ist der RGM ausgecheckt.
  • Eine neue Rezeptgruppe wird erstellt, dann ein neues Rezept.
  • Eine existierende Variable wird zur Rezeptgruppe hinzugefügt.
  • Drei neue Variablen werden erstellt und hinzugefügt.
  • Verriegelungen werden ausgecheckt und eine neue Verriegelung wird erstellt.
  • Ein neues Keyboard-Bild wird mit einer neuen Schablone erstellt.
  • In der Rezeptgruppe wird die neue erstellte Verriegelung zugewiesen.
  • Das Keyboard-Bild wird zugewiesen.
  • Eine neue Variable für Sichtbarkeit erstellt und mit einer Variablen der Rezeptgruppe verknüpft.

Wenn nur die Rezeptgruppe auf Änderungen übernehmen gesetzt wird und ein anderer Client synchronisiert, dann:

  • erhält der andere Client:
    • eine Rezeptgruppe mit einer verknüpften Variablen
    • und einem Rezept, das diese Variable enthält
  • alle anderen Informationen gehen verloren

Wenn dieser Client die Rezeptgruppe sperrt, bearbeitet und wieder frei gibt, sind alle neu projektierten Informationen verloren.

Für korrekte Übernahme mus das Änderungen übernehmen erfolgen für:

  • RGM
  • Rezeptgruppe
  • Rezept
  • Variablen
  • Verriegelungen
  • Keyboard-Bild
  • Schablone für Keyboard-Bild

Noch in diesem Kapitel

Status der Elemente und Module

Legende des Symbole


Status der Elemente und Module

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Änderungen ermöglichen, übernehmen und verwerfen -> Status der Elemente und Module

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wurde ein Element ausgecheckt ändert sich das Symbol im Projektbaum bzw. in der Detailansicht. Der Benutzer, der das Element ausgecheckt hat, hat neben dem Symbol eine Checkbox mit grünem Haken. Alle anderen eine Checkbox mit rotem X. Ein ! bedeutet, dass innerhalb des Knotens einzelne Elemente ausgecheckt sind.

Siehe Abschnitt Legende.

Im Spezialfall der Variablenverwaltung werden die Symbole leicht transparent dargestellt, wenn über das Modul ausgecheckt wurde.

Example Beispiel

Alle Variablen sind von einem Benutzer ausgecheckt. Ein anderer Benutzer kann diese Variablen nicht ändern, er kann aber eine weiter Variable hinzufügen.

Ausnahme: Modul Checkout

Folgende Aktionen sind nur möglich, wenn das gesamte Modul auf Änderungen ermöglichen gesetzt wird:

  • anlegen von Array-Variablen
  • anlegen von Struktur-datentypen
  • kopieren oder einfügen von Array- und Strukturvariablen
  • erstellen von Variablen basierend auf einem Struktur-Datentyp mit Array
  • ändern von Array-Einstellungen einer Variablen
  • ändern von Array-Einstellungen in zenon Logic von einer Variablen mit zenon Logic-Profil

info Info

Wird eine Variable angelegt, ohne dass das komplette Modul Variablen auf Änderungen ermöglichen gesetzt wurde, dann werden die Dimensionen automatisch auf 0 gesetzt. Damit wird verhindert, dass ungewollt eine Strukturvariable erzeugt wird.

Folgende Elemente/Module können nur gesamt auf Änderungen ermöglichen oder Änderungen übernehmen gesetzt werden:

  • Archive
  • Benutzer
  • Menüs
  • Reaktionsmatrix
  • Rezepte Standard
  • Rezeptgruppen
  • Skripte
  • Schriften
  • Verriegelungen
  • Zuweisungen

Anzeige Änderungsdatum im Detail-Fenster

Im Detail-Fenster stehen zwei Spalten mit Informationen zum letzten Änderungszeitpunkt zur Verfügung:

  • Letzte Änderung übernommen: Zeigt bei alle Listen, deren Inhalte Verteiltes Engineering betreffen,den Zeitpunkt des letzten Updates in der Datenbank oder des letzte Eincheckens an.
  • Zuletzt geändert: Zeigt Zeitstempel der letzten Änderung der Datei im Dateisystem.

Wenn die Spalten nicht angezeigt werden, können Sie aktiviert werden über:

  1. führen Sie einen Rechtsklick in den Spaltenkopf aus
  2. wählen Sie im Kontextmenü den Befehl Spaltenauswahl
    (Welche Spalten zur Verfügung stehen, hängt vom Modul ab.)
  3. wählen Sie die gewünschten Spalten in der linken Auswahlliste hinzu (Multiselekt ist möglich)
  4. fügen Sie die Spalten per Klick auf die Schaltfläche Hinzufügen-> zur rechten Liste hinzu
  5. wählen Sie über die Schaltlfäche Nach oben oder Nach unten die jeweils gewünschte Position
  6. bestätigen und schließen Sie den Dialog mit Klick auf OK


Legende des Symbole

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Änderungen ermöglichen, übernehmen und verwerfen -> Legende des Symbole

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die folgenden Symbole stellen die Zustände der Element im Verteilten Engineering dar.

(z.B.: Ein Bild kann durch den Benutzer geändert werden [image])

Elemente der Detailansicht des Projektmanagers:

Symbol | Beschreibung
 | Neues Element wurde in der lokalen Projektkopie eingefügt. Dieses wird erst beim Check-In des Elements am Server übertragen.
 | Neues Modul wurde in der lokalen Projektkopie eingefügt. Dieses wird erst beim CheckIn des Moduls am Server übertragen.
 | Element wurde in der lokalen Projektkopie als gelöscht markiert. Dieses wird erst beim CheckIn des Elements am Server gelöscht.
 | Modul wurde in der lokalen Projektkopie als gelöscht markiert. Dieses wird erst beim CheckIn des Moduls am Server gelöscht.
 | Element kann vom aktuellen Benutzer bearbeitet werden.
 | Modul kann vom aktuellen Benutzer bearbeitet werden.
 | Element ist durch einen anderen Benutzer gesperrt.

Anzeige im Projektbaum:

Symbol | Beschreibung
 | Modul kann vom aktuellen Benutzer bearbeitet werden.
 | Modul wird durch einen anderen Benutzer bearbeitet und ist für den aktuellen Benutzer gesperrt.
 | Mindestens ein Element des Moduls ist zur Bearbeitung markiert (nicht das gesamte Modul).


Löschen von Elementen

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Löschen von Elementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Datenbankelemente werden zunächst nur als gelöscht markiert. Auf anderen Clients können an diesen Elementen keine Änderungen mehr vorgenommen werden, sie werden als gesperrt gekennzeichnet. Werden Änderungen übernommen, werden die Elementen definitiv gelöscht. Ebenfalls ist es möglich, die Löschaktion rückgängig zu machen mittels Änderungen verwerfen.

Example Beispiel

Die gilt beispielsweise für Variablen: Die Änderungen müssen zunächst übernommen werden, um ein definitives Löschen zu ermöglichen.

Dateielemente wie Bilder, Dateien (Sprachtabellen, Grafiken) usw. werden nach einer Bestätigung ab ausführenden Rechner sofort gelöscht. Neue und gelöschte Elemente werden immer erst bei der nächsten Synchronisierung übertrage. Wird also ein Element gelöscht, so kann es auf anderen Rechnern noch bearbeitet werden, wird allerdings nach der Synchronisierung endgültig gelöscht.


Synchronisation des Mehrplatzfähigen Projekts

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Synchronisation des Mehrplatzfähigen Projekts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nachdem ein anderer Benutzer Elemente hinzugefügt oder gelöscht hat, muss das Projekt synchronisiert werden um die Änderungen zu erhalten. Dies erfolgt im Kontextmenü des Projektes über den Eintrag Projekt -> Kontextmenü -> Mehrplatz -> Synchronisieren oder Alle Module/lokale Version aktualisieren.

Folgende Auswahlmöglichkeiten finden sich im Kontextmenü:

Parameter

Beschreibung

Synchronisieren

Die lokale Kopie wird mit der Server DB abgeglichen und aktualisiert. Das Projekt wird neu in den Editor geladen.
Achtung: Ausgenommen sind jene Elemente/Module, die von diesem Benutzer ausgecheckt sind.

Lokale Version aktualisieren

Siehe Synchronisieren

Änderungen ermöglichen

Checkt Elemente/Module aus

Änderungen übernehmen

Checkt Elemente/Module ein

Änderungen verwerfen

Die Änderungen des Elements werden nicht übernommen, sondern verworfen. Nach dem Änderungen verwerfen wird der Projektstand aus der Server DB erneut übernommen.

Achtung: Bei Änderungen verwerfen für ein noch nicht übernommenes Element, werden Änderungen die von diesem Element abhängen ebenfalls verworfen.

Neue und gelöschte Elemente werden immer erst bei der nächsten Synchronisierung übertrage.

info Info

Die Elemente/Module die vom selben Benutzer ausgecheckt sind, der die Synchronisation durchführt, werden bei der Synchronisation nicht berücksichtigt.


Rezeptgruppen-Manager

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Rezeptgruppen-Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit der Rezeptgruppen-Manager unter Windows CE einsetzbar ist, müssen die Daten des RGM in einer alternativen Ablage zur MS Access Datenbank abgelegt werden. Für Windows CE werden die Daten binär in einer Dateistruktur abgelegt.

Wenn Sie unter Projekteigenschaften -> Allgemein die Checkbox Windows CE Projekt aktivieren, werden die Daten des RGM automatisch binär angelegt.
Sie können die binäre Speicherung der Daten auch unabhängig von CE-Projekten manuell einstellen über:
Eigenschaften Rezeptgruppen -> Rezeptgruppen Manager -> RGM Datenablage -> binäre Dateien CE kompatibel).

Interne ID: Rezeptgruppen-Manager

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Rezeptgruppen-Manager

Rezeptgruppen Manager

Definieren Sie die Dateiablage für den Rezeptgruppen-Manager.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Rezeptgruppen-Manager

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Rezeptgruppen-Manager

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Eine Konvertierung der MS Access Datenbank nach binär oder umgekehrt ist nicht vorgesehen.

Bereits existierende RGM-Daten werden nicht konvertiert! Sie müssen bei Bedarf die Daten vor der Umstellung in XML exportieren. Im Anschluss können Sie das Projekt umstellen und die Daten in die neue Datenablage importieren.

Wechsel der Datenbank

Wurde beim RGM in der Eigenschaft RGM Datenablage als Datenbank MS ACCESS DB gewählt und wird dann die Checkbox Windows CE Projekt aktiviert, wird ein Hinweis zur Konvertierung aufgeschaltet:

Um die Daten der bisherigen Datenbank zu erhalten:

  1. exportieren Sie die Daten nach XML
  2. stellen Sie Datenbank um
  3. importieren Sie die XML-Datei

Filterdialog zur Runtime

Wird bei den Optionen der Rezeptwerttabelle in der Bildumschaltung die Eigenschaft Dialog zur Runtime anbieten aktiviert, stehen unter Windows CE nur eingeschränkte Optionen zur Verfügung:

  • Rezeptfilter
  • Spalteneinstellungen (für Rezepttabelle)

Rezeptauswahl, Anlagenmodellierung und Spalteneinstellungen für Rezeptliste werden nicht angeboten.

Mehrbenutzer-Projekte

In Mehrbenutzerprojekten können binäre Dateien und MS Access Datenbank unabhängig von einander ausgecheckt werden.

Im Fenster In Bearbeitung wird lokal immer nur der Status der auf diesem Rechner eingestellten Speicherart dargestellt. Werden Binärdateien verwendet, ist nicht ersichtlich, dass die Access Datenbank noch ausgechecked ist.

Damit ist folgendes Szenario möglich:

  • auf PC A ist die Access Datenbank ausgechecked
  • auf PC B wird CE-Projekt aktiviert und damit auf Binärdateien umgestellt
  • auf PC B werden die Binärdateien ausgechecked
  • auf PC B werden die Änderungen übernommen und dann mit PC A synchronisiert
  • damit wird auch auf PC A auf Binärdateien umgestellt
  • die Access Datenbank auf PC A bleibt damit weiter ausgechecked
  • erst wenn PC B wieder auf Access Datenbank umstellt, wird ersichtlich, dass auch auf PC A die Access Datenbank ausgechecked ist


VBA und VSTA

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> VBA und VSTA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Projektbaum im Kontextmenü von Programmierschnittstellen den Eintrag VBA Editor öffnen bzw. VSTA Editor öffnen wählen, dann wird der Editor ausgecheckt und Änderungen sind möglich.

Achtung: In VBA sind Änderungen generell möglich, auch wenn das Element auf einem anderen Rechner auf Änderungen ermöglichen gesetzt wurde.,
Daher beachten Sie bei Änderungen über VBA:

  1. bevor Sie Änderungen vornehmen: überprüfen Sie, ob es sich um ein Mehrplatzfähiges Projekt handelt
  2. wenn ja: überprüfen Sie, ob das Element von einem anderen Client hinzugefügt wird
  3. wenn ja: überprüfen Sie, ob das Element lokal den Status Änderungen ermöglichen (check out) hat
    1. wenn ja: das Objekt kann geändert werden,
    2. wenn nein: das Objekt muss auf Änderungen ermöglichen gesetzte werden
    • überprüfen Sie erneut, ob das Objekt den Status Änderungen ermöglichen hat
    • wenn ja: das Objekt kann in VBA geändert werden
  4. nach den Änderungen muss das Objekt über VBA wieder auf den Status Änderungen übernehmen (check in) gesetzt werden

attention Achtung

Bei der Mehrprojektverwaltung darf der VBA Editor nicht mit Alt+F11 geöffnet werden, da er sonst nicht ausgecheckt wird. Wird VBA nicht ausgecheckt, werden die Änderungen nicht übernommen. Es erfolgt eine Warnung beim Aufrufen des VBA Editors, welche Projekte das betrifft.


Beenden des Editors

Handbuch -> Verteiltes Engineering -> Umgang mit einem Mehrplatzfähigen Projekt -> Beenden des Editors

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Jeder Benutzer sollte die Änderungen an seinen Objekten übernehmen, bevor er den Editor, das Projekt oder den Arbeitsbereich schließt. Solange dies nicht geschehen ist, können andere Benutzer an diesen Objekten keine Änderungen durchführen. Siehe auch Kapitel Editor/Abschnitt: Editor beenden.

Erfolgt ein Schließen, ohne dass die Änderungen übernommen wurden, wird ein Dialog zum Übernehmen oder Ablehnen der Änderungen aufgeschaltet:

Parameter | Beschreibung
Listenfeld Elemente | Listet alle zur Bearbeitung gesperrten Elemente auf. Änderungen für die angezeigten Elemente könne über die entsprechenden Schaltflächen übernommen oder verworfen werden.
Änderungen übernehmen | Für alle angezeigten Elemente werden die Änderungen übernommen.
Änderungen verwerfen | Für alle angezeigten Elemente werden die Änderungen verworfen.
Bearbeiten... | Der Beenden-Vorgang wird abgebrochen.
Weiter | Setzt den Beenden-Vorgang für das aktuelle Projekt im Arbeitsbereich fort. Die Elemente bleiben für andere Benutzer gesperrt. Sind mehrere Mehrplatzfähige Projekte zu schließen, wird im Anschluss dieser Dialog für das nächste zu schließende Projekte angeboten.
Weiter alle | Setzt den Beenden Vorgang für alle noch zu schließenden Mehrplatzfähige Projekte im Arbeitsbereich fort. Die Elemente bleiben für andere Benutzer gesperrt.
Hilfe | Öffnet die Online-Hilfe.


Offline arbeiten

Handbuch -> Verteiltes Engineering -> Offline arbeiten

Beim Offline arbeiten, besteht keine Verbindung zum Server, z.B. wenn ein Projektant sein Projekt am Laptop mit zum Kunden nimmt.

Um ein Projekt offline zu schalten muss im Kontextmenü des Projektes der Eintrag 'Offline Modus aktuvieren' gewählt werden. Projekte, die keine Verindung zum DB-Server haben, werden automatisch offline aktiviert.

info Info

Im Offline Betrieb ist kein Änderungen übernehmen und Änderungen verwerfen möglich!

Im Offline Betrieb ist nur ein Änderungen ermöglichen durchführbar, sonst wären im Offline Betrieb keine Änderungen möglich. Erst im Online Betrieb können wieder Änderungen übernommen werden.

Noch in diesem Kapitel

Offline schalten

Von Offline zu Online

Möglichkeiten im Offline Betrieb


Offline schalten

Handbuch -> Verteiltes Engineering -> Offline arbeiten -> Offline schalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es kann unter verschiedenen Umständen Offline gegangen werden, die im Einzelnen beleuchtet werden.

Noch in diesem Kapitel

Elemente/Module sind durch einen anderen Benutzer gesperrt

Elemente/Module sind vom selben User beim Offline-Schalten ausgecheckt

Es sind keine Elemente/Module beim Offline-Schalten ausgecheckt


Elemente/Module sind durch einen anderen Benutzer gesperrt

Handbuch -> Verteiltes Engineering -> Offline arbeiten -> Offline schalten -> Elemente/Module sind durch einen anderen Benutzer gesperrt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zum Zeitpunkt des Offline-Schaltens ändert bereits ein anderer Benutzer das Element/Modul. In diesem Fall können Offline keine Änderungen gemacht werden.


Elemente/Module sind vom selben User beim Offline-Schalten ausgecheckt

Handbuch -> Verteiltes Engineering -> Offline arbeiten -> Offline schalten -> Elemente/Module sind vom selben User beim Offline-Schalten ausgecheckt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zum Zeitpunkt des Offline-Schaltens ändert derselben Benutzer bereits das Element/Modul. In diesem Fall sind keine Online-Änderungen von anderen Benutzern möglich.


Es sind keine Elemente/Module beim Offline-Schalten ausgecheckt

Handbuch -> Verteiltes Engineering -> Offline arbeiten -> Offline schalten -> Es sind keine Elemente/Module beim Offline-Schalten ausgecheckt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zum Zeitpunkt des Offline-Schaltens werden gerade keine Elemente/Module geändert.

Variante 1:

Offline werden Änderungen bei einem Element/Modul ermöglicht, dasselbe passiert aber auch online.

Benutzer A macht offline Änderungen an einem Element/Modul, Benutzer B online.

Beim Online-Schalten durch Benutzer A wird erkannt das Benutzer B das Modul/Element gerade online bearbeitet.

Änderungen von Benutzer A gehen verloren.

attention Achtung

In diesem Fall gehen die offline gemachten Änderungen (Von Benuzter A) verloren!

Variante 2:

Als Benutzer A seine Änderungen übernehmen lässt, hat Benutzer B seine Änderungen bereits übernommen.

Die Änderungen von Benutzer A überschreiben beim Online-Schalten die Änderungen von Benutzer B.

attention Achtung

In diesem Fall werden die Online gemachten Änderungen (von Benutzer B) überschrieben!


Von Offline zu Online

Handbuch -> Verteiltes Engineering -> Offline arbeiten -> Von Offline zu Online

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Offline-Projekt wieder online zu schalten, muss im Kontextmenü von Projekt der Eintrag Projekt/online gewählt werden. Das Projekt wird sofort synchronisiert und neu in den Editor geladen.


Möglichkeiten im Offline Betrieb

Handbuch -> Verteiltes Engineering -> Offline arbeiten -> Möglichkeiten im Offline Betrieb

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Elemente/Module

Neu anlegen, ändern, umbenennen und löschen


Weltbild

Handbuch -> Weltbild

Mit dem Weltbild können Bilder, die größer als die zugrunde liegende Schablone sind, angezeigt und gesteuert werden. Damit ist es möglich, sehr große Anlagen komplett darzustellen und darin zu navigieren. Im Weltbild kann auf Anlagenteile gezoomt werden. Abhängig von den Zoomstufen kann definiert werden, welche Details angezeigt werden (zooming, panning und deculuttering). Elemente können auch direkt angesprungen werden.

info Info

Einige Elemente, wie z.B. Combo-/Listbox, Alarmmeldeliste, Diagramm des Erweiterten Trends usw., lassen sich nicht zoomen. Die Größe dieser Elemente bleibt konstant, allerdings ändert sich die Position.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Noch in diesem Kapitel

Projektieren im Editor

Funktion Bildumschaltung auf Weltbild-Übersicht

Bedienen zur Runtime


Projektieren im Editor

Handbuch -> Weltbild -> Projektieren im Editor

Um ein Weltbild zu verwenden, benötigen Sie:

  1. ein Bild, das die Größe seiner Schablone übersteigt; dieses ist das Weltbild
  2. ein Bild vom Typ Weltbild-Übersicht; dieses dient zur Navigation im Weltbild und wirkt auf die Schablone des Weltbilds

Hinweis: Diese beiden Bilder müssen auf unterschiedlichen Schablonen basieren.

Beim Aufrufen des Bildes vom Typ Weltbild-Übersicht definieren Sie, welche Schablone von diesem Bild gesteuert werden soll.

Tipps:

  • Benutzen Sie das Weltbild nicht als Startbild.
  • Starten Sie das Weltbild und die Weltbild-Übersicht gemeinsam mit einem Skript.

info Info

Bei Navigation mit Multitouch-Gesten ist kein Bild vom Typ-Weltbild-Übersicht nötig. Mit Multitouch kann direkt im Weltbild navigiert werden.

Bildelemente

Die Sichtbarkeit von Dynamischen Elementen und Vektorelementen sowie deren Namen für Objektlisten werden in den Eigenschaften des jeweiligen Objekts definiert: Runtime/Weltbilddarstellung/...

Interne ID: Projektieren im Editor

Weltbilddarstellung

Eigenschaften zum Verhalten des Elements in der Weltbilddarstellung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Projektieren im Editor

Runtime

Eigenschaften für das Runtime-Verhalten des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Weltbild anlegen

Bild vom Typ Weltbild-Übersicht anlegen

Zoomstufen

Objekte


Weltbild anlegen

Handbuch -> Weltbild -> Projektieren im Editor -> Weltbild anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Weltbild anzulegen:

  1. legen Sie ein neues Bild an
  2. navigieren Sie zur Eigenschaften-Gruppe Größe

    Interne ID: Weltbild anlegen

    Größe

    Eigenschaften für die Größe und die Position des Bildes, die aus der verknüpften Schablone übernommen werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. wählen Sie die Eigenschaft Größe aus Schablone

    Interne ID: Weltbild anlegen

    Größe aus Schablone

    Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
    Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
    Default: aktiv.

    Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. deaktivieren Sie diese Eigenschaft (Haken entfernen, falls vorhanden)
  5. wählen Sie für die Eigenschaften Breite [Pixel] und Höhe [Pixel] Werte, die die Größe der Schablone für dieses Bild übersteigen

    Interne ID: Weltbild anlegen

    Höhe [Pixel]

    Nur verfügbar, wenn die Eigenschaft Größe aus Schablone inaktiv ist.
    Höhe des Bildes in Pixel.

    Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Weltbild anlegen

    Breite [Pixel]

    Nur verfügbar, wenn die Eigenschaft Größe aus Schablone inaktiv ist.
    Breite des Bildes in Pixel.

    Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Maximalwerte: 32.000

  6. legen Sie eine Bildumschalt-Funktion für dieses Bild an


Bild vom Typ Weltbild-Übersicht anlegen

Handbuch -> Weltbild -> Projektieren im Editor -> Bild vom Typ Weltbild-Übersicht anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Bild vom Typ Weltbild-Übersicht anzulegen:

  1. erstellen Sie eine Schablone für das Bild
  2. achten Sie auf die geeignete Größe (Empfehlung: 550 x 350 Pixel)
  3. aktivieren Sie für die Schablone die Eigenschaften Immer im Vordergrund und Schließen bei Fokusverlust unterdrücken

    Interne ID: Bild vom Typ Weltbild-Übersicht anlegen

    Schließen bei Fokusverlust unterdrücken

    Aktiv: Bei Fokusverlust bleibt die Schablone geöffnet. Das Schließen einer anderen Schablone bei Fokusverlust wird unterdrückt, falls in dieser Schablone geklickt wurde. So können Bildschirmbereiche definiert werden, in denen das Klicken die mit Schließen bei Fokusverlust projektierten geöffneten Schablonen nicht schließt.

    Interne ID: Bild vom Typ Weltbild-Übersicht anlegen

    Schließen bei Fokusverlust

    Steuert das Verhalten der Schablone bei Fokusverlust.

    Aktiv: Bei einem Linksklick außerhalb der Schablone schließt sich diese automatisch, wenn in einen Bildschirmbereich geklickt wird, der zwar zur zenon Runtime aber weder zur Schablone selbst noch zu einer Schablone mit gesetzter Eigenschaft Schließen bei Fokusverlust unterdrücken gehört.

    Default: inaktiv

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Bild vom Typ Weltbild-Übersicht anlegen

    Immer im Vordergrund

    Aktiv: Kein anderes Bild überdeckt diesen Bereich im Onlinebetrieb. Bilder im Hintergrund können aber bedient werden.
    Inaktiv: Bilder dieser Schablone können von anderen Bildern überdeckt werden.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. legen Sie ein neues Bild an
  5. wählen Sie als Bildtyp Weltbild-Übersicht
  6. weisen Sie dem Bild die Schablone zu
  7. fügen Sie über das Menü Kontrollelemente die gewünschten Elemente zum Steuern des Weltbildes ein
  8. fügen Sie eine Funktion zum Schließen des Bildes vom Typ Weltbild-Navigation ein
  9. erstellen Sie eine Funktion zum Umschalten auf das Bild vom Typ Weltbild-Übersicht

Parameter | Beschreibung
Vorlage einfügen | Öffnet den Dialog zur Auswahl einer Vorlage für den Bildtyp. Vorlagen werden mit zenon mitgeliefert und können auch individuell selbst erstellt werden. Vorlagen fügen vordefinierte Kontrollelemente an vordefinierten Plätzen im Bild ein. Nicht benötigte Elemente können nach dem Anlegen auch einzeln entfernt werden. Zusätzliche Elemente werden aus der Dropdownliste ausgewählt und im Bild aufgezogen. Elemente können im Bild verschoben und individuell angeordnet werden.
Übersichtsbild (Schablone) | Anzeige des Bildes, das gesteuert wird.
Objektliste | Liste der direkt ansteuerbaren Objekte.
aktuelle Zoomstufe | Zeigt aktuelle Zoomstufe an.
Zoom min. | Schaltet Zoom aus, das Bild wird in Schablonengröße angezeigt.
Zoom max. | Maximale Zoomstufe.
Zoom Schieberegler | Schieberegler zum Einstellen der Zoomstufen.
+ (Vergrößern) | In das Bild zoomen.
- (Verkleinern) | Aus dem Bild zoomen.
nach links | Verschiebt den angezeigten Ausschnitt nach links.
nach rechts | Verschiebt den angezeigten Ausschnitt nach rechts.
nach oben | Verschiebt den angezeigten Ausschnitt nach oben.
nach unten | Verschiebt den angezeigten Ausschnitt nach unten.


Zoomstufen

Handbuch -> Weltbild -> Projektieren im Editor -> Zoomstufen

Zoomstufen definieren das Verhältnis von Schablonengröße zum angezeigten Bild. Die Anzeige erfolgt in Stufen, denen eine Prozentzahl zugewiesen wird. 100 % entspricht der Schablonengröße. Je größer der Ausschnitt, desto niedriger die Stufe.

Um Zoomstufen zu projektieren:

  1. navigieren Sie in den Projekteigenschaften zur Gruppe Grafische Ausprägung/Runtime allgemein

    Interne ID: Zoomstufen

    Runtime allgemein

    Enthält Einstellungen zur Runtime.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Zoomstufen

    Grafische Ausprägung

    Eigenschaften für die grafische Ausprägung der Runtime.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. klicken Sie bei der Eigenschaft Zoomstufen f. Weltbild auf die Schaltfläche ...

    Interne ID: Zoomstufen

    Zoomstufen f. Weltbild

    Der Dialog für die Definition der Zoomstufen für die Weltbild-Funktionalität wird geöffnet.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. der Dialog zur Konfiguration der Zoomstufen wird geöffnet

Parameter | Beschreibung
Vorhandene Zoomstufen | In dieser Liste werden die aktuell vorhandenen Zoomstufen angezeigt.
Neu... | Erzeugt eine neue Zoomstufe. Sie können den vorgeschlagenen Wert manuell anpassen. Der Wert muss zwischen 1 und 100 liegen.
Bearbeiten... | Öffnet für die markierte Stufe das Feld für den Prozentwert.
Löschen... | Löscht die selektierte Zoomstufe.

Minimale Zoomstufe

Die minimale Stufe ist auf das Verhältnis der Bildgröße zur Schablonengröße begrenzt.

Beispiel:

  • Es werden 10 Zoomstufen von 10% bis 100% projektiert.
  • Das Bild hat doppelte Schablonengröße.
    • Die Zoomstufen reichen bis 50%. Ab diesem Punkt wird immer die volle Bildgröße dargestellt.
  • Das Bild hat vierfache Schablonengröße.
    • Die Zoomstufen reichen bis 20 %.


Objekte

Handbuch -> Weltbild -> Projektieren im Editor -> Objekte

Jedes Element in einem Bild kann mit einem eindeutigen Namen versehen werden. Dieser Name kann auch zur Navigation in der Weltbild-Übersicht benutzt werden. Klick auf den Namen in der Objektliste verschiebt den angezeigten Ausschnitt bis das Element in der Mitte des Ausschnitts liegt.

Um Objekte zu definieren:

  1. klicken Sie auf das gewünschte Element
  2. navigieren Sie in den Eigenschaften zur Gruppe Runtime

    Interne ID: Objekte

    Runtime

    Eigenschaften für das Runtime-Verhalten des Elements.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. klicken Sie in die Eigenschaft Name für Objektliste

    Interne ID: Objekte

    Name für Objektliste

    Element wird in die Stationsliste des Weltbildes mit dem hier angegebenen Text eingetragen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. vergeben Sie einen Namen für das Objekt

Zur Runtime werden alle benannten Objekte in der Objektliste angezeigt.


Funktion Bildumschaltung auf Weltbild-Übersicht

Handbuch -> Weltbild -> Funktion Bildumschaltung auf Weltbild-Übersicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Aufruf eines Bildes vom Typ Weltbild-Übersicht zur Runtime wird festgelegt, welche Schablone vom Bild navigiert wird. Das zu steuernde Bild darf die Eigenschaft Größe aus Schablone nicht aktiviert haben und muss größer sein als die dazugehörige Schablone.

Interne ID: Funktion Bildumschaltung auf Weltbild-Übersicht

Größe aus Schablone

Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
Default: aktiv.

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Um eine Funktion Bildumschaltung auf ein Bild vom Typ Weltbild-Übersicht zu projektieren:

  1. erstellen Sie eine neue Funktion
  2. wählen Sie Bildumschaltung
  3. der Dialog zur Bildauswahl wird geöffnet
  4. wählen Sie das Bild vom Typ Weltbild-Übersicht
  5. der Dialog zur Konfiguration des Bildes wird geöffnet

Parameter | Beschreibung
Anzeigen des Übersichtsbildes für Schablone | Auswahl der Schablone, die gesteuert werden soll, aus Dropdownliste.
Rahmenfarben | Definiert Farbdarstellung zur Runtime:
Standard | Farbe des Rahmens, der den selektierten Bereich im Weltbild anzeigt. Klick auf Farbe öffnet Palette zur Auswahl.
Bei Auswahl mit Rechtsklick | Farbe des Rahmens, wenn der Ausschnitt mit der rechten Maustaste zum Verschieben angeklickt wird. Klick auf Farbe öffnet Palette zur Auswahl.
Einstellungen |
Rahmenbreite | Breite des Rahmens, der den selektierten Bereich im Weltbild anzeigt.
Übersichtsbild zyklisches aktualisieren | Aktiv: Dynamische Elemente im zugeordneten Bild werden in definierten Zeitabständen aktualisiert.
Sekunden | Zeit in Sekunden für zyklisches Update.
Selektiertes Objekt bei Auswahl hervorheben | Aktiv: Wird ein Objekt in der Objektliste angeklickt, wird das Objekt optisch hervorgehoben.
Zoom | Eigenschaften für Zoom.
Seitenverhältnisse beachten | Aktiv: Seitenverhältnisse werden beim Zoom beibehalten.
Seitliche Ziehpunkte deaktivieren | Aktiv: Die Anfasspunkte des Rahmens werden mit Ausnahme der Eckpunkte abgeschaltet und nicht mehr angezeigt.
Zoomen mit +/- Tasten in | Auswahl, wie mit den Tasten + und - gezoomt wird. Die Tasten müssen entsprechend zugewiesen werden.
% | Mit den zugewiesenen Tasten wird in Prozentstufen gezoomt. Eingabe eines Wertes zwischen 1 und 100. Default: 10
Zoomstufen | Mit den zugewiesenen Tasten wird in Zoomstufen gezoomt.
Verschiebung durch die Pfeiltasten in Pixeln | Angabe der Pixel, die ein Bild beim Verschieben mit den Pfeiltasten verschoben wird. Die Tasten müssen entsprechend zugewiesen werden. Eingabe eines Werts zwischen 1 und 16.000. Default: 100
OK | Übernimmt Angaben, schließt Dialog und öffnet Dialog zum Ersetzen von Verknüpfungen.
Abbruch | Verwirft alle Eingaben und schließt Dialog.
Hilfe | Öffnet die Online-Hilfe.

info Info

Änderungen der Eigenschaften im Editor wirken sich zur Runtime erst nach dem Neuaufschalten des Bildes vom Typ Weltbild-Übersicht aus.


Bedienen zur Runtime

Handbuch -> Weltbild -> Bedienen zur Runtime

Um zur Runtime in einem Weltbild navigieren zu können, benutzen Sie:

  • Bild vom Typ-Weltbild-Übersicht
    oder
  • Multitouch-Gesten am Touchscreen

Weltbild-Übersicht

  1. rufen Sie das Weltbild mit einer Bildumschaltfunktion auf
  2. rufen Sie das Bild vom Typ Weltbild-Übersicht mit einer Bildumschaltfunktion auf

Tipp: Benutzen Sie ein Skript, um immer beide Bildumschaltungen gemeinsam aufzurufen.

Mithilfe der Kontrollelementen, der Maus und der Tastatur können Sie im Weltbild navigieren und zoomen. Mehr dazu lesen Sie im Abschnitt Weltbild-Übersicht.

Multitouch

Aktivieren Sie die Eigenschaft Multitouch für Zoomen und Scrollen oder programmieren Sie entsprechende VBA/VSTA Events, um im Weltbild zu scrollen und zu zoomen. Mehr dazu lesen Sie im Abschnitt Navigation mit Multitouch im Weltbild.

Interne ID: Bedienen zur Runtime

Multitouch für Zoomen und Scrollen

Aktiv: Für Zoomen und Scrolling im Weltbild können Multitouch-Gesten verwendet werden, ohne dass diese in VSTA programmiert werden müssen. Ist diese Eigenschaft aktiv, werden keine VBA/VSTA Events für Multitouch-Gesten erzeugt.

Nur verfügbar, wenn die Eigenschaft Multitouch aktiv aktiviert wurde und Größe aus Schablone nicht aktiv ist.

Interne ID: Bedienen zur Runtime

Größe aus Schablone

Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
Default: aktiv.

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bedienen zur Runtime

Multitouch aktiv

Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Noch in diesem Kapitel

Weltbild-Übersicht

Navigation mit Multitouch im Weltbild


Weltbild-Übersicht

Handbuch -> Weltbild -> Bedienen zur Runtime -> Weltbild-Übersicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zur Runtime stehen in im Weltbild-Übersicht mehrere Möglichkeiten zur Verfügung, um Zoom-Größe und angezeigten Ausschnitt zu steuern:

  • Kontrollelemente
  • Maus und Touch
  • Tastatur

Die Kontrollelemente können auch per Touchscreen bedient werden. Die Berührpunkte für die Steuerung per Maus sind entsprechend dimensioniert, um auch problemlos mit Touch bedient zu werden.

Bei Verwendung von Multitouch-Gesten kann direkt im Weltbild navigiert werden und es ist kein Bild vom Typ Weltbild-Übersicht nötig.

Noch in diesem Kapitel

Navigation mit Kontrollelementen

Navigation mit der Maus

Navigation mit der Tastatur


Navigation mit Kontrollelementen

Handbuch -> Weltbild -> Bedienen zur Runtime -> Weltbild-Übersicht -> Navigation mit Kontrollelementen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter | Beschreibung
Zoom min. | Schaltet Zoom aus. Der Ausschnitt wird in der Größe der Schablone angezeigt.
Zoom max. | Maximale Zoomstufe.
+ | In das Bild zoomen.
- | Aus dem Bild zoomen.
Schieberegler | Schieberegler zum Einstellen der Zoomstufen.
Nach links | Verschiebt den angezeigten Ausschnitt nach links.
Nach rechts | Verschiebt den angezeigten Ausschnitt nach rechts.
Nach oben | Verschiebt den angezeigten Ausschnitt nach oben.
Nach unten | Verschiebt den angezeigten Ausschnitt nach unten.
Objektliste | Liste der direkt ansteuerbaren Objekte. Klick auf ein Objekt zentriert das Objekt im angezeigten Bildausschnitt.


Navigation mit der Maus

Handbuch -> Weltbild -> Bedienen zur Runtime -> Weltbild-Übersicht -> Navigation mit der Maus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Maus und Touchbedienung stehen Ihnen folgende Aktionen zur Verfügung:

  • Ausschnitt verschieben:

    Um den gezeigten Ausschnitt des Weltbilds zu verschieben , haben Sie mehrere Möglichkeiten:

    1. Klicken Sie in den Ausschnitt auf den Mittelpunkt und bewegen Sie bei gedrückter linker Maustaste die Maus über die Schablone.
    2. Drücken Sie die Leertaste und klicken Sie in das Weltbild: Die Form des Mauszeigers ändert sich zur Hand. Mit der Maus kann jetzt das Weltbild verschoben werden. Klicks mit der linken Maustaste werden im Weltbild nicht ausgewertet, wenn die Leertaste gedrückt ist.
    3. Klicken Sie mit der rechten Maustaste in den Ausschnitt und bewegen Sie die Maus bei gedrückter rechter Maustaste über die Schablone.
    4. Halten Sie das Mausrad gedrückt und bewegen Sie die Maus über die Schablone.
  • Zoomen:
    Klicken Sie in den Ausschnitt und drehen Sie das Mausrad, um zu zoomen. Gezoomt wird in den eingestellten Zoomstufen. Der Mauszeiger bleibt beim Zoomen über der gewählten Stelle im Bild.
  • Scrollen:
    Das Weltbild kann mit dem Mausrad gescrollt werden:
    • Vertikal: Klicken Sie ins Weltbild und drehen Sie das Mausrad.
    • Horizontal: Klicken Sie ins Weltbild, halten Sie die Taste Umschalt gedrückt und drehen Sie das Mausrad.


Navigation mit der Tastatur

Handbuch -> Weltbild -> Bedienen zur Runtime -> Weltbild-Übersicht -> Navigation mit der Tastatur

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können auch mit der Tastatur zoomen und verschieben. Dazu müssen den Kontrollelementen Tasten zugewiesen werden, zum Beispiel:

  • hoch -> Pfeiltaste nach oben
  • runter -> Pfeiltaste nach unten
  • links -> Pfeiltaste nach links
  • rechts -> Pfeiltaste nach rechts
  • + (Schieberegler) -> Taste +
  • - (Schieberegler) -> Taste -

Um eine Taste einem Kontrollelement zuzuweisen:

  1. markieren Sie das Kontrollelement
  2. navigieren Sie zur Eigenschaft Tastenkombination

    Interne ID: Navigation mit der Tastatur

    Tastenkombination

    Tastenkombinationen unterstützen das Ausführen bedienbarer Bildelemente. Zum Beispiel:

    - Ausführen von Kontrollelementen und Funktionen, die einem Element zugewiesenen wurden
    - Sollwert Absetzen (z. B. bei Schalter)
    - Fokus setzen bei bestimmten Fenstern (z.B. Kurvenliste im Erweiteren Trend oder Comboboxen im RGM)

    Klick auf Eingabefeld öffnet Dialog zur Definition der Tastenkombination. Im Dialog wird die gewünschte Kombination direkt eingegeben.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. klicken Sie auf die Schaltfläche ... oder in das Eingabefeld
  4. der Dialog zur Festlegung der Tastenkombination wird geöffnet
  5. klicken Sie in das Feld Tastenkombination
  6. drücken Sie auf der Tastatur die gewünschte Taste oder Tastenkombination, z.B.: +
  7. die Tastenkombination wird im Eingabefeld angezeigt
  8. schließen Sie den Dialog mit Klick auf OK


Navigation mit Multitouch im Weltbild

Handbuch -> Weltbild -> Bedienen zur Runtime -> Navigation mit Multitouch im Weltbild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Multitouch-Gesten für Zoomen und Scrollen eignen sich auf Touchpanels auch zur Navigation im Weltbild. Dazu ist kein Bild vom Typ Weltbild-Übersicht nötig. Um Multitouch-Gesten zur Navigation im Weltbild verwenden zu können, müssen diese:

  • entweder über die Eigenschaft Multitouch für Zoomen und Scrollen aktiviert

    Interne ID: Navigation mit Multitouch im Weltbild

    Multitouch für Zoomen und Scrollen

    Aktiv: Für Zoomen und Scrolling im Weltbild können Multitouch-Gesten verwendet werden, ohne dass diese in VSTA programmiert werden müssen. Ist diese Eigenschaft aktiv, werden keine VBA/VSTA Events für Multitouch-Gesten erzeugt.

    Nur verfügbar, wenn die Eigenschaft Multitouch aktiv aktiviert wurde und Größe aus Schablone nicht aktiv ist.

    Interne ID: Navigation mit Multitouch im Weltbild

    Größe aus Schablone

    Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
    Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
    Default: aktiv.

    Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Navigation mit Multitouch im Weltbild

    Multitouch aktiv

    Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
    Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Mehr in der Online-Hilfe.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • oder über VBA/VSTA implementiert werden

Zoomen und scrollen über Eigenschaft Multitouch für Zoomen und Scrollen

Um Multitouch ohne VBA/VSTA zu verwenden:

  1. aktivieren Sie in den Projekteigenschaften im Knoten Touchbedienung die Eigenschaft Multitouch aktiv

    Interne ID: Navigation mit Multitouch im Weltbild

    Touchbedienung

    Eigenschaften für die Touchbedienung.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. deaktivieren Sie bei den Eigenschaften des Bildes im Knoten Größe die Eigenschaft Größe aus Schablone

    Interne ID: Navigation mit Multitouch im Weltbild

    Größe

    Eigenschaften für die Größe und die Position des Bildes, die aus der verknüpften Schablone übernommen werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren Sie bei den Eigenschaften des Bildes im Knoten Allgemein die Eigenschaft Multitouch für Zoomen und Scrollen

    Interne ID: Navigation mit Multitouch im Weltbild

    Allgemein

    Allgemeine Eigenschaften des Bildes.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Damit kann im Bild bei Touchbedienung mit Multitouch-Gesten gescrollt und gezoomt werden. VBA/VSTA Events für Zoomen und Scrollen werden damit deaktiviert.

Zoomen und scrollen über VBA/VSTA

Um Zoomen und Scrollen mit VBA/VSTA Events zu realisieren darf die Eigenschaft Multitouch für Zoomen und Scrollen nicht aktiv sein.

Im DynPicture stehen zur Verfügung:

  • Property

    int ZoomLevel: Gibt den aktuelle Zoomlevel im Weltbild an (gültiger Wert nur in der Runtime und für ein Weltbild).

  • Methode

    SetZoomAndPos(float ZoomX, float ZoomY, int ZoomLevel, int CursorX, int CursorY, int PosX, int PosY, int PosMode):

    ZoomX -> Neuer Zoomfaktor X-Richtung, wenn nicht benutzt,auf 0 setzen

    ZoomY -> Neuer Zoomfaktor Y-Richtung, wenn nicht benutzt,auf 0 setzen

    ZoomLevel -> Zoom Level, wenn nicht benutzt, auf -1 setzen

    CursorX -> Cursorposition X

    CursorY -> Cursorposition Y

    PosX -> Neue Position X (siehe PosMode)

    PosY -> Neue Position Y (siehe PosMode)

    PosMode -> Koordinaten in Pos

    -1 = PosX, PosY werden ignoriert

    0 = Mittelpunkt , Original Koordinaten

    1 = Mittelpunkt , gezoomte Koordinaten

    2 = links oben , Original Koordinaten

    3 = links oben , gezoomte Koordinaten

    4 = Gezoomte Koordinaten des Cursors von links oben
    Die Position des Fensters wird so verändert, dass nach dem Zoomvorgang der Mauszeiger noch immer über der selben Stelle des Bildes liegt

Achtung: ZoomX, ZoomY und ZoomLevel können nie gleichzeitig verwendet werden. Entweder wird ein ZoomLevel angegeben oder Zoomfaktoren für X-Achse und Y-Achse.


Wizards

Handbuch -> Wizards

Um immer wiederkehrende Aufgaben beim Projektieren möglichst einfach und zeitsparend erledigen zu können, bietet zenon Wizards zu unterschiedlichen Bereichen im Engineering an.

Benutzer können auch eigene Wizards erstellen.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Wizards starten

Um einen Wizard zu starten:

  • wählen Sie in der Dropdownliste Datei den Eintrag Wizards ...

    oder

  • drücken Sie die Tastenkombination Alt+F12

Der Wizard für die Projekterstellung wird bei der Erstellung eines neuen Projekts automatisch angeboten.

Einstellungen zenon6.ini

Damit Wizards angezeigt werden, müssen die Einstellungen für VBA und/oder VSTA in der in der zenon6.ini korrekt gesetzt sein:

[VBA]

EIN=1

[VSTA]

ON=1

Werden VSTA Wizards bei korrekten Einstellungen nicht angezeigt, setzen Sie im Abschnitt [VSTA] den Eintrag LOADED= auf 1.

Noch in diesem Kapitel

Themen

Wizards erstellen und adaptieren

Wizards aktualisieren


Themen

Handbuch -> Wizards -> Themen

Folgende Wizards stehen Ihnen in zenon zur Verfügung:

  • Export - Import
    • FactoryLink Import Wizard
    • Import Wizard
    • PDiag Import Wizard
    • XML Export Wizard
  • Language table
    • Wizard für Systemtexte
  • Project
    • Project Wizard VBA
    • Project Wizard VSTA
    • Dokumentation-Wizard
  • Screens and Frames
    • Weltbild - World View Wizard
  • Variables and functions
    • Funktionen - Wizard for Functions
    • System Variablen anlegen - System Variable Creation Wizard
    • Variablen anlegen - Wizard for creating variables

Noch in diesem Kapitel

Analyzer Export Wizard

Export - Import

Language table

Pharmaceutical

Project

Screens and Frames

Variables


Analyzer Export Wizard

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard

Der zenon Analyzer Export Wizard unterstützt den Export von Metadaten aus zenon für den zenon Analyzer.

Exportiert werden können:

  • Daten aus dem Globalprojekt
    • Anlagenmodelle
    • Alarm/Ereignis-Klassen
    • Alarm-Ereignis-Gruppen
    • Benutzer
  • Variablen aus lokalen Projekten

Hinweis: Der Wizard steht nur in englischer Sprache zur Verfügung.

Noch in diesem Kapitel

Wizard installieren und aufrufen

Startfenster

Konfiguration

Wizard beenden


Wizard installieren und aufrufen

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Wizard installieren und aufrufen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Wizard zu installieren:

  1. öffnen Sie in zenon den Arbeitsbereich
  2. wählen Sie im Menü Datei den Befehl Wizards aktualisieren
  3. klicken Sie im Bereich Zusätzliche Ordner für VSTA Wizards auf die Schaltfläche ...
  4. navigieren Sie im Dateibrowser zum Installationsmediuem
  5. wählen Sie dort den Ordner [Installationsmedium]\Setup\Wizard\zenon7.00\WizardsVSTA aus
  6. wählen Sie die wizards.ini aus
  7. starten Sie das Update
  8. der Wizard wurde ins Verzeichnis der Wizards eingetragen und kann gestartet werden

Hinweis: Wird der Wizard nicht angezeigt, fügen Sie zum Workspace Add-in folgende Referenz hinzu: system.core

Wizard aufrufen

Damit Wizards angezeigt werden, müssen die Einstellungen für VBA und/oder VSTA in der in der zenon6.ini korrekt gesetzt sein:

[VBA]

EIN=1

[VSTA]

ON=1

Werden VSTA Wizards bei korrekten Einstellungen nicht angezeigt, setzen Sie im Abschnitt [VSTA] den Eintrag LOADED= auf 1. Um den Wizard aufzurufen:

  1. öffnen Sie in zenon das Menü Datei
    oder drücken Sie die Tastenkombination Alt+F12
  2. wählen Sie den Eintrag Wizards...
  3. der Auswahldialog wird geöffnet
  4. navigieren Sie zum Knoten Analyzer
  5. wählen Sie den Analyzer Export Wizard

  6. mit Klick auf OK starten Sie den Wizard


Startfenster

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Startfenster

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Öffnen des Wizards erhalten Sie eine Übersichtsseite, die alle exportierbaren Objekte auflistet.

Die einzelnen Objekte werden in eigenen Registerkarten für den Export konfiguriert.

Mit Klick auf die Schaltfläche Next navigieren Sie durch die Konfiguration des Exports.


Konfiguration

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Export mit dem Analyzer Export Wizard werden alle in der Registerkarte Data collection gewählten Module der Reihe nach zur Detailkonfiguration angeboten. Mit Klick auf die Schaltfläche Next gelangen Sie zur jeweils nächsten Stufe.

Sie können einzelne Registerkarten auch direkt anwählen durch Klick auf den Titel der Registerkarte. Damit ist es möglich, Konfigurationsschritte jederzeit zu modifizieren oder einen neuen Exportvorgang mit geänderten Parametern vorzunehmen, ohne den Wizard neu zu starten.

Folgende Registerkarten stehen zum Export zur Verfügung:

  • Data collection: Optionen zum Sammeln der Metadaten
  • Equipment modeling: Export der Modellgruppen
  • Alarm_event classe: Alarm/Ereignis-Klassen
  • Alarm_event groups: Alarm/Ereignis-Gruppen
  • Users: Benutzer
  • Projects: Projekte
  • Variables: Variablen
  • Export overview: Übersicht über die zu exportierenden Metadaten
  • Finish: Start des Exports und Ergebnis

Jede Registerkarte ist in drei Bereiche aufgeteilt:

  1. Informationsbereich:
    Hinweise, welche Daten in dieser Registerkarte konfiguriert werden und welche Möglichkeiten Sie haben.
  2. Listenfeld: Liste der zum Export zur Verfügung stehenden Objekte.
  3. Konfigurationsbereich: Möglichkeit, Daten vor dem Export zu bearbeiten

Noch in diesem Kapitel

Data collection

Equipment modeling

Alarm/Ereignis-Klassen

Alarm/Ereignis_Gruppen

Users

Projects

Variables

Export overview

Finish


Data collection

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Data collection

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Registerkarte legen Sie fest:

  1. Objekte, die exportiert werden sollen
  2. Datenbank, zu der verbunden wird
  3. allgemeine Optionen für den Export

Parameter

Beschreibung

Data Collection

Informationen und Hinweise zu aktuellen Exportvorgängen.

Collection settings

Eisntellungen zur Datensammlung

SCADA side

Einstellungen für zenon.

Definiert die aus dem zenon Arbeitsbereich zu exportierenden Elemente. Die Einstellungen entscheiden über zu exportierende Elemente. Die Feineinstellungen erfolgen in der jeweiligen Registerkarte.

Equipment modeling

Aktiv: Anlagenmodelle werden aus Globalprojekt exportiert .

Alarm/event classes

Aktiv: Alarm/Ereignis-Klassen werden aus Globalprojekt exportiert.

Alarm/event groups

Aktiv: Alarm/Ereignis-Gruppen werden aus Globalprojekt exportiert.

Users

Aktiv: Benutzer werden aus Globalprojekt exportiert.

Projects

Aktiv: Die Projektliste wird exportiert.

Variables

Aktiv: Variablen werden aus den Projekten exportiert.

Steht nur zur Verfügung, wenn die Option Projects aktiviert wurde.

Database side

Einstellungen für Datenbank. Definiert Rechner sowie Name und Instanz der Datenbank. Deren Datensätze sind:

  • Ziel des Exports
  • Quelle beim eventuellen Zusammenführen

DB host

Rechner, der Datenbank hostet.

DB name

Name der Datenbank.

DB instance

Instanz der Datenbank.

Options

Allgemeine Optionen für den Export.

Preselect the existing database objects in the collected meta data sets

Aktiv: Alle Einträge, die sowohl in zenon als auch der Datenbank vorhanden sind, werden im Auswahlbereich des Hauptfensters vorausgewählt.

Suggest the changeable form the existing database objects

Aktiv: Die editierbaren Werte der vorausgewählten Einträge, stammen von der Datenbank.

Diese werden damit beim Exportieren nicht geändert.

Nur verfügbar, wenn Preselect the existing database objects in the collected meta data sets aktiviert wurde.

Remove the positive database difference to the selected objects

Aktiv: Dateneinträge, die sich in der Datenbank befinden, aber nicht in zenon, werden in der Datenbank gelöscht.

Report the raised troubles

Aktiv: Ausnahmen und Fehler beim Ausführend es Wizards werden gemeldet.

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Equipment modeling

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Equipment modeling

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der zu exportierenden Modellgruppen aus dem Globalprojekt.

Parameter

Beschreibung

Equipment modeling

Informationen und Hinweise zum Export.

Equipment modeling settings

Listenfeld mit Auswahlmöglichkeit für Modellgruppen. Um einen Eintrag auszuwählen, aktivieren Sie die Checkbox vor dem Eintrag.

Im Listenfeld wird in den einzelnen Knoten immer der Name so angezeigt, wie er in der Datenbank abgelegt wurde. Falls der Name geändert wurde, wird der originale Name aus dem zenon Projekt in einer Klammer angezeigt.

Editierbereich

Ermöglicht es, im Auswahlfenster ausgewählte Elemente zu bearbeiten.

Name

Name des Eintrags

Description

Ergänzende Beschreibung

Continual edit

Aktiv: Deaktiviert die Schaltfläche Edit. Änderungen werden ohne Bestätigungsabfrage übernommen, sobald ein Eintrag verlassen wird .

Vorteil: Schnelleres Editieren mehrerer Daten.

Nachteil: Zufällige, unerwünschte Datenänderung möglich.

Edit/Apply

Nur verfügbar, wenn Continual Edit nicht aktiv ist.

Edit Öffnet den Einzelbearbeitungsmodus für den ausgewählten Eintrag. Die Schaltffäche wechselt zu Apply.

Änderungen müssen über Apply bestätigt oder über Cancel verworfen werden.

Wird im Auswahlfeld ein anderes Element angeklickt oder die Ablaufstufe geändert, erfolgt eine Abfrage:

  • geänderte Daten übernehmen: Schaltfläche Ja
  • verwerfen: Schaltfläche Nein
  • Element nicht wechseln: Schaltfläche Abbrechen

Vorteil: Genauere Kontrolle der Daten.

Nachteil: Langsameres Editieren der Daten.

Cancel

Verwirft alle Änderungen für ausgewähltes Element.

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Alarm/Ereignis-Klassen

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Alarm/Ereignis-Klassen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der zu exportierenden Alarm/Ereignis-Klassen aus dem Globalprojekt.

Parameter

Beschreibung

Alarm/event classes

Informationen und Hinweise zum Export.

Alarm/event classes settings

Listenfeld mit Auswahlmöglichkeit für Alarm/Ereignis-Klassen . Um einen Eintrag auszuwählen, aktivieren Sie die Checkbox vor dem Eintrag.

Editierbereich

Ermöglicht es, im Auswahlfenster ausgewählte Elemente zu bearbeiten.

Name

Name des Eintrags.

Description

Ergänzende Beschreibung.

Color

Aktuelle Farbe. Klick öffnet Palette zur Auswahl einer Farbe.

Continual edit

Aktiv: Deaktiviert die Schaltfläche Edit. Änderungen werden ohne Bestätigungsabfrage übernommen, sobald ein Eintrag verlassen wird .

Vorteil: Schnelleres Editieren mehrerer Daten.

Nachteil: Zufällige, unerwünschte Datenänderung möglich.

Edit/Apply

Nur verfügbar, wenn Continual Edit nicht aktiv ist.

Edit Öffnet den Einzelbearbeitungsmodus für den ausgewählten Eintrag. Die Schaltffäche wechselt zu Apply.

Änderungen müssen über Apply bestätigt oder über Cancel verworfen werden.

Wird im Auswahlfeld ein anderes Element angeklickt oder die Ablaufstufe geändert, erfolgt eine Abfrage:

  • geänderte Daten übernehmen: Schaltfläche Ja
  • verwerfen: Schaltfläche Nein
  • Element nicht wechseln: Schaltfläche Abbrechen

Vorteil: Genauere Kontrolle der Daten.

Nachteil: Langsameres Editieren der Daten.

Cancel

Verwirft alle Änderungen für ausgewähltes Element.

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Alarm/Ereignis_Gruppen

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Alarm/Ereignis_Gruppen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der zu exportierenden Alarm/Ereignis-Gruppen aus dem Globalprojekt.

Parameter

Beschreibung

Alarm/event groups

Informationen und Hinweise zum Export.

Alarm/event groups settings

Listenfeld mit Auswahlmöglichkeit für Alarm/Ereignis-Gruppen. Um einen Eintrag auszuwählen, aktivieren Sie die Checkbox vor dem Eintrag.

Editierbereich

Ermöglicht es, im Auswahlfenster ausgewählte Elemente zu bearbeiten.

Name

Name des Eintrags

Description

Ergänzende Beschreibung

Color

Aktuelle Farbe. Klick öffnet Palette zur Auswahl einer Farbe.

Continual edit

Aktiv: Deaktiviert die Schaltfläche Edit. Änderungen werden ohne Bestätigungsabfrage übernommen, sobald ein Eintrag verlassen wird .

Vorteil: Schnelleres Editieren mehrerer Daten.

Nachteil: Zufällige, unerwünschte Datenänderung möglich.

Edit/Apply

Nur verfügbar, wenn Continual Edit nicht aktiv ist.

Edit Öffnet den Einzelbearbeitungsmodus für den ausgewählten Eintrag. Die Schaltffäche wechselt zu Apply.

Änderungen müssen über Apply bestätigt oder über Cancel verworfen werden.

Wird im Auswahlfeld ein anderes Element angeklickt oder die Ablaufstufe geändert, erfolgt eine Abfrage:

  • geänderte Daten übernehmen: Schaltfläche Ja
  • verwerfen: Schaltfläche Nein
  • Element nicht wechseln: Schaltfläche Abbrechen

Vorteil: Genauere Kontrolle der Daten.

Nachteil: Langsameres Editieren der Daten.

Cancel

Verwirft alle Änderungen für ausgewähltes Element.

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Users

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Users

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der zu exportierenden Benutzer aus dem Globalprojekt.

Parameter

Beschreibung

Users

Informationen und Hinweise zum Export.

Users settings

Listenfeld mit Auswahlmöglichkeit für Benutzer. Um einen Eintrag auszuwählen, aktivieren Sie die Checkbox vor dem Eintrag.

Editierbereich

Ermöglicht es, im Auswahlfenster ausgewählte Elemente zu bearbeiten.

Name

Name des Eintrags

Description

Ergänzende Beschreibung

Continual edit

Aktiv: Deaktiviert die Schaltfläche Edit. Änderungen werden ohne Bestätigungsabfrage übernommen, sobald ein Eintrag verlassen wird .

Vorteil: Schnelleres Editieren mehrerer Daten.

Nachteil: Zufällige, unerwünschte Datenänderung möglich.

Edit/Apply

Nur verfügbar, wenn Continual Edit nicht aktiv ist.

Edit Öffnet den Einzelbearbeitungsmodus für den ausgewählten Eintrag. Die Schaltffäche wechselt zu Apply.

Änderungen müssen über Apply bestätigt oder über Cancel verworfen werden.

Wird im Auswahlfeld ein anderes Element angeklickt oder die Ablaufstufe geändert, erfolgt eine Abfrage:

  • geänderte Daten übernehmen: Schaltfläche Ja
  • verwerfen: Schaltfläche Nein
  • Element nicht wechseln: Schaltfläche Abbrechen

Vorteil: Genauere Kontrolle der Daten.

Nachteil: Langsameres Editieren der Daten.

Cancel

Verwirft alle Änderungen für ausgewähltes Element.

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Projects

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Projects

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der zu exportierenden lokalen Projekte.

Parameter

Beschreibung

Projects

Informationen und Hinweise zum Export.

Projects settings

Listenfeld mit Auswahlmöglichkeit für Projekte. Um einen Eintrag auszuwählen, aktivieren Sie die Checkbox vor dem Eintrag.

Editierbereich

Ermöglicht es, im Auswahlfenster ausgewählte Elemente zu bearbeiten.

Um einen Eintrag auszuwählen, aktivieren Sie die Checkbox vor dem Eintrag.

Name

Name des Eintrags.

Description

Ergänzende Beschreibung.

Server

Adresse des Servers.

Standby

Adresse des Standby-Servers.

Continual edit

Aktiv: Deaktiviert die Schaltfläche Edit. Änderungen werden ohne Bestätigungsabfrage übernommen, sobald ein Eintrag verlassen wird .

Vorteil: Schnelleres Editieren mehrerer Daten.

Nachteil: Zufällige, unerwünschte Datenänderung möglich.

Edit/Apply

Nur verfügbar, wenn Continual Edit nicht aktiv ist.

Edit Öffnet den Einzelbearbeitungsmodus für den ausgewählten Eintrag. Die Schaltffäche wechselt zu Apply.

Änderungen müssen über Apply bestätigt oder über Cancel verworfen werden.

Wird im Auswahlfeld ein anderes Element angeklickt oder die Ablaufstufe geändert, erfolgt eine Abfrage:

  • geänderte Daten übernehmen: Schaltfläche Ja
  • verwerfen: Schaltfläche Nein
  • Element nicht wechseln: Schaltfläche Abbrechen

Vorteil: Genauere Kontrolle der Daten.

Nachteil: Langsameres Editieren der Daten.

Cancel

Verwirft alle Änderungen für ausgewähltes Element.

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Variables

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Variables

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der zu exportierenden Variablen aus den lokalen Projekten.

Bei der Auswahl der Variablen können die angebotenen Einträge im Auswahlfenster nach Projekten vorgefiltert werden:

Parameter

Beschreibung

Variables

Informationen und Hinweise zum Export.

Variables settings

Listenfeld mit Auswahlmöglichkeit für Projekte. Um einen Eintrag auszuwählen, aktivieren Sie die Checkbox vor dem Eintrag.

Project

Dropdownliste, um Projekte für Variablenauswahl auszuwählen. Es werden immer nur die Variablen des ausgewählten Projekts angezeigt.

Es können mehrerer Projekte der Reihe nach aufgerufen werden, um deren Variablen auszuwählen.

Die Variablenauswahl wird in der Registerkarte Export overview angezeigt.

Show variables of selected equipment modeling nodes only

Aktiv: Nur Variablen, die sich in den ausgewählten Anlagenmodellen befinden, werden angezeigt.

Editierbereich

Ermöglicht es, im Auswahlfenster ausgewählte Elemente zu bearbeiten.

Name

Name des Eintrags.

Description

Ergänzende Beschreibung.

Continual edit

Aktiv: Deaktiviert die Schaltfläche Edit. Änderungen werden ohne Bestätigungsabfrage übernommen, sobald ein Eintrag verlassen wird .

Vorteil: Schnelleres Editieren mehrerer Daten.

Nachteil: Zufällige, unerwünschte Datenänderung möglich.

Edit/Apply

Nur verfügbar, wenn Continual Edit nicht aktiv ist.

Edit Öffnet den Einzelbearbeitungsmodus für den ausgewählten Eintrag. Die Schaltffäche wechselt zu Apply.

Änderungen müssen über Apply bestätigt oder über Cancel verworfen werden.

Wird im Auswahlfeld ein anderes Element angeklickt oder die Ablaufstufe geändert, erfolgt eine Abfrage:

  • geänderte Daten übernehmen: Schaltfläche Ja
  • verwerfen: Schaltfläche Nein
  • Element nicht wechseln: Schaltfläche Abbrechen

Vorteil: Genauere Kontrolle der Daten.

Nachteil: Langsameres Editieren der Daten.

Cancel

Verwirft alle Änderungen für ausgewähltes Element.

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Export overview

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Export overview

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Registerkarte listet die für den Export ausgewählten Elemente auf.

Folgende Einträge werden vom Wizard erstellt und können vom Benutzer nicht verändert werden:

  • Status texts
  • Variable to equipment modeling mappings
  • Equipment modeling to operating shift mappings

Navigation

Schaltfläche

Beschreibung

Back

Schaltet im Ablauf des Wizards eine Stufe zurück.

Next

Klick auf Schaltfläche schaltet eine Stufe im Ablauf weiter.

Finish

Führt Export durch.

Steht nur in der Registerkarte Finish zur Verfügung.

Cancel

Beendet Ausführung des Wizards.

Beim beenden ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll

  • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
  • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern

Konfiguration ändern

Um Einträge vor dem Export zu verändern:

  • klicken Sie auf die Schaltfläche Back
    oder
  • wählen Sie die Registerkarte direkt aus

Daten exportieren

Um alle Einstellungen zu bestätigen und die Daten zu exportieren:

  • klicken Sie auf die Schaltfläche Next
  • klicken Sie in der Registerkarte Finish auf die Schaltfläche Finish

Hinweis: Je nach Einstellungen führt der Export auch zum Löschen von Daten in der Datenbank.

Weitere Exporte durchführen

Um einen weiteren Export zu konfigurieren und zu starten:

  • klicken Sie auf die Schaltfläche Back oder wählen Sie die Registerkarte direkt aus
  • konfigurieren Sie die gewünschten Exportstufen neu
  • klicken Sie in der Registerkarte Finish auf die Schaltfläche Finish


Finish

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Konfiguration -> Finish

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die konfigurierten Daten zu exportieren:

  1. klicken Sie in der Registerkarte Finish auf die

  2. der Export wird gestartet
  3. im Ausgabefenster werden die exportierten Elemente dokumentiert

  4. klicken Sie auf Cancel, um den Wizard zu beenden
    oder konfigurieren Sie die Registerkarten neu, um einen weiteren Export vorzubereiten


Wizard beenden

Handbuch -> Wizards -> Themen -> Analyzer Export Wizard -> Wizard beenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Wizard zu beenden:

  • klicken Sie die Schaltfläche Close bzw. Cancel
  • ein Dialog fragt ab, ob die Konfiguration gespeichert werden soll
    • Klick auf Ja schreibt die Konfiguration in die Registry und beendet Wizard; beim nächsten Start wird der Wizard mit dieser Konfiguration geöffnet
    • Klick auf Nein beendet Wizard ohne Konfiguration zu speichern


Export - Import

Handbuch -> Wizards -> Themen -> Export - Import

Wizards für Export und Import von Daten.

Noch in diesem Kapitel

FactoryLink Import Wizard

PDiag Import Wizard

WinCC Import Wizard

XML Export Wizard VSTA

XML Import Wizard


FactoryLink Import Wizard

Handbuch -> Wizards -> Themen -> Export - Import -> FactoryLink Import Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der FactoryLink Import Wizard ist ein Assistent, der den Benutzer beim Portieren eines FactoryLink-Projektes auf zenon unterstützt.

attention Achtung

Die Sprache des zenon-Editors sollte auf Englisch gestellt werden, um einen möglichst fehlerfreien Import des FactoryLink-Projektes zu gewährleisten.

Noch in diesem Kapitel

Export der Projektdaten aus FactoryLink

Import des Projektes

Liste der importierbaren Objekte


Export der Projektdaten aus FactoryLink

Handbuch -> Wizards -> Themen -> Export - Import -> FactoryLink Import Wizard -> Export der Projektdaten aus FactoryLink

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Export der FactoryLink-Projektdaten hat über das Menü Display - Library Converter in der Anwendung ClientBuilder zu erfolgen. Hier müssen die gewünschten Libraries und alle zu konvertierenden Projektinhalte ausgewählt werden.

attention Achtung

Als Zielformat muss unbedingt ASCII ausgewählt werden.

Zusätzlich muss Zugriff auf die im Projekt verwendeten Bitmaps gegeben sein. Alle Dateien müssen in der Ordnerstruktur verbleiben, die von FactoryLink erstellt wurde.


Import des Projektes

Handbuch -> Wizards -> Themen -> Export - Import -> FactoryLink Import Wizard -> Import des Projektes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über das Menü Datei - Wizards... wird ein Auswahldialog angezeigt, welche alle verfügbaren Wizards in zenon anzeigt. Der FactoryLink Import Wizard befindet sich in der Gruppe Wizards - Export/Import - FactoryLink Import Wizard.

Noch in diesem Kapitel

Welcome

Preparation

Tag selection

Mimic selection

Events


Welcome

Welcome

Auf der ersten Seite des Wizards wird kurz der Ablauf und die folgenden Seiten des Wizards beschrieben.


Preparation

Preparation

Auf dieser Seite sind grundlegende Informationen zur Ausführung des Wizards vorhanden. Um doppelt vorhandene Namen von Bildern und Schablonen beim Import ausschließen zu können empfiehlt es sich, ein neues Projekt in zenon zu erstellen. Über einen Klick auf Create empty project kann der zenon-Dialog zur Erstellung eines neuen Projektes aufgerufen werden, falls das aktuell geladene Projekt kein leeres sein sollte.

attention Achtung

Nach der Erstellung eines neuen Projektes öffnet sich automatisch der Wizard-Auswahldialog von zenon. Dieser Auswahldialog muss geschlossen werden, da der FactoryLink Import Wizard im Hintergrund aktiv bleibt.


Tag selection

Tag selection

Auf dieser Seite muss die Datei imltags.asc des zu importierenden FactoryLink-Projektes ausgewählt werden. Über einen Klick auf Import! werden alle Variableninformationen des Projektes in zenon importiert. Der Wizard öffnet die Datei mit den Variableninformationen und liest Namen, Typen und Beschreibung der Variablen aus. Als Standardtreiber wird in zenon der Intern-Treiber verwendet.

info Info

Nach dem Import der Variablen können die verwendeten Treiber in zenon über Properties -> Addressing -> Driver Connection -> Driver geändert werden.


Mimic selection

Mimic selection

Auf dieser Seite müssen alle relevanten Ordner ausgewählt werden, in denen sich die Bilddaten, Schablonen, Bitmaps und Symbole des Projektes befinden.

Zusätzlich zum normalen Import als Bildsymbol besteht im Wizard die Möglichkeit, ein Symbolbild zu erstellen. Dabei erstellt der Wizard ein Bild mit allen im Projekt enthaltenen Symbolen. Diese Symbole müssen nun manuell in die lokale Symbolbibliothek des zenon-Projektes kopiert werden. Enthält das Projekt FactoryLink-Animationen (beispielsweise Symbols Bit Group), in denen Variablen mit Symbolen verknüpft werden, kann der Wizard auf diese Weise diese Animationen auf ein zenon-Combi-Element übertragen.


Events

Events

Auf dieser Seite wird eine Zusammenfassung der Konvertierungen angezeigt. Die Liste kann bei Bedarf nach bestimmten Ereignissen gefiltert werden.


Liste der importierbaren Objekte

Handbuch -> Wizards -> Themen -> Export - Import -> FactoryLink Import Wizard -> Liste der importierbaren Objekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Import von Variablennamen, Beschreibung und Typen, Übertragen der FactoryLink-Verbindungen auf den zenon-Intern-Treiber
  • Import und Erstellen von FactoryLink Templates und Mimics.
  • Import von FactoryLink Bitmaps in den Bilderordner des zenon-Projektmanagers
  • Import und Erstellung von statischen Bildelementen:
  • Rechteck
  • Linien
  • abgerundete Rechtecke
  • Kreise/Ellipsen
  • Text
  • Polygone
  • PolyLinien
  • Kuchendiagramme
  • Bitmaps
  • Import von MultiLang-Texten aus Textelementen in die zenon Sprachtabellen
  • Schriften aus FactoryLink-Projekten werden in der Größe approximiert und auf die bestehenden Standard-Projektschriften angepasst
  • Möglichkeit der Symbolbild-Erstellung, welches alle Symbole zum manuellen Import in die lokale Symbolbibliothek enthält
  • FactoryLink Symbolimport als zenon Bildsymbole
  • Alternativer Symbolimport aus der zenon Symbolbibliothek, wenn ein manueller Import durchgeführt wurde
  • Konvertierung von CB-Animationen (ColorBit) auf ein zenon Combi-Element
  • Konvertierung von OBG-Animationen (Symbols Bit Group) auf ein zenon Combi-Element
  • Konvertierung von DR-Animationen (Display Register) auf ein zenon Text-Element
  • Konvertierung von SR-Animationen (Send Register) auf einen zenon Text-Button


PDiag Import Wizard

Handbuch -> Wizards -> Themen -> Export - Import -> PDiag Import Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon PDiag Import Wizard unterstüzt beim Import von PDiag-Meldungen. Dieser Wizard kann auch als Vorlage für eigene Erweiterungen in diesem Zusammenhang dienen.

Der PDiag Import Wizard steht nur in englischer Sprache zur Verfügung.

Noch in diesem Kapitel

Voraussetzungen

Einstellungen

Import der Meldungen


Voraussetzungen

Handbuch -> Wizards -> Themen -> Export - Import -> PDiag Import Wizard -> Voraussetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Wizard importiert eine aus dem Simatic Modul Prozess Diagnose (PDiag) exportierte XML-Datei. Dieser Export kann im Simatic Manager/Prozess Diagnose mit dem Menüpunkt Prozessdiagnose | Exportieren durchgeführt werden.

Die so erzeugte XML-Datei wird mit dem Wizard in zenon importiert. Dabei werden Variablen, die auf dem S7-TCP Treiber basieren, vom Treiberobjekttyp Alarm-S angelegt. Jede Meldung und jeder Begleitwert entspricht einer zenon Variable.

Als Begleitwerte werden nur UINT-Variablen importiert. Dabei wird der Meldetext auf die Simatic PDiag Kennzeichen "@1X%2d@", "@1X%3d@" und "@1X%4d@" analysiert und für zenon entsprechend angepasst. Eine Verwendung der Sprachtabelle für dynamische Texte ist ebenfalls möglich. Dabei sind die Texte ausserhalb des Wizards in die zenon Sprachtabelle zu übertragen.

Dieser Wizard importiert ebenfalls S7-Graph Meldungen, die von PDiag automatisch generiert werden und somit ebenfalls in der XML-Datei enthalten sind.


Einstellungen

Handbuch -> Wizards -> Themen -> Export - Import -> PDiag Import Wizard -> Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Wizard zu starten:

  1. wählen Sie im Menü Datei den Befehl Wizards...

    Alternative: Tastenkombination Alt+F12

  2. der Dialog zur Auswahl der zenon Wizards wird geöffnet
  3. öffnen Sie den Knoten Export/Import
  4. wählen Sie PDIAG Wizard

Der Wizard führt über die Registerkarten

  • Welcome
  • Settings
  • Finish

zum Import einer XML-Datei.

Noch in diesem Kapitel

Welcome

Settings

Finish


Welcome

Welcome

Die Registerkarte Welcome enthält eine kurze Erklärung zu Funktionsweise und Voraussetzungen des Wizards.

Um zur Registerkarte Settings zu gelangen, klicken Sie auf die Menüauswahl Settings oder auf den Pfeil links unten.


Settings

Settings

In der Registerkarte Settings führen Sie die Einstellungen für den Import durch.

Einstellung

Beschreibung

Driver

Auswahl des S7-TCP Treibers aus dem aktiven Projekt, für den der Import durchgeführt werden soll.

PDIAG XML File

Auswahl der zu importierenden XML-Datei.

Identification

Optionaler Eintrag für die Variablenkennung. Auf diesen Eintrag kann in der Variablenliste gefiltert werden.

Net Adress

Legt die Netzadresse für die zenon Variablenadressierung fest. Die gültige Netzadresse entnehmen Sie aus der Treiberkonfiguration.

Alarm Group

Legt die Alarm/Ereignis-Gruppe der importierten Meldungen fest.

Achtung: Der Wizard legt keine Alarm/Ereignis-Gruppen in zenon selbstständig an. Diese müssen vor dem Import manuell erzeugt werden.

In IPA

Aktiv: Setzt für die Variablen die Eigenschaft In IPA-Datenbank speichern. Damit werden die Meldungen in den Industrial Performance Analyzer übertragen.

Interne ID: Settings

In IPA-Datenbank speichern

Aktiv: Die Alarme dieser Variable sind für die Auswertung im Industrial Performance Analyzer (IPA) verfügbar.
Inaktiv: Die Alarme dieser Variable werden bei der Auswertung im Industrial Performance Analyzer nicht berücksichtigt.
Default: inaktiv

Achtung: Der Industrial Performance Analyzer ist ein optionales Modul und muss lizenziert sein, um verwendet werden zu können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Get Alarm Class

Aktiv: Die im Simatic Manager gesetzte Meldungspriorität wird als zenon Alarm/Ereignis-Klasse interpretiert wird.

Achtung: Der Wizard legt keine Alarm/Ereignis-Klassen in zenon selbstständig an. Diese müssen vor dem Import manuell erzeugt werden.

Mit Finish wird der Import gestartet. Diese Schaltfläche ist nur in der Registerkarte Finish aktiv. Klicken Sie dazu auf die Menüauswahl Finish oder auf den Pfeil links unten.


Finish

Finish

Um den Import zu starten, klicken Sie auf die Schaltfläche Finish.


Import der Meldungen

Handbuch -> Wizards -> Themen -> Export - Import -> PDiag Import Wizard -> Import der Meldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Während des Imports werden Hinweise ausgegeben:

Nach Abschluss des Imports erscheint ein Hinweis darauf, wie viele Variablen importiert wurden.

Wichtige Meldungen

Meldung | Beschreibung
message text too long | Der Alarmtext ist zu lang und wird auf die in zenon gültige Länge abgeschnitten.
creating attribute variable for dynamic limit text | Neben der Meldevariable wird eine Begleitwertvariable für den dynamischen Grenzwerttext angelegt.


WinCC Import Wizard

Handbuch -> Wizards -> Themen -> Export - Import -> WinCC Import Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der WinCC Import Wizard importiert ausgewählte Teile von bestehenden WinCC Projekten in das aktuell geladene zenon Projekt. Der Import der WinCC Projektdaten erfolgt über zwei Programme:

  • WinCC Graphics Converter: exportiert WinCC Bilder, Schablonen und Symbole aus WinCC in eine XML-Datei
  • WinCC Import Wizard: importiert
    • Data Blocks (Structure Tags), Tags, Alarme und Archive direkt
    • Bilder, Schablonen und Symbole via XML-Dateien, die zuvor mit dem WinCC Graphics Converter erzeugt wurden

Noch in diesem Kapitel

Installation

WinCC Graphics Converter

WinCC Import Wizard


Installation

Handbuch -> Wizards -> Themen -> Export - Import -> WinCC Import Wizard -> Installation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit Sie den WinCC Import Wizard ausführen können, müssen Sie zuerst alle Komponenten installieren.

info Info

Beachten Sie, dass Sie zenon NICHT auf demselben Rechner wie WinCC installieren sollten.

Installation WinCC Graphics Converter

Um auf die WinCC Informationen zugreifen zu können, muss der WinCC Graphics Converter lokal am Rechner, auf dem das WinCC-Projekt läuft, installiert werden. Das Setup befindet sich auf dem zenon Installationsmedium im Ordner \Additional_Software\WinCC Graphics Converter.

Nach der Installation finden Sie unter Start - Alle Programme - COPA-DATA - WinCC Graphics Converter das Konvertierungs Tool für verschiedene WinCC Versionen. Starten Sie immer nur das passende Tool.

info Info

Für den Einsatz des Konverters wird ein installiertes .NET Framework 3.5 vorausgesetzt. Bei der Installation des Konverters wird dessen Vorhandensein überprüft. Fehlt das Framework, wird die Installation abgebrochen. Installieren Sie in diesem Fall zuerst das .NET Framework 3.5 und starten Sie dann die Installation des Konverters neu.

Installation des Wizard ab zenon 7.0

Der Wizard wird automatisch mit dem <CD_PRODUCTAME> Editor mitinstalliert. Es sind keine separaten Einstellungen erforderlich. Sie können den Wizard gleich im zenon Editor unter Datei - Wizards... und dort im Bereich Export/Import starten.

Installation des Wizard für zenon 6.51

Da der Wizard nicht Bestandteil von 6.51 SP0 ist, müssen Sie für die Installation folgende Schritte durchführen:

  • Installieren Sie mindestens das Build 6 von zenon 6.51. Das Build 6 können Sie bei Ihrem Vertriebspartner bzw. beim COPA-DATA Support anfordern.
  • Installieren Sie den Wizard mit dem WinCC Graphics Converter. Dieses Setup installiert das WinCC Graphics Converter Tool und auch den Wizard sofern zenon 6.51 SP0 installiert ist. Das Setup können Sie bei Ihrem Vertriebspartner bzw. beim COPA-DATA Support anfordern.
  • Starten Sie nach der Installation den zenon Editor. Es erscheint der Dialog zur Aktualisierung der Wizards. Mittels Aktualisierung starten wird der Wizard dem VSTA Workspace hinzugefügt.
    Sollten Sie diesen Schritt später durchführen wollen, können Sie im zenon Editor im Menü Datei - Wizards aktualisieren... jederzeit wieder zu diesem Dialog gelangen.

  • Starten Sie den VSTA Editor im zenon Editor im Menü Datei - VSTA Editor öffnen... und selektieren Sie im Fenster Project Explorer den Knoten References. Im Kontextmenü führen Sie Add Reference... aus, um zwei fehlende Referenzen nachzutragen:
    • MSDASC: Im Add Reference Dialog wechseln Sie auf die Registerkarte COM und fügen die Komponente Microsoft OLE DB Service Component 1.0 Type Library dem Projekt hinzu.
    • ADODB: Im Add Reference Dialog wechseln Sie auf die Registerkarte Browse. Navigieren Sie zum Ordnern C:\Program Files (x86)\Microsoft.NET\Primary Interop Assemblies und selektieren Sie die Datei adodb.dll.

  • Nun können Sie im VSTA Editor im Fenster Project Explorer den Knoten WorkspaceAddin selektieren und das Addin durch den Kontextmenü Befehl Build kompillieren.

Sobald der Kompillierungsvorgang erfolgreich war, steht der Wizard im zenon Editor unter Datei - Wizards... und dort im Bereich Export/Import zur Verfügung.


WinCC Graphics Converter

Handbuch -> Wizards -> Themen -> Export - Import -> WinCC Import Wizard -> WinCC Graphics Converter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der WinCC Graphics Converter ermöglicht es, Bilder, Schablonen und Symbole in WinCC Projekten auszuwählen und als XML-Dateien zu exportieren.

info Info

Derzeit können XML-Dateien mit WinCC Projekten der Version 7.0 und 7.0 SP1 erstellt werden.

Noch in diesem Kapitel

Welcome

Select .pdl files

Select output folder

Convert


Welcome

Welcome

Mit dem WinCC Graphics Convert lassen sich WinCC Grafik Dateien (pdl) in ein für den WinCC Import Wizard lesbares XML Format konvertieren. Bestehende Grafikinformationen werden als PNG- und WMF-Dateien zusammen mit dem XML-Dateien gespeichert und in einem ausgewählten Ordner gespeichert.

Um den Konverter auszuführen:

  1. klicken Sie auf Start
  2. navigieren Sie zu COPA-DATA -> WinCC Graphics Converter
  3. starten Sie den WinCC Graphics Converter
  4. folgen Sie den Anweisungen des Wizards


Select .pdl files

Select .pdl files

In dieser Registerkarte wählen Sie die PDL-Dateien, die aus dem WinCC Projekt exportiert werden sollen. Dazu:

  1. klicken Sie auf die Schaltfläche Select .pdl files
  2. navigieren Sie zum Projekt-Ordner, der die PDL-Dateien enthält

    Hinweis: Damit die Dateien ausgewählt werden können, muss das WinCC Projekt auf dem Rechner geladen sein!

  3. wählen Sie die gewünschten Dateien aus
  4. alle ausgewählten PDL-Dateien werden im Vorschaufenster angezeigt


Select output folder

Select output folder

In dieser Registerkarte wählen Sie den Ordner, in dem die Exportdateien abgelegt werden sollen. Dazu:

  1. klicken Sie auf die Schaltfläche Select output folder
  2. navigieren Sie zum Ordner, in dem die Exportdatien abgelegt werden sollen
  3. Hinweis: Sie können im Auswahldialog auch einen neuen Ordner erstellen


Convert

Convert

In dieser Registerkarte führen Sie die Konvertierung durch.

Kopieren Sie nach erfolgtem Export den Ordner auf den rechner mit dem zenon Projekt, in das die Daten importiert werden sollen oder sorgen Sie dafür, dass de Rechner mit dem zenon Projekt Zugriff auf den Export-Ordner hat.


WinCC Import Wizard

Handbuch -> Wizards -> Themen -> Export - Import -> WinCC Import Wizard -> WinCC Import Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

DerImport WinCC Wizard wird über den Wizard Dialog des Editors gestartet und dient für den Import folgender WinCC Elemente:

  • Import der Screens (die über WinCC Graphics Converter erzeugten XML-Dateien werden in zenon Schablonen, Bilder und Symbole umgewandelt)
  • Import der WinCC Tags (nur S7 TCP)
  • Import der WinCC Structure Tags ( nur S7 TCP)
  • Import Alarm Limits
  • Import Archive Tags

Wizard aufrufen

Damit Wizards angezeigt werden, müssen die Einstellungen für VBA und/oder VSTA in der in der zenon6.ini korrekt gesetzt sein:

[VBA]

EIN=1

[VSTA]

ON=1

Werden VSTA Wizards bei korrekten Einstellungen nicht angezeigt, setzen Sie im Abschnitt [VSTA] den Eintrag LOADED= auf 1.

Um den Wizard aufzurufen:

  1. öffnen Sie in zenon das Menü Datei
    oder drücken Sie die Tastenkombination Alt+F12
  2. wählen Sie den Eintrag Wizards...
  3. der Auswahldialog wird geöffnet
  4. navigieren Sie zum Knoten Export/Import
  5. wählen Sie den WinCC Import Wizard
  6. mit Klick auf OK starten Sie den Wizard

Der Wizard ist in Bereiche unterteilt:

  • Welcome: Überblick über den Wizards.
  • Settings: Einstellungen für die Verbindung zum WinCC Projekt. Nach erfolgreicher Verbindung werden die Registerkarten für den direkten Import angezeigt:
    • Data Blocks: Structure Tags aus WinCC
    • Tags: Tags aus WinCC
    • Alarm Limits: Alramklassen und Alarme aus WinCC
    • Archive Tags: Archivdateien aus WinCC
  • Screens: Import der Bilder aus WinCC über den WinCC Graphics Converter

Noch in diesem Kapitel

Welcome

Settings

Data Blocks

Tags

Alarm Limits

Archive Tags

Screens


Welcome

Welcome

Die Startseite des Wizards informiert über alle weiteren Importschritte.

Der direkte Import von Daten ist erst möglich, nachdem in der Registerkarte Settings die Verbindung zum WinCC Projekt konfiguriert wurde.


Settings

Settings

In dieser Registerkarte konfigurieren Sie die Verbindung zum WinCC Projekt, dessen Daten importiert werden sollen.

Parameter | Beschreibung
WinCC DB connection | Konfiguration der Verbindung zur WinCC Datenbank.
Connected with | Anzeige der aktiven Verbindung.
Connect | Stellt Verbindung her.
New Connection | Öffnet den Dialog zur Konfiguration einer neuen Verbindung.
Driver selection (S7 TCP) | Konfiguration des zenon Treibers.
Driver | Auswahl eines zenon Treibers aus Dropdownliste.
Create new Driver | Öffnet Dialog zur Erstellung eines neuen Treibers.

attention Achtung

Damit die Verbindung hergestellt werden kann, muss das WinCC Projekt am PC, mit dem die Verbindung hergestellt wird, aktiv sein oder im WinCC Explorer geöffnet sein.

Konfiguration der Verbindung

Um eine Verbindung herzustellen:

  1. klicken Sie auf die Schaltfläche New connection
  2. der Dialog für die Verbindungseinstellungen wird geöffnet

  3. auf der Registerkarte Provider wählen Sie den Provider Microsoft OLE DB Provider for SQL Server
  4. auf der Registerkarte Connection:
    1. Bei server name tragen Sie die Instanz des SQL Servers in dem sich das WinCC Projekt befindet. z.B.: HOSTNAME\WINCC
      Wichtig: Die WinCC SQL Server Instanz (sqlsrv.exe) muss in der Firewall freigeschaltet sein.
    2. Bei logon information tragen Sie Ihre Zugangsdaten ein. Die Zugangsdaten müssen zuerst mit dem SQL Server Management Studio in der SQL Server Instanz angelegt werden.
      Wichtig: Aktivieren Sie die Option Allow saving password
    3. Bei database selektieren Sie das WinCC Editor Projekt. Das ist der Datenbankname ohne dem abschließenden _R
      Hinweis: Das Projekt muss im WinCC Editor geladen und aktiv sein, sonst ist das Projekt nicht im Datenbankserver verfügbar.
    4. Testen Sie die Verbindung
  5. schließen Sie den Konfigurationsdialog mit OK
  6. danach können Sie über die Schaltfläche Connect im Wizard die Verbindung zum WinCC Projekt herstellen.
  7. wählen Sie einen zenon Treiber aus

Nach erfolgreicher Verbindung und Auswahl eines zenon Treibers werden die Registerkarten für den direkten Import angezeigt.


Data Blocks

Data Blocks

In dieser registerkarte werden die im WinCC Explorer unter Data Blocks angezeigten Datenblöcke ausgewählt und als Datentypen in zenon importiert.

Die WinCC Data Blocks werden nach Treiber gruppiert und nach Block-Type und Name sortiert angezeigt.

Um Datenblöcke zu importieren:

  1. wählen Sie die gewünschten Datenblöcke aus
  2. klicken Sie auf Import Data Blocks

Ergebnis

Data Blocks in WinCC:

Datentypen in zenon


Tags

Tags

Auf dieser Registerkarte werden Tags (S7), die im WinCC Explorer unter Tag Management angezeigt werden, ausgewählt und als zenon Variablen importiert. Der Export kann direkt nach zenon erfolgen oder in eine CSV-Datei.

Um Tags zu importieren:

  1. wählen Sie die gewünschten Tags aus
  2. klicken Sie auf Import Tags oder Import to CSV

Ergebnis

Tags in WinCC:

Variablen in zenon:


Alarm Limits

Alarm Limits

In dieser Registerkarte werden Alarmklassen und Grenzwerte importiert:

  • Import Alarm Classes : Importiert Alarmklassen in ein vorhandenes globales Projekt
  • Import Alarms: Importiert Alarmklassen und Gruppen ins lokale zenon Projekt und erstellt für die Grenzwerte Variablen

Import Alarm Classes

Importiert Alarmklassen aus WinCC in ein Globales Projekt in zenon. Das Globale Projekt muss in zenon bereits angelegt und aktiv sein.

Um Alarmklassen zu importieren:

  1. wählen Sie die gewünschten Alarmklassen aus
  2. klicken Sie auf Import Alarm Classes

Ergebnis

Alarmklassen in WinCC:

Alarmklassen in zenon:

Import Alarms

Bei dieser Form des Imports werden alle Alarmklassen und Alarmgruppen in das zenon Projekt importiert. Die WinCC Limit-Texte werden durch Grenzwertvariablen ersetzt.

Um Alarme zu importieren:

  1. wählen Sie die gewünschten Alarme aus
  2. klicken Sie auf Import Alarms

Ergebnis

Alarme in WinCC:

Alarme in zenon:


Archive Tags

Archive Tags

Auf dieser Registerkarte können Tags, die im WinCC Explorer unter Tag Logging eingetragen sind, ausgewählt und importiert werden. Der Import erfolgt in eines der beiden dabei neu in zenon Projekt angelegten angelegten Archive BINARY oder ANALOG.

attention Achtung

Tags werden nur dann im zenon Archive angelegt, wenn diese vorher als Tags importiert wurden.

Um Archive Tags zu importieren:

  1. wählen Sie die gewünschten Archive Tags aus
  2. klicken Sie auf Import Archiv Tags

Ergebnis

Archive Tags in WinCC:

Archive in zenon:


Screens

Screens

Auf dieser Registerkarte werden die mit dem WinCC Graphics Converter erzeugten XML in das aktive zenon Projekt importiert. In zenonwerden Schablonen, Bilder und Standard-Bildelemente automatisch anhand der gespeicherten Information in der XML Datei sowie den im Verzeichnis liegenden WMF-Dateien und PNG-Dateien erzeugt.

Parameter | Beschreibung
Liste der Dateien | Zeigt alle im gewählten Ordner vorhandenen Dateien an.
Select Folder | Öffnet Dialog zur Auswahl des ordners mit den Import-Dateien.
Select All | Wählt alle im Fenster vorhandenen Dateien aus.
Import XML | Startet den Import.

Um Bilder zu importieren:

  1. wählen Sie die gewünschten XML-Dateien aus
  2. klicken Sie auf Import XML

Ergebnis

Bilder in WinCC:

Bilder in zenon:

Welche WinCC Bild Elemente werden automatisch in zenon ED angelegt?

Standard-Bildelemente

  • Line
  • Polygon
  • Polyline
  • Ellipse
  • Circle
  • Elipse Segment
  • Pie Segment
  • Elipse Arc
  • Circular Arc
  • Rectangle
  • Rounded Rectangle
  • Static Text

Tube Objects

  • Polygon tube
  • T-piece
  • Double T-piece
  • Tube bend

Smart Objects

  • I/O Field
  • Graphic Object
  • Windows Objects
  • Button

Für alle anderen WinCC Objekte wird inzenon ein Platzhalter erstellt.


XML Export Wizard VSTA

Handbuch -> Wizards -> Themen -> Export - Import -> XML Export Wizard VSTA

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem XML Export Wizard exportieren Sie alle gewünschten Module eines Projekts in einen Ordner Ihrer Wahl. Für jedes Modul wird eine eigene XML-Datei angelegt.

Der Wizard steht nur in englischer Sprache zur Verfügung.

Noch in diesem Kapitel

Wizard starten

XML-Dateien auswählen

Export


Wizard starten

Handbuch -> Wizards -> Themen -> Export - Import -> XML Export Wizard VSTA -> Wizard starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Wizard zu starten:

  • klicken Sie auf Datei -> Wizards...
    • oder drücken Sie die Tastenkombination Alt+F12
  • das Auswahlfenster mit den verfügbaren Wizards öffnet sich
  • wählen Sie das Verzeichnis Export/Import

  • wählen Sie dort XML Export Wizard

  • klicken Sie auf OK
  • der Wizard startet mit der Willkommensseite und zeigt an:
    • eine kurze Anleitung
    • die zenon Version
    • den Namen des Projekts, aus dem exportiert wird
    • Projekt-GUID
    • Projekt-Pfad

  • die Pfeiltaste führt Sie Schritt für Schritt durch den Wizard
    • alternativ öffnet ein Klick auf einen Karteireiter die jeweilige Einstellung
  • um die Taste Export zu aktivieren, muss die Seite Export XML progress geöffnet sein


XML-Dateien auswählen

Handbuch -> Wizards -> Themen -> Export - Import -> XML Export Wizard VSTA -> XML-Dateien auswählen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wählen Sie, welche Module des Projekts exportiert werden sollen:

  • klick Sie auf Select Directory, um den den Ordner für den Export zu definieren
  • wählen Sie durch Aktivieren der Checkboxen die Module und Elemente, die exportiert werden sollen (bei Badraf nach unten scrollen)


Export

Handbuch -> Wizards -> Themen -> Export - Import -> XML Export Wizard VSTA -> Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Export zu starten:

  • klicken Sie auf die Schaltfläche Export
  • die gewünschten Module werden exportiert
  • im Ausgabefenster wird angezeigt, welche Module mit welchem Erfolg exportiert werden
  • der Wizard schließt sich 3 Sekunden nach Ende des Exports automatisch


XML Import Wizard

Handbuch -> Wizards -> Themen -> Export - Import -> XML Import Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Wizard unterstützt Sie beim Import von Variablen, Funktionen, Bildern und Skripten aus einer XML-Datei.

attention Achtung

Dieser Wizard unterstützt kein Verteiltes Engineering und ist bei Multiuser-Projekten nicht anwendbar.


Language table

Handbuch -> Wizards -> Themen -> Language table

Wizards für die Sprachumschaltung.

Noch in diesem Kapitel

Schlüsselwörter Wizard - Language Text Wizard


Schlüsselwörter Wizard - Language Text Wizard

Handbuch -> Wizards -> Themen -> Language table -> Schlüsselwörter Wizard - Language Text Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Wizard sucht nach Texten und Schlüsselwörtern und erzeugt Textlisten.

Dieser Wizard macht aus Texten Schlüsselwörter.

Das Projekt wird nach Texten durchsucht und diese Texte werden in Schlüsselwörter umgewandelt (mit einem @ versehen).

Das Projekt wird nach Schlüsselwörtern durchsucht. Diese Schlüsselwörter werden in die Sprachtabelle eingetragen.


Pharmaceutical

Handbuch -> Wizards -> Themen -> Pharmaceutical

Wizards für die Pharmazeutische Industrie.

Noch in diesem Kapitel

Pharmaceutical Wizard


Pharmaceutical Wizard

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Pharmaceutical Wizard ermöglicht die Verwaltung von validierten Projekten der Pharmazeutischen Industrie. Er fasst die für ein Good Maufacturing Process (GMP) Projekt relevanten Einstellungen zusammen. Diese können hier verwaltet und geändert werden. Die Einstellungen werden entweder über ein bestehendes Projekt oder über eine Konfigurationsdatei in den Wizard geladen.

Folgende Einstellungen werden verwaltet:

  • Allgemeine Projekteinstellungen
  • Benutzerverwaltung
  • Benutzergruppen
  • Einstellungen für die Chronologische Ereignisliste
  • Einstellungen für die Alarmmeldeliste
  • XML-Vorlagen

Im Wizard projektierte Einstellungen können :

  • ins aktiven Projekt zurückgeschrieben werden
  • in einem neuen Projekt gespeichert werden
  • in einer spezieller Konfigurationsdatei gespeichert werden
    Diese im Wizard erzeugten Konfigurationsdateien können immer wieder verwendet und erweitert werden, sind aber nur mit dem Wizard lesbar und veränderbar.

Noch in diesem Kapitel

Wizard starten

Welcome

Settings

Project properties

User administration

User groups

CEL & Alarms

Templates I

Templates II

Finish


Wizard starten

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> Wizard starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Wizard zu starten:

  1. klicken Sie auf Datei -> Wizards...

    oder drücken Sie die Tastenkombination Alt+F12

  2. das Auswahlfenster mit den verfügbaren Wizards öffnet sich
  3. wählen Sie das Verzeichnis Pharmaceutical
  4. wählen Sie dort Pharmaceutical Wizard

  5. klicken Sie auf OK
  6. der Wizard startet mit der Willkommensseite


Welcome

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> Welcome

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Registerkarte Welcome informiert über Leistung und Nutzung des Wizards.

Die Navigation durch den Wizard erfolgt über Klicks auf die einzelnen Registerkarten oder Schritt für Schritt per Klick auf die Pfeiltasten.

Klick auf Cancel beendet den Wizard. Alle seit der letzten Speicherung in einer Datei oder einem Projekt gemachten Änderungen werden verworfen.


Settings

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> Settings

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden:

  • Einstellungen geladen
  • Projektbeschreibungen angepasst

Parameter

Beschreibung

Configuration

Festlegung, welches Projekt bearbeitet wird.

Load from active project

Lädt Einstellungen des im Arbeitsbereich aktiven Projekts in den Wizard.

Load from configuration file

Lädt Daten aus einer gespeicherten Konfigurationsdatei (*.cof). Die Datei wird aus der Liste ausgewählt. Die Liste zeigt alle im gewählten Ordner (Select directory) vorhandenen Konfigurationsdateien.

Info: Konfigurationsdateien können nur mit dem Wizard gelesen, erstellt und geändert werden.

Select directory

Öffnet Dateiauswahldialog, um den Ordner auszuwählen, in dem sich die gewünschten Konfigurationsdateien (*.cof) befinden. Diese werden in der Listen unter der Schaltfläche angezeigt.

Templates

Einstellungen für XML- und XRS-Vorlagen.

Project description

Angaben zum Projekt, wie im Dialog der Eigenschaft Projektbeschreibung definiert.

Interne ID: Settings

Projektbeschreibung

Der Konfigurationsdialog für die Projekt-Information wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Wird vom geladenen Projekt übernommen und kann hier geändert werden. alle Änderungen werden zur Kontrolle in der Registerkarte Finish angezeigt.

Author

Autor des Projekts.

Manager

Projektmanager.

Company

Unternehmen.

Comment

Kommentare.


Project properties

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> Project properties

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellungen für:

  • Netzwerk
  • Bedienberechtigung im Netzwerk
  • Änderungshistorie

Parameter

Beschreibung

Network

Interne ID: Project properties

Netzwerk

Interne ID: Project properties

Netzwerk

Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Active

Interne ID: Project properties

Netzwerk aktiv

Interne ID: Project properties

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Server name

Interne ID: Project properties

Server

Interne ID: Project properties

Server

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Standby name

Interne ID: Project properties

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Redundancy type

Interne ID: Project properties

Redundanztyp

Interne ID: Project properties

Redundanztyp

Nur verfügbar, wenn bei der Eigenschaft Standby ein Rechner eingetragen wurde.

Interne ID: Project properties

Standby

Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

Interne ID: Project properties

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
Achtung: Server und Standby müssen identische Systemzeit haben.
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

zenon unterstützt zwei Redundanztypen:

Softwareredundanz: Das System besteht aus einer Steuerung und zwei redundanten Leitsystem-Rechnern. Beide Rechner müssen Verbindung zur Steuerung haben. Beide Rechner kommunizieren mit der Steuerung und halten gleichzeitig die Daten aus der Steuerung aktuell. Die Kommunikation zur Steuerung übernimmt der Rechner mit Server-Funktion. Der Server kommuniziert also bidirektional, der Standby unidirektional. Fällt der Server aus, übernimmt der Standby-Server die bidirektionale Kommunikation mit der Steuerung.

Hardwareredundanz: Das System besteht aus zwei redundanten Steuerungen und zwei redundanten Leitsystem-Rechnern. Jeder Rechner kommuniziert mit einer Steuerung bidirektional. Beide Rechner und beide Steuerungen gleichen ihre Daten ab. Fällt eine Komponente im ersten System aus, übernimmt das zweite System.

Default: Softwareredundanz

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn bei der Eigenschaft Standby ein Rechner eingetragen wurde.

zenon unterstützt zwei Redundanztypen:

Softwareredundanz: Das System besteht aus einer Steuerung und zwei redundanten Leitsystem-Rechnern. Beide Rechner müssen Verbindung zur Steuerung haben. Beide Rechner kommunizieren mit der Steuerung und halten gleichzeitig die Daten aus der Steuerung aktuell. Die Kommunikation zur Steuerung übernimmt der Rechner mit Server-Funktion. Der Server kommuniziert also bidirektional, der Standby unidirektional. Fällt der Server aus, übernimmt der Standby-Server die bidirektionale Kommunikation mit der Steuerung.

Hardwareredundanz: Das System besteht aus zwei redundanten Steuerungen und zwei redundanten Leitsystem-Rechnern. Jeder Rechner kommuniziert mit einer Steuerung bidirektional. Beide Rechner und beide Steuerungen gleichen ihre Daten ab. Fällt eine Komponente im ersten System aus, übernimmt das zweite System.

Default: Softwareredundanz

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Network authorization

Interne ID: Project properties

Bedienberechtigung

Interne ID: Project properties

Bedienberechtigung

Eigenschaften für die Bedienberechtigung im Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaften für die Bedienberechtigung im Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Active

Interne ID: Project properties

Bedienberechtigung aktiv

Interne ID: Project properties

Bedienberechtigung aktiv

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Timeout for request [s]

Interne ID: Project properties

Timeout für Abfrage [s]

Interne ID: Project properties

Timeout für Abfrage [s]

Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
Wird die Bedienberechtigung im Netzwerk von einer Station blockiert, kann diese von einem anderen Rechner angefordert werden. Innerhalb des hier festgelegten Zeitraums muss diese Anfrage beantwortet werden. Nach Ablauf der Frist ohne Antwort erhält die anfragende Station automatisch die Berechtigung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
Wird die Bedienberechtigung im Netzwerk von einer Station blockiert, kann diese von einem anderen Rechner angefordert werden. Innerhalb des hier festgelegten Zeitraums muss diese Anfrage beantwortet werden. Nach Ablauf der Frist ohne Antwort erhält die anfragende Station automatisch die Berechtigung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Timeout for acknowlewdgement [s]

Interne ID: Project properties

Timeout für Bedienberechtigung [s]

Interne ID: Project properties

Timeout für Bedienberechtigung [s]

Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
Innerhalb dieses Zeitraumes muss sich der Rechner (Client), der die Bedienberechtigung besitzt, beim Server melden. Passiert das nicht, wird die Bedienberechtigung automatisch freigegeben.
Achtung: Dieser Wert muss kleiner sein als die in der Eigenschaft Timeout [s] eingestellte Zeit.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
Innerhalb dieses Zeitraumes muss sich der Rechner (Client), der die Bedienberechtigung besitzt, beim Server melden. Passiert das nicht, wird die Bedienberechtigung automatisch freigegeben.
Achtung: Dieser Wert muss kleiner sein als die in der Eigenschaft Timeout [s] eingestellte Zeit.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

History of changes

Interne ID: Project properties

Änderungshistorie

Interne ID: Project properties

Änderungshistorie

Eigenschaften für die Änderungs-Historie.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaften für die Änderungs-Historie.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Active

Interne ID: Project properties

Änderungshistorie aktiv

Interne ID: Project properties

Änderungshistorie aktiv

Aktiv: Änderungen im Projekt werden mitprotokolliert.
Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Änderungen im Projekt werden mitprotokolliert.
Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Detailing level

Interne ID: Project properties

Detaillierungsstufe

Interne ID: Project properties

Detaillierungsstufe

Nur verfügbar, wenn die Eigenschaft Änderungshistorie aktiv aktiviert wurde.

Auswahl der Detailstufen aus Dropdownliste.

  • Objekt: Es werden lediglich die Objektnamen der geänderten Objekte aufgezeichnet. Details zu den geänderten Eigenschaften und deren Werte scheinen nicht in der Änderungshistorie auf.
  • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
  • Wertänderungen: Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsgrad. Dabei wird neben dem neuen Wert einer Eigenschaft auch deren alter Wert gespeichert. Somit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich.

Default: Eigenschaften

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn die Eigenschaft Änderungshistorie aktiv aktiviert wurde.

Auswahl der Detailstufen aus Dropdownliste.

  • Objekt: Es werden lediglich die Objektnamen der geänderten Objekte aufgezeichnet. Details zu den geänderten Eigenschaften und deren Werte scheinen nicht in der Änderungshistorie auf.
  • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
  • Wertänderungen: Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsgrad. Dabei wird neben dem neuen Wert einer Eigenschaft auch deren alter Wert gespeichert. Somit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich.

Default: Eigenschaften

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


User administration

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> User administration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Einstellungen für die Benutzerverwaltung:

Parameter

Beschreibung

User administration

Interne ID: User administration

Benutzerverwaltung

Interne ID: User administration

Benutzerverwaltung

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Delete users

Interne ID: User administration

Löschen von Benutzern

Interne ID: User administration

Löschen von Benutzern

Aktiv: Löschen eines Benutzers in der Runtime ist erlaubt.
Inaktiv: Benutzer können nur gelöscht markiert werden. Die Benutzer bleiben dabei in der Liste der Benutzer, sind allerdings für die Bedienung in der Runtime nicht mehr gültig (nach FDA Richtlinie).
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Löschen eines Benutzers in der Runtime ist erlaubt.
Inaktiv: Benutzer können nur gelöscht markiert werden. Die Benutzer bleiben dabei in der Liste der Benutzer, sind allerdings für die Bedienung in der Runtime nicht mehr gültig (nach FDA Richtlinie).
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Minimum password length

Interne ID: User administration

Min. Passwortlänge

Interne ID: User administration

Min. Passwortlänge

Zeichenanzahl, die ein Passwort mindestens haben muss.
Minimum: 0.
Maximum: 20.
Default: 6.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zeichenanzahl, die ein Passwort mindestens haben muss.
Minimum: 0.
Maximum: 20.
Default: 6.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Period of password validity [days]

Interne ID: User administration

Pwt. Gültigkeitsd.[d]

Interne ID: User administration

Pwt. Gültigkeitsd.[d]

Eingabe eines Zeitraumes (in Tagen), wie lange ein Passwort gültig ist. Nach abgelaufener Zeit muss ein neues Passwort vergeben werden.
Minimum: 0 - Das Passwort läuft nie ab und muss nicht erneuert werden. Bei dieser Einstellung wird der Wert 2147483647 auf die Systemtreibervariable "Tage bis Passwort abläuft" geschrieben.
Maximum: 4294967295.
Default: 0.
Achtung: Bei Produktionen nach den Richtlinien der FDA ist der Eintrag 0 hier nicht zulässig, da die Regeln der FDA ein zyklisches Ändern des Passworts verlangen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eingabe eines Zeitraumes (in Tagen), wie lange ein Passwort gültig ist. Nach abgelaufener Zeit muss ein neues Passwort vergeben werden.
Minimum: 0 - Das Passwort läuft nie ab und muss nicht erneuert werden. Bei dieser Einstellung wird der Wert 2147483647 auf die Systemtreibervariable "Tage bis Passwort abläuft" geschrieben.
Maximum: 4294967295.
Default: 0.
Achtung: Bei Produktionen nach den Richtlinien der FDA ist der Eintrag 0 hier nicht zulässig, da die Regeln der FDA ein zyklisches Ändern des Passworts verlangen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Number of invalid user name inputs

Interne ID: User administration

Min. Passwortlänge

Zeichenanzahl, die ein Passwort mindestens haben muss.
Minimum: 0.
Maximum: 20.
Default: 6.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Number of invalid password inputs

Interne ID: User administration

Max. Passwortfehleing.

Interne ID: User administration

Max. Passwortfehleing.

Anzahl der falschen Passwort-Eingaben.
Wird diese Anzahl überschritten, so wird der entsprechende Benutzer gesperrt. Ein entsprechender Eintrag in der Chronologischen Ereignisliste (CEL) wird erstellt. Nur ein Administrator kann ihn wieder entsperren.
Minimum: 0.
Maximum: 65535.
Default: 3.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Anzahl der falschen Passwort-Eingaben.
Wird diese Anzahl überschritten, so wird der entsprechende Benutzer gesperrt. Ein entsprechender Eintrag in der Chronologischen Ereignisliste (CEL) wird erstellt. Nur ein Administrator kann ihn wieder entsperren.
Minimum: 0.
Maximum: 65535.
Default: 3.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

User administration storage

Speicherung der Benutzerverwaltung

Selected user storage

Auswahl, wo die Benutzereinstellungen gespeichert werden:

  • Projekt
  • Active Directory (AD)
  • Active Directory Application Mode (ADAM)

ADAM connection string

Interne ID: User administration

ADAM/AD-LDS Verbindung

Interne ID: User administration

ADAM/AD-LDS Verbindung

Verbindungspfad zu ADAM bzw. AD LDS.

Der Verbindungspfad muss in folgender Form eingegeben werden: [PC-Name]:[Port]/[Organisation]

Beispiel: w3k:50000/O=700,c=com

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Verbindungspfad zu ADAM bzw. AD LDS.

Der Verbindungspfad muss in folgender Form eingegeben werden: [PC-Name]:[Port]/[Organisation]

Beispiel: w3k:50000/O=700,c=com

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

ADAM user identification

Interne ID: User administration

ADAM/AD-LDS Benutzername

Interne ID: User administration

ADAM/AD-LDS Benutzername

Benutzername eines lokalen Benutzers des ADAM/AD LDS PCs mit Administratorrechten.

Mehr zu AD-LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Benutzername eines lokalen Benutzers des ADAM/AD LDS PCs mit Administratorrechten.

Mehr zu AD-LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

ADAM password

Interne ID: User administration

ADAM/AD-LDS Passwort

Interne ID: User administration

ADAM/AD-LDS Passwort

Kennwort des lokalen Benutzers des ADAM/AD LDS PCs.

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Kennwort des lokalen Benutzers des ADAM/AD LDS PCs.

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Log out/log in

Eigenschaften für An- und Abmeldung.

Activate automatical logout

Interne ID: User administration

Automatisches Logout aktiv

Interne ID: User administration

Automatisches Logout aktiv

Aktiv: Der Benutzer wird automatisch ausgeloggt, wenn für die definierte Zeit keine Bedienaktion stattfindet.
Inaktiv: Der Benutzer wird vom System nicht automatisch ausgeloggt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Der Benutzer wird automatisch ausgeloggt, wenn für die definierte Zeit keine Bedienaktion stattfindet.
Inaktiv: Der Benutzer wird vom System nicht automatisch ausgeloggt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Activate temporary login

Interne ID: User administration

Temp. Login aktiv

Interne ID: User administration

Temp. Login aktiv

Aktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, wird er zur Eingabe seiner Kennung und seines Passworts aufgefordert.
Inaktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, erhält er die Information, dass er dazu nicht berechtigt ist.
Default: aktiv.

Hinweis: Position und Größe der Login-Maske können in der zenon6.ini unter [Befehlsgabe] Position = definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, wird er zur Eingabe seiner Kennung und seines Passworts aufgefordert.
Inaktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, erhält er die Information, dass er dazu nicht berechtigt ist.
Default: aktiv.

Hinweis: Position und Größe der Login-Maske können in der zenon6.ini unter [Befehlsgabe] Position = definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Locked buttons style

Interne ID: User administration

Gesperrte Buttons

Interne ID: User administration

Gesperrte Buttons

Nur verfügbar, wenn die Eigenschaft Temp. Login aktiv inaktiv ist.
Definiert das Aussehen von Buttons, die aufgrund der Einstellungen der Bedienberechtigung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Verriegelte Buttons (Grafische Ausprägung) kombiniert.

Interne ID: User administration

Verriegelte Buttons

Definiert das Aussehen von Buttons zur Runtime, die aufgrund einer Verriegelung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Gesperrte Buttons (Benutzerverwaltung) kombiniert.

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Diese Eigenschaft wirkt unabhängig von der Eigenschaft Grafische Kennzeichnung aktiv. Ein grauer Button kann z.B. auch ein Schlosssymbol anzeigen.

Interne ID: User administration

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn die Eigenschaft Temp. Login aktiv inaktiv ist.
Definiert das Aussehen von Buttons, die aufgrund der Einstellungen der Bedienberechtigung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Verriegelte Buttons (Grafische Ausprägung) kombiniert.

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Set names for authorization levels

Entspricht Eigenschaft Berechtigungsebenen umbenennen.

Interne ID: User administration

Berechtigungsebenen umbenennen

Den 128 Berechtigungsebenen kann neben der Nummer ein Name zugewiesen werden. Hier wird der Dialog für die Definition der Namen geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Jeder der 128 Berechtigungsebenen kann neben der Nummer ein Name zugewiesen werden. Klick in die rechte Spalte ermöglicht das Umbenennen.


User groups

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> User groups

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte weisen Sie Benutzergruppen Berechtigungsebenen zu.

Parameter | Beschreibung
User groups | Liste der Benutzergruppen
User group levels | Liste der Berechtigungsebenen
Delete | Löscht ausgewähltes Objekt ohne Sicherheitsabfrage.

Klick auf eine Benutzergruppe zeigt deren Berechtigungsebenen an. Klick in den Level ermöglicht das Editieren des Levels. Der Name wird automatisch angepasst. Klick in einen leerenLevel ermöglicht das Einfügen einer neuen Berechtigungsebene.

Mit Klick auf Delete können sowohl Gruppen als auch zugewiesene Berechtigungsebenen gelöscht werden. Beim Löschen erfolgt keine Sicherheitsabfrage.


CEL & Alarms

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> CEL & Alarms

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Konfiguration der Chronologischen Ereignisliste und der ALarmverwaltung.

Parameter

Beschreibung

Chronlogic Event List and Alarm Message List

Interne ID: CEL & Alarms

Chronologische Ereignisliste

Interne ID: CEL & Alarms

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

CEL active

Interne ID: CEL & Alarms

CEL aktiv

Interne ID: CEL & Alarms

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Update automatically

Interne ID: CEL & Alarms

Automatisch aktualisieren

Interne ID: CEL & Alarms

Automatisch aktualisieren

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Aktiv: Während die CEL in der Runtime geöffnet ist, werden neue Ereignisse sofort hinzugefügt, wenn sie auftreten.
Inaktiv: Während die CEL geöffnet ist, werden keine neuen Einträge hinzugefügt. Die neuen Einträge werden erst beim nächsten Öffnen der CEL hinzugefügt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Aktiv: Während die CEL in der Runtime geöffnet ist, werden neue Ereignisse sofort hinzugefügt, wenn sie auftreten.
Inaktiv: Während die CEL geöffnet ist, werden keine neuen Einträge hinzugefügt. Die neuen Einträge werden erst beim nächsten Öffnen der CEL hinzugefügt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Print system messages

Interne ID: CEL & Alarms

Systemmeldungen drucken

Interne ID: CEL & Alarms

Systemmeldungen drucken

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Aktiv: Beim Online-Druck werden auch Systemmeldungen ausgedruckt.
Inaktiv: Systemmeldungen werden beim Online-Druck nicht ausgedruckt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Aktiv: Beim Online-Druck werden auch Systemmeldungen ausgedruckt.
Inaktiv: Systemmeldungen werden beim Online-Druck nicht ausgedruckt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Long dynamic limit texts CEL

Interne ID: CEL & Alarms

Lange dynamische Grenzwerttexte CEL

Interne ID: CEL & Alarms

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Signature text editable

Interne ID: CEL & Alarms

Signaturtext editierbar

Interne ID: CEL & Alarms

Signaturtext editierbar

Aktiv: In der Runtime wird ein Dialog zum Editieren des Signaturtextes geöffnet.
Inaktiv: Der Signaturtext kann in der Runtime nicht geändert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: In der Runtime wird ein Dialog zum Editieren des Signaturtextes geöffnet.
Inaktiv: Der Signaturtext kann in der Runtime nicht geändert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Data storage CEL

Interne ID: CEL & Alarms

Datenspeicherung CEL

Interne ID: CEL & Alarms

Datenspeicherung CEL

Eigenschaften für die Speicherung der Einträge der Chronologischen Ereignisliste (CEL) im Hauptspeicher und auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eigenschaften für die Speicherung der Einträge der Chronologischen Ereignisliste (CEL) im Hauptspeicher und auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Size of the ringpuffer

Interne ID: CEL & Alarms

Größe des Ringpuffers

Interne ID: CEL & Alarms

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Größe des CEL-Ringpuffers. Bei Überlauf des Ringpuffers (cel.bin) werden die Einträge in das CEL-Archiv (*.cel) übertragen.
Minimum: 1
Maximum: 32767
Default: 100

Hinweis: Zur Runtime werden eventuell mehr Einträge als projektiert angezeigt, da alte Einträge erst beim Aktualisieren der Liste aus der CEL entfernt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Größe des CEL-Ringpuffers. Bei Überlauf des Ringpuffers (cel.bin) werden die Einträge in das CEL-Archiv (*.cel) übertragen.
Minimum: 1
Maximum: 32767
Default: 100

Hinweis: Zur Runtime werden eventuell mehr Einträge als projektiert angezeigt, da alte Einträge erst beim Aktualisieren der Liste aus der CEL entfernt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Save CEL data

Interne ID: CEL & Alarms

CEL-Daten speichern

Interne ID: CEL & Alarms

CEL-Daten speichern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Ringpuffer und historische Daten: Alle CEL-Einträge (*.cel) werden gespeichert.

Nur Ringpuffer: Nur eine definierte Anzahl von CEL-Einträgen (cel.bin) wird gespeichert. Die Anzahl wird über die Eigenschaft Größe des Ringpuffers definiert.
Default: Auf CE-Geräten wird nur der Ringpuffer (cel.bin) gespeichert; auf PCs werden auch die historischen Einträge (*.cel) gespeichert.
Default: Default
Die Dateien (cel.bin und *.cel) werden im Verzeichnis \Projektverzeichnis\Computername\Projektname gespeichert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Ringpuffer und historische Daten: Alle CEL-Einträge (*.cel) werden gespeichert.

Nur Ringpuffer: Nur eine definierte Anzahl von CEL-Einträgen (cel.bin) wird gespeichert. Die Anzahl wird über die Eigenschaft Größe des Ringpuffers definiert.
Default: Auf CE-Geräten wird nur der Ringpuffer (cel.bin) gespeichert; auf PCs werden auch die historischen Einträge (*.cel) gespeichert.
Default: Default
Die Dateien (cel.bin und *.cel) werden im Verzeichnis \Projektverzeichnis\Computername\Projektname gespeichert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Save ringpuffer on change

Interne ID: CEL & Alarms

Ringpuffer bei Wertänderung speichern

Interne ID: CEL & Alarms

Ringpuffer bei Wertänderung speichern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Aktiv: Jede Änderung der Daten der Chronologischen Ereignisliste (CEL) bewirkt auch das Speichern der Daten (cel.bin).
Hinweis: Damit wird bei jeder Speicherung der gesamte Ringpuffer gespeichert. Das kann - vor allem bei Flash Disks - zu erheblicher Systembelastung führen.
Inaktiv: Daten der CEL (cel.bin) werden beim Beenden der Runtime oder beim Ausführen der Funktion AML- und CEL-Ringspeicher speichern gespeichert. Empfiehlt sich vor allem bei niedriger Performance. Historische Daten (*.cel) können unabhängig von dieser Einstellung bei jeder Wertänderung gespeichert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Aktiv: Jede Änderung der Daten der Chronologischen Ereignisliste (CEL) bewirkt auch das Speichern der Daten (cel.bin).
Hinweis: Damit wird bei jeder Speicherung der gesamte Ringpuffer gespeichert. Das kann - vor allem bei Flash Disks - zu erheblicher Systembelastung führen.
Inaktiv: Daten der CEL (cel.bin) werden beim Beenden der Runtime oder beim Ausführen der Funktion AML- und CEL-Ringspeicher speichern gespeichert. Empfiehlt sich vor allem bei niedriger Performance. Historische Daten (*.cel) können unabhängig von dieser Einstellung bei jeder Wertänderung gespeichert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Logging

Interne ID: CEL & Alarms

Protokollierung

Interne ID: CEL & Alarms

Protokollierung

Allgemeine Eigenschaften für die Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Allgemeine Eigenschaften für die Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alarm acknowledgement

Interne ID: CEL & Alarms

Alarm-Quittierung

Interne ID: CEL & Alarms

Alarm-Quittierung

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Wird ein Alarm quittiert, erfolgt ein Eintrag in die Chronologische Ereignisliste (CEL).
Inaktiv: Das Quittieren von Alarmen führt zu keinem Eintrag in der CEL.
Default: inaktiv.

Interne ID: CEL & Alarms

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Wird ein Alarm quittiert, erfolgt ein Eintrag in die Chronologische Ereignisliste (CEL).
Inaktiv: Das Quittieren von Alarmen führt zu keinem Eintrag in der CEL.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Function Set SV

Interne ID: CEL & Alarms

Funktion SW-Setzen

Interne ID: CEL & Alarms

Funktion SW-Setzen

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
Default: inaktiv
Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
Default: inaktiv
Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Send recipes

Interne ID: CEL & Alarms

Rezepte absetzen

Interne ID: CEL & Alarms

Rezepte absetzen

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Keine Protokollierung: Das Absetzen von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
Rezepte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts in der CEL protokolliert.
Rezepte und Werte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts sowie den Namen und alten und neuen Werten der Variablen in der CEL protokolliert.
Default: keine Protokollierung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Keine Protokollierung: Das Absetzen von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
Rezepte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts in der CEL protokolliert.
Rezepte und Werte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts sowie den Namen und alten und neuen Werten der Variablen in der CEL protokolliert.
Default: keine Protokollierung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Change recipes

Interne ID: CEL & Alarms

Rezepte ändern

Interne ID: CEL & Alarms

Rezepte ändern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Keine Protokollierung: Das Ändern von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
Rezepte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts in der CEL protokolliert.
Rezepte und Werte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts sowie den Namen und alten und neuen Werten der geänderten Variablen in der CEL protokolliert.
Default: keine Protokollierung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Keine Protokollierung: Das Ändern von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
Rezepte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts in der CEL protokolliert.
Rezepte und Werte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts sowie den Namen und alten und neuen Werten der geänderten Variablen in der CEL protokolliert.
Default: keine Protokollierung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Alarm groups

Alarm/Ereignis-Gruppen

Add

Fügt die im Eingabefeld eingetragene Zeichenfolge als neue Alarm/Ereignis-Gruppe hinzu. Hinzufügen kann auch über die Taste Eingabe erfolgen.

Remove

Löscht markierte Alarm/Ereignis-Gruppe.

Alarm classes

Alarm/Ereignis-Klassen

Add

Fügt die im Eingabefeld eingetragene Zeichenfolge als neue Alarm/Ereignis-Klasse hinzu. Hinzufügen kann auch über die Taste Eingabe erfolgen.

Remove

Löscht markierte Alarm/Ereignis-Klasse.


Templates I

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> Templates I

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte können folgende Elemente bearbeitet werden:

  • Bilder
  • Datentypen
  • Farbpaletten
  • Reaktionsmatrizen

In der jeweils rechten Liste werden die für das Element in der aktuellen Konfigurationsdatei vorhandenen XML-Dateien angezeigt und bearbeitet.

Schaltflächen | Funktion
Rechte Liste |
Export | Öffnet Dialog zum Exportieren der XML-Dateien, die im Editor über den Befehl Selektierte XML exportierten erstellt wurden.
Import | Öffnet Dialog zum Importieren von XML-Dateien, die im Editor über den Befehl Selektierte XML exportierten erstellt wurden. Import erfolgt in den Ordner %ProgrammData%\Copa-Data\zenon700\Templates\PharmaWizard
Delete | Löscht XML-Dateien, die im Editor über den Befeh.l Selektierte XML exportierten erstellt wurden.
Linke Liste |
Add | Fügt Vorlagen aus der linken Liste hinzu. Alternativ kann auch ein Doppelklick auf die Vorlage ausgeführt werden. Das Speichern im aktuellen oder einem neuen Projekt erfolgt in der Registerkarte Finish.
Remove | Entfernt Vorlage aus der Liste.


Templates II

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> Templates II

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte können folgende Elemente bearbeitet werden:

  • Symbole
  • Reports aus dem Report Generator

In der jeweils rechten Liste werden die in der aktuellen Konfigurationsdatei für das Element vorhandenen XML-Dateien angezeigt und bearbeitet. Reports werden als XRS-Dateien gespeichert.

Schaltflächen | Funktion
Rechte Liste |
Export | Öffnet Dialog zum Export von XML-Dateien, die im Editor über den Befehl Selektierte XML exportierten erstellt wurden.
Import | Öffnet Dialog zum Import von XML-Dateien, die im Editor über den Befehl Selektierte XML exportierten erstellt wurden. C:\\ProgrammData\Copa-Data\zenon700\Templates\PharmaWizard.
Delete | Löscht XML-Dateien, die im Editor über den Befehl Selektierte XML exportierten erstellt wurden.
Linke Liste |
Add | Fügt Vorlagen aus der linken Liste hinzu. ALternativ kann auch ein Doppelklick auf die Vorlage ausgeführt werden. Das Speichern im aktuellen oder einem neuen Projekt erfolgt in der Registerkarte Finish.
Remove | Entfernt Vorlage aus der Liste.


Finish

Handbuch -> Wizards -> Themen -> Pharmaceutical -> Pharmaceutical Wizard -> Finish

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte wird:

  • die Projektbeschreibung eingetragen
  • definiert, wie die geänderten Projektierungen gespeichert werden

Parameter

Beschreibung

Project description

Angaben zum Projekt, wie in der Registerkarte Settings definiert. Nur ANzeige, keine Änderung möglich.

Author

Name des Projektanten.

Manager

Name des Managers.

Company

Unternehmen.

Comment

Kommentar zum Projekt.

Save configuration settings

Optionen zur Speicherung der im Wizard durchgeführten Änderungen.

Nachrichten-Feld

Meldungen über Erfolg/Misserfolg von Speicheraktionen.

... in current project

Alle Einstellungen werden in das aktuelle Projekt geladen. Die Einstellungen im Projekt werden dabei überschrieben.

... as new project

Ein neues Projekt mit den gesetzten Einstellungen und ausgewählten Vorlagen wird erstellt. Ein Projektname muss vorher ausgewählt werden.

... as fíle

Eine neue Konfigurationsdatei vom Dateitype *.cof wird erzeugt. Wird der Name einer bestehenden Konfigurationsdatei verwendet wird diese überschrieben.

Achtung: Die erstellten Konfigurationsdateien können nur mit dem Wizard gelesen, erstellt und geändert werden.

Name

Name der Konfigurationsdatei.


Project

Handbuch -> Wizards -> Themen -> Project

Wizards für:

  • Projekterstellung
  • den Vergleich von Projektsicherungen
  • die Erstellung einer Projektdokumentation

Noch in diesem Kapitel

Project comparison

Project Wizard

Dokumentation-Wizard


Project comparison

Handbuch -> Wizards -> Themen -> Project -> Project comparison

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

´Der Wizard ermöglicht den Vergleich von Projektsicherungen. Dabei wird ausgewertet, welche Objekte und Elemente gelöscht, hinzugefügt oder verändert wurden. Das Ergebnis kann als XML-Datei oder als HTML-Datei gespeichert und angezeigt werden.

Voraussetzungen

Der Wizard kann Projektsicherungen einlesen und vergleichen, die:

  • als ZIP-Datei gespeichert wurden
  • mit aktiver Versionierung erstellt wurden
  • mit aktivem XML-Export erstellt wurden

Um Versionierung und XML-Export zu aktivieren:

  1. öffnen Sie in den Projekteigenschaften den Knoten Allgemein

    Interne ID: Project comparison

    Allgemein

    Allgemeine Eigenschaften des Projekts.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  2. navigieren Sie zum Abschnitt Versionierung

    Interne ID: Project comparison

    Versionierung

    Eigenschaften für die Versionierung von Projektsicherungen.

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  3. aktivieren Sie die Eigenschaft Versionierung aktiv

    Interne ID: Project comparison

    Versionierung aktiv

    Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

    Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

    Inaktiv: keine Versionierung der Projektsicherungen.

    Default: inaktiv

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  4. aktivieren Sie die Eigenschaft XML-Export aktiv

    Interne ID: Project comparison

    XML-Export aktiv

    Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

    Aktiv: Bei jeder Projektsicherung wird eine XML-Datei (Version.zip) eingefügt. Diese enthält 24 XML-Dateien mit den Sicherungen der einzelnen Module.

    Hinweis: Bei Mehrplatzfähigen Projekten nur bei lokaler Sicherung.

    Default: inaktiv

    Mehr im Online-Handbuch.

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Temporäre Dateien

Während des Vergleichs entpackt der Wizard die Projektsicherungen in den temporären Ordner BackUpComparisonWorkingFolder. Dieser wird im Pfad C:\Users\Public\Documents\zenon_Projects\Worspace angelegt. Dieser temporäre Ordner wird beim Schließen des Wizards wieder gelöscht.

Noch in diesem Kapitel

Wizard starten

Welcome

Settings

Compare

Documentation


Wizard starten

Handbuch -> Wizards -> Themen -> Project -> Project comparison -> Wizard starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Wizard zu starten:

  1. klicken Sie auf Datei -> Wizards...

    oder drücken Sie die Tastenkombination Alt+F12

  2. das Auswahlfenster mit den verfügbaren Wizards öffnet sich
  3. wählen Sie das Verzeichnis Project
  4. wählen Sie dort Backup Comparison Wizard

  5. klicken Sie auf OK
  6. der Wizard startet mit der Willkommensseite


Welcome

Handbuch -> Wizards -> Themen -> Project -> Project comparison -> Welcome

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Registerkarte Welcome informiert über Leistung und Nutzung des Wizards.

Die Navigation durch den Wizard erfolgt über Klicks auf die einzelnen Registerkarten oder Schritt für Schritt per Klick auf die Pfeiltasten.

Klick auf Cancel beendet den Wizard.


Settings

Handbuch -> Wizards -> Themen -> Project -> Project comparison -> Settings

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden die beiden Projektsicherungen ausgewählt, die verglichen werden sollen, sowie die zenon Module, die in diesen Vergleich einbezogen werden sollen.

Parameter

Beschreibung

Select project backups

Auswahl der Backup-Dateien.

Latest version

Neuere Version. Klick auf Schaltfläche ... öffnet Datei-Browser zur Auswahl einer Projektsicherung.

Hinweis: Projektsicherungen befinden sich standardmäßig im Ordner %ProgramData%\COPA-DATA\SQL2008R2\BACKUP\[Project], können aber über Export in beliebige Ordner abgelegt werden.

Older version

Ältere Version. Klick auf Schaltfläche ... öffnet Datei-Browser zur Auswahl einer Projektsicherung.

Select project modules

Auswahl der Module, die verglichen werden sollen. Auswahl erfolgt über Aktivierung der Checkboxen vor den Modulen.

Diese Einstellungen werden für jeden Benutzer individuell gespeichert und sind beim nächsten Öffnen des Wizards wieder verfügbar.

Pfeiltasten

Klick auf Schaltfläche wechselt zur vorigen oder nächsten Registerkarte.

Cancel

Beendet Wizard.


Compare

Handbuch -> Wizards -> Themen -> Project -> Project comparison -> Compare

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden die Projektsicherungen auf Basis der ausgewählten Module verglichen.

Parameter

Beschreibung

Listenfeld

Im Listenfeld werden nach Klick auf die Schaltfläche Compare die Unterschiede der Projektsicherungen dargestellt.

Inhalte der Spalten:

  • Module: Name des Moduls.
  • Result: Name des Objekts.
  • Element: Anzeige und Beschreibung des Elements.
  • Parameter: Name des veränderten Parameters.
  • Old: Bisheriger Wert eines veränderten Parameters.
  • New: Neuer Wert eines veränderten Parameters.

Farbliche Kennzeichnung:

  • blau: neue Objekte und Elemente
  • rot: gelöschte Objekte und Elemente
  • grün: geänderte Objekte und Elemente
  • schwarz: unveränderte Objekte und Elemente

Navigation

Elemente für die Navigation in der Liste.

Changed elements

Aktiv: Klick auf vertikale Pfeil-Schaltfläche springt zum vorigen/nächsten geänderten Element.

Deleted elements

Aktiv: Klick auf vertikale Pfeil-Schaltfläche springt zum vorigen/nächsten gelöschten Element.

New elements

Aktiv: Klick auf vertikale Pfeil-Schaltfläche springt zum vorigen/nächsten neuen Element.

Show only differences

Aktiv: Nach Klick auf die Schaltfläche Compare werden nur die Unterschiede farblich dargestellt, gleich gebliebene Elemente werden nicht angezeigt.

Wird diese Option geändert, muss der Vergleich über Klick auf Compare neu gestartet werden.

Compare

Vergleicht die Projektsicherungen entsprechend der Auswahl und zeigt diese im Listenfeld an.

Doppelpfeiltasten vertikal

Klick auf Schaltfläche springt zum vorigen/nächsten Modul.

Pfeiltasten vertikal

Klick auf Schaltfläche springt je nach Einstellungen zum vorigen/nächsten Ergebnis der gleichen Art:

  • Changed elements
  • Deleted elements
  • New elements

Pfeiltasten horizontal

Klick auf Schaltfläche wechselt zur vorigen oder nächsten Registerkarte.

Cancel

Beendet Wizard.

Beispiel Projektvergleich:

Alle Objekte:

Einige Änderungen:

Im Modul Bilder wurde:

  • das Bild batch gelöscht
  • im Bild SYSTEM_2 ein Textelement geändert
  • im Bild START ein Button mit Name Button_1 hinzugefügt
  • im Bild ALARM nichts geändert

Nur Unterschiede:

Die Änderungen sind wie im vorigen Screenshot erkennbar. Gleich gebliebene Objekte und Elemente werden ausgeblendet.


Documentation

Handbuch -> Wizards -> Themen -> Project -> Project comparison -> Documentation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte kann das Ergebnis des Projektsicherungsvergleichs als XML-Datei oder HTML-Datei angezeigt und gespeichert werden.

Parameter

Beschreibung

Settings

Einstellungen für Typ der Dokumentation.

Create XML

Aktiv: Eine XML-Datei wird erstellt.

Create HTML

Aktiv: Eine HTML-Datei wird erstellt.

Save Path

Pfad zum Ordner, in dem die Datei gespeichert wird. Nur Anzeige. Auswahl erfolgt über Schaltfläche Compare.

Create documentation

Klick auf Schaltfläche:

  • Öffnet Datei-Browser: Wählen Sie hier den Speicherplatz und vergeben Sie einen Namen für die Dokumentationsdatei.
  • Die Dokumentation wird im gewünschten Typ gespeichert und zeigt diese im Listenfeld an.

Listenfeld

Anzeige der Dokumentation.

Pfeiltaste

Klick auf Schaltfläche wechselt zur vorigen Registerkarte.

Cancel

Beendet Wizard.

Beispiel XML-Datei

Anzeige im Wizard:

Darstellung als XML-Datei:

Beispiel HTML Datei

Bei der Erstellung einer HTML-Datei werden im Speicherpfad auch eine XML-Datei und eine XSLT Datei erstellt. Aus diesen beiden Dateien wird die HTML Datei dynamisch erzeugt:

Aufbau der HTML-Datei:


Project Wizard

Handbuch -> Wizards -> Themen -> Project -> Project Wizard

Mit den Wizard können grundlegende Objekte für neue Projekte erstellt werden. Es können konfiguriert werden:

  • Informationen zum Projekt
  • Treiber, auch mit Treiber-Variablen
  • grafische Einstellungen
  • Basis-Bilder mit Symbolen, WPF-Element, AML, CEL, Systeminformationen und einer Übersicht der Simulations-Variablen
  • Navigation

Im Wizard geänderte Einstellungen werden im Benutzerprofil des Betriebssystems gespeichert und beim nächsten Öffnen durch den gleichen Benutzer wieder geladen.

Der Wizard wird in Englisch ausgeführt, die Sprache im Projekt entspricht der des geöffneten zenon Editors. Dieser Wizard wird beim Anlegen eines neuen Projekts automatisch ausgeführt.

Noch in diesem Kapitel

Wizard starten

Welcome

Project info

Drivers

Graphic settings

Screen selection

Finish

Beispiel zur Runtime


Wizard starten

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Wizard starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Wizard wird automatisch beim Anlegen eines neuen Projekts gestartet. Er kann auch direkt im Dialog zum Starten der Wizards ausgewählt werden.

Achtung: Wird der Wizard in einem bestehenden Projekt gestartet, werden vorhandene Objekte eventuell verändert oder überschrieben.

Um den Wizard manuell zu starten:

  1. klicken Sie auf Datei -> Wizards...

    oder drücken Sie die Tastenkombination Alt+F12

  2. das Auswahlfenster mit den verfügbaren Wizards öffnet sich
  3. wählen Sie das Verzeichnis Project

  4. wählen Sie dort Project Wizard VSTA

  5. klicken Sie auf OK
  6. der Wizard startet mit der Willkommensseite

Wenn Sie den Wizard aus einem bestehenden Projekt aus aufrufen, erhalten Sie einen Warnhinweis:

Mit Klick auf Ja bestätigen Sie, dass Sie Veränderungen Ihrer bestehenden Konfiguration akzeptieren.


Welcome

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Welcome

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Registerkarte Welcome informiert über Leistung und Nutzung des Wizards.

Die Navigation durch den Wizard erfolgt über Klicks auf die einzelnen Registerkarten oder Schritt für Schritt per Klick auf die Pfeiltasten.

Klick auf Close beendet den Wizard.

Klick auf Overwrite erstellt das Projekt und überschreibt eventuell bestehende Objekte. Die Schaltfläche wird nur aktiv, wenn die Registerkarte Finish geöffnet wird.


Project info

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Project info

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden allgemeine Projekteinstellungen vorgenommen sowie Einstellungen für Versionierung und Änderungshistorie konfiguriert

Parameter

Beschreibung

Author

Autor des Projekts.

Manager

Zuständiger Manager.

Company

Unternehmen.

Comment

Kommentar zum Projekt.

Backup settings

Einstellungen zur Versionierung.

Versionierung

Interne ID: Project info

Versionierung aktiv

Interne ID: Project info

Versionierung aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

Inaktiv: keine Versionierung der Projektsicherungen.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

Inaktiv: keine Versionierung der Projektsicherungen.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

XML export active

Interne ID: Project info

XML-Export aktiv

Interne ID: Project info

XML-Export aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Bei jeder Projektsicherung wird eine XML-Datei (Version.zip) eingefügt. Diese enthält 24 XML-Dateien mit den Sicherungen der einzelnen Module.

Hinweis: Bei Mehrplatzfähigen Projekten nur bei lokaler Sicherung.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Bei jeder Projektsicherung wird eine XML-Datei (Version.zip) eingefügt. Diese enthält 24 XML-Dateien mit den Sicherungen der einzelnen Module.

Hinweis: Bei Mehrplatzfähigen Projekten nur bei lokaler Sicherung.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

History of changes

Einstellungen für Änderungshistorie.

Active

Interne ID: Project info

Änderungshistorie aktiv

Interne ID: Project info

Änderungshistorie aktiv

Aktiv: Änderungen im Projekt werden mitprotokolliert.
Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Änderungen im Projekt werden mitprotokolliert.
Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Detailing levels

Interne ID: Project info

Detaillierungsstufe

Interne ID: Project info

Detaillierungsstufe

Nur verfügbar, wenn die Eigenschaft Änderungshistorie aktiv aktiviert wurde.

Auswahl der Detailstufen aus Dropdownliste.

  • Objekt: Es werden lediglich die Objektnamen der geänderten Objekte aufgezeichnet. Details zu den geänderten Eigenschaften und deren Werte scheinen nicht in der Änderungshistorie auf.
  • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
  • Wertänderungen: Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsgrad. Dabei wird neben dem neuen Wert einer Eigenschaft auch deren alter Wert gespeichert. Somit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich.

Default: Eigenschaften

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar, wenn die Eigenschaft Änderungshistorie aktiv aktiviert wurde.

Auswahl der Detailstufen aus Dropdownliste.

  • Objekt: Es werden lediglich die Objektnamen der geänderten Objekte aufgezeichnet. Details zu den geänderten Eigenschaften und deren Werte scheinen nicht in der Änderungshistorie auf.
  • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
  • Wertänderungen: Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsgrad. Dabei wird neben dem neuen Wert einer Eigenschaft auch deren alter Wert gespeichert. Somit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich.

Default: Eigenschaften

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Pfeiltasten

Navigieren um eine Registerkarte vor oder zurück.

Overwrite

Erstellt Projekt und überschreibt eventuell vorhandene Objekte. Nur aktiv, wenn die Registerkarte Finish geöffnet wird.

Close

Beendet den Wizard.
Die vorgenommen Änderungen können für den aktuellen Benutzer gespeichert werden.


Drivers

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Drivers

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden die benötigten zenon Treiber ausgewählt.

Parameter

Beschreibung

Treiberliste

Liste der zenon Treiber. Auswahl erfolgt durch Klick auf den Treiber.

Driver information

Anzeige der Informationen zum ausgewählten Treiber.

Driver name

Name des Treibers, wie er im Projekt aufscheinen soll. Freie Texteingabe.

Interne ID: Drivers

Bezeichnung

Interne ID: Drivers

Bezeichnung

Eindeutige Bezeichnung des Treibers.
zenon identifiziert den Treiber über diesen Namen und nicht über den Dateinamen. So ist es möglich, den gleichen Treiber mehrmals zu laden. Das ist z.B. bei seriellen Treibern notwendig, wenn sie auf gleiche Steuerungstypen an verschiedenen seriellen Schnittstellen zugreifen müssen.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Eindeutige Bezeichnung des Treibers.
zenon identifiziert den Treiber über diesen Namen und nicht über den Dateinamen. So ist es möglich, den gleichen Treiber mehrmals zu laden. Das ist z.B. bei seriellen Treibern notwendig, wenn sie auf gleiche Steuerungstypen an verschiedenen seriellen Schnittstellen zugreifen müssen.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Add

Fügt den ausgewählten Treiber zur Liste der anzulegenden Treiber hinzu.

Remove

Löscht den ausgewählten Treiber aus der Liste der anzulegenden Treiber.

Liste anzulegender Treiber

Liste der anzulegenden Treiber mit Name, Beschreibung und Dateiname.

Create screen with driver statistic variables

Aktiv: Für jeden Treiber wird ein Bild mit Treiber-Variablen erstellt.

Pfeiltasten

Navigieren um eine Registerkarte vor oder zurück.

Overwrite

Erstellt Projekt und überschreibt eventuell vorhandene Objekte. Nur aktiv, wenn die Registerkarte Finish geöffnet wird.

Close

Beendet den Wizard.
Die vorgenommen Änderungen können für den aktuellen Benutzer gespeichert werden.


Graphic settings

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Graphic settings

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden die AUflösung sowie Einstellungen für Runtime und Touchscreens konfiguriert.

Parameter

Beschreibung

General project settings

Allgemeine grafische Einstellungen für das Projekt.

Current primary monitor size

Anzeige der aktuellen Bildschirmauflösung. Bei Mehrmonitor-Systemen wird die AUflösung des Hauptbildschirms angezeigt.

Screen resolution

Auswahl der gewünschten Bildschirmauflösung aus Dropdownliste.

Runtime title

Interne ID: Graphic settings

Treiber unsichtbar

Interne ID: Graphic settings

Treiber unsichtbar

Aktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste nicht angezeigt.

Inaktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste angezeigt.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste nicht angezeigt.

Inaktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste angezeigt.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Graphics quality

Interne ID: Graphic settings

Grafikqualität

Interne ID: Graphic settings

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Graphic settings

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: Graphic settings

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Menu position

Auswahl der Menüposition aus Dropdownliste.

Runtime settings

Einstellungen für die Runtime.

Alarm status active

Interne ID: Graphic settings

Statuszeile aktiv

Interne ID: Graphic settings

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Interne ID: Graphic settings

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Dieser Wizard aktiviert automatisch die Eigenschaft Alarmmeldeliste aktiv.

Driver invisible

Interne ID: Graphic settings

Treiber unsichtbar

Aktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste nicht angezeigt.

Inaktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste angezeigt.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Touch operation

Einstellungen für Touch-Bedienung

Multitouch

Interne ID: Graphic settings

Multitouch aktiv

Interne ID: Graphic settings

Multitouch aktiv

Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Cursor visible

Interne ID: Graphic settings

Cursor sichtbar

Interne ID: Graphic settings

Cursor sichtbar

Aktiv: Der Cursor in der Runtime ist sichtbar.
Inaktiv: Der Cursor in der Runtime ist unsichtbar. Bei Projekten mit Touchscreen kann die Darstellung des Cursors als störend empfunden und mit dieser Eigenschaft ausgeschaltet werden.
Default: aktiv.

ACHTUNG: Diese Funktionalität funktioniert nur bei Elementen des Leitsystems (Bilder, Elemente, ..) nicht aber bei Windows Standard-Elementen (Titelzeilen, Menüs, Scrollbalken, ...). Dazu muss der Cursor direkt im Betriebssystem deaktiviert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Aktiv: Der Cursor in der Runtime ist sichtbar.
Inaktiv: Der Cursor in der Runtime ist unsichtbar. Bei Projekten mit Touchscreen kann die Darstellung des Cursors als störend empfunden und mit dieser Eigenschaft ausgeschaltet werden.
Default: aktiv.

ACHTUNG: Diese Funktionalität funktioniert nur bei Elementen des Leitsystems (Bilder, Elemente, ..) nicht aber bei Windows Standard-Elementen (Titelzeilen, Menüs, Scrollbalken, ...). Dazu muss der Cursor direkt im Betriebssystem deaktiviert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Automatic keyboard

Interne ID: Graphic settings

Automatisches Keyboard

Interne ID: Graphic settings

Automatisches Keyboard

Für Projekte mit Touchscreen.
Aktiv: Es wird automatisch ein Keyboard Fenster aufgeschaltet, wenn eine Eingabe notwendig ist (z.B: beim Sollwert setzen oder einloggen).
Inaktiv: Kein Keyboard Fenster wird geöffnet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Für Projekte mit Touchscreen.
Aktiv: Es wird automatisch ein Keyboard Fenster aufgeschaltet, wenn eine Eingabe notwendig ist (z.B: beim Sollwert setzen oder einloggen).
Inaktiv: Kein Keyboard Fenster wird geöffnet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Create keyboard screen

Aktiv: Erstellt DIALOGKBD für alphanumerische Eingaben und SETVALUEKBD für numerische Eingaben. Details siehe Kapitel Bild vom Typ Keyboard anlegen. Damit diese zur Runtime verwendet werden können, muss die Option Automatic Keyboard aktiv sein.

Keybooard size (%)

Interne ID: Graphic settings

Keyboard Größe [%]

Interne ID: Graphic settings

Keyboard Größe [%]

Definiert, in welcher Größe in Prozent – ausgehend von der Originalgröße – das automatische Keyboard in der Runtime dargestellt werden soll.
Minimum: 50 %
Maximum: 300 %
Default: 100 %

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Definiert, in welcher Größe in Prozent – ausgehend von der Originalgröße – das automatische Keyboard in der Runtime dargestellt werden soll.
Minimum: 50 %
Maximum: 300 %
Default: 100 %

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Pfeiltasten

Navigieren um eine Registerkarte vor oder zurück.

Overwrite

Erstellt Projekt und überschreibt eventuell vorhandene Objekte. Nur aktiv, wenn die Registerkarte Finish geöffnet wird.

Close

Beendet den Wizard.
Die vorgenommen Änderungen können für den aktuellen Benutzer gespeichert werden.


Screen selection

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Screen selection

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte können Bilder ausgewählt werden, die im Projekt angelegt werden sollen.

Achtung: Die Bildumschaltfunktionen auf die ausgewählten Bilder werden mit den Standardeinstellungen konfiguriert. Es werden keine speziellen Einstellungen wie Filter, Variablen usw. vorgenommen.

Parameter

Beschreibung

Screen types

Konfiguration der Bilder.

Auswahlfeld

Auswahl des Bildtyps aus der Dropdownliste.

Liste Schablonen (Template)

Auswahl der Schablone für das Bild. Größe und Vorschau werden angezeigt.

Width

Breite des Bildes.

Nur Anzeige,

Height

Höhe des Bildes.

Nur Anzeige,

Vorschau

Vorschau des ausgewählten Bildtyps mit der ausgewählten Schablone. Standard wird leer angezeigt.

Eingabefeld Name

Freie Benennung des Bildnamens.

Add

Fügt Bild mit ausgewähltem Namen zur Liste der Bilder hinzu.

Remove

Entfernt ausgewähltes Bild aus Liste der Bilder.

Liste Bilder

Listet alle konfigurierten Bilder mit Name, Bildtyp und Größe auf.

Es können maximal 14 Bilder angelegt werden.

Demo project

Einstellungen für ein Beispielprojekt.

Create demo screens

Aktiv: Es werden beispielhafte Bilder für die Projektierung erstellt. Auswahl der Demo-Bilder:

  • Demo pages: Beispielseiten (wird immer erstellt)
  • Alarm message list: AML
  • Chronologic event list: CEL
  • System information: Seiten mit Systeminformationen, Anzahl abgängig von der Auflösung

Pfeiltasten

Navigieren um eine Registerkarte vor oder zurück.

Overwrite

Erstellt Projekt und überschreibt eventuell vorhandene Objekte. Nur aktiv, wenn die Registerkarte Finish geöffnet wird.

Close

Beendet den Wizard.
Die vorgenommen Änderungen können für den aktuellen Benutzer gespeichert werden.

Beispielkonfiguration


Finish

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Finish

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte wird das Projekt erstellt.

Klick auf die Schaltfläche Overwrite erstellt das Projekt entsprechend den Einstellungen in den anderen Registerkarten. Eventuell bereits vorhandene Objekte werden dabei überschrieben. Der Wizard bleibt für weitere Konfigurationen geöffnet. Um den Wizard zu beenden, klicken Sie auf Close.


Beispiel zur Runtime

Handbuch -> Wizards -> Themen -> Project -> Project Wizard -> Beispiel zur Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Folge sehen Sie zwei Beispiele, wie sich Ihre Eingaben im Wizard auf die Darstellung zur Runtime auswirken.

  • Beispiel 1: Mit aktiver Option Create demo screens.
  • Beispiel 2: Ohne Beispielbilder.

Noch in diesem Kapitel

Mit Demo-Bilder

Ohne Demo-Bilder


Mit Demo-Bilder

Mit Demo-Bilder

Startseite:

Navigation:

SIMUL Information:

Report Viewer:

AML:

CEL:

SystemInfo_1 ( je Bildschirmauflösung 1-3 Bilder):

SystemInfo_2 (1280x1024):

Treiber:


Ohne Demo-Bilder

Ohne Demo-Bilder

Startseite:

Navigation:


Dokumentation-Wizard

Handbuch -> Wizards -> Themen -> Project -> Dokumentation-Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Wizard führt Sie durch die Schritte, die nötig sind, um ein HTML-Dokument des aktiven Projektes zu erstellen.

Es kann definiert werden, welche Module im Dokument inkludiert werden sein sollen und welche nicht.

Der Wizard ist veränderbar.


Screens and Frames

Handbuch -> Wizards -> Themen -> Screens and Frames

Wizards für Bilder und Schablonen.

Noch in diesem Kapitel

Weltbild - World View Wizard


Weltbild - World View Wizard

Handbuch -> Wizards -> Themen -> Screens and Frames -> Weltbild - World View Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Wizard hilft Ihnen bei der Erstellung eines Weltbildes in einem existierenden Projekt.

Er bietet folgende Bildarten:

  • Weltbild Übersicht
  • Weltbild
  • Funktion Bildumschaltung

attention Achtung

Dieser Wizard unterstützt kein Verteiltes Engineering und ist bei Multiuser-Projekten nicht anwendbar.


Variables

Handbuch -> Wizards -> Themen -> Variables

Wizards für Variablen.

Noch in diesem Kapitel

Variable creation wizard

Driver Simulation


Variable creation wizard

Handbuch -> Wizards -> Themen -> Variables -> Variable creation wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Wizard dient zum schnellen Anlegen von vielen Variablen.

attention Achtung

Dieser Wizard unterstützt kein Verteiltes Engineering und ist bei Multiuser-Projekten nicht anwendbar.


Driver Simulation

Handbuch -> Wizards -> Themen -> Variables -> Driver Simulation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Wizard erstellt für jeden Treiber im zenon Projekt, für den ein Treibersimulationsprojekt angelegt ist, ein eigenes straton Programm. Dieses straton Programm simuliert für alle Variablenpaare des Treibers, auf die eine Substituierungsregel zutrifft, eine Direktzuweisung von Befehlsvariable auf Rückmeldevariable.

Beispiel

  • zenon Variablen:
    • Test_CO : USINT
    • Test_RV : USINT
    • Switch_CO: USINT
    • Switch_RV: LREAL
  • Regel für Substituierung:
    • *_CO -> *_RV
  • Ergebnis in straton:

Noch in diesem Kapitel

Wizard starten

Welcome

Settings

Rebuild


Wizard starten

Handbuch -> Wizards -> Themen -> Variables -> Driver Simulation -> Wizard starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den Wizard zu starten:

  1. klicken Sie auf Datei -> Wizards...

    oder drücken Sie die Tastenkombination Alt+F12

  2. das Auswahlfenster mit den verfügbaren Wizards öffnet sich
  3. wählen Sie das Verzeichnis Variables
  4. wählen Sie dort Driver Simulation Wizard

  5. klicken Sie auf OK
  6. der Wizard startet mit der Willkommensseite


Welcome

Handbuch -> Wizards -> Themen -> Variables -> Driver Simulation -> Welcome

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Registerkarte Welcome informiert über Leistung und Nutzung des Wizards.

Die Navigation durch den Wizard erfolgt über Klicks auf die einzelnen Registerkarten oder Schritt für Schritt per Klick auf die Pfeiltasten.

Klick auf Close beendet den Wizard.


Settings

Handbuch -> Wizards -> Themen -> Variables -> Driver Simulation -> Settings

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden die Substituierungsregeln erstellt.

Parameter

Beschreibung

Execute wizard when compiling straton project

Aktiv: Sobald in zenon die Aktion Runtime-Dateien erzeugen ausgeführt wird, wird auch der Wizard ausgeführt.

Hinweis: Die Logik zum Erstellen des straton Projekts läuft im Hintergrund. Die Oberfläche des Wizards wird nicht aufgeschaltet.

Drivers with simulation project

Listet alle Treiber des derzeit im zenon Editor aktiven zenon Projekts auf, für die ein Treibersimulationsprojekt angelegt wurde. Wird in dieser Liste ein Treiber ausgewählt, werden im Bereich Replacement pattern die für diesen Treiber definierten Substituierungsregeln angezeigt.

Replacement pattern

Substituierungsregeln.

COMMAND Variable

Befehlsvariable.

Es ist maximal eine Wildcard (*) erlaubt.

RESPONSE Variable

Rückmeldevariable.

Es ist maximal eine Wildcard (*) erlaubt.

Add

Fügt Regel zur Liste der Regeln hinzu.

Modify

Ermöglicht Änderung der ausgewählten Regel.

Remove

Entfernt ausgewählte Regel aus der Liste der Regeln.

Liste der Regeln

Listet definierte Regeln auf.

Pfeiltasten

Schalten zur vorherigen bzw. folgenden Registerkarte.

Close

Schließt Wizard.

Werden Regeln geändert, wird beim Beenden des Dialogs die Neuerstellung des Simulationsprojekts angeboten. Dazu wird ein Dialog aufgeschaltet:

Hinweis: Bestätigen Sie diesen Dialog mit Ja, wenn für einen Treiber alle Substituierungsregeln gelöscht werden. Simulationsprojekte ohne Substituierungsregeln werden beim automatischen Erzeugen der Runtime-Dateien in zenon nicht beachtet.


Rebuild

Handbuch -> Wizards -> Themen -> Variables -> Driver Simulation -> Rebuild

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf dieser Registerkarte kann ein Rebuild aller straton Simulationsprojekte angestoßen werden.

Klick auf die Schaltfläche Rebuild startet das Neuerstellen der Treibersimulationsprojekte für alle entsprechenden Treiber im Projekt.


Wizards erstellen und adaptieren

Handbuch -> Wizards -> Wizards erstellen und adaptieren

Wizards sind gewöhnliche Formulare, die bestimmte Funktionen im Code-Teil beinhalten. Dadurch werden die Formulare als zenon Wizard erkannt.

Die mit zenon ausgelieferten Wizards können als Grundlage für eigene Wizards dienen.

Eigene Wizards können in eigenen Ordnern abgelegt werden. Alle nötigen Informationen müssen in die Datei wizards.ini eingetragen werden. Diese kann beim Aktualisieren der Wizards mit eingebunden werden.

VBA und VSTA Wizards

Um Wizards zu erstellen sind für VBA und VSTA folgende Angaben nötig:

  • Name
  • Beschreibung
  • Kategorie
  • Anzeige im Dialog
  • Versionsnummer

Diese Funktionen werden von zenon ausgelesen, um Formulare als Wizards zu identifizieren und um die entsprechenden Informationen im Wizard-Dialog anzuzeigen.

Details zum Erstellen von VSTA-Wizards lesen Sie im Abschnitt Details VSTA-Wizards.

Name

Gibt den Wizard-Namen an, wie er im Dialog für die Wizards angezeigt wird.

Beispiel: Project Wizard VSTA

VBA | VSTA
Public Function GetWizardName() As String GetWizardName = "Project-Wizard" End Function | GetWizardName (Type string)

Beschreibung

Enthält die Beschreibung des Wizards, wie sie im Bereich "Beschreibung" des Dialogs angezeigt wird.

Beispiel: This wizard creates a simple zenon Project (V.1)

VBA | VSTA
Public Function GetWizardInfo() As String GetWizardInfo = "Wizard for creation of a project" End Function | GetWizardInfo (Type string)

Kategorie

Gibt die Kategorie an, in die der Wizard eingeordnet wird.

Zum Beispiel: Project

Hinweis: Bestehende Kategorien können verwendet werden. VBA- und VSTA-Wizards können in die die gleiche Kategorie eingeordnet werden.

VBA | VSTA
Public Function GetWizardCategory() As String GetWizardCategory = "Project" End Function | GetWizardCategory (Type string)

Anzeige im Dialog

Bestimmt, ob der Wizard im Dialog angezeigt wird oder nicht. Damit kann ein Wizard ausgeblendet werden, ohne dass alle Funktionen gelöscht oder aus dem Add-in entfernt werden müssen:

= true: wird angezeigt

= false: wird ausgeblendet

VBA | VSTA
Public Function IsZenOnWizard() As Boolean IsZenOnWizard = True End Function | IsZenOnWizard (Type bool)

Versionsnummer

Gibt die Versionsnummer aus, die bei der Beschreibung angezeigt wird. Sie wird benötigt, um das Aktualisieren der Wizards zu managen.

Beispiel: (V.1)

Hinweis: Innerhalb einer Wizard class dürfen keine Funktionen mit gleichem Namen enthalten sein. Das gilt auch, wenn sie unterschiedliche Parameter zurückmelden.

VBA | VSTA
Public Function GetWizardVersion() As Integer GetWizardVersion = 6 End Function | GetWizardVersion (Type int)

Noch in diesem Kapitel

Details VSTA-Wizard


Details VSTA-Wizard

Handbuch -> Wizards -> Wizards erstellen und adaptieren -> Details VSTA-Wizard

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VSTA Wizard

#region Wizard_Identification

/// <summary>
/// This Static method returns the name of the wizard,
/// which will be displayed in the wizard-tree.
/// </summary>
/// <returns></returns>

static public string GetWizardName()
{
string strValue = "Name of the wizard";
return strValue;
}

/// <summary>
/// This Static method returns the description of the wizard,
/// which will be displayed at the bottom of the wizard-dialog.
/// </summary>/// <returns></returns>
static public string GetWizardInfo()
{
string strValue = "A more detailed description of the wizard.";
return strValue;
}

/// <summary>
/// This static method returns the category name of the wizard,
/// which will be used as node-name in the wizards-tree.
/// </summary>
/// <returns></returns>

static public string GetWizardCategory()
{
string strValue = "Wizard category";
return strValue;
}

/// <summary>
/// This static method returns a bool which can be used to "switch" the wizard
/// on/off in the wizard dialog (false=wizard is not shown in the tree).
/// </summary>
/// <returns></returns>

static public bool IsZenOnWizard()
{
bool bValue=true;
} return bValue;

/// <summary>
/// This static method returns the version of the wizard.
/// Indicated at the bottom of the wizard-dialog.
/// </summary>
/// <returns>wizard version</returns>

static public int GetWizardVersion()
{
int nValue = 1;
return nValue;
}

/// <summary>
/// This method is called when the wizard has been selected in the
/// wizard dialog and confirmed with "OK".
/// </summary>

public void StartWizard()
{
this.Show();
}
#endregion

VB.Net

'This shared method returns the name of the wizard,
'which will be displayed in the wizard-tree.

Public Shared Function GetWizardName() As String
GetWizardName = "Name of the wizard"
End Function

'This shared method returns the description of the wizard,
'which will be displayed at the bottom of the wizard-dialog.

Public Shared Function GetWizardInfo() As String
GetWizardInfo = "A more detailed description of the wizard."
End Function

'This shared method returns the category name of the wizard,
'which will be used as node-name in the wizards-tree.

Public Shared Function GetWizardCategory() As String
GetWizardCategory = "Wizard category"
End Function

'This shared method returns a bool which can be used to "switch" the wizard
'on/off in the wizard dialog (false=wizard is not shown in the tree).

Public Shared Function IsZenOnWizard() As Boolean
IsZenOnWizard = True
End Function

'This shared method returns the version of the wizard.
'Indicated at the bottom of the wizard-dialog.

Public Shared Function GetWizardVersion() As Integer
GetWizardVersion = 1
End Function

'This method is called when the wizard has been selected in the
'wizard dialog and confirmed with "OK".

Public Sub StartWizard()
Me.Show()
End Sub

C# Workspace

Damit der Editor dynamisch eine Instanz der VSTA-Class erstellen kann, muss eine zusätzliche Funktion zum "Default" Workspace Code hinzugefügt werden. Dieses Code-Segment muss vorhanden sein, damit der Wizard nach Auswahl im Dialog angezeigt wird. Dieses Code-Segment sollte nicht modifiziert werden!

#region Wizard

/// <summary>
/// This Routine Enables the Dynamic creation of VSTA-Wizards.
/// </summary>
/// <param name="strClassname"></param>

public void StartWizard(string strClassname)
{

//Retrieve the ClassType by its Typename:

Type t = Type.GetType(strClassname);
if(t!=null)
{

//Since the ClassType has been found, let's create it.
//The wizard from ClassType %strClassname% is required
//to have a Constructor with ZenWorkspace Parameter!

object[] Params = new object[] { this.ZenWorkspace };
object Wizard = Activator.CreateInstance(t, Params);
if (Wizard != null)
{
t.InvokeMember("StartWizard", BindingFlags.Public | BindingFlags.Instance | BindingFlags.InvokeMethod, null, Wizard, null);
}
}
}
#endregion

And for the VB.Net workspace like this:
'This Routine Enables the Dynamic creation of VSTA-Wizards,
'and should not be modified or removed!

Public Sub StartWizard(ByVal strClassname As String)
Dim obClassType As Type
Dim obWizard As Object
Dim obParams(0) As Object
obClassType = Type.GetType(strClassname)
If (Not obClassType Is Nothing) Then
obParams(0) = Me.ZenWorkspace
obWizard = Activator.CreateInstance(obClassType, obParams)
If (Not obWizard Is Nothing) Then
obClassType.InvokeMember("StartWizard", System.Reflection.BindingFlags.Public Or System.Reflection.BindingFlags.Instance Or ystem.Reflection.BindingFlags.InvokeMethod, obWizard, Nothing, Nothing)
End If
End If
End Sub


Wizards aktualisieren

Handbuch -> Wizards -> Wizards aktualisieren

Bei der Installation eines Servicepacks von zenon wird automatisch das Aktualisieren der Wizards angeboten.

Bestehende Wizards werden vom Setup nicht überschrieben. Daher kann es erforderlich sein, dass Wizards manuell importiert und aktualisiert werden.

Update anfordern

Ein Update kann jederzeit auch manuell über den Eintrag Wizards aktualisieren in der Dropdownliste Datei angestoßen werden.

Parameter

Beschreibung

Wizard-Liste

Listet alle VBA- und im laufenden Add-in vorhandenen VSTA-Wizards auf.

  • Name

Name des Wizards.
  • Objektname

VBA/VSTA Objektname.
  • Vorh. Version

Aktuell genutzte Version.
  • Neue Version

Version auf die upgedatet wird.
  • Information

Informationen zum Status und zur bevorstehenden Aktion:

  • Neu: Wizard ist noch nicht in der VBA-Datei vorhanden.
  • Geändert: Eine neue Version ist verfügbar.
  • Nicht mehr gewartet: Der vorhandene Wizard ist veraltet und wird gelöscht.
  • Typ

VBA oder VSTA
  • Benutzerspezifisch

wurde Wizard vom Benutzer erstellt oder verändert

Datenquellen

Möglichkeit, eigene Ordner für eigene Wizards zu definieren. Eingetragen wird der Speicherort der individuellen wizards.ini.

Die Einträge dazu werden in der zenon.ini im Abschnitt [VSTA] bzw [VBA] als WIZARDPATH= gespeichert.

Zusätzlicher Ordner für VSTA Wizards

Individueller Speicherort für eigene VSTA Wizards.

Zusätzlicher Ordner für VBA Wizards

Individueller Speicherort für eigene VBA Wizards.

Erneut erinnert

Der Dialog wird beim nächsten Editorstart wieder aufgeschaltet.

ktualisierung starten

Die in der Wizard-Liste ausgewählten Wizards werden aktualisiert.

Abbruch

Der Dialog wird ohne Aktualisierung beendet und erst nach der nächsten Installation eines Servicepacks wieder angeboten.

Aktualität sicher stellen

Da nicht instanzierte Objekte zum Zeitpunkt der Dialogaufschaltung nicht überprüft werden können, werden einige Objekte immer zum Update angeboten. Damit wird sicher gestellt dass Sie nicht mit veralteten Versionen arbeiten. Die im Update-Dialog angezeigte Version dient nur der Information für Consulting und Entwicklung.

Wizards im Unternehmen verteilen

Wenn Sie eigene Wizards geschrieben haben, und diese auch anderen Benutzern zur Verfügung stellen möchten, dann können Sie ebenfalls diesen Mechanismus nutzen.
Dazu exportieren Sie die Wizards aus ihrer VBA/VBA Entwicklungsumgebung und legen die Exportdateien am Besten in ein freigegebenes Netzlaufwerk ab. Zur Steuerung des Imports dienen ini Dateien. Diese müssen Sie entsprechend erstellen und ebenfalls in dem Netzlaufwerk ablegen.
Die Beschreibung für den Aufbau der Dateien finden Sie hier: Für VBA und für VSTA.

Nun müssen Sie ihren Kollegen nur mehr den Speicherort zeigen und diese können die Wizards bequem in Ihren Editor importieren. Wenn Sie geänderte oder neue Wizards haben müssen Sie nur den neuen Stand exportieren, ablegen und die Versionsnummer erhöhen. Damit können Sie Wizards bequem im Unternehmen verteilen.

Mögliche Fehler beim Aktualisieren von VSTA Wizards

Fehler

Mögliche Ursachen

Im Dialog zur Aktualisierung werden keine VSTA-Wizards angezeigt
  • Nur Wizards, die sich im geladene Add-in befinden, werden aufgelistet.
    Falls VSTA-Wizards nicht angezeigt werden, muss das VSTA Add-in beim Start Editors aktiviert werden. Dazu setzen Sie in der zenon6.ini im Abschnitt [VSTA] den Eintrag LOADED= auf 1.
  • Kann der Workspace wegen Fehler im Code nicht kompiliert werden, werden keine Wizards aufgelistet.

Ein bestimmter Wizard wird nicht angezeigt.
  • Der Wizards unterstützt die benötigte Methoden nicht.
  • Der Workspace wurde nachdem der Wizards implementiert wurde noch nicht kompiliert, das laufende Add-in beinhaltet den Wizard noch nicht.

Selbst erstellte Wizards werden nicht angezigt.
  • Der konfigurierter Pfad ist falsch.
  • Die im konfigurierte Pfad aufgerufene wizards.ini ist alt oder fehlerhaft.

Noch in diesem Kapitel

Aufbau der wizards.ini


Aufbau der wizards.ini

Handbuch -> Wizards -> Wizards aktualisieren -> Aufbau der wizards.ini

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aufbau der INI-Datei für die Verwaltung der Wizards in VSTA und VBA.

info Info

Diese Dokumentation steht nur in Englisch zur Verfügung.

Noch in diesem Kapitel

VSTA wizards.ini

VBA wizards.ini

Benötigte Methoden für Aktualisierung


VSTA wizards.ini

Handbuch -> Wizards -> Wizards aktualisieren -> Aufbau der wizards.ini -> VSTA wizards.ini

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

[DEFAULT]: Contains global settings

COUNT: Amount of Wizards included in the INI (Must be modified when adding/removing a Wizard to the ini

[MYWORKSPACE] Contains settings for the Workspace.cs

VERSION: Current Version

[WIZARD_X]: Contains settings of a Wizard:

NAME: Name as indicated in the Update dialog

CLASSNAME: Name of the Form-Class representing the Wizard.

VERSION: Version number

PATH:Path-expansion to location of the files.

DELETE: 1 when the Wizard is to be removed from the Workspace

FILES: The amount of files included in this wizard

FILE_X: The name of a file included in the wizard

TYPE_X: The type of the file (Required for the Form.cs and Resx File)

DEP_X: The Name of a file on which this file depends

Beispiel

[DEFAULT]

COUNT=3

[MYWORKSPACE]

VERSION=1

[WIZARD_1]

NAME=Export-Wizard

CLASSNAME=Wizard_Exportxml

VERSION=3

PATH=\Wizard_Exportxml

DELETE=0

FILES=3

FILE_1=Wizard_Exportxml.cs

TYPE_1=Form

FILE_2=Wizard_Exportxml.Designer.cs

DEP_2=Wizard_Exportxml.cs

FILE_3=Wizard_Exportxml.resx

DEP_3=Wizard_Exportxml.cs

TYPE_3=EmbeddedResource

[WIZARD_2]

NAME=Wizard_Project

CLASSNAME=Wizard_Project

VERSION=1

PATH=\Wizard_Project

DELETE=0

FILES=3

FILE_1=Wizard_Project.cs

TYPE_1=Form

FILE_2=Wizard_Project.Designer.cs

DEP_2=Wizard_Project.cs

FILE_3=Wizard_Project.resx

DEP_3=Wizard_Project.cs

TYPE_3=EmbeddedResource

[WIZARD_3]

NAME=Demo Wizard

CLASSNAME=Wizard_Demo

VERSION=1

PATH=\Wizard_Demo

DELETE=0

FILES=3

FILE_1=Wizard_Demo.cs

TYPE_1=Form

FILE_2=Wizard_Demo.Designer.cs

DEP_2=Wizard_Demo.cs

FILE_3=Wizard_Demo.resx

DEP_3=Wizard_Demo.cs

TYPE_3=EmbeddedResource


VBA wizards.ini

Handbuch -> Wizards -> Wizards aktualisieren -> Aufbau der wizards.ini -> VBA wizards.ini

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

[DEFAULT]: Contains global settings

COUNT: Amount of Wizards included in the INI (Must be modified when adding/removing a Wizard to the ini

[MYWORKSPACE] Contains settings for the Workspace.cs

VERSION: Current Version

[WIZARD_X]: Contains settings of a Wizard:

NAME: Name as indicated in the Update dialog

VERSION: Current Version

PATH:Path-expansion to location of the files.

VB_NAME: Name of the VBA-Object representing the Wizard.

VB_TYPE: 0=Form, 1=class

DELETE: 1 when the Wizard is to be removed from the Workspace

Beispiel

[DEFAULT]

COUNT=3

[MYWORKSPACE]

VERSION=3

[WIZARD_1]

NAME=Wizard for creating variables

VERSION=8

PATH=\CreateVariables\frmCreateVariables.frm

VB_NAME=frmCreateVariables

VB_TYPE=0

DELETE=0

[WIZARD_2]

NAME=Document Wizard

VERSION=12

PATH=\DocuWizard\frmDocuWizardEx.frm

VB_NAME=frmDocuWizardEx

VB_TYPE=0

DELETE=0

[WIZARD_3]

NAME=Import-Wizard

VERSION=3

PATH=\ImportWizard\frmImportWizard.frm

VB_NAME=frmImportWizard

VB_TYPE=0

DELETE=1


Benötigte Methoden für Aktualisierung

Handbuch -> Wizards -> Wizards aktualisieren -> Aufbau der wizards.ini -> Benötigte Methoden für Aktualisierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beispiel für die Methoden, die benötigt werden, damit die Wizards im Dialog für die Aktualisierung angezeigt werden:

VBA

'The following methods define the form as a control system Wizard. If IsZenOnWizard is set to false,

'the Wizard does not appear in the Wizarddialog, does not influence the Wizardupdate Dialog.

Public Function GetWizardName() As String

GetWizardName = "Empty Wizard"

End Function

Public Function GetWizardInfo() As String

GetWizardInfo = "<TODO: Add description here>"

End Function

Public Function GetWizardCategory() As String

GetWizardCategory = "<TODO: Add category-information here>"

End Function

Public Function IsZenonWizard() As Boolean

IsZenonWizard = False

End Function

Public Function GetWizardVersion() As Integer

GetWizardVersion = 6

End Function

VSTA

#region Wizard_Identification

/// <summary>

/// This Static method returns the name of the wizard,

/// which will be displayed in the wizard-tree.

/// </summary>

/// <returns></returns>

static public string GetWizardName()

{

string strValue = "Demo Wizard";

return strValue;

}

/// <summary>

/// This Static method returns the description of the wizard,

/// which will be displayed at the bottom of the wizard-dialog.

/// </summary>/// <returns></returns>

static public string GetWizardInfo()

{

string strValue = "This is our Demo Wizard";

return strValue;

}

/// <summary>

/// This static method returns the category name of the wizard,

/// which will be used as node-name in the wizards-tree.

/// </summary>

/// <returns></returns>

static public string GetWizardCategory()

{

string strValue = "Wizard VSTA";

return strValue;

}

/// <summary>

/// This static method returns a bool which can be used to "switch" the wizard

/// on/off in the wizard dialog (false=wizard is not shown in the tree).

/// </summary>

/// <returns></returns>

static public bool IsZenOnWizard()

{

bool bValue = false;

return bValue;

}

/// <summary>

/// This static method returns the version of the wizard.

/// Indicated at the bottom of the wizard-dialog.

/// </summary>

/// <returns>wizard version</returns>

static public int GetWizardVersion()

{

int nValue = 1;

return nValue;

}

/// <summary>

/// This method is called when the wizard has been selected in the

/// wizard dialog and confirmed with "OK".

/// </summary>

public void StartWizard()

{

this.Show();

}

#endregion


Zeitsteuerung

Handbuch -> Zeitsteuerung

In der Zeitsteuerung werden alle Funktionsaufrufe, die zu einem definierten (fixen) Zeitpunkt oder zyklisch ausgeführt werden sollen, festgelegt.
So können zum Beispiel sensible Produktionsdaten täglich auf ein Netzlaufwerk am Server gesichert werden.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Zeit-Funktion neu | Legt eine neue Funktion zur Zeitsteuerung an.
XML exportieren alle... | Exportiert alle Einträge in eine XML-Datei.
XML importieren... | Importiert Einträge aus einer XML-Datei.
Editorprofil | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Projektieren im Editor

Zeitsteuerung Detailansicht Symbolleiste und Kontextmenü


Projektieren im Editor

Handbuch -> Zeitsteuerung -> Projektieren im Editor

Die Definition der Zeitsteuerung erfolgt nach der Anwahl der Verzweigung Zeitsteuerung im Projektmanager. Bereits bestehende Zeit-Funktionen werden nach der Auswahl im Detailbereich angezeigt.

Mit dem Kontextmenü und dem Befehl Zeit-Funktion neu lässt sich eine neue Zeit-Funktion erstellen.

Im Eigenschaftenfenster werden nun die Eigenschaften der neuen Zeit-Funktion angezeigt und können geändert werden.

Die einzelnen Eigenschaften werden in der Eigenschaften-Hilfe detailliert beschrieben.

Hinweis: Monatswechsel und Jahreswechsel beziehen sich auf das eingestellte Ausführungsdatum und nicht auf den konkreten Wechsel zum 01. 01. 00:00 Uhr. Soll der Wechsel zu exakt diesem Zeitpunkt ausgeführt werden, muss die Projektierung für diesen Zeitpunkt angelegt werden, z.B. 01. 01. 2012 00:00:00 Uhr.


Zeitsteuerung Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Zeitsteuerung -> Zeitsteuerung Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Zeit-Funktion neu | Fügt eine neue Zeit-Funktion in die Liste ein.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert aus XML-Datei.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


zenon Logic

Handbuch -> zenon Logic

zenon Logic ist die in zenon integrierte Programmierumgebung nach IEC 61131. Sie steht als Editor und Runtime (Soft-SPS) zur Verfügung.

tutorial Lizenzinformation

In Editor und Runtime lizenzpflichtig.

Hinweis: 8 Tags sind in Standardlizenz enthalten. Details zur Lizenzierung siehe Abschnitt Lizenzierung.

Noch in diesem Kapitel

Grundlagen zenon Logic Workbench (IEC 61131-3)

zenon Logic Workbench

zenon Logic Runtime (Soft SPS)

zenon Logic Runtime Manager


Grundlagen zenon Logic Workbench (IEC 61131-3)

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Logic ist eine IEC 61131-3 Programmierumgebung für die unterschiedlichsten Zielsysteme mit zenon Logic Laufzeit-Kernel. Im Fall von zenon ist der zenon Logic Laufzeit-Kernel als Soft-SPS für PC- und CE-Plattformen ausgeführt.
Mit der zenon Logic Entwicklungsumgebung - der so genannten Workbench - können Steuerungen in den fünf definierten Sprachen der IEC 61131-3 projektiert und programmiert werden.

Kontextmenü Projektmanager

Menüpunkt | Aktion
zenon Logic Projekt neu | Öffnet den Assistenten zum Anlegen eines neuen zenon Logic Projektes.
XML importieren... | Importiert Einträge aus einer XML-Datei. Achtung: Bei XML-Import muss online change deaktiviert werden, damit das Nachladen der in der zenon Logic Variablen funktioniert.
Externes zenon Logic Projekt importieren... | Öffnet den Dialog zur Auswahl eines zenon Logic Projektordners.
Editorprofile | Öffnet die Dropdownliste mit vordefinierten Editorprofilen.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Allgemeine Informationen zu diesem Hilfekapitel

zenon Logic Allgemein

zenon Logic Detailansicht Symbolleiste und Kontextmenü

Erste Schritte mit zenon Logic in zenon

Variablenhandling

Arrays

Daten-Strukturen

Verteiltes Engineering (Mehrplatzfähigkeit)

Wiederverwenden von Projekten


Allgemeine Informationen zu diesem Hilfekapitel

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Allgemeine Informationen zu diesem Hilfekapitel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Kapitel bietet Ihnen einen schnellen Einstieg in den Umgang mit zenon Logic in Verbindung mit der integrierten Lösung mit zenon. Es ist keine Anleitung für die Anwendung der Programmiersprachen, Funktionen oder Funktionsblöcken. Verwenden Sie die äußerst umfangreiche Hilfefunktion direkt in der zenon Logic Workbench (IEC 61131-3 Programmierumgebung).

Die zenon Logic Workbench bietet eine umfangreiche Hilfefunktion. Die Hilfe kann über den Menüpunkt Hilfe der zenon Logic Workbench oder hier aufgerufen werden. Um ein Hilfekapitel zu einem bestimmten Thema (z.B. Funktionsbaustein) aufzurufen, markieren Sie diesen per Mausklick und drücken Sie anschließend F1.

Die in zenon integrierte zenon Logic Workbench hat unabhängig vom I/O bzw. TAG Ausbau des zenon Editors keine TAG-Limitierung.


zenon Logic Allgemein

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> zenon Logic Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Logic ist eine IEC 61131-3 Programmierumgebung für die unterschiedlichsten Zielsysteme mit zenon Logic Laufzeit-Kernel. Im Fall von zenon ist der zenon Logic Laufzeit-Kernel als Soft-SPS für PC- und CE-Plattformen ausgeführt.

zenon Logic Workbench

Die zenon Logic Workbench ist das Werkzeug zur Programmierung Ihrer zenon Logic SPS. Die zenon Logic Workbench wird im zenon Editor gestartet. Es stehen alle fünf in der IEC 61131-3 definierten Sprachen zur Verfügung:

Abkürzung | Langform der Sprache
SFC | Sequential Function Chart (Ablaufsprache - AS)
FBD | Function Block Diagram (Funktionsplan - FUP)
LD | Ladder Diagram (Kontaktplan - KOP)
ST | Structured Text (Strukturierter Text - ST)
IL | Instruction List (Anweisungsliste - AWL)

IEC 61131-3

Der Teil 3 der IEC 61131 beschreibt die Syntax und Semantik von Programmiersprachen für programmierbare Steuerungen, die im Teil 1 der IEC 61131 definiert sind.

zenon Logic Runtime

Die zenon Logic Runtime ist das Zielsystem und führt den kompilierten Code der zenon Logic Workbench aus. Es gibt die zenon Logic Soft-SPS für den PC (Windows® XP, XPe, Vista, Server) und für Windows® CE Plattformen. Neben der Soft-SPS gibt es auch Hardware-SPS, die den zenon Logic Laufzeit-Kernel als OEM Software implementiert haben. Die Hersteller dieser Hardware-SPS finden Sie auf www.copalp.com.

Mehr Informationen über die zenon Logic Runtime finden Sie hier: zenon Logic Runtime (Soft SPS)


zenon Logic Detailansicht Symbolleiste und Kontextmenü

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> zenon Logic Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
zenon Logic Projekt neu | Öffnet den Dialog zur Erstellung eines neues Projektes, legt es in der Liste ab und öffnet die zenon Logic Workbench mit dem neuen Projekt.
zenon Logic Projekt in Workbench öffnen | öffnet das ausgewählte Projekt in der zenon Logic Workbench .
Löschen | Löscht ausgewählte Einträge nach einer Sicherheitsabfrage.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Text in selektierter Spalte ersetzen | Öffnet Dialog zum Suchen und Ersetzen von Texten.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
XML importieren | Importiert aus XML-Datei. Achtung: Bei XML-Import muss online change deaktiviert werden, damit das Nachladen der in der zenon Logic Variablen funktioniert.
Externes zenon Logic Projekt importieren | Öffnet ein Fenster zur Auswahl des Projektordners.
Alle Filter entfernen | Entfernt alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Erste Schritte mit zenon Logic in zenon

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Erste Schritte mit zenon Logic in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier werden die Schritte erklärt, um ein zenon Logic Projekt im zenon Editor anzulegen und in zenon zu konfigurieren und zu bearbeiten. Wenn Sie das erste Mal mit zenon Logic in zenon zu arbeiten, empfehlen wir, dieser Anleitung zu folgen.

Noch in diesem Kapitel

Anlegen eines zenon Logic Projekts in einem zenon Projekt

Bearbeiten eines zenon Logic Projekts

Löschen eines zenon Logic Projekts

Aufbau der Workbench


Anlegen eines zenon Logic Projekts in einem zenon Projekt

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Erste Schritte mit zenon Logic in zenon -> Anlegen eines zenon Logic Projekts in einem zenon Projekt

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein neues zenon Logic Projekt anzulegen:

  1. führen Sie einen Rechtsklick auf den Knoten zenon Logic (IEC 61131-3) oder in dessene Detailansicht aus
  2. wählen Sie im Kontextmenü oder in der Symbolleiste den Befehl zenon Logic Projekt neu...
  3. der Konfigurationsdialog wird geöffnet
  4. vergeben Sie einen gültigen Namen
  5. wählen Sie den gewünschten Treiber
    • straton Treiber werden automatisch konfiguriert
    • für IEC Treiber wird nach dem Beenden des Dialogs der Konfigurationsdialog geöffnet
  6. erstellen Sie mit Klick auf Fertigstellen das Projekt

info Info

Die Eigenschaften des zenon Logic Projektes im zenon Projekt stellen Sie im Eigenschaften-Fenster des zenon Editors ein. Die Beschreibung der einzelnen Eigenschaften finden Sie in der Eigenschaften-Hilfe.

Die Eigenschaften des zenon Logic Projekts selbst ändern Sie in dessen Projekteinstellungen. Öffnen Sie dafür die Projektparameter in der Workbench über Projekt/Projekt-Parameter im Hauptmenü.

Dialog Projekt neu

Parameter

Beschreibung

Name

Frei definierbarer Namen für das zenon Logic Projekt.

Hinweis: Der Name

  • besteht aus Buchstaben
  • darf nicht länger als 15 Zeichen sein
  • darf nicht leer sein
  • darf nur gültige Zeichen enthalten:
  • ungültig sind: alle Ziffern und Sonderzeichen wie \ / , ; ß ä ö ü : * ? " < > | ( )
  • ein Punkt ist nur im Namen, nicht aber als erstes Zeichen zulässig
  • Die Schaltfläche Fertigstellen ist nur dann aktiv, wenn ein zulässiger Name eingegeben wird.

Treiber

Auswahl des Treibers. Sie haben Sie die Wahl zwischen:

  • stratonNG (Default):
    legt eine neue Verbindung mit dem korrekten Projektnamen, dem zenon Logic Runtime-Port und der IP-ADresse 127.0.0.1 an
  • straton32:
    legt eine neue Verbindung mit zenon Logic Runtime-Port und der IP-ADresse 127.0.0.1 an
  • IEC870:
    öffnet Konfigurationsdialog
  • IRC850:
    öffnet Konfigurationsdialog

Diese Auswahl definiert die spätere Runtime-Kommunikation zwischen zenon Logic und zenon. Außerdem wird darauf basierend das Anlegen der Bedienen und Beobachten (B und B) Variablen ausgelegt:

  • namensbasierend beim STRATON Treiber,
  • adressbasierend beim IEC Treiber

Fertigstellen

Erstellt das neue zenon Logic Projekt.

Abbrechen

Bricht Projekterstellung ab.

Hilfe

Öffnet Online-Hilfe.

Treiberauswahl

Entscheidunghshilfe für die Treiberauswahl:

Treiber

Eigenschaften

straton32 Treiber:

Ethernet TCP/IP basierend.

Vorteile:

  • kann zyklisch oder spontan (bei Wertänderung betrieben werden
  • unterstützt komplexe Datentypen (Strukturdatentypen oder Arrays)

stratonNG Treiber:

Standardtreiber für zenon Logic Projekte. Erfüllt alle Voraussetzungen wie straton32.

Darüber hinaus:

  • ermöglicht mehrere Verbindungen in einem Treiber zu mehreren Runtimes gleichzeitig (empfiehlt sich zur Nutzung unter Windows CE)
  • arbeitet performanter als der straton32 Treiber

IEC870 Treiber:

Wird meistens in der Infrastruktur-Automation verwendet.

Eigenschaften:

  • kann seriell (-101) oder über Ethernet TCP/IP (-104) betrieben werden
  • Datenverkehr ist generell spontan (bei Wertänderung)
  • komplexe Datentypen werden nicht unterstützt

IEC850 Treiber:

Nachfolger des IEC60870 Standards und umfassend objektorientiert ausgelegt.

Informationen zur Konfiguration der Treiber finden Sie in der jeweiligen Hilfe des Treibers:

  • straton32 Treiber: straton32
  • stratonNG Treiber: stratonNG
  • IEC870 Treiber: IEC870
  • IEC850 Treiber: IEC850

attention Achtung

Die Auswahl eines Treibers kann später nicht mehr rückgängig gemacht werden!

Ausnahme: Wechsel vom straton32 zum stratonNG Treiber ist möglich.

Treiber austauschen

Um einen Treiberwechsel von straton32 zu stratonNG durchzuführen:

  • wählen Sie der Detailansicht des Knotens Variablen/Treiber das zenon Logic Projekt mit dem straton 32 Treiber
  • wählen Sie im Kontextmenü Treiber austauschen
  • der Dialog zur Treiberauswahl wird geöffnet
  • es ist nur der stratonNG Treiber auswählbar
  • wählen Sie den Treiber
  • schließen Sie den Dialog
  • die Konfiguration wird in das zenon Logic Projekt übernommen


Bearbeiten eines zenon Logic Projekts

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Erste Schritte mit zenon Logic in zenon -> Bearbeiten eines zenon Logic Projekts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Doppelklick auf das entsprechende Projekt bzw. über das Kontextmenü öffnen Sie ein bestehendes zenon Logic Projekt zur Bearbeitung. Dasselbe erreichen Sie über das entsprechende Icon in der Symbolleiste im Detailfenster.


Löschen eines zenon Logic Projekts

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Erste Schritte mit zenon Logic in zenon -> Löschen eines zenon Logic Projekts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein zenon Logic Projekt zu löschen:

  1. wählen Sie im Kontextmenüs des Projekts oder in der Symbolleiste den Befehl löschen

    (Mehrfachauswahl ist möglich)

  2. bestätigen Sie die Sicherheitsabfrage, ob Sie das Projekt wirklich löschen möchten
  3. wählen Sie, ob der Treiber des Projekts gelöscht werden soll

    (Beim gleichzeitigen Löschen mehrerer Projekte das Löschen des Treibers für jedes Projekt extra abgefragt.)

attention Achtung

Beim Löschen des Treibers werden alle in zenon mit diesem Treiber verknüpften variablen ebenfalls gelöscht


Aufbau der Workbench

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Erste Schritte mit zenon Logic in zenon -> Aufbau der Workbench

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Logic Workbench gliedert sich in folgende Bereiche:

Bereich | Beschreibung
1 | In diesem Bereich werden Dokumente angezeigt und bearbeitet (Programme, Watch-Listen,...).
2 | Der Arbeitsbereich: Dokumente werde in dieser Liste angelegt und geöffnet.
3 | Das Ausgabefenster zeigt Meldungen und stellt Diagnose-Tools zur Verfügung.
4 | Im Variablen-Editor werden Variablen und Instanzen deklariert.
5 | Die Eigenschaften-Registerkarte und die Z-Anordnung werden für die Projektierung der Grafik Dokumente verwendet.
6 | Die Registerkarte Bibliotheken listet alle verfügbaren Funktionen und Funktionsblöcke auf.
7 | Die Registerkarte Spion zeigt die Online-Werte von ausgewählten Variablen während des Debuggings.
8 | Die Registerkarte Definitionen zeigt alle Definitionen.
9 | Die Registerkarte Grafik listet alle grafischen Objekte.

Jeder Bereicht (außer Bereich 1) kann mit den Befehlen aus dem Menü Ansicht ausgeblendet oder angezeigt werden.

Im mittleren Bereich befinden sich die Dokumente des Arbeitsbereichs. Sind mehrere Dokumente gleichzeitig geöffnet, wird über die Registerkarten am unter Ende des Bereichs zwischen den Dokumenten umgeschaltet. Mit der Schaltfläche X in der Titelleiste kann das aktive Dokument geschlossen werden.

Der Variablen-Editor und der Dokumenten-Bereich in der Mitte können zu jeder Zeit über die entsprechende Schaltfläche (blaues Symbol mit weißem Strich) oder einen Doppelklick in die Titelleiste maximiert werden.

Sind mehrere Dokumente im mittleren Bereich geöffnet, kann eines davon im oberen oder linken Bereich fixiert werden. Dafür führen Sie einen Rechtsklick auf die entsprechende Registerkarte aus und wählen Fixieren. Mit dem selben Menü heben Sie zu jeder Zeit die Fixierung eines Dokuments auf oder fixieren ein anderes.


Variablenhandling

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Variablenhandling

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die intelligente Integration von zenon Logic in zenon bietet herausragende Vorteile in der Projektierung von SPS- und SCADA-Projekten. Die sogenannten B&B-Variablen (Bedienen und Beobachten) aus dem SPS-System sind mit wenigen Mausklicks in zenon verfügbar. Bei Änderung der Variable (Name, Datentyp,...) wird diese sofort an das jeweils andere System weitergeleitet und aktualisiert.

Der Vorteil der Integration:

  • Einfache Handhabe von B&B-Variablen
  • Sofortige Nachführung bei Änderungen
  • Arbeitsersparnis durch Wegfall von Export/Import
  • Bessere Qualität durch Minimierung von Fehlerquellen

attention Achtung

Externe UDFBs von anderen zenon Logic Projekten sind nicht Teil des zenon Logic Projekts und damit in zenon nicht vorhanden.

Noch in diesem Kapitel

Anlegen von B und B Variablen in zenon Logic

Anlegen von B und B Variablen in zenon

Verwenden von zenon Variablen in zenon Logic

Variablennamen


Anlegen von B und B Variablen in zenon Logic

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Variablenhandling -> Anlegen von B und B Variablen in zenon Logic

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alle in der zenon Logic Workbench angelegten Variablen können als B&B (Bedienen und Beobachten) Variablen gekennzeichnet werden:

  • Lokale Programm-Variablen
  • Globale Variablen
  • Retain-Variablen (=remantente Variablen)
  • Array-Variablen
  • Struktur-Variablen
  • UDFB-Instanzen (User Defined Function Block)

Hinweis: Variablen vom Datentyp TIME können nicht als B&B Variablen deklariert werden.

attention Achtung

Bei der Verwendung von UDFB-Instanzen als B&B Variablen wird empfohlen, nur ein zenon Logic Projekt im zenon Projekt zu warten.

Werden zwei oder mehrere zenon Logic Projekte in zenon gewartet, so erscheinen die als B&B gekennzeichneten UDFBs auch als Strukturdatentypen.

Variablen als B&B kennzeichnen

Dazu sind folgende Schritte notwendig:

(Die genauen Schritte eine Variable in zenon Logic anzulegen entnehmen Sie der Online Hilfe der zenon Logic Workbench.)

  1. Führen Sie einen Rechtsklick auf die Variable in der Variablenliste aus.
  2. Wählen Sie Eigenschaften im Kontextmenü.
  3. Im folgenden Dialog aktivieren Sie die Checkbox Symbole einbetten.
  4. Wechseln Sie in der Combobox das Profil von None auf STRATON (*Bedienen und Beobachten für zenon*).
  5. Klicken Sie auf OK.

Nun ist diese B&B-Variable in der zenon Variablenliste eingetragen.

attention Achtung

Sobald eine zenon Logic Variable als B&B-Variable deklariert wurde, darf sie in der Workbench nicht mehr als Text editiert werden!

Dies führt zum Verlust von Variablendeklarationen.

Die B&B-Variable wird in zenon mit einem Präfix angezeigt. Das Präfix setzt sich wie folgt zusammen:

<zenon Logic Projektname>/<zenon Logic Programmname bzw. Global oder Retain>/<Variablenname>

attention Achtung

Variablen sind in der Zeichenlänge beschränkt. Inklusive Präfix darf der Variablenname maximal 128 Zeichen lang sein.

In Variablenliste aktivieren

Um nicht über das Kontextmenü und den Profildialog gehen zu müssen, können Sie das Profil und die Checkbox direkt in der Variablenliste in zenon Logic aktivieren.

Markieren Sie die Zelle Eigenschaften der entsprechenden Variablen. Drücken Sie Strg+F12. Somit erscheint das Profil zenon Logic in dieser Zelle. Zusätzlich muss noch in der Spalte Symb. per Doppelklick oder mit Enter die Checkbox für das Einbetten des Symbols aktiviert werden.

attention Achtung

Die Checkbox Symbole einbetten muss aktiviert sein. Variablen, bei denen diese Checkbox nicht aktiviert ist, können nicht über den STRATON Treiber von zenon kommunizieren und werden daher auch keine Werte liefern.

Zusatzattribute der Variable

Die Zusatzattribute Kennung und Beschreibung einer Variable werden ebenfalls in zenon angezeigt, wenn Sie das Profil STRATON (*Bedienen und Beobachten für zenon*) selektieren. Die Inhalte der Kennung und Beschreibung finden Sie in zenon in den Variableneigenschaften Kennung und Betriebsmittelkennung.

Arrays und Strukturvariablen

Werden Arrays oder Strukturvariablen mit dem Profil STRATON (*Bedienen und Beobachten für zenon*) markiert, werde diese ebenfalls in der zenon Variablenliste angezeigt. Allerdings müssen Sie danach noch die gewünschten Elemente der Variable aktivieren.

attention Achtung

Sollte eine B&B Variable ein Array sein, muss das Setzen von Initialwerten sehr vorsichtig erfolgen.

Empfehlung: Arrays mit Initialwerten sollten nicht als B&B deklariert werden! Ist das unumgänglich, darf der String, der die Initialwerte beschreibt, nicht länger als 1024 Zeichen sein.

UDFB-Instanzen

  1. Eingabevariablen bei UDFB Instanzen werden in zenon durch die integrierte Lösung nicht zur Verfügung gestellt.
  2. In zenon können keine Variablen einer UDFB Instanz erzeugt werden. Das ist nur möglich, indem eine Instanz dieser UDFB in zenon Logic erzeugt und das zenon Logic Profil gesetzt wird.

    UDFB-Instanzen, die mit dem Profil zenon Logic (*Bedienen und Beobachten für zenon*) markiert sind, werden nicht automatisch in zenon zur Verfügung gestellt. Für den Fall, dass Sie das möchten, müssen Sie diese Funktionalität mithilfe des folgenden Eintrags in der Datei K5DBXS.INI manuell aktivieren. Gehen Sie in der Datei K5DBXS.INI in die Sektion [XS] und tragen Sie dort ShareUDFBDatatype=1 ein.

    Wenn Sie den Eintrag deaktivieren, werden bestehende UDFB-Datentypen in einem Projekt weiterhin modifiziert. Es werden allerdings keine neuen UDFBs angelegt.

Hardware IO-Deklarationen

zenon Logic IO-Variablen können in zenon verwendet werden, wenn diese in der zenon Logic Workbench:

  • über ein Profil verfügen
  • einen Alias-Namen erhalten haben; dieser wird in zenon anstelle von %IX0.0 (board type, board index, bitnumber) verwendet
    Ein Alias ist nicht nötig, wenn das Profil zenon Logic verwendet wird und die Eigenschaft embed symbol aktiviert wurde. In diesem Fall steht die Variable auch in zenon (Editor und Runtime) zur Verfügung.

Hinweis: Wird eine I/O Gruppe in zenon Logic gelöscht, werden die Variablen vom I/O Board mit zenon Logic Profil auch in zenon gelöscht.

Achtung:

  • IO-Variablen können in zenon nicht umbenannt werden.
  • IO-Variablen für zenon Logic IO-Karten können in zenon nicht erstellt werden.
  • Der Datentyp von IO-Variablen sollte in zenon nicht geändert werden: Änderungen werden in der zenon Logic Workbench nicht übernommen.
  • Änderungen der Hardware IO-Deklarationen sollten immer in zenon Logic durchgeführt werden. In zenon kann keine neue Variable für den straton32 Treiber als Hardware I/O Variable für zenon Logic erstellt werden.


Anlegen von B und B Variablen in zenon

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Variablenhandling -> Anlegen von B und B Variablen in zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

B&B (Bedienen und Beobachten) Variablen für die Soft-SPS zenon Logic können auch in zenon deklariert werden. Legen Sie dafür eine Variable in zenon in gewohnter Weise an:

attention Achtung

Achten Sie darauf, dass die Schreibweise der Variable den Konventionen der IEC 61131-3 entspricht (keine Sonderzeichen, Umlaute,...), da ansonsten im Dialog die Schaltfläche Fertigstellen nicht freigegeben wird. Siehe auch: Variablennamen

info Info

Die in zenon deklarierten Variablen werden in zenon Logic immer im Globalen Bereich der Variablenliste eingetragen.

Änderungen an Variablen eines zenon Logic Treibers in zenon

Werden Variablen eines Treibers, der mit einem zenon Logic Projekt verknüpft ist, geändert:

  • erfolgt eine Änderungserkennung im zenon Logic Projekt
  • fragt die die zenon Logic Workbench Verbindung zur Runtime nach, ob das Projekt neu kompiliert werden soll,

Dieses Verhalten ist unabhängig davon, ob die Änderung Auswirkungen auf das zenon Logic Projekt hat.


Verwenden von zenon Variablen in zenon Logic

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Variablenhandling -> Verwenden von zenon Variablen in zenon Logic

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es ist sehr einfach möglich, Variablen aus herkömmlichen SPS-Systemen (z.B. Siemens S7 oder Beckhoff TwinCAT), die über die entsprechenden zenon Treiber in zenon eingelesen werden, in zenon Logic weiterzuverarbeiten.

Eine Möglichkeit stellt hier die Funktionalität der Zuweisung dar (siehe Zuweisungen). Die Variable aus der SPS (z.B. S7) wird per Zuweisung einer zenon Logic Variable zugewiesen. Dabei ist immer nur eine unidirektionale Kommunikation möglich.

Einfacher, schneller und bidirktional (!) werden die SPS-Variablen (z.B. von einer S7) über eine Shared Memory Verbindung zwischen zenon und zenon Logic ausgetauscht. Um die SPS-Variablen in der zenon Logic Workbench sichtbar zu schalten, müssen Sie in den Eigenschaften der Variablen das Flag extern sichtbar setzen.

Sobald diese Flag gesetzt ist, ist die Varible in der Variablenliste der zenon Logic Workbench enthalten.

attention Achtung

Beachten Sie Wechselwirkungen mit der Eigenschaft Hysterese:
Wurde für die zenon Variable eine Hysterese konfiguriert, entspricht der Wert in zenon Logic nicht dem Wert in der SPS. Es ist auch möglich, dass er nicht dem Wert in zenon entspricht:

Interne ID: Verwenden von zenon Variablen in zenon Logic

Hysterese

Eigenschaften für die Hysterese.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Ändert sich der Wert in der SPS und dabei innerhalb der konfigurierten Hystere-Bandbreite, wird er nicht an die zenon Runtime kommuniziert und damit auch nicht an zenon Logic.
  • Wird der Wert vom Benutzer in zenon geändert (z.B. über eine Funktion) und der Wert bleibt innerhalb der konfigurierten Hystere-Bandbreite, bleibt der Wert in zenon und zenon Logic gleich, ändert sich aber in der SPS.
  • Wird der Wert in zenon Logic geändert und bleibt innerhalb der konfigurierten Hystere-Bandbreite, ändert sich der Wert in der SPS und in zenon Logic, bleibt aber in zenon unverändert.
    Wenn sich in dieser Situation der Wert in der SPS ändert und innerhalb der konfigurierten Hystere-Bandbreite bleibt, exisiteren drei unterschiedliche Werte:
    einer in der SPS, einer in zenon und einer in zenon Logic.

Eine solche Variable wird in zenon Logic speziell gekennzeichnet, da diese in zenon Logic nicht mehr verändert werden kann. Die Variable hier zu verändern würde zu Problemen führen, da die Quelle dieser Variable die SPS Programmierumgebung der Fremd-SPS (z.B. Step7) ist.

attention Achtung

Vorsicht bei der Wahl des Variablennamens! Der Name einer Variable aus einer Fremd-SPS muss den IEC 61131-3 Konventionen hinsichtlich Schreibweise entsprechen. Siehe Variablennamen.

Damit die Kommunikation zur Runtime für solche Variablen auch stattfindet, muss in zenon Logic noch ein I/O Treiber - der Shared Memory Treiber - angelegt werden.

Öffnen Sie dazu die Felbuskonfiguration in der zenon Logic Workbench mit Datei -> Öffnen... -> Feldbus Konfiguration.

Über das Menü Einfügen -> Konfiguration einfügen... öffnet sich folgender Dialog:

Wählen Sie hier die Konfiguration STRATON zu zenon-RT Verbidung aus. Damit fügt sich diese Konfiguration in den Baum der Feldbuskonfiguration ein:

Nun ist gewährleistet, dass die extern sichtbaren Variablen aus zenon mit zenon Logic kommunizieren.

info Info

Beachten Sie, dass eine solche Verbindung nur lokal auf einem PC oder CE Gerät funktioniert. Es kann hier nicht mit einer entfernten zenon Logic Runtime auf einem anderen Gerät kommuniziert werden.

Arrays und Strukturvariablen

Mithilfe des zenrt Treibers werden komplexe Variablen (Arrays und Strukturvariablen) in flache Strukturen aufgelöst. Die Werte von Variablen mit gleichen Namen in zenon Logic und zenon werden über den Shared Memory Treiber ausgetauscht.

info Info

Die Funktionen zum Prüfen des Status einer Variablen und zum Dirty-Setzen werden zurzeit nicht unterstützt.

Die Statusinformationen (Zeitstempel und Statusbits) werden für komplexe Datentypen nicht unterstützt.

Wenn Sie ein Element eines Arrays oder einer Strukturvariablen als extern sichtbar kennzeichnen, wird in der zenon Logic Workbench eine einfach Variable mit entsprechendem Namen angelegt. Wenn Sie das Array oder die Strukturvariable selbst als extern sichtbar kennzeichnen, wird diese komplexe Variable in der Workbench angelegt.

info Info

Wenn Sie ein Array oder eine Strukturvariable als extern sichtbar markieren, werden die einzelnen Elemente nicht mehr in der Workbench angelegt.

In der Workbench können Sie Variablen anlegen, die '.' oder '[]' im Namen haben. Daher können Sie Variablen anlegen, die denselben Namen haben wie Variablen die aus einem Array oder einer Strukturvariable hervorgehen. In diesem Fall ist die Kommunikation mithilfe des zenrt Treibers nicht möglich, da keine eindeutige Zuordnung hergestellt werden kann.

attention Achtung

Array-Variablen in zenon, die auf einem straton32 oder stratonNG Treiber basieren, dürfen nicht mit 1 beginnen. Ein zenon Array mit der Dimension 1,2,2 wird in zenon Logic nur als einfache Variable angelegt.


Variablennamen

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Variablenhandling -> Variablennamen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablennamen müssen für zenon Logic den Bestimmungen der IEC 61131-3 folgen. Die Richtigkeit wird bei der Eingabe sowohl von zenon als auch von zenon Logic überprüft (Kommunikation über STRATON Treiber).

Hingegen muss bei Variablen von anderen Treibern (z.B. S7 TCP/IP Treiber) vom Projektanten darauf geachtet werden, dass der Variablenname den Konventionen der IEC 61131-3 entspricht (Kommunikation über Shared Memory).

Beispiele für die IEC 61131-3 Schreibweise

Zulässige Bezeichner | Unzulässige Bezeichner | Unzulässig weil:
_XYZ | __XYZ | Zwei Mal Unterstrich.
xy_z | xy__z | Zwei Mal Unterstrich.
xyz_ | xyz__ | Zwei Mal Unterstrich.
MotorOn | Motor On | Leerzeichen.
Motor_On | Motor/On | Schrägstrich.
mw10 | 1mw10 | Ziffer/Zahl zu Beginn.
xyz | #xyz | Raute.
_Motor1 | _Motor 1 | Leerzeichen.
Stoerung | Störung | Umlaut.
Ueberbruecken | Überbrücken | Umlaut.
Mo_tor | Mo-tor | Bindestrich.

Ab der Version 6.22 SP1 ist es möglich, auch Variablen zu verwenden die der IEC 61131-3 Schreibweise nicht entsprechen (freie Variablennamen). Dies ist aber mit Vorsicht zu behandeln.

Befolgen Sie dabei folgende Regeln bei der Verwendung von freien Variablennamen:

  • Variablennamen dürfen folgende Zeichen/Zeichenfolgen nicht enthalten: '(*', '*)', '//', '{' und '}'
  • Variablennamen dürfen nicht mit zwei Unterstrichen '__' beginnen
  • Werden freie Variablennamen in den Programmiersprachen ST oder IL (AWL) verwendet, müssen diesen innerhalb von geschwungenen Klammern {} stehen.
  • Werden freie Variablennamen als Struktur oder Array verwendet müssen dies innerhalb von geschwungenen Klammern {} stehen.
  • Variablen mit freiem Variablennamen mit Basis-Datentypen dürfen ohne geschwungene Klammern {} in den Programmiersprachen FBD (FUP) und LD (KOP) verwendet werden und müssen dann als globale Variablen deklariert sein.
  • Variablen mit gleichem Namen mit {} bzw. ohne {} werden als zwei unterschiedliche Variablen betrachtet.

info Info

Strukturvariablen und Arrays von Strukturvariablen mit Punkt (".") im Namen werden korrekt dargestellt. Standard-Arrays mit Schrägstrich ( "/") oder Punkt (".") im Namen zeigen keine Werte in der spy list an.


Arrays

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Arrays

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Arrays können in zenon und in zenon Logic für beide Systeme angelegt werden. Die Deklaration als B&B Variable erfolgt wie in den Kapiteln Anlegen von B und B-Variablen in zenon Logic und Anlegen von B und B-Variablen in zenon beschrieben.

attention Achtung

Array-Variablen in zenon, die auf einem straton32 oder stratonNG Treiber basieren, dürfen nicht mit 1 beginnen. Ein zenon Array mit der Dimension 1,2,2 wird in zenon Logic nur als einfache Variable angelegt.

Achten Sie beim Anlegen von Arrays in zenon Logic darauf, dass die Einzelement in zenon aktiviert werden müssen.

Klicken Sie beim Anlegen von Arrays in zenon im Dialog Arraybeginn ist 0 an, damit die Arrays in den beiden System dieselben Indizes haben.

attention Achtung

Arrays mit Initialwerten sollten nicht als B&B deklariert werden! Ist das unumgänglich, darf der String, der die Initialwerte beschreibt, nicht länger als 1024 Zeichen sein.


Daten-Strukturen

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Daten-Strukturen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Strukturdatentypen können entweder in zenon oder in der zenon LogicWorkbench angelegt werden.

info Info

Beachten Sie beim Anlegen von Strukturdatentypen in zenon die IEC 61131-3 Schreibweise, ansonsten wird der Strukturdatentyp in zenon Logic nicht angezeigt. Siehe auch Variablennamen. Die Schreibweise wird hier von zenon nicht überprüft!

info Info

Wenn Sie Strukturdatentypen in zenon Logic anlegen, so werden diese in zenon immer als verknüpft deklariert.

Legen Sie daher einen Strukturdatentyp besser in zenon an, weil Sie dann die Wahl zwischen verknüpftem und eingebetteten Datentyp haben.


Verteiltes Engineering (Mehrplatzfähigkeit)

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Verteiltes Engineering (Mehrplatzfähigkeit)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Es ist möglich, dass mehrere Projektanten gemeinsam an einem zenon Projekt arbeiten. Somit kann auch ein zenon Logic Projekt von einem Projektanten bearbeitet werden, und das restliche zenon Projekt von einem anderen.

Variablen

B&B (Bedienen und Beobachten) Variablen werden beim Verteilten Engineering vom zenon Logic Projekt separat behandelt.

Sie können Variablen wie gehabt in zenon Logic anlegen. Sollen die Variablen auch in zenon zur Verfügung stehen, müssen Sie ihnen die entsprechende Eigenschaft zuweisen (Eingebettetes Symbol, Profil zenon Logic (*Bedienen und Beobachten fürzenon*)). Danach ist die Variable in zenon neu angelegt. Sie können sie für andere Projektanten einchecken (Änderungen übernehmen). Eine eingecheckte Variable können Sie in der zenon Logic Workbench nicht mehr bearbeiten. Sie wird in der zenon Logic Variablenliste entsprechend gekennzeichnet.

Treiber

zenon Logic Treiber werden beim Verteilten Engineering ebenfalls vom zenon Logic Projekt separat behandelt. Das heißt, für Änderungen müssen Sie den STRATON Treiber auschecken (Änderungen ermöglichen).

zenon Logic Projekte

Zur Bearbeitung eines zenon Logic Projekts eines mehrplatzfähigen Projekts muss dieses ausgecheckt werden (Änderungen ermöglichen). Nach der Projektierung können Sie die Änderungen verwerfen oder übernehmen.

zenon Logic Projekte löschen

zenon Logic Projekte können auch gelöscht werden:

  • wenn sie ausgecheckt sind (Änderungen ermöglichen)
  • im Offline-Modus


Wiederverwenden von Projekten

Handbuch -> zenon Logic -> Grundlagen zenon Logic Workbench (IEC 61131-3) -> Wiederverwenden von Projekten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Logic Projekte, die mit der stand-alone Workbench von COPA-DATA erstellt wurden, können sehr einfach in ein zenon Projekt integriert werden.

Selektieren Sie im Kontextmenü der Detailansicht des Moduls zenon Logic (IEC 61131-3) den Menüpunkt Externes zenon Logic Projekt importieren.... Mit diesem Befehl können Sie ein bestehendes zenon Logic Projekt angeben (Ordner markieren) und in das bestehende zenon Projekt integrieren.

Eine weitere Möglichkeit stellt der XML Import dar. Im Kontextmenü der Detailansicht des Moduls zenon Logic (IEC 61131-3) findet man den Befehl XML importieren. Damit können zenon Logic Projekte welche per XML Export exportiert wurden, einfach in das zenon Projekt importiert werden.

Hinweis: Bei XML-Import muss online change deaktiviert werden, damit das Nachladen der in der zenon Logic Variablen funktioniert.


zenon Logic Workbench

Handbuch -> zenon Logic -> zenon Logic Workbench

In diesem Bereich finden Sie die Dokumentation für die zenon Logic Workbench. Diese steht nur als Online-Hilfe zur Verfügung.


zenon Logic Runtime (Soft SPS)

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Logic Runtime interpretiert den kompilierten SPS Code der zenon Logic Workbench. Die Runtime läuft auf Windows XP, XP embedded PCs, VISTA, Windows 7 und auf Windows CE Plattformen.
Dieses Handbuch gibt einen Überblick zur Verwendung der zenon Logic Runtime und des Konfigurationstools zenon Logic Runtime Manager.

attention Achtung

Aus Performance-Gründen benötigt die zenon Logic Runtime Version 6.22 SP0 Build 2 den straton Treiber für zenon der selben Version oder jünger. Ältere zenon Logic Runtime Versionen funktionieren weiterhin mit allen straton Treibern.

Noch in diesem Kapitel

Oberfläche

Lizenzierung

Starten der zenon Logic Runtime

zenon Logic Runtime Zyklus

Beenden der zenon Logic Runtime

Erstellen der Hot Restart Datei

Remote Systeme

zenon Logic Runtime mit Real Time Kernel (RTK)

Redundanz zenon Logic und zenon

OEM Spezifikation

Weiterleitung von Zeitstempel und der Variablen Statusinformation

zenon Logic I/O Treiber Unterstützung

zenon Logic I/O Treiber: Hot-Restart/Online Change

Fehlermeldungen


Oberfläche

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Oberfläche

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Prinzipiell ist die zenon Logic Runtime nur als Symbol im Systemtray zu sehen. Mit einem Doppelklick auf das Symbol mit dem grünen Pfeil oder über das Kontextmenü Anzeigen erscheint die zenon Logic Runtime Oberfläche.

Je nach aktuellem Zustand zeigt die Oberfläche unterschiedliche Status (läuft, Schrittmodus, Unterbrechungspunkt(e), angehalten).

Ein Balkendiagramm zeigt die Auslastung der SPS an.

Neben den Informationen zum Zustand des laufenden zenon Logic Projekts können auf der zenon Logic Runtime-Oberfläche noch folgende Aktionen durchgeführt werden:

  • Schieberegler Erlaubtes Maximum der SPS Ressourcen:erlaubtes Maximum festlegen
  • Schaltfläche Einstellungen...: ermöglicht die Konfiguration über drei Registerkarten
    • Allgemeine Einstellungen
    • Redundanz
    • Fortgeschrittene
  • Schaltfläche Start/Stopp: öffnet den Dialog zum Starten der Runtime bzw. stoppt die Runtime
  • Schaltfläche Meldungen: öffnet und schließt das Meldungsfenster

Noch in diesem Kapitel

Schieberegler Erlaubtes Maximum

Einstellungen

Meldungen


Schieberegler Erlaubtes Maximum

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Oberfläche -> Schieberegler Erlaubtes Maximum

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Schieberegler Erlaubtes Maximum dient dazu, anderen Applikation, die auf dem selben Gerät laufen - wie z.B. zenon - Systemressourcen zu garantieren.

Mit diesem Regler kann die maximal erlaubte Ausführungszeit bezogen auf die Zykluszeit eingestellt werden. Wird der Regler zum Beispiel bei einer eingestellten Zykluszeit von 10 ms auf 50% gestellt, darf der SPS-Zyklus maximal 5 ms in Anspruch nehmen. Dauert der SPS Zyklus länger als 5 ms, wird die restliche Berechnung im darauf folgenden Zyklus durchgeführt. Somit muss aus SPS Sicht ein Zyklus ausgelassen werden. Daraus ergibt sich ein Zyklenüberlauf.

Der Regler kann zwischen 10% und 100% stufenlos eingestellt werden.

Der Bargraf (PLC load) gibt an, wie hoch die SPS Auslastung bezogen auf die Einstellung des Reglers ist. Daraus lässt sich schließen, wie der Regler für optimales Tuning verschoben werden muss.

SPS-Auslastung hoch (Bargraf zwischen 50% und 100%): Schiebregler in Richtung 100% verstellen oder Zykluszeit erhöhen.


Einstellungen

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Oberfläche -> Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Einstellungen erlauben in drei Registerkarten die Konfiguration der zenon Logic Runtime:

  • Allgemeine Einstellungen
  • Redundanz
  • Fortgeschrittene

Noch in diesem Kapitel

Allgemein

Redundanz

Erweiterte Einstellungen


Allgemein

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Oberfläche -> Einstellungen -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Registerkarte Allgemeine können die verschiedenen Parameter zur zenon Logic Runtime verändert werden:

Parameter | Auswirkung
Kommunikation |
Port (Main): | IP Port der zenon Logic Runtime für den zyklischen Datenaustausch (z.B. zenon Logic Workbench).
Port (Binding): | IP Port der zenon Logic Runtime für den spontanen Datenaustausch (z.B. straton32.exe Treiber von zenon bzw. Binding).
Hochlauf |
Kein Start. Diese Box öffnen: | Beim Starten der zenon Logic Runtime wird zuerst diese Box geöffnet.
Kaltstart: | Initialisiertes Hochlaufen. Auch Retain Variablen werden initialisiert gestartet.
Kaltstart (laden v. RETAIN Variablen): | Initialisierter Hochlauf mit aktuellen Werten der Retain Variablen. Diese beinhalten nur Werte, keinen Status (siehe Info-Box).
Warmstart: | Restart mit allen Variablenwerten wie beim Beenden.
Start im Schrittmodus | Startet die zenon Logic Runtime und hält diese sofort im Debugging Modus an.
Verzögerung [s] | Verzögert den Start um die eingestellte Anzahl von Sekunden. Default: 0
RETAIN-Daten |
Speicherpfad Retain-Daten | Hier wird die Datei mit den Retain Daten abgelegt. Die Standardeinstellung hängt davon ab, wie die zenon Logic Runtime gestartet wurde.
Retain-Variablen mit ihrem Namen speichern | Aktivieren Sie diese Checkbox, wenn Sie die Retain-Daten im Format mit den Variablennamen speichern möchten. Dadurch können die Werte von Retain-Variablen auch gespeichert werden, wenn Sie eine Retain-Variable hinzufügen oder löschen. Hinweis: Damit eine Variable gespeichert werden kann, muss sie in der zenon Logic Workbench als eingebettet markiert sein. Wenn Sie die checkbox nicht aktivieren, werden die Retain-Daten herkömmlich gespeichert. Nach einer Änderung der Retain-Variablen, startet die Runtime mit den Initialwerten für alle Retain-Variablen. Default: deaktiviert
Zyklisches Speichern der Retain-Variablen | Wenn Sie diese Checkbox deaktivieren, werden die Retain-Daten nicht mehr zyklisch - nach einer Änderung aber nicht häufiger als ca. alle 10 ms - gespeichert, sondern nur beim Beenden der Runtime. Default: aktiviert
Echtzeitpriorität | Setzt den zenon Logic Runtime Prozess auf Windows Priorität Echtzeit. Ein nicht gesetztes Flag bedeutet Priorität Normal.

info Info

Wenn Sie in zenon die Option Retain-Variablen mit Namen speichern aktiviert haben und auch bei manuellem Runtime-Start nützen möchten, müssen Sie sicherstellen, dass in der Datei K5DBXS.INI im Bereich [CMD] die Option RETAINBYNAME gesetzt ist. Dadurch werden beim Start der zenon Logic Workbench alle Retain-Variblen als eingebettet markiert.
Hinweis: Die INI-Datei wird nur beim Start der zenon Logic Workbench ausgewertet. Änderungen während die Workbench läuft haben kein Auswirkungen.

Interne ID: Allgemein

Retain-Variablen mit Namen speichern

Speichert die Retain-Variablen mit ihrem Variablennamen, wenn Sie den Starttyp automatisch starten/stoppen ausgewählt haben. Außerdem werden Retain-Variablen in zenon Logic automatisch eingebettet.

Interne ID: Allgemein

Starttyp

Der Starttyp definiert, ob und wie die zenon Logic Runtime mit der Leitsystem Runtime gestartet wird.
Autom. starten: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, läuft die zenon Logic Runtime weiter.
Autom. starten/stoppen: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, so wird auch die zenon Logic Runtime beendet.
Manuell starten: In Bezug auf die zenon Logic Runtime passiert nichts, wenn die Leitsystem Runtime gestartet oder beendet wird. In diesem Fall muss die zenon Logic Runtime manuell gestartet werden (z.B. mit dem zenon Logic Runtime Manager).
Default: autom. starten stoppen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Hinweis: Um diese Funktion auch bei manuellem Runtime-Start zu nützen, müssen Sie die Option auch aktivieren. Zusätzlich müssen Sie die Option über Kommandozeilenparameter bzw. INI-Datei/Einstellungsdialog aktivieren.

Default: aktiviert

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

info Info

Retain Variablen

Retain Daten enthalten nur den Wert der zenon Logic Variablen, nicht deren Status. Das bedeutet für den Start:

  • Warmstart: Der Status, der für eine Variable gesetzt wurde, wird wieder hergestellt - unabhängig davon, ob es sich um eine Retain Variable handelt oder nicht.
  • Kaltstart mit Retain Variablen: Nur der Wert der Retain Variablen in zenon Logic wird wieder hergestellt, nicht der Status.

info Info

Wurde die zenon Logic Runtime mit der zenon Runtime oder mit dem zenon Logic Runtime Manager gestartet, so werden Änderungen aus dieser Oberfläche nach einem Neustart der zenon Logic Runtime nicht übernommen!

Einstellungsänderungen führen Sie daher wie gewohnt in den zenon Logic Projekteigenschaften des zenon Editors oder im zenon Logic Runtime Manager durch.

In solchen Fällen dient dieser Dialog dafür, festzustellen welche Parameter an die zenon Logic Runtime übergeben wurden.

Die Einstellungsänderungen in diesem Dialog kommen nur zum Tragen, wenn die zenon Logic Runtime direkt (z.B. über den Windows Explorer) gestartet wird.


Redundanz

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Oberfläche -> Einstellungen -> Redundanz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der Registerkarte Redundanz sind die Redundanzeinstellungen der zenon Logic Runtime ersichtlich.

Folgende Einträge können in dieser Oberfläche überprüft oder eingegeben werden:

Eintrag | Bedeutung
Redundanz aktivieren | Runtime läuft im Redundanzmodus
Server Port: | Port für die Replikationsverbindung
Server Time-out [ms] | Time-out, um festzustellen, ob der passive Client vorhanden ist. Nach Ablauf dieses Time-outs wird die Replikation beendet.
Client Time-out [ms] | Time-out, um festzustellen, dass der aktive Server nicht mehr verfügbar ist. Danach wird der passive Client zum aktiven Server.
Partneradresse: | IP-Adresse des Redundanzpartners.

info Info

Details zur Konfiguration der Redundanz von zenon Logic und zenon finden Sie im Kapitel Redundanz zenon Logic und zenon.


Erweiterte Einstellungen

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Oberfläche -> Einstellungen -> Erweiterte Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Registerkarte werden Einstellungen für die spontane Kommunikation mit externen Applikationen (Binding, zenon Treiber,...) vorgenommen.

Folgende Einstellungen können vorgenommen werden:

Eintrag | Bedeutung | Wertebereich
System | Max. Länge der Systemqueue. In dieser Queue werden z.B. Überläufe der Eventqueue gepuffert. | 1024 ... 65520 Default: 1024
Alarme | Länge der Alarmqueue (aktuell nicht verwendet) | 0 ... 65520 Default: 0
Max. Verbindungen | Anzahl der möglichen Verbindungen (nicht änderbar) | 4 ... 65535 Default: 256
Ereignisse | Länge der Eventqueue: In diese Queue werden die Events des zenon Logic Runtime Eventservers geschrieben. Von dort werden diese über TCP verschickt. Läuft diese Queue über, werden die Überlaufmeldungen in die System Queue geschrieben. | 0 ... 65535 Default: 8192
Meldungen | Länge der Infoqueue. In dieser Queue werden die Meldungen an die zenon Logic Workbench gepuffert. | 1024 ... 65520 Default: 32768
Max. Puffer | Puffergröße der Events pro Zyklus. Mit diesem Parameter wird definiert, wie viele Variablen über den Eventserver je Zyklus abgearbeitet werden können. | 128 ... 65535 Default: 1024
Zurücksetzen | Stellt die Defaulteinstellungen wieder her |

info Info

Werden bei großen Projekten mehr als 1024 Variablen zwischen zenon Logic und zenon über den straton32.exe Treiber übertragen, so muss der Parameter Max. Puffer entsprechend erhöht werden. Eine einfache Methode, die Zahl für Max. Puffer zu eruieren, ist der Wert für die kompilierten I/Os im Ausgabefenster des zenon Logic Compilers . Siehe Bild unten.


Meldungen

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Oberfläche -> Meldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der zenon Logic Runtime-Oberfläche können Meldungen der Runtime angezeigt werden. Um die Ansicht zu aktivieren, klicken Sie auf die Schaltfläche Meldungen>>. Die Meldungsanzeige öffnet sich. Um die Meldungsanzeige zu schließen, klicken Sie auf die Schaltfläche Meldungen<<.

Für Aktionen in der Meldungsanzeige klicken Sie mit der linken oder rechten Maustaste in die Meldungsanzeige. Sie erhalten ein Kontextmenü:

Menüeintrag | Beschreibung
Zeitstempel der Meldungen anzeigen | Fügt jeder Meldung einen Zeitstempel hinzu.
Meldungen in die Zwischenablage kopieren | Kopiert alle Meldungen in die Zwischenablage.
Alle Meldungen löschen | Löscht alle Meldungen aus dem Meldungsfenster.

Die Einstellungen für das Logging von zenon Logic und den Treibern verwalten Sie Sie über den Diagnose Viewer. Dabei erhält jede zenon Logic Runtime und jeder Bustreiber eine eigene Verbindung als Diagnose Client zum Diagnose Server. Ausgenommen davon sind veraltete Treiber, zum Beispiel von einem Fremdhersteller.


Lizenzierung

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Lizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Installation mit zenon (zenon Runtime und zenon Logic Runtime auf einem PC)

Die zenon Logic Runtime wird automatisch mit der zenon Seriennummer mitlizenziert. Geben Sie bei der Installation die Seriennummer und Aktivierungsnummer im entsprechenden Dialog ein. Sollten Sie keine Lizenznummer zur Verfügung haben, klicken Sie auf Demo Version.

Autarke Installation (zenon Logic Runtime ohne zenon Runtime auf einem PC)

Bei einer autarken Installation (zenon Logic läuft ohne zenon Runtime auf dem PC) geben Sie die Seriennummer und Aktivierungsnummer direkt im Installationsdialog ein.

Nachträgliche Lizenzierung mit Lizenzanforderung

Sie können die Lizenzierung auch nachträglich mit der Lizenzanforderung durchführen. Rufen Sie die Lizenzanforderung im Windows Startmenü unter Alle Programme -> COPA-DATA -> Licencing auf. Bei einer nachträglichen Lizenzierung werden in diesem Dialog die Seriennummer und die Aktivierungsnummer eingetragen. Der Vorgang wird mit OK abgeschlossen.

Um eine Softlizenzierung durchzuführen, muss die so genannte Lizenznummer aus der Hardware-Konfiguration Ihres PCs ausgelesen werden. Klicken Sie dafür auf den Button Lizenzanforderung für Softlizenzierung und folgen Sie den Angaben in den folgenden Dialogen.

Nachträgliche Lizenzierung über den zenon Editor

Im zenon Editor wird über Datei -> Allgemeine Konfiguration -> Produkt lizenzieren... der Dialog für die Lizenzierung geöffnet. Hier können Sie ebenfalls die Seriennummer und Aktivierungsnummer eingeben.

Information über die Lizenz der zenon Logic Runtime

Öffnen Sie die Oberfläche der zenon Logic Runtime indem Sie auf das zenon Logic Runtime Icon im Systemtray klicken. Danach klicken Sie in die linke obere Ecke und wählen Über STRATONRT.... Damit erscheint ein Fenster mit Information über Version und Lizenz der zenon Logic Runtime.

Noch in diesem Kapitel

TAG-Behandlung 700 - zenon Logic

Demomode


TAG-Behandlung 700 - zenon Logic

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Lizenzierung -> TAG-Behandlung 700 - zenon Logic

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Anzahl der in zenon Logic verbrauchten TAGs richten sich nach der Anzahl der verbrauchten I/Os in zenon Logic minus der Anzahl der verbrauchten I/Os mit einem zenon oder zenon Logic Profil. Diese I/Os werden schon bei der TAG-Berechnung in zenon berücksichtigt.

Somit wird sichergestellt, dass keine I/Os doppelt gezählt werden.

Die verbrauchten I/Os werden in der UI der zenon Logic Runtime angezeigt.


Demomode

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Lizenzierung -> Demomode

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn sie eine falsche oder keine Seriennummer beziehungsweise einen falschen oder keinen Activierungsschlüssel eingeben oder kein Dongle angesteckt ist, startet die zenon Logic Runtime im Demomode. Der Demomode stoppt die zenon Logic Runtime nach 15 Minuten. Ist eine spezielle Demo-Seriennummer eingegeben, so läuft die zenon Logic Runtime für 30 Tage. Nach Ablauf der 30 Tage beträgt die maximale Laufzeit der zenon Logic Runtime wiederum 15 Minuten.

zenon Logic Mini

Sie haben die zenon Logic Runtime Lizenz nicht gekauft, besitzen aber eine gültige zenon Runtime Lizenz. Dann ist automatisch eine Mini-Version der zenon Logic Runtime lizenziert. Mit der Mini-Version können bis zu 8 Tags (= Variablen) über Input/Output Mechanismen von zenon Logic verwendet werden. Als Tags werden Variablen von Feldbustreibern und Variablen mit Profilen (z.B. B&B Profil zenon Logic) gerechnet.

Berechnungsbeispiel:

  • 4 Variablen für die Kommunikation zenon Logic <=> zenon
  • 4 Variablen für die Kommunikation zenon Logic <=> Profibus
  • Ergibt die volle Ausschöpfung der 8 Tags (4 + 4 = 8).


Starten der zenon Logic Runtime

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Starten der zenon Logic Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Logic Runtime ist multiinstanzfähig und benötigt daher Parameter (Übergabeparameter), wenn sie gestartet wird.

Es gibt drei Möglichkeiten die zenon Logic Runtime zu starten:

  1. mit der zenon Runtime
  2. mit dem zenon Logic Runtime Manager
  3. in einer DOS-Shell/BAT-Datei

Mit zenon Runtime starten

Um die zenon Logic Runtime mit der zenon Runtime zu starten:

  • Selektieren Sie das zenon Logic Projekt im zenon Editor.
  • Verändern Sie je nach Wunsch den Starttyp (Runtime). Die Eigenschaften zu Starttyp sind in der eingebetteten Hilfe von zenon beschrieben.

    Interne ID: Starten der Runtime

    Starttyp

    Der Starttyp definiert, ob und wie die zenon Logic Runtime mit der Leitsystem Runtime gestartet wird.
    Autom. starten: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, läuft die zenon Logic Runtime weiter.
    Autom. starten/stoppen: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, so wird auch die zenon Logic Runtime beendet.
    Manuell starten: In Bezug auf die zenon Logic Runtime passiert nichts, wenn die Leitsystem Runtime gestartet oder beendet wird. In diesem Fall muss die zenon Logic Runtime manuell gestartet werden (z.B. mit dem zenon Logic Runtime Manager).
    Default: autom. starten stoppen.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Starten der Runtime

    Runtime

    Eigenschaften für die zenon Logic Runtime (Soft SPS).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Start mit dem zenon Logic Runtime Manager

Um die zenon Logic Runtime manuell zu starten, kommt der zenon Logic Runtime Manager zum Einsatz. Sie finden den zenon Logic Runtime Manager im Bereich COPA-DATA im Windows® Startmenü. Der zenon Logic Runtime Manager dient dazu, zenon Logic Runtime Instanzen auf einem PC zu starten. Hier kann z.B. Harte Echtzeit ausgewählt werden, um die zenon Logic Echtzeit-Version zu starten (zenon Logic RTK) oder um eine zenon Logic Runtime Instanz beim System-Hochlauf zu starten ("Autostart").

Genauere Anweisungen zu den einzelnen Elementen des zenon Logic Runtime Managers erhalten Sie, indem Sie den Mauszeiger darüber führen. Damit wird die jeweilige Hilfe in der Embedded Help im unteren Bereich angezeigt.

Die gesamte Hilfe zu dieser Anwendung erhalten Sie, wenn Sie auf das ? in der Menüleiste klicken.

attention Achtung

Ab der Version Vista des Windows-Betriebsystems muss der Runtime-Manager mit Administratorrechten gestartet werden.

Starten in einer DOS-Shell

Die zenon Logic Runtime kann in einer DOS-Shell oder ähnlichen Einrichtungen (.bat Datei) gestartet werden. Für die Befehle gilt:

  • alle Befehle müssen in Großbuchstaben geschrieben werden
  • als Vorzeichen sind erlaubt:
    -
    /
    kein Zeichen

Folgende Übergabeparameter stehen zur Verfügung:

Hauptparameter:

Paramter | Beschreibung
PORT=<Zahl> | Kommunikationsport. Ohne Parameter: 1200
PORTTRACE=<Zahl> | Eventserverport, Binding Port . Ohne Parameter: PORT+7800
PATH=<DB-Path> | Ablageort des zenon Logic Applikationscode. Ohne Parameter: zenon Logic Runtime-Verzeichnis
ZENPATH=<Pfad> | zenon Pfad (ohne Bedeutung)
ZENPROJECT=<Name> | zenon Projektname (ohne Bedeutung)
DONTHIDE | Runtime nach dem Start nicht verstecken (einziger Parameter ohne ‚=’)
STEP=<0|1> | Ohne Parameter: kein Steppingmode. 0: kein Steppingmode 1: Start im Steppingmode
START=<0|1|2|3> | Ohne Parameter: Warmstart 0: Setupdialog aufschalten 1: Coldstart 2: Warmstart 3: Hotstart
LOWPRIORITY=<0|1> | Ohne Parameter: low priority 0: low priority 1: Windows real time priority
WRITELOG=<0|1> | Ohne Parameter: Log erstellen 0: Kein Log erstellen 1: Log erstellen Die Logdatei wird im PATH-Verzeichnis als STRATONRTLOG.TXT erstellt.

Zusätzliche Parameter:

Paramter | Beschreibung
REMPATH=<Pfad> | Pfad für remanente Daten. Ohne Parameter: PATH-Verzeichnis
DELAY=<Zahl> | Start-Delay in [s]: Verzögerter Start der zenon Logic Runtime. Ohne Parameter: 0
MAXUTILPRCT=<Zahl> | Stellung des Schiebereglers für die maximale SPS Auslastung in %. Ohne Parameter: 100

Eventserver:

Einstellungen wie unter Einstellungen/Fortgeschrittene für den Event-Server.

Paramter | Beschreibung
QSSYSTEM=<Zahl> | Größe der Systemqueue. Ohne Parameter: 1024
QSALARM=<Zahl> | Größe der Alarmqueue. Ohne Parameter: 0
QSEVENT=<Zahl> | Größe der Eventqueue. Ohne Parameter: 8192
QSINFO=<Zahl> | Größe der Infoqueue. Ohne Parameter: 32768
NBEVENT=<Zahl> | Maximale Anzahl registrierbarer Events. Ohne Parameter: 1024
EVENTCON=<Zahl> | Anzahl der möglichen Event-Verbindungen. Ohne Parameter: 256

Redundanzeinstellungen:

Parameter | Beschreibung
REDENABLE=<0,1> | Redundanz ein/aus. Ohne Parameter: 0
REDADDR=<IP> | Redundanz Partneradresse.
REDPORT=<Zahl> | Redundanz Port für Replikation.
REDCLITIMEOUT=<Zahl> | Redundanz Client Time-out [ms]; Time-out für das Hochstufen zum aktiven Server. Ohne Parameter: 1000
REDSRVTIMEOUT=<Zahl> | Redundanz Server Time-out [ms]; Time-out für das Beenden der Replikation. Ohne Parameter: 1000
REDZENON=<0,1> | Wenn 1, dann wird die Partneradresse aus der PROJECT.INI gelesen. Ohne Parameter: 0


zenon Logic Runtime Zyklus

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime Zyklus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Logic Runtime Zyklus setzt sich zusammen aus:

  • Calc. time: Zeit für Datenaustausch, Berechnung, Ablage berechneter Werte, schreiben und lesen geänderter Werte.
  • Cycle time: Komplette Zykluszeit, deren Länge von System latency abhängt.
  • System latency: Ansprechzeit des Systems.

Diese Werte lassen sich in der zenon Logic Oberfläche anzeigen. Benutzen Sie dafür die Tastenkombination ALT+S oder Umschalt+ALT+A.

Eigenschaft | Beschreibung
Binding exchange | Einlesen der Binding Werte, die im Netzwerk publiziert werden und von der Applikation konfiguriert wurden (wenn konfiguriert).
I/O exchange | Datenaustausch der I/O Treiber (außer Modbus Slave/Server) und der I/O Boards (wenn konfiguriert).
Application executione | Ausführung der Programme.
Digital sampling trace | Ausführen des Digital Sampling (wenn konfiguriert).
Events | Absenden der Events (Binding bzw. straton32.exe-Treiber von zenon) (wenn konfiguriert).
Forced values | Einlesen der Sollwerte von zenon, von der zenon Logic Workbench (online Debugging) und Datenaustausch des Modbus Slave/Server (wenn konfiguriert).
Sleep | Restliche Zeit bis zum Verstreichen der Zykluszeit abwarten. Bei der Zyklus-Einstellung "So schnell wie möglich (Freilauf)" beträgt diese Zeit immer 1 ms. Die Zeit des Sleep dient dazu, dass Aufgaben des Betriebssystems bzw. von anderen Windows Applikationen ausgeführt werden können.

Zeitzuweisung SPS und Windows

Mit dem Schieberegler in der zenon Logic Runtime Oberfläche bestimmen Sie, wie viel Zeit für die SPS reserviert wird und wie viel für Windows. Der Wert des Bargrafen bezieht sich dabei immer auf das im Schiebregler eingestellte Verhältnis.

Noch in diesem Kapitel

Fehlermeldungen cycle time


Fehlermeldungen cycle time

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime Zyklus -> Fehlermeldungen cycle time

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Überschreitungen der cycle Time werden Meldungen in der zenon Logic Runtime bzw. in der Workbench ausgegeben und entsprechende Einträge in das Logfile geschrieben.

Fehlermeldung Oberfläche | Eintrag Logfile | Bedeutung
Timing configuration error. (x) cycles lost. | Timing configuration error. (x1) cycles lost. Configured cycle time = (x2) us, maximum execution time = (x3) us, maximum PLC utilisation = (x4). | Anzahl (x) der nicht ausgeführten Zyklen aufgrund von Zykluszeitüberschreitungen. Die Ausführungszeit ist größer als die eingestellte Zykluszeit bzw. sind nicht genügend CPU Ressourcen verfügbar.
Timing configuration error. PLC utilization peaked at (x)%. | Timing configuration error. PLC utilization exceeds 80%. Configured cycle time = (x1) us, maximum execution time = (x2) us, maximum PLC utilisation = (x3)%." | Die Ausführungszeit beträgt mehr als 80% der eingestellten Zykluszeit, tatsächlich (x)%.

Fehlerbehebung

Überschreitungen des cycle time beheben Sie durch:

  • cycle time erhöhen
  • Ausführungszeit verringern, z.B.:
    • System mit mehr CPU-Ressourcen verwenden
    • C-compiled Code verwenden
    • Programm reduzieren


Beenden der zenon Logic Runtime

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Beenden der zenon Logic Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Logic Runtime kann manuell über das Kontextmenü des Symbols im Systemtray oder über das geöffnet Fenster der zenon Logic Runtime beendet werden:

Kontextmenü Symbol

  • Mit einem rechten Mausklick auf das Icon im Systemtray erhalten Sie folgendes Kontextmenü:

  • Mit Klick auf Beenden öffnet sich ein Dialog

  • Mit Klick auf Ja wird die Runtime gestoppt und beendet.

Im Fenster der zenon Logic Runtime

Eine weitere Möglichkeit zum Beenden der Runtime bietet das geöffnet Fenster der zenon Logic Runtime:

  • Mit Klick in die linke obere Ecke des Fensters erhalten Sie folgendes Menü:

  • Mit Klick auf Exit werden öffnet sich ein Dialog
  • Bestätigen Sie diesen, wird die zenon Logic Runtime sofort beendet

info Info

Wurde die zenon Logic Runtime mit der zenon Runtime gestartet und wurde im zenon Editor für das zenon Logic Projekt der Starttyp "autom. starten/stoppen" ausgewählt, dann wird die zenon Logic Runtime automatisch mit dem Beenden der zenon Runtime beendet.


Erstellen der Hot Restart Datei

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Erstellen der Hot Restart Datei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie die zenon Logic Runtime schließen, wird automatisch eine Hot Restart Datei erstellt. Sie können auch selbst mithilfe der Funktion WriteHot das Schreiben der Hot Restart Datei anstoßen.

Jedes Mal wenn eine Hot Restart Datei erstellt wird, wird auch eine Backup-Datei erstellt, bei der das letzte Zeichen des Dateinamens durch '_' ersetzt wird. Außerdem weden die Dateien mit einem Header erstellt, der die Checksum der Daten der Datei enthält. Beim Lesen der Datei wird Header und Checksum überprüft. Wenn ein Fehler auftritt, wird die Backup-Datei verwendet.

Die Funktion WriteHot besitzt folgende Eingabeparameter:

Parameter | Beschreibung
I | Trigger; Wenn dieser Parameter TRUE ist, wird die Funktion ausgeführt.
SYNC | Wenn dieser Parameter TRUE ist, wird der Zyklus so lange angehalten bis die Hot Restart Datei geschrieben ist. Wenn der Parameter FALSE ist, wird die Funktion asynchron ausgeführt.
BUSY | Dieser Parameter ist TRUE, wenn die Funktion ausgeführt wird.

info Info

Wenn Sie die Funktion in einem Zyklus mehrmals aufrufen, wird nur der letzte Aufruf berücksichtigt.


Remote Systeme

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Remote Systeme

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieser Abschnitt befasst sich mit Zielsystemen, die sich nicht auf dem lokalen Computer befinden. Der Zugang zum Zielsystem erfolgt immer über Ethernet TCP/IP.

Noch in diesem Kapitel

zenon Runtime und zenon Logic Runtime auf einem Remote-PC

zenon Logic Runtime autark (PC)


zenon Runtime und zenon Logic Runtime auf einem Remote-PC

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Remote Systeme -> zenon Runtime und zenon Logic Runtime auf einem Remote-PC

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Installation auf dem Zielsystem

Als ersten Schritt installieren und lizenzieren Sie die zenon Runtime auf dem Remote-PC. Die zenon Logic Runtime wird automatisch mitinstalliert/lizenziert.

Download der Projektdaten mit zenon Logic Runtime, Starttyp "autom. starten/stoppen" oder "autom. starten"

Um die zenon und zenon Logic Runtime Dateien zu übertragen, verwenden Sie die Remote Transport-Funktionalität von zenon. Genaueres dazu finden Sie im Kapitel Remote Transport.

Die zenon Logic Runtime wird automatisch mit der zenon Runtime gestartet und beendet.

Download der Applikationsdaten mit mit zenon Logic Runtime Starttyp "manuell starten"

Wird die zenon Logic Runtime auf dem Ziel-PC manuell gestartet (z.B. beim Hochlaufen des Betriebssystems), muss der SPS-Code manuell mit der zenon Logic Workbench auf die Zielplattform geladen werden. Dazu

  • tragen Sie im Eigenschaften-Dialog Workbench im zenon Editor die richtigen Parameter ein: Ziel-Host und Ziel-Port

    Interne ID: zenon Runtime und zenon Logic Runtime auf einem Remote-PC

    Ziel-Port

    Der Runtime Port des zenon Logic Zielsystems für die Verbindung der Workbench. Diese Information ist für die zenon Logic Workbench, um sich auf das Zielsystem (zenon Logic Runtime) für z.B. Online Debugging zu verbinden.
    Minimum: 0.
    Maximum: 4294967295.
    Default: 1200.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: zenon Runtime und zenon Logic Runtime auf einem Remote-PC

    Ziel-Host

    Der Runtime Host (IP-Adresse oder Rechnername) des zenon Logic Zielsystems für die Verbindung der Workbench für z.B. Online Debugging.
    Default: localhost.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: zenon Runtime und zenon Logic Runtime auf einem Remote-PC

    Workbench

    Eigenschaften für die zenon Logic Workbench.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • klicken Sie in der zenon Logic Workbench auf die Schaltfläche Online
  • damit stellt die zenon Logic Workbench mit dem Zielsystem eine Verbindung her.
  • nun kann der SPS-Code mit der Schaltfläche Download auf das Zielsystem geladen werden, der Fortschritt des Downloads wird in Form eines Balkens dargestellt
  • nach dem Download läuft die SPS sofort mit der neuen Applikation an

war der Download erfolgreich und läuft das SPS Programm auf dem Zielsystem fehlerfrei, wird in der Symbolleiste RUN angezeigt


zenon Logic Runtime autark (PC)

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Remote Systeme -> zenon Logic Runtime autark (PC)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Installation auf dem Zielsystem:

Installieren Sie die zenon Logic Runtime mit der autarken Installation auf dem Zielsystem.

Start:

Bevor man das zenon Logic Projekt downloaden kann, muss dieses gestartet werden. Dies passiert am besten mit dem zenon Logic Runtime Manager. Mit diesem Werkzeug können Sie auch voreinstellen, dass die zenon Logic Runtime beim Hochlaufen des Betriebssystems gestartet wird.

Download der Applikationsdaten mit mit zenon Logic Runtime Starttyp "manuell starten"

Wird die zenon Logic Runtime auf dem Ziel-PC manuell gestartet (z.B. beim Hochlaufen des Betriebssystems), muss der SPS-Code manuell mit der zenon Logic Workbench auf die Zielplattform geladen werden. Dazu

  • tragen Sie im Eigenschaften-Dialog Workbench im zenon Editor die richtigen Parameter ein: Ziel-Host und Ziel-Port

    Interne ID: zenon Logic Runtime autark (PC)

    Ziel-Port

    Der Runtime Port des zenon Logic Zielsystems für die Verbindung der Workbench. Diese Information ist für die zenon Logic Workbench, um sich auf das Zielsystem (zenon Logic Runtime) für z.B. Online Debugging zu verbinden.
    Minimum: 0.
    Maximum: 4294967295.
    Default: 1200.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: zenon Logic Runtime autark (PC)

    Ziel-Host

    Der Runtime Host (IP-Adresse oder Rechnername) des zenon Logic Zielsystems für die Verbindung der Workbench für z.B. Online Debugging.
    Default: localhost.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: zenon Logic Runtime autark (PC)

    Workbench

    Eigenschaften für die zenon Logic Workbench.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • klicken Sie in der zenon Logic Workbench auf die Schaltfläche Online
  • damit stellt die zenon Logic Workbench mit dem Zielsystem eine Verbindung her.
  • nun kann der SPS-Code mit der Schaltfläche Download auf das Zielsystem geladen werden, der Fortschritt des Downloads wird in Form eines Balkens dargestellt
  • nach dem Download läuft die SPS sofort mit der neuen Applikation an

war der Download erfolgreich und läuft das SPS Programm auf dem Zielsystem fehlerfrei, wird in der Symbolleiste RUN angezeigt


zenon Logic Runtime mit Real Time Kernel (RTK)

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Logic Runtime mit Realtime Kernel (RTK) ist das zenon Logic Laufzeitsystem für die harte Echtzeit. Damit sind höchster Determinismus und Ausfallsicherheit gegenüber dem Betriebssystem gewährleistet.

Voraussetzungen:

  • Die zenon Logic RTK steht nur für die Windows Betriebssysteme XP (XPe), VISTA und Windows 7, jeweils in der der 32-Bit Version, zur Verfügung.
  • Die zenon Logic RTK kann nur mit dem zenon Logic Runtime Manager (Flag Harte Echtzeit muss gesetzt sein) oder in einer DOS-Shell/BAT-Datei gestartet werden .

attention Achtung

Betreiben Sie nicht zwei Echtzeiterweiterungen parallel auf einem Rechner. Das heißt:

  • Ist bereits eine andere Echtzeiterweiterung auf dem Rechner aktiv, starten Sie die zenon Logic RTK nicht.
  • Es kann jeweils nur eine Instanz der zenon Logic RTK gestartet werden.

Der Realtime Kernel ist so ausgelegt, dass er unbeeinflusst von Windows den zenon Logic Runtime Zyklus triggert. Somit wird der zenon Logic Runtime Zyklus garantiert deterministisch ausgeführt. Es können Zykluszeiten ab 100 µs betrieben werden.

Der Anteil der Rechenkapazität des PCs kann über einen Schieberegler eingestellt werden:

Je nach Größe der SPS Applikation und eingestellter Zykluszeit muss mit dem Schieberegler die SPS Auslastung angepasst werden. Der Schieberegler kann zwischen 10% und 85% verschoben werden. Die Aktuelle Auslastung (Balken) zeigt an, ob das erlaubte Maximum für die Abarbeitung des SPS Zyklus ausreicht.

Stößt der Balken an die 100%, besteht die Gefahr von Zyklenüberläufen! Stellen Sie dann den Regler höher (gegen 85%). Ist das aufgrund der Applikationen in Windows (z.B. lange Bildaufschaltzeiten von zenon) nicht möglich, muss die Zykluszeit der zenon Logic Applikation erhöht werden.

attention Achtung

Erreicht der Balken die 100% Markierung, besteht die Gefahr von Zyklenüberläufen!

Example Beispiele

Schieberegler auf 10%, Zykluszeit 10ms:

Der zenon Logic RTK stehen für die Abarbeitung des SPS Programms 1 ms, nämlich 10% der eingestellten Zykluszeit von 10 ms zur Verfügung.

Schieberegler auf 50%, Zykluszeit 5ms:

Der zenon Logic RTK stehen für die Abarbeitung des SPS Programms 2,5ms zur Verfügung.

Schieberegler auf 85%, Zykluszeit 20ms:

Der zenon Logic RTK stehen für die Abarbeitung des SPS Programms 17ms zur Verfügung.

Formel

Um festzustellen, ob die Einstellung des Sliders im Zusammenhang mit der Zykluszeit keine Zyklenüberläufe verursacht, kann folgende Formel angewandt werden:

Zykluszeit > (100/Reglerposition[%])*Berechnungszeit

Um die Berechnungszeit des SPS-Zyklus festzustellen, drücken Sie UMSCHALT+ALT+a und notieren sich den Wert Max. Ber. Zeit [µs].

Annahme:

Max. Ber. Zeit: 274µs

Reglerposition: 50%

Eingestellte Zykluszeit: 1ms (1000µs)

Berechnung:

(100/50)*274 = 548µs

Daraus folgt, dass die eingestellte Zykluszeit von 1 ms ausreichend ist.

attention Achtung

Bitte beachten Sie: Wir die oben beschriebene Formel nicht eingehalten, ist ein Determinismus auf Basis der Zykluszeit NICHT mehr gegeben!

Beschreibung der dargestellten Messwerte (Anzeigen mit ALT+s bzw. UMSCHALT+ALT+a):

Systemlatentzzeit (ALT+s) |
Aktuell [µs] | Aktuelle Systemlatenzzeit (siehe auch Runtime Zyklus)
Maximum [µs] | Maximale Systemlatenzzeit (seit dem Runtime Start)

Erweiterte Statistik (UMSCHALT+ALT+a) |
Ber. Zeit [µs] | Aktuelle Berechnungszeit des letzten Zyklus
Max. Ber. Zeit [µs] | Maximale Berechnungszeit für einen SPS Zyklus (seit dem Runtime Start)
Zykluszeit [µs] | Aktuelle Zykluszeit
Min. Zykluszeit [µs] | Minimale Zykluszeit (seit dem Runtime Start)
Max. Zykluszeit [µs] | Maximale Zykluszeit (seit dem Runtime Start)
Zyklenüberlauf [1] | Zähler für Zykluszeitüberschreitungen (seit dem Runtime Start)
Treiberüberlauf [1] | Zähler für versäumte SPS Zyklen von Windows- (Nicht-Echtzeit-) Treibern (seit dem Runtime Start)

Der Wert der Zykluszeit kann immer nur aus einem Vielfachen der HAL Timer Periode (Zeitbasis) sein. Die Zeitbasis hängt vom ausgewählten Timer und dessen Zeitbasis ab (siehe auch zenon Logic RTK Konfiguration). Das bedeutet: Eine eingestellte Zykluszeit von 10 ms einer Hardware mit einer Zeitbasis von 122 µs wird nicht mit genau 10,000 ms, sondern mit 10,004 ms ausgeführt.

Noch in diesem Kapitel

Einschränkungen und Voraussetzungen der zenon Logic RTK

zenon Logic RTK Konfiguration

Blue Screen Handling

Fehlercodes beim Starten der zenon Logic RTK


Einschränkungen und Voraussetzungen der zenon Logic RTK

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> Einschränkungen und Voraussetzungen der zenon Logic RTK

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hardwarevoraussetzungen für zenon Logic RTK

ACPI:

Hardware (PC oder IPC) und Betriebssystem (Windows® XP, XPe, Vista) müssen ACPI unterstützen:

  • ACPI-Multiprocessor-P
  • ACPI-PC (Advanced Configuration and Power Interface)
  • ACPI-Uniprozessor-PC

Ob Ihr PC ACPI unterstützt, sehen Sie in der Systemsteuerung (System/Geräte-Manager/Computer).

Prozessoren:

Die zenon Logic RTK wird ab folgenden Prozessorgenerationen unterstützt:

  • Pentium II oder jünger
  • AMD Athlon XP oder jünger

Einschränkungen

Der zenon Logic Real Time Kernel (RTK) läuft als eigener Prozess auf Hardwarebene unabhängig vom Betriebssystem, die zenon Logic Runtime dagegen unter Windows®. Die echtzeitfähige zenon Logic RTK weist gegenüber der zenon Logic Runtime (RT) einige Einschränkungen auf:

Funktionsbausteine:

Folgende Funktionsbausteine werden nicht direkt im Kernel Mode abgearbeitet, sondern nur emuliert:

  • alle Dateioperationen (Kategorie 'Files')
  • alle TCP/IP Bausteine (Kategorie 'TCP-IP')

Folgende Funktionsbausteine werden von der zenon Logic RTK nicht unterstützt:

  • day_time_local (Kategorie 'Clock')

info Info

Um genau festzustellen, welche Funktionsbausteine der zenon Logic Standard-Bibliothek unterstützt werden, verwenden Siedas Feature der Konfiguration der zenon Logic Workbench (Hauptmenü: Projekt/Konfiguration/Upload).

Nach Auswahl der Konfiguration werden die nicht unterstützten Funktionsbausteine in der Bibliothek rot eingefärbt.

I/O Treiber

Folgende zenon Logic I/O Treiber werden von der zenon Logic RTK im Kernel Mode ausgeführt (Echtzeit):

  • Profibus (Hilscher CIF Profibus)
  • Hilscher SYCON universal (Hilscher SYCON Konfiguration)

Weiter Informationen zu unterstützten I/O Treibern finden sie hier: zenon Logic I/O Treiber Unterstützung

Echtzeit-Treiber registrieren und deregistrieren

In äußerst seltenen Fällen kann es notwendig sein, dass der Echtzeit-Treiber der zenon Logic RTK händisch registriert oder deregistriert werden muss. Starten Sie dazu die Eingabe auf Kommandozeilenebene (command Prompt) über:
Start > ausführen > cmd.

Verwenden Sie folgende Syntax für:

  • Registrieren:

<Verzeichnis der zenon Logic RTK>:\ stratonrtkvm -regsrv

  • Deregistrieren:

<Verzeichnis der zenon Logic RTK>:\ stratonrtkvm -unregsrv

Beispiel für <Verzeichnis der zenon Logic RTK>: C:\Programme\COPA-DATA\zenon 700


zenon Logic RTK Konfiguration

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Logic Real Time Kernel (RTK) läuft als eigene Instanz auf der Hardwarebene, unabhängig vom Betriebssystem. Die Timerticks zur Steuerung werden direkt vom Motherboard bezogen. Welche Timer zur Verfügung stehen, hängt von der verwendeten Hardware ab. Die Konfiguration erfolgt mit dem zenon Logic RTK Konfigurator.

Noch in diesem Kapitel

RTK Konfiguration starten

RTK Basisinformationen

RTK Grundeinstellungen

RTK Taskmanager

RTK Hardwarekonfiguration

RTK Logs

RTK Konfigurator Beenden


RTK Konfiguration starten

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Konfiguration starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klicken Sie in der Windows Systemsteuerung doppelt auf die Schaltfläche für den zenon Logic RTK Konfigurator.

Das Fenster zur Bearbeitung der Konfiguration öffnet sich. Im linken Bereich sehen Sie einen Menübaum mit folgenden Punkten:

  • CDrtHAL Konfiguration
  • Grundeinstellungen
  • Taskmanager
  • Hardwarekonfiguration
  • Zugriff auf den physikalischen Speicher
  • Log messages

Im rechten Fenster erhalten Sie Informationen zu den Menüpunkten und konfigurieren Sie den RTK.


RTK Basisinformationen

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Basisinformationen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nach dem Start ist im linken Fenster der Konfigurations-Software der Menüpunkt 'CDrtHAL Konfiguration' aktiviert. Im rechten Fenster stehen Ihnen Basisinformationen zum Konfigurator und zum System zur Verfügung:

Eigenschaft | Information
Version | Version des Echtzeit-Treibers (CDrtHAL).
Status | RTK ist aktiv oder inaktiv.
Interrupt controller | Typ des Interrupt Controllers.
High precision event timer | Unterstützung abhängig von Hardware. Windows Vista zertifizierte PCs unterstützen diese Funktion.
Prozesskerne | Zahl der zur Verfügung stehenden Prozesskerne.


RTK Grundeinstellungen

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Grundeinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

RTK Grundeinstellungen

In den Grundeinstellungen legen Sie fest:

  • Quelle für den Timertick
  • CPU, auf der der RTK ausgeführt wird
  • Basiszeit als Grundlage für den Multiplikationsfaktor für die Berechnung der Zykluszeit

Timer für Echtzeitquelle

Welche Timer in der Auswahlliste angezeigt wird, hängt von der verwendeten Hardware ab. Diese Informationen werden auch auf der Startseite der RTK Konfiguration angezeigt. Vorhanden können sein:

  • Interrupt-Controller APIC
  • Interrupt-Controller PIC
  • HPET (High precision event timer)

Daraus ergeben sich folgende Möglichkeiten:

  1. PIC ohne HPET
    • Timer (8254 Timer), Basiszeiten: 334 µs, 143 µs, 112 µs, 53 µs
    • Profile (Echtzeituhr), Basiszeiten: 488 µs, 244 µs, 122 µs
  2. APIC ohne HPET
    • Timer, (Echtzeituhr), Basiszeiten: 488 µs, 244 µs, 122 µs
    • Profile (Lokaler APIC), Basiszeiten: frei wählbar zwischen 50 – 500 µs
    • Unbenutzt (8254 Timer) Basiszeiten: frei wählbar zwischen 50 – 500 µs
  3. APIC mit HPET und Windows VISTA
    • Timer, (HPET timer 0), Basiszeiten: 500 µs, 250 µs, 125 µs
    • Profile (Lokaler APIC), Basiszeiten: frei wählbar zwischen 50 – 500 µs
    • Unbenutzt (HPET timer 2) Basiszeiten: frei wählbar zwischen 50 – 500 µs

Ob und in welchem Rahmen Basiszeiten frei wählbar sind, hängt ab von Hardware (Echtzeituhr) und Betriebssystem. Bei Einsatz der „Timer“ Echtzeitquelle wird für die Echtzeitausführung die Quelle des Windows Timer Interrupts verwendet. In diesem Fall muss die eingestellte Basiszeit ein ganzzähliger Teiler der Windows Timer Interrupt Basiszeit sein.

Echtzeitquelle: abhängig vom Betriebssystem. Auswahl über Listenfeld (drop down).

Als Basiseinstellung wird empfohlen: Unbenutzt (HPET Timer2).

Echtzeit CPU: Auswahl der CPU, auf der die Prozesse des RTK abgearbeitet werden sollen.

Basiszeit: Basiszeit des Timerticks. Je nach Echtzeitquelle wird sie aus einer Liste ausgewählt oder frei eingetragen. Im Betrieb bezieht sicher der Multiplikationsfaktor für die Timerticks auf die hier eingetragene Basisizeit

attention Achtung

Bei Verwendung von Profile: Echtzeitquelle darf das Kernel-Profiling unter keinen Umständen aktiviert werden, während eine zenon Logic RTK Applikation ausgeführt wird. Für weitere Informationen zu Kernel-Profiling siehe: http://www.microsoft.com/downloads/details.aspx?familyid=9d467a69-57ff-4ae7-96ee-b18c4790cffd&displaylang=en


RTK Taskmanager

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Taskmanager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Taskmanager informiert über Zykluszeiten und Ausführungszeiten.

Eigenschaft | Information
Zykluszeit (in Mikrosekunden) | Minimal- und Maximalwerte sowie aktueller Wert. Zyklus meint die Zyklen des Timerticks bezogen auf die Basiszeit.
Ausführungszeit (in Mikrosekunden) | Minimal- und Maximalwerte sowie aktueller Wert.


RTK Hardwarekonfiguration

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Hardwarekonfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Kommunikation mit den im Kernel Mode ausgeführten I/O Treibern (z.B. Profibus) wird ein eigener reservierter Speicherbereich benötigt. zenon Logic RTK und das I/O Treiber-System handeln dafür einen Bereich aus, auf den beide lesend und schreibend zugreifen.

Die Konfiguration bietet drei Einstellungen an:

Option | Auswirkung
Zugriff auf den physikalischen Speicher generell verbieten. | Frei gegebene Speicherbereiche stellen ein Sicherheitsrisiko hinsichtlich Schadsoftware dar. Im Auslieferungszustand wird daher der Zugriff auf den physikalischen Speicher verboten. Grundeinstellung.
Zugriff auf den physikalischen Speicher generell erlauben. | Gibt den gesamten Speicher für die Kommuniaktion frei, zenon Logic RTK und Profibus legen ihre Kommunikationsbereiche willkürlich fest. Unsichere Einstellung, die nicht empfohlen wird.
Zugriff auf bestimmte physikalische Speicherbereiche erlauben. | . zenon Logic RTK und I/O Treiber bewegen sich in einem fest zugewiesenen Speicherbereich. Empfohlene Einstellung

Noch in diesem Kapitel

Speicherbereich definieren


Speicherbereich definieren

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Hardwarekonfiguration -> Speicherbereich definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Speicherbereich definieren

Um zenon Logic und I/O Treiber einen festen Speicherbereich zuzuweisen, klicken Sie erst im linken Fenster auf den Abschnitt Zugriff auf den physikalischen Speicher und dann im rechten Auswahlfenster auf Zugriff auf bestimmte physikalische Speicherbereiche erlauben.

Eigenschaft | Information
Bereich | Nummer wird vom Konfigurator automatisch vergeben.
Basisadresse | Startadresse für den freien Speicher, kann zum Beispiel über das Hilscher Tool (im Lieferumfang der Karte) ermittelt werden.
Länge | Länge des freien Bereichs. Achtung: muss in Byte angegeben werden.
Hinzufügen | Erstellt einen neuen Eintrag in der Liste.
Entfernen | Löscht einen bestehenden Eintrag aus der Liste.


RTK Logs

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Logs

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Meldungen des RTK werden im Bereich Log messages angezeigt.

Eigenschaft | Information
Datum/Uhrzeit | Wann ist das Ereignis eingetreten.
Typ | Welche Art von Meldung (Status, Fehler, ...)
Beschreibung | Was ist passiert.


RTK Konfigurator Beenden

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> zenon Logic RTK Konfiguration -> RTK Konfigurator Beenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Schaltfläche OK werden alle Änderungen übernommen und der Konfigurator wird geschlossen. Falls das System neu gestartet werden muss, wird eine entsprechende Meldung angezigt.

Wird der Konfigurator über einen Klick auf das Symbol zum Schließen (X) oder Abbrechen beendet, erfolgt eine Abfrage, ob Änderungen übernommen werden sollen.


Blue Screen Handling

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> Blue Screen Handling

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein möglicher Bluescreen of Death (BSOD) wird von der zenon Logic RTK verzögerungsfrei festgestellt.

Ist die zenon Logic RTK für ein Stillsetzen bei einem BSOD konfiguriert, wird - sofern definiert - das Shut-down-Programm sofort angestoßen, d.h. noch vor dem theoretisch nächsten Zyklus.

Ist die zenon Logic RTK für ein Weiterlaufen konfiguriert, wird der nächste Zyklus nach einer minimalen Verzögerung von ca. 10 ms (umschalten des Grafik Modus) ausgeführt.

Um dies zu erreichen, muss in der zenon Logic Applikation die zenon Logic Funktion RTK_OnBugCheck der zenon Logic Standard-Bibliothek mit TRUE beaufschlagt sein.

attention Achtung

Im Fall eines BSOD kann das Ausführen der zenon Logic Applikation eingeschränkt sein.

Folgende Funktionen werden danach nicht mehr unterstützt:

Dateioperationen, TCP Funktionen, Funktionen der Seriellen Schnittstelle, Nicht-Echtzeit Feldbustreiber, System-Uhr Funktionen, RETAIN Variablen, Schreiben von Log Messages (Änderungen durch Produkt-Versionszyklen vorbehalten).

Um in der zenon Logic Applikation festzustellen, ob sich ein BSOD erreignet hat, verwenden Sie die zenon Logic Funktion RTK_IsBugCheck.

Systemvoraussetzungen für ein reibungsloses weiterlaufen nach einem BSOD:

  • Windows® XP SP2 oder höher (z.B. Vista)
  • Pentium 3, 4 oder M (Centrino) oder höher

Optionen für Profibus Master (Hilscher CIF Profibus):

Kein Reset nach Stop (Ausgänge beibehalten): Ist diese Option gesetzt, bleiben die Ausgänge der Profibus I/Os nach der Shut-down-Sequenz gesetzt. Anderenfalls würden die Ausgänge nach der Shut-down-Sequenz auf die parametrierten Ersatzwerte geschaltet.


Fehlercodes beim Starten der zenon Logic RTK

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic Runtime mit Real Time Kernel (RTK) -> Fehlercodes beim Starten der zenon Logic RTK

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der angezeigte Fehlercode bezieht sich auf das Starten der STRATONRTKVM.exe

Fehlercode | Bedeutung
0x00000000 | Wenn in der zenon Logic RTK ein Fehler aufgetreten ist, wird der Fehler meist durch eine zweiteilige Meldung näher beschrieben. Die Log Meldung mit Fehlercode 0x00000000 kann jeweils ignoriert werden.
0xFFFFFFFF | Beim Starten der STRATONRTKVM.exe ist ein Time-Out aufgetreten ist. Mögliche Ursachen: STRATONRTKVM.exe ist nicht vorhanden, zu hohe Auslastung des Systems. Achtung: Nach einem solchen Fehler ist sicherzustellen, dass sowohl die STRATONRTKVM.exe wie auch die STRATONRTK.exe nicht mehr läuft (Taskmanager) bevor STRATONRTK erneut gestartet wird.
0x00000001 – 0x0000FFFF | Ist ein Fehler code der zenon Logic Virtual Machine (COPALP Fehlercode).
0xFFFF01, 0xFFFF02 | Fehler beim Laden der Nicht-Echtzeit Bus-Treiber: wahrscheinliche Ursache: inkompatibler (alte Version) einer/mehrerer Bustreiber.
0xFFFFF000 | rtHAL Fehlercode (0xFFFFF000 wird zum rtHAL code addiert)
0xFFFFF001 | Stellen Sie sicher, dass der rtHAL Treiber korrekt installiert wurde. Sollte das Problem weiterhin bestehen wenden Sie sich an Ihren zenon Support und teilen Sie uns bitte die genaue Windows Version (Service pack, Hot fixes, …) und die verwendete Windows HAL mit. Der Name der verwendeten HAL wird im Geräte-Manager unter Computer angezeigt. Systemvoraussetzungen: ACPI, Pentium II oder AMD Athlon oder höher.

rtHAL Fehlercodes

0x0

Kein Fehler

Mögliche Fehlercodes beim Starten

Fehlercode | Bedeutung
0x1 | Fehler beim Laden des Treibers. Ursache: Treiber nicht korrekt registriert.
0x2 | START konnte nicht durchgeführt werden. Ursache: Falsche Version des Treibers installiert.

Fehlercodes während der Laufzeit

Fehlercode | Bedeutung
0x6 | SUSPEND konnte nicht durchgeführt werden.
0x7 | STOP konnte nicht durchgeführt werden.

Interne STRATON Virtual Machine Fehlercodes

#define T5RET_OK 0
#define T5RET_ERROR 1
#define T5RET_BADCODE 2 /* invalid app code - bad header */
#define T5RET_BADCODETARGET 3 /* invalid code - bad target id */
#define T5RET_BADCODEVERSION 4 /* invalid code - bad version */
#define T5RET_EXECSIZE 5 /* exec buffer overflow */
#define T5RET_BADREQUEST 6 /* unknown comm request */
#define T5RET_SERVEREAD 7 /* cannot process read request */
#define T5RET_UNKNOWNTIC 8 /* unknocn tic code */
#define T5RET_DATA8OVERFLOW 9 /* too many DATA8 used */
#define T5RET_DATA16OVERFLOW 10 /* too many DATA16 used */
#define T5RET_DATA32OVERFLOW 11 /* too many DATA32 used */
#define T5RET_DIVZERO 12 /* division by 0 in TIC (32bit) */
#define T5RET_TIMEOVERFLOW 13 /* too many TIME variables */
#define T5RET_CANTACTIME 14 /* active timers not supported */
#define T5RET_SAFETICLOOP 15 /* awful loop in TIC (safe mode) */
#define T5RET_OUTOFTIC 16 /* TIC code ointer out of range */
#define T5RET_UNKNOWNSTF 17 /* not supported std function */
#define T5RET_LDIVZERO 18 /* division by 0 in TIC (64bit) */
#define T5RET_DATA64OVERFLOW 19 /* too many DATA64 used */
#define T5RET_STRINGOVERFLOW 20 /* too many strings */
#define T5RET_SDIVZERO 21 /* division by zero in TIC (8 bit) */
#define T5RET_WDIVZERO 22 /* division by zero in TIC (16 bit) */
#define T5RET_HOTRESOURCES 23 /* HOT restart: system resources used */
#define T5RET_HOTMAP 24 /* invalid var map in hot restart */
#define T5RET_HOTACTIME 25 /* change of active timer map */
#define T5RET_HOTSTAMP 26 /* bad build stamp for hot restart */
#define T5RET_HOTSFC 27 /* SFC changed - no hot restart! */
#define T5RET_HOTRETAIN 28 /* retain def has changed - no hot */
#define T5RET_HOTFORMAT 29 /* bad DB format - no hot restart! */
#define T5RET_CYCLEOVERFLOW 30 /* cycle time overflow */
#define T5RET_RETAINSTORING 31 /* cant store retain variables */
#define T5RET_ARRAYBOUND 32 /* array index out of bounds */
#define T5RET_RECURSE 33 /* recursive call of sub-program */
#define T5RET_XVOVERFLOW 34 /* too many external variables used */
#define T5RET_NOBSAMPLING 35 /* sampling trace not supported */
#define T5RET_TASKOVERFLOW 36 /* too many tasks */
#define T5RET_HOTCALLSTACK 37 /* call stack overflow (hot) */
#define T5RET_STACKOVER 38 /* stack overlow */
#define T5RET_HOTASI 39 /* cannot hot restart ASi */
#define T5RET_TOXC 40 /* OXC limit reached */
#define T5RET_WOXC 41 /* OXC info */


Redundanz zenon Logic und zenon

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Redundanz zenon Logic und zenon

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Logic kann redundant eingesetzt werden und bietet die Möglichkeit, die zenon Redundanz mit der zenon Logic Redundanz zu kombinieren.

In diesem Kapitel wird die Konfiguration der zenon/zenon Logic Redundanz beschrieben. Die zenon/zenon Logic Redundanz wird im Folgenden als SCADA Logic Redundanz bezeichnet.

Weitere Begrifflichkeiten:

  • zenon Server = Dominanter zenon Server
  • zenon SB = zenon Standby-Server
  • Aktive zenon Logic Runtime = Ausführende zenon Logic Runtime-Instanz
  • Passive zenon Logic Runtime = Backupsystem (Standby) der zenon Logic Runtime

Betriebssysteme

Die Redundanz kann mit folgenden Betriebssystem umgesetzt werden:

  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows CE

Noch in diesem Kapitel

Voraussetzungen

Redundanz konfigurieren


Voraussetzungen

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Redundanz zenon Logic und zenon -> Voraussetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die SCADA Logic Redundanz werden zwei PCs benötigt. Die beiden PCs werden über Ethernet TCP/IP (100 MBit, empfohlen 1 GBit) verbunden.

attention Achtung

Die SCADA Logic Redundanz setzt voraus, dass beide Systeme, zenon und zenon Logic, auf einem PC installiert sind.

Es wird empfohlen, die Zykluszeit des zenon Logic Projekts auf das Doppelte der Zykluszeit eines Einzelprojekts einzustellen, mindestens aber auf 50 ms.

Da man bei der SCADA-Logic davon ausgeht, dass zenon Logic und zenon über den sogenanten Shared Memory Treiber (zenon Logic zu zenonRT Verbindung) kommunizieren, muss zu jeder Zeit gewährleistet sein, dass der zenon Server und die aktive zenon Logic Runtime auf demselben PC laufen.

Um eine einseitige Umschaltung von zenon Logic bzw. zenon zu verhindern, muss eine Synchronisation zwischen der zenon Logic Runtime und zenon Runtime projektiert werden. Dafür wird ein Watchdog verwendet.

Watchdog

zenon Logic

Der Status des zenon Projekts (Standalone/Server/Standby-Server/Client) wird über den Shared Memory Kommandobereich übertragen und vom Redundanz-Funktionsblock ausgewertet. Dieser hat als Eingang einen frei definierbaren Time-out Wert. Als Ausgang werden Binärwerte für Redundanzumschaltung sowie aktive, passiv, ausgefallene Runtimes etc. ausgegeben. Diese bestimmen die Reaktion der zenon Logic Runtime.

Um klar festzustellen, von welchem zenon Projekt der Watchdog bzw. der Status kommt, muss:

  • der zenon Runtime-Treiber bzw. der Shared Memory Bereich über die zenon Projekt-GUID verfügen
  • der zenon Runtime-Treiber bzw. der Shared Memory Bereich über den zenon Logic Projektnamen verfügen

zenon

Ein vom zenon Runtime-Treiber generierter Watchdog wird über den Shared Memory Kommandobereich übertragen und in zenon ausgewertet. Diese Auswertung erfolgt je nach Einstellung der Eigenschaften Ausfallerkennung nach [s] und Funktion für Ausfallerkennung. Diese definieren eine Time-out Zeit und eine Funktion (normalerweise Runtime beenden).

Interne ID: Voraussetzungen

Runtime beenden

Diese Funktion beendet die Runtime des Leitsystems.

Mehr im Online-Handbuch

Interne ID: Voraussetzungen

Funktion für Ausfallerkennung

Auswahl der Funktion, die nach Ablauf der der in der Eigenschaft Ausfallerkennung nach [s] definierten Zeitspanne ausgeführt werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Funktion.

Nach Ablauf des Timeouts beginnt die Watchdogprüfung erst bei erneutem Anmelden der Runtime neu. Wird eine Funktion aus einem anderen Projekt verwendet, muss dieses Projekt bereits geladen sein, wenn das Projekt mit dem integrierten zenon Logic Projekt geladen wird.

Mehr in der Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Voraussetzungen

Ausfallerkennung nach [s]

Angabe der Zeit in Sekunden, innerhalb der sich der Watchdog der zenon Logic Runtime ändern muss. Nach Überschreitung wird die in Funktion für Ausfallerkennung projektierte Funktion ausgeführt.

0: deaktiviert den Watchdog

Default: für neue Projekte 30 s, für bestehende Projekte 0 s.

Mehr in der Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Damit hier der richtige Watchdog ausgewertet wird, muss auch bei mehreren aktiven zenon Logic Projekten erkennbar sein, von welchem zenon Logic Projekt der Watchdog kommt. Dazu muss:

  • der zenon Runtime-Treiber bzw. der Shared Memory Bereich über den zenon Logic Projektnamen verfügen

attention Achtung

Der Start der zenon Runtime darf nicht über den zenon Editor erfolgen, sondern muss über den direkten Aufruf der zenon Runtime geschehen!

Die zenon Redundanz muss eingerichtet sein. Details: Siehe Hilfekapitel Netzwerk.


Redundanz konfigurieren

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Redundanz zenon Logic und zenon -> Redundanz konfigurieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon Logic und zenon können sich im redundanten Betrieb gegenseitig über einen Watchdog kontrollieren. Fällt die zenon Logic Runtime aus:

  • wird auch die lokale zenon Runtime beendet
  • werden beide Systeme auf Redundazbetrieb geschaltet

Konfiguration in zenon

Um die Redundanz zu aktivieren:

  • aktivieren Sie die Eigenschaft Redundanter Betrieb in der Gruppe Runtime der Eigenschaften des zenon Logic Projekts in zenon

    Interne ID: Redundanz konfigurieren

    Runtime

    Eigenschaften für die zenon Logic Runtime (Soft SPS).

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Redundanz konfigurieren

    Redundanter Betrieb

    Aktiv: Die zenon Logic Runtime wird redundant gestartet.
    Inaktiv: Die zenon Logic Runtime wird nicht redundant gestartet.

    ACHTUNG: Die Standby-Runtime muss gestartet werden.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • definieren Sie
    • Ausfallerkennung nach [s]

      Interne ID: Redundanz konfigurieren

      Ausfallerkennung nach [s]

      Angabe der Zeit in Sekunden, innerhalb der sich der Watchdog der zenon Logic Runtime ändern muss. Nach Überschreitung wird die in Funktion für Ausfallerkennung projektierte Funktion ausgeführt.

      Interne ID: Redundanz konfigurieren

      Funktion für Ausfallerkennung

      Auswahl der Funktion, die nach Ablauf der der in der Eigenschaft Ausfallerkennung nach [s] definierten Zeitspanne ausgeführt werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Funktion.

      Nach Ablauf des Timeouts beginnt die Watchdogprüfung erst bei erneutem Anmelden der Runtime neu. Wird eine Funktion aus einem anderen Projekt verwendet, muss dieses Projekt bereits geladen sein, wenn das Projekt mit dem integrierten zenon Logic Projekt geladen wird.

      Mehr in der Online-Handbuch

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

      0: deaktiviert den Watchdog

      Default: für neue Projekte 30 s, für bestehende Projekte 0 s.

      Mehr in der Online-Handbuch.

      Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    • Funktion für Ausfallerkennung

Konfiguration in zenon Logic

Die Einstellungen zur Redundanz werden in der straton Runtime in der Registerkarte Redundanz vorgenommen.

Watchdog

Mit dem Watchdog prüft die jeweils andere Seite laufend auf Veränderung dieses Zählers. Wenn sich der Zähler für eine projektierbare Zeit nicht verändert, wird dies dem Programm mitgeteilt:

  • zenon: eine beim integrierten Projekt projektierte Funktion wird ausgeführt (Funktion für Ausfallerkennung)
  • zenon Logic: ein Funktionsblock Ausgang wird aktiv

Die Watchdogprüfung beginnt, sobald die andere Seite ihren Watchdog das erste Mal verändert hat. Dies ist nötig, da Zeit zum Start benötigt wird, bzw. die zenon Logic Runtime nicht unbedingt mit der zenon Runtime starten muss.

info Info

Wird die zenon Logic Runtime manuell gestartet, müssen folgende Kommandozeilenparamter gesetzt werden:

  • zenon Pfad:

    ZENPATH=<Pfad>

  • Name zenon Projekt:

    ZENPROJECT=<Name>

  • Information, ob zenon Netzwerkprojekt:

    REDENABLE=<0,1>

    REDZENON=<0,1>

Watchdog in zenon

zenon prüft den zenon Logic Runtime Watchdog wenn:

  • die zenon Logic Runtime Code ausführt, Timeout <> 0 ist und die Runtime zu einem integrierten zenon Logic Projekt zugeordnet werden kann
  • die zenon Logic Runtime gestoppt wird
  • die zenon Logic Runtime passiv ist oder passiv startet
  • die zenon Logic Runtime beendet wird und vorher passiv oder aktiv war

Funktion für Ausfallerkennung

Mit der Eigenschaft Funktion für Ausfallerkennung wird eine Funktion ausgewählt, die ausgeführt wird, sobald das in Ausfallerkennung nach [s] definierte Timeout für den Watchdog abgelaufen ist. Eine erneute Prüfung des Watchdogs erfolgt erst, wenn die Runtime erneut angemeldet wird.

Wird eine Funktion aus einem anderen Projekt verwendet, muss dieses Projekt bereits geladen sein, wenn das Projekt mit dem integrierten zenon Logic Projekt geladen wird

Protokollierung

Die Anbindung des zenon Logic zenRt Treibers kann mit dem Diagnose Viewer protokolliert werden. Der Modulname ist zenon Logic. Jede Meldung beinhaltet den Namen des zenon und den des zenon Logic Projektes. Die Protokollierung umfasst:

  • Error
    • zprj:<z-projekt> sprj:<s-projekt> Runtime <Runtime-Prozess-ID> watchdog expired.
      Watchdog der Runtime wurde zu lange durch die Runtime nicht bedient.
    • zprj:<z-projekt> sprj: <s-projekt> Runtime: <Runtime-Prozess-ID> Unknown straton project.
      zenon Logic Projekt kann keinem integrierten zenon Projekt zugeordnet werden.
  • Warnings
    • vm: <Vm-Prozess-ID> zenon project '<Name>' unknown
      Name des zenon Logic Ptojekts in zenon unbekannt.

Watchdog in zenon Logic Runtime

Für den zenon Logic Watchdog gilt:

  • Der zenon Watchdog wird laufend überprüft solange das Timeout der zenonAusfallerkennung <> 0 ist.
    Diese Überprüfung findet statt wenn:
    • Code ausgeführt wird
    • Die Runtime aktiv oder passiv ist.

Funktionsbausteine zenrt_Red und RedSwitch

In zenon Logic kann mit Hilfe von Funktionsbausteinen überprüft werden, ob eine Verbindung zu einem zenon Server besteht und der Zustand von zenon Logic bei Bedarf umgeschaltet werden .

Der Baustein zenrt_Red überprüft mittels der Timout-Informationen aus dem Treiber "straton_to_zenon_Runtime_Connection", ob zenon Logic mit einem zenon Server verbunden ist. Ist das nicht der Fall, kann mit dem Funktionsbaustein RedSwitch das betroffene zenon Logic auf inaktiv geschaltet und der Standby auf aktiv geschaltet werden.

Weiter Informationen zu den Funktionsbausteinen finden Sie in der zenon Logic Online-Hilfe.

Zeitbehandlung im Funktionsbaustein zenrt_Red

Die Anzahl der Umschaltversuche zählen im Takt des Timeouts hoch. Ist das zenon Logic Runtime Projekt einem zenon Netzwerkprojekt zugeordnet, wird die Netzwerktimeoutzeit (Eigenschaft Timeout [s] in Gruppe Netzwerk) zur Ausfallerkennungszeit (Eigenschaft Ausfallerkennung nach [s]) hinzugefügt. Die Zeit, der der Ausgang ERROR aktiv wird, ist nun nicht mehr MAX_SWITCH * Zyklus sondern MAX_SWITCH * Timeout [+ Netztimeout].

Interne ID: Redundanz konfigurieren

Netzwerk

Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Redundanz konfigurieren

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: Redundanz konfigurieren

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Als Standby-Server wird der nicht prozessführend, nicht dominante zenon Rechner betrachtet.
Der nicht prozessführende, dominante Rechner (Server startet als Standby) wird nicht als Standby betrachtet.


OEM Spezifikation

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> OEM Spezifikation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser OEM Spezifikation werden die Möglichkeiten der COPA-DATA zenon Logic Runtime beschrieben, auf welche in der zenon Logic Workbench Hilfe mit "siehe OEM-Spezifikation" verwiesen wird.

Konfiguration (Projekteigenschaften)

Die zenon Logic Workbench enthält standardmäßig viele Features und eine reichhaltige Bibliothek an Funktionen und Funktionsblöcken. Abhängig von der Runtime Konfiguration können einige Features oder Bausteine nicht verfügbar sein. Daher ist es möglich, Konfigurationen für die Workbench auszuwählen, um die Features hervorzuheben, die von der Runtime nicht unterstützt werden.

In der zenon Logic Workbench steht unter Projekt -> Konfiguration... eine Liste an Konfigurationen zur Verfügung. Diese kann sich mit den Produkt-/Versionszyklen ändern.

Dateiverwaltungsfunktionen (Funktionsbausteine)

Diese Funktionen ermöglichen sequentielle Lese-/Schreiboperationen in Dateien.

Folgende Funktionen werden von den zenon Logic Runtime-Versionen

  • CE
  • RT (PC)
  • RTK (PC)

unterstützt und sind nicht-blockierend implementiert:

F_ROPEN, F_WOPEN, F_AOPEN, F_CLOSE, F_EOF, FA_READ, FA_WRITE, FM_READ, FM_WRITE, FB_READ, FB_WRITE, F_EXIST, F_GETSIZE, F_COPY, F_DELETE, F_RENAME, LogFileCSV

Folgende Funktionen werden nur von den zenon Logic Runtime-Versionen

  • CE
  • RT (PC)

unterstützt und sind blockierend implementiert:

F_EXIST, F_GETSIZE, F_COPY, F_DELETE, F_RENAME

Mögliche Pfade variieren je nach Betriebssystem (XP, Vista). Bitte beachten Sie, dass bei Windows Vista mit eingeschaltetem UAC (User Account Control) manche Verzeichnisse schreibgeschützt sind.

SFC Ausführung

Die Ausführung von SFC Programmen, entspricht der eines T5 Standard Zielsystems und folgt den Angaben der zenon Logic Workbench Hilfe.

Die Exklusivität von Transitionen innerhalb einer Divergenz wird unterstützt.

Applikationen vernetzen - Binding

Es können maximal 65535 Binding-Variablen im Netzwerk publiziert werden. Allerdings reduziert sich dieser Wert mit jeder Variablen, die über den Eventbetrieb zu zenon gesendet wird.

Die Standard IP Port Nummer einer zenon Logic Runtime ist 9000.

Projekteigenschaften - "C" Compiler

Dieses Feature wird von allen zenon Logic Zielsystemen (RT, CE, RTK) unterstützt. Es können alle standardmäßig in der zenon Logic Workbench vorgeschlagenen C-Compiler verwendet werden. Achtung: Verwenden Sie nur den Default-Namen der erzeugten Runtime-DLL.

LogFileCSV (Funktionsbaustein)

Siehe erster Punkt: Dateiverwaltungsfunktionen (Funktionsbausteine).

Weitere OEM-relevante Features und Funktionen:

Feature | RT (PC) | RTK (PC) | CE
DTAT (Funktionsbaustein) | x | x | x
TCP/IP Management Funktionen | x | x | x
Dynamische Speicherzuweisungsfunktionen | x | x | x
PrintF (Funktion) | x | x | x
Step by Step Debugging | x | x | x
Funktionen zur Verwaltung der Echtzeituhr | x | x | x
Digitale Sampling-Aufzeichnung | x | x | x
UDP Management Funktionen | x | x | x
T5 Registry Management Funktionen | - | - | -
DTFORMAT (Funktion) | x | x | x
GETSYSINFO (Funktion) - _SYSINFO_CYCLESTAMP_MS | x | x | x
Variablen Statusbits | x | -1 | x
DAY_TIME (Funktion) | x | x | x
SET_DAY_TIME (Funktion)2 | x | - | x

Legende:

  • x: Unterstützt
    • 1: Treiber, die Variablen Statusbits unterstützen, werden von der zenon Logic RTK nur emuliert oder nicht unterstützt. Daher kann auf die Statusbits bzw. den Zeitstempel nicht zugegriffen werden.
    • 2: zenonarbeitet intern mit UNIX-Zeit. Daher sind nur Systemzeiten innerhalb deren Gültigkeit zulässig (0-MAXDINT beginnend mit 1.1.1970 0:00 GMT). Daten, die auf einen früheren Zeitpunkt verweisen, beeinträchtigen die Funktionsweise der zenon Runtime.
  • -: Nicht unterstützt

RETAIN Variablen (Remanente Merker)

RETAIN Variablen werden beim normalen Stoppen oder Schließen der Runtime auf dem definierten Speicherort abgelegt, für gewöhnlich im Instanzenpfad (Übergabeparameter PATH). Je nach System ist dies die Festplatte oder eine Flash-Karte.

Mit der Funktion "WriteHot" können RETAIN- und Hot-Restart-Daten explizit gespeichert werden, zum Beispiel nach jeder Änderung oder zyklisch.

Manche zenon Logic I/O Treiber unterstützen die Ablage der RETAIN Werte auf das SRAM (batteriegepuffertes RAM), z.B. der ThinkIO/System758-Treiber.

Damit bei einem Neustart der SPS Applikation die RETAIN Werte geladen werden, muss die zenon Logic Runtime mit den entsprechenden Übergabeparametern/Einstellungen gestartet werden (Kaltstart - RETAIN Variablen laden).

I/O Treiber

Informationen zu unterstützten I/O Treibern finden Sie hier: zenon Logic I/O Treiber Unterstützung

Informationen zur Unterstützung von Online Change oder Hot-Restart finden Sie hier: zenon Logic I/O Treiber: Hot-Restart/Online Change


Weiterleitung von Zeitstempel und der Variablen Statusinformation

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Weiterleitung von Zeitstempel und der Variablen Statusinformation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab Version 6.22 SP1 Build 3 leitet die zenon Logic Runtime Zeitstempel und Variablen Statusinformationen von zenon Logic I/O Treibern automatisch an den Eventhandler der zenon Logic Runtime und somit über straton32 an zenon weiter. Damit werden in zenon (z.B. CEL) die Zeitstempel der Quelle (I/O Treiber Slave oder Server) angezeigt und nicht der Zeitstempel der zenon Logic Runtime.

Folgende Voraussetzungen müssen dafür gegeben sein:

  • Die Variable muss über einen Zeitstempel im zenon Logic I/O Treiber verfügen. Dies ist abhängig vom Protokoll. Manche Treiber stellen keine Zeitstempelung zur Verfügung.
  • Das zenon Logic Projekt muss mit eingeschaltetem Compiler-Flag Statusbits für Variablen mit Profil anlegen kompiliert worden und geladen sein.

Überblick Weiterleitung des Zeitstempels:

Hinweis: Die Bezeichner zenon und zenon Logic in der Grafik sind beispielhaft. Sie können je nach Konfiguration anders lauten und entsprechen zenon und zenon Logic.


zenon Logic I/O Treiber Unterstützung

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic I/O Treiber Unterstützung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Von den verschiedenen zenon Logic Runtime Typen unterstütze I/O Treiber:

Treiber | RT (PC) | RTK (PC) | CE
Advantech ADAM 5550 | - | - | -
Anybus Konfiguration | x | E | -
ApplicomIO Konfiguration | x | E | -
AS-interface | x | - | -
BECKHOFF CX1000 | - | - | x
Brodersen IOTOOLS | x | E | -
CAN-bus | - | - | -
Hilscher CIF Profibus | x | x1 | x
Hilscher SYCON Konfiguration | x | E | x2
Hilscher SYCON Konfiguration [universal] | x | x | x
Hilscher SYCON.net Konfiguration | x | E | -
IEC 60870 Slave | x | - | x
IEC 61850 Client | x | E1 | x
IEC 61850 Server | x | - | x
Interbus-S | x | E | -
MODBUS Master Protokoll | x | E | x
MODBUS Slave Protokoll | x | E | x
PROFINET IO | x | E | x
SoftNet ProfibusDP | x | E | -
straton zu zenon Runtime Verbindung | x | - | x
ThinkIO/IO System 758 | - | - | x
Wago 750-860 | - | - | -
Weihenstephan Standard - Client | x | E | x
Win32 Shared memory | x | - | -
XFlow | - | - | -

Legende

x: Voll unterstützt

-: Nicht unterstützt

E: Wird emuliert ausgeführt (Performance Einbußen möglich, Determinismus im SPS Zyklus eingeschränkt, Treiber-Ausfall bei einem BSOD)

1: Die Treiber-spezifischen Funktionsbausteine funktioneren unter zenon Logic RTK nicht.

2: Hilscher DLLs müssen auf der Zielplattform verfügbar sein


zenon Logic I/O Treiber: Hot-Restart/Online Change

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> zenon Logic I/O Treiber: Hot-Restart/Online Change

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Logic I/O Treiber unterstützten Hot-Restart bzw. Online Change in unterschiedlicher Weise:

Treiber | Hot-Restart | Online Change | Online Change mit Änderung der Bustreiber-konfiguration
Anybus Konfiguration | x | x | x1
ApplicomIO Konfiguration | x | x | x1
AS-interface | x | x | x1
BECKHOFF CX1000 | x | x | -
Brodersen IOTOOLS | x | x | x1
Hilscher CIF Profibus | x | x | -
Hilscher SYCON Konfiguration | x | x | x1
Hischer SYCON Konfiguration [universal] | x | x | x1
Hilscher SYCON.net Konfiguration | x | x | x1
IEC 61850 Client | x | x | -
Interbus-S | x | x | -
MODBUS Master Protokoll | x | x | x1
MODBUS Slave Protokoll | x | x | x1
PROFINET IO | x | x | -
SoftNet ProfibusDP | x | x | x1
straton zu zenon Runtime Verbindung | x | x | -2
ThinkIO/IO System 758 | x | x | -
Weihenstephan Standard - Client | x | x | x1
Win32 Shared memory | x | x | x1

Legende

x: Funktionalität vorhanden

-: Funktionalität nicht vorhanden

1: Online Change mit Änderung der Bustreiberkonfiguration hat immer eine Reinitialisierung des I/O Treibers zur Folge. Durch die Reinitialisierung können I/Os kurzfristig ausfallen!

2: Keine Änderung in der Bustreiberkonfiguration möglich.


Fehlermeldungen

Handbuch -> zenon Logic -> zenon Logic Runtime (Soft SPS) -> Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler während der Ausführung werden in der Log-Datei protokolliert.

Fehlermeldung | Beschreibung
General error. | Nicht näher spezifizierter Fehler.
Invalid application code - bad header. | STRATON.cod Datei ungültig. Header ungültig.
Invalid application code - bad target ID. | STRATON.cod Datei ungültig. Target ID ungültig.
Invalid application code - bad version. | STRATON.cod Datei ungültig. Version ungültig.
Unknown communication request. | Host und Runtime nicht kompatibel (T5 Protokoll).
Cannot process read request. | Eingehende Kommunikationsanforderung kann nicht verarbeitet werden.
Unknown TIC code. | Ungültige Anweisung in der straton.cod Datei.
Too many DATA8 used. | Zu viele SINT/USINT Variablen verwendet.
Too many DATA16 used. | Zu viele INT/UINT Variablen verwendet.
Too many DATA32 used. | Zu viele DINT/UDINT/REAL Variablen verwendet.
Division by 0 in TIC (32bit). | Division durch Null in der SPS-Logik des Anwenders.
Too many TIME variables. | Speicherüberlauf beim On Line Change.
Infinite loop in TIC (safe mode). | Nicht beendete Schleife im Applikationscode.
Standard function used, which is not supported by this runtime. | SPS-Logik des Anwenders verweist auf eine Funktion, die in dieser Version der Runtime nicht verfügbar ist.
Division by 0 in TIC (64bit). | Division durch Null in der SPS-Logik des Anwenders.
Too many DATA64 used. | Zu viele LINT/LREAL Variablen verwendet.
Too many strings. | Speicherüberlauf beim On Line Change.
Division by zero in TIC (8 bit). | Division durch Null in der SPS-Logik des Anwenders.
Division by zero in TIC (16 bit). | Division durch Null in der SPS-Logik des Anwenders.
HOT restart: System resources used. | Hot Restart nicht möglich.
Invalid variable map in hot restart. | Hot Restart nicht möglich.
Bad build stamp for hot restart. | Hot Restart nicht möglich. Ungültige straton.cod Version.
SFC changed - no hot restart! | Hot Restart nicht möglich.
Retain definition has changed - no hot restart. | Hot Restart nicht möglich.
Bad DB format - no hot restart! | Hot Restart nicht möglich.
Cycle time overflow. | Zykluszeitüberlauf
Can not store retain variables. | Nicht genügend Speicherplatz um RETAIN Variablen zu speichern.
Array index out of bounds. | Zugriff auf ungültigen Array Index.
Recursive call of sub-program. | Ein Sub-Programm ruft sich selbst auf.
Too many external variables used. | Speicherüberlauf beim On Line Change.
Too many tasks. | Speicherüberlauf beim On Line Change.
Call stack overflow (hot). | Speicherüberlauf beim On Line Change.
Stack overflow. | Zu viele Aufrufe verschachtelter Sub-Programme.
Can not hot restart (ASi). | Hot Restart nicht möglich (Asi-Bus Treiber).
Online change not supported. | Online-change nicht möglich
Online change failed - Bad code. | Online-change nicht möglich. Ungültige straton.cod Datei
Online change - Not the same application. | Online-change nicht möglich
Online change failed - IO drivers. | Online-change nicht möglich
Online change failed - CT segment changed. | Online-change nicht möglich
Online change failed - bus drivers. | Online-change nicht möglich. Bustreiber erlaubt online-change nicht.
Online change failed - variable map / profiles. | Online-change nicht möglich
Online change failed - tasks. | Online-change nicht möglich
Online change failed - MODBUS. | Online-change nicht möglich
Online change failed - CAN bus. | Online-change nicht möglich
Online change failed - event production. | Online-change nicht möglich
Online change failed - change D8 alloc. | Online-change nicht möglich
Online change failed - change D16 alloc. | Online-change nicht möglich
Online change failed - change D32 alloc. | Online-change nicht möglich
Online change failed - change D64 alloc. | Online-change nicht möglich
Online change failed - change TMR alloc. | Online-change nicht möglich
Online change failed - change STR alloc. | Online-change nicht möglich
Online change failed - change FBI alloc. | Online-change nicht möglich
Online change failed - change CFC alloc. | Online-change nicht möglich
Online change failed - change XV alloc. | Online-change nicht möglich
Online change failed - STR buff size. | Online-change nicht möglich
Online change failed - STR length. | Online-change nicht möglich
Online change failed - FBI buffer. | Online-change nicht möglich
Online change failed - FBI changed. | Online-change nicht möglich
Online change failed - Program style. | Online-change nicht möglich
Online change failed - Number of programs. | Online-change nicht möglich


zenon Logic Runtime Manager

Handbuch -> zenon Logic -> zenon Logic Runtime Manager

Der zenon Logic Runtime Manager verwaltet alle stand alone/manuell zu startenden zenon Logic Runtime Projekte auf Ihrem Computer. Es spielt keine Rolle ob eine zenon Runtime auf diesem Computer installiert ist oder nicht.

Noch in diesem Kapitel

Warum soll der zenon Logic Runtime Manager verwendet werden?

Hauptmenü

Eigenschaftenhilfe


Warum soll der zenon Logic Runtime Manager verwendet werden?

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Warum soll der zenon Logic Runtime Manager verwendet werden?

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Wenn Sie Ihr zenon Logic Projekt in zenon erstellt haben und die zenon Eigenschaft des zenon Logic Projekts RT Starttyp auf manuell starten gesetzt ist, ist der zenon Logic Runtime Manager das optimale Werkzeug, um die Parameter für den manuellen Start zu organisieren.
  • Wenn Sie Ihre zenon Logic Runtime Projekte beim Booten des Windows Betriebssystems starten möchten, können Sie dies im zenon Logic Runtime Manager mit einem Mausklick einstellen.
  • Wenn Sie Ihre zenon Logic Projekte reorganisieren möchten, könne Sie das mit dem zenon Logic Runtime Manager machen.
  • Wenn Sie Ihr zenon Logic Runtime autark (ohne zenon Runtime) laufen lassen möchten, geschieht der Aufruf der zenon Logic Runtime Instanzen am Besten mit dem zenon Logic Runtime Manager.


Hauptmenü

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Hauptmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Konfigurationen: Hier werden die zenon Logic Runtime Projekte verwaltet
  • Sprachen: Hier kann die Sprach online umgestellt werden
  • Einstellungen: Eintrag des Pfades der zenon Logic Runtime
  • ?: Aufruf der Hilfe
  • Beenden: Beenden des Programms - Hinweis: Vergessen Sie nicht die Einstellungen abzuspeichern, bevor Sie den zenon Logic Runtime Manager beenden!


Eigenschaftenhilfe

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Führen Sie den Mauszeiger über ein Element im zenon Logic Runtime Manager, um den dazugehörigen Hilfetext in der Eigenschaftenhilfe anzuzeigen.

Zusätzlich sind alle Elemente des zenon Logic Runtime Managers hier zusammengefasst beschrieben:

Noch in diesem Kapitel

Konfigurationsliste

zenon Logic Projekt Verzeichnis

Name der Konfiguration

Port (Main)

Port (Binding)

Startup

Im Schrittmodus starten

Windows Echtzeit Priorität

Harte Echtzeit

Report Ausgabe

Autostart

Schaltfläche "Neu"

Schaltfläche "Bearbeiten"

Schaltfläche "Speichern"

Schaltfläche "Löschen"

Schaltfläche "Start"

zenon Logic Runtime (Einstellungen)

Sprachwahl (Sprachen)

Startbilschirm anzeigen (Einstellungen)


Konfigurationsliste

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Konfigurationsliste

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Liste enthält alle verfügbaren zenon Logic Runtime Konfigurationen.

Klicken Sie auf einen Eintrag in der Liste, um die Parametereinstellungen anzuzeigen.

Klicken Sie danach auf Bearbeiten, um die Parameter zu ändern.

Klicken Sie auf Speichern, um die Änderungen zu sichern.


zenon Logic Projekt Verzeichnis

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> zenon Logic Projekt Verzeichnis

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der ausgewählte Pfad des zenon Logic Runtime Projekts (Ablageort des SPS-Codes) wird hier automatisch eingetragen. Dieser Eintrag kann mit der Hand bzw. durch Linksklick auf das Verzeichnis-Symbol verändert werden.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Name der Konfiguration

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Name der Konfiguration

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Name des letzten Verzeichnisses der zenon Logic Runtime Dateien wird hier automatisch eingetragen, wenn eine neue Konfiguration angelegt wird. Sie können diesen Name beliebig ändern.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Port (Main)

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Port (Main)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier wird der Main Port der zenon Logic Runtime Instanz eingetragen. Dieser Port definiert die Verbindung der zenon Logic Workbench und eines zenon Treibers. Per Default wird dieser Port auf 1200 gesetzt.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Port (Binding)

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Port (Binding)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier wird der Binding Port der zenon Logic Runtime Instanz eingetragen. Der Binding Port definiert die Verbindung für die spontane TCP/IP-Kommunikation zu anderen zenon Logic Runtimes. Per Default wird dieser Port um 7800 höher als der Main Port gesetzt.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Startup

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Startup

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Definieren Sie hier das Startup Verhalten der zenon Logic Runtime Instanz.

  • Cold start - Die zenon Logic Runtime startet mit initialisierten Variablen.
  • Cold start (load RETAIN variables) - Die zenon Logic Runtime startet initialisiert mit remanenten Merkern.
  • Hot restart - Die zenon Logic Runtime startet mit den Variablenwerten vom Zeitpunkt des Anhaltens der Runtime.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Im Schrittmodus starten

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Im Schrittmodus starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die zenon Logic Runtime im Schrittmodus zu starten, aktivieren Sie diese Checkbox.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Windows Echtzeit Priorität

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Windows Echtzeit Priorität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit die zenon Logic Runtime Instanz mit der Windows Realtime Priorität läuft, aktivieren Sie diese Checkbox.

info Info

Wir empfehlen die Realtime Priorität immer gesetzt zu lassen. Ein deaktivieren der Realtime Priorität ist in erster Linie für Testzwecke gedacht (z.B. bei Gefahr von Endlosschleifen).

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Harte Echtzeit

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Harte Echtzeit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie diese Checkbox aktiviert haben, wird beim Start der Konfiguration die zenon Logic Echtzeit SPS (zenon Logic RTK) aufgerufen. Da die zenon Logic Echtzeit SPS auf dem PC nur einmal laufen darf, wird sichergestellt, dass nur bei einer Konfiguration in der Liste diese Checkbox aktiviert ist.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Report Ausgabe

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Report Ausgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aktivieren Sie diese Checkbox, um das Schreiben von Meldungen der Runtime in eine Log-Datei zu aktivieren.

info Info

Das Schreiben der Log-Datei geht auf Kosten der Performance.

info Info

Die Log-Datei hat den Namen "zenon Logic RTLOG.txt" und wird im zenon Logic Runtime Projekt Verzeichnis abgelegt.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Autostart

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Autostart

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine zenon Logic Runtime Instanz direkt mit dem Booten des Windows Betriebssystems zu starten, aktivieren Sie diese Checkbox.

info Info

Bevor Sie irgendeine, bereits gespeicherte, Einstellung verändern können, müssen Sie zuerst die betreffende Konfiguration in der Liste auswählen. Danach klicken Sie auf die Schaltfläche Bearbeiten. Um die Änderungen der Einstellungen abzuspeichern, klicken Sie auf die Schaltfläche Speichern.


Schaltfläche "Neu"

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Schaltfläche "Neu"

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie eine neue Konfiguration anlegen wollen, klicken Sie auf die Schaltfläche Neu. Danach öffnet sich ein Dialog, in dem Sie das Verzeichnis auswählen können, in das die zenon Logic Runtime Dateien (der SPS-Code) abgelegt werden. Bestätigen Sie Ihre Auswahl mit OK. Sie können den Namen der Konfiguration ändern. Um die Konfiguration und den Namen der Konfiguration abzuspeichern, klicken Sie auf Speichern.


Schaltfläche "Bearbeiten"

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Schaltfläche "Bearbeiten"

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bevor Sie die Parameter einer Konfiguration verändern können, müssen Sie auf die Schaltfläche Bearbeiten klicken, nachdem Sie einen Eintrag aus der Konfigurationsliste ausgewählt haben. Um die Änderungen abzuspeichern, müssen Sie anschließend auf Speichern klicken.


Schaltfläche "Speichern"

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Schaltfläche "Speichern"

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Klicken Sie auf die Schaltfläche Speichern, um alle Änderungen abzuspeichern.


Schaltfläche "Löschen"

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Schaltfläche "Löschen"

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Konfiguration zu löschen, selektieren Sie einen Eintrag aus der Konfigurationsliste und klicken auf die Schaltfläche Löschen.


Schaltfläche "Start"

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Schaltfläche "Start"

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die zenon Logic Runtime mit der entsprechenden Konfiguration zu starten, wählen Sie eine Konfiguration aus der Liste aus und klicken Sie auf die Schaltfläche Start. Die zenon Logic Runtime startet sofort.

info Info

Wenn das Verzeichnis der Konfiguration keine zenon Logic Runtime Dateien (SPS-Code) enthält, so startet die zenon Logic Runtime im Modus Kein Programm.


zenon Logic Runtime (Einstellungen)

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> zenon Logic Runtime (Einstellungen)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Tragen Sie hier den Pfad der zenon Logic Runtime ein (Pfad der stratonRT.exe). Um in der Ordnerstruktur Ihre Festplatte zu browsen, klicken Sie auf das Verzeichnis- Symbol.


Sprachwahl (Sprachen)

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Sprachwahl (Sprachen)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wählen Sie die gewünschte Sprache, in dem Sie auf die entsprechende Flagge klicken.


Startbilschirm anzeigen (Einstellungen)

Handbuch -> zenon Logic -> zenon Logic Runtime Manager -> Eigenschaftenhilfe -> Startbilschirm anzeigen (Einstellungen)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie diese Checkbox aktivieren, wird der Startbildschirm des zenon Logic Runtime Managers beim Start angezeigt.


zenon Demo-Projekt

Handbuch -> zenon Demo-Projekt

Mit zenon wird standardmäßig ein Demo-Projekt installiert. Dieses Projekt enthält mehrere Unterprojekte, die den Einsatz von zenon in unterschiedlichen Branchen demonstrieren:

  • Automotive
  • Energie
  • Infrastruktur
  • Gebäudeautomatisierung
  • Food and Beverage
  • Pharmazeutische Industrie

Wenn Sie den zenon Editor das erste Mal starten, wird das Demo-Projekt automatisch geladen. Das Projekt DEMO_INTEGRATION ist als Startprojekt bereits voreingestellt. Um das Projekt in der Runtime zu starten, drücken Sie im Editor die Taste F5. Das Integrationsprojekt wird in der Runtime geöffnet.

Noch in diesem Kapitel

Integrationsprojekt

Automotive

Energie

Infrastruktur

Gebäudeautomatisierung

Food and Beverage

Pharmazeutische Industrie


Integrationsprojekt

Handbuch -> zenon Demo-Projekt -> Integrationsprojekt

Das Integrationsprojekt beinhaltet eine Reihe von Unterprojekten, die Sie von diesem Bild aus starten können. Die Projekte sind sprachumschaltbar. Gestartet wird das Projekt in der Sprache des Editors. Um die Sprache umzuschalten, klicken Sie auf den Button System und wählen Sie die gewünschte Sprache aus.

Überblick und Bedienung

Der Startbildschirm bietet Naviagtionselemente und eine Übersicht über die Branchen:

  • Automotive
  • Energie
  • Infrastruktur
  • Gebäudeautomatisierung
  • Food and Beverage
  • Pharmazeutische Industrie

Hinweis: In diesem Integrationsprojekt wurden Energie, Infrastruktur und Gebäudeautomatisierung in der Navigation zusammengefasst.

Parameter

Beschreibung

Logo

In diesem Fall das Logo des Produkts zenon Supervisor. Kann durch beliebiges Firmenlogo ersetzt werden.

Das Logo wurde mit einer Funktion versehen, die beim Klick darauf das Projekt nachlädt. Beim Nachladen werden Änderungen, die seit dem Runtimestart im Editor vorgenommen wurden, ins laufende Projekt übernommen.

Herzlich willkommen User

User entspricht dem Namen des angemeldeten Benutzers. Um sich mit einem anderen Namen und anderen Berechtigungen anzumelden, klicken Sie rechts unten auf den Button Log on/off.

Unterprojekte

In den sechs Bereichen werden die Unterprojekte dargestellt. Unterprojekte starten Sie:

  • über einen Klick auf einen Detaillink
    oder
  • über Klick auf einen der Navigationsbuttons darunter.

Navigationsleiste

Dient zum Umschalten auf andere Projekte, zum Aufschalten der Systeminformationen und des Anmeldebildschirms sowie zum Beenden der Runtime:

  • Home:
    Schaltet bei Unterprojekten auf den Startbildschirm des jeweiligen Unterprojekts.
  • [Projekt]:
    Öffnet das jeweilige Projekt. Innerhalb eines Projekts belegt mit Bildern des Projekts.
  • System:
    Öffnet ein Bild mit Systeminformationen und der Sprachumschaltung.
  • Log on/off:
    Öffnet den Dialog zum Anmelden eines Benutzers.
  • Exit:
    Beendet die Runtime.

Noch in diesem Kapitel

System

Benutzeranmeldung


System

Handbuch -> zenon Demo-Projekt -> Integrationsprojekt -> System

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Klick auf den Button System öffnen Sie einen Dialog, in dem Sie:

  • über Systemtreibervariablen allgemeine Systeminformationen erhalten:
    • Computername
    • Version der Runtimedateien
    • Version des Projekts
    • Zeit im Leerlauf
    • Auslastung des Arbeitsspeichers
  • das Farbschema mit der Chamäleon-Technologie umschalten können
  • die Sprache auswählen können


Benutzeranmeldung

Handbuch -> zenon Demo-Projekt -> Integrationsprojekt -> Benutzeranmeldung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Klick auf den Button Log on/off öffnen Sie einen Dialog, in dem Sie sich als Benutzer anmelden können. der Benutzer User wird beim Start der Runtime automatisch angemeldet.

Damit Sie die die Runtime in verschiedenen Rollen mit unterschiedlichen Berechtigungen ausprobieren können, erhalten Sie in dem Dialog auch Informationen zu weiteren Benutzernamen und Passwörtern.

Zugangsdaten für Demo-Projekt:

Beachten Sie Groß-/Kleinschreibung.

Benutzername | Passwort
User | User
Operator | Operator
Manager | Manager


Automotive

Handbuch -> zenon Demo-Projekt -> Automotive

In diesem Projekt sehen Sie ein typisches Projekt aus dem Automobilbau mit Bildern für:

  • Alarme
  • Ereignisse
  • Trends
  • Reports
  • Kennzahlen
  • Anlagen

Die grüne Leiste links oben zeigt Ihnen, wo Sie sich gerade befinden und ermöglicht Ihnen, einfach zum Ausgangspunkt zurück zu navigieren.

Button | Beschreibung
Alarmmeldeliste: | Zeigt aktuelle Alarme an. Diese können zur besseren Übersicht gefiltert werden. Einige gefilterte Ansichten wurden bereits in einem Submenü vordefiniert. Alarme können hier auch quittiert werden. Der Button Alarm Statistik öffnet ein Bild mit dem Industrial Performance Analyser.
Ereignisliste: | Zeigt Einträge in die Chronologische Ereignisliste an. Einige wurden bereits in einem Submenü vordefiniert.
Trend: | Bietet verschiedene Auswertungen. Einige wurden bereits in einem Submenü vordefiniert.
Report: | Bietet Berichte, die mit dem Report Viewer im RDL- Format angezeigt werden. Einige wurden bereits in einem Submenü vordefiniert.
Kennzahlen: | Darstellung der Leistungszähler (Mathetreiber) sowie S7 Implementierung. Einige wurden bereits in einem Submenü vordefiniert.
Anlagen: | Bietet Überblick über die gesamte Anlage. Mit integrierter Weltbildfunktionalität sowie Zoomen und Scrollen für Multitouch.


Energie

Handbuch -> zenon Demo-Projekt -> Energie

In diesem Projekt sehen Sie modellhafte Anwendungen aus dem Bereich Energie.

Die grüne Leiste links oben zeigt Ihnen, wo Sie sich gerade befinden und ermöglicht Ihnen, einfach zum Ausgangspunkt zurück zu navigieren.

Button

Beschreibung

Wind

Darstellung eines Windparks.

  • Wind Turbine:
    Dynamische Rotation statischer Elemente, sowie diverse Wertanzeigen.
  • Windpark:
    Weltbild mit Decluttering Mechanismus, wobei mit Zommen mehr Windradwerte dargestellt werden.
  • Turbinen Report:
    Report, der mit dem Report Viewer die Turbinenleistung als Bargraf und die produzierte Energie als Trend darstellt.
  • Windpark Report:
    Berichte aus dem Report Generator, sowie Auslastungsanzeigen als Bargrafen.

Hydro PP

Darstellung eines Wasserkraftwerks.

  • HPP_M1:
    Simulation verschiedener Energiemodi wie Netzmodus oder Turbinenmodus und deren Frequenz/Leistungs-Diagramm.
  • Hydro PP:
    Übersichtsbild einer Wasserkraftanlage mit Pegelständen. Verwendet zenon ALC Technologie.
  • Inbetriebnahme.
    Fasst alle wichtigen Daten in einem Bild zusammen.

Substation

Visualisierung einer Substation mit Weltbild und verschiedenen Details.

Distribution

Visualisierung der Energieverteilung.


Infrastruktur

Handbuch -> zenon Demo-Projekt -> Infrastruktur

Infrastrukturprojekt, das die Verkehrsleitung in einem Tunnel zeigt.

Die grüne Leiste links oben zeigt Ihnen, wo Sie sich gerade befinden und ermöglicht Ihnen, einfach zum Ausgangspunkt zurück zu navigieren.

Mit einem Rechtsklick auf den Button Traffic Program North bzw. Traffic Program South erhalten Sie einem Kontextmenü, in dem Sie zwischen den Betriebsmodi Stopp, Langsam und Normal umschalten können.


Gebäudeautomatisierung

Handbuch -> zenon Demo-Projekt -> Gebäudeautomatisierung

Das Projekt zur Gebäudeautomatisierung nutzt EMS (Energy Management System). Es:

  • zeigt den aktuellen und erwartetenden Energiebezug
  • ermöglicht, steuernd in den Bezug einzugreifen
  • steuert die Klimaanlage

Die grüne Leiste links oben zeigt Ihnen, wo Sie sich gerade befinden und ermöglicht Ihnen, einfach zum Ausgangspunkt zurück zu navigieren.

Button | Beschreibung
EMS View: | Überblick über den Energieverbrauch und Ausblick auf den zu erwartenden Verbrauch.
EMS Geräte: | Steuerung von Geräten, um den Energiebezug zu beeinflussen. Zwei verschiedene Verbrauchergruppen sowie ein Dieselgenerator können separat geschalten werden. Die Auswirkungen der Schalthandlungen sehen Sie im Bild EMS View.
Gebäudeautomatisierung: | Steuerung der Klimaanlage und Verbrauchsanzeige. Für das Tortendiagramm wird WPF verwendet.


Food and Beverage

Handbuch -> zenon Demo-Projekt -> Food and Beverage

Lebensmittelproduktion mit Batchprozess, Abfüllung, Verpackung und Pasteurisierung.

Die grüne Leiste links oben zeigt Ihnen, wo Sie sich gerade befinden und ermöglicht Ihnen, einfach zum Ausgangspunkt zurück zu navigieren.

Mehr zum Thema Batch Control lesen Sie im Abschnitt Batch Control.

Button

Beschreibung

Batchproduktion

Batchproduktion mit Rezeptverwaltung.

  • Start des Batches über Auswahl eines Vorlagenrezepts. Dieses kann als Test ausgeführt und frei gegeben werden. Nach der Freigabe kann ein Steuerrezept erstellt und gestartet werden.
  • In den beiden Tanks müssen, je nach Rezept, Zutaten manuell hinzugefügt werden. Dazu wird ein Popup-Fenster aufgeschaltet.
  • Nach überprüfen des PH Wertes wird das Produkt automatisch abgefüllt.

Submenü:

  • Prozesssteuerung:
    Steuerung der Batchproduktion.
  • Rezeptmanagement:
    Erstellen und bearbeiten von Vorlagenrezepten und Steuerrezepten.
    Es können unterschiedliche Rezepte mit unterschiedlichen Zutaten erstellt werden. Dafür stehen zwei Editoren zur Verfügung.
  • Ereignisliste:
    Zeigt während dem Batch Prozess wichtige CEL-Einträge an.
  • Batchtrend:
    Ein auf den Batchprozess abgestimmtes Trend-Bild, das den kompletten Batchprozess mittels Charts und Gant darstellt.
  • Batchreport:
    Reports zu Batchproduktionen.

Verpackungslinie:

Darstellung einer Verpackungslinie mit dynamischer Prozessstatusfarbenänderung sowie Darstellung dazugehöriger OEE Kennzahlen und Simulationssteuerung.

Die Simulation beinhaltet:

  • Startup
  • Produktions
  • Rundown

Die Simulation startet gemeinsam mit der Runtime, dabei wird zuerst eine initiale Startup-Phase durchgeführt. Die Produktionsphase wird solange wiederholt bis die Simulation mit „Rundown PLMS" heruntergefahren wird. Mit einem neuen Batch startet die Simulation wieder automatisch.

  • Trends, Alarme und OEE zeigen die wichtigsten Werte während des Produktionsvorganges der Linie an.
  • Der Alarm Report zeigt eine grafische Auswertung der aufgetretenen Alarme während der gesamten Produktionsphase.

Abfüllmaschine

Die Statusinformationen bieten einen detaillierteren Einblick in die Simulationswerte bezogen auf die Abfüllmaschine.

  • Das Statusmodell leitet sich vom Weihenstephaner Statusmodell ab. Es repräsentiert den aktuellen Operationsstatus der Abfüllmaschine.
  • Im Rezeptgruppenmanager können Rezepte mit Schattenvariablen und Rezeptüberprüfung gemanagt werden.
  • Die CEL zeigt auf die Abfüllmaschine gefilterte Ereignisse an, Verbrauch Report liefert Reports zu Produktion und Verbrauch von Ressourcen.

Pasteurisierer
  • WPF-Darstellung der Temperaturen. Ist die Simulationsautomatik abgeschaltet, kann zwischen drei Modi (OFF, CIP und Pasteurization) manuell geschalten werden.
  • Mit der implementierten Einheitenumschaltung kann zwischen Celsius und Fahrenheit umgeschaltet werden.
  • Trend, CEL und Alarmmeldeliste stellen Online-Daten und historische Daten zur Überwachung der Prozesswerte der Maschine dar.
  • Der Reportgenerator fasst alle wichtigen Daten der Maschine zusammen.


Pharmazeutische Industrie

Handbuch -> zenon Demo-Projekt -> Pharmazeutische Industrie

Pharmazeutische Produktion mit Batchprozess.

Die grüne Leiste links oben zeigt Ihnen, wo Sie sich gerade befinden und ermöglicht Ihnen, einfach zum Ausgangspunkt zurück zu navigieren.

Mehr zum Thema Batch Control lesen Sie im Abschnitt Batch Control.

Button

Beschreibung

Prozess
  • Starten des Batchprozesses durch Auswahl des gewünschten Batchrezepts.
  • Starten eines Batches und Eingabe einer Signatur gemäß FDA. (Für den Benutzer User ist das Passwort User. Weitere Benutzer siehe Benutzeranmeldung.)
  • Während des Batchprozesses muss der Benutzer manuell Zutaten für Primärer Reaktor 2 beimengen. Dazu muss die Zutat und deren Menge über das manuelle Dosierungssystem hinzugefügt werden.
  • Manuelle Alarme können durch Klicken auf den Motor des Reaktors oder des Konusmischers erzeugt werden.
  • Temperaturen, Drücke und Rührwerkdrehzahl können über die Trend-Bilder angezeigt und analysiert werden.
  • Nach dem Akzeptieren des Batches wird der Batch automatisch abgeschlossen.
  • Der Report zeigt nun den kompletten Batch Prozess des selektierten Rezepts.

CIP – CIP RGM
  • Wählen Sie die gewünschte Rezeptgruppe, um eine Liste der darin enthaltenen Rezepte darzustellen.
  • Die Rezeptliste zeigt den Status und die Version aller Rezepte dieser Rezeptgruppe an. Rezepte können zur schnellen und einfachen Auswahl sortiert und gefiltert werden.
  • Sobald ein Rezept ausgewählt wurde, kann dieses, je nach Berechtigungsstufe, geladen oder modifiziert werden
  • Die Rezeptwertliste zeigt die rezeptabhängigen Variablen und die dazugehörigen Variablenwerte des Rezeptes an.
  • Im Prozessfenster können die Werte des ausgewählten Rezepts direkt im Prozess angezeigt werden. Der Button Lese vom Rezept zeigt die Werte im Prozess an. Der Button Schreibe zu Rezept modifiziert das selektierte Rezept mit den veränderten Werten.
  • Laden Sie ein Rezept und klicken Sie auf Start CIP im Bild CIP.

Kombinierte Filter
  • Globale Filtermöglichkeit für Alarmmeldeliste, Chronologische Ereignisliste und Trend-Bild.


zenon Operator

Handbuch -> zenon Operator

Der zenon Operator ist an Maschinenbedienung angepasst. Er besteht aus Editor und Runtime. Die Runtime steht für PC-Betriebssysteme und CE-Betriebssysteme zur Verfügung. Unter Windows CE gibt es systembedingte Einschränkungen.

Die prinzipielle Funktionsweise entspricht dem zenon Supervisor, der Operator ist gegenüber dem zenon Supervisor aber funktionell eingeschränkt.

Zum Editieren eines Operator Projekts kann entweder der Editor des zenon Operators verwendet werden oder der Editor des zenon Supervisors. Wenn im Supervisor Editor Funktionalitäten projektiert werden, die in der Operator Runtime nicht zur Verfügung stehen, werden diese nicht ausgeführt.

Noch in diesem Kapitel

Einschränkungen für zenon Operator

zenon unter Windows CE


Einschränkungen für zenon Operator

Handbuch -> zenon Operator -> Einschränkungen für zenon Operator

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Operator wird auf Embedded Betriebssystemen eingesetzt. Sein Funktionsumfang unterscheidet sich von dem des zenon Supervisors. Das Windows CE Betriebssystem bedingt zusätzliche Einschränkungen für den zenon Operator. Details finden Sie in der folgenden Übersicht:

Legende:

  • +: Standard
  • *: möglich
  • -: nicht möglich
  • o: als optionales Modul lizenzierbar
Features Operator Runtime | für PC | für CE
Allgemein |  |
Dongle-Lizenz | * | -
64 - 8192 Tags | * | *
Direct X/Grafik | * | -
Globalprojekt | * | *
Mehrprojektfähigkeit im Editor | - (nur 1 Projekt plus Globalprojekt) | - (nur 1 Projekt plus Globalprojekt)
Mehrprojektfähigkeit in der Runtime | - (nur 1 Projekt plus Globalprojekt) | - (nur 1 Projekt plus Globalprojekt)
Module |  |
Archivserver | - | -
Archivserver Starter Edition | o | o (ab CE 6.0)
Automatic Line Coloring | o | o
Erweiterter Trend | - | -
Erweiterter Trend Starter Edition | o | o (ab CE 6.0)
Industrial Maintenance Manager | - | -
Industrial Performance Analyzer | - | -
Message Control inklusive Text To Speech Engine | o | -
Production and Facility Scheduler | - (Scheduler verfügbar) | - (Scheduler verfügbar)
Report Generator (ohne Datenspeicherung) | o | -
RDL Viewer | o | -
Rezeptgruppen-Manager | o | o (ab CE 6.0)
Treiber: 1 Treiber inkludiert, ausgenommen Energy Treiber (IEC870-101/103/104, IEC850, DNP3, Modbus Energy) | * | *
Treiber: mehrere Instanzen | - | -
S7 Graph | o | o
Netzwerk |  |
zenon Netzwerk | + | +
Redundanz | - (nur Server Client) | - (nur Server Client)
zenon Webserver Light, 3 Clients. Nur mit Verbindung zur lokalen Runtime | o | o
zenon Webserver. | - | -
zenon Webclient | * | - (Klassische Clients sind möglich.)
Programmierschnittstellen |  |
Process Control Engine | + | +
VBA/VSTA | - | -
zenon Logic |  |
zenon Logic Monitoring Viewer | o | -
zenon OPC Server | - | -
zenon SQL Server | - | -

Alle nicht angeführten Module/Funktionalitäten sind mit dem zenon Operator verfügbar.

zenon Operator Editor

Für den Operator Editor stehen zusätzlich optional zur Verfügung:

  • zenon Logic Monitoring Builder
  • zenon Logic Workbench Pro
  • VBA/VSTA

Noch in diesem Kapitel

Besondere Einschränkungen für die CE Version


Besondere Einschränkungen für die CE Version

Handbuch -> zenon Operator -> Einschränkungen für zenon Operator -> Besondere Einschränkungen für die CE Version

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Module, die nur unter Windows CE 6.0 und höher zur Verfügung stehen:

  • Archivserver Starter Edition
    Einschränkungen siehe HandbuchArchivserver, Kapitel Archivserver Starter Edition.
  • Erweiterter Trend Starter Edition
    Einschränkungen siehe Handbuch Erweiterter Trend.
    Zusätzlich stehen bei CE-Projekten folgende Kontrollelemente nicht zur Verfügung:
    • Diagrammbutton
    • Kurvenbutton
    • Diagrammeinstellungen
    • Druckdialog
    • X-Achsenbutton
    • Cursor-Ausgabfenster
    • Filterprofile
  • Rezeptgruppen-Manager

Alarm-Statusleiste quittieren

Unter Windows CE kann die Alarm-Statusleiste nicht über einen Klick mit der rechten Maustaste quittiert werden.

Archivierung

Zur Archivierung steht unter Windows CE nur die Archivserver Starter Edition zur Verfügung. Diese weist gegenüber dem Archivserver einige Einschränkungen auf. Details siehe Kapitel Archivserver Starter Edition im Handbuch Archivierung.

Auflösung des CE Gerätes und Darstellung der CEL und AML Filter Dialoge

Die Alarmverwaltung, sowie die Chronologische Ereignisliste (CEL) erlauben eine Filterauswahl zur Runtime. Dies ist allerdings erst mit einer Auflösung ab 800x600 sinnvoll bedienbar. Die Profilverwaltung in den entsprechenden Bildern steht nicht zur Verfügung. Dadurch haben auch die Schaltflächen Speichern und Löschen keinerlei Funktion. Da unter Windows CE der Druckdialog nicht aufgerufen werden kann, verliert auch die entsprechende Schaltfläche ihre Funktion.

Bildtypen, die nicht zur Verfügung stehen:

  • Variablen-Diagnose
  • Video

Benutzerverwaltung

Active Directory and ADAM/AD LDS stehen unter Windows CE nicht zur Verfügung.

Dynamik

Dynamik wie etwa Drehen, Höhen- und Breiten-Änderung, X- und Y-Position dynamisch sind nicht verfügbar

Dynamische Elemente

ActiveX Elemente: Registrierung unter Windows CE:

Active X – Elemente müssen unter CE vor Ihrem Einsatz registriert werden. Hilfe dazu entnehmen Sie bitte dem Kapitel „Projektierungshinweise – Active X“.

Universalregler

Die Anzeige als Band steht nicht zur Verfügung.

Interne ID: Besondere Einschränkungen für die CE Version

Band

Nur verfügbar, wenn die Anzeige als Teilkreis nicht aktiv ist.

Interne ID: Besondere Einschränkungen für die CE Version

Teilkreis

Nur verfügbar, wenn die Anzeige als Band nicht aktiv ist:
Aktiv: Der Wert wird mit einem Teilkreis vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Teilkreis wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Unter Windows CE nicht verfügbar.
Aktiv: Der Wert wird mit einem Band vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Band wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

XAML- und WPF-Dateien

WPF steht nicht zur Verfügung. Daher wird auch XAML, das als Beschreibungssprache für WPF genutzt wird, nicht verwendet.

Filter in AML und CEL

Die Filter für die Alarmmeldeliste und für die Chronologische Ereignisliste können nicht projektiert werden, wenn die Eigenschaft Windows CE Projekt aktiviert ist. Da diese Dialoge sehr groß sind, wurde diese Einschränkung gemacht, um die Bedienbarkeit auch auf kleinen Displays (PDAs) zu gewährleisten. Wenn Sie Windows CE Projekte erstellen ohne die Eigenschaft Windows CE Projekt zu aktivieren, können Sie die Filterdialoge wie gewohnt nutzen.

Filterprofile

Unter Windows CE ist es nicht möglich, mit Profilen in der Runtime zu arbeiten.

Freie Schablonenform

Bei Schablonen steht die Freie Schablonenform unter Windows CE nicht zur Verfügung.

Interne ID: Besondere Einschränkungen für die CE Version

Freie Schablonenform

Ermöglicht die Verwendung der freien Schablonenform für die selektierte Schablone. Dadurch ist es möglich Schablonen mit z.B. abgerundeten Ecken, Löchern usw. zu definieren.

Aktiv: Die freie Schablonenform wird für diese Schablone und die damit verknüpften Bilder verwendet.

Inaktiv: Freie Schablonenform steht nicht nur Verfügung. Eine bereits bestehende freie Schablonenform wird im Schablonen- und im Bildeditor nicht angezeigt.

Default: inaktiv

Hinweis: Steht nicht zur Verfügung für Schablone Alarmstatuszeile und nicht unter Windows CE.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Grafik

3D Füllmuster

3D Füllmuster sind freigeschalten, benötigen jedoch erhöhte Grafikleistung der CE Maschinen.
Daher wird der Einsatz nicht empfohlen.

Grafikqualität

Grafikfunktionen, die die Einstellung Windows Erweitert, in der Eigenschaft Grafikqualität zur Verfügung stellt, wie schattierte Füllungen und Transparenz, sind unter CE nicht verfügbar.
Hinweis: Transparente GIF-Dateien und mit Einschränkungen PNG-Dateien sind darstellbar.

Interne ID: Besondere Einschränkungen für die CE Version

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: Besondere Einschränkungen für die CE Version

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: Besondere Einschränkungen für die CE Version

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Fülleffekte

Fülleffekte von statischen Elementen können in Abhängigkeit des CE-Terminals anders dargestellt werden als am PC.

Für die Vektorelemente gibt es unter CE nur die Füllmuster voll und nicht gefüllt
Für die Vektorelemente gibt es unter CE nur die Linienarten: voll, strichliert, ohne.

GIF-Dateien

Um GIF-Dateien unter Windows CE anzeigen zu können, muss am Zielgerät die Datei IMGDECEMP.dll vorhanden sein. Fehlt die Datei, können Sie die Datei IMGDECEMP.dll beim support@copadata.com anfordern.

Linien

Linien können nicht mit abgerundeten Ecken dargestellt werden. Auch wenn in den Projekteigenschaften unter 'Grafische Ausprägung' die 'Erweiterte Grafikfunktion' deaktiviert wurde, werden unter CE abgerundete Ecken nicht angezeigt.

Darstellung der Rezeptnamen

Im Bild vom Typ Rezeptgruppen-Manager können die Rezeptname nur in einer Combobox angezeigt werden. Die Anzeige als Listbox (über Style L) wird von CE Plattformen nicht unterstützt.

Hauptmenüs

Unter Windows CE können nur die Standard-Hauptmenüs angezeigt werden. Jegliche Änderung von Farbe, Größe der Schrift oder Schriftart ist nicht möglich.

Lizenzierung (Dongle)

Für Windows CE ist keine Dongle-Lizenzierung verfügbar, weder lokal noch über Netzwerkdongle.

Mehrprojektfähigkeit

Unter Windows CE ist keine Mehrprojektfähigkeit gegeben, d.h. es kann immer nur ein Projekt laufen. Dies hat zur Folge, dass bei Netzwerkprojekten auf Hierarchien (Dachprojekt, I-Projekt) verzichtet werden muss. Das Global Projekt ist von dieser Einschränkung ausgenommen.

Projektgröße

Unter Windows CE steht nur ein gewisser Platz an Arbeitsspeicher zur Verfügung.

Unter Windows CE 5.x kann die Anwendung nur auf Slot0 ausgeführt werden und ist damit auf 32 MB beschränkt. Wird Windows CE 5.x gestartet, stehen abhängig von der Größe des Images (zwischen 15 und 19 MB) die restlichen MB für zenon noch zur Verfügung. Aufgrund der 20%- Regel können somit maximal 25,6 MB für Image, zenon und Projekt verwendet werden.

Ab Windows CE 6.0 ist der Arebitsspeicher mit 2 GB limitiert. Die 20%-Regel gilt aber auch hier.

info Info

20%-Regel: Nach Aufschalten aller zenon Bilder sollen noch mindestens 20 % des Speichers frei sein. Wird diese Grenze nicht beachtet, kann eine einwandfreie Funktionalität von zenon nicht garantiert werden.

Querverweisliste

Wird in einem CE Projekt eine Funktion mit einem Button verknüpft, die unter Windows CE nicht verfügbar ist, so wird dieser in der Runtime als 'Funktion wurde gelöscht' gekennzeichnet.

Rechte Maustaste

Die rechte Doppelklick Funktion ist unter Windows CE nicht verfügbar.

Redundanz

Redundanz in Kombination mit einem CE Gerät als Client ist möglich. Redundanz wobei das CE Gerät die Funktion vom Server oder Standby Server übernimmt, ist nicht möglich.

Sollwert setzen

Die Sollwerteinstellung zum Element oder zur Funktion über Makro oder Programm funktioniert nicht. Sollwertvorgaben sind nur über die Eingabemaske bzw. beim Zahlenwert über das Element möglich.

Wird auf einem CE Gerät ein Sollwert auf eine HD-Variable abgesetzt (z.B. mittels Universal-Regler), ist eine gewisse Verzögerung die Folge, da nicht schnell genug auf die Speicherkarte geschrieben werden kann. Auch kann es zu Verzögerungen kommen, wenn alle Sollwerte in die CEL mitprotokolliert werden und die CEL sofort für jeden Eintrag geschrieben wird (Projekt-Einstellung).

Treibersimulation

Die Simulation - programmiert steht unter Windows CE 6 nicht zur Verfügung.

Vektorelemente

Kreisbogen

Unter Windows CE wird das statische Element Kreisbogen nur bei einer Linienstärke von 1 richtig angezeigt.
Achtung: Breitere Kreisbögen werden auch bei Netzwerkprojekten falsch visualisiert. Die Kreisbögen erscheinen dann zerstückelt und entsprechen nicht der Projektierung am PC.

Kreissegment

Das Element Kreissegment steht unter Windows CE nicht zur Verfügung.

Variablen

Variablen vom Datentyp LINT sind unter Windows CE nicht verfügbar.

Weltbilddarstellung

Die Weltbilddarstellung steht aufgrund der benötigten Grafikleistung unter Windows CE nicht zur Verfügung.

WMF- und EMF-Dateien

Die Verwendung von Meta Dateien (*.wmf) und (*.emf) ist nicht möglich.


zenon unter Windows CE

Handbuch -> zenon Operator -> zenon unter Windows CE

Die CE Runtime von zenon Operator ist auf verschiedenen CE Hardware Plattformen lauffähig. Grundsätzlich bietet die CE Version von zenon dieselbe Funktionalität wie die PC Version von zenon Operator mit einigen Einschränkungen, die sich durch die geringeren Hardwareressourcen ergeben.

Details zur Installation der zenon und zenon Logic Runtimes für Windows CE lesen Sie in den Kapiteln:

  • zenon Operator Runtime für Windows CE
  • zenon Logic Runtime für Windows CE

tutorial Lizenzinformation

Die zenon Runtime für Windows CE ist lizenzpflichtig.

Noch in diesem Kapitel

Allgemeines

Voraussetzungen

Systemdateien

Netzwerk

Verbindung über ActiveSync oder Windows Mobile Device Center

Rezeptgruppen-Manager

Transparenz

Pocket PC und Windows Mobil Edition


Allgemeines

Handbuch -> zenon Operator -> zenon unter Windows CE -> Allgemeines

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Windows CE ist eine offene, skalierbare Plattform für eine Vielzahl von Geräten im Bereich der Kommunikation, Unterhaltung, Industrie und mobilen Datenverarbeitung. Vereinfacht ausgedrückt, handelt es sich dabei um ein auf das Essenzielle reduziertes Betriebssystem, das nur sehr geringe Hardwareressourcen benötigt. Dies bedeutet, dass sehr preisgünstige Hardwarekomponenten mit einem auf Windows basierenden System ausgerüstet werden können.
Windows CE ermöglicht die Realisierung von Geräten, die miteinander kommunizieren, Informationen mit Windows basierenden PCs austauschen und Verbindungen zum Internet herstellen können.
Windows CE ist ein Realtime-fähiges 32-Bit-Betriebssystem mit Funktionen wie Multitasking und Multithreading, das eine offene Architektur aufweist und eine breite Gerätepalette unterstützt. Windows CE ist kompakt, bietet also auch bei begrenztem Arbeitsspeicher eine hohe Leistung.

Vorteile von Windows CE sind unter anderem:

  • schnelles Hochfahren des Gerätes, da das Betriebsystem bei jedem Bootvorgang neu in den Speicher entpackt wird
  • keine Gefahr, dass das Betriebsystem durch fehlgeschlagene Installationen oder Viren beeinflusst wird, da auf dem CE Gerät keine Software installiert werden kann
  • hohe Robustheit, da man bei Windows CE Geräten auf sich bewegende Teile (wie z.B. Festplatten..) in der Regel verzichtet

Nachteile von Windows CE sind unter anderem:

  • eingeschränkte Funktionalität, da nicht das komplette Windows API (Application Programming Interface) zur Verfügung steht
  • langsamere Lese- und Schreibzugriffe auf die Compact-Flash Karte
  • verringerte Lebensdauer der Speichermedien durch häufigen Zugriff verringert

Die zenon Runtime bietet unter CE die gleichen Funktionalitäten wie am PC. Eingeschränkt werden diese durch geringere Hardwareressourcen und Einschränkungen des Betriebssystems.

Noch in diesem Kapitel

Projekte für CE erstellen

Lizenzierung


Projekte für CE erstellen

Handbuch -> zenon Operator -> zenon unter Windows CE -> Allgemeines -> Projekte für CE erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem Editor erhält der Anwender ein Werkzeug, mit dem er Kleinstprojekte, kleine bis mittlere Applikationen bis hin zu Großprojekten erstellen kann. Das Projektierungswerkzeug bleibt immer dasselbe. Unabhängig für welche Plattform Projekte erstellt werden, es steht immer der volle Projektierungskomfort zur Verfügung. Sie haben volle auflösungsunabhängige Projektdatenkompatibilität.

CE-Editor

Für CE-Projekte wird im Editor unter -> Eigenschaften -> Allgemein die Checkbox 'Windows CE Projekt' aktiviert. Damit werden nur jene Funktionen frei gegeben, die auch unter Windows CE zur Verfügung stehen. Alle anderen Funktionen werden grau dargestellt. Ausgenommen VBA: Im Editor kann VBA für Wizards genutzt werden, in der Runtime jedoch nicht.

Der Editor ist je nach Lizenzierung auf 8.192 Tags begrenzt.

VBA unter CE

VBA steht im Editor für Wizards zur Verfügung. In der Runtime wird VBA nicht unterstützt.


Lizenzierung

Handbuch -> zenon Operator -> zenon unter Windows CE -> Allgemeines -> Lizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime für Windows CE wird mit dem Remote Transport lizenziert. Wenn Sie Verbindung zum Zielsystem aufbauen, können Sie die Seriennummer und die Lizenzierungsnummer für die CE Version eingeben. Die Seriennummer wird am CE Gerät in der Datei zenon6.ini gespeichert, die Aktivierungsnummer in der Registry.

info Info

Die Seriennummer und Aktivierungsnummer wird bei der Eingabe im Remote Transport am PC nur bedingt auf Validität kontrolliert. Erst beim Start der Runtime auf dem CE Gerät wird die Gültigkeit vollständig überprüft. Bitte daher die Runtime einmal nach dem Updaten der Seriennummer/Aktivierungsnummer starten, um zu prüfen ob die Nummern korrekt eingegeben wurden.

Im Standard-Lieferumfang befindet sich eine CE Demo Seriennummer, die keine Aktivierungsnummer verlangt.

Example Beispiel

Demo Seriennummer für CE 5.0 und Windows Mobile 5: 0.19211400.0.-128

Demo Seriennummer für CE 6.0: 0.59211400.0.-256.0

Die Demo Version für CE 5:

  • ist beschränkt auf
    • 2.048 Variablen
    • eine Laufzeit von 10 Minuten
  • enthält
    • Process Control Engine
    • zenon Webserver Pro

Die Demo Version für CE 6.0:

  • ist beschränkt auf
    • 4.096 Variablen
    • eine Laufzeit von 10 Minuten
  • enthält
    • Process Control Engine
    • Erweiterter Trend Modul (Starter Edition)
    • Archivserver (Starter Edition)
    • zenon Webserver Pro (3 Clients)

attention Achtung

Unter den Windows Mobile Edition können abhängig vom verfügbaren Gerätespeicher, den installierten Programmen und der Größe des Projektes nur ca. 800 bis 1000 Variablen geladen werden.


Voraussetzungen

Handbuch -> zenon Operator -> zenon unter Windows CE -> Voraussetzungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime ist unter Windows CE auf den unterschiedlichsten Geräten, unabhängig vom Hardwarehersteller, lauffähig. Für jede Kombination aus Betriebsystem und Prozessortyp wird eine eigene Runtime benötigt, die für diese spezifische Plattform kompiliert und gewartet werden muss.
Mindestanforderung an das CE Gerät sind:

  • 64 MB RAM Speicher
  • 32 MB freier Plattenspeicher

Da die Prozessorgeschwindigkeit stark vom Prozessortyp abhängig ist, kann eine Mindestgeschwindigkeit nicht definiert werden. Generell gilt aber, dass der Prozessor eine Taktfrequenz von mindestens 400 MHz aufweisen sollte.
Empfohlen wird:

  • 128 MB RAM oder mehr
  • 64 MB oder mehr
  • Prozessor mit 800 MHz für ARM Prozessoren bzw. 600 MHz für x86-Architektur
  • Netzwerkinterface

info Info

Die Ablage der Runtime sowie des das Projektes, muss auf einem permanent beschreibbaren remanenten Speicher erfolgen.

CE Geräte mit Touchscreen haben meistens eine niedrigere Bildschirmauflösung. Dies ist bei der Projektierung zu berücksichtigen. Manche Dialoge, wie etwa der Variablenauswahldialog der Standard Rezeptur, sowie andere Dialoge zur Runtime, sind bei einer Bildschirmauflösung von 320 x 240 schlecht oder u. U. nicht bedienbar. Eine Mindestanforderung gibt es hier jedoch nicht.
Die Projektierungshinweise beinhalten einen Leitfaden, für die Projektierung niedriger Auflösungen.

attention Achtung

zenon muss in der entsprechenden Version installiert sein. PC Version und die CE Version von zenon müssen zusammenpassen (gleiche Version, gleiches Service Pack).

Noch in diesem Kapitel

CE - Versionen und Prozessorunterstützung

Kompatibilität


CE - Versionen und Prozessorunterstützung

Handbuch -> zenon Operator -> zenon unter Windows CE -> Voraussetzungen -> CE - Versionen und Prozessorunterstützung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In der aktuellen zenon Version 7.00 werden folgende Windows CE Versionen und Prozessoren unterstützt:

  • CE 5.00 für x86
  • CE 5.00 für ARMV4/V5
  • CE 6.00 für x86
  • CE 6.00 für ARMV4/V5

info Info

Informationen zu unterstützten CE Versionen und Prozessoren für frühere zenon Version finden Sie in der jeweiligen Dokumentation oder erhalten Sie beim COPA-DATA Support.


Kompatibilität

Handbuch -> zenon Operator -> zenon unter Windows CE -> Voraussetzungen -> Kompatibilität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das zenon CE Installationsmedium enthält alle bisherigen kompatiblen Runtime-Versionen als ZIP-Datei. Diese Dateien beinhalten die Binärdateien, aber keine vollständig lauffähigen Runtimes.

Werden Runtime-Dateien mit einer neueren Editorversion erzeugt, benötigen Sie eventuell ältere Treiber für die Runtime. Dazu:

  • navigieren Sie zur entsprechenden ZIP-Datei im Ordner Runtime compatibility auf dem Installationsmedium
  • entpacken Sie den Treiber aus der Datei
  • übertragen Sie den Treiber zum Gerät


Systemdateien

Handbuch -> zenon Operator -> zenon unter Windows CE -> Systemdateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime für Windows CE setzt das Vorhandensein unterschiedlichster Systemdateien voraus. Fehlt eine dieser Dateien, so erzeugt das Betriebssystem eine Fehlermeldung beim Starten der Runtime, dass eine oder mehrere Komponenten nicht gefunden wurden. Folgende Systemdateien sind unbedingt erforderlich:

Datei | Beschreibung
mfc90u.dll | Erforderlich für die Runtime. Es kommt eine Fehlermeldung beim Starten, wenn diese Datei nicht vorhanden ist.
msvcr90.dll | Erforderlich für die Runtime. Es kommt eine Fehlermeldung beim Starten, wenn diese Datei nicht vorhanden ist.
atl90.dll | Nicht erforderlich für das Starten der Runtime, aber für den Einsatz eines Treibers mit Netzwerkanbindung oder den Einsatz von zenon im Netzwerk. Wenn diese Datei nicht vorhanden ist, kann das Gerät nicht als Client fungieren bzw. funktionieren TCP/IP Treiberanbindungen nicht.
IMGDECMP.dll | Nicht erforderlich für das Starten der Runtime, aber erforderlich für die Darstellung von Transparenz, wenn Alpha Blending im Betriebssystem nicht integriert ist. Eine Animation ist bei GIF Dateien unter Windows CE nicht möglich.
VBSCRIPT.dll + JSCRIPT.dll | Nicht erforderlich für das Starten der Runtime. Diese Datei wird benötigt für die PCE (Process Control Engine).

Einige dieser Systemdateien werden mit der Installation von zenon für CE mit installiert und können z.B. mit dem UpdateCE Tool auf das CE Gerät übertragen werden. Alle diese Systemdateien sollten bereits vom Gerätehersteller in das Betriebssystem-Image des CE Geräts integriert werden.

attention Achtung

Für Hersteller von Windows CE Betriebsystemimages:
CE Versionen vor 6.0 benötigen die Datei toolhelp.dll. Damit die Datei am CE Gerät vorhanden und die Toolhelp.h im SDK auch verfügbar ist, aktivieren Sie im Platform Manager folgenden Eintrag:
Core OS -> Display Based Device ->Core OS Services -> Debugging Tools -> Toolhelp API. Hiermit ist die Toolhelp.dll im Image mit dabei.
Tipp: Verwenden Sie immer das aktuellste Servicepack des Platform Builder.

Hinweis: Die toolhelp.dll wird für Windows CE 6 nicht benötigt und soll mit CE 6 nicht verwendet werden.

Noch in diesem Kapitel

20 % Regel

Runtime


20 % Regel

Handbuch -> zenon Operator -> zenon unter Windows CE -> Systemdateien -> 20 % Regel

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die bereits seit Windows CE 3.0 bestehende Einschränkung auf 32 MB Speicher (ein sogenannter‚ Slot, siehe Abbildung) ist auch bei Windows CE 5.0 noch gültig und wird erst ab Version 6 aufgehoben.

Speicherbegrenzung heißt: In diesen 32 MB muss die Runtime (Variablen, Funktionen, Bilder, Treiber, System, Dateien usw.) geladen werden. Je nach Gerät werden beim Starten von Windows CE verschiedenste Treiber und Systemdateien im Speicher geladen, wodurch die Runtime nie die vollen 32 MB nutzen kann.

Unter Windows CE.NET (4.xx) und CE 5.0 ist diese Grenze von 32 MB Speicher pro Anwendung zwar noch immer vorhanden, jedoch kann der Speicher, der vom Betriebsystem oder Anwendungen in anderen Slots belegt wurde, im Slot in dem die Runtime gestartet ist, nun schon benutzt werden. Durch diese Betriebssystemerweiterung von CE.NET /CE 5.0 ist mehr Speicher für die Runtime verfügbar.

Die maximale Projektgröße wird vom Betriebsystem und der verwendeten Hardware eingeschränkt. Es steht nicht, wie am PC üblich, eine große Menge Speicher zur Verfügung. Die Dauer für das Schreiben von einem Kilobyte Daten auf die CompactFlash Karte liegt nicht (wie üblicherweise am PC) im Millisekunden Bereich, sondern ist um ein Vielfaches höher.

Windows CE wurde für niedrig performante Hardware entwickelt, die ohne bewegende Teile auskommen kann. Nur die wenigsten CE Geräte verfügen über eine aktive Kühlung des Prozessors. Oftmals erledigen Prozessoren von CE Geräten alle Aufgaben wie z.B. Berechnungen, Grafikaufbau, TCP/IP Kommunikation, serielle Kommunikation usw.

Diese Aufgaben werden am PC durch die einzelnen Hardwarekomponenten erledigt. Durch diesen Umstand kann die Performance eines CE Gerätes nicht mit der eines PCs verglichen werden.

Die maximale Projektgröße ist daher stark Geräteabhängig. Es kann keine allgemeine Grenze für z.B. die maximale Variablenanzahl oder die Anzahl der maximalen Alarme gegeben werden.

info Info

Wenn die Runtime gestartet ist, alle Bilder einmal aufgerufen wurden und die maximale Anzahl der Alarme im Speicher anstehen, so müssen 20 % des verfügbaren Hauptspeichers frei sein, um eine fehlerfreie Funktion garantieren zu können.

Der verfügbare Hauptspeicher lässt sich mithilfe der Systemvariable (Systemtreiber) 'Freier Hauptspeicher %' ermitteln.

Windows CE 6.0

Ab CE 6.0 gelten die oben genannten Einschränkungen des Betriebsystems nicht mehr. Der verfügbare Speicher kann durch jede Appliaktion voll genutzt werden. Da jedoch der Speicher auf den handelsüblichen CE Geräten oftmals mit 128 MB oder 256 MB RAM begrenzt ist, kann es trotzdem zu Speicherengpässen kommen. Besonders wenn Sie die Erweiterter Trend & Archivserver Starter Edition einsetzen. Die oben beschriebene 20% Regel hat daher nach wie vor seine Gültigkeit.


Runtime

Handbuch -> zenon Operator -> zenon unter Windows CE -> Systemdateien -> Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime für Windows CE besteht aus folgenden Dateien:

Dateiname | Beschreibung
zenonrCE.exe | Die Runtime Anwendung
Cd_tooCE.dll | Erforderliche Datei für die Runtime
ZennetsrvCE.dll | Der Netservice für Windows CE. Erforderlich bei Netzwerkprojekten.
SysSrvCE.exe | Der Transportservice.
LogCliLibCE.dll | Der Logserver Client
zenon6.ini | Textdatei mit Einstellungen für die Runtime wie etwa Startprojekt, Sprache der Runtime usw.
UpdateCE.exe | Anwendung, wird für das CE Update Tool benötigt.
RgermaCE.dll | Deutsche Sprachdatei
RengliCE.dll | Englische Sprachdatei
RfrancCE.dll | Französische Sprachdatei
RitaliCE.dll | Italienische Sprachdatei
RrussiCE.dll | Russische Sprachdatei
RspaniCE.dll | Spanische Sprachdatei

Mit dem CE Runtime Update Programm, erreichbar über das Menü Option, lässt sich die Runtime auf ein CE Gerät installieren.

info Info

Für Verbindungen zu Windows CE 6.0 mit CX1000, Profibus oder SYCONuni gilt: Es muss sichergestellt sein, dass die Datei CDMemDrv.dll auf das Gerät übertragen wurde. CDMemDrv.dll ist ein Windows CE Gerätetreiber. Die DLL steht für x86 und ARMV4I zur Verfügung.

Zusätzlich gibt es noch zahlreiche Treiber zur Hardwarekommunikation. Die im Projekt verwendeten Treiber werden, wenn der Prozessortyp des CE Gerätes vom Editor erkannt wird, automatisch mit dem Projekt über den Remote Transport übertragen. Die Art bzw. die Anzahl der übertragenen Dateien, sind im Ausgabe-Fenster des Editors ersichtlich.

Diese Dateien müssen immer für die jeweilige CE Version und für den jeweiligen Prozessortyp geeignet sein. Das Mischen von Dateien aus verschiedenen CE Versionen oder auch Servicepacks kann zu Ausfällen und unerwünschten Nebeneffekten führen und ist daher nicht zulässig.

info Info

Beim Start von zenonrce.exe, wird auch die Datei syssrvce.exe ausgeführt. Dadurch wird gewährleistet, dass immer eine TCP-Verbindung aufgebaut werden kann. Es werden lange Wartezeiten vermieden und es wird nur eine Datei für die autostart Funktionalität benötigt.


Netzwerk

Handbuch -> zenon Operator -> zenon unter Windows CE -> Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon ist selbstverständlich auch unter Windows CE netzwerkfähig. Das CE Terminal kann als Server oder Client in Kombination mit weiteren Terminals oder herkömmlichen PCs fungieren. Eine weitere Möglichkeit ist, das CE Terminal als Datenserver in Kombination mit einem PC zu verwenden.

Redundanz im Netzwerk ist mit dem Einsatz von Windows CE nicht möglich, d.h. das ein CE Terminal nicht als Standby- Server arbeiten kann. Wenn jedoch PCs als Server und Standby- Server eingesetzt werden, kann sich das CE Terminal als Client verbinden und sich bei einer Redundanzumschaltung automatisch zum aktuellen Server verbinden.

info Info

Die Mehrprojektfähigkeit ist mit Windows CE nicht gegeben.

Es können allerdings mehrere CE Projekte auf einem PC in ein I-Projekt zusammengefasst werden.

Will man die CE Runtime im Netzwerk einsetzen, so müssen folgende Anforderungen erfüllt sein:

Netzwerkanschluss des CE Terminals

TCP/IP Netzwerk mit vollständiger(!) Namensauflösung

Eindeutige Rechnernamen und IP- Adressen im Netzwerk

Erforderliche Systemdatei sowie Runtime am CE Terminal vorhanden. (siehe auch Kapitel Voraussetzungen)

Runtime Lizenz mit Netzwerkunterstützung am CE Terminal

info Info

Wenn ein CE Terminal im Netzwerk eingesetzt wird, egal ob Server oder Client, muss am CE Terminal eine Runtime Lizenz mit Netzwerk verwendet werden.

Für Remote Transport ist keine Netzwerklizenz erforderlich!

Ist diese Netzwerk Lizenz nicht vorhanden wird zenon automatisch als Standalone gestartet, und es wird von jedem CE Gerät eine eigene Verbindung zur SPS erstellt.

Noch in diesem Kapitel

Netzwerkeinstellungen

CE Terminal als Server

CE Terminal als Client

Diagnosemöglichkeiten

CE Terminal als Datenserver


Netzwerkeinstellungen

Handbuch -> zenon Operator -> zenon unter Windows CE -> Netzwerk -> Netzwerkeinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Da die Namensauflösung unter Windows CE nicht immer gegeben ist, müssen gegebenenfalls der Rechnername und die IP Adresse des CE Terminals und des PC bekannt gemacht werden. Am PC gibt es hierzu die Textdatei HOSTS, die im /Windows/System32/Drivers/ETC Verzeichnis zu finden ist. In dieser Datei ist die IP- Adresse des CE Terminals und der Rechnername des CE Terminals von einem Tabstopp getrennt in Großbuchstaben einzufügen. z.B. 192.168.0.100 WINDOWSCE2

info Info

Achten Sie beim Speichern dieser Datei darauf, dass diese ohne Dateiname-Erweiterung .txt abgespeichert wird!

Die Verlinkung zwischen Computernamen und den IP-Adressen muss sowohl am PC als auch am CE Terminal definiert werden, wenn das Netzwerk eine dynamische Namensauflösung nicht vollständig unterstützt. (Bei der dynamischen Namensauflösung werden Computernamen aufgrund der IP-Adresse aufgelöst). Am PC wird diese Information in der 'HOSTS' Datei gespeichert, die unter '/Windows/system32/drivers/etc' zu finden ist.

Das Betriebssystem Windows CE unterstützt die Funktionalität einer HOSTS Datei nicht. Damit auch die Namensauflösung vom CE Terminal aus richtig funktioniert, muss in der zenon6.ini des CE Terminals der Rechnername und die entsprechende IP Adresse eingetragen werden. Folgender Eintrag ist dafür notwendig:

Example Beispiel

[IPADDR]
Mein-Computer Name=meine IP-Adresse
CE_Terminal Nae =CE_Terminal IP-Adresse

SERVERNAME=192.168.1.152

Tragen Sie unter Servername den Namen Ihres Servers ein. Die IP- Adresse ändern Sie entsprechend auf die IP- Adresse Ihres Servers ab.

Beispiel: Ihr Server heißt PC0815 und hat die IP- Adresse 192.52.9.32 dann tragen Sie oben ein: PC0815=192.52.9.32

Beachten Sie, dass Sie den Rechnernamen in GROSSBUCHSTABEN schreiben!

weitere Beispiele

[IPADDR]

WINDOWSCE2=192.168.0.100

PC1=192.168.0.1

Da es nicht immer gegeben ist, dass das CE Terminal seinen eigenen Rechnername kennt, muss gegebenenfalls auch dieser hier eingetragen werden.

attention Achtung

Verwenden Sie keine dynamischen IP-Adressen wenn die Namensauflösung im Netzwerk nicht gegeben ist.


CE Terminal als Server

Handbuch -> zenon Operator -> zenon unter Windows CE -> Netzwerk -> CE Terminal als Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Konstellation ist das Projekt auf dem CE Terminal ein Serverprojekt (mit eingeschränktem Funktionsumfang). Alle anderen Rechner die sich zum Terminal verbinden sind Clients (sowohl PC Clients, CE Clients als auch Web Clients möglich).

Eingesetzte Treiber werden am CE Terminal gestartet. Da ein CE Terminal als Server eingesetzt wird, ist der Funktionsumfang auf den PC Clients auch eingeschränkt. Der Einsatz eines CE Terminals als Standby- Server ist, wie bereits erwähnt, nicht möglich.

Dieses Modell hat folgende Merkmale:

Das CE Projekt hat weiterhin einen eingeschränkten Funktionsumfang, d.h. es ist keine Datenarchivierung möglich und es sind keine Module vorhanden.

Das CE Terminal sendet Prozessdaten an alle angeschlossenen Clients. Alarmverwaltung, REMAs Mathematikberechnungen werden am CE Terminal verwaltet.

Bei vielen angeschlossenen Clients ist das CE Terminal einer relativ großen Netzwerklast ausgesetzt, was zur Auslastung des CE Terminals führen kann.

Die Projektierung des CE Terminals als Server in der Praxis:

Um das CE Terminal als Server deklarieren zu können, muss der Rechnername des CE Terminals in der Projektkonfiguration als Server eingetragen werden. Achten Sie darauf, dass der Rechnername in Großbuchstaben eingetippt wird. Nachdem Sie fertig projektiert haben müssen die Runtime Dateien mittels Remote Transport zum Server (CE Terminal) übertragen werden. Anschließend müssen Sie auch einmalig die Runtime Dateien auf alle Clients transportieren.

Für das gesamte System muss nur ein einziges Projekt erstellt werden. Zukünftige Projektierungsänderungen müssen lediglich zum Server transportiert werden. Alle Clients werden bei Projektänderungen mit den aktuellen Projektierungsdaten versorgt.

Es sollen nur jene Funktionalitäten in dem Projekt verwendet werden, die am CE Terminal auch unterstützt werden. Der Schalter CE Projekt ist hierzu ein nützliches Werkzeug. Er bewahrt Sie davor Module (Bilder, Funktionen etc.) zu projektieren, die unter Windows CE ohnehin nicht funktionieren.

Um trotz Einsatz eines CE Terminals die Datenarchivierung zu ermöglichen, Module wie z.B. erweiterten Trend oder Report Generator zur Verfügung zu haben und auch eine Vielzahl von Clients mit Daten versorgen zu können, ohne dass die Vor- Ort- Bedienung Ausführungseinbußen erleidet, wurden zwei weitere Projektierungsmöglichkeiten entwickelt:


CE Terminal als Client

Handbuch -> zenon Operator -> zenon unter Windows CE -> Netzwerk -> CE Terminal als Client

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In dieser Konstellation ist das Projekt auf dem CE Terminal kein Serverprojekt. Das Projekt auf dem CE Terminal verbindet sich also als Client zu einem Server. Der Server kann sowohl ein PC als auch ein anderes CE Terminal sein.

Dieses Modell hat folgende Merkmale:

Das CE Projekt hat am Client einen eingeschränkten Funktionsumfang, d.h. am CE Client wird nur das angezeigt, was unter CE unterstützt wird. Archive, erweiterte Trends, Reports, Rezeptgruppenmanager, Message Control usw. werden nicht angezeigt. Das Projekt am Server kann aber sehr wohl derartige Elemente beinhalten wenn der Server ein PC ist. Am PC Client ist in diesem Fall, falls lizenziert, die komplette Projektierung vorhanden. Um den Benutzer nicht unnötig zu verwirren kann bei der Projektierung angegeben werden: Unter CE sichtbar. Ist diese Checkbox nicht angekreuzt, dann werden die entsprechenden Elemente am CE Terminal nicht angezeigt.

Die Netzwerklast ist am CE Client unerheblich, da immer nur eine einzige Verbindung, nämlich die zum Server, besteht. Die Treiber sind in dieser Konstellation am Server gestartet.

Die Projektierung des CE Terminals als Client in der Praxis:

Für das gesamte System muss nur ein einziges Projekt erstellt werden. Dieses Projekt läuft am Server, der für alle Daten die Datenhoheit besitzt.

Projektiert wird auf dem PC von dem aus die erzeugten Runtime Dateien mittels Remote Transport an den Server und an die Clients übertragen werden.

Sollten im Nachhinein noch Projektierungsänderungen stattfinden so müssen diese nur noch per Remote Transport an den Server übertragen werden. Die Clients übernehmen diese Änderungen nach der Ausführung der Funktion Nachladen.

Der Schalter CE Projekt muss nicht gesetzt werden. Es steht für das Projekt die gesamte Funktionalität zenon zur Verfügung. Da auf der CE Seite nur ein eingeschränkter Funktionsumfang einsetzbar ist, werden Funktionen, die unter CE nicht vorhanden sind, dort auch nicht ausgeführt (Module, bestimmte Funktionen, etc.).

Um den Maschinenbediener nicht zu verwirren, indem Bilder und Funktionen auf dem CE Terminal angeboten werden, die nicht funktionieren bzw. die vom ihm nicht benützt werden sollen, gibt es bei Bildern und Buttons im Editor eine Option Sichtbar unter CE. Mit dieser Option wird dem Projektanten ermöglicht, sein Projekt so zu gestalten, dass ein Teil unter CE und ein anderer Teil nur auf dem PC (PC-Server, weiterer PC Client...) sichtbar ist.


Diagnosemöglichkeiten

Handbuch -> zenon Operator -> zenon unter Windows CE -> Netzwerk -> Diagnosemöglichkeiten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

CE Terminal als Server

Um sicherzustellen, dass das CE Terminal auch wirklich seine Serveraufgaben übernommen hat, kann man versuchen einen im Projekt eingesetzten Treiber bei laufender Runtime mittels Explorer am CE Terminal zu löschen. Ist das möglich, dann läuft die Runtime am CE Terminal nicht als Server (exklusiv geöffnete Applikationen können nicht gelöscht werden). Möglicherweise kennt das CE Terminal seinen eigenen Namen nicht richtig oder die Runtime am CE Terminal besitzt keine Netzwerklizenz.

CE Terminal als Client

Kann der Client keine Verbindung zum Server aufbauen, so werden bei dynamischen Elementen blaue Punkte angezeigt. Die Option Status anzeigen muss für die dynamischen Elemente im Eigenschaftsfenster aktiviert sein.

Systemtreiber

Der Systemtreiber bietet eine Vielzahl von Variablen für Netzwerkdiagnose.

Sonstiges

Wenn das CE Terminal im Netzwerk eingesetzt wird, soll es möglich sein über den Befehl: telnet RECHNERNAME 1100 in der Eingabeaufforderung eine Verbindung zum CE Terminal aufzubauen. (Cursor blinkt links oben im Eck). Die Runtime am CE Terminal muss gestartet sein.

RECHNERNAME steht dabei für den Namen des CE- Terminals (ermittelbar über die Systemsteuerung des Terminals); 1100 ist der Port über den der Netzwerkdienst (zennetsrvce.dll) kommuniziert.

Sollte der Verbindungsversuch mittels Telnet fehlschlagen, stimmt möglicherweise die Namensauflösung im Netzwerk nicht, hat das CE Terminal keine Runtime mit Netzwerklizenz, oder die Systemdatei: atl90.dll ist nicht am Terminal vorhanden.

Die Datei zennetsrvce.dll für die jeweilige Plattform wird mittels Remote Transport automatisch zum CE Terminal übertragen (Remote alle Runtime Dateien übertragen). Sollte dies nicht der Fall sein, sind auf dem Rechner die Runtime Dateien für CE möglicherweise nicht installiert. Ist im Editormenü die Option CE Runtime Update vorhanden, dann sind die Runtime Dateien für CE installiert.

Kommt es bei einem Server zu dem Effekt, dass sich einmal der eine und dann wieder der andere Client verbindet, liegt es möglicherweise daran, dass beide CE Terminals den gleichen Rechnername verwenden. Windows CE gibt keine Fehlermeldung aus wenn der Rechnername im Netzwerk bereits verwendet wird.


CE Terminal als Datenserver

Handbuch -> zenon Operator -> zenon unter Windows CE -> Netzwerk -> CE Terminal als Datenserver

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um trotz Einsatz eines CE Terminals mit Prozessanbindung (z.B. an der MPI Schnittstelle des CE Terminals) die Datenarchivierung zu ermöglichen, Module wie z.B. erweiterten Trend oder Report Generator zur Verfügung zu haben und auch eine Vielzahl von Clients mit Daten zu versorgen, ohne dass die Vor- Ort- Bedienung Ausführungseinbußen erleidet, wurde die Möglichkeit des CE Terminals als Datenserver entwickelt:

Dieses Modell hat folgende Merkmale:

Hier fungiert das CE Terminal in erster Linie als so genannter Datenserver, d.h. es werden im Hintergrund alle Treiberdaten zu einem weiteren Rechner (PC-Server) gesendet, der die eigentliche Serverfunktion übernimmt. Dieser kann gegebenenfalls Daten archivieren, die Alarm und CEL Listen verwalten, sowie eine beliebige Anzahl von Clients versorgen. Auch der Einsatz von weiteren Modulen wie etwa Rezeptgruppenmanager, Message Control, SQL Server, Erweiterten Trend usw. ist möglich.

Das CE Terminal ist in zweiter Linie einer dieser Clients und wird somit vom Server mit allen Online Daten, Bildern, Alarmmeldungen usw. versorgt.

Für den Fall dass dieser PC Server ausfällt , übernimmt das CE Terminal die Alarm und CEL Verwaltung.

attention Achtung

Das CE Terminal speichert nicht die Alarm und CEL Einträge während der Server inaktiv ist

Module, die unter CE nicht verfügbar sind, funktionieren nicht. Es muss darauf geachtet werden, dass keine Daten für die Archivierung am CE Terminal gespeichert werden. Das CE Terminal übernimmt nicht die Serverfunktion für die angeschlossenen Clients. Clients zeigen blaue Punkte als Zeichen einer Kommunikationsstörung an.

Wie im redundanten Netzwerk (Server und Standby- Server) ist auch hier der eigentliche Server dominant, d.h. nach dem Hochlaufen des PC Servers stuft sich das CE Terminal wieder zurück und fungiert weiter als Datenserver. Treiberdaten wie etwa HDD Daten werden abgeglichen. Der Server verwendet die am Server zuletzt gültige AML und CEL Daten und sendet diese an alle Clients (auch Datenserver). Das Archivmodul auf dem PC Server kann wieder archivieren und die restliche Clients gleichen sich mit dem Server ab und bekommen auch wieder Daten geliefert. Der Abgleich von System- und Mathematiktreiber funktioniert technisch bedingt nur teilweise.

Sollte der Datenserver ausfallen, so wird mittels roten Punkten an den Elementen auf dem Server und auf allen Clients eine Kommunikationsstörung angezeigt. Der Server übernimmt nicht die SPS Anbindung!

Diese Konstellation ist auch universell im PC Netzwerk einsetzbar, z.B. bei Verwendung eines leistungsschwächeren PCs direkt an der Maschine, der über eine Datenanbindung an den Prozess verfügt. Die Datenarchivierung erfolgt aber nicht auf diesem Rechner sondern abgesetzt im Netzwerk auf einem anderen zenon Server, der die Archivierung durchführt und die Datenhoheit besitzt.

Fazit: Fällt der Datenserver aus, so besteht keine Kommunikation mit der Steuerung. Alle Clients zeigen gestörte Werte an und es werden keine Daten archiviert. Fällt der Server aus, so wird während dieses Ausfalls ebenfalls keine Archivierung durchgeführt. Für die Zeit des Stillstandes sind keinerlei archivierte Daten verfügbar. Fällt der Server aus, übernimmt der Datenserver zwar die Alarmverwaltung, jedoch Alarme die in dieser Zeit kommen und gehen werden nicht am Server übernommen.

Projektierung des Datenserverkonzeptes in der Praxis:

Projektiert wird auf dem PC von dem aus die erzeugten Runtime Daten mittels Remote Transport zum Server und zum CE Terminal übertragen werden. Alle Clients (auch der Datenserver verhält sich wie ein Client) werden bei Projektänderungen mit den aktuellen Projektierungsdaten versorgt.

attention Achtung

In der Projektkonfiguration muss der Rechnername des PCs als Server und der Rechnername des CE Terminals als Standby- Server eingetragen werden. Zusätzlich muss die Option Standby als Datenserver gesetzt werden.

Die Option CE Projekt muss nicht gesetzt werden. Es steht für das Projekt die gesamte Funktionalität von zenon zur Verfügung. Da auf der CE Seite nur ein eingeschränkter Funktionsumfang einsetzbar ist, werden Funktionen, die unter CE nicht vorhanden sind, dort auch nicht ausgeführt (Module, bestimmte Funktionen, etc.)

Um den Maschinenbediener nicht zu verwirren, indem Bilder und Funktionen auf dem CE Terminal angeboten werden, die nicht funktionieren bzw. die vom ihm nicht benützt werden sollen, gibt es bei Bildern und den Buttons im Editor eine Option Sichtbar unter CE. Mit dieser Option wird dem Projektanten ermöglicht, sein Projekt so zu gestalten, dass ein Teil unter CE und ein anderer Teil nur auf dem PC (PC-Server, weiterer PC Client...) sichtbar ist.

Sonstige Einschränkungen des Datenservers:

Der Systemtreiber und der Mathematiktreiber werden im Datenserverkonzept (und nur dort) besonders behandelt: Sowohl der System- als auch der Mathematiktreiber laufen im Datenserverkonzept nur am Server. Der Datenserver bekommt daher die Werte dieser Treiber nicht. Erst wenn der Server beendet wird, starten am Datenserver Mathematik- und Systemtreiber. Sobald der Server wieder online ist, stuft sich der Datenserver zurück, beide Treiber laufen nun wieder am Server. Ab diesem Zeitpunkt erhält der Datenserver keine Werte mehr vom System- bzw. vom Mathematiktreiber. Daher funktionieren Mathematikvariablen im Datenserverkonzept auch nicht richtig.

Globale Variablen vom Systemtreiber wie etwa Aktuelle Clients, Anzahl angeschlossene Clients, Aktuellen Server werden vom Server verwaltet. Diese Variablen werden nicht vom Server an den Datenserver übermittelt. Der Datenserver zeigt bei diesen Variablen seine eigenen lokalen Inhalte an, die nicht mit denen vom Server übereinstimmen. Dies ist systembedingt und kann nicht geändert werden.

Einzige Ausnahme bilden die Lokalen Variablen des Systemtreibers wie etwa Freier Speicher, Freier Festplattenplatz usw. Diese Variablen werden immer lokal auf dem jeweiligen Rechner ausgelesen.

info Info

Alternativ zum Datenserverkonzept kann ab der Version 6.20 Projektübergreifende Archivierung verwendet werden um Daten von verschiedenen CE Terminals zu archivieren. Hierzu braucht jedes CE Terminal eine Netzwerk-Lizenz und im Projekt muss das CE Terminal als Server definiert werden.

Auf einem PC, der über eine Archivserver Lizenz verfügt, werden die CE Projekte als Unterprojekte eingefügt. Im I-Projekt können über die Archivkonfiguration Variablen von den Unterprojekten eingefügt werden. Nähere Informationen erhalten Sie in der Hilfe zur Archivierung.


Verbindung über ActiveSync oder Windows Mobile Device Center

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit Hilfe des Microsoft Programms ActiveSync (bis inklusive Windows XP) oder Windows Mobile Device Center (ab Windows Vista) können Sie zwischen einem industriellen CE Terminal und einen PC eine Verbindung aufbauen.

  • In dieser Anleitung wird der Aufbau mittels ActiveSync beschrieben: Serielle Verbindung unter Windows XP
  • Das Windows Mobile Device Center funktioniert analog: USB-Verbindung unter Windows 7

Noch in diesem Kapitel

USB-Verbindung unter Windows 7

Serielle Verbindung unter Windows XP

Update Windows CE Runtime


USB-Verbindung unter Windows 7

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center -> USB-Verbindung unter Windows 7

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei einer USB Verbindung zwischen dem CE Gerät und einem Rechner unter Windows 7:

  1. stellen Sie sicher, dass eine Verbindung zum Internet möglich ist
  2. verbinden Sie die beiden Geräte per USB-Kabel
  3. bei bestehender Internetverbindung wird das Windows Mobile Device Center automatisch installiert und die Verbindung hergestellt
  4. Sie können Daten übertragen, wie im Kapitel Update Windows CE Runtime beschrieben

info Info

Besteht bei der Verbindung per USB keine Internetverbindung, erfolgt keine automatische Installation und Konfiguration. In diesem Fall:

  • stellen Sie die Internetverbindnung her
  • navigieren Sie zu zum Gerätemanager in der Systemsteuerung
  • führen Sie einen Rechtsklick auf das noch nicht erkannten Gerät aus
  • wählen Sie Treibersoftware aktualisieren
  • Windows installiert den Treiber
  • Windows installiert den Windows Mobile Adapter und damit das Windows Mobile Device Center


Serielle Verbindung unter Windows XP

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center -> Serielle Verbindung unter Windows XP

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für diese Anleitung zur seriellen Verbindung unter Windows XP gilt:

  • Als Kommunikationsart wird nur auf serielle Punkt zu Punkt Verbindungen eingegangen.
  • Als Betriebssystem für das CE Terminal wird Windows CE 5.0 oder CE 6.0 vorausgesetzt.
  • Andere Betriebssysteme werden nicht behandelt.
  • Die Verbindung im Beispiel wird seriell über ein Nullmodemkabel hergestellt.

Noch in diesem Kapitel

Konfiguration PC

Konfiguration CE

Kommunikation starten

Fehlerbehebung


Konfiguration PC

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center -> Serielle Verbindung unter Windows XP -> Konfiguration PC

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zuerst muss Activesync installiert werden. Laden Sie die passende Version aus dem Microsoft Downloadcenter und installieren Sie es in ein beliebiges Verzeichnis. Achten Sie darauf, dass die installierte Version die gewünschte CE Version unterstützt.

Standardmäßig versucht Activesync auf allen COM-Ports und USB-Ports nacheinander eine Verbindung herzustellen. Wurde noch nie eine Verbindung hergestellt, muss die Verbindung auf CE-Gerät und PC gleichzeitig gestartet werden. Dabei ist die erfolgreiche Verbindungsaufnahme nicht sicher.

Empfehlung: Fügen Sie am PC folgende Einträge in die Registry ein, damit Activesync nur auf dem von Ihnen definierten COM-Port sucht:

[HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows CE Services]

SerialPort=COM1

Starten Sie Activesync und unter Datei -> Verbindungseigenschaften stellen Sie den COM-Port ein:


Konfiguration CE

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center -> Serielle Verbindung unter Windows XP -> Konfiguration CE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Neue Verbindung anlegen

Legen Sie am CE Panel eine neue Verbindung anlegen. Starten Sie dazu am CE Panel das Programm: /windows/remnet.exe

  1. Konfigurieren Sie eine neue serielle Verbindung.
  2. Make new connection
  3. Vergeben Sie einen Namen und selektieren Sie Direct Connection.
  4. Drücken Sie Next.
  5. Wählen Sie einen freien seriellen RS232 Port aus, an dem Sie das Nullmodem Kabel anschließen können.
  6. Drücken Sie Configure.
  7. Port Settings (Connection Preferences):
    1. Baud Rate: 19200
      Wenn noch nie eine Verbindung bestanden hat, empfiehlt sich 19200 Baud, da Active Sync damit standardmäßig arbeitet. Danach kann die Baudrate auf 115200 erhöht werden.
    2. Data Bits: 8
    3. Parity: None
    4. Stop Bits: 1
    5. Flow Control: Hardware
  8. Beenden Sie das Programm Remnet.

Communications registrieren

Im nächsten Schritt müssen Sie am CE Terminal in der Systemsteuerung den Dialog Communications starten.

  1. Aktivieren Sie in der Registerkarte PC Connection die Eigenschaft Enable direct connections to desktop computer.
  2. Klicken Sie auf die Schaltfläche Change und wählen Sie die vorher im Programm Remnet eingestellte Verbindung aus.
  3. Bestätigen Sie alle Dialoge mit OK und schließen Sie die Systemsteuerung

Einstellungen speichern

Speichern Sie die Änderungen der CE Registry am CE Gerät dauerhaft. Sonst gehen diese alle bei einem Neustart des Panels verloren !

Zum Speichern stellt jedes CE Terminal ein eigenes Tool zur Verfügung, zum Beispiel regflush.exe, flushreg.exe, savereg.exe usw. Sollten Sie keine Möglichkeit finden, die Registry zu speichern, kontaktieren Sie Ihren Hardwarehersteller.


Kommunikation starten

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center -> Serielle Verbindung unter Windows XP -> Kommunikation starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Geräte verbinden

Verbinden Sie das CE Panel mit dem PC über ein Nullmodem-Kabel.

  • PC: Die im Activesync konfigurierte Schnitstelle
  • CE: Die im Remnet konfigurierte Schnittstelle.

Achtung: Nur ein korrekt belegtes Nullmodemkabel wird von Activesync akzeptiert!

Pinbelegung eines Nullmodellkabels:

Kommunikation starten

Starten Sie am CE-Gerät das Programm /windows/repllog.exe.

Wenn das Icon in der Statusleiste am PC grün wird, steht die Verbindung. Ein Dialog wird aufgeschaltet, in dem Sie die Partnerschaft ablehnen und das Panel nur als Gast anmelden können.

Jetzt können Sie im Activesync Programm über Datei -> Durchsuchen direkt auf das CE Gerät zugreifen, Verzeichnisse erstellen, Dateien kopieren usw.

Hinweis: Dateien, wie etwa die zenon6.ini, können nicht direkt am CE Gerät geöffnet werden. Diese müssen erst auf den PC kopiert, dort bearbeitet und anschließend wieder zurückkopiert werden. Die Meldung beim Zurückkopieren über Dateikonvertierung kann ignoriert werden. Diese Konvertierung ist z.B. bei Office Dateien erforderlich.

Über diese Activesync Verbindung kann man jetzt mittels des CE Runtime Update Tools, den Transport Service auf das CE Panel kopieren. Details dazu lesen Sie im Abschnitt Update Windows CE Runtime.

attention Achtung

Die Kommunikatión funktioniert nur über repllog.

Auch wenn Sie am CE Panel über \windows\remnet.exe die Verbindung doppelt anklicken, scheint es, als ob die Verbindung erstellt würde, die Verbindung kommt aber nicht zustande.


Fehlerbehebung

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center -> Serielle Verbindung unter Windows XP -> Fehlerbehebung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn die Verbindung nicht zustande kommt, überprüfen Sie ob:

  • am CE Panel bzw. am PC das Kabel an den richtigen COM Schnittstelle angeschlossen ist
  • ein richtiges Nullmodemkabel verwendet wird
  • auf dem CE Gerät alle Einstellungen wie beschrieben vorgenommen wurden
  • ob der COM-Port den Sie am CE-Gerät verwenden wirklich ein RS232 Port und kein RS485/422 Port ist

Häufige Fragen

Frage

Antwort

Activesync öffnet immer ein Fenster "Verbindung erstellen".

Führen Sie die richtige Registrierungsdatei aus.

Am Rechner erhalte ich immer die Meldung, dass das Gerät nicht erkannt wird.

Überprüfen Sie, ob ein korrektes Nullmodemkabel benutzt wird.

Activesync wird zwar grün, aber nichts geht!

Die Verbindung wurde möglicherweise am CE Panel durch Doppelklick der Verbindung in Remnet.exe gestartet.

Starten Sie die Verbindung über Repllog.exe.

Wie kann ich überprüfen, ob ich auf der CE Seite den richtigen COM Port eingestellt habe?

Deaktivieren Sie im Activesync unter Datei -> Verbindungseinstellungen den seriellen COM-Port.

Überprüfen Sie die Verbindung über den COM-Port mit einem Terminalprogramm. (Bis inklusive Windows XP ist Hyperterminal in den Lieferumfang des Betriebssystems inkludiert.)

Wenn Sie dann die Verbindung über CE Repllog.exe. starten, sehen Sie bei jedem Retry im Terminal CLIENT.


Update Windows CE Runtime

Handbuch -> zenon Operator -> zenon unter Windows CE -> Verbindung über ActiveSync oder Windows Mobile Device Center -> Update Windows CE Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Update der Windows CE Runtime durchzuführen:

  • stellen Sie sicher, dass der zenon Transport Service (SysSrvCE.exe) auf dem CE Gerät läuft
  • vergewissern Sie sich, dass sie keine Remote Verbindung mittels zenon Editor zum Gerät aufgebaut haben
  • wählen Sie im zenon Menü Optionen den Befehl Update Windows CE Runtime
  • der Dialog zur Übertragung von Runtime-Dateien öffnet sich
  • konfigurieren Sie die Verbindung
  • definieren Sie die zu übertragenden Dateien
  • wählen Sie die Version aus
  • starten Sie das Update

Verbindung konfigurieren

Die Verbindung zum Windows CE Gerät konfigurieren Sie in der Registerkarte Connection.

Parameter | Beschreibung
Serial | Einstellung für serielle Verbindung zum Windows CE Gerät, Port muss ausgewählt werden.
TCP/IP | Einstellungen für TCP/IP Verbindung zum Windows CE Gerät.
Adress | IP Adresse.
Name | Name.
Syssrvce.exe starts with these settings | Einstellung für Start der syssrvce.exe.
Serial | Aktiv: serielle Verbindung wird gewählt, Port muss ausgewählt werden.
TCP/IP | Aktiv: TCP/IP Verbindung wird gewählt.
Connection with MS ActiveSync | Einstellungen zur Verbindung über MS ActiveSync
Use MS ActiveSync for initial transport of syssrvce.exe | Aktiv: syssrvce.exe wird beim ersten Transport über MS ActiveSync übertragen.
Destination folder | Zielordner.
Help | Öffnet die Online-Hilfe
Save | Speichert alle Änderungen.
Exit | Schließt das Update CE Tool und bietet zuvor das Speichern noch nicht gesicherter Änderungen an.

Zu übertragende Dateien definieren

Parameter | Beschreibung
Files to update | Dateien, die übertragen werden sollen.
HMI Runtime | Aktiv: Überträgt zenon Dateien zum Zielgerät. Default: aktiv
PLC Runtime | Aktiv: Überträgt zenon Logic Dateien zum Zielgerät. Default: inaktiv
OS system files | Aktiv: Überträgt nötige Dateien des Betriebssystems. Default: aktiv
Update zenon6.ini | Überträgt die zenon6.ini zum Zielgerät. Damit werden auch die Lizenzinformationen am Zielgerät geändert.
Options |
Language | Gewünschte Sprache am Zielsystem. Default: English
HMI drivers | Auswahl der zu übertragenden HMI Treiber.
Availabel | Liste der zur Verfügung stehenden Treiber.
Selected | Liste der ausgewählten Treiber.
Add | Fügt markierte Treiber zur Liste der ausgewählten Treiber hinzu.
Add all | Fügt alle Treiber zur Liste der ausgewählten Treiber hinzu.
Remove | Löscht markierte Treiber aus der Liste der ausgewählten Treiber.
Remove all | Löscht alle Treiber aus der Liste der ausgewählten Treiber.
Help | Öffnet die Online-Hilfe
Save | Speichert alle Änderungen.
Exit | Schließt das Update CE Tool und bietet zuvor das Speichern noch nicht gesicherter Änderungen an.

Version auswählen

Wählen Sie in der Registerkarte Versions die passende Version aus, falls sie nicht automatisch erkannt wurde.

Parameter | Beschreibung
WinCE version | Version des Windows CE Betriebssystems am Zielgerät. Klick auf Schaltfläche öffnet Dropdownliste zur Auswahl.
Processor type | Prozessor des Geräts.
Source path | Pfad zum Ordner, der die Dateien enthält. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl des Ordners.
New | Fügt neuen, leeren Eintrag in Liste ein.
Delete | Löscht den ausgewählten Eintrag aus der Liste,
Test | Überprüft Einstellungen.
Help | Öffnet die Online-Hilfe
Save | Speichert alle Änderungen.
Exit | Schließt das Update CE Tool und bietet zuvor das Speichern noch nicht gesicherter Änderungen an.

Update starten

Um die Verbindung herzustellen:

  • klicken Sie in der Registerkarte Update auf die Schaltfläche Start.

  • die Daten für die Übertragung werden überprüft und in einem Fenster angezeigt
  • starten Sie mit einem Klick auf die Schaltfläche Next die Übertragung zum Zielgerät

Falls die Übertragung aufgrund fehlender Dateien nicht gestartet werden kann, erhalten Sie eine Fehlermeldung mit der Liste der fehlenden Dateien:

  • Falls Sie die Fehlermeldung "The current update was not completed" erhalten, wurde die Installation unterbrochen oder nicht korrekt beendet.

info Info

Soll zenVNCServer.exe per Update ersetzt werden, wird dieser beendet und nach dem Update wieder gestartet. Dazu muss die Datei zenVNCSrvCE.exe in der

UpdateCE.ini im Abschnitt [SOURCES_FILES_GENERAL]folgende Einträge enthalten (per default vorhanden):

  • zenVNCSrvCE.exe
  • zenVNCCfgCE.exe


Rezeptgruppen-Manager

Handbuch -> zenon Operator -> zenon unter Windows CE -> Rezeptgruppen-Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit der Rezeptgruppen-Manager unter Windows CE einsetzbar ist, müssen die Daten des RGM in einer alternativen Ablage zur MS Access Datenbank abgelegt werden. Für Windows CE werden die Daten binär in einer Dateistruktur abgelegt.

Wenn Sie unter Projekteigenschaften -> Allgemein die Checkbox Windows CE Projekt aktivieren, werden die Daten des RGM automatisch binär angelegt.
Sie können die binäre Speicherung der Daten auch unabhängig von CE-Projekten manuell einstellen über:
Eigenschaften Rezeptgruppen -> Rezeptgruppen Manager -> RGM Datenablage -> binäre Dateien CE kompatibel).

Interne ID: Rezeptgruppen-Manager

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Rezeptgruppen-Manager

Rezeptgruppen Manager

Definieren Sie die Dateiablage für den Rezeptgruppen-Manager.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Rezeptgruppen-Manager

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Rezeptgruppen-Manager

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

attention Achtung

Eine Konvertierung der MS Access Datenbank nach binär oder umgekehrt ist nicht vorgesehen.

Bereits existierende RGM-Daten werden nicht konvertiert! Sie müssen bei Bedarf die Daten vor der Umstellung in XML exportieren. Im Anschluss können Sie das Projekt umstellen und die Daten in die neue Datenablage importieren.

Wechsel der Datenbank

Wurde beim RGM in der Eigenschaft RGM Datenablage als Datenbank MS ACCESS DB gewählt und wird dann die Checkbox Windows CE Projekt aktiviert, wird ein Hinweis zur Konvertierung aufgeschaltet:

Um die Daten der bisherigen Datenbank zu erhalten:

  1. exportieren Sie die Daten nach XML
  2. stellen Sie Datenbank um
  3. importieren Sie die XML-Datei

Filterdialog zur Runtime

Wird bei den Optionen der Rezeptwerttabelle in der Bildumschaltung die Eigenschaft Dialog zur Runtime anbieten aktiviert, stehen unter Windows CE nur eingeschränkte Optionen zur Verfügung:

  • Rezeptfilter
  • Spalteneinstellungen (für Rezepttabelle)

Rezeptauswahl, Anlagenmodellierung und Spalteneinstellungen für Rezeptliste werden nicht angeboten.

Mehrbenutzer-Projekte

In Mehrbenutzerprojekten können binäre Dateien und MS Access Datenbank unabhängig von einander ausgecheckt werden.

Im Fenster In Bearbeitung wird lokal immer nur der Status der auf diesem Rechner eingestellten Speicherart dargestellt. Werden Binärdateien verwendet, ist nicht ersichtlich, dass die Access Datenbank noch ausgechecked ist.

Damit ist folgendes Szenario möglich:

  • auf PC A ist die Access Datenbank ausgechecked
  • auf PC B wird CE-Projekt aktiviert und damit auf Binärdateien umgestellt
  • auf PC B werden die Binärdateien ausgechecked
  • auf PC B werden die Änderungen übernommen und dann mit PC A synchronisiert
  • damit wird auch auf PC A auf Binärdateien umgestellt
  • die Access Datenbank auf PC A bleibt damit weiter ausgechecked
  • erst wenn PC B wieder auf Access Datenbank umstellt, wird ersichtlich, dass auch auf PC A die Access Datenbank ausgechecked ist


Transparenz

Handbuch -> zenon Operator -> zenon unter Windows CE -> Transparenz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Unter Windows CE können GIF-Dateien transparent dargestellt werden. Im Gegensatz dazu stehen die Transparenzeinstellungen in den erweiterten Grafikfunktionen unter Windows CE nicht zur Verfügung.

Um eine transparente GIF-Datei unter Windows CE darzustellen:

  • muss am Zielgerät die Datei IMGDECEMP.dll vorhanden sein.
    Fehlt die Datei, können Sie die Datei IMGDECEMP.dll beim support@copadata.com anfordern.
  • Die Transparenz kann den Wert 0% oder 100% besitzen. Zwischenwerte sind nicht möglich.

info Info

Transparenz für PNG Dateien von 0% bis 100% unter Windows CE ist kein Bestandteil von zenon, kann aber unter bestimmten Voraussetzungen genutzt werden:

  • zenon Version 6.22 SP1 oder höher wird verwendet
  • Alpha Blending muss vom Hersteller des Zielgeräts bereits implementiert worden sein; COPA-DATA kann dazu keine Unterstützung zur Verfügung stellen


Pocket PC und Windows Mobil Edition

Handbuch -> zenon Operator -> zenon unter Windows CE -> Pocket PC und Windows Mobil Edition

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Beenden von zenon mit X auf einem Pocket PC bzw. Windows Mobile Edition ist zu beachten, dass die Anwendung nicht beendet wird, sondern im Hintergrund weiterläuft.

Um beim erneuten Starten der Anwendung zu verhindern, dass Ihr Gerät zenon noch einmal starten möchte, haben Sie mit dem Tool Start_CERT.exe die Möglichkeit die Anwendung in den Vordergrund zu holen oder wenn diese nicht gestartet sein sollte zu starten.

Wir empfehlen daher auf Pocket PC und Windows Mobile Plattformen die Runtime generell über Start_CERT.exe zu starten und nicht direkt über einen Link.

Hinweis: Pocket PC wird ab zenon Version 7 nicht mehr unterstützt.


zenon Science Package for Lego MINDSTORMS 2.0

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0

Das zenon Science Package for LEGO MINDSTORMS 2.0 ermöglicht die Programmierung von LEGO Mindstorms NXT 2.0 Objekten. Programme werden in zenon Logic erstellt und auf dem LEGO Controller mit straton ausgeführt. zenon Logic ist eine in zenon integrierte IEC 61131-3 Programmierumgebung.

Diese Anleitung führt durch Installation und Programmierung für die Automatisierung eines LEGO Mindstorms NXT 2.0 Objekts mit zenon. In dieser Dokumentation sind nur Informationen in Bezug auf den Betrieb mit straton enthalten. Grundlegende Informationen zu Programmierung und Betrieb von LEGO MINDSTORM NXT 2.0 Objekten entnehmen Sie der LEGO Dokumentation.

tutorial Lizenzinformation

Wird zenon Science Package for LEGO MINDSTORMS 2.0 auf einem System verwendet, das:

  • noch keine zenon Installation enthält, dann läuft es mit einer eingeschränkten zenon Science Package Lizenz
  • das bereits eine zenon Installation enthält, dann läuft es mit der bereits bestehenden jeweiligen zenon Lizenz

Sämtliche nötige Software ist auf der DVD "zenon Science Package for LEGO MINDSTORMS 2.0" enthalten. Dieses Paket enthält keine Hardware und keine Bauteile oder Steuerungen der Firma LEGO.

Für die Projektierung von LEGO Hardware mit zenon verwenden Sie folgende Software:

  • zenon: Software zum Beobachten und Steuern, die das integrierte zenon Logic enthält.
  • zenon Logic Workbench: Programmierumgebung für Programme, die auf der eingebetteten straton Firmware laufen.
  • straton: Firmware für den LEGO Controller.

Auf dem Installationsmedium finden Sie alle nötigen Applikationen und Informationen. Diese sollten bereits in Ihrem zenon Ordner am PC angelegt sein. Die wichtigsten Ordner:

  • FIRMWARE: Dieser Ordner enthält die Firmware, die Sie mit dem LEGO Firmware Loader auf Ihren LEGO MINDSTORMS NXT 2.0 Controller laden können. Details dazu lesen Sie im Kapitel Firmware installieren.
  • USB_DRIVER: Dieser Ordner enthält die INF-Datei für den USB-auf-Seriell Treiber.

info Info

LEGO®, MINDSTORMS® und NXT sind Marken und Produkte der Firma LEGO.

Noch in diesem Kapitel

Installation

Verbindung zwischen zenon Logic und straton herstellen

straton Anwendungen für NXT entwickeln

MINDSTORMS 2.0 Runtime mit zenon verbinden

Fragen und Antworten

Verwendung komplexer Variablen


Installation

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für dem Einsatz des zenon Science Package for LEGO benötigen Sie:

  • zenon ab Version 7.00 SP0
  • Firmware für den LEGO Controller

Falls Sie bereits zenon 7.00 oder höher auf Ihrem Rechner installiert haben, verfügen Sie auch über eine Lizenz für den Einsatz des zenon Science Package for LEGO. Falls Sie zenon noch nicht installiert haben, installieren Sie die zenon Version von der DVD. Es handelt sich dabei um eine eingeschränkte Lizenz für den Einsatz mit LEGO MINDSTORMS 2.0.

Noch in diesem Kapitel

zenon installieren

Demo-Projekte

Firmware installieren

Umgang mit bereits existierender Firmware

Bluetooth-Verbindung zum Controller herstellen


zenon installieren

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation -> zenon installieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um zenonin der jeweils aktuellen Version zu installieren:

  1. starten Sie die DVD
  2. wählen Sie zenon 8.2
  3. folgen Sie den Anleitungen des Installationsassistenten

Hinweis: Falls Sie bereits über eine zenon Version ab 7.00 verfügen, ist keine Installation notwendig.

Noch in diesem Kapitel

zenon Science Package Lizenz


zenon Science Package Lizenz

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation -> zenon installieren -> zenon Science Package Lizenz

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das zenon Science Package for LEGO MINDSTORMS 2.0 ist in der zenon Standardlizenz enthalten. Wird diese Version auf einem System ohne zenon installiert, läuft es mit einer zenon Science Package Lizenz. Mit dieser Lizenz können im Rahmen der lizenzierten Module auch zenon Projekte erstellt und bearbeitet werden.

Diese Lizenz beinhaltet:

  • 128 Variablen
  • Erweiterter Trend Starter Edition
  • Archivserver Starter Edition
  • VBA
  • zenon Logic Workbench
  • straton Firmware

Hinweis: Diese Lizenz ist 90 Minuten lauffähig. Danach muss der Editor beendet und neu gestartet werden.


Demo-Projekte

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation -> Demo-Projekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit der Installations-DVD erhalten Sie auch zwei Demo-Projekte:

  • MINDSTORMS_DEMO: Gibt Ihnen einen Überblick über Sensoren und Controller. Benutzen Sie dieses Projekt, um sich mit LEGO MINDSTORMS 2.0 und dessen Programmierung vertraut zu machen.
  • LEGO_DEMO_SHOOTERBOT: Ein Beispielprojekt für den Shooterbot. Sie können es nach Belieben an Ihre Bedürfnisse anpassen.

Wenn Sie den Editor über die DVD installiert haben, befindet sich die Demo-Projekte bereits im Arbeitsbereich. Benutzen Sie eine bereits vorhandene zenon Installation, dann finden Sie die Demo-Projekte auf der DVD im Science Workspace. Laden Sie den Arbeitsbereich mit den beiden Projekte in zenon. Dazu:

  1. führen Sie einen Rechtsklick auf den aktuellen Arbeitsbereich aus
  2. wählen Sie im Kontextmenü Arbeitsbereich -> Sicherung rücklesen...
  3. navigieren Sie zur Arbeitsbereichsicherung auf der DVD (*.wsb)
  4. wählen Sie Datei aus und klicken Sie auf OK

Um die Projekte zu öffnen:

  1. navigieren Sie im Arbeitsbereich zum Knoten zenon Logic (IEC 61131-3)
  2. wählen Sie den Knoten mit einem Linksklick aus
  3. wählen Sie das Projekt mindstorms
  4. klicken Sie auf das Symbol öffnen in der Symbolleiste oder führen Sie einen Doppelklick auf das Projekt aus, um das Projekt in der zenon Logic Workbench zu öffnen


Firmware installieren

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation -> Firmware installieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Ihr LEGO MINDSTORMS 2.0 mit zenon nutzen zu können, müssen Sie die straton Firmware auf den Controller laden. In diesem Kapitel erfahren Sie, wie Sie:

  • straton Firmware auf den Controller laden
  • bereits vorhandene straton Firmware updaten bzw. bereits existierende andere Firmware ersetzen
  • eine USB-Verbindung mit dem COPA-DATA USB-Treiber zum Controller herstellen
  • eine Bluetooth-Verbindung zum Controller herstellen

straton Firmware auf den Controller laden

Um die straton Firmware auf den LEGO MINDSTORMS NXT 2.0 Controller zu laden, benötigen Sie die LEGO MINDSTORMS NXT 2.0 Software, die Sie mit Ihrem LEGO MINDSTORMS NXT 2.0 erhalten haben.

attention Achtung

Befindet sich bereits eine andere Firmware auf dem Controller, als die von LEGO gelieferte, beachten Sie die Vorgehensweise im Abschnitt Umgang mit bereits existierender Firmware.

Um die Firmware zu laden:

  1. Starten Sie die LEGO MINDSTORMS NXT 2.0 Software.
  2. Wählen Sie im Menü Tools -> Update NXT Firmware

  3. Achten Sie auf das korrekte Format: *.rfw.
    Sollte die Dateiendung noch auf *.bin lauten, ändern Sie diese auf *.rfw.
    Die Datei sollte STRATON_NXT_100_2011_0414.rfw oder ähnlich heißen.
  4. Klicken Sie auf die Schaltfläche Browse.
  5. Wählen Sie den Ordner mit der Firmware.

  6. Starten Sie den NXT Controller.
    Drücken Sie dazu die orange Taste.
  7. Verbinden Sie den Controller über USB mit dem PC.
  8. Klicken Sie auf die Schaltfläche Download, um die Firmware auf den Controller zu laden.

  9. Entfernen Sie das USB-Kabel.
  10. Der Controller startet mit der aktualisierten Firmware

info Info

Um die geladene straton später upzudaten oder wieder durch Firmware von LEGO zu ersetzen, folgen Sie den Anweisungen im Abschnitt Umgang mit bereits existierender Firmware.


Umgang mit bereits existierender Firmware

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation -> Umgang mit bereits existierender Firmware

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Befindet sich bereits Firmware, die nicht von LEGO stammt, auf dem Controller, muss dieser in den Firmware-Load-Modus versetzt werden, um andere Firmware installieren zu können. Dieser Modus wird auch benötigt, wenn die straton Firmware upgedatet oder wieder LEGO Firmware geladen werden soll. Um den Controller in den Firmware-Load-Modus zu versetzen:

  1. Drücken Sie gleichzeitig mindestens 5 Sekunden lang bis Sie ein leises Klicken hören
    • die orange Starttaste und
    • den Rest-Knopf auf der Geräüterückseite.
      Den Rest-Knopf erreichen Sie am besten mit einem spitzen Gegenstand.

  2. Schalten Sie den NXT Controller durch Drücken der orangefarbenen Taste ein.

  3. Der NXT Controller startet im Firmware-Load-Modus . Sie hören ein regelmäßiges Geräusch.
  4. Starten Sie den Download der gewünschten Firmware.
    Dazu muss eine Verbindung per USB oder Bluetooth hergestellt werden. Für die USB-Verbindung zu zenon/straton wird der COPA-DATA Treiber benötigt.

attention Achtung

Der Firmware-Load-Modus kann nur mit dem Download einer Firmware beendet werden.

Noch in diesem Kapitel

USB-Verbindung ohne LEGO Firmware


USB-Verbindung ohne LEGO Firmware

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation -> Umgang mit bereits existierender Firmware -> USB-Verbindung ohne LEGO Firmware

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn die benutzte Firmware nicht von LEGO stammt, muss eventuell der entsprechende Treiber installiert werden. Der USB Controller wird in diesem Fall bei der Verbindung zum PC nicht erkannt. Um die USB-Verbindung herzustellen:

  1. Öffnen Sie die Systemsteuerung -> System -> Gerätemanager.
  2. Führen Sie einen Doppelklick auf Unbekanntes Gerät aus.
  3. Klicken Sie in de Registerkarte Treiber auf Treiber aktualisieren.
  4. Der Dialog zur Treiberauswahl wird geöffnet.
  5. Wählen Sie Auf dem Computer nach Treibersoftware suchen.
  6. Wählen Sie den Ordner aus, in dem sich die Datei Mindstorm_straton.inf befindet.
  7. Eine Warnung bezüglich des Treiberherstellers wird angezeigt.
  8. Wählen Sie Treiber dennoch installieren.
  9. Das Gerät kann nun über USB kommunizieren.


Bluetooth-Verbindung zum Controller herstellen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Installation -> Bluetooth-Verbindung zum Controller herstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Falls der PC über einen Bluetooth-Port verfügt, kann die Verbindung zum Controller auch via Bluetooth hergestellt werden. Um Bluetooth für die Verbindung zwischen PC und Controller zu konfigurieren:

  1. Schalten Sie den LEGO Controller durch Drücken der orangen Taste ein.

  2. Drücken Sie erneut die orange Taste.
  3. Wählen Sie mit der rechten grauen Pfeiltaste Settings aus.

  4. Bestätigen Sie Auswahl durch Drücken der orangen Taste.
  5. Navigieren Sie mit Hilfe der grauen Tasten ins Menü für Bluetooth-Einstellungen.
    1. Schalten Sie Bluetooth ein.
    2. Vergeben Sie einen Bluetooth-Namen.
    3. Setzen Sie den Bluetootth-Status auf visible.
    4. Klicken Sie die dunkelgraue Taste, um das Bluetooth-Menü zu verlassen.
  6. Wechseln Sie ins Menü Connections.
  7. Wählen Sie mit Hilfe der grauen Tasten Bluetooth aus.
  8. Jetzt kann der Controller über Bluetooth gefunden werden.
  9. Öffnen Sie den Bluetooth Gerätemanager auf dem PC.
    1. Wählen Sie Gerät hinzufügen.
    2. Windows sucht nach sichtbaren Bluetooth-Geräten.
    3. Wählen Sie aus der Liste Ihren MINDSTORMS NXT Controller aus und klicken Sie auf Weiter.
    4. Der MINDSTORM Controller verlangt die Eingabe eines Passworts für die Herstellung der Verbindung:
      1234_ wird vorgeschlagen. Bestätigen Sie das Passwort mit Drücken der orangen Taste.
    5. Das im MINDSTORMS 2.0 Controller definierte Passwort muss auch am PC eingegeben werden.
    6. Klicken Sie auf Weiter.
  10. Die Verbindung wird hergestellt und die Treiber werden installiert.
  11. Führen Sie einen Doppelklick auf das erstellte Bluetooth-Gerät aus.
    Sie sehen das installierte Gerät und den zugewiesenen COM-Port. Mit diesem COM-Port verbinden Sie die zenon Logic Workbench oder zenon mit dem dem stratonNG-Treiber.
    Um den Port anzupassen:
    1. Klicken Sie auf Eigenschaften.
    2. Klicken Sie auf die Schaltfläche Erweitert.
    3. Ändern Sie die Portnummer entsprechend Ihren Wünschen.


Verbindung zwischen zenon Logic und straton herstellen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Verbindung zwischen zenon Logic und straton herstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Verbindung zwischen zenon Logic und straton herzustellen:

  1. Starten Sie zenon. Das Projekt MINDSTORMS wird geöffnet.
    Sollte ein anderes Projekt oder ein anderer ARbeitsbereich geöffnet werden, öffnen Sie den Arbeitsbereich für das Projekt über das Kontextmenü für den Arbeitsbereich.
    Möchten Sie ein neues Projekt erstellen:
    1. wählen Sie Datei -> Projekt neu
    2. erstellen Sie ein neues zenon Logic Projekt indem Sie nach einem Rechtsklick auf den Knoten zenon Logic im Projektbaum zenon Logic Projekt neu... wählen
  2. Öffnen Sie das zenon Logic Projekt mit Doppelklick in der Workbench.
  3. Klicken Sie in der zenon Logic Workbench auf Tools -> Kommunikations-Parameter.

  4. Der Dialog Optionen wird mit der Registerkarte Debug zur Konfiguration der Verbindung geöffnet.
  5. Klicken Sie auf die Schaltfläche ..., um den Dialog für die Einstellungen für die serielle Kommunikation zu öffnen.

  6. Konfigurieren Sie die serielle Einstellung passend zu den Einstellungen für den LEGO Controller.
    Hinweis: In diesem Dialog sind nur die COM-Ports 1 bis 4 auswählbar. Sie können jedoch im Dialog Optionen, Registerkarte Debug, den COM-Port direkt in das Feld Kommunikationsparameter eintragen.

  7. Damit haben Sie Verbindung zwischen zenon Logic und straton konfiguriert.

Noch in diesem Kapitel

NXT Treiber in zenon Logic hinzufügen

NXT Controller verbinden

Controller Grundeinstellungen


NXT Treiber in zenon Logic hinzufügen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Verbindung zwischen zenon Logic und straton herstellen -> NXT Treiber in zenon Logic hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den NXT Treiber in zenon Logic einzufügen:

  1. Führen Sie im Projektbaum der zenon Logic Workbench einen Doppelklick auf Feldbuskonfiguration aus.
  2. Klicken Sie im Fenster I/O Treiber auf das Symbol oder den Befehl im Kontextmenü für Konfiguration einfügen.

  3. Der Dialog zur Konfiguration wird geöffnet.

  4. Wählen Sie LEGO Mindstorms NXT 2.0.
  5. Es sind drei Abschnitte vorhanden:
    • NXT (Status)
    • Drives
    • Sensors

    Klick auf das Pluszeichen (+) vor dem Abschnitt öffnet Teilbereich. Für jeden dieser Abschnitte lassen sich sehr einfach vordefinierte Variablen erstellen.

Variablen erstellen

Erstellen Sie die benötigten Variablen:

  1. Führen Sie einen Rechtsklick auf den Zweig NXT, Drives oder Sensors aus.

  2. Wählen Sie im Kontextmenü Create variable.

Drives

Es existieren zwei Versionen: easy und advanced. Für den Einstieg wählen Sie am besten easy und dann Create variable. Mehr über die Verwendung von Advanced Variables lesen Sie im Abschnitt Verwendung komplexer Variablen.

Sensors

Bevor Sie im Abschnitt Sensors eine Variable erstellen, müssen Sie im Feld Type einen Sensortyp auswählen. Dazu führen Sie einen Doppelklick auf das Feld Value aus.

Konfigurationsbeispiel:


NXT Controller verbinden

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Verbindung zwischen zenon Logic und straton herstellen -> NXT Controller verbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den NXT Controller zu verbinden:

  1. Wählen Sie am Controller USB als Verbindungsmedium:
    1. Drücken Sie die orange Taste.
    2. Navigieren Sie mit den grauen Tasten zum Menü Settings und öffnen Sie es mit Druck auf die orange Taste.
    3. Wählen Sie Connection.
    4. Wählen Sie USB.
      (Falls Sie über Bluetooth verbinden möchten, wählen Sie hier Bluetooth aus.)
  2. Kompilieren Sie das zenon Logic Projekt:
    1. Führen Sie einen Rechtsklick auf mindstorms im Projektbaum aus.
    2. Wählen Sie im Kontextmenü Projekt kompilieren.
  3. Gehen Sie online:
    1. Wählen Sie im zenon Logic Menü Projekt den Eintrag Online aus.
    2. Die Abfrage für den Download wird geöffnet:

    3. Klicken Sie auf Yes.
  4. Das Projekt ist online und Sie können verfolgen, wie die Sensoren Werte einlesen.


Controller Grundeinstellungen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Verbindung zwischen zenon Logic und straton herstellen -> Controller Grundeinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Basiskonfiguration

  1. Konfigurieren Sie die Kommunikationseinstellungen (Details siehe folgender Abschnitt: Settings).
  2. Aktivieren oder deaktivieren Sie Bluetooth (Details siehe folgender Abschnitt: Connection).
  3. Bei aktivem Bluetooth: Vergeben Sie einen einzigartigen Namen für die Bluetooth-Kommunikation.

Bedienung

Einschalten

Um den Controller einzuschalten, drücken Sie die orange Taste.

Menü-Navigation

  • Menü öffnen: Drücken Sie die orange Taste.
  • Menü schließen: Drücken Sie die dunkelgraue Taste.
  • Im Menü navigieren: Drücken Sie die linke oder rechte graue Pfeiltaste. Mit der orangen Taste wählen Sie einen Menüeintrag aus. Um ein Untermenü zu verlassen, ohne zu speichern, drücken Sie die dunkelgraue Taste.

Ausschalten

  1. Wählen Sie im Hauptmenü Turn off und drücken Sie die orange Taste.
  2. Wählen Sie eine Option aus:
    1. Save: Sichert alle Einstellungen auf den Flash-Speicher und beendet den Controller. Damit werden die aktuell geladene straton Anwendung, die Retain-Data und die Konfiguration (Connection, Volume) auf den Flash-Speicher gespeichert.
    2. Don't save: Schließt die Anwendung ohne Daten oder Konfiguration auf den Flash-Speicher zu sichern.
    3. Cancel: Das Schließen wird abgebrochen und das Hauptmenü geöffnet.

Beim nächsten Start werden die zuletzt gesicherten Daten (straton Anwendung, Retain-Data etc.) geladen.

straton Menü

Mit dem straton Menü können Sie die geladene straton Applikation starten oder stoppen. Um das Menü zu öffnen, wählen Sie im Hauptmenü den Eintrag straton .

Statistics

Statistics zeigt Ihnen Informationen über die aktuell laufende Applikation. Um die entsprechenden Daten anzuzeigen, wählen Sie im Hauptmenü den Eintrag Statistics. Sie sehen:

  • den Namen der geladenen Applikation
  • Größe des Codes in kB
  • die Datenbankgröße in kB
  • die Ausführungszeit des straton Zyklus
  • die Zyklus-Latenz in Microsekunden

Menü Settings

In diesem Menü konfigurieren und sehen Sie:

  • Versions: Information zur verwendeten Version.
  • Bluetooth: Aktivierung oder Deaktivierung von Bluetooth. Name und Kontakte können verwaltet werden.
    • Name: Geben Sie einen Namen für das Bluetooth Gerät an. Der Name sollte im Bluetooth-Netz einzigartig sein.
    • On/Off: Aktiviert/deaktiviert Bluetooth am Controller.
    • Visibility: Legt fest, ob das Gerät für andere Bluetooth-Geräte sichtbar ist.
    • Search: Startet Suche nach Bluetooth-Geräten. Um ein Gerät zu den Bluetooth-Kontakten hionzuzufügen, wählen Sie es aus der Liste der gefundenen Geräte aus.
    • Contacts: Kontakte verwalten. Sie können Kontakte (Geräte, die sich verbinden dürfen) entfernen oder Verbindungen (z. B. zum Pairen) herstellen.

Connection

Auswahl der Verbindung, die vom straton Kommunikationsserver benutzt werden soll. Diese Verbindung wird für die Kommunikation mit der zenon Logic Workbench benutzt. Der Kommunikationsserver beinhaltet auch einen MODBUS Slave. Auch der zenon Treiber für straton muss mit dem Kommunikationsserver verbunden werden. Mögliche Einstellungen sind:

  • USB
  • Bluetooth: eingehende Bluetooth-Verbindung
  • RS-485: RS-485 Port mit den Parametern 115200, E, 8, 1
    Achtung: Die Verwendung von RS-485 deaktiviert den Sensor-Port 4. Beachten Sie auch, dass das straton Kommunikationsserver Protokoll nur Point-to-Point verwendet werden kann.
  • None: Der Kommunikationsserver wird nicht verwendet.

Volume

Definiert die Lautstärke der eingebauten Lautsprecher. Mögliche Werte sind 0 bis 4, wobei gilt:

  • 0: abgeschaltet
  • 4: Maximum


straton Anwendungen für NXT entwickeln

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für straton Anwendungen auf LEGO MINDSTORMS 2.0 gelten folgende Einschränkungen:

straton Runtime:

  • Maximalgröße für Code: 26 kB
  • Maximalgröße der straton Datenbank: 20 kB

Hinweis: Größe des Codes und der Datenbank können im Menü Statistics überprüft werden.

zenon Logic Workbench

  • Es können nur die COM-Ports 1 - 9 verwendet werden. Wurde einem USB-Gerät oder einem Bluetooth COM-Port eine höherer Portnummer als 9 zugewiesen, muss dies manuell auf eine Portnummer kleiner als 10 konfiguriert werden.
  • In der Workbench können nur die Ports COM1 – COM4 ausgewählt werden. Es können allerdings Portnummern direkt in den Parameterstring eingetragen werden, z.B. COM9:19200,N,8,1. (Siehe auch Abschnitt Verbindung zwischen zenon Logic und straton herstellen.)
    Hinweis: Bei einer USB- oder Bluetooth-Verbindung genügt die Angabe des Ports, z.B. COM5

info Info

Generelle Informationen zur Programmierung von LEGO MINDSTORMS NXT 2.0 entnehmen Sie der LEGO Dokumentation.

Noch in diesem Kapitel

NXT Kommunikation-Ports benutzen

Funktionen


NXT Kommunikation-Ports benutzen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

NXT Objekte enthalten drei Kommunikation-Ports, die von der straton Anwendung angesprochen werden können.

Über das Menü Settings wird eine dieser Verbindungen für den Kommunikationsserver ausgewählt. Diese Verbindung kann dann nicht mehr aus der straton Anwendung heraus (z.B. von einem MODBUS Master oder einem Funktionsblock) benutzt werden. Wurde allerdings eine MODBUS Slave Konfiguration hinzugefügt, kann ein MODBUS Slave den hier konfigurierten Port benutzen.

Weitere Informationen über die Nutzung des seriellen Ports im straton Programm und über den MODBUS I/O Treiber finden Sie in der zenon Logic Dokumentation. Drücken Sie dazu in der Workbench die Taste F1 oder benutzen Sie das Menü Hilfe.

Alle Ports, die nicht vom Kommunikationsserver benutzt werden, können von der straton Anwendung verwendet werden und werden wie im Folgenden beschrieben angesprochen:

Noch in diesem Kapitel

USB

Bluetooth

RS-485 Port (seriell)

Feldbus


USB

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> USB

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Über den USB-Port kann der NXT Baustein mit einem PC verbunden werden. Vom PC wird NXT als serielle Verbindung erkannt.

Von der straton Anwendung kann der USB-Port angesprochen werden, indem USB als COM-Port ausgewählt wird.


Bluetooth

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Bluetooth

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der Bluetooth-Port kann auf zwei Arten verwendet werden:

  1. Für eingehende Verbindungen:
    Dabei wird die Verbindung von einem Remote-Gerät aufgebaut, z.B. einem PC. In diesem Fall genügt die Zeichenfolge BT, um den Bluetooth-Port zu benutzen.
  2. Für ausgehende Verbindungen:
    NXT wird konfiguriert, um eine Verbindung zu einem anderen Bluetooth-Gerät aufzubauen, zum Beispiel eine anderes NXT Objekt. In diesem Fall benutzen Sie eine Zeichenfolge, die mit BT beginnt und mit dem Namen des Geräts endet, zum Beispiel: BT:NXT.
    Hinweis: Das anzusprechende Gerät muss bereits in den Bluetooth-Kontakten enthalten sein. Um ein Gerät manuell zu den Kontakten hinzuzufügen, starten Sie die Suche und stellen Sie die Verbindung einmal manuell her. Beim ersten Kontakt ist eventuell Pairing nötig.


RS-485 Port (seriell)

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> RS-485 Port (seriell)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

NXT Objekte enthalten auch einen seriellen RS-485 Port. Dieser wird allerdings mit dem Sensor 4 geteilt. Es kann also nur der Port oder nur der Sensor verwendet werden.

Der RS-485 Port wird über die Zeichenfolge HS angesprochen. Damit wird der Port standardmäßig mit folgenden Parametern geöffnet:

  • Baudrate: 115200 Bit/s
  • Parity: even
  • Data Bits: 8
  • Stop Bit: 1

Parameter anpassen

Wenn Sie die Kommunikationsparameter anpassen möchten, fügen Sie diese nach dem Doppelpunkt, getrennt durch Kommata, ein. Die Reihenfolge:

  • Baudrate in bits/s
  • Parity: N (none), E (even), O (odd), M (mark) and S (space)
  • Data Bits
  • Stop Bit

Zum Beispiel: HS:19200,N,8,1

Hinweis: Wenn Sie den RS-485 Port mit MODBUS oder dem straton Protokoll benutzen, setzen Sie Data Bits immer auf 8.


Feldbus

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit straton NXT kann auch die MODBUS Slave and MODBUS Master Konfiguration verwendet werden. Informationen zu MODBUS finden Sie in der zenon Logic Dokumentation. Drücken Sie dazu in der Workbench die Taste F1 oder benutzen Sie das Menü Hilfe. Die Nutzung der NXT Sensoren und Motor-Ports konfigurieren Sie in der LEGO MINDSTORMS NXT 2.0 Konfiguration.

Noch in diesem Kapitel

Status Variablen

Drive Variablen

Farbsensor Variablen

Touch Sensor Multiplexer (HT)

Gyroskopischer Sensor (HT)

Digitaler Beschleunigungs-Sensor (HT)

Digital Kompass-Sensor (HT)

Andere Sensoren


Status Variablen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Status Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Statusvariablen stehen zur Verfügung:

  • STATUS_BATTERYVOLTAGE: aktuelle Ladung der Batterie in Millivolt.
  • STATUS_BATTERYSTATE: Batteriekapazität.
    Wert: 0 bis 4 (wie am NXT Display angezeigt)
  • STATUS_BLUETOOTHSTATE: Bluetooth Status
    Werte:
    • 0: ein
    • 1: sichtbar
    • 2: verbunden
    • 3: verbunden und sichtbar
    • 4: aus
  • STATUS_USBSTATE: USB Status
    Werte:
    • 0: getrennt
    • 1: verbunden
    • 2: in Betrieb
  • STATUS_RECHARGEABLE: Status für wiederaufladbare Akkus
    Werte:
    • 0: Keine wiederaufladbaren Akkus vorhanden
    • 1: wiederaufladbare Akkus vorhanden
  • STATUS_ERROR: Fehler-Code


Drive Variablen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Drive Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Antrieb stehen folgende Variablen zur Verfügung:

  • PORT_x_AUTOSPEED (SINT, Output): Definiert Geschwindigkeit des Motors.
    Werte: von -100 bis 100
    • 0: Motor aus
    • -100: Maximalgeschwindigkeit rückwärts
    • 100: Maximalgeschwindigkeit vorwärts
  • PORT_x_TACHOCOUNT (DINT, Input): Enthält absolute Anzahl an Umdrehungen des Motors in Winkelgraden. 360° sind eine vollständige Umdrehung pro Sekunde. Mögliche Werte: von -2.147.483.648 bis 2.147.483.647

Komplexe Variablen

Komplexere Operationen mit den Antrieben konfigurieren Sie mit komplexen Variablen. Diese wählen Sie über den Eintrag Create advanced variables im Kontextmenü.

attention Achtung

Benutzen Sie die AUTOSPEED Variable und die Advanced Variables nicht zur gleichen Zeit. Die gemeinsame Verwendung kann zu zu einem undefinierten Verhalten des Antriebs führen.

Eine Beschreibung, wie diese Variablen konfiguriert werden, finden Sie im Abschnitt Verwendung komplexer Variablen.


Farbsensor Variablen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Farbsensor Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Farberkennung stehen folgende Variablen zur Verfügung:

  • PORT_x_COLOR (INT, Output): Definiert den Sensor-Modus.
    • 0: Passiver Modus (Helligkeit messen)
    • 1: Rot wird gemessen
    • 2: Grün wird gemessen
    • 3: Blau wird gemessen
    • 4: Alle Farben werden gemessen
  • PORT_x_VALUE (INT, Input)

    Wenn der Modus passiv, rot, grün oder blau ist:

    • Ein Wert zwischen 0 und 255 legt die Farbintensität fest.

    Wenn der Modus alle Farben ist:

    • 1: schwarz
    • 2: blau
    • 3: grün
    • 4: gelb
    • 5: rot
    • 6: weiß
  • PORT_x_RED: Im Modus alle Farben wird Intensität der Farbe rot gemessen.
  • PORT_x_GREEN: Im Modus alle Farben wird Intensität der Farbe grün gemessen.
  • PORT_x_BLUE: Im Modus alle Farben wird Intensität der Farbe blau gemessen.
  • PORT_x_GRAY: Helligkeit wird gemessen


Touch Sensor Multiplexer (HT)

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Touch Sensor Multiplexer (HT)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Touch-Sensoren stehen folgende Variablen zur Verfügung:

Unter Verwendung des Hitechnic Touch Sensor Multiplexer können bis zu vier Sensoren mit einem NXT Port verbunden werden:

  • PORT_x_SWITCH1: Status von Sensor 1
  • PORT_x_SWITCH2: Status von Sensor 2
  • PORT_x_SWITCH3: Status von Sensor 3
  • PORT_x_SWITCH4: Status von Sensor 4


Gyroskopischer Sensor (HT)

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Gyroskopischer Sensor (HT)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der LEGO MINDSTORMS 2.0 NXT Gyro Sensor informiert über die Anzahl der Umdrehungen des Motors und über die Richtung der Umdrehungen. Die Umdrehungen werden in Winkelgraden gemessen. 360° sind eine vollständige Umdrehung pro Sekunde.

Nach dem Start der straton Anwendung wird der Sensor beim Anschließen automatisch kalibriert. Dazu wird der aktuelle Null-Wert berechnet. Dieser Vorgang dauert etwa 200 ms. Während dieser Zeit darf der Sensor nicht bewegt werden.

  • PORT_x_VALUE: Anzahl der Winkelgrade pro Rotationssekunde
  • PORT_x_INVALID: Steht auf TRUE wenn:
    • der Sensor kalibriert wird
    • der Wert nicht ausgelesen werden kann


Digitaler Beschleunigungs-Sensor (HT)

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Digitaler Beschleunigungs-Sensor (HT)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der LEGO MINDSTORMS 2.0 NXT Beschleunigungssensor enthält einen 3-Achsen-Beschleunigungsmesser, der Beschleunigung in den drei Achsen x, y und z misst. Die Beschleunigung wird im Bereich von -2g bis +2g mit etwa 200 Unterteilungen pro g angezeigt.

Der Beschleunigungssensor kann auch verwendet werden, um Neigung in drei Achsen zu messen. Das ist möglich, weil die Erdanziehungskraft als Beschleunigung wahrgenommen wird. Wenn der Sensor in der normalen horizontalen Position unbewegt ist, werden die X-Achse und die Y-Achse nahe Null sein, weil sie horizontal sind, während der Wert für die Z-Achse nahe 200 sein wird, was 1g entspricht. Wenn Sie den Sensor dann neigen, wird auch auf den anderen Achsen Erdanziehungskraft wahr genommen und der Wert für die Z-Achse wird sinken. Da die Erdanziehungskraft unter den drei Teilvektoren verteilt wird, kann die Neigung des Sensors bestimmt werden.

  • PORT_x_VALUE_X: Beschleunigung in Richtung der X-Achse
  • PORT_x_VALUE_Y: Beschleunigung in Richtung der Y-Achse
  • PORT_x_VALUE_Z: Beschleunigung in Richtung der Z-Achse
  • PORT_x_INVALID: Wird auf TRUE gesetzt, wenn die Daten des Sensors nicht gelesen werden können.


Digital Kompass-Sensor (HT)

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Digital Kompass-Sensor (HT)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der LEGO MINDSTORMS 2.0 NXT Kompass-Sensor enthält einen magnetischen Digitalkompass, der das magnetische Feld der Erde misst und einen Steuerkurs-Winkel berechnet. Der Kompass-Sensor verbindet sich mit einem NXT Standardkabel zu einem NXT-Port und verwendet das digitale I2C Kommunikationsprotokoll. Der aktuelle Kurs wird auf die nächste ganze Gradzahl berechnet.

Der HiTechnic Kompass-Sensor wird, wie jeder andere magnetische Kompass auch, von lokalen magnetischen Störungen beeinflusst . Gegenstände aus Metall wie Motoren, Batterien und Leitungen können magnetische Störungen verursachen. Lokale magnetische Störungen können den Kompass zur Ausgabe eines Kurses veranlassen, der mehrere Grad vom aktuellen magnetischen Kurs abweicht. Dieser Effekt wird Kompass-Abweichung genannt. Um diese Abweichung zu korrigieren, hat der HiTechnic Kompass-Sensor eine eingebaute Kalibrierungsfunktion, die Abweichungen korrigiert und diese Werte im Kompass speichert.

Die Kalibrierung ist fakultativ und in der Regel im Normalbetrieb nicht erforderlich. Um die Notwendigkeit von Kalibrierung zu minimieren, montieren Sie den Kompass mindestens 10 bis 15 cm (4 - 6 Zoll) vom NXT und den NXT Motoren entfernt.

Um den Kompass im Programm zu kalibrieren:

  • Wählen Sie calibration mode aus.
  • Programmieren Sie Ihr NXT-Objekt so, dass es sich in einem sehr engen Kreis dreht (rotiert).
  • Es muss sich zwischen 1½- und 2-Mal (mehr als 360 Grade) drehen.
  • E muss eine volle Umdrehung in ungefähr 20 Sekunden vollführen.

Der Kompass wird die Kalibrierungseinstellungen beibehalten, bis eine andere Kalibrierung durchgeführt wird, auch wenn er abgesteckt wird.

  • PORT_x_VALUE: Aktueller Kurs in Grad.

    0: Norden

  • PORT_x_INVALID: Wird auf TRUE gesetzt, wenn die Daten des Sensors nicht gelesen werden können.
  • PORT_x_CAL: (Ausgabe) Kontrolliert den Kalibrierungsmodus.
    • TRUE: in Kalibrierungsmodus wechseln
    • FALSE: zum Mess-Modus wechseln.

    Hinweis: Im Kalibrierungsmodus liefert der Sensor ungültige Daten.


Andere Sensoren

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> NXT Kommunikation-Ports benutzen -> Feldbus -> Andere Sensoren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende weitere Variablen für Sensoren stehen zur Verfügung:

  • PORT_x_VALUE: Sensor-Wert, abhängig vom Sensor
    • Sound dB
    • Sound dBA
    • Ultrasonic: Entfernung in Zentimeter (cm)
    • Temperature: Temperatur in Zehntelgrad Celsius (°C/10)
  • PORT_x_INVALID:
    • TRUE: Sensor befindet sich im Fehlerzustand


Funktionen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Funktionen auswählen zu können, müssen sich diese im entsprechenden Ordner befinden. Kopieren Sie dazu den Ordner Mindstorms NXT aus dem Ordner HWDEF auf der DVD in den Ordner HWDEF Ihrer straton Installation.
Zum Beispiel: %ProgramData%\COPA-DATA\zenon700\straton\HWDEF\Mindstorms NXT

Folgende Funktionen stehen zur Verfügung:

  • BUTTONENABLE: straton übernimmt Kontrolle über NXT-Tasten.
  • BUTTONGET: Übermittelt Information, welche Taste gedrückt wurde.
  • DISPLAYERASE: Löscht Bildschirminhalt.
  • DISPLAYLINE: Zeichnet eine Linie.
  • DISPLAYPIXEL: Zeichnet ein Pixel.
  • DISPLAYSTRING: Schreibt eine Zeichenfolge.
  • SOUNDFREQUENCY: Gibt Töne aus.

Noch in diesem Kapitel

BUTTONENABLE

BUTTONGET

DISPLAYERASE

DISPLAYLINE

DISPLAYPIXEL

DISPLAYSTRING

SOUNDFREQUENCY


BUTTONENABLE

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen -> BUTTONENABLE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

BOOL BUTTONENABLE (BOOL ENABLE)

Bei Aufruf mit ENABLE und Status TRUE, wird die Kontrolle über die Tasten am NXT Objekt an straton übergeben. Die Zustände der Tasten können mit BUTTONGET ausgelesen werden-

Hinweise:

  • Das Menü System am NXT Objekt wird in diesem Fall deaktiviert.
  • Der Aufruf dieser Funktion ist nur möglich, wenn das Menü am NXT Objekt inaktiv ist.
  • Dieser Status kann unterbrochen werden, z. Beispiel durch einen Bluetooth Pairing-Dialog. In diesem Fall gibt die BUTTONGET den Wert -1 zurück.

Rückgabewert:

  • TRUE: Aktion wurde erfolgreich ausgeführt.


BUTTONGET

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen -> BUTTONGET

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

SINT BUTTONGET

Rückgabewerte:

  • -1: Tasten können von straton nicht gelesen werden. Das Menü System am NXT-Objekt ist aktiviert.
  • 0: Keine Taste gedrückt.
  • 1: Linke Taste gedrückt.
  • 2: Taste Eingabe (orange Taste) gedrückt.
  • 3: Rechte Taste gedrückt.
  • 4: Taste Verlassen (dunkelgraue Taste) gedrückt.


DISPLAYERASE

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen -> DISPLAYERASE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

BOOL DISPLAYERASE

Löscht den Bildschirminhalt.

Rückgabewert:

  • TRUE: Aktion wurde erfolgreich ausgeführt


DISPLAYLINE

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen -> DISPLAYLINE

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

BOOL DISPLAYLINE (USINT X1,USINT Y1,USINT X2, USINT Y2, BOOL C)

Zeichnet eine Linie vom Punkt X1,Y1 zum Punkt X2,Y2.

Werte für C:

  • TRUE: zeichnet Linie
  • FALSE: löscht Linie

Rückgabewert:

  • TRUE: Aktion wurde erfolgreich ausgeführt


DISPLAYPIXEL

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen -> DISPLAYPIXEL

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

BOOL DISPLAYPIXEL (USINT X, USINT Y, BOOL C)

Zeichnet einen Punkt mit den Koordinaten X,Y.

Werte für C:

  • TRUE: zeichnet Punkt
  • FALSE: löscht Punkt

Rückgabewert:

  • TRUE: Aktion wurde erfolgreich ausgeführt


DISPLAYSTRING

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen -> DISPLAYSTRING

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

BOOL DISPLAYSTRING(USINT X, USINT Y, STRING TEXT)

Schreibt eine Zeichenfolge, beginnend mit der angegebenen XY-Position.

Rückgabewert:

  • TRUE: Aktion wurde erfolgreich ausgeführt


SOUNDFREQUENCY

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> straton Anwendungen für NXT entwickeln -> Funktionen -> SOUNDFREQUENCY

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

BOOL SOUNDFREQUENCY(UDINT FREQ, UDINT DUR, USINT VOL)

Spielt einen Ton mit der angegebenen Frequenz in Hz während der definierten Dauer in Millisekunden. Die Lautstärke (VOL) wird in einer Bandbreite von 1 bis 4 angegeben. Sie wird begrenzt durch die im Menü Volume konfigurierte Maximallautstärke.

Rückgabewert:

  • TRUE: Aktion wurde erfolgreich ausgeführt


MINDSTORMS 2.0 Runtime mit zenon verbinden

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> MINDSTORMS 2.0 Runtime mit zenon verbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Erstellung eines neuen zenon Logic Projekts in zenon wird empfohlen, den stratonNG Treiber zu verwenden. Dieser unterstützt serielle Kommunikation.

Beim Erstellen eines neuen zenon Logic Projekts legen Sie im Dialog den Namen des Projekts und den verwendeten Treiber fest.

Wählen Sie aus der Dropdownliste STRATONNG.

Hinweis: Die Treiberauswahl kann nachträglich nicht mehr geändert werden.

stratonNG Treiber konfigurieren

Um den Treiber zu konfigurieren:

  1. wählen Sie im zenon Projektbaum den Knoten Variablen -> Treiber
  2. markieren Sie den stratonNG Treiber
    Anmerkung: dieser wird mit dem für das Projekt definierten Namen angezeigt, z.B. straton: mindstorms
  3. wählen Sie im Kontextmenü Treiberkonfiguration
  4. der Dialog für die Treiberkonfiguration wird geöffnet
  5. öffnen Sie die Registerkarte Connections

Um den Treiber zu bearbeiten:

  1. markieren Sie den Verbindungsnamen
  2. klicken Sie auf Edit
  3. konfigurieren Sie die Verbindung
  4. klicken Sie auf Save und dann OK

Konfiguration des Treibers für die Verbindung im Rahmen von LEGO MINDSTORMS 2.0:

Option

Beschreibung

Connection name

Muss dem Projektnamen entsprechen.

Unterscheidet sich der Name vom Projekt, führt das zu Fehlern bei der Verbindung mit dem Controller.

Adressing

Bei der Kommunikation mit straton NXT über USB oder Bluetooth genügt es, den Port ohne weitere Einstellungen zu setzen, z. B. COM5:

Primary IP address

Eingabe des COM-Ports.

Eingaben, die mit COM beginnen und mit einem Doppelpunkt enden, werden als COM-Ports interpretiert.

Achtung: Der Doppelpunkt (:) am Ende der Portdefinition muss vorhanden sein. Sonst kann die Verbindung nicht hergestellt werden.

Werden keine weiteren Parameter angegeben, wird die Standardkonfiguration des COM-Ports verwendet:

  • Baudrate: 115200 Bit/s
  • Parity: even
  • Data Bits: 8
  • Stop Bit: 1

Wenn Sie die Kommunikationsparamter anpassen möchten, fügen Sie diese nach dem Doppelpunkt, getrennt durch Kommata, ein. Die Reihenfolge:

  • Baudrate in bits/s
  • Parity: N (none), E (even), O (odd), M (mark) and S (space)
  • Data Bits
  • Stop Bit

Zum Beispiel: COM5:19200,N,8,1

Einschränkungen: Wenn ein COM-Port angegeben wird, dann können nicht verwendet werden:

  • Event-Connection
  • Mehrfachverbindungen (mehr als eine Verbindung mit einem Treiber)

Die Dokumentation dieser Einstellungen betrifft die Kommunikation im Rahmen von LEGO MINDSTORMS 2.0. Details zur allgemeinen Konfiguration des stratonNG Treibers finden Sie in der Online-Hilfe (F1) im Kapitel stratonNG.


Fragen und Antworten

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Fragen und Antworten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die häufigsten Fragen zu Installation und Betrieb von LEGO MINDSTORM mit straton und dem zenon Science Package.

Frage | Antwort
Warum bekomme ich eine Fehlermeldung bei der Installation? | Wahrscheinlich befindet sich bereits eine zenon Installation am System. Benutzen Sie die vorhandene Installation. Details: Fehlermeldung bei der Installation des zenon Science Packages.
Wie wechsle ich zurück zur originalen LEGO Firmware? | Die Rückkehr entspricht dem Vorgehen wie beim Installieren der straton Firmware, wenn bereits andere Firmware vorhanden ist. Details: Original LEGO Firmware aktivieren.
Was mache ich, wenn der LEGO Firmware Loader den Controller nicht findet? | Wechseln Sie den USB-Port oder installieren Sie dessen Treiber neu. Details: LEGO Firmware Loader findet Controller nicht.
Was mache ich, wenn der zenon Logic Workbench Treiber nicht mit meinem Controller kommuniziert? | Das kann mehrere Ursachen haben. Überprüfen Sie die Einstellungen und ob alle Geräte online sind. Details: zenon Logic Workbench Treiber kommuniziert nicht mit dem Controller
Was mache ich, wenn der stratonNG Treiber nicht mit meinem Controller kommuniziert? | Das kann mehrere Ursachen haben. Überprüfen Sie die Kommunikations-Parameter, Runtime und das Projekt. Details: stratonNG Treiber kommuniziert nicht mit dem Controller.

Weitere Fragen und Antworten finden Sie auch im COPA-DATA Anwenderforum: www.copadata.com/forums/.

Noch in diesem Kapitel

Fehlermeldung bei der Installation des zenon Science Packages

Original LEGO Firmware aktivieren

LEGO Firmware Loader findet Controller nicht

zenon Logic Workbench Treiber kommuniziert nicht mit dem Controller

stratonNG Treiber kommuniziert nicht mit dem Controller


Fehlermeldung bei der Installation des zenon Science Packages

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Fragen und Antworten -> Fehlermeldung bei der Installation des zenon Science Packages

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie erhalten bei der Installation des zenonscience Package eine Fehlermeldung, die auf eine bereits existierende Installation verweist.

Auf Ihrem System wurde diese Version von zenon bereits installiert. Sie müssen zenon nicht mehr installieren und können die vorhandene Version verwenden. Importieren Sie die Demo-Projekte von der DVD und fahren Sie mit dem Punkt Firmware installieren fort.


Original LEGO Firmware aktivieren

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Fragen und Antworten -> Original LEGO Firmware aktivieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Befindet sich bereits Firmware, die nicht von LEGO stammt, auf dem Controller, muss dieser in den Firmware-Load-Modus versetzt werden, um andere Firmware installieren zu können. Dieser Modus wird auch benötigt, wenn die straton Firmware upgedatet oder wieder LEGO Firmware geladen werden soll. Um den Controller in den Firmware-Load-Modus zu versetzen:

  1. Drücken Sie gleichzeitig mindestens 5 Sekunden lang bis Sie ein leises Klicken hören
    • die orange Starttaste und
    • den Rest-Knopf auf der Geräüterückseite.
      Den Rest-Knopf erreichen Sie am besten mit einem spitzen Gegenstand.

  2. Schalten Sie den NXT Controller durch Drücken der orangefarbenen Taste ein.

  3. Der NXT Controller startet im Firmware-Load-Modus . Sie hören ein regelmäßiges Geräusch.
  4. Starten Sie den Download der gewünschten Firmware.
    Dazu muss eine Verbindung per USB oder Bluetooth hergestellt werden. Für die USB-Verbindung zu zenon/straton wird der COPA-DATA Treiber benötigt.

attention Achtung

Der Firmware-Load-Modus kann nur mit dem Download einer Firmware beendet werden.

Download der LEGO-Firmware:

  1. Verbinden Sie den Controller per USB mit dem PC.
  2. Starten Sie die LEGO MINDSTOMS NXT 2.0 Software.
  3. Wählen Sie im Menü Tools den Eintrag Update NXT Firmware.
  4. Die Original LEGO MINDSTOMS NXT Firmware ist vorausgewählt.
  5. Klicken Sie auf die Schaltfläche Download.
  6. Der Controller startet mit der Original LEGO Firmware neu.


LEGO Firmware Loader findet Controller nicht

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Fragen und Antworten -> LEGO Firmware Loader findet Controller nicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn der LEGO Firmware Loader den Controller nicht findet verbinden Sie das USB-Kabel mit einem anderen USB-Port. Damit wird der USB-Treiber für den Firmware Loader Modus installiert.

Wenn das Problem damit nicht gelöst wird, deinstallieren Sie den Treiber. Dazu:

  1. Öffnen Sie während der Controller verbunden ist den Gerätemanager in der Systemsteuerung.
  2. Wählen Sie den LEGO MINDSTORMS NXT Firmware Update Mode Treiber aus.
  3. Führen Sie einen Rechtsklick darauf aus.

  4. Wählen Sie im Kontextmenü Deinstallieren.
  5. Entfernen Sie das USB-Kabel vom LEGO MINDSTORMS 2.0 Controller und verbinden Sie es erneut.
  6. Der Treiber wird automatisch neu installiert.


zenon Logic Workbench Treiber kommuniziert nicht mit dem Controller

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Fragen und Antworten -> zenon Logic Workbench Treiber kommuniziert nicht mit dem Controller

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Kommunikation zum Controller ist eine Punkt-zu-Punkt Kommunikation über einen virtuellen seriellen Port. Es kann immer nur eine Anwendung zur gleichen Zeit verbunden werden.

Wenn die Kommunikation fehlschlägt, können mehrere Gründe dafür verantwortlich sein. Die häufigsten sind:

  1. Der stratonNG driver und zenon sind noch online.
  2. Die Einstellungen für den COM-Port sind falsch. Setzen Sie im Menü Communication parameters die richtigen Einstellungen für den COM-Port.
  3. Die Verbindungseinstellungen für den Controller sind nicht auf das richtige Medium gesetzt (USB oder Bluetooth). Setzen Sie diese auf die aktuell verwendete Verbindung.


stratonNG Treiber kommuniziert nicht mit dem Controller

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Fragen und Antworten -> stratonNG Treiber kommuniziert nicht mit dem Controller

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Kommunikation zum Controller ist eine Punkt-zu-Punkt Kommunikation über einen virtuellen seriellen Port. Es kann immer nur eine Anwendung zur gleichen Zeit verbunden werden.

Wenn die Kommunikation fehlschlägt, können mehrere Gründe dafür verantwortlich sein. Die häufigsten sind:

  1. Die zenon Logic Workbench ist noch online.
  2. Die Einstellungen für den COM-Port sind falsch.
  3. Die straton Runtime wurde am LEGO MINDSTORMS 2.0 Controller nicht gestartet.
    Um die Runtime zu starten:
    1. Drücken Sie die orange Taste.
    2. Sobald Sie den Eintrag straton sehen, drücken Sie die orange Teste erneut.
    3. Wählen Sie Start und drücken Sie die orange Taste.

    Dass die Runtime läuft, erkennen Sie daran, dass sich das quadratische Symbol neben dem Batteriestatus dreht.

  4. Das straton Projekt wurde nicht auf den Controller heruntergeladen.
    Wurde ein Projekt heruntergeladen, prüfen Sie, ob es das korrekte Projekt ist.
  5. Die Symbolnamen der Variablen wurden nicht aktiviert.
  6. Der Verbindungsname des stratonNG Treibers ist nicht ident mit dem Namen des zenon Logic Projekts.
  7. Die Verbindungseinstellungen für den Controller sind nicht auf das richtige Medium gesetzt (USB oder Bluetooth). Setzen Sie diese auf die aktuell verwendete Verbindung.


Verwendung komplexer Variablen

Handbuch -> zenon Science Package for Lego MINDSTORMS 2.0 -> Verwendung komplexer Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Abschnitt sehen Sie , wie Sie einen Motor mit komplexen Variablen steuern.

info Info

Die Verwendung komplexer Variablen wird nur erfahrenen Anwendern empfohlen!

Mit zusätzlicher Programmierung können Sie die NXT Motoren veranlassen, sich um einem vorgegeben Winkel zu bewegen. Das wird benötigt, um sehr präzise Bewegungen zu projektieren. Für die Projektierung:

  1. Erstellen Sie alle Variablen mit einem Rechtsklick auf den Port und Auswahl von Create advanced variables im Kontextmenü.

  2. Sie erhalten 15 Variablen.

Die für Sie relevanten Variablen sind:

  • PORT_n_FLAGS
    • Bit-Maske, von welchen Variablen geschrieben werden soll.
  • PORT_n_TACHOLIMIT
    • Das relative Limit dafür, mit wie vielen Grad, der Motor drehen soll.
    • Achtung: Dieser Wert ist immer positiv, auch wenn der Motor rückwärts dreht.
  • PORT_n_MODE
    • Modus, den der Motor benutzen soll.
    • Meint nicht vorwärts oder rückwärts oder steigend und sinkende Geschwindigkeit, sondern interne Kommandos.
  • PORT_n_SPEED
    • Geschwindigkeit des Motors.
    • Bandbreite: -100 (rückwärts) bis 100 (vorwärts)
  • PORT_n_RUNSTATE
    • Wie der Motor laufen soll.
    • Physikalische Eigenschaften (set speed instantly, Ramp UP or Ramp DOWN)

attention Achtung

Alle Variablen müssen in einem Zyklus geschrieben werden!

Das bedeutet: Die Variablen können nicht von der zenon Logic Workbench aus forciert werden.

Struktur

Intern verwendet NXT ein Struktur. Alle Variablen dieser Struktur werden per Rechtsklick auf den Port und Auswahl von Create advanced variables im Kontextmenü erzeugt. Diese Struktur wird in jedem Zyklus geschrieben. Aber, da PORT_n_FLAGS von straton nach jedem Zyklus auf 0 gesetzt wird, passiert nichts weiter.

Die Variable PORT_n_Flags ist eine Bit-Maske für jene Variablen, die für die Struktur, die straton abfragt, in diesem Zyklus relevant sind. Um einen Move n degree Befehl abzusetzen, setzen Sie die PORT_n_FLAGS Variable auf eine Bit-Maske [ST]:

Damit haben sie definiert, dass Sie Daten für PORT_n_MODE, PORT_n_SPEED und PORT_n_TACHOLIMIT bereit stellen. Welche Werte müssen diese Variablen haben?

Sie benötigen auch für PORT_n_MODE eine Bit-Maske. Grundsätzlich müssen Sie immer beide setzen, wenn sie eine Vorwärtsbewegung erzeugen wollen[ST]:

Sie haben nun die Bit-Maske gesetzt, welche Variablen upgedatet werden sollen und einige interne Flag-Paramter.

Jetzt kommt der für uns interessantere Teil: Der Drehmodus des Motors - PORT_n_RUNSTATE. Hier steht Ihnen keine Bit-Maske zur Verfügung. Die Werte sind exklusiv.

Und schließlich: PORT_n_SPEED und PORT_n_TACHOLIMIT:

attention Achtung

Stellen Sie unbedingt sicher, dass Sie diese Werte nicht in jedem Zyklus schreiben. Sonst wird das Dreh-Kommando in jedem Zyklus ausgeführt. Sie müssen aber dennoch alle Variablen in jedem Zyklus schreiben. Blockieren Sie das Schreiben dieser Werte.


zenon Webserver und zenon Webserver Pro

Handbuch -> zenon Webserver und zenon Webserver Pro

Der zenon Webserver bringt Projekte 1:1 ins Internet und Intranet. So können Produktionsdaten unternehmens- oder konzernweit veröffentlicht werden. Für den Transfer sind keinerlei Projektanpassungen erforderlich.

info Info

zenon Webserver kommunizieren wahlweise über IPv4 oder IPv6. IPv6 ist erst ab Version 7 möglich.

Der zenon Webserver steht in drei Ausprägungen zur Verfügung:

  • zenon Webserver: reine Beobachtungsfunktionalität.
  • zenon Webserver Pro: komplette Bedien- und Beobachtungsfunktionalität. Über das Web kann direkt auf Prozesse eingegriffen werden.
  • zenon Webserver Pro Light: eingeschränkte Funktionalität des zenon Webservers PRO für die Verwendung mit zenon Operator.

Unterschiede siehe Abschnitt Versionen.

tutorial Lizenzinformation

zenon Webserver, Webserver Pro und Webserver Pro Light sind lizenzpflichtig. Details siehe Abschnitt Lizenzierung.

Noch in diesem Kapitel

Versionen

Grundlagen

Generelle Einschränkungen

Lizenzierung

zenon Webserver (Pro)

zenon Webclient

VSTA mit Webclient, Webserver und Webserver Pro

Projektieren im Editor

Erstellen der HTML-Seite für den Projekteinstieg

Fehlerbehandlung

zenon Webserver in eine Internetumgebung einbinden


Versionen

Handbuch -> zenon Webserver und zenon Webserver Pro -> Versionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Webserver unterscheiden sich im Funktionsumfang:

  • zenonWebserver Pro:
    Ermöglicht aktive Bedienhandlungen mit zenon Supervisor.
    Start und Betrieb unter Windows CE unterliegen bestimmten Einschränkungen.
  • zenonWebserver Pro Light:
    Ermöglicht aktive Bedienhandlungen mit zenon Operator und zenon Supervisor. Unterschiede zum zenon Webserver Pro:
    • Der Runtimeserver, zu dem sich die zenon Webclients verbinden, muss der gleiche Rechner sein, auf dem zenon Webserver Pro Light läuft.
      Für die Prüfung wird der Computername verwendet, Domains werden nicht berücksichtigt
      Achtung: Bei Projekten mit Redundanz muss der zenon Webserver Pro Light redundant ausgeführt werden - eine Instanz am Server und eine am Standby-Server.
    • Maximal 3 Clients.
    • Keine Unterstützung für verschlüsselten Netzwerkverkehr. Bei verschlüsselter Kommunikation startet er nicht bzw. beendet er sich selbst. Die Überprüfung auf Verschlüsselung erfolgt zur Runtime alle 60 Sekunden.
    • HTTP Tunnelling wird nicht unterstützt.
  • zenon Webserver:
    Fungiert nur als Viewer. Aktive Bedienaktionen wie Sollwert absetzen, Rezept ausführen, PFS Einstellungen speichern usw. sind nicht möglich.
    Ausnahme: Ab Version 6.22 SP1 Build5 kann auch mit dem zenon Webserver folgende aktive Bedienhandlung durchgeführt werden:
    • Interne Variablen (Berechnung lokal) auf dem Webclient per Funktion Sollwert absetzen beschrieben werden.
      Hinweis: Das Beschreiben per Elementeingabe oder VBA ist nicht möglich.

Beispiel Einsatz zenon Webserver Pro Light

Beim Start des zenon Webservers definiert die Seriennummer, ob ein Webserver, ein Webserver Pro oder ein Webserver Pro Light gestartet wird. Mit dem Start eines Webservers Pro Light werden dessen Einschränkungen aktiv:

  1. HTTP Tunnelling steht nicht zur Verfügung.
  2. Es wird regelmäßig überprüft, ob die Netzwerkverschlüsselung aktiv ist. Bei aktiver Verschlüsselung wird der Webserver Pro Light beendet.
  3. Verbindungen werden nur dann hergestellt, wenn der Computername des Ziels (Runtime-Server) identisch mit dem Computernamen des Webservers ist.
    1. Ein Projekt läuft mit Server (Rechner A) und Standby-Server (Rechner B).
    2. Auf Rechner A wird der zenon Webserver PRO Light gestartet.
    3. Ein Client verbindet sich über den Webserver PRO Light zum Runtime-Server.
    4. Die Runtime auf Rechner A stürzt ab. Rechne rB übernimmt als Standby-Server.
    5. Der Client versucht, auf den Standby-Server Rechner B umzuschalten.
    6. Da der Web Server mit Lizenz für Webserver PRO Light läuft, lehnt dieser die Verbindung vom Webclient zum Rechner B ab. Der Web Client ist offline.


Grundlagen

Handbuch -> zenon Webserver und zenon Webserver Pro -> Grundlagen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Webclient zeigt die Runtime in einem Browser so an, wie sie auch ein normaler Client mit zenon anzeigen würde. Dazu benötigt er einen zenon Webserver und einen Runtimeserver.

Definitionen

  • zenon Webclient

    Der zenon Webclient ist ein Programm, das in einem Standard Webbrowser läuft und ein Projekt darstellt. Er verbindet sich über den zenon Webserver mit einem Runtime Server. Er zeigt das Projekt des Runtime Servers so, wie es auch ein normaler Client anzeigen würde. Einziger Unterschied: Beim zenon Webclient erfolgt die Darstellung in einem Browser.

    Hinweis: Der zenon Webclient stellt immer die Eigenschaften der zenon Energy Edition Lizenz zur Verfügung. Beim Start wird jedoch der normale Startbildschirm angezeigt.

  • Runtime Server

    Der Runtime Server ist jener Rechner, auf dem das Projekt als Serverprojekt läuft. Der Runtime Server hat die gesamte Datenhoheit über alle Daten: Projektierungsdaten, online Daten, historische Daten.

  • zenon Webserver

    Der zenon Webserver ist ein Gateway (Proxy-Server), der folgende Aufgaben erfüllt:

    • Datenschnittstelle (TCP/IP Portumsetzung) zwischen dem Runtime Server und dem Webclient.
    • Überprüfung der Lizenz und Überprüfung der Anzahl der mit dem zenon Webserver gleichzeitig verbundenen Clients.
  • Publishingdienst

    Der Publishingdienst ist ein Standard HTTP Webserver von einem Dritthersteller. Dieser ist notwendig, damit die Projekteinstiegsseite veröffentlicht wird. Für den eigentlichen zenon Webclient-Betrieb ist dieser Dienst nicht erforderlich. Der zenon Webclient greift nicht auf den Publishingdienst zu. Zur klaren Unterscheidung vom zenon Webserver wird dieser Dienst nicht als Webserver, sondern immer als Publishingdienst bezeichnet.
    Achtung: Der Publishingdienst muss im Webbrowser zu den Vertrauenswürdigen Seiten hinzugefügt werden.

info Info

Bei kleinen Projekten können der Runtimeserver, der zenon Webserver und der Publishingdienst auf ein und demselben Rechner betrieben werden.

Der zenon Webclient und der Runtime Server müssen immer auf unterschiedlichen Rechner betrieben werden.


Generelle Einschränkungen

Handbuch -> zenon Webserver und zenon Webserver Pro -> Generelle Einschränkungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Projekte, die über einen zenon Webclient bedient werden, weisen folgende Einschränkungen auf:

  • Alarme:
    Das Quittieren von Alarmen ist nur bei Verwendung des zenon Webserver Pro möglich.
  • Archive:

    Archive können weder gelesen noch verändert oder gespeichert werden.

  • Benutzerverwaltung

    AD und ADAM/ADLDS funktionieren mit bestimmten Einschränkungen(wie auch auf Standard-Clients):
    AD: die Rechner müssen sich in der gleichen Domäne befinden
    ADAM/ADLDS: der Webclient benötigt eine physikalische Verbindung (plus offener Port) zum Webserver und zum ADAM/ADLDS Server

  • Bilder:
    • Das Bild vom Typ Archiv-Nachbearbeitung ist nicht verfügbar.
  • Drucken:

    Vor dem ersten Drucken auf dem zenon Webclient muss die Funktion Drucker auswählen ausgeführt werden. Hier können die Drucker für den Client definiert werden. Diese Einstellungen werden in der zenon6.ini gespeichert, sodass dieser Vorgang nicht mit jedem neuen Druckauftrag neu ausgeführt werden muss.

  • IPA:

    Das Modul Industrial Performance Analyzer (IPA) ist nur auf zenon Webclients in einem Intranet verfügbar, da über das Internet keine Verbindung zur Datenbank hergestellt werden kann. Bei einer Verbindung im Intranet müssen die Datenbank-Berechtigungen beachtet werden, damit ein Remote-Rechner in Form eines zenon Webclients auf diese Datenbank zugreifen kann.

  • Menüs

    Im zenon Webclient werden Hauptmenüs nicht angezeigt.

  • Monitor Verwaltung:

    Die Monitor Verwaltung funktioniert nur eingeschränkt. So sind z.B. Auflösung anpassen und Scrollbalken nicht verfügbar.

  • PFS:

    Der Production and Facility Scheduler (PFS) ist nur ab Version 6.01 verfügbar.

  • Statusinformationen:

    Die Statusinformationen, die durch ein gedrückt Halten der rechten Maustaste angezeigt werden, sind nur teilweise verfügbar.

  • Tastenkombinationen:

    Die Tastenkombinationen auf Buttons wie z.B. F3 sind nicht verfügbar.

  • VBA:

    VBA ist nur verfügbar, wenn VBA auf dem zenon Webclient manuell installiert wurde. Für detaillierte Informationen dazu wenden Sie sich an den zenon Support.

  • VSTA: Webserver und Webclient unterstützen VSTA in unterschiedlicher Ausprägung.

    Generell unterstützt der Webclient VSTA, ausgenommen:

    • debuggen
    • Funktion VSTA Editor Anzeigen
    • kompilieren

    Details siehe Kapitel VSTA mit Webclient, Webserver und Webserver Pro.

Zusätzliche Einschränkungen für Windows CE:

  • Es können maximal drei zenon Webclients gleichzeitig mit einer CE Runtime verbunden sein.
  • Der zenon Webserver muss auf demselben Gerät laufen wie die CE Runtime, mit der er verbunden sein soll. Eine Verbindung zu einer CE Runtime auf einem anderen Gerät ist nicht möglich.

Die Lizenzierung des zenon Webservers für CE erfolgt über die Remote Lizenzierung.

Browser

attention Achtung

VBA/VSTA und Data Execution Prevention

Das Betriebssystem verhindert über die Funktion Data Execution Prevention (DEP) auch, dass VBA-Code im Browser ausgeführt wird.

Microsoft Internet Explorer 8 und 9:
Der Microsoft Internet Explorer bietet ab Version 8 die Möglichkeit, DEP für den Browser zu deaktivieren.

  • navigieren Sie zu Extras -> Internetoptionen -> Erweitert -> Sicherheit
  • deaktivieren Sie die Option Speicherschutz aktivieren, um das Risiko von Onlineangriffen zu verringern

Andere Browser

DEP muss komplett abgeschaltet werden, da der Browserprozess nicht explizit ausgenommen werden kann. Dies wird aus Sicherheitsgründen nicht empfohlen.

Generelle Empfehlung: Verwenden Sie VSTA statt VBA.


Lizenzierung

Handbuch -> zenon Webserver und zenon Webserver Pro -> Lizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Durch die Lizenzierung wird festgelegt:

  • in welcher >Ausprägung der zenon Webserver läuft:
    • zenon Webserver Standard
    • zenon Webserver Pro
    • zenon Webserver Pro Light
  • Anzahl der parallel möglichen zenon Webclient Verbindungen (Concurrent Use Lizenz)

Hinweis: Ohne gültige Lizenzierung läuft der zenon Webserver im Demo-Modus. Dabei gelten folgende Einschränkungen:

  • der zenon Webserver kann nur manuell gestartet werden
  • die Laufzeit ist auf 30 Minuten beschränkt
  • die Anzahl der möglichen Clients ist auf 2 beschränkt

Um von Demo-Modus auf eine gültige Lizenz umzuschalten, stoppen Sie den zenon Webserver und geben Sie in der Registerkarte Licence eine gültige Lizenznummer ein. Starten Sie dann den Webserver manuell neu.

zenon Operator und Windows CE

Für den zenon Operator steht der zenon Webserver Pro Light zur Verfügung.

Für Windows CE steht ein in die Runtime eingebauter zenon Webserver Pro zur Verfügung, d.h. die Runtime muss gestartet werden, damit der zenon Webserver Pro läuft. Dieser ist bedingt durch die Plattform in seiner Funktionalität eingeschränkt. Die Lizenzierung erfolgt über den Remote Transport im Editor mittels Remote Lizenzierung.

Lizenz registrieren

Um den zenon Werbserver zu lizenzieren:

  1. öffnen Sie Start -> Alle Programme -> COPA-DATA -> Licensing 7.00

    oder:

    starten Sie den Webserver über Systemsteuerung -> zenon Webserver

  2. der Dialog zur Eingabe der Lizenzdaten öffnet sich
    • wählen Sie Webserver
  3. geben Sie Seriennummer und AKtivierungsnummer ein

    Die Daten dazu finden Sie:

    • auf Ihrem Lizenzsschein
    • auf dem Lizenzaufkleber
    • in der Lizenzdatei License.txt

      Pfad Vista/7: C:\Users\Public\Documents\zenon_Projects\

      Pfad XP: C:\Dokumente und Einstellungen/All Users/Anwendungsdaten/COPA-DATA/zenon700

    Hinweis: Achten Sie bei der Eingabe auf Groß-/Kleinschreibung!

  4. starten Sie den zenon Webserver auf der Registerkarte State neu
  5. nach dem Neustart nutzen Sie den zenon Webserver mit der eingegebenen Lizenz

Dialog zur Lizenzierung

Parameter | Beschreibung
Editor/Runtime | Aktiv: Lizenz gilt für den zenon Editor und/oder die zenon Runtime.
Webserver | Aktiv: Lizenz gilt für den zenon Webserver.
Analyzer | Aktiv: Lizenz gilt für den zenon Analyzer.
Seriennummer | Seriennummer der Lizenz. Sollte bereits eine Lizenz vorhanden sein, wird deren Lizenznummer hier angezeigt.
Aktivierungsnummer | Aktivierungsnummer der Lizenz. Sollte bereits eine Lizenz vorhanden sein, wird deren Aktivierungsnummer hier angezeigt.
OK | Daten übernehmen und zenon beim nächstern Neustart mit dieser Lizenz starten.
Abbrechen | Eingaben verwerfen und zenon mit bisheriger oder ohne Lizenz nutzen.
Softlizenz anfordern | Öffnet Assistent zur Anforderung einer Softlizenz.

Alternativ:

  1. Starten Sie den Webserver über Systemsteuerung -> zenon Webserver.
  2. Geben Sie auf der Registerkarte Licence im zenon Webserver die Seriennummer und die Aktivierungsnummer ein, die auf dem Lizenzschein ausgewiesen sind.

  3. Klicken Sie auf Save um die beiden Nummern zu speichern.
  4. Starten Sie den zenon Webserver auf der Registerkarte State neu.

attention Achtung

Beim Neustart verlieren alle angeschlossenen zenon Webclients die Verbindung. Die zenon Webclients führen nach der eingestellten Timeoutzeit einen automatischen Reconnect durch.

Hinweis: Lizenznummer und AKtivierungsnummer werden in die zenSrv.ini eingetragen.

Noch in diesem Kapitel

Donglelizenzierung

Softlizenzierung


Donglelizenzierung

Handbuch -> zenon Webserver und zenon Webserver Pro -> Lizenzierung -> Donglelizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

zenon unterstützt zur Lizenzierung per Dongle die Systeme WIBU-Key und Codemeter. Details dazu lesen Sie im Handbuch Lizenzierung im Abschnitt Donglelizenzierung.

Die Lizenzierung über einen Dongle erfolgt über:

  • rechnerbezogenen Dongle oder
  • Netzwerkdongle

Rechnerbezogener Dongle

Rechnerbezogenen Dongle einsetzen:

  1. Sie bekommen einen Dongle und einen Lizenzschein mit Seriennummer und Aktivierungsnummer.
  2. Schließen Sie den Dongle an den selben Rechner an, auf dem Sie den zenon Webserver installiert haben.
  3. Registrieren Sie die Lizenz im System.

Netzwerkdongle

Alternativ zum Dongle auf dem selben Rechner können Sie auch den zentralen COPA-DATA Netzwerkdongle verwenden. Dieser kann an einem beliebigen Rechner im Netzwerk stecken. Die Lizenzierung erfolgt analog der Lizenzierung des rechnerbezogenen Dongles.

info Info

Verliert ein mit Codemeter lizenzierter zenon Webserver die Verbindung zum Dongle, wird der Webserver beendet.


Softlizenzierung

Handbuch -> zenon Webserver und zenon Webserver Pro -> Lizenzierung -> Softlizenzierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für eine Softlizenzierung:

  1. Starten Sie das Programm Web-Server-Licensing.

  2. Klicken Sie auf die Schaltfläche Lizenzanforderung für Softlizenzierung.
  3. Das Formular für Ihre Lizenzdaten wird geöffnet.

  4. Füllen Sie alle Felder aus und klicken Sie auf Weiter.
  5. Das Programm erzeugt einen Lizenzanforderungsschein mit der für Ihren Rechner gültigen Lizenznummer.

  6. Schicken Sie Ihre Lizenzanforderung an Ihren Vertriebspartner:
    1. per Klick auf Senden über E-Mail
    2. per Klick auf Drucken als Ausdruck oder Fax

      Die Lizenznummer ist auf dem Lizenzschein ebenfalls enthalten und muss mit der Ihres Rechners übereinstimmen.

  7. Eine Infobox fasst den Vorgang zusammen.

  8. Sobald Sie Ihre Lizenzdaten erhalten haben, registrieren Sie die Lizenz im System


zenon Webserver (Pro)

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Verbindung zwischen dem zenon Webclient und dem Runtime Server herzustellen, ist der zenon Webserver notwendig. Dieser kann auf jedem beliebigen Rechner im Netzwerk installiert werden, der eine physikalische Netzwerkverbindung zum Runtime Server hat. Der Betrieb des zenon Webclients und des Runtime Servers auf dem selben Rechner ist nicht möglich. Der zenon Webserver kann allerdings auch auf dem selben Rechner wie der Runtime Server installiert sein.

info Info

Eine komplette Deinstallation des Webservers ist nur möglich, wenn der Webserver nicht läuft.

Informationen zum Redundanzbetrieb finden Sie im Kapitel Redundanzbetrieb.

Noch in diesem Kapitel

Anleitung: vorbereiten - installieren - starten


Anleitung: vorbereiten - installieren - starten

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den zenon Webserver (Pro) einzusetzen, sind folgende Schritte notwendig:

  1. Netzwerk und Server in Projekteinstellung
  2. WWW-Publishingdienst am PC installieren
  3. zenon Webserver installieren
  4. zenon Webserver in Betrieb nehmen
  5. zenon Webclient installieren und starten

1. Projekteinstellung

Das Projekt, das über den zenon Webserver gestartet werden soll, benötigt folgende Grundeinstellungen im zenon Editor:

  • Projekteigenschaft -> Netzwerk -> Netzwerk aktiv aktivieren.

    Interne ID: Anleitung: vorbereiten - installieren - starten

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

    Interne ID: Anleitung: vorbereiten - installieren - starten

    Netzwerk

    Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Projekteigenschaft -> Netzwerk -> Server -> Rechner (Name) mit der Runtime eintragen.

    Interne ID: Anleitung: vorbereiten - installieren - starten

    Server

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

    Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

2. WWW-Publishingdienst am PC installieren

Der Publishingdienst ist nötig, um die Projekteinstiegsseite zu veröffentlichen. Sie können dazu beliebige Systeme verwenden. Um den Windows eigenen Publishingdienst zu benutzen:

  1. Öffnen Sie in der Systemsteuerung ->Programme und Funktionen -> Windows-Funktionen aktivieren oder deaktivieren.
  2. Navigieren Sie zu Internetinformationsdienste -> WWW-Dienste.
  3. Aktivieren Sie alle WWW-Dienste.
  4. Fügen Sie den Publishingdienst im Webbrowser zu Vertrauenswürdige Seiten hinzu.

Informationen von Microsoft zu diesem Thema finden Sie auf: http://technet.microsoft.com/de-de/library/cc782498(WS.10).aspx

Wurden die Dienste erfolgreich aktiviert, muss folgender Ordner im Stammverzeichnis vorhanden sein:
C:\inetpub\wwwroot

info Info

Wurde der zenon Webserver bereits vorher installiert, muss der dabei angelegte Ordner C:\Program Files \COPA-DATA\zenon WEB Server\zenon nach C:\inetpub\wwwroot verschoben werden.

3. Web-Server installieren

Der zenon Webserver wird auf dem Rechner mit den aktivierten WWW-Diensten installiert.

  1. Starten Sie die Installation von der DVD und folgen Sie den Anweisungen des Installationsassitenten. Details zur Installation finden Sie im Kapitel Installation zenon Webserver von DVD.
  2. Konfigurieren Sie die Einstellungen des Webservers:
    • ab zenon 6.20 in der Datei global_vars.js im Ordner C:\inetpub\wwwroot\zenon\config
    • bis zenon 6.20 in der Datei project.html im Ordner

4. Web-Server in Betrieb nehmen

Um den zenon Webserver in Betrieb zu nehmen:

  1. stellen Sie sicher, dass die WWW-Publishingdienste gestartet wurden und die Einstiegsseite bereit steht
  2. starten Sie das Runtime-Projekt am Rechner
  3. starten Sie den zenon Webserver

    Details zu Start und Einstellungen des zenon Webservers lesen Sie im Kapitel Start und Servereinstellungen.

5. Web-Client installieren und starten

Um die Runtime per Browser zu beobachten oder zu bedienen, benötigen Sie auf dem entsprechenden rechner einen zenon Webclient.

  1. Installieren Sie den zenon Webclient.

    Details zum Webclient finden Sie im Kapitel zenon Webclient.

  2. Starten Sie den Microsoft Internet-Explorer und verbinden Sie den Webclient mit dem Rechner, auf dem der zenon Webserver läuft.

    Eventuell muss diese Seite als "Vertrauenswürdige Seite" in der Internet-Explorer Einstellung unter Extras -> Internetoptionen -> Sicherheit hinzugefügt werden.

  3. Die Anzahl der gleichzeitig einsetzbaren Webclients hängt von Ihrer Lizenz ab.

attention Achtung

VBA/VSTA und Data Execution Prevention

Das Betriebssystem verhindert über die Funktion Data Execution Prevention (DEP) auch, dass VBA-Code im Browser ausgeführt wird.

Microsoft Internet Explorer 8 und 9:
Der Microsoft Internet Explorer bietet ab Version 8 die Möglichkeit, DEP für den Browser zu deaktivieren.

  • navigieren Sie zu Extras -> Internetoptionen -> Erweitert -> Sicherheit
  • deaktivieren Sie die Option Speicherschutz aktivieren, um das Risiko von Onlineangriffen zu verringern

Andere Browser

DEP muss komplett abgeschaltet werden, da der Browserprozess nicht explizit ausgenommen werden kann. Dies wird aus Sicherheitsgründen nicht empfohlen.

Generelle Empfehlung: Verwenden Sie VSTA statt VBA.

Einschränkungen für den den zenon Webserver und zenon Webclient finden Sie im Kapitel Generelle Einschränkungen.

Noch in diesem Kapitel

Installation zenon Webserver von DVD

Benutzerrechte für Installation

Start und Servereinstellungen

Einstellungen in global_vars.js

Einstellungen in projekt.html

Dateiablage Runtime-Dateien

Redundanzbetrieb


Installation zenon Webserver von DVD

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Installation zenon Webserver von DVD

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den zenon Webserver oder Webserver Pro zu installieren:

  1. Aktivieren Sie die WWW-Dienste auf dem Rechner.

    Der Ordner C:\inetpub\wwwroot muss existieren.

  2. Legen Sie die zenon DVD in das Laufwerk ein, der Startbildschirm wird angezeigt.

    Falls Sie Autostart von CD/DVD deaktiviert haben, führen Sie die start.exe auf der CD aus.

  3. Wählen Sie zenon Webserver aus.
  4. Folgen Sie der Installationsroutine.
  5. Starten Sie den Computer neu.

Die Setup-Dateien für den Webclient finden Sie nach der Installation in Unterverzeichnissen des Webserver-Installationspfades (xxx steht für die jeweilige Version von zenon), z.B.: C:/Programme/COPA-DATA/zenonWebServer/zenon/controlversions/Versionxxx/zenon_WEB_Client_Setup_GERMAN.EXE
oder

C:/Inetpub/wwwroot/zenon/controlversions/Versionxxx/zenon_WEB_Client_Setup_GERMAN.EXE

Es werden auch die Beispiel-Webseiten (index*.html und init*.html) mitinstalliert. Diese sind im Unterverzeichnis zenon des Webserver-Installationspfades zu finden, z.B.:
C:/Programme/zenonWebServer/zenon/index.htm
oder
C:/Inetpub/wwwroot/zenon/index.html

info Info

Der Dienst für den zenon Webserver wird nur in der lizenzierten Version automatisch gestartet. Im Demo-Modus muss der Webserver manuell über die Webserver-Konsole in den Systemeigenschaften gestartet werden.


Benutzerrechte für Installation

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Benutzerrechte für Installation

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Installation benötigen Sie folgende Benutzerrechte:

zenon Webserver:

Für die Installation und die Konfiguration des zenon Webservers (Eintragen der Seriennummer und des Aktivierungsschlüssels) benötigen Sie Administratorrechte.

Für den eigentlichen Betrieb gilt: Da der zenon Webserver im Hintergrund als Dienst läuft (im Kontext des SYSTEM Users), muss für den Betrieb kein Benutzer eingeloggt sein. Es ist daher unerheblich, welche Windows-Benutzerrechte der eingeloggte Benutzer hat.

zenon Webclient:

Für die Installation sind Administratorrechte nötig.

Für den Betrieb reichen die normalen Benutzerrechte aus.


Start und Servereinstellungen

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Start und Servereinstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Normalbetrieb wird der zenon Webserver automatisch gestartet. Sollte er gestoppt worden sein oder wird die Lizenznummer neu eingegeben, muss er manuell neu gestartet werden.

Hinweis: Ohne gültige Lizenzierung läuft der zenon Webserver im Demo-Modus. Dabei gelten folgende Einschränkungen:

  • der zenon Webserver kann nur manuell gestartet werden
  • die Laufzeit ist auf 30 Minuten beschränkt
  • die Anzahl der möglichen Clients ist auf 2 beschränkt

Um von Demo-Modus auf eine gültige Lizenz umzuschalten, stoppen Sie den zenon Webserver und geben Sie in der Registerkarte Licence eine gültige Lizenznummer ein. Starten Sie dann den Webserver manuell neu.

zenon Webserver konfigurieren

Um den Webserver zu konfigurieren:

  1. öffnen Sie die Systemsteuerung
  2. führen Sie einen Doppelklick auf zenon Webserver aus
  3. Der Dialog für Konfiguration und Lizenzierung öffnet sich

Parameter

Beschreibung

State:

Zeigt Version und Status des Webservers an:

Version:

  • zenon Webserver Pro
  • zenon Webserver Pro Light

Statusmeldungen:

  • running: Webserver läuft mit gültiger Lizenz
  • stopped: Webserver wurde gestoppt
  • Demomodus: Webserver läuft im Demomodus ohne Lizenz
  • not installed: Webserver nicht als Dienst registriert oder Installationsfehler

Max. number of clients:

Maximale Zahl an Clients, die sich zum Webserver verbinden dürfen. Zahl wird durch Lizenz definiert.
Im Demomodus sind 2 Clients für 30 Minuten lizenziert.

Number of active clients:

Zeigt Zahl der aktuell verbundenen Clients an.

Start

Startet Webserver.

Stop

Stoppt Webserver.

Refresh

Aktualisiert Anzeige .

Logfile

Öffnet die Log-Datei.

HTTP tunnelling

Aktiv: HTTP Tunneling ist aktiviert.

Nur verfügbar für zenon Webserver PRO, nicht in der Light-Version.
Hinweis: Kann nur geändert werden, wenn der Webserver im Status gestoppt ist. Im laufenden Betrieb kann nicht umgeschaltet werden.

Active clients

Liste der verbundenen Clients.

OK

Übernimmt Einstellungen und schließt Dialog.

Abbrechen

Verwirft Änderungen und schließt Dialog.

zenon Webserver manuell starten

Um den Webserver manuell zu starten:

  1. öffnen Sie die Systemsteuerung
  2. führen Sie einen Doppelklick auf zenon Webserver aus
  3. Der Dialog für Konfiguration und Lizenzierung öffnet sich

  4. wählen Sie die Verbindung über TCP oder HTTP
  5. klicken Sie auf die Schaltfläche Start

Start und Konfiguration unter Windows CE

Für Windows CE steht kein Startdialog zur Verfügung. Der zenon Webserver ist bereits in die Runtime integriert.

Um den zenon Webserver unter Windows CE zu starten, muss:

  • im Projekt die Eigenschaft Netzwerk aktiv aktiviert sein

    Interne ID: Start und Servereinstellungen

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • die Runtime gestartet sein
  • der zenon Webserver lizenziert sein

Hinweis: Unter Windows CE steht HTTP Tunnelling nicht zur Verfügung.

Die Konfiguration erfolgt analog den Angaben im Kapitel Einstellungen in projekt.html.

Unter Windows CE unterliegt die Funktionalität allen Einschränkungen, die generell für Windows CE und zenon Webserver unter Windows CE gelten.

Noch in diesem Kapitel

HTTP Tunnelling


HTTP Tunnelling

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Start und Servereinstellungen -> HTTP Tunnelling

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

-Der zenon Webserver kann anstellen von TCP-Verbindungen auch HTTP-Verbindungen annehmen. HTTP Verbindungen werden nur von zenon Webclients akzeptiert. Die Verbindung zum Runtime Server erfolgt immer über TCP. Für jede TCP Verbindung vom Webclient zum Webserver wird eine eigene HTTP-Verbindung aufgebaut.

Per Default werden Verbindungen über TCP aufgebaut. Um HTTP Tunnelling zu verwenden, muss:

  • HTTP über den Konfigurationsdialog oder einen Eintrag in der zenon6.ini aktiviert werden
  • der Port 8080 oder der in zenon6.ini konfigurierte Alternativport am Webserver PC erreichbar sein
  • die Projekteinstiegsseite für Webclients, die sich zum Webserver mit HTTP Tunnelling verbinden sollen, den Parameter UseHTTP mit einem Wert ungleich 0 im <embed> und <object> Eintrag aufweisen

Hinweis: Unter Windows CE steht HTTP Tunnelling nicht zur Verfügung.

Ablauf

Der Webclient schickt seine Nachrichten für den Runtime Server per HTTP-POST an den Webserver. Dieser leitet sie per TCP über die zugeordnete Verbindung zum Runtime Server weiter. Der Runtime Server schickt seine Nachrichten für den Webclient per TCP an den Webserver, der sie puffert.

Der Puffer einer Verbindung wird vom Webclient durch HTTP-GET-Anfragen geleert. Ist keine Nachricht für eine Verbindung verfügbar, so wartet der Client für eine konfigurierbare Zeit (Eintrag POLLING_INTERVALL in zenon6.ini mit Standardwert = 2 Sekunden).

Details siehe Kapitel Ablauf bei HTTP-Verbindung.

Fehlermeldungen

Bei aktiver HTTP-Verbindung werden im Diagnose Viewer teilweise anstelle netzwerkspezischer Meldungen HTTP-spezifische Meldungen angezeigt. Zum Beispiel bei Verbindungsaufbau und -abbau oder bei HTTP-Fehler.

Noch in diesem Kapitel

Ablauf bei HTTP-Verbindung


Ablauf bei HTTP-Verbindung

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Start und Servereinstellungen -> HTTP Tunnelling -> Ablauf bei HTTP-Verbindung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
Ablauf bei HTTP-Verbindung

Starten des Webservers

Der Webserver kann gestartet werden über

  • Dialog in der Systemsteuerung
  • Manuell

Dialog in der Systemsteuerung

  1. öffnen Sie die Systemsteuerung
  2. öffnen Sie den Konfigurationsdialog zenon Webserver
  3. aktivieren Sie die Checkbox HTTP
  4. klicken Sie auf die Schaltfläche Start

Manueller Start

  1. öffnen Sie den Explorer
  2. geben Sie in die Adresszeile ein: %cd_system%
  3. öffnen Sie die Datei zenWebSrv.ini mit einem Texteditor
  4. navigieren Sie zum Eintrag [DEFAULT]
  5. erstellen oder editieren Sie den Eintrag USE_HTTP_PROXY= und setzen Sie den Wert auf 1.
    (USE_HTTP_PROXY=1)
  6. speichern und schließen Sie die Datei
  7. starten Sie den zenon Webserver über eine der vier folgenden Möglichkeiten:
    1. Konfigurationsdialog in der Systemsteuerung
    2. über die Kommandozeile: Webserver als Dienst oder durch Eingabe des vollständigen Pfades starten
    3. in der Dienstansicht des Taskmanagers oder im Systemsteuerungselement Dienste den Dienst ZenWebSrv starten
    4. im Windows Explorer ins Installationsverzeichnis des Webservers navigieren und diesen durch eine Doppelklick auf zenWebSrv.exe starten

Ablauf Verbindungen

Wenn ein Webclient gestartet wird, verbindet er sich über den Webserver zum Runtime Server:

  1. Der Benutzer startet den Browser und öffnet die Projekteinstiegsseite.
  2. Die Projekteinstiegsseite veranlasst den Browser, den Webclient mit der vorgegebenen HTTP Tunnelling-Konfiguration zu starten.
  3. Der Webclient baut 3 HTTP-Verbindungen (Steuer-, Daten- und Dateiabgleichverbindung) zum Webserver auf:
    1. Eine Verbindungs-ID wird vom Webclient angefordert.
    2. Der Webserver sendet eine freie Verbindungs-ID, wenn eine verfügbar ist. Die gesendete ID wird in der Liste vergebener Verbindungs-IDs eingetragen. Dies geschieht, damit keine ID zweimal vergeben werden kann und um die HTTP-Verbindung auf eine TCP-Verbindung umlegen zu können.
    3. Das Netzwerk-Init-Paket wird über die HTTP Verbindung zum Webserver gesendet.
    4. Der Webserver prüft, ob dieser Webclient bereits in der Liste der aktiven Clients ist. Ist der Client neu, wird geprüft, ob die maximale Client Anzahl bereits erreicht wurde. Kann die Clientverbindung akzeptiert werden, so wird eine TCP Verbindung zur Runtime hergestellt und das Init-Paket weitergeleitet. Die angenommene Client-Verbindung und die hergestellte Server-Verbindung werden bis Verbindungsende aufeinander umgelegt: Daten von der Client-Verbindung werden über die Server-Verbindung weitergeleitet und umgekehrt.
  4. Datenaustausch:
    1. Der Webserver arbeitet als Protokoll-Übersetzer zwischen TCP und HTTP und puffert die Nachrichten.
    2. Daten von der Runtime für den Webclient werden am Server zwischengespeichert. Der Webclient ruft diese durch GET-Anfragen ab.
    3. Daten vom Webclient für die Runtime werden vom Webclient mittels POST-Anfrage gesendet und vom Webserver zur Runtime weitergeleitet.
  5. Wird der Webclient im Browser beendet (Browser wird geschlossen oder die Projekteinstiegsseite wird verlassen), so werden die Verbindungen vom Webclient abgebaut.
    1. Der Webclient sendet ein Netzwerk-Ende-Paket an den Webserver. Der Webserver leitet dieses an die Runtime weiter, beendet die Verbindung und räumt die belegten Ressourcen (Arbeitsspeicher, Ports, Verbindungs-ID …) auf.
    2. Beim Aufräumen auf der Client-Seite wird zusätzlich ein HTTP-Ende-Paket an den Webserver gesendet, um sicherzustellen, dass die Verbindungs-ID aus der Liste entfernt wurde.


Einstellungen in global_vars.js

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Einstellungen in global_vars.js

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Konfigurationsdatei global_vars.js wird für zenon Versionen ab 6.20 verwendet. Sie befindet sich im Ordner C:\inetpub\wwwroot\zenon\config\

global_vars.js

// Here enter the exact string how your project is named

var PROJECTNAME = "ENTER_PROJECTNAME_HERE";

// Please enter here the computername, where your zenon Runtime is installed and running

var RUNTIMESERVER= "ENTER_RUNTIMESERVERNAME_HERE";

// Here you have to enter computername, where you installed the zenon Webserver

var WEBSERVER = "ENTER_WEBSERVERNAME_HERE";

// Enter an optional init-zenon-function to be executed when the webclients connects to its server. Defaultvalue = "Init"

var INITFUNCTION = "Init";

// Enable zoom feature (will stretch the project resolution to the size of the webclient control) OFF = "0" / ON = "1"

var ZOOM = "0";

// Here you have to enter the version number corresponding to the Webclient.

var VERSION = "6,51,0,0";

Parameter

Parameter

Beschreibung

Projectname

Legt Name des Runtimeprojekts fest.

var PROJECTNAME = "NAME";

Zum Beispiel:

var PROJECTNAME = "zenon";

Hinweis: Das Projekt muss auf dem angegeben Runtime Server als Serverprojekt laufen.

RuntimeServer

Gibt den Zielrechner, auf dem die Runtime für das Projekt läuft an.

var RUNTIMESERVER = "NAME";

Zum Beispiel:

var RUNTIMESERVER = "T13-XPDE32";

Hinweis: Nur Großbuchstaben verwenden. Rechnernamen ohne Domainsuffix angeben.

Der Name muss mit dem Servernamen in der Projektkonfiguration übereinstimmen, siehe auch: Projektkonfiguration zenon 5.x und Projektkonfiguration zenon 6.x.

Redundanz Runtime-Server

Bei redundanten Runtime-Projekten wird nur der Name des Servers angegeben, nicht der Name des Standby-Servers. Der Name des Standby-Servers ist in der project.ini des Projekts gespeichert. Der zenon Webclient speichert diese bei der ersten Verbindung mit dem Runtime Server lokal. Das bedeutet: Bei der ersten Verbindung mit einem redundanten Projekt muss der Runtime Server online sein. Bei jeder weiteren Verbindung funktioniert dann das Redundanzkonzept, d.h. der zenon Webclient versucht, zuerst eine Verbindung mit dem Runtime Server aufzubauen. Wenn dieser nicht erreichbar ist, wird automatisch eine Verbindung mit dem Standby Server aufgebaut.

Redundanz Webserver

Wenn neben dem zenon Runtime-Server auch der zenon Webserver redundant betrieben werden soll, müssen:

  • zwei zenon Webserver auf unterschiedlichen Rechnern installiert und lizenziert werden
  • müssen bei der Variablendeklaration in der HTML Seite beide zenon Webserver durch einen Beistrich getrennt angeben werden:

    var WEBSERVER = WEBSERVER,WEB-STANDBY-SERVER";

Webserver

Gibt den Zielrechner an, auf dem der zenon Webserver installiert wurde, an. Achtung: Das ist nicht der Publishing Server!

var WEBSERVER = "NAME";

Zum Beispiel:

var WEBSERVER = "CD1111";

Hinweis: Nur Großbuchstaben verwenden. Rechnernamen ohne Domainsuffix angeben.

Initfunction

Legt eine zenon Funktion fest, die beim Starten des Projekts im Browser ausgeführt wird.

var INITFUNCTION = "Init";

Zum Beispiel:

var INITFUNCTION = "Init";

Default: "Init"

Hinweis: Die Schreibweise muss mit dem Funktionsnamen in zenon übereinstimmt (Groß-/Kleinschreibung) .

Zoom

Definiert, ob das Projekt in der Browseransicht gezoomt werden kann.

var ZOOM = "WERT";

0: OFF

1: ON

Zum Beispiel:

var ZOOM = "0";

Hinweis: Die Zoomanpassung wird nur beim Initialisieren übernommen, nicht, wenn die Runtime bereits läuft. Wird eine bestimmte Größe gewünscht ist, muss diese vom Active X Control definiert werden.

var VERSION

Legt die zenon Webclient Version fest.

var VERSION = "WERT";

zum Beispiel:

var VERSION = "6,50,1,0";

Diese muss immer gleich der oder höher als die zenon Runtime Version sein.

Hinweis: Achten Sie bei der Eingabe von Parametern in der Datei global_vars.js auf Groß und Kleinschreibung.

Eine Beispielkonfiguration finden Sie auf der DVD. Wie diese angepasst wird, lesen Sie im Kapitel Konfiguration der Beispielseite.


Einstellungen in projekt.html

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Einstellungen in projekt.html

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für ältere zenon Versionen wird die Konfigurationsdatei project.html verwendet.

<html>

<head>

<title></title>

</head>

<BODY scroll="no" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0" BGCOLOR=#FFFFFF>

<script language="JavaScript"><!--

var PROJECTNAME = "PROJECTNAME";

var RUNTIMESERVER= "RUNTIMESERVER";

var WEBSERVER = "WEBSERVER";

if (navigator.appName == "Netscape")

{

document.write ('<embed type="application/x-eskeractivex"');

document.write ('id="CD_IClient1"');

document.write ('classid="CLSID:2A3BC66B-03D7-11D4-991A-080009ABB492"');

document.write (' codebase="zenwebcli.ocx#version=1.0.0.1"');

document.write (' width=100%');

document.write (' height=100%');

document.write (' Project="' +PROJECTNAME+ '"');

document.write (' Server="' +RUNTIMESERVER+ '"');

document.write (' WebServer="' +WEBSERVER+ '"');

document.write (' Load="-1"');

document.write (' ScrollV="0"');

document.write (' Scrollh="0"');

document.write (' InitFunction="Init"');

document.write ('>');

}

else

{

document.write ('<object');

document.write (' id="CD_IClient1"');

document.write (' classid="clsid:2A3BC66B-03D7-11D4-991A-080009ABB492"');

document.write (' codebase="zenwebcli.ocx#version=1.0.0.1"');

document.write (' width=100%');

document.write (' height=100%');

document.write ('>');

document.write (' <PARAM NAME="Project" VALUE="' +PROJECTNAME+ '">');

document.write (' <PARAM NAME="Server" VALUE="' +RUNTIMESERVER+ '">');

document.write (' <PARAM NAME="WebServer" VALUE="' +WEBSERVER+ '">');

document.write (' <PARAM NAME="Load" VALUE="-1">');

document.write (' <PARAM NAME="ScrollV" VALUE="0">');

document.write (' <PARAM NAME="Scrollh" VALUE="0">');

document.write (' <PARAM NAME="InitFunction" VALUE="Init">');

document.write ('</object>');

}

// --></script>

</html>

Diese HTML-Datei wird analog der global_vars.js konfiguriert:

Parameter

Parameter

Beschreibung

Projectname

Legt Name des Runtimeprojekts fest.

Hinweis: Das Projekt muss auf dem angegeben Runtime Server als Serverprojekt laufen.

RuntimeServer

Gibt den Zielrechner, auf dem die Runtime für das Projekt läuft an.

Hinweis: Nur Großbuchstaben verwenden. Rechnernamen ohne Domainsuffix angeben.

Der Name muss mit dem Servernamen in der Projektkonfiguration übereinstimmen, siehe auch: Projektkonfiguration zenon 5.x und Projektkonfiguration zenon 6.x.

Redundanz Runtime-Server

Bei redundanten Runtime-Projekten wird nur der Name des Servers angegeben, nicht der Name des Standby-Servers. Der Name des Standby-Servers ist in der project.ini des Projekts gespeichert. Der zenon Webclient speichert diese bei der ersten Verbindung mit dem Runtime Server lokal. Das bedeutet: Bei der ersten Verbindung mit einem redundanten Projekt muss der Runtime Server online sein. Bei jeder weiteren Verbindung funktioniert dann das Redundanzkonzept, d.h. der zenon Webclient versucht, zuerst eine Verbindung mit dem Runtime Server aufzubauen. Wenn dieser nicht erreichbar ist, wird automatisch eine Verbindung mit dem Standby Server aufgebaut.

Redundanz Webserver

Wenn neben dem zenon Runtime-Server auch der zenon Webserver redundant betrieben werden soll, müssen:

  • zwei zenon Webserver auf unterschiedlichen Rechnern installiert und lizenziert werden
  • müssen bei der Variablendeklaration in der HTML Seite beide zenon Webserver durch einen Beistrich getrennt angeben werden:

    var WEBSERVER = "WEBSERVER,WEB-STANDBY-SERVER";

Webserver

Gibt den Zielrechner an, auf dem der zenon Webserver installiert wurde, an. Achtung: Das ist nicht der Publishingdienst!

Hinweis: Nur Großbuchstaben verwenden. Rechnernamen ohne Domainsuffix angeben.

Initfunction

Legt eine zenon Funktion fest, die beim Starten des Projekts im Browser ausgeführt wird.

Hinweis: Die Schreibweise muss mit dem Funktionsnamen in zenon übereinstimmt (Groß-/Kleinschreibung) .

Zoom

Definiert, ob das Projekt in der Browseransicht gezoomt werden kann.

Hinweis: Die Zoomanpassung wird nur beim Initialisieren übernommen, nicht, wenn die Runtime bereits läuft. Wird eine bestimmte Größe gewünscht ist, muss diese vom Active X Control definiert werden.


Dateiablage Runtime-Dateien

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Dateiablage Runtime-Dateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Webserver speichert die Runtime-Dateien standardmäßig im Ordner %Temp%\zenWebCli.

%Temp% bezeichnet unter Windows den temporären Dateiordner. Dieser wird für jeden Benutzer individuell gespeichert und kann unter Systemsteuerung -> System -> Erweiterte Systemeinstellungen -> Umgebungsvariablen verändert werden.

Über einen Eintrag in der zenon6.ini könen Sie einen beliebigen Ordner als Ablageort für die Runtimedateien festlegen:

  1. öffnen Sie die zenon6.ini
  2. navigieren Sie zum Abschnitt

    [PATH]

  3. erstellen oder modifizieren Sie den Eintrag

    WEB_PROJECT_PATH=


Redundanzbetrieb

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver (Pro) -> Anleitung: vorbereiten - installieren - starten -> Redundanzbetrieb

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Webserver kann ab zenon Webclient 6.01 auch redundant betrieben werden.

Bei redundanten Runtime-Stationen werden auch redundante zenon Webserver empfohlen. Fällt ein zenon Webserver aus bzw. wird gestoppt, wechselt der zenon Webclient automatisch zum Standby-Webserver.

attention Achtung

Ein automatisches Zurückwechseln wie beim Runtime Server erfolgt nicht. Der zenon Webclient bleibt solange mit dem zenon Standby-Webserver verbunden, bis:

  • der zenon Webclient neu gestartet wird oder
  • der zenon Standby-Webserver gestoppt wird bzw. ausfällt

Dann versucht der zenon Webclient sich wieder mit dem als Standard definierten ersten zenon Webserver zu verbinden.

Bei Verwendung nur eines zenon Webservers empfiehlt es sich, diesen nicht auf dem selben Rechner wie den Runtime Server oder den Runtime Standby-Server zu betreiben, da bei einem Ausfall dieses Rechners der zenon Webserver ebenfalls ausfallen würde.


zenon Webclient

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webclient

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um Projekte zur Runtime in einem Browser darstellen zu können, muss der zenon Webclient auf demselben Recher lokal installiert sein. Details zu Browser-Betriebssystemen finden Sie im Kapitel Browser.

Der zenon Webclient besteht vor allem aus einem ActiveX Control. Dieses stellt die Informationen in einem Browser 1:1 wie in einem normalen Runtime-Client dar. Die Verbindung zum Runtime Server erfolgt mittels TCP/IP über den zenon Webserver.

Die aktuellen Installationsdateien für den zenon Webclient befinden sich nach der Installation des zenon Webservers (Pro) im jeweiligen Unterverzeichnis, z.B.:

C:\inetpub\wwwroot\zenon\controlversions\version651SP0\WEB_Client_Setup_GERMAN.exe.

Alle zenon Webclient Setups sind digital signiert und können auch auf einer Webseite zum Download bereitgestellt werden. Über die Eigenschaften des zenon Webclient Setups können Sie die entsprechenden Zertifikatinformationen abrufen.

zenon Webclient Setups in allen zur Verfügung stehenden Sprachversionen befinden sich auf der zenon Webserver DVD im Ordner COPA-DATA\Web Client versions.

info Info

Der zenon Webclient sendet Error und Log-Files. Der Diagnose Server wird bei einer Installation des zenon Webclients mitinstalliert.

Noch in diesem Kapitel

Browser

Verschlüsselung der Kommunikation im Netzwerk

zenon Webclient - Kompatibilität


Browser

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webclient -> Browser

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Webclient unterstützt folgende Browser:

  • Microsoft Internet Explorer
  • Mozilla Firefox
  • Google Chrome
  • Apple Safari

Es wird empfohlen, die jeweils aktuellste Version zu verwenden.

info Info

Der Browser für den zenon muss eines der folgenden Betriebssysteme unterstützen:

  • Windows XP
  • Windows Vista
  • Windows7
  • Windows 2003/2008 Server.

Andere Betriebssysteme wie Windows CE, Linux oder sonstige sind nur in Verbindung mit einem Terminalserver verwendbar.

Browserstart

Die Projekteinstiegsseite entscheidet auf Basis der Browser-Identifikation, ob und wie der Webclient gestartet wird:

  • Internet Explorer: Start als ActiveX Komponente
  • Firefox: Start als Plugin
  • Chrome: Start als Plugin
  • Safari: Start als Plugin
  • andere Browsern oder nicht unterstützte Versionen: eine Fehlermeldung wird angezeigt; der Webclient startet nicht

Unterstützte Versionen

Browser

ab Version

Anmerkung

Microsoft Internet Explorer
  • 3.0
  • empfohlen ab: 8.0
  • Windows XP: 6.0
  • beachten Sie die Hinweise zum Speicherschutz bei IE 8/9

Mozilla Firefox
  • 3.6.4: Plugin-Container muss manuell aktiviert werden
  • empfohlen ab: 4.0 (Plugin-Container ist standardmäßig aktiviert)
  • beachten Sie die Hinweise zur Konfiguration und zu Keyboards

Google Chrome

  • 1.0
  • empfohlen: ab 7.0

Apple Safari
  • 3.0
  • empfohlen: ab 5.0

attention Achtung

VBA/VSTA und Data Execution Prevention

Das Betriebssystem verhindert über die Funktion Data Execution Prevention (DEP) auch, dass VBA-Code im Browser ausgeführt wird.

Microsoft Internet Explorer 8 und 9:
Der Microsoft Internet Explorer bietet ab Version 8 die Möglichkeit, DEP für den Browser zu deaktivieren.

  • navigieren Sie zu Extras -> Internetoptionen -> Erweitert -> Sicherheit
  • deaktivieren Sie die Option Speicherschutz aktivieren, um das Risiko von Onlineangriffen zu verringern

Andere Browser

DEP muss komplett abgeschaltet werden, da der Browserprozess nicht explizit ausgenommen werden kann. Dies wird aus Sicherheitsgründen nicht empfohlen.

Generelle Empfehlung: Verwenden Sie VSTA statt VBA.

Konfiguration Mozilla Firefox

Für Mozilla Firefox ist für alle Versionen unterhalb Version 4 das manuelle Aktivieren des Plugin Containers nötig. Dazu:

  1. geben Sie in die Adresszeile ein: about:config
  2. der Browser schaltet eventuell eine Warnung auf: Hier endet möglicherweise die Gewährleistung!
  3. klicken Sie auf die Schaltfläche: Ich werde vorsichtig sein, versprochen!
  4. navigieren Sie zur Eigenschaft dom.ipc.plugins.enabled
  5. diese muss auf true gesetzt sein
  6. um diesen Status zu setzen:
    1. führen Sie einen Rechtsklick auf die Eigenschaft aus
    2. wählen Sie im Kontextmenü den befehl: Umschalten
  7. schließen Sie den Browser

Hinweis: Werden diese Einstellungen nicht vorgenommen, so kann der Webclient im Firefox nicht mit der Runtime kommunizieren. Bilder werden zwar angezeigt, aber alle Variablen werden als offline angezeigt; Bildelemente haben damit keine Werte und werden blau markiert.

attention Achtung

Individuell angepasste Bilder vom Typ Keyboard funktionieren unter Umständen mit dem Browser Mozilla Firefox nicht korrekt.

Ursache: Mozilla Firefox lädt neue Fenster im Hintergrund, ohne ihnen den Fokus zu geben. Individuell angepasste Keyboard-Bilder werden aber geschlossen, sobald sie den Fokus verlieren.

Lösung: Benutzen Sie einen anderen Browser wie z.B. Microsoft Internet Explorer, Apple Safari oder Google Chrome.

Automatische Keyboards sind nicht betroffen!


Verschlüsselung der Kommunikation im Netzwerk

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webclient -> Verschlüsselung der Kommunikation im Netzwerk

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ab zenon Version 7 kann die Kommunikation im Netzwerk mit starker Verschlüsselung geschützt werden.

Um die Verschlüsselung im Webclient zu aktivieren:

  1. starten Sie im Startmenü die Verknüpfung \Programme\COPA-DATA\Network communication encryption
    oder die Datei zenWebCryptConfig.exe im zenon Programmordner.
  2. der Dialog zur Konfiguration wird geöffnet

Parameter | Beschreibung
Encrypt network communication | Aktiv: Die Kommunikation im Netzwerk wird verschlüsselt.
Password | Passwort eintragen. Kriterien siehe Abschnitt "Passwort Netzwerkverschlüsselung" im Kapitel Starke Verschlüsselung der Netzwerkkommunikation. Die angezeigte Länge wird immer auf 20 Zeichen gesetzt, um die tatsächliche Länge zu verbergen.
Verify password | Passwort zur Bestätigung erneut eingeben.
OK | Übernimmt Änderungen und schließt Dialog.
Cancel | Verwirft Änderungen und schließt Dialog.

info Info

Hinweise zu Fehlermeldungen der starken Verschlüsselung finden Sie im:

Handbuch Netzwerk -> Kapitel Starke Verschlüsselung der Netzwerkkommunikation -> Abschnitt Fehlermeldungen.


zenon Webclient - Kompatibilität

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webclient -> zenon Webclient - Kompatibilität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit dem zenon Webclient greifen Sie analog zur Runtime-Kompatibilität auf unterschiedliche Runtime-Versionen zu. Die Versionsnummer des Webclients muss lediglich gleich der Runtime-Version oder höher sein.

Die Runtime Online-Kompatibilität ermöglicht die Interoperabilität von Runtime-Systemen (auch über Webclient) im zenon Netzwerk, selbst wenn die Version der Client-Runtime höher ist als jene der Server-Runtime.

Die aktuelle Runtime kann Projekte folgender Versionen laden:

  • 6.20 SP4
  • 6.21 SP0
  • 6.21 SP1
  • 6.22 SP0
  • 6.22 SP1
  • 6.50 SP0
  • 6.51 SP0
  • 7.00 SP0

Im Rahmen der Mehrprojektverwaltung können auch unterschiedliche Projekte geladen werden. Zum Beispiel kann das I-Projekt von der Version 7.00 sein, ein Unterprojekt von der Version 6.51 und ein weiteres Unterprojekt von der Version 6.22 SP1.

info Info

Verwenden Sie am besten immer den zenon Webclient mit der höchsten Servicepacknummer innerhalb einer Version.


VSTA mit Webclient, Webserver und Webserver Pro

Handbuch -> zenon Webserver und zenon Webserver Pro -> VSTA mit Webclient, Webserver und Webserver Pro

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

VSTA wird von zenon in Webserver und Webserver Pro in unterschiedlicher Ausprägung unterstützt.

Funktion

Webclient mit Webserver Standard

Webclient mit Webserver Pro

VSTA-Makro Dialog anzeigen

+

+

VSTA-Makro ausführen

+

+

VSTA-Editor öffnen

-

-

VSTA Events

+

+

Anmerkung
  • Es werden keine Werte auf zenon Variablen geschrieben.
  • Windows Messageboxen können geöffnet werden.
  • Kompilieren und debuggen ist nicht möglich.
    Dazu muss eine Standard zenon Runtime verwendet werden.
  • Alle zenon VSTA Funktionalitäten sind vollständig verfügbar.
  • Kompilieren und debuggen ist nicht möglich.
    Dazu muss eine Standard zenon Runtime verwendet werden.

Installation

Für die Verwendung von VSTA

  • müssen folgende Applikationen am System vorhanden sein oder manuell installiert werden:
    • Microsoft Visual Studio Tools for Applications 2.0 (VSTA 2.0)
    • Microsoft .Net Framework 3.5

    Beide Programme befinden sich auf dem Installationsmedium für den zenon Webserver bzw. für zenon 7.00.

  • muss sich die VSTAIntegration.dll im zenon Programmverzeichnis befinden.
    Diese wird bei der Installation von zenon automatisch installiert.

INI-Einträge

In der zenon6.ini müssen folgende Einträge gesetzt werden:

[VSTA]

ON=1

CSHARP=1

[VBA]

EIN=1

EVENT=1

Anmerkung: Die zenon6.ini finden Sie im Ordner C:\ProgramData\COPA-DATA\System\


Projektieren im Editor

Handbuch -> zenon Webserver und zenon Webserver Pro -> Projektieren im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um über das Internet oder Intranet auf einen Runtime Server zugreifen zu können, muss das Projekt ein Netzwerkprojekt sein.

Noch in diesem Kapitel

Projektkonfiguration 5.x

Projektkonfiguration ab 6.x

Bildschirmauflösung und Monitorverwaltung

Mehrprojektverwaltung und redundante Projekte


Projektkonfiguration 5.x

Handbuch -> zenon Webserver und zenon Webserver Pro -> Projektieren im Editor -> Projektkonfiguration 5.x

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime muss als Server gestartet sein. Dies wird im Editor in den Projekteigenschaften in der Registerkarte Netz konfiguriert. Um das Projekt im Netzwerk einsetzen zu können, muss die Checkbox Projekt im Netzwerk einsetzen aktiviert werden. Mit Hilfe des Buttons ... wird der Rechner ausgewählt, der die Rolle des Servers für dieses Projekt übernehmen soll. Dieser Rechnername muss dann auch in der Projekteinstiegsseite (z.B.: Globalvars.js, siehe Konfiguration der Beispielseite) angegeben werden, damit eine Verbindung hergestellt werden kann.

Weiter Informationen über die Netzwerkmöglichkeiten und Einstellungen finden Sie im Kapitel Netzwerk.


Projektkonfiguration ab 6.x

Handbuch -> zenon Webserver und zenon Webserver Pro -> Projektieren im Editor -> Projektkonfiguration ab 6.x

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Runtime muss als Server gestartet sein. Dies wird im Editor bei den Projekteigenschaften im Bereich Netzwerk konfiguriert:

Interne ID: Projektkonfiguration ab 6.x

Netzwerk

Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • Checkbox für die Eigenschaft Netzwerk aktiv muss aktiviert sein

    Interne ID: Projektkonfiguration ab 6.x

    Netzwerk aktiv

    Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
    Inaktiv: Das Projekt ist ein Standalone-Projekt.
    Default: inaktiv.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

  • in der Eigenschaft Server muss der Rechnername des Runtime Servers eingetragen sein. Dieser Rechnername muss auch in der Projekteinstiegsseite (z.B.: Globalvars.js, siehe Konfiguration der Beispielseite) angegeben werden, damit eine Verbindung hergestellt werden kann.

    Interne ID: Projektkonfiguration ab 6.x

    Server

    Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
    Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

    Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
    Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Weitere Informationen zum zenon Netzwerk finden Sie im Kapitel Netzwerk.


Bildschirmauflösung und Monitorverwaltung

Handbuch -> zenon Webserver und zenon Webserver Pro -> Projektieren im Editor -> Bildschirmauflösung und Monitorverwaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die zenon Monitor Verwaltung steht im zenon Webclient mit Einschränkungen zur Verfügung.

Wichtig für die Projektierung: Die automatische Anpassung der Auflösung an den Client kann im Webeinsatz nicht verwendet werden. Deshalb muss bereits bei der Projektierung die Bildschirmgröße passend gesetzt werden. Standardmäßig verwendet der zenon Webclient die beim Projekt eingestellte Bildschirmgröße: Projekteigenschaften -> Grafische Ausprägung -> Monitorverwaltung -> Klick auf Schaltfläche ... -> Registerkarte Allgemein - Bildschirmauflösung.

Interne ID: Bildschirmauflösung und Monitorverwaltung

Monitorverwaltung

Der Konfigurationsdialog für die Monitorverwaltung wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Bildschirmauflösung und Monitorverwaltung

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Die Auflösung kann über eine Einstellung des zenon Webclients skaliert werden. Details siehe Kapitel Konfiguration der Beispielseite.

Mit Hilfe der Zoom-Eigenschaft kann der zenon Webclient auf die Größe eines ActiveX-Elements gezoomt werden.

Größe im Browser

Der Browser benötigt immer einen Bereich der Monitorfläche für Menüs und Scrollbalken. Der Bereich, der dem zenon Webclient zur Darstellung zur Verfügung steht, ist daher immer kleiner als die eingestellte Monitorauflösung. Wenn Sie im Browser ein Vollbild des Projekts haben möchten, müssen Sie die Bildschirmgröße kleiner einstellen, als die tatsächlich am zenon Webclient vorhandene.

Zum Beispiel:
Monitorauflösung am zenon Webclient PC: 1024x768 Pixel
Bildschirmgröße in der Monitorverwaltung: 800x600.

info Info

Wenn Sie die Mehrprojektverwaltung am zenon Webclient nutzen, muss die eingestellte Bildschirmgröße bei allen Projekten gleich sein!

Mehrmonitorsystem:

In einem Mehrmonitorsystem werden die Prozessbilder, wie im Profil projektiert, auf den verschiedenen reellen Monitoren aufgeschaltet. Beim Einsatz eines Webclients liegen diese dann außerhalb des sichtbaren Bereichs, können aber durch scrollen erreicht werden.

Empfehlung: Konfigurieren Sie das Monitorprofil so, dass alle Monitore auf den Hauptmonitor gemapped werden, dann haben Sie direkten Zugriff auf alle Monitore.

info Info

Am zenon Webclient wird standardmäßig immer das Profil Standard geladen. Sie können aber über den Eintrag SCREENPROFILE= in der zenon6.ini ein anderes Monitorprofil vorgeben.


Mehrprojektverwaltung und redundante Projekte

Handbuch -> zenon Webserver und zenon Webserver Pro -> Projektieren im Editor -> Mehrprojektverwaltung und redundante Projekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der zenon Webclient unterstützt alle Netzwerkfähigkeiten wie ein normaler Client. ist das Startprojekt ein Integrationsprojekt, werden daher auch alle Unterprojekte geladen.

Hinweis: Der Webclient Rechner benötigt bei Integrationsprojekten den gleichen Speicher und die gleiche Hardware wie ein normaler Client.

Ebenso werden redundante Runtime Server unterstützt.


Erstellen der HTML-Seite für den Projekteinstieg

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit der Webbrowser den zenon Webclient starten kann, und sich dieser zum entsprechenden Runtime Server verbinden kann, bedarf es einer Projekteinstiegsseite. Diese Seite enthält den dafür notwendigen Code. Als Skriptsprache wird dazu Java Script verwendet.

Voraussetzungen:

  • Java Script muss im Browser aktiviert sein.
  • der zenon Webclient muss lokal auf dem Rechner installiert sein, auf dem der Webbrowser ausgeführt wird.

Empfehlung: Schalten Sie vor die Projekteinstiegsseite (init.htm) eine Startseite (index .htm ) , die den Download des Webclients ermöglicht. Diese Startseite enthält Hyperlinks:

  • zum Download des zenon Webclient Controls
  • zur Projekteinstiegsseite init.htm, die einen Browsercheck ausführt und die Verbindung zum zenon Webserver und zum Runtime Server herstellt

Einstellungen TCP und HTTP

Die Einstellungen unterscheiden sich für Verbindungen via TCP und via HTTP nur durch den Eintrag UseHTTP .

  • Beispiel für TCP
  • Beispiel für HTTP

Noch in diesem Kapitel

Beispiel Projekteinstiegsseite init.htm für TCP

Beispiel Projekteinstiegsseite init.htm für HTTP

Beispiel von der Webserver DVD


Beispiel Projekteinstiegsseite init.htm für TCP

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für TCP

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der Projekteinstiegsseite prüft ein Browsercheck, welchen Browser der Webclient verwendet. Je nach Ergebnis wird der Webclient gestartet oder eine Fehlermeldung ausgegeben.

Beispiel Projekteinstieg

Die Einstiegsseite ruft drei Skripte auf, um den verwendeten Browser zu prüfen und entweder die Verbindung zur Runtime herzustellen oder eine Fehlermeldung auszugeben:

  • global_vars.js: definiert Werte der Übergabeparameter zum Starten des Webclients
  • browsercheck.js: prüft die Version des Browsers
  • initcode.js: definiert Funktionen, die zum Starten des Webclients verwendet werden

Noch in diesem Kapitel

init.htm


init.htm

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für TCP -> init.htm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die init.htm überprüft den verwendeten Browser und startet dann entweder das Projekt oder gibt eine Fehlermeldung aus. Dazu werden drei Skripte benutzt:

  1. Die Konfiguration wird aus global_vars.js geladen.
  2. Der Browser wird durch browsercheck.js bestimmt.
  3. Wenn es sich um einen unterstützten Browser handelt, wird die passende Funktion zum Einbinden des Webclients aus initcode.js ausgeführt.

Beispiel

<html>

<head>

<title></title>

</head>

<BODY scroll="no" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0" BGCOLOR=#FFFFFF>

<script language="javascript" type="text/javascript" src="global_vars.js"></script>

<script language="javascript" type="text/javascript" src="browsercheck.js"></script>

<script language="javascript" type="text/javascript" src="initcode.js"></script>

<script language="JavaScript" type="text/javascript">

switch(browsercheck()) {

case "IEXPLORER":

runIexplorer(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION);

break;

case "NPAPI":

runNPAPI(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION);

break;

case "UNSUPPORTED_BROWSER":

alert(navigator.appName + ' : ' + navigator.appVersion + ' is not supported!');

break;

default:

alert("invalid parameter");

break;

}

</script>

</html>

Noch in diesem Kapitel

global_vars.js

browsercheck.js

initcode.js


global_vars.js

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für TCP -> init.htm -> global_vars.js

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit diesem Javascript wird der Webclient konfiguriert. Details zu den Optionen finden Sie im Kapitel Einstellungen in global_vars.js.

Beispielkonfiguration:

// Here enter the exact string how your project is named

var PROJECTNAME = "Project_001";

// Please enter here the computername, where your zenOn Runtime is installed and running

var RUNTIMESERVER= "PC_016";

// Here you have to enter computername, where you installed the zenon Webserver

var WEBSERVER = "PC_016";

// Enter an optional init-zenOn-function to be executed when the webclients connects to its server. Defaultvalue = "Init"

var INITFUNCTION = "Init";

// Enable zoom feature (will stretch the project resolution to the size of the webclient control) OFF = "0" / ON = "1"

var ZOOM = "0";

// Here you have to enter the version number corresponding to the Webclient.

var VERSION = "6,22,0,0";


browsercheck.js

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für TCP -> init.htm -> browsercheck.js

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Javascript findet heraus, welcher Browser den Webclient starten will und gibt das Ergebnis an die init.htm zurück.

function browsercheck(){

var UserAgent = navigator.userAgent;

var fWin32 = (UserAgent.lastIndexOf('Win') != -1) && (UserAgent.lastIndexOf('Windows 3.1') == -1) && (UserAgent.lastIndexOf('Win16') == -1);

var fMSIE_6to9 = (UserAgent.lastIndexOf('MSIE 6.0') != -1) || (UserAgent.lastIndexOf('MSIE 7.0') != -1) || (UserAgent.lastIndexOf('MSIE 8.0') != -1) || (UserAgent.lastIndexOf('MSIE 9.0') != -1);

var fNPAPI = (UserAgent.lastIndexOf('Firefox/3.6.') != -1) || (UserAgent.lastIndexOf('Firefox/4.') != -1) || (UserAgent.lastIndexOf('Chrome/7.') != -1) || ((UserAgent.lastIndexOf('Safari') != -1) && (UserAgent.lastIndexOf('Version/5.') != -1));

if(fWin32)

{

//Win32-Browser

if(fMSIE_6to9)

{

//Internet Explorer --> use ActiveX-Control

return "IEXPLORER";

}

if(fNPAPI)

{

//Firefox, Chrome or Safari --> use NPAPI-Plugin

return "NPAPI";

}

}

//Non-Win32-Browser or not supported Browser (Opera, ...)

return "UNSUPPORTED_BROWSER";

}


initcode.js

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für TCP -> init.htm -> initcode.js

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Javascript setzt den <embed> Eintrag zum Starten des Webclients in Apple Safari, Google Chrome und Mozilla Firefox sowie den <object> Eintrag zum Starten des Webclients in Microsoft Internet Explorer:

function runNPAPI(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION) {

document.write ('<embed type="application/x-zenon"');

document.write (' width=100%');

document.write (' height=100%');

document.write (' Project="' +PROJECTNAME+ '"');

document.write (' Server="' +RUNTIMESERVER+ '"');

document.write (' WebServer="' +WEBSERVER+ '"');

document.write (' Load="-1"');

document.write (' ScrollV="0"');

document.write (' Scrollh="0"');

document.write (' InitFunction="' +INITFUNCTION+ '"');

document.write (' Zoom="' +ZOOM+ '"');

document.write ('>');

document.write (' </EMBED> ');

}

function runIexplorer(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION) {

document.write ('<object');

document.write (' id="CD_IClient1"');

document.write (' classid="clsid:2A3BC66B-03D7-11D4-991A-080009ABB492"');

document.write (' codebase="zenWebCli.ocx#version=' +VERSION+ '"');

document.write (' width=100%');

document.write (' height=100%');

document.write ('>');

document.write (' <PARAM NAME="Project" VALUE="' +PROJECTNAME+ '">');

document.write (' <PARAM NAME="Server" VALUE="' +RUNTIMESERVER+ '">');

document.write (' <PARAM NAME="WebServer" VALUE="' +WEBSERVER+ '">');

document.write (' <PARAM NAME="Load" VALUE="-1">');

document.write (' <PARAM NAME="ScrollV" VALUE="0">');

document.write (' <PARAM NAME="Scrollh" VALUE="0">');

document.write (' <PARAM NAME="InitFunction" VALUE="' +INITFUNCTION+ '">');

document.write (' <PARAM NAME="Zoom" VALUE="' +ZOOM+ '">');

document.write ('</object>');

}


Beispiel Projekteinstiegsseite init.htm für HTTP

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für HTTP

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Auf der Projekteinstiegsseite prüft ein Browsercheck, welchen Browser der Webclient verwendet. Je nach Ergebnis werden die Parameter für die Verwendung von HTTP gesetzt und der Webclient gestartet oder eine Fehlermeldung ausgegeben.

Beispiel Projekteinstieg

Die Einstiegsseite ruft drei Skripte auf, um den verwendeten Browser zu prüfen und entweder die Verbindung zur Runtime herzustellen oder eine Fehlermeldung auszugeben:

  • global_vars.js: definiert Werte der Übergabeparameter zum Starten des Webclients
  • browsercheck.js: prüft die Version des Browsers
  • initcode.js: definiert Funktionen, die zum Starten des Webclients verwendet werden

Noch in diesem Kapitel

init.htm


init.htm

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für HTTP -> init.htm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Hier erfolgt der eigentliche Projekteinstieg für den Browser. Dazu werden drei Skripte benutzt:

  1. Die Konfiguration wird aus global_vars.js geladen.
  2. Der Browser wird durch browsercheck.js bestimmt.
  3. Wenn es sich um einen unterstützten Browser handelt, wird die passende Funktion zum Einbinden des Webclients aus initcode.js ausgeführt.

<html>

<head>

<title></title>

</head>

<BODY scroll="no" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0" BGCOLOR=#FFFFFF>

<script language="javascript" type="text/javascript" src="global_vars.js"></script>

<script language="javascript" type="text/javascript" src="browsercheck.js"></script>

<script language="javascript" type="text/javascript" src="initcode.js"></script>

<script language="JavaScript" type="text/javascript">

switch(browsercheck()) {

case "IEXPLORER":

runIexplorer(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION);

break;

case "NPAPI":

runNPAPI(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION);

break;

case "UNSUPPORTED_BROWSER":

alert(navigator.appName + ' : ' + navigator.appVersion + ' is not supported!');

break;

default:

alert("invalid parameter");

break;

}

</script>

</html>

Noch in diesem Kapitel

global_vars.js

browsercheck.js

initcode.js


global_vars.js

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für HTTP -> init.htm -> global_vars.js

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Mit diesem Javascript wird der Webclient konfiguriert. Details zu den Optionen finden Sie im Kapitel Einstellungen in global_vars.js.

Beispielkonfiguration:

// Here enter the exact string how your project is named

var PROJECTNAME = "HAUSVISU_CDA";

// Please enter here the computername, where your zenOn Runtime is installed and running

var RUNTIMESERVER= "CDSBG016";

// Here you have to enter computername, where you installed the zenon Webserver

var WEBSERVER = "CDSBG036";

// Enter an optional init-zenOn-function to be executed when the webclients connects to its server. Defaultvalue = "Init"

var INITFUNCTION = "Init";

// Enable zoom feature (will stretch the project resolution to the size of the webclient control) OFF = "0" / ON = "1"

var ZOOM = "0";

// Here you have to enter the version number corresponding to the Webclient.

var VERSION = "7,00,0,0";

// Enable HTTP tunnelling feature: 0 = inactive (available on zenon WebClient version 7.00 and higher)

var HTTP = "1";


browsercheck.js

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für HTTP -> init.htm -> browsercheck.js

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Javascript findet heraus, welcher Browser den Webclient starten will und gibt das Ergebnis an die init.htm zurück.

function browsercheck(){

var UserAgent = navigator.userAgent;

var fWin32 = (UserAgent.lastIndexOf('Win') != -1) && (UserAgent.lastIndexOf('Windows 3.1') == -1) && (UserAgent.lastIndexOf('Win16') == -1);

var fMSIE_6to9 = (UserAgent.lastIndexOf('MSIE 6.0') != -1) || (UserAgent.lastIndexOf('MSIE 7.0') != -1) || (UserAgent.lastIndexOf('MSIE 8.0') != -1) || (UserAgent.lastIndexOf('MSIE 9.0') != -1);

var fNPAPI = (UserAgent.lastIndexOf('Firefox/3.6.') != -1) || (UserAgent.lastIndexOf('Firefox/4.') != -1) || (UserAgent.lastIndexOf('Chrome/7.') != -1) || ((UserAgent.lastIndexOf('Safari') != -1) && (UserAgent.lastIndexOf('Version/5.') != -1));

if(fWin32)

{

//Win32-Browser

if(fMSIE_6to9)

{

//Internet Explorer --> use ActiveX-Control

return "IEXPLORER";

}

if(fNPAPI)

{

//Firefox, Chrome or Safari --> use NPAPI-Plugin

return "NPAPI";

}

}

//Non-Win32-Browser or not supported Browser (Opera, ...)

return "UNSUPPORTED_BROWSER";

}


initcode.js

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel Projekteinstiegsseite init.htm für HTTP -> init.htm -> initcode.js

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Javascript setzt den <embed> Eintrag zum Starten des Webclients in Apple Safari, Google Chrome und Mozilla Firefox sowie den <object> Eintrag zum Starten des Webclients in Microsoft Internet Explorer:

function runNPAPI(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION) {

document.write ('<embed type="application/x-zenon"');

document.write (' width=100%');

document.write (' height=100%');

document.write (' Project="' +PROJECTNAME+ '"');

document.write (' Server="' +RUNTIMESERVER+ '"');

document.write (' WebServer="' +WEBSERVER+ '"');

document.write (' Load="-1"');

document.write (' ScrollV="0"');

document.write (' Scrollh="0"');

document.write (' InitFunction="' +INITFUNCTION+ '"');

document.write (' Zoom="' +ZOOM+ '"');

document.write (' UseHTTP = "' +HTTP+ '"');

document.write ('>');

document.write (' </EMBED> ');

}

function runIexplorer(PROJECTNAME,RUNTIMESERVER,WEBSERVER,INITFUNCTION,ZOOM,VERSION) {

document.write ('<object');

document.write (' id="CD_IClient1"');

document.write (' classid="clsid:2A3BC66B-03D7-11D4-991A-080009ABB492"');

document.write (' codebase="zenWebCli.ocx#version=' +VERSION+ '"');

document.write (' width=100%');

document.write (' height=100%');

document.write ('>');

document.write (' <PARAM NAME="Project" VALUE="' +PROJECTNAME+ '">');

document.write (' <PARAM NAME="Server" VALUE="' +RUNTIMESERVER+ '">');

document.write (' <PARAM NAME="WebServer" VALUE="' +WEBSERVER+ '">');

document.write (' <PARAM NAME="Load" VALUE="-1">');

document.write (' <PARAM NAME="ScrollV" VALUE="0">');

document.write (' <PARAM NAME="Scrollh" VALUE="0">');

document.write (' <PARAM NAME="InitFunction" VALUE="' +INITFUNCTION+ '">');

document.write (' <PARAM NAME="Zoom" VALUE="' +ZOOM+ '">');

document.write (' <PARAM NAME="UseHTTP" VALUE="' +HTTP + '">');

document.write ('</object>');

}


Beispiel von der Webserver DVD

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel von der Webserver DVD

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei der Installation des zenon Webservers wird ein Beispiel für eine Startseite (index.htm) mit Hyperlinks zum Download der Webclient Controls und Hyperlinks zum Projekteinstieg (init.htm) mitinstalliert.

Verzeichnisstruktur auf der Festplatte:
C:/Programme/COPA-DATA/zenonWebServer/zenon.

Wenn Sie bereits einen Internet Information Server auf Ihrem Rechner installiert haben, wird der Ordner zenon vom Setup automatisch im wwwroot Verzeichnis des IIS angelegt.

Die Installation des Webclients wird über die Datei index.htm angeboten.

Der Projekteinstieg erfolgt über die Datei init.htm.

Noch in diesem Kapitel

Die Seite index.htm

Wahl des Fenstermodus für den Start des Webclients

Konfiguration der Beispielseite


Die Seite index.htm

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel von der Webserver DVD -> Die Seite index.htm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Seite index.htm ist die Startseite für unser Beispiel. Sie startet per Default in Englisch und kann direkt auf der Seite, rechts oben, in andere Sprachen umgeschaltet werden.

Die Seite index.htm:

  • informiert über kompatible Browser
  • bietet Links zum Start der zenon Webclients
  • bietet Link zur Installation der zenon Webclient Controls; diese sind nötig, wenn auf dem Rechner mit dem Weblient kein zenon installiert ist
  • ruft beim Start des Webclients die Projekteinstiegsseite init.htm auf, die auch den Browsercheck durchführt

Noch in diesem Kapitel

HTML-Code für index.htm


HTML-Code für index.htm

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel von der Webserver DVD -> Die Seite index.htm -> HTML-Code für index.htm

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der HTML-Code der Beispiel-Einstiegsseite index.htm:

<?xml version="1.0" ?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

<link rel="stylesheet" type="text/css" href="ressources/style.css" />

<title>COPA-DATA :: zenon webserver demo</title>

</head>

<body>

<div class="bodywrap1">

<div class="bodywrap2">

<div class="main">

<div class="innerheader">

<div class="languageSwitch">

<ul>

<li><a href="index_de.htm">Deutsch</a></li>

<li><a href="index.htm">English</a></li>

<li><a href="index_it.htm">Italiano</a></li>

<li><a href="index_fr.htm">Francais</a></li>

<li><a href="index_es.htm">Español</a></li>

</ul>

</div><!-- languageSwitch -->

<a href="http://www.copadata.com" target="_blank"><img src="ressources/logo.png" alt="COPA-DATA Home" /></a>

</div><!-- inner header -->

<div class="content">

<h1>zenon webserver</h1>

<p> This page is an example how to realize the web access to a zenon Runtime server via the zenon Webserver.</p>

<h3>System requirements</h3>

<p>The web client can be used by several browsers. The following browsers have been tested:</p>

<ul>

<li>Microsoft Internet Explorer version 3.x - 9.x</li>

<li>Mozilla Firefox version 3.6.4 - 4.x</li>

<li>Google Chrome version 7.x</li>

<li>Apple Safari (only Windows) version 5.x</li>

</ul>

<h3>Configuration of Mozilla Firefox</h3>

<p>For Mozilla Firefox you need at least version 3.6.4 or higher. You must carry out the following adjustments in the Firefox configuration:</p>

<ul>

<li>Enter &quot;about:config&quot; in the address line.</li>

<li>If the browser displays the message &quot;This might void your warranty&quot;, press button &quot;I’ll be careful, I promise&quot;.</li>

<li>Property &quot;dom.ipc.plugins.enabled&quot; must be set to &quot;true&quot;. If not, you must set the property as follows:

<ul>

<li>Right click on the property</li>

<li>Click on &quot;Toggle&quot; in the shown context menu</li>

</ul>

If you do not apply these settings, the web client cannot communicate with the zenon Runtime in Firefox. The screens are shown but all variables are displayed as offline. </li>

</ul>

<p>&nbsp;</p>

<h2>Installation of the zenon webclient control </h2>

<p>For this method of installation the zenon webclient control has to be downloaded and installed by hand. After the successful installation of the zenon webclient control the defined project can be started.</p>

<div style="margin: 0px auto 0px auto" >

<div class="startdown">

<h3>Start the zenon webclient</h3>

<img src="ressources/start-windowed.png" width="71" height="80" alt="Start the zenon web client" onclick="window.location.href='init.htm'" />

<img src="ressources/start-new-window.png" width="71" height="80" alt="Start the zenon web client in a new window" onclick="window.open('init.htm','WindowTitle','width=1024,height=768')" />

<img src="ressources/start-fullscreen.png" width="71" height="80" alt="Start the zenon web client in full-screen mode" onclick="window.open('init.htm','WindowTitle','fullscreen')" />

</div>

<div class="startdown">

<h3>Install the zenon webclient control</h3>

<img src="ressources/download-700.png" width="71" height="80" alt="Download the zenon client control setup (7.00 SP0)" onclick="window.location.href='controlversions/version700SP0/WEB_Client_Setup_ENGLISH.EXE'" />

<img src="ressources/download-651.png" width="71" height="80" alt="Download the zenon client control setup (6.51 SP0)" onclick="window.location.href='controlversions/version651SP0/WEB_Client_Setup_ENGLISH.EXE'" />

<img src="ressources/download-622.png" width="71" height="80" alt="Download the zenon client control setup (6.22 SP1)" onclick="window.location.href='controlversions/version622SP1/WEB_Client_Setup_ENGLISH.EXE'" />

</div>

</div>

<h2>General structure</h2>

<p> For displaying zenon projects in the web browser the zenon webclient control has to exist on the webclient.</p>

<p> Info: The client control has to be of the same version (e.g. 6.51 SP0) as the Runtime server.</p>

<p> Some configuration data (version info, project name, name of the zenon webserver PC, name of the zenon Runtime server PC, and others) have to be known, so that the client control can find the zenon Runtime server. These data have to be entered in the configuration file &quot;\config\global_vars.js&quot;. You can edit this file with a standard text editor (Notepad).</p>

<p> You will find more information in the zenon Webserver documentation.</p>

<p>&nbsp;</p>

</div>

</div><!-- main -->

</div><!-- bodywrap2 -->

</div><!-- bodywrap1 -->

</body>

</html>


Wahl des Fenstermodus für den Start des Webclients

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel von der Webserver DVD -> Wahl des Fenstermodus für den Start des Webclients

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Links zum Start des zenon Webclients können unterschiedlich ausgeführt sein:

Der zenon Webclient kann in unterschiedlichen Modi gestartet werden:

  1. Standard
  2. Neues Fenster
  3. Fullscreen

1. Standard

Der zenon Webclient - und damit das Projekt - wird innerhalb des HTML Framesets angezeigt.

<html>
<head>
</head>

<body>
<a href= ../ init. html >Link_für_Stardard</a>
</body>
</html>

2. New Window

Der zenon Webclient - und damit das Projekt - wird in einem neuen Browser Fenster im normalen Modus geöffnet.

<html>
<head>
</head>

<body>
<a href= ../ init . html target=_blank>Link_für_Stardard</a>
</body>
</html>

3. Fullscreen

Der zenon Webclient - und damit das Projekt - wird mit Hilfe eines Java-Scripts, in einem neuen Browser Fenster im Vollbildmodus geöffnet. Der Pfad der index.html wird dabei global in der Java-Script Funktion definiert.

<html>
<head>
<script>
<!--
function fullwin(){
window.open( ../projekt_M.htm ,,fullscreen)
}
//-->
</script>
</head>

<body>
<a href=# onclick=javascript:fullwin()>Link_für_Fullscreen</a>
</body>
</html>


Konfiguration der Beispielseite

Handbuch -> zenon Webserver und zenon Webserver Pro -> Erstellen der HTML-Seite für den Projekteinstieg -> Beispiel von der Webserver DVD -> Konfiguration der Beispielseite

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Setup wird der zenon Webserver mitinstalliert.

Im Ordner C:\inetpub\wwwroot\zenon\config kann die Konfigurationsdatei Global_vars.js in einem Texteditor geöffnet werden.

Konfiguration

Redundanter zenon Webserver (ab Webclient 6.01):

Parameter

Beschreibung

Projectname

Legt Name des Runtimeprojekts fest.

var PROJECTNAME = "NAME";

Zum Beispiel:

var PROJECTNAME = "zenon";

Hinweis: Das Projekt muss auf dem angegeben Runtime Server als Serverprojekt laufen.

RuntimeServer

Gibt den Zielrechner, auf dem die Runtime für das Projekt läuft an.

var RUNTIMESERVER = "NAME";

Zum Beispiel:

var RUNTIMESERVER = "T13-XPDE32";

Hinweis: Nur Großbuchstaben verwenden. Rechnernamen ohne Domainsuffix angeben.

Der Name muss mit dem Servernamen in der Projektkonfiguration übereinstimmen, siehe auch: Projektkonfiguration zenon 5.x und Projektkonfiguration zenon 6.x.

Redundanz Runtime-Server

Bei redundanten Runtime-Projekten wird nur der Name des Servers angegeben, nicht der Name des Standby-Servers. Der Name des Standby-Servers ist in der project.ini des Projekts gespeichert. Der zenon Webclient speichert diese bei der ersten Verbindung mit dem Runtime Server lokal. Das bedeutet: Bei der ersten Verbindung mit einem redundanten Projekt muss der Runtime Server online sein. Bei jeder weiteren Verbindung funktioniert dann das Redundanzkonzept, d.h. der zenon Webclient versucht, zuerst eine Verbindung mit dem Runtime Server aufzubauen. Wenn dieser nicht erreichbar ist, wird automatisch eine Verbindung mit dem Standby Server aufgebaut.

Redundanz Webserver

Wenn neben dem zenon Runtime-Server auch der zenon Webserver redundant betrieben werden soll, müssen:

  • zwei zenon Webserver auf unterschiedlichen Rechnern installiert und lizenziert werden
  • müssen bei der Variablendeklaration in der HTML Seite beide zenon Webserver durch einen Beistrich getrennt angeben werden:

    var WEBSERVER = WEBSERVER,WEB-STANDBY-SERVER";

Webserver

Gibt den Zielrechner an, auf dem der zenon Webserver installiert wurde, an. Achtung: Das ist nicht der Publishing Server!

var WEBSERVER = "NAME";

Zum Beispiel:

var WEBSERVER = "CD1111";

Hinweis: Nur Großbuchstaben verwenden. Rechnernamen ohne Domainsuffix angeben.

Initfunction

Legt eine zenon Funktion fest, die beim Starten des Projekts im Browser ausgeführt wird.

var INITFUNCTION = "Init";

Zum Beispiel:

var INITFUNCTION = "Init";

Default: "Init"

Hinweis: Die Schreibweise muss mit dem Funktionsnamen in zenon übereinstimmt (Groß-/Kleinschreibung) .

Zoom

Definiert, ob das Projekt in der Browseransicht gezoomt werden kann.

var ZOOM = "WERT";

0: OFF

1: ON

Zum Beispiel:

var ZOOM = "0";

Hinweis: Die Zoomanpassung wird nur beim Initialisieren übernommen, nicht, wenn die Runtime bereits läuft. Wird eine bestimmte Größe gewünscht ist, muss diese vom Active X Control definiert werden.

var VERSION

Legt die zenon Webclient Version fest.

var VERSION = "WERT";

zum Beispiel:

var VERSION = "6,50,1,0";

Diese muss immer gleich der oder höher als die zenon Runtime Version sein.

Zusätzliche Parameter

Die Parameter width/height geben die Position der Scrollbalken im Browser an Größe des ActiveX Controls (zenon Webclient) im Browser an. Default ist dabei 100%.

info Info

Werden die Scrollbalken auf 105% parametriert, dann werden sie in den nicht sichtbaren Bereich des Browsers verschoben.
Die Parameter ScrollV und ScrollH geben an, wohin der Browser beim Starten des zenon Webclients scrollen soll. Default ist 0. Diese Einstellung können Sie nutzen, wenn sich ihre Bedienleiste am unteren Bildschirmrand befindet. Dann können Sie den Browser bei Projektstart bereits dorthin scrollen lassen. Damit sehen die Benutzer die Bedienleiste sofort beim Starten des Projekts und müssen nicht erst scrollen.

Für VBA oder andere Anbindungen

Ein Webclient-Control (CD_IClient) kann mit Hilfe einer externen Applikation (z.B. VBA, C# etc.) implementiert werden, ohne den Standard Webclient mittels Internet Explorer zu benutzen.

Create: in Übereinstimmung mit den angegebenen Parameter (Projekt, Server, Webserver) kann eine Verbindung mithilfe von "create" initialisiert werden. Dadurch wird dann die Verbindung zum Runtime Server gestartet (ActiveX initialisiert).
GetApplication: Zugriff auf die zenon COM-Objekte (VBA-Schnittstelle) der Runtime. Dadurch ist es möglich, auf die Runtime Objekte des aktiven zenon Projekts (Application.Projects.Item. ...) zuzugreifen.

Start des zenon Webclients

Durch einen Doppelklick auf die Seite init.html im Ordner C:\inetpub\wwwroot\zenon können Sie den zenon Webclient jederzeit starten und testen.


Fehlerbehandlung

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bekannte Fehlermeldungen oder Ausführungsfehler:

  • Absturz nach Browser Refresh
  • ActiveX control failed to load
  • ActiveX control nicht korrekt installiert
  • Ausnahmefehler Webclient ab Internet Explorer 8
  • HTTP Fehlermeldungen
  • Init Runtime Error
  • Keyboards in Firefox
  • Max. Clients erreicht

Noch in diesem Kapitel

Absturz nach Browser Refresh

ActiveX control failed to load

ActiveX control nicht korrekt installiert

Ausnahmefehler Webclient ab nternet Explorer 8

HTTP Fehlermeldungen

Init Runtime Error

Keyboards in Firefox

Max. Clients erreicht


Absturz nach Browser Refresh

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> Absturz nach Browser Refresh

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Verwendung des Internet Explorers 6 mit dem zenon Webclient kann es zu einem Absturz des IE kommen, wenn die Schaltfläche Refresh betätigt wird. Daher raten wir von der Verwendung der Schaltfläche Refresh ab.

Diese Schaltfläche bewirkt eine völlige Entladung und einen Neustart des zenon Webclients. Das bedeutet, dass die Verbindung zum Runtime Server unterbrochen wird und vom Webclient erst wieder neu aufgebaut werden muss.

Error 101

Falls auf dem Client Rechner bereits ein zenon Webclient installiert war, kann es beim Verbinden vom zenon Webclient zum zenon Webserver bzw. Runtime Server folgende Fehlermeldungen auftreten:
Error 101
Das Projekt XXX wurde mit der Version XXX bearbeitet, und kann hier nicht geöffnet werden
In diesem Fall:

  1. Webclients deinstallieren
  2. Rechner neu starten
  3. zenon Webclient neu installieren


ActiveX control failed to load

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> ActiveX control failed to load

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn der Browser einen Init Runtime Error ausgibt, gibt es mehrere möglich Ursachen dafür. Die wahrscheinlichste:

  • Die Sicherheitseinstellungen des Browsers verhindern das korrekte Ausführen des ActiveX Controls.


ActiveX control nicht korrekt installiert

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> ActiveX control nicht korrekt installiert

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn der Browser nach dem Aufruf der Projekteinstiegsseite nur ein X anzeigt anstelle der Runtime:

  • wurde das ActiveX Control für den zenon Webclient nicht korrekt installiert
  • die falsche Version des zenon Webclients installiert


Ausnahmefehler Webclient ab nternet Explorer 8

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> Ausnahmefehler Webclient ab nternet Explorer 8

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehler

Der Webclient wird mit einem Ausnahmefehler beendet, wenn im Projekt VSTA oder VBA ausgeführt wird.

Ursache

Der Microsoft Internet Explorer verfügt ab Version 8 über eine Einstellung zum Speicherschutz. Ist diese aktiv, führt das Ausführen von VBA zu einem Ausnahmefehler und zum Beenden des Internet Explorers. VSTA aktiviert immer auch VBA.

Behebung

Deaktivieren Sie den Speicherschutz im Internet Explorer unter:

Extras->Internetoptionen->Erweitert->Speicherschutz aktivieren, um das Risiko von Onlineangriffen zu verringern


HTTP Fehlermeldungen

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> HTTP Fehlermeldungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Fehlermeldungen und ihre Bedeutung:

Eintrag | Level | Erklärung
NetSrv Error Do Send HTTP failed! HTTP-Status: [HTTP-Status] | ERRORS | Der HTTP Webserver hat einen HTTP-POST-Request mit einem Fehler beantwortet.
NetSrv Error Do Send HTTP failed! | ERRORS | Die HTTP-POST-Anfrage ist fehlgeschlagen (z.B. Timeout).
NetSrv Error Do Send HTTP Server failed! Data Management Class Error! | ERRORS | Beim Speichern einer Nachricht in den Puffer am HTTP Webserver ist ein Fehler aufgetreten. Der Fehler ist in der Datenmanagementklasse aufgetreten.
NetSrv Error Do Send HTTP Server failed! | ERRORS | Beim Speichern einer Nachricht in den Puffer am HTTP Webserver ist ein Fehler aufgetreten. Der Fehler ist in der Pufferliste aufgetreten.
NetSrv Error Do Recv HTTP failed! HTTP-Status: [HTTP-Status] | ERRORS | Der HTTP Webserver hat einen HTTP-GET-Request mit einem Fehler beantwortet.
NetSrv Error Do Recv HTTP failed! | ERRORS | Die HTTP-GET-Anfrage ist fehlgeschlagen (z.B. Timeout).
NetSrv Error Do Recv HTTP Server failed! Data Management Class Error! | ERRORS | Beim Lesen einer Nachricht aus dem Puffer am HTTP Webserver ist ein Fehler aufgetreten. Der Fehler ist in der Datenmanagementklasse aufgetreten.
NetSrv Error Do Recv HTTP Server failed! Buffer Too Small! | ERRORS | Das aus der Pufferliste gelesene Paket ist zu groß für den Datenpuffer. Hinweis: Aufgrund der einheitlichen maximalen Paketgröße, die auch als Pufferlängendefinition dient, sollte dieser Fehler eigentlich nie auftreten.
NetSrv Error Do Recv HTTP Server failed! Error While Copying Data Into Buffer! | ERRORS | Beim Kopieren der Daten aus der Pufferliste ist ein Fehler aufgetreten.
Error Out Of Memory While Adding Data to HTTP GET Response | ERRORS | Das Anlegen eines Speicherbereichs beim Zusammenstellen einer HTTP Antwort am HTTP Webserver war nicht möglich.
Error On Adding Data to HTTP GET Response | ERRORS | Beim Kopieren der Daten aus der Pufferliste in die HTTP Antwort ist ein Fehler aufgetreten.
HTTP Send Get Response Failed: [Status] | ERRORS | Das Senden der Antwort auf eine HTTP-GET-Anfrage ist fehlgeschlagen. Der Statuscode ist ein System-Error-Code (in der MSDN Library nachschlagbar).
Error Out Of Memory While Receiving Data from HTTP POST | ERRORS | Das Anlegen eines Speicherbereichs beim Auslesen einer HTTP-POST-Anfrage am HTTP Webserver war nicht möglich.
Error on Receiving Data from HTTP POST [Status] | ERRORS | Das Auslesen der Daten aus der HTTP-POST-Anfrage ist fehlgeschlagen. Der Statuscode ist ein System-Error-Code (in der MSDN Library nachschlagbar).
Error Data Block Of HTTP Post Request Too Large | ERRORS | Die Daten der empfangenen Anfrage überschreiten die definierte maximale Paketgröße.
HTTP Send Post Response Failed: [Status] | ERRORS | Das Senden der Antwort auf eine HTTP-POST-Anfrage ist fehlgeschlagen. Der Statuscode ist ein System-Error-Code (in der MSDN Library nachschlagbar).
Error Out Of Memory While Parsing HTTP Request | ERRORS | Das Anlegen eines Speicherbereichs beim Weitergeben einer HTTP-Anfrage an den zuständigen Thread war nicht möglich.
Memory Error on Creating Receive Buffer | ERRORS | Das Anlegen eines Speicherbereichs beim Erstellen des HTTP-Empfangspuffer war nicht möglich.
Error on Creating HTTP Request Event | ERRORS | Das Erstellen des Events für den Empfang von HTTP Anfragen ist fehlgeschlagen.
Error While Waiting For HTTP Request: [Status] --> Exiting Listening Thread | ERRORS | Beim Warten auf eine HTTP Anfrage ist ein Fehler aufgetreten. Der Statuscode ist ein System-Error-Code (in der MSDN Library nachschlagbar).
Unexpected Result While Waiting For HTTP Request: [Status] --> Exiting Listening Thread | ERRORS | Das Warten auf eine HTTP Anfrage lieferte ein nicht erwartetes Ergebnis. Der Statuscode ist ein System-Error-Code (in der MSDN Library nachschlagbar).
HTTP-Request Without ID Received | ERRORS | Die Verbindungs-ID in der HTTP-Anfrage war nicht vorhanden.
Error on Extracting HTTP-Request-ID From URL | ERRORS | Die Verbindungs-ID der HTTP-Anfrage konnte nicht ausgelesen werden.
Error: Closing HTTP Connection ID [ID] Could Not Be Resolved | ERRORS | Es wurde versucht, eine nicht vorhandene oder bereits geschlossene Verbindung zu schließen. Dieser Fehler ist weniger kritisch, da die Aufforderung zum Löschen der Verbindungs-ID beim Aufräumen der Ressourcen einer Verbindung nach deren Ende öfter als einmal erfolgen kann.
HTTP-Request With Incompatible ID Format Received | ERRORS | Die Verbindungs-ID in der HTTP Anfrage hat nicht das erwartete Format.
Could Not Assign New HTTP ID Because The Map Is Full | ERRORS | Eine neue Verbindung konnte nicht akzeptiert werden, da kein Platz in der Verbindungsliste mehr ist. Die Liste bietet Platz für über 4,2 Milliarden Verbindungen, daher sollte diese Nachricht nie auftauchen.
Error During HTTP-Accept | ERRORS | Beim Akzeptieren einer HTTP Verbindung ist ein Fehler aufgetreten.
Error On Sending HTTP ID: [Status] | ERRORS | Das Senden der HTTP Antwort mit der Verbindungs-ID für die neue Client-Verbindung ist fehlgeschlagen. Der Statuscode ist ein System-Error-Code (in der MSDN Library nachschlagbar).
Error: HTTP Connection ID [ID] Could Not Be Resolved | ERRORS | Die Verbindungs-ID der HTTP-Anfrage konnte nicht aufgelöst werden.
Error: HTTP Request Could Not Be Assigned To The Socket | ERRORS | Die HTTP-Anfrage konnte nicht an den zuständigen Thread weitergegeben werden.
Unsupported HTTP-Request Received | ERRORS | Eine nicht unterstützte HTTP-Anfrage wurde Empfangen. Unterstützt werden GET und POST Anfragen.
Error While Receiving HTTP Request: [Status] --> Exiting Listening Thread | ERRORS | Beim Empfangen einer HTTP Anfrage ist ein Fehler aufgetreten.
Error on Removing HTTP Connection ID From The Map! | ERRORS | Beim Entfernen einer Verbindungs-ID aus der Liste ist ein Fehler aufgetreten. Verbindungs-IDs werden entfernt, wenn eine Verbindung geschlossen wird.
Removing HTTP Connection ID [ID] From The Map! | DEBUG | Die Verbindung wurde geschlossen und die ID wurde aus der Liste entfernt.
Error on Removing Non-Active HTTP Connection ID From The Map! | ERRORS | Beim Entfernen der Verbindungs-ID einer inaktiven Verbindung ist ein Fehler aufgetreten. Eine Verbindung ist dann inaktiv, wenn 5 Minuten lang keine HTTP-Anfragen empfangen wurden. Eigentlich sollte eine solche Verbindung schon vorher wegen dem Ausbleiben von Watchdogs entfernt werden.
Removing Non-Active HTTP Connection ID [ID] From The Map! | DEBUG | Die Verbindungs-ID wurde aus der Liste entfernt, da die Verbindung inaktiv ist. Eine Verbindung ist dann inaktiv, wenn 5 Minuten lang keine HTTP-Anfragen empfangen wurden. Eigentlich sollte eine solche Verbindung schon vorher wegen dem Ausbleiben von Watchdogs entfernt werden.
Error While Waiting for HTTP Connection Map Check [Status]! | ERRORS | Der Thread zum Prüfen der Verbindungs-ID hat beim Warten auf den nächsten Zyklus einen Fehler festgestellt und wird beendet. Der Statuscode ist ein System-Error-Code (in der MSDN Library nachschlagbar).
NetSrv Accept HTTP Client Socket Error On Starting HTTP Reply Thread | ERRORS | Der Thread zur Beantwortung von HTTP Anfragen konnte nicht gestartet werden.
NetSrv Info Accept HTTP Client IP:[IP-Adressr]:[Port] Ok | DEBUG | Die HTTP Verbindung wurde erfolgreich angenommen.
NetSrv Memory Error Do Recv HTTP failed! | ERRORS | Es ist ein Fehler wegen zu wenig Arbeitsspeicher beim Empfangen von Daten über HTTP Tunnelling aufgetreten.

LOG-Einträge aus CNSBlockingSocketExceptions

Level: immer ERRORS

Eintrag: Exception-Text | Erklärung
Connect: HTTP Error | Der HTTP Webserver hat eine Verbindungs-ID-Anfrage mit einem Fehler beantwortet.
Connect: ID-Data did not have the expected Format | Die vom HTTP Webserver gelieferte Verbindungs-ID hat nicht das erwartete Format.
Connect: Server denied HTTP ID | Der HTTP Webserver hat die Erteilung einer Verbindungs-ID abgelehnt.
Connect: Error during ID-Acquisition | Beim Anfragen um eine Verbindungs-ID ist ein Fehler aufgetreten (z.B. Timeout).
HttpInitialize Failed | HTTP Server API konnte nicht initialisiert werden
HttpCreateHttpHandle Failed | Die HTTP Anfragen Liste konnte nicht erzeugt werden
HttpAddUrl Failed | Der Server konnte nicht in den Listen-Modus gehen


Init Runtime Error

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> Init Runtime Error

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn der Browser einen Init Runtime Error ausgibt, gibt es mehrere mögliche Ursachen dafür:

  • Runtime am Runtime Server ist nicht aktiv
  • SERVERNAME in Globalvars.js ist falsch geschrieben oder falsch angegeben (immer Großbuchstaben verwenden).
  • PROJEKTNAME in Globalvars.js ist falsch geschrieben oder falsch angegeben (immer Großbuchstaben verwenden).
  • Der zenon Webserver ist nicht gestartet.

Hinweise zur Fehlerursache finden Sie eventuell auch in der Datei zenNetErr.txt . Diese zeichent Netzwerkinformationen auf.


Keyboards in Firefox

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> Keyboards in Firefox

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn individuelle Keyboards in Firefox nicht korrekt funktionieren, beachten Sie folgenden Hinweis:

attention Achtung

Individuell angepasste Bilder vom Typ Keyboard funktionieren unter Umständen mit dem Browser Mozilla Firefox nicht korrekt.

Ursache: Mozilla Firefox lädt neue Fenster im Hintergrund, ohne ihnen den Fokus zu geben. Individuell angepasste Keyboard-Bilder werden aber geschlossen, sobald sie den Fokus verlieren.

Lösung: Benutzen Sie einen anderen Browser wie z.B. Microsoft Internet Explorer, Apple Safari oder Google Chrome.

Automatische Keyboards sind nicht betroffen!


Max. Clients erreicht

Handbuch -> zenon Webserver und zenon Webserver Pro -> Fehlerbehandlung -> Max. Clients erreicht

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Meldung auf dem zenon Webclient.

Mehr Clients als lizenziert, versuchen, sich zum zenon Webserver zu verbinden.


zenon Webserver in eine Internetumgebung einbinden

Handbuch -> zenon Webserver und zenon Webserver Pro -> zenon Webserver in eine Internetumgebung einbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um den zenon Webserver in eine Internetumgebung einzubinden:

  • muss eine eventuell vorhandene Firewall entsprechend konfiguriert werden:
    • Der Port 1102 auf der Firewall muss für eingehende Pakete offen sein, damit ein zenon Webclient auf einen zenon Webserver und damit auf einen Runtime Server zugreifen kann.
    • NAT (Network Address Transformation) muss auf der Gateway-Station laufen. NAT wandelt die interne LAN Adresse in die Adresse der Gateway-Station um. Wenn z.B. jemand innerhalb des LAN surft, sieht es von außen so aus, als ob immer die Gateway-Station die Anfragen senden würde.
    • Statische IP-Adresse für zenon Webserver:
      Die Firewall auf der Gateway-Station muss so konfiguriert sein, dass alle eingehenden Pakete für den Port 1102 automatisch an die Station mit dem zenon Webserver gesendet werden. Das beduetet: Diese Station muss über eine statischen IP-Adresse verfügen.
  • muss die Projekteinstiegsseite angepasst werden, damit der zenon Webclient weiß, auf welche Station im Internet er zugreifen muss. Die Anpassung erfolgt in global_vars.js bzw bei älteren Versionen in project_A_X.html (X steht für die Sprachversion wie G für German) :
    • Unter WebServer VALUE= WEB-SERVERNAME muss der Computername der Gateway-Station (die Station, die vom Internet aus sichtbar ist) und nicht der Computername des echten zenon Webservers eingegeben werden. Der echte Webserver ist vom Internet aus nicht sichtbar. Die Gateway-Station leitet die Anfragen des zenon Webclients auf den Port 1102 dann automatisch an den echten zenon Webserver weiter.


Zuweisungen

Handbuch -> Zuweisungen

Zuweisungen ermöglichen es, den aktuellen Wert einer Variablen auf eine zweite Variable innerhalb eines Treibers oder treiberübergreifend zu rangieren.

tutorial Lizenzinformation

In Standardlizenz für Editor und Runtime enthalten.

zenon erlaubt es, Werte aus der Steuerung direkt in eine SQL-Datenbank oder spontane Wertänderungen von einem Treiber in einen zweiten Treiber zu schreiben. Zuweisungen können projektübergreifend erfolgen.

Achtung: Projektübergreifende Zuweisungen werden erst nach dem Laden aller Projekte ausgeführt.

Übertragung

Eine Zuweisung überträgt Wert, Status und Zeitstempel der Quellvariablen auf die Zielvariable.

Hinweis: Status und Zeitstempel können aktuell nur von folgenden Treibern verarbeitet werden:

  • Intern Treiber
  • SQL Treiber
  • AK Treiber (SICAM 230)

Die Status Echtzeit extern (T_EXTERN), Echtzeit intern (T_INTERN)und Sommer/Winterzeit Ankündigung (T_CHG_A) werden nicht übertragen. Diese werden vom Zeitstempel definiert.

Die Signalauflösung sollte für beide Variablen die gleichen Grenzen besitzen (Überlaufverhalten).

Die Übertragung des Wertes erfolgt bei Wertänderung: Wann immer die Quellvariable ihren Wert ändert, wird auch der Wert der Zielvariable geändert. Sollte der Wert der Zielvariable unabhängig von dem der Quellvariable geändert werden, so hat die Zielvariable den unterschiedlichen Wert so lange, bis der Wert der Quellvariable sich wieder ändert.

info Info

Auch Zuweisungen auf Intern Variablen werden nur auf dem Server ausgeführt.

Kontextmenü Projektmanager

Menüpunkt | Aktion
Zuweisung neu | Fügt eine neue Zuweisung in die Liste ein.
XML exportieren alle... | Exportiert alle Einträge in XML-Datei.
XML importieren... | Importiert XML-Dateien.
Hilfe | Öffnet die Online-Hilfe.

Noch in diesem Kapitel

Projektieren im Editor

Zuweisungen Detailansicht Symbolleiste und Kontextmenü

Trigger Variablen und Trigger-Art


Projektieren im Editor

Handbuch -> Zuweisungen -> Projektieren im Editor

Um Zuweisungen zu definieren:

  1. navigieren Sie im Projektmanager zum Unterknoten Zuweisungen im Knoten Variablen
  2. bereits bestehende Zuweisungen werden in er Detailansicht angezeigt
  3. wählen Sie aus dem Kontextmenü oder der Symbolleiste die gewünschte Aktion, z.B. Zuweisung neu
  4. im Eigenschaften-Fenster werden die Eigenschaften der Zuweisung angezeigt und können geändert werden

Eine Zuweisung benötigt unbedingt:

  • einen eindeutigen Namen
  • eine Quellvariable
  • eine Zielvariable

Beim Anwählen der Eigenschaften Quellvariable bzw. Zielvariable wird jeweils die Variablenliste zur Auswahl der gewünschten Variablen geöffnet. Als Quelle ist jede Variable jedes Treibers (ausgenommen String-Variablen) selektierbar. Die Zielvariable muss eine Lese/Schreib-Freigabe besitzen.

Interne ID: Projektieren im Editor

Zielvariable

Name der Variable, der der Wert der Quellvariable zugewiesen werden soll.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Interne ID: Projektieren im Editor

Quellvariable

Name der Variable, deren Wert der Zielvariable zugewiesen werden soll.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Jede Wertänderung der Quellvariablen wird an die Zielvariable der Zuweisung übertragen.

Über das Kontextmenü der Detailansicht des Projektmanagers lassen sich bestehende Zuweisungen ausschneiden, kopieren, einfügen und löschen.


Zuweisungen Detailansicht Symbolleiste und Kontextmenü

Handbuch -> Zuweisungen -> Zuweisungen Detailansicht Symbolleiste und Kontextmenü

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Kontextmenü

Menüpunkt | Aktion
Zuweisung neu | Fügt eine neue Zuweisung in die Liste ein.
Ausschneiden | Kopiert gewählte Einträge in Zwischenablage und löscht sie aus der Liste.
Kopieren | Kopiert ausgewählte Einträge in die Zwischenablage.
Einfügen | Fügt den Inhalt der Zwischenablage ein. Ist bereits ein Eintrag mit gleichem Namen vorhanden, wird der Inhalt als "Kopie von" eingefügt.
Löschen | Löscht ausgewählte Einträge.
Selektierte Zelle bearbeiten | Öffnet die ausgewählte Zelle zur Bearbeitung. Welche Zelle in einer markierten Zeile ausgewählt wurde, sehen Sie am Fernglas-Symbol in der Titelzeile.
Eigenschaften | Öffnet das Fenster Eigenschaften für den gewählten Eintrag.
Selektierte XML exportieren | Exportiert ausgewählte Einträge in XML-Datei.
XML importieren | Importiert XML-Dateien.
Filter entfernen | Entfernt alle Filtereinstellungen.
Hilfe | Öffnet die Online-Hilfe.


Trigger Variablen und Trigger-Art

Handbuch -> Zuweisungen -> Trigger Variablen und Trigger-Art

Für Zuweisungen können eine Triggervariable und eine Trigger-Art definiert werden. Damit können ereignisgesteuerte Zuweisungen definiert werden. Werte werden damit nicht mehr automatisch zugewiesen, sondern nur noch bei Wertänderung der Triggervariablen.

Folgende Konfigurationen sind möglich:

Triggervariable | Trigger Art | Ergebnis
nicht definiert |  | Jede Änderung in der Quellvariablen bewirkt, dass der Quellwert der Zielvariablen zugewiesen wird.
definiert | Flanke | Die Zuweisung wird nur dann ausgeführt, wenn die Triggervariable eine Wertänderung von 0 auf 1 erfährt. Nur eine positive Flanke der Bit Variable führt dazu, dass die Zuweisung ausgelöst wird. Die Zuweisung wird nicht mehr durch eine Änderung des Wertes in der Quellvariable automatisch angestoßen.
definiert | Pegel | Die Zuweisung wird immer ausgeführt, solange die Trigger Variable den Wert 1 hat. Jedes Mal, wenn sich der Wert der Quellvariable ändert, wird die Zuweisung aktiviert und der Wert wird in die Zielvariable geschrieben. Diese Zuweisung bleibt aktiv, bis sich der Wert der Triggervariablen wieder auf 0 ändert.


Treiber

Treiber

In diesem Bereich finden Sie alle zenon Treiberdokumentationen.


Tutorials

Tutorials

In diesem Bereich finden Sie alle zenon Tutorials.


Glossar

Glossar

In diesem Glossar werden relvante Begriffe, die in zenon verwendet werden, kurz erklärt.


A

Glossar -> A

abbrechen

Schließt einen Dialog und verwirft alle durchgeführten Änderungen.

Abfülllinie

Fertigungslinie in der Nahrungs- und Genussmittelindustrie im Rahmen der Befüllung von Getränkebehältern.

Abgerundetes Rechteck

Vektor-Element, das den Eckenradius eines Rechtecks mit Hilfe spezieller Eigenschaften oder eines Einstellpunkts stufenlos festlegen lässt.

Ablaufsprache

Eine der fünf in der IEC 61131-3 genormten Sprachen zur Programmierung einer SPS-Steuerung in Form eines Petri-Netzes (Schrittkette-Ablaufsteuerung).Eine Ablaufsteuerung ist eine Kette von Steuerungsschritten, welche durch Weiterschaltungsbedingungen (Transitionen) miteinander verbunden sind. Direkt an den Schrittsymbolen werden Befehle, auch Aktionen genannt, eingebunden. Beim Erreichen eines Steuerungsschrittes mit angehängter Aktion wird z.B. ein Ausgang gesetzt oder ein Programmsprung durchgeführt.

Absetzfortschritt

Prozentuelle Angabe, wie weit ein Rezept vom Leitsystem in die Steuerung abgesetzt wurde.

Absetzstatus

Statusinformation, welchen Zustand ein Rezept bei der Abarbeitung hat, z.B. in Abarbeitung, fertig, Fehler usw.

Absolutbetrag

Absolutbetrag ist immer eine nichtnegative, reelle Zahl, die bei einer reellen oder komplexen Zahl dem Abstand zu Null entspricht.

absolute Position

Von einem übergeordneten Objekt abhängige Position am Bildschirm. Die Schablonen orientieren sich am Monitor, Bildelemente an der Schablone, Symbolelemente am Symbol usw. Der Nullpunkt befindet sich in der linken oberen Ecke des übergeordneten Objektes.

absolute Schaltzeit

Zeitpunkt, zu dem ein Schaltpunkt ausgeführt wird.

absoluter Pfad

Definiert den Weg zu Dateien oder Ordnern unter Angabe von (Rechnername), Laufwerk und Ordnername. Dabei wird immer von einem Rechnernamen (UNC Pfad z.B. \\PC1) oder von einem Laufwerk als Startpunk ausgegangen (z.B. C:\).

absoluter Schaltpunkt

Verknüpft einen Zeitpunkt mit einer definierten Aktion.

absoluter Zeitpunkt

Zu genau diesem Zeitpunkt soll eine Aktion ausgeführt werden.

absoluter Zeitraum

Nicht vom momentanen Zeitpunkt abhängiger Zeitraum.

Abtastrate

Bezeichnet die Häufigkeit, mit der ein Signal pro Zeitintervall abgetastet wird.

Abwärtskompatibilität

Als Abwärtskompatibilität wird die Verwendbarkeit bzw. Kompatibilität neuerer oder erweiterter Versionen zu den Anwendungsbedingungen einer früheren Version bezeichnet.

Achse

Bezeichnet eine Koordinatenachse. Diese ist in der Mathematik der Sammelbegriff für:- die Abszisse (X-Achse), die horizontale (waagerechte) Koordinatenachse eines kartesischen Koordinatensystems und - die Ordinate (Y-Achse), die vertikale (senkrechte) Koordinatenachse desselben.

Achsenfarbe

Die Farbgebung einer Achse des karthesischen Koordinatensystems.

Achsentyp

Beschreibt, ob die Skalierung der Achse logarithmisch oder linear erfolgt.

Achsenunterteilung

Bestimmt die Anzahl der Ticks der Achse.

Active Directory Application Mode

Funktional eingeschränkte Version des Active Directory Verzeichnisdiensts, die der Anbindung von Anwendungen oder Diensten dient, die LDAP-konforme Informationen benötigen. Verfügbar unter Windows XP und Windows Server 2003. Wurde durch AD LDS abgelöst.Die zenon Benutzerverwaltung kann die Benutzerinformationen aus ADAM auslesen.

ActiveX

Bezeichnet ein Softwarekomponenten-Modell von Microsoft für aktive Inhalte. ActiveX-Komponenten erweitern die Component Object Model-Standards (COM) von Microsoft.

ActiveX Control

Dynamisches Element im Leitsystem oder Steuerelement für VBA/VSTA auf Basis der Microsoft ActiveX Technologie.

ActiveX Einstellungen

Parameter, die die Arbeitsweise eines ActiveX Elements regeln.

ActiveX Interface

Ermöglicht Übergabe von Daten/Steuerbefehlen an ActiveX.

AD-LDS

Funktional eingeschränkte Version des Active Directory Verzeichnisdiensts, die der Anbindung von Anwendungen oder Diensten dient, die LDAP-konforme Informationen benötigen. Verfügbar ab Windows Vista, Windows Server 2008.Die zenon Benutzerverwaltung kann die Benutzerinformationen aus AD LDS auslesen.

Administrationsdienst

Prozess (zenAdminSrv.exe), der für die Ausführung aller zenon Applikationen (Editor, Runtime, Startup Tool usw.) erforderlich ist.

Adresse

Bezeichnet den Bereich einer Speicherstelle in einer Steuerung.

Adressierung

Die Adressierung beschreibt den Weg, wie ein Speicherort lokalisiert wird.

Agent

Kleines Programm, das Geräte überwacht, mit denen zenon Treiber bidirektional kommunizieren, und mit dem man auch Einstellungen vornehmen kann.

Aggregat

Physikalisch verfügbarer Maschinen- oder Anlagenteil, mit dem Grundfunktionen ausgeführt werden können. (ISA 88: Unit)

Aggregatfreigabe

Element des Moduls Batch Control, das die Belegung eines Aggregats im Aggregatmanager aufhebt. Dadurch ist das Aggregat wieder durch andere Rezepte belegbar.

Aggregatmanager

Interner Verwaltungsmechanismus, der für alle REE in der Runtime die Aggregatsbelegungen verwaltet.

Aggregatsbelegung

Element des Moduls Batch Control, das die Belegung eines Aggregats im Aggregatmanager bewirkt. Ein belegtes Aggregat kann nur von Grundfunktionen innerhalb des Rezepts verwendet werden. Damit ist das Aggregat für Grundfunktionen anderer, parallel ablaufender Rezepte gesperrt.

Aktion

Im Bereich Batch Control: Alle Befehle, die bei der Bearbeitung des Rezepts verwendet werden, z.B.: Grundfunktion einfügen, Rezept testen usw..

Aktionstext

Bestimmt den Text in der Befehlsgabe, der zu der zugehörigen Aktion wie z.B. Sollwertvorgabe, Statusvorgabe usw. zugeordnet ist.

Aktionsvariable

Variable, die bei der Befehlsgabe den Wert/Status zur Steuerung absetzt.

Aktivierungsnummer

Individuelle Zeichenfolge, die das Produkt freischaltet. Die Nummer wird gegen die Seriennummer + Donglenummer bzw. die Seriennummer + Lizenznummer geprüft.

Aktor

Technische Einrichtung, die eine Eingangsgröße in eine andersartige Ausgangsgröße umwandelt um eine Aktion oder einen Effekt hervorzurufen. In der Steuer- und Regelungstechnik bezeichnen Aktoren das wandlerbezogene Gegenstück zu Sensoren und bilden die Stellglieder in einem Regelkreis. Sie setzen Signale einer Regelung in (meist) mechanische Arbeit (Bewegung) um. Ein Beispiel ist das Öffnen und Schließen eines Ventils.

aktueller Wert

Der zum Zeitpunkt der Abfrage gültige Wert einer Variablen.

Alarm

Ein Alarm soll auf ein Ereignis aufmerksam machen. Er wird durch eine Grenzwertverletzung ausgelöst.Die Verwaltung der Alarme erfolgt in der Alarmmeldeliste (AML).

Alarm/Ereignis-Gruppe

Dient zur Gruppierung von Ereignissen in AML/CEL. Kann frei verwendet werden z.B. für die örtliche Zuordnung zu Bereichen, aber auch für die Gruppierung nach Prioritäten wie Meldung, Störung, Alarm usw.Im Gegensatz zu den Alarm/Ereignis-Klassen können die Alarm/Ereignis-Gruppen von der Steuerung abgemeldet werden.

Alarm/Ereignis-Klasse

Dient zur Klassifizierung von Ereignissen in AML/CEL. Kann frei verwendet werden z.B. für die örtliche Zuordnung zu Bereichen, aber auch für die Gruppierung nach Prioritäten wie Meldung, Störung, Alarm usw.Im Gegensatz zu den Alarm/Ereignis-Gruppen können die Alarm/Ereignis-Klassen für die Einfärbung der AML/CEL verwendet werden.Ebenso können die Alarm/Ereignis-Klassen Alarmbereichen zugeordnet werden.

Alarmbereich

Dient dazu Alarm/Ereignis-Klassen zu gruppieren. Über den Alarmbereich können Statusinformationen wie z.B. die Anzahl der unquittierten Alarme im Bereich abgefragt werden.Diese Statusinformationen können dazu genutzt werden eine Bildalarmierung aufzubauen.

Alarmbereich-Eintrag

Ordnet eine Alarm/Ereignis-Klasse einem Alarmbereich zu. Jeder Eintrag verfügt über Statusvariablen, die den Zustand aller Alarme in der Alarm/Ereignis-Klasse anzeigen.

Alarm-Eintrag

Ein einzelnes Ereignis, das in der Alarmmeldeliste gespeichert ist.

Alarmmeldeliste

Liste zum Anzeigen und Bearbeiten von Alarmen. Die Alarmmeldeliste wird doppelt geführt: Einmal als Ringpuffer im Speicher und einmal als historische Daten in Dateien auf der Festplatte.Im Gegensatz zur Chronologischen Ereignisliste verwaltet die Alarmmeldeliste drei Zeitstempel: kommt, geht, quittiert.

Alarmmeldeliste Filter

Bildtyp, mit dem benutzerspezifische Filterbilder für die Alarmmeldeliste projektiert werden können.

Alarm-S Begleitwert

Treiber-Objekttyp, der den Begleitwert des S7-PDiag Systems in das Leitsystem überträgt. Der Begleitwert enthält z.B. die Schrittnummer des gestörten Schritts in S7-Graph.

Alarm-S Meldung

Treiber-Objekttyp, der Informationen des S7-PDiag Systems in das Leitsystem überträgt. Auf dem Offset 0 wird die Meldungsnummer mit dem Datentyp UDINT übertragen.Auf dem Offset der Meldungsnummer wird als BOOL übertragen ob die Meldung ansteht.

Alarm-S Telegramm

Alarmmeldungen des Siemens Simatic S7 PDIAG Systems.Die Telegramme können mittels S7TCPC Treiber aus der Steuerung ausgelesen werden und direkt als Alarm-Einträge in die Alarmmeldeliste übernommen werden.

Alarm-S Variable

Eine Variable, die auf dem Treiber-Objekttyp Alarm-S Meldung basiert.

Alarmstatistik

Auswertung der Alarme (Dauer, Häufigkeit usw.) mit Hilfe des Industrial Performance Analayzers.

Alarmstatuszeile

Informationszeile, die in der Runtime immer im Vordergrund vor allen Programmen dargestellt wird und den ältesten oder den jüngsten unquittierten Alarm anzeigt.

Alarmursache

Frei definierbare Ursachen für das Auftreten eines Alarms im Industrial Performance Analyzer. Die möglichen Alarmursachen werden in einer Liste verwaltet und können im IPA Alarmen zugeordnet werden. Alarmursachen können als Filterkriterium benutzt werden.

Alarm-Variable

Variable, die für die Siemens Bildalarmierung verwendet wird.

Alarmverwaltung

Modul zur Darstellung und Verwaltung von Alarmen.Zugehörige Elemente sinde: Alarmmeldeliste, Alarmstatuszeile, Alarm/Ereignis-Gruppen, Alarm/Ereignis-Klassen, Alarmbereiche, Funktionen usw.

Alarmzustand

Gibt an, ob ein Alarm "anstehend" oder "gegangen" ist.

Analogsignal

Bezeichnet ein Signal, dessen Stärke (Amplitude) kontinuierlich jeden Wert zwischen einem Minimum und einem Maximum annehmen kann. Dies trifft auf nahezu alle realen Prozesse oder Zustände zu. Damit solche Signale vom Computer verarbeitet werden können, müssen sie mittels eines Analog-Digital-Wandlers in ein Digitalsignal umgewandelt werden.

Analyzer Domain

Abgegrenzter Einsatzbereich zur Gruppierung von Analyzer Projects. Jede Analyzer Domain ist eine eigene Datenbank im SQL Server.

Analyzer Project

In sich abgeschlossener Bereich von Meta- und Nutzdaten im zenon Anaylzer.

Änderungen ermöglichen

Ermöglicht in einem mehrplatzfähigen Projekt den exklusiven Zugriff auf ein Element/Modul, um Änderungen durchführen zu können.Der Zustand wird im zentralen Serverprojekt gespeichert. Damit ist der Zugriff von anderen Anwendern auf das Element/Modul nicht mehr möglich.

Änderungen übernehmen

In einem mehrplatzfähigen Projekt werden damit alle durchgeführten Anpassungen von der lokalen Projektkopie in das zentrales Serverprojekt übernommen.

Änderungen verwerfen

Gibt in einem mehrplatzfähigen Projekt gesperrte Elemente/Module wieder frei, ohne die durchgeführten Änderungen in das zentrale Serverprojekt zu übernehmen. Die Änderungen werden durch den Serverstand ersetzt und gehen damit verloren.

Änderungshistorie

Datenaufzeichnung, die im Editor alle Änderungen mitprotokolliert und in der Projekt-Datenbank abspeichert.

Änderungsvergleich

Überprüft, ob sich Daten geändert haben.

Anfang Parallelzweig

Element, das eine Aufteilung des Rezeptablaufs in zwei oder mehrere Zweige ermöglicht.

Anfang Verzweigung

Element, das eine Aufteilung des Rezeptablaufs in zwei oder mehrere Zweige ermöglicht, von denen immer nur ein Zweig aktiv werden kann. Jeder nachfolgende Zweig muss mit einer Transition beginnen. Die Transition bestimmt im Rezeptablauf, welcher Zweig ausgeführt wird.

Anfangselement

Element des Moduls Batch Control, mit dem jedes Rezept beginnt.

Anfasspunkt

Grafisches Element (Rechteck, Kreis, Raute oder Sonnensymbol) mit dem ein Bildelement in der Farbe und Form geändert werden kann.

Animation

Eine Technik, bei der durch das Anzeigen von Einzelbildern für den Betrachter ein bewegtes Bild geschaffen wird.

Anlage

Planvolle Zusammenstellung von Bauteilen zu einer Gesamtheit mit einem bestimmten Zweck.

Anlagengruppe

Element der Anlagenmodellierung, um physikalischen Anlagen Objekte (Variablen, Rezepte, Funktionen, Archive usw.) projektübergreifend zuordnen zu können.

Anlagen-Kennzeichnung

Zusätzliche Kennzeichnung für Variablen, damit diese im Industrial Performance Analyzer gefiltert werden können. Die Definition der Anlagenkennzeichnung kann als Präfix im Namen oder der Kennnung der Variable angegeben werden.

Anlagenmodell

Erlaubt es, eine physikalisch existierende Anlage in beliebig viele hirarchisch gegliederte Anlagengruppen zu unterteilen.

Anlagenmodellierung

Ein Modul, das es ermöglicht, Objekte in Form eines hierarchischen Baums in Anlagengruppen zu gruppieren. Diesen Anlagengruppen können Variablen, Rezepte, Funktionen, Archive usw. projektübergreifend zugeordnet werden. In Editor und Runtime kann nach den Anlagengruppen gefiltert werden.Die Anlagenmodellierung kann nur in einem Globalprojekt erfolgen.

Anweisungsliste

Eine der fünf in IEC 61131-3 standardisierten Methoden zur Programmierung von Speicherprogrammierbaren Steuerungen (SPS), die hauptsächlich zur logischen Verknüpfung von Steuerungseingängen und -ausgängen verwendet wird.Hauptmerkmale von AWL sind, dass Operatoren nur einen Operanden besitzen. Die Syntax der Sprache ist an die Assemblersprache angelehnt und bietet nur sehr umständliche Strukturierungsmöglichkeiten durch Sprungbefehle. Vorteile ergeben sich aber, wenn aufgrund einer Speicherknappheit der eingesetzten CPU der Programmcode kleingehalten werden soll.

Anwender

Personen oder Organisationen, die eine Benutzung (einer Software zum Beispiel) veranlassen, ohne selbst Benutzer sein zu müssen.

API

Schnittstelle zur Anwendungsprogrammierung, die von einem Softwaresystem anderen Programmen zur Anbindung an das System zur Verfügung gestellt wird.

Arbeitsbereich

Ist eine Verwaltungseinheit im Editor, in der Projekte gruppiert werden. Nur Projekte, die in einen Arbeitsbereich eingefügt sind, können im Editor bearbeitet werden.

Archiv

Speicherort für historische Daten. Gespeichert werden: Wert, Zeitstempel in ms und der Status der Variablen.

Archiv Auslagerung

Archivdateien können nach einer einstellbaren Zeit aus dem System entfernt werden. Die Zeit und das Format, in dem die Daten abgelegt werden, sind einstellbar.

Archiv Speicherformat

Dateiformat, in dem die Archive gespeichert werden.

Archiv Speicherzyklus

Zeitlicher Abstand zwischen dem Erstellen neuer Archivdateien.

Archivdatei

Datei, in der der Archivserver die Archivdaten speichert.

Archivdaten

Werte aller im Archiv projektierten Variablen, die in der Runtime im Archiv gespeichert wurden.

Archivierung bei Wertänderung

Bei jeder Wertänderung werden die Werte der verknüpften Variablen mit Zeitstempel und Status in das Archiv geschrieben.

Archiv-Nachbearbeitung

Bildtyp, in dem Archive geöffnet und einzelne Datensätze manuell modifiziert werden können.

Archivserver

Modul das zur Aufzeichnung von historischen Daten eingesetzt wird. Im Archivserver werden Archive verwaltet.

Archivvariable

Eine Variable, die in einem Archiv verwendet wird. Die Werte der Variable werden je nach Einstellung in einem Archiv aufgezeichnet.

Array

Feld von Variablen des selben Typs. Das Feld kann bis zu drei Dimensionen besitzen. Die Nummerierung der Indizes beginnt wahlweise bei 0 oder bei 1.Im Gegensatz zu einem Blockarray kann jede Variable einzeln in allen Modulen verwendet werden und zählt bei der Lizenzierung als einzelner TAG.

Array-Variable

Bestimmt den Namen, die Größe, Adressierung und andere Eigenschaften eines Arrays. Die Elemente eines Arrays werden als Variablen des Arrays bezeichnet und übernehmen die zentralen Einstellungen der Array-Variablen.

ASCII

American Standard Code for Information Interchange - ist eine 7-Bit-Zeichenkodierung und bildet die US-Variante von ISO 646 sowie die Grundlage für spätere mehrbittige Zeichensätze und -kodierungen.

Assembly

Ist eine ausführbare Datei (.exe) oder Dynamic Link Library-Datei (.dll) und bildet den Bausteine des .NET Frameworks.Sie stellt die grundlegende Einheit für Bereitstellung, Versionskontrolle, Wiederverwendung, Aktivierungsscoping und Sicherheitsberechtigungen in einer .NET-basierten Anwendung dar. Sie liefert der Common Language Runtime die zum Erkennen der Typimplementierungen notwendigen Informationen. Man kann sich eine Assembly als Auflistung von Typen und Ressourcen vorstellen, die eine logische Funktionalitätseinheit bilden und für ein Zusammenwirken konzipiert sind.

Assistent

Führt durch die Parametrierung und erlaubt das einfache Anlegen von komplexen Objekten. Im Gegensatz zu den Wizards sind die Assistenten direkt in das Produkt integriert und können nicht angepasst werden.

Audiodatei

Ist eine Datei, die Audiodaten wie Musik oder Sprache enthält.

Aufzeichnungsart

Die Art mit der Daten in einem Archiv aufgezeichnet werden. Mögliche Arten: Zyklisch, spontan und ereignisgesteuert.

Ausführungsposition

Position in einem Rezept des Moduls Batch Control an dem die Abarbeitung im halbautomatischen und manuellen Modus automatisch unterbrochen wird und die aktiven Elemente in den Pause Status versetzt werden. Mit dem Kommando "nächster Schritt" wird der Ablauf an dieser Positon fortgesetzt.

Ausgabefenster

Anzeigebereicht, in dem Meldungen vom Remote-Transport und vom Runtime-Dateien erzeugen angezeigt werden.

Ausgang

Sendet ein elektrisches Signal (Null oder Eins oder einen numerischen Wert) an die angeschlossene Leitung.

Ausspeicherleistung

Die Rate, mit der der Speichernutzer Gas aus einer Speicheranlage entnimmt.

autark

Existiert unabhängig von anderen Komponenten.

Automatic Line Coloring

Automatic Line Coloring ist ein Modul, das es ermöglicht abhängig vom Prozesszustand Leitungen (dargestellt durch Linien-, Rechteck- oder Leitung-Vektor-Elemente) einzufärben. Als verfahrenstechnisches Element wird das Combi-Element verwendet.Die ALC dient zur einfachen automatischen Dynamisierung von Leitungen in der Verfahrenstechnik (für Medien) sowie topologischen Netzen in der elektrischen Energieverteilung (für Strom).

Automatisierung

Übertragung von Arbeit vom Menschen auf Automaten oder Zusammenfassung wiederkehrender Funktionsabläufe.

AVI

Audio Video Interleave ist ein von Microsoft definiertes Video-Containerformat. "Audio Video Interleave" bedeutet, dass Audio- und Videodaten ineinander verzahnt, also "interleaved" abgespeichert werden.


B

Glossar -> B

BACnet

BACnet wurde und wird unter der Schirmherrschaft der American Society of Heating, Refrigerating and Air-Conditioning Engineers (ASHRAE) entwickelt. Die Entwicklung begann im Juni 1987 um einen einheitlichen firmenneutralen Standard für die Datenkommunikation in und mit Systemen der Gebäudeautomation bereitzustellen. BACnet wurde im Jahr 1995 ANSI/ASHRAE-Norm 135. Im Januar 2003 wurde BACnet ISO-Norm 16484-5.

Bargraph

Dynamisches Element für die analoge Anzeige der Größe eines Signals. Dabei verändert sich die Länge eines Balkens mit der Signalgröße. Der Begriff leitet sich vom englischen "bar" für "Balken" ab.

Basiseinheit

Maßeinheit, deren Wert als Grundlage für die Berechnung des Werts der Umrechnungseinheit berechnet wird.

Batch Control

Werkzeug zur Erstellung und Ausführung von ISA S88 konformen Master-Rezepten und Kontroll-Rezepten.

Batchbetrieb

Automatisches, sequentielles Abarbeiten eines Stapels von Einzeloperationen.

BDE-System

System zur Betriebsdatenerfassung, besteht aus BDE-Maschinen, BDE-Bereichsterminals, BDE-Gruppenrechnern, die durch BDE-Interfaces an einen Leitrechner angebunden sind.

Beckhoff-TwinCAT

Nutzt jeden kompatiblen PC als Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Substituiert herkömmliche SPS- und NC/CNC-Steuerungen sowie Bediengeräte.

Bedienberechtigung

Stellt sicher, dass im zenon Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.

Bediener

Bezeichnet die Person, die z.B. eine Maschine bedient.

Befehl

Befehle führen eine Aktion durch, wie z.B. das Öffnen eines Arbeitsbereichs oder das Ausführen eines Wizards. Mit jeder Schaltfläche in der Symbolleiste des Editors ist ein Befehl verknüpft. Durch Klicken auf die Schaltfläche wird der Befehl ausgeführt.

Befehlsgabe

Bezeichnet eine besondere Art Sollwerte abzusetzen im Energy Bereich. Dabei wird der Befehl über eine Variable (die Aktionsvariable) abgesetzt und über eine zweite Variable (die Rückmeldevariable) zurückgelesen. Bevor eine Befehl abgesetzt wird, werden die Verriegelungsbedingungen (Topologische- wie Befehlsverriegelungen) geprüft. Ebenso wird geprüft, ob die Steuerung das Absetzen erlaubt - Select Before Operate.

Befehlsgabe-Element

Dynamisches Element, mit dem Befehle für das Modul Befehlsgabe abgesetzt werden.

Befehlsgruppe

Fasst Aktionen der Befehlsgabe für eine oder mehrere Variablen in einer Gruppe zusammen.

Befehlsparameter

Der eingestellte Wert wird zum Beginn der Grundfunktion auf die Steuerung abgesetzt. Zusätzlich kann der Wert in Bedingungen als Vergleichswert herangezogen werden.Ein Befehlsparameter ist ein Platzhalter und muss mit einer zenon Variablen verknüpft werden.

Begrüßungsbildschirm

Information, die beim Starten des Programms angezeigt wird.

Benutzer

Person, die mit einer Software arbeitet. Dem Benutzer können Attribute wie Benutzername, Passwort usw. sowie Benutzerrechte in Form von Berechtigungsebenen zugeordnet werden.

benutzerdefiniertes Ereignis

Zusätzlich zu den vorgegebenen Ereignissen wie z.B. Schichtbeginn, Schichtende usw. können vom Benutzer Ereignisse definiert werden. Durch das Ausführen der Funktion "PFS - benutzerdefiniertes Ereignis anstoßen" wird das Ereignis in der Runtime ausgelöst.

Benutzergruppe

Zusammenfassung von einer oder mehreren Berechtigungsebenen unter einem Namen. Die Benutzergruppen können Benutzern zugeordnet werden.

Benutzerverwaltung

Programm oder Programmteil, in dem definiert wird, welche Benutzer in einem System existieren, nach welchen Regeln sie sich im System anmelden und welche Rechte sie im System haben.

Berechtigungsebene

Bestimmt, ob ein Benutzer eine Aktion ausführen darf. Bei jedem Bedienelement in einem Bild kann eine Berechtigungsebene vergeben werden. Ebenso können für ausgewählte Funktionalitäten wie Alarm quittieren, Projekt im Editor laden usw... Berechtigungsebenen vergeben werden.Es gibt 128 Ebenen (von 0-127), wobei 0 die Systemebene ist, über die jeder Benutzer verfügt.

Berechtigungsgruppe

Fasst 32 Berechtigungsebenen in einer Variable vom Datentyp UDINT zusammen.

Betriebsdatenerfassung

Sammelbegriff für die Erfassung von Daten über Zustände und Prozesse im Betrieb.

Betriebsstunden-Zähler

Eine Variable, die zur aufsummierenden Messung der Zeit, die ein Gerät bzw. ein elektrischer Verbraucher in Betrieb ist, verwendet wird.

Betriebssystem

Ein Betriebssystem ist die Software, die die Verwendung (den Betrieb) eines Computers ermöglicht. Es verwaltet Betriebsmittel wie Speicher, Ein- und Ausgabegeräte und steuert die Ausführung von Programmen.

Bild

Eine begrenzte Fläche am Monitor, die Elemente/Objekte zum Bedienen, Steuern, Beobachten, Auswerten usw. von Maschinen, Anlagen und Prozessen beinhaltet.Es gibt verschiedene Bildtypen, die vordefinierte Funktionen mitbringen. Bilder basieren immer auf Schablonen, die die Position am Monitor festlegen. Es können mehrere Bilder gleichzeitig und auch auf mehreren Monitoren angezeigt werden.

Bild-ab

Taste, die den Cursor am Bildschirm um die Höhe des Bildschirms nach unten bewegt.

Bildalarmierung

Die Bildalarmierung führt den Anwender in der Runtime z.B. durch blinkende Elemente zu jenem Bild, in dem der Alarm grafisch dargestellt wird.Die Projektierung erfolgt mit Hilfe der Alarmbereiche.

Bildalarmierung Button

Dynamisches Element, mit dem die Bildalarmierung umgesetzt werden kann. Nur für SICAM 230 verfügbar.

Bild-auf

Taste, die den Cursor am Bildschirm um die Höhe des Bildschirms nach oben bewegt.

Bildeditor

Bereich im Hauptfenster, in dem Bilder gezeichnet werden.

Bildelement

Alle Elemente (Symbole, Dynamische und Vektor-Elemente sowie Kontrollelemente) die in einem Bild liegen.

Bildlauffeld

Grafisches Element in der Bildlaufleiste, um den angezeigten Inhalt horizontal oder vertikal zu verschieben. Das Verhältnis von Bildlauffeld zu Bildlaufleiste entspricht dem Verhältnis von angezeigtem Inhalt zum Gesamtinhalt des Elements.

Bildlaufleiste

Grafisches Werkzeug zum Verschieben von Bildschirminhalten entlang einer horizontalen oder vertikalen Achse.

Bildlaufpfeil

Grafisches Element in der Bildlaufleiste zum horizontalen oder vertikalen Bewegen des Bildlauffelds.

Bildschirmauflösung

Anzahl der dargestellten Pixel am Monitor, z.B: 640x480 (VGA) usw.

Bildsymbol

Symbol, das in einem Bild eingebettet oder verknüpft ist.

Bildtyp

Definiert die Art des Bildes und die darin standardmäßig verfügbaren Elemente. Für jeden Bildtyp stehen für die Funktionalität abgestimmte Elemente (Buttons, Listen usw.) zur Verfügung.So hat z.B. ein Bild vom Typ Alarmeldeliste alle Objekte, die zur Darstellung und Filterung von Alarmen erforderlich sind.

bildtypspezifische Funktion

Funktion, die einem Element zur Verfügung steht, wenn es in einem bestimmten Bildtyp verwendet wird.

Binärvariable

Variable, deren Wert nur zwei Zustände annehmen kann: 0 oder 1, High oder Low, True oder False.

Binärwert

Wert, der nur zwei Zustände, z.B. 0 und 1 bzw. High und Low ... annehmen kann.

Bitmap

Zweidimensionales Rastergrafikformat, das für die Betriebssysteme Microsoft Windows und OS/2 entwickelt und mit Windows 3.0 eingeführt wurde. Die Dateiendung ist .bmp, seltener .dib.

Bitmap Button

Dynamisches Element, mit dem eine Aktion (Funktion ausführen, Sollwert setzen) ausgelöst wird. Der Bitmap Button kann nur Grafiken darstellen. Ab 6.50 wird er durch das Dynamische Element Button ersetzt.

Blockarray

Eindimensionales Variablenfeld, dessen Feldgröße einstellbar ist. Der gesamte Block wird vom Treiber auf einmal gelesen und geschrieben. Dadurch ist ein Performancegewinn besonders bei symbolisch adressierten Steuerungen erreichbar. Im Gegensatz zu einem Array kann auf die einzelnen Werte nur mit Hilfe von VBA oder dem Rezeptgruppen Manager zugegriffen werden. Bei der Lizenzierung zählt es als nur ein TAG.

Blockwrite

Zusammenfassung von mehreren Schreibbefehlen in ein Schreibtelegramm. Wird z.B. beim Absetzen eines Rezepts verwendet.

Blue Screen of Death

Ist eine Beschreibung einer bestimmten Kategorie von Fehlermeldungen, welche insbesondere von Microsoft Windows-Betriebssystemen angezeigt werden. Dabei wird die Bedienoberfläche des Betriebssystems vollständig durch einen blauen Bildschirm ersetzt, auf dem in weißer Schrift Fehlerinformationen erscheinen.

Branche

Bezeichnet in der Wirtschaft eine Gruppe von Unternehmen, die ähnliche Produkte herstellen, die mit ähnlichen Artikeln (Sortimenten) handeln oder die ähnliche Dienstleistungen erbringen.

Breaktpoint

Bezeichnet eine Stelle im Programm, an der ein Debugger bei der Verarbeitung von Befehlen anhält, sobald er sie erreicht hat.

Build

Builds beinhalten Fehlerbehebungen. Bei jeder Kompilierung der Version wird die Build-Nummer hochgezählt. Diese Builds werden betroffenen Kunden zur Verfügung gestellt. Builds sind nur teilweise dem Qualitätssicherungsprozess unterworfen. Alle Builds werden in vollständig qualitätsgesicherten Service Packs zusammengefasst.

Bus Treiber

Ist ein Computerprogramm oder -modul, das zur Interaktion mit angeschlossenen (Feld-)Bussen dient.

Busklemme

Intelligente Reihenklemme, die unterschiedliche analoge und digitale Eingangs- und Ausgangssignale verarbeiten kann. Sie wird einfach und kompakt wie eine konventionelle Reihenklemme untergebracht und verdrahtet, verfügt aber im Gegensatz zur Reihenklemme über eine intelligente Elektronik.

Busklemmen-Controller

Eine Busklemmeneinheit besteht üblicherweise aus einem Buskoppler und einer größeren Anzahl von elektronischen Reihenklemmen. Der Buskoppler verfügt über eine Schnittstelle zu einem Feldbus und bindet auf diese Weise die Busklemmen in das Steuerungssystem ein. Buskoppler mit eigener Intelligenz werden als Busklemmen-Controller bezeichnet. Sie verfügen in kleinem Rahmen bereits über SPS-Funktionalität und können kleinere Steuerungsaufgaben dezentral, ohne Eingriff des Steuerungsrechners, abarbeiten.

Button

Dynamisches Element, mit dem eine Aktion (Funktion ausführen, Sollwert setzen) ausgelöst wird. Der Button verfügt über folgende Ausprägungen: Darstellung von Text und Grafiken sowie als transparentes Objekt, das über andere Elemente gelegt werden kann.


C

Glossar -> C

C#

C# (lies engl. c sharp, englische Aussprache) ist eine vom Softwarehersteller Microsoft im Rahmen seiner .NET-Strategie entwickelte Programmiersprache.

Cause of Transmission

Übertragungsursache laut IEC 60870 Protokoll. Der Wert der Übertragungsursache (siehe IEC60870-5-101 7.2.3) wird auf die zenon Statusbits 32 - 37 abgebildet.

CE Editor

Spezieller Editor für Windows CE Projekte, der nur die für Windows CE möglichen Einstellungen zulässt.

CEL-Eintrag

Ein einzelnes Ereignis, das in der Chronologischen Ereignisliste gespeichert ist.

CEL-Ereignis

Ein Grenzwertverletzung, die einen Eintrag in der Chronologischen Ereignisliste auslöst.

Checkbox

Ist ein Standardelement einer graphischen Software-Benutzungsoberfläche (GUI). Eine Checkbox hat in den meisten Fällen zwei, seltener drei oder mehr Zustände.

Chronologische Ereignisliste

Zentrale Verwaltung von Ereignissen im Leitsystem. Die Chronologische Ereignisliste (CEL) wird doppelt geführt: Einmal als Ringpuffer im Speicher und einmal als historische Daten in Dateien auf der Festplatte.Im Gegensatz zur Alarmmeldeliste verwaltet die Chronologische Ereignisliste nur den Zeitstempel "kommt".

Chronologische Ereignisliste Filter

Bildtyp, mit dem benutzerspezifische Filterbilder für die Chronologische Ereignisliste projektiert werden können.

ClearType

Die vor allem bei kursiven Schriftschnitten entstehenden Stufen werden beim herkömmlichen Antialiasing mit Bildpunkten in Grautönen so ausgeglichen, dass das Auge scheinbar schräge Linien wahrnimmt. ClearType verbessert diese Form der Schriftdarstellung weiter, indem es auch die Subpixel – die drei Farbbestandteile eines Pixels – einzeln anspricht und ebenfalls zur Kantenglättung heranzieht. ClearType verbessert diese Form der Schriftdarstellung weiter, indem es auch die Subpixel – die drei Farbbestandteile eines Pixels – einzeln anspricht und ebenfalls zur Kantenglättung heranzieht.

Client

Ein Programm, das mit einem anderen Programm, dem Server kommuniziert, um von ihm Zugang zu Diensten (Funktionalitäten) und/oder Daten zu erhalten.

Clientprojekt

Projekt mit aktiviertem Netzwerk und eingetragenem Server, das alle Daten (ausgenommen lokale Variablen des Interntreibers und des Systemtreibers) vom Serverprojekt über das Netzwerk (TCP/IP Kommunikation) bezieht.

CoDeSys

IEC 61131-3 SPS System der Firma 3S.

Coil

Eine Bezeichnung für Speicheradressraum, der binär aufgebaut ist und bei dem Schreibe- und Leseoperationen ausgeführt werden können. Wird bei Modbus verwendet.

Combi-Element

Universales Dynamisches Element, das verschiedenste grafische Ausprägungen annehmen kann: Grafik, Symbol aus der Bibliothek, in Bildern eingebettetes Symbole oder Text.Die Darstellung wird von Variablenwerten der Hauptvariablen oder weiteren Variablen bestimmt. Es ist möglich: - Statusinformationen aller verknüpfter Variablen auszuwerten- beliebige Verknüpfungen mittels Formeln zu erstellen- Zustände der Hauptvariablen direkt in das Combilement zu übertragen- verfahrenstechnische Elemente für das Automatic Line Coloring umzusetzen

Combo-/Listbox

Dynamisches Element, das abhängig vom Variablenwert einen Text in einer Auswahlliste anzeigt. Durch Selektion eines Eintrags wird der dazugehörige Wert abgesetzt oder die dazugehörige Funktion ausgeführt. Die Anzeige kann wahlweise in einer Combobox oder einer Listbox erfolgen.

Compiler

Ein Compiler ist ein Computerprogramm, das ein in einer Quellsprache geschriebenes Programm – genannt Quellprogramm – in ein semantisch äquivalentes Programm einer Zielsprache (Zielprogramm) umwandelt. Üblicherweise handelt es sich dabei um die Übersetzung eines von einem Programmierer in einer Programmiersprache geschriebenen Quelltexts in Assemblersprache, Bytecode oder Maschinensprache.

COM-Port

Serielle Kommunikationsschnittstelle.

Connector

Bindeglied zwischen Datenquelle und zenon Analyzer. Umfasst Connector Container, Connector Stub und Connector Plug-ins wie z.B. Connector zenonSQL.

Connector Container

Objekt zur Verwaltung von Connectoren. Befindet sich auf der Quelle. Lädt ein Connector Plug-in nach Anforderung vom Connector Stub und führt es aus.

Connector Plug-in

Teil des Connectors, der die Verbindung zwischen Stub und Container herstellt. Wird in der Abfrage angesprochen. Für unterschiedliche Aufgaben stehen unterschiedliche Plug-ins zur Verfügung, z.B.: zenonSQL oder zenonV6.

Connector Stub

Komponente zur Anknüpfung entfernter Systeme an den Microsoft SQL Server. Befindet sich am Ziel.

Continuous Function Chart

Programmiersprache für Speicherprogrammierbarer Steuerungen. Keine der fünf in der IEC 61131-3-Norm definierten Sprachen, aber mit der definierten FUP (FDB) gleichgestellt, stellt sie eine gängige Erweiterung von IEC-Programmierumgebungen dar. Wird vor allem in der Prozessleittechnik verwendet, da sie deren komplexe Steuerungs- und Regelungsaufgaben sehr gut abbilden kann.CFC ist eine graphische Programmiersprache, in der Funktionsblöcke miteinander verschaltet werden, anstatt eine Abfolge von textuellen Befehlen einzugeben wie bei klassischen Programmiersprachen. Als Vorbild sind dabei, Schaltpläne aus der Hardwareentwicklung zu sehen.

ControlLogix

Gerät von Allen-Bradley (Rockwell), das Ablaufsteuerung, Achssteuerung und Prozesssteuerung vereint. Logix bezeichnet eine universelle Steuerungsplattform, die bisher getrennte Systeme integriert.

CSV

Character Separated Values - beschreibt den Aufbau einer Textdatei zur Speicherung oder zum Austausch einfach strukturierter Daten.

CSV-Datei

Datei, die Daten vom Typ CSV (Character Separated Values) enthält.

Cursor

Auch: Einfügemarke, Schreibmarke, Eingabemarkierung: Markiert in einem Computerprogramm die aktuelle Bearbeitungsposition.

Cursor-Ausgabefenster

In diesem Fenster werden die Werte der Cursor-Messung des Erweiterten Trends dargestellt. Ist das Fenster nicht im Bild vorhanden werden die Werte am oberen Rand des Diagrammfensters eingeblendet.


D

Glossar -> D

Data Concentrator

Teil des zenon Analyzer um Daten von Steuerungen zusammenzufassen und bereitzustellen.

Datenbaustein

Datenbereich in einer Siemens Steuerung.

Datenbaustein-Nummer

Eindeutige Nummer eines Datenbausteins in einer Siemens Steuerung.

Datentelegramm

Datenpaket, das über ein Kommuniktationsmedium zu einem Kommunikationspartner gesendet wird.

Datentyp

Definiert einen festgelegten Wertbereich (fixe Ober- und Untergrenze) mit einer festgelegten Anzahl an Werten. Daher können reelle Zahlen als Gleitkommazahlen nur mit einer bestimmten Genauigkeit abgebildet werden.

Datumsanzeige

Kontrollelement, das ein veränderbares Datum anzeigt.

dBase

dBASE war die erste weitgenutzte Datenbank-Applikation (genauer eher ein Datenbankverwaltungssystem) für Mikrocomputer und wurde von der Firma Ashton-Tate für das Betriebssystem CP/M vertrieben. Später wurde die Datenbank auf den IBM-PC unter DOS portiert.Die Basisidee des dBASE-Systems ist, die Tabellen einer Datenbank in speziell strukturierten Files (DataBaseFiles = DBF) zu halten.

Decluttering

Funktionalität des Weltbildes: Je nach eingestellter Zoomstufe werden Objekte dargestellt oder ausgeblendet.Dadurch wird die Übersichtlichkeit erhöht.

Detailansicht

Bietet Details der Module im Projektmanager zur Bearbeitung an.

Diagnose Client

Programm, das sich über TCP/IP mit dem Diagnose Server verbindet und Fehlerprotokolle an diesen sendet. Jedes zenon Programm agiert als Diagnose Client.

Diagnose Server

Programm zur Fehleranalyse: Fehlerprotokolle werden von den Diagnose Clients an den Server geschickt und von diesem in LOG-Dateien abgespeichert. Der Diagnose Server ist in den Transportservice integriert.

Diagnose Viewer

Programm, das sich über TCP/IP mit dem Diagnose Server verbindet und die dort verfügbaren Fehlerprotokolle anzeigt. Das Programm kann sich entweder online verbinden oder historische Daten auslesen und gefiltert darstellen.Das Programm dient auch zur Konfiguration des Diagnose Servers.

Diagnose-Einstellungen

Definiert, welche Informationen an den Diagnose Server gesendet werden.

Diagramm

Ist eine grafische Darstellung von Daten, z.B. in Kurvenform. Einzelne Kurven werden in einem Diagramm zusammengefasst. Im Erweiterten Trend wird das Diagramm im Diagrammfenster dargestellt.

Diagrammfenster

Das Diagrammfenster zeigt ein Diagramm an.

Diagrammname

Frei wählbarer Name des Diagramms im Erweiterten Trend. Kann im Bild Erweiterter Trend in der Runtime angezeigt und auch ausgedruckt werden. Im Editor wird der Diagrammname in der Bildumschaltungsfunktion zur leichteren Identifikation der Funktion angezeigt.

Dialogschrift

Die Schriftart, die in den Standard-Programmdialogen in der Runtime verwendet wird.

Dienst

Führt als Programm, Routine oder Prozess, eine bestimmte Systemfunktion zur Unterstützung anderer Programme durch, insbesondere auf einer niedrigen (hardwarenahen) Ebene. Beispiele sind: SQL Server Dienst, Administrationsdienst usw.

Digitalsignal

Überträgt eine Information, zum Beispiel eine elektrische Wechselspannung, in Form einer Zahlenkolonne, die die Information mathematisch beschreibt, im Gegensatz zum Analogsignal, das eine physikalische Größe entweder direkt überträgt oder durch eine andere physikalische Größe abbildet.

Direct2D

Eine Technologie zur Darstellung von 2D Grafiken. Ist ein Bestandteil von DirectX und setzt auf Direct3D auf. Kann sowohl hardwarebeschleunigt als auch per Software-Fallback (wenn die Hardware den Modus nicht unterstützt) arbeiten.

Direct3D

Eine Technologie zur Darstellung von 3D Grafiken. Ist ein Bestandteil von DirectX. Kann sowohl hardwarebeschleunigt als auch per Software-Fallback (wenn die Hardware den Modus nicht unterstützt) arbeiten.

DirectX

Eine Sammlung COM-basierter Programmierschnittstellen (API) für multimediaintensive Anwendungen auf der Windows-Plattform. zenon kann zur Grafikausgabe den DirectX-Modus verwenden.

Dongle

Hardware, die Software vor unautorisierter Nutzung schützt.

Donglelizenz

Bindet die Nutzung der Software an das Vorhandenseins eines Dongles am Rechner oder im Netzwerk.

Donglelizenzierung

Lizenzierungsart, bei der die Lizenz an einen Dongle gebunden wird. Im Gegensatz zur Softlizenz ist diese Lizenzierungsart nicht rechnergebunden und damit portabel.

Donglenummer

Eindeutige Nummer, die im Dongle eingebrannt ist und mit der Produkt-ID der Seriennummer übereinstimmen muss. Die Donglenummer wird mit einem Aufkleber am Dongle sichtbar gemacht und kann mit der WIBU-KEY Software ausgelesen werden.

Dongleserver

Rechner, auf dem eine spezielle Donglesoftware läuft, die den Zugriff auf einen Netzwerkdongle ermöglicht.

Drag&Drop

Bezeichnet das Bewegen eines Elements durch Ziehen und Ablegen mit der Maus.

Dropdownliste

Ist ein Element einer grafischen Benutzeroberfläche, das durch eine Benutzeraktion ein „nach unten herausfallendes“ Listenfeld sichtbar macht.

Dynamischer Text

Dynamisches Element zur Darstellung des Werts einer Stringvariablen in alphanumerischer Form oder zur Darstellung des aktuellen Grenzwerttexts von numerischen Variablen.

Dynamisches Element

Ein Dynamisches Element repräsentiert Variablenwerte in grafischer Form. Die interne Verwaltung basiert auf Vektoren. Dadurch ist eine verlustfreie Größenänderung möglich.

Dynamisierung

Abhängig von Variablenwerten wird eine Anzeige verändert. Die Ausprägungen können völlig unterschiedlich sein: Farbumschläge, Blinken, Anzeige verschiedener Grafikdateien, Änderung der Position, Drehung, Sichtbarkeit, Transparenz usw...


E

Glossar -> E

Editor

Grafische Benutzeroberfläche zur Erstellung, Bearbeitung und Wartung von zenon Projekten.

Editorprofil

Speichert die Position und Verfügbarkeit der Schaltflächen in den Symbolleisten und die Anordnung der Symbolleisten im Editor. Ebenso werden die Position und die Größe der Editor-Fenster gespeichert.Es können bis zu 10 Editorprofile gespeichert werden.

EIB

Standard nach EN 50090, in der aktuellen Version als KNX Standard auch nach ISO/IEC 14543-3. Beschreibt, wie bei einer Installation Sensoren und Aktoren in einem Haus miteinander verbunden werden können, und legt fest, wie diese kommunizieren müssen (Protokoll).

EIB-Schnittstelle

Schnittstelle, die dem EIB-Standard entspricht.

Eigenschaftenfenster

Anzeigebereich, in dem die Eigenschaften der selektierten Elemente angezeigt werden.

Eigenschaftenhilfe

Fenster im Editor, das kurze Erklärungen zur selektierten Eigenschaft anzeigt.

Einfache Variable

Variable, die auf einem Einfachen Datentyp basiert.

Einfacher Datentyp

Datentyp, der direkt auf einem IEC Datentyp basiert und ihn mit Eigenschaften der Variablen wie z.B. Einheit, Skalierung, Grenzwerten usw. ergänzt. Alle diese Eigenschaften können an die darauf basierenden Variablen vererbt werden.

Eingabe

Taste, die Eingaben, die über die Tastatur gemacht werden, bestätigt und an das System schickt.

Eingabefeld

Kontrollelement zur Eingabe von Zeichen.

Eingang

Empfängt ein elektrisches Signal (Null oder Eins oder einen numerischen Wert) von der angeschlossenen Leitung.

Eingangsverriegelung

Ermöglicht es die Ausführung einer Grundfunktion abhängig von Prozesszuständen zu unterbinden. Die Verriegelungsbedingung kann mit Hilfe einer Formel definiert werden.

eingebetteter Datentyp

Datentyp, der in einem Struktur-Datentyp als Struktur-Element eingebunden ist, aber im Gegensatz zum verknüpften Datentyp eine Kopie des ursprünglichen Einfachen Datentyps ist. Damit sind alle Eigenschaften beim Struktur-Element einstellbar.

eingebettetes Symbol

Eine Gruppe von grafischen Elementen in einem Bild, die zusammengefasst werden und einen eindeutigen Namen bekommen. Der Speicherort befindet sich im Gegensatz zu den verknüpften Symbolen im Bild.

Einheitenumschaltung

Funktionalität um in der Runtime die Anzeige und Eingabe zwischen verschiedenen Maßeinheiten zu wechseln, z.B. Meter auf Yard.

Einspeicherleistung

Die Rate, mit der der Speichernutzer Gas in eine Speicheranlage einbringt.

Einzelplatzprojekt

Ein Projekt, das über keine Netzwerkverbindungen verfügt. Es kann nicht von einem Client oder einem Standby-Server aus angesprochen werden. Es kann Daten von anderen Projekten, die in der selben Runtime laufen, anzeigen und verarbeiten, z.B. Variablenwerte anzeigen, Einträge in der Alarmmeldeliste und der Chronologischen Ereignisliste anzeigen, Trendkurven anzeigen, Variablenwerte im Archivserver aufzeichnen, Variablenwerte auf andere Variablen zuweisen usw...

Ende

Taste, die den Cursor an die letztmögliche Eingabeposition oder ans Ende der Eingabezeile positioniert.

Ende Parallelzweig

Element, das die Aufteilung des Rezeptablaufs in zwei oder mehrere Zweige wieder zu einem Zweig zusammenführt.

Ende Verzweigung

Element, das eine durch ein Element Anfang Verzweigung begonnene Verzweigung wieder zusammenführt.

Endelement

Element des Moduls Batch Control, mit dem jedes Rezept endet.

Energy Edition

Erweiterung des Standardumfangs um spezielle Features, die nur im Energiemark benötigt werden, z.B. Befehlsgabe.

Energy Management System

Ein Werkzeug zur Unterstützung der betriebswirtschaftlichen Betriebsführung. Es dient zur Umsetzung eines Energiebezugsmanagements bei kleinen bis mittleren Energieerzeugern, aber auch bei Industrieunternehmen, deren Energiebezug über Sonderverträge geregelt ist.

Entf

Taste, die Zeichen rechts vom Cursor löscht.

Erdschlusssuche

Bei einem Erdschluss kann mithilfe dieser Funktion der betroffen Netzbereich mit der Erdschlussfarbe eingefärbt und dadurch der Fehlerort lokalisiert werden.

ereignisgesteuerte Archivierung

Die Daten werden bei der positiven Flanke der Ereignisvariable in das Archiv geschrieben.

ereignisgesteuerte Aufzeichnung

Die Daten werden bei der positiven Flanke der Ereignisvariable in das Archiv geschrieben.

Ersatzwert

Der Ersatzwert kann viele Funktionen haben. Zum einen wird beim Auffüllen von Archiven der voreingestellte Ersatzwert der Variable in das Archiv geschrieben. Zum anderen kann der Benutzer den aktuellen Wert mit einem Ersatzwert überschreiben. Dieser Wert wird nicht an die angeschlossene Hardware übertragen, sondern bleibt im Prozessabbild des Rechners. In alle zenon Module wird nun dieser Wert gesandt und weiterverarbeitet.

Event

Ein Ereignis dient in der Softwaretechnik zur Steuerung des Programmflusses. Das Programm wird nicht linear durchlaufen, sondern es werden spezielle Ereignisbehandlungsroutinen immer dann ausgeführt, wenn ein bestimmtes Ereignis auftritt.

Event-Port

TCP-Port, über den die Anwendung Ereignisse kommuniziert.

externe Variable

Externe Variablen ermöglichen den Datenaustausch mit der Steuerung über einen Treiber. Eine externe Variable ist das Abbild eines definierten Speicherplatzes in der Steuerung. Auf diesen Speicherplatz kann sowohl vom Leitsystem als auch von der Steuerung lesend und schreibend zugegriffen werden.


F

Glossar -> F

Farbpalette

Eine Sammlung von Farben. Die einzelnen Farben werden benannt und können jedem Element bei den Farbeigenschaften zugewiesen werden. Die Farbpalletten können sowohl im Editor, als auch in der Runtime gewechselt werden.

Farbschema

Definiert das Aussehen der Menüleiste, der Fenster und der Symbolleisten im Editor.

FDA 21 CFR Part 11

Nutzung sicherer, computergenerierter, zeitgestempelter Protokolle, um unabhängig Datum und Zeit von Benutzereingaben aufzuzeichnen sowie von Aktionen, die elektronische Einträge erstellen, verändern oder löschen.

Fehlerortung

Erweiterung der Automatic Line Coloring. Wird von einem Erdschlussrelais oder einem Kurzschlussrelais ein Fehler gemeldet, können die betroffenen Leitungen mit einer Fehlerfarbe eingefärbt werden.

Fenster

Im Editor stehen zur Anzeige mehrere verschiebbare, größenänderbare und ein-/ausblendbare Fenster zur Verfügung. Ein Fenster zeigt einen bestimmten Inhalt an. Beispielsweise zeigt das Ausgabe-Fenster alle Statusinformationen beim Laden von Projekten und beim Erzeugen der Runtime Dateien.Die Position und die Größe werden in Editorprofilen gespeichert.

Fertigungslinie

Automatisiertes Produktionssystem, in dem mehrere Bearbeitungsstationen durch Materialflusssysteme nach dem Linienprinzip verbunden sind. Verschiedene Produkte können unterschiedliche Fertigungslinien benötigen, die dann unterschiedliche Teile der Fertigungsstraße nutzen.

Fertigungsstraße

Fertigungseinrichtung, mit der in räumlicher und zeitlicher Abfolge Fertigungsschritte durchgeführt werden.

Filterprofil

Speichert in der Runtime die im aktuellen Bild angewandten Filtereinstellungen. Es können beliebig viele Filterprofile gespeichert werden.

First In First Out

Bezeichnet jegliche Verfahren der Speicherung, bei denen diejenigen Elemente, die zuerst gespeichert wurden, auch zuerst wieder aus dem Speicher entnommen werden. Das gegenteilige Prinzip wird als Last In – First Out-Verfahren (LIFO) bezeichnet.

Fokus

Markiert und aktiviert ein Element aus einer Elementgruppe, das die Tastatureingaben des Benutzers empfängt.

forcen

Einen Wert manuell auf eine Variable schreiben. Der bestehende Wert wird dabei auf jeden Fall überschrieben. Am Ende des Zyklus kann er von der Applikation wieder auf einen berechneten Wert gesetzt werden.

Formel

Mathematische Formel, die z.B. beim Mathematiktreiber, im Reportgenerator oder bei Verriegelungen verwendet werden kann.

Funktion

Eine vordefinierte Aktion, die in der Runtime angestoßen werden kann, z.B. ein Bildumschaltung oder eine Dateioperation usw.

Funktionsassistent

Assistent, um Reportfunktionen dialoggestützt zu erstellen.

Funktionsplan

Eine der fünf in der IEC 61131 definierten Programmiersprache für Speicherbare Programmierungen (SPS). Wird zunehmend von CFC ersetzt.


G

Glossar -> G

Gantt-Darstellung

Ist eine nach dem Unternehmensberater Henry L. Gantt (1861–1919) entwickelte Form der Darstellung, die die zeitliche Abfolge von Aktivitäten grafisch in Form von horizontalen Balken auf einer Zeitachse darstellt.

GIF

Graphics Interchange Format (Grafikaustausch-Format) ist ein Grafikformat mit guter verlustfreier Komprimierung für Grafiken mit geringer Farbtiefe (bis zu 256 verschiedene Farben pro Einzelbild). Darüber hinaus können mehrere Einzelbilder in einer Datei abgespeichert werden, die als Animation interpretiert werden.

Globale Symbolbibliothek

Zentraler Speicherort für Symbole, die in jedem Projekt verwendet werden können. Jede Gruppe der Bibliothek entspricht einer Datei, die lokal am Editorrechner gespeichert wird. Besonders bei Verteiltem Engineering und bei Weitergabe von Projekten ist darauf zu achten, dass die erforderlichen Gruppen mitgegeben werden.In den Projektsicherungen ist nur die Projekt-Symbolbibliothek enthalten.

Globalprojekt

Dient als Vorlage für Objekte, die in allen Projekten des selben Arbeitsbereichs genutzt werden können, z.B. Schablonen, Benutzer, Schriften, Anlagenmodelle usw..

Grafik

Ist der Sammelbegriff für alle künstlerischen oder technischen Zeichnungen und Abbildungen.

Granularität

Gibt an in welcher Anzahl von Stellen Werte von einer Steuerung gelesen werden. Beispielsweise werden die Werte von einer Siemens S7 Steuerung im Merkerbereich mit der Granularität Byte gelsesn. Es lässt sich also ein Bit nicht einzeln auslesen. Es muss immer das enthaltene Byte ausgelsen werden und das entsprechnde Bit ausmaskiert werden.

Grundfunktion

Vordefinierter Handlungsablauf bestehend aus einer Eingangsverriegelung, Befehls- und Rückgabeparametern, einer Weiterschaltbedingung, Ereignisreaktion usw. (ISA 88: Phase)

GUID

Zeichenfolge zur eindeutigen Identfizierung eines Objekts.


H

Glossar -> H

Harddisk-Datenspeicherung

Speichert Variablenwerte zyklisch in einem FIFO-Ringspeicher auf der Festplatte. Pro Variable wird eine Datei mit der Dateiendung HDD im Runtimeordner angelegt.

Hard-SPS

Als Hardware ausgeführte SPS im Schaltschrank. Zum Beispiel Mikro-SPS, Kompakt-SPS, modulare Hard-SPS, Panel-SPS, Embedded-SPS usw.

Hardwaremodus

Im Gegensatz zum Simulationsmodus wird mit der Steuerung kommuniziert. Die Variablenwerte werden von der Steuerung berechnet. Die Kommunikation kann mittels Treiberkommandos gestoppt (Offlinemodus) und wieder gestartet (Onlinemodus) werden.

Hardwareredundanz

Redundantes System, bei dem sowohl Steuerung als auch Leitsystem redundant ausgelegt sind. Beide Steuerungen halten Daten parallel vor. Der Standby-Server kommuniziert bidirektional mit der Standby-SPS. Bei einem Ausfall von Server oder erster SPS übernehmen Standby-Server und Standy-SPS.

Hauptmenü

Eine Zeile mit einer Reihe von Schlüsselbegriffen. Durch Klick auf einen Begriff wird eine Dropdownliste geöffnet, die wiederum eine Reihe von Befehlen unter Schlüsselbegriffen und/oder Symbolen zur Auswahl anbietet.

Haupttick

Langer Teilstrich einer Skala oder Achse.

Hintergrundgrafik

Externe Rastergrafik, die hinter allen Bildelementen angezeigt wird.

Höchstlastprognose

Spezieller Bildtyp, nur für SICAM 230 verfügbar.

Horizontale Transparenz

Erlaubt im Netzwerk den Zugriff auf alle Projekte auf derselben Ebene.

Hot Restart

In straton bedeutet Hot-Restart den Neustart einer straton Applikation mit genau den Variablen-Werten wie beim Beenden der Applikation.

HTML

Ist eine textbasierte Auszeichnungssprache zur Strukturierung von Inhalten wie Texten, Bildern und Hyperlinks in Dokumenten.Im HTML-Bild werden HTML-Inhalte angezeigt.

HTML-Datei

Textdatei, die nach dem HTML-Standard der W3C aufgebaut ist.


I

Glossar -> I

IEC 61131-3

Spezifiziert Syntax und Semantik von Programmiersprachen für Speicherprogrammierbare Steuerungen (SPS) wie in Teil 1 der IEC 61131 definiert. Folgende Sprachen sind definiert:1.) IL -Instruction List; AWL -Anweisungsliste: Vergleichbar mit Assembler2.) LD -Ladder Diagram; KOP - Kontaktplan: Vergleichbar mit einem Elektro-Schaltplan der um 90° gedreht ist3.) FBD - Function Block Diagram; FBS - Funktionsbausteinsprache: Teilweise (insbesondere bei Step 7) auch als FUP (Funktionsplan) bekannt. Ähnelt Logik-Schaltplänen.4.) SFC - Sequential Function Chart; AS - Ablaufsprache: Eine Art Zustandsdiagramm, bei Step7 als S7-Graph bekannt. Die IEC 61131-3:2003 sieht den SFC als eine Weiterentwicklung von Grafcet nach EN 60848.5.) ST - Structured Text; ST - Strukturierter Text: Angelehnt an Hochsprachen, bei Step 7 als SCL (Structured Control Language) bezeichnet.6.) CFC - Continuous Function Chart; CFC - Continuous Function Chart: Nicht Teil der IEC 61131-3: Vollgrafisches Projektierwerkzeug, speziell für Regelungen und Verriegelungen.

IEC Datentyp

In der IEC 61131-3 genormte Einfache Datentypen wie z.B. INT, USINT usw. Es ist ein festgelegter Wertbereich (fixe Ober- und Untergrenze) mit einer festgelegten Anzahl an Werten definiert. Daher können reelle Zahlen als Gleitkommazahlen nur mit einer bestimmten Genauigkeit abgebildet werden.

Industrial Maintenance Manager

Modul zur Pflege von Maschinen und Wartungsdaten. Serviceintervalle können geplant und verwaltet werden. Auf einen Blick ist feststellbar, welche Geräte, Anlagen, Maschinen usw. heute/in dieser Woche/ nächstes Monat usw. gewartet werden müssen. Ebenso wird protokolliert, welche Wartungsarbeiten in der Vergangenheit durchgeführt worden sind.Das Modul speichert die Daten in einer beliebigen ODBC fähigen SQL-Datenbank.

Industrial Performance Analyzer

Modul, um Alarmdaten statistisch auszuwerten und Schwachstellen an der Anlage zu lokalisieren. Fehler, die am häufigsten auftreten und welche die größten Stillstandzeiten verursachen können identifiziert werden.Die Runtime schreibt Alarm- und Schichtinformationen (bei Verwendung des Production & Faclity Schedulers) in eine ODBC fähige SQL-Datenbank.Es können mehrere Runtime Systeme die Daten in einer zentralen Datenbank ablegen. Die Datenauswertung kann damit über mehrere Anlagen/Systeme hinweg erfolgen.

Instanz-DB

Datenbaustein in S7, der die Laufzeitvariablen für eine S7-Graph Schrittkette enthält. Jede Schrittkette hat genau einen Instanz-DB. Der Instanz-DB hat normalerweise die selbe Nummer wie der Funktionsbaustein der Schrittkette.

Instanz-DB Variable

Variable als Blockarry, die den gesamten Instanz-DB einer S7-Graph Schrittkette beinhaltet. Über sie werden sämtliche Zustandsinformationen ausgelesen.

Integrationsprojekt

Eigenständiges Projekt, das Unterprojekte beinhaltet, auf die in der Runtime zugegriffen werden kann. Siehe Mehrprojektverwaltung.Das Projekt kann in der Mehrprojektveraltung als reines Verwaltungsprojekt eingesetzt oder auch als vollwertiges Projekt genutzt werden.Wird das Integrationsprojekt als Startprojekt gesezt, werden in der Runtime alle unterlagerten Projekte automatisch mit gestartet.

Intern Treiber

In die Runtime integrierter Treiber, auf dem Variablen angelegt werden können, die zum Speichern von Informationen gedacht sind, die nicht auf einer Steuerung gespeichert werden können/sollen.

interne Variable

Interne Variablen haben keine Verbindung zur Steuerung. Interne Variablen werden im Speicher des Leitsystems abgelegt und basieren auf internen Treibern wie z.B. dem Interntreiber, dem Systemtreiber, dem Mathematiktreiber oder dem Simulatortreiber. Interne Variablen werden z.B. benutzt, um lokale Berechnungen durchzuführen.

IP-Adresse

Werden in Computernetzen, die auf dem Internetprotokoll (IP) basieren, verwendet, um Daten von ihrem Absender zum vorgesehenen Empfänger transportieren zu können. Aufgrund der Adresse kann das Datenpaket den Empfänger eindeutig identifizieren.

Ist-Abweichung

Der Unterschied eines tatsächlichen Werts zu einem gewünschten Wert.

Istwert

Der momentan im Prozessabbild vorhandene Wert. Das kann der Spontanwert, Ersatzwert oder der gestörte Wert (Status I-Bit) sein.


J

Glossar -> J

JPG

Ein Grafikformat, das vom Gremium Joint Photographic Experts Group zur JPEG-Norm entwickelt wurde.Die JPEG-Norm beschreibt lediglich Bildkompressionsverfahren, legt aber nicht fest, wie die so entstandenen Daten gespeichert werden sollen. Gemeinhin werden mit „JPEG-Dateien“ oder „JPG-Dateien“ Dateien im Grafikformat JPEG File Interchange Format (JFIF) bezeichnet. JFIF ist jedoch nur eine Art, JPEG-Daten abzulegen.


K

Glossar -> K

Kalenderanzeige

Kontrollelement, das einen Kalender zur Auswahl eines Datums anzeigt.

Kennung

Frei definierbarer Text für die Identifikation der Variablen oder des Datentyps. Ergänzend zum Variablennamen/Datentyp.

Keyboard

Ist ein virtuelles Eingabegerät, das am Bildschirm angezeigt wird. Es enthält eine Anzahl von Bedienelementen, die die Eingabe von Zeichen ermöglichen.

Keyboard-Bild

Bild vom Typ Keyboard

Kommando

Im Bereich Batch Control: Befehl, der in den Rezeptablauf eingreift, z.B.: Starten, Stoppen, Modusänderungen usw...

Kontaktplan

Eine der fünf in der IEC 61131 genormten Sprachen zur Programmierung von Speicherprogrammierbaren Steuerungen (SPS). Diese grafische Sprache ist an Stromlaufpläne angelehnt und eignet sich vor allem für Verknüpfungssteuerungen.

Kontextmenü

Eine Dropdownliste, die sich beim Rechtsklick öffnet und die eine Reihe von Befehlen unter Schlüsselbegriffen und/oder Symbolen anbietet. Die Befehle beziehen sich immer auf das selektierte Element.

Kontrollelement

Für jeden Bildtyp spezielle Elemente, mit denen die Steuerung, Auswahl und Eingabe umgesetzt wird. Diese können in Form von Buttons, statischen Texten, Comboboxen, Listboxen, grafischen und tabellarischen Darstellungen, Eingabefelder, Radiobuttons, Spincontrols, Kalenderanzeigen, Datumsanzeigen und Zeitanzeigen ausgeführt sein.

Kopfzeile

Oberere Bereich einer Tabelle, der die Spaltentitel enthält.

Kreisbogen

Vektor-Element, das einen Viertelkreis darstellt.

Kreisredundanz

Nutzt die Mehrprojektverwaltung um mehrere Projekte redundant auszuführen und dabei ein Minimum an PC Hardware zu benötigen. Beispiel: Drei Projekte lassen sich mit drei Rechnern redundant ausführen.

Kreissegment

Vektor-Element, das einen beliebigen Teil eines Kreises/einer Ellipse darstellt. Bei Darstellungsart transparent wird nur die äußere Linie dargestellt.

Kurzschlusserkennungsgerät

Ein Leitungsschutzgerät zur Erkennung von Kurzschlüssen in einem Netzelement.


L

Glossar -> L

Last In First Out

Bezeichnet jegliche Verfahren der Speicherung, bei denen diejenigen Elemente, die zuletzt gespeichert wurden, auch zuerst wieder zuerst aus dem Speicher entnommen werden. Das gegenteilige Prinzip wird als First In – First Out-Verfahren (FIFO) bezeichnet.

Latch

Ist eine bestimmte Ausführung eines elektronischen 1-Bit-Datenspeichers und bildet die Grundlage für weite Bereiche der Digital-Hardware, insbesondere innerhalb CPU- und Peripherie-Chips.Ein Latch (engl. für Schnappschloss, Auffangregister) hat neben dem Dateneingang mindestens einen zweiten Eingang (oft Enable genannt), der die Betriebsart steuert: In der transparenten Phase folgt der Ausgang des Latches unmittelbar dem Dateneingang; in der Halte-Phase wird der letzte Zustand davor eingefroren. Zusätzlich zu diesem Steuereingang kann es je nach Ausführung weitere geben, z. B. einen Reset-Eingang, der bei mehreren Latches in einem Chip gern global für alle diese Einzellatches wirkt.Im Gegensatz zu taktflankengesteuerten Flipflops ist ein Latch während der gesamten aktiven Taktphase transparent, d. h. Eingangsänderungen können den Ausgang sofort beeinflussen.

latchen

Eine Schaltung geht in einen bestimmten Zustand und verharrt darin, bis ein manuelles Rücksetzen erfolgt.

Lesetelegramm

Datenpaket, das zu einer Steuerung gesendet wird, um von dort Werte zu lesen.

Listenfeld

Ist ein Standardelement einer graphischen Software-Benutzungsoberfläche (GUI). Es dient zur Darstellung von durch den Benutzer auswählbaren Einträgen in Listenform. Bei den Einträgen handelt sich in der Regel um Daten textueller Natur, aber auch die Darstellung von Piktogrammen oder Kombinationen aus Text und Bild sind möglich.

Lizenz

Räumt dem Anwender Nutzungsrechte an der Software ein. Die Nutzungsrechte sind in der EULA - End User License Agreement - festgelegt.

Lizenzaufkleber

Aufkleber, der Seriennummer und Aktivierungsnummer enthält. Der Aufkleber wird auf lizenzierter Hardware angebracht um einen Lizenznachweis zu erbringen.

Lizenzierung

Der Vorgang, bei dem die Lizenz dem Anwender zugeordnet wird.

Lizenznummer

Rechnerspezifische Zeichenfolge, die für die Softlizenzierung verwendet wird. Die Lizenznummer wird zusammen mit der Seriennummer durch die Aktivierungsnummer überprüft.

Lizenzschein

Dokument, das die erteilte Lizenz enthält. Der Lizenzschein beschreibt unter anderem den lizenzierten Produktumfang, die Seriennummer, die Aktivierungsnummer und bei Softlizenzierung die Lizenznummer.

LOG-Datei

Textdatei, in der Fehlerprotokolle gespeichert werden.

Login

Vorgang, bei dem sich ein Benutzer am System anmeldet.

Logout

Vorgang, bei dem sich ein Benutzer am System abmeldet.

lokale Projektkopie

Abbild des zentralen Serverprojekts auf einem mit dem Server verbundenem Rechner. Alle Änderungen in einem mehrplatzfähigen Projekt werden darin durchgeführt und mit "Änderungen übernemen" an das zentrale Serverprojekt übertragen.


M

Glossar -> M

Maßeinheit

Die nach wissenschaftlichen oder zweckmäßigen Gesichtspunkten gewählte Einheit zum Messen von Größen, Mengen und Gewichten.

Mathematik Treiber

In die Runtime integrierter Treiber, der mathematische Funktionen zur Verfügung stellt.

Matrix-Editor

Editor zum Erstellen von Rezepten im Modul Bacth Control. Im Gegensatz zum PFC-Editor wird das Rezept in einer Ablaufmatrix erstellt.

Matrix-Rezept

Rezept im Modul Batch Control, das mit dem Matrix-Editor erstellt wurde.

Mauszeiger

Bewegtes Symbol als Zeigegerät auf einem Comuterbildschirm. Fester Bestandteil von grafischen Benutzeroberflächen.

Mehrplatzfähiges Projekt

Kann im Editor durch mehrere Benutzer auf mehreren Computern gleichzeitig bearbeitet werden.

Mehrprojektverwaltung

Editor: Ermöglicht die gleichzeitige Bearbeitung mehrere Projekte in einem Arbeitsbereich.Runtime: Erlaubt das gleichzeitige Starten mehrerer Projekte und damit den projektübergreifenden Datenzugriff. Somit kann direkt auf Variablen, Funktionen, Archive usw. aus anderen Projekten zugegriffen werden.Vorraussetzung: Integrationsprojekt, das in der Runtime als Startprojekt geladen wird.Die Mehrprojektverwaltung wird dazu genutzt um dezentrale Lösungen umzusetzen. So ist es möglich Unterprojekte als Serverprojekte auf verschiedenen Rechnern zu betreiben.

Meldungselement

Dynamisches Element, das abhängig von den Werten zweier Variablen aus einer Textdatei einen Text ausliest und anzeigt.

Meldungsvariable

Variable vom Typ String, die den Zustandstext der S7-Graph Heuristik abbildet.

Menü

Eine Dropdownliste, die eine Reihe von Befehlen unter Schlüsselbegriffen und/oder Symbolen zur Auswahl anbietet.

Menüeditor

Grafische Oberfläche zur Gestaltung von Haupt- und Kontextmenüs.

Menüeintrag

Ein Befehl, der in einem Menü als Schlüsselbegriff und/oder Symbol angeboten wird.

Message Control

Modul zum Versand von Nachrichten an einzelne Empfänger oder Empfängergruppen per E-Mail, SMS, Sprache usw.

Messbeleg

Datensatz im SAP Instandhaltungsmodul (PM): Nachweis einer Messung an einem Meßpunkt oder Zähler zu einem bestimmten Zeitpunkt.

MIB

Beschreibt die Informationen, die über ein Netzwerk-Management-Protokoll (zum Beispiel SNMP) abgefragt oder modifiziert werden können. Diese Informationen werden Managed Objects genannt.

Modbus RTU

Standardisiertes Kommunikationsprotokoll zur Verbindung mit Modbus-Steuerungen über serielle Schnittstelle. Genormt von Modbus-IDA (www.modbus.org).Das Protokoll kann auch über TCP/IP geroutet werden. Normalerweise wird dazu aber das Protokoll Open Modbus TCP/IP verwendet.

Monitor

Ist ein Bildanzeigegerät zum Anschluss an einen Computer.

Monitoring Viewer

Tool zur Darstellung aller zenon Logic Programme in der zenon Runtime. Ist Bestandteil des Moduls PLC Diagnosis.

Monitorprofil

Teil der Monitorverwaltung, der die Anordnung bzw. Verfügbarkeit der realen Monitore und die Zuordnung der virtuellen Monitore zu den realen Monitoren definiert.Ebenso wird eingestellt, ob die Runtime an die Bildschirmauflösung angepasst werden soll oder Bildlaufleisten angezeigt werden sollen.

Monitorverwaltung

Dient zur Administration von Bildanzeigegeräten und Bildschirmauflösungen. Für Einzelmonitorsysteme muss hier die optimale Zielauflösung für die Runtime eingestellt werden, sowie, ob die Anzeige automatisch an die Bildschirmauflösung des Monitors angepasst werden soll (automatische Skalierung).Für Mehrmonitorsysteme werden die verfügbaren Monitore und deren Positionen definiert sowie die Zuordnungen der virtuellen zu den realen Monitoren.

MP3

Ist ein Dateiformat zur Speicherung von verlustbehaftet komprimierten digitalen Audiodaten.

MPEG

Progressives Video-Format mit mehreren Layern.

Multibin

Dynamisches Element, das abhängig von Variablenwerten eine Grafik anzeigt oder Symbole einfärbt und einen Zustandstext ausgibt. Es können sowohl numerische Variablen als auch Binärvariablen verknüpft werden. Ist als erste Variable eine Binärvariable verknüpft, kann Multibin auch als Schalter oder Taster für die erste Variable benutzt werden. Die definierten Zustände werden von oben nach unten abgearbeitet. Die Einstellungen des ersten zutreffenden Zustands werden angezeigt.

Multi-Binär

Typ einer Reaktionsmatrix, bei der Unterzustände, Statusrangierungen und Sonderfunktionen projektiert werden können.

Multi-Numerisch

Typ einer Reaktionsmatrix, bei der zusätzliche Statusabfragen, Statusrangierungen und Sonderfunktionen projektiert werden können.

Multitouch

Bildschirm mit Mehrfinger-Gestenerkennung. Die besondere, berührungsempfindliche Oberfläche ermöglicht die Eingabe von Daten mit Hilfe von Gesten. Der kapazitive oder optische Touchscreen erkennt gleichzeitig mehrere Berührungen, meist mit den Fingern, womit mehr Bedienmethoden zum Einsatz kommen können als bei Systemen, die nur einen einzigen Berührungspunkt gleichzeitig erfassen können.


N

Glossar -> N

Nach-links

Taste, die den Cursor am Bildschirm nach links bewegt.

Nach-oben

Taste, die den Cursor am Bildschirm nach oben bewegt.

Nach-rechts

Taste, die den Cursor am Bildschirm nach rechts bewegt.

Nach-unten

Taste, die den Cursor am Bildschirm nach unten bewegt.

Nebentick

Kurzer Teilstrich einer Skala oder Achse.

Netzadresse

Für TCP/IP-Treiber: Zuordnung einer Variablen zu einer Verbindung, wenn der Treiber über mehrere gleichzeitige Verbindungen verfügt. Für serielle Treiber: Bus- oder Stationsadresse der angeschlossenen (Feld-)Busteilnehmer.

Netzelement

Teil eines elektrischen Netzes. Zum Beispiel: Leitung, Generator, Schalter, Trafo usw. Zur Darstellung in einem Bild wird ein Combielement bzw. eine Linie, Poylinie oder Rohrleitung verwendet.

Netzwerkdongle

Hardware, auf der eine bestimmte Anzahl an gleichzeitig nutzbaren Softwarelizenzen aufgebucht sind. Der Zugriff erfolgt über das Netzwerk.

Notizbuch

Bildytp, mit dem Textdateien angezeigt und bearbeitet werden können.

numerische Variable

Variable, deren Wert aus Ziffern besteht. Die Darstellung kann in dezimaler, oktaler, binärer oder hexadezimaler Form erfolgen.


O

Glossar -> O

Offline-Drucken

Die Ausgabe auf dem definiertern Drucker erfolgt durch expliziten Aufruf (Funktion, Buttondruck etc.).

Offline-Import

Daten aus einer Quelldatei z.B. CSV oder XML Datei auslesen und übernehmen.

Offlinemodus

Der Treiber befindet sich im Hardwaremodus und kommuniziert nicht mit der Steuerung. Der Treiber ist gestoppt.

OID

Ist ein eindeutiger Bezeichner, der benutzt wird um ein Informationsobjekt zu benennen. In der Netzwerktechnik wird im Zusammenhang mit SNMP von OIDs gesprochen, wenn damit ein Objekt aus der Management Information Base (MIB) gemeint ist.

OLE

Ist ein von Microsoft entwickeltes Objektsystem und Protokoll, das die Zusammenarbeit unterschiedlicher (OLE-fähiger) Applikationen und damit die Erstellung heterogener Verbunddokumente ermöglichen soll.

Online Change

Mit der Funktion Online Change können modifizierte straton Applikationen auf das Zielsystem geladen und übernommen werden, ohne dass die SPS (in weiterer Folge der Prozess) gestoppt werden muss. In straton muss die Funktionalität Online Change zuvor aktiviert und konfiguriert werden.

Online-Auswahlmenü

Ein Menü, das in der Runtime automatisch aufgeschaltet wird und eine Auswahl zwischen verschiedenen Optionen zulässt.

Online-Drucken

Jeder Eintrag in die AML bzw. CEL löst ein Ausgabe auf dem definierten Listendrucker aus.

Online-Hilfe

Direkt im Programm verfügbare Hlfe.

Online-Import

Daten von online verfügbaren Quellen z.B. einer Steuerung oder einem Server übernehmen.

Online-Modus

Der Treiber befindet sich im Hardwaremodus und kommuniziert mit der Steuerung. Der Treiber ist gestartet.

Online-Wert

Aktueller Wert einer Variablen.

OPC

Ermöglicht den Datenaustausch zwischen Anwendungen unterschiedlicher Hersteller in der Automatisierungstechnik durch ein einheitliches Kommunikationsprotokoll.

OPC UA

Neu definierter Kommunikationsstack der OPC Foundation, um den Datenaustausch zwischen Anwendungen der Automatisierungstechnik zu vereinfachen.

Open Modbus TCP/IP

Standardisiertes Kommunikationsprotokoll zur Verbindung mit Modbus-Steuerungen über TCP/IP. Genormt von Modbus-IDA (www.modbus.org).

Optionsfeld

Ist ein Standardelement einer graphischen Software-Benutzungsoberfläche (GUI). Es kann zwei Zustände annehmen: aktiviert und deaktiviert. In einer Gruppe von zusammenhängenden Optionsfeldern muss immer genau eines aktiv sein.

Ordner

Mit Ordnern werden Dateien, wie Programme und Dokumente, auf einem Datenträger organisiert. Ordner können sowohl Dateien als auch weitere Ordner enthalten.


P

Glossar -> P

Parallelzweig

Bereich des Modul Batch Control. Ein Parallelzweig beginnt mit einem Anfang Parallelzweig Element und wird durch ein Ende Parallelzweig Element wieder auf einen Ausführungszweig zusammengeführt. Dazwischen befinden sich mindestens zwei Zweige, die gleichzeitig ausgeführt werden.

PCE-Projekt

Fasst mehrere Tasks für die Process Control Engine (PCE) zusammen.

Pfad

Definiert den Weg zu Dateien oder Ordnern mit relativen oder absoluten Angaben.

PFC-Editor

Editor zum Erstellen von Rezepten im Modul Bacth Control. PFC steht für Procedural Function Chart und ist in ISA 88 definiert. Im Gegensatz zum Matrix-Editor wird das Rezept in einem Ablaufdiagramm erstellt.

PFC-Rezept

Rezept im Modul Batch Control, das mit dem PFC-Editor erstellt wurde.

PFS

Umfangreiches Tool, um zeitliche Abläufe direkt zu steuern. Es werden zwei Ausführungsmodi unterstützt: Absolutzeiten und Relativzeiten. Alle Zeiten sind auf ein Kalendermodell aufgeschaltet mit einer Vorschaumöglichkeit, die es erlaubt zukünftige Schaltpunkte zu kontrollieren.

Pharma Edition

Erweiterung des Standardumfangs um spezielle Features, die vor allem in der pharmazeutischen Industrie benötigt werden, z.B. Batch Control.

Pipe-Symbol

Senkrechter Strich (|) wird zur Trennung von Texten z.B. in den Sprachdateien verwendet. Wird auf deutschen Tastaturen mit AltGr + < erzeugt.

PNG

Portable Network Graphics ist ein Grafikformat für Rastergrafiken mit verlustfreier Bildkompression. Es wurde als freier Ersatz für das ältere, bis zum Jahr 2004 mit Patentforderungen belastete Format GIF entworfen und ist weniger komplex als TIFF. PNG unterstützt neben unterschiedlichen Farbtiefen auch Transparenz per Alphakanal.

Polygon

Vektor-Element, das ein Vieleck durch seine Eckpunkte beschreibt.

Polylinie

Vektor-Element, das eine Linie darstellt, die über mehrere Stützpunkte zu definieren ist. Die Linie wird vom ersten Punkt zum zweiten Punkt gezogen, von dort weiter zum dritten Stützpunkt und so weiter.

Popup-Bild

Bild in der Runtime, das andere Bilder teilweise verdeckt.

Portnummer

Ist Teil einer IP-Adresse, die Werte von 0 bis 65535 annehmen kann. Die Nummer definiert einen eindeutigen Kommunikationskanal. Für eine Kommunikation mit TCP/IP sind immer die IP-Adresse und eine Portnummer erforderlich, um einen Empfänger eindeutig zu adressieren.Auch die Protokolle UDP und SCTP arbeiten mit Portnummern.

Pos1

Taste, die den Cursor an den linken oberen Bildschirmrand oder an den Anfang der Eingabezeile positioniert.

positive Flanke

Die Wertänderung einer Variablen von einenm kleineren Wert zu einem größeren Wert.

Post Mortem Analyse

Die Möglichkeit einen Fehler analysieren zu können, der zu einem Gerätabsturz geführt hat. Dazu werden am Gerät Daten gespeichert und später ausgelesen.

Primitivobjekt

Ist die Kombination aus Datentyp und Treiber-Objekttyp

Process Control Engine

System zur Erweiterung der Runtime um frei programmierbare Tasks.Die Process Control Engine besteht aus zwei Teilen: Programmierumgebung zur Erstellung von Tasks und ein Laufzeitsystem, das VB-Skript oder Java Code einmalig oder zyklisch abarbeitet.Die Tasks können mit der Runtime oder über Funktionen gestartet werden. Die Ankopplung an die Runtime erfolgt über Variablen.

Process Gateway

Modul zum Datenaustausch mit Drittsystemen. Es stehen mehrere Kommunikationsprotokolle wie z.B. Modbus oder IEC 60870 zur Verfügung.

Produkt-ID

An der ersten Position der Seriennummer steht eine eindeutige Produkt-ID, welche die Lizenz eindeutig identifiziert. Bei Donglelizenzierung stimmt die Produkt-ID mit der Donglenummer überein.

Programmierschnittstellen

Sie bieten zur Erweiterung der Funktionsmöglichkeiten Programmierwerkzeuge wie PCE, VBA und VSTA an.

Projekt

Zusammenfassung von Einstellungen, Bildern, Funktionen, Variablen, Rezepten usw. zum Darstellen einer Visualisierungsaufgabe.Im Editor werden die Projekte erstellt. In der Runtime werden die Projekte dargestellt. Die Speicherung der Editor-Daten erfolgt zum Teil in einer SQL-Datenbank und als Binärdateien. Die Datenablage kann entweder lokal am Editor Rechner oder auf einem zentralen Rechner (Mehrplatzverwaltung) erfolgen. Von Projekten kann jederzeit ein Backup erstellt werden, und dieses am selben oder auch auf einem anderen Rechner rückgelesen werden.Für die Runtime muss das Projekt in Binärdateien übersetzt werden (Runtime Dateien erzeugen). Für die Runtime ist keine Datenbank erforderlich.

Projektbaum

Strukturierte grafische Darstellung aller Projekte und Module in einem Arbeitsbereich.

Projekt-Eigenschaft

Alle Eigenschaften, die das Verhalten und das Aussehen des Projekts bestimmen.

Projektmanager

Fenster im Editor, in dem der Projektbaum, die Detailansicht und die Netzwerktopologie angezeigt werden.

Projektsimulation

Dabei wird nicht nur ein einzelner Treiber in den Simulationsmodus geschaltet, sondern das gesamte Projekt. Je nach Einstellungen werden auch alle Runtime-Daten in ein Simulationsabbild kopiert, damit auch Schalthandlungen im Simulationsmodus aufgezeichnet bzw. analysiert werden können.

Projekt-Symbolbibliothek

Projektspezifischer Speicherort für Symbole. Zur Gruppierung werden die Meta Informationen verwendet.Anders als die Globale Symbolbibliothek ist sie in der Projektsicherung enthalten.

Property

Eigenschaft eines Elements/Objekts, auf die mit VBA/VSTA zugegriffen wird.

Prozessabbild

Das Prozessabbild spiegelt den momentanen Zustand des Prozesses bzw. der Signalzustände wider. Es wird im Speicher des Leitsystems gehalten und von den Treibern aktualisiert. Jede Anfrage eines Online-Wertes eines Moduls (z.B. Bilder, Archivserver usw.) wird aus dem Prozessabbild beantwortet.

Prozesskopplung

Das Projekt kommuniziert mit den Steuerungen (Treiber im Hardwaremodus).

Prozessleitsystem

Ermöglicht das Führen einer verfahrenstechnischen Anlage. Es besteht typischerweise aus sogenannten prozessnahen Komponenten (PNK) sowie Bedien- und Beobachtungsstationen (BUB).

Prozessor-Architektur

Prozessoren haben ein sehr weites Aufgabenspektrum mit stark unterschiedlichen Anforderungsprofilen. Daher wurden unterschiedliche Prozessor-Architekturen entwickelt, die unterschiedliche Konzepte in Bezug auf Struktur und Funktionsweise verwirklichen.

Prozessor-Familie

Die Prozessor-Familie stellt eine spezifische, hochentwickelte Architektur dar, die den Prozessor charakterisiert und sich von anderen Prozessor-Familien deutlich unterscheidet. Jede Prozessor-Familie hat einen eigenen Befehlssatz und benötigt einen nur für diese Prozessor-Familie geeigneten Compiler zur Programmerstellung.


Q

Glossar -> Q

Quellenfarbe

Jede Quelle im Automatic Line Coloring verfügt über eine Linien- und eine Füllfarbe. Mit diesen Farben werden die durch die Quelle versorgten Netzelemente eingefärbt.

Quellrezept

Rezept, das auf ein Zielrezept kopiert wird. Das Quellrezept wird auf das Zielrezept kopiert.

Querverweisliste

Darstellung für Querbeziehungen innerhalb eines Projekts, z.B. an welchen Stellen Variablen oder Funktionen verwendet werden.


R

Glossar -> R

Raster

Geichmäßige Unterteilung einer Fläche, eines Volumens oder einer Menge. Dient zur Auswahl, Orientierung, Sortierung oder Verteilung.

Raster-Einstellungen

Bestimmung der Bedingungen eines Rasters wie Linienabstände.

RDL

Ist ein von Microsoft definierter Standard zur Definition von Reports im XML-Format.

Reaktionsmatrix

Eine Zusammenstellung von Zuständen, die mit beliebig vielen Variablen verknüpft werden können. Bei jeder Wertänderung einer Variablen wird die Reaktionsmatrix ausgewertet und der erste zutreffende Zustand löst die projektierte Reaktion aus. Reaktionen können sein: Farbumschläge, Alarme, Funktionenausführungen usw.Im Gegensatz zu den Grenzwerten können Reaktionsmatrizen zusätzlich Statusinformationen überwachen.

reaktivieren

Fasst idente Alarme in der der Alarmmeldeliste zu einem einzigen Eintrag zusammen. Dargestellt werden können die kumulierte Alarmanzahl, sowie Zeit und Status des letzten aufgetretenen Alarms.

Rechtsklick

Das Betätigen der rechten Maustaste.

Redundanz

Bedeutet, dass ein Projekt doppelt ausgelegt ist. Das redundante System setzt sich aus Server (=Hauptsystem) und Standby (=Ersatzsystem) zusammen.Ein redundantes System wird zur Erhöhung der Ausfallsicherheit eingesetzt. Dabei werden alle Daten - projektierte Daten wie die zur Laufzeit erzeugten Daten - doppelt gehalten.Es wird zwischen Hardwareredundanz und Softwareredundanz unterschieden.

REE

Teil des Moduls Batch Control zur Ablaufsteuerung von Rezepten. Die Engine führt ein Kontrollrezept aus und verwaltet den gesamten Ablauf des Rezepts.

Register

Eine Bezeichnung für Speicheradressraum, der mit 16 Bit (Integer) adressiert wird. Bei Input Register ist nur lesender Zugriff möglich, bei Holding Register lesender und schreibender Zugriff. Wird bei Modbus verwendet.

Registerkarte

Bezeichnet die einzelnenen Einstellseiten von Dialogen des Bildeditors, der Rezepteditioren usw...

Regler

Beeinflusst selbsttätig in einem meist technischen Prozess eine oder mehrere physikalische Größen auf ein vorgegebenes Niveau unter Reduzierung von Störeinflüssen.

Reihenklemme

Eine Klemme dient in der Elektrotechnik zum lösbaren Anschluss oder der Verbindung von Drähten, Adern und Leitungen. Reihenklemmen sind beliebig aneinander anreihbar auf einer Tragschiene (zum Beispiel DIN-Schiene TS35 "Hutschiene") zu befestigen.

relative Position

Von einem anderen Objekt abhängige Position am Bildschirm.

relativer Pfad

Definiert den Weg zu Dateien oder Ordnern unter Angabe von Ordnernanmen ausgehend von einem definierten Startordner (z.B. ..\Ordner).

relativer Schaltpunkt

Abhängig von einem Ereignis wird eine definierte Aktion ausgeführt.

relativer Zeitpunkt

Abhängig von einem Ereignis wird die Aktion ausgeführt.

relativer Zeitraum

Vom momentanen Zeitpunkt abhängiger Zeitbereich mit Start- und Endezeit.

Relativereignis

Der Zeitpunkt des Auftretens des Ereignissses im Production & Facility Scheduler hängt von einem anderen Ereignis, z.B. Schichtbeginn ab.

remanent

Dauerhaft zur Verfügung gestellt.

Remanentdaten

Speichert Daten automatisch auf einem nicht flüchtigen Datenträger, so dass die Daten nach Beendigung der Software oder nach Abschalten des Gerätes erhalten bleiben.

Remote Function Call

Ist einerseits ein Synonym für das Remote Procedure Call-Konzept (kurz RPC). Dieses bezeichnet Verfahren, mit denen Funktionen in einem entfernten System aufgerufen werden. RFC ist anderseits auch der Überbegriff für die SAP eigenen Protokolle und Schnittstellen zur Abwicklung solcher Funktionsaufrufe bis hin zu deren Implementierung.

Remote-Port

TCP-Port, der auf einem entfernten Gerät angesprochen werden soll.

Remote-Transport

Stellt verschiedenste Funktionalitäten zur Verfügung, um ein Projekt auf einem Remote-Computer zu warten: Übertragung der Runtime-Dateien, Setzen des Startprojekts, Starten und Beenden der Runtime etc.

Report

Tabellarische Darstellung von Werten, Meldungen, Grafiken usw... Die Daten können am Monitor angezeigt, als Datei gespeichert und ausgedruckt werden.

Report Builder

Editor von Microsoft zur Bearbeitung von Reports in Form von RDL-Dateien.

Report Generator

Werkzeug zum Erstellen von Reports. Es stehen Funktionen zum Auslesen von Daten aus den verschiedenen Modulen zur Verfügung, z.B. Alarmmeldeliste, Chronologische Ereignisliste, Archivserver, online Werte, beliebige SQL-Datenbanken...Für Archivdaten besteht die Möglichkeit diese zu verändern und in den Archivserver als Handwerte zurückzuschreiben.Die Daten können formatiert und umgerechnet werden. Die resultierenden Reports können angezeigt, gespeichert und gedruckt werden.

Report Viewer

Teil des Moduls Reporting zum Anzeigen von Reports, die auf RDL-Dateien basieren, in der Runtime. Als Datenquellen können AML-, Archiv- und CEL-Daten sowie Online-Werte aus zenon verwendet werden.

Reportfunktion

In Zellen des Report Generators benutzte Funktionen. Diese Funktionen sind nur im Report Generator verfügbar.

Revision

Status von Variablen, bei dem Alarmbehandlung und Befehlsgabe vom Prozessleitsystem unterdrückt werden.Damit ist es einfach möglich, einzelne Anlageteile von der Alarmierung und Verarbeitung vorübergehend auszublenden. Der aktuelle Wert der Steuerung wird weiterhin in den Bildern angezeigt.

Rezept

In Rezepten werden zusammengehörige Daten wie Maschinenparameter oder Formatdaten zusammengefasst gespeichert. Diese Daten können mit einem Arbeitsschritt vom Leitsystem in die Steuerung übertragen werden und umgekehrt. Es wird zwischen Standard-Rezepten und RGM-Rezepten unterschieden.Im Modul Batch Control ist in einem Rezept zusätzlich zu den Daten auch der Ablauf definiert. Dabei wird zwischen Matrix-Rezept und PFC-Rezept unterschieden.

Rezept absetzen

Überträgt ein Rezept vom Leitsystem zur Steuerung.

Rezeptauswahl

Lässt den Anwender ein Rezept auswählen.

Rezeptgruppe

Die Rezeptgruppe fasst RGM-Rezepte im Rezeptgruppen-Manager zusammen. Bei der Rezeptgruppe werden die Variablen und die Min./Max. Werte definiert. Diese Definitionen sind für alle RGM-Rezepte in der Rezeptgruppe gültig.

Rezeptgruppen-Manager

Ein Modul zur Verwaltung von Rezeptgruppen und den dazugehörenden Rezepten. Bei der Rezeptgruppe werden Variablen, Filter und sonstige Einstellungen definiert. Die zughörigen Rezepte übernehmen diese Einstellungen. Bei den Rezepten wird die auszuführende Aktion, z.B. Wert absetzen, Status ändern, Wert von einer anderen Variable übernehmen usw. eingestellt.

Rezeptgruppen-Name

Eindeutiger Name einer Rezeptgruppe im Rezeptgruppen-Manager

Rezeptimport

Der Import eines Standard-Rezepts bzw. RGM-Rezepts.

Rezeptname

Eindeutiger Name eines Rezepts (Standard-Rezepte und RGM-Rezepte)

Rezeptnummer

Eindeutige Nummer eines RGM-Rezepts

Rezeptwert

Der Rezeptwert ist der Wert, der beim Absetzen des Rezepts vom Leitsystem zur Steuerung übertragen wird. Beim Lesen von der Steuerung wird der Rezeptwert im Leitsystem mit dem Wert aus der Steuerung überschrieben.

RGM-Rezept

RGM-Rezepte ermöglichen eine gruppierte Rezeptverwaltung. Jedes RGM-Rezept ist einer Rezeptgruppe zugeordnet. Es können alle Datentypen verwendet werden. Es können Status verarbeitet werden. Es können Zuweisungen von einer Variablen auf die andere durchgeführt werden.

Ringpuffer

Ein Ringpuffer speichert kontinuierlich eine einstellbare Datenmenge. Ist der Speicherplatz voll werden die Daten entweder nach dem FIFO oder nach dem LIFO Prinzip überschrieben.

Rohrleitung

Vektor-Element, das eine Polylinie darstellt, bei der bei Linienstärke > 1 die Füllfarbe eingestellt werden kann.

Rück

Taste, die Zeichen links vom Cursor löscht.

Rückgabeparameter

Dient zum Auslesen von Istzuständen aus dem Prozess. Der Wert kann in Bedingungen als Vergleichswert herangezogen werden und es können damit Reaktionen verknüpft werden.Ein Rückgabeparameter ist ein Platzhalter und muss mit einer zenon Variablen verknüpft werden.

Rückleseordner

Ordner, aus dem Archivdateien z.B. für den Erweiterten Trend und den Report Generator gelesen werden können.

Rückmeldevariable

Variable, die bei der Befehlsgabe den Wert/Status von der Steuerung zurückliest.

Rückspeisung

Bezeichnet den Betriebsmodus eines elektrischen Bauelements entgegen seiner primären Richtung, z.B.: rückspeisefähiger Transformator.

Runtime

Die Runtime / Laufzeitumgebung lässt Projekte plattformunabhängig ablaufen, das heißt, unabhängig von der verwendeten Hardware und dem Betriebssystem. Eine Laufzeitumgebung stellt die „Plattform“ dar, in der die Projekte ablaufen. Die Runtime benötigt zum Ablauf keine Entwicklungsumgebung.

Runtime-Dateien

Sind vom Editor erzeugten Dateien, die von der Runtime gelesen und interpretiert werden. Einige Runtime-Dateien werden von der Runtime modifiziert; z.B. Standard-Rezepte,Rezeptgruppen-Manager etc.Die Runtime-Dateien werden im Runtime-Ordner abgelegt.

Runtime-Daten

Alle Daten, die von der Runtime erzeugt und verwaltet werden, z.B. Daten der Alarmmeldeliste, der Chronologischen Ereignisliste, des Archivservers... Dazu gehören auch die Daten, die vom Editor erzeugt werden (Runtime-Dateien) und in der Runtime geändert werden können, wie z.B. Daten von: Standard-Rezepte, Rezepgruppen-Manager, Benutzerverwaltung usw.

Runtime-Hilfe

Bietet die Möglichkeit, in der Runtime zu Elementen (aufrufbar über das Kontextmenü) oder in der Alarmmeldeliste (über einen Button) Hilfekapitel aus einer CHM-Datei aufzurufen.

Runtime-Ordner

In diesen Ordner werden die Runtime-Dateien des Projekts gespeichert. Der Pfad wird beim Setzten des Startprojekts in die zenon6.ini eingetragen.Der Runtime-Ordner kann in den Projekt-Eigenschaften geändert werden.Im Runtime-Ordner befinden sich der Unterordner 'RT' und ein Unterordner mit dem Namen des Rechners. Im Ordner 'RT' befinden sich alle Runtime-Dateien, die vom Editor erzeugt werden. Im Ordner 'Rechnername' befinden sich alle Datendateien, die in der Runtime angelegt werden.

Runtimeprofil

Speichert die Positionen der aktuell in der Runtime augeschalteten Bilder sowie die darin angewandten Filter.Die Runtimeprofile sind benutzerabhängig. Ein Administrator kann die Profile anderer Benutzer sowie des Benutzers "System" verwalten.Es können beliebig viele Runtimeprofile gespeichert werden.

Runtime-Server

Rechner im Netzwerk, der ein Projekt geladen hat, das als Serverprojekt definiert ist.

Runtime-Zustand

Information, ob sich die Runtime im Hardware- oder im Simulationsmodus befindet.


S

Glossar -> S

S7-Graph

S7-Graph setzt auf der Siemens Programmiersoftware Step 7 auf. Es wird für sequentielle Abläufe mit alternativen oder parallelen Schrittfolgen (SFC) verwendet. In der Runtime kann der momentane Zustand der Ablaufsteuerung in der SPS direkt im gleichnamigen Bildtyp dargestellt werden.

S7-Graph Heuristik

Analysiert die S7-Graph Schrittketten und ermittelt alle Transitionen, die ein Weiterschalten verhindern. Die Bedingungen, die ein Weiterschalten verhindern, werden in der Meldungsvariablen ausgegeben.

S7-Import

Die Variablen eines S7-Projekts können mit dem S7-Import in die Variablenliste übernommen werden.

S7-PDiag

Ermöglicht die Projektierung der Prozess-Diagnose für Siemens S7. Mit der Prozess-Diagnose lassen sich fehlerhafte Zustände außerhalb des Automatisierungssystems (z. B. Endschalter nicht erreicht) erkennen.

S7-Projektdatei

Ablage für S7-Programme, die in Siemens Step 7 bearbeitet werden können. Die Variablen können mit dem S7-Import in die Variablenliste übernommen werden.

SAP

Deutsches Softwareunternehmen, das das Softwarepaket SAP ERP herstellt.

SAP Funktion

Eine in zenon definierte Funktion, die einen RFC-Funktionsbaustein im SAP System aufruft.

SAP Interface

Modul zum Datenaustausch von Variablenwerten und Alarmen mit einem externen SAP System.

SCADA

Konzept zur Überwachung und Steuerung technischer Prozesse.

SCADA Logic

In das SCADA System integrierte SPS Logik. Diese hat keine direkte Verbindung zum Prozess, sondern erhält Informationen vorzugsweise über das SCADA-System.

Schablone

Bestimmt die Größe und die Lage eines Bereichs am Monitor, in dem in der Runtime Bilder aufgeschaltet werden. Jedes Bild basiert auf einer Schablone. Bei einer Schablone können weitere Eigenschaften gesetzt werden, die an die darauf basierenden Bilder übertragen werden.

Schabloneneditor

Grafische Oberfläche, mit der die Größe und Lage von Schablonen definiert werden kann.

Schablonenform-Editor

Grafische Oberfläche, mit der die frei definierbare Form von Schablonen definiert werden kann.

Schalter

Dynamisches Element, das den Werte einer Binärvariablen anzeigt und modifiziert. Es kann auch als Taster verwendet werden.

Schaltfläche

Eine Schaltfläche (engl. Button) bezeichnet ein grafisches Element in der Benutzeroberfläche. Durch Anklicken wird der dem Steuerelement zugeordnete Befehl ausgeführt.

Schaltpunkt

Definition eines Zeitpunkts zu dem eine Aktion ausgeführt wird.

Schaltspiel-Zähler

Eine Variable, die zur aufsummierenden Messung der Schaltvorgänge (Ein/Aus), die ein Gerät durchläuft, verwendet wird.

Schaltvorschau

Schalthandlungen werden vor Ausführung in einer Liste angezeigt.

Schaltzeit

Zeitpunkt, zu dem ein Schaltpunkt ausgeführt wird.

Scheduler

Erlaubt die Projektierung von Schalthandlungen (Sollwert setzen bzw. Funktion ausführen), die zu definierten Zeitpunkten ausgeführt werden.Als Datenablage wird die des PFS verwendet. Somit ist ein Umstieg vom Scheduler zum PFS möglich.

Schichtzeiten

Beginn und Endezeit mehrerer Schichten. Die Definition der Zeiten erfolgt im Production & Facility Scheduler

Schieberegler

Regler, dessen Wirkung durch Bewegung entlang einer Skala auf einer Längsachse definiert wird.

Schreibtelegramm

Datenpaket, das zu einer Steuerung gesendet wird, um dort einen oder mehrere Sollwerte zu setzen.

Schrift

Bestimmt die Art, den Schnitt und die Größe einer grafischen Ausprägung für Buchstaben und Ziffern. Jede definierte Schrift bekommt eine eindeutige Nummer, auf die referenziert wird. Dadurch kann die Schrift zentral geändert werden.

Schriftliste

Dient zur Verwaltung von Schriften. In Runtime und Editor können die Schriftlisten online gewechslet werden.

Screenshot

Abbild des kompletten Bildschirminhalts oder eines Teils davon.

Sensor

Technisches Bauteil, das bestimmte physikalische oder chemische Eigenschaften wie Wärmestrahlung, Temperatur, Feuchtigkeit, Druck, Schall, Helligkeit oder Beschleunigung und/oder die stoffliche Beschaffenheit seiner Umgebung qualitativ oder als Messgröße quantitativ erfassen kann und in weiterverarbeitbare Größen (meist elektrische Signale) umwandelt.

Seriennummer

Eindeutige Zeichenfolge mit mehreren Positionen, die durch Punkt getrennt sind. An der ersten Position steht eine eindeutige Produkt-ID. Die restlichen Positionen definieren den Produktumfang. Bei Donglelizenzierung stimmt die Produkt-ID mit der Donglenummer überein.

Server

Ein Programm, das mit einem anderen Programm, dem Client, kommuniziert, um ihm Zugang zu Diensten (Funktionalitäten) und/oder Daten zu verschaffen.

Server-Port

Standardmäßig eingestellter TCP-Port auf einem Server, über den Clients mit dem Server kommunizieren.

Serverprojekt

Projekt mit aktiviertem Netzwerk und eingetragenem Server, das für die gesamte Datenverwaltung verantwortlich ist. Es kann über das Netzwerk (TCP/IP Kommunikation) Daten an angeschlossene Clientprojekte bzw. an ein Standbyprojekt senden bzw. von diesen empfangen.

Service Pack

Service Packs sind kumulierte Fehlerbehebungen für eine Version. Sie durchlaufen den kompletten Qualitätssicherungsprozess. Sie beinhalten alle Builds, die bis dorthin veröffentlicht wurden. Service Pack 0 ist das erste offizielle Release einer neuen Version.

Sicherung

Zusätzliche Speicherung von Daten (z.B. Projekte oder Arbeistbereich) zur späteren Wiederherstellung.

SI-Einheit

Das Internationale Einheitensystem, abgekürzt SI (von frz.: Système international d’unités), ist das auf dem internationalen Größensystem (ISQ) basierende Einheitensystem. Dieses 1960 eingeführte metrische Einheitensystem ist heute das weltweit am weitesten verbreitete Einheitensystem für physikalische Größen.

SIMOTION

System der Firma Siemens zur Automatisierung von Produktionsmaschinen mit dem Schwerpunkt Bewegungssteuerung.SIMOTION setzt sich zusammen aus dem SIMOTION SCOUT und dem SIMOTION Kernel für verschiedene Hardware Plattformen. Der Scout ist das Engineering-System zur Erstellung eines Projektes mit Hardwarekonfiguration und Anwenderdaten.

Simple Network Management Protocol

Verbreitetets Protokoll um Netzwerke zu überwachen und zu protokollieren. SNMP Agenten (Harware und/oder Software) liefern Daten über Aktivitäten aller Komponenten (Hubs, Router, Bridges, etc.) an die MIB (Management Information Base) auf einem Kontrollrechner. Komponenten werden auf Erreichbarkeit überprüft und gesteuert.

Simulation

Es werden Abläufe an einem Modell durchgeführt/durchgespielt um Erkenntnisse über das reale System zu gewinnen oder dieses zu ersetzen.

Simulation - programmiert

Möglichkeit, einen Treiber auf Simulationsmodus zu stellen. Dabei wird keine Kommunikation zur Steuerung aufgebaut, sondern die Werte werden von einem frei programmierbaren Simulationsprojekt berechnet. Das Simulationsprojekt wird mit der zenon Logic Workbench erstellt und läuft in der zenon Logic Runtime ab.

Simulation - statisch

Möglichkeit, einen Treiber auf Simulationsmodus zu stellen. Dabei wird keine Kommunikation zur Steuerung aufgebaut, sondern alle Werte werden mit 0 initialisiert.

Simulation - zählend

Möglichkeit, einen Treiber auf Simulationsmodus zu stellen. Dabei wird keine Kommunikation zur Steuerung aufgebaut, sondern alle Werte werden mit 0 initialisiert und werden in der eingestellten Updatezeit jeweils um 1 bis zum Maximalwert inkrementiert und beginnen dann wieder bei 0.

Simulationsabbild

Speicherbereich, in dem alle Werte der Simulation abgelegt werden.

Simulationsmodus

Im Gegensatz zum Hardwaremodus erfolgt keine Kommunikation mit der Steuerung. Die Variablenwerte werden über die eingestellte Simulationsart (statisch, zählend oder programmiert) berechnet.

Simulationsprojekt

zenon Logic Projekt, das dazu verwendet wird, um eine externe Steuerung zu simulieren. Alle Variablen, die auf dem Treiber basieren, können mit simulierten Werten versorgt werden.

Simulator Treiber

Treiber, auf dem Variablen angelegt werden können, die zum Speichern von Informationen gedacht sind, die nicht auf einer Steuerung gespeichert werden können/sollen. Im Gegensatz zum Intern Treiber ist dieser Treiber numerisch adressiert und die Variablenwerte können in Form verschiedener Inkrement- und Dekrementfunktionen automatisch beeinflusst werden.

Skalierbarkeit

Fähigkeit, sich an verändernde Bedingungen hinsichtlich Größe eines Systems oder Zahl der Komponenten anzupassen.

Skalierung

Größenveränderung bzw. die Anpassung verschiedener Eigenschaften an eine bestehende Skala.

Skript

Zusammenfassung von einzelnen Funktionen, die gleichzeitig angestoßen werden.

Slot-SPS

Als PC-Steckkarte realisierte SPS. Gilt als gehäuselose Hard-SPS.

Softlizenz

Bindet die Nutzung der Software an die Eingabe einer korrekten Lizenznummer.

Softlizenzierung

Lizenzierungsart, bei der die Lizenz an einen bestimmten Rechner gebunden wird. Dazu wird die Lizenznummer verwendet.

Soft-SPS

Eine Soft-SPS (Speicherprogrammierbare Steuerung in Software) besteht aus einem PC oder einem Microcontroller, einer SPS-Software und den E/A-Bausteinen oder Feldbus-Erweiterungen wie z.B. Busklemmen.

Softwareredundanz

Redundantes System, bei dem nur vom Server aus auf die Steuerung geschrieben wird. Der Standby hat nur lesenden Zugriff.

Sollwert

Wert, der zur Steuerung übertragen wird und den dort vorhandenen Wert überschreiben soll.

Sollwert absetzen

Überträgt einen Sollwert vom Leitsystem zur Steuerung.

Spalteneinstellungen

Definiert die Spaltenbreite, Spaltenüberschriften, Reihenfolge, Sortierart, Gitterdarstellung, Hintergrundfarben usw.

Spaltentitel

Überschrift für eine Spalte in einer Tabelle.

Spincontrol

Kontrollelement, das mit zwei Schaltflächen mit Pfeilen für hinauf und hinunter ausgebildet ist. Das Element erlaubt es dem Benutzer in einem vorgegebenen Bereich von Werten zu navigieren. Mit den Pfeilschaltflächen wird der angezeigte Wert um eins inkrementiert bzw. dekrementiert.

Spontaner Datenverkehr

Aufbau von Verbindungen im Netzwerk und Übertragung von Daten nur bei Bedarf.

Spontanwert

Aktueller Variablenwert, der mit dem Wert in der Steuerung übereinstimmt, das bedeutet, dass der Wert nicht gestört (I-Bit), nicht auf Revision gesetzt und nicht der Ersatzwert ist.

Sprachdatei

Datei für die Sprachumschaltung, die die Schlüsselwörter und die Übersezungen - getrennt durch ein Pipe-Symbol - beinhaltet.Die Dateien werden in der Sprachtabelle angezeigt und im Projektmanager im Knoten Dateien/Sprachdateien verwaltet.

Sprachtabelle

Eine Tabelle zur Organisation von Sprachdateien für die Online-Sprachumschaltung in Editor und Runtime.

Sprachumschaltung

Ermöglicht in Editor und Runtime den Wechsel zwischen Sprachdateien, z.B. Umschaltung von Deutsch auf Englisch.

Sprungziel

Element des Moduls Batch Control, das einen direkten Sprung auf eine definierte Stelle eines Zweiges ermöglicht.

SPS

Eine Speicherprogrammierbare Steuerung (SPS, engl. Programmable Logic Controller, PLC) ist eine Baugruppe, die zur Steuerung und/oder Regelung einer Maschine oder Anlage eingesetzt wird. In der Regel ist eine solche Baugruppe elektronisch ausgeführt und ähnelt den Baugruppen eines Computers. Die Geber (Sensoren) und die Stellglieder (Aktoren) sind mit dieser Baugruppe verbunden. Das zugehörige Betriebssystem (Firmware) stellt sicher, dass dem Anwenderprogramm immer der aktuelle Zustand der Geber zur Verfügung steht. Anhand dieser Informationen kann das Anwenderprogramm die Stellglieder so ein- oder ausschalten, dass die Maschine oder die Anlage in der gewünschten Weise funktioniert.

SPS-Treiber

Ist ein Computerprogramm oder -modul, das zur Interaktion mit angeschlossenen Steuerungen dient.

SQL Server Dienst

Prozess, der Datenbankfunktionalität bereitstellt. Um mit dem Editor arbeiten zu können, muss der Dienst gestartet sein.

SQL-Datenbank

Datenbanksystem zur elektronischen Datenverwaltung, das als Abfragesprache SQL (Structured Query Language) unterstützt. Meist handelt es sich um eine relationale Datenbank.

Stammknoten

Erste Ebene in einer Baumstruktur.

Standard-Funktion

Für einige Module kann direkt in der Detailansicht eine vordefinierte Funktion angelegt werden. Dabei wird jene Funktion verwendet, die mit dem Modul am häufigsten verwendet wird, z.B. "Sollwert setzen" bei Variablen.

Standard-Port

Standardmäßig eingestellter TCP-Port, über den die Anwendung normalerweise kommuniziert.

Standardprofil

Mit dem Standardprofil wird das Aussehen des Editor wieder in den Auslieferungszustand zurückgesetzt. Alle Symbolleisten, Fensterpositionen usw. werden wieder in den Ursprungszustand zurückgesetzt.

Standard-Rezept

Standard-Rezepte sind eine einfache Rezeptverwaltung ohne Strukturen/Gruppen. Es können alle Datentypen außer Strings verwendet werden. Es können keine Status verarbeitet werden. Es können keine Zuweisungen von einer Variablen auf die andere durchgeführt werden.

Standbyprojekt

Projekt mit aktiviertem Netzwerk und eingetragenem Standby-Server. Das Projekt ist redundant mit dem Serverprojekt für die gesamte Datenverwaltung verantwortlich. Alle Daten kommen vom Serverprojekt und werden lokal gespeichert. Nach dem Erkennen des Ausfalls des Serverprojekts wird das Projekt selbst zum Serverprojekt hochgestuft und übernimmt damit die Datenhoheit. Ab dann können sich Clientprojekte verbinden.

Standby-Server

Programm, das über alle aktuellen Daten und Verbindungen des Servers verfügt und bei dessen Ausfall spontan die Serveraufgaben übernimmt.

Starter Edition

Module mit eingeschränktem Funktionsumfang, die im Basispaket (außer für Windows CE) enthalten sind.

Startindex

Definiert den Startpunkt eines Arrays.

Startprojekt

Das Projekt, das beim Starten der Runtime als erstes geladen wird. Pro Rechner kann es nur ein Startprojekt geben. Es wird in der Datei 'zenon6.ini' gespeichert.

Startup Tool

Programm zur Verwaltung von verschiedenen Versionen. Die versionsabhängigen Komponeten wie Datenbankdienst, Transportservice, ActiveX Elemente usw. können registriert und die Applikationen gestartet werden. Es können zusätzliche Parameter wie Sprache, Übergabeparameter, verwendeter SQL Server, Startprojekt usw. eingestellt werden.

Statischer Text

Vektor-Element, das einen fixen Text darstellt.

Status

Aktueller Zustand eines Vorgangs, eines Gerätes, einer Variable, usw.

Statusverarbeitung

Ist die Möglichkeit Status zu lesen, zu schreiben, anzuzeigen und danach zu filtern.Jede Variable besteht in der Runtime aus einem Wert, einem Zeitstempel und einem 64 Bit Statusregister.

Step 7

Programmiersoftware für Siemens Simatic. STEP steht für STeuerungen Einfach Programmieren

Step 7 Datei

Projektdatei für das Siemens Programmiersystem Step 7. Die Variablen dieser Projekte können mit dem S7-Import in die Variablenliste übernommen werden.

Stoßfreie Redundanz

Mechanismus, bei dem der Standby durch Datenpufferung die Totzeit bei Serverausfall überbrückt. Dadurch wird Datenausfall bei einem Serverausfall verhindert.

straton Applikation

Alle Programme, alle Variablen und die I/O Konfiguration eines straton Projekts.

straton Runtime

Lässt straton Projekte plattformunabhängig ablaufen, das heißt, unabhängig von der verwendeten Hardware und dem Betriebssystem. Eine Laufzeitumgebung stellt die „Plattform“ dar, in der die Projekte ablaufen. Die Runtime benötigt zum Ablauf keine Workbench.

straton Runtime mit Realtime Kernel

Laufzeitsystem für harte Echtzeit, das unabhängig vom Betriebssystem läuft.

Stringvariable

Variable, deren Wert aus einer alphanumerischen Zeichenfolge besteht.

Stringwert

Eine Zeichenfolge. Kann Ziffern, Buchstaben und Sonderzeichen beinhalten.

Structured Query Language

Datenbanksprache zur Definition, Abfrage und Manipulation von Daten in relationalen Datenbanken. SQL ist von ANSI und ISO standardisiert und wird von fast allen gängigen Datenbanksystemen unterstützt. SQL umfasst die folgenden Datenbanksprachen: Data Manipulation Language, Data Definition Language, Data Control Language.

Struktur-Datentyp

Zusammengesetzte Struktur, die aus Struktur-Elementen zusammengesetzt ist. Diese können Einfache Datentypen bzw. bestehende andere Struktur-Datentypen sein.

Struktur-Element

Ein Teil eines Struktur-Datentyps. Es basiert entweder auf einem Einfachen oder einem Struktur-Datentyp. Bei Einfachen Datentypen kann unterschieden werden, ob diese eingebettet oder verknüpft werden. Eingebettet bedeutet, dass eine Kopie des Datentyps erzeugt wird und alle Eigenschaften damit beim Struktur-Element einstellbar sind. Bei verknüpften Datentypen wird nur eine Referenz auf den Datentyp hergestellt. Alle Eigenschaften werden von dort übernommen.

Strukturierter Text

Eine der fünf in IEC 61131 definierten Programmiersprachen. ST bietet mehr Strukturierungsmöglichkeiten als AWL und löst diese daher immer mehr ab. Bei Step 7 als SCL (Structured Control Language) bezeichnet.

Symbol

Zusammenfassung von unterschiedlichen Dynamischen Elementen und Vektor-Elementen zu einem neuen Element dessen Größenänderung sich proportional auf alle enthaltetnen Elemente auswirkt.Ein Symbol kann entweder in einem Bild eingebettet sein oder verknüpft sein. Verknüpfte Symbole werden in der Globalen Symbolbibliothek oder in der Projekt-Symbolbibliothek gespeichert werden.

Symbol bewegen

Dynamisches Elemnt, das ein Symbol abhängig von Variablenwerten verschiebt, dreht und in der Größe ändert.

Symboleditor

Bereich im Hauptfenster, in dem Symbole gezeichnet und konfiguriert werden. Ergänzend zum Bildeditor können im Symboleditor die Eigenschaften der Symbolelemente freigegeben werden.

Symbolelement

Einzelnes Dynamisches Element oder Vektor Element, das in einem Symbol eingebettet ist.

Symbolleiste

Eine Reihe, eine Spalte oder ein Block von Schaltflächen, die auf dem Bildschirm angezeigt werden. Wenn Sie auf diese Schaltflächen klicken, werden die dahinterliegenden Befehle ausgeführt. Die Symbolleisten können angepasst und auf dem Bildschirm verschoben werden. Die Einstellung wird in Editorprofilen gespeichert. Symbolleisten stehen nur im Editor zur Verfügung.

System Treiber

In die Runtime integrierter Treiber, der vordefinierte Variablen zur Verfügung stellt. Diese beinhalten Informationen zum Projekt bzw. zur Hardware, auf der das Projekt gestartet ist.

Systemstatus

Statusinformation eines Computers, z.B. Betriebsystem, Startprojekt, Lizenzierung, Runtime-Status etc.

Systemtreibervariable

Variable, die auf dem System Treiber basiert.


T

Glossar -> T

TAG

Ein TAG entspricht einer externen Variablen unabhängig vom Datentyp. Interne Variablen werden nicht als TAG gezählt. TAGs werden ausschließlich für die Lizenzierung verwendet. Für die Ermittlung der Lizenzgröße wird die Summe der TAGs von folgenden Treibern herangezogen: Alle SPS- und Bus Treiber; nicht gezählt werden: Interne Prozessvariablen (Intern Treiber) sowie Prozessvariablen vom System Treiber, Mathematik Treiber und Simulator Treiber

Task

Ein Programm in VB-Skript oder Java für die Process Control Engine (PCE).

Tastatur

Eine Tastatur ist ein Eingabegerät, das als Bedienelement eine Anzahl von zu drückenden Tasten enthält.

Tastenkombination

Durch das gleichzeitge Drücken vordefinierter Tasten wird eine Aktion angestoßen. Wird als Anwenderhilfe zur Abkürung einer Befehlssequenz verwendet.

TCP

Ist eine Vereinbarung (Protokoll) darüber, auf welche Art und Weise Daten zwischen Computern ausgetauscht werden sollen. Alle Betriebssysteme moderner Computer beherrschen TCP und nutzen es für den Datenaustausch mit anderen Rechnern. Das Protokoll ist ein zuverlässiges, verbindungsorientiertes, paketvermittelndes Transportprotokoll in Computernetzwerken. Es ist Teil der Internetprotokollfamilie, der Grundlage des Internets.

TCP/IP

Ist eine Familie von Netzwerkprotokollen und wird wegen ihrer großen Bedeutung für das Internet auch als Internetprotokollfamilie bezeichnet.

Technologische Funktion

Entsprechung der Grundfunktion in der Steuerung. In ISA 88 wird der Begriff Process Action dafür verwendet. (ISA 88: Process Action)

Terminal Server

Der Terminal Server ermöglicht Remotecomputern den Zugriff auf Windows-basierte Programme, die unter Windows Server 2003 Standard Edition, Windows Server 2003 Enterprise Edition oder Windows Server 2003 Datacenter Edition ausgeführt werden. Benutzer können von Remotestandorten aus Programme ausführen, Dateien speichern und Netzwerkressourcen verwenden, als wären diese Ressourcen auf ihren eigenen Computern installiert.

Text Button

Dynamisches Element mit dem eine Aktion (Funktion ausführen, Sollwert setzen) ausgelöst wird. Der Text Button kann nur Text darstellen. Ab 6.50 wird er durch das Dynamische Element Button ersetzt.

Thread

Bezeichnet in der Informatik einen Ausführungsstrang oder eine Ausführungsreihenfolge in der Abarbeitung eines Programms. Ein Thread ist Teil eines Prozesses.

Tick

Teilstrich einer Skala oder Achse. Es wird unterscheiden zwischen Hauptticks und Nebenticks.

TIFF

Das Tagged Image File Format ist ein Dateiformat zur Speicherung von Bilddaten. Das TIF-Format wurde ursprünglich von Aldus (1994 von Adobe übernommen) und Microsoft für gescannte Rastergrafiken für die Farbseparation entwickelt.

Timeout

Zeitspanne, innerhalb der ein Ereignis eintreten muss, bevor eine bestimmte Reaktion angestoßen wird.

Tolpologische Einfärbung

Repräsentiert den elektrischen Zustand einer Leitung bzw. eines Schaltgeräts durch Farbgebung.

Tooltip

Hinweis, der automatisch angezeigt wird, wenn der Mauszeiger eine bestimmte Zeit auf einem Element verweilt.

Topologische Leitung

Vektor-Element zur Linieneinfärbung für die topologische Darstellung von elektrischen Netzen. Nur für SICAM 230 verfügbar.

Topologische Verriegelung

Durch die Projektierung des elektrischen Netzes automatisch errechnete Verriegelung, z.B.: Spannung gegen Erde.

Topologischer Strang

Dynanisches Element zur Linieneinfärbung für die topologische Darstellung von elektrischen Netzen. Nur für SICAM 230 verfügbar.

Touchpanel

Gerät mit einer berührungsempfindlichen Datrstellungsoberfläche (Touchscreen).

Touchscreen

Eingabegerät, bei dem durch Berührung von Teilen eines Bildes der Programmablauf eines technischen Gerätes, meist eines Computers, scheinbar direkt gesteuert werden kann. Das durch den Touchscreen „berührungsempfindliche“ Bild kann dabei sowohl dynamisch mittels Monitoren oder über Projektion, als auch physikalisch (z. B. gedruckt) generiert worden sein.

Transition

Element des Moduls Batch Control, das eine Bedingung beinhaltet. Das Element wird nach Grundfunktionen eingesetzt um einen definierten Übergang von einer Grundfunktion in die nächste zu gewährleisten.

Trap

Steht im Bereich der Computertechnik für eine Ausnahme oder einen Fehler. Es ist typischerweise ein synchroner Interrupt, der von einer Ausnahmebedingung ausgelöst wird, z.B. Breakpoint, Division durch Null, ungültiger Speicherzugriff, usw.

Treiber

Ist ein Computerprogramm oder -modul, das die Interaktion mit angeschlossenen oder eingebauten Geräten (Hardware) steuert. Dazu nutzt es Schnittstellen zum Kommunikationsbus oder anderen Kommunikationssystemen, an denen das Gerät angeschlossen ist, um Steuersignale und/oder Daten zum Gerät zu senden bzw. von ihm zu empfangen.

Treiberabbild

Jeder Treiber verwaltet darin den momentanen Zustand des Prozesses bzw. der Signalzustände. Änderungen darin werden mit dem Prozessabbild synchronisiert.

Treiberkommando

Ein Befehl, um einen Treiber in einen definierten Zustand zu versetzen. Beispiel: Treiber starten, stoppen usw...

Treiber-Objekttyp

Spezifiziert einen Bereich der Steuerung. Ist je nach Hersteller unterschiedlich. Mögliche Typen sind: Merker, Datenbaustein, Holding Register, Coil...

Treibersimulation

Dabei wird ein einzelner Treiber in den Simulationsmodus geschaltet, d.h. er hat keine Prozesskommunikation. Es gibt die drei Ausprägungen: Simulation - programmiertSimulation - zählendSimulation - statisch

Trend-Element

Dynamisches Element zur Darstellung von Werten in Form von Trendkurven.

Trendkurve

Zeigt den Verlauf eines Variablenwerts an. Die Kurve kann vom Variablenwert direkt (online Trend) oder von archivierten Werten (historischer Trend) gebildet werden. Kurven können im Erweiterten Trend oder im dynamischen Element 'Trendkurve' angezeigt werden.

Triggervariable

Variable, die durch eine Wertänderung etwas auslöst, z.B. eine Zuweisung durchführt oder Werte ins Archiv schreibt.

TÜV

Eingetragene Vereine, die technische Sicherheitskontrollen, insbesondere auch solche die durch staatliche Gesetze oder Anordnungen vorgeschrieben sind, auf privatwirtschaftlicher Basis durchführen. Mitglieder sind seit Gründung des ersten Dampfkessel-Revisions-Vereins - so der ursprüngliche Name - im Jahre 1866 Wirtschaftsunternehmen, die überwachungsbedürftige Anlagen betreiben.


U

Glossar -> U

Übersichtsfenster

Ein Darstellungsbereich in der Runtime, der es ermöglicht, ein Mehrmonitorprojekt auf einem einzelnen Monitor darzustellen.

UDP

Ist ein minimales, verbindungsloses Netzwerkprotokoll, das zur Transportschicht der Internetprotokollfamilie gehört. Aufgabe von UDP ist es, Daten, die über das Internet übertragen werden, der richtigen Anwendung zukommen zu lassen.UDP stellt einen verbindungslosen, nicht-zuverlässigen Übertragungsdienst bereit. Das bedeutet, es gibt keine Garantie, dass ein einmal gesendetes Paket auch ankommt, dass Pakete in der gleichen Reihenfolge ankommen, in der sie gesendet wurden, oder dass ein Paket nur einmal beim Empfänger eintrifft. Eine Anwendung, die UDP nutzt, muss daher gegenüber verlorengegangenen und unsortierten Paketen unempfindlich sein oder selbst entsprechende Korrekturmaßnahmen beinhalten.

Uhr

Dynamisches Element, das die aktuelle Uhrzeit und das Datum anzeigt. Es kann auch zur Umrechnung von numerischen Werten in eine Uhrzeit/Datum verwendet werden.

Umrechnungseinheit

Maßeinheit, deren Wert bei der Einheitenumschaltung aus dem Wert der Basiseinheit berechnet wird: Der Wert wird mit einem Faktor multipliziert und um einen Offset verschoben. Zusätzlich kann eine Kommaverschiebung angegeben werden.

Umschalttaste

Die Taste wird hauptsächlich benutzt, um statt eines Kleinbuchstabens durch gleichzeitiges Drücken der Umschalttaste den entsprechenden Großbuchstaben einzugeben. Daneben dient sie zur Eingabe verschiedener Sonderzeichen, die den Nummerntasten des alphanumerischen Tastaturbereichs zugeordnet sind.

Universalregler

Dynamisches Element, das Regler in verschiedensten Ausprägungen darstellt. Variablenwerte können in Form von Schiebereglern, Bargrafen, LED Balkenanzeigen usw. angezeigt werden.

Unsichtbarer Button

Dynamisches Element, mit dem eine Aktion (Funktion ausführen, Sollwert setzen) ausgelöst wird. Der Unsichtbare Button wird als transparentes Element dargestellt. Ab 6.50 wird er durch das Dynamische Element Button ersetzt.

Unterprojekt

Eigenständiges Projekt, das einem Integrationsprojekt unterlagert ist. Siehe Mehrprojektverwaltung.

URL

Steht für Uniform Resource Locator und identifiziert und lokalisiert eine Ressource über das verwendete Netzwerkprotokoll (beispielsweise HTTP oder FTP) und den Ort (engl. location) der Ressource in Computernetzwerken.

User Control

Kombiniert die Funktionalität eines oder mehrerer WPF-Steuerelemente (Windows Presentation Foundation) mit benutzerdefiniertem Code.

UTC

Die koordinierte Weltzeit, international als UTC (engl. "Coordinated Universal Time") abgekürzt, ist die heute gültige Weltzeit. Eingeführt wurde sie 1972. Die Genauigkeit ist in Sekunden.Von der koordinierten Weltzeit werden ausgehend vom Nullmeridian, der durch den Londoner Stadtteil Greenwich verläuft, die Zeiten in den verschiedenen Zeitzonen der Erde abgeleitet. UTC ersetzt die Greenwich Mean Time (GMT).


V

Glossar -> V

Variable

Eine Variable repräsentiert einen Wert im Speicher des Leitsystems. Es gibt interne und externe Variablen.Variablen basieren auf einem Datentyp und einem Treiber-Objekttyp. Bei den Variablen werden sehr viele Eigenschaften zentral gespeichert, die an unterschiedlichen Stellen im Leitsystem genutzt werden. Beispielsweise im Editor projektierbare Eigenschaften wie die Einheit, der Messbereich, usw. In der Runtime sind zusätzlich Status und Zeitstempel Teil der Variablen.

Variablen-Diagnose

Bildtyp zur Anzeige von Variablenwerten, Zeitstempeln und Status. Variablenwerte können auch abgesetzt werden.

Variablenname

Eindeutige Bezeichnung für eine Variable.

VB.NET

Ist eine vom Softwarehersteller Microsoft im Rahmen seiner .NET-Strategie von Visual Basic aus weiterentwickelte Programmiersprache.

VBA

Ist eine zu den Microsoft-Office-Programmen gehörende Skriptsprache. Sie wurde aus dem von Microsoft entwickelten BASIC-Dialekt Visual Basic (VB) abgeleitet und wurde zur Steuerung von Abläufen innerhalb der Microsoft-Office-Programme entwickelt.In zenon wird VBA im Editor zur Automatisierung der Projektierung angeboten und in der Runtime zur Erweiterung des Funktionsumfangs.

Vektor-Element

Ein Vektor-Element ist ein grafisches Darstellungselement. Die interne Verwaltung basiert auf Vektoren. Dadurch ist eine verlustfreie Größenänderung möglich. Im Gegensatz zu einem Dynamischen Element wird kein Variablenwert repräsentiert.

Vektorgrafik

Setzt sich aus mathematischen Primitiven zusammen, die sich zweidimensional in der Ebene beschreiben lassen, wie Linien, Kreise, Polygone oder allgemeine Kurven. Vektorgrafiken erlauben im Gegensatz zu Rastergrafiken verlustfreie Größenänderungen.

Verbindungslinie

Teil des Verbindungsstücks im Modul Batch Control: Positioniert den Verbindungspunkt am Element.

Verbindungspunkt

Teil des Verbindungsstücks im Modul Batch Control. Verbindet zwei Elemente (z.b: Grundfunktion mit Grundfunktion oder Grundfunktion mit Linie) miteinader. Er ändert die Farbe wenn der Mauszeiger darüber steht.

Verbindungsstück

Möglichkeit im Modul Batch Control, Elemente miteiander zu verbinden. Es besteht aus Verbindungspunkt und Verbindungslinie.

Verbindungs-Timeout

Zeitspanne, während der keine Rückmeldung der Steuerung erfolgen kann ohne dass darauf reagiert wird.

verknüpfter Datentyp

Datentyp, der in einem Struktur-Datentyp als Struktur-Element eingebunden ist, aber im Gegensatz zum eingebetteten Datentyp nur eine Referenz auf den Datentyp enthält.

verknüpftes Element

(1) Ein Element, das in einem anderen Element verwendet wird, z.B.: Ein Zahlenwert ist mit einer Variablen verknüpft und zeigt deren Wert an.(2) Ein Element, das als Basis für das Element dient, z.B.: Ein Datentyp und ein Treiber bilden die Grundlage für eine Variable.

verknüpftes Symbol

Symbol aus einer Symbolbibliothek, das in einem Bild referenziert wird. Der Speicherort befindet sich in der Bibliothek. Das Symbol kann nur dort geändert werden. Im Gegensatz dazu gibt es die eingebetteten Symbole, die im Bild gespeichert sind.

vermaschtes Netz

Jeder Netzwerkknoten ist mit einem oder mehreren anderen Knoten verbunden. Die Informationen werden von Knoten zu Knoten weitergereicht, bis sie das Ziel erreichen. Wenn jeder Teilnehmer mit jedem anderen Teilnehmer verbunden ist, spricht man von einem vollständig vermaschten Netz. Vermaschte Netze sind im Regelfall selbstheilend und dadurch sehr zuverlässig: Wenn ein Knoten oder eine Verbindung blockiert ist oder ausfällt, kann sich das Netz darum herum neu stricken. Die Daten werden umgeleitet und das Netzwerk ist nach wie vor betriebsfähig.

Verpackungsanlage

Zusammenstellung von Maschinen, deren Aufgabe das automatische Verpacken von Produkten ist.

Verriegelung

Ermöglicht es, die Eingabe von Werten bzw. die Ausführung von Aktionen abhängig von Variablenwerten und/oder Status zu unterbinden.

Verriegelungesbedingung

Logische Formel die definiert, wann die Verriegelung erfolgt. Wenn das Ergebnis der Formel wahr ist, ist die Verriegelung aktiv.

Verriegelungsvariable

Variable, mit der die Verriegelungesbedingung für eine Verriegelung erstellt wird.

Verteiltes Engineering

Gleichzeitiges Bearbeiten eines Projekts im Editor durch mehrere Benutzer auf mehreren Computern.

Verzögerungszeit nach Verbindungsabbruch

Zeitspanne, die nach einem Abbruch der Verbindung gewartet wird, bis ein neuer Verbindungsversuch gestartet wird.

Verzweigung

Bereich des Moduls Batch Control, der eine Aufteilung in zwei oder mehrere Zweige ermöglicht, von denen beim Rezeptablauf immer nur ein Zweig aktiv werden kann. Es handelt sich um eine Entweder-Oder-Verzweigung.Eine Verzweigung beginnt immer mit dem Element Anfang Verzweigung und endet mit dem Element Ende Verzweigung.

VGA

Bezeichnet einen Computergrafik-Standard (EISA, 1987), der bestimmte Kombinationen von Bildauflösung und Farbanzahl (Farb-Bit-Tiefe) sowie Wiederholfrequenz definiert. Heute steht VGA meist für die Auflösung von 640 × 480 Pixeln.

Video

Bildtyp zur Darstellung einer AVI-Datei oder eines online Videostreams. Die online Daten können auch als AVI- oder BMP-Datei abgespeichert werden.

virtueller Monitor

In einem Mehrmonitorsystem können Bilder einem virtuellen Anzeigebereich zugeordnet werden. Bei der Bildumschaltung in der Runtime oder bereits in der Monitorverwaltung wird festgelegt, auf welchem real existierenden Monitor das Bild aufgeschaltet wird.

Visual Basic

Visual Basic ist eine proprietäre objektorientierte Programmiersprache, deren neuere Versionen auf dem Microsoft .NET-Framework basieren. Um zwischen den alten, nicht vollständig objektorientierten, und den neuen, auf dem .NET-Framework basierenden Versionen zu unterscheiden werden erstere bis inklusive Visual Basic 6.0 als Visual Basic Classic, die letzteren hingegen als Visual Basic .NET (Abk. VB.NET) bezeichnet.

Visualisierung

Von lateinisch 'visualis', 'zum Sehen gehörig'. Bezeichnet im Allgemeinen die Darstellung eines abstrakten Sachverhaltes mit optischen Mitteln, also die bildliche Aufbereitung, Darstellung und Kommunikation von Information und umfasst alle Arten bildlicher Repräsentation und Sichtbarmachung. Visualisierung meint nicht nur Illustration, sondern drückt komplexe Inhalte mit eigenen Mitteln aus.

VSTA

Eine von Microsoft entwicklete Entwicklungsumgebung (IDE), mit der in den Programmiersprachen VB.NET und C# programmiert werden kann.VSTA ist das Nachfolgeprodukt für VBA.In zenon wird VSTA im Editor zur Automatisierung der Projektierung angeboten und in der Runtime zur Erweiterung des Funktionsumfangs.


W

Glossar -> W

Warten-Kontroll-System

Übernimmt Alarme und erstellt daraus über die SAP RFC-Schnittstelle Störmeldungen in einem SAP ERP System. Die Alarmmeldungen aus zenon werden in einer Datenbank für spätere Auswertungen abgelegt. Die Darstellung erfolgt in einer Liste, in der ein Wartenführer Meldungen klassifizieren kann. Nur schwerwiegende Alarme („Grossstörungen“) werden in das SAP System übernommen.

Wartung

Als Wartung werden gemäß DIN 31051 (Stand 2003) Maßnahmen zur Verzögerung des Abbaus des vorhandenen Abnutzungsvorrates der Betrachtungseinheit verstanden.Die Wartung wird im Allgemeinen in regelmäßigen Abständen und häufig von ausgebildetem Fachpersonal durchgeführt. So kann eine möglichst lange Lebensdauer und ein geringer Verschleiß der gewarteten Objekte gewährleistet werden. Fachgerechte Wartung ist oft auch Bestandteil der Gewährleistung.

Wartungsmeldung

Instandhaltungs- oder Servicemeldung, die an das SAP Wartungsmodul übertragen wird.

WAV

Ist ein Containerformat zur digitalen Speicherung von Audiodaten.

Webclient

Stellt Projekte in einem Webbrowser wie z.B. Internet Explorer oder Firefox dar.

Webserver

Ist ein Dienst, der Dokumente an Clients wie z. B. Webbrowser überträgt.

Weiterschaltbedingung

Wenn die Bedingung erfüllt ist, ist die Grundfunktion fertig ausgeführt und der im Rezept projektierte Ablauf wird weiter fortgesetzt.

Weltbild

Ein Bild, das größer als der am Monitor darstellbare Bereich (=Schablonengröße) ist. Es lassen sich damit Übersichtsbilder erstellen, um einen möglichst großen Anlagenbereich darzustellen.Das Weltbild unterstützt zooming und decluttering, d.h. je nach eingestellter Zoomstufe können unterschiedliche Elemente bzw. Details dargestellt werden.Das Weltbild unterstützt das Setzen von Objektmarken. Wird ein Objekt in der Runtime ausgewählt, wird es mittig im Bild positioniert und markiert.

Weltbild-Übersicht

Bildtyp zur verkleinerten Darstellung eines Weltbilds und zur Navigation darin.

Wert absetzen

Überträgt einen Wert vom Leitsystem zur Steuerung.

Windows CE

Windows CE ist eine Familie von Betriebssystemen von Microsoft für PDA und embedded Systems. Es ähnelt in der Bedienung MS-Windows für PCs, verwendet aber einen anderen Kernel. Somit funktionieren auch keine herkömmlichen Windows-Programme. CE unterstützt die Prozessor-Architekturen Intel x86, MIPS, ARM (mit Intel PXA) und Hitachi SuperH. Es kann auch als hartes Echtzeitbetriebssystem eingesetzt werden. Für unterschiedliche Windows CE Versionen und Prozessor-Architekturen existieren angepasste Runtimes.

Windows CE Projekt

Jedes Projekt kann unter Windows CE verwendet werden. Einige Funktionalitäten stehen jedoch in der Windows CE Runtime nicht zur Verfügung. Daher gibt es eigene Windows CE Projekte, bei denen nur Eigenschaften projektierbar sind, die auch funktionieren. Ein Windows CE Projekt wird über die Projekt-Eigenschaft 'Windows CE Projekt' definiert.

Windows CE Runtime

Eine speziell compilierte Runtime für das Betriebsystem Windows CE. Die Runtime läuft nur auf der Prozessor-Architektur und der Betriebssystem-Version, für die sie erzeugt wurde.

Windows Vista

Betriebssystem der Firma Microsoft. Nachfolger von Windows XP.

Windows XP

Betriebssystem der Firma Microsoft. XP steht für „eXPerience“.

Windows XP Embedded

Betriebssystem der Firma Microsoft. Es stammt von Windows XP Professional ab und unterscheidet sich von Windows CE/PocketPC dadurch, dass es eine andere Geräteklasse anspricht. XP Embedded ist nur lauffähig auf x86-Hardware. Verwendungsgebiete sind Geräte, die auf einem x86-Prozessor basieren.

Wischer-Event

Ereignis, das kurzeitig ausgelöst wird, um auf einen geänderten Zustand hinzuweisen. Meistens handelt es sich dabei um ein Bit, das kurzzeitig auf 1 gesetzt und dann wieder zurückgesetzt wird. Es kann aber auch eine Windows Message sein, auf die in einer Programmiersprache reagiert wird.

Wizard

Ist ein VBA Programm, das bei der Projektierung unterstützt und Objekte automatisch erstellt bzw. modifiziert. Alle Wizards liegen im Sourcecode vor und können individuell angepasst werden.

WPF

Ist ein Grafik-Framework und Teil des .NET Frameworks ab 3.0 von Microsoft. Dabei wird die Präsentation und die Programmlogik getrennt. Die Daten werden in XAML-Dateien gespeichert.


X

Glossar -> X

X-Achse

Die horizontale (waagerechte) Koordinatenachse eines kartesischen Koordinatensystems (Abszisse).

XAML

Ist eine XML-basierte Sprache die verwendet wird, um grafische Elemente, Benutzeroberflächen, Verhaltensweisen, Animationen, Transformationen, Darstellung von Farbverläufen, Abspielen von Mediadateien und vieles mehr zu definieren. XAML wurde von Microsoft eingeführt als Auszeichnungssprache, die in Windows Presentation Foundation (WPF), einer Desktop-orientierten Technologie, verwendet wird.

XAML-Datei

Textdatei, die in Form der Extensible Application Markup Language aufgebaut ist.

XML

Extensible Markup Language - ist eine Auszeichnungssprache zur Darstellung hierarchisch strukturierter Daten in Form von Textdateien.

XML-Datei

Textdatei, die in Form der Extensible Markup Language aufgebaut ist.


Y

Glossar -> Y

Y-Achse

Die vertikale (senkrechte) Koordinatenachse eines kartesischen Koordinatensystems (Ordinate).


Z

Glossar -> Z

Zahlenwert

Dynamisches Element zur Darstellung des Werts einer Variablen in numerischer Form.

Zeicheneditor

Übergegriff für den Bildeditor, Schabloneneditor und den Symboleditor.Diese Editoren werden im Hauptfenster angezeigt.

Zeigerinstrument

Dynamisches Element zur Darstellung des Werts einer Variable wie in einem analogen Messgerät, welches einen Zeiger zur Darstellung benutzt.

Zeitachse

Die Koordinatenachse eines kartesischen Koordinatensystems, auf der ein Zeitbereich dargestellt wird.

Zeitanzeige

Kontrollelement, das eine veränderbare Zeitangabe anzeigt.

Zeitfilter

Einstellbarer Filter zur Eingrenzung der angezeigten Daten auf eine bestimmte Zeitspanne. Es gibt absolute Filter (von - bis sind fest eingetragen) und relative Filter (von jetzt weg eine bestimmte Zeitspanne).

Zeitmodell

Enthält die Definition der Schichten und Pausen des Production & Facility Schedulers.

Zeitmodell-Gruppe

Fasst mehrere Zeitmodelle zusammen.

Zeitsteuerung

Führt zu einem definierten Zeitpunkt oder zyklisch Funktionen aus.

zenon

Objektorientiertes Prozessleitsystem der Firma COPA-DATA.

zenon Analyzer

Erstellt Reports aus unterschiedlichen Quellen.

zenon API

Programmierschnittstelle, die Programmierumgebungen den Zugriff auf den Editor und die Runtime ermöglicht. Damit lassen sich Automatisierungsaufgaben erledigen; Stichwort: automatisch projektieren. Zusätzlich kann auch der Funktionsumfang durch selbstgeschriebene Programme erweitert werden.Die Schnittstelle wird von VBA/VSTA verwendet und steht 1:1 auch für externe Applikationen zur Verfügung. Als Basistechnologie wird Microsoft COM verwendet.

zenon Logic

Flexible IEC 61131-3 Programmierumgebung von COPALP für alle fünf Sprachen: Ablaufsprache (AS), Funktionsplan(FUP)/CFC, Kontaktplan (KOP), Strukturierter Text (ST) und Anweisungsliste (AWL). Deckt viele Bereiche der industriellen Automatisierung ab: Leitebene (SCADA-Logic), Steuerungsebene (Soft-SPS) und Feldebene (straton embedded). Soft-SPS und SCADA-Logic sowie straton Workbench sind im Prozessleitsystem zenon von COPA-DATA als zenon Logic integriert.

zenon Operator

Objektorientiertes Maschinen-Bediensystem (HMI)der Firma COPA-DATA. Im Gegensatz zum zenon Supervisor ist der Funktionsumfang eingeschränkt.

zenon Supervisor

Objektorientiertes Prozessleitsystem der Firma COPA-DATA. Im Gegensatz zum zenon Operator können alle Module und Optionen aktiviert werden.

zenon Webserver

Ermöglicht den Zugriff auf zenon Projekte über einen Webclient. Der Webserver fungiert dabei als Lizenzverwaltung und als Proxyserver.

zenon Webserver Pro

Ermöglicht den Zugriff auf zenon Projekte über einen Webclient. Der Webserver fungiert dabei als Lizenzverwaltung und als Proxyserver. Die Pro Version unterstützt die komplette Bedien- und Beobachtungsfunktionalität. Über das Web kann direkt auf Prozesse eingegriffen werden.

zenon Webserver Pro Light

Webserver Pro mit folgenden Einschränkungen: Maximal drei Clients, Verbindung nur auf lokale Server, keine Datenverschlüsselung, kein HTTP Tunneling.

zentrales Serverprojekt

Ist die Basis eines mehrplatzfähiges Projekts und wird zentral auf einem als Server definierten Rechner verwaltet.Änderungen können in beliebig vielen verbundenen lokalen Projektkopien durchgeführt werden, nicht jedoch direkt auf dem zentralen Projekt. Selbst am Server wird mit einer lokalen Projektkopie gearbeitet.

Ziel-Host

IP-Adresse oder Rechnername des Zielsystems.

Ziel-Port

TCP-Port, der auf dem Zielsystem angesprochen werden soll.

Zielrezept

Rezept, auf das beim Rezept kopieren geschrieben wird. Das Quellrezept wird auf das Zielrezept kopiert.

Zoom

Veränderung der Brennweite bzw. Veränderung der Betrachtungsgröße, um einen Bildausschnitt zu fokussieren. 100 % bedeutet, jedes Pixel einer Grafik entspricht genau einem Pixel auf dem Bildschirm.

Zoom-Schaltfläche

Grafischer Repräsentant in Programmoberfläche, der das Ein- und Ausschalten der Zoom-Funktion ermöglicht.

Zoom-Schieberegler

Linearer grafischer Regler mit dessen Betätigung Zoomstufen verändert werden.

Zustandselement

Dynamisches Element, das Eigenschaften der verknüpften Variablen wie z.B. Farben, Blinken usw. auf ein Symbol überträgt und statische Grenzwertexte anzeigt.

Zuweisung

Bezeichnet das Schreiben des Wertes von einer Variable auf eine andere Variable. Bei getriggerten Zuweisungen wird der Schreibvorgang nur so lange ausgeführt, so lange das Triggerbit gesetzt ist, bzw. nur wenn das Triggerbit gesetzt wird.

Zweig

Ein Ausführungsbereich im Modul Batch Control. Auf ihm können Grundfunktionen, Transitionen und Sprungziele platziert sein.

zyklische Archivierung

Die Daten werden in dem eingestellten Zeitintervall in das Archiv geschrieben.

zyklische Aufzeichnung

Die Daten werden nach dem eingestellten Zeitintervall in das Archiv geschrieben.

Zykluszeit

Bestimmt den Zeitabstand der Aufzeichnung bei der zyklischen Aufzeichnung im Archiv und bei der Harddisk-Datenspeicherung.


Symbols

Glossar -> Symbols

.NET

Ist eine von Microsoft entwickelte Softwareplattform. Diese umfasst eine Laufzeitumgebung, eine für Programmierer bestimmte Sammlung von Klassenbibliotheken (API), und angeschlossene Dienstprogramme (Services). Die Plattform ist derzeit in ihrem vollen Umfang nur für Windows verfügbar.

.NET Framework

Das .NET Framework ist Microsofts Programmiermodel für „managed code“ zum Erstellen herausragender Applikationen mit nahtloser und sicherer Kommunikation und der Möglichkeit, eine breite Vielfalt von Businessprozessen zu modellieren. Das aktuelle .NET Framework 3.5 beinhaltet unter anderem Windows Presentation Foundation (WPF), Windows Workflow Foundation (WF), Windows Communication Foundation (WCF), Windows CardSpace, LINQ und volle Visual Studio 2008-Integration.

3-D Winkelstück

Veraltetes Vektor-Element, das zur Darstellung eines Winkels mit einer dreidimensionalen Füllung genutzt wurde.

3D-Fülleffekt

Grafische Objekte wie z.B. Rechteck, Kreis usw. erhalten durch farbige Verläufe der Füllfarbe ein dreidimensionales Erscheinungsbild.

3S

Hersteller von CoDeSys. 3S steht für Smart Software Solutions.


Sollten Sie in unserer Onlinehilfe zu einem Problem keine Lösung finden, wenden Sie sich bitte an unser Support Team oder nutzen Sie unser Online-Forum.

Support Teams

Als Nutzer des Wartungsvertrages Basic (ist in jeder Lizenz gratis enthalten) erreichen Sie unseren Support am besten per E-Mail an support@copadata.com.
Infomationen zur telefonischen Erreichbarkeit der Support Teams finden Sie auch auf unserer Website: Support Verfügbarkeit

Als Inhaber eines Wartungsvertrages Advanced oder Premium benutzen Sie bitte die in Ihrem Vertrag angegebene Telefonnummer.

Informationen zu den COPA-DATA Wartungsverträgen erhalten Sie bei unseren Beratern unter sales@copadata.com.

Forum

Viele Informationen und Unterstützung von Anwendern und den COPA-DATA Experten finden Sie auch im COPA-DATA Forum.

Downloads

Nutzer alles Wartungsvertäge finden auf der COPA-DATA Website Handbücher, Tutorials und Videos zum Download.
Anwender mit Advanced und Premium Wartungsverträgen haben online auch Zugang zu Service Packs, VBA Beispielen und gespeicherten Workshops.

Für den Download von Dateien müssen Sie als 'Member' angemeldet sein. Die Anmeldung ist kostenlos und eröffnet Ihnen den Zugang zu Informationen, die unseren Kunden vorbehalten sind.


FKT_ACM_RSP

Interne ID: FKT_ACM_RSP

AML- und CEL-Ringpuffer speichern

Diese Funktion speichert aktuelle Alarme und Ereignisse in die Dateien ALARM.BIN und CEL.BIN.

Mehr im Online-Handbuch


FKT_ALARM_BLINK_QUIT

Interne ID: FKT_ALARM_BLINK_QUIT

Alarme blinkquittieren

Diese Funktion quittiert das Blinken aller Elemente des aktuell geöffneten Bildes einer ausgewählten Schablone.

Mehr im Online-Handbuch


FKT_ALARM_GRP_KLASSEN

Interne ID: FKT_ALARM_GRP_KLASSEN

Alarmmeldeliste, Alarm/Ereignis-Gruppen/Klassen aktivieren/deaktivieren

Diese Funktion schaltet eine Alarm/Ereignis-Gruppe, eine Alarm/Ereignis-Klasse oder die gesamte Alarmverwaltung ein oder aus.

Mehr im Online-Handbuch


FKT_ALARM_GRUPPEN_VERB

Interne ID: FKT_ALARM_GRUPPEN_VERB

Alarm/Ereignis-Gruppe abmelden/anmelden

Diese Funktion schaltet die Verbindung zur SPS für eine ausgewählte Alarm/Ereignis-Gruppe aus oder ein.

Mehr im Online-Handbuch


FKT_AML_AUS

Interne ID: FKT_AML_AUS

Alarmmeldeliste inaktiv

Diese Funktion schaltet die gesamte Alarmverwaltung aus.

Mehr im Online-Handbuch


FKT_AML_DEL

Interne ID: FKT_AML_DEL

Alarme löschen

Diese Funktion löscht gefilterte Alarme.

Mehr im Online-Handbuch


FKT_AML_EIN

Interne ID: FKT_AML_EIN

Alarmmeldeliste aktiv

Diese Funktion schaltet die gesamte Alarmverwaltung ein.

Mehr im Online-Handbuch


FKT_AML_EXP

Interne ID: FKT_AML_EXP

AML exportieren

Diese Funktion exportiert gefilterte Einträge der Alarmliste in ein externes Format.

Mehr im Online-Handbuch


FKT_AML_QTT

Interne ID: FKT_AML_QTT

Alarme quittieren

Diese Funktion quittiert gefilterte Alarme.

Mehr im Online-Handbuch


FKT_AML_TGL

Interne ID: FKT_AML_TGL

Alarmmeldeliste aktiv/inaktiv

Diese Funktion schaltet die gesamte Alarmverwaltung ein oder aus.

Mehr im Online-Handbuch


FKT_APP_HELP

Interne ID: FKT_APP_HELP

Hilfe aufrufen

Diese Funktion öffnet eine ausgewählte Hilfeseite aus einer CHM-Datei.

Mehr im Online-Handbuch


FKT_APP_PALETTESWITCH

Interne ID: FKT_APP_PALETTESWITCH

Farbpalette umschalten

Erstellt eine Funktion, um zur Runtime zwischen Farbpaletten umzuschalten.

Mehr im Online-Handbuch.


FKT_APP_RT_PROFILES

Interne ID: FKT_APP_RT_PROFILES

Runtimeprofile

Erstellt eine Funktion, mit der zur Runtime die Profilverwaltung geöffnet, ein Profil erstellt oder ein Profil geladen werden kann.

Mehr im Online-Handbuch.


FKT_APP_SAVE_REMDATA

Interne ID: FKT_APP_SAVE_REMDATA

Remanentdaten speichern

Erlaubt das Speichern der Daten für die konfigurierten Module. Zur Auswahl stehen: AML-Ringpuffer, CEL-Ringpuffer, System Treiber und Mathematik Treiber, Intern Treiber, Remanentabbilder aller Treiber und Sperrung der Befehlsgabe.

Mehr im Online-Handbuch.


FKT_APP_SIMULATION

Interne ID: FKT_APP_SIMULATION

Projektsimulation aktivieren/deaktivieren

Diese Funktion ermöglicht es Ihnen, zwischen Simulationsmodus und Hardwaremodus umzuschalten. Außerdem können Sie die Art des Simulationsmodus bzw. des Hardwaremodus auswählen.

Mehr im Online-Handbuch


FKT_APP_TEXT_LISTE

Interne ID: FKT_APP_TEXT_LISTE

Sprachumschaltung

Diese Funktion schaltet in mehrsprachigen Projekten auf eine ausgewählte Sprache um.

Mehr im Online-Handbuch


FKT_APP_UNITS_SWITCH

Interne ID: FKT_APP_UNITS_SWITCH

Einheitenumschaltung

Diese Funktion schaltet zwischen Basiseinheit und Umrechnungseinheit um. Die Zuordnung erfolgt in einem Dialog, der beim Erstellen der Funktion angeboten wird und später über die Eigenschaft Parameter geändert werden kann.

Interne ID: FKT_APP_UNITS_SWITCH

Parameter

Übergabeparameter der Funktion; hängt vom Typ der Funktion ab.
Abhängig vom Typ der Funktion wird der entsprechende Parameterdialog geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Mehr im Online-Handbuch.


FKT_ARV_AKT

Interne ID: FKT_ARV_AKT

Offene Archive anzeigen

Diese Funktion zeigt eine Liste der laufenden Archive des optionalen Moduls Archivserver an.

Mehr im Online-Handbuch


FKT_ARV_AUS

Interne ID: FKT_ARV_AUS

Archiv beenden

Diese Funktion beendet ein ausgewähltes Archiv des optionalen Moduls Archivserver.

Mehr im Online-Handbuch


FKT_ARV_EIN

Interne ID: FKT_ARV_EIN

Archiv starten

Diese Funktion startet ein ausgewähltes Archiv des optionalen Moduls Archivserver.

Mehr im Online-Handbuch


FKT_ARV_EXP

Interne ID: FKT_ARV_EXP

Archive exportieren

Diese Funktion exportiert gefilterte Archiveinträge des optionalen Moduls Archivserver in ein externes Format.

Mehr im Online-Handbuch


FKT_ARV_IND

Interne ID: FKT_ARV_IND

Archiv indizieren

Diese Funktion indiziert Archive. Sie wird immer am prozessführenden Server ausgeführt.

Mehr im Online-Handbuch


FKT_BEDIENBERECHTIGUNG

Interne ID: FKT_BEDIENBERECHTIGUNG

Bedienberechtigung im Netzwerk

Diese Funktion holt oder gibt die Bedienberechtigung im Netzwerk frei.

Mehr im Online-Handbuch


FKT_BILD_AUS

Interne ID: FKT_BILD_AUS

Bild schließen

Diese Funktion schließt ein ausgewähltes Bild.

Mehr im Online-Handbuch


FKT_BILD_EIN

Interne ID: FKT_BILD_EIN

Bildumschaltung

Diese Funktion öffnet ein ausgewähltes Bild. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_BILD_FOKUS

Interne ID: FKT_BILD_FOKUS

Fokus verschieben

Diese Funktion setzt den Eingabefokus auf ein bestimmtes Element in einem Bild, dessen Schablone den Fokus hat.

Mehr im Online-Handbuch


FKT_BILD_MENU

Interne ID: FKT_BILD_MENU

Menü anzeigen

Diese Funktion öffnet oder schließt ein ausgewähltes Hauptmenü. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_BILD_MITTE

Interne ID: FKT_BILD_MITTE

Bildmittelpunkt verschieben

Diese Funktion scrollt und/oder zoomt in einem Weltbild.

Mehr im Online-Handbuch


FKT_BILD_SW_KDBMDI

Interne ID: FKT_BILD_SW_KDBMDI

Sollwertvorgabe für Keyboard-Bild

Diese Funktion stellt für ein Bild vom Typ Keyboard einen vordefinierten Wert ein (Vorschlagswert) oder setzt einen vordefinierten Wert ab und schließt das Bild.

Mehr im Online-Handbuch


FKT_BILD_VAR

Interne ID: FKT_BILD_VAR

Bild indiziert

Diese Funktion öffnet ein Bild, dessen Name eine ausgewählte Variable beinhaltet.

Mehr im Online-Handbuch


FKT_BILD_ZURUECK

Interne ID: FKT_BILD_ZURUECK

Bild zurück

Diese Funktion schaltet auf das vorher geöffnete Bild der ausgewählten Schablone zurück.

Mehr im Online-Handbuch


FKT_CEL_EXP

Interne ID: FKT_CEL_EXP

CEL exportieren

Diese Funktion exportiert gefilterte Einträge der Chronologischen Ereignisliste (CEL) in ein externes Format.

Mehr im Online-Handbuch


FKT_CHANGE_ALC_COLOR

Interne ID: FKT_CHANGE_ALC_COLOR

ALC-Quellenfarbe ändern

Funktion zur Konfiguration der ALC-Quellenfarben bei Fehlerortung in elektrischen Netzen.

Mehr im Online-Handbuch.


FKT_DATEIOPERATION

Interne ID: FKT_DATEIOPERATION

Dateioperation

Diese Funktion kopiert, löscht oder verschiebt ausgewählte Dateien. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_DBASE_READ

Interne ID: FKT_DBASE_READ

dBase Datei lesen

Diese Funktion liest eine ausgewählte dBase-Datei und führt sie als ein Rezept aus.

Mehr im Online-Handbuch


FKT_DIAGRAM_PRINT

Interne ID: FKT_DIAGRAM_PRINT

Erweiterter Trend Diagramm drucken

Mithilfe dieser Funktion können Sie Diagramme des Erweiterten Trends ausdrucken oder in einer Datei (JPG oder BMP) speichern, ohne dass Sie das Bild vom Typ Erweiterter Trend aufschalten müssen.

Mehr im Online Handbuch


FKT_EINGABE_FOCUS

Interne ID: FKT_EINGABE_FOCUS

Eingabe auf Element mit Fokus aktivieren

Diese Funktion löst die Funktionalität des Elements aus, das gerade den Eingabefokus hat.

Mehr im Online-Handbuch


FKT_EMS_START

Interne ID: FKT_EMS_START

EMS starten

Mit Hilfe dieser Funktion wird die Optimierung für ein selektiertes Versorgunsgebiet im EMS Modul gestartet.

Diese Funktion wird nur am Server ausgeführt.

Mehr im Online-Handbuch


FKT_EMS_STOP

Interne ID: FKT_EMS_STOP

EMS stoppen

Mit Hilfe dieser Funktion wird die Optimierung für ein selektiertes Versorgunsgebiet im EMS Modul gestartet.

Diese Funktion wird nur am Server ausgeführt.

Mehr im Online-Handbuch


FKT_EXP_DATEN

Interne ID: FKT_EXP_DATEN

Daten exportieren

Diese Funktion exportiert auf der Festplatte gespeicherte Werte (*.HDD) ausgewählter Variablen in ein externes Format.

Mehr im Online-Handbuch


FKT_FKT_AUS

Interne ID: FKT_FKT_AUS

Funktionen bei Grenzwerten inaktiv

Diese Funktion schaltet die Funktionsverwaltung aus. Automatisch ausgeführte Funktionen (z.B. durch Zeitsteuerung, Grenzwertverletzung, etc.) werden nicht ausgeführt.

Mehr im Online-Handbuch


FKT_FKT_EIN

Interne ID: FKT_FKT_EIN

Funktionen bei Grenzwerten aktiv

Diese Funktion schaltet die Funktionsverwaltung ein. Automatisch ausgeführte Funktionen (z.B. durch Zeitsteuerung, Grenzwertverletzung, etc.) werden ausgeführt.

Mehr im Online-Handbuch


FKT_FKT_TGL

Interne ID: FKT_FKT_TGL

Funktionen bei Grenzwerten aktiv/inaktiv

Diese Funktion schaltet die Funktionsverwaltung ein oder aus. Automatisch ausgeführte Funktionen (z.B. durch Zeitsteuerung, Grenzwertverletzung, etc.) werden (nicht) ausgeführt.

Mehr im Online-Handbuch


FKT_GNDFLT_ACKNOWLEDGE

Interne ID: FKT_GNDFLT_ACKNOWLEDGE

Erdschlussmeldung quittieren

Funktion zum Quittieren einer Erdschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.


FKT_GNDFLT_SEARCH_END

Interne ID: FKT_GNDFLT_SEARCH_END

Erdschlusssuche beenden

Funktion zum Beenden der Erdschlusssuche.

Mehr im Online-Handbuch.


FKT_GNDFLT_SEARCH_START

Interne ID: FKT_GNDFLT_SEARCH_START

Erdschlusssuche starten

Funktion zum Starten der Erdschlusssuche.

Mehr im Online-Handbuch.


FKT_GRAPH7_HEURISTIK

Interne ID: FKT_GRAPH7_HEURISTIK

S7-Graph Heuristik auswerten

Diese Funktion ermöglicht es Ihnen, die S7-Graph Heuristik durchzuführen, ohne dass das Bild vom Typ S7-Graph aktiv ist.

Mehr im Online-Handbuch


FKT_HDD_AUS

Interne ID: FKT_HDD_AUS

HD-Verwaltung inaktiv

Diese Funktion schaltet die Harddisk-Datenspeicherung aus. HDD-Dateien werden nicht geschrieben.

Mehr im Online-Handbuch


FKT_HDD_EIN

Interne ID: FKT_HDD_EIN

HD-Verwaltung aktiv

Diese Funktion schaltet die Harddisk-Datenspeicherung ein. HDD-Dateien werden geschrieben.

Mehr im Online-Handbuch


FKT_HDD_TGL

Interne ID: FKT_HDD_TGL

HD-Verwaltung inaktiv/aktiv

Diese Funktion schaltet die Harddisk-Datenspeicherung ein oder aus. HDD-Dateien werden (nicht) geschrieben.

Mehr im Online-Handbuch


FKT_IMM_CHECKMAINT

Interne ID: FKT_IMM_CHECKMAINT

Offene Wartungen ermitteln

Diese Funktion ermittelt für die angegeben Anlagen die Anzahl der fälligen Wartungen aus dem Industrial Maintenance Manager. Der auszuwertende Zeitraum kann angegeben werden. Die Anzahl der offenen Wartungen wird auf frei definierbare Statusvariablen geschrieben.

Mehr im Online-Handbuch


FKT_IPA_CREATE_DOCUMENT

Interne ID: FKT_IPA_CREATE_DOCUMENT

IPA-Dokument erzeugen/drucken

Diese Funktion erzeugt aus den gefilterten Daten des Industrial Performance Analyzers ein Dokument und druckt dieses aus oder speichert es als HTML Dokument ab.

Mehr im Online-Handbuch


FKT_MOMENTAN_PRT

Interne ID: FKT_MOMENTAN_PRT

Drucken Momentanwerte

Diese Funktion druckt aktuelle Werte ausgewählter Variablen aus.

Mehr im Online-Handbuch


FKT_MONITOR_ZUORDNEN

Interne ID: FKT_MONITOR_ZUORDNEN

Monitor zuordnen

Diese Funktion weist einem ausgewählten virtuellen Monitor einen ausgewählten realen Monitor zu. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_MOUSE_REVERSE

Interne ID: FKT_MOUSE_REVERSE

Rechtsklick simulieren

Diese Funktion interpretiert den nächsten Mausklick als einen Rechtsklick.

Mehr im Online-Handbuch


FKT_MSG_AUS

Interne ID: FKT_MSG_AUS

Sende Nachricht deaktivieren

Diese Funktion schaltet das Senden von Nachrichten des optionalen Moduls Message Control aus.

Mehr im Online-Handbuch


FKT_MSG_EDB

Interne ID: FKT_MSG_EDB

Empfängerdatenbank anzeigen

Diese Funktion öffnet einen Dialog, in dem ein Benutzer die Empfänger-Datenbank des optionalen Moduls Message Control bearbeiten kann.


FKT_MSG_EIN

Interne ID: FKT_MSG_EIN

Sende Nachricht aktivieren

Diese Funktion schaltet das Senden von Nachrichten des optionalen Moduls Message Control ein.

Mehr in der Online-Hilfe.


FKT_MSG_SAVEQUEUE

Interne ID: FKT_MSG_SAVEQUEUE

Aktuelle Queue speichern

Speichert zur Runtime ein Abbild der aktuellen Queue.

Mehr in der Online-Hilfe.


FKT_MSG_SUPPRESS

Interne ID: FKT_MSG_SUPPRESS

Gruppen/Klassen/Bereiche/Anlagen unterdrücken

Deaktiviert oder aktiviert Elemente der Liste, für die keine Nachrichten verschickt werden sollen.

Mehr in der Online-Hilfe.


FKT_NACHLADEN

Interne ID: FKT_NACHLADEN

Nachladen

Diese Funktion lädt im Editor geänderte Runtime-Dateien nach.

Mehr im Online-Handbuch


FKT_PFS_EVENT

Interne ID: FKT_PFS_EVENT

PFS - benutzerdefiniertes Ereignis anstoßen

Diese Funktion führt ein zuvor vom Benutzer angelegtes PFS-Ereignis aus.

Mehr im Online-Handbuch


FKT_PRT_AMLCEL

Interne ID: FKT_PRT_AMLCEL

Drucken AML oder CEL

Diese Funktion druckt gefilterte Einträge der Alarmliste oder der Chronologischen Ereignisliste (CEL) aus.

Mehr im Online-Handbuch


FKT_PRT_HARDCOPY

Interne ID: FKT_PRT_HARDCOPY

Screenshot drucken

Diese Funktion druckt entweder den aktuellen Bildschirm oder das aktuell geöffnete Bild einer ausgewählten Schablone aus. Bei Mehr-Monitor-Systemen kann für Schablonen der Monitor ausgewählt werden. Der Ausdruck kann wahlweise auf ein Fax umgeleitet werden.

Mehr im Online-Handbuch


FKT_PRT_ONLINE

Interne ID: FKT_PRT_ONLINE

Online-Drucken ein/ausschalten

Diese Funktion schaltet den Online-Ausdruck der Alarmliste oder der Chronologischen Ereignisliste (CEL) ein oder aus.

Mehr im Online-Handbuch


FKT_PRT_ONLINE_SWITCH

Interne ID: FKT_PRT_ONLINE_SWITCH

Online-Drucker umschalten

Diese Funktion schaltet den Online-Ausdruck auf einen ausgewählten Drucker um. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_PRT_WAHL

Interne ID: FKT_PRT_WAHL

Drucker wählen

Diese Funktion öffnet einen Dialog, in dem der Benutzer Drucker für die verschiedenen Druckaufgaben auswählen kann.

Mehr im Online-Handbuch


FKT_PWD_LOGIN

Interne ID: FKT_PWD_LOGIN

Login mit Dialog

Diese Funktion öffnet den Standard-Login-Dialog.

Mehr im Online-Handbuch


FKT_PWD_LOGIN_DIREKT

Interne ID: FKT_PWD_LOGIN_DIREKT

Login ohne Passwort

Diese Funktion loggt einen ausgewählten Benutzer ein, ohne nach seinem Passwort zu fragen.

Mehr im Online-Handbuch


FKT_PWD_LOGOUT

Interne ID: FKT_PWD_LOGOUT

Logout

Diese Funktion loggt den aktuell eingeloggten Benutzer aus.

Mehr im Online-Handbuch


FKT_PWD_PWDEDIT

Interne ID: FKT_PWD_PWDEDIT

Passwort ändern

Diese Funktion öffnet einen Dialog, wo der aktuell eingeloggte Benutzer sein Passwort ändern kann.

Mehr im Online-Handbuch


FKT_PWD_USREDIT

Interne ID: FKT_PWD_USREDIT

Benutzer ändern

Diese Funktion öffnet einen Dialog, in dem ein eingeloggter Administrator Benutzer anlegen, editieren oder löschen kann.

Mehr im Online-Handbuch


FKT_QUIT

Interne ID: FKT_QUIT

Runtime beenden

Diese Funktion beendet die Runtime des Leitsystems.

Mehr im Online-Handbuch


FKT_REDUNDANZ

Interne ID: FKT_REDUNDANZ

Redundanz-Umschaltung

Diese Funktion tauscht den Server und den Standby-Server des Projekts aus.

Mehr im Online-Handbuch


FKT_REZ_DIREKT

Interne ID: FKT_REZ_DIREKT

Standard-Rezept einzeln direkt

Diese Funktion sendet die Werte eines ausgewählten Standard-Rezepts an die Steuerung.

Mehr im Online-Handbuch


FKT_REZ_WAHL

Interne ID: FKT_REZ_WAHL

Standard-Rezept einzeln mit Auswahl

Diese Funktion öffnet einen Dialog, in dem der Benutzer ein Standard-Rezept ändern und ausführen kann.

Mehr im Online-Handbuch


FKT_REZ_WAHL_ONL

Interne ID: FKT_REZ_WAHL_ONL

Standard-Rezept einzeln mit Online-Auswahl

Diese Funktion öffnet einen Dialog, in dem der Benutzer ein Standard-Rezept auswählen und ausführen und/oder ändern kann.

Mehr im Online-Handbuch


FKT_REZEPT

Interne ID: FKT_REZEPT

Standard-Rezept

Diese Funktion schreibt, liest, kopiert, importiert oder exportiert ein ausgewähltes Standard-Rezept. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_RGM

Interne ID: FKT_RGM

Rezeptgruppen-Manager

Diese Funktion schreibt, liest, kopiert, importiert oder exportiert ein ausgewähltes Rezept des optionalen Moduls Rezeptgruppen Manager (RGM). Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_SAP_CALL_FUNCTION

Interne ID: FKT_SAP_CALL_FUNCTION

SAP Funktion ausführen

Führt eine im SAP Interface definierte SAP Funktion zur Laufzeit aus. Die SAP Funktion wiederum triggert im SAP System wiederum einen Remote Function Call (RFC)


FKT_SAT1

Interne ID: FKT_SAT1

Befehlsgabe aktivieren

SAT Funktion


FKT_SAT2

Interne ID: FKT_SAT2

Schichtwechsel-Protokoll generieren

SAT Funktion


FKT_SAT_SEA_RUN

Interne ID: FKT_SAT_SEA_RUN

Schaltfolge Automatiklauf


FKT_SAT_TOP_ERDSCHLUSS

Interne ID: FKT_SAT_TOP_ERDSCHLUSS

Topologie - Erdschlusssuche

Schaltet die Erdschluss-Suche ein oder aus. Zu Beginn der Erdschluss-Suche werden die aktuell anstehenden Störungen eingefroren. Neue Störungen werden erst nach Beendigung der Suche angezeigt.


FKT_SAT_TOP_LOADSHEDDING

Interne ID: FKT_SAT_TOP_LOADSHEDDING

Topologie - Verbindungen prüfen

Mit Hilfe der Funktion Loadshedding kann der Versorgungszustand von topologischen Verbrauchern ermittelt und auf Variablen abgebildet werden.

Es werden bis zu 32 Quellen unterstützt.


FKT_SCHABFOCUS_AUS

Interne ID: FKT_SCHABFOCUS_AUS

Fokus von Schablone nehmen

Diese Funktion entfernt den Eingabefokus von dem aktuell geöffneten Bild einer ausgewählten Schablone. So können Projekte mit reiner Tastaturbedienung erstellt werden.

Mehr im Online-Handbuch


FKT_SCHABFOCUS_EIN

Interne ID: FKT_SCHABFOCUS_EIN

Fokus auf Schablone setzen

Diese Funktion setzt den Eingabefokus auf das aktuell geöffnete Bild einer ausgewählten Schablone. So können Projekte mit reiner Tastaturbedienung erstellt werden.

Mehr im Online-Handbuch


FKT_SCHABLONE_AUS

Interne ID: FKT_SCHABLONE_AUS

Schablone schließen

Diese Funktion schließt das aktuell geöffnete Bild einer ausgewählten Schablone.

Mehr im Online-Handbuch


FKT_SCRIPT_DIR

Interne ID: FKT_SCRIPT_DIR

Skript ausführen

Diese Funktion führt ein ausgewähltes Skript aus.

Mehr im Online-Handbuch


FKT_SCRIPT_WHL

Interne ID: FKT_SCRIPT_WHL

Skript mit Online-Auswahl

Diese Funktion öffnet einen Dialog, in dem der Benutzer ein Skript auswählen und ausführen kann.

Mehr im Online-Handbuch


FKT_SENDE_NACHRICHT

Interne ID: FKT_SENDE_NACHRICHT

Sende Nachricht

Diese Funktion sendet eine Nachricht des optionalen Moduls Message Control.

Mehr im Online-Handbuch


FKT_SHRTFLT_ACKNOWLEDGE

Interne ID: FKT_SHRTFLT_ACKNOWLEDGE

Kurzschlussmeldung quittieren

Funktion zum Quittieren einer Kurzschlussmeldung. Öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.


FKT_SIMULATION

Interne ID: FKT_SIMULATION

Simulation ein/ausschalten

Diese Funktion schaltet die Simultion ein oder aus.


FKT_TBL_AUS

Interne ID: FKT_TBL_AUS

Report ausführen

Diese Funktion führt einen ausgewählten Report des optionalen Moduls Report Generator aus.

Mehr im Online-Handbuch


FKT_TBL_EXP

Interne ID: FKT_TBL_EXP

Report exportieren

Diese Funktion exportiert einen ausgewählten Report des optionalen Moduls Report Generator in ein externes Format.

Mehr im Online-Handbuch


FKT_TBL_EXPW

Interne ID: FKT_TBL_EXPW

Online-Drucken neue Seite beginnen

Diese Funktion beendet bei aktiviertem Online-Druck eine Seite und beginnt eine neue. Die Seitennummer wird auf 1 zurück gesetzt.

Mehr im Online-Handbuch


FKT_TBL_PRN

Interne ID: FKT_TBL_PRN

Report drucken

Diese Funktion druckt einen ausgewählten Report des optionalen Moduls Report Generator.

Mehr im Online-Handbuch


FKT_TM_READ

Interne ID: FKT_TM_READ

Uhrzeit von Variable lesen

Diese Funktion liest die Zeit aus einer String-Variable der Steuerung und setzt die Systemzeit des Betriebssystems entsprechend. So kann die Systemzeit der Steuerung mit der des Betriebssystems synchronisiert werden.

Mehr im Online-Handbuch


FKT_TM_WRITE

Interne ID: FKT_TM_WRITE

Uhrzeit auf Variable schreiben

Diese Funktion liest die Systemzeit des Betriebssystems und schreibt sie auf eine String-Variable in der Steuerung. So kann die Systemzeit der Steuerung mit der des Betriebssystems synchronisiert werden.

Mehr im Online-Handbuch


FKT_TREIBERKOMMANDO

Interne ID: FKT_TREIBERKOMMANDO

Treiber Kommandos

Diese Funktion sendet ein ausgewähltes Kommando zu einem ausgewählten Treiber. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_UEBERSICHT

Interne ID: FKT_UEBERSICHT

Übersichtsfenster anzeigen

Diese Funktion öffnet ein Übersichtsfenster, sodass man auf einem Ein-Monitor-System ein Mehr-Monitor-System simulieren kann.

Mehr im Online-Handbuch


FKT_VAR_ALIGN_VM_IMAGE

Interne ID: FKT_VAR_ALIGN_VM_IMAGE

Treiber Simulationsabbild an Standby übertragen

Wird nur am Standby-Server ausgeführt.

Fordert bei Ausführung vom Server ein Abbild für die ausgewählten Treiber. Der Treiber hat dafür 5 Sekunden Zeit.

Mehr im Online-Handbuch


FKT_VAR_SOLLWERT

Interne ID: FKT_VAR_SOLLWERT

Sollwert absetzen

Diese Funktion sendet für eine ausgewählte Variable einen neuen Wert zur Steuerung.

Mehr im Online-Handbuch


FKT_VBA_IDE

Interne ID: FKT_VBA_IDE

VBA-Editor öffnen

Diese Funktion öffnet den VBA-Editor.

Mehr im Online-Handbuch


FKT_VBA_MAKRO

Interne ID: FKT_VBA_MAKRO

VBA-Makro ausführen

Diese Funktion führt ein ausgewähltes VBA-Makro aus.

Achtung: Der VBA Event project inactive wird vor den AUTO_END_xxx Skripten ausgeführt. Daher wird in Skripten die zenon Funktion VBA-Makro ausführen nicht mehr ausgeführt, da VBA zu diesem Zeitpunkt nicht mehr läuft. VBA-Makros, die zum Beenden der Runtime ausgeführt werden sollen, müssen über das Event Project.Inactive angestoßen werden.

Mehr im Online-Handbuch


FKT_VBA_MCR

Interne ID: FKT_VBA_MCR

VBA-Makro Dialog anzeigen

Diese Funktion öffnet den VBA Makro Dialog.

Mehr im Online-Handbuch


FKT_VBA_PCE

Interne ID: FKT_VBA_PCE

PCE-Editor öffnen

Diese Funktion öffnet den Editor des optionalen Moduls Process Control Engine (PCE).

Mehr im Online-Handbuch


FKT_VSTA_CALLMACRO

Interne ID: FKT_VSTA_CALLMACRO

VSTA-Makro ausführen

Diese Funktion führt ein ausgewähltes VSTA-Makro aus.

Mehr im Online-Handbuch


FKT_VSTA_SHOWIDE

Interne ID: FKT_VSTA_SHOWIDE

VSTA-Editor öffnen

Diese Funktion öffnet den VSTA-Editor.

Mehr im Online-Handbuch


FKT_VSTA_SHOWMACRODLG

Interne ID: FKT_VSTA_SHOWMACRODLG

VSTA-Makro Dialog anzeigen

Diese Funktion öffnet den VSTA Makro-Dialog.

Mehr im Online-Handbuch


FKT_WND_AUDI_AUFUEHREN

Interne ID: FKT_WND_AUDI_AUFUEHREN

Audiodatei ausführen

Diese Funktion spielt eine ausgewählte Audiodatei (*.wav) einmalig ab.

Mehr im Online-Handbuch


FKT_WND_AUDI_START

Interne ID: FKT_WND_AUDI_START

Dauerton Start

Diese Funktion spielt eine Audiodatei (*.wav) wiederholt ab.

Mehr im Online-Handbuch


FKT_WND_AUDI_STOP

Interne ID: FKT_WND_AUDI_STOP

Dauerton Stopp

Diese Funktion stoppt das wiederholte Abspielen einer Audiodatei (*.wav).

Mehr im Online-Handbuch


FKT_WND_BTN

Interne ID: FKT_WND_BTN

In den Hintergrund

Diese Funktion schaltet die Runtime des Leitsystems in den Hintergrund.

Mehr im Online-Handbuch


FKT_WND_PROG_AUFUEHREN

Interne ID: FKT_WND_PROG_AUFUEHREN

Starte Programm

Diese Funktion startet ein externes Programm. Übergabeparameter können definiert werden. Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch


FKT_WND_TOP

Interne ID: FKT_WND_TOP

In den Vordergrund

Diese Funktion schaltet die zenon Runtime in den Vordergrund.

Achtung: Beim in den Vordergrund Schalten wird die Alarmstatuszeile überdeckt.

Mehr im Online-Handbuch


GRP_FKT_AMLCEL

Interne ID: GRP_FKT_AMLCEL

AML und CEL

Diese Gruppe beinhaltet Funktionen für den Umgang mit der Alarmliste und der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch


GRP_FKT_ANWENDUNG

Interne ID: GRP_FKT_ANWENDUNG

Anwendung

Diese Gruppe beinhaltet Funktionen für den Umgang mit Projekt-Einstellungen.

Mehr im Online-Handbuch


GRP_FKT_ARV

Interne ID: GRP_FKT_ARV

Archivserver

Diese Gruppe beinhaltet Funktionen für das optionale Modul Archivserver.

Mehr im Online-Handbuch


GRP_FKT_BILD

Interne ID: GRP_FKT_BILD

Bilder

Diese Gruppe beinhaltet Funktionen für den Umgang mit Bildern.

Mehr im Online-Handbuch


GRP_FKT_FAULT_LOCATION

Interne ID: GRP_FKT_FAULT_LOCATION

Fehlerortung in elektrischen Netzen

Enthält Funktionen zur Fehlerortung in elektrischen Netzen.

Mehr im Online-Handbuch.


GRP_FKT_FAVORITEN

Interne ID: GRP_FKT_FAVORITEN

Favoriten


GRP_FKT_NACHRICHT

Interne ID: GRP_FKT_NACHRICHT

Message Control

Diese Gruppe beinhaltet Funktionen für das optionale Modul Message Control.

Mehr im Online-Handbuch


GRP_FKT_NETZ

Interne ID: GRP_FKT_NETZ

Netzwerk

Diese Gruppe beinhaltet Funktionen für den Umgang mit einem Netzwerk.

Mehr im Online-Handbuch


GRP_FKT_PASSWORT

Interne ID: GRP_FKT_PASSWORT

Benutzerverwaltung

Diese Gruppe beinhaltet Funktionen für die Benutzerverwaltung.

Mehr im Online-Handbuch


GRP_FKT_REZEPT

Interne ID: GRP_FKT_REZEPT

Rezepte

Diese Gruppe beinhaltet Funktionen für den Umgang mit Standard-Rezepten und Rezepten des optionalen Moduls Rezeptgruppen Manager.

Mehr im Online-Handbuch


GRP_FKT_SCRIPT

Interne ID: GRP_FKT_SCRIPT

Skript

Diese Gruppe beinhaltet Funktionen für den Umgang mit Skripten.

Mehr im Online-Handbuch


GRP_FKT_TABELLE

Interne ID: GRP_FKT_TABELLE

Report Generator

Diese Gruppe beinhaltet Funktionen für das optionale Modul Report Generator.

Mehr im Online-Handbuch


GRP_FKT_VARIABLE

Interne ID: GRP_FKT_VARIABLE

Variable

Diese Gruppe beinhaltet Funktionen für den Umgang mit Variablen.

Mehr im Online-Handbuch


GRP_FKT_VBA

Interne ID: GRP_FKT_VBA

VBA

Diese Gruppe beinhaltet Funktionen für den Umgang mit VBA-Makros.

Mehr im Online-Handbuch


GRP_FKT_VSTA

Interne ID: GRP_FKT_VSTA

VSTA

Diese Gruppe beinhaltet Funktionen für den Umgang mit VSTA-Makros.

Mehr im Online-Handbuch


GRP_FKT_WINDOWS

Interne ID: GRP_FKT_WINDOWS

Windows

Diese Gruppe beinhaltet Funktionen für den Umgang mit Betriebssystem-Funktionalität.

Mehr im Online-Handbuch


ID_230TOP_PROP_B_FOS

Interne ID: ID_230TOP_PROP_B_FOS

Grenze für Fehlerort aus Schutz

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TopologyBorderFOS"


ID_230TOP_PROP_B_SV

Interne ID: ID_230TOP_PROP_B_SV

Grenze für Stromverteilungsrechnung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TopologyBorderSV"


ID_230TOP_PROP_INVISIBLE

Interne ID: ID_230TOP_PROP_INVISIBLE

in RT unsichtbar

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RTInvisible"


ID_230TOP_PROP_LIRE

Interne ID: ID_230TOP_PROP_LIRE

Wirkrichtung/Einbaurichtung umdrehen

Tauscht den links/rechts Bezug bei topologischen Elementen, die einen Richtungsbezug haben.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TopologyLRChanged"


ID_230TOP_PROP_NC_CABLETYPE

Interne ID: ID_230TOP_PROP_NC_CABLETYPE

Kabeltyp

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCCableType"


ID_230TOP_PROP_NC_CURRENTMAX

Interne ID: ID_230TOP_PROP_NC_CURRENTMAX

Strombelastbarkeit [A]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCCCurrentMax"


ID_230TOP_PROP_NC_I_VAL

Interne ID: ID_230TOP_PROP_NC_I_VAL

Last [A]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCCurrentVal"


ID_230TOP_PROP_NC_I_VAR

Interne ID: ID_230TOP_PROP_NC_I_VAR

Meßwert Strom

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCCurrentVar"


ID_230TOP_PROP_NC_LENGTH

Interne ID: ID_230TOP_PROP_NC_LENGTH

Länge [m]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCCLength"


ID_230TOP_PROP_NC_REAKT

Interne ID: ID_230TOP_PROP_NC_REAKT

Reaktanz [Ohm]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCCReactance"


ID_230TOP_PROP_NC_RESIST

Interne ID: ID_230TOP_PROP_NC_RESIST

Resistanz [Ohm]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCCResistance"


ID_230TOP_PROP_NC_TYPE

Interne ID: ID_230TOP_PROP_NC_TYPE

Typ

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCType"


ID_230TOP_PROP_NC_U_VAL

Interne ID: ID_230TOP_PROP_NC_U_VAL

Spannungsebene [V]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCVoltageVal"


ID_230TOP_PROP_NC_U_VAR

Interne ID: ID_230TOP_PROP_NC_U_VAR

Meßwert Spannung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NCVoltageVar"


ID_230TOP_PROP_RES_NR

Interne ID: ID_230TOP_PROP_RES_NR

Betriebsmitteltyp

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TopologyResourceNr"


ID_230TOP_PROP_ZUORD_VAR

Interne ID: ID_230TOP_PROP_ZUORD_VAR

Basisname für Ergebnisvariablen

Variable, die als Basis für Variablen in der Topologie dient.

In der Topologie können Sie für jede Leitung eine Variable festlegen. Diese Variable dient als Basis für weitere Variablen,

die Sie in der Topologieprojektierung definieren. Sie können dann leistungsbezogenen, von der Topologie berechnete

Werte diesen Variablen zuordnen.

Klicken Sie auf die Schaltfläche, um den Dialog zur Variablenauswahl zu öffnen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Mapping-Variable"


ID_ADMINUSER

Interne ID: ID_ADMINUSER

Administrator

Aktiv: Dieser Benutzer ist ein Administrator. Also darf er andere Benutzer in der Runtime editieren und das System entsperren.
Inaktiv: Dieser Benutzer ist kein Administrator.
Default: inaktiv.

ACHTUNG: Ein Administrator kann anderen Benutzern nur Berechtigungsgruppen freigeben, die er auch selbst besitzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Admin"


ID_ADRESSPARAM

Interne ID: ID_ADRESSPARAM

Ext. Adressparameter

Externe Eigenschaft für zenon Logic. Betrifft nur Variablen, die nicht vom straton-Treiber sind.
Profileigenschaften in zenon Logic (wie z.B. "eingebettet" oder Adressparameter für Profibus).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Adressparam"


ID_ALARM_BEREICH_ALARMVAR

Interne ID: ID_ALARM_BEREICH_ALARMVAR

Anzahl aktive Alarme

Variable, die die Anzahl der aktiven Alarme in diesem Alarmbereich als Wert beinhaltet.
Öffnet den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmVar"


ID_ALARM_BEREICH_QUITVAR

Interne ID: ID_ALARM_BEREICH_QUITVAR

Anzahl unquittierte Alarme

Variable, die die Anzahl der unquittierten Alarme in diesem Alarmbereich als Wert beinhaltet.
Öffnet den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "QuitVar"


ID_ALARM_BEREICH_STATUSVAR

Interne ID: ID_ALARM_BEREICH_STATUSVAR

Statusvariable

Das erste Bit dieser Bytevariable zeigt an, ob es aktive Alarme in diesem Alarmbereich gibt.
Das zweite Bit dieser Bytevariable zeigt an, ob es unquittierte Alarme in diesem Alarmbereich gibt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusVar"


ID_ALARM_BEREICHITEM_ALARMVAR

Interne ID: ID_ALARM_BEREICHITEM_ALARMVAR

Anzahl aktive Alarme

Variable, die die Anzahl der aktiven Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich als Wert beinhaltet.
Öffnet den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmVar"


ID_ALARM_BEREICHITEM_DELETE

Interne ID: ID_ALARM_BEREICHITEM_DELETE

{Klassenverknüpfung löschen}

Der Bereichseintrag wird gelöscht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeleteEntry"


ID_ALARM_BEREICHITEM_KLASSE

Interne ID: ID_ALARM_BEREICHITEM_KLASSE

Alarm/Ereignis-Klasse

Alarm/Ereignis-Klasse für den Bereichseintrag.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Class"


ID_ALARM_BEREICHITEM_QUITVAR

Interne ID: ID_ALARM_BEREICHITEM_QUITVAR

Anzahl unquittierte Alarme

Variable, die die Anzahl der unquittierten Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich als Wert beinhaltet.
Öffnet den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "QuitVar"


ID_ALARM_BEREICHITEM_STATUSVAR

Interne ID: ID_ALARM_BEREICHITEM_STATUSVAR

Statusvariable

Das erste Bit dieser Bytevariable zeigt an, ob es aktive Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich gibt.
Das zweite Bit dieser Bytevariable zeigt an, ob es unquittierte Alarme der ausgewählten Alarm/Ereignis-Klasse in diesem Alarmbereich gibt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusVar"


ID_ALARM_PROP_BEREICH_ID

Interne ID: ID_ALARM_PROP_BEREICH_ID

Nr.

Nummer des Alarmbereichs.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Id"


ID_ALARM_PROP_BEREICH_ITEMS

Interne ID: ID_ALARM_PROP_BEREICH_ITEMS

Klassenverknüpfung

Fasst Statusvariable, Anzahl der aktiven Alarme und der unquittierten Alarme zusammen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Items"


ID_ALARM_PROP_BEREICH_NAME

Interne ID: ID_ALARM_PROP_BEREICH_NAME

Name

Name des Alarmbereichs.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_ALARM_PROP_BEREICH_NEU

Interne ID: ID_ALARM_PROP_BEREICH_NEU

{Klassenverknüpfung neu}

Legt einen neuen Bereichseintrag für den Alarmbereich an.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "New"


ID_ALARM_PROP_GRPKLS

Interne ID: ID_ALARM_PROP_GRPKLS

Allgemein

Eigenschaften für die Alarm/Ereignis-Gruppen bzw. Alarm/Ereignis-Klassen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GrpCls"


ID_ALARM_PROP_GRPKLS_COLOR

Interne ID: ID_ALARM_PROP_GRPKLS_COLOR

Farbe

Farbe der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.
Die Farbe der Alarm/Ereignis-Klasse kann für die Darstellung in den Listen verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Color"


ID_ALARM_PROP_GRPKLS_FUNKTION

Interne ID: ID_ALARM_PROP_GRPKLS_FUNKTION

Funktion

Name der Funktion, die ausgeführt wird, wenn ein Alarm dieser Gruppe/Klasse auftritt. Eine Klick auf die Schaltfläche öffnet den Dialog zur Funktionsauswahl. Alternativ tragen Sie den Namen der Funktion manuell in das Textfeld ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


ID_ALARM_PROP_GRPKLS_ID

Interne ID: ID_ALARM_PROP_GRPKLS_ID

Nr.

Nummer der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Id"


ID_ALARM_PROP_GRPKLS_IMAGE

Interne ID: ID_ALARM_PROP_GRPKLS_IMAGE

Grafikdatei

Selektieren Sie eine Grafik für die Alarm/Ereignis-Gruppe oder Alarm/Ereignis-Klasse. Ein Linksklick auf die Schaltfläche öffnet die Dateiauswahl. Selektieren Sie die gewünschte Grafikdatei.

Default: keine Datei

Mehr im Online-Handbuch zu Alarm/Ereignis-Gruppen

Mehr im Online-Handbuch zu Alarm/Ereignis-Klassen

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Image"


ID_ALARM_PROP_GRPKLS_NAME

Interne ID: ID_ALARM_PROP_GRPKLS_NAME

Name

Name der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_ALARM_PROP_GRPKLS_STATUSVAR

Interne ID: ID_ALARM_PROP_GRPKLS_STATUSVAR

Statusvariable

Name der Variablen, deren Wert anzeigt, ob die Gruppe/Klasse im Moment aktiv geschalten ist oder ob die Alarme dieser Gruppe/Klasse derzeit ignoriert werden.

Es können nur Binärvariablen verwendet werden. Ein Klick auf die Schaltfläche öffnet den Dialog zur Variablenauswahl. Alternativ tragen Sie den Namen der Variablen manuell in das Textfeld ein.

Variablen-Wert = 1: Gruppe/Klasse ist aktiv.

Alarm/Ereignis-Gruppen bzw. Alarm/Ereignis-Klassen können mit Hilfe der Funktion Alarm/Ereignis-Gruppe abmelden/anmelden aktiviert werden.

Interne ID: ID_ALARM_PROP_GRPKLS_STATUSVAR

Alarm/Ereignis-Gruppe abmelden/anmelden

Diese Funktion schaltet die Verbindung zur SPS für eine ausgewählte Alarm/Ereignis-Gruppe aus oder ein.

Mehr im Online-Handbuch

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusVar"


ID_ALARM_PROP_GRPKLS_TEXT

Interne ID: ID_ALARM_PROP_GRPKLS_TEXT

Beschreibung

Beschreibung der Alarm/Ereignis-Gruppe bzw. Alarm/Ereignis-Klasse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Description"


ID_ALARM_VERWALTUNG

Interne ID: ID_ALARM_VERWALTUNG

Alarm-Verwaltung

Der Konfigurationsdialog für die Alarmmeldeliste wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmAdministration"


ID_ALPHABACKCOLOR

Interne ID: ID_ALPHABACKCOLOR

Transparenz Füllfarbe [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiviert ist.

Interne ID: ID_ALPHABACKCOLOR

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ALPHABACKCOLOR

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor"

Nur verfügbar wenn die Projekteigenschaft Grafikqualität aktiviert ist.

Interne ID: ID_ALPHABACKCOLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ALPHABACKCOLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ALPHABACKCOLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor"

Definiert über einen Wert zwischen 0 und 100 Prozent die Deckkraft der Farbe.

0: unsichtbar

100: deckend.

Alle Werte dazwischen erscheinen je nach Einstellung transparent.

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor"


ID_ALPHABACKCOLOR2

Interne ID: ID_ALPHABACKCOLOR2

Transparenz Verlaufsfarbe [%]

Nur verfügbar, wenn in der Eigenschaft Füllmuster Verlauf ausgewählt wurde und die Eigenschaft Über Helligkeitswerte nicht aktiviert ist.

Interne ID: ID_ALPHABACKCOLOR2

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor2"

Interne ID: ID_ALPHABACKCOLOR2

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor2"

Nur verfügbar wenn die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ALPHABACKCOLOR2

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ALPHABACKCOLOR2

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ALPHABACKCOLOR2

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor2"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor2"

Definiert über einen Wert zwischen 0 und 100 Prozent die Deckkraft der Farbe.

0: unsichtbar

100: deckend.

Alle Werte dazwischen erscheinen je nach Einstellung transparent.

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBackColor2"


ID_ALPHACOLORRAHMEN

Interne ID: ID_ALPHACOLORRAHMEN

Transparenz Rahmenfarbe [%]

Nur verfügbar, wenn die EigenschaftÜber Helligkeitswerte nicht aktiviert wurde.

Interne ID: ID_ALPHACOLORRAHMEN

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ALPHACOLORRAHMEN

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBorderColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBorderColor"

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität aktiviert ist.

Interne ID: ID_ALPHACOLORRAHMEN

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ALPHACOLORRAHMEN

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ALPHACOLORRAHMEN

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBorderColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBorderColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBorderColor"

Definiert über einen Wert zwischen 0 und 100 Prozent die Deckkraft der Farbe.

0: unsichtbar

100: deckend.

Alle Werte dazwischen erscheinen je nach Einstellung transparent.

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaBorderColor"


ID_ALPHALINECOLOR

Interne ID: ID_ALPHALINECOLOR

Transparenz Linienfarbe [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Interne ID: ID_ALPHALINECOLOR

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ALPHALINECOLOR

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaLineColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaLineColor"

Nur verfügbar wenn die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ALPHALINECOLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ALPHALINECOLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ALPHALINECOLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaLineColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaLineColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaLineColor"

Definiert über einen Wert zwischen 0 und 100 Prozent die Deckkraft der Farbe.

0: unsichtbar

100: deckend.

Alle Werte dazwischen erscheinen je nach Einstellung transparent.

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlphaLineColor"


ID_AML_AKTIV

Interne ID: ID_AML_AKTIV

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmAdminActive"


ID_AML_BLINKQUIT

Interne ID: ID_AML_BLINKQUIT

Blink-Quittierung

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Mit dem Quittieren des Blinkens eines Elements wird auch der entsprechende Alarm in der Alarmmeldeliste quittiert
Inaktiv: Das Quittieren des Blinkens eines Elements beendet nur das Blinken. Der entsprechende Alarm wird nicht quittiert.
Default: inaktiv.
Das Blinken von Elementen kann durch einen Doppelklick mit der rechten Maustaste auf das entsprechende Element oder durch die Funktion "Blinkquittieren" quittiert werden.

Interne ID: ID_AML_BLINKQUIT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmFlashAcknowledge"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmFlashAcknowledge"


ID_AML_CLS_COLOR

Interne ID: ID_AML_CLS_COLOR

Alarm/Ereignis-Klassen Farbe

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
nicht verwenden: Die Farben der Alarm/Ereignis-Klassen werden in der Alarmmeldeliste in der Runtime nicht verwendet.
als Textfarbe: Die Farben der Alarm/Ereignis-Klassen werden in der Alarmmeldeliste in der Runtime als Textfarben für die entsprechenden Einträge verwendet.
als Zeilenhintergrund: Die Farben der Alarm/Ereignis-Klassen werden in der Alarmmeldeliste in der Runtime als Hintergrundfarben für die entsprechenden Einträge verwendet.
Default: als Zeilenhintergrund

Interne ID: ID_AML_CLS_COLOR

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmClsColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmClsColor"


ID_AML_COLOR_DEL

Interne ID: ID_AML_COLOR_DEL

Farbe

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_COLOR_DEL

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorDel"

Nur für Alarme mit aktiver Eigenschaft Löschpflichtig verfügbar.

Interne ID: ID_AML_COLOR_DEL

Löschpflichtig

Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Kein Löschen erforderlich.
Default: inaktiv

Interne ID: ID_AML_COLOR_DEL

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorDel"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorDel"

Farbe für Zeitstempel von Alarm gelöscht in der Alarmmeldeliste. Definiert auch Farbe für Grafik in Spalte Alarmzustand.

Diese Farbe wird nur für aktive, nicht aber für historische Alarme verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorDel"


ID_AML_COLOR_GEHT

Interne ID: ID_AML_COLOR_GEHT

Farbe

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Farbe für Geht-Zeit in der Alarmmeldeliste. Definiert auch Farbe für Grafik in Spalte Alarmzustand.

Interne ID: ID_AML_COLOR_GEHT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorClr"

Diese Farbe wird nur für aktive, nicht aber für historische Alarme verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorClr"


ID_AML_COLOR_KOMMT

Interne ID: ID_AML_COLOR_KOMMT

Farbe

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Farbe für Kommt-Zeit in der Alarmmeldeliste. Definiert auch Farbe für Grafik in Spalte Alarmzustand.

Interne ID: ID_AML_COLOR_KOMMT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorRec"

Diese Farbe wird nur für aktive, nicht aber für historische Alarme verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorRec"


ID_AML_COLOR_QUIT

Interne ID: ID_AML_COLOR_QUIT

Farbe

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Farbe für Quittiert-Zeit in der Alarmmeldeliste. Definiert auch Farbe für Grafik in Spalte Alarmzustand.

Interne ID: ID_AML_COLOR_QUIT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorAkn"

Diese Farbe wird nur für aktive, nicht aber für historische Alarme verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmColorAkn"


ID_AML_COMES_PREF

Interne ID: ID_AML_COMES_PREF

Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_COMES_PREF

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefComes"

Eingabe eines Präfix, das links vor dem Zeitstempel des gekommenen Alarms steht. Das Präfix hilft, den Zeitstempel von Alarm kommt schnell zu erkennen. Bei leerem Eintrag, wird kein Präfix angezeigt.

Interne ID: ID_AML_COMES_PREF

Alarm kommt

Eigenschaften für die Darstellung von Alarm kommt in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefComes"

Default: >>

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefComes"


ID_AML_COMES_PREF_IMAGE

Interne ID: ID_AML_COMES_PREF_IMAGE

Grafikdatei Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_COMES_PREF_IMAGE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageComes"

Definieren Sie eine Datei, die zusätzlich oder anstatt des Präfix links vor dem Zeitstempel des kommenden Alarms angezeigt werden soll. Die Grafik hilft den Zeitstempel von Alarm kommt schnell zu erkennen. Wenn Sie zusätzlich zu Präfix eine Datei definieren, wird diese links neben dem Präfix angezeigt.

Interne ID: ID_AML_COMES_PREF_IMAGE

Alarm kommt

Eigenschaften für die Darstellung von Alarm kommt in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageComes"

Interne ID: ID_AML_COMES_PREF_IMAGE

Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Eingabe eines Präfix, das links vor dem Zeitstempel des gekommenen Alarms steht. Das Präfix hilft, den Zeitstempel von Alarm kommt schnell zu erkennen. Bei leerem Eintrag, wird kein Präfix angezeigt.

Default: >>

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageComes"

Default: keine Datei

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageComes"


ID_AML_COUNT1

Interne ID: ID_AML_COUNT1

Meldung 1 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in Eigenschaft Meldung 2 Alarmanzahl.

Interne ID: ID_AML_COUNT1

Meldung 2 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in Eigenschaft Meldung 3 Alarmanzahl.

Interne ID: ID_AML_COUNT1

Meldung 3 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in der Eigenschaft Größe des Ringpuffers.

Interne ID: ID_AML_COUNT1

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: ID_AML_COUNT1

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt1"

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt1"

Interne ID: ID_AML_COUNT1

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt1"


ID_AML_COUNT2

Interne ID: ID_AML_COUNT2

Meldung 2 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in Eigenschaft Meldung 3 Alarmanzahl.

Interne ID: ID_AML_COUNT2

Meldung 3 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in der Eigenschaft Größe des Ringpuffers.

Interne ID: ID_AML_COUNT2

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: ID_AML_COUNT2

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt2"

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt2"

Interne ID: ID_AML_COUNT2

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt2"


ID_AML_COUNT3

Interne ID: ID_AML_COUNT3

Meldung 3 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in der Eigenschaft Größe des Ringpuffers.

Interne ID: ID_AML_COUNT3

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: ID_AML_COUNT3

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt3"

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt3"

Interne ID: ID_AML_COUNT3

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt3"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsgCnt3"


ID_AML_DELETEINCEL

Interne ID: ID_AML_DELETEINCEL

Alarm-Löschen

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Wird ein löschpflichtiger Alarm gelöscht, erfolgt ein Eintrag in die Chronologische Ereignisliste (CEL).
Inaktiv: Beim Löschen von Alarmen erfolgt kein Eintrag in die CEL.
Default: inaktiv.

Interne ID: ID_AML_DELETEINCEL

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmCELDelete"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmCELDelete"


ID_AML_DETACH

Interne ID: ID_AML_DETACH

Ringpuffer-Verwaltung

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Wenn die in der Eigenschaft Größe des Ringpuffers definierte Anzahl der Alarme im Speicher überschritten wird, wird eine der folgenden Aktionen ausgeführt:
neue verwerfen: Neue Alarme werden ignoriert. Diese werden damit nicht gespeichert und gehen verloren!
ältesten ausreihen: Sobald ein neuer Alarm auftritt, wird der älteste Alarm im Speicher in die entsprechende Datei verschoben.
neuesten ausreihen: Der neueste Alarm wird in die entsprechende Datei verschoben.
Default: älteste ausreihen

Interne ID: ID_AML_DETACH

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmDetach"

Interne ID: ID_AML_DETACH

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmDetach"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmDetach"


ID_AML_GOES_PREF

Interne ID: ID_AML_GOES_PREF

Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_GOES_PREF

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefGoes"

Eingabe eines Präfix, das links vor dem Zeitstempel des kommenden Alarms steht. Das Präfix hilft, den Zeitstempel von Alarm geht schnell zu erkennen. Bei leerem Eintrag, wird kein Präfix angezeigt.

Interne ID: ID_AML_GOES_PREF

Alarm geht

Eigenschaften für die Darstellung von Alarm geht in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefGoes"

Default: >>

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefGoes"


ID_AML_GOES_PREF_IMAGE

Interne ID: ID_AML_GOES_PREF_IMAGE

Grafikdatei Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_GOES_PREF_IMAGE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageGoes"

Definieren Sie eine Datei, die zusätzlich oder anstatt des Präfix links vor dem Zeitstempel des gegangenen Alarms angezeigt werden soll. Die Grafik hilft den Zeitstempel von Alarm geht schnell zu erkennen. Wenn Sie zusätzlich zu Präfix eine Datei definieren, wird diese links neben dem Präfix angezeigt.

Interne ID: ID_AML_GOES_PREF_IMAGE

Alarm geht

Eigenschaften für die Darstellung von Alarm geht in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageGoes"

Interne ID: ID_AML_GOES_PREF_IMAGE

Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Eingabe eines Präfix, das links vor dem Zeitstempel des kommenden Alarms steht. Das Präfix hilft, den Zeitstempel von Alarm geht schnell zu erkennen. Bei leerem Eintrag, wird kein Präfix angezeigt.

Default: >>

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageGoes"

Default: keine Datei

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageGoes"


ID_AML_GRP_CLEARED

Interne ID: ID_AML_GRP_CLEARED

Alarm geht

Eigenschaften für die Darstellung von Alarm geht in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_AML_GRP_COLOR

Interne ID: ID_AML_GRP_COLOR

Farben AML-Einträge

Eigenschaften für die Definition der Farben für die Alarm-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML_Color"


ID_AML_GRP_DEL

Interne ID: ID_AML_GRP_DEL

Alarm gelöscht

Eigenschaften für die Darstellung von Alarm gelöscht in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_AML_GRP_IMAGE

Interne ID: ID_AML_GRP_IMAGE

Graphik AML-Einträge

Eigenschaften für die Grafikeinstellungen der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML_Images"


ID_AML_GRP_MEM

Interne ID: ID_AML_GRP_MEM

Datenspeicherung AML

Eigenschaften für die Speicherung der Alarme im Hauptspeicher und auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML_Mem"


ID_AML_GRP_QUIT

Interne ID: ID_AML_GRP_QUIT

Alarm quittiert

Eigenschaften für die Darstellung von Alarm quittiert in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_AML_GRP_RECIVED

Interne ID: ID_AML_GRP_RECIVED

Alarm kommt

Eigenschaften für die Darstellung von Alarm kommt in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_AML_GRP_STATUSBAR

Interne ID: ID_AML_GRP_STATUSBAR

Alarmstatuszeile

Eigenschaften für die Statuszeile der Alarmverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML_StatusBar"


ID_AML_IMAGE_DEL

Interne ID: ID_AML_IMAGE_DEL

Grafikdatei Zustand

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_IMAGE_DEL

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageDel"

Auswahl einer Grafikdatei für den Zustand Alarm gelöscht. Sie können sich diese Datei alternativ zur selektierten Farbe des Zustands in der Runtime in der Alarmmeldeliste anzeigen lassen. Dazu wählen Sie im Filter für die AML in der Registerkarte Spalteneinstellungen für die Spalte Alarmzustand die Anzeigeart Grafikdatei.

Default: keine Datei

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageDel"


ID_AML_IMAGE_GEHT

Interne ID: ID_AML_IMAGE_GEHT

Grafikdatei Zustand

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_IMAGE_GEHT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageClr"

Selektieren Sie eine Grafikdatei für den Zustand Alarm geht. Sie können sich diese Datei alternativ zur selektierten Farbe des Zustands in der Runtime in der Alarmmeldeliste anzeigen lassen. Dazu selektieren Sie im Filter für die AML in der Registerkarte Spalteneinstellungen für die Spalte Alarmzustand die Anzeigeart Grafikdatei.

Default: keine Datei

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageClr"


ID_AML_IMAGE_KOMMT

Interne ID: ID_AML_IMAGE_KOMMT

Grafikdatei Zustand

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_IMAGE_KOMMT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageRec"

Selektieren Sie eine Grafikdatei für den Zustand Alarm kommt. Sie können sich diese Datei alternativ zur selektierten Farbe des Zustands in der Runtime in der Alarmmeldeliste anzeigen lassen. Dazu selektieren Sie im Filter für die AML in der Registerkarte Spalteneinstellungen für die Spalte Alarmzustand die Anzeigeart Grafikdatei.

Default: keine Datei

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageRec"


ID_AML_IMAGE_QUIT

Interne ID: ID_AML_IMAGE_QUIT

Grafikdatei Zustand

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_IMAGE_QUIT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageAkn"

Selektieren Sie eine Grafikdatei für den Zustand Alarm quittiert. Sie können sich diese Datei alternativ zur selektierten Farbe des Zustands in der Runtime in der Alarmmeldeliste anzeigen lassen. Dazu selektieren Sie im Filter für die AML in der Registerkarte Spalteneinstellungen für die Spalte Alarmzustand die Anzeigeart Grafikdatei.

Default: keine Datei

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmImageAkn"


ID_AML_LISTENTRY

Interne ID: ID_AML_LISTENTRY

Spalteneinstellung AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Öffnet den Dialog zur Definition der Spalten, die in der Alarmmeldeliste angezeigt werden.
Diese Einstellungen gelten als Default für Alarmmeldeliste, Alarmmeldeliste Filter und Alarmstatuszeile. Diese können bei der Definition der einzelnen Alarmfunktionen geändert werden.

Interne ID: ID_AML_LISTENTRY

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmListEntry"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmListEntry"


ID_AML_LST_STYLE

Interne ID: ID_AML_LST_STYLE

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_AML_LST_STYLE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmHeader"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_AML_LST_STYLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_AML_LST_STYLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmHeader"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmHeader"

Interne ID: ID_AML_LST_STYLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmHeader"

Interne ID: ID_AML_LST_STYLE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmHeader"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmHeader"


ID_AML_MEMCOUNT

Interne ID: ID_AML_MEMCOUNT

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: ID_AML_MEMCOUNT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMemCount"

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMemCount"


ID_AML_MITREAKTZEIT

Interne ID: ID_AML_MITREAKTZEIT

Reaktiviertzeit verwenden

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Wenn derselbe Alarm mehrmals hintereinander auftritt, wird nur eine Zeile in der Alarmmeldeliste erstellt. Zusätzliche Informationen (z.B. Alarmzähler) können in der Liste dargestellt werden.
Inaktiv: Jeder Alarm erhält eine eigene Zeile in der Alarmmeldeliste.
Default: inaktiv.

Interne ID: ID_AML_MITREAKTZEIT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmTimeReactive"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmTimeReactive"


ID_AML_MSG1

Interne ID: ID_AML_MSG1

Meldung 1 Text

Nur verfügbar, wenn der Wert in Eigenschaft Meldung 1 Alarmanzahl größer als 0 ist.
Text der Meldung für die Eigenschaft Meldung 1 Alarmanzahl, der zur Runtime in der Statuszeile angezeigt werden soll. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.

Interne ID: ID_AML_MSG1

Meldung 1 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in Eigenschaft Meldung 2 Alarmanzahl.

Interne ID: ID_AML_MSG1

Meldung 2 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in Eigenschaft Meldung 3 Alarmanzahl.

Interne ID: ID_AML_MSG1

Meldung 3 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in der Eigenschaft Größe des Ringpuffers.

Interne ID: ID_AML_MSG1

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: ID_AML_MSG1

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg1"

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg1"

Interne ID: ID_AML_MSG1

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg1"


ID_AML_MSG2

Interne ID: ID_AML_MSG2

Meldung 2 Text

Nur verfügbar, wenn der Wert in Eigenschaft Meldung 2 Alarmanzahl größer als 0 ist.
Text der Meldung für die EigenschaftMeldung 2 Alarmanzahl , der zur Runtime in der Statuszeile angezeigt werden soll. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.

Interne ID: ID_AML_MSG2

Meldung 2 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in Eigenschaft Meldung 3 Alarmanzahl.

Interne ID: ID_AML_MSG2

Meldung 3 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in der Eigenschaft Größe des Ringpuffers.

Interne ID: ID_AML_MSG2

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: ID_AML_MSG2

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg2"

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg2"

Interne ID: ID_AML_MSG2

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg2"


ID_AML_MSG3

Interne ID: ID_AML_MSG3

Meldung 3 Text

Nur verfügbar, wenn der Wert in Eigenschaft Meldung 3 Alarmanzahl größer als 0 ist.
Text der Meldung für die Eigenschaft Meldung 3 Alarmanzahl, der zur Runtime in der Statuszeile angezeigt werden soll. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.

Interne ID: ID_AML_MSG3

Meldung 3 Alarmanzahl

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Anzahl der Einträge in der AML, die nötig sind, damit diese Meldung zur Runtime in der Alarmstatuszeile angezeigt wird. Diese Meldung wird mit blauem Hintergrund und weißer Textfarbe angezeigt und überlagert die Alarmstatuszeile.
Minimum: 0 (Keine Meldung wird angezeigt)
Maximum: 100
Default: 0
Achtung: Der Wert muss kleiner sein als der Wert in der Eigenschaft Größe des Ringpuffers.

Interne ID: ID_AML_MSG3

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Maximale Anzahl der Einträge für den Ringpuffer.

Interne ID: ID_AML_MSG3

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg3"

Minimum: 1
Maximum: 32767
Default: 100

Empfohlen: Mindestens Anzahl der Variablen mit Alarmen.

Achtung: Der Ringpuffer muss immer ausreichend dimensioniert werden. Zur Runtime wird der Ringpuffer im Arbeitsspeicher dynamisch gehandhabt. Es werden also auch Alarme angezeigt, die die Größe des Ringpuffers übersteigen. In der Speicherdatei des Ringpuffers (alarm.bin) werden aber nur Alarme bis zur festgelegten Anzahl gespeichert. Alle Einträge werden parallel in die Alarmdatei (*.aml) im Runtimeordner eingetragen. Beide Dateien werden synchronisiert. Bei Pufferüberlauf können in der Alarmdatei unquittierte Einträge enthalten sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg3"

Interne ID: ID_AML_MSG3

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg3"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg3"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmMsg3"


ID_AML_ONLY_STACK

Interne ID: ID_AML_ONLY_STACK

AML-Daten speichern

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Nur Ringpuffer: Nur anstehende Alarme (alarm.bin) werden auf der Festplatte gespeichert.
Ringpuffer und historische Daten: Auch historische Alarme (*.aml) werden gespeichert.
Default: Auf CE-Geräten wird nur der Ringpuffer (alarm.bin) auf die Festplatte gespeichert; auf PCs werden auch die historischen Einträge (*.aml) gespeichert.
Default: Default.
Die Dateien (alarm.bin und *.aml) werden im Ordner \Projektordner\Computername\Projektname gespeichert.

Interne ID: ID_AML_ONLY_STACK

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmlOnlyStack"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmlOnlyStack"


ID_AML_QUIT_PREF

Interne ID: ID_AML_QUIT_PREF

Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_QUIT_PREF

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefQuit"

Eingabe eines Präfix, das links vor dem Zeitstempel des quittierten Alarms steht. Das Präfix hilft, den Zeitstempel von Alarm quittiert schnell zu erkennen. Bei leerem Eintrag, wird kein Präfix angezeigt.

Interne ID: ID_AML_QUIT_PREF

Alarm quittiert

Eigenschaften für die Darstellung von Alarm quittiert in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefQuit"

Default: --

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefQuit"


ID_AML_QUIT_PREF_IMAGE

Interne ID: ID_AML_QUIT_PREF_IMAGE

Grafikdatei Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Interne ID: ID_AML_QUIT_PREF_IMAGE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageQuit"

Definieren Sie eine Datei, die zusätzlich oder anstatt des Präfix links vor dem Zeitstempel des quittierten Alarms angezeigt werden soll. Die Grafik hilft den Zeitstempel von Alarm quittiert schnell zu erkennen. Wenn Sie zusätzlich zu Präfix eine Datei definieren, wird diese links neben dem Präfix angezeigt.

Interne ID: ID_AML_QUIT_PREF_IMAGE

Alarm quittiert

Eigenschaften für die Darstellung von Alarm quittiert in der Alarmmeldeliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageQuit"

Interne ID: ID_AML_QUIT_PREF_IMAGE

Präfix

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.

Eingabe eines Präfix, das links vor dem Zeitstempel des quittierten Alarms steht. Das Präfix hilft, den Zeitstempel von Alarm quittiert schnell zu erkennen. Bei leerem Eintrag, wird kein Präfix angezeigt.

Default: --

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageQuit"

Default: keine Datei

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPrefImageQuit"


ID_AML_QUITINCEL

Interne ID: ID_AML_QUITINCEL

Alarm-Quittierung

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Wird ein Alarm quittiert, erfolgt ein Eintrag in die Chronologische Ereignisliste (CEL).
Inaktiv: Das Quittieren von Alarmen führt zu keinem Eintrag in der CEL.
Default: inaktiv.

Interne ID: ID_AML_QUITINCEL

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmCELAcknowledge"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmCELAcknowledge"


ID_AML_STATUS_AKTIV

Interne ID: ID_AML_STATUS_AKTIV

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Interne ID: ID_AML_STATUS_AKTIV

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusActive"

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusActive"


ID_AML_STATUS_DISPLAY

Interne ID: ID_AML_STATUS_DISPLAY

Anzeige

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
ältester Alarm: Abhängig von der Einstellung der Eigenschaft nächsten nachschieben wird nur der älteste unquittierte Alarm in der Statuszeile in der Runtime angezeigt (inaktiv) oder der älteste Alarm wird zuerst angezeigt (aktiv).
jüngster Alarm: Abhängig von der Einstellung der Eigenschaft nächsten nachschieben wird nur der jüngste unquittierte Alarm in der Statuszeile in der Runtime angezeigt (inaktiv) oder der jüngste Alarm wird zuerst angezeigt (aktiv).
Default: ältester Alarm

Interne ID: ID_AML_STATUS_DISPLAY

nächsten nachschieben

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Aktiv: Alle unquittierten Alarme werden zur Runtime in der Statuszeile hintereinander angezeigt. Sobald ein Alarm durch einen Doppelklick mit der rechten Maustaste quittiert wurde, wird der nächste Alarm angezeigt. Abhängig von der Einstellung in der Eigenschaft Anzeige wird der älteste oder der neueste Alarm zuerst angezeigt.
Inaktiv: In der Statuszeile wird immer nur ein Alarm angezeigt. Die Statuszeile ist leer, nachdem der Alarm quittiert wurde.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusDisplay"

Interne ID: ID_AML_STATUS_DISPLAY

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Interne ID: ID_AML_STATUS_DISPLAY

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusDisplay"

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusDisplay"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusDisplay"


ID_AML_STATUS_FONT

Interne ID: ID_AML_STATUS_FONT

Schrift

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Schriftart für die Statuszeile in der Runtime.

Interne ID: ID_AML_STATUS_FONT

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Interne ID: ID_AML_STATUS_FONT

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusFont"

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusFont"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusFont"


ID_AML_STATUS_SUBSEQ

Interne ID: ID_AML_STATUS_SUBSEQ

nächsten nachschieben

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
Aktiv: Alle unquittierten Alarme werden zur Runtime in der Statuszeile hintereinander angezeigt. Sobald ein Alarm durch einen Doppelklick mit der rechten Maustaste quittiert wurde, wird der nächste Alarm angezeigt. Abhängig von der Einstellung in der Eigenschaft Anzeige wird der älteste oder der neueste Alarm zuerst angezeigt.
Inaktiv: In der Statuszeile wird immer nur ein Alarm angezeigt. Die Statuszeile ist leer, nachdem der Alarm quittiert wurde.
Default: aktiv

Interne ID: ID_AML_STATUS_SUBSEQ

Anzeige

Nur verfügbar bei aktivierter Eigenschaft Statuszeile aktiv.
ältester Alarm: Abhängig von der Einstellung der Eigenschaft nächsten nachschieben wird nur der älteste unquittierte Alarm in der Statuszeile in der Runtime angezeigt (inaktiv) oder der älteste Alarm wird zuerst angezeigt (aktiv).
jüngster Alarm: Abhängig von der Einstellung der Eigenschaft nächsten nachschieben wird nur der jüngste unquittierte Alarm in der Statuszeile in der Runtime angezeigt (inaktiv) oder der jüngste Alarm wird zuerst angezeigt (aktiv).
Default: ältester Alarm

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusAlign"

Interne ID: ID_AML_STATUS_SUBSEQ

Statuszeile aktiv

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Sobald ein Alarm auftritt, wird zur Runtime am oberen Bildschirmrand eine rote Statuszeile mit der Alarminformation angezeigt. In dieser Statuszeile kann der Alarm auch durch einen Doppelklick mit der rechten Maustaste quittiert werden, wenn der angemeldete Benutzer über die entsprechenden Rechte verfügt.
Inaktiv: Keine Statuszeile wird angezeigt.
Default: aktiv

Interne ID: ID_AML_STATUS_SUBSEQ

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusAlign"

Achtung Mehrprojektverwaltung: Einstellung im Integrationsprojekt definiert Verhalten für Unterprojekte, unabhängig von der Einstellung der Unterprojekte. Zur Runtime wird immer die Alarmstatuszeile des obersten Projekts verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusAlign"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmStatusAlign"


ID_AUTOLOGOFFTIME

Interne ID: ID_AUTOLOGOFFTIME

Zeit [min]

Zeit ohne Bedienaktion, nach der ein Benutzer automatisch ausgeloggt wird (in Minuten).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AutoLogoutTime"


ID_AUTOLOGOUT

Interne ID: ID_AUTOLOGOUT

Automatisches Logout aktiv

Aktiv: Der Benutzer wird automatisch ausgeloggt, wenn für die definierte Zeit keine Bedienaktion stattfindet.
Inaktiv: Der Benutzer wird vom System nicht automatisch ausgeloggt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AutoLogout"


ID_BACKUP_FILE_NAME

Interne ID: ID_BACKUP_FILE_NAME

Dateiname

Name der Sicherungsdatei.
Default: JJJJ-MM-TT_hh-mm-ss Projektname.zip.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_BiffiDCM_NV

Interne ID: ID_BiffiDCM_NV

NV-Index

Der NV-Index ist nur für Node-Data relevant.

Geben Sie hier den Netzwerkvariablen-Index (NVI/NVO) der Variable an.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NV-Index"


ID_BiffiDCM_SENDDIRECT

Interne ID: ID_BiffiDCM_SENDDIRECT

Send directly

Die Einstellung ist nur für Node-Data relevant.

Geben Sie an, ob ein Sollwert direkt oder gepuffert zum DCM übertragen werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Send_direct"


ID_BiffiDCM_TRANSIENT

Interne ID: ID_BiffiDCM_TRANSIENT

Transient command

Die Einstellung ist nur für Node-Data relevant.

Geben Sie an, ob ein via command event empfangener Istwert automatisch vom Treiber wieder auf 0 zurückgesetzt werden soll, d.h. ob es sich um eine implizite Wischermeldung handelt. (z.B. ICON2K Open, Close, Stop)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Transient"


ID_BURPVI_ADDRESS

Interne ID: ID_BURPVI_ADDRESS

PVI Name

Ist der Name der SPS Variable. Der Name wird aus Taskname/Variablenname gebildet. Für Globale Variable: Nur Variablenname

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BURPVI_ADDRESS"


ID_BURPVI_GROUP

Interne ID: ID_BURPVI_GROUP

PVI Address

Addressinformationen für den Bernecker und Reiner PVI Treiber (BURPVI)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_PVI_Address"


ID_BURPVI_VL_LENGTH

Interne ID: ID_BURPVI_VL_LENGTH

PVI Length (VL)

Variablenlänge in Bytes.
Bei Einzelvariablen entspricht die Variablenlänge der Prozessdatenlänge. Bei Feldvariablen ist die Variablenlänge als Elementlänge definiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BURPVI_VL_LENGTH"


ID_BURPVI_VN_ELEMENTS

Interne ID: ID_BURPVI_VN_ELEMENTS

PVI Number of Elements (VN)

Anzahl der Elemente bei Feldvariablen.
Bei mehrdimensionalen Feldvariablen wird die Anzahl der Elemente aller Felddimensionen angegeben (Beispiel: var[10][5] => VN=50).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BURPVI_VN_ELEMENTS"


ID_BURPVI_VT_TYPE

Interne ID: ID_BURPVI_VT_TYPE

PVI Type (VT)

Variablentyp in der Steuerung. Die möglichen Werte sind im online Handbuch beschrieben. Durch die Verwendung eines abweichenden Datentyps in zenon kann ein Typecasting erfolgen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BURPVI_VT_TYPE"


ID_CEL_AKTIV

Interne ID: ID_CEL_AKTIV

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELAdminActive"


ID_CEL_ARCHIVE_CHANGE

Interne ID: ID_CEL_ARCHIVE_CHANGE

Archivdaten

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Keine Protokollierung: Das Editieren von Archiven wird in der CEL nicht mitprotokolliert.
Änderungen protokollieren: Beim Editieren von Archiven wird der Name des Archivs, der Name der Variable sowie der alte und neue Wert und der alte und neue Zeitstempel in der CEL protokolliert.
Default: keine Protokollierung

Interne ID: ID_CEL_ARCHIVE_CHANGE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ArchiveChangeToCEL"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ArchiveChangeToCEL"


ID_CEL_CLS_COLOR

Interne ID: ID_CEL_CLS_COLOR

Alarm/Ereignis-Klassen Farbe

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
nicht verwenden: Die Farben der Alarm/Ereignis-Klassen werden in der CEL in der Runtime nicht verwendet.
als Textfarbe: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Textfarben für die entsprechenden Einträge verwendet. Diese überschreiben die Auswahl in der Eigenschaft sortierter Text.
als Zeilenhintergrund: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Hintergrundfarben für die entsprechenden Einträge verwendet.
Default: als Textfarbe

Interne ID: ID_CEL_CLS_COLOR

sortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Definiert Farbe des Textes für die Einträge in der Chronologischen Ereignisliste (CEL).
Hinweise:

1. Wird für die Eigenschaft Alarm/Ereignis-Klassen Farbe als Textfarbe gewählt, dann hat diese Farbe Vorrang vor der Auswahl in sortierter Text.

2. Für SICAM 230: Um in der Liste durchgehend die gleiche Farbe zu haben, muss für die Eigenschaft unsortierter Text die gleiche Farbe gewählt werden.

Interne ID: ID_CEL_CLS_COLOR

unsortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv und nur für SICAM 230.
Textfarbe für unsortierte Einträge in der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELClsColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELClsColor"

Interne ID: ID_CEL_CLS_COLOR

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELClsColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELClsColor"


ID_CEL_COLOR_SORT

Interne ID: ID_CEL_COLOR_SORT

sortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Interne ID: ID_CEL_COLOR_SORT

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELColorSort"

Definiert Farbe des Textes für die Einträge in der Chronologischen Ereignisliste (CEL).
Hinweise:

1. Wird für die Eigenschaft Alarm/Ereignis-Klassen Farbe als Textfarbe gewählt, dann hat diese Farbe Vorrang vor der Auswahl in sortierter Text.

Interne ID: ID_CEL_COLOR_SORT

Alarm/Ereignis-Klassen Farbe

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
nicht verwenden: Die Farben der Alarm/Ereignis-Klassen werden in der CEL in der Runtime nicht verwendet.
als Textfarbe: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Textfarben für die entsprechenden Einträge verwendet. Diese überschreiben die Auswahl in der Eigenschaft sortierter Text.
als Zeilenhintergrund: Die Farben der Alarm/Ereignis-Klassen werden zur Runtime in der CEL als Hintergrundfarben für die entsprechenden Einträge verwendet.
Default: als Textfarbe

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELColorSort"

2. Für SICAM 230: Um in der Liste durchgehend die gleiche Farbe zu haben, muss für die Eigenschaft unsortierter Text die gleiche Farbe gewählt werden.

Interne ID: ID_CEL_COLOR_SORT

unsortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv und nur für SICAM 230.
Textfarbe für unsortierte Einträge in der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELColorSort"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELColorSort"


ID_CEL_COLOR_UNSORT

Interne ID: ID_CEL_COLOR_UNSORT

unsortierter Text

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv und nur für SICAM 230.
Textfarbe für unsortierte Einträge in der Chronologischen Ereignisliste (CEL).

Interne ID: ID_CEL_COLOR_UNSORT

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELColorUnsort"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELColorUnsort"


ID_CEL_GRP_ALLGEMEIN

Interne ID: ID_CEL_GRP_ALLGEMEIN

Protokollierung

Allgemeine Eigenschaften für die Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CEL_Common"


ID_CEL_GRP_COLOR

Interne ID: ID_CEL_GRP_COLOR

Farben CEL Einträge

Eigenschaften für die Definition der Farben für die Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CEL_Color"


ID_CEL_GRP_MEM

Interne ID: ID_CEL_GRP_MEM

Datenspeicherung CEL

Eigenschaften für die Speicherung der Einträge der Chronologischen Ereignisliste (CEL) im Hauptspeicher und auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CEL_Mem"


ID_CEL_LISTENTRY

Interne ID: ID_CEL_LISTENTRY

Spalteneinstellung CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Der Dialog zur Definition für die Spalten in der CEL wird geöffnet.
Diese Einstellungen gelten als Default und können bei der Definition der einzelnen CEL-Funktionen geändert werden.

Interne ID: ID_CEL_LISTENTRY

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELListEntry"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELListEntry"


ID_CEL_LST_STYLE

Interne ID: ID_CEL_LST_STYLE

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_CEL_LST_STYLE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELHeader"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELHeader"


ID_CEL_MEMCOUNT

Interne ID: ID_CEL_MEMCOUNT

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Größe des CEL-Ringpuffers. Bei Überlauf des Ringpuffers (cel.bin) werden die Einträge in das CEL-Archiv (*.cel) übertragen.
Minimum: 1
Maximum: 32767
Default: 100

Interne ID: ID_CEL_MEMCOUNT

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELMemCount"

Hinweis: Zur Runtime werden eventuell mehr Einträge als projektiert angezeigt, da alte Einträge erst beim Aktualisieren der Liste aus der CEL entfernt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELMemCount"


ID_CEL_ONLY_STACK

Interne ID: ID_CEL_ONLY_STACK

CEL-Daten speichern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Ringpuffer und historische Daten: Alle CEL-Einträge (*.cel) werden gespeichert.

Interne ID: ID_CEL_ONLY_STACK

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CelOnlyStack"

Nur Ringpuffer: Nur eine definierte Anzahl von CEL-Einträgen (cel.bin) wird gespeichert. Die Anzahl wird über die Eigenschaft Größe des Ringpuffers definiert.
Default: Auf CE-Geräten wird nur der Ringpuffer (cel.bin) gespeichert; auf PCs werden auch die historischen Einträge (*.cel) gespeichert.
Default: Default
Die Dateien (cel.bin und *.cel) werden im Verzeichnis \Projektverzeichnis\Computername\Projektname gespeichert.

Interne ID: ID_CEL_ONLY_STACK

Größe des Ringpuffers

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Größe des CEL-Ringpuffers. Bei Überlauf des Ringpuffers (cel.bin) werden die Einträge in das CEL-Archiv (*.cel) übertragen.
Minimum: 1
Maximum: 32767
Default: 100

Hinweis: Zur Runtime werden eventuell mehr Einträge als projektiert angezeigt, da alte Einträge erst beim Aktualisieren der Liste aus der CEL entfernt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CelOnlyStack"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CelOnlyStack"


ID_CEL_RECIPE_CHANGE

Interne ID: ID_CEL_RECIPE_CHANGE

Rezepte ändern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Keine Protokollierung: Das Ändern von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
Rezepte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts in der CEL protokolliert.
Rezepte und Werte protokollieren: Beim Ändern eines Rezepts wird dieses mit dem Namen des geänderten Rezepts sowie den Namen und alten und neuen Werten der geänderten Variablen in der CEL protokolliert.
Default: keine Protokollierung

Interne ID: ID_CEL_RECIPE_CHANGE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeChangeToCEL"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeChangeToCEL"


ID_CEL_RECIPE_WRITE

Interne ID: ID_CEL_RECIPE_WRITE

Rezepte absetzen

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Keine Protokollierung: Das Absetzen von Standard Rezepten und Rezepten des Rezeptgruppen-Managers (RGM) wird nicht in der CEL protokolliert.
Rezepte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts in der CEL protokolliert.
Rezepte und Werte protokollieren: Beim Absetzen eines Rezepts wird dieses mit dem Namen des Rezepts sowie den Namen und alten und neuen Werten der Variablen in der CEL protokolliert.
Default: keine Protokollierung

Interne ID: ID_CEL_RECIPE_WRITE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeWriteToCEL"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeWriteToCEL"


ID_CEL_SPONTAN

Interne ID: ID_CEL_SPONTAN

Automatisch aktualisieren

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Aktiv: Während die CEL in der Runtime geöffnet ist, werden neue Ereignisse sofort hinzugefügt, wenn sie auftreten.
Inaktiv: Während die CEL geöffnet ist, werden keine neuen Einträge hinzugefügt. Die neuen Einträge werden erst beim nächsten Öffnen der CEL hinzugefügt.
Default: aktiv

Interne ID: ID_CEL_SPONTAN

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELSpontan"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELSpontan"


ID_CEL_SYSMSGPRT

Interne ID: ID_CEL_SYSMSGPRT

Systemmeldungen drucken

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Interne ID: ID_CEL_SYSMSGPRT

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELSysMsgPrint"

Aktiv: Beim Online-Druck werden auch Systemmeldungen ausgedruckt.
Inaktiv: Systemmeldungen werden beim Online-Druck nicht ausgedruckt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELSysMsgPrint"


ID_CEL_VERWALTUNG

Interne ID: ID_CEL_VERWALTUNG

CEL-Verwaltung

Der Konfigurationsdialog für die Chronologische Ereignisliste (CEL) wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELAdministration"


ID_CHANGELOG_COMMENT

Interne ID: ID_CHANGELOG_COMMENT

Kommentar

Kommentar für den ausgewählten Eintrag in der Änderungshistorie.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment"


ID_CHANGELOG_FILTER_DATASETS

Interne ID: ID_CHANGELOG_FILTER_DATASETS

Max. Datensätze

Gibt die maximale Anzahl von Einträgen an, die in der Listenanssicht angezeigt werden sollen.
Minimum: 0.
Das heißt, dass alle Einträge angezeigt werden.
Maximum: 2147483647.
Default: 1000.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Datensätze"


ID_CHANGELOG_FILTER_PROP_GRP0

Interne ID: ID_CHANGELOG_FILTER_PROP_GRP0

Erweiterter Filter

Eigenschaften für den erweiterten Filter der Änderungs-Historie.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_CHANGELOG_FILTER_TIME_MAX

Interne ID: ID_CHANGELOG_FILTER_TIME_MAX

Max. Zeitstempel

Nur verfügbar, wenn Zeitbereich aktiv ist:
Spätester Zeitpunkt für angezeigte Einträge.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimestampMax"


ID_CHANGELOG_FILTER_TIME_MIN

Interne ID: ID_CHANGELOG_FILTER_TIME_MIN

Min. Zeitstempel

Nur verfügbar, wenn Zeitbereich aktiv ist:
Frühester Zeitpunkt für angezeigte Einträge.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimestampMin"


ID_CHANGELOG_FILTER_TIMERANGE

Interne ID: ID_CHANGELOG_FILTER_TIMERANGE

Zeitbereich aktiv

Aktiv: Filtern auf Zeitbereich ist möglich.
Inaktiv: Filtern auf Zeitbereich ist nicht möglich.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimeRange"


ID_CHANGELOG_PROP_GRP0

Interne ID: ID_CHANGELOG_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die Einträge in der Änderungshistorie.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_COLOR_COLOR_GRP

Interne ID: ID_COLOR_COLOR_GRP

Farbe

Enthält alle Eigenschaften der Farben für Farbpaletten.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColColor"


ID_COLOR_COLOR_NAME

Interne ID: ID_COLOR_COLOR_NAME

Bezeichnung

Name der Farbe.

Default: Color plus Indexnummer, z. B.: Color 1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColColorName"


ID_COLOR_COLOR_VALUE

Interne ID: ID_COLOR_COLOR_VALUE

Farbe

Ermöglicht Auswahl oder Definition der Farbe. Klick auf ... öffnet eine Farbpalette zur Auswahl einer Farbe. Die Farbe kann auch als Hexadezimalcode direkt in das Feld eingegeben werden.

Default: weiß (#FFFFFF)

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColColorValue"


ID_COLOR_PALETTE_GRP

Interne ID: ID_COLOR_PALETTE_GRP

Farbpalette

Enthält die Eigenschaften der Farbpalette.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColPalette"


ID_COLOR_PALETTE_NAME

Interne ID: ID_COLOR_PALETTE_NAME

Palettenname

Name der Farbpalette.

Default: Color palette plus Indexnummer, z. B.: Color palette 1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PaletteName"


ID_COLORRAHMEN

Interne ID: ID_COLORRAHMEN

Rahmenfarbe

Definiert die Rahmenfarbe des Elements. Die Farbe kann direkt als Hexadezimalwert eingegeben oder nach Klick auf die Schaltfläche ... gewählt werden. Bei Auswahl von Automatisch ändert sich der Farbwert abhängig vom Wert der Füllfarbe.

Interne ID: ID_COLORRAHMEN

Füllfarbe

Nur verfügbar, wenn die Eigenschaft Transparent auf inaktiv geschaltet wurde.

Interne ID: ID_COLORRAHMEN

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BorderColor"

Definiert die Füllfarbe des Elements. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Die Füllfarbe kann dynamisch geändert werden über die Eigenschaft Füllfarbe aus der Gruppe Farben dynamisch .

Interne ID: ID_COLORRAHMEN

Farben dynamisch

Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BorderColor"

Interne ID: ID_COLORRAHMEN

Füllfarbe

Name der Variable, deren Grenzwertfarben die Hintergrund-/Füllfarbe des Elements beeinflussen sollen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BorderColor"

Hinweis: Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Achtung: Im Weltbild Übersichtsfenster haben Farbänderungen im Editor keine Auswirkung zur Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BorderColor"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BorderColor"


ID_COMPLEXITEM_BITOFFSET

Interne ID: ID_COMPLEXITEM_BITOFFSET

Bit Offset

Bitnummer des Strukturelements in der Struktur.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitOffset"


ID_COMPLEXITEM_HASREF

Interne ID: ID_COMPLEXITEM_HASREF

mit Datentyp verknüpft

Aktiv: Das Element ist mit dem zugrundeliegenden Datentyp verknüpft. Änderungen im zugrundeliegenden Datentyp wirken sich direkt auf das Element aus. Eigenschaften des Elements können nicht mehr editiert werden.
Inaktiv: Das Element ist nicht mehr mit dem zugrundeliegenden Datentyp verknüpft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HasRef"


ID_COMPLEXITEM_INDEX

Interne ID: ID_COMPLEXITEM_INDEX

Pos. in Struktur

Position der Variable in der Struktur.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ItemIndex"


ID_COMPLEXITEM_OFFSET

Interne ID: ID_COMPLEXITEM_OFFSET

Offset

Offset des Strukturelements in der Struktur.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset"


ID_DELUSER

Interne ID: ID_DELUSER

Löschen von Benutzern

Aktiv: Löschen eines Benutzers in der Runtime ist erlaubt.
Inaktiv: Benutzer können nur gelöscht markiert werden. Die Benutzer bleiben dabei in der Liste der Benutzer, sind allerdings für die Bedienung in der Runtime nicht mehr gültig (nach FDA Richtlinie).
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DelUser"


ID_DISABLEDBUTTONS

Interne ID: ID_DISABLEDBUTTONS

Gesperrte Buttons

Nur verfügbar, wenn die Eigenschaft Temp. Login aktiv inaktiv ist.
Definiert das Aussehen von Buttons, die aufgrund der Einstellungen der Bedienberechtigung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Verriegelte Buttons (Grafische Ausprägung) kombiniert.

Interne ID: ID_DISABLEDBUTTONS

Verriegelte Buttons

Definiert das Aussehen von Buttons zur Runtime, die aufgrund einer Verriegelung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Gesperrte Buttons (Benutzerverwaltung) kombiniert.

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Diese Eigenschaft wirkt unabhängig von der Eigenschaft Grafische Kennzeichnung aktiv. Ein grauer Button kann z.B. auch ein Schlosssymbol anzeigen.

Interne ID: ID_DISABLEDBUTTONS

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DisabledButtonStyle"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DisabledButtonStyle"

Interne ID: ID_DISABLEDBUTTONS

Temp. Login aktiv

Aktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, wird er zur Eingabe seiner Kennung und seines Passworts aufgefordert.
Inaktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, erhält er die Information, dass er dazu nicht berechtigt ist.
Default: aktiv.

Hinweis: Position und Größe der Login-Maske können in der zenon6.ini unter [Befehlsgabe] Position = definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DisabledButtonStyle"

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DisabledButtonStyle"


ID_DRV_KNOTEN

Interne ID: ID_DRV_KNOTEN

Treiber Anbindung

Treiber-spezifische Eigenschaften für die Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DriverConnection"


ID_DRV_STRAT_CREATE

Interne ID: ID_DRV_STRAT_CREATE

Bearbeiten

Nur verfügbar, wenn ein Prozesstreiber gewählt wurde, der Projektname gültig ist und nur ein einzelner Treiber ausgewählt wurde. Nicht verfügbar für Treiber für die Simulator Variable.

Klick öffnet das Simulationsprojekt in der zenon Logic Workbench. Existiert kein Simulationsprojekt für diesen Treiber, wird dieses automatisch erzeugt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CreateSimulPrj"


ID_DRV_STRAT_DEL

Interne ID: ID_DRV_STRAT_DEL

Löschen

Nur verfügbar, wenn ein Simulationsprojekt definiert ist und nur ein Treiber ausgewählt ist.

Löscht Simulationsprojekt nach Sicherheitsabfrage.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DelSimulPrj"


ID_DRV_STRAT_EV_PORT

Interne ID: ID_DRV_STRAT_EV_PORT

Event-Port

Nur verfügbar, wenn ein Simulationsprojekt erzeugt wurde.

TCP/IP Port für den spontanen Datenaustausch. Die Portnummer muss eindeutig, im Projekt frei und auf dem Rechner, auf dem der Treiber läuft, verfügbar sein. Beim Erzeugen des Simulationsprojektes wird automatisch eine eindeutige Portnummer vergeben.

Hinweis: Eine automatisch vergebene Portnummer ist nur für das jeweilige Projekt eindeutig. In multihierarchischen Projekten muss diese überprüft werden, um Kommunikationsfehler mit der zenon Logic Workbench/Runtime zu vermeiden.

Minimum: 6001 (bei automatischer Vergabe, manuell: empfohlen)

Maximum: 6998 (bei automatischer Vergabe, manuell: empfohlen)

Default: 6001

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SimulEvPort"


ID_DRV_STRAT_GRP

Interne ID: ID_DRV_STRAT_GRP

Treiber-Simulationsprojekt

Beinhaltet alle Eigenschaften für die Konfiguration der Simulation - programmiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_DRV_STRAT_NAME

Interne ID: ID_DRV_STRAT_NAME

Name

Name des Simulationsprojektes. Ist beim Start der zenon Logic Workbench kein gültiger Name vorhanden, wird automatisch ein Name vergeben. Dieser setzt sich zusammen aus dem Treibernamen und dessen Bezeichnung.

Bedingungen für gültige Namen:

- darf nicht leer sein

- muss im Projekt eindeutig sein

- darf nur für zenon Logic erlaubte Zeichen beinhalten; verboten sind: /\:*?<>!|"

Minimum: 1 Zeichen

Maximum: 15 Zeichen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SimulName"


ID_DRV_STRAT_PORT

Interne ID: ID_DRV_STRAT_PORT

Standard-Port

Nur verfügbar, wenn ein Simulationsprojekt erzeugt wurde.

TCP/IP Port für die Kommunikation mit der zenon Logic Workbench. Die Portnummer muss eindeutig, im Projekt frei und auf dem Rechner, auf dem der Treiber läuft, verfügbar sein. Beim Erzeugen des Simulationsprojektes wird automatisch eine eindeutige Portnummer vergeben.

Hinweis: Eine automatisch vergebene Portnummer ist nur für das jeweilige Projekt eindeutig. In multihierarchischen Projekten muss diese überprüft werden, um Kommunikationsfehler mit der zenon Logic Workbench/Runtime zu vermeiden.

Minimum: 6000 (bei automatischer Vergabe, manuell: empfohlen)

Maximum: 6999 (bei automatischer Vergabe, manuell: empfohlen)

Default: 6000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SimulPort"


ID_DYN_PROP_BLINKVAR

Interne ID: ID_DYN_PROP_BLINKVAR

Blinken von Grenzwert übernehmen

Variable, von deren Grenzwert(en) das Blinken für das Element übernommen werden soll. Klick auf die Schaltfläche ... öffnet den Variablenauswahldialog.

Im Gegensatz zum normalen Blinken blinkt das ganze Element und nicht nur der dargestellte Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BlinkVariable"


ID_DYN_PROP_GLOWEFFECT_BLINKVAR

Interne ID: ID_DYN_PROP_GLOWEFFECT_BLINKVAR

Variable für Blinken

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Interne ID: ID_DYN_PROP_GLOWEFFECT_BLINKVAR

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_DYN_PROP_GLOWEFFECT_BLINKVAR

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_BLINKVAR

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectBlinkVariable"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectBlinkVariable"

Interne ID: ID_DYN_PROP_GLOWEFFECT_BLINKVAR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_DYN_PROP_GLOWEFFECT_BLINKVAR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_BLINKVAR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectBlinkVariable"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectBlinkVariable"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectBlinkVariable"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectBlinkVariable"

Variable, von deren Grenzwert oder Grenzwerten das Blinken für den Glow-Effekt übernommen werden soll. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectBlinkVariable"


ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Variable für Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Einfärben

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Aktiv: Der Glow-Effekt für das Element wird eingefärbt. Damit wird der gesamte Glow Effekt mit nur einer definierten Farbe dargestellt. Die Farbe kann über die Eigenschaft Farbe oder eine in Eigenschaft Variable für Farbe definierte Variable eingestellt werden. Sind beide Eigenschaften aktiv, wird die Farbe aus Variable für Farbe verwendet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Bestimmt die Farbe des Glow Effekts. Klick auf Schaltfläche ... öffnet Farbpalette zur Auswahl der Farbe. Direkte Eingabe des Hex-Werts in Feld ist möglich.

Default: 0xFFFF90 (Gelb)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Inaktiv: Die Farben des Elementes werden für den Glow-Effekt verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_GLOWCOLOR_VARIABLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"

Name der Variablen, deren Grenzwertfarben die Glow-Farbe beeinflussen sollen. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden. Wenn keine Variable verknüpft ist, wird die in der Eigenschaft Farbe definierte Farbe verwendet.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectGlowColorVariable"


ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Sichtbarkeit von Grenzwert übernehmen

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Variable für Sichtbarkeit

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Name der Variablen, deren Wert die Sichtbarkeit des Glow-Effekts beeinflusst. Die Sichtbarkeit wird entweder aus den Grenzwerteigenschaften dieser Variablen übernommen (Eigenschaft Sichtbarkeit von Grenzwert übernehmen aktiv) oder durch den Wertbereich bestimmt, der bei den Eigenschaften Sichtbar von und Sichtbar bis definiert ist. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Sichtbar bis

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Definiert den Wert, bis zu dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: höchster möglicher Wert der inVariable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Sichtbar von

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Definiert den Wert, ab dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Hinweis: Wenn keine Variable verknüpft ist, ist der Glow-Effekt immer sichtbar.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Aktiv: Die Sichtbarkeit des Glow-Effekts wird von den Grenzwerteigenschaften der Variable beeinflusst.

Achtung: Zumindest bei einem Grenzwert dieser Variablen muss die Eigenschaft Unsichtbar aktiv sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_AUSGRENZWERT

Unsichtbar

Aktiv: Zustand wird im dynamischen Element "Zustandselement" nicht dargestellt oder Elemente werden nicht dargestellt, wenn ihre Sichtbarkeit über diese Variable gesteuert wird.
Inaktiv: Die Sichtbarkeit wird nicht durch die Grenzwertverletzung beeinflusst.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"

Inaktiv: Die Sichtbarkeit wird von den Eigenschaften des Elements beeinflusst.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFromLimit"


ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Sichtbar bis

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Sichtbarkeit von Grenzwert übernehmen

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein.

Aktiv: Die Sichtbarkeit des Glow-Effekts wird von den Grenzwerteigenschaften der Variable beeinflusst.

Achtung: Zumindest bei einem Grenzwert dieser Variablen muss die Eigenschaft Unsichtbar aktiv sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Unsichtbar

Aktiv: Zustand wird im dynamischen Element "Zustandselement" nicht dargestellt oder Elemente werden nicht dargestellt, wenn ihre Sichtbarkeit über diese Variable gesteuert wird.
Inaktiv: Die Sichtbarkeit wird nicht durch die Grenzwertverletzung beeinflusst.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Inaktiv: Die Sichtbarkeit wird von den Eigenschaften des Elements beeinflusst.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Variable für Sichtbarkeit

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Name der Variablen, deren Wert die Sichtbarkeit des Glow-Effekts beeinflusst. Die Sichtbarkeit wird entweder aus den Grenzwerteigenschaften dieser Variablen übernommen (Eigenschaft Sichtbarkeit von Grenzwert übernehmen aktiv) oder durch den Wertbereich bestimmt, der bei den Eigenschaften Sichtbar von und Sichtbar bis definiert ist. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Sichtbar von

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Definiert den Wert, ab dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Hinweis: Wenn keine Variable verknüpft ist, ist der Glow-Effekt immer sichtbar.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_BIS

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"

Definiert den Wert, bis zu dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: höchster möglicher Wert der inVariable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityTo"


ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Variable für Sichtbarkeit

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Name der Variablen, deren Wert die Sichtbarkeit des Glow-Effekts beeinflusst. Die Sichtbarkeit wird entweder aus den Grenzwerteigenschaften dieser Variablen übernommen (Eigenschaft Sichtbarkeit von Grenzwert übernehmen aktiv) oder durch den Wertbereich bestimmt, der bei den Eigenschaften Sichtbar von und Sichtbar bis definiert ist. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Sichtbar bis

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Definiert den Wert, bis zu dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: höchster möglicher Wert der inVariable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Sichtbar von

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Definiert den Wert, ab dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Sichtbarkeit von Grenzwert übernehmen

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein.

Aktiv: Die Sichtbarkeit des Glow-Effekts wird von den Grenzwerteigenschaften der Variable beeinflusst.

Achtung: Zumindest bei einem Grenzwert dieser Variablen muss die Eigenschaft Unsichtbar aktiv sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VARIABLE

Unsichtbar

Aktiv: Zustand wird im dynamischen Element "Zustandselement" nicht dargestellt oder Elemente werden nicht dargestellt, wenn ihre Sichtbarkeit über diese Variable gesteuert wird.
Inaktiv: Die Sichtbarkeit wird nicht durch die Grenzwertverletzung beeinflusst.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Inaktiv: Die Sichtbarkeit wird von den Eigenschaften des Elements beeinflusst.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"

Hinweis: Wenn keine Variable verknüpft ist, ist der Glow-Effekt immer sichtbar.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityVariable"


ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Sichtbar von

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Sichtbarkeit von Grenzwert übernehmen

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein.

Aktiv: Die Sichtbarkeit des Glow-Effekts wird von den Grenzwerteigenschaften der Variable beeinflusst.

Achtung: Zumindest bei einem Grenzwert dieser Variablen muss die Eigenschaft Unsichtbar aktiv sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Unsichtbar

Aktiv: Zustand wird im dynamischen Element "Zustandselement" nicht dargestellt oder Elemente werden nicht dargestellt, wenn ihre Sichtbarkeit über diese Variable gesteuert wird.
Inaktiv: Die Sichtbarkeit wird nicht durch die Grenzwertverletzung beeinflusst.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Inaktiv: Die Sichtbarkeit wird von den Eigenschaften des Elements beeinflusst.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Variable für Sichtbarkeit

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Name der Variablen, deren Wert die Sichtbarkeit des Glow-Effekts beeinflusst. Die Sichtbarkeit wird entweder aus den Grenzwerteigenschaften dieser Variablen übernommen (Eigenschaft Sichtbarkeit von Grenzwert übernehmen aktiv) oder durch den Wertbereich bestimmt, der bei den Eigenschaften Sichtbar von und Sichtbar bis definiert ist. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Sichtbar bis

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in der Eigenschaft Variable für Sichtbarkeit eine Variable definiert sein und die Eigenschaft Sichtbarkeit von Grenzwert übernehmen muss inaktiv sein.

Definiert den Wert, bis zu dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: höchster möglicher Wert der inVariable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Hinweis: Wenn keine Variable verknüpft ist, ist der Glow-Effekt immer sichtbar.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_SICHTBARKEIT_VON

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"

Definiert den Wert, ab dem der Glow-Effekt sichtbar ist.
Minimum: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Maximum: höchster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variablen.
Default: niedrigster möglicher Wert der in Variable für Sichtbarkeit verknüpften Variable.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectVisibilityFrom"


ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Blinkfarbe von Grenzwert übernehmen

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in Eigenschaft Variable für Blinken eien Variable definiert sein.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Variable für Blinken

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Variable, von deren Grenzwert oder Grenzwerten das Blinken für den Glow-Effekt übernommen werden soll. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Aktiv: Übernimmt Farbe für den Glow-Effekt für das Blinken aus dem aktiven Grenzwert der in Eigenschaft Blinkfarbe aus Grenzwert definierten Variablen. Diese Eigenschaft ist unabhängig von der Eigenschaft Einfärben. Der Glow-Effekt wechselt beim Blinken nicht zu unsichtbar, sondern zum aktiv eingestellten Glow Effekt.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Einfärben

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Aktiv: Der Glow-Effekt für das Element wird eingefärbt. Damit wird der gesamte Glow Effekt mit nur einer definierten Farbe dargestellt. Die Farbe kann über die Eigenschaft Farbe oder eine in Eigenschaft Variable für Farbe definierte Variable eingestellt werden. Sind beide Eigenschaften aktiv, wird die Farbe aus Variable für Farbe verwendet.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Variable für Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Name der Variablen, deren Grenzwertfarben die Glow-Farbe beeinflussen sollen. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden. Wenn keine Variable verknüpft ist, wird die in der Eigenschaft Farbe definierte Farbe verwendet.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Bestimmt die Farbe des Glow Effekts. Klick auf Schaltfläche ... öffnet Farbpalette zur Auswahl der Farbe. Direkte Eingabe des Hex-Werts in Feld ist möglich.

Default: 0xFFFF90 (Gelb)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Inaktiv: Die Farben des Elementes werden für den Glow-Effekt verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Blinkfarbe aus Grenzwert

Aktiv: Übernimmt Hintergrundfarbe des Blinkens aus dem aktiven Grenzwert der Variablen für Blinken von Grenzwert übernehmen. Element wechselt beim Blinken nicht zu unsichtbar, sondern zur aktiven Hintergrundfarbe.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Blinken von Grenzwert übernehmen

Variable, von deren Grenzwert(en) das Blinken für das Element übernommen werden soll. Klick auf die Schaltfläche ... öffnet den Variablenauswahldialog.

Im Gegensatz zum normalen Blinken blinkt das ganze Element und nicht nur der dargestellte Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Default: inaktiv

Hinweis: Diese Farbe wird nicht berücksichtigt, wenn die Hintergrundfarbe Transparent konfiguriert ist.

Interne ID: ID_DYN_PROP_GLOWEFFECT_USEBLINKCOLOR

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseBlinkColor"


ID_DYN_PROP_USEBLINKCOLOR

Interne ID: ID_DYN_PROP_USEBLINKCOLOR

Blinkfarbe aus Grenzwert

Aktiv: Übernimmt Hintergrundfarbe des Blinkens aus dem aktiven Grenzwert der Variablen für Blinken von Grenzwert übernehmen. Element wechselt beim Blinken nicht zu unsichtbar, sondern zur aktiven Hintergrundfarbe.

Interne ID: ID_DYN_PROP_USEBLINKCOLOR

Blinken von Grenzwert übernehmen

Variable, von deren Grenzwert(en) das Blinken für das Element übernommen werden soll. Klick auf die Schaltfläche ... öffnet den Variablenauswahldialog.

Im Gegensatz zum normalen Blinken blinkt das ganze Element und nicht nur der dargestellte Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseBlinkColor"

Default: inaktiv

Hinweis: Diese Farbe wird nicht berücksichtigt, wenn die Hintergrundfarbe Transparent konfiguriert ist.

Interne ID: ID_DYN_PROP_USEBLINKCOLOR

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseBlinkColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseBlinkColor"


ID_DYNPICTURE_DONTRESIZEELEMS

Interne ID: ID_DYNPICTURE_DONTRESIZEELEMS

Elemente nicht an Bildschirmauflösung anpassen

Aktiv: Die im Bild enthaltenen Elemente werden zur Runtime nicht automatisch an die Bildschirmauflösung angepasst, sondern behalten die im Editor projektierte Position und Größe bei.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DontResizeElements"


ID_DYNPICTURE_MULTITOUCH

Interne ID: ID_DYNPICTURE_MULTITOUCH

Multitouch für Zoomen und Scrollen

Aktiv: Für Zoomen und Scrolling im Weltbild können Multitouch-Gesten verwendet werden, ohne dass diese in VSTA programmiert werden müssen. Ist diese Eigenschaft aktiv, werden keine VBA/VSTA Events für Multitouch-Gesten erzeugt.

Nur verfügbar, wenn die Eigenschaft Multitouch aktiv aktiviert wurde und Größe aus Schablone nicht aktiv ist.

Interne ID: ID_DYNPICTURE_MULTITOUCH

Größe aus Schablone

Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
Default: aktiv.

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MultiTouch"

Interne ID: ID_DYNPICTURE_MULTITOUCH

Multitouch aktiv

Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MultiTouch"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MultiTouch"


ID_DYNPICTURE_PROP1

Interne ID: ID_DYNPICTURE_PROP1

Dateiname

Dateiname des Bildes.
Der Dateiname wird vom System automatisch generiert und kann nicht geändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_DYNPICTURE_PROP2

Interne ID: ID_DYNPICTURE_PROP2

Schablone

Änderung der zugeordneten Schablone, ohne dass die Bildelemente auf die neue Bildgröße umgerechnet werden (strecken oder stauchen).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Template"


ID_DYNPICTURE_PROP3

Interne ID: ID_DYNPICTURE_PROP3

Bildtyp

Standard: Bildtyp für die Erstellung von Prozessbildern. Alle vektoriellen and dynamischen Elemente können verwendet werden.
Spezielle Bildtypen: Bilder, die nicht vom Bildtyp "Standard" sind, müssen nur einmal erstellt werden und können über spezielle Filtereinstellungen der Funktion Bildumschaltung jeweils mit verschiedenen Daten geöffnet werden. Sobald ein spezieller Bildtyp ausgewählt wurde, stehen im Menü Kontrollelemente die entsprechenden Bedienelemente für den Bildtyp zur Verfügung.

Achtung: Sobald der Bildtyp von Standard auf einen speziellen Bildtyp geändert wurde, ist er fixiert und kann nicht weiter geändert werden.

Default: Standard

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Type"


ID_DYNPICTURE_PROP4

Interne ID: ID_DYNPICTURE_PROP4

Hintergrundfarbe

Definiert die Hintergrundfarbe des Bildes. Die Farbe kann als Hexadezimalwert direkt in das Feld eingetragen oder nach Klick auf die Schaltfläche ... ausgewählt werden.
Default: Farbe aus der Schablone.
Hinweis: Farbe aus der Schablone wird als Kopie übernommen und nicht verknüpft. Spätere Änderungen der Farbe in der Schablone haben keine Auswirkungen auf bestehende Bilder, sondern nur auf neu erstellte.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundColor"


ID_DYNPICTURE_PROP5

Interne ID: ID_DYNPICTURE_PROP5

X von

X-Koordinate des linken oberen Eckpunktes des Bildes (in logischen Einheiten). Diese Eigenschaft dient nur der Information und kann nicht geändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinX"


ID_DYNPICTURE_PROP6

Interne ID: ID_DYNPICTURE_PROP6

X bis

X-Koordinate des rechten unteren Eckpunktes des Bildes (in logischen Einheiten). Diese Eigenschaft dient nur der Information und kann nicht geändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxX"


ID_DYNPICTURE_PROP7

Interne ID: ID_DYNPICTURE_PROP7

Y von

Y-Koordinate des linken oberen Eckpunktes des Bildes (in logischen Einheiten). Diese Eigenschaft dient nur der Information und kann nicht geändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinY"


ID_DYNPICTURE_PROP8

Interne ID: ID_DYNPICTURE_PROP8

Y bis

Y-Koordinate des rechten unteren Eckpunktes des Bildes (in logischen Einheiten). Diese Eigenschaft dient nur der Information und kann nicht geändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxY"


ID_DYNPICTURE_PROP9

Interne ID: ID_DYNPICTURE_PROP9

Höhe [Pixel]

Nur verfügbar, wenn die Eigenschaft Größe aus Schablone inaktiv ist.
Höhe des Bildes in Pixel.

Interne ID: ID_DYNPICTURE_PROP9

Größe aus Schablone

Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
Default: aktiv.

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Height"

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Height"


ID_DYNPICTURE_PROP10

Interne ID: ID_DYNPICTURE_PROP10

Breite [Pixel]

Nur verfügbar, wenn die Eigenschaft Größe aus Schablone inaktiv ist.
Breite des Bildes in Pixel.

Interne ID: ID_DYNPICTURE_PROP10

Größe aus Schablone

Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
Default: aktiv.

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Width"

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Width"


ID_DYNPICTURE_PROP11

Interne ID: ID_DYNPICTURE_PROP11

Start-Funktion

Funktion, die beim Öffnen des Bildes in der Runtime automatisch ausgeführt werden soll.
Öffnet den Funktionsauswahldialog.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StartFunction"


ID_DYNPICTURE_PROP12

Interne ID: ID_DYNPICTURE_PROP12

Ende-Funktion

Funktion, die beim Schließen des Bildes in der Runtime automatisch ausgeführt werden soll.
Öffnet den Funktionaauswahldialog.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

ACHTUNG: Das Öffnen eines anderen Bildes derselben Schablone schließt dieses Bild automatisch und führt somit auch die verknüpfte Funktion aus.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EndFunction"


ID_DYNPICTURE_PROP13

Interne ID: ID_DYNPICTURE_PROP13

Größe aus Schablone

Aktiv: Die Größe und die Position des Bildes werden von der verknüpften Schablone definiert.
Inaktiv: Die Breite und die Höhe des Bildes lassen sich größer als die Schablone definieren. Die Position der linken oberen Ecke wird immer noch durch die Schablone definiert.
Default: aktiv.

Hinweis: Größenangaben kleiner als die Schablone werden ignoriert. Werden Bilder größer als die Schablone definiert, werden Sie zum Weltbild und benötigen zur Navigation zusätzlich ein Bild vom Typ Weltbild-Übersicht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SizeFromTemplate"


ID_DYNPICTURE_PROP14

Interne ID: ID_DYNPICTURE_PROP14

Modaler Dialog

Aktiv: Solange das Bild in der Runtime geöffnet ist, können Elemente in einem anderen Bild nicht bedient werden (z.B für den Bildtyp “Login”). Bedient werden können allerdings Bilder, die aus dem modalen Bild heraus geöffnet wurden.
Inaktiv: Andere Bilder können wie gewohnt bedient werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Modal"


ID_DYNPICTURE_PROP15

Interne ID: ID_DYNPICTURE_PROP15

Sichtbar unter CE

Aktiv: Das Bild wird auch unter Windows CE dargestellt.
Inaktiv: Das Bild wird unter Windows CE nicht dargestellt.
Default: aktiv.

Damit kann man in Netzwerken mit PCs und CE-Geräten auf den PCs Funktionalitäten nutzen, die von Windows CE nicht unterstützt werden, ohne dass es auf den CE-Geräten zu Problemen kommt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowInCE"


ID_DYNPICTURE_PROP16

Interne ID: ID_DYNPICTURE_PROP16

Grafikdatei

Auswahl der Hintergrundgrafik die im Bild an hinterster Ebene angezeigt wird.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPic"


ID_DYNPICTURE_PROP17

Interne ID: ID_DYNPICTURE_PROP17

Ausrichtung

Nur verfügbar, nachdem eine Grafikdatei ausgewählt wurde.
Darstellungsart der Hintergrundgrafik im Bild:
normal: original Größe in der linken oberen Ecke positioniert.
zentriert: original Göße zentriert in der Bildmitte zentriert.
gestreckt: formatfüllend auf Bildgröße gestreckt.
gekachelt: original Größe in Kacheln nebeneinander.

Interne ID: ID_DYNPICTURE_PROP17

Grafikdatei

Auswahl der Hintergrundgrafik die im Bild an hinterster Ebene angezeigt wird.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPicStyle"

Mehr im online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPicStyle"


ID_DYNPICTURE_PROP18

Interne ID: ID_DYNPICTURE_PROP18

Rahmen-Style

Nur verfügbar, wenn ein Rahmen in der Definition der Schablone ausgewählt:
Rahmenart des Bildes.
Dicker Rahmen: Ein dicker Rahmen wird um das Bild dargestellt. Die Größe des Bildes kann in der Runtime verändert werden.
Dünner Rahmen: Ein dünner Rahmen wird um das Bild dargestellt.
Kein Rahmen: Kein Rahmen wird um das Bild dargestellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BorderStyle"


ID_DYNPICTURE_PROP19

Interne ID: ID_DYNPICTURE_PROP19

Titel anzeigen

Nur verfügbar, wenn ein Rahmen für das Bild ausgewählt ist:
Aktiv: Windows-Titelleiste für dieses Bild verwenden. Das Bild kann in der Runtime verschoben werden.
Inaktiv: Keine Titelleiste verwenden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowTitle"


ID_DYNPICTURE_PROP20

Interne ID: ID_DYNPICTURE_PROP20

Bild aktiv Variable

Die hier verknüpfte Bitvariable wird auf 1 gesetzt, wenn das Bild geöffnet wird; sie wird auf 0 zurückgesetzt, wenn das Bild geschlossen wird.
Öffnet den Variablesauswahldialog gefiltert auf Bit-Variablen.

ACHTUNG: Das Öffnen eines anderen Bildes derselben Schablone schließt dieses Bild automatisch und führt somit die verknüpfte Funktion aus.

Beispiel: Die Hintergrundfarbe von Buttons in einer Bedienleiste sollte anzeigen, welches Bild gerade geöffnet ist. Die Bit-Variables, die zu den einzelnen Bildern verknüpft sind, haben alle die Grenzwertfarbe grün für den Wert 1 und die Grenzwertfarbe weiß für den Wert 0. Diese Bit-Variablen werden zu der dynamischen Hintergrundfarbe der entsprechenden Buttons verknüpft. Der Button, der das gerade geöffnete Bild aufschaltet, hat also immer die Hintergrundfarbe grün und alle anderen sind weiß.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PicActivVar"


ID_DYNPICTURE_PROP21

Interne ID: ID_DYNPICTURE_PROP21

Hintergrundfarbe

Definiert Hintergrundfarbe des Symbols. Klicken Sie zum Öffnen der Farbpalette auf die Schaltfläche oder geben Sie die Farbe in RGB als Hex-Werte ein.

Achtung: Die hier festgelegte Hintergrundfarbe gilt für alle Symbole und dient ausschließlich als Hintergrundfarbe des Symboleditors.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundColor"


ID_DYNPICTURE_PROP22

Interne ID: ID_DYNPICTURE_PROP22

Höhe [Pixel]

Definiert die Symbolhöhe in Pixel. Die eingestellte Höhe dient als original Höhe für das Symbol, wenn Sie es in ein Bild ziehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Height"


ID_DYNPICTURE_PROP23

Interne ID: ID_DYNPICTURE_PROP23

Breite [Pixel]

Definiert Symbolbreite in Pixel. Die eingestellte Breite dient als original Breite für das Symbol, wenn Sie es in ein Bild ziehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Width"


ID_DYNPICTURE_PROP24

Interne ID: ID_DYNPICTURE_PROP24

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AutoKBLayout"


ID_DYNPICTURE_PROP_GRP0

Interne ID: ID_DYNPICTURE_PROP_GRP0

Allgemein

Allgemeine Eigenschaften des Bildes.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Picture"


ID_DYNPICTURE_PROP_GRP1

Interne ID: ID_DYNPICTURE_PROP_GRP1

Größe

Eigenschaften für die Größe und die Position des Bildes, die aus der verknüpften Schablone übernommen werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Size"


ID_DYNPICTURE_PROP_GRP2

Interne ID: ID_DYNPICTURE_PROP_GRP2

Fensterstil

Eigenschaften für die äußere Erscheinung des Bildes.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Representation"


ID_DYNPICTURE_PROP_GRP3

Interne ID: ID_DYNPICTURE_PROP_GRP3

Ausführung

Mit dem Bild verknüpfte Funktionen und Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Functions"


ID_DYNPICTURE_PROP_GRP4

Interne ID: ID_DYNPICTURE_PROP_GRP4

Hintergrundgrafik

In jedem Bild kann eine Grafikdatei als Hintergrund angezeigt werden. Diese Grafik ist in der hintersten Sichtbarkeitsebene positioniert und wird von allen anderen Elementen des Bildes überdeckt. Zur Positionierung stehen Möglichkeiten wie zentriert oder gekachelt zur Verfügung. Ein freies verschieben ist nicht möglich.

Alternativ kann auch ein Button mit einer Grafikdatei ohne verknüpfte Funktion zur Darstellung einer frei positionierbaren Grafikdatei verwendet werden

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Background"


ID_DYNPICTURE_PROP_GRP5

Interne ID: ID_DYNPICTURE_PROP_GRP5

Allgemein

Eigenschaften für die Größe und Hintergrundfarbe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Symbols"


ID_DYNPICTURE_SCHAB_HIGHLIGHT_ALPHA

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_ALPHA

Umgebungstransparenz

Nur verfügbar, wenn die Eigenschaft Schablone hervorheben aktiviert wurde.

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_ALPHA

Schablone hervorheben

Nur verfügbar, wenn die Eigenschaft Modaler Dialog aktiviert wurde.

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_ALPHA

Modaler Dialog

Aktiv: Solange das Bild in der Runtime geöffnet ist, können Elemente in einem anderen Bild nicht bedient werden (z.B für den Bildtyp “Login”). Bedient werden können allerdings Bilder, die aus dem modalen Bild heraus geöffnet wurden.
Inaktiv: Andere Bilder können wie gewohnt bedient werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmbientAlpha"

Aktiv: Die Schablone, auf der das Bild beruht, wird hervorgehoben. Dabei wird der gesamte Bereich außerhalb der Schablone mit einer eingestellten Farbe und Transparenz eingefärbt. Der Bereich der hervorgehobenen Schablone bleibt von der Einfärbung unberührt. Es darf immer nur ein Bild mit dieser Eigenschaft gleichzeitig aufgeschaltet werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmbientAlpha"

Bestimmt die Transparenz der Umgebungsfarbe der Schablone, auf der das Bild beruht. Klick auf Schaltfläche ... öffnet Schieberegler für Definition der Transparenz.

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_ALPHA

Umgebungsfarbe

Nur verfügbar, wenn die Eigenschaft Schablone hervorheben aktiviert wurde.

Bestimmt die Umgebungsfarbe der Schablone, auf der das Bild beruht. Klick auf Schaltfläche ... öffnet Auswahldialog für Farbe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmbientAlpha"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmbientAlpha"


ID_DYNPICTURE_SCHAB_HIGHLIGHT_COLOR

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_COLOR

Umgebungsfarbe

Nur verfügbar, wenn die Eigenschaft Schablone hervorheben aktiviert wurde.

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_COLOR

Schablone hervorheben

Nur verfügbar, wenn die Eigenschaft Modaler Dialog aktiviert wurde.

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_COLOR

Modaler Dialog

Aktiv: Solange das Bild in der Runtime geöffnet ist, können Elemente in einem anderen Bild nicht bedient werden (z.B für den Bildtyp “Login”). Bedient werden können allerdings Bilder, die aus dem modalen Bild heraus geöffnet wurden.
Inaktiv: Andere Bilder können wie gewohnt bedient werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmbientColor"

Aktiv: Die Schablone, auf der das Bild beruht, wird hervorgehoben. Dabei wird der gesamte Bereich außerhalb der Schablone mit einer eingestellten Farbe und Transparenz eingefärbt. Der Bereich der hervorgehobenen Schablone bleibt von der Einfärbung unberührt. Es darf immer nur ein Bild mit dieser Eigenschaft gleichzeitig aufgeschaltet werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmbientColor"

Bestimmt die Umgebungsfarbe der Schablone, auf der das Bild beruht. Klick auf Schaltfläche ... öffnet Auswahldialog für Farbe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AmbientColor"


ID_DYNPICTURE_SCHAB_HIGHLIGHT_TYPE

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_TYPE

Schablone hervorheben

Nur verfügbar, wenn die Eigenschaft Modaler Dialog aktiviert wurde.

Interne ID: ID_DYNPICTURE_SCHAB_HIGHLIGHT_TYPE

Modaler Dialog

Aktiv: Solange das Bild in der Runtime geöffnet ist, können Elemente in einem anderen Bild nicht bedient werden (z.B für den Bildtyp “Login”). Bedient werden können allerdings Bilder, die aus dem modalen Bild heraus geöffnet wurden.
Inaktiv: Andere Bilder können wie gewohnt bedient werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Highlight"

Aktiv: Die Schablone, auf der das Bild beruht, wird hervorgehoben. Dabei wird der gesamte Bereich außerhalb der Schablone mit einer eingestellten Farbe und Transparenz eingefärbt. Der Bereich der hervorgehobenen Schablone bleibt von der Einfärbung unberührt. Es darf immer nur ein Bild mit dieser Eigenschaft gleichzeitig aufgeschaltet werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Highlight"


ID_EDITSIGNATURE

Interne ID: ID_EDITSIGNATURE

Signaturtext editierbar

Aktiv: In der Runtime wird ein Dialog zum Editieren des Signaturtextes geöffnet.
Inaktiv: Der Signaturtext kann in der Runtime nicht geändert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EditSignature"


ID_ELE_BITMAP_DOWN

Interne ID: ID_ELE_BITMAP_DOWN

Grafikdatei bei gedrückt

Bild, das auf dem Button im gedrückten Zustand dargestellt werden soll (*.bmp, *.wmf, *.jpg, *.gif). Klick auf die Schaltfläche ... öffnet den Dateiauswahldialog.
Achtung: Bilder müssen im Projektmanager im Knoten Dateien/Grafiken bereits vorhanden sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FileNameDown"


ID_ELE_CORNER_ALL_X

Interne ID: ID_ELE_CORNER_ALL_X

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Interne ID: ID_ELE_CORNER_ALL_X

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_ALL_X

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_X"

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_X"


ID_ELE_CORNER_ALL_Y

Interne ID: ID_ELE_CORNER_ALL_Y

Alle Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Interne ID: ID_ELE_CORNER_ALL_Y

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_ALL_Y

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_Y"

Interne ID: ID_ELE_CORNER_ALL_Y

Proportional

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht gesetzt ist.

Aktiv: Für die Abrundung der Ecken kann nur der X-Wert eingegeben werden. Der Y-Wert ist immer gleich.

Der bei Alle X [%] eingegebene Prozentwert bezieht sich auf die kürzere Seite (Breite oder Höhe) des Elements.

Interne ID: ID_ELE_CORNER_ALL_Y

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_Y"

Inaktiv: Die X- und Y-Werte können frei eingegeben werden. Der X-Wert bezieht auf die Breite des Elementes, der Y-Wert auf die Höhe.

Default: aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_Y"

Definiert den Rundungswert der Y-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerAll_Y"


ID_ELE_CORNER_LEFTBOTTOM_X

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_X

Links/Unten X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist und die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_X

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_X

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_X

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_X"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_X"

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_X

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_X

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_X"

Definiert den Rundungswert der X-Achse für den linken unteren Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle X [%] wird verwendet.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_X

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_X"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_X"


ID_ELE_CORNER_LEFTBOTTOM_Y

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Links/Unten Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist sowie die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Proportional

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht gesetzt ist.

Aktiv: Für die Abrundung der Ecken kann nur der X-Wert eingegeben werden. Der Y-Wert ist immer gleich.

Der bei Alle X [%] eingegebene Prozentwert bezieht sich auf die kürzere Seite (Breite oder Höhe) des Elements.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

Inaktiv: Die X- und Y-Werte können frei eingegeben werden. Der X-Wert bezieht auf die Breite des Elementes, der Y-Wert auf die Höhe.

Default: aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

Definiert den Rundungswert der Y-Achse für den linken unteren Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle Y [%] wird verwendet.

Interne ID: ID_ELE_CORNER_LEFTBOTTOM_Y

Alle Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der Y-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftBottom_Y"


ID_ELE_CORNER_LEFTTOP_X

Interne ID: ID_ELE_CORNER_LEFTTOP_X

Links/Oben X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist und die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_CORNER_LEFTTOP_X

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_CORNER_LEFTTOP_X

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_CORNER_LEFTTOP_X

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_X"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_X"

Interne ID: ID_ELE_CORNER_LEFTTOP_X

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_LEFTTOP_X

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_X"

Definiert den Rundungswert der X-Achse für den linken oberen Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle X [%] wird verwendet.

Interne ID: ID_ELE_CORNER_LEFTTOP_X

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_X"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_X"


ID_ELE_CORNER_LEFTTOP_Y

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Links/Oben Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist sowie die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Proportional

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht gesetzt ist.

Aktiv: Für die Abrundung der Ecken kann nur der X-Wert eingegeben werden. Der Y-Wert ist immer gleich.

Der bei Alle X [%] eingegebene Prozentwert bezieht sich auf die kürzere Seite (Breite oder Höhe) des Elements.

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

Inaktiv: Die X- und Y-Werte können frei eingegeben werden. Der X-Wert bezieht auf die Breite des Elementes, der Y-Wert auf die Höhe.

Default: aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

Definiert den Rundungswert der Y-Achse für den linken oberen Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle Y [%] wird verwendet.

Interne ID: ID_ELE_CORNER_LEFTTOP_Y

Alle Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der Y-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerLeftTop_Y"


ID_ELE_CORNER_PROPORTIONAL

Interne ID: ID_ELE_CORNER_PROPORTIONAL

Proportional

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht gesetzt ist.

Interne ID: ID_ELE_CORNER_PROPORTIONAL

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_PROPORTIONAL

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerProportional"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerProportional"

Aktiv: Für die Abrundung der Ecken kann nur der X-Wert eingegeben werden. Der Y-Wert ist immer gleich.

Der bei Alle X [%] eingegebene Prozentwert bezieht sich auf die kürzere Seite (Breite oder Höhe) des Elements.

Interne ID: ID_ELE_CORNER_PROPORTIONAL

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerProportional"

Inaktiv: Die X- und Y-Werte können frei eingegeben werden. Der X-Wert bezieht auf die Breite des Elementes, der Y-Wert auf die Höhe.

Default: aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerProportional"


ID_ELE_CORNER_RIGHTBOTTOM_X

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_X

Rechts/Unten X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_X

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_X

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_X"

Definiert den Rundungswert der X-Achse für den rechten unteren Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle X [%] wird verwendet.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_X

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_X"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_X"


ID_ELE_CORNER_RIGHTBOTTOM_Y

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Rechts/Unten Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist. und die Eigenschaft Über Helligkeitswerte nicht gesetzt ist sowie die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Proportional

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht gesetzt ist.

Aktiv: Für die Abrundung der Ecken kann nur der X-Wert eingegeben werden. Der Y-Wert ist immer gleich.

Der bei Alle X [%] eingegebene Prozentwert bezieht sich auf die kürzere Seite (Breite oder Höhe) des Elements.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

Inaktiv: Die X- und Y-Werte können frei eingegeben werden. Der X-Wert bezieht auf die Breite des Elementes, der Y-Wert auf die Höhe.

Default: aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

Definiert den Rundungswert der Y-Achse für den rechten unteren Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle Y [%] wird verwendet.

Interne ID: ID_ELE_CORNER_RIGHTBOTTOM_Y

Alle Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der Y-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightBottom_Y"


ID_ELE_CORNER_RIGHTTOP_X

Interne ID: ID_ELE_CORNER_RIGHTTOP_X

Rechts/Oben X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist und die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_CORNER_RIGHTTOP_X

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_CORNER_RIGHTTOP_X

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_CORNER_RIGHTTOP_X

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_X"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_X"

Interne ID: ID_ELE_CORNER_RIGHTTOP_X

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_RIGHTTOP_X

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_X"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_X"

Definiert den Rundungswert der X-Achse für den rechten oberen Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle X [%] wird verwendet.

Interne ID: ID_ELE_CORNER_RIGHTTOP_X

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_X"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_X"


ID_ELE_CORNER_RIGHTTOP_Y

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Rechts/Oben Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist sowie die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Proportional

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht gesetzt ist.

Aktiv: Für die Abrundung der Ecken kann nur der X-Wert eingegeben werden. Der Y-Wert ist immer gleich.

Der bei Alle X [%] eingegebene Prozentwert bezieht sich auf die kürzere Seite (Breite oder Höhe) des Elements.

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Alle X [%]

Nur verfügbar wenn die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der X-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

Inaktiv: Die X- und Y-Werte können frei eingegeben werden. Der X-Wert bezieht auf die Breite des Elementes, der Y-Wert auf die Höhe.

Default: aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

Definiert den Rundungswert der Y-Achse für den rechten oberen Eckpunkt. Klick auf die Schaltfläche ... öffnet einen Schieberegler zur Einstellung der Rundung. Mögliche Werte:

-1: Die Einstellung aus Alle Y [%] wird verwendet.

Interne ID: ID_ELE_CORNER_RIGHTTOP_Y

Alle Y [%]

Nur verfügbar, wenn die Eigenschaft Proportional aktiv ist und die Eigenschaft Über Helligkeitswerte nicht aktiv ist.

Definiert den Rundungswert der Y-Achse in Prozent für alle Eckpunkte. Dieser Wert wird für alle Eckpunkte verwendet, deren Wert -1 beträgt. Einzelne Eckpunkte lassen sich also auch unabhängig definieren.

Wird der Rundungswert geändert, werden alle Eckpunkt automatisch auf den Wert -1 gesetzt. Damit werden alle Eckpunkte wieder auf den hier vorgegebenen Wert zurückgesetzt.

Wertbereich: 0 % bis 100 %.

Default: 20

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"

0 bis 100: Rundung in Prozent.

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CornerRightTop_Y"


ID_ELE_DRAGBEGIN

Interne ID: ID_ELE_DRAGBEGIN

DragBegin

VBA Makro, das ausgeführt werden soll, wenn das Ziehen beginnt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DragBegin"


ID_ELE_DRAGDROP

Interne ID: ID_ELE_DRAGDROP

DragDrop

VBA Makro, das ausgeführt werden soll, wenn die Maustaste losgelassen wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DragDrop"


ID_ELE_DRAGOVER

Interne ID: ID_ELE_DRAGOVER

DragOver

VBA Makro, das ausgeführt werden soll, wenn der Cursor über das Element bewegt wird, während die linke Taste gedrückt ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DragOver"


ID_ELE_EMBEDDED_FONT

Interne ID: ID_ELE_EMBEDDED_FONT

Schrift

Auswahl der Schrift, mit der die Darstellung erfolgt.

ACHTUNG: Diese Option funktioniert nur bei eingebetteten Schriften.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Font"


ID_ELE_LAYER

Interne ID: ID_ELE_LAYER

Sichtbarkeitsebene

Wählen Sie in der Dropdown Liste eine der 16 Sichtbarkeitsebenen (von 0 bis 15) aus. Mit der Symbolleiste Sichtbarkeitsebenen bestimmen Sie, welche Ebenen im Editor angezeigt oder ausgeblendet werden. Dadurch ist gewährleistet, dass auch komplexe Bilder übersichtlich projektiert werden können. Die Ebenen können individuell genutzt werden. Die Ebenen haben keinen Einfluss auf die Vordergrund-/Hintergrundinformation und keinen Einfluss auf die Darstellung in der Runtime.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Layer"


ID_ELE_LIGHTNING

Interne ID: ID_ELE_LIGHTNING

Farbverlauf

Nur verfügbar, wenn Füllmuster auf Farbverlauf gesetzt wurde.

Interne ID: ID_ELE_LIGHTNING

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_LIGHTNING

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Lightning"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Lightning"

Definiert den Farbverlauf für Vektorelemente.

linear: gleichmäßiger Verlauf
punktuell: Verlauf von den Rändern zum Zentrum

punktuell mit Kanten: Verlauf von den Rändern zum Zentrum mit Kantenbildung

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Lightning"


ID_ELE_LINECOLOR

Interne ID: ID_ELE_LINECOLOR

Linienfarbe

Definiert die Linienfarbe des Elements. Die Farbe kann direkt als Hexadezimalwert eingegeben oder nach Klick auf die Schaltfläche ... gewählt werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineColorEx"


ID_ELE_NUM_BASE_ON

Interne ID: ID_ELE_NUM_BASE_ON

Zahlenbasis anzeigen

Steht nur zur Verfügung, wenn Sie bei der Eigenschaft Zahlenbasis für Anzeige Binär, Hexadezimal oder Oktal selektiert haben.

Interne ID: ID_ELE_NUM_BASE_ON

Zahlenbasis für Anzeige

Stellen Sie hier das Zahlensystem für die Darstellung der Werte ein. Folgende Zahlensysteme stehen Ihnen zur Verfügung:
Binär: Binäre Darstellung. Dieses Format wird durch ein "b" hinter dem Wert angezeigt.
Dezimal: Dezimale Darstellung.
Exponential: Dezimale Darstellung in exponentieller Schreibweise. Beispiel: 1E+03 entspricht 1000 in dezimaler Darstellung.
Hexadezimal: Hexadezimale Darstellung. Dieses Format wird durch ein "h" hinter dem Wert angezeigt.
Oktal: Oktale Darstellung. Dieses Format wird durch ein "o" hinter dem Wert angezeigt.
Default: Dezimal.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowValueBasis"

Zeigt hinter dem Wert eine Kurzbezeichnung für die Zahlenbasis an:

Folgende Kurzbezeichnung werden angezeigt:

- Für Binär: b

- Für Dezimal: keine Kurzbezeichnung

- Für Dezimal Exponential: keine Kurzbezeichnung

- Für Hexadezimal: h

- Für Oktal: o

Default: Aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowValueBasis"


ID_ELE_PROP0

Interne ID: ID_ELE_PROP0

Elementname

Der Elementname muss für den Zugriff über VBA vergeben werden.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_ELE_PROP1

Interne ID: ID_ELE_PROP1

Fokus wird auf Element gesetzt

Aktiv: Das dynamische Element ist über die Tastatur bedienbar.
Inaktiv: Das dynamische Element kann über die Tastatur nicht erreicht werden.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Tab"


ID_ELE_PROP2

Interne ID: ID_ELE_PROP2

Unter WinCE sichtbar

Steuert die Sichtbarkeit von Elementen und Bildern unter Windows CE. Projekte, die unter CE und am PC verwendet werden, können dadurch flexibler gestaltet werden; die Bedienführung für den Benutzer wird verbessert. Es lassen sich zum Beispiel Buttons ausblenden, die zu Bildern führen, die unter CE nicht darstellbar sind (z.B. IPA) .

Aktiv: Das Bild/Element wird auch unter Windows CE dargestellt.

Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UnderCE"


ID_ELE_PROP5

Interne ID: ID_ELE_PROP5

Typ

ComboBox: Dieses Element wird als ComboBox verwendet.
ListBox: Dieses Element wird als ListBox verwendet.
Default: ListBox.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ControlType"


ID_ELE_PROP10

Interne ID: ID_ELE_PROP10

Startpunkt X [Pixel]

X-Koordinate des oberen linken Eckpunktes des Elements (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StartX"


ID_ELE_PROP11

Interne ID: ID_ELE_PROP11

Startpunkt Y [Pixel]

Y-Koordinate des oberen linken Eckpunktes des Elements (in Pixel)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StartY"


ID_ELE_PROP12

Interne ID: ID_ELE_PROP12

Endpunkt X [Pixel]

X-Koordinate des unteren rechten Eckpunktes des Elements (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EndX"


ID_ELE_PROP13

Interne ID: ID_ELE_PROP13

Endpunkt Y [Pixel]

Y-Koordinate des unteren rechten Eckpunktes des Elements (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EndY"


ID_ELE_PROP14

Interne ID: ID_ELE_PROP14

Breite [Pixel]

Breite des Elements (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Width"


ID_ELE_PROP15

Interne ID: ID_ELE_PROP15

Höhe [Pixel]

Höhe des Elements (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Height"


ID_ELE_PROP16

Interne ID: ID_ELE_PROP16

Name für Objektliste

Element wird in die Stationsliste des Weltbildes mit dem hier angegebenen Text eingetragen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Stationname"


ID_ELE_PROP17

Interne ID: ID_ELE_PROP17

Sichtbar von

Niedrigste Zoomstufe, in der das Element im Weltbild sichtbar sein soll.
Default: -1.
Wobei sichtbar in den Zoomstufen von -1 bis -1 bedeutet, dass das Element in allen Zoomstufen angezeigt wird.

Zoomstufen werden projektiert über die Projekteigenschaft Grafische Ausprägung -> Runtime allgemein -> Zoomstufen f. Weltbild.

Interne ID: ID_ELE_PROP17

Zoomstufen f. Weltbild

Der Dialog für die Definition der Zoomstufen für die Weltbild-Funktionalität wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMin"

Interne ID: ID_ELE_PROP17

Runtime allgemein

Enthält Einstellungen zur Runtime.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMin"

Interne ID: ID_ELE_PROP17

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMin"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMin"


ID_ELE_PROP18

Interne ID: ID_ELE_PROP18

Sichtbar bis

Höchste Zoomstufe, in der das Element im Weltbild sichtbar sein soll.

Default: -1.
Wobei sichtbar in den Zoomstufen von -1 bis -1 bedeutet, dass das Element in allen Zoomstufen angezeigt wird.

Zoomstufen werden projektiert über die Projekteigenschaft Grafische Ausprägung -> Runtime allgemein -> Zoomstufen f. Weltbild

Interne ID: ID_ELE_PROP18

Zoomstufen f. Weltbild

Der Dialog für die Definition der Zoomstufen für die Weltbild-Funktionalität wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMax"

Interne ID: ID_ELE_PROP18

Runtime allgemein

Enthält Einstellungen zur Runtime.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMax"

Interne ID: ID_ELE_PROP18

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMax"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomMax"


ID_ELE_PROP19

Interne ID: ID_ELE_PROP19

Schrift

Auswahl der Schrift, mit der die Darstellung erfolgt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Font"


ID_ELE_PROP20

Interne ID: ID_ELE_PROP20

Init

VBA Makro, das beim Initialisieren des Elements ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Init"


ID_ELE_PROP21

Interne ID: ID_ELE_PROP21

LeftClickUp

VBA Makro, das beim Loslassen der linken Maustaste auf dem Element ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LeftClickUp"


ID_ELE_PROP22

Interne ID: ID_ELE_PROP22

LeftClickDown

VBA Makro, das beim Drücken der linken Maustaste auf dem Element ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LeftClickDown"


ID_ELE_PROP23

Interne ID: ID_ELE_PROP23

LeftDoubleClick

VBA Makro, das beim Doppelklicken der linken Maustaste auf dem Element ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LeftDClick"


ID_ELE_PROP24

Interne ID: ID_ELE_PROP24

RightClickUp

VBA Makro, das beim Loslassen der rechten Maustaste auf dem Element ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RightClickUp"


ID_ELE_PROP25

Interne ID: ID_ELE_PROP25

RightClickDown

VBA Makro, das beim Drücken der rechten Maustaste auf dem Element ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RightClickDown"


ID_ELE_PROP26

Interne ID: ID_ELE_PROP26

RightDoubleClick

VBA Makro, das beim Doppelklicken der rechten Maustaste auf dem Element ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RightDClick"


ID_ELE_PROP27

Interne ID: ID_ELE_PROP27

SetFocus

VBA Makro, das ausgeführt werden soll, wenn das Element den Focus erhält.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetFocus"


ID_ELE_PROP28

Interne ID: ID_ELE_PROP28

KillFocus

VBA Makro, das ausgeführt werden soll, wenn das Element den Focus verliert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KillFocus"


ID_ELE_PROP29

Interne ID: ID_ELE_PROP29

Draw

VBA Makro, das ausgeführt werden soll, wenn das Element am Bildschirm neu gezeichnet wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Draw"


ID_ELE_PROP30

Interne ID: ID_ELE_PROP30

Kontextmenü

Kontextmenü für das Element.
Ein Klick mit der rechten Maustaste auf das Element öffnet das Kontextmenü in der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Menu"


ID_ELE_PROP31

Interne ID: ID_ELE_PROP31

Tooltip

Text, der in der Runtime als Tooltip für das Element angezeigt werden soll. Ein Tooltip wird in der Runtime automatisch angezeigt, wenn der Mauszeiger eine Weile auf dem Element still steht. Zeilenumbrüche können mit \n eingefügt werden.
Maximum: 79 Zeichen.

ACHTUNG: Die Zeichenkombination \n wird für die 79 Zeichen Begrenzung mitgezählt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Tooltip"


ID_ELE_PROP32

Interne ID: ID_ELE_PROP32

Hilfe-Datei

Hilfe-Datei (*.chm), die für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Klick auf ... öffnet den Dateiauswahldialog.
Achtung: Nur Hilfe-Dateien, die im Knoten "Dateien/Hilfe" hinzugefügt wurden, stehen zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Helpfile"


ID_ELE_PROP33

Interne ID: ID_ELE_PROP33

Hilfe-Kapitel

Hilfe-Kapitel, das für dieses Element in Verbindung mit einem Kontextmenü verwendet werden soll. Name der zugrunde liegenden HTML Seite.
Achtung: Dieser Eintrag berücksichtigt Groß-/Kleinschreibung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HelpCapture"


ID_ELE_PROP34

Interne ID: ID_ELE_PROP34

MouseOver

VBA Makro, das ausgeführt werden soll, wenn der Cursor über das Element bewegt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MouseOver"


ID_ELE_PROP35

Interne ID: ID_ELE_PROP35

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsSetValue"


ID_ELE_PROP36

Interne ID: ID_ELE_PROP36

Sollwert / Ändern um

Wert, der als Sollwert abgesetzt oder als Default vorgeschlagen werden soll.
Wenn "aktuellen Wert vorschlagen" aktiv ist: Wert, der zum aktuellen Wert addiert wird.
In Kombination mit der Eigenschaft "ohne Dialog" lässt sich so ein Inkrement- (positiver Wert) bzw. Dekrement- (negativer Wert) Schalter realisieren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValue"


ID_ELE_PROP37

Interne ID: ID_ELE_PROP37

Sollwert Text

Sollwert Text

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueText"


ID_ELE_PROP39

Interne ID: ID_ELE_PROP39

Minimum

Nur verfügbar, wenn "Sollwertgrenzen von Variable übernehmen" nicht aktiv ist:
Untergrenze des erlaubten Bereiches für den Sollwert.

ACHTUNG: Der hier eingegebene Wert wird ignoriert, wenn eine Variable für das dynamische Sollwert-setzen-Minimum ausgewählt ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"


ID_ELE_PROP40

Interne ID: ID_ELE_PROP40

Maximum

Nur verfügbar, wenn "Sollwertgrenzen von Variable übernehmen" nicht aktiv ist:
Obergrenze des erlaubten Bereiches für den Sollwert.

ACHTUNG: Der hier eingegebene Wert wird ignoriert, wenn eine Variable für das dynamische Sollwert-setzen-Maximum ausgewählt ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"


ID_ELE_PROP41

Interne ID: ID_ELE_PROP41

ohne Dialog

Aktiv: Der eingetragene Wert wird ohne Möglichkeit einer Änderung in der Runtime als Sollwert abgesetzt.
Inaktiv: Vor dem Schreiben auf die Hardware hat der Anwender in der Runtime die Möglichkeit den Wert noch zu ändern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HWDirect"


ID_ELE_PROP42

Interne ID: ID_ELE_PROP42

aktuellen Wert vorschlagen

Aktiv: Der aktuelle Prozesswert der Variablen wird beim Setzen als Sollwert vorgeschlagen.
In diesem Fall wird der Wert unter "Sollwert / Ändern um" vor dem absetzen zum aktuellen Wert addiert (positiver Wert) oder von ihm subtrahiert (negativer Wert).
Inaktiv: Der in "Sollwert / Ändern um" definierte Wert wird vorgeschlagen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Preset"


ID_ELE_PROP43

Interne ID: ID_ELE_PROP43

Sollwertgrenzen von Variable übernehmen

Aktiv: Die Einschränkung des Bereichs, in dem Sollwerte abgesetzt werden dürfen, wird nicht unter “Minimum” und “Maximum” definiert sondern aus der Variablendefinition übernommen.
Inaktiv: Die Einschränkung des Bereichs kann direkt in "Minimum" und "Maximum" eingegeben werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LimitFromVar"


ID_ELE_PROP44

Interne ID: ID_ELE_PROP44

Sollwert absetzen über

Sollwert setzen mit:
Befehlsgabe: Der neue Wert wird über die Aktion Sollwertvorgabe in der Befehlsgabe gesetzt.

Eingabemaske: Der neue Wert wird über die Standard-Eingabemaske eingegeben. Wenn ein Bild des Bildtyps "Keyboard" mit dem Namen "SETVALUEKBD" (für numerische Variablen) oder "SETSTRINGKBD" (für String-Variablen) existiert, wird dieses Bild anstelle der Standard-Eingabemaske verwendet.

Element: Der neue Wert wird direkt im Element eingegeben (nur bei den Elementen Zahlenwert und Textelement).

Programm: Der neue Wert wird in einem externen Programm eingegeben.

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Interne ID: ID_ELE_PROP44

SW setzen aktiv

Aktiv: Diese Variable für "Sollwert setzen" Aktionen freigeben.
Inaktiv: Diese Variable ist schreibgeschützt.
Default: aktiv

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueWith"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueWith"


ID_ELE_PROP46

Interne ID: ID_ELE_PROP46

Berechtigungsebene

Passwortlevel für das Setzen von Sollwerten oder das Ausführen von Funktionen mit dem ausgewählten dynamischen Element.
Minimum: 0.
Maximum: 127.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Passwordlevel"


ID_ELE_PROP47

Interne ID: ID_ELE_PROP47

Signatur erforderlich

Aktiv: Die Bedienung des Elements erfordert eine Signatur.

Auch bei einem bereits eingeloggten Benutzer wird hier aus Sicherheisgründen nochmals das Passwort abgefragt. Der Signaturtext wird nach erfolgreicher Bedienung in der Chronologischen Ereignisliste (CEL) protokolliert.

Achtung: Nur eingeloggte Benutzer können eine Aktion signieren. Ein temporäres Login ist bei zu signierenden Aktionen nicht möglich

Inaktiv: Keine Signatur ist erforderlich.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_ELE_PROP48

Interne ID: ID_ELE_PROP48

Signaturtext

Dieser Text wird beim Signieren in der Chronologischen Ereignisliste (CEL) mitprotokolliert oder wird in der Runtime als Default vorgeschlagen, wenn die Signatur in den Projekteigenschaften als editierbar definiert wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SignatureText"


ID_ELE_PROP49

Interne ID: ID_ELE_PROP49

Externes Programm

Nur verfügbar, wenn für das Sollwert Setzen externes Programm ausgewählt wurde:
Das Setzen des Sollwerts wird über ein externes Programm ausgeführt, das in der hier aufgeschalteten Dialogbox ausgewählt werden muss.

Diese Programm wird dann gestartet und erhält folgende Parameter:
1) Name der verknüpften Variable
2) Vorschlagswert, wie in den entsprechenden Eigenschaften definiert
3) linke Koordinate des Elements in Pixel
4) obere Koordinate des Elements in Pixel
5) rechte Koordinate des Elements in Pixel
6) untere Koordinate des Elements in Pixel
7) erlaubtes Minimum für den Sollwert, wie in den entsprechenden Eigenschaften definiert
8) erlaubtes Maximum für den Sollwert, wie in den entsprechenden Eigenschaften definiert

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetProgram"


ID_ELE_PROP51

Interne ID: ID_ELE_PROP51

Grenzwerttext anzeigen

Aktiv: Der Zustands-/Grenzwerttext der zugeordneten Variable wird im Element angezeigt.
Inaktiv: Kein Text wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ContitionText"


ID_ELE_PROP52

Interne ID: ID_ELE_PROP52

Nur Füllfläche einfärben

Aktiv: Bei Kreisen, Polygonen und Rechtecken, die dem verknüpften Symbol zugeordnet sind, wird nur die Füllfarbe nach der Farbdefinition der Variable geändert. Die Farbe der Umrandung bleibt erhalten.
Inaktiv: Auch die Umrandung wird entsprechend gefärbt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FillArea"


ID_ELE_PROP58

Interne ID: ID_ELE_PROP58

Funktion

Name der verknüpften Funktion.
Öffnet den Funktionsauswahldialog.
Diese Funktion wird ausgeführt, wenn der Button in der Runtime mit der Maus angeklickt oder die verknüpfte Tastenkombination gedrückt wird.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Nur SICAM 230 und Element Bild-Alarmierung:

Zusätzlich zur Standardeigenschaft Bildumschaltung wird durch die verknüpfte Funktion das Bild ermittelt, dessen Alarmzustände angezeigt werden sollen.
Obligat (außer bei Einstellung Global aktiv)!

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


ID_ELE_PROP59

Interne ID: ID_ELE_PROP59

Variable

Für Buttons nur verfügbar, wenn sie als Schalter verwendet werden:
Name der verknüpften Variable.
Öffnet den Variablenauswahldialog.
Der Wert dieser Variable wird in diesem Element angezeigt und kann hier auch gesetzt werden.

Nur SICAM 230 und Element Bild-Alarmierung:
Die obige Beschreibung betrifft nur die Elemente Textbutton, Bitmapbutton und Unsichtbarer Button.

Bedeutung in SICAM 230:
Auf die ausgewählte Variable (32 Bit) werden die Zustände der Alarm/Ereignis-Klassen abgebildet. Je Klasse werden 2 Bits beschrieben (nach Klassennummer aufsteigend).

Niederwertiges Bit: Alarm aktiv/inaktiv

Höherwertiges Bit: Alarm quittiert/unquittiert

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"


ID_ELE_PROP60

Interne ID: ID_ELE_PROP60

Schalter

Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

Interne ID: ID_ELE_PROP60

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Switch"

Aktiv: Das Element schaltet den Wert einer Bit-Variable.
Inaktiv: Das Element führt eine Funktion aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Switch"


ID_ELE_PROP61

Interne ID: ID_ELE_PROP61

Taster

Nur verfügbar, wenn Schalter aktiv ist. (Ausnahme: Im Dynamischen Element Schalter immer verfügbar.)
Aktiv: Der Sollzustand - definiert in der Eigenschaft Taster EIN - wird nur solange hergestellt, wie die linke Maustaste gedrückt bleibt, aber mindestens die Haltezeit [ms] lang.
Inaktiv: Der Sollzustand bleibt, auch wenn die Maustaste losgelassen wird.
Default: inaktiv.

Interne ID: ID_ELE_PROP61

Haltezeit [ms]

Nur verfügbar, wenn Schalter aktiv ist:
Wenn Taster aktiv ist: Zeit (in ms), die ein Zustand gehalten wird, ausgehend vom Linksklick auf das entsprechende Element.

Wenn Taster inaktiv ist: Reaktionsverzögerung auf Linksklick.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Scanner"

Interne ID: ID_ELE_PROP61

Taster EIN

Nur verfügbar, wenn Taster aktiv ist:
Aktiv: Taster schaltet auf EIN.
Inaktiv: Taster schaltet auf AUS.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Scanner"

Interne ID: ID_ELE_PROP61

Schalter

Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

Interne ID: ID_ELE_PROP61

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Scanner"

Aktiv: Das Element schaltet den Wert einer Bit-Variable.
Inaktiv: Das Element führt eine Funktion aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Scanner"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Scanner"


ID_ELE_PROP62

Interne ID: ID_ELE_PROP62

Taster EIN

Nur verfügbar, wenn Taster aktiv ist:
Aktiv: Taster schaltet auf EIN.
Inaktiv: Taster schaltet auf AUS.
Default: inaktiv.

Interne ID: ID_ELE_PROP62

Taster

Nur verfügbar, wenn Schalter aktiv ist. (Ausnahme: Im Dynamischen Element Schalter immer verfügbar.)
Aktiv: Der Sollzustand - definiert in der Eigenschaft Taster EIN - wird nur solange hergestellt, wie die linke Maustaste gedrückt bleibt, aber mindestens die Haltezeit [ms] lang.
Inaktiv: Der Sollzustand bleibt, auch wenn die Maustaste losgelassen wird.
Default: inaktiv.

Interne ID: ID_ELE_PROP62

Haltezeit [ms]

Nur verfügbar, wenn Schalter aktiv ist:
Wenn Taster aktiv ist: Zeit (in ms), die ein Zustand gehalten wird, ausgehend vom Linksklick auf das entsprechende Element.

Wenn Taster inaktiv ist: Reaktionsverzögerung auf Linksklick.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScannerOn"

Interne ID: ID_ELE_PROP62

Schalter

Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

Interne ID: ID_ELE_PROP62

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScannerOn"

Aktiv: Das Element schaltet den Wert einer Bit-Variable.
Inaktiv: Das Element führt eine Funktion aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScannerOn"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScannerOn"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScannerOn"


ID_ELE_PROP63

Interne ID: ID_ELE_PROP63

Sofortreaktion

Nur verfügbar, wenn Schalter aktiv ist:
Aktiv: Der Schalter ändert in der Runtime sofort seine Stellung, unabhängig davon, ob das verknüpfte Bit in der Steuerung tatsächlich gesetzt wurde, oder nicht. Im nächsten Treiberupdatezyklus wird das Bit dann aus der Steuerung gelesen. Der Schalter wird dann an die tatsächliche Bitstellung in der Steuerung wieder angepasst.
Achtung: Der Schalter ist optisch erst wieder bedienbar, wenn der Wert aus der Steuerung gelesen wurde.

Interne ID: ID_ELE_PROP63

Schalter

Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

Interne ID: ID_ELE_PROP63

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FastReaction"

Aktiv: Das Element schaltet den Wert einer Bit-Variable.
Inaktiv: Das Element führt eine Funktion aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FastReaction"

Inaktiv: Der Schalter ändert seine Stellung erst, nachdem das Bit zur SPS abgesetzt und dann wieder gelesen wurde.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FastReaction"


ID_ELE_PROP64

Interne ID: ID_ELE_PROP64

Haltezeit [ms]

Nur verfügbar, wenn Schalter aktiv ist:
Wenn Taster aktiv ist: Zeit (in ms), die ein Zustand gehalten wird, ausgehend vom Linksklick auf das entsprechende Element.

Interne ID: ID_ELE_PROP64

Taster

Nur verfügbar, wenn Schalter aktiv ist. (Ausnahme: Im Dynamischen Element Schalter immer verfügbar.)
Aktiv: Der Sollzustand - definiert in der Eigenschaft Taster EIN - wird nur solange hergestellt, wie die linke Maustaste gedrückt bleibt, aber mindestens die Haltezeit [ms] lang.
Inaktiv: Der Sollzustand bleibt, auch wenn die Maustaste losgelassen wird.
Default: inaktiv.

Interne ID: ID_ELE_PROP64

Taster EIN

Nur verfügbar, wenn Taster aktiv ist:
Aktiv: Taster schaltet auf EIN.
Inaktiv: Taster schaltet auf AUS.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReactionTime"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReactionTime"

Interne ID: ID_ELE_PROP64

Schalter

Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

Interne ID: ID_ELE_PROP64

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReactionTime"

Aktiv: Das Element schaltet den Wert einer Bit-Variable.
Inaktiv: Das Element führt eine Funktion aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReactionTime"

Wenn Taster inaktiv ist: Reaktionsverzögerung auf Linksklick.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReactionTime"


ID_ELE_PROP65

Interne ID: ID_ELE_PROP65

Tastenkombination

Tastenkombinationen unterstützen das Ausführen bedienbarer Bildelemente. Zum Beispiel:

- Ausführen von Kontrollelementen und Funktionen, die einem Element zugewiesenen wurden
- Sollwert Absetzen (z. B. bei Schalter)
- Fokus setzen bei bestimmten Fenstern (z.B. Kurvenliste im Erweiteren Trend oder Comboboxen im RGM)

Klick auf Eingabefeld öffnet Dialog zur Definition der Tastenkombination. Im Dialog wird die gewünschte Kombination direkt eingegeben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShortCut"


ID_ELE_PROP66

Interne ID: ID_ELE_PROP66

Grafikdatei

Grafik, die auf dem Button im ungedrückten Zustand dargestellt werden soll (*.bmp, *.wmf, *.jpg, *.gif, *.png). Klick auf die Schaltfläche ... öffnet den Dateiauswahldialog.
Achtung: Bilder müssen im Projektmanager im Knoten Dateien/Grafiken bereits vorhanden sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FileName"


ID_ELE_PROP67

Interne ID: ID_ELE_PROP67

Grafikdatei für Aus (0)

Vordefiniertes oder benutzerdefiniertes Bitmap für den LOW-Zustand des Schalters.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLow"


ID_ELE_PROP68

Interne ID: ID_ELE_PROP68

Grafikdatei für Ein (1)

Vordefiniertes oder benutzerdefiniertes Bitmap für den HIGH-Zustand des Schalters.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapHigh"


ID_ELE_PROP69

Interne ID: ID_ELE_PROP69

Um Nullpunkt

Wirkt sich nur auf die Darstellung von Werten mit Vorzeichen aus:
Aktiv: Der Balken reicht von Null bis zum aktuellen Wert der verknüpften Variable.
Inaktiv: Der Balken reicht vom niedrigsten angezeigten Wert bis zum aktuellen Wert der verknüpften Variable.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FromZero"


ID_ELE_PROP70

Interne ID: ID_ELE_PROP70

Anzeigetyp

Absolutzeit: Es wird die Zeit der Systemuhr mit den entsprechenden Formatierungen angezeigt.
Zeitdifferenz: Der Wert einer verknüpften Variablen wird im eingestellten Zeitformat dargestellt.
Default: Absolutzeit.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ViewType"


ID_ELE_PROP71

Interne ID: ID_ELE_PROP71

Formatierung

Format der Zeit-/Datumsanzeige.
Ein Formatierungsstring wird aus der Liste ausgewählt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Format"


ID_ELE_PROP72

Interne ID: ID_ELE_PROP72

Zweizeilige Darstellung

Nur verfügbar bei absoluter Zeit:
Aktiv: Bei der gleichzeitigen Darstellung von Zeit und Datum wird in der ersten Zeile die Zeit und in der zweiten Zeile das Datum angezeigt.
Inaktiv: Datum und Uhrzeit werden in einer Zeile dargestellt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwoLines"


ID_ELE_PROP73

Interne ID: ID_ELE_PROP73

Trennzeichen

Nur verfügbar mit Zeitdifferenz:
Trennzeichen für die Darstellung von Uhrzeit/Datum.
(z.B. : in 10:15)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Separator"


ID_ELE_PROP75

Interne ID: ID_ELE_PROP75

Symbol

Aus der Liste der im Bild vorhandenen Symbole kann ein Symbol ausgewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Symbol"


ID_ELE_PROP76

Interne ID: ID_ELE_PROP76

Text

Nur verfügbar bei numerischen Variablen:
Text, der angezeigt werden sollte, wenn keine Grenzwertverletzung ansteht (ansonsten wird der entsprechende Grenzwerttext angezeigt).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynText"


ID_ELE_PROP77

Interne ID: ID_ELE_PROP77

Linienart

Auswahl des Linientyps für das Element aus der Liste.
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität deaktiviert, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.
Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP77

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP77

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineType"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineType"

Interne ID: ID_ELE_PROP77

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineType"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineType"


ID_ELE_PROP78

Interne ID: ID_ELE_PROP78

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_PROP78

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FillPattern"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FillPattern"


ID_ELE_PROP79

Interne ID: ID_ELE_PROP79

Bildtypspezifische Funktion

Nur verfügbar in Bildern mit einem speziellen Bildtyp (Bildtyp ist nicht "Standard"):
Name der verknüpften Bildtyp-spezifischen Funktion.
Öffnet den Dialog zur Auswahl von Bildtyp-spezifischen Funktionen.
Statt einer allgemeinen Funktion kann eine speziell auf den Bildtyp abgestimmte Funktion verknüpft werden. Diese Funktion wird ausgeführt, wenn der Button in der Runtime mit der Maus angeklickt oder die verknüpfte Tastenkombination gedrückt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MDIFunction"


ID_ELE_PROP80

Interne ID: ID_ELE_PROP80

Beschriftung

Beschriftung des Elements im Editor.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Legend"


ID_ELE_PROP81

Interne ID: ID_ELE_PROP81

Style L

Windows-Style des Elements, nur für internen Gebrauch.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StyleL"


ID_ELE_PROP82

Interne ID: ID_ELE_PROP82

Style H

Windows-Style des Elements, nur für internen Gebrauch.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StyleH"


ID_ELE_PROP83

Interne ID: ID_ELE_PROP83

Horizontal

Horizontaler Bezugspunkt des Elements. Mögliche Werte sind: links, zentriert, rechts.
Dieser Punkt wird als Ausgangspunkt für die Berechnung des Startwinkels für das Drehen (statisch und dynamisch) sowie für die dynamische Größenänderung verwendet.

Default: Links

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HorizontalOrigin"


ID_ELE_PROP84

Interne ID: ID_ELE_PROP84

Vertikal

Vertikaler Bezugspunkt des Elements. Mögliche Werte sind: oben, zentriert, unten.
Dieser Punkt wird als Ausgangspunkt für die Berechnung des Startwinkels für das Drehen (statisch und dynamisch) sowie für die dynamische Größenänderung verwendet.

Default: Oben

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VerticalOrigin"


ID_ELE_PROP85

Interne ID: ID_ELE_PROP85

Symbolnummer

Eindeutige Nummer des Symbols.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PropSymbolNumber"


ID_ELE_PROP86

Interne ID: ID_ELE_PROP86

Name des verknüpften Symbols

Name des verknüpften Symbols.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LinkName"


ID_ELE_PROP91

Interne ID: ID_ELE_PROP91

Minimum

Kleinster Variablenwert, der im Element dargestellt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ViewMin"


ID_ELE_PROP92

Interne ID: ID_ELE_PROP92

Maximum

Größter Variablenwert, der im Element dargestellt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ViewMax"


ID_ELE_PROP93

Interne ID: ID_ELE_PROP93

Absolutbetrag

Für Element Zahlenwert nur verfügbar, wenn Wert in Prozent anzeigen inaktiv ist.

Interne ID: ID_ELE_PROP93

Wert in Prozent anzeigen

Aktiv: Der Wert der Variable wird in 0-100% dargestellt.
0% = Messbereich Minimum
100% = Messbereich Maximum
Die Umrechnung erfolgt linear. Auch Sollwert-Eingaben erfolgen in Prozent.
Inaktiv: Der Wert wird wie gewohnt dargestellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Absolute"

Aktiv: Anzeige des Variablenwertes ohne Vorzeichen (-200 = 200).
Inaktiv: Normale Darstellung des Wertes.
Default: inaktiv.

Hinweis: Die Sollwert-Eingabe erfolgt in diesem Fall in Prozent.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Absolute"


ID_ELE_PROP97

Interne ID: ID_ELE_PROP97

Immer

Aktiv: Die Animation läuft immer.
Inaktiv: Die Animation wird nicht ausgeführt. Optional kann mit einer verknüpften Variable die Animation ein- und ausgeschalten werden.

Interne ID: ID_ELE_PROP97

Variable

Bit-Variable, die die Animation ein und aus schaltet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Animate"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Animate"


ID_ELE_PROP98

Interne ID: ID_ELE_PROP98

Variable

Bit-Variable, die die Animation ein und aus schaltet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AnimateVar"


ID_ELE_PROP99

Interne ID: ID_ELE_PROP99

Kategorie

Begriff zur Kategorisierung. Nach dieser Eigenschaft kann auch gefiltert bzw. gruppiert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Category"


ID_ELE_PROP100

Interne ID: ID_ELE_PROP100

Beschreibung

Nähere Beschreibung des Symbols. Nach dieser Eigenschaft kann auch gefiltert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Information"


ID_ELE_PROP101

Interne ID: ID_ELE_PROP101

Textfarbe

Textfarbe des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextColor"


ID_ELE_PROP102

Interne ID: ID_ELE_PROP102

Füllfarbe

Nur verfügbar, wenn die Eigenschaft Transparent auf inaktiv geschaltet wurde.

Interne ID: ID_ELE_PROP102

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor"

Definiert die Füllfarbe des Elements. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Die Füllfarbe kann dynamisch geändert werden über die Eigenschaft Füllfarbe aus der Gruppe Farben dynamisch .

Interne ID: ID_ELE_PROP102

Farben dynamisch

Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor"

Interne ID: ID_ELE_PROP102

Füllfarbe

Name der Variable, deren Grenzwertfarben die Hintergrund-/Füllfarbe des Elements beeinflussen sollen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor"

Hinweis: Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Achtung: Im Weltbild Übersichtsfenster haben Farbänderungen im Editor keine Auswirkung zur Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor"


ID_ELE_PROP103

Interne ID: ID_ELE_PROP103

Balkenfarbe

Farbe für den Balken des Bargraphen. Die eingestellte Farbe wird verwendet, wenn keine Grenzwertverletzung der Variable ansteht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextColor"


ID_ELE_PROP104

Interne ID: ID_ELE_PROP104

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Transparent"


ID_ELE_PROP108

Interne ID: ID_ELE_PROP108

Füllfarbe

Füll- bzw. Hintergrundfarbe des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor"


ID_ELE_PROP109

Interne ID: ID_ELE_PROP109

Symbolgruppe

Definiert die Gruppenzugehörigkeit des Symbols. Dieser Wert kann nicht geändert werden. Symbole aus der Projekt-Symbolbibliothek erhalten den Wert Project.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Group"


ID_ELE_PROP111

Interne ID: ID_ELE_PROP111

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Interne ID: ID_ELE_PROP111

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1"


ID_ELE_PROP112

Interne ID: ID_ELE_PROP112

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Interne ID: ID_ELE_PROP112

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2"

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2"


ID_ELE_PROP113

Interne ID: ID_ELE_PROP113

Textumbruch

Aktiv: Automatischer Zeilenumbruch wird für den Text im Element verwendet.
Die Länge der Zeilen hängt von der Breite des Elements ab.
Inaktiv: Der Text wird in einer Zeile dargestellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Wordbreak"


ID_ELE_PROP114

Interne ID: ID_ELE_PROP114

Text bei gedrückt

Beschriftung des Buttons, die im gedrückten Zustand erscheinen sollte.

Zeichenfolge \n erzwingt neue Zeile.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DownText"


ID_ELE_PROP115

Interne ID: ID_ELE_PROP115

Funktionausführung beim Drücken

Aktiv: Die verknüpfte Funktion wird beim Drücken des Elements ausgeführt.
Inaktiv: Die verknüpfte Funktion wird beim loslassen des Elements ausgeführt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FktOnDown"


ID_ELE_PROP116

Interne ID: ID_ELE_PROP116

Button Form

Form des Buttons:
eckig: Die Ecken des Buttons sind scharf, Rundungen werden über die Eigenschaften der Gruppe Abrundung eingestellt.
rund: Der Button wird rund dargestellt.

Interne ID: ID_ELE_PROP116

Abrundung

Eigenschaften für die Darstellung abgerundeter Ecken.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BtnStyleBorder"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BtnStyleBorder"


ID_ELE_PROP117

Interne ID: ID_ELE_PROP117

Farbverlauf invertiert

Nur verfügbar, wenn die Füllung des Buttons nicht einfarbig ist.
Aktiv: Der Helligkeitsverlauf wird invertiert.
Inaktiv: Der Helligkeitsverlauf wird nicht invertiert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BtnStyleInvert"


ID_ELE_PROP118

Interne ID: ID_ELE_PROP118

Füllung

Füllung des Buttons:
einfarbig: Kein Verlauf
linear: gleichmäßiger Verlauf
strahlend: Von unten bis zur Mitte Füllfarbe 1, dann Verlauf von Mitte nach oben
punktuell: Verlauf von den Rändern zum Zentrum

punktuell mit Kanten: Verlauf von den Rändern zum Zentrum mit Kantenbildung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BtnStyleFill"


ID_ELE_PROP121

Interne ID: ID_ELE_PROP121

Status der Variable anzeigen

Aktiv: Der Status der Variablen wird durch ein farbiges Quadrat am Element angezeigt.

Farbe:
rotes Quadrat zeigt an, dass es Probleme in der Kommunikation mit der SPS gibt.>
blaues Quadrat am Client zeigt an, dass der Client seine Verbindung zum Server verloren hat.
blaues Quadrat auf der Station zeigt an, dass der Wert nicht initialisiert wurde.

Position des Quadrats am Element bei Elementform:

rund: oberen Rand, in der Mitte
abgerundet: obere rechte Ecke, leicht nach links versetzt
eckig und alle anderen: rechte obere Ecke

Inaktiv: Der Status wird nicht angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowState"


ID_ELE_PROP122

Interne ID: ID_ELE_PROP122

Ausrichtung horizontal

Horizontale Ausrichtung der Ausgabe im Element für die Anzeige. Mögliche Einstellungen über Dropdownliste:

- zentriert
- linksbündig
- rechtsbündig

Default: zentriert

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HorizontalAlign"


ID_ELE_PROP123

Interne ID: ID_ELE_PROP123

Ausrichtung vertikal

Vertikale Ausrichtung der Ausgabe im Element für die Anzeige. Mögliche Einstellungen über Dropdownliste:

- zentriert
- oben
- unten

Default: zentriert

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VerticalAlign"


ID_ELE_PROP124

Interne ID: ID_ELE_PROP124

Elementrahmen

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Dünner Rahmen

3D

Default: Dünner Rahmen

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Frame"


ID_ELE_PROP125

Interne ID: ID_ELE_PROP125

Maßeinheit anzeigen

Nur verfügbar:
Allgemein: wenn die Eigenschaft Wert anzeigen aktiviert wurde.
Bei Element Uhr : wenn als Anzeigetyp Zeitdifferenz gewählt wurde.
Bei Element Zeigerinstrument: wenn Eigenschaft 3D aktiviert wurde.

Interne ID: ID_ELE_PROP125

3D

Aktiv: Das Element wird 3-dimensional dargestellt.
Inaktiv: Das Element wird flach dargestellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowUnit"

Interne ID: ID_ELE_PROP125

Anzeigetyp

Absolutzeit: Es wird die Zeit der Systemuhr mit den entsprechenden Formatierungen angezeigt.
Zeitdifferenz: Der Wert einer verknüpften Variablen wird im eingestellten Zeitformat dargestellt.
Default: Absolutzeit.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowUnit"

Interne ID: ID_ELE_PROP125

Wert anzeigen

Zusätzliche Anzeige des aktuellen Wertes als Zahl; Position im Element und Schriftfarbe können frei gewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowUnit"

Aktiv: Die technische Einheit der verknüpften Variable wird hinter dem Wert angezeigt.
Wird der Wert in Prozent dargestellt, so wird das Prozentzeichen % anstatt der technischen Einheit der verknüpften Variable verwendet.
Inaktiv: Die technische Einheit wird nicht angezeigt.
Default: aktiv.

Hinweis:

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowUnit"


ID_ELE_PROP126

Interne ID: ID_ELE_PROP126

Wert in Prozent anzeigen

Aktiv: Der Wert der Variable wird in 0-100% dargestellt.
0% = Messbereich Minimum
100% = Messbereich Maximum
Die Umrechnung erfolgt linear. Auch Sollwert-Eingaben erfolgen in Prozent.
Inaktiv: Der Wert wird wie gewohnt dargestellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Percentage"


ID_ELE_PROP127

Interne ID: ID_ELE_PROP127

3D

Aktiv: Das Element wird 3-dimensional dargestellt.
Inaktiv: Das Element wird flach dargestellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ThreeDimensional"


ID_ELE_PROP129

Interne ID: ID_ELE_PROP129

Prozentdarstellung

Aktiv: Der Wert der Variable wird in 0-100% dargestellt.
0% = Messbereich Minimum
100% = Messbereich Maximum
Die Umrechnung erfolgt linear. Auch Sollwert-Eingaben erfolgen in Prozent.
Inaktiv: Der Wert wird wie gewohnt dargestellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Percentage"


ID_ELE_PROP130

Interne ID: ID_ELE_PROP130

Band

Nur verfügbar, wenn die Anzeige als Teilkreis nicht aktiv ist.

Interne ID: ID_ELE_PROP130

Teilkreis

Nur verfügbar, wenn die Anzeige als Band nicht aktiv ist:
Aktiv: Der Wert wird mit einem Teilkreis vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Teilkreis wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Ribbon"

Unter Windows CE nicht verfügbar.
Aktiv: Der Wert wird mit einem Band vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Band wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Ribbon"


ID_ELE_PROP131

Interne ID: ID_ELE_PROP131

Teilkreis

Nur verfügbar, wenn die Anzeige als Band nicht aktiv ist:
Aktiv: Der Wert wird mit einem Teilkreis vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Teilkreis wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Pie"


ID_ELE_PROP132

Interne ID: ID_ELE_PROP132

Explizit

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv

Hinweis: Beim Element Zeigerinstrument nur verfügbar, wenn die Darstellung als Band oder Teilkreis aktiv ist.

Interne ID: ID_ELE_PROP132

Teilkreis

Nur verfügbar, wenn die Anzeige als Band nicht aktiv ist:
Aktiv: Der Wert wird mit einem Teilkreis vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Teilkreis wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Explicit"

Interne ID: ID_ELE_PROP132

Band

Nur verfügbar, wenn die Anzeige als Teilkreis nicht aktiv ist.

Unter Windows CE nicht verfügbar.
Aktiv: Der Wert wird mit einem Band vom minimalen Wert bis zum aktuellen Wert dargestellt.
Inaktiv: Kein Band wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Explicit"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Explicit"


ID_ELE_PROP135

Interne ID: ID_ELE_PROP135

Kurven als Fläche anzeigen

Aktiv: Kurven werden als Flächen dargestellt.
Inaktiv: Kurven werden als Linien dargestellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Area"


ID_ELE_PROP136

Interne ID: ID_ELE_PROP136

Nicht interpolieren

Aktiv: Werte werden ohne Interpolation in Stufen verbunden.
Inaktiv: Werte werden mit Interpolation verbunden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NoInterpolation"


ID_ELE_PROP137

Interne ID: ID_ELE_PROP137

Zahlenwerte anzeigen

Aktiv: Die Werte des letzten Refreshs werden für alle verknüpften Variablen als Zahlen angezeigt.
Inaktiv: Die Werte werden nicht angezeigt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NumericalValues"


ID_ELE_PROP138

Interne ID: ID_ELE_PROP138

Achsen anzeigen

Aktiv: Zeit- und Prozentachse werden angezeigt.
Inaktiv: Keine Achsen werden angezeigt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Axes"


ID_ELE_PROP139

Interne ID: ID_ELE_PROP139

Kurveninfo anzeigen

Aktiv: Der Name oder der geänderte Kurztext und der Messbereich der verknüpften Variablen werden in einer Legende dargestellt.
Inaktiv: Keine Legende wird dargestellt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Addresses"


ID_ELE_PROP140

Interne ID: ID_ELE_PROP140

Wert während Mausbewegung setzen

Aktiv: Andauerndes senden neuer Werte während der Mausbewegung.
Inaktiv: Einmaliges senden des neuen Wertes, wenn die Maustaste losgelassen wird.
(Nur wenn in der Sektion “Sollwert” die Option “direkt zur Hardware” aktiviert ist)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MouseMovement"


ID_ELE_PROP141

Interne ID: ID_ELE_PROP141

Wert anzeigen

Zusätzliche Anzeige des aktuellen Wertes als Zahl; Position im Element und Schriftfarbe können frei gewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowValue"


ID_ELE_PROP142

Interne ID: ID_ELE_PROP142

Grafikgröße

Definition der Bitmapgrösse.
Originalgrösse: Originalgrösse des verknüpften Bitmaps.
Gestreckt: Bitmapgrösse wird an die Grösse des Elements angepasst (gestreckt).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Representation"


ID_ELE_PROP150

Interne ID: ID_ELE_PROP150

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP150

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineWidth"

Interne ID: ID_ELE_PROP150

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineWidth"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineWidth"


ID_ELE_PROP151

Interne ID: ID_ELE_PROP151

Wertfarbe

Farbe für den darzustellenden Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueColor"


ID_ELE_PROP152

Interne ID: ID_ELE_PROP152

Wertposition

Position für den darzustellenden Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValuePos"


ID_ELE_PROP153

Interne ID: ID_ELE_PROP153

Startwinkel

Definition des Anfangswinkels (0°=unten, weiter im Uhrzeigersinn).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StartAngle"


ID_ELE_PROP154

Interne ID: ID_ELE_PROP154

Öffnungswinkel

Öffnungswinkel des Zeigerausschlags (max. 360° - Startwinkel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OpeningAngle"


ID_ELE_PROP155

Interne ID: ID_ELE_PROP155

Scrollweite [%]

Diese Eigenschaft legt fest, um wieviel % die Kurve bei Erreichen der Darstellungsgrenze verschoben wird; als Werte sind Eingaben von 0%-100% direkt über die Werteingabe oder über den Scrollbalken möglich.
0%: Pro Neueintrag ältesten Eintrag entfernen.
50%: Bei Überlauf halben Bildbereich löschen und weiterschreiben.
100%: Bei Überlauf gesamten Bildbereich löschen und neu beginnen.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScrollWidth"


ID_ELE_PROP156

Interne ID: ID_ELE_PROP156

Laufrichtung

Diese Eigenschaft definiert die Anordnung der darzustellenden Zeitachse.
Nach rechts: Links ältester, rechts aktuellster Wert.
Nach links: Rechts ältester, links aktuellster Wert.
Nach oben: Unten ältester, oben aktuellster Wert.
Nach unten: Oben ältester, unten aktuellster Wert.
Wenn die Achsen angezeigt werden, zeigt ein Pfeil in der linken unteren Ecke des Elements die Laufrichtung an.
Default: nach rechts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Direction"


ID_ELE_PROP157

Interne ID: ID_ELE_PROP157

Text

Text, der im Bild dargestellt werden soll.

Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text"


ID_ELE_PROP158

Interne ID: ID_ELE_PROP158

Textwinkel [°]

Winkel für die Darstellung des Textes.

ACHTUNG: Diese Option funktioniert nur bei eingebetteten Schriften.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextAngle"


ID_ELE_PROP159

Interne ID: ID_ELE_PROP159

Buchstabenneigung [°]

Buchstabenneigung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextLetterAngle"


ID_ELE_PROP160

Interne ID: ID_ELE_PROP160

Zahlenbasis für Anzeige

Stellen Sie hier das Zahlensystem für die Darstellung der Werte ein. Folgende Zahlensysteme stehen Ihnen zur Verfügung:
Binär: Binäre Darstellung. Dieses Format wird durch ein "b" hinter dem Wert angezeigt.
Dezimal: Dezimale Darstellung.
Exponential: Dezimale Darstellung in exponentieller Schreibweise. Beispiel: 1E+03 entspricht 1000 in dezimaler Darstellung.
Hexadezimal: Hexadezimale Darstellung. Dieses Format wird durch ein "h" hinter dem Wert angezeigt.
Oktal: Oktale Darstellung. Dieses Format wird durch ein "o" hinter dem Wert angezeigt.
Default: Dezimal.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueBase"


ID_ELE_PROP161

Interne ID: ID_ELE_PROP161

Skala anzeigen

Aktiv: Am Element wird eine Skala angezeigt.
Inaktiv: Keine Skala wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowScale"


ID_ELE_PROP162

Interne ID: ID_ELE_PROP162

Abstand [Pixel]

Abstand zwischen Skala und Element (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScaleDistance"


ID_ELE_PROP163

Interne ID: ID_ELE_PROP163

Höhe [Pixel]

Höhe der Skala (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScaleHeight"


ID_ELE_PROP164

Interne ID: ID_ELE_PROP164

Hauptticks

Wertbereich für die Hauptticks (Ziffernanzeigen) der Skalierung.

Beispiel: Die Eingabe 50 führt zur Anzeige eines Hauptticks in 50er Schritten: 0 - 50 - 100 - 150 ...

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MainTicks"


ID_ELE_PROP165

Interne ID: ID_ELE_PROP165

Nebenticks

Wertbereich für die Nebenticks (keine Ziffernanzeigen) an der Skalierung.
Beispiel: Die Eingabe 100 führt zu der Anzeige eines Nebenticks bei jedem Tausenderschritt vom kleisten angezeiten Wert beginnend.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmallTicks"


ID_ELE_PROP166

Interne ID: ID_ELE_PROP166

Farbe Hauptticks

Farbe der Hauptticks (Ziffernanzeigen) der Skalierung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MainTickColor"


ID_ELE_PROP167

Interne ID: ID_ELE_PROP167

Farbe Nebenticks

Farbe der Nebenticks (keine Ziffernanzeigen) an der Skalierung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmallTickColor"


ID_ELE_PROP168

Interne ID: ID_ELE_PROP168

Legende anzeigen

Bei Aktivierung wird eine Beschriftung (Werte) zur Skala angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowLegend"


ID_ELE_PROP169

Interne ID: ID_ELE_PROP169

Abstand [Pixel]

Abstand zwischen Legende und Skala (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LegendDistance"


ID_ELE_PROP170

Interne ID: ID_ELE_PROP170

Legendenfarbe

Farbe der Legende.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LegendColor"


ID_ELE_PROP171

Interne ID: ID_ELE_PROP171

Logarithmisch

Aktiv: Logarithmische Skalierung.
Inaktiv: Lineare Skalierung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Logarithmic"


ID_ELE_PROP172

Interne ID: ID_ELE_PROP172

Umgekehrte Laufrichtung

Umkehrung von Minimal- und Maximalwert in der grafischen Darstellung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReverseDirection"


ID_ELE_PROP173

Interne ID: ID_ELE_PROP173

Diskret

Werteingabe nur in eingestellten Schritten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Discrete"


ID_ELE_PROP174

Interne ID: ID_ELE_PROP174

Diskrete Stufen

Anzahl der Schritte für die Eigenschaft Diskrete Stufen.

Minimum: 2

Maximum: 20

Default: 5

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DiscreteSteps"


ID_ELE_PROP175

Interne ID: ID_ELE_PROP175

Knopf anzeigen

An der Stelle des aktuellen Wertes wird im Element ein Bedienelement (Knopf) angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowKnob"


ID_ELE_PROP176

Interne ID: ID_ELE_PROP176

Knopfform

Knopfform aus Liste auswählen. (flach, hoch, vertieft)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KnobStyle"


ID_ELE_PROP177

Interne ID: ID_ELE_PROP177

Knopffarbe

Farbe des Knopfes.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KnobColor"


ID_ELE_PROP191

Interne ID: ID_ELE_PROP191

Form

Linear: Darstellung als Balken oder Schieberegler.
Rund: Darstellung als Zeigerelement.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Shape"


ID_ELE_PROP192

Interne ID: ID_ELE_PROP192

Ausrichtung

Nur verfügbar für lineare Form:
Horizontal: Horizontale Darstellung des Balken oder Schiebereglers.
Vertikal: Vertikale Darstellung des Balken oder Schiebereglers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Align"


ID_ELE_PROP193

Interne ID: ID_ELE_PROP193

Startwinkel

Nur verfügbar für runde Form:
Position des Zeigerinstruments für den Minimalwert (0° unten).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Start"


ID_ELE_PROP194

Interne ID: ID_ELE_PROP194

Endwinkel

Nur verfügbar für runde Form:
Position des Zeigerinstruments für den Maximalwert (0° unten).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "End"


ID_ELE_PROP195

Interne ID: ID_ELE_PROP195

Stil

Folgende Stile der Darstellung stehen zur Verfügung:
– Schiebe-/Drehregler
– Balken
– LED Balken
– Bewegte Skala

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Style"


ID_ELE_PROP196

Interne ID: ID_ELE_PROP196

Zeigerart

Grafische Markierung des aktuellen Wertes durch
– Linie
– Zeiger
– Dreieck

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Pointer"


ID_ELE_PROP197

Interne ID: ID_ELE_PROP197

Balken explizit

Nur verfügbar, wenn für die Eigenschaft Stil Balken, Bewegte Skala oder LED Balken gewählt wurde.

Interne ID: ID_ELE_PROP197

Stil

Folgende Stile der Darstellung stehen zur Verfügung:
– Schiebe-/Drehregler
– Balken
– LED Balken
– Bewegte Skala

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Explicit"

Diese Eigenschaft wirkt sich nur auf die Darstellung von Werten mit definierten Grenzwerten aus Variablen aus. Grenzwerte aus Reaktionsmatrizen werden nicht ausgewertet.

Aktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird nur der Teil der Darstellung, der in die Grenzwertverletzung hinein reicht, in der Farbe des jeweiligen Grenzwertes dargestellt.
Hat die Variable mehrere definierte Grenzwerte, so werden die entsprechenden Bereiche der Darstellung jeweils in der Farbe des Grenzwertes dargestellt.

Inaktiv: Wird ein Grenzwert der verknüpften Variable verletzt, so wird die gesamte Darstellung in der Farbe des verletzten Grenzwertes dargestellt.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Explicit"


ID_ELE_PROP198

Interne ID: ID_ELE_PROP198

Zeiger-/Balkenfarbe

Farbe für den Zeiger bzw. Balken.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PointerColor"


ID_ELE_PROP199

Interne ID: ID_ELE_PROP199

Schleppzeiger anzeigen

Minimum-/Maximum-Anzeige aktivieren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinMaxView"


ID_ELE_PROP200

Interne ID: ID_ELE_PROP200

Darstellungsart

Grafische Markierung (Schleppzeiger) für den Minimal- bzw. Maximalwert durch:
– Linie
– Zeiger
– Dreieck

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinMaxShape"


ID_ELE_PROP201

Interne ID: ID_ELE_PROP201

Farbe Minimalwert

Farbe für angezeigtes Minimum.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinColor"


ID_ELE_PROP202

Interne ID: ID_ELE_PROP202

Farbe Maximalwert

Farbe für angezeigtes Maximum.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxColor"


ID_ELE_PROP203

Interne ID: ID_ELE_PROP203

Automatisch zurücksetzen

Schleppzeiger für Minimum-/Maximumanzeige automatisch nach eingestellter Zeit zurücksetzen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AutoReset"


ID_ELE_PROP204

Interne ID: ID_ELE_PROP204

Zurücksetzen nach [min]

Zeit für automatisches Zurücksetzen der Min./Max. Anzeige.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AutoResetTime"


ID_ELE_PROP211

Interne ID: ID_ELE_PROP211

Links [Pixel]

Abstand zwischen dem linken Rand des Elements und der grafischen Darstellung (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LeftFrame"


ID_ELE_PROP212

Interne ID: ID_ELE_PROP212

Rechts [Pixel]

Abstand zwischen dem rechten Rand des Elements und der grafischen Darstellung (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RightFrame"


ID_ELE_PROP213

Interne ID: ID_ELE_PROP213

Oben [Pixel]

Abstand zwischen dem oberen Rand des Elements und der grafischen Darstellung (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TopFrame"


ID_ELE_PROP214

Interne ID: ID_ELE_PROP214

Unten [Pixel]

Abstand zwischen dem unteren Rand des Elements und der grafischen Darstellung (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BottomFrame"


ID_ELE_PROP221

Interne ID: ID_ELE_PROP221

Titel anzeigen

Titel anzeigen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowTitle"


ID_ELE_PROP222

Interne ID: ID_ELE_PROP222

Titelposition

Position für den Titel.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TitlePos"


ID_ELE_PROP223

Interne ID: ID_ELE_PROP223

Titelfarbe

Textfarbe für den Titel.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TitleColor"


ID_ELE_PROP224

Interne ID: ID_ELE_PROP224

Titeltext

Text, der als Titel angezeigt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TitleText"


ID_ELE_PROP225

Interne ID: ID_ELE_PROP225

Abstand [Pixel]

Abstand zwischen Titel und Wertanzeige (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueDistance"


ID_ELE_PROP231

Interne ID: ID_ELE_PROP231

Laufrichtung

Laufrichtung des Balken.
nach oben: Niedrigster Wert unten, höchster Wert oben.
nach unten: Niedrigster Wert oben, höchster Wert unten.
nach links: Niedrigster Wert rechts, höchster Wert links.
nach rechts: Niedrigster Wert links, höchster Wert rechts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Direction"


ID_ELE_PROP241

Interne ID: ID_ELE_PROP241

Stunden

Stunden des Darstellungszeitraums.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RepresentationHour"


ID_ELE_PROP242

Interne ID: ID_ELE_PROP242

Minuten

Minuten des Darstellungszeitraums.
Minimum: 0.
Maximum: 59.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RepresentationMinute"


ID_ELE_PROP243

Interne ID: ID_ELE_PROP243

Sekunden

Sekunden des Darstellungszeitraums.
Minimum: 0.
Maximum: 59.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RepresentationSecond"


ID_ELE_PROP251

Interne ID: ID_ELE_PROP251

Stunden

Stunden der Aktualisierungszeit.
Minimum: 0.
Maximum: 119304.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefreshHour"


ID_ELE_PROP252

Interne ID: ID_ELE_PROP252

Minuten

Minuten der Aktualisierungszeit.
Minimum: 0.
Maximum: 59.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefreshMinute"


ID_ELE_PROP253

Interne ID: ID_ELE_PROP253

Sekunden

Sekunden der Aktualisierungszeit.
Minimum: 0.
Maximum: 59.
Default: 1.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefreshSecond"


ID_ELE_PROP254

Interne ID: ID_ELE_PROP254

Millisekunden

Millisekunden der Aktualisierungszeit.
Minimum: 0.
Maximum: 999.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefreshMilliSecond"


ID_ELE_PROP262

Interne ID: ID_ELE_PROP262

Linienfarbe

Normalfarbe; bei Grenzwertverletzung wird die Grenzwertfarbe verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineColor"


ID_ELE_PROP263

Interne ID: ID_ELE_PROP263

Linienart

Durchgezogene Linie, Striche, Strichpunkt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineStyle"


ID_ELE_PROP264

Interne ID: ID_ELE_PROP264

Min. Anzeigebereich

Minimum des technischen Darstellungsbereichs für die Kurve (Ausschnittvergrößerung).
Minimum: Minimalwert der Variable.
Maximum: Maximalwert der Variable.
Default: Minimalwert der Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ViewMin"


ID_ELE_PROP265

Interne ID: ID_ELE_PROP265

Max. Anzeigebereich

Maximum des technischen Darstellungsbereichs für die Kurve (Ausschnittvergrößerung).
Minimum: Minimalwert der Variable.
Maximum: Maximalwert der Variable.
Default: Maximalwert der Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ViewMax"


ID_ELE_PROP266

Interne ID: ID_ELE_PROP266

Kurvenname

Anzeige bei gesetzter Option "Kurveninfo anzeigen".
Bleibt diese Eigenschaft leer, so wird der Name der Variable angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TrendText"


ID_ELE_PROP271

Interne ID: ID_ELE_PROP271

Darstellungsart

Bitmap: Für jeden Zustand kann ein Bitmap ausgewählt werden.
Zusätzlich kann auch die Farbe eines Bildsymbols geändert werden.
Nur Bildsymbol: Für jeden Zustand kann einem bereits im Bild bestehenden Symbol eine Farbe zugeordnet werden.
Symbol aus Bibliothek: Für jeden Zustand kann ein Symbol aus der Bibliothek sowie seine Linien- und Hintergrungfarbe ausgewählt werden.
Zeichen: Für jeden Zustand kann ein Zeichen definiert werden (nur SICAM 230).
Zustandstext & Bildsymbol: Für jeden Zustand kann ein Text definiert werden.
Zusätzlich kann auch die Farbe eines Bildsymbols geändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RepresentationStyle"


ID_ELE_PROP272

Interne ID: ID_ELE_PROP272

Übereinander

Nur verfügbar für Darstellungsart "Symbol aus Bibliothek":
Aktiv: Sind mehrere Wertzuordnungen aktiv, erfolgt die Darstellung übereinander, d.h. alle aktiven Zustände werden angezeigt.
Inaktiv: Nur der höchstpriore aktive Zustand wird angezeigt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Overlapping"


ID_ELE_PROP273

Interne ID: ID_ELE_PROP273

Separate Farben

Nur verfügbar, wenn "Übereinander" aktiv ist:
Aktiv: Jeder Zustand wird in seiner definierten Farbe dargestellt.
Inaktiv: Die Farbe des höchstprioren aktiven Zustandes wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SeparateColors"


ID_ELE_PROP274

Interne ID: ID_ELE_PROP274

Separates Blinken

Nur verfügbar, wenn "Übereinander" aktiv ist:
Aktiv: Das Blinken jedes Zustands wird separat dargestellt.
Inaktiv: Das Blinken des höchstprioren aktiven Zustandes wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SeparateBlinking"


ID_ELE_PROP275

Interne ID: ID_ELE_PROP275

Texte gekettet

Nur verfügbar für Darstellungsart "Zustandstext":
Aktiv: Wenn mehrere Zustände zutreffen, werden die Texte als kombinierter String dargestellt.
Inaktiv: Der Text des höchstprioren aktiven Zustandes wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Chained"


ID_ELE_PROP276

Interne ID: ID_ELE_PROP276

Transparent

Aktiv: Der Symbolhintergrund ist transparent.
Inaktiv: Der Symbolhintergrund kann für jeden Zustand separat definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FillColor"


ID_ELE_PROP278

Interne ID: ID_ELE_PROP278

In Originalgröße

Aktiv: Das Bitmap wird in seiner Originalgrösse dargestellt.
Inaktiv: Das Bitmap wird auf die Größe des Elements gestreckt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OriginalSize"


ID_ELE_PROP279

Interne ID: ID_ELE_PROP279

Bildsymbol aktiv

Nur verfügbar für Darstellungsart "Bitmap" oder "Zustandstext":
Aktiv: Zusätzlich zum animierten Bitmap bzw. Zustandstext kann ein Bildsymbol mit gesteuert werden.
Inaktiv: Kein Bildsymbol wird mit animiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsPictureSymbol"


ID_ELE_PROP280

Interne ID: ID_ELE_PROP280

Bildsymbol

Nurverfügbar für Darstellungsart "Nur Bildsymbol" oder wenn "Bildsymbol aktiv" aktiv ist:
Auswahl des Bildsymbols, dessen Farbe nach Zustand umgeschaltet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PictureSymbol"


ID_ELE_PROP281

Interne ID: ID_ELE_PROP281

Nur Füllfläche einfärben

Aktiv: Die Farbumschaltung betrifft nur die Füllfläche.
Inaktiv: Die Farbumschaltung betrifft auch die Linien.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FillAreaOnly"


ID_ELE_PROP282

Interne ID: ID_ELE_PROP282

Blinken der Haupt-Variable übernehmen

Aktiv: Das Blinkattribut der Hauptvariablen wird übernommen und kann auf dem Element quittiert werden.
Inaktiv: Kein Blinken tritt auf.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BlinkingFromVariable"


ID_ELE_PROP283

Interne ID: ID_ELE_PROP283

Blinken aller Variablen berücksichtigen

Nur verfügbar, wenn "Blinken von Hauptvariable übernehmen" aktiv ist:
Aktiv: Die Blinkattribute aller Variablen werden übernommen.
Inaktiv: Nur das Blinkattribut der Hauptvariable wird übernommen oder es gibt überhaupt kein blinken (abhängig von der Eigenschaft "Blinken von Hauptvariable übernehmen").

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BlinkingFromAllVariables"


ID_ELE_PROP284

Interne ID: ID_ELE_PROP284

Blinkhintergrund transparent

Aktiv: Der Symbolhintergrund ist beim Blinken transparent (Bitmaphintergrund ist nicht transparent darstellbar).
Inaktiv: Der Symbolhintergrund ist nicht transparent.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BlinkingBackGroundTransparent"


ID_ELE_PROP285

Interne ID: ID_ELE_PROP285

Blinkhintergrundfarbe

Hintergrundfarbe bei nicht gesetzter Option "Blinkhintergrund transparent".

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BlinkingBackColor"


ID_ELE_PROP286

Interne ID: ID_ELE_PROP286

Status der Hauptvariable anzeigen

Mit der Markierung der Option "Status anzeigen" wird im Onlinebetrieb bei der Betätigung der rechten Maustaste zusätzlich zur Variablenanzeige auch die aktuelle Statusbitbelegung für die hinterlegte Variable angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowState"


ID_ELE_PROP287

Interne ID: ID_ELE_PROP287

Status anzeigen mit Quadrat

Wenn ein Ausnahmestatus (z.B. "gestört") ansteht, so wird rechts oben in der Elementfläche eine rote Markierung gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RedPoint"


ID_ELE_PROP288

Interne ID: ID_ELE_PROP288

Topologischer Typ

Topologischer Typ

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TopologyType"


ID_ELE_PROP289

Interne ID: ID_ELE_PROP289

Transformatorseite

Transformatorseite

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TransformerSide"


ID_ELE_PROP290

Interne ID: ID_ELE_PROP290

Speisungsnummer

Speisungsnummer

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SupplyNumber"


ID_ELE_PROP291

Interne ID: ID_ELE_PROP291

Konfiguration und Test

Öffnet den Dialog zur Definition der Zustände.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StateAndTest"


ID_ELE_PROP292

Interne ID: ID_ELE_PROP292

Farbe der Haupt-Variable übernehmen

Aktiv: Die Füllfarbe bei eingebetteten Symbolen und Symbolen aus Bibliothek wird beim Zustand Default von der Hauptvariablen übernommen, wenn bei dieser eine Grenzwertverletzung vorliegt.
Das bedeutet: Solange eine Grenzwertverletzung der Hauptvariablen besteht, wird die Füllfarbe aus der Grenzwertfarbe übernommen. Die Farbdefinition bei den Zuständen wird also überschrieben. Weitere Zustandsattribute wie z.B. Blinken, Transparenz oder Original Symbolfarbe werden jedoch aus der Zustandsdefinition übernommen. Auf Bitmapdarstellung hat diese Eigenschaft keine Auswirkung.

Ausnahme: Ist beim Zustand Default die Eigenschaft Original Symbolfarbe aktiviert, wird immer die originale Symbolfarbe verwendet.
Inaktiv: Die Farbe der Hauptvariablen hat keinen Einfluss auf die dargestellten Farben des Combi-Elements.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorFromVariable"


ID_ELE_PROP294

Interne ID: ID_ELE_PROP294

Gedrückt Zustand halten

Nur verfügbar wenn die Eigenschaften Schalter, Taster und Sofortreaktion aktiv sind.

Interne ID: ID_ELE_PROP294

Sofortreaktion

Nur verfügbar, wenn Schalter aktiv ist:
Aktiv: Der Schalter ändert in der Runtime sofort seine Stellung, unabhängig davon, ob das verknüpfte Bit in der Steuerung tatsächlich gesetzt wurde, oder nicht. Im nächsten Treiberupdatezyklus wird das Bit dann aus der Steuerung gelesen. Der Schalter wird dann an die tatsächliche Bitstellung in der Steuerung wieder angepasst.
Achtung: Der Schalter ist optisch erst wieder bedienbar, wenn der Wert aus der Steuerung gelesen wurde.

Inaktiv: Der Schalter ändert seine Stellung erst, nachdem das Bit zur SPS abgesetzt und dann wieder gelesen wurde.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"

Interne ID: ID_ELE_PROP294

Taster

Nur verfügbar, wenn Schalter aktiv ist. (Ausnahme: Im Dynamischen Element Schalter immer verfügbar.)
Aktiv: Der Sollzustand - definiert in der Eigenschaft Taster EIN - wird nur solange hergestellt, wie die linke Maustaste gedrückt bleibt, aber mindestens die Haltezeit [ms] lang.
Inaktiv: Der Sollzustand bleibt, auch wenn die Maustaste losgelassen wird.
Default: inaktiv.

Interne ID: ID_ELE_PROP294

Haltezeit [ms]

Nur verfügbar, wenn Schalter aktiv ist:
Wenn Taster aktiv ist: Zeit (in ms), die ein Zustand gehalten wird, ausgehend vom Linksklick auf das entsprechende Element.

Wenn Taster inaktiv ist: Reaktionsverzögerung auf Linksklick.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"

Interne ID: ID_ELE_PROP294

Taster EIN

Nur verfügbar, wenn Taster aktiv ist:
Aktiv: Taster schaltet auf EIN.
Inaktiv: Taster schaltet auf AUS.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"

Interne ID: ID_ELE_PROP294

Schalter

Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

Interne ID: ID_ELE_PROP294

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"

Aktiv: Das Element schaltet den Wert einer Bit-Variable.
Inaktiv: Das Element führt eine Funktion aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"

Aktiv: Solange die Maustaste auf diesem Element gedrückt bleibt, ändert sich die grafische Darstellung nicht - unabhängig davon, ob sich der Wert in der SPS ändert. Beim Element Schalter muss dafür auch die Eigenschaft 3D aktiv sein.
Inaktiv: Das Element stellt immer den Wert der Variablen aus der SPS dar.

Interne ID: ID_ELE_PROP294

3D

Aktiv: Das Element wird 3-dimensional dargestellt.
Inaktiv: Das Element wird flach dargestellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StayPressed"


ID_ELE_PROP296

Interne ID: ID_ELE_PROP296

Konfiguration

Öffnet den Dialog zur Definition der Zustände.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Status"


ID_ELE_PROP301

Interne ID: ID_ELE_PROP301

Zeit für den Textwechsel [s]

Bei mehreren gesetzten Bits der Zeilenvariablen erfolgt nach der projektierten Zeit automatisch die Textumschaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextChangeTime"


ID_ELE_PROP302

Interne ID: ID_ELE_PROP302

Textdatei

Auswahl der Textdatei.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MessageText"


ID_ELE_PROP303

Interne ID: ID_ELE_PROP303

Spaltenauswahl

Die Spaltenvariable muss eine Wortvariable sein und definiert die Spaltenposition, aus der der Text genommen wird.

ACHTUNG: Die Spaltenvariable muss vor der Zeilenvariable ausgewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"


ID_ELE_PROP304

Interne ID: ID_ELE_PROP304

Zeilenaktivierung

Die Zeilenvariable definiert die Zeilenposition, aus der der Text genommen wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColVars"


ID_ELE_PROP306

Interne ID: ID_ELE_PROP306

ActiveX Einstellungen

Auswahl des ActiveX-Elements und der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ActiveX"


ID_ELE_PROP312

Interne ID: ID_ELE_PROP312

Helligkeit aussen

Nur verfügbar, wenn "Über Helligkeitswerte" aktiv ist:
Helligkeit an der Aussenseite des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OuterBrightness"


ID_ELE_PROP313

Interne ID: ID_ELE_PROP313

Helligkeit innen

Nur verfügbar, wenn "Über Helligkeitswerte" aktiv ist:
Helligkeit in der Mitte des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InnerBrightness"


ID_ELE_PROP314

Interne ID: ID_ELE_PROP314

Farbverlauf versetzt

Wie weit soll der Lichteffekt von der Mitte des Elements versetzt sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Shifted"


ID_ELE_PROP321

Interne ID: ID_ELE_PROP321

Änderung X-Richtung aktiv

Aktiv: Horizontales Bewegen des verknüpften Elements ist verfügbar.
Inaktiv: Horizontales Bewegen ist nicht verfügbar.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsXActive"


ID_ELE_PROP322

Interne ID: ID_ELE_PROP322

Variable

Name der Variable für das horizontale Bewegen des Elements.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XVariable"


ID_ELE_PROP323

Interne ID: ID_ELE_PROP323

Min. Variablenwert

Minimaler Variablenwert für das horizontale Bewegen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XVarMin"


ID_ELE_PROP324

Interne ID: ID_ELE_PROP324

Max. Variablenwert

Maximaler Variablenwert für das horizontale Bewegen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XVarMax"


ID_ELE_PROP325

Interne ID: ID_ELE_PROP325

Min. Bewegung [Pixel]

Horizontale Position des Elements für minimalen Variablenwert (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XViewMin"


ID_ELE_PROP326

Interne ID: ID_ELE_PROP326

Max. Bewegung [Pixel]

Horizontale Position des Elements für maximalen Variablenwert (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XViewMax"


ID_ELE_PROP327

Interne ID: ID_ELE_PROP327

Änderung Y-Richtung aktiv

Aktiv: Vertikales Bewegen des verknüpften Elements ist verfügbar.
Inaktiv: Vertikales Bewegen ist nicht verfügbar.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsYActive"


ID_ELE_PROP328

Interne ID: ID_ELE_PROP328

Variable

Name der Variable für das vertikale Bewegen des Elements.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YVariable"


ID_ELE_PROP329

Interne ID: ID_ELE_PROP329

Min. Variablenwert

Minimaler Variablenwert für das vertikale Bewegen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YVarMin"


ID_ELE_PROP330

Interne ID: ID_ELE_PROP330

Max. Variablenwert

Maximaler Variablenwert für das vertikale Bewegen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YVarMax"


ID_ELE_PROP331

Interne ID: ID_ELE_PROP331

Min. Bewegung [Pixel]

Vertikale Position des Elements für minimalen Variablenwert (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YViewMin"


ID_ELE_PROP332

Interne ID: ID_ELE_PROP332

Max. Bewegung [Pixel]

Vertikale Position des Elements für maximalen Variablenwert (in Pixel).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YViewMax"


ID_ELE_PROP333

Interne ID: ID_ELE_PROP333

Änderung Breite aktiv

Aktiv: Zoomen der Breite des verknüpften Elements ist verfügbar.
Inaktiv: Zoomen der Breite ist nicht verfügbar.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsXZoomActive"


ID_ELE_PROP334

Interne ID: ID_ELE_PROP334

Variable

Name der Variable für das Zoomen der Breite des Elements.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XZoomVariable"


ID_ELE_PROP335

Interne ID: ID_ELE_PROP335

Min. Variablenwert

Minimaler Variablenwert für das Zoomen der Breite des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XZoomVarMin"


ID_ELE_PROP336

Interne ID: ID_ELE_PROP336

Max. Variablenwert

Maximaler Variablenwert für das Zoomen der Breite des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XZoomVarMax"


ID_ELE_PROP337

Interne ID: ID_ELE_PROP337

Min. Breite [%]

Zoomfaktor der Breite des Elements für den minimalen Variablenwert (in %).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XZoomViewMin"


ID_ELE_PROP338

Interne ID: ID_ELE_PROP338

Max. Breite [%]

Zoomfaktor der Breite des Elements für den maximalen Variablenwert (in %).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XZoomViewMax"


ID_ELE_PROP339

Interne ID: ID_ELE_PROP339

Änderung Höhe aktiv

Zoomen der Höhe des Elements aktivieren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsYZoomActive"


ID_ELE_PROP340

Interne ID: ID_ELE_PROP340

Variable

Name der Variable für das Zoomen der Höhe des Elements.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YZoomVariable"


ID_ELE_PROP341

Interne ID: ID_ELE_PROP341

Min. Variablenwert

Minimaler Variablenwert für das Zoomen der Höhe des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YZoomVarMin"


ID_ELE_PROP342

Interne ID: ID_ELE_PROP342

Max. Variablenwert

Maximaler Variablenwert für das Zoomen der Höhe des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YZoomVarMax"


ID_ELE_PROP343

Interne ID: ID_ELE_PROP343

Min. Höhe [%]

Zoomfaktor der Höhe des Elements für den minimalen Variablenwert (in %).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YZoomViewMin"


ID_ELE_PROP344

Interne ID: ID_ELE_PROP344

Max. Höhe [%]

Zoomfaktor der Höhe des Elements für den maximalen Variablenwert (in %).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YZoomViewMax"


ID_ELE_PROP345

Interne ID: ID_ELE_PROP345

Drehen aktiv

Aktiv: Drehen des verknüpften Elements ist verfügbar.
Inaktiv: Drehen ist nicht verfügbar.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsTwistActive"


ID_ELE_PROP346

Interne ID: ID_ELE_PROP346

Variable

Name der Variable für das Drehen des Elements.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwistVariable"


ID_ELE_PROP347

Interne ID: ID_ELE_PROP347

Min. Variablenwert

Minimaler Variablenwert für das Drehen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwistVarMin"


ID_ELE_PROP348

Interne ID: ID_ELE_PROP348

Max. Variablenwert

Maximaler Variablenwert für das Drehen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwistVarMax"


ID_ELE_PROP349

Interne ID: ID_ELE_PROP349

Min. Drehung [°]

Drehwinkel des Elements für den minimalen Variablenwert (in °).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwistViewMin"


ID_ELE_PROP350

Interne ID: ID_ELE_PROP350

Max. Drehung [°]

Drehwinkel des Elements für den maximalen Variablenwert (in °).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwistViewMax"


ID_ELE_PROP351

Interne ID: ID_ELE_PROP351

Einträge

Nur verfügbar, wenn die Eigenschaft Einträge aus Stringvariable inaktiv ist.

Interne ID: ID_ELE_PROP351

Einträge aus Stringvariable

Aktiv: Einträge für Combo-/Listbox werden über die in der Eigenschaft Variable ausgewählte Stringvariable definiert.

Interne ID: ID_ELE_PROP351

Variable

Nur verfügbar, wenn Eigenschaft Einträge aus Stringvariable aktiv ist.

Auswahl der Stringvariable, die die Einträge für Combo-/Listbox enthält. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "States"

Inaktiv: Einträge werden im Editor über den Dialog der Eigenschaft Einträge definiert.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "States"

Klick auf Schaltfläche ... öffnet den Dialog zur Definition der Einträge für eine statische List-/Combobox.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "States"


ID_ELE_PROP354

Interne ID: ID_ELE_PROP354

Füllfarbe

Hintergrundfarbe des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonFillColor"


ID_ELE_PROP357

Interne ID: ID_ELE_PROP357

Global

Alarme werden systemweit berücksichtigt.
Hauptverwendung: Summenalarm der globalen Alarmliste.
Aktiv: Alarme werden unabhängig vom verküpften Bild berücksichtigt.
Die verknüpfte Funktion wird nur zur Bildumschaltung verwendet.

Inaktiv: Nur Alarme des verknüpften Bildes werden berücksichtigt.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BAGlobal"


ID_ELE_PROP358

Interne ID: ID_ELE_PROP358

Projekt

Auswahl eines einzelnen Projektes oder aller Projekte.

Nur verfügbar, wenn Global aktiv ist.

Einsatz bei mehrhierarchischen Projekten.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BAProjekt"


ID_ELE_PROP359

Interne ID: ID_ELE_PROP359

Priorität

Priorisierung der Alarm/Ereignis-Klassen.
Aktiv: Es wird auch bei Auswahl mehrerer Alarm/Ereignis-Klassen nur eine angezeigt.
Prioritätsregeln:

  1. Je niedriger die Klassennummer, desto höher die Priorität.
  2. Unquittiert höher prior als quittiert.

Inaktiv: alle ausgewählten Klassen werden gleichzeitig (nebeneinander) angezeigt.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BAPriorität"


ID_ELE_PROP360

Interne ID: ID_ELE_PROP360

Unsichtbar

Das Element wird in der Runtime nicht angezeigt

Aktiv: Das Element wird in der Runtime ausgeblendet.
Wird angewendet, wenn das Element nur eine Abbildungvariable ansteuern aber selbst nicht angezeigt werden soll.

Inaktiv: Das Element wird als Button angezeigt.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BAUnsichtbar"


ID_ELE_PROP361

Interne ID: ID_ELE_PROP361

Alarm/Ereignis-Klassen

Auswahl der anzuzeigenden Alarm/Ereignis-Klassen.

Öffnet den Klassenauswahlkatalog.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BAKlassen"


ID_ELE_PROP362

Interne ID: ID_ELE_PROP362

Erste abzubildende Alarm/Ereignis-Klasse

Ab dieser Klasse werden die Klassenzustände auf die Abbildungsvariable geschrieben.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset"


ID_ELE_PROP363

Interne ID: ID_ELE_PROP363

Quelle

Ersetzen von Variablen und/oder Funktionen in einem Symbol:

Geben Sie die Quellvariablen/Quellfunktion an. Dabei können Platzhalter (?, *) verwendet werden. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Ziele definieren Sie dann über die Eigenschaft Ziel.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Interne ID: ID_ELE_PROP363

Ziel

Ersetzen von Variablen und/oder Funktionen in einem Symbol:
Geben Sie die neu zuzordnenden Variablen/Funktionen an. Dabei sind keine Platzhalter erlaubt. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Quellen definieren Sie zuvor über die Eigenschaft Quelle.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubstituteSource"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubstituteSource"


ID_ELE_PROP364

Interne ID: ID_ELE_PROP364

Ziel

Ersetzen von Variablen und/oder Funktionen in einem Symbol:
Geben Sie die neu zuzordnenden Variablen/Funktionen an. Dabei sind keine Platzhalter erlaubt. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Quellen definieren Sie zuvor über die Eigenschaft Quelle.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Interne ID: ID_ELE_PROP364

Quelle

Ersetzen von Variablen und/oder Funktionen in einem Symbol:

Geben Sie die Quellvariablen/Quellfunktion an. Dabei können Platzhalter (?, *) verwendet werden. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Ziele definieren Sie dann über die Eigenschaft Ziel.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubstituteDestination"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubstituteDestination"


ID_ELE_PROP365

Interne ID: ID_ELE_PROP365

über Variablennamen

Aktiv: Das Ersetzen der Verknüpfungen wird über den Namen der Variablen realisiert.
Inaktiv Das Ersetzen der Verknüpfungen wird über die Kennung der Variablen realisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubstituteOnName"


ID_ELE_PROP366

Interne ID: ID_ELE_PROP366

Groß-/Kleinschreibung beachten

Aktiv: Die Gross/Kleinschreibung in den Eingaben für die Quelle und das Ziel zum ersetzen von Variablen und/oder Funktionen wird berücksichtigt.
Inaktiv: Die Gross/Kleinschreibung in den Eingaben für die Quelle und das Ziel zum ersetzen von Variablen und/oder Funktionen wird nicht berücksichtigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubstituteMatchCase"


ID_ELE_PROP377

Interne ID: ID_ELE_PROP377

Fokus Position links/rechts

Definiert die horizontale Position bei Tastaturbedienung zur Runtime. Position wird über Kontextmenü und Mauseingabe im Hauptfenster definiert und kann hier nicht verändert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TABOrderH"


ID_ELE_PROP378

Interne ID: ID_ELE_PROP378

Fokus Position oben/unten

Definiert die vertikale Position bei Tastaturbedienung zur Runtime. Position wird über Kontextmenü und Mauseingabe im Hauptfenster definiert und kann hier nicht verändert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TABOrderV"


ID_ELE_PROP379

Interne ID: ID_ELE_PROP379

Hauptticks

Definiert Hauptteilstriche der Skala.
Wert gibt Abstand zwischen den Hauptticks an. Wert muss größer oder gleich dem Wert der Nebenticks sein. Bei gleichem Wert werden keine Nebenticks angezeigt.

Interne ID: ID_ELE_PROP379

Nebenticks

Definiert Unterteilung der Skala zwischen Hauptticks.

Wert gibt Abstand zwischen den Nebenticks an. Wert muss kleiner oder gleich dem Wert der Hauptticks sein. Bei gleichem Wert werden keine Nebenticks angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MainTicks"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MainTicks"


ID_ELE_PROP380

Interne ID: ID_ELE_PROP380

Nebenticks

Definiert Unterteilung der Skala zwischen Hauptticks.

Interne ID: ID_ELE_PROP380

Hauptticks

Definiert Hauptteilstriche der Skala.
Wert gibt Abstand zwischen den Hauptticks an. Wert muss größer oder gleich dem Wert der Nebenticks sein. Bei gleichem Wert werden keine Nebenticks angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmallTicks"

Wert gibt Abstand zwischen den Nebenticks an. Wert muss kleiner oder gleich dem Wert der Hauptticks sein. Bei gleichem Wert werden keine Nebenticks angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmallTicks"


ID_ELE_PROP381

Interne ID: ID_ELE_PROP381

Abbildung der selektierten Alarm/Ereignis-Klassen

Modus wie die Klassenzustände auf die Abbildungsvariable geschrieben werden.

Aktiv: Die Zustände der ausgewählten Alarm/Ereignis-Klassen werden lückenlos auf die Abbildungsvariable geschrieben.
z.B. ausgewählte Klassen 1,3 -> Klasse1: Bits 0,1; Klasse 3: Bits 2,3

Inaktiv: Die Zustände der ausgewählten Alarm/Ereignis-Klassen werden auf feste Positionen der Abbildungsvariablen geschrieben.
z.B. ausgewählte Klassen 1,3 -> Klasse1: Bits 0,1;0 (Klasse 2: Bits 2.3); Klasse 3: Bits 4,5

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AbbModus"


ID_ELE_PROP382

Interne ID: ID_ELE_PROP382

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCType"


ID_ELE_PROP383

Interne ID: ID_ELE_PROP383

Quelle

Nur verfügbar, wenn ein Funktionstyp Quelle oder Trafo ausgewählt ist:
Auswahl der verknüpften Quelle/Trafos.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCSourceID"


ID_ELE_PROP384

Interne ID: ID_ELE_PROP384

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCUseColor"


ID_ELE_PROP385

Interne ID: ID_ELE_PROP385

Mehrfachversorgung darstellen

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.
Definiert die Darstellungsart, wenn das Element mit mehreren aktiven Quellen verbunden ist:
höchst-priore Quelle: Es wird nur die Farbe der Quelle mit der höchsten Priorität verwendet.
zwei höchst-priore Quellen: Die unterschiedlichen Farben der beiden Quellen mit der höchsten Priorität werden strichliert dargestellt.
alternative Farbe: Alternative Farbe für die Einfärbung bei Mehrfachversorgung.

Interne ID: ID_ELE_PROP385

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCMultiSource"

Default: höchst-priore Quelle

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCMultiSource"


ID_ELE_PROP386

Interne ID: ID_ELE_PROP386

Link-Nummer

Nur verfügbar, wenn ein Funktionstyp Link ausgewählt ist:
Identifikationsnummer des Links. Ein anderes Link auf einem anderen Bild mit derselben Identifikationsnummer wird die Daten des Quelllinks übernehmen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCLinkID"


ID_ELE_PROP387

Interne ID: ID_ELE_PROP387

gesicherte Versorgung darstellen

Steht nur zur Verfügung, wenn Farbe aus ALC aktiviert wurde.

Interne ID: ID_ELE_PROP387

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""

Auswahl, wie die gesicherte Versorgung dargestellt werden soll:

  • doppelte Breite
  • doppelte Helligkeit
  • normal

Default: normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_ELE_PROP388

Interne ID: ID_ELE_PROP388

Vorrang bei Darstellung

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.

Interne ID: ID_ELE_PROP388

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCPrecedence"

Definiert den Vorrang der Darstellung, wenn das Element mit mehreren aktiven Quellen verbunden ist.
Mehrfachversorgung: Das Element wird entsprechend den Regeln der Mehrfachversorgung dargestellt.
gesicherte Versorgung: Das Element wird entsprechend den Regeln der gesicherten Versorgung dargestellt.
Kein Vorrang: Die Einfärberegeln für Mehrfachversorgung und für Gesicherte Versorgung werden gleichzeitig angewandt, falls beide Kriterien erfüllt werden

Default: Mehrfachversorgung
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCPrecedence"


ID_ELE_PROP389

Interne ID: ID_ELE_PROP389

Beim Verlassen zurücksetzen

Nur verfügbar wenn Taster aktiv ist:
Wird der Mauszeiger bei gedrückter Maustaste vom Taster weg bewegt, so wird der Wert der Variable automatisch zurückgesetzt.

Interne ID: ID_ELE_PROP389

Taster

Nur verfügbar, wenn Schalter aktiv ist. (Ausnahme: Im Dynamischen Element Schalter immer verfügbar.)
Aktiv: Der Sollzustand - definiert in der Eigenschaft Taster EIN - wird nur solange hergestellt, wie die linke Maustaste gedrückt bleibt, aber mindestens die Haltezeit [ms] lang.
Inaktiv: Der Sollzustand bleibt, auch wenn die Maustaste losgelassen wird.
Default: inaktiv.

Interne ID: ID_ELE_PROP389

Haltezeit [ms]

Nur verfügbar, wenn Schalter aktiv ist:
Wenn Taster aktiv ist: Zeit (in ms), die ein Zustand gehalten wird, ausgehend vom Linksklick auf das entsprechende Element.

Wenn Taster inaktiv ist: Reaktionsverzögerung auf Linksklick.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ResetOnLeave"

Interne ID: ID_ELE_PROP389

Taster EIN

Nur verfügbar, wenn Taster aktiv ist:
Aktiv: Taster schaltet auf EIN.
Inaktiv: Taster schaltet auf AUS.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ResetOnLeave"

Interne ID: ID_ELE_PROP389

Schalter

Nur verfügbar wenn die Eigenschaft SW setzen aktiv nicht aktiviert wurde.

Interne ID: ID_ELE_PROP389

SW setzen aktiv

Aktiv: Für das entsprechende dynamische Element ist das Setzen von Sollwerten erlaubt.
Inaktiv: In diesem Element ist die Variable schreibgeschützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ResetOnLeave"

Aktiv: Das Element schaltet den Wert einer Bit-Variable.
Inaktiv: Das Element führt eine Funktion aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ResetOnLeave"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ResetOnLeave"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ResetOnLeave"


ID_ELE_PROP391

Interne ID: ID_ELE_PROP391

Rahmen-/Schattenfarbe

Nur verfügbar, wenn als Rahmenart Rahmen oder Schatten ausgewählt wurde.

Interne ID: ID_ELE_PROP391

Rahmenart

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
Rahmen: Das Element kann mit einem Rahmen versehen werden.
Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

Interne ID: ID_ELE_PROP391

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP391

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP391

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameColor"

Default: Kein Rahmen/Schatten

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameColor"

Definition der Farbe des Rahmens oder des Schattens. Die Farbe kann als Hexadezimalwert direkt in das Feld eingegeben oder nach einem Klick auf die Schaltfläche ... ausgewählt werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameColor"


ID_ELE_PROP392

Interne ID: ID_ELE_PROP392

Abstand [Pixel]

Nur verfügbar, wenn als Rahmenart Rahmen oder Schatten gewählt wurde.

Interne ID: ID_ELE_PROP392

Rahmenart

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
Rahmen: Das Element kann mit einem Rahmen versehen werden.
Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

Interne ID: ID_ELE_PROP392

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP392

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP392

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameOffset"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameOffset"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameOffset"

Default: Kein Rahmen/Schatten

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameOffset"

Abstand des Rahmens oder Schattens zum Element in Pixel. Die Richtung des Abstands wird beim Schatten von der Eigenschaft Winkel [°] bestimmt. Die Größe des Wertebereichs ist von der Bildschirm-Auflösung abhängig.

Interne ID: ID_ELE_PROP392

Winkel [°]

Nur verfügbar, wenn als Rahmenart Schatten und die Projekteigenschaft Grafikqualität gewählt wurde.

Winkel in Grad, in dem sich der Schatten verschiebt.

Werte: 0° bis 359°. 0° entspricht der rechten äußeren Position (3 Uhr), wird gegen den Uhrzeigersinn fortgesetzt.

Default: 0°

Klick auf die Schaltfläche ... öffnet Schieberegler.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameOffset"

Default: 10

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameOffset"


ID_ELE_PROP393

Interne ID: ID_ELE_PROP393

Linienbreite [Pixel]

Definition der Linienbreite für den Rahmen in Pixel.

Default: 1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameWidth"


ID_ELE_PROP394

Interne ID: ID_ELE_PROP394

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP394

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeText"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP394

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeText"

Interne ID: ID_ELE_PROP394

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeText"

Interne ID: ID_ELE_PROP394

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeText"

Interne ID: ID_ELE_PROP394

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeText"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeText"


ID_ELE_PROP395

Interne ID: ID_ELE_PROP395

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Interne ID: ID_ELE_PROP395

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP395

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Normal"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP395

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Normal"

Interne ID: ID_ELE_PROP395

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Normal"

Interne ID: ID_ELE_PROP395

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Normal"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Normal"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Normal"


ID_ELE_PROP396

Interne ID: ID_ELE_PROP396

Text Zeile 1 mit Shift

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, wenn die Umschalttaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Interne ID: ID_ELE_PROP396

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP396

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Shift"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP396

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Shift"

Interne ID: ID_ELE_PROP396

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Shift"

Interne ID: ID_ELE_PROP396

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Shift"

Interne ID: ID_ELE_PROP396

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Shift"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Shift"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Shift"


ID_ELE_PROP397

Interne ID: ID_ELE_PROP397

Text Zeile 1 mit Strg

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, wenn die Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Interne ID: ID_ELE_PROP397

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP397

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Ctrl"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP397

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Ctrl"

Interne ID: ID_ELE_PROP397

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Ctrl"

Interne ID: ID_ELE_PROP397

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Ctrl"

Interne ID: ID_ELE_PROP397

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Ctrl"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Ctrl"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1Ctrl"


ID_ELE_PROP398

Interne ID: ID_ELE_PROP398

Text Zeile 1 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Interne ID: ID_ELE_PROP398

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP398

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1CtrlAlt"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP398

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1CtrlAlt"

Interne ID: ID_ELE_PROP398

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1CtrlAlt"

Interne ID: ID_ELE_PROP398

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1CtrlAlt"

Interne ID: ID_ELE_PROP398

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1CtrlAlt"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1CtrlAlt"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text1CtrlAlt"


ID_ELE_PROP399

Interne ID: ID_ELE_PROP399

Text Zeile 2 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen..

Interne ID: ID_ELE_PROP399

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP399

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Normal"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP399

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Normal"

Interne ID: ID_ELE_PROP399

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Normal"

Interne ID: ID_ELE_PROP399

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Normal"

Interne ID: ID_ELE_PROP399

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Normal"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Normal"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Normal"


ID_ELE_PROP400

Interne ID: ID_ELE_PROP400

Text Zeile 2 mit Shift

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Umschalttaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Interne ID: ID_ELE_PROP400

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP400

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Shift"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP400

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Shift"

Interne ID: ID_ELE_PROP400

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Shift"

Interne ID: ID_ELE_PROP400

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Shift"

Interne ID: ID_ELE_PROP400

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Shift"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Shift"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Shift"


ID_ELE_PROP401

Interne ID: ID_ELE_PROP401

Text Zeile 2 mit Strg

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Interne ID: ID_ELE_PROP401

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP401

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Ctrl"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP401

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Ctrl"

Interne ID: ID_ELE_PROP401

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Ctrl"

Interne ID: ID_ELE_PROP401

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Ctrl"

Interne ID: ID_ELE_PROP401

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Ctrl"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Ctrl"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2Ctrl"


ID_ELE_PROP402

Interne ID: ID_ELE_PROP402

Text Zeile 2 mit Strg + Alt (Alt Gr)

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der zweiten Textzeile im Button, wenn die Steuerungstaste und Alt Gr gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Interne ID: ID_ELE_PROP402

Beschriftung mit Steuertasten ändern

Nur verfügbar, wenn Sie Automatische Beschriftung in den Eigenschaften des Bildes deaktiviert haben.

Interne ID: ID_ELE_PROP402

Automatische Beschriftung

aktiv: Für die Buchstaben, Zahlen und F-Tasten eines Bildes vom Bildtyp Keyboard wird die Originalbeschriftung des Tastaturlayouts vom Betriebssystem übernommen. Es können keine alternativen Beschriftungen definiert werden. Wurden Tasten bereits anders beschriftet, wird zur Runtime wieder die Originalbeschriftung verwendet. Funktionstasten wie Tab oder Umschalt können weiter alternativ beschriftet werden.

inaktiv: Alle Tasten können individuell beschriftet werden und werden zur Runtime entsprechend angezeigt.

Default: aktiv

Hinweis: Der Ziffernblock der Tastatur wird nicht automatisch beschriftet und die Beschriftung kann zur Runtime jederzeit angepasst werden, unabhängig von der Einstellung dieser Eigenschaft.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2CtrlAlt"

aktiv: Zur Beschriftung des Buttons benutzen Sie Text Zeile 1 Normal bis Text Zeile 2 mit Strg + Alt (Alt Gr). Die Eingabe unter Text Zeile 1 und Text Zeile 2 ist hinfällig.

Interne ID: ID_ELE_PROP402

Text Zeile 2

Zweite Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Hinweis: Diese Eigenschaft dient der Kompatibilität mit älteren Versionen. In aktuellen Versionen: Eigenschaft Text Zeile 1 verwenden und neue Zeilen mit \n beginnen.

Achtung: Diese Zeile muss leer bleiben, wenn der automatische Zeilenumbruch verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2CtrlAlt"

Interne ID: ID_ELE_PROP402

Text Zeile 1

Erste Textzeile im Button.
Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Um das &-Zeichen selbst darzustellen muss ”&&” eingegeben werden.

Mit der Zeichenfolge \n kann ein Zeilenumbruch erzwungen werden.

Achtung: Um \n zu nutzen, muss die Eigenschaft Text Zeile 2 leer bleiben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2CtrlAlt"

Interne ID: ID_ELE_PROP402

Text Zeile 1 Normal

Nur verfügbar, wenn Beschriftung mit Steuertasten ändern aktiv ist.
Beschriftung der erste Textzeile im Button, ohne dass eine Steuerungstaste gedrückt ist.
Hinweis: Mit dem &-Zeichen wird das nächste Zeichen in der Runtime unterstrichen dargestellt. Geben Sie ”&&” ein, um das &-Zeichen selbst darzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2CtrlAlt"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2CtrlAlt"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text2CtrlAlt"


ID_ELE_PROP403

Interne ID: ID_ELE_PROP403

Anfangstyp

Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.

Interne ID: ID_ELE_PROP403

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP403

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP403

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapStart"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapStart"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapStart"

Definiert Symbol für Startpunkt der Linie. Klick auf Feld öffnet Dialog zur Auswahl eines Elements.

Für Kreisbogen und Kreissegment nur verfügbar, wenn Füllmuster auf ohne gestellt wurde.

Interne ID: ID_ELE_PROP403

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_PROP403

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapStart"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapStart"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapStart"


ID_ELE_PROP404

Interne ID: ID_ELE_PROP404

Endtyp

Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.

Interne ID: ID_ELE_PROP404

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP404

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP404

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapEnd"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapEnd"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapEnd"

Definiert Symbol für Endpunkt der Linie. Klick auf Feld öffnet Dialog zur Auswahl eines Elements.

Für Kreisbogen und Kreissegment nur verfügbar, wenn Füllmuster auf ohne gestellt wurde.

Interne ID: ID_ELE_PROP404

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_PROP404

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapEnd"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapEnd"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapEnd"


ID_ELE_PROP405

Interne ID: ID_ELE_PROP405

Größe

Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.

Interne ID: ID_ELE_PROP405

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP405

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP405

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapScale"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapScale"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapScale"

Definiert den Vergrößerungsfaktor für die Linienbreite des Pfeils. Der Faktor bezieht sich auf die Linienbreite des Vektorelements wie in der Eigenschaft Linienbreite [Pixel] definiert.

Für Kreisbogen und Kreissegment nur verfügbar, wennFüllmuster auf ohne gestellt wurde.

Interne ID: ID_ELE_PROP405

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_PROP405

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapScale"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapScale"

Wert: größer oder gleich 1

Default: 4

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCapScale"


ID_ELE_PROP_BACKCOLOR2

Interne ID: ID_ELE_PROP_BACKCOLOR2

Verlaufsfarbe

Nur verfügbar, wenn die Eigenschaft Füllmuster auf Farbverlauf aktiv ist und die Projekteigenschaft Grafikqualität aktiv ist.

Interne ID: ID_ELE_PROP_BACKCOLOR2

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_BACKCOLOR2

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_BACKCOLOR2

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Interne ID: ID_ELE_PROP_BACKCOLOR2

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_PROP_BACKCOLOR2

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Definiert zweite Farbe für den Farbverlauf. Bei Auswahl von Automatisch ändert sich der Farbwert abhängig vom Wert der Füllfarbe.

Interne ID: ID_ELE_PROP_BACKCOLOR2

Füllfarbe

Nur verfügbar, wenn die Eigenschaft Transparent auf inaktiv geschaltet wurde.

Interne ID: ID_ELE_PROP_BACKCOLOR2

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Definiert die Füllfarbe des Elements. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Die Füllfarbe kann dynamisch geändert werden über die Eigenschaft Füllfarbe aus der Gruppe Farben dynamisch .

Interne ID: ID_ELE_PROP_BACKCOLOR2

Farben dynamisch

Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Interne ID: ID_ELE_PROP_BACKCOLOR2

Füllfarbe

Name der Variable, deren Grenzwertfarben die Hintergrund-/Füllfarbe des Elements beeinflussen sollen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Hinweis: Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Achtung: Im Weltbild Übersichtsfenster haben Farbänderungen im Editor keine Auswirkung zur Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"


ID_ELE_PROP_BACKCOLORBUTTON2

Interne ID: ID_ELE_PROP_BACKCOLORBUTTON2

Verlaufsfarbe

Nur verfügbar, wenn die Eigenschaft Füllung nicht auf einfarbig gesetzt wurde.

Interne ID: ID_ELE_PROP_BACKCOLORBUTTON2

Füllung

Füllung des Buttons:
einfarbig: Kein Verlauf
linear: gleichmäßiger Verlauf
strahlend: Von unten bis zur Mitte Füllfarbe 1, dann Verlauf von Mitte nach oben
punktuell: Verlauf von den Rändern zum Zentrum

punktuell mit Kanten: Verlauf von den Rändern zum Zentrum mit Kantenbildung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Definiert zweite Farbe für den Farbverlauf. Bei Auswahl von Automatisch ändert sich der Farbwert abhängig vom Wert der Füllfarbe.

Interne ID: ID_ELE_PROP_BACKCOLORBUTTON2

Füllfarbe

Nur verfügbar, wenn die Eigenschaft Transparent auf inaktiv geschaltet wurde.

Interne ID: ID_ELE_PROP_BACKCOLORBUTTON2

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Definiert die Füllfarbe des Elements. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Die Füllfarbe kann dynamisch geändert werden über die Eigenschaft Füllfarbe aus der Gruppe Farben dynamisch .

Interne ID: ID_ELE_PROP_BACKCOLORBUTTON2

Farben dynamisch

Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Interne ID: ID_ELE_PROP_BACKCOLORBUTTON2

Füllfarbe

Name der Variable, deren Grenzwertfarben die Hintergrund-/Füllfarbe des Elements beeinflussen sollen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Hinweis: Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Achtung: Im Weltbild Übersichtsfenster haben Farbänderungen im Editor keine Auswirkung zur Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2"


ID_ELE_PROP_COLORGRADIENTANGLE

Interne ID: ID_ELE_PROP_COLORGRADIENTANGLE

Winkel [°]

Definiert die Richtung des Farbverlaufs ausgehend vom Mittelpunkt des Elements.

Werte: 0° bis 360°

Default: 0°

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngle"


ID_ELE_PROP_COLORGRADIENTOFFSET

Interne ID: ID_ELE_PROP_COLORGRADIENTOFFSET

Versatz [%]

Nur verfügbar, wenn bei einem Vektorelement die Eigenschaft Farbverlauf oder beim Dynamischen Element Button die Eigenschaft Füllung gesetzt wurde auf: linear oder punktuell oder punktuell mit Kanten.

Interne ID: ID_ELE_PROP_COLORGRADIENTOFFSET

Füllung

Füllung des Buttons:
einfarbig: Kein Verlauf
linear: gleichmäßiger Verlauf
strahlend: Von unten bis zur Mitte Füllfarbe 1, dann Verlauf von Mitte nach oben
punktuell: Verlauf von den Rändern zum Zentrum

punktuell mit Kanten: Verlauf von den Rändern zum Zentrum mit Kantenbildung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffset"

Interne ID: ID_ELE_PROP_COLORGRADIENTOFFSET

Farbverlauf

Nur verfügbar, wenn Füllmuster auf Farbverlauf gesetzt wurde.

Interne ID: ID_ELE_PROP_COLORGRADIENTOFFSET

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_PROP_COLORGRADIENTOFFSET

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffset"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffset"

Definiert den Farbverlauf für Vektorelemente.

linear: gleichmäßiger Verlauf
punktuell: Verlauf von den Rändern zum Zentrum

punktuell mit Kanten: Verlauf von den Rändern zum Zentrum mit Kantenbildung

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffset"

Definiert den Abstand des Farbverlaufspunktes vom Mittelpunkt des Elements. Dabei handelt es sich um einen Prozentwert.

Werte: 0 beschreibt den Mittelpunkt im Element, 100 den Rand.
Hinweis: Dieser Wert kann auch außerhalb des Elements liegen und ist daher nicht auf 100 beschränkt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffset"


ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

2. Blinkzustand unsichtbar

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in Eigenschaft Variable für Blinken eine Variable definiert sein und die Eigenschaft Blinkfarbe von Grenzwert übernehmen aktiv sein.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Blinkfarbe von Grenzwert übernehmen

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Zusätzlich muss in Eigenschaft Variable für Blinken eien Variable definiert sein.

Aktiv: Übernimmt Farbe für den Glow-Effekt für das Blinken aus dem aktiven Grenzwert der in Eigenschaft Blinkfarbe aus Grenzwert definierten Variablen. Diese Eigenschaft ist unabhängig von der Eigenschaft Einfärben. Der Glow-Effekt wechselt beim Blinken nicht zu unsichtbar, sondern zum aktiv eingestellten Glow Effekt.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Einfärben

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Aktiv: Der Glow-Effekt für das Element wird eingefärbt. Damit wird der gesamte Glow Effekt mit nur einer definierten Farbe dargestellt. Die Farbe kann über die Eigenschaft Farbe oder eine in Eigenschaft Variable für Farbe definierte Variable eingestellt werden. Sind beide Eigenschaften aktiv, wird die Farbe aus Variable für Farbe verwendet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Variable für Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Name der Variablen, deren Grenzwertfarben die Glow-Farbe beeinflussen sollen. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden. Wenn keine Variable verknüpft ist, wird die in der Eigenschaft Farbe definierte Farbe verwendet.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Bestimmt die Farbe des Glow Effekts. Klick auf Schaltfläche ... öffnet Farbpalette zur Auswahl der Farbe. Direkte Eingabe des Hex-Werts in Feld ist möglich.

Default: 0xFFFF90 (Gelb)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Inaktiv: Die Farben des Elementes werden für den Glow-Effekt verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Blinkfarbe aus Grenzwert

Aktiv: Übernimmt Hintergrundfarbe des Blinkens aus dem aktiven Grenzwert der Variablen für Blinken von Grenzwert übernehmen. Element wechselt beim Blinken nicht zu unsichtbar, sondern zur aktiven Hintergrundfarbe.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Blinken von Grenzwert übernehmen

Variable, von deren Grenzwert(en) das Blinken für das Element übernommen werden soll. Klick auf die Schaltfläche ... öffnet den Variablenauswahldialog.

Im Gegensatz zum normalen Blinken blinkt das ganze Element und nicht nur der dargestellte Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Default: inaktiv

Hinweis: Diese Farbe wird nicht berücksichtigt, wenn die Hintergrundfarbe Transparent konfiguriert ist.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Transparent

Aktiv: Deaktiviert die Hintergrundfarbe des Elements.

Bei einem Button bewirkt diese Option einen Unsichtbaren Button. Dieser kann als unsichtbare Schaltfläche über andere Elemente gelegt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Variable für Blinken

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Variable, von deren Grenzwert oder Grenzwerten das Blinken für den Glow-Effekt übernommen werden soll. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_2NDBLINKSTATEVISIBLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"

Aktiv: Der Glow-Effekt wechselt beim Blinken nicht zum eingestellten Glow-Effekt, sondern zu unsichtbar. Dadurch ist ein Blinken zwischen unsichtbar und der Blinkfarbe aus dem Grenzwert möglich.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect2ndBlinkStateVisible"


ID_ELE_PROP_GLOWEFFECT_ACTIVE

Interne ID: ID_ELE_PROP_GLOWEFFECT_ACTIVE

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_ELE_PROP_GLOWEFFECT_ACTIVE

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_ACTIVE

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectActive"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectActive"

Interne ID: ID_ELE_PROP_GLOWEFFECT_ACTIVE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GLOWEFFECT_ACTIVE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_ACTIVE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectActive"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectActive"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectActive"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectActive"


ID_ELE_PROP_GLOWEFFECT_ALPHA

Interne ID: ID_ELE_PROP_GLOWEFFECT_ALPHA

Transparenz [%]

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Interne ID: ID_ELE_PROP_GLOWEFFECT_ALPHA

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_ELE_PROP_GLOWEFFECT_ALPHA

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_ALPHA

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectAlpha"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectAlpha"

Interne ID: ID_ELE_PROP_GLOWEFFECT_ALPHA

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GLOWEFFECT_ALPHA

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_ALPHA

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectAlpha"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectAlpha"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectAlpha"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectAlpha"

Transparenzwert, mit dem der Glow-Effekt auf dem Element dargestellt wird. Einheit: in Prozent. Klick auf Schaltfläche ... öffnet Schieberegler.

Minimum: 0%, unsichtbar

Maximum: 100%, voll deckend

Default: 20%

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectAlpha"


ID_ELE_PROP_GLOWEFFECT_COLOR

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Einfärben

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Aktiv: Der Glow-Effekt für das Element wird eingefärbt. Damit wird der gesamte Glow Effekt mit nur einer definierten Farbe dargestellt. Die Farbe kann über die Eigenschaft Farbe oder eine in Eigenschaft Variable für Farbe definierte Variable eingestellt werden. Sind beide Eigenschaften aktiv, wird die Farbe aus Variable für Farbe verwendet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Variable für Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Name der Variablen, deren Grenzwertfarben die Glow-Farbe beeinflussen sollen. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden. Wenn keine Variable verknüpft ist, wird die in der Eigenschaft Farbe definierte Farbe verwendet.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Inaktiv: Die Farben des Elementes werden für den Glow-Effekt verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_COLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"

Bestimmt die Farbe des Glow Effekts. Klick auf Schaltfläche ... öffnet Farbpalette zur Auswahl der Farbe. Direkte Eingabe des Hex-Werts in Feld ist möglich.

Default: 0xFFFF90 (Gelb)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectColor"


ID_ELE_PROP_GLOWEFFECT_EVENT

Interne ID: ID_ELE_PROP_GLOWEFFECT_EVENT

Nur aktiv wenn gedrückt

Nur verfügbar, wenn Eigenschaft Aktivieren aktiv ist und es sich um eine Button Element handelt.

Interne ID: ID_ELE_PROP_GLOWEFFECT_EVENT

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_ELE_PROP_GLOWEFFECT_EVENT

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_EVENT

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectEvent"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectEvent"

Interne ID: ID_ELE_PROP_GLOWEFFECT_EVENT

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GLOWEFFECT_EVENT

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_EVENT

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectEvent"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectEvent"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectEvent"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectEvent"

Aktiv: Der Glow-Effekt wird nur dargestellt, wenn der Button gedrückt ist. Der Glow-Effekt kann während des Drückens auch die Farbe wechseln, blinken oder unsichtbar geschaltet werden.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectEvent"


ID_ELE_PROP_GLOWEFFECT_SPREAD

Interne ID: ID_ELE_PROP_GLOWEFFECT_SPREAD

Ausbreitung [Pixel]

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Interne ID: ID_ELE_PROP_GLOWEFFECT_SPREAD

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_ELE_PROP_GLOWEFFECT_SPREAD

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_SPREAD

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectSpread"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectSpread"

Interne ID: ID_ELE_PROP_GLOWEFFECT_SPREAD

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GLOWEFFECT_SPREAD

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_SPREAD

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectSpread"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectSpread"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectSpread"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectSpread"

Definiert den Ausbreitungsfaktor für den Glow-Effekt. Dieser wird definiert als Anzahl an Pixel, die auf jeder Seite in die Ausbreitung mit eingerechnet werden.

Minimum: 0, keine Ausbreitung

Maximum: 50

Default: 15

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectSpread"


ID_ELE_PROP_GLOWEFFECT_USECOLOR

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Einfärben

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist.

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Aktivieren

Nur verfügbar, wenn die Projekteigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde und die Projekteigenschaft Windows CE Projekt nicht aktiv ist. Verfügbarkeit ist auch abhängig vom grafischen Element.

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Aktiv: Glow-Effekt wird zur Runtime für das Element angewandt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Aktiv: Der Glow-Effekt für das Element wird eingefärbt. Damit wird der gesamte Glow Effekt mit nur einer definierten Farbe dargestellt. Die Farbe kann über die Eigenschaft Farbe oder eine in Eigenschaft Variable für Farbe definierte Variable eingestellt werden. Sind beide Eigenschaften aktiv, wird die Farbe aus Variable für Farbe verwendet.

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Variable für Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Name der Variablen, deren Grenzwertfarben die Glow-Farbe beeinflussen sollen. Ein Klick auf die Schaltfläche ... öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden. Wenn keine Variable verknüpft ist, wird die in der Eigenschaft Farbe definierte Farbe verwendet.

Default: keine Variable verknüpft

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Interne ID: ID_ELE_PROP_GLOWEFFECT_USECOLOR

Farbe

Nur verfügbar, wenn die Eigenschaft Aktivieren aktiv ist. Die Eigenschaft Einfärben muss aktiviert werden.

Bestimmt die Farbe des Glow Effekts. Klick auf Schaltfläche ... öffnet Farbpalette zur Auswahl der Farbe. Direkte Eingabe des Hex-Werts in Feld ist möglich.

Default: 0xFFFF90 (Gelb)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"

Inaktiv: Die Farben des Elementes werden für den Glow-Effekt verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffectUseColor"


ID_ELE_PROP_GRP0

Interne ID: ID_ELE_PROP_GRP0

Allgemein

Allgemeine Eigenschaften des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_ELE_PROP_GRP1

Interne ID: ID_ELE_PROP_GRP1

Position

Eigenschaften zu Position und Größe des Dynamischen Elements.

Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Position"


ID_ELE_PROP_GRP2

Interne ID: ID_ELE_PROP_GRP2

Weltbilddarstellung

Eigenschaften zum Verhalten des Elements in der Weltbilddarstellung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Overview"


ID_ELE_PROP_GRP3

Interne ID: ID_ELE_PROP_GRP3

Farben

Farbeigenschaften des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Color"


ID_ELE_PROP_GRP4

Interne ID: ID_ELE_PROP_GRP4

VBA

Eigenschaften für mit dem Element verknüpfte VBA Makros.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VBA"


ID_ELE_PROP_GRP5

Interne ID: ID_ELE_PROP_GRP5

Allgemeine Ereignisse

VBA Makros für allgemeine Ereignisse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_ELE_PROP_GRP6

Interne ID: ID_ELE_PROP_GRP6

Sollwert absetzen

Eigenschaften zum Setzen von Sollwerten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValue"


ID_ELE_PROP_GRP7

Interne ID: ID_ELE_PROP_GRP7

Variable / Funktion

Eigenschaften für die mit dem Element verknüpfte Variable oder Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Element"


ID_ELE_PROP_GRP8

Interne ID: ID_ELE_PROP_GRP8

Anzeigeeinstellungen

Eigenschaften für die Wertanzeige im Element.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DisplayArea"


ID_ELE_PROP_GRP9

Interne ID: ID_ELE_PROP_GRP9

Farben statisch

Eigenschaften für die farbliche Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Colors_Static"


ID_ELE_PROP_GRP10

Interne ID: ID_ELE_PROP_GRP10

SW Grenzen statisch

Fix definierte Sollwertgrenzen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "etValueLimits_Static"


ID_ELE_PROP_GRP11

Interne ID: ID_ELE_PROP_GRP11

Darstellung

Eigenschaften für die grafische Darstellung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Representation"


ID_ELE_PROP_GRP12

Interne ID: ID_ELE_PROP_GRP12

Skala

Eigenschaften für die Darstellung einer Skala.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Scale"


ID_ELE_PROP_GRP13

Interne ID: ID_ELE_PROP_GRP13

Schleppzeiger

Eigenschaften für die grundlegende Darstellungsform des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Look"


ID_ELE_PROP_GRP14

Interne ID: ID_ELE_PROP_GRP14

Rand

Eigenschaften für den Rahmen des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Border"


ID_ELE_PROP_GRP15

Interne ID: ID_ELE_PROP_GRP15

Titel

Eigenschaften für die Darstellung eines Titels.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Title"


ID_ELE_PROP_GRP16

Interne ID: ID_ELE_PROP_GRP16

Knopf

Eigenschaften für die Laufrichtung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Knob"


ID_ELE_PROP_GRP17

Interne ID: ID_ELE_PROP_GRP17

Darstellungszeitraum

Zeitraum, der in den Kurven dargestellt werden soll.
(Stunden, Minuten Sekunden)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Time"


ID_ELE_PROP_GRP18

Interne ID: ID_ELE_PROP_GRP18

Aktualisierungszeit

Zeitintervall, in dem die Darstellung aktualisiert wird (d.h. ein neuer Wert hinzugefügt wird).
(Stunden, Minuten, Sekunden, Millisekunden)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Refresh"


ID_ELE_PROP_GRP20

Interne ID: ID_ELE_PROP_GRP20

Bildsymbol Einstellungen

Eigenschaften für die Verwendung des Elements mit verschiedenen Farben eines zuvor im Bild angelegten einzelnen Symbols zur Anzeige der verschiedenen Zustände.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PictSymbol"


ID_ELE_PROP_GRP21

Interne ID: ID_ELE_PROP_GRP21

Automatic Line Coloring

Eigenschaften für Automatic Line Coloring (ALC).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALC"


ID_ELE_PROP_GRP22

Interne ID: ID_ELE_PROP_GRP22

Maus Ereignisse

VBA Makros für Maus Ereignisse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Mouse Events"


ID_ELE_PROP_GRP23

Interne ID: ID_ELE_PROP_GRP23

Drag&Drop

VBA Makros für Drag&Drop Ereignisse.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Drag_Drop"


ID_ELE_PROP_GRP24

Interne ID: ID_ELE_PROP_GRP24

Farbverlauf

Eigenschaften für die Projektierung von Farbverläufen. Nur verfügbar, wenn Farbverlauf als Füllmuster ausgewählt ist.
Mehr im Online-Handbuch.

Interne ID: ID_ELE_PROP_GRP24

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Interne ID: ID_ELE_PROP_GRP24

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "3D-Filling"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "3D-Filling"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "3D-Filling"


ID_ELE_PROP_GRP25

Interne ID: ID_ELE_PROP_GRP25

Automatic Line Coloring

Eigenschaften nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Eigenschaften für ALC.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALC"


ID_ELE_PROP_GRP26

Interne ID: ID_ELE_PROP_GRP26

Abrundung

Eigenschaften für die Darstellung abgerundeter Ecken.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Roundness"


ID_ELE_PROP_GRP27

Interne ID: ID_ELE_PROP_GRP27

Binärwert

Eigenschaften für das Setzen eines binären Sollwerts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BinaryValue"


ID_ELE_PROP_GRP28

Interne ID: ID_ELE_PROP_GRP28

Numerischer Wert

Eigenschaften für das Setzen eines analogen Sollwerts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AnalogValue"


ID_ELE_PROP_GRP29

Interne ID: ID_ELE_PROP_GRP29

Kopfzeile und Raster

Eigenschaften für die Kopfzeile und das Raster.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_ELE_PROP_GRP30

Interne ID: ID_ELE_PROP_GRP30

Einträge dynamisch erzeugen

Eigenschaften für dynamische Combo-/Listbox.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynEntries"


ID_ELE_PROP_GRP31

Interne ID: ID_ELE_PROP_GRP31

Bildalarmierung Button

Nur verfügbar in SICAM 230.
Eigenschaften für das Bildalarmierungselement.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BA-Elem"


ID_ELE_PROP_GRP33

Interne ID: ID_ELE_PROP_GRP33

Kurzschlusserkennung

Enthält die Eigenschaften zur Fehlerortung von Kurzschlüssen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_ELE_PROP_GRP34

Interne ID: ID_ELE_PROP_GRP34

Textformatierung

Eigenschaften für das Format des dargestellten Texts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextAlign"


ID_ELE_PROP_GRP35

Interne ID: ID_ELE_PROP_GRP35

Bitmap Einstellungen

Eigenschaften für die Verwendung des Elements mit verschiedenen Bitmaps zur Anzeige der Zustände.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BMPSettings"


ID_ELE_PROP_GRP36

Interne ID: ID_ELE_PROP_GRP36

Symbol aus Bibliothek Einstellungen

Eigenschaften für die Verwendung des Elements mit Symbolen aus der Bibliothek zur Anzeige der Zustände.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LibSymSettings"


ID_ELE_PROP_GRP37

Interne ID: ID_ELE_PROP_GRP37

Topologie

Eigenschaften für SICAM 230.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MrLinzSettings"


ID_ELE_PROP_GRP38

Interne ID: ID_ELE_PROP_GRP38

Ausprägung

Einstellungen zur grafischen Ausprägung des Reglers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SuperLook"


ID_ELE_PROP_GRP39

Interne ID: ID_ELE_PROP_GRP39

Bezugspunkt

Bestimmt den Startpunkt für die Berechnung des Drehwinkels bzw. der dynamischen Größenänderung des Elements.

ACHTUNG: Bei nicht rechteckigen Elementen beziehen sich die Angaben immer auf das umschließende Rechteck.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Dynamic"


ID_ELE_PROP_GRP40

Interne ID: ID_ELE_PROP_GRP40

Runtime

Eigenschaften für das Runtime-Verhalten des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Runtime"


ID_ELE_PROP_GRP41

Interne ID: ID_ELE_PROP_GRP41

Tastaturbedienung

Eigenschaften für die Online-Bedienung des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Operation"


ID_ELE_PROP_GRP43

Interne ID: ID_ELE_PROP_GRP43

Grafikdatei

Eigenschaften für die Grafikdatei des Dynamischen Elements Button.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_ELE_PROP_GRP44

Interne ID: ID_ELE_PROP_GRP44

Berechtigung

Eigenschaften für die Bedienberechtigung des Elements.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Rights"


ID_ELE_PROP_GRP45

Interne ID: ID_ELE_PROP_GRP45

Sichtbarkeit

Eigenschaften für die Sichtbarkeit des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynamicVisibility"


ID_ELE_PROP_GRP46

Interne ID: ID_ELE_PROP_GRP46

Anzeigebereich statisch

Eigenschaften für den fix definierten Anzeigebereich des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Displayrange_Static"


ID_ELE_PROP_GRP47

Interne ID: ID_ELE_PROP_GRP47

Blinken

Eigenschaften für das Blinken des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynamicBlinking"


ID_ELE_PROP_GRP48

Interne ID: ID_ELE_PROP_GRP48

Universalregler

Konfiguration des Reglers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Universal_Slider"


ID_ELE_PROP_GRP49

Interne ID: ID_ELE_PROP_GRP49

Legende

Konfiguration der Legende des Reglers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Legend"


ID_ELE_PROP_GRP50

Interne ID: ID_ELE_PROP_GRP50

Rahmen/Schatten

Eigenschaften für Rahmen und Schatten um das Element.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrame"


ID_ELE_PROP_GRP51

Interne ID: ID_ELE_PROP_GRP51

Öffnungswinkel

Definition der Winkel für das Kreissegment

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Segment"


ID_ELE_PROP_GRP52

Interne ID: ID_ELE_PROP_GRP52

Grafik für Checkbox

Eigenschaften für Checkbox.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GraphicalImage"


ID_ELE_PROP_GRP53

Interne ID: ID_ELE_PROP_GRP53

Grafikdatei

Einstellungen für Grafikdateien.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgCtrlImages"


ID_ELE_PROP_GRP54

Interne ID: ID_ELE_PROP_GRP54

Statusfarbe

Einstellungen für farbliche Kennzeichnung des Status einer Nachricht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgCtrlColors"


ID_ELE_PROP_GRP_ALC_FAULTS

Interne ID: ID_ELE_PROP_GRP_ALC_FAULTS

Erdschlusserkennung

Enthält die Eigenschaften zur Fehlerortung von Erdschlüssen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Faults"


ID_ELE_PROP_GRP_ALC_FOS

Interne ID: ID_ELE_PROP_GRP_ALC_FOS

Fehlerort aus Schutz / Lastverteilung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FOS_LoadBal"


ID_ELE_PROP_GRP_EFFECTS

Interne ID: ID_ELE_PROP_GRP_EFFECTS

Effekte

Enthält Eigenschaften für die Konfiguration von Bild-Effekten.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Effects"


ID_ELE_PROP_GRP_GLOW_EFFECT

Interne ID: ID_ELE_PROP_GRP_GLOW_EFFECT

Glow (nur DirectX)

Eigenschaften für die Konfiguration des Glow-Effekts. Nur verfügbar, wenn Eigenschaft Grafikqualität auf DirectX Hardware oder DirectX Software gesetzt wurde.

Interne ID: ID_ELE_PROP_GRP_GLOW_EFFECT

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_PROP_GRP_GLOW_EFFECT

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_ELE_PROP_GRP_GLOW_EFFECT

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GlowEffect"


ID_ELE_PROP_GRP_LINECAPS

Interne ID: ID_ELE_PROP_GRP_LINECAPS

Linienenden

Enthält Eigenschaften für Form von Linienanfang und Linienende.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineCaps"


ID_ELE_PROP_GRP_SW

Interne ID: ID_ELE_PROP_GRP_SW

Sollwert absetzen

Eigenschaften für das Setzen von Sollwerten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValue"


ID_ELE_PROP_SYMBOLFORM_CLICKAREA

Interne ID: ID_ELE_PROP_SYMBOLFORM_CLICKAREA

Symbolform bestimmt Klickbereich

Ermöglicht es, einen klickbaren Button mit beliebiger Form zu erstellen. Steht nur für Option Symbol aus Bibliothek des Combi-Elements zur Verfügung.

Aktiv: Die Symbolform wird als Klickbereich verwendet, jedes Element im Symbol wird einzeln für den Klickbereich berücksichtigt.

Inaktiv: Die Form des Combi-Elements (gesamtes Rechteck) wird als Klickbereich verwendet.

Default: inaktiv

Achtung: Unter Windows CE nicht verfügbar.

Eigenschaft steht ab Version 6.51 zur Verfügung. Bei Projekten für frühere Versionen wird die Eigenschaft als inaktiv behandelt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolFormClickArea"


ID_ELE_PROP_UNIT_POS

Interne ID: ID_ELE_PROP_UNIT_POS

Einheits-Position [%]

Nur verfügbar, wenn Maßeinheit anzeigen aktiv ist.

Interne ID: ID_ELE_PROP_UNIT_POS

Maßeinheit anzeigen

Nur verfügbar:
Allgemein: wenn die Eigenschaft Wert anzeigen aktiviert wurde.
Bei Element Uhr : wenn als Anzeigetyp Zeitdifferenz gewählt wurde.
Bei Element Zeigerinstrument: wenn Eigenschaft 3D aktiviert wurde.

Interne ID: ID_ELE_PROP_UNIT_POS

3D

Aktiv: Das Element wird 3-dimensional dargestellt.
Inaktiv: Das Element wird flach dargestellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UnitPos"

Interne ID: ID_ELE_PROP_UNIT_POS

Anzeigetyp

Absolutzeit: Es wird die Zeit der Systemuhr mit den entsprechenden Formatierungen angezeigt.
Zeitdifferenz: Der Wert einer verknüpften Variablen wird im eingestellten Zeitformat dargestellt.
Default: Absolutzeit.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UnitPos"

Interne ID: ID_ELE_PROP_UNIT_POS

Wert anzeigen

Zusätzliche Anzeige des aktuellen Wertes als Zahl; Position im Element und Schriftfarbe können frei gewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UnitPos"

Aktiv: Die technische Einheit der verknüpften Variable wird hinter dem Wert angezeigt.
Wird der Wert in Prozent dargestellt, so wird das Prozentzeichen % anstatt der technischen Einheit der verknüpften Variable verwendet.
Inaktiv: Die technische Einheit wird nicht angezeigt.
Default: aktiv.

Hinweis:

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UnitPos"

Positioniert die Anzeige der Einheit und ermöglicht es so, Einheiten mit verschiedener Breite an untereinander liegenden Zahlenwerten auszurichten. Zur Positionierung wird ein Prozentwert zwischen 0 und 100 angegeben.

Die Einheit wird immer rechts neben der gewählten Position ausgegeben, der dazugehörende Wert links davon, abhängig von der eingestellten Ausrichtung.

Default: 0 - entspricht keiner prozentuellen Ausrichtung, Wert und Einheit werden immer zusammen dargestellt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UnitPos"


ID_ELE_SplineTension

Interne ID: ID_ELE_SplineTension

Rundung

Nur verfügbar, wenn in den Projekteigenschaften die Option Grafikqualität im Knoten Grafische Ausprägung/Bilder aktiviert wurde.

Interne ID: ID_ELE_SplineTension

Bilder

Eigenschaften für die Anzeige der Bilder in der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SplineTension"

Interne ID: ID_ELE_SplineTension

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SplineTension"

Interne ID: ID_ELE_SplineTension

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_ELE_SplineTension

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SplineTension"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SplineTension"

Definiert für Polylinien, Polygone und Rohrleitungen die Rundung.

Werte: 0,0 (keine Rundung) bis 1,0. (maximale Rundung)

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SplineTension"


ID_ELE_TEXT_FROM_VARIABLE

Interne ID: ID_ELE_TEXT_FROM_VARIABLE

Text aus Variablenwert

Nur verfügbar für Stringvariablen.

Aktiv: Text wird aus Wert der verknüpften Variablen übernommen.

Inaktiv: Text wird aus Rema übernommen.

Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextFromVariable"


ID_ELE_TEXT_TRANSLATE_TEXT

Interne ID: ID_ELE_TEXT_TRANSLATE_TEXT

Anzeigetext übersetzen

Aktiv: Die anzuzeigenden Texte werden übersetzt. Wird ein Text bearbeitet, wird der Entwurf ohne Übersetzung angezeigt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TranslateText"


ID_ELESEG_END_ANGLE

Interne ID: ID_ELESEG_END_ANGLE

Endwinkel [°]

Ende des Öffnungswinkels. Der Öffnungswinkel des Kreissegmentes wird zwischen Startwinkel und Endwinkel angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SegEndAngle"


ID_ELESEG_START_ANGLE

Interne ID: ID_ELESEG_START_ANGLE

Startwinkel [°]

Anfang des Öffnungswinkels. Der Öffnungswinkel des Kreissegmentes wird zwischen Startwinkel und Endwinkel angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SegStartAngle"


ID_ELREST_DEVPARAM

Interne ID: ID_ELREST_DEVPARAM

Device parameter

Die folgenden Properties dienen Ihnen zur Adressierung des ELREST32-Treibers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Device parameter"


ID_EMS_PROP0

Interne ID: ID_EMS_PROP0

Name

Eindeutige Bezeichnung zur Identifizierung von Geräten, Gebieten und Anlagen im EMS.

Achtung: Namen sollten über alle Netze/Versorgungsgebiete im EMS eindeutig sein.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_EMS_PROP1

Interne ID: ID_EMS_PROP1

Kennung

Optionale Eingabe eines längeren Namens oder einer detaillierten Beschreibung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Longtext"


ID_EMS_PROP2

Interne ID: ID_EMS_PROP2

Bereinigter Verbrauch

Variable, an die der Gruppenverbrauch geschickt wird, bereinigt um die Werte von Verbraucherabschaltungen und Speichereinsätzen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BerVerbr"


ID_EMS_PROP3

Interne ID: ID_EMS_PROP3

Prognose

Variable, an die der prognostizierte Verbrauch der Gruppe geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Prognose"


ID_EMS_PROP4

Interne ID: ID_EMS_PROP4

Optimale Last

Variable, an die das Ergebnis der Lastverteilung für die Gruppe geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OptimLast"


ID_EMS_PROP5

Interne ID: ID_EMS_PROP5

Windgeschwindigkeit

Variable für den Wert der Windgeschwindigkeit. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Wind"


ID_EMS_PROP6

Interne ID: ID_EMS_PROP6

Temperatur

Variable für den Wert der Temperatur. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Temp"


ID_EMS_PROP7

Interne ID: ID_EMS_PROP7

Charakteristische Tage

Variable für Tageskennung (Wochen- oder Feiertag). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Tage"


ID_EMS_PROP8

Interne ID: ID_EMS_PROP8

Aktueller Verbrauch

Variable, die den aktuellen Wert des Gebietsverbrauchs beinhaltet. Der Wert muss die Zählerdifferenz pro Zeiteinheit der Summe der Verbräuche des Versorgungsgebietes darstellen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Achtung: Stellen Sie sicher, dass der Wert zyklisch übertragen wird, da er die kurzfristige Optimierungsrechnung auslöst.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AktValue"


ID_EMS_PROP9

Interne ID: ID_EMS_PROP9

Akt. Verbrauchsmittelwert

Prozessvariable mit aktuellem Verbrauchsmittelwert (Ergebnis aus den erfassten Messwerten). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AktMean"


ID_EMS_PROP10

Interne ID: ID_EMS_PROP10

Endverbrauch Prognose

Variable, die den Endwert der Prognosegerade zum Ende der Verrechnungsperiode enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProgEndValue"


ID_EMS_PROP11

Interne ID: ID_EMS_PROP11

Startverbrauch Prognose

Variable, die den den Startwert der Prognosegeraden am Anfang des Prognosezeitraums enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProgStartValue"


ID_EMS_PROP12

Interne ID: ID_EMS_PROP12

Letzter Schaltwert

Variable, die die Summe der Bezugsmittelwerte, zu denen in der aktuellen Periode noch Schaltaktionen geplant sind, enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Achtung: Diese Variable muss für den Intern Treiber projektiert werden, um eine einwandfreie Funktion zu gewährleisten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LastSwitchValue"


ID_EMS_PROP13

Interne ID: ID_EMS_PROP13

Erster Schaltwert

Variable, die den errechneten Bezugsmittelwert, zu dem die nächste Schalthandlung ausgeführt wird, enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Achtung: Diese Variable muss für den Intern Treiber projektiert werden, um eine einwandfreie Funktion zu gewährleisten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FirstSwitchValue"


ID_EMS_PROP14

Interne ID: ID_EMS_PROP14

Prognose Fehlerbereich

Variable, die den möglichen Prognosefehler des Prognoseendwertes enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProgChannelValue"


ID_EMS_PROP15

Interne ID: ID_EMS_PROP15

Prognose Mittelwert

Variable, die den aktuellen Mittelwert der Realwertprognose enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProgMean"


ID_EMS_PROP16

Interne ID: ID_EMS_PROP16

Prognose Fehlerbereich Mittelwert

Variable, die den möglichen Prognosefehler des Mittelwerts der Realwertprognose enthält. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProgChannelMean"


ID_EMS_PROP17

Interne ID: ID_EMS_PROP17

Bezugsgrenze

Variable, die die aktuell eingestellte Bezugsleistungsgrenze enthält. Ändert sich ihr Wert zur Runtime, wird auch die Bezugsleistungsgrenze für eine Verrechnungsperiode geändert. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Limit"


ID_EMS_PROP18

Interne ID: ID_EMS_PROP18

Angepasste Bezugsgrenze

Variable mit angepasster Bezugsleistungsgrenze (nach oben korrigierte Bezugsleistungsgrenze) bei Überschreitung der Grenze in einer der Vorperioden. Wird die Bezugsleistungsgrenze in einer Periode überschritten, wird die Bezugsleistungsgrenze um die Überschreitung erhöht.

Wenn Sie keine Variable verknüpfen, erfolgt keine Erhöhung der Bezugsleistungsgrenze nach einer Überschreitung.

Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AdjustedLimit"


ID_EMS_PROP19

Interne ID: ID_EMS_PROP19

Ist-Abweichung brutto

Variable für die mittlere Abweichung der Realwertprognose. Diese entspricht der Differenz zwischen prognostiziertem Mittelwert der Realwertprognose und der Bezugsleistungsgrenze. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeviationActual"


ID_EMS_PROP20

Interne ID: ID_EMS_PROP20

Ist-Abweichung netto

Variable für die mittlere Abweichung der Istwertprognose. Diese entspricht der Differenz zwischen prognostiziertem Mittelwert der Istwertprognose und der Bezugsleistungsgrenze. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeviationReal"


ID_EMS_PROP21

Interne ID: ID_EMS_PROP21

Tageswechsel

Uhrzeit, zu der das EMS einen Tageswechsel vornimmt. Diese Einstellung ist für alle Geräte wichtig, deren maximale Schalthäufigkeit pro Zeitheit 24 Stunden überschreitet. Der Tageszähler wird normalerweise um 00 Uhr zurückgesetzt. Mit dieser Einstellung passiert das Rücksetzen zu einer anderen definierten Uhrzeit.

Maximalwert: 23:59:59

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DayChangeover"


ID_EMS_PROP22

Interne ID: ID_EMS_PROP22

Prognosehorizont

Dauer einer Verrechnungsperiode in hh:mm:ss. Die Trendrechnung und die Optimierung verwenden diese Zeit als Berechnungshorizont. In der Regel werden 15, 30 oder 60 Minuten als Werte verwendet.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ForecastHorizon"


ID_EMS_PROP23

Interne ID: ID_EMS_PROP23

Hysterese Zuschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Abschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Interne ID: ID_EMS_PROP23

Sicherheitsabstand [%]

Sicherheitsabstand zur Bezugsgrenze in Prozent. Der Sicherheitsabstand wird auch von den Eigenschaften Hysterese Zuschalten [%] und Hysterese Abschalten [%] beeinflusst.

Interne ID: ID_EMS_PROP23

Hysterese Abschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Zuschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HysteresisOn"

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HysteresisOn"

Default: 0

Achtung: Wird der Bereich zu groß dimensioniert, kann eventuell die Bezugsgrenze überschritten werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HysteresisOn"


ID_EMS_PROP24

Interne ID: ID_EMS_PROP24

Hysterese Abschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Zuschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Interne ID: ID_EMS_PROP24

Sicherheitsabstand [%]

Sicherheitsabstand zur Bezugsgrenze in Prozent. Der Sicherheitsabstand wird auch von den Eigenschaften Hysterese Zuschalten [%] und Hysterese Abschalten [%] beeinflusst.

Interne ID: ID_EMS_PROP24

Hysterese Zuschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Abschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Default: 0

Achtung: Wird der Bereich zu groß dimensioniert, kann eventuell die Bezugsgrenze überschritten werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HysteresisOff"

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HysteresisOff"

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HysteresisOff"


ID_EMS_PROP25

Interne ID: ID_EMS_PROP25

Sicherheitsabstand [%]

Sicherheitsabstand zur Bezugsgrenze in Prozent. Der Sicherheitsabstand wird auch von den Eigenschaften Hysterese Zuschalten [%] und Hysterese Abschalten [%] beeinflusst.

Interne ID: ID_EMS_PROP25

Hysterese Abschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Zuschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SafetyClearance"

Interne ID: ID_EMS_PROP25

Hysterese Zuschalten [%]

Definiert den Bereich der Hysterese in Prozent, in dem keine Abschaltungen stattfinden dürfen, damit die Sicherheitsabstand [%] zur Bezugsgrenze eingehalten wird.

Default: 0

Achtung: Wird der Bereich zu groß dimensioniert, kann eventuell die Bezugsgrenze überschritten werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SafetyClearance"

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SafetyClearance"


ID_EMS_PROP26

Interne ID: ID_EMS_PROP26

Optimierungszyklus

Zyklus in hh:mm:ss, in dem die kurzfristige Optimierung rechnet. Die Anzeige des Bildes wird nach jeder Optimierung aktualisiert, mindestens aber einmal pro Zyklus.

Default: 00:00:30

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OptCycle"


ID_EMS_PROP27

Interne ID: ID_EMS_PROP27

Totzeit Beginn Tarifintervall

Zeit in hh:mm:ss am Anfang eines Verrechnungsintervalls. In diesem Zeitraum werden keine Schalthandlungen durch die Optimierung vorgenommen, da die Prognoseergebnisse noch zu ungenau sind.

Default: 00:00:00

Maximalwert: 23:59:59

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeadLength"


ID_EMS_PROP37

Interne ID: ID_EMS_PROP37

max. Verh. FlGas/Bezug

Nur verfügbar, wenn mindestens eine Flüssiggasanlage im Versorgungsgebiet vorhanden ist.

Definieren Sie, wie viel Gas die Verbraucher maximal aus dem Flüssiggasspeicher verwenden dürfen. Geben Sie die Menge als Verhältnis zwischen im Flüssiggasspeicher vorhandenem Gas und von den Verbrauchern benötigtem Gas an.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxFlGasBezug"


ID_EMS_PROP38

Interne ID: ID_EMS_PROP38

min. Verh. FlGas/Bezug

Nur verfügbar, wenn mindestens eine Flüssiggasanlage im Versorgungsgebiet vorhanden ist.

Definieren Sie, wie viel Gas die Verbraucher minimal aus dem Flüssiggasspeicher verwenden müssen. Geben Sie die Menge als Verhältnis zwischen im Flüssiggasspeicher vorhandenem Gas und von den Verbrauchern benötigtem Gas an.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinFlGasBezug"


ID_EMS_PROP39

Interne ID: ID_EMS_PROP39

Oberer Prognosefehler

Variable für oberen Prognosefehler. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UpperErrorBound"


ID_EMS_PROP40

Interne ID: ID_EMS_PROP40

Unterer Prognosefehler

Variable für unteren Prognosefehler. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LowerErrorBound"


ID_EMS_PROP41

Interne ID: ID_EMS_PROP41

Aktueller Verbrauch

Variable, an die der aktuelle Gruppenverbrauch mit Verbraucherabschaltungen geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Consumtion"


ID_EMS_PROP42

Interne ID: ID_EMS_PROP42

Tagesenergie

Variable für Gruppenverbräuche der Verrechnungsperiode des Tages. Fungiert als Merker-Variable in Zukunftsarchiven. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DayEnergy"


ID_EMS_PROP44

Interne ID: ID_EMS_PROP44

Verfügbarkeitsflag

Variable, die angibt, ob der Erzeuger für das EMS verfügbar ist, und somit geschalten werden kann. Ist die Verfügbarkeit gegeben, verbleibt der Erzeuger in seinem zuletzt gültigen Schaltzustand. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Active"


ID_EMS_PROP45

Interne ID: ID_EMS_PROP45

Verz.-Zeit Einschalten

Zeit in hh:mm:ss, die der Erzeuger zum Einschalten benötigt. Die Leistung des Gerätes steht dem EMS erst nach Ablauf der Zeit zur Verfügung.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OnDelay"


ID_EMS_PROP46

Interne ID: ID_EMS_PROP46

Verz.-Zeit Ausschalten

Zeit in hh:mm:ss, die der Erzeuger zum Einschalten benötigt. Die Leistung des Gerätes steht dem EMS erst nach Ablauf der Zeit zur Verfügung.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OffDelay"


ID_EMS_PROP47

Interne ID: ID_EMS_PROP47

Vorwarnung ein

Variable für die Vorwarnung beim Einschalten des Verbrauchers. Eine Vorwarnung wird entsprechend der eingestellten Länge Vorwarnzeit gesetzt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Interne ID: ID_EMS_PROP47

Länge Vorwarnzeit

Zeit, im Format hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Schaltvorwarnung kann vom System eine Vorwarnung für den Benutzer ausgegeben werden, damit der Benutzer informiert wird, bevor es zur eigentlichen Schalthandlung kommt.

Interne ID: ID_EMS_PROP47

Schaltvorwarnung

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnOn"

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnOn"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnOn"


ID_EMS_PROP48

Interne ID: ID_EMS_PROP48

Vorwarnung aus

Variable für die Vorwarnung beim Ausschalten des Verbrauchers. Eine Vorwarnung wird entsprechend der eingestellten Länge Vorwarnzeit gesetzt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Interne ID: ID_EMS_PROP48

Länge Vorwarnzeit

Zeit, im Format hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Schaltvorwarnung kann vom System eine Vorwarnung für den Benutzer ausgegeben werden, damit der Benutzer informiert wird, bevor es zur eigentlichen Schalthandlung kommt.

Interne ID: ID_EMS_PROP48

Schaltvorwarnung

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnOff"

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnOff"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnOff"


ID_EMS_PROP50

Interne ID: ID_EMS_PROP50

Schaltzustand

Variable, die den aktuellen Schaltzustand des Verbrauchers liefert (EIN oder AUS). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "State"


ID_EMS_PROP51

Interne ID: ID_EMS_PROP51

Einschalten

Variable zum Einschalten des Verbrauchers. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchOn"


ID_EMS_PROP52

Interne ID: ID_EMS_PROP52

Ausschalten

Variable zum Ausschalten des Verbrauchers. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchOff"


ID_EMS_PROP55

Interne ID: ID_EMS_PROP55

aktueller Verbrauch

Liefert den Messwert des aktuellen Verbrauchs eines BHKWs. Dieser Wert sollte immer einer definierten Schaltstufe entsprechen, damit er eindeutig zugeordnet werden kann. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Consumption"


ID_EMS_PROP56

Interne ID: ID_EMS_PROP56

{Sperrzeit neu}

Erstellt eine neue Sperrzeit. Klicken Sie dazu in das Feld oder auf die Schaltfläche. Die Sperrzeiten erhalten den Namen "Sperrzeit" plus eine fortlaufende Nummer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NewLock"


ID_EMS_PROP57

Interne ID: ID_EMS_PROP57

{Sperrzeit löschen}

Löscht nach einer Sicherheitsabfrage die jeweilige Sperrzeit. Klicken Sie dazu in das Feld oder auf die Schaltfläche. Die fortlaufende Nummerierung der folgenden Sperrzeiten wird angepasst und jeweils um eine Stufe reduziert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DelLock"


ID_EMS_PROP58

Interne ID: ID_EMS_PROP58

Anfang

Beginn der Sperrzeit im Format hh:mm:ss.

Maximalwert: 23:59:59

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockStart"


ID_EMS_PROP59

Interne ID: ID_EMS_PROP59

Ende

Ende der Sperrzeit im Format hh:mm:ss.

Maximalwert: 23:59:59

Hinweis: Zeit wird als Lokalzeit gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockStop"


ID_EMS_PROP60

Interne ID: ID_EMS_PROP60

Typ

Legt fest, welche Handlungen während der Sperrzeit untersagt sind:

Aus: Keine Ausschaltung während der Sperrzeit möglich.

Ein: Keine Einschaltung während der Sperrzeit möglich.

Beide: Weder Ein- noch Ausschaltung während der Sperrzeit möglich.

Default: Beide

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockType"


ID_EMS_PROP61

Interne ID: ID_EMS_PROP61

Min. Einschaltzeit

Minimale Zeit in hh:mm:ss, die der Erzeuger nach dem Schalten auf Spitzenleistung eingeschaltet bleiben muss. Erst nach Ablauf dieser Zeit wird der Erzeuger vom EMS wieder für Abschaltvorgänge berücksichtigt.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinOn"


ID_EMS_PROP62

Interne ID: ID_EMS_PROP62

Max. Einschaltzeit

Maximale Zeit in hh:mm:ss, die der Erzeuger nach dem Schalten auf Spitzenleistung eingeschalten bleiben kann. Nach Ablauf der Zeit wird der Erzeuger vom EMS automatisch abgeschaltet, selbst wenn dies zu einem Überschreiten der Bezugsgrenze führen sollte.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxOn"


ID_EMS_PROP63

Interne ID: ID_EMS_PROP63

Min. Ausschaltzeit

Minimale Zeit in hh:mm:ss, die der Erzeuger nach dem Abschalten in diesem Zustand bleiben muss. Erst nach Ablauf dieser Zeit wird der Erzeuger vom EMS wieder für Einschaltvorgänge berücksichtigt.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinOff"


ID_EMS_PROP64

Interne ID: ID_EMS_PROP64

Max. Ausschaltzeit

Maximale Zeit in hh:mm:ss, die der Erzeuger nach dem Abschalten in diesem Zustand bleiben kann. Nach Ablauf der Zeit wird der Erzeuger vom EMS automatisch eingeschaltet, unabhängig davon, ob die aktuelle Bezugsgrenze überschritten ist.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxOff"


ID_EMS_PROP67

Interne ID: ID_EMS_PROP67

Länge Vorwarnzeit

Zeit, im Format hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Schaltvorwarnung kann vom System eine Vorwarnung für den Benutzer ausgegeben werden, damit der Benutzer informiert wird, bevor es zur eigentlichen Schalthandlung kommt.

Interne ID: ID_EMS_PROP67

Schaltvorwarnung

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Warn"

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Warn"


ID_EMS_PROP68

Interne ID: ID_EMS_PROP68

Max. Schalthäufigkeit

Maximale Anzahl der Schalthandlungen pro Zeiteinheit. Ein- und Ausschalten werden jeweils als eine separate Schalthandlungen berücksichtigt. Auch das Schalten von Nenn- auf Spitzenleistung wird als eine Schalthandlung gewertet.

Interne ID: ID_EMS_PROP68

pro Zeiteinheit

Zeiteinheit in hh:mm:ss für die Max. Schalthäufigkeit.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxSwitch"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxSwitch"


ID_EMS_PROP69

Interne ID: ID_EMS_PROP69

pro Zeiteinheit

Zeiteinheit in hh:mm:ss für die Max. Schalthäufigkeit.

Interne ID: ID_EMS_PROP69

Max. Schalthäufigkeit

Maximale Anzahl der Schalthandlungen pro Zeiteinheit. Ein- und Ausschalten werden jeweils als eine separate Schalthandlungen berücksichtigt. Auch das Schalten von Nenn- auf Spitzenleistung wird als eine Schalthandlung gewertet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchUnit"

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchUnit"


ID_EMS_PROP70

Interne ID: ID_EMS_PROP70

Leistungsbestimmung

Wählen Sie über die Dropdown-Liste aus, wie die Leistungsbestimmung durchgeführt werden soll.

default: Leistungsverbrauch wird durch die Nennleistung bestimmt. Dieser Wert ist fix projektiert.

gemessen: Aktueller Leistungsverbrauch wird über die Variable aus aktueller Verbrauch festgestellt.

Interne ID: ID_EMS_PROP70

aktueller Verbrauch

Liefert den Messwert des aktuellen Verbrauchs eines BHKWs. Dieser Wert sollte immer einer definierten Schaltstufe entsprechen, damit er eindeutig zugeordnet werden kann. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerType"

Default: default

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerType"


ID_EMS_PROP71

Interne ID: ID_EMS_PROP71

Standby-Leistung

Geben Sie hier die Nennleistung des Erzeugers ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Power"


ID_EMS_PROP72

Interne ID: ID_EMS_PROP72

Standby-Leistung Variable

Dieser Variablenwert überschreibt zur Laufzeit den fix projektierten Wert der Nennleistung. Damit kann die aktuell erbrachte Nennleistung eines Erzeugers während der Laufzeit angepasst werden, zum Beispiel wenn der Leistungswert über einen Messpunkt erfasst wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerVar"


ID_EMS_PROP73

Interne ID: ID_EMS_PROP73

Einschaltpriorität

Legt die Priorität für das Einschalten des Geräts fest. Je größer der Wert, desto höher die Priorität. Geräte mit höherer Priorität werden zuerst vom EMS berücksichtigt.

Minimum: 0

Maximum: 32000

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OnPrio"


ID_EMS_PROP74

Interne ID: ID_EMS_PROP74

Ausschaltpriorität

Legt die Priorität zum Ausschalten des Geräts fest. Je größer der Wert, desto höher die Priorität. Geräte mit höherer Priorität werden zuerst vom EMS berücksichtigt.

Minimum: 0

Maximum: 32000

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OffPrio"


ID_EMS_PROP75

Interne ID: ID_EMS_PROP75

Anteil an Gruppe [%]

Anteil der Leistung des Verbrauchers an der Gesamtleistung der Verbrauchergruppe in Prozent.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GroupShare"


ID_EMS_PROP76

Interne ID: ID_EMS_PROP76

Erlös [€/kWh]/Priorität

Erlös des Verbrauchers in € pro kWh oder Schaltpriorität.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000001

Default: 1.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Revenue"


ID_EMS_PROP77

Interne ID: ID_EMS_PROP77

Min. Temperatur [°C]

Minimaltemperatur. Unterhalb dieser Temperatur darf der Verbraucher nicht mehr eingesetzt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinTemp"


ID_EMS_PROP78

Interne ID: ID_EMS_PROP78

Max. Temperatur [°C]

Maximaltemperatur in °C. Oberhalb dieser Temperatur darf der Verbraucher nicht mehr eingesetzt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxTemp"


ID_EMS_PROP79

Interne ID: ID_EMS_PROP79

Spitzenleistung

Geben Sie hier die gewünschte Spitzenleistung ein. Das EMS Modul kann ausgehend von der Nennleistung auf diesen Wert für Spitzenleistung umschalten. Der Bezugswert wird um die geschaltete Leistungsdifferenz reduziert.

Wenn der Erzeuger nur über eine zuschaltbare Leistung verfügt und es damit keine Grundleistung gibt, dann ist nur die Spitzenleistung des Erzeugers einzustellen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PeakPower"


ID_EMS_PROP80

Interne ID: ID_EMS_PROP80

Schaltvorwarnung

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Interne ID: ID_EMS_PROP80

Länge Vorwarnzeit

Zeit, im Format hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Schaltvorwarnung kann vom System eine Vorwarnung für den Benutzer ausgegeben werden, damit der Benutzer informiert wird, bevor es zur eigentlichen Schalthandlung kommt.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnSwitch"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WarnSwitch"


ID_EMS_PROP83

Interne ID: ID_EMS_PROP83

Schalten Standby

Befehlsvariable, die auf Standby schaltet. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchOff"


ID_EMS_PROP84

Interne ID: ID_EMS_PROP84

Schalten Spitzenleistung

Befehlsvariable für Schaltungen auf Spitzenleistung. In der Regel wird von Nennleistung auf Spitzenleistung geschaltet. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchOn"


ID_EMS_PROP86

Interne ID: ID_EMS_PROP86

Schaltzustand

Variable, an die der aktuelle Schaltzustand des Erzeugers (AUS oder EIN) geschickt werden sollt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "State"


ID_EMS_PROP87

Interne ID: ID_EMS_PROP87

Leistungsplan

Definiert die Schaltplanvariable für Leistungssollwerte. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerPlan"


ID_EMS_PROP88

Interne ID: ID_EMS_PROP88

Schaltplan

Definiert die Schaltplanvariable für Schalthandlungen. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Schedule"


ID_EMS_PROP89

Interne ID: ID_EMS_PROP89

Aktueller Füllstand

Variable, an die der aktuelle Füllstand des Gasspeichers geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ActualLevel"


ID_EMS_PROP90

Interne ID: ID_EMS_PROP90

Ausspeicherleistung soll

Variable mit dem Sollwert der Ausspeicherleistung. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WithdrawalSet"


ID_EMS_PROP91

Interne ID: ID_EMS_PROP91

Ausspeicherleistung ist

Variable, an die der Ist-Wert der Ausspeicherleistung geschickt wird. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WidthdrawalActual"


ID_EMS_PROP92

Interne ID: ID_EMS_PROP92

Min. Sollfüllstand

Sollwertvariable mit dem Grenzwert für den minimalen Füllstand. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinSetLevel"


ID_EMS_PROP93

Interne ID: ID_EMS_PROP93

Schwellwert für Füllstandsabweichung

Hysterese für die Füllstandswerte.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon, ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000000

Default: 0.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Threshold"


ID_EMS_PROP94

Interne ID: ID_EMS_PROP94

Max. Füllstand [kWh]

Maximaler Füllstand des Gasspeichers in kWh. Dieser Wert darf durch das EMS nicht überschritten werden.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon, ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000000

Default: 0.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxLevel"


ID_EMS_PROP95

Interne ID: ID_EMS_PROP95

Min. Füllstand [kWh]

Minimaler Füllstand des Gasspeichers in kWh. Dieser Wert darf durch das EMS nicht unterschritten werden.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon, ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000000

Default: 0.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinLevel"


ID_EMS_PROP96

Interne ID: ID_EMS_PROP96

Max. Ausspeicherleistung [kWh]

Maximale Ausspeicherleistung des Gasspeichers in kWh.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon, ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000000

Default: 0.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxWithdrawal"


ID_EMS_PROP97

Interne ID: ID_EMS_PROP97

Basiskosten [€/kWh]

Erlös des Gasspeichers in € pro kWh.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon, ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000001

Default: 1.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BaseCosts"


ID_EMS_PROP98

Interne ID: ID_EMS_PROP98

Strafkosten [€/kWh]

Strafkosten des Gasspeichers in € je kWh.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000000

Default: 1.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Penalty"


ID_EMS_PROP99

Interne ID: ID_EMS_PROP99

Max. Einspeicherleistung [kWh]

Maximale Einspeicherleistung des Gasspeichers in kWh.

Die Funktion rechnet mit insgesamt 7 Stellen, unabhängig davon ob sie sich vor oder hinter dem Dezimalpunkt befinden.

Maximalwert: 9999999

Minimalwert: 0.000000

Default: 0.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxInjection"


ID_EMS_PROP100

Interne ID: ID_EMS_PROP100

Rohrnetzspeicher

aktiv: Dieser Gasspeicher ist ein Rohrnetzspeicher.

Damit im Versorgungsgebiet ein Flüssiggasspeicher angelegt werden kann, muss zuvor ein Rohrnetzspeicher definiert werden.

Achtung: Pro Versorgungsgebiet kann nur ein Rohrnetzspeicher definiert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Netzspeicher"


ID_EMS_PROP101

Interne ID: ID_EMS_PROP101

Max. Füllstand im Netzspeicher für Ausspeicherung

Maximaler Füllstand im Netzspeicher für Ausspeicherung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxPressure"


ID_EMS_PROP102

Interne ID: ID_EMS_PROP102

EMS läuft

Variable, die zur Laufzeit angibt, ob das im EMS Bild angezeigte Versorgungsgebiet aktiviert wurde. Die Aktivierung erfolgt über eine Funktion. Die Variable muss vom Typ BOOL sein. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Running"


ID_EMS_PROP103

Interne ID: ID_EMS_PROP103

Einschaltpriorität Variable

Variable, die die Einschaltpriorität des Geräts während der Laufzeit dynamisch anpasst. Damit können z.B. Erzeuger in Abhängigkeit von einer Außentemperatur in der EMS Hierarchie umgereiht werden. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OnPrioVar"


ID_EMS_PROP104

Interne ID: ID_EMS_PROP104

Ausschaltpriorität Variable

Variable, die die Ausschaltpriorität des Geräts während der Laufzeit dynamisch anpasst. Damit können z.B. Erzeuger in Abhängigkeit von einer Außentemperatur in der EMS Hierarchie umgereiht werden. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OffPrioVar"


ID_EMS_PROP105

Interne ID: ID_EMS_PROP105

Interner Schaltzustand

Variable, in der die unterschiedlichen Status für die Geräte abgebildet werden. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DispoStatus"


ID_EMS_PROP106

Interne ID: ID_EMS_PROP106

Min. Einschaltzeit Variable

Variable, die zur Runtime die minimale Einschaltzeit anpassen kann. Ein in der Runtime vorhandener Wert überschreibt den in der Projektierung eingestellten Wert. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinOnVar"


ID_EMS_PROP107

Interne ID: ID_EMS_PROP107

Max. Einschaltzeit Variable

Variable, die zur Runtime die maximale Einschaltzeit anpassen kann. Ein in der Runtime vorhandener Wert überschreibt den in der Projektierung eingestellten Wert. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxOnVar"


ID_EMS_PROP108

Interne ID: ID_EMS_PROP108

Min. Ausschaltzeit Variable

Variable, die zur Runtime die minimale Ausschaltzeit anpassen kann. Ein in der Runtime vorhandener Wert überschreibt den in der Projektierung eingestellten Wert. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinOffVar"


ID_EMS_PROP109

Interne ID: ID_EMS_PROP109

Max. Ausschaltzeit Variable

Variable, die zur Runtime die maximale Ausschaltzeit anpassen kann. Ein in der Runtime vorhandener Wert überschreibt den in der Projektierung eingestellten Wert. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxOffVar"


ID_EMS_PROP110

Interne ID: ID_EMS_PROP110

{Stufe neu}

Erstellt eine neue Schaltstufe. Klicken Sie dazu in das Feld oder auf die Schaltfläche. Die Schaltstufen erhalten den Namen "Schaltstufe" plus eine fortlaufende Nummer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NewStufe"


ID_EMS_PROP111

Interne ID: ID_EMS_PROP111

{Stufe löschen}

Löscht die aktuelle Schaltstufe. Klicken Sie dazu in das Feld oder auf die Schaltfläche. Die fortlaufende Nummerierung der folgenden Schaltstufen wird angepasst und jeweils um eine Stufe reduziert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DelGrade"


ID_EMS_PROP112

Interne ID: ID_EMS_PROP112

Leistung

Leistungswert der Schaltstufe. Der spätere Leistungswert während der Laufzeit muss immer exakt einem in den Schaltstufen definierten Wert entsprechen.

Default: 0.000000

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradePower"


ID_EMS_PROP113

Interne ID: ID_EMS_PROP113

Leistung Variable

Variable, mit der der Leistungswert einer BHKW Schaltstufe während der Runtime dynamisch angepasst werden kann. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradePowerVar"


ID_EMS_PROP114

Interne ID: ID_EMS_PROP114

Länge Vorwarnzeit

Zeit in hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Vorwarnung ein bzw. Vorwarnung aus kann vom System eine Vorwarnung für den Benutzer ausgegeben werden. Der Anwender wird informiert, bevor es zur eigentlichen Schalthandlung kommt.

Interne ID: ID_EMS_PROP114

Vorwarnung aus

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Variable Länge Vorwarnzeit bei einem Ausschaltvorgang benachrichtigt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarn"

Interne ID: ID_EMS_PROP114

Vorwarnung ein

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit bei einem Einschaltvorgang vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarn"

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarn"


ID_EMS_PROP115

Interne ID: ID_EMS_PROP115

Vorwarnung ein

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit bei einem Einschaltvorgang vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Interne ID: ID_EMS_PROP115

Länge Vorwarnzeit

Zeit in hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Vorwarnung ein bzw. Vorwarnung aus kann vom System eine Vorwarnung für den Benutzer ausgegeben werden. Der Anwender wird informiert, bevor es zur eigentlichen Schalthandlung kommt.

Interne ID: ID_EMS_PROP115

Vorwarnung aus

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Variable Länge Vorwarnzeit bei einem Ausschaltvorgang benachrichtigt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarnOn"

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarnOn"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarnOn"


ID_EMS_PROP116

Interne ID: ID_EMS_PROP116

Vorwarnung aus

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Variable Länge Vorwarnzeit bei einem Ausschaltvorgang benachrichtigt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Interne ID: ID_EMS_PROP116

Länge Vorwarnzeit

Zeit in hh:mm:ss, die zur Vorwarnung einer Schalthandlung benötigt wird. Über die Variable Vorwarnung ein bzw. Vorwarnung aus kann vom System eine Vorwarnung für den Benutzer ausgegeben werden. Der Anwender wird informiert, bevor es zur eigentlichen Schalthandlung kommt.

Interne ID: ID_EMS_PROP116

Vorwarnung ein

Definiert Variable, die Benutzer bei Schaltungen entsprechend der eingestellten Länge Vorwarnzeit bei einem Einschaltvorgang vorwarnt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarnOff"

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarnOff"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeWarnOff"


ID_EMS_PROP117

Interne ID: ID_EMS_PROP117

Verzögerungszeit Einschalten

Zeit in hh:mm:ss, die das BHKW zum Einschalten benötigt. Die Leistung des Gerätes steht dem EMS erst nach Ablauf dieser Zeit zur Verfügung.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeOnDelay"


ID_EMS_PROP118

Interne ID: ID_EMS_PROP118

Verzögerungszeit Ausschalten

Zeit in hh:mm:ss, die das BHKW zum Ausschalten benötigt. Ein Leistungsabfall erfolgt erst nach Ablauf der eingestellten Zeit.

Maximalwert: 23:59:59

Mehr im Onlinehandbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeOffDelay"


ID_EMS_PROP119

Interne ID: ID_EMS_PROP119

Min. Einschaltzeit

Minimale Zeit in hh:mm:ss, die das BHKW nach dem Schalten auf Spitzenleistung eingeschaltet bleiben muss. Erst nach Ablauf dieser Zeit wird der Erzeuger vom EMS wieder für Abschaltvorgänge berücksichtiigt.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeMinOn"


ID_EMS_PROP120

Interne ID: ID_EMS_PROP120

Max. Einschaltzeit

Maximale Zeit in hh:mm:ss, die das BHKW nach dem Schalten auf Spitzenleistung eingeschalten bleiben kann. Nach Ablauf der Zeit wird der Erzeuger vom EMS automatisch abgeschalten, selbst wenn diese zu einem Überschreiten der Bezugsgrenze führen sollte.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GradeMaxOn"


ID_EMS_PROP121

Interne ID: ID_EMS_PROP121

Sollwert-Variable

Globale Sollwertvariable, die das BHKW schaltet. Die einzelnen Werte bzw. Variablen an den LeistungsstufenStufen dienen lediglich zur Angabe der Stufenleistung. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValue"


ID_EMS_PROP122

Interne ID: ID_EMS_PROP122

Hysterese

Die Hysterese definiert den erlaubten Bereich, in dem der aktuelle Wert noch einer der Schaltstufen zugeordnet werden kann. Liegt ein Verbrauchswert nicht innerhalb der Hysterese einer der projektierten Schaltstufen, gilt das BHKW für das EMS als inaktiv.

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Hysteresis"


ID_EMS_PROP123

Interne ID: ID_EMS_PROP123

Geplante Schaltungen

Ermöglicht die Verknüpfung einer String-Variablen, die alle geplanten Schalthandlungen aus dem EMS erhält. Klick auf die Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Power"


ID_EMS_PROP124

Interne ID: ID_EMS_PROP124

Nennleistung

Nennleistung des Verbrauchers in kW.

Dieser Wert kann über Zuweisung einer Variablen in der Eigenschaft Nennleistung Variable zur Runtime dynamisch angepasst werden.

Interne ID: ID_EMS_PROP124

Nennleistung Variable

Die aktuell bezogene Nennleistung eines Verbrauchers kann während der Laufzeit über eine Variable angepasst werden, z.B. wenn der Leistungswert über einen Messpunkt erfasst wird. Dieser Variablenwert überschreibt zur Runtime den fix projektierten Wert der Nennleistung. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerVar"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerVar"


ID_EMS_PROP125

Interne ID: ID_EMS_PROP125

Nennleistung Variable

Die aktuell bezogene Nennleistung eines Verbrauchers kann während der Laufzeit über eine Variable angepasst werden, z.B. wenn der Leistungswert über einen Messpunkt erfasst wird. Dieser Variablenwert überschreibt zur Runtime den fix projektierten Wert der Nennleistung. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Interne ID: ID_EMS_PROP125

Nennleistung

Nennleistung des Verbrauchers in kW.

Dieser Wert kann über Zuweisung einer Variablen in der Eigenschaft Nennleistung Variable zur Runtime dynamisch angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerVar"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PowerVar"


ID_EMS_PROP_GRP0

Interne ID: ID_EMS_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die EMS Ebene.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_EMS_PROP_GRP1

Interne ID: ID_EMS_PROP_GRP1

Eingangswerte

Einstellungen für aktuelle Werte und Bezugsgrenzen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InputValues"


ID_EMS_PROP_GRP2

Interne ID: ID_EMS_PROP_GRP2

Spezifische Gas-Parameter

Diese Eigenschaften stehen nur für Netze, Versorgungsgebiete und Verbrauchergruppen in Gasnetzen zur Verfügung.

Diese Parameter beeinflussen die Auswahl der Geräte, die durch die Optimierung automatisch geschalten werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Gas"


ID_EMS_PROP_GRP4

Interne ID: ID_EMS_PROP_GRP4

Sperrzeiten

Mittels frei definierbarer Zeitbereiche können einzelne Geräte des EMS aus der Optimierung ausgeschlossen werden. Geräte mit einer definierten Sperrzeit werden in diesem Zeitraum nicht vom EMS berücksichtigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Locks"


ID_EMS_PROP_GRP6

Interne ID: ID_EMS_PROP_GRP6

Schaltstufen

Diese Einstellungen stehen nur für Erzeuger in Stromnetzen zur Verfügung.

Blockheizkraftwerke unterscheiden sich von Standard-Erzeugern durch das Vorhandensein von vordefinierten Schaltstufen. Ein BHKW kann nur Leistungswerte annehmen, die auch als Schaltstufe definiert wurden. Das EMS kann auch nur Schaltungen von einer auf die nächst höhere oder nächst kleinere Schaltstufe vornehmen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Schaltstufen"


ID_EMS_PROP_GRP9

Interne ID: ID_EMS_PROP_GRP9

Berechnete Werte

Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung während der Laufzeit angepasst werden. Damit können abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variables"


ID_EMS_PROP_GRP10

Interne ID: ID_EMS_PROP_GRP10

Parameter

Diese Einstellungen beeinflussen grundlegend die Optimierung für das selektierte Versorgungsgebiet. Änderungen dieser Parameter haben direkten Einfluss auf die durch das EMS automatisch vorgenommenen Schalt-Operationen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Parameters"


ID_EMS_PROP_GRP11

Interne ID: ID_EMS_PROP_GRP11

Schaltzeiten

Das EMS kann mit Hilfe dieser Parameter unterschiedliche Laufzeiten oder zeitliche Anforderungen an einzelne Geräte berücksichtigen. Die Schaltzeiten sind ein wesentlicher Einflussfaktor zur Auswahl eines Gerätes für einen Schaltvorgang.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProducerTimes"


ID_EMS_PROP_GRP12

Interne ID: ID_EMS_PROP_GRP12

Typ/Leistung

Diese Eigenschaften stehen nur für Geräte in Gasnetzen zur Verfügung.

Die hier getroffenen Einstellungen bestimmen das grundlegende Verhalten der im Gasnetz relevanten Geräte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ConsumerTypePower"


ID_EMS_PROP_GRP13

Interne ID: ID_EMS_PROP_GRP13

Leistung/Priorität

Diese Eigenschaften stehen nur für Geräte in Stromnetzen zur Verfügung. Sie bestimmen das grundlegende Verhalten der im Stromnetz relevanten Geräte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProducerPrioPower"


ID_EMS_PROP_GRP14

Interne ID: ID_EMS_PROP_GRP14

Schaltvariablen

Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung während der Laufzeit angepasst werden. Damit können abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CurrentConsumerVariables"


ID_EMS_PROP_GRP15

Interne ID: ID_EMS_PROP_GRP15

Schaltvariablen

Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung während der Laufzeit angepasst werden. Damit können abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarGasCons"


ID_EMS_PROP_GRP16

Interne ID: ID_EMS_PROP_GRP16

Schaltvariablen

Mit Hilfe von Prozessvariablen können wichtige Parameter für die Prognose und Optimierung zur Runtime angepasst werden. Damit lassen sich abhängig von Messwerten wichtige EMS Parameter wie zum Beispiel Schaltprioritäten an den aktuellen Prozess anpassen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProducerVariables"


ID_EMS_PROP_GRP17

Interne ID: ID_EMS_PROP_GRP17

Füllstände

Diese Eigenschaften stehen nur für Gasspeicher und Flüssiggasanlagen in Gasnetzen zur Verfügung.

Füllstände stellen die wichtigsten Parameter für Gasspeicher dar. Kennt das EMS den aktuellen Füllstand bzw. die Minimal- und Maximalwerte, kann es in Zeiten des Überschusses die Speicher auffüllen bzw. in Zeiten des Bedarfs entleeren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GasFillLevel"


ID_EMS_PROP_GRP19

Interne ID: ID_EMS_PROP_GRP19

Statusinformation

Definiert Informationsübermittlung zum Status des EMS.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Status"


ID_EMS_PROP_GRP20

Interne ID: ID_EMS_PROP_GRP20

Leistung

Fasst Angaben zu Leistung zusammen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProducerPrioPower"


ID_EMS_PROP_GRP21

Interne ID: ID_EMS_PROP_GRP21

Priorität

Enthält die Einstellung der Prioritäten für Einschaltung und Auschaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProducerPrioPower"


ID_EMS_PROP_GRP22

Interne ID: ID_EMS_PROP_GRP22

Einschaltzeit

Einstellungen für die Festlegung der Einschaltzeiten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchOn"


ID_EMS_PROP_GRP23

Interne ID: ID_EMS_PROP_GRP23

Ausschaltzeit

Einstellungen für die Festlegung der Ausschaltzeiten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchOff"


ID_EMS_PROP_GRP24

Interne ID: ID_EMS_PROP_GRP24

Schalthäufigkeit

Enthält Parameter zur Bestimmung der Max. Schalthäufigkeit pro Zeiteinheit.

Interne ID: ID_EMS_PROP_GRP24

pro Zeiteinheit

Zeiteinheit in hh:mm:ss für die Max. Schalthäufigkeit.

Maximalwert: 23:59:59

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchFrequency"

Interne ID: ID_EMS_PROP_GRP24

Max. Schalthäufigkeit

Maximale Anzahl der Schalthandlungen pro Zeiteinheit. Ein- und Ausschalten werden jeweils als eine separate Schalthandlungen berücksichtigt. Auch das Schalten von Nenn- auf Spitzenleistung wird als eine Schalthandlung gewertet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchFrequency"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SwitchFrequency"


ID_EMS_PROP_GRP25

Interne ID: ID_EMS_PROP_GRP25

Statusinformation

Legt fest, wie Informationen zu Schaltzustand und Interner Schaltzustand übermittelt werden.

Interne ID: ID_EMS_PROP_GRP25

Interner Schaltzustand

Variable, in der die unterschiedlichen Status für die Geräte abgebildet werden. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusVariables"

Interne ID: ID_EMS_PROP_GRP25

Schaltzustand

Variable, an die der aktuelle Schaltzustand des Erzeugers (AUS oder EIN) geschickt werden sollt. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusVariables"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusVariables"


ID_EMS_PROP_GRP27

Interne ID: ID_EMS_PROP_GRP27

Statusinformation

Legt fest, wie Informationen zu aktueller Verbrauch, Interner Schaltzustand und Schaltzustand übermittelt werden.

Interne ID: ID_EMS_PROP_GRP27

Schaltzustand

Variable, die den aktuellen Schaltzustand des Verbrauchers liefert (EIN oder AUS). Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CurrentConsumerVariables"

Interne ID: ID_EMS_PROP_GRP27

Interner Schaltzustand

Variable, in der die unterschiedlichen Status für die Geräte abgebildet werden. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CurrentConsumerVariables"

Interne ID: ID_EMS_PROP_GRP27

aktueller Verbrauch

Liefert den Messwert des aktuellen Verbrauchs eines BHKWs. Dieser Wert sollte immer einer definierten Schaltstufe entsprechen, damit er eindeutig zugeordnet werden kann. Öffnen Sie mit einem Klick auf die Schaltfläche den Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CurrentConsumerVariables"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CurrentConsumerVariables"


ID_ERSETZEN_ZUSAMMEN

Interne ID: ID_ERSETZEN_ZUSAMMEN

Zusammengesetzte Namen

Aktiv: Die Namen der verknüpften Variablen werden aus dem Objektnamen des Symbols und der in Symbol definierten Variablen zusammengesetzt. Die beiden Namen werden durch einen Punkt getrennt: "Symbolname.Variable"
Inaktiv: Die normalen Variablennamen werden verwendet.
Default: inaktiv
Beispiel:
Variablenname: Motor.Drehzahl
Der Symbol Objektname ist "Motor". Das Dynamisches Element, das im Symbol eingesetzt ist, hat als verknüpfte Variable den Platzhalter "Drehzahl".
Den Platzhalter "Drehzahl" kann man bei der Symbolerstellung einfach bei der Variableneigenschaft eintippen.
Zusammengesetzte Namen funktionieren auch mit verschachtelten Symbolen:
Hat man ein Symbol "Pumpe", das wiederum ein Symbol "Motor" und ein Symbol "Umrichter" mit dem Variablenplatzhalter "Leistung" enthält, dann funktioniert die Verknüpfung, wenn es im Projekt eine Variable Pumpe.Motor.Leistung und eine Variable Pumpe.Umrichter.Leistung gibt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubstituteCombinedName"


ID_EXTERNVISIBLE

Interne ID: ID_EXTERNVISIBLE

Extern sichtbar

Externe Eigenschaft für zenon Logic. Betrifft nur Variablen, die nicht vom zenon Logic Treiber sind.
Aktiv: Die Variable ist auch in zenon Logic sichtbar und kann in zenon Logic-Projekten verwendet werden. Die Variablendefinition kann in zenon Logic nicht geändert werden. Der Wert der Variable kann geändert werden.

Achtung: Beachten Sie Wechselwirkungen mit der Eigenschaft Hysterese. Details im Online-Handbuch.
Inaktiv: Die Variable ist in zenon Logic nicht sichtbar.
Default: inaktiv.

Interne ID: ID_EXTERNVISIBLE

Hysterese

Eigenschaften für die Hysterese.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExternVisible"

Achtung: Variablennamen müssen für zenon Logic den Bestimmungen der IEC 61131-3 folgen, d.h. nur Zahlen, Buchstaben (keine Umlaute) und Unterstriche sind erlaubt. Zusätzlich darf der Name nicht mit einer Zahl beginnen. Das beinhaltet auch, dass Strukturen und Arrays des Leitsystems nicht extern sichtbar sein können, weil sie Klammern bzw. Punkte beinhalten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExternVisible"


ID_EXTERNVISIBLE_FOR

Interne ID: ID_EXTERNVISIBLE_FOR

Extern sichtbar für

Nur verfügbar wenn die Eigenschaft Extern sichtbar aktiviert ist.

Interne ID: ID_EXTERNVISIBLE_FOR

Extern sichtbar

Externe Eigenschaft für zenon Logic. Betrifft nur Variablen, die nicht vom zenon Logic Treiber sind.
Aktiv: Die Variable ist auch in zenon Logic sichtbar und kann in zenon Logic-Projekten verwendet werden. Die Variablendefinition kann in zenon Logic nicht geändert werden. Der Wert der Variable kann geändert werden.

Achtung: Beachten Sie Wechselwirkungen mit der Eigenschaft Hysterese. Details im Online-Handbuch.
Inaktiv: Die Variable ist in zenon Logic nicht sichtbar.
Default: inaktiv.

Interne ID: ID_EXTERNVISIBLE_FOR

Hysterese

Eigenschaften für die Hysterese.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExternVisibleFor"

Achtung: Variablennamen müssen für zenon Logic den Bestimmungen der IEC 61131-3 folgen, d.h. nur Zahlen, Buchstaben (keine Umlaute) und Unterstriche sind erlaubt. Zusätzlich darf der Name nicht mit einer Zahl beginnen. Das beinhaltet auch, dass Strukturen und Arrays des Leitsystems nicht extern sichtbar sein können, weil sie Klammern bzw. Punkte beinhalten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExternVisibleFor"

Entscheiden Sie explizit, für welche zenon Logic Projekte die Variable sichtbar sein soll. Wenn Sie das Eingabefeld leer lassen, ist die Variable für alle zenon Logic Projekte sichtbar. Sie können aber auch einzelne zenon Logic Projekte explizit angeben. Trennen Sie die Namen der einzelnen Projekt jeweils mit einem Semikolon (";"). Sie können auch mit Wildcards arbeiten, z.B. steht P1* für alle zenon Logic Projekte, die mit P1 beginnen. (Hinweis: Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.)

Die Anzahl der Zeichen ist auf maximal 64 begrenzt.

Default: -

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExternVisibleFor"


ID_FILE_NAME

Interne ID: ID_FILE_NAME

Dateiname

Name der eingebundenen Datei.
Externe Dateien, die auf diese Weise eingebunden werden, werden sowohl im Runtime-Verzeichnis als auch im Datenbank-Verzeichnis des Projektes gespeichert.
Achtung: Immer wenn neue Runtime-Dateien erzeugt werden, werden die Dateien im Runtime-Ordner mit denen des Datenbank-Ordners überschrieben. Daher sollten externe Dateien nur über das Kontextmenü der entsprechenden Datei und nicht extern geändert werden, damit die Dateien auch im Datenbank-Ordner geändert werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_FKT_PROP1

Interne ID: ID_FKT_PROP1

Typ

Der Typ wird beim Anlegen der Funktion aus der Liste der Systemfunktionen ausgewählt und kann hier nachträglich geändert werden.
Öffnet den Funktionsauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FktType"


ID_FKT_PROP2

Interne ID: ID_FKT_PROP2

Parameter

Übergabeparameter der Funktion; hängt vom Typ der Funktion ab.
Abhängig vom Typ der Funktion wird der entsprechende Parameterdialog geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Parameters"


ID_FKT_PROP3

Interne ID: ID_FKT_PROP3

Name

Eindeutige Bezeichnung der Funktion.
Die Bezeichnung wird beim Anlegen einer Funktion vom System vergeben, kann aber nachträglich geändert werden, soweit die neu vergebene Bezeichnung nicht bereits für eine andere Funktion verwendet wird.
Maximum: 128 Zeichen.
Default: Function_x (wobei x eine fortlaufende Zahl ist).

ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_FKT_PROP4

Interne ID: ID_FKT_PROP4

Aktueller Rechner

Nur verfügbar in Netzwerk-Projekten:
Die Funktion wird auf dem Rechner ausgeführt, auf dem sie angestossen wurde.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsActual"


ID_FKT_PROP5

Interne ID: ID_FKT_PROP5

Server

Nur verfügbar in Netzwerk-Projekten:
Die Funktion wird auf dem Server des Projekts ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsServer"


ID_FKT_PROP6

Interne ID: ID_FKT_PROP6

Standby

Nur verfügbar in redundanten Netzwerk-Projekten:
Die Funktion wird auf dem Standby-Server des Projekts ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsStandBy"


ID_FKT_PROP7

Interne ID: ID_FKT_PROP7

Client

Nur verfügbar in Netzwerk-Projekten:
Die Funktion wird auf allen Clients des Projekts ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsClient"


ID_FKT_PROP_GRP0

Interne ID: ID_FKT_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_FKT_PROP_GRP1

Interne ID: ID_FKT_PROP_GRP1

Ausführung

Nur verfügbar in Netzwerk-Projekten:
Auswahl auf welchem/n Rechner(n) die Funktion ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Execution"


ID_FKT_VBA_XML_PROP_587

Interne ID: ID_FKT_VBA_XML_PROP_587

Horiz. Abstand [Pixel]

Horizontaler Abstand des Endes der Rundung von der tatsächlichen Ecke in Pixel.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset_H"


ID_FKT_VBA_XML_PROP_588

Interne ID: ID_FKT_VBA_XML_PROP_588

Vertikaler Abstand [Pixel]

Vertikaler Abstand des Endes der Rundung von der tatsächlichen Ecke in Pixel.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset_V"


ID_FKTLEVELLIST

Interne ID: ID_FKTLEVELLIST

Funktionsbererechtigungen

Bestimmte Systemfunktionen (z.B: Projekt laden) können über die Berechtigungsebenen für unbefugte Benutzer gesperrt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FktLevelList"


ID_FONT_NAME

Interne ID: ID_FONT_NAME

Name

Frei vergebbare Bezeichnung, dient nur zur Information.
Default: Neue Schrift x (wobei x eine fortlaufende Zahl ist).
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_FONT_NUMMER

Interne ID: ID_FONT_NUMMER

Nummer

Eindeutige Nummer der Schrift.
Die Nummer wird beim Anlegen einer Schrift vom System vergeben. Die Nummern 1 und 2 sind fix vergeben und können nicht geändert werden. Alle anderen Schriftnummern können nachträglich geändert werden, soweit die neu vergebene Nummer nicht bereits für eine andere Schrift verwendet wird.

Hinweis: Bei gleichen Nummern im Globalprojekt und im Projekt wird die Projektschrift verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Number"


ID_FONT_PROP_GRP

Interne ID: ID_FONT_PROP_GRP

Schrift

Enthält Eigenschaften für die Schriftart.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_FONT_SCHRIFTART

Interne ID: ID_FONT_SCHRIFTART

Schriftart

Auswahl der Schriftart aus den auf dem Computer installierten Schriftarten.
Achtung: Der Dialog zur Auswahl der Schriftart ist ein Windows Standarddialog. Dieser ermöglicht auch die Auswahl weiterer Eigenschaften wie Schriftfarbe. Diese zusätzlichen Einstellungen haben aber keine Wirkung auf die Darstellung in zenon.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Font"


ID_FONTLIST_NAME

Interne ID: ID_FONTLIST_NAME

Name

Name der Schriftliste.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_FONTLIST_PROP_GRP

Interne ID: ID_FONTLIST_PROP_GRP

Schriftliste

Eigenschaften für die Schriftliste.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_GFXRT_CHECKIMAGE_0FF

Interne ID: ID_GFXRT_CHECKIMAGE_0FF

Aus

Auswahl einer Grafik, die zur Runtime den Status „Wert ist 0 und Eigenschaft kann editiert werden" darstellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CheckOffImage"


ID_GFXRT_CHECKIMAGE_0FF_INACTIVE

Interne ID: ID_GFXRT_CHECKIMAGE_0FF_INACTIVE

Aus (inaktiv)

Auswahl einer Grafik, die zur Runtime den Status „Wert ist 0 und Eigenschaft kann nicht editiert werden" darstellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CheckOffImageInActive"


ID_GFXRT_CHECKIMAGE_0N

Interne ID: ID_GFXRT_CHECKIMAGE_0N

Ein

Auswahl einer Grafik, die zur Runtime den Status „Wert ist 1 und Eigenschaft kann editiert werden" darstellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CheckOnImage"


ID_GFXRT_CHECKIMAGE_0N_INACTIVE

Interne ID: ID_GFXRT_CHECKIMAGE_0N_INACTIVE

Ein (inaktiv)

Auswahl einer Grafik, die zur Runtime den Status „Wert ist 1 und Eigenschaft kann nicht editiert werden" darstellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CheckOnImageInActive"


ID_HILFE_GRP

Interne ID: ID_HILFE_GRP

Hilfe

Eigenschaften für die Online-Hilfe des Objekts.
Wenn hier keine Hilfe für das Element definiert ist, kann direkt im Kontextmenu dieses Elements ein allgemeines Hilfekapitel definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Help"


ID_IEC870_103_FktType

Interne ID: ID_IEC870_103_FktType

IEC870-103 FUNCTION TYPE

Geben Sie einen Wert ein. Entspricht FUN in der Norm.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IEC870_103_FktType"


ID_IEC870_103_Index

Interne ID: ID_IEC870_103_Index

IEC870-103 Index

Geben Sie einen Wert ein. Enspricht der Reihenfolge von MEA in ASDU 3 oder 9.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IEC870_103_Index"


ID_IEC870_103_InfNo

Interne ID: ID_IEC870_103_InfNo

IEC870-103 INFORMATION NUMBER

Geben Sie einen Wert ein. Entspricht INF in der Norm.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IEC870_103_InfNo"


ID_IEC870_COA1

Interne ID: ID_IEC870_COA1

IEC870 COA

Geben Sie die Common Object Address (COA) ein. Die Grenzen des verfügbaren Wertebereichs richten sich nach den Treibereinstellungen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IEC870_COA1"


ID_IEC870_IOA1

Interne ID: ID_IEC870_IOA1

IEC870 IOA

Geben Sie die Information Object Address (IOA) ein. Die Grenzen des verfügbaren Wertebereichs richten sich nach den Treibereinstellungen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IEC870_IOA1"


ID_IEC870_TYPE

Interne ID: ID_IEC870_TYPE

IEC870 Type identification

Wählen Sie in der Dropdown-Liste den ASDU-Typ des Datenpunktes.

default: T00 internal state

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IEC870_TYPE"


ID_IMM_DNS

Interne ID: ID_IMM_DNS

Datenbank

Definition der ODBC-Verbindung für die Datenbank des Industrial Maintenance Managers (IMM).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IMMDns"


ID_IMM_TABLEDEV

Interne ID: ID_IMM_TABLEDEV

Tabelle für Geräte

Name der Tabelle in der Datenbank für die Geräte. Bei Leerzeichen im Namen muss der gesamte Name in Hochkomma angeführt werden. Generell sollten jedoch Leerzeichen im Namen vermieden werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IMMTableDevice"


ID_IMM_TABLEDOC

Interne ID: ID_IMM_TABLEDOC

Tabelle für Dokumente

Name der Tabelle in der Datenbank für die Dokumente. Bei Leerzeichen im Namen muss der gesamte Name in Hochkomma angeführt werden. Generell sollten jedoch Leerzeichen im Namen vermieden werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IMMTableDoc"


ID_IMM_TABLEHIST

Interne ID: ID_IMM_TABLEHIST

Tabelle für Historie

Name der Tabelle in der Datenbank für die Historie. Bei Leerzeichen im Namen muss der gesamte Name in Hochkomma angeführt werden. Generell sollten jedoch Leerzeichen im Namen vermieden werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IMMTableHist"


ID_IMM_TABLEMAINT

Interne ID: ID_IMM_TABLEMAINT

Tabelle für Wartungsarb.

Name der Tabelle in der Datenbank für die Wartungsarbeiten. Bei Leerzeichen im Namen muss der gesamte Name in Hochkomma angeführt werden. Generell sollten jedoch Leerzeichen im Namen vermieden werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IMMTableMaint"


ID_IMM_USERLVL

Interne ID: ID_IMM_USERLVL

Berechtigungsebene

Berechtigungsgruppe, die man braucht um Daten aus der Datenbank löschen zu können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IMMUserLvl"


ID_INITIALVALUE

Interne ID: ID_INITIALVALUE

Extern Initwert

Externe Eigenschaft für zenon Logic. Betrifft nur Variablen, die nicht vom straton-Treiber sind.
Initialwert der Variable in zenon Logic beim Kaltstart bzw. Warmstart.
Die erlaubte Eingabe hier hängt vom Datentyp der Variable ab. So können für ganzzahlige Variablen nur Werte ohne Dezimalstellen eingegeben werden. Für Fließkomma-Variablen muss ein Punkt als Dezimaltrennzeichen verwendet werden, ein Komma funktioniert nicht.
Das Leitsystem prüft die Gültigkeit der Eingabe hier nicht. Das kann zu einer Fehlermeldung in zenon Logic führen.

ACHTUNG: Bei Variablen des internen Treibers muss diese Eigenschaft den selben Wert haben wie der Initialwert in den Einstellungen für interne Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InitialValue"


ID_KNOTEN_VERKN

Interne ID: ID_KNOTEN_VERKN

Verknüpfungsregel

Eigenschaften für das Ersetzen der Verknüpfungen zu Variablen und/oder Funktionen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Linkings"


ID_LASTUSEDOFFSET

Interne ID: ID_LASTUSEDOFFSET

letzter verwendeter Offset

Anzeige des zuletzt von der automatischen Adressierung verwendeten Offsets.
Diese Eigenschaft dient nur der Information und kann nicht verändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LastUsedOffset"


ID_LEVELEDIT

Interne ID: ID_LEVELEDIT

Berechtigungsebenen umbenennen

Den 128 Berechtigungsebenen kann neben der Nummer ein Name zugewiesen werden. Hier wird der Dialog für die Definition der Namen geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserLevelList"


ID_LEVELLIST

Interne ID: ID_LEVELLIST

Berechtigungsebenen

Eine oder mehr der 128 Berechtigungsgruppen können dem Benutzer zugeordnet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserLevel"


ID_MATHVAR_PROP_ENABLE_VAR

Interne ID: ID_MATHVAR_PROP_ENABLE_VAR

Berechnung aktivieren

Ordnet der Mathematik-Variablen eine Variable zu, deren Wert steuert, ob die Berechnung ausgeführt wird. Die Zuordnung einer Variablen aktiviert die Eigenschaft.

Klick auf die Schaltfläche ... oder in das Feld mit der Variablen öffnet den Dialog zur Auswahl einer Variablen.

Default: deaktiviert, keine Variable zugeordnet.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableCalc"


ID_MATHVAR_PROP_FORMEL

Interne ID: ID_MATHVAR_PROP_FORMEL

Formel

Öffnet den Dialog zur Eingabe der Formel für die Berechnung der Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Formula"


ID_MINPWLENGTH

Interne ID: ID_MINPWLENGTH

Min. Passwortlänge

Zeichenanzahl, die ein Passwort mindestens haben muss.
Minimum: 0.
Maximum: 20.
Default: 6.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinPwLength"


ID_MONITOR_VERWALTUNG

Interne ID: ID_MONITOR_VERWALTUNG

Monitorverwaltung

Der Konfigurationsdialog für die Monitorverwaltung wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MonitorAministration"


ID_MSGCONTROL_DISPATCHER_ACTIVE

Interne ID: ID_MSGCONTROL_DISPATCHER_ACTIVE

Versandart aktiv

Aktiv: Der Versand von Nachrichten über dieses Medium ist möglich.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Active"


ID_MSGCONTROL_ENGINE_EXPORTTOMESSAGE32

Interne ID: ID_MSGCONTROL_ENGINE_EXPORTTOMESSAGE32

Einstellungen in Messag32.ini exportieren (v6.XX)

Speichert Einstellungen, die ab Version 7 getroffen werden, für Versionen 6.xx in der messag32.ini. Klick auf Schaltfläche startet Export. Aktuelle Einstellungen der messag32.ini werden nach einer Sicherheitsabfrage überschrieben. Die Einstellungen der messag32.ini dienen der Kompatibilität und betreffen nur zenon Versionen 6.xx. Ab Version 7 werden die Einstellungen in der zenon6.ini gespeichert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExportToMessag32"


ID_MSGCONTROL_ENGINE_GRP

Interne ID: ID_MSGCONTROL_ENGINE_GRP

Message Control

Gruppe für projektübergreifende Einstellungen im Message Control.

Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

Interne ID: ID_MSGCONTROL_ENGINE_GRP

Projektspezifische Einstellungen

Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgCtrlSettings"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgCtrlSettings"


ID_MSGCONTROL_MODEM_COUNTWELCOME

Interne ID: ID_MSGCONTROL_MODEM_COUNTWELCOME

Begrüßungstext wiederholen

Anzahl der Wiederholungen für den Willkommenstext.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CountWelcome"


ID_MSGCONTROL_MODEM_GRP

Interne ID: ID_MSGCONTROL_MODEM_GRP

Sprachnachricht (Audiodatei)

Einstellungen für die Gruppe Telefon.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DispatchSettings"


ID_MSGCONTROL_MODEM_IGNOREDISCONNECT

Interne ID: ID_MSGCONTROL_MODEM_IGNOREDISCONNECT

Auflegen ignorieren

Aktiv: Ein Verbindungsabbruch (z. B. Empfänger beendet Gespräch) wird ignoriert und die Nachricht wird vollständig abgespielt, bevor die Leitung geschlossen wird.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IgnoreDisconnect"


ID_MSGCONTROL_MODEM_LINEID

Interne ID: ID_MSGCONTROL_MODEM_LINEID

Leitungs-Id

Automatisch erstelle Gerät-ID, die das ausgewählte Modem identifiziert. Dient bei mehreren Modems gleichen Namens zur Unterscheidung der Geräte. Nur Anzeige, nicht veränderbar.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineId"


ID_MSGCONTROL_MODEM_LINENAME

Interne ID: ID_MSGCONTROL_MODEM_LINENAME

Leitungsname

Auswahl des zu verwenden Modems aus Dropdownliste.

Wird keine Dropdownliste angezeigt, dann wurde für diesen Rechner kein Modem konfiguriert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Line"


ID_MSGCONTROL_MODEM_TIMEOUT

Interne ID: ID_MSGCONTROL_MODEM_TIMEOUT

Timeout

Zeit in Minuten, nach der eine stehende Verbindung abgebrochen und beendet werden soll. Zeitintervall muss länger sein als die für das Abspielen und Bestätigen der Nachricht benötigte Zeit.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimeOut"


ID_MSGCONTROL_OUTLOOK_GRP

Interne ID: ID_MSGCONTROL_OUTLOOK_GRP

E-Mail Nachricht (Outlook)

Gruppe für Einstellungen der Versandart Outlook.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DispatchSettings"


ID_MSGCONTROL_OUTLOOK_PROFILE

Interne ID: ID_MSGCONTROL_OUTLOOK_PROFILE

Profil

Name des Outlook Profils, das für den Versand benutzt werden soll. Auswahl aus Dropdownliste.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Profile"


ID_MSGCONTROL_OUTLOOK_SUBJECT

Interne ID: ID_MSGCONTROL_OUTLOOK_SUBJECT

Betreff (Id)

Eindeutiger Betreff der ausgehenden Nachricht. Dieser dient bei eingehenden Nachrichten als Kriterium, ob die Nachricht für Message Control bestimmt ist und verarbeitet werden soll.

Eingehenden E-Mails müssen diesen Text im Betreff enthalten, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Betreff nicht enthalten, werden nicht an Message Control weitergeleitet.

Mindestlänge: 4 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Subject"


ID_MSGCONTROL_PROJECT_ACTIVEATSTARTUP

Interne ID: ID_MSGCONTROL_PROJECT_ACTIVEATSTARTUP

Aktiv bei Runtimestart

Aktiv: Message Control wird mit der Runtime gestartet.

Default: aktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ActiveAtStartup"


ID_MSGCONTROL_PROJECT_ATTEMPTS

Interne ID: ID_MSGCONTROL_PROJECT_ATTEMPTS

Max. Anzahl der Versuche

Maximale Anzahl der Versandversuche bei Versandfehler.

Maximum: 100

Minimum: 1

Default: 3

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Attempts"


ID_MSGCONTROL_PROJECT_CELITEMS

Interne ID: ID_MSGCONTROL_PROJECT_CELITEMS

In CEL protokollieren

Legt fest, welche Ereignisse in der CEL protokolliert werden. Auswahl aus Dropdownliste:

- alle Bestätigungen

- keine Bestätigungen

- nur negative Bestätigungen

- nur positive Bestätigungen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CelDetail"


ID_MSGCONTROL_PROJECT_COLOR_ERROR

Interne ID: ID_MSGCONTROL_PROJECT_COLOR_ERROR

Fehler beim Versand

Definiert die Farbe, mit der die Spalte Status im Bild vom Typ Message Control hinterlegt wird, wenn der Versand einer Nachricht fehl geschlagen ist. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Farbe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ErrorIColor"


ID_MSGCONTROL_PROJECT_COLOR_SENDING

Interne ID: ID_MSGCONTROL_PROJECT_COLOR_SENDING

Nachricht wird verschickt

Definiert die Farbe, mit der die Spalte Status im Bild vom Typ Message Control hinterlegt wird, solange die Nachricht verschickt wird. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Farbe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SendingColor"


ID_MSGCONTROL_PROJECT_COLOR_SENT

Interne ID: ID_MSGCONTROL_PROJECT_COLOR_SENT

Nachricht wurde verschickt

Definiert die Farbe, mit der die Spalte Status im Bild vom Typ Message Control hinterlegt wird, wenn die Nachricht erfolgreich verschickt wurde. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Farbe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SentColor"


ID_MSGCONTROL_PROJECT_GRP

Interne ID: ID_MSGCONTROL_PROJECT_GRP

Projektspezifische Einstellungen

Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

Interne ID: ID_MSGCONTROL_PROJECT_GRP

Message Control

Gruppe für projektübergreifende Einstellungen im Message Control.

Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgCtrlSettings"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgCtrlSettings"


ID_MSGCONTROL_PROJECT_LOG_DELETE

Interne ID: ID_MSGCONTROL_PROJECT_LOG_DELETE

Manuelles löschen von Nachrichten in CEL protokolieren.

Aktiv: Manuelles Löschen von Einträgen aus der CEL wird in der CEL protokolliert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LogDeleteActions"


ID_MSGCONTROL_PROJECT_STATUSIMAGE_ERROR

Interne ID: ID_MSGCONTROL_PROJECT_STATUSIMAGE_ERROR

Fehler beim Versand

Definiert eine Grafik, die im Bild vom Typ Message Control in der Spalte Status angezeigt wird, wenn der Sendeversuch für eine Nachricht fehl geschlagen ist. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Grafikdatei.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ErrorImage"


ID_MSGCONTROL_PROJECT_STATUSIMAGE_SENDING

Interne ID: ID_MSGCONTROL_PROJECT_STATUSIMAGE_SENDING

Nachricht wird verschickt

Definiert eine Grafik, die im Bild vom Typ Message Control in der Spalte Status angezeigt wird, solange versucht wird, eine Nachricht zu verschicken. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Grafikdatei.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SendingImage"


ID_MSGCONTROL_PROJECT_STATUSIMAGE_SENT

Interne ID: ID_MSGCONTROL_PROJECT_STATUSIMAGE_SENT

Nachricht wurde verschickt

Definiert eine Grafik, die im Bild vom Typ Message Control in der Spalte Status angezeigt wird, sobald die Nachricht erfolgreich verschickt wurde. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Grafikdatei.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SentImage"


ID_MSGCONTROL_PROJECT_SUBJECT_DYN

Interne ID: ID_MSGCONTROL_PROJECT_SUBJECT_DYN

Dynamischer Teil des Betreffs

Definiert den projektspezifischen Teil des Betreffs ausgehender und eingehender Nachrichten. Wird zusammen mit der Eigenschaft E-Mail Nachricht (Outlook)/Betreff (Id) bzw.E-Mail Nachricht (SMTP) /E-Mail Betreff in den globalen Message Control Versandeinstellungen verwendet. Eingehende Nachrichten werden auf diesen Inhalt zur Weiterleitung an Message Control gefiltert.

Interne ID: ID_MSGCONTROL_PROJECT_SUBJECT_DYN

Message Control

Gruppe für projektübergreifende Einstellungen im Message Control.

Projektspezifische Einstellungen konfigurieren Sie im Projektbaum mit den Eigenschaften für Projektspezifische Einstellungen im Konten Message Control.

Interne ID: ID_MSGCONTROL_PROJECT_SUBJECT_DYN

Projektspezifische Einstellungen

Enthält projektspezifische Einstellungen für die Konfiguration des Moduls Message Control.

Globale Einstellungen für den Versand konfigurieren Sie im Bereich Arbeitsplatz mit den Eigenschaften der Gruppe Message Control.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubjectDyn"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubjectDyn"

Interne ID: ID_MSGCONTROL_PROJECT_SUBJECT_DYN

E-Mail Betreff

Eingabe des Betreffs für ausgehende E-Mails.

Eingehenden E-Mails müssen diesen Text ebenfalls im Betreff stehen haben, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Text nicht enthalten, werden weder an Message Control weitergeleitet noch vom Server gelöscht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubjectDyn"

Interne ID: ID_MSGCONTROL_PROJECT_SUBJECT_DYN

E-Mail Nachricht (SMTP)

Einstellungen zum E-Mail-Versand per SMTP.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubjectDyn"

Interne ID: ID_MSGCONTROL_PROJECT_SUBJECT_DYN

Betreff (Id)

Eindeutiger Betreff der ausgehenden Nachricht. Dieser dient bei eingehenden Nachrichten als Kriterium, ob die Nachricht für Message Control bestimmt ist und verarbeitet werden soll.

Eingehenden E-Mails müssen diesen Text im Betreff enthalten, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Betreff nicht enthalten, werden nicht an Message Control weitergeleitet.

Mindestlänge: 4 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubjectDyn"

Interne ID: ID_MSGCONTROL_PROJECT_SUBJECT_DYN

E-Mail Nachricht (Outlook)

Gruppe für Einstellungen der Versandart Outlook.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubjectDyn"

Der Text kann Platzhalter beinhalten für:

  • Schlüssel aus der Sprachtabelle
  • Name einer Variablen
  • zusammengesetzter Eintrag in der Sprachtabelle

Syntax: $ kennzeichnet Text; Textteile werden durch Semikolon (;)getrennt, der Text muss mit einem Semikolon (;)enden.
Beispiel: $@Achtung;%Var1;

Eine Liste der Parameter finden Sie im Kapitel Grenzwerttext Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubjectDyn"


ID_MSGCONTROL_PROJECT_TIMETOWAIT

Interne ID: ID_MSGCONTROL_PROJECT_TIMETOWAIT

Wartezeit zwischen Versuchen [min]

Wartezeit in Minuten für die Wiederholung zwischen zwei Sendeversuchen bzw. Weiterleitung einer Nachricht.

Default: 5

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimeToWait"


ID_MSGCONTROL_SMSGATEWAY_GRP

Interne ID: ID_MSGCONTROL_SMSGATEWAY_GRP

SMS-Nachricht (SMS-Gateway)

Einstellungen für SMS-Gateway.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DispatchSettings"


ID_MSGCONTROL_SMSGATEWAY_INBOX

Interne ID: ID_MSGCONTROL_SMSGATEWAY_INBOX

Eingangsordner

Eingangsordner des SMS-Servers für den SMS-Versand.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Inbox"


ID_MSGCONTROL_SMSGATEWAY_ORIGINID

Interne ID: ID_MSGCONTROL_SMSGATEWAY_ORIGINID

Absenderkennung

Absenderkennung für SMS-Versand.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OriginId"


ID_MSGCONTROL_SMSGATEWAY_OUTBOX

Interne ID: ID_MSGCONTROL_SMSGATEWAY_OUTBOX

Ausgangsordner

Ausgangsordner des SMS-Servers für den SMS-Versand.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Outbox"


ID_MSGCONTROL_SMSGATEWAY_PREFIX

Interne ID: ID_MSGCONTROL_SMSGATEWAY_PREFIX

Anfangsbuchstabe der SMS-Dateien

Anfangsbuchstabe der SMS-Dateien. Muss für jedes Projekt eindeutig sein.

Länge: 1 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Prefix"


ID_MSGCONTROL_SMSGATEWAY_SEMAPHOREPREFIX

Interne ID: ID_MSGCONTROL_SMSGATEWAY_SEMAPHOREPREFIX

Anfangsbuchstabe der Sperr/Semaphor-Dateien

Anfangsbuchstabe der Sperrdatei. Muss für jedes Projekt eindeutig sein.

Länge: 1 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SemaPrefix"


ID_MSGCONTROL_SMSGATEWAY_SMARTALARM

Interne ID: ID_MSGCONTROL_SMSGATEWAY_SMARTALARM

Smart Alarming

Aktiv: Smartalarming wird verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmartAlarm"


ID_MSGCONTROL_SMSGATEWAY_STATUSBOX

Interne ID: ID_MSGCONTROL_SMSGATEWAY_STATUSBOX

Statusordner

Ordner des SMS-Servers für Statusmeldung bei SMS-Versand.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Statusbox"


ID_MSGCONTROL_SMSGATEWAY_TIMEOUT

Interne ID: ID_MSGCONTROL_SMSGATEWAY_TIMEOUT

Timeout

Timeout-Zeit für ausgehende Nachrichten in Minuten. Legt fest, nach welcher Zeitspanne eine Nachricht als "nicht erfolgreich verschickt" interpretiert wird.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimeOut"


ID_MSGCONTROL_SPEECH_GRP

Interne ID: ID_MSGCONTROL_SPEECH_GRP

Sprachnachricht (Text to Speech)

Einstellungen für die Sprachausgabe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DispatchSettings"


ID_MSGCONTROL_SPEECH_RATE

Interne ID: ID_MSGCONTROL_SPEECH_RATE

Geschwindigkeit des Redeflusses

Geschwindigkeit der Stimme.

Minimum: -10

Maximum: 10

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Rate"


ID_MSGCONTROL_SPEECH_VOICEID

Interne ID: ID_MSGCONTROL_SPEECH_VOICEID

Stimme

Auswahl der Stimme und Sprache aus Dropdownliste.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VoiceId"


ID_MSGCONTROL_SPEECH_VOLUME

Interne ID: ID_MSGCONTROL_SPEECH_VOLUME

Lautstärke

Lautstärke der Stimme. Zahl entspricht dem Prozentwert vom Maximalwert der gewählten Stimme.

Maximum: 100

Minimum: 0
0: Wert vom Betriebssystem wird ohne Änderung übernommen.

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Volume"


ID_MSGCTRL_GRP

Interne ID: ID_MSGCTRL_GRP

Message Control

Eigenschaften für die Verwendung der Benutzers im Message Control.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Message Control"


ID_MSGCTRL_MAIL_POP_APOP

Interne ID: ID_MSGCTRL_MAIL_POP_APOP

APOP zur Authentifizierung verwenden

Steuert die Authentifizierung am Posteingangsserver.

Aktiv: Zur Authentifizierung wird das APOP Kommando anstelle von Benutzer (USER) und Passwort (PASS) verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopUseApop"


ID_MSGCTRL_MAIL_POP_GROUP

Interne ID: ID_MSGCTRL_MAIL_POP_GROUP

Posteingangsserver

Eigenschaften für die Konfiguration des POP3 Servers für den Posteingang.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InboundServerSettings"


ID_MSGCTRL_MAIL_POP_KEEP_MAILS

Interne ID: ID_MSGCTRL_MAIL_POP_KEEP_MAILS

Gelesene E-Mails am Server belassen

Aktiv: E-Mails werden nach dem Abruf am Server nicht gelöscht.

Default: inaktiv

Hinweis: : Da POP3 keinerlei Möglichkeit zum Filtern der Mails beim Abrufen beinhaltet, werden immer alle im Posteingang vorhandenen Mails abgerufen. Ist diese Eigenschaft aktiv, steigt der Speicherverbauch am Server und die Performance beim ABruf kann sinken.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopKeepMails"


ID_MSGCTRL_MAIL_POP_PASSWORD

Interne ID: ID_MSGCTRL_MAIL_POP_PASSWORD

Passwort

Passwort für die Anmeldung am Posteingangsserver (POP3).

Das Passwort wird verschlüsselt gespeichert und nur für die Authentifizierung entschlüsselt. Bei der Eingabe werden keine Zeichen im Klartext angezeigt. Das Feld zeigt immer 16 Zeichen an, unabhängig von der tatsächlichen Länge des Passworts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopPassword"


ID_MSGCTRL_MAIL_POP_POLLING_INTERVALL

Interne ID: ID_MSGCTRL_MAIL_POP_POLLING_INTERVALL

Minimale Zeitspanne zwischen Abfragen (s)

Minimaler Abstand in Sekunden zwischen zwei Abruf-Versuchen. Wert sollte die Vorgaben des POP3 Servers nicht unterschreiten.

Minimalwert: 10

Default: 60

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopPollingIntervall"


ID_MSGCTRL_MAIL_POP_PORT

Interne ID: ID_MSGCTRL_MAIL_POP_PORT

Port

Port, auf dem der POP3 Server angesprochen wird.

Maximalwert: 65535

Default für ungesicherte Verbindung: 110

Default für gesicherte Verbindung: 995

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopPort"


ID_MSGCTRL_MAIL_POP_SECURITY

Interne ID: ID_MSGCTRL_MAIL_POP_SECURITY

Verschlüsselung

Auswahl der Verschlüsselung für die Verbindung. Klick öffnet Dropdownliste für Auswahl. Mögliche Optionen:

keine: die Verbindung wird ungesichert aufgebaut.

SSL Version 2 und 3: die Verbindung wird mit dem hybriden Verschlüsselungsmodell SSL aufgebaut.

TLS Version 1: die Verbindung wird mit TLS aufgebaut. TLS Version1 ist der Nachfolger von SSL und entspricht SSL 3.1.

Default: SSL Version 2 und 3

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopSecurity"


ID_MSGCTRL_MAIL_POP_SERVER

Interne ID: ID_MSGCTRL_MAIL_POP_SERVER

Serveradresse

Vollständige ADresse des POP3 Servers.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopServer"


ID_MSGCTRL_MAIL_POP_USERNAME

Interne ID: ID_MSGCTRL_MAIL_POP_USERNAME

Benutzername

Benutzername für die Anmeldung am Posteingangsserver (POP3).

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PopUser"


ID_MSGCTRL_MAIL_SMTP_AUTHENTICATION

Interne ID: ID_MSGCTRL_MAIL_SMTP_AUTHENTICATION

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpAuthentication"


ID_MSGCTRL_MAIL_SMTP_GROUP

Interne ID: ID_MSGCTRL_MAIL_SMTP_GROUP

Postausgangsserver

Eigenschaften für die Konfiguration des SMTP Servers für den Postausgang.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OutboundServerSettings"


ID_MSGCTRL_MAIL_SMTP_IS_POP_SERVER

Interne ID: ID_MSGCTRL_MAIL_SMTP_IS_POP_SERVER

Posteingangsserver für ausgehende E-Mails verwenden

Aktiv: Der Posteingangsserver wird als Server für den Postausgang verwendet. Diese Eigenschaft betrifft nur die Serveradresse.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUsePopServer"


ID_MSGCTRL_MAIL_SMTP_OTHER_CREDENTIALS

Interne ID: ID_MSGCTRL_MAIL_SMTP_OTHER_CREDENTIALS

Andere Anmeldedaten als am Posteingangsserver verwenden

Nur verfügbar, wenn für die Eigenschaft Authentifizierung am Postausgangsserver SMTP Authentifizierung am Postausgangsserver verwenden gewählt wurde.

Interne ID: ID_MSGCTRL_MAIL_SMTP_OTHER_CREDENTIALS

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpDifferentCredentials"

Aktiv: Für die Authentifizierung am Postausgangsserver werden andere Anmeldedaten als am Posteingangsserver verwendet.

Inaktiv: Anmeldedaten für den Posteingangsserver werden auch Postausgangsserver verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpDifferentCredentials"


ID_MSGCTRL_MAIL_SMTP_PASSWORD

Interne ID: ID_MSGCTRL_MAIL_SMTP_PASSWORD

Passwort

Passwort für den Postausgangsserver.

Nur verfügbar, wenn die Eigenschaft Andere Anmeldedaten als am Posteingangsserver verwenden aktiviert wurde. Ist die Eigenschaft inaktiv, ist das in der Eigenschaft Passwort der Gruppe Posteingangsserver definierte Passwort hinterlegt.

Interne ID: ID_MSGCTRL_MAIL_SMTP_PASSWORD

Posteingangsserver

Eigenschaften für die Konfiguration des POP3 Servers für den Posteingang.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpPassword"

Interne ID: ID_MSGCTRL_MAIL_SMTP_PASSWORD

Passwort

Passwort für die Anmeldung am Posteingangsserver (POP3).

Das Passwort wird verschlüsselt gespeichert und nur für die Authentifizierung entschlüsselt. Bei der Eingabe werden keine Zeichen im Klartext angezeigt. Das Feld zeigt immer 16 Zeichen an, unabhängig von der tatsächlichen Länge des Passworts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpPassword"

Interne ID: ID_MSGCTRL_MAIL_SMTP_PASSWORD

Andere Anmeldedaten als am Posteingangsserver verwenden

Nur verfügbar, wenn für die Eigenschaft Authentifizierung am Postausgangsserver SMTP Authentifizierung am Postausgangsserver verwenden gewählt wurde.

Interne ID: ID_MSGCTRL_MAIL_SMTP_PASSWORD

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpPassword"

Aktiv: Für die Authentifizierung am Postausgangsserver werden andere Anmeldedaten als am Posteingangsserver verwendet.

Inaktiv: Anmeldedaten für den Posteingangsserver werden auch Postausgangsserver verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpPassword"

Das Passwort wird verschlüsselt gespeichert und nur für die Authentifizierung entschlüsselt. Bei der Eingabe werden keine Zeichen im Klartext angezeigt. Das Feld zeigt immer 16 Zeichen an, unabhängig von der tatsächlichen Länge des Passworts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpPassword"


ID_MSGCTRL_MAIL_SMTP_POP_GROUP

Interne ID: ID_MSGCTRL_MAIL_SMTP_POP_GROUP

E-Mail Nachricht (SMTP)

Einstellungen zum E-Mail-Versand per SMTP.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DispatchSettings"


ID_MSGCTRL_MAIL_SMTP_PORT

Interne ID: ID_MSGCTRL_MAIL_SMTP_PORT

Port

Port für die Verbindung zum Postausgangsserver (SMTP).

Maximal: 65535

Default: 25

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpPort"


ID_MSGCTRL_MAIL_SMTP_SECURITY

Interne ID: ID_MSGCTRL_MAIL_SMTP_SECURITY

Verschlüsselung

Auswahl der Verschlüsselung für die Verbindung. Klick öffnet Dropdownliste für Auswahl. Mögliche Optionen:

keine: die Verbindung wird ungesichert aufgebaut.

SSL Version 2 und 3: die Verbindung wird mit dem hybriden Verschlüsselungsmodell SSL aufgebaut.

TLS Version 1: die Verbindung wird mit TLS aufgebaut. TLS Version1 ist der Nachfolger von SSL und entspricht SSL 3.1.

Default: keine

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpSecurity"


ID_MSGCTRL_MAIL_SMTP_SERVER

Interne ID: ID_MSGCTRL_MAIL_SMTP_SERVER

Serveradresse

Nur verfügbar, wenn Posteingangsserver für ausgehende E-Mails verwenden inaktiv ist.

Interne ID: ID_MSGCTRL_MAIL_SMTP_SERVER

Posteingangsserver für ausgehende E-Mails verwenden

Aktiv: Der Posteingangsserver wird als Server für den Postausgang verwendet. Diese Eigenschaft betrifft nur die Serveradresse.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpServer"

Vollständige Adresse des SMTP Servers.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpServer"


ID_MSGCTRL_MAIL_SMTP_SRCADDR

Interne ID: ID_MSGCTRL_MAIL_SMTP_SRCADDR

Adresse für ausgehende E-Mails

Nur verfügbar, wenn die Eigenschaft Benutzername ist Adresse für ausgehende E-Mails inaktiv oder nicht verfügbar ist.

Interne ID: ID_MSGCTRL_MAIL_SMTP_SRCADDR

Benutzername ist Adresse für ausgehende E-Mails

Nur verfügbar, wenn die EigenschaftAuthentifizierung am Postausgangsserver einen anderen Wert als keine Authentifizierung enthält.

Interne ID: ID_MSGCTRL_MAIL_SMTP_SRCADDR

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpOutMailAddress"

Aktiv: Der für die Authentifizierung am SMTP Server verwendete Benutzername wird auch als Absenderadresse für die ausgehende E-Mails verwendet.

Inaktiv: der in der Eigenschaft Adresse für ausgehende E-Mails definierte Absender wird verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpOutMailAddress"

Absenderadresse für ausgehende E-Mails.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpOutMailAddress"


ID_MSGCTRL_MAIL_SMTP_SRCADDR_IS_USERNAME

Interne ID: ID_MSGCTRL_MAIL_SMTP_SRCADDR_IS_USERNAME

Benutzername ist Adresse für ausgehende E-Mails

Nur verfügbar, wenn die EigenschaftAuthentifizierung am Postausgangsserver einen anderen Wert als keine Authentifizierung enthält.

Interne ID: ID_MSGCTRL_MAIL_SMTP_SRCADDR_IS_USERNAME

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUserIsOutMailAddress"

Aktiv: Der für die Authentifizierung am SMTP Server verwendete Benutzername wird auch als Absenderadresse für die ausgehende E-Mails verwendet.

Inaktiv: der in der Eigenschaft Adresse für ausgehende E-Mails definierte Absender wird verwendet.

Interne ID: ID_MSGCTRL_MAIL_SMTP_SRCADDR_IS_USERNAME

Adresse für ausgehende E-Mails

Nur verfügbar, wenn die Eigenschaft Benutzername ist Adresse für ausgehende E-Mails inaktiv oder nicht verfügbar ist.

Absenderadresse für ausgehende E-Mails.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUserIsOutMailAddress"

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUserIsOutMailAddress"


ID_MSGCTRL_MAIL_SMTP_SUBJECT

Interne ID: ID_MSGCTRL_MAIL_SMTP_SUBJECT

E-Mail Betreff

Eingabe des Betreffs für ausgehende E-Mails.

Eingehenden E-Mails müssen diesen Text ebenfalls im Betreff stehen haben, um vom System weiter verarbeitet zu werden. E-Mails, die diesen Text nicht enthalten, werden weder an Message Control weitergeleitet noch vom Server gelöscht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpSubject"


ID_MSGCTRL_MAIL_SMTP_USERNAME

Interne ID: ID_MSGCTRL_MAIL_SMTP_USERNAME

Benutzername

Benutzername für den Postausgangsserver.

Nur verfügbar, wenn Andere Anmeldedaten als am Posteingangsserver verwenden aktiviert wurde. Ist die Eigenschaft inaktiv, wird der Benutzername aus der Eigenschaft Benutzername in der Gruppe Posteingangsserver angezeigt. Sonst wird der zuletzt eingegebene Benutzername für den Postausgangsserver angezeigt.

Interne ID: ID_MSGCTRL_MAIL_SMTP_USERNAME

Posteingangsserver

Eigenschaften für die Konfiguration des POP3 Servers für den Posteingang.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUser"

Interne ID: ID_MSGCTRL_MAIL_SMTP_USERNAME

Benutzername

Benutzername für die Anmeldung am Posteingangsserver (POP3).

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUser"

Interne ID: ID_MSGCTRL_MAIL_SMTP_USERNAME

Andere Anmeldedaten als am Posteingangsserver verwenden

Nur verfügbar, wenn für die Eigenschaft Authentifizierung am Postausgangsserver SMTP Authentifizierung am Postausgangsserver verwenden gewählt wurde.

Interne ID: ID_MSGCTRL_MAIL_SMTP_USERNAME

Authentifizierung am Postausgangsserver

Auswahl der Authentifizierung am Postausgangsserver. Klick öffnet Dropdownliste zur Auswahl:

Keine Authentifizierung: Versand erfolgt ohne Authentifizierung

Vor E-Mailversand am Posteingangsserver anmelden: Bevor eine Nachricht verschickt wird, erfolgt die Anmeldung am POP3 Server.

SMTP Authentifizierung am Postausgangsserver verwenden: Vor dem Versand erfolgt eine Anmeldung am SMPT Server.

Default: Keine Auswahl

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUser"

Aktiv: Für die Authentifizierung am Postausgangsserver werden andere Anmeldedaten als am Posteingangsserver verwendet.

Inaktiv: Anmeldedaten für den Posteingangsserver werden auch Postausgangsserver verwendet.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUser"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmtpUser"


ID_NETZ_APP_CLOSE_BOX

Interne ID: ID_NETZ_APP_CLOSE_BOX

Beenden-Benachrichtigung

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Aktiv: Beim Beenden der Runtime auf einem Server wird auf allen verbundenen Clients eine Meldung angezeigt, die das Beenden der Runtime anzeigt. Das Beenden der Runtime wird um 70 Sekunden verzögert, damit auf den Clients Eingaben noch korrekt abgeschlossen werden können.
Inaktiv: Die Runtime auf dem Server wird ohne Anzeige einer Meldung auf den Clients sofort geschlossen.

Interne ID: ID_NETZ_APP_CLOSE_BOX

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AppCloseBox"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AppCloseBox"


ID_NICHTLINIARE_ANPASSUNG

Interne ID: ID_NICHTLINIARE_ANPASSUNG

Wertanpassung nichtlinear

Nicht-lineare Wertanpassung über VBA Makros.
Eigenschaften für die nicht-lineare Umrechnung der SPS-Werte in Visualisierungswerte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NonlinAdjust"


ID_OPCUA_BROWSENAME

Interne ID: ID_OPCUA_BROWSENAME

Browse name

Entspricht dem Browse name der OPC UA Spezifikation.

Es sind nur hierarchische Verweise vorwärts erlaubt, ausgehend vom Objekt-Ordner.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BrowseName"


ID_PASSWORD_SHOWLOCK

Interne ID: ID_PASSWORD_SHOWLOCK

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowLock"


ID_PICTURE_MIN

Interne ID: ID_PICTURE_MIN

Min/Max Buttons

Nur verfügbar, wenn eine Titelleiste für das Bild angezeigt wird:
Aktiv: Buttons zum Vergrößern und Verkleinern des Bildes werden in der Titelleiste angezeigt.
Inaktiv: Keine solchen Buttons werden angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowMinimize"


ID_PICTURE_SYSMENU

Interne ID: ID_PICTURE_SYSMENU

Systemmenü

Nur verfügbar, wenn eine Titelleiste für das Bild angezeigt wird:
Aktiv: Das Systemmenü des Bildes wird in der Titelleiste angezeigt.
Inaktiv: Kein solcher Button wird angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowSysMenu"


ID_PICTURE_TITLE

Interne ID: ID_PICTURE_TITLE

Name

Eindeutiger Name des Bildes.
Default: Picture x (wobei x eine fortlaufende Zahl ist).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Title"


ID_PREDEFINED_BITMAPS

Interne ID: ID_PREDEFINED_BITMAPS

Vordefinierte Grafiken

Vordefinierte Bitmaps für den LOW/HIGH Zustand können aus der Liste ausgewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PredefinedBitmaps"


ID_PROFILENAME

Interne ID: ID_PROFILENAME

Extern Profilname

Externe Eigenschaft für zenon Logic. Betrifft nur Variablen, die nicht vom straton-Treiber sind.
Name des eingestellten Profils in zenon Logic (z.B. STRATON, ProfDP).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Profilename"


ID_PROJECT_ALC_CONFIG

Interne ID: ID_PROJECT_ALC_CONFIG

ALC Konfiguration

Der Konfigurationsdialog für Automatic Line Coloring (ALC) wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCConfig"


ID_PROJECT_ALC_GROUNDFAULTMODE

Interne ID: ID_PROJECT_ALC_GROUNDFAULTMODE

Modus der Erdschlusssuche

Legt fest, ob bei der Erdschlusssuche der potenziell erdschlussbehaftete Netzteil eingefärbt wird oder das gesamte Netz, in dem sich ein Erdschluss befindet.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultMode"


ID_PROJECT_ALC_MAXOVERLOAD

Interne ID: ID_PROJECT_ALC_MAXOVERLOAD

Max. zulässige Stromüberlastung [%]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCMaxOverload"


ID_PROJECT_ALC_SEARCHMODE

Interne ID: ID_PROJECT_ALC_SEARCHMODE

Modus der Einfärbung

Legt den Modus der Einfärbung für den Zustand UNDEFINED fest. Klick auf Dropdownliste öffnet Auswahl:

- Standard: Die Quellenfarbe wird ausgehend von jeder eingeschalteten Quelle im Netz verteilt, solange der nächste Schalter geschlossen ist.

- Versorgung vorrangig: Färbt nur Leitungen ein, die von zumindest einer Quelle potenziell versorgt sind, aber von keiner Quelle eindeutig.

Default: Standard

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCSearchMode"


ID_PROJECT_ASMACTIVE

Interne ID: ID_PROJECT_ASMACTIVE

IPA aktiv

Der Industrial Performance Analyzer (IPA) dient dazu, Alarmdaten und damit einhergehende Standzeiten in verschiedenen Listenansichten anzuzeigen und auszuwerten.

Hinweis: Das Modul Industrial Performance Analyzer muss extra lizenziert werden.

Aktiv: Die Funktionalität des Industrial Performance Analyzers steht Ihnen zur Verfügung. Die weiteren Eigenschaften, die Sie an dieser Stelle für den IPA vornehmen können, können Sie jetzt bearbeiten.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmActive"


ID_PROJECT_ASMAKZ

Interne ID: ID_PROJECT_ASMAKZ

Anlagen-Kennzeichnung

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Anlagen-Kennzeichnungen helfen Ihnen im Bild vom Typ Industrial Performance Analyzer nach gewünschten Alarmdaten zu filtern. Die hier definierte Anlagen-Kennzeichnung kann entweder im Namen oder in der Kennung der Variablen vorkommen, die den Alarm verursacht hat.

Ein Linksklick auf die Schaltfläche öffnet einen Dialog, in dem Sie die gewünschten Anlagen-Kennzeichnungen definieren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AKZ"


ID_PROJECT_ASMAKZMODE

Interne ID: ID_PROJECT_ASMAKZMODE

Anlagen-Kennzeichnung über

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Die Definition der Anlagen-Kennzeichnung kann als Präfix im Namen der Variable oder in der Kennung der Variable angegeben werden. Dies ist bei der Variablendefinition zu berücksichtigen.
Kennung: Ein Teil der Variablenkennung wird für die Anlagen-Kennzeichnung im Industrial Performance Analyzer (IPA) verwendet.
Variablenname: Ein Teil des Variablennamens wird für die Anlagen-Kennzeichnung verwendet.

Default: Variablenname.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AkzMode"


ID_PROJECT_ASMBUFFERSIZE

Interne ID: ID_PROJECT_ASMBUFFERSIZE

Puffergröße

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Maximale Anzahl von Alarmen, die in den Puffer geschrieben werden.

Hinweis: Wenn der Puffer voll ist und weitere Alarme in ihm gespeichert werden sollen, gehen die ältesten im Puffer gespeicherten Alarme verloren. Berücksichtigen Sie das bei der Projektierung.
Minimum: 0.
Maximum: 4294967295.
Default: 10000.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmBufferSize"


ID_PROJECT_ASMCYCLETIME

Interne ID: ID_PROJECT_ASMCYCLETIME

Speicherzyklus

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Definieren Sie das Intervall, in dem die Alarmdaten vom Puffer in die Datenbank geschrieben werden. Aus Performancegründen hält der Industrial Performance Analyzer (IPA) keine dauernde Verbindung zu der Datenbank. Mithilfe des Speicherzyklus legen Sie fest, wie oft Daten in die Datenbank geschrieben werden.

Geben Sie das Zeitintervall im Format HH:MM:SS an.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmCycleTime"


ID_PROJECT_ASMDNS

Interne ID: ID_PROJECT_ASMDNS

Datenbank

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Definieren Sie hier die Verbindung zu einer ODBC-fähigen Datenbank (z.B. Microsoft SQL-Server), die der Industrial Performance Analyzer zur Speicherung der Alarmdaten verwenden soll. Eine Linksklick auf die Schaltfläche öffnet den Dialog zur Auswahl der Datenquelle. Wenn Sie noch keine Datenquelle angelegt haben, können Sie eine neue Datenquelle mithilfe diese Dialogs anlegen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmDns"


ID_PROJECT_ASMPREDEFFILTER

Interne ID: ID_PROJECT_ASMPREDEFFILTER

Zeitfilter vordefinieren

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Bei der Auswertung von Alarmdaten im Bild vom Typ Industrial Performance Analyzer in der Runtime können Zeitfilter zur Hilfe genommen werden, um sich nur Alarme aus gewissen Zeitbereichen anzeigen zu lassen.

Ein Linksklick auf die Schaltfläche öffnet einen Dialog, in dem Sie die von Ihnen gewünschten Zeitfilter definieren können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PredefFilter"


ID_PROJECT_ASMTABLE

Interne ID: ID_PROJECT_ASMTABLE

Tabellenname

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Geben Sie einen Namen für die Tabelle des Industrial Performance Analyzers in der ODBC-fähigen Datenbank an. Wenn eine Tabelle mit diesem Namen noch nicht existiert, wird Sie beim ersten Start der Runtime automatisch angelegt.

Hinweis: Gültige Tabellennamen dürfen nur alphanumerische Zeichen und/oder Leerzeichen enthalten und nicht mit einer Zahl anfangen. Sie dürfen nicht mehr als 128 Zeichen umfassen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmTable"


ID_PROJECT_BACKUPTIME

Interne ID: ID_PROJECT_BACKUPTIME

Zeitpunkt der Sicherung

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Interne ID: ID_PROJECT_BACKUPTIME

Versionierung aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

Inaktiv: keine Versionierung der Projektsicherungen.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackupTime"

Zeigt Zeitpunkt der letzten Projektsicherung als Sekunden in UTC an.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackupTime"


ID_PROJECT_BACKUPXML

Interne ID: ID_PROJECT_BACKUPXML

XML-Export aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Interne ID: ID_PROJECT_BACKUPXML

Versionierung aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

Inaktiv: keine Versionierung der Projektsicherungen.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackupWithXML"

Aktiv: Bei jeder Projektsicherung wird eine XML-Datei (Version.zip) eingefügt. Diese enthält 24 XML-Dateien mit den Sicherungen der einzelnen Module.

Hinweis: Bei Mehrplatzfähigen Projekten nur bei lokaler Sicherung.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackupWithXML"


ID_PROJECT_CLEARTYPEFONT

Interne ID: ID_PROJECT_CLEARTYPEFONT

ClearType Schriften

Aktiv: ClearType Schriften werden verwendet. Kann die Lesbarkeit von Schriften auf LCD-Bildschirmen in nativer Auflösung verbessern.

Inaktiv: Windows Standardschriften werden verwendet. Eignet sich oft für Röhrenmonitore und LCDs mit interpolierter Auflösung.
Hinweis: Wurde für die Eigenschaft Grafikqualität Windows Basis oder Windows Erweitert gewählt, muss unter Windows Vista und Windows 7 im Betriebssystem die Verwendung von ClearType-Schriften deaktiviert werden. Wurde DirectX gewählt, kann Cleartype unabhängig vom Betriebssystem ein- und ausgeschaltet werden.

Interne ID: ID_PROJECT_CLEARTYPEFONT

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROJECT_CLEARTYPEFONT

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PROJECT_CLEARTYPEFONT

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ClearTypeFont"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ClearTypeFont"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ClearTypeFont"

Default: aktiv.

Hinweis: Änderungen der Einstellung werden für den Editor erst nach dem Neustart des Editors wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ClearTypeFont"


ID_PROJECT_DBD_SERVER

Interne ID: ID_PROJECT_DBD_SERVER

Datenbankserver

Diese Eigenschaft kann nur beim Erstellen eines Projektes eingegeben werden.
Zeigt den Datenbankserver eines mehrplatzfähigen Projekts an.
Kein Eintrag bedeutet, dass das Projekt nicht mehrplatzfähig ist und die Projektdatenbank auf dem lokalen Rechner abgelegt ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DatabaseServer"


ID_PROJECT_IPA_ALARMCAUSELIST

Interne ID: ID_PROJECT_IPA_ALARMCAUSELIST

Alarmursachen

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Im Bild vom Typ Industrial Performance Analyzer kann jedem erfassten Alarm eine Alarmursache aus einer Liste zugewiesen werden. Es ist möglich nach den Alarmursachen zu filtern.

Die Liste der Alarmursachen wird hier verwaltet.

Ein Linksklick auf die Schaltfläche öffnet einen Dialog, in dem Sie mögliche Alarmursachen definieren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmAlarmCauseListe"


ID_PROJECT_IPA_SHIFTINFOPFS

Interne ID: ID_PROJECT_IPA_SHIFTINFOPFS

Schicht aus PFS

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Übernimmt die Zeiten für die definierten Schichten aus dem Modul Production & Facility Scheduler. Die Schichtzeiten werden dann dort gewartet.

Aktiv: Die zum Alarm aktuelle Schicht wird aus dem Production & Facility Scheduler (PFS) ausgelesen.
Inaktiv: Die zum Alarm aktuelle Schicht wird aus einer verknüpften Variable und einer definierten Liste gelesen.
Default: aktiv.
Achtung: Der Production & Facility Scheduler ist ein optionales Modul und muss lizenziert sein, um hier verwendet werden zu können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmShiftInfoPFS"


ID_PROJECT_IPA_SHIFTINFOVARIABLE

Interne ID: ID_PROJECT_IPA_SHIFTINFOVARIABLE

Schicht aus Variable

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben. Außerdem muss Schicht aus PFS inaktiv sein.

Name der Variablen, deren Wert Informationen über die aktuelle Schicht liefert. Selektieren Sie eine Variable vom Typ INT. Damit können Sie folgendes Schichtmodell erstellen.
Beispiel:

1 = Frühschicht, 2 = Spätschicht, 3 = Nachtschicht, -1 = Pause. Die Schichtbezeichnung für die Auswertung kann über die Eigenschaft Schichtname aus Liste definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmShiftInfoVariable"


ID_PROJECT_IPA_SHIFTLIST

Interne ID: ID_PROJECT_IPA_SHIFTLIST

Schichtname aus Liste

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben. Außerdem muss Schichtname aus PFS inaktiv sein.

Hier definieren Sie Namen zu den Werten der Variablen, die Sie unter Schicht aus Variable verknüpft haben.

Ein Linksklick auf die Schaltfläche öffnet einen Dialog, in dem Sie einzelnen Werten Namen zuweisen.

Schichtnamen können Werten einer verknüpften Variablen zugewiesen werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmShiftNameListe"


ID_PROJECT_IPA_SHIFTPFS

Interne ID: ID_PROJECT_IPA_SHIFTPFS

Schichtname aus PFS

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Übernimmt die Namen für die definierten Schichten aus dem Modul Production & Facility Scheduler. Die Schichtnamen werden dann dort gewartet.

Aktiv: Die zum Alarm aktuelle Schicht wird aus dem Production & Facility Scheduler (PFS) ausgelesen.
Inaktiv: Die zum Alarm aktuelle Schicht wird aus einer verknüpften Variable und einer definierten Liste gelesen.
Default: aktiv.

Achtung: Der Production & Facility Scheduler ist ein optionales Modul und muss lizenziert sein, um hier verwendet werden zu können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmShiftNamePFS"


ID_PROJECT_IPA_USRLEVEL

Interne ID: ID_PROJECT_IPA_USRLEVEL

Zum Löschen

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Mit dem Bild vom Typ Industrial Performance Analyzer ist es möglich während der Runtime Alarmdaten, die sich in der Datenbank befinden, zu löschen. Um hier einen Missbrauch zu vermeiden, können Sie projektieren, welche Berechtigung der Benutzer haben muss, um Einträge zu löschen.

Selektieren Sie aus dem Dropdownmenü die gewünschte Bedienberechtigung.

Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmUsrLvl"


ID_PROJECT_IPA_USRLEVELCAUSE

Interne ID: ID_PROJECT_IPA_USRLEVELCAUSE

Zum Editieren

Nur verfügbar, wenn Sie IPA aktiv aktiviert haben.

Mit dem Bild vom Typ Industrial Performance Analyzer ist es möglich während der Runtime Alarmdaten, die sich in der Datenbank befinden, zu editieren. Um hier einen Missbrauch zu vermeiden, können Sie projektieren, welche Berechtigung der Benutzer haben muss, um Einträge zu editieren.

Selektieren Sie aus dem Dropdownmenü die gewünschte Bedienberechtigung.

Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AsmUsrLvlCause"


ID_PROJECT_MAIN_TEMPLATES

Interne ID: ID_PROJECT_MAIN_TEMPLATES

Hauptschablonen

Namen der Schablonen, die in der Variable Zuletzt geöffnetes Bild des Systemtreibers angeführt werden. Klick auf ... öffnet den Dialog für die Schablonenauswahl.

Hinweis: Diese Eigenschaft wirkt sich auch auf die Funktion Bild zurück aus.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MainTemplates"


ID_PROJECT_MULTIUSER

Interne ID: ID_PROJECT_MULTIUSER

Mehrplatzfähiges Projekt

Aktiv: Das Projekt wird als Mehrplatz-Projekt verwendet. Im Projektbaum gibt es einen zusätzlichen Knoten "In Bearbeitung".

Inaktiv: Das Projekt wird als Einzelplatz-Projekt verwendet.

Default: inaktiv.

Diese Eigenschaft kann nur über das Kontextmenü des Projekts aktiviert werden.

ACHTUNG: Das Aktivieren dieser Eigenschaft kann nicht mehr rückgängig gemacht werden. Allerdings kann ein Mehrplatzfähiges Projekt über eine Projektsicherung in ein neues Einzelplatzprojekt konvertiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MultiUser"


ID_PROJECT_RTVERSION

Interne ID: ID_PROJECT_RTVERSION

RT Dateien erzeugen für

Default: Die Runtime-Dateien werden für die aktuelle Version des Editors erzeugt

6.20 SP4: Die Runtime-Dateien werden für die Version 6.20 Servicepack 4 erzeugt.

6.21 SP0: Die Runtime-Dateien werden für die Version 6.21 Servicepack 0 erzeugt.

6.21 SP1: Die Runtime-Dateien werden für die Version 6.21 Servicepack 1 erzeugt.

6.22 SP0: Die Runtime-Dateien werden für die Version 6.22 Servicepack 0 erzeugt.

6.22 SP1: Die Runtime-Dateien werden für die Version 6.22 Servicepack 1 erzeugt.

6.50 SP0: Die Runtime-Dateien werden für die Version 6.50 Servicepack 0 erzeugt.

6.51 SP0: Die Runtime-Dateien werden für die Version 6.51 Servicepack 0 erzeugt.

Achtung: Um die Konsistenz der Runtime-Dateien zu gewährleisten, müssen nach jeder Änderung dieser Eigenschaft alle Runtime-Dateien neu erzeugt werden. Auch die Konfigurationen aller Treiber werden konvertiert. Einstellungen, die es in der entsprechenden Version nicht gibt, werden auf Default gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RTVersion"


ID_PROJECT_RUNTIMELASSO

Interne ID: ID_PROJECT_RUNTIMELASSO

Runtime Lasso

Aktiv: Durch Bewegen der Maus mit gedrückter linker Maustaste können in der Runtime mehrere Elemente selektiert werden. Auf diese Elemente kann dann ein VBA-Makro zugreifen.
Inaktiv: Die Lassofunktionalität wird nicht verwendet.
Default: inaktiv
Hinweis: Lasso funktioniert nur für Elemente, die 'Über Tastatur erreichbar' sind und mit denen eine Variable oder Funktion verknüpft ist. Statische Elemente werden nicht ausgewählt. Die Lassofunktion kann für einzelne Bildelemente über die Eigenschaft Runtime/mit Lasso auswählbart aktiviert oder deaktiviert werden.

Interne ID: ID_PROJECT_RUNTIMELASSO

mit Lasso auswählbar

Die Auswahl per Lasso zur Runtime ermöglicht die Identifizierung von Dynamischen Elementen für die Verwendung mit VBA Events.
Aktiv: Das Element kann zur Runtime mit dem Lasso ausgewählt werden.
Inaktiv: Das Element kann zur Runtime nicht ausgewählt werden.
Default: aktiv

Achtung: Damit das Element zur Runtime auswählbar ist, muss zusätzlich in den Projekteigenschaften die Eigenschaft Runtime Einstellungen/Runtime Lasso aktiviert sein!

Interne ID: ID_PROJECT_RUNTIMELASSO

Runtime Einstellungen

Eigenschaften für das Runtime-Verhalten des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RuntimeLasso"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RuntimeLasso"

Interne ID: ID_PROJECT_RUNTIMELASSO

Runtime

Eigenschaften für das Runtime-Verhalten des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RuntimeLasso"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RuntimeLasso"


ID_PROJECT_USEVERSION

Interne ID: ID_PROJECT_USEVERSION

Versionierung aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

Inaktiv: keine Versionierung der Projektsicherungen.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionActive"


ID_PROJECT_VERSIONDETAIL

Interne ID: ID_PROJECT_VERSIONDETAIL

Detailnummer

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionDetail"


ID_PROJECT_VERSIONNUMBER

Interne ID: ID_PROJECT_VERSIONNUMBER

Hauptversion

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Interne ID: ID_PROJECT_VERSIONNUMBER

Versionierung aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

Inaktiv: keine Versionierung der Projektsicherungen.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionNumber"

Vom Benutzer zu vergebende Nummer. Diese wird intern mit einer Detailnummer, getrennt durch einen Punkt, ergänzt und als Projektversion dargestellt.

Interne ID: ID_PROJECT_VERSIONNUMBER

Projektversion

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Zeigt Projektversion an. Die Versionsnummer besteht aus der vom Benutzer vergebenen Nummer der Hauptversion und der intern hinter dem Punkt vergebenen Detailnummer.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionNumber"

Achtung: Willkürliche Veränderungen dieser Nummer beeinflussen die Konsistenz der Versionierung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionNumber"


ID_PROJECT_VERSIONS

Interne ID: ID_PROJECT_VERSIONS

Versionierung

Eigenschaften für die Versionierung von Projektsicherungen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_Versioning"


ID_PROJECT_VERSIONSTRING

Interne ID: ID_PROJECT_VERSIONSTRING

Projektversion

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Interne ID: ID_PROJECT_VERSIONSTRING

Versionierung aktiv

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Aktiv: Projektversionierung wird verwendet. Jede Projektsicherung wird mit einer eigenen Versionsnummer gespeichert.

Inaktiv: keine Versionierung der Projektsicherungen.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionString"

Zeigt Projektversion an. Die Versionsnummer besteht aus der vom Benutzer vergebenen Nummer der Hauptversion und der intern hinter dem Punkt vergebenen Detailnummer.

Interne ID: ID_PROJECT_VERSIONSTRING

Hauptversion

Nur verfügbar, wenn die Eigenschaft Versionierung aktiv aktiviert wurde.

Vom Benutzer zu vergebende Nummer. Diese wird intern mit einer Detailnummer, getrennt durch einen Punkt, ergänzt und als Projektversion dargestellt.

Achtung: Willkürliche Veränderungen dieser Nummer beeinflussen die Konsistenz der Versionierung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionString"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VersionString"


ID_PROJECT_ZOOM_STEPS

Interne ID: ID_PROJECT_ZOOM_STEPS

Zoomstufen f. Weltbild

Der Dialog für die Definition der Zoomstufen für die Weltbild-Funktionalität wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZoomSteps"


ID_PROJEKT_ADAM

Interne ID: ID_PROJEKT_ADAM

ADAM/AD-LDS Verbindung

Verbindungspfad zu ADAM bzw. AD LDS.

Der Verbindungspfad muss in folgender Form eingegeben werden: [PC-Name]:[Port]/[Organisation]

Beispiel: w3k:50000/O=700,c=com

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ADAM"


ID_PROJEKT_ADAM_PWD

Interne ID: ID_PROJEKT_ADAM_PWD

ADAM/AD-LDS Passwort

Kennwort des lokalen Benutzers des ADAM/AD LDS PCs.

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ADAMPwd"


ID_PROJEKT_ADAM_USER

Interne ID: ID_PROJEKT_ADAM_USER

ADAM/AD-LDS Benutzername

Benutzername eines lokalen Benutzers des ADAM/AD LDS PCs mit Administratorrechten.

Mehr zu AD-LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ADAMUser"


ID_PROJEKT_ALARM_CEL

Interne ID: ID_PROJEKT_ALARM_CEL

AML und CEL

Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML_CEL"


ID_PROJEKT_ALLGEMEIN

Interne ID: ID_PROJEKT_ALLGEMEIN

Allgemein

Allgemeine Eigenschaften des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Projekt"


ID_PROJEKT_ALT_PATH

Interne ID: ID_PROJEKT_ALT_PATH

Datenordner

Leer: Der Standardpfad wird für das Speichern von Alarmmeldeliste, Chronologischer Ereignisliste (CEL), Harddisk-Daten, Archivdaten etc.verwendet (Projektpfad\Rechnername\Projektname).
Pfad: Der hier eingegebene Pfad wird zum Speichern der Daten verwendet ("Eingegebener Pfad\Rechnername\Projektname").
Achtung: Falls der eingegebene Pfad nicht existiert (Netzwerkprobleme, Wechseldatanträger nicht vorhanden), werden von der Runtime keine Daten mehr geschrieben. Das bedeutet: 100% Datenverlust. Die Runtime bleibt bedienbar, muss aber neu gestartet werden. Die Verfügbarkeit des Ordners kann mit der Systemtreibervariablen Runtime Datenordner nicht verfügbar überprüft werden.
Tipp: Setzen Sie den Datenordner nie auf ein entfernbares Laufwerk, wie einen USB Stick oder ein Netzlaufwerk. Daten am besten lokal aufzeichnen und extern sichern

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltDataPath"


ID_PROJEKT_AML

Interne ID: ID_PROJEKT_AML

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML"


ID_PROJEKT_ANTIALIASING

Interne ID: ID_PROJEKT_ANTIALIASING

Antialiasing verwenden

Nur verfügbar, wenn Grafikqualität aktiviert ist.

Interne ID: ID_PROJEKT_ANTIALIASING

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROJEKT_ANTIALIASING

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PROJEKT_ANTIALIASING

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseAntialiasing"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseAntialiasing"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseAntialiasing"

Schaltet die Kantenglättung von Linien ein. Dadurch werden vor allem schräge Linien grafisch wesentlich ansprechender dargestellt. Der Treppeneffekt entfällt. Wurde in der Eigenschaft Grafikqualität DirectX Software oder DirectX Hardware gewählt, kann Antialiasing unabhängig von den Betriebssystemeinstellungen ein- und ausgeschaltet werden. Die Antialiasing Qualität von DirectX ist höher als bei Windows Erweitert.

Antialising kann die Bildumschaltzeiten besonders bei älteren Betriebssystemen (bis Windows XP) verlängern.

Mögliche Optionen sind:

Ein: Kantenglättung immer aktiv

Aus: Kantenglättung deaktiviert

Default: Bei Windows Vista, Windows 7 und neueren Betriebssystemen ist die Kantenglättung aktiviert, bei älteren Betriebssystemen (Windows XP, Server 2003) deaktiviert.

Default: Default

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseAntialiasing"


ID_PROJEKT_AUTOMATIC_FUNC

Interne ID: ID_PROJEKT_AUTOMATIC_FUNC

Automatische Funktionsausführung

Eigenschaften für die automatische Funktionsausführung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AutoFunc"


ID_PROJEKT_AUTOMATIC_FUNCTION

Interne ID: ID_PROJEKT_AUTOMATIC_FUNCTION

Funktion

Nur verfügbar, wenn der automatische Funktionsaufruf aktiv ist:
Funktion, die nach abgelaufener Zeit ohne Bedienaktion ausgeführt wird.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


ID_PROJEKT_AUTOMATIC_FUNCTION_ACTIVE

Interne ID: ID_PROJEKT_AUTOMATIC_FUNCTION_ACTIVE

Autom. Funktionsausführung aktiv

Aktiv: Automatische Funktionsausführung, wenn der Rechner über einen eingegebenen Zeitraum nicht benutzt wurde.
Inaktiv: Schaltet diese Funktionalität aus.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FuncActive"


ID_PROJEKT_AUTOMATIC_FUNCTION_TIME

Interne ID: ID_PROJEKT_AUTOMATIC_FUNCTION_TIME

Zeit ohne Bedienaktion (in Minuten)

Nur verfügbar, wenn der automatische Funktionsaufruf aktiv ist:
Hier kann der Zeitraum eingegeben werden, der ohne Bedienaktion verstreichen muss um die Funktion auszuführen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FuncActiveTime"


ID_PROJEKT_BLINK_FREQUENCY

Interne ID: ID_PROJEKT_BLINK_FREQUENCY

Blinkfreq. [ZehntelSek.]

Blinkfrequenz der Elemente eingegeben in Zehntelsekunden (z.B: Eingabe 5 entspricht Blinken im 1/2 Sekunden Takt).
Minimum: 0.
Maximum: 2147483647.
Default: 5.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BlinkRate"


ID_PROJEKT_CEL

Interne ID: ID_PROJEKT_CEL

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CEL"


ID_PROJEKT_CHANGELOG

Interne ID: ID_PROJEKT_CHANGELOG

Änderungshistorie

Eigenschaften für die Änderungs-Historie.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeLog"


ID_PROJEKT_CHANGELOG_AKTIV

Interne ID: ID_PROJEKT_CHANGELOG_AKTIV

Änderungshistorie aktiv

Aktiv: Änderungen im Projekt werden mitprotokolliert.
Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeLogAktiv"


ID_PROJEKT_CHANGELOG_AUTOCHECKOUT

Interne ID: ID_PROJEKT_CHANGELOG_AUTOCHECKOUT

Änderungen automatisch ermöglichen

Nur verfügbar in mehrplatzfähigen Projekten und wenn die Änderungshistorie aktiv ist:
Aktiv: Änderungen für Einträge der Liste werden automatisch ermöglicht, wenn Kommentare hinzugefügt werden. Sie müssen dann von Hand übernommen werden.
Inaktiv: Kommentare können nur hinzugefügt werden, nachdem Änderungen für die Einträge vorher von Hand ermöglicht wurden.
Default: inaktiv.

ACHTUNG: Diese Funktionalität benötigt viel Performance, wenn sie aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeLogCheckout"


ID_PROJEKT_CHANGELOG_DETAIL

Interne ID: ID_PROJEKT_CHANGELOG_DETAIL

Detaillierungsstufe

Nur verfügbar, wenn die Eigenschaft Änderungshistorie aktiv aktiviert wurde.

Interne ID: ID_PROJEKT_CHANGELOG_DETAIL

Änderungshistorie aktiv

Aktiv: Änderungen im Projekt werden mitprotokolliert.
Inaktiv: Änderungen im Projekt werden nicht mitprotokolliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeLogState"

Auswahl der Detailstufen aus Dropdownliste.

  • Objekt: Es werden lediglich die Objektnamen der geänderten Objekte aufgezeichnet. Details zu den geänderten Eigenschaften und deren Werte scheinen nicht in der Änderungshistorie auf.
  • Eigenschaften: Zusätzlich zu den Objektnamen werden die geänderten Eigenschaften sowie deren neue Werte in die Historie aufgenommen.
  • Wertänderungen: Diese Einstellung bewirkt den größtmöglichen Aufzeichnungsgrad. Dabei wird neben dem neuen Wert einer Eigenschaft auch deren alter Wert gespeichert. Somit ist eine komplette Rückverfolgung von Änderungen auf Wertebene möglich.

Default: Eigenschaften

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ChangeLogState"


ID_PROJEKT_CURSOR_VISIBLE

Interne ID: ID_PROJEKT_CURSOR_VISIBLE

Cursor sichtbar

Aktiv: Der Cursor in der Runtime ist sichtbar.
Inaktiv: Der Cursor in der Runtime ist unsichtbar. Bei Projekten mit Touchscreen kann die Darstellung des Cursors als störend empfunden und mit dieser Eigenschaft ausgeschaltet werden.
Default: aktiv.

ACHTUNG: Diese Funktionalität funktioniert nur bei Elementen des Leitsystems (Bilder, Elemente, ..) nicht aber bei Windows Standard-Elementen (Titelzeilen, Menüs, Scrollbalken, ...). Dazu muss der Cursor direkt im Betriebssystem deaktiviert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CursorVisible"


ID_PROJEKT_DRIVER_INVISIBLE

Interne ID: ID_PROJEKT_DRIVER_INVISIBLE

Treiber unsichtbar

Aktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste nicht angezeigt.

Inaktiv: Gestartete Treiber werden zur Runtime in der Windows Taskleiste angezeigt.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DriverInvisible"


ID_PROJEKT_ENABLEMENU

Interne ID: ID_PROJEKT_ENABLEMENU

Hauptmenüs aktiv

Aktiv: Damit wird am oberen Rand des Runtime-Fensters ein Balken für die Darstellung der Menüs reserviert.
Inaktiv: In der Runtime werden keine Hauptmenüs angezeigt.
Default: inaktiv.

ACHTUNG: Wenn Hauptmenüs verwendet werden, muss diese Option aktiviert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableMenu"


ID_PROJEKT_EXPORT_UNICODE

Interne ID: ID_PROJEKT_EXPORT_UNICODE

Textexport als Unicode

Aktiv: Textexport in Unicode-Dateien.
Inaktiv: Textexport in ANSI-Dateien.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExportUnicode"


ID_PROJEKT_GDIPLUS

Interne ID: ID_PROJEKT_GDIPLUS

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROJEKT_GDIPLUS

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PROJEKT_GDIPLUS

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseGDIplus"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseGDIplus"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseGDIplus"


ID_PROJEKT_GRP0

Interne ID: ID_PROJEKT_GRP0

Drucken

Eigenschaften für den Online-Ausdruck der Alarmmeldeliste (AML) oder der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Print"


ID_PROJEKT_GRP1

Interne ID: ID_PROJEKT_GRP1

Name/Ordner

Eigenschaften für den Namen und den Speicherplatz des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_PROJEKT_GRP2

Interne ID: ID_PROJEKT_GRP2

Runtime Einstellungen

Eigenschaften für das Runtime-Verhalten des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Runtime"


ID_PROJEKT_GRP3

Interne ID: ID_PROJEKT_GRP3

Touchbedienung

Eigenschaften für die Touchbedienung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Touch"


ID_PROJEKT_GRP4

Interne ID: ID_PROJEKT_GRP4

Automatisches Logout

Eigenschaften für automatisches Ausloggen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AutLogout"


ID_PROJEKT_GRP5

Interne ID: ID_PROJEKT_GRP5

Temporäres Login

Eigenschaften für das temporäre Einloggen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TempLogin"


ID_PROJEKT_GRP6

Interne ID: ID_PROJEKT_GRP6

Industrial Performance Analyzer

Eigenschaften für den Industrial Performance Analyzer (IPA).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IPA"


ID_PROJEKT_GRP7

Interne ID: ID_PROJEKT_GRP7

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Graphics"


ID_PROJEKT_GRP8

Interne ID: ID_PROJEKT_GRP8

Datenspeicherung IPA

Eigenschaften für die Datenspeicherung des Industrial Performance Analyzers (IPA).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Storage"


ID_PROJEKT_GRP9

Interne ID: ID_PROJEKT_GRP9

Auswertung

Eigenschaften für die Auswertung der Daten des Industrial Performance Analyzers (IPA).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Analysis"


ID_PROJEKT_GRP10

Interne ID: ID_PROJEKT_GRP10

Allgemein

Allgemeine Eigenschaften für die Datei.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_PROJEKT_GRP11

Interne ID: ID_PROJEKT_GRP11

Allgemein

Allgemeine Eigenschaften für das zenon Logic Projekt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_PROJEKT_GRP12

Interne ID: ID_PROJEKT_GRP12

Allgemein

Allgemeine Eigenschaften für die Projektsicherung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_PROJEKT_GRP13

Interne ID: ID_PROJEKT_GRP13

Gesperrte/Verriegelte Elemente

Eigenschaften für die Anzeige gesperrter Elemente.
Elemente, die durch eine Berechtigungsgruppe oder eine Verriegelung gesperrt sind, werden mit einem Schlosssymbol oder einer frei wählbaren Grafik gekennzeichnet.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Lock_Symbol"


ID_PROJEKT_GRP14

Interne ID: ID_PROJEKT_GRP14

Bilder

Eigenschaften für die Anzeige der Bilder in der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_PROJEKT_GRP15

Interne ID: ID_PROJEKT_GRP15

Industrial Maintenance Manager

Eigenschaften des Industrial Maintenance Manager (IMM). Diese sind nur verfügbar, wenn der Industrial Maintenance Manager lizenziert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_PROJEKT_GRP16

Interne ID: ID_PROJEKT_GRP16

Berechtigungen

Bedienberechtigungen für das Löschen und Bearbeiten von Einträgen in der Datenbank des Industrial Performance Analyzers (IPA).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Rights"


ID_PROJEKT_GRP17

Interne ID: ID_PROJEKT_GRP17

Runtime allgemein

Enthält Einstellungen zur Runtime.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_PROJEKT_GRP18

Interne ID: ID_PROJEKT_GRP18

Active Directory/ADAM/AD-LDS

Eigenschaften für die Verwendung des

- Active Directory (AD)

- Active Directory Application Mode (ADAM)

- Active Directory Lightweight Directory Services (AD LDS)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_PROJEKT_GUID

Interne ID: ID_PROJEKT_GUID

Projekt ID

Jedes Projekt wird durch eine eindeutige GUID identifiziert. Diese Eigenschaft kann nicht geändert werden.
Das ist auch der Name der Unterverzeichnisses im SQL-Verzeichnis, wo das Projekt gespeichert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GUID"


ID_PROJEKT_KEYBOARD_SIZE

Interne ID: ID_PROJEKT_KEYBOARD_SIZE

Keyboard Größe [%]

Definiert, in welcher Größe in Prozent – ausgehend von der Originalgröße – das automatische Keyboard in der Runtime dargestellt werden soll.
Minimum: 50 %
Maximum: 300 %
Default: 100 %

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardSize"


ID_PROJEKT_LIMIT_FUNCTION_ON_START

Interne ID: ID_PROJEKT_LIMIT_FUNCTION_ON_START

Grenzwertfunkt. beim RT-Start ausführen

Aktiv: Beim Start der Runtime wird eine mit einem anstehenden Grenzwert verknüpfte Funktion erneut ausgeführt.
Inaktiv: Beim Start der Runtime wird eine mit einem anstehenden Grenzwert verknüpfte Funktion nicht erneut ausgeführt.
Default: aktiv.

ACHTUNG: Diese Eigenschaft betrifft nur Grenzwerte, die keine Alarme sind!

Beispiel 1: Die Runtime wird geschlossen und kein Grenzwert ist verletzt. Dann wird ein Grenzwert verletzt und danach die Runtime gestartet. Ist der verletzte Grenzwert ein Alarm, so wird die verknüpfte Funktion beim Starten der Runtime ausgeführt. Ist der Grenzwert kein Alarm, wird die Einstellung dieser Eigenschaft benutzt.
Beispiel 2: Die Runtime wird geschlossen und ein Grenzwert, der kein Alarm ist, ist verletzt. Die verknüpfte Funktion wurde in dem Moment ausgeführt, als der Grenzwert verletzt wurde. Wenn die Runtime neu gestartet wird, ist dieser Grenzwert immer noch verletzt. Abhängig von dieser Eigenschaft wird die verknüpfte Funktion erneut ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LimitFunctionOnStart"


ID_PROJEKT_MAIN_WINDOW

Interne ID: ID_PROJEKT_MAIN_WINDOW

Runtime-Titel

Darstellung des Runtime-Hauptfensters.

kein Titel: Vollflächige Darstellung ohne Anzeige einer Titelleiste, .

Titel mit Min. und Max. Schaltfläche: Das Fenster kann in der Größe verändert und verschoben werden. Schließen ist nicht möglich (auch nicht über Kontextmenü, Aufgabenleiste oder die Tastenkombination Alt+F4). Rechtsklick auf Titelleiste öffnet Kontextmenü.

Titel mit System, Min. und Max. Schaltfläche: Das Fenster kann in der Größe verändert und verschoben, sowie per per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

Titel mit Systemmenü: Das Fenster kann verschoben und per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

Titel ohne Schaltflächen: Das Fenster kann verschoben und per Klick auf die Schaltfläche X geschlossen werden. Rechtsklick auf Titelleiste öffnet Kontextmenü.

Default: kein Titel

Achtung: Wenn diese Eigenschaft im Editor geändert wird, muss die Runtime neu gestartet werden. Nachladen alleine funktioniert nicht, da zur Übernahme das Hauptfenster der Runtime erst geschlossen und dann neu geöffnet werden muss.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MainWindowStyle"


ID_PROJEKT_MULTITOUCH

Interne ID: ID_PROJEKT_MULTITOUCH

Multitouch aktiv

Aktiv: Multi-Touch kann verwendet werden. Flicks (kurze Wischbewegungen) und Rechtsklick (antippen und halten) werden deaktiviert.
Voraussetzungen: Alle entsprechenden Treiber und Gerät sind vorhanden. Das Gerät muss verbunden und eingeschaltet sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MultiTouch"


ID_PROJEKT_NAME

Interne ID: ID_PROJEKT_NAME

Projektname

Eindeutiger Name des Projektes.
Dieser dient zur besseren Lesbarkeit, intern wird in der Regel die GUID verwendet.

Erlaubt sind: Ziffern, Buchstaben und folgende Sonderzeichen: $, -, @, _, {}, ~, !, ()
Hinweis: Beachten Sie beim Ändern des Projektnamens, dass eventuell projektübegreifende Bezüge in Integrationsprojekten oder projektübergreifende Nutzung von Variablen, Funktionen und VBA angepasst werden müssen. Benutzen Sie dazu den Dialog zum Ersetzen von Projektbezügen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_PROJEKT_NETZ

Interne ID: ID_PROJEKT_NETZ

Netzwerk

Eigenschaften für die Verwendung des Projekts in einem Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Net"


ID_PROJEKT_NETZ_AKTIV

Interne ID: ID_PROJEKT_NETZ_AKTIV

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetActive"


ID_PROJEKT_NETZ_DATENSERVER

Interne ID: ID_PROJEKT_NETZ_DATENSERVER

Standby als Datenserver

Nur verfügbar, wenn in der Eigenschaft Standby ein Standby-Server definiert wurde.
Aktiv: Der Standby-Server wird als Datenserver verwendet, d.h. der Standby-Server hat die Verbindung zur Hardware und schleift die Daten zum Server durch.
Inaktiv: Der Server selbst wird als Datenserver verwendet.
Mehr im Online-Handbuch

Interne ID: ID_PROJEKT_NETZ_DATENSERVER

Standby

Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

Interne ID: ID_PROJEKT_NETZ_DATENSERVER

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: ID_PROJEKT_NETZ_DATENSERVER

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetDataServer"

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetDataServer"

Interne ID: ID_PROJEKT_NETZ_DATENSERVER

Server

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetDataServer"

Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
Achtung: Server und Standby müssen identische Systemzeit haben.
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetDataServer"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetDataServer"


ID_PROJEKT_NETZ_REDUNDANZTYP

Interne ID: ID_PROJEKT_NETZ_REDUNDANZTYP

Redundanztyp

Nur verfügbar, wenn bei der Eigenschaft Standby ein Rechner eingetragen wurde.

Interne ID: ID_PROJEKT_NETZ_REDUNDANZTYP

Standby

Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

Interne ID: ID_PROJEKT_NETZ_REDUNDANZTYP

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: ID_PROJEKT_NETZ_REDUNDANZTYP

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetType"

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetType"

Interne ID: ID_PROJEKT_NETZ_REDUNDANZTYP

Server

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetType"

Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
Achtung: Server und Standby müssen identische Systemzeit haben.
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetType"

zenon unterstützt zwei Redundanztypen:

Softwareredundanz: Das System besteht aus einer Steuerung und zwei redundanten Leitsystem-Rechnern. Beide Rechner müssen Verbindung zur Steuerung haben. Beide Rechner kommunizieren mit der Steuerung und halten gleichzeitig die Daten aus der Steuerung aktuell. Die Kommunikation zur Steuerung übernimmt der Rechner mit Server-Funktion. Der Server kommuniziert also bidirektional, der Standby unidirektional. Fällt der Server aus, übernimmt der Standby-Server die bidirektionale Kommunikation mit der Steuerung.

Hardwareredundanz: Das System besteht aus zwei redundanten Steuerungen und zwei redundanten Leitsystem-Rechnern. Jeder Rechner kommuniziert mit einer Steuerung bidirektional. Beide Rechner und beide Steuerungen gleichen ihre Daten ab. Fällt eine Komponente im ersten System aus, übernimmt das zweite System.

Default: Softwareredundanz

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetType"


ID_PROJEKT_NETZ_ROUTING_AKTIV

Interne ID: ID_PROJEKT_NETZ_ROUTING_AKTIV

Routing aktiv

Aktiv: Der Rechner fungiert als Knotenrechner und kann Pakete routen. Dabei laufen alle Netzwerkpakete von außerhalb über diesen Rechner.
Diese Einstellung kann zu Engpässen führen und beeinflusst die möglichen Netzwerktopologien . Ein Einsatz ist in speziellen Netzwerkkonstellationen sinnvoll, z.B. bei WAN-Netzwerken oder gerouteten Netzwerken. Es wird daher empfohlen, die Einstellung zu deaktivieren.

Default: inaktiv

Mehr im Online Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetRoutingActive"


ID_PROJEKT_NETZ_SB

Interne ID: ID_PROJEKT_NETZ_SB

Standby

Nur verfügbar, wenn in der Eigenschaft Server ein Server eingetragen wurde.
Dieser Rechner übernimmt bei redundanten Systemen bei einem Serverausfall die Rolle des Servers. Der Serverausfall wird erkannt, wenn der Server während der in Timeout [s] definierten Zeit nicht reagiert. Ein eigener Puffer im Standby überbrückt die Totzeit zwischen Serverausfall und Umschaltung und verhindert so Datenverlust.

Interne ID: ID_PROJEKT_NETZ_SB

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: ID_PROJEKT_NETZ_SB

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetSB"

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetSB"

Interne ID: ID_PROJEKT_NETZ_SB

Server

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetSB"

Hinweis Name: "localhost" darf nicht als Name für den Standby oder den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.
Achtung: Server und Standby müssen identische Systemzeit haben.
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetSB"


ID_PROJEKT_NETZ_SERVER

Interne ID: ID_PROJEKT_NETZ_SERVER

Server

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Rechner, der bei Netzwerkprojekten die Verbindung zur Hardware herstellt und die Projektdaten verwaltet. Die Clients verbinden sich zu diesem Rechner.

Interne ID: ID_PROJEKT_NETZ_SERVER

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetServer"

Hinweis Name: Die IP-Adresse genügt nicht, es muss der Name des Rechners eingetragen werden. "localhost" darf nicht als Name für den Server verwendet werden.
Wird der Name geändert, kann dieser nicht nachgeladen werden. Er wird erst nach einem Neustart der Runtime aktualisiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetServer"


ID_PROJEKT_NETZ_TIMEOUT

Interne ID: ID_PROJEKT_NETZ_TIMEOUT

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: ID_PROJEKT_NETZ_TIMEOUT

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTimeout"

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTimeout"


ID_PROJEKT_NETZ_TOKEN

Interne ID: ID_PROJEKT_NETZ_TOKEN

Bedienberechtigung

Eigenschaften für die Bedienberechtigung im Netzwerk.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Token"


ID_PROJEKT_NETZ_TOKEN_AKTIV

Interne ID: ID_PROJEKT_NETZ_TOKEN_AKTIV

Bedienberechtigung aktiv

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
Default: inaktiv.

Interne ID: ID_PROJEKT_NETZ_TOKEN_AKTIV

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenActive"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenActive"


ID_PROJEKT_NETZ_TOKEN_QUESTION

Interne ID: ID_PROJEKT_NETZ_TOKEN_QUESTION

Timeout für Abfrage [s]

Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
Wird die Bedienberechtigung im Netzwerk von einer Station blockiert, kann diese von einem anderen Rechner angefordert werden. Innerhalb des hier festgelegten Zeitraums muss diese Anfrage beantwortet werden. Nach Ablauf der Frist ohne Antwort erhält die anfragende Station automatisch die Berechtigung.

Interne ID: ID_PROJEKT_NETZ_TOKEN_QUESTION

Bedienberechtigung aktiv

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
Default: inaktiv.

Interne ID: ID_PROJEKT_NETZ_TOKEN_QUESTION

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenQuestion"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenQuestion"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenQuestion"


ID_PROJEKT_NETZ_TOKEN_QUIT

Interne ID: ID_PROJEKT_NETZ_TOKEN_QUIT

Timeout für Bedienberechtigung [s]

Nur verfügbar, wenn die Eigenschaft Bedienberechtigung aktiv aktiviert wurde.
Innerhalb dieses Zeitraumes muss sich der Rechner (Client), der die Bedienberechtigung besitzt, beim Server melden. Passiert das nicht, wird die Bedienberechtigung automatisch freigegeben.
Achtung: Dieser Wert muss kleiner sein als die in der Eigenschaft Timeout [s] eingestellte Zeit.

Interne ID: ID_PROJEKT_NETZ_TOKEN_QUIT

Timeout [s]

Nur verfügbar, wenn die Eigenschaft Netzwerk aktiv aktiviert wurde.

Interne ID: ID_PROJEKT_NETZ_TOKEN_QUIT

Netzwerk aktiv

Aktiv: Das Projekt wird als Netzwerkprojekt verwendet. Ein Server muss definiert werden.
Inaktiv: Das Projekt ist ein Standalone-Projekt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenQuit"

Zeitraum in Sekunden, in dem ein Rechner auf einen Watchdog reagieren muss. Die hier eingestellte Zeit wird gedrittelt und nach jedem Drittel überprüft ein Watchdog die Verbindung zum Server. Reagiert der Server auf mindestens einen der drei Watchdogs, wird angenommen, dass Verbindung zum Server besteht. Die Kommunikation zum Server wird ausschließlich über diese Watchdog-Funktionalität überprüft.
Achtung: Der Netzwerk-Timeout muss mindestens die Hälfte des TCP-Timeouts des Betriebssystems betragen.

Beachten Sie die Besonderheiten für WAN und Wählverbindungen. Hier bedeutet eine Standardeinstellung für den Watchdog, dass die Verbindung permanent aufrecht erhalten wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenQuit"

Interne ID: ID_PROJEKT_NETZ_TOKEN_QUIT

Bedienberechtigung aktiv

Nur verfügbar bei aktiver Eigenschaft Netzwerk aktiv.
Die Bedienberechtigung im Netzwerk stellt sicher, dass im Netzwerk immer nur eine Station zur gleichen Zeit aktive Bedienhandlungen ausführen darf (z. B. Sollwerte ändern). Passiver, lesender Zugriff ist davon unabhängig immer möglich.
Aktiv: Nur ein Rechner kann das Projekt zur selben Zeit bedienen (z.B. Alarme quittieren, Sollwerte setzen).
Inaktiv: Mehrere Rechner können das Projekt zur gleichen Zeit bedienen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenQuit"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetTokenQuit"


ID_PROJEKT_NOT_TRANSLATED

Interne ID: ID_PROJEKT_NOT_TRANSLATED

Nicht übersetzte Schlüsselwörter anzeigen

Einstellung für die Darstellung von Schlüsselwörter, die in keiner der Sprachdateien existieren:

Aktiv: Darstellung zur Runtime als Schlüsselwort, zum Beispiel: @Text.
Inaktiv: Darstellung zur Runtime ohne vorangestelltes @, zum Beispiel: Text

Hinweis: Existiert das Schlüsselwort in einer der Sprachdateien, verfügt jedoch über keine Übersetzung, wird zur Runtime kein Text angezeigt (leerer String).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowNotTranslated"


ID_PROJEKT_PASSWORT

Interne ID: ID_PROJEKT_PASSWORT

Benutzerverwaltung

Projektbezogene Eigenschaften für die Benutzer-Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Password"


ID_PROJEKT_POKEACK

Interne ID: ID_PROJEKT_POKEACK

Funktion SW-Setzen

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
Aktiv: Beim erfolgreichen Schreiben von Werten auf die Hardware erfolgt ein entsprechender Eintrag in der CEL.
Inaktiv: Das erfolgreiche Schreiben von Werten wird in der CEL nicht protokolliert.
Default: inaktiv
Hinweis: Um diese Eigenschaft zu verwenden, muss das Sollwert-Setzen über die Funktion Sollwert absetzen ausgeführt werden.

Interne ID: ID_PROJEKT_POKEACK

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELPokeAck"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELPokeAck"


ID_PROJEKT_PRINT_ACTIVE

Interne ID: ID_PROJEKT_PRINT_ACTIVE

Drucken aktiv

Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
Inaktiv: Kein Online-Ausdruck findet statt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrintActive"


ID_PROJEKT_PRINT_AML_CEL

Interne ID: ID_PROJEKT_PRINT_AML_CEL

Ausdruck für

Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
Ermöglicht die Wahl, ob AMl oder CEL online gedruckt werden. Es kann immer nur eine der beiden Listen gedruckt werden.

Interne ID: ID_PROJEKT_PRINT_AML_CEL

Drucken aktiv

Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
Inaktiv: Kein Online-Ausdruck findet statt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrintCEL"

Alarmmeldeliste: Die Alarmmeldeliste (AML) wird online gedruckt.
Chronologische Ereignisliste: Die Chronologische Ereignisliste (CEL) wird online gedruckt.
Default: Alarmmeldeliste

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrintCEL"


ID_PROJEKT_PRINT_LINES_PAGE

Interne ID: ID_PROJEKT_PRINT_LINES_PAGE

Zeilen pro Seite

Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
Anzahl der Zeilen, die beim Online-Ausdruck pro Seite gedruckt werden.
Minimum: 0

Interne ID: ID_PROJEKT_PRINT_LINES_PAGE

Drucken aktiv

Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
Inaktiv: Kein Online-Ausdruck findet statt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrintLines"

Maximum: 65535
Default: 72

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrintLines"


ID_PROJEKT_SAME_COMMENTS

Interne ID: ID_PROJEKT_SAME_COMMENTS

Selbe Kommentare

Aktiv: Kommentare, die zur Runtime, zu einem Alarm hinzugefügt werden, werden auch beim dazugehörenden Eintrag der Chronologischen Ereignisliste (CEL) abgelegt.
Inaktiv: Kommentare zu einem Alarm werden nur in der Alarmmeldeliste abgelegt.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SameComments"


ID_PROJEKT_SEL_WITH_BORDER

Interne ID: ID_PROJEKT_SEL_WITH_BORDER

Selektion mit Rahmen

Aktiv: In der Alarmmeldeliste (AML) und der Chronologischen Ereignisliste (CEL) werden selektierte Zeilen durch mit einem Rahmen hervorgehoben. Empfohlen für bessere Lesbarkeit bei hohen Bildschirmauflösungen.
Inaktiv: Die Hintergrundfarbe der selektierten Zeilen wird invertiert. Empfohlen für bessere Lesbarkeit bei niedrigen Bildschirmauflösungen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SelBorder"


ID_PROJEKT_STARTBILD

Interne ID: ID_PROJEKT_STARTBILD

Startbild

Beim Start der Runtime wird dieses Bild automatisch geöffnet. Das erste in einem Projekt erzeugte Bild wird hier automatisch eingetragen.
Klick auf Schaltfläche ... öffnet den Bildauswahldialog.

Hinweis: Spezielle Bildtypen als Startbild werden mit leerem Filter und damit ohne Daten aufgeschaltet

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StartPictureGuid"


ID_PROJEKT_TOUCH1

Interne ID: ID_PROJEKT_TOUCH1

Bevorzugte Position

Eigenschaften für die bevorzugte Position, an der das automatische Keyboard relativ zum ausgewählten Element geöffnet wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPosition"


ID_PROJEKT_TOUCH2

Interne ID: ID_PROJEKT_TOUCH2

Alternative Position

Eigenschaften für die alternative Position, an der das automatische Keyboard relativ zum ausgewählten Element geöffnet wird, wenn es an der bevorzugten Position nicht geöffnet werden kann.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPositionAlt"


ID_PROJEKT_TOUCHSCREEN

Interne ID: ID_PROJEKT_TOUCHSCREEN

Automatisches Keyboard

Für Projekte mit Touchscreen.
Aktiv: Es wird automatisch ein Keyboard Fenster aufgeschaltet, wenn eine Eingabe notwendig ist (z.B: beim Sollwert setzen oder einloggen).
Inaktiv: Kein Keyboard Fenster wird geöffnet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Touchscreen"


ID_PROJEKT_TOUCHSCREEN_HORZ

Interne ID: ID_PROJEKT_TOUCHSCREEN_HORZ

Verschiebung horizontal [Pixel]

Horizontaler Abstand (in Pixeln) zum ausgewählten Element für die bevorzugte Position des automatischen Keyboards.
Default: 2.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPixelHorz"


ID_PROJEKT_TOUCHSCREEN_HORZ_ALT

Interne ID: ID_PROJEKT_TOUCHSCREEN_HORZ_ALT

Verschiebung horizontal [Pixel]

Horizontaler Abstand (in Pixeln) zum ausgewählten Element für die alternative Position des automatischen Keyboards.
Default: 2.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPixelHorzAlt"


ID_PROJEKT_TOUCHSCREEN_RIGHTLEFT

Interne ID: ID_PROJEKT_TOUCHSCREEN_RIGHTLEFT

Horizontal

Horizontale Position des automatischen Keyboards für die bevorzugte Position.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPosHorz"


ID_PROJEKT_TOUCHSCREEN_RIGHTLEFT_ALT

Interne ID: ID_PROJEKT_TOUCHSCREEN_RIGHTLEFT_ALT

Horizontal

Horizontale Position des automatischen Keyboards für die alternative Position.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPosHorzAlt"


ID_PROJEKT_TOUCHSCREEN_TOPBOT

Interne ID: ID_PROJEKT_TOUCHSCREEN_TOPBOT

Vertikal

Vertikale Position des automatischen Keyboards für die bevorzugte Position.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPosVert"


ID_PROJEKT_TOUCHSCREEN_TOPBOT_ALT

Interne ID: ID_PROJEKT_TOUCHSCREEN_TOPBOT_ALT

Vertikal

Vertikale Position des automatischen Keyboards für die alternative Position.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPosVertAlt"


ID_PROJEKT_TOUCHSCREEN_VERT

Interne ID: ID_PROJEKT_TOUCHSCREEN_VERT

Verschiebung vertikal [Pixel]

Vertikaler Abstand (in Pixeln) zum ausgewählten Element für die bevorzugte Position des automatischen Keyboards.
Default: 2.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPixelVert"


ID_PROJEKT_TOUCHSCREEN_VERT_ALT

Interne ID: ID_PROJEKT_TOUCHSCREEN_VERT_ALT

Verschiebung vertikal [Pixel]

Vertikaler Abstand (in Pixeln) zum ausgewählten Element für die alternative Position des automatischen Keyboards.
Default: 2.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KeyboardPixelVertAlt"


ID_PROJEKT_TREND_MILLISEC

Interne ID: ID_PROJEKT_TREND_MILLISEC

Trend und HD-Werte in Millisekunden

Aktiv: Darstellung und interne Verarbeitung der HD-Werte, sowie der Refresh der aktiven Bilder erfolgt in Millisekunden.
Inaktiv: Darstellung und interne Verarbeitung der HD-Werte, sowie der Refresh der aktiven Bilder erfolgt in Sekunden.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TrendMilliSec"


ID_PROJEKT_VARBEZEICHNER

Interne ID: ID_PROJEKT_VARBEZEICHNER

Variablenanzeige mit

Variablenanzeige in der Runtime über:
Klickt man in der Runtime mit der rechten Maustaste auf das Element und hält die Maustaste gedrückt, so wird abhängig von dieser Eigenschaft hier der Name, die Kennung oder die Adresse der Variable als Information angezeigt.
Darüber hinaus wird diese Eigenschaft für die defaultmäßige Anzeige der Variable in der Legende des Trendelements verwendet.
Zudem wird diese Eigenschaft für die Darstellung des Trendelements und in der Dialogbox des Multibin-Elements im Editor verwendet.
Adresse: Variablen werden mit ihrer Adresse angezeigt.
Kennung: Variablen werden mit ihrer Kennung angezeigt.
Name: Variablen werden mit ihrem Namen angezeigt.
Default: Name.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarIdentifier"


ID_PROJEKT_VERWALTUNG

Interne ID: ID_PROJEKT_VERWALTUNG

Projekt-Verwaltung

Der Konfigurationsdialog für das Projekt wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProjectAdministration"


ID_PROJEKT_VERZEICHNIS

Interne ID: ID_PROJEKT_VERZEICHNIS

Runtime-Ordner

Verzeichnis für die Runtime-Dateien des Projekts.
In dieses Verzeichnis werden die erzeugten Runtime-Dateien gespeichert und das Verzeichnis wird als Runtime Startverzeichnis gespeichert.
Als Default wird hier der beim Erstellen des Projekts angegebene Ordner eingetragen. Der Ordner kann hier nachträglich geändert werden.

Hinweis! Die bereits von der Runtime erzeugten historischen Daten werden müssen ggfs. manuell in den neuen Ordner umkopiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WorkingPath"


ID_PROJEKT_WINDOWS_CE

Interne ID: ID_PROJEKT_WINDOWS_CE

Windows CE Projekt

Aktiv: Funktionalitäten, die unter Windows CE nicht unterstützt werden, werden im Editor ausgeblendet (grau oder unsichtbar).
Hinweis: Wurde beim RGM für die Eigenschaft RGM Datenablage die Option MS Access DB ausgewählt, wird beim Aktivieren dieser Eigenschaft ein Dialog mit Hinweisen zur Konvertierung geöffnet.

Interne ID: ID_PROJEKT_WINDOWS_CE

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WindowsCE"

Inaktiv: Die gesamte lizenzierte Funktionalität der Editors steht zur Verfügung.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WindowsCE"


ID_PROP_COMBOLIST_DYNCONTENT_USE

Interne ID: ID_PROP_COMBOLIST_DYNCONTENT_USE

Einträge aus Stringvariable

Aktiv: Einträge für Combo-/Listbox werden über die in der Eigenschaft Variable ausgewählte Stringvariable definiert.

Interne ID: ID_PROP_COMBOLIST_DYNCONTENT_USE

Variable

Nur verfügbar, wenn Eigenschaft Einträge aus Stringvariable aktiv ist.

Auswahl der Stringvariable, die die Einträge für Combo-/Listbox enthält. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseDynContent"

Inaktiv: Einträge werden im Editor über den Dialog der Eigenschaft Einträge definiert.

Interne ID: ID_PROP_COMBOLIST_DYNCONTENT_USE

Einträge

Nur verfügbar, wenn die Eigenschaft Einträge aus Stringvariable inaktiv ist.

Klick auf Schaltfläche ... öffnet den Dialog zur Definition der Einträge für eine statische List-/Combobox.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseDynContent"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseDynContent"


ID_PROP_COMBOLIST_DYNCONTENT_VARIABLE

Interne ID: ID_PROP_COMBOLIST_DYNCONTENT_VARIABLE

Variable

Nur verfügbar, wenn Eigenschaft Einträge aus Stringvariable aktiv ist.

Interne ID: ID_PROP_COMBOLIST_DYNCONTENT_VARIABLE

Einträge aus Stringvariable

Aktiv: Einträge für Combo-/Listbox werden über die in der Eigenschaft Variable ausgewählte Stringvariable definiert.

Inaktiv: Einträge werden im Editor über den Dialog der Eigenschaft Einträge definiert.

Interne ID: ID_PROP_COMBOLIST_DYNCONTENT_VARIABLE

Einträge

Nur verfügbar, wenn die Eigenschaft Einträge aus Stringvariable inaktiv ist.

Klick auf Schaltfläche ... öffnet den Dialog zur Definition der Einträge für eine statische List-/Combobox.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynContentVariable"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynContentVariable"

Auswahl der Stringvariable, die die Einträge für Combo-/Listbox enthält. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynContentVariable"


ID_PROP_COMBOLIST_FGCOLOR_SEL

Interne ID: ID_PROP_COMBOLIST_FGCOLOR_SEL

Textfarbe bei Selektion

Definiert die Farbe des Textes, wenn ein Element ausgewählt wird. Die Farbe kann als Hexadezimalwert direkt in das Feld eingegeben oder nach Klick auf ... ausgewählt werden. Die Farbe ist statisch und verwendet nicht die verknüpfte Variable.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextColorSelected"


ID_PROP_COMBOLIST_HGCOLOR_SEL

Interne ID: ID_PROP_COMBOLIST_HGCOLOR_SEL

Hintergrundfarbe bei Selektion

Definiert die Hintergrundfarbe, wenn ein Element ausgewählt wird. Die Farbe kann als Hexadezimalwert direkt in das Feld eingegeben oder nach Klick auf ... ausgewählt werden. Die Farbe ist statisch und verwendet nicht die verknüpfte Variable.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorSelected"


ID_PROP_COMBOLIST_SOFORTREAKT

Interne ID: ID_PROP_COMBOLIST_SOFORTREAKT

Sofortreaktion

Ermöglicht, bei langsam reagierenden Treibern, eine Reaktion als bereits erfolgt darzustellen, auch wenn die Antwort des Treibers nich aussteht.

aktiv: Stellt in Visualisierung Treiberreaktion als erfolgt dar, auch wenn sie noch ausständig ist.

Deafault: aktiv

Hinweis: Sollte der Treiber nicht reagieren, wird das Ausbleiben der Reaktion nicht bemerkt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InstantReaction"


ID_PROP_ELE_RT_LASSO

Interne ID: ID_PROP_ELE_RT_LASSO

mit Lasso auswählbar

Die Auswahl per Lasso zur Runtime ermöglicht die Identifizierung von Dynamischen Elementen für die Verwendung mit VBA Events.
Aktiv: Das Element kann zur Runtime mit dem Lasso ausgewählt werden.
Inaktiv: Das Element kann zur Runtime nicht ausgewählt werden.
Default: aktiv

Achtung: Damit das Element zur Runtime auswählbar ist, muss zusätzlich in den Projekteigenschaften die Eigenschaft Runtime Einstellungen/Runtime Lasso aktiviert sein!

Interne ID: ID_PROP_ELE_RT_LASSO

Runtime Lasso

Aktiv: Durch Bewegen der Maus mit gedrückter linker Maustaste können in der Runtime mehrere Elemente selektiert werden. Auf diese Elemente kann dann ein VBA-Makro zugreifen.
Inaktiv: Die Lassofunktionalität wird nicht verwendet.
Default: inaktiv
Hinweis: Lasso funktioniert nur für Elemente, die 'Über Tastatur erreichbar' sind und mit denen eine Variable oder Funktion verknüpft ist. Statische Elemente werden nicht ausgewählt. Die Lassofunktion kann für einzelne Bildelemente über die Eigenschaft Runtime/mit Lasso auswählbart aktiviert oder deaktiviert werden.

Interne ID: ID_PROP_ELE_RT_LASSO

Runtime

Eigenschaften für das Runtime-Verhalten des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LassoSelect"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LassoSelect"

Interne ID: ID_PROP_ELE_RT_LASSO

Runtime Einstellungen

Eigenschaften für das Runtime-Verhalten des Projekts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LassoSelect"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LassoSelect"


ID_PROP_GRP_SYSTEMMODEL_GROUP

Interne ID: ID_PROP_GRP_SYSTEMMODEL_GROUP

Allgemein

Allgemeine Eigenschaften der Anlagengruppe.

Mehr in Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_PROP_GRP_SYSTEMMODEL_MODEL

Interne ID: ID_PROP_GRP_SYSTEMMODEL_MODEL

Allgemein

Allgemeine Eigenschaften des Anlagenmodells.

Mehr in Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_PROP_MSGCTRL_MESSAGE_ACKREQ

Interne ID: ID_PROP_MSGCTRL_MESSAGE_ACKREQ

Empfangsbestätigungspflichtig

Nachricht muss beim Empfang bestätigt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AckReq"


ID_PROP_MSGCTRL_MESSAGE_ACKTIMEOUT

Interne ID: ID_PROP_MSGCTRL_MESSAGE_ACKTIMEOUT

Empfangsbestätigungstimeout

Zeitfenster für die Bestätigung der Nachricht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AckTimeOut"


ID_PROP_MSGCTRL_MESSAGE_ATTACHMENT

Interne ID: ID_PROP_MSGCTRL_MESSAGE_ATTACHMENT

Anhang

Name des Anhangs einer Nachricht. Nur für E-Mail über SMTP.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Attachment"


ID_PROP_MSGCTRL_MESSAGE_ATTEMPTS

Interne ID: ID_PROP_MSGCTRL_MESSAGE_ATTEMPTS

Versuche

Anzahl der Versandversuche.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Attempts"


ID_PROP_MSGCTRL_MESSAGE_CODESFROMFUNCTION

Interne ID: ID_PROP_MSGCTRL_MESSAGE_CODESFROMFUNCTION

Funktionspezifische Codes

Anzeige, ob ein individueller Code für die Bestätigung verwendet wird.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CodesFromFunction"


ID_PROP_MSGCTRL_MESSAGE_CUSTOMID

Interne ID: ID_PROP_MSGCTRL_MESSAGE_CUSTOMID

Custom Identifier

Benutzerdefinierte Identifier.
Kann nur über VBA/VSTA im Event MessageCreated"gesetzt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CustomIdentifier"


ID_PROP_MSGCTRL_MESSAGE_CYCLECOUNTER

Interne ID: ID_PROP_MSGCTRL_MESSAGE_CYCLECOUNTER

Anzahl der Versandzyklen

Anzahl der Weiterleitungen dieser Nachricht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CycleCounter"


ID_PROP_MSGCTRL_MESSAGE_DESTINATION

Interne ID: ID_PROP_MSGCTRL_MESSAGE_DESTINATION

Ziel

Zieladresse der Nachricht (E-Mail-ADresse, Telefonnummer).

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Destination"


ID_PROP_MSGCTRL_MESSAGE_GUID

Interne ID: ID_PROP_MSGCTRL_MESSAGE_GUID

GUID

Eindeutige Kennung (GUID) der Nachricht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Guid"


ID_PROP_MSGCTRL_MESSAGE_MAXATTEMPTS

Interne ID: ID_PROP_MSGCTRL_MESSAGE_MAXATTEMPTS

Max. Versuche

Maximale Anzahl der Versandversuche.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxAttempts"


ID_PROP_MSGCTRL_MESSAGE_MESSAGE

Interne ID: ID_PROP_MSGCTRL_MESSAGE_MESSAGE

Nachricht

Nachrichtentext.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MessageText"


ID_PROP_MSGCTRL_MESSAGE_SEND

Interne ID: ID_PROP_MSGCTRL_MESSAGE_SEND

nächster Versuch

Zeitpunkt für den nächste Sende-Versuch der Nachricht.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Send"


ID_PROP_MSGCTRL_MESSAGE_SENT

Interne ID: ID_PROP_MSGCTRL_MESSAGE_SENT

Erzeugt / letzter Versand

Zeitpunkt, zu dem die Nachricht erzeugt wurde oder zu dem der letzte Sendeversuch erfolgte.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Sent"


ID_PROP_MSGCTRL_MESSAGE_TIMETOWAIT

Interne ID: ID_PROP_MSGCTRL_MESSAGE_TIMETOWAIT

Wartezeit

Wartezeit in Minuten für Überwachung von Timeout und Weiterleitung von Nachrichten.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimeToWait"


ID_PROP_MSGCTRL_MESSAGE_TITLE

Interne ID: ID_PROP_MSGCTRL_MESSAGE_TITLE

Betreff

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Title"


ID_PROP_SKIN_ADVANCEDSETTINGS

Interne ID: ID_PROP_SKIN_ADVANCEDSETTINGS

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AdvancedStyleH"


ID_PROP_SKIN_ADVANCEDSETTINGS_GROUP

Interne ID: ID_PROP_SKIN_ADVANCEDSETTINGS_GROUP

Bildlaufleisten

Eigenschaften für die horizontalen und vertikalen Bildlaufleisten.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AdvancedStyle"


ID_PROP_SKIN_ENABLEHEADER

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Kopfzeile bedienbar

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile selektiert haben.

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_ENABLEHEADER

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Interne ID: ID_PROP_SKIN_ENABLEHEADER

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Ermöglicht es die Kopfzeile für das entsprechende Listenfeld zu bedienen. Zur Runtime können Sie die einzelnen Spalten verschieben und ihre Breite verändern. Sie könne die Darstellung nach einer beliebigen Spalte sortieren.

aktiv: Die Kopfzeile ist bedienbar.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnableHeader"


ID_PROP_SKIN_GRIDCOLORH

Interne ID: ID_PROP_SKIN_GRIDCOLORH

Horizontale Linienfarbe

Definiert die Linienfarbe der horizontalen Rasterlinien in der Listendarstellung in der Runtime. Ein Linksklick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Sie können die gewünschte Farbbezeichnung auch direkt als Hex-Code (RGB) ins Eingabefeld eingeben.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps verwendet.

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridColorH"


ID_PROP_SKIN_GRIDCOLORV

Interne ID: ID_PROP_SKIN_GRIDCOLORV

Vertikale Linienfarbe

Definiert die Linienfarbe der horizontalen Rasterlinien in der Listendarstellung in der Runtime. Ein Linksklick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Sie können die gewünschte Farbbezeichnung auch direkt als Hex-Code (RGB) ins Eingabefeld eingeben.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps verwendet.

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridColorV"


ID_PROP_SKIN_GRIDGRP

Interne ID: ID_PROP_SKIN_GRIDGRP

Raster

Eigenschaften für das Raster des Listenfelds.

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Grid"


ID_PROP_SKIN_GRIDSIZEH

Interne ID: ID_PROP_SKIN_GRIDSIZEH

Horizontale Linienbreite [Pixel]

Breite der horizontalen Rasterlinien in Pixel. Verändern Sie den Wert, um die horizontalen Linien des Rasters in der Listendarstellung in der Runtime zu ändern. Wenn Sie 0 eingeben werden die horizontalen Linien ausgeblendet.

Default: 1.

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridSizeH"


ID_PROP_SKIN_GRIDSIZEV

Interne ID: ID_PROP_SKIN_GRIDSIZEV

Vertikale Linienbreite [Pixel]

Breite der vertikalen Rasterlinien in Pixel. Verändern Sie den Wert, um die vertikalen Linien des Rasters in der Listendarstellung in der Runtime zu ändern. Wenn Sie 0 eingeben werden die vertikalen Linien ausgeblendet.

Default: 1.

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridSizeV"


ID_PROP_SKIN_GRIDTYPEH

Interne ID: ID_PROP_SKIN_GRIDTYPEH

Horizontale Linienart

Definiert die Art der horizontalen Rasterlinien in der Listendarstellung in der Runtime. Klicken Sie auf die Linie und selektieren Sie die gewünschte Linienart (durchgezogenen Linie, unterbrochenen Linie, gestrichelte Linie usw.).

Default: durchgezogenen Linie.

Achtung: Diese Eigenschaft steht nur zur Verfügung, wenn der Wert für die Eigenschaft Horizontale Linienbreite [Pixel] 1 beträgt. Für Werte >1 wird immer eine durchgezogene Linie verwendet.

Interne ID: ID_PROP_SKIN_GRIDTYPEH

Horizontale Linienbreite [Pixel]

Breite der horizontalen Rasterlinien in Pixel. Verändern Sie den Wert, um die horizontalen Linien des Rasters in der Listendarstellung in der Runtime zu ändern. Wenn Sie 0 eingeben werden die horizontalen Linien ausgeblendet.

Default: 1.

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridTypeH"

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridTypeH"


ID_PROP_SKIN_GRIDTYPEV

Interne ID: ID_PROP_SKIN_GRIDTYPEV

Vertikale Linienart

Definiert die Art der vertikalen Rasterlinien in der Listendarstellung in der Runtime. Klicken Sie auf die Linie und selektieren Sie die gewünschte Linienart (durchgezogenen Linie, unterbrochenen Linie, gestrichelte Linie usw.).

Default: durchgezogenen Linie.

Achtung: Diese Eigenschaft steht nur zur Verfügung, wenn der Wert für die Eigenschaft Vertikale Linienbreite [Pixel] 1 beträgt. Für Werte >1 wird immer eine durchgezogene Linie verwendet.

Interne ID: ID_PROP_SKIN_GRIDTYPEV

Vertikale Linienbreite [Pixel]

Breite der vertikalen Rasterlinien in Pixel. Verändern Sie den Wert, um die vertikalen Linien des Rasters in der Listendarstellung in der Runtime zu ändern. Wenn Sie 0 eingeben werden die vertikalen Linien ausgeblendet.

Default: 1.

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridTypeV"

Hinweis: Das Raster wird nur angezeigt, wenn in der Funktion Bildumschaltung oder in der Runtime im Filter das Raster aktiviert ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GridTypeV"


ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor"


ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Interne ID: ID_PROP_SKIN_HEADERBAR_BACKCOLOR2

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBackColor2"


ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTANGLE

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientAngle"


ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Interne ID: ID_PROP_SKIN_HEADERBAR_COLORGRADIENTOFFSET

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderColorGradientOffset"


ID_PROP_SKIN_HEADERBAR_FONT

Interne ID: ID_PROP_SKIN_HEADERBAR_FONT

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderFont"


ID_PROP_SKIN_HEADERBAR_FONT_COLOR

Interne ID: ID_PROP_SKIN_HEADERBAR_FONT_COLOR

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderFontColor"


ID_PROP_SKIN_HEADERBAR_GRP

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Interne ID: ID_PROP_SKIN_HEADERBAR_GRP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBar"


ID_PROP_SKIN_HEADERBAR_LIGHTNING

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Interne ID: ID_PROP_SKIN_HEADERBAR_LIGHTNING

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderLightning"


ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Absteigend sortiert

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für absteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTDOWN

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"

Default: keine Datei

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DescDownImage"


ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Aufsteigend sortiert

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds für aufsteigend sortiert angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSORTUP

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"

Default: keine Datei

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AscSortImage"


ID_PROP_SKIN_HEADERBAR_PRJSPAN

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Hintergrund

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Selektieren Sie eine Grafikdatei, die in der Runtime in der Kopfzeile des Listenfelds als Hintergrund angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Interne ID: ID_PROP_SKIN_HEADERBAR_PRJSPAN

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"

Default: keine Datei

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderBarImage"


ID_PROP_SKIN_HEADERBAR_STYLE

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Interne ID: ID_PROP_SKIN_HEADERBAR_STYLE

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HeaderStyle"


ID_PROP_SKIN_HORBAR_BACKCOLOR

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorH"


ID_PROP_SKIN_HORBAR_BACKCOLOR2

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Interne ID: ID_PROP_SKIN_HORBAR_BACKCOLOR2

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2H"


ID_PROP_SKIN_HORBAR_BUTTONHEIGHT

Interne ID: ID_PROP_SKIN_HORBAR_BUTTONHEIGHT

Höhe Bildlaufpfeil [Pixel]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_BUTTONHEIGHT

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonHeightH"

Definieren Sie die Höhe des Bildlaufpfeils der horizontalen Bildlaufleiste in Pixel. Passen Sie den Wert Ihren Vorstellungen an.

Default: 12.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonHeightH"


ID_PROP_SKIN_HORBAR_BUTTONWIDTH

Interne ID: ID_PROP_SKIN_HORBAR_BUTTONWIDTH

Breite Bildlaufpfeil [Pixel]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_BUTTONWIDTH

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonWidthH"

Definieren Sie die Breite des Bildlaufpfeils der horizontalen Bildlaufleiste in Pixel. Passen Sie den Wert Ihren Vorstellungen an.

Default: 12.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonWidthH"


ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTANGLE

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleH"


ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Interne ID: ID_PROP_SKIN_HORBAR_COLORGRADIENTOFFSET

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetH"


ID_PROP_SKIN_HORBAR_GRP

Interne ID: ID_PROP_SKIN_HORBAR_GRP

Horizontale Bildlaufleiste

Eigenschaften für die horizontalen Bildlaufleisten des Listenfelds.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HorizontalBar"


ID_PROP_SKIN_HORBAR_LIGHTNING

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Interne ID: ID_PROP_SKIN_HORBAR_LIGHTNING

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningH"


ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Bildlaufpfeil Links

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld für den Bildlaufpfeil Links für die horizontale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJLEFTBMP

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftH"


ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Bildlaufpfeil Rechts

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld für den Bildlaufpfeil Rechts für die horizontale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJRIGHTBMP

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightH"


ID_PROP_SKIN_HORBAR_PRJSPAN

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Hintergrund Grafikdatei

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld als Hintergrund für die horizontale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJSPAN

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanH"


ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Bildlauffeld

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld für das Bildlauffeld für die horizontale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Interne ID: ID_PROP_SKIN_HORBAR_PRJTHUMBBMP

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbH"


ID_PROP_SKIN_HORBAR_STYLE

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Interne ID: ID_PROP_SKIN_HORBAR_STYLE

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleH"


ID_PROP_SKIN_HORBAR_THUMBSIZE

Interne ID: ID_PROP_SKIN_HORBAR_THUMBSIZE

Breite Bildlauffeld [Pixel]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_HORBAR_THUMBSIZE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ThumbSizeH"

Definieren Sie die Breite des Bildlauffelds der horizontalen Bildlaufleiste in Pixel. Passen Sie den Wert Ihren Vorstellungen an.

Default: 20.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ThumbSizeH"


ID_PROP_SKIN_NOSELECTION

Interne ID: ID_PROP_SKIN_NOSELECTION

Selektierte Zeile nicht markieren

Hiermit legen Sie fest, ob die selektierte Zeile im Listenfeld grafisch hervorgehoben wird. Wenn Sie die Eigenschaft aktivieren, sehen Sie nicht welchen Eintrag Sie selektiert haben. Alle Zeilen der Liste sehen gleich aus.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HideSelection"


ID_PROP_SKIN_SHOWBORDER

Interne ID: ID_PROP_SKIN_SHOWBORDER

Rahmenlinie anzeigen

Ermöglicht es einen Rahmen, um ein Element anzuzeigen. Die Flags der Eigenschaften Style L und Style H werden dadurch ausmaskiert.

Interne ID: ID_PROP_SKIN_SHOWBORDER

Style H

Windows-Style des Elements, nur für internen Gebrauch.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowBorder"

Interne ID: ID_PROP_SKIN_SHOWBORDER

Style L

Windows-Style des Elements, nur für internen Gebrauch.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowBorder"

aktiv: Der Rahmen wird um das entsprechenden Element angezeigt.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowBorder"


ID_PROP_SKIN_SHOWHEADER

Interne ID: ID_PROP_SKIN_SHOWHEADER

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Interne ID: ID_PROP_SKIN_SHOWHEADER

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_SHOWHEADER

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Interne ID: ID_PROP_SKIN_SHOWHEADER

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Interne ID: ID_PROP_SKIN_SHOWHEADER

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_SHOWHEADER

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_SHOWHEADER

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_SHOWHEADER

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Interne ID: ID_PROP_SKIN_SHOWHEADER

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Interne ID: ID_PROP_SKIN_SHOWHEADER

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Interne ID: ID_PROP_SKIN_SHOWHEADER

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_SHOWHEADER

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowHeader"


ID_PROP_SKIN_VERBAR_BACKCOLOR

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der vertikalen Bildlaufleisten benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorV"


ID_PROP_SKIN_VERBAR_BACKCOLOR2

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der vertikalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Interne ID: ID_PROP_SKIN_VERBAR_BACKCOLOR2

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der vertikalen Bildlaufleisten benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor2V"


ID_PROP_SKIN_VERBAR_BUTTONHEIGHT

Interne ID: ID_PROP_SKIN_VERBAR_BUTTONHEIGHT

Höhe Bildlaufpfeil [Pixel]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_BUTTONHEIGHT

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonHeightV"

Definieren Sie die Höhe des Bildlaufpfeils der vertikalen Bildlaufleiste in Pixel. Passen Sie den Wert Ihren Vorstellungen an.

Default: 12.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonHeightV"


ID_PROP_SKIN_VERBAR_BUTTONWIDTH

Interne ID: ID_PROP_SKIN_VERBAR_BUTTONWIDTH

Breite Bildlaufpfeil [Pixel]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_BUTTONWIDTH

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonWidthV"

Definieren Sie die Breite des Bildlaufpfeils der vertikalen Bildlaufleiste in Pixel. Passen Sie den Wert Ihren Vorstellungen an.

Default: 12.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ButtonWidthV"


ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTANGLE

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der vertikalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der vertikalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientAngleV"


ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Interne ID: ID_PROP_SKIN_VERBAR_COLORGRADIENTOFFSET

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der vertikalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der vertikalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ColorGradientOffsetV"


ID_PROP_SKIN_VERBAR_GRP

Interne ID: ID_PROP_SKIN_VERBAR_GRP

Vertikale Bildlaufleiste

Eigenschaften für die vertikalen Bildlaufleisten des Listenfelds.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VerticalBar"


ID_PROP_SKIN_VERBAR_LIGHTNING

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Interne ID: ID_PROP_SKIN_VERBAR_LIGHTNING

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"

Selektieren Sie hier die Art des Farbverlaufs für die vertikale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LightningV"


ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Bildlaufpfeil Hinauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld für den Bildlaufpfeil Hinauf für die vertikale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJLEFTBMP

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapLeftV"


ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Bildlaufpfeil Hinunter

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld für den Bildlaufpfeil Hinunter für die vertikale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJRIGHTBMP

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapRightV"


ID_PROP_SKIN_VERBAR_PRJSPAN

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Hintergrund Grafikdatei

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld als Hintergrund für die vertikale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJSPAN

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapSpanV"


ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Bildlauffeld

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Selektieren Sie eine Grafikdatei, die in der Runtime im Listenfeld für das Bildlauffeld für die vertikale Bildlaufleiste angezeigt werden soll. Diese Grafik wird verwendet, wenn Sie bei Anzeigestil Grafikdatei selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der horizontalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der horizontalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML.

Mehr im Online-Handbuch CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die horizontale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Interne ID: ID_PROP_SKIN_VERBAR_PRJTHUMBBMP

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der horizontalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"

Default: keine Datei

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitmapThumbV"


ID_PROP_SKIN_VERBAR_STYLE

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Anzeigestil

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Farbverlauf, Versatz [%] und Winkel [°] nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Winkel [°]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Anzeigestil

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Kopfzeile anzeigen

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben.
Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Zeigt die Kopfzeile für das entsprechende Listenfeld an. In der Gruppe Kopfzeile können Sie das Aussehen der Kopfzeile Ihren Vorstellungen entsprechend anpassen.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Kopfzeile

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Eigenschaften für die Kopfzeile des Listenfelds.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

aktiv: Die Kopfzeile wird angezeigt.

Default: aktiv

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Kopfzeile CEL

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.
keine Kopfzeile: In der CEL wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.
fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt.
bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der CEL angezeigt. Die einzelnen Spalten können zur Runtime verschoben werden, die Breite kann geändert werden, es kann nach einer beliebigen Spalte sortiert werden.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Chronologische Ereignisliste

Eigenschaften für die Verwaltung der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Kopfzeile AML

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
keine Kopfzeile: In der Alarmmeldeliste wird in der Runtime keine Kopfzeile mit Spaltentitel angezeigt.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

fixierte Kopfzeile: Eine fixe Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt.

bedienbare Kopfzeile: Eine bedienbare Kopfzeile mit entsprechenden Spaltentiteln wird in der Alarmmeldeliste angezeigt. Die einzelnen Spalten können zur Runtime verschoben und in der Breite angepasst werden. Es kann nach einer beliebigen Spalte sortiert werden.

Achtung: Die Einstellungen keine Kopfzeile und bedienbare Kopfzeile sind zur Runtime nur funktionsfähig, wenn für das Listenelement des AML-Bildes die Eigenschaft Erweiterte grafische Einstellungen inaktiv geschaltet oder in den Projekteigenschaften in der Gruppe Grafische Ausprägung die Eigenschaft Grafikqualität auf off gestellt wurde.
Default: bedienbare Kopfzeile

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Alarmmeldeliste

Eigenschaften für die Alarmkonfiguration.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Hier definieren Sie, wie die Kopfzeile des Listenfelds ausschauen soll. Selektieren Sie eine der folgenden Optionen:

Farbverlauf: Verwendet einen speziellen Farbverlauf für die Kopfzeile, den Sie mithilfe der Einstellungen Füllfarbe, Verlaufsfarbe, Lichteffekt, Versatz und Winkel nach Ihren Vorstellungen anpassen können.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Winkel

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Versatz

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der Kopfzeile nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der Kopfzeile, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Lichteffekt

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die Kopfzeile aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Verlaufsfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Füllfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch AML

Mehr im Online-Handbuch CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Füllfarbe

Nur verfügbar, wenn Sie in den Projekteinstellungen in der Gruppe Alarmmeldeliste für die Eigenschaft Kopfzeile AML bzw. in der Gruppe Chronologische Ereignisliste für die Eigenschaft Kopfzeile CEL bedienbare Kopfzeile oder fixierte Kopfzeile selektiert haben. Weiters müssen Sie auch die Eigenschaften Erweiterte grafische Einstellungen und Kopfzeile anzeigen für das jeweilige Listenfeld aktivieren.

Verfügbar für die Cursor-Ausgabeliste im Erweiterten Trend.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der Kopfzeile benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Textfarbe

Definieren Sie die Farbe, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Schrift

Diese Eigenschaft steht Ihnen unter Windows XP nicht zur Verfügung.

Definieren Sie die Schrift, die für Text in der Kopfzeile verwendet werden soll. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der vordefinierten Schriftarten.

Als Schrift für neu angelegte Elemente wird die jeweils zuletzt verwendete Schrift dieses Elements übernommen.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Default: Standard.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Mehr im Online-Handbuch für ETM

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Definieren Sie den Winkel, in dessen Richtung sich der Farbverlauf ausbreitet. Als Ausgangspunkt wird der mit der Eigenschaft Versatz [%] definierte Punkt verwendet.

Minimum: 0

Maximum: 360

Default: 0

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Versatz [%]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie den Abstand des Farbverlaufpunkts vom Mittelpunkt der vertikalen Bildlaufleiste nach links oder rechts in Prozent. 0 entspricht dem Mittelpunkt der vertikalen Bildlaufleiste, 100 dem rechten Rand und -100 dem linken Rand.

Minimum: -100

Maximum: 100

Default: 0

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Farbverlauf

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Selektieren Sie hier die Art des Farbverlaufs für die vertikale Bildlaufleiste aus folgenden Optionen:

Linear: gleichmäßiger Verlauf

Punktuell: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs

Punktuell mit Kante: Verlauf von den Rändern zum definierten Ausgangspunkts des Farbverlaufs mit Kantenbildung

Default: Linear

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Verlaufsfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die zweite Hintergrundfarbe, die für den Farbverlauf in der vertikalen Bildlaufleiste benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein. Bei Auswahl von Automatisch ändert sich der Wert abhängig vom Wert der Einstellung Füllfarbe.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Interne ID: ID_PROP_SKIN_VERBAR_STYLE

Füllfarbe

Diese Eigenschaft hat nur Auswirkung, wenn Sie bei der Eigenschaft Anzeigestil Farbverlauf selektiert haben.

Definieren Sie die erste Hintergrundfarbe, die für den Farbverlauf in der vertikalen Bildlaufleisten benutzt wird. Ein Klick auf die Schaltfläche öffnet die Palette der vordefinierten Farben. Oder tragen Sie die Farbbezeichnung manuell als Hex-Code (RGB) ins Eingabefeld ein.

Als Farbe für neu angelegte Elemente wird die jeweils zuletzt verwendete Farbe dieses Elementtyps übernommen.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"

Grafikdatei: Verwendet die selektierten Grafikdateien für die einzelnen Bereiche. Wenn keine Grafikdateien selektiert wurde, wird die Anzeige Farbverlauf verwendet.

Standard: Verwendet die standard Einstellung für die Kopfzeile. Sie können nur die Schrift und die Textfarbe mithilfe der entsprechenden Einstellungen verändern.

Default: Standard.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BarStyleV"


ID_PROP_SKIN_VERBAR_THUMBSIZE

Interne ID: ID_PROP_SKIN_VERBAR_THUMBSIZE

Breite Bildlauffeld [Pixel]

Nur verfügbar, wenn Sie Erweiterte grafische Einstellungen aktiviert haben.

Interne ID: ID_PROP_SKIN_VERBAR_THUMBSIZE

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ThumbSizeV"

Definieren Sie die Breite des Bildlauffelds der vertikalen Bildlaufleiste in Pixel. Passen Sie den Wert Ihren Vorstellungen an.

Default: 20.

Mehr im Online-Handbuch für AML.

Mehr im Online-Handbuch für CEL.

Mehr im Online-Handbuch für ETM.

Mehr im Online-Handbuch für RGM.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ThumbSizeV"


ID_PROP_SYSTEMMODEL_GROUP_NAME

Interne ID: ID_PROP_SYSTEMMODEL_GROUP_NAME

Name

Name der Gruppe. Wird beim Erstellen automatisch mit fortlaufender Nummer vergeben und kann beliebig geändert werden.

Default: GruppeX (X steht für eine fortlaufende Nummer)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_PROP_SYSTEMMODEL_ROOT_NAME

Interne ID: ID_PROP_SYSTEMMODEL_ROOT_NAME

Name

Name des Modells. Wird beim Erstellen automatisch mit fortlaufender Nummer vergeben und kann beliebig geändert werden.

Default: ModellX (X steht für eine fortlaufende Nummer)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_PROP_SYSTEMMODELGOUP

Interne ID: ID_PROP_SYSTEMMODELGOUP

Anlagengruppen

Verknüpft Element mit einem Anlagenmodell. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Anlagengruppe.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SystemModelGroup"


ID_PROP_VIEWLIMITFROMVAR

Interne ID: ID_PROP_VIEWLIMITFROMVAR

Anzeigebereich von Variable übernehmen

Übernimmt den Anzeigebereich aus der verknüpften Variablen. So können diese Anzeigebereiche beim Ersetzen durch eine Variable mit anderen Wertebereichen aktualisiert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ViewLimitFromVar"


ID_PROP_WPFELEM_CONFIG_LINKS

Interne ID: ID_PROP_WPFELEM_CONFIG_LINKS

Konfiguration

Öffnet den Dialog zur Konfiguration der XAML-Datei. Eigenschaften, Ereignisse, Transformationen und Bedienberechtigungen können zugewiesen werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LinksConfig"


ID_PROP_WPFELEM_XAMLFILE

Interne ID: ID_PROP_WPFELEM_XAMLFILE

XAML-Datei

Auswahl der XAML-Datei für das WPF-Element. Klick auf ... öffnet Dialog zur Auswahl. Die Datei muss bereits im Projektmanager unter Dateien/Grafiken angelegt worden sein oder im Dialog über das Symbol Datei hinzufügen ausgewählt werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FileName"


ID_PUNCHFRAME_ALPHA

Interne ID: ID_PUNCHFRAME_ALPHA

Transparenz [%]

Nur verfügbar, wenn als Rahmenart Schatten und die Projekteigenschaft Grafikqualität ausgewählt wurde.

Interne ID: ID_PUNCHFRAME_ALPHA

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PUNCHFRAME_ALPHA

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PUNCHFRAME_ALPHA

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAlpha"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAlpha"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAlpha"

Interne ID: ID_PUNCHFRAME_ALPHA

Rahmenart

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
Rahmen: Das Element kann mit einem Rahmen versehen werden.
Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

Default: Kein Rahmen/Schatten

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAlpha"

Gibt die Transparenz des Schattens zwischen 0 und 100 % an.

0: deckend

100: durchsichtig

Default: 60

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAlpha"


ID_PUNCHFRAME_ANGLE

Interne ID: ID_PUNCHFRAME_ANGLE

Winkel [°]

Nur verfügbar, wenn als Rahmenart Schatten und die Projekteigenschaft Grafikqualität gewählt wurde.

Interne ID: ID_PUNCHFRAME_ANGLE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PUNCHFRAME_ANGLE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PUNCHFRAME_ANGLE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAngle"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAngle"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAngle"

Interne ID: ID_PUNCHFRAME_ANGLE

Rahmenart

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
Rahmen: Das Element kann mit einem Rahmen versehen werden.
Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

Default: Kein Rahmen/Schatten

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAngle"

Winkel in Grad, in dem sich der Schatten verschiebt.

Werte: 0° bis 359°. 0° entspricht der rechten äußeren Position (3 Uhr), wird gegen den Uhrzeigersinn fortgesetzt.

Default: 0°

Klick auf die Schaltfläche ... öffnet Schieberegler.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameAngle"


ID_PUNCHFRAME_SIZE

Interne ID: ID_PUNCHFRAME_SIZE

Schattengröße [%]

Nur verfügbar, wenn als Rahmenart Schatten und die Projekteigenschaft Grafikqualität gewählt wurde.

Interne ID: ID_PUNCHFRAME_SIZE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PUNCHFRAME_SIZE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PUNCHFRAME_SIZE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSize"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSize"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSize"

Interne ID: ID_PUNCHFRAME_SIZE

Rahmenart

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
Rahmen: Das Element kann mit einem Rahmen versehen werden.
Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

Default: Kein Rahmen/Schatten

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSize"

Wert in Pixel, der die Größe des Schattens unabhängig definiert.

Die Größe des Wertebereichs ist von der Bildschirm-Auflösung abhängig.

Positiver Wert: Schatten wird größer als Element

Negativer Wert: Schatten wird kleiner als Element.

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSize"


ID_PUNCHFRAME_SOFTFOCUS

Interne ID: ID_PUNCHFRAME_SOFTFOCUS

Weichzeichnung

Nur verfügbar, wenn als Rahmenart Schatten und die Projekteigenschaft Grafikqualität gewählt wurde.

Interne ID: ID_PUNCHFRAME_SOFTFOCUS

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PUNCHFRAME_SOFTFOCUS

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PUNCHFRAME_SOFTFOCUS

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSoftFocus"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSoftFocus"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSoftFocus"

Interne ID: ID_PUNCHFRAME_SOFTFOCUS

Rahmenart

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
Rahmen: Das Element kann mit einem Rahmen versehen werden.
Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

Default: Kein Rahmen/Schatten

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSoftFocus"

Definiert den Grad der Weichzeichnung in Anzahl der Pixel, die für das Verwischen verwendet werden. Je höher dieser Wert ist, desto weicher wird der Übergang des Schattens. Klick auf die Schaltfläche ... öffnet den Schieberegler zur Einstellung des Werts.

Werte: 0 bis 50

0: Keine Weichzeichnung

50: Maximale Weichzeichnung

Default: 0

Achtung: Wird ein Wert ungleich 0 eingestellt, dann bremst die Berechnung des Schattens eventuell die Systemleistung. Das gilt im Editor besonders für das Verschieben des Schattens oder das Platzieren von anderen Objekten auf dem Schatten. Zur Runtime ist jede Bildumschaltung davon betroffen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameSoftFocus"


ID_PUNCHFRAME_TYPE

Interne ID: ID_PUNCHFRAME_TYPE

Rahmenart

Dropdownliste zur Auswahl der Rahmenart. Zur Verfügung stehen:

Kein Rahmen/Schatten: Es wird kein Rahmen und Schatten angezeigt.
Rahmen: Das Element kann mit einem Rahmen versehen werden.
Schatten: Das Element kann mit einem Schatten versehen werden. (Nur verfügbar, wenn in den Projekteigenschaften Grafikqualität aktiviert wurde.)
Ausnahme: Die Elemente Statischer Text und Zustandselement können keinen Schatten erhalten.

Interne ID: ID_PUNCHFRAME_TYPE

Grafikqualität

Einstellung für Qualität der Grafikdarstellung.
DirectX ermöglicht eine höhere Qualität als Windows Basis oder Windows Erweitert. DirectX Darstellung wird nur in der Runtime unterstützt. Prinzipiell ist bei Verwendung von DirectX die Einstellung DirectX Hardware zu bevorzugen und DirectX Software nur zu verwenden, wenn unbedingt nötig.

Mögliche Auswahl:

Windows Basis: Grundlegende Grafikeigenschaften. Für ressourcenschwache Hardware empfohlen.

Windows Erweitert: Stellt verbesserte Funktionen für die grafische Darstellung zur Verfügung, benötigt mehr Ressourcen.

DirectX Software: Grafikberechnung wird von der CPU erledigt und kann zu hoher CPU Auslastung führen.

DirectX Hardware: Ein Teil der Grafikberechnungen wird auf die Grafikkarte ausgelagert. Unterstützt das System die Einstellung nicht, wird automatisch auf DirectX Software umgeschaltet.

Default: Windows Erweitert

Achtung: Windows Erweitert und DirectX stehen unter Windows CE nicht zur Verfügung.

Hinweise:
Beim Umschalten des Modus während der Projektierung kann es zu geringfügigen Pixelabweichungen kommen. Die Eigenschaft sollte daher vor dem Erstellen von Bildern gesetzt werden.
Beim Aktivieren von Windows Basis werden für alle Linienarten, die eine Linienbreite [Pixel] >1 verwenden, sämtliche Linientypen wieder auf durchgehende Linie gesetzt.

Mehr im Online-Handbuch

Interne ID: ID_PUNCHFRAME_TYPE

Linienbreite [Pixel]

Linienbreite (in Pixel).
Minimum: 0
Die Linienbreite ist in diesem Fall 1 Pixel.
Maximum: 65535
Default: 1
Achtung: Wurde in den Projekteigenschaften im Knoten Grafische Ausprägung die Eigenschaft Grafikqualität auf Windows Basis gestellt, kann die Linienbreite >1 nur mit einer Linie des Typs "durchgehende Linie" verwendet werden.

Interne ID: ID_PUNCHFRAME_TYPE

Grafische Ausprägung

Eigenschaften für die grafische Ausprägung der Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameType"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameType"

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameType"

Default: Kein Rahmen/Schatten

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PunchFrameType"


ID_PWVALID

Interne ID: ID_PWVALID

Pwt. Gültigkeitsd.[d]

Eingabe eines Zeitraumes (in Tagen), wie lange ein Passwort gültig ist. Nach abgelaufener Zeit muss ein neues Passwort vergeben werden.
Minimum: 0 - Das Passwort läuft nie ab und muss nicht erneuert werden. Bei dieser Einstellung wird der Wert 2147483647 auf die Systemtreibervariable "Tage bis Passwort abläuft" geschrieben.
Maximum: 4294967295.
Default: 0.
Achtung: Bei Produktionen nach den Richtlinien der FDA ist der Eintrag 0 hier nicht zulässig, da die Regeln der FDA ein zyklisches Ändern des Passworts verlangen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PWValid"


ID_READWRITE

Interne ID: ID_READWRITE

Extern SW setzen aktiv

Externe Eigenschaft für zenon Logic. Betrifft nur Variablen, die nicht vom straton-Treiber sind.
Aktiv: Der Wert der Variable kann in zenon Logic geändert werden. Die Variablendefinition kann in zenon Logic nicht geändert werden.
Inaktiv: Variable kann in zenon Logic nicht geändert werden.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReadWrite"


ID_RECIPE_GRP1

Interne ID: ID_RECIPE_GRP1

Allgemein

Allgemeine Eigenschaften für das Rezept.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_RECIPE_PW

Interne ID: ID_RECIPE_PW

Berechtigungsebene

Benötigte Berechtigungsgruppe zum Ändern des Rezepts in der Runtime.
Ein Benutzer darf Rezeptwerte nur dann ändern (lesen, manuelles ändern, löschen), wenn er das Passwortlevel erfüllt.
Minimum: 0.
Maximum: 127.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PasswordLevel"


ID_REMA_PROP1

Interne ID: ID_REMA_PROP1

Name

Eindeutiger Name der Reaktionsmatrix.

ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_REMA_PROP2

Interne ID: ID_REMA_PROP2

Typ

Typ der Reaktionsmatrix:
Binär: Auswertung diskreter Zustände (bitorientiert)
Multi-binär: erweiterte Auswertung von 32-Bit-Variablen; die ersten 16 Bit bestimmen den Wert der Variable und werden als Zahlenwert übergeben; Umrangierung von Statusbits; Sonderfunktion (abschalten von Variablen bei gesetztem Statusbit) (Schutzdatenprojektierung - nur SAT-spezifisch)
Analog: Auswertung analoger Zustände (Wertorientiert)
Multi-analog: erweiterte Auswertung mit gleichzeitiger Statusrangierung und Sonderfunktion (abschalten von Variablen bei gesetztem Statusbit)
String: Textvergleich
Der Typ wird beim erstellen einer neuen Reaktionsmatrix festgelegt und kann später nicht mehr verändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Type"


ID_REMA_PROP46

Interne ID: ID_REMA_PROP46

Zusatzinformation 1

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserProperty1"


ID_REMA_PROP47

Interne ID: ID_REMA_PROP47

Zusatzinformation 2

In der Runtime kann die hier eingegebene Zusatzinformation in einem VBA Makro ausgewertet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserProperty2"


ID_REMA_PROP_GRP0

Interne ID: ID_REMA_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die Reaktionsmatrix.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_REMA_STATES

Interne ID: ID_REMA_STATES

Konfiguration

Der Dialog zur Definition der Zustände wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "States"


ID_RGM_PROP06

Interne ID: ID_RGM_PROP06

Gruppenname

Name der Rezeptgruppe.

Bei Einstellung Binäre Dateien für Eigenschaft RGM Datenablage sind nur alphanumerischen Zeichen erlaubt.

Interne ID: ID_RGM_PROP06

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_RGM_PROP13

Interne ID: ID_RGM_PROP13

Rezeptnummer

Nummer des Rezepts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeNumber"


ID_RGM_PROP14

Interne ID: ID_RGM_PROP14

Rezeptname

Name für Rezept. Der Rezeptname muss eindeutig sein. Wurde Binäre Dateien für die Eigenschaft RGM Datenablage gewählt, darf der Name nur alphanumerische Zeichen enthalten.

Interne ID: ID_RGM_PROP14

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeName"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeName"


ID_RGM_PROP15

Interne ID: ID_RGM_PROP15

Kommentar 1

Kommentarzeile 1 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment1"


ID_RGM_PROP16

Interne ID: ID_RGM_PROP16

Kommentar 2

Kommentarzeile 2 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment2"


ID_RGM_PROP21

Interne ID: ID_RGM_PROP21

Synchron schreiben

Wird bei Rezeptgruppe für alle Rezepte dieser Rezeptgruppe gesetzt und kann bei jedem Rezept überschrieben werden.

Aktiv : Beim Schreiben eines Rezepts werden im Bild des Rezeptgruppen Managers alle Kontrollelemente gesperrt, bis vom Treiber die Rückmeldung kommt, dass alle Werte des Rezepts erfolgreich geschrieben wurden oder der eingestellte Timeout [ms] verstrichen ist.

Interne ID: ID_RGM_PROP21

Timeout [ms]

Wird bei Rezeptgruppe für alle Rezepte dieser Rezeptgruppe gesetzt und kann bei jedem Rezept überschrieben werden.

Wenn Synchron schreiben aktiviert wurde, kann hier ein Timeout eingegeben werden. Die Kontrollelemente des Bildes Rezeptgruppen Manager werden spätestens nach dieser Zeit wieder freigegeben. Wird als Timeout der Wert 0 eingegeben, so berechnet zenon die Wartezeit wie folgt: 30000+(100*Anzahl der Datenpunkte)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WriteSync"

Inaktiv : Die Werte des Rezepts werden ohne Warten auf eine Rückmeldung geschrieben. Die Kontrollelemente sind sofort wieder bedienbar. Die Rückmeldung des Treibers erfolgt über das Statusbit WR_SUC, das auf 1 gesetzt wird, sobald Werte erfolgreich geschrieben wurden

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WriteSync"


ID_RGM_PROP22

Interne ID: ID_RGM_PROP22

Timeout [ms]

Wird bei Rezeptgruppe für alle Rezepte dieser Rezeptgruppe gesetzt und kann bei jedem Rezept überschrieben werden.

Wenn Synchron schreiben aktiviert wurde, kann hier ein Timeout eingegeben werden. Die Kontrollelemente des Bildes Rezeptgruppen Manager werden spätestens nach dieser Zeit wieder freigegeben. Wird als Timeout der Wert 0 eingegeben, so berechnet zenon die Wartezeit wie folgt: 30000+(100*Anzahl der Datenpunkte)

Interne ID: ID_RGM_PROP22

Synchron schreiben

Wird bei Rezeptgruppe für alle Rezepte dieser Rezeptgruppe gesetzt und kann bei jedem Rezept überschrieben werden.

Aktiv : Beim Schreiben eines Rezepts werden im Bild des Rezeptgruppen Managers alle Kontrollelemente gesperrt, bis vom Treiber die Rückmeldung kommt, dass alle Werte des Rezepts erfolgreich geschrieben wurden oder der eingestellte Timeout [ms] verstrichen ist.

Inaktiv : Die Werte des Rezepts werden ohne Warten auf eine Rückmeldung geschrieben. Die Kontrollelemente sind sofort wieder bedienbar. Die Rückmeldung des Treibers erfolgt über das Statusbit WR_SUC, das auf 1 gesetzt wird, sobald Werte erfolgreich geschrieben wurden

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WriteTimeout"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WriteTimeout"


ID_RGM_PROP23

Interne ID: ID_RGM_PROP23

Berechtigungsebene

Auswahl der Berechtigungseben aus Dropdownliste.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PWLevel"


ID_RGM_PROP26

Interne ID: ID_RGM_PROP26

Min

Steht nur zur Verfügung, wenn Eigenschaft Sollwertgrenzen von Variable übernehmen nicht aktiviert wurde.

Interne ID: ID_RGM_PROP26

Sollwertgrenzen von Variable übernehmen

Aktiv: Die Sollwertgrenzen werden dynamisch von der Variablen geholt und nicht fix in der Rezeptgruppe eingestellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"

Minimalwert der Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"


ID_RGM_PROP27

Interne ID: ID_RGM_PROP27

Max

Steht nur zur Verfügung, wenn Eigenschaft Sollwertgrenzen von Variable übernehmen nicht aktiviert wurde.

Interne ID: ID_RGM_PROP27

Sollwertgrenzen von Variable übernehmen

Aktiv: Die Sollwertgrenzen werden dynamisch von der Variablen geholt und nicht fix in der Rezeptgruppe eingestellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"

Maximalwert der Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"


ID_SAP_ADDITIONAL_GRP

Interne ID: ID_SAP_ADDITIONAL_GRP

Meldungen

Legen Sie in den folgenden Properties fest, welche Zusatzinformationen bei einer Störmeldung mitgesendet werden sollen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapAdditional"


ID_SAP_DEBUG_GRP

Interne ID: ID_SAP_DEBUG_GRP

Fehlersuche

Mit den folgenden Properties testen Sie die Verbindung zwischen zenon und dem SAP-System.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapDebug"


ID_SAP_FIELD_GRP

Interne ID: ID_SAP_FIELD_GRP

Strukturfeld

Einstellungen zur Konfiguration der Daten eines Strukturfelds für SAP ERP.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_SapStructField"


ID_SAP_FUNC_ACTIVITY_GRP

Interne ID: ID_SAP_FUNC_ACTIVITY_GRP

Aktivitätsüberwachung

Enthält Eigenschaften zur Aktivitätsüberwachung.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_SapFuncActivity"


ID_SAP_FUNC_ACTIVITY_VAR

Interne ID: ID_SAP_FUNC_ACTIVITY_VAR

Aktivität

Numerische Variable zur Aktivitätsüberwachung der SAP Funktion. Kann z.B. für Verriegelungen verwendet werden, um überlappende Aufrufe zu verhindern.

Mögliche Werte: 0, 1, 2

0 = inaktiv

1 = in Aufrufwarteschlange eingereiht

2 = Aufruf aktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ActivityVar"


ID_SAP_FUNC_ERROR_CODE_VAR

Interne ID: ID_SAP_FUNC_ERROR_CODE_VAR

Fehlercode

Numerische Variable für den Fehlercode des Funktionsaufrufs.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ErrorVar"


ID_SAP_FUNC_ERROR_GRP

Interne ID: ID_SAP_FUNC_ERROR_GRP

Fehlermeldungen

Enthält Eigenschaften zur Konfiguration von Fehlermeldungen bei SAP Funktionen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_SapFuncError"


ID_SAP_FUNC_ERROR_TEXT_VAR

Interne ID: ID_SAP_FUNC_ERROR_TEXT_VAR

Fehlertext

String-Variable für Kurzbeschreibung des letzten aufgetretenen Fehlers.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ErrorTextVar"


ID_SAP_FUNC_INFO

Interne ID: ID_SAP_FUNC_INFO

Info

Frei wählbarer Kurztext. Dient nur zur Information. Wird, soweit vorhanden, beim Anlegen einer SAP Funktion über den Wizard entsprechend der Schnittstellenbeschreibung im SAP System gesetzt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Info"


ID_SAP_FUNC_LABEL

Interne ID: ID_SAP_FUNC_LABEL

Funktionsname

Frei vergebbare Bezeichnung für die SAP Funktion.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Label"


ID_SAP_FUNC_LAST_ERROR_VAR

Interne ID: ID_SAP_FUNC_LAST_ERROR_VAR

Fehlerbeschreibung

String-Variable für ausführliche Be\-schreibung des letzten aufgetre\-te\-nen Fehlers.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LastErrorVar"


ID_SAP_FUNC_NAME

Interne ID: ID_SAP_FUNC_NAME

RFC-Funktionsbaustein

Name des aufgerufenen Funk\-tions\-bau\-steins im SAP System.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_SAP_FUNCTION_GRP

Interne ID: ID_SAP_FUNCTION_GRP

SAP Funktion

Enthält Eigenschaften für die grundlegende Konfiguration von SAP Funktionen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_SapFunctions"


ID_SAP_LOGON_GRP

Interne ID: ID_SAP_LOGON_GRP

SAP Logon

Legen Sie in den folgenden Properties Informationen über den Mandanten und Benutzer fest, die für die Verbindung benutzt werden sollen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapLogon"


ID_SAP_NOTIFICATION_GRP

Interne ID: ID_SAP_NOTIFICATION_GRP

Wartungsmeldung

Mit den folgenden Properties legen Sie fest, welche Zusatzinformationen bei Störmeldungen mitgesendet werden sollen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapNotification"


ID_SAP_PAR_TAB_INFO

Interne ID: ID_SAP_PAR_TAB_INFO

Info

Frei wählbarer Kurztext. Dient nur zur Information und wird, sofern vorhanden, beim Anlegen einer SAP Funktion über den Wizard entsprechend der Schnittstellenbeschreibung im SAP System gesetzt .

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Info"


ID_SAP_PAR_TAB_NAME

Interne ID: ID_SAP_PAR_TAB_NAME

Name im SAP System

Name des Parameters, der Tabelle oder des Strukturfeldes im SAP System.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_SAP_PAR_TAB_OPTIONAL

Interne ID: ID_SAP_PAR_TAB_OPTIONAL

Optional

Gibt an, ob der Parameter oder Tabelle optional ist. Optionale Parameter und Tabellen können beim Aufruf des Funktionsbausteins weggelassen werden.

Dient nur zur Information, und wird beim Anlegen einer SAP Funktion über den Wizard entsprechend der Schnittstellenbeschreibung im SAP System gesetzt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Optional"


ID_SAP_PAR_TAB_TYPE

Interne ID: ID_SAP_PAR_TAB_TYPE

Typ

Art des Parameters. Abhängig von Funktionstyp. Dient nur zur Information, und wird beim Anlegen einer SAP-Funktion über den Wizard entsprechend der Schnittstellenbeschreibung im SAP System gesetzt.

Import: der Wert des Parameters wird dem Funktions\-bau\-stein beim Aufruf über\-ge\-ben.

Export: der Wert des Para\-me\-ters wird vom Funk\-tionsaufruf zu\-rück\-gegeben.

Changing: sowohl Ein- als auch Rückgabeparameter.

Tabelle: Funktionstyp Tabelle. Kann nicht geändert werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Type"


ID_SAP_PAR_TAB_VARIABLE

Interne ID: ID_SAP_PAR_TAB_VARIABLE

Variable

Mit dem Parameter, der Tabelle oder dem Strukturfeld verknüpfte zenon Va\-riable. Bei Tabellen in der Regel eine Array-Variable.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"


ID_SAP_PARAMETER_GRP

Interne ID: ID_SAP_PARAMETER_GRP

Parameter

Enthält Eigenschaften zur Konfiguration der Parameter für SAP Funktionen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_SapParameter"


ID_SAP_PROP_CLIENT

Interne ID: ID_SAP_PROP_CLIENT

Mandant

Nummer oder Name des Mandanten auf dem SAP-System, mit dem die Verbindung hergestellt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapClient"


ID_SAP_PROP_END_TIME

Interne ID: ID_SAP_PROP_END_TIME

Bis

Zeitpunkt, bis zu dem der Zeitplan ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EndTime"


ID_SAP_PROP_EQUIPMENT

Interne ID: ID_SAP_PROP_EQUIPMENT

Techn. Platz/Equipment

Gibt an, ob das SAP-System die übergebene Betriebsmittelkennung der Variable als Nummer eines Technischen Platzes, oder eines Equipments behandelt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapEquipment"


ID_SAP_PROP_EVERY_DAY

Interne ID: ID_SAP_PROP_EVERY_DAY

Jeden Tag

Der Zeitplan wird jeden Tag ausgeführt. Ist diese Eigenschaft aktiv, sind die Eigenschaften der einzelnen Tage inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EveryDay"


ID_SAP_PROP_FRIDAY

Interne ID: ID_SAP_PROP_FRIDAY

Freitag

Der Zeitplan wird jeden Freitag ausgeführt. Nur aktiv, wenn „Jeden Tag" nicht aktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Friday"


ID_SAP_PROP_INTERVAL

Interne ID: ID_SAP_PROP_INTERVAL

Alle

Intervall, in dem der Zeitplan ausgeführt wird. Ist keine Endzeit angegeben, wird der Zeitplan bis jeweils Mitternacht der ausgewählten Tage ausgeführt

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Interval"


ID_SAP_PROP_LANGUAGE

Interne ID: ID_SAP_PROP_LANGUAGE

Sprache

Benutzersprache. Von der eingestellten Sprache ist die Behandlung von Umlauten, Sonderzeichen, usw. durch das SAP-System abhängig.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapLanguage"


ID_SAP_PROP_MESSBELEG

Interne ID: ID_SAP_PROP_MESSBELEG

Messbeleg erzeugen

Aktiv: Erzeugen Sie einen Messbeleg, der zum SAP-System gesendet wird.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapMeasDoc"


ID_SAP_PROP_MONDAY

Interne ID: ID_SAP_PROP_MONDAY

Montag

Der Zeitplan wird jeden Montag ausgeführt. Nur aktiv, wenn „Jeden Tag" nicht aktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Monday"


ID_SAP_PROP_NOTIFICATION_TYPE

Interne ID: ID_SAP_PROP_NOTIFICATION_TYPE

Meldungsart

Eine der im SAP-System voreingestellten Meldungsarten. Die Reaktion des SAP-Systems auf die Störmeldung richtet sich nach der Meldungsart.

Wird keine Meldungsart angegeben, kann das SAP-System keine Störmeldung anlegen, und gibt eine Fehlermeldung zurück.

Mehr im Online-Hanbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapNotificationType"


ID_SAP_PROP_PASSWORD

Interne ID: ID_SAP_PROP_PASSWORD

Passwort

Passwort des SAP System Benutzers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapPassword"


ID_SAP_PROP_PLANT

Interne ID: ID_SAP_PROP_PLANT

Werk

Instandhaltungswerk in Störmeldungen. Wird kein Instandhaltungswerk eingetragen, verwendet das SAP-System als Default das Werk des Anlagenteils (Technischer Platz, Equipment), für den die Störmeldung erstellt wird.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapPlant"


ID_SAP_PROP_REPORTER

Interne ID: ID_SAP_PROP_REPORTER

Melder

Der Melder wird bei Störmeldungen im SAP-System zusätzlich eingetragen.

Wird kein Melder angegeben, trägt das SAP-System als Default den am System angemeldeten Benutzer ein.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapReporter"


ID_SAP_PROP_ROUTER

Interne ID: ID_SAP_PROP_ROUTER

Routerstring

IP-Adresse oder Name des SAP-Routers, über den die Verbindung hergestellt wird. Falls die Verbindung über mehrere SAP-Router („Hops") läuft, muss der dem Leitsystem nächstgelegene SAP-Router angegeben werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapRouter"


ID_SAP_PROP_SATURDAY

Interne ID: ID_SAP_PROP_SATURDAY

Samstag

Der Zeitplan wird jeden Samstag ausgeführt. Nur aktiv, wenn „Jeden Tag" nicht aktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Saturday"


ID_SAP_PROP_SERVER

Interne ID: ID_SAP_PROP_SERVER

Anwendungsserver

IP-Adresse oder Name des SAP-Servers, mit dem die Verbindung hergestellt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapServer"


ID_SAP_PROP_START_TIME

Interne ID: ID_SAP_PROP_START_TIME

Ab/Um

Startzeit des Zeitplans. Werden für Intervall und Endzeit jeweils 00.00.00 angegeben, wird der Zeitplan an den ausgewählten Tagen nur einmalig um diese Uhrzeit ausgeführt

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StartTime"


ID_SAP_PROP_SUNDAY

Interne ID: ID_SAP_PROP_SUNDAY

Sonntag

Der Zeitplan wird jeden Sonntag ausgeführt. Nur aktiv, wenn „Jeden Tag" nicht aktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Sunday"


ID_SAP_PROP_SYSTEM

Interne ID: ID_SAP_PROP_SYSTEM

Systemnummer

Systemnummer des SAP-Systems, mit dem die Verbindung hergestellt wird (auf einem Anwendungsserver können mehrere SAP-Systeme mit unterschiedlichen System ID's laufen)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapSystemId"


ID_SAP_PROP_TEST

Interne ID: ID_SAP_PROP_TEST

Verbindung testen

Versucht, mit den angegebenen Einstellungen eine Verbindung mit dem SAP-System herzustellen. Kann keine Verbindung hergestellt werden, erfolgt eine detaillierte Fehlermeldung in Form einer Messagebox.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapTest"


ID_SAP_PROP_THURSDAY

Interne ID: ID_SAP_PROP_THURSDAY

Donnerstag

Der Zeitplan wird jeden Donnerstag ausgeführt. Nur aktiv, wenn „Jeden Tag" nicht aktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Thursday"


ID_SAP_PROP_TRACE

Interne ID: ID_SAP_PROP_TRACE

Protokollierung

Steuert das Mitprotokollieren der Kommunikation zum SAP-System.

aktiv: Die Kommunikation zwischen zenon und dem SAP-System wird protokolliert.

Default: inaktiv

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapTrace"


ID_SAP_PROP_TUESDAY

Interne ID: ID_SAP_PROP_TUESDAY

Dienstag

Der Zeitplan wird jeden Dienstag ausgeführt. Nur aktiv, wenn „Jeden Tag" nicht aktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Tuesday"


ID_SAP_PROP_USER

Interne ID: ID_SAP_PROP_USER

Benutzer

Anmeldename des SAP System Benutzers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapUser"


ID_SAP_PROP_VAR_NAME

Interne ID: ID_SAP_PROP_VAR_NAME

Name

Name der für den ausgewählten Zeitplan selektierten Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapVarName"


ID_SAP_PROP_VAR_TAG

Interne ID: ID_SAP_PROP_VAR_TAG

Kennung

Kennung der für den ausgewählten Zeitplan selektierten Variablen.

Mehr im Onine-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapVarTag"


ID_SAP_PROP_VAR_TYPE

Interne ID: ID_SAP_PROP_VAR_TYPE

Typ

Typ der für den ausgewählten Zeitplan selektierten Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapVarType"


ID_SAP_PROP_VAR_UNIT

Interne ID: ID_SAP_PROP_VAR_UNIT

Maßeinheit

Einheit der für den ausgewählten Zeitplan selektierten Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapVarUnit"


ID_SAP_PROP_WEDNESDAY

Interne ID: ID_SAP_PROP_WEDNESDAY

Mittwoch

Der Zeitplan wird jeden Mittwoch ausgeführt. Nur aktiv, wenn „Jeden Tag" nicht aktiv ist

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Wednesday"


ID_SAP_SCHEDULE_DATE_GRP

Interne ID: ID_SAP_SCHEDULE_DATE_GRP

Wochentag

Mit den folgenden Properties legen Sie fest, an welchem Wochentag bzw. an welchen Wochentagen der Zeitplan ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScheduleDate"


ID_SAP_SCHEDULE_MEAS_DOC_GRP

Interne ID: ID_SAP_SCHEDULE_MEAS_DOC_GRP

Messbeleg

Mit dem folgenden Property legen Sie fest, welcher Melder bei Störmeldungen angegeben werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScheduleMeasDoc"


ID_SAP_SCHEDULE_TIME_GRP

Interne ID: ID_SAP_SCHEDULE_TIME_GRP

Uhrzeit

Mit den folgenden Properties legen Sie fest, zu welcher Uhrzeit der Zeitplan ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ScheduleTime"


ID_SAP_SYSTEM_GRP

Interne ID: ID_SAP_SYSTEM_GRP

SAP ERP System

Geben Sie in den folgenden Properties Namen oder Nummern des SAP-Servers, -Routers und -Systems an, die für den Verbindungsaufbau verwendet werden sollen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SapSystem"


ID_SAP_TAB_ROWCOUNT_VAR

Interne ID: ID_SAP_TAB_ROWCOUNT_VAR

Zeilenanzahl

Numerische Variable für die Anzahl der Zeilen, die aus der mit der Tabelle ver\-knüpf\-ten Variable über\-nom\-men wer\-den sollen, beziehungsweise Anzahl der beim Aufruf der SAP Funktion gelesenen Zeilen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RowCountVar"


ID_SAP_TABLE_GRP

Interne ID: ID_SAP_TABLE_GRP

Tabelle

Enthält Eigenschaften für den Funktionstyp Tabelle.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_SapTable"


ID_SATBEF_PROP1

Interne ID: ID_SATBEF_PROP1

Modus

Auswahl des Verwendungszwecks

Vorgabe: Befehlselement dient zur Befehlsgabe

Funktionsaufruf: Befehlselement dient zur Funktionsausführung.
Diese Option existiert nur aus Kompatibilitätgründen zu älteren Versionen und sollte nicht mehr verwendet werden.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Mode"


ID_SATBEF_PROP2

Interne ID: ID_SATBEF_PROP2

Bild

Auswahl des Bildes, das bei Aktivierung des Elements in der Runtime geöffnet werden soll.

Es werden nur Bilder vom Typ "Befehl" angeboten.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PictSwitch"


ID_SATBEF_PROP3

Interne ID: ID_SATBEF_PROP3

Parameter

Öffnet den Parameterdialog des Befehlselements.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PictFilter"


ID_SATBEF_PROP4

Interne ID: ID_SATBEF_PROP4

Funktion

Auswahl der auszuführenden Funktion bei Modus: Funktion .
Wird nicht mehr verwendet. Ist nur aus Kompatibilitätsgründen zu älteren Versionen enthalten.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


ID_SATBEF_PROP5

Interne ID: ID_SATBEF_PROP5

Aktivierungsgruppe

Auswahl der Aktivierungsgruppe.

Nur notwendig in Verbindung mit Vorwahlfunktion.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ActivationGroup"


ID_SATBEF_PROP6

Interne ID: ID_SATBEF_PROP6

immer anwählbar

Aktiv: Befehlsanwahl direkt per Mausklick (links)

Inaktiv: Befehlsanwahl nur nach vorhergehender Anwahlfunktion möglich (Funktionen ->Anwendung ->Befehlsaktivierung)
Nach Befehlsaktivierung in der Runtime wird ein Laufrahmen bei allen derart projektierten Befehlselementen angezeigt.

Erzeugen einer neuen Befehlsaktion mittels rechtem Mausklick -> Aktion neu.

Achtung: in der Dialogansicht nur im linken Fenster möglich.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlwaysSelectable"


ID_SATBEF_PROP_GRP1

Interne ID: ID_SATBEF_PROP_GRP1

Aktion

Eigenschaften für Befehlsaktionen

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Action"


ID_SAVE_ALWAYS_BIN_AML

Interne ID: ID_SAVE_ALWAYS_BIN_AML

Ringpuffer bei Wertänderung speichern

Nur verfügbar bei aktivierter Eigenschaft Alarmmeldeliste aktiv.
Aktiv: Jede Änderung der Daten der Alarmmeldeliste bewirkt auch das Speichern der Daten (alarm.bin).
Hinweis: Damit wird bei jeder Speicherung der gesamte Ringpuffer gespeichert. Das kann - vor allem bei Flash Disks - zu erheblicher Systembelastung führen.
Inaktiv: Daten der Alarmmeldeliste (alarm.bin) werden nur beim Beenden der Runtime oder beim Ausführen der Funktion AML- und CEL-Ringbuffer speichern gespeichert. Empfiehlt sich vor allem bei niedriger Performance. Historische Daten (*.aml) können unabhängig von dieser Einstellung bei jeder Wertänderung gespeichert werden.

Interne ID: ID_SAVE_ALWAYS_BIN_AML

Alarmmeldeliste aktiv

Aktiv: Die Alarmverwaltung ist in der Runtime aktiv. Alarme werden aufgezeichnet und die Alarmmeldeliste ist verfügbar.
Inaktiv: Alarme werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SaveAmlStack"

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SaveAmlStack"


ID_SAVE_ALWAYS_BIN_CEL

Interne ID: ID_SAVE_ALWAYS_BIN_CEL

Ringpuffer bei Wertänderung speichern

Nur verfügbar bei aktivierter Eigenschaft CEL aktiv.

Interne ID: ID_SAVE_ALWAYS_BIN_CEL

CEL aktiv

Aktiv: Die Chronologische Ereignisliste (CEL) ist in der Runtime aktiv. Ereignisse werden aufgezeichnet und die CEL ist verfügbar.
Inaktiv: Keine Ereignisse werden aufgezeichnet.
Default: aktiv

Hinweis: Änderungen werden erst nach einem Neustart der Runtime wirksam.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SaveCelStack"

Aktiv: Jede Änderung der Daten der Chronologischen Ereignisliste (CEL) bewirkt auch das Speichern der Daten (cel.bin).
Hinweis: Damit wird bei jeder Speicherung der gesamte Ringpuffer gespeichert. Das kann - vor allem bei Flash Disks - zu erheblicher Systembelastung führen.
Inaktiv: Daten der CEL (cel.bin) werden beim Beenden der Runtime oder beim Ausführen der Funktion AML- und CEL-Ringspeicher speichern gespeichert. Empfiehlt sich vor allem bei niedriger Performance. Historische Daten (*.cel) können unabhängig von dieser Einstellung bei jeder Wertänderung gespeichert werden.

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SaveCelStack"


ID_SCRIPT_DEL

Interne ID: ID_SCRIPT_DEL

{Skript löschen}

Das Skript wird gelöscht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeleteScript"


ID_SCRIPT_GRP0

Interne ID: ID_SCRIPT_GRP0

Allgemein

Allgemeine Einstellungen für das Skript.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_SCRIPT_IMEX_NAME

Interne ID: ID_SCRIPT_IMEX_NAME

Name

Eindeutiger Name des Rezepts.
Default: Recipe_x (wobei x eine fortlaufende Zahl ist).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeName"


ID_SCRIPT_NAME

Interne ID: ID_SCRIPT_NAME

Name

Eindeutiger Name des Skripts.
Default: Script_x (wobei x eine fortlaufende Zahl ist).
Der Name kann frei gewählt werden, aber es gibt vordefinierte Namen für Skripte, die automatisch ausgeführt werden sollen. Diese Namen können ausgewählt oder eingegeben werden:
AUTOSTART: Das Skript wird beim Runtime-Start (Einzelplatz bzw. Server) automatisch nach dem Aufschalten des Startbildes ausgeführt (am Einzelplatz bzw. Server), wenn das Projekt das Runtime-Startprojekt ist.
AUTOEND: Das Skript wird beim Beenden des Runtime-Betriebes (Einzelplatz bzw. Server) automatisch ausgeführt (am Einzelplatz bzw. Server), wenn das Projekt das Runtime-Startprojekt ist.
Achtung: VBA-Makros, die in "AUTO_END" ausgeführt werden sollen, müssen über Project.Inactive aufgerufen werden. Zyklische Archive dürfen nicht im Skript AUTOEND angegeben werden.
AUTOSTART_CLIENT: Das Skript wird beim Runtime-Start des Clients automatisch vor dem Aufschalten des Startbildes am Client ausgeführt, wenn das Projekt das Runtime-Startprojekt ist.
AUTOEND_CLIENT: Das Skript wird beim Beenden des Runtime-Betriebes des Clients automatisch am Client ausgeführt., wenn das Projekt das Runtime-Startprojekt ist.
AUTOSTART_SRVPRJ: Das Skript wird beim Runtime-Start auf dem Rechner, der Server für das Projekt ist, automatisch vor dem Aufschalten des Startbildes ausgeführt, wenn das Projekt nicht das Runtime-Startprojekt ist.
AUTOEND_SRVPRJ: Das Skript wird beim Beenden des Runtime-Betriebes auf dem Rechner, der Server für das Projekt ist, automatisch ausgeführt, wenn das Projekt nicht das Runtime-Startprojekt ist.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Hinweis Mehrplatzfähige Projekte: Beim Ändern von Skriptnamen werden die Parameter der verbundenen Funktionen nach einer Kontrollabfrage zum Änderungen Ermöglichen automatisch angepasst. Nach erfolgreicher Änderung wird das Skript geändert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_SCRIPT_NEW

Interne ID: ID_SCRIPT_NEW

{Skript neu}

Ein neues Skript mit dem Default-Namen Script_x (wobei x eine fortlaufende Zahl ist) wird erstellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NewScript"


ID_SCRIPT_SYNCWRITE

Interne ID: ID_SCRIPT_SYNCWRITE

Synchron schreiben

Aktiv: Eine Funktionsausführung mit diesem Rezept wird erst beendet, wenn eine positive Rückmeldung der Schreibaktion kommt oder die definierte Wartezeit verstrichen ist.
Damit kann in Skripten sichergestellt werden, dass die nachfolgende Funktion erst aufgeführt wird, wenn diese tatsächlich abgeschlossen ist.
Die Rückmeldung kann auch über das Statusbit "WR-SUC“ abgefragt werden.
Inaktiv: Es wird keine Schreibbestätigung abgewartet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SyncWrite"


ID_SCRIPT_SYNCWRITE_TIMEOUT

Interne ID: ID_SCRIPT_SYNCWRITE_TIMEOUT

Timeout [ms]

Wenn "Synchrones Schreiben“ aktiviert wurde, kann hier ein Timeout eingegeben werden.
Wird hier 0 eingegeben, so berechnet das Leitsystem die Wartezeit wie folgt:
3000+(100*Anzahl der Datenpunkte)
Minimum: 0.
Maximum: 4294967295.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SyncWriteTimeout"


ID_SEA_PROP_ABBRUCH

Interne ID: ID_SEA_PROP_ABBRUCH

Abbruch

Zustand der Abbruchvariablen, bei dem die Schaltfolge abgebrochen werden soll.

0 ... AUS

1 ... EIN

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Cancel"


ID_SEA_PROP_ABBRUCH_PV

Interne ID: ID_SEA_PROP_ABBRUCH_PV

Abbruch-Variable

Über die ausgewählte Variable kann die laufende Schaltfolge abgebrochen werden.

Prozess- oder Merkervariable (empfohlen: Interntreiber BOOL).

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CancelVariable"


ID_SEA_PROP_DIREKT

Interne ID: ID_SEA_PROP_DIREKT

Direkt ausführbar

Die Schaltfolge wird durch eine Funktion (Anwendung->Schaltfolge Automatiklauf) gestartet.

Sie läuft, wenn keine Fehler auftreten automatisch ab.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DirectExecute"


ID_SEA_PROP_GRP0

Interne ID: ID_SEA_PROP_GRP0

Allgemein

Parameter der Schaltfolge

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_SEA_PROP_LERNEN

Interne ID: ID_SEA_PROP_LERNEN

Lernen erlaubt

Die Schaltfolge kann in der Runtime Schalthandlungen aufzeichnen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LearningEnabled"


ID_SEA_PROP_NAME

Interne ID: ID_SEA_PROP_NAME

Bezeichnung

Eindeutiger Name der Schaltfolge

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_SEA_PROP_VAR

Interne ID: ID_SEA_PROP_VAR

Variable

Variable (obligat), auf die die Schaltfolgenzustände abgebildet werden.
Merkervariable (empfohlen: Interntreiber DWORD).

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"


ID_SIZEINBYTE

Interne ID: ID_SIZEINBYTE

Größe in Byte

Anzeige der Gesamtgrösse der Strukturvariable in Byte.
Diese Eigenschaft dient nur der Information und kann nicht verändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SizeInByte"


ID_SPRECON870_COUNTER_NODE

Interne ID: ID_SPRECON870_COUNTER_NODE

Counters

Eigenschaften für Counter group.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_Counters"


ID_SPRECON870_COUNTERACTIVE

Interne ID: ID_SPRECON870_COUNTERACTIVE

Counter value handling

Nur verfügbar, wenn in der Treiberkonfiguration eine Gruppe angelegt wurde.

Aktiviert: Die Zählerverarbeitung wird vom Treiber genutzt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_CounterActive"


ID_SPRECON870_COUNTERGROUP

Interne ID: ID_SPRECON870_COUNTERGROUP

Counter group

Nur verfügbar, wenn Eigenschaft Counter value handling aktiviert wurde.

Interne ID: ID_SPRECON870_COUNTERGROUP

Counter value handling

Nur verfügbar, wenn in der Treiberkonfiguration eine Gruppe angelegt wurde.

Aktiviert: Die Zählerverarbeitung wird vom Treiber genutzt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_CounterGroupID"

Name zur Identifikation der Counter group, wie im Treiber konfiguriert.

Über die Zuordnung der Variable zu einer Zählergruppe wird das Verhalten der Variable definiert. Die Zählergruppe stellt eine Art Reaktionsmatrix dar, die die Zählwertverarbeitung (z.B. Umwandlung von Absolutwert auf Relativwert) regelt.

Default: < No group >

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_CounterGroupID"


ID_SPRECON870_MAXCOUNTDIFF

Interne ID: ID_SPRECON870_MAXCOUNTDIFF

Maximum counter difference

Nur verfügbar, wenn Eigenschaft Counter value handling aktiviert wurde.

Interne ID: ID_SPRECON870_MAXCOUNTDIFF

Counter value handling

Nur verfügbar, wenn in der Treiberkonfiguration eine Gruppe angelegt wurde.

Aktiviert: Die Zählerverarbeitung wird vom Treiber genutzt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_MaxCounterDifference"

Definiert den maximalen Unterschied zwischen zwei übertragenen Zählwerten. Die maximale Änderung bezieht sich auf den normierten Zählerwert (Werteberechnung). Bei Überschreitung der maximalen Zählwertdifferenz wird die Einstellung der Eigenschaft Max. counter diff. exceeded ausgeführt.

Interne ID: ID_SPRECON870_MAXCOUNTDIFF

Max. counter diff. exceeded

Nur verfügbar, wenn Eigenschaft Counter value handling aktiviert wurde.

Behandlung von Zählwerten (Relativ/Absolut), bei denen die Überwachung auf Maximum counter difference anspricht.

Auswahl aus Dropdownliste:

- Disabled

- Set INVALID state: Status wird gesetzt und dadurch - sofern konfiguriert - die Replacement value handling aktiviert. Diese Behandlung gilt auch für den Zählerüberlauf von Absolutwerten. Wenn der Fehlerzustand erreicht wird, wird der Status INVALID gesetzt und der aktuelle Zählwert verworfen. Der zuletzt Empfangene Zählwert wird als ungültig makiert. Berechnungen die einen vorherigen Zählwert benötigen können erst nach zwei Empfangenen Zählwerten wieder durchgeführt werden. Der Status INVALID wird zurückgesetzt, sobald ein neuer Zählwert mit Differenz kleiner der Einstellungen für die Eigenschaft Replacement value handling empfangen wird.

Interne ID: ID_SPRECON870_MAXCOUNTDIFF

Replacement value handling

Eigenschaften für Behandlung von Ersatzwerten. Eigenschaften werden verwendet, wenn in Gruppe die Eigenschaft auf steht. Ersatzwertbehandlung gilt für alle Variablen des Treibers.

Achtung: Wurde die Ersatzwertbehandlung im Treiber aktiviert, darf in zenon keine Ersatzwertstrategie für diese Variable projektiert werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_MaxCounterDifference"

Default: Disabled

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_MaxCounterDifference"

Minimum: 0 - deaktiviert, maximalen Änderung wird nicht überwacht

Maximum: 65535

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_MaxCounterDifference"


ID_SPRECON870_ONMAXCOUNTDIFF

Interne ID: ID_SPRECON870_ONMAXCOUNTDIFF

Max. counter diff. exceeded

Nur verfügbar, wenn Eigenschaft Counter value handling aktiviert wurde.

Interne ID: ID_SPRECON870_ONMAXCOUNTDIFF

Counter value handling

Nur verfügbar, wenn in der Treiberkonfiguration eine Gruppe angelegt wurde.

Aktiviert: Die Zählerverarbeitung wird vom Treiber genutzt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_OnMaxCounterDifference"

Behandlung von Zählwerten (Relativ/Absolut), bei denen die Überwachung auf Maximum counter difference anspricht.

Interne ID: ID_SPRECON870_ONMAXCOUNTDIFF

Maximum counter difference

Nur verfügbar, wenn Eigenschaft Counter value handling aktiviert wurde.

Definiert den maximalen Unterschied zwischen zwei übertragenen Zählwerten. Die maximale Änderung bezieht sich auf den normierten Zählerwert (Werteberechnung). Bei Überschreitung der maximalen Zählwertdifferenz wird die Einstellung der Eigenschaft Max. counter diff. exceeded ausgeführt.

Minimum: 0 - deaktiviert, maximalen Änderung wird nicht überwacht

Maximum: 65535

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_OnMaxCounterDifference"

Auswahl aus Dropdownliste:

- Disabled

- Set INVALID state: Status wird gesetzt und dadurch - sofern konfiguriert - die Replacement value handling aktiviert. Diese Behandlung gilt auch für den Zählerüberlauf von Absolutwerten. Wenn der Fehlerzustand erreicht wird, wird der Status INVALID gesetzt und der aktuelle Zählwert verworfen. Der zuletzt Empfangene Zählwert wird als ungültig makiert. Berechnungen die einen vorherigen Zählwert benötigen können erst nach zwei Empfangenen Zählwerten wieder durchgeführt werden. Der Status INVALID wird zurückgesetzt, sobald ein neuer Zählwert mit Differenz kleiner der Einstellungen für die Eigenschaft Replacement value handling empfangen wird.

Interne ID: ID_SPRECON870_ONMAXCOUNTDIFF

Replacement value handling

Eigenschaften für Behandlung von Ersatzwerten. Eigenschaften werden verwendet, wenn in Gruppe die Eigenschaft auf steht. Ersatzwertbehandlung gilt für alle Variablen des Treibers.

Achtung: Wurde die Ersatzwertbehandlung im Treiber aktiviert, darf in zenon keine Ersatzwertstrategie für diese Variable projektiert werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_OnMaxCounterDifference"

Default: Disabled

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_OnMaxCounterDifference"


ID_SPRECON870_ONNOUPDATE

Interne ID: ID_SPRECON870_ONNOUPDATE

Not updated in time

Nur verfügbar, wenn Eigenschaft Counter value handling aktiviert wurde.

Interne ID: ID_SPRECON870_ONNOUPDATE

Counter value handling

Nur verfügbar, wenn in der Treiberkonfiguration eine Gruppe angelegt wurde.

Aktiviert: Die Zählerverarbeitung wird vom Treiber genutzt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_OnNoUpdate"

Definiert das Verhalten bei Zählwerten die nicht innerhalb des Zeitfensters aktualisiert werden. bzw. die Ersatzwertbehandlung (s.u.) wird aktiviert. Auswahl aus Dropdownliste:
- Disabled: Einstellungen aus Eigenschaften Replacement value handling werden verwendet.

Interne ID: ID_SPRECON870_ONNOUPDATE

Replacement value handling

Eigenschaften für Behandlung von Ersatzwerten. Eigenschaften werden verwendet, wenn in Gruppe die Eigenschaft auf steht. Ersatzwertbehandlung gilt für alle Variablen des Treibers.

Achtung: Wurde die Ersatzwertbehandlung im Treiber aktiviert, darf in zenon keine Ersatzwertstrategie für diese Variable projektiert werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_OnNoUpdate"

- Set INVALID state: Status INVALID wird gesetzt.

Default: Disabled

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_OnNoUpdate"


ID_SPRECON870_SUBSTITUTE_NODE

Interne ID: ID_SPRECON870_SUBSTITUTE_NODE

Replacement value handling

Eigenschaften für Behandlung von Ersatzwerten. Eigenschaften werden verwendet, wenn in Gruppe die Eigenschaft auf steht. Ersatzwertbehandlung gilt für alle Variablen des Treibers.

Achtung: Wurde die Ersatzwertbehandlung im Treiber aktiviert, darf in zenon keine Ersatzwertstrategie für diese Variable projektiert werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementHandling"


ID_SPRECON870_SUBSTVALUETYPE

Interne ID: ID_SPRECON870_SUBSTVALUETYPE

Replacement value handling

Auswahl für Ersatzwertbehandlung, wenn die Variable den Status INVALID oder NT_870 hat. Auswahl aus Dropdownliste:

- Disabled: Keine Ersatzwertbehandlung.

- Last valid value: Schaltet um auf letzten ungestörten Wert. Dazu muss von diesem Wert ein Prozessabbild gespeichert worden sein. Wenn es keinen letzten ungestörten Wert gibt, wird der zur Verfügung stehende Wert verwendet (z.B. 0 + INVALID).

- Use replacement value: Variable wird mit dem Wert der Eigenschaft Replacement value beschrieben.

Interne ID: ID_SPRECON870_SUBSTVALUETYPE

Replacement value

Wert mit dem die Variable beschrieben wird, wenn für die Eigenschaft Replacement value handling Use replacement value gewählt wurde.

Minimum: 4294967295

Maximum: 0

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementType"

- Use replacement variable: Die Variable wird sowohl mit dem Wert als auch dem Status der Variable aus der Eigenschaft Replacement variable beschrieben.
Ausnahme: Wenn die Ersatzwertvariable selbst den Status INVALID noch den Status NT_870 aufweist, wird nicht auf diese Variable umgeschaltet sondern die eigene Variable mit Wert und Status beibehalten.
Spezialfall Status GI: Da während einer Generalabfrage der Ersatzwert noch nicht vorhanden sein muss, kann eine Variable kurzzeitig auf INVALID geht bis der Ersatzwert empfangen wurde.

Interne ID: ID_SPRECON870_SUBSTVALUETYPE

Replacement variable

Variable, deren Wert und Status übernommen wird, wenn für die Eigenschaft Replacement value handling Use replacement varianle gewählt wurde. Jede Wertänderung der Ersatzwertvariable wird auf die gestörte Variable abgebildet. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Achtung: Als Variable darf nur eine Variable desselben Treibers ausgewählt werden. Wird im Dialog eine Variable eines anderen Treibers ausgewählt, wird zwar der Dialog geschlossen die Einstellung aber nicht übernommen.

Default: leer

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementType"

Alle Einstellungen, ausgenommen Disabled setzen das Statusbit ALT_VAL. Sobald der Grund für die Ersatzwertbehandlung ( INVALID oder NT_870 ) wegfällt, übernimmt die Variable wieder den Prozesswert und das Statusbit ALT_VAL wird zurückgesetzt.

Default: Disabled

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementType"


ID_SPRECON870_SUBSTVALUEVAL

Interne ID: ID_SPRECON870_SUBSTVALUEVAL

Replacement value

Wert mit dem die Variable beschrieben wird, wenn für die Eigenschaft Replacement value handling Use replacement value gewählt wurde.

Interne ID: ID_SPRECON870_SUBSTVALUEVAL

Replacement value handling

Auswahl für Ersatzwertbehandlung, wenn die Variable den Status INVALID oder NT_870 hat. Auswahl aus Dropdownliste:

- Disabled: Keine Ersatzwertbehandlung.

- Last valid value: Schaltet um auf letzten ungestörten Wert. Dazu muss von diesem Wert ein Prozessabbild gespeichert worden sein. Wenn es keinen letzten ungestörten Wert gibt, wird der zur Verfügung stehende Wert verwendet (z.B. 0 + INVALID).

- Use replacement value: Variable wird mit dem Wert der Eigenschaft Replacement value beschrieben.

- Use replacement variable: Die Variable wird sowohl mit dem Wert als auch dem Status der Variable aus der Eigenschaft Replacement variable beschrieben.
Ausnahme: Wenn die Ersatzwertvariable selbst den Status INVALID noch den Status NT_870 aufweist, wird nicht auf diese Variable umgeschaltet sondern die eigene Variable mit Wert und Status beibehalten.
Spezialfall Status GI: Da während einer Generalabfrage der Ersatzwert noch nicht vorhanden sein muss, kann eine Variable kurzzeitig auf INVALID geht bis der Ersatzwert empfangen wurde.

Interne ID: ID_SPRECON870_SUBSTVALUEVAL

Replacement variable

Variable, deren Wert und Status übernommen wird, wenn für die Eigenschaft Replacement value handling Use replacement varianle gewählt wurde. Jede Wertänderung der Ersatzwertvariable wird auf die gestörte Variable abgebildet. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Achtung: Als Variable darf nur eine Variable desselben Treibers ausgewählt werden. Wird im Dialog eine Variable eines anderen Treibers ausgewählt, wird zwar der Dialog geschlossen die Einstellung aber nicht übernommen.

Default: leer

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementValue"

Alle Einstellungen, ausgenommen Disabled setzen das Statusbit ALT_VAL. Sobald der Grund für die Ersatzwertbehandlung ( INVALID oder NT_870 ) wegfällt, übernimmt die Variable wieder den Prozesswert und das Statusbit ALT_VAL wird zurückgesetzt.

Default: Disabled

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementValue"

Minimum: 4294967295

Maximum: 0

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementValue"


ID_SPRECON870_SUBSTVALUEVAR

Interne ID: ID_SPRECON870_SUBSTVALUEVAR

Replacement variable

Variable, deren Wert und Status übernommen wird, wenn für die Eigenschaft Replacement value handling Use replacement varianle gewählt wurde. Jede Wertänderung der Ersatzwertvariable wird auf die gestörte Variable abgebildet. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Interne ID: ID_SPRECON870_SUBSTVALUEVAR

Replacement value handling

Auswahl für Ersatzwertbehandlung, wenn die Variable den Status INVALID oder NT_870 hat. Auswahl aus Dropdownliste:

- Disabled: Keine Ersatzwertbehandlung.

- Last valid value: Schaltet um auf letzten ungestörten Wert. Dazu muss von diesem Wert ein Prozessabbild gespeichert worden sein. Wenn es keinen letzten ungestörten Wert gibt, wird der zur Verfügung stehende Wert verwendet (z.B. 0 + INVALID).

- Use replacement value: Variable wird mit dem Wert der Eigenschaft Replacement value beschrieben.

Interne ID: ID_SPRECON870_SUBSTVALUEVAR

Replacement value

Wert mit dem die Variable beschrieben wird, wenn für die Eigenschaft Replacement value handling Use replacement value gewählt wurde.

Minimum: 4294967295

Maximum: 0

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementVariable"

- Use replacement variable: Die Variable wird sowohl mit dem Wert als auch dem Status der Variable aus der Eigenschaft Replacement variable beschrieben.
Ausnahme: Wenn die Ersatzwertvariable selbst den Status INVALID noch den Status NT_870 aufweist, wird nicht auf diese Variable umgeschaltet sondern die eigene Variable mit Wert und Status beibehalten.
Spezialfall Status GI: Da während einer Generalabfrage der Ersatzwert noch nicht vorhanden sein muss, kann eine Variable kurzzeitig auf INVALID geht bis der Ersatzwert empfangen wurde.

Alle Einstellungen, ausgenommen Disabled setzen das Statusbit ALT_VAL. Sobald der Grund für die Ersatzwertbehandlung ( INVALID oder NT_870 ) wegfällt, übernimmt die Variable wieder den Prozesswert und das Statusbit ALT_VAL wird zurückgesetzt.

Default: Disabled

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementVariable"

Achtung: Als Variable darf nur eine Variable desselben Treibers ausgewählt werden. Wird im Dialog eine Variable eines anderen Treibers ausgewählt, wird zwar der Dialog geschlossen die Einstellung aber nicht übernommen.

Default: leer

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SPRECON870_ReplacementVariable"


ID_STARTATNEWOFFSET

Interne ID: ID_STARTATNEWOFFSET

Jeder Datentyp startet mit neuem Offset

Nur verfügbar, wenn automatische Adressierung aktiv ist:
Aktiv: Jeder Datentyp der Strukturvariable startet an einem neuen Offset.
Inaktiv: Datentypen der Strukturvariable können auch im selben Offset sein.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsStartAtNewOffset"


ID_STRATON_1

Interne ID: ID_STRATON_1

Projektname

Name des zenon Logic Projekts. Maximal 15 Zeichen.

ACHTUNG: Änderungen des Projektnamens können Verknüpfungen zu dynamischen Elementen auflösen.
ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_STRATON_2

Interne ID: ID_STRATON_2

Projektordner

Arbeitsverzeichnis des zenon Logic Projekts.

ACHTUNG: Diese Eigenschaft kann nicht verändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WorkingFolder"


ID_STRATON_3

Interne ID: ID_STRATON_3

Ziel-Host

Der Runtime Host (IP-Adresse oder Rechnername) des zenon Logic Zielsystems für die Verbindung der Workbench für z.B. Online Debugging.
Default: localhost.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VMHost"


ID_STRATON_4

Interne ID: ID_STRATON_4

Ziel-Port

Der Runtime Port des zenon Logic Zielsystems für die Verbindung der Workbench. Diese Information ist für die zenon Logic Workbench, um sich auf das Zielsystem (zenon Logic Runtime) für z.B. Online Debugging zu verbinden.
Minimum: 0.
Maximum: 4294967295.
Default: 1200.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VMPort"


ID_STRATON_5

Interne ID: ID_STRATON_5

Starttyp

Der Starttyp definiert, ob und wie die zenon Logic Runtime mit der Leitsystem Runtime gestartet wird.
Autom. starten: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, läuft die zenon Logic Runtime weiter.
Autom. starten/stoppen: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, so wird auch die zenon Logic Runtime beendet.
Manuell starten: In Bezug auf die zenon Logic Runtime passiert nichts, wenn die Leitsystem Runtime gestartet oder beendet wird. In diesem Fall muss die zenon Logic Runtime manuell gestartet werden (z.B. mit dem zenon Logic Runtime Manager).
Default: autom. starten stoppen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VMStartTyp"


ID_STRATON_6

Interne ID: ID_STRATON_6

Startort

Diese Eigenschaft ist nur in Verbindung mit dem Runtime Starttyp “autom. starten stoppen” und “autom. starten” relevant.
alle Rechner: In diesem Modus wird auf allen Rechner (Server, Clients und Standby Server), auf denen das Leitsystem-Projekt geladen wurde, die zenon Logic Runtime mit der Leitsystem-Runtime gestartet bzw. gestartet und gestoppt.
Server: In diesem Modus wird die zenon Logic Runtime nur auf einem Leitsystem-Server gestartet bzw. gestartet und gestoppt. Auf Clients bzw. auf Standby Servern wird die zenon Logic Runtime nicht gestartet.
Server und SB: In diesem Modus wird die zenon Logic Runtime nur auf dem Leitsystem-Server und Standby Server gestartet bzw. gestartet und gestoppt. Auf Clients wird die zenon Logic Runtime nicht gestartet.
Default: alle Rechner.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VMStartArea"


ID_Syskron_LDS_FKT_RD

Interne ID: ID_Syskron_LDS_FKT_RD

Syskron_LDS Function Read

Definieren Sie hier die Zugriffsfunktion zum Lesen. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der Zugriffsfunktion. Alternativ tragen Sie den Namen der Zugriffsfunktion manuell in das Textfeld ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Syskron_LDS_FKT_RD"


ID_Syskron_LDS_FKT_WR

Interne ID: ID_Syskron_LDS_FKT_WR

Syskron_LDS Function Write

Definieren Sie hier die Zugriffsfunktion zum Schreiben. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der Zugriffsfunktion. Alternativ tragen Sie den Namen der Zugriffsfunktion manuell in das Textfeld ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Syskron_LDS_FKT_WR"


ID_Syskron_LDS_PARAM_RD

Interne ID: ID_Syskron_LDS_PARAM_RD

Syskron_LDS Parameters Read

Definieren Sie hier alle Funktionsübergabe-Parameter. Ein Klick auf die Schaltfläche öffnet den Dialog zur Eingabe aller Funktionsübergabe-Parameter, die in der Runtime zum Lesen an die Funktion übergeben werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Syskron_LDS_PARAM_RD"


ID_Syskron_LDS_PARAM_WR

Interne ID: ID_Syskron_LDS_PARAM_WR

Syskron_LDS Parameters Write

Definieren Sie hier alle Funktionsübergabe-Parameter. Ein Klick auf die Schaltfläche öffnet den Dialog zur Eingabe aller Funktionsübergabe-Parameter, die in der Runtime zum Schreiben an die Funktion übergeben werden. Der letzte Übergabeparameter ist immer der von zenon gesendete Sollwert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Syskron_LDS_PARAM_WR"


ID_SYSVAR_INHALT

Interne ID: ID_SYSVAR_INHALT

Typ

Definition des Typs der Systemvariable. Der Inhalt kann nur geändert werden, wenn es noch keine Variable mit dem neuen Typ gibt. Bsp: Sie können nur eine Variable aktueller Server pro Projekt anlegen.

Achtung!

Wenn Sie den Typ ändernwird der Variablennamen und eventuell auch der Datentyp geändert. Beachten Sie das bei Verwendung der Variablen in dynmaischen Elementen eventuell der Anzeigebereich bzw. der Variablenname in VBA/VSTA angepasst werden muss.

Für benutzerdefinierte Systemtreibervariablen bleibt die Dropdown-Liste leer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Inhalt"


ID_SYSVAR_THEMA

Interne ID: ID_SYSVAR_THEMA

Thema

Logische Gruppe der Systemvariable.

Für benutzerdefinierte Systemtreibervariablen bleibt die Dropdown-Liste leer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Thema"


ID_TEMPLATE_PROP1

Interne ID: ID_TEMPLATE_PROP1

Name

Eindeutiger Name der Schablone.
Default: Template_x (wobei x eine fortlaufende Zahl ist).
Maximum: 28 Zeichen im Projekt, 27 Zeichen im Globalprojekt.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TemplateName"


ID_TEMPLATE_PROP2

Interne ID: ID_TEMPLATE_PROP2

Oben [Pixel]

Y-Koordinate des linken oberen Eckpunktes der Schablone in Pixel (ausgehend von der eingestellten Bildschirmauflösung).
Minimum: -2147483648.
Maximum: 2147483647.
Default: 0.

ACHTUNG: Wir empfehlen Schablonen nicht größer als 32000*32000 Pixel zu definieren um Schmiereffekte zu vermeiden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosTop"


ID_TEMPLATE_PROP3

Interne ID: ID_TEMPLATE_PROP3

Links [Pixel]

X-Koordinate des linken oberen Eckpunktes der Schablone in Pixel (ausgehend von der eingestellten Bildschirmauflösung).
Minimum: -2147483648.
Maximum: 2147483647.
Default: 0.

ACHTUNG: Wir empfehlen Schablonen nicht größer als 32000*32000 Pixel zu definieren um Schmiereffekte zu vermeiden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosLeft"


ID_TEMPLATE_PROP4

Interne ID: ID_TEMPLATE_PROP4

Rechts [Pixel]

X-Koordinate des rechten unteren Eckpunktes der Schablone in Pixel (ausgehend von der eingestellten Bildschirmauflösung).
Minimum: -2147483648.
Maximum: 2147483647.
Default: Maximum der aktuellen Bildschirmauflösung.

ACHTUNG: Wir empfehlen Schablonen nicht größer als 32000*32000 Pixel zu definieren um Schmiereffekte zu vermeiden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosRight"


ID_TEMPLATE_PROP5

Interne ID: ID_TEMPLATE_PROP5

Unten [Pixel]

Y-Koordinate des rechten unteren Eckpunktes der Schablone in Pixel (ausgehend von der eingestellten Bildschirmauflösung).
Minimum: -2147483648.
Maximum: 2147483647.
Default: Maximum der aktuellen Bildschirmauflösung.

ACHTUNG: Wir empfehlen Schablonen nicht größer als 32000*32000 Pixel zu definieren um Schmiereffekte zu vermeiden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosBottom"


ID_TEMPLATE_PROP7

Interne ID: ID_TEMPLATE_PROP7

Hintergrundfarbe

Hintergrundfarbe als Vorschlag für alle auf dieser Schablone neu definierten Bilder.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundColor"


ID_TEMPLATE_PROP8

Interne ID: ID_TEMPLATE_PROP8

Grafikdatei

Auswahl der Hintergrundgrafik als Vorlage für alle auf dieser Schablone neu definierten Bilder.
Hinweis: Eine Änderung der Grafikdatei wirkt sich nicht auf bereits existierende Bilder aus, die auf dieser Schablone basieren.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPicture"


ID_TEMPLATE_PROP9

Interne ID: ID_TEMPLATE_PROP9

Ausrichtung

Nur verfügbar, nachdem eine Grafikdatei ausgewählt wurde:

Interne ID: ID_TEMPLATE_PROP9

Grafikdatei

Auswahl der Hintergrundgrafik als Vorlage für alle auf dieser Schablone neu definierten Bilder.
Hinweis: Eine Änderung der Grafikdatei wirkt sich nicht auf bereits existierende Bilder aus, die auf dieser Schablone basieren.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPictureStyle"

Mögliche Darstellungsarten:
gekachelt: Originalgröße, in Kacheln nebeneinander.

gestreckt: formatfüllend, auf Bildgröße gestreckt.

normal: Originalgröße, in der linken oberen Ecke positioniert.
zentriert: Originalgröße, zentriert in der Bildmitte zentriert.

Default: normal.

Freies Verschieben ist nicht möglich

Hinweis: Eine Änderung der Ausrichtung wirkt sich nicht auf die Bilder aus, die auf der Schablone basieren.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPictureStyle"


ID_TEMPLATE_PROP10

Interne ID: ID_TEMPLATE_PROP10

Immer im Vordergrund

Aktiv: Kein anderes Bild überdeckt diesen Bereich im Onlinebetrieb. Bilder im Hintergrund können aber bedient werden.
Inaktiv: Bilder dieser Schablone können von anderen Bildern überdeckt werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowForeground"


ID_TEMPLATE_PROP11

Interne ID: ID_TEMPLATE_PROP11

Titel

Nur verfügbar, wenn ein Rahmen für die Schablone ausgewählt ist:
Aktiv: Windows-Titelleisten für die Bilder dieser Schablone verwenden. Die Bilder können in der Runtime verschoben werden.
Inaktiv: Keine Titelleiste verwenden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowTitle"


ID_TEMPLATE_PROP12

Interne ID: ID_TEMPLATE_PROP12

Systemmenü

Nur verfügbar, wenn der Titel aktiv ist:
Aktiv: Windows-Systemmenü in der Titelleiste anzeigen.
Inaktiv: Kein Systemmenü anzeigen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowSysMenu"


ID_TEMPLATE_PROP13

Interne ID: ID_TEMPLATE_PROP13

Min./Max. Schaltflächen

Nur verfügbar, wenn der Titel aktiv ist:
Aktiv: Windows Symbolfeld in der Titelleiste anzeigen.
Inaktiv: Kein Symbolfeld anzeigen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowMinimize"


ID_TEMPLATE_PROP14

Interne ID: ID_TEMPLATE_PROP14

Rahmenart

Rahmenart des Bildes.
Dicker Rahmen: Ein dicker Rahmen wird um das Bild dargestellt. Die Größe des Bildes kann in der Runtime verändert werden.
Dünner Rahmen: Ein dünner Rahmen wird um das Bild dargestellt.
Kein Rahmen: Kein Rahmen wird um das Bild dargestellt.
Default: Kein Rahmen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BorderStyle"


ID_TEMPLATE_PROP18

Interne ID: ID_TEMPLATE_PROP18

Anzeige im Schabloneneditor

Aktiv: Die ausgewählte Schablone wird im Schabloneneditor angezeigt.
Inaktiv: Die Schablone wird im Schabloneneditor nicht angezeigt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibleInEditor"


ID_TEMPLATE_PROP20

Interne ID: ID_TEMPLATE_PROP20

Standardposition verwenden

aktiv: Positioniert die Schablone für die Alarmstatuszeile am oberen Bildschirmrand.

Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StandardPosition"


ID_TEMPLATE_PROP21

Interne ID: ID_TEMPLATE_PROP21

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP21

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosType"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP21

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosType"

Interne ID: ID_TEMPLATE_PROP21

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosType"

Interne ID: ID_TEMPLATE_PROP21

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosType"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosType"


ID_TEMPLATE_PROP22

Interne ID: ID_TEMPLATE_PROP22

Vertikal

Nur aktiv, wenn Sie bei Positionierung relativ zum Element oder relativ zum Mauszeiger selektieren.

Interne ID: ID_TEMPLATE_PROP22

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP22

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefVert"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP22

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefVert"

Interne ID: ID_TEMPLATE_PROP22

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefVert"

Interne ID: ID_TEMPLATE_PROP22

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefVert"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefVert"

Selektieren Sie in der Dropdown Liste den gewünschten Bezugspunkt für die Schablone. Wählen Sie zwischen oben, unten oder zentriert.

Default: oben

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefVert"


ID_TEMPLATE_PROP23

Interne ID: ID_TEMPLATE_PROP23

Horizontal

Nur aktiv, wenn Sie bei Positionierung relativ zum Element oder relativ zum Mauszeiger selektieren.

Interne ID: ID_TEMPLATE_PROP23

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP23

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefHorz"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP23

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefHorz"

Interne ID: ID_TEMPLATE_PROP23

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefHorz"

Interne ID: ID_TEMPLATE_PROP23

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefHorz"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefHorz"

Selektieren Sie in der Dropdown Liste den gewünschten Bezugspunkt für die Schablone. Wählen Sie zwischen links, rechts oder zentriert.

Default: links

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RefHorz"


ID_TEMPLATE_PROP24

Interne ID: ID_TEMPLATE_PROP24

Vertikal

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP24

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP24

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosVert"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP24

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosVert"

Interne ID: ID_TEMPLATE_PROP24

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosVert"

Interne ID: ID_TEMPLATE_PROP24

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosVert"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosVert"

Selektieren Sie in der Dropdown Liste den gewünschte bevorzugten Bezugspunkt auf dem Element. Bei der Aufschaltung der Schablone wird zuerst versucht von diesem Punkt auszugehen. Wählen Sie zwischen oben oder unten.

Default: oben

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosVert"


ID_TEMPLATE_PROP25

Interne ID: ID_TEMPLATE_PROP25

Horizontal

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP25

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP25

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosHorz"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP25

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosHorz"

Interne ID: ID_TEMPLATE_PROP25

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosHorz"

Interne ID: ID_TEMPLATE_PROP25

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosHorz"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosHorz"

Selektieren Sie in der Dropdown Liste den gewünschte bevorzugten Bezugspunkt auf dem Element. Bei der Aufschaltung der Schablone wird zuerst versucht von diesem Punkt auszugehen. Wählen Sie zwischen links oder rechts.

Default: links

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PosHorz"


ID_TEMPLATE_PROP26

Interne ID: ID_TEMPLATE_PROP26

Verschiebung vertikal [Pixel]

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP26

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP26

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelVert"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP26

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelVert"

Interne ID: ID_TEMPLATE_PROP26

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelVert"

Interne ID: ID_TEMPLATE_PROP26

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelVert"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelVert"

Durch Eingabe eines positiven oder negativen Zahlenwertes, verschieben Sie den bevorzugten Bezugspunkt vertikal an die gewünschte Position.

Default: 2

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelVert"


ID_TEMPLATE_PROP27

Interne ID: ID_TEMPLATE_PROP27

Verschiebung horizontal [Pixel]

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP27

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP27

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelHorz"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP27

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelHorz"

Interne ID: ID_TEMPLATE_PROP27

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelHorz"

Interne ID: ID_TEMPLATE_PROP27

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelHorz"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelHorz"

Durch Eingabe eines positiven oder negativen Zahlenwertes, verschieben Sie den bevorzugten Bezugspunkt horizontal an die gewünschte Position.

Default: 2

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PixelHorz"


ID_TEMPLATE_PROP28

Interne ID: ID_TEMPLATE_PROP28

Alternativ vertikal

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP28

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP28

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefVert"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP28

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefVert"

Interne ID: ID_TEMPLATE_PROP28

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefVert"

Interne ID: ID_TEMPLATE_PROP28

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefVert"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefVert"

Selektieren Sie in der Dropdown Liste den gewünschten alternativen Bezugspunkt für die Schablone. Bei der Aufschaltung der Schablone wird der alternative Bezugspunkt verwendet, wenn es nicht möglich ist, die Schablone am bevorzugten Bezugspunkt aufzuschalten. Wählen Sie zwischen oben, unten oder zentriert.

Default: oben

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefVert"


ID_TEMPLATE_PROP29

Interne ID: ID_TEMPLATE_PROP29

Alternativ horizontal

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP29

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP29

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefHorz"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP29

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefHorz"

Interne ID: ID_TEMPLATE_PROP29

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefHorz"

Interne ID: ID_TEMPLATE_PROP29

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefHorz"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefHorz"

Selektieren Sie in der Dropdown Liste den gewünschten alternativen Bezugspunkt für die Schablone. Bei der Aufschaltung der Schablone wird der alternative Bezugspunkt verwendet, wenn es nicht möglich ist die Schablone am bevorzugten Bezugspunkt aufzuschalten. Wählen Sie zwischen links, rechts oder zentriert.

Default: links

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltRefHorz"


ID_TEMPLATE_PROP30

Interne ID: ID_TEMPLATE_PROP30

Vertikal

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP30

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP30

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosVert"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP30

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosVert"

Interne ID: ID_TEMPLATE_PROP30

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosVert"

Interne ID: ID_TEMPLATE_PROP30

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosVert"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosVert"

Selektieren Sie in der Dropdown Liste den gewünschte alternativen Bezugspunkt auf dem Element. Bei der Aufschaltung der Schablone wird der alternative Bezugspunkt verwendet, wenn es nicht möglich ist die Schablone am bevorzugten Bezugspunkt aufzuschalten. Wählen Sie zwischen oben oder unten.

Default: oben

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosVert"


ID_TEMPLATE_PROP31

Interne ID: ID_TEMPLATE_PROP31

Horizontal

Nur aktiv, wenn Sie bei Positionierung auf relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP31

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP31

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosHorz"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP31

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosHorz"

Interne ID: ID_TEMPLATE_PROP31

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosHorz"

Interne ID: ID_TEMPLATE_PROP31

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosHorz"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosHorz"

Selektieren Sie in der Dropdown Liste den gewünschten alternativen Bezugspunkt auf dem Element. Bei der Aufschaltung der Schablone wird der alternative Bezugspunkt verwendet, wenn es nicht möglich ist, die Schablone am bevorzugten Bezugspunkt aufzuschalten. Wählen Sie zwischen links oder rechts.

Default: links

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPosHorz"


ID_TEMPLATE_PROP32

Interne ID: ID_TEMPLATE_PROP32

Verschiebung vertikal [Pixel]

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP32

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP32

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelVert"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP32

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelVert"

Interne ID: ID_TEMPLATE_PROP32

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelVert"

Interne ID: ID_TEMPLATE_PROP32

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelVert"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelVert"

Durch Eingabe eines positiven oder negativen Zahlenwertes, verschieben Sie den alternativen Bezugspunkt vertikal an die gewünschte Position.

Default: 2

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelVert"


ID_TEMPLATE_PROP33

Interne ID: ID_TEMPLATE_PROP33

Verschiebung horizontal [Pixel]

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP33

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP33

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelHorz"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP33

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelHorz"

Interne ID: ID_TEMPLATE_PROP33

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelHorz"

Interne ID: ID_TEMPLATE_PROP33

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelHorz"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelHorz"

Durch Eingabe eines positiven oder negativen Zahlenwertes, verschieben Sie den alternativen Bezugspunkt horizontal an die gewünschte Position.

Default: 2

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AltPixelHorz"


ID_TEMPLATE_PROP34

Interne ID: ID_TEMPLATE_PROP34

Schließen bei Fokusverlust

Steuert das Verhalten der Schablone bei Fokusverlust.

Aktiv: Bei einem Linksklick außerhalb der Schablone schließt sich diese automatisch, wenn in einen Bildschirmbereich geklickt wird, der zwar zur zenon Runtime aber weder zur Schablone selbst noch zu einer Schablone mit gesetzter Eigenschaft Schließen bei Fokusverlust unterdrücken gehört.

Interne ID: ID_TEMPLATE_PROP34

Schließen bei Fokusverlust unterdrücken

Aktiv: Bei Fokusverlust bleibt die Schablone geöffnet. Das Schließen einer anderen Schablone bei Fokusverlust wird unterdrückt, falls in dieser Schablone geklickt wurde. So können Bildschirmbereiche definiert werden, in denen das Klicken die mit Schließen bei Fokusverlust projektierten geöffneten Schablonen nicht schließt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CloseOnClickOutside"

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CloseOnClickOutside"


ID_TEMPLATE_PROP35

Interne ID: ID_TEMPLATE_PROP35

Freie Schablonenform

Ermöglicht die Verwendung der freien Schablonenform für die selektierte Schablone. Dadurch ist es möglich Schablonen mit z.B. abgerundeten Ecken, Löchern usw. zu definieren.

Aktiv: Die freie Schablonenform wird für diese Schablone und die damit verknüpften Bilder verwendet.

Inaktiv: Freie Schablonenform steht nicht nur Verfügung. Eine bereits bestehende freie Schablonenform wird im Schablonen- und im Bildeditor nicht angezeigt.

Default: inaktiv

Hinweis: Steht nicht zur Verfügung für Schablone Alarmstatuszeile und nicht unter Windows CE.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseFreeForming"


ID_TEMPLATE_PROP36

Interne ID: ID_TEMPLATE_PROP36

Freie Schablonenform definieren

Nur verfügbar, wenn Sie Freie Schablonenform aktiviert haben.

Interne ID: ID_TEMPLATE_PROP36

Freie Schablonenform

Ermöglicht die Verwendung der freien Schablonenform für die selektierte Schablone. Dadurch ist es möglich Schablonen mit z.B. abgerundeten Ecken, Löchern usw. zu definieren.

Aktiv: Die freie Schablonenform wird für diese Schablone und die damit verknüpften Bilder verwendet.

Inaktiv: Freie Schablonenform steht nicht nur Verfügung. Eine bereits bestehende freie Schablonenform wird im Schablonen- und im Bildeditor nicht angezeigt.

Default: inaktiv

Hinweis: Steht nicht zur Verfügung für Schablone Alarmstatuszeile und nicht unter Windows CE.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefineFreeForm"

Definieren Sie die Form für die selektierte Schablone. Führen Sie einen Linksklick auf die Schaltfläche aus, um die entsprechende Schablone im Schablonenform-Editor zu öffnen. Dort können Sie mithilfe von Kreisen, Rechtecken, abgerundeten Rechtecken und Polygonen die Form der Schablone festlegen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefineFreeForm"


ID_TEMPLATE_PROP37

Interne ID: ID_TEMPLATE_PROP37

Schließen bei Fokusverlust unterdrücken

Aktiv: Bei Fokusverlust bleibt die Schablone geöffnet. Das Schließen einer anderen Schablone bei Fokusverlust wird unterdrückt, falls in dieser Schablone geklickt wurde. So können Bildschirmbereiche definiert werden, in denen das Klicken die mit Schließen bei Fokusverlust projektierten geöffneten Schablonen nicht schließt.

Interne ID: ID_TEMPLATE_PROP37

Schließen bei Fokusverlust

Steuert das Verhalten der Schablone bei Fokusverlust.

Aktiv: Bei einem Linksklick außerhalb der Schablone schließt sich diese automatisch, wenn in einen Bildschirmbereich geklickt wird, der zwar zur zenon Runtime aber weder zur Schablone selbst noch zu einer Schablone mit gesetzter Eigenschaft Schließen bei Fokusverlust unterdrücken gehört.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IgnoreCloseOnClick"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IgnoreCloseOnClick"


ID_TEMPLATE_PROP38

Interne ID: ID_TEMPLATE_PROP38

Position beim Neuaufschalten beibehalten

Aktiv: Eine Schablone, die zur Runtime manuell verschoben wurde, wird beim Aufschalten eines neues Bildes nicht auf die projektierte Position zurückgesetzt, wenn sie bereits am selben Client geöffnet ist.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NoMoveOnReopen"


ID_TEMPLATE_PROP_GRP0

Interne ID: ID_TEMPLATE_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_TEMPLATE_PROP_GRP1

Interne ID: ID_TEMPLATE_PROP_GRP1

Rahmen

Eigenschaften für den Rahmen der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Frame"


ID_TEMPLATE_PROP_GRP2

Interne ID: ID_TEMPLATE_PROP_GRP2

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Position"


ID_TEMPLATE_PROP_GRP3

Interne ID: ID_TEMPLATE_PROP_GRP3

Hintergrundgrafik

In jedem Bild kann eine Grafikdatei als Hintergrund angezeigt werden. Hintergrundgrafiken für Schablonen werden automatisch allen neuen Bildern zugewiesen, die auf dieser Schablone basieren. Bereits existierende Bilder müssen nachträglich manuell angepasst werden.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPicture"


ID_TEMPLATE_PROP_GRP4

Interne ID: ID_TEMPLATE_PROP_GRP4

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Interne ID: ID_TEMPLATE_PROP_GRP4

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP_GRP4

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TemplateReference"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP_GRP4

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TemplateReference"

Interne ID: ID_TEMPLATE_PROP_GRP4

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TemplateReference"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TemplateReference"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TemplateReference"


ID_TEMPLATE_PROP_GRP5

Interne ID: ID_TEMPLATE_PROP_GRP5

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP_GRP5

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP_GRP5

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrimaryReference"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP_GRP5

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrimaryReference"

Interne ID: ID_TEMPLATE_PROP_GRP5

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrimaryReference"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrimaryReference"

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PrimaryReference"


ID_TEMPLATE_PROP_GRP6

Interne ID: ID_TEMPLATE_PROP_GRP6

Alternativer Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Interne ID: ID_TEMPLATE_PROP_GRP6

Positionierung

Bestimmt die Position der Schablone und der auf ihr basierenden Bilder zur Runtime.

absolute Position verwenden: Positioniert die Schablone an den bei Position definierten Koordinaten.

Interne ID: ID_TEMPLATE_PROP_GRP6

Position

Eigenschaften für die Position und Größe der Schablone.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlternativeReference"

relativ zum Element: Positioniert den Bezugspunkt der Schablone relativ zu jenem Element, von dem die Bildumschaltung angestoßen wurde. Hier können Sie sowohl den Bezugspunkt der Schablone (bei Bezugspunkt Schablone) als auch den Bezugspunkt des Elements (bei Bezugspunkt Element) inklusive der Abstände zum Element festlegen. Zur Runtime wird dann der Bezugspunkt der Schablone immer auf den errechneten Bezugspunkt des Elements gelegt. Kann die Schablone an dieser Position nicht aufgeschaltet werden, da das Bild dadurch außerhalb des sichtbaren Bildschirmbereichs wäre, werden die Alternativbezugspunkte verwendet. Diese stellen Sie für die Schablone bei Bezugspunkt Schablone ein und für das Element bei Alternativer Bezugspunkt Element ein.

Interne ID: ID_TEMPLATE_PROP_GRP6

Bezugspunkt Element

Nur aktiv, wenn Sie bei Positionierung relativ zum Element selektieren.

Hier definieren Sie den Bezugspunkt zum Element. Abhängig davon wird die Schablone aufgeschaltet. Ist der Bezugspunkt beispielsweiße links/zentriert mit 0 Pixel Abstand, wird genau auf diesen Bezugspunk an der linken Kante in der Mitte des Elements der Bezugspunkt der Schablone positioniert. Den Bezugspunkt der Schablone stellen Sie unter Bezugspunkt Schablone ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlternativeReference"

Interne ID: ID_TEMPLATE_PROP_GRP6

Bezugspunkt Schablone

Hier definieren Sie den Bezugspunkt der Schablone. Abhängig davon wird die Schablone in der Runtime aufgeschaltet, wenn Sie bei Positionierung relativ zum Mauszeiger bzw. relativ zum Element gewählt haben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlternativeReference"

relativ zum Mauszeiger: Das Bild wird abhängig vom Bezugspunkt der Schablone aufgeschaltet. Dieser entspricht der aktuellen Position des Mauszeigers. Den Bezugspunkt legen Sie bei Bezugspunkt Schablone fest. Er wird im Schablonen-Editor als roter Punkt dargestellt. Beispiel: Befindet sich der Bezugspunkt links oben, wird die Schablone vom Bezugspunkt ausgehend nach rechts unten aufgeschaltet.
Kann das Bild an der projektierten Position nicht vollständig dargestellt werden, wird die Position soweit verschoben, dass das gesamte Bild innerhalb des dargestellten Bereichs des Monitors bleibt.

Default: absolute Position verwenden

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlternativeReference"

Hier definieren Sie den alternativen Bezugspunkt am Element. Dieser ist nur wirksam, wenn die Schablone nicht im darstellbaren Bereich des Bildschirms aufgeschaltet werden kann. Es empfiehlt sich immer die entgegengesetzen Einstellungen zum regulären Bezugspunkt (eingestellt bei Bezugspunkt Element) zu verwenden. Beispiel: Ist der Bezugspunkt rechts/zentriert sollte der alternative Bezugspunkt rinks/zentriert sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlternativeReference"


ID_TEMPLATE_PROP_GRP7

Interne ID: ID_TEMPLATE_PROP_GRP7

Freie Schablonenform

Eigenschaften für die frei Schablonenform.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FreeForm"


ID_TEMPLOGIN

Interne ID: ID_TEMPLOGIN

Temp. Login aktiv

Aktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, wird er zur Eingabe seiner Kennung und seines Passworts aufgefordert.
Inaktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, erhält er die Information, dass er dazu nicht berechtigt ist.
Default: aktiv.

Hinweis: Position und Größe der Login-Maske können in der zenon6.ini unter [Befehlsgabe] Position = definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TempLogin"


ID_TOPOLOGIE_PROP1

Interne ID: ID_TOPOLOGIE_PROP1

Strichelung1

Strichelung1

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BrokenLine1"


ID_TOPOLOGIE_PROP2

Interne ID: ID_TOPOLOGIE_PROP2

Strichelung2

Strichelung 2

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BrokenLine2"


ID_TOPOLOGIE_PROP3

Interne ID: ID_TOPOLOGIE_PROP3

Strichbreite

Strichbreite

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineWidth"


ID_TOPOLOGIE_PROP4

Interne ID: ID_TOPOLOGIE_PROP4

Objektname als Link

Objektname als Link

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OBJNameLink"


ID_TOPOLOGIE_PROP5

Interne ID: ID_TOPOLOGIE_PROP5

AnzeigeModus

Anzeige Modus

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DisplayMode"


ID_TOPOLOGIE_PROP6

Interne ID: ID_TOPOLOGIE_PROP6

Strichbreite Gesichert

Strichbreite Gesichert

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineWidthFGES"


ID_TOPOLOGIE_PROP7

Interne ID: ID_TOPOLOGIE_PROP7

Saumbreite

Saumbreite

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SaumWidth"


ID_TOPOLOGIE_PROP8

Interne ID: ID_TOPOLOGIE_PROP8

Symbol F1

Symbol F1

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolF1"


ID_TOPOLOGIE_PROP9

Interne ID: ID_TOPOLOGIE_PROP9

Symbol F2

Symbol F2

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolF2"


ID_TOPOLOGIE_PROP10

Interne ID: ID_TOPOLOGIE_PROP10

Symbol FGES

Symbol FGES

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolFGES"


ID_TOPOLOGIE_PROP11

Interne ID: ID_TOPOLOGIE_PROP11

Symbol Saum

Symbol Saum

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolSaum"


ID_TOPOLOGIE_PROP12

Interne ID: ID_TOPOLOGIE_PROP12

Symbol F1 Farben

Symbol F1 Farben

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolF1_Mode"


ID_TOPOLOGIE_PROP13

Interne ID: ID_TOPOLOGIE_PROP13

Symbol F2 Farben

Symbol F2 Farben

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolF2_Mode"


ID_TOPOLOGIE_PROP14

Interne ID: ID_TOPOLOGIE_PROP14

Symbol FGES Farben

Symbol FGES Farben

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolFGES_Mode"


ID_TOPOLOGIE_PROP15

Interne ID: ID_TOPOLOGIE_PROP15

Symbol Saum Farben

Symbol Saum Farben

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SymbolSaum_Mode"


ID_TOPOLOGIE_PROP16

Interne ID: ID_TOPOLOGIE_PROP16

Variable SS_1_1

Variable SS_1_1

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_1_1"


ID_TOPOLOGIE_PROP17

Interne ID: ID_TOPOLOGIE_PROP17

Variable SS_1_2

Variable SS_1_2

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_1_2"


ID_TOPOLOGIE_PROP18

Interne ID: ID_TOPOLOGIE_PROP18

Variable SS_1_3

Variable SS_1_3

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_1_3"


ID_TOPOLOGIE_PROP19

Interne ID: ID_TOPOLOGIE_PROP19

Variable SS_1_4

Variable SS_1_4

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_1_4"


ID_TOPOLOGIE_PROP20

Interne ID: ID_TOPOLOGIE_PROP20

Variable Anfang1

Variable Anfang1

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_Start1"


ID_TOPOLOGIE_PROP21

Interne ID: ID_TOPOLOGIE_PROP21

Variable Normtrennstelle

Variable Normtrennstelle

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VariableStandardIsolatingPoint"


ID_TOPOLOGIE_PROP22

Interne ID: ID_TOPOLOGIE_PROP22

Variable Anfang2

Variable Anfang 2

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_Start2"


ID_TOPOLOGIE_PROP23

Interne ID: ID_TOPOLOGIE_PROP23

Variable SS_2_1

Variable SS_2_1

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_2_1"


ID_TOPOLOGIE_PROP24

Interne ID: ID_TOPOLOGIE_PROP24

Variable SS_2_2

Variable SS_2_2

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_2_2"


ID_TOPOLOGIE_PROP25

Interne ID: ID_TOPOLOGIE_PROP25

Variable SS_2_3

Variable SS_2_3

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_2_3"


ID_TOPOLOGIE_PROP26

Interne ID: ID_TOPOLOGIE_PROP26

Variable SS_2_4

Variable SS_2_4

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable_SS_2_4"


ID_TOPOLOGIE_PROP27

Interne ID: ID_TOPOLOGIE_PROP27

Zeichen woanders getrennt

Zeichen woanders getrennt

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DistributionLineCharacter"


ID_TOPOLOGIE_PROP31

Interne ID: ID_TOPOLOGIE_PROP31

Reaktanz

Blindwiderstand in Ohm zur Ermittlung des Fehlerorts.
Nur in Verbindung mit Option Fehlerort und Topologie.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Reactance"


ID_TOPOLOGIE_PROP_GRP1

Interne ID: ID_TOPOLOGIE_PROP_GRP1

Topologie

Element\\Topologie

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Topology"


ID_TOPOLOGIE_PROP_GRP2

Interne ID: ID_TOPOLOGIE_PROP_GRP2

Einfärbung

Element\\Topologie\\Symbolsteuerung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TopColors"


ID_TOPOLOGIE_PROP_GRP3

Interne ID: ID_TOPOLOGIE_PROP_GRP3

Strang

Element\\Topologie\\Strang

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "/*Element/Topologie/Strang*/"


ID_TOPOLOGIE_PROP_GRP4

Interne ID: ID_TOPOLOGIE_PROP_GRP4

Netzberechnungen

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetCalc"


ID_TOPOLOGIE_PROP_GRP5

Interne ID: ID_TOPOLOGIE_PROP_GRP5

Kabel

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetCalcCable"


ID_TREIBER_CONFIG

Interne ID: ID_TREIBER_CONFIG

Konfiguration

Öffnet den Dialog zur Konfigurations des Treibers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Configuration"


ID_TREIBER_FILE

Interne ID: ID_TREIBER_FILE

Dateiname

Dateiname des Treibers.
Die Datei befindet sich im Programmverzeichnis des Leitsystems.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NameFile"


ID_TREIBER_GRP0

Interne ID: ID_TREIBER_GRP0

Allgemein

Allgemeine Eigenschaften für den Treiber.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_TREIBER_NAME

Interne ID: ID_TREIBER_NAME

Bezeichnung

Eindeutige Bezeichnung des Treibers.
zenon identifiziert den Treiber über diesen Namen und nicht über den Dateinamen. So ist es möglich, den gleichen Treiber mehrmals zu laden. Das ist z.B. bei seriellen Treibern notwendig, wenn sie auf gleiche Steuerungstypen an verschiedenen seriellen Schnittstellen zugreifen müssen.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_TREIBER_PROP6

Interne ID: ID_TREIBER_PROP6

Beschreibung

Beschreibung des Treibers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Description"


ID_TREIBER_PROP_GRP0

Interne ID: ID_TREIBER_PROP_GRP0

Adressierung

Allgemeine Eigenschaften für den Treiber.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Address"


ID_TREIBER_PROP_GRP1

Interne ID: ID_TREIBER_PROP_GRP1

Treiber Anbindung

Fasst Konfiguration der Anbindung mit IEC-Datentyp, Priorität und Standby zusammen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Driver"


ID_TREIBER_PROP_GRP2

Interne ID: ID_TREIBER_PROP_GRP2

Array-Einstellungen

Eigenschaften für die Struktur von Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Structure"


ID_TREIBER_PROP_GRP3

Interne ID: ID_TREIBER_PROP_GRP3

Struktur-Optionen

Optionen für Struktur-Elemente.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StructOptions"


ID_TREIBER_PROP_GRP4

Interne ID: ID_TREIBER_PROP_GRP4

Adressierungsoptionen

Optionen für die Adressierung von Array-Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AddressOptions"


ID_TREND_DEL

Interne ID: ID_TREND_DEL

{Kurve löschen}

Die Kurve wird gelöscht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CurveDel"


ID_TREND_NEU

Interne ID: ID_TREND_NEU

{Kurve neu}

Eine neue Kurve für das Trendelement wird erstellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CurveNew"


ID_TYPE_GW_NEW

Interne ID: ID_TYPE_GW_NEW

{Grenzwert neu}

Ein neuer Grenzwert für den Datentyp wird erstellt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NewLimit"


ID_UEBER_HELLIGKEIT

Interne ID: ID_UEBER_HELLIGKEIT

Über Helligkeitswerte

Aktiv: Die Helligkeit des Farbverlaufs kann frei definiert werden.
Inaktiv: Die Helligkeit des Farbverlaufs wird automatisch vergeben.

Hinweis: Bei aktiver Option, können keine abgerundeten Ecken gesetzt werden. Wird die Option für ein Element aktiviert, das abgerundete Ecken verwendet, so wird das Element mit nicht abgerundeten Ecken dargestellt.

Diese Eigenschaft ist nur verfügbar, wenn bei der Eigenschaft Füllmuster der Farbverlauf aktiviert ist.

Interne ID: ID_UEBER_HELLIGKEIT

Füllmuster

Auswahl des Füllmusters für das Element aus der Liste.

Diese Eigenschaft ist nur dann verfügbar, wenn die Eigenschaft Über Helligkeitswerte inaktiv ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Brightness"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Brightness"


ID_UNIT_PROP_DECSHIFT

Interne ID: ID_UNIT_PROP_DECSHIFT

Kommaverschiebung

Korrektur der Nachkommastellen. Um diesen Wert wird die Anzahl der Kommastellen in der Umrechnungseinheit gegenüber der Basiseinheit verschoben.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DecShift"


ID_UNIT_PROP_FACTOR

Interne ID: ID_UNIT_PROP_FACTOR

Faktor

Angabe des Umrechnungsfaktors mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (k für y=kx+d bzw. m für y=mx+b).

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Factor"


ID_UNIT_PROP_GRP0

Interne ID: ID_UNIT_PROP_GRP0

Allgemein

Eigenschaften für die Einheitenumrechnung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_UNIT_PROP_NAME

Interne ID: ID_UNIT_PROP_NAME

Maßeinheit

Angabe der Basiseinheit, aus der umgerechnet wird, oder der Umrechnungseinheit, in die umgerechnet wird. Zum Beispiel C°, K, m, y, Celsius, Kelvin, Meter, Yard usw.

Die Eingabe ist auf 50 Zeichen beschränkt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_UNIT_PROP_OFFSET

Interne ID: ID_UNIT_PROP_OFFSET

Offset

aus Primäreinheit (d für y=kx+d)

Angabe des Umrechungsoffsets mit dem der Wert der Basiseinheit in den Wert der Umrechnungseinheit umgerechnet wird (d für y=kx+d bzw. b für y=mx+b).

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset"


ID_USER_ACTIVE

Interne ID: ID_USER_ACTIVE

Benutzer aktiv

Aktiv: Der Benutzer wird in der Runtime akzeptiert.
Inaktiv: Der Benutzer wird in der Runtime nicht akzeptiert.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserActive"


ID_USER_GROUPS

Interne ID: ID_USER_GROUPS

Benutzergruppen

Alle Benutzergruppen, die dem selektierten Benutzer zugeordnet sind.

Klicken Sie auf die Schaltfläche, um Benutzergruppen hinzuzufügen oder zu entfernen

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserGroups"


ID_USER_GRP

Interne ID: ID_USER_GRP

Benutzer

Eigenschaften für den Benutzer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_USER_LOCKCODE

Interne ID: ID_USER_LOCKCODE

Sperrcode

4-stelliger PIN-Code.

Dieser Code wird vom Benutzer verwendet, um verschiedene Bereiche zu sperren bzw. wieder frei zugeben. Durch Sperren mit diesem Code wird verhindert, dass eine unbeabsichtigte Freigabe einer Sperrung erfolgt und so zu Unfällen führt.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockCode"


ID_USER_LOCKED

Interne ID: ID_USER_LOCKED

Gesperrt

Aktiv: Der Benutzer ist gesperrt.
Inaktiv: Der Benutzer ist nicht gesperrt.
Default: inaktiv.

Nach einer definierten Anzahl falscher Eingabe des Passwortes wird ein Benutzer automatisch gesperrt. Hier kann die Sperrung aufgehoben werde.
In der Runtime kann nur ein Administrator einen Benutzer entsperren, da nur ein Administrator Benutzer editieren kann.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserLocked"


ID_USER_MSGCTRL_EMAIL

Interne ID: ID_USER_MSGCTRL_EMAIL

E-Mail

E-Mail Adresse des Benutzers.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgEmail"


ID_USER_MSGCTRL_ERSATZUSER

Interne ID: ID_USER_MSGCTRL_ERSATZUSER

Ersatzperson

Person, die den Benutzer bei Nichterreichbarkeit ersetzt. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Benutzers.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgErsatzUser"


ID_USER_MSGCTRL_GSM

Interne ID: ID_USER_MSGCTRL_GSM

GSM

Nummer des Mobiltelefons des Benutzers. Wird für Nachrichten über GSM und SMS verwendet.

Eingabe in Ziffern, ein führendes + als Abkürzung für 00 der internationalen Ländervorwahl ist erlaubt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgGSM"


ID_USER_MSGCTRL_NACKCODE

Interne ID: ID_USER_MSGCTRL_NACKCODE

NA-Code

Not-Available-Code, mit dem der Benutzer die Annahme der Nachricht verweigern kann.

Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft PIN-Code unterscheiden.

Interne ID: ID_USER_MSGCTRL_NACKCODE

PIN-Code

PIN Code, mit dem der Benutzer den Empfang der Nachricht bestätigt.

Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft NA-Code unterscheiden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgNACKCode"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgNACKCode"


ID_USER_MSGCTRL_PHONE

Interne ID: ID_USER_MSGCTRL_PHONE

Telefon

Nummer des Festnetztelefons des Benutzers. Wird für Voice to Speech verwendet.

Eingabe in Ziffern, ein führendes + als Abkürzung für 00 der internationalen Ländervorwahl ist erlaubt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgPhone"


ID_USER_MSGCTRL_PINCODE

Interne ID: ID_USER_MSGCTRL_PINCODE

PIN-Code

PIN Code, mit dem der Benutzer den Empfang der Nachricht bestätigt.

Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft NA-Code unterscheiden.

Interne ID: ID_USER_MSGCTRL_PINCODE

NA-Code

Not-Available-Code, mit dem der Benutzer die Annahme der Nachricht verweigern kann.

Hinweis: Dieser Code sollte sich deutlich vom Code der Eigenschaft PIN-Code unterscheiden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgPinCode"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MsgPinCode"


ID_USER_MSGCTRL_USER

Interne ID: ID_USER_MSGCTRL_USER

Message Control Benutzer

Aktiv: Benutzer wird von Message Control verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsMsgCtrlUser"


ID_USERGROUP_GRP

Interne ID: ID_USERGROUP_GRP

Benutzergruppe

Eigenschaften für die Benutzergruppe

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_USERGROUP_LEVEL

Interne ID: ID_USERGROUP_LEVEL

Berechtigungsebenen

Alle Berechtigungsebenen, die der selektierten Benutzergruppe zugeordnet sind.

Klicken Sie auf die Schaltfläche, um Berechtigungsebenen hinzuzufügen oder zu entfernen.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserGroupLevel"


ID_USERGROUP_NAME

Interne ID: ID_USERGROUP_NAME

Name

Name der selektierten Benutzergruppe.

Klicken Sie in das Eingabefeld, um den Namen zu ändern.

Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung, da der Name im Active Directory überprüfbar sein muss.
@ ist kein gültiges Zeichen für den Namen einer Benutzergruppe.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserGroupName"


ID_USERGRP_MSGCTRL_ISMSGCTRL

Interne ID: ID_USERGRP_MSGCTRL_ISMSGCTRL

Message Control Gruppe

Aktiv: Benutzergruppe wird von Message Control verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsMsgCtrlGroup"


ID_USERGRP_MSGCTRL_USERORDER

Interne ID: ID_USERGRP_MSGCTRL_USERORDER

Benutzerreihenfolge

Legt Reihenfolge der Benutzer in der Gruppe fest. Klick auf Schaltfläche ... öffnet Dialog zur Konfiguration der Reihenfolge.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserGroupOrder"


ID_USERKENNUNG

Interne ID: ID_USERKENNUNG

Benutzername

Eindeutige Kennung, mit der sich der Benutzer einloggen muss.
Bei diversen Benutzeraktionen kann diese Zeichenfolge in der Chronologischen Ereignisliste (CEL) angezeigt werden. In der CEL gibt es eine eigene Spalte für die Anzeige dieser Information. Zusätzlich kann diese Information auch mit Hilfe einer Systemtreiber-Variablen angezeigt werden.
Maximum: 20 Zeichen.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserIdentification"


ID_USERNAME

Interne ID: ID_USERNAME

Vollständiger Name

Name des Benutzers.
Beim diversen Benutzeraktionen kann diese Zeichenfolge in der Chronologischen Ereignisliste (CEL) angezeigt werden. Das sollte der volle Name der Benutzers sein. In der CEL gibt es eine eigene Spalte für die Anzeige dieser Information. Zusätzlich kann diese Information auch mit Hilfe einer Systemtreiber-Variable angezeigt werden.

ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserName"


ID_USERPASSWORD

Interne ID: ID_USERPASSWORD

Passwort

Öffnet die Dialogbox zum Ändern des Passworts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserPassword"


ID_VAR_AKS_GRP1

Interne ID: ID_VAR_AKS_GRP1

AKS-General

Datenpunkte des AK-Treibers werden mit dem OPM parametriert.

Weiterführende Informationen zur Parametrierung sind in der SICAM230 Hilfe und in der Hilfe der TOOLBOX II nachzulesen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AKS-General"


ID_VAR_AKS_GRP1_ENG

Interne ID: ID_VAR_AKS_GRP1_ENG

AKS-General

Datapoints will be engineered by OPM.

Further information available in SICAM230 help and in TOOLBOX II help.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AKS-General"


ID_VAR_AKS_GRP2

Interne ID: ID_VAR_AKS_GRP2

AKS-Extended

Datenpunkte des AK-Treibers werden mit dem OPM parametriert.

Weiterführende Informationen zur Parametrierung sind in der SICAM230 Hilfe und in der Hilfe der TOOLBOX II nachzulesen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AKS-Extended"


ID_VAR_AKS_GRP2_ENG

Interne ID: ID_VAR_AKS_GRP2_ENG

AKS-Extended

Datapoints will be engineered by OPM.

Further information available in SICAM230 help and in TOOLBOX II help.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AKS-Extended"


ID_VAR_AKS_GRP3

Interne ID: ID_VAR_AKS_GRP3

Redundanz

Datenpunkte des AK-Treibers werden mit dem OPM parametriert.

Weiterführende Informationen zur Parametrierung sind in der SICAM230 Hilfe und in der Hilfe der TOOLBOX II nachzulesen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Redundancy"


ID_VAR_AKS_GRP3_ENG

Interne ID: ID_VAR_AKS_GRP3_ENG

Redundancy

Datapoints will be engineered by OPM.

Further information available in SICAM230 help and in TOOLBOX II help.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Redundancy"


ID_VAR_AKS_GRP4

Interne ID: ID_VAR_AKS_GRP4

Befehle

Datenpunkte des AK-Treibers werden mit dem OPM parametriert.

Weiterführende Informationen zur Parametrierung sind in der SICAM230 Hilfe und in der Hilfe der TOOLBOX II nachzulesen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Command"


ID_VAR_AKS_GRP4_ENG

Interne ID: ID_VAR_AKS_GRP4_ENG

Command

Datapoints will be engineered by OPM.

Further information available in SICAM230 help and in TOOLBOX II help.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Command"


ID_VAR_ALARMBEREICH

Interne ID: ID_VAR_ALARMBEREICH

Alarmbereich

Hier kann die Variable mit einem Alarmbereich verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmDomain"


ID_VAR_ALARMKANAL0

Interne ID: ID_VAR_ALARMKANAL0

Alarm-Variable1

Nur verfügbar in SICAM 230.
Erste Variable für die Bildalarmierung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPV0"


ID_VAR_ALARMKANAL1

Interne ID: ID_VAR_ALARMKANAL1

Alarm-Variable2

Nur verfügbar in SICAM 230.
Zweite Variable für die Bildalarmierung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPV1"


ID_VAR_ALARMKANAL2

Interne ID: ID_VAR_ALARMKANAL2

Alarm-Variable3

Nur verfügbar in SICAM 230:
Dritte Variable für die Bildalarmierung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmPV2"


ID_VAR_ALARMQUIT

Interne ID: ID_VAR_ALARMQUIT

Quittiervariable

Binärvariable: Wird ein Alarm der steuernden Variablen quittiert wird, wird der Wert der Quittiervariablen auf den unter Quittierwert definierten Wert gesetzt.

Interne ID: ID_VAR_ALARMQUIT

Quittierwert

Wenn ein Alarm dieser Variable quittiert wird, wird die unter Quittiervariable ausgewählte Variable auf diesen Wert gesetzt.

Auswahl 0 oder 1.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmQuitPV"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmQuitPV"


ID_VAR_ALARMQUIT_VALUE

Interne ID: ID_VAR_ALARMQUIT_VALUE

Quittierwert

Wenn ein Alarm dieser Variable quittiert wird, wird die unter Quittiervariable ausgewählte Variable auf diesen Wert gesetzt.

Interne ID: ID_VAR_ALARMQUIT_VALUE

Quittiervariable

Binärvariable: Wird ein Alarm der steuernden Variablen quittiert wird, wird der Wert der Quittiervariablen auf den unter Quittierwert definierten Wert gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmQuitPVValue"

Auswahl 0 oder 1.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmQuitPVValue"


ID_VAR_ARCHHYSTNEG

Interne ID: ID_VAR_ARCHHYSTNEG

Negativ für Archiv

Hysterese für Archivierung bei Wertänderung bezogen auf Messbereich.

Hysteresebereich für Eintrag bei abnehmender Wertänderung. Werte werden nur dann ins Archiv eingetragen, wenn die Änderung unter dem hier eingestellten Hysteresebereich liegt.
Default: 0 (keine Hysterese)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ArchHystNeg"


ID_VAR_ARCHHYSTPOS

Interne ID: ID_VAR_ARCHHYSTPOS

Positiv für Archiv

Hysterese für Archivierung bei Wertänderung bezogen auf Messbereich.

Hysteresebereich für Eintrag bei zunehmender Wertänderung. Werte werden nur dann ins Archiv eingetragen, wenn die Änderung über dem hier eingestellten Hysteresebereich liegt.
Default: 0 (keine Hysterese)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ArchHystPos"


ID_VAR_ARRAYSIZE

Interne ID: ID_VAR_ARRAYSIZE

Größe Blockarray

Nur mehr aus Kompatibilitätsgründen vorhanden.
Bis Version 5.50 Definition der Block-Array-Größe.
Achtung: Im Intern Treiber zwar einstellbar, aber zur Runtime ohne Funktion (Wert immer 0).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ArraySizeOld"


ID_VAR_ARRDIM1

Interne ID: ID_VAR_ARRDIM1

Dim 1

Größe der ersten Dimension des Arrays.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Dim1"


ID_VAR_ARRDIM2

Interne ID: ID_VAR_ARRDIM2

Dim 2

Größe der zweiten Dimension des Arrays.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Dim2"


ID_VAR_ARRDIM3

Interne ID: ID_VAR_ARRDIM3

Dim 3

Größe der dritten Dimension des Arrays.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Dim3"


ID_VAR_AUSRICHTUNG

Interne ID: ID_VAR_AUSRICHTUNG

Ausrichtung

Abhängig von der Granularität des Treibers die Position der Variable innerhalb des definierten Offsets.

Für Byte-Variablen:
HiByte: Höherwertiges Byte im Wort-Offset.
LoByte: Niederwertiges Byte im Wort-Offset.
HiWord-HiByte Höherwerztiges Byte im höherwertigen Wort im Doppelwort-Offset.
HiWord-LoByte: Niederwertiges Byte im höherwertigen Word im Doppelwort-Offset.
LoWord-HiByte: Höherwertiges Byte im niederwertigen Wort im Doppelwort-Offset.
LoWord-LoByte: Niederwertiges Byte im niederwertigen Wort im Doppelwort-Offset.

Für Wort-Variablen:
HiWord: Höherwertiges Wort im Doppelwort-Offset.
LoWord: Niederwertiges Wort im Doppelwort-Offset.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Alignment"


ID_VAR_BASETYPE

Interne ID: ID_VAR_BASETYPE

IEC Datentyp

Zugrundeliegender Datentyp.

ACHTUNG: Wenn der zugrundelegende Datentyp nachträglich geändert wird, müssen alle anderen Eigenschaften des Datentyps überprüft bzw. angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ID_DataTyp"


ID_VAR_BEZEICHNUNG

Interne ID: ID_VAR_BEZEICHNUNG

Allgemein

Allgemeine Eigenschaften der Variable oder des Datentyps.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Title"


ID_VAR_BIT

Interne ID: ID_VAR_BIT

Bit-Nummer

Nummer des Bits innerhalb des eingestellten Offsets.
Minimum: 0.
Maximum: 65535.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BitAddr"


ID_VAR_BMKENNUNG

Interne ID: ID_VAR_BMKENNUNG

Betriebsmittelkennung

Beliebiger String.
Wird im Leitsystem intern nicht verwendet, steht aber beim Export von Werten zur Verfügung um eine Zuordnung der exportierten Werte für Management-Systeme (z.B. ERP) zu ermöglichen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Recourceslabel"


ID_VAR_CPLX_OFFSET

Interne ID: ID_VAR_CPLX_OFFSET

Start Offset

Startoffset für die Strukturvariable.
An diesem Offset wird mit der Adressierung der beinhalteten Variablen begonnen.
Minimum: 0.
Maximum: 4294967295.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset"


ID_VAR_DB

Interne ID: ID_VAR_DB

Datenbaustein

Nummer des Datenbausteins.
Minimum: 0.
Maximum: 4294967295.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DataBlock"


ID_VAR_DDEAKTIV

Interne ID: ID_VAR_DDEAKTIV

DDE aktiv

Aktiv: Die Variable steht anderen Windowsapplikationen zur Verfügung (z.B. Excel, Visual Basic etc.). Windows-Applikationen mit DDE-Client-Funktionalität können die Variablenwerte somit nutzen. Die Updatezeit ist 0,5 s.
Inaktiv: Die Variable steht anderen Windowsapplikationen nicht zur Verfügung.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DDEActive"


ID_VAR_DESC

Interne ID: ID_VAR_DESC

Beschreibung

Bezeichnung des Datentyps.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Description"


ID_VAR_EINHEIT

Interne ID: ID_VAR_EINHEIT

Maßeinheit

Technische Einheit der Variablen für die Darstellung zur Runtime. Wurden im Modul Einheiten bereits Basiseinheiten erstellt, stehen diese in einer Dropdownliste zur Auswahl zur Verfügung.
Maximum: 50 Zeichen.
Default: leer.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Unit"


ID_VAR_ERSATZ

Interne ID: ID_VAR_ERSATZ

Archivfüllwert

Dieser Wert wird verwendet, um zyklische Archive aufzufüllen. Wenn es dort Zeitbereiche gibt, zu denen es keine Verbindung zur Hardware gab, wird dieser Wert verwendet, solange noch kein Wert von der Hardware übertragen wurde. Sonst wird der der zuletzt gültige Wert zum Auffüllen verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlternateValue"


ID_VAR_EXTERN

Interne ID: ID_VAR_EXTERN

Externe Einstellungen

Externe Eigenschaften für zenon Logic. Betrifft nur Variablen, die nicht vom straton-Treiber sind.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "External"


ID_VAR_GW_AKTIV

Interne ID: ID_VAR_GW_AKTIV

Grenzwert aktiv

Aktiv: Der Grenzwert wird in der Runtime berücksichtigt.
Inaktiv: Der Grenzwert wird in der Runtime ignoriert.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Active"


ID_VAR_GW_ALARM

Interne ID: ID_VAR_GW_ALARM

In Alarmmeldeliste

Aktiv: Bei einer Grenzwertverletzung wird ein Eintrag in der Alarmmeldeliste erstellt.
Inaktiv: In der Alarmmeldeliste wird kein Eintrag erstellt.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Alarm"


ID_VAR_GW_ALARMVERW

Interne ID: ID_VAR_GW_ALARMVERW

Aufruf über Button im Bild Alarmmedeliste

Nur verfügbar, wenn der Grenzwert ein Alarm ist:
Aktiv: Die verknüpfte Funktion wird im Onlinebetrieb nicht spontan ausgeführt, sondern erst bei der Betätigung des Buttons "Funktion" in der Alarmliste.
Inaktiv: Die Funktion wird spontan ausgeführt, sobald der Alarm auftritt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML_Call"


ID_VAR_GW_AMLCEL

Interne ID: ID_VAR_GW_AMLCEL

AML/CEL

Eigenschaften für die Alarm- und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AML_CEL"


ID_VAR_GW_BLINKEN

Interne ID: ID_VAR_GW_BLINKEN

Blinken

Aktiv: Dynamische Elemente, die mit dieser Variable verknüpft sind, beginnen zu blinken, sobald dieser Grenzwert verletzt wird.
Das Blinken kann durch einen rechten Doppelklick quittiert werden.
Inaktiv: Kein Blinken wird durch diesen Grenzwert hervorgerufen.
Default: inaktiv.
Achtung: In Kombination mit der Eigenschaft Verzögerungszeit [s] wirkt sich diese Eigenschaft im Netzwerk folgendermaßen aus:
Grenzwert mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Grenzwert mit Blinken und Verzögerung: Verknüpfte Elemente blinken nur am Server, nicht aber auf den Clients.
Alarm mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Alarm mit Blinken und Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.

Interne ID: ID_VAR_GW_BLINKEN

Verzögerungszeit [s]

Zeitspanne in Sekunden, in der die Grenzwertverletzung anstehen muss. Der Wert muss mindestens die angegebene Zeitspanne ununterbrochen anstehen, damit die definierten Aktionen der Grenzwertverletzung ausgelöst werden.
AML/CEL:
- Als Zeitstempel für die Grenzwertverletzung in der AML und/oder der CEL wird der Zeitpunkt der ersten Verletzung verwendet.
- Als Wert wird der erste Wert nach der Verzögerungszeit eingetragen, also nicht der Alarm auslösende Wert.

ACHTUNG: In Kombination mit der Eigenschaft Blinken wirkt sich diese Eigenschaft im Netzwerk folgendermaßen aus:
Grenzwert mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Grenzwert mit Blinken und Verzögerung: Verknüpfte Elemente blinken nur am Server, nicht aber auf den Clients.
Alarm mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Alarm mit Blinken und Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.

Minimum: 0
Maximum: 4294967295
Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Blinking"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Blinking"


ID_VAR_GW_CEL

Interne ID: ID_VAR_GW_CEL

In Chronologische Ereignisliste

Aktiv: Im Fall einer Grenzwertverletzung wird ein Eintrag in der Chronologischen Ereignisliste (CEL) erstellt.
Inaktiv: Kein Eintrag in der Chronologischen Ereignisliste wird erstellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Cel"


ID_VAR_GW_DEL

Interne ID: ID_VAR_GW_DEL

{Grenzwert löschen}

Der Grenzwert wird gelöscht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DelLimit"


ID_VAR_GW_DRUCKEN

Interne ID: ID_VAR_GW_DRUCKEN

Drucken

Aktiv: Alarm oder Grenzwertverletzung wird für diese Variable je nach Einstellung in Eigenschaft Ausdruck für in der Gruppe AML und CEL der Prjekteigenschaften online gedruckt.
Inaktiv: Kein Online-Ausdruck.
Default: inaktiv

Interne ID: ID_VAR_GW_DRUCKEN

AML und CEL

Eigenschaften für die Alarmierung und Chronologische Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Print"

Interne ID: ID_VAR_GW_DRUCKEN

Ausdruck für

Nur verfügbar bei aktiver Eigenschaft Drucken aktiv.
Ermöglicht die Wahl, ob AMl oder CEL online gedruckt werden. Es kann immer nur eine der beiden Listen gedruckt werden.

Interne ID: ID_VAR_GW_DRUCKEN

Drucken aktiv

Aktiv: Chronologische Ereignisliste (CEL) oder Alarmmeldeliste (AML) wird online gedruckt: Bei jedem Eintrag in die AML bzw. CEL wird das Ereignis an den in den Projekteigenschaften definierten Drucker gesendet.
Inaktiv: Kein Online-Ausdruck findet statt.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Print"

Alarmmeldeliste: Die Alarmmeldeliste (AML) wird online gedruckt.
Chronologische Ereignisliste: Die Chronologische Ereignisliste (CEL) wird online gedruckt.
Default: Alarmmeldeliste

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Print"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Print"


ID_VAR_GW_FARBE

Interne ID: ID_VAR_GW_FARBE

Grenzwertfarbe

Farbinformation für die Symboleinfärbung und die Zustandsfarbe bei der Verwendung der Variablen im Binärelement; die Farbdefinition der Alarmtexte in der Alarmmeldeliste erfolgt in der Alarm/Ereignis-Klassendefinition

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Color"


ID_VAR_GW_FKT

Interne ID: ID_VAR_GW_FKT

Funktion

Eigenschaften für die verknüpfte Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function_root"


ID_VAR_GW_FUNKTION

Interne ID: ID_VAR_GW_FUNKTION

Funktion

Funktion, die in der Runtime automatisch ausgeführt werden soll, wenn der Grenzwert verletzt wird.
Ist der Zustand als Alarm definiert, kann die spontane Funktionsausführung unterbunden werden (Option "Aufruf über die Alarm-Verwaltung").
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


ID_VAR_GW_GRENZWERT

Interne ID: ID_VAR_GW_GRENZWERT

Grenzwert

Nur verfügbar, wenn kein dynamischer Grenzwert definiert ist:
Definiert den Wert, ab welchem der Grenzwert verletzt ist.
Ob Werte darüber oder darunter eine Verletzung auslösen, wird bei der Eigenschaft "Minimum / Maximum" festgelegt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LimitValue"


ID_VAR_GW_GRP1

Interne ID: ID_VAR_GW_GRP1

Grenzen

Eigenschaften für die Berechnung des Grenzwerts.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Ranges"


ID_VAR_GW_GRUPPE

Interne ID: ID_VAR_GW_GRUPPE

Alarm/Ereignis-Gruppe

Zuweisung einer Alarm/Ereignis-Gruppe (max. 65535) für den Grenzwert bei Verwendung als Alarm.
Die Zuordnung zu einer Alarm/Ereignis-Gruppen erfolgt durch Selektion in der Liste.
Default: 0 - (nicht verwendet).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Group"


ID_VAR_GW_HILFE

Interne ID: ID_VAR_GW_HILFE

Hilfe-Datei

Nur verfügbar, wenn der Grenzwert ein Alarm ist:
Datei (*.chm), aus der ein Hilfe-Kapitel für diesen Alarm in der Alarmliste angezeigt werden soll.
Wird hier die Zeichenfolge $PRG:xxxxxx eingegeben und die Elektroplan-Anbindung ist lizenziert, wird anstatt der Hilfe das Elektroplanprogramm mit dem angegebenen Parameter xxxxxx gestartet. Die Eigenschaft Hilfe-Kapitel wird ignoriert, darf aber nicht leer sein.
Der EXE-Pfad des Elektroplan-Programms wird in der Datei zenOn6.ini im Eintrag EDOC_PATH in Sektion [PATH] definiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HelpFile"


ID_VAR_GW_HILFEKAP

Interne ID: ID_VAR_GW_HILFEKAP

Hilfe-Kapitel

Nur verfügbar, wenn der Grenzwert ein Alarm ist:
Hilfe-Kapitel, das für diesen Alarm in der Alarmliste angezeigt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HelpCapture"


ID_VAR_GW_HLP

Interne ID: ID_VAR_GW_HLP

Hilfe

Eigenschaften für das verknüpfte Hilfekapitel.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Help_root"


ID_VAR_GW_KLASSE

Interne ID: ID_VAR_GW_KLASSE

Alarm/Ereignis-Klasse

Zuweisung einer Alarm/Ereignis-Klasse (max. 65535) für den Grenzwert bei Verwendung als Alarm.
Die Alarm/Ereignis-Klassenzuordnung erfolgt durch Selektion in der Liste.
Default: 0 - (nicht verwendet).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Class"


ID_VAR_GW_KOMMENTAR

Interne ID: ID_VAR_GW_KOMMENTAR

Kommentar erforderlich

Nur verfügbar, wenn Eigenschaft Quittierpflichtig aktiv ist.

Interne ID: ID_VAR_GW_KOMMENTAR

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmComment"

Aktiv: Bevor ein Alarm quittiert werden kann, muss ein Kommentar eingegeben werden. Der Benutzer muss dazu über die Funktionsberechtigung Alarm Kommentar eingeben verfügen.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmComment"


ID_VAR_GW_LOESCHEN

Interne ID: ID_VAR_GW_LOESCHEN

Löschpflichtig

Nur verfügbar bei aktiver EigenschaftQuittierpflichtig .
Aktiv: Der Alarm muss quittiert und gelöscht werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Kein Löschen erforderlich.
Default: inaktiv

Interne ID: ID_VAR_GW_LOESCHEN

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmDelete"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmDelete"


ID_VAR_GW_MINMAX

Interne ID: ID_VAR_GW_MINMAX

Minimum/Maximum

Minimum: Grenzwertverletzung beim Erreichen oder Unterschreiten des definierten Grenzwertes.
Maximum: Grenzwertverletzung beim Erreichen oder Überschreiten des definierten Grenzwertes.
Default: Minimum.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsMax"


ID_VAR_GW_NEW

Interne ID: ID_VAR_GW_NEW

{Grenzwert neu}

Ein neuer Grenzwert wird angelegt.
Bis zu 65535 Grenzwerte sind möglich.
Bit-Variablen haben immer zwei Grenzwerte.
Grenzwerte für String-Variablen sind nicht möglich. Stattdessen kann hier (wie bei anderen Variablen auch) eine Reaktionsmatrix verwendet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NewLimit"


ID_VAR_GW_QUITTIEREN

Interne ID: ID_VAR_GW_QUITTIEREN

Quittierpflichtig

Nur verfügbar für Alarme.
Aktiv: Der Alarm muss quittiert werden, bevor er aus dem Ringpuffer entfernt wird.
Inaktiv: Keine Quittierung erforderlich.
Default bei Alarmen: aktiv, sonst inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlarmAcknowledge"


ID_VAR_GW_SCHWELLWERT

Interne ID: ID_VAR_GW_SCHWELLWERT

Schwellwert

Es kann ein Schwellwert eingegeben werden, der für das Gehen eines Grenzwertes eingesetzt wird. Ungewollte Reaktionen bei flatternden numerischen Werten können somit vermieden werden.
Beispiel 1: Maximalwert = 900, Schwellwert = 10, ergibt 890
Grenzwert ist verletzt ab einem Wert 900 und verlässt den kritischen Bereich wieder, wenn er unter 890 geht.
Beispiel 2: Minimalwert = 900, Schwellwert = 10, ergibt 910
Grenzwert ist verletzt ab einem Wert 900 und verlässt den kritischen Bereich wieder, wenn er über 910 geht.
Im Unterschied zur Hysterese beeinflusst diese Eigenschaft nicht die Darstellung des Wertes, sondern nur das Alarmverhalten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ThresholdValue"


ID_VAR_GW_TEXT

Grenzwerttext

Dieser Text wird zur Runtime bei Grenzwertverletzungen, je nach Einstellung, in der Alarmmeldeliste, der Chronologischen Ereignisliste und/oder der Alarmstatuszeile ausgegeben.

Dynamischer Grenzwerttext: erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen und der Reaktionsmatrizen einzufügen. Dabei lässt sich auch ein fixer Text über einen Index mit Schlüsselwörter aus einer Sprachtabelle verknüpfen. Das führt zu einigen Begrenzungen:
Statischer Text wird im Speicherbereich für den Grenzwert abgelegt, wofür maximal 128 Zeichen zur Verfügung stehen. Die Werte der veknüpften Variablen werden im Speicherbereich für den Kommentartext abgelegt, begrenzt auf maximal 80 Zeichen.

Die Begrenzungen kann umgangen werden durch die Erweiterung für lange dynamische Grenzwerttexte. Aktivieren Sie dazu Lange dynamische Grenzwerttexte CEL bzw. Lange dynamische Grenzwerttexte AML. Variablenwerte für dynamische Grenzwerttexte werden dann in eine eigene Datei ausgelagert. Achtung: Bei der Verwendung von dynamischen Grenzwerten kann kein Kommentar eingegeben werden.

Interne ID: ID_VAR_GW_TEXT

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text"

Interne ID: ID_VAR_GW_TEXT

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text"


ID_VAR_GW_UNSICHTBAR

Interne ID: ID_VAR_GW_UNSICHTBAR

Unsichtbar

Aktiv: Zustand wird im dynamischen Element "Zustandselement" nicht dargestellt oder Elemente werden nicht dargestellt, wenn ihre Sichtbarkeit über diese Variable gesteuert wird.
Inaktiv: Die Sichtbarkeit wird nicht durch die Grenzwertverletzung beeinflusst.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Invisible"


ID_VAR_GW_VARIABEL

Interne ID: ID_VAR_GW_VARIABEL

Dynamischer Grenzwert aktiv

Steuert, ob der Grenzwert fix definiert ist oder über eine Variable dynamisch festgelegt wird.

aktiv: Der Grenzwert wird nicht über eine feste technische Wertzuordnung definiert sondern über den technischen Wert einer anderen Variablen.

AML/CEL: Als Zeitstempel für die Grenzwertverletzung in der AML und/oder der CEL wird der jüngere Zeitstempel der beiden Variablen benutzt

Default: inaktiv

ACHTUNG: Ändert sich der variable Grenzwert, so dass der aktuelle Wert der Variable ohne Änderung dann im verletzten Bereich liegt, wird auch eine Grenzwertverletzung ausgelöst.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsVariable"


ID_VAR_GW_VARIABLE

Interne ID: ID_VAR_GW_VARIABLE

Variable

Nur verfügbar, wenn der dynamische Grenzwert aktiv ist:
Variable, die als dynamischer Grenzwert verwendet werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"


ID_VAR_GW_VERZOEGEUNG

Interne ID: ID_VAR_GW_VERZOEGEUNG

Verzögerungszeit [s]

Zeitspanne in Sekunden, in der die Grenzwertverletzung anstehen muss. Der Wert muss mindestens die angegebene Zeitspanne ununterbrochen anstehen, damit die definierten Aktionen der Grenzwertverletzung ausgelöst werden.
AML/CEL:
- Als Zeitstempel für die Grenzwertverletzung in der AML und/oder der CEL wird der Zeitpunkt der ersten Verletzung verwendet.
- Als Wert wird der erste Wert nach der Verzögerungszeit eingetragen, also nicht der Alarm auslösende Wert.

ACHTUNG: In Kombination mit der Eigenschaft Blinken wirkt sich diese Eigenschaft im Netzwerk folgendermaßen aus:
Grenzwert mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Grenzwert mit Blinken und Verzögerung: Verknüpfte Elemente blinken nur am Server, nicht aber auf den Clients.
Alarm mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Alarm mit Blinken und Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.

Interne ID: ID_VAR_GW_VERZOEGEUNG

Blinken

Aktiv: Dynamische Elemente, die mit dieser Variable verknüpft sind, beginnen zu blinken, sobald dieser Grenzwert verletzt wird.
Das Blinken kann durch einen rechten Doppelklick quittiert werden.
Inaktiv: Kein Blinken wird durch diesen Grenzwert hervorgerufen.
Default: inaktiv.
Achtung: In Kombination mit der Eigenschaft Verzögerungszeit [s] wirkt sich diese Eigenschaft im Netzwerk folgendermaßen aus:
Grenzwert mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Grenzwert mit Blinken und Verzögerung: Verknüpfte Elemente blinken nur am Server, nicht aber auf den Clients.
Alarm mit Blinken und ohne Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.
Alarm mit Blinken und Verzögerung: Verknüpfte Elemente blinken am Server und auf den Clients.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Delay"

Minimum: 0
Maximum: 4294967295
Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Delay"


ID_VAR_GW_ZUSATZ_ATTRIB

Interne ID: ID_VAR_GW_ZUSATZ_ATTRIB

Zusatzattribute

Zusätzliche Eigenschaften für den Grenzwert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AddAttrib"


ID_VAR_HDAKTIV

Interne ID: ID_VAR_HDAKTIV

Harddisk Datenspeicherung aktiv

Aktiv: Variablenwerte werden auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element "Trendelement" oder den Export/Import der Werte gespeichert.

Inaktiv: Keine Variablenwerte werden gespeichert.

Default: inaktiv.

Die HD-Daten brauchen je gespeicherten HD-Wert 24 Bytes Platz, unabhängig vom zu speichernden Variablentyp. Neben dem Wert werden noch folgende Informationen gespeichert:
- Zeit, zu der der Wert gemessen wurde.
- Millisekunden beim Einlesen des Wertes.
- Status des Wertes um Elemente entsprechend anzupassen.
- Zähler für eindeutige Kennung des Wertes (Spontantreiber).

Hinweis: Die Datenspeicherung wird auch bei der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend aktiviert, wenn Onlinedaten ausgewertet werden.
Variablen vom Typ String werden von der Harddisk-Datenspeicherung nicht unterstützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HDActive"


ID_VAR_HDRDA

Interne ID: ID_VAR_HDRDA

Aufzeichnungsart

Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
Harddisk-Daten (zyklisch): Zyklisches Schreiben der Werte auf die Festplatte.
Nachsortierte Werte (RDA): Die Werte werden blockweise vom Treiber auf die Festplatte geschrieben. (Für Post-Mortem-Analyse bei Fehler auf der Steuerung geeignet.)

Interne ID: ID_VAR_HDRDA

Harddisk Datenspeicherung aktiv

Aktiv: Variablenwerte werden auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element "Trendelement" oder den Export/Import der Werte gespeichert.

Inaktiv: Keine Variablenwerte werden gespeichert.

Default: inaktiv.

Die HD-Daten brauchen je gespeicherten HD-Wert 24 Bytes Platz, unabhängig vom zu speichernden Variablentyp. Neben dem Wert werden noch folgende Informationen gespeichert:
- Zeit, zu der der Wert gemessen wurde.
- Millisekunden beim Einlesen des Wertes.
- Status des Wertes um Elemente entsprechend anzupassen.
- Zähler für eindeutige Kennung des Wertes (Spontantreiber).

Hinweis: Die Datenspeicherung wird auch bei der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend aktiviert, wenn Onlinedaten ausgewertet werden.
Variablen vom Typ String werden von der Harddisk-Datenspeicherung nicht unterstützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsKDAActiv"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsKDAActiv"


ID_VAR_HDUPDATE

Interne ID: ID_VAR_HDUPDATE

Zykluszeit [s]

Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
Intervallzeit [in Sekunden] für die Ablage von Onlinewerten auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element Trend, für Onlinedaten im Erweiterten Trend oder den Export/Import der Werte.

Interne ID: ID_VAR_HDUPDATE

Harddisk Datenspeicherung aktiv

Aktiv: Variablenwerte werden auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element "Trendelement" oder den Export/Import der Werte gespeichert.

Inaktiv: Keine Variablenwerte werden gespeichert.

Default: inaktiv.

Die HD-Daten brauchen je gespeicherten HD-Wert 24 Bytes Platz, unabhängig vom zu speichernden Variablentyp. Neben dem Wert werden noch folgende Informationen gespeichert:
- Zeit, zu der der Wert gemessen wurde.
- Millisekunden beim Einlesen des Wertes.
- Status des Wertes um Elemente entsprechend anzupassen.
- Zähler für eindeutige Kennung des Wertes (Spontantreiber).

Hinweis: Die Datenspeicherung wird auch bei der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend aktiviert, wenn Onlinedaten ausgewertet werden.
Variablen vom Typ String werden von der Harddisk-Datenspeicherung nicht unterstützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HDUpdate"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HDUpdate"


ID_VAR_HDWERTE

Interne ID: ID_VAR_HDWERTE

Anzahl Werte

Nur verfügbar, wenn die Eigenschaft Harddisk Datenspeicherung aktiv aktiv ist:
Werteanzahl für die Ablage von Onlinewerten auf der Festplatte (Ringspeicher) für die Auswertung im Dynamischen Element Trend, für Onlinedaten im Erweiterten Trend oder den Export/Import der Werte.

Interne ID: ID_VAR_HDWERTE

Harddisk Datenspeicherung aktiv

Aktiv: Variablenwerte werden auf der Festplatte (Ringspeicher) für die Auswertung im dynamischen Element "Trendelement" oder den Export/Import der Werte gespeichert.

Inaktiv: Keine Variablenwerte werden gespeichert.

Default: inaktiv.

Die HD-Daten brauchen je gespeicherten HD-Wert 24 Bytes Platz, unabhängig vom zu speichernden Variablentyp. Neben dem Wert werden noch folgende Informationen gespeichert:
- Zeit, zu der der Wert gemessen wurde.
- Millisekunden beim Einlesen des Wertes.
- Status des Wertes um Elemente entsprechend anzupassen.
- Zähler für eindeutige Kennung des Wertes (Spontantreiber).

Hinweis: Die Datenspeicherung wird auch bei der Bildumschaltung auf ein Bild vom Typ Erweiterter Trend aktiviert, wenn Onlinedaten ausgewertet werden.
Variablen vom Typ String werden von der Harddisk-Datenspeicherung nicht unterstützt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HDSize"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HDSize"


ID_VAR_HYSTERESE

Interne ID: ID_VAR_HYSTERESE

Hysterese

Eigenschaften für die Hysterese.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Hysteresis"


ID_VAR_HYSTNEG

Interne ID: ID_VAR_HYSTNEG

Negativ für Signal

Hysterese für Grenzwert bezogen auf Signalbereich.

Hysteresebereich für Eintrag bei abnehmender Wertänderung. Werte werden nur dann als Grenzwertverletzung interpretiert, wenn die Änderung unter dem hier eingestellten Hysteresebereich liegt.
Default: 0 (keine Hysterese)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HystNeg"


ID_VAR_HYSTPOS

Interne ID: ID_VAR_HYSTPOS

Positiv für Signal

Hysterese für Grenzwert bezogen auf Signalbereich.

Hysteresebereich für Eintrag bei zunehmender Wertänderung. Werte werden nur dann als Grenzwertverletzung interpretiert, wenn die Änderung über dem hier eingestellten Hysteresebereich liegt.
Default: 0 (keine Hysterese)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HystPos"


ID_VAR_INTERN_INITIALWERT

Interne ID: ID_VAR_INTERN_INITIALWERT

Initialwert

Der hier definierte Wert wird beim Start der Runtime als aktueller Wert der Variable verwendet, wenn die Eigenschaft "Remanenz" auf "Initialwert" gesetzt ist..

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Initial_value"


ID_VAR_INTERN_LOKAL

Interne ID: ID_VAR_INTERN_LOKAL

Berechnung

Lokal: Die interne Variable wird bei Netzwerk-Projekten lokal d.h. auf dem Client ausgewertet bzw. verwaltet.
D.h. der Wert der Variable kann auf jedem Client unterschiedlich sein und auch die Grenzwerte werden lokal ausgewertet.
Netzwerk: Die interne Variable wird bei Netzwerk-Projekten auf dem Server des Projekts ausgewertet bzw. verwaltet. Sie hat auf dem Server und auf allen Clients denselben Wert.
Default: lokal.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Local"


ID_VAR_INTERN_REMANENZ

Interne ID: ID_VAR_INTERN_REMANENZ

Remanenz

Aus: Beim Start der Runtime wird der Ersatzwert der Variable bzw. bei String-Variablen ein leerer String als Startwert verwendet.
Initialwert: Der Startwert wird auf den in der Eigenschaft "Initialwert" angegebenen Wert gesetzt.
Remanent: Der letzte Wert der Variablen wird beim Neustart der Runtime als Startwert verwendet.
Default: aus.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Remanenz"


ID_VAR_KANALTYP

Interne ID: ID_VAR_KANALTYP

Treiber-Objekttyp

Abhängig vom verwendeten Teiber wird bei der Erstellung der Variable ein Objekttyp ausgewählt und kann hier später geändert werden.
Siemens: Datenbaustein, Merker, Ein-/Ausgang.
Modbus: Coil und Holding Register.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ID_DriverTyp"


ID_VAR_KENNUNG

Interne ID: ID_VAR_KENNUNG

Kennung

Frei definierbarer String für die Identifikation der Variable oder des Datentyps.

Beispiel: Kann bei der Online-Sprachumschaltung anstatt des Variablennamens verwendet werden, da dieser nicht sprachumschaltbar ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Tagname"


ID_VAR_LBOUND

Interne ID: ID_VAR_LBOUND

Startindex

Wählen Sie den Startindex des Arrays aus der Dropdown-Liste aus.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LBound"


ID_VAR_LINANPASS

Interne ID: ID_VAR_LINANPASS

Wertanpassung linear

Lineare Wertanpassung über Messbereich.
Einstellungen zur linearen Umrechnung der SPS-Werte in Visualisierungswerte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LinAdjust"


ID_VAR_LOCKING

Interne ID: ID_VAR_LOCKING

Befehlsgruppe

Verknüpfung einer Befehlsgruppe zu dieser Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Locking"


ID_VAR_MAKROHARDWARE

Interne ID: ID_VAR_MAKROHARDWARE

AdjustHardwareValue

Nur verfügbar, wenn nicht-lineare Wertanpassung aktiv ist:
Makro wird bei jeder Änderung des Rohwertes (SPS) aufgerufen um den Wert im Leitsystem upzudaten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AdjustHardware"


ID_VAR_MAKROZENON

Interne ID: ID_VAR_MAKROZENON

AdjustScadaValue

Nur verfügbar, wenn nicht-lineare Wertanpassung aktiv ist:
Makro wird beim Absetzen eines Leitsystem Wertes aufgerufen um den Rohwert (SPS) zu aktualisieren.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AdjustZenon"


ID_VAR_MAXGRADIENT

Interne ID: ID_VAR_MAXGRADIENT

Maximaler Gradient

Nur verfügbar in SICAM 230.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxGradient"


ID_VAR_MESSMAX

Interne ID: ID_VAR_MESSMAX

Messbereich max.

Maximaler Wert der Variablen im Leitsystem.
Wenn nicht durch die Wertanpassung nichtlinear anders definiert, wird der Rohwert der Variablen (Signalauflösung) für die Verwendung im Leitsystem immer linear in den Messbereich umgerechnet. Alle weiteren numerischen Werteingaben für die Variable in Editor und Runtime beziehen sich auf den Messbereich (z.B. Definition von Grenzwerten, Sollwertgrenzen, Darstellungsbereich, Sollwertvorgaben, ...).

Interne ID: ID_VAR_MESSMAX

Wertanpassung nichtlinear

Nicht-lineare Wertanpassung über VBA Makros.
Eigenschaften für die nicht-lineare Umrechnung der SPS-Werte in Visualisierungswerte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RangeMax"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RangeMax"


ID_VAR_MESSMIN

Interne ID: ID_VAR_MESSMIN

Messbereich min.

Minimaler Wert der Variablen im Leitsystem.
Wenn nicht durch die Wertanpassung nichtlinear anders definiert, wird der Rohwert der Variablen (Signalauflösung) für die Verwendung im Leitsystem immer linear in den Messbereich umgerechnet. Alle weiteren numerischen Werteingaben für die Variable in Editor und Runtime beziehen sich auf den Messbereich (z.B. Definition von Grenzwerten, Sollwertgrenzen, Darstellungsbereich, Sollwertvorgaben, ...).

Interne ID: ID_VAR_MESSMIN

Wertanpassung nichtlinear

Nicht-lineare Wertanpassung über VBA Makros.
Eigenschaften für die nicht-lineare Umrechnung der SPS-Werte in Visualisierungswerte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RangeMin"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RangeMin"


ID_VAR_NACHKOMMA

Interne ID: ID_VAR_NACHKOMMA

Nachkommastellen

Anzahl der Nachkommastellen des Variablenwertes für die Darstellung im Leitsystem.
Minimum: 0
Maximum: 5
Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Digits"


ID_VAR_NAME

Interne ID: ID_VAR_NAME

Name

Eindeutiger Name der Variable. Das Zeichen # ist nicht erlaubt.
Hinweis: Für Treiber, die auf einer zenon Logic Verbindung beruhen, ist ein Präfix zu beachten. Details siehe Abschnitt Anlegen von B und B Variablen in zenon Logic im Handbuch.
Änderungen des Variablennamens müssen in den Programmierumgebungen (VBA, VSTA, PCE) nachgezogen werden.

Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_VAR_NETADDR

Interne ID: ID_VAR_NETADDR

Netzadresse

Busadresse oder Netzadresse der Variable.
Minimum: 0.
Maximum: 4294967295.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NetAddr"


ID_VAR_NORMALZUSTAND

Interne ID: ID_VAR_NORMALZUSTAND

Normalwert

Wählen Sie im Dropdown-Menü, ob der Normalwert für diese Variable oder Datentyp Ein oder Aus sein soll. Verfügbar für Variablen und Datentypen vom Typ BOOL, UINT und WORD für alle Treiber.

Default: Aus

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NormalState"


ID_VAR_NORMALZUSTANDAKT

Interne ID: ID_VAR_NORMALZUSTANDAKT

Aktiv

Ermöglicht das Definieren eines Normalzustands für Variablen und Datentypen vom Typ Bool, UINT und WORD für alle Treiber.

Aktiv: Es kann ein Normalzustand definiert werden

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NormalStateActive"


ID_VAR_OFFSET

Interne ID: ID_VAR_OFFSET

Offset

Offset der Variable.
Bei linear adressierenden Steuerungen: der Speicherbereich.
Bei namensauflösenden Steuerungen: die Zuweisungsadresse.
Minimum: 0.
Maximum: 4294967295.
Default: 0.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset"


ID_VAR_OFS_SOURCE

Interne ID: ID_VAR_OFS_SOURCE

Offset-Berechnung

Selektieren Sie die gewünschte Berechnungsart für den Offset. Folgende Möglichkeiten stehen Ihnen zur Verfügung:

  • Adresse folgt Datentyp-Offset und Start-Offset
  • Automatische Adressierung
  • Manuelle Addressierung

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OfsSource"


ID_VAR_PRIORITAET

Interne ID: ID_VAR_PRIORITAET

Priorität

Wenn die globale Updatezeit in der Treiber-Konfiguration nicht verwendet wird, können dort Updatezeiten für die verschiedenen Prioritäten gesetzt werden. Hier wird einer Variable eine Priorität zugeordent.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UpdatePriority"


ID_VAR_PROP_GRP0

Interne ID: ID_VAR_PROP_GRP0

Adressierung

Eigenschaften für die Adressierung der Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Address"


ID_VAR_PROP_GRP1

Interne ID: ID_VAR_PROP_GRP1

Wertberechnung

Definition des Wertebereichs der Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Value"


ID_VAR_PROP_GRP2

Interne ID: ID_VAR_PROP_GRP2

Zusätzliche Einstellungen

Erweiterte Eigenschaften für die Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Extended"


ID_VAR_PROP_GRP3

Interne ID: ID_VAR_PROP_GRP3

Harddisk Datenspeicherung

Eigenschaften für das Speichern von Variablenwerten auf der Festplatte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HardDisk"


ID_VAR_PROP_GRP4

Interne ID: ID_VAR_PROP_GRP4

Grenzwerte

Eigenschaften zum Grenzwertverhalten bzw. Alarmverhalten der Variable.

Eigenschaften dieser Gruppe stehen nur zur Verfügung, wenn Reaktionsmatrix aktiv nicht aktiviert ist.

Interne ID: ID_VAR_PROP_GRP4

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Limits"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Limits"


ID_VAR_PROP_GRP7

Interne ID: ID_VAR_PROP_GRP7

Protokollierung in CEL

Eigenschaften für die Protokollierung in der Chronologischen Ereignisliste (CEL).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueProtocol"


ID_VAR_PROP_GRP8

Interne ID: ID_VAR_PROP_GRP8

Alarmbehandlung

Eigenschaften für die Quittiervariable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Alarmhandling"


ID_VAR_PROP_GRP9

Interne ID: ID_VAR_PROP_GRP9

Bildalarmierung

Nur verfügbar in SICAM 230:
Eigenschaften für die Bildalarmierung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PictureAlarm"


ID_VAR_PROP_GRP10

Interne ID: ID_VAR_PROP_GRP10

Normalzustand

Eigenschaften für den Normalzustand einer Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NormalState"


ID_VAR_PROP_GRP11

Interne ID: ID_VAR_PROP_GRP11

Interne Variable

Eigenschaften für interne Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InternalVariable"


ID_VAR_PROP_GRP12

Interne ID: ID_VAR_PROP_GRP12

Systemtreibervariable

Eigenschaften für Systemtreiber Variablen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InternalVariable"


ID_VAR_PROP_GRP_GOOSE

Interne ID: ID_VAR_PROP_GRP_GOOSE

GOOSE

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE"


ID_VAR_READWRITE

Interne ID: ID_VAR_READWRITE

SW setzen aktiv

Aktiv: Diese Variable für "Sollwert setzen" Aktionen freigeben.
Inaktiv: Diese Variable ist schreibgeschützt.
Default: aktiv

Wenn Sollwerte über die Befehlsgabe und eine Rückmeldevariable im Dynamische Element Combi-Element gesetzt werden, können sie unabhängig von der Einstellung der Eigenschaft SW setzen aktiv gesetzt werden. Alle Aktionsbuttons im Bild Befehlsgabe, die eine direkte Modifikation der Rückmeldevariablen auslösen, sind dann auf unsichtbar gesetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InOut"


ID_VAR_REMA

Interne ID: ID_VAR_REMA

Reaktionsmatrix

Mithilfe der Dropdownliste wählen Sie für die selektierte Variable eine verfügbare Reaktionsmatrix aus. Wenn Sie keine Reaktionsmatrix verwenden möchte, selektieren Sie den Eintrag <keine verwenden>.

Default: <keine verwenden>

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Rema"


ID_VAR_REMA_KNOTEN

Interne ID: ID_VAR_REMA_KNOTEN

Reaktionsmatrix

Eigenschaften für die Verwendung einer Reaktionsmatrix für die Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Rema"


ID_VAR_REMAAKTIV

Interne ID: ID_VAR_REMAAKTIV

Reaktionsmatrix aktiv

Aktiv: Statt der Grenzwerte wird eine Reaktionsmatrix verwendet.
Inaktiv: Grenzwerte können für die Variable definiert werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "IsRemaActiv"


ID_VAR_SBO

Interne ID: ID_VAR_SBO

Select Before Operate

Achtung: Diese Funktionalität wird nur von den Treibern IEC870, IEC850 und DNP3 unterstützt und nur, wenn in der Befehlsgabe für die Eigenschaft Aktionstyp Doppelbefehl gewählt wurde.

Interne ID: ID_VAR_SBO

Aktionstyp

Nur verfügbar bei der Aktion 'Befehl':
Typ des Befehls.
Doppelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand'.
Einzelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand' Nach der 'Flankenverzögerung' wird der Wert 0 geschrieben. Dieses Schreiben ist nicht mehr Laufzeit überwacht.
Default: Einzelbefehl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SBO"

Aktiv: Bevor der Wert der Variablen in die Hardware geschrieben wird, fragt zenon ab, ob die Variable in der Hardware für die Aktion bereit ist = Select before Operate (SBO).
Achtung: Bei Einzelbefehlen wird dann das automatische Zurücksetzen des Variablenwerts nach der in der Eigenschaft Flankenverzögerung definierten Zeitspanne nicht ausgeführt.

Interne ID: ID_VAR_SBO

Flankenverzögerung

Nur verfügbar, wenn bei der Eigenschaft Aktionstyp Einzelbefehl gewählt wurde.
Nach Ablauf dieser Zeit in Millisekunden wird der Wert der Befehlsvariable - abhängig von der Schaltrichtung - auf 0 oder 1 zurückgesetzt. Das Zurücksetzen des Wertes wird nicht ausgeführt, wenn die Eigenschaft Select Before Operate der Aktionsvariable aktiviert wurde.
Minimum: 0
Maximum: 4294967295
Default: 1000
Achtung: Es wird nicht gewartet, bis die Laufzeitüberwachung beendet ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SBO"

Inaktiv: Der Wert der Variable wird ohne vorherige Rückfrage in die Hardware geschrieben = Direct execute.
Default: inaktiv
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SBO"


ID_VAR_SIGMAX

Interne ID: ID_VAR_SIGMAX

Signalbereich max.

Maximaler Wert der Variablen in der Steuerung.
Wenn nicht durch die Wertanpassung nichtlinear anders definiert, wird der Rohwert der Variablen (Signalauflösung) für die Verwendung im Leitsystem immer linear in den Messbereich umgerechnet. Alle weiteren numerischen Werteingaben für die Variable in Editor und Runtime beziehen sich auf den Messbereich (z.B. Definition von Grenzwerten, Sollwertgrenzen, Darstellungsbereich, Sollwertvorgaben, ...).

Interne ID: ID_VAR_SIGMAX

Wertanpassung nichtlinear

Nicht-lineare Wertanpassung über VBA Makros.
Eigenschaften für die nicht-lineare Umrechnung der SPS-Werte in Visualisierungswerte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SignalMax"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SignalMax"


ID_VAR_SIGMIN

Interne ID: ID_VAR_SIGMIN

Signalbereich min.

Minimaler Wert der Variablen in der Steuerung.
Wenn nicht durch die Wertanpassung nichtlinear anders definiert, wird der Rohwert der Variablen (Signalauflösung) für die Verwendung im Leitsystem immer linear in den Messbereich umgerechnet. Alle weiteren numerischen Werteingaben für die Variable in Editor und Runtime beziehen sich auf den Messbereich (z.B. Definition von Grenzwerten, Sollwertgrenzen, Darstellungsbereich, Sollwertvorgaben, ...).

Interne ID: ID_VAR_SIGMIN

Wertanpassung nichtlinear

Nicht-lineare Wertanpassung über VBA Makros.
Eigenschaften für die nicht-lineare Umrechnung der SPS-Werte in Visualisierungswerte.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SignalMin"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SignalMin"


ID_VAR_SIGNAL

Interne ID: ID_VAR_SIGNAL

Wertbereich Steuerung

Wertbereich der Variable in der Steuerung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SignalRange"


ID_VAR_SOLLMAX

Interne ID: ID_VAR_SOLLMAX

Max. Sollwert

Das hier eingestellte Maximum für "Sollwert absetzen" Aktionen kann in dynamischen Elementen übernommen werden, anstatt dass es dort separat eingestellt werden muss.
Dies empfiehlt sich vor allem, wenn sich im Messbereich der Variablen nachträglich Änderungen ergeben können, da diese Änderungen hier zentral und nicht bei jedem einzelnen Element angepasst werden können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueMax"


ID_VAR_SOLLMIN

Interne ID: ID_VAR_SOLLMIN

Min. Sollwert

Das hier eingestellte Minimum für "Sollwert absetzen" Aktionen kann in dynamischen Elementen übernommen werden, anstatt dass es dort separat eingestellt werden muss.
Dies empfiehlt sich vor allem, wenn sich im Messbereich der Variablen nachträglich Änderungen ergeben können, da diese Änderungen hier zentral und nicht bei jedem einzelnen Element angepasst werden können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueMin"


ID_VAR_STANDBY

Interne ID: ID_VAR_STANDBY

Nur von Standby anfordern

Aktiv: Der Wert der Variable vom Standby-Server wird angezeigt.
Inaktiv: Der Wert der Variable vom Server wird angezeigt.
(nur bei Hardware-Treibern)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Standby"


ID_VAR_STRINGLAENGE

Interne ID: ID_VAR_STRINGLAENGE

Stringlänge

Nur verfügbar bei String-Variablen:
Maximale Anzahl von Zeichen, die die Variable aufnehmen kann.
Minimum: 0 Zeichen.
Maximum: 65535 Zeichen.
Default: 5 Zeichen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StringLength"


ID_VAR_STRINGLAENGE2

Interne ID: ID_VAR_STRINGLAENGE2

Stringlänge

Nur verfügbar bei String-Variablen:
Maximale Anzahl von Zeichen, die die Variable aufnehmen kann.
Minimum: 0
Maximum: 65535
Default: 5

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxStringLen"


ID_VAR_SWP_ACT

Interne ID: ID_VAR_SWP_ACT

Alter und neuer Wert

Aktiv: Beim Ändern des Sollwerts dieser Variable werden der alte und der neue Wert in der Chronologischen Ereignisliste (CEL) protokolliert.
Inaktiv: Nur der neue Wert wird protokolliert.
Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SV_Act"


ID_VAR_SWP_ART

Interne ID: ID_VAR_SWP_ART

Protokollierung

Legt fest, wie das Sollwert Absetzen in der CEL protokolliert wird:

Alles: Alle "Sollwert absetzen" Aktionen dieser Variable über dynamische Elemente und "Sollwert setzen" Funktionen werden in der Chronologischen Ereignisliste (CEL) protokolliert.
Nichts: Keine "Sollwert absetzen" Aktionen werden in der CEL protokolliert.
Nur über Dyn. Element: Nur "Sollwert absetzen" Aktionen über dynamische Elemente werden in der CEL mitprotokolliert.
Default: Nur über Dyn. Element

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueProtocol"


ID_VAR_SWP_VBA

Interne ID: ID_VAR_SWP_VBA

SW setzen über VBA

Aktiv : Setzen des Sollwerts dieser Variable über ein VBA-Makro wird in der Chronologischen Ereignisliste (CEL) protokolliert.
Inaktiv: Setzen des Sollwerts dieser Variable über ein VBA-Makro wird nicht protokolliert.
Default: aktiv

Hinweis: Bei Variablen, die im IEC870 process gateway als Befehlsvariable konfiguriert sind, wird bei aktiver Eigenschaft jeden Befehl als Sollwert Absetzen über die COM-Schnittstelle in der CEL protokolliert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SV_VBA"


ID_VAR_TREIBER

Interne ID: ID_VAR_TREIBER

Treiber

Treiber für die Variable. Dieser wird beim Erstellen der Variable ausgewählt und kann hier später verändert werden.

Hinweis: Treiber für zenon Logic Projekte können nachträglich nicht mehr verändert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Driver"


ID_VAR_TYPE

Interne ID: ID_VAR_TYPE

Datentyp

Datentyp der Variable; wird beim Erstellen der Variable ausgewählt und kann hier später verändert werden.

ACHTUNG: Wenn der Datentyp nachträglich geändert wird, müssen alle anderen Eigenschaften der Variable überprüft bzw. angepasst werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ID_DataTyp"


ID_VAR_USEMAKRO

Interne ID: ID_VAR_USEMAKRO

Nicht-lineare Wertanpassung über Makros

Die nicht-lineare Wertanpassung wird bei Variablen verwendet, deren Rohwert (Steuerung) sich nicht linear in den Messwert (Leitsystem) skalieren lässt.
Aktiv: Rohwerte werden nicht-linear (mit VBA Makros) auf Leitsystemwerte skaliert.
Nach Aktivierung der Option “Nicht-lineare Wertanpassung” sind die VBA Makros für die Umrechnung unter "AdjustHardwareValue" und "AdjustZenOnValue" anzugeben.
Inaktiv: Rohwerte werden linear auf Leitsystemwerte skaliert.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseMacro"


ID_VAR_WERTATTRIB

Interne ID: ID_VAR_WERTATTRIB

Wertattribute

Eigenschaften für die Wertattribute der Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueAttrib"


ID_VAR_ZWREMANR

Interne ID: ID_VAR_ZWREMANR

Zählergruppe

Nur verfügbar in SICAM 230.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CounterGroup"


ID_VARGROUP

Interne ID: ID_VARGROUP

Extern Variablengruppe

Externe Eigenschaft für zenon Logic. Betrifft nur Variablen, die nicht vom straton32-Treiber sind.
Variablengruppe in zenon Logic ("Global" oder "Retain" oder leer).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Vargroup"


ID_VARINASM

Interne ID: ID_VARINASM

In IPA-Datenbank speichern

Aktiv: Die Alarme dieser Variable sind für die Auswertung im Industrial Performance Analyzer (IPA) verfügbar.
Inaktiv: Die Alarme dieser Variable werden bei der Auswertung im Industrial Performance Analyzer nicht berücksichtigt.
Default: inaktiv

Achtung: Der Industrial Performance Analyzer ist ein optionales Modul und muss lizenziert sein, um verwendet werden zu können.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarInASM"


ID_VERRIEG_CBTR_FORMULA

Interne ID: ID_VERRIEG_CBTR_FORMULA

Erkennungsunterdrückung

Eingabe der Formel, mit der die Erkennung eines Schalterfalls unterdrückt wird. Klick auf die Schaltfläche ... öffnet den Formeleditor.

Für die Formel können alle Variablen der Verriegelung verwendet werden, Namensersetzungen wie bei der Definition der Verriegelungsbedingungen einer Aktion sind möglich.

Hinweis: Variablen, die in der Formel verwendet werden, können bei der Verriegelung nicht gelöscht werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CBTR_Formula"


ID_VERRIEG_CBTR_MONITORED

Interne ID: ID_VERRIEG_CBTR_MONITORED

Schalterfallerkennung

Steht nur zur Verfügung, wenn die Eigenschaft Set status PROGRESS aktiviert ist.

Interne ID: ID_VERRIEG_CBTR_MONITORED

Set status PROGRESS

Aktiv: Bei den Aktionen Befehl und Nachführen wird das Statusbit In Bearbeitung (PROGRESS) bei der Rückmeldevariable gesetzt, wenn die Aktionen in der Runtime angestoßen werden.
Das Bit dient dazu eine grafische Anzeige zu realisieren, um dem Benutzer anzuzeigen, dass gerade eine Aktion ausgeführt wird. Mit Hilfe eines Combielements oder einer Reaktionsmatrix können Sie das Statusbit abfragen und eine grafische Anzeige umsetzen.

Inaktiv: Das Statusbit wird nicht gesetzt.

Default: inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CBTR_Act"

Aktiv: Überwacht Rückmeldevariable auf unerwarteten Wertwechsel von <> 0 auf 0.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CBTR_Act"


ID_VERRIEG_PROP1

Interne ID: ID_VERRIEG_PROP1

Name

Eindeutiger Name der Verriegelung oder Befehlsgabe.
Default: Verriegelung/Befehlsgruppe x (wobei x eine fortlaufende Zahl ist).
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch zum Erstellen einer:

- Verriegelung

- Befehlsgabe

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_VERRIEG_PROP2

Interne ID: ID_VERRIEG_PROP2

Aktionsvariable

Name der mit der Befehlsgruppe verknüpften Variablen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_VERRIEG_PROP3

Interne ID: ID_VERRIEG_PROP3

Variablenname der Rückmeldung

Variablenname bzw. die Maske für das Ersetzen der Rückmeldevariable.
Ein im Namen vorkommendes Sternchen (*) dient als Platzhalter für den Ersetzungstext. Es kann nur ein Platzhalter im Namen verwendet werden. Bei der Eingabe der Maske ist darauf bedacht zu nehmen, dass dieser Name bei der Ersetzung auch einen vorhandenen Variablennamen ergibt.
Wenn die hier verwendete Variable (ersetzt oder absolut) zum Zeitpunkt des Erzeugens der Runtime Dateien nicht vorhanden ist, steht diese Befehlsgruppe in der Runtime nicht zur Verfügung. Eine entsprechende Meldung weist beim Erzeugen von Runtime Dateien auf diesen Fehler hin.
Direkte Eingabe oder öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RückmeldVarName"


ID_VERRIEG_PROP4

Interne ID: ID_VERRIEG_PROP4

Set status PROGRESS

Aktiv: Bei den Aktionen Befehl und Nachführen wird das Statusbit In Bearbeitung (PROGRESS) bei der Rückmeldevariable gesetzt, wenn die Aktionen in der Runtime angestoßen werden.
Das Bit dient dazu eine grafische Anzeige zu realisieren, um dem Benutzer anzuzeigen, dass gerade eine Aktion ausgeführt wird. Mit Hilfe eines Combielements oder einer Reaktionsmatrix können Sie das Statusbit abfragen und eine grafische Anzeige umsetzen.

Inaktiv: Das Statusbit wird nicht gesetzt.

Default: inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Sollrichtungsanzeige"


ID_VERRIEG_PROP5

Interne ID: ID_VERRIEG_PROP5

Laufzeitüberwachung

Bestimmt Ablauf der Laufzeitüberwachung.

  • keine: Keine Laufzeitüberwachung.
  • über Rückmeldevariable: Der Wert der Rückmeldevariable wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.
  • über Übertragungsursache: COT (Cause of Transmission) wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.
    Für die Aktion 'Befehl' werden die Status für die Übertragungsursache (Cause of Transmission=COT) ausgewertet.
    Wird innerhalb des bei der Aktion projektierten Timeout der COT-Ablauf nicht erfolgreich beendet, wird das Statusbit TIMEOUT gesetzt. Die Überwachung wird nur aktiviert, wenn der zu schreibende Wert ungleich dem aktuellen Wert der Aktionsvariable ist.

    Interne ID: ID_VERRIEG_PROP5

    Timeout

    Nur verfügbar bei den Aktionen 'Befehl' und 'Sollwertvorgabe':
    Für die Laufzeitüberwachung verwendetes Timeout in Sekunden.
    Minimum: 0.
    Maximum: 4294967295.
    Default: 30.

    Mehr im Online-Handbuch

    Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Laufzeitüberwachung"

Default: keine.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Laufzeitüberwachung"


ID_VERRIEG_PROP6

Interne ID: ID_VERRIEG_PROP6

Aktionstyp

Nur verfügbar bei der Aktion 'Befehl':
Typ des Befehls.
Doppelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand'.
Einzelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand' Nach der 'Flankenverzögerung' wird der Wert 0 geschrieben. Dieses Schreiben ist nicht mehr Laufzeit überwacht.
Default: Einzelbefehl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Type"


ID_VERRIEG_PROP7

Interne ID: ID_VERRIEG_PROP7

Rückmeldezustand/Schaltrichtung

Nicht verfügbar bei den Aktionen: Blockieren, Sperre und Freigeben.
Definiert den erwarteten Wert bzw. Status der Rückmeldevariable nach Aktionsausführung. Die möglichen Eingaben unterscheiden sich je nach Aktion .
Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Direction"


ID_VERRIEG_PROP9

Interne ID: ID_VERRIEG_PROP9

CEL-Eintrag unterdrücken

Aktiv: Bei der Aktionsausführung wird in der Chronologischen Ereignisliste (CEL) kein Eintrag erstellt.
Inaktiv: Bei der Aktionsausführung wird in der CEL ein Eintrag erstellt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELBlock"


ID_VERRIEG_PROP10

Interne ID: ID_VERRIEG_PROP10

Timeout

Nur verfügbar bei den Aktionen 'Befehl' und 'Sollwertvorgabe':
Für die Laufzeitüberwachung verwendetes Timeout in Sekunden.
Minimum: 0.
Maximum: 4294967295.
Default: 30.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Timeout"


ID_VERRIEG_PROP11

Interne ID: ID_VERRIEG_PROP11

Logische Verknüpfung

Öffnet den Dialog um die Formel für die Bedingung zu definieren.
Verriegelungsbedingungen werden im Netzwerk immer lokal berechnet. Durch Verwendung lokaler Variablen (z.B. vom Systemtreiber oder interne Variablen) können auf einem Client andere Bedingungen erfüllt sein als am Server.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Formula"


ID_VERRIEG_PROP12

Interne ID: ID_VERRIEG_PROP12

Entriegelbar

Nur verfügbar in SICAM 230 oder, wenn die Energy Edition lizenziert ist:
Aktiv: Verriegelung kann im Bild vom Typ Befehlsgabe manuell entriegelt werden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Delocking"


ID_VERRIEG_PROP13

Interne ID: ID_VERRIEG_PROP13

Verriegelungstext

Beschreibung der Verriegelungsbedingung.
In der Runtime kann dieser Text im Bild vom Typ Befehlsgabe angezeigt werden (wenn die Energy Edition lizenziert ist) oder in einem VBA Makro ausgewertet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Text"


ID_VERRIEG_PROP14

Interne ID: ID_VERRIEG_PROP14

Befehl

Nur verfügbar bei der Aktion 'Befehl':
Definiert den Wert, welcher bei der Aktion 'Befehl' als Wert auf die Befehlsvariable geschrieben wird.0: Die Befehlsvariable wird auf 0 gesetzt.
1: Die Befehlsvariable wird aud 1 gesetzt.
Default: 1.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CommandState"


ID_VERRIEG_PROP15

Interne ID: ID_VERRIEG_PROP15

Modifizierbare Status

Nur verfügbar bei der Aktion 'Statusvorgabe':
Liste der mittels der Aktion 'Statusvorgabe' veränderbaren Stati.
Default: keine.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "State"


ID_VERRIEG_PROP16

Interne ID: ID_VERRIEG_PROP16

Soll/Ist-Vergleich

Aktiv: Es wird geprüft, ob der Wert der Rückmeldevariable bereits der durchzuführenden Schaltrichtung entspricht. Ist das der Fall, wird in der Befehlsgabe eine entriegelbare Verriegelungsmeldung angezeigt.
Inaktiv: Es erfolgt keine Überprüfung der Schaltrichtung.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Actual"


ID_VERRIEG_PROP17

Interne ID: ID_VERRIEG_PROP17

Bild modal

Aktiv: Unabhängig von der Eigenschaft 'Modaler Dialog' des Bildes wird das Befehlsbild modal aufgeschalten. D.h. andere Bilder sind erst wieder bedienbar, nachdem das Bild geschlossen wurde.
Inaktiv: Das Befehlsbild wird normal aufgeschalten.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BildModal"


ID_VERRIEG_PROP18

Interne ID: ID_VERRIEG_PROP18

Bildtitel aus Rückmeldevariable

Aktiv: Die Kennung der Rückmeldeariable wird als Bildtitel verwendet.
Inaktiv: Der Name des Bildes wird als Bildtitel verwendet.
Default: inaktiv.
Achtung: Zur Aktivierung des Bildtitels muss zusätzlich in der entsprechenden Schablone die Eigenschaft Titel aktiviert werden.

Interne ID: ID_VERRIEG_PROP18

Titel

Nur verfügbar, wenn ein Rahmen für die Schablone ausgewählt ist:
Aktiv: Windows-Titelleisten für die Bilder dieser Schablone verwenden. Die Bilder können in der Runtime verschoben werden.
Inaktiv: Keine Titelleiste verwenden.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BildtitelRM"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BildtitelRM"


ID_VERRIEG_PROP19

Interne ID: ID_VERRIEG_PROP19

Befehlsbild

Name des zu öffnenden Bildes, wenn kein aktionsspezifisches Bild definiert ist und das Bild nicht über die Funktion Bildumschaltung geöffnet wird.

Hinweis: Wird die Befehlsgabe durch ein Sollwertsetzen beim Element initiiert, muss hier ein Bild verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Befehlsbild"


ID_VERRIEG_PROP20

Interne ID: ID_VERRIEG_PROP20

Bild

Bild vom Typ Befehlsgabe, das beim Ausführen der Aktion über das Kontextmenü des Elements verwendet wird. Wenn kein Bild eingetragen ist, wird das Bild, das in der Eigenschaft Befehlsbild in der Befehlsgruppe eingetragen ist, verwendet. Ein projektiertes, jedoch nicht vorhandenes Bild erzeugt eine Fehlermeldung beim Erzeugen der Runtime-Dateien. Die Aktion wird in diesem Fall nicht übernommen.
Default: keines.

Interne ID: ID_VERRIEG_PROP20

Befehlsbild

Name des zu öffnenden Bildes, wenn kein aktionsspezifisches Bild definiert ist und das Bild nicht über die Funktion Bildumschaltung geöffnet wird.

Hinweis: Wird die Befehlsgabe durch ein Sollwertsetzen beim Element initiiert, muss hier ein Bild verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PicGUID"

Hinweis: Wird die Befehlsgabe durch ein Sollwertsetzen beim Element initiiert, wird diese Eigenschaft ignoriert und immer das Bild benutzt, das in der Eigenschaft Befehlsbild in der Befehlsgruppe eingetragen ist.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PicGUID"


ID_VERRIEG_PROP21

Interne ID: ID_VERRIEG_PROP21

Aktionsbutton

Nicht verfügbar bei der Aktion 'Sperre' oder, wenn kein Befehlsbild zugeordnet ist:
Zuordnung der Aktion zu einem im Bild vom Typ Befehlsgabe definierten Aktionsbutton.
Wenn die Befehlsgruppe mit einem anderen Bild verwendet wird (z.B. über Funktion), bleibt trotzdem die Zuordnung zu dem Aktionsbutton bestehen. Fehlt ein solcher Button, ist diese Aktion im Bild nicht verfügbar.
In der Auswahlliste werden nur die noch nicht zugeordneten Aktionsbuttons angeboten.
Default: keiner.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CmdBtn"


ID_VERRIEG_PROP22

Interne ID: ID_VERRIEG_PROP22

Automatisch schließen

Aktiv: Nach Ausführung der Aktion wird das Befehlsbild automatisch geschlossen.
Inaktiv: Das Befehlsbild wird nicht automatisch geschlossen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CloseMDIWnd"


ID_VERRIEG_PROP23

Interne ID: ID_VERRIEG_PROP23

Zweihandbedienung

Nur verfügbar für zweistufige Ausführung:
Aktiv: Das Kontrollelement 'Ausführen 2' ist nur bedienbar, wenn gleichzeitig die Taste STRG gedrückt wird.
Inaktiv: Das Kontrollelement ist immer bedienbar.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwoHand"


ID_VERRIEG_PROP24

Interne ID: ID_VERRIEG_PROP24

Flankenverzögerung

Nur verfügbar, wenn bei der Eigenschaft Aktionstyp Einzelbefehl gewählt wurde.
Nach Ablauf dieser Zeit in Millisekunden wird der Wert der Befehlsvariable - abhängig von der Schaltrichtung - auf 0 oder 1 zurückgesetzt. Das Zurücksetzen des Wertes wird nicht ausgeführt, wenn die Eigenschaft Select Before Operate der Aktionsvariable aktiviert wurde.
Minimum: 0
Maximum: 4294967295
Default: 1000
Achtung: Es wird nicht gewartet, bis die Laufzeitüberwachung beendet ist.

Interne ID: ID_VERRIEG_PROP24

Select Before Operate

Achtung: Diese Funktionalität wird nur von den Treibern IEC870, IEC850 und DNP3 unterstützt und nur, wenn in der Befehlsgabe für die Eigenschaft Aktionstyp Doppelbefehl gewählt wurde.

Aktiv: Bevor der Wert der Variablen in die Hardware geschrieben wird, fragt zenon ab, ob die Variable in der Hardware für die Aktion bereit ist = Select before Operate (SBO).
Achtung: Bei Einzelbefehlen wird dann das automatische Zurücksetzen des Variablenwerts nach der in der Eigenschaft Flankenverzögerung definierten Zeitspanne nicht ausgeführt.

Inaktiv: Der Wert der Variable wird ohne vorherige Rückfrage in die Hardware geschrieben = Direct execute.
Default: inaktiv
Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EdgeDelay"

Interne ID: ID_VERRIEG_PROP24

Aktionstyp

Nur verfügbar bei der Aktion 'Befehl':
Typ des Befehls.
Doppelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand'.
Einzelbefehl: Schreibt den Wert der Eigenschaft 'Befehlsgabezustand' Nach der 'Flankenverzögerung' wird der Wert 0 geschrieben. Dieses Schreiben ist nicht mehr Laufzeit überwacht.
Default: Einzelbefehl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EdgeDelay"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EdgeDelay"


ID_VERRIEG_PROP25

Interne ID: ID_VERRIEG_PROP25

Zweistufig

Aktiv: Die Aktion wird erst ausgeführt, wenn das Control „Ausführen 2“ bestätigt wurde.

Inaktiv: Die Aktion wird ausgeführt:

  • nach dem Entriegeln der letzten Verriegelung
  • sofort, wenn keine Verriegelung ansteht

Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TwoLevel"


ID_VERRIEG_PROP29

Interne ID: ID_VERRIEG_PROP29

Sollwert

Nur verfügbar, wenn Eigenschaft Rückmeldezustand/Schaltrichtung auf DIR gesetzt wurde.

Interne ID: ID_VERRIEG_PROP29

Rückmeldezustand/Schaltrichtung

Nicht verfügbar bei den Aktionen: Blockieren, Sperre und Freigeben.
Definiert den erwarteten Wert bzw. Status der Rückmeldevariable nach Aktionsausführung. Die möglichen Eingaben unterscheiden sich je nach Aktion .
Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueDirectly"

Definiert den abzusetzenden Sollwert.

Default: 0

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueDirectly"


ID_VERRIEG_PROP30

Interne ID: ID_VERRIEG_PROP30

Ergebnisvariable

Zeigt das Ergebnis der Verriegelungsbedingung auf der selektierten Variable an.

Eine Klick auf die Schaltfläche, öffnet den Dialog zur Auswahl der Variable. Sie können den Namen der Variable auch direkt in das Feld eingeben.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueVariable"


ID_VERRIEG_PROP31

Interne ID: ID_VERRIEG_PROP31

Qualifier of Command verwenden

Nur verfügbar, wenn Sie die Energy Edition lizenziert haben.

Sie können Befehlen eine Zusatzinformation (Qualifier of Command) mitgeben, wenn der Treiber dies unterstützt. Mögliche Treiber: IEC850, IEC870 und DNP3.

aktiv: Aktiviert die Eingabe unter Qualifier of Command.

Interne ID: ID_VERRIEG_PROP31

Qualifier of Command

Geben Sie einen Zahlenwert ein, der als Befehlsparamter zum Treiber gesendet wird. Je nach Treiber wird dieser unterschiedlich ausgewertet.
IEC850: Werte 0 - 3 werden bei Befehlen im Feld Check eingefügt, sonst ignoriert.

IEC870: Werte 0 - 31 werden bei Befehlen im Feld QU eingesetzt, sonst ignoriert.

DNP3: Wert 1 beim Befehl bedeutet Pulse, sonst Latch.

Minimum: 0

Maximum: 127

Default: 0

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseQOC"

Default: inaktiv

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseQOC"


ID_VERRIEG_PROP32

Interne ID: ID_VERRIEG_PROP32

Qualifier of Command

Geben Sie einen Zahlenwert ein, der als Befehlsparamter zum Treiber gesendet wird. Je nach Treiber wird dieser unterschiedlich ausgewertet.
IEC850: Werte 0 - 3 werden bei Befehlen im Feld Check eingefügt, sonst ignoriert.

IEC870: Werte 0 - 31 werden bei Befehlen im Feld QU eingesetzt, sonst ignoriert.

DNP3: Wert 1 beim Befehl bedeutet Pulse, sonst Latch.

Minimum: 0

Maximum: 127

Default: 0

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "QOC"


ID_VERRIEG_PROP33

Interne ID: ID_VERRIEG_PROP33

Name

Frei definierbarer Teil der Benennung einer Verriegelung.

Wird hier ein Name vergeben, so setzt sich die komplette Benennung zusammen aus: Name: Logische Verknüpfung, zum Beispiel: Name: X03 unquittiert AND X02.

Interne ID: ID_VERRIEG_PROP33

Logische Verknüpfung

Öffnet den Dialog um die Formel für die Bedingung zu definieren.
Verriegelungsbedingungen werden im Netzwerk immer lokal berechnet. Durch Verwendung lokaler Variablen (z.B. vom Systemtreiber oder interne Variablen) können auf einem Client andere Bedingungen erfüllt sein als am Server.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"

Wird hier kein Name vergeben, wird die komplette Benennung automatisch erstellt aus: Bedingung <Index>: Logische Verknüpfung, zum Beispiel: Bedingung 01: X03 unquittiert AND X02.

Default: Bedingung <Index>

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_VERRIEG_PROP34

Interne ID: ID_VERRIEG_PROP34

Menü ID

Eindeutige ID der Aktion. Die Menü ID wird für die Erstellung von Kontextmenüs zur Runtime verwendet. Werden zwei Aktionen mit der gleichen ID ausgestattet, werden sie im Aktionsbaum mit einem speziellen Symbol markiert.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CmdMenuID"


ID_VERRIEG_PROP35

Interne ID: ID_VERRIEG_PROP35

Verriegelungsvariable

Variable, die für die Verriegelungsbedingung verwendet werden kann. Durch Klick auf die Schaltfläche ..., kann die Variable ausgetauscht werden, ohne dass die Formel angepasst werden muss.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_VERRIEG_PROP_DEL

Interne ID: ID_VERRIEG_PROP_DEL

{Bedingung löschen}

Die Bedingung wird gelöscht.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Delete"


ID_VERRIEG_PROP_GRP0

Interne ID: ID_VERRIEG_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die Verriegelung oder Befehlsgabe.

Mehr im Online-Handbuch zum Erstellen einer:

- Verriegelung

- Befehlsgabe

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_VERRIEG_PROP_GRP4

Interne ID: ID_VERRIEG_PROP_GRP4

Befehlsgabebild

Eigenschaften für das Befehlsgabebild.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_VERRIEG_PROP_GRP5

Interne ID: ID_VERRIEG_PROP_GRP5

Optionen

Eigenschaften für die Optionen der Befehlsgabe.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_VERRIEG_PROP_GRP6

Interne ID: ID_VERRIEG_PROP_GRP6

Aktionseinstellungen

Eigenschaften für die Aktionseinstellungen der Befehlsgabe.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_VERRIEG_PROP_GRP7

Interne ID: ID_VERRIEG_PROP_GRP7

Variable

Eigenschaften für die Variablen der Verriegelung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_VERRIEG_PROP_GRP8

Interne ID: ID_VERRIEG_PROP_GRP8

Bedingung

Eigenschaften für die Bedingungen der Verriegelung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_VERRIEG_PROP_GRP9

Interne ID: ID_VERRIEG_PROP_GRP9

Berechtigung

Enthält Eigenschaften zur Festlegung der Berechtigungsebenen zum Verriegeln und Entriegeln.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


ID_VERRIEG_PROP_GRP10

Interne ID: ID_VERRIEG_PROP_GRP10

Statusverarbeitung

Einstellungen zur Statusverarbeitung in der Befehlsgabe.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusHandling"


ID_VERRIEG_PROP_GRP11

Interne ID: ID_VERRIEG_PROP_GRP11

Befehlsgabebild

Einstellungen zum Befehlsgabebild in der Befehlsgabe.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CommandScreen"


ID_VERRIEG_PROP_NEW

Interne ID: ID_VERRIEG_PROP_NEW

{Bedingung neu}

Eine neue Bedingung wird angelegt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "New"


ID_VORSCHAU

Interne ID: ID_VORSCHAU

Vorschau

Steht nur zur Verfügung, wenn eine Variable mit dem Symbol verknüpft ist.

Öffnet den Dialog zum Ersetzen der Verknüpfungen. Änderungen in der Vorschau werden in die Eigenschaften Quelle und Ziel übernommen und umgekehrt.

Interne ID: ID_VORSCHAU

Ziel

Ersetzen von Variablen und/oder Funktionen in einem Symbol:
Geben Sie die neu zuzordnenden Variablen/Funktionen an. Dabei sind keine Platzhalter erlaubt. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Quellen definieren Sie zuvor über die Eigenschaft Quelle.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Preview"

Interne ID: ID_VORSCHAU

Quelle

Ersetzen von Variablen und/oder Funktionen in einem Symbol:

Geben Sie die Quellvariablen/Quellfunktion an. Dabei können Platzhalter (?, *) verwendet werden. Mehrere Einträge werden durch ein Semikolon (;) getrennt.

Die Ziele definieren Sie dann über die Eigenschaft Ziel.
Beispiel: Variablen im Symbol: Tank1.Füllstand und Tank1.Ventilstellung. Diese sollen durch die Variablen Tank2.Füllstand und Tank2.Ventilstellung ersetzt werden.
Dazu geben Sie bei Quelle ein: *1* und bei Ziel 2. Zur Runtime werden dann die 1er Variablen durch die 2er Variablen ersetzt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Preview"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Preview"


ID_WORKSPACE_PROP_MSGCTRL

Interne ID: ID_WORKSPACE_PROP_MSGCTRL

* * * ---! ID_WORKSPACE_PROP_MSGCTRL fehlt in der VBAHelp !--- * * *

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MessageControl"


ID_WORKSPACE_PROP_PATH

Interne ID: ID_WORKSPACE_PROP_PATH

Arbeitsbereichsdatei

Name und Speicherort der Arbeitsbereichsdatei. Nur Anzeige.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Workspacepath"


ID_WORKSPACE_PROPS_GRP

Interne ID: ID_WORKSPACE_PROPS_GRP

Arbeitsbereich

Enthält Eigenschaften für den Arbeitsbereich.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Arbeitsbereich"


ID_WRONGPW

Interne ID: ID_WRONGPW

Max. Benutzerfehleing.

Anzahl der falschen Benutzernamen-Eingaben.
Wird diese Anzahl überschritten, so wird das System gesperrt. Ein entsprechender Eintrag in der Chronologischen Ereignisliste (CEL) wird erstellt. Keine Benutzer ausser Administratoren können sich mehr einloggen. Durch das Einloggen eines Administrators wird das System automatisch wieder entsperrt.
Minimum: 0.
Maximum: 65535.
Default: 3.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserTries"


ID_WRONGUSER

Interne ID: ID_WRONGUSER

Max. Passwortfehleing.

Anzahl der falschen Passwort-Eingaben.
Wird diese Anzahl überschritten, so wird der entsprechende Benutzer gesperrt. Ein entsprechender Eintrag in der Chronologischen Ereignisliste (CEL) wird erstellt. Nur ein Administrator kann ihn wieder entsperren.
Minimum: 0.
Maximum: 65535.
Default: 3.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PasswordTries"


ID_ZEITSTG_PROP1

Interne ID: ID_ZEITSTG_PROP1

Name

Name der Zeit-Funktion.
Default: Time-Function x (wobei x eine fortlaufende Zahl ist).

ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_ZEITSTG_PROP2

Interne ID: ID_ZEITSTG_PROP2

Funktion

Funktion, die zeitgesteuert ausgeführt werden soll.
Öffnet den Funktionsauswahldialog.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


ID_ZEITSTG_PROP3

Interne ID: ID_ZEITSTG_PROP3

Aktiv

Aktiv: Die Zeit-Funktion wird in der Runtime ausgeführt.
Inaktiv: Die Zeit-Funktion wird in der Runtime nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Active"


ID_ZEITSTG_PROP4

Interne ID: ID_ZEITSTG_PROP4

Ausführungstyp

ab diesem Tag: Die Funktion wird ab dem eingestellten Tag jeden Tag zur eingestellten Zeit ausgeführt.
nur an diesem Tag: Die Funktion wird am eingestellten Tag zur eingestellten Zeit einmalig ausgeführt.
zyklisch ab diesem Tag: Die Funktion wird ab dem eingestellten Tag in dem definierten Intervall zyklisch ausgeführt.
zyklisch nur an diesem Tag: Die Funktion wird nur an dem eingestellten Wochentag in dem definierten Intervall zyklisch ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Type"


ID_ZEITSTG_PROP5

Interne ID: ID_ZEITSTG_PROP5

Startzeitpunkt

Datum, an dem bzw. ab dem die Zeit-Funktion ausgeführt werden soll.

Hinweis: Zeit wird in UTC gespeichert. Details siehe Kapitel Behandlung von Zeitangaben im Handbuch Runtime.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExecuteDate"


ID_ZEITSTG_PROP7

Interne ID: ID_ZEITSTG_PROP7

Intervall

Zeitintervall, in dem die Funktion ausgeführt werden soll.
Default: 00:15:00.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Interval"


ID_ZEITSTG_PROP8

Interne ID: ID_ZEITSTG_PROP8

Intervall ein Monat

Nur verfügbar, wenn für die Eigenschaft Ausführungstyp der Wert zyklisch gewählt wurde.
Aktiv: Die Funktion wird nach einem Intervall von einem Monat zum Monatswechsel ausgeführt.
Inaktiv: Die anderen Einstellungen zum Ausführen der Funktion werden verwendet.
Default: inaktiv

Interne ID: ID_ZEITSTG_PROP8

Ausführungstyp

ab diesem Tag: Die Funktion wird ab dem eingestellten Tag jeden Tag zur eingestellten Zeit ausgeführt.
nur an diesem Tag: Die Funktion wird am eingestellten Tag zur eingestellten Zeit einmalig ausgeführt.
zyklisch ab diesem Tag: Die Funktion wird ab dem eingestellten Tag in dem definierten Intervall zyklisch ausgeführt.
zyklisch nur an diesem Tag: Die Funktion wird nur an dem eingestellten Wochentag in dem definierten Intervall zyklisch ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Monthly"

Hinweis: Monatswechsel und Jahreswechsel beziehen sich auf das eingestellte Ausführungsdatum und nicht auf den konkreten Wechsel zum 01. 01. 00:00 Uhr. Soll der Wechsel zu exakt diesem Zeitpunkt ausgeführt werden, muss die Projektierung für diesen Zeitpunkt angelegt werden, z.B. 01. 01. 2012 00:00:00 Uhr.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Monthly"


ID_ZEITSTG_PROP9

Interne ID: ID_ZEITSTG_PROP9

Intervall ein Jahr

Nur verfügbar, wenn für die Eigenschaft Ausführungstyp der Wert zyklisch gewählt wurde.
Aktiv: Die Funktion wird nach einem Intervall von einem Jahr zum Jahreswechsel ausgeführt.
Inaktiv: Die anderen Einstellungen zum Ausführen der Funktion werden verwendet.
Default: inaktiv

Interne ID: ID_ZEITSTG_PROP9

Ausführungstyp

ab diesem Tag: Die Funktion wird ab dem eingestellten Tag jeden Tag zur eingestellten Zeit ausgeführt.
nur an diesem Tag: Die Funktion wird am eingestellten Tag zur eingestellten Zeit einmalig ausgeführt.
zyklisch ab diesem Tag: Die Funktion wird ab dem eingestellten Tag in dem definierten Intervall zyklisch ausgeführt.
zyklisch nur an diesem Tag: Die Funktion wird nur an dem eingestellten Wochentag in dem definierten Intervall zyklisch ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Yearly"

Hinweis: Monatswechsel und Jahreswechsel beziehen sich auf das eingestellte Ausführungsdatum und nicht auf den konkreten Wechsel zum 01. 01. 00:00 Uhr. Soll der Wechsel zu exakt diesem Zeitpunkt ausgeführt werden, muss die Projektierung für diesen Zeitpunkt angelegt werden, z.B. 01. 01. 2012 00:00:00 Uhr.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Yearly"


ID_ZEITSTG_PROP10

Interne ID: ID_ZEITSTG_PROP10

Montag

Aktiv: Funktion wird (auch) an Montagen ausgeführt.
Inaktiv: Funktion wird an Montagen nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Monday"


ID_ZEITSTG_PROP11

Interne ID: ID_ZEITSTG_PROP11

Dienstag

Aktiv: Funktion wird (auch) an Dienstagen ausgeführt.
Inaktiv: Funktion wird an Dienstagen nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Tuesday"


ID_ZEITSTG_PROP12

Interne ID: ID_ZEITSTG_PROP12

Mittwoch

Aktiv: Funktion wird (auch) an Mittwochen ausgeführt.
Inaktiv: Funktion wird an Mittwochen nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Wednesday"


ID_ZEITSTG_PROP13

Interne ID: ID_ZEITSTG_PROP13

Donnerstag

Aktiv: Funktion wird (auch) an Donnerstagen ausgeführt.
Inaktiv: Funktion wird an Donnerstagen nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Thursday"


ID_ZEITSTG_PROP14

Interne ID: ID_ZEITSTG_PROP14

Freitag

Aktiv: Funktion wird (auch) an Freitagen ausgeführt.
Inaktiv: Funktion wird an Freitagen nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Friday"


ID_ZEITSTG_PROP15

Interne ID: ID_ZEITSTG_PROP15

Samstag

Aktiv: Funktion wird (auch) an Samstagen ausgeführt.
Inaktiv: Funktion wird an Samstagen nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Saturday"


ID_ZEITSTG_PROP16

Interne ID: ID_ZEITSTG_PROP16

Sonntag

Aktiv: Funktion wird (auch) an Sonntagen ausgeführt.
Inaktiv: Funktion wird an Sonntagen nicht ausgeführt.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Sunday"


ID_ZEITSTG_PROP_GRP0

Interne ID: ID_ZEITSTG_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die Zeit-Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TimeFct"


ID_ZEITSTG_PROP_GRP1

Interne ID: ID_ZEITSTG_PROP_GRP1

Zeit-Einstellungen

Zeit-Einstellungen für die Funktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Timeadj"


ID_ZEITSTG_PROP_GRP3

Interne ID: ID_ZEITSTG_PROP_GRP3

Triggerzeitpunkte

Nur mit zyklischem Ausführungstyp:
Auswahl von Monats- bzw. Jahreswechsel.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TriggerTime"


ID_ZEITSTG_PROP_GRP4

Interne ID: ID_ZEITSTG_PROP_GRP4

Ausführungstage

Auswahl an welchem/n Tag(en) die Funktion ausgeführt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ExecutionDays"


ID_ZUWEIS_PROP1

Interne ID: ID_ZUWEIS_PROP1

Name

Eindeutiger Name der Zuweisung.
Default: Zuweisung x (wobei x eine fortlaufende Zahl ist).

ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_ZUWEIS_PROP2

Interne ID: ID_ZUWEIS_PROP2

Quellvariable

Name der Variable, deren Wert der Zielvariable zugewiesen werden soll.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SourceVariable"


ID_ZUWEIS_PROP3

Interne ID: ID_ZUWEIS_PROP3

Zielvariable

Name der Variable, der der Wert der Quellvariable zugewiesen werden soll.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TargetVariable"


ID_ZUWEIS_PROP4

Interne ID: ID_ZUWEIS_PROP4

Triggervariable

Die hier verknüpfte Bit-Variable stößt die Zuweisung an. Wenn keine Variable verknüpft ist, funktioniert die Zuweisung spontan. D.h. immer wenn sich der Wert der Quellvariable ändert, wird er automatisch auf die Zielvariable geschrieben.
Öffnet den Variablenauswahldialog gefiltert auf Bit-Variablen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TriggerVariable"


ID_ZUWEIS_PROP5

Interne ID: ID_ZUWEIS_PROP5

Trigger Art

Flanke: Die Zuweisung wird ausgeführt, wenn sich der Wert der verknüpften Trigger-Variable von 0 auf 1 ändert.
Pegel: Die Zuweisung wird ausgeführt, solange der Wert der verknüpften Trigger-Variable 1 ist.
Default: Flanke.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TriggerType"


ID_ZUWEIS_PROP_GRP0

Interne ID: ID_ZUWEIS_PROP_GRP0

Allgemein

Allgemeine Eigenschaften für die Zuweisung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_ZW_PROP_ABFRAGE

Interne ID: ID_ZW_PROP_ABFRAGE

Zählerabfrage-Variabel

Variable für Zählerabfrage.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "QueryPV"


ID_ZW_PROP_AUSGANGABS

Interne ID: ID_ZW_PROP_AUSGANGABS

Zählertyp-Ausgang: Absolut

Ausgang als Absolutwert

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OutputAbs"


ID_ZW_PROP_AUSGANGREL

Interne ID: ID_ZW_PROP_AUSGANGREL

Zählertyp-Ausgang: Relativ

Ausgabe als Relativwert.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OutputRel"


ID_ZW_PROP_EINGANGABS

Interne ID: ID_ZW_PROP_EINGANGABS

Zählertyp-Eingang

Absolutwert oder Relativwert

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InputAbs"


ID_ZW_PROP_GRP0

Interne ID: ID_ZW_PROP_GRP0

Allgemein

Mit den folgenden Properties legen Sie die Eigenschaften der Zählwert-Rema fest.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


ID_ZW_PROP_MAXWERT

Interne ID: ID_ZW_PROP_MAXWERT

Max. Zählerstand

Maximaler Zählerstand

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxCount"


ID_ZW_PROP_NAHANDLING

Interne ID: ID_ZW_PROP_NAHANDLING

NA-Behandlung

Modus für "nicht aktualisiert" Behandlung (Zählwert außerhalb des Zeitfensters)

Umschalten auf INVALID-Bit: Zählwert wird auf INVALID gesetzt

Umschalten auf Ersatzwert: Zählwert wird auf parametrierten Ersatzwert gesetzt

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NAHandling"


ID_ZW_PROP_NAME

Interne ID: ID_ZW_PROP_NAME

Bezeichnung

Name der Zählergruppe

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


ID_ZW_PROP_NUMBER

Interne ID: ID_ZW_PROP_NUMBER

ID

Interne Nummer der Zählergruppe

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Number"


ID_ZW_PROP_OFFSET

Interne ID: ID_ZW_PROP_OFFSET

Offset [s]

Zeit nach Hochlauf für 1. Abfrage in Sekunden

Damit wird gewährleistet, dass die Connection zur Gegenstelle OK ist.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Offset"


ID_ZW_PROP_OVHANDLING

Interne ID: ID_ZW_PROP_OVHANDLING

OV-Behandlung

Verhalten bei Absolutwertüberlauf oder Gradientenüberschreitung.

Umschalten auf INVALID-Bit: Zählwert wird auf INVALID gesetzt

Umschalten auf Ersatzwert: Zählwert wird auf parametrierten Ersatzwert gesetzt

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "OVHandling"


ID_ZW_PROP_TARIF

Interne ID: ID_ZW_PROP_TARIF

Variable für Tarifkennung

Steuervariable für Tarifkennung.

Zuweisung auf Anwenderstati 1...8

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TariffPV"


ID_ZW_PROP_TIMEOUT

Interne ID: ID_ZW_PROP_TIMEOUT

Zeitfenster [s]

Timeout für Vollständigkeitsprüfung.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Timeout"


ID_ZW_PROP_TRIGGER

Interne ID: ID_ZW_PROP_TRIGGER

Triggervariable

Von Abfragezeitpunkt bis Ablauf des Zeitfensters: 1

Sonst: 0

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TriggerPV"


ID_ZW_PROP_ZYKLUSZEIT

Interne ID: ID_ZW_PROP_ZYKLUSZEIT

Gruppenzykluszeit [s]

Zykluszeit für Zählerabfrage in Sekunden

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CycleTime"


IDD_VARVERWALTUNG5

Interne ID: IDD_VARVERWALTUNG5

Name

Name des Datentyps. Länge ist auf 128 Zeichen begrenzt.
Achtung: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


IDP_3TFORM_EDITOR

Interne ID: IDP_3TFORM_EDITOR

Flächenverwendung

Legen Sie fest, welche Auswirkung das erstellte Element auf die Schablone haben soll.

Folgende Einstellungen stehen zur Verfügung:

Abdecken: Die Fläche des Elements wird als Bildbereich verwendet

Ausschneiden: Die Fläche des Elements wird von den darunterliegenden Flächen entfernt

Verodert: Je nachdem, ob sich unter dem Element eine abdeckende Fläche befindet oder nicht, wird wird entweder ausgeschnitten oder abgedeckt

Hinweis: Die Flächenverwendung bezieht sich immer auf die unter dem Element liegende Fläche.

Für neu angelegte Elemente wird immer die zuletzt selektierte Einstellung verwendet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Combine"


IDP_AMISTS_DEVICE

Interne ID: IDP_AMISTS_DEVICE

AMISTS device

Es kann sowohl ein Gerät als auch ein Lastschaltgerät angegeben werden. Dieses muß in der Datenbank des Transaktionsservers enthalten sein.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AMISTSDevice"


IDP_AMISTS_LSDGROUP

Interne ID: IDP_AMISTS_LSDGROUP

AMISTS load switch group

Für Schaltprogramme wird hier die Gruppe von Lastschaltgeräten spezifiziert.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AMISTSLSGroup"


IDP_AMISTS_REFERENCE

Interne ID: IDP_AMISTS_REFERENCE

AMISTS reference

Hierüber wird die Verbindung zwischen der Variablen und dem entsprechenden Transaktionsserver hergestellt, wie er in der Treiberkonfiguration parametriert wurde.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AMISTSReference"


IDP_AMISTS_RELAYADDRESS

Interne ID: IDP_AMISTS_RELAYADDRESS

AMISTS relaynumber (1-5)

Bei einem Lastschaltgerät wird hiermit das entsprechende Relais im Wertebereich von 1 bis 5 spezifiziert. Bei einem Gerät ist diese Angabe nicht relevant.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AMISTSRelayNumber"


IDP_AMISTS_RELAYPROGRAM

Interne ID: IDP_AMISTS_RELAYPROGRAM

AMISTS load switch Program (block 17)

Hier wird ein Schaltprogramm angegeben. Dieses muß im Block 17 der Parametrierung des Transaktionsservers aufgeführt sein.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AMISTSLSDProgram"


IDP_AML_LONGLIMITS

Interne ID: IDP_AML_LONGLIMITS

Lange dynamische Grenzwerttexte AML

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.
Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.AML abgelegt. Diese wird zusätzlich zur Datei A*.AML angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.
Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LongDynLimits"


IDP_BATCH_ACTION_ALLOC_GRP

Interne ID: IDP_BATCH_ACTION_ALLOC_GRP

Parameter zuweisen

Enthält Eigenschaften für die Zuweisung von Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActAllocGrp"


IDP_BATCH_ACTION_CELACTIVE

Interne ID: IDP_BATCH_ACTION_CELACTIVE

CEL Eintrag erzeugen

Aktiv: Der in der Eigenschaft CEL Meldungstext definierte Text wird in die CEL eingetragen.

Interne ID: IDP_BATCH_ACTION_CELACTIVE

CEL Meldungstext

Nur verfügbar, wenn Eigenschaft CEL Eintrag erzeugen aktiv ist.

Text, der in die CEL eingetragen wird. Kann Schlüsselwörter aus der Sprachumschaltung enthalten.

Maximum: 512 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActCelEn"

Der Eintrag erfolgt in der CEL am Server mit dem zu diesem Zeitpunkt angemeldeten Benutzer.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActCelEn"


IDP_BATCH_ACTION_CELMSG

Interne ID: IDP_BATCH_ACTION_CELMSG

CEL Meldungstext

Nur verfügbar, wenn Eigenschaft CEL Eintrag erzeugen aktiv ist.

Interne ID: IDP_BATCH_ACTION_CELMSG

CEL Eintrag erzeugen

Aktiv: Der in der Eigenschaft CEL Meldungstext definierte Text wird in die CEL eingetragen.

Der Eintrag erfolgt in der CEL am Server mit dem zu diesem Zeitpunkt angemeldeten Benutzer.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActCelMsg"

Text, der in die CEL eingetragen wird. Kann Schlüsselwörter aus der Sprachumschaltung enthalten.

Maximum: 512 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActCelMsg"


IDP_BATCH_ACTION_DESCR

Interne ID: IDP_BATCH_ACTION_DESCR

Beschreibung

Freie Texteingabe zur Beschreibung des gewählten Ereignisses.
Beschreibung ist zur Runtime nicht sichtbar und gilt nur für den Editor.
Maximum: 512 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActDescr"


IDP_BATCH_ACTION_DESTTAG

Interne ID: IDP_BATCH_ACTION_DESTTAG

Zielparameter

Nur verfügbar, wenn ein Quellparameter gewählt wurde.

Interne ID: IDP_BATCH_ACTION_DESTTAG

Quellparameter

Parameter, dessen Wert auf den in der Eigenschaft Zielparameter gewählten Parameters übertragen wird. Klick auf Schaltfläche ... öffnet Dialog zur Parameterauswahl.

Beim Start der Grundfunktion zur Runtime wird der beim Quellparameter verknüpfte Wert der Variable abgefragt. Wird kein gültiger Wert empfangen, kann mittels der Reaktion „Verknüpfte Variable gestört" reagiert werden. Wird der Parameter umbenannt, wird die Änderung automatisch übernommen.

Zur Runtime wird während der Validierung überprüft, ob der Zielparameter vorhanden ist und die bei den Parametern verknüpften Variablen gültig und vom richtigen Typ sind.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActDestTag"

Parameter, auf den der Wert des in der Eigenschaft Quellparameter gewählten Parameters übertragen wird. Klick auf Schaltfläche ... öffnet Dialog zur Parameterauswahl. Es werden nur Parameter vom passenden Typ angeboten. Wird der Parameter umbenannt, wird die Änderung automatisch übernommen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActDestTag"


IDP_BATCH_ACTION_FUNC

Interne ID: IDP_BATCH_ACTION_FUNC

Funktion

Funktion, die ausgeführt werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl.

Es kann eine Funktion aus dem lokalen Projekt oder einem anderen Projekt gewählt werden. Das Projekt muss so wie die Funktion zur Runtime zur Verfügung stehen. Wird die Funktion umbenannt, wird die Änderung automatisch übernommen.

Zur Runtime wird während der Validierung überprüft, ob die Funktion vorhanden ist.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActFunc"


IDP_BATCH_ACTION_FUNCTION_GRP

Interne ID: IDP_BATCH_ACTION_FUNCTION_GRP

Funktion

Enthält Eigenschaft zur Funktionsauswahl.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActFuncGrp"


IDP_BATCH_ACTION_GENERAL_GRP

Interne ID: IDP_BATCH_ACTION_GENERAL_GRP

Allgemein

Enthält allgemeine Eigenschaften für Ereignisse.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActGeneral"


IDP_BATCH_ACTION_LOG_GRP

Interne ID: IDP_BATCH_ACTION_LOG_GRP

CEL-Eintrag

Enthält Eigenschaften für Einträge in die CEL und in LOG-Dateien.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActLogGrp"


IDP_BATCH_ACTION_LOGMSG

Interne ID: IDP_BATCH_ACTION_LOGMSG

Log Meldungstext

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActLogMsg"


IDP_BATCH_ACTION_LOGMSG_EN

Interne ID: IDP_BATCH_ACTION_LOGMSG_EN

Logeintrag erzeugen

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActLogEn"


IDP_BATCH_ACTION_PRIO

Interne ID: IDP_BATCH_ACTION_PRIO

Ausführungsreihung

Zeigt die Ausführungsreihenfolge an, wenn für das gleiche Ereignis mehrere Reaktionen definiert wurden. Die Reihenfolge wird durch die Position in der Liste definiert und hier nur angezeigt. Die Reihenfolge kann in der Liste über die Symbolleiste oder das Kontextmenü des Ereignisses geändert werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActPrio"


IDP_BATCH_ACTION_REACTION_GRP

Interne ID: IDP_BATCH_ACTION_REACTION_GRP

Reaktionen

Enthält Eigenschaften für Reaktionen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTagGrp"


IDP_BATCH_ACTION_RECIPE_GRP

Interne ID: IDP_BATCH_ACTION_RECIPE_GRP

Rezeptbeeinflussung

Enthält Eigenschaften für REE Modus und Kommando.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActRecipeGrp"


IDP_BATCH_ACTION_RESCMD

Interne ID: IDP_BATCH_ACTION_RESCMD

Kommando

Rezept- oder Grundfunktionskommando, das zur Runtime beim Eintreten des Ereignisses ausgeführt wird. Rezeptkommandos beeinflussen die Ausführung des gesamten Rezepts. Grundfunktionskommandos beeinflussen nur jene Grundfunktion, für die die Reaktion konfiguriert wurde bzw. für die das Ereignis aufgetreten ist. Das Rezeptkommando bzw. Grundfunktionskommando wird zur Runtime nur ausgeführt, wenn das Kommando auch erlaubt ist. Zum Beispiel: Ein Rezept kann nicht fortgesetzt werden, wenn das Rezept gerade angehalten wird. Eine Grundfunktion kann nicht neu gestartet werden wenn die Grundfunktion in der Runtime pausiert ist, oder in Ausführung ist.

Hinweis: Die Validierung des Rezepts in der Runtime prüft die Grundfunktionskommandos bzw. Rezeptkommandos nicht auf Plausibilität

Auswahl des REE Kommandos aus Dropdownliste:

  • Grundfunktion anhalten
  • Grundfunktion fortsetzen
  • Grundfunktion neu starten
  • Grundfunktion pausieren
  • Ignorieren
  • Rezept abbrechen
  • Rezept anhalten
  • Rezept fortsetzen
  • Rezept neu starten
  • Rezept pausieren
  • Rezept stoppen

Default: Ignorieren

Hinweis: Pro Ereignis kann nur ein einziges Kommando gesetzt werden. Für alle weiteren Ereignisse des gleichen Typs wird die Eigenschaft automatisch auf Ignorieren gesetzt. Auch für "Runtime beenden" angestoßen wird die Eigenschaft automatisch auf Ignorieren gesetzt. Wenn der Ereignis geändert wird, wird diese Einstellung eventuell auch auf Ignorieren gesetzt.

Interne ID: IDP_BATCH_ACTION_RESCMD

Ereignis

Auswahl des Ereignistyps, bei dem die Reaktion ausgeführt werden soll, aus Dropdownliste.
Für jedes Ereignis können mehrere Reaktionen definiert werden. Die Ausführungsreihenfolge kann in der Detailansicht festgelegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActResCmd"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActResCmd"


IDP_BATCH_ACTION_RESCMDMODE

Interne ID: IDP_BATCH_ACTION_RESCMDMODE

REE Modus

Über diese Reaktion kann in der Runtime den REE-Modus als Reaktion auf das Ereignisgesteuert werden.

Auswahl des REE-Modus aus Dropdownliste:

  • Automatisch
  • Halbautomatisch
  • Ignorieren
  • Manuell

Default: Ignorieren

Hinweis: Pro Ereignis kann der REE Modus nur einmal gesetzt werden. Für alle weiteren Ereignisse des gleichen Typs wird der Modus automatisch auf Ignorieren gesetzt. Auch für "Runtime beenden" angestoßen wird der Modus automatisch auf Ignorieren gesetzt. Wird der Ereignis geändert auf ein Ereignis, für das bereits eine bestehende Reaktion für den REE-Modus konfiguriert wurde, wird die REE-Modus Reaktion vom geänderten Ereignis auf Ignorieren gesetzt. Ist noch keine Reaktion für den REE-Modus für das neue Ereignis vorhanden, wird die REE Modus Reaktion beibehalten. Ausnahme: "Runtime beenden" angestoßen.

Interne ID: IDP_BATCH_ACTION_RESCMDMODE

Ereignis

Auswahl des Ereignistyps, bei dem die Reaktion ausgeführt werden soll, aus Dropdownliste.
Für jedes Ereignis können mehrere Reaktionen definiert werden. Die Ausführungsreihenfolge kann in der Detailansicht festgelegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActResCmdMode"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActResCmdMode"


IDP_BATCH_ACTION_SETTAG

Interne ID: IDP_BATCH_ACTION_SETTAG

Parameter

Parameter, auf den der definierte Sollwert als Reaktion auf das Ereignis geschrieben werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Parameters. Bei der Parameterwahl gilt:

  • Es können nur Parameter der Grundfunktion ausgewählt werden, zu der die Reaktion gehört.
  • Es können sowohl Rückmeldeparameter als auch Befehlsparameter gewählt werden.
  • Wird ein Parameter umbenannt, wird die Änderung automatisch übernommen.
  • Der Parametersollwert kann abhängig vom Parameterdatentyp eingegeben werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTag"


IDP_BATCH_ACTION_SETTAG_BO

Interne ID: IDP_BATCH_ACTION_SETTAG_BO

Wert Bool

Steht nur zur Verfügung, wenn in der Eigenschaft Parameter ein Parameter vom Typ Binär ausgewählt wurde.

Interne ID: IDP_BATCH_ACTION_SETTAG_BO

Parameter

Parameter, auf den der definierte Sollwert als Reaktion auf das Ereignis geschrieben werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Parameters. Bei der Parameterwahl gilt:

  • Es können nur Parameter der Grundfunktion ausgewählt werden, zu der die Reaktion gehört.
  • Es können sowohl Rückmeldeparameter als auch Befehlsparameter gewählt werden.
  • Wird ein Parameter umbenannt, wird die Änderung automatisch übernommen.
  • Der Parametersollwert kann abhängig vom Parameterdatentyp eingegeben werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTBool"

Sollwert für einen binären Parameter. Auswahl aus Dropdownliste:

  • Aus (0)
  • Ein (1)
  • Toggeln: wechselt Zustand
    Beim Start der Grundfunktion wird der Wert abgefragt und bei der Reaktion invertiert geschrieben. Wird kein gültiger Wert empfange,n kann mittels der Reaktion „Verknüpfte Variable gestört" reagiert werden.
  • Default: Aus (0)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTBool"


IDP_BATCH_ACTION_SETTAG_DUR

Interne ID: IDP_BATCH_ACTION_SETTAG_DUR

Zeitdauer

Steht nur zur Verfügung, wenn in der Eigenschaft Parameter ein Parameter vom Typ Zeitdauer ausgewählt wurde.

Interne ID: IDP_BATCH_ACTION_SETTAG_DUR

Parameter

Parameter, auf den der definierte Sollwert als Reaktion auf das Ereignis geschrieben werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Parameters. Bei der Parameterwahl gilt:

  • Es können nur Parameter der Grundfunktion ausgewählt werden, zu der die Reaktion gehört.
  • Es können sowohl Rückmeldeparameter als auch Befehlsparameter gewählt werden.
  • Wird ein Parameter umbenannt, wird die Änderung automatisch übernommen.
  • Der Parametersollwert kann abhängig vom Parameterdatentyp eingegeben werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTDuration"

Sollwert in Tagen, Stunden, Minuten und Sekunden für Parameter vom Typ Zeitdauer. Die Zeitspanne wird als Wert in Sekunden auf die beim Parameter verknüpfte Variable geschrieben.

  • Maximalwert: 0T 00:00:00
  • Minimalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Zum Beispiel: 30 Minuten und 5 Sekunden = 1805

Zur Runtime wird während der Validierung des Rezepts überprüft, ob der Wert in Sekunden innerhalb der Minimum/Maximum Grenzen der beim Parameter verknüpften Variable liegt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTDuration"


IDP_BATCH_ACTION_SETTAG_GRP

Interne ID: IDP_BATCH_ACTION_SETTAG_GRP

Parameter Sollwert setzen

Enthält Eigenschaften für Parameter Sollwert setzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTagGrp"


IDP_BATCH_ACTION_SETTAG_MEUNIT

Interne ID: IDP_BATCH_ACTION_SETTAG_MEUNIT

Tag Einheit

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTagMeUnit"


IDP_BATCH_ACTION_SETTAG_NUM

Interne ID: IDP_BATCH_ACTION_SETTAG_NUM

Wert Numerisch

Steht nur zur Verfügung, wenn in der Eigenschaft Parameter ein Parameter vom Typ Numerisch ausgewählt wurde.

Interne ID: IDP_BATCH_ACTION_SETTAG_NUM

Parameter

Parameter, auf den der definierte Sollwert als Reaktion auf das Ereignis geschrieben werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Parameters. Bei der Parameterwahl gilt:

  • Es können nur Parameter der Grundfunktion ausgewählt werden, zu der die Reaktion gehört.
  • Es können sowohl Rückmeldeparameter als auch Befehlsparameter gewählt werden.
  • Wird ein Parameter umbenannt, wird die Änderung automatisch übernommen.
  • Der Parametersollwert kann abhängig vom Parameterdatentyp eingegeben werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTNum"

Sollwert für Parameter vom Typ Numerisch.
Es kann eine negative oder positive Ganzzahl oder Fließkommazahl definiert werden, die als Reaktion auf den Parameter geschrieben wird.

Zur Runtime wird während der Validierung des Rezepts überprüft, ob der Wert innerhalb der Minimum/Maximum Grenzen der beim Parameter verknüpften Variable liegt.

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTNum"


IDP_BATCH_ACTION_SETTAG_STR

Interne ID: IDP_BATCH_ACTION_SETTAG_STR

Wert String

Steht nur zur Verfügung, wenn in der Eigenschaft Parameter ein Parameter vom Typ String ausgewählt wurde.

Interne ID: IDP_BATCH_ACTION_SETTAG_STR

Parameter

Parameter, auf den der definierte Sollwert als Reaktion auf das Ereignis geschrieben werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines Parameters. Bei der Parameterwahl gilt:

  • Es können nur Parameter der Grundfunktion ausgewählt werden, zu der die Reaktion gehört.
  • Es können sowohl Rückmeldeparameter als auch Befehlsparameter gewählt werden.
  • Wird ein Parameter umbenannt, wird die Änderung automatisch übernommen.
  • Der Parametersollwert kann abhängig vom Parameterdatentyp eingegeben werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTStr"

Sollwert für Parameter vom Typ String.

Zur Runtime wird während der Validierung des Rezepts überprüft, ob die Länge des Stringwerts kleiner als die maximale Stringlänge der der beim Parameter verknüpften String-Variable ist.

Interne ID: IDP_BATCH_ACTION_SETTAG_STR

Stringlänge

Nur verfügbar bei String-Variablen:
Maximale Anzahl von Zeichen, die die Variable aufnehmen kann.
Minimum: 0 Zeichen.
Maximum: 65535 Zeichen.
Default: 5 Zeichen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTStr"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSetTStr"


IDP_BATCH_ACTION_SRCTAG

Interne ID: IDP_BATCH_ACTION_SRCTAG

Quellparameter

Parameter, dessen Wert auf den in der Eigenschaft Zielparameter gewählten Parameters übertragen wird. Klick auf Schaltfläche ... öffnet Dialog zur Parameterauswahl.

Interne ID: IDP_BATCH_ACTION_SRCTAG

Zielparameter

Nur verfügbar, wenn ein Quellparameter gewählt wurde.

Parameter, auf den der Wert des in der Eigenschaft Quellparameter gewählten Parameters übertragen wird. Klick auf Schaltfläche ... öffnet Dialog zur Parameterauswahl. Es werden nur Parameter vom passenden Typ angeboten. Wird der Parameter umbenannt, wird die Änderung automatisch übernommen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSrcTag"

Beim Start der Grundfunktion zur Runtime wird der beim Quellparameter verknüpfte Wert der Variable abgefragt. Wird kein gültiger Wert empfangen, kann mittels der Reaktion „Verknüpfte Variable gestört" reagiert werden. Wird der Parameter umbenannt, wird die Änderung automatisch übernommen.

Zur Runtime wird während der Validierung überprüft, ob der Zielparameter vorhanden ist und die bei den Parametern verknüpften Variablen gültig und vom richtigen Typ sind.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActSrcTag"


IDP_BATCH_ACTION_TYPE

Interne ID: IDP_BATCH_ACTION_TYPE

Ereignis

Auswahl des Ereignistyps, bei dem die Reaktion ausgeführt werden soll, aus Dropdownliste.
Für jedes Ereignis können mehrere Reaktionen definiert werden. Die Ausführungsreihenfolge kann in der Detailansicht festgelegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BatchActType"


IDP_BATCH_MR_GENERAL_GRP

Interne ID: IDP_BATCH_MR_GENERAL_GRP

* * * ---! IDP_BATCH_MR_GENERAL_GRP fehlt in der VBAHelp !--- * * *

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_General"


IDP_BATCH_PHASE_ABORTING_CND

Interne ID: IDP_BATCH_PHASE_ABORTING_CND

Abbgebrochen

Bedingung für den Wechsel von abbrechend auf abgebrochen.

Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AbortingCnd"


IDP_BATCH_PHASE_DESCRIPTION

Interne ID: IDP_BATCH_PHASE_DESCRIPTION

Beschreibung

Frei definierbarer String zur näheren Beschreibung der Grundfunktion. Beschreibung ist sprachumschaltbar.

Maximale Länge: 512 Zeichen

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Description"


IDP_BATCH_PHASE_DONE

Interne ID: IDP_BATCH_PHASE_DONE

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Interne ID: IDP_BATCH_PHASE_DONE

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Done"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Done"


IDP_BATCH_PHASE_GENERAL_GRP

Interne ID: IDP_BATCH_PHASE_GENERAL_GRP

Allgemein

Allgemeine Eigenschaften der Grundfunktion.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_General"


IDP_BATCH_PHASE_HOLDING_CND

Interne ID: IDP_BATCH_PHASE_HOLDING_CND

Angehalten

Bedingung für den Wechsel von anhaltend auf angehalten.

Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HoldingCnd"


IDP_BATCH_PHASE_INTERLOCKING

Interne ID: IDP_BATCH_PHASE_INTERLOCKING

Eingangsverriegelung

Definiert Bedingung für Eingangsverriegelung. Klick auf Schaltfläche ... oder Eintrag öffnet den Formeleditor zur Definition einer Bedingung.
Wird eine Eingangsverriegelung konfiguriert, dann wird die Grundfunktion zur Runtime erst ausgeführt, wenn die Bedingung für die Eingangsverriegelung erfüllt wurde. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Die Formel gibt TRUE oder FALSE als Ergebnis aus. Die Bedingung kann zur Runtime angezeigt, aber nicht verändert werden.
Die Wartezeit für die Eingangsverriegelung wird mit der Eigenschaft Wartezeit Eingangsverrieglung konfiguriert.

Interne ID: IDP_BATCH_PHASE_INTERLOCKING

Wartezeit Eingangsverrieglung

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Eingangsverriegelung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Beginn der Prüfung der Eingangsverriegelung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Eingangsverriegelung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Interlocking"

Mehr in der Online-Hilfe .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Interlocking"


IDP_BATCH_PHASE_MINEXECTIME

Interne ID: IDP_BATCH_PHASE_MINEXECTIME

Minimale Ausführungsdauer

Minimale Ausführungsdauer der Grundfunktion.

  • >0: Zeitraum, der nach dem Schreiben der Befehlsparameter mindestens gewartet wird, unabhängig davon, ob die Weiterschaltbedingung erfüllt ist.
  • 0: Ausführungsdauer wird nicht überprüft

Minimale Ausführungsdauer kann Maximale Ausführungsdauer überschreiten.

Interne ID: IDP_BATCH_PHASE_MINEXECTIME

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: IDP_BATCH_PHASE_MINEXECTIME

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinExecTime"

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinExecTime"

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinExecTime"


IDP_BATCH_PHASE_NAME

Interne ID: IDP_BATCH_PHASE_NAME

Name

Name der Grundfunktion. Muss pro Aggregat eindeutig sein. Der Name darf keinen Punkt enthalten, nicht nur aus Leerzeichen bestehen und darf nicht leer sein. Name ist sprachumschaltbar.
Default: Grundfunktion x (wobei x eine fortlaufende Zahl ist).

Maximale Länge: 256 Zeichen

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


IDP_BATCH_PHASE_PARENT_UNIT_DESCRIPTION

Interne ID: IDP_BATCH_PHASE_PARENT_UNIT_DESCRIPTION

Aggregatbeschreibung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UnitDescription"


IDP_BATCH_PHASE_PARENT_UNIT_NAME

Interne ID: IDP_BATCH_PHASE_PARENT_UNIT_NAME

Aggregat

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Unit"


IDP_BATCH_PHASE_PAUSING_CND

Interne ID: IDP_BATCH_PHASE_PAUSING_CND

Pausiert

Bedingung für den Wechsel von pausierend auf pausiert.
Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PausingCnd"


IDP_BATCH_PHASE_RESTARTING_CND

Interne ID: IDP_BATCH_PHASE_RESTARTING_CND

Neu gestartet

Bedingung für den Wechsel von neu startend auf laufend.

Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RestartingCnd"


IDP_BATCH_PHASE_STOPPING_CND

Interne ID: IDP_BATCH_PHASE_STOPPING_CND

Gestoppt

Bedingung für den Wechsel von stoppend auf gestoppt.

Für die Bedingung kann eine Formel definiert werden. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden.
Option: Für die Gültigkeit der Grundfunktion können Variablen verknüpft werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StoppingCnd"


IDP_BATCH_PHASE_TOALLOCATION

Interne ID: IDP_BATCH_PHASE_TOALLOCATION

Wartezeit Aggregatsbelegung

Zeit in Tagen, Stunden, Minuten und Sekunden, die auf die Belegung des Aggregats gewartet wird. Die Wartezeit kann zur Runtime verändert werden, solange sich das Rezept im Status editierbar befindet.

Nach Ablauf der definierten Zeit wird das Ereignis Wartezeit Aggregatsbelegung überschritten ausgelöst und das Element hervorgehoben dargestellt. Weitere Aktionen müssen vom Projektanten definiert werden. Erfolgen keine weiteren Aktionen, wird weiter gewartet.

Maximum: 9999T 23:59:59
Default: 0T 00:00:00

Hinweis: Ein Aggregat kann immer nur von einem einzigen Rezept mit Status In Ausführung belegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ToAllocation"


IDP_BATCH_PHASE_TODONE

Interne ID: IDP_BATCH_PHASE_TODONE

Maximale Ausführungsdauer

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Weiterschaltbedingung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Schreiben der Befehlsparameter zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Weiterschaltbedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: IDP_BATCH_PHASE_TODONE

Weiterschaltbedingung

Definiert Bedingung für Weiterschaltung. Klick auf Schaltfläche ... oder Eintrag öffnet Formeleditor zur Definition einer Bedingung.
Bedingung kann zur Runtime angezeigt, aber nicht verändert werden. Die Zeitspanne, die auf die Erfüllung der Bedingung gewartet wird, wird mit der Eigenschaft Maximale Ausführungsdauer definiert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ToDone"

Hinweis: Zeit läuft weiter, wenn das Rezept/die Grundfunktion pausiert wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ToDone"


IDP_BATCH_PHASE_TOINTERLOCK

Interne ID: IDP_BATCH_PHASE_TOINTERLOCK

Wartezeit Eingangsverrieglung

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die in der Eigenschaft Eingangsverriegelung definierte Bedingung den Wert TRUE zurückgeben muss. Die Wartezeit beginnt mit dem Beginn der Prüfung der Eingangsverriegelung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit Eingangsverriegelung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Interne ID: IDP_BATCH_PHASE_TOINTERLOCK

Eingangsverriegelung

Definiert Bedingung für Eingangsverriegelung. Klick auf Schaltfläche ... oder Eintrag öffnet den Formeleditor zur Definition einer Bedingung.
Wird eine Eingangsverriegelung konfiguriert, dann wird die Grundfunktion zur Runtime erst ausgeführt, wenn die Bedingung für die Eingangsverriegelung erfüllt wurde. Die Formel kann aus einem oder mehreren Befehlsparametern und Rückgabeparametern der Grundfunktion bestehen. Wert und Status der Variablen können verwendet werden. Die Formel gibt TRUE oder FALSE als Ergebnis aus. Die Bedingung kann zur Runtime angezeigt, aber nicht verändert werden.
Die Wartezeit für die Eingangsverriegelung wird mit der Eigenschaft Wartezeit Eingangsverrieglung konfiguriert.

Mehr in der Online-Hilfe .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ToInterlocking"

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ToInterlocking"


IDP_BATCH_PHASE_TOPHASEEND

Interne ID: IDP_BATCH_PHASE_TOPHASEEND

Wartezeit nachfolgende Bedingungen

Zeitraum in Tagen, Stunden, Minuten und Sekunden, in dem die Grundfunktion abgeschlossen werden werden muss. Die Wartezeit beginnt mit dem Erreichen der Weiterschaltbedingung zu laufen. Wird innerhalb der Wartezeit die Bedingung nicht erfüllt, wird das Ereignis Wartezeit nachfolgende Bedingung überschritten ausgelöst und weiter gewartet. Wurde keine Reaktion auf das Ereignis definiert, das ein anderes Verhalten erzwingt, wird weiter gewartet bis die Bedingung erfüllt wird.

Wird als Wartezeit 0T 00:00:00 eingestellt, wird das Ereignis nicht ausgelöst.

  • Minimalwert: 0T 00:00:00
  • Maximalwert: 9999T 23:59:59
  • Default: 0T 00:00:00

Hinweis: Ob nachfolgende Bedingungen existieren, hängt von der Rezeptstruktur ab. Die Konfiguration einer Wartezeit sollte daher besser nicht im Editor erfolgen, sondern zur Runtime.

Die Wartezeit läuft unabhängig vom Rezeptstatus (also z. B. auch bei Rezept pausieren) und auch beim Beenden und Neustarten der Runtime ununterbrochen weiter.

Mehr in der Online-Hilfe im Kapitel Zeiten.
Mehr in der Online-Hilfe im Kapitel Nachfolgende Bedingung.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ToPhaseEnd"


IDP_BATCH_PHASE_TRANS_CND_GRP

Interne ID: IDP_BATCH_PHASE_TRANS_CND_GRP

Bedingungen transiente Status

Gruppe mit Eigenschaften für Übergangsbedingungen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GPR_TransCnd"


IDP_BATCH_PHASE_USER_GRP

Interne ID: IDP_BATCH_PHASE_USER_GRP

Benutzer-Grundfunktion

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_User"


IDP_BATCH_PHASE_USERFKT

Interne ID: IDP_BATCH_PHASE_USERFKT

Funktion

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserPFunc"


IDP_BATCH_PHASE_USERMSG

Interne ID: IDP_BATCH_PHASE_USERMSG

Meldungstext

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserPMsg"


IDP_BATCH_PHASE_USERPHASE

Interne ID: IDP_BATCH_PHASE_USERPHASE

Benutzer-Grundfunktion

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserPhase"


IDP_BATCH_PHASE_USERTIMEOUT

Interne ID: IDP_BATCH_PHASE_USERTIMEOUT

Wartezeit Bedienhandlung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UserPTimeout"


IDP_BATCH_TAG_DATATYPE

Interne ID: IDP_BATCH_TAG_DATATYPE

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

Interne ID: IDP_BATCH_TAG_DATATYPE

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DataType"

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_DATATYPE

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DataType"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DataType"


IDP_BATCH_TAG_DEFVALUE_BOOL

Interne ID: IDP_BATCH_TAG_DEFVALUE_BOOL

Wert Binär

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl und die Eigenschaft Parameterdatentyp auf Binär gesetzt wurde.

Interne ID: IDP_BATCH_TAG_DEFVALUE_BOOL

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_DEFVALUE_BOOL

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueBool"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueBool"

Interne ID: IDP_BATCH_TAG_DEFVALUE_BOOL

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueBool"

Interne ID: IDP_BATCH_TAG_DEFVALUE_BOOL

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueBool"

Wert für den binären Befehlsparameter. Auswahl aus Dropdownliste:
Aus (0):
Ein (1):
Toggeln: wechselt Zustand

Default: Aus (0)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueBool"


IDP_BATCH_TAG_DEFVALUE_MEUNIT

Interne ID: IDP_BATCH_TAG_DEFVALUE_MEUNIT

Einheit

Einheit für Wert.

Wird aus der in Eigenschaft Variable (Allgemein/Variablenverknüpfung) verknüpften Variable übernommen. Nur Anzeige, kann hier nicht geändert werden.

Interne ID: IDP_BATCH_TAG_DEFVALUE_MEUNIT

Variablenverknüpfung

Eigenschaften zur Verknüpfung von Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueMeUnit"

Interne ID: IDP_BATCH_TAG_DEFVALUE_MEUNIT

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueMeUnit"

Interne ID: IDP_BATCH_TAG_DEFVALUE_MEUNIT

Variable

Variable, die mit dem Parameter verknüpft wird. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Variablen werden dabei abhängig vom gewählten Parameterdatentyp gefiltert angezeigt. Es kann eine Variable aus dem lokalen Projekt oder einem anderen Projekt gewählt werden. Variable und Projekt müssen zur Runtime auch verfügbar sein. Wird die Variable umbenannt, wird die Änderung automatisch übernommen.

Interne ID: IDP_BATCH_TAG_DEFVALUE_MEUNIT

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

Interne ID: IDP_BATCH_TAG_DEFVALUE_MEUNIT

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueMeUnit"

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_DEFVALUE_MEUNIT

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueMeUnit"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueMeUnit"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueMeUnit"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueMeUnit"


IDP_BATCH_TAG_DEFVALUE_NUM

Interne ID: IDP_BATCH_TAG_DEFVALUE_NUM

Wert Numerisch

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl und die Eigenschaft Parameterdatentyp auf Numerisch gesetzt wurde.

Interne ID: IDP_BATCH_TAG_DEFVALUE_NUM

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_DEFVALUE_NUM

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueNum"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueNum"

Interne ID: IDP_BATCH_TAG_DEFVALUE_NUM

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueNum"

Interne ID: IDP_BATCH_TAG_DEFVALUE_NUM

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueNum"

Wert für den numerischen Befehlsparameter.

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueNum"


IDP_BATCH_TAG_DEFVALUE_STR

Interne ID: IDP_BATCH_TAG_DEFVALUE_STR

Wert String

Zeichenfolge, die für den Wert des Parameters verwendet wird.
Nur verfügbar, wenn in der Gruppe Allgemein, die die Eigenschaft Allgemein auf Befehl und die Eigenschaft Parameterdatentyp auf String gesetzt wurde.

Interne ID: IDP_BATCH_TAG_DEFVALUE_STR

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

Interne ID: IDP_BATCH_TAG_DEFVALUE_STR

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueStr"

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_DEFVALUE_STR

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueStr"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueStr"

Interne ID: IDP_BATCH_TAG_DEFVALUE_STR

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueStr"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueStr"


IDP_BATCH_TAG_DEFVALUE_TIME

Interne ID: IDP_BATCH_TAG_DEFVALUE_TIME

Wert Zeitdauer

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl und die Eigenschaft Parameterdatentyp auf Zeitdauer gesetzt wurde.

Interne ID: IDP_BATCH_TAG_DEFVALUE_TIME

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_DEFVALUE_TIME

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueTime"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueTime"

Interne ID: IDP_BATCH_TAG_DEFVALUE_TIME

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueTime"

Interne ID: IDP_BATCH_TAG_DEFVALUE_TIME

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueTime"

Angabe der Dauer in Tagen, Stunden, Minuten und Sekunden für den Befehlsparameter Zeitdauer.

Maximalwert: 0T 00:00:00

Minimalwert: 9999T 23:59:59

Default: 0T 00:00:00

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DefValueTime"


IDP_BATCH_TAG_DESCRIPTION

Interne ID: IDP_BATCH_TAG_DESCRIPTION

Beschreibung

Freier Text zur näheren Beschreibung des Parameters. Der Text ist zur Runtime sprachumschaltbar und wird im Dialog zur Bearbeitung der Grundfunktion und im Dialog zur Bearbeitung der Parameter angezeigt.

Maximum: 512 Zeichen

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Description"


IDP_BATCH_TAG_GENERAL_GRP

Interne ID: IDP_BATCH_TAG_GENERAL_GRP

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_General"


IDP_BATCH_TAG_MATERIAL

Interne ID: IDP_BATCH_TAG_MATERIAL

Materialverfolgung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Material"


IDP_BATCH_TAG_MAX

Interne ID: IDP_BATCH_TAG_MAX

Maximum Parameter

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl und die Eigenschaft Parameterdatentyp auf numerisch gesetzt wurde.

Interne ID: IDP_BATCH_TAG_MAX

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_MAX

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"

Interne ID: IDP_BATCH_TAG_MAX

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"

Interne ID: IDP_BATCH_TAG_MAX

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"

Maximalwert für den Parameter.

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Max"


IDP_BATCH_TAG_MIN

Interne ID: IDP_BATCH_TAG_MIN

Minimum Parameter

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl und die Eigenschaft Parameterdatentyp auf numerisch gesetzt wurde.

Interne ID: IDP_BATCH_TAG_MIN

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_MIN

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"

Interne ID: IDP_BATCH_TAG_MIN

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"

Interne ID: IDP_BATCH_TAG_MIN

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"

Minimalwert für den Parameter.

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Min"


IDP_BATCH_TAG_NAME

Interne ID: IDP_BATCH_TAG_NAME

Name

Name des Parameters. Dieser muss innerhalb der Grundfunktion eindeutig sein. Der Name darf nicht leer sein, keinen Punkt enthalten und nicht nur aus Leerzeichen bestehen. Groß-/Kleinschreibung wird unterschieden. Der Name ist zur Runtime sprachumschaltbar und wird im Dialog zur Bearbeitung der Grundfunktion und im Dialog zur Bearbeitung der Parameter angezeigt.

Maximum: 256 Zeichen

Default: Parameter x, wobei x als automatisch erstellte fortlaufende Nummerierung einen eindeutigen Namen sicher stellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


IDP_BATCH_TAG_PARENT_PHASE

Interne ID: IDP_BATCH_TAG_PARENT_PHASE

Grundfunktion

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Phase"


IDP_BATCH_TAG_PARENT_UNIT

Interne ID: IDP_BATCH_TAG_PARENT_UNIT

Aggregat

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Unit"


IDP_BATCH_TAG_RECIPEPARAM

Interne ID: IDP_BATCH_TAG_RECIPEPARAM

Im Rezept änderbar

Nur verfügbar, wenn in der Gruppe Allgemein die Eigenschaft Typ auf Befehl gesetzt wurde.

Interne ID: IDP_BATCH_TAG_RECIPEPARAM

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeParam"

Interne ID: IDP_BATCH_TAG_RECIPEPARAM

Allgemein

Allgemeine Eigenschaften für Parameter.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeParam"

Aktiv: Rezeptersteller kann zur Runtime Parameter modifizieren.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeParam"


IDP_BATCH_TAG_TAGTYPE

Interne ID: IDP_BATCH_TAG_TAGTYPE

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TagType"


IDP_BATCH_TAG_TIME_MAX

Interne ID: IDP_BATCH_TAG_TIME_MAX

Max. Zeit Variable

Maximum für Wert Zeitdauer einer Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxTime"


IDP_BATCH_TAG_TIME_MIN

Interne ID: IDP_BATCH_TAG_TIME_MIN

Min. Zeit Variable

Minimum für Wert Zeitdauer einer Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MinTime"


IDP_BATCH_TAG_VALUES_GRP

Interne ID: IDP_BATCH_TAG_VALUES_GRP

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_Values"


IDP_BATCH_TAG_VAR_DATENART

Interne ID: IDP_BATCH_TAG_VAR_DATENART

Variablendatentyp

Datentyp der Variable. Nur Anzeige.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarDataType"


IDP_BATCH_TAG_VAR_MAX

Interne ID: IDP_BATCH_TAG_VAR_MAX

Max. Wert Variable

Maximalwert der Variable. Nur Anzeige.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarMax"


IDP_BATCH_TAG_VAR_MIN

Interne ID: IDP_BATCH_TAG_VAR_MIN

Min. Wert Variable

Minimalwert der Variable. Nur Anzeige.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarMin"


IDP_BATCH_TAG_VAR_STRLENGTH

Interne ID: IDP_BATCH_TAG_VAR_STRLENGTH

Stringlänge

String-Länge, wie bei der Variable projektiert. Nur Anzeige

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarStrLength"


IDP_BATCH_TAG_VAR_TREIBER

Interne ID: IDP_BATCH_TAG_VAR_TREIBER

Treiber

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarDriver"


IDP_BATCH_TAG_VAR_TREIBERBEZ

Interne ID: IDP_BATCH_TAG_VAR_TREIBERBEZ

Treiberbezeichnung

Name des Treiber der Variable. Nur Anzeige.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarDriverDesc"


IDP_BATCH_TAG_VAR_UNIT

Interne ID: IDP_BATCH_TAG_VAR_UNIT

Einheit

Einheit der Variable. Nur Anzeige.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VarUnit"


IDP_BATCH_TAG_VARIABLE

Interne ID: IDP_BATCH_TAG_VARIABLE

Variable

Variable, die mit dem Parameter verknüpft wird. Klick auf Schaltfläche ... öffnet Dialog zur Variablenauswahl.

Variablen werden dabei abhängig vom gewählten Parameterdatentyp gefiltert angezeigt. Es kann eine Variable aus dem lokalen Projekt oder einem anderen Projekt gewählt werden. Variable und Projekt müssen zur Runtime auch verfügbar sein. Wird die Variable umbenannt, wird die Änderung automatisch übernommen.

Interne ID: IDP_BATCH_TAG_VARIABLE

Parameterdatentyp

Auswahl des Datentyps aus Dropdownliste für den in der Eigenschaft Typ gewählten Parametertyp. Als Datentyp kann gewählt werden:

Interne ID: IDP_BATCH_TAG_VARIABLE

Typ

Auswahl des Paramtertyps aus Dropdownliste:

  • Befehl: Befehlsparamter.
    Der für den Befehlsparameter definierte Wert wird bei der Ausführung der Grundfunktion auf die beim Befehlsparameter verknüpfte Variable geschrieben.
  • Rückgabe: Rückgabeparameter.
    Können zur Runtime über Reaktionen beschrieben werden.

Zur Runtime wird bei der Validierung des Rezepts für Befehlsparameter überprüft, ob:

  • die verknüpfte Variable existiert und vom richtigen Typ ist
  • der Wert für den Befehlsparameter innerhalb der Sollwertgrenzen der verknüpften Variablen liegt
  • in der Grundfunktion nur ein Befehlsparameter pro Variable existiert (verhindert, dass ein Befehlsparameter die Variable z. B. mit 0 beschreibt und ein weiteren Befehlsparameter mit 1)

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"

  • Binär: binäre Daten
  • Numerisch: numerische Daten
  • String: Zeichenfolge.
  • Zeitdauer: Zeitdauer

Die Auswahl des Datentyps beeinflusst die in der Gruppe Sollwert absetzen zur Verfügung stehenden Eigenschaften.

Interne ID: IDP_BATCH_TAG_VARIABLE

Sollwert absetzen

Gruppe für Eigenschaften zum Sollwert Absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"

Hinweis: Der Parameterdatentyp kann auch noch geändert werden, nachdem bereits eine Variable verknüpft und bereits ein Wert für den Befehlsparameter definiert worden ist. Das kann bei der Validierung des Rezepts in der Runtime zu Fehler führen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"


IDP_BATCH_TAG_VARIABLE_GRP

Interne ID: IDP_BATCH_TAG_VARIABLE_GRP

Variablenverknüpfung

Eigenschaften zur Verknüpfung von Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_Variable"


IDP_BATCH_TAG_VARIATIONMAX

Interne ID: IDP_BATCH_TAG_VARIATIONMAX

Abweichung positiv

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VariationMax"


IDP_BATCH_TAG_VARIATIONMIN

Interne ID: IDP_BATCH_TAG_VARIATIONMIN

Abweichung negativ

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VariationMin"


IDP_BATCH_UNIT_DESCRIPTION

Interne ID: IDP_BATCH_UNIT_DESCRIPTION

Beschreibung

Frei definierbarer String zur näheren Beschreibung des Aggregats. Diese Beschreibung steht zur Runtime im AUswahldialog der Grundfunktion zur Verfügung. Die Beschreibung ist sprachumschaltbar.

Maximale Länge: 512 Zeichen

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Description"


IDP_BATCH_UNIT_GENERAL_GRP

Interne ID: IDP_BATCH_UNIT_GENERAL_GRP

Allgemein

Allgemeine Eigenschaften des Aggregats.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_General"


IDP_BATCH_UNIT_NAME

Interne ID: IDP_BATCH_UNIT_NAME

Name

Name des Aggregats. Der Name muss pro Projekt eindeutig sein. Er darf keinen Punkt enthalten, nicht nur aus Leerzeichen bestehen und darf nicht leer sein. Name ist sprachumschaltbar.

Default: Aggregat x (wobei x eine fortlaufende Zahl ist).

Maximale Länge: 256 Zeichen

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


IDP_CEL_ARVERRPERIOD

Interne ID: IDP_CEL_ARVERRPERIOD

Archiv Auslagerung [h]

Zeit in Stunden für Fehlerbehandlung.

Wird beim Auslagern von Archiven ein Fehler festgestellt, erfolgt nach der eingestellten Zeitspanne ein Eintrag in die Chronologischen Ereignisliste (CEL).

Kann eine ARX-Datei nicht gelesen werden, wird diese in .ar_ umbenannt und die nächste Datei verwendet.
Default: 12

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ArciveOverPeriod"


IDP_CEL_LONGLIMITS

Interne ID: IDP_CEL_LONGLIMITS

Lange dynamische Grenzwerttexte CEL

Bestimmt, ob das Kommentarfeld für dynamische Grenzwerttexte zur Verfügung steht. Der dynamische Grenzwert erlaubt es, aktuelle Werte anderer Variablen in den Grenzwerttext einer Variablen einzufügen.

Aktiv: Dynamische Inhalte werden in einer Datei mit der Namenskonvention D*.CEL gespeichert. Diese wird zusätzlich zur Datei C*.CEL angelegt. Das Kommentarfeld kann damit für Kommentare benutzt werden. Dynamische Grenzwerttexte dürfen maximal 254 Zeichen lang sein.

Inaktiv: Das Kommentarfeld wird für die dynamischen Grenzwerttexte genutzt und ist für Kommentare gesperrt. Maximale Länge: 80 Zeichen.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LongDynLimits"


IDP_CEL_TEXTLEN

Interne ID: IDP_CEL_TEXTLEN

Länge statischer Grenzwerttexte CEL

Länge des statischen Grenzwerttexts in der CEL in Zeichen.

Legt fest, aus wie vielen Zeichen der statische Grenzwerttext in der CEL maximal bestehen darf. Die Minimal- und Maximalwerte gelten auch für VBA/VSTA.

Minimum: 127

Maximum: 1023

Default: 127

Einschränkung: Beim dBase-Export ist die Länge auf 256 Zeichen beschränkt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CELTextLen"


IDP_DYN_ELE_KBD

Interne ID: IDP_DYN_ELE_KBD

Keyboardbild verwenden

Beim Anwählen des Elementes zur Runtime wird das Keyboard aufgeschaltet.
Beim Anwählen eines freien Eingabefeldes zur Runtime wird das Keyboardbild DIALOGKBD (sofern vorhanden) aufgeschaltet.
Default: aktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KbdUsage"


IDP_DYN_ELE_KBD_NAME

Interne ID: IDP_DYN_ELE_KBD_NAME

Keyboardbild

Name des verknüpften Keyboardbildes.
Nur verfügbar unter Verwendung des Keyboardbildes:

Wurde hier kein Keyboardbild angegeben, kommt bei Stringvariablen das SETSTRINGKBD, bei numerischen Variablen (keine Bitvariablen) das SETVALUEKBD, bei Bitvariablen das SETBOOLKBD.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "KbdName"


IDP_DYNELE_ALC_ALIAS

Interne ID: IDP_DYNELE_ALC_ALIAS

Alias verwenden

Nur verfügbar, wenn Farbe aus ALC aktiv ist.
Aktiv: Alias wird verwendet. Das Element bezieht zur Runtime seine ALC-Farbe von einem anderen Element im topologischen Modell, ohne selbst Teil des Modells zu sein.

Interne ID: IDP_DYNELE_ALC_ALIAS

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAlias"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAlias"


IDP_DYNELE_ALC_ALIAS_NAME

Interne ID: IDP_DYNELE_ALC_ALIAS_NAME

Alias

Nur verfügbar, wenn Farbe aus ALC aktiv ist.

Interne ID: IDP_DYNELE_ALC_ALIAS_NAME

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAliasName"

Definiert Quellelement für Alias verwenden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl eines vorhandenen Elements.

Interne ID: IDP_DYNELE_ALC_ALIAS_NAME

Alias verwenden

Nur verfügbar, wenn Farbe aus ALC aktiv ist.
Aktiv: Alias wird verwendet. Das Element bezieht zur Runtime seine ALC-Farbe von einem anderen Element im topologischen Modell, ohne selbst Teil des Modells zu sein.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAliasName"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAliasName"


IDP_DYNELE_ALC_ALTCOL

Interne ID: IDP_DYNELE_ALC_ALTCOL

Alternative Farbe

Nur verfügbar, wenn die Eigenschaft Mehrfachversorgung darstellen den Wert alternative Farbe hat.

Interne ID: IDP_DYNELE_ALC_ALTCOL

Mehrfachversorgung darstellen

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.
Definiert die Darstellungsart, wenn das Element mit mehreren aktiven Quellen verbunden ist:
höchst-priore Quelle: Es wird nur die Farbe der Quelle mit der höchsten Priorität verwendet.
zwei höchst-priore Quellen: Die unterschiedlichen Farben der beiden Quellen mit der höchsten Priorität werden strichliert dargestellt.
alternative Farbe: Alternative Farbe für die Einfärbung bei Mehrfachversorgung.

Interne ID: IDP_DYNELE_ALC_ALTCOL

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAlternativeColor"

Default: höchst-priore Quelle

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAlternativeColor"

Alternative Farbe für die ALC Einfärbung bei Mehrfachversorgung.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCAlternativeColor"


IDP_DYNELE_ALC_DASHLEN

Interne ID: IDP_DYNELE_ALC_DASHLEN

Strichelungslänge mehrfachversorgt

Nur verfügbar, wenn die Eigenschaft Mehrfachversorgung darstellen den Wert zwei höchstpriore Quellen hat.

Interne ID: IDP_DYNELE_ALC_DASHLEN

Mehrfachversorgung darstellen

Nur verfügbar, wenn die Eigenschaft Farbe aus ALC aktiv ist.
Definiert die Darstellungsart, wenn das Element mit mehreren aktiven Quellen verbunden ist:
höchst-priore Quelle: Es wird nur die Farbe der Quelle mit der höchsten Priorität verwendet.
zwei höchst-priore Quellen: Die unterschiedlichen Farben der beiden Quellen mit der höchsten Priorität werden strichliert dargestellt.
alternative Farbe: Alternative Farbe für die Einfärbung bei Mehrfachversorgung.

Interne ID: IDP_DYNELE_ALC_DASHLEN

Farbe aus ALC

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist:
Aktiv: Die automatische Farbe der verknüpften Quelle(n) wird verwendet.
Inaktiv: Die Standard-Farbe wird verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCDashLen"

Default: höchst-priore Quelle

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCDashLen"

Definiert die Strichelungslänge in Pixel für die gestrichelte ALC-Einfärbung bei Mehrfachversorgung.

Minmal: 0 (automatische Strichelungslänge)

Maximal: 32767

Default: 0

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCDashLen"


IDP_DYNELE_ALC_EXCHANGEINOUT

Interne ID: IDP_DYNELE_ALC_EXCHANGEINOUT

Eingang/Ausgang tauschen

Nur verfügbar, wenn als Funktionstyp Trafo, Schalter, Schieber oder Trenner eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_EXCHANGEINOUT

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCExchangeInOut"

Aktiv: Verschiebt den Eingang des ALC-Elements nach rechts oder unten und den Ausgang nach links oder oben.

Default: inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCExchangeInOut"


IDP_DYNELE_ALC_GROUNDFAULTTYPE

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTTYPE

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTTYPE

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultType"

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultType"


IDP_DYNELE_ALC_GROUNDFAULTVARDISP

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARDISP

Anzeige

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Ausgangsvariable der Fehlerortung fest, um den Zustand des Erdschlusserkennungsgeräts anzuzeigen. Die hier verknüpfte Variable sollte eine lokale Variable sein, um Probleme im Netzwerkbetrieb zu verhindern. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARDISP

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARDISP

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarDisp"

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarDisp"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarDisp"


IDP_DYNELE_ALC_GROUNDFAULTVARFWD

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARFWD

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARFWD

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARFWD

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarFwd"

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarFwd"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarFwd"


IDP_DYNELE_ALC_GROUNDFAULTVARREV

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARREV

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARREV

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARREV

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarRev"

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarRev"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarRev"


IDP_DYNELE_ALC_GROUNDFAULTVARTRG

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARTRG

Auslösung

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable fest, die die Erkennung eines Erdschlusses anzeigt. Bei gerichteten Erdschlussmeldern muss zusätzlich die Richtung (Rückwärts oder Vorwärts) definiert werden. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARTRG

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarTrg"

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARTRG

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Erdschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarTrg"

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARTRG

Typ

Nur verfügbar, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_GROUNDFAULTVARTRG

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarTrg"

Legt die Richtung (voreilend/rückeilend) und die Verarbeitungsart der Meldung (keine, Dauermeldung oder Wischer) fest:

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

Wischer: Meldungen, die während einer laufenden Suche eintreffen, werden unterdrückt

nacheilend: auf die erste steigende Flanke einer Richtung wird 2 s gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch .

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarTrg"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCGroundFaultVarTrg"


IDP_DYNELE_ALC_LINEREACT

Interne ID: IDP_DYNELE_ALC_LINEREACT

Reaktanzwert der Leitung [Ohm]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCReact"


IDP_DYNELE_ALC_LINERESIST

Interne ID: IDP_DYNELE_ALC_LINERESIST

Resistanzwert der Leitung [Ohm]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCResist"


IDP_DYNELE_ALC_LOADTYPE

Interne ID: IDP_DYNELE_ALC_LOADTYPE

Last

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCLoadType"


IDP_DYNELE_ALC_LOADVAL

Interne ID: IDP_DYNELE_ALC_LOADVAL

Last fix [A]

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCLoadVal"


IDP_DYNELE_ALC_PROTID

Interne ID: IDP_DYNELE_ALC_PROTID

Schutzgerät-ID

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCProtID"


IDP_DYNELE_ALC_REVSRC

Interne ID: IDP_DYNELE_ALC_REVSRC

Quelle für Rückspeisung

Nur verfügbar, wenn Sie bei der Eigenschaft Funktionstyp Trafo selektiert haben.

Interne ID: IDP_DYNELE_ALC_REVSRC

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCReverseSourceID"

Auswahl der verknüpften Trafos.

Wenn Sie eine andere Quelle als UNDEFINED [0] selektieren, ist der Trafo rückwärtsspeisefähig. Das bedeutet, dass sich der Trafo in beiden Richtungen - vom Eingang zum Ausgang (Vorwärtsrichtung) und auch vom Ausgang zum Eingang (Rückwärtsrichtung) - gleich verhält. Der einzige Unterschied besteht darin, dass zur Weiterverbreitung die Quellnummer der Eigenschaft Quelle für Rückspeisung und nicht die der Eigenschaft Quelle verwendet wird.

Interne ID: IDP_DYNELE_ALC_REVSRC

Quelle

Nur verfügbar, wenn ein Funktionstyp Quelle oder Trafo ausgewählt ist:
Auswahl der verknüpften Quelle/Trafos.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCReverseSourceID"

Hinweis: Fehlerhafte Netzzustände oder fehlerhafte Projektierungen, wie z.B. gleichzeitige Speisung von Eingang und Ausgang oder Kurzschluss von Eingang und Ausgang werden nicht speziell eingefärbt. Das bedeutet, dass sich der rückwärtsspeisefähiger Trafo verhält wie zwei antiparallel geschaltete Trafos, die nicht rückwärtsspeisefähig sind.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCReverseSourceID"


IDP_DYNELE_ALC_SHORTFAULTTYPE

Interne ID: IDP_DYNELE_ALC_SHORTFAULTTYPE

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTTYPE

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultType"

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultType"


IDP_DYNELE_ALC_SHORTFAULTVARDISP

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARDISP

Anzeige

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARDISP

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARDISP

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarDisp"

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarDisp"

Legt die Ausgangsvariable der Fehlerortung fest, um den Zustand des Kurzschlusserkennungsgeräts anzuzeigen. Die hier verknüpfte Variable sollte eine lokale Variable sein, um Probleme im Netzwerkbetrieb zu verhindern. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarDisp"


IDP_DYNELE_ALC_SHORTFAULTVARFWD

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARFWD

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARFWD

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARFWD

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarFwd"

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarFwd"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarFwd"


IDP_DYNELE_ALC_SHORTFAULTVARREV

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARREV

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARREV

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARREV

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarRev"

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarRev"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarRev"


IDP_DYNELE_ALC_SHORTFAULTVARTRG

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARTRG

Auslösung

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARTRG

Typ

Steht nur zur Verfügung, wenn als Funktionstyp Schalter eingestellt wurde.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARTRG

Funktionstyp

Nur verfügbar, wenn Automatic Line Coloring (ALC) lizenziert ist.
Auswahl des Funktionstyps des Elements. Klick auf Funktionstyp öffnet Dropdownliste zur Auswahl:
Abschluss: Für Sammelschienenende; unterdrückt beim Kompilieren im Editor die Fehlermeldung "Linie nur einseitig angeschlossen“.
Generator: Element funktioniert als Generator (analog Quelle) - bei Aktivität wird die Farbe an den nächsten Linienzug weitergeleitet.
keine Funktion: Das Element hat im ALC keine Funktion.
Link: Die ALC-Information wird von einem Quell-Link an ein Ziel-Link weitergeleitet.
Quelle: Bei aktiver Quelle wird ihre Farbe an den nächsten Linienzug weitergeleitet.
Schalter: Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Schalter geschlossen ist und von einer Quelle versorgt wird.
Schieber (Ventil): Funktioniert analog Schalter. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn das Ventil offen, bzw. teilweise offen ist und wenn es von einer Quelle versorgt wird. Werte der Hauptvariable: siehe Handbuch.
Senke: Dieser Funktionstyp hat keine Auswirkung auf die Einfärbung. Mit VBA kann jedoch abgefragt werden, ob dieser Verbraucher versorgt wird.
Trafo: Wenn das Element versorgt wird, wandelt es eine Quelle (Farbe) in eine andere um.
Trenner: funktioniert analog Schalter, beinhaltet aber eine topologische Verriegelung Trenner unter Last. Die Farbe wird an den nächsten Linienzug weitergeleitet, wenn der Trenner geschlossen ist und von einer Quelle versorgt wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarTrg"

Legt die Verarbeitung der Meldung (keine oder Dauermeldung) und deren Richtung (voreilend/nacheilend) fest.

keine: normaler Schalter

Dauermeldung: Meldung wird als Erdschlussauslösung verarbeitet

nacheilend: auf die erste steigende Flanke einer Richtung wird gewartet

voreilend: aktuelle Zustand der Richtung wird verwendet

Default: keine

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarTrg"

Legt die Variable für die Meldung des Kurzschlusserkennungsgeräts fest. Bei gerichteten Kurzschlussmeldern muss zusätzlich die Richtung (Vorwärts oder Rückwärts) definiert werden. Klick auf Schaltfläche ... öffnet den Dialog zur Auswahl einer Variablen.

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARTRG

Rückwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung rückwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarTrg"

Interne ID: IDP_DYNELE_ALC_SHORTFAULTVARTRG

Vorwärts

Steht nur zur Verfügung, wenn ein Typ ausgewählt wurde.
Legt die Variable für Kurzschlusserkennung vorwärts fest. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Variablen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarTrg"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCShortFaultVarTrg"


IDP_DYNELE_ALC_VARCURI

Interne ID: IDP_DYNELE_ALC_VARCURI

Messwert des aktuellen Stromflusses

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCVarCurI"


IDP_DYNELE_ALC_VARCURP

Interne ID: IDP_DYNELE_ALC_VARCURP

Messwert der aktuellen Scheinleistung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCVarCurP"


IDP_DYNELE_ALC_VARLOAD

Interne ID: IDP_DYNELE_ALC_VARLOAD

Last variabel

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCVarLoad"


IDP_DYNELE_ALC_VARMAXI

Interne ID: IDP_DYNELE_ALC_VARMAXI

Grenzwert Strombelastbarkeit

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCVarMaxI"


IDP_DYNELE_ALC_VARPROTREACT

Interne ID: IDP_DYNELE_ALC_VARPROTREACT

Reaktanzwert aus Schutz

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ALCVarProtReact"


IDP_DYNELE_LIMITCOLOR_ACTIVE

Interne ID: IDP_DYNELE_LIMITCOLOR_ACTIVE

Grenzwertfarbe verwenden

Sie können festlegen, ob die bei der mit dem Element verknüpften Variable definierte Grenzwertfarbe in der Runtime dargestellt werden soll. Je nach Art des Elements wirkt sich die Farbe auf den angezeigten Text oder beim Universalregler auf dessen Indikator aus.

Aktiv: In der Runtime wird die definierte Grenzwertfarbe dargestellt.

Default: aktiv (um Kompatibilität zu gewährleisten)

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LimitColor"


IDP_ELE_POS_START_ANGLE

Interne ID: IDP_ELE_POS_START_ANGLE

Drehwinkel [°]

Frei definierbarer Winkel, um den das Element gedreht wird. Positive Werte drehen gegen den Uhrzeigersinn, negative Werte im Uhrzeigersinn. Werte über 360° werden als Differenz zu 360° dargestellt (400° entspricht 40°). Es können nur ganze Zahlen eingetragen werden.

Bei gedrehten Elementen sind folgende Aktionen nicht mehr möglich:
- spiegeln
- rotieren um +/- 90°
- skalieren per Pfeiltasten

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Angle"


IDP_ELE_VAR_LOCKING

Interne ID: IDP_ELE_VAR_LOCKING

Verriegelung

Verknüpfung einer existierenden Verriegelung zu diesem Element.

Wenn eine Bedingung in einer der Formeln der Verriegelung wahr ist, ist dieses Element gesperrt, sodass keine Bedienung mehr möglich ist. Falls in den Projekteigenschaften definiert, wird für die Dauer der Sperre ein Schlosssymbol auf dem Element angezeigt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Locking"


IDP_GFXRT_ROWHEIGHT

Interne ID: IDP_GFXRT_ROWHEIGHT

Zeilenhöhe [Pixel]

Nur verfügbar, wenn die Eigenschaft Erweiterte grafische Einstellungen aktiv ist.

Interne ID: IDP_GFXRT_ROWHEIGHT

Erweiterte grafische Einstellungen

Nur für PC verfügbar.

Steuert die Verwendung der anpassbaren horizontalen und vertikalen Bildlaufleisten, der Kopfzeile und des Rasters. Wenn Sie diese Eigenschaft aktivieren, können Sie die Anzeige des Listenfelds für die Alarmmeldeliste und die Chronologische Ereignisliste nach Ihren Wünschen anpassen.

Default: inaktiv.

Mehr im Online-Handbuch für AML

Mehr im Online-Handbuch für CEL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RowHeight"

Ermöglicht die Einstellung der Zeilenhöhe in Pixel unabhängig von der Schriftgröße.

Maximalwert: 4294967295 px
Minmalwert: 0 px - Zeilenhöhe wird an die Schriftgröße angepasst.

Default: 0

Achtung: Wird die Zeilenhöhe zu groß gewählt, wird unter umständen zur Runtime nichts angezeigt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RowHeight"


IDP_GRP_FCNMANAGER

Interne ID: IDP_GRP_FCNMANAGER

Funktionen

Eigenschaften für die Funktionsverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FncManager"


IDP_GRP_HDDMANAGER

Interne ID: IDP_GRP_HDDMANAGER

Hardisk Datenspeicherung

Eigenschaften für die Hardisk-Daten (HDD) Verwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HDD"


IDP_GRP_RGMSETTING

Interne ID: IDP_GRP_RGMSETTING

Rezeptgruppen Manager

Definieren Sie die Dateiablage für den Rezeptgruppen-Manager.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RGM"


IDP_GRP_RTDIALOGES

Interne ID: IDP_GRP_RTDIALOGES

Runtime Meldungen bei

Eigenschaften für Runtime-Meldungen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RTMessageBoxes"


IDP_HDD_ACTIVE

Interne ID: IDP_HDD_ACTIVE

HD-Daten aktiv

Aktiv: Harddisk-Daten (HDD) werden aufgezeichnet.
Inaktiv: Harddisk-Daten (HDD) werden nicht aufgezeichnet.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Active"


IDP_HDD_FILLDATA

Interne ID: IDP_HDD_FILLDATA

Daten Pufferung

Aktiv: Eine systemintern fest eingestellte Anzahl an Bytes wird gepuffert und dann blockweise gespeichert.
Inaktiv: Der jeweils ankommende Wert wird gespeichert.
Default: aktiv.

Berechnung: es wird jede kte Zykluszeit gespeichert. k ist der größte ganzzahlige Teiler der zu speichernden HD-Werte, der kleiner oder gleich 84 ist.
Beispiel: Anzahl Werte 300 -> Speicherung jeden 75. Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FillData"


IDP_LOCKED_BUTTONS

Interne ID: IDP_LOCKED_BUTTONS

Verriegelte Buttons

Definiert das Aussehen von Buttons zur Runtime, die aufgrund einer Verriegelung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Gesperrte Buttons (Benutzerverwaltung) kombiniert.

Interne ID: IDP_LOCKED_BUTTONS

Gesperrte Buttons

Nur verfügbar, wenn die Eigenschaft Temp. Login aktiv inaktiv ist.
Definiert das Aussehen von Buttons, die aufgrund der Einstellungen der Bedienberechtigung gesperrt sind. Wird zur Runtime für die Bedienung von Tasten mit der Eigenschaft Verriegelte Buttons (Grafische Ausprägung) kombiniert.

Interne ID: IDP_LOCKED_BUTTONS

Temp. Login aktiv

Aktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, wird er zur Eingabe seiner Kennung und seines Passworts aufgefordert.
Inaktiv: Wenn ein Benutzer nicht eingeloggt ist und ein Element zu bedienen versucht, das eine Bedienberechtigung erfordert, erhält er die Information, dass er dazu nicht berechtigt ist.
Default: aktiv.

Hinweis: Position und Größe der Login-Maske können in der zenon6.ini unter [Befehlsgabe] Position = definiert werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockedButtonStyle"

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockedButtonStyle"

Mögliche Darstellungsformen:

  • Grau
  • Normal
  • Unsichtbar

Default: Normal

Diese Eigenschaft wirkt unabhängig von der Eigenschaft Grafische Kennzeichnung aktiv. Ein grauer Button kann z.B. auch ein Schlosssymbol anzeigen.

Interne ID: IDP_LOCKED_BUTTONS

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockedButtonStyle"

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockedButtonStyle"


IDP_MENU_SEP_COLOR

Interne ID: IDP_MENU_SEP_COLOR

Farbe

Definieren Sie die Füllfarbe der Trennlinie. Die Farbe kann als Hexadezimalwert direkt in das Feld eingetragen oder nach Klick auf die Schaltfläche ... ausgewählt werden.

Default: schwarz

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SeparatorColor"


IDP_MENU_SEP_GROUP

Interne ID: IDP_MENU_SEP_GROUP

Trennlinie

Allgemeine Einstellungen zur Trennlinie in einem Menü.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GRP_Separator"


IDP_MENU_SEP_WIDTH

Interne ID: IDP_MENU_SEP_WIDTH

Breite

Definieren Sie die Breite der Trennlinie in Pixel.

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SeparatorWidth"


IDP_MSGCTRL_GSM_SMS_CHECK_MODEM

Interne ID: IDP_MSGCTRL_GSM_SMS_CHECK_MODEM

Verbindung prüfen

Klick auf Schaltfläche testet Verbindung zum Modem. Es wird getestet:

1. Öffnen und Vorbereiten des in der Eigenschaft Modemanschluss (seriell) definierten COM-Ports.

Interne ID: IDP_MSGCTRL_GSM_SMS_CHECK_MODEM

Modemanschluss (seriell)

Auswahl des COM-Ports, an dem das Modem ansprechbar ist. Klick öffnet Dropdownliste zur Auswahl. Korrekter Port kann in der Systemsteuerung in der Gruppe Telefon und Modem ausgelesen werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CheckModem"

2. Antwort des Modemsa.

3. PIN-Authentifizierung, wenn benötigt.

4. Modemkonfiguration. Für die Konfiguration wird für Nummer der Kurzmitteilungszentrale ein Dummy-Eintrag verwendet, da die Gültigkeit dieser Telefonnummer erst durch das Versenden einer SMS geprüft werden kann.

Interne ID: IDP_MSGCTRL_GSM_SMS_CHECK_MODEM

Nummer der Kurzmitteilungszentrale

Eingabe der Telefonnummer des SMSC (Kurzmitteilungszentrale) des verwendeten GSM-Providers. Eintrag muss eine gültige Telefonnummer sein und darf nur aus Ziffern bestehen. Ein führendes + als Kennzeichen für internationale Vorwahl ist erlaubt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CheckModem"

Der Erfolg oder Misserfolg des Tests wird in einer Meldung angezeigt. Fehlerinformationen werden in die LOG-Dateien geschrieben.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CheckModem"


IDP_MSGCTRL_GSM_SMS_COM_PORT

Interne ID: IDP_MSGCTRL_GSM_SMS_COM_PORT

Modemanschluss (seriell)

Auswahl des COM-Ports, an dem das Modem ansprechbar ist. Klick öffnet Dropdownliste zur Auswahl. Korrekter Port kann in der Systemsteuerung in der Gruppe Telefon und Modem ausgelesen werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SerialPort"


IDP_MSGCTRL_GSM_SMS_GRP

Interne ID: IDP_MSGCTRL_GSM_SMS_GRP

SMS-Nachricht (GSM-Modem)

Einstellungen für den SMS-Versand über GSM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DispatchSettings"


IDP_MSGCTRL_GSM_SMS_PIN

Interne ID: IDP_MSGCTRL_GSM_SMS_PIN

PIN-Code

Eingabe der PIN für das Modem. Eintrag darf nur aus Ziffern bestehen. Wird für die Verwendung des Modems kein PIN benötigt, wird der Wert dieser Eigenschaft ignoriert.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PersonalIdentificationNumber"


IDP_MSGCTRL_GSM_SMS_SMSC_NUMBER

Interne ID: IDP_MSGCTRL_GSM_SMS_SMSC_NUMBER

Nummer der Kurzmitteilungszentrale

Eingabe der Telefonnummer des SMSC (Kurzmitteilungszentrale) des verwendeten GSM-Providers. Eintrag muss eine gültige Telefonnummer sein und darf nur aus Ziffern bestehen. Ein führendes + als Kennzeichen für internationale Vorwahl ist erlaubt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SmscPhoneNumber"


IDP_NET_CHECK

Interne ID: IDP_NET_CHECK

Überpüfungsergebnis

Ausgabe des Überprüfungsergebnisses der Netzwerktopologie.

Keine Einträge möglich.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Check"


IDP_NET_COMPUTER

Interne ID: IDP_NET_COMPUTER

Rechnername

Name des Zielrechners im Netzwerk. Klick auf Schaltfläche ... öffnet Dropdownliste mit im Netzwerk angemeldeten Rechnern.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Computer"


IDP_NET_COMPUTER_GRP

Interne ID: IDP_NET_COMPUTER_GRP

Rechner

Eigenschaften für den Rechner in der Netzwerktopologie.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: ""


IDP_NET_DIRECTORY

Interne ID: IDP_NET_DIRECTORY

Startprojekt Runtime-Ordner

Runtime-Ordner des Startptrojekts am Zielrechner. Die Dateien des Startprojekts werden in diesem Ordner abgelegt, alle anderen Projekte relativ dazu, entsprechend der Struktur am lokalen PC. Verwenden Sie den Projektnamen als Ordnername, um automatisch die gleiche Struktur wie am Engineering-Rechner zu erzeugen.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WorkingPath"


IDP_NET_PROJECT

Interne ID: IDP_NET_PROJECT

Startprojekt

Startprojekt für den Zielrechner. Klick auf Dropdownliste öffnet Liste bereits vorhandener Projekte.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


IDP_PRN_MAXJOBS

Interne ID: IDP_PRN_MAXJOBS

Max. Druckaufträge

Maximale Anzahl der Druck Jobs im Druckmanager von Windows. Wenn diese Anzahl überschritten wird, so wird ein Eintrag in der Chronologischen Ereignisliste (CEL) generiert.
Minimum: 0.
Maximum: 65535.
Default: 90.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MaxPrintJobs"


IDP_PWL_EXECUTE

Interne ID: IDP_PWL_EXECUTE

Berechtigunsebene für Ausführung

Definiert die zum Verriegeln nötige Berechtigungsebene. Klick auf Ebene öffnet Dropdownliste zur Auswahl.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PwlExecute"


IDP_PWL_UNLOCK

Interne ID: IDP_PWL_UNLOCK

Berechtigunsebene zur Entriegelung

Definiert die zum Entriegeln nötige Berechtigungsebene. Klick auf Ebene öffnet Dropdownliste zur Auswahl.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PwlUnlock"


IDP_RGM_DATASOURCE

Interne ID: IDP_RGM_DATASOURCE

RGM Datenablage

Auswahl der gewünschte Dateiablage für den Rezeptgruppen-Manager aus Dropdown Liste:
MS Access DB: MS Access Datenbank. Nicht für Windows CE geeignet.
Binäre Dateien (CE kompatibel): Für Verwendung des RGM auf PC und unter Windows CE.

Default: Binäre Dateien (CE kompatibel)

Hinweis: Eine nachträgliche Konvertierung der Daten ist nicht vorgesehen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DataSource"


IDP_RGM_FILTER

Interne ID: IDP_RGM_FILTER

Filtertext

Definiert Filter für Variablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Filter"


IDP_RGM_GROUP_ALLGEMEIN

Interne ID: IDP_RGM_GROUP_ALLGEMEIN

Allgemein

Allgemeine Einstellungen für Rezeptgruppe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Allgemein"


IDP_RGM_GROUP_FEEDBACK

Interne ID: IDP_RGM_GROUP_FEEDBACK

Feedback

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback"


IDP_RGM_GROUP_FEEDBACK_CHECK

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK

Feedback Rezeptwerte prüfen

Rückmeldevariablen für Rezeptwert prüfen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT1

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT1

Kommentar 1

Kommentar 1 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment1"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT2

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT2

Kommentar 2

Kommentar 2 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment2"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT3

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT3

Kommentar 3

Kommentar 3 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment3"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT4

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT4

Kommentar 4

Kommentar 4 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment4"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT5

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT5

Kommentar 5

Kommentar 5 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment5"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT6

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT6

Kommentar 6

Kommentar 6 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment6"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT7

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT7

Kommentar 7

Kommentar 7 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment7"


IDP_RGM_GROUP_FEEDBACK_CHECK_CMT8

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_CMT8

Kommentar 8

Kommentar 8 des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Comment8"


IDP_RGM_GROUP_FEEDBACK_CHECK_DIFFER

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_DIFFER

Rezeptwerte Prüfen - Abweichungen

Abweichungen beim Ergebnis der Prüfung des Rezepts als Text.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Different"


IDP_RGM_GROUP_FEEDBACK_CHECK_NAME

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_NAME

Rezeptname

Name des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Name"


IDP_RGM_GROUP_FEEDBACK_CHECK_NUMBER

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_NUMBER

Rezeptnummer

Nummer des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Number"


IDP_RGM_GROUP_FEEDBACK_CHECK_RESULT

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_RESULT

Rezeptwerte Prüfen - Ergebnis

Ergebnis der Prüfung des Rezepts als nummerischer Wert.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Result"


IDP_RGM_GROUP_FEEDBACK_CHECK_RIGHTS

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_RIGHTS

Berechtigungsebene

Ebene der Bedienberechtigung des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Rights"


IDP_RGM_GROUP_FEEDBACK_CHECK_STATUS_NR

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_STATUS_NR

Rezeptstatus Nr.

Status des zuletzt geprüften Rezepts als Zahl.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Status_Nr"


IDP_RGM_GROUP_FEEDBACK_CHECK_STATUS_TXT

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_STATUS_TXT

Rezeptstatus Text

Status des zuletzt geprüften Rezepts. Der Text hat das Format: 1 - @Text
Dieser Text wird als Rohtext auf die Variable geschrieben. Um den Text übersetzt anzuzeigen, muss im Anzeigeelement (dynamischer Text) die Eigenschaft Anzeigetext übersetzen aktiv sein.

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_STATUS_TXT

Anzeigetext übersetzen

Aktiv: Die anzuzeigenden Texte werden übersetzt. Wird ein Text bearbeitet, wird der Entwurf ohne Übersetzung angezeigt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Status_Txt"

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Status_Txt"


IDP_RGM_GROUP_FEEDBACK_CHECK_TIMECHANGE

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_TIMECHANGE

Änderungszeit

Zeitpunkt der letzten Rezeptänderung des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Timechange"


IDP_RGM_GROUP_FEEDBACK_CHECK_USERCHANGE

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_USERCHANGE

Änderungsbenutzer

Name des angemeldeten Benutzers der letzten Rezeptänderung des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Userchange"


IDP_RGM_GROUP_FEEDBACK_CHECK_VERSION

Interne ID: IDP_RGM_GROUP_FEEDBACK_CHECK_VERSION

Rezeptversion

Version des zuletzt geprüften Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Check_Version"


IDP_RGM_GROUP_FEEDBACK_READ

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ

Feedback Rezept lesen

Rückmeldevariablen für Rezept lesen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read"


IDP_RGM_GROUP_FEEDBACK_READ_CMT1

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT1

Kommentar 1

Kommentar 1 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment1"


IDP_RGM_GROUP_FEEDBACK_READ_CMT2

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT2

Kommentar 2

Kommentar 2 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment2"


IDP_RGM_GROUP_FEEDBACK_READ_CMT3

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT3

Kommentar 3

Kommentar 3 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment3"


IDP_RGM_GROUP_FEEDBACK_READ_CMT4

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT4

Kommentar 4

Kommentar 4 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment4"


IDP_RGM_GROUP_FEEDBACK_READ_CMT5

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT5

Kommentar 5

Kommentar 5 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment5"


IDP_RGM_GROUP_FEEDBACK_READ_CMT6

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT6

Kommentar 6

Kommentar 6 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment6"


IDP_RGM_GROUP_FEEDBACK_READ_CMT7

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT7

Kommentar 7

Kommentar 7 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment7"


IDP_RGM_GROUP_FEEDBACK_READ_CMT8

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_CMT8

Kommentar 8

Kommentar 8 des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Comment8"


IDP_RGM_GROUP_FEEDBACK_READ_NAME

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_NAME

Rezeptname

Name des zuletzt gelesenen Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Name"


IDP_RGM_GROUP_FEEDBACK_READ_NUMBER

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_NUMBER

Rezeptnummer

Nummer des zuletzt gelesenen Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Number"


IDP_RGM_GROUP_FEEDBACK_READ_RESULT

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_RESULT

Rezept fertig gelesen

Ergebnis des Rezept Lesens als nummerischer Wert.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Result"


IDP_RGM_GROUP_FEEDBACK_READ_RIGHTS

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_RIGHTS

Berechtigungsebene

Ebene der Bedienberechtigung des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Rights"


IDP_RGM_GROUP_FEEDBACK_READ_STATUS_NR

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_STATUS_NR

Rezeptstatus Nr.

Status des zuletzt gelesenen Rezepts als Zahl.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Status_Nr"


IDP_RGM_GROUP_FEEDBACK_READ_STATUS_TXT

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_STATUS_TXT

Rezeptstatus Text

Status des zuletzt gelesenen Rezepts. Der Text hat das Format: 1 - @Text
Dieser Text wird als Rohtext auf die Variable geschrieben. Um den Text übersetzt anzuzeigen, muss im Anzeigeelement (dynamischer Text) die Eigenschaft Anzeigetext übersetzen aktiv sein.

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_STATUS_TXT

Anzeigetext übersetzen

Aktiv: Die anzuzeigenden Texte werden übersetzt. Wird ein Text bearbeitet, wird der Entwurf ohne Übersetzung angezeigt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Status_Txt"

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Status_Txt"


IDP_RGM_GROUP_FEEDBACK_READ_TIMECHANGE

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_TIMECHANGE

Änderungszeit

Zeitpunkt der letzten Rezeptänderung des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Timechange"


IDP_RGM_GROUP_FEEDBACK_READ_USERCHANGE

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_USERCHANGE

Änderungsbenutzer

Name des angemeldeten Benutzers bei der letzten Rezeptänderung des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Userchange"


IDP_RGM_GROUP_FEEDBACK_READ_VERSION

Interne ID: IDP_RGM_GROUP_FEEDBACK_READ_VERSION

Rezeptversion

Version des zuletzt gelesenen Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Read_Version"


IDP_RGM_GROUP_FEEDBACK_WRITE

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE

Feedback Rezept absetzen

Rückmeldevariablen für Rezept absetzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT1

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT1

Kommentar 1

Kommentar 1 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment1"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT2

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT2

Kommentar 2

Kommentar 2 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment2"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT3

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT3

Kommentar 3

Kommentar 3 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment3"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT4

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT4

Kommentar 4

Kommentar 4 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment4"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT5

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT5

Kommentar 5

Kommentar 5 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment5"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT6

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT6

Kommentar 6

Kommentar 6 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment6"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT7

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT7

Kommentar 7

Kommentar 7 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment7"


IDP_RGM_GROUP_FEEDBACK_WRITE_CMT8

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_CMT8

Kommentar 8

Kommentar 8 des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Comment8"


IDP_RGM_GROUP_FEEDBACK_WRITE_NAME

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_NAME

Rezeptname

Name des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Name"


IDP_RGM_GROUP_FEEDBACK_WRITE_NUMBER

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_NUMBER

Rezeptnummer

Nummer des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Number"


IDP_RGM_GROUP_FEEDBACK_WRITE_RESULT

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_RESULT

Rezept fertig abgesetzt

Ergebnis des Absetzens des Rezept als nummerischer Wert.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Result"


IDP_RGM_GROUP_FEEDBACK_WRITE_RIGHTS

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_RIGHTS

Berechtigungsebene

Ebene der Bedienberechtigung des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Rights"


IDP_RGM_GROUP_FEEDBACK_WRITE_STATUS_NR

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_STATUS_NR

Rezeptstatus Nr.

Status des zuletzt abgesetzten Rezeptes als Zahl.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Status_Nr"


IDP_RGM_GROUP_FEEDBACK_WRITE_STATUS_TXT

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_STATUS_TXT

Rezeptstatus Text

Status des zuletzt abgesetzten Rezepts. Der Text hat das Format: 1 - @Text
Dieser Text wird als Rohtext auf die Variable geschrieben. Um den Text übersetzt anzuzeigen, muss im Anzeigeelement (dynamischer Text) die Eigenschaft Anzeigetext übersetzen aktiv sein.

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_STATUS_TXT

Anzeigetext übersetzen

Aktiv: Die anzuzeigenden Texte werden übersetzt. Wird ein Text bearbeitet, wird der Entwurf ohne Übersetzung angezeigt.

Default: inaktiv

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Status_Txt"

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Status_Txt"


IDP_RGM_GROUP_FEEDBACK_WRITE_TIMECHANGE

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_TIMECHANGE

Änderungszeit

Zeitpunkt der letzten Rezeptänderung des zuletzt abgesetzten Rezepts.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Timechange"


IDP_RGM_GROUP_FEEDBACK_WRITE_USERCHANGE

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_USERCHANGE

Änderungsbenutzer

Name des angemeldeten Benutzers bei der letzten Rezeptänderung des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Userchange"


IDP_RGM_GROUP_FEEDBACK_WRITE_VERSION

Interne ID: IDP_RGM_GROUP_FEEDBACK_WRITE_VERSION

Rezeptversion

Version des zuletzt abgesetzten Rezeptes.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_Write_Version"


IDP_RGM_GROUP_FEEDBACK_XMLIMPORT

Interne ID: IDP_RGM_GROUP_FEEDBACK_XMLIMPORT

Feedback XML Import

Rückmeldevariablen für XML-Import.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_XMLImport"


IDP_RGM_GROUP_FEEDBACK_XMLIMPORT_RESULT

Interne ID: IDP_RGM_GROUP_FEEDBACK_XMLIMPORT_RESULT

Ergebnis des Importes

Erfolg des XML-Imports.

Klick auf Schaltfläche ... öffnet Dialog für Variablenauswahl.

Werte: Siehe Systemtreibervariablen - Rezepte Standard und RGM.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Feedback_XMLImport_Result"


IDP_RGM_INTERLOCKING

Interne ID: IDP_RGM_INTERLOCKING

Verriegelung

Zuordnung einer Verriegelung zur Variablen. Auswahl aus Dropdownliste.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Interlocking"


IDP_RGM_KEYBOARD

Interne ID: IDP_RGM_KEYBOARD

Keyboardbild

Verknüpfung eines Bildes vom Typ Keyboard, das zur Runtime bei Linksklick auf Variable zur Werteingabe aufgeschaltet werden soll. Klick auf Schaltfläche öffnet Dialog zur AUswahl.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Keyboard"


IDP_RGM_RCP_COMMENT3

Interne ID: IDP_RGM_RCP_COMMENT3

Kommentar 3

Kommentarzeile 3 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment3"


IDP_RGM_RCP_COMMENT4

Interne ID: IDP_RGM_RCP_COMMENT4

Kommentar 4

Kommentarzeile 4 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment4"


IDP_RGM_RCP_COMMENT5

Interne ID: IDP_RGM_RCP_COMMENT5

Kommentar 5

Kommentarzeile 5 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment5"


IDP_RGM_RCP_COMMENT6

Interne ID: IDP_RGM_RCP_COMMENT6

Kommentar 6

Kommentarzeile 6 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment6"


IDP_RGM_RCP_COMMENT7

Interne ID: IDP_RGM_RCP_COMMENT7

Kommentar 7

Kommentarzeile 7 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment7"


IDP_RGM_RCP_COMMENT8

Interne ID: IDP_RGM_RCP_COMMENT8

Kommentar 8

Kommentarzeile 8 zum aktuellen Rezept.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comment8"


IDP_RGM_RCP_COMMENTS_GRP

Interne ID: IDP_RGM_RCP_COMMENTS_GRP

Kommentare

Gruppe der Rezept-Kommentare. Pro Rezept können 8 Kommentare eingegeben werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Comments"


IDP_RGM_RECIPE_ALLGEMEIN

Interne ID: IDP_RGM_RECIPE_ALLGEMEIN

Allgemein

Allgemeine Eigenschaften des Rezepts.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Allgemein"


IDP_RGM_RECIPE_STATUS

Interne ID: IDP_RGM_RECIPE_STATUS

Status

Auswahl des Rezeptstatus aus Dropdownliste. (Konfiguration der Status in Eigenschaft Rezeptgruppen Manager /Bezeichner Rezeptstatus.) Der Rezeptstatus kann pro Rezeptversion unterschiedlich eingestellt werden. Diese Eigenschaft kann auch in der Runtime verändert werden.

Interne ID: IDP_RGM_RECIPE_STATUS

Rezeptversion

Zeigt die Versionsnummer des gewählten Rezeptes an. Nur Anzeige, keine Änderung möglich. Versionsnummer wird vom System automatisch gesetzt. Maximal können 89999 Rezeptversionen angelegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Status"

Interne ID: IDP_RGM_RECIPE_STATUS

Bezeichner Rezeptstatus

Konfiguration der Statusbezeichner. Klick auf Eigenschaft öffnet Dialog zur Konfiguration. Liste der Status wird bei der Statusauswahl im Rezept verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Status"

Interne ID: IDP_RGM_RECIPE_STATUS

Rezeptgruppen Manager

Definieren Sie die Dateiablage für den Rezeptgruppen-Manager.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Status"

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Status"


IDP_RGM_RECIPE_VERSION

Interne ID: IDP_RGM_RECIPE_VERSION

Rezeptversion

Zeigt die Versionsnummer des gewählten Rezeptes an. Nur Anzeige, keine Änderung möglich. Versionsnummer wird vom System automatisch gesetzt. Maximal können 89999 Rezeptversionen angelegt werden.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RecipeVersion"


IDP_RGM_REPORTFONT

Interne ID: IDP_RGM_REPORTFONT

Tabellenschrift einstellbar

Ermöglicht, dass bei Bildern des Typs Rezeptgruppen-Manager die Schrift einstellbar ist. Es wird die in der Eigenschaft Schrift projektierte Schriftart verwendet. Ansonsten ist diese Eigenschaft wirkungslos.

Interne ID: IDP_RGM_REPORTFONT

Schrift

Auswahl der Schrift, mit der die Darstellung erfolgt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReportFont"

Wird eine benutzerdefinierte Tabelle (mit Report Generator erstellt) verwendet, werden die im Report festgelegten Schriften verwendet.

Default: Inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ReportFont"


IDP_RGM_SHADOW_VARIABLE

Interne ID: IDP_RGM_SHADOW_VARIABLE

Schattenvariable

Schattenvariablen ermöglichen zur Runtime das Ändern eines RGM Rezeptwerts über ein Bild. Für jede in einer Rezeptgruppe vorhandene Variable kann eine Schattenvariable definiert werden. Zur Runtime wird die RGM Variable über die Funktion Rezeptgruppen-Manager mit der die Aktion Rezeptwerte auf Schattenvariablen schreiben durch eine durch eine Schattenvariable ersetzt und nach einer Änderung über die Aktion Schattenvariablen auf Rezeptwert schreiben in den RGM zurückgeschrieben.

Interne ID: IDP_RGM_SHADOW_VARIABLE

Rezeptgruppen-Manager

Diese Funktion schreibt, liest, kopiert, importiert oder exportiert ein ausgewähltes Rezept des optionalen Moduls Rezeptgruppen Manager (RGM). Wahlweise kann vorher ein Dialog für den Benutzer geöffnet werden.

Mehr im Online-Handbuch

Klick auf Schaltfläche öffnet Dialog zur AUswahl der Schattenvaríablen. Pro Rezeptgruppe kann eine Schattenvariable nur einmal verwendet werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShadowVariable"


IDP_RGM_STATUS_LIST

Interne ID: IDP_RGM_STATUS_LIST

Bezeichner Rezeptstatus

Konfiguration der Statusbezeichner. Klick auf Eigenschaft öffnet Dialog zur Konfiguration. Liste der Status wird bei der Statusauswahl im Rezept verwendet.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "StatusList"


IDP_RGM_VARLNK_ALLGEMEIN

Interne ID: IDP_RGM_VARLNK_ALLGEMEIN

Allgemein

Allgemeine Eigenschaften für Variable in Rezeptgruppe.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Allgemein"


IDP_RGM_VARLNK_BORDERS

Interne ID: IDP_RGM_VARLNK_BORDERS

Wertgrenzen

Einstellungen für Wertgrenzen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueBorders"


IDP_RGM_VARLNK_GENERAL

Interne ID: IDP_RGM_VARLNK_GENERAL

Werteigenschaften

Eigenschaften für Werte.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ValueGeneral"


IDP_RGM_VARLNK_RANGEFROMVAR

Interne ID: IDP_RGM_VARLNK_RANGEFROMVAR

Sollwertgrenzen von Variable übernehmen

Aktiv: Die Sollwertgrenzen werden dynamisch von der Variablen geholt und nicht fix in der Rezeptgruppe eingestellt.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RangeFromVar"


IDP_RGM_VARLNK_SHADOW

Interne ID: IDP_RGM_VARLNK_SHADOW

Schattenvariable

Eigenschaften für Schattenvariablen.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShadowVarGrp"


IDP_RGM_VISIBILITYVAR

Interne ID: IDP_RGM_VISIBILITYVAR

Sichtbarkeitsvariable

Auswahl einer Variablen zur Steuerung der Sichtbarkeit. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl.

Mehr in der Online-Hilfe.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibilityVar"


IDP_RTD_ACTION_OK

Interne ID: IDP_RTD_ACTION_OK

Datenexport

Aktiv: Bei erfolgreichem Export von Daten wird in der Runtime eine Meldung angezeigt.
Inaktiv: Die Erfolgsmeldung wird unterdrückt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ActionOK"


IDP_RTD_DLGFONT

Interne ID: IDP_RTD_DLGFONT

Dialogschrift

Nur verfügbar, wenn Dialogschrift einstellbar aktiviert ist.

Interne ID: IDP_RTD_DLGFONT

Dialogschrift einstellbar

Ermöglicht es, Dialoge und mehrseitige Einstellungen in der Runtime mit einer einstellbaren Schrift anzuzeigen. Die zu verwendende Schrift selektieren Sie mithilfe der Eigenschaft Dialogschrift.

aktiv: Die unter Dialogschrift selektierte Schrift wird in der Runtime verwendet.

inaktiv: Die Systemschrift wird in der Runtime für Dialoge und mehrseitige Einstellungen verwendet.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RtDlgFont"

Definieren Sie hier die Schrift, die in der Runtime für Dialoge und mehrseitige Einstellungen verwendet werden soll. Ein Klick auf die Schaltfläche öffnet den Dialog zur Schriftauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RtDlgFont"


IDP_RTD_ENDLGFONT

Interne ID: IDP_RTD_ENDLGFONT

Dialogschrift einstellbar

Ermöglicht es, Dialoge und mehrseitige Einstellungen in der Runtime mit einer einstellbaren Schrift anzuzeigen. Die zu verwendende Schrift selektieren Sie mithilfe der Eigenschaft Dialogschrift.

Interne ID: IDP_RTD_ENDLGFONT

Dialogschrift

Nur verfügbar, wenn Dialogschrift einstellbar aktiviert ist.

Definieren Sie hier die Schrift, die in der Runtime für Dialoge und mehrseitige Einstellungen verwendet werden soll. Ein Klick auf die Schaltfläche öffnet den Dialog zur Schriftauswahl.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnRtDlgFont"

aktiv: Die unter Dialogschrift selektierte Schrift wird in der Runtime verwendet.

inaktiv: Die Systemschrift wird in der Runtime für Dialoge und mehrseitige Einstellungen verwendet.

Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EnRtDlgFont"


IDP_RTD_FILE_REPLACE

Interne ID: IDP_RTD_FILE_REPLACE

Dateien ersetzen

Aktiv: Wenn beim Datenexport eine Datei überschrieben wird, wird in der Runtime eine Meldung angezeigt.
Inaktiv: Die Meldung wird unterdrückt.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FileReplace"


IDP_RTD_INSUFFICIENT_LEVEL

Interne ID: IDP_RTD_INSUFFICIENT_LEVEL

Berechtigung nicht ausreichend

Nur verfügbar, wenn Eigenschaft Fehlerhafter Eingabe aktiv ist.

Interne ID: IDP_RTD_INSUFFICIENT_LEVEL

Fehlerhafter Eingabe

Aktiv: Bei falschen Benutzereingaben (Sollwert setzen, einloggen, etc.) werden in der Runtime entsprechende Meldungen angezeigt.
Inaktiv: Die Meldungen werden unterdrückt. Für diesen Fall stehen im Systemtreiber Bit-Variables zur Verfügung, mit denen man durch das Verknüpfen einer Funktion mit einem Grenzwert auf die Falscheingaben individuell reagieren kann.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InsufficientLevel"

Aktiv: Führt zur Runtime ein Benutzer eine Funktion aus, die eine Berechtigungsebene erfordert, die der angemeldete Benutzer nicht erfüllt, wird ein Fenster mit einer Fehlermeldung angezeigt.

Inaktiv: Bei falscher Berechtigungsebene wird keine Fehlermeldung angezeigt. Die Systemtreibervariable keine Funktionsberechtigung wird trotzdem gesetzt und kann mittels Grenzwert oder Reaktionsmatrix ausgewertet werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InsufficientLevel"


IDP_RTD_INVALID_INPUT

Interne ID: IDP_RTD_INVALID_INPUT

Fehlerhafter Eingabe

Aktiv: Bei falschen Benutzereingaben (Sollwert setzen, einloggen, etc.) werden in der Runtime entsprechende Meldungen angezeigt.
Inaktiv: Die Meldungen werden unterdrückt. Für diesen Fall stehen im Systemtreiber Bit-Variables zur Verfügung, mit denen man durch das Verknüpfen einer Funktion mit einem Grenzwert auf die Falscheingaben individuell reagieren kann.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "InvalidInput"


IDP_RTP_PICTBACKCOUNT

Interne ID: IDP_RTP_PICTBACKCOUNT

Anzahl f. Bild zurück Fkt.

Anzahl der Bilder, die in die Liste für die Funktion "Bild zurück" eingetragen werden sollen.
Hinweis: Jeder Aufruf der Funktion Bildumschaltung zählt mit, auch wenn er nicht direkt erfolgt, sondern als Start-Funktion in den Bildeigenschaften eingetragen ist.
Minimum: 0.
Maximum: 65535.
Default: 10.

Interne ID: IDP_RTP_PICTBACKCOUNT

Start-Funktion

Funktion, die beim Öffnen des Bildes in der Runtime automatisch ausgeführt werden soll.
Öffnet den Funktionsauswahldialog.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackPictCount"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackPictCount"


IDP_RTP_SYSKEYLOCK

Interne ID: IDP_RTP_SYSKEYLOCK

Systemtasten sperren

Aktiv: Systemtasten wie Alt+Esc, Strg+Esc, Alt+Tab, Alt-F4 etc. werden in der Runtime gesperrt.
Inaktiv: Systemtasten werden nicht gesperrt.
Default: inaktiv

Mehr im Online-Handbuch

Hinweis: Weitere Systemtasten können zur Runtime über Keyblock Runtime Start gesperrt werden.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SysKeyLock"


IDP_RTP_WATCHFILES

Interne ID: IDP_RTP_WATCHFILES

Runtime-Dateien indizieren

Aktiv: Ein Verzeichnis-Cache für die Runtime-Daten wird für den schnelleren Zugriff aktiviert.
Inaktiv: Der Verzeichnis-Cache wird nicht verwendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FileWatcher"


IDP_STRATON_CMD_BINDPORT

Interne ID: IDP_STRATON_CMD_BINDPORT

Event-Port

Diese Eigenschaft ist nur in Verbindung mit dem Runtime-Starttyp “autom. starten stoppen” und “autom. starten” relevant.

Port Nummer, die die zenon Logic Runtime beim Starten öffnet. "Binding" stellt den Port für die spontane (event-basierte) Datenübertragung dar.
Minimum: 0.
Maximum: 4294967295.
Default: 9000.

ACHTUNG: Muss um 7800 höher sein als der Main Port.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDBindPort"


IDP_STRATON_CMD_HOST

Interne ID: IDP_STRATON_CMD_HOST

Host

Diese Eigenschaft ist nur in Verbindung mit dem Runtime-Starttyp "autom. starten stoppen" und "autom. starten" relevant.
Die zenon Logic Runtime startet nur wenn dieser Parameter mit der eigenen IP Adresse oder dem Computernamen übereinstimmt!

Für gewöhnlich sollte hier "localhost" oder 127.0.0.1 stehen. In wenigen Fällen ist es notwendig eine dezitierte IP Adresse (oder Rechnername) anzugeben. Dies ist dann notwendig wenn die zenon Logic Runtime bei mehreren, gleichen Einzelplatz-Projekten nur auf einem Rechner starten soll. Ein weiterer Grund könnte sein, wenn die zenon Logic Runtime auf einem zenon Client gestartet werden soll aber nicht auf dem Server.

Die Änderung dieses Paramters kopiert automatisch die Host-Adresse und den Main Port in die Konfiguration des entsprechenden straton32 Treibers. Sollte das unerwünscht sein, muss dieser Parameter im straton32 Treiber manuell geändert werden.

Default: localhost.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDHost"


IDP_STRATON_CMD_LOG

Interne ID: IDP_STRATON_CMD_LOG

Protokolldatei führen

Diese Eigenschaft ist nur in Verbindung mit dem Runtime-Starttyp “autom. starten stoppen” und “autom. starten” relevant.
Aktiv: Werden von der zenon Logic Runtime Fehlermeldungen ausgegeben, werden diese in einer Datei abgelegt.
Inaktiv: Werden von der zenon Logic Runtime Fehlermeldungen ausgegeben, werden diese nicht abgelegt.
Default: inaktiv.

ACHTUNG: Ein Schreiben von Protokolldateien kann den SPS-Zyklus beeinflussen!

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDTrace"


IDP_STRATON_CMD_MAINPORT

Interne ID: IDP_STRATON_CMD_MAINPORT

Standard-Port

Diese Eigenschaft ist nur in Verbindung mit dem Runtime-Starttyp "autom. starten stoppen" und "autom. starten" relevant.
Port Nummer, die die zenon Logic Runtime beim Starten öffnet. "Main" stellt den Port für die zyklische Abfrage (Pollen) der zenon Logic Werte dar.

Die Änderung dieses Paramters kopiert automatisch die Host-Adresse und den Main Port in die Konfiguration des entsprechenden straton32 Treibers. Sollte das unerwünscht sein, muss dieser Parameter im straton32 Treiber manuell geändert werden.

Minimum: 0.
Maximum: 4294967295.
Default: 1200.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDMainPort"


IDP_STRATON_CMD_PRIO

Interne ID: IDP_STRATON_CMD_PRIO

Realtime Priorität

Diese Eigenschaft ist nur in Verbindung mit dem Runtime-Starttyp “autom. starten stoppen” und “autom. starten” relevant.
Aktiv: Setzt den zenon Logic Runtime Prozess auf Windows Priorität "Echtzeit".
Inaktiv: Setzt den zenon Logic Runtime Prozess auf Windows Priorität "Normal".
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDPrio"


IDP_STRATON_CMD_REDUNDANCY

Interne ID: IDP_STRATON_CMD_REDUNDANCY

Redundanter Betrieb

Aktiv: Die zenon Logic Runtime wird redundant gestartet.
Inaktiv: Die zenon Logic Runtime wird nicht redundant gestartet.

ACHTUNG: Die Standby-Runtime muss gestartet werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDRedundancy"


IDP_STRATON_CMD_RETAINBYNAME

Interne ID: IDP_STRATON_CMD_RETAINBYNAME

Retain-Variablen mit Namen speichern

Speichert die Retain-Variablen mit ihrem Variablennamen, wenn Sie den Starttyp automatisch starten/stoppen ausgewählt haben. Außerdem werden Retain-Variablen in zenon Logic automatisch eingebettet.

Interne ID: IDP_STRATON_CMD_RETAINBYNAME

Starttyp

Der Starttyp definiert, ob und wie die zenon Logic Runtime mit der Leitsystem Runtime gestartet wird.
Autom. starten: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, läuft die zenon Logic Runtime weiter.
Autom. starten/stoppen: Die zenon Logic Runtime startet mit der Leitsystem Runtime. Wird die Leitsystem Runtime beendet, so wird auch die zenon Logic Runtime beendet.
Manuell starten: In Bezug auf die zenon Logic Runtime passiert nichts, wenn die Leitsystem Runtime gestartet oder beendet wird. In diesem Fall muss die zenon Logic Runtime manuell gestartet werden (z.B. mit dem zenon Logic Runtime Manager).
Default: autom. starten stoppen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDRetainByName"

Hinweis: Um diese Funktion auch bei manuellem Runtime-Start zu nützen, müssen Sie die Option auch aktivieren. Zusätzlich müssen Sie die Option über Kommandozeilenparameter bzw. INI-Datei/Einstellungsdialog aktivieren.

Default: aktiviert

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDRetainByName"


IDP_STRATON_CMD_START

Interne ID: IDP_STRATON_CMD_START

Startup

Diese Eigenschaft ist nur in Verbindung mit dem Runtime-Starttyp “autom. starten stoppen” und “autom. starten” relevant.
Kaltstart: Initialisiertes Hochlaufen. Auch Retain-Variablen werden initialisiert gestartet.
Kaltstart (laden v. RETAIN-Variablen: Initialisierter Hochlauf mit aktuellen Werten der Retain Variablen.
Hotstart: Restart mit allen Variablenwerten wie beim Beenden.
Default: Kaltstart.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDStartup"


IDP_STRATON_CMD_STEP

Interne ID: IDP_STRATON_CMD_STEP

Start im Schrittmodus

Diese Eigenschaft ist nur in Verbindung mit dem Runtime-Starttyp “autom. starten stoppen” und “autom. starten” relevant.
Aktiv: Startet die zenon Logic Runtime aber hält diese sofort im Debugging Modus an.
Inaktiv: Startet die zenon Logic Runtime normal.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CMDStep"


IDP_STRATON_FKT_WDG_TO

Interne ID: IDP_STRATON_FKT_WDG_TO

Funktion für Ausfallerkennung

Auswahl der Funktion, die nach Ablauf der der in der Eigenschaft Ausfallerkennung nach [s] definierten Zeitspanne ausgeführt werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Funktion.

Interne ID: IDP_STRATON_FKT_WDG_TO

Ausfallerkennung nach [s]

Angabe der Zeit in Sekunden, innerhalb der sich der Watchdog der zenon Logic Runtime ändern muss. Nach Überschreitung wird die in Funktion für Ausfallerkennung projektierte Funktion ausgeführt.

0: deaktiviert den Watchdog

Default: für neue Projekte 30 s, für bestehende Projekte 0 s.

Mehr in der Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VmFktWdgTo"

Nach Ablauf des Timeouts beginnt die Watchdogprüfung erst bei erneutem Anmelden der Runtime neu. Wird eine Funktion aus einem anderen Projekt verwendet, muss dieses Projekt bereits geladen sein, wenn das Projekt mit dem integrierten zenon Logic Projekt geladen wird.

Mehr in der Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VmFktWdgTo"


IDP_STRATON_RUNTIME

Interne ID: IDP_STRATON_RUNTIME

Runtime

Eigenschaften für die zenon Logic Runtime (Soft SPS).

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Runtime"


IDP_STRATON_TIMEOUT

Interne ID: IDP_STRATON_TIMEOUT

Verbindungstimeout [s]

Timeout (in Sekunden) für die Verbindung zu zenon Logic Zielsystemen.
Bei sehr leistungsarmen Zielplattformen kann dieser Timeout höher gestellt werden.
Minimum: 0.
Maximum: 4294967295.
Default: 10.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Timeout"


IDP_STRATON_WDG_TO

Interne ID: IDP_STRATON_WDG_TO

Ausfallerkennung nach [s]

Angabe der Zeit in Sekunden, innerhalb der sich der Watchdog der zenon Logic Runtime ändern muss. Nach Überschreitung wird die in Funktion für Ausfallerkennung projektierte Funktion ausgeführt.

Interne ID: IDP_STRATON_WDG_TO

Funktion für Ausfallerkennung

Auswahl der Funktion, die nach Ablauf der der in der Eigenschaft Ausfallerkennung nach [s] definierten Zeitspanne ausgeführt werden soll. Klick auf Schaltfläche ... öffnet Dialog zur Auswahl einer Funktion.

Nach Ablauf des Timeouts beginnt die Watchdogprüfung erst bei erneutem Anmelden der Runtime neu. Wird eine Funktion aus einem anderen Projekt verwendet, muss dieses Projekt bereits geladen sein, wenn das Projekt mit dem integrierten zenon Logic Projekt geladen wird.

Mehr in der Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VmWdgTo"

0: deaktiviert den Watchdog

Default: für neue Projekte 30 s, für bestehende Projekte 0 s.

Mehr in der Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VmWdgTo"


IDP_STRATON_WORKBENCH

Interne ID: IDP_STRATON_WORKBENCH

Workbench

Eigenschaften für die zenon Logic Workbench.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Workbench"


IDP_USER_LOGIN_RTP

Interne ID: IDP_USER_LOGIN_RTP

Runtimeprofil

Auswahl des Runtimeprofils, das dem Benutzer beim Einloggen zugewiesen werden soll. Mögliche Profile:

keines: Kein Profil wird zugeordnet

DEFAULT: Das Profil DEFAULT wird zugeordnet

LAST: Das Profil LAST wird zugeordnet

Default: keines

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LoginRTP"


IDP_VALUE_LEADING_ZEROS

Interne ID: IDP_VALUE_LEADING_ZEROS

Führende Nullen anzeigen

Nur verfügbar, wenn Sie bei der Eigenschaft Zahlenbasis für Anzeige Binär, Dezimal, Hexadezimal oder Oktal selektiert haben.

Interne ID: IDP_VALUE_LEADING_ZEROS

Zahlenbasis für Anzeige

Stellen Sie hier das Zahlensystem für die Darstellung der Werte ein. Folgende Zahlensysteme stehen Ihnen zur Verfügung:
Binär: Binäre Darstellung. Dieses Format wird durch ein "b" hinter dem Wert angezeigt.
Dezimal: Dezimale Darstellung.
Exponential: Dezimale Darstellung in exponentieller Schreibweise. Beispiel: 1E+03 entspricht 1000 in dezimaler Darstellung.
Hexadezimal: Hexadezimale Darstellung. Dieses Format wird durch ein "h" hinter dem Wert angezeigt.
Oktal: Oktale Darstellung. Dieses Format wird durch ein "o" hinter dem Wert angezeigt.
Default: Dezimal.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowLeadingZeros"

Entscheiden Sie, ob Sie bei der Anzeige des Zahlenwerts auch führende Nullen angezeigt bekommen möchten.

Aktiv: Die Zahlenwerte werden entsprechende ihrer Zahlenbasis mit unterschiedlich vielen Stellen angezeigt. Die von der Zahl nicht benötigten Stellen werden mit führenden Nullen aufgefüllt. Für die unterschiedlichen Zahlenbasen stehen folgende Stellen zur Verfügung:

- Binär: 32 Stelllen

- Dezimal: 10 Stellen

- Hexadezimal: 8 Stellen

- Oktal: 11 Stellen

Default: inaktiv

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ShowLeadingZeros"


IDS_A_GERAET

Interne ID: IDS_A_GERAET

A-Device

Nummer des A-Geräts.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeviceA"


IDS_ANIMATION

Interne ID: IDS_ANIMATION

GIF-Animation

Eigenschaften für die Animation, wenn eine animierte GIF Datei verwendet wird.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Animation"


IDS_B_GERAET

Interne ID: IDS_B_GERAET

B-Device

Nummer des B-Geräts.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeviceB"


IDS_BACNETNG_DATATYPE

Interne ID: IDS_BACNETNG_DATATYPE

BACnet data type

Definieren Sie, wie eine numerische Variable oder eine Stringvariable auf eine BACnet Eigenschaft abgebildet wird. Selektieren Sie den gewünschten Datentyp aus der Dropdownliste. Die Beschreibung der möglichen Datentypen finden Sie im Online-Handbuch.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BACnetDataType"


IDS_BACNETNG_EVENTSTATE

Interne ID: IDS_BACNETNG_EVENTSTATE

BACnet event state

Status des event state als Zahl darstellen. In diesem Fall kann der Text für den event state frei definiert werden.

Werte:

-1: Text wird verwendet

0: Normal

1: Fault

2: Off-normal

3: High-limit

4: Low-limit

5: Life-safety-alarm

Default: -1

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BACnetEventState"


IDS_BACNETNG_PROPERTYID

Interne ID: IDS_BACNETNG_PROPERTYID

BACnet property ID

Stellen Sie die Property ID ein für benutzerspezifische Eigenschaften oder wenn Sie die Eigenschaft nicht in Name oder Kennung angeben möchten.

Hinweis: Nur wenn Sie -1 einstellen, wird die Eigenschaft über Name bzw. Kennung ermittelt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BACnetPropertyID"


IDS_BACNETNG_STRINGLENGTH

Interne ID: IDS_BACNETNG_STRINGLENGTH

BACnet string length

Nur verfügbar, wenn Sie bei der Eigenschaft BACnet data type den Datentyp BITSTRING selektiert haben.

Interne ID: IDS_BACNETNG_STRINGLENGTH

BACnet data type

Definieren Sie, wie eine numerische Variable oder eine Stringvariable auf eine BACnet Eigenschaft abgebildet wird. Selektieren Sie den gewünschten Datentyp aus der Dropdownliste. Die Beschreibung der möglichen Datentypen finden Sie im Online-Handbuch.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BACnetStringLength"

Definieren Sie hier die Länge des Bitstrings in Bit.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BACnetStringLength"


IDS_BACNETNG_WRITEPRIORITY

Interne ID: IDS_BACNETNG_WRITEPRIORITY

BACnet write priority

Geben Sie die Schreibpriorität an, mit der die Variable geschrieben wird. Wenn Sie 0 eingeben, wird die Variable ohne Angabe der Schreibpriorität geschrieben.

Mögliche Werte sind 0 - 16.

Niedrigste Priorität: 16

Höchste Priorität: 1

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BACnetWritePriority"


IDS_BAZ_WERT

Interne ID: IDS_BAZ_WERT

Befehlsausgabezeit

Befehlsausgabezeit

TK160: Befehlsausgabezeit in ms

IEC Datentypen:

0… wie in AX parametriert

1… kurz

2… mittel

3… lang

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BAZ_WERT"


IDS_BAZ_WERT_ENG

Interne ID: IDS_BAZ_WERT_ENG

Command output time

TI160: Command output time in ms

IEC Data types:

0… as parameterized in AX

1… short

2… medium

3… long

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BAZ_WERT"


IDS_BITSIZE

Interne ID: IDS_BITSIZE

BitSize

Bit Size aus der Steuerung.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NGBitsize"


IDS_C_GERAET

Interne ID: IDS_C_GERAET

C-Device

Nummer des C-Geräts.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeviceC"


IDS_CTI_SECONDARYOBJECT

Interne ID: IDS_CTI_SECONDARYOBJECT

Secondary object

Gibt den sekundären Objekttyp an für

- Time/Zähler

- Drum

- Loop-Variable

- Alarm-Variable

Mehr in der Online-Hilfe

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SecondaryObject"


IDS_DATENPUNKT

Interne ID: IDS_DATENPUNKT

Datapoint

Datenpunktnummer aus der DDC.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Datapoint"


IDS_DLL

Interne ID: IDS_DLL

Dll

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Dll"


IDS_DP_GERAET

Interne ID: IDS_DP_GERAET

Datapoint to...

Gerät, das angesprochen werden soll, z.B B-Gerät.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DeviceDp"


IDS_DP_TYPE

Interne ID: IDS_DP_TYPE

Telegrammkennung

Telegrammtyp, Typkennung

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DP_TYPE"


IDS_DP_TYPE_ENG

Interne ID: IDS_DP_TYPE_ENG

Telegram Identifier

Telegram type, Message type

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DP_TYPE"


IDS_DYNAMICFARBE

Interne ID: IDS_DYNAMICFARBE

Farben dynamisch

Definition der Farben des Elements über die Grenzwertfarben der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Colors_Dynamic"


IDS_DYNAMISCH

Interne ID: IDS_DYNAMISCH

Größe und Drehen dynamisch

Eigenschaften zur Dynamik des Elements.
Die Darstellung des Elements wird über Zustände von Variablen zur Laufzeit dynamisch angepasst.

Hinweis: Einstellungen dieser Gruppe haben keine Auswirkung auf die Darstellung von bestimmten Kontrollelementen in Bildern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Dynamic"


IDS_EIB_ADRESSE

Interne ID: IDS_EIB_ADRESSE

EIB-Address

Die folgenden Properties dienen Ihnen zur Adressierung des EibV2_32-Treibers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EIB-Address"


IDS_EKANAL

Interne ID: IDS_EKANAL

Ersatz-PV

Ersatzvariable

Im Fehlerfall wird auf den Wert dieser Variablen umgeschaltet.

(siehe auch Parameter "Invalid-Behandlung")

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EW_EKANAL"


IDS_EKANAL_ENG

Interne ID: IDS_EKANAL_ENG

Substitute variable

Substitute variable

In case of invalid state will be switched over to the value of this variable.

(see also parameter "Invalid treatment")

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EW_EKANAL"


IDS_ELE_PROP_DREHEN

Interne ID: IDS_ELE_PROP_DREHEN

Drehen

Drehen des Elements abhängig vom Wert einer Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Twist"


IDS_ELE_PROP_XRICHTUNG

Interne ID: IDS_ELE_PROP_XRICHTUNG

X-Position dynamisch

Horizontales Verschieben des Elements abhängig vom Wert der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XPos"


IDS_ELE_PROP_XZOOMEN

Interne ID: IDS_ELE_PROP_XZOOMEN

Änderung Breite

Breite des Elements abhängig vom Wert der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "XZoom"


IDS_ELE_PROP_YRICHTUNG

Interne ID: IDS_ELE_PROP_YRICHTUNG

Y-Position dynamisch

Vertikales Verschieben des Elements abhängig vom Wert der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YPos"


IDS_ELE_PROP_YZOOMEN

Interne ID: IDS_ELE_PROP_YZOOMEN

Änderung Höhe

Höhe des Elements abhängig vom Wert der ausgewählten Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "YZoom"


IDS_ETS2_DATABASE

Interne ID: IDS_ETS2_DATABASE

ETS2 Database

Definieren Sie hier die gewünschte Datenbank. Ein Klick auf die Schaltfläche öffnet einen Dialog zur Auswahl der Datenbank. Alternativ tragen Sie den Namen der Datenbank manuell in das Textfeld ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ETS2Database"


IDS_EW

Interne ID: IDS_EW

Ersatzwert

Ersatzwert auf den umgeschaltet wird.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EW"


IDS_EW_ENG

Interne ID: IDS_EW_ENG

Substitute value

Substitute value to be switched on

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EW"


IDS_EWB

Interne ID: IDS_EWB

auf Ersatzwert schalten

Auf Ersatzwert schalten

Aktiv: Ersatzwert wird verwendet

Inaktiv: Ersatzwert wird nicht verwendet

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EWB"


IDS_EWB_ENG

Interne ID: IDS_EWB_ENG

Toggle to substitute value

Switch to substitute value

Active: Substitute value will be used

Inactive: Substitute value will not be used

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EWB"


IDS_EWB_INI

Interne ID: IDS_EWB_INI

Ersatzwert/Normalzustand initialisieren

Ersatzwert Initialisierung

Aktiv: Ersatzwert in der Runtime wird durch Normalzustand überschrieben

Inaktiv: Ersatzwert wird beibehalten

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EWB_INI"


IDS_EWB_INI_ENG

Interne ID: IDS_EWB_INI_ENG

Inititialize substitute value/normal state

Initialization of substitute value

Active: Substitute value will be overwritten in runtime by normal state

Inactive: Substitute value will be kept

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EWB_INI"


IDS_FOCUS_LINECOLOR

Interne ID: IDS_FOCUS_LINECOLOR

Fokus Linienfarbe

Definiert die Farbe des Rahmens, der zur Runtime das Objekt mit dem Fokus identifiziert. Die Farbe kann als Hexadezimalwert direkt in das Feld eingegeben oder nach Klick auf ... ausgewählt werden.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FocusLineColor"


IDS_FOCUS_LINEWIDTH

Interne ID: IDS_FOCUS_LINEWIDTH

Fokus Linienbreite

Definiert die Linienbreite des Rahmens, der zur Runtime das Objekt mit dem Fokus identifiziert.

Default: 3 Pixel

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FocusLineWidth"


IDS_GA

Interne ID: IDS_GA

GA-Antwort

Antwort auf Generalabfrage

Aktiv: Datenpunkt wird bei Generalabfrage gesendet

Inaktiv: Datenpunkt wird bei Generalabfrage nicht gesendet

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GA"


IDS_GA_ENG

Interne ID: IDS_GA_ENG

GI-Reply

Datapoint answers to General request

Active: Datapoint will be sent at General request

Inactive: Datapoint will not be sent at General request

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GA"


IDS_GT

Interne ID: IDS_GT

GT (Wdh.-rate in ms)

Befehlszykluszeit (Retriggerzeit) in ms

Regulierbefehle, Retriggerbefehle

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GT"


IDS_GT_ENG

Interne ID: IDS_GT_ENG

GT [ms]

Command cycle (retriggered) time in ms

Regulating-, triggered commands

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GT"


IDS_HAUPTGRUPPE

Interne ID: IDS_HAUPTGRUPPE

Main group

Geben Sie die Nummer der gewünschten Hauptgruppe ein.

Minimum: 0

Maximum: 15

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MainGroup"


IDS_HGFARBE_VARIABLE

Interne ID: IDS_HGFARBE_VARIABLE

Füllfarbe

Name der Variable, deren Grenzwertfarben die Hintergrund-/Füllfarbe des Elements beeinflussen sollen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorVariable"


IDS_HGFARBE_VARIABLE2

Interne ID: IDS_HGFARBE_VARIABLE2

Verlaufsfarbe

Name der Variable, deren Grenzwertfarbe die Verlaufsfarbe des Elements beeinflussen soll.
Klicken Sie in das Eingabefeld, um den Dialog für die Variablenauswahl zu öffnen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColorVariable2"


IDS_I_BIT

Interne ID: IDS_I_BIT

Invalid-Behandlung

keine: keine Behandlung.

letzter gültiger Wert: Umschaltung auf Ersatzwertabbild mit letzem ungestörtem Wert.

Umschaltung auf Ersatzwert: Umschaltung auf Ersatzwertabbild; Wert von parametriertem Ersatzwert.

Umschaltung auf Ersatz-PV: Umschaltung auf Ersatzwertabbild; Wert von der Ersatz-PV.

Ersatzwert nachführen: Umschaltung auf Ersatzwertabbild; Wert muss händisch nachgeführt werden.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "I_BIT"


IDS_I_BIT_ENG

Interne ID: IDS_I_BIT_ENG

Invalid treatment

Invalid treatment

No: no treatment

Last valid value: switch to substitute image; using last valid value

Toggle to substitute value: switch to substitute image; using parameterized substitute value

Toggle to substitute PV: switch to substitute image; using value from substitute PV

Correct substitute value: switch to substitute image; value must be corrected manually

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "I_BIT"


IDS_IEC61850_ADDR

Interne ID: IDS_IEC61850_ADDR

IEC61850-Address

IEC 61850-Adresse

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "I61850_ADR"


IDS_IEC61850_CDC

Interne ID: IDS_IEC61850_CDC

CDC

CDC

Auswahl des CDC für die Erweiterung "Logischer Knoten"

Default: DEFAULT

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "I61850_CDC"


IDS_IEC61850_EWB

Interne ID: IDS_IEC61850_EWB

Toggle to substitute value

Auf Ersatzwert schalten

Aktiv: Aktueller Wert = Ersatzwert

Inaktiv: Aktueller Wert = Prozesswert

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EWB"


IDS_IEC61850_EWB_INI

Interne ID: IDS_IEC61850_EWB_INI

Inititialize substitute value

Ersatzwert/Normalzustand initialisieren

Aktiv: Ersatzwert in der Runtime wird durch Prozesszustand überschrieben.

Inaktiv: Ersatzwert wird beibehalten.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "EW_INI"


IDS_IEC61850_GOOSE_ATTR1

Interne ID: IDS_IEC61850_GOOSE_ATTR1

GOOSE Attr1

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR1"


IDS_IEC61850_GOOSE_ATTR1_POS

Interne ID: IDS_IEC61850_GOOSE_ATTR1_POS

GOOSE Attr1 dataset position

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR1_POS"


IDS_IEC61850_GOOSE_ATTR2

Interne ID: IDS_IEC61850_GOOSE_ATTR2

GOOSE Attr2

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR2"


IDS_IEC61850_GOOSE_ATTR2_POS

Interne ID: IDS_IEC61850_GOOSE_ATTR2_POS

GOOSE Attr2 dataset position

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR2_POS"


IDS_IEC61850_GOOSE_ATTR3

Interne ID: IDS_IEC61850_GOOSE_ATTR3

GOOSE Attr3

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR3"


IDS_IEC61850_GOOSE_ATTR3_POS

Interne ID: IDS_IEC61850_GOOSE_ATTR3_POS

GOOSE Attr3 dataset position

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR3_POS"


IDS_IEC61850_GOOSE_ATTR4

Interne ID: IDS_IEC61850_GOOSE_ATTR4

GOOSE Attr4

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR4"


IDS_IEC61850_GOOSE_ATTR4_POS

Interne ID: IDS_IEC61850_GOOSE_ATTR4_POS

GOOSE Attr4 dataset position

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR4_POS"


IDS_IEC61850_GOOSE_ATTR5

Interne ID: IDS_IEC61850_GOOSE_ATTR5

GOOSE Attr5

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR5"


IDS_IEC61850_GOOSE_ATTR5_POS

Interne ID: IDS_IEC61850_GOOSE_ATTR5_POS

GOOSE Attr5 dataset position

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_ATTR5_POS"


IDS_IEC61850_GOOSE_IDX

Interne ID: IDS_IEC61850_GOOSE_IDX

GOOSE Index

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "GOOSE_INDEX"


IDS_IEC61850_IBIT

Interne ID: IDS_IEC61850_IBIT

Invalid treatment

Invalid-Behandlung

keine: keine Behandlung

letzter gültiger Wert: Umschaltung auf Ersatzwertabbild mit letzem ungestörtem Wert

Umschaltung auf Ersatzwert: Umschaltung auf Ersatzwertabbild; Wert von parametriertem Ersatzwert

Umschaltung auf Ersatz-PV: Umschaltung auf Ersatzwertabbild; Wert von der Ersatz-PV

Ersatzwert nachführen: Umschaltung auf Ersatzwertabbild; Wert muss händisch nachgeführt werden

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "I_BIT"


IDS_IEC61850_LANNR

Interne ID: IDS_IEC61850_LANNR

IEC61850-Stationnumber

IEC61850-Stationsnummer

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "I61850_LAN"


IDS_IEC61850_MERKER

Interne ID: IDS_IEC61850_MERKER

Marker

Merker

Aktiv: Variable ohne Prozessbezug (Adresse wird nicht geprüft; für interne Verwendung)
Siehe auch Interntreiber

Inaktiv: Variable wird vom Prozess aktualisiert

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MERKER"


IDS_IEC61850_ST_SAVE

Interne ID: IDS_IEC61850_ST_SAVE

Save state

Status speichern

Aktiv: Status der Variablen wird auf Festplatte gespeichert

Wird bei Neustart der Runtime rückgelesen.

Inaktiv: Status wird nicht gespeichert.

Default: Inaktiv

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ST_SAVE"


IDS_IEC61850_VAL_SAVE

Interne ID: IDS_IEC61850_VAL_SAVE

Save value

Wert speichern

Aktiv: Wert der Variablen wird auf Festplatte gespeichert

Wird bei Neustart der Runtime rückgelesen.

Inaktiv: Wert wird nicht gespeichert.

Default: Inaktiv

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VAL_SAVE"


IDS_IEC61850_WERT

Interne ID: IDS_IEC61850_WERT

IEC61850-Value

IEC61850 Wert

Dieser Wert legt bei den CDCs INS, INC, SGCB und ACD fest, welche Einzelmeldung/Einzelbefehl ausgewertet wird

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "I61850_VAL"


IDS_IGROUP

Interne ID: IDS_IGROUP

iGroup

Indexgruppe aus der Steuerung.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NGIGroup"


IDS_ILON_DATAPOINT

Interne ID: IDS_ILON_DATAPOINT

iLON Datapoint

Klick auf die Schaltfläche öffnet eine Verbindung zum ILON Router zur Auswahl der Variablen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "iiLonDataPoint"


IDS_INOUT

Interne ID: IDS_INOUT

Prozessrichtung

Prozessrichtung

Empfangen: Datenpunkt wird nur empfangen (z.B. Meldungen, Messwerte)

Senden: Datenpunkt wird gesendet (z.B. Befehle, Sollwerte).

Damit ein Datenpunkt gesendet werden kann, muss auch SW setzen aktiv aktiviert sein (siehe "Sollwert setzen").

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Send"


IDS_INOUT_ENG

Interne ID: IDS_INOUT_ENG

Prozess direction

Process direction

Receive: Datapoint will be received only (e.g. messages, measuring values)

Send: Datapoint will be sent (e.g. commands, setpoints).

To be able to be sent, the datapoint has to have also the Set value active property active (see "Set value").

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Send"


IDS_KURVE_NEU

Interne ID: IDS_KURVE_NEU

Kurven

Eigenschaften für die Kurven des Trendelements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Curves"


IDS_LINIENFARBE_VARIABLE

Interne ID: IDS_LINIENFARBE_VARIABLE

Text-/Linienfarbe

Name der Variable, deren Grenzwertfarben die Linien-/Textfarbe des Elements beeinflussen sollen.
Öffnet den Variablenauswahldialog.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LineColorVariable"


IDS_LOGID

Interne ID: IDS_LOGID

Log ID

Geben Sie die Adresse des Logs (Log ID) in der Steuerung ein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Log ID"


IDS_LON_DATABASE

Interne ID: IDS_LON_DATABASE

LON Database

Klick auf die Schaltfläche öffnet die Lon Datenbank zur Auswahl der Variablen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LonDatabase"


IDS_MERKER

Interne ID: IDS_MERKER

Merker

Aktiv: Variable ohne Prozessbezug (Adresse wird nicht geprüft; für interne Verwendung)

siehe auch Interntreiber

Inaktiv: Variable wird vom Prozess aktualisiert

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MERKER"


IDS_MERKER_ENG

Interne ID: IDS_MERKER_ENG

Marker

Active: Datapoint will not be updated by process value (can be used as internal variable, doesn't need a datapoint address)

Inactive: Datapoint will be updated by process value

see also Driver Intern

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MERKER"


IDS_MITTELGRUPPE

Interne ID: IDS_MITTELGRUPPE

Middle group

Geben Sie die Nummer der gewünschten Mittelgruppe ein.

Minimum: 0

Maximum: 7

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "MiddleGroup"


IDS_NG_ADRESSE

Interne ID: IDS_NG_ADRESSE

Beckhoff specific

Einstellungen für Bitsize und Igroup.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NGAddress"


IDS_NODE

Interne ID: IDS_NODE

Node

Geben Sie die Knotenadresse der Steuerung an.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Node"


IDS_NWMAGENT

Interne ID: IDS_NWMAGENT

NWM-Agent kopieren

Über diese Funktion kann ein bereits angelegter Agent auf einen neuen kopiert werden.

Der neue Agent muss zuvor angelegt worden sein.

Es werden alle zugehörigen Variablen erzeugt.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NWM-Agent"


IDS_NWMPARA

Interne ID: IDS_NWMPARA

NWM-Parameter

Öffnen des Parameterdialogs.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NWM-Parameter"


IDS_OKT1

Interne ID: IDS_OKT1

O1/Region

Regionsnummer bzw. Octet 1 (CASDU1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "R_NR"


IDS_OKT1_ENG

Interne ID: IDS_OKT1_ENG

O1/Region number

Region number or Octet 1 (CASDU1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "R_NR"


IDS_OKT2

Interne ID: IDS_OKT2

O2/Komponente

Komponentennummer bzw. Octet 2 (CASDU2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "K_NR"


IDS_OKT2_ENG

Interne ID: IDS_OKT2_ENG

O2/Component

Component number or Octet 2 (CASDU2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "K_NR"


IDS_OKT3

Interne ID: IDS_OKT3

O3/Baugruppe

Baugruppennummer bzw. Octet 3 (IOA1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "B_NR"


IDS_OKT3_ENG

Interne ID: IDS_OKT3_ENG

O3/Board

Board number or Octet 3 (IOA1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "B_NR"


IDS_OKT4

Interne ID: IDS_OKT4

O4/Wertnummer

Wertnummer bzw. Octet 4 (IOA2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "W_NR"


IDS_OKT4_ENG

Interne ID: IDS_OKT4_ENG

O4/Value number

Value number or Octet 4 (IOA2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "W_NR"


IDS_OKT5

Interne ID: IDS_OKT5

O5/Datenart

Datenart bzw. Octet 5 (IOA3)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DA"


IDS_OKT5_ENG

Interne ID: IDS_OKT5_ENG

O5/Subaddress

Data type or Octet 5 (IOA3)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DA"


IDS_OKT6

Interne ID: IDS_OKT6

Point

Pointnummer bzw. Octet 6

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PT"


IDS_OKT6_ENG

Interne ID: IDS_OKT6_ENG

Point

Point number or Octet 6

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "PT"


IDS_POS1

Interne ID: IDS_POS1

Position 1

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Position1"


IDS_POS2

Interne ID: IDS_POS2

Position 2

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Position2"


IDS_PROJEKT_ACTIVE_DIR

Interne ID: IDS_PROJEKT_ACTIVE_DIR

Zugriff auf Active Directory

Selektieren Sie, ob Sie das Active Directory, ADAM oder keines von beiden benutzen möchten. Folgende Optionen stehen Ihnen zur Verfügung.

- ADAM - Active Directory Application Mode: Sie benutzen ADAM oder AD LDS. Stellen Sie sicher, dass Sie die entsprechenden Einstellung für die Eigenschaften ADAM/AD-LDS Verbindung, ADAM/AD-LDS Benutzername und ADAM/AD-LDS Passwort vornehmen.

Interne ID: IDS_PROJEKT_ACTIVE_DIR

ADAM/AD-LDS Passwort

Kennwort des lokalen Benutzers des ADAM/AD LDS PCs.

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseActiveDirectory"

Interne ID: IDS_PROJEKT_ACTIVE_DIR

ADAM/AD-LDS Benutzername

Benutzername eines lokalen Benutzers des ADAM/AD LDS PCs mit Administratorrechten.

Mehr zu AD-LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseActiveDirectory"

Interne ID: IDS_PROJEKT_ACTIVE_DIR

ADAM/AD-LDS Verbindung

Verbindungspfad zu ADAM bzw. AD LDS.

Der Verbindungspfad muss in folgender Form eingegeben werden: [PC-Name]:[Port]/[Organisation]

Beispiel: w3k:50000/O=700,c=com

Mehr zu AD LDS im Online-Handbuch.

Mehr zu ADAM im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseActiveDirectory"

- Ja: Sie benutzen Active Directory.

- Nein: Sie greifen nicht auf die Benutzer von ADAM bzw. AD LDS oder AD zu. Die in zenon verwendeten Benutzer sind vollkommen unabhängig von Windows Benutzern.

Default: Nein

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "UseActiveDirectory"


IDS_PROJEKT_DIRS

Interne ID: IDS_PROJEKT_DIRS

Dateiablage

Der Konfigurationsdialog für die Projekt-Pfade wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProjectPaths"


IDS_PROJEKT_INFO

Interne ID: IDS_PROJEKT_INFO

Projektbeschreibung

Der Konfigurationsdialog für die Projekt-Information wird geöffnet.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProjectInfo"


IDS_PROJEKT_MODIFILES

Interne ID: IDS_PROJEKT_MODIFILES

RT änderbare Daten

Der Konfigurationsdialog für die Runtime änderbaren Daten wird geöffnet.
Standard-Rezepte, Rezeptgruppen-Manager, Scheduler oder Production and Facility Scheduler und Benutzerverwaltung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProjectModidata"


IDS_PROJEKT_REMTRANS

Interne ID: IDS_PROJEKT_REMTRANS

Remote-Transport

Der Konfigurationsdialog für den Remote Transport wird geöffnet.
Der Remote Transport dient dem transportieren, nachladen, starten und beenden eines Projekts auf einem entfernten Rechner und dem anfordern des aktuellen Status.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ProjectTransport"


IDS_RED

Interne ID: IDS_RED

redundante Peripherieadresse

Redundante Adresse

Aktiv: Redundante Adresse verwenden

Inaktiv: Keine redundante Adresse

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RED"


IDS_RED_ENG

Interne ID: IDS_RED_ENG

Redundancy Peripheral address

Redundant address

Active: Use redundant address

Inactive: No redundant address

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "RED"


IDS_REG

Interne ID: IDS_REG

Regulierbefehl

Regulierbefehle, Retriggerbefehle

Aktiv: Befehl ist Regulierbefehl

Inaktiv: Standardbefehl

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "REG"


IDS_REG_ENG

Interne ID: IDS_REG_ENG

Enable regulating commands

Regulating-, triggered commands

Active: Command is regulating-, triggered command

Inactive: Standard command

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "REG"


IDS_RLINE

Interne ID: IDS_RLINE

REYDISP-Linie

REYDISP Liniennummer

Nur bei Störschrieb-Datenpunkt

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LINIE"


IDS_RLINE_ENG

Interne ID: IDS_RLINE_ENG

REYDISP-Line

REYDISP line number

Only for disturbance data datapoints

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LINIE"


IDS_ROKT1

Interne ID: IDS_ROKT1

Red. O1/Region

Redundante Peripherieadresse

Regionsnummer bzw. Octet 1 (CASDU1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "R_2"


IDS_ROKT1_ENG

Interne ID: IDS_ROKT1_ENG

Red. O1/Region number

Redundant datapoint address

Region number or Octet 1 (CASDU1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "R_2"


IDS_ROKT2

Interne ID: IDS_ROKT2

Red. O2/Komponente

Redundante Peripherieadresse

Komponentennummer bzw. Octet 2 (CASDU2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "K_2"


IDS_ROKT2_ENG

Interne ID: IDS_ROKT2_ENG

Red. O2/Component

Redundant datapoint address

Region number or Octet 2 (CASDU2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "K_2"


IDS_ROKT3

Interne ID: IDS_ROKT3

Red. O3/Baugruppe

Redundante Peripherieadresse

Baugruppennummer bzw. Octet 3 (IOA1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "B_2"


IDS_ROKT3_ENG

Interne ID: IDS_ROKT3_ENG

Red. O3/Board

Redundant datapoint address

Region number or Octet 3 (IOA1)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "B_2"


IDS_ROKT4

Interne ID: IDS_ROKT4

Red. O4/Wertnummer

Redundante Peripherieadresse

Wertnummer bzw. Octet 4 (IOA2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "W_2"


IDS_ROKT4_ENG

Interne ID: IDS_ROKT4_ENG

Red. O4/Value number

Redundant datapoint address

Region number or Octet 4 (IOA2)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "W_2"


IDS_ROKT5

Interne ID: IDS_ROKT5

Red. O5/Datenart

Redundante Peripherieadresse

Datenart bzw. Octet 5 (IOA3)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "D_2"


IDS_ROKT5_ENG

Interne ID: IDS_ROKT5_ENG

Red. O5/Subaddress

Redundant datapoint address

Region number or Octet 5 (IOA3)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "D_2"


IDS_SE_ADRESSE

Interne ID: IDS_SE_ADRESSE

Address

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SeAddress"


IDS_SE_STANDARD

Interne ID: IDS_SE_STANDARD

Standard

aktiv: Alle C-Geräte an einem B-Gerät werden als sogenannte "C-Schiene" angesehen. Die C-Geräte werden damit nicht mehr direkt ausgewählt, sondern die Datenpunkte auf den C-Geräten werden so behandelt, als würden
sie auf dem B-Gerät liegen.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Standard"


IDS_SICHTBARKEIT

Interne ID: IDS_SICHTBARKEIT

Sichtbarkeit/Blinken

Eigenschaften für die Sichtbarkeit und das Blinken des Elements.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Visibility"


IDS_SICHTBARKEIT_AUSGRENZWERT

Interne ID: IDS_SICHTBARKEIT_AUSGRENZWERT

von Grenzwert übernehmen

Nur verfügbar, nachdem eine Variable ausgewählt wurde:
Aktiv: Die Sichtbarkeit des Elements wird von den Grenzwerteigenschaften der Variable beeinflusst.
ACHTUNG: Zumindest bei einem Grenzwert der Variable muss die Eigenschaft "Unsichtbar" aktiviert sein.
Inaktiv: Die Sichtbarkeit wird von den Eigenschaften des Elements beeinflusst.
Default: aktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibilityFromLimit"


IDS_SICHTBARKEIT_BIS

Interne ID: IDS_SICHTBARKEIT_BIS

bis

Nur verfügbar, nachdem eine Variable ausgewählt wurde und wenn die Sichtbarkeit nicht vom Grenzwert übernommen wird:
Größter Wert der Variable, bei dem das Element sichtbar ist.
Minimum: niedrigstmöglicher Wert der verknüpften Variable.
Maximum: höchstmöglicher Wert der verknüpften Variable.
Default: höchstmöglicher Wert der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibilityTo"


IDS_SICHTBARKEIT_VARIABLE

Interne ID: IDS_SICHTBARKEIT_VARIABLE

Variable

Name der Variablen, deren Wert die Sichtbarkeit des Elements beeinflusst. Die Sichtbarkeit wird entweder aus den Grenzwerteigenschaften dieser Variablen übernommen oder durch den Wertbereich bestimmt, der bei den Eigenschaften von und bis definiert ist.
Ein Klick auf die Schaltfläche öffnet den Dialog zur Variablenauswahl. Der Name kann auch manuell in das Textfeld eingegeben werden.
Wenn keine Variable verknüpft ist, ist das Element immer sichtbar.

Interne ID: IDS_SICHTBARKEIT_VARIABLE

bis

Nur verfügbar, nachdem eine Variable ausgewählt wurde und wenn die Sichtbarkeit nicht vom Grenzwert übernommen wird:
Größter Wert der Variable, bei dem das Element sichtbar ist.
Minimum: niedrigstmöglicher Wert der verknüpften Variable.
Maximum: höchstmöglicher Wert der verknüpften Variable.
Default: höchstmöglicher Wert der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibilityVariable"

Interne ID: IDS_SICHTBARKEIT_VARIABLE

von

Nur verfügbar, nachdem eine Variable ausgewählt wurde und wenn die Sichtbarkeit nicht vom Grenzwert übernommen wird:
Kleinster Wert der Variable, bei dem das Element sichtbar ist.
Minimum: niedrigstmöglicher Wert der verknüpften Variable.
Maximum: höchstmöglicher Wert der verknüpften Variable.
Default: niedrigstmöglicher Wert der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibilityVariable"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibilityVariable"


IDS_SICHTBARKEIT_VON

Interne ID: IDS_SICHTBARKEIT_VON

von

Nur verfügbar, nachdem eine Variable ausgewählt wurde und wenn die Sichtbarkeit nicht vom Grenzwert übernommen wird:
Kleinster Wert der Variable, bei dem das Element sichtbar ist.
Minimum: niedrigstmöglicher Wert der verknüpften Variable.
Maximum: höchstmöglicher Wert der verknüpften Variable.
Default: niedrigstmöglicher Wert der verknüpften Variable.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VisibilityFrom"


IDS_ST_SAVE

Interne ID: IDS_ST_SAVE

Status speichern

Aktiv: Status der Variablen wird auf Festplatte gespeichert.

Wird bei Neustart der Runtime rückgelesen.

Inaktiv: Status wird nicht gespeichert.

Default: Inaktiv

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ST_SAVE"


IDS_ST_SAVE_ENG

Interne ID: IDS_ST_SAVE_ENG

Save state

Save status

Active: The status bits (e.g. Revision) of the datapoint will be saved (STATUS.BIN) and will be reread at start of runtime.

Inactive: The status bits of the datapoint will not be saved.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ST_SAVE"


IDS_STRING78

Interne ID: IDS_STRING78

Anzeigebereich dynamisch

Eigenschaften für den dynamischen Anzeigebereich.
Dies erlaubt den Anzeigebereich in der Runtime dynamisch über Variablenwerte zu ändern.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Displayrange_Dynamic"


IDS_STRING79

Interne ID: IDS_STRING79

Minimum

Variable, die das Minimum des Anzeigebereichs in der Runtime definiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynMinVar"


IDS_STRING80

Interne ID: IDS_STRING80

Maximum

Variable, die das Maximum des Anzeigebereichs in der Runtime definiert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "DynMaxVar"


IDS_STRING81

Interne ID: IDS_STRING81

SW Grenzen dynamisch

Eigenschaften zu den dynamischen Sollwertgrenzen.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueLimits_Dynamic"


IDS_STRING82

Interne ID: IDS_STRING82

Minimum

Nur verfügbar, wenn "Sollwertgrenzen von Variable übernehmen" nicht aktiv ist:
Variable, deren aktueller Wert als untere Sollwertgrenze für das Element gilt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueDynMin"


IDS_STRING83

Interne ID: IDS_STRING83

Maximum

Nur verfügbar, wenn "Sollwertgrenzen von Variable übernehmen" nicht aktiv ist:
Variable, deren aktueller Wert als obere Sollwertgrenze für das Element gilt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValueDynMax"


IDS_SYMADRESSE

Interne ID: IDS_SYMADRESSE

3S Arti specific

Die folgenden Properties dienen Ihnen zur Adressierung des 3S_Arti_NG-Treibers.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NGAddress"


IDS_SYMNAME

Interne ID: IDS_SYMNAME

Symbol name

Symbolname der Variablen in der Steuerung.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "NGSymName"


IDS_TRANS

Interne ID: IDS_TRANS

Transparente Daten

Transparente Daten

Nur bei Störschrieb-Datenpunkt.

DISTO: Störschriebauswertung mit DISTO

REYDISP: Störschriebauswertung für REYROLL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TRANS"


IDS_TRANS_ENG

Interne ID: IDS_TRANS_ENG

Transparent Data

Transparent Data

Only for disturbance data datapoints.

DISTO: Storing of disturbance records by DISTO

REYDISP: Storing of disturbance records by REYROLL

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TRANS"


IDS_UNTERGRUPPE

Interne ID: IDS_UNTERGRUPPE

Sub group

Geben Sie die Nummer der gewünschten Untergruppe ein.

Minimum: 0

Maximum: 255

Default: 0

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SubGroup"


IDS_VAL_SAVE

Interne ID: IDS_VAL_SAVE

Wert speichern

Aktiv: Wert der Variablen wird auf Festplatte gespeichert.

Wird bei Neustart der Runtime rückgelesen.

Inaktiv: Wert wird nicht gespeichert.

Default: Inaktiv.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VAL_SAVE"


IDS_VAL_SAVE_ENG

Interne ID: IDS_VAL_SAVE_ENG

Save value

Save value

Active: The value of the datapoint will be saved (STATUS.BIN) and will be reread at start of runtime.

Inactive: The value will not be saved and is 0 at restart.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VAL_SAVE"


IDS_VAR_ERSATZWERT_STRING

Interne ID: IDS_VAR_ERSATZWERT_STRING

String Archivfüllwert

Dieser Wert wird für Stringvariablen verwendet um zyklische Archive aufzufüllen. Wenn es dort Zeitbereiche gibt, zu denen es keine Verbindung zur Hardware gab, wird dieser Wert verwendet, solange noch kein Wert von der Hardware übertragen wurde. Sonst wird der der zuletzt gültige Wert zum auffüllen verwendet.
ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "AlternateValueString"


IDS_VTA

Interne ID: IDS_VTA

Adressierungsart

Adresstyp

Muss mit Parametrierung in GW1703.ini und der Gegenstelle übereinstimmen.

STA: Systemtechnisch

VTA: Verfahrenstechnisch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VTA"


IDS_VTA_ENG

Interne ID: IDS_VTA_ENG

Typ of addressing

Address type

In accordance to parameterization of GW1703.ini and remote station.

STA: System technical

VTA: Process technical (PTA in GW1703.ini)

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VTA"


IDS_WDH

Interne ID: IDS_WDH

WDH (Anz. Wdh.)

Max. Anzahl an Wiederholungen

Regulierbefehle, Retriggerbefehle

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WDH"


IDS_WDH_ENG

Interne ID: IDS_WDH_ENG

Repeats

Max. count of repeats

Regulating-, triggered commands

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "WDH"


IDS_Z_NR

Interne ID: IDS_Z_NR

Zielnummer

LAN-Stations- oder LAN-Gruppennummer

Bei serieller Ankopplung Linkadresse

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Z_NR"


IDS_Z_NR_ENG

Interne ID: IDS_Z_NR_ENG

Destination number

LAN station or LAN group number

Link address if serial connection

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Z_NR"


IDS_Z_TYP

Interne ID: IDS_Z_TYP

Zieltyp

Auswahl LAN-Station oder LAN-Gruppe

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Z_TYP"


IDS_Z_TYP_ENG

Interne ID: IDS_Z_TYP_ENG

Destination typ

Selection of LAN station or LAN group

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Z_TYP"


IDS_ZEIT

Interne ID: IDS_ZEIT

Zeitbeigabe durch AKS

Zeitbeigabe

Aktiv: Rechnerzeit wird beim Empfang beigegeben.

Inaktiv: Zeit aus Telegramm wird verwendet.

Invalide oder unplausible Zeit wird automatisch durch die Rechnerzeit ersetzt.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZEIT"


IDS_ZEIT_ENG

Interne ID: IDS_ZEIT_ENG

Time stamp by AKS

Time setting

Active: Computer time will be used when received

Inactive: Telegram time will be used

Invalid or implausible time stamp will be replaced automatically by computer time.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ZEIT"


IDS_ZENMENU_PROP01

Interne ID: IDS_ZENMENU_PROP01

Menü ID

Name des Menüeintrags.

Bei Aktionstyp Befehlsgabe sind die in der Befehlsgabe bereits definierte Aktionen aus einer Dropdownliste auswählbar.

Interne ID: IDS_ZENMENU_PROP01

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


IDS_ZENMENU_PROP02

Interne ID: IDS_ZENMENU_PROP02

Text

Beschriftung des Menüeintrags im Menü. Der Eintrag muss eindeutig sein. Sind mehrere Einträge mit gleichem Text vorhanden, wird zur Runtime nur der erste dieser Menüeinträge angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Caption"


IDS_ZENMENU_PROP04

Interne ID: IDS_ZENMENU_PROP04

Datei

Nur verfügbar für Aktionstyp "Hilfe":
Hilfedatei, aus der ein Kapitel angezeigt werden soll.
Normalerweise werden die Hilfeseiten der verknüpften Elemente angezeigt. Hat ein verknüpftes Element keine Hilfeseite, so wird die hier definierte angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HelpFile"


IDS_ZENMENU_PROP05

Interne ID: IDS_ZENMENU_PROP05

Kapitel

Nur verfügbar für Aktionstyp "Hilfe":
Hilfekapitel, das angezeigt werden soll.

ACHTUNG: Dieser Eintrag berücksichtigt Groß-/Kleinschreibung.
Normalerweise werden die Hilfeseiten der verknüpften Elemente angezeigt. Hat ein verknüpftes Element keine Hilfeseite, so wird die hier definierte angezeigt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "HelpCapture"


IDS_ZENMENU_PROP06

Interne ID: IDS_ZENMENU_PROP06

Grafikdatei

Grafikdatei, die im ganz linken Bereich angezeigt wird.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Picture"


IDS_ZENMENU_PROP07

Interne ID: IDS_ZENMENU_PROP07

Häkchen

Vor dem Menüeintrag wird ein Häkchen angezeigt. Dies dient nur zur grafischen Darstellung.

Default: inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Checked"


IDS_ZENMENU_PROP08

Interne ID: IDS_ZENMENU_PROP08

Aktiv

Aktiv: Der Menüeintrag wird normal dargestellt und die damit verknüpfte Aktion wird bei Betätigung ausgeführt.
Inaktiv: Der Eintrag wird gegreyed dargestellt und die damit verknüpfte Aktion wird nicht ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Enabled"


IDS_ZENMENU_PROP09

Interne ID: IDS_ZENMENU_PROP09

Sichtbar

Steuert, ob der Menüeintrag zur Runtime angezeigt wird.

Default: aktiv

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Visible"


IDS_ZENMENU_PROP10

Interne ID: IDS_ZENMENU_PROP10

Trennlinie aktiv

Aktiv: Statt eines Menüeintrags wird eine horizontale Trennlinie eingefügt. Breite und Farbe der Linie können definiert werden.

Default: inaktiv

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Seperator"


IDS_ZENMENU_PROP11

Interne ID: IDS_ZENMENU_PROP11

Untermenü

Der Menüeintrag führt keine Aktion aus, sondern öffnet ein Untermenü.

Default: Inaktiv.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Popup-Menu"


IDS_ZENMENU_PROP12

Interne ID: IDS_ZENMENU_PROP12

Aktionstyp

Folgenden Aktionstypen stehen in Haupt- und Kontextmenü zur Verfügung:

Funktion: Eine Funktion wird ausgeführt.
Hilfe: Ein Hilfe-Eintrag wird angezeigt.
Keine Aktion: Keine Aktion wird ausgeführt.
Sollwert setzen: Ein Sollwert wird auf eine Variableabgesetzt.

Folgenden Aktionstypen können nur im Kontextmenü ausgeführt werden:

Alarme quittieren: Quittiert alle Alarme für Variablen, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind.
Blinken quittieren: Schaltet den Blinkzustand aller Alarme für Variablen ab, die mit dem dynamischen Element, auf das sich das Kontextmenü bezieht, verknüpften sind. Der Alarm wird dabei nicht quittiert.
Befehlsgabe: Führt eine Befehlsgabe aus.
VBA Makro: Ein VBA Makro wird ausgeführt.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Type"


IDS_ZENMENU_PROP13

Interne ID: IDS_ZENMENU_PROP13

Berechtigungsebene

Passwortlevel für das Ausführen dieses Menüeintrags.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Password"


IDS_ZENMENU_PROP14

Interne ID: IDS_ZENMENU_PROP14

Textfarbe

Textfarbe für das ausgewählte Menü.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "TextColor"


IDS_ZENMENU_PROP15

Interne ID: IDS_ZENMENU_PROP15

Hintergrundfarbe

Hintergrundfarbe für das ausgewählte Menü.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackColor"


IDS_ZENMENU_PROP16

Interne ID: IDS_ZENMENU_PROP16

Schrift

Schriftart der Menüs. Gilt für alle Menüeinträge.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Font"


IDS_ZENMENU_PROP17

Interne ID: IDS_ZENMENU_PROP17

Funktion

Nur verfügbar für Aktionstyp "Funktion":
Funktion, die über den ausgewählten Menüeintrag ausgeführt werden soll.
Wenn hier mehr als eine Funktion ausgeführt werden soll, so muss ein Skript mit den gewünschten Funktionen erstellt und die Funktion zum Ausführen des Skripts hier verknüpft werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


IDS_ZENMENU_PROP18

Interne ID: IDS_ZENMENU_PROP18

VBA-Makro

Nur verfügbar für Aktionstyp "VBA Makro":
VBA Makro, das über den ausgewählten Menüeintrag ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "VBA-Macro"


IDS_ZENMENU_PROP19

Interne ID: IDS_ZENMENU_PROP19

Variable

Nur verfügbar für Aktionstyp "Sollwert setzen":
Variable, auf die über den ausgewählten Menü-Eintrag ein Sollwert abgesetzt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Variable"


IDS_ZENMENU_PROP20

Interne ID: IDS_ZENMENU_PROP20

Sollwert/Änderung um

Nur verfügbar für Aktionstyp "Sollwert setzen":
Zahlenwert, der als Sollwert auf die ausgewählte Variable abgesetzt werden soll. Es werden nur Zahlenwerte erwartet und akzeptiert. Die Werte werden mit bis zu 6 Nachkommastellen übernommen.
Ist die Eigenschaft Aktuellen Wert vorschlagen aktiviert, so wird der aktuelle Wert der Variable um diesen Wert erhöht (positiver Wert) oder verringert (negativer Wert).

Interne ID: IDS_ZENMENU_PROP20

Aktuellen Wert vorschlagen

Nur verfügbar für Aktionstyp "Sollwert setzen":
Aktiv: Der aktuelle Wert der Variable wird als Sollwert vorgeschlagen.
Inaktiv: Der Sollwert wird direkt in den Eigenschaften des Menüeintrags angegeben.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Sollwert"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Sollwert"


IDS_ZENMENU_PROP21

Interne ID: IDS_ZENMENU_PROP21

Variable aus Element

Nur verfügbar für Aktionstyp "Sollwert setzen" und Kontextmenüs:
Aktiv: Variable für Sollwert setzen wird aus dem dynamischen Element übernommen.
Inaktiv: Variable für Sollwert setzen wird in den Eigenschaften des Menüeintrags angegeben.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "FromElem"


IDS_ZENMENU_PROP22

Interne ID: IDS_ZENMENU_PROP22

Dialog

Nur verfügbar für Aktionstyp "Sollwert setzen":
Aktiv: Beim Ausführen der Aktion wird vor dem Absetzen des Sollwerts eine Dialogbox geöffnet, die es dem Anwender erlaubt den Sollwert vor dem absetzen zu ändern.
Sind Keyboardbilder (z.B. SETVALUEKBD, SETSTRINGKBD oder SETBOOLKBD) vorhanden, werden diese anstelle der Dialogbox automatisch aufgeschaltet.
Inaktiv: Der in den Eigenschaften des Menüeintrags definierte Wert wird direkt an die Hardware gesendet.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SWDialog"


IDS_ZENMENU_PROP23

Interne ID: IDS_ZENMENU_PROP23

Aktuellen Wert vorschlagen

Nur verfügbar für Aktionstyp "Sollwert setzen":
Aktiv: Der aktuelle Wert der Variable wird als Sollwert vorgeschlagen.
Inaktiv: Der Sollwert wird direkt in den Eigenschaften des Menüeintrags angegeben.
Default: inaktiv.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "ActValue"


IDS_ZENMENU_PROP24

Interne ID: IDS_ZENMENU_PROP24

Name

Eindeutiger Name des Menüs.
Default: Neues Hauptmenü x oder Neues Kontextmenü x (wobei x eine fortlaufende Zahl ist).

ACHTUNG: Diese Eigenschaft steht für die Sprachumschaltung nicht zur Verfügung.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Name"


IDS_ZENMENU_PROP34

Interne ID: IDS_ZENMENU_PROP34

Verriegelung

Auswahl einer Verriegelung für den Menüeintrag.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Locking"


IDS_ZENMENU_PROP36

Interne ID: IDS_ZENMENU_PROP36

Grafikdatei

Hintergrundgrafik für den Menüeintrag.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPicture"


IDS_ZENMENU_PROP37

Interne ID: IDS_ZENMENU_PROP37

Ausrichtung

Größe der Hintergrundgrafik für den Menüeintrag.
Originalgröße: Das Bild wird in seiner Originalgröße dargestellt. Der Menüeintrag wird an die Größe des Bildes angepasst.
Gestreckt: Das Bild wird auf die Größe des Menüeintrags gestreckt.
Default: Originalgröße.

Beispiel: Menüs sollten in einem Touchscreen-Projekt verwendet werden. Als Standard werden für die Größe der einzelnen Menüeinträge die Einstellungen des Betriebssystems verwendet. Mit einer Hintergrundgrafik in Originalgröße lässt sich die Größe der Menüeinträge aber individuell gestalten.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "BackgroundPicRepres"


IDS_ZENMENU_PROP_GRP2

Interne ID: IDS_ZENMENU_PROP_GRP2

Berechtigung

Eigenschaften der Bedienberechtigung des Menüeintrags.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Rights"


IDS_ZENMENU_PROP_GRP3

Interne ID: IDS_ZENMENU_PROP_GRP3

Darstellung / Typ

Eigenschaften der Darstellung des Menüeintrags.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Represantation"


IDS_ZENMENU_PROP_GRP4

Interne ID: IDS_ZENMENU_PROP_GRP4

Funktion/Makro

Funktion oder VBA Makro, die über diesen Menüeintrag ausgefürt werden sollten.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Function"


IDS_ZENMENU_PROP_GRP5

Interne ID: IDS_ZENMENU_PROP_GRP5

Sollwert absetzen

Eigenschaften für den abzusetzenden Wert.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "SetValue"


IDS_ZENMENU_PROP_GRP6

Interne ID: IDS_ZENMENU_PROP_GRP6

Hilfe

Eigenschaften für die Hilfeseite für den Menüeintrag.
Diese Funktionalität erlaubt die Anzeige HTML-basierender Hilfeseiten aus einer CHM Datei in der Runtime. In Kontextmenüs kann die Hilfe auch kontextsensitiv sein.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Help"


IDS_ZENMENU_PROP_GRP7

Interne ID: IDS_ZENMENU_PROP_GRP7

Hintergrundgrafik

Eigenschaften für die Hintergrundgrafik des Menüeintrags.

Mehr im Online Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Backgroundpicture"


IDS_ZENMENU_PROP_GRP8

Interne ID: IDS_ZENMENU_PROP_GRP8

Aktion

Eigenschaften der Aktion, die mit dem Menüeintrag ausgeführt werden soll.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "Action"


IDS_ZENMENU_PROP_GRP9

Interne ID: IDS_ZENMENU_PROP_GRP9

Allgemein

Allgemeine Einstellungen des ausgewählten Menüs.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "General"


IDS_ZYKLISCH_LESEN

Interne ID: IDS_ZYKLISCH_LESEN

Read cyclical

Legt fest, auf welche Art der Wert von der Steuerung übertragen wird.

aktiv: Der Wert wird zyklisch von der Steuerung angefordert.

Default: inaktiv

Hinweis: Diese Option sollte sehr vorsichtig gewählt werden, die Busbelastung steigt dadurch enorm an.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "CyclicReading"


LOCK_BITMAP_LOCKING

Interne ID: LOCK_BITMAP_LOCKING

Verriegelung-Grafikdatei

Nur verfügbar, wenn Grafische Kennzeichnung aktiv aktiv ist.

Interne ID: LOCK_BITMAP_LOCKING

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockLockBitmap"

Auswahl der Grafikdatei, die ein verriegeltes Element anzeigt. Die Datei muss im Projektmanager im Knoten Dateien/Grafiken als Bitmap-Datei angelegt sein.

Erlaubtes Format: 16 x 16 Pixel, größere Bitmaps werden gestaucht dargestellt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockLockBitmap"


LOCK_BITMAP_USER

Interne ID: LOCK_BITMAP_USER

Gesperrt-Grafikdatei

Nur verfügbar, wenn Grafische Kennzeichnung aktiv aktiv ist.

Interne ID: LOCK_BITMAP_USER

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockUserBitmap"

Auswahl der Grafikdatei, die ein für die Bedienung gesperrtes Element anzeigt. Die Datei muss im Projektmanager im Knoten Dateien/Grafiken als Bitmap-Datei angelegt sein.

Erlaubtes Format: 16 x 16 Pixel, größere Bitmaps werden gestaucht dargestellt.

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockUserBitmap"


LOCK_FILL_COLOR

Interne ID: LOCK_FILL_COLOR

Füllfarbe Schlosssymbol

Nur verfügbar, wenn Grafische Kennzeichnung aktiv aktiv ist.
Definiert die Füllfarbe des Schlosssymbols. Definiert die Linienfarbe des Schlosssymbols. Farbe kann direkt als Hexadezimalwert in das Feld eingetragen oder nach Klick auf ... ausgewählt werden.

Interne ID: LOCK_FILL_COLOR

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockFillColor"

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockFillColor"


LOCK_LINE_COLOR

Interne ID: LOCK_LINE_COLOR

Linienfarbe Schlosssymbol

Nur verfügbar, wenn Grafische Kennzeichnung aktiv aktiv ist.

Interne ID: LOCK_LINE_COLOR

Grafische Kennzeichnung aktiv

Aktiv: Gesperrte Elemente können mit einem Schlosssymbol oder eine frei wählbare Grafik gekennzeichnet werden.
Default: Inaktiv

Mehr im Online-Handbuch.

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockLineColor"

Definiert die Linienfarbe des Schlosssymbols. Die Farbe kann direkt als Hexadezimalwert in das Feld eingetragen oder nach Klick auf ... ausgewählt werden.

Mehr im Online-Handbuch

Diese Funktion ist in VBA (mit Klassenname) und im XML-Export (ohne Klassenname) wie folgt anzusprechen: "LockLineColor"


Startkapitel Embedded Help

Willkommen bei der zenon Eigenschaftenhilfe

Die Eigenschaftenhilfe zeigt Ihnen zu jeder Eigenschaft eine kurze Information an: Wofür wird die Eigenschaft verwendet, was ist ihr Standardwert, von welchen anderen Eigenschaften ist die Eigenschaft abhängig usw. Es wird auch ein Link in die Online-Hilfe angeboten, sowie der Eigenschaftenname für VBA/VSTA angezeigt.