Befehlsgabe

Befehlsgabe

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Befehlsgabe dient primär zum gesicherten Schalten von Datenpunkten in der Energietechnik. Gesichert heißt, dass überprüft wird, ob die Schalthandlung aufgrund der projektierten Verriegelungsbedingung und der dynamisch aktualisierten Topologie (kein Zusammenhang mit der zenon Netzwerktopologie) erlaubt ist. Die Projektierung der Topologie erfolgt über die ALC.

Aus diesen Bedingungen ergibt sich ob die Schalthandlung zu diesem Zeitpunkt erlaubt ist (Keine Verriegelungsbedingung anstehend), verboten ist (eine nicht entriegelbare Bedingung ansteht) oder nach Entriegelung (entriegelbare Verriegelung(en) ansteht) ausgeführt werden darf.

Ein Datenpunkt der Befehlsgabe besteht immer aus 2 Datenpunkten. Der Rückmeldevariable, sowie der Befehlsvariable. Auf einen dieser Datenpunkte wird die Aktion ausgeführt.

Bedienhandlungen werden über ein Kontextmenü oder das Bild vom Typ Befehlsgabe ausgeführt. Für dieses stehen spezifische Kontrollelemente zur Verfügung. In diesem Bild ist auch ein Ablauf programmiert wodurch die Entriegelung, zweistufige Ausführung und Sperre ermöglicht wird. Aktiviert wird das Bild über ein Bildelement, Funktion oder Kontextmenü.

Die Synchronisierung der Ausführung der Befehlsgabe erfolgt durch ein im Treiber laufzeitüberwachtes, zyklisch zu aktualisierendes Zugriffsobjekt, welches der Rückmeldevariable zugeordnet und dessen Aktivierung durch den Status „Select“ bei dieser angezeigt wird.

Die Zugriffsobjekte werden bei Bedarf erzeugt und sind auf der RT Seite dem Ersteller zugeordnet. Durch die Verwaltung dieser Objekte im Treiber ist sichergestellt das zu einer Rückmeldevariable nur ein Zugriffsobjekt aktiv ist.

Die Befehlsgruppen können auf Verriegelungsebene exportiert, importiert und über die Zwischenablage ausgetauscht und dupliziert werden. Befehlsverrriegelungen und allgemeine Verriegelungen werden in einer gemeinsamen Datendatei (verriegel.bin/verrieg.cmp) abgelegt und auch gemeinsam verwaltet. Darum ist es auch nicht möglich eine allgemeine Verriegelung und eine Befehlsgruppe mit gleichem Namen zu haben.

Noch in diesem Kapitel

Begriffsdefinition

Power On


Begriffsdefinition

Befehlsgabe -> Begriffsdefinition

Noch in diesem Kapitel

Befehlsbild

Befehlsgruppe

Rückmeldevariable

Befehlsvariable

Befehlsgabe Aktion

Aktionsvariable

Aufschaltvariable

Bedingungsvariablen

Verriegelungsbedingung

Interne Verriegelungsbedingungen

Topologische Verriegelungsbedingungen


Befehlsbild

Befehlsgabe -> Begriffsdefinition -> Befehlsbild

Bild vom Typ „Befehlsgabe“ welches für die Interaktion mit dem Anwender für die Befehlsausführung dient. Enthält maßgeschneiderte Funktionalität und Bildelemente für die Befehlsgabe.


Befehlsgruppe

Befehlsgabe -> Begriffsdefinition -> Befehlsgruppe

Diese Art der Verriegelung beinhaltet eine projektierbare Anzahl von Aktionen mit ihren statischen Verriegelungen, sowie die bei den statische Verriegelungen zur Verfügung stehenden Formelvariablen.


Rückmeldevariable

Befehlsgabe -> Begriffsdefinition -> Rückmeldevariable

Wie der Name bereits beschreibt, wird über diesen Datenpunkt der aktuelle bzw. resultierende Wert einer Schalthandlung (Befehlsgabeaktion im weiterem nur Aktion) zurückgemeldet. Sie kann aber auch direkt der Datenpunkt auf welchem eine Aktion ausgeführt wird, sein.

Wird ersetzt.


Befehlsvariable

Befehlsgabe -> Begriffsdefinition -> Befehlsvariable

Auf diesen Datenpunkt werden die Aktionen „Einzelbefehl“, „Doppelbefehl“ und „Sollwertvorgabe“ ausgeführt. Für diese kann SBO (select before operate) aktiviert werden.

Wird ersetzt.


Befehlsgabe Aktion

Befehlsgabe -> Begriffsdefinition -> Befehlsgabe Aktion

Die Aktion definiert die Art des auszuführenden Befehls mit seinen Parametern sowie den statischen Befehlsgabeverriegelungen. Dies kann das Schreiben eines Wertes oder eines Status sein.


Aktionsvariable

Befehlsgabe -> Begriffsdefinition -> Aktionsvariable

Um einen einheitlichen Begriff für den Datenpunkt auf welchen eine Aktion Einfluss nimmt zu haben, wird dieser Aktionsvariable genannt. Letztendlich kann dies die Rückmeldevariable oder Befehlsvariabel sein.


Aufschaltvariable

Befehlsgabe -> Begriffsdefinition -> Aufschaltvariable

Die Aufschaltvariable ist jener Datenpunkt, der mit der Befehlsgruppe verknüpft ist und zum Aufschalten des Bild vom Typ Befehlsgaber“ verwendet wird.

Die Aufschaltvariable muss immer eine Befehlsgruppe projektiert haben. Aus der Befehlsgruppe wird dann die Rückmeldevariable und Aktionsvariable ermittelt.

Das heißt aber nicht das die Variable bei der Befehlsgruppe verwendet werden muss. Wenn die verwendete Befehlsgruppe die Rückmeldevariable absolut definiert und die Aktionsvariablen absolut definiert sind, ist es auch möglich das die Aufschaltvariable in der Befehlsgruppe nicht verwendet wird. Mit Ersetzung funktioniert es nicht, da der Datenpunkt nicht aufgelöst werden kann.


Bedingungsvariablen

Befehlsgabe -> Begriffsdefinition -> Bedingungsvariablen

Datenpunkte welche bei den Bedingungen der Verriegelungsbedingungen in den Formeln verwendet werden können.

Wenn eine Bedingungsvariable verwendet wird, kann diese nicht gelöscht werden.

Wenn eine Bedingungsvariable gelöscht wird welche nicht die letzte definierte ist, werden die Nachfolgenden nach vor geschoben und die Formeln angepasst.

Wird ersetzt.


Verriegelungsbedingung

Befehlsgabe -> Begriffsdefinition -> Verriegelungsbedingung

Bei jeder Aktion kann eine beliebige Anzahl von Verriegelungsbedingungen definiert werden. Diese werden vor Ausführung der Aktion geprüft.


Interne Verriegelungsbedingungen

Befehlsgabe -> Begriffsdefinition -> Interne Verriegelungsbedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Bedingungen werden ohne dass der Projektant Einfluss darauf nehmen kann vor Aktionsausführung geprüft.

z. B.: Select konnte nicht aktiviert werden oder SBO wurde abgelehnt.


Topologische Verriegelungsbedingungen

Befehlsgabe -> Begriffsdefinition -> Topologische Verriegelungsbedingungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Bedingungen ergeben sich aus dem aktuellen topologischen Zustand. Projektiert wird die Topologie mittels ALC.


Power On

Befehlsgabe -> Power On

Wir werden mit einem Schritt für Schritt Beispiel unsere erste Befehlsgabe projektieren und ausführen. Am Weg dorthin werden wir einen Teil der Funktionalität der Befehlsgabe kennen lernen. Eine nähere Betrachtung spezieller Funktionalität erfolgt im Anschluss.

Im Editor erzeugen wir ein neues Projekt und legen den Simulatortreiber an (falls dieser nicht schon existiert). Wir verwenden diesen Treiber der Einfachheit halber, obwohl damit in Bezug auf die Befehsgabe gewisse Einschränkungen bestehen.

Bitte beachten Sie, dass zur vollen Unterstützung aller Möglichkeiten der Befehsgabe z.B. der IEC870-Treiber mit entsprechendem 60870-Gerät erforderlich ist. Dieser Treiber unterstützt COT (cause of transmission) und SBO. Diese Funktionalität ist wiederum für die Laufzeitüberwachung und den SBO Ablauf notwendig.

info Info

Es empfiehlt sich den mitgelieferten 'Projekt Wizard' auszuführen. Dieser legt Ihnen eine grundlegende Projektstruktur an und erspart Ihnen das manuelle definieren der Prozessbilder.

Noch in diesem Kapitel

Bild für Befehlsgabe

Erzeugen der Befehlsgabe

Menü erzeugen

Start der RT


Bild für Befehlsgabe

Befehlsgabe -> Power On -> Bild für Befehlsgabe

Für die Benutzerinteraktion der Befehlsgabe zur Laufzeit wurde ein eigener Bildtyp „Befehlsgabe“ geschaffen. In diesem werden vom Bediner die zur Befehlsausführung notwendigen Aktivitäten ausgeführt. Dies kann z. B. das entriegeln einer anstehenden Verriegelung oder die Bestätigung der Ausführung bei zweistufiger Ausführung sein.

Bei diesem Bildtyp stehen spezifische Kontrollelemente zur Verfügung, welche die für die Befehlsgabe notwendige Bedienerhandlungen ermöglichen und Informationen über den Zustand der Befehlsgabe visualisieren.

Noch in diesem Kapitel

Bild erzeugen

REMA für die Schaltrichtungstexte

Datenpunkte anlegen


Bild erzeugen

Befehlsgabe -> Power On -> Bild für Befehlsgabe -> Bild erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Erzeugen Sie ein Bild über das entsprechende Kontextmenü.

Bei der Einstellung „Bildtyp“ wählen wir den Typ „Befehlsgabe“ aus. Hierdurch haben wir das Bild zu einem Bild für die Befehlsgabe gemacht. Als nächstes werden wir die Standardkontrollelemente zum Bild hinzufügen. Wir machen dies mittels dem Menüpunkt „Vorlage einfügen“ im Menü „Kontrollelemente“

Es wird Ihnen eine Vielzahl von Kontrollelementen eingefügt. Die detaillierte Funktionalität der Controls werden wir uns später ansehen. Im Moment soll uns das nicht weiter beschäftigen.

Das Bild benennen wir „PowerOn“

info Info

Es empfiehlt sich eine eigene Schablone für dieses Bild zu verwenden. Diese sollte nicht der gesamten Bildschirmauflösung entsprechen, sonder wie ein Pop Up Fenster behandelt werden.

Sollten nicht alle 'Default' Kontrollelemente auf Ihrer gewählten Schablone Platz finden reicht für dieses Beispiel die Verwendung folgender Kontrollelemente:


REMA für die Schaltrichtungstexte

Befehlsgabe -> Power On -> Bild für Befehlsgabe -> REMA für die Schaltrichtungstexte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Texte für die Schaltrichtung in der RT werden über Grenzwerte oder REMA-Zustände ermittelt. Dies eröffnet die Möglichkeit, unterschiedliche Texte für jeden Datenpunkt, welche die gleiche Verriegelung haben, zu verwenden. Sichtbar werden diese Texte im Kontextmenü und im Control Schaltrichtung.

Wir projektieren eine Multibinär Rema mit folgenden Eigenschaften:

Wert | Grenzwerttext
0 | @aus
1 | @ein
2 | @diff
3 | @stör
4 | @keine

Alle weiteren Einstellungen der Zustände sind default. Die REMA benennen wir „Schaltrichtung“.


Datenpunkte anlegen

Befehlsgabe -> Power On -> Bild für Befehlsgabe -> Datenpunkte anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die Befehlsgabe testen zu können benötigen wir natürlich Datenpunkte. Diese werden wir nun erzeugen.

Name | Treiber | Typ | Offset
SW_Schalter1_RM | Simulator | SPS Merker/Int | 110
SW_Schalter1_BE | Simulator | SPS Merker/Int | 110
SW_Schalter1_CO | Simulator | SPS Merker/Int | 114
SW_Schalter2_RM | Simulator | SPS Merker/Int | 112
SW_Schalter2_BE | Simulator | SPS Merker/Int | 112
SW_Schalter2_CO | Simulator | SPS Merker/Int | 116

Da dem Simulator Treiber die Zuordnung der Befehlsvariable zur Rückmeldevariable nicht bekannt ist, werden diese jeweils auf den gleichen Offset projektiert. Hierdurch aktualisieren sich diese gegenseitig, zumindest im Wert.

Die Namensgebung erfolgt so, dass der Text _SchalterX später das Ersetzungszeichen * ersetzen kann.

Bei den *RM und *BE Datenpunkten ordnen wir die REMA „Schaltrichtung“ zu.

attention Achtung

Vergessen Sie nicht für den Simulatortreiber die Steuervariable mit Offset 0 zu projektieren beziehungsweise diese auf den Wert 0 zu setzen. Ansonsten läuft der Treiber im Simulationsmodus.


Erzeugen der Befehlsgabe

Befehlsgabe -> Power On -> Erzeugen der Befehlsgabe

Nun erzeugen wird eine einfache Befehlsgruppe um die Projektierungsmöglichkeiten der Befehlsgabe kennen zu lernen.

Hierzu können wir im Projektbaum am Knoten „Befehlsgabe“ das Kontextmenü

öffnen und mit Befehlsgabe neu eine neue Befehlsgruppe erstellen.

Alternativ kann nach Anwahl des Projektknoten im Fenster der Befehlsgruppen mittels Kontextmenü

und Neu eine Befehlsgruppe erzeugt werden.

Nach Anlegen einer neuen Befehlsgabe wird diese im Baum mit dem Standardnamen „Verriegelung X“ eingefügt. X wird durch eine Nummer ersetzt welche den Namen eindeutig über alle Verriegelungen im Projekt, also auch den allgemeinen Verriegelungen, macht.

Sehen wir uns als nächstes die Eigenschaften bei der Verriegelung an:

Folgende Änderungen der Defaulteinstellungen vornehmen:

  • Name auf den im Bild ändern.
  • Variablenname der Rückmeldung auf den abgebildeten Text ändern.
  • In Bearbeitung setzen aktivieren.
  • Laufzeitüberwachung aktivieren.
  • Als Befehlsbild „PowerOn“ wählen.

Erklärung der Eigenschaften.

Parameter

Beschreibung

Name

Benennung der Befehlsgruppe. Muss eindeutig über alle Verriegelungen im Projekt sein. Dieser Name wird später dann bei der Prozessvariable welche diese Verriegelung verwendet angezeigt. Die eigentliche Zuordnung erfolgt jedoch über eine eindeutige fortlaufend numerische ID. Der Name ist nur für die GUI, Export und Import.

Variablenname der Rückmeldung

Hier ist der Variablenname bzw. die Maske für die Ersetzung der Rückmeldevariable abzulegen.

Ein im Namen vorkommender ‚*’ dient als Platzhalter für den Ersetzungstext. Es kann nur ein Platzhalter im Namen verwendet werden. Bei der Eingabe der Maske ist darauf bedacht zu nehmen, dass dieser Name bei der Ersetzung auch einen vorhandenen Variablennamen ergibt.

Wenn die hier verwendete Variable (ersetzt oder absolut) zum Zeitpunkt der Kompilierung nicht vorhanden ist, steht diese Befehlsgruppe in der RT nicht zur Verfügung. Eine entsprechende Meldung weist beim Kompilieren auf diesen Fehler hin.

In Bearbeitung setzen

Wenn aktiviert, dann wird bei den Aktionen Befehl und Nachführen das Statusbit In Bearbeitung (PROGRESS) beschrieben. Der Wert auf welchem das Statusbit gesetzt wird, hängt von der Schaltrichtung der Aktion ab.

Das Statusbit wird auf 1 gesetzt wenn:

  • Die Rückmeldezustand/Schaltrichtung der Aktion EIN oder AUS ist.
  • Die Rückmeldevariable nicht bereits den Wert der eingestellten Schaltrichtung hat.

Das Statusbit wird bei der Prüfung der Verriegelungen gesetzt und bleibt auf den Wert bis das Bild wieder in Stufe 1 zurückkehrt bzw. geschlossen wird.
Das impliziert auch, dass der Status während die Laufzeitüberwachung und/oder Flankenverzögerung aktiv ist, gesetzt bleibt.

Wir die Ausführung der Aktion durch ein Kontextmenü angestoßen oder ist die Aktion einstufig, wird das Statusbit entsprechend gesetzt.

Laufzeitüberwachung

Bestimmt Ablauf der Laufzeitüberwachung. Wählen Sie aus der Dropdownliste:

  • keine: Keine Laufzeitüberwachung.
  • über Rückmeldevariable: Der Wert der Rückmeldevariable wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.
  • über Übertragungsursache: COT (Cause of Transmission) wird benutzt, um zu überprüfen, ob der Vorgang erfolgreich war.
    Für die Aktion 'Befehl' werden die Status für die Übertragungsursache (Cause of Transmission=COT) ausgewertet.
    Wird innerhalb des bei der Aktion projektierten Timeout der COT-Ablauf nicht erfolgreich beendet, wird das Statusbit TIMEOUT gesetzt. Die Überwachung wird nur aktiviert, wenn der zu schreibende Wert ungleich dem aktuellen Wert der Aktionsvariable ist.

Siehe auch: Cause_of_Transmission_(COT)_Ablauf

Bild modal

Wenn aktiviert dann wird das Bild unabhängig der gewählten Einstellung „Modaler Dialog“ beim Bild, modal angezeigt.

Bildtitel von RM

Die Kennung der Rückmeldevariable wird im Bildtitel angezeigt. Dies erfolgt nur wenn das Bild auch einen Titel bei der Schablone projektiert hat.

Online sprachübersetzbar.

Befehlsbild

Name des aufzuschaltenden Bildes wenn kein aktionspezifisches Bild definiert ist und nicht über die Funktion „Bild direkt“ das Bild geöffnet wird.

Noch in diesem Kapitel

Bedingungsvariablen definieren

Aktion erzeugen

Verriegelungsbedingen projektieren

Verriegelung der Variable zuordnen


Bedingungsvariablen definieren

Befehlsgabe -> Power On -> Erzeugen der Befehlsgabe -> Bedingungsvariablen definieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zu jeder Aktion kann eine beliebige Anzahl von Verriegelungsbedingungen definiert werden. Durch diese Bedingungen kann die Ausführbarkeit der Aktion zusätzlich eingeschränkt werden. Diese Bedingungen werden durch Formeln definiert in denen Variablen aus den aktiven Projekten verwendet werden können. Die bei der Befehlsgruppe verfügbaren Variablen sind zu definieren. Die Formel spricht diese über den Index an. Die Bedingungsvariable wird wenn ein ‚*’ in der Definition enthalten ist ersetzt.

Durch Selektion des Knoten „Variable“ bei der Befehlsgruppe kann über das Kontextmenü

mit Neu eine neue Bedingungsvariable hinzugefügt werden. Den Variablenauswahldialog brechen wir ab, woraufhin uns eine leere Definition erzeugt wird. Diese selektieren und bei der Einstellung Variable den Text SW*_CO eingeben. Die Einstellungen für die Bedingungsvariable sind dann wie folgt:


Aktion erzeugen

Befehlsgabe -> Power On -> Erzeugen der Befehlsgabe -> Aktion erzeugen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Aktionen sind die bei der Befehlsgruppe möglichen Schaltbefehle, mit der aktionsspezifischen Projektierung. Durch Selektion der Befehlsgruppe und Aktivieren des Kontextmenüs können Sie die gewünschte Aktion anlegen.

Mit Befehl neu legen wir eine neue Aktion „Befehl“ an. Nun parametrieren wir die Aktion:

  • Variable auf SW*_BE
  • Soll/Ist-Vergleich aktivieren
  • Befehlsbutton auf Aktion 1 / Text Button_1

So sollten die Einstellungen dann aussehen:

Erklärung der Eigenschaften.

Parameter

Beschreibung

Variable

Variable, auf die geschrieben wird. Bei manchen Aktionen ist dies die Rückmeldevariable. In diesem Falle ist das Feld gesperrt.

Ein im Namen vorkommender ‚*’ dient als Platzhalter für den Ersetzungstext. Es kann nur ein Platzhalter im Namen verwendet werden.

Wenn die hier verwendete Variable (ersetzt oder absolut) zum Zeitpunkt der Kompilierung nicht vorhanden ist, steht diese Aktion in der RT nicht zur Verfügung. Eine entsprechende Meldung weist beim Kompilieren auf diesen Fehler hin.

Default: Keine Zuordnung

Typ

Legt den Typ vom Befehl fest. Mögliche Einstellungen sind Einzel- oder Doppelbefehl.

Doppelbefehl:

Schreibt den Wert der Einstellung „Befehlsgabezustand“.

Einzelbefehl:

Wie Doppelbefehl jedoch wird automatisch nach der Flankenverzögerung ein erneutes Schreiben mit dem Wert 0 ausgeführt. Dieses Schreiben ist nicht mehr laufzeitüberwacht.

Bei allen anderen Aktionen gesperrt.

Initialisierung: Einzelbefehl

Schaltrichtung

Definiert den erwarteten Wert bzw. Status der Rückmeldevariable nach Aktionsausführung.

Bei den Aktionen Blockieren, Sollwert, Sperre und Freigeben gesperrt.

Default: Aus

Befehlsgabezustand

Definiert den Wert, welcher bei der Aktion „Befehl“ als Wert auf die Befehlsvariable geschrieben wird.

Bei allen Aktionen außer „Einzelbefehl“ und „Doppelbefehl“ gesperrt.

Default: 0

CEL-Eintrag unterdrücken

Wenn aktiv, dann wird bei Aktionsausführung kein Eintrag in die CEL erstellt.

Initialisierung: Inaktiv

Timeout

Für die Laufzeitüberwachung verwendetes Timeout. Ist nur bei den Aktionen Befehl und Sollwertvorgabe verfügbar. Maßeinheit sind Sekunden

Default: 30

Flankenverzögerung

Zeit in Millisekunden, welche bei einem Einzelbefehl das Schreiben von 0 verzögert.

Nur bei der Aktion „Einzelbefehl“ freigegeben.

Es wird nicht gewartet bis die Laufzeitüberwachung beendet ist.

Default: 1000 ms

Modifizierbare Stati

Liste der mittels der Aktion „Status setzen“ veränderbaren Stati.

Nur bei der Aktion „Statusvorgabe“ freigegeben.

Default: Keine Modifizierbar

Soll-/Ist-Vergleich

Wenn aktiviert, dann wird geprüft ob der Wert der Rückmeldevariable bereits der Schaltrichtung entspricht. Wenn ja, wird eine entriegelbare Verriegelungsmeldung angezeigt.

Default: Inaktiv

Menü spez. Bild

Bild vom Typ Befehlsgabe, welches bei der Aktivierung der Aktion über das Kontextmenü vom Element aktiviert wird. Wenn kein Bild eingetragen ist, wird das Bild welches bei der Befehlsgruppe eingetragen ist verwendet. Ein projektiertes, jedoch nicht vorhandenes Bild erzeugt eine Fehlermeldung beim Kompilieren und die Aktion wird nicht übernommen.

Default: Keine Zuordnung

Befehlsbutton

Zuordnung der Aktion zu einem Aktionsbutton im Bild definiert bei der Befehlsgruppe. Wenn die Befehlsgruppe mit einem anderen Bild verwendet wird (z. b. über Funktion), bleibt trotzdem die Zuordnung zu dem Aktionsbutton bestehen. Mit anderen Worten die Aktion wird immer auf den Button mit der zugeordneten Aktions-ID gelegt. Fehlt ein solcher, ist diese Aktion im Bild nicht verfügbar. In der Auswahlliste werden nur die noch nicht zugeordneten Aktionsbuttons angeboten.

Diese Einstellung ist gesperrt, wenn bei der Befehlsgruppe kein Bild zugeordnet wurde oder bei dem Aktionstyp „Sperre“.

Default: Keine Zuordnung

Automatisch schließen

Wenn aktiv, dann wird das Bild nach Ausführung der Aktion automatisch geschlossen.

Default: Inaktiv

Zweihandbedienung

Wenn aktiv, dann wird das Control „Ausführen 2“ nur freigegeben wenn die Taste „Strg“ gehalten wird.

Ist gesperrt, wenn keine zweistufige Ausführung.

Default: Inaktiv

Zweistufig

Wenn aktiv, wird erst nach Betätigung des Controls „Ausführen 2“ die Aktion ausgeführt. Wenn nicht aktiv dann wird die Aktion nach entriegeln der letzten Verriegelung bzw. wenn keine Verriegelung ansteht sofort ausgeführt.

Bei Aktion „Sperre“ gesperrt.

Default: Aktiv

Example Beispiel

Diesen Vorgang wiederholen wir und legen noch zusätzliche Aktionen für die Schaltrichtung 'OFF' und für die Aktionen „Revision [Ein]“ und „Revision [Aus]“ an.


Verriegelungsbedingen projektieren

Befehlsgabe -> Power On -> Erzeugen der Befehlsgabe -> Verriegelungsbedingen projektieren

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wofür Verriegelungsbedingungen dienen, wurde ja schon bei der Projektierung der Bedingungsvariable erläutert, hier wollen wird nun eine einfache Bedingung erzeugen.

Hierzu selektieren wir bei unserer Befehlsverrieglung die Aktion „Einzelbefehl: SW*_BE[Ein]“ und dort den Knoten „Bedingung“. Durch Klick auf die Einstellung Bedingung neu erzeugen wir nun eine neue Bedingung.

Erklärung der Eigenschaften.

Parameter | Beschreibung
Bedingung löschen | Die Bedingung wird gelöscht und steht dann nicht mehr zur Vergfügung.
Logische Verknüpfung | Zeigt die Formel an, deren Ergebnis wahr sein muss, um die Verriegelung zu aktivieren. Editiert wird die Formel mittels Formeleditor. Der Formeleditor entspricht jenem vom Combi-Element.
Verriegelungstext | Text welcher als Verriegelungsmeldung angezeigt wird wenn die Verriegelungsbedingung eintritt.
Entriegelbar | Wenn aktiv dann kann die Verriegelung entriegelt werden.

Eigenschaften entsprechend obiger Abbildung setzen.


Verriegelung der Variable zuordnen

Befehlsgabe -> Power On -> Erzeugen der Befehlsgabe -> Verriegelung der Variable zuordnen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit die Befehlsgruppe verwendet wird, muss diese den Variablen zugeordnet werden. Dies geschieht, indem bei der Einstellung „Verriegelung“ die gewünschte Befehlsgruppe zugeordnet wird.

Wir ordnen folgenden Variablen unsere Befehlsgruppe zu:

  • SW_Schalter1_RM
  • SW_Schalter1_BE
  • SW_Schalter2_RM
  • SW_Schalter2_BE


Menü erzeugen

Befehlsgabe -> Power On -> Menü erzeugen

Die Befehlsgabe kann auch über ein bildelementspezifisches Kontextmenü aktiviert werden. Hierfür erzeugen wir ein Kontextmenü mit einem Eintrag welcher folgende Einstellungen hat:

Einstellungen beim Menüeintrag:

Wichtig sind hier zwei Einstellungen:

Parameter | Beschreibung
Aktionstyp | Mit der Energy-Lizenz hat diese Einstellung eine Auswahlmöglichkeit mehr. Es kann der Wert „Befehlsgabe“ selektiert werden. Hierdurch wird dieser Menüeintrag einer, welcher direkt einer Befehlsgabeaktion zugeordnet ist. Welcher, wird bei der Einstellung „Name“ bestimmt.
Name | Diese Einstellung bestimmt die Aktion bzw. Aktionen welche dem Menüpunkt zugeordnet werden, wenn man bei der Einstellung Aktionstyp „Befehlsgabe“ einstellt .

Diese beiden Einstellungen stellen wir auf die abgebildeten Werte, wobei mit dem Aktionstyp zu beginnen ist.

Noch in diesem Kapitel

Menü zuordnen


Menü zuordnen

Befehlsgabe -> Power On -> Menü erzeugen -> Menü zuordnen

Hierzu erzeugen wir im Bild „START“ für alle unsere Variablen SW* ein Zahlenelement. Falls dieses noch nicht durch den Wizard angelegt wurde, definieren Sie dieses bitte an dieser Stelle und stellen Sie sicher, dass dieses Bild als 'Start Bild' für das Projekt eingestellt ist.

info Info

Ein Beispiel Wie ein solches Bild aussehen kann finden Sie im Kapitel 'Start der RT'

Dem Zahlenelement von SW_Schalter1_RM, SW_Schalter1_BE und SW_Schalter2_RM ordnen wir unser Menü zu.


Start der RT

Befehlsgabe -> Power On -> Start der RT

Nun sind wir soweit, das Projekt zu kompilieren und wenn keine Fehlermeldungen im Editor angezeigt werden, auch zu starten.

Unser Startbild könnte dann so aussehen:

Noch in diesem Kapitel

Befehl ausführen

Befehl ausführen die 2.

Verriegelungsbedingung testen


Befehl ausführen

Befehlsgabe -> Power On -> Start der RT -> Befehl ausführen

Um nun einen Befehl auszuführen, aktivieren wir das Kontextmenü für das Element von Variable SW_Schalter1_RM.

Wir sehen, dass der Menüpunkt mit dem Namen ID_CMD_AUTO mit den Aktionen, welche bei der Befehlsgruppe der Variable vom Element (wenn im Weiterem der Begriff „Befehlsgruppe“ verwendet wird, gilt ist diese immer definiert durch diese Abhängigkeit) definiert sind, ersetzt wurde.

Wählen wir nun Befehl: ein aus.

Es wird nun automatisch auf das bei der Befehlsgruppe definierte Bild umgeschaltet.

Wenn wir das Bild kurz betrachten wird uns auffallen, dass einige Controls welche im Editor im Bild vorhanden sind fehlen.

Parameter | Beschreibung
Aktion 2 | Dem Aktionsbutton ist bei der Befehlsgruppe keine Aktion zugeordnet. Aktionsbuttons ohne Aktion werden versteckt.
Beenden | Das Bild ist nicht modal.
Ausführen | Wir sind nicht in Stufe 1.
Entriegeln | Keine Verriegelungsbedingung anstehend.

Wird nun der Button Ausführen 2 angeklickt, erfolgt die Befehlsausführung. Erkennbar ist dies daran, dass die Befehls und Rückmeldevariable kurz auf 1 gehen und dann wieder auf 0.

Da bei der Aktion nicht aktiviert ist, das Bild nach Ausführung zu schließen, wechselt das Bild in die Stufe 1, in welcher erneut Befehle aktiviert werden können.

Mittels dem Aktionsbutton 1 kann die zugeordnete Aktion Befehl: ein erneut ausgeführt werden.


Befehl ausführen die 2.

Befehlsgabe -> Power On -> Start der RT -> Befehl ausführen die 2.

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Aktivieren wir wieder das Startbild und rufen das Kontextmenü vom Bildelement der Variable SW_Schalter1_BE auf.

Hier sehen wir, dass bei gleichem Menü und gleicher Verriegelung nur der Befehl ein bzw. der Befehl aus verfügbar sind. Der Grund hierfür ist, dass die zugeordnete Variable die Befehlsvariable ist, Statusoperationen werden automatisch für eine Befehlsvariable nicht angeboten.


Verriegelungsbedingung testen

Befehlsgabe -> Power On -> Start der RT -> Verriegelungsbedingung testen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um unsere Verriegelungsbedingung zu aktivieren, muss die Variable SW_Schalter1_CO einen Wert > 10 haben. Also führen wir bei der Variable ein „Sollwert setzen“ mit dem Wert 1000 aus.

Nun führen wir erneut die Aktion Befehl: ein aus.

Im Control der Verriegelungsmeldung wird nun der von uns projektierte Verriegelungstext angezeigt. Die Aktion kann so lange nicht ausgeführt werden, bis der Wert der Verriegelungsvariable wieder auf '0' gesetzt wird.