EibV2_32

EibV2_32

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Treiber für die Kommunikation mit dem European Installation Bus (EIB / KNX).

Der Treiber benötigt zur Runtime die Falcon Runtime, sowie die Software SQLANY für den Datenbankzugriff im Editor (Bestandteil der ETS Software).

Die Falcon Runtime und die ETS Dateien finden Sie am zenon Installationsmedium im Ordner: ...\Additional_Software\EIB - Falcon Runtime.

Noch in diesem Kapitel

EIBV2_32 - Datenblatt

Treiber-Historie

Voraussetzungen

Konfiguration

Variablen anlegen

Treiberspezifische Funktionen

Treiberkommandos

Fehleranalyse


EIBV2_32 - Datenblatt

EibV2_32 -> EIBV2_32 - Datenblatt

Allgemein: |
Treiberdateiname | EIBV2_32.exe
Treiberbezeichnung | EIB-KNX Bus Treiber
Steuerungs-Typen | EIB/KNX fähige Stationen
Steuerungs-Hersteller | EIB; KNX;

Treiber unterstützt: |
Protokoll | EIB Bus;
Adressierung: Adress-basiert | x
Adressierung: Namens-basiert | -
Kommunikation spontan | x
Kommunikation pollend | x
Online Browsing | -
Offline Browsing | x
Echtzeitfähig | -
Blockwrite | -
Modemfähig | -
Serielles Logging | -
RDA numerisch | -
RDA String | -

Voraussetzungen: |
Hardware PC | RS 232 serielle Schnittstelle; Standard Netzwerkkarte
Software PC | Zur Laufzeit: Schnittstellenprogramm Falcon Runtime. Für den Variablenimport Falcon Runtime >=2.0
Hardware Steuerung | Für Kommunikation über TCP/IP: Siemens TCP/IP - EIB Adapter: 5WG1 146-3AB01
Software Steuerung | -
Benötigt v-dll | x

Plattformen: |
Betriebssysteme | Windows Vista, 7, 8, 8.1 Server 2008/R2, Server 2012/R2;
CE Plattformen | -;


Treiber-Historie

EibV2_32 -> Treiber-Historie

Datum | Treiberversion | Änderung
07.07.08 | 1000 | Treiberdokumentation wurde neu erstellt

Treiberversionierung

Mit zenon 7.10 wurde die Versionierung der Treiber verändert. Ab dieser Version gibt es eine versionsübergreifende Build-Nummer. Das ist die Zahl an der 4. Stelle der Dateiversion.
Zum Beispiel: 7.10.0.4228 bedeutet: Der Treiber ist für Version 7.10, Servicepack 0 und hat die Build-Nummer 4228.

Erweiterungen oder Fehlerbehebungen werden zukünftig in einem Build eingebaut und sind dann ab der nächsthöheren Build-Nummer verfügbar.

Example Beispiel

Eine Treibererweiterung wurde in Build 4228 implementiert. Der Treiber, den Sie im Einsatz haben, verfügt über die Build-Nummer 8322. Da die Build-Nummer Ihres Treibers höher ist als die Build-Nummer der Erweiterung, ist die Erweiterung enthalten. Die Versionsnummer des Treiber (die ersten drei Stellen der Dateiversion) spielen dabei keine Rolle. Die Treiber sind versionsunabsabhängig


Voraussetzungen

EibV2_32 -> Voraussetzungen

Dieses Kapitel enthält Informationen zu den Voraussetzungen, die für die Verwendung des Treibers erforderlich sind.

Noch in diesem Kapitel

PC

Runtime


PC

EibV2_32 -> Voraussetzungen -> PC

Am PC, auf dem die zenon Entwicklungsumgebung (Editor) installiert werden soll, muss die EIB‑Projektierungssoftware ETS2 (ETS20.EXE) oder ETS3 installiert sein, damit Variablendefinitionen aus der ETS-Datenbank übernommen werden können. Für die Runtime ist die ETS-Datenbank nicht erforderlich.

Software-Installation

Möchten Sie die Variablen aus der ETS-Datenbank übernehmen, ist folgende Installation notwendig.

  • EIB-Projektierungssoftware ETS 2 oder ETS 3.
  • Für die Kommunikation während der Laufzeit benötigen Sie die „Falcon Runtime License". Bei einer ETS2 Installation ab Version 1.2, kann Falcon bereits auf dem Rechner vorhanden sein. Die Falcon Software wird auch mit der EIB-Treiber CD ausgeliefert.
  • Abhängig von der verwendeten ETS-Datenbank muss die jeweilige ETESVR32.DLL in das Installationsverzeichniss der ETS-Datenbank kopiert und mittels regsrv32 registriert werden.
  • Die zu Ihrer ETS-Datenbank passende ETESVR32.dll finden Sie am zenon Installationsmedium im Ordner: ...\Additional_Software\EIB - Falcon Runtime.
  • Für Version ETS2: Die Software für den Datenbankzugriff SQLANY50.ZIP in das ETS-Verzeichnis entpacken. Bei ETS3 wird SQLANY80 verwendet und mit ETS3 bereits automatisch mitinstalliert.

Für den Online-Import muss die Datei EIBv2_DB.dll im zenon Ordner vorhanden sein.

Hinweis: Falls der Treiber nicht über das Setup-Programm installiert wurde, kopieren Sie die EibV2_32.exe in den zenon Installationsordner und tragen diese dann mit dem Tool Driverinfo.exe in die TREIBER_DE.XML ein.


Runtime

EibV2_32 -> Voraussetzungen -> Runtime

Die Runtime benötigt das Schnittstellenprogramm Falcon von EIBA (siehe Abschnitt Softwareinstallation im Kapitel PC).


Konfiguration

EibV2_32 -> Konfiguration

In diesem Kapitel lesen Sie, wie Sie den Treiber im Projekt anlegen und welche Einstellungen beim Treiber möglich sind.

info Info

Weitere Einstellungen, die Sie für Variablen in zenon vornehmen können, finden Sie im Kapitel Variablen der Online-Hilfe.

Noch in diesem Kapitel

Anlegen eines Treibers

Einstellungen im Treiberdialog


Anlegen eines Treibers

EibV2_32 -> Konfiguration -> Anlegen eines Treibers

Um einen neuen Treiber anzulegen:

  1. Klicken Sie mit der rechten Maustaste im Projektmanager auf Treiber und selektieren Sie im Kontextmenü Treiber neu.
  2. In der folgenden Dialogbox bietet Ihnen das Programm eine Auflistung aller verfügbaren Treiber an.

  3. Selektieren Sie den gewünschten Treiber und vergeben Sie eine Bezeichnung für diesen:
    • Die Treiberbezeichnung muss eindeutig sein, d.h. wird ein und derselbe Treiber mehrmals im Projekt verwendet, so muss jeweils eine neue Bezeichnung vergeben werden.
    • Die Treiberbezeichnung ist Bestandteil des Dateinamens. Daher darf Sie nur Zeichen enthalten, die vom Betriebssystem unterstützt werden. Nicht gültige Zeichen werden durch einen Unterstrich (_) ersetzt.
    • Achtung: Die Bezeichnung kann später nicht mehr geändert werden.
  4. Bestätigen Sie den Dialog mit OK. Im folgenden Dialog werden die einzelnen Konfigurationen der jeweiligen Treiber eingestellt.

Für ein Projekt müssen nur die jeweils notwendigen Treiber eingebunden werden. Späteres Einbinden eines weiteren Treibers ist problemlos möglich.

info Info

Bei neu angelegten Projekten oder bei bestehenden Projekten, die in eine Version ab 6.21 konvertiert werden, werden die folgenden Treiber automatisch angelegt:

  • Intern
  • MathDr32
  • SysDrv.


Einstellungen im Treiberdialog

EibV2_32 -> Konfiguration -> Einstellungen im Treiberdialog

Folgende Einstellungen können Sie beim Treiber vornehmen:

  • Allgemein
  • EIBV2-Einstellungen

info Info

Die Treiberkonfiguration muss auf dem eigentlichen Runtime-Rechner geöffnet und bestätigt werden.

Noch in diesem Kapitel

Allgemein

Treiberdialog EIBV2-Einstellungen


Allgemein

EibV2_32 -> Konfiguration -> Einstellungen im Treiberdialog -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Parameter

Beschreibung

Modus

Ermöglicht ein Umschalten zwischen Hardware und Simulationsmodus

  • Hardware:

    Die Verbindung zur Steuerung wird hergestellt.

  • Simulation - statisch

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden vom Treiber simuliert. In diesem Modus bleiben die Werte konstant bzw. die Variablen behalten die über zenon Logic gesetzen Werte. Jede Variable hat seinen eigenen Speicherbereich. Zum Beispiel zwei Variablen vom Typ Merker mit Offset 79, können zur Runtime unterschiedliche Werte haben und beeinflussen sich gegenseitig nicht. Ausnahme: Der Simulatortreiber.

  • Simulation - zählend

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden vom Treiber simuliert. In diesem Modus zählt der Treiber die Werte innerhalb ihres Wertebereichs automatisch hoch.

  • Simulation - programmiert

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden von einem frei programmierbaren Simulationsprojekt berechnet. Das Simulationsprojekt wird mit der zenon Logic Workbench erstellt und läuft in einer in den Treiber integrierten zenon Logic Runtime ab. Details siehe Kapitel Treibersimulation.

Update-Liste im Speicher Halten

Einmal angeforderte Variablen werden weiterhin von der Steuerung angefordert, auch wenn diese aktuell nicht mehr benötigt werden.
Dies hat den Vorteil, dass z B. mehrmalige Bildumschaltungen nach dem erstmaligen Aufschalten beschleunigt werden, da die Variablen nicht neu angefordert werden müssen. Der Nachteil ist eine erhöhte Belastung der Kommunikation zur Steuerung.

Ausgänge schreibbar

Aktiv: Ausgänge können beschrieben werden.

Inaktiv: Das Beschreiben der Ausgänge wird unterbunden.

Hinweis: Steht nicht für jeden Treiber zur Verfügungen.

Variablenabbild remanent

Diese Option speichert und restauriert den aktuellen Wert, den Zeitstempel und die Status eines Datenpunkts.

Grundvoraussetzung: Die Variable muss einen gültigen Wert und Zeitstempel besitzen.

Das Variablenabbild wird im Modus Hardware gespeichert wenn:

  • einer der Status S_MERKER_1(0) bis S_MERKER8(7), REVISION(9), AUS(20) oder ERSATZWERT(27) aktiv ist

Das Variablenabbild wird immer gespeichert wenn:

  • die Variable vom Objekttyp Treibervariable ist
  • der Treiber im Simulationsmodus läuft. (nicht programmierte Simulation)

Folgende Status werden beim Start der Runtime nicht restauriert:

  • SELECT(8)
  • WR-ACK(40)
  • WR-SUC(41)

Der Modus Simulation - programmiert beim Treiberstart ist kein Kriterium, um das remanente Variablenabbild zu restaurieren.

Am Standby Server stoppen

Einstellung für Redundanz bei Treibern, die nur eine Kommunikationsverbindung erlauben. Dazu wird der Treiber am Standby Server gestoppt und erst beim Hochstufen wieder gestartet.

Achtung: Ist diese Option aktiv, ist die lückenlose Archivierung nicht mehr gewährleistet.

Aktiv: Versetzt den Treiber am nicht-prozessführenden Server automatisch in einen Stopp-ähnlichen Zustand. Im Unterschied zum Stoppen über Treiberkommando erhält die Variable nicht den Status abgeschaltet, sondern einen leeren Wert. Damit wird verhindert, dass beim Hochstufen zum Server nicht relevante Werte in AML , CEL und Archiv erzeugt werden.

Update Zeit Global

Aktiv: Die eingestellte Globale Update Zeit in ms wird für alle Variablen im Projekt verwendet. Die bei den Variablen eingestellte Priorität wird nicht verwendet.
Inaktiv: Die eingestellten Prioritäten werden für die einzelnen Variablen verwendet.

Priorität

Hier werden die Pollingzeiten der einzelnen Prioritäten eingestellt. Alle Variablen mit der entsprechenden Priorität werden in der eingestellten Zeit gepollt. Die Zuordnung zu den Variablen erfolgt separat bei jeder Variablen über die Einstellungen in den Variableneigenschaften.
Mit den Prioritäten kann die Kommunikation der einzelnen Variablen auf die Wichtigkeit bzw. benötigte Aktualität abgestuft werden. Daraus ergibt sich eine verbesserte Verteilung der Kommunikationslast.

OK

Übernimmt Einstellungen aus allen Registerkarten und schließt den Dialog.

Abbrechen

Verwirft alle Änderungen und schließt den Dialog.

Hilfe

Öffnet die Online-Hilfe.

Update Zeit zyklische Treiber

Für zyklische Treiber gilt:

Beim Sollwert Setzen, Advisen von Variablen und bei Requests wird sofort ein Lesezyklus für alle Treiber ausgelöst - unabhängig von der eingestellten Update Zeit. Damit wird sicher gestellt, dass der Wert nach dem Schreiben in der Visualisierung sofort zur Verfügung steht. Update-Zeiten können damit für zyklische Treiber kürzer ausfallen als eingestellt.


Treiberdialog EIBV2-Einstellungen

EibV2_32 -> Konfiguration -> Einstellungen im Treiberdialog -> Treiberdialog EIBV2-Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das für die Kommunikation mit dem EIB-Bus verwendete Falcon Control verwendet ab Version 1.23 den „Connection Manager" zum Verwalten und Konfigurieren aller Kommunikationsprotokolle. Für die Konfiguration bedeutet das zwei Möglichkeiten:

  • Konfiguration über Falcon Connection Manager
  • Konfiguration über zenon Dialog

1. Falcon Connection Manager

Unterstützt die installierte Falcon Version bereits den Connection Manager, wird der Falcon Connection Manager aufgerufen. Alle Schnittstellen und Protokolle, die die installierte Falcon-Version unterstützt, können vom Treiber verwendet werden.

Hinweis: Nicht alle Falcon-Versionen unterstützen alle Schnittstellen und Protokolle.

Der Connection Manager liefert für die ausgewählte Schnittstelle drei Informationen zurück:

  1. Name für die ausgewählte Verbindung,
  2. eine eindeutige Kennung (GUID) der ausgewählten Schnittstelle
  3. String mit den Verbindungsdaten

Diese werden in der Treiberkonfiguration gespeichert, und in der Runtime zum Verbindungsaufbau verwendet.

attention Achtung

Beachten Sie bei der Nutzung des Falcon Connection Managers:

  • Eruieren Sie vor der Auswahl der Falcon-Version die Versiongeschichte und beachten Sie die Systemanforderungen von Falcon. Nicht alle Falcon-Versionen laufen unter allen Betriebssystemen!
  • Weil der Connection Manager Teil des Falcon Controls ist, muss ab den neuen Treiberversionen auch auf dem Editor-Rechner eine passende Falcon-Version installiert sein. Diese Version muss in der Lage sein, die in der Runtime verwendeten Schnittstellen und Protokolle zu bearbeiten.
  • Nutzen Sie nur aktuelle Treiber. Ältere Treiber-Versionen sind mit den neuen Einstellungen nicht kompatibel.

Konvertierung Falcon Versionen

Wird auf einem Rechner, auf dem zuvor eine Falcon-Version ohne Connection Manager installiert war, eine neuere Version installiert, werden beim Öffnen des Konfigurationsdialogs die bisherigen projektierten Einstellungen für die Verwendung des Connection Managers konvertiert.

Im Connection Manager wird eine Verbindung gesucht, die den projektierten Einstellungen entspricht. Existiert keine solche Verbindung, wird eine neue angelegt und ausgewählt.

Einstellungen für Schnittstellen und Protokolle, die auch von vorherigen Falcon-Versionen unterstützt werden, werden weiterhin im bisherigen Format gespeichert .

attention Achtung

Falcon-Versionen, die zwar bereits den Connection Manger, aber noch nicht die neueren Schnittstellen und Protokolle unterstützen, kennen unter Umständen die mit neueren Falcon-Versionen projektierten Schnittstellen noch nicht.

Diese Schnittstellen können daher von den älteren Versionen nicht verwendet und konfiguriert werden.

Der Verbindungsaufbau mit diesen Protokollen in der Runtime schlägt dann fehl, die Variablen gehen auf „gestört".

Konfiguration

Siehe Abschnitt Konfiguration mit Falcon Connection Manager.

2. zenon Dialog

Wird ein Falcon Control verwendet, das den Connection Manager noch nicht unterstützt (vor 1.23), wird nur derzenon Konfigurationsdialog angezeigt. Es können dann auch nur die von diesem Dialog angebotenen Schnittstellen und Protokolle verwendet und konfiguriert werden: PEI16, PEI10 und EIBlib/IP.

Konfiguration

Siehe Abschnitt Konfiguration ohne Falcon Connection Manager.

Noch in diesem Kapitel

Konfiguration mit Falcon Connection Manager

Konfiguration ohne Falcon Connection Manager

IP-Konfiguration per Client


Konfiguration mit Falcon Connection Manager

EibV2_32 -> Konfiguration -> Einstellungen im Treiberdialog -> Treiberdialog EIBV2-Einstellungen -> Konfiguration mit Falcon Connection Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Unterstützt die installierte Falcon Version bereits den Connection Manager (ab 1,23), erfolgt die Konfiguration über den Falcon Connection Manager. Alle Schnittstellen und Protokolle, die die installierte Falcon-Version unterstützt, können vom Treiber verwendet werden.

Parameter |  | Beschreibung
Kommunikationsschnittstelle |  | Auswahl der Verbindung über Dropdownliste. Wird noch keine Verbindung angeboten, muss über Klick auf die Schaltfläche Bearbeiten eine neue Verbindung angelegt werden.
Bearbeiten |  | Öffnet den Falcon Connection Manager, um neue Verbindungen anzulegen oder vorhandene zu bearbeiten. Welche Verbindungen zur Verfügung stehen, hängt ab von der installierten Falcon Version.
Watchdog (min) |  | Prüfintervall in Minuten, in dem getestet wird, ob die Busteilnehmer ansprechbar sind. Default: 5 Aus: 0
Verzögerung beim Lesen (ms) | Der Treiber liest alle 30 Sekunden alle Werte, für die noch kein gültiger Wert vorhanden ist. Sind viele Werte ausständig, kann das Lesen zu sehr hohem Datenverkehr führen. Aktiv: Zwischen den einzelnen Werten wird das Lesen um den eingestellten Wert verzögert. Default: 100 ms
IP-Adresskonfiguration per Client-Rechner |  | Aktiv: Konfiguration der IP-Adresse kann für bis zu acht unterschiedliche Gateways erfolgen. Details siehe Abschnitt IP-Konfiguration per Client.

Noch in diesem Kapitel

Falcon Connection Manager


Falcon Connection Manager

EibV2_32 -> Konfiguration -> Einstellungen im Treiberdialog -> Treiberdialog EIBV2-Einstellungen -> Konfiguration mit Falcon Connection Manager -> Falcon Connection Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Welche Verbindungen zur Verfügung stehen, hängt ab von der installierten Falcon Version. Die folgenden Konfiguration verstehen sich daher als Beispiele.

Für alle Dialoge gilt:

  • Schaltfläche Neu: konfiguriert neue Verbindung
  • Schaltfläche Löschen: markierte Verbindung wird gelöscht
  • Schaltfläche OK: übernimmt Einstellungen für markierte Verbindung und schließt Connection Manager
  • Schaltfläche Abbrechen: verwirft Einstellungen für markierte Verbindung und schließt Connection Manager
  • Markierte Verbindung kann bearbeitet werden

KNXnet/IP

Parameter | Beschreibung
Name | Name der Verbindung wie er in der Dropdownliste angezeigt wird.
Typ | KNXnet/IP. Auswahl über Dropdownliste.
Standardverbindung | Diese Verbindung wird in der Dropdownliste der Kommunikationsschnittstelle vorausgewählt.
Kommunikationsparameter | Einstellungen für Kommunikation
KNXnet/IP Gerät | Einstellungen für Gerät.
Erneut scannen | Sucht nach im Netzwerk vorhandenen Geräten.
Dropdownliste Gerät | Liste aller zur Verfügung stehenden Geräte.
MAC-Adr.: | MAC-Adresse des gewählten Geräts.
Name | Name des Geräts
IP-Adresse | IP-Adresse
Port | Portnummer
NAT-Modus | aktiv: NAT wird genutzt. Default: inaktiv
KNXnet/IP Diagnose-Assistent | Startet den Diagnose-Assistent.

KNXnet/IP Routing

Parameter | Beschreibung
Name | Name der Verbindung wie er in der Dropdownliste angezeigt wird.
Typ | KNXnet/IP Routing. Auswahl über Dropdownliste.
Standardverbindung | Diese Verbindung wird in der Dropdownliste der Kommunikationsschnittstelle vorausgewählt.
Kommunikationsparameter | Einstellungen für Kommunikation
Netzwerk Adapter auswählen: | Auswahl des Netzwerk-Adapters aus Dropdownliste. Zahl in Klammer zeigt die über den Adapter verbundenen KNX/IP Geräte.
Rescan für KNXnet/IP Geräte | Sucht nach im Netzwerk vorhandenen Geräten.
Dropdownliste Gerät | Liste aller zur Verfügung stehenden Geräte.
Multicast-Adr.: | Multicast-Adresse
Port | Portnummer

IP

Parameter

Beschreibung

Name

Name der Verbindung wie er in der Dropdownliste angezeigt wird.

Typ

IP (EIBlib/IP)

Auswahl über Dropdownliste.

Standardverbindung

Diese Verbindung wird in der Dropdownliste der Kommunikationsschnittstelle vorausgewählt.

Kommunikationsparameter

Einstellungen für Kommunikation

Server

IP Adresse des Servers.

Protokoll

Wahl des Protokolls:

  • TCP
  • UDP

Konfig. Port

Portnummer für Konfiguration.

Lese-Port

Portnummer zum Lesen.

Schreib-Port

Portnummer zum Schreiben.

COM Port

Wahl des COM Ports aus Dropdownliste.

USB

Parameter | Beschreibung
Name | Name der Verbindung wie er in der Dropdownliste angezeigt wird.
Typ | KNXnet/IP. Auswahl über Dropdownliste:
Standardverbindung | Diese Verbindung wird in der Dropdownliste der Kommunikationsschnittstelle vorausgewählt.
Kommunikationsparameter | Einstellungen für Kommunikation
USB Gerät | Auswahl aus Dropdownliste


Konfiguration ohne Falcon Connection Manager

EibV2_32 -> Konfiguration -> Einstellungen im Treiberdialog -> Treiberdialog EIBV2-Einstellungen -> Konfiguration ohne Falcon Connection Manager

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Steht der Falcon Connection Manager nicht zur Verfügung, erfolgt die Konfiguration der Verbindung in der zenon Treiberkonfiguration, Registerkarte EIBV2-Einstellungen:

Parameter

Beschreibung

Typ

Auswahl der Verbindung über Dropdownliste:

  • PEI 16 mit 9600 bps
  • PEI 10 mit 19200 bps
  • EIBLib/IP über TCP/IP

Watchdog (min)

Prüfintervall in Minuten, in dem getestet wird, ob die Busteilnehmer ansprechbar sind.
Default: 5

Aus: 0

Verzögerung beim Lesen (ms)

Der Treiber liest alle 30 Sekunden alle Werte, für die noch kein gültiger Wert vorhanden ist. Sind viele Werte ausständig, kann das Lesen zu sehr hohem Datenverkehr führen.

Aktiv: Zwischen den einzelnen Werten wird das Lesen um den eingestellten Wert verzögert.

Default: 100 ms

PEI 16 / PEI 10

Einstellungen für PEI 16 und PEI 10

COM Port

Wahl des COM Ports aus Dropdownliste.

EIBLib/IP

Einstellungen für Verbindungen über TCP/IP

Protokoll

Wahl des Protokolls:

  • TCP
  • UDP

Port f. Konfiguration

Portnummer für Konfiguration.

Port f. Lesen

Portnummer zum Lesen.

Port f. Schreiben

Portnummer zum Schreiben.

IP-Adresskonfiguration per Client-Rechner

Aktiv: Konfiguration der IP-Adresse kann für bis zu acht unterschiedliche Gateways erfolgen.

Details siehe Abschnitt IP-Konfiguration per Client.

IP-Adresse

IP-Adresse des Gateways für alle Geräte


IP-Konfiguration per Client

EibV2_32 -> Konfiguration -> Einstellungen im Treiberdialog -> Treiberdialog EIBV2-Einstellungen -> IP-Konfiguration per Client

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die clientspezifische Angabe von Ziel-IP-Adressen gilt nur für EIBlib/IP.

Gateways, die die neueren IP-Protokolle (EIBnet/IP) unterstützen, erlauben mehrere Verbindungen auf die gleiche IP-Adresse und benötigen diese Konfiguration nicht.

Die Konfiguration erfolgt in der Registerkarte EIBV2 Einstellungen gleichermaßen für:

  • Konfiguration ohne Falcon Connection Manager

  • und für den Falcon Connection Manager

Parameter | Beschreibung
IP-Adresskonfiguration per Client-Rechner | Aktiv: Konfiguration der IP-Adresse kann für bis zu acht unterschiedliche Gateways.
Rechnername | Name des Rechners.
IP-Adresse | IP-Adresse des Gateways.


Variablen anlegen

EibV2_32 -> Variablen anlegen

So werden Variablen im zenon Editor angelegt:

Noch in diesem Kapitel

Variablen im Editor anlegen

Adressierung

Treiberobjekte und Datentypen

Variablen anlegen durch Import

Treibervariablen


Variablen im Editor anlegen

EibV2_32 -> Variablen anlegen -> Variablen im Editor anlegen

Variablen können angelegt werden:

  • als einfache Variable
  • in Arrays
  • als Struktur-Variablen

Dialog Variable

Um eine neue Variable zu erstellen, gleich welchen Typs:

  1. wählen Sie im Knoten Variablen im Kontextmenü den Befehl Variable neu

  2. der Dialog zur Konfiguration der Variable wird geöffnet
  3. konfigurieren Sie die Variable
  4. welche Einstellungen möglich sind, hängt ab vom Typ der Variablen

Eigenschaft

Beschreibung

Name

Eindeutiger Name der Variablen. Ist eine Variable mit gleichem Namen im Projekt bereits vorhanden, kann keine weitere Variable mit diesem Namen angelegt werden.

Maximale Länge: 128 Zeichen

Achtung: Die Zeichen # und @ sind für Variablennamen nicht erlaubt. Bei Verwendung nicht zugelassener Zeichen kann die Variablenerstellung nicht abgeschlossen werden, die Schaltfläche Fertigstellen bleibt inaktiv.

Treiber

Wählen Sie aus der Dropdownliste den gewünschten Treiber.

Hinweis: Sollte im Projekt noch kein Treiber angelegt sein, wird automatisch der Treiber für interne Variable (Intern.exe) geladen.

Treiber-Objekttyp

Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.

Datentyp

Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.

Array-Einstellungen

Erweiterte Einstellungen für Array-Variablen. Details dazu lesen Sie im Abschnitt Arrays.

Adressierungsoptionen

Erweiterte Einstellungen für Arrays und Struktur-Variablen. Details dazu lesen Sie im jeweiligen Abschnitt.

Automatische Elementeaktivierung

Erweiterte Einstellungen für Arrays und Struktur-Variablen. Details dazu lesen Sie im jeweiligen Abschnitt.

Ableitung vom Datentyp

Messbereich, Signalbereich und Sollwert Setzen werden immer:

  • vom Datentyp abgeleitet
  • beim Ändern des Datentyps automatisch angepasst

Hinweis Signalbereich: Bei einem Wechsel auf einen Datentyp, der den eingestellten Signalbereich nicht unterstützt, wird der Signalbereich automatisch angepasst. Zum Beispiel wird bei einem Wechsel von INT auf SINT der Signalbereich auf 127 geändert. Die Anpassung erfolgt auch dann, wenn der Signalbereich nicht vom Datentyp abgeleitet wurde. In diesem Fall muss der Messbereich manuell angepasst werden.


Adressierung

EibV2_32 -> Variablen anlegen -> Adressierung

Gruppenadressen

Bei Gruppenadressierung ist die Angabe von Haupt-, Mittel- und Untergruppe erforderlich. Bei der Übernahme aus der Datenbank werden zur Information die mit der betreffenden Gruppe verknüpften Objekte angezeigt.


Treiberobjekte und Datentypen

EibV2_32 -> Variablen anlegen -> Treiberobjekte und Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Treiberobjekte sind in der Steuerung verfügbare Bereiche wie z. B. Merker, Datenbausteine usw. Hier lesen Sie, welche Treiberobjekte vom Treiber zur Verfügung gestellt werden und welche IEC-Datentypen dem jeweiligen Treiberobjekt zugeordnet werden können.

Noch in diesem Kapitel

Treiberobjekte

Zuordnung der Datentypen


Treiberobjekte

EibV2_32 -> Variablen anlegen -> Treiberobjekte und Datentypen -> Treiberobjekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Objekttypen stehen in diesem Treiber zur Verfügung:

Treiberobjekttyp | Kanaltyp | Lesen / Schreiben | Unterstützte Datentypen | Kommentar
Gruppe | 80 | L/S | REAL, BOOL, DINT, UDINT, INT, UINT, USINT, SINT |
Gruppe 1-6 Bit | 83 | L/S | USINT |
Gruppe 16Bit-Float (EIS 5) | 82 | L/S | REAL |
Treibervariable | 35 | L/S | BOOL, SINT, USINT, INT, UINT, DINT, UDINT, REAL, STRING | Variablen zur statistischen Auswertung der Kommunikation. Weitere Infos finden Sie bei den Treibervariablen

Objekte für Prozessvariablen in zenon

Objekt | Lesen | Schreiben | Kommentar
Gruppe Bit | J | J |
Gruppe Byte | J | J |
Gruppe Wort | J | J |
Gruppe Doppelwort | J | J |


Zuordnung der Datentypen

EibV2_32 -> Variablen anlegen -> Treiberobjekte und Datentypen -> Zuordnung der Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Alle Variablen in zenon werden von IEC-Datentypen abgeleitet. In folgender Tabelle werden zur besseren Übersicht die IEC-Datentypen den Datentypen der Steuerung gegenübergestellt.

Steuerung | zenon | Datenart
 | BOOL | 8
 | USINT | 9
 | SINT | 10
 | UINT | 2
 | INT | 1
 | UDINT | 4
 | DINT | 3
 | ULINT | 27
 | LINT | 26
 | REAL | 5
 | LREAL | 6
 | STRING | 12
 | WSTRING | 21
 | DATE | 18
 | TIME | 17
 | DATE_AND_TIME | 20
 | TOD (Time of Day) | 19

Datenart: Die Eigenschaft Datenart ist die interne numerische Bezeichnung des Datentyps. Diese wird auch für den erweiterten DBF Import/Export der Variablen verwendet.


Variablen anlegen durch Import

EibV2_32 -> Variablen anlegen -> Variablen anlegen durch Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen können auch mittels Variablenimport angelegt werden. Für jeden Treiber stehen XML- und DBF-Import zur Verfügung.

info Info

Details zu Import und Export von Variablen finden Sie im Handbuch Import-Export im Abschnitt Variablen.

Noch in diesem Kapitel

XML Import

DBF Import/Export

Online-Import


XML Import

EibV2_32 -> Variablen anlegen -> Variablen anlegen durch Import -> XML Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für den Import/Export von Variablen gilt:

  • Der Import/Export darf nicht aus dem Globalprojekt gestartet werden.
  • Der Start erfolgt über:
    • Kontextmenü zu Variablen bzw. Datentyp im Projektbaum
    • oder Kontextmenü einer Variablen bzw. eines Datentyps
    • oder Symbol in der Symbolleiste Variablen

attention Achtung

Beim Import/Überschreiben von existierenden Datentypen werden alle Variablen geändert, die auf diesem existierenden Datentyp basieren.

Beispiel:

Es existiert ein Datentyp XYZ abgeleitet vom Typ INT mit Variablen, die auf diesem Datentyp basieren. Ihre zu importierende XML-Datei enthält ebenfalls einen Datentyp mit Namen XYZ, allerdings abgeleitet vom Typ STRING. Wird dieser Datentyp importiert, so wird der existierende Datentyp überschrieben und bei allen auf ihm basierenden Variablen der Typ angepasst. D.h. die Variablen sind jetzt STRING- und keine INT-Variablen mehr.


DBF Import/Export

EibV2_32 -> Variablen anlegen -> Variablen anlegen durch Import -> DBF Import/Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Daten können nach dBase exportiert und aus dBase importiert werden.

info Info

Import und Export über CSV oder dBase unterstützt keine treiberspezifischen Variableneinstellungen wie z. B. Formeln. Nutzen Sie dafür den Export/Import über XML.

Import DBF-Datei

Um den Import zu starten:

  1. führen Sie einen Rechtsklick auf die Variablenliste aus
  2. wählen Sie in der Dropdownliste von Erweiterter Export/Import ... den Befehl dBase importieren
  3. folgen Sie dem Importassistenten

Das Format der Datei ist im Kapitel Dateiaufbau beschrieben.

info Info

Beachten Sie:

  • Treiberobjekttyp und Datentyp müssen in der DBF-Datei an den Zieltreiber angepasst werden, damit Variablen importiert werden.
  • dBase unterstützt beim Import keine Strukturen oder Arrays (komplexe Variablen).

Export DBF-Datei

Um den Export zu starten:

  1. führen Sie einen Rechtsklick auf die Variablenliste aus
  2. wählen Sie im Dropdownliste von Erweiterter Export/Import ... den Befehl dBase exportieren...
  3. folgen Sie dem Exportassistenten

attention Achtung

DBF-Dateien:

  • müssen in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • dürfen im Pfadnamen keinen Punkt (.) enthalten.
    Z. B. ist der Pfad C:\users\Max.Mustermann\test.dbf ungültig.
    Gültig wäre: C:\users\MaxMustermann\test.dbf
  • müssen nahe am Stammverzeichnis (Root) abgelegt werden, um die eventuelle Beschränkungen für Dateinamenlänge inklusive Pfad zu erfüllen: maximal 255 Zeichen

Das Format der Datei ist im Kapitel Dateiaufbau beschrieben.

info Info

dBase unterstützt beim Export keine Strukturen oder Arrays (komplexe Variablen).

Dateiaufbau der dBase Exportdatei

Für den Variablenimport und -export muss die dBaseIV-Datei folgende Struktur und Inhalte besitzen.

attention Achtung

dBase unterstützt keine Strukturen oder Arrays (komplexe Variablen).

DBF-Dateien müssen:

  • in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • nahe am Stammverzeichnis (Root) abgelegt werden

Struktur

Bezeichnung | Typ | Feldgröße | Bemerkung
KANALNAME | Char | 128 | Variablenname. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_R | C | 128 | Ursprünglicher Name einer Variablen, der durch den Eintrag unter VARIABLENNAME ersetzt werden soll (Feld/Spalte muss manuell angelegt werden). Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_D | Log | 1 | Variable wird bei Eintrag 1 gelöscht (Feld/Spalte muss manuell angelegt werden).
TAGNR | C | 128 | Kennung. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
EINHEIT | C | 11 | Technische Maßeinheit
DATENART | C | 3 | Datentyp (z. B. Bit, Byte, Wort, ...) entspricht dem Datentyp.
KANALTYP | C | 3 | Speicherbereich in der SPS (z. B. Merkerbereich, Datenbereich, ...) entspricht Treiber-Objekttyp.
HWKANAL | Num | 3 | Bus-Adresse
BAUSTEIN | N | 3 | Datenbaustein-Adresse (nur bei Variablen aus den Datenbereich der SPS)
ADRESSE | N | 5 | Offset
BITADR | N | 2 | Für Bit-Variablen: Bitadresse Für Byte-Variablen: 0=niederwertig, 8=höherwertig Für String-Variablen: Stringlänge (max. 63 Zeichen)
ARRAYSIZE | N | 16 | Anzahl der Variablen im Array für Index-Variablen ACHTUNG: Nur die erste Variable steht voll zur Verfügung. Alle folgenden sind nur über VBA oder den Rezeptgruppen Manager zugänglich
LES_SCHR | L | 1 | Lese-Schreib-Berechtigung 0: Sollwert setzen ist nicht erlaubt 1: Sollwert setzen ist erlaubt
MIT_ZEIT | L | 1 | Zeitstempelung in zenon (nur wenn vom Treiber unterstützt)
OBJEKT | N | 2 | Treiberspezifische ID-Nummer des Primitivobjekts setzt sich zusammen aus TREIBER-OBJEKTTYP und DATENTYP
SIGMIN | Float | 16 | Rohwertsignal minimal (Signalauflösung)
SIGMAX | F | 16 | Rohwertsignal maximal (Signalauflösung)
ANZMIN | F | 16 | technischer Wert minimal (Messbereich)
ANZMAX | F | 16 | technischer Wert maximal (Messbereich)
ANZKOMMA | N | 1 | Anzahl der Nachkommastellen für die Darstellung der Werte (Messbereich)
UPDATERATE | F | 19 | Updaterate für Mathematikvariablen (in sec, eine Dezimalstelle möglich) bei allen anderen Variablen nicht verwendet
MEMTIEFE | N | 7 | Nur aus Kompatibilitätsgründen vorhanden
HDRATE | F | 19 | HD-Updaterate für hist. Werte (in sec, eine Dezimalstelle möglich)
HDTIEFE | N | 7 | HD-Eintragtiefe für hist. Werte (Anzahl)
NACHSORT | L | 1 | HD-Werte als nachsortierte Werte
DRRATE | F | 19 | Aktualisierung an die Ausgabe (für zenon DDE-Server, in sec, eine Kommastelle möglich)
HYST_PLUS | F | 16 | Positive Hysterese; ausgehend vom Messbereich
HYST_MINUS | F | 16 | Negative Hyterese; ausgehend vom Messbereich
PRIOR | N | 16 | Priorität der Variable
REAMATRIZE | C | 32 | Name der zugeordnete Reaktionsmatrix
ERSATZWERT | F | 16 | Ersatzwert; ausgehend vom Messbereich
SOLLMIN | F | 16 | Sollwertgrenze Minimum; ausgehend vom Messbereich
SOLLMAX | F | 16 | Sollwertgrenze Maximum; ausgehend vom Messbereich
VOMSTANDBY | L | 1 | Variable vom Standby Server anfordern; der Wert der Variable wird im redundanten Netzwerkbetrieb nicht vom Server sondern vom Standby Server angefordert
RESOURCE | C | 128 | Betriebsmittelkennung. Freier String für Export und Anzeige in Listen. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
ADJWVBA | L | 1 | Nichtlineare Wertanpassung: 0: Nichtlineare Wertanpassung wird verwendet 1: Nichtlineare Wertanpassung wird nicht verwendet
ADJZENON | C | 128 | Verknüpftes VBA-Makro zum Lesen der Variablenwerte für die nichtlineare Wertanpassung.
ADJWVBA | C | 128 | Verknüpftes VBA-Makro zum Schreiben der Variablenwerte für die nichtlineare Wertanpassung.
ZWREMA | N | 16 | Verknüpfte Zählwert-Rema.
MAXGRAD | N | 16 | Maximaler Gradient für die Zählwert-Rema.

attention Achtung

Beim Import müssen Treiberobjekttyp und Datentyp in der DBF-Datei an den Zieltreiber angepasst werden, damit Variablen importiert werden.

Grenzwertdefinition

Grenzwertdefinition für Grenzwert 1 bis 4, bzw. Zustand 1 bis 4:

Bezeichnung | Typ | Feldgröße | Bemerkung
AKTIV1 | L | 1 | Grenzwert aktiv (pro Grenzwert vorhanden)
GRENZWERT1 | F | 20 | technischer Wert oder ID-Nummer der verknüpften Variable für einen dynamischen Grenzwert (siehe VARIABLEx) (wenn unter VARIABLEx 1 steht und hier -1, wird die bestehende Variablenzuordnung nicht überschrieben)
SCHWWERT1 | F | 16 | Schwellwert für den Grenzwert
HYSTERESE1 | F | 14 | wird nicht verwendet
BLINKEN1 | L | 1 | Blinkattribut setzen
BTB1 | L | 1 | Protokollierung in CEL
ALARM1 | L | 1 | Alarm
DRUCKEN1 | L | 1 | Druckerausgabe (bei CEL oder Alarm)
QUITTIER1 | L | 1 | quittierpflichtig
LOESCHE1 | L | 1 | löschpflichtig
VARIABLE1 | L | 1 | dyn. Grenzwertverknüpfung der Grenzwert wird nicht durch einen absoluten Wert (siehe Feld GRENZWERTx) festgelegt.
FUNC1 | L | 1 | Funktionsverknüpfung
ASK_FUNC1 | L | 1 | Ausführung über die Alarmmeldeliste
FUNC_NR1 | N | 10 | ID-Nummer der verknüpften Funktion (steht hier -1, so wird die bestehende Funktion beim Import nicht überschrieben)
A_GRUPPE1 | N | 10 | Alarm/Ereignis-Gruppe
A_KLASSE1 | N | 10 | Alarm/Ereignis-Klasse
MIN_MAX1 | C | 3 | Minimum, Maximum
FARBE1 | N | 10 | Farbe als Windowskodierung
GRENZTXT1 | C | 66 | Grenzwerttext
A_DELAY1 | N | 10 | Zeitverzögerung
INVISIBLE1 | L | 1 | Unsichtbar

Bezeichnungen in der Spalte Bemerkung beziehen sich auf die in den Dialogboxen zur Definition von Variablen verwendeten Begriffe. Bei Unklarheiten, siehe Kapitel Variablendefinition.


Online-Import

EibV2_32 -> Variablen anlegen -> Variablen anlegen durch Import -> Online-Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Variablen des EiB Treibers können direkt von der Steuerung in zenon importiert werden. Für den Online-Import muss die Datei EIBv2_DB.dll im zenon Ordner vorhanden sein.

Für den Online-Import:

  1. wählen Sie im Kontextmenü des Treibers den Befehl Variablen vom Treiber importieren
  2. der Dialog zur Variablenauswahl wird geöffnet
  3. wählen Sie die gewünschten Variablen
  4. übernehmen Sie die Variablenadresse
  5. schließen Sie den Dialog mit Klick auf OK

Variablenauswahl

Parameter

Beschreibung

Datenbank

Auswahl der EIB-Datenbank.

Standard: EIB.DB im Installationsverzeichnis von ETS.

Ab ETS3 können zusätzliche Datenbanken angelegt werden. Um eine alternative Datenbank zu wählen, geben Sie den Namen inklusive Pfad in das Dialogfeld ein oder wählen Sie die Datenbank über Klick auf die Schaltfläche ... aus.
Bei leerem Feld wird automatisch die EIB.DB Datenbank verwendet.

Achtung: Die eteSvr32.dll muss Version 1.4.7.1 oder höher sein. Ältere Versionen werden nicht unterstützt und führen beim Einlesen der Datenbank zu einem Fehler.

Projekt

Auswahl eines Projektes aus der Datenbank über Dropdownliste.

Objekte des Projekts werden eingelesen (ETS Objekte) und im Listenfeld angezeigt. Das Einlesen kann - abhängig von der Projektgröße - mehrere Minuten dauern.

ETS Objekte

Die Objekte werden im Baum hierarchisch dargestellt.

Objekte der jeweils nächsttieferen Hierarchiestufe werden im Listenfeld Groups angezeigt.

Ist im Baum eine Untergruppe selektiert, werden im Listenfeld Groups die mit dieser Gruppe verknüpften Kommunikationsobjekte angezeigt. Diese Anzeige dient nur der Information.

Gruppen werden Klick auf die Schaltfläche Hinzufügen zur Importliste hinzugefügt. Dabei gilt:

  • Objekte aus dem Listenfeld (Main Group, Middle Group, Sub Group) haben Vorrang vor den im Baum (ETS Objekte) selektierten. Sind in der Liste Gruppen selektiert, werden diese in die Auswahl übernommen, ansonsten die im Baum selektierten Gruppen.
  • Sind in der Liste bzw. im Baum Haupt- oder Mittelgruppen selektiert, werden alle darin enthaltenen Untergruppen in die Auswahl übernommen.
  • Sub Groups können per Doppelklick hinzugefügt werden

Groups

Je nach Auswahl im Bereich ETS Objekte stehen Gruppen zur Auswahl zur Verfügung:

  • Main Group
  • Middle Group
  • Sub Group
  • Object

Variablen

Liste der zu importierenden Variablen.

Hinzufügen

Ausgewählte Variablen aus ETS Objekte oder den Gruppen zur Liste hinzufügen.

Entfernen

Markierte Variablen aus der Importliste entfernen. Mehrfachauswahl ist möglich.

OK

Bestätigt Konfiguration des Online-Imports, schließt Dialog und startet Variablenimport.

Abbrechen

Verwirft Auswahl und schließt Dialog. es werden keine Variablen importiert.

Beispiel

  1. Auswahl aus der Datenbank EIB stellt drei Gruppen zur Verfügung:
    • Switches
    • Input
    • Sequence modules
  2. Auswahl von Switches öffnet Middle Group

  3. Auswahl von Binaryoutput.2 aus der Middle Group öffnet Sub Group
    • 1 - Ausgang A
    • 2 - Ausgang A
    • 3 - Ausgang C
    • 4 - Ausgang D

  4. Auswahl der Sub Group 1 - Ausgang A öffnet die Liste der Objekte


Treibervariablen

EibV2_32 -> Variablen anlegen -> Treibervariablen

Das Treiberkit implementiert eine Reihe von Treibervariablen. Diese sind unterteilt in:

  • Information
  • Konfiguration
  • Statistik und
  • Fehlermeldungen

Die Definitionen der im Treiberkit implementierten Variablen sind in der Importdatei drvvar.dbf (auf der CD im Verzeichnis: CD_Laufwerk:/Predefined/Variables) verfügbar und können von dort importiert werden.

Hinweis: Variablennamen müssen in zenon einzigartig sein. Soll nach einem Import der Treibervariablen aus drvvar.dbf ein erneuter Import durchgeführt werden, müssen die zuvor importierten Variablen umbenannt werden.

info Info

Nicht jeder Treiber unterstützt alle Treibervariablen.

Zum Beispiel werden:

  • Variablen für Modem-Informationen nur von modemfähigen Treibern unterstützt
  • Treibervariablen für den Polling-Zyklus nur für rein pollenden Treibern
  • verbindungsbezogene Informationen wie ErrorMSG nur von Treibern, die zu einem Zeitpunkt nur eine Verbindung bearbeiten

Information

Name aus Import | Typ | Offset | Erklärung
MainVersion | UINT | 0 | Haupt-Versionsnummer des Treibers.
SubVersion | UINT | 1 | Sub-Versionsnummer des Treibers.
BuildVersion | UINT | 29 | Build-Versionsnummer des Treibers.
RTMajor | UINT | 49 | zenon Hauptversionsnummer
RTMinor | UINT | 50 | zenon Sub-Versionsnummer
RTSp | UINT | 51 | zenon Servicepack-Nummer
RTBuild | UINT | 52 | zenon Buildnummer
LineStateIdle | BOOL | 24.0 | TRUE, wenn die Modemleitung belegt ist.
LineStateOffering | BOOL | 24.1 | TRUE, wenn ein Anruf rein kommt.
LineStateAccepted | BOOL | 24.2 | Der Anruf wird angenommen.
LineStateDialtone | BOOL | 24.3 | Rufton wurde erkannt.
LineStateDialing | BOOL | 24.4 | Wahl aktiv.
LineStateRingBack | BOOL | 24.5 | Während Verbindungsaufbau.
LineStateBusy | BOOL | 24.6 | Zielstation besetzt.
LineStateSpecialInfo | BOOL | 24.7 | Spezielle Statusinformation empfangen.
LineStateConnected | BOOL | 24.8 | Verbindung hergestellt.
LineStateProceeding | BOOL | 24.9 | Wahl ausgeführt.
LineStateOnHold | BOOL | 24.10 | Verbindung in Halten.
LineStateConferenced | BOOL | 24.11 | Verbindung im Konferenzmodus.
LineStateOnHoldPendConf | BOOL | 24.12 | Verbindung in Halten für Konferenz.
LineStateOnHoldPendTransfer | BOOL | 24.13 | Verbindung in Halten für Transfer.
LineStateDisconnected | BOOL | 24.14 | Verbindung beendet.
LineStateUnknow | BOOL | 24.15 | Verbindungszustand nicht bekannt.
ModemStatus | UDINT | 24 | Aktueller Modemstatus.
TreiberStop | BOOL | 28 | Treiber gestoppt Bei Treiberstop, hat die Variable den Wert TRUE und ein OFF-Bit. Nach dem Treiberstart, hat die Variable den Wert FALSE und kein OFF-Bit.
SimulRTState | UDINT | 60 | Informiert über Status der Runtime bei Treibersimulation.

Konfiguration

Name aus Import | Typ | Offset | Erklärung
ReconnectInRead | BOOL | 27 | Wenn TRUE, dann wird beim Lesen automatisch ein Neuaufbau der Verbindung durchgeführt.
ApplyCom | BOOL | 36 | Änderungen an den Einstellungen der seriellen Schnittstelle zuweisen. Das Schreiben auf diese Variable hat unmittelbar den Aufruf der Methode SrvDrvVarApplyCom zur Folge (aktuell ohne weitere Funktion).
ApplyModem | BOOL | 37 | Änderungen an den Modemeinstellungen zuweisen. Das Schreiben auf diese Variable hat unmittelbar den Aufruf der Methode SrvDrvVarApplyModem zur Folge. Diese schließt die aktuelle Verbindung und öffnet eine neue entsprechend den Einstellungen PhoneNumberSet und ModemHwAdrSet.
PhoneNumberSet | STRING | 38 | Telefonnummer, welche verwendet werden soll.
ModemHwAdrSet | DINT | 39 | Hardwareadresse, welche zu der Telefonnummer gehört.
GlobalUpdate | UDINT | 3 | Updatezeit in Millisekunden (ms).
BGlobalUpdaten | BOOL | 4 | TRUE, wenn die Updatezeit global ist.
TreiberSimul | BOOL | 5 | TRUE, wenn der Treiber in Simulation ist.
TreiberProzab | BOOL | 6 | TRUE, wenn das Prozessabbild gehalten werden soll.
ModemActive | BOOL | 7 | TRUE, wenn das Modem bei diesem Treiber aktiv ist.
Device | STRING | 8 | Name der seriellen Schnittstelle oder Name des Modem.
ComPort | UINT | 9 | Nummer der seriellen Schnittstelle.
Baudrate | UDINT | 10 | Baudrate der seriellen Schnittstelle.
Parity | SINT | 11 | Parität der seriellen Schnittstelle.
ByteSize | USINT | 14 | Bitanzahl pro Zeichen der seriellen Schnittstelle. Wert = 0, wenn der Treiber keine serielle Kommunikation herstellen kann.
StopBit | USINT | 13 | Anzahl der Stoppbits der seriellen Schnittstelle.
Autoconnect | BOOL | 16 | TRUE, wenn die Modemverbindung automatisch beim Lesen/Schreiben aufgebaut werden soll.
PhoneNumber | STRING | 17 | Aktuelle Telefonnummer.
ModemHwAdr | DINT | 21 | Hardwareadresse zur aktuellen Telefonnummer.
RxIdleTime | UINT | 18 | Wenn länger als diese Zeit in Sekunden (s) erfolgreich kein Datenverkehr stattfindet, wird die Modemverbindung beendet.
WriteTimeout | UDINT | 19 | Maximale Schreibdauer bei einer Modemverbindung in Millisekunden (ms).
RingCountSet | UDINT | 20 | So oft läutet ein hereinkommender Anruf, bevor dieser angenommen wird.
ReCallIdleTime | UINT | 53 | Wartezeit zwischen Anrufen in Sekunden (s).
ConnectTimeout | UINT | 54 | Zeit in Sekunden (s) für Verbindungsaufbau.

Statistik

Name aus Import | Typ | Offset | Erklärung
MaxWriteTime | UDINT | 31 | Längste Zeit in Millisekunden (ms), die zum Schreiben benötigt wird.
MinWriteTime | UDINT | 32 | Kürzeste Zeit in Millisekunden (ms), die zum Schreiben benötigt wird.
MaxBlkReadTime | UDINT | 40 | Längste Zeit in Millisekunden (ms), die zum Lesen eines Datenblocks benötigt wird.
MinBlkReadTime | UDINT | 41 | Kürzeste Zeit in Millisekunden (ms), die zum Lesen eines Datenblocks benötigt wird.
WriteErrorCount | UDINT | 33 | Anzahl der Schreibfehler.
ReadSucceedCount | UDINT | 35 | Anzahl der erfolgreichen Leseversuche.
MaxCycleTime | UDINT | 22 | Längste Zeit in Millisekunden (ms), die zum Lesen aller angeforderten Daten benötigt wurde.
MinCycleTime | UDINT | 23 | Kürzeste Zeit in Millisekunden (ms), die zum Lesen aller angeforderten Daten benötigt wurde.
WriteCount | UDINT | 26 | Anzahl der Schreibversuche.
ReadErrorCount | UDINT | 34 | Anzahl der fehlerhaften Leseversuche.
MaxUpdateTimeNormal | UDINT | 56 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Normal in Millisekunden (ms).
MaxUpdateTimeHigher | UDINT | 57 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Höher in Millisekunden (ms).
MaxUpdateTimeHigh | UDINT | 58 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Hoch in Millisekunden (ms).
MaxUpdateTimeHighest | UDINT | 59 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Höchste in Millisekunden (ms).
PokeFinish | BOOL | 55 | Geht für eine Abfrage auf 1, wenn alle anstehenden Pokes ausgeführt wurden.

Fehlermeldungen

Name aus Import | Typ | Offset | Erklärung
ErrorTimeDW | UDINT | 2 | Zeit (in Sekunden seit 1.1.1970), wann der letzte Fehler auftrat.
ErrorTimeS | STRING | 2 | Zeit (in Sekunden seit 1.1.1970), wann der letzte Fehler als String auftrat.
RdErrPrimObj | UDINT | 42 | Nummer des PrimObjektes, als der letzte Lesefehler verursacht wurde.
RdErrStationsName | STRING | 43 | Name der Station, als der letzte Lesefehler verursacht wurde.
RdErrBlockCount | UINT | 44 | Anzahl der zu lesenden Blöcke, als der letzte Lesefehler verursacht wurde.
RdErrHwAdresse | DINT | 45 | Hardwareadresse, als der letzte Lesefehler verursacht wurde.
RdErrDatablockNo | UDINT | 46 | Bausteinnummer, als der letzte Lesefehler verursacht wurde.
RdErrMarkerNo | UDINT | 47 | Merkernummer, als der letzte Lesefehler verursacht wurde.
RdErrSize | UDINT | 48 | Blockgröße, als der letzte Lesefehler verursacht wurde.
DrvError | USINT | 25 | Fehlermeldung als Nummer.
DrvErrorMsg | STRING | 30 | Fehlermeldung als Klartext.
ErrorFile | STRING | 15 | Name der Fehlerprotokolldatei.


Treiberspezifische Funktionen

EibV2_32 -> Treiberspezifische Funktionen

Dieser Treiber unterstützt folgende Funktionen:

Übernahme von Variablen aus der ETS Datenbank

Über den Button „Datenbank" können Variablendefinitionen aus der ETS 2.0-Datenbank übernommen werden. Es können nur Gruppenadressen übernommen werden.

Gruppenadressen

Bei Gruppenadressierung ist die Angabe von Haupt-, Mittel- und Untergruppe erforderlich. Bei der Übernahme aus der Datenbank werden zur Information die mit der betreffenden Gruppe verknüpften Objekte angezeigt.

Zyklisch lesen von Gruppen

Der EIB-Treiber arbeitet spontan, das heißt er holt sich die Werte am Anfang, und wartet dann, bis er von der Hardware (bzw. Falcon), benachrichtigt wird, dass sich ein Wert geändert hat. Wenn nun ein Gerät am Bus ausfällt, erfährt man in der Regel nichts davon, es kommen aber keine neuen Werte mehr.

Hat man wichtige Geräte am Bus (z. B. Brandmelder) ist eine solche Situation natürlich fatal. Zu diesem Zweck kann man Variablen solcher Geräte auf "Zyklisch lesen" setzen (in den Adresseigenschaften), damit sie regelmäßig ausgelesen werden, und ein Ausfall sofort festgestellt werden kann.

attention Achtung

Diese Option sollte sehr Vorsichtig gewählt werden, die Busbelastung steigt dadurch enorm an.

INI Einträge

project.ini Einträge

Über folgenden Eintrag in der project.ini kann festgelegt werden, ob ein Diagnosefenster angezeigt wird. Im Diagnosefenster werden alle Lese- und Schreibanforderungen mit den entsprechenden Antworten sowie alle Fehler angezeigt. Über den Button „Speichern" kann der Inhalt des Diagnosefensters in der Datei „Diagnose.txt" im Projektverzeichnis gespeichert werden.

[EIBV2_32]

DIAGNOSE=1

Einschränkungen

Es können nur Gruppen gelesen werden die in der ETS3 Software als Lesend (Attribut L) definiert sind. Gruppen die nur beschreibbar sind werden in zenon grundsätzlich auf INVALID gesetzt bis ein Wert geschrieben wird weil der Treiber erst dann den Status der Datenpunkte kennt.


Treiberkommandos

EibV2_32 -> Treiberkommandos

Dieses Kapitel beschreibt Standardfunktionalitäten, die für die meisten zenon Treiber gültig sind. Nicht alle hier beschriebenen Funktionalitäten stehen für jeden Treiber zur Verfügung. Zum Beispiel enthält ein Treiber, der laut Datenblatt keine Modemverbindung unterstützt, auch keine Modem-Funktionalitäten.

Treiberkommandos dienen dazu, Treiber über zenon zu beeinflussen, z. B. starten und stoppen.
Die Projektierung erfolgt über die Funktion Treiber Kommandos. Dazu:

  • legen Sie eine neue Funktion an
  • wählen Sie Variablen -> Treiberkommandos
  • der Dialog zur Konfiguration wird geöffnet

Parameter

Beschreibung

Treiber

Dropdownliste mit allen im Projekt geladenen Treibern.

Aktueller Zustand

Fixer Eintrag, in aktuellen Versionen ohne Funktion.

Treiberkommando

Dropdownliste zur Auswahl des Kommandos.
  • Treiber starten (Online-Modus)

Treiber wird neu initialisiert und gestartet.
  • Treiber stoppen (Offline-Modus)

Treiber wird angehalten, es werden keine neuen Daten angenommen.

Hinweis: Ist der Treiber im Offline-Modus, erhalten alle Variablen, die für diesem Treiber angelegt wurden, den Status Abgeschaltet (OFF; Bit 20).

  • Treiber in Simulationsmodus

Treiber wird in den Simulationsmodus gesetzt.
Die Werte aller Variablen des Treibers werden vom Treiber simuliert. Es werden keine Werte von der angeschlossenen Hardware (z. B. SPS, Bussystem, ...) angezeigt.
  • Treiber in Hardwaremodus

Treiber wird in den Hardwaremodus gesetzt.
Für die Variablen des Treibers werden die Werte von der angeschlossenen Hardware (z. B. SPS, Bussystem, ...) angezeigt.
  • Treiberspezifisches Kommando

Eingabe treiberspezifischer Kommandos. Öffnet Eingabefeld für die Eingabe eines Kommandos.
  • Treiber Sollwertsetzen aktivieren

Sollwert setzen auf Treiber ist erlaubt.
  • Treiber Sollwertsetzen deaktivieren

Sollwert setzen auf Treiber wird verhindert.
  • Verbindung mit Modem aufbauen

Verbindung aufbauen (für Modem-Treiber). Öffnet Eingabefelder für Hardware-Adresse und Eingabe der zu wählenden Nummer.
  • Verbindung mit Modem trennen

Verbindung beenden (für Modem-Treiber).

Diesen Dialog zur Runtime anbieten

Dialog wird zur Runtime für Änderungen angeboten.

Treiberkommandos im Netzwerk

Wenn sich der Rechner, auf dem die Funktion Treiberkommandos ausgeführt wird, im zenon Netzwerk befindet, werden zusätzliche Aktionen ausgeführt. Ein spezielles Netzwerkkommando wird vom Rechner zum Server des Projekts gesendet, der dann die gewünschte Aktion auf seinem Treiber durchführt. Zusätzlich sendet der Server das gleiche Treiberkommando zum Standby des Projekts. Der Standby führt die Aktion auch auf seinem Treiber aus.

Dadurch ist gewährleistet, dass Server und Standby synchronisiert sind. Dies funktioniert nur, wenn Server und Standby jeweils eine funktionierende und unabhängige Verbindung zur Hardware haben.


Fehleranalyse

EibV2_32 -> Fehleranalyse

Sollte es zu Kommunikationsproblemen kommen, bietet dieses Kapitel Hilfen, um den Fehler zu finden.

Noch in diesem Kapitel

Mögliche Fehlerquellen

Analysetool

Checkliste


Mögliche Fehlerquellen

EibV2_32 -> Fehleranalyse -> Mögliche Fehlerquellen

Kabel abgesteckt

Schnittstellenprogramm Falcon nicht installiert

info Info

Mit dem Schnittstellenprogramm Falcon wird ein Testprogramm namens PeiTestWizard mit installiert, mit dessen Hilfe die Verbindung zur EIB-Hardware getestet werden kann.


Analysetool

EibV2_32 -> Fehleranalyse -> Analysetool

Alle zenon Module wie z. B. Editor, Runtime, Treiber, usw. schreiben Meldungen in eine gemeinsame Log-Datei. Um sie korrekt und übersichtlich anzuzeigen, benutzen Sie das Programm Diagnose Viewer, das mit zenon mitinstalliert wird. Sie finden es unter Start/Alle Programme/zenon/Tools 7.11 -> Diagviewer.

zenon Treiber protokollieren alle Fehler in Log-Dateien. Der Standardordner für die Log-Dateien ist der Ordner LOG unterhalb des Ordners ProgramData, zum Beispiel: C:\ProgramData\zenon\zenon7.11\LOG für die zenon Version 7.11. Log-Dateien sind Textdateien mit einer speziellen Struktur.

Achtung: Mit den Standardeinstellungen zeichnet ein Treiber nur Fehlerinformationen auf. Mit dem Diagnose Viewer kann bei den meisten Treibern die Diagnose-Ebene auf „Debug" und „Deep Debug" erweitert werden. Damit protokolliert der Treiber auch alle anderen wesentlichen Aufgaben und Ereignisse.

Im Diagnose Viewer kann man auch:

  • eben erstellte Einträge live mitverfolgen
  • die Aufzeichnungseinstellungen anpassen
  • den Ordner, in dem die Log-Dateien gespeichert werden, ändern

Hinweise:

  1. Unter Windows CE werden aus Ressourcegründen auch Fehler standardmäßig nicht protokolliert.
  2. Der Diagnose Viewer zeigt alle Einträge in UTC (Koordinierter Weltzeit) an und nicht in der lokalen Zeit.
  3. Der Diagnose Viewer zeigt in seiner Standardeinstellung nicht alle Spalten einer Log-Datei an. Um mehr Spalten anzuzeigen, aktivieren Sie die Eigenschaft Add all columns with entry im Kontextmenü der Spaltentitel.
  4. Bei Verwendung von reinem Error-Logging befindet sich eine Problembeschreibung in der Spalte Error text. In anderen Diagnose-Ebenen befindet sich diese Beschreibung in der Spalte General text.
  5. Viele Treiber zeichnen bei Kommunikationsprobleme auch Fehlernummern auf, die die SPS ihnen zuweist. Diese werden in Error text und/oder Error code und/oder Driver error parameter(1 und 2) angezeigt. Hinweise zur Bedeutung der Fehlercodes erhalten Sie in der Treiberdokumentation und der Protokoll/SPS-Beschreibung.
  6. Stellen Sie am Ende Ihrer Tests den Diagnose-Level von Debug oder Deep Debug wieder zurück. Bei Debug und Deep Debug fallen beim Protokollieren sehr viele Daten an, die auf der Festplatte gespeichert werden und die Leistung Ihres Systems beeinflussen können. Diese werden auch nach dem Schließen des Diagnose Viewers weiter aufgezeichnet.

info Info

Weitere Informationen zum Diagnose Viewer finden Sie im Kapitel Diagnose Viewer.


Checkliste

EibV2_32 -> Fehleranalyse -> Checkliste

Ist das Gerät (die SPS), mit dem versucht wird eine Kommunikation herzustellen, an das Stromversorgungsnetz angeschlossen?

Ist das Verbindungskabel zwischen Steuerung (SPS) und PC bzw. IPC korrekt angeschlossen?

Wurde die „Error – Textdatei" analysiert (Welche Fehler sind aufgetreten)?

Das zenon Projekt wird an support@copadata.com geschickt