Internationalisierung

Internationalisierung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im täglichen Geschäftsleben ist globales Handeln und Denken ein wichtiger Faktor.

Leistungsstark, ergonomisch, international ... nur drei Schlagwörter, welche die zenon Philosophie repräsentieren und dieser Herausforderung Rechnung tragen.

Dieses Tutorial zeigt Ihnen am Beispiel konkreter Problemstellungen, wie Sie mit geringem Aufwand Ihre Projekte in Ihrer vertrauten Umgebung auch für internationale Geschäftsfelder adaptieren können. Sei es die Anpassung von Sprachen oder Maßeinheiten bis hin zum optischen Erscheinungsbild. Bereichert wird dieses Tutorial mit Praxistipps und Hinweisen auf mögliche Fehlerquellen.

Anwendungsbeispiele:

  • Auslieferung eines Projektes in unterschiedlichen Sprachen
  • verschiedensprachige Bedienung einer Anlage
  • Anpassung von Maßeinheiten an die lokale Umgebung
  • unterschiedliche Darstellungsmöglichkeiten der Bedienoberfläche
  • Anpassung an besondere Gegebenheiten
  • Barrierefreiheit

Noch in diesem Kapitel

Voraussetzungen

Projekteinstellungen

Projektierung der Sprachumschaltung

Sprachumschaltbare Grafiken

Einheiten umrechnen

Wizard auf bestehende Projekte anwenden

Übersetzungshilfe Project Translation Interface

Message Control (lizenzpflichtig)

Anwendungsmöglichkeiten der Sprachumschaltung

Zusammenfassung


Voraussetzungen

Internationalisierung -> Voraussetzungen

Dieses Tutorial setzt geringes zenon-Basiswissen voraus. Für Neueinsteiger und unerfahrene Anwender ist es daher ratsam, zuerst das Basis-Tutorial durchzuarbeiten. Wichtige Projekteinstellungen dieses Tutorials werden Schritt für Schritt vorgegeben, jedoch nicht näher und detaillierter beschrieben.

Noch in diesem Kapitel

Vorbereitungen für dieses Tutorial

Bedienung der Runtime


Vorbereitungen für dieses Tutorial

Internationalisierung -> Voraussetzungen -> Vorbereitungen für dieses Tutorial

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie bereits über Basiswissen zum zenon Editor verfügen, können Sie dieses Kapitel überspringen.

Es wird ein neutrales Projekt angelegt und ein leeres Bild angelegt.

Parameter | Beschreibung
Arbeitsbereichname | Tutorials_Workspace
Projektname | INTERNATIONAL
Projektart | Standardprojekt
Bildname | Main
Variablenname 1 | Füllstand
Variablenname 2 | Temperatur
Variablentreiber | Intern - Treiber für interne Variablen
Variablentyp | INT

Noch in diesem Kapitel

Erstellen eines neuen Arbeitsbereiches

Erstellen eines neuen Projekts

Bild erstellen

Erstellung zweier Variablen


Erstellen eines neuen Arbeitsbereiches

Internationalisierung -> Voraussetzungen -> Vorbereitungen für dieses Tutorial -> Erstellen eines neuen Arbeitsbereiches

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Schritt werden Sie die Vorbereitungen für die Projektierung der einzelnen Tutorialschritte durchführen. Sie werden

  • einen neutralen Arbeitsbereich erstellen
  • ein Projekt erstellen
  • Treiber einbinden
  • Variablen erstellen

Erstellen Sie zu Beginn eine neutrale Umgebung indem Sie einen neuen Arbeitsbereich mit einem neuen Projekt anlegen.

Zum Anlegen eines neuen Arbeitsbereiches gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Datei den Befehl Arbeitsbereich/Neu
  2. Bennen Sie den Arbeitsbereich mit Workspace_International


Erstellen eines neuen Projekts

Internationalisierung -> Voraussetzungen -> Vorbereitungen für dieses Tutorial -> Erstellen eines neuen Projekts

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Ein neues Projekt erstellen Sie mit folgenden Schritten:

  1. Wählen Sie im Menü Datei den Befehl Projekt neu... aus
  2. Wählen Sie den Projekttyp Standardprojekt
  3. Benennen Sie Ihr Projekt mit INTERNATIONAL
  4. Das Projekt wird nun automatisch erzeugt und es öffnet sich der zenon Project Wizard
  5. Beenden Sie den Wizard mit der Schaltfläche Close
  6. Bestätigen Sie den Folgedialog Form Closing durch Klick auf die Schaltfläche Nein

info Info

Es steht nun eine neutrale Umgebung für die weiteren Tutorial-Schritte zur Verfügung.


Bild erstellen

Internationalisierung -> Voraussetzungen -> Vorbereitungen für dieses Tutorial -> Bild erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

  • Öffnen Sie im Projektmanager den Knoten Bilder.
  • Wählen Sie Bild neu
  • Gehen Sie in das Eigenschaftenfenster und wählen Sie den Eintrag Allgemein.
  • Geben Sie dem Bild den Namen Main.

info Info

Das Tutorial-Projekt verfügt jetzt über eine (noch leere) Bildschirmoberfläche


Erstellung zweier Variablen

Internationalisierung -> Voraussetzungen -> Vorbereitungen für dieses Tutorial -> Erstellung zweier Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Tutorial wird auf zwei Größen Bezug genommen. Temperatur und Füllmenge werden auf die jeweiligen Einheiten eines Landes angepasst.

Dafür werden zwei Variablen benötigt. Zum erstellen von zwei Variablen:

  1. Öffnen Sie im Projektmanager den Knoten Variable.
  2. Erstellen Sie in der Detailansicht mit dem Befehl Variable neu... eine Variable
  3. Wählen Sie im Dialogfenster Variable erstellen die Einträge
    • Intern - Treiber für interne Variablen als Treiber
    • Interne Variable als Treiber-Objekttyp
    • INT als D atentyp der Variable
    • Füllmenge als Name
  4. Bestätigen Sie die Eingabe mit der Schaltfläche Fertigstellen
  5. Erstellen Sie eine zweite Variable mit dem Namen Temperatur (restliche Optionen wie oben)


Bedienung der Runtime

Internationalisierung -> Voraussetzungen -> Bedienung der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Tutorial werden Sie öfters aufgefordert, die Runtime zu starten. Vergessen Sie dabei nicht, im COPA-DATA Editor die entsprechenden Runtime-Dateien zu erzeugen.

Um Runtime-Dateien zu erzeugen verwenden Sie

  • Tastaturkürzel
  • Symbolleiste

Verwendung der Tastaturkürzel:

Parameter | Beschreibung
F7 | Geänderte Runtime Dateien erzeugen.
F5 | Startet die Runtime
Alt+F4 | Beendet die Runtime
attention Achtung
Zwischen den einzelnen Tests sollten Sie die Runtime jeweils beenden. Drücken Sie dazu die Tastenkombination Alt+F4.

Verwendung der Symbolleiste

Verwenden Sie die Symbole

  • Geänderte Runtime-Dateien erzeugen zum Speichern.
  • Runtime starten um die Projektierung in der Runtime zu überprüfen.

Sollten diese Symbolleiste in Ihrem Editor nicht angezeigt werden so aktivieren Sie diese:
Menüleiste Optionen => Symbolleisten => Runtime-Dateien


Projekteinstellungen

Internationalisierung -> Projekteinstellungen

Im zenon Editor und in der Runtime können Sie sich die zu übersetzenden Schlüsselwörter anzeigen lassen.

  1. Öffnen Sie die Projekteinstellungen durch Klick auf den Projektnamen International.
  2. Klicken Sie in den Eigenschaften auf den Menüeintrag Grafische Ausprägung,
  3. Runtime allgemein.
  4. Aktivieren Sie die Eigenschaft Nicht übersetzte Schlüsselwörter anzeigen.

info Info

Diese Auswahl legt fest, ob Schlüsselwörter in der Runtime übersetzt angezeigt werden oder in der "Quellsprache" mit einem vorangestellten @.

Noch in diesem Kapitel

Schlüsselwörter im Editor

Schlüsselwörter zur Runtime anzeigen

Nutzen der zenon internen Sprachfiles


Schlüsselwörter im Editor

Internationalisierung -> Projekteinstellungen -> Schlüsselwörter im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sehen Sie sich nun ein wenig im zenon Editor um. Wenn sie z. B. auf den Knoten Bilder klicken und sich die Detailansicht betrachten, so werden Sie nun (nach Aktivierung der Schlüsselwörteransicht) bei den Spaltenüberschriften ein vorangestelltes @-Zeichen entdecken.

Klicken Sie auf diverse Knotenpunkte im Projektmanager und betrachten Sie dabei die Überschriften der Detailansicht.

info Info

Sie wissen nun, wie Sie übersetzbare Texte erkennen und ein- und ausblenden können.

Hinweis:
Im Editor werden Schlüsselwörter mit bereits vorliegenden Übersetzungen ohne @ angezeigt


Schlüsselwörter zur Runtime anzeigen

Internationalisierung -> Projekteinstellungen -> Schlüsselwörter zur Runtime anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sehen Sie sich nun Ihr bisher erstelltes Projekt in der Runtime an.

  • Ist einem Schlüsselwort eine Übersetzung zugeordnet, dann werden in der Runtime die übersetzten Texte angezeigt.
  • Ist einem Schlüsselwort keine Übersetzung zugeordnet, wird in der Runtime kein Text angezeigt.
  • Noch nicht übersetzte Texte können als Schlüsselwort angezeigt werden.

Hinweis: Beachten Sie, dass dieses @-Zeichen nur beim ersten Start der Runtime angezeigt wird. Nach der ersten Sprachumschaltung bzw. einem Reload der Runtime wird diese Zeichen ausgeblendet.


Nutzen der zenon internen Sprachfiles

Internationalisierung -> Projekteinstellungen -> Nutzen der zenon internen Sprachfiles

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie werden nun lernen, wie Sie zenon interne Schlüsselwörter nutzen können:

Anwendungsbeispiele:

  • Bei der Suche nach fehlenden bzw. fehlerhaften Übersetzungen
  • Nutzung von zenon-Ressourcen für Ihre Projektierung
  • Nutzung vorhandener (und auch bereits übersetzter) Dialoge für Ihr Projekt
  • Visualisierung von Variablennamen in der zenon Runtime

Die in zenon verwendeten Begriffe sind nicht standardmäßig in der Sprachdatei integriert. Sie können unter support@copadata.com eine Sprachdatei anfordern. Die Ressourcen liegen derzeit in folgenden Sprachen vor:

  • Chinesisch (vereinfacht)
  • Englisch
  • Französisch
  • Italienisch
  • Russisch
  • Spanisch
  • Tschechisch

info Info

In der Praxis werden Sie die Eigenschaft Nicht übersetzte Schlüsselwörter anzeigen sehr selten aktiviert lassen. Dies ist auch der Grund, warum bei Neuanlage eines Projektes diese Eigenschaft immer auf deaktiviert gesetzt ist.


Projektierung der Sprachumschaltung

Internationalisierung -> Projektierung der Sprachumschaltung

Die folgenden Schritte zeigen Ihnen, wie einfach Sie in zenon sprachumschaltbare Texte erstellen:

  • Das Wort Füllstand soll sprachumschaltbar sein.
  • Das Umschalten zwischen Deutsch und Portugiesisch soll möglich sein.

Noch in diesem Kapitel

Übersetzungstabellen mit Sprachdatei & Schlüsselwort

Funktion Sprachumschaltung

Weitere Sprachen hinzufügen

Simulation der Sprachumschaltung im Editor

Verwendung des @-Zeichens

Schriftlisten und Textlänge


Übersetzungstabellen mit Sprachdatei & Schlüsselwort

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Durch die folgenden Schritte werden Sie erlernen, wie Sie Sprachen und zu übersetzende Wörter projektieren. Dazu sind folgende Schritte notwendig:

  1. Sprachdatei erstellen
  2. Schlüsselwörter verwalten
  3. Funktion erstellen
  4. Funktion anwenden

Noch in diesem Kapitel

Sprachdatei erstellen

Schlüsselwörter verwalten


Sprachdatei erstellen

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort -> Sprachdatei erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Erstellen Sie eine Sprachtabelle, um als sprachumschaltbar gekennzeichnete Texte mit der Übersetzung befüllen zu können.

  1. öffnen Sie im Projektmanager den Knoten Sprachdatei
  2. wählen Sie Sprachdatei neu...
  3. geben Sie den Namen der neuen Sprachdatei ein
    (in diesem Beispiel PORTUGUESE.TXT)
    Hinweis: Die Benennung der Sprachdateien erfolgt automatisch in Großbuchstaben
  4. bestätigen Sie mit Klick auf die Schaltfläche Speichern

Noch in diesem Kapitel

Praxistipps für die Sprachdateien

Die Bedeutung der Sprachdatei ZENONSTR.TXT

Wissenswertes zur Sprachdatei


Praxistipps für die Sprachdateien

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort -> Sprachdatei erstellen -> Praxistipps für die Sprachdateien

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Achten Sie bereits bei der Benennung der Sprachtabellen auf einfache und internationale Standards. Beachten Sie dabei, dass auch Projektpartner (z B. Übersetzer, Administratoren vor Ort) damit arbeiten werden, welche Ihre Sprache nicht beherrschen. Überlegen Sie sich von Beginn an einen Standard, den Sie dann auch bei späteren Erweiterungen anwenden.

Example Beispiele
  • Benennen Sie Ihre Sprachtabelle mit German anstelle Deutschland und/oder Deutsch

oder ...

  • verwenden Sie international gültige Bezeichnungen wie D, USA, GB, JP ...

info Info

Klare und internationale Benennungen der Sprachdateien erleichtern die Zusammenarbeit und steigern die Effizienz.

Mehrere Sprachdateien in unterschiedlichen Projekten

Wenn Sie mehrere Sprachdateien verwenden - z. B. Globalprojekte oder Projekte mit integrierten Projekten - achten Sie auf unterschiedliche Benennungen.

Anderenfalls können Sie bei Nutzung der Export- und Importfunktion für die Übersetzung einer Sprachdatei nur schwer erkennen, welche Sprachdatei in welches Projekt zu importieren ist.

Example Beispiel

TUTORIAL-PORTUGUESE anstelle von Portuguese

Info

Genaue Bezeichnungen erleichtern die Zuordnung bei Globalen Projekten

Vermeidung von sprachabhängigen Zeichen

Vermeiden Sie bei der Benennung von Sprachtabellen sprachabhängige Sonderzeichen, um so die Zusammenarbeit mit internationalen Partnern zu optimieren.

Beispiele für sprachabhängige Sonderzeichen:

öäüß im deutschsprachigen Raum

øåæ im skandinavischen Raum

Die Inhalte der Sprachtabellen - also die Übersetzungen - dürfen selbstverständlich sprachabhängige Sonderzeichen enthalten!

Info

Bei Projekten mit länder- und sprachübergreifender Zusammenarbeit können sprachabhängige Zeichen bei der Sprachtabellenbenennung sowie bei Einträgen in den Schlüsselwörtern zu Missverständnissen zwischen den Projektpartnern führen!


Die Bedeutung der Sprachdatei ZENONSTR.TXT

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort -> Sprachdatei erstellen -> Die Bedeutung der Sprachdatei ZENONSTR.TXT

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In zenon werden bei der Projektierung der Sprachumschaltung die Einträge der Spalte Schlüsselwörter herangezogen. Die Sprachdatei ZENONSTR.TXT bezieht sich jeweils auf die zenon Setup-Sprache, die auf dem ausführenden Computer definiert ist.

Eigene Sprachdatei für Muttersprache

Unter gewissen Voraussetzungen kann es bei der Projektierung sinnvol sein, auch für seine "Muttersprache" eine eigene Sprachtabelle anzulegen. Speziell, wenn Sie mit ausländischen Kollegen gemeinsam an einem Projekt arbeiten (Stichwort: Global- und Netzwerkprojekt). In diesem Falle ZENONSTR.TXT ist standortabhängig.


Wissenswertes zur Sprachdatei

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort -> Sprachdatei erstellen -> Wissenswertes zur Sprachdatei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Eine Sprachdatei kann jederzeit eingefügt werden. Auch eine nachträgliche Einfügung ist problemlos möglich. So können Sie Ihre bestehenden Projekte bei Ausweitung Ihrer Geschäftstätigkeit auf eine neue Sprachregion adaptieren!
  • Die Sortierung der Schlüsselwörter erfolgt bei jedem Aufruf des Knotens Sprachdatei automatisch.
  • Ein Klick auf die Überschrift sortiert die Liste jeweils neu.


Schlüsselwörter verwalten

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort -> Schlüsselwörter verwalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Je umfangreicher Ihr Projekt wird, desto mehr Wörter werden Sie mehrsprachig darstellen. Die Wartung erfolgt mit Schlüsselwörtern.

  1. Öffnen Sie im Projektmanager den Knoten Sprachdatei
  2. Platzieren Sie den Cursor in der letzen Zeile der Spalte Schlüsselwort
  3. Tragen Sie das zu übersetzende Schlüsselwort Füllstand ein
  4. Bestätigen Sie die Eingabe mit der Eingabetaste (die Zellen der restlichen Sprachdateien werden mit diesem Eintrag vorausgefüllt)
  5. Tragen Sie die Übersetzung in der jeweiligen Spalte Ihrer Sprachdatei ein.
    (in unserem Beispiel nível in die Spalte TUTORIAL-PORTUGUESE.TXT)
  6. Tragen Sie das Wort Temperatur mit der entsprechenden Übersetzung temperatura ein

Noch in diesem Kapitel

Fremdpsrachige Sonderzeichen einbauen

Praxistipps für die Schlüsselwörter


Fremdpsrachige Sonderzeichen einbauen

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort -> Schlüsselwörter verwalten -> Fremdpsrachige Sonderzeichen einbauen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Vielleicht ist es Ihnen bei unserem Beispiel aufgefallen: Die portugiesische Übersetzung für das Wort Füllstand ist nível.

Sehen Sie sich den I-Punkt genauer an: Das Portugiesische Alphabet verwendet sogenannte Diakritika. Über dem Kleinbuchstaben í steht in der portugiesischen Sprache kein Punkt sondern vielmehr ein Akzent.

Was also tun, wenn sie in portugiesischer Sprache projektieren müssen und keine entsprechende Tastatur zur Verfügung haben?

Die Lösung ist denkbar einfach:

  1. Öffnen Sie im Projektmanager den Knoten Sprachdatei.
  2. Wählen Sie in der Symbolleiste der Sprachumschaltung das Symbol Zeichentabelle...

  3. Die Windows Zeichentabelle wird nun geöffnet.
  4. Wählen Sie das gesuchte Zeichen
  5. Die Schaltfläche Kopieren kopiert den ausgewählten Buchstaben in die Zwischenablage.
  6. Wechseln Sie zurück in den Editor. Fügen sie den Buchstaben mit Strg+V an der gewünschten Stelle ein.

info Info

Sollte der gewünschte Buchstabe nicht sichtbar sein, dann wechseln sie den Zeichensatz.

§§ Trenner

Example Beispiel

Buchstaben der russischen Sprache finden sich im Zeichensatz Windows: Kyrillisch


Praxistipps für die Schlüsselwörter

Internationalisierung -> Projektierung der Sprachumschaltung -> Übersetzungstabellen mit Sprachdatei & Schlüsselwort -> Schlüsselwörter verwalten -> Praxistipps für die Schlüsselwörter

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Diese Tipps sollen Ihnen helfen, in zenon sprachumschaltbare Texte effizient zu projektieren und Fehler bereits im Vorfeld zu minimieren:

Korrekter Abschluss der Eingabe eines Schlüsselwortes

Schließen Sie die Eingaben jedes einzelnen Schlüsselwortes immer mit der Eingabetaste ab.

Hintergrund:
In vielen Computerprogrammen ist es üblich mit der Tabulatortaste in das nächste Eingabefeld zu springen. Diese Funktionalität wird in der Sprachdatei nicht unterstützt! Vielmehr birgt diese Herangehensweise ein sehr großes Fehlerpotential, da die Tabulatortaste nicht in das nächste Feld springt sondern tatsächlich den Tabulator als (unsichtbaren) Inhalt setzt!

Anpassung an länderspezifische Sprachunterschiede

Sie können die Funktion der Sprachumschaltung auch für nationale Begriffe aus einer Sprachfamilie verwenden. Die Unterschiede zwischen Britischem und Amerikanischem Englisch sind hier als Beispiel aufgelistet.

Exemplarische Gegenüberstellung Britisches und Amerikanisches Englisch
GB | USA
colour | color
modelling | modeling
licence | license

Projektiertes Schlüsselwort = Eintrag in der Sprachtabelle

Gewöhnen Sie sich an, projektierte Schlüsselwörter umgehend in der Sprachtabelle anzulegen.

Liegt die Übersetzung noch nicht vor, kann z.B. eine internationale Sprache aus dem Geschäftsumfeld Ihres Unternehmens (z.B. Englisch, Französisch, Spanisch, Russisch ...) als Vorübersetzung eingesetzt werden.

Auch Mischformen sind möglich. Bedenken Sie dabei jedoch den zusätzlichen Verwaltungsaufwand und das erhöhte Fehlerrisiko.

"Fremdsprachige" Schlüsselwörter

Bei Projekten, bei denen Kollegen mit unterschiedlicher Sprachherkunft zusammenarbeiten, wird empfohlen die Schlüsselwörter in einer einheitlichen Sprache anzulegen.


Funktion Sprachumschaltung

Internationalisierung -> Projektierung der Sprachumschaltung -> Funktion Sprachumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Nutzung der erstellten Sprachdateien und Schlüsselwörter erfolgt mit Hilfe einer zenon Funktion. Folgende zwei Schritte sind dazu auszuführen:

  1. Funktion erstellen
  2. Funktion anwenden

Noch in diesem Kapitel

Funktion Sprachumschaltung erstellen

Funktion anwenden


Funktion Sprachumschaltung erstellen

Internationalisierung -> Projektierung der Sprachumschaltung -> Funktion Sprachumschaltung -> Funktion Sprachumschaltung erstellen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Pro Sprache ist einmalig eine Funktion anzulegen:

  1. Öffnen Sie im Projektmanager den Knoten Funktionen.
  2. Wählen Sie Funktion neu...
    Die Auswahlbox der Funtkionen öffnet sich
  3. Wählen Sie die Anwendungsfunktion Sprachumschaltung

  4. In dem sich öffnenden Dialog wählen Sie die Sprachdatei durch Klick auf die Schaltfläche ...
  5. Wählen Sie in dem sich öffnenden Dialog TUTORIAL-PORTUGUESE.TXT
  6. Bestätigen Sie Ihre Eingabe mit OK
  7. Benennen Sie diese Funktion mit Language_portuguese im Eigenschaftenfenster.
    Gehen Sie dazu im Eigenschaftenfenster auf den Knoten Allgemein.
  8. Wiederholen Sie den oberen Schritt für Ihre Systemsprache.
    Benennen Sie diese Sprachumschaltungsfunktion mit Language_native. Wählen Sie ZENONSTR.TXT als Sprachdatei.

Hinweis: Die zu verknüpfende Datei ZENONSTR.TXT enthält immer die Sprache, auf die Ihr System eingestellt ist. Wenn sie mit zenon auf einem deutsprachigen Betriebssystem arbeiten, so verknüpfen Sie in unserem Beispiel Punkt 8 der obigen Anleitung mit ZENONSTR.TXT.

Der Vorteil:

Diese Funktion muss pro Sprache nur einmal erstellt werden!

Wann immer Sie die Sprachumschaltung nutzen wollen, verknüpfen Sie die bestehende Funktion mit dem jeweiligen Element (z B. Button, Bildelement, ...). Sie müssen nur sicherstellen, dass das Schlüsselwort bei der Projektierung ein @-Zeichen vorangestellt hat und dieses Schlüsselwort auch in der Sprachdatei hinterlegt ist.

info Info

Sie wissen nun, wie Sie eine Funktion für die Sprachumschaltung in Ihrem Projekt anlegen können.


Funktion anwenden

Internationalisierung -> Projektierung der Sprachumschaltung -> Funktion Sprachumschaltung -> Funktion anwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  1. Führen Sie nun die vorausgegangenen Schritte zusammen, um Ihre Übersetzungen in der Runtime sicht- und anwendbar zu machen.

Um die Sprachumschaltung zu aktivieren, legen Sie diese auf zwei Buttons Native und Portuguese.

  1. Öffnen Sie das Bild Main.
  2. Wählen Sie aus der Menüzeile Elemente => Button
  3. Zeichnen Sie im Bild Main einen Button
  4. Wählen Sie die Funktion Language_Portuguese
  5. Im Eigenschaftenfenster fügen Sie in der Eigenschaftengruppe Darstellung im Eingabefeld Text Zeile 1: Portuguese ein.
  6. Wiederholen Sie die Schritte 1 bis 4 und verwenden Sie dabei die Funktion für Sprachumschaltung auf Ihre Systemsprache (zenonstr.txt).
    In einem früheren Schritt wurde diese Funktion bereits erstellt und mit Language_native benannt.

Noch in diesem Kapitel

Textfelder einfügen

Erster Test in der Runtime

Sprache als Text anzeigen

Praxistipps für die Funktion Sprachumschaltung


Textfelder einfügen

Internationalisierung -> Projektierung der Sprachumschaltung -> Funktion Sprachumschaltung -> Funktion anwenden -> Textfelder einfügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nachdem Sie nun die notwendigen Vorarbeiten kennen, wenden sie die Sprachtabelle in einem Bild mit zwei Texten an:

  1. Öffnen Sie im Projektmanager den Knoten Bilder
  2. Wählen Sie das Bild Main
  3. Öffnen Sie das Bild mit einem Doppelklick auf den Namen Main
  4. Wählen Sie aus der Menüzeile Elemente => Statischer Text
  5. Zeichnen Sie im Bild Main das Textfeld

  6. Geben Sie im Eigenschaftenfenster im Eigenschaftenfeld Text @Füllstand ein
  7. Wiederholen Sie die Schritte 4 bis 6 mit dem Wort Temperatur
    (im Eigenschaftenfenster ist @Temperatur einzugeben)

info Info

Das Zeichen @ dient als Indikator für sprachumschaltbare Texte!


Erster Test in der Runtime

Internationalisierung -> Projektierung der Sprachumschaltung -> Funktion Sprachumschaltung -> Funktion anwenden -> Erster Test in der Runtime

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können nun die projektierte Sprachumschaltung in der Runtime testen:

  • Die aktuellen Runtime Dateien erstellen Sie mit der Taste F7.
  • Die Runtime starten Sie mit der Taste F5.

Je nach Positionierung Ihrer Textfelder und Buttons sollte die Runtimeansicht so ähnlich aussehen. Durch Klick auf die Sprachbuttons sollten die Texte zwischen den beiden Sprachen wechseln.

info Info

Die Runtime kann mit der Tastenkombination ALT + F4 beendet werden.


Sprache als Text anzeigen

Internationalisierung -> Projektierung der Sprachumschaltung -> Funktion Sprachumschaltung -> Funktion anwenden -> Sprache als Text anzeigen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Dieses Beispiel zeigt, wie Sie in mehrsprachigen Projekten die jeweilige Projektsprache als Text anzeigen können.

Dazu sind folgende Schritte - zusätzlich zu der bisherigen Projektierung - notwendig:

  1. übersetzen Sie ein Schlüsselwort
  2. machen Sie dieses Schlüsselwort mit einem vorangestellten @-Zeichen sprachumschaltbar
  3. platzieren Sie ein Textfeld in Ihrem Bild

Dies wird folgendermassen projektiert:

  1. öffnen Sie im Projektmanager den Knoten Sprachdatei
  2. geben Sie ein neues Schlüsselwort ein: Sprache
  3. Tragen Sie in der jeweiligen Sprache anstelle der wortwörtlichen Übersetzung die Begriffe native (in der Spalte ZENONSTR.TXT), sowie portuguese (in der dazugehörigen Spalte) ein
  4. Wechseln Sie im Projektmanager in den Knoten Bilder.
  5. Platzieren Sie ein Element Statischer Text und tragen Sie in den Darstellungseigenschaften im Eingabefeld Textfeld @Sprache ein
  6. Starten Sie die Runtime (F5)

Hinweis: Das Schlüsselwort wird dabei nicht in seiner ursprünglichen Bedeutung übersetzt, sondern dient vielmehr als Platzhalter. Die Übersetzung repräsentiert in diesem Beispiel die Sprache der Übersetzung.

info Info

Sie wissen nun, wie sie die gewählte Sprache als Text anzeigen können.


Praxistipps für die Funktion Sprachumschaltung

Internationalisierung -> Projektierung der Sprachumschaltung -> Funktion Sprachumschaltung -> Funktion anwenden -> Praxistipps für die Funktion Sprachumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Erstellen Sie immer eine neue Sprachtabelle wenn Sie eine Funktion Sprachumschaltung anlegen und umgekehrt.
  • Bennen Sie Ihre Funktion eindeutig.
  • Stellen Sie bei der Benennung allen Sprachumschaltungsoptionen ein Präfix voran (z. B. Language_ ..., Switch_to_ ...).
  • Um die Übersichtlichkeit in der Detailansicht Funktionen zu optimieren, benutzen Sie Filtertexte und Sortierung.


Weitere Sprachen hinzufügen

Internationalisierung -> Projektierung der Sprachumschaltung -> Weitere Sprachen hinzufügen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im nun folgenden Schritt fügen Sie dem bestehenden Projekt als weitere Sprache Polnisch hinzugefügt.

Folgende Schritte sind dazu notwendig:

  • Sprachdatei anlegen
  • Schlüsselwörter eingeben
  • Funktion erstellen

  1. Legen Sie eine neue Sprachdatei an:
    1. Öffnen Sie im Projektmanager den Knoten Sprachdatei.
    2. Erstellen Sie eine neue Sprachdatei und benennen Sie diese mit TUTORIAL-POLISH
    3. Ergänzen Sie diese neue Sprachdatei mit den jeweiligen Übersetzungen (Füllstand: poziom, Temperatur: temperatura)
  2. Erstellen Sie eine neue Funktion:
    1. Öffnen Sie im Projektmanager den Knoten Funktionen
    2. Erstellen Sie mit Funktion neu eine neue Funktion
    3. Wählen Sie im Funktionsauswahlfenster im Knoten Anwendung den Eintrag Sprachumschaltung
    4. Wählen Sie die Zuordnung durch Klick auf die Schaltfläche ... und Auswahl von TUTORIAL-POLISH.txt
    5. Benennen Sie diese Funktion mit Language_polish
  3. Funktion verknüpfen
    1. Öffnen Sie das Bild Main mit einem Doppelklick auf den Namen
    2. Wählen Sie aus der Menüzeile Elemente => Button
    3. Zeichnen Sie einen Button
    4. Wählen Sie die Funktion Language_polish
    5. Im Eigenschaftenfenster fügen Sie in den Darstellungseigenschaften im Eingabefeld Text Zeile 1: Polish ein
    6. Testen sie die neuprojektierte Sprachumschaltung für Polnisch in der Runtime (F5).

info Info

Die Runtime kann mit der Tastenkombination ALT + F4 beendet werden.


Simulation der Sprachumschaltung im Editor

Internationalisierung -> Projektierung der Sprachumschaltung -> Simulation der Sprachumschaltung im Editor

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie können bereits bei der Projektierung im Editor erste Auswirkungen der Sprachumschaltung simulieren. Dieser Schritt ist besonders hilfreich, um unterschiedliche Textlängen bereits bei der Projektierung im Editor sichtbar zu machen. Die Dialogsprache des Editors bleibt dadurch unverändert.

Dazu:

  1. Öffnen Sie im Projektmanager den Knoten Sprachdatei
  2. Wählen Sie im Kontextmenü oder der Symbolleiste Sprachdatei für Editor und wählen Sie die entsprechende Sprache aus.
    Die Benennung erfolgt analog zu den Namen der Sprachtabellen.
    Der unterste Eintrag der Dropdownliste aktiv schaltet die Funktionalität ein (bei aktiver Checkbox) oder aus (Einträge sind grau).

info Info

Durch die Auswahl Sprachdatei für Editor können Sie direkt im Editor Ihre Projektierung mit der gewählten Sprache anzeigen lassen. Die gewählte Sprachdatei wird durch eine grüne Überschrift gekennzeichnet.

Ansicht im Editor bei gewählter Sprachtabelle


Verwendung des @-Zeichens

Internationalisierung -> Projektierung der Sprachumschaltung -> Verwendung des @-Zeichens

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Das @-Zeichen dient als Indikator, dass der nachfolgende Text sprachumschaltbar sein soll.
Nach Anlage der entsprechenden Übersetzung in der Sprachtabelle (siehe Schlüsselwörter verwalten) stehen diese Übersetzungen zur Verfügung.

In der Praxis wird es auch zu Mehrfachverwendungen eines Schlüsselwortes kommen. In diesem Fall nehmen Sie das verwendete Schlüsselwort nur einmal in der Sprachtabelle auf.

Noch in diesem Kapitel

Regeln bei Verwendung des @-Zeichens

Beispiel mit zusammengesetzten Wörtern


Regeln bei Verwendung des @-Zeichens

Internationalisierung -> Projektierung der Sprachumschaltung -> Verwendung des @-Zeichens -> Regeln bei Verwendung des @-Zeichens

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Schlüsselwörter werden durch das Zeichen @ gekennzeichnet. Dabei gilt:

@Text

Der gesamte Text wird übersetzt

Text@

Der Text wird nicht übersetzt

@Text@

Der Text zwischen den @ wird übersetzt

Hier gilt: Nach einer ungeraden Anzahl von @ wird der Text übersetzt (man Beginnt am Anfang des Eintrags zu zählen).

Zum Beispiel: @user@Doe

  • user wird übersetzt
  • Doe nicht

Verketten

Ein Aneinanderketten von Textelementen, die übersetzt werden, und solchen, die nicht übersetzt werden, ist möglich:

Example Beispiel

@Der Benutzer@ Doe @wird ausgeloggt.

@Text1@ Text2 @Text3
  • Text 1: wird übersetzt
  • Text 2: wird nicht übersetzt
  • Text 3: wird übersetzt


Beispiel mit zusammengesetzten Wörtern

Internationalisierung -> Projektierung der Sprachumschaltung -> Verwendung des @-Zeichens -> Beispiel mit zusammengesetzten Wörtern

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bereits bestehende Schlüsselwörter können auch in Kombination genutzt werden.

Aufgabenstellung:

Folgende Begriffe sollen sprachumschaltbar sein und in Menüs dargestellt werden:

  • Licht ein
  • Klimaanlage ein

Die Übersetzung lautet:

  • lâmpada ligado
    (Licht ein)
  • ar condicionado ligado
    (Klimaanlage ein)
  • lâmpada desligado
    (Licht aus)
  • ar condicionado desligado
    (Klimaanlage aus)

Noch in diesem Kapitel

Der einfache Weg

Der elegante Weg

Menüs und Web Server

Menüs in der Runtime sichtbar machen


Der einfache Weg

Internationalisierung -> Projektierung der Sprachumschaltung -> Verwendung des @-Zeichens -> Beispiel mit zusammengesetzten Wörtern -> Der einfache Weg

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Der einfachste Weg in diesem Beispiel ist, den Text wie folgt in der Sprachtabelle einzugeben:

@Licht ein

@Klimaanlage ein

In der Sprachtabelle würden in unserem Beispiel einfach die Begriffe "Licht ein" und "Klimaanlage ein" unabhängig voneinander mit beiden Wörtern übersetzt.


Der elegante Weg

Internationalisierung -> Projektierung der Sprachumschaltung -> Verwendung des @-Zeichens -> Beispiel mit zusammengesetzten Wörtern -> Der elegante Weg

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Viel effizienter wird es jedoch, wenn wir bereits übersetzte (Einzel-)Wörter zusammensetzen. Je umfangreicher Ihr Projekt, desto grösser die Synergien!

  1. Fügen Sie die Schlüsselwörter zu Ihrer Sprachdatei ZENONSTR.TXT neu hinzu:
    1. Licht
    2. Klimaanlage
    3. ein
    4. aus
    5. Steuerung
  2. Fügen Sie die Übersetzungen in der Sprachdatei TUTORIAL-PORTUGUESE.TXT hinzu:
    1. lâmpada
    2. ar condicionado
    3. ligado
    4. desligado
    5. controle

Achtung:

Arbeiten Sie ruhig und konzentriert. Hier kommt es auf jeden Leerschritt und seine Platzierung an.
@Licht@ @ein ist nichtgleich @Licht@@ ein. Beachten Sie dazu die Regeln wie im Kapitel "Regeln bei Verwendung des @-Zeichens" beschrieben.


Menüs und Web Server

Internationalisierung -> Projektierung der Sprachumschaltung -> Verwendung des @-Zeichens -> Beispiel mit zusammengesetzten Wörtern -> Menüs und Web Server

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sprachabhängige Menüs erstellen Sie ebenso einfach wie Elemente. In diesem Beispiel werden nur Menüs zur Darstellung der Textumschaltung angelegt. Auf die Verknüpfung der Menüeinträge mit einer Variablen wird bewusst verzichtet.

  1. Öffnen Sie im Projektmanager den Knoten Menüs.
  2. Wählen Sie in der Symbolleiste der Detailansicht Hauptmenü neu
  3. Benennen Sie das soeben erzeugte Hauptmenü mit Main
    1. Klicken Sie dazu im Knotenpunkt der Menüeigenschaften auf den ersten Eintrag.
    2. Tragen Sie im Eigenschaftenfenster im Textfeld die Benennung Main ein.
      Sie finden dieses Textfeld im Knotenpunkt Darstellung / Typ.
  4. Klicken Sie in der Querverweisliste in das erste Kästchen (links oben) und erstellen Sie einen Eintrag @Steuerung
  5. Befüllen Sie die darunterliegende Kästchen mit den Einträgen
    @Licht@ @ein
    @Licht@ @aus
    @Klimaanlage@ @ein
    @Klimaanlage@ @aus

Hinweis:
Im Web Server steht die Sprachumschaltung in der Menüfunktion nicht zur Verfügung!


Menüs in der Runtime sichtbar machen

Internationalisierung -> Projektierung der Sprachumschaltung -> Verwendung des @-Zeichens -> Beispiel mit zusammengesetzten Wörtern -> Menüs in der Runtime sichtbar machen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bevor Sie nun Ihre sprachumschaltbaren Menüs in der Runtime nutzen können, müssen Sie diese noch im Editor aktivieren. Das erfolgt mit Hilfe einer Funktion.

  1. Öffnen Sie im Projektmanager den Knoten Funktionen.
  2. Wählen Sie Funktion neu...
  3. Wählen Sie
    1. die Bilderfunktion
    2. Menü anzeigen

  4. Wählen Sie in der sich öffnenden Dialogbox
    1. die Aktion Menü anzeigen und
    2. Main als Menü
  5. Benennen Sie im Eigenschaftenfenster diese Funktion mit Show_Menue

Abschliessend zeichnen Sie im Bild Main noch eine Schaltfläche und wenden die soeben erstellte Funktion an.

Nachdem Sie nun die notwendigen Vorarbeiten geleistet haben wenden Sie das erstellte Menü auf einem Button an:

  1. Öffnen Sie im Projektmanager den Knoten Bilder.
  2. Wählen Sie das Bild Main
  3. Öffnen Sie das Bild mit einem Doppelklick auf den Namen Main
  4. Wählen Sie aus der Menüzeile Elemente => Button
  5. In dem sich öffnenden Fenster
    1. Funktionsauswahl
    2. wählen Sie die Funktion Show_Menue
  6. Benennen Sie diesen Button mit Menü anzeigen.
    Wechseln Sie dazu im Eigenschaftenfenster auf den Knotenpunkt Darstellung und geben Sie den Text im Eingabefeld Text Zeile 1: ein.

info Info

Wenn Sie den Begriff "Menüs anzeigen" auch in Ihre Sprachtabelle eintragen, wird auch dieser Button sprachabhängig angezeigt. Der Buttonbeschriftung stellen Sie dementsprechend ein @-Zeichen voran.

Die Übersetzung lautet: Mostrar menu

Testen Sie Ihre Eingaben in der Runtime.


Schriftlisten und Textlänge

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie dieses Tutorial bisher Schritt für Schritt nachgestellt haben, wird es Ihnen bereits aufgefallen sein: unterschiedliche Sprachen haben unterschiedliche Textlängen.

Dieser Umstand stellt vor allem bei Buttons eine Herausforderung dar. Durch den eingeschränkten Platz kann es dazu kommen, dass Texte abgeschnitten werden.

Eine sehr einfache und effiziente Lösung ist in diesem Falle, für längere Texteinträge eine kleinere Schriftgröße zu verwenden. Dazu stellt zenon die Funktionalität von Schriftlisten zur Verfügung.

Noch in diesem Kapitel

Schriftlisten

Arbeiten mit Schriftlisten

Defaultschrift(en)

Projektierung der Schriftlistenumschaltung

Praxistipps zur Gestaltung unterschiedlicher Textlängen


Schriftlisten

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge -> Schriftlisten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Bei Verwendung der Schriftlisten, muss nicht jede Schriftdarstellung in Größe, Art, Schnitt, Codierung und Effekt einzeln, pro Text oder Beschriftung gesetzt werden.

Ein weiterer Vorteil: Änderungen an einem Schriftlistenobjekt werden automatisch auf die gesamte Projektierung angewendet.

Fremdsprachige Zeichensätze:

Schriftlisten werden auch für fremdsprachige Zeichensätze verwendet. Für asiatische, kyrillische oder arabische Schriftzeichen bieten sie die Möglichkeit, Buchstaben im jeweiligen Alphabet darzustellen. Auch sprachabhängige Sonderzeichen sind so abbildbar.


Arbeiten mit Schriftlisten

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge -> Arbeiten mit Schriftlisten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zum Anlegen einer Schriftliste gehen Sie wie folgt vor:

  1. Wechseln Sie im Knotenpunkt Bilder auf Schriftlisten
  2. Mit der Schaltfläche Schriftliste neu erstellen Sie eine neue Schriftliste
  3. Zur besseren Orientierung benennen Sie die erstellte Schriftliste.
    In diesem Beispiel: Language_portuguese
  4. Ändern Sie die jeweilige Schrift.
    Um diese Projektierung in der Runtime sichtbar zu machen, wählen Sie eine Schriftart, welche sich von der Standardschrift erheblich unterscheidet, wie z.B. Vladimir Script.

attention Achtung

Die Änderungen müssen für jede Schrift einzeln durchgeführt werden.


Defaultschrift(en)

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge -> Defaultschrift(en)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Inhalte aus der Symbolleiste Elemente sind mit Defaultwerten belegt.

Zum Ändern der Defaulteinstellungen führen Sie folgende Schritte aus:

  1. Wechseln Sie im Knotenpunkt Bilder auf Schriftlisten.
  2. Wechseln Sie in die Zeile mit der jeweiligen Schrift.
  3. Klicken Sie auf ... neben der Eigenschaft Schriftart im Eigenschaftenfenster um das Schriftartenfenster zu öffnen.
  4. Ändern Sie die Schrifteinstellungen nach Ihren Vorstellungen.

Belegung der Schriftlisten:

  • Standardschrift2 (Position 2) für Textelemente in zenon
  • Button - (Position 6) normal für die Beschriftung des Elementes Button

info Info

Beachten Sie in Ihrer bisherigen Projektierung die Auswirkung, wenn Sie die Schriftart oder -größe ändern.


Projektierung der Schriftlistenumschaltung

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge -> Projektierung der Schriftlistenumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Schriftlistenumschaltung wird ebenfalls mit der Funktion Sprachumschaltung realisiert. Auch hier gilt: Pro Schriftliste legen Sie eine Funktion an, die beliebig oft verwendet werden kann.

Sollten Sie bereits eine Funktion zur Sprachumschaltung erstellt haben, können Sie diese verwenden. Es ist lediglich in der Funktion die entsprechende Schriftliste anzugeben.

Noch in diesem Kapitel

Neuanlage der Funktion für die Schriftumschaltung

Schriftumschaltung bei vorhandener Sprachumschaltungsfunktion


Neuanlage der Funktion für die Schriftumschaltung

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge -> Projektierung der Schriftlistenumschaltung -> Neuanlage der Funktion für die Schriftumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Folgende Schritte erklären die Erstellung einer Funktion zur Umschaltung zwischen einzelnen Schriftlisten. Eine Sprachdateiumschaltung wird in diesem Beispiel absichtlich weggelassen.

  1. Öffnen Sie im Projektmanager den Knoten Funktionen.
  2. Wählen Sie Funktion neu...
    Die Auswahlbox der Funktionen öffnet sich.
  3. Wählen Sie im Ordner Anwendung die Funktion Sprachumschaltung.

  4. In der sich öffnenden Dialogbox wählen Sie die Schriftliste durch Klick auf die Dropdownliste Schriftliste
  5. Wählen Sie Language_portuguese in der Schriftliste.
  6. Bestätigen Sie Ihre Eingabe mit OK
  7. Benennen Sie diese Funktion mit Schriftliste_portuguese im Eigenschaftenfenster.
    Gehen Sie dazu im Eigenschaftenfenster auf den Knoten Allgemein.
  8. Wiederholen Sie den oberen Schritt für Ihre Systemsprache.
    Wählen Sie dazu Schriftliste 1 aus. Benennen Sie diese Funktion mit Schriftliste_native.


Schriftumschaltung bei vorhandener Sprachumschaltungsfunktion

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge -> Projektierung der Schriftlistenumschaltung -> Schriftumschaltung bei vorhandener Sprachumschaltungsfunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollten Sie bereits eine Funktion zur Sprachumschaltung erstellt haben, können Sie diese verwenden. Es ist lediglich in der Funktion die entsprechende Schriftliste anzugeben.

Nachfolgende Schritte bauen auf die bisherigen Tutorialschritte auf:

  1. Öffnen Sie im Projektmanager den Knoten Funktionen.
  2. Wählen Sie die bestehende Funktion Language_portuguese aus.
  3. Wählen Sie im Eigenschaftenfenster der Funktion die Schriftliste Language_portuguese aus
  4. Bestätigen Sie Ihre Eingabe mit OK.
  5. Benennen Sie diese Funktion mit Language_portuguese im Eigenschaftenfenster.
    Gehen Sie dazu im Eigenschaftenfenster auf den Knoten Allgemein.
  6. Wiederholen Sie den oberen Schritt für Ihre Systemsprache.
    Benennen Sie diese Sprachumschaltungsfunktion mit Language_native. Wählen Sie ZENONSTR.TXT als Sprachdatei.


Praxistipps zur Gestaltung unterschiedlicher Textlängen

Internationalisierung -> Projektierung der Sprachumschaltung -> Schriftlisten und Textlänge -> Praxistipps zur Gestaltung unterschiedlicher Textlängen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Achten Sie bei der Projektierung darauf, dass Wörter in verschiedenen Sprachen unterschiedlich lang sein können.

Folgende Vorschläge können Ihnen helfen, diese Aufgabe zu bewältigen:

  • Projektieren Sie pro Sprache eine eigene Schriftliste:
    z. B.: Button english big, Button italian big.
  • Projektieren Sie pro Anwendungsbereich mehrere Schriftlisten:
    z. B.: Buttonschrift gross / Buttonschrift klein.
  • Projektieren Sie Ihre Schriftlisten mit einer höheren Schriftgröße:
    z. B.: Buttonschrift um zwei Punkte größer als üblich, um später auftretende längere Schriften mit einmaliger Korrektur der Schriftgröße anzupassen.

Empfehlung: Verwenden Sie einen dieser Schritte bereits zu Beginn der Projektierung. Auch wenn das Projekt vorerst nur in zwei Sprachen zur Verfügung stehen soll, sparen Sie sich bei einer späteren Ausweitung zusätzliche Anpassungsarbeiten.

Praxisbeispiele für unterschiedliche Textlänge

Deutsch | Englisch | Italienisch
ein | on | innestato
aus | off | OFF

Fremdsprachige Zeichen

Hinweis: Nicht jede Schriftart verfügt über die notwendigen Zeichen bzw. Schriftzeichen. Wenn Sie eine asiatische oder kyrillische Schrift projektieren, wählen Sie eine Schriftart, welche die erforderlichen Sonderzeichen enthält.

Achten Sie deshalb bereits bei der Projektierung darauf, eine Schrift zu verwenden, welche über fremdsprachige Zeichensätze verfügt.

Example Beispiel

Die Schriftart Arial Unicode MS bietet die gängigsten Schriftscripte zur Auswahl an.

Hinweis zu Tastenkombinationen

Achten Sie auch bei der Zuweisung von Tastenkombinationen auf internationale Bezeichnungen, ähnlich der bereits bekannten Systematik in Anwendungsprogrammen (ALT+P für Print anstelle ALT+D für Drucken).

Hinweis: Die Tastenkombinationen werden bei den Element-Einstellungen im Knotenpunkt Runtime im Eingabefeld Tastenkombination projektiert.

Zusatznutzen der Sprachumschaltung

Eine weitere Anwendungsmöglichkeit der Sprachumschaltung bietet die Anpassung des textlichen Erscheinungsbildes an äußerliche Gegebenheiten. Eine Sprachumschaltung muss nicht zwangsläufig zu einer zweiten Sprache führen:
Beispiele:

  • Dickere Schrift bei kontrastreicher Darstellung
  • Geänderte Schriftfarbe um rot-/grün Sehschwäche entgegenzuwirken


Sprachumschaltbare Grafiken

Internationalisierung -> Sprachumschaltbare Grafiken

Im folgenden Abschnitt wird die Sprachumschaltung mit der jeweiligen Flagge grafisch dargestellt.

Noch in diesem Kapitel

Sprachumschaltbare Grafiken - Dateisystem

Sprachumschaltbare Grafiken - Vorbereitung

Projektierung von Sprachumschaltbaren Grafiken

Praxistipps Grafiken umschalten


Sprachumschaltbare Grafiken - Dateisystem

Internationalisierung -> Sprachumschaltbare Grafiken -> Sprachumschaltbare Grafiken - Dateisystem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Anders als bei Texten, müssen Grafiken nicht gesondert als sprachumschaltbar gekennzeichnet sein. Die Zuordnung passiert auf Dateiebene unter Zuhilfename von (von zenon vorgegebenen) standardisierten Verzeichnissen.

Um dieses Prinzip zu verstehen, beachten Sie Folgendes:

  1. Öffnen Sie in einem neutralen und leeren Projekt den Knotenpunkt Dateien.
  2. Klicken Sie auf den Knotenpunkt Grafiken.

    Hinweis: Beachten Sie den leeren Inhalt dieses Ordners

  3. Wechseln Sie in den Knotenpunkt Sprachdatei und erstellen Sie dort eine neue Sprachdatei.
  4. Benennen Sie die neue Sprachdatei mit TUTORIAL-PORTUGUESE.
  5. Wechseln Sie zurück in den Knotenpunkt Dateien:
    Das erste, was nun auffällt ist, dass der Ordner Grafiken Unterordner enthält (zu erkennen an dem vorangestellten [+]).
  6. Öffnen Sie den Ordner Grafiken mit Klick auf [+].
  7. Zu einem besseren Verständnis wird nun eine dritte Sprache hinzugefügt
  8. Erweitern Sie die Ansicht des Knotenpunktes Dateien, sodass die Ordner Dateien und Grafiken aufgeklappt sind.
  9. Klicken Sie nun einmalig im Knotenpunkt auf den Eintrag Sprachdatei
  10. Beobachten Sie nun den Ordner Dateien während Sie folgendes projektieren:
    1. Erstellen Sie eine neue Sprachtabelle
    2. benennen Sie diese mit TUTORIAL-POLISH
    3. und bestätigen Sie diesen Eintrag mit OK.

Bei Ausführung einer Sprachumschaltefunktion wird die Grafik aus dem jeweiligen Ordner automatisch in die Runtime geladen.

info Info

Wird eine Sprachtabelle gelöscht, so bleiben die Unterverzeichnisse im Knotenpunkt Dateien erhalten.


Sprachumschaltbare Grafiken - Vorbereitung

Internationalisierung -> Sprachumschaltbare Grafiken -> Sprachumschaltbare Grafiken - Vorbereitung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nachdem Sie nun das Prinzip der umschaltbaren Grafik kennengelernt haben, projektieren Sie die Aufgabenstellung.

Vorbereitung:

Für die nächsten Schritte sollten Sie pro Sprache eine Bilddatei der jeweiligen Landesflagge bereit haben.

  1. Erstellen Sie im Knotenpunkt Sprachumschaltung zwei neue Sprachdateien und benennen Sie diese mit TUTORIAL-PORTUGUESE.TXT sowie TUTORIAL-POLISH.TXT.
  2. Wechseln Sie in das Bild Main.
  3. Zeichnen Sie einen Button und bestätigen Sie den folgenden Dialog ohne eine Funktion auszuwählen mit OK.
  4. Wählen Sie im Eigenschaftenfenster unter Darstellung und dort die Eigenschaft Grafikdatei: die Schaltfläche ...
  5. In dem sich nun öffnenden Dialog wählen Sie Datei importieren...

  6. In dem sich nun öffnenden Dateibrowser wählen Sie eine Grafikdatei (Landesflagge), passend zu Ihrer Landessprache.


Projektierung von Sprachumschaltbaren Grafiken

Internationalisierung -> Sprachumschaltbare Grafiken -> Projektierung von Sprachumschaltbaren Grafiken

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nachdem Ihr Projekt in Ihrer Sprache angelegt und mit einer entsprechenden Grafik versehen wurde, fügen Sie nun die fremdsprachigen Grafikinhalte ein.

Dazu sind zwei Schritte notwendig:

  1. Grafik in entsprechendem Dateiordner hochladen
  2. Anpassung der Sprachumschaltefunktion

Noch in diesem Kapitel

Grafik in Dateiordner hochladen

Anpassung der Sprachumschaltefunktion


Grafik in Dateiordner hochladen

Internationalisierung -> Sprachumschaltbare Grafiken -> Projektierung von Sprachumschaltbaren Grafiken -> Grafik in Dateiordner hochladen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Beim Hochladen der Grafiken gehen Sie wie üblich in zenon vor:

  1. Öffnen Sie den Knotenpunkt Dateien.
  2. Klicken Sie im Strukturpunkt Grafiken den Ordner TUTORIAL-PORTUGUESE.
  3. Laden Sie mit dem Befehl Datei importieren... die entsprechende Grafik hoch.
  4. Wiederholen Sie diesen Schritt mit der Grafik für die polnische Sprache.

attention Achtung

Die Dateibenennung der Bilder muss bei der Sprachumschaltung in allen Sprachen identisch sein.


Anpassung der Sprachumschaltefunktion

Internationalisierung -> Sprachumschaltbare Grafiken -> Projektierung von Sprachumschaltbaren Grafiken -> Anpassung der Sprachumschaltefunktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Wenn Sie jetzt noch eine Sprachumschaltefunktion erstellen, können Sie die Projektierung Ihrer sprachabhängigen Grafikumschaltung in der Runtime testen.

  1. Öffnen Sie im Projektmanager den Knoten Funktionen.
  2. Wählen Sie Funktion neu...
    Die Auswahlbox der Funktionen öffnet sich.
  3. Wählen Sie die Funktion Sprachumschaltung.
  4. Wählen Sie in der sich öffnenden Dialogbox durch Klick auf die Dropdownliste Grafiken.

  5. Wählen Sie TUTORIAL-PORTUGUESE.
  6. Bestätigen Sie Ihre Eingabe mit OK.

info Info

Sie können diese Zuordnung der Grafik selbstverständlich einer bereits projektierten Funktion hinzufügen.


Praxistipps Grafiken umschalten

Internationalisierung -> Sprachumschaltbare Grafiken -> Praxistipps Grafiken umschalten

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Wie schon öfters in diesem Tutorial erwähnt: eine einheitliche Benennung erleichtert die Projektierung. Da bei der Grafikumschaltung der Bildername eine entscheidende Rolle spielt, sollten Sie hier (ausnahmsweise) auf die Länderbezeichnung im Dateinamen verzichten. Stattdessen fügen Sie der Bildbenennung eine Bezeichnung wie z.B. Flagge_Sprachidentifizierung hinzu.
  • Sie können die Möglichkeit der Sprachumschaltung nicht nur zur "Übersetzung" von Bildern verwenden. Eine mögliche Anwendung ist die Wahlmöglichkeit zweier Bedienoberflächen, um z. B. äußerlichen Einflüssen wie Sonnenstrahlen entgegenzuwirken.
  • Ein weiteres Anwendungsbeispiel für umschaltbare Grafiken ist die Möglichkeit, länderspezifische Firmenlogos in Ihrem HMI-System zu visualisieren.
  • Auch wenn Sie nur in einer Sprachregion tätig sind: nutzen Sie diese Funktion für Ihre Zwecke. So können Sie z.B. einzelne Werke (auch in einem Land) mit dieser Funktion grafisch kennzeichnen.


Einheiten umrechnen

Internationalisierung -> Einheiten umrechnen

Nicht nur die Sprache, auch Maßeinheiten sind abhängig von Regionen. Mit zenon sind Sie auch für diese Aufgabe bestens gerüstet.

Noch in diesem Kapitel

Projektierung der Werteumrechnung

Skripte zum Zusammenfassen mehrerer Funktionen

Vom Betriebssystem vorgegebene Werteumrechnung

Tipps zur Werteumrechnung


Projektierung der Werteumrechnung

Internationalisierung -> Einheiten umrechnen -> Projektierung der Werteumrechnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

In diesem Tutorial werden Sie jetzt die Masseinheit internationalisieren: Liter werden in Gallonen umgerechnet und Grad Celsius in Fahrenheit.

Dazu gehen Sie analog zu den bisherigen Schritten vor:

  • Parametrierung der Werteumrechnung
  • Zuordnung zu Variable
  • Erstellung einer Funktion
  • Anwendung der Funktion

Noch in diesem Kapitel

Vorbereitung des Projektes

Projektierung der Maßeinheit

Zuordnung zur Variable

Projektierung der Funktion

Maßeinheit und Funktion auf Button anwenden


Vorbereitung des Projektes

Internationalisierung -> Einheiten umrechnen -> Projektierung der Werteumrechnung -> Vorbereitung des Projektes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sollten Sie dieses Tutorial bis hier her Schritt für Schritt nachvollzogen haben, so werden Sie von den nun folgenden Einstellungen bereits einige vollzogen haben. In diesem Falle können Sie Ihre bisherige Arbeit übernehmen bzw. die bereits vollzogenen Schritte auslassen.

  • Wählen Sie das Bild Main
  • Öffnen Sie das Bild mit einem Doppelklick auf den Namen

Text einfügen

  • Wählen Sie die Menüleiste Elemente.
  • Wählen Sie dort Statischer Text.
  • Platzieren Sie diesen Text in ihrem Bild.
  • Geben Sie im Eigenschaftenfenster das Wort @Füllstand ein.
  • Öffnen Sie im Projektmanager den Knoten Sprachdatei.
  • Platzieren Sie den Cursor in der letzen Zeile der Spalte Schlüsselwort.
  • Tragen Sie das zu übersetzende Schlüsselwort Füllstand ein.
  • Bestätigen Sie die Eingabe mit der Eingabetaste. Die Zellen der restlichen Sprachdateien werden mit diesem Eintrag vorausgefüllt.
  • Tragen Sie die Übersetzung in der jeweiligen Spalte Ihrer Sprachdatei ein (nÍvel).
  • Wiederholen Sie die Schritte mit dem Wort Temperatur.
    Die Übersetzung lautet: temperatura.

Zahlenwerte einfügen

Um die nachfolgend beschriebene Projektierung der Einheitenumrechnung sichtbar zu machen fügen Sie Ihrem Projekt noch Zahlenwerte hinzu:

  • Wählen Sie die Menüleiste Elemente.
  • Wählen Sie dort Zahlenwert.
  • Platzieren Sie diesen Text in ihrem Bild.
  • Wählen Sie die Variable Füllmenge.
  • Wiederholen Sie diese Schritte mit der Variable Temperatur.

Ansichtmuster der bisherigen Projektierung im Editor


Projektierung der Maßeinheit

Internationalisierung -> Einheiten umrechnen -> Projektierung der Werteumrechnung -> Projektierung der Maßeinheit

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Öffnen Sie im Projektmanager den Knoten Variablen.
  • Wählen Sie den Eintrag Maßeinheiten.
  • Erstellen Sie mit Basiseinheit neu eine neue Basiseinheit.
  • In diesem Beispiel wollen wir Liter in Gallonen umrechnen.
    Benennen Sie deshalb Basiseinheit mit Füllmenge.
  • Erstellen Sie mit Umrechnungseinheit neu den Eintrag Liter.
    Drücken Sie dazu das Symbol oder benutzen Sie die Rechte Maustaste.
  • Belassen Sie die Einstellungen im Eigenschaftenfenster wie vorgegeben.
  • Erstellen Sie einen zweiten Eintrag und nennen Sie diesen Gallonen.
  • Ändern Sie im Eigenschaftenfenster des Eintrages Gallonen den Faktor auf 0,264172.

Maßeinheitenumrechnung mit Fahrenheit

  • Wiederholen Sie diese Schritte für die Temperatur
  • Erstellen Sie dabei Eine neue Basiseinheit Temperatur und
  • zwei Umrechnungseinheiten Celsius und Fahrenheit

info Info

Für die Umrechnung von Celsius in Fahrenheit setzen Sie folgende Eigenschaften:

Faktor: 1.8 und Offset: 32


Zuordnung zur Variable

Internationalisierung -> Einheiten umrechnen -> Projektierung der Werteumrechnung -> Zuordnung zur Variable

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Damit zenon die Maßeinheiten einer Variable zuordnen kann, sind folgende Schritte auszuführen:

  • Öffnen Sie im Projektmanager den Knoten Variable.
  • Wählen Sie die Variable Temperatur.
  • Wählen Sie im Eigenschaftenfenster unter Allgemein die Eigenschaft Maßeinheit: aus.
  • Wählen Sie in der Dropdownliste die Maßeinheit Temperatur.

  • Wiederholen Sie diesen Schritt mit der Variable Füllmenge und der Maßeinheit Füllmenge.


Projektierung der Funktion

Internationalisierung -> Einheiten umrechnen -> Projektierung der Werteumrechnung -> Projektierung der Funktion

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Öffnen Sie im Projektmanager den Knoten Funktionen.
  • Erstellen Sie mit Funktion neu eine neue Funktion.
  • Wählen Sie in dem sich öffnenden Funktions-Auswahl-Dialog den Eintrag Variable Einheitenumschaltung
    Dieser Eintrag befindet sich im Knoten Variable.
  • Wählen Sie im folgenden Dialogfenster neben der Basiseinheit Füllmenge, die Dropdownliste Umschalten in.
  • Ändern Sie in der Dopdownliste den Eintrag <Basiseinheit> auf Gallonen.
  • Bennenen Sie diese Funktion mit convert_to_Gallons.
  • Wiederholen Sie diese Schritte für Liter und benennen Sie die neue Funktion mit convert_to_Liter.


Maßeinheit und Funktion auf Button anwenden

Internationalisierung -> Einheiten umrechnen -> Projektierung der Werteumrechnung -> Maßeinheit und Funktion auf Button anwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Anwendung der Funktion Maßeinheitenumschaltung ist wieder sehr einfach:

  1. erstellen Sie einen Button
  2. benennen Sie den Button mit Liter
  3. ziehen Sie die Funktion via Drag&Drop über den Button
  4. wiederholen Sie die Schritte für Gallonen
  5. testen Sie Ihre Projektierung in der Runtime

info Info

Damit Sie die Einheitenrechnung in der Runtime nachvollziehen können, müssen die Werte von Füllstand und Temperatur befüllt sein.

Klicken Sie dazu mit einem Linksklick der Maus auf das Zahlenwertfeld und setzen Sie einen Modifizierten Spontanwert, z.B. 20000

Beispiel für Sollwertvorgabe:

Selbstverständlich können Sie auch hier die Buttonbeschriftung Liter mit einem vorangestellten
@-Zeichen und einen Eintrag in der Sprachtabelle übersetzen.


Skripte zum Zusammenfassen mehrerer Funktionen

Internationalisierung -> Einheiten umrechnen -> Skripte zum Zusammenfassen mehrerer Funktionen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Im Laufe dieses Tutorials wurden mehrere Funktionen erstellt. Dieses Kapitel widmet sich der Herausforderung, mehrere Funktionen in einem Skript zusammenzufassen.

Die Zusammenfassung mehrerer Funktionen erfolgt nach dem bekannten Schema:

  • Erstellung eines Skriptes.
  • Parametrierung des Skriptes.
  • Anwendung des Skriptes mit der Funktion Script ausführen.

Example Beispiel

Ein Skript wird angelegt, das sämtliche Funktionen eines Landes zusammenfasst.

Noch in diesem Kapitel

Projektierung eines Skriptes

Anwendung eines Skriptes

Skript online auswählbar

Praxistipps Skripte


Projektierung eines Skriptes

Internationalisierung -> Einheiten umrechnen -> Skripte zum Zusammenfassen mehrerer Funktionen -> Projektierung eines Skriptes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um ein Skript zu erstellen und Funktionen hinzuzufügen:

  • Öffnen Sie im Projektmanager den Knoten Funktionen.
  • Erweitern Sie die Ansicht und wählen Sie den Eintrag Skripte.

  • Erstellen Sie in der Detailansicht mit Skript neu ein neues Skript.
    Bennen Sie dieses mit Country_native im Eigenschaftenfenster.
  • Drücken Sie in der Detailansicht die Schaltfläche Funktionen hinzufügen.
  • Bennen Sie dieses Skript mit Call_German im Eigenschaftenfenster.
  • Fügen Sie in dem sich nun öffnenden Funktionsauswahl-Dialog die entsprechenden Funktionen hinzu.
    Wählen Sie die entsprechende Funktion und drücken Sie Hinzufügen.

    Hinweis: Mit Shift bzw. Strg + Mauscklick ist eine Mehrfachauswahl von Variablen möglich.
  • Wiederholen Sie diese Schritte für ein zweites Skript:
    Skriptname: Call_Portuguese


Anwendung eines Skriptes

Internationalisierung -> Einheiten umrechnen -> Skripte zum Zusammenfassen mehrerer Funktionen -> Anwendung eines Skriptes

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Für die Anwendung des erstellten Skriptes:

  • Erstellen Sie eine neue Funktion.
  • Öffnen Sie die Funktionsgruppe Skript.
  • Wählen Sie Skript ausführen.

  • In dem sich öffnenden Dialog Skript auswählen wählen Sie Country_native
  • Bennennen Sie dieses neu erstellte Skript mit Call_native.
  • Erstellen Sie ein neues Skript für die portugiesische Umschaltung.

Wenn Sie nun im Bild Main zwei neue Buttons zeichnen und die soeben erstellte Funktion anwenden, haben Sie mehrere Funktionen mit einem Mausklick abgedeckt.


Skript online auswählbar

Internationalisierung -> Einheiten umrechnen -> Skripte zum Zusammenfassen mehrerer Funktionen -> Skript online auswählbar

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Zum Abschluss der Skriptanwendung werden Sie nun lernen, wie Sie die Auswahl Ihrer Skripte in der Runtime auswählbar machen.

  • Dazu gehen Sie exakt gleich vor, wie im Vorgängerkapitel beschrieben.
  • Bei der Auswahl der Skriptumschaltfunktion wählen Sie jedoch Skript mit Online-Auswahl.

  • Zeichnen Sie im Bild Main einen Button Sprachauswahl und wenden Sie die soeben erstellte Funktion darauf an.
  • Testen Sie Ihre Projektierung nun in der Runtime.

info Info

Die Skript-Funktion Skript mit Online Auswahl bietet für den Bediener der Runtime die freie Auswahlmöglichkeit.


Praxistipps Skripte

Internationalisierung -> Einheiten umrechnen -> Skripte zum Zusammenfassen mehrerer Funktionen -> Praxistipps Skripte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nachdem Sie nun gelernt haben, Skripte zusammenzufassen stehen Ihnen eine Menge an Anwendungsmöglichkeiten offen.

Beispiele:

  • Fremdsprachige Mitarbeiter können sich Ihre Bedienoberfläche in deren Muttersprache anzeigen lassen.
  • Eine Projektierung von Einzelfunktionen und Skripten ermöglicht Flexibilität und Wiederverwendung.
  • Nutzen Sie Skripte, um Standardvorgänge zusammenzufassen.
  • Durch den Einsatz von Skripten und dem daraus entstehenden Mehrfachnutzen können Einzelfunktionen eingespart werden. Administration und Übersichtlichkeit werden dadurch erleichtert.


Vom Betriebssystem vorgegebene Werteumrechnung

Internationalisierung -> Einheiten umrechnen -> Vom Betriebssystem vorgegebene Werteumrechnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Nicht alle Wertumrechnungen müssen projektiert werden.

Folgende Werte und deren Darstellung werden in zenon direkt vom Betriebssystem übernommen:

  • Datumsformat
  • Uhrzeitformat


Tipps zur Werteumrechnung

Internationalisierung -> Einheiten umrechnen -> Tipps zur Werteumrechnung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com
  • Verwenden sie für die Wertedarstellung - wann immer es möglich ist - die Einheitendarstellung. So sparen Sie sich die Übersetzung.
    Beispiel Temperaturanzeige: Grad als Wort ist zu übersetzen. Das Zeichen ° hingegen ist nicht nur in allen Sprachen gleich, es kann sogar auf Celsius, Fahrenheit und Kelvin gleichermaßen angewandt werden.
    Setzen Sie dazu in den Eigenschaften der Basiseinheit das entsprechende Zeichen.
  • Selbstverständlich können Sie bei der Benennung der Maßeinheiten ebenfalls mit dem
    @-Zeichen übersetzbare Begriffe einfügen. Das Bild zeigt beide Möglichkeiten:

  • Fügen Sie jeder Sprachumschaltefunktion die entsprechende Werteumrechnung hinzu. Anderenfalls kann es sehr leicht zu Missverständnissen kommen.
  • Setzen Sie die exakte Einheitenbezeichnung als Tooltip. In der gewohnten Umgebung wird der Mensch selbstverständlich immer in seiner jeweiligen Landeseinheit denken. Für die Fehlersuche, Optimierung der Internationalisierung und Projektoren mit Schwerpunkt Internationalisierung kann diese Verwendung des Tooltipps jedoch eine wesentliche Arbeitserleichterung bringen.
    Machen Sie diesen Tooltip übersetzbar, verwenden Sie internationale Bezeichnungen auch bei Land. Natürlich können Sie die Maßeinheit (in unserem Beispiel Celsius) auch in die jeweilige Sprache übersetzen.


Wizard auf bestehende Projekte anwenden

Internationalisierung -> Wizard auf bestehende Projekte anwenden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Sie haben in diesem Tutorial gelernt, wie Sie mögliche Herausforderungen des internationalen Arbeitens in zenon lösen. Doch zenon wäre nicht zenon, wenn es nicht eine kleine eingebaute Erleichterung für diese Arbeitsschritte bereitstellen würde.

Mit Hilfe des eingebauten Wizards können Sie ein bereits bestehendes einsprachiges Projekt automatisiert zu einem mehrsprachigen machen.

info Info

Der Wizard steht nur in englischer Sprache zur Verfügung.

Noch in diesem Kapitel

Projektierung des Wizards


Projektierung des Wizards

Internationalisierung -> Wizard auf bestehende Projekte anwenden -> Projektierung des Wizards

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um einen Wizard zu starten:

  • wählen Sie in der Menüzeile Datei den Eintrag Wizards ...

    oder

  • drücken Sie die Tastenkombination Alt+F12
  • wählen Sie im Ordner Language table den Language change wizard

  • Wählen Sie die entsprechenden Eingaben.
  • Mit Pfeil nach links und Pfeil nach rechts navigieren Sie durch den Wizard.
  • Der Wizard wird mit der Schaltfläche SAVE! auf der Save language table Seite des Wizards ausgeführt
  • Zum Beenden des Wizards drücken Sie Cancel.

In der Sprachtabelle des Projektes sind alle vorhandenen sprachumschaltbaren Schlüsselwörter aufgeführt.

info Info

Nach Abschluss des Wizards sind alle in einem Projekt enthaltenen sprachumschaltbaren Schlüsselwörter aufgelistet.


Übersetzungshilfe Project Translation Interface

Internationalisierung -> Übersetzungshilfe Project Translation Interface

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um mehrsprachige Texte effizient und schnell übersetzen zu können bietet zenon ab der Version 7.10 ein externes Übersetzungstool.

Dieses arbeitet eng mit dem Language Translation Wizard zusammen:

  • Der Wizard dient dabei zum Export und zur Aufbereitung der in zenon projektierten mehrsprachigen Inhalten.
  • Das Project Translation Interface ünterstützt den Übersetzer durch Darstellung der projektierten Bilder sowie Marker für Textlängen.
  • Nach abgeschlossener Übersetzung importiert der Wizard die Daten zurück nach zenon.


Message Control (lizenzpflichtig)

Internationalisierung -> Message Control (lizenzpflichtig)

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Achten Sie darauf, in den Eigenschaften für den Knotenpunkt Message Control den Eintrag Dynamischer Teil des Betreffs ebenfalls sprachabhängig zu gestalten.

Achten Sie auch bei der Projektierung der Benutzerverwaltung auf internationale Standards. Wenn Sie sich angewöhnen, Telefonnummern immer inklusive der internationalen Vorwahl einzugeben, sind Sie bestens für spätere Erweiterungen vorbereitet.

Beachten Sie dabei auch allfällige Anforderungen der jeweiligen Telefonanlage wie z.B. "0 für Freileitung".
Diese Einträge setzen Sie unter: Benutzerverwaltung => Benutzer => Schaltfläche Benutzer neu => Registerkarte Message Control

attention Achtung

Achten Sie bei Sprachbenachrichtigungen darauf, dass das angeschlossene Telefon für die Sprachnachrichten auch über die notwendigen Berechtigungen (z.B. Auslandsgespräche ...) verfügt.

Noch in diesem Kapitel

Sprachabhängige Texte bei Message Control


Sprachabhängige Texte bei Message Control

Internationalisierung -> Message Control (lizenzpflichtig) -> Sprachabhängige Texte bei Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Denken Sie daran auch abgehende Messages zu internationalisieren.

Dabei arbeiten Benutzerverwaltung und Message Control eng zusammen:

  • In den Einstellungen der Benutzerverwaltung werden die Kontaktdaten der Empfänger eingetragen.
  • Mit Hilfe von Benutzergruppen können Sprachgruppen gebildet werden.
  • In der Versandart der Message Control wird der jeweilige Empfänger(kreis) hinzugefügt

Noch in diesem Kapitel

Projektierung der Message Control

Praxistipps für sprachabhängige Message Control


Projektierung der Message Control

Internationalisierung -> Message Control (lizenzpflichtig) -> Sprachabhängige Texte bei Message Control -> Projektierung der Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um eine Nachricht abzusetzen:

  1. Öffnen Sie im Projektmanager den Knoten Message Control
  2. Geben Sie im Eigenschaftenfenster im Eintrag Dynamischer Teil des Betreffs: einen entsprechenden Text ein. Achten Sie darauf, dass dem Text ein @-Zeichen vorangestellt ist.
    In diesem Beispiel geben Sie @Beispieltext für den Betreff in der Message Control ein.
  3. Wechseln Sie im Projektmanager zum Knoten Sprachdatei und fügen Sie diesen Satz als neues Schlüsselwort ein.
  4. Erstellen Sie nun die dazugehörige Funktion:
    Wählen Sie dazu in der Funktionsgruppe Message Control die Funktion Sende Nachricht
  5. Parametrieren Sie diese Funktion in der Registerkarte Nachricht, indem Sie im Feld Freier Nachrichtentext @Textnachricht im Modul Message Control eingeben

    Hinweis: Bei der Zuordnung der Empfängername in der Registerkarte Versandart => Empfängername => ... ist Mehrfachauswahl möglich
    Erstellen Sie in der Sprachdatei die jeweilige Übersetzung für Ihren Nachrichtentext.
    Übersetzung für dieses Tutorial: xxx


Praxistipps für sprachabhängige Message Control

Internationalisierung -> Message Control (lizenzpflichtig) -> Sprachabhängige Texte bei Message Control -> Praxistipps für sprachabhängige Message Control

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Um die jeweilige Sprache der abgehenden Nachricht dem Empfänger anpassen zu können erstellen Sie in der Benutzerverwaltung sprachabhängige Benutzergruppen. Diese Gruppen können zusätzlich zu vorhandenen Gruppen angelegt werden.

Wenn sie mit dieser Methode arbeiten, empfiehlt sich bei der Gruppenbenennung eine entsprechende Kennzeichnung im Namen voranzustellen:


Anwendungsmöglichkeiten der Sprachumschaltung

Internationalisierung -> Anwendungsmöglichkeiten der Sprachumschaltung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. Sollten Sie Fragen oder Anregungen zur Dokumentation haben, wenden Sie sich bitte an: documentation@copadata.com

Die Möglichkeit der Sprachumschaltung ist nicht nur auf klassische Sprachumschaltung beschränkt. Einige Beispiele, wie sie die Mehrsprachigkeit ebenfalls anwenden können:

  • Tooltipps
  • Menüs
  • Alarmmeldeliste
  • Chronologische Ereignislisten

Für die von zenon bereitgestellten Bildtypen sowie die in der Runtime und im Editor verwendeten Dialoge können Sie unter support@copadata.com übersetzte Sprachtabellen anfordern.

Diese Sprachtabellen stehen für folgende Sprachen zur Verfügung:

  • Englisch
  • Französisch
  • Italienisch
  • Russisch
  • Spanisch


Zusammenfassung

Internationalisierung -> Zusammenfassung

Nach Abschluss dieses Tutorials wissen Sie, wie Sie mit zenon effizient und mit wenig Aufwand internationale Projekte projektieren. Viel Spaß dabei.

Empfehlenswerte Kapitel der Online-Hilfe

Für zusätzliche Informationen lesen Sie die entsprechenden Kapitel in der Onlinehilfe.

Die angeführten Links geben einen Überblick über die in diesem Tutorial verarbeiteten Informationen.

  • Editor
    Beschreibung
  • Basis Tutorial
  • Projektverwaltung und Arbeitsbereich
  • Effizient projektieren mit zenon
  • Bilder
  • Funktionen
  • Skripte
  • Sprachumschaltung
  • Message Control
  • Masseinheitenumschaltung
  • Wizard: Language change