3S_Arti_NG

3S_Arti_NG

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Getestet mit folgender Hard- und Software

Version von Firm- und Software

ELAU MAX 4

ELAU EPAS-4 V 16

3S CoDeSys V 2.3

Sind beide Software-Tools (EPAS-4 und CoDeSys) gleichzeitig auf einem Rechner installiert, können Kommunikationsprobleme zwischen zenon und der jeweiligen Soft-SPS auftreten.

Testaufbau

  • Kommunikation zu einer CoDeSys SP RTE lokal
  • Kommunikation zu einer CoDeSys SP RTE über ethernet
  • Kommunikation zu einer Elau MAX-4 SPS über ethernet

Einstellungen in CoDeSys

Um eine Kommunikation mit der Leitstation und der Soft-SPS von CoDeSys aufbauen zu können, müssen folgende Einstellungen vorgenommen werden.

In den Zielsystem Einstellungen muss die 3S CoDeSys SP RTE Konfiguration ausgewählt werden.

Des Weitern müssen die Einstellungen „Symboldatei senden" und „Symbolkonfiguration aus INI-Datei" aktiviert werden.

In den Kommunikationsparametern benötigt man einen localhost mit dem Port 1200.

In den Optionen unter Symbolkonfiguration müssen die Parameter „Symboleinträge erzeugen" und „XML Symboltabelle erzeugen" ausgewählt werden.

Einstellungen in EPAS

Um eine Kommunikation mit der Leitstation und EPAS aufbauen zu können, müssen folgende Einstellungen vorgenommen werden.

In den Einstellungen für die Kommunikationsparameter benötigt man einen neuen Kanal mit der IP-Adresse und dem Port 5000.

In den Optionen unter Symbolkonfiguration müssen die Parameter „Symboleinträge erzeugen" und „XML Symboltabelle erzeugen" aktiviert werden.

Über die Schaltfläche Symbolfile konfigurieren, muss die Einstellung „Sammeleinträge ausgeben" deaktiviert sein.

In den Optionen unter Login muss der Parameter „Symbol-Datei aktualisieren" aktiviert werden.

Fehlerwartezeit

20 sek.

Zugriffsverfahren

Polling

Anzahl der Steuerungen

beliebig

Noch in diesem Kapitel

3S_ARTI_NG - Datenblatt

Treiber-Historie

Voraussetzungen

Konfiguration

Variablen anlegen

Treiberspezifische Funktionen

Treiberkommandos

Fehleranalyse


3S_ARTI_NG - Datenblatt

3S_Arti_NG -> 3S_ARTI_NG - Datenblatt

Allgemein: |
Treiberdateiname | 3S_ARTI_NG.exe
Treiberbezeichnung | Codesys Arti NG Treiber
Steuerungs-Typen | Codesys Soft SPSen, Moeller XControl SPSen XC200 und XC600, sowie Elau PacDrive Steuerungen MAX 4, C200, C400, C600, P600.
Steuerungs-Hersteller | 3S; Elau; Moeller;

Treiber unterstützt: |
Protokoll | 3S-Arti;
Adressierung: Adress-basiert | --
Adressierung: Namens-basiert | X
Kommunikation spontan | --
Kommunikation pollend | X
Online Browsing | X
Offline Browsing | X
Echtzeitfähig | --
Blockwrite | X
Modemfähig | --
Serielles Logging | --
RDA numerisch | --
RDA String | --

Voraussetzungen: |
Hardware PC | Standard Netzwerkkarte
Software PC | Codesys Software ab Version 2.42 inkl. ARTI Schnittstelle: SymArticlient.dll und Articlient.dll nötig, von 3S zu beziehen.
Hardware Steuerung | --
Software Steuerung | Codesys Software ab Version 2.42 inkl. ARTI Schnittstelle.Für Windows CE ARM Plattformen ab Version 2.5.2.0 inkl. ARTI Schnittstelle.
Benötigt v-dll | X

Plattformen: |
Betriebssysteme | Windows CE 6.0, Embedded Compact 7; Windows 7, 8, 8.1, 10, Server 2008R2, Server 2012, Server 2012R2;
CE Plattformen | x86; ARM;


Treiber-Historie

3S_Arti_NG -> Treiber-Historie

Datum | Treiberversion | Bemerkung
20.04.2006 | 100 | Dokument erstellt / BK
17.05.2006 | 300 | Erweiterungen im Zuge der Freigabe /TS, MC
14.08.2008 | 1400 |

Treiberversionierung

Mit zenon 7.10 wurde die Versionierung der Treiber verändert. Ab dieser Version gibt es eine versionsübergreifende Build-Nummer. Das ist die Zahl an der 4. Stelle der Dateiversion.
Zum Beispiel: 7.10.0.4228 bedeutet: Der Treiber ist für Version 7.10, Service Pack 0 und hat die Build-Nummer 4228.

Erweiterungen oder Fehlerbehebungen werden zukünftig in einem Build eingebaut und sind dann ab der nächsthöheren Build-Nummer verfügbar.

Example Beispiel

Eine Treibererweiterung wurde in Build 4228 implementiert. Der Treiber, den Sie im Einsatz haben, verfügt über die Build-Nummer 8322. Da die Build-Nummer Ihres Treibers höher ist als die Build-Nummer der Erweiterung, ist die Erweiterung enthalten. Die Versionsnummer des Treiber (die ersten drei Stellen der Dateiversion) spielen dabei keine Rolle. Die Treiber sind versionsunabsabhängig


Voraussetzungen

3S_Arti_NG -> Voraussetzungen

Dieses Kapitel enthält Informationen zu den Voraussetzungen, die für die Verwendung des Treibers erforderlich sind.

Noch in diesem Kapitel

PC

Steuerung


PC

3S_Arti_NG -> Voraussetzungen -> PC

Zusätzliche Software

  • Installation der aktuellen CoDeSys – Software (ab Version 2.12)
  • Installation eines Laufzeitsystems (über CoDeSys - Tool „InstallTarget")
  • Einstellen der Kommunikationsparameter in CoDeSys

Unterstützte Verbindungen

Zurzeit werden die Verbindungsarten TCP/IP Level 2 und Level 4 Routing unterstützt (Einstellbar in der Treiberkonfiguration).

Softwareinstallation - PC

Treiber 3S_ARTI_NG.EXE Datei ins aktuelle zenon Verzeichnis kopieren (wenn nicht bereits vorhanden).

Der Treiber benötigt die Bibliotheken ArtiClient.dll und SymArtiClient.dll. Diese Dlls sollten mit der CoDeSys-Software mit installiert werden. Sie stehen auf der COPA-DATA Webseite im Kundenbereich zum Download zur Verfügung.

info Info

Die Dateien ArtiClient.dll und SymArtiClient.dll müssen von der Version 2.4.2.3 oder neuer sein.

Softwareinstallation - CE

Der Treiber 3S_ARTI_NG.DLL, wird unter CE, über Remote-Transport, automatisch vom Editor auf das CE Gerät kopiert. Auch am CE Gerät werden die Dlls ArtiClient.dll und SymArtiClient.dll benötigt. Hier handelt es sich allerdings um eigene Dlls für Windows CE! Zurzeit gibt es Dlls für X86 und StrongArm Prozessoren. Auch diese Dlls sollen von 3S bezogen werden. Die Dateien müssen am CE Gerät ins Runtime Verzeichnis kopiert werden. (Wo auch die Dateien zenon6.ini, und zenonrce.exe liegen).

Unter Windows CE ist es nicht möglich, mehrere Treiber vom gleichen Typ zu verwenden.


Steuerung

3S_Arti_NG -> Voraussetzungen -> Steuerung

Für welche Steuerungen

Der Treiber 3S_ARTI_NG dient zur Anbindung an eine 3S CoDeSys Soft-SPS über die ARTI-Schnittstelle (Asynchronous RunTime Interface), die im Gegensatz zur normalen 3S-Schnittstelle (3S_32) auch den Einsatz unter Windows CE erlaubt


Konfiguration

3S_Arti_NG -> Konfiguration

In diesem Kapitel lesen Sie, wie Sie den Treiber im Projekt anlegen und welche Einstellungen beim Treiber möglich sind.

info Info

Weitere Einstellungen, die Sie für Variablen in zenon vornehmen können, finden Sie im Kapitel Variablen der Online-Hilfe.

Noch in diesem Kapitel

Anlegen eines Treibers

Einstellungen im Treiberdialog


Anlegen eines Treibers

3S_Arti_NG -> Konfiguration -> Anlegen eines Treibers

Um einen neuen Treiber anzulegen:

  1. Klicken Sie mit der rechten Maustaste im Projektmanager auf Treiber und selektieren Sie im Kontextmenü Treiber neu.
  2. In der folgenden Dialogbox bietet Ihnen das Programm eine Auflistung aller verfügbaren Treiber an.

  3. Selektieren Sie den gewünschten Treiber und vergeben Sie eine Bezeichnung für diesen:
    • Die Treiberbezeichnung muss eindeutig sein, d.h. wird ein und derselbe Treiber mehrmals im Projekt verwendet, so muss jeweils eine neue Bezeichnung vergeben werden.
    • Die Treiberbezeichnung ist Bestandteil des Dateinamens. Daher darf Sie nur Zeichen enthalten, die vom Betriebssystem unterstützt werden. Nicht gültige Zeichen werden durch einen Unterstrich (_) ersetzt.
    • Achtung: Die Bezeichnung kann später nicht mehr geändert werden.
  4. Bestätigen Sie den Dialog mit OK. Im folgenden Dialog werden die einzelnen Konfigurationen der jeweiligen Treiber eingestellt.

Für ein Projekt müssen nur die jeweils notwendigen Treiber eingebunden werden. Späteres Einbinden eines weiteren Treibers ist problemlos möglich.

info Info

Bei neu angelegten Projekten oder bei bestehenden Projekten, die in eine Version ab 6.21 konvertiert werden, werden die folgenden Treiber automatisch angelegt:

  • Intern
  • MathDr32
  • SysDrv.


Einstellungen im Treiberdialog

3S_Arti_NG -> Konfiguration -> Einstellungen im Treiberdialog

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Folgende Einstellungen können Sie beim Treiber vornehmen:

info Info

Die Datei <Treiberbezeichnung>.csv enthält alle Verbindungsinformationen. Die Verbindungen können im Konfigurationsdialog des Treibers definiert und verändert werden. Siehe dazu die „Treiberspezifikation".

Diese Datei finden Sie im Projektverzeichnis unter \RT\FILES\zenon\custom\drivers

Noch in diesem Kapitel

Allgemein

Treiberdialog CoDeSys

Treiberdialog Info


Allgemein

3S_Arti_NG -> Konfiguration -> Einstellungen im Treiberdialog -> Allgemein

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Beim Anlegen eines Treibers wird der Konfigurationsdialog geöffnet. Um den Dialog später zum Bearbeiten zu öffnen, führen Sie einen Doppelklick auf den Treiber in der Liste aus oder klicken Sie auf die Eigenschaft Konfiguration.

Parameter

Beschreibung

Modus

Ermöglicht ein Umschalten zwischen Hardware und Simulationsmodus

  • Hardware:

    Die Verbindung zur Steuerung wird hergestellt.

  • Simulation - statisch

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden vom Treiber simuliert. In diesem Modus bleiben die Werte konstant oder die Variablen behalten die über zenon Logic gesetzen Werte. Jede Variable hat seinen eigenen Speicherbereich. Zum Beispiel zwei Variablen vom Typ Merker mit Offset 79, können zur Runtime unterschiedliche Werte haben und beeinflussen sich gegenseitig nicht. Ausnahme: Der Simulatortreiber.

  • Simulation - zählend

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden vom Treiber simuliert. In diesem Modus zählt der Treiber die Werte innerhalb ihres Wertebereichs automatisch hoch.

  • Simulation - programmiert

    Es wird keine Kommunikation zur Steuerung aufgebaut, die Werte werden von einem frei programmierbaren Simulationsprojekt berechnet. Das Simulationsprojekt wird mit der zenon Logic Workbench erstellt und läuft in einer in den Treiber integrierten zenon Logic Runtime ab. Details siehe Kapitel Treibersimulation.

Update-Liste im Speicher Halten

Einmal angeforderte Variablen werden weiterhin von der Steuerung angefordert, auch wenn diese aktuell nicht mehr benötigt werden.
Dies hat den Vorteil, dass z B. mehrmalige Bildumschaltungen nach dem erstmaligen Aufschalten beschleunigt werden, da die Variablen nicht neu angefordert werden müssen. Der Nachteil ist eine erhöhte Belastung der Kommunikation zur Steuerung.

Ausgänge schreibbar

Aktiv: Ausgänge können beschrieben werden.

Inaktiv: Das Beschreiben der Ausgänge wird unterbunden.

Hinweis: Steht nicht für jeden Treiber zur Verfügungen.

Variablenabbild remanent

Diese Option speichert und restauriert den aktuellen Wert, den Zeitstempel und die Status eines Datenpunkts.

Grundvoraussetzung: Die Variable muss einen gültigen Wert und Zeitstempel besitzen.

Das Variablenabbild wird im Modus Hardware gespeichert wenn:

  • einer der Status S_MERKER_1(0) bis S_MERKER8(7), REVISION(9), AUS(20) oder ERSATZWERT(27) aktiv ist

Das Variablenabbild wird immer gespeichert wenn:

  • die Variable vom Objekttyp Treibervariable ist
  • der Treiber im Simulationsmodus läuft. (nicht programmierte Simulation)

Folgende Status werden beim Start der Runtime nicht restauriert:

  • SELECT(8)
  • WR-ACK(40)
  • WR-SUC(41)

Der Modus Simulation - programmiert beim Treiberstart ist kein Kriterium, um das remanente Variablenabbild zu restaurieren.

Am Standby Server stoppen

Einstellung für Redundanz bei Treibern, die nur eine Kommunikationsverbindung erlauben. Dazu wird der Treiber am Standby Server gestoppt und erst beim Hochstufen wieder gestartet.

Achtung: Ist diese Option aktiv, ist die lückenlose Archivierung nicht mehr gewährleistet.

Aktiv: Versetzt den Treiber am nicht-prozessführenden Server automatisch in einen Stopp-ähnlichen Zustand. Im Unterschied zum Stoppen über Treiberkommando erhält die Variable nicht den Status abgeschaltet, sondern einen leeren Wert. Damit wird verhindert, dass beim Hochstufen zum Server nicht relevante Werte in AML , CEL und Archiv erzeugt werden.

Hinweis: Nicht verfügbar, wenn CE Terminal als Datenserver dient. Weitere Informationen dazu erhalten Sie im Handbuch zenon Operator im Kapitel CE Terminal als Datenserver.

Update Zeit Global

Aktiv: Die eingestellte Globale Update Zeit in ms wird für alle Variablen im Projekt verwendet. Die bei den Variablen eingestellte Priorität wird nicht verwendet.
Inaktiv: Die eingestellten Prioritäten werden für die einzelnen Variablen verwendet.

Priorität

Hier werden die Pollingzeiten der einzelnen Prioritätsklassen eingestellt. Alle Variablen mit der entsprechenden Priorität werden in der eingestellten Zeit gepollt.

Die Zuordnung zu den Variablen erfolgt separat bei jeder Variablen über die Einstellungen in den Variableneigenschaften.
Mit den Prioritätsklassen kann die Kommunikation der einzelnen Variablen auf die Wichtigkeit oder benötigte Aktualität abgestuft werden. Daraus ergibt sich eine verbesserte Verteilung der Kommunikationslast.

Achtung: Prioritätsklassen werden nicht von jedem Treiber unterstützt. Zum Beispiel unterstützen spontan kommunizierende Treiber dies nicht.

Dialog beenden

Parameter | Beschreibung
OK | Übernimmt alle Änderungen in allen Registerkarten und schließt den Dialog.
Abbrechen | Verwirft alle Änderungen in allen Registerkarten und schließt den Dialog.
Hilfe | Öffnet die Online-Hilfe.

Update Zeit zyklische Treiber

Für zyklische Treiber gilt:

Beim Sollwert Setzen, Advisen von Variablen und bei Requests wird sofort ein Lesezyklus für alle Treiber ausgelöst - unabhängig von der eingestellten Update Zeit. Damit wird sicher gestellt, dass der Wert nach dem Schreiben in der Visualisierung sofort zur Verfügung steht. Update-Zeiten können damit für zyklische Treiber kürzer ausfallen als eingestellt.


Treiberdialog CoDeSys

3S_Arti_NG -> Konfiguration -> Einstellungen im Treiberdialog -> Treiberdialog CoDeSys

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Einstellung | Beschreibung
Neu | Dieser Button legt eine neue Verbindung an und öffnet anschließend den Dialog mit den Verbindungseinstellungen
Bearbeiten | Öffnet den Dialog mit den Verbindungseinstellungen für die momentan gewählte Verbindung aus der Liste.
Löschen | Löscht die momentan gewählte Verbindung in der Liste.
Ok | Übernimmt die Einstellungen und schließt den Dialog.
Abbrechen | Schließt den Dialog ohne die Einstellungen zu übernehmen.

Dialog für die Verbindungseinstellungen

Einstellung

Beschreibung

Verbindungsname

Frei wählbarer Name für die Verbindung.

Netzadresse

Eindeutige Nummer der Verbindung. Muss der Eigenschaft Netzadresse in den Eigenschaften der Variablen entsprechen.

Lokal

Die anzusprechende Steuerung läuft lokal auf dem selben Rechner.

Remote

Die Steuerung lauft auf einem Rechner im Netzwerk. Klick auf die Schaltfläche ... öffnet Dialog zur Auswahl eines rechners im Netzwerk.

Port

Die Portnummer der Steuerung.

  • Default CoDeSys: 1200
  • Default EPAS: 5000

Protokoll

Auswahl eines Kommunikationsprotokolls.

(TCP/IP Level 2 Route oder Level 4)

Buffergröße

Größe des Kommunikationspuffers.

  • Default CoDeSys: 5000
  • Default EPAS: 1500

Timeout

Aktiv: Angabe eines Timeouts für die ARTIClient.dll in Millisekunden (ms).

Inaktiv: Der Default-Timeout (ARTI_INFINITE … unendlich) wird angewendet.

Login verwenden

Aktiv: Öffnet einen Kommunikationskanal

Motorola Byteordner

Ermöglicht Kommunikation mit Motorola CPU.

Default CoDeSys

Setzt die Defaulteinstellungen für CoDeSys Steuerungen.

Achtung: Die bestehenden Einstellungen werden überschrieben!

Default EPAS

Setzt die Defaulteinstellungen für EPAS Steuerungen.

Achtung: Die bestehenden Einstellungen werden überschrieben!

Ok

Übernimmt die Einstellungen und schließt den Dialog.

Abbrechen

Schließt den Dialog ohne die Einstellungen zu übernehmen.


Treiberdialog Info

3S_Arti_NG -> Konfiguration -> Einstellungen im Treiberdialog -> Treiberdialog Info

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Auf der Infopage wird die Version der ARTI Library und die Treiberversion angegeben.


Variablen anlegen

3S_Arti_NG -> Variablen anlegen

So werden Variablen im zenon Editor angelegt:

Noch in diesem Kapitel

Variablen im Editor anlegen

Adressierung

Treiberobjekte und Datentypen

Variablen anlegen durch Import

Treibervariablen


Variablen im Editor anlegen

3S_Arti_NG -> Variablen anlegen -> Variablen im Editor anlegen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Variablen können angelegt werden:

  • als einfache Variable
  • in Arrays
  • als Struktur-Variablen

Dialog Variable

Um eine neue Variable zu erstellen, gleich welchen Typs:

  1. wählen Sie im Knoten Variablen im Kontextmenü den Befehl Variable neu

  2. der Dialog zur Konfiguration der Variable wird geöffnet
  3. konfigurieren Sie die Variable
  4. welche Einstellungen möglich sind, hängt ab vom Typ der Variablen

Eigenschaft

Beschreibung

Name

Eindeutiger Name der Variablen. Ist eine Variable mit gleichem Namen im Projekt bereits vorhanden, kann keine weitere Variable mit diesem Namen angelegt werden.

Maximale Länge: 128 Zeichen

Achtung: Die Zeichen # und @ sind für Variablennamen nicht erlaubt. Bei Verwendung nicht zugelassener Zeichen kann die Variablenerstellung nicht abgeschlossen werden, die Schaltfläche Fertigstellen bleibt inaktiv.
Hinweis: Manche Treiber erlauben die Adressierung auch über die Eigenschaft Symbolische Adresse.

Treiber

Wählen Sie aus der Dropdownliste den gewünschten Treiber.

Hinweis: Sollte im Projekt noch kein Treiber angelegt sein, wird automatisch der Treiber für interne Variable (Intern.exe) geladen.

Treiber-Objekttyp

Wählen Sie aus der Dropdownliste den passenden Treiber-Objekttyp aus.

Datentyp

Wählen Sie den gewünschten Datentyp. Klick auf die Schaltfläche ... öffnet den Auswahl-Dialog.

Array-Einstellungen

Erweiterte Einstellungen für Array-Variablen. Details dazu lesen Sie im Abschnitt Arrays.

Adressierungsoptionen

Erweiterte Einstellungen für Arrays und Struktur-Variablen. Details dazu lesen Sie im jeweiligen Abschnitt.

Automatische Elementeaktivierung

Erweiterte Einstellungen für Arrays und Struktur-Variablen. Details dazu lesen Sie im jeweiligen Abschnitt.

Symbolische Adresse

Die Eigenschaft Symbolische Adresse kann für die Adressierung alternativ zu Name oder Kennung der Variablen verwendet werden. Die Auswahl erfolgt im Treiberdialog, die Konfiguration in der Variableneigenschaft. Beim Import von Variablen unterstützter Treiber wird die Eigenschaft automatisch eingetragen.

Maximale Länge: 1024 Zeichen.

Ableitung vom Datentyp

Messbereich, Signalbereich und Sollwert Setzen werden immer:

  • vom Datentyp abgeleitet
  • beim Ändern des Datentyps automatisch angepasst

Hinweis Signalbereich: Bei einem Wechsel auf einen Datentyp, der den eingestellten Signalbereich nicht unterstützt, wird der Signalbereich automatisch angepasst. Zum Beispiel wird bei einem Wechsel von INT auf SINT der Signalbereich auf 127 geändert. Die Anpassung erfolgt auch dann, wenn der Signalbereich nicht vom Datentyp abgeleitet wurde. In diesem Fall muss der Messbereich manuell angepasst werden.


Adressierung

3S_Arti_NG -> Variablen anlegen -> Adressierung

Gruppe/Eigenschaft

Beschreibung

Allgemein

Name

Frei vergebbarer Name.

Achtung: Je zenon Projekt muss der Name eindeutig sein.

Kennung

Frei vergebbare Kennung, z. B. für Betriebsmittelkennung, Kommentar...

Adressierung

Netzadresse

Busadresse oder Netzadresse der Variablen.

Diese Adresse bezieht sich auf die Busadresse der Verbindungsprojektierung im Treiber. Damit wird ausgewählt auf welcher Steuerung sich die Variable befindet.

Datenbaustein

Für Variablen vom Objekttyp Erweiterter Datenbaustein muss hier die Datenbaustein-Nummer angegeben werden.

Einstellbar von 0 bis 4294967295 . Den genauen maximalen Bereich für Datenbausteine entnehmen Sie dem Handbuch für die Steuerung.

Offset

Offset der Variablen, die Speicheradresse der Variable in der Steuerung. Einstellbar von 0 bis 4294967295 .

Ausrichtung

Wird für diesen Treiber nicht verwendet.

Bitnummer

Nummer des Bits innerhalb des eingestellten Offsets.

Mögliche Eingabe: 0 ... 65535

Stringlänge

Nur verfügbar bei String-Variablen: Maximale Anzahl von Zeichen, die die Variable aufnehmen kann.

Treiber Anbindung/Datentyp

Datentyp der Variablen. Wird beim Erstellen der Variablen ausgewählt und kann hier geändert werden.

ACHTUNG: Wenn der Datentyp nachträglich geändert wird, müssen alle anderen Eigenschaften der Variablen überprüft bzw. angepasst werden.

Treiber Anbindung/Treiberobjekttyp

Objekttyp der Variablen. Wird abhängig vom verwendeten Treiber beim Erstellen der Variablen ausgewählt und kann hier geändert werden.

Treiber Anbindung/Priorität

Ordnet einer Variablen eine Priorität für die Updatezeit zu.

Symbol Name

Wird beim online Import automatisch gesetzt.

Variablenzuordnung in zenon

Dem Variablennamen wird als Präfix die Netzadresse (Stationsadresse) mit einem Punkt [.] als Trennzeichen vorgestellt. Der Symbolname ist der gleiche Name wie im SPS-Programm verwendet.

Variablenadressierung über Symbolname

Variablen können über einen Symbolnamen angesprochen werden. Damit können Variablen in zenon unabhängig von der Benennung in der SPS benannt werden. Um für eine Variable einen Symbolnamen zu erstellen:

  1. navigieren Sie in den Variableneigenschaften zum Knoten Adressierung
  2. navigieren Sie zur Gruppe 3S Arti specific
  3. vergeben Sie im Eingabefeld der Eigenschaft Symbol name einen Symbolnamen für die Variable in der SPS

Adressierung von Binärvariablen

Der 3S_Arti Treiber benutzt für die Kommunikation mit der SPS den Symbolnamen. Um in einem INT einzelne Bits anzusprechen, werden:

  1. ein INT von der SPS importiert
    und dann
  2. manuell 16 Binärevariablen mit jeweils dem Symbolnamen und einer Bitnummern zwischen 0 und 15 erstellt

Änderung Präfix für Variable

Das Präfix der Variablen kann auch später geändert werden. Änderungen haben unterschiedliche Auswirkungen auf die Kommunikation und den Import von Variablen.

Kommunikation

Wird das Präfix geändert, funktioniert die Kommunikation weiter. Denn für die Kommunikation werden die Netzadresse der Variablen und der Symbolname verwendet. Die Variable braucht für die Kommunikation kein Präfix und muss nicht dem Symbolnamen entsprechen.

Import

Eine Änderung des Präfix beeinflusst den Online- und Offline-Import. Eine Änderung hat folgende Auswirkungen auf den Import:

  • Das Suchen nach neue Variablen funktioniert nicht mehr.
    Alle Variablen werden als neu gekennzeichnet, da für den Import keine Variablen mit dieser Netzadresse existieren.
  • Die Suche nach gelöschten Variablen funktioniert nicht mehr.
    Variablen, die im SPS Programm gelöscht wurden, aber in zenon noch vorhanden sind, werden nicht erkannt. Denn für den Import existieren keine Variablen mit dieser Netzadresse in zenon.
  • Das Zusammenführen (Mergen) beim Ändern des Datentyps funktioniert nicht mehr.
    Beim Import wird die Variable in zenon nicht gefunden.


Treiberobjekte und Datentypen

3S_Arti_NG -> Variablen anlegen -> Treiberobjekte und Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Treiberobjekte sind in der Steuerung verfügbare Bereiche wie z. B. Merker, Datenbausteine usw. Hier lesen Sie, welche Treiberobjekte vom Treiber zur Verfügung gestellt werden und welche IEC-Datentypen dem jeweiligen Treiberobjekt zugeordnet werden können.

Noch in diesem Kapitel

Treiberobjekte

Zuordnung der Datentypen


Treiberobjekte

3S_Arti_NG -> Variablen anlegen -> Treiberobjekte und Datentypen -> Treiberobjekte

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Folgende Objekttypen stehen in diesem Treiber zur Verfügung:

Treiberobjekttyp | Kanaltyp | Lesen | Schreiben | Unterstützte Datentypen | Kommentar
SPS-Merker | 8 | X | X | LREAL, WORD, DWORD, REAL, DATE_AND_TIME, DINT, UDINT, INT, UINT, TOD, STRING, BOOL, USINT, SINT |
Treibervariable | 35 | X | X | BOOL, SINT, USINT, INT, UINT, DINT, UDINT, REAL, STRING | Variablen zur statistischen Auswertung der Kommunikation. Weitere Infos finden Sie bei den Treibervariablen

Treiber Objekttypen | Kanaltyp | Untersützte Datentypen (Datenart) | Lesen | Schreiben | Kommentar
Merker | 8 | BOOL | X | X |
Merker | 8 | DATE_AND_TIME | X | X |
Merker | 8 | DINT | X | X |
Merker | 8 | INT | X | X |
Merker | 8 | LREAL | X | X |
Merker | 8 | REAL | X | X |
Merker | 8 | SINT | X | X |
Merker | 8 | STRING | X | X |
Merker | 8 | TOD | X | X |
Merker | 8 | UDINT | X | X |
Merker | 8 | UINT | X | X |
Merker | 8 | USINT | X | X |


Zuordnung der Datentypen

3S_Arti_NG -> Variablen anlegen -> Treiberobjekte und Datentypen -> Zuordnung der Datentypen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Alle Variablen in zenon werden von IEC-Datentypen abgeleitet. In folgender Tabelle werden zur besseren Übersicht die IEC-Datentypen den Datentypen der Steuerung gegenübergestellt.

Beispiele für alle möglichen IEC Datentypen

SPS | zenon
BOOL | BOOL
DT oder DATE_AND_TIME | DATE_AND_TIME
DINT | DINT
INT | INT
LREAL | LREAL
REAL | REAL
SINT | SINT
STRING | STRING
TOD oder TIME_OF_DAY | TOD
UDINT | UDINT
UINT | UINT
USINT | USINT
WORD | WORD
DWORD | DWORD

Datenart: Die Eigenschaft Datenart ist die interne numerische Bezeichnung des Datentyps. Diese wird auch für den erweiterten DBF Import/Export der Variablen verwendet.


Variablen anlegen durch Import

3S_Arti_NG -> Variablen anlegen -> Variablen anlegen durch Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Variablen können auch mittels Variablenimport angelegt werden. Für jeden Treiber stehen XML- und DBF-Import zur Verfügung.

info Info

Details zu Import und Export von Variablen finden Sie im Handbuch Import-Export im Abschnitt Variablen.

Noch in diesem Kapitel

XML Import

DBF Import/Export

Online-Import


XML Import

3S_Arti_NG -> Variablen anlegen -> Variablen anlegen durch Import -> XML Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Für den Import/Export von Variablen gilt:

  • Der Import/Export darf nicht aus dem Globalprojekt gestartet werden.
  • Der Start erfolgt über:
    • Kontextmenü zu Variablen oder Datentyp im Projektbaum
    • oder Kontextmenü einer Variablen oder eines Datentyps
    • oder Symbol in der Symbolleiste Variablen

attention Achtung

Beim Import/Überschreiben von existierenden Datentypen werden alle Variablen geändert, die auf diesem existierenden Datentyp basieren.

Beispiel:

Es existiert ein Datentyp XYZ abgeleitet vom Typ INT mit Variablen, die auf diesem Datentyp basieren. Ihre zu importierende XML-Datei enthält ebenfalls einen Datentyp mit Namen XYZ, allerdings abgeleitet vom Typ STRING. Wird dieser Datentyp importiert, so wird der existierende Datentyp überschrieben und bei allen auf ihm basierenden Variablen der Typ angepasst. D.h. die Variablen sind jetzt STRING- und keine INT-Variablen mehr.


DBF Import/Export

3S_Arti_NG -> Variablen anlegen -> Variablen anlegen durch Import -> DBF Import/Export

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Daten können nach dBase exportiert und aus dBase importiert werden.

info Info

Import und Export über CSV oder dBase unterstützt keine treiberspezifischen Variableneinstellungen wie z. B. Formeln. Nutzen Sie dafür den Export/Import über XML.

Import DBF-Datei

Um den Import zu starten:

  1. führen Sie einen Rechtsklick auf die Variablenliste aus
  2. wählen Sie in der Dropdownliste von Erweiterter Export/Import ... den Befehl dBase importieren
  3. folgen Sie dem Importassistenten

Das Format der Datei ist im Kapitel Dateiaufbau beschrieben.

info Info

Beachten Sie:

  • Treiberobjekttyp und Datentyp müssen in der DBF-Datei an den Zieltreiber angepasst werden, damit Variablen importiert werden.
  • dBase unterstützt beim Import keine Strukturen oder Arrays (komplexe Variablen).

Export DBF-Datei

Um den Export zu starten:

  1. führen Sie einen Rechtsklick auf die Variablenliste aus
  2. wählen Sie im Dropdownliste von Erweiterter Export/Import ... den Befehl dBase exportieren...
  3. folgen Sie dem Exportassistenten

attention Achtung

DBF-Dateien:

  • müssen in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • dürfen im Pfadnamen keinen Punkt (.) enthalten.
    Z. B. ist der Pfad C:\users\Max.Mustermann\test.dbf ungültig.
    Gültig wäre: C:\users\MaxMustermann\test.dbf
  • müssen nahe am Stammverzeichnis (Root) abgelegt werden, um die eventuelle Beschränkungen für Dateinamenlänge inklusive Pfad zu erfüllen: maximal 255 Zeichen

Das Format der Datei ist im Kapitel Dateiaufbau beschrieben.

info Info

dBase unterstützt beim Export keine Strukturen oder Arrays (komplexe Variablen).

Dateiaufbau der dBase Exportdatei

Für den Variablenimport und -export muss die dBaseIV-Datei folgende Struktur und Inhalte besitzen.

attention Achtung

dBase unterstützt keine Strukturen oder Arrays (komplexe Variablen).

DBF-Dateien müssen:

  • in der Benennung dem 8.3 DOS Format für Dateinamen entsprechen (8 alphanumerische Zeichen für Name, 3 Zeichen Erweiterung, keine Leerzeichen)
  • nahe am Stammverzeichnis (Root) abgelegt werden

Struktur

Bezeichnung | Typ | Feldgröße | Bemerkung
KANALNAME | Char | 128 | Variablenname. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_R | C | 128 | Ursprünglicher Name einer Variablen, der durch den Eintrag unter VARIABLENNAME ersetzt werden soll (Feld/Spalte muss manuell angelegt werden). Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
KANAL_D | Log | 1 | Variable wird bei Eintrag 1 gelöscht (Feld/Spalte muss manuell angelegt werden).
TAGNR | C | 128 | Kennung. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
EINHEIT | C | 11 | Technische Maßeinheit
DATENART | C | 3 | Datentyp (z. B. Bit, Byte, Wort, ...) entspricht dem Datentyp.
KANALTYP | C | 3 | Speicherbereich in der SPS (z. B. Merkerbereich, Datenbereich, ...) entspricht Treiber-Objekttyp.
HWKANAL | Num | 3 | Bus-Adresse
BAUSTEIN | N | 3 | Datenbaustein-Adresse (nur bei Variablen aus den Datenbereich der SPS)
ADRESSE | N | 5 | Offset
BITADR | N | 2 | Für Bit-Variablen: Bitadresse Für Byte-Variablen: 0=niederwertig, 8=höherwertig Für String-Variablen: Stringlänge (max. 63 Zeichen)
ARRAYSIZE | N | 16 | Anzahl der Variablen im Array für Index-Variablen ACHTUNG: Nur die erste Variable steht voll zur Verfügung. Alle folgenden sind nur über VBA oder den Rezeptgruppen Manager zugänglich
LES_SCHR | L | 1 | Lese-Schreib-Berechtigung 0: Sollwert setzen ist nicht erlaubt 1: Sollwert setzen ist erlaubt
MIT_ZEIT | L | 1 | Zeitstempelung in zenon (nur wenn vom Treiber unterstützt)
OBJEKT | N | 2 | Treiberspezifische ID-Nummer des Primitivobjekts setzt sich zusammen aus TREIBER-OBJEKTTYP und DATENTYP
SIGMIN | Float | 16 | Rohwertsignal minimal (Signalauflösung)
SIGMAX | F | 16 | Rohwertsignal maximal (Signalauflösung)
ANZMIN | F | 16 | technischer Wert minimal (Messbereich)
ANZMAX | F | 16 | technischer Wert maximal (Messbereich)
ANZKOMMA | N | 1 | Anzahl der Nachkommastellen für die Darstellung der Werte (Messbereich)
UPDATERATE | F | 19 | Updaterate für Mathematikvariablen (in sec, eine Dezimalstelle möglich) bei allen anderen Variablen nicht verwendet
MEMTIEFE | N | 7 | Nur aus Kompatibilitätsgründen vorhanden
HDRATE | F | 19 | HD-Updaterate für hist. Werte (in sec, eine Dezimalstelle möglich)
HDTIEFE | N | 7 | HD-Eintragtiefe für hist. Werte (Anzahl)
NACHSORT | L | 1 | HD-Werte als nachsortierte Werte
DRRATE | F | 19 | Aktualisierung an die Ausgabe (für zenon DDE-Server, in sec, eine Kommastelle möglich)
HYST_PLUS | F | 16 | Positive Hysterese; ausgehend vom Messbereich
HYST_MINUS | F | 16 | Negative Hyterese; ausgehend vom Messbereich
PRIOR | N | 16 | Priorität der Variable
REAMATRIZE | C | 32 | Name der zugeordnete Reaktionsmatrix
ERSATZWERT | F | 16 | Ersatzwert; ausgehend vom Messbereich
SOLLMIN | F | 16 | Sollwertgrenze Minimum; ausgehend vom Messbereich
SOLLMAX | F | 16 | Sollwertgrenze Maximum; ausgehend vom Messbereich
VOMSTANDBY | L | 1 | Variable vom Standby Server anfordern; der Wert der Variable wird im redundanten Netzwerkbetrieb nicht vom Server sondern vom Standby Server angefordert
RESOURCE | C | 128 | Betriebsmittelkennung. Freier String für Export und Anzeige in Listen. Länge kann über den Eintrag MAX_LAENGE in der project.ini eingeschränkt werden.
ADJWVBA | L | 1 | Nichtlineare Wertanpassung: 0: Nichtlineare Wertanpassung wird verwendet 1: Nichtlineare Wertanpassung wird nicht verwendet
ADJZENON | C | 128 | Verknüpftes VBA-Makro zum Lesen der Variablenwerte für die nichtlineare Wertanpassung.
ADJWVBA | C | 128 | Verknüpftes VBA-Makro zum Schreiben der Variablenwerte für die nichtlineare Wertanpassung.
ZWREMA | N | 16 | Verknüpfte Zählwert-Rema.
MAXGRAD | N | 16 | Maximaler Gradient für die Zählwert-Rema.
attention Achtung
Beim Import müssen Treiberobjekttyp und Datentyp in der DBF-Datei an den Zieltreiber angepasst werden, damit Variablen importiert werden.

Grenzwertdefinition

Grenzwertdefinition für Grenzwert 1 bis 4, oder Zustand 1 bis 4:

Bezeichnung | Typ | Feldgröße | Bemerkung
AKTIV1 | L | 1 | Grenzwert aktiv (pro Grenzwert vorhanden)
GRENZWERT1 | F | 20 | technischer Wert oder ID-Nummer der verknüpften Variable für einen dynamischen Grenzwert (siehe VARIABLEx) (wenn unter VARIABLEx 1 steht und hier -1, wird die bestehende Variablenzuordnung nicht überschrieben)
SCHWWERT1 | F | 16 | Schwellwert für den Grenzwert
HYSTERESE1 | F | 14 | wird nicht verwendet
BLINKEN1 | L | 1 | Blinkattribut setzen
BTB1 | L | 1 | Protokollierung in CEL
ALARM1 | L | 1 | Alarm
DRUCKEN1 | L | 1 | Druckerausgabe (bei CEL oder Alarm)
QUITTIER1 | L | 1 | quittierpflichtig
LOESCHE1 | L | 1 | löschpflichtig
VARIABLE1 | L | 1 | dyn. Grenzwertverknüpfung der Grenzwert wird nicht durch einen absoluten Wert (siehe Feld GRENZWERTx) festgelegt.
FUNC1 | L | 1 | Funktionsverknüpfung
ASK_FUNC1 | L | 1 | Ausführung über die Alarmmeldeliste
FUNC_NR1 | N | 10 | ID-Nummer der verknüpften Funktion (steht hier -1, so wird die bestehende Funktion beim Import nicht überschrieben)
A_GRUPPE1 | N | 10 | Alarm/Ereignis-Gruppe
A_KLASSE1 | N | 10 | Alarm/Ereignis-Klasse
MIN_MAX1 | C | 3 | Minimum, Maximum
FARBE1 | N | 10 | Farbe als Windowskodierung
GRENZTXT1 | C | 66 | Grenzwerttext
A_DELAY1 | N | 10 | Zeitverzögerung
INVISIBLE1 | L | 1 | Unsichtbar

Bezeichnungen in der Spalte Bemerkung beziehen sich auf die in den Dialogboxen zur Definition von Variablen verwendeten Begriffe. Bei Unklarheiten, siehe Kapitel Variablendefinition.


Online-Import

3S_Arti_NG -> Variablen anlegen -> Variablen anlegen durch Import -> Online-Import

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Über den Online-Import können Variablen aus einer Steuerung ausgelesen oder von einer *.SYM_XML Datei importiert werden. Werden viele Variablen online importiert, reicht eventuell die eingestellte Buffergröße nicht aus. Diese muss dann im Dialogfenster CoDeSys erhöht werden.

Um Variablen online zu importieren:

  1. selektieren Sie den Treiber
  2. wählen Sie im Kontextmenü Variablen vom treiber importieren
  3. wählen Sie zwischen:
    • Symboldatei und
    • browsen via ARTI
  4. folgen Sie dem Importassistenten

Parameter | Beschreibung
Load variables from "*.SYM_XML" symbols file | Variablen aus einer XML Symboldatei einlesen.
Browse variables via ARTI | Variablen direkt von der Steuerung einlesen.

Im nächsten Schritt werden die Dateien aus einer Symboldatei oder direkt aus ARTI importiert. Danach erfolgt die Vorauswahl und Zuordnung der Variablen.

Noch in diesem Kapitel

Import aus einer Symboldatei

Import via ARTI

Vorauswahl und Zuordnung der Variablen


Import aus einer Symboldatei

3S_Arti_NG -> Variablen anlegen -> Variablen anlegen durch Import -> Online-Import -> Import aus einer Symboldatei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Für den XML Import muss eine Station (Netzadresse) und die entsprechende Symboldatei ausgewählt werden. Die zur Auswahl stehenden Stationen wurden zuvor in der Treiberkonfiguration angelegt.

Parameter | Beschreibung
Station | Die Station, für welche die Variablen angelegt werden sollen.
3S symbol file | Dateipfad der XML Symboldatei.

Im nächsten Schritt erfolgt die Vorauswahl und Zuordnung der Variablen.


Import via ARTI

3S_Arti_NG -> Variablen anlegen -> Variablen anlegen durch Import -> Online-Import -> Import via ARTI

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Beim Import über die ARTI-Schnittstelle muss die auszulesende Station ausgewählt werden. Diese muss zuvor in der Treiberkonfiguration angelegt worden sein.

Parameter | Beschreibung
Select a station to browse | Auswahl der Station, aus der die Variablen gelesen werden sollen.

Im nächsten Schritt erfolgt die Vorauswahl und Zuordnung der Variablen.


Vorauswahl und Zuordnung der Variablen

3S_Arti_NG -> Variablen anlegen -> Variablen anlegen durch Import -> Online-Import -> Vorauswahl und Zuordnung der Variablen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Um die Auswahlliste einzuschränken, ist es möglich, die zu importierenden Variablen vorzufiltern:

Parameter | Beschreibung
Name | Filterausdruck für den Symbolnamen. Wildcards sind erlaubt. (Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.)
Type | Filterausdruck für den Symboltyp. Wildcards sind erlaubt. (Wildcards sind nur als Präfix oder Suffix zugelassen, also *xxx oder xxx*.)
Import all matched symbols | Es werden alle Symbole aus der Importquelle angeboten, die dem Filter Name bzw. Typ entsprechen.
Import only new symbols | Es werden alle Symbole aus der Importquelle angeboten, die dem Filter Name bzw. Typ entsprechen und noch nicht in zenon angelegt wurden. Dabei wird der Symbolname mit dem in zenon erstellten Variablennamen verglichen. Achtung: Funktioniert nur, wenn nach dem Import der zenon Variablenname nicht verändert wurde!
Delete old symbols | Es werden alle zenon Variablen zum Löschen angeboten, die in der Importquelle nicht vorhanden sind. Dazu werden die Symbolnamen mit den Adresseinstellungen der zenon Variable verglichen. Bei dieser Auswahl kann nicht nach Name oder Typ gefiltert werden. Achtung: Nach dem Auswählen und Bestätigen des Dialogs werden die Variablen in zenon gelöscht!

Beim Filtern von Namen und Typen muss auf die Groß- bzw. Kleinschreibung geachtet werden.

Auswahldialog

Nach dem Einlesen der Symbole kann eine Auswahl als zenon Variablen importiert werden.

Parameter | Beschreibung
Ok | Die gewählten Symbole sollen in zenon als Variablen angelegt werden.
Abbrechen | Der Import soll abgebrochen werden.
Hinzufügen | Die gewählten Symbole soll zur Auswahlliste hinzugefügt werden.
Entfernen | Die gewählten Symbole soll aus der Auswahlliste entfernt werden.

Variablenzuordnung in zenon

Beim Import in zenon wird dem Variablennamen die Netzadresse (Stationsadresse) mit einem Punkt als Trennzeichen vorgestellt. Der Symbolname entspricht dem Namen, wie er im SPS-Programm verwendet wird. Zum Beispiel:

Variablenname: 0.PLC_PRG.Timer1.IN

Symbolname: PLC_PRG.Timer1.IN


Treibervariablen

3S_Arti_NG -> Variablen anlegen -> Treibervariablen

Das Treiberkit implementiert eine Reihe von Treibervariablen. Diese sind unterteilt in:

  • Information
  • Konfiguration
  • Statistik und
  • Fehlermeldungen

Die Definitionen der im Treiberkit implementierten Variablen sind in der Importdatei drvvar.dbf (auf der Installationsmedium im Ordner \Predefined\Variables) verfügbar und können von dort importiert werden.

Hinweis: Variablennamen müssen in zenon einzigartig sein. Soll nach einem Import der Treibervariablen aus drvvar.dbf ein erneuter Import durchgeführt werden, müssen die zuvor importierten Variablen umbenannt werden.

info Info

Nicht jeder Treiber unterstützt alle Treibervariablen.

Zum Beispiel werden:

  • Variablen für Modem-Informationen nur von modemfähigen Treibern unterstützt
  • Treibervariablen für den Polling-Zyklus nur für rein pollenden Treibern
  • verbindungsbezogene Informationen wie ErrorMSG nur von Treibern, die zu einem Zeitpunkt nur eine Verbindung bearbeiten

Information

Name aus Import | Typ | Offset | Erklärung
MainVersion | UINT | 0 | Haupt-Versionsnummer des Treibers.
SubVersion | UINT | 1 | Sub-Versionsnummer des Treibers.
BuildVersion | UINT | 29 | Build-Versionsnummer des Treibers.
RTMajor | UINT | 49 | zenon Hauptversionsnummer
RTMinor | UINT | 50 | zenon Sub-Versionsnummer
RTSp | UINT | 51 | zenon Service Pack-Nummer
RTBuild | UINT | 52 | zenon Buildnummer
LineStateIdle | BOOL | 24.0 | TRUE, wenn die Modemleitung belegt ist.
LineStateOffering | BOOL | 24.1 | TRUE, wenn ein Anruf rein kommt.
LineStateAccepted | BOOL | 24.2 | Der Anruf wird angenommen.
LineStateDialtone | BOOL | 24.3 | Rufton wurde erkannt.
LineStateDialing | BOOL | 24.4 | Wahl aktiv.
LineStateRingBack | BOOL | 24.5 | Während Verbindungsaufbau.
LineStateBusy | BOOL | 24.6 | Zielstation besetzt.
LineStateSpecialInfo | BOOL | 24.7 | Spezielle Statusinformation empfangen.
LineStateConnected | BOOL | 24.8 | Verbindung hergestellt.
LineStateProceeding | BOOL | 24.9 | Wahl ausgeführt.
LineStateOnHold | BOOL | 24.10 | Verbindung in Halten.
LineStateConferenced | BOOL | 24.11 | Verbindung im Konferenzmodus.
LineStateOnHoldPendConf | BOOL | 24.12 | Verbindung in Halten für Konferenz.
LineStateOnHoldPendTransfer | BOOL | 24.13 | Verbindung in Halten für Transfer.
LineStateDisconnected | BOOL | 24.14 | Verbindung beendet.
LineStateUnknow | BOOL | 24.15 | Verbindungszustand nicht bekannt.
ModemStatus | UDINT | 24 | Aktueller Modemstatus.
TreiberStop | BOOL | 28 | Treiber gestoppt Bei Treiberstop, hat die Variable den Wert TRUE und ein OFF-Bit. Nach dem Treiberstart, hat die Variable den Wert FALSE und kein OFF-Bit.
SimulRTState | UDINT | 60 | Informiert über Status der Runtime bei Treibersimulation.

Konfiguration

Name aus Import | Typ | Offset | Erklärung
ReconnectInRead | BOOL | 27 | Wenn TRUE, dann wird beim Lesen automatisch ein Neuaufbau der Verbindung durchgeführt.
ApplyCom | BOOL | 36 | Änderungen an den Einstellungen der seriellen Schnittstelle zuweisen. Das Schreiben auf diese Variable hat unmittelbar den Aufruf der Methode SrvDrvVarApplyCom zur Folge (aktuell ohne weitere Funktion).
ApplyModem | BOOL | 37 | Änderungen an den Modemeinstellungen zuweisen. Das Schreiben auf diese Variable hat unmittelbar den Aufruf der Methode SrvDrvVarApplyModem zur Folge. Diese schließt die aktuelle Verbindung und öffnet eine neue entsprechend den Einstellungen PhoneNumberSet und ModemHwAdrSet.
PhoneNumberSet | STRING | 38 | Telefonnummer, welche verwendet werden soll.
ModemHwAdrSet | DINT | 39 | Hardwareadresse, welche zu der Telefonnummer gehört.
GlobalUpdate | UDINT | 3 | Updatezeit in Millisekunden (ms).
BGlobalUpdaten | BOOL | 4 | TRUE, wenn die Updatezeit global ist.
TreiberSimul | BOOL | 5 | TRUE, wenn der Treiber in Simulation ist.
TreiberProzab | BOOL | 6 | TRUE, wenn das Prozessabbild gehalten werden soll.
ModemActive | BOOL | 7 | TRUE, wenn das Modem bei diesem Treiber aktiv ist.
Device | STRING | 8 | Name der seriellen Schnittstelle oder Name des Modem.
ComPort | UINT | 9 | Nummer der seriellen Schnittstelle.
Baudrate | UDINT | 10 | Baudrate der seriellen Schnittstelle.
Parity | SINT | 11 | Parität der seriellen Schnittstelle.
ByteSize | USINT | 14 | Bitanzahl pro Zeichen der seriellen Schnittstelle. Wert = 0, wenn der Treiber keine serielle Kommunikation herstellen kann.
StopBit | USINT | 13 | Anzahl der Stoppbits der seriellen Schnittstelle.
Autoconnect | BOOL | 16 | TRUE, wenn die Modemverbindung automatisch beim Lesen/Schreiben aufgebaut werden soll.
PhoneNumber | STRING | 17 | Aktuelle Telefonnummer.
ModemHwAdr | DINT | 21 | Hardwareadresse zur aktuellen Telefonnummer.
RxIdleTime | UINT | 18 | Wenn länger als diese Zeit in Sekunden (s) erfolgreich kein Datenverkehr stattfindet, wird die Modemverbindung beendet.
WriteTimeout | UDINT | 19 | Maximale Schreibdauer bei einer Modemverbindung in Millisekunden (ms).
RingCountSet | UDINT | 20 | So oft läutet ein hereinkommender Anruf, bevor dieser angenommen wird.
ReCallIdleTime | UINT | 53 | Wartezeit zwischen Anrufen in Sekunden (s).
ConnectTimeout | UINT | 54 | Zeit in Sekunden (s) für Verbindungsaufbau.

Statistik

Name aus Import | Typ | Offset | Erklärung
MaxWriteTime | UDINT | 31 | Längste Zeit in Millisekunden (ms), die zum Schreiben benötigt wird.
MinWriteTime | UDINT | 32 | Kürzeste Zeit in Millisekunden (ms), die zum Schreiben benötigt wird.
MaxBlkReadTime | UDINT | 40 | Längste Zeit in Millisekunden (ms), die zum Lesen eines Datenblocks benötigt wird.
MinBlkReadTime | UDINT | 41 | Kürzeste Zeit in Millisekunden (ms), die zum Lesen eines Datenblocks benötigt wird.
WriteErrorCount | UDINT | 33 | Anzahl der Schreibfehler.
ReadSucceedCount | UDINT | 35 | Anzahl der erfolgreichen Leseversuche.
MaxCycleTime | UDINT | 22 | Längste Zeit in Millisekunden (ms), die zum Lesen aller angeforderten Daten benötigt wurde.
MinCycleTime | UDINT | 23 | Kürzeste Zeit in Millisekunden (ms), die zum Lesen aller angeforderten Daten benötigt wurde.
WriteCount | UDINT | 26 | Anzahl der Schreibversuche.
ReadErrorCount | UDINT | 34 | Anzahl der fehlerhaften Leseversuche.
MaxUpdateTimeNormal | UDINT | 56 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Normal in Millisekunden (ms).
MaxUpdateTimeHigher | UDINT | 57 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Höher in Millisekunden (ms).
MaxUpdateTimeHigh | UDINT | 58 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Hoch in Millisekunden (ms).
MaxUpdateTimeHighest | UDINT | 59 | Zeit seit letzter Aktualisierung der Prioritätsgruppe Höchste in Millisekunden (ms).
PokeFinish | BOOL | 55 | Geht für eine Abfrage auf 1, wenn alle anstehenden Pokes ausgeführt wurden.

Fehlermeldungen

Name aus Import | Typ | Offset | Erklärung
ErrorTimeDW | UDINT | 2 | Zeit (in Sekunden seit 1.1.1970), wann der letzte Fehler auftrat.
ErrorTimeS | STRING | 2 | Zeit (in Sekunden seit 1.1.1970), wann der letzte Fehler als String auftrat.
RdErrPrimObj | UDINT | 42 | Nummer des PrimObjektes, als der letzte Lesefehler verursacht wurde.
RdErrStationsName | STRING | 43 | Name der Station, als der letzte Lesefehler verursacht wurde.
RdErrBlockCount | UINT | 44 | Anzahl der zu lesenden Blöcke, als der letzte Lesefehler verursacht wurde.
RdErrHwAdresse | DINT | 45 | Hardwareadresse, als der letzte Lesefehler verursacht wurde.
RdErrDatablockNo | UDINT | 46 | Bausteinnummer, als der letzte Lesefehler verursacht wurde.
RdErrMarkerNo | UDINT | 47 | Merkernummer, als der letzte Lesefehler verursacht wurde.
RdErrSize | UDINT | 48 | Blockgröße, als der letzte Lesefehler verursacht wurde.
DrvError | USINT | 25 | Fehlermeldung als Nummer.
DrvErrorMsg | STRING | 30 | Fehlermeldung als Klartext.
ErrorFile | STRING | 15 | Name der Fehlerprotokolldatei.


Treiberspezifische Funktionen

3S_Arti_NG -> Treiberspezifische Funktionen

Dieser Treiber unterstützt folgende Funktionen:

Erweiterte Fehlerdatei

Nein

Serielles Logging

Nein

Blockwrite

Ja

Redundanz

Ja

RDA

Nein

Echtzeitstempelung

Nein

Browsen

Ja

INI Einträge

zenon6.ini

keine

project.ini

keine

WinCE

Ja


Treiberkommandos

3S_Arti_NG -> Treiberkommandos

Dieses Kapitel beschreibt Standardfunktionalitäten, die für die meisten zenon Treiber gültig sind. Nicht alle hier beschriebenen Funktionalitäten stehen für jeden Treiber zur Verfügung. Zum Beispiel enthält ein Treiber, der laut Datenblatt keine Modemverbindung unterstützt, auch keine Modem-Funktionalitäten.

Treiberkommandos dienen dazu, Treiber über zenon zu beeinflussen, z. B. starten und stoppen.
Die Projektierung erfolgt über die Funktion Treiber Kommandos. Dazu:

  • legen Sie eine neue Funktion an
  • wählen Sie Variablen -> Treiberkommandos
  • der Dialog zur Konfiguration wird geöffnet

Parameter

Beschreibung

Treiber

Dropdownliste mit allen im Projekt geladenen Treibern.

Aktueller Zustand

Fixer Eintrag, in aktuellen Versionen ohne Funktion.

Treiberkommando

Dropdownliste zur Auswahl des Kommandos.
  • Treiber starten (Online-Modus)

Treiber wird neu initialisiert und gestartet.
  • Treiber stoppen (Offline-Modus)

Treiber wird angehalten, es werden keine neuen Daten angenommen.

Hinweis: Ist der Treiber im Offline-Modus, erhalten alle Variablen, die für diesem Treiber angelegt wurden, den Status Abgeschaltet (OFF; Bit 20).

  • Treiber in Simulationsmodus

Treiber wird in den Simulationsmodus gesetzt.
Die Werte aller Variablen des Treibers werden vom Treiber simuliert. Es werden keine Werte von der angeschlossenen Hardware (z. B. SPS, Bussystem, ...) angezeigt.
  • Treiber in Hardwaremodus

Treiber wird in den Hardwaremodus gesetzt.
Für die Variablen des Treibers werden die Werte von der angeschlossenen Hardware (z. B. SPS, Bussystem, ...) angezeigt.
  • Treiberspezifisches Kommando

Eingabe treiberspezifischer Kommandos. Öffnet Eingabefeld für die Eingabe eines Kommandos.
  • Treiber Sollwertsetzen aktivieren

Sollwert setzen auf Treiber ist erlaubt.
  • Treiber Sollwertsetzen deaktivieren

Sollwert setzen auf Treiber wird verhindert.
  • Verbindung mit Modem aufbauen

Verbindung aufbauen (für Modem-Treiber). Öffnet Eingabefelder für Hardware-Adresse und Eingabe der zu wählenden Nummer.
  • Verbindung mit Modem trennen

Verbindung beenden (für Modem-Treiber).

Diesen Dialog zur Runtime anbieten

Dialog wird zur Runtime für Änderungen angeboten.

Treiberkommandos im Netzwerk

Wenn sich der Rechner, auf dem die Funktion Treiberkommandos ausgeführt wird, im zenon Netzwerk befindet, werden zusätzliche Aktionen ausgeführt. Ein spezielles Netzwerkkommando wird vom Rechner zum Server des Projekts gesendet, der dann die gewünschte Aktion auf seinem Treiber durchführt. Zusätzlich sendet der Server das gleiche Treiberkommando zum Standby des Projekts. Der Standby führt die Aktion auch auf seinem Treiber aus.

Dadurch ist gewährleistet, dass Server und Standby synchronisiert sind. Dies funktioniert nur, wenn Server und Standby jeweils eine funktionierende und unabhängige Verbindung zur Hardware haben.


Fehleranalyse

3S_Arti_NG -> Fehleranalyse

Sollte es zu Kommunikationsproblemen kommen, bietet dieses Kapitel Hilfe, um den Fehler zu finden.

Noch in diesem Kapitel

Analysetool

Fehlernummern

Checkliste


Analysetool

3S_Arti_NG -> Fehleranalyse -> Analysetool

Alle zenon Module wie z. B. Editor, Runtime, Treiber, usw. schreiben Meldungen in eine gemeinsame LOG-Datei. Um sie korrekt und übersichtlich anzuzeigen, benutzen Sie das Programm Diagnose Viewer, das mit zenon mitinstalliert wird. Sie finden es unter Start/Alle Programme/zenon/Tools 7.50 -> Diagviewer.

zenon Treiber protokollieren alle Fehler in LOG-Dateien. Der Standardordner für die LOG-Dateien ist der Ordner LOG unterhalb des Ordners ProgramData, zum Beispiel:

%ProgramData%\COPA-DATA\LOG. LOG-Dateien sind Textdateien mit einer speziellen Struktur.

Achtung: Mit den Standardeinstellungen zeichnet ein Treiber nur Fehlerinformationen auf. Mit dem Diagnose Viewer kann bei den meisten Treibern die Diagnose-Ebene auf „Debug" und „Deep Debug" erweitert werden. Damit protokolliert der Treiber auch alle anderen wesentlichen Aufgaben und Ereignisse.

Im Diagnose Viewer kann man auch:

  • neu erstellte Einträge in Echtzeit mitverfolgen
  • die Aufzeichnungseinstellungen anpassen
  • den Ordner, in dem die LOG-Dateien gespeichert werden, ändern

Hinweise:

  1. Der Diagnose Viewer zeigt alle Einträge in UTC (Koordinierter Weltzeit) an und nicht in der lokalen Zeit.
  2. Der Diagnose Viewer zeigt in seiner Standardeinstellung nicht alle Spalten einer LOG-Datei an. Um mehr Spalten anzuzeigen, aktivieren Sie die Eigenschaft Add all columns with entry im Kontextmenü der Spaltentitel.
  3. Bei Verwendung von reinem Error-Logging befindet sich eine Problembeschreibung in der Spalte Error text. In anderen Diagnose-Ebenen befindet sich diese Beschreibung in der Spalte General text.
  4. Viele Treiber zeichnen bei Kommunikationsprobleme auch Fehlernummern auf, die die SPS ihnen zuweist. Diese werden in Error text und/oder Error code und/oder Driver error parameter(1 und 2) angezeigt. Hinweise zur Bedeutung der Fehlercodes erhalten Sie in der Treiberdokumentation und der Protokoll/SPS-Beschreibung.
  5. Stellen Sie am Ende Ihrer Tests den Diagnose-Level von Debug oder Deep Debug wieder zurück. Bei Debug und Deep Debug fallen beim Protokollieren sehr viele Daten an, die auf der Festplatte gespeichert werden und die Leistung Ihres Systems beeinflussen können. Diese werden auch nach dem Schließen des Diagnose Viewers weiter aufgezeichnet.

attention Achtung

Unter Windows CE werden aus Ressourcegründen Fehler standardmäßig nicht protokolliert.

Weitere Informationen zum Diagnose Viewer finden Sie im Handbuch Diagnose Viewer.


Fehlernummern

3S_Arti_NG -> Fehleranalyse -> Fehlernummern

Fehlercode | Erklärung
-1 | Common ARTI error.
-101 | The type of protocol is not supported.
-102 | The communication channel is not valid or open.
-103 | A channel with the specified parameters is already open.
-104 | The wrong type of message was received.
-105 | There was not any message received.
-106 | There was not enough data for this message type received.
-201 | There is too much data in the send queue.
-202 | There is too much data in the receive queue.
-203 | Only in the synchronous mode if last service has not finished yet.
-301 | Common communication error in the system –dependent level.
-401 | There wasn't such a file on the target or it could not be opened.
-402 | The file data doesn't fit completely in the provided buffer.
-501 | A strictly necessary function parameter is NULL or invalid.
-502 | The maximum number of open channels is exceeded.
-503 | There is no SDD assigned to the channel.
-504 | There is no type table assigned to the SDD.
-505 | The end of symbol table is reached.
-506 | There is no symbol with that name found in the SDD.
-507 | The data stream for reading the variables is bigger than the target's buffer.
-508 | The data stream for writing the variables in the VarList is bigger than the target's buffer.
-509 | Another VarList is still active with reading / writing its values.
-510 | Writing various VarList blocks is not supported.
-511 | The variable's swap size doesn't fit with the number of bytes to be written
-512 | Error in parsing the symbol file.
-513 | There is a new project on the runtime system so symbols data have changed.
-514 | Error in sorting the symbol file.
-515 | There is no project downloaded to the runtime system.


Checkliste

3S_Arti_NG -> Fehleranalyse -> Checkliste

  • Wurde die „Error – Textdatei" analysiert (Welche Fehler sind aufgetreten)?
  • Ist die Option „Symboldatei senden" aktiv? Siehe dazu die Allgemeinen Zielsystem Einstellungen.
  • Ist die Remotestation im Netz erreichbar (Ping)?
  • Das zenon Projekt wird an support@copadata.com geschickt