Treiber Modemanbindung

Treiber Modemanbindung

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Diese Beschreibung erläutert die Anwendung und Konfiguration der standardmäßig im Treiberkit implementierten Modemanbindung. Die Gesichtspunkte der Programmierung werden hier nicht näher behandelt, hierzu wird auf die Treiberkitdokumentation verwiesen.

Treiberspezifische Einstellungen und Voraussetzungen sind in der für den entsprechenden Treiber erstellten Dokumentation nachzulesen.

Es wird auch vorausgesetzt, dass der Leser mit dem Leitsystem vertraut ist.

Die hier beschriebene Modemanbindung ist nicht unter Windows CE 2.x verfügbar.

Noch in diesem Kapitel

Allgemein

Konfiguration

Laufzeit

Fehlersuche


Allgemein

Treiber Modemanbindung -> Allgemein

Damit die Modemanbindung bei einem Treiber verwendet werden kann, müssen folgende Voraussetzungen erfüllt sein.

Der Treiber muss die Anbindung der Steuerung über Modem unterstützen. Ob der Treiber die Anbindung über Modem unterstützt, ist im Konfigurationsdialog Com

erkennbar. Wenn die Checkbox Modemverbindung sichtbar ist, kann über Modem verbunden werden.

Die Anbindung des Modems erfolgt über die Windowschnittstelle TAPI (Telephony Application Program Interface). Es muss somit ein TAPI-Modem eingerichtet sein.

Auf der Gegenseite muss ebenfalls eine Modembedienung vorhanden sein.


Konfiguration

Treiber Modemanbindung -> Konfiguration

Noch in diesem Kapitel

Modem

Rufeinstellungen

Treiber

Variablen


Modem

Treiber Modemanbindung -> Konfiguration -> Modem

Das Modem wird bei der Systemsteuerung / Modems angelegt. Dies hat vor der Treiberkonfiguration zu erfolgen. Die generelle Konfiguration Ihres Modems entnehmen Sie bitte der Dokumentation zum Modem bzw. Ihres Betriebssystemes.

Hier erfolgt nur eine Beschreibung der Voraussetzungen für die Modemanbindung.


Rufeinstellungen

Treiber Modemanbindung -> Konfiguration -> Rufeinstellungen

Im Konfigurationsdialog Eigenschaften von xxx

ist auf zwei Einstellungen besonders zu achten.

Noch in diesem Kapitel

Wahl abbrechen

Trennen nach Leerlauf

Protokolldatei


Wahl abbrechen

Treiber Modemanbindung -> Konfiguration -> Rufeinstellungen -> Wahl abbrechen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Der Wert muss größer als jener in Zeit f. Aufbau sein.

Die Einstellung muss aktiviert sein.


Trennen nach Leerlauf

Treiber Modemanbindung -> Konfiguration -> Rufeinstellungen -> Trennen nach Leerlauf

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Der Wert muss größer als jener welcher bei der Inaktivität konfiguriert wurde sein.

Die Einstellung muss aktiviert sein.


Protokolldatei

Treiber Modemanbindung -> Konfiguration -> Rufeinstellungen -> Protokolldatei

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Bei den erweiterten Einstellungen

gibt es die Checkbox Protokolldatei aufzeichnen. Wenn diese aktiviert wird, so werden alle Daten welche mit dem Modem ausgetauscht werden in einer Protokolldatei aufgezeichnet. Die Datei liegt im Windows-Verzeichnis (z B.: C:/WINNT) und hat den Names des Modems für welches die Aufzeichnung erfolgt. Zum Beispiel: ModemLog_Sportster 28800-33600 External.txt. Diese Datei ist für die Fehlererkennung nützlich. Aufgrund der schnell zunehmenden Größe, sollte die Protokollierung nur kurzzeitig aktiviert werden.


Treiber

Treiber Modemanbindung -> Konfiguration -> Treiber

Wenn die Checkbox Modemverbindung aktiviert wurde, ändert die Dialogseite ihr Aussehen und zeigt die Felder für die Modemkonfiguration an.

Noch in diesem Kapitel

Modem

Telefonnummer

HW-Adresse

Inaktivität

Zeit zwischen Anrufen

Automatisch verbinden


Modem

Treiber Modemanbindung -> Konfiguration -> Treiber -> Modem

Wählen Sie hier das gewünschte TAPI-Modem aus.


Telefonnummer

Treiber Modemanbindung -> Konfiguration -> Treiber -> Telefonnummer

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Die Telefonnummer, mit welcher eine Verbindung hergestellt werden soll. Wenn keine Nummer angegeben wird, erfolgt kein automatischer Verbindungsaufbau.


HW-Adresse

Treiber Modemanbindung -> Konfiguration -> Treiber -> HW-Adresse

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Die Hardware-Adresse für welche die Telefonnummer gilt. Es werden nur Variablen für die definierte Hardwareadresse abgefragt. Wenn -1 konfiguriert wird, werden alle Adressen abgefragt.


Inaktivität

Treiber Modemanbindung -> Konfiguration -> Treiber -> Inaktivität

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Nach dieser Zeit [s] ohne Antwort der Station wird die Verbindung beendet.

Default: 30s


Zeit zwischen Anrufen

Treiber Modemanbindung -> Konfiguration -> Treiber -> Zeit zwischen Anrufen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Diese Zeit [s] wird zwischen den Anrufen gewartet.

Default: 60s


Automatisch verbinden

Treiber Modemanbindung -> Konfiguration -> Treiber -> Automatisch verbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Wenn aktiviert, dann wird sofort beim Starten der Runtime und vorliegen einer Telefonnummer der Verbindungsaufbau gestartet.


Variablen

Treiber Modemanbindung -> Konfiguration -> Variablen

Im Leitsystem wird die Zuordnung der Variablen zu einer Station über die Netzadresse vorgenommen.

Zu einem Zeitpunkt kann ein Modem nur einmal in Verwendung sein, und immer nur Verbindung zu einer Station haben. Demzufolge werden dann nur die Variablen der verbundenen Station gelesen. Die restlichen Variablen haben den Status gestört (INVALID-Bit aktiv). Nur wenn die Station als Hardwareadresse -1 hat, werden die Variablen mit allen Netzadressen von dieser Station gelesen.


Laufzeit

Treiber Modemanbindung -> Laufzeit

Das Verhalten der Modemanbindung zur Laufzeit, ist abhängig von der aktuell aktiven Konfiguration. Beim Start der Runtime, werden die Einstellungen von der Treiberkonfiguration übernommen, sind jedoch zur Laufzeit änderbar. Die Änderungen, werden mittels der hierfür vorgesehenen Treibervariablen vorgenommen.

Noch in diesem Kapitel

Treibervariablen

Verbindung aufbauen

Verbindung beenden


Treibervariablen

Treiber Modemanbindung -> Laufzeit -> Treibervariablen

Für die Modemanbindung gibt es eine Reihe von Treibervariablen welche sich in 2 Gruppen teilen.

Die Benennung, Type und Offset der Treibervariablen, entspricht jener im Variablenimportfile DRVVAR.DBF.

Es wird hier nur auf die Treibervariablen, welche für die Modemanbindung relevant sind, eingegangen.

Noch in diesem Kapitel

Einstellungen

Statusinformationen


Einstellungen

Treiber Modemanbindung -> Laufzeit -> Treibervariablen -> Einstellungen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In dieser Gruppe, sind die Treibervariablen aufgeführt, welche den aktuellen Konfigurationszustand beinhalten bzw. für die Neukonfiguration vorgesehen sind.

ModemActive

1, wenn das Modem bei diesem Treiber aktiv ist.

Device

Name des Modems. Es kann auch ein anders Modem zur Laufzeit eingestellt werden. Hierbei ist jedoch darauf zu achten ein definiertes TAPI-Modem anzugeben. Eine veränderte Einstellung muss mit ApplyModem aktiviert werden.

ReconnectInRead

Wenn 1, dann wird beim Lesen automatisch ein Neuaufbau der Verbindung durchgeführt. Unter Lesen ist hierbei das Lesen von der Schnittstelle gemeint. Wenn Autoconnect aktiv ist, bleibt diese Einstellung ohne Belang.

PhoneNumber

Aktuelle Telefonnummer. Wenn die aktuelle Telefonnummer leer ist, erfolgt niemals ein abgehender Verbindungsaufbau, egal wie die Einstellungen bei Autoconnect od. ReconnectInRead sind. Bei einem ankommenden, angenommen Anruf wird die Telefonnummer gelöscht.

ModemHwAdr

Hardwareadresse zur aktuellen Telefonnummer. Nur Variablen mit der hier eingestellten Netzadresse werden gelesen. Bei einem angenommenen eingehenden Anruf wird der Wert auf -2 gesetzt bis sich die anrufende Station identifiziert. Nach der Identifizierung wird die Netzadresse der anrufenden Station eingetragen. Ein Wert von -1 gibt an, dass mit allen Netzadressen über diese Verbindung kommuniziert werden soll.

Autoconnect

1, wenn die Modemverbindung automatisch beim Lesen/Schreiben aufgebaut werden soll. Lesen/Schreiben bezieht sich hierbei auf die Schnittstelle.

Wenn die Verbindung unterbrochen wird, so erfolgt bei 1 automatisch eine erneute Anwahl der Station, mit der in Phone-Number abgelegten Nummer. Die Netzadresse geht erst auf gestört, wenn die erneute Anwahl fehlschlägt. So lange Autoconnect 1 ist und eine Nummer in PhoneNumber enthalten ist, wird der Verbindungsaufbau erneut versucht.

RxIdleTime

Wenn länger als diese Zeit in Millisekunden keine Daten erhalten werden, wird die Modemverbindung beendet. Die Systemsteuerung/Modems beinhaltet eine ähnliche Einstellung, welche jedoch nur prüft, ob irgendwelche Daten über das Modem übertragen werden.

WriteTimeout

So lange darf bei einer Modemverbindung maximal das Schreiben dauern.

PhoneNumberSet

Telefonnummer, zu welcher beim nächsten ApplyModem eine Verbindung aufgebaut werden soll. Ist die Telefonnummer leer, wird keine neue Verbindung aufgebaut.

ModemHwAdrSet

Hardwareadresse, welche zu PhoneNumberSet gehört.

ApplyModem

Wenn der Wert 1 geschrieben wird, erfolgt die Zuweisung der aktuellen Inhalte der Treibervariablen Device, PhonenumberSet und ModemHWAdrSet. Eine aktuell bestehende Verbindung wird auf alle Fälle beendet.

RingCountSet

Anzahl der Rufe, welche abgewartet werden, bevor der Anruf angenommen wird. Ob ankommende Anrufe angenommen werden, ist immer vom Treiber abhängig. Nicht alle Treiber unterstützen ankommende Anrufe. Näheres hierzu in der Treiberdokumentation.

ReCallIdleTime

Wartezeit zwischen Anrufen.

ConnectTimeout

Zeit für Verbindungsaufbau. Innerhalb dieser Zeit muss die Verbindung hergestellt werden können, ansonsten wird der Versuch erfolglos abgebrochen.


Statusinformationen

Treiber Modemanbindung -> Laufzeit -> Treibervariablen -> Statusinformationen

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com
LineStateIdle | 1, wenn die Modemleitung frei ist. Dieser Status wird erst aktiv, wenn bereits einmal eine Verbindung bestanden hat.
LineStateOffering | 1, wenn ein Anruf ansteht.
LineStateAccepted | 1, wenn der Anruf angenommen wurde.
LineStateConnected | 1, wenn die Verbindung hergestellt wurde. Wenn bei bestehender Verbindung eine andere Station angewählt wird, dann bleibt der Connectstatus aktiv, obwohl für die Neuanwahl die aktuelle Verbindung beendet wird.
LineStateProceeding | 1, wenn die Wahl ausgeführt wurde.
LineStateDisconnected | 1, wenn die Verbindung beendet ist. Dieser Status steht nur an, wenn noch keine Verbindung aufgebaut wurde.
ModemStatus | Aktueller Modemstatus. Enthält die Zustände LineStatexxxx im gesamten.


Verbindung aufbauen

Treiber Modemanbindung -> Laufzeit -> Verbindung aufbauen

Die Anwahl kann auf mehrere Arten ausgelöst werden:

Noch in diesem Kapitel

Autoconnect bei Runtimestart

Autoconnect bei Verbindungsabriss

Treiberkommando Modem verbinden

ApplyModem


Autoconnect bei Runtimestart

Treiber Modemanbindung -> Laufzeit -> Verbindung aufbauen -> Autoconnect bei Runtimestart

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Wenn die Runtime gestartet wird und Autoconnect konfiguriert wurde, erfolgt sofort ein Verbindungsaufbau zu der gewünschten Station. Wenn dieser erfolgreich war, werden alle Variablen der angewählten Station eingelesen, ohne dass diese einmal auf gestört sind.

Dieser Verbindungsaufbau wird auch ausgeführt, wenn keine Variablen von der Station gelesen werden müssen. Wenn dies nicht gewünscht wird, kann dies mit einem kleinen Trick umgangen werden. Deaktivieren Sie Autoconnect in der Treiberkonfiguration. Telefonnummer und HW-Adresse muss jedoch konfiguriert werden. Im Autostart-Skript setzen Sie die Treibervariable Autoconnect auf 1. Nun erfolgt die automatische Verbindung, wenn Daten benötigt werden. Detto beim Schreiben.


Autoconnect bei Verbindungsabriss

Treiber Modemanbindung -> Laufzeit -> Verbindung aufbauen -> Autoconnect bei Verbindungsabriss

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Für den automatischen Wiederaufbau der Verbindung bei Abriß müssen folgende Punkte erfüllt sein.

Treibervariable PhoneNumber nicht leer

Treibervariable ModemHwAdr ungleich -2

Variablen der Station gelesen od. geschrieben werden sollen

Treibervariable Autoconnect ist 1 oder Treibervariable ReconnectInRead ist 1


Treiberkommando Modem verbinden

Treiber Modemanbindung -> Laufzeit -> Verbindung aufbauen -> Treiberkommando Modem verbinden

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Mit diesem Treiberkommando kann der Verbindungsaufbau zu einer Station manuell ausgelöst werden. Die Telefonnummer und HW-Adresse ist entsprechend der Zielstation anzugeben.

Wenn bereits eine Verbindung zu der Zielrufnummer besteht, wird keine Neuanwahl vorgenommen. Die HW-Adresse wird immer übernommen. Hierdurch kann die HW-Adresse der Zielstation getauscht werden. Die Verbindung wird unabhängig der Notwendigkeit zum Datenaustausch aufgebaut.


ApplyModem

Treiber Modemanbindung -> Laufzeit -> Verbindung aufbauen -> ApplyModem

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Durch setzen der Treibervariable ApplyModem auf 1 werden die aktuell eingestellten Werte in Device, PhoneNumberSet und ModemHwAdrSet übernommen. Die aktuelle Verbindung wird auf alle Fälle beendet. Eine neue Verbindung wird nur aufgebaut wenn die Rufnummer (PhoneNumberSet) nicht leer ist.


Verbindung beenden

Treiber Modemanbindung -> Laufzeit -> Verbindung beenden

Die Verbindung wird aus mehreren Gründen beendet:

  • Beim Verbindungsaufbau konnte die Verbindung nicht innerhalb der konfigurierten Zeit erstellt werden. Siehe auch Konfiguration Zeit für Aufbau, Treibervariable ConnectTimeout.
  • Es wurde keine Antwort der Gegenstation innerhalb der konfigurierten Zeit erhalten. Siehe hierzu auch Konfiguration Inaktivität und Treibervariable RxIdleTime.
  • Es wurden zu lange keine Daten übertragen und TAPI beendet die Verbindung. Siehe hierzu Systemsteuerung/Modems/Rufeinstellung.
  • Das Treiberkommando Modem verbinden wurde mit einer, zur aktuellen Verbindung unterschiedlichen Rufnummer aufgerufen.
  • Das Treiberkommando Modem auflegen wurde aufgerufen. Dies beendet eine aktuelle Verbindung und löscht die Rufnummer der Station. Hierdurch wird auch kein Autoconnect mehr ausgeführt.
  • Die Runtime wird beendet.


Fehlersuche

Treiber Modemanbindung -> Fehlersuche

Bei der Anbindung über Modem gibt es aufgrund der Mehrzahl an beteiligten Baugruppen auch mehr Möglichkeiten Fehler in der Projektierung zu haben.

Noch in diesem Kapitel

PC

SPS


PC

Treiber Modemanbindung -> Fehlersuche -> PC

Auf der PC-Seite werden die Modemeinstellungen durch Installation der entsprechenden TAPI-Treiber definiert. Hierdurch sind die grundlegenden Kommandos für die Modemfunktionen bekannt.

Wenn das Modem zwar abhebt, jedoch nicht wählt, ist es eventuell notwendig die Einstellung auf Freizeichen warten zu deaktivieren. In Nebestelleanlagen wird dies häufig notwendig sein.

Wenn bei ankommenden Anrufen das Modem abhebt, synchronisiert und sofort wieder auflegt, ist wahrscheinlich die Indentifizierung fehlgeschlagen.

Noch in diesem Kapitel

Modem Protokoll

Schnittstellenprotokoll


Modem Protokoll

Treiber Modemanbindung -> Fehlersuche -> PC -> Modem Protokoll

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Um den Fehler eventuell leichter eingrenzen zu können ist es möglich in der Systemsteuerung/Modems/Eigenschaften/Einstellungen/Erweitert die Checkbox Protokoll aufzeichnen zu aktivieren. Bei aktiver Protokollierung wird im Windowsverzeichnis z. B.: C:/WINNT eine Protokolldatei erstellt. Der Name der Datei ist vom Modemnamen abhängig, z. B.: ModemLog_Sportster 28800-33600 External.txt. In dieser Datei werden sämtliche Daten protokolliert, welche mit dem Modem ausgetauscht werden. Aktivieren Sie diese Einstellung nur kurzzeitig, da die Datei sehr schnell einen erheblichen Platzbedarf aufweist.


Schnittstellenprotokoll

Treiber Modemanbindung -> Fehlersuche -> PC -> Schnittstellenprotokoll

Vorheriges Kapitel Nächstes Kapitel Alle anzeigen Alle anzeigen Alle verbergen Alle verbergen
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Alle Treiber mit Modemanbindung haben auch die Möglichkeit im Treiber eine Protokollierung der erhaltenen und gesendeten Daten zu aktivieren. Durch Eintragen der Sektion

[RS232LOG]

LOGCOMx=1

in die Projekt-INI, wird die Schnittstellenprotokollierung aktiviert. Die Daten werden in der Datei LOGFILE.TXT gespeichert, welche im Treiberverzeichnis abgelegt wird.

Aktivieren Sie die Protokollierung nur kurzzeitig, da die Datei sehr schnell einen erheblichen Platz beansprucht.


SPS

Treiber Modemanbindung -> Fehlersuche -> SPS

In der SPS sind im Normalfalle Programme für die Modemanbindung notwendig. Für die Programmierung und Konfiguration dieser Funktionsbaugruppen wird auf die entsprechende Herstellerdokumentation verwiesen.

Die Konfiguration des Modems ist vorzunehmen. Entsprechende Registerdokumentation entnehmen Sie der Modembeschreibung.

Wenn Anrufe von der SPS an die Runtime durchgeführt werden sollen, ist die für den Treiber notwendige Identifizierung zu implementieren. Details hierzu in der Treiberdokumentation.