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1. Welcome to COPA-DATA help 

ZENON VIDEO-TUTORIALS 

You can find practical examples for project configuration with zenon in our YouTube channel 

(https://www.copadata.com/tutorial_menu). The tutorials are grouped according to topics and 

give an initial insight into working with different zenon modules. All tutorials are available in 

English. 

 

GENERAL HELP 

If you cannot find any information you require in this help chapter or can think of anything that you 
would like added, please send an email to documentation@copadata.com 
(mailto:documentation@copadata.com). 

 

PROJECT SUPPORT 

You can receive support for any real project you may have from our Support Team, who you can contact 
via email at support@copadata.com (mailto:support@copadata.com). 

 

LICENSES AND MODULES 

If you find that you need other modules or licenses, our staff will be happy to help you. Email 
sales@copadata.com (mailto:sales@copadata.com). 
 

2. Licensing 

To be able to use zenon as an editor or Runtime, the product must be licensed. zenon runs in Demo 
Mode (on page 6) until it has been licensed. 
 

https://www.copadata.com/tutorial_menu
mailto:documentation@copadata.com
mailto:support@copadata.com
mailto:sales@copadata.com
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3. License zenon 

There are several possibilities for licensing zenon: 

1. To license 

 In Windows, open Start -> All programs -> COPA-DATA -> Licensing, or 

 In the zenon Editor, open File -> General configuration -> License product ... or: 

 In the zenon Editor, open Help -> About-> Change/request license, or 

 In the Startup Tool, click on the Tools button, select Licensing then click on Start. 

2. The dialog for entering license data opens. 

3. Select zenon Editor/Runtime 

4. Enter serial number and activation number 

You find the data for this: 

 on your license certificate 

 On the license sticker 

 Pay attention to capital letters and small letters when entering the data! 

5. After the Editor/Runtime is restarted, use zenon with the license entered 

LICENSING DIALOG 
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Parameter Description 

Editor/Runtime Active: License is valid for the zenon Editor or the zenon Runtime. 

Web Server Active: License valid for zenon Web Server. 

Serial number License serial number.  

If there is already a license available, its serial number is displayed 
here. Enter the current serial number here. 

Activation number License activation number.  

If there is already a license available, its activation number is 
displayed here. 

OK Import data and start zenon with this license when it is next started. 

Cancel Discard entries and use zenon with the previous license or no license. 

Request soft license Opens the dialog to request a soft license. 

 
 

4. Demo mode 

If the editor is not licensed, it runs in demo mode. Runtime runs in demo mode if it is not licensed. 

Demo mode Conditions 

Editor: The Editor runs: 

 the first 40 times it is started for 30 minutes  

 from the 41st to the 50th Start: 20 minutes 

 from the 51st Start at: 10 minutes 

Runtime: A not-licensed Runtime runs for 30 days or 40 starts according to which comes first.  

From the 41st start or the 31st day on, Runtime only runs for 10 minutes. 

The user is informed that it is running in demo mode when it starts.  

 This behavior for unlicensed version is also applicable to the zenon Logic Workbench and 
Runtime. 
 

5. Version and license information 

You can see the version and license that you are currently using and which modules are included in this: 
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 In the Editor: If, in the zenon Editor, you click on Help -> About.... 

 In Runtime: If you execute the Show license information function. 

 The Change/request license button is not present in Runtime. 

 

Parameters/buttons Description 

Version Version number of Editor or Runtime. 

Edition Edition used. 

Serial Number License serial number. 

Activation number License activation number. 

Expiration time (optional) Information on the expiration date of the license for limited 
licenses. 

Licensed modules Information on licensed module. 

Change/request license Opens the dialog for licensing (on page 5). 

Close Closes the dialog. 

 
 

6. Selecting the appropriate license size 

The licenses for the Editor and the Runtime are calculated by adding up the necessary TAGs or IOs. 
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CALCULATION VIA TAGS 

1 TAG equals 1 variable. For determining the license size, consider the total number of TAGs (= 
variables) of the following drivers: 

 PLC drivers and bus drivers 

Variables of the following drivers do not count: 

 Internal driver 

 system driver 

 mathematics driver 

 simulation driver 

You can license TAGs for the Editor and the Runtime in the following gradation: 

 64 TAGs 

 128 TAGs 

 256 TAGs 

 512 TAGs 

 1,024 TAGs 

 2,048 TAGs 

 4,096 TAGs 

 8,192 TAGs 

 16,384 TAGs 

 65536 TAGs 

 unlimited 

A license upgrade to a higher number of TAGs is possible at any time. 

CALCULATION VIA IOS 

License can also be based on I/Os. For determining the license size, consider the total number of IOs of 
the following drivers: 

 PLC drivers and bus drivers 

Variables of the following drivers do not count: 

 Internal driver 

 system driver 

 mathematics driver 

 simulation driver 
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CALCULATION 

Data type Valence 

1 bit   1 I/Os 

1 byte   8 I/Os 

1 WORD 16 I/Os 

1 DWORD 16 I/Os 

1 float 16 I/Os 

1 string (max. 64 characters) 16 I/Os 

If you cannot find the desired data type in the list, it is because of the selected driver. Some drivers have 
a specific denotation of the data types. You will find more information in the driver documentation of 
the driver you use. You will find this either in the online help in the Drivers section, as a PDF file on our 
installation medium or on our website www.copadata.com (http://www.copadata.com) in the 
download section. 

  Example 

96 binary and 20 numerical values are to be visualized in zenon: 

Multiply the 20 numeric values with 16 and you receive 320 I/Os. Add these to the 96 
binary values. As a result you get 416 I/Os, which now are the basis for the license size. 

DISPLAY IN ZENON 

In the status line of the detail view of the variables the following information can be found: 

 

 How many I/Os are used currently. 

 How many I/Os are licensed. 

 An example: 

 3799/550/1: 3799 entries exist, 550 are listed because of a filter, one entry is selected. 

 For project 22730 an unlimited number of I/Os is licensed. 

http://www.copadata.com/
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NOTE FOR CLIENT LICENSE 

You can use client licenses if: 

 The start project is a standalone project or a client  

 The start project uses a maximum of 64 TAGs when a license is required, if it is not a client 

 All subprojects are clients  
 

7. Types of licensing 

You can license zenon in different ways: 

 Soft licensing (on page 11): Requests a unique PC identification number when the editor or 
Runtime is started. 
Characteristics: 

 The license cannot be stolen. 

 The license is computer related. 

 Practical for notebooks. 

 Dongle licensing (on page 12): Looks for a hardware dongle at a parallel port or USB port when 
the editor or Runtime is started.  

Dongles are available as: 

 Workplace dongle: 

 Network dongle: A certain number of licenses are booked on a central dongle on the 
network, which can be used at the same time as concurrent-use licenses.  

Notes for dongles: 

 easy handling 

 A license can be taken from one PC to another by simply moving the dongle. 

 No problems due to hard disk failures 

  Information 

If there is no license or all licenses are are assigned in the network, then the editor or 
Runtime starts in demo mode (on page 6). 
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7.1 Soft licensing 

The soft license assigns a computer with a unique identification. In doing so, certain components of the 
computer are examined. This license always only works on a certain computer. If it is to be transferred 
to another computer or too many components on the licensed computer are changed, it must be 
reissued.  

To obtain a software license: 

1. In the File menu, select: General configuration -> License product. 

2. The licensing dialog (on page 4) opens. 

3. Enter the serial number. 

4. Click on Request soft license. 

5. The product licensing dialog opens.  
If this has not yet happened, enter the serial number. 

6. Click on License request for soft licensing. 

7. Enter your contact details. 

8. click on Next. 

9. There are two possibilities for sending these: 

a) automatic 

 Click on the Send to button  

 Select the desired COPA-DATA organization  

 When clicking on OK, the license request is sent by your email program 

 via button Print you can print your copy or send it to a connected fax machine 

a) manually 

 Click on the Finish button  

 The license request is saved as a text file 

 An information window informs you of the name and save location 

 the file is automatically opened in the Text Editor 

 send the email by email or fax to your sales partner 

As soon as you have received your license data, reopen the licensing dialog and enter your activation 
number. 
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7.2 Dongle licensing 

With dongle licensing, a dongle is connected directly to the computer for an individual workspace 
license or to a network computer for a network license. zenon uses two dongle systems: 

 CodeMeter (on page 12) 
(included with setup) 

 WibuKey (on page 41) 
(software included on installation medium) 

Software necessary for the installation of CodeMeter licensing is also automatically installed during the 
installation of zenon.  

CONFIGURATION 

In general, no further settings need to be made for dongles used locally. The use of network dongles 
may mean that individual configuration is necessary. You can find these in the respective dongle 
software.  

For details of this, see the chapters on the WibuKey (on page 41) and CodeMeter (on page 12).  

WIBUKEY 

The additional WibuKey  administration software is no longer automatically installed with the setup 
from zenon version 7.50. This software is however supplied with zenon. If necessary, install the current 
version of the WibuKey software from your zenon  installation medium: 

 ...\AdditionalSoftware\WIBU-SYSTEMS WibuKey 

 Users who already work with WibuKey continue to receive new licenses for their WibuKey 
dongles.  
 

7.2.1 CodeMeter 

The CodeMeter dongle can be used at a single workplace or in a network.  

The following must be the case in order for CodeMeter to be used: 

 The CodeMeter USB stick must be available in a USB port on the local computer or as a server on 
a network computer. 

 The dongle firmware must be at least version 1.16 or above  

 Descriptions of the CodeMeter WebAdmin relate to version 6.10 thereof. 
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  ATTENTION 

If the dongle is removed during ongoing operation, zenon closes and is opened in demo 
mode until a valid license is detected again.  

CONFIGURATION 

To configure, start the CodeMeter control center application via: Windows Desktop -> Start -> All programs 

-> CodeMeter -> CodeMeter Control Center.   

The CodeMeter control centre opens with 2 tabs: 

 License: Contains information on the dongles found. 

 Events: Displays the number of sticks connected, the license entries, the firm items found and all 
access to the CodeMeter Runtime server. To log the entries on a permanent basis, activate the 
Logging entry in the File menu. 

 In versions before 6.10, there is also the Allocation tab available to configure allocation 
processes for licenses. From CodeMeter version 6.10, it is only still available if the corresponding entries 
are present on the client. 

  Information 

This manual covers the most important applications for zenon users.  
You can find detailed help on the use of CodeMeter in the help integrated into 
CodeMeter. To call these up in the: 

 Control center: In the Help menu, click on the Help entry. 

 WebAdmin: Click on the question mark in the second line of the menu. 

The CodeMeter help is called up context-sensitively. 
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License tab 

Dongles and licenses are displayed and configured in this tab. 
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Option Description 

License Lists all active CodeMeter sticks. 

Name: Individual name of the stick selected; can be amended using the 
button with the pen (to the right of it). 

Serial Number: Serial number of the stick selected. 

Version: Firmware version of the selected stick. 

Capacity: Display of free memory in percentage and bytes. 

Status Selection of the status of the selected CodeMeter stick using 
radio buttons. 

 Deactivated:  
The stick connected is deactivated and cannot be used by 
any application. 

 Activates when connected:  
The stick is activated as long as it is connected. It is 
automatically deactivated after removal from the PC. 

 Activated:  
The stick is fully activated and remains activated after it is 
removed. 
Recommended status: Ensures that unauthorized persons do 
not have access to licenses and personal data (e.g. 
CmPasswordManager) 

Changes must be confirmed using the dongle password. 

License updating Starts the assistant to add, amend and delete licenses. 

Eject Allows the stick to be ejected. 

Change password Enables the password to be changed. 

CodeMeter has been 

started/stopped 
Information on whether the CodeMeter  service is running. Can 
be changed in the Action menu. 

WebAdmin Starts the web browser with the administration user interface for 
network dongles Port 22350 must be open for this. For more 

details, see the Network administration (on page 21) chapter.  

 
 

Update certified time 

You can update the certified time saved in the dongle via the CodeMeter time server. You need access 
to the Internet for this. 

To update the time: 

1. Start the CodeMeter WebAdmin 
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2. Check your network settings (on page 22): 

a) Are the proxy settings correct in CodeMeter Webadmin?  

b) Is your access data up-to-date? 

3. Navigate to the Container menu. 

4. Select the desired stick. 

5. Click on CMContainer info 

 

6. Navigate to the Certified time (CM Container) entry. 

7. Click on the symbol to update:  

8. You are notified that this will update all sticks. 

9. Click on OK.  

10. You receive information on the update carried out.  
Hint: In the event of an error message (on page 34), you primarily check your access data.  
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Request license  

To request or update licenses for CodeMeter, select the Update license button in the Licenses tab in 
the CodeMeter control center (on page 12). The license update assistant starts: 

 

Decide if you are: 

 requesting a license  

 entering a license update 

 want to create a receipt for COPA-DATA  

 

LICENSE REQUEST 

With license requests, you can: 
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 extend an existing COPA-DATA license 

 create a new COPA-DATA license 

 

ENHANCE LICENSE 

To add another COPA-DATA license: 

1. In the Option step, select Enhance existing license. 

2. Click on Next. 

3. Select in COPA-DATA. 

4. Click on Next. 

5. Select the save location. 

6. click on Apply. 

7. Send the file to your COPA-DATA sales partner. 

REQUEST NEW LICENSE 

To request a new COPA-DATA license: 

1. In the Option step, select Enhance existing license. 

2. Click on Next. 

3. enter the Firmcode that you received from COPA-DATA.  

4. Click on Next. 

5. Select the save location. 

6. click on Apply. 
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7. Send the file to your COPA-DATA sales partner. 
 

Adapt license 

You can adapt the scope of your license concerning extent and runtime at any time. To do this: 

1. Order the desired change at COPA-DATA. 

2. You will receive a *.WibuCmRaU file for your dongle. 

3. Install the file 

a) either via double click on the file  

b) or by dragging the file ion the CodeMeter control center 

You will receive a message about successfully updating your license.  
If you receive an error message (on page 34) 229, the license on the dongle is already up to date 

If it is necessary for your license request to create a .WibuCmRaC file or to install the .WibuCmRaU file 
with the update manually, follow the instructions in chapter Update license manually (on page 19).  
 

Request or update license 

To update your license manually: 

1. Create a .WibuCmRaC file  

2. Send this file to COPA-DATA. 

3. You will get an updated .WibuCmRaU file back. 

4. Copy this to the dongle 

CREATE WIBUCMRAC FILE 

1. Make sure that the CodeMeter dongle is connected to your PC. 

2. Open the CodeMeter Control Center. 
Path: Start -> Programs -> CodeMeter -> CodeMeter Control Center 

3. In the License tab, click on the License update button. 

4. The license update assistant starts. 
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5. Click on Next. 

 

6. Select Create license and click Next. 

 

7. Select Enhance existing license. 
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8. Click on Next. 

 

9. Select the manufacturer and click on Next. 

10. Select the desired location for the appropriated .WibuCmRaC file.   

11. Click on Apply.  

12. The .WibuCmRaC file is created.  

13. Send the file to sales@copadata.com or the address you have been given. 

INSTALL WIBUCMRAU FILE 

You will receive, from COPA-DATA, an updated *.WibuCmRaU file.  

Install the file via double click on the file on the dongle. 

Alternative: 

1. Open the CodeMeter control center. 

2. In the dialog for updating licenses, select Lizenzaktualisierung einspielen. 

3. Follow the instructions given to you by the installation wizard.  
 

Network administration using WebAdmin 

For network administration, start the WebAdmin user interface by clicking on the WebAdmin button in 
the CodeMeter control center. Detailed information on the individual settings can be found in the 
CodeMeter WebAdmin help pages. You can get to this using the question mark (?) symbol in WebAdmin. 
The most important options and instructions are also in this document: 

 CodeMeter stick administration (on page 27)  

 License administration (on page 28)  
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 Saving license data (on page 28) 

 Network settings (on page 22) 

 Proxy settings (on page 22) 

  Attention 

CodeMeter WebAdmin uses port 22350 by default.  
Note: 

 If a firewall other than that integrated into the Windows operating system is 
used, this port must be enabled.  

 If the port is changed, the WebAdmin surface cannot be started, because the 
port is part of the address,. 
 For example: http://localhost:22350/configuration/extra.html  
In this case, use appropriate freeware tools or standard Windows tools to 
determine which port is currently being used and enter this address into the 
address line of the browsers instead of 22350.  
Then amend the port in WebAdmin via Settings-> Advanced-> Extras . 

 
 

Network  

For faultless communication with a Network dongle and the start of the WebAdmin, correct network 
settings are a requirement. 
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SERVER SEARCH LIST 

 

Option Description 

Server search list Display of the available CodeMeter servers. The entries can be 
removed and sorted. The order defined here decides the order 
of connection attempts made by clients. 

Only the servers defined in the list are searched for. This way, 
requests from clients are directed to a defined CodeMeter 
Network server. 

 If a CodeMeter Server is in a different subnetwork, 
use the IP address for the search list.  

This search list should only be used if the CM Stick cannot 
be found in the network. 

Add new server Opens the dialog for selecting a server.  
You define the CodeMeter network server here using its 
computer name or IP address. 

Apply Applies the changes. 

Restore default Restores the default settings. 
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PROXY 

For access to CodeMeter services in the Internet, such as time server, enter the applicable access data 
for your company here.  

 

  Attention 

CodeMeter notes this credentials. If you regularly change your access password, you 
must also change this in the CodeMeter WebAdmin proxy settings! 

ACTIVATE AS SERVER 

To activate a stick as a server in the network: 
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1. Click on Settings -> Server -> Server access. 

 

2. In the Network server area, click on Activate. 

If you need another port for communication, then change it using Settings -> Advanced -> Extras. 

The computer becomes a CodeMeter network server and makes all its licenses available in the 
network. 
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AMEND PORT 

You can amend several communication parameters via Settings -> Advanced -> Extras.  
CodeMeter WebAdmin communicates using port 22350 by default. You can amend it here if necessary. 

 

Option Description 

Network port Port for CodeMeter communication in the network.  

Default: 22350  

The value can be adjusted individually. In this case, it must be ensured that all 
CodeMeter Runtime servers use the same port.  
The CodeMeter service must be restarted once a change has been made. 

 do not change port. 

Network waiting time Time that is waited for a response from the server. 

Default: 100 seconds 

UDP response time Maximum response time within which a UDP request must be answered.  

Default: 1000 milliseconds. 
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CodeMeter sticks 

The WebAdmin starts in the Container/All containers view. 

Here, you select the desired dongle and the desired information and actions: 

 Licenses: Display of the available licenses.  

 CmContainer Infos: Information on the dongle. 

 User data: Data on users, number of licenses and validity. 

 Backing up and restoring: Backing up the data from a stick to a file and restoring it. 

CMCONTAINER INFOS 

You show details of the selected dongle with the CmContainer Infos button.  
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Option Description 

CmStick Display of the detected sticks and their status. 

All other information relates to the selected stick. 

Name  Shows the name given in the control center (on page 12). 

Serial Number Serial number of the stick. 

CmContainer type Hardware version of the stick. 

Drive Drive information for the stick, drive sizes are only given for sticks 
with flash memory. 

Status Activation status as defined in the control center (on page 12). 

System time (PC) Local time on the CodeMeter Runtime server. 

System time (CMContainer) Internal time saved on the stick.  

Certified time The certified time saved on the stick. Is amended with the update 
symbol (to the right). 

 to update (on page 15) using the CodeMeter timeserver, 
you require an active internet connection. Ensure that the 
network settings (on page 22) are correct, in particular in relation 
to current access data. 

Free memory Free memory available on the stick. To defragment the memory, 
click on the Defragment symbol (to the right). 

 
 

Administering licenses 

You administer your licenses in the Licenses tab in the Container menu. 

1. Select the desired dongle.  

2. You can find information on the licenses of these dongles below the <COPA-DATA> subheading.  

3. For further details, click on the figure in the Product Code column.  
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OVERVIEW 
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Option Description 

Product Code Numerical value for the product. Clicking on the number 
leads to the details. 

Name Dongle name 

Usage units If applicable, display of usage units remaining. 

Expiration date If applicable, the expiration date is shown. Afterwards, 
zenon switches to demo mode (on page 6).  

Number of licenses Total number of licenses 

Feature Map Licenses that are supplied with different 
functionality or modules. 

DETAILS 

 

Option Description 

Dongle Number Serial number of the dongle. Must correspond with the number of the active 
dongle. 

TIME LIMITS 

A dongle can also have a time limit through:  

 Expiration date  

 Time period for use 
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EXPIRATION DATE 

The dongle can be equipped with a fixed expiration date. The expiration date denotes the last day on 
which the license is valid. zenon switches to demo mode afterwards. The expiration date is shown in 
CodeMeter WebAdmin.  
To find out the expiration date:  

1. Navigate to the dongle. 

2. The end date is shown in the Date of expiration column in the Licenses view. 
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3. The end date is also shown on the Value column in the detail view. 

 

TIME PERIOD FOR USE 

The dongle can be equipped with a specified usage period. This starts from the first time that zenon 
Editor or Runtime is used. Once the time period has expired, zenon switches to demo mode. To check 
the time limit: 

1. Navigate to the dongle. 

2. Show the licenses. 

3. Click, in the entry under COPA-DATA, on the figure in the Product Code column. 

The Product Item Details window opens. 
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In the Usage period line, you can see the licensed time period and the start date in the Value 
column. 
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Troubleshooting 

Error Solution 

zenon only runs in demo mode. Check  

 your licenses 

 The connection to the network dongle 

 if the license information (SERIAL7= and 
ACTIVATIONKEY7=) was correctly entered in 
zenon6.ini.  
Take care for possible blanks behind the serial number 
(SERIAL7=) or the activation key (ACTIVATIONKEY7=). 
Directory for zenon6.ini:Vista: 
%ProgramData%\COPA-DATA\System 

Dongle is not found.  Check the network settings (on page 22).  

 If the stick is in another domain, add it to the server list (on 
page 22). 

 Increase the UDP response time (on page 22).  

 If it is a virtual machine, then configure the stick as 
removable media (on page 35).  

 Configuration as removable media can - 
depending on the computer configuration - also lead to a 
computer no longer booting. 

 Configure the stick as HID (on page 36).  

Error 410  
(with SD cards) 

The connection to the SD card is unstable. 

Use an external card reader. 

Certified time cannot be updated. Please check: 

 Proxy settings (on page 22), especially access data and 
Password  

 List of time server under Settings -> time server 
 for example: cmtime.codemeter.com, 
cmtime.codemeter.de, cmtime.codemeter.fr, 
cmtime.codemeter.us 

Error message at updating the license:  

Error at updating the CmSticks 

x-xxxxxxx:  
This update can no longer be read in. 

The content of the CmStick has a 

newer version, error229. 

The update for this license has already been written to the 
dongle. The dongle is up-to-date. 
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Windows operating system shows the 
message: 

Low Memory 

The dongle is identified as local memory. In some cases, this can 
lead to the operating system giving the message "Insufficient 
memory". 

This message can be ignored. 

Alternatively, the dongle can also be configured as removable 
media. For details on configuration, see the Configure dongle 

as removable media or HID (on page 35) section.  

 Configuration as removable media can - depending 
on the computer configuration - also lead to a computer no 
longer booting. 

Windows operating system no longer shows 
symbol for the Recycle Bin. 

This may happen if the dongle is identified as a fixed local 
network.  

Alternatively, the dongle can also be configured as removable 
media. For details on configuration, see the Configure dongle 

as removable media or HID (on page 35) section.  

 Configuration as removable media can - depending 
on the computer configuration - also lead to a computer no 
longer booting. 

 
 

Configuration possibilities for the CodeMeter dongle 

The dongle is integrated into the system as an HID (Human Interface Device) device by default. This 
configuration is recommended. The dongle can also be configured as a local mass-storage device or 
removable media.  
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CONFIGURATIONS 

Configured as: Description Limitations 

HID The dongle:  

 Is not displayed in the list of 
available drives  

 Is not allocated a drive 
letter. 

Only available for CodeMeter dongles 
without memory. 

Local mass-storage 

device 
The dongle is displayed and 
managed as a local drive. 

For configuration, see the 
Configure dongle as an HID or 
mass-storage device (on page 
36) section. 

Can lead to:  

 The operating system reporting too 
little memory for the dongle  

 the icon for the Windows Recycle 
Bin no longer being displayed  

 the dongle not being found in virtual 
machines 

Removable media The dongle is displayed and 
managed as removable media.  

For details about configuration 
see the Configure dongle as 

removable media chapter. 

With configuration as removable 
media: 

 The booting of the computer can be 
prevented for with computers that 
can boot from a USB drive  

 The dongle appears as a drive in the 
task bar and can be removed 
(ejected) at any time 

 
 

Configure dongle as an HID or mass-storage device 

CodeMeter supports, from version 5.0, the Human Interface Device (HID) class of USB standards. 
CodeMeter dongles can therefore log onto the system as a HID instead of a Mass Storage Device. The 
dongle is thus not shown in the list of available drives and is not allocated a drive letter. HID support is 
available for all CodeMeter dongles without memory. Special USB host drivers do not need to be 
installed for configuration, because the functionality is provided by the operating system.  

Requirements: 

 CodeMeter container with the identification "2-xxxxxxx" or 3-xxxxxxx". 

 CodeMeter firmware 2.02 or higher. 

 CodeMeter Runtime 5.0 or higher. Should the version of  CodeMeter that you have installed be 
older, you can download the current CodeMeter Runtime from Wibu Systems (www.wibu.com 
(http://www.wibu.com/support-downloads.html)). 

http://www.wibu.com/support-downloads.html
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HID TO MASS STORAGE DEVICE 

To switch USB communication from Human Interface Device (HID) to Mass Storage Device:  

1. Check, in CodeMeter WebAdmin, the status in the Container -> CmContainer Info tab. 

2. No drive is assigned. 

 

3. Call up the CodeMeter command line interface cmu: Start -> Program Files -> CodeMeter -> Tools -> 

CodeMeter Command Prompt. 

4. Enter the following commands in the command input line that appears: 
cmu32 /s [box mask-serial number] --set-config-disk MsdCommunication 

 For [box mask - serial number], enter the serial number of the stick. 

Once the command has been successfully executed, the following is displayed: 
Communication mode changed successfully. 
Please replug your CmDongle to apply the changes. 

5. Remove the dongle from the computer.  

6. Reconnect the dongle to the computer. 
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7. In the CodeMeter Control Center, the switch to MSD is shown in the Events tab. 

 

8. In CodeMeter WebAdmin, check the drive in the Container -> CmContainer Info tab.  
A drive is entered but there is no flash memory. 
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MASS STORAGE DEVICE TO HID 

To switch the USB communication from Mass Storage Device to Human Interface Device (HID):  

1. Check, in CodeMeter WebAdmin, the status in the Container -> CmContainer Info tab.  

2. A drive is assigned but there is no flash memory.  

 

3. Call up the CodeMeter command line interface cmu: Start -> Program Files -> CodeMeter -> Tools -> 

CodeMeter Command Prompt. 

Enter the following commands in the command input line that appears: 
cmu32 /s [box mask-serial number] --set-config-disk HidCommunication 

 For [box mask - serial number], enter the serial number of the stick. 

Once the command has been successfully executed, the following is displayed: 
Communication mode changed successfully. 
Please replug your CmDongle to apply the changes. 

4. Remove the dongle from the computer.  

5. Reconnect the dongle to the computer. 
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6. In the CodeMeter Control Center, the switch to HID is shown in the Events tab. 

 

7. Check the drive in CodeMeter WebAdmin, in the Content/CmContainer tab. Nothing should be 
entered. 
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7.2.2 WibuKey 

WibuKey can be used at a single workplace or in a network. The dongle must be active in a USB port or 
parallel port on the local computer or as a server on a network computer.  

To check the settings of the stick: 

1. Install the WibuKey administration software from the installation medium. 
Save location: 
\AdditionalSoftware\WIBU-SYSTEMS WibuKey 
Use this software for licensing with the network dongle. 

2. Open the Control Panel. 

3. Open the WibuKey system control element.  

4. Select the stick to be tested on the local computer or on the network. 

To list server Wibu boxes in the network, click on the Read in button. 

5. Check if the number in the last column of the second row is identical with the starting number of 
the stick. 

 

You can read more about the operation of the stick in the network dongle (on page 41) chapter.  
 

Network dongle 

To use a WibuKey in the network as a dongle, the server and client must be configured accordingly: 

 Server configuration (on page 42) 

 Client configuration (on page 43)  
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  Attention 

WibuKey uses port 22347. This port is fixed and cannot be changed. Note: 

 If a firewall other than that integrated into the Windows operating system is 
used, this port must be enabled if you wish to use the WibuKey as a network 
dongle.  

 
 

Configuring the server 

The WibuKey server has to run on the dongle server. The WibuKey server can be configured either as an 
application (e.g. started via Autostart) or as a service. 

On installing the WibuKey software the options 

32 Bit WkNet/WkLAN network server 

Install as NT service with Autostart 

have to be activated, so that the WibuKey server is installed as a service (recommended). 

 

In order to start the WibuKey server as an application, a link to the file WkSvW32.exe has to be 
created in the Windows Autostart. 

The file can be found in the C:/Programme/WIBUKEY/Server/ folder after installation. 
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Configuring a client 

Some network settings for the client have to be entered in the Control Panel. Under WibuKey 
subsystems, you can select the type of network access you use. The licensing of zenon uses the WkLan 
subsystem. 

Under Server Name/IP address either the server name or its IP address or a mask for the IP address is 
entered. With Browse the list is filled with all found dongle servers. 

 

The entries are processed in the sequence of the list and also can be combined. 

If the first entry is a certain server, it is checked, if the dongle server service runs on that PC and if a 
dongle is plugged in (faster!). If no dongle is found here and the next entry is a filter mask, all PCs in the 
network going with that filter mask are are tried out. 

On the Contents page, the server(s) where the dongles were found should then be listed: 
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8. Command line parameter for licensing tool 

The licensing tool can be controlled with the following flags as parameters: 

Passing over a parameter is done by putting a `/` or a `-` before the parameter:  

for example: /silent or -silent 

Parameters Description 

request forces the program to omit the first dialog and go straight to the dialog for 
requesting the activation key 
(it does not matter if the flag /silent or -silent is also used) 

sernum:<num> forces the program to use the serial number which is passed with <num>  for 
licensing instead of reading the number from the zenon6.ini file. 

actkey:<key> forces the program to use the activation key which is passed with <key>  for 

licensing instead of reading the key from the zenOn6.ini file. 

silent forces the program to not show a dialog. The file License.txt is still created. 

mailto:<addr> works only in connection with the flag silent  and forces the program to send 

the license request to the specified address <addr>  via e-mail. 

 
 

9. Remote licensing 

To allocate a license to a computer via remote connection: 

1. in the context menu of the project select Remote Transport -> Change password and display licensing  

2. start the Remote Transport 

3. as soon as the connection is established, the licensing of the remote computer is displayed 

 

4. enter the serial number and the activation number of your license form 

5. confirm the input by clicking OK 
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10. Characteristics of the Server Client operation 

Licensing of modules in the server client operation has the following characteristics: 

HISTORIAN 

The following cases are distinguished: 

 Server and client licensed: Archives can be opened and edited at the client 

 Server licensed and client not licensed: Archives can be opened but not edited at the client 

 Client not licensed and started as standalone: Archive window can be opened; the individual 
archives cannot be opened 

AUTOMATIC LINE COLORING 

The following cases are distinguished: 

 Server licensed and client not licensed: ALC functionality is available unrestrictedly 

 Client not licensed and started as standalone: ALC functionality is not available 

  Information 

If the Server is licensed for the Energy Edition, ALC is also licensed. 

BATCH CONTROL 

The client gets the license from the server and does not need its own license. If the server does not have 
a license of its own, the client cannot use the module. 

LOAD MANAGEMENT 

The following cases are distinguished: 

 Server licensed and client not licensed: Load ManagementEMS functionality is available without 
restriction 

 Client not licensed and started as standalone: Load ManagementEMS functionality is not 
available 
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MESSAGE CONTROL 

The client gets the license from the server and does not need its own license. If the server does not have 
a license of its own, the client cannot use the module. 

11. Everywhere Server by zenon 

Everywhere Server gets the license of the Runtime. The license for Everywhere Server is issued by 
Runtime. The Everywhere Server can not be used, If the Runtime does not have a corresponding 
license.  

For this reason, it may happen that the Runtime is running, but the Everywhere Server can not be 
started because of missing license rights. In this case, please use the licensing tool (on page 4) in order 
to receive a corresponding license. 
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